 All Classes
AbortableHSSFListener
AbsExpression
AbstractEscherHolderRecord
AbstractEscherOptRecord
AbstractExcelConverter
AbstractExcelUtils
AbstractFunctionPtg
AbstractShape
AbstractWordConverter
AbstractWordUtils
ActiveXShape
AddDivideExpression
AddPtg
Address
AddSubtractExpression
AdjustValue
AggregateFunction
AggregatingUDFFinder
AgileDecryptor
AlignmentTextProp
AnalysisToolPak
AnimationInfo
AnimationInfoAtom
ArcTanExpression
ArcToCommand
Area2DPtgBase
Area3DPtg
AreaErrPtg
AreaEval
AreaEvalBase
AreaFormatRecord
AreaI
AreaI.OffsetArea
AreaNPtg
AreaPtg
AreaPtgBase
AreaRecord
AreaReference
AreaReference
ArrayPtg
ArrayRecord
ArrayUtil
Attachment
AttachmentChunks
AttachmentChunks.AttachmentChunksSorter
AttrPtg
AttrPtg.SpaceType
AutoFilter
AutoFilterInfoRecord
AutoShape
AutoShape
AutoShapes
AxisCrossBetween
AxisCrosses
AxisLineFormatRecord
AxisOptionsRecord
AxisOrientation
AxisParentRecord
AxisPosition
AxisRecord
AxisUsedRecord
Background
Background
BackupRecord
BarRecord
BATBlock
BATBlock.BATBlockAndIndex
BATManaged
BeginRecord
Beta
Biff8DecryptingStream
Biff8EncryptionKey
BiffHeaderInput
BiffViewer
BinaryTree
BitField
BitFieldFactory
Bitmap
BitmapPainter
BitMaskTextProp
BKFAbstractType
BlankEval
BlankRecord
BlockAllocationTableReader
BlockAllocationTableWriter
BlockingInputStream
BlockList
BlockStore
BlockWritable
BodyElementType
BodyType
BOFRecord
BookBoolRecord
Bookmark
BookmarkFirstDescriptor
Bookmarks
BookmarksImpl
BookmarksTables
BooleanFunction
BoolErrRecord
BoolEval
BoolPtg
BorderCode
BorderFormatting
BorderFormatting
Borders
BorderStyle
BottomMarginRecord
BoundSheetRecord
BreakClear
BreakType
BuiltinFormats
ByteArrayBackedDataSource
ByteChunk
ByteField
BytePropertyNode
CachedPropertyNode
CalcCountRecord
CalcModeRecord
CalculationChain
CalendarFieldFunction
CategorySeriesAxisRecord
CatLabRecord
Cell
CellDateFormatter
CellElapsedFormatter
CellFormat
CellFormatCondition
CellFormatPart
CellFormatResult
CellFormatter
CellFormatType
CellGeneralFormatter
CellHandler
CellNumberFormatter
CellRange
CellRangeAddress
CellRangeAddress
CellRangeAddress8Bit
CellRangeAddressBase
CellRangeAddressList
CellRangeAddressList
CellRangeUtil
CellRecord
CellReference
CellReference
CellReference.NameType
CellStyle
CellTextFormatter
CellUtil
CellValue
CellValueRecordInterface
CellWalk
CellWalkContext
CertificateEmbeddingOption
CFHeaderRecord
CFRecordsAggregate
CFRuleRecord
CFRuleRecord.ComparisonOperator
CharacterProperties
CharacterPropertyFetcher
CharacterRun
CharacterSprmCompressor
CharacterSprmUncompressor
CharFlagsTextProp
CharIndexTranslator
Chart
ChartAxis
ChartAxisFactory
ChartData
ChartDataFactory
ChartDataSource
ChartEndBlockRecord
ChartEndObjectRecord
ChartFormatRecord
ChartFRTInfoRecord
ChartLegend
ChartRecord
ChartStartBlockRecord
ChartStartObjectRecord
ChartSubstreamRecordAggregate
ChartTitleFormatRecord
Child
Choose
CHPAbstractType
CHPBinTable
CHPFormattedDiskPage
CHPX
Chunk
Chunk
Chunk.BlockOffsetCommand
Chunk.Command
ChunkFactory
ChunkGroup
ChunkHeader
ChunkHeaderV11
ChunkHeaderV4V5
ChunkHeaderV6
ChunkNotFoundException
Chunks
ChunkSeparator
ChunkStream
ChunkTrailer
ClassID
ClientAnchor
CloseIgnoringInputStream
ClosePathCommand
CodepageRecord
CollaboratingWorkbooksEnvironment
CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
Color
Colorref
ColorSchemeAtom
Column
ColumnHelper
ColumnInfoRecord
ColumnInfoRecordsAggregate
Columns
ComboboxShape
CommandLineTextExtractor
Comment
Comment
Comment2000
Comment2000Atom
CommentShape
CommentsTable
CommonObjectDataSubRecord
CommonsLogger
ComparisonOperator
ComplexFileTable
CompressedRTF
CompressedStreamStore
CompressionOption
ConcatEval
ConcatPtg
ConditionalFormatting
ConditionalFormattingRule
ConditionalFormattingTable
Configuration
Constants
ConstantValueParser
ContentType
ContentTypeManager
ContentTypes
Context
ContinuableRecord
ContinuableRecordInput
ContinuableRecordOutput
ContinueRecord
ControlPtg
ConvertAnchor
CorruptPowerPointFileException
CosExpression
CosineArcTanExpression
Count
Counta
Countblank
Countif
CountryRecord
CreationHelper
CRNCountRecord
CRNRecord
CString
CTColComparator
CurrentUserAtom
CurveToCommand
CustomGeometry
CustomProperties
CustomProperty
CustomViewSettingsRecordAggregate
DataFormat
DataFormatRecord
DataFormatter
DataInputBlock
DataItemRecord
DataLabelExtensionRecord
DataSource
DataSources
DataValidation
DataValidation.ErrorStyle
DataValidationConstraint
DataValidationConstraint.OperatorType
DataValidationConstraint.ValidationType
DataValidationHelper
DataValidityTable
DateAndTime
DateFormatConverter
DateFormatConverter.DateFormatTokenizer
DateFunc
DateParser
DateUtil
DateWindow1904Record
DatRecord
Days360
DBCellRecord
DBCellRecord.Builder
DConRefRecord
Decryptor
DefaultColWidthRecord
DefaultDataLabelTextPropertiesRecord
DefaultEscherRecordFactory
DefaultFontReplacer
DefaultMarshaller
DefaultRowHeightRecord
DefaultUDFFinder
DelayableLittleEndianOutput
DeletedArea3DPtg
DeletedRef3DPtg
DeltaRecord
DIB
DigitalCertificatePart
DigitalSignatureOriginPart
DimensionsRecord
DirectoryChunk
DirectoryChunkNotFoundException
DirectoryEntry
DirectoryNode
DirectoryProperty
DirectoryProperty.PropertyComparator
DividePtg
Document
Document
DocumentAtom
DocumentAtom.SlideSize
DocumentBlock
DocumentDescriptor
DocumentEncryptionAtom
DocumentEntry
DocumentInputStream
DocumentNode
DocumentOutputStream
DocumentPosition
DocumentProperties
DocumentProperty
DocumentSummaryInformation
DOPAbstractType
Drawing
DrawingDump
DrawingGroupRecord
DrawingManager
DrawingManager2
DrawingParagraph
DrawingRecord
DrawingRecordForBiffViewer
DrawingSelectionRecord
DrawingTable
DrawingTableCell
DrawingTableRow
DrawingTextBody
DrawingTextPlaceholder
DropCapSpecifier
DSFRecord
DummyGraphics2d
DummyPositionSensitiveRecordWithChildren
DummyRecordWithChildren
DVALRecord
DVConstraint
DVConstraint.FormulaPair
DVRecord
EcmaDecryptor
EFBiffViewer
EmbeddedObjectRefSubRecord
EMF
EncryptedDocumentException
EncryptedPowerPointFileException
EncryptedSlideShow
EncryptionHeader
EncryptionInfo
EncryptionOption
EncryptionVerifier
EndRecord
EndSubRecord
Entry
EntryNode
EntryUtils
Environment
EOFRecord
EqualPtg
ERFListener
ErrorConstant
ErrorConstants
ErrorEval
Errortype
ErrPtg
EscherAggregate
EscherArrayProperty
EscherBitmapBlip
EscherBlipRecord
EscherBlipWMFRecord
EscherBoolProperty
EscherBSERecord
EscherChildAnchorRecord
EscherClientAnchorRecord
EscherClientDataRecord
EscherComplexProperty
EscherContainerRecord
EscherDelayStm
EscherDggRecord
EscherDggRecord.FileIdCluster
EscherDgRecord
EscherDump
EscherGraphics
EscherGraphics2d
EscherMetafileBlip
EscherOptRecord
EscherPart
EscherPictBlip
EscherProperties
EscherProperty
EscherPropertyFactory
EscherPropertyMetaData
EscherRecord
EscherRecordFactory
EscherRecordHolder
EscherRGBProperty
EscherSerializationListener
EscherShapePathProperty
EscherSimpleProperty
EscherSpgrRecord
EscherSplitMenuColorsRecord
EscherSpRecord
EscherStm
EscherTertiaryOptRecord
EscherTextboxRecord
EscherTextboxWrapper
EvaluationCell
EvaluationException
EvaluationName
EvaluationSheet
EvaluationWorkbook
EvaluationWorkbook.ExternalName
EvaluationWorkbook.ExternalSheet
Even
EventBasedExcelExtractor
EventRecordFactory
EventWorkbookBuilder
EventWorkbookBuilder.SheetRecordCollectingListener
EvilUnclosedBRFixingInputStream
ExAviMovie
ExcelExtractor
ExcelExtractor
ExcelStyleDateFormatter
ExcelToFoConverter
ExcelToFoUtils
ExcelToHtmlConverter
ExcelToHtmlUtils
ExControl
ExControlAtom
ExEmbed
ExEmbedAtom
ExHyperlink
ExHyperlinkAtom
ExMCIMovie
ExMediaAtom
ExObjList
ExObjListAtom
ExOleObjAtom
ExOleObjStg
ExpPtg
Expression
ExpressionParser
ExtendedFormatRecord
ExtendedPivotTableViewFieldsRecord
ExternalNameRecord
ExternSheetRecord
ExternSheetReferenceToken
ExtractorFactory
ExtSSTRecord
ExtSSTRecord.InfoSubRecord
ExVideoContainer
FeatFormulaErr2
FeatHdrRecord
FeatProtection
FeatRecord
FeatSmartTag
Ffn
FibBase
FibBaseAbstractType
FIBFieldHandler
FibRgLw95AbstractType
FibRgLw97AbstractType
FibRgW97AbstractType
Field
FieldDescriptor
FieldIterator
Fields
FieldsDocumentPart
FieldsImpl
FieldsTables
FileBackedDataSource
FileHelper
FileInformationBlock
FilePassRecord
FileSharingRecord
Fill
Fill
Fill
FillPatternType
FilteringDirectoryNode
FinanceFunction
FinanceLib
Fixed0ArgFunction
Fixed1ArgFunction
Fixed2ArgFunction
Fixed3ArgFunction
Fixed4ArgFunction
FixedField
FLDAbstractType
FnGroupCountRecord
FoDocumentFacade
Font
FontBasisRecord
FontCharset
FontCollection
FontCollection
FontDetails
FontEntityAtom
FontFamily
FontFormatting
FontFormatting
FontIndexRecord
FontMetricsDumper
FontRecord
FontReplacer
FontReplacer.Triplet
FontScheme
FontTable
FontUnderline
Footer
FooterRecord
FootnoteReferenceDescriptor
ForkedEvaluator
FormatRecord
FormattedDiskPage
FormatTrackingHSSFListener
Formula
Formula
FormulaError
FormulaEvaluator
FormulaParseException
FormulaParser
FormulaParsingWorkbook
FormulaRecord
FormulaRecordAggregate
FormulaRenderer
FormulaRenderingWorkbook
FormulaShifter
FormulaType
FormulaViewer
FrameRecord
FRDAbstractType
Freeform
FreeRefFunction
FSPA
FSPAAbstractType
FSPADocumentPart
FSPATable
FtCblsSubRecord
FtrHeader
FuncPtg
Function
Function0Arg
Function1Arg
Function2Arg
Function3Arg
Function4Arg
FunctionEval
FunctionMetadata
FunctionMetadataRegistry
FuncVarPtg
GenericPropertyNode
GreaterEqualPtg
GreaterThanPtg
Grfhic
GrfhicAbstractType
GridsetRecord
GroupMarkerSubRecord
Guide
GutsRecord
GZIPSheetDataWriter
HCenterRecord
HDFType
HDGFDiagram
HDGFException
HDGFLZW
Header
HeaderBlock
HeaderBlockConstants
HeaderBlockWriter
HeaderFooter
HeaderFooter
HeaderFooterBase
HeaderFooterHelper
HeaderFooterRecord
HeaderRecord
HeadersFooters
HeadersFootersAtom
HeadersFootersContainer
HeaderStories
HexDump
HexRead
HideObjRecord
Hlookup
HMEFContentsExtractor
HMEFDumper
HMEFMessage
HorizontalAlignment
HorizontalPageBreakRecord
HPBFDocument
HPBFDumper
HPBFPart
HPSFException
HPSFPropertiesExtractor
HPSFRuntimeException
HRESIAbstractType
HSLFException
HSLFSlideShow
HSMFDump
HSSFAnchor
HSSFAutoFilter
HSSFBorderFormatting
HSSFCell
HSSFCellStyle
HSSFCellUtil
HSSFChart
HSSFChart.HSSFChartType
HSSFChildAnchor
HSSFClientAnchor
HSSFColor
HSSFColor.AQUA
HSSFColor.AUTOMATIC
HSSFColor.BLACK
HSSFColor.BLUE
HSSFColor.BLUE_GREY
HSSFColor.BRIGHT_GREEN
HSSFColor.BROWN
HSSFColor.CORAL
HSSFColor.CORNFLOWER_BLUE
HSSFColor.DARK_BLUE
HSSFColor.DARK_GREEN
HSSFColor.DARK_RED
HSSFColor.DARK_TEAL
HSSFColor.DARK_YELLOW
HSSFColor.GOLD
HSSFColor.GREEN
HSSFColor.GREY_25_PERCENT
HSSFColor.GREY_40_PERCENT
HSSFColor.GREY_50_PERCENT
HSSFColor.GREY_80_PERCENT
HSSFColor.INDIGO
HSSFColor.LAVENDER
HSSFColor.LEMON_CHIFFON
HSSFColor.LIGHT_BLUE
HSSFColor.LIGHT_CORNFLOWER_BLUE
HSSFColor.LIGHT_GREEN
HSSFColor.LIGHT_ORANGE
HSSFColor.LIGHT_TURQUOISE
HSSFColor.LIGHT_YELLOW
HSSFColor.LIME
HSSFColor.MAROON
HSSFColor.OLIVE_GREEN
HSSFColor.ORANGE
HSSFColor.ORCHID
HSSFColor.PALE_BLUE
HSSFColor.PINK
HSSFColor.PLUM
HSSFColor.RED
HSSFColor.ROSE
HSSFColor.ROYAL_BLUE
HSSFColor.SEA_GREEN
HSSFColor.SKY_BLUE
HSSFColor.TAN
HSSFColor.TEAL
HSSFColor.TURQUOISE
HSSFColor.VIOLET
HSSFColor.WHITE
HSSFColor.YELLOW
HSSFComment
HSSFConditionalFormatting
HSSFConditionalFormattingRule
HSSFCreationHelper
HSSFDataFormat
HSSFDataFormatter
HSSFDataValidation
HSSFDataValidationHelper
HSSFDateUtil
HSSFErrorConstants
HSSFEvaluationWorkbook
HSSFEventFactory
HSSFFont
HSSFFontFormatting
HSSFFooter
HSSFFormulaEvaluator
HSSFFormulaParser
HSSFHeader
HSSFHyperlink
HSSFListener
HSSFName
HSSFObjectData
HSSFOptimiser
HSSFPalette
HSSFPatriarch
HSSFPatternFormatting
HSSFPicture
HSSFPictureData
HSSFPolygon
HSSFPrintSetup
HSSFRegionUtil
HSSFRequest
HSSFRichTextString
HSSFRow
HSSFShape
HSSFShapeContainer
HSSFShapeGroup
HSSFSheet
HSSFSheetConditionalFormatting
HSSFSimpleShape
HSSFTextbox
HSSFUserException
HSSFWorkbook
HtmlDocumentFacade
HWPFDocument
HWPFDocumentCore
HWPFFileSystem
HWPFList
HWPFLister
HWPFOldDocument
HWPFOutputStream
Hyperlink
Hyperlink
Hyperlink
Hyperlink
Hyperlink
HyperlinkRecord
Hyphenation
IAdjustableShape
IBody
IBodyElement
IdentifierManager
IfElseExpression
IfFunc
IllegalPropertySetDataException
IllegalVariantTypeException
ImageExtractor
ImagePainter
ImageUtils
Index
IndexedColors
IndexedUDFFinder
IndexRecord
Indirect
IntegerField
InteractiveInfo
InteractiveInfoAtom
InterfaceEndRecord
InterfaceHdrRecord
Internal
InternalSheet
InternalWorkbook
IntersectionEval
IntersectionPtg
IntList
IntMapper
IntPtg
InvalidFormatException
InvalidOperationException
InvalidRecordFormatException
IOUtils
Irr
IStabilityClassifier
IterationRecord
JPEG
LabelRecord
LabelSSTRecord
LastCellOfRowDummyRecord
LayoutMode
LayoutTarget
LazilyConcatenatedByteArray
LbsDataSubRecord
LbsDataSubRecord.LbsDropData
LeftMarginRecord
LegendPosition
LegendRecord
LessEqualPtg
LessThanPtg
LFOAbstractType
LFOLVLBaseAbstractType
Line
Line
LineCap
LineDash
LineDecoration
LineEndLength
LineEndWidth
LineFormatRecord
LineShape
LineSpacingDescriptor
LineSpacingRule
LineStyle
LineStyle
LineToCommand
LinkedDataRecord
ListAutoNumber
ListData
ListEntry
ListFormatOverride
ListFormatOverrideLevel
ListLevel
ListManagedBlock
ListTables
LiteralValueExpression
LittleEndian
LittleEndian.BufferUnderrunException
LittleEndianByteArrayInputStream
LittleEndianByteArrayOutputStream
LittleEndianConsts
LittleEndianInput
LittleEndianInputStream
LittleEndianOutput
LittleEndianOutputStream
LogicalFunction
LongField
Lookup
LSTFAbstractType
LVLFAbstractType
LZWDecompresser
MainContents
MainMaster
ManualLayout
ManuallyPositionable
MAPIAttribute
MAPIDateAttribute
MAPIMessage
MapInfo
MAPIProperty
MAPIRtfAttribute
MAPIStringAttribute
Margin
MarkUnsupportedException
MasterSheet
MasterSheet
Match
MaxExpression
MemAreaPtg
MemErrPtg
MemFuncPtg
MemoryPackagePart
MemoryPackagePartOutputStream
MergeCellsRecord
MergedCellsTable
MessageSubmissionChunk
Metafile
Metafile.Header
MinaMaxa
MinExpression
MissingArgEval
MissingArgPtg
MissingCellDummyRecord
MissingRecordAwareHSSFListener
MissingRowDummyRecord
MissingSectionException
MMSRecord
Mode
ModExpression
MoveToCommand
MovieShape
MulBlankRecord
MulRKRecord
MultiOperandNumericFunction
MultiplyDivideExpression
MultiplyPtg
MutableByteArrayOutputStream
MutableProperty
MutablePropertySet
MutableSection
Na
Name
NameCommentRecord
NameEval
NameIdChunks
NamePtg
NameRecord
NameXEval
NameXPtg
NDocumentInputStream
NoFormatIDException
NoPropertySetStreamException
NoSingleSectionException
NotEqualPtg
NoteRecord
Notes
Notes
Notes
Notes
NotesAtom
NotesImpl
NotesTables
NoteStructureSubRecord
NoteType
NotImplementedException
NotImplementedFunction
Now
NPOIFSDocument
NPOIFSFileSystem
NPOIFSMiniStore
NPOIFSStream
NPropertyTable
Npv
Nullable
NullEscherSerializationListener
NullLogger
NumberComparer
NumberEval
NumberFormatIndexRecord
NumberFormatter
NumberPtg
NumberRecord
NumberToTextConverter
NumericFunction
NumericFunction.OneArg
NumericFunction.TwoArg
NumericRanges
NumericValueEval
ObjectData
ObjectLinkRecord
ObjectPoolImpl
ObjectProtectRecord
ObjectsPool
ObjRecord
Odd
ODocumentInputStream
OEPlaceholderAtom
OEShapeAtom
OfficeDrawing
OfficeDrawing.HorizontalPositioning
OfficeDrawing.HorizontalRelativeElement
OfficeDrawing.VerticalPositioning
OfficeDrawing.VerticalRelativeElement
OfficeDrawings
OfficeDrawingsImpl
OfficeXmlFileException
Offset
OldCHPBinTable
OldExcelFormatException
OldFileFormatException
OldPAPBinTable
OldPowerPointFormatException
OldSectionTable
OldWordFileFormatException
Ole10Native
Ole10NativeException
OLEShape
OOXMLLister
OOXMLLite
OPCPackage
OpenXML4JException
OpenXML4JRuntimeException
OperandPtg
OperandResolver
OperationEvaluationContext
OperationPtg
Outline
OutlineTextRefAtom
OutlookTextExtactor
Package
PackageAccess
PackageDigitalSignature
PackageDigitalSignatureManager
PackageHelper
PackageNamespaces
PackagePart
PackagePartCollection
PackagePartName
PackageProperties
PackagePropertiesMarshaller
PackagePropertiesPart
PackagePropertiesUnmarshaller
PackageRelationship
PackageRelationshipCollection
PackageRelationshipTypes
PackagingURIHelper
PageBreakRecord
PageBreakRecord.Break
PageItemRecord
PageOrder
PageSettingsBlock
PaletteRecord
PaneInformation
PaneRecord
PAPAbstractType
PAPBinTable
PaperSize
PAPFormattedDiskPage
PAPX
Paragraph
ParagraphAlignment
ParagraphFlagsTextProp
ParagraphHeight
ParagraphProperties
ParagraphPropertyFetcher
ParagraphSprmCompressor
ParagraphSprmUncompressor
Parent
ParentAwareRecord
ParenthesisPtg
PartAlreadyExistsException
PartMarshaller
PartUnmarshaller
PasswordRecord
PasswordRev4Record
Path
PathCommand
PatternFormatting
PatternFormatting
PercentEval
PercentPtg
PersistPtrHolder
PersistRecord
PICF
PICFAbstractType
PICFAndOfficeArtData
PICT
Picture
Picture
Picture
Picture
PictureData
PictureData
PictureData
PictureShape
PicturesManager
PicturesTable
PictureType
PieceDescriptor
PinExpression
Placeholder
Placeholder
PLCDumper
PlexOfCps
PlexOfField
PlotAreaRecord
PlotGrowthRecord
PNG
POIDocument
POIFSBigBlockSize
POIFSChunkParser
POIFSConstants
POIFSDocument
POIFSDocumentPath
POIFSDump
POIFSFileSystem
POIFSHeaderDumper
POIFSLister
POIFSReader
POIFSReaderEvent
POIFSReaderListener
POIFSViewable
POIFSViewEngine
POIFSViewer
POIFSWriterEvent
POIFSWriterListener
POILogFactory
POILogger
Pointer
PointerContainingStream
PointerFactory
PointerV6
POIOLE2TextExtractor
POITextExtractor
POIXMLDocument
POIXMLDocumentPart
POIXMLException
POIXMLFactory
POIXMLProperties
POIXMLPropertiesTextExtractor
POIXMLRelation
POIXMLTextExtractor
Polygon
PolygonShape
PositionDependentRecord
PositionDependentRecordAtom
PositionDependentRecordContainer
PositionInParagraph
PowerPointExtractor
PowerPtg
PPDrawing
PPDrawingGroup
PPDrawingTextListing
PPFont
PPGraphics2D
PPTX2PNG
PPTXMLDump
PrecisionRecord
PresetGeometries
PrintCellComments
PrintGridlinesRecord
PrintHeadersRecord
PrintOrientation
PrintSetup
PrintSetupRecord
Property
Property
PropertyBlock
PropertyConstants
PropertyFetcher
PropertyIDMap
PropertyModifier
PropertyNode
PropertyNode.EndComparator
PropertyNode.StartComparator
PropertySet
PropertySetFactory
PropertyTable
PropertyTableBase
ProtectionRev4Record
ProtectRecord
Ptg
PublisherTextExtractor
QCBit
QCPLCBit
QCPLCBit.Type0
QCPLCBit.Type12
QCPLCBit.Type4
QCPLCBit.Type8
QCTextBit
QuadToCommand
QuickButCruddyTextExtractor
QuickTest
QuillContents
Range
RangeEval
RangePtg
Rank
Rate
RawDataBlock
RawDataBlockList
ReadingNotSupportedException
ReadOnlySharedStringsTable
RecalcIdRecord
RecipientChunks
RecipientChunks.RecipientChunksSorter
Record
Record
RecordAggregate
RecordAggregate.PositionTrackingVisitor
RecordAggregate.RecordVisitor
RecordAtom
RecordBase
RecordContainer
RecordFactory
RecordFactoryInputStream
RecordFormatException
RecordFormatException
RecordGenerator
RecordInputStream
RecordInputStream.LeftoverDataException
RecordLister
RecordStream
RecordTypes
RecordTypes.Type
RecordUtil
Ref3DPtg
RefErrorPtg
RefEval
RefEvalBase
RefModeRecord
RefNPtg
RefPtg
RefPtgBase
RefreshAllRecord
Region
Region
RegionUtil
RelationalOperationEval
RelationshipSource
Replace
Resources
RevisionMarkAuthorTable
RichTextRun
RichTextString
RightMarginRecord
RKRecord
RKUtil
RootProperty
RoundTripHFPlaceholder12
Row
Row.MissingCellPolicy
RowBlocksReader
RowFunc
RowRecord
RowRecordsAggregate
Rows
SavedByEntry
SavedByTable
SaveRecalcRecord
ScalarConstantPtg
ScatterChartData
ScatterChartSerie
ScenarioProtectRecord
SCLRecord
Section
Section
SectionDescriptor
SectionIDMap
SectionProperties
SectionSprmCompressor
SectionSprmUncompressor
SectionTable
SelectionRecord
SEPAbstractType
SEPX
SeriesChartGroupIndexRecord
SeriesIndexRecord
SeriesLabelsRecord
SeriesListRecord
SeriesRecord
SeriesTextRecord
SeriesToChartGroupRecord
ShadingDescriptor
ShadingDescriptor80
Shape
Shape
Shape
ShapeContainer
ShapeFactory
ShapeGroup
ShapeGroup
ShapeOutline
ShapePainter
ShapesTable
ShapeTypes
ShapeTypes
ShapeTypes
SharedFeature
SharedFormula
SharedFormulaRecord
SharedStringsTable
SharedValueManager
SharedValueRecordBase
SHD80AbstractType
SHDAbstractType
Sheet
Sheet
Sheet
SheetBuilder
SheetConditionalFormatting
SheetContainer
SheetDataWriter
SheetNameFormatter
SheetPropertiesRecord
SheetReferences
SheetUtil
ShortField
ShortList
SimpleFilledShape
SimpleShape
SimpleShape
SinArcTanExpression
SinExpression
SinglentonTextPiece
SingleXmlCells
Slide
Slide
Slide
SlideAndNotesAtomListing
SlideAtom
SlideIdListing
SlideLayout
SlideListWithText
SlideMaster
SlidePersistAtom
SlideShow
SlideShow
SlideShowDumper
SlideShowRecordDumper
SLWTListing
SLWTTextListing
SmallBlockTableReader
SmallBlockTableWriter
SmallDocumentBlock
SmallDocumentBlockList
Sound
SoundCollection
SoundData
SoundData
SpecialPropertySet
SpreadsheetVersion
SprmBuffer
SprmIterator
SprmOperation
SprmUncompressor
SprmUtils
SqrtExpression
SSCellRange
SSTRecord
StandardRecord
StdfBaseAbstractType
StdfPost2000AbstractType
Stream
StreamHelper
StreamIDRecord
StreamStore
StringChunk
StringEval
StringPtg
StringRecord
StringsStream
StringUtil
StringUtil.StringsIterator
StringValueEval
StshifAbstractType
StyleDescription
StyleRecord
StyleSheet
StylesTable
StyleTextPropAtom
SubdocumentType
SubRecord
Substitute
Subtotal
SubtractPtg
Sumif
Sumifs
SummaryInformation
Sumproduct
Sumx2my2
Sumx2py2
Sumxmy2
SupBookRecord
SXSSFCell
SXSSFRow
SXSSFSheet
SXSSFWorkbook
SystemOutLogger
SystemTimeUtils
T
TabDescriptor
TabIdRecord
Table
Table
TableAutoformatLookSpecifier
TableCell
TableCell
TableCellDescriptor
TableIterator
TableProperties
TableRecord
TableRow
TableSprmCompressor
TableSprmUncompressor
TableStylesRecord
TanExpression
TAPAbstractType
TargetMode
TBDAbstractType
TblPtg
TCAbstractType
TempFile
TextAlign
TextAlignment
TextAutofit
TextBodyPropertyFetcher
TextBox
TextBox
Textbox
TextboxShape
TextBytesAtom
TextCap
TextCharsAtom
TextDirection
TextDocumentFacade
TextFunction
TextHeaderAtom
TextObjectRecord
TextPainter
TextPainter.TextElement
TextPiece
TextPieceTable
TextProp
TextPropCollection
TextRecord
TextRulerAtom
TextRun
TextRun
TextSegement
TextShape
TextSpecInfoAtom
TextSpecInfoAtom.TextSpecInfoRun
TextStyleListing
ThemesTable
Thumbnail
TickRecord
TimeFunc
TitleMaster
TLPAbstractType
TNEFAttribute
TNEFDateAttribute
TNEFMAPIAttribute
TNEFProperty
TNEFStringAttribute
TOC
Today
TopMarginRecord
TrailerStream
TwoDEval
TwoOperandNumericOperation
TxInteractiveInfoAtom
TxMasterStyleAtom
Types
TypesLister
TypeWriter
UDFFinder
UnaryMinusEval
UnaryMinusPtg
UnaryPlusEval
UnaryPlusPtg
UncalcedRecord
UnderlinePatterns
UnexpectedPropertySetTypeException
UnhandledDataStructure
UnicodeString
UnicodeString
UnicodeString.ExtRst
UnicodeString.FormatRun
UnicodeString.PhRun
UnionPtg
Units
UnitsRecord
UnknownEscherRecord
UnknownPtg
UnknownQCBit
UnknownRecord
UnknownRecordPlaceholder
UnknownStream
UnmarshallContext
UnsupportedVariantTypeException
UPX
UserEditAndPersistListing
UserEditAtom
UserSViewBegin
UserSViewEnd
UseSelFSRecord
Util
Value
ValueAxis
ValueEval
ValueOperatorPtg
ValueRangeRecord
ValueRecordsAggregate
Variant
VariantSupport
VariantTypeException
VCenterRecord
VerticalAlign
VerticalAlignment
VerticalAlignment
VerticalPageBreakRecord
ViewDefinitionRecord
ViewFieldsRecord
ViewSourceRecord
VisioTextExtractor
Vlookup
VSDDumper
WindowOneRecord
WindowProtectRecord
WindowTwoRecord
WMF
Word6Extractor
WordExtractor
WordToFoConverter
WordToFoUtils
WordToHtmlConverter
WordToHtmlUtils
WordToTextConverter
Workbook
WorkbookDependentFormula
WorkbookEvaluator
WorkbookFactory
WorkbookRecordList
WorkbookUtil
WorkdayCalculator
WorksheetProtectionBlock
WriteAccessRecord
WriteProtectRecord
WritingNotSupportedException
WSBoolRecord
XMLParagraph
XMLSlideShow
XSLFAutoShape
XSLFBackground
XSLFColor
XSLFCommentAuthors
XSLFComments
XSLFCommonSlideData
XSLFConnectorShape
XSLFDrawing
XSLFFactory
XSLFFontManager
XSLFFreeformShape
XSLFGraphicFrame
XSLFGroupShape
XSLFHyperlink
XSLFImageRenderer
XSLFNotes
XSLFNotesMaster
XSLFPictureData
XSLFPictureShape
XSLFPowerPointExtractor
XSLFRelation
XSLFRenderingHint
XSLFShadow
XSLFShape
XSLFShapeContainer
XSLFShapeType
XSLFSheet
XSLFSimpleShape
XSLFSlide
XSLFSlideLayout
XSLFSlideMaster
XSLFSlideShow
XSLFTable
XSLFTableCell
XSLFTableRow
XSLFTableStyle
XSLFTableStyles
XSLFTextBox
XSLFTextParagraph
XSLFTextRun
XSLFTextShape
XSLFTheme
XSSFAnchor
XSSFAutoFilter
XSSFBorderFormatting
XSSFCell
XSSFCellAlignment
XSSFCellBorder
XSSFCellBorder.BorderSide
XSSFCellFill
XSSFCellStyle
XSSFChart
XSSFChartAxis
XSSFChartDataFactory
XSSFChartLegend
XSSFChartSheet
XSSFChildAnchor
XSSFClientAnchor
XSSFColor
XSSFComment
XSSFConditionalFormatting
XSSFConditionalFormattingRule
XSSFConnector
XSSFCreationHelper
XSSFDataFormat
XSSFDataValidation
XSSFDataValidationConstraint
XSSFDataValidationHelper
XSSFDialogsheet
XSSFDrawing
XSSFDump
XSSFEvaluationWorkbook
XSSFEvenFooter
XSSFEvenHeader
XSSFEventBasedExcelExtractor
XSSFExcelExtractor
XSSFExportToXml
XSSFFactory
XSSFFirstFooter
XSSFFirstHeader
XSSFFont
XSSFFontFormatting
XSSFFormulaEvaluator
XSSFFormulaUtils
XSSFGraphicFrame
XSSFHeaderFooter
XSSFHyperlink
XSSFImportFromXML
XSSFManualLayout
XSSFMap
XSSFName
XSSFOddFooter
XSSFOddHeader
XSSFPatternFormatting
XSSFPicture
XSSFPictureData
XSSFPrintSetup
XSSFReader
XSSFReader.SheetIterator
XSSFRelation
XSSFRichTextString
XSSFRow
XSSFRowShifter
XSSFSave
XSSFScatterChartData
XSSFShape
XSSFShapeGroup
XSSFSheet
XSSFSheetConditionalFormatting
XSSFSheetXMLHandler
XSSFSheetXMLHandler.SheetContentsHandler
XSSFSimpleShape
XSSFSingleXmlCell
XSSFTable
XSSFTextBox
XSSFValueAxis
XSSFVMLDrawing
XSSFWorkbook
XSSFXmlColumnPr
XWPFAbstractNum
XWPFComment
XWPFCommentsDecorator
XWPFDocument
XWPFFactory
XWPFFooter
XWPFFootnote
XWPFFootnotes
XWPFHeader
XWPFHeaderFooter
XWPFHeaderFooterPolicy
XWPFHyperlink
XWPFHyperlinkDecorator
XWPFHyperlinkRun
XWPFLatentStyles
XWPFNum
XWPFNumbering
XWPFParagraph
XWPFParagraphDecorator
XWPFPicture
XWPFPictureData
XWPFRelation
XWPFRun
XWPFSettings
XWPFStyle
XWPFStyles
XWPFTable
XWPFTable.XWPFBorderType
XWPFTableCell
XWPFTableCell.XWPFVertAlign
XWPFTableRow
XWPFWordExtractor
XYNumericFunction
XYNumericFunction.Accumulator
ZipContentTypeManager
ZipEntrySource
ZipFileZipEntrySource
ZipHelper
ZipInputStreamZipEntrySource
ZipInputStreamZipEntrySource.FakeZipEntry
ZipPackage
ZipPackagePart
ZipPackagePropertiesMarshaller
ZipPartMarshaller


Constant Field Values

Contents
  • org.apache.*
org.apache.*

org.apache.poi.POIXMLDocument
public static final java.lang.String | DOCUMENT_CREATOR | "Apache POI"
public static final java.lang.String | OLE_OBJECT_REL_TYPE | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/oleObject"
public static final java.lang.String | PACK_OBJECT_REL_TYPE | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/package"

org.apache.poi.POIXMLProperties.CustomProperties
public static final java.lang.String FORMAT_ID "{D5CDD505-2E9C-101B-9397-08002B2CF9AE}"

org.apache.poi.common.usermodel.Hyperlink
public static final int | LINK_DOCUMENT | 2
public static final int | LINK_EMAIL | 3
public static final int | LINK_FILE | 4
public static final int | LINK_URL | 1

org.apache.poi.ddf.EscherBitmapBlip
public static final short | RECORD_ID_DIB | -4065
public static final short | RECORD_ID_JPEG | -4067
public static final short | RECORD_ID_PNG | -4066

org.apache.poi.ddf.EscherBlipRecord
public static final java.lang.String | RECORD_DESCRIPTION | "msofbtBlip"
public static final short | RECORD_ID_END | -3817
public static final short | RECORD_ID_START | -4072

org.apache.poi.ddf.EscherBlipWMFRecord
public static final java.lang.String RECORD_DESCRIPTION "msofbtBlip"

org.apache.poi.ddf.EscherBSERecord
public static final byte | BT_DIB | 7
public static final byte | BT_EMF | 2
public static final byte | BT_ERROR | 0
public static final byte | BT_JPEG | 5
public static final byte | BT_PICT | 4
public static final byte | BT_PNG | 6
public static final byte | BT_UNKNOWN | 1
public static final byte | BT_WMF | 3
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtBSE"
public static final short | RECORD_ID | -4089

org.apache.poi.ddf.EscherChildAnchorRecord
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtChildAnchor"
public static final short | RECORD_ID | -4081

org.apache.poi.ddf.EscherClientAnchorRecord
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtClientAnchor"
public static final short | RECORD_ID | -4080

org.apache.poi.ddf.EscherClientDataRecord
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtClientData"
public static final short | RECORD_ID | -4079

org.apache.poi.ddf.EscherContainerRecord
public static final short | BSTORE_CONTAINER | -4095
public static final short | DG_CONTAINER | -4094
public static final short | DGG_CONTAINER | -4096
public static final short | SOLVER_CONTAINER | -4091
public static final short | SP_CONTAINER | -4092
public static final short | SPGR_CONTAINER | -4093

org.apache.poi.ddf.EscherDggRecord
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtDgg"
public static final short | RECORD_ID | -4090

org.apache.poi.ddf.EscherDgRecord
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtDg"
public static final short | RECORD_ID | -4088

org.apache.poi.ddf.EscherMetafileBlip
public static final short | RECORD_ID_EMF | -4070
public static final short | RECORD_ID_PICT | -4068
public static final short | RECORD_ID_WMF | -4069
public static final short | SIGNATURE_EMF | 15680
public static final short | SIGNATURE_PICT | 21536
public static final short | SIGNATURE_WMF | 8544

org.apache.poi.ddf.EscherOptRecord
public static final java.lang.String | RECORD_DESCRIPTION | "msofbtOPT"
public static final short | RECORD_ID | -4085

org.apache.poi.ddf.EscherPictBlip
public static final short | RECORD_ID_EMF | -4070
public static final short | RECORD_ID_PICT | -4068
public static final short | RECORD_ID_WMF | -4069

org.apache.poi.ddf.EscherProperties
public static final short | BLIP__BLIPFILENAME | 261
public static final short | BLIP__BLIPFLAGS | 262
public static final short | BLIP__BLIPTODISPLAY | 260
public static final short | BLIP__BRIGHTNESSSETTING | 265
public static final short | BLIP__CONTRASTSETTING | 264
public static final short | BLIP__CROPFROMBOTTOM | 257
public static final short | BLIP__CROPFROMLEFT | 258
public static final short | BLIP__CROPFROMRIGHT | 259
public static final short | BLIP__CROPFROMTOP | 256
public static final short | BLIP__DOUBLEMOD | 268
public static final short | BLIP__GAMMA | 266
public static final short | BLIP__NOHITTESTPICTURE | 316
public static final short | BLIP__PICTUREACTIVE | 319
public static final short | BLIP__PICTUREBILEVEL | 318
public static final short | BLIP__PICTUREFILLMOD | 269
public static final short | BLIP__PICTUREGRAY | 317
public static final short | BLIP__PICTUREID | 267
public static final short | BLIP__PICTURELINE | 270
public static final short | BLIP__PRINTBLIP | 271
public static final short | BLIP__PRINTBLIPFILENAME | 272
public static final short | BLIP__PRINTFLAGS | 273
public static final short | BLIP__TRANSPARENTCOLOR | 263
public static final short | CALLOUT__CALLOUTACCENTBAR | 890
public static final short | CALLOUT__CALLOUTANGLE | 834
public static final short | CALLOUT__CALLOUTDROPSPECIFIED | 836
public static final short | CALLOUT__CALLOUTDROPTYPE | 835
public static final short | CALLOUT__CALLOUTLENGTHSPECIFIED | 837
public static final short | CALLOUT__CALLOUTMINUSX | 892
public static final short | CALLOUT__CALLOUTMINUSY | 893
public static final short | CALLOUT__CALLOUTTEXTBORDER | 891
public static final short | CALLOUT__CALLOUTTYPE | 832
public static final short | CALLOUT__DROPAUTO | 894
public static final short | CALLOUT__ISCALLOUT | 889
public static final short | CALLOUT__LENGTHSPECIFIED | 895
public static final short | CALLOUT__XYCALLOUTGAP | 833
public static final short | FILL__ANGLE | 395
public static final short | FILL__BACKOPACITY | 388
public static final short | FILL__BLIPFILENAME | 391
public static final short | FILL__BLIPFLAGS | 392
public static final short | FILL__CRMOD | 389
public static final short | FILL__DZTYPE | 405
public static final short | FILL__FILLBACKCOLOR | 387
public static final short | FILL__FILLCOLOR | 385
public static final short | FILL__FILLED | 443
public static final short | FILL__FILLOPACITY | 386
public static final short | FILL__FILLTYPE | 384
public static final short | FILL__FOCUS | 396
public static final short | FILL__HEIGHT | 394
public static final short | FILL__HITTESTFILL | 444
public static final short | FILL__NOFILLHITTEST | 447
public static final short | FILL__ORIGINX | 408
public static final short | FILL__ORIGINY | 409
public static final short | FILL__PATTERNTEXTURE | 390
public static final short | FILL__RECTBOTTOM | 404
public static final short | FILL__RECTLEFT | 401
public static final short | FILL__RECTRIGHT | 403
public static final short | FILL__RECTTOP | 402
public static final short | FILL__SHADECOLORS | 407
public static final short | FILL__SHADEPRESET | 406
public static final short | FILL__SHADETYPE | 412
public static final short | FILL__SHAPE | 445
public static final short | FILL__SHAPEORIGINX | 410
public static final short | FILL__SHAPEORIGINY | 411
public static final short | FILL__TOBOTTOM | 400
public static final short | FILL__TOLEFT | 397
public static final short | FILL__TORIGHT | 399
public static final short | FILL__TOTOP | 398
public static final short | FILL__USERECT | 446
public static final short | FILL__WIDTH | 393
public static final short | GEOMETRY__3DOK | 379
public static final short | GEOMETRY__ADJUST10VALUE | 336
public static final short | GEOMETRY__ADJUST2VALUE | 328
public static final short | GEOMETRY__ADJUST3VALUE | 329
public static final short | GEOMETRY__ADJUST4VALUE | 330
public static final short | GEOMETRY__ADJUST5VALUE | 331
public static final short | GEOMETRY__ADJUST6VALUE | 332
public static final short | GEOMETRY__ADJUST7VALUE | 333
public static final short | GEOMETRY__ADJUST8VALUE | 334
public static final short | GEOMETRY__ADJUST9VALUE | 335
public static final short | GEOMETRY__ADJUSTVALUE | 327
public static final short | GEOMETRY__BOTTOM | 323
public static final short | GEOMETRY__FILLOK | 383
public static final short | GEOMETRY__FILLSHADESHAPEOK | 382
public static final short | GEOMETRY__GEOTEXTOK | 381
public static final short | GEOMETRY__LEFT | 320
public static final short | GEOMETRY__LINEOK | 380
public static final short | GEOMETRY__RIGHT | 322
public static final short | GEOMETRY__SEGMENTINFO | 326
public static final short | GEOMETRY__SHADOWok | 378
public static final short | GEOMETRY__SHAPEPATH | 324
public static final short | GEOMETRY__TOP | 321
public static final short | GEOMETRY__VERTICES | 325
public static final short | GEOTEXT__ALIGNMENTONCURVE | 194
public static final short | GEOTEXT__BOLDFONT | 250
public static final short | GEOTEXT__CHARBOUNDINGBOX | 246
public static final short | GEOTEXT__DEFAULTPOINTSIZE | 195
public static final short | GEOTEXT__FONTFAMILYNAME | 197
public static final short | GEOTEXT__HASTEXTEFFECT | 241
public static final short | GEOTEXT__ITALICFONT | 251
public static final short | GEOTEXT__KERNCHARACTERS | 243
public static final short | GEOTEXT__NOMEASUREALONGPATH | 249
public static final short | GEOTEXT__REVERSEROWORDER | 240
public static final short | GEOTEXT__ROTATECHARACTERS | 242
public static final short | GEOTEXT__RTFTEXT | 193
public static final short | GEOTEXT__SCALETEXTONPATH | 247
public static final short | GEOTEXT__SHADOWFONT | 253
public static final short | GEOTEXT__SMALLCAPSFONT | 254
public static final short | GEOTEXT__STRETCHCHARHEIGHT | 248
public static final short | GEOTEXT__STRETCHTOFITSHAPE | 245
public static final short | GEOTEXT__STRIKETHROUGHFONT | 255
public static final short | GEOTEXT__TEXTSPACING | 196
public static final short | GEOTEXT__TIGHTORTRACK | 244
public static final short | GEOTEXT__UNDERLINEFONT | 252
public static final short | GEOTEXT__UNICODE | 192
public static final short | GROUPSHAPE__1DADJUSTMENT | 957
public static final short | GROUPSHAPE__BEHINDDOCUMENT | 954
public static final short | GROUPSHAPE__BORDERBOTTOMCOLOR | 925
public static final short | GROUPSHAPE__BORDERLEFTCOLOR | 924
public static final short | GROUPSHAPE__BORDERRIGHTCOLOR | 926
public static final short | GROUPSHAPE__BORDERTOPCOLOR | 923
public static final short | GROUPSHAPE__DESCRIPTION | 897
public static final short | GROUPSHAPE__EDITEDWRAP | 953
public static final short | GROUPSHAPE__FLAGS | 959
public static final short | GROUPSHAPE__HIDDEN | 958
public static final short | GROUPSHAPE__HR_ALIGN | 916
public static final short | GROUPSHAPE__HR_HEIGHT | 917
public static final short | GROUPSHAPE__HR_PCT | 915
public static final short | GROUPSHAPE__HR_WIDTH | 918
public static final short | GROUPSHAPE__HYPERLINK | 898
public static final short | GROUPSHAPE__ISBUTTON | 956
public static final short | GROUPSHAPE__METROBLOB | 937
public static final short | GROUPSHAPE__ONDBLCLICKNOTIFY | 955
public static final short | GROUPSHAPE__POSH | 911
public static final short | GROUPSHAPE__POSRELH | 912
public static final short | GROUPSHAPE__POSRELV | 914
public static final short | GROUPSHAPE__POSV | 913
public static final short | GROUPSHAPE__PRINT | 959
public static final short | GROUPSHAPE__REGROUPID | 904
public static final short | GROUPSHAPE__SCRIPT | 910
public static final short | GROUPSHAPE__SCRIPTEXT | 919
public static final short | GROUPSHAPE__SCRIPTLANG | 920
public static final short | GROUPSHAPE__SHAPENAME | 896
public static final short | GROUPSHAPE__TABLEPROPERTIES | 927
public static final short | GROUPSHAPE__TABLEROWPROPERTIES | 928
public static final short | GROUPSHAPE__TOOLTIP | 909
public static final short | GROUPSHAPE__UNUSED906 | 906
public static final short | GROUPSHAPE__WEBBOT | 933
public static final short | GROUPSHAPE__WRAPDISTBOTTOM | 903
public static final short | GROUPSHAPE__WRAPDISTLEFT | 900
public static final short | GROUPSHAPE__WRAPDISTRIGHT | 902
public static final short | GROUPSHAPE__WRAPDISTTOP | 901
public static final short | GROUPSHAPE__WRAPPOLYGONVERTICES | 899
public static final short | GROUPSHAPE__ZORDER | 938
public static final short | LINESTYLE__ANYLINE | 508
public static final short | LINESTYLE__ARROWHEADSOK | 507
public static final short | LINESTYLE__BACKCOLOR | 450
public static final short | LINESTYLE__COLOR | 448
public static final short | LINESTYLE__CRMOD | 451
public static final short | LINESTYLE__FILLBLIP | 453
public static final short | LINESTYLE__FILLBLIPFLAGS | 455
public static final short | LINESTYLE__FILLBLIPNAME | 454
public static final short | LINESTYLE__FILLDZTYPE | 458
public static final short | LINESTYLE__FILLHEIGHT | 457
public static final short | LINESTYLE__FILLWIDTH | 456
public static final short | LINESTYLE__HITLINETEST | 509
public static final short | LINESTYLE__LINEDASHING | 462
public static final short | LINESTYLE__LINEDASHSTYLE | 463
public static final short | LINESTYLE__LINEENDARROWHEAD | 465
public static final short | LINESTYLE__LINEENDARROWLENGTH | 469
public static final short | LINESTYLE__LINEENDARROWWIDTH | 468
public static final short | LINESTYLE__LINEENDCAPSTYLE | 471
public static final short | LINESTYLE__LINEESTARTARROWLENGTH | 467
public static final short | LINESTYLE__LINEFILLSHAPE | 510
public static final short | LINESTYLE__LINEJOINSTYLE | 470
public static final short | LINESTYLE__LINEMITERLIMIT | 460
public static final short | LINESTYLE__LINESTARTARROWHEAD | 464
public static final short | LINESTYLE__LINESTARTARROWWIDTH | 466
public static final short | LINESTYLE__LINESTYLE | 461
public static final short | LINESTYLE__LINETYPE | 452
public static final short | LINESTYLE__LINEWIDTH | 459
public static final short | LINESTYLE__NOLINEDRAWDASH | 511
public static final short | LINESTYLE__OPACITY | 449
public static final short | PERSPECTIVE__OFFSETX | 577
public static final short | PERSPECTIVE__OFFSETY | 578
public static final short | PERSPECTIVE__ORIGINX | 586
public static final short | PERSPECTIVE__ORIGINY | 587
public static final short | PERSPECTIVE__PERSPECTIVEON | 639
public static final short | PERSPECTIVE__PERSPECTIVEX | 583
public static final short | PERSPECTIVE__PERSPECTIVEY | 584
public static final short | PERSPECTIVE__SCALEXTOX | 579
public static final short | PERSPECTIVE__SCALEXTOY | 581
public static final short | PERSPECTIVE__SCALEYTOX | 580
public static final short | PERSPECTIVE__SCALEYTOY | 582
public static final short | PERSPECTIVE__TYPE | 576
public static final short | PERSPECTIVE__WEIGHT | 585
public static final short | PROTECTION__LOCKADJUSTHANDLES | 126
public static final short | PROTECTION__LOCKAGAINSTGROUPING | 127
public static final short | PROTECTION__LOCKAGAINSTSELECT | 122
public static final short | PROTECTION__LOCKASPECTRATIO | 120
public static final short | PROTECTION__LOCKCROPPING | 123
public static final short | PROTECTION__LOCKPOSITION | 121
public static final short | PROTECTION__LOCKROTATION | 119
public static final short | PROTECTION__LOCKTEXT | 125
public static final short | PROTECTION__LOCKVERTICES | 124
public static final short | SHADOWSTYLE__COLOR | 513
public static final short | SHADOWSTYLE__CRMOD | 515
public static final short | SHADOWSTYLE__HIGHLIGHT | 514
public static final short | SHADOWSTYLE__OFFSETX | 517
public static final short | SHADOWSTYLE__OFFSETY | 518
public static final short | SHADOWSTYLE__OPACITY | 516
public static final short | SHADOWSTYLE__ORIGINX | 528
public static final short | SHADOWSTYLE__ORIGINY | 529
public static final short | SHADOWSTYLE__PERSPECTIVEX | 525
public static final short | SHADOWSTYLE__PERSPECTIVEY | 526
public static final short | SHADOWSTYLE__SCALEXTOX | 521
public static final short | SHADOWSTYLE__SCALEXTOY | 523
public static final short | SHADOWSTYLE__SCALEYTOX | 522
public static final short | SHADOWSTYLE__SCALEYTOY | 524
public static final short | SHADOWSTYLE__SECONDOFFSETX | 519
public static final short | SHADOWSTYLE__SECONDOFFSETY | 520
public static final short | SHADOWSTYLE__SHADOW | 574
public static final short | SHADOWSTYLE__SHADOWOBSURED | 575
public static final short | SHADOWSTYLE__TYPE | 512
public static final short | SHADOWSTYLE__WEIGHT | 527
public static final short | SHAPE__BACKGROUNDSHAPE | 831
public static final short | SHAPE__BLACKANDWHITESETTINGS | 772
public static final short | SHAPE__CONNECTORSTYLE | 771
public static final short | SHAPE__DELETEATTACHEDOBJECT | 830
public static final short | SHAPE__LOCKSHAPETYPE | 828
public static final short | SHAPE__MASTER | 769
public static final short | SHAPE__OLEICON | 826
public static final short | SHAPE__PREFERRELATIVERESIZE | 827
public static final short | SHAPE__WMODEBW | 774
public static final short | SHAPE__WMODEPUREBW | 773
public static final short | TEXT__ANCHORTEXT | 135
public static final short | TEXT__BIDIR | 139
public static final short | TEXT__FONTROTATION | 137
public static final short | TEXT__IDOFNEXTSHAPE | 138
public static final short | TEXT__ROTATETEXTWITHSHAPE | 189
public static final short | TEXT__SCALETEXT | 134
public static final short | TEXT__SINGLECLICKSELECTS | 187
public static final short | TEXT__SIZE_TEXT_TO_FIT_SHAPE | 191
public static final short | TEXT__SIZESHAPETOFITTEXT | 190
public static final short | TEXT__TEXTBOTTOM | 132
public static final short | TEXT__TEXTFLOW | 136
public static final short | TEXT__TEXTID | 128
public static final short | TEXT__TEXTLEFT | 129
public static final short | TEXT__TEXTRIGHT | 131
public static final short | TEXT__TEXTTOP | 130
public static final short | TEXT__USEHOSTMARGINS | 188
public static final short | TEXT__WRAPTEXT | 133
public static final short | THREED__3DEFFECT | 700
public static final short | THREED__CRMOD | 648
public static final short | THREED__DIFFUSEAMOUNT | 661
public static final short | THREED__EDGETHICKNESS | 663
public static final short | THREED__EXTRUDEBACKWARD | 665
public static final short | THREED__EXTRUDEFORWARD | 664
public static final short | THREED__EXTRUDEPLANE | 666
public static final short | THREED__EXTRUSIONCOLOR | 667
public static final short | THREED__LIGHTFACE | 703
public static final short | THREED__METALLIC | 701
public static final short | THREED__SHININESS | 662
public static final short | THREED__SPECULARAMOUNT | 640
public static final short | THREED__USEEXTRUSIONCOLOR | 702
public static final short | THREEDSTYLE__AMBIENTINTENSITY | 722
public static final short | THREEDSTYLE__CONSTRAINROTATION | 763
public static final short | THREEDSTYLE__FILLHARSH | 767
public static final short | THREEDSTYLE__FILLINTENSITY | 730
public static final short | THREEDSTYLE__FILLX | 727
public static final short | THREEDSTYLE__FILLY | 728
public static final short | THREEDSTYLE__FILLZ | 729
public static final short | THREEDSTYLE__KEYHARSH | 766
public static final short | THREEDSTYLE__KEYINTENSITY | 726
public static final short | THREEDSTYLE__KEYX | 723
public static final short | THREEDSTYLE__KEYY | 724
public static final short | THREEDSTYLE__KEYZ | 725
public static final short | THREEDSTYLE__ORIGINX | 718
public static final short | THREEDSTYLE__ORIGINY | 719
public static final short | THREEDSTYLE__PARALLEL | 765
public static final short | THREEDSTYLE__RENDERMODE | 713
public static final short | THREEDSTYLE__ROTATIONANGLE | 709
public static final short | THREEDSTYLE__ROTATIONAXISX | 706
public static final short | THREEDSTYLE__ROTATIONAXISY | 707
public static final short | THREEDSTYLE__ROTATIONAXISZ | 708
public static final short | THREEDSTYLE__ROTATIONCENTERAUTO | 764
public static final short | THREEDSTYLE__ROTATIONCENTERX | 710
public static final short | THREEDSTYLE__ROTATIONCENTERY | 711
public static final short | THREEDSTYLE__ROTATIONCENTERZ | 712
public static final short | THREEDSTYLE__SKEWAMOUNT | 721
public static final short | THREEDSTYLE__SKEWANGLE | 720
public static final short | THREEDSTYLE__TOLERANCE | 714
public static final short | THREEDSTYLE__XROTATIONANGLE | 705
public static final short | THREEDSTYLE__XVIEWPOINT | 715
public static final short | THREEDSTYLE__YROTATIONANGLE | 704
public static final short | THREEDSTYLE__YVIEWPOINT | 716
public static final short | THREEDSTYLE__ZVIEWPOINT | 717
public static final short | TRANSFORM__ROTATION | 4

org.apache.poi.ddf.EscherPropertyMetaData
public static final byte | TYPE_ARRAY | 5
public static final byte | TYPE_BOOLEAN | 1
public static final byte | TYPE_RGB | 2
public static final byte | TYPE_SHAPEPATH | 3
public static final byte | TYPE_SIMPLE | 4
public static final byte | TYPE_UNKNOWN | 0

org.apache.poi.ddf.EscherShapePathProperty
public static final int | CLOSED_CURVES | 3
public static final int | CLOSED_POLYGON | 1
public static final int | COMPLEX | 4
public static final int | CURVES | 2
public static final int | LINE_OF_STRAIGHT_SEGMENTS | 0

org.apache.poi.ddf.EscherSpgrRecord
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtSpgr"
public static final short | RECORD_ID | -4087

org.apache.poi.ddf.EscherSplitMenuColorsRecord
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtSplitMenuColors"
public static final short | RECORD_ID | -3810

org.apache.poi.ddf.EscherSpRecord
public static final int | FLAG_BACKGROUND | 1024
public static final int | FLAG_CHILD | 2
public static final int | FLAG_CONNECTOR | 256
public static final int | FLAG_DELETED | 8
public static final int | FLAG_FLIPHORIZ | 64
public static final int | FLAG_FLIPVERT | 128
public static final int | FLAG_GROUP | 1
public static final int | FLAG_HASSHAPETYPE | 2048
public static final int | FLAG_HAVEANCHOR | 512
public static final int | FLAG_HAVEMASTER | 32
public static final int | FLAG_OLESHAPE | 16
public static final int | FLAG_PATRIARCH | 4
public static final java.lang.String | RECORD_DESCRIPTION | "MsofbtSp"
public static final short | RECORD_ID | -4086

org.apache.poi.ddf.EscherTertiaryOptRecord
public static final short RECORD_ID -3806

org.apache.poi.ddf.EscherTextboxRecord
public static final java.lang.String | RECORD_DESCRIPTION | "msofbtClientTextbox"
public static final short | RECORD_ID | -4083

org.apache.poi.extractor.ExtractorFactory
public static final java.lang.String CORE_DOCUMENT_REL "http://schemas.openxmlformats.org/officeDocument/2006/relationships/officeDocument"

org.apache.poi.hmef.CompressedRTF
public static final java.lang.String LZW_RTF_PRELOAD "{\\rtf1\\ansi\\mac\\deff0\\deftab720{\\fonttbl;}{\\f0\\fnil \\froman \\fswiss \\fmodern \\fscript \\fdecor MS Sans SerifSymbolArialTimes New RomanCourier{\\colortbl\\red0\\green0\\blue0\n\r\\par \\pard\\plain\\f0\\fs20\\b\\i\\u\\tab\\tx"

org.apache.poi.hmef.HMEFMessage
public static final long HEADER_SIGNATURE 574529400L

org.apache.poi.hmef.attribute.TNEFProperty
public static final int | LEVEL_ATTACHMENT | 2
public static final int | LEVEL_END_OF_FILE | -1
public static final int | LEVEL_MESSAGE | 1
public static final int | PTYPE_APPTIME | 7
public static final int | PTYPE_BINARY | 258
public static final int | PTYPE_BOOLEAN | 11
public static final int | PTYPE_CLASSID | 72
public static final int | PTYPE_CURRENCY | 6
public static final int | PTYPE_DOUBLE | 5
public static final int | PTYPE_ERROR | 10
public static final int | PTYPE_I2 | 2
public static final int | PTYPE_I8 | 20
public static final int | PTYPE_LONG | 3
public static final int | PTYPE_MULTIVALUED | 4096
public static final int | PTYPE_NULL | 1
public static final int | PTYPE_OBJECT | 13
public static final int | PTYPE_R4 | 4
public static final int | PTYPE_STRING8 | 30
public static final int | PTYPE_SYSTIME | 64
public static final int | PTYPE_UNICODE | 31
public static final int | PTYPE_UNSPECIFIED | 0
public static final int | TYPE_BYTE | 6
public static final int | TYPE_DATE | 3
public static final int | TYPE_DWORD | 8
public static final int | TYPE_LONG | 5
public static final int | TYPE_MAX | 9
public static final int | TYPE_SHORT | 4
public static final int | TYPE_STRING | 1
public static final int | TYPE_TEXT | 2
public static final int | TYPE_TRIPLES | 0
public static final int | TYPE_WORD | 7

org.apache.poi.hpsf.ClassID
public static final int LENGTH 16

org.apache.poi.hpsf.Constants
public static final int | CP_037 | 37
public static final int | CP_EUC_JP | 51932
public static final int | CP_EUC_KR | 51949
public static final int | CP_GB18030 | 54936
public static final int | CP_GB2312 | 52936
public static final int | CP_GBK | 936
public static final int | CP_ISO_2022_JP1 | 50220
public static final int | CP_ISO_2022_JP2 | 50221
public static final int | CP_ISO_2022_JP3 | 50222
public static final int | CP_ISO_2022_KR | 50225
public static final int | CP_ISO_8859_1 | 28591
public static final int | CP_ISO_8859_2 | 28592
public static final int | CP_ISO_8859_3 | 28593
public static final int | CP_ISO_8859_4 | 28594
public static final int | CP_ISO_8859_5 | 28595
public static final int | CP_ISO_8859_6 | 28596
public static final int | CP_ISO_8859_7 | 28597
public static final int | CP_ISO_8859_8 | 28598
public static final int | CP_ISO_8859_9 | 28599
public static final int | CP_JOHAB | 1361
public static final int | CP_KOI8_R | 20866
public static final int | CP_MAC_ARABIC | 10004
public static final int | CP_MAC_CENTRAL_EUROPE | 10029
public static final int | CP_MAC_CHINESE_SIMPLE | 10008
public static final int | CP_MAC_CHINESE_TRADITIONAL | 10002
public static final int | CP_MAC_CROATIAN | 10082
public static final int | CP_MAC_CYRILLIC | 10007
public static final int | CP_MAC_GREEK | 10006
public static final int | CP_MAC_HEBREW | 10005
public static final int | CP_MAC_ICELAND | 10079
public static final int | CP_MAC_JAPAN | 10001
public static final int | CP_MAC_KOREAN | 10003
public static final int | CP_MAC_ROMAN | 10000
public static final int | CP_MAC_ROMANIA | 10010
public static final int | CP_MAC_THAI | 10021
public static final int | CP_MAC_TURKISH | 10081
public static final int | CP_MAC_UKRAINE | 10017
public static final int | CP_MS949 | 949
public static final int | CP_SJIS | 932
public static final int | CP_UNICODE | 1200
public static final int | CP_US_ACSII | 20127
public static final int | CP_US_ASCII2 | 65000
public static final int | CP_UTF16 | 1200
public static final int | CP_UTF16_BE | 1201
public static final int | CP_UTF8 | 65001
public static final int | CP_WINDOWS_1250 | 1250
public static final int | CP_WINDOWS_1251 | 1251
public static final int | CP_WINDOWS_1252 | 1252
public static final int | CP_WINDOWS_1253 | 1253
public static final int | CP_WINDOWS_1254 | 1254
public static final int | CP_WINDOWS_1255 | 1255
public static final int | CP_WINDOWS_1256 | 1256
public static final int | CP_WINDOWS_1257 | 1257
public static final int | CP_WINDOWS_1258 | 1258

org.apache.poi.hpsf.DocumentSummaryInformation
public static final java.lang.String DEFAULT_STREAM_NAME "\u0005DocumentSummaryInformation"

org.apache.poi.hpsf.PropertySet
public static final int | OS_MACINTOSH | 1
public static final int | OS_WIN16 | 0
public static final int | OS_WIN32 | 2

org.apache.poi.hpsf.SummaryInformation
public static final java.lang.String DEFAULT_STREAM_NAME "\u0005SummaryInformation"

org.apache.poi.hpsf.Util
public static final long EPOCH_DIFF 11644473600000L

org.apache.poi.hpsf.Variant
public static final int | VT_ARRAY | 8192
public static final int | VT_BLOB | 65
public static final int | VT_BLOB_OBJECT | 70
public static final int | VT_BOOL | 11
public static final int | VT_BSTR | 8
public static final int | VT_BYREF | 16384
public static final int | VT_CARRAY | 28
public static final int | VT_CF | 71
public static final int | VT_CLSID | 72
public static final int | VT_CY | 6
public static final int | VT_DATE | 7
public static final int | VT_DECIMAL | 14
public static final int | VT_DISPATCH | 9
public static final int | VT_EMPTY | 0
public static final int | VT_ERROR | 10
public static final int | VT_FILETIME | 64
public static final int | VT_HRESULT | 25
public static final int | VT_I1 | 16
public static final int | VT_I2 | 2
public static final int | VT_I4 | 3
public static final int | VT_I8 | 20
public static final int | VT_ILLEGAL | 65535
public static final int | VT_ILLEGALMASKED | 4095
public static final int | VT_INT | 22
public static final int | VT_LPSTR | 30
public static final int | VT_LPWSTR | 31
public static final int | VT_NULL | 1
public static final int | VT_PTR | 26
public static final int | VT_R4 | 4
public static final int | VT_R8 | 5
public static final int | VT_RESERVED | 32768
public static final int | VT_SAFEARRAY | 27
public static final int | VT_STORAGE | 67
public static final int | VT_STORED_OBJECT | 69
public static final int | VT_STREAM | 66
public static final int | VT_STREAMED_OBJECT | 68
public static final int | VT_TYPEMASK | 4095
public static final int | VT_UI1 | 17
public static final int | VT_UI2 | 18
public static final int | VT_UI4 | 19
public static final int | VT_UI8 | 21
public static final int | VT_UINT | 23
public static final int | VT_UNKNOWN | 13
public static final int | VT_USERDEFINED | 29
public static final int | VT_VARIANT | 12
public static final int | VT_VECTOR | 4096
public static final int | VT_VERSIONED_STREAM | 73
public static final int | VT_VOID | 24

org.apache.poi.hpsf.wellknown.PropertyIDMap
public static final int | PID_APPNAME | 18
public static final int | PID_AUTHOR | 4
public static final int | PID_BYTECOUNT | 4
public static final int | PID_CATEGORY | 2
public static final int | PID_CHARCOUNT | 16
public static final int | PID_CODEPAGE | 1
public static final int | PID_COMMENTS | 6
public static final int | PID_COMPANY | 15
public static final int | PID_CREATE_DTM | 12
public static final int | PID_DICTIONARY | 0
public static final int | PID_DOCPARTS | 13
public static final int | PID_EDITTIME | 10
public static final int | PID_HEADINGPAIR | 12
public static final int | PID_HIDDENCOUNT | 9
public static final int | PID_KEYWORDS | 5
public static final int | PID_LASTAUTHOR | 8
public static final int | PID_LASTPRINTED | 11
public static final int | PID_LASTSAVE_DTM | 13
public static final int | PID_LINECOUNT | 5
public static final int | PID_LINKSDIRTY | 16
public static final int | PID_MANAGER | 14
public static final int | PID_MAX | 16
public static final int | PID_MMCLIPCOUNT | 10
public static final int | PID_NOTECOUNT | 8
public static final int | PID_PAGECOUNT | 14
public static final int | PID_PARCOUNT | 6
public static final int | PID_PRESFORMAT | 3
public static final int | PID_REVNUMBER | 9
public static final int | PID_SCALE | 11
public static final int | PID_SECURITY | 19
public static final int | PID_SLIDECOUNT | 7
public static final int | PID_SUBJECT | 3
public static final int | PID_TEMPLATE | 7
public static final int | PID_THUMBNAIL | 17
public static final int | PID_TITLE | 2
public static final int | PID_WORDCOUNT | 15

org.apache.poi.hpsf.wellknown.SectionIDMap
public static final java.lang.String UNDEFINED "[undefined]"

org.apache.poi.hslf.blip.DIB
public static final int HEADER_SIZE 14

org.apache.poi.hslf.blip.WMF.AldusHeader
public static final int APMHEADER_KEY -1698247209

org.apache.poi.hslf.dev.PPTXMLDump
public static final int | HEADER_SIZE | 8
public static final int | PICT_HEADER_SIZE | 25
public static final java.lang.String | PICTURES_ENTRY | "Pictures"
public static final java.lang.String | PPDOC_ENTRY | "PowerPoint Document"

org.apache.poi.hslf.model.ActiveXShape
public static final int DEFAULT_ACTIVEX_THUMBNAIL -1

org.apache.poi.hslf.model.Fill
public static final int | FILL_BACKGROUND | 9
public static final int | FILL_PATTERN | 1
public static final int | FILL_PICTURE | 3
public static final int | FILL_SHADE | 4
public static final int | FILL_SHADE_CENTER | 5
public static final int | FILL_SHADE_SCALE | 7
public static final int | FILL_SHADE_SHAPE | 6
public static final int | FILL_SHADE_TITLE | 8
public static final int | FILL_SOLID | 0
public static final int | FILL_TEXTURE | 2

org.apache.poi.hslf.model.Hyperlink
public static final byte | LINK_FIRSTSLIDE | 2
public static final byte | LINK_LASTSLIDE | 3
public static final byte | LINK_NEXTSLIDE | 0
public static final byte | LINK_NULL | -1
public static final byte | LINK_PREVIOUSSLIDE | 1
public static final byte | LINK_URL | 8

org.apache.poi.hslf.model.Line
public static final int | LINE_DOUBLE | 1
public static final int | LINE_SIMPLE | 0
public static final int | LINE_THICKTHIN | 2
public static final int | LINE_THINTHICK | 3
public static final int | LINE_TRIPLE | 4
public static final int | PEN_DASH | 7
public static final int | PEN_DASHDOT | 4
public static final int | PEN_DASHDOTDOT | 5
public static final int | PEN_DASHDOTGEL | 9
public static final int | PEN_DOT | 3
public static final int | PEN_DOTGEL | 6
public static final int | PEN_LONGDASHDOTDOTGEL | 11
public static final int | PEN_LONGDASHDOTGEL | 10
public static final int | PEN_LONGDASHGEL | 8
public static final int | PEN_PS_DASH | 2
public static final int | PEN_SOLID | 1

org.apache.poi.hslf.model.MovieShape
public static final int | DEFAULT_MOVIE_THUMBNAIL | -1
public static final int | MOVIE_AVI | 2
public static final int | MOVIE_MPEG | 1

org.apache.poi.hslf.model.Picture
public static final byte | DIB | 7
public static final int | EMF | 2
public static final int | JPEG | 5
public static final int | PICT | 4
public static final int | PNG | 6
public static final int | WMF | 3

org.apache.poi.hslf.model.PPFont
public static final byte | ANSI_CHARSET | 0
public static final byte | DEFAULT_CHARSET | 1
public static final byte | DEFAULT_PITCH | 0
public static final byte | FF_DECORATIVE | 80
public static final byte | FF_DONTCARE | 0
public static final byte | FF_MODERN | 48
public static final byte | FF_ROMAN | 16
public static final byte | FF_SCRIPT | 64
public static final byte | FF_SWISS | 32
public static final byte | FIXED_PITCH | 1
public static final byte | SYMBOL_CHARSET | 2
public static final byte | VARIABLE_PITCH | 2

org.apache.poi.hslf.model.Shape
public static final int | EMU_PER_CENTIMETER | 360000
public static final int | EMU_PER_INCH | 914400
public static final int | EMU_PER_POINT | 12700
public static final int | MASTER_DPI | 576
public static final int | PIXEL_DPI | 96
public static final int | POINT_DPI | 72

org.apache.poi.hslf.model.SimpleShape
public static final double DEFAULT_LINE_WIDTH 0.75

org.apache.poi.hslf.model.Table
protected static final int | BORDER_BOTTOM | 3
protected static final int | BORDER_LEFT | 4
protected static final int | BORDER_RIGHT | 2
protected static final int | BORDER_TOP | 1
protected static final int | BORDERS_ALL | 5
protected static final int | BORDERS_INSIDE | 7
protected static final int | BORDERS_NONE | 8
protected static final int | BORDERS_OUTSIDE | 6

org.apache.poi.hslf.model.TableCell
protected static final int | DEFAULT_HEIGHT | 40
protected static final int | DEFAULT_WIDTH | 100

org.apache.poi.hslf.model.TextPainter
protected static final char DEFAULT_BULLET_CHAR 9632

org.apache.poi.hslf.model.TextShape
public static final int | AlignCenter | 1
public static final int | AlignJustify | 3
public static final int | AlignLeft | 0
public static final int | AlignRight | 2
public static final int | AnchorBottom | 2
public static final int | AnchorBottomBaseline | 7
public static final int | AnchorBottomCentered | 5
public static final int | AnchorBottomCenteredBaseline | 9
public static final int | AnchorMiddle | 1
public static final int | AnchorMiddleCentered | 4
public static final int | AnchorTop | 0
public static final int | AnchorTopBaseline | 6
public static final int | AnchorTopCentered | 3
public static final int | AnchorTopCenteredBaseline | 8
public static final int | WrapByPoints | 1
public static final int | WrapNone | 2
public static final int | WrapSquare | 0
public static final int | WrapThrough | 4
public static final int | WrapTopBottom | 3

org.apache.poi.hslf.model.textproperties.AlignmentTextProp
public static final int | CENTER | 1
public static final int | JUSTIFY | 3
public static final int | JUSTIFYLOW | 6
public static final int | LEFT | 0
public static final int | RIGHT | 2
public static final int | THAIDISTRIBUTED | 5

org.apache.poi.hslf.model.textproperties.CharFlagsTextProp
public static final int | BOLD_IDX | 0
public static final int | ENABLE_NUMBERING_1_IDX | 11
public static final int | ENABLE_NUMBERING_2_IDX | 12
public static final int | ITALIC_IDX | 1
public static final int | RELIEF_IDX | 9
public static final int | RESET_NUMBERING_IDX | 10
public static final int | SHADOW_IDX | 4
public static final int | STRIKETHROUGH_IDX | 8
public static final int | UNDERLINE_IDX | 2

org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp
public static final int | BULLET_HARDCOLOR_IDX | 2
public static final int | BULLET_HARDFONT_IDX | 1
public static final int | BULLET_HARDSIZE_IDX | 4
public static final int | BULLET_IDX | 0

org.apache.poi.hslf.record.AnimationInfoAtom
public static final int | AnimateBg | 16384
public static final int | Automatic | 4
public static final int | Hide | 4096
public static final int | Play | 256
public static final int | Reverse | 1
public static final int | Sound | 16
public static final int | StopSound | 64
public static final int | Synchronous | 1024

org.apache.poi.hslf.record.DocumentAtom.SlideSize
public static final int | A4_SIZED_PAPER | 2
public static final int | BANNER | 5
public static final int | CUSTOM | 6
public static final int | LETTER_SIZED_PAPER | 1
public static final int | ON_35MM | 3
public static final int | ON_SCREEN | 0
public static final int | OVERHEAD | 4

org.apache.poi.hslf.record.ExEmbedAtom
public static final int | DOES_NOT_FOLLOW_COLOR_SCHEME | 0
public static final int | FOLLOWS_ENTIRE_COLOR_SCHEME | 1
public static final int | FOLLOWS_TEXT_AND_BACKGROUND_SCHEME | 2

org.apache.poi.hslf.record.ExMediaAtom
public static final int | fLoop | 1
public static final int | fNarration | 4
public static final int | fRewind | 2

org.apache.poi.hslf.record.ExOleObjAtom
public static final int | DRAW_ASPECT_DOCPRINT | 8
public static final int | DRAW_ASPECT_ICON | 4
public static final int | DRAW_ASPECT_THUMBNAIL | 2
public static final int | DRAW_ASPECT_VISIBLE | 1
public static final int | SUBTYPE_CLIPART_GALLERY | 1
public static final int | SUBTYPE_DEFAULT | 0
public static final int | SUBTYPE_EQUATION | 6
public static final int | SUBTYPE_EXCEL | 3
public static final int | SUBTYPE_EXCEL_CHART | 14
public static final int | SUBTYPE_GRAPH | 4
public static final int | SUBTYPE_IMAGE | 9
public static final int | SUBTYPE_MEDIA_PLAYER | 15
public static final int | SUBTYPE_NOTEIT | 13
public static final int | SUBTYPE_ORGANIZATION_CHART | 5
public static final int | SUBTYPE_POWERPOINT_PRESENTATION | 10
public static final int | SUBTYPE_POWERPOINT_SLIDE | 11
public static final int | SUBTYPE_PROJECT | 12
public static final int | SUBTYPE_SOUND | 8
public static final int | SUBTYPE_WORD_TABLE | 2
public static final int | SUBTYPE_WORDART | 7
public static final int | TYPE_CONTROL | 2
public static final int | TYPE_EMBEDDED | 0
public static final int | TYPE_LINKED | 1

org.apache.poi.hslf.record.HeadersFootersAtom
public static final int | fHasDate | 1
public static final int | fHasFooter | 32
public static final int | fHasHeader | 16
public static final int | fHasSlideNumber | 8
public static final int | fHasTodayDate | 2
public static final int | fHasUserDate | 4

org.apache.poi.hslf.record.HeadersFootersContainer
public static final int | FOOTERATOM | 2
public static final int | HEADERATOM | 1
public static final short | NotesHeadersFootersContainer | 79
public static final short | SlideHeadersFootersContainer | 63
public static final int | USERDATEATOM | 0

org.apache.poi.hslf.record.InteractiveInfoAtom
public static final byte | ACTION_CUSTOMSHOW | 7
public static final byte | ACTION_HYPERLINK | 4
public static final byte | ACTION_JUMP | 3
public static final byte | ACTION_MACRO | 1
public static final byte | ACTION_MEDIA | 6
public static final byte | ACTION_NONE | 0
public static final byte | ACTION_OLE | 5
public static final byte | ACTION_RUNPROGRAM | 2
public static final byte | JUMP_ENDSHOW | 6
public static final byte | JUMP_FIRSTSLIDE | 3
public static final byte | JUMP_LASTSLIDE | 4
public static final byte | JUMP_LASTSLIDEVIEWED | 5
public static final byte | JUMP_NEXTSLIDE | 1
public static final byte | JUMP_NONE | 0
public static final byte | JUMP_PREVIOUSSLIDE | 2
public static final byte | LINK_CustomShow | 6
public static final byte | LINK_FirstSlide | 2
public static final byte | LINK_LastSlide | 3
public static final byte | LINK_NextSlide | 0
public static final byte | LINK_NULL | -1
public static final byte | LINK_OtherFile | 10
public static final byte | LINK_OtherPresentation | 9
public static final byte | LINK_PreviousSlide | 1
public static final byte | LINK_SlideNumber | 7
public static final byte | LINK_Url | 8

org.apache.poi.hslf.record.OEPlaceholderAtom
public static final byte | Body | 14
public static final byte | CenteredTitle | 15
public static final byte | ClipArt | 22
public static final byte | Graph | 20
public static final byte | MasterBody | 2
public static final byte | MasterCenteredTitle | 3
public static final byte | MasterDate | 7
public static final byte | MasterFooter | 9
public static final byte | MasterHeader | 10
public static final byte | MasterNotesBody | 6
public static final byte | MasterNotesSlideImage | 5
public static final byte | MasterSlideNumber | 8
public static final byte | MasterSubTitle | 4
public static final byte | MasterTitle | 1
public static final byte | MediaClip | 24
public static final byte | None | 0
public static final byte | NotesBody | 12
public static final byte | NotesSlideImage | 11
public static final byte | Object | 19
public static final byte | OrganizationChart | 23
public static final int | PLACEHOLDER_FULLSIZE | 0
public static final int | PLACEHOLDER_HALFSIZE | 1
public static final int | PLACEHOLDER_QUARTSIZE | 2
public static final byte | Subtitle | 16
public static final byte | Table | 21
public static final byte | Title | 13
public static final byte | VerticalTextBody | 18
public static final byte | VerticalTextTitle | 17

org.apache.poi.hslf.record.RecordTypes
public static final int | EscherAlignRule | 61459
public static final int | EscherAnchor | 61454
public static final int | EscherArcRule | 61460
public static final int | EscherBlip_END | 61719
public static final int | EscherBlip_START | 61464
public static final int | EscherBSE | 61447
public static final int | EscherBStoreContainer | 61441
public static final int | EscherCalloutRule | 61463
public static final int | EscherChildAnchor | 61455
public static final int | EscherClientAnchor | 61456
public static final int | EscherClientData | 61457
public static final int | EscherClientRule | 61461
public static final int | EscherClientTextbox | 61453
public static final int | EscherCLSID | 61462
public static final int | EscherColorMRU | 61722
public static final int | EscherColorScheme | 61728
public static final int | EscherConnectorRule | 61458
public static final int | EscherDeletedPspl | 61725
public static final int | EscherDg | 61448
public static final int | EscherDgContainer | 61442
public static final int | EscherDgg | 61446
public static final int | EscherDggContainer | 61440
public static final int | EscherOleObject | 61727
public static final int | EscherOPT | 61451
public static final int | EscherRegroupItems | 61720
public static final int | EscherSelection | 61721
public static final int | EscherSolverContainer | 61445
public static final int | EscherSp | 61450
public static final int | EscherSpContainer | 61444
public static final int | EscherSpgr | 61449
public static final int | EscherSpgrContainer | 61443
public static final int | EscherSplitMenuColors | 61726
public static final int | EscherTextbox | 61452
public static final int | EscherUserDefined | 61730

org.apache.poi.hslf.record.SlideAtom
public static final int | MASTER_SLIDE_ID | 0
public static final int | USES_MASTER_SLIDE_ID | -2147483648

org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
public static final int | BIG_OBJECT | 15
public static final int | BLANK_SLIDE | 16
public static final int | FOUR_OBJECTS | 14
public static final int | HANDOUT | 6
public static final int | MASTER_NOTES | 4
public static final int | MASTER_SLIDE | 3
public static final int | NOTES_TITLE_BODY | 5
public static final int | TITLE_2_COLUMN_BODY | 8
public static final int | TITLE_2_COLUNM_LEFT_2_ROW_BODY | 11
public static final int | TITLE_2_COLUNM_RIGHT_2_ROW_BODY | 10
public static final int | TITLE_2_ROW_BODY | 9
public static final int | TITLE_2_ROW_BOTTOM_2_COLUMN_BODY | 12
public static final int | TITLE_2_ROW_TOP_2_COLUMN_BODY | 13
public static final int | TITLE_BODY_SLIDE | 1
public static final int | TITLE_MASTER_SLIDE | 2
public static final int | TITLE_ONLY | 7
public static final int | TITLE_SLIDE | 0
public static final int | VERTICAL_TITLE_2_ROW_BODY_LEFT | 17
public static final int | VERTICAL_TITLE_BODY_LEFT | 17

org.apache.poi.hslf.record.SlideListWithText
public static final int | MASTER | 1
public static final int | NOTES | 2
public static final int | SLIDES | 0

org.apache.poi.hslf.record.TextHeaderAtom
public static final int | BODY_TYPE | 1
public static final int | CENTER_TITLE_TYPE | 6
public static final int | CENTRE_BODY_TYPE | 5
public static final int | HALF_BODY_TYPE | 7
public static final int | NOTES_TYPE | 2
public static final int | OTHER_TYPE | 4
public static final int | QUARTER_BODY_TYPE | 8
public static final int | TITLE_TYPE | 0

org.apache.poi.hslf.record.UserEditAtom
public static final int | LAST_VIEW_NONE | 0
public static final int | LAST_VIEW_NOTES | 3
public static final int | LAST_VIEW_OUTLINE_VIEW | 2
public static final int | LAST_VIEW_SLIDE_VIEW | 1

org.apache.poi.hslf.usermodel.PictureData
protected static final int CHECKSUM_SIZE 16

org.apache.poi.hsmf.datatypes.AttachmentChunks
public static final java.lang.String PREFIX "__attach_version1.0_#"

org.apache.poi.hsmf.datatypes.Chunk
public static final java.lang.String DEFAULT_NAME_PREFIX "__substg1.0_"

org.apache.poi.hsmf.datatypes.NameIdChunks
public static final java.lang.String PREFIX "__nameid_version1.0"

org.apache.poi.hsmf.datatypes.RecipientChunks
public static final java.lang.String PREFIX "__recip_version1.0_#"

org.apache.poi.hsmf.datatypes.Types
public static final int | APP_TIME | 7
public static final int | ASCII_STRING | 30
public static final int | BINARY | 258
public static final int | BOOLEAN | 11
public static final int | CLS_ID | 72
public static final int | CURRENCY | 6
public static final int | DIRECTORY | 13
public static final int | DOUBLE | 5
public static final int | ERROR | 10
public static final int | FLOAT | 4
public static final int | LONG | 3
public static final int | LONG_LONG | 20
public static final int | MULTIVALUED_FLAG | 4096
public static final int | NULL | 1
public static final int | SHORT | 2
public static final int | TIME | 64
public static final int | UNICODE_STRING | 31
public static final int | UNSPECIFIED | 0

org.apache.poi.hssf.model.InternalSheet
public static final short | BottomMargin | 3
public static final short | LeftMargin | 0
public static final byte | PANE_LOWER_LEFT | 2
public static final byte | PANE_LOWER_RIGHT | 0
public static final byte | PANE_UPPER_LEFT | 3
public static final byte | PANE_UPPER_RIGHT | 1
public static final short | RightMargin | 1
public static final short | TopMargin | 2

org.apache.poi.hssf.model.PolygonShape
public static final short OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING 30

org.apache.poi.hssf.record.ArrayRecord
public static final short sid 545

org.apache.poi.hssf.record.AutoFilterInfoRecord
public static final short sid 157

org.apache.poi.hssf.record.BackupRecord
public static final short sid 64

org.apache.poi.hssf.record.BlankRecord
public static final short sid 513

org.apache.poi.hssf.record.BOFRecord
public static final int | BUILD | 4307
public static final int | BUILD_YEAR | 1996
public static final int | HISTORY_MASK | 65
public static final short | sid | 2057
public static final int | TYPE_CHART | 32
public static final int | TYPE_EXCEL_4_MACRO | 64
public static final int | TYPE_VB_MODULE | 6
public static final int | TYPE_WORKBOOK | 5
public static final int | TYPE_WORKSHEET | 16
public static final int | TYPE_WORKSPACE_FILE | 256
public static final int | VERSION | 1536

org.apache.poi.hssf.record.BookBoolRecord
public static final short sid 218

org.apache.poi.hssf.record.BoolErrRecord
public static final short sid 517

org.apache.poi.hssf.record.BottomMarginRecord
public static final short sid 41

org.apache.poi.hssf.record.BoundSheetRecord
public static final short sid 133

org.apache.poi.hssf.record.CalcCountRecord
public static final short sid 12

org.apache.poi.hssf.record.CalcModeRecord
public static final short | AUTOMATIC | 1
public static final short | AUTOMATIC_EXCEPT_TABLES | -1
public static final short | MANUAL | 0
public static final short | sid | 13

org.apache.poi.hssf.record.CFHeaderRecord
public static final short sid 432

org.apache.poi.hssf.record.CFRuleRecord
public static final byte | CONDITION_TYPE_CELL_VALUE_IS | 1
public static final byte | CONDITION_TYPE_FORMULA | 2
public static final short | sid | 433

org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator
public static final byte | BETWEEN | 1
public static final byte | EQUAL | 3
public static final byte | GE | 7
public static final byte | GT | 5
public static final byte | LE | 8
public static final byte | LT | 6
public static final byte | NO_COMPARISON | 0
public static final byte | NOT_BETWEEN | 2
public static final byte | NOT_EQUAL | 4

org.apache.poi.hssf.record.CodepageRecord
public static final short | CODEPAGE | 1200
public static final short | sid | 66

org.apache.poi.hssf.record.ColumnInfoRecord
public static final short sid 125

org.apache.poi.hssf.record.CommonObjectDataSubRecord
public static final short | OBJECT_TYPE_ARC | 4
public static final short | OBJECT_TYPE_BUTTON | 7
public static final short | OBJECT_TYPE_CHART | 5
public static final short | OBJECT_TYPE_CHECKBOX | 11
public static final short | OBJECT_TYPE_COMBO_BOX | 20
public static final short | OBJECT_TYPE_COMMENT | 25
public static final short | OBJECT_TYPE_DIALOG_BOX | 15
public static final short | OBJECT_TYPE_EDIT_BOX | 13
public static final short | OBJECT_TYPE_GROUP | 0
public static final short | OBJECT_TYPE_GROUP_BOX | 19
public static final short | OBJECT_TYPE_LABEL | 14
public static final short | OBJECT_TYPE_LINE | 1
public static final short | OBJECT_TYPE_LIST_BOX | 18
public static final short | OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING | 30
public static final short | OBJECT_TYPE_OPTION_BUTTON | 12
public static final short | OBJECT_TYPE_OVAL | 3
public static final short | OBJECT_TYPE_PICTURE | 8
public static final short | OBJECT_TYPE_POLYGON | 9
public static final short | OBJECT_TYPE_RECTANGLE | 2
public static final short | OBJECT_TYPE_RESERVED1 | 10
public static final short | OBJECT_TYPE_RESERVED2 | 21
public static final short | OBJECT_TYPE_RESERVED3 | 22
public static final short | OBJECT_TYPE_RESERVED4 | 23
public static final short | OBJECT_TYPE_RESERVED5 | 24
public static final short | OBJECT_TYPE_RESERVED6 | 26
public static final short | OBJECT_TYPE_RESERVED7 | 27
public static final short | OBJECT_TYPE_RESERVED8 | 28
public static final short | OBJECT_TYPE_RESERVED9 | 29
public static final short | OBJECT_TYPE_SCROLL_BAR | 17
public static final short | OBJECT_TYPE_SPINNER | 16
public static final short | OBJECT_TYPE_TEXT | 6
public static final short | sid | 21

org.apache.poi.hssf.record.ContinueRecord
public static final short sid 60

org.apache.poi.hssf.record.CountryRecord
public static final short sid 140

org.apache.poi.hssf.record.CRNCountRecord
public static final short sid 89

org.apache.poi.hssf.record.CRNRecord
public static final short sid 90

org.apache.poi.hssf.record.DateWindow1904Record
public static final short sid 34

org.apache.poi.hssf.record.DBCellRecord
public static final int | BLOCK_SIZE | 32
public static final short | sid | 215

org.apache.poi.hssf.record.DConRefRecord
public static final short sid 81

org.apache.poi.hssf.record.DefaultColWidthRecord
public static final int | DEFAULT_COLUMN_WIDTH | 8
public static final short | sid | 85

org.apache.poi.hssf.record.DefaultRowHeightRecord
public static final short | DEFAULT_ROW_HEIGHT | 255
public static final short | sid | 549

org.apache.poi.hssf.record.DeltaRecord
public static final double | DEFAULT_VALUE | 0.0010
public static final short | sid | 16

org.apache.poi.hssf.record.DimensionsRecord
public static final short sid 512

org.apache.poi.hssf.record.DrawingGroupRecord
public static final short sid 235

org.apache.poi.hssf.record.DrawingRecord
public static final short sid 236

org.apache.poi.hssf.record.DrawingRecordForBiffViewer
public static final short sid 236

org.apache.poi.hssf.record.DrawingSelectionRecord
public static final short sid 237

org.apache.poi.hssf.record.DSFRecord
public static final short sid 353

org.apache.poi.hssf.record.DVALRecord
public static final short sid 434

org.apache.poi.hssf.record.DVRecord
public static final short sid 446

org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord
public static final short sid 9

org.apache.poi.hssf.record.EndSubRecord
public static final short sid 0

org.apache.poi.hssf.record.EOFRecord
public static final int | ENCODED_SIZE | 4
public static final short | sid | 10

org.apache.poi.hssf.record.EscherAggregate
public static final short | sid | 9876
public static final short | ST_ACCENTBORDERCALLOUT1 | 50
public static final short | ST_ACCENTBORDERCALLOUT2 | 51
public static final short | ST_ACCENTBORDERCALLOUT3 | 52
public static final short | ST_ACCENTBORDERCALLOUT90 | 181
public static final short | ST_ACCENTCALLOUT1 | 44
public static final short | ST_ACCENTCALLOUT2 | 45
public static final short | ST_ACCENTCALLOUT3 | 46
public static final short | ST_ACCENTCALLOUT90 | 179
public static final short | ST_ACTIONBUTTONBACKPREVIOUS | 194
public static final short | ST_ACTIONBUTTONBEGINNING | 196
public static final short | ST_ACTIONBUTTONBLANK | 189
public static final short | ST_ACTIONBUTTONDOCUMENT | 198
public static final short | ST_ACTIONBUTTONEND | 195
public static final short | ST_ACTIONBUTTONFORWARDNEXT | 193
public static final short | ST_ACTIONBUTTONHELP | 191
public static final short | ST_ACTIONBUTTONHOME | 190
public static final short | ST_ACTIONBUTTONINFORMATION | 192
public static final short | ST_ACTIONBUTTONMOVIE | 200
public static final short | ST_ACTIONBUTTONRETURN | 197
public static final short | ST_ACTIONBUTTONSOUND | 199
public static final short | ST_ARC | 19
public static final short | ST_ARROW | 13
public static final short | ST_BALLOON | 17
public static final short | ST_BENTARROW | 91
public static final short | ST_BENTCONNECTOR2 | 33
public static final short | ST_BENTCONNECTOR3 | 34
public static final short | ST_BENTCONNECTOR4 | 35
public static final short | ST_BENTCONNECTOR5 | 36
public static final short | ST_BENTUPARROW | 90
public static final short | ST_BEVEL | 84
public static final short | ST_BLOCKARC | 95
public static final short | ST_BORDERCALLOUT1 | 47
public static final short | ST_BORDERCALLOUT2 | 48
public static final short | ST_BORDERCALLOUT3 | 49
public static final short | ST_BORDERCALLOUT90 | 180
public static final short | ST_BRACEPAIR | 186
public static final short | ST_BRACKETPAIR | 185
public static final short | ST_CALLOUT1 | 41
public static final short | ST_CALLOUT2 | 42
public static final short | ST_CALLOUT3 | 43
public static final short | ST_CALLOUT90 | 178
public static final short | ST_CAN | 22
public static final short | ST_CHEVRON | 55
public static final short | ST_CIRCULARARROW | 99
public static final short | ST_CLOUDCALLOUT | 106
public static final short | ST_CUBE | 16
public static final short | ST_CURVEDCONNECTOR2 | 37
public static final short | ST_CURVEDCONNECTOR3 | 38
public static final short | ST_CURVEDCONNECTOR4 | 39
public static final short | ST_CURVEDCONNECTOR5 | 40
public static final short | ST_CURVEDDOWNARROW | 105
public static final short | ST_CURVEDLEFTARROW | 103
public static final short | ST_CURVEDRIGHTARROW | 102
public static final short | ST_CURVEDUPARROW | 104
public static final short | ST_DIAMOND | 4
public static final short | ST_DONUT | 23
public static final short | ST_DOUBLEWAVE | 188
public static final short | ST_DOWNARROW | 67
public static final short | ST_DOWNARROWCALLOUT | 80
public static final short | ST_ELLIPSE | 3
public static final short | ST_ELLIPSERIBBON | 107
public static final short | ST_ELLIPSERIBBON2 | 108
public static final short | ST_FLOWCHARTALTERNATEPROCESS | 176
public static final short | ST_FLOWCHARTCOLLATE | 125
public static final short | ST_FLOWCHARTCONNECTOR | 120
public static final short | ST_FLOWCHARTDECISION | 110
public static final short | ST_FLOWCHARTDELAY | 135
public static final short | ST_FLOWCHARTDISPLAY | 134
public static final short | ST_FLOWCHARTDOCUMENT | 114
public static final short | ST_FLOWCHARTEXTRACT | 127
public static final short | ST_FLOWCHARTINPUTOUTPUT | 111
public static final short | ST_FLOWCHARTINTERNALSTORAGE | 113
public static final short | ST_FLOWCHARTMAGNETICDISK | 132
public static final short | ST_FLOWCHARTMAGNETICDRUM | 133
public static final short | ST_FLOWCHARTMAGNETICTAPE | 131
public static final short | ST_FLOWCHARTMANUALINPUT | 118
public static final short | ST_FLOWCHARTMANUALOPERATION | 119
public static final short | ST_FLOWCHARTMERGE | 128
public static final short | ST_FLOWCHARTMULTIDOCUMENT | 115
public static final short | ST_FLOWCHARTOFFLINESTORAGE | 129
public static final short | ST_FLOWCHARTOFFPAGECONNECTOR | 177
public static final short | ST_FLOWCHARTONLINESTORAGE | 130
public static final short | ST_FLOWCHARTOR | 124
public static final short | ST_FLOWCHARTPREDEFINEDPROCESS | 112
public static final short | ST_FLOWCHARTPREPARATION | 117
public static final short | ST_FLOWCHARTPROCESS | 109
public static final short | ST_FLOWCHARTPUNCHEDCARD | 121
public static final short | ST_FLOWCHARTPUNCHEDTAPE | 122
public static final short | ST_FLOWCHARTSORT | 126
public static final short | ST_FLOWCHARTSUMMINGJUNCTION | 123
public static final short | ST_FLOWCHARTTERMINATOR | 116
public static final short | ST_FOLDEDCORNER | 65
public static final short | ST_HEART | 74
public static final short | ST_HEXAGON | 9
public static final short | ST_HOMEPLATE | 15
public static final short | ST_HORIZONTALSCROLL | 98
public static final short | ST_HOSTCONTROL | 201
public static final short | ST_IRREGULARSEAL1 | 71
public static final short | ST_IRREGULARSEAL2 | 72
public static final short | ST_ISOCELESTRIANGLE | 5
public static final short | ST_LEFTARROW | 66
public static final short | ST_LEFTARROWCALLOUT | 77
public static final short | ST_LEFTBRACE | 87
public static final short | ST_LEFTBRACKET | 85
public static final short | ST_LEFTRIGHTARROW | 69
public static final short | ST_LEFTRIGHTARROWCALLOUT | 81
public static final short | ST_LEFTRIGHTUPARROW | 182
public static final short | ST_LEFTUPARROW | 89
public static final short | ST_LIGHTNINGBOLT | 73
public static final short | ST_LINE | 20
public static final short | ST_MIN | 0
public static final short | ST_MOON | 184
public static final short | ST_NIL | 4095
public static final short | ST_NOSMOKING | 57
public static final short | ST_NOT_PRIMATIVE | 0
public static final short | ST_NOTCHEDCIRCULARARROW | 100
public static final short | ST_NOTCHEDRIGHTARROW | 94
public static final short | ST_OCTAGON | 10
public static final short | ST_PARALLELOGRAM | 7
public static final short | ST_PENTAGON | 56
public static final short | ST_PICTUREFRAME | 75
public static final short | ST_PLAQUE | 21
public static final short | ST_PLUS | 11
public static final short | ST_QUADARROW | 76
public static final short | ST_QUADARROWCALLOUT | 83
public static final short | ST_RECTANGLE | 1
public static final short | ST_RIBBON | 53
public static final short | ST_RIBBON2 | 54
public static final short | ST_RIGHTARROWCALLOUT | 78
public static final short | ST_RIGHTBRACE | 88
public static final short | ST_RIGHTBRACKET | 86
public static final short | ST_RIGHTTRIANGLE | 6
public static final short | ST_ROUNDRECTANGLE | 2
public static final short | ST_SEAL | 18
public static final short | ST_SEAL16 | 59
public static final short | ST_SEAL24 | 92
public static final short | ST_SEAL32 | 60
public static final short | ST_SEAL4 | 187
public static final short | ST_SEAL8 | 58
public static final short | ST_SMILEYFACE | 96
public static final short | ST_STAR | 12
public static final short | ST_STRAIGHTCONNECTOR1 | 32
public static final short | ST_STRIPEDRIGHTARROW | 93
public static final short | ST_SUN | 183
public static final short | ST_TEXTARCHDOWNCURVE | 145
public static final short | ST_TEXTARCHDOWNPOUR | 149
public static final short | ST_TEXTARCHUPCURVE | 144
public static final short | ST_TEXTARCHUPPOUR | 148
public static final short | ST_TEXTBOX | 202
public static final short | ST_TEXTBUTTONCURVE | 147
public static final short | ST_TEXTBUTTONPOUR | 151
public static final short | ST_TEXTCANDOWN | 175
public static final short | ST_TEXTCANUP | 174
public static final short | ST_TEXTCASCADEDOWN | 155
public static final short | ST_TEXTCASCADEUP | 154
public static final short | ST_TEXTCHEVRON | 140
public static final short | ST_TEXTCHEVRONINVERTED | 141
public static final short | ST_TEXTCIRCLECURVE | 146
public static final short | ST_TEXTCIRCLEPOUR | 150
public static final short | ST_TEXTCURVE | 27
public static final short | ST_TEXTCURVEDOWN | 153
public static final short | ST_TEXTCURVEUP | 152
public static final short | ST_TEXTDEFLATE | 161
public static final short | ST_TEXTDEFLATEBOTTOM | 163
public static final short | ST_TEXTDEFLATEINFLATE | 166
public static final short | ST_TEXTDEFLATEINFLATEDEFLATE | 167
public static final short | ST_TEXTDEFLATETOP | 165
public static final short | ST_TEXTFADEDOWN | 171
public static final short | ST_TEXTFADELEFT | 169
public static final short | ST_TEXTFADERIGHT | 168
public static final short | ST_TEXTFADEUP | 170
public static final short | ST_TEXTHEXAGON | 26
public static final short | ST_TEXTINFLATE | 160
public static final short | ST_TEXTINFLATEBOTTOM | 162
public static final short | ST_TEXTINFLATETOP | 164
public static final short | ST_TEXTOCTAGON | 25
public static final short | ST_TEXTONCURVE | 30
public static final short | ST_TEXTONRING | 31
public static final short | ST_TEXTPLAINTEXT | 136
public static final short | ST_TEXTRING | 29
public static final short | ST_TEXTRINGINSIDE | 142
public static final short | ST_TEXTRINGOUTSIDE | 143
public static final short | ST_TEXTSIMPLE | 24
public static final short | ST_TEXTSLANTDOWN | 173
public static final short | ST_TEXTSLANTUP | 172
public static final short | ST_TEXTSTOP | 137
public static final short | ST_TEXTTRIANGLE | 138
public static final short | ST_TEXTTRIANGLEINVERTED | 139
public static final short | ST_TEXTWAVE | 28
public static final short | ST_TEXTWAVE1 | 156
public static final short | ST_TEXTWAVE2 | 157
public static final short | ST_TEXTWAVE3 | 158
public static final short | ST_TEXTWAVE4 | 159
public static final short | ST_THICKARROW | 14
public static final short | ST_TRAPEZOID | 8
public static final short | ST_UPARROW | 68
public static final short | ST_UPARROWCALLOUT | 79
public static final short | ST_UPDOWNARROW | 70
public static final short | ST_UPDOWNARROWCALLOUT | 82
public static final short | ST_UTURNARROW | 101
public static final short | ST_VERTICALSCROLL | 97
public static final short | ST_WAVE | 64
public static final short | ST_WEDGEELLIPSECALLOUT | 63
public static final short | ST_WEDGERECTCALLOUT | 61
public static final short | ST_WEDGERRECTCALLOUT | 62

org.apache.poi.hssf.record.ExtendedFormatRecord
public static final short | ALT_BARS | 3
public static final short | BIG_SPOTS | 9
public static final short | BRICKS | 10
public static final short | CENTER | 2
public static final short | CENTER_SELECTION | 6
public static final short | DASH_DOT | 9
public static final short | DASH_DOT_DOT | 11
public static final short | DASHED | 3
public static final short | DIAMONDS | 16
public static final short | DOTTED | 4
public static final short | DOUBLE | 6
public static final short | FILL | 4
public static final short | FINE_DOTS | 2
public static final short | GENERAL | 0
public static final short | HAIR | 7
public static final short | JUSTIFY | 5
public static final short | LEFT | 1
public static final short | MEDIUM | 2
public static final short | MEDIUM_DASH_DOT | 10
public static final short | MEDIUM_DASH_DOT_DOT | 12
public static final short | MEDIUM_DASHED | 8
public static final short | NO_FILL | 0
public static final short | NONE | 0
public static final short | NULL | -16
public static final short | RIGHT | 3
public static final short | sid | 224
public static final short | SLANTED_DASH_DOT | 13
public static final short | SOLID_FILL | 1
public static final short | SPARSE_DOTS | 4
public static final short | SQUARES | 15
public static final short | THICK | 5
public static final short | THICK_BACKWARD_DIAG | 7
public static final short | THICK_FORWARD_DIAG | 8
public static final short | THICK_HORZ_BANDS | 5
public static final short | THICK_VERT_BANDS | 6
public static final short | THIN | 1
public static final short | THIN_BACKWARD_DIAG | 13
public static final short | THIN_FORWARD_DIAG | 14
public static final short | THIN_HORZ_BANDS | 11
public static final short | THIN_VERT_BANDS | 12
public static final short | VERTICAL_BOTTOM | 2
public static final short | VERTICAL_CENTER | 1
public static final short | VERTICAL_JUSTIFY | 3
public static final short | VERTICAL_TOP | 0
public static final short | XF_CELL | 0
public static final short | XF_STYLE | 1

org.apache.poi.hssf.record.ExternalNameRecord
public static final short sid 35

org.apache.poi.hssf.record.ExternSheetRecord
public static final short sid 23

org.apache.poi.hssf.record.ExtSSTRecord
public static final int | DEFAULT_BUCKET_SIZE | 8
public static final int | MAX_BUCKETS | 128
public static final short | sid | 255

org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord
public static final int ENCODED_SIZE 8

org.apache.poi.hssf.record.FeatHdrRecord
public static final int | SHAREDFEATURES_ISFFACTOID | 4
public static final int | SHAREDFEATURES_ISFFEC2 | 3
public static final int | SHAREDFEATURES_ISFLIST | 5
public static final int | SHAREDFEATURES_ISFPROTECTION | 2
public static final short | sid | 2151

org.apache.poi.hssf.record.FeatRecord
public static final short sid 2152

org.apache.poi.hssf.record.FilePassRecord
public static final short sid 47

org.apache.poi.hssf.record.FileSharingRecord
public static final short sid 91

org.apache.poi.hssf.record.FnGroupCountRecord
public static final short | COUNT | 14
public static final short | sid | 156

org.apache.poi.hssf.record.FontRecord
public static final short | sid | 49
public static final short | SS_NONE | 0
public static final short | SS_SUB | 2
public static final short | SS_SUPER | 1
public static final byte | U_DOUBLE | 2
public static final byte | U_DOUBLE_ACCOUNTING | 34
public static final byte | U_NONE | 0
public static final byte | U_SINGLE | 1
public static final byte | U_SINGLE_ACCOUNTING | 33

org.apache.poi.hssf.record.FooterRecord
public static final short sid 21

org.apache.poi.hssf.record.FormatRecord
public static final short sid 1054

org.apache.poi.hssf.record.FormulaRecord
public static final short sid 6

org.apache.poi.hssf.record.FtCblsSubRecord
public static final short sid 12

org.apache.poi.hssf.record.GridsetRecord
public static final short sid 130

org.apache.poi.hssf.record.GroupMarkerSubRecord
public static final short sid 6

org.apache.poi.hssf.record.GutsRecord
public static final short sid 128

org.apache.poi.hssf.record.HCenterRecord
public static final short sid 131

org.apache.poi.hssf.record.HeaderFooterRecord
public static final short sid 2204

org.apache.poi.hssf.record.HeaderRecord
public static final short sid 20

org.apache.poi.hssf.record.HideObjRecord
public static final short | HIDE_ALL | 2
public static final short | SHOW_ALL | 0
public static final short | SHOW_PLACEHOLDERS | 1
public static final short | sid | 141

org.apache.poi.hssf.record.HorizontalPageBreakRecord
public static final short sid 27

org.apache.poi.hssf.record.HyperlinkRecord
public static final short sid 440

org.apache.poi.hssf.record.IndexRecord
public static final short sid 523

org.apache.poi.hssf.record.InterfaceEndRecord
public static final short sid 226

org.apache.poi.hssf.record.InterfaceHdrRecord
public static final int | CODEPAGE | 1200
public static final short | sid | 225

org.apache.poi.hssf.record.IterationRecord
public static final short sid 17

org.apache.poi.hssf.record.LabelRecord
public static final short sid 516

org.apache.poi.hssf.record.LabelSSTRecord
public static final short sid 253

org.apache.poi.hssf.record.LbsDataSubRecord
public static final int sid 19

org.apache.poi.hssf.record.LeftMarginRecord
public static final short sid 38

org.apache.poi.hssf.record.MergeCellsRecord
public static final short sid 229

org.apache.poi.hssf.record.MMSRecord
public static final short sid 193

org.apache.poi.hssf.record.MulBlankRecord
public static final short sid 190

org.apache.poi.hssf.record.MulRKRecord
public static final short sid 189

org.apache.poi.hssf.record.NameCommentRecord
public static final short sid 2196

org.apache.poi.hssf.record.NameRecord
public static final byte | BUILTIN_AUTO_ACTIVATE | 10
public static final byte | BUILTIN_AUTO_CLOSE | 3
public static final byte | BUILTIN_AUTO_DEACTIVATE | 11
public static final byte | BUILTIN_AUTO_OPEN | 2
public static final byte | BUILTIN_CONSOLIDATE_AREA | 1
public static final byte | BUILTIN_CRITERIA | 5
public static final byte | BUILTIN_DATA_FORM | 9
public static final byte | BUILTIN_DATABASE | 4
public static final byte | BUILTIN_FILTER_DB | 13
public static final byte | BUILTIN_PRINT_AREA | 6
public static final byte | BUILTIN_PRINT_TITLE | 7
public static final byte | BUILTIN_RECORDER | 8
public static final byte | BUILTIN_SHEET_TITLE | 12
public static final short | sid | 24

org.apache.poi.hssf.record.NoteRecord
public static final short | NOTE_HIDDEN | 0
public static final short | NOTE_VISIBLE | 2
public static final short | sid | 28

org.apache.poi.hssf.record.NoteStructureSubRecord
public static final short sid 13

org.apache.poi.hssf.record.NumberRecord
public static final short sid 515

org.apache.poi.hssf.record.ObjectProtectRecord
public static final short sid 99

org.apache.poi.hssf.record.ObjRecord
public static final short sid 93

org.apache.poi.hssf.record.PageBreakRecord.Break
public static final int ENCODED_SIZE 6

org.apache.poi.hssf.record.PaletteRecord
public static final short | FIRST_COLOR_INDEX | 8
public static final short | sid | 146
public static final byte | STANDARD_PALETTE_SIZE | 56

org.apache.poi.hssf.record.PaneRecord
public static final short | ACTIVE_PANE_LOWER_LEFT | 2
public static final short | ACTIVE_PANE_LOWER_RIGHT | 0
public static final short | ACTIVE_PANE_UPER_LEFT | 3
public static final short | ACTIVE_PANE_UPPER_LEFT | 3
public static final short | ACTIVE_PANE_UPPER_RIGHT | 1
public static final short | sid | 65

org.apache.poi.hssf.record.PasswordRecord
public static final short sid 19

org.apache.poi.hssf.record.PasswordRev4Record
public static final short sid 444

org.apache.poi.hssf.record.PrecisionRecord
public static final short sid 14

org.apache.poi.hssf.record.PrintGridlinesRecord
public static final short sid 43

org.apache.poi.hssf.record.PrintHeadersRecord
public static final short sid 42

org.apache.poi.hssf.record.PrintSetupRecord
public static final short sid 161

org.apache.poi.hssf.record.ProtectionRev4Record
public static final short sid 431

org.apache.poi.hssf.record.ProtectRecord
public static final short sid 18

org.apache.poi.hssf.record.RecalcIdRecord
public static final short sid 449

org.apache.poi.hssf.record.RecordInputStream
public static final short MAX_RECORD_DATA_SIZE 8224

org.apache.poi.hssf.record.RefModeRecord
public static final short | sid | 15
public static final short | USE_A1_MODE | 1
public static final short | USE_R1C1_MODE | 0

org.apache.poi.hssf.record.RefreshAllRecord
public static final short sid 439

org.apache.poi.hssf.record.RightMarginRecord
public static final short sid 39

org.apache.poi.hssf.record.RKRecord
public static final short | RK_IEEE_NUMBER | 0
public static final short | RK_IEEE_NUMBER_TIMES_100 | 1
public static final short | RK_INTEGER | 2
public static final short | RK_INTEGER_TIMES_100 | 3
public static final short | sid | 638

org.apache.poi.hssf.record.RowRecord
public static final int | ENCODED_SIZE | 20
public static final short | sid | 520

org.apache.poi.hssf.record.SaveRecalcRecord
public static final short sid 95

org.apache.poi.hssf.record.ScenarioProtectRecord
public static final short sid 221

org.apache.poi.hssf.record.SCLRecord
public static final short sid 160

org.apache.poi.hssf.record.SelectionRecord
public static final short sid 29

org.apache.poi.hssf.record.SharedFormulaRecord
public static final short sid 1212

org.apache.poi.hssf.record.SSTRecord
public static final short sid 252

org.apache.poi.hssf.record.StringRecord
public static final short sid 519

org.apache.poi.hssf.record.StyleRecord
public static final short sid 659

org.apache.poi.hssf.record.SupBookRecord
protected static final char | CH_ALT_STARTUP_DIR | 7
protected static final char | CH_DOWN_DIR | 3
protected static final char | CH_LIB_DIR | 8
protected static final char | CH_LONG_VOLUME | 5
protected static final char | CH_SAME_VOLUME | 2
protected static final char | CH_STARTUP_DIR | 6
protected static final char | CH_UP_DIR | 4
protected static final char | CH_VOLUME | 1
public static final short | sid | 430

org.apache.poi.hssf.record.TabIdRecord
public static final short sid 317

org.apache.poi.hssf.record.TableRecord
public static final short sid 566

org.apache.poi.hssf.record.TableStylesRecord
public static final short sid 2190

org.apache.poi.hssf.record.TextObjectRecord
public static final short | HORIZONTAL_TEXT_ALIGNMENT_CENTERED | 2
public static final short | HORIZONTAL_TEXT_ALIGNMENT_JUSTIFIED | 4
public static final short | HORIZONTAL_TEXT_ALIGNMENT_LEFT_ALIGNED | 1
public static final short | HORIZONTAL_TEXT_ALIGNMENT_RIGHT_ALIGNED | 3
public static final short | sid | 438
public static final short | TEXT_ORIENTATION_NONE | 0
public static final short | TEXT_ORIENTATION_ROT_LEFT | 3
public static final short | TEXT_ORIENTATION_ROT_RIGHT | 2
public static final short | TEXT_ORIENTATION_TOP_TO_BOTTOM | 1
public static final short | VERTICAL_TEXT_ALIGNMENT_BOTTOM | 3
public static final short | VERTICAL_TEXT_ALIGNMENT_CENTER | 2
public static final short | VERTICAL_TEXT_ALIGNMENT_JUSTIFY | 4
public static final short | VERTICAL_TEXT_ALIGNMENT_TOP | 1

org.apache.poi.hssf.record.TopMarginRecord
public static final short sid 40

org.apache.poi.hssf.record.UncalcedRecord
public static final short sid 94

org.apache.poi.hssf.record.UnknownRecord
public static final int | BITMAP_00E9 | 233
public static final int | CODENAME_1BA | 442
public static final int | HEADER_FOOTER_089C | 2204
public static final int | LABELRANGES_015F | 351
public static final int | PHONETICPR_00EF | 239
public static final int | PLS_004D | 77
public static final int | PRINTSIZE_0033 | 51
public static final int | QUICKTIP_0800 | 2048
public static final int | SCL_00A0 | 160
public static final int | SHEETEXT_0862 | 2146
public static final int | SHEETPR_0081 | 129
public static final int | SHEETPROTECTION_0867 | 2151
public static final int | SORT_0090 | 144
public static final int | STANDARDWIDTH_0099 | 153

org.apache.poi.hssf.record.UserSViewBegin
public static final short sid 426

org.apache.poi.hssf.record.UserSViewEnd
public static final short sid 427

org.apache.poi.hssf.record.UseSelFSRecord
public static final short sid 352

org.apache.poi.hssf.record.VCenterRecord
public static final short sid 132

org.apache.poi.hssf.record.VerticalPageBreakRecord
public static final short sid 26

org.apache.poi.hssf.record.WindowOneRecord
public static final short sid 61

org.apache.poi.hssf.record.WindowProtectRecord
public static final short sid 25

org.apache.poi.hssf.record.WindowTwoRecord
public static final short sid 574

org.apache.poi.hssf.record.WriteAccessRecord
public static final short sid 92

org.apache.poi.hssf.record.WriteProtectRecord
public static final short sid 134

org.apache.poi.hssf.record.WSBoolRecord
public static final short sid 129

org.apache.poi.hssf.record.cf.BorderFormatting
public static final short | BORDER_DASH_DOT | 9
public static final short | BORDER_DASH_DOT_DOT | 11
public static final short | BORDER_DASHED | 3
public static final short | BORDER_DOTTED | 7
public static final short | BORDER_DOUBLE | 6
public static final short | BORDER_HAIR | 4
public static final short | BORDER_MEDIUM | 2
public static final short | BORDER_MEDIUM_DASH_DOT | 10
public static final short | BORDER_MEDIUM_DASH_DOT_DOT | 12
public static final short | BORDER_MEDIUM_DASHED | 8
public static final short | BORDER_NONE | 0
public static final short | BORDER_SLANTED_DASH_DOT | 13
public static final short | BORDER_THICK | 5
public static final short | BORDER_THIN | 1

org.apache.poi.hssf.record.cf.CellRangeUtil
public static final int | ENCLOSES | 4
public static final int | INSIDE | 3
public static final int | NO_INTERSECTION | 1
public static final int | OVERLAP | 2

org.apache.poi.hssf.record.cf.FontFormatting
public static final int | FONT_CELL_HEIGHT_PRESERVED | -1
public static final short | SS_NONE | 0
public static final short | SS_SUB | 2
public static final short | SS_SUPER | 1
public static final byte | U_DOUBLE | 2
public static final byte | U_DOUBLE_ACCOUNTING | 34
public static final byte | U_NONE | 0
public static final byte | U_SINGLE | 1
public static final byte | U_SINGLE_ACCOUNTING | 33

org.apache.poi.hssf.record.cf.PatternFormatting
public static final short | ALT_BARS | 3
public static final short | BIG_SPOTS | 9
public static final short | BRICKS | 10
public static final short | DIAMONDS | 16
public static final short | FINE_DOTS | 2
public static final short | LEAST_DOTS | 18
public static final short | LESS_DOTS | 17
public static final short | NO_FILL | 0
public static final short | SOLID_FOREGROUND | 1
public static final short | SPARSE_DOTS | 4
public static final short | SQUARES | 15
public static final short | THICK_BACKWARD_DIAG | 7
public static final short | THICK_FORWARD_DIAG | 8
public static final short | THICK_HORZ_BANDS | 5
public static final short | THICK_VERT_BANDS | 6
public static final short | THIN_BACKWARD_DIAG | 13
public static final short | THIN_FORWARD_DIAG | 14
public static final short | THIN_HORZ_BANDS | 11
public static final short | THIN_VERT_BANDS | 12

org.apache.poi.hssf.record.chart.AreaFormatRecord
public static final short sid 4106

org.apache.poi.hssf.record.chart.AreaRecord
public static final short sid 4122

org.apache.poi.hssf.record.chart.AxisLineFormatRecord
public static final short | AXIS_TYPE_AXIS_LINE | 0
public static final short | AXIS_TYPE_MAJOR_GRID_LINE | 1
public static final short | AXIS_TYPE_MINOR_GRID_LINE | 2
public static final short | AXIS_TYPE_WALLS_OR_FLOOR | 3
public static final short | sid | 4129

org.apache.poi.hssf.record.chart.AxisOptionsRecord
public static final short sid 4194

org.apache.poi.hssf.record.chart.AxisParentRecord
public static final short | AXIS_TYPE_MAIN | 0
public static final short | AXIS_TYPE_SECONDARY | 1
public static final short | sid | 4161

org.apache.poi.hssf.record.chart.AxisRecord
public static final short | AXIS_TYPE_CATEGORY_OR_X_AXIS | 0
public static final short | AXIS_TYPE_SERIES_AXIS | 2
public static final short | AXIS_TYPE_VALUE_AXIS | 1
public static final short | sid | 4125

org.apache.poi.hssf.record.chart.AxisUsedRecord
public static final short sid 4166

org.apache.poi.hssf.record.chart.BarRecord
public static final short sid 4119

org.apache.poi.hssf.record.chart.BeginRecord
public static final short sid 4147

org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
public static final short sid 4128

org.apache.poi.hssf.record.chart.CatLabRecord
public static final short sid 2134

org.apache.poi.hssf.record.chart.ChartEndBlockRecord
public static final short sid 2131

org.apache.poi.hssf.record.chart.ChartEndObjectRecord
public static final short sid 2133

org.apache.poi.hssf.record.chart.ChartFormatRecord
public static final short sid 4116

org.apache.poi.hssf.record.chart.ChartFRTInfoRecord
public static final short sid 2128

org.apache.poi.hssf.record.chart.ChartRecord
public static final short sid 4098

org.apache.poi.hssf.record.chart.ChartStartBlockRecord
public static final short sid 2130

org.apache.poi.hssf.record.chart.ChartStartObjectRecord
public static final short sid 2132

org.apache.poi.hssf.record.chart.ChartTitleFormatRecord
public static final short sid 4176

org.apache.poi.hssf.record.chart.DataFormatRecord
public static final short sid 4102

org.apache.poi.hssf.record.chart.DataLabelExtensionRecord
public static final short sid 2154

org.apache.poi.hssf.record.chart.DatRecord
public static final short sid 4195

org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord
public static final short | CATEGORY_DATA_TYPE_ALL_TEXT_CHARACTERISTIC | 2
public static final short | CATEGORY_DATA_TYPE_SHOW_LABELS_CHARACTERISTIC | 0
public static final short | CATEGORY_DATA_TYPE_VALUE_AND_PERCENTAGE_CHARACTERISTIC | 1
public static final short | sid | 4132

org.apache.poi.hssf.record.chart.EndRecord
public static final short sid 4148

org.apache.poi.hssf.record.chart.FontBasisRecord
public static final short sid 4192

org.apache.poi.hssf.record.chart.FontIndexRecord
public static final short sid 4134

org.apache.poi.hssf.record.chart.FrameRecord
public static final short | BORDER_TYPE_REGULAR | 0
public static final short | BORDER_TYPE_SHADOW | 1
public static final short | sid | 4146

org.apache.poi.hssf.record.chart.LegendRecord
public static final short | sid | 4117
public static final byte | SPACING_CLOSE | 0
public static final byte | SPACING_MEDIUM | 1
public static final byte | SPACING_OPEN | 2
public static final byte | TYPE_BOTTOM | 0
public static final byte | TYPE_CORNER | 1
public static final byte | TYPE_LEFT | 4
public static final byte | TYPE_RIGHT | 3
public static final byte | TYPE_TOP | 2
public static final byte | TYPE_UNDOCKED | 7

org.apache.poi.hssf.record.chart.LineFormatRecord
public static final short | LINE_PATTERN_DARK_GRAY_PATTERN | 6
public static final short | LINE_PATTERN_DASH | 1
public static final short | LINE_PATTERN_DASH_DOT | 3
public static final short | LINE_PATTERN_DASH_DOT_DOT | 4
public static final short | LINE_PATTERN_DOT | 2
public static final short | LINE_PATTERN_LIGHT_GRAY_PATTERN | 8
public static final short | LINE_PATTERN_MEDIUM_GRAY_PATTERN | 7
public static final short | LINE_PATTERN_NONE | 5
public static final short | LINE_PATTERN_SOLID | 0
public static final short | sid | 4103
public static final short | WEIGHT_HAIRLINE | -1
public static final short | WEIGHT_MEDIUM | 1
public static final short | WEIGHT_NARROW | 0
public static final short | WEIGHT_WIDE | 2

org.apache.poi.hssf.record.chart.LinkedDataRecord
public static final byte | LINK_TYPE_CATEGORIES | 2
public static final byte | LINK_TYPE_TITLE_OR_TEXT | 0
public static final byte | LINK_TYPE_VALUES | 1
public static final byte | REFERENCE_TYPE_DEFAULT_CATEGORIES | 0
public static final byte | REFERENCE_TYPE_DIRECT | 1
public static final byte | REFERENCE_TYPE_ERROR_REPORTED | 4
public static final byte | REFERENCE_TYPE_NOT_USED | 3
public static final byte | REFERENCE_TYPE_WORKSHEET | 2
public static final short | sid | 4177

org.apache.poi.hssf.record.chart.NumberFormatIndexRecord
public static final short sid 4174

org.apache.poi.hssf.record.chart.ObjectLinkRecord
public static final short | ANCHOR_ID_CHART_TITLE | 1
public static final short | ANCHOR_ID_SERIES_OR_POINT | 4
public static final short | ANCHOR_ID_X_AXIS | 3
public static final short | ANCHOR_ID_Y_AXIS | 2
public static final short | ANCHOR_ID_Z_AXIS | 7
public static final short | sid | 4135

org.apache.poi.hssf.record.chart.PlotAreaRecord
public static final short sid 4149

org.apache.poi.hssf.record.chart.PlotGrowthRecord
public static final short sid 4196

org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord
public static final short sid 4165

org.apache.poi.hssf.record.chart.SeriesIndexRecord
public static final short sid 4197

org.apache.poi.hssf.record.chart.SeriesLabelsRecord
public static final short sid 4108

org.apache.poi.hssf.record.chart.SeriesListRecord
public static final short sid 4118

org.apache.poi.hssf.record.chart.SeriesRecord
public static final short | BUBBLE_SERIES_TYPE_DATES | 0
public static final short | BUBBLE_SERIES_TYPE_NUMERIC | 1
public static final short | BUBBLE_SERIES_TYPE_SEQUENCE | 2
public static final short | BUBBLE_SERIES_TYPE_TEXT | 3
public static final short | CATEGORY_DATA_TYPE_DATES | 0
public static final short | CATEGORY_DATA_TYPE_NUMERIC | 1
public static final short | CATEGORY_DATA_TYPE_SEQUENCE | 2
public static final short | CATEGORY_DATA_TYPE_TEXT | 3
public static final short | sid | 4099
public static final short | VALUES_DATA_TYPE_DATES | 0
public static final short | VALUES_DATA_TYPE_NUMERIC | 1
public static final short | VALUES_DATA_TYPE_SEQUENCE | 2
public static final short | VALUES_DATA_TYPE_TEXT | 3

org.apache.poi.hssf.record.chart.SeriesTextRecord
public static final short sid 4109

org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord
public static final short sid 4165

org.apache.poi.hssf.record.chart.SheetPropertiesRecord
public static final byte | EMPTY_INTERPOLATED | 2
public static final byte | EMPTY_NOT_PLOTTED | 0
public static final byte | EMPTY_ZERO | 1
public static final short | sid | 4164

org.apache.poi.hssf.record.chart.TextRecord
public static final short | DATA_LABEL_PLACEMENT_ABOVE | 5
public static final short | DATA_LABEL_PLACEMENT_AUTO | 9
public static final short | DATA_LABEL_PLACEMENT_AXIS | 4
public static final short | DATA_LABEL_PLACEMENT_BELOW | 6
public static final short | DATA_LABEL_PLACEMENT_CENTER | 3
public static final short | DATA_LABEL_PLACEMENT_CHART_DEPENDENT | 0
public static final short | DATA_LABEL_PLACEMENT_INSIDE | 2
public static final short | DATA_LABEL_PLACEMENT_LEFT | 7
public static final short | DATA_LABEL_PLACEMENT_OUTSIDE | 1
public static final short | DATA_LABEL_PLACEMENT_RIGHT | 8
public static final short | DATA_LABEL_PLACEMENT_USER_MOVED | 10
public static final short | DISPLAY_MODE_OPAQUE | 2
public static final short | DISPLAY_MODE_TRANSPARENT | 1
public static final byte | HORIZONTAL_ALIGNMENT_BOTTOM | 3
public static final byte | HORIZONTAL_ALIGNMENT_CENTER | 2
public static final byte | HORIZONTAL_ALIGNMENT_JUSTIFY | 4
public static final byte | HORIZONTAL_ALIGNMENT_LEFT | 1
public static final short | ROTATION_NONE | 0
public static final short | ROTATION_ROTATED_90_DEGREES | 2
public static final short | ROTATION_ROTATED_90_DEGREES_CLOCKWISE | 3
public static final short | ROTATION_TOP_TO_BOTTOM | 1
public static final short | sid | 4133
public static final byte | VERTICAL_ALIGNMENT_BOTTOM | 3
public static final byte | VERTICAL_ALIGNMENT_CENTER | 2
public static final byte | VERTICAL_ALIGNMENT_JUSTIFY | 4
public static final byte | VERTICAL_ALIGNMENT_TOP | 1

org.apache.poi.hssf.record.chart.TickRecord
public static final short sid 4126

org.apache.poi.hssf.record.chart.UnitsRecord
public static final short sid 4097

org.apache.poi.hssf.record.chart.ValueRangeRecord
public static final short sid 4127

org.apache.poi.hssf.record.pivottable.DataItemRecord
public static final short sid 197

org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord
public static final short sid 256

org.apache.poi.hssf.record.pivottable.PageItemRecord
public static final short sid 182

org.apache.poi.hssf.record.pivottable.StreamIDRecord
public static final short sid 213

org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord
public static final short sid 176

org.apache.poi.hssf.record.pivottable.ViewFieldsRecord
public static final short sid 177

org.apache.poi.hssf.record.pivottable.ViewSourceRecord
public static final short sid 227

org.apache.poi.hssf.usermodel.HSSFCell
public static final short | ENCODING_COMPRESSED_UNICODE | 0
public static final short | ENCODING_UNCHANGED | -1
public static final short | ENCODING_UTF_16 | 1

org.apache.poi.hssf.usermodel.HSSFFont
public static final java.lang.String FONT_ARIAL "Arial"

org.apache.poi.hssf.usermodel.HSSFFontFormatting
public static final byte | U_DOUBLE | 2
public static final byte | U_DOUBLE_ACCOUNTING | 34
public static final byte | U_NONE | 0
public static final byte | U_SINGLE | 1
public static final byte | U_SINGLE_ACCOUNTING | 33

org.apache.poi.hssf.usermodel.HSSFHyperlink
public static final int | LINK_DOCUMENT | 2
public static final int | LINK_EMAIL | 3
public static final int | LINK_FILE | 4
public static final int | LINK_URL | 1

org.apache.poi.hssf.usermodel.HSSFPicture
public static final int | PICTURE_TYPE_DIB | 7
public static final int | PICTURE_TYPE_EMF | 2
public static final int | PICTURE_TYPE_JPEG | 5
public static final int | PICTURE_TYPE_PICT | 4
public static final int | PICTURE_TYPE_PNG | 6
public static final int | PICTURE_TYPE_WMF | 3

org.apache.poi.hssf.usermodel.HSSFPictureData
public static final short | FORMAT_MASK | -16
public static final short | MSOBI_DIB | 31360
public static final short | MSOBI_EMF | 15680
public static final short | MSOBI_JPEG | 18080
public static final short | MSOBI_PICT | 21536
public static final short | MSOBI_PNG | 28160
public static final short | MSOBI_WMF | 8544

org.apache.poi.hssf.usermodel.HSSFRichTextString
public static final short NO_FONT 0

org.apache.poi.hssf.usermodel.HSSFRow
public static final int INITIAL_CAPACITY 5

org.apache.poi.hssf.usermodel.HSSFShape
public static final int | LINESTYLE_DASHDOTDOTSYS | 4
public static final int | LINESTYLE_DASHDOTGEL | 8
public static final int | LINESTYLE_DASHDOTSYS | 3
public static final int | LINESTYLE_DASHGEL | 6
public static final int | LINESTYLE_DASHSYS | 1
public static final int | LINESTYLE_DOTGEL | 5
public static final int | LINESTYLE_DOTSYS | 2
public static final int | LINESTYLE_LONGDASHDOTDOTGEL | 10
public static final int | LINESTYLE_LONGDASHDOTGEL | 9
public static final int | LINESTYLE_LONGDASHGEL | 7
public static final int | LINESTYLE_NONE | -1
public static final int | LINESTYLE_SOLID | 0
public static final int | LINEWIDTH_DEFAULT | 9525
public static final int | LINEWIDTH_ONE_PT | 12700

org.apache.poi.hssf.usermodel.HSSFSheet
public static final int INITIAL_CAPACITY 20

org.apache.poi.hssf.usermodel.HSSFSimpleShape
public static final short | OBJECT_TYPE_COMBO_BOX | 20
public static final short | OBJECT_TYPE_COMMENT | 25
public static final short | OBJECT_TYPE_LINE | 1
public static final short | OBJECT_TYPE_OVAL | 3
public static final short | OBJECT_TYPE_PICTURE | 8
public static final short | OBJECT_TYPE_RECTANGLE | 2

org.apache.poi.hssf.usermodel.HSSFTextbox
public static final short | HORIZONTAL_ALIGNMENT_CENTERED | 2
public static final short | HORIZONTAL_ALIGNMENT_DISTRIBUTED | 7
public static final short | HORIZONTAL_ALIGNMENT_JUSTIFIED | 4
public static final short | HORIZONTAL_ALIGNMENT_LEFT | 1
public static final short | HORIZONTAL_ALIGNMENT_RIGHT | 3
public static final short | OBJECT_TYPE_TEXT | 6
public static final short | VERTICAL_ALIGNMENT_BOTTOM | 3
public static final short | VERTICAL_ALIGNMENT_CENTER | 2
public static final short | VERTICAL_ALIGNMENT_DISTRIBUTED | 7
public static final short | VERTICAL_ALIGNMENT_JUSTIFY | 4
public static final short | VERTICAL_ALIGNMENT_TOP | 1

org.apache.poi.hssf.usermodel.HSSFWorkbook
public static final int INITIAL_CAPACITY 3

org.apache.poi.hssf.util.CellRangeAddress8Bit
public static final int ENCODED_SIZE 6

org.apache.poi.hssf.util.HSSFColor.AQUA
public static final java.lang.String | hexString | "3333:CCCC:CCCC"
public static final short | index | 49

org.apache.poi.hssf.util.HSSFColor.AUTOMATIC
public static final short index 64

org.apache.poi.hssf.util.HSSFColor.BLACK
public static final java.lang.String | hexString | "0:0:0"
public static final short | index | 8

org.apache.poi.hssf.util.HSSFColor.BLUE
public static final java.lang.String | hexString | "0:0:FFFF"
public static final short | index | 12
public static final short | index2 | 39

org.apache.poi.hssf.util.HSSFColor.BLUE_GREY
public static final java.lang.String | hexString | "6666:6666:9999"
public static final short | index | 54

org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN
public static final java.lang.String | hexString | "0:FFFF:0"
public static final short | index | 11
public static final short | index2 | 35

org.apache.poi.hssf.util.HSSFColor.BROWN
public static final java.lang.String | hexString | "9999:3333:0"
public static final short | index | 60

org.apache.poi.hssf.util.HSSFColor.CORAL
public static final java.lang.String | hexString | "FFFF:8080:8080"
public static final short | index | 29

org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE
public static final java.lang.String | hexString | "9999:9999:FFFF"
public static final short | index | 24

org.apache.poi.hssf.util.HSSFColor.DARK_BLUE
public static final java.lang.String | hexString | "0:0:8080"
public static final short | index | 18
public static final short | index2 | 32

org.apache.poi.hssf.util.HSSFColor.DARK_GREEN
public static final java.lang.String | hexString | "0:3333:0"
public static final short | index | 58

org.apache.poi.hssf.util.HSSFColor.DARK_RED
public static final java.lang.String | hexString | "8080:0:0"
public static final short | index | 16
public static final short | index2 | 37

org.apache.poi.hssf.util.HSSFColor.DARK_TEAL
public static final java.lang.String | hexString | "0:3333:6666"
public static final short | index | 56

org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW
public static final java.lang.String | hexString | "8080:8080:0"
public static final short | index | 19

org.apache.poi.hssf.util.HSSFColor.GOLD
public static final java.lang.String | hexString | "FFFF:CCCC:0"
public static final short | index | 51

org.apache.poi.hssf.util.HSSFColor.GREEN
public static final java.lang.String | hexString | "0:8080:0"
public static final short | index | 17

org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT
public static final java.lang.String | hexString | "C0C0:C0C0:C0C0"
public static final short | index | 22

org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT
public static final java.lang.String | hexString | "9696:9696:9696"
public static final short | index | 55

org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT
public static final java.lang.String | hexString | "8080:8080:8080"
public static final short | index | 23

org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT
public static final java.lang.String | hexString | "3333:3333:3333"
public static final short | index | 63

org.apache.poi.hssf.util.HSSFColor.INDIGO
public static final java.lang.String | hexString | "3333:3333:9999"
public static final short | index | 62

org.apache.poi.hssf.util.HSSFColor.LAVENDER
public static final java.lang.String | hexString | "CCCC:9999:FFFF"
public static final short | index | 46

org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON
public static final java.lang.String | hexString | "FFFF:FFFF:CCCC"
public static final short | index | 26

org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE
public static final java.lang.String | hexString | "3333:6666:FFFF"
public static final short | index | 48

org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE
public static final java.lang.String | hexString | "CCCC:CCCC:FFFF"
public static final short | index | 31

org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN
public static final java.lang.String | hexString | "CCCC:FFFF:CCCC"
public static final short | index | 42

org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE
public static final java.lang.String | hexString | "FFFF:9999:0"
public static final short | index | 52

org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE
public static final java.lang.String | hexString | "CCCC:FFFF:FFFF"
public static final short | index | 41
public static final short | index2 | 27

org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW
public static final java.lang.String | hexString | "FFFF:FFFF:9999"
public static final short | index | 43

org.apache.poi.hssf.util.HSSFColor.LIME
public static final java.lang.String | hexString | "9999:CCCC:0"
public static final short | index | 50

org.apache.poi.hssf.util.HSSFColor.MAROON
public static final java.lang.String | hexString | "8000:0:0"
public static final short | index | 25

org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN
public static final java.lang.String | hexString | "3333:3333:0"
public static final short | index | 59

org.apache.poi.hssf.util.HSSFColor.ORANGE
public static final java.lang.String | hexString | "FFFF:6666:0"
public static final short | index | 53

org.apache.poi.hssf.util.HSSFColor.ORCHID
public static final java.lang.String | hexString | "6666:0:6666"
public static final short | index | 28

org.apache.poi.hssf.util.HSSFColor.PALE_BLUE
public static final java.lang.String | hexString | "9999:CCCC:FFFF"
public static final short | index | 44

org.apache.poi.hssf.util.HSSFColor.PINK
public static final java.lang.String | hexString | "FFFF:0:FFFF"
public static final short | index | 14
public static final short | index2 | 33

org.apache.poi.hssf.util.HSSFColor.PLUM
public static final java.lang.String | hexString | "9999:3333:6666"
public static final short | index | 61
public static final short | index2 | 25

org.apache.poi.hssf.util.HSSFColor.RED
public static final java.lang.String | hexString | "FFFF:0:0"
public static final short | index | 10

org.apache.poi.hssf.util.HSSFColor.ROSE
public static final java.lang.String | hexString | "FFFF:9999:CCCC"
public static final short | index | 45

org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE
public static final java.lang.String | hexString | "0:6666:CCCC"
public static final short | index | 30

org.apache.poi.hssf.util.HSSFColor.SEA_GREEN
public static final java.lang.String | hexString | "3333:9999:6666"
public static final short | index | 57

org.apache.poi.hssf.util.HSSFColor.SKY_BLUE
public static final java.lang.String | hexString | "0:CCCC:FFFF"
public static final short | index | 40

org.apache.poi.hssf.util.HSSFColor.TAN
public static final java.lang.String | hexString | "FFFF:CCCC:9999"
public static final short | index | 47

org.apache.poi.hssf.util.HSSFColor.TEAL
public static final java.lang.String | hexString | "0:8080:8080"
public static final short | index | 21
public static final short | index2 | 38

org.apache.poi.hssf.util.HSSFColor.TURQUOISE
public static final java.lang.String | hexString | "0:FFFF:FFFF"
public static final short | index | 15
public static final short | index2 | 35

org.apache.poi.hssf.util.HSSFColor.VIOLET
public static final java.lang.String | hexString | "8080:0:8080"
public static final short | index | 20
public static final short | index2 | 36

org.apache.poi.hssf.util.HSSFColor.WHITE
public static final java.lang.String | hexString | "FFFF:FFFF:FFFF"
public static final short | index | 9

org.apache.poi.hssf.util.HSSFColor.YELLOW
public static final java.lang.String | hexString | "FFFF:FFFF:0"
public static final short | index | 13
public static final short | index2 | 34

org.apache.poi.hssf.util.PaneInformation
public static final byte | PANE_LOWER_LEFT | 2
public static final byte | PANE_LOWER_RIGHT | 0
public static final byte | PANE_UPPER_LEFT | 3
public static final byte | PANE_UPPER_RIGHT | 1

org.apache.poi.hwpf.HWPFDocumentCore
protected static final java.lang.String | STREAM_OBJECT_POOL | "ObjectPool"
protected static final java.lang.String | STREAM_WORD_DOCUMENT | "WordDocument"

org.apache.poi.hwpf.converter.AbstractWordConverter
protected static final char | UNICODECHAR_NO_BREAK_SPACE | 160
protected static final char | UNICODECHAR_NONBREAKING_HYPHEN | 8209
protected static final char | UNICODECHAR_ZERO_WIDTH_SPACE | 8203

org.apache.poi.hwpf.converter.AbstractWordUtils
public static final float | TWIPS_PER_INCH | 1440.0f
public static final int | TWIPS_PER_PT | 20

org.apache.poi.hwpf.model.FIBFieldHandler
public static final int | AUTOSAVESOURCE | 35
public static final int | BKDEDN | 68
public static final int | BKDFTN | 66
public static final int | BKDMOTHER | 64
public static final int | CLX | 33
public static final int | CMDS | 24
public static final int | DGGINFO | 50
public static final int | DOCUNDO | 77
public static final int | DOP | 31
public static final int | FORMFLDSTTBS | 45
public static final int | GRPXSTATNOWNERS | 36
public static final int | MODIFIED | 87
public static final int | PGDEDN | 67
public static final int | PGDFTN | 65
public static final int | PGDMOTHER | 63
public static final int | PLCASUMY | 89
public static final int | PLCDOAHDR | 39
public static final int | PLCFANDREF | 4
public static final int | PLCFANDTXT | 5
public static final int | PLCFATNBKF | 42
public static final int | PLCFATNBKL | 43
public static final int | PLCFBKF | 22
public static final int | PLCFBKL | 23
public static final int | PLCFBTECHPX | 12
public static final int | PLCFBTELVC | 86
public static final int | PLCFBTEPAPX | 13
public static final int | PLCFDOAMOM | 38
public static final int | PLCFENDREF | 46
public static final int | PLCFENDTXT | 47
public static final int | PLCFFLDATN | 19
public static final int | PLCFFLDEDN | 48
public static final int | PLCFFLDFTN | 18
public static final int | PLCFFLDHDR | 17
public static final int | PLCFFLDHDRTXBX | 59
public static final int | PLCFFLDMCR | 20
public static final int | PLCFFLDMOM | 16
public static final int | PLCFFLDTXBX | 57
public static final int | PLCFFNDREF | 2
public static final int | PLCFFNDTXT | 3
public static final int | PLCFGLSY | 10
public static final int | PLCFGRAM | 90
public static final int | PLCFHDD | 11
public static final int | PLCFHDRTXBXTXT | 58
public static final int | PLCFLST | 73
public static final int | PLCFLVC | 88
public static final int | PLCFPAD | 7
public static final int | PLCFPGDEDN | 49
public static final int | PLCFPGDFTN | 34
public static final int | PLCFPHE | 8
public static final int | PLCFSEA | 14
public static final int | PLCFSED | 6
public static final int | PLCFSPL | 55
public static final int | PLCFTXBXBKD | 75
public static final int | PLCFTXBXHDRBKD | 76
public static final int | PLCFTXBXTXT | 56
public static final int | PLCFWKB | 54
public static final int | PLCMCR | 25
public static final int | PLCOCX | 85
public static final int | PLCSPAHDR | 41
public static final int | PLCSPAMOM | 40
public static final int | PLCUPCRGBUSE | 81
public static final int | PLCUPCUSP | 82
public static final int | PLFLFO | 74
public static final int | PLGOSL | 84
public static final int | PMS | 44
public static final int | PRDRVR | 27
public static final int | PRENVLAND | 29
public static final int | PRENVPORT | 28
public static final int | RGBUSE | 78
public static final int | ROUTESLIP | 70
public static final int | STSHF | 1
public static final int | STSHFORIG | 0
public static final int | STTBAUTOCAPTION | 53
public static final int | STTBCAPTION | 52
public static final int | STTBFASSOC | 32
public static final int | STTBFATNBKMK | 37
public static final int | STTBFBKMK | 21
public static final int | STTBFFFN | 15
public static final int | STTBFINTFLD | 69
public static final int | STTBFMCR | 26
public static final int | STTBFNM | 72
public static final int | STTBFRMARK | 51
public static final int | STTBFUSSR | 92
public static final int | STTBGLSY | 9
public static final int | STTBGLSYSTYLE | 83
public static final int | STTBLISTNAMES | 91
public static final int | STTBSAVEDBY | 71
public static final int | STTBTTMBD | 61
public static final int | STWUSER | 60
public static final int | UNUSED | 62
public static final int | USKF | 80
public static final int | USP | 79
public static final int | WSS | 30

org.apache.poi.hwpf.model.FieldDescriptor
public static final int | FIELD_BEGIN_MARK | 19
public static final int | FIELD_END_MARK | 21
public static final int | FIELD_SEPARATOR_MARK | 20

org.apache.poi.hwpf.model.FieldsTables
public static final int | PLCFFLDATN | 0
public static final int | PLCFFLDEDN | 1
public static final int | PLCFFLDFTN | 2
public static final int | PLCFFLDHDR | 3
public static final int | PLCFFLDHDRTXBX | 4
public static final int | PLCFFLDMOM | 5
public static final int | PLCFFLDTXBX | 6

org.apache.poi.hwpf.model.StyleSheet
public static final int NIL_STYLE 4095

org.apache.poi.hwpf.model.types.CHPAbstractType
protected static final byte | ISS_NONE | 0
protected static final byte | ISS_SUBSCRIPTED | 2
protected static final byte | ISS_SUPERSCRIPTED | 1
protected static final byte | KCD_CIRCLE | 3
protected static final byte | KCD_COMMA | 2
protected static final byte | KCD_DOT | 1
protected static final byte | KCD_NON | 0
protected static final byte | KCD_UNDER_DOT | 4
protected static final byte | KUL_BY_WORD | 2
protected static final byte | KUL_DASH | 7
protected static final byte | KUL_DASH_LONG | 39
protected static final byte | KUL_DASH_LONG_HEAVY | 55
protected static final byte | KUL_DASHED_HEAVY | 23
protected static final byte | KUL_DOT | 8
protected static final byte | KUL_DOT_DASH | 9
protected static final byte | KUL_DOT_DASH_HEAVY | 25
protected static final byte | KUL_DOT_DOT_DASH | 10
protected static final byte | KUL_DOT_DOT_DASH_HEAVY | 26
protected static final byte | KUL_DOTTED | 4
protected static final byte | KUL_DOTTED_HEAVY | 20
protected static final byte | KUL_DOUBLE | 3
protected static final byte | KUL_HIDDEN | 5
protected static final byte | KUL_NONE | 0
protected static final byte | KUL_SINGLE | 1
protected static final byte | KUL_THICK | 6
protected static final byte | KUL_WAVE | 11
protected static final byte | KUL_WAVE_DOUBLE | 43
protected static final byte | KUL_WAVE_HEAVY | 27
protected static final byte | LBRCRJ_BOTH | 3
protected static final byte | LBRCRJ_LEFT | 1
protected static final byte | LBRCRJ_NONE | 0
protected static final byte | LBRCRJ_RIGHT | 2
protected static final byte | SFXTTEXT_BACKGROUND_BLINK | 2
protected static final byte | SFXTTEXT_LAS_VEGAS_LIGHTS | 1
protected static final byte | SFXTTEXT_MARCHING_ANTS | 4
protected static final byte | SFXTTEXT_MARCHING_RED_ANTS | 5
protected static final byte | SFXTTEXT_NO | 0
protected static final byte | SFXTTEXT_SHIMMER | 6
protected static final byte | SFXTTEXT_SPARKLE_TEXT | 3

org.apache.poi.hwpf.model.types.HRESIAbstractType
public static final byte | HRES_ADD_LETTER_BEFORE | 2
public static final byte | HRES_CHANGE_LETTER_AFTER | 5
public static final byte | HRES_CHANGE_LETTER_BEFORE | 3
public static final byte | HRES_DELETE_BEFORE_CHANGE_BEFORE | 6
public static final byte | HRES_DELETE_LETTER_BEFORE | 4
public static final byte | HRES_NO | 0
public static final byte | HRES_NORMAL | 1

org.apache.poi.hwpf.model.types.PAPAbstractType
protected static final byte | BRCL_DOUBLE | 2
protected static final byte | BRCL_SHADOW | 3
protected static final byte | BRCL_SINGLE | 0
protected static final byte | BRCL_THICK | 1
protected static final byte | BRCP_BAR_TO_LEFT_OF_PARAGRAPH | 16
protected static final byte | BRCP_BORDER_ABOVE | 1
protected static final byte | BRCP_BORDER_BELOW | 2
protected static final byte | BRCP_BOX_AROUND | 15
protected static final byte | BRCP_NONE | 0
protected static final boolean | FMINHEIGHT_AT_LEAST | true
protected static final boolean | FMINHEIGHT_EXACT | false
protected static final byte | WALIGNFONT_AUTO | 4
protected static final byte | WALIGNFONT_CENTERED | 1
protected static final byte | WALIGNFONT_HANGING | 0
protected static final byte | WALIGNFONT_ROMAN | 2
protected static final byte | WALIGNFONT_VARIABLE | 3

org.apache.poi.hwpf.model.types.SEPAbstractType
public static final byte | BKC_EVEN_PAGE | 3
public static final byte | BKC_NEW_COLUMN | 1
public static final byte | BKC_NEW_PAGE | 2
public static final byte | BKC_NO_BREAK | 0
public static final byte | BKC_ODD_PAGE | 4
public static final boolean | DMORIENTPAGE_LANDSCAPE | false
public static final boolean | DMORIENTPAGE_PORTRAIT | true
public static final byte | NFCPGN_ARABIC | 0
public static final byte | NFCPGN_LETTER_LOWER_CASE | 4
public static final byte | NFCPGN_LETTER_UPPER_CASE | 3
public static final byte | NFCPGN_ROMAN_LOWER_CASE | 2
public static final byte | NFCPGN_ROMAN_UPPER_CASE | 1

org.apache.poi.hwpf.sprm.SprmOperation
public static final int | PAP_TYPE | 1
public static final int | TAP_TYPE | 5
public static final int | TYPE_CHP | 2
public static final int | TYPE_PAP | 1
public static final int | TYPE_PIC | 3
public static final int | TYPE_SEP | 4
public static final int | TYPE_TAP | 5

org.apache.poi.hwpf.usermodel.BorderCode
public static final int SIZE 4

org.apache.poi.hwpf.usermodel.CharacterProperties
public static final short | SPRM_BRC | 26725
public static final short | SPRM_CCV | 26736
public static final short | SPRM_CHARSCALE | 18514
public static final short | SPRM_CPG | 18539
public static final short | SPRM_DISPFLDRMARK | -13726
public static final short | SPRM_DTTMRMARK | 26629
public static final short | SPRM_DTTMRMARKDEL | 26724
public static final short | SPRM_DXASPACE | -30656
public static final short | SPRM_FBOLD | 2101
public static final short | SPRM_FCAPS | 2107
public static final short | SPRM_FDATA | 2054
public static final short | SPRM_FDSTRIKE | 10835
public static final short | SPRM_FELID | 18542
public static final short | SPRM_FEMBOSS | 2136
public static final short | SPRM_FFLDVANISH | 2050
public static final short | SPRM_FIMPRINT | 2132
public static final short | SPRM_FITALIC | 2102
public static final short | SPRM_FOBJ | 2134
public static final short | SPRM_FOLE2 | 2058
public static final short | SPRM_FOUTLINE | 2104
public static final short | SPRM_FRMARK | 2049
public static final short | SPRM_FRMARKDEL | 2048
public static final short | SPRM_FSHADOW | 2105
public static final short | SPRM_FSMALLCAPS | 2106
public static final short | SPRM_FSPEC | 2133
public static final short | SPRM_FSTRIKE | 2103
public static final short | SPRM_FVANISH | 2108
public static final short | SPRM_HIGHLIGHT | 10764
public static final short | SPRM_HPS | 19011
public static final short | SPRM_HPSKERN | 18507
public static final short | SPRM_HPSPOS | 18501
public static final short | SPRM_IBSTRMARK | 18436
public static final short | SPRM_IBSTRMARKDEL | 18531
public static final short | SPRM_ICO | 10818
public static final short | SPRM_IDCTHINT | 10351
public static final short | SPRM_IDSIRMARKDEL | 18535
public static final short | SPRM_ISS | 10824
public static final short | SPRM_ISTD | 18992
public static final short | SPRM_KUL | 10814
public static final short | SPRM_LID | 19009
public static final short | SPRM_NONFELID | 18541
public static final short | SPRM_OBJLOCATION | 26638
public static final short | SPRM_PICLOCATION | 27139
public static final short | SPRM_PROPRMARK | -13737
public static final short | SPRM_RGFTCASCII | 19023
public static final short | SPRM_RGFTCFAREAST | 19024
public static final short | SPRM_RGFTCNOTFAREAST | 19025
public static final short | SPRM_SFXTEXT | 10329
public static final short | SPRM_SHD | 18534
public static final short | SPRM_SYMBOL | 27145
public static final short | SPRM_YSRI | 18510

org.apache.poi.hwpf.usermodel.CharacterRun
public static final short | SPRM_BRC | 26725
public static final short | SPRM_CHARSCALE | 18514
public static final short | SPRM_CPG | 18539
public static final short | SPRM_DISPFLDRMARK | -13726
public static final short | SPRM_DTTMRMARK | 26629
public static final short | SPRM_DTTMRMARKDEL | 26724
public static final short | SPRM_DXASPACE | -30656
public static final short | SPRM_FBOLD | 2101
public static final short | SPRM_FCAPS | 2107
public static final short | SPRM_FDATA | 2054
public static final short | SPRM_FDSTRIKE | 10835
public static final short | SPRM_FELID | 18542
public static final short | SPRM_FEMBOSS | 2136
public static final short | SPRM_FFLDVANISH | 2050
public static final short | SPRM_FIMPRINT | 2132
public static final short | SPRM_FITALIC | 2102
public static final short | SPRM_FOBJ | 2134
public static final short | SPRM_FOLE2 | 2058
public static final short | SPRM_FOUTLINE | 2104
public static final short | SPRM_FRMARK | 2049
public static final short | SPRM_FRMARKDEL | 2048
public static final short | SPRM_FSHADOW | 2105
public static final short | SPRM_FSMALLCAPS | 2106
public static final short | SPRM_FSPEC | 2133
public static final short | SPRM_FSTRIKE | 2103
public static final short | SPRM_FVANISH | 2108
public static final short | SPRM_HIGHLIGHT | 10764
public static final short | SPRM_HPS | 19011
public static final short | SPRM_HPSKERN | 18507
public static final short | SPRM_HPSPOS | 18501
public static final short | SPRM_IBSTRMARK | 18436
public static final short | SPRM_IBSTRMARKDEL | 18531
public static final short | SPRM_ICO | 10818
public static final short | SPRM_IDCTHINT | 10351
public static final short | SPRM_IDSIRMARKDEL | 18535
public static final short | SPRM_ISS | 10824
public static final short | SPRM_ISTD | 18992
public static final short | SPRM_KUL | 10814
public static final short | SPRM_LID | 19009
public static final short | SPRM_NONFELID | 18541
public static final short | SPRM_OBJLOCATION | 26638
public static final short | SPRM_PICLOCATION | 27139
public static final short | SPRM_PROPRMARK | -13737
public static final short | SPRM_RGFTCASCII | 19023
public static final short | SPRM_RGFTCFAREAST | 19024
public static final short | SPRM_RGFTCNOTFAREAST | 19025
public static final short | SPRM_SFXTEXT | 10329
public static final short | SPRM_SHD | 18534
public static final short | SPRM_SYMBOL | 27145
public static final short | SPRM_YSRI | 18510

org.apache.poi.hwpf.usermodel.DateAndTime
public static final int SIZE 4

org.apache.poi.hwpf.usermodel.Paragraph
public static final short | SPRM_ANLD | -14786
public static final short | SPRM_AUTOSPACEDE | 9271
public static final short | SPRM_AUTOSPACEDN | 9272
public static final short | SPRM_BRCBAR | 26153
public static final short | SPRM_BRCBOTTOM | 25638
public static final short | SPRM_BRCL | 9224
public static final short | SPRM_BRCLEFT | 25637
public static final short | SPRM_BRCP | 9225
public static final short | SPRM_BRCRIGHT | 25639
public static final short | SPRM_BRCTOP | 25636
public static final short | SPRM_CHGTABS | -14827
public static final short | SPRM_CHGTABSPAPX | -14835
public static final short | SPRM_CRLF | 9284
public static final short | SPRM_DCS | 17452
public static final short | SPRM_DXAABS | -31720
public static final short | SPRM_DXAFROMTEXT | -31697
public static final short | SPRM_DXALEFT | -31729
public static final short | SPRM_DXALEFT1 | -31727
public static final short | SPRM_DXARIGHT | -31730
public static final short | SPRM_DXAWIDTH | -31718
public static final short | SPRM_DYAABS | -31719
public static final short | SPRM_DYAAFTER | -23532
public static final short | SPRM_DYABEFORE | -23533
public static final short | SPRM_DYAFROMTEXT | -31698
public static final short | SPRM_DYALINE | 25618
public static final short | SPRM_FADJUSTRIGHT | 9288
public static final short | SPRM_FBIDI | 9281
public static final short | SPRM_FINTABLE | 9238
public static final short | SPRM_FKEEP | 9221
public static final short | SPRM_FKEEPFOLLOW | 9222
public static final short | SPRM_FKINSOKU | 9267
public static final short | SPRM_FLOCKED | 9264
public static final short | SPRM_FNOAUTOHYPH | 9258
public static final short | SPRM_FNOLINENUMB | 9228
public static final short | SPRM_FNUMRMLNS | 9283
public static final short | SPRM_FOVERFLOWPUNCT | 9269
public static final short | SPRM_FPAGEBREAKBEFORE | 9223
public static final short | SPRM_FRAMETEXTFLOW | 17466
public static final short | SPRM_FSIDEBYSIDE | 9220
public static final short | SPRM_FTOPLINEPUNCT | 9270
public static final short | SPRM_FTTP | 9239
public static final short | SPRM_FWIDOWCONTROL | 9265
public static final short | SPRM_FWORDWRAP | 9268
public static final short | SPRM_ILFO | 17931
public static final short | SPRM_ILVL | 9738
public static final short | SPRM_JC | 9219
public static final short | SPRM_NUMRM | -14779
public static final short | SPRM_OUTLVL | 9792
public static final short | SPRM_PC | 9755
public static final short | SPRM_PROPRMARK | -14785
public static final short | SPRM_RULER | -14798
public static final short | SPRM_SHD | -14771
public static final short | SPRM_SHD80 | 17453
public static final short | SPRM_USEPGSUSETTINGS | 9287
public static final short | SPRM_WALIGNFONT | 17465
public static final short | SPRM_WHEIGHTABS | 17451
public static final short | SPRM_WR | 9251

org.apache.poi.hwpf.usermodel.Range
public static final int | TYPE_CHARACTER | 1
public static final int | TYPE_LISTENTRY | 4
public static final int | TYPE_PARAGRAPH | 0
public static final int | TYPE_SECTION | 2
public static final int | TYPE_TABLE | 5
public static final int | TYPE_TEXT | 3
public static final int | TYPE_UNDEFINED | 6

org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier
public static final int SIZE 4

org.apache.poi.hwpf.usermodel.TableCellDescriptor
public static final int SIZE 20

org.apache.poi.openxml4j.opc.ContentTypes
public static final java.lang.String | CORE_PROPERTIES_PART | "application/vnd.openxmlformats-package.core-properties+xml"
public static final java.lang.String | CUSTOM_XML_PART | "application/vnd.openxmlformats-officedocument.customXmlProperties+xml"
public static final java.lang.String | DIGITAL_SIGNATURE_CERTIFICATE_PART | "application/vnd.openxmlformats-package.digital-signature-certificate"
public static final java.lang.String | DIGITAL_SIGNATURE_ORIGIN_PART | "application/vnd.openxmlformats-package.digital-signature-origin"
public static final java.lang.String | DIGITAL_SIGNATURE_XML_SIGNATURE_PART | "application/vnd.openxmlformats-package.digital-signature-xmlsignature+xml"
public static final java.lang.String | EXTENSION_GIF | "gif"
public static final java.lang.String | EXTENSION_JPG_1 | "jpg"
public static final java.lang.String | EXTENSION_JPG_2 | "jpeg"
public static final java.lang.String | EXTENSION_PICT | "tiff"
public static final java.lang.String | EXTENSION_PNG | "png"
public static final java.lang.String | EXTENSION_TIFF | "tiff"
public static final java.lang.String | EXTENSION_XML | "xml"
public static final java.lang.String | IMAGE_GIF | "image/gif"
public static final java.lang.String | IMAGE_JPEG | "image/jpeg"
public static final java.lang.String | IMAGE_PICT | "image/pict"
public static final java.lang.String | IMAGE_PNG | "image/png"
public static final java.lang.String | IMAGE_TIFF | "image/tiff"
public static final java.lang.String | PLAIN_OLD_XML | "application/xml"
public static final java.lang.String | RELATIONSHIPS_PART | "application/vnd.openxmlformats-package.relationships+xml"
public static final java.lang.String | XML | "text/xml"

org.apache.poi.openxml4j.opc.PackageNamespaces
public static final java.lang.String | CONTENT_TYPES | "http://schemas.openxmlformats.org/package/2006/content-types"
public static final java.lang.String | CORE_PROPERTIES | "http://schemas.openxmlformats.org/package/2006/metadata/core-properties"
public static final java.lang.String | DIGITAL_SIGNATURE | "http://schemas.openxmlformats.org/package/2006/digital-signature"
public static final java.lang.String | MARKUP_COMPATIBILITY | "http://schemas.openxmlformats.org/markup-compatibility/2006"
public static final java.lang.String | RELATIONSHIPS | "http://schemas.openxmlformats.org/package/2006/relationships"

org.apache.poi.openxml4j.opc.PackageProperties
public static final java.lang.String | NAMESPACE_DC | "http://purl.org/dc/elements/1.1/"
public static final java.lang.String | NAMESPACE_DCTERMS | "http://purl.org/dc/terms/"

org.apache.poi.openxml4j.opc.PackageRelationship
public static final java.lang.String | ID_ATTRIBUTE_NAME | "Id"
public static final java.lang.String | RELATIONSHIP_TAG_NAME | "Relationship"
public static final java.lang.String | RELATIONSHIPS_TAG_NAME | "Relationships"
public static final java.lang.String | TARGET_ATTRIBUTE_NAME | "Target"
public static final java.lang.String | TARGET_MODE_ATTRIBUTE_NAME | "TargetMode"
public static final java.lang.String | TYPE_ATTRIBUTE_NAME | "Type"

org.apache.poi.openxml4j.opc.PackageRelationshipTypes
public static final java.lang.String | CORE_DOCUMENT | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/officeDocument"
public static final java.lang.String | CORE_PROPERTIES | "http://schemas.openxmlformats.org/package/2006/relationships/metadata/core-properties"
public static final java.lang.String | CORE_PROPERTIES_ECMA376 | "http://schemas.openxmlformats.org/officedocument/2006/relationships/metadata/core-properties"
public static final java.lang.String | CUSTOM_PROPERTIES | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/custom-properties"
public static final java.lang.String | CUSTOM_XML | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/customXml"
public static final java.lang.String | DIGITAL_SIGNATURE | "http://schemas.openxmlformats.org/package/2006/relationships/digital-signature/signature"
public static final java.lang.String | DIGITAL_SIGNATURE_CERTIFICATE | "http://schemas.openxmlformats.org/package/2006/relationships/digital-signature/certificate"
public static final java.lang.String | DIGITAL_SIGNATURE_ORIGIN | "http://schemas.openxmlformats.org/package/2006/relationships/digital-signature/origin"
public static final java.lang.String | EXTENDED_PROPERTIES | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/extended-properties"
public static final java.lang.String | HYPERLINK_PART | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/hyperlink"
public static final java.lang.String | IMAGE_PART | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/image"
public static final java.lang.String | STYLE_PART | "http://schemas.openxmlformats.org/officeDocument/2006/relationships/styles"
public static final java.lang.String | THUMBNAIL | "http://schemas.openxmlformats.org/package/2006/relationships/metadata/thumbnail"

org.apache.poi.openxml4j.opc.internal.ContentTypeManager
public static final java.lang.String | CONTENT_TYPES_PART_NAME | "[Content_Types].xml"
public static final java.lang.String | TYPES_NAMESPACE_URI | "http://schemas.openxmlformats.org/package/2006/content-types"

org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
public static final java.lang.String | NAMESPACE_CP_URI | "http://schemas.openxmlformats.org/package/2006/metadata/core-properties"
public static final java.lang.String | NAMESPACE_DC_URI | "http://purl.org/dc/elements/1.1/"
public static final java.lang.String | NAMESPACE_DCTERMS_URI | "http://purl.org/dc/terms/"
public static final java.lang.String | NAMESPACE_XSI_URI | "http://www.w3.org/2001/XMLSchema-instance"

org.apache.poi.openxml4j.opc.internal.ZipHelper
public static final int READ_WRITE_FILE_BUFFER_SIZE 8192

org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller
protected static final java.lang.String | KEYWORD_CATEGORY | "category"
protected static final java.lang.String | KEYWORD_CONTENT_STATUS | "contentStatus"
protected static final java.lang.String | KEYWORD_CONTENT_TYPE | "contentType"
protected static final java.lang.String | KEYWORD_CREATED | "created"
protected static final java.lang.String | KEYWORD_CREATOR | "creator"
protected static final java.lang.String | KEYWORD_DESCRIPTION | "description"
protected static final java.lang.String | KEYWORD_IDENTIFIER | "identifier"
protected static final java.lang.String | KEYWORD_KEYWORDS | "keywords"
protected static final java.lang.String | KEYWORD_LANGUAGE | "language"
protected static final java.lang.String | KEYWORD_LAST_MODIFIED_BY | "lastModifiedBy"
protected static final java.lang.String | KEYWORD_LAST_PRINTED | "lastPrinted"
protected static final java.lang.String | KEYWORD_MODIFIED | "modified"
protected static final java.lang.String | KEYWORD_REVISION | "revision"
protected static final java.lang.String | KEYWORD_SUBJECT | "subject"
protected static final java.lang.String | KEYWORD_TITLE | "title"
protected static final java.lang.String | KEYWORD_VERSION | "version"

org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller
protected static final java.lang.String | KEYWORD_CATEGORY | "category"
protected static final java.lang.String | KEYWORD_CONTENT_STATUS | "contentStatus"
protected static final java.lang.String | KEYWORD_CONTENT_TYPE | "contentType"
protected static final java.lang.String | KEYWORD_CREATED | "created"
protected static final java.lang.String | KEYWORD_CREATOR | "creator"
protected static final java.lang.String | KEYWORD_DESCRIPTION | "description"
protected static final java.lang.String | KEYWORD_IDENTIFIER | "identifier"
protected static final java.lang.String | KEYWORD_KEYWORDS | "keywords"
protected static final java.lang.String | KEYWORD_LANGUAGE | "language"
protected static final java.lang.String | KEYWORD_LAST_MODIFIED_BY | "lastModifiedBy"
protected static final java.lang.String | KEYWORD_LAST_PRINTED | "lastPrinted"
protected static final java.lang.String | KEYWORD_MODIFIED | "modified"
protected static final java.lang.String | KEYWORD_REVISION | "revision"
protected static final java.lang.String | KEYWORD_SUBJECT | "subject"
protected static final java.lang.String | KEYWORD_TITLE | "title"
protected static final java.lang.String | KEYWORD_VERSION | "version"

org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

org.apache.poi.poifs.common.POIFSConstants
public static final int | BIG_BLOCK_MINIMUM_DOCUMENT_SIZE | 4096
public static final int | DIFAT_SECTOR_BLOCK | -4
public static final int | END_OF_CHAIN | -2
public static final int | FAT_SECTOR_BLOCK | -3
public static final int | LARGER_BIG_BLOCK_SIZE | 4096
public static final int | LARGEST_REGULAR_SECTOR_NUMBER | -5
public static final int | PROPERTY_SIZE | 128
public static final int | SMALL_BLOCK_SIZE | 64
public static final int | SMALLER_BIG_BLOCK_SIZE | 512
public static final int | UNUSED_BLOCK | -1

org.apache.poi.poifs.crypt.Decryptor
public static final java.lang.String DEFAULT_PASSWORD "VelvetSweatshop"

org.apache.poi.poifs.crypt.EncryptionHeader
public static final int | ALGORITHM_AES_128 | 26126
public static final int | ALGORITHM_AES_192 | 26127
public static final int | ALGORITHM_AES_256 | 26128
public static final int | ALGORITHM_RC4 | 26625
public static final int | HASH_SHA1 | 32772
public static final int | MODE_CBC | 2
public static final int | MODE_CFB | 3
public static final int | MODE_ECB | 1
public static final int | PROVIDER_AES | 24
public static final int | PROVIDER_RC4 | 1

org.apache.poi.poifs.filesystem.DocumentInputStream
protected static final int | EOF | -1
protected static final int | SIZE_INT | 4
protected static final int | SIZE_LONG | 8
protected static final int | SIZE_SHORT | 2

org.apache.poi.poifs.filesystem.Ole10Native
public static final java.lang.String OLE10_NATIVE "\u0001Ole10Native"

org.apache.poi.poifs.property.Property
protected static final int | _NO_INDEX | -1
protected static final byte | _NODE_BLACK | 1
protected static final byte | _NODE_RED | 0

org.apache.poi.poifs.property.PropertyConstants
public static final byte | DIRECTORY_TYPE | 1
public static final byte | DOCUMENT_TYPE | 2
public static final int | PROPERTY_TYPE_OFFSET | 66
public static final byte | ROOT_TYPE | 5

org.apache.poi.poifs.storage.HeaderBlockConstants
public static final int | _bat_array_offset | 76
public static final int | _bat_count_offset | 44
public static final int | _max_bats_in_header | 109
public static final int | _property_start_offset | 48
public static final int | _sbat_block_count_offset | 64
public static final int | _sbat_start_offset | 60
public static final long | _signature | -2226271756974174256L
public static final int | _signature_offset | 0
public static final int | _xbat_count_offset | 72
public static final int | _xbat_start_offset | 68

org.apache.poi.sl.usermodel.ShapeTypes
public static final int | AccentBorderCallout1 | 50
public static final int | AccentBorderCallout2 | 51
public static final int | AccentBorderCallout3 | 52
public static final int | AccentBorderCallout90 | 181
public static final int | AccentCallout1 | 44
public static final int | AccentCallout2 | 45
public static final int | AccentCallout3 | 46
public static final int | AccentCallout90 | 179
public static final int | ActionButtonBackPrevious | 194
public static final int | ActionButtonBeginning | 196
public static final int | ActionButtonBlank | 189
public static final int | ActionButtonDocument | 198
public static final int | ActionButtonEnd | 195
public static final int | ActionButtonForwardNext | 193
public static final int | ActionButtonHelp | 191
public static final int | ActionButtonHome | 190
public static final int | ActionButtonInformation | 192
public static final int | ActionButtonMovie | 200
public static final int | ActionButtonReturn | 197
public static final int | ActionButtonSound | 199
public static final int | Arc | 19
public static final int | Arrow | 13
public static final int | Balloon | 17
public static final int | BentArrow | 91
public static final int | BentConnector2 | 33
public static final int | BentConnector3 | 34
public static final int | BentConnector4 | 35
public static final int | BentConnector5 | 36
public static final int | BentUpArrow | 90
public static final int | Bevel | 84
public static final int | BlockArc | 95
public static final int | BorderCallout1 | 47
public static final int | BorderCallout2 | 48
public static final int | BorderCallout3 | 49
public static final int | BorderCallout90 | 180
public static final int | BracePair | 186
public static final int | BracketPair | 185
public static final int | Callout1 | 41
public static final int | Callout2 | 42
public static final int | Callout3 | 43
public static final int | Callout90 | 178
public static final int | Can | 22
public static final int | Chevron | 55
public static final int | CircularArrow | 99
public static final int | CloudCallout | 106
public static final int | Cube | 16
public static final int | CurvedConnector2 | 37
public static final int | CurvedConnector3 | 38
public static final int | CurvedConnector4 | 39
public static final int | CurvedConnector5 | 40
public static final int | CurvedDownArrow | 105
public static final int | CurvedLeftArrow | 103
public static final int | CurvedRightArrow | 102
public static final int | CurvedUpArrow | 104
public static final int | Diamond | 4
public static final int | Donut | 23
public static final int | DoubleWave | 188
public static final int | DownArrow | 67
public static final int | DownArrowCallout | 80
public static final int | Ellipse | 3
public static final int | EllipseRibbon | 107
public static final int | EllipseRibbon2 | 108
public static final int | FlowChartAlternateProcess | 176
public static final int | FlowChartCollate | 125
public static final int | FlowChartConnector | 120
public static final int | FlowChartDecision | 110
public static final int | FlowChartDelay | 135
public static final int | FlowChartDisplay | 134
public static final int | FlowChartDocument | 114
public static final int | FlowChartExtract | 127
public static final int | FlowChartInputOutput | 111
public static final int | FlowChartInternalStorage | 113
public static final int | FlowChartMagneticDisk | 132
public static final int | FlowChartMagneticDrum | 133
public static final int | FlowChartMagneticTape | 131
public static final int | FlowChartManualInput | 118
public static final int | FlowChartManualOperation | 119
public static final int | FlowChartMerge | 128
public static final int | FlowChartMultidocument | 115
public static final int | FlowChartOfflineStorage | 129
public static final int | FlowChartOffpageConnector | 177
public static final int | FlowChartOnlineStorage | 130
public static final int | FlowChartOr | 124
public static final int | FlowChartPredefinedProcess | 112
public static final int | FlowChartPreparation | 117
public static final int | FlowChartProcess | 109
public static final int | FlowChartPunchedCard | 121
public static final int | FlowChartPunchedTape | 122
public static final int | FlowChartSort | 126
public static final int | FlowChartSummingJunction | 123
public static final int | FlowChartTerminator | 116
public static final int | FoldedCorner | 65
public static final int | Heart | 74
public static final int | Hexagon | 9
public static final int | HomePlate | 15
public static final int | HorizontalScroll | 98
public static final int | HostControl | 201
public static final int | IrregularSeal1 | 71
public static final int | IrregularSeal2 | 72
public static final int | IsocelesTriangle | 5
public static final int | LeftArrow | 66
public static final int | LeftArrowCallout | 77
public static final int | LeftBrace | 87
public static final int | LeftBracket | 85
public static final int | LeftRightArrow | 69
public static final int | LeftRightArrowCallout | 81
public static final int | LeftRightUpArrow | 182
public static final int | LeftUpArrow | 89
public static final int | LightningBolt | 73
public static final int | Line | 20
public static final int | Moon | 184
public static final int | NoSmoking | 57
public static final int | NotchedCircularArrow | 100
public static final int | NotchedRightArrow | 94
public static final int | NotPrimitive | 0
public static final int | Octagon | 10
public static final int | Parallelogram | 7
public static final int | Pentagon | 56
public static final int | PictureFrame | 75
public static final int | Plaque | 21
public static final int | Plus | 11
public static final int | QuadArrow | 76
public static final int | QuadArrowCallout | 83
public static final int | Rectangle | 1
public static final int | Ribbon | 53
public static final int | Ribbon2 | 54
public static final int | RightArrowCallout | 78
public static final int | RightBrace | 88
public static final int | RightBracket | 86
public static final int | RightTriangle | 6
public static final int | RoundRectangle | 2
public static final int | Seal | 18
public static final int | SmileyFace | 96
public static final int | Star | 12
public static final int | Star16 | 59
public static final int | Star24 | 92
public static final int | Star32 | 60
public static final int | Star4 | 187
public static final int | Star8 | 58
public static final int | StraightConnector1 | 32
public static final int | StripedRightArrow | 93
public static final int | Sun | 183
public static final int | TextArchDownCurve | 145
public static final int | TextArchDownPour | 149
public static final int | TextArchUpCurve | 144
public static final int | TextArchUpPour | 148
public static final int | TextBox | 202
public static final int | TextButtonCurve | 147
public static final int | TextButtonPour | 151
public static final int | TextCanDown | 175
public static final int | TextCanUp | 174
public static final int | TextCascadeDown | 155
public static final int | TextCascadeUp | 154
public static final int | TextChevron | 140
public static final int | TextChevronInverted | 141
public static final int | TextCircleCurve | 146
public static final int | TextCirclePour | 150
public static final int | TextCurve | 27
public static final int | TextCurveDown | 153
public static final int | TextCurveUp | 152
public static final int | TextDeflate | 161
public static final int | TextDeflateBottom | 163
public static final int | TextDeflateInflate | 166
public static final int | TextDeflateInflateDeflate | 167
public static final int | TextDeflateTop | 165
public static final int | TextFadeDown | 171
public static final int | TextFadeLeft | 169
public static final int | TextFadeRight | 168
public static final int | TextFadeUp | 170
public static final int | TextHexagon | 26
public static final int | TextInflate | 160
public static final int | TextInflateBottom | 162
public static final int | TextInflateTop | 164
public static final int | TextOctagon | 25
public static final int | TextOnCurve | 30
public static final int | TextOnRing | 31
public static final int | TextPlainText | 136
public static final int | TextRing | 29
public static final int | TextRingInside | 142
public static final int | TextRingOutside | 143
public static final int | TextSimple | 24
public static final int | TextSlantDown | 173
public static final int | TextSlantUp | 172
public static final int | TextStop | 137
public static final int | TextTriangle | 138
public static final int | TextTriangleInverted | 139
public static final int | TextWave | 28
public static final int | TextWave1 | 156
public static final int | TextWave2 | 157
public static final int | TextWave3 | 158
public static final int | TextWave4 | 159
public static final int | ThickArrow | 14
public static final int | Trapezoid | 8
public static final int | UpArrow | 68
public static final int | UpArrowCallout | 79
public static final int | UpDownArrow | 70
public static final int | UpDownArrowCallout | 82
public static final int | UturnArrow | 101
public static final int | VerticalScroll | 97
public static final int | Wave | 64
public static final int | WedgeEllipseCallout | 63
public static final int | WedgeRectCallout | 61
public static final int | WedgeRRectCallout | 62

org.apache.poi.ss.formula.FormulaType
public static final int | ARRAY | 2
public static final int | CELL | 0
public static final int | CONDFORMAT | 3
public static final int | DATAVALIDATION_LIST | 5
public static final int | NAMEDRANGE | 4
public static final int | SHARED | 1

org.apache.poi.ss.formula.function.FunctionMetadataRegistry
public static final int | FUNCTION_INDEX_CHOOSE | 100
public static final short | FUNCTION_INDEX_EXTERNAL | 255
public static final int | FUNCTION_INDEX_IF | 1
public static final short | FUNCTION_INDEX_INDIRECT | 148
public static final short | FUNCTION_INDEX_SUM | 4
public static final java.lang.String | FUNCTION_NAME_IF | "IF"

org.apache.poi.ss.formula.functions.Address
public static final int | REF_ABSOLUTE | 1
public static final int | REF_RELATIVE | 4
public static final int | REF_ROW_ABSOLUTE_COLUMN_RELATIVE | 2
public static final int | REF_ROW_RELATIVE_RELATIVE_ABSOLUTE | 3

org.apache.poi.ss.formula.functions.TextFunction
protected static final java.lang.String EMPTY_STRING ""

org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
public static final java.lang.String FUNCTION_NAME_IF "IF"

org.apache.poi.ss.formula.ptg.AddPtg
public static final byte sid 3

org.apache.poi.ss.formula.ptg.Area3DPtg
public static final byte sid 59

org.apache.poi.ss.formula.ptg.AreaErrPtg
public static final byte sid 43

org.apache.poi.ss.formula.ptg.AreaNPtg
public static final short sid 45

org.apache.poi.ss.formula.ptg.AreaPtg
public static final short sid 37

org.apache.poi.ss.formula.ptg.ArrayPtg
public static final int | PLAIN_TOKEN_SIZE | 8
public static final byte | sid | 32

org.apache.poi.ss.formula.ptg.AttrPtg
public static final byte sid 25

org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
public static final int | CR_BEFORE | 1
public static final int | CR_BEFORE_CLOSE_PAREN | 5
public static final int | CR_BEFORE_OPEN_PAREN | 3
public static final int | SPACE_AFTER_EQUALITY | 6
public static final int | SPACE_BEFORE | 0
public static final int | SPACE_BEFORE_CLOSE_PAREN | 4
public static final int | SPACE_BEFORE_OPEN_PAREN | 2

org.apache.poi.ss.formula.ptg.BoolPtg
public static final byte | sid | 29
public static final int | SIZE | 2

org.apache.poi.ss.formula.ptg.ConcatPtg
public static final byte sid 8

org.apache.poi.ss.formula.ptg.DeletedArea3DPtg
public static final byte sid 61

org.apache.poi.ss.formula.ptg.DeletedRef3DPtg
public static final byte sid 60

org.apache.poi.ss.formula.ptg.DividePtg
public static final byte sid 6

org.apache.poi.ss.formula.ptg.EqualPtg
public static final byte sid 11

org.apache.poi.ss.formula.ptg.ErrPtg
public static final short sid 28

org.apache.poi.ss.formula.ptg.ExpPtg
public static final short sid 1

org.apache.poi.ss.formula.ptg.FuncPtg
public static final byte | sid | 33
public static final int | SIZE | 3

org.apache.poi.ss.formula.ptg.FuncVarPtg
public static final byte sid 34

org.apache.poi.ss.formula.ptg.GreaterEqualPtg
public static final byte | sid | 12
public static final int | SIZE | 1

org.apache.poi.ss.formula.ptg.GreaterThanPtg
public static final byte sid 13

org.apache.poi.ss.formula.ptg.IntersectionPtg
public static final byte sid 15

org.apache.poi.ss.formula.ptg.IntPtg
public static final byte | sid | 30
public static final int | SIZE | 3

org.apache.poi.ss.formula.ptg.LessEqualPtg
public static final byte sid 10

org.apache.poi.ss.formula.ptg.LessThanPtg
public static final byte sid 9

org.apache.poi.ss.formula.ptg.MemAreaPtg
public static final short sid 38

org.apache.poi.ss.formula.ptg.MemErrPtg
public static final short sid 39

org.apache.poi.ss.formula.ptg.MemFuncPtg
public static final byte sid 41

org.apache.poi.ss.formula.ptg.MissingArgPtg
public static final byte sid 22

org.apache.poi.ss.formula.ptg.MultiplyPtg
public static final byte sid 5

org.apache.poi.ss.formula.ptg.NamePtg
public static final short sid 35

org.apache.poi.ss.formula.ptg.NameXPtg
public static final short sid 57

org.apache.poi.ss.formula.ptg.NotEqualPtg
public static final byte sid 14

org.apache.poi.ss.formula.ptg.NumberPtg
public static final byte | sid | 31
public static final int | SIZE | 9

org.apache.poi.ss.formula.ptg.OperationPtg
public static final int | TYPE_BINARY | 1
public static final int | TYPE_FUNCTION | 2
public static final int | TYPE_UNARY | 0

org.apache.poi.ss.formula.ptg.ParenthesisPtg
public static final byte sid 21

org.apache.poi.ss.formula.ptg.PercentPtg
public static final byte | sid | 20
public static final int | SIZE | 1

org.apache.poi.ss.formula.ptg.PowerPtg
public static final byte sid 7

org.apache.poi.ss.formula.ptg.Ptg
public static final byte | CLASS_ARRAY | 64
public static final byte | CLASS_REF | 0
public static final byte | CLASS_VALUE | 32

org.apache.poi.ss.formula.ptg.RangePtg
public static final byte | sid | 17
public static final int | SIZE | 1

org.apache.poi.ss.formula.ptg.Ref3DPtg
public static final byte sid 58

org.apache.poi.ss.formula.ptg.RefErrorPtg
public static final byte sid 42

org.apache.poi.ss.formula.ptg.RefNPtg
public static final byte sid 44

org.apache.poi.ss.formula.ptg.RefPtg
public static final byte sid 36

org.apache.poi.ss.formula.ptg.StringPtg
public static final byte sid 23

org.apache.poi.ss.formula.ptg.SubtractPtg
public static final byte sid 4

org.apache.poi.ss.formula.ptg.TblPtg
public static final short sid 2

org.apache.poi.ss.formula.ptg.UnaryMinusPtg
public static final byte sid 19

org.apache.poi.ss.formula.ptg.UnaryPlusPtg
public static final byte sid 18

org.apache.poi.ss.formula.ptg.UnionPtg
public static final byte sid 16

org.apache.poi.ss.usermodel.BorderFormatting
public static final short | BORDER_DASH_DOT | 9
public static final short | BORDER_DASH_DOT_DOT | 11
public static final short | BORDER_DASHED | 3
public static final short | BORDER_DOTTED | 7
public static final short | BORDER_DOUBLE | 6
public static final short | BORDER_HAIR | 4
public static final short | BORDER_MEDIUM | 2
public static final short | BORDER_MEDIUM_DASH_DOT | 10
public static final short | BORDER_MEDIUM_DASH_DOT_DOT | 12
public static final short | BORDER_MEDIUM_DASHED | 8
public static final short | BORDER_NONE | 0
public static final short | BORDER_SLANTED_DASH_DOT | 13
public static final short | BORDER_THICK | 5
public static final short | BORDER_THIN | 1

org.apache.poi.ss.usermodel.BuiltinFormats
public static final int FIRST_USER_DEFINED_FORMAT_INDEX 164

org.apache.poi.ss.usermodel.Cell
public static final int | CELL_TYPE_BLANK | 3
public static final int | CELL_TYPE_BOOLEAN | 4
public static final int | CELL_TYPE_ERROR | 5
public static final int | CELL_TYPE_FORMULA | 2
public static final int | CELL_TYPE_NUMERIC | 0
public static final int | CELL_TYPE_STRING | 1

org.apache.poi.ss.usermodel.CellStyle
public static final short | ALIGN_CENTER | 2
public static final short | ALIGN_CENTER_SELECTION | 6
public static final short | ALIGN_FILL | 4
public static final short | ALIGN_GENERAL | 0
public static final short | ALIGN_JUSTIFY | 5
public static final short | ALIGN_LEFT | 1
public static final short | ALIGN_RIGHT | 3
public static final short | ALT_BARS | 3
public static final short | BIG_SPOTS | 9
public static final short | BORDER_DASH_DOT | 9
public static final short | BORDER_DASH_DOT_DOT | 11
public static final short | BORDER_DASHED | 3
public static final short | BORDER_DOTTED | 7
public static final short | BORDER_DOUBLE | 6
public static final short | BORDER_HAIR | 4
public static final short | BORDER_MEDIUM | 2
public static final short | BORDER_MEDIUM_DASH_DOT | 10
public static final short | BORDER_MEDIUM_DASH_DOT_DOT | 12
public static final short | BORDER_MEDIUM_DASHED | 8
public static final short | BORDER_NONE | 0
public static final short | BORDER_SLANTED_DASH_DOT | 13
public static final short | BORDER_THICK | 5
public static final short | BORDER_THIN | 1
public static final short | BRICKS | 10
public static final short | DIAMONDS | 16
public static final short | FINE_DOTS | 2
public static final short | LEAST_DOTS | 18
public static final short | LESS_DOTS | 17
public static final short | NO_FILL | 0
public static final short | SOLID_FOREGROUND | 1
public static final short | SPARSE_DOTS | 4
public static final short | SQUARES | 15
public static final short | THICK_BACKWARD_DIAG | 7
public static final short | THICK_FORWARD_DIAG | 8
public static final short | THICK_HORZ_BANDS | 5
public static final short | THICK_VERT_BANDS | 6
public static final short | THIN_BACKWARD_DIAG | 13
public static final short | THIN_FORWARD_DIAG | 14
public static final short | THIN_HORZ_BANDS | 11
public static final short | THIN_VERT_BANDS | 12
public static final short | VERTICAL_BOTTOM | 2
public static final short | VERTICAL_CENTER | 1
public static final short | VERTICAL_JUSTIFY | 3
public static final short | VERTICAL_TOP | 0

org.apache.poi.ss.usermodel.ClientAnchor
public static final int | DONT_MOVE_AND_RESIZE | 3
public static final int | MOVE_AND_RESIZE | 0
public static final int | MOVE_DONT_RESIZE | 2

org.apache.poi.ss.usermodel.ComparisonOperator
public static final byte | BETWEEN | 1
public static final byte | EQUAL | 3
public static final byte | GE | 7
public static final byte | GT | 5
public static final byte | LE | 8
public static final byte | LT | 6
public static final byte | NO_COMPARISON | 0
public static final byte | NOT_BETWEEN | 2
public static final byte | NOT_EQUAL | 4

org.apache.poi.ss.usermodel.ConditionalFormattingRule
public static final byte | CONDITION_TYPE_CELL_VALUE_IS | 1
public static final byte | CONDITION_TYPE_FORMULA | 2

org.apache.poi.ss.usermodel.DataValidation.ErrorStyle
public static final int | INFO | 2
public static final int | STOP | 0
public static final int | WARNING | 1

org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType
public static final int | BETWEEN | 0
public static final int | EQUAL | 2
public static final int | GREATER_OR_EQUAL | 6
public static final int | GREATER_THAN | 4
public static final int | IGNORED | 0
public static final int | LESS_OR_EQUAL | 7
public static final int | LESS_THAN | 5
public static final int | NOT_BETWEEN | 1
public static final int | NOT_EQUAL | 3

org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
public static final int | ANY | 0
public static final int | DATE | 4
public static final int | DECIMAL | 2
public static final int | FORMULA | 7
public static final int | INTEGER | 1
public static final int | LIST | 3
public static final int | TEXT_LENGTH | 6
public static final int | TIME | 5

org.apache.poi.ss.usermodel.ErrorConstants
public static final int | ERROR_DIV_0 | 7
public static final int | ERROR_NA | 42
public static final int | ERROR_NAME | 29
public static final int | ERROR_NULL | 0
public static final int | ERROR_NUM | 36
public static final int | ERROR_REF | 23
public static final int | ERROR_VALUE | 15

org.apache.poi.ss.usermodel.ExcelStyleDateFormatter
public static final char | H_BRACKET_SYMBOL | 57360
public static final char | HH_BRACKET_SYMBOL | 57361
public static final char | L_BRACKET_SYMBOL | 57366
public static final char | LL_BRACKET_SYMBOL | 57367
public static final char | M_BRACKET_SYMBOL | 57362
public static final char | MM_BRACKET_SYMBOL | 57363
public static final char | MMMMM_START_SYMBOL | 57345
public static final char | MMMMM_TRUNCATE_SYMBOL | 57346
public static final char | S_BRACKET_SYMBOL | 57364
public static final char | SS_BRACKET_SYMBOL | 57365

org.apache.poi.ss.usermodel.Font
public static final byte | ANSI_CHARSET | 0
public static final short | BOLDWEIGHT_BOLD | 700
public static final short | BOLDWEIGHT_NORMAL | 400
public static final short | COLOR_NORMAL | 32767
public static final short | COLOR_RED | 10
public static final byte | DEFAULT_CHARSET | 1
public static final short | SS_NONE | 0
public static final short | SS_SUB | 2
public static final short | SS_SUPER | 1
public static final byte | SYMBOL_CHARSET | 2
public static final byte | U_DOUBLE | 2
public static final byte | U_DOUBLE_ACCOUNTING | 34
public static final byte | U_NONE | 0
public static final byte | U_SINGLE | 1
public static final byte | U_SINGLE_ACCOUNTING | 33

org.apache.poi.ss.usermodel.FontFormatting
public static final short | SS_NONE | 0
public static final short | SS_SUB | 2
public static final short | SS_SUPER | 1
public static final byte | U_DOUBLE | 2
public static final byte | U_DOUBLE_ACCOUNTING | 34
public static final byte | U_NONE | 0
public static final byte | U_SINGLE | 1
public static final byte | U_SINGLE_ACCOUNTING | 33

org.apache.poi.ss.usermodel.PatternFormatting
public static final short | ALT_BARS | 3
public static final short | BIG_SPOTS | 9
public static final short | BRICKS | 10
public static final short | DIAMONDS | 16
public static final short | FINE_DOTS | 2
public static final short | LEAST_DOTS | 18
public static final short | LESS_DOTS | 17
public static final short | NO_FILL | 0
public static final short | SOLID_FOREGROUND | 1
public static final short | SPARSE_DOTS | 4
public static final short | SQUARES | 15
public static final short | THICK_BACKWARD_DIAG | 7
public static final short | THICK_FORWARD_DIAG | 8
public static final short | THICK_HORZ_BANDS | 5
public static final short | THICK_VERT_BANDS | 6
public static final short | THIN_BACKWARD_DIAG | 13
public static final short | THIN_FORWARD_DIAG | 14
public static final short | THIN_HORZ_BANDS | 11
public static final short | THIN_VERT_BANDS | 12

org.apache.poi.ss.usermodel.PrintSetup
public static final short | A3_PAPERSIZE | 8
public static final short | A4_EXTRA_PAPERSIZE | 53
public static final short | A4_PAPERSIZE | 9
public static final short | A4_PLUS_PAPERSIZE | 60
public static final short | A4_ROTATED_PAPERSIZE | 77
public static final short | A4_SMALL_PAPERSIZE | 10
public static final short | A4_TRANSVERSE_PAPERSIZE | 55
public static final short | A5_PAPERSIZE | 11
public static final short | B4_PAPERSIZE | 12
public static final short | B5_PAPERSIZE | 13
public static final short | ELEVEN_BY_SEVENTEEN_PAPERSIZE | 17
public static final short | ENVELOPE_10_PAPERSIZE | 20
public static final short | ENVELOPE_9_PAPERSIZE | 19
public static final short | ENVELOPE_C3_PAPERSIZE | 29
public static final short | ENVELOPE_C4_PAPERSIZE | 30
public static final short | ENVELOPE_C5_PAPERSIZE | 28
public static final short | ENVELOPE_C6_PAPERSIZE | 31
public static final short | ENVELOPE_CS_PAPERSIZE | 28
public static final short | ENVELOPE_DL_PAPERSIZE | 27
public static final short | ENVELOPE_MONARCH_PAPERSIZE | 37
public static final short | EXECUTIVE_PAPERSIZE | 7
public static final short | FOLIO8_PAPERSIZE | 14
public static final short | LEDGER_PAPERSIZE | 4
public static final short | LEGAL_PAPERSIZE | 5
public static final short | LETTER_PAPERSIZE | 1
public static final short | LETTER_ROTATED_PAPERSIZE | 75
public static final short | LETTER_SMALL_PAGESIZE | 2
public static final short | NOTE8_PAPERSIZE | 18
public static final short | QUARTO_PAPERSIZE | 15
public static final short | STATEMENT_PAPERSIZE | 6
public static final short | TABLOID_PAPERSIZE | 3
public static final short | TEN_BY_FOURTEEN_PAPERSIZE | 16

org.apache.poi.ss.usermodel.ShapeTypes
public static final int | ACCENT_BORDER_CALLOUT_1 | 114
public static final int | ACCENT_BORDER_CALLOUT_2 | 115
public static final int | ACCENT_BORDER_CALLOUT_3 | 116
public static final int | ACCENT_CALLOUT_1 | 108
public static final int | ACCENT_CALLOUT_2 | 109
public static final int | ACCENT_CALLOUT_3 | 110
public static final int | ACTION_BUTTON_BACK_PREVIOUS | 166
public static final int | ACTION_BUTTON_BEGINNING | 168
public static final int | ACTION_BUTTON_BLANK | 161
public static final int | ACTION_BUTTON_DOCUMENT | 170
public static final int | ACTION_BUTTON_END | 167
public static final int | ACTION_BUTTON_FORWARD_NEXT | 165
public static final int | ACTION_BUTTON_HELP | 163
public static final int | ACTION_BUTTON_HOME | 162
public static final int | ACTION_BUTTON_INFORMATION | 164
public static final int | ACTION_BUTTON_MOVIE | 172
public static final int | ACTION_BUTTON_RETURN | 169
public static final int | ACTION_BUTTON_SOUND | 171
public static final int | ARC | 89
public static final int | BENT_ARROW | 63
public static final int | BENT_CONNECTOR_2 | 97
public static final int | BENT_CONNECTOR_3 | 98
public static final int | BENT_CONNECTOR_4 | 99
public static final int | BENT_CONNECTOR_5 | 100
public static final int | BENT_UP_ARROW | 50
public static final int | BEVEL | 83
public static final int | BLOCK_ARC | 41
public static final int | BORDER_CALLOUT_1 | 111
public static final int | BORDER_CALLOUT_2 | 112
public static final int | BORDER_CALLOUT_3 | 113
public static final int | BRACE_PAIR | 95
public static final int | BRACKET_PAIR | 94
public static final int | CALLOUT_1 | 105
public static final int | CALLOUT_2 | 106
public static final int | CALLOUT_3 | 107
public static final int | CAN | 74
public static final int | CHART_PLUS | 187
public static final int | CHART_STAR | 186
public static final int | CHART_X | 185
public static final int | CHEVRON | 38
public static final int | CHORD | 88
public static final int | CIRCULAR_ARROW | 65
public static final int | CLOUD | 121
public static final int | CLOUD_CALLOUT | 120
public static final int | CORNER | 86
public static final int | CORNER_TABS | 182
public static final int | CUBE | 73
public static final int | CURVED_CONNECTOR_2 | 101
public static final int | CURVED_CONNECTOR_3 | 102
public static final int | CURVED_CONNECTOR_4 | 103
public static final int | CURVED_CONNECTOR_5 | 104
public static final int | CURVED_DOWN_ARROW | 71
public static final int | CURVED_LEFT_ARROW | 69
public static final int | CURVED_RIGHT_ARROW | 68
public static final int | CURVED_UP_ARROW | 70
public static final int | DECAGON | 14
public static final int | DIAG_STRIPE | 87
public static final int | DIAMOND | 6
public static final int | DODECAGON | 15
public static final int | DONUT | 42
public static final int | DOUBLE_WAVE | 130
public static final int | DOWN_ARROW | 47
public static final int | DOWN_ARROW_CALLOUT | 59
public static final int | ELLIPSE | 35
public static final int | ELLIPSE_RIBBON | 124
public static final int | ELLIPSE_RIBBON_2 | 125
public static final int | FLOW_CHART_ALTERNATE_PROCESS | 159
public static final int | FLOW_CHART_COLLATE | 148
public static final int | FLOW_CHART_CONNECTOR | 143
public static final int | FLOW_CHART_DECISION | 133
public static final int | FLOW_CHART_DELAY | 158
public static final int | FLOW_CHART_DISPLAY | 157
public static final int | FLOW_CHART_DOCUMENT | 137
public static final int | FLOW_CHART_EXTRACT | 150
public static final int | FLOW_CHART_INPUT_OUTPUT | 134
public static final int | FLOW_CHART_INTERNAL_STORAGE | 136
public static final int | FLOW_CHART_MAGNETIC_DISK | 155
public static final int | FLOW_CHART_MAGNETIC_DRUM | 156
public static final int | FLOW_CHART_MAGNETIC_TAPE | 154
public static final int | FLOW_CHART_MANUAL_INPUT | 141
public static final int | FLOW_CHART_MANUAL_OPERATION | 142
public static final int | FLOW_CHART_MERGE | 151
public static final int | FLOW_CHART_MULTIDOCUMENT | 138
public static final int | FLOW_CHART_OFFLINE_STORAGE | 152
public static final int | FLOW_CHART_OFFPAGE_CONNECTOR | 160
public static final int | FLOW_CHART_ONLINE_STORAGE | 153
public static final int | FLOW_CHART_OR | 147
public static final int | FLOW_CHART_PREDEFINED_PROCESS | 135
public static final int | FLOW_CHART_PREPARATION | 140
public static final int | FLOW_CHART_PROCESS | 132
public static final int | FLOW_CHART_PUNCHED_CARD | 144
public static final int | FLOW_CHART_PUNCHED_TAPE | 145
public static final int | FLOW_CHART_SORT | 149
public static final int | FLOW_CHART_SUMMING_JUNCTION | 146
public static final int | FLOW_CHART_TERMINATOR | 139
public static final int | FOLDED_CORNER | 82
public static final int | FRAME | 84
public static final int | FUNNEL | 175
public static final int | GEAR_6 | 173
public static final int | GEAR_9 | 174
public static final int | HALF_FRAME | 85
public static final int | HEART | 76
public static final int | HEPTAGON | 12
public static final int | HEXAGON | 11
public static final int | HOME_PLATE | 37
public static final int | HORIZONTAL_SCROLL | 128
public static final int | IRREGULAR_SEAL_1 | 80
public static final int | IRREGULAR_SEAL_2 | 81
public static final int | LEFT_ARROW | 45
public static final int | LEFT_ARROW_CALLOUT | 56
public static final int | LEFT_BRACE | 92
public static final int | LEFT_BRACKET | 90
public static final int | LEFT_CIRCULAR_ARROW | 66
public static final int | LEFT_RIGHT_ARROW | 51
public static final int | LEFT_RIGHT_ARROW_CALLOUT | 60
public static final int | LEFT_RIGHT_CIRCULAR_ARROW | 67
public static final int | LEFT_RIGHT_RIBBON | 126
public static final int | LEFT_RIGHT_UP_ARROW | 54
public static final int | LEFT_UP_ARROW | 53
public static final int | LIGHTNING_BOLT | 75
public static final int | LINE | 1
public static final int | LINE_INV | 2
public static final int | MATH_DIVIDE | 179
public static final int | MATH_EQUAL | 180
public static final int | MATH_MINUS | 177
public static final int | MATH_MULTIPLY | 178
public static final int | MATH_NOT_EQUAL | 181
public static final int | MATH_PLUS | 176
public static final int | MOON | 78
public static final int | NO_SMOKING | 43
public static final int | NON_ISOSCELES_TRAPEZOID | 9
public static final int | NOTCHED_RIGHT_ARROW | 49
public static final int | OCTAGON | 13
public static final int | PARALLELOGRAM | 7
public static final int | PENTAGON | 10
public static final int | PIE | 40
public static final int | PIE_WEDGE | 39
public static final int | PLAQUE | 34
public static final int | PLAQUE_TABS | 184
public static final int | PLUS | 131
public static final int | QUAD_ARROW | 55
public static final int | QUAD_ARROW_CALLOUT | 62
public static final int | RECT | 5
public static final int | RIBBON | 122
public static final int | RIBBON_2 | 123
public static final int | RIGHT_ARROW | 44
public static final int | RIGHT_ARROW_CALLOUT | 57
public static final int | RIGHT_BRACE | 93
public static final int | RIGHT_BRACKET | 91
public static final int | ROUND_1_RECT | 27
public static final int | ROUND_2_DIAG_RECT | 29
public static final int | ROUND_2_SAME_RECT | 28
public static final int | ROUND_RECT | 26
public static final int | RT_TRIANGLE | 4
public static final int | SMILEY_FACE | 79
public static final int | SNIP_1_RECT | 31
public static final int | SNIP_2_DIAG_RECT | 33
public static final int | SNIP_2_SAME_RECT | 32
public static final int | SNIP_ROUND_RECT | 30
public static final int | SQUARE_TABS | 183
public static final int | STAR_10 | 21
public static final int | STAR_12 | 22
public static final int | STAR_16 | 23
public static final int | STAR_24 | 24
public static final int | STAR_32 | 25
public static final int | STAR_4 | 16
public static final int | STAR_5 | 17
public static final int | STAR_6 | 18
public static final int | STAR_7 | 19
public static final int | STAR_8 | 20
public static final int | STRAIGHT_CONNECTOR_1 | 96
public static final int | STRIPED_RIGHT_ARROW | 48
public static final int | SUN | 77
public static final int | SWOOSH_ARROW | 72
public static final int | TEARDROP | 36
public static final int | TRAPEZOID | 8
public static final int | TRIANGLE | 3
public static final int | UP_ARROW | 46
public static final int | UP_ARROW_CALLOUT | 58
public static final int | UP_DOWN_ARROW | 52
public static final int | UP_DOWN_ARROW_CALLOUT | 61
public static final int | UTURN_ARROW | 64
public static final int | VERTICAL_SCROLL | 127
public static final int | WAVE | 129
public static final int | WEDGE_ELLIPSE_CALLOUT | 119
public static final int | WEDGE_RECT_CALLOUT | 117
public static final int | WEDGE_ROUND_RECT_CALLOUT | 118

org.apache.poi.ss.usermodel.Sheet
public static final short | BottomMargin | 3
public static final short | FooterMargin | 5
public static final short | HeaderMargin | 4
public static final short | LeftMargin | 0
public static final byte | PANE_LOWER_LEFT | 2
public static final byte | PANE_LOWER_RIGHT | 0
public static final byte | PANE_UPPER_LEFT | 3
public static final byte | PANE_UPPER_RIGHT | 1
public static final short | RightMargin | 1
public static final short | TopMargin | 2

org.apache.poi.ss.usermodel.Textbox
public static final short OBJECT_TYPE_TEXT 6

org.apache.poi.ss.usermodel.Workbook
public static final int | PICTURE_TYPE_DIB | 7
public static final int | PICTURE_TYPE_EMF | 2
public static final int | PICTURE_TYPE_JPEG | 5
public static final int | PICTURE_TYPE_PICT | 4
public static final int | PICTURE_TYPE_PNG | 6
public static final int | PICTURE_TYPE_WMF | 3
public static final int | SHEET_STATE_HIDDEN | 1
public static final int | SHEET_STATE_VERY_HIDDEN | 2
public static final int | SHEET_STATE_VISIBLE | 0

org.apache.poi.ss.util.CellRangeAddress
public static final int ENCODED_SIZE 8

org.apache.poi.ss.util.CellUtil
public static final java.lang.String | ALIGNMENT | "alignment"
public static final java.lang.String | BORDER_BOTTOM | "borderBottom"
public static final java.lang.String | BORDER_LEFT | "borderLeft"
public static final java.lang.String | BORDER_RIGHT | "borderRight"
public static final java.lang.String | BORDER_TOP | "borderTop"
public static final java.lang.String | BOTTOM_BORDER_COLOR | "bottomBorderColor"
public static final java.lang.String | DATA_FORMAT | "dataFormat"
public static final java.lang.String | FILL_BACKGROUND_COLOR | "fillBackgroundColor"
public static final java.lang.String | FILL_FOREGROUND_COLOR | "fillForegroundColor"
public static final java.lang.String | FILL_PATTERN | "fillPattern"
public static final java.lang.String | FONT | "font"
public static final java.lang.String | HIDDEN | "hidden"
public static final java.lang.String | INDENTION | "indention"
public static final java.lang.String | LEFT_BORDER_COLOR | "leftBorderColor"
public static final java.lang.String | LOCKED | "locked"
public static final java.lang.String | RIGHT_BORDER_COLOR | "rightBorderColor"
public static final java.lang.String | ROTATION | "rotation"
public static final java.lang.String | TOP_BORDER_COLOR | "topBorderColor"
public static final java.lang.String | VERTICAL_ALIGNMENT | "verticalAlignment"
public static final java.lang.String | WRAP_TEXT | "wrapText"

org.apache.poi.ss.util.ImageUtils
public static final int PIXEL_DPI 96

org.apache.poi.util.IdentifierManager
public static final long | MAX_ID | 9223372036854775806L
public static final long | MIN_ID | 0L

org.apache.poi.util.LittleEndianConsts
public static final int | BYTE_SIZE | 1
public static final int | DOUBLE_SIZE | 8
public static final int | INT_SIZE | 4
public static final int | LONG_SIZE | 8
public static final int | SHORT_SIZE | 2

org.apache.poi.util.Units
public static final int | EMU_PER_PIXEL | 9525
public static final int | EMU_PER_POINT | 12700

org.apache.poi.xslf.usermodel.XSLFPictureData
public static final int | PICTURE_TYPE_BMP | 11
public static final int | PICTURE_TYPE_DIB | 7
public static final int | PICTURE_TYPE_EMF | 2
public static final int | PICTURE_TYPE_EPS | 10
public static final int | PICTURE_TYPE_GIF | 8
public static final int | PICTURE_TYPE_JPEG | 5
public static final int | PICTURE_TYPE_PICT | 4
public static final int | PICTURE_TYPE_PNG | 6
public static final int | PICTURE_TYPE_TIFF | 9
public static final int | PICTURE_TYPE_WMF | 3
public static final int | PICTURE_TYPE_WPG | 12

org.apache.poi.xslf.usermodel.XSLFRenderingHint
public static final int | TEXT_AS_CHARACTERS | 1
public static final int | TEXT_AS_SHAPES | 2

org.apache.poi.xssf.model.StylesTable
public static final int FIRST_CUSTOM_STYLE_ID 165

org.apache.poi.xssf.streaming.SXSSFWorkbook
public static final int DEFAULT_WINDOW_SIZE 100

org.apache.poi.xssf.usermodel.XSSFDrawing
protected static final java.lang.String | NAMESPACE_A | "http://schemas.openxmlformats.org/drawingml/2006/main"
protected static final java.lang.String | NAMESPACE_C | "http://schemas.openxmlformats.org/drawingml/2006/chart"

org.apache.poi.xssf.usermodel.XSSFFont
public static final java.lang.String | DEFAULT_FONT_NAME | "Calibri"
public static final short | DEFAULT_FONT_SIZE | 11

org.apache.poi.xssf.usermodel.XSSFName
public static final java.lang.String | BUILTIN_CONSOLIDATE_AREA | "_xlnm.Consolidate_Area"
public static final java.lang.String | BUILTIN_CRITERIA | "_xlnm.Criteria:"
public static final java.lang.String | BUILTIN_DATABASE | "_xlnm.Database"
public static final java.lang.String | BUILTIN_EXTRACT | "_xlnm.Extract:"
public static final java.lang.String | BUILTIN_FILTER_DB | "_xlnm._FilterDatabase"
public static final java.lang.String | BUILTIN_PRINT_AREA | "_xlnm.Print_Area"
public static final java.lang.String | BUILTIN_PRINT_TITLE | "_xlnm.Print_Titles"
public static final java.lang.String | BUILTIN_SHEET_TITLE | "_xlnm.Sheet_Title"

org.apache.poi.xssf.usermodel.XSSFShape
public static final int | EMU_PER_PIXEL | 9525
public static final int | EMU_PER_POINT | 12700
public static final int | PIXEL_DPI | 96
public static final int | POINT_DPI | 72

org.apache.poi.xssf.usermodel.XSSFWorkbook
public static final float | DEFAULT_CHARACTER_WIDTH | 7.001699924468994f
public static final int | PICTURE_TYPE_BMP | 11
public static final int | PICTURE_TYPE_EPS | 10
public static final int | PICTURE_TYPE_GIF | 8
public static final int | PICTURE_TYPE_TIFF | 9
public static final int | PICTURE_TYPE_WPG | 12

org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper
public static final java.lang.String | HeaderFooterEntity_Date | "&D"
public static final java.lang.String | HeaderFooterEntity_File | "&F"
public static final java.lang.String | HeaderFooterEntity_Time | "&T"

org.apache.poi.xwpf.usermodel.Document
public static final int | PICTURE_TYPE_BMP | 11
public static final int | PICTURE_TYPE_DIB | 7
public static final int | PICTURE_TYPE_EMF | 2
public static final int | PICTURE_TYPE_EPS | 10
public static final int | PICTURE_TYPE_GIF | 8
public static final int | PICTURE_TYPE_JPEG | 5
public static final int | PICTURE_TYPE_PICT | 4
public static final int | PICTURE_TYPE_PNG | 6
public static final int | PICTURE_TYPE_TIFF | 9
public static final int | PICTURE_TYPE_WMF | 3
public static final int | PICTURE_TYPE_WPG | 12

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES
Copyright 2012 The Apache Software Foundation or its licensors, as applicable.


Deprecated List

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

Deprecated API

Contents
  • Deprecated Interfaces
  • Deprecated Classes
  • Deprecated Fields
  • Deprecated Methods
  • Deprecated Constructors
  • Deprecated Enum Constants
Deprecated Interfaces
org.apache.poi.hwpf.model.HDFType

Deprecated Classes
org.apache.poi.hwpf.model.BytePropertyNode
byte positions shall not be saved in memory
org.apache.poi.hssf.util.CellRangeAddress
use CellRangeAddress
org.apache.poi.hssf.util.CellRangeAddressList
use CellRangeAddressList
org.apache.poi.openxml4j.opc.Package
(name clash with Package use OPCPackage instead.
org.apache.poi.hssf.util.Region
(Aug-2008) use CellRangeAddress
org.apache.poi.ss.util.Region
(Aug-2008) use CellRangeAddress
org.apache.poi.hwpf.usermodel.Shape
Use OfficeDrawing instead
org.apache.poi.hwpf.model.ShapesTable
org.apache.poi.hssf.record.UnicodeString
Use UnicodeString instead
org.apache.poi.xwpf.model.XWPFHyperlinkDecorator
Use XWPFHyperlinkRun instead

Deprecated Fields
org.apache.poi.hwpf.HWPFDocument._officeArts
org.apache.poi.hssf.record.PaneRecord.ACTIVE_PANE_UPER_LEFT
use ACTIVE_PANE_UPPER_LEFT
org.apache.poi.hwpf.usermodel.Picture.BMP
org.apache.poi.hwpf.usermodel.Picture.EMF
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_1_reserved1
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_10_reserved10
org.apache.poi.hwpf.model.types.FibBaseAbstractType.field_11_Chs
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_11_reserved11
org.apache.poi.hwpf.model.types.FibBaseAbstractType.field_12_chsTables
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_12_reserved12
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_12_reserved4
org.apache.poi.hwpf.model.types.FibBaseAbstractType.field_13_fcMin
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_13_reserved13
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_13_reserved5
org.apache.poi.hwpf.model.types.FibBaseAbstractType.field_14_fcMac
org.apache.poi.hwpf.model.types.FibRgLw95AbstractType.field_14_reserved5
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_14_reserved6
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_15_reserved7
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_16_reserved8
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_17_reserved9
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_18_reserved10
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_19_reserved11
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_2_reserved1
org.apache.poi.hwpf.model.types.FibRgLw95AbstractType.field_2_reserved1
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_2_reserved2
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_20_reserved12
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_21_reserved13
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_22_reserved14
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_3_reserved2
org.apache.poi.hwpf.model.types.FibRgLw95AbstractType.field_3_reserved2
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_3_reserved3
org.apache.poi.hwpf.model.types.FibRgLw95AbstractType.field_4_reserved3
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_4_reserved4
org.apache.poi.hwpf.model.types.FibRgLw95AbstractType.field_5_reserved4
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_5_reserved5
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_6_reserved6
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType.field_7_reserved3
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_7_reserved7
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_8_reserved8
org.apache.poi.hwpf.model.types.FibBaseAbstractType.field_9_envr
org.apache.poi.hwpf.model.types.FibRgW97AbstractType.field_9_reserved9
org.apache.poi.hwpf.model.FSPA.FSPA_SIZE
org.apache.poi.hwpf.usermodel.Picture.GIF
org.apache.poi.ss.formula.eval.BlankEval.INSTANCE
(Nov 2009) use BlankEval.instance
org.apache.poi.hwpf.usermodel.Picture.JPG
org.apache.poi.hwpf.sprm.SprmOperation.PAP_TYPE
org.apache.poi.hwpf.model.FieldsTables.PLCFFLDATN
org.apache.poi.hwpf.model.FieldsTables.PLCFFLDEDN
org.apache.poi.hwpf.model.FieldsTables.PLCFFLDFTN
org.apache.poi.hwpf.model.FieldsTables.PLCFFLDHDR
org.apache.poi.hwpf.model.FieldsTables.PLCFFLDHDRTXBX
org.apache.poi.hwpf.model.FieldsTables.PLCFFLDMOM
org.apache.poi.hwpf.model.FieldsTables.PLCFFLDTXBX
org.apache.poi.hwpf.usermodel.Picture.PNG
org.apache.poi.hwpf.sprm.SprmOperation.TAP_TYPE
org.apache.poi.hwpf.usermodel.Picture.TIFF
org.apache.poi.hwpf.usermodel.Picture.TIFF1
org.apache.poi.hwpf.usermodel.Range.TYPE_CHARACTER
org.apache.poi.hwpf.usermodel.Range.TYPE_LISTENTRY
org.apache.poi.hwpf.usermodel.Range.TYPE_PARAGRAPH
org.apache.poi.hwpf.usermodel.Range.TYPE_SECTION
org.apache.poi.hwpf.usermodel.Range.TYPE_TABLE
org.apache.poi.hwpf.usermodel.Range.TYPE_TEXT
org.apache.poi.hwpf.usermodel.Range.TYPE_UNDEFINED
org.apache.poi.hwpf.usermodel.Picture.WMF1
org.apache.poi.hwpf.usermodel.Picture.WMF2

Deprecated Methods
org.apache.poi.xslf.usermodel.XMLSlideShow._getXSLFSlideShow()
org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting.addConditionalFormatting(Region[], HSSFConditionalFormattingRule[])
use CellRangeAddress instead of Region
org.apache.poi.hssf.usermodel.HSSFSheet.addMergedRegion(Region)
(Aug-2008) use CellRangeAddress instead of Region
org.apache.poi.hssf.usermodel.HSSFWorkbook.addSSTString(String)
Do not call this method from your applications. Use the methods available in the HSSFRow to add string HSSFCells
org.apache.poi.hwpf.model.TextPiece.adjustForDelete(int, int)
org.apache.poi.hwpf.model.TextPiece.characterLength()
org.apache.poi.hwpf.usermodel.CharacterRun.cloneProperties()
This method shall not be public and should not be called from high-level code
org.apache.poi.POIDocument.copyNodeRecursively(Entry, DirectoryEntry)
org.apache.poi.poifs.filesystem.EntryUtils.copyNodes(DirectoryEntry, DirectoryEntry, List)
use FilteringDirectoryNode instead
org.apache.poi.POIDocument.copyNodes(DirectoryNode, DirectoryNode, List)
org.apache.poi.POIDocument.copyNodes(POIFSFileSystem, POIFSFileSystem, List)
org.apache.poi.openxml4j.opc.Package.create(File)
use OPCPackage.create(File)
org.apache.poi.openxml4j.opc.Package.create(OutputStream)
use OPCPackage.create(OutputStream)
org.apache.poi.openxml4j.opc.Package.create(String)
use OPCPackage.create(String)
org.apache.poi.ss.formula.eval.forked.ForkedEvaluator.create(Workbook, IStabilityClassifier)
(Sep 2009) (reduce overloading) use ForkedEvaluator.create(Workbook, IStabilityClassifier, UDFFinder)
org.apache.poi.hssf.usermodel.HSSFRow.createCell(short)
(Aug 2008) use HSSFRow.createCell(int)
org.apache.poi.hssf.usermodel.HSSFRow.createCell(short, int)
(Aug 2008) use HSSFRow.createCell(int, int)
org.apache.poi.xssf.usermodel.XSSFSheet.createComment()
since Nov 2009 this method is not compatible with the common SS interfaces, use (org.apache.poi.ss.usermodel.ClientAnchor) instead
org.apache.poi.extractor.ExtractorFactory.createExtractor(DirectoryNode, POIFSFileSystem)
Use ExtractorFactory.createExtractor(DirectoryNode) instead
org.apache.poi.hssf.usermodel.HSSFWorkbook.findSheetNameFromExternSheet(int)
for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.
org.apache.poi.hpsf.wellknown.SectionIDMap.get(Object)
Use SectionIDMap.get(byte[]) instead!
org.apache.poi.hwpf.usermodel.Picture.getAspectRatioX()
use more precise Picture.getHorizontalScalingFactor()
org.apache.poi.hwpf.usermodel.Picture.getAspectRatioY()
use more precise Picture.getVerticalScalingFactor()
org.apache.poi.ss.usermodel.BuiltinFormats.getBuiltinFormats()
(May 2009) use BuiltinFormats.getAll()
org.apache.poi.hssf.usermodel.HSSFRow.getCell(short)
(Aug 2008) use HSSFRow.getCell(int)
org.apache.poi.hssf.usermodel.HSSFCell.getCellNum()
(Oct 2008) use HSSFCell.getColumnIndex()
org.apache.poi.hwpf.model.StyleSheet.getCharacterStyle(int)
org.apache.poi.hwpf.model.TextPieceTable.getCharIndex(int)
org.apache.poi.hwpf.model.CharIndexTranslator.getCharIndex(int)
This API were based on incorrect assumption that single byte offset corresponds to single char offset
org.apache.poi.hwpf.model.TextPieceTable.getCharIndex(int, int)
org.apache.poi.hwpf.model.CharIndexTranslator.getCharIndex(int, int)
This API were based on incorrect assumption that single byte offset corresponds to single char offset
org.apache.poi.hwpf.model.StyleDescription.getCHP()
org.apache.poi.hssf.usermodel.HSSFSheet.getColumnWidth(short)
(Sep 2008) use HSSFSheet.getColumnWidth(int)
org.apache.poi.hssf.record.WindowOneRecord.getDisplayedTab()
- Misleading name - use getFirstVisibleTab()
org.apache.poi.hssf.usermodel.HSSFWorkbook.getDisplayedTab()
- Misleading name - use getFirstVisibleTab()
org.apache.poi.hwpf.usermodel.Picture.getDxaCropLeft()
org.apache.poi.hwpf.usermodel.Picture.getDxaCropRight()
org.apache.poi.hwpf.usermodel.Picture.getDyaCropBottom()
org.apache.poi.hwpf.usermodel.Picture.getDyaCropTop()
org.apache.poi.hwpf.model.BytePropertyNode.getEndBytes()
Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.
org.apache.poi.hwpf.usermodel.HeaderStories.getEndnoteContNote()
org.apache.poi.hwpf.usermodel.HeaderStories.getEndnoteContSeparator()
org.apache.poi.hwpf.usermodel.HeaderStories.getEndnoteSeparator()
org.apache.poi.hwpf.usermodel.HeaderStories.getEvenFooter()
org.apache.poi.hwpf.usermodel.HeaderStories.getEvenHeader()
org.apache.poi.hssf.usermodel.HSSFWorkbook.getExternalSheetIndex(int)
for POI internal use only (formula parsing). This method is likely to be removed in future versions of POI.
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcffldAtn()
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcffldEdn()
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcffldFtn()
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcffldHdr()
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcffldHdrtxbx()
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcffldMom()
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcffldTxbx()
org.apache.poi.hwpf.model.FileInformationBlock.getFcPlcspaMom()
org.apache.poi.hwpf.model.FieldsTables.getFieldsPLCF(int)
org.apache.poi.hwpf.HWPFDocument.getFieldsTables()
org.apache.poi.POIOLE2TextExtractor.getFileSystem()
Use POIOLE2TextExtractor.getRoot() instead
org.apache.poi.hssf.extractor.EventBasedExcelExtractor.getFileSystem()
Use POIOLE2TextExtractor.getRoot() instead
org.apache.poi.hwpf.usermodel.HeaderStories.getFirstFooter()
org.apache.poi.hwpf.usermodel.HeaderStories.getFirstHeader()
org.apache.poi.hwpf.extractor.WordExtractor.getFooterText()
org.apache.poi.hwpf.usermodel.HeaderStories.getFootnoteContNote()
org.apache.poi.hwpf.usermodel.HeaderStories.getFootnoteContSeparator()
org.apache.poi.hwpf.usermodel.HeaderStories.getFootnoteSeparator()
org.apache.poi.hssf.usermodel.HSSFConditionalFormatting.getFormattingRegions()
(Aug-2008) use HSSFConditionalFormatting.getFormattingRanges()
org.apache.poi.hwpf.model.types.FibBaseAbstractType.getFSpare0()
This field should not be used according to specification
org.apache.poi.hwpf.extractor.WordExtractor.getHeaderText()
org.apache.poi.hsmf.MAPIMessage.getHmtlBody()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcffldAtn()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcffldEdn()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcffldFtn()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcffldHdr()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcffldHdrtxbx()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcffldMom()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcffldTxbx()
org.apache.poi.hwpf.model.FileInformationBlock.getLcbPlcspaMom()
org.apache.poi.hssf.usermodel.HSSFSheet.getMergedRegionAt(int)
(Aug-2008) use HSSFSheet.getMergedRegion(int)
org.apache.poi.hwpf.usermodel.HeaderStories.getOddFooter()
org.apache.poi.hwpf.usermodel.HeaderStories.getOddHeader()
org.apache.poi.hssf.record.WindowTwoRecord.getPaged()
use isActive()
org.apache.poi.hwpf.model.StyleDescription.getPAP()
org.apache.poi.hwpf.model.PAPX.getParagraphProperties(StyleSheet)
org.apache.poi.hwpf.model.StyleSheet.getParagraphStyle(int)
org.apache.poi.hwpf.extractor.Word6Extractor.getParagraphText()
org.apache.poi.hssf.usermodel.HSSFName.getReference()
(Nov 2008) Misleading name. Use HSSFName.getRefersToFormula() instead.
org.apache.poi.hwpf.model.types.LSTFAbstractType.getReserved1()
This field should not be used according to specification
org.apache.poi.hssf.record.WindowOneRecord.getSelectedTab()
- Misleading name - use getActiveSheetIndex()
org.apache.poi.hssf.usermodel.HSSFWorkbook.getSelectedTab()
- Misleading name - use getActiveSheetIndex()
org.apache.poi.hwpf.HWPFDocument.getShapesTable()
use HWPFDocument.getOfficeDrawingsMain() instead
org.apache.poi.hslf.usermodel.PictureData.getSize()
Use getData().length instead.
org.apache.poi.hssf.usermodel.HSSFWorkbook.getSSTString(int)
Do not call this method from your applications. Use the methods available in the HSSFRow to get string HSSFCells
org.apache.poi.hwpf.model.BytePropertyNode.getStartBytes()
Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.
org.apache.poi.hwpf.model.TextPiece.getStringBuffer()
org.apache.poi.util.LittleEndian.getUnsignedByte(byte[], int)
Use LittleEndian.getUByte(byte[], int) instead
org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType.getUnused1()
This field should not be used according to specification
org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType.getUnused2()
This field should not be used according to specification
org.apache.poi.hssf.model.InternalSheet.getValueRecords()
use InternalSheet.getCellValueIterator() instead
org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate.getValueRecords()
use ValueRecordsAggregate.iterator() instead
org.apache.poi.hssf.record.aggregates.RowRecordsAggregate.getValueRecords()
use RowRecordsAggregate.getCellValueIterator() instead
org.apache.poi.hssf.usermodel.HSSFSheet.getVerticallyCenter(boolean)
(Mar-2008) use getVerticallyCenter() instead
org.apache.poi.hssf.usermodel.HSSFSheet.groupColumn(short, short)
(Sep 2008) use HSSFSheet.groupColumn(int, int)
org.apache.poi.hwpf.usermodel.Range.insertAfter(ParagraphProperties, int)
Use code shall not work with ParagraphProperties
org.apache.poi.hwpf.usermodel.Range.insertAfter(ParagraphProperties, int, int, int)
Use code shall not work with ParagraphProperties
org.apache.poi.hwpf.usermodel.Range.insertAfter(ParagraphProperties, int, String)
Use code shall not work with ParagraphProperties
org.apache.poi.hwpf.usermodel.Range.insertAfter(String, CharacterProperties)
User code should not work with CharacterProperties
org.apache.poi.hwpf.usermodel.Range.insertBefore(ParagraphProperties, int)
Use code shall not work with ParagraphProperties
org.apache.poi.hwpf.usermodel.Range.insertBefore(ParagraphProperties, int, int, int)
Use code shall not work with ParagraphProperties
org.apache.poi.hwpf.usermodel.Range.insertBefore(ParagraphProperties, int, String)
Use code shall not work with ParagraphProperties
org.apache.poi.hwpf.usermodel.Range.insertBefore(String, CharacterProperties)
User code should not work with CharacterProperties
org.apache.poi.hwpf.usermodel.Range.insertBefore(TableProperties, int)
Use code shall not work with TableProperties. Use Range.insertTableBefore(short, int) instead
org.apache.poi.hssf.usermodel.HSSFSheet.isColumnHidden(short)
(Sep 2008) use HSSFSheet.isColumnHidden(int)
org.apache.poi.hwpf.model.types.FibBaseAbstractType.isFEmptySpecial()
This field should not be used according to specification
org.apache.poi.hwpf.model.types.FibBaseAbstractType.isFMac()
This field should not be used according to specification
org.apache.poi.hwpf.model.types.FibBaseAbstractType.isReserved1()
This field should not be used according to specification
org.apache.poi.hwpf.model.types.FibBaseAbstractType.isReserved2()
This field should not be used according to specification
org.apache.poi.hwpf.model.types.LVLFAbstractType.isUnused1()
This field should not be used according to specification
org.apache.poi.hwpf.model.types.LSTFAbstractType.isUnused1()
This field should not be used according to specification
org.apache.poi.hwpf.model.types.LSTFAbstractType.isUnused2()
This field should not be used according to specification
org.apache.poi.openxml4j.opc.Package.open(InputStream)
use OPCPackage.open(InputStream)
org.apache.poi.openxml4j.opc.Package.open(String)
use OPCPackage.open(String)
org.apache.poi.openxml4j.opc.Package.open(String, PackageAccess)
use OPCPackage.open(String,PackageAccess)
org.apache.poi.openxml4j.opc.Package.openOrCreate(File)
use OPCPackage.openOrCreate(java.io.File)
org.apache.poi.hpsf.wellknown.SectionIDMap.put(Object, Object)
Use SectionIDMap.put(byte[], PropertyIDMap) instead!
org.apache.poi.util.LittleEndian.putInt(byte[], int)
Use LittleEndian.putInt(byte[], int, int) instead
org.apache.poi.util.LittleEndian.putShort(byte[], short)
Use LittleEndian.putShort(byte[], int, short) instead
org.apache.poi.util.LittleEndian.putUInt(byte[], long)
Use LittleEndian.putUInt(byte[], int, long) instead
org.apache.poi.hssf.record.RecordInputStream.readAllContinuedRemainder()
Best to write a input stream that wraps this one where there is special sub record that may overlap continue records.
org.apache.poi.hssf.usermodel.HSSFWorkbook.resolveNameXText(int, int)
for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.
org.apache.poi.hssf.util.CellRangeAddress8Bit.serialize(int, byte[])
use CellRangeAddress8Bit.serialize(LittleEndianOutput)
org.apache.poi.ss.util.CellRangeAddress.serialize(int, byte[])
use CellRangeAddress.serialize(LittleEndianOutput)
org.apache.poi.hssf.util.HSSFRegionUtil.setBorderBottom(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.hssf.util.HSSFRegionUtil.setBorderLeft(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.hssf.util.HSSFRegionUtil.setBorderRight(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.hssf.util.HSSFRegionUtil.setBorderTop(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.hssf.util.HSSFRegionUtil.setBottomBorderColor(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.xssf.usermodel.XSSFSheet.setCellComment(String, XSSFComment)
since Nov 2009 use XSSFCell.setCellComment(org.apache.poi.ss.usermodel.Comment) instead
org.apache.poi.hssf.usermodel.HSSFCell.setCellNum(short)
(Jan 2008) Doesn't update the row's idea of what cell this is, use HSSFRow.moveCell(HSSFCell, short) instead
org.apache.poi.hssf.usermodel.HSSFComment.setColumn(short)
(Nov 2009) use HSSFComment.setColumn(int) }
org.apache.poi.hssf.usermodel.HSSFSheet.setColumnGroupCollapsed(short, boolean)
(Sep 2008) use HSSFSheet.setColumnGroupCollapsed(int, boolean)
org.apache.poi.hssf.usermodel.HSSFSheet.setColumnHidden(short, boolean)
(Sep 2008) use HSSFSheet.setColumnHidden(int, boolean)
org.apache.poi.hssf.usermodel.HSSFSheet.setColumnWidth(short, short)
(Sep 2008) use HSSFSheet.setColumnWidth(int, int)
org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator.setCurrentRow(HSSFRow)
(Aug 2008) - not needed, since the current row can be derived from the cell
org.apache.poi.hssf.usermodel.HSSFSheet.setDefaultColumnWidth(short)
(Sep 2008) use HSSFSheet.setDefaultColumnWidth(int)
org.apache.poi.hssf.record.WindowOneRecord.setDisplayedTab(short)
- Misleading name - use setFirstVisibleTab()
org.apache.poi.hssf.usermodel.HSSFWorkbook.setDisplayedTab(short)
- Misleading name - use setFirstVisibleTab()
org.apache.poi.hwpf.model.FileInformationBlock.setFcPlcffldAtn(int)
org.apache.poi.hwpf.model.FileInformationBlock.setFcPlcffldEdn(int)
org.apache.poi.hwpf.model.FileInformationBlock.setFcPlcffldFtn(int)
org.apache.poi.hwpf.model.FileInformationBlock.setFcPlcffldHdr(int)
org.apache.poi.hwpf.model.FileInformationBlock.setFcPlcffldHdrtxbx(int)
org.apache.poi.hwpf.model.FileInformationBlock.setFcPlcffldMom(int)
org.apache.poi.hwpf.model.FileInformationBlock.setFcPlcffldTxbx(int)
org.apache.poi.hwpf.model.FileInformationBlock.setLcbPlcffldAtn(int)
org.apache.poi.hwpf.model.FileInformationBlock.setLcbPlcffldEdn(int)
org.apache.poi.hwpf.model.FileInformationBlock.setLcbPlcffldFtn(int)
org.apache.poi.hwpf.model.FileInformationBlock.setLcbPlcffldHdr(int)
org.apache.poi.hwpf.model.FileInformationBlock.setLcbPlcffldHdrtxbx(int)
org.apache.poi.hwpf.model.FileInformationBlock.setLcbPlcffldMom(int)
org.apache.poi.hwpf.model.FileInformationBlock.setLcbPlcffldTxbx(int)
org.apache.poi.hssf.util.HSSFRegionUtil.setLeftBorderColor(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.hssf.record.WindowTwoRecord.setPaged(boolean)
use setActive()
org.apache.poi.hssf.usermodel.HSSFName.setReference(String)
(Nov 2008) Misleading name. Use HSSFName.setRefersToFormula(String) instead.
org.apache.poi.hssf.util.HSSFRegionUtil.setRightBorderColor(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.hssf.record.WindowOneRecord.setSelectedTab(short)
- Misleading name - use setActiveSheetIndex()
org.apache.poi.hssf.usermodel.HSSFWorkbook.setSelectedTab(short)
use setSelectedTab(int)
org.apache.poi.hssf.util.HSSFRegionUtil.setTopBorderColor(short, Region, HSSFSheet, HSSFWorkbook)
(Aug 2008) use CellRangeAddress instead of Region
org.apache.poi.hwpf.model.TextPiece.substring(int, int)
org.apache.poi.hwpf.model.CHPFormattedDiskPage.toByteArray(CharIndexTranslator, int)
Use CHPFormattedDiskPage.toByteArray(CharIndexTranslator) instead
org.apache.poi.hwpf.usermodel.Range.type()
org.apache.poi.hwpf.usermodel.Paragraph.type()
org.apache.poi.hwpf.usermodel.ListEntry.type()
org.apache.poi.hwpf.sprm.TableSprmUncompressor.uncompressTAP(byte[], int)
org.apache.poi.hssf.usermodel.HSSFSheet.ungroupColumn(short, short)
(Sep 2008) use HSSFSheet.ungroupColumn(int, int)
org.apache.poi.hwpf.usermodel.Range.usesUnicode()
Range is not linked to any text piece anymore, so to check if unicode is used please access TextPieceTable during document load time
org.apache.poi.hwpf.model.FontTable.writeTo(HWPFFileSystem)
org.apache.poi.hwpf.model.ComplexFileTable.writeTo(HWPFFileSystem)
org.apache.poi.hwpf.model.PAPBinTable.writeTo(HWPFFileSystem, CharIndexTranslator)
org.apache.poi.hwpf.model.SectionTable.writeTo(HWPFFileSystem, int)
org.apache.poi.hwpf.model.CHPBinTable.writeTo(HWPFFileSystem, int, CharIndexTranslator)

Deprecated Constructors
org.apache.poi.hwpf.model.BytePropertyNode(int, int, CharIndexTranslator, Object)
org.apache.poi.hwpf.model.CHPBinTable(byte[], byte[], int, int, int, TextPieceTable)
Use CHPBinTable.CHPBinTable(byte[], byte[], int, int, CharIndexTranslator) instead
org.apache.poi.hwpf.model.CHPFormattedDiskPage(byte[], int, int, TextPieceTable)
Use CHPFormattedDiskPage.CHPFormattedDiskPage(byte[], int, CharIndexTranslator) instead
org.apache.poi.hwpf.model.CHPX(int, int, CharIndexTranslator, byte[])
org.apache.poi.hwpf.model.CHPX(int, int, CharIndexTranslator, SprmBuffer)
org.apache.poi.hwpf.model.DocumentProperties(byte[], int)
Use DocumentProperties.DocumentProperties(byte[],int,int) instead
org.apache.poi.hssf.extractor.EventBasedExcelExtractor(DirectoryNode, POIFSFileSystem)
Use EventBasedExcelExtractor.EventBasedExcelExtractor(DirectoryNode) instead
org.apache.poi.hssf.extractor.ExcelExtractor(DirectoryNode, POIFSFileSystem)
Use ExcelExtractor.ExcelExtractor(DirectoryNode) instead
org.apache.poi.hwpf.model.FSPATable(byte[], int, int, List)
org.apache.poi.hdgf.HDGFDiagram(DirectoryNode, POIFSFileSystem)
Use HDGFDiagram.HDGFDiagram(DirectoryNode) instead
org.apache.poi.hpbf.HPBFDocument(DirectoryNode, POIFSFileSystem)
Use HPBFDocument.HPBFDocument(DirectoryNode) instead
org.apache.poi.hslf.HSLFSlideShow(DirectoryNode, POIFSFileSystem)
Use HSLFSlideShow.HSLFSlideShow(DirectoryNode) instead
org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator(HSSFSheet, HSSFWorkbook)
(Sep 2008) HSSFSheet parameter is ignored
org.apache.poi.hwpf.HWPFDocument(DirectoryNode, POIFSFileSystem)
Use HWPFDocument.HWPFDocument(DirectoryNode) instead
org.apache.poi.hwpf.HWPFOldDocument(DirectoryNode, POIFSFileSystem)
org.apache.poi.hwpf.model.ListLevel(byte[], int)
org.apache.poi.hsmf.MAPIMessage(DirectoryNode, POIFSFileSystem)
Use MAPIMessage.MAPIMessage(DirectoryNode) instead
org.apache.poi.hwpf.model.OldSectionTable(byte[], int, int, int, TextPieceTable)
Use OldSectionTable.OldSectionTable(byte[],int,int) instead
org.apache.poi.hsmf.extractor.OutlookTextExtactor(DirectoryNode, POIFSFileSystem)
org.apache.poi.openxml4j.opc.Package(PackageAccess)
use OPCPackage
org.apache.poi.hwpf.model.PAPBinTable(byte[], byte[], byte[], int, int, int, TextPieceTable)
Use PAPBinTable.PAPBinTable(byte[], byte[], byte[], int, int, CharIndexTranslator) instead
org.apache.poi.hwpf.model.PAPFormattedDiskPage(byte[])
Use PAPFormattedDiskPage.PAPFormattedDiskPage() instead
org.apache.poi.hwpf.model.PAPFormattedDiskPage(byte[], byte[], int, int, TextPieceTable)
Use PAPFormattedDiskPage.PAPFormattedDiskPage(byte[], byte[], int, CharIndexTranslator) instead
org.apache.poi.hwpf.model.PAPX(int, int, CharIndexTranslator, SprmBuffer, byte[])
org.apache.poi.hwpf.usermodel.Paragraph(int, int, Table)
org.apache.poi.hwpf.usermodel.Paragraph(PAPX, Range)
org.apache.poi.hwpf.usermodel.Paragraph(PAPX, Range, int)
org.apache.poi.hwpf.model.PicturesTable(HWPFDocument, byte[], byte[], FSPATable, EscherRecordHolder)
org.apache.poi.hwpf.model.PlexOfField(int, int, byte[])
org.apache.poi.POIDocument(DirectoryNode, POIFSFileSystem)
use POIDocument.POIDocument(DirectoryNode) instead
org.apache.poi.hslf.extractor.PowerPointExtractor(DirectoryNode, POIFSFileSystem)
Use PowerPointExtractor.PowerPointExtractor(DirectoryNode) instead
org.apache.poi.hpbf.extractor.PublisherTextExtractor(DirectoryNode, POIFSFileSystem)
org.apache.poi.hwpf.usermodel.Range(int, int, int, Range)
org.apache.poi.hwpf.sprm.SprmBuffer()
Use SprmBuffer.SprmBuffer(int) instead
org.apache.poi.hwpf.sprm.SprmBuffer(byte[])
Use SprmBuffer.SprmBuffer(byte[],int) instead
org.apache.poi.hwpf.sprm.SprmBuffer(byte[], boolean)
Use SprmBuffer.SprmBuffer(byte[],boolean,int) instead
org.apache.poi.hwpf.model.TextPiece(int, int, byte[], PieceDescriptor, int)
Use TextPiece.TextPiece(int,int,byte[],PieceDescriptor) instead
org.apache.poi.hssf.record.UnicodeString(RecordInputStream)
Use UnicodeString instead
org.apache.poi.hssf.record.UnicodeString(String)
Use UnicodeString instead
org.apache.poi.hdgf.extractor.VisioTextExtractor(DirectoryNode, POIFSFileSystem)
Use VisioTextExtractor.VisioTextExtractor(DirectoryNode) instead
org.apache.poi.hwpf.extractor.Word6Extractor(DirectoryNode, POIFSFileSystem)
Use Word6Extractor.Word6Extractor(DirectoryNode) instead
org.apache.poi.hwpf.extractor.WordExtractor(DirectoryNode, POIFSFileSystem)
Use WordExtractor.WordExtractor(DirectoryNode) instead
org.apache.poi.xssf.extractor.XSSFExcelExtractor(String)
Use XSSFExcelExtractor.XSSFExcelExtractor(org.apache.poi.openxml4j.opc.OPCPackage) instead.
org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator(XSSFWorkbook, IStabilityClassifier)
(Sep 2009) (reduce overloading) use XSSFFormulaEvaluator.create(XSSFWorkbook, org.apache.poi.ss.formula.IStabilityClassifier, org.apache.poi.ss.formula.udf.UDFFinder)
org.apache.poi.xssf.usermodel.XSSFWorkbook(String)

Deprecated Enum Constants
org.apache.poi.hwpf.model.SubdocumentType.MACRO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help

PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POI API Documentation

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Index

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV NEXT

FRAMES NO FRAMES

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

A

A3_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A3 - 297x420 mm
A4_EXTRA_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A4 Extra - 9.27 x 12.69 in
A4_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A4 - 210x297 mm
A4_PLUS_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A4 Plus - 210x330 mm
A4_ROTATED_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A4 Rotated - 297x210 mm
A4_SIZED_PAPER - Static variable in class org.apache.poi.hslf.record.DocumentAtom.SlideSize

A4_SMALL_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A4 Small - 210x297 mm
A4_TRANSVERSE_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A4 Transverse - 210x297 mm
A5_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
A5 - 148x210 mm
AB_DEFAULT_DIR - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AB_DEFAULT_PAB - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AB_PROVIDER_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AB_PROVIDERS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AB_SEARCH_PATH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AB_SEARCH_PATH_UPDATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AbortableHSSFListener - Class in org.apache.poi.hssf.eventusermodel
Abstract class for use with the HSSFRequest and HSSFEventFactory, which allows for the halting of processing.
AbortableHSSFListener() - Constructor for class org.apache.poi.hssf.eventusermodel.AbortableHSSFListener

abortableProcessEvents(HSSFRequest, InputStream) - Method in class org.apache.poi.hssf.eventusermodel.HSSFEventFactory
Processes a DocumentInputStream into essentially Record events.
abortableProcessRecord(Record) - Method in class org.apache.poi.hssf.eventusermodel.AbortableHSSFListener
Process an HSSF Record.
abortableProcessWorkbookEvents(HSSFRequest, POIFSFileSystem) - Method in class org.apache.poi.hssf.eventusermodel.HSSFEventFactory
Processes a file into essentially record events.
abortableProcessWorkbookEvents(HSSFRequest, DirectoryNode) - Method in class org.apache.poi.hssf.eventusermodel.HSSFEventFactory
Processes a file into essentially record events.
ABS - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

AbsExpression - Class in org.apache.poi.xslf.model.geom
Absolute Value Formula
absoluteDay(Calendar, boolean) - Static method in class org.apache.poi.hssf.usermodel.HSSFDateUtil

absoluteDay(Calendar, boolean) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given a Calendar, return the number of days since 1900/12/31.
AbstractEscherHolderRecord - Class in org.apache.poi.hssf.record
The escher container record is used to hold escher records.
AbstractEscherHolderRecord() - Constructor for class org.apache.poi.hssf.record.AbstractEscherHolderRecord

AbstractEscherHolderRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.AbstractEscherHolderRecord

AbstractEscherOptRecord - Class in org.apache.poi.ddf
Common abstract class for EscherOptRecord and EscherTertiaryOptRecord
AbstractEscherOptRecord() - Constructor for class org.apache.poi.ddf.AbstractEscherOptRecord

AbstractExcelConverter - Class in org.apache.poi.hssf.converter
Common class for ExcelToFoConverter and ExcelToHtmlConverter
AbstractExcelConverter() - Constructor for class org.apache.poi.hssf.converter.AbstractExcelConverter

AbstractExcelUtils - Class in org.apache.poi.hssf.converter
Common class for ExcelToFoUtils and ExcelToHtmlUtils
AbstractExcelUtils() - Constructor for class org.apache.poi.hssf.converter.AbstractExcelUtils

AbstractFunctionPtg - Class in org.apache.poi.ss.formula.ptg
This class provides the base functionality for Excel sheet functions There are two kinds of function Ptgs - tFunc and tFuncVar Therefore, this class will have ONLY two subclasses
AbstractFunctionPtg(int, int, byte[], int) - Constructor for class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

abstractNums - Variable in class org.apache.poi.xwpf.usermodel.XWPFNumbering

AbstractShape - Class in org.apache.poi.hssf.model
An abstract shape is the lowlevel model for a shape.
AbstractShape() - Constructor for class org.apache.poi.hssf.model.AbstractShape

AbstractWordConverter - Class in org.apache.poi.hwpf.converter

AbstractWordConverter() - Constructor for class org.apache.poi.hwpf.converter.AbstractWordConverter

AbstractWordUtils - Class in org.apache.poi.hwpf.converter

AbstractWordUtils() - Constructor for class org.apache.poi.hwpf.converter.AbstractWordUtils

ACCENT_BORDER_CALLOUT_1 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACCENT_BORDER_CALLOUT_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACCENT_BORDER_CALLOUT_3 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACCENT_CALLOUT_1 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACCENT_CALLOUT_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACCENT_CALLOUT_3 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

AccentBorderCallout1 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

AccentBorderCallout2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

AccentBorderCallout3 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

AccentBorderCallout90 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

AccentCallout1 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

AccentCallout2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

AccentCallout3 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

AccentCallout90 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ACCESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ACCESS_LEVEL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ACCOUNT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

accumulate(double, double) - Method in interface org.apache.poi.ss.formula.functions.XYNumericFunction.Accumulator

ACOS - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

ACOSH - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

ACTION_BUTTON_BACK_PREVIOUS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_BEGINNING - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_BLANK - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_DOCUMENT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_END - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_FORWARD_NEXT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_HELP - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_HOME - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_INFORMATION - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_MOVIE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_RETURN - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_BUTTON_SOUND - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ACTION_CUSTOMSHOW - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

ACTION_HYPERLINK - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

ACTION_JUMP - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

ACTION_MACRO - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

ACTION_MEDIA - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

ACTION_NONE - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom
Action Table
ACTION_OLE - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

ACTION_RUNPROGRAM - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

ActionButtonBackPrevious - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonBeginning - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonBlank - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonDocument - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonEnd - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonForwardNext - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonHelp - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonHome - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonInformation - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonMovie - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonReturn - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ActionButtonSound - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ACTIVE_PANE_LOWER_LEFT - Static variable in class org.apache.poi.hssf.record.PaneRecord

ACTIVE_PANE_LOWER_RIGHT - Static variable in class org.apache.poi.hssf.record.PaneRecord

ACTIVE_PANE_UPER_LEFT - Static variable in class org.apache.poi.hssf.record.PaneRecord
Deprecated. use ACTIVE_PANE_UPPER_LEFT
ACTIVE_PANE_UPPER_LEFT - Static variable in class org.apache.poi.hssf.record.PaneRecord

ACTIVE_PANE_UPPER_RIGHT - Static variable in class org.apache.poi.hssf.record.PaneRecord

ACTIVEX_BINS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

ACTIVEX_CONTROLS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

ActiveXShape - Class in org.apache.poi.hslf.model
Represents an ActiveX control in a PowerPoint document.
ActiveXShape(int, int) - Constructor for class org.apache.poi.hslf.model.ActiveXShape
Create a new Picture
ActiveXShape(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.ActiveXShape
Create a Picture object
add(int, Record) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

add(CFRecordsAggregate) - Method in class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

add(TextPiece) - Method in class org.apache.poi.hwpf.model.TextPieceTable

add(UDFFinder) - Method in class org.apache.poi.ss.formula.udf.AggregatingUDFFinder
Add a new toolpack
add(int, int) - Method in class org.apache.poi.util.IntList
add the specfied value at the specified index
add(int) - Method in class org.apache.poi.util.IntList
Appends the specified element to the end of this list
add(T) - Method in class org.apache.poi.util.IntMapper
Appends the specified element to the end of this list
add(int, short) - Method in class org.apache.poi.util.ShortList
add the specfied value at the specified index
add(short) - Method in class org.apache.poi.util.ShortList
Appends the specified element to the end of this list
addAbstractNum(XWPFAbstractNum) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
add a new AbstractNum and return its AbstractNumID
addAll(IntList) - Method in class org.apache.poi.util.IntList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
addAll(int, IntList) - Method in class org.apache.poi.util.IntList
Inserts all of the elements in the specified collection into this list at the specified position.
addAll(ShortList) - Method in class org.apache.poi.util.ShortList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
addAll(int, ShortList) - Method in class org.apache.poi.util.ShortList
Inserts all of the elements in the specified collection into this list at the specified position.
addArea(int, int, int, int) - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable

addArrayRecord(ArrayRecord) - Method in class org.apache.poi.hssf.record.aggregates.SharedValueManager
Add specified Array Record.
addAttribute(TNEFAttribute) - Method in class org.apache.poi.hmef.Attachment

addAuthor(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

addAuthor(String) - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

addBMPHeader(byte[]) - Static method in class org.apache.poi.hslf.blip.DIB

addBold(boolean, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addBorder(BorderCode, String, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addBreak(int, int, int) - Method in class org.apache.poi.hssf.record.PageBreakRecord
Adds the page break at the specified parameters
addBreak() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that a break shall be placed at the current location in the run content.
addBreak(BreakType) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that a break shall be placed at the current location in the run content.
addBreak(BreakClear) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that a break shall be placed at the current location in the run content.
addBSERecord(EscherBSERecord) - Method in class org.apache.poi.hssf.model.InternalWorkbook

addCarriageReturn() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that a carriage return shall be placed at the current location in the run content.
addCell() - Method in class org.apache.poi.xslf.usermodel.XSLFTableRow

addCellOffset(int) - Method in class org.apache.poi.hssf.record.DBCellRecord.Builder

addCellRangeAddress(int, int, int, int) - Method in class org.apache.poi.ss.util.CellRangeAddressList
Add a cell range structure.
addCellRangeAddress(CellRangeAddress) - Method in class org.apache.poi.ss.util.CellRangeAddressList

addChar(char, int) - Method in class org.apache.poi.hssf.usermodel.FontDetails

addCharactersProperties(CharacterRun, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addCharacterTextPropCollection(int) - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Create a new Character TextPropCollection, and add it to the list
addChars(char[], int[]) - Method in class org.apache.poi.hssf.usermodel.FontDetails

addChild(Property) - Method in class org.apache.poi.poifs.property.DirectoryProperty
Add a new child to the collection of children
addChild(Property) - Method in interface org.apache.poi.poifs.property.Parent
Add a new child to the collection of children
addChildAfter(Record, Record) - Method in class org.apache.poi.hslf.record.RecordContainer
Adds the given Child Record after the supplied record
addChildBefore(EscherRecord, int) - Method in class org.apache.poi.ddf.EscherContainerRecord

addChildBefore(Record, Record) - Method in class org.apache.poi.hslf.record.RecordContainer
Adds the given Child Record before the supplied record
addChildRecord(EscherRecord) - Method in class org.apache.poi.ddf.EscherContainerRecord

addChildRecord(EscherRecord) - Method in class org.apache.poi.ddf.UnknownEscherRecord

addCleanColIntoCols(CTCols, CTCol) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

addCluster(int, int) - Method in class org.apache.poi.ddf.EscherDggRecord

addCluster(int, int, boolean) - Method in class org.apache.poi.ddf.EscherDggRecord
Add a new cluster
addColor(byte, byte, byte) - Method in class org.apache.poi.hssf.usermodel.HSSFPalette
Adds a new color into an empty color slot.
addCommand(PathCommand) - Method in class org.apache.poi.xslf.model.geom.Path

addConditionalFormatting(HSSFConditionalFormatting) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
Adds a copy of HSSFConditionalFormatting object to the sheet
addConditionalFormatting(ConditionalFormatting) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

addConditionalFormatting(Region[], HSSFConditionalFormattingRule[]) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
Deprecated. use CellRangeAddress instead of Region
addConditionalFormatting(CellRangeAddress[], HSSFConditionalFormattingRule[]) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
Allows to add a new Conditional Formatting set to the sheet.
addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule[]) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

addConditionalFormatting(CellRangeAddress[], HSSFConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

addConditionalFormatting(CellRangeAddress[], HSSFConditionalFormattingRule, HSSFConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule, ConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Add a new Conditional Formatting to the sheet.
addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule, ConditionalFormattingRule) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Add a new Conditional Formatting consisting of two rules.
addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule[]) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Add a new Conditional Formatting set to the sheet.
addConditionalFormatting(ConditionalFormatting) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Adds a copy of a ConditionalFormatting object to the sheet
addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule[]) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting

addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting

addConditionalFormatting(CellRangeAddress[], ConditionalFormattingRule, ConditionalFormattingRule) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting

addConditionalFormatting(ConditionalFormatting) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting
Adds a copy of HSSFConditionalFormatting object to the sheet
addContentType(PackagePartName, String) - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Build association extention-> content type (will be stored in [Content_Types].xml) for example ContentType="image/png" Extension="png"
addControl(String, String) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Add a control in this presentation
addDataValidation(DVRecord) - Method in class org.apache.poi.hssf.record.aggregates.DataValidityTable

addDbcell(int) - Method in class org.apache.poi.hssf.record.IndexRecord

addDescription(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

addDescription(String) - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

AddDivideExpression - Class in org.apache.poi.xslf.model.geom
Add Divide Formula
addEndnote(CTFtnEdn) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

addEntry(CTRst) - Method in class org.apache.poi.xssf.model.SharedStringsTable
Add an entry to this Shared String table (a new value is appened to the end).
addEscherProperty(EscherProperty) - Method in class org.apache.poi.ddf.AbstractEscherOptRecord
Add a property to this record.
addEscherRecord(int, EscherRecord) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

addEscherRecord(EscherRecord) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

AddEval - Static variable in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

addExternalRelationship(String, String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Adds an external relationship to a part (except relationships part).
addExternalRelationship(String, String, String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Adds an external relationship to a part (except relationships part).
addExternalRelationship(String, String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Adds an external relationship to a part (except relationships part).
addExternalRelationship(String, String, String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Adds an external relationship to a part (except relationships part).
addExternalRelationship(String, String) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Adds an external relationship to a part (except relationships part).
addExternalRelationship(String, String, String) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Adds an external relationship to a part (except relationships part).
addFlowToPageSequence(Element, String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addFont(String) - Method in class org.apache.poi.hslf.record.FontCollection
Add font with the specified name to the font collection.
addFont(String, int, int, int, int) - Method in class org.apache.poi.hslf.record.FontCollection

addFont(PPFont) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Add a font in this presentation
addFontFamily(String, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addFontSize(int, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addFooterAtom() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
Insert a CString record that stores the user's date.
addFootnote(CTFtnEdn) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

addFootnote(XWPFFootnote) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes
add an XWPFFootnote to the document
addFootnote(CTFtnEdn) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes
add a footnote to the document
addFormat(String, Format) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Adds a new format to the available formats.
addFormatRun(UnicodeString.FormatRun) - Method in class org.apache.poi.hssf.record.common.UnicodeString
Adds a font run to the formatted string.
addHeaderAtom() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
Insert a CString record that stores the user's date.
addHyperlink(Hyperlink) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Add a hyperlink to this presentation
addHyperlink(XSSFHyperlink) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Register a hyperlink in the collection of hyperlinks on this sheet
addIndent(Paragraph, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addJustification(Paragraph, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addKeywords(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

addKeywords(String) - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

addLateHeaderFooter(HeaderFooterRecord) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
HEADERFOOTER is new in 2007.
addLateRecords(RecordStream) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
This method reads PageSettingsBlock records from the supplied RecordStream until the first non-PageSettingsBlock record is encountered.
addLineBreak() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Insert a line break
addList(ListData, ListFormatOverride) - Method in class org.apache.poi.hwpf.model.ListTables

addListener(HSSFListener, short) - Method in class org.apache.poi.hssf.eventusermodel.HSSFRequest
add an event listener for a particular record type.
addListenerForAllRecords(HSSFListener) - Method in class org.apache.poi.hssf.eventusermodel.HSSFRequest
This is the equivalent of calling addListener(myListener, sid) for EVERY record in the org.apache.poi.hssf.record package.
addListItem(Element) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addListItemBody(Element) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addListItemLabel(Element, String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addMarshaller(String, PartMarshaller) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Add a marshaller.
addMergedRegion(int, int, int, int) - Method in class org.apache.poi.hssf.model.InternalSheet

addMergedRegion(Region) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Aug-2008) use CellRangeAddress instead of Region
addMergedRegion(CellRangeAddress) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
adds a merged region of cells (hence those cells form one)
addMergedRegion(CellRangeAddress) - Method in interface org.apache.poi.ss.usermodel.Sheet
Adds a merged region of cells (hence those cells form one)
addMergedRegion(CellRangeAddress) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Adds a merged region of cells (hence those cells form one)
addMergedRegion(CellRangeAddress) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Adds a merged region of cells (hence those cells form one).
addMeta(String, String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

addMeta(String, String) - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

addMovie(String, int) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Add a movie in this presentation
addMultipleBlanks(MulBlankRecord) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

addName(NameRecord) - Method in class org.apache.poi.hssf.model.InternalWorkbook
creates new name
addNewCol() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
add a new column for each row in this table
addNewParagraph(CTP) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
add a new paragraph to the end of the footnote
addNewRowBetween(int, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

addNewTableCell() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
adds a new TableCell at the end of this tableRow
addNewTbl(CTTbl) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
add a new table to the end of the footnote
addNewTextParagraph() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
add a new paragraph run to this shape
addNewTextRun() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Add a new run of text
addNum(XWPFNum) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
add a new number to the numbering document
addNum(BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
Add a new num with an abstractNumID
addNum(BigInteger, BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
Add a new num with an abstractNumID and a numID
addPackagePart(PackagePart) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Add the specified part to the package.
addPageSequence(Element) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addPageSequence(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addParagraph() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
Add a Paragraph to this Table Cell
addParagraph(XWPFParagraph) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
add a Paragraph to this TableCell
addParagraphProperties(Paragraph, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addParagraphTextPropCollection(int) - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Create a new Paragraph TextPropCollection, and add it to the list
addPicture(PictureData) - Method in class org.apache.poi.hslf.HSLFSlideShow
Add a new picture to this presentation.
addPicture(byte[], int) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Adds a picture to this presentation and returns the associated index.
addPicture(File, int) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Adds a picture to this presentation and returns the associated index.
addPicture(byte[], int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Adds a picture to the workbook.
addPicture(byte[], int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Adds a picture to the workbook.
addPicture(byte[], int) - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Adds a picture to the workbook.
addPicture(byte[], int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Adds a picture to the workbook.
addPicture(byte[], int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Adds a picture to the workbook.
addPicture(InputStream, int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Adds a picture to the workbook.
addPicture(InputStream, int, String, int, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Adds a picture to the run.
addPictureData(PictureData) - Method in interface org.apache.poi.sl.usermodel.Resources

addPictureData(byte[], int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

addPictureData(InputStream, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

addPictureData(byte[], int) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
Adds a picture to the document.
addPictureData(InputStream, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
Adds a picture to the document.
addPictureReference(int) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Add the indexed picture to this drawing relations
addProperty(GenericPropertyNode) - Method in class org.apache.poi.hwpf.model.PlexOfCps

addProperty(Property) - Method in class org.apache.poi.poifs.property.PropertyTableBase
Add a property to the list of properties we manage
addProperty(String, String) - Method in class org.apache.poi.POIXMLProperties.CustomProperties
Add a new string property
addProperty(String, double) - Method in class org.apache.poi.POIXMLProperties.CustomProperties
Add a new double property
addProperty(String, int) - Method in class org.apache.poi.POIXMLProperties.CustomProperties
Add a new integer property
addProperty(String, boolean) - Method in class org.apache.poi.POIXMLProperties.CustomProperties
Add a new boolean property
AddPtg - Class in org.apache.poi.ss.formula.ptg
Addition operator PTG the "+" binomial operator.
addRecords(MergeCellsRecord[]) - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable

addRecords(RecordStream) - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock
This method reads WorksheetProtectionBlock records from the supplied RecordStream until the first non-WorksheetProtectionBlock record is encountered.
addRef(int, int, int) - Method in class org.apache.poi.hssf.record.ExternSheetRecord
Add a zero-based reference to a SupBookRecord.
addREFRecord(ExternSheetRecord.RefSubRecord) - Method in class org.apache.poi.hssf.record.ExternSheetRecord
adds REF struct (ExternSheetSubRecord)
addRegionBody(Element) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addRelation(String, POIXMLDocumentPart) - Method in class org.apache.poi.POIXMLDocumentPart
Add a new child POIXMLDocumentPart
addRelationship(PackagePartName, TargetMode, String, String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Add a relationship to the package (except relationships part).
addRelationship(PackagePartName, TargetMode, String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Add a package relationship.
addRelationship(PackagePartName, TargetMode, String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Add a relationship to a part (except relationships part).
addRelationship(PackagePartName, TargetMode, String, String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Add a relationship to a part (except relationships part).
addRelationship(URI, TargetMode, String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Add a relationship to a part (except relationships part).
addRelationship(URI, TargetMode, String, String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Add a relationship to a part (except relationships part).
addRelationship(PackageRelationship) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Add the specified relationship to the collection.
addRelationship(URI, TargetMode, String, String) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Add a relationship to the collection.
addRelationship(PackagePartName, TargetMode, String) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Add a relationship to a part (except relationships part).
addRelationship(PackagePartName, TargetMode, String, String) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Add a relationship to a part (except relationships part).
addRenderingHints(Map) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the values of an arbitrary number of preferences for the rendering algorithms.
addRenderingHints(Map) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

addRenderingHints(Map) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

address - Variable in class org.apache.poi.hdgf.pointers.Pointer

Address - Class in org.apache.poi.ss.formula.functions
Creates a text reference as text, given specified row and column numbers.
Address() - Constructor for class org.apache.poi.ss.formula.functions.Address

addRow(RowRecord) - Method in class org.apache.poi.hssf.model.InternalSheet
Adds a row record to the sheet
addRow() - Method in class org.apache.poi.xslf.usermodel.XSLFTable

addRow(int, String, int, String) - Method in class org.apache.poi.xwpf.usermodel.TOC

addRow(XWPFTableRow) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
add a new Row to the table
addRow(XWPFTableRow, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
add a new Row to the table at position pos
ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

addRule(CFRuleRecord) - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

addRule(HSSFConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting
add a Conditional Formatting rule.
addRule(ConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

addRule(ConditionalFormattingRule) - Method in interface org.apache.poi.ss.usermodel.ConditionalFormatting
Add a Conditional Formatting rule.
addRule(ConditionalFormattingRule) - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormatting
Add a Conditional Formatting rule.
addRun(CTR) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
add a new run at the end of the position of the content of parameter run
addRun(XWPFRun) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
adds a new Run to the Paragraph
addSection(Section) - Method in class org.apache.poi.hpsf.MutablePropertySet
Adds a section to this property set.
addSection(Section) - Method in class org.apache.poi.hpsf.SpecialPropertySet

addSerie(ChartDataSource<?>, ChartDataSource<? extends Number>) - Method in interface org.apache.poi.ss.usermodel.charts.ScatterChartData

addSerie(ChartDataSource<?>, ChartDataSource<? extends Number>) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData

addShape(Shape) - Method in class org.apache.poi.hslf.model.ShapeGroup
Add a shape to this group.
addShape(Shape) - Method in class org.apache.poi.hslf.model.Sheet
Add a new Shape to this Slide
addShape(HSSFShape) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
add a shape to this drawing
addShape(HSSFShape) - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup

addShape(Shape) - Method in interface org.apache.poi.sl.usermodel.ShapeContainer

addSheetReference(String, int) - Method in class org.apache.poi.ss.util.SheetReferences

addSimplePageMaster(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

addSlideListWithText(SlideListWithText) - Method in class org.apache.poi.hslf.record.Document
Adds a new SlideListWithText record, at the appropriate point in the child records.
addSlideLookup(int, int) - Method in class org.apache.poi.hslf.record.PersistPtrHolder
Adds a new slide, notes or similar, to be looked up by this.
addSlidePersistAtom(SlidePersistAtom) - Method in class org.apache.poi.hslf.record.SlideListWithText
Add a new SlidePersistAtom, to the end of the current list, and update the internal list of SlidePersistAtoms
addSpecialSprm(short, byte[], List<byte[]>) - Static method in class org.apache.poi.hwpf.sprm.SprmUtils

addSprm(short, byte) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

addSprm(short, byte[]) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

addSprm(short, int) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

addSprm(short, short) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

addSprm(short, boolean, List<byte[]>) - Static method in class org.apache.poi.hwpf.sprm.SprmUtils

addSprm(short, int, byte[], List<byte[]>) - Static method in class org.apache.poi.hwpf.sprm.SprmUtils

addSSTString(UnicodeString) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Adds a string to the SST table and returns its index (if its a duplicate just returns its index and update the counts) ASSUMES compressed unicode (meaning 8bit)
addSSTString(String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. Do not call this method from your applications. Use the methods available in the HSSFRow to add string HSSFCells
addStandardOptions(HSSFShape, EscherOptRecord) - Method in class org.apache.poi.hssf.model.AbstractShape
Add standard properties to the opt record.
addStandardOptions(HSSFShape, EscherOptRecord) - Method in class org.apache.poi.hssf.model.CommentShape
Sets standard escher options for a comment.
addString(UnicodeString) - Method in class org.apache.poi.hssf.record.SSTRecord
Add a string.
addStyle(XWPFStyle) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
add a style to the document
addStyleClass(Element, String, String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

addSubRecord(int, SubRecord) - Method in class org.apache.poi.hssf.record.ObjRecord

addSubRecord(SubRecord) - Method in class org.apache.poi.hssf.record.ObjRecord

AddSubtractExpression - Class in org.apache.poi.xslf.model.geom
Add Subtract Formula
addTableCellProperties(TableRow, TableCell, boolean, boolean, boolean, boolean, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addTableRowProperties(TableRow, StringBuilder) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlUtils

addTextboxWrapper(EscherTextboxWrapper) - Method in class org.apache.poi.hslf.record.PPDrawing
Add a new EscherTextboxWrapper to this PPDrawing.
addThumbnail(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Add a thumbnail to the package.
addTitle() - Method in class org.apache.poi.hslf.model.Slide
Create a TextBox object that represents the slide's title.
addToolPack(UDFFinder) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Register a new toolpack in this workbook.
addToolPack(UDFFinder) - Method in interface org.apache.poi.ss.usermodel.Workbook
Register a new toolpack in this workbook.
addToolPack(UDFFinder) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Register a new toolpack in this workbook.
addToolPack(UDFFinder) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Register a new toolpack in this workbook.
addUnmarshaller(String, PartUnmarshaller) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Add an unmarshaller.
addUserDateAtom() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
Insert a CString record that stores the user's date.
addValidationData(DataValidation) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Creates a data validation object
addValidationData(DataValidation) - Method in interface org.apache.poi.ss.usermodel.Sheet
Creates a data validation object
addValidationData(DataValidation) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Creates a data validation object
addValidationData(DataValidation) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

addValueRecord(int, CellValueRecordInterface) - Method in class org.apache.poi.hssf.model.InternalSheet
Adds a value record to the sheet's contained binary records (i.e.
addWithName(String) - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection
Add the TextProp with this name to the list
adjustDictionaryOffset(int) - Method in class org.apache.poi.hdgf.HDGFLZW
We have a slight shift by 18 bytes
adjustDictionaryOffset(int) - Method in class org.apache.poi.hmef.CompressedRTF
We use regular dictionary offsets, so no need to change anything
adjustDictionaryOffset(int) - Method in class org.apache.poi.util.LZWDecompresser
Adjusts the position offset if needed when looking something up in the dictionary.
adjustFIB(int) - Method in class org.apache.poi.hwpf.usermodel.Range
Adjust the value of the various FIB character count fields, eg FIB.CCPText after an insert or a delete...
adjustForDelete(int, int, int) - Method in class org.apache.poi.hwpf.model.CHPBinTable

adjustForDelete(int, int, int) - Method in class org.apache.poi.hwpf.model.PAPBinTable

adjustForDelete(int, int) - Method in class org.apache.poi.hwpf.model.PropertyNode
Adjust for a deletion that can span multiple PropertyNodes.
adjustForDelete(int, int) - Method in class org.apache.poi.hwpf.model.TextPiece
Deprecated.
adjustForInsert(int, int) - Method in class org.apache.poi.hwpf.model.CHPBinTable

adjustForInsert(int, int) - Method in class org.apache.poi.hwpf.model.PAPBinTable

adjustForInsert(int, int) - Method in class org.apache.poi.hwpf.model.SectionTable

adjustForInsert(int, int) - Method in class org.apache.poi.hwpf.model.TextPieceTable
Adjust all the text piece after inserting some text into one of them
adjustFormula(Ptg[], int) - Method in class org.apache.poi.ss.formula.FormulaShifter

AdjustValue - Class in org.apache.poi.xslf.model.geom
Represents a shape adjust values (see section 20.1.9.5 in the spec)
AdjustValue(CTGeomGuide) - Constructor for class org.apache.poi.xslf.model.geom.AdjustValue

advance - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

afterDelete(int, int) - Method in class org.apache.poi.hwpf.model.BookmarksTables

afterInsert(Sheet) - Method in class org.apache.poi.hslf.model.ActiveXShape

afterInsert(Sheet) - Method in class org.apache.poi.hslf.model.Fill

afterInsert(Sheet) - Method in class org.apache.poi.hslf.model.Picture
By default set the orininal image size
afterInsert(Sheet) - Method in class org.apache.poi.hslf.model.Shape
Event which fires when a shape is inserted in the sheet.
afterInsert(Sheet) - Method in class org.apache.poi.hslf.model.Table

afterInsert(Sheet) - Method in class org.apache.poi.hslf.model.TextShape
When a textbox is added to a sheet we need to tell upper-level PPDrawing about it.
afterInsert(int, int) - Method in class org.apache.poi.hwpf.model.BookmarksTables

afterProcess() - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter
Special actions that need to be called after processing complete, like updating stylesheets or building document notes list.
afterProcess() - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

afterProcess() - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

afterRecordSerialize(int, short, int, EscherRecord) - Method in interface org.apache.poi.ddf.EscherSerializationListener
Fired after a record has been serialized.
afterRecordSerialize(int, short, int, EscherRecord) - Method in class org.apache.poi.ddf.NullEscherSerializationListener

aggregateDrawingRecords(DrawingManager2, boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
Finds the DrawingRecord for our sheet, and attaches it to the DrawingManager (which knows about the overall DrawingGroup for our workbook).
AggregateFunction - Class in org.apache.poi.ss.formula.functions

AggregateFunction() - Constructor for class org.apache.poi.ss.formula.functions.AggregateFunction

AggregatingUDFFinder - Class in org.apache.poi.ss.formula.udf
Collects add-in libraries and VB macro functions together into one UDF finder
AggregatingUDFFinder(UDFFinder...) - Constructor for class org.apache.poi.ss.formula.udf.AggregatingUDFFinder

AgileDecryptor - Class in org.apache.poi.poifs.crypt

AgileDecryptor(EncryptionInfo) - Constructor for class org.apache.poi.poifs.crypt.AgileDecryptor

ALGORITHM_AES_128 - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

ALGORITHM_AES_192 - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

ALGORITHM_AES_256 - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

ALGORITHM_RC4 - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

ALIGN_CENTER - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
center horizontal alignment
ALIGN_CENTER_SELECTION - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
center-selection? horizontal alignment
ALIGN_FILL - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
fill? horizontal alignment
ALIGN_GENERAL - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
general (normal) horizontal alignment
ALIGN_JUSTIFY - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
justified horizontal alignment
ALIGN_LEFT - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
left-justified horizontal alignment
ALIGN_RIGHT - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
right-justified horizontal alignment
AlignCenter - Static variable in class org.apache.poi.hslf.model.TextShape

AlignJustify - Static variable in class org.apache.poi.hslf.model.TextShape

AlignLeft - Static variable in class org.apache.poi.hslf.model.TextShape
How to align the text
ALIGNMENT - Static variable in class org.apache.poi.ss.util.CellUtil

AlignmentTextProp - Class in org.apache.poi.hslf.model.textproperties
Definition for the alignment text property.
AlignmentTextProp() - Constructor for class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

AlignRight - Static variable in class org.apache.poi.hslf.model.TextShape

allCellsIterator() - Method in class org.apache.poi.xssf.streaming.SXSSFRow

allocateShapeId() - Method in class org.apache.poi.hslf.model.Sheet
Allocates new shape id for the new drawing group id.
allocateShapeId(short) - Method in class org.apache.poi.hssf.model.DrawingManager
Allocates new shape id for the new drawing group id.
allocateShapeId(short) - Method in class org.apache.poi.hssf.model.DrawingManager2
Allocates new shape id for the new drawing group id.
allocateShapeId(short, EscherDgRecord) - Method in class org.apache.poi.hssf.model.DrawingManager2
Allocates new shape id for the new drawing group id.
allocateSpace(int) - Method in class org.apache.poi.poifs.storage.BlockAllocationTableWriter
Allocate space for a block of indices
ALT_BARS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Wide dots
ALT_BARS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

ALT_BARS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Wide dots
ALT_BARS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Wide dots
ALTERNATE_RECIPIENT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ALTERNATE_RECIPIENT_ALLOWED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

altLangId - Variable in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

AnalysisToolPak - Class in org.apache.poi.ss.formula.atp

anchor - Variable in class org.apache.poi.xssf.usermodel.XSSFShape
anchor that is used by this shape
ANCHOR_ID_CHART_TITLE - Static variable in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

ANCHOR_ID_SERIES_OR_POINT - Static variable in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

ANCHOR_ID_X_AXIS - Static variable in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

ANCHOR_ID_Y_AXIS - Static variable in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

ANCHOR_ID_Z_AXIS - Static variable in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

anchorBorder(int, Line) - Method in class org.apache.poi.hslf.model.TableCell

AnchorBottom - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorBottomBaseline - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorBottomCentered - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorBottomCenteredBaseline - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorMiddle - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorMiddleCentered - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorTop - Static variable in class org.apache.poi.hslf.model.TextShape
How to anchor the text
AnchorTopBaseline - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorTopCentered - Static variable in class org.apache.poi.hslf.model.TextShape

AnchorTopCenteredBaseline - Static variable in class org.apache.poi.hslf.model.TextShape

AND - Static variable in class org.apache.poi.ss.formula.functions.BooleanFunction

AnimateBg - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
whether the background of the shape is animated
AnimationInfo - Class in org.apache.poi.hslf.record
A container record that specifies information about animation information for a shape.
AnimationInfo(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.AnimationInfo
Set things up, and find our more interesting children
AnimationInfo() - Constructor for class org.apache.poi.hslf.record.AnimationInfo
Create a new AnimationInfo, with blank fields
AnimationInfo - Static variable in class org.apache.poi.hslf.record.RecordTypes

AnimationInfoAtom - Class in org.apache.poi.hslf.record
An atom record that specifies the animation information for a shape.
AnimationInfoAtom() - Constructor for class org.apache.poi.hslf.record.AnimationInfoAtom
Constructs a brand new link related atom record.
AnimationInfoAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.AnimationInfoAtom
Constructs the link related atom record from its source data.
AnimationInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ANR - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ANSI_CHARSET - Static variable in class org.apache.poi.hslf.model.PPFont
ANSI character set
ANSI_CHARSET - Static variable in interface org.apache.poi.ss.usermodel.Font
ANSI character set
ANY - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
'Any value' type - value not restricted
APMHEADER_KEY - Static variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

APP_TIME - Static variable in class org.apache.poi.hsmf.datatypes.Types
AppTime - application time value
append(RecordBase) - Method in class org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

append(byte[]) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

append(byte[], int) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

append(String, XSSFFont) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Append new text to this text run and apply the specify font to it
append(String) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Append new text to this text run
appendAlign(StringBuilder, short) - Static method in class org.apache.poi.hssf.converter.ExcelToHtmlUtils

appendChildRecord(Record) - Method in class org.apache.poi.hslf.record.RecordContainer
Add a new child record onto a record's list of children.
appendContent(XSLFSheet) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Append content to this sheet.
appendFormat(StringBuffer, String) - Static method in class org.apache.poi.ss.formula.SheetNameFormatter
Convenience method for (SheetNameFormatter.format(String)) when a StringBuffer is already available.
appendFormat(StringBuffer, String, String) - Static method in class org.apache.poi.ss.formula.SheetNameFormatter

appendRootLevelRecord(Record) - Method in class org.apache.poi.hslf.HSLFSlideShow
Adds a new root level record, at the end, but before the last PersistPtrIncrementalBlock.
appendText(String) - Method in class org.apache.poi.hslf.model.TextRun
Adds the supplied text onto the end of the TextRun, creating a new RichTextRun (returned) for it to sit in.
appendValueText(StringBuilder) - Method in class org.apache.poi.hssf.record.BoolErrRecord

appendValueText(StringBuilder) - Method in class org.apache.poi.hssf.record.CellRecord
Append specific debug info (used by CellRecord.toString() for the value contained in this record.
appendValueText(StringBuilder) - Method in class org.apache.poi.hssf.record.FormulaRecord

appendValueText(StringBuilder) - Method in class org.apache.poi.hssf.record.LabelSSTRecord

appendValueText(StringBuilder) - Method in class org.apache.poi.hssf.record.NumberRecord

appendValueText(StringBuilder) - Method in class org.apache.poi.hssf.record.RKRecord

applies(Object) - Method in class org.apache.poi.ss.format.CellFormatPart
Returns true if this format part applies to the given value.
applies - Variable in class org.apache.poi.ss.format.CellFormatResult
This is true if no condition was given that applied to the value, or if the condition is satisfied.
apply(Object) - Method in class org.apache.poi.ss.format.CellFormat
Returns the result of applying the format to the given value.
apply(Cell) - Method in class org.apache.poi.ss.format.CellFormat
Fetches the appropriate value from the cell, and returns the result of applying it to the appropriate format.
apply(JLabel, Object) - Method in class org.apache.poi.ss.format.CellFormat
Uses the result of applying this format to the value, setting the text and color of a label before returning the result.
apply(JLabel, Cell) - Method in class org.apache.poi.ss.format.CellFormat
Fetches the appropriate value from the cell, and uses the result, setting the text and color of a label before returning the result.
apply(Object) - Method in class org.apache.poi.ss.format.CellFormatPart
Apply this format part to the given value.
apply(JLabel, Object) - Method in class org.apache.poi.ss.format.CellFormatPart
Apply this format part to the given value, applying the result to the given label.
applyFont(int, int, short) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Applies a font to the specified characters of a string.
applyFont(int, int, Font) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Applies a font to the specified characters of a string.
applyFont(Font) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Sets the font of the entire string.
applyFont(short) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Applies the specified font to the entire string.
applyFont(int, int, short) - Method in interface org.apache.poi.ss.usermodel.RichTextString
Applies a font to the specified characters of a string.
applyFont(int, int, Font) - Method in interface org.apache.poi.ss.usermodel.RichTextString
Applies a font to the specified characters of a string.
applyFont(Font) - Method in interface org.apache.poi.ss.usermodel.RichTextString
Sets the font of the entire string.
applyFont(short) - Method in interface org.apache.poi.ss.usermodel.RichTextString
Applies the specified font to the entire string.
applyFont(int, int, short) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Applies a font to the specified characters of a string.
applyFont(int, int, Font) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Applies a font to the specified characters of a string.
applyFont(Font) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Sets the font of the entire string.
applyFont(short) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Applies the specified font to the entire string.
applyPaint(SimpleShape) - Method in class org.apache.poi.hslf.model.PPGraphics2D

applyStroke(SimpleShape) - Method in class org.apache.poi.hslf.model.PPGraphics2D

applyTransform(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Apply 2-D transforms before drawing this shape.
Arc - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ARC - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ArcTanExpression - Class in org.apache.poi.xslf.model.geom
Date: 10/24/11
ArcToCommand - Class in org.apache.poi.xslf.model.geom
ArcTo command within a shape path in DrawingML: Where wr and wh are the height and width radiuses of the supposed circle being used to draw the arc.
Area2DPtgBase - Class in org.apache.poi.ss.formula.ptg
Common superclass of 2-D area refs
Area2DPtgBase(int, int, int, int, boolean, boolean, boolean, boolean) - Constructor for class org.apache.poi.ss.formula.ptg.Area2DPtgBase

Area2DPtgBase(AreaReference) - Constructor for class org.apache.poi.ss.formula.ptg.Area2DPtgBase

Area2DPtgBase(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.Area2DPtgBase

Area3DPtg - Class in org.apache.poi.ss.formula.ptg
Title: Area 3D Ptg - 3D reference (Sheet + Area)
Area3DPtg(String, int) - Constructor for class org.apache.poi.ss.formula.ptg.Area3DPtg

Area3DPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.Area3DPtg

Area3DPtg(int, int, int, int, boolean, boolean, boolean, boolean, int) - Constructor for class org.apache.poi.ss.formula.ptg.Area3DPtg

Area3DPtg(AreaReference, int) - Constructor for class org.apache.poi.ss.formula.ptg.Area3DPtg

AreaErrPtg - Class in org.apache.poi.ss.formula.ptg
AreaErr - handles deleted cell area references.
AreaErrPtg() - Constructor for class org.apache.poi.ss.formula.ptg.AreaErrPtg

AreaErrPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.AreaErrPtg

AreaEval - Interface in org.apache.poi.ss.formula.eval

AreaEvalBase - Class in org.apache.poi.ss.formula.eval

AreaEvalBase(int, int, int, int) - Constructor for class org.apache.poi.ss.formula.eval.AreaEvalBase

AreaEvalBase(AreaI) - Constructor for class org.apache.poi.ss.formula.eval.AreaEvalBase

AreaFormatRecord - Class in org.apache.poi.hssf.record.chart
The area format record is used to define the colours and patterns for an area.

AreaFormatRecord() - Constructor for class org.apache.poi.hssf.record.chart.AreaFormatRecord

AreaFormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.AreaFormatRecord

AreaI - Interface in org.apache.poi.ss.formula.ptg
Common interface for AreaPtg and Area3DPtg, and their child classes.
AreaI.OffsetArea - Class in org.apache.poi.ss.formula.ptg

AreaI.OffsetArea(int, int, int, int, int, int) - Constructor for class org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

AreaNPtg - Class in org.apache.poi.ss.formula.ptg
Specifies a rectangular area of cells A1:A4 for instance.
AreaNPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.AreaNPtg

AreaPtg - Class in org.apache.poi.ss.formula.ptg
Specifies a rectangular area of cells A1:A4 for instance.
AreaPtg(int, int, int, int, boolean, boolean, boolean, boolean) - Constructor for class org.apache.poi.ss.formula.ptg.AreaPtg

AreaPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.AreaPtg

AreaPtg(String) - Constructor for class org.apache.poi.ss.formula.ptg.AreaPtg

AreaPtg(AreaReference) - Constructor for class org.apache.poi.ss.formula.ptg.AreaPtg

AreaPtgBase - Class in org.apache.poi.ss.formula.ptg
Specifies a rectangular area of cells A1:A4 for instance.
AreaPtgBase() - Constructor for class org.apache.poi.ss.formula.ptg.AreaPtgBase

AreaPtgBase(AreaReference) - Constructor for class org.apache.poi.ss.formula.ptg.AreaPtgBase

AreaPtgBase(int, int, int, int, boolean, boolean, boolean, boolean) - Constructor for class org.apache.poi.ss.formula.ptg.AreaPtgBase

AreaRecord - Class in org.apache.poi.hssf.record.chart
The area record is used to define a area chart.

AreaRecord() - Constructor for class org.apache.poi.hssf.record.chart.AreaRecord

AreaRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.AreaRecord

AreaReference - Class in org.apache.poi.hssf.util

AreaReference(String) - Constructor for class org.apache.poi.hssf.util.AreaReference
Create an area ref from a string representation.
AreaReference(CellReference, CellReference) - Constructor for class org.apache.poi.hssf.util.AreaReference
Creates an area ref from a pair of Cell References.
AreaReference - Class in org.apache.poi.ss.util

AreaReference(String) - Constructor for class org.apache.poi.ss.util.AreaReference
Create an area ref from a string representation.
AreaReference(CellReference, CellReference) - Constructor for class org.apache.poi.ss.util.AreaReference
Creates an area ref from a pair of Cell References.
areDirectoriesIdentical(DirectoryEntry, DirectoryEntry) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Checks to see if the two Directories hold the same contents.
areDocumentsIdentical(DocumentEntry, DocumentEntry) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Checks to see if two Documents have the same name and the same contents.
areFieldsStripped() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Are fields currently being stripped from the text that this HeaderStories returns? Default is false, but can be changed
areFieldsStripped() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
Are fields currently being stripped from the text that this XSSFHeaderFooter returns? Default is false, but can be changed
ARIAL - Static variable in class org.apache.poi.hslf.model.PPFont

ARRAY - Static variable in class org.apache.poi.ss.formula.FormulaType

arraycopy(byte[], int, byte[], int, int) - Static method in class org.apache.poi.util.ArrayUtil
This is really a debugging version of System.arraycopy().
arrayMoveWithin(Object[], int, int, int) - Static method in class org.apache.poi.util.ArrayUtil
Moves a number of entries in an array to another point in the array, shifting those inbetween as required.
ArrayPtg - Class in org.apache.poi.ss.formula.ptg
ArrayPtg - handles arrays The ArrayPtg is a little weird, the size of the Ptg when parsing initially only includes the Ptg sid and the reserved bytes.
ArrayPtg(Object[][]) - Constructor for class org.apache.poi.ss.formula.ptg.ArrayPtg

ArrayRecord - Class in org.apache.poi.hssf.record
ARRAY (0x0221)
Treated in a similar way to SharedFormulaRecord
ArrayRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ArrayRecord

ArrayRecord(Formula, CellRangeAddress8Bit) - Constructor for class org.apache.poi.hssf.record.ArrayRecord

ArrayUtil - Class in org.apache.poi.util
Utility classes for dealing with arrays.
ArrayUtil() - Constructor for class org.apache.poi.util.ArrayUtil

Arrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ascent - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

ASCII_STRING - Static variable in class org.apache.poi.hsmf.datatypes.Types
An 8-bit string, probably in CP1252, but don't quote us...
asFileEnding(int) - Static method in class org.apache.poi.hsmf.datatypes.Types

ASIN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

ASINH - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

asName(int) - Static method in class org.apache.poi.hsmf.datatypes.Types

ASSISTANT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ASSISTANT_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ASSOC_CONTENT_COUNT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATAN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

ATAN2 - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

ATANH - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

atomHeader - Static variable in class org.apache.poi.hslf.record.CurrentUserAtom
Standard Atom header
ATTACH_ADDITIONAL_INFO - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_CONTENT_BASE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_CONTENT_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_CONTENT_LOCATION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_DATA - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_DISPOSITION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_ENCODING - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_EXTENSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_FILENAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_FLAGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_LONG_FILENAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_LONG_PATHNAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_METHOD - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_MIME_SEQUENCE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_MIME_TAG - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_NETSCAPE_MAC_INFO - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_NUM - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_PATHNAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_RENDERING - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_SIZE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_TAG - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ATTACH_TRANSPORT_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

attachData - Variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks

attachExtension - Variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks

attachFileName - Variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks

attachLongFileName - Variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks

Attachment - Class in org.apache.poi.hmef
An attachment within a HMEFMessage.
Attachment() - Constructor for class org.apache.poi.hmef.Attachment

ATTACHMENT_X400_PARAMETERS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AttachmentChunks - Class in org.apache.poi.hsmf.datatypes
Collection of convenence chunks for standard parts of the MSG file attachment.
AttachmentChunks(String) - Constructor for class org.apache.poi.hsmf.datatypes.AttachmentChunks

AttachmentChunks.AttachmentChunksSorter - Class in org.apache.poi.hsmf.datatypes
Orders by the attachment number.
AttachmentChunks.AttachmentChunksSorter() - Constructor for class org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter

attachmentDirectory - Variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks

attachMimeTag - Variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks

attachRenderingWMF - Variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks
This is in WMF Format.
AttrPtg - Class in org.apache.poi.ss.formula.ptg
"Special Attributes" This seems to be a Misc Stuff and Junk record.
AttrPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.AttrPtg

AttrPtg.SpaceType - Class in org.apache.poi.ss.formula.ptg

author - Variable in class org.apache.poi.xwpf.usermodel.XWPFComment

authorIsMultibyte() - Method in class org.apache.poi.hssf.record.NoteRecord
For unit testing only!
AUTHORIZING_USERS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AUTO_FORWARD_COMMENT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AUTO_FORWARDED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AUTO_RESPONSE_SUPPRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

AutoFilter - Interface in org.apache.poi.ss.usermodel
Represents autofiltering for the specified worksheet.
AutoFilterInfoRecord - Class in org.apache.poi.hssf.record
The AutoFilterInfo record specifies the number of columns that have AutoFilter enabled and indicates the beginning of the collection of AutoFilter records.
AutoFilterInfoRecord() - Constructor for class org.apache.poi.hssf.record.AutoFilterInfoRecord

AutoFilterInfoRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.AutoFilterInfoRecord

Automatic - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
whether the animation starts automatically
AUTOMATIC - Static variable in class org.apache.poi.hssf.record.CalcModeRecord
automatically calculate formulas (1)
AUTOMATIC_EXCEPT_TABLES - Static variable in class org.apache.poi.hssf.record.CalcModeRecord
automatically calculate formulas except for tables (-1)
AUTOSAVESOURCE - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

AutoShape - Class in org.apache.poi.hslf.model
Represents an AutoShape.
AutoShape(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.AutoShape

AutoShape(int, Shape) - Constructor for class org.apache.poi.hslf.model.AutoShape

AutoShape(int) - Constructor for class org.apache.poi.hslf.model.AutoShape

AutoShape - Interface in org.apache.poi.sl.usermodel

AutoShapes - Class in org.apache.poi.hslf.model
Stores definition of auto-shapes.
AutoShapes() - Constructor for class org.apache.poi.hslf.model.AutoShapes

autoSizeColumn(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Adjusts the column width to fit the contents.
autoSizeColumn(int, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Adjusts the column width to fit the contents.
autoSizeColumn(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Adjusts the column width to fit the contents.
autoSizeColumn(int, boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Adjusts the column width to fit the contents.
autoSizeColumn(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Adjusts the column width to fit the contents.
autoSizeColumn(int, boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Adjusts the column width to fit the contents.
autoSizeColumn(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Adjusts the column width to fit the contents.
autoSizeColumn(int, boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Adjusts the column width to fit the contents.
available() - Method in interface org.apache.poi.hssf.record.BiffHeaderInput

available() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

available() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

available() - Method in class org.apache.poi.hssf.record.RecordInputStream

available() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

available() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

available() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

available() - Method in class org.apache.poi.poifs.storage.DataInputBlock

available() - Method in class org.apache.poi.util.BlockingInputStream

available() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

available() - Method in interface org.apache.poi.util.LittleEndianInput

available() - Method in class org.apache.poi.util.LittleEndianInputStream

AVEDEV - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

AVERAGE - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

AXIS_TYPE_AXIS_LINE - Static variable in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

AXIS_TYPE_CATEGORY_OR_X_AXIS - Static variable in class org.apache.poi.hssf.record.chart.AxisRecord

AXIS_TYPE_MAIN - Static variable in class org.apache.poi.hssf.record.chart.AxisParentRecord

AXIS_TYPE_MAJOR_GRID_LINE - Static variable in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

AXIS_TYPE_MINOR_GRID_LINE - Static variable in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

AXIS_TYPE_SECONDARY - Static variable in class org.apache.poi.hssf.record.chart.AxisParentRecord

AXIS_TYPE_SERIES_AXIS - Static variable in class org.apache.poi.hssf.record.chart.AxisRecord

AXIS_TYPE_VALUE_AXIS - Static variable in class org.apache.poi.hssf.record.chart.AxisRecord

AXIS_TYPE_WALLS_OR_FLOOR - Static variable in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

AxisCrossBetween - Enum in org.apache.poi.ss.usermodel.charts
Specifies the possible crossing states of an axis.
AxisCrosses - Enum in org.apache.poi.ss.usermodel.charts
Specifies the possible crossing points for an axis.
AxisLineFormatRecord - Class in org.apache.poi.hssf.record.chart
The axis line format record defines the axis type details.

AxisLineFormatRecord() - Constructor for class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

AxisLineFormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

AxisOptionsRecord - Class in org.apache.poi.hssf.record.chart
The axis options record provides unit information and other various tidbits about the axis.

AxisOptionsRecord() - Constructor for class org.apache.poi.hssf.record.chart.AxisOptionsRecord

AxisOptionsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.AxisOptionsRecord

AxisOrientation - Enum in org.apache.poi.ss.usermodel.charts
Specifies the possible ways to place a picture on a data point, series, wall, or floor.
AxisParentRecord - Class in org.apache.poi.hssf.record.chart
The axis size and location

AxisParentRecord() - Constructor for class org.apache.poi.hssf.record.chart.AxisParentRecord

AxisParentRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.AxisParentRecord

AxisPosition - Enum in org.apache.poi.ss.usermodel.charts
Enumeration of all possible axis positions.
AxisRecord - Class in org.apache.poi.hssf.record.chart
The axis record defines the type of an axis.

AxisRecord() - Constructor for class org.apache.poi.hssf.record.chart.AxisRecord

AxisRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.AxisRecord

AxisUsedRecord - Class in org.apache.poi.hssf.record.chart
The number of axes used on a chart.

AxisUsedRecord() - Constructor for class org.apache.poi.hssf.record.chart.AxisUsedRecord

AxisUsedRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.AxisUsedRecord

B

B4_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
B4 (JIS) 250x354 mm
B5_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
B5 (JIS) 182x257 mm
Background - Class in org.apache.poi.hslf.model
Background shape
Background(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Background

Background - Interface in org.apache.poi.sl.usermodel

BackupRecord - Class in org.apache.poi.hssf.record
Title: Backup Record
BackupRecord() - Constructor for class org.apache.poi.hssf.record.BackupRecord

BackupRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.BackupRecord

Balloon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BANNER - Static variable in class org.apache.poi.hslf.record.DocumentAtom.SlideSize

BarRecord - Class in org.apache.poi.hssf.record.chart
The bar record is used to define a bar chart.

BarRecord() - Constructor for class org.apache.poi.hssf.record.chart.BarRecord

BarRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.BarRecord

BaseTextPropAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

BATBlock - Class in org.apache.poi.poifs.storage
A block of block allocation table entries.
BATBlock.BATBlockAndIndex - Class in org.apache.poi.poifs.storage

BATManaged - Interface in org.apache.poi.poifs.filesystem
This interface defines behaviors for objects managed by the Block Allocation Table (BAT).
beforeRecordSerialize(int, short, EscherRecord) - Method in interface org.apache.poi.ddf.EscherSerializationListener
Fired before a given escher record is serialized.
beforeRecordSerialize(int, short, EscherRecord) - Method in class org.apache.poi.ddf.NullEscherSerializationListener

BeginRecord - Class in org.apache.poi.hssf.record.chart
The begin record defines the start of a block of records for a (grpahing data object.
BeginRecord() - Constructor for class org.apache.poi.hssf.record.chart.BeginRecord

BeginRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.BeginRecord

BENT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BENT_CONNECTOR_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BENT_CONNECTOR_3 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BENT_CONNECTOR_4 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BENT_CONNECTOR_5 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BENT_UP_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BentArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BentConnector2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BentConnector3 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BentConnector4 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BentConnector5 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BentUpArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Beta - Annotation Type in org.apache.poi.util
Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.
BETWEEN - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

BETWEEN - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Between' operator
BETWEEN - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

Bevel - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BEVEL - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Biff8DecryptingStream - Class in org.apache.poi.hssf.record.crypto

Biff8DecryptingStream(InputStream, int, Biff8EncryptionKey) - Constructor for class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

Biff8EncryptionKey - Class in org.apache.poi.hssf.record.crypto

BiffHeaderInput - Interface in org.apache.poi.hssf.record

BiffViewer - Class in org.apache.poi.hssf.dev
Utillity for reading in BIFF8 records and displaying data from them.
BIG_BLOCK_MINIMUM_DOCUMENT_SIZE - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
The minimum size of a document before it's stored using Big Blocks (normal streams).
BIG_OBJECT - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

BIG_SPOTS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Large spots
BIG_SPOTS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

BIG_SPOTS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Large spots
BIG_SPOTS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Large spots
BINARY - Static variable in class org.apache.poi.hsmf.datatypes.Types
Binary - counted byte array
BinaryTagData - Static variable in class org.apache.poi.hslf.record.RecordTypes

BinaryTree - Class in org.apache.poi.util
Red-Black tree-based implementation of Map.
BinaryTree() - Constructor for class org.apache.poi.util.BinaryTree
Construct a new BinaryTree
BinaryTree(Map) - Constructor for class org.apache.poi.util.BinaryTree
Constructs a new BinaryTree from an existing Map, with keys and values sorted
BIRTHDAY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

BitField - Class in org.apache.poi.util
Manage operations dealing with bit-mapped fields.
BitField(int) - Constructor for class org.apache.poi.util.BitField
Create a BitField instance
BitFieldFactory - Class in org.apache.poi.util
Returns immutable Btfield instances.
BitFieldFactory() - Constructor for class org.apache.poi.util.BitFieldFactory

Bitmap - Class in org.apache.poi.hslf.blip
Represents a bitmap picture data: JPEG or PNG.
Bitmap() - Constructor for class org.apache.poi.hslf.blip.Bitmap

BITMAP_00E9 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

BitmapPainter - Class in org.apache.poi.hslf.blip
Creates BufferedImage using javax.imageio.ImageIO and draws it in the specified graphics.
BitmapPainter() - Constructor for class org.apache.poi.hslf.blip.BitmapPainter

BitMaskTextProp - Class in org.apache.poi.hslf.model.textproperties
Definition of a special kind of property of some text, or its paragraph.
BitMaskTextProp(int, int, String, String[]) - Constructor for class org.apache.poi.hslf.model.textproperties.BitMaskTextProp

bitType - Variable in class org.apache.poi.hpbf.model.qcbits.QCBit

BKC_EVEN_PAGE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

BKC_NEW_COLUMN - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

BKC_NEW_PAGE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

BKC_NO_BREAK - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

BKC_ODD_PAGE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

BKDEDN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

BKDFTN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

BKDMOTHER - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

BKFAbstractType - Class in org.apache.poi.hwpf.model.types
BooKmark First descriptor (BKF).
BKFAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.BKFAbstractType

BLANK_SLIDE - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

BlankEval - Class in org.apache.poi.ss.formula.eval

BlankRecord - Class in org.apache.poi.hssf.record
Title: Blank cell record (0x0201)
BlankRecord() - Constructor for class org.apache.poi.hssf.record.BlankRecord
Creates a new instance of BlankRecord
BlankRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.BlankRecord

BLIP__BLIPFILENAME - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__BLIPFLAGS - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__BLIPTODISPLAY - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__BRIGHTNESSSETTING - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__CONTRASTSETTING - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__CROPFROMBOTTOM - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__CROPFROMLEFT - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__CROPFROMRIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__CROPFROMTOP - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__DOUBLEMOD - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__GAMMA - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__NOHITTESTPICTURE - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PICTUREACTIVE - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PICTUREBILEVEL - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PICTUREFILLMOD - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PICTUREGRAY - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PICTUREID - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PICTURELINE - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PRINTBLIP - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PRINTBLIPFILENAME - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__PRINTFLAGS - Static variable in class org.apache.poi.ddf.EscherProperties

BLIP__TRANSPARENTCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

BLOCK_ARC - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BLOCK_SIZE - Static variable in class org.apache.poi.hssf.record.DBCellRecord

BlockAllocationTableReader - Class in org.apache.poi.poifs.storage
This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
BlockAllocationTableReader(POIFSBigBlockSize, int, int[], int, int, BlockList) - Constructor for class org.apache.poi.poifs.storage.BlockAllocationTableReader
create a BlockAllocationTableReader for an existing filesystem.
BlockAllocationTableWriter - Class in org.apache.poi.poifs.storage
This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
BlockAllocationTableWriter(POIFSBigBlockSize) - Constructor for class org.apache.poi.poifs.storage.BlockAllocationTableWriter
create a BlockAllocationTableWriter
BlockArc - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

blockCount() - Method in interface org.apache.poi.poifs.storage.BlockList

BlockingInputStream - Class in org.apache.poi.util
Implementation of a BlockingInputStream to provide data to RawDataBlock that expects data in 512 byte chunks.
BlockingInputStream(InputStream) - Constructor for class org.apache.poi.util.BlockingInputStream

BlockList - Interface in org.apache.poi.poifs.storage
Interface for lists of blocks that are mapped by block allocation tables
BlockStore - Class in org.apache.poi.poifs.filesystem
This abstract class describes a way to read, store, chain and free a series of blocks (be they Big or Small ones)
BlockStore() - Constructor for class org.apache.poi.poifs.filesystem.BlockStore

BlockStore.ChainLoopDetector - Class in org.apache.poi.poifs.filesystem
Used to detect if a chain has a loop in it, so we can bail out with an error rather than spinning away for ever...
BlockStore.ChainLoopDetector(long) - Constructor for class org.apache.poi.poifs.filesystem.BlockStore.ChainLoopDetector

BlockWritable - Interface in org.apache.poi.poifs.storage
An interface for persisting block storage of POIFS components.
BMP - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
Body - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the body text.
BODY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

body - Variable in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

body - Variable in class org.apache.poi.hwpf.converter.TextDocumentFacade

BODY_CONTENT_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

BODY_CONTENT_LOCATION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

BODY_CRC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

BODY_HTML - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

BODY_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

bodyElements - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

bodyElements - Variable in class org.apache.poi.xwpf.usermodel.XWPFTableCell

BodyElementType - Enum in org.apache.poi.xwpf.usermodel
9 Jan 2010
BodyType - Enum in org.apache.poi.xwpf.usermodel
9 Jan 2010
BOFRecord - Class in org.apache.poi.hssf.record
Title: Beginning Of File (0x0809)
BOFRecord() - Constructor for class org.apache.poi.hssf.record.BOFRecord
Constructs an empty BOFRecord with no fields set.
BOFRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.BOFRecord

bold - Variable in class org.apache.poi.hwpf.converter.FontReplacer.Triplet

BOLD_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

BOLDWEIGHT_BOLD - Static variable in interface org.apache.poi.ss.usermodel.Font
Bold boldness (bold)
BOLDWEIGHT_NORMAL - Static variable in interface org.apache.poi.ss.usermodel.Font
Normal boldness (not bold)
BookBoolRecord - Class in org.apache.poi.hssf.record
Title: Save External Links record (BookBool)
BookBoolRecord() - Constructor for class org.apache.poi.hssf.record.BookBoolRecord

BookBoolRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.BookBoolRecord

Bookmark - Interface in org.apache.poi.hwpf.usermodel
User friendly interface to access information about document bookmarks
BookmarkCollection - Static variable in class org.apache.poi.hslf.record.RecordTypes

BookmarkEntityAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

BookmarkFirstDescriptor - Class in org.apache.poi.hwpf.model

BookmarkFirstDescriptor() - Constructor for class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

BookmarkFirstDescriptor(byte[], int) - Constructor for class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

Bookmarks - Interface in org.apache.poi.hwpf.usermodel
User-friendly interface to access document bookmarks
BookmarkSeedAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

BookmarksImpl - Class in org.apache.poi.hwpf.usermodel
Implementation of user-friendly interface for document bookmarks
BookmarksImpl(BookmarksTables) - Constructor for class org.apache.poi.hwpf.usermodel.BookmarksImpl

BookmarksTables - Class in org.apache.poi.hwpf.model

BookmarksTables(byte[], FileInformationBlock) - Constructor for class org.apache.poi.hwpf.model.BookmarksTables

BOOLEAN - Static variable in class org.apache.poi.hsmf.datatypes.Types
Boolean - 16-bit Boolean value.
BooleanFunction - Class in org.apache.poi.ss.formula.functions
Here are the general rules concerning Boolean functions: Blanks are ignored (not either true or false) Strings are ignored if part of an area ref or cell ref, otherwise they must be 'true' or 'false' Numbers: 0 is false.
BooleanFunction() - Constructor for class org.apache.poi.ss.formula.functions.BooleanFunction

BoolErrRecord - Class in org.apache.poi.hssf.record
Creates new BoolErrRecord.
BoolErrRecord() - Constructor for class org.apache.poi.hssf.record.BoolErrRecord
Creates new BoolErrRecord
BoolErrRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.BoolErrRecord

BoolEval - Class in org.apache.poi.ss.formula.eval

BoolPtg - Class in org.apache.poi.ss.formula.ptg
Boolean (boolean) Stores a (java) boolean value in a formula.
BORDER_BOTTOM - Static variable in class org.apache.poi.hslf.model.Table

BORDER_BOTTOM - Static variable in class org.apache.poi.ss.util.CellUtil

BORDER_CALLOUT_1 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BORDER_CALLOUT_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BORDER_CALLOUT_3 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BORDER_DASH_DOT - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
dash-dot border
BORDER_DASH_DOT - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
dash-dot border
BORDER_DASH_DOT - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
dash-dot border
BORDER_DASH_DOT_DOT - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
dash-dot-dot border
BORDER_DASH_DOT_DOT - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
dash-dot-dot border
BORDER_DASH_DOT_DOT - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
dash-dot-dot border
BORDER_DASHED - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
dash border
BORDER_DASHED - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
dash border
BORDER_DASHED - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
dash border
BORDER_DOTTED - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
hair-line border
BORDER_DOTTED - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
hair-line border
BORDER_DOTTED - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
hair-line border
BORDER_DOUBLE - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
double-line border
BORDER_DOUBLE - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
double-line border
BORDER_DOUBLE - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
double-line border
BORDER_HAIR - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
dot border
BORDER_HAIR - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
dot border
BORDER_HAIR - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
dot border
BORDER_LEFT - Static variable in class org.apache.poi.hslf.model.Table

BORDER_LEFT - Static variable in class org.apache.poi.ss.util.CellUtil

BORDER_MEDIUM - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
Medium border
BORDER_MEDIUM - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
Medium border
BORDER_MEDIUM - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Medium border
BORDER_MEDIUM_DASH_DOT - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
medium dash-dot border
BORDER_MEDIUM_DASH_DOT - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
medium dash-dot border
BORDER_MEDIUM_DASH_DOT - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
medium dash-dot border
BORDER_MEDIUM_DASH_DOT_DOT - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
medium dash-dot-dot border
BORDER_MEDIUM_DASH_DOT_DOT - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
medium dash-dot-dot border
BORDER_MEDIUM_DASH_DOT_DOT - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
medium dash-dot-dot border
BORDER_MEDIUM_DASHED - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
Medium dashed border
BORDER_MEDIUM_DASHED - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
Medium dashed border
BORDER_MEDIUM_DASHED - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Medium dashed border
BORDER_NONE - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
No border
BORDER_NONE - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
No border
BORDER_NONE - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
No border
BORDER_RIGHT - Static variable in class org.apache.poi.hslf.model.Table

BORDER_RIGHT - Static variable in class org.apache.poi.ss.util.CellUtil

BORDER_SLANTED_DASH_DOT - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
slanted dash-dot border
BORDER_SLANTED_DASH_DOT - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
slanted dash-dot border
BORDER_SLANTED_DASH_DOT - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
slanted dash-dot border
BORDER_THICK - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
Thick border
BORDER_THICK - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
Thick border
BORDER_THICK - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thick border
BORDER_THIN - Static variable in class org.apache.poi.hssf.record.cf.BorderFormatting
Thin border
BORDER_THIN - Static variable in interface org.apache.poi.ss.usermodel.BorderFormatting
Thin border
BORDER_THIN - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thin border
BORDER_TOP - Static variable in class org.apache.poi.hslf.model.Table

BORDER_TOP - Static variable in class org.apache.poi.ss.util.CellUtil

BORDER_TYPE_REGULAR - Static variable in class org.apache.poi.hssf.record.chart.FrameRecord

BORDER_TYPE_SHADOW - Static variable in class org.apache.poi.hssf.record.chart.FrameRecord

BorderCallout1 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BorderCallout2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BorderCallout3 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BorderCallout90 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BorderCode - Class in org.apache.poi.hwpf.usermodel
Mapping class for BRC80 structure (Border Code for Word 97)
BorderCode() - Constructor for class org.apache.poi.hwpf.usermodel.BorderCode

BorderCode(byte[], int) - Constructor for class org.apache.poi.hwpf.usermodel.BorderCode

BorderFormatting - Class in org.apache.poi.hssf.record.cf
Border Formatting Block of the Conditional Formatting Rule Record.
BorderFormatting() - Constructor for class org.apache.poi.hssf.record.cf.BorderFormatting

BorderFormatting(LittleEndianInput) - Constructor for class org.apache.poi.hssf.record.cf.BorderFormatting
Creates new FontFormatting
BorderFormatting - Interface in org.apache.poi.ss.usermodel

Borders - Enum in org.apache.poi.xwpf.usermodel
Specifies all types of borders which can be specified for WordprocessingML objects which have a border.
BORDERS_ALL - Static variable in class org.apache.poi.hslf.model.Table

BORDERS_INSIDE - Static variable in class org.apache.poi.hslf.model.Table

BORDERS_NONE - Static variable in class org.apache.poi.hslf.model.Table

BORDERS_OUTSIDE - Static variable in class org.apache.poi.hslf.model.Table

BorderStyle - Enum in org.apache.poi.ss.usermodel
The enumeration value indicating the line style of a border in a cell, i.e., whether it is borded dash dot, dash dot dot, dashed, dotted, double, hair, medium, medium dash dot, medium dash dot dot, medium dashed, none, slant dash dot, thick or thin.
bottom - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

BOTTOM_BORDER_COLOR - Static variable in class org.apache.poi.ss.util.CellUtil

BottomMargin - Static variable in class org.apache.poi.hssf.model.InternalSheet

BottomMargin - Static variable in interface org.apache.poi.ss.usermodel.Sheet

BottomMarginRecord - Class in org.apache.poi.hssf.record
Record for the bottom margin.

BottomMarginRecord() - Constructor for class org.apache.poi.hssf.record.BottomMarginRecord

BottomMarginRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.BottomMarginRecord

bounds - Variable in class org.apache.poi.hslf.blip.Metafile.Header
Boundary of the metafile drawing commands
BoundSheetRecord - Class in org.apache.poi.hssf.record
Title: Bound Sheet Record (aka BundleSheet) (0x0085)
BoundSheetRecord(String) - Constructor for class org.apache.poi.hssf.record.BoundSheetRecord

BoundSheetRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.BoundSheetRecord
UTF8: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + len(str) UNICODE: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + 2 * len(str)
BRACE_PAIR - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BracePair - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BRACKET_PAIR - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

BracketPair - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

BRCL_DOUBLE - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCL_SHADOW - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCL_SINGLE - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCL_THICK - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCP_BAR_TO_LEFT_OF_PARAGRAPH - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCP_BORDER_ABOVE - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCP_BORDER_BELOW - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCP_BOX_AROUND - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BRCP_NONE - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

BreakClear - Enum in org.apache.poi.xwpf.usermodel
Specifies the set of possible restart locations which may be used as to determine the next available line when a break's type attribute has a value of textWrapping.
BreakType - Enum in org.apache.poi.xwpf.usermodel
Specifies the possible types of break characters in a WordprocessingML document.
BRICKS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Brick-like layout
BRICKS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

BRICKS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Brick-like layout
BRICKS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Brick-like layout
BSTORE_CONTAINER - Static variable in class org.apache.poi.ddf.EscherContainerRecord

BT_DIB - Static variable in class org.apache.poi.ddf.EscherBSERecord

BT_EMF - Static variable in class org.apache.poi.ddf.EscherBSERecord

BT_ERROR - Static variable in class org.apache.poi.ddf.EscherBSERecord

BT_JPEG - Static variable in class org.apache.poi.ddf.EscherBSERecord

BT_PICT - Static variable in class org.apache.poi.ddf.EscherBSERecord

BT_PNG - Static variable in class org.apache.poi.ddf.EscherBSERecord

BT_UNKNOWN - Static variable in class org.apache.poi.ddf.EscherBSERecord

BT_WMF - Static variable in class org.apache.poi.ddf.EscherBSERecord

BUBBLE_SERIES_TYPE_DATES - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

BUBBLE_SERIES_TYPE_NUMERIC - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

BUBBLE_SERIES_TYPE_SEQUENCE - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

BUBBLE_SERIES_TYPE_TEXT - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

BUILD - Static variable in class org.apache.poi.hssf.record.BOFRecord
suggested default 0x10d3
build(int) - Method in class org.apache.poi.hssf.record.DBCellRecord.Builder

build() - Method in class org.apache.poi.ss.util.SheetBuilder
Builds sheet from parent workbook and 2D array with cell values.
BUILD_YEAR - Static variable in class org.apache.poi.hssf.record.BOFRecord
suggested default 0x07CC (1996)
buildFontCharactersProperty(String) - Static method in class org.apache.poi.hssf.usermodel.FontDetails

buildFontHeightProperty(String) - Static method in class org.apache.poi.hssf.usermodel.FontDetails

buildFontWidthsProperty(String) - Static method in class org.apache.poi.hssf.usermodel.FontDetails

buildMergedRangesMap(HSSFSheet) - Static method in class org.apache.poi.hssf.converter.ExcelToHtmlUtils
Creates a map (i.e.
buildRecordAtOffset(byte[], int) - Static method in class org.apache.poi.hslf.record.Record
Build and return the Record at the given offset.
buildRichTextRuns(LinkedList, LinkedList, String) - Method in class org.apache.poi.hslf.model.TextRun

buildShapes(CTGroupShape) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

buildStyle(HSSFWorkbook, HSSFCellStyle) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

buildStylesheet(Map<String, Map<String, String>>) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

buildTextPropList(int, TextProp[], byte[], int) - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection
For an existing set of text properties, build the list of properties coded for in a given run of properties.
BUILTIN_AUTO_ACTIVATE - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_AUTO_CLOSE - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_AUTO_DEACTIVATE - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_AUTO_OPEN - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_CONSOLIDATE_AREA - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_CONSOLIDATE_AREA - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
A built-in defined name that refers to a consolidation area
BUILTIN_CRITERIA - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_CRITERIA - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
A built-in defined name that refers to a range containing the criteria values to be used in applying an advanced filter to a range of data
BUILTIN_DATA_FORM - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_DATABASE - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_DATABASE - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
A built-in defined name that specified that the range specified is from a database data source
BUILTIN_EXTRACT - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
this defined name refers to the range containing the filtered output values resulting from applying an advanced filter criteria to a source range
BUILTIN_FILTER_DB - Static variable in class org.apache.poi.hssf.record.NameRecord

BUILTIN_FILTER_DB - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
?an be one of the following this defined name refers to a range to which an advanced filter has been applied.
BUILTIN_PRINT_AREA - Static variable in class org.apache.poi.hssf.record.NameRecord

BUILTIN_PRINT_AREA - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
A built-in defined name that specifies the workbook's print area
BUILTIN_PRINT_TITLE - Static variable in class org.apache.poi.hssf.record.NameRecord

BUILTIN_PRINT_TITLE - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
A built-in defined name that specifies the row(s) or column(s) to repeat at the top of each printed page.
BUILTIN_RECORDER - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_SHEET_TITLE - Static variable in class org.apache.poi.hssf.record.NameRecord
Included for completeness sake, not implemented
BUILTIN_SHEET_TITLE - Static variable in class org.apache.poi.xssf.usermodel.XSSFName
A built-in defined name that refers to a sheet title.
BuiltinFormats - Class in org.apache.poi.ss.usermodel
Utility to identify built-in formats.
BuiltinFormats() - Constructor for class org.apache.poi.ss.usermodel.BuiltinFormats

BULLET_HARDCOLOR_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

BULLET_HARDFONT_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

BULLET_HARDSIZE_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

BULLET_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

BUSINESS_FAX_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

BUSINESS_HOME_PAGE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

BYTE_SIZE - Static variable in interface org.apache.poi.util.LittleEndianConsts

ByteArrayBackedDataSource - Class in org.apache.poi.poifs.nio
A POIFS DataSource backed by a byte array.
ByteArrayBackedDataSource(byte[], int) - Constructor for class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

ByteArrayBackedDataSource(byte[]) - Constructor for class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

ByteChunk - Class in org.apache.poi.hsmf.datatypes
A Chunk that holds binary data, normally unparsed.
ByteChunk(String, int, int) - Constructor for class org.apache.poi.hsmf.datatypes.ByteChunk
Creates a Byte Chunk.
ByteChunk(int, int) - Constructor for class org.apache.poi.hsmf.datatypes.ByteChunk
Create a Byte Chunk, with the specified type.
ByteField - Class in org.apache.poi.util
representation of a byte (8-bit) field at a fixed location within a byte array
ByteField(int) - Constructor for class org.apache.poi.util.ByteField
construct the ByteField with its offset into its containing byte array and a default value of 0
ByteField(int, byte) - Constructor for class org.apache.poi.util.ByteField
construct the ByteField with its offset into its containing byte array and initialize its value
ByteField(int, byte[]) - Constructor for class org.apache.poi.util.ByteField
Construct the ByteField with its offset into its containing byte array and initialize its value from its byte array
ByteField(int, byte, byte[]) - Constructor for class org.apache.poi.util.ByteField
construct the ByteField with its offset into its containing byte array, initialize its value, and write its value to its byte array
byteOrder - Variable in class org.apache.poi.hpsf.PropertySet
Specifies this PropertySet's byte order.
BytePropertyNode<T extends BytePropertyNode<T>> - Class in org.apache.poi.hwpf.model
Deprecated. byte positions shall not be saved in memory
BytePropertyNode(int, int, CharIndexTranslator, Object) - Constructor for class org.apache.poi.hwpf.model.BytePropertyNode
Deprecated.
BytePropertyNode(int, int, Object) - Constructor for class org.apache.poi.hwpf.model.BytePropertyNode
Deprecated.
bytes - Variable in class org.apache.poi.hpsf.ClassID
The bytes making out the class ID in correct order, i.e.
bytesLength() - Method in class org.apache.poi.hwpf.model.SinglentonTextPiece

bytesLength() - Method in class org.apache.poi.hwpf.model.TextPiece
Returns the length, in bytes
byteToHex(int) - Static method in class org.apache.poi.util.HexDump

C

CachedPropertyNode - Class in org.apache.poi.hwpf.model

CachedPropertyNode(int, int, SprmBuffer) - Constructor for class org.apache.poi.hwpf.model.CachedPropertyNode

CALC_CHAIN - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

CalcCountRecord - Class in org.apache.poi.hssf.record
Title: Calc Count Record Description: Specifies the maximum times the gui should perform a formula recalculation.
CalcCountRecord() - Constructor for class org.apache.poi.hssf.record.CalcCountRecord

CalcCountRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CalcCountRecord

calcExtSSTRecordSize() - Method in class org.apache.poi.hssf.record.SSTRecord
Calculates the size in bytes of the EXTSST record as it would be if the record was serialized.
CalcModeRecord - Class in org.apache.poi.hssf.record
Title: Calc Mode Record
CalcModeRecord() - Constructor for class org.apache.poi.hssf.record.CalcModeRecord

CalcModeRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CalcModeRecord

calcSize(int, String, String, String) - Method in class org.apache.poi.hwpf.dev.FieldIterator

calcSize(int) - Static method in class org.apache.poi.poifs.storage.SmallDocumentBlock
Calculate the storage size of a set of SmallDocumentBlocks
calculateChecksum(byte[]) - Static method in class org.apache.poi.util.IOUtils

calculateMaximumSize(POIFSBigBlockSize, int) - Static method in class org.apache.poi.poifs.storage.BATBlock
Calculates the maximum size of a file which is addressable given the number of FAT (BAT) sectors specified.
calculateMaximumSize(HeaderBlock) - Static method in class org.apache.poi.poifs.storage.BATBlock

calculateNonWeekendHolidays(double, double, double[]) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator
Calculates how many holidays in a list are workdays, considering an interval of dates.
calculateSizeOfRecords(int, int) - Static method in class org.apache.poi.hssf.record.DBCellRecord

calculateStorageRequirements(POIFSBigBlockSize, int) - Static method in class org.apache.poi.poifs.storage.BATBlock
Calculate how many BATBlocks are needed to hold a specified number of BAT entries.
calculateWorkdays(double, double, double[]) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator
Calculate how many workdays are there between a start and an end date, as excel representations, considering a range of holidays.
calculateWorkdays(double, int, double[]) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator
Calculate the workday past x workdays from a starting date, considering a range of holidays.
calculateXBATStorageRequirements(POIFSBigBlockSize, int) - Static method in class org.apache.poi.poifs.storage.BATBlock
Calculate how many XBATBlocks are needed to hold a specified number of BAT entries.
CalculationChain - Class in org.apache.poi.xssf.model
The cells in a workbook can be calculated in different orders depending on various optimizations and dependencies.
CalculationChain() - Constructor for class org.apache.poi.xssf.model.CalculationChain

CalculationChain(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.model.CalculationChain

CalendarFieldFunction - Class in org.apache.poi.ss.formula.functions
Implementation of Excel functions Date parsing functions: Date - DAY, MONTH and YEAR Time - HOUR, MINUTE and SECOND
CALLBACK_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Callout1 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Callout2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Callout3 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Callout90 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CALLOUT_1 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CALLOUT_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CALLOUT_3 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CALLOUT__CALLOUTACCENTBAR - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTANGLE - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTDROPSPECIFIED - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTDROPTYPE - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTLENGTHSPECIFIED - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTMINUSX - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTMINUSY - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTTEXTBORDER - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__CALLOUTTYPE - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__DROPAUTO - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__ISCALLOUT - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__LENGTHSPECIFIED - Static variable in class org.apache.poi.ddf.EscherProperties

CALLOUT__XYCALLOUTGAP - Static variable in class org.apache.poi.ddf.EscherProperties

Can - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CAN - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

canDraw(XSLFShape) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Checks if this sheet displays the specified shape.
canDraw(XSLFShape) - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout
Render this sheet into the supplied graphics object
canDraw(XSLFShape) - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster
Render this sheet into the supplied graphics object
cantSplit() - Method in class org.apache.poi.hwpf.usermodel.TableRow

CAR_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

cat(byte[][]) - Static method in class org.apache.poi.hpsf.Util
Concatenates the contents of several byte arrays into a single one.
category - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
A categorization of the content of this package.
CATEGORY_DATA_TYPE_ALL_TEXT_CHARACTERISTIC - Static variable in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

CATEGORY_DATA_TYPE_DATES - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

CATEGORY_DATA_TYPE_NUMERIC - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

CATEGORY_DATA_TYPE_SEQUENCE - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

CATEGORY_DATA_TYPE_SHOW_LABELS_CHARACTERISTIC - Static variable in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

CATEGORY_DATA_TYPE_TEXT - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

CATEGORY_DATA_TYPE_VALUE_AND_PERCENTAGE_CHARACTERISTIC - Static variable in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

CategorySeriesAxisRecord - Class in org.apache.poi.hssf.record.chart
This record refers to a category or series axis and is used to specify label/tickmark frequency.

CategorySeriesAxisRecord() - Constructor for class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

CategorySeriesAxisRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

CatLabRecord - Class in org.apache.poi.hssf.record.chart
CATLAB - Category Labels (0x0856)

CatLabRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.CatLabRecord

CEILING - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

CELL - Static variable in class org.apache.poi.ss.formula.FormulaType

Cell - Interface in org.apache.poi.ss.usermodel
High level representation of a cell in a row of a spreadsheet.
cell(String, String) - Method in interface org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler
A cell, with the given formatted value, was encountered
cell(String, String) - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

CELL_TYPE_BLANK - Static variable in interface org.apache.poi.ss.usermodel.Cell
Blank Cell type (3)
CELL_TYPE_BOOLEAN - Static variable in interface org.apache.poi.ss.usermodel.Cell
Boolean Cell type (4)
CELL_TYPE_ERROR - Static variable in interface org.apache.poi.ss.usermodel.Cell
Error Cell type (5)
CELL_TYPE_FORMULA - Static variable in interface org.apache.poi.ss.usermodel.Cell
Formula Cell type (2)
CELL_TYPE_NUMERIC - Static variable in interface org.apache.poi.ss.usermodel.Cell
Numeric Cell type (0)
CELL_TYPE_STRING - Static variable in interface org.apache.poi.ss.usermodel.Cell
String Cell type (1)
CellDateFormatter - Class in org.apache.poi.ss.format
Formats a date value.
CellDateFormatter(String) - Constructor for class org.apache.poi.ss.format.CellDateFormatter
Creates a new date formatter with the given specification.
CellElapsedFormatter - Class in org.apache.poi.ss.format
This class implements printing out an elapsed time format.
CellElapsedFormatter(String) - Constructor for class org.apache.poi.ss.format.CellElapsedFormatter
Creates a elapsed time formatter.
CellFormat - Class in org.apache.poi.ss.format
Format a value according to the standard Excel behavior.
CellFormatCondition - Class in org.apache.poi.ss.format
This object represents a condition in a cell format.
CellFormatCondition() - Constructor for class org.apache.poi.ss.format.CellFormatCondition

CellFormatPart - Class in org.apache.poi.ss.format
Objects of this class represent a single part of a cell format expression.
CellFormatPart(String) - Constructor for class org.apache.poi.ss.format.CellFormatPart
Create an object to represent a format part.
CellFormatResult - Class in org.apache.poi.ss.format
This object contains the result of applying a cell format or cell format part to a value.
CellFormatResult(boolean, String, Color) - Constructor for class org.apache.poi.ss.format.CellFormatResult
Creates a new format result object.
CellFormatter - Class in org.apache.poi.ss.format
This is the abstract supertype for the various cell formatters.
CellFormatter(String) - Constructor for class org.apache.poi.ss.format.CellFormatter
Creates a new formatter object, storing the format in CellFormatter.format.
CellFormatType - Enum in org.apache.poi.ss.format
The different kinds of formats that the formatter understands.
CellGeneralFormatter - Class in org.apache.poi.ss.format
A formatter for the default "General" cell format.
CellGeneralFormatter() - Constructor for class org.apache.poi.ss.format.CellGeneralFormatter
Creates a new general formatter.
CellHandler - Interface in org.apache.poi.ss.util.cellwalk
Represents callback for CellWalk traverse method.
cellIterator() - Method in class org.apache.poi.hssf.usermodel.HSSFRow

cellIterator() - Method in interface org.apache.poi.ss.usermodel.Row

cellIterator() - Method in class org.apache.poi.xssf.streaming.SXSSFRow

cellIterator() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Cell iterator over the physically defined cells:
CellNumberFormatter - Class in org.apache.poi.ss.format
This class implements printing out a value using a number format.
CellNumberFormatter(String) - Constructor for class org.apache.poi.ss.format.CellNumberFormatter
Creates a new cell number formatter.
CellRange<C extends Cell> - Interface in org.apache.poi.ss.usermodel
Represents a rectangular region of a Sheet
CellRangeAddress - Class in org.apache.poi.hssf.util
Deprecated. use CellRangeAddress
CellRangeAddress(int, int, int, int) - Constructor for class org.apache.poi.hssf.util.CellRangeAddress
Deprecated.
CellRangeAddress(RecordInputStream) - Constructor for class org.apache.poi.hssf.util.CellRangeAddress
Deprecated.
CellRangeAddress - Class in org.apache.poi.ss.util
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

CellRangeAddress(int, int, int, int) - Constructor for class org.apache.poi.ss.util.CellRangeAddress

CellRangeAddress(RecordInputStream) - Constructor for class org.apache.poi.ss.util.CellRangeAddress

CellRangeAddress8Bit - Class in org.apache.poi.hssf.util
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
Like CellRangeAddress except column fields are 8-bit.
CellRangeAddress8Bit(int, int, int, int) - Constructor for class org.apache.poi.hssf.util.CellRangeAddress8Bit

CellRangeAddress8Bit(LittleEndianInput) - Constructor for class org.apache.poi.hssf.util.CellRangeAddress8Bit

CellRangeAddressBase - Class in org.apache.poi.ss.util
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
Common subclass of 8-bit and 16-bit versions
CellRangeAddressBase(int, int, int, int) - Constructor for class org.apache.poi.ss.util.CellRangeAddressBase

CellRangeAddressList - Class in org.apache.poi.hssf.util
Deprecated. use CellRangeAddressList
CellRangeAddressList(int, int, int, int) - Constructor for class org.apache.poi.hssf.util.CellRangeAddressList
Deprecated.
CellRangeAddressList() - Constructor for class org.apache.poi.hssf.util.CellRangeAddressList
Deprecated.
CellRangeAddressList(RecordInputStream) - Constructor for class org.apache.poi.hssf.util.CellRangeAddressList
Deprecated.
CellRangeAddressList - Class in org.apache.poi.ss.util
Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas).
CellRangeAddressList() - Constructor for class org.apache.poi.ss.util.CellRangeAddressList

CellRangeAddressList(int, int, int, int) - Constructor for class org.apache.poi.ss.util.CellRangeAddressList
Convenience constructor for creating a CellRangeAddressList with a single CellRangeAddress.
CellRangeAddressList(RecordInputStream) - Constructor for class org.apache.poi.ss.util.CellRangeAddressList

CellRangeUtil - Class in org.apache.poi.hssf.record.cf

CellRecord - Class in org.apache.poi.hssf.record
Base class for all cell value records (implementors of CellValueRecordInterface).
CellRecord() - Constructor for class org.apache.poi.hssf.record.CellRecord

CellRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CellRecord

CellReference - Class in org.apache.poi.hssf.util
Common conversion functions between Excel style A1, C27 style cell references, and POI usermodel style row=0, column=0 style references.
CellReference(String) - Constructor for class org.apache.poi.hssf.util.CellReference
Create an cell ref from a string representation.
CellReference(int, int) - Constructor for class org.apache.poi.hssf.util.CellReference

CellReference(int, int, boolean, boolean) - Constructor for class org.apache.poi.hssf.util.CellReference

CellReference(String, int, int, boolean, boolean) - Constructor for class org.apache.poi.hssf.util.CellReference

CellReference - Class in org.apache.poi.ss.util

CellReference(String) - Constructor for class org.apache.poi.ss.util.CellReference
Create an cell ref from a string representation.
CellReference(int, int) - Constructor for class org.apache.poi.ss.util.CellReference

CellReference(int, short) - Constructor for class org.apache.poi.ss.util.CellReference

CellReference(Cell) - Constructor for class org.apache.poi.ss.util.CellReference

CellReference(int, int, boolean, boolean) - Constructor for class org.apache.poi.ss.util.CellReference

CellReference(String, int, int, boolean, boolean) - Constructor for class org.apache.poi.ss.util.CellReference

CellReference.NameType - Enum in org.apache.poi.ss.util
Used to classify identifiers found in formulas as cell references or not.
cellReferenceIsWithinRange(String, String, SpreadsheetVersion) - Static method in class org.apache.poi.ss.util.CellReference
Used to decide whether a name of the form "[A-Z]*[0-9]*" that appears in a formula can be interpreted as a cell reference.
cells - Variable in class org.apache.poi.hslf.model.Table

CellStyle - Interface in org.apache.poi.ss.usermodel

CellTextFormatter - Class in org.apache.poi.ss.format
This class implements printing out text.
CellTextFormatter(String) - Constructor for class org.apache.poi.ss.format.CellTextFormatter

CellUtil - Class in org.apache.poi.ss.util
Various utility functions that make working with a cells and rows easier.
CellValue - Class in org.apache.poi.ss.usermodel
Mimics the 'data view' of a cell.
CellValue(double) - Constructor for class org.apache.poi.ss.usermodel.CellValue

CellValue(String) - Constructor for class org.apache.poi.ss.usermodel.CellValue

CellValueRecordInterface - Interface in org.apache.poi.hssf.record
The cell value record interface is implemented by all classes of type Record that contain cell values.
CellWalk - Class in org.apache.poi.ss.util.cellwalk
Traverse cell range.
CellWalk(Sheet, CellRangeAddress) - Constructor for class org.apache.poi.ss.util.cellwalk.CellWalk

CellWalkContext - Interface in org.apache.poi.ss.util.cellwalk

CENTER - Static variable in class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

CENTER - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

CENTER_SELECTION - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

CENTER_TITLE_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

CenteredTitle - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the title text.
CENTRE_BODY_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

CertificateEmbeddingOption - Enum in org.apache.poi.openxml4j.opc
Specifies the location where the X.509 certificate that is used in signing is stored.
CF_BITMAP - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format - Bitmap
CF_DIB - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format - Device Independent Bitmap
CF_ENHMETAFILE - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format - Enhanced Windows metafile format
CF_METAFILEPICT - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format - Windows metafile format.
CFHeaderRecord - Class in org.apache.poi.hssf.record
Conditional Formatting Header record CFHEADER (0x01B0)
CFHeaderRecord() - Constructor for class org.apache.poi.hssf.record.CFHeaderRecord
Creates new CFHeaderRecord
CFHeaderRecord(CellRangeAddress[], int) - Constructor for class org.apache.poi.hssf.record.CFHeaderRecord

CFHeaderRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CFHeaderRecord

CFRecordsAggregate - Class in org.apache.poi.hssf.record.aggregates
CFRecordsAggregate - aggregates Conditional Formatting records CFHeaderRecord and number of up to three CFRuleRecord records together to simplify access to them.
CFRecordsAggregate(CellRangeAddress[], CFRuleRecord[]) - Constructor for class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

CFRuleRecord - Class in org.apache.poi.hssf.record
Conditional Formatting Rule Record (0x01B1).

CFRuleRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CFRuleRecord

CFRuleRecord.ComparisonOperator - Class in org.apache.poi.hssf.record

CFRuleRecord.ComparisonOperator() - Constructor for class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

CFTAG_FMTID - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format Tag - Format ID
CFTAG_MACINTOSH - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format Tag - Macintosh clipboard format
CFTAG_NODATA - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format Tag - No Data
CFTAG_WINDOWS - Static variable in class org.apache.poi.hpsf.Thumbnail
Clipboard Format Tag - Windows clipboard format
CH_ALT_STARTUP_DIR - Static variable in class org.apache.poi.hssf.record.SupBookRecord

CH_DOWN_DIR - Static variable in class org.apache.poi.hssf.record.SupBookRecord

CH_LIB_DIR - Static variable in class org.apache.poi.hssf.record.SupBookRecord

CH_LONG_VOLUME - Static variable in class org.apache.poi.hssf.record.SupBookRecord

CH_SAME_VOLUME - Static variable in class org.apache.poi.hssf.record.SupBookRecord

CH_STARTUP_DIR - Static variable in class org.apache.poi.hssf.record.SupBookRecord

CH_UP_DIR - Static variable in class org.apache.poi.hssf.record.SupBookRecord

CH_VOLUME - Static variable in class org.apache.poi.hssf.record.SupBookRecord

changeExternalReference(String, String) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Changes an external referenced file to another file.
changeExternalReference(String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Changes an external referenced file to another file.
changeName(Property, String) - Method in class org.apache.poi.poifs.property.DirectoryProperty
Change a Property's name
changeRowNum(SXSSFRow, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet

changeTextInRichTextRun(RichTextRun, String) - Method in class org.apache.poi.hslf.model.TextRun
Handles an update to the text stored in one of the Rich Text Runs
CHAR - Static variable in class org.apache.poi.ss.formula.functions.TextFunction
Returns the character specified by a number.
characterLength() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns the character length of a document.
characterLength() - Method in class org.apache.poi.hwpf.model.SinglentonTextPiece

characterLength() - Method in class org.apache.poi.hwpf.model.TextPiece
Deprecated.
CharacterProperties - Class in org.apache.poi.hwpf.usermodel

CharacterProperties() - Constructor for class org.apache.poi.hwpf.usermodel.CharacterProperties

CharacterPropertyFetcher<T> - Class in org.apache.poi.xslf.model

CharacterPropertyFetcher(int) - Constructor for class org.apache.poi.xslf.model.CharacterPropertyFetcher

CharacterRun - Class in org.apache.poi.hwpf.usermodel
This class represents a run of text that share common properties.
characters(char[], int, int) - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
Captures characters only if a t(ext) element is open.
characters(char[], int, int) - Method in class org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler
Captures characters only if a suitable element is open.
CharacterSprmCompressor - Class in org.apache.poi.hwpf.sprm

CharacterSprmCompressor() - Constructor for class org.apache.poi.hwpf.sprm.CharacterSprmCompressor

CharacterSprmUncompressor - Class in org.apache.poi.hwpf.sprm

CharacterSprmUncompressor() - Constructor for class org.apache.poi.hwpf.sprm.CharacterSprmUncompressor

characterTextPropTypes - Static variable in class org.apache.poi.hslf.record.StyleTextPropAtom
All the different kinds of character properties we might handle
CharFlagsTextProp - Class in org.apache.poi.hslf.model.textproperties
Definition for the common character text property bitset, which handles bold/italic/underline etc.
CharFlagsTextProp() - Constructor for class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

CharFormatAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

CharIndexTranslator - Interface in org.apache.poi.hwpf.model

charset - Variable in class org.apache.poi.hslf.model.PPFont

Chart - Interface in org.apache.poi.ss.usermodel
High level representation of a chart.
chart - Variable in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

CHART - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

CHART_PLUS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CHART_STAR - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CHART_X - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ChartAxis - Interface in org.apache.poi.ss.usermodel.charts
High level representation of chart axis.
ChartAxisFactory - Interface in org.apache.poi.ss.usermodel.charts
A factory for different chart axis.
ChartData - Interface in org.apache.poi.ss.usermodel.charts
A base for all charts data types.
ChartDataFactory - Interface in org.apache.poi.ss.usermodel.charts
A factory for different charts data types.
ChartDataSource<T> - Interface in org.apache.poi.ss.usermodel.charts
Represents data model of the charts.
ChartEndBlockRecord - Class in org.apache.poi.hssf.record.chart
ENDBLOCK - Chart Future Record Type End Block (0x0853)

ChartEndBlockRecord() - Constructor for class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

ChartEndBlockRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

ChartEndObjectRecord - Class in org.apache.poi.hssf.record.chart
ENDOBJECT - Chart Future Record Type End Object (0x0855)

ChartEndObjectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartEndObjectRecord

ChartFormatRecord - Class in org.apache.poi.hssf.record.chart
Class ChartFormatRecord (0x1014)
(As with all chart related records, documentation is lacking.
ChartFormatRecord() - Constructor for class org.apache.poi.hssf.record.chart.ChartFormatRecord

ChartFormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartFormatRecord

ChartFRTInfoRecord - Class in org.apache.poi.hssf.record.chart
CHARTFRTINFO - Chart Future Record Type Info (0x0850)

ChartFRTInfoRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

ChartLegend - Interface in org.apache.poi.ss.usermodel.charts
High level representation of chart legend.
ChartRecord - Class in org.apache.poi.hssf.record.chart
CHART (0x1002)
The chart record is used to define the location and size of a chart.
Chart related records don't seem to be covered in either the OOO or the MS documentation.
ChartRecord() - Constructor for class org.apache.poi.hssf.record.chart.ChartRecord

ChartRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartRecord

chartsheet - Variable in class org.apache.poi.xssf.usermodel.XSSFChartSheet

CHARTSHEET - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

ChartStartBlockRecord - Class in org.apache.poi.hssf.record.chart
STARTBLOCK - Chart Future Record Type Start Block (0x0852)

ChartStartBlockRecord() - Constructor for class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

ChartStartBlockRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

ChartStartObjectRecord - Class in org.apache.poi.hssf.record.chart
STARTOBJECT - Chart Future Record Type Start Object (0x0854)

ChartStartObjectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartStartObjectRecord

ChartSubstreamRecordAggregate - Class in org.apache.poi.hssf.record.aggregates
Manages the all the records associated with a chart sub-stream.
Includes the initial BOFRecord and final EOFRecord.
ChartSubstreamRecordAggregate(RecordStream) - Constructor for class org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate

ChartTitleFormatRecord - Class in org.apache.poi.hssf.record.chart
CHARTTITLEFORMAT (0x1050)
Describes the formatting runs associated with a chart title.
ChartTitleFormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

check(int) - Method in class org.apache.poi.util.CommonsLogger
Check if a logger is enabled to log at the specified level
check(int) - Method in class org.apache.poi.util.NullLogger
Check if a logger is enabled to log at the specified level
check(int) - Method in class org.apache.poi.util.POILogger
Check if a logger is enabled to log at the specified level
check(int) - Method in class org.apache.poi.util.SystemOutLogger
Check if a logger is enabled to log at the specified level
checkElementForOPCCompliance(Element) - Method in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller
Check the element for the following OPC compliance rules:
checkExternSheet(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
returns the extern sheet number for specific sheet number , if this sheet doesn't exist in extern sheet , add it
checkIfEncrypted(HSLFSlideShow) - Static method in class org.apache.poi.hslf.EncryptedSlideShow
Check to see if a HSLFSlideShow represents an encrypted PowerPoint document, or not
checksum - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

CHECKSUM_SIZE - Static variable in class org.apache.poi.hslf.usermodel.PictureData
Size of the image checksum calculated using MD5 algorithm.
checkValue(double) - Static method in class org.apache.poi.ss.formula.functions.NumericFunction

Chevron - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CHEVRON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Child - Interface in org.apache.poi.poifs.property
This interface defines methods for finding and setting sibling Property instances
CHILDRENS_NAMES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Choose - Class in org.apache.poi.ss.formula.functions

Choose() - Constructor for class org.apache.poi.ss.formula.functions.Choose

chooseSingleElementFromArea(AreaEval, int, int) - Static method in class org.apache.poi.ss.formula.eval.OperandResolver
Implements (some perhaps not well known) Excel functionality to select a single cell from an area depending on the coordinates of the calling cell.
CHORD - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CHPAbstractType - Class in org.apache.poi.hwpf.model.types
Character Properties.
CHPAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.CHPAbstractType

CHPBinTable - Class in org.apache.poi.hwpf.model
This class holds all of the character formatting properties.
CHPBinTable() - Constructor for class org.apache.poi.hwpf.model.CHPBinTable

CHPBinTable(byte[], byte[], int, int, int, TextPieceTable) - Constructor for class org.apache.poi.hwpf.model.CHPBinTable
Deprecated. Use CHPBinTable.CHPBinTable(byte[], byte[], int, int, CharIndexTranslator) instead
CHPBinTable(byte[], byte[], int, int, CharIndexTranslator) - Constructor for class org.apache.poi.hwpf.model.CHPBinTable
Constructor used to read a binTable in from a Word document.
CHPFormattedDiskPage - Class in org.apache.poi.hwpf.model
Represents a CHP fkp.
CHPFormattedDiskPage() - Constructor for class org.apache.poi.hwpf.model.CHPFormattedDiskPage

CHPFormattedDiskPage(byte[], int, int, TextPieceTable) - Constructor for class org.apache.poi.hwpf.model.CHPFormattedDiskPage
Deprecated. Use CHPFormattedDiskPage.CHPFormattedDiskPage(byte[], int, CharIndexTranslator) instead
CHPFormattedDiskPage(byte[], int, CharIndexTranslator) - Constructor for class org.apache.poi.hwpf.model.CHPFormattedDiskPage
This constructs a CHPFormattedDiskPage from a raw fkp (512 byte array read from a Word file).
CHPX - Class in org.apache.poi.hwpf.model
DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
CHPX(int, int, CharIndexTranslator, byte[]) - Constructor for class org.apache.poi.hwpf.model.CHPX
Deprecated.
CHPX(int, int, CharIndexTranslator, SprmBuffer) - Constructor for class org.apache.poi.hwpf.model.CHPX
Deprecated.
Chunk - Class in org.apache.poi.hdgf.chunks
Base of all chunks, which hold data, flags etc
Chunk(ChunkHeader, ChunkTrailer, ChunkSeparator, byte[]) - Constructor for class org.apache.poi.hdgf.chunks.Chunk

Chunk - Class in org.apache.poi.hsmf.datatypes

Chunk(String, int, int) - Constructor for class org.apache.poi.hsmf.datatypes.Chunk

Chunk(int, int) - Constructor for class org.apache.poi.hsmf.datatypes.Chunk

Chunk.BlockOffsetCommand - Class in org.apache.poi.hdgf.chunks
A special kind of command that holds the offset to a block
Chunk.Command - Class in org.apache.poi.hdgf.chunks
A command in the visio file.
ChunkFactory - Class in org.apache.poi.hdgf.chunks
Factor class to create the appropriate chunks, which needs the version of the file to process the chunk header and trailer areas.
ChunkFactory(int) - Constructor for class org.apache.poi.hdgf.chunks.ChunkFactory

ChunkFactory.CommandDefinition - Class in org.apache.poi.hdgf.chunks
The definition of a Command, which a chunk may hold.
ChunkFactory.CommandDefinition(int, int, String) - Constructor for class org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition

ChunkGroup - Interface in org.apache.poi.hsmf.datatypes
A group of chunks, that are at the same point in the file structure.
ChunkHeader - Class in org.apache.poi.hdgf.chunks
A chunk header
ChunkHeader() - Constructor for class org.apache.poi.hdgf.chunks.ChunkHeader

ChunkHeaderV11 - Class in org.apache.poi.hdgf.chunks
A chunk header from v11+
ChunkHeaderV11() - Constructor for class org.apache.poi.hdgf.chunks.ChunkHeaderV11

ChunkHeaderV4V5 - Class in org.apache.poi.hdgf.chunks
A chunk header from v4 or v5
ChunkHeaderV4V5() - Constructor for class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

ChunkHeaderV6 - Class in org.apache.poi.hdgf.chunks
A chunk header from v6
ChunkHeaderV6() - Constructor for class org.apache.poi.hdgf.chunks.ChunkHeaderV6

chunkId - Variable in class org.apache.poi.hsmf.datatypes.Chunk

ChunkNotFoundException - Exception in org.apache.poi.hsmf.exceptions

ChunkNotFoundException() - Constructor for exception org.apache.poi.hsmf.exceptions.ChunkNotFoundException

ChunkNotFoundException(String) - Constructor for exception org.apache.poi.hsmf.exceptions.ChunkNotFoundException

Chunks - Class in org.apache.poi.hsmf.datatypes
Collection of convenience chunks for standard parts of the MSG file.
Chunks() - Constructor for class org.apache.poi.hsmf.datatypes.Chunks

ChunkSeparator - Class in org.apache.poi.hdgf.chunks
A separator between the trailer of one chunk, and the header of the next one
ChunkSeparator(byte[], int) - Constructor for class org.apache.poi.hdgf.chunks.ChunkSeparator

ChunkStream - Class in org.apache.poi.hdgf.streams

ChunkStream(Pointer, StreamStore, ChunkFactory) - Constructor for class org.apache.poi.hdgf.streams.ChunkStream

ChunkTrailer - Class in org.apache.poi.hdgf.chunks
A trailer that follows a chunk
ChunkTrailer(byte[], int) - Constructor for class org.apache.poi.hdgf.chunks.ChunkTrailer

CIRCULAR_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CIRCULAR_REF_ERROR - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval

CircularArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

claim(int) - Method in class org.apache.poi.poifs.filesystem.BlockStore.ChainLoopDetector

CLASS_ARRAY - Static variable in class org.apache.poi.ss.formula.ptg.Ptg

CLASS_REF - Static variable in class org.apache.poi.ss.formula.ptg.Ptg

CLASS_VALUE - Static variable in class org.apache.poi.ss.formula.ptg.Ptg

ClassID - Class in org.apache.poi.hpsf
Represents a class ID (16 bytes).
ClassID(byte[], int) - Constructor for class org.apache.poi.hpsf.ClassID
Creates a ClassID and reads its value from a byte array.
ClassID() - Constructor for class org.apache.poi.hpsf.ClassID
Creates a ClassID and initializes its value with 0x00 bytes.
classID - Variable in class org.apache.poi.hpsf.PropertySet
Specifies this PropertySet's "classID" field.
classifyCellReference(String, SpreadsheetVersion) - Static method in class org.apache.poi.ss.util.CellReference
Classifies an identifier as either a simple (2D) cell reference or a named range name
CLEAN - Static variable in class org.apache.poi.ss.formula.functions.TextFunction
An implementation of the CLEAN function: In Excel, the Clean function removes all non-printable characters from a string.
cleanColumns() - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

clear() - Method in class org.apache.poi.hpsf.MutableSection
Removes all properties from the section including 0 (dictionary) and 1 (codepage).
clear() - Method in class org.apache.poi.hssf.record.EscherAggregate

clear() - Method in class org.apache.poi.hssf.util.LazilyConcatenatedByteArray
Clears the array (sets the concatenated length back to zero.
clear() - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

clear() - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Clear all relationships.
clear() - Method in class org.apache.poi.util.BinaryTree
Removes all mappings from this map
clear(int) - Method in class org.apache.poi.util.BitField
Clear the bits.
clear() - Method in class org.apache.poi.util.IntList
Removes all of the elements from this list.
clear() - Method in class org.apache.poi.util.ShortList
Removes all of the elements from this list.
clear() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape
Removes all of the elements from this container (optional operation).
clear() - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
Removes all of the elements from this container (optional operation).
clear() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Removes all of the elements from this container (optional operation).
clearAll() - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Clear all content types.
clearAllCachedResultValues() - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Should be called whenever there are major changes (e.g.
clearAllCachedResultValues() - Method in class org.apache.poi.ss.formula.WorkbookEvaluator
Should be called whenever there are changes to input cells in the evaluated workbook.
clearAllCachedResultValues() - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
Should be called whenever there are changes to input cells in the evaluated workbook.
clearAllCachedResultValues() - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
Should be called whenever there are major changes (e.g.
clearByte(byte) - Method in class org.apache.poi.util.BitField
Clear the bits.
clearDrawingGroups() - Method in class org.apache.poi.hssf.model.DrawingManager2
Clears the cached list of drawing groups
clearEscherRecords() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

clearFields() - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

clearFormatting() - Method in class org.apache.poi.hssf.record.common.UnicodeString

clearFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Removes any formatting that may have been applied to the string.
clearFormatting() - Method in interface org.apache.poi.ss.usermodel.RichTextString
Removes any formatting that may have been applied to the string.
clearFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Removes any formatting that may have been applied to the string.
clearOffsetsSizes() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

clearOverrideContentTypes() - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Clear all override content types.
clearRect(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Clears the specified rectangle by filling it with the background color of the current drawing surface.
clearRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

clearRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

clearRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

clearRelationships() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Clear package relationships.
clearRelationships() - Method in class org.apache.poi.openxml4j.opc.PackagePart

clearRelationships() - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Delete all the relationships attached to this.
clearSections() - Method in class org.apache.poi.hpsf.MutablePropertySet
Removes all sections from this property set.
clearSections() - Method in class org.apache.poi.hpsf.SpecialPropertySet

clearShort(short) - Method in class org.apache.poi.util.BitField
Clear the bits.
clearSubRecords() - Method in class org.apache.poi.hssf.record.ObjRecord

clearText() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
unset text from this shape
CLIENT_SUBMIT_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ClientAnchor - Interface in org.apache.poi.ss.usermodel
A client anchor is attached to an excel worksheet.
clip(Shape) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Intersects the current Clip with the interior of the specified Shape and sets the Clip to the resulting intersection.
clip(Shape) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

clip(Shape) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

ClipArt - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a clipart object.
clipRect(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Intersects the current clip with the specified rectangle.
clipRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

clipRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

clipRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

clone() - Method in class org.apache.poi.ddf.EscherRecord
Escher records may need to be clonable in the future.
clone() - Method in class org.apache.poi.ddf.EscherTextboxRecord

clone() - Method in class org.apache.poi.ddf.UnknownEscherRecord

clone() - Method in class org.apache.poi.hslf.model.textproperties.BitMaskTextProp

clone() - Method in class org.apache.poi.hslf.model.textproperties.TextProp
Clone, eg when you want to actually make use of one of these.
clone() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

clone() - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate
Performs a deep clone of the record
clone() - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

clone() - Method in class org.apache.poi.hssf.record.AutoFilterInfoRecord

clone() - Method in class org.apache.poi.hssf.record.BlankRecord

clone() - Method in class org.apache.poi.hssf.record.BOFRecord

clone() - Method in class org.apache.poi.hssf.record.BoolErrRecord

clone() - Method in class org.apache.poi.hssf.record.BottomMarginRecord

clone() - Method in class org.apache.poi.hssf.record.CalcCountRecord

clone() - Method in class org.apache.poi.hssf.record.CalcModeRecord

clone() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting

clone() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

clone() - Method in class org.apache.poi.hssf.record.cf.PatternFormatting

clone() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

clone() - Method in class org.apache.poi.hssf.record.CFRuleRecord

clone() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord

clone() - Method in class org.apache.poi.hssf.record.chart.AreaRecord

clone() - Method in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

clone() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord

clone() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord

clone() - Method in class org.apache.poi.hssf.record.chart.AxisRecord

clone() - Method in class org.apache.poi.hssf.record.chart.AxisUsedRecord

clone() - Method in class org.apache.poi.hssf.record.chart.BarRecord

clone() - Method in class org.apache.poi.hssf.record.chart.BeginRecord

clone() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

clone() - Method in class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

clone() - Method in class org.apache.poi.hssf.record.chart.ChartRecord

clone() - Method in class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

clone() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord

clone() - Method in class org.apache.poi.hssf.record.chart.DatRecord

clone() - Method in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

clone() - Method in class org.apache.poi.hssf.record.chart.EndRecord

clone() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord

clone() - Method in class org.apache.poi.hssf.record.chart.FontIndexRecord

clone() - Method in class org.apache.poi.hssf.record.chart.FrameRecord

clone() - Method in class org.apache.poi.hssf.record.chart.LegendRecord

clone() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord

clone() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord

clone() - Method in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

clone() - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

clone() - Method in class org.apache.poi.hssf.record.chart.PlotAreaRecord

clone() - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SeriesIndexRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SeriesListRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

clone() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

clone() - Method in class org.apache.poi.hssf.record.chart.TextRecord

clone() - Method in class org.apache.poi.hssf.record.chart.TickRecord

clone() - Method in class org.apache.poi.hssf.record.chart.UnitsRecord

clone() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord

clone() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

clone() - Method in class org.apache.poi.hssf.record.common.UnicodeString

clone() - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

clone() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

clone() - Method in class org.apache.poi.hssf.record.ContinueRecord

clone() - Method in class org.apache.poi.hssf.record.DBCellRecord

clone() - Method in class org.apache.poi.hssf.record.DefaultColWidthRecord

clone() - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord

clone() - Method in class org.apache.poi.hssf.record.DeltaRecord

clone() - Method in class org.apache.poi.hssf.record.DimensionsRecord

clone() - Method in class org.apache.poi.hssf.record.DrawingRecord

clone() - Method in class org.apache.poi.hssf.record.DrawingSelectionRecord

clone() - Method in class org.apache.poi.hssf.record.DVALRecord

clone() - Method in class org.apache.poi.hssf.record.DVRecord
Clones the object.
clone() - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

clone() - Method in class org.apache.poi.hssf.record.EndSubRecord

clone() - Method in class org.apache.poi.hssf.record.EOFRecord

clone() - Method in class org.apache.poi.hssf.record.FeatHdrRecord

clone() - Method in class org.apache.poi.hssf.record.FeatRecord

clone() - Method in class org.apache.poi.hssf.record.FilePassRecord

clone() - Method in class org.apache.poi.hssf.record.FileSharingRecord
Clone this record.
clone() - Method in class org.apache.poi.hssf.record.FooterRecord

clone() - Method in class org.apache.poi.hssf.record.FormatRecord

clone() - Method in class org.apache.poi.hssf.record.FormulaRecord

clone() - Method in class org.apache.poi.hssf.record.FtCblsSubRecord

clone() - Method in class org.apache.poi.hssf.record.GridsetRecord

clone() - Method in class org.apache.poi.hssf.record.GroupMarkerSubRecord

clone() - Method in class org.apache.poi.hssf.record.GutsRecord

clone() - Method in class org.apache.poi.hssf.record.HCenterRecord

clone() - Method in class org.apache.poi.hssf.record.HeaderFooterRecord

clone() - Method in class org.apache.poi.hssf.record.HeaderRecord

clone() - Method in class org.apache.poi.hssf.record.HorizontalPageBreakRecord

clone() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

clone() - Method in class org.apache.poi.hssf.record.IndexRecord

clone() - Method in class org.apache.poi.hssf.record.IterationRecord

clone() - Method in class org.apache.poi.hssf.record.LabelRecord

clone() - Method in class org.apache.poi.hssf.record.LabelSSTRecord

clone() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord

clone() - Method in class org.apache.poi.hssf.record.LeftMarginRecord

clone() - Method in class org.apache.poi.hssf.record.MergeCellsRecord

clone() - Method in class org.apache.poi.hssf.record.MulBlankRecord

clone() - Method in class org.apache.poi.hssf.record.NoteRecord

clone() - Method in class org.apache.poi.hssf.record.NoteStructureSubRecord

clone() - Method in class org.apache.poi.hssf.record.NumberRecord

clone() - Method in class org.apache.poi.hssf.record.ObjectProtectRecord

clone() - Method in class org.apache.poi.hssf.record.ObjRecord

clone() - Method in class org.apache.poi.hssf.record.PaneRecord

clone() - Method in class org.apache.poi.hssf.record.PasswordRecord
Clone this record.
clone() - Method in class org.apache.poi.hssf.record.PrintGridlinesRecord

clone() - Method in class org.apache.poi.hssf.record.PrintHeadersRecord

clone() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

clone() - Method in class org.apache.poi.hssf.record.ProtectRecord

clone() - Method in class org.apache.poi.hssf.record.Record

clone() - Method in class org.apache.poi.hssf.record.RefModeRecord

clone() - Method in class org.apache.poi.hssf.record.RefreshAllRecord

clone() - Method in class org.apache.poi.hssf.record.RightMarginRecord

clone() - Method in class org.apache.poi.hssf.record.RKRecord

clone() - Method in class org.apache.poi.hssf.record.RowRecord

clone() - Method in class org.apache.poi.hssf.record.SaveRecalcRecord

clone() - Method in class org.apache.poi.hssf.record.ScenarioProtectRecord

clone() - Method in class org.apache.poi.hssf.record.SCLRecord

clone() - Method in class org.apache.poi.hssf.record.SelectionRecord

clone() - Method in class org.apache.poi.hssf.record.SharedFormulaRecord

clone() - Method in class org.apache.poi.hssf.record.StringRecord

clone() - Method in class org.apache.poi.hssf.record.SubRecord

clone() - Method in class org.apache.poi.hssf.record.TextObjectRecord

clone() - Method in class org.apache.poi.hssf.record.TopMarginRecord

clone() - Method in class org.apache.poi.hssf.record.UnknownRecord

clone() - Method in class org.apache.poi.hssf.record.UserSViewBegin

clone() - Method in class org.apache.poi.hssf.record.UserSViewEnd

clone() - Method in class org.apache.poi.hssf.record.UseSelFSRecord

clone() - Method in class org.apache.poi.hssf.record.VCenterRecord

clone() - Method in class org.apache.poi.hssf.record.VerticalPageBreakRecord

clone() - Method in class org.apache.poi.hssf.record.WindowProtectRecord

clone() - Method in class org.apache.poi.hssf.record.WindowTwoRecord

clone() - Method in class org.apache.poi.hssf.record.WSBoolRecord

clone() - Method in class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

clone() - Method in class org.apache.poi.hwpf.model.Colorref

clone() - Method in class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

clone() - Method in class org.apache.poi.hwpf.model.Hyphenation

clone() - Method in class org.apache.poi.hwpf.model.PropertyModifier

clone() - Method in class org.apache.poi.hwpf.model.PropertyNode

clone() - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

clone() - Method in class org.apache.poi.hwpf.usermodel.BorderCode

clone() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

clone() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Used to create a deep copy of this object.
clone() - Method in class org.apache.poi.hwpf.usermodel.DateAndTime

clone() - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

clone() - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

clone() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

clone() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

clone() - Method in class org.apache.poi.hwpf.usermodel.Section

clone() - Method in class org.apache.poi.hwpf.usermodel.SectionProperties

clone() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor

clone() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

clone() - Method in class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

clone() - Method in class org.apache.poi.hwpf.usermodel.TableCellDescriptor

clone() - Method in class org.apache.poi.hwpf.usermodel.TableProperties

clone() - Method in class org.apache.poi.openxml4j.opc.PackagePartCollection

clone(OPCPackage, File) - Static method in class org.apache.poi.util.PackageHelper
Clone the specified package.
clone() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Make a copy of this style.
cloneCFAggregate() - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate
Create a deep clone of the record
cloneCol(CTCols, CTCol) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

cloneDrawings(InternalSheet) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Check if the cloned sheet has drawings.
cloneFilter(int, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook

cloneProperties() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Deprecated. This method shall not be public and should not be called from high-level code
cloneProperties() - Method in class org.apache.poi.hwpf.usermodel.Paragraph
clone the ParagraphProperties object associated with this Paragraph so that you can apply the same properties to another paragraph.
cloneSheet() - Method in class org.apache.poi.hssf.model.InternalSheet
Clones the low level records of this sheet and returns the new sheet instance.
cloneSheet(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
create an HSSFSheet from an existing sheet in the HSSFWorkbook.
cloneSheet(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Create an Sheet from an existing sheet in the Workbook.
cloneSheet(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Create an Sheet from an existing sheet in the Workbook.
cloneSheet(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Create an XSSFSheet from an existing sheet in the XSSFWorkbook.
cloneStyleFrom(ExtendedFormatRecord) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
Clones all the style information from another ExtendedFormatRecord, onto this one.
cloneStyleFrom(FontRecord) - Method in class org.apache.poi.hssf.record.FontRecord
Clones all the font style information from another FontRecord, onto this one.
cloneStyleFrom(CellStyle) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Clones all the style information from another HSSFCellStyle, onto this one.
cloneStyleFrom(HSSFCellStyle) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle

cloneStyleFrom(CellStyle) - Method in interface org.apache.poi.ss.usermodel.CellStyle
Clones all the style information from another CellStyle, onto this one.
cloneStyleFrom(CellStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Clones all the style information from another XSSFCellStyle, onto this one.
cloneViaReserialise() - Method in class org.apache.poi.hssf.record.Record
Clone the current record, via a call to serialize it, and another to create a new record from the bytes.
close() - Method in class org.apache.poi.hslf.dev.SlideShowDumper
Shuts things down.
close() - Method in class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
Shuts down the underlying streams
close() - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

close() - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream
Close this stream and flush the content.
close() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

close() - Method in class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

close() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Close the open, writable package and save its content.
close() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Close this part : flush this part, close the input stream and output stream.
close() - Method in class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

close() - Method in class org.apache.poi.openxml4j.opc.ZipPackagePart

close() - Method in interface org.apache.poi.openxml4j.util.ZipEntrySource
Indicates we are done with reading, and resources may be freed
close() - Method in class org.apache.poi.openxml4j.util.ZipFileZipEntrySource

close() - Method in class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource

close() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

close() - Method in class org.apache.poi.poifs.filesystem.DocumentOutputStream
Closes this output stream and releases any system resources associated with this stream.
close() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

close() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Closes the FileSystem, freeing any underlying files, streams and buffers.
close() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

close() - Method in class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

close() - Method in class org.apache.poi.poifs.nio.DataSource
Close the underlying stream
close() - Method in class org.apache.poi.poifs.nio.FileBackedDataSource

close() - Method in class org.apache.poi.util.BlockingInputStream

close() - Method in class org.apache.poi.util.CloseIgnoringInputStream

close() - Method in class org.apache.poi.xssf.streaming.SheetDataWriter
flush and close the temp data writer.
CLOSED_CURVES - Static variable in class org.apache.poi.ddf.EscherShapePathProperty

CLOSED_POLYGON - Static variable in class org.apache.poi.ddf.EscherShapePathProperty

CloseIgnoringInputStream - Class in org.apache.poi.util
A wrapper around an InputStream, which ignores close requests made to it.
CloseIgnoringInputStream(InputStream) - Constructor for class org.apache.poi.util.CloseIgnoringInputStream

closeImpl() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Close the package and cause a save of the package.
closeImpl() - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Close and save the package.
ClosePathCommand - Class in org.apache.poi.xslf.model.geom
Date: 10/25/11
closeQuietly(Closeable) - Static method in class org.apache.poi.util.IOUtils
Quietly (no exceptions) close Closable resource.
CLOUD - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CLOUD_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CloudCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CLS_ID - Static variable in class org.apache.poi.hsmf.datatypes.Types
ClassId - OLE GUID
CLX - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

CMDS - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

CODENAME_1BA - Static variable in class org.apache.poi.hssf.record.UnknownRecord

CODEPAGE - Static variable in class org.apache.poi.hssf.record.CodepageRecord
the likely correct value for CODEPAGE (at least for US versions).
CODEPAGE - Static variable in class org.apache.poi.hssf.record.InterfaceHdrRecord
suggested (and probably correct) default
CodepageRecord - Class in org.apache.poi.hssf.record
Title: Codepage Record
CodepageRecord() - Constructor for class org.apache.poi.hssf.record.CodepageRecord

CodepageRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CodepageRecord

codepageToEncoding(int) - Static method in class org.apache.poi.hpsf.VariantSupport
Turns a codepage number into the equivalent character encoding's name.
coerceValueToBoolean(ValueEval, boolean) - Static method in class org.apache.poi.ss.formula.eval.OperandResolver

coerceValueToDouble(ValueEval) - Static method in class org.apache.poi.ss.formula.eval.OperandResolver
Applies some conversion rules if the supplied value is not already a number.
coerceValueToInt(ValueEval) - Static method in class org.apache.poi.ss.formula.eval.OperandResolver
Applies some conversion rules if the supplied value is not already an integer.
Value is first coerced to a double ( See coerceValueToDouble() ).
coerceValueToString(ValueEval) - Static method in class org.apache.poi.ss.formula.eval.OperandResolver

CollaboratingWorkbooksEnvironment - Class in org.apache.poi.ss.formula
Manages a collection of WorkbookEvaluators, in order to support evaluation of formulas across spreadsheets.
For POI internal use only
CollaboratingWorkbooksEnvironment.WorkbookNotFoundException - Exception in org.apache.poi.ss.formula

collapseColumn(int) - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

collapseRow(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

Color - Interface in org.apache.poi.ss.usermodel

COLOR_GROUP - Static variable in class org.apache.poi.ss.format.CellFormatPart
Within CellFormatPart.FORMAT_PAT, the group number for the matched color.
COLOR_NORMAL - Static variable in interface org.apache.poi.ss.usermodel.Font
normal type of black color.
COLOR_PAT - Static variable in class org.apache.poi.ss.format.CellFormatPart
Pattern for the color part of a cell format part.
COLOR_RED - Static variable in interface org.apache.poi.ss.usermodel.Font
Dark Red color
Colorref - Class in org.apache.poi.hwpf.model
24-bit color structure
Colorref() - Constructor for class org.apache.poi.hwpf.model.Colorref

Colorref(byte[], int) - Constructor for class org.apache.poi.hwpf.model.Colorref

Colorref(int) - Constructor for class org.apache.poi.hwpf.model.Colorref

ColorSchemeAtom - Class in org.apache.poi.hslf.record
A ColorSchemeAtom (type 2032).
ColorSchemeAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ColorSchemeAtom
For the Colour Scheme (ColorSchem) Atom
ColorSchemeAtom() - Constructor for class org.apache.poi.hslf.record.ColorSchemeAtom
Create a new ColorSchemeAtom, to go with a new Slide
ColorSchemeAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

Column - Class in org.apache.poi.ss.formula.functions

Column() - Constructor for class org.apache.poi.ss.formula.functions.Column

columnExists(CTCols, long) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper
Does the column at the given 0 based index exist in the supplied list of column definitions?
ColumnHelper - Class in org.apache.poi.xssf.usermodel.helpers
Helper class for dealing with the Column settings on a CTWorksheet (the data part of a sheet).
ColumnHelper(CTWorksheet) - Constructor for class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

ColumnInfoRecord - Class in org.apache.poi.hssf.record
Title: COLINFO Record (0x007D)
Description: Defines with width and formatting for a range of columns
REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

ColumnInfoRecord() - Constructor for class org.apache.poi.hssf.record.ColumnInfoRecord
Creates a column info record with default width and format
ColumnInfoRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ColumnInfoRecord

ColumnInfoRecordsAggregate - Class in org.apache.poi.hssf.record.aggregates

ColumnInfoRecordsAggregate() - Constructor for class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate
Creates an empty aggregate
ColumnInfoRecordsAggregate(RecordStream) - Constructor for class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

Columns - Class in org.apache.poi.ss.formula.functions
Implementation for Excel COLUMNS function.
Columns() - Constructor for class org.apache.poi.ss.formula.functions.Columns

COMBIN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

combine(ExternSheetRecord[]) - Static method in class org.apache.poi.hssf.record.ExternSheetRecord

combine(URI, URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Combine two URIs.
combine(String, String) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Combine a string URI with a prefix and a suffix.
ComboboxShape - Class in org.apache.poi.hssf.model
Represents a combobox shape.
commandDefinitions - Variable in class org.apache.poi.hdgf.chunks.Chunk
The possible different commands we can hold
CommandLineTextExtractor - Class in org.apache.poi.extractor
A command line wrapper around ExtractorFactory, useful for when debugging.
CommandLineTextExtractor() - Constructor for class org.apache.poi.extractor.CommandLineTextExtractor

Comment - Class in org.apache.poi.hslf.model

Comment(Comment2000) - Constructor for class org.apache.poi.hslf.model.Comment

COMMENT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Comment - Interface in org.apache.poi.ss.usermodel

COMMENT - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

Comment2000 - Class in org.apache.poi.hslf.record
This class represents a comment on a slide, in the format used by PPT 2000/XP/etc.
Comment2000(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.Comment2000
Set things up, and find our more interesting children
Comment2000() - Constructor for class org.apache.poi.hslf.record.Comment2000
Create a new Comment2000, with blank fields
Comment2000 - Static variable in class org.apache.poi.hslf.record.RecordTypes

Comment2000Atom - Class in org.apache.poi.hslf.record
An atomic record containing information about a comment.
Comment2000Atom() - Constructor for class org.apache.poi.hslf.record.Comment2000Atom
Constructs a brand new comment atom record.
Comment2000Atom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.Comment2000Atom
Constructs the comment atom record from its source data.
Comment2000Atom - Static variable in class org.apache.poi.hslf.record.RecordTypes

Comment2000Summary - Static variable in class org.apache.poi.hslf.record.RecordTypes

Comment2000SummaryAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

COMMENT_AUTHORS - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

COMMENTS - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

comments - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

CommentShape - Class in org.apache.poi.hssf.model
Represents a cell comment.
CommentShape(HSSFComment, int) - Constructor for class org.apache.poi.hssf.model.CommentShape
Creates the low-level records for a comment.
CommentsTable - Class in org.apache.poi.xssf.model

CommentsTable() - Constructor for class org.apache.poi.xssf.model.CommentsTable

CommentsTable(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.model.CommentsTable

commit() - Method in class org.apache.poi.POIXMLDocumentPart
Save the content in the underlying package part.
commit() - Method in class org.apache.poi.POIXMLProperties
Commit changes to the underlying OPC package
commit() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow

commit() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

commit() - Method in class org.apache.poi.xslf.usermodel.XSLFTheme

commit() - Method in class org.apache.poi.xssf.model.CalculationChain

commit() - Method in class org.apache.poi.xssf.model.CommentsTable

commit() - Method in class org.apache.poi.xssf.model.MapInfo

commit() - Method in class org.apache.poi.xssf.model.SharedStringsTable

commit() - Method in class org.apache.poi.xssf.model.SingleXmlCells

commit() - Method in class org.apache.poi.xssf.model.StylesTable

commit() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

commit() - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing

commit() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

commit() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

commit() - Method in class org.apache.poi.xssf.usermodel.XSSFVMLDrawing

commit() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

commit() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
commit and saves the document
commit() - Method in class org.apache.poi.xwpf.usermodel.XWPFFooter
save and commit footer
commit() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes

commit() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeader
save and commit footer
commit() - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
save and commit numbering
commit() - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings

commit() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles

COMMON_VIEWS_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CommonObjectDataSubRecord - Class in org.apache.poi.hssf.record
The common object data record is used to store all common preferences for an excel object.

CommonObjectDataSubRecord() - Constructor for class org.apache.poi.hssf.record.CommonObjectDataSubRecord

CommonObjectDataSubRecord(LittleEndianInput, int) - Constructor for class org.apache.poi.hssf.record.CommonObjectDataSubRecord

CommonsLogger - Class in org.apache.poi.util
A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
CommonsLogger() - Constructor for class org.apache.poi.util.CommonsLogger

COMPANY_MAIN_PHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

COMPANY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

compare(AttachmentChunks, AttachmentChunks) - Method in class org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter

compare(RecipientChunks, RecipientChunks) - Method in class org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter

compare(PropertyNode<?>, PropertyNode<?>) - Method in class org.apache.poi.hwpf.model.PropertyNode.EndComparator

compare(PropertyNode<?>, PropertyNode<?>) - Method in class org.apache.poi.hwpf.model.PropertyNode.StartComparator

compare(Property, Property) - Method in class org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator
compare method.
compare(double, double) - Static method in class org.apache.poi.ss.util.NumberComparer
This class attempts to reproduce Excel's behaviour for comparing numbers.
compare(String, String) - Method in class org.apache.poi.xssf.extractor.XSSFExportToXml
Compares two xpaths to define an ordering according to the XML Schema
compare(CTCol, CTCol) - Method in class org.apache.poi.xssf.util.CTColComparator

compareTo(UnicodeString) - Method in class org.apache.poi.hssf.record.common.UnicodeString

compareTo(UnicodeString.ExtRst) - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

compareTo(UnicodeString.FormatRun) - Method in class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

compareTo(HSSFRichTextString) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Compares one rich text string to another.
compareTo(Object) - Method in class org.apache.poi.hssf.usermodel.HSSFRow

compareTo(T) - Method in class org.apache.poi.hwpf.model.PropertyNode
Used for sorting in collections.
compareTo(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.PackagePartName
Compare two part name following the rule M1.12 : Part name equivalence is determined by comparing part names as case-insensitive ASCII strings.
compareTo(Region) - Method in class org.apache.poi.ss.util.Region
Deprecated. Compares that the given region is the same less than or greater than this region.
compareTo(XSSFRow) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Compares two XSSFRow objects.
ComparisonOperator - Class in org.apache.poi.ss.usermodel
The conditional format operators used for "Highlight Cells That Contain..." rules.
ComparisonOperator() - Constructor for class org.apache.poi.ss.usermodel.ComparisonOperator

COMPLEX - Static variable in class org.apache.poi.ddf.EscherShapePathProperty

ComplexFileTable - Class in org.apache.poi.hwpf.model

ComplexFileTable() - Constructor for class org.apache.poi.hwpf.model.ComplexFileTable

ComplexFileTable(byte[], byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.ComplexFileTable

CompositeMasterId - Static variable in class org.apache.poi.hslf.record.RecordTypes

compress(byte[]) - Static method in class org.apache.poi.ddf.EscherBlipWMFRecord
Compress the contents of the provided array
compress(InputStream) - Method in class org.apache.poi.hdgf.HDGFLZW
Compress the given input stream, returning the array of bytes of the compressed input
compress(InputStream, OutputStream) - Method in class org.apache.poi.hdgf.HDGFLZW
Performs the Visio compatible streaming LZW compression.
compress(byte[], int, int) - Method in class org.apache.poi.hslf.blip.Metafile

compressCharacterProperty(CharacterProperties, CharacterProperties) - Static method in class org.apache.poi.hwpf.sprm.CharacterSprmCompressor

COMPRESSED1 - Static variable in class org.apache.poi.hwpf.usermodel.Picture

COMPRESSED2 - Static variable in class org.apache.poi.hwpf.usermodel.Picture

COMPRESSED_SIGNATURE - Static variable in class org.apache.poi.hmef.CompressedRTF

COMPRESSED_SIGNATURE_INT - Static variable in class org.apache.poi.hmef.CompressedRTF

CompressedRTF - Class in org.apache.poi.hmef
Within a HMEFMessage, the content is often stored in as RTF, but LZW compressed.
CompressedRTF() - Constructor for class org.apache.poi.hmef.CompressedRTF

CompressedStreamStore - Class in org.apache.poi.hdgf.streams
A StreamStore where the data on-disk is compressed, using the crazy Visio LZW
CompressedStreamStore(byte[], int, int) - Constructor for class org.apache.poi.hdgf.streams.CompressedStreamStore
Creates a new compressed StreamStore, which will handle the decompression.
compression - Variable in class org.apache.poi.hslf.blip.Metafile.Header
Reserved.
CompressionOption - Enum in org.apache.poi.openxml4j.opc
Specifies the compression level for content that is stored in a PackagePart.
compressParagraphProperty(ParagraphProperties, ParagraphProperties) - Static method in class org.apache.poi.hwpf.sprm.ParagraphSprmCompressor

compressSectionProperty(SectionProperties) - Static method in class org.apache.poi.hwpf.sprm.SectionSprmCompressor

compressTableProperty(TableProperties) - Static method in class org.apache.poi.hwpf.sprm.TableSprmCompressor

COMPUTER_NETWORK_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

concatenate(byte[]) - Method in class org.apache.poi.hssf.util.LazilyConcatenatedByteArray
Concatenates an array onto the end of our array.
CONCATENATE - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

ConcatEval - Class in org.apache.poi.ss.formula.eval

ConcatPtg - Class in org.apache.poi.ss.formula.ptg

CONDFORMAT - Static variable in class org.apache.poi.ss.formula.FormulaType

CONDITION_OPERATOR_GROUP - Static variable in class org.apache.poi.ss.format.CellFormatPart
Within CellFormatPart.FORMAT_PAT, the group number for the operator in the condition.
CONDITION_PAT - Static variable in class org.apache.poi.ss.format.CellFormatPart
Pattern for the condition part of a cell format part.
CONDITION_TYPE_CELL_VALUE_IS - Static variable in class org.apache.poi.hssf.record.CFRuleRecord

CONDITION_TYPE_CELL_VALUE_IS - Static variable in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
This conditional formatting rule compares a cell value to a formula calculated result, using an operator
CONDITION_TYPE_FORMULA - Static variable in class org.apache.poi.hssf.record.CFRuleRecord

CONDITION_TYPE_FORMULA - Static variable in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
This conditional formatting rule contains a formula to evaluate.
CONDITION_VALUE_GROUP - Static variable in class org.apache.poi.ss.format.CellFormatPart
Within CellFormatPart.FORMAT_PAT, the group number for the value in the condition.
ConditionalFormatting - Interface in org.apache.poi.ss.usermodel
The ConditionalFormatting class encapsulates all settings of Conditional Formatting.
ConditionalFormattingRule - Interface in org.apache.poi.ss.usermodel
Represents a description of a conditional formatting rule
ConditionalFormattingTable - Class in org.apache.poi.hssf.record.aggregates
Holds all the conditional formatting for a workbook sheet.
See OOO exelfileformat.pdf sec 4.12 'Conditional Formatting Table'
ConditionalFormattingTable() - Constructor for class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable
Creates an empty ConditionalFormattingTable
ConditionalFormattingTable(RecordStream) - Constructor for class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

Configuration - Class in org.apache.poi.openxml4j.opc
Storage class for configuration storage parameters.
Configuration() - Constructor for class org.apache.poi.openxml4j.opc.Configuration

Constants - Class in org.apache.poi.hpsf
Defines constants of general use.
Constants() - Constructor for class org.apache.poi.hpsf.Constants

ConstantValueParser - Class in org.apache.poi.ss.formula.constant
To support Constant Values (2.5.7) as required by the CRN record.
construct(CellValueRecordInterface, RecordStream, SharedValueManager) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate
Processes a single cell value record
CONTACT_ADDRTYPES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTACT_DEFAULT_ADDRESS_INDEX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTACT_EMAIL_ADDRESSES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTACT_ENTRY_IDS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTACT_VERSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

container - Variable in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Reference to the package using this content type manager.
CONTAINER_CLASS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTAINER_CONTENTS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTAINER_FLAGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTAINER_HIERARCHY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTAINER_MODIFY_VERSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

containPart(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Check if a part already exists in this package from its name.
contains(CellRangeAddress, CellRangeAddress) - Static method in class org.apache.poi.hssf.record.cf.CellRangeUtil
Check if the specified range is located inside of this cell range.
contains(String) - Method in class org.apache.poi.POIXMLProperties.CustomProperties
Check if a property with this name already exists in the collection of custom properties
contains(int, int) - Method in interface org.apache.poi.ss.formula.eval.AreaEval
returns true if the cell at row and col specified as absolute indexes in the sheet is contained in this area.
contains(int, int) - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

contains(int, short) - Method in class org.apache.poi.ss.util.Region
Deprecated. Answers: "is the row/column inside this range?"
contains(int) - Method in class org.apache.poi.util.IntList
Returns true if this list contains the specified element.
contains(short) - Method in class org.apache.poi.util.ShortList
Returns true if this list contains the specified element.
containsAlignFormattingBlock() - Method in class org.apache.poi.hssf.record.CFRuleRecord

containsAll(IntList) - Method in class org.apache.poi.util.IntList
Returns true if this list contains all of the elements of the specified collection.
containsAll(ShortList) - Method in class org.apache.poi.util.ShortList
Returns true if this list contains all of the elements of the specified collection.
containsBorderFormattingBlock() - Method in class org.apache.poi.hssf.record.CFRuleRecord

containsCell(CellRangeAddress, int, int) - Static method in class org.apache.poi.ss.util.SheetUtil

containsChart() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Does this HSSFPatriarch contain a chart? (Technically a reference to a chart, since they get stored in a different block of records) FIXME - detect chart in all cases (only seems to work on some charts so far)
containsColumn(int) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

containsColumn(int) - Method in interface org.apache.poi.ss.formula.eval.AreaEval
returns true if the specified col is in range
containsColumn(int) - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

containsFontFormattingBlock() - Method in class org.apache.poi.hssf.record.CFRuleRecord

containsKey(Object) - Method in class org.apache.poi.hpsf.CustomProperties
Checks against both String Name and Long ID
containsKey(Object) - Method in class org.apache.poi.util.BinaryTree
Returns true if this map contains a mapping for the specified key.
containsPatternFormattingBlock() - Method in class org.apache.poi.hssf.record.CFRuleRecord

containsProtectionFormattingBlock() - Method in class org.apache.poi.hssf.record.CFRuleRecord

containsRow(int) - Method in interface org.apache.poi.ss.formula.eval.AreaEval
returns true if the specified row is in range
containsRow(int) - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

containsValue(Object) - Method in class org.apache.poi.hpsf.CustomProperties
Checks against both the property, and its values.
containsValue(Object) - Method in class org.apache.poi.util.BinaryTree
Returns true if this map maps one or more keys to the specified value.
CONTENT_CONFIDENTIALITY_ALGORITHM_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENT_CORRELATOR - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENT_COUNT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENT_IDENTIFIER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENT_INTEGRITY_CHECK - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENT_LENGTH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENT_RETURN_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENT_TYPES - Static variable in interface org.apache.poi.openxml4j.opc.PackageNamespaces
Content Types.
CONTENT_TYPES_PART_NAME - Static variable in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Content type part name.
CONTENT_UNREAD - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTENTS_SORT_ORDER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

contentStatus - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The status of the content.
ContentType - Class in org.apache.poi.openxml4j.opc.internal
Represents a immutable MIME ContentType value (RFC 2616 §3.7)
ContentType(String) - Constructor for class org.apache.poi.openxml4j.opc.internal.ContentType
Constructor.
contentType - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The type of content represented, generally defined by a specific use and intended audience.
ContentTypeManager - Class in org.apache.poi.openxml4j.opc.internal
Manage package content types ([Content_Types].xml part).
ContentTypeManager(InputStream, OPCPackage) - Constructor for class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Constructor.
contentTypeManager - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Manage parts content types of this package.
ContentTypes - Class in org.apache.poi.openxml4j.opc
Open Packaging Convention content types (see Annex F : Standard Namespaces and Content Types).
ContentTypes() - Constructor for class org.apache.poi.openxml4j.opc.ContentTypes

Context - Class in org.apache.poi.xslf.model.geom
Date: 10/24/11
Context(CustomGeometry, Rectangle2D, IAdjustableShape) - Constructor for class org.apache.poi.xslf.model.geom.Context

ContinuableRecord - Class in org.apache.poi.hssf.record.cont
Common superclass of all records that can produce ContinueRecords while being serialized.
ContinuableRecord() - Constructor for class org.apache.poi.hssf.record.cont.ContinuableRecord

ContinuableRecordInput - Class in org.apache.poi.hssf.record.cont
A decorated RecordInputStream that can read primitive data types (short, int, long, etc.) spanned across a ContinueRecord boundary.
ContinuableRecordInput(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.cont.ContinuableRecordInput

ContinuableRecordOutput - Class in org.apache.poi.hssf.record.cont
An augmented LittleEndianOutput used for serialization of ContinuableRecords.
ContinuableRecordOutput(LittleEndianOutput, int) - Constructor for class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

ContinueRecord - Class in org.apache.poi.hssf.record
Title: Continue Record(0x003C) - Helper class used primarily for SST Records
ContinueRecord(byte[]) - Constructor for class org.apache.poi.hssf.record.ContinueRecord

ContinueRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ContinueRecord

CONTROL_FLAGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTROL_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTROL_STRUCTURE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONTROL_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ControlPtg - Class in org.apache.poi.ss.formula.ptg
Common superclass for tExp tTbl tParen tNlr tAttr tSheet tEndSheet
ControlPtg() - Constructor for class org.apache.poi.ss.formula.ptg.ControlPtg

CONVERSATION_INDEX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONVERSATION_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONVERSATION_TOPIC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

conversationTopic - Variable in class org.apache.poi.hsmf.datatypes.Chunks
Sort of like the subject line, but without the RE: and FWD: parts.
CONVERSION_EITS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONVERSION_PROHIBITED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CONVERSION_WITH_LOSS_PROHIBITED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

convert(POIFSBigBlockSize, byte[], int) - Static method in class org.apache.poi.poifs.storage.DocumentBlock
convert a single long array into an array of DocumentBlock instances
convert(POIFSBigBlockSize, byte[], int) - Static method in class org.apache.poi.poifs.storage.SmallDocumentBlock
convert a single long array into an array of SmallDocumentBlock instances
convert(POIFSBigBlockSize, BlockWritable[], int) - Static method in class org.apache.poi.poifs.storage.SmallDocumentBlock
Factory for creating SmallDocumentBlocks from DocumentBlocks
convert(Locale, DateFormat) - Static method in class org.apache.poi.ss.util.DateFormatConverter

convert(Locale, String) - Static method in class org.apache.poi.ss.util.DateFormatConverter

ConvertAnchor - Class in org.apache.poi.hssf.model

ConvertAnchor() - Constructor for class org.apache.poi.hssf.model.ConvertAnchor

convertBlankRecords(MulBlankRecord) - Static method in class org.apache.poi.hssf.record.RecordFactory
Converts a MulBlankRecord into an equivalent array of BlankRecords
convertBrcToInt(short[]) - Static method in class org.apache.poi.hwpf.sprm.SprmUtils

convertBytesToTC(byte[], int) - Static method in class org.apache.poi.hwpf.usermodel.TableCellDescriptor

convertCellRangesToRegions(CellRangeAddress[]) - Static method in class org.apache.poi.ss.util.Region
Deprecated. Convert a List of CellRange objects to an array of regions
convertColStringToIndex(String) - Static method in class org.apache.poi.ss.util.CellReference
takes in a column reference portion of a CellRef and converts it from ALPHA-26 number format to 0-based base 10.
convertComparisonResult(int) - Method in class org.apache.poi.ss.formula.eval.RelationalOperationEval
Converts a standard compare result (-1, 0, 1) to true or false according to subclass' comparison type.
CONVERTED_EITS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

convertFromExternSheetIndex(int) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

convertFromExternSheetIndex(int) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

convertFromExternSheetIndex(int) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

convertNumToColString(int) - Static method in class org.apache.poi.ss.util.CellReference
Takes in a 0-based base-10 column and returns a ALPHA-26 representation.
convertRawBytesToEscherRecords() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

convertRecordsToUserModel() - Method in class org.apache.poi.hssf.record.EscherAggregate
Converts the Records into UserModel objects on the bound HSSFPatriarch
convertRegionsToCellRanges(Region[]) - Static method in class org.apache.poi.ss.util.Region
Deprecated.
convertRKRecords(MulRKRecord) - Static method in class org.apache.poi.hssf.record.RecordFactory
Converts a MulRKRecord into an equivalent array of NumberRecords
convertSharedFormulas(Ptg[], int, int) - Method in class org.apache.poi.ss.formula.SharedFormula
Creates a non shared formula from the shared formula counterpart, i.e.
convertTime(String) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Converts a string of format "HH:MM" or "HH:MM:SS" to its (Excel) numeric equivalent
convertToCellRangeAddress(Region) - Static method in class org.apache.poi.ss.util.Region
Deprecated.
convertToNumberRecord(RKRecord) - Static method in class org.apache.poi.hssf.record.RecordFactory
RK record is a slightly smaller alternative to NumberRecord POI likes NumberRecord better
copy(byte[], int, int, byte[], int) - Static method in class org.apache.poi.hpsf.Util
Copies a part of a byte array into another byte array.
copy(byte[], int, int) - Static method in class org.apache.poi.hpsf.Util
Copies bytes from a source byte array into a new byte array.
copy() - Method in class org.apache.poi.hssf.util.CellRangeAddress8Bit

copy() - Method in class org.apache.poi.ss.formula.Formula

copy() - Method in class org.apache.poi.ss.formula.ptg.OperandPtg

copy() - Method in class org.apache.poi.ss.util.CellRangeAddress

copy() - Method in class org.apache.poi.ss.util.CellRangeAddressList

copy(InputStream, OutputStream) - Static method in class org.apache.poi.util.IOUtils
Copies all the data from the given InputStream to the OutputStream.
copyArea(int, int, int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D

copyArea(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

copyArea(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

copyArea(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

copyBaseFields(CellRecord) - Method in class org.apache.poi.hssf.record.CellRecord

copyBlockHeaderToContents() - Method in class org.apache.poi.hdgf.streams.CompressedStreamStore
Some kinds of streams expect their 4 byte header to be on the front of the contents.
copyBlockHeaderToContents() - Method in class org.apache.poi.hdgf.streams.StreamStore

copyFile(File, File) - Static method in class org.apache.poi.openxml4j.opc.internal.FileHelper
Copy a file.
copyLayout(XSLFSlide) - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout
Copy placeholders from this layout to the destination slide
copyNodeRecursively(Entry, DirectoryEntry) - Method in class org.apache.poi.POIDocument
Deprecated.
copyNodeRecursively(Entry, DirectoryEntry) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Copies an Entry into a target POIFS directory, recursively
copyNodes(POIFSFileSystem, POIFSFileSystem, List<String>) - Method in class org.apache.poi.POIDocument
Deprecated.
copyNodes(DirectoryNode, DirectoryNode, List<String>) - Method in class org.apache.poi.POIDocument
Deprecated.
copyNodes(DirectoryEntry, DirectoryEntry) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Copies all the nodes from one POIFS Directory to another
copyNodes(FilteringDirectoryNode, FilteringDirectoryNode) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Copies nodes from one Directory to the other minus the excepts
copyNodes(DirectoryEntry, DirectoryEntry, List<String>) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Deprecated. use FilteringDirectoryNode instead
copyNodes(POIFSFileSystem, POIFSFileSystem) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Copies all nodes from one POIFS to the other
copyNodes(POIFSFileSystem, POIFSFileSystem, List<String>) - Static method in class org.apache.poi.poifs.filesystem.EntryUtils
Copies nodes from one POIFS to the other, minus the excepts.
copyOf(byte[], int) - Static method in class org.apache.poi.util.ArrayUtil
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOfRange(byte[], int, int) - Static method in class org.apache.poi.util.ArrayUtil
Copies the specified range of the specified array into a new array.
copyStream(InputStream, OutputStream) - Static method in class org.apache.poi.openxml4j.opc.StreamHelper
Copy the input stream into the output stream.
copyTo(OutputStream) - Method in class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

copyTo(OutputStream) - Method in class org.apache.poi.poifs.nio.DataSource
Copies the contents to the specified OutputStream
copyTo(OutputStream) - Method in class org.apache.poi.poifs.nio.FileBackedDataSource

copyUpdatedCells(Workbook) - Method in class org.apache.poi.ss.formula.eval.forked.ForkedEvaluator
Copies the values of all updated cells (modified by calls to ForkedEvaluator.updateCell(String, int, int, ValueEval)) to the supplied workbook.
Typically, the supplied workbook is a writable copy of the 'master workbook', but at the very least it must contain sheets with the same names.
CORE_DOCUMENT - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Core properties relationship type.
CORE_DOCUMENT_REL - Static variable in class org.apache.poi.extractor.ExtractorFactory

CORE_PROPERTIES - Static variable in interface org.apache.poi.openxml4j.opc.PackageNamespaces
Core Properties.
CORE_PROPERTIES - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Core properties relationship type.
CORE_PROPERTIES_ECMA376 - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Core properties relationship type as defiend in ECMA 376.
CORE_PROPERTIES_PART - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Core Properties part.
CORE_PROPERTIES_PART_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Core properties partname.
CORE_PROPERTIES_URI - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Core properties part URI.
CORNER - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CORNER_TABS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CORRELATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CORRELATE_MTSID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CorruptPowerPointFileException - Exception in org.apache.poi.hslf.exceptions
This exception is thrown when we try to open a PowerPoint file, and something is fundamentally broken about it.
CorruptPowerPointFileException(String) - Constructor for exception org.apache.poi.hslf.exceptions.CorruptPowerPointFileException

COS - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

CosExpression - Class in org.apache.poi.xslf.model.geom
Date: 10/24/11
COSH - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

CosineArcTanExpression - Class in org.apache.poi.xslf.model.geom
Date: 10/24/11
COUNT - Static variable in class org.apache.poi.hssf.record.FnGroupCountRecord
suggested default (14 dec)
Count - Class in org.apache.poi.ss.formula.functions
Counts the number of cells that contain numeric data within the list of arguments.
Count() - Constructor for class org.apache.poi.ss.formula.functions.Count

Counta - Class in org.apache.poi.ss.formula.functions
Counts the number of cells that contain data within the list of arguments.
Counta() - Constructor for class org.apache.poi.ss.formula.functions.Counta

Countblank - Class in org.apache.poi.ss.formula.functions
Implementation for the function COUNTBLANK
Countblank() - Constructor for class org.apache.poi.ss.formula.functions.Countblank

countBlocks() - Method in interface org.apache.poi.poifs.filesystem.BATManaged
Return the number of BigBlock's this instance uses
countBlocks() - Method in class org.apache.poi.poifs.filesystem.POIFSDocument
Return the number of BigBlock's this instance uses
countBlocks() - Method in class org.apache.poi.poifs.property.NPropertyTable
Return the number of BigBlock's this instance uses
countBlocks() - Method in class org.apache.poi.poifs.property.PropertyTable
Return the number of BigBlock's this instance uses
countBlocks() - Method in class org.apache.poi.poifs.storage.BlockAllocationTableWriter
Return the number of BigBlock's this instance uses
countBlocks() - Method in class org.apache.poi.poifs.storage.SmallBlockTableWriter
Return the number of BigBlock's this instance uses
Countif - Class in org.apache.poi.ss.formula.functions
Implementation for the function COUNTIF
Countif() - Constructor for class org.apache.poi.ss.formula.functions.Countif

countOfAllChildren() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Total count of all children and their children's children.
countOfAllChildren() - Method in class org.apache.poi.hssf.usermodel.HSSFShape
Count of all children and their children's children.
countOfAllChildren() - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Count of all children and their childrens children.
countRanges() - Method in class org.apache.poi.ss.util.CellRangeAddressList
Get the number of following ADDR structures.
COUNTRY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CountryRecord - Class in org.apache.poi.hssf.record
Title: Country Record (aka WIN.INI country)
CountryRecord() - Constructor for class org.apache.poi.hssf.record.CountryRecord

CountryRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CountryRecord

COURIER_NEW - Static variable in class org.apache.poi.hslf.model.PPFont

CP_037 - Static variable in class org.apache.poi.hpsf.Constants
Codepage 037, a special case
CP_EUC_JP - Static variable in class org.apache.poi.hpsf.Constants
Codepage for EUC-JP
CP_EUC_KR - Static variable in class org.apache.poi.hpsf.Constants
Codepage for EUC-KR
CP_GB18030 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for GB18030
CP_GB2312 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for GB2312
CP_GBK - Static variable in class org.apache.poi.hpsf.Constants
Codepage for GBK, aka MS936
CP_ISO_2022_JP1 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-2022-JP
CP_ISO_2022_JP2 - Static variable in class org.apache.poi.hpsf.Constants
Another codepage for ISO-2022-JP
CP_ISO_2022_JP3 - Static variable in class org.apache.poi.hpsf.Constants
Yet another codepage for ISO-2022-JP
CP_ISO_2022_KR - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-2022-KR
CP_ISO_8859_1 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-1
CP_ISO_8859_2 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-2
CP_ISO_8859_3 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-3
CP_ISO_8859_4 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-4
CP_ISO_8859_5 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-5
CP_ISO_8859_6 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-6
CP_ISO_8859_7 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-7
CP_ISO_8859_8 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-8
CP_ISO_8859_9 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for ISO-8859-9
CP_JOHAB - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Johab
CP_KOI8_R - Static variable in class org.apache.poi.hpsf.Constants
Codepage for KOI8-R
CP_MAC_ARABIC - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Arabic (Java: MacArabic)
CP_MAC_CENTRAL_EUROPE - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Central Europe (Latin-2) (Java: MacCentralEurope)
CP_MAC_CHINESE_SIMPLE - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Chinese Simplified (Java: unknown - use EUC_CN, ISO2022_CN_GB, MS936 or cp935)
CP_MAC_CHINESE_TRADITIONAL - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Chinese Traditional (Java: unknown - use Big5, MS950, or cp937)
CP_MAC_CROATIAN - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Croatian (Java: MacCroatian)
CP_MAC_CYRILLIC - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Cyrillic (Java: MacCyrillic)
CP_MAC_GREEK - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Greek (Java: MacGreek)
CP_MAC_HEBREW - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Hebrew (Java: MacHebrew)
CP_MAC_ICELAND - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Iceland (Java: MacIceland)
CP_MAC_JAPAN - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Japan (Java: unknown - use SJIS, cp942 or cp943)
CP_MAC_KOREAN - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Korean (Java: unknown - use EUC_KR or cp949)
CP_MAC_ROMAN - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Roman (Java: MacRoman)
CP_MAC_ROMANIA - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Romanian (Java: MacRomania)
CP_MAC_THAI - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Thai (Java: MacThai)
CP_MAC_TURKISH - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Turkish (Java: MacTurkish)
CP_MAC_UKRAINE - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Macintosh Ukrainian (Java: MacUkraine)
CP_MS949 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for MS949
CP_SJIS - Static variable in class org.apache.poi.hpsf.Constants
Codepage for SJIS
CP_UNICODE - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Unicode
CP_US_ACSII - Static variable in class org.apache.poi.hpsf.Constants
Codepage for US-ASCII
CP_US_ASCII2 - Static variable in class org.apache.poi.hpsf.Constants
Another codepage for US-ASCII
CP_UTF16 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for UTF-16
CP_UTF16_BE - Static variable in class org.apache.poi.hpsf.Constants
Codepage for UTF-16 big-endian
CP_UTF8 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for UTF-8
CP_WINDOWS_1250 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1250
CP_WINDOWS_1251 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1251
CP_WINDOWS_1252 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1252
CP_WINDOWS_1253 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1253
CP_WINDOWS_1254 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1254
CP_WINDOWS_1255 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1255
CP_WINDOWS_1256 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1256
CP_WINDOWS_1257 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1257
CP_WINDOWS_1258 - Static variable in class org.apache.poi.hpsf.Constants
Codepage for Windows 1258
CR - Static variable in class org.apache.poi.hslf.dev.PPTXMLDump

CR_BEFORE - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
01H = Carriage returns before the next token (not allowed before tParen token)
CR_BEFORE_CLOSE_PAREN - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
05H = Carriage returns before closing parenthesis (only allowed before tParen, tFunc, and tFuncVar tokens)
CR_BEFORE_OPEN_PAREN - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
03H = Carriage returns before opening parenthesis (only allowed before tParen token)
create(TNEFAttribute) - Static method in class org.apache.poi.hmef.attribute.MAPIAttribute
Parses a MAPI Properties TNEF Attribute, and returns the list of MAPI Attributes contained within it
create(InputStream) - Static method in class org.apache.poi.hmef.attribute.TNEFAttribute
Creates a new TNEF Attribute by reading data from the stream within a HMEFMessage
create(InputStream) - Static method in class org.apache.poi.hpsf.PropertySetFactory
Creates the most specific PropertySet from an InputStream.
create() - Static method in class org.apache.poi.hslf.HSLFSlideShow
Constructs a new, empty, Powerpoint document.
create() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Creates a new Graphics object that is a copy of this Graphics object.
create(int) - Static method in class org.apache.poi.hslf.usermodel.PictureData
Create an instance of PictureData by type.
create(SharedFormulaRecord[], CellReference[], ArrayRecord[], TableRecord[]) - Static method in class org.apache.poi.hssf.record.aggregates.SharedValueManager

create(HSSFSheet, String) - Static method in class org.apache.poi.hssf.record.CFRuleRecord
Creates a new comparison operation rule
create(HSSFSheet, byte, String, String) - Static method in class org.apache.poi.hssf.record.CFRuleRecord
Creates a new comparison operation rule
create(byte[]) - Static method in class org.apache.poi.hssf.record.crypto.Biff8EncryptionKey
Create using the default password and a specified docId
create(String, byte[]) - Static method in class org.apache.poi.hssf.record.crypto.Biff8EncryptionKey

create(RecordInputStream) - Static method in class org.apache.poi.hssf.record.InterfaceEndRecord

create() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

create(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

create() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

create() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

create(String, Properties) - Static method in class org.apache.poi.hssf.usermodel.FontDetails
Create an instance of FontDetails by loading them from the provided property object.
create(HSSFWorkbook) - Static method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

create(HSSFWorkbook, IStabilityClassifier, UDFFinder) - Static method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator

create(InternalWorkbook) - Static method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

create(String) - Static method in class org.apache.poi.openxml4j.opc.OPCPackage
Creates a new package.
create(File) - Static method in class org.apache.poi.openxml4j.opc.OPCPackage
Creates a new package.
create(OutputStream) - Static method in class org.apache.poi.openxml4j.opc.OPCPackage

create(String) - Static method in class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage.create(String)
create(File) - Static method in class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage.create(File)
create(OutputStream) - Static method in class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage.create(OutputStream)
create(Workbook, IStabilityClassifier) - Static method in class org.apache.poi.ss.formula.eval.forked.ForkedEvaluator
Deprecated. (Sep 2009) (reduce overloading) use ForkedEvaluator.create(Workbook, IStabilityClassifier, UDFFinder)
create(Workbook, IStabilityClassifier, UDFFinder) - Static method in class org.apache.poi.ss.formula.eval.forked.ForkedEvaluator

create(Ptg[]) - Static method in class org.apache.poi.ss.formula.Formula
Creates a Formula object from a supplied Ptg array.
create(LittleEndianInput) - Static method in class org.apache.poi.ss.formula.ptg.FuncPtg

create(int) - Static method in class org.apache.poi.ss.formula.ptg.FuncPtg

create(LittleEndianInput) - Static method in class org.apache.poi.ss.formula.ptg.FuncVarPtg
Creates new function pointer from a byte array usually called while reading an excel file.
create(String, int) - Static method in class org.apache.poi.ss.formula.ptg.FuncVarPtg
Create a function ptg from a string tokenised by the parser
create(POIFSFileSystem) - Static method in class org.apache.poi.ss.usermodel.WorkbookFactory
Creates an HSSFWorkbook from the given POIFSFileSystem
create(NPOIFSFileSystem) - Static method in class org.apache.poi.ss.usermodel.WorkbookFactory
Creates an HSSFWorkbook from the given NPOIFSFileSystem
create(OPCPackage) - Static method in class org.apache.poi.ss.usermodel.WorkbookFactory
Creates an XSSFWorkbook from the given OOXML Package
create(InputStream) - Static method in class org.apache.poi.ss.usermodel.WorkbookFactory
Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given InputStream.
create(File) - Static method in class org.apache.poi.ss.usermodel.WorkbookFactory
Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given File, which must exist and be readable.
create(int, int, int, int, List<B>, Class<B>) - Static method in class org.apache.poi.ss.util.SSCellRange

create(XSSFWorkbook) - Static method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

create(XSSFWorkbook, IStabilityClassifier, UDFFinder) - Static method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator

CREATE_NULL_AS_BLANK - Static variable in interface org.apache.poi.ss.usermodel.Row
A new, blank cell is created for missing cells.
CREATE_TEMPLATES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

createAccumulator() - Method in class org.apache.poi.ss.formula.functions.Sumx2my2

createAccumulator() - Method in class org.apache.poi.ss.formula.functions.Sumx2py2

createAccumulator() - Method in class org.apache.poi.ss.formula.functions.Sumxmy2

createAccumulator() - Method in class org.apache.poi.ss.formula.functions.XYNumericFunction
Constructs a new instance of the Accumulator used to calculated this function
createAddInFunctions() - Static method in class org.apache.poi.hssf.record.SupBookRecord

createAggregate(List, int, DrawingManager2) - Static method in class org.apache.poi.hssf.record.EscherAggregate
Collapses the drawing records into an aggregate.
createAnchor(HSSFAnchor) - Method in class org.apache.poi.hssf.model.AbstractShape
Creates an escher anchor record from a HSSFAnchor.
createAnchor(HSSFAnchor) - Static method in class org.apache.poi.hssf.model.ConvertAnchor

createAnchor(int, int, int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
createAnchor(int, int, int, int, int, int, int, int) - Method in interface org.apache.poi.ss.usermodel.Drawing
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
createAnchor(int, int, int, int, int, int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing

createAutoShape() - Method in class org.apache.poi.xslf.usermodel.XSLFDrawing

createAutoShape() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

createAutoShape() - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
create a new shape with a predefined geometry and add it to this shape container
createAutoShape() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

createBarChart(HSSFWorkbook, HSSFSheet) - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Creates a bar chart.
createBasicLinkExternal(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createBasicLinkInternal(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createBATBlock(POIFSBigBlockSize, ByteBuffer) - Static method in class org.apache.poi.poifs.storage.BATBlock
Create a single BATBlock from the byte buffer, which must hold at least one big block of data to be read.
createBATBlocks(POIFSBigBlockSize, int[]) - Static method in class org.apache.poi.poifs.storage.BATBlock
Create an array of BATBlocks from an array of int block allocation table entries
createBlock() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createBlock() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createBlock() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createBlockIfNeeded(int) - Method in class org.apache.poi.poifs.filesystem.BlockStore
Extends the file if required to hold blocks up to the specified offset, and return the block from there.
createBlockIfNeeded(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Load the block at the given offset, extending the file if needed
createBlockIfNeeded(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore
Load the block, extending the underlying stream if needed
createBlocks() - Method in class org.apache.poi.poifs.storage.BlockAllocationTableWriter
Create the BATBlocks we need
createBookmark(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createBorder() - Method in class org.apache.poi.hslf.model.Table
Create a border to format this table
createBorderFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule
create a new border formatting structure if it does not exist, otherwise just return existing object.
createBorderFormatting() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
Create a new border formatting structure if it does not exist, otherwise just return existing object.
createBorderFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
Create a new border formatting structure if it does not exist, otherwise just return existing object.
createBuiltInName(byte, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Generates a NameRecord to represent a built-in region
createCell(short) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Deprecated. (Aug 2008) use HSSFRow.createCell(int)
createCell(short, int) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Deprecated. (Aug 2008) use HSSFRow.createCell(int, int)
createCell(int) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Use this to create new cells within the row and return it.
createCell(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Use this to create new cells within the row and return it.
createCell(HSSFRow, int, String, HSSFCellStyle) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
Creates a cell, gives it a value, and applies a style if provided
createCell(HSSFRow, int, String) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
Create a cell, and give it a value.
createCell(int) - Method in interface org.apache.poi.ss.usermodel.Row
Use this to create new cells within the row and return it.
createCell(int, int) - Method in interface org.apache.poi.ss.usermodel.Row
Use this to create new cells within the row and return it.
createCell(Row, int, String, CellStyle) - Static method in class org.apache.poi.ss.util.CellUtil
Creates a cell, gives it a value, and applies a style if provided
createCell(Row, int, String) - Static method in class org.apache.poi.ss.util.CellUtil
Create a cell, and give it a value.
createCell(int) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Use this to create new cells within the row and return it.
createCell(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Use this to create new cells within the row and return it.
createCell(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Use this to create new cells within the row and return it.
createCell(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Use this to create new cells within the row and return it.
createCell() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
create a new XWPFTableCell and add it to the tableCell-list of this tableRow
createCellComment(ClientAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch

createCellComment(ClientAnchor) - Method in interface org.apache.poi.ss.usermodel.Drawing
Creates a comment.
createCellComment(ClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Creates a comment.
createCellStyle() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Create a new Cell style and add it to the workbook's style table.
createCellStyle() - Method in interface org.apache.poi.ss.usermodel.Workbook
Create a new Cell style and add it to the workbook's style table
createCellStyle() - Method in class org.apache.poi.xssf.model.StylesTable

createCellStyle() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Create a new Cell style and add it to the workbook's style table
createCellStyle() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Create a new XSSFCellStyle and add it to the workbook's style table
createCellXF() - Method in class org.apache.poi.hssf.model.InternalWorkbook
creates a new Cell-type Extneded Format Record and adds it to the end of ExtendedFormatRecords collection
createCFAggregate(RecordStream) - Static method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate
Create CFRecordsAggregate from a list of CF Records
createChart(ClientAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch

createChart(ClientAnchor) - Method in interface org.apache.poi.ss.usermodel.Drawing
Creates a chart.
createChart(XSSFClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Creates a chart.
createChart(ClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing

createChunk(byte[], int) - Method in class org.apache.poi.hdgf.chunks.ChunkFactory
Creates the appropriate chunk at the given location.
createChunkHeader(int, byte[], int) - Static method in class org.apache.poi.hdgf.chunks.ChunkHeader
Creates the appropriate ChunkHeader for the Chunk Header at the given location, for the given document version.
createClientAnchor() - Method in class org.apache.poi.hssf.usermodel.HSSFCreationHelper
Creates a HSSFClientAnchor.
createClientAnchor() - Method in interface org.apache.poi.ss.usermodel.CreationHelper

createClientAnchor() - Method in class org.apache.poi.xssf.usermodel.XSSFCreationHelper
Creates a XSSFClientAnchor.
createComment(HSSFAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Constructs a cell comment.
createComment() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Deprecated. since Nov 2009 this method is not compatible with the common SS interfaces, use (org.apache.poi.ss.usermodel.ClientAnchor) instead
createConditionalFormattingRule(byte, String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
A factory method allowing to create a conditional formatting rule with a cell comparison operator
TODO - formulas containing cell references are currently not parsed properly
createConditionalFormattingRule(byte, String) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

createConditionalFormattingRule(String) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
A factory method allowing to create a conditional formatting rule with a formula.
The formatting rules are applied by Excel when the value of the formula not equal to 0.
TODO - formulas containing cell references are currently not parsed properly
createConditionalFormattingRule(byte, String, String) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
A factory method allowing to create a conditional formatting rule with a cell comparison operator
createConditionalFormattingRule(byte, String) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *
createConditionalFormattingRule(String) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Create a conditional formatting rule based on a Boolean formula.
createConditionalFormattingRule(byte, String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting
A factory method allowing to create a conditional formatting rule with a cell comparison operator
TODO - formulas containing cell references are currently not parsed properly
createConditionalFormattingRule(byte, String) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting

createConditionalFormattingRule(String) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting
A factory method allowing to create a conditional formatting rule with a formula.

createConnector() - Method in class org.apache.poi.xslf.usermodel.XSLFDrawing

createConnector() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

createConnector() - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
create a connector
createConnector() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

createConnector(XSSFClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Creates a simple shape.
createConnector(XSSFChildAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup
Creates a simple shape.
createCustom(int, int, String) - Static method in class org.apache.poi.hsmf.datatypes.MAPIProperty

createCustomConstraint(String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createCustomConstraint(String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createCustomConstraint(String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createCustomFormulaConstraint(String) - Static method in class org.apache.poi.hssf.usermodel.DVConstraint

created - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Date of creation of the resource.
createDataFormat() - Method in class org.apache.poi.hssf.usermodel.HSSFCreationHelper

createDataFormat() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Returns the instance of HSSFDataFormat for this workbook.
createDataFormat() - Method in interface org.apache.poi.ss.usermodel.CreationHelper
Creates a new DataFormat instance
createDataFormat() - Method in interface org.apache.poi.ss.usermodel.Workbook
Returns the instance of DataFormat for this workbook.
createDataFormat() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Returns the instance of DataFormat for this workbook.
createDataFormat() - Method in class org.apache.poi.xssf.usermodel.XSSFCreationHelper

createDataFormat() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Returns the instance of XSSFDataFormat for this workbook.
createDateConstraint(int, String, String, String) - Static method in class org.apache.poi.hssf.usermodel.DVConstraint
Creates a date based data validation constraint.
createDateConstraint(int, String, String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createDateConstraint(int, String, String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createDateConstraint(int, String, String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createDecimalConstraint(int, String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createDecimalConstraint(int, String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createDecimalConstraint(int, String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createDelayedOutput(int) - Method in interface org.apache.poi.util.DelayableLittleEndianOutput
Creates an output stream intended for outputting a sequence of size bytes.
createDelayedOutput(int) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

createDgRecord() - Method in class org.apache.poi.hssf.model.DrawingManager

createDgRecord() - Method in class org.apache.poi.hssf.model.DrawingManager2

createDialogsheet(String, CTDialogsheet) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

createDimensions() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

createDirectory(String) - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
create a new DirectoryEntry
createDirectory(String) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
create a new DirectoryEntry
createDirectory(String) - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

createDirectory(String) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
create a new DirectoryEntry in the root directory
createDirectory(String) - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
create a new DirectoryEntry in the root directory
createDocument(String, InputStream) - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
create a new DocumentEntry
createDocument(String, int, POIFSWriterListener) - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
create a new DocumentEntry; the data will be provided later
createDocument(String, InputStream) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
create a new DocumentEntry
createDocument(String, int, POIFSWriterListener) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
create a new DocumentEntry; the data will be provided later
createDocument(String, InputStream) - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

createDocument(String, int, POIFSWriterListener) - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

createDocument(InputStream, String) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Create a new document to be added to the root directory
createDocument(String, int, POIFSWriterListener) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
create a new DocumentEntry in the root entry; the data will be provided later
createDocument(InputStream, String) - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Create a new document to be added to the root directory
createDocument(String, int, POIFSWriterListener) - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
create a new DocumentEntry in the root entry; the data will be provided later
createDocumentInputStream(String) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
open a document in the directory's entry's list of entries
createDocumentInputStream(Entry) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
open a document in the directory's entry's list of entries
createDocumentInputStream(String) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
open a document in the root entry's list of entries
createDocumentInputStream(String) - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
open a document in the root entry's list of entries
createDocumentPart(POIXMLDocumentPart, PackageRelationship, PackagePart) - Method in class org.apache.poi.POIXMLFactory
Create a POIXMLDocumentPart from existing package part and relation.
createDocumentPart(POIXMLDocumentPart, PackageRelationship, PackagePart) - Method in class org.apache.poi.xslf.usermodel.XSLFFactory

createDocumentPart(POIXMLDocumentPart, PackageRelationship, PackagePart) - Method in class org.apache.poi.xssf.usermodel.XSSFFactory

createDocumentPart(POIXMLDocumentPart, PackageRelationship, PackagePart) - Method in class org.apache.poi.xwpf.usermodel.XWPFFactory

createDrawingGroup() - Method in class org.apache.poi.hssf.model.InternalWorkbook
Creates a primary drawing group record.
createDrawingPatriarch() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Creates the top-level drawing patriarch.
createDrawingPatriarch() - Method in interface org.apache.poi.ss.usermodel.Sheet
Creates the top-level drawing patriarch.
createDrawingPatriarch() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Creates the top-level drawing patriarch.
createDrawingPatriarch() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Create a new SpreadsheetML drawing.
createDVRecord(HSSFSheet) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

createEmpty() - Static method in class org.apache.poi.hssf.record.aggregates.SharedValueManager

createEmptyBATBlock(POIFSBigBlockSize, boolean) - Static method in class org.apache.poi.poifs.storage.BATBlock
Creates a single BATBlock, with all the values set to empty.
createEnclosingCellRange(CellRangeAddress, CellRangeAddress) - Static method in class org.apache.poi.hssf.record.cf.CellRangeUtil
Create an enclosing CellRange for the two cell ranges.
createErrorBox(String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

createErrorBox(String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidation
Sets the title and text for the error box .
createErrorBox(String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

createExplicitListConstraint(String[]) - Static method in class org.apache.poi.hssf.usermodel.DVConstraint

createExplicitListConstraint(String[]) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createExplicitListConstraint(String[]) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createExplicitListConstraint(String[]) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createExternalGraphic(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createExternalReferences(String, String[]) - Static method in class org.apache.poi.hssf.record.SupBookRecord

createExtractor(File) - Static method in class org.apache.poi.extractor.ExtractorFactory

createExtractor(InputStream) - Static method in class org.apache.poi.extractor.ExtractorFactory

createExtractor(OPCPackage) - Static method in class org.apache.poi.extractor.ExtractorFactory

createExtractor(POIFSFileSystem) - Static method in class org.apache.poi.extractor.ExtractorFactory

createExtractor(DirectoryNode, POIFSFileSystem) - Static method in class org.apache.poi.extractor.ExtractorFactory
Deprecated. Use ExtractorFactory.createExtractor(DirectoryNode) instead
createExtractor(DirectoryNode) - Static method in class org.apache.poi.extractor.ExtractorFactory

createExtSSTRecord(int) - Method in class org.apache.poi.hssf.record.SSTRecord
Creates an extended string record based on the current contents of the current SST record.
createFont() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
create a new Font and add it to the workbook's font table
createFont() - Method in interface org.apache.poi.ss.usermodel.Workbook
Create a new Font and add it to the workbook's font table
createFont() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Create a new Font and add it to the workbook's font table
createFont() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Create a new Font and add it to the workbook's font table
createFontFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule
create a new font formatting structure if it does not exist, otherwise just return existing object.
createFontFormatting() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
Create a new font formatting structure if it does not exist, otherwise just return existing object.
createFontFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
Create a new font formatting structure if it does not exist, otherwise just return existing object.
createFooter(STHdrFtr.Enum) - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

createFooter(STHdrFtr.Enum, XWPFParagraph[]) - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

createFootnote() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createFootnoteBody() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createFootnotes() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Creates an empty footnotes element for the document if one does not already exist
createForCountingOnly() - Static method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

createFormat(String) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Creates a FormatRecord, inserts it, and returns the index code.
createFormat(Cell) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Create and return a Format based on the format string from a cell's style.
createFormula(int, int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

createFormulaEvaluator() - Method in class org.apache.poi.hssf.usermodel.HSSFCreationHelper
Creates a HSSFFormulaEvaluator, the object that evaluates formula cells.
createFormulaEvaluator() - Method in interface org.apache.poi.ss.usermodel.CreationHelper
Creates FormulaEvaluator - an object that evaluates formula cells.
createFormulaEvaluator() - Method in class org.apache.poi.xssf.usermodel.XSSFCreationHelper
Creates a XSSFFormulaEvaluator, the object that evaluates formula cells.
createFormulaListConstraint(String) - Static method in class org.apache.poi.hssf.usermodel.DVConstraint

createFormulaListConstraint(String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createFormulaListConstraint(String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createFormulaListConstraint(String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createForRowShift(int, int, int, int) - Static method in class org.apache.poi.ss.formula.FormulaShifter

createForSheetShift(int, int) - Static method in class org.apache.poi.ss.formula.FormulaShifter

createFreeform() - Method in class org.apache.poi.xslf.usermodel.XSLFDrawing

createFreeform() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

createFreeform() - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
create a new shape with a custom geometry
createFreeform() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

createFreezePane(int, int, int, int) - Method in class org.apache.poi.hssf.model.InternalSheet
Creates a split (freezepane).
createFreezePane(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Creates a split (freezepane).
createFreezePane(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Creates a split (freezepane).
createFreezePane(int, int, int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Creates a split (freezepane).
createFreezePane(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Creates a split (freezepane).
createFreezePane(int, int, int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Creates a split (freezepane).
createFreezePane(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Creates a split (freezepane).
createFreezePane(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Creates a split (freezepane).
createFreezePane(int, int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Creates a split (freezepane).
createFromEmbeddedOleObject(POIFSFileSystem) - Static method in class org.apache.poi.poifs.filesystem.Ole10Native
Creates an instance of this class from an embedded OLE Object.
createFromEmbeddedOleObject(DirectoryNode) - Static method in class org.apache.poi.poifs.filesystem.Ole10Native
Creates an instance of this class from an embedded OLE Object.
createGroup(HSSFClientAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Creates a new group record stored under this patriarch.
createGroup(HSSFChildAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Create another group under this group.
createGroup() - Method in class org.apache.poi.xslf.usermodel.XSLFDrawing

createGroup() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

createGroup() - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
create a group of shapes belonging to this container
createGroup() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

createGroup(XSSFClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Creates a simple shape.
createHeader(STHdrFtr.Enum) - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

createHeader(STHdrFtr.Enum, XWPFParagraph[]) - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

createHeader1() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createHeader1() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createHeader2() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createHeader2() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createHyperlink(int) - Method in class org.apache.poi.hssf.usermodel.HSSFCreationHelper

createHyperlink(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createHyperlink(int) - Method in interface org.apache.poi.ss.usermodel.CreationHelper
Creates a new Hyperlink, of the given type
createHyperlink() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

createHyperlink(int) - Method in class org.apache.poi.xssf.usermodel.XSSFCreationHelper

createIf(int) - Static method in class org.apache.poi.ss.formula.ptg.AttrPtg

createImage(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createIndexRecord(int, int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

createInformationProperties() - Method in class org.apache.poi.POIDocument
Will create whichever of SummaryInformation and DocumentSummaryInformation (HPSF) properties are not already part of your document.
createInline() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createIntegerConstraint(int, String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createIntegerConstraint(int, String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createIntegerConstraint(int, String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createInternalReferences(short) - Static method in class org.apache.poi.hssf.record.SupBookRecord

createLeader() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createLineBreak() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createListBlock() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createListItem() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createListItem() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createListItemBody() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createListItemLabel(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createMasterSheet() - Method in interface org.apache.poi.sl.usermodel.SlideShow

createName() - Method in class org.apache.poi.hssf.model.InternalWorkbook
creates new name
createName() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
creates a new named range and add it to the model
createName() - Method in interface org.apache.poi.ss.usermodel.Workbook
Creates a new (uninitialised) defined name in this workbook
createName() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Creates a new (uninitialised) defined name in this workbook
createName() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

createNewFont() - Method in class org.apache.poi.hssf.model.InternalWorkbook
creates a new font record and adds it to the "font table".
createNonClosingInputStream(InputStream) - Static method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Convenience method for clients that want to avoid the auto-close behaviour of the constructor.
createNonClosingInputStream(InputStream) - Static method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Convenience method for clients that want to avoid the auto-close behaviour of the constructor.
createNoteInline(String) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

createNumbering() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Creates an empty numbering if one does not already exist and sets the numbering member
createNumericConstraint(int, int, String, String) - Static method in class org.apache.poi.hssf.usermodel.DVConstraint
Creates a number based data validation constraint.
createNumericConstraint(int, int, String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createNumericConstraint(int, int, String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createNumericConstraint(int, int, String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createPageMaster(float, String) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

createPageMaster(Section, String, int) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

createPageSequence(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createParagraph() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createParagraph() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createParagraph() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Appends a new paragraph to this document
createPart(PackagePartName, String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Create and add a part, with the specified name and content type, to the package.
createPart(PackagePartName, String, ByteArrayOutputStream) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Add a part to the package.
createPartImpl(PackagePartName, String, boolean) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Core method to create a package part.
createPartImpl(PackagePartName, String, boolean) - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Create a new MemoryPackagePart from the specified URI and content type aram partName The part URI.
createPartName(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Create an OPC compliant part name by throwing an exception if the URI is not valid.
createPartName(String) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Create an OPC compliant part name.
createPartName(String, PackagePart) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Create an OPC compliant part name by resolving it using a base part.
createPartName(URI, PackagePart) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Create an OPC compliant part name by resolving it using a base part.
createPatternFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule
create a new pattern formatting structure if it does not exist, otherwise just return existing object.
createPatternFormatting() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
Create a new pattern formatting structure if it does not exist, otherwise just return existing object.
createPatternFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
Create a new pattern formatting structure if it does not exist, otherwise just return existing object.
createPicture(HSSFClientAnchor, int) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Creates a picture.
createPicture(ClientAnchor, int) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch

createPicture(HSSFChildAnchor, int) - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Creates a picture.
createPicture(ClientAnchor, int) - Method in interface org.apache.poi.ss.usermodel.Drawing
Creates a picture.
createPicture(String) - Method in class org.apache.poi.xslf.usermodel.XSLFDrawing

createPicture(int) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

createPicture(int) - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
create a picture belonging to this container
createPicture(int) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

createPicture(XSSFClientAnchor, int) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Creates a picture.
createPicture(ClientAnchor, int) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing

createPicture(XSSFClientAnchor, int) - Method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup
Creates a picture.
createPointer(byte[], int) - Method in class org.apache.poi.hdgf.pointers.PointerFactory

createPolygon(HSSFClientAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Creates a polygon
createPolygon(HSSFChildAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Creates a polygon
createPromptBox(String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

createPromptBox(String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidation
Sets the title and text for the prompt box .
createPromptBox(String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

createProperties(byte[], int, short) - Method in class org.apache.poi.ddf.EscherPropertyFactory
Create new properties from a byte array.
createPropertyBlockArray(POIFSBigBlockSize, List<Property>) - Static method in class org.apache.poi.poifs.storage.PropertyBlock
Create an array of PropertyBlocks from an array of Property instances, creating empty Property instances to make up any shortfall
createPtg() - Method in interface org.apache.poi.ss.formula.EvaluationName

createPtg(LittleEndianInput) - Static method in class org.apache.poi.ss.formula.ptg.Ptg

createQCPLCBit(String, String, byte[]) - Static method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

createRecord(byte[], int) - Method in class org.apache.poi.ddf.DefaultEscherRecordFactory
Generates an escher record including the any children contained under that record.
createRecord(byte[], int) - Method in interface org.apache.poi.ddf.EscherRecordFactory
Create a new escher record from the data provided.
createRecord(RecordInputStream) - Static method in class org.apache.poi.hssf.record.RecordFactory
create a record, if there are MUL records than multiple records are returned digested into the non-mul form.
createRecordForType(long, byte[], int, int) - Static method in class org.apache.poi.hslf.record.Record
For a given type (little endian bytes 3 and 4 in record header), byte array, start position and length: will return a Record object that will handle that record Remember that while PPT stores the record lengths as 8 bytes short (not including the size of the header), this code assumes you're passing in corrected lengths
createRecords(InputStream, PrintStream, BiffViewer.BiffRecordListener, boolean) - Static method in class org.apache.poi.hssf.dev.BiffViewer
Create an array of records from an input stream
createRecords(InputStream) - Static method in class org.apache.poi.hssf.record.RecordFactory
Create an array of records from an input stream
createRelationship(POIXMLRelation, POIXMLFactory) - Method in class org.apache.poi.POIXMLDocumentPart
Create a new child POIXMLDocumentPart
createRelationship(POIXMLRelation, POIXMLFactory, int) - Method in class org.apache.poi.POIXMLDocumentPart

createRelationship(POIXMLRelation, POIXMLFactory, int, boolean) - Method in class org.apache.poi.POIXMLDocumentPart
Create a new child POIXMLDocumentPart
createRichTextString(String) - Method in class org.apache.poi.hssf.usermodel.HSSFCreationHelper

createRichTextString(String) - Method in interface org.apache.poi.ss.usermodel.CreationHelper
Creates a new RichTextString instance
createRichTextString(String) - Method in class org.apache.poi.xssf.usermodel.XSSFCreationHelper
Creates a new XSSFRichTextString for you.
createRow(int) - Static method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
Create a row record.
createRow(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Create a new row within the sheet and return the high level representation
createRow(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Create a new row within the sheet and return the high level representation
createRow(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Create a new row within the sheet and return the high level representation
createRow(int) - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

createRow(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Create a new row within the sheet and return the high level representation
createRow() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
create a new XWPFTableRow object with as many cells as the number of columns defined in that moment
createRun() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Appends a new run to this paragraph
createSafeSheetName(String) - Static method in class org.apache.poi.ss.util.WorkbookUtil
Creates a valid sheet name, which is conform to the rules.
createSafeSheetName(String, char) - Static method in class org.apache.poi.ss.util.WorkbookUtil
Creates a valid sheet name, which is conform to the rules.
createScatterChartData() - Method in interface org.apache.poi.ss.usermodel.charts.ChartDataFactory

createScatterChartData() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartDataFactory

createSeries() - Method in class org.apache.poi.hssf.usermodel.HSSFChart

createShape(EscherContainerRecord, Shape) - Static method in class org.apache.poi.hslf.model.ShapeFactory
Create a new shape from the data provided.
createShape(HSSFShape, int) - Static method in class org.apache.poi.hssf.model.AbstractShape
Create a new shape object used to create the escher records.
createShape(HSSFChildAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Create a new simple shape under this group.
createShapeGroup(EscherContainerRecord, Shape) - Static method in class org.apache.poi.hslf.model.ShapeFactory

createSheet(RecordStream) - Static method in class org.apache.poi.hssf.model.InternalSheet
read support (offset used as starting point for search) for low level API.
createSheet() - Static method in class org.apache.poi.hssf.model.InternalSheet
Creates a sheet with all the usual records minus values and the "index" record (not required).
createSheet() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
create an HSSFSheet for this HSSFWorkbook, adds it to the sheets and returns the high level representation.
createSheet(String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Create a new sheet for this Workbook and return the high level representation.
createSheet() - Method in interface org.apache.poi.ss.usermodel.Workbook
Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
createSheet(String) - Method in interface org.apache.poi.ss.usermodel.Workbook
Create a new sheet for this Workbook and return the high level representation.
createSheet() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
createSheet(String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Create an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
createSheet() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Create an XSSFSheet for this workbook, adds it to the sheets and returns the high level representation.
createSheet(String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Create a new sheet for this Workbook and return the high level representation.
createSheetBOF() - Static method in class org.apache.poi.hssf.record.BOFRecord

createSimpeShape(EscherContainerRecord, Shape) - Static method in class org.apache.poi.hslf.model.ShapeFactory

createSimpleShape(HSSFClientAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Creates a simple shape.
createSimpleShape(XSSFClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Creates a simple shape.
createSimpleShape(XSSFChildAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup
Creates a simple shape.
createSingleRecord(RecordInputStream) - Static method in class org.apache.poi.hssf.record.RecordFactory

createSkip(int) - Static method in class org.apache.poi.ss.formula.ptg.AttrPtg

createSlide() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Create a blank Slide.
createSlide() - Method in interface org.apache.poi.sl.usermodel.SlideShow

createSlide(XSLFSlideLayout) - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Create a slide and initialize it from the specified layout.
createSlide() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Create a blank slide.
createSpace(int, int) - Static method in class org.apache.poi.ss.formula.ptg.AttrPtg

createSpContainer(int, boolean) - Method in class org.apache.poi.hslf.model.ActiveXShape
Create a new Placeholder and initialize internal structures
createSpContainer(int, boolean) - Method in class org.apache.poi.hslf.model.AutoShape

createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.Background

createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.Line

createSpContainer(int, boolean) - Method in class org.apache.poi.hslf.model.MovieShape
Create a new Placeholder and initialize internal structures
createSpContainer(int, boolean) - Method in class org.apache.poi.hslf.model.Picture
Create a new Picture and populate the inital structure of the EscherSp record which holds information about this picture.
createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.Placeholder
Create a new Placeholder and initialize internal structures
createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.Shape
Creates the lowerlevel escher records for this shape.
createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.ShapeGroup
Create a new ShapeGroup and create an instance of EscherSpgrContainer which represents a group of shapes
createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.SimpleShape
Create a new Shape
createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.TableCell

createSpContainer(boolean) - Method in class org.apache.poi.hslf.model.TextBox
Create a new TextBox and initialize its internal structures
createSplitPane(int, int, int, int, int) - Method in class org.apache.poi.hssf.model.InternalSheet
Creates a split pane.
createSplitPane(int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Creates a split pane.
createSplitPane(int, int, int, int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Creates a split pane.
createSplitPane(int, int, int, int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Creates a split pane.
createSplitPane(int, int, int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Creates a split pane.
createStream(Pointer, byte[], ChunkFactory, PointerFactory) - Static method in class org.apache.poi.hdgf.streams.Stream
Uses the pointer to locate a Stream within the document data, and creates it.
createStubWorkbook(ExternSheetRecord[], BoundSheetRecord[], SSTRecord) - Static method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder
Creates a stub Workbook from the supplied records, suitable for use with the HSSFFormulaParser
createStubWorkbook(ExternSheetRecord[], BoundSheetRecord[]) - Static method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder
Creates a stub workbook from the supplied records, suitable for use with the HSSFFormulaParser
createStyleRecord(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Creates a new StyleRecord, for the given Extended Format index, and adds it onto the end of the records collection
createStyles() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Creates an empty styles for the document if one does not already exist
createSubRecord(LittleEndianInput, int) - Static method in class org.apache.poi.hssf.record.SubRecord
read a sub-record from the supplied stream
createTable() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createTable() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTable() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createTable() - Method in class org.apache.poi.xslf.usermodel.XSLFDrawing

createTable() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

createTable() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Creates a new Table, and associates it with this Sheet
createTable() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Create an empty table with one row and one column as default.
createTable(int, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Create an empty table with a number of rows and cols specified
createTableBody() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createTableBody() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTableBody() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createTableCell() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createTableCell() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTableCell() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createTableColumn() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createTableColumn() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTableColumnGroup() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTableHeader() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createTableHeader() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTableHeaderCell() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTableRow() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createTableRow() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createTableRow() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createTempFile() - Static method in class org.apache.poi.util.PackageHelper
Creates an empty file in the default temporary-file directory,
createTempFile(String, String) - Static method in class org.apache.poi.util.TempFile
Creates a temporary file.
createTempFile() - Method in class org.apache.poi.xssf.streaming.GZIPSheetDataWriter

createTempFile() - Method in class org.apache.poi.xssf.streaming.SheetDataWriter
Create a temp file to write sheet data.
createText(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

createText(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createText(String) - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createTextbox(HSSFClientAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Constructs a textbox under the patriarch.
createTextbox(HSSFChildAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Create a new textbox under this group.
createTextBox() - Method in class org.apache.poi.xslf.usermodel.XSLFDrawing

createTextBox() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

createTextBox() - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
create a text box
createTextBox() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

createTextbox(XSSFClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Constructs a textbox under the drawing.
createTextbox(XSSFChildAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup
Constructs a textbox.
createTextLengthConstraint(int, String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createTextLengthConstraint(int, String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createTextLengthConstraint(int, String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createTextRuler() - Method in class org.apache.poi.hslf.model.TextRun

createTextRun() - Method in class org.apache.poi.hslf.model.TextShape

createTimeConstraint(int, String, String) - Static method in class org.apache.poi.hssf.usermodel.DVConstraint
Creates a time based data validation constraint.
createTimeConstraint(int, String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createTimeConstraint(int, String, String) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createTimeConstraint(int, String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createTOC() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

createUnorderedList() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

createUnorderedList() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

createValidation(DataValidationConstraint, CellRangeAddressList) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

createValidation(DataValidationConstraint, CellRangeAddressList) - Method in interface org.apache.poi.ss.usermodel.DataValidationHelper

createValidation(DataValidationConstraint, CellRangeAddressList) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

createValueAxis(AxisPosition) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxisFactory

createValueAxis(AxisPosition) - Method in class org.apache.poi.xssf.usermodel.XSSFChart

createWatermark(String) - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

createWorkbook(List<Record>) - Static method in class org.apache.poi.hssf.model.InternalWorkbook
read support for low level API.
createWorkbook() - Static method in class org.apache.poi.hssf.model.InternalWorkbook
Creates an empty workbook object with three blank sheets and all the empty fields.
createWriter(File) - Method in class org.apache.poi.xssf.streaming.GZIPSheetDataWriter

createWriter(File) - Method in class org.apache.poi.xssf.streaming.SheetDataWriter
Create a writer for the sheet data.
createXBATBlocks(POIFSBigBlockSize, int[], int) - Static method in class org.apache.poi.poifs.storage.BATBlock
Create an array of XBATBlocks from an array of int block allocation table entries
CREATION_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CREATION_VERSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CreationHelper - Interface in org.apache.poi.ss.usermodel
An object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
creator - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
An entity primarily responsible for making the content of the resource.
CRNCountRecord - Class in org.apache.poi.hssf.record
XCT - CRN Count
CRNCountRecord() - Constructor for class org.apache.poi.hssf.record.CRNCountRecord

CRNCountRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CRNCountRecord

CRNRecord - Class in org.apache.poi.hssf.record
Title: CRN(0x005A)
Description: This record stores the contents of an external cell or cell range
REFERENCE: OOO 5.23

CRNRecord() - Constructor for class org.apache.poi.hssf.record.CRNRecord

CRNRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.CRNRecord

crossAxis(ChartAxis) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis
Declare this axis cross another axis.
crossAxis(ChartAxis) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

CString - Class in org.apache.poi.hslf.record
A CString (type 4026).
CString(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.CString
For the CStrubg Atom
CString() - Constructor for class org.apache.poi.hslf.record.CString
Create an empty CString
CString - Static variable in class org.apache.poi.hslf.record.RecordTypes

CTColComparator - Class in org.apache.poi.xssf.util

CTColComparator() - Constructor for class org.apache.poi.xssf.util.CTColComparator

Cube - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CUBE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURRENCY - Static variable in class org.apache.poi.hsmf.datatypes.Types
Currency - signed 64-bit integer that represents a base ten decimal with four digits to the right of the decimal point
CURRENT_VERSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CurrentUserAtom - Class in org.apache.poi.hslf.record
This is a special kind of Atom, becauase it doesn't live inside the PowerPoint document.
CurrentUserAtom() - Constructor for class org.apache.poi.hslf.record.CurrentUserAtom
Create a new Current User Atom
CurrentUserAtom(POIFSFileSystem) - Constructor for class org.apache.poi.hslf.record.CurrentUserAtom
Find the Current User in the filesystem, and create from that
CurrentUserAtom(DirectoryNode) - Constructor for class org.apache.poi.hslf.record.CurrentUserAtom
Find the Current User in the filesystem, and create from that
CurrentUserAtom(byte[]) - Constructor for class org.apache.poi.hslf.record.CurrentUserAtom
Create things from the bytes
CurrentUserAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

CURVED_CONNECTOR_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURVED_CONNECTOR_3 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURVED_CONNECTOR_4 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURVED_CONNECTOR_5 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURVED_DOWN_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURVED_LEFT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURVED_RIGHT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CURVED_UP_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

CurvedConnector2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CurvedConnector3 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CurvedConnector4 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CurvedConnector5 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CurvedDownArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CurvedLeftArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CurvedRightArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CurvedUpArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

CURVES - Static variable in class org.apache.poi.ddf.EscherShapePathProperty

CurveToCommand - Class in org.apache.poi.xslf.model.geom
Date: 10/25/11
CUSTOM - Static variable in class org.apache.poi.hslf.record.DocumentAtom.SlideSize

CUSTOM_PROPERTIES - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Custom properties relationship type.
CUSTOM_XML - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Custom XML relationship type.
CUSTOM_XML_MAPPINGS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

CUSTOM_XML_PART - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Custom XML part.
CUSTOMER_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

CustomGeometry - Class in org.apache.poi.xslf.model.geom
Definition of a custom geometric shape
CustomGeometry(CTCustomGeometry2D) - Constructor for class org.apache.poi.xslf.model.geom.CustomGeometry

CustomProperties - Class in org.apache.poi.hpsf
Maintains the instances of CustomProperty that belong to a DocumentSummaryInformation.
CustomProperties() - Constructor for class org.apache.poi.hpsf.CustomProperties

CustomProperty - Class in org.apache.poi.hpsf
This class represents custom properties in the document summary information stream.
CustomProperty() - Constructor for class org.apache.poi.hpsf.CustomProperty
Creates an empty CustomProperty.
CustomProperty(Property) - Constructor for class org.apache.poi.hpsf.CustomProperty
Creates a CustomProperty without a name by copying the underlying Property' attributes.
CustomProperty(Property, String) - Constructor for class org.apache.poi.hpsf.CustomProperty
Creates a CustomProperty with a name.
CustomViewSettingsRecordAggregate - Class in org.apache.poi.hssf.record.aggregates
Manages the all the records associated with a 'Custom View Settings' sub-stream.
Includes the initial USERSVIEWBEGIN(0x01AA) and final USERSVIEWEND(0x01AB).
CustomViewSettingsRecordAggregate(RecordStream) - Constructor for class org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

D

DASH_DOT - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

DASH_DOT_DOT - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

DASHED - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

data - Variable in class org.apache.poi.hpbf.model.HPBFPart

data - Variable in class org.apache.poi.hpbf.model.qcbits.QCBit

data - Variable in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart
Storage for the part data.
DATA_FORMAT - Static variable in class org.apache.poi.ss.util.CellUtil

DATA_LABEL_PLACEMENT_ABOVE - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_AUTO - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_AXIS - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_BELOW - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_CENTER - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_CHART_DEPENDENT - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_INSIDE - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_LEFT - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_OUTSIDE - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_RIGHT - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DATA_LABEL_PLACEMENT_USER_MOVED - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DataFormat - Interface in org.apache.poi.ss.usermodel

DataFormatRecord - Class in org.apache.poi.hssf.record.chart
The data format record is used to index into a series.

DataFormatRecord() - Constructor for class org.apache.poi.hssf.record.chart.DataFormatRecord

DataFormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.DataFormatRecord

DataFormatter - Class in org.apache.poi.ss.usermodel
DataFormatter contains methods for formatting the value stored in an Cell.
DataFormatter() - Constructor for class org.apache.poi.ss.usermodel.DataFormatter
Creates a formatter using the default locale.
DataFormatter(boolean) - Constructor for class org.apache.poi.ss.usermodel.DataFormatter
Creates a formatter using the default locale.
DataFormatter(Locale, boolean) - Constructor for class org.apache.poi.ss.usermodel.DataFormatter
Creates a formatter using the given locale.
DataFormatter(Locale) - Constructor for class org.apache.poi.ss.usermodel.DataFormatter
Creates a formatter using the given locale.
DataInputBlock - Class in org.apache.poi.poifs.storage
Wraps a byte array and provides simple data input access.
DataItemRecord - Class in org.apache.poi.hssf.record.pivottable
SXDI - Data Item (0x00C5)

DataItemRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.pivottable.DataItemRecord

DataLabelExtensionRecord - Class in org.apache.poi.hssf.record.chart
DATALABEXT - Chart Data Label Extension (0x086A)

DataLabelExtensionRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

dataOffset - Variable in class org.apache.poi.hpbf.model.qcbits.QCBit

DataSource - Class in org.apache.poi.poifs.nio
Common definition of how we read and write bytes
DataSource() - Constructor for class org.apache.poi.poifs.nio.DataSource

DataSources - Class in org.apache.poi.ss.usermodel.charts
Class DataSources is a factory for ChartDataSource instances.
DataValidation - Interface in org.apache.poi.ss.usermodel

DataValidation.ErrorStyle - Class in org.apache.poi.ss.usermodel
Error style constants for error box
DataValidation.ErrorStyle() - Constructor for class org.apache.poi.ss.usermodel.DataValidation.ErrorStyle

DATAVALIDATION_LIST - Static variable in class org.apache.poi.ss.formula.FormulaType

DataValidationConstraint - Interface in org.apache.poi.ss.usermodel

DataValidationConstraint.OperatorType - Class in org.apache.poi.ss.usermodel
Condition operator enum
DataValidationConstraint.ValidationType - Class in org.apache.poi.ss.usermodel
ValidationType enum
DataValidationHelper - Interface in org.apache.poi.ss.usermodel

DataValidityTable - Class in org.apache.poi.hssf.record.aggregates
Manages the DVALRecord and DVRecords for a single sheet
See OOO excelfileformat.pdf section 4.14
DataValidityTable(RecordStream) - Constructor for class org.apache.poi.hssf.record.aggregates.DataValidityTable

DataValidityTable() - Constructor for class org.apache.poi.hssf.record.aggregates.DataValidityTable

dataValue - Variable in class org.apache.poi.hslf.model.textproperties.TextProp

date() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

DATE - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
Date type
DateAndTime - Class in org.apache.poi.hwpf.usermodel
This class is used to represent a date and time in a Word document.
DateAndTime() - Constructor for class org.apache.poi.hwpf.usermodel.DateAndTime

DateAndTime(byte[], int) - Constructor for class org.apache.poi.hwpf.usermodel.DateAndTime

DateFormatConverter - Class in org.apache.poi.ss.util
Convert java DateFormat patterns into Excel custom number formats.
DateFormatConverter() - Constructor for class org.apache.poi.ss.util.DateFormatConverter

DateFormatConverter.DateFormatTokenizer - Class in org.apache.poi.ss.util

DateFormatConverter.DateFormatTokenizer(String) - Constructor for class org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer

DateFunc - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function DATE
DateParser - Class in org.apache.poi.ss.formula.atp
Parser for java dates.
DateTimeMCAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

dateToFileTime(Date) - Static method in class org.apache.poi.hpsf.Util
Converts a Date into a filetime.
DateUtil - Class in org.apache.poi.ss.usermodel
Contains methods for dealing with Excel dates.
DateUtil() - Constructor for class org.apache.poi.ss.usermodel.DateUtil

DateWindow1904Record - Class in org.apache.poi.hssf.record
Title: Date Window 1904 Flag record
DateWindow1904Record() - Constructor for class org.apache.poi.hssf.record.DateWindow1904Record

DateWindow1904Record(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DateWindow1904Record

DatRecord - Class in org.apache.poi.hssf.record.chart
The dat record is used to store options for the chart.

DatRecord() - Constructor for class org.apache.poi.hssf.record.chart.DatRecord

DatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.DatRecord

DAY - Static variable in class org.apache.poi.ss.formula.functions.CalendarFieldFunction

Days360 - Class in org.apache.poi.ss.formula.functions
Calculates the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations.
Days360() - Constructor for class org.apache.poi.ss.formula.functions.Days360

DBCellRecord - Class in org.apache.poi.hssf.record
Title: DBCell Record (0x00D7)
Description: Used by Excel and other MS apps to quickly find rows in the sheets.
DBCellRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DBCellRecord

DBCellRecord.Builder - Class in org.apache.poi.hssf.record

DBCellRecord.Builder() - Constructor for class org.apache.poi.hssf.record.DBCellRecord.Builder

DConRefRecord - Class in org.apache.poi.hssf.record
DConRef records specify a range in a workbook (internal or external) that serves as a data source for pivot tables or data consolidation.
DConRefRecord(byte[]) - Constructor for class org.apache.poi.hssf.record.DConRefRecord
Read constructor.
DConRefRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DConRefRecord
Read Constructor.
debug() - Method in class org.apache.poi.hdgf.HDGFDiagram
Prints out some simple debug on the base contents of the file.
DEBUG - Static variable in class org.apache.poi.util.POILogger

DECAGON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

DECIMAL - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
Decimal type
declarations - Variable in class org.apache.poi.hwpf.converter.FoDocumentFacade

decode() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord
Convert raw data to escher records.
decodeNumber(int) - Static method in class org.apache.poi.hssf.util.RKUtil
Do the dirty work of decoding; made a private static method to facilitate testing the algorithm
decodeURI(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Decode a URI by converting all percent encoded character into a String character.
decompress(byte[], int, int) - Static method in class org.apache.poi.ddf.EscherBlipWMFRecord
Decompresses a byte array.
decompress(byte[], int, int) - Static method in class org.apache.poi.hdgf.streams.CompressedStreamStore
Decompresses the given data, returning it as header + contents
decompress(InputStream, OutputStream) - Method in class org.apache.poi.hmef.CompressedRTF
Decompresses the whole of the compressed RTF stream, outputting the resulting RTF bytes.
decompress(InputStream) - Method in class org.apache.poi.util.LZWDecompresser
Decompresses the given input stream, returning the array of bytes of the decompressed input.
decompress(InputStream, OutputStream) - Method in class org.apache.poi.util.LZWDecompresser
Perform a streaming decompression of the input.
Decryptor - Class in org.apache.poi.poifs.crypt

Decryptor() - Constructor for class org.apache.poi.poifs.crypt.Decryptor

DEF_CREATE_DL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEF_CREATE_MAILUSER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEFAULT - Static variable in interface org.apache.poi.ss.formula.udf.UDFFinder

DEFAULT - Static variable in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

DEFAULT_ACTIVEX_THUMBNAIL - Static variable in class org.apache.poi.hslf.model.ActiveXShape

DEFAULT_BUCKET_SIZE - Static variable in class org.apache.poi.hssf.record.ExtSSTRecord

DEFAULT_BULLET_CHAR - Static variable in class org.apache.poi.hslf.model.TextPainter
Display unicode square if a bullet char can't be displayed, for example, if Wingdings font is used.
DEFAULT_CHARACTER_WIDTH - Static variable in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Width of one character of the default font in pixels.
DEFAULT_CHARSET - Static variable in class org.apache.poi.hslf.model.PPFont
Default character set.
DEFAULT_CHARSET - Static variable in interface org.apache.poi.ss.usermodel.Font
Default character set.
DEFAULT_COLUMN_WIDTH - Static variable in class org.apache.poi.hssf.record.DefaultColWidthRecord
The default column width is 8 characters
DEFAULT_FONT_COLOR - Static variable in class org.apache.poi.xssf.usermodel.XSSFFont
Default font color is black
DEFAULT_FONT_NAME - Static variable in class org.apache.poi.xssf.usermodel.XSSFFont
By default, Microsoft Office Excel 2007 uses the Calibry font in font size 11
DEFAULT_FONT_SIZE - Static variable in class org.apache.poi.xssf.usermodel.XSSFFont
By default, Microsoft Office Excel 2007 uses the Calibry font in font size 11
DEFAULT_HEIGHT - Static variable in class org.apache.poi.hslf.model.TableCell

DEFAULT_LINE_WIDTH - Static variable in class org.apache.poi.hslf.model.SimpleShape

DEFAULT_MOVIE_THUMBNAIL - Static variable in class org.apache.poi.hslf.model.MovieShape

DEFAULT_NAME_PREFIX - Static variable in class org.apache.poi.hsmf.datatypes.Chunk

DEFAULT_PASSWORD - Static variable in class org.apache.poi.poifs.crypt.Decryptor

DEFAULT_PITCH - Static variable in class org.apache.poi.hslf.model.PPFont
Constants for the pitch and family of the font.
DEFAULT_PROFILE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEFAULT_ROW_HEIGHT - Static variable in class org.apache.poi.hssf.record.DefaultRowHeightRecord
The default row height for empty rows is 255 twips (255 / 20 == 12.75 points)
DEFAULT_STORE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEFAULT_STREAM_NAME - Static variable in class org.apache.poi.hpsf.DocumentSummaryInformation
The document name a document summary information stream usually has in a POIFS filesystem.
DEFAULT_STREAM_NAME - Static variable in class org.apache.poi.hpsf.SummaryInformation
The document name a summary information stream usually has in a POIFS filesystem.
DEFAULT_VALUE - Static variable in class org.apache.poi.hssf.record.DeltaRecord

DEFAULT_VIEW_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEFAULT_WIDTH - Static variable in class org.apache.poi.hslf.model.TableCell

DEFAULT_WINDOW_SIZE - Static variable in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Specifies how many rows can be accessed at most via getRow().
DEFAULT_XML_OPTIONS - Static variable in class org.apache.poi.POIXMLDocumentPart

defaultcolwidth - Variable in class org.apache.poi.hssf.model.InternalSheet

DefaultColWidthRecord - Class in org.apache.poi.hssf.record
Title: Default Column Width Record (0x0055)
DefaultColWidthRecord() - Constructor for class org.apache.poi.hssf.record.DefaultColWidthRecord

DefaultColWidthRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DefaultColWidthRecord

DefaultDataLabelTextPropertiesRecord - Class in org.apache.poi.hssf.record.chart
The default data label text properties record identifies the text characteristics of the preceding text record.

DefaultDataLabelTextPropertiesRecord() - Constructor for class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

DefaultDataLabelTextPropertiesRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

DefaultEscherRecordFactory - Class in org.apache.poi.ddf
Generates escher records when provided the byte array containing those records.
DefaultEscherRecordFactory() - Constructor for class org.apache.poi.ddf.DefaultEscherRecordFactory
Creates an instance of the escher record factory
DefaultFontReplacer - Class in org.apache.poi.hwpf.converter

DefaultFontReplacer() - Constructor for class org.apache.poi.hwpf.converter.DefaultFontReplacer

DefaultMarshaller - Class in org.apache.poi.openxml4j.opc.internal.marshallers
Default marshaller that specified that the part is responsible to marshall its content.
DefaultMarshaller() - Constructor for class org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller

defaultPackageAccess - Static variable in class org.apache.poi.openxml4j.opc.OPCPackage
Default package access.
defaultPartMarshaller - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Default part marshaller.
defaultrowheight - Variable in class org.apache.poi.hssf.model.InternalSheet

DefaultRowHeightRecord - Class in org.apache.poi.hssf.record
Title: Default Row Height Record Description: Row height for rows with undefined or not explicitly defined heights.
DefaultRowHeightRecord() - Constructor for class org.apache.poi.hssf.record.DefaultRowHeightRecord

DefaultRowHeightRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DefaultRowHeightRecord

DefaultRulerAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

DefaultUDFFinder - Class in org.apache.poi.ss.formula.udf
Default UDF finder - for adding your own user defined functions.
DefaultUDFFinder(String[], FreeRefFunction[]) - Constructor for class org.apache.poi.ss.formula.udf.DefaultUDFFinder

DEFERRED_DELIVERY_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEGREES - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

DelayableLittleEndianOutput - Interface in org.apache.poi.util
Implementors of this interface allow client code to 'delay' writing to a certain section of a data output stream.
A typical application is for writing BIFF records when the size is not known until well after the header has been written.
DELEGATION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

delete(int, int) - Method in class org.apache.poi.hwpf.HWPFDocument

delete() - Method in class org.apache.poi.hwpf.usermodel.Range

delete() - Method in interface org.apache.poi.poifs.filesystem.Entry
Delete this Entry.
delete() - Method in class org.apache.poi.poifs.filesystem.EntryNode
Delete this Entry.
delete() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

DELETE_AFTER_SUBMIT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

deleteChild(Property) - Method in class org.apache.poi.poifs.property.DirectoryProperty
Delete a Property
DeletedArea3DPtg - Class in org.apache.poi.ss.formula.ptg
Title: Deleted Area 3D Ptg - 3D referecnce (Sheet + Area)
DeletedArea3DPtg(int) - Constructor for class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

DeletedArea3DPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

DeletedRef3DPtg - Class in org.apache.poi.ss.formula.ptg
Title: Deleted Reference 3D Ptg
DeletedRef3DPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg
Creates new DeletedRef3DPtg
DeletedRef3DPtg(int) - Constructor for class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

deleteLegend() - Method in interface org.apache.poi.ss.usermodel.Chart
Delete current chart legend.
deleteLegend() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

deletePart(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Delete the part with the specified name and its associated relationships part if one exists.
deletePartRecursive(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Delete the part with the specified name and all part listed in its associated relationships part if one exists.
DELIVER_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DELIVERY_POINT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DELIVERY_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.RecipientChunks

deliveryTypeChunk - Variable in class org.apache.poi.hsmf.datatypes.RecipientChunks
Normally EX or SMTP.
DeltaRecord - Class in org.apache.poi.hssf.record
Title: Delta Record (0x0010)
Description: controls the accuracy of the calculations
REFERENCE: PG 303 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

DeltaRecord(double) - Constructor for class org.apache.poi.hssf.record.DeltaRecord

DeltaRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DeltaRecord

DELTAX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DELTAY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEPARTMENT_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEPTH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

dereferenceResult(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.WorkbookEvaluator
Dereferences a single value from any AreaEval or RefEval evaluation result.
descent - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

description - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
An explanation of the content of the resource.
destinationCompressed() - Method in class org.apache.poi.hdgf.pointers.Pointer

destinationCompressed() - Method in class org.apache.poi.hdgf.pointers.PointerV6

destinationHasChunks() - Method in class org.apache.poi.hdgf.pointers.Pointer

destinationHasChunks() - Method in class org.apache.poi.hdgf.pointers.PointerV6

destinationHasPointers() - Method in class org.apache.poi.hdgf.pointers.Pointer

destinationHasPointers() - Method in class org.apache.poi.hdgf.pointers.PointerV6

destinationHasStrings() - Method in class org.apache.poi.hdgf.pointers.Pointer

destinationHasStrings() - Method in class org.apache.poi.hdgf.pointers.PointerV6

DETAILS_TABLE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DEVSQ - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

DG_CONTAINER - Static variable in class org.apache.poi.ddf.EscherContainerRecord

DGG_CONTAINER - Static variable in class org.apache.poi.ddf.EscherContainerRecord

DGGINFO - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

DIAG_STRIPE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

dialogsheet - Variable in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

Diamond - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

DIAMOND - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

DIAMONDS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Diamonds
DIAMONDS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

DIAMONDS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Diamonds
DIAMONDS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Diamonds
DIB - Class in org.apache.poi.hslf.blip
Represents a DIB picture data in a PPT file
DIB() - Constructor for class org.apache.poi.hslf.blip.DIB

DIB - Static variable in class org.apache.poi.hslf.model.Picture
Windows DIB (BMP)
dictionary - Variable in class org.apache.poi.hpsf.Section
Maps property IDs to section-private PID strings.
DIFAT_SECTOR_BLOCK - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
Indicates the sector holds a DIFAT block (0xFFFFFFFC)
DIGITAL_SIGNATURE - Static variable in interface org.apache.poi.openxml4j.opc.PackageNamespaces
Digital Signatures.
DIGITAL_SIGNATURE - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Digital signature relationship type.
DIGITAL_SIGNATURE_CERTIFICATE - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Digital signature certificate relationship type.
DIGITAL_SIGNATURE_CERTIFICATE_PART - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Digital Signature Certificate part.
DIGITAL_SIGNATURE_ORIGIN - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Digital signature origin relationship type.
DIGITAL_SIGNATURE_ORIGIN_PART - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Digital Signature Origin part.
DIGITAL_SIGNATURE_XML_SIGNATURE_PART - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Digital Signature XML Signature part.
DigitalCertificatePart - Class in org.apache.poi.openxml4j.opc.internal.signature
Digital certificate part.
DigitalCertificatePart() - Constructor for class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

DigitalSignatureOriginPart - Class in org.apache.poi.openxml4j.opc.internal.signature
Represents a digital signature origin part.
DigitalSignatureOriginPart() - Constructor for class org.apache.poi.openxml4j.opc.internal.signature.DigitalSignatureOriginPart

DimensionsRecord - Class in org.apache.poi.hssf.record
Title: Dimensions Record
DimensionsRecord() - Constructor for class org.apache.poi.hssf.record.DimensionsRecord

DimensionsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DimensionsRecord

DIRECTORY - Static variable in class org.apache.poi.hsmf.datatypes.Types
Object/Directory - embedded object in a property
directory - Variable in class org.apache.poi.POIDocument
The directory that our document lives in
DIRECTORY_TYPE - Static variable in interface org.apache.poi.poifs.property.PropertyConstants

DirectoryChunk - Class in org.apache.poi.hsmf.datatypes
A Chunk that is just a placeholder in the MAPIMessage directory structure, which contains children.
DirectoryChunk(DirectoryNode, String, int, int) - Constructor for class org.apache.poi.hsmf.datatypes.DirectoryChunk

DirectoryChunkNotFoundException - Exception in org.apache.poi.hsmf.exceptions
Exception for when a directory chunk is not found but is expected.
DirectoryChunkNotFoundException(String) - Constructor for exception org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException

DirectoryEntry - Interface in org.apache.poi.poifs.filesystem
This interface defines methods specific to Directory objects managed by a Filesystem instance.
DirectoryNode - Class in org.apache.poi.poifs.filesystem
Simple implementation of DirectoryEntry
DirectoryProperty - Class in org.apache.poi.poifs.property
Directory property
DirectoryProperty(String) - Constructor for class org.apache.poi.poifs.property.DirectoryProperty
Default constructor
DirectoryProperty(int, byte[], int) - Constructor for class org.apache.poi.poifs.property.DirectoryProperty
reader constructor
DirectoryProperty.PropertyComparator - Class in org.apache.poi.poifs.property

DirectoryProperty.PropertyComparator() - Constructor for class org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator

disableLocking() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Disable sheet protection
DISC_VAL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISCARD_REASON - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISCLOSE_RECIPIENTS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISCLOSURE_OF_RECIPIENTS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISCRETE_VALUES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

display(PrintWriter, int) - Method in class org.apache.poi.ddf.EscherContainerRecord

display(PrintWriter, int) - Method in class org.apache.poi.ddf.EscherRecord
The display methods allows escher variables to print the record names according to their hierarchy.
DISPLAY_BCC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISPLAY_CC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISPLAY_MODE_OPAQUE - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DISPLAY_MODE_TRANSPARENT - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

DISPLAY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISPLAY_NAME_PREFIX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISPLAY_TO - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DISPLAY_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

displayBATReader(BlockAllocationTableReader) - Static method in class org.apache.poi.poifs.dev.POIFSHeaderDumper

displayBCCChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
Value that shows in the BCC field
displayCCChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
value that shows in the CC field
displayDirectory(DirectoryNode, String, boolean) - Static method in class org.apache.poi.poifs.dev.POIFSLister

displayFromChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
Value that is in the FROM field
displayHeader(HeaderBlock) - Static method in class org.apache.poi.poifs.dev.POIFSHeaderDumper

displayParts() - Method in class org.apache.poi.dev.OOXMLLister
Displays information on all the different parts of the OOXML file container.
displayRawBlocksSummary(RawDataBlockList) - Static method in class org.apache.poi.poifs.dev.POIFSHeaderDumper

displayRelations() - Method in class org.apache.poi.dev.OOXMLLister
Displays information on all the different relationships between different parts of the OOXML file container.
displayToChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
Value that is in the TO field (not actually the addresses as they are stored in recip directory nodes
dispose() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Disposes of this graphics context and releases any system resources that it is using.
dispose() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

dispose() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

dispose() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

DIV_ZERO - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval
#DIV/0! - Division by zero
DIV_ZERO - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg
#DIV/0! - Division by zero
DivideEval - Static variable in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

DividePtg - Class in org.apache.poi.ss.formula.ptg
This PTG implements the standard binomial divide "/"
DIVIDER - Static variable in class org.apache.poi.extractor.CommandLineTextExtractor

DL_EXPANSION_HISTORY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DL_EXPANSION_PROHIBITED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

DMORIENTPAGE_LANDSCAPE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

DMORIENTPAGE_PORTRAIT - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

DocRoutingSlip - Static variable in class org.apache.poi.hslf.record.RecordTypes

docstream - Variable in class org.apache.poi.hslf.dev.PPTXMLDump

Document - Class in org.apache.poi.hslf.record
Master container for Document.
Document(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.Document
Set things up, and find our more interesting children
Document - Static variable in class org.apache.poi.hslf.record.RecordTypes

document - Variable in class org.apache.poi.hwpf.converter.FoDocumentFacade

document - Variable in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

document - Variable in class org.apache.poi.hwpf.converter.TextDocumentFacade

document - Variable in class org.apache.poi.POITextExtractor
The POIDocument that's open
Document - Interface in org.apache.poi.xwpf.usermodel

document - Variable in class org.apache.poi.xwpf.usermodel.XWPFFootnotes

document - Variable in class org.apache.poi.xwpf.usermodel.XWPFParagraph
For access to the document's hyperlink, comments, tables etc
DOCUMENT - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

DOCUMENT_CREATOR - Static variable in class org.apache.poi.POIXMLDocument

DOCUMENT_SUMMARY_INFORMATION_ID - Static variable in class org.apache.poi.hpsf.wellknown.SectionIDMap
The DocumentSummaryInformation's first and second sections' format ID.
DOCUMENT_TYPE - Static variable in interface org.apache.poi.poifs.property.PropertyConstants

DocumentAtom - Class in org.apache.poi.hslf.record
A Document Atom (type 1001).
DocumentAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.DocumentAtom
For the Document Atom
DocumentAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

DocumentAtom.SlideSize - Class in org.apache.poi.hslf.record
Holds the different Slide Size values
DocumentAtom.SlideSize() - Constructor for class org.apache.poi.hslf.record.DocumentAtom.SlideSize

DocumentBlock - Class in org.apache.poi.poifs.storage
A block of document data.
DocumentBlock(RawDataBlock) - Constructor for class org.apache.poi.poifs.storage.DocumentBlock
create a document block from a raw data block
DocumentBlock(InputStream, POIFSBigBlockSize) - Constructor for class org.apache.poi.poifs.storage.DocumentBlock
Create a single instance initialized with data.
DocumentDescriptor - Class in org.apache.poi.poifs.filesystem
Class DocumentDescriptor
DocumentDescriptor(POIFSDocumentPath, String) - Constructor for class org.apache.poi.poifs.filesystem.DocumentDescriptor
Trivial constructor
DocumentEncryptionAtom - Class in org.apache.poi.hslf.record
A Document Encryption Atom (type 12052).
DocumentEncryptionAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.DocumentEncryptionAtom
For the Document Encryption Atom
DocumentEncryptionAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

DocumentEntry - Interface in org.apache.poi.poifs.filesystem
This interface defines methods specific to Document objects managed by a Filesystem instance.
DocumentInputStream - Class in org.apache.poi.poifs.filesystem
This class provides methods to read a DocumentEntry managed by a POIFSFileSystem or NPOIFSFileSystem instance.
DocumentInputStream() - Constructor for class org.apache.poi.poifs.filesystem.DocumentInputStream
For use by downstream implementations
DocumentInputStream(DocumentEntry) - Constructor for class org.apache.poi.poifs.filesystem.DocumentInputStream
Create an InputStream from the specified DocumentEntry
DocumentInputStream(POIFSDocument) - Constructor for class org.apache.poi.poifs.filesystem.DocumentInputStream
Create an InputStream from the specified Document
DocumentInputStream(NPOIFSDocument) - Constructor for class org.apache.poi.poifs.filesystem.DocumentInputStream
Create an InputStream from the specified Document
DocumentNode - Class in org.apache.poi.poifs.filesystem
Simple implementation of DocumentEntry
DocumentOutputStream - Class in org.apache.poi.poifs.filesystem
This class provides a wrapper over an OutputStream so that Document writers can't accidently go over their size limits
DocumentPosition - Class in org.apache.poi.hwpf.usermodel

DocumentPosition(HWPFDocument, int) - Constructor for class org.apache.poi.hwpf.usermodel.DocumentPosition

DocumentProperties - Class in org.apache.poi.hwpf.model
Comment me
DocumentProperties(byte[], int) - Constructor for class org.apache.poi.hwpf.model.DocumentProperties
Deprecated. Use DocumentProperties.DocumentProperties(byte[],int,int) instead
DocumentProperties(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.DocumentProperties

DocumentProperty - Class in org.apache.poi.poifs.property
Trivial extension of Property for POIFSDocuments
DocumentProperty(String, int) - Constructor for class org.apache.poi.poifs.property.DocumentProperty
Constructor
DocumentProperty(int, byte[], int) - Constructor for class org.apache.poi.poifs.property.DocumentProperty
reader constructor
DocumentSummaryInformation - Class in org.apache.poi.hpsf
Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
DocumentSummaryInformation(PropertySet) - Constructor for class org.apache.poi.hpsf.DocumentSummaryInformation
Creates a DocumentSummaryInformation from a given PropertySet.
DOCUNDO - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

DODECAGON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

DOES_NOT_FOLLOW_COLOR_SCHEME - Static variable in class org.apache.poi.hslf.record.ExEmbedAtom
Embedded document does not follow the color scheme.
doesContainsSheetName(String, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Determines whether a workbook contains the provided sheet name.
doesFormulaReferToDeletedCell(Ptg[]) - Static method in class org.apache.poi.ss.formula.ptg.Ptg

DOLLAR - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

DONT_MOVE_AND_RESIZE - Static variable in interface org.apache.poi.ss.usermodel.ClientAnchor
Do Not Move or Resize With Underlying Rows/Columns
Donut - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

DONUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

DOP - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

DOPAbstractType - Class in org.apache.poi.hwpf.model.types
Document Properties.
DOPAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.DOPAbstractType

DOTTED - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

DOUBLE - Static variable in class org.apache.poi.hsmf.datatypes.Types
Double - floating point double
DOUBLE - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

DOUBLE_SIZE - Static variable in interface org.apache.poi.util.LittleEndianConsts

DOUBLE_WAVE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

DoubleWave - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

DOWN_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

DOWN_ARROW_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

DownArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

DownArrowCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

draw(Graphics2D) - Method in class org.apache.poi.hslf.model.Background

draw(Graphics2D) - Method in class org.apache.poi.hslf.model.Picture

draw(Shape) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Strokes the outline of a Shape using the settings of the current Graphics2D context.
draw(Graphics2D) - Method in class org.apache.poi.hslf.model.Shape

draw(Graphics2D) - Method in class org.apache.poi.hslf.model.ShapeGroup

draw(Graphics2D) - Method in class org.apache.poi.hslf.model.Sheet

draw(Graphics2D) - Method in class org.apache.poi.hslf.model.SimpleShape

draw(Graphics2D) - Method in class org.apache.poi.hslf.model.Slide

draw(Graphics2D) - Method in class org.apache.poi.hslf.model.TextShape

draw(Graphics2D, Picture) - Method in class org.apache.poi.hslf.usermodel.PictureData

draw(Shape) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

draw(Shape) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

draw(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFBackground

draw(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

draw(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

draw(Graphics2D, Shape) - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

draw(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Draw this shape into the supplied canvas
draw(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Render this sheet into the supplied graphics object
draw(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

draw(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

draw(Graphics2D, double, double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

draw3DRect(int, int, int, int, boolean) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

DRAW_ASPECT_DOCPRINT - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom
The object is displayed on the screen as though it were printed to a printer.
DRAW_ASPECT_ICON - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom
The object is displayed as an icon.
DRAW_ASPECT_THUMBNAIL - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom
The object is displayed as a thumbnail image.
DRAW_ASPECT_VISIBLE - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom
The object) is displayed as an embedded object inside of a container,
drawArc(int, int, int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws the outline of a circular or elliptical arc covering the specified rectangle.
drawArc(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawArc(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawArc(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawBytes(byte[], int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawChars(char[], int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawContent(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFPictureShape

drawContent(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw any content within this shape (image, text, etc.).
drawContent(Graphics2D) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

drawGlyphVector(GlyphVector, float, float) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Renders the text of the specified GlyphVector using the Graphics2D context's rendering attributes.
drawGlyphVector(GlyphVector, float, float) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawGlyphVector(GlyphVector, float, float) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Image, int, int, Color, ImageObserver) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws as much of the specified image as is currently available.
drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
drawImage(Image, int, int, ImageObserver) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws as much of the specified image as is currently available.
drawImage(BufferedImage, BufferedImageOp, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Renders a BufferedImage that is filtered with a BufferedImageOp.
drawImage(Image, AffineTransform, ImageObserver) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Renders an image, applying a transform from image space into user space before drawing.
drawImage(Image, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
drawImage(BufferedImage, BufferedImageOp, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, AffineTransform, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawImage(Image, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawImage(Image, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawImage(Image, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Image, int, int, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Image, int, int, Color, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Image, int, int, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Image, AffineTransform, ImageObserver) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(BufferedImage, BufferedImageOp, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawImage(Graphics2D, XSLFPictureData, Rectangle2D) - Method in class org.apache.poi.xslf.usermodel.XSLFImageRenderer
Render picture data into the supplied graphics
Drawing - Interface in org.apache.poi.ss.usermodel
High level representation of spreadsheet drawing.
drawing - Variable in class org.apache.poi.xssf.usermodel.XSSFShape
Parent drawing
DrawingDump - Class in org.apache.poi.util
Dump out the aggregated escher records
DrawingDump() - Constructor for class org.apache.poi.util.DrawingDump

DrawingGroupRecord - Class in org.apache.poi.hssf.record

DrawingGroupRecord() - Constructor for class org.apache.poi.hssf.record.DrawingGroupRecord

DrawingGroupRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DrawingGroupRecord

DrawingManager - Class in org.apache.poi.hssf.model
Provides utilities to manage drawing groups.
DrawingManager(EscherDggRecord) - Constructor for class org.apache.poi.hssf.model.DrawingManager

DrawingManager2 - Class in org.apache.poi.hssf.model
Provides utilities to manage drawing groups.
DrawingManager2(EscherDggRecord) - Constructor for class org.apache.poi.hssf.model.DrawingManager2

DrawingParagraph - Class in org.apache.poi.xslf.usermodel

DrawingParagraph(CTTextParagraph) - Constructor for class org.apache.poi.xslf.usermodel.DrawingParagraph

DrawingRecord - Class in org.apache.poi.hssf.record
DrawingRecord (0x00EC)

DrawingRecord() - Constructor for class org.apache.poi.hssf.record.DrawingRecord

DrawingRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DrawingRecord

DrawingRecordForBiffViewer - Class in org.apache.poi.hssf.record
This is purely for the biff viewer.
DrawingRecordForBiffViewer() - Constructor for class org.apache.poi.hssf.record.DrawingRecordForBiffViewer

DrawingRecordForBiffViewer(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DrawingRecordForBiffViewer

DrawingRecordForBiffViewer(DrawingRecord) - Constructor for class org.apache.poi.hssf.record.DrawingRecordForBiffViewer

DRAWINGS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

DrawingSelectionRecord - Class in org.apache.poi.hssf.record
MsoDrawingSelection (0x00ED)
Reference: [MS-OGRAPH].pdf sec 2.4.69
DrawingSelectionRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DrawingSelectionRecord

DrawingTable - Class in org.apache.poi.xslf.usermodel

DrawingTable(CTTable) - Constructor for class org.apache.poi.xslf.usermodel.DrawingTable

DrawingTableCell - Class in org.apache.poi.xslf.usermodel

DrawingTableCell(CTTableCell) - Constructor for class org.apache.poi.xslf.usermodel.DrawingTableCell

DrawingTableRow - Class in org.apache.poi.xslf.usermodel

DrawingTableRow(CTTableRow) - Constructor for class org.apache.poi.xslf.usermodel.DrawingTableRow

DrawingTextBody - Class in org.apache.poi.xslf.usermodel

DrawingTextBody(CTTextBody) - Constructor for class org.apache.poi.xslf.usermodel.DrawingTextBody

DrawingTextPlaceholder - Class in org.apache.poi.xslf.usermodel
A DrawingTextBody which is a placeholder
DrawingTextPlaceholder(CTTextBody, CTPlaceholder) - Constructor for class org.apache.poi.xslf.usermodel.DrawingTextPlaceholder

drawLine(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws a line, using the current color, between the points (x1, y1) and (x2, y2) in this graphics context's coordinate system.
drawLine(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawLine(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawLine(int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawLine(int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawLine(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawOval(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws the outline of an oval.
drawOval(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawOval(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawOval(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawPolygon(int[], int[], int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws a closed polygon defined by arrays of x and y coordinates.
drawPolygon(Polygon) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawPolygon(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawPolygon(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawPolygon(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawPolyline(int[], int[], int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws a sequence of connected lines defined by arrays of x and y coordinates.
drawPolyline(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawPolyline(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawPolyline(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawRect(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws the outline of the specified rectangle.
drawRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawRenderableImage(RenderableImage, AffineTransform) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Renders a RenderedImage, applying a transform from image space into user space before drawing.
drawRenderableImage(RenderableImage, AffineTransform) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawRenderableImage(RenderableImage, AffineTransform) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawRenderedImage(RenderedImage, AffineTransform) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Renders a RenderableImage, applying a transform from image space into user space before drawing.
drawRenderedImage(RenderedImage, AffineTransform) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawRenderedImage(RenderedImage, AffineTransform) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws an outlined round-cornered rectangle using this graphics context's current color.
drawRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawString(String, float, float) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Renders the text specified by the specified String, using the current text attribute state in the Graphics2D context.
drawString(String, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws the text given by the specified string, using this graphics context's current font and color.
drawString(AttributedCharacterIterator, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Draws the text given by the specified iterator, using this graphics context's current color.
drawString(AttributedCharacterIterator, float, float) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Renders the text of the specified iterator, using the Graphics2D context's current Paint.
drawString(AttributedCharacterIterator, float, float) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawString(String, float, float) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawString(AttributedCharacterIterator, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawString(String, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

drawString(String, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawString(AttributedCharacterIterator, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

drawString(String, float, float) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawString(String, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawString(AttributedCharacterIterator, float, float) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

drawString(AttributedCharacterIterator, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

DropCapSpecifier - Class in org.apache.poi.hwpf.usermodel
This data structure is used by a paragraph to determine how it should drop its first letter.
DropCapSpecifier() - Constructor for class org.apache.poi.hwpf.usermodel.DropCapSpecifier

DropCapSpecifier(byte[], int) - Constructor for class org.apache.poi.hwpf.usermodel.DropCapSpecifier

DropCapSpecifier(short) - Constructor for class org.apache.poi.hwpf.usermodel.DropCapSpecifier

DSFRecord - Class in org.apache.poi.hssf.record
Title: Double Stream Flag Record (0x0161)
Description: tells if this is a double stream file.
DSFRecord(boolean) - Constructor for class org.apache.poi.hssf.record.DSFRecord

DSFRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DSFRecord

DummyGraphics2d - Class in org.apache.poi.hssf.usermodel

DummyGraphics2d() - Constructor for class org.apache.poi.hssf.usermodel.DummyGraphics2d

DummyPositionSensitiveRecordWithChildren - Class in org.apache.poi.hslf.record
If we come across a record we know has children of (potential) interest, but where the record itself is boring, but where other records may care about where this one lives, we create one of these.
DummyPositionSensitiveRecordWithChildren(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren
Create a new holder for a boring record with children, but with position dependent characteristics
DummyRecordWithChildren - Class in org.apache.poi.hslf.record
If we come across a record we know has children of (potential) interest, but where the record itself is boring, we create one of these.
DummyRecordWithChildren(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.DummyRecordWithChildren
Create a new holder for a boring record with children
dump(byte[], int, int, PrintStream) - Method in class org.apache.poi.ddf.EscherDump
Decodes the escher stream from a byte array and dumps the results to a print stream.
dump(int, byte[], PrintStream) - Method in class org.apache.poi.ddf.EscherDump

dump(Writer) - Method in class org.apache.poi.hslf.dev.PPTXMLDump
Dump the structure of the supplied PPT file into XML
dump(byte[], int, int, int) - Method in class org.apache.poi.hslf.dev.PPTXMLDump
Dump a part of the document stream into XML
dump() - Method in class org.apache.poi.hsmf.dev.HSMFDump

dump(DirectoryEntry, File) - Static method in class org.apache.poi.poifs.dev.POIFSDump

dump(byte[], long, OutputStream, int, int) - Static method in class org.apache.poi.util.HexDump
dump an array of bytes to an OutputStream
dump(byte[], long, OutputStream, int) - Static method in class org.apache.poi.util.HexDump
dump an array of bytes to an OutputStream
dump(byte[], long, int) - Static method in class org.apache.poi.util.HexDump
dump an array of bytes to a String
dump(InputStream, PrintStream, int, int) - Static method in class org.apache.poi.util.HexDump
Dumps bytesToDump bytes to an output stream.
dump(ZipFile) - Static method in class org.apache.poi.xssf.dev.XSSFDump

dump(InputStream, OutputStream) - Static method in class org.apache.poi.xssf.dev.XSSFDump

dump001CompObj(DirectoryNode) - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpChpx(boolean, boolean) - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpContents() - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpCONTENTSguessed(DirectoryNode) - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpCONTENTSraw(DirectoryNode) - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpDrawingGroupRecords(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Spits out a list of all the drawing records in the workbook.
dumpDrawingRecords(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Aggregates the drawing records and dumps the escher record hierarchy to the standard output.
dumpEnvelope() - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpEscher() - Method in class org.apache.poi.hpbf.dev.HPBFDumper
Dump out the escher parts of the file.
dumpEscherDelayStm(DirectoryNode) - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpEscherStm(DirectoryNode) - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpFIB() - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpFileSystem() - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpOld(long, InputStream, PrintStream) - Method in class org.apache.poi.ddf.EscherDump
This version of dump is a translation from the open office escher dump routine.
dumpPapx(boolean, boolean) - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpParagraphLevels(ListTables, ParagraphProperties) - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpParagraphs(boolean) - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpParagraphsDom(boolean) - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpPictures(byte[], int) - Method in class org.apache.poi.hslf.dev.PPTXMLDump
Dumps the Pictures OLE stream into XML.
dumpQuill() - Method in class org.apache.poi.hpbf.dev.HPBFDumper

dumpSprms(SprmIterator, String) - Method in class org.apache.poi.hwpf.dev.HWPFLister

dumpStream(Stream, int) - Static method in class org.apache.poi.hdgf.dev.VSDDumper

dumpTextPieces(boolean) - Method in class org.apache.poi.hwpf.dev.HWPFLister

DVALRecord - Class in org.apache.poi.hssf.record
Title: DATAVALIDATIONS Record (0x01B2)
Description: used in data validation ; This record is the list header of all data validation records (0x01BE) in the current sheet.
DVALRecord() - Constructor for class org.apache.poi.hssf.record.DVALRecord

DVALRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DVALRecord

DVConstraint - Class in org.apache.poi.hssf.usermodel

DVConstraint.FormulaPair - Class in org.apache.poi.hssf.usermodel

DVConstraint.FormulaPair(Ptg[], Ptg[]) - Constructor for class org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair

DVRecord - Class in org.apache.poi.hssf.record
Title: DATAVALIDATION Record (0x01BE)
Description: This record stores data validation settings and a list of cell ranges which contain these settings.
DVRecord(int, int, int, boolean, boolean, boolean, boolean, String, String, boolean, String, String, Ptg[], Ptg[], CellRangeAddressList) - Constructor for class org.apache.poi.hssf.record.DVRecord

DVRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.DVRecord

E

EcmaDecryptor - Class in org.apache.poi.poifs.crypt

EcmaDecryptor(EncryptionInfo) - Constructor for class org.apache.poi.poifs.crypt.EcmaDecryptor

EFBiffViewer - Class in org.apache.poi.hssf.dev

EFBiffViewer() - Constructor for class org.apache.poi.hssf.dev.EFBiffViewer
Creates a new instance of EFBiffViewer
ELEVEN_BY_SEVENTEEN_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
11 x 17 in
Ellipse - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

ELLIPSE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ELLIPSE_RIBBON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ELLIPSE_RIBBON_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

EllipseRibbon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

EllipseRibbon2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

emailFromChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
TODO
embedAtom - Variable in class org.apache.poi.hslf.record.ExEmbed

EmbeddedObjectRefSubRecord - Class in org.apache.poi.hssf.record
ftPictFmla (0x0009)
A sub-record within the OBJ record which stores a reference to an object stored in a separate entry within the OLE2 compound file.
EmbeddedObjectRefSubRecord(LittleEndianInput, int) - Constructor for class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

EMF - Class in org.apache.poi.hslf.blip
Represents EMF (Windows Enhanced Metafile) picture data.
EMF() - Constructor for class org.apache.poi.hslf.blip.EMF

EMF - Static variable in class org.apache.poi.hslf.model.Picture
Windows Enhanced Metafile (EMF)
EMF - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
EMPTY - Static variable in class org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment

EMPTY_ARRAY - Static variable in class org.apache.poi.hssf.record.NoteRecord

EMPTY_INSTANCE - Static variable in class org.apache.poi.ss.formula.eval.StringEval

EMPTY_INTERPOLATED - Static variable in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

EMPTY_NOT_PLOTTED - Static variable in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

EMPTY_PTG_ARRAY - Static variable in class org.apache.poi.ss.formula.ptg.Ptg

EMPTY_STRING - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

EMPTY_ZERO - Static variable in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

EMU_PER_CENTIMETER - Static variable in class org.apache.poi.hslf.model.Shape

EMU_PER_INCH - Static variable in class org.apache.poi.hslf.model.Shape
In Escher absolute distances are specified in English Metric Units (EMUs), occasionally referred to as A units; there are 360000 EMUs per centimeter, 914400 EMUs per inch, 12700 EMUs per point.
EMU_PER_PIXEL - Static variable in class org.apache.poi.util.Units

EMU_PER_PIXEL - Static variable in class org.apache.poi.xssf.usermodel.XSSFShape

EMU_PER_POINT - Static variable in class org.apache.poi.hslf.model.Shape

EMU_PER_POINT - Static variable in class org.apache.poi.util.Units

EMU_PER_POINT - Static variable in class org.apache.poi.xssf.usermodel.XSSFShape

ENABLE_NUMBERING_1_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

ENABLE_NUMBERING_2_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

enableLocking() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable sheet protection
encHeaderToken - Static variable in class org.apache.poi.hslf.record.CurrentUserAtom
The PowerPoint magic number for an encrytpted file
ENCLOSES - Static variable in class org.apache.poi.hssf.record.cf.CellRangeUtil
first range encloses or is equal to the second
encode(String) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
percent-encode white spaces and characters above 0x80.
encode(LittleEndianOutput, Object[]) - Static method in class org.apache.poi.ss.formula.constant.ConstantValueParser

ENCODED_SIZE - Static variable in class org.apache.poi.hssf.record.EOFRecord

ENCODED_SIZE - Static variable in class org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord

ENCODED_SIZE - Static variable in class org.apache.poi.hssf.record.PageBreakRecord.Break

ENCODED_SIZE - Static variable in class org.apache.poi.hssf.record.RowRecord

ENCODED_SIZE - Static variable in class org.apache.poi.hssf.util.CellRangeAddress8Bit

ENCODED_SIZE - Static variable in class org.apache.poi.ss.util.CellRangeAddress

ENCODING_COMPRESSED_UNICODE - Static variable in class org.apache.poi.hssf.usermodel.HSSFCell

ENCODING_UNCHANGED - Static variable in class org.apache.poi.hssf.usermodel.HSSFCell

ENCODING_UTF_16 - Static variable in class org.apache.poi.hssf.usermodel.HSSFCell

EncryptedDocumentException - Exception in org.apache.poi

EncryptedDocumentException(String) - Constructor for exception org.apache.poi.EncryptedDocumentException

EncryptedPowerPointFileException - Exception in org.apache.poi.hslf.exceptions
This exception is thrown when we try to open a PowerPoint file, and discover that it is encrypted
EncryptedPowerPointFileException(String) - Constructor for exception org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException

EncryptedSlideShow - Class in org.apache.poi.hslf
This class provides helper functions for determining if a PowerPoint document is Encrypted.
EncryptedSlideShow() - Constructor for class org.apache.poi.hslf.EncryptedSlideShow

EncryptionHeader - Class in org.apache.poi.poifs.crypt

EncryptionHeader(DocumentInputStream) - Constructor for class org.apache.poi.poifs.crypt.EncryptionHeader

EncryptionHeader(String) - Constructor for class org.apache.poi.poifs.crypt.EncryptionHeader

EncryptionInfo - Class in org.apache.poi.poifs.crypt

EncryptionInfo(POIFSFileSystem) - Constructor for class org.apache.poi.poifs.crypt.EncryptionInfo

EncryptionInfo(NPOIFSFileSystem) - Constructor for class org.apache.poi.poifs.crypt.EncryptionInfo

EncryptionInfo(DirectoryNode) - Constructor for class org.apache.poi.poifs.crypt.EncryptionInfo

EncryptionOption - Enum in org.apache.poi.openxml4j.opc
Specifies the encryption option for parts in a Package.
EncryptionVerifier - Class in org.apache.poi.poifs.crypt

EncryptionVerifier(String) - Constructor for class org.apache.poi.poifs.crypt.EncryptionVerifier

EncryptionVerifier(DocumentInputStream, int) - Constructor for class org.apache.poi.poifs.crypt.EncryptionVerifier

END_DATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

END_OF_CHAIN - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
Indicates the sector is the end of a chain (0xFFFFFFFE)
endBold() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

EndDocument - Static variable in class org.apache.poi.hslf.record.RecordTypes

endDoubleUnderline() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

endElement(String, String, String) - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable

endElement(String, String, String) - Method in class org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler

ENDNOTE - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

endnotes - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

EndRecord - Class in org.apache.poi.hssf.record.chart
The end record defines the end of a block of records for a (Graphing) data object.
EndRecord() - Constructor for class org.apache.poi.hssf.record.chart.EndRecord

EndRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.EndRecord

endRow() - Method in interface org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler
A row with the (zero based) row number has ended
endRow() - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

EndSubRecord - Class in org.apache.poi.hssf.record
ftEnd (0x0000)
The end data record is used to denote the end of the subrecords.

EndSubRecord() - Constructor for class org.apache.poi.hssf.record.EndSubRecord

EndSubRecord(LittleEndianInput, int) - Constructor for class org.apache.poi.hssf.record.EndSubRecord

endUnderline() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

enforceCommentsProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Enforce the Comments protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to comments (w:edit="comments")

sample snippet from settings.xml
enforceFillingFormsProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Enforce the Filling Forms protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to forms (w:edit="forms")

sample snippet from settings.xml
enforceReadonlyProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Enforces the readOnly protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to readOnly (w:edit="readOnly")

sample snippet from settings.xml
enforceTrackedChangesProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Enforce the Tracked Changes protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to trackedChanges (w:edit="trackedChanges")

sample snippet from settings.xml
enforceUpdateFields() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Enforces fields update on document open (in Word).
ensureRelationships() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Ensure that the relationships collection is not null.
ensureStyleAtomPresent() - Method in class org.apache.poi.hslf.model.TextRun
Ensure a StyleTextPropAtom is present for this run, by adding if required.
Entry - Interface in org.apache.poi.poifs.filesystem
This interface provides access to an object managed by a Filesystem instance.
ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

EntryNode - Class in org.apache.poi.poifs.filesystem
Abstract implementation of Entry Extending classes should override isDocument() or isDirectory(), as appropriate Extending classes must override isDeleteOK()
EntryNode(Property, DirectoryNode) - Constructor for class org.apache.poi.poifs.filesystem.EntryNode
create a DocumentNode.
entrySet() - Method in class org.apache.poi.util.BinaryTree
Returns a set view of the mappings contained in this map.
entrySetByValue() - Method in class org.apache.poi.util.BinaryTree
Returns a set view of the mappings contained in this map.
EntryUtils - Class in org.apache.poi.poifs.filesystem

EntryUtils() - Constructor for class org.apache.poi.poifs.filesystem.EntryUtils

ENVELOPE_10_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Envelope #10 4 1/8 x 9 1/2
ENVELOPE_9_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Envelope #9 3 7/8 x 8 7/8
ENVELOPE_C3_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
Envelope C3 324x458 mm
ENVELOPE_C4_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
Envelope C4 229x324 mm
ENVELOPE_C5_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup

ENVELOPE_C6_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
Envelope C6 114x162 mm
ENVELOPE_CS_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
Envelope C5 162x229 mm
ENVELOPE_DL_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
Envelope DL 110x220 mm
ENVELOPE_MONARCH_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup

Environment - Class in org.apache.poi.hslf.record
Environment, which contains lots of settings for the document.
Environment(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.Environment
Set things up, and find our more interesting children
Environment - Static variable in class org.apache.poi.hslf.record.RecordTypes

EOF - Static variable in class org.apache.poi.poifs.filesystem.DocumentInputStream
returned by read operations if we're at end of document
eof() - Method in class org.apache.poi.poifs.storage.RawDataBlock
When we read the data, did we hit end of file?
EOFRecord - Class in org.apache.poi.hssf.record
End Of File record.
EOFRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.EOFRecord

EOL - Static variable in class org.apache.poi.util.HexDump

EPOCH_DIFF - Static variable in class org.apache.poi.hpsf.Util
The difference between the Windows epoch (1601-01-01 00:00:00) and the Unix epoch (1970-01-01 00:00:00) in milliseconds: 11644473600000L.
equal(byte[], byte[]) - Static method in class org.apache.poi.hpsf.Util
Checks whether two byte arrays a and b are equal.
EQUAL - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

EQUAL - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Equal to' operator
EQUAL - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

EqualEval - Static variable in class org.apache.poi.ss.formula.eval.RelationalOperationEval

EqualPtg - Class in org.apache.poi.ss.formula.ptg

equals(Object) - Method in class org.apache.poi.ddf.EscherComplexProperty
Determine whether this property is equal to another property.
equals(Object) - Method in class org.apache.poi.ddf.EscherSimpleProperty
Returns true if one escher property is equal to another.
equals(Object) - Method in class org.apache.poi.hpsf.ClassID
Checks whether this ClassID is equal to another object.
equals(Object) - Method in class org.apache.poi.hpsf.Property
Compares two properties.
equals(Object) - Method in class org.apache.poi.hpsf.PropertySet
Returns true if the PropertySet is equal to the specified parameter, else false.
equals(Object) - Method in class org.apache.poi.hpsf.Section
Checks whether this section is equal to another object.
equals(Object) - Method in class org.apache.poi.hpsf.SpecialPropertySet

equals(Collection<?>, Collection<?>) - Static method in class org.apache.poi.hpsf.Util
Checks whether two collections are equal.
equals(Object[], Object[]) - Static method in class org.apache.poi.hpsf.Util
Compares to object arrays with regarding the objects' order.
equals(Object) - Method in class org.apache.poi.hssf.record.common.UnicodeString
Our handling of equals is inconsistent with compareTo.
equals(Object) - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

equals(Object) - Method in class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

equals(Object) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
Will consider two different records with the same contents as equals, as the various indexes that matter are embedded in the records
equals(Object) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle

equals(Object) - Method in class org.apache.poi.hssf.usermodel.HSSFFont

equals(Object) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString

equals(Object) - Method in class org.apache.poi.hssf.usermodel.HSSFRow

equals(Object) - Method in class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

equals(Object) - Method in class org.apache.poi.hwpf.model.Colorref

equals(Object) - Method in class org.apache.poi.hwpf.model.Ffn

equals(Object) - Method in class org.apache.poi.hwpf.model.FibBase

equals(Object) - Method in class org.apache.poi.hwpf.model.FontTable

equals(Object) - Method in class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

equals(Object) - Method in class org.apache.poi.hwpf.model.Hyphenation

equals(Object) - Method in class org.apache.poi.hwpf.model.ListData

equals(Object) - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

equals(Object) - Method in class org.apache.poi.hwpf.model.ListLevel

equals(Object) - Method in class org.apache.poi.hwpf.model.ListTables

equals(Object) - Method in class org.apache.poi.hwpf.model.PAPX

equals(Object) - Method in class org.apache.poi.hwpf.model.ParagraphHeight

equals(Object) - Method in class org.apache.poi.hwpf.model.PICF

equals(Object) - Method in class org.apache.poi.hwpf.model.PieceDescriptor

equals(Object) - Method in class org.apache.poi.hwpf.model.PropertyModifier

equals(Object) - Method in class org.apache.poi.hwpf.model.PropertyNode

equals(Object) - Method in class org.apache.poi.hwpf.model.SavedByEntry
Compares this object with another, for equality.
equals(Object) - Method in class org.apache.poi.hwpf.model.SectionDescriptor

equals(Object) - Method in class org.apache.poi.hwpf.model.SEPX

equals(Object) - Method in class org.apache.poi.hwpf.model.StyleDescription

equals(Object) - Method in class org.apache.poi.hwpf.model.StyleSheet

equals(Object) - Method in class org.apache.poi.hwpf.model.TextPiece

equals(Object) - Method in class org.apache.poi.hwpf.model.TextPieceTable

equals(Object) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

equals(Object) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

equals(Object) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType

equals(Object) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType

equals(Object) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

equals(Object) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType

equals(Object) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType

equals(Object) - Method in class org.apache.poi.hwpf.model.UPX

equals(Object) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

equals(Object) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

equals(Object) - Method in class org.apache.poi.hwpf.usermodel.DateAndTime

equals(Object) - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

equals(Object) - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

equals(Object) - Method in class org.apache.poi.hwpf.usermodel.SectionProperties

equals(Object) - Method in class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

equals(Object) - Method in class org.apache.poi.openxml4j.opc.internal.ContentType

equals(Object) - Method in class org.apache.poi.openxml4j.opc.PackagePartName
Part name equivalence is determined by comparing part names as case-insensitive ASCII strings.
equals(Object) - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

equals(Object) - Method in class org.apache.poi.poifs.filesystem.DocumentDescriptor
equality.
equals(Object) - Method in class org.apache.poi.poifs.filesystem.POIFSDocumentPath
equality.
equals(Object) - Method in class org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator
Object equality, implemented as object identity
equals(Object) - Method in class org.apache.poi.ss.format.CellFormat
Returns true if the other object is a CellFormat object with the same format.
equals(Object) - Method in class org.apache.poi.ss.util.CellReference
Checks whether this cell reference is equal to another object.
equals(Region) - Method in class org.apache.poi.ss.util.Region
Deprecated.
equals(Object) - Method in class org.apache.poi.util.IntList
Compares the specified object with this list for equality.
equals(Object) - Method in class org.apache.poi.util.ShortList
Compares the specified object with this list for equality.
equals(Object) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder

equals(Object) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill

equals(Object) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Checks is the supplied style is equal to this style
equals(Object) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

equals(Object) - Method in class org.apache.poi.xssf.usermodel.XSSFColor

equals(Object) - Method in class org.apache.poi.xssf.usermodel.XSSFFont

equals(Object) - Method in class org.apache.poi.xssf.usermodel.XSSFName
Compares this name to the specified object.
equals(Object) - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData

equalsContents(Object) - Method in class org.apache.poi.hpsf.CustomProperty
Compares two custom properties for equality.
ERFListener - Interface in org.apache.poi.hssf.eventmodel
An ERFListener is registered with the EventRecordFactory.
ERROR - Static variable in class org.apache.poi.hsmf.datatypes.Types
Error - 32-bit error value
ERROR - Static variable in class org.apache.poi.util.POILogger

ERROR_DIV_0 - Static variable in class org.apache.poi.ss.usermodel.ErrorConstants
#DIV/0! - Division by zero
ERROR_NA - Static variable in class org.apache.poi.ss.usermodel.ErrorConstants
#N/A - Argument or function not available
ERROR_NAME - Static variable in class org.apache.poi.ss.usermodel.ErrorConstants
#NAME? - Wrong function or range name
ERROR_NULL - Static variable in class org.apache.poi.ss.usermodel.ErrorConstants
#NULL! - Intersection of two cell ranges is empty
ERROR_NUM - Static variable in class org.apache.poi.ss.usermodel.ErrorConstants
#NUM! - Value range overflow
ERROR_REF - Static variable in class org.apache.poi.ss.usermodel.ErrorConstants
#REF! - Illegal or deleted cell reference
ERROR_VALUE - Static variable in class org.apache.poi.ss.usermodel.ErrorConstants
#VALUE! - Wrong type of operand
ErrorConstant - Class in org.apache.poi.ss.formula.constant
Represents a constant error code value as encoded in a constant values array.
ErrorConstants - Class in org.apache.poi.ss.usermodel
Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)
ErrorConstants() - Constructor for class org.apache.poi.ss.usermodel.ErrorConstants

ErrorEval - Class in org.apache.poi.ss.formula.eval

Errortype - Class in org.apache.poi.ss.formula.functions
Implementation for the ERROR.TYPE() Excel function.
Errortype() - Constructor for class org.apache.poi.ss.formula.functions.Errortype

ErrPtg - Class in org.apache.poi.ss.formula.ptg

EscherAggregate - Class in org.apache.poi.hssf.record
This class is used to aggregate the MSODRAWING and OBJ record combinations.
EscherAggregate(DrawingManager2) - Constructor for class org.apache.poi.hssf.record.EscherAggregate

EscherAlignRule - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherAnchor - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherArcRule - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherArrayProperty - Class in org.apache.poi.ddf
Escher array properties are the most wierd construction ever invented with all sorts of special cases.
EscherArrayProperty(short, byte[]) - Constructor for class org.apache.poi.ddf.EscherArrayProperty

EscherArrayProperty(short, boolean, byte[]) - Constructor for class org.apache.poi.ddf.EscherArrayProperty

EscherBitmapBlip - Class in org.apache.poi.ddf

EscherBitmapBlip() - Constructor for class org.apache.poi.ddf.EscherBitmapBlip

EscherBlip_END - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherBlip_START - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherBlipRecord - Class in org.apache.poi.ddf

EscherBlipRecord() - Constructor for class org.apache.poi.ddf.EscherBlipRecord

EscherBlipWMFRecord - Class in org.apache.poi.ddf
The blip record is used to hold details about large binary objects that occur in escher such as JPEG, GIF, PICT and WMF files.
EscherBlipWMFRecord() - Constructor for class org.apache.poi.ddf.EscherBlipWMFRecord

EscherBoolProperty - Class in org.apache.poi.ddf
Represents a boolean property.
EscherBoolProperty(short, int) - Constructor for class org.apache.poi.ddf.EscherBoolProperty
Create an instance of an escher boolean property.
EscherBSE - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherBSERecord - Class in org.apache.poi.ddf
The BSE record is related closely to the EscherBlipRecord and stores extra information about the blip.
EscherBSERecord() - Constructor for class org.apache.poi.ddf.EscherBSERecord

EscherBStoreContainer - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherCalloutRule - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherChildAnchor - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherChildAnchorRecord - Class in org.apache.poi.ddf
The escher child achor record is used to specify the position of a shape under an existing group.
EscherChildAnchorRecord() - Constructor for class org.apache.poi.ddf.EscherChildAnchorRecord

EscherClientAnchor - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherClientAnchorRecord - Class in org.apache.poi.ddf
The escher client anchor specifies which rows and cells the shape is bound to as well as the offsets within those cells.
EscherClientAnchorRecord() - Constructor for class org.apache.poi.ddf.EscherClientAnchorRecord

EscherClientData - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherClientDataRecord - Class in org.apache.poi.ddf
The EscherClientDataRecord is used to store client specific data about the position of a shape within a container.
EscherClientDataRecord() - Constructor for class org.apache.poi.ddf.EscherClientDataRecord

EscherClientRule - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherClientTextbox - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherCLSID - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherColorMRU - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherColorScheme - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherComplexProperty - Class in org.apache.poi.ddf
A complex property differs from a simple property in that the data can not fit inside a 32 bit integer.
EscherComplexProperty(short, byte[]) - Constructor for class org.apache.poi.ddf.EscherComplexProperty
Create a complex property using the property id and a byte array containing the complex data value.
EscherComplexProperty(short, boolean, byte[]) - Constructor for class org.apache.poi.ddf.EscherComplexProperty
Create a complex property using the property number, a flag to indicate whether this is a blip reference and the complex property data.
EscherConnectorRule - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherContainerRecord - Class in org.apache.poi.ddf
Escher container records store other escher records as children.
EscherContainerRecord() - Constructor for class org.apache.poi.ddf.EscherContainerRecord

EscherDelayStm - Class in org.apache.poi.hpbf.model

EscherDelayStm(DirectoryNode) - Constructor for class org.apache.poi.hpbf.model.EscherDelayStm

EscherDeletedPspl - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherDg - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherDgContainer - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherDgg - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherDggContainer - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherDggRecord - Class in org.apache.poi.ddf
This record defines the drawing groups used for a particular sheet.
EscherDggRecord() - Constructor for class org.apache.poi.ddf.EscherDggRecord

EscherDggRecord.FileIdCluster - Class in org.apache.poi.ddf

EscherDggRecord.FileIdCluster(int, int) - Constructor for class org.apache.poi.ddf.EscherDggRecord.FileIdCluster

EscherDgRecord - Class in org.apache.poi.ddf
This record simply holds the number of shapes in the drawing group and the last shape id used for this drawing group.
EscherDgRecord() - Constructor for class org.apache.poi.ddf.EscherDgRecord

EscherDump - Class in org.apache.poi.ddf
Used to dump the contents of escher records to a PrintStream.
EscherDump() - Constructor for class org.apache.poi.ddf.EscherDump

EscherGraphics - Class in org.apache.poi.hssf.usermodel
Translates Graphics calls into escher calls.
EscherGraphics(HSSFShapeGroup, HSSFWorkbook, Color, float) - Constructor for class org.apache.poi.hssf.usermodel.EscherGraphics
Construct an escher graphics object.
EscherGraphics2d - Class in org.apache.poi.hssf.usermodel
Translates Graphics2d calls into escher calls.
EscherGraphics2d(EscherGraphics) - Constructor for class org.apache.poi.hssf.usermodel.EscherGraphics2d
Constructs one escher graphics object from an escher graphics object.
EscherMetafileBlip - Class in org.apache.poi.ddf

EscherMetafileBlip() - Constructor for class org.apache.poi.ddf.EscherMetafileBlip

EscherOleObject - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherOPT - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherOptRecord - Class in org.apache.poi.ddf
The opt record is used to store property values for a shape.
EscherOptRecord() - Constructor for class org.apache.poi.ddf.EscherOptRecord

EscherPart - Class in org.apache.poi.hpbf.model
Parent class of all Escher parts
EscherPart(DirectoryNode, String[]) - Constructor for class org.apache.poi.hpbf.model.EscherPart
Creates the Escher Part, and finds our child escher records
EscherPictBlip - Class in org.apache.poi.ddf

EscherPictBlip() - Constructor for class org.apache.poi.ddf.EscherPictBlip

EscherProperties - Class in org.apache.poi.ddf
Provides a list of all known escher properties including the description and type.
EscherProperties() - Constructor for class org.apache.poi.ddf.EscherProperties

EscherProperty - Class in org.apache.poi.ddf
This is the abstract base class for all escher properties.
EscherProperty(short) - Constructor for class org.apache.poi.ddf.EscherProperty
The id is distinct from the actual property number.
EscherProperty(short, boolean, boolean) - Constructor for class org.apache.poi.ddf.EscherProperty
Constructs a new escher property.
EscherPropertyFactory - Class in org.apache.poi.ddf
Generates a property given a reference into the byte array storing that property.
EscherPropertyFactory() - Constructor for class org.apache.poi.ddf.EscherPropertyFactory

EscherPropertyMetaData - Class in org.apache.poi.ddf
This class stores the type and description of an escher property.
EscherPropertyMetaData(String) - Constructor for class org.apache.poi.ddf.EscherPropertyMetaData

EscherPropertyMetaData(String, byte) - Constructor for class org.apache.poi.ddf.EscherPropertyMetaData

EscherRecord - Class in org.apache.poi.ddf
The base abstract record from which all escher records are defined.
EscherRecord() - Constructor for class org.apache.poi.ddf.EscherRecord
Create a new instance
EscherRecordFactory - Interface in org.apache.poi.ddf
The escher record factory interface allows for the creation of escher records from a pointer into a data array.
EscherRecordHolder - Class in org.apache.poi.hwpf.model
Based on AbstractEscherRecordHolder from HSSF.
EscherRecordHolder() - Constructor for class org.apache.poi.hwpf.model.EscherRecordHolder

EscherRecordHolder(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.EscherRecordHolder

EscherRegroupItems - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherRGBProperty - Class in org.apache.poi.ddf
A color property.
EscherRGBProperty(short, int) - Constructor for class org.apache.poi.ddf.EscherRGBProperty

EscherSelection - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherSerializationListener - Interface in org.apache.poi.ddf
Interface for listening to escher serialization events.
EscherShapePathProperty - Class in org.apache.poi.ddf
Defines the constants for the various possible shape paths.
EscherShapePathProperty(short, int) - Constructor for class org.apache.poi.ddf.EscherShapePathProperty

EscherSimpleProperty - Class in org.apache.poi.ddf
A simple property is of fixed length and as a property number in addition to a 32-bit value.
EscherSimpleProperty(short, int) - Constructor for class org.apache.poi.ddf.EscherSimpleProperty
The id is distinct from the actual property number.
EscherSimpleProperty(short, boolean, boolean, int) - Constructor for class org.apache.poi.ddf.EscherSimpleProperty
Constructs a new escher property.
EscherSolverContainer - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherSp - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherSpContainer - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherSpgr - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherSpgrContainer - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherSpgrRecord - Class in org.apache.poi.ddf
The spgr record defines information about a shape group.
EscherSpgrRecord() - Constructor for class org.apache.poi.ddf.EscherSpgrRecord

EscherSplitMenuColors - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherSplitMenuColorsRecord - Class in org.apache.poi.ddf
A list of the most recently used colours for the drawings contained in this document.
EscherSplitMenuColorsRecord() - Constructor for class org.apache.poi.ddf.EscherSplitMenuColorsRecord

EscherSpRecord - Class in org.apache.poi.ddf
Together the the EscherOptRecord this record defines some of the basic properties of a shape.
EscherSpRecord() - Constructor for class org.apache.poi.ddf.EscherSpRecord

EscherStm - Class in org.apache.poi.hpbf.model

EscherStm(DirectoryNode) - Constructor for class org.apache.poi.hpbf.model.EscherStm

EscherTertiaryOptRecord - Class in org.apache.poi.ddf
"The OfficeArtTertiaryFOPT record specifies a table of OfficeArtRGFOPTE properties, as defined in section 2.3.1." -- [MS-ODRAW] -- v20110608; Office Drawing Binary File Format
EscherTertiaryOptRecord() - Constructor for class org.apache.poi.ddf.EscherTertiaryOptRecord

EscherTextbox - Static variable in class org.apache.poi.hslf.record.RecordTypes

EscherTextboxRecord - Class in org.apache.poi.ddf
Holds data from the parent application.
EscherTextboxRecord() - Constructor for class org.apache.poi.ddf.EscherTextboxRecord

EscherTextboxWrapper - Class in org.apache.poi.hslf.record
A wrapper around a DDF (Escher) EscherTextbox Record.
EscherTextboxWrapper(EscherTextboxRecord) - Constructor for class org.apache.poi.hslf.record.EscherTextboxWrapper
Creates the wrapper for the given DDF Escher Record and children
EscherTextboxWrapper() - Constructor for class org.apache.poi.hslf.record.EscherTextboxWrapper
Creates a new, empty wrapper for DDF Escher Records and their children
EscherUserDefined - Static variable in class org.apache.poi.hslf.record.RecordTypes

eval(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.NumericFunction

eval(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.NumericFunction.OneArg

evaluate(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.eval.ConcatEval

evaluate(String, int, int) - Method in class org.apache.poi.ss.formula.eval.forked.ForkedEvaluator
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.eval.IntersectionEval

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.eval.PercentEval

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.eval.RangeEval

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.eval.RelationalOperationEval
This is a description of how the relational operators apply in MS Excel.
evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

evaluate(double, double) - Method in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.eval.UnaryMinusEval

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.eval.UnaryPlusEval

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Address

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.BooleanFunction

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.CalendarFieldFunction

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Choose

evaluate(int, int) - Method in class org.apache.poi.ss.formula.functions.Column

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Column

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Column

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Columns

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Count

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Counta

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Countblank

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Countif

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.DateFunc

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Days360

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Days360

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Errortype

evaluate(double) - Method in class org.apache.poi.ss.formula.functions.Even

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.FinanceFunction

evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.FinanceFunction

evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.FinanceFunction

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.FinanceFunction

evaluate(double[]) - Method in class org.apache.poi.ss.formula.functions.FinanceFunction

evaluate(double, double, double, double, boolean) - Method in class org.apache.poi.ss.formula.functions.FinanceFunction

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Fixed0ArgFunction

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Fixed1ArgFunction

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Fixed2ArgFunction

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Fixed3ArgFunction

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Fixed4ArgFunction

evaluate(ValueEval[], OperationEvaluationContext) - Method in interface org.apache.poi.ss.formula.functions.FreeRefFunction

evaluate(ValueEval[], int, int) - Method in interface org.apache.poi.ss.formula.functions.Function

evaluate(int, int) - Method in interface org.apache.poi.ss.formula.functions.Function0Arg
see Function.evaluate(ValueEval[], int, int)
evaluate(int, int, ValueEval) - Method in interface org.apache.poi.ss.formula.functions.Function1Arg
see Function.evaluate(ValueEval[], int, int)
evaluate(int, int, ValueEval, ValueEval) - Method in interface org.apache.poi.ss.formula.functions.Function2Arg
see Function.evaluate(ValueEval[], int, int)
evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in interface org.apache.poi.ss.formula.functions.Function3Arg
see Function.evaluate(ValueEval[], int, int)
evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval) - Method in interface org.apache.poi.ss.formula.functions.Function4Arg
see Function.evaluate(ValueEval[], int, int)
evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Hlookup

evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Hlookup

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Hyperlink

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Hyperlink

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.IfFunc

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.IfFunc

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Index

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Index

evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Index

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Index

evaluate(ValueEval[], OperationEvaluationContext) - Method in class org.apache.poi.ss.formula.functions.Indirect

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Irr

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.LogicalFunction

evaluate(ValueEval) - Method in class org.apache.poi.ss.formula.functions.LogicalFunction

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Lookup

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Lookup

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Match

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Match

evaluate(double[]) - Static method in class org.apache.poi.ss.formula.functions.Mode
if v is zero length or contains no duplicates, return value is Double.NaN.
evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Mode

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction

evaluate(double[]) - Method in class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction

evaluate(int, int) - Method in class org.apache.poi.ss.formula.functions.Na

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.NotImplementedFunction

evaluate(int, int) - Method in class org.apache.poi.ss.formula.functions.Now

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Npv

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.NumericFunction

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.NumericFunction.OneArg

evaluate(double) - Method in class org.apache.poi.ss.formula.functions.NumericFunction.OneArg

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.NumericFunction.TwoArg

evaluate(double, double) - Method in class org.apache.poi.ss.formula.functions.NumericFunction.TwoArg

evaluate(double) - Method in class org.apache.poi.ss.formula.functions.Odd

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Offset

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Rank

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Rank

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Rate

evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Replace

evaluate(int, int) - Method in class org.apache.poi.ss.formula.functions.RowFunc

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.RowFunc

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.RowFunc

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Rows

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Substitute

evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Substitute

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Subtotal

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Sumif

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Sumif

evaluate(ValueEval[], OperationEvaluationContext) - Method in class org.apache.poi.ss.formula.functions.Sumifs

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.Sumproduct

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.T

evaluate(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.TextFunction

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.TimeFunc

evaluate(int, int) - Method in class org.apache.poi.ss.formula.functions.Today

evaluate(int, int, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Value

evaluate(int, int, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Vlookup

evaluate(int, int, ValueEval, ValueEval, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.Vlookup

evaluate(int, int, ValueEval, ValueEval) - Method in class org.apache.poi.ss.formula.functions.XYNumericFunction

evaluate(EvaluationCell) - Method in class org.apache.poi.ss.formula.WorkbookEvaluator

evaluate(Cell) - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.AbsExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.AddDivideExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.AddSubtractExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.AdjustValue

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.ArcTanExpression

evaluate(Formula) - Method in class org.apache.poi.xslf.model.geom.Context

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.CosExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.CosineArcTanExpression

evaluate(Context) - Method in interface org.apache.poi.xslf.model.geom.Expression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.Guide

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.IfElseExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.LiteralValueExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.MaxExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.MinExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.ModExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.MultiplyDivideExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.PinExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.SinArcTanExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.SinExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.SqrtExpression

evaluate(Context) - Method in class org.apache.poi.xslf.model.geom.TanExpression

evaluate(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
evaluateAll() - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Loops over all cells in all sheets of the supplied workbook.
evaluateAll() - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
Loops over all cells in all sheets of the associated workbook.
evaluateAll() - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
Loops over all cells in all sheets of the supplied workbook.
evaluateAllFormulaCells(HSSFWorkbook) - Static method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Loops over all cells in all sheets of the supplied workbook.
evaluateAllFormulaCells(Workbook) - Static method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Loops over all cells in all sheets of the supplied workbook.
evaluateAllFormulaCells(XSSFWorkbook) - Static method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
Loops over all cells in all sheets of the supplied workbook.
evaluateDoubleArg(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.functions.TextFunction

evaluateFirstArg(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.functions.Choose

evaluateFirstArg(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.functions.IfFunc

evaluateFormulaCell(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
If cell contains formula, it evaluates the formula, and saves the result of the formula.
evaluateFormulaCell(Cell) - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
If cell contains formula, it evaluates the formula, and saves the result of the formula.
evaluateFormulaCell(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
If cell contains formula, it evaluates the formula, and saves the result of the formula.
evaluateFunc(ValueEval[], int, int) - Method in class org.apache.poi.ss.formula.functions.TextFunction

evaluateInCell(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
evaluateInCell(Cell) - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
evaluateInCell(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
evaluateIntArg(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.functions.TextFunction

evaluateStringArg(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.functions.TextFunction

EvaluationCell - Interface in org.apache.poi.ss.formula
Abstracts a cell for the purpose of formula evaluation.
EvaluationException - Exception in org.apache.poi.ss.formula.eval
This class is used to simplify error handling logic within operator and function implementations.
EvaluationException(ErrorEval) - Constructor for exception org.apache.poi.ss.formula.eval.EvaluationException

EvaluationName - Interface in org.apache.poi.ss.formula
Abstracts a name record for formula evaluation.
For POI internal use only
EvaluationSheet - Interface in org.apache.poi.ss.formula
Abstracts a sheet for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook - Interface in org.apache.poi.ss.formula
Abstracts a workbook for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook.ExternalName - Class in org.apache.poi.ss.formula

EvaluationWorkbook.ExternalName(String, int, int) - Constructor for class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName

EvaluationWorkbook.ExternalSheet - Class in org.apache.poi.ss.formula

EvaluationWorkbook.ExternalSheet(String, String) - Constructor for class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet

Even - Class in org.apache.poi.ss.formula.functions

Even() - Constructor for class org.apache.poi.ss.formula.functions.Even

EVEN - Static variable in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

EventBasedExcelExtractor - Class in org.apache.poi.hssf.extractor
A text extractor for Excel files, that is based on the hssf eventusermodel api.
EventBasedExcelExtractor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hssf.extractor.EventBasedExcelExtractor
Deprecated. Use EventBasedExcelExtractor.EventBasedExcelExtractor(DirectoryNode) instead
EventBasedExcelExtractor(DirectoryNode) - Constructor for class org.apache.poi.hssf.extractor.EventBasedExcelExtractor

EventBasedExcelExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hssf.extractor.EventBasedExcelExtractor

EventRecordFactory - Class in org.apache.poi.hssf.eventmodel
Event-based record factory.
EventRecordFactory(ERFListener, short[]) - Constructor for class org.apache.poi.hssf.eventmodel.EventRecordFactory

EventWorkbookBuilder - Class in org.apache.poi.hssf.eventusermodel
When working with the EventUserModel, if you want to process formulas, you need an instance of InternalWorkbook to pass to a HSSFWorkbook, to finally give to HSSFFormulaParser, and this will build you stub ones.
EventWorkbookBuilder() - Constructor for class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder

EventWorkbookBuilder.SheetRecordCollectingListener - Class in org.apache.poi.hssf.eventusermodel
A wrapping HSSFListener which will collect BoundSheetRecords and ExternSheetRecords as they go past, so you can create a Stub InternalWorkbook from them once required.
EventWorkbookBuilder.SheetRecordCollectingListener(HSSFListener) - Constructor for class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

EvilUnclosedBRFixingInputStream - Class in org.apache.poi.xssf.util
This is a seriously sick fix for the fact that some .xlsx files contain raw bits of HTML, without being escaped or properly turned into XML.
EvilUnclosedBRFixingInputStream(InputStream) - Constructor for class org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream

EXACT - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

ExAviMovie - Class in org.apache.poi.hslf.record
A container record that specifies information about a movie stored externally.
ExAviMovie(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExAviMovie
Set things up, and find our more interesting children
ExAviMovie() - Constructor for class org.apache.poi.hslf.record.ExAviMovie
Create a new ExAviMovie, with blank fields
ExAviMovie - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExCDAudio - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExCDAudioAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExcelExtractor - Class in org.apache.poi.hssf.extractor
A text extractor for Excel files.
ExcelExtractor(HSSFWorkbook) - Constructor for class org.apache.poi.hssf.extractor.ExcelExtractor

ExcelExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hssf.extractor.ExcelExtractor

ExcelExtractor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hssf.extractor.ExcelExtractor
Deprecated. Use ExcelExtractor.ExcelExtractor(DirectoryNode) instead
ExcelExtractor(DirectoryNode) - Constructor for class org.apache.poi.hssf.extractor.ExcelExtractor

ExcelExtractor - Interface in org.apache.poi.ss.extractor
Common interface for Excel text extractors, covering HSSF and XSSF
ExcelStyleDateFormatter - Class in org.apache.poi.ss.usermodel
A wrapper around a SimpleDateFormat instance, which handles a few Excel-style extensions that are not supported by SimpleDateFormat.
ExcelStyleDateFormatter() - Constructor for class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

ExcelStyleDateFormatter(String) - Constructor for class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

ExcelStyleDateFormatter(String, DateFormatSymbols) - Constructor for class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

ExcelStyleDateFormatter(String, Locale) - Constructor for class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

ExcelToFoConverter - Class in org.apache.poi.hssf.converter
Converts xls files (97-2007) to XSL FO.
ExcelToFoConverter(Document) - Constructor for class org.apache.poi.hssf.converter.ExcelToFoConverter

ExcelToFoConverter(FoDocumentFacade) - Constructor for class org.apache.poi.hssf.converter.ExcelToFoConverter

ExcelToFoUtils - Class in org.apache.poi.hssf.converter

ExcelToFoUtils() - Constructor for class org.apache.poi.hssf.converter.ExcelToFoUtils

ExcelToHtmlConverter - Class in org.apache.poi.hssf.converter
Converts xls files (97-2007) to HTML file.
ExcelToHtmlConverter(Document) - Constructor for class org.apache.poi.hssf.converter.ExcelToHtmlConverter

ExcelToHtmlConverter(HtmlDocumentFacade) - Constructor for class org.apache.poi.hssf.converter.ExcelToHtmlConverter

ExcelToHtmlUtils - Class in org.apache.poi.hssf.converter

ExcelToHtmlUtils() - Constructor for class org.apache.poi.hssf.converter.ExcelToHtmlUtils

ExControl - Class in org.apache.poi.hslf.record
A container record that specifies information about an ActiveX control.
ExControl(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExControl
Set things up, and find our more interesting children
ExControl() - Constructor for class org.apache.poi.hslf.record.ExControl
Create a new ExEmbed, with blank fields
ExControl - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExControlAtom - Class in org.apache.poi.hslf.record
An atom record that specifies an ActiveX control.
ExControlAtom() - Constructor for class org.apache.poi.hslf.record.ExControlAtom
Constructs a brand new embedded object atom record.
ExControlAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExControlAtom
Constructs the ExControlAtom record from its source data.
ExControlAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

execute(GeneralPath, Context) - Method in class org.apache.poi.xslf.model.geom.ArcToCommand

execute(GeneralPath, Context) - Method in class org.apache.poi.xslf.model.geom.ClosePathCommand

execute(GeneralPath, Context) - Method in class org.apache.poi.xslf.model.geom.CurveToCommand

execute(GeneralPath, Context) - Method in class org.apache.poi.xslf.model.geom.LineToCommand

execute(GeneralPath, Context) - Method in class org.apache.poi.xslf.model.geom.MoveToCommand

execute(GeneralPath, Context) - Method in interface org.apache.poi.xslf.model.geom.PathCommand
Execute the command an append a segment to the specified path
execute(GeneralPath, Context) - Method in class org.apache.poi.xslf.model.geom.QuadToCommand

EXECUTIVE_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Executive 7 1/4 x 10 1/2 in
ExEmbed - Class in org.apache.poi.hslf.record
This data represents an embedded object in the document.
ExEmbed(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExEmbed
Set things up, and find our more interesting children
ExEmbed() - Constructor for class org.apache.poi.hslf.record.ExEmbed
Create a new ExEmbed, with blank fields
ExEmbed - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExEmbedAtom - Class in org.apache.poi.hslf.record
The atom that holds metadata on a specific embedded object in the document.
ExEmbedAtom() - Constructor for class org.apache.poi.hslf.record.ExEmbedAtom
Constructs a brand new embedded object atom record.
ExEmbedAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExEmbedAtom
Constructs the embedded object atom record from its source data.
ExEmbedAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExHyperlink - Class in org.apache.poi.hslf.record
This class represents the data of a link in the document.
ExHyperlink(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExHyperlink
Set things up, and find our more interesting children
ExHyperlink() - Constructor for class org.apache.poi.hslf.record.ExHyperlink
Create a new ExHyperlink, with blank fields
ExHyperlink - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExHyperlinkAtom - Class in org.apache.poi.hslf.record
Tne atom that holds metadata on a specific Link in the document.
ExHyperlinkAtom() - Constructor for class org.apache.poi.hslf.record.ExHyperlinkAtom
Constructs a brand new link related atom record.
ExHyperlinkAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExHyperlinkAtom
Constructs the link related atom record from its source data.
ExHyperlinkAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExLink - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExLinkAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExMCIMovie - Class in org.apache.poi.hslf.record
A container record that specifies information about a movie stored externally.
ExMCIMovie(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExMCIMovie
Set things up, and find our more interesting children
ExMCIMovie() - Constructor for class org.apache.poi.hslf.record.ExMCIMovie
Create a new ExMCIMovie, with blank fields
ExMCIMovie - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExMediaAtom - Class in org.apache.poi.hslf.record
An atom record that specifies information about external audio or video data.
ExMediaAtom() - Constructor for class org.apache.poi.hslf.record.ExMediaAtom
Constructs a brand new link related atom record.
ExMediaAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExMediaAtom
Constructs the link related atom record from its source data.
ExMediaAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExMIDIAudio - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExObjList - Class in org.apache.poi.hslf.record
This class holds the links to exernal objects referenced from the document.
ExObjList(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExObjList
Set things up, and find our more interesting children
ExObjList() - Constructor for class org.apache.poi.hslf.record.ExObjList
Create a new ExObjList, with blank fields
ExObjList - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExObjListAtom - Class in org.apache.poi.hslf.record
Tne atom that holds the seed info used by a ExObjList
ExObjListAtom() - Constructor for class org.apache.poi.hslf.record.ExObjListAtom
Constructs a brand new link related atom record.
ExObjListAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExObjListAtom
Constructs the link related atom record from its source data.
ExObjListAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExObjRefAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExOleObjAtom - Class in org.apache.poi.hslf.record
Atom storing information for an OLE object.
ExOleObjAtom() - Constructor for class org.apache.poi.hslf.record.ExOleObjAtom
Constructs a brand new link related atom record.
ExOleObjAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExOleObjAtom
Constructs the link related atom record from its source data.
ExOleObjAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExOleObjStg - Class in org.apache.poi.hslf.record
Storage for embedded OLE objects.
ExOleObjStg() - Constructor for class org.apache.poi.hslf.record.ExOleObjStg
Constructs a new empty storage container.
ExOleObjStg(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExOleObjStg
Constructs the link related atom record from its source data.
ExOleObjStg - Static variable in class org.apache.poi.hslf.record.RecordTypes

EXP - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

EXPAND_BEGIN_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

EXPAND_END_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

expandColumn(int) - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

EXPANDED_BEGIN_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

EXPANDED_END_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

expandRow(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

EXPIRY_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

EXPLICIT_CONVERSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

exportToXML(OutputStream, boolean) - Method in class org.apache.poi.xssf.extractor.XSSFExportToXml
Exports the data in an XML stream
exportToXML(OutputStream, String, boolean) - Method in class org.apache.poi.xssf.extractor.XSSFExportToXml
Exports the data in an XML stream
ExpPtg - Class in org.apache.poi.ss.formula.ptg

ExpPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.ExpPtg

ExpPtg(int, int) - Constructor for class org.apache.poi.ss.formula.ptg.ExpPtg

Expression - Interface in org.apache.poi.xslf.model.geom
Date: 10/24/11
ExpressionParser - Class in org.apache.poi.xslf.model.geom
A simple regexp-based parser of shape guide formulas in DrawingML
ExpressionParser() - Constructor for class org.apache.poi.xslf.model.geom.ExpressionParser

ExQuickTimeMovie - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExQuickTimeMovieData - Static variable in class org.apache.poi.hslf.record.RecordTypes

EXTENDED_PROPERTIES - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Extended properties relationship type.
ExtendedFormatRecord - Class in org.apache.poi.hssf.record
Title: Extended Format Record Description: Probably one of the more complex records.
ExtendedFormatRecord() - Constructor for class org.apache.poi.hssf.record.ExtendedFormatRecord
Constructor ExtendedFormatRecord
ExtendedFormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ExtendedFormatRecord

ExtendedPivotTableViewFieldsRecord - Class in org.apache.poi.hssf.record.pivottable
SXVDEX - Extended PivotTable View Fields (0x0100)

ExtendedPivotTableViewFieldsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

EXTENSION_GIF - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

EXTENSION_JPG_1 - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

EXTENSION_JPG_2 - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

EXTENSION_PICT - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

EXTENSION_PNG - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

EXTENSION_TIFF - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

EXTENSION_XML - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

ExternalNameRecord - Class in org.apache.poi.hssf.record
EXTERNALNAME (0x0023)

ExternalNameRecord() - Constructor for class org.apache.poi.hssf.record.ExternalNameRecord

ExternalNameRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ExternalNameRecord

ExternSheetRecord - Class in org.apache.poi.hssf.record
EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

ExternSheetRecord() - Constructor for class org.apache.poi.hssf.record.ExternSheetRecord

ExternSheetRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ExternSheetRecord

ExternSheetReferenceToken - Interface in org.apache.poi.ss.formula
Should be implemented by any Ptg subclass that needs has an extern sheet index
For POI internal use only
extract(POIFSBigBlockSize, ListManagedBlock[]) - Static method in class org.apache.poi.poifs.storage.SmallDocumentBlock
create a list of SmallDocumentBlock's from raw data
extractAttachments(File) - Method in class org.apache.poi.hmef.extractor.HMEFContentsExtractor
Extracts all the message attachments to the supplied directory
extractMessageBody(File) - Method in class org.apache.poi.hmef.extractor.HMEFContentsExtractor
Extracts the RTF message body to the supplied file
ExtractorFactory - Class in org.apache.poi.extractor
Figures out the correct POITextExtractor for your supplied document, and returns it.
ExtractorFactory() - Constructor for class org.apache.poi.extractor.ExtractorFactory

extractPicture(CharacterRun, boolean) - Method in class org.apache.poi.hwpf.model.PicturesTable
Returns picture object tied to specified CharacterRun
ExtSSTRecord - Class in org.apache.poi.hssf.record
Title: Extended Static String Table (0x00FF)
Description: This record is used for a quick lookup into the SST record.
ExtSSTRecord() - Constructor for class org.apache.poi.hssf.record.ExtSSTRecord

ExtSSTRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ExtSSTRecord

ExtSSTRecord.InfoSubRecord - Class in org.apache.poi.hssf.record

ExtSSTRecord.InfoSubRecord(int, int) - Constructor for class org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord
Creates new ExtSSTInfoSubRecord
ExtSSTRecord.InfoSubRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord

ExVideoContainer - Class in org.apache.poi.hslf.record
A container record that specifies information about external video data.
ExVideoContainer(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.ExVideoContainer
Set things up, and find our more interesting children
ExVideoContainer() - Constructor for class org.apache.poi.hslf.record.ExVideoContainer
Create a new ExVideoContainer, with blank fields
ExVideoContainer - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExWAVAudioEmbedded - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExWAVAudioEmbeddedAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

ExWAVAudioLink - Static variable in class org.apache.poi.hslf.record.RecordTypes

F

FACT - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

FALSE - Static variable in class org.apache.poi.ss.formula.eval.BoolEval

FALSE - Static variable in class org.apache.poi.ss.formula.functions.BooleanFunction

FALSE - Static variable in class org.apache.poi.ss.usermodel.CellValue

FAT_SECTOR_BLOCK - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
Indicates the sector holds a FAT block (0xFFFFFFFD)
FATAL - Static variable in class org.apache.poi.util.POILogger

FeatFormulaErr2 - Class in org.apache.poi.hssf.record.common
Title: FeatFormulaErr2 (Formula Evaluation Shared Feature) common record part
FeatFormulaErr2() - Constructor for class org.apache.poi.hssf.record.common.FeatFormulaErr2

FeatFormulaErr2(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.common.FeatFormulaErr2

FeatHdrRecord - Class in org.apache.poi.hssf.record
Title: FeatHdr (Feature Header) Record
FeatHdrRecord() - Constructor for class org.apache.poi.hssf.record.FeatHdrRecord

FeatHdrRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FeatHdrRecord

FeatProtection - Class in org.apache.poi.hssf.record.common
Title: FeatProtection (Protection Shared Feature) common record part
FeatProtection() - Constructor for class org.apache.poi.hssf.record.common.FeatProtection

FeatProtection(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.common.FeatProtection

FeatRecord - Class in org.apache.poi.hssf.record
Title: Feat (Feature) Record
FeatRecord() - Constructor for class org.apache.poi.hssf.record.FeatRecord

FeatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FeatRecord

FeatSmartTag - Class in org.apache.poi.hssf.record.common
Title: FeatSmartTag (Smart Tag Shared Feature) common record part
FeatSmartTag() - Constructor for class org.apache.poi.hssf.record.common.FeatSmartTag

FeatSmartTag(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.common.FeatSmartTag

fetch(CTTextParagraphProperties) - Method in class org.apache.poi.xslf.model.CharacterPropertyFetcher

fetch(CTTextCharacterProperties) - Method in class org.apache.poi.xslf.model.CharacterPropertyFetcher

fetch(XSLFSimpleShape) - Method in class org.apache.poi.xslf.model.ParagraphPropertyFetcher

fetch(CTTextParagraphProperties) - Method in class org.apache.poi.xslf.model.ParagraphPropertyFetcher

fetch(XSLFSimpleShape) - Method in class org.apache.poi.xslf.model.PropertyFetcher

fetch(XSLFSimpleShape) - Method in class org.apache.poi.xslf.model.TextBodyPropertyFetcher

fetch(CTTextBodyProperties) - Method in class org.apache.poi.xslf.model.TextBodyPropertyFetcher

fetchBlocks(int, int) - Method in interface org.apache.poi.poifs.storage.BlockList
get the blocks making up a particular stream in the list.
fetchDocumentEncryptionAtom(HSLFSlideShow) - Static method in class org.apache.poi.hslf.EncryptedSlideShow
Return the DocumentEncryptionAtom for a HSLFSlideShow, or null if there isn't one.
FF_DECORATIVE - Static variable in class org.apache.poi.hslf.model.PPFont
Novelty fonts.
FF_DONTCARE - Static variable in class org.apache.poi.hslf.model.PPFont
Don't care or don't know.
FF_MODERN - Static variable in class org.apache.poi.hslf.model.PPFont
Fonts with constant stroke width (monospace), with or without serifs.
FF_ROMAN - Static variable in class org.apache.poi.hslf.model.PPFont
Fonts with variable stroke width (proportional) and with serifs.
FF_SCRIPT - Static variable in class org.apache.poi.hslf.model.PPFont
Fonts designed to look like handwriting.
FF_SWISS - Static variable in class org.apache.poi.hslf.model.PPFont
Fonts with variable stroke width (proportional) and without serifs.
Ffn - Class in org.apache.poi.hwpf.model
FFN - Font Family Name.
Ffn(byte[], int) - Constructor for class org.apache.poi.hwpf.model.Ffn

fHasDate - Static variable in class org.apache.poi.hslf.record.HeadersFootersAtom
A bit that specifies whether the date is displayed in the footer.
fHasFooter - Static variable in class org.apache.poi.hslf.record.HeadersFootersAtom
bit that specifies whether the footer text is displayed.
fHasHeader - Static variable in class org.apache.poi.hslf.record.HeadersFootersAtom
bit that specifies whether the header text is displayed.
fHasSlideNumber - Static variable in class org.apache.poi.hslf.record.HeadersFootersAtom
A bit that specifies whether the slide number is displayed in the footer.
fHasTodayDate - Static variable in class org.apache.poi.hslf.record.HeadersFootersAtom
A bit that specifies whether the current datetime is used for displaying the datetime.
fHasUserDate - Static variable in class org.apache.poi.hslf.record.HeadersFootersAtom
A bit that specifies whether the date specified in UserDateAtom record is used for displaying the datetime.
FibBase - Class in org.apache.poi.hwpf.model
Base part of the File information Block (FibBase).
FibBase() - Constructor for class org.apache.poi.hwpf.model.FibBase

FibBase(byte[], int) - Constructor for class org.apache.poi.hwpf.model.FibBase

FibBaseAbstractType - Class in org.apache.poi.hwpf.model.types
Base part of the File information Block (FibBase).
FibBaseAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.FibBaseAbstractType

FIBFieldHandler - Class in org.apache.poi.hwpf.model

FibRgLw95AbstractType - Class in org.apache.poi.hwpf.model.types
The FibRgLw95 structure is the third section of the FIB for Word95.
FibRgLw95AbstractType() - Constructor for class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

FibRgLw97AbstractType - Class in org.apache.poi.hwpf.model.types
The FibRgLw97 structure is the third section of the FIB.
FibRgLw97AbstractType() - Constructor for class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

FibRgW97AbstractType - Class in org.apache.poi.hwpf.model.types
The FibRgW97 structure is a variable-length portion of the Fib.
FibRgW97AbstractType() - Constructor for class org.apache.poi.hwpf.model.types.FibRgW97AbstractType

Field - Interface in org.apache.poi.hwpf.usermodel

field_10_ccpAtn - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_10_ccpTxbx - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_10_flags2 - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_10_fNoLnn - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_10_ftsCellPaddingBottom - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_10_grpfIhdt - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_10_ilvlRestartLim - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_10_padding2 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_10_pctCharWidth - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_10_reserved10 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_10_wSpare - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_10_wWidthIndent - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_11_ccpEdn - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_11_ccpHdrTxbx - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_11_Chs - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated.
field_11_dxaGoal - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_11_dxaHotz - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_11_ftsCellPaddingRight - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_11_grfhic - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_11_lidDefault - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_11_lspd - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_11_nLnnMod - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_11_reserved11 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_11_wWidthBefore - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_12_cConsexHypLim - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_12_ccpTxbx - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_12_chsTables - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated.
field_12_dxaLnn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_12_dyaBefore - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_12_dyaGoal - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_12_lidFE - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_12_reserved12 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_12_reserved4 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_12_wCellSpacingLeft - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_12_wWidthAfter - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_13_ccpHdrTxbx - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_13_dxaPgn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_13_dyaAfter - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_13_fcMin - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated.
field_13_kcd - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_13_mx - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_13_reserved13 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_13_reserved5 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_13_wCellSpacingTop - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_13_widthAndFitsFlags - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_13_wSpare2 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_14_dttmCreated - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_14_dxaAbs - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_14_dyaPgn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_14_fcMac - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated.
field_14_fInTable - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_14_fUndetermine - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_14_lidFE - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType

field_14_my - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_14_reserved5 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Deprecated.
field_14_reserved6 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_14_wCellSpacingBottom - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_15_dttmRevised - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_15_dxaReserved1 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_15_dyaAbs - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_15_finTableW97 - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_15_fLBetween - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_15_iss - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_15_reserved7 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_15_wCellSpacingRight - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_16_dttmLastPrint - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_16_dxaFromText - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_16_dyaReserved1 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_16_fSpecSymbol - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_16_ftsCellSpacingLeft - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_16_fTtp - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_16_reserved8 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_16_vjc - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_17_dmBinFirst - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_17_dxaAbs - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_17_dxaReserved2 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_17_dyaFromText - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_17_ftsCellSpacingTop - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_17_idct - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_17_nRevision - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_17_reserved9 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_18_dmBinOther - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_18_dxaFromTextRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_18_dyaAbs - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_18_dyaReserved2 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_18_ftsCellSpacingBottom - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_18_idctHint - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_18_reserved10 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_18_tmEdited - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_19_cWords - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_19_dmPaperReq - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_19_dxaWidth - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_19_dyaFromTextBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_19_fReserved - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_19_ftsCellSpacingRight - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_19_kul - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_19_reserved11 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_1_bkc - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_1_cbMac - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_1_cbMac - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_1_chHolder - Variable in class org.apache.poi.hwpf.model.types.FLDAbstractType

field_1_cstd - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_1_cvFore - Variable in class org.apache.poi.hwpf.model.types.SHDAbstractType

field_1_formatFlags - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_1_grfhic - Variable in class org.apache.poi.hwpf.model.types.GrfhicAbstractType

field_1_gridset_flag - Variable in class org.apache.poi.hssf.record.GridsetRecord

field_1_grpfChp - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_1_hres - Variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

field_1_ibkl - Variable in class org.apache.poi.hwpf.model.types.BKFAbstractType

field_1_info1 - Variable in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

field_1_info1 - Variable in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

field_1_iStartAt - Variable in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

field_1_iStartAt - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_1_istd - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_1_istd - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_1_itl - Variable in class org.apache.poi.hwpf.model.types.TLPAbstractType

field_1_lcb - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_1_lsid - Variable in class org.apache.poi.hwpf.model.types.LFOAbstractType

field_1_lsid - Variable in class org.apache.poi.hwpf.model.types.LSTFAbstractType

field_1_nAuto - Variable in class org.apache.poi.hwpf.model.types.FRDAbstractType

field_1_precision - Variable in class org.apache.poi.hssf.record.PrecisionRecord

field_1_reserved1 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_1_rgf - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_1_spid - Variable in class org.apache.poi.hwpf.model.types.FSPAAbstractType

field_1_value - Variable in class org.apache.poi.hwpf.model.types.SHD80AbstractType

field_1_value - Variable in class org.apache.poi.hwpf.model.types.TBDAbstractType

field_1_wIdent - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_20_bpp - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_20_brcTop - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_20_brcTop - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_20_cCh - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_20_fBiDi - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_20_fBrLnAbove - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_20_hresi - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_20_reserved12 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_21_brcLeft - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_21_brcLeft - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_21_brcTop80 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_21_cPg - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_21_fBrLnBelow - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_21_fRTL - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_21_hpsKern - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_21_reserved13 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_22_brcBottom - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_22_brcBottom - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_22_brcLeft80 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_22_cParas - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_22_fNoAllowOverlap - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_22_hpsPos - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_22_pcVert - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_22_reserved14 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_23_brcBottom80 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_23_brcRight - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_23_brcRight - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_23_Edn - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_23_fSpare - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_23_pcHorz - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_23_shd - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_24_brc - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_24_brcRight80 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_24_Edn1 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_24_fPropMark - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_24_grpfTap - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_24_wr - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_25_cLines - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_25_dxaReserved3 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_25_fNoAutoHyph - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_25_ibstPropRMark - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_25_ibstRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_25_internalFlags - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_26_cWordsFtnEnd - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_26_dttmPropRMark - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_26_dyaHeight - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_26_dyaReserved3 - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_26_itcMac - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_26_sfxtText - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_27_cChFtnEdn - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_27_cProps - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_27_dxaAdjust - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_27_dxtCharSpace - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_27_fDblBdr - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_27_fMinHeight - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_28_cPgFtnEdn - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_28_dcs - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_28_dxaWebView - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_28_dyaLinePitch - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_28_fBorderWS - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_29_clm - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_29_cParasFtnEdn - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_29_dxaRTEWrapWidth - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_29_dyaFromText - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_29_ufel - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_2_bkf_flags - Variable in class org.apache.poi.hwpf.model.types.BKFAbstractType

field_2_cbHeader - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_2_cbSTDBaseInFile - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_2_chHres - Variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

field_2_cvBack - Variable in class org.apache.poi.hwpf.model.types.SHDAbstractType

field_2_flags - Variable in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

field_2_flt - Variable in class org.apache.poi.hwpf.model.types.FLDAbstractType

field_2_fSideBySide - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_2_fTitlePage - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_2_hps - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_2_info2 - Variable in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

field_2_jc - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_2_nfc - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_2_nFib - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_2_reserved1 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Deprecated.
field_2_reserved1 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_2_reserved1 - Variable in class org.apache.poi.hwpf.model.types.LFOAbstractType

field_2_reserved2 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_2_rsid - Variable in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

field_2_tlp_flags - Variable in class org.apache.poi.hwpf.model.types.TLPAbstractType

field_2_tplc - Variable in class org.apache.poi.hwpf.model.types.LSTFAbstractType

field_2_unused2 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_2_wWidth - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_2_xaLeft - Variable in class org.apache.poi.hwpf.model.types.FSPAAbstractType

field_30_cLinesFtnEdn - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_30_copt - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_30_dxaColWidthWwd - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_30_dxaFromText - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_30_unused2 - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_31_dmOrientPage - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_31_fLocked - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_31_hpsAsci - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_31_lKeyProtDoc - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_31_pctWwd - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_32_fWidowControl - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_32_hpsFE - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_32_iHeadingPgn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_32_view - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_32_viewFlags - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_33_docinfo4 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_33_fKinsoku - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_33_hpsBi - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_33_pgnStart - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_33_rgdxaCenter - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_34_adt - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_34_ftcSym - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_34_fWordWrap - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_34_lnnMin - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_34_rgdxaCenterPrint - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_35_doptypography - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_35_fOverflowPunct - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_35_shdTable - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_35_wTextFlow - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_35_xchSym - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_36_brcBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_36_dogrid - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_36_fcPic - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_36_fTopLinePunct - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_36_unused3 - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_37_brcTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_37_docinfo5 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_37_fAutoSpaceDE - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_37_fcObj - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_37_pgbProp - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_38_brcLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_38_docinfo6 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_38_fAutoSpaceDN - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_38_lTagObj - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_38_unused4 - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_39_asumyi - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_39_brcRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_39_fcData - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_39_wAlignFont - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_39_xaPage - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_3_dxaGapHalf - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_3_fAutoPgn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_3_fKeep - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_3_footnoteInfo - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_3_ftcAscii - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_3_info - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_3_info3 - Variable in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

field_3_info3 - Variable in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

field_3_info3 - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_3_ipat - Variable in class org.apache.poi.hwpf.model.types.SHDAbstractType

field_3_mm - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_3_reserved2 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Deprecated.
field_3_reserved2 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_3_reserved2 - Variable in class org.apache.poi.hwpf.model.types.LFOAbstractType

field_3_reserved3 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_3_rgistdPara - Variable in class org.apache.poi.hwpf.model.types.LSTFAbstractType

field_3_shd - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_3_unused - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_3_yaTop - Variable in class org.apache.poi.hwpf.model.types.FSPAAbstractType

field_40_brcVertical - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_40_cChWS - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_40_fontAlign - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_40_hresiOld - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_40_yaPage - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_41_brcHorizontal - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_41_cChWSFtnEdn - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_41_ibstRMarkDel - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_41_lvl - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_41_xaPageNUp - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_42_dttmRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_42_fBiDi - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_42_grfDocEvents - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_42_wCellPaddingDefaultTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_42_yaPageNUp - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_43_dttmRMarkDel - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_43_dxaLeft - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_43_fNumRMIns - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_43_virusinfo - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_43_wCellPaddingDefaultLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_44_dxaRight - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_44_fCrLf - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_44_istd - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_44_Spare - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_44_wCellPaddingDefaultBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_45_dyaTop - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_45_fUsePgsuSettings - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_45_idslRMReason - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_45_reserved1 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_45_wCellPaddingDefaultRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_46_dyaBottom - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_46_fAdjustRight - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_46_ftsCellPaddingDefaultTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_46_idslReasonDel - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_46_reserved2 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_47_cDBC - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_47_cpg - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_47_dzaGutter - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_47_ftsCellPaddingDefaultLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_47_itap - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_48_cDBCFtnEdn - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_48_dyaHdrTop - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_48_fInnerTableCell - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_48_ftsCellPaddingDefaultBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_48_Highlight - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_49_CharsetFlags - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_49_dyaHdrBottom - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_49_fOpenTch - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_49_ftsCellPaddingDefaultRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_49_reserved - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_4_bchUpe - Variable in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

field_4_ccpText - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_4_clfolvl - Variable in class org.apache.poi.hwpf.model.types.LFOAbstractType

field_4_dyaRowHeight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_4_fKeepFollow - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_4_flags - Variable in class org.apache.poi.hwpf.model.types.LSTFAbstractType

field_4_fOutlineDirtySave - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_4_ftcFE - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_4_lid - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_4_nfcPgn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_4_reserved3 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Deprecated.
field_4_reserved4 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_4_rgbxchNums - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_4_stiMaxWhenSaved - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_4_wCellPaddingLeft - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_4_xaRight - Variable in class org.apache.poi.hwpf.model.types.FSPAAbstractType

field_4_xExt - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_50_ccolM1 - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_50_chse - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_50_fTtpEmbedded - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_50_nfcFtnRef - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_50_wCellSpacingDefaultTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_51_dxcRight - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_51_fEvenlySpaced - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_51_fPropRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_51_nfcEdnRef - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_51_wCellSpacingDefaultLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_52_dxcLeft - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_52_hpsZoonFontPag - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_52_ibstPropRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_52_unused5 - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_52_wCellSpacingDefaultBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_53_dttmPropRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_53_dxaColumns - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_53_dxcLeft1 - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_53_dywDispPag - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_53_wCellSpacingDefaultRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_54_fConflictOrig - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_54_fDyaBeforeAuto - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_54_ftsCellSpacingDefaultTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_54_rgdxaColumn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_55_dxaColumnWidth - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_55_fConflictOtherDel - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_55_fDyaAfterAuto - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_55_ftsCellSpacingDefaultLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_56_dmOrientFirst - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_56_dxaRight - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_56_ftsCellSpacingDefaultBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_56_wConflict - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_57_dxaLeft - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_57_fLayout - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_57_ftsCellSpacingDefaultRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_57_IbstConflict - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_58_dttmConflict - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_58_dxaLeft1 - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_58_unused6 - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_58_wCellPaddingOuterTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_59_fDispFldRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_59_jc - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_59_olstAnm - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_59_wCellPaddingOuterLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_5_ccpFtn - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_5_docinfo - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_5_fCantSplit - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_5_fPageBreakBefore - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_5_ftcOther - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_5_fUnlocked - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_5_grfhic - Variable in class org.apache.poi.hwpf.model.types.LSTFAbstractType

field_5_grfstd - Variable in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

field_5_ibstFltAutoNum - Variable in class org.apache.poi.hwpf.model.types.LFOAbstractType

field_5_istdMaxFixedWhenSaved - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_5_ixchFollow - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_5_pnNext - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_5_reserved4 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Deprecated.
field_5_reserved5 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_5_wCellPaddingTop - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_5_yaBottom - Variable in class org.apache.poi.hwpf.model.types.FSPAAbstractType

field_5_yExt - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_60_brcTop - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_60_ibstDispFldRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_60_wCellPaddingOuterBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_61_brcLeft - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_61_dttmDispFldRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_61_wCellPaddingOuterRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_62_brcBottom - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_62_ftsCellPaddingOuterTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_62_xstDispFldRMark - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_63_brcRight - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_63_fcObjp - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_63_ftsCellPaddingOuterLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_64_brcBetween - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_64_ftsCellPaddingOuterBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_64_lbrCRJ - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_65_brcBar - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_65_fSpecVanish - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_65_ftsCellPaddingOuterRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_66_fHasOldProps - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_66_shd - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_66_wCellSpacingOuterTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_67_anld - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_67_fSdtVanish - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_67_wCellSpacingOuterLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_68_phe - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_68_wCellSpacingOuterBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_68_wCharScale - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_69_fPropRMark - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_69_wCellSpacingOuterRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_6_brcl - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_6_ccpHdd - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_6_ccpText - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_6_cnsPgn - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_6_docinfo1 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_6_dxaIndentSav - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_6_fCantSplit90 - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_6_flags - Variable in class org.apache.poi.hwpf.model.types.FSPAAbstractType

field_6_flags1 - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_6_ftcBi - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_6_grfhic - Variable in class org.apache.poi.hwpf.model.types.LFOAbstractType

field_6_nVerBuiltInNamesWhenSaved - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_6_reserved6 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_6_swHMF - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_6_wCellPaddingBottom - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_70_ftsCellSpacingOuterTop - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_70_ibstPropRMark - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_71_dttmPropRMark - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_71_ftsCellSpacingOuterLeft - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_72_ftsCellSpacingOuterBottom - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_72_itbdMac - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_73_ftsCellSpacingOuterRight - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_73_rgdxaTab - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_74_rgtbd - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_74_rgtc - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_75_numrm - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_75_rgshd - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_76_fPropRMark - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_76_ptap - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_77_fHasOldProps - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_77_fNoAllowOverlap - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_78_cHorzBands - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_78_ipgp - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_79_cVertBands - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_79_rsid - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_7_brcp - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_7_ccpFtn - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_7_cTxbx - Variable in class org.apache.poi.hwpf.model.types.FSPAAbstractType

field_7_docinfo2 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_7_dxaSpace - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_7_fPgnRestart - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_7_fTableHeader - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_7_ftcAsci - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_7_grf - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_7_nFibBack - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_7_reserved3 - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Deprecated.
field_7_reserved3 - Variable in class org.apache.poi.hwpf.model.types.LFOAbstractType

field_7_reserved7 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_7_unused2 - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_7_wCellPaddingRight - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_80_rgbrcInsideDefault_0 - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_81_rgbrcInsideDefault_1 - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_8_cbGrpprlChpx - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_8_ccpAtn - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_8_ccpHdd - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_8_cv - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_8_docinfo3 - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_8_fEndNote - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_8_ftcFE - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_8_ftsCellPaddingLeft - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_8_ilvl - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_8_lKey - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

field_8_padding - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_8_reserved8 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_8_tlp - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

field_9_cbGrpprlPapx - Variable in class org.apache.poi.hwpf.model.types.LVLFAbstractType

field_9_ccpEdn - Variable in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

field_9_ccpMcr - Variable in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

field_9_dxaTab - Variable in class org.apache.poi.hwpf.model.types.DOPAbstractType

field_9_envr - Variable in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated.
field_9_ftcOther - Variable in class org.apache.poi.hwpf.model.types.StshifAbstractType

field_9_ftsCellPaddingTop - Variable in class org.apache.poi.hwpf.model.types.TCAbstractType

field_9_ico - Variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

field_9_ilfo - Variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

field_9_lnc - Variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

field_9_mmPM - Variable in class org.apache.poi.hwpf.model.types.PICFAbstractType

field_9_reserved9 - Variable in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Deprecated.
field_9_wWidth - Variable in class org.apache.poi.hwpf.model.types.TAPAbstractType

FIELD_BEGIN_MARK - Static variable in class org.apache.poi.hwpf.model.FieldDescriptor

FIELD_END_MARK - Static variable in class org.apache.poi.hwpf.model.FieldDescriptor

field_pictureData - Variable in class org.apache.poi.ddf.EscherBlipRecord

FIELD_SEPARATOR_MARK - Static variable in class org.apache.poi.hwpf.model.FieldDescriptor

FieldDescriptor - Class in org.apache.poi.hwpf.model
Class for the FLD structure.
FieldDescriptor(byte[]) - Constructor for class org.apache.poi.hwpf.model.FieldDescriptor

FieldIterator - Class in org.apache.poi.hwpf.dev
For iterating through our fields.
FieldIterator() - Constructor for class org.apache.poi.hwpf.dev.FieldIterator

Fields - Interface in org.apache.poi.hwpf.usermodel
User-friendly interface to access document Fields
FieldsDocumentPart - Enum in org.apache.poi.hwpf.model

FieldsImpl - Class in org.apache.poi.hwpf.usermodel
Default implementation of Field
FieldsImpl(FieldsTables) - Constructor for class org.apache.poi.hwpf.usermodel.FieldsImpl

FieldsTables - Class in org.apache.poi.hwpf.model
This class provides access to all the fields Plex.
FieldsTables(byte[], FileInformationBlock) - Constructor for class org.apache.poi.hwpf.model.FieldsTables

file() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

FileBackedDataSource - Class in org.apache.poi.poifs.nio
A POIFS DataSource backed by a File
FileBackedDataSource(File) - Constructor for class org.apache.poi.poifs.nio.FileBackedDataSource

FileBackedDataSource(FileChannel) - Constructor for class org.apache.poi.poifs.nio.FileBackedDataSource

FileHelper - Class in org.apache.poi.openxml4j.opc.internal
Provide useful method to manage file.
FileHelper() - Constructor for class org.apache.poi.openxml4j.opc.internal.FileHelper

FileInformationBlock - Class in org.apache.poi.hwpf.model
The File Information Block (FIB).
FileInformationBlock(byte[]) - Constructor for class org.apache.poi.hwpf.model.FileInformationBlock
Creates a new instance of FileInformationBlock
FilePassRecord - Class in org.apache.poi.hssf.record
Title: File Pass Record (0x002F)
Description: Indicates that the record after this record are encrypted.
FilePassRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FilePassRecord

FileSharingRecord - Class in org.apache.poi.hssf.record
Title: FILESHARING (0x005B)
Description: stores the encrypted readonly for a workbook (write protect) This functionality is accessed from the options dialog box available when performing 'Save As'.
REFERENCE: PG 314 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

FileSharingRecord() - Constructor for class org.apache.poi.hssf.record.FileSharingRecord

FileSharingRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FileSharingRecord

filetimeToDate(int, int) - Static method in class org.apache.poi.hpsf.Util
Converts a Windows FILETIME into a Date.
filetimeToDate(long) - Static method in class org.apache.poi.hpsf.Util
Converts a Windows FILETIME into a Date.
Fill - Interface in org.apache.poi.common.usermodel

Fill - Class in org.apache.poi.hslf.model
Represents functionality provided by the 'Fill Effects' dialog in PowerPoint.
Fill(Shape) - Constructor for class org.apache.poi.hslf.model.Fill
Construct a Fill object for a shape.
fill(Shape) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Fills the interior of a Shape using the settings of the Graphics2D context.
FILL - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

fill(Shape) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

fill(Shape) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

fill(List<CHPX>) - Method in class org.apache.poi.hwpf.model.CHPFormattedDiskPage

fill(List<PAPX>) - Method in class org.apache.poi.hwpf.model.PAPFormattedDiskPage
Fills the queue for writing.
fill(POIFSBigBlockSize, List) - Static method in class org.apache.poi.poifs.storage.SmallDocumentBlock
fill out a List of SmallDocumentBlocks so that it fully occupies a set of big blocks
Fill - Interface in org.apache.poi.sl.usermodel

fill(Graphics2D, Shape) - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

fill3DRect(int, int, int, int, boolean) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

FILL__ANGLE - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__BACKOPACITY - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__BLIPFILENAME - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__BLIPFLAGS - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__CRMOD - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__DZTYPE - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__FILLBACKCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__FILLCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__FILLED - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__FILLOPACITY - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__FILLTYPE - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__FOCUS - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__HEIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__HITTESTFILL - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__NOFILLHITTEST - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__ORIGINX - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__ORIGINY - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__PATTERNTEXTURE - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__RECTBOTTOM - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__RECTLEFT - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__RECTRIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__RECTTOP - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__SHADECOLORS - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__SHADEPRESET - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__SHADETYPE - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__SHAPE - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__SHAPEORIGINX - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__SHAPEORIGINY - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__TOBOTTOM - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__TOLEFT - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__TORIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__TOTOP - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__USERECT - Static variable in class org.apache.poi.ddf.EscherProperties

FILL__WIDTH - Static variable in class org.apache.poi.ddf.EscherProperties

FILL_BACKGROUND - Static variable in class org.apache.poi.hslf.model.Fill
Use the background fill color/pattern
FILL_BACKGROUND_COLOR - Static variable in class org.apache.poi.ss.util.CellUtil

FILL_FOREGROUND_COLOR - Static variable in class org.apache.poi.ss.util.CellUtil

FILL_PATTERN - Static variable in class org.apache.poi.hslf.model.Fill
Fill with a pattern (bitmap)
FILL_PATTERN - Static variable in class org.apache.poi.ss.util.CellUtil

FILL_PICTURE - Static variable in class org.apache.poi.hslf.model.Fill
Center a picture in the shape
FILL_SHADE - Static variable in class org.apache.poi.hslf.model.Fill
Shade from start to end points
FILL_SHADE_CENTER - Static variable in class org.apache.poi.hslf.model.Fill
Shade from bounding rectangle to end point
FILL_SHADE_SCALE - Static variable in class org.apache.poi.hslf.model.Fill
Similar to FILL_SHADE, but the fill angle is additionally scaled by the aspect ratio of the shape.
FILL_SHADE_SHAPE - Static variable in class org.apache.poi.hslf.model.Fill
Shade from shape outline to end point
FILL_SHADE_TITLE - Static variable in class org.apache.poi.hslf.model.Fill
shade to title
FILL_SOLID - Static variable in class org.apache.poi.hslf.model.Fill
Fill with a solid color
FILL_TEXTURE - Static variable in class org.apache.poi.hslf.model.Fill
A texture (pattern with its own color map)
fillArc(int, int, int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Fills a circular or elliptical arc covering the specified rectangle.
fillArc(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

fillArc(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

fillArc(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

fillCache(Object) - Method in class org.apache.poi.hwpf.model.CachedPropertyNode

fillChart(Chart, ChartAxis...) - Method in interface org.apache.poi.ss.usermodel.charts.ChartData
Fills a charts with data specified by implementation.
fillChart(Chart, ChartAxis...) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData

fillDecoder(String, String) - Method in class org.apache.poi.hwpf.dev.FieldIterator

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.AbstractEscherOptRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherBitmapBlip

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherBlipRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherBSERecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherChildAnchorRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherClientDataRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherContainerRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherDggRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherDgRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherMetafileBlip

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherPictBlip

fillFields(byte[], EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherRecord
Delegates to fillFields(byte[], int, EscherRecordFactory)
fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherRecord
The contract of this method is to deserialize an escher record including it's children.
fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherSpgrRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherSpRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.EscherTextboxRecord

fillFields(byte[], int, EscherRecordFactory) - Method in class org.apache.poi.ddf.UnknownEscherRecord

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FRDAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.HRESIAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType

fillFields(byte[], int) - Method in class org.apache.poi.hwpf.usermodel.TableCellDescriptor

fillOval(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Fills an oval bounded by the specified rectangle with the current color.
fillOval(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

fillOval(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

fillOval(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

FillPatternType - Enum in org.apache.poi.ss.usermodel
The enumeration value indicating the style of fill pattern being used for a cell format.
fillPolygon(int[], int[], int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Fills a closed polygon defined by arrays of x and y coordinates.
fillPolygon(Polygon) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

fillPolygon(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

fillPolygon(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics
Fills a (closed) polygon, as defined by a pair of arrays, which hold the x and y coordinates.
fillPolygon(int[], int[], int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d
Fills a (closed) polygon, as defined by a pair of arrays, which hold the x and y coordinates.
fillRect(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Fills the specified rectangle.
fillRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

fillRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

fillRect(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

fillRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Fills the specified rounded corner rectangle with the current color.
fillRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

fillRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

fillRoundRect(int, int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

fillVariableFields(byte[], byte[]) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

filter - Variable in class org.apache.poi.hslf.blip.Metafile.Header
Reserved.
FILTERING_HOOKS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FilteringDirectoryNode - Class in org.apache.poi.poifs.filesystem
A DirectoryEntry filter, which exposes another DirectoryEntry less certain parts.
FilteringDirectoryNode(DirectoryEntry, Collection<String>) - Constructor for class org.apache.poi.poifs.filesystem.FilteringDirectoryNode
Creates a filter round the specified directory, which will exclude entries such as "MyNode" and "MyDir/IgnoreNode".
finalize() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

finalize() - Method in class org.apache.poi.xssf.streaming.SheetDataWriter

FinanceFunction - Class in org.apache.poi.ss.formula.functions

FinanceFunction() - Constructor for class org.apache.poi.ss.formula.functions.FinanceFunction

FinanceLib - Class in org.apache.poi.ss.formula.functions

find(TextRun) - Static method in class org.apache.poi.hslf.model.Hyperlink
Find hyperlinks in a text run
find(Shape) - Static method in class org.apache.poi.hslf.model.Hyperlink
Find hyperlink assigned to the supplied shape
find(Document) - Static method in class org.apache.poi.hslf.usermodel.SoundData
Find all sound records in the supplied Document records
FIND - Static variable in class org.apache.poi.ss.formula.functions.TextFunction
Implementation of the FIND() function.
Syntax:
FIND(find_text, within_text, start_num)
FIND returns the character position of the first (case sensitive) occurrence of find_text inside within_text.
findAuthor(String) - Method in class org.apache.poi.xssf.model.CommentsTable

findByName(String) - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection
Fetch the TextProp with this name, or null if it isn't present
findCellComment(InternalSheet, int, int) - Static method in class org.apache.poi.hssf.usermodel.HSSFCell
Cell comment finder.
findCellComment(String) - Method in class org.apache.poi.xssf.model.CommentsTable

findChildRecords(byte[], int, int) - Static method in class org.apache.poi.hslf.record.Record
Default method for finding child records of a container record
findChildren(byte[]) - Method in class org.apache.poi.hdgf.streams.PointerContainingStream
Performs a recursive search, identifying the pointers we contain, creating the Streams for where they point to, then searching those if appropriate.
findChunks() - Method in class org.apache.poi.hdgf.streams.ChunkStream
Process the contents of the stream out into chunks
findColor(byte, byte, byte) - Method in class org.apache.poi.hssf.usermodel.HSSFPalette
Finds the first occurance of a given color
findColumnInfo(int) - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate
Finds the ColumnInfoRecord which contains the specified columnIndex
findCommentShape(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFVMLDrawing
Find a shape with ClientData of type "NOTE" and the specified row and column
findDrawingGroup() - Method in class org.apache.poi.hssf.model.InternalWorkbook
Finds the primary drawing group, if one already exists
findEndOfRowOutlineGroup(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

findEndOfRowOutlineGroup(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

FINDER_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

findFirstOfType(long) - Method in class org.apache.poi.hslf.record.RecordContainer
Finds the first child record of the given type, or null if none of the child records are of the given type.
findFirstRecordBySid(short) - Method in class org.apache.poi.hssf.model.InternalSheet
Returns the first occurrence of a record matching a particular sid.
findFirstRecordBySid(short) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns the first occurance of a record matching a particular sid.
findFirstRecordLocBySid(short) - Method in class org.apache.poi.hssf.model.InternalSheet
Finds the first occurrence of a record matching a particular sid and returns it's position.
findFirstRecordLocBySid(short) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns the index of a record matching a particular sid.
findFirstWithId(short) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord
Descends into all our children, returning the first EscherRecord with the given id, or null if none found
findFirstWithId(short) - Method in class org.apache.poi.hwpf.model.EscherRecordHolder
Descends into all our children, returning the first EscherRecord with the given id, or null if none found
findFont(short, short, short, String, boolean, boolean, short, byte) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Finds a font that matches the one with the supplied attributes
findFont(short, short, short, String, boolean, boolean, short, byte) - Method in interface org.apache.poi.ss.usermodel.Workbook
Finds a font that matches the one with the supplied attributes
findFont(short, short, short, String, boolean, boolean, short, byte) - Method in class org.apache.poi.xssf.model.StylesTable
Finds a font that matches the one with the supplied attributes
findFont(short, short, short, String, boolean, boolean, short, byte) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Finds a font that matches the one with the supplied attributes
findFont(short, short, short, String, boolean, boolean, short, byte) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Finds a font that matches the one with the supplied attributes
findFunction(String) - Method in class org.apache.poi.ss.formula.atp.AnalysisToolPak

findFunction(String) - Method in class org.apache.poi.ss.formula.udf.AggregatingUDFFinder
Returns executor by specified name.
findFunction(String) - Method in class org.apache.poi.ss.formula.udf.DefaultUDFFinder

findFunction(String) - Method in interface org.apache.poi.ss.formula.udf.UDFFinder
Returns executor by specified name.
findFunction(String) - Method in class org.apache.poi.xssf.model.IndexedUDFFinder

findMatchingType(byte[]) - Static method in enum org.apache.poi.hwpf.usermodel.PictureType

findNextRecordBySid(short, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns the next occurance of a record matching a particular sid.
findObjectRecord() - Method in class org.apache.poi.hssf.usermodel.HSSFObjectData
Finds the EmbeddedObjectRefSubRecord, or throws an Exception if there wasn't one
findRecordAtPos(int) - Static method in class org.apache.poi.hslf.dev.SlideIdListing

findRecordAtPos(int) - Static method in class org.apache.poi.hslf.dev.UserEditAndPersistListing

findRefIndexFromExtBookIndex(int) - Method in class org.apache.poi.hssf.record.ExternSheetRecord

findSheetNameFromExternSheet(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
finds the sheet name by his extern sheet index
findSheetNameFromExternSheet(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.
findSimilarColor(byte, byte, byte) - Method in class org.apache.poi.hssf.usermodel.HSSFPalette
Finds the closest matching color in the custom palette.
findSimilarColor(int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFPalette
Finds the closest matching color in the custom palette.
findSprm(short) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

findStartOfRowOutlineGroup(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

findTextRecords(int, Vector<String>) - Method in class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
For the given position, look if the record is a text record, and wind on after.
findTextRuns(PPDrawing) - Static method in class org.apache.poi.hslf.model.Sheet
For a given PPDrawing, grab all the TextRuns
findTextRuns(Record[], List<TextRun>) - Static method in class org.apache.poi.hslf.model.Sheet
Scans through the supplied record array, looking for a TextHeaderAtom followed by one of a TextBytesAtom or a TextCharsAtom.
findUserDefinedFunction(String) - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

findUserDefinedFunction(String) - Method in class org.apache.poi.ss.formula.WorkbookEvaluator

FINE_DOTS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Small fine dots
FINE_DOTS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

FINE_DOTS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Small fine dots
FINE_DOTS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Small fine dots
FIRST - Static variable in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

FIRST_COLOR_INDEX - Static variable in class org.apache.poi.hssf.record.PaletteRecord
The byte index of the first color
FIRST_CUSTOM_STYLE_ID - Static variable in class org.apache.poi.xssf.model.StylesTable
The first style id available for use as a custom style
FIRST_USER_DEFINED_FORMAT_INDEX - Static variable in class org.apache.poi.ss.usermodel.BuiltinFormats
The first user-defined format starts at 164.
firstSubrange(Range) - Method in interface org.apache.poi.hwpf.usermodel.Field

Fixed0ArgFunction - Class in org.apache.poi.ss.formula.functions
Convenience base class for functions that only take zero arguments.
Fixed0ArgFunction() - Constructor for class org.apache.poi.ss.formula.functions.Fixed0ArgFunction

Fixed1ArgFunction - Class in org.apache.poi.ss.formula.functions
Convenience base class for functions that must take exactly one argument.
Fixed1ArgFunction() - Constructor for class org.apache.poi.ss.formula.functions.Fixed1ArgFunction

Fixed2ArgFunction - Class in org.apache.poi.ss.formula.functions
Convenience base class for functions that must take exactly two arguments.
Fixed2ArgFunction() - Constructor for class org.apache.poi.ss.formula.functions.Fixed2ArgFunction

Fixed3ArgFunction - Class in org.apache.poi.ss.formula.functions
Convenience base class for functions that must take exactly three arguments.
Fixed3ArgFunction() - Constructor for class org.apache.poi.ss.formula.functions.Fixed3ArgFunction

Fixed4ArgFunction - Class in org.apache.poi.ss.formula.functions
Convenience base class for functions that must take exactly four arguments.
Fixed4ArgFunction() - Constructor for class org.apache.poi.ss.formula.functions.Fixed4ArgFunction

FIXED_PITCH - Static variable in class org.apache.poi.hslf.model.PPFont

FixedField - Interface in org.apache.poi.util
behavior of a field at a fixed location within a byte array
FLAG_BACKGROUND - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_CHILD - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_CONNECTOR - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_DELETED - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_FLIPHORIZ - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_FLIPVERT - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_GROUP - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_HASSHAPETYPE - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_HAVEANCHOR - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_HAVEMASTER - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_OLESHAPE - Static variable in class org.apache.poi.ddf.EscherSpRecord

FLAG_PATRIARCH - Static variable in class org.apache.poi.ddf.EscherSpRecord

flags - Variable in class org.apache.poi.hslf.model.PPFont

FLDAbstractType - Class in org.apache.poi.hwpf.model.types
Field Descriptor (FLD).
FLDAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.FLDAbstractType

FLOAT - Static variable in class org.apache.poi.hsmf.datatypes.Types
R4 - 4-byte floating point value
fLoop - Static variable in class org.apache.poi.hslf.record.ExMediaAtom
A bit that specifies whether the audio or video data is repeated continuously during playback.
FLOOR - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

FLOW_CHART_ALTERNATE_PROCESS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_COLLATE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_CONNECTOR - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_DECISION - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_DELAY - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_DISPLAY - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_DOCUMENT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_EXTRACT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_INPUT_OUTPUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_INTERNAL_STORAGE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_MAGNETIC_DISK - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_MAGNETIC_DRUM - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_MAGNETIC_TAPE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_MANUAL_INPUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_MANUAL_OPERATION - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_MERGE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_MULTIDOCUMENT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_OFFLINE_STORAGE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_OFFPAGE_CONNECTOR - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_ONLINE_STORAGE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_OR - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_PREDEFINED_PROCESS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_PREPARATION - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_PROCESS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_PUNCHED_CARD - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_PUNCHED_TAPE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_SORT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_SUMMING_JUNCTION - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FLOW_CHART_TERMINATOR - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FlowChartAlternateProcess - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartCollate - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartConnector - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartDecision - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartDelay - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartDisplay - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartDocument - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartExtract - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartInputOutput - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartInternalStorage - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartMagneticDisk - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartMagneticDrum - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartMagneticTape - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartManualInput - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartManualOperation - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartMerge - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartMultidocument - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartOfflineStorage - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartOffpageConnector - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartOnlineStorage - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartOr - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartPredefinedProcess - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartPreparation - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartProcess - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartPunchedCard - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartPunchedTape - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartSort - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartSummingJunction - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FlowChartTerminator - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

flush() - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

flush() - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream
Flush this output stream.
flush() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

flush() - Method in class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

flush() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Flush the package : save all.
flush() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Flush the content of this part.
flush() - Method in class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

flush() - Method in class org.apache.poi.openxml4j.opc.ZipPackagePart

flush() - Method in class org.apache.poi.poifs.filesystem.DocumentOutputStream
Flushes this output stream and forces any buffered output bytes to be written out.
flushImpl() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Flush the package but not save.
flushImpl() - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Flush the package.
flushRows(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Specifies how many rows can be accessed at most via getRow().
flushRows() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flush all rows to disk.
FMINHEIGHT_AT_LEAST - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

FMINHEIGHT_EXACT - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

fNarration - Static variable in class org.apache.poi.hslf.record.ExMediaAtom
A bit that specifies whether the audio data is recorded narration for the slide show.
FnGroupCountRecord - Class in org.apache.poi.hssf.record
Title: Function Group Count Record
FnGroupCountRecord() - Constructor for class org.apache.poi.hssf.record.FnGroupCountRecord

FnGroupCountRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FnGroupCountRecord

FoDocumentFacade - Class in org.apache.poi.hwpf.converter

FoDocumentFacade(Document) - Constructor for class org.apache.poi.hwpf.converter.FoDocumentFacade

foDocumentFacade - Variable in class org.apache.poi.hwpf.converter.WordToFoConverter

FOLDED_CORNER - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FoldedCorner - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

FOLDER_ASSOCIATED_CONTENTS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FOLDER_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FOLIO8_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
Folio 8 1/2 x 13 in
FOLLOWS_ENTIRE_COLOR_SCHEME - Static variable in class org.apache.poi.hslf.record.ExEmbedAtom
Embedded document follows the entire color scheme.
FOLLOWS_TEXT_AND_BACKGROUND_SCHEME - Static variable in class org.apache.poi.hslf.record.ExEmbedAtom
Embedded document follows the text and background scheme.
font(String, String) - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

Font - Interface in org.apache.poi.ss.usermodel

FONT - Static variable in class org.apache.poi.ss.util.CellUtil

FONT_ARIAL - Static variable in class org.apache.poi.hssf.usermodel.HSSFFont
Arial font
FONT_CELL_HEIGHT_PRESERVED - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting

FONT_HANDLER - Static variable in class org.apache.poi.xslf.usermodel.XSLFRenderingHint
Use this object to resolve unknown / missing fonts when rendering slides
FONT_TABLE - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

FontBasisRecord - Class in org.apache.poi.hssf.record.chart
The font basis record stores various font metrics.

FontBasisRecord() - Constructor for class org.apache.poi.hssf.record.chart.FontBasisRecord

FontBasisRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.FontBasisRecord

FontCharset - Enum in org.apache.poi.ss.usermodel
Charset represents the basic set of characters associated with a font (that it can display), and corresponds to the ANSI codepage (8-bit or DBCS) of that character set used by a given language.
FontCollection - Class in org.apache.poi.hslf.record
FontCollection ia a container that holds information about all the fonts in the presentation.
FontCollection(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.FontCollection

FontCollection - Static variable in class org.apache.poi.hslf.record.RecordTypes

FontCollection - Interface in org.apache.poi.sl.usermodel

FontDetails - Class in org.apache.poi.hssf.usermodel
Stores width and height details about a font.
FontDetails(String, int) - Constructor for class org.apache.poi.hssf.usermodel.FontDetails
Construct the font details with the given name and height.
FontEmbeddedData - Static variable in class org.apache.poi.hslf.record.RecordTypes

FontEntityAtom - Class in org.apache.poi.hslf.record
This atom corresponds exactly to a Windows Logical Font (LOGFONT) structure.
FontEntityAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.FontEntityAtom
Build an instance of FontEntityAtom from on-disk data
FontEntityAtom() - Constructor for class org.apache.poi.hslf.record.FontEntityAtom
Create a new instance of FontEntityAtom
FontEntityAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

FontFamily - Enum in org.apache.poi.ss.usermodel
The font family this font belongs to.
FontFormatting - Class in org.apache.poi.hssf.record.cf
Font Formatting Block of the Conditional Formatting Rule Record.
FontFormatting() - Constructor for class org.apache.poi.hssf.record.cf.FontFormatting

FontFormatting(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.cf.FontFormatting
Creates new FontFormatting
FontFormatting - Interface in org.apache.poi.ss.usermodel
High level representation for Font Formatting component of Conditional Formatting settings
FontIndexRecord - Class in org.apache.poi.hssf.record.chart
The font index record indexes into the font table for the text record.

FontIndexRecord() - Constructor for class org.apache.poi.hssf.record.chart.FontIndexRecord

FontIndexRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.FontIndexRecord

FontMetricsDumper - Class in org.apache.poi.util

FontMetricsDumper() - Constructor for class org.apache.poi.util.FontMetricsDumper

fontName - Variable in class org.apache.poi.hwpf.converter.FontReplacer.Triplet

FontRecord - Class in org.apache.poi.hssf.record
Title: Font Record (0x0031)
- describes a font in the workbook (index = 0-3,5-infinity - skip 4)
FontRecord() - Constructor for class org.apache.poi.hssf.record.FontRecord

FontRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FontRecord

FontReplacer - Interface in org.apache.poi.hwpf.converter

FontReplacer.Triplet - Class in org.apache.poi.hwpf.converter

FontReplacer.Triplet() - Constructor for class org.apache.poi.hwpf.converter.FontReplacer.Triplet

FontScheme - Enum in org.apache.poi.ss.usermodel
Defines the font scheme to which this font belongs.
fontSize(short) - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

FontTable - Class in org.apache.poi.hwpf.model
FontTable or in MS terminology sttbfffn is a common data structure written in all Word files.
FontTable(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.FontTable

FontUnderline - Enum in org.apache.poi.ss.usermodel
the different types of possible underline formatting
Footer - Interface in org.apache.poi.ss.usermodel
Common definition of a HSSF or XSSF page footer.
FOOTER - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

FOOTERATOM - Static variable in class org.apache.poi.hslf.record.HeadersFootersContainer

FooterMargin - Static variable in interface org.apache.poi.ss.usermodel.Sheet

FooterMCAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

FooterRecord - Class in org.apache.poi.hssf.record
Title: Footer Record (0x0015)
Description: Specifies the footer for a sheet
FooterRecord(String) - Constructor for class org.apache.poi.hssf.record.FooterRecord

FooterRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FooterRecord

footers - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

FOOTNOTE - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

FootnoteReferenceDescriptor - Class in org.apache.poi.hwpf.model

FootnoteReferenceDescriptor() - Constructor for class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

FootnoteReferenceDescriptor(byte[], int) - Constructor for class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

footnotes - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

forInt(byte) - Static method in enum org.apache.poi.ss.usermodel.FormulaError

ForkedEvaluator - Class in org.apache.poi.ss.formula.eval.forked
An alternative workbook evaluator that saves memory in situations where a single workbook is concurrently and independently evaluated many times.
FORM_CATEGORY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_CATEGORY_SUB - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_CLSID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_CONTACT_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_DESIGNER_GUID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_DESIGNER_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_HIDDEN - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_HOST_MAP - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_MESSAGE_BEHAVIOR - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FORM_VERSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

format - Variable in class org.apache.poi.hdgf.pointers.Pointer

format - Variable in class org.apache.poi.hpsf.PropertySet
Specifies this PropertySet's format.
format - Variable in class org.apache.poi.ss.format.CellFormatter
The original specified format.
format(Object) - Method in class org.apache.poi.ss.format.CellFormatter
Formats the value, returning the resulting string.
format(String) - Static method in class org.apache.poi.ss.formula.SheetNameFormatter
Used to format sheet names as they would appear in cell formula expressions.
format(Date, StringBuffer, FieldPosition) - Method in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

format(String, Object[]) - Static method in class org.apache.poi.util.StringUtil
Apply printf() like formatting to a string.
format2DRefAsString() - Method in interface org.apache.poi.ss.formula.ExternSheetReferenceToken

format2DRefAsString() - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

format2DRefAsString() - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

FORMAT_ID - Static variable in class org.apache.poi.POIXMLProperties.CustomProperties
Each custom property element contains an fmtid attribute with the same GUID value ({D5CDD505-2E9C-101B-9397-08002B2CF9AE}).
FORMAT_MASK - Static variable in class org.apache.poi.hssf.usermodel.HSSFPictureData

FORMAT_PAT - Static variable in class org.apache.poi.ss.format.CellFormatPart
Pattern for an entire cell single part.
formatAsString() - Method in class org.apache.poi.ss.usermodel.CellValue

formatAsString() - Method in class org.apache.poi.ss.util.AreaReference
Example return values:

Result
Comment A1:A1Single cell area reference without sheet A1:$C$1Multi-cell area reference without sheet Sheet1!A$1:B4Standard sheet name 'O''Brien''s Sales'!B5:C6' Sheet name with special characters
formatAsString() - Method in class org.apache.poi.ss.util.CellRangeAddress

formatAsString(String, boolean) - Method in class org.apache.poi.ss.util.CellRangeAddress

formatAsString() - Method in class org.apache.poi.ss.util.CellReference
Example return values:

Result
Comment A1Cell reference without sheet Sheet1!A1Standard sheet name 'O''Brien''s Sales'!A1' Sheet name with special characters
formatCellValue(Cell) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Returns the formatted value of a cell as a String regardless of the cell type.
formatCellValue(Cell, FormulaEvaluator) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Returns the formatted value of a cell as a String regardless of the cell type.
formatID - Variable in class org.apache.poi.hpsf.Section
The section's format ID, Section.getFormatID().
formatIterator() - Method in class org.apache.poi.hssf.record.common.UnicodeString

formatMatches(ColumnInfoRecord) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

formatNumberDateCell(CellValueRecordInterface) - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Formats the given numeric of date Cell's contents as a String, in as close as we can to the way that Excel would do so.
formatRawCellContents(double, int, String) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Formats the given raw cell value, based on the supplied format index and string, according to excel style rules.
formatRawCellContents(double, int, String, boolean) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Formats the given raw cell value, based on the supplied format index and string, according to excel style rules.
FormatRecord - Class in org.apache.poi.hssf.record
Title: Format Record (0x041E)
Description: describes a number format -- those goofy strings like $(#,###)
REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

FormatRecord(int, String) - Constructor for class org.apache.poi.hssf.record.FormatRecord

FormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FormatRecord

formatReferenceAsString() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

formatReferenceAsString() - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

FormattedDiskPage - Class in org.apache.poi.hwpf.model
Represents an FKP data structure.
FormattedDiskPage() - Constructor for class org.apache.poi.hwpf.model.FormattedDiskPage

FormattedDiskPage(byte[], int) - Constructor for class org.apache.poi.hwpf.model.FormattedDiskPage
Uses a 512-byte array to create a FKP
formatter - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

FormatTrackingHSSFListener - Class in org.apache.poi.hssf.eventusermodel
A proxy HSSFListener that keeps track of the document formatting records, and provides an easy way to look up the format strings used by cells from their ids.
FormatTrackingHSSFListener(HSSFListener) - Constructor for class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Creates a format tracking wrapper around the given listener, using the default locale for the formats.
FormatTrackingHSSFListener(HSSFListener, Locale) - Constructor for class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Creates a format tracking wrapper around the given listener, using the given locale for the formats.
formatValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellDateFormatter
Format a value according the format string.
formatValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellElapsedFormatter
Format a value according the format string.
formatValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellFormatter
Format a value according the format string.
formatValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellGeneralFormatter
The general style is not quite the same as any other, or any combination of others.
formatValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellNumberFormatter
Format a value according the format string.
formatValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellTextFormatter
Format a value according the format string.
FORMFLDSTTBS - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

Formula - Class in org.apache.poi.ss.formula
Encapsulates an encoded formula token array.
FORMULA - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
Formula ( 'Custom' ) type
Formula - Class in org.apache.poi.xslf.model.geom
A guide formula in DrawingML.
Formula() - Constructor for class org.apache.poi.xslf.model.geom.Formula

FormulaError - Enum in org.apache.poi.ss.usermodel
Enumerates error values in SpreadsheetML formula calculations.
FormulaEvaluator - Interface in org.apache.poi.ss.usermodel
Evaluates formula cells.
For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.
FormulaParseException - Exception in org.apache.poi.ss.formula
This exception thrown when a supplied formula has incorrect syntax (or syntax currently not supported by POI).
FormulaParser - Class in org.apache.poi.ss.formula
This class parses a formula string into a List of tokens in RPN order.
FormulaParsingWorkbook - Interface in org.apache.poi.ss.formula
Abstracts a workbook for the purpose of formula parsing.
For POI internal use only
FormulaRecord - Class in org.apache.poi.hssf.record
Formula Record (0x0006).
FormulaRecord() - Constructor for class org.apache.poi.hssf.record.FormulaRecord
Creates new FormulaRecord
FormulaRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.FormulaRecord

FormulaRecordAggregate - Class in org.apache.poi.hssf.record.aggregates
The formula record aggregate is used to join together the formula record and it's (optional) string record and (optional) Shared Formula Record (template reads, excel optimization).
FormulaRecordAggregate(FormulaRecord, StringRecord, SharedValueManager) - Constructor for class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

FormulaRenderer - Class in org.apache.poi.ss.formula
Common logic for rendering formulas.
For POI internal use only
FormulaRenderer() - Constructor for class org.apache.poi.ss.formula.FormulaRenderer

FormulaRenderingWorkbook - Interface in org.apache.poi.ss.formula
Abstracts a workbook for the purpose of converting formula to text.
For POI internal use only
FormulaShifter - Class in org.apache.poi.ss.formula

FormulaType - Class in org.apache.poi.ss.formula
Enumeration of various formula types.
For POI internal use only
FormulaViewer - Class in org.apache.poi.hssf.dev
FormulaViewer - finds formulas in a BIFF8 file and attempts to read them/display data from them.
FormulaViewer() - Constructor for class org.apache.poi.hssf.dev.FormulaViewer
Creates new FormulaViewer
forString(String) - Static method in enum org.apache.poi.ss.usermodel.FormulaError

FORWARD_SLASH_CHAR - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Forward slash URI separator.
FORWARD_SLASH_STRING - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Forward slash URI separator.
FOUR_OBJECTS - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

FRAME - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FrameRecord - Class in org.apache.poi.hssf.record.chart
The frame record indicates whether there is a border around the displayed text of a chart.

FrameRecord() - Constructor for class org.apache.poi.hssf.record.chart.FrameRecord

FrameRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.FrameRecord

FRDAbstractType - Class in org.apache.poi.hwpf.model.types
Footnote Reference Descriptor (FRD).
FRDAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.FRDAbstractType

free() - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream
Frees all blocks in the stream
Freeform - Class in org.apache.poi.hslf.model
A "Freeform" shape.
Freeform(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Freeform
Create a Freeform object and initialize it from the supplied Record container.
Freeform(Shape) - Constructor for class org.apache.poi.hslf.model.Freeform
Create a new Freeform.
Freeform() - Constructor for class org.apache.poi.hslf.model.Freeform
Create a new Freeform.
FreeRefFunction - Interface in org.apache.poi.ss.formula.functions
For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed.
fRewind - Static variable in class org.apache.poi.hslf.record.ExMediaAtom
A bit that specifies whether the audio or video data is rewound after playing.
fromArray(T[]) - Static method in class org.apache.poi.ss.usermodel.charts.DataSources

fromByte(byte) - Static method in class org.apache.poi.util.LZWDecompresser
Given a java byte, turn it into an integer between 0 and 255 (i.e.
fromInt(int) - Static method in class org.apache.poi.util.LZWDecompresser
Given an integer, turn it into a java byte, handling the wrapping.
fromNumericCellRange(Sheet, CellRangeAddress) - Static method in class org.apache.poi.ss.usermodel.charts.DataSources

fromStringCellRange(Sheet, CellRangeAddress) - Static method in class org.apache.poi.ss.usermodel.charts.DataSources

FSPA - Class in org.apache.poi.hwpf.model
File Shape Address structure
FSPA() - Constructor for class org.apache.poi.hwpf.model.FSPA

FSPA(byte[], int) - Constructor for class org.apache.poi.hwpf.model.FSPA

FSPA_SIZE - Static variable in class org.apache.poi.hwpf.model.FSPA
Deprecated.
FSPAAbstractType - Class in org.apache.poi.hwpf.model.types
File Shape Address (FSPA).
FSPAAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.FSPAAbstractType

FSPADocumentPart - Enum in org.apache.poi.hwpf.model

FSPATable - Class in org.apache.poi.hwpf.model
This class holds all the FSPA (File Shape Address) structures.
FSPATable(byte[], FileInformationBlock, FSPADocumentPart) - Constructor for class org.apache.poi.hwpf.model.FSPATable

FSPATable(byte[], int, int, List<TextPiece>) - Constructor for class org.apache.poi.hwpf.model.FSPATable
Deprecated.
FtCblsSubRecord - Class in org.apache.poi.hssf.record
This structure appears as part of an Obj record that represents a checkbox or radio button.
FtCblsSubRecord() - Constructor for class org.apache.poi.hssf.record.FtCblsSubRecord
Construct a new FtCblsSubRecord and fill its data with the default values
FtCblsSubRecord(LittleEndianInput, int) - Constructor for class org.apache.poi.hssf.record.FtCblsSubRecord

FTP_SITE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

FtrHeader - Class in org.apache.poi.hssf.record.common
Title: FtrHeader (Future Record Header) common record part
FtrHeader() - Constructor for class org.apache.poi.hssf.record.common.FtrHeader

FtrHeader(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.common.FtrHeader

FuncPtg - Class in org.apache.poi.ss.formula.ptg

Function - Interface in org.apache.poi.ss.formula.functions
Common interface for all implementations of Excel built-in functions.
Function0Arg - Interface in org.apache.poi.ss.formula.functions
Implemented by all functions that can be called with zero arguments
Function1Arg - Interface in org.apache.poi.ss.formula.functions
Implemented by all functions that can be called with one argument
Function2Arg - Interface in org.apache.poi.ss.formula.functions
Implemented by all functions that can be called with two arguments
Function3Arg - Interface in org.apache.poi.ss.formula.functions
Implemented by all functions that can be called with three arguments
Function4Arg - Interface in org.apache.poi.ss.formula.functions
Implemented by all functions that can be called with four arguments
FUNCTION_INDEX_CHOOSE - Static variable in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

FUNCTION_INDEX_EXTERNAL - Static variable in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

FUNCTION_INDEX_IF - Static variable in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

FUNCTION_INDEX_INDIRECT - Static variable in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

FUNCTION_INDEX_SUM - Static variable in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

FUNCTION_NAME_IF - Static variable in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry
The name of the IF function (i.e.
FUNCTION_NAME_IF - Static variable in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
The name of the IF function (i.e.
FunctionEval - Class in org.apache.poi.ss.formula.eval

FunctionEval() - Constructor for class org.apache.poi.ss.formula.eval.FunctionEval

FunctionMetadata - Class in org.apache.poi.ss.formula.function
Holds information about Excel built-in functions.
FunctionMetadataRegistry - Class in org.apache.poi.ss.formula.function
Allows clients to get FunctionMetadata instances for any built-in function of Excel.
functions - Static variable in class org.apache.poi.ss.formula.eval.FunctionEval
Array elements corresponding to unimplemented functions are null
FuncVarPtg - Class in org.apache.poi.ss.formula.ptg

FUNNEL - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

FV - Static variable in class org.apache.poi.ss.formula.functions.FinanceFunction

fv(double, double, double, double, boolean) - Static method in class org.apache.poi.ss.formula.functions.FinanceLib
Future value of an amount given the number of payments, rate, amount of individual payment, present value and boolean value indicating whether payments are due at the beginning of period (false => payments are due at end of period)

G

GE - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

GE - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Greater than or equal to' operator
GEAR_6 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

GEAR_9 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

GENDER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

GENERAL - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

GENERAL_FORMAT - Static variable in class org.apache.poi.ss.format.CellFormat
Format a value as it would be were no format specified.
generateContiguous(String) - Static method in class org.apache.poi.ss.util.AreaReference
Takes a non-contiguous area reference, and returns an array of contiguous area references.
generateData() - Method in class org.apache.poi.hpbf.model.EscherPart
Serialises our Escher children back into bytes.
generateData() - Method in class org.apache.poi.hpbf.model.HPBFPart
Called just before writing out, to trigger the data byte array to be updated with the latest contents.
generateData() - Method in class org.apache.poi.hpbf.model.MainContents

generateData() - Method in class org.apache.poi.hpbf.model.QuillContents

generateIv(int, byte[], byte[]) - Method in class org.apache.poi.poifs.crypt.AgileDecryptor

generateRelationIfNeeded(PackagePart) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Generates the relation if required
GENERATION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

GenericDateMCAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

GenericPropertyNode - Class in org.apache.poi.hwpf.model

GenericPropertyNode(int, int, byte[]) - Constructor for class org.apache.poi.hwpf.model.GenericPropertyNode

GEOMETRY__3DOK - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST10VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST2VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST3VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST4VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST5VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST6VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST7VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST8VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUST9VALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__ADJUSTVALUE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__BOTTOM - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__FILLOK - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__FILLSHADESHAPEOK - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__GEOTEXTOK - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__LEFT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__LINEOK - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__RIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__SEGMENTINFO - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__SHADOWok - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__SHAPEPATH - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__TOP - Static variable in class org.apache.poi.ddf.EscherProperties

GEOMETRY__VERTICES - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__ALIGNMENTONCURVE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__BOLDFONT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__CHARBOUNDINGBOX - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__DEFAULTPOINTSIZE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__FONTFAMILYNAME - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__HASTEXTEFFECT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__ITALICFONT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__KERNCHARACTERS - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__NOMEASUREALONGPATH - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__REVERSEROWORDER - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__ROTATECHARACTERS - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__RTFTEXT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__SCALETEXTONPATH - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__SHADOWFONT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__SMALLCAPSFONT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__STRETCHCHARHEIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__STRETCHTOFITSHAPE - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__STRIKETHROUGHFONT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__TEXTSPACING - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__TIGHTORTRACK - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__UNDERLINEFONT - Static variable in class org.apache.poi.ddf.EscherProperties

GEOTEXT__UNICODE - Static variable in class org.apache.poi.ddf.EscherProperties

get(String) - Method in class org.apache.poi.hpsf.CustomProperties
Gets a named value from the custom properties.
get(long) - Method in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Gets the ID string for an ID from the PropertyIDMap.
get(byte[]) - Method in class org.apache.poi.hpsf.wellknown.SectionIDMap
Returns the PropertyIDMap for a given section format ID.
get(Object) - Method in class org.apache.poi.hpsf.wellknown.SectionIDMap
Deprecated. Use SectionIDMap.get(byte[]) instead!
get(int) - Method in class org.apache.poi.hslf.record.ExObjList
Lookup a hyperlink by its unique id
get(int) - Static method in class org.apache.poi.hsmf.datatypes.MAPIProperty

get(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

get(int) - Method in class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

get(int) - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable

get(Object) - Method in class org.apache.poi.util.BinaryTree
Returns the value to which this map maps the specified key.
get() - Method in class org.apache.poi.util.ByteField
get the ByteField's current value
get() - Method in class org.apache.poi.util.IntegerField
get the IntegerField's current value
get(int) - Method in class org.apache.poi.util.IntList
Returns the element at the specified position in this list.
get(int) - Method in class org.apache.poi.util.IntMapper

get() - Method in class org.apache.poi.util.LongField
get the LongField's current value
get() - Method in class org.apache.poi.util.ShortField
get the ShortField's current value
get(int) - Method in class org.apache.poi.util.ShortList
Returns the element at the specified position in this list.
get123Prefix() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get some old holdover from lotus 123.
get7BitEncoding() - Method in class org.apache.poi.hsmf.datatypes.StringChunk
Returns the Encoding that will be used to decode any "7 bit" (non unicode) data.
get_cbFfnM1() - Method in class org.apache.poi.hwpf.model.Ffn

getAbsoluteValue(int, int) - Method in interface org.apache.poi.ss.formula.eval.AreaEval

getAbsoluteValue(int, int) - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getAbstractNum() - Method in class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

getAbstractNum(BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
get AbstractNum by abstractNumID
getAbstractNumID(BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
return the abstractNumID If the AbstractNumID not exists return null
getAccentAndFollowingHyperlinkColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Accent And Following Hyperlink Colour
getAccentAndHyperlinkColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Accent And Hyperlink Colour
getAccentColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Accent Colour
getAcceptedAtTime() - Method in class org.apache.poi.hsmf.datatypes.MessageSubmissionChunk

getAction() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Hyperlink Action.
getActiveCell() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Return location of the active cell, e.g.
getActiveCellCol() - Method in class org.apache.poi.hssf.model.InternalSheet

getActiveCellCol() - Method in class org.apache.poi.hssf.record.SelectionRecord
get the active cell's col
getActiveCellRef() - Method in class org.apache.poi.hssf.record.SelectionRecord
get the active cell's reference number
getActiveCellRow() - Method in class org.apache.poi.hssf.model.InternalSheet
Returns the active row
getActiveCellRow() - Method in class org.apache.poi.hssf.record.SelectionRecord
get the active cell's row
getActivePane() - Method in class org.apache.poi.hssf.record.PaneRecord
Get the active pane field for the Pane record.
getActivePane() - Method in class org.apache.poi.hssf.util.PaneInformation
Returns the active pane
getActiveSheetIndex() - Method in class org.apache.poi.hssf.record.WindowOneRecord

getActiveSheetIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
gets the tab whose data is actually seen when the sheet is opened.
getActiveSheetIndex() - Method in interface org.apache.poi.ss.usermodel.Workbook
Convenience method to get the active sheet.
getActiveSheetIndex() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Convenience method to get the active sheet.
getActiveSheetIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Convenience method to get the active sheet.
getActualSizeOfElements(short) - Static method in class org.apache.poi.ddf.EscherArrayProperty
Sometimes the element size is stored as a negative number.
getAddMenuCount() - Method in class org.apache.poi.hssf.record.MMSRecord
get number of add menu options (should be 0)
getAddress() - Method in interface org.apache.poi.common.usermodel.Hyperlink
Hypelink address.
getAddress() - Method in class org.apache.poi.hdgf.pointers.Pointer

getAddress() - Method in class org.apache.poi.hslf.model.Hyperlink
Gets the hyperlink URL
getAddress() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Hyperlink address.
getAddress() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Hypelink address.
getAddress() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Hypelink address.
getAdjustmentValue(int) - Method in class org.apache.poi.hslf.model.AutoShape
Gets adjust value which controls smart resizing of the auto-shape.
getAdjustValue(String) - Method in class org.apache.poi.xslf.model.geom.Context

getAdjustValue(String) - Method in interface org.apache.poi.xslf.model.geom.IAdjustableShape

getAdt() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the adt field for the DOP record.
getAdtlDiag() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get for diagonal borders? No idea (its a palette color for the other function we didn't know what was?)
getAdtlDiagLineStyle() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the diagonal border line style? Who the heck ever heard of a diagonal border?
getAdtlFillPattern() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the additional fill pattern
getAdtlPaletteOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the additional palette options bitmask (see individual bit getter methods that reference this method)
getAlgorithm() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getAlgorithm() - Method in class org.apache.poi.poifs.crypt.EncryptionVerifier

getAlign(short) - Static method in class org.apache.poi.hssf.converter.AbstractExcelUtils

getAlignment() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the type of horizontal alignment for the text.
getAlignment() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the horizontal alignment of the cell.
getAlignment() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the type of horizontal alignment for the cell
getAlignment() - Method in class org.apache.poi.hwpf.model.ListLevel
"Alignment (left, right, or centered) of the paragraph number."
getAlignment() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the type of horizontal alignment for the cell
getAlignment() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of horizontal alignment for the cell
getAlignment() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Returns the paragraph alignment which shall be applied to text in this paragraph.
getAlignmentEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of horizontal alignment for the cell
getAlignmentOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the alignment options bitmask.
getAll() - Method in class org.apache.poi.hsmf.datatypes.AttachmentChunks

getAll() - Method in class org.apache.poi.hsmf.datatypes.Chunks

getAll() - Static method in class org.apache.poi.hsmf.datatypes.MAPIProperty

getAll() - Method in class org.apache.poi.hsmf.datatypes.NameIdChunks

getAll() - Method in class org.apache.poi.hsmf.datatypes.RecipientChunks

getAll() - Static method in class org.apache.poi.ss.usermodel.BuiltinFormats

getAllEmbeddedObjects() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Gets all embedded OLE2 objects from the Workbook.
getAllEmbedds() - Method in class org.apache.poi.POIXMLDocument
Get the document's embedded files.
getAllEmbedds() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Get the document's embedded files.
getAllEmbedds() - Method in class org.apache.poi.xslf.XSLFSlideShow
Get the document's embedded files.
getAllEmbedds() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the document's embedded files.
getAllEmbedds() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Get the document's embedded files.
getAllKnownRecordSIDs() - Static method in class org.apache.poi.hssf.record.RecordFactory

getAllPackagePictures() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getAllPackagePictures() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
get all Pictures in this package
getAllPictures() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Gets all pictures from the Workbook.
getAllPictures() - Method in class org.apache.poi.hwpf.model.PicturesTable
Not all documents have all the images concatenated in the data stream although MS claims so.
getAllPictures() - Method in interface org.apache.poi.ss.usermodel.Workbook
Gets all pictures from the Workbook.
getAllPictures() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Returns all Pictures, which are referenced from the document itself.
getAllPictures() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Gets all pictures from the Workbook.
getAllPictures() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Gets all pictures from the Workbook.
getAllPictures() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Returns all Pictures, which are referenced from the document itself.
getAllPictures() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

getAllReferencedCells() - Method in class org.apache.poi.ss.util.AreaReference
Returns a reference to every cell covered by this area
getAllShapes() - Method in class org.apache.poi.hwpf.model.ShapesTable
Deprecated.
getAllSimpleXmlCell() - Method in class org.apache.poi.xssf.model.SingleXmlCells

getAllText() - Method in class org.apache.poi.hdgf.extractor.VisioTextExtractor
Locates all the text entries in the file, and returns their contents.
getAllTextEndAt() - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12
Returns where in the text that this block of hyperlinks stops applying to.
getAllThreadsPreferEventExtractors() - Static method in class org.apache.poi.extractor.ExtractorFactory
Should all threads prefer event based over usermodel based extractors? (usermodel extractors tend to be more accurate, but use more memory) Default is to use the thread level setting, which defaults to false.
getAllXSSFMaps() - Method in class org.apache.poi.xssf.model.MapInfo

getAlternateExpression() - Method in class org.apache.poi.hssf.record.WSBoolRecord
whether alternate expression evaluation is on
getAlternateExpression() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
whether alternate expression evaluation is on
getAlternateFormula() - Method in class org.apache.poi.hssf.record.WSBoolRecord
whether alternative formula entry is on
getAlternateFormula() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
whether alternative formula entry is on
getAltFont(int) - Method in class org.apache.poi.hwpf.model.FontTable

getAltFontName() - Method in class org.apache.poi.hwpf.model.Ffn

getAltLangId() - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun
Alternate Windows LANGID of this text; must be a valid non-East Asian LANGID if the text has an East Asian language, otherwise may be an East Asian LANGID or language neutral (zero).
getAnchor() - Method in class org.apache.poi.hslf.model.Shape
Returns the anchor (the bounding box rectangle) of this shape.
getAnchor() - Method in class org.apache.poi.hssf.usermodel.HSSFShape

getAnchor() - Method in interface org.apache.poi.sl.usermodel.Shape

getAnchor() - Method in class org.apache.poi.xslf.usermodel.XSLFBackground

getAnchor() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

getAnchor() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getAnchor() - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

getAnchor() - Method in class org.apache.poi.xslf.usermodel.XSLFShape

getAnchor() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getAnchor() - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Returns the frame anchor.
getAnchor() - Method in class org.apache.poi.xssf.usermodel.XSSFShape

getAnchor() - Method in class org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

getAnchor2D() - Method in class org.apache.poi.hslf.model.Shape
Returns the anchor (the bounding box rectangle) of this shape.
getAnchor2D() - Method in class org.apache.poi.hslf.model.ShapeGroup
Returns the anchor (the bounding box rectangle) of this shape group.
getAnchorHeightInPoints(HSSFSheet) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor
Calculates the height of a client anchor in points.
getAnchorId() - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord
Get the anchor id field for the ObjectLink record.
getAnchorType() - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor
Gets the anchor type
getAnchorType() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Gets the anchor type
getAnchorType() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor
Gets the anchor type
getAngle() - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

getAnimationInfoAtom() - Method in class org.apache.poi.hslf.record.AnimationInfo
Returns the AnimationInfo
getAnld() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the anld field for the PAP record.
getApplicationName() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the application name (or null).
getArabic() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
is this arabic?
getArea() - Method in class org.apache.poi.ss.util.Region
Deprecated.
getArea3DEval(int, int, int, int, int) - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getAreaAt(int) - Method in class org.apache.poi.hssf.record.MergeCellsRecord

getAreaEval(int, int, int, int) - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getARgb() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Standard Alpha Red Green Blue ctColor value (ARGB).
getARGBHex() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Return the ARGB value in hex format, eg FF00FF00.
getArrayFormulaRange() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

getArrayFormulaRange() - Method in class org.apache.poi.hssf.usermodel.HSSFCell

getArrayFormulaRange() - Method in interface org.apache.poi.ss.usermodel.Cell
Only valid for array formula cells
getArrayFormulaRange() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Only valid for array formula cells
getArrayFormulaRange() - Method in class org.apache.poi.xssf.usermodel.XSSFCell

getArrayRecord(int, int) - Method in class org.apache.poi.hssf.record.aggregates.SharedValueManager

getAs7bitString() - Method in class org.apache.poi.hsmf.datatypes.ByteChunk
Returns the data, formatted as a string assuming it was a non-unicode string.
getAsDate(MAPIAttribute) - Static method in class org.apache.poi.hmef.attribute.MAPIDateAttribute
Returns the Date of a Attribute, converting as appropriate
getAsDate(TNEFAttribute) - Static method in class org.apache.poi.hmef.attribute.TNEFDateAttribute
Returns the Date of a Attribute, converting as appropriate
getAsEmbededMessage() - Method in class org.apache.poi.hsmf.datatypes.DirectoryChunk
Treats the directory as an embeded MAPIMessage (it normally is one), and returns a MAPIMessage object to process it with.
getAspectRatioX() - Method in class org.apache.poi.hwpf.usermodel.Picture
Deprecated. use more precise Picture.getHorizontalScalingFactor()
getAspectRatioY() - Method in class org.apache.poi.hwpf.usermodel.Picture
Deprecated. use more precise Picture.getVerticalScalingFactor()
getAsString(MAPIAttribute) - Static method in class org.apache.poi.hmef.attribute.MAPIStringAttribute
Returns the string of a Attribute, converting as appropriate
getAsString(TNEFAttribute) - Static method in class org.apache.poi.hmef.attribute.TNEFStringAttribute
Returns the string of a Attribute, converting as appropriate
getAsumyi() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the asumyi field for the DOP record.
getAttachmentFiles() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the message attachments.
getAttachments() - Method in class org.apache.poi.hmef.HMEFMessage
Returns all the Attachments of the message.
getAttribute(TNEFProperty) - Method in class org.apache.poi.hmef.Attachment
Return the attachment attribute with the given ID, or null if there isn't one.
getAttributedString(TextRun) - Method in class org.apache.poi.hslf.model.TextPainter
Convert the underlying set of rich text runs into java.text.AttributedString
getAttributes() - Method in class org.apache.poi.hmef.Attachment
Returns all HMEF/TNEF attributes of the attachment, such as filename, icon and contents
getAttributes() - Method in class org.apache.poi.hssf.record.FontRecord
get the font attributes (see individual bit getters that reference this method)
getAuthor() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the author (or null).
getAuthor() - Method in class org.apache.poi.hslf.model.Comment
Get the Author of this comment
getAuthor() - Method in class org.apache.poi.hslf.record.Comment2000
Get the Author of this comment
getAuthor() - Method in class org.apache.poi.hssf.record.NoteRecord
Name of the original comment author
getAuthor() - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Name of the original comment author
getAuthor(int) - Method in class org.apache.poi.hwpf.model.RevisionMarkAuthorTable
Get an author by its index.
getAuthor() - Method in interface org.apache.poi.ss.usermodel.Comment
Name of the original comment author
getAuthor(long) - Method in class org.apache.poi.xssf.model.CommentsTable

getAuthor() - Method in class org.apache.poi.xssf.usermodel.XSSFComment

getAuthor() - Method in class org.apache.poi.xwpf.usermodel.XWPFComment

getAuthorById(long) - Method in class org.apache.poi.xslf.usermodel.XSLFCommentAuthors

getAuthorInitials() - Method in class org.apache.poi.hslf.model.Comment
Get the Author's Initials of this comment
getAuthorInitials() - Method in class org.apache.poi.hslf.record.Comment2000
Get the Author's Initials of this comment
getAutobreaks() - Method in class org.apache.poi.hssf.record.WSBoolRecord
show automatic page breaks or not
getAutobreaks() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
show automatic page breaks or not
getAutobreaks() - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether the sheet displays Automatic Page Breaks.
getAutobreaks() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether the sheet displays Automatic Page Breaks.
getAutobreaks() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether the sheet displays Automatic Page Breaks.
getAvailableSpace() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

getAxis() - Method in interface org.apache.poi.ss.usermodel.Chart

getAxis() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

getAxisType() - Method in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord
Get the axis type field for the AxisLineFormat record.
getAxisType() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Get the axis type field for the AxisParent record.
getAxisType() - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Get the axis type field for the Axis record.
getBackcolorIndex() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Get the backcolor index field for the AreaFormat record.
getBackground() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns the background color used for clearing a region.
getBackground() - Method in class org.apache.poi.hslf.model.Sheet
Returns the background shape for this sheet.
getBackground() - Method in class org.apache.poi.hslf.model.Slide
Background for this slide.
getBackground() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the background field for the Tick record.
getBackground() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getBackground() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

getBackground() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getBackground() - Method in interface org.apache.poi.sl.usermodel.Sheet

getBackground() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getBackground() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getBackground() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout

getBackground() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getBackgroundColor() - Method in class org.apache.poi.hslf.model.Fill
Background color
getBackgroundColor() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Get the background color field for the AreaFormat record.
getBackgroundColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Background Colour
getBackup() - Method in class org.apache.poi.hssf.record.BackupRecord
get the backup flag
getBackupFlag() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
determine whether the Excel GUI will backup the workbook when saving.
getBackuppos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getBackupRecord() - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns the position of the backup record.
getBadFontHeight() - Method in class org.apache.poi.hssf.record.RowRecord
get whether the font and row height are not compatible
getBarBorder() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getBarBorder() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getBarBorder() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getBarSpace() - Method in class org.apache.poi.hssf.record.chart.BarRecord
Get the bar space field for the Bar record.
getBaseStyle() - Method in class org.apache.poi.hwpf.model.StyleDescription

getBaseUnit() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the base unit field for the AxisOptions record.
getBasicFunction(int) - Static method in class org.apache.poi.ss.formula.eval.FunctionEval

getBasisStyleID() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle

getBATArray() - Method in class org.apache.poi.poifs.storage.HeaderBlock
Returns the offsets to the first (up to) 109 BAT sectors.
getBATBlockAndIndex(int) - Method in class org.apache.poi.poifs.filesystem.BlockStore
Returns the BATBlock that handles the specified offset, and the relative index within it
getBATBlockAndIndex(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Returns the BATBlock that handles the specified offset, and the relative index within it
getBATBlockAndIndex(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore
Returns the BATBlock that handles the specified offset, and the relative index within it
getBATBlockAndIndex(int, HeaderBlock, List<BATBlock>) - Static method in class org.apache.poi.poifs.storage.BATBlock
Returns the BATBlock that handles the specified offset, and the relative index within it.
getBATCount() - Method in class org.apache.poi.poifs.storage.HeaderBlock

getBATEntriesPerBlock() - Method in class org.apache.poi.poifs.common.POIFSBigBlockSize

getBchUpe() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
An unsigned integer that specifies the size, in bytes, of std in LPStd.
getBeginChar() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getBeginPos() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getBeginRun() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getBeginText() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getBest(int, int) - Static method in class org.apache.poi.hmef.attribute.TNEFProperty

getBiffName(int) - Static method in class org.apache.poi.hssf.record.UnknownRecord
These BIFF record types are known but still uninterpreted by POI
getBigBlockSize() - Method in class org.apache.poi.poifs.common.POIFSBigBlockSize

getBigBlockSize() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem

getBigBlockSize() - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem

getBigBlockSize() - Method in class org.apache.poi.poifs.storage.HeaderBlock

getBigBlockSize() - Method in class org.apache.poi.poifs.storage.RawDataBlock
What's the big block size?
getBigBlockSize() - Method in class org.apache.poi.poifs.storage.SmallDocumentBlock

getBigBlockSizeDetails() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem

getBigBlockSizeDetails() - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem

getBitFieldFunction(String, String, String, String) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getBitFieldGet(String, String, String, String) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getBitFieldSet(String, String, String, String) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getBitFieldType(String, String, String) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getBits() - Method in class org.apache.poi.hpbf.model.QuillContents

getBitType() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit
Returns the type of the bit data, eg TEXT or PLC
getBkc() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Break code.
getBkf_flags() - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Get the bkf_flags field for the BKF record.
getBlipRecord() - Method in class org.apache.poi.ddf.EscherBSERecord

getBlipRecords() - Method in class org.apache.poi.hwpf.model.PICFAndOfficeArtData

getBlipType(byte) - Static method in class org.apache.poi.ddf.EscherBSERecord
Retrieve the string representation given a blip id.
getBlipTypeMacOS() - Method in class org.apache.poi.ddf.EscherBSERecord
The expected blip type under MacOS (failure to match this blip type will result in Excel converting to this format).
getBlipTypeWin32() - Method in class org.apache.poi.ddf.EscherBSERecord
The expected blip type under windows (failure to match this blip type will result in Excel converting to this format).
getBlock() - Method in class org.apache.poi.poifs.storage.BATBlock.BATBlockAndIndex

getBlock() - Method in class org.apache.poi.xwpf.usermodel.TOC

getBlockAt(int) - Method in class org.apache.poi.poifs.filesystem.BlockStore
Load the block at the given offset.
getBlockAt(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Load the block at the given offset.
getBlockAt(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore
Load the block at the given offset.
getBlockIterator() - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream

getBlockSize(int) - Static method in class org.apache.poi.poifs.crypt.Decryptor

getBlockStoreBlockSize() - Method in class org.apache.poi.poifs.filesystem.BlockStore
Returns the size of the blocks managed through the block store.
getBlockStoreBlockSize() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem

getBlockStoreBlockSize() - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore

getBlue() - Method in class org.apache.poi.ddf.EscherRGBProperty

getBlur() - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

getBody() - Method in class org.apache.poi.hmef.HMEFMessage
Returns the Message Body, as RTF, or null if the mapi property for this isn't set
getBody() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

getBody() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

getBody() - Method in interface org.apache.poi.xwpf.usermodel.IBodyElement

getBody() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph

getBody() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getBodyElements() - Method in interface org.apache.poi.xwpf.usermodel.IBody
Returns an Iterator with paragraphs and tables, in the order that they occur in the text.
getBodyElements() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
returns an Iterator with paragraphs and tables
getBodyElements() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getBodyElements() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

getBodyElements() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
returns an Iterator with paragraphs and tables
getBodyElementsIterator() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getBold() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get a boolean value for the boldness to use.
getBoldWeight() - Method in class org.apache.poi.hssf.record.FontRecord
get the bold weight for this font (100-1000dec or 0x64-0x3e8).
getBoldweight() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get the boldness to use
getBoldweight() - Method in interface org.apache.poi.ss.usermodel.Font

getBoldweight() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the boldness to use
getBookmark(int) - Method in interface org.apache.poi.hwpf.usermodel.Bookmarks

getBookmark(int) - Method in class org.apache.poi.hwpf.usermodel.BookmarksImpl

getBookmarks() - Method in class org.apache.poi.hwpf.HWPFDocument

getBookmarksAt(int) - Method in class org.apache.poi.hwpf.usermodel.BookmarksImpl

getBookmarksCount() - Method in class org.apache.poi.hwpf.model.BookmarksTables

getBookmarksCount() - Method in interface org.apache.poi.hwpf.usermodel.Bookmarks

getBookmarksCount() - Method in class org.apache.poi.hwpf.usermodel.BookmarksImpl

getBookmarksStartedBetween(int, int) - Method in interface org.apache.poi.hwpf.usermodel.Bookmarks

getBookmarksStartedBetween(int, int) - Method in class org.apache.poi.hwpf.usermodel.BookmarksImpl

getBooleanCellValue() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
get the value of the cell as a boolean.
getBooleanCellValue() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getBooleanCellValue() - Method in interface org.apache.poi.ss.usermodel.Cell
Get the value of the cell as a boolean.
getBooleanCellValue() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Get the value of the cell as a boolean.
getBooleanCellValue() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Get the value of the cell as a boolean.
getBooleanValue() - Method in class org.apache.poi.hssf.record.BoolErrRecord
get the value for the cell
getBooleanValue() - Method in class org.apache.poi.ss.formula.eval.BoolEval

getBooleanValue() - Method in class org.apache.poi.ss.usermodel.CellValue

getBorder() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getBorderAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getBorderBetween() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.
getBorderBottom() - Method in class org.apache.poi.hslf.model.TableCell

getBorderBottom() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the type of border to use for the bottom border of the cell
getBorderBottom() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the borderline style for the bottom border
getBorderBottom() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getBorderBottom() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the type of border to use for the bottom border of the cell
getBorderBottom() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getBorderBottom() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the type of border to use for the bottom border of the cell
getBorderBottom() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderBottom() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getBorderBottom() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the bottom border of the cell
getBorderBottom() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.
getBorderBottomColor() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderBottomEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the bottom border of the cell
getBorderColor(XSSFCellBorder.BorderSide) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Get the color to use for the selected border
getBorderColor(XSSFCellBorder.BorderSide) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Gets border color
getBorderDiagonal() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the type of border to use for the diagonal border of the cell
getBorderDiagonal() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getBorderDiagonal() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getBorderDiagonal() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getBorderFormatting() - Method in class org.apache.poi.hssf.record.CFRuleRecord

getBorderFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

getBorderFormatting() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule

getBorderFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule

getBorderFormattingBlock() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getBorderLeft() - Method in class org.apache.poi.hslf.model.TableCell

getBorderLeft() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the type of border to use for the left border of the cell
getBorderLeft() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the borderline style for the left border
getBorderLeft() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getBorderLeft() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the type of border to use for the left border of the cell
getBorderLeft() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getBorderLeft() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the type of border to use for the left border of the cell
getBorderLeft() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderLeft() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getBorderLeft() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the left border of the cell
getBorderLeft() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed on the left side of the page around the specified paragraph.
getBorderLeftColor() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderLeftEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the left border of the cell
getBorderOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the border options bitmask (see the corresponding bit getter methods that reference back to this one)
getBorderRight() - Method in class org.apache.poi.hslf.model.TableCell

getBorderRight() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the type of border to use for the right border of the cell
getBorderRight() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the borderline style for the right border
getBorderRight() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getBorderRight() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the type of border to use for the right border of the cell
getBorderRight() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getBorderRight() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the type of border to use for the right border of the cell
getBorderRight() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderRight() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getBorderRight() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the right border of the cell
getBorderRight() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed on the right side of the page around the specified paragraph.
getBorderRightColor() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderRightEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the right border of the cell
getBorders() - Method in class org.apache.poi.xssf.model.StylesTable

getBorderStyle(short) - Static method in class org.apache.poi.hssf.converter.AbstractExcelUtils

getBorderStyle(XSSFCellBorder.BorderSide) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Get the type of border to use for the selected border
getBorderTop() - Method in class org.apache.poi.hslf.model.TableCell

getBorderTop() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the type of border to use for the top border of the cell
getBorderTop() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the borderline style for the top border
getBorderTop() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getBorderTop() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the type of border to use for the top border of the cell
getBorderTop() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getBorderTop() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the type of border to use for the top border of the cell
getBorderTop() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderTop() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getBorderTop() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the top border of the cell
getBorderTop() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.
getBorderTopColor() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getBorderTopEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of border to use for the top border of the cell
getBorderType() - Method in class org.apache.poi.hssf.record.chart.FrameRecord
Get the border type field for the Frame record.
getBorderType(BorderCode) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getBorderType() - Method in class org.apache.poi.hwpf.usermodel.BorderCode
Border type code: 0 none 1 single 2 thick 3 double 5 hairline 6 dot 7 dash large gap 8 dot dash 9 dot dot dash 10 triple 11 thin-thick small gap 12 thick-thin small gap 13 thin-thick-thin small gap 14 thin-thick medium gap 15 thick-thin medium gap 16 thin-thick-thin medium gap 17 thin-thick large gap 18 thick-thin large gap 19 thin-thick-thin large gap 20 wave 21 double wave 22 dash small gap 23 dash dot stroked 24 emboss 3D 25 engrave 3D codes 64 - 230 represent border art types and are used only for page borders
getBorderWidth(short) - Static method in class org.apache.poi.hssf.converter.AbstractExcelUtils

getBorderWidth(BorderCode) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getBottom() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
getBottomBorder() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getBottomBorder() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getBottomBorder() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getBottomBorderColor() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the color to use for the bottom border
getBottomBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getBottomBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the color to use for the left border
getBottomBorderColor() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getBottomBorderColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the color to use for the left border
getBottomBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getBottomBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the bottom border
Color is optional.
getBottomBorderPaletteIdx() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the palette index for the bottom border
getBottomBorderXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the bottom border as a XSSFColor
getBottomInset() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Returns the distance (in points) between the bottom of the text frame and the bottom of the inscribed rectangle of the shape that contains the text.
getBoundaryHeight() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the boundary height of the metafile drawing commands
getBoundaryLeft() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the left boundary of the metafile drawing commands
getBoundaryTop() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the top boundary of the metafile drawing commands
getBoundaryType() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

getBoundaryWidth() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the boundary width of the metafile drawing commands
getBounds() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getBounds() - Method in class org.apache.poi.ddf.EscherPictBlip

getBoundSheetRecords() - Method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

getBoundWorkbook() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Returns the Workbook that this Cell is bound to
getBpp() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the bpp field for the PICF record.
getBrc() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Border.
getBrcBar() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the brcBar field for the PAP record.
getBrcBetween() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the brcBetween field for the PAP record.
getBrcBottom() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the brcBottom field for the PAP record.
getBrcBottom() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the brcBottom field for the SEP record.
getBrcBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the brcBottom field for the TAP record.
getBrcBottom() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom border.
getBrcBottom() - Method in class org.apache.poi.hwpf.usermodel.TableCell

getBrcBottom80() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the brcBottom80 field for the PICF record.
getBrcHorizontal() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the brcHorizontal field for the TAP record.
getBrcl() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Border line style.
getBrcLeft() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the brcLeft field for the PAP record.
getBrcLeft() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the brcLeft field for the SEP record.
getBrcLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the brcLeft field for the TAP record.
getBrcLeft() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left border.
getBrcLeft() - Method in class org.apache.poi.hwpf.usermodel.TableCell

getBrcLeft80() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the brcLeft80 field for the PICF record.
getBrcp() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Rectangle border codes.
getBrcRight() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the brcRight field for the PAP record.
getBrcRight() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the brcRight field for the SEP record.
getBrcRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the brcRight field for the TAP record.
getBrcRight() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right border.
getBrcRight() - Method in class org.apache.poi.hwpf.usermodel.TableCell

getBrcRight80() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the brcRight80 field for the PICF record.
getBrcTop() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the brcTop field for the PAP record.
getBrcTop() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the brcTop field for the SEP record.
getBrcTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the brcTop field for the TAP record.
getBrcTop() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top border.
getBrcTop() - Method in class org.apache.poi.hwpf.usermodel.TableCell

getBrcTop80() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the brcTop80 field for the PICF record.
getBrcVertical() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the brcVertical field for the TAP record.
getBreak(int) - Method in class org.apache.poi.hssf.record.PageBreakRecord
Retrieves the region at the row/column indicated
getBreaks() - Method in class org.apache.poi.hssf.record.PageBreakRecord

getBreaksIterator() - Method in class org.apache.poi.hssf.record.PageBreakRecord

getBSERecord(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook

getBspos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getBStoreContainers() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder

getBubbleSeriesType() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Get the bubble series type field for the Series record.
getBucketSSTOffset() - Method in class org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord

getBuild() - Method in class org.apache.poi.hssf.record.BOFRecord
get the build that wrote this file
getBuildYear() - Method in class org.apache.poi.hssf.record.BOFRecord
Year of the build that wrote this file
getBuiltinFormat(String) - Static method in class org.apache.poi.hssf.usermodel.HSSFDataFormat
get the format index that matches the given format string
getBuiltinFormat(short) - Static method in class org.apache.poi.hssf.usermodel.HSSFDataFormat
get the format string that matches the given format index
getBuiltinFormat(int) - Static method in class org.apache.poi.ss.usermodel.BuiltinFormats
Get the format string that matches the given format index
getBuiltinFormat(String) - Static method in class org.apache.poi.ss.usermodel.BuiltinFormats
Get the format index that matches the given format string
Automatically converts "text" to excel's format string to represent text.
getBuiltinFormats() - Static method in class org.apache.poi.hssf.usermodel.HSSFDataFormat

getBuiltinFormats() - Static method in class org.apache.poi.ss.usermodel.BuiltinFormats
Deprecated. (May 2009) use BuiltinFormats.getAll()
getBuiltInName() - Method in class org.apache.poi.hssf.record.NameRecord
Gets the Built In Name
getBulletChar() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the bullet character
getBulletCharacter() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getBulletColor() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the bullet color
getBulletFont() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the bullet font
getBulletFont() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getBulletFontColor() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getBulletFontSize() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Returns the bullet size that is to be used within a paragraph.
getBulletOffset() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the bullet offset
getBulletOffsets() - Method in class org.apache.poi.hslf.record.TextRulerAtom
First line of paragraph's distance from shape's left margin, in master coordinates (576 dpi).
getBulletSize() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the bullet size
getBulletText(ListTables, Paragraph, int) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getBx() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
X position of shape relative to anchor CP
getBy() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Y position of shape relative to anchor CP
getByteArray(byte[], int, int) - Static method in class org.apache.poi.util.LittleEndian
Copy a portion of a byte array
getByteCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the byte count or 0 if the DocumentSummaryInformation does not contain a byte count.
getByteIndex(int) - Method in interface org.apache.poi.hwpf.model.CharIndexTranslator
Calculates the byte index of the given char index.
getByteIndex(int) - Method in class org.apache.poi.hwpf.model.TextPieceTable

getByteOrder() - Method in class org.apache.poi.hpsf.PropertySet
Returns the property set stream's low-level "byte order" field.
getByteOrder() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getBytes() - Method in class org.apache.poi.hpsf.ClassID
Gets the bytes making out the class ID.
getBytes() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Method getBytes - get the bytes of just the HSSF portions of the XLS file.
getBytes() - Method in class org.apache.poi.hwpf.model.GenericPropertyNode

getBytesWritten() - Method in class org.apache.poi.hslf.util.MutableByteArrayOutputStream
Return how many bytes we've stuffed in so far
getByteValue() - Method in enum org.apache.poi.ss.usermodel.FontUnderline

getCacheContents() - Method in class org.apache.poi.hwpf.model.CachedPropertyNode

getCachedBooleanValue() - Method in class org.apache.poi.hssf.record.FormulaRecord

getCachedErrorValue() - Method in class org.apache.poi.hssf.record.FormulaRecord

getCachedFormulaResultType() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Only valid for formula cells
getCachedFormulaResultType() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getCachedFormulaResultType() - Method in interface org.apache.poi.ss.usermodel.Cell
Only valid for formula cells
getCachedFormulaResultType() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Only valid for formula cells
getCachedFormulaResultType() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Only valid for formula cells
getCachedResultType() - Method in class org.apache.poi.hssf.record.FormulaRecord

getCacheOfSavedSize() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the cache of the saved size
getCacheOfSize() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the cache of the metafile size
getCalcMode() - Method in class org.apache.poi.hssf.record.CalcModeRecord
get the calc mode flag for formulas
getCalculationChain() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Return the CalculationChain object for this workbook
getCantLockServerB() - Method in class org.apache.poi.hslf.record.ExEmbedAtom
Gets whether the embedded server cannot be locked.
getCategory() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the category (or null).
getCategory() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getCategoryAxisCross() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Get the category axis cross field for the ValueRange record.
getCategoryDataType() - Method in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord
Get the category data type field for the DefaultDataLabelTextProperties record.
getCategoryDataType() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Get the category data type field for the Series record.
getCategoryLabelsCellRange() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getCategoryProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get the category property.
getCategoryProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the category of the content of this package.
getCategorySpace() - Method in class org.apache.poi.hssf.record.chart.BarRecord
Get the category space field for the Bar record.
getCbFeatData() - Method in class org.apache.poi.hssf.record.FeatRecord

getCbGrpprlChpx() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.
getCbGrpprlPapx() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.
getCbHeader() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
An unsigned integer that specifies the size, in bytes, of this PICF structure.
getCbMac() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
How many bytes of the main stream contain real data.
getCbMac() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the cbMac field for the FibRgLw95 record.
getCbMac() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning.
getCbSTDBaseInFile() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the size, in bytes, of the Stdf structure.
getCCh() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cCh field for the DOP record.
getCChFtnEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cChFtnEdn field for the DOP record.
getCChWS() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cChWS field for the DOP record.
getCChWSFtnEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cChWSFtnEdn field for the DOP record.
getCcolM1() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the ccolM1 field for the SEP record.
getCConsexHypLim() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cConsexHypLim field for the DOP record.
getCcpAtn() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpAtn field for the FibRgLw95 record.
getCcpAtn() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the comment subdocument.
getCcpEdn() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpEdn field for the FibRgLw95 record.
getCcpEdn() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the endnote subdocument.
getCcpFtn() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpFtn field for the FibRgLw95 record.
getCcpFtn() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the footnote subdocument.
getCcpHdd() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpHdd field for the FibRgLw95 record.
getCcpHdd() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the header subdocument.
getCcpHdrTxbx() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpHdrTxbx field for the FibRgLw95 record.
getCcpHdrTxbx() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the textbox subdocument of the header.
getCcpMcr() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpMcr field for the FibRgLw95 record.
getCcpText() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpText field for the FibRgLw95 record.
getCcpText() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the main document.
getCcpTxbx() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the ccpTxbx field for the FibRgLw95 record.
getCcpTxbx() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the textbox subdocument of the main document.
getCDBC() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cDBC field for the DOP record.
getCDBCFtnEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cDBCFtnEdn field for the DOP record.
getCell(int, int) - Method in class org.apache.poi.hslf.model.Table
Gets a cell
getCell(short) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Deprecated. (Aug 2008) use HSSFRow.getCell(int)
getCell(int) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Get the hssfcell representing a given column (logical cell) 0-based.
getCell(int, Row.MissingCellPolicy) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Get the hssfcell representing a given column (logical cell) 0-based.
getCell(HSSFRow, int) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
Get a specific cell from a row.
getCell(int) - Method in class org.apache.poi.hwpf.usermodel.TableRow

getCell(int, int) - Method in interface org.apache.poi.ss.formula.EvaluationSheet

getCell(int, int) - Method in interface org.apache.poi.ss.usermodel.CellRange

getCell(int) - Method in interface org.apache.poi.ss.usermodel.Row
Get the cell representing a given column (logical cell) 0-based.
getCell(int, Row.MissingCellPolicy) - Method in interface org.apache.poi.ss.usermodel.Row
Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
getCell(Row, int) - Static method in class org.apache.poi.ss.util.CellUtil
Get a specific cell from a row.
getCell(int, int) - Method in class org.apache.poi.ss.util.SSCellRange

getCell(int) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Get the cell representing a given column (logical cell) 0-based.
getCell(int, Row.MissingCellPolicy) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
getCell(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Returns the cell at the given (0 based) index, with the Row.MissingCellPolicy from the parent Workbook.
getCell(int, Row.MissingCellPolicy) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
getCell(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow

getCellAlignment() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
get the cellAlignment object to use for manage alignment
getCellComment() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Returns comment associated with this cell
getCellComment(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns cell comment for the specified row and column
getCellComment() - Method in interface org.apache.poi.ss.usermodel.Cell
Returns comment associated with this cell
getCellComment(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns cell comment for the specified row and column
getCellComment() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Returns comment associated with this cell
getCellComment(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns cell comment for the specified row and column
getCellComment() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns cell comment associated with this cell
getCellComment() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup

getCellComment(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getCellFormula() - Method in class org.apache.poi.hssf.usermodel.HSSFCell

getCellFormula() - Method in interface org.apache.poi.ss.usermodel.Cell
Return a formula for the cell, for example, SUM(C4:E4)
getCellFormula() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Return a formula for the cell, for example, SUM(C4:E4)
getCellFormula() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Return a formula for the cell, for example, SUM(C4:E4)
getCellMarginBottom() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getCellMarginLeft() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getCellMarginRight() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getCellMarginTop() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getCellNum() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Deprecated. (Oct 2008) use HSSFCell.getColumnIndex()
getCellOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
gets the options bitmask - you can also use corresponding option bit getters (see other methods that reference this one)
getCellRangeAddress() - Method in class org.apache.poi.hssf.record.DVRecord

getCellRangeAddress(int) - Method in class org.apache.poi.ss.util.CellRangeAddressList

getCellRangeAddresses() - Method in class org.apache.poi.ss.util.CellRangeAddressList

getCellRanges() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

getCellRef() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Get the reference of the cell this applies to, es A55
getCellRefParts() - Method in class org.apache.poi.ss.util.CellReference
Returns the three parts of the cell reference, the Sheet name (or null if none supplied), the 1 based row number, and the A based column letter.
getCellRefs() - Method in class org.apache.poi.hssf.record.FeatRecord

getCells() - Method in interface org.apache.poi.ss.usermodel.CellRange

getCells() - Method in class org.apache.poi.ss.util.SSCellRange

getCells() - Method in class org.apache.poi.xslf.usermodel.DrawingTableRow

getCells() - Method in class org.apache.poi.xslf.usermodel.XSLFTableRow

getCellStyle() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
get the style for the cell.
getCellStyle() - Method in interface org.apache.poi.ss.usermodel.Cell
Return the cell's style.
getCellStyle() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Return the cell's style.
getCellStyle() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Return the cell's style.
getCellStyleAt(short) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
get the cell style object at the given index
getCellStyleAt(short) - Method in interface org.apache.poi.ss.usermodel.Workbook
Get the cell style object at the given index
getCellStyleAt(short) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Get the cell style object at the given index
getCellStyleAt(short) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
gGet the cell style object at the given index
getCellStyleXfAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getCellType() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
get the cells type (numeric, formula or string)
getCellType() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getCellType() - Method in interface org.apache.poi.ss.usermodel.Cell
Return the cell type.
getCellType() - Method in class org.apache.poi.ss.usermodel.CellValue

getCellType() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Return the cell type.
getCellType() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Return the cell type.
getCellValueIterator() - Method in class org.apache.poi.hssf.model.InternalSheet
Get all the value records (from LOC).
getCellValueIterator() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
Returns an iterator for the cell values
getCellValueRecord() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Should only be used by HSSFSheet and friends.
getCellWidth(Cell, int, DataFormatter, boolean) - Static method in class org.apache.poi.ss.util.SheetUtil
Compute width of a single cell
getCellXfAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getCenter() - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

getCenter() - Method in interface org.apache.poi.ss.usermodel.Footer
Get the center of the footer.
getCenter() - Method in interface org.apache.poi.ss.usermodel.Header
Get the center of the header.
getCenter() - Method in interface org.apache.poi.ss.usermodel.HeaderFooter
Get the center of the header or footer.
getCenter() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
get the text representing the center part of this element
getCenterSection(String) - Method in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

getCh() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Type of field boundary the FLD describes: 19 -- field begin mark, 20 -- field separation mark; 21 -- field end mark
getChainLoopDetector() - Method in class org.apache.poi.poifs.filesystem.BlockStore
Creates a Detector for loops in the chain
getChainLoopDetector() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem

getChainLoopDetector() - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore

getChar() - Method in class org.apache.poi.xwpf.usermodel.PositionInParagraph

getCharacterPos() - Method in class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

getCharacterProperties(StyleSheet, short) - Method in class org.apache.poi.hwpf.model.CHPX

getCharacterProps(int, int) - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
Character properties for the specified text type and indent level.
getCharacterRun(int) - Method in class org.apache.poi.hwpf.usermodel.Range
Gets the character run at index.
getCharacterRunTriplet(CharacterRun) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

getCharactersCovered() - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection
Fetch the number of characters this styling applies to
getCharactersCovered() - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom
Get the number of characters covered by this records
getCharacterSpacing() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

getCharacterSpacing() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getCharacterSpacing() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getCharacterStyle(int) - Method in class org.apache.poi.hwpf.model.StyleSheet
Deprecated.
getCharacterStyles() - Method in class org.apache.poi.hslf.record.StyleTextPropAtom

getCharacterStyles() - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
Returns array of character styles defined in this record.
getCharacterTable() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getCharacterTextLengthCovered() - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Returns how many characters the character's TextPropCollections cover.
getCharCount() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the character count or 0 if the SummaryInformation does not contain a char count.
getCharCount() - Method in class org.apache.poi.hssf.record.common.UnicodeString
get the number of characters in the string, as an un-wrapped int
getCharCountShort() - Method in class org.apache.poi.hssf.record.common.UnicodeString
get the number of characters in the string, wrapped as needed to fit within a short
getCharIndex(int) - Method in interface org.apache.poi.hwpf.model.CharIndexTranslator
Deprecated. This API were based on incorrect assumption that single byte offset corresponds to single char offset
getCharIndex(int, int) - Method in interface org.apache.poi.hwpf.model.CharIndexTranslator
Deprecated. This API were based on incorrect assumption that single byte offset corresponds to single char offset
getCharIndex(int) - Method in class org.apache.poi.hwpf.model.TextPieceTable
Deprecated.
getCharIndex(int, int) - Method in class org.apache.poi.hwpf.model.TextPieceTable
Deprecated.
getCharIndexRanges(int, int) - Method in interface org.apache.poi.hwpf.model.CharIndexTranslator
Finds character ranges that includes specified byte range.
getCharIndexRanges(int, int) - Method in class org.apache.poi.hwpf.model.TextPieceTable

getCharSet() - Method in class org.apache.poi.hslf.model.PPFont
get the character set
getCharSet() - Method in class org.apache.poi.hslf.record.FontEntityAtom
get the character set
getCharset() - Method in class org.apache.poi.hssf.record.FontRecord
get the character set
getCharSet() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get character-set to use.
getCharSet() - Method in interface org.apache.poi.ss.usermodel.Font
get character-set to use.
getCharSet() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get character-set to use.
getCharsetFlags() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the CharsetFlags field for the CHP record.
getChartAxisFactory() - Method in interface org.apache.poi.ss.usermodel.Chart

getChartAxisFactory() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

getChartDataFactory() - Method in interface org.apache.poi.ss.usermodel.Chart

getChartDataFactory() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

getChartGroupIndex() - Method in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord
Get the chart group index field for the SeriesChartGroupIndex record.
getChartGroupIndex() - Method in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord
Get the chart group index field for the SeriesToChartGroup record.
getChartHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Get the height of the chart.
getCharts() - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Returns all charts in this drawing.
getChartTitle() - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Returns the chart's title, if there is one, or null if not
getChartWidth() - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Get the width of the chart.
getChartX() - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Get the X offset of the chart
getChartY() - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Get the Y offset of the chart
getCharWidth(char) - Method in class org.apache.poi.hssf.usermodel.FontDetails
Retrieves the width of the specified character.
getCheckCalculationErrors() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getCheckDateTimeFormats() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getCheckEmptyCellRef() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getCheckInconsistentFormulas() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getCheckInconsistentRanges() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getCheckNumbersAsText() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getChecksum() - Method in class org.apache.poi.hslf.blip.WMF.AldusHeader
Returns a checksum value for the previous 10 shorts in the header.
getChecksum(byte[]) - Static method in class org.apache.poi.hslf.usermodel.PictureData
Compute 16-byte checksum of this picture using MD5 algorithm.
getChecksum() - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData

getCheckUnprotectedFormulas() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getChHolder() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
ch field holder (along with reserved bits).
getChHres() - Method in class org.apache.poi.hwpf.model.types.HRESIAbstractType
The character that will be used to add or change a letter when hres is 2, 3, 5 or 6.
getChild(int) - Method in class org.apache.poi.ddf.EscherContainerRecord

getChild(int) - Method in class org.apache.poi.ddf.EscherRecord
Returns the indexed child record.
getChildById(short) - Method in class org.apache.poi.ddf.EscherContainerRecord

getChildContainers() - Method in class org.apache.poi.ddf.EscherContainerRecord
Returns all of our children which are also EscherContainers (may be 0, 1, or vary rarely 2 or 3)
getChildIndex() - Method in class org.apache.poi.poifs.property.Property
Get the child property (its index in the Property Table)
getChildIterator() - Method in class org.apache.poi.ddf.EscherContainerRecord

getChildPointers() - Method in class org.apache.poi.hdgf.streams.PointerContainingStream
Returns all the pointers that we contain
getChildRecords() - Method in class org.apache.poi.ddf.EscherContainerRecord

getChildRecords() - Method in class org.apache.poi.ddf.EscherRecord

getChildRecords() - Method in class org.apache.poi.ddf.UnknownEscherRecord

getChildRecords() - Method in class org.apache.poi.hslf.record.PPDrawing
We're pretending to be an atom, so return null
getChildRecords() - Method in class org.apache.poi.hslf.record.PPDrawingGroup
We're pretending to be an atom, so return null
getChildRecords() - Method in class org.apache.poi.hslf.record.Record
Fetch all the child records of this record If this record is an atom, will return null If this record is a non-atom, but has no children, will return an empty array
getChildRecords() - Method in class org.apache.poi.hslf.record.RecordAtom
We're an atom, returns null
getChildRecords() - Method in class org.apache.poi.hslf.record.RecordContainer
Return any children
getChildren() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Returns a list of all shapes contained by the patriarch.
getChildren() - Method in interface org.apache.poi.hssf.usermodel.HSSFShapeContainer

getChildren() - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Return all children contained by this shape.
getChildren() - Method in class org.apache.poi.poifs.property.DirectoryProperty
Get an iterator over the children of this Parent; all elements are instances of Property.
getChildren() - Method in interface org.apache.poi.poifs.property.Parent
Get an iterator over the children of this Parent; all elements are instances of Property.
getChooseFuncOffset() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

getCHorzBands() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Size of each horizontal style band, in number of rows.
getCHP() - Method in class org.apache.poi.hwpf.model.StyleDescription
Deprecated.
getCHPX(int) - Method in class org.apache.poi.hwpf.model.CHPFormattedDiskPage

getCHPX() - Method in class org.apache.poi.hwpf.model.StyleDescription

getCHPX(int) - Method in class org.apache.poi.hwpf.model.StyleSheet

getCHPXs() - Method in class org.apache.poi.hwpf.model.CHPFormattedDiskPage

getChs() - Method in class org.apache.poi.hwpf.model.Ffn

getChs() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value MUST be 0 and MUST be ignored.
getChse() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the chse field for the CHP record.
getChsTables() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value MUST be 0 and MUST be ignored.
getChunkId() - Method in class org.apache.poi.hsmf.datatypes.Chunk
Gets the id of this chunk
getChunks() - Method in class org.apache.poi.hdgf.streams.ChunkStream

getChunks() - Method in class org.apache.poi.hsmf.datatypes.AttachmentChunks

getChunks() - Method in interface org.apache.poi.hsmf.datatypes.ChunkGroup
Returns the chunks that make up the group.
getChunks() - Method in class org.apache.poi.hsmf.datatypes.Chunks

getChunks() - Method in class org.apache.poi.hsmf.datatypes.NameIdChunks

getChunks() - Method in class org.apache.poi.hsmf.datatypes.RecipientChunks

getCipherMode() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getCipherMode() - Method in class org.apache.poi.poifs.crypt.EncryptionVerifier

getClassID() - Method in class org.apache.poi.hpsf.PropertySet
Returns the property set stream's low-level "class ID" field.
getClassID() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getClfolvl() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Count of levels whose format is overridden (see LFOLVL).
getClientDataRecord(EscherContainerRecord, int) - Static method in class org.apache.poi.hslf.model.ShapeFactory

getClientDataRecord(int) - Method in class org.apache.poi.hslf.model.SimpleShape
Find a record in the underlying EscherClientDataRecord
getClientRecords() - Method in class org.apache.poi.hslf.model.SimpleShape
Search for EscherClientDataRecord, if found, convert its contents into an array of HSLF records
getCLines() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cLines field for the DOP record.
getCLinesFtnEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cLinesFtnEdn field for the DOP record.
getClip() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Gets the current clipping area.
getClip() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getClip() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

getClip() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getClipboardFormat() - Method in class org.apache.poi.hpsf.Thumbnail
Returns an int representing the Clipboard Format
getClipboardFormatTag() - Method in class org.apache.poi.hpsf.Thumbnail
Returns an int representing the Clipboard Format Tag
getClipboardName() - Method in class org.apache.poi.hslf.record.ExEmbed
Gets the name that appears in the paste special dialog.
getClipBounds() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns the bounding rectangle of the current clipping area.
getClipBounds() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getClipBounds(Rectangle) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getClipBounds() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

getClipBounds() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getClipRect() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getClipRect() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

getClm() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the clm field for the SEP record.
getCnsPgn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the cnsPgn field for the SEP record.
getCode() - Method in enum org.apache.poi.ss.usermodel.FormulaError

getCodepage() - Method in class org.apache.poi.hpsf.CustomProperties
Gets the codepage.
getCodepage() - Method in class org.apache.poi.hpsf.Section
Gets the section's codepage, if any.
getCodepage() - Method in class org.apache.poi.hssf.record.CodepageRecord
get the codepage for this workbook
getCol() - Method in class org.apache.poi.ss.util.CellReference

getCol1() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The column number for the top-left position.
getCol1() - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

getCol1() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the column (0 based) of the first cell.
getCol1() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getCol2() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The column of the bottom right corner of this shape.
getCol2() - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

getCol2() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the column (0 based) of the second cell.
getCol2() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getColapsed() - Method in class org.apache.poi.hssf.record.RowRecord
get whether or not to colapse this row
getColBandSize() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getColDefaultStyle(long) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

getColInputCol() - Method in class org.apache.poi.hssf.record.TableRecord

getColInputRow() - Method in class org.apache.poi.hssf.record.TableRecord

getCollapsed() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

getColLevelMax() - Method in class org.apache.poi.hssf.record.GutsRecord
get the maximum outline level for the col gutter.
getColor() - Method in interface org.apache.poi.common.usermodel.Fill

getColor() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Gets this graphics context's current color.
getColor(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Returns color by its index
getColor(HSSFColor) - Static method in class org.apache.poi.hssf.converter.AbstractExcelUtils

getColor(int) - Method in class org.apache.poi.hssf.record.PaletteRecord
Returns the color value at a given index
getColor() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getColor() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

getColor() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getColor() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get the color for the font
getColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPalette
Retrieves the color at a given index
getColor(int) - Method in class org.apache.poi.hssf.usermodel.HSSFPalette
Retrieves the color at a given index
getColor(int) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getColor() - Method in class org.apache.poi.hwpf.usermodel.BorderCode
Color: 0 Auto 1 Black 2 Blue 3 Cyan 4 Green 5 Magenta 6 Red 7 Yellow 8 White 9 DkBlue 10 DkCyan 11 DkGreen 12 DkMagenta 13 DkRed 14 DkYellow 15 DkGray 16 LtGray
getColor() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

getColor() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getColor() - Method in interface org.apache.poi.ss.usermodel.Font
get the color for the font
getColor() - Method in class org.apache.poi.xslf.usermodel.XSLFColor

getColor() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the indexed color value for the font References a color defined in IndexedColors.
getColor() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Get text color.
getColor() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
Get cell color.
getColor1() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

getColor2() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

getColor24(int) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getColor3() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

getColor4() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

getColorPaletteIndex() - Method in class org.apache.poi.hssf.record.FontRecord
get the font's color palette index
getColorScheme() - Method in class org.apache.poi.hslf.model.Sheet
Color scheme for this sheet.
getColorScheme() - Method in class org.apache.poi.hslf.model.Slide
Color scheme for this slide.
getColorScheme() - Method in class org.apache.poi.hslf.record.MainMaster

getColorScheme() - Method in class org.apache.poi.hslf.record.Notes

getColorScheme() - Method in class org.apache.poi.hslf.record.SheetContainer

getColorScheme() - Method in class org.apache.poi.hslf.record.Slide

getColorSchemeAtoms() - Method in class org.apache.poi.hslf.record.MainMaster

getColourPaletteIndex() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Get the colour palette index field for the LineFormat record.
getColumn() - Method in class org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord

getColumn() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

getColumn() - Method in class org.apache.poi.hssf.record.BlankRecord
get the column this cell defines within the row
getColumn() - Method in class org.apache.poi.hssf.record.CellRecord

getColumn() - Method in interface org.apache.poi.hssf.record.CellValueRecordInterface

getColumn() - Method in class org.apache.poi.hssf.record.LabelRecord

getColumn() - Method in class org.apache.poi.hssf.record.NoteRecord
Return the column that contains the comment
getColumn() - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Return the column of the cell that contains the comment
getColumn() - Method in interface org.apache.poi.ss.formula.eval.RefEval
returns the zero based column index.
getColumn() - Method in class org.apache.poi.ss.formula.eval.RefEvalBase

getColumn() - Method in class org.apache.poi.ss.formula.ptg.ExpPtg

getColumn() - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

getColumn() - Method in class org.apache.poi.ss.formula.ptg.TblPtg

getColumn(int) - Method in interface org.apache.poi.ss.formula.TwoDEval

getColumn() - Method in interface org.apache.poi.ss.usermodel.Comment
Return the column of the cell that contains the comment
getColumn(long, boolean) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper
Returns the Column at the given 0 based index
getColumn() - Method in class org.apache.poi.xssf.usermodel.XSSFComment

getColumn1Based(long, boolean) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper
Returns the Column at the given 1 based index.
getColumnBreaks() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

getColumnBreaks() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getColumnBreaks() - Method in interface org.apache.poi.ss.usermodel.Sheet
Retrieves all the vertical page breaks
getColumnBreaks() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Retrieves all the vertical page breaks
getColumnBreaks() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Vertical page break information used for print layout view, page layout view, drawing print breaks in normal view, and for printing the worksheet.
getColumnCount() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

getColumnFrom() - Method in class org.apache.poi.ss.util.Region
Deprecated. get the upper left hand corner column number
getColumnHelper() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getColumnIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFCell

getColumnIndex() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getColumnIndex() - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getColumnIndex() - Method in interface org.apache.poi.ss.usermodel.Cell
Returns column index of this cell
getColumnIndex() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Returns column index of this cell
getColumnIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns column index of this cell
getColumnName(int) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter
Generates name for output as column header in case AbstractExcelConverter.isOutputColumnHeaders() == true
getColumnNumber() - Method in interface org.apache.poi.ss.util.cellwalk.CellWalkContext
Returns number of current column.
getColumnStyle(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns the HSSFCellStyle that applies to the given (0 based) column, or null if no style has been set for that column
getColumnStyle(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
getColumnStyle(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
getColumnStyle(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
getColumnTo() - Method in class org.apache.poi.ss.util.Region
Deprecated. get the lower right hand corner column number
getColumnWidth(HSSFSheet, int) - Static method in class org.apache.poi.hssf.converter.AbstractExcelConverter

getColumnWidth(int) - Method in class org.apache.poi.hssf.model.InternalSheet
get the width of a given column in units of 1/256th of a character width
getColumnWidth() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

getColumnWidth(short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.getColumnWidth(int)
getColumnWidth(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get the width (in units of 1/256th of a character width )
getColumnWidth(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
get the width (in units of 1/256th of a character width )
getColumnWidth(Sheet, int, boolean) - Static method in class org.apache.poi.ss.util.SheetUtil
Compute width of a column and return the result
getColumnWidth(Sheet, int, boolean, int, int) - Static method in class org.apache.poi.ss.util.SheetUtil
Compute width of a column based on a subset of the rows and return the result
getColumnWidth(int) - Method in class org.apache.poi.xslf.usermodel.XSLFTable

getColumnWidth(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
get the width (in units of 1/256th of a character width )
getColumnWidth(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get the actual column width (in units of 1/256th of a character width )
getColumnWidthInPx(int) - Static method in class org.apache.poi.hssf.converter.AbstractExcelUtils
See here for Xio explanation and details
getColWidth() - Method in class org.apache.poi.hssf.record.DefaultColWidthRecord
get the default column width
getCommand() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the command field - usually the name of the file being embedded including the full path, may be a command specified during embedding the file.
getCommandDefinitions() - Method in class org.apache.poi.hdgf.chunks.Chunk
Gets the command definitions, which define and describe much of the data held by the chunk.
getCommands() - Method in class org.apache.poi.hdgf.chunks.Chunk

getComment() - Method in class org.apache.poi.hssf.usermodel.HSSFName
Returns the comment the user provided when the name was created.
getComment() - Method in interface org.apache.poi.ss.usermodel.Name
Returns the comment the user provided when the name was created.
getComment() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Returns the comment the user provided when the name was created.
getComment2000() - Method in class org.apache.poi.hslf.model.Comment

getComment2000Atom() - Method in class org.apache.poi.hslf.record.Comment2000
Returns the Comment2000Atom of this Comment
getCommentAt(int) - Method in class org.apache.poi.xslf.usermodel.XSLFComments

getCommentAuthors() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Returns the list of comment authors, if there is one.
getCommentByID(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getComments() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the comments (or null).
getComments() - Method in class org.apache.poi.hslf.model.Slide
Get the comment(s) for this slide.
getComments() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getComments() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getCommentsRange() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns the Range which covers all annotations.
getCommentsTable(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the sheet's comments object if there is one, or null if not
getCommentsText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor

getCommentText() - Method in class org.apache.poi.hssf.record.NameCommentRecord

getCommentText() - Method in class org.apache.poi.xwpf.model.XWPFCommentsDecorator

getCommonSlideData() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getCommonXpath() - Method in class org.apache.poi.xssf.usermodel.XSSFTable
Calculates the xpath of the root element for the table.
getCompany() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the company (or null).
getComparisonOperation() - Method in class org.apache.poi.hssf.record.CFRuleRecord

getComparisonOperation() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

getComparisonOperation() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
The comparison function used when the type of conditional formatting is set to ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS
getComparisonOperation() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
The comparison function used when the type of conditional formatting is set to ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS
getComplexData() - Method in class org.apache.poi.ddf.EscherComplexProperty
Get the complex data value.
getComponent(int) - Method in class org.apache.poi.poifs.filesystem.POIFSDocumentPath
get the specified component
getComposite() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns the current Composite in the Graphics2D context.
getComposite() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getComposite() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getCompressedSize() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getCompressedSize() - Method in class org.apache.poi.ddf.EscherPictBlip

getCompressedSize() - Method in class org.apache.poi.hmef.CompressedRTF
Returns how big the compressed version was.
getCompressionFlag() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Is the contents of the blip compressed?
getConditionalFormattingAt(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
gets Conditional Formatting object at a particular index
getConditionalFormattingAt(int) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Gets Conditional Formatting object at a particular index
getConditionalFormattingAt(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting
gets Conditional Formatting object at a particular index
getConditionalFormattingTable() - Method in class org.apache.poi.hssf.model.InternalSheet

getConditionOperator() - Method in class org.apache.poi.hssf.record.DVRecord
get the condition operator
getConditionType() - Method in class org.apache.poi.hssf.record.CFRuleRecord

getConditionType() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

getConditionType() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
Type of conditional formatting rule.
getConditionType() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
Type of conditional formatting rule.
getConstName(String, String, int) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getConstraint() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getContainerPartRelationship() - Static method in class org.apache.poi.openxml4j.opc.PackageRelationship

getContent() - Method in class org.apache.poi.hwpf.usermodel.Picture

getContents() - Method in class org.apache.poi.hdgf.streams.StreamStore

getContents() - Method in class org.apache.poi.hmef.Attachment
Returns the contents of the attachment.
getContents(PackagePart) - Method in class org.apache.poi.xssf.usermodel.XSSFRelation
Fetches the InputStream to read the contents, based of the specified core part, for which we are defined as a suitable relationship
getContentStatus() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getContentStatusProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get content status.
getContentStatusProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the status of the content.
getContentType(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Get the content type for the specified part, if any.
getContentType() - Method in class org.apache.poi.openxml4j.opc.PackagePart

getContentType() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getContentType() - Method in class org.apache.poi.POIXMLRelation
Return the content type.
getContentTypeFromFileExtension(String) - Static method in class org.apache.poi.openxml4j.opc.ContentTypes

getContentTypeProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get content type.
getContentTypeProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the type of content represented, generally defined by a specific use and intended audience.
getContentTypeZipEntry(ZipPackage) - Static method in class org.apache.poi.openxml4j.opc.internal.ZipHelper
Retrieve the Zip entry of the content types part.
getControlIndex() - Method in class org.apache.poi.hslf.model.ActiveXShape

getConversationTopic() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the conversation topic of the parsed Outlook Message.
getCoordinates() - Method in class org.apache.poi.hslf.model.ShapeGroup
Gets the coordinate space of this group.
getCopies() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getCopies() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the number of copies.
getCopies() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the number of copies.
getCopies() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the number of copies.
getCopt() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Collection of the 5 flags.
getCorePart() - Method in class org.apache.poi.POIXMLDocument

getCoreProperties() - Method in class org.apache.poi.POIXMLProperties
Returns the core document properties
getCoreProperties() - Method in class org.apache.poi.POIXMLTextExtractor
Returns the core document properties
getCoreProperties() - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Returns the core document properties
getCorePropertiesText() - Method in class org.apache.poi.POIXMLPropertiesTextExtractor
Returns the core document properties, eg author
getCorePropertiesZipEntry(ZipPackage) - Static method in class org.apache.poi.openxml4j.opc.internal.ZipHelper
Retrieve the zip entry of the core properties part.
getCoreXf() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Used so that StylesSource can figure out our location
getCount() - Method in class org.apache.poi.hssf.record.FnGroupCountRecord
get the number of built-in functions
getCount() - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
Return an integer representing the total count of strings in the workbook.
getCount() - Method in class org.apache.poi.xssf.model.SharedStringsTable
Return an integer representing the total count of strings in the workbook.
getCountOfLinesToDrop() - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

getCountRead() - Method in class org.apache.poi.hssf.model.RecordStream

getCP() - Method in class org.apache.poi.hwpf.model.SinglentonTextPiece

getCP() - Method in class org.apache.poi.hwpf.model.TextPiece
Returns the character position we start at.
getCParas() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cParas field for the DOP record.
getCParasFtnEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cParasFtnEdn field for the DOP record.
getCpg() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Code page of run in pre-Unicode files.
getCPg() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cPg field for the DOP record.
getCPgFtnEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cPgFtnEdn field for the DOP record.
getCpMin() - Method in class org.apache.poi.hwpf.model.TextPieceTable

getCProps() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This value MUST be 0 and MUST be ignored.
getCQuickSaves() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
An unsigned integer.
getCreated() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getCreateDateTime() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the creation time (or null).
getCreatedProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get created date.
getCreatedProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the date of creation of the resource.
getCreatedPropertyString() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get created date formated into a String.
getCreateEmptyCells() - Method in class org.apache.poi.ss.util.SheetBuilder
Returns true if null array elements should be treated as empty cells.
getCreationHelper() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getCreationHelper() - Method in interface org.apache.poi.ss.usermodel.Workbook
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
getCreationHelper() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
getCreationHelper() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Returns an object that handles instantiating concrete classes of the various instances for XSSF.
getCreator() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getCreatorProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get creator.
getCreatorProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the entity primarily responsible for making the content of the resource.
getCrossBetween() - Method in interface org.apache.poi.ss.usermodel.charts.ValueAxis

getCrossBetween() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

getCrosses() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getCrosses() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getCrossingPoint() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the crossing point field for the AxisOptions record.
getCrossingPoint() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Get the crossing point field for the CategorySeriesAxis record.
getCspName() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getCssClassPrefixCell() - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

getCssClassPrefixDiv() - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

getCssClassPrefixRow() - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

getCssClassPrefixTable() - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

getCstd() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the count of elements in STSH.rglpstd.
getCTAbstractNum() - Method in class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

getCTAxPos() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getCTAxPos() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

getCTBorder() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Returns the underlying XML bean.
getCTCalcChain() - Method in class org.apache.poi.xssf.model.CalculationChain

getCTCell() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns the xml bean containing information about the cell's location (reference), value, data type, formatting, and formula
getCTCellAlignment() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Access to low-level data
getCTChart() - Method in class org.apache.poi.xssf.usermodel.XSSFChart
Return the underlying CTChart bean, within the Chart Space
getCTChartsheet() - Method in class org.apache.poi.xssf.usermodel.XSSFChartSheet
Provide access to the CTChartsheet bean holding this sheet's data
getCTChartSpace() - Method in class org.apache.poi.xssf.usermodel.XSSFChart
Return the underlying CTChartSpace bean, the root element of the SpreadsheetML Chart part.
getCTColor() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Returns the underlying XML bean
getCTComment(String) - Method in class org.apache.poi.xssf.model.CommentsTable

getCTComment() - Method in class org.apache.poi.xssf.usermodel.XSSFComment

getCTCommentAuthorsList() - Method in class org.apache.poi.xslf.usermodel.XSLFCommentAuthors

getCTComments() - Method in class org.apache.poi.xssf.model.CommentsTable

getCTCommentsList() - Method in class org.apache.poi.xslf.usermodel.XSLFComments

getCTConnector() - Method in class org.apache.poi.xssf.usermodel.XSSFConnector

getCTCrosses() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getCTCrosses() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

getCTDrawing() - Method in class org.apache.poi.xssf.usermodel.XSSFChartSheet

getCTDrawing() - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing
Return the underlying CTDrawing bean, the root element of the SpreadsheetML Drawing part.
getCTDrawing() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getCTFill() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Returns the underlying XML bean.
getCTFont() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the underlying CTFont font
getCTFtnEdn() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getCTGraphicalObjectFrame() - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame

getCTGroupShape() - Method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup

getCTHyperlink() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink

getCTHyperlink() - Method in class org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

getCTLegacyDrawing() - Method in class org.apache.poi.xssf.usermodel.XSSFChartSheet

getCTLegacyDrawing() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getCTLegend() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartLegend
Return the underlying CTLegend bean.
getCTManualLayout() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout
Return the underlying CTManualLayout bean.
getCtMap() - Method in class org.apache.poi.xssf.usermodel.XSSFMap

getCTMapInfo() - Method in class org.apache.poi.xssf.model.MapInfo

getCTName() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Returns the underlying named range object
getCTNum() - Method in class org.apache.poi.xwpf.usermodel.XWPFNum

getCTNumFmt() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getCTNumFmt() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

getCTP() - Method in class org.apache.poi.xwpf.model.XMLParagraph

getCTP() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph

getCTPicture() - Method in class org.apache.poi.xssf.usermodel.XSSFPicture
Return the underlying CTPicture bean that holds all properties for this picture
getCTPicture() - Method in class org.apache.poi.xwpf.usermodel.XWPFPicture
Return the underlying CTPicture bean that holds all properties for this picture
getCTPlaceholder() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getCTPresentation() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow

getCTR() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Get the currently used CTR object
getCTRow() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Returns the underlying CTRow xml bean containing all cell definitions in this row
getCtRow() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow

getCTRst() - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Return the underlying xml bean
getCTScaling() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getCTScaling() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

getCTSchema() - Method in class org.apache.poi.xssf.usermodel.XSSFMap

getCTSchemaById(String) - Method in class org.apache.poi.xssf.model.MapInfo
Gets the
getCTShape() - Method in class org.apache.poi.xssf.usermodel.XSSFComment

getCTShape() - Method in class org.apache.poi.xssf.usermodel.XSSFSimpleShape

getCTSingleXMLCells() - Method in class org.apache.poi.xssf.model.SingleXmlCells

getCTStyle() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
get ctStyle
getCTStylesheet() - Method in class org.apache.poi.xssf.model.StylesTable
For unit testing only!
getCTTable() - Method in class org.apache.poi.xslf.usermodel.XSLFTable

getCTTable() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getCTTbl() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getCTTc() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getCTTransform2D() - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

getCTWorkbook() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Return the underlying XML bean
getCTWorksheet() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Provide access to the CTWorksheet bean holding this sheet's data
getCTxbx() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Count of textboxes in shape (undo doc only).
getCupx() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
number of UPXs (and UPEs)
getCurrentCountry() - Method in class org.apache.poi.hssf.record.CountryRecord
gets the current country
getCurrentEditOffset() - Method in class org.apache.poi.hslf.record.CurrentUserAtom
Points to the UserEditAtom
getCurrentUserAtom() - Method in class org.apache.poi.hslf.HSLFSlideShow
Fetch the Current User Atom of the document
getCurrentUserPassword() - Static method in class org.apache.poi.hssf.record.crypto.Biff8EncryptionKey

getCustomMenuText() - Method in class org.apache.poi.hssf.record.NameRecord
get the custom menu text
getCustomPalette() - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns the custom palette in use for this workbook; if a custom palette record does not exist, then it is created.
getCustomPalette() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getCustomProperties() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Gets the custom properties.
getCustomProperties() - Method in class org.apache.poi.POIXMLProperties
Returns the custom document properties
getCustomProperties() - Method in class org.apache.poi.POIXMLTextExtractor
Returns the custom document properties
getCustomProperties() - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Returns the custom document properties
getCustomPropertiesText() - Method in class org.apache.poi.POIXMLPropertiesTextExtractor
Returns the custom document properties, if there are any
getCustomXMLMappings() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

getCv() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
24-bit color.
getCvBack() - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType
24-bit background color.
getCVertBands() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Size of a vertical style band, in number of columns.
getCvFore() - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType
24-bit foreground color.
getCWords() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cWords field for the DOP record.
getCWordsFtnEnd() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the cWordsFtnEnd field for the DOP record.
getData() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
The BLIP data
getData() - Method in class org.apache.poi.ddf.EscherTextboxRecord
Returns any extra data associated with this record.
getData() - Method in class org.apache.poi.ddf.UnknownEscherRecord

getData() - Method in class org.apache.poi.hmef.attribute.MAPIAttribute

getData() - Method in class org.apache.poi.hmef.attribute.MAPIRtfAttribute
Returns the raw uncompressed RTF data
getData() - Method in class org.apache.poi.hmef.attribute.TNEFAttribute

getData() - Method in class org.apache.poi.hpbf.model.HPBFPart
Returns the raw data that makes up this document part.
getData() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

getData() - Method in class org.apache.poi.hslf.blip.Bitmap

getData() - Method in class org.apache.poi.hslf.blip.DIB

getData() - Method in class org.apache.poi.hslf.blip.EMF
Extract compressed EMF data from a ppt
getData() - Method in class org.apache.poi.hslf.blip.PICT
Extract compressed PICT data from a ppt
getData() - Method in class org.apache.poi.hslf.blip.PNG

getData() - Method in class org.apache.poi.hslf.blip.WMF
Extract compressed WMF data from a ppt
getData() - Method in class org.apache.poi.hslf.record.ExOleObjStg
Opens an input stream which will decompress the data on the fly.
getData() - Method in class org.apache.poi.hslf.record.SoundData
Returns the sound data.
getData() - Method in class org.apache.poi.hslf.usermodel.ObjectData
Gets an input stream which returns the binary of the embedded data.
getData() - Method in class org.apache.poi.hslf.usermodel.PictureData
Returns the binary data of this Picture
getData() - Method in class org.apache.poi.hslf.usermodel.SoundData
Gets an input stream which returns the binary of the sound data.
getData() - Method in class org.apache.poi.hssf.record.ContinueRecord
get the data for continuation
getData() - Method in class org.apache.poi.hssf.record.DrawingRecord

getData() - Method in class org.apache.poi.hssf.usermodel.HSSFPictureData

getData() - Method in interface org.apache.poi.poifs.storage.ListManagedBlock
Get the data from the block
getData() - Method in class org.apache.poi.poifs.storage.RawDataBlock
Get the data from the block
getData() - Method in class org.apache.poi.poifs.storage.SmallDocumentBlock
Get the data from the block
getData() - Method in interface org.apache.poi.sl.usermodel.PictureData

getData() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

getData() - Method in interface org.apache.poi.ss.usermodel.PictureData
Gets the picture data.
getData() - Method in class org.apache.poi.xslf.usermodel.XSLFPictureData
Gets the picture data as a byte array.
getData() - Method in class org.apache.poi.xssf.usermodel.XSSFPictureData
Gets the picture data as a byte array.
getData() - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData
Gets the picture data as a byte array.
getDataBuffer() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the buffer containing the embedded file's data, or null if no data was embedded.
getDataCategoryLabels() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getDataFormat() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the index of the format
getDataFormat() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the index of the format
getDataFormat() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the index of the number format (numFmt) record used by this cell format.
getDataFormatString() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Get the contents of the format string, by looking up the DataFormat against the bound workbook
getDataFormatString(Workbook) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Get the contents of the format string, by looking up the DataFormat against the supplied workbook
getDataFormatString(InternalWorkbook) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Get the contents of the format string, by looking up the DataFormat against the supplied low level workbook
getDataFormatString() - Method in interface org.apache.poi.ss.usermodel.CellStyle
Get the format string
getDataFormatString() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the contents of the format string, by looking up the StylesSource
getDataInputBlock(DocumentBlock[], int) - Static method in class org.apache.poi.poifs.storage.DocumentBlock

getDataInputBlock(SmallDocumentBlock[], int) - Static method in class org.apache.poi.poifs.storage.SmallDocumentBlock

getDataLabelPlacement() - Method in class org.apache.poi.hssf.record.chart.TextRecord

getDataLength() - Method in class org.apache.poi.hslf.record.ExOleObjStg
Gets the uncompressed length of the data.
getDataName() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getDataOffset() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

getDataSecondaryCategoryLabels() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getDataSize() - Method in class org.apache.poi.hssf.record.AutoFilterInfoRecord

getDataSize() - Method in class org.apache.poi.hssf.record.BackupRecord

getDataSize() - Method in class org.apache.poi.hssf.record.BlankRecord

getDataSize() - Method in class org.apache.poi.hssf.record.BOFRecord

getDataSize() - Method in class org.apache.poi.hssf.record.BookBoolRecord

getDataSize() - Method in class org.apache.poi.hssf.record.BottomMarginRecord

getDataSize() - Method in class org.apache.poi.hssf.record.BoundSheetRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CalcCountRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CalcModeRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CellRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CFRuleRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.AreaRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.AxisRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.AxisUsedRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.BarRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.BeginRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.CatLabRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartEndObjectRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartStartObjectRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.DatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.EndRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.FontIndexRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.FrameRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.LegendRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.PlotAreaRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SeriesIndexRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SeriesListRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.TextRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.TickRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.UnitsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CodepageRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

getDataSize() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getDataSize() - Method in class org.apache.poi.hssf.record.common.FeatProtection

getDataSize() - Method in class org.apache.poi.hssf.record.common.FeatSmartTag

getDataSize() - Static method in class org.apache.poi.hssf.record.common.FtrHeader

getDataSize() - Method in interface org.apache.poi.hssf.record.common.SharedFeature

getDataSize() - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst
Returns our size, excluding our 4 byte header
getDataSize() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ContinueRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CountryRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CRNCountRecord

getDataSize() - Method in class org.apache.poi.hssf.record.CRNRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DateWindow1904Record

getDataSize() - Method in class org.apache.poi.hssf.record.DBCellRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DConRefRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DefaultColWidthRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DeltaRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DimensionsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DrawingRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DrawingSelectionRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DSFRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DVALRecord

getDataSize() - Method in class org.apache.poi.hssf.record.DVRecord

getDataSize() - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.EndSubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.EOFRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ExternalNameRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ExternSheetRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ExtSSTRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FeatHdrRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FeatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FilePassRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FileSharingRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FnGroupCountRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FontRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FormatRecord

getDataSize() - Method in class org.apache.poi.hssf.record.FtCblsSubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.GridsetRecord

getDataSize() - Method in class org.apache.poi.hssf.record.GroupMarkerSubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.GutsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.HCenterRecord

getDataSize() - Method in class org.apache.poi.hssf.record.HeaderFooterBase

getDataSize() - Method in class org.apache.poi.hssf.record.HeaderFooterRecord

getDataSize() - Method in class org.apache.poi.hssf.record.HideObjRecord

getDataSize() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getDataSize() - Method in class org.apache.poi.hssf.record.IndexRecord

getDataSize() - Method in class org.apache.poi.hssf.record.InterfaceEndRecord

getDataSize() - Method in class org.apache.poi.hssf.record.InterfaceHdrRecord

getDataSize() - Method in class org.apache.poi.hssf.record.IterationRecord

getDataSize() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

getDataSize() - Method in class org.apache.poi.hssf.record.LeftMarginRecord

getDataSize() - Method in class org.apache.poi.hssf.record.MergeCellsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.MMSRecord

getDataSize() - Method in class org.apache.poi.hssf.record.MulBlankRecord

getDataSize() - Method in class org.apache.poi.hssf.record.MulRKRecord

getDataSize() - Method in class org.apache.poi.hssf.record.NameCommentRecord

getDataSize() - Method in class org.apache.poi.hssf.record.NameRecord

getDataSize() - Method in class org.apache.poi.hssf.record.NoteRecord

getDataSize() - Method in class org.apache.poi.hssf.record.NoteStructureSubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ObjectProtectRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PageBreakRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PaletteRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PaneRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PasswordRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PasswordRev4Record

getDataSize() - Method in class org.apache.poi.hssf.record.pivottable.DataItemRecord

getDataSize() - Method in class org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.pivottable.PageItemRecord

getDataSize() - Method in class org.apache.poi.hssf.record.pivottable.StreamIDRecord

getDataSize() - Method in class org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

getDataSize() - Method in class org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

getDataSize() - Method in class org.apache.poi.hssf.record.pivottable.ViewSourceRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PrecisionRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PrintGridlinesRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PrintHeadersRecord

getDataSize() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ProtectionRev4Record

getDataSize() - Method in class org.apache.poi.hssf.record.ProtectRecord

getDataSize() - Method in class org.apache.poi.hssf.record.RecalcIdRecord

getDataSize() - Method in class org.apache.poi.hssf.record.RefModeRecord

getDataSize() - Method in class org.apache.poi.hssf.record.RefreshAllRecord

getDataSize() - Method in class org.apache.poi.hssf.record.RightMarginRecord

getDataSize() - Method in class org.apache.poi.hssf.record.RowRecord

getDataSize() - Method in class org.apache.poi.hssf.record.SaveRecalcRecord

getDataSize() - Method in class org.apache.poi.hssf.record.ScenarioProtectRecord

getDataSize() - Method in class org.apache.poi.hssf.record.SCLRecord

getDataSize() - Method in class org.apache.poi.hssf.record.SelectionRecord

getDataSize() - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

getDataSize() - Method in class org.apache.poi.hssf.record.StandardRecord

getDataSize() - Method in class org.apache.poi.hssf.record.StyleRecord

getDataSize() - Method in class org.apache.poi.hssf.record.SubRecord

getDataSize() - Method in class org.apache.poi.hssf.record.SupBookRecord

getDataSize() - Method in class org.apache.poi.hssf.record.TabIdRecord

getDataSize() - Method in class org.apache.poi.hssf.record.TableStylesRecord

getDataSize() - Method in class org.apache.poi.hssf.record.TopMarginRecord

getDataSize() - Method in class org.apache.poi.hssf.record.UncalcedRecord

getDataSize() - Method in class org.apache.poi.hssf.record.UnknownRecord

getDataSize() - Method in class org.apache.poi.hssf.record.UserSViewBegin

getDataSize() - Method in class org.apache.poi.hssf.record.UserSViewEnd

getDataSize() - Method in class org.apache.poi.hssf.record.UseSelFSRecord

getDataSize() - Method in class org.apache.poi.hssf.record.VCenterRecord

getDataSize() - Method in class org.apache.poi.hssf.record.WindowOneRecord

getDataSize() - Method in class org.apache.poi.hssf.record.WindowProtectRecord

getDataSize() - Method in class org.apache.poi.hssf.record.WindowTwoRecord

getDataSize() - Method in class org.apache.poi.hssf.record.WriteAccessRecord

getDataSize() - Method in class org.apache.poi.hssf.record.WriteProtectRecord

getDataSize() - Method in class org.apache.poi.hssf.record.WSBoolRecord

getDataSize() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the size of the embedded file.
getDataStream() - Method in class org.apache.poi.hwpf.HWPFDocument

getDataStream(DirectoryNode) - Method in class org.apache.poi.poifs.crypt.AgileDecryptor

getDataStream(DirectoryNode) - Method in class org.apache.poi.poifs.crypt.Decryptor
Return a stream with decrypted data.
getDataStream(NPOIFSFileSystem) - Method in class org.apache.poi.poifs.crypt.Decryptor

getDataStream(POIFSFileSystem) - Method in class org.apache.poi.poifs.crypt.Decryptor

getDataStream(DirectoryNode) - Method in class org.apache.poi.poifs.crypt.EcmaDecryptor

getDataString() - Method in class org.apache.poi.hmef.attribute.MAPIRtfAttribute
Returns the uncompressed RTF as a string
getDataString() - Method in class org.apache.poi.hmef.attribute.MAPIStringAttribute

getDataType() - Method in class org.apache.poi.hssf.record.DVRecord

getDataValidationHelper() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getDataValidationHelper() - Method in interface org.apache.poi.ss.usermodel.Sheet

getDataValidationHelper() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet

getDataValidationHelper() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getDataValidations() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getDataValues() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getDate() - Method in class org.apache.poi.hmef.attribute.MAPIDateAttribute

getDate() - Method in class org.apache.poi.hmef.attribute.TNEFDateAttribute

getDate() - Method in class org.apache.poi.hslf.record.Comment2000Atom
Gets the date the comment was made.
getDate(byte[]) - Static method in class org.apache.poi.hslf.util.SystemTimeUtils
Get the date found in the byte array, as a java Data object
getDate(byte[], int) - Static method in class org.apache.poi.hslf.util.SystemTimeUtils
Get the date found in the byte array, as a java Data object
getDate() - Method in class org.apache.poi.hwpf.usermodel.DateAndTime

getDateCellValue() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Get the value of the cell as a date.
getDateCellValue() - Method in interface org.apache.poi.ss.usermodel.Cell
Get the value of the cell as a date.
getDateCellValue() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Get the value of the cell as a date.
getDateCellValue() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Get the value of the cell as a date.
getDateTimeFormat() - Method in class org.apache.poi.hslf.model.HeadersFooters
An integer that specifies the format ID to be used to style the datetime.
getDateTimeText() - Method in class org.apache.poi.hslf.model.HeadersFooters
This is the date that the user wants in the footers, instead of today's date.
getDbcellAt(int) - Method in class org.apache.poi.hssf.record.IndexRecord

getDcs() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dcs field for the PAP record.
getDebugInfo() - Method in class org.apache.poi.hssf.record.common.UnicodeString
return a character representation of the fields of this record
getDeCompressedSize() - Method in class org.apache.poi.hmef.CompressedRTF
Returns how big the decompressed version was.
getDefaultColumnWidth(HSSFSheet) - Static method in class org.apache.poi.hssf.converter.AbstractExcelConverter

getDefaultColumnWidth() - Method in class org.apache.poi.hssf.model.InternalSheet
get the default column width for the sheet (if the columns do not define their own width)
getDefaultColumnWidth() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get the default column width for the sheet (if the columns do not define their own width) in characters
getDefaultColumnWidth() - Method in interface org.apache.poi.ss.usermodel.Sheet
Get the default column width for the sheet (if the columns do not define their own width) in characters
getDefaultColumnWidth() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Get the default column width for the sheet (if the columns do not define their own width) in characters
getDefaultColumnWidth() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get the default column width for the sheet (if the columns do not define their own width) in characters.
getDefaultCountry() - Method in class org.apache.poi.hssf.record.CountryRecord
gets the default country
getDefaultFileName() - Method in class org.apache.poi.POIXMLRelation
Return the default part name.
getDefaultFooter() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

getDefaultFormat(Cell) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Returns a default format for a cell.
getDefaultHeader() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get whether the window should display a default header
getDefaultHeader() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.AreaErrPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.ControlPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.MemAreaPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.MemErrPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.MemFuncPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.NamePtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.OperationPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.Ptg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.RefErrorPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.ScalarConstantPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.UnknownPtg

getDefaultOperandClass() - Method in class org.apache.poi.ss.formula.ptg.ValueOperatorPtg

getDefaultRowHeight() - Method in class org.apache.poi.hssf.model.InternalSheet
get the default row height for the sheet (if the rows do not define their own height)
getDefaultRowHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
getDefaultRowHeight() - Method in interface org.apache.poi.ss.usermodel.Sheet
Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
getDefaultRowHeight() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
getDefaultRowHeight() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
getDefaultRowHeightInPoints() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get the default row height for the sheet (if the rows do not define their own height) in points.
getDefaultRowHeightInPoints() - Method in interface org.apache.poi.ss.usermodel.Sheet
Get the default row height for the sheet (if the rows do not define their own height) in points.
getDefaultRowHeightInPoints() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Get the default row height for the sheet (if the rows do not define their own height) in points.
getDefaultRowHeightInPoints() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get the default row height for the sheet measued in point size (if the rows do not define their own height).
getDefaultTabSize() - Method in class org.apache.poi.hslf.record.TextRulerAtom
Default distance between tab stops, in master coordinates (576 dpi).
getDefaultTabSize() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getDefinition() - Method in class org.apache.poi.hdgf.chunks.Chunk.Command

getDelayTime() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A signed integer that specifies the delay time, in milliseconds, before the animation starts to play.
getDelMenuCount() - Method in class org.apache.poi.hssf.record.MMSRecord
get number of add del options (should be 0)
getDenominator() - Method in class org.apache.poi.hssf.record.SCLRecord
Get the denominator field for the SCL record.
getDescription() - Method in class org.apache.poi.ddf.EscherPropertyMetaData

getDescription() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getDescription() - Method in class org.apache.poi.xwpf.usermodel.XWPFPicture

getDescriptionProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get description.
getDescriptionProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the explanation of the content of the resource.
getDescriptionText() - Method in class org.apache.poi.hssf.record.NameRecord
gets the description text
getDescriptor(int) - Method in class org.apache.poi.hwpf.model.NotesTables

getDescriptor() - Method in class org.apache.poi.hwpf.usermodel.TableCell
Returns the TableCellDescriptor for this cell.
getDescriptorFirst(int) - Method in class org.apache.poi.hwpf.model.BookmarksTables

getDescriptorFirstIndex(GenericPropertyNode) - Method in class org.apache.poi.hwpf.model.BookmarksTables

getDescriptorLim(int) - Method in class org.apache.poi.hwpf.model.BookmarksTables

getDescriptorsCount() - Method in class org.apache.poi.hwpf.model.NotesTables

getDescriptorsFirstCount() - Method in class org.apache.poi.hwpf.model.BookmarksTables

getDescriptorsLimCount() - Method in class org.apache.poi.hwpf.model.BookmarksTables

getDeviceConfiguration() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns the device configuration associated with this Graphics2D.
getDeviceConfiguration() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getDeviceConfiguration() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getDgContainers() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder

getDgg() - Method in class org.apache.poi.hssf.model.DrawingManager

getDgg() - Method in class org.apache.poi.hssf.model.DrawingManager2

getDggContainer() - Method in class org.apache.poi.hslf.record.PPDrawingGroup

getDggContainers() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder

getDiag() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
Not sure what this is for (maybe fill lines?) 1 = down, 2 = up, 3 = both, 0 for none..
getDiagonalBorderColor() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the color to use for the diagonal border
getDiagonalBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getDiagonalBorderColor() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getDiagonalBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getDialog() - Method in class org.apache.poi.hssf.record.WSBoolRecord
get whether sheet is a dialog sheet or not
getDialog() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get whether sheet is a dialog sheet or not
getDialog() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getDictionary() - Method in class org.apache.poi.hpsf.Section
Gets the section's dictionary.
getDimColor() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A rgb structure that specifies a color for the dim effect after the animation is complete.
getDirectory() - Method in class org.apache.poi.hsmf.datatypes.DirectoryChunk
Returns the directory entry for this chunk.
getDirectory() - Method in class org.apache.poi.hssf.usermodel.HSSFObjectData
Gets the object data.
getDirectory(File) - Static method in class org.apache.poi.openxml4j.opc.internal.FileHelper
Get the directory part of the specified file path.
getDiskLen(Record) - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

getDisplayBCC() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the display value of the "BCC" line of the outlook message.
getDisplayCC() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the display value of the "CC" line of the outlook message.
getDisplayedTab() - Method in class org.apache.poi.hssf.record.WindowOneRecord
Deprecated. - Misleading name - use getFirstVisibleTab()
getDisplayedTab() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. - Misleading name - use getFirstVisibleTab()
getDisplayFormulas() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get whether the window should display formulas
getDisplayFrom() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the display value of the "FROM" line of the outlook message This is not the actual address that was sent from but the formated display of the user name.
getDisplayGridlines() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get whether the window should display gridlines
getDisplayGuts() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get whether the outline symbols are displaed
getDisplayGuts() - Method in class org.apache.poi.hssf.record.WSBoolRecord
get whether to display the guts or not
getDisplayGuts() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get whether to display the guts or not
getDisplayGuts() - Method in interface org.apache.poi.ss.usermodel.Sheet
Get whether to display the guts or not, default value is true
getDisplayGuts() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Get whether to display the guts or not, default value is true
getDisplayGuts() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get whether to display the guts or not, default value is true
getDisplayHorizontalScrollbar() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get whether to display the horizontal scrollbar or not
getDisplayMode() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the display mode field for the Text record.
getDisplayName() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getDisplayRowColHeadings() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get whether the window should display row and column headings
getDisplayTabs() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get whether to display the tabs or not
getDisplayTo() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the display value of the "TO" line of the outlook message.
getDisplayVerticalScrollbar() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get whether to display the vertical scrollbar or not
getDisplayZeros() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get whether the window should display zero values
getDistance() - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

getDistanceBetweenColumns() - Method in class org.apache.poi.hwpf.usermodel.Section

getDmBinFirst() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dmBinFirst field for the SEP record.
getDmBinOther() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dmBinOther field for the SEP record.
getDmOrientFirst() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dmOrientFirst field for the SEP record.
getDmOrientPage() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dmOrientPage field for the SEP record.
getDmPaperReq() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dmPaperReq field for the SEP record.
getDocFinalVersion() - Method in class org.apache.poi.hslf.record.CurrentUserAtom

getDocId() - Method in class org.apache.poi.hssf.record.FilePassRecord

getDocinfo() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the docinfo field for the DOP record.
getDocinfo1() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the docinfo1 field for the DOP record.
getDocinfo2() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the docinfo2 field for the DOP record.
getDocinfo3() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the docinfo3 field for the DOP record.
getDocinfo4() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the docinfo4 field for the DOP record.
getDocinfo5() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the docinfo5 field for the DOP record.
getDocinfo6() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the docinfo6 field for the DOP record.
getDocMajorNo() - Method in class org.apache.poi.hslf.record.CurrentUserAtom

getDocMinorNo() - Method in class org.apache.poi.hslf.record.CurrentUserAtom

getDocparts() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the doc parts (or null) when this method is implemented.
getDocPersistRef() - Method in class org.apache.poi.hslf.record.UserEditAtom

getDocProperties() - Method in class org.apache.poi.hwpf.HWPFDocument

getDocSummaryInformation() - Method in class org.apache.poi.hssf.extractor.EventBasedExcelExtractor
Would return the document information metadata for the document, if we supported it
getDocSummaryInformation() - Method in class org.apache.poi.POIOLE2TextExtractor
Returns the document information metadata for the document
getDocument() - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

getDocument() - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

getDocument() - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

getDocument() - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

getDocument() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

getDocument() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

getDocument() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

getDocument() - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

getDocument() - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

getDocument() - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

getDocument() - Method in class org.apache.poi.hwpf.usermodel.Range

getDocument() - Method in class org.apache.poi.poifs.property.DocumentProperty
get the POIFSDocument
getDocument() - Method in class org.apache.poi.POIXMLTextExtractor
Returns opened document
getDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Returns the low level document base object
getDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph

getDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun

getDocumentAtom() - Method in class org.apache.poi.hslf.record.Document
Returns the DocumentAtom of this Document
getDocumentRecord() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Helper method for usermodel and model: Get the document record
getDocumentSize() - Method in class org.apache.poi.hdgf.HDGFDiagram

getDocumentSummaryInformation() - Method in class org.apache.poi.POIDocument
Fetch the Document Summary Information of the document
getDocumentSummaryInformationProperties() - Static method in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Returns the Document Summary Information properties singleton.
getDocumentSummaryInformationText() - Method in class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

getDocumentText() - Method in class org.apache.poi.hwpf.HWPFDocumentCore
Returns document text, i.e.
getDogrid() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the dogrid field for the DOP record.
getDoptypography() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the doptypography field for the DOP record.
getDouble(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get a double value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java double
getDouble(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get a double value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java double
getDraft() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getDraft() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the draft mode.
getDraft() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the draft mode.
getDraft() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the draft mode.
getDrawAreaHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFPolygon

getDrawAreaWidth() - Method in class org.apache.poi.hssf.usermodel.HSSFPolygon

getDrawAspect() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Gets whether the object can be completely seen, or if only the icon is visible.
getDrawing() - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Return the drawing that owns this shape
getDrawingEscherAggregate() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns the agregate escher records for this sheet, it there is one.
getDrawingGroupId() - Method in class org.apache.poi.ddf.EscherDggRecord.FileIdCluster

getDrawingGroupId() - Method in class org.apache.poi.ddf.EscherDgRecord
Gets the drawing group id for this record.
getDrawingManager() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getDrawingPatriarch() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns the top-level drawing patriach, if there is one.
getDrawingsSaved() - Method in class org.apache.poi.ddf.EscherDggRecord

getDrawingText() - Method in class org.apache.poi.xslf.usermodel.XSLFCommonSlideData

getDropCap() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getDropCap() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getDropCapType() - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

getDttmConflict() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When the change was made.
getDttmCreated() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the dttmCreated field for the DOP record.
getDttmDispFldRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
The date for the ListNum field number change.
getDttmLastPrint() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the dttmLastPrint field for the DOP record.
getDttmPropRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Date/time at which properties of this were changed for this run of text by the author.
getDttmPropRMark() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dttmPropRMark field for the PAP record.
getDttmPropRMark() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dttmPropRMark field for the SEP record.
getDttmRevised() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the dttmRevised field for the DOP record.
getDttmRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
getDttmRMarkDel() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).
getDVRecNo() - Method in class org.apache.poi.hssf.record.DVALRecord
Get number of following DV records
getDx1() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Retrieves offset within the parent coordinate space for the top left point.
getDx1() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The x offset within the top-left cell.
getDx1() - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

getDx1() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the x coordinate within the first cell.
getDx1() - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

getDx1() - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

getDx1() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getDx2() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Retrieves offset within the parent coordinate space for the bottom right point.
getDx2() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The x offset withing the cell for the bottom-right corner of this shape.
getDx2() - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

getDx2() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
getDx2() - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

getDx2() - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

getDx2() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getDxaAbs() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dxaAbs field for the PAP record.
getDxaAbs() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Absolute horizontal position.
getDxaAdjust() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getDxaColumns() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dxaColumns field for the SEP record.
getDxaColumnWidth() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dxaColumnWidth field for the SEP record.
getDxaColWidthWwd() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getDxaCropLeft() - Method in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
getDxaCropRight() - Method in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
getDxaFromText() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Horizontal distance between text and absolutely positioned object.
getDxaFromText() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Left distance from surrounding text when absolutely positioned.
getDxaFromTextRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Right distance from surrounding text when absolutely positioned.
getDxaGapHalf() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Measures half of the white space that will be maintained between text in adjacent columns of a table row.
getDxaGoal() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dxaGoal field for the PICF record.
getDxaGoal() - Method in class org.apache.poi.hwpf.usermodel.Picture
Gets the initial width of the picture, in twips, prior to cropping or scaling.
getDxaHotz() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the dxaHotz field for the DOP record.
getDxaIndentSav() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed.
getDxaLeft() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dxaLeft field for the PAP record.
getDxaLeft() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dxaLeft field for the SEP record.
getDxaLeft1() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dxaLeft1 field for the PAP record.
getDxaLnn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dxaLnn field for the SEP record.
getDxaPgn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dxaPgn field for the SEP record.
getDxaReserved1() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dxaReserved1 field for the PICF record.
getDxaReserved2() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dxaReserved2 field for the PICF record.
getDxaReserved3() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dxaReserved3 field for the PICF record.
getDxaRight() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dxaRight field for the PAP record.
getDxaRight() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dxaRight field for the SEP record.
getDxaRTEWrapWidth() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getDxaSpace() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Space following each character in the run expressed in twip units..
getDxaTab() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the dxaTab field for the DOP record.
getDxaWebView() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getDxaWidth() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dxaWidth field for the PAP record.
getDxcLeft() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Left indent in character units.
getDxcLeft1() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
First line indent in character units.
getDxcRight() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Right indent in character units.
getDxfAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getDxtCharSpace() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dxtCharSpace field for the SEP record.
getDy1() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Gets offset within the parent coordinate space for the top left point.
getDy1() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The y offset within the top-left corner of the current shape.
getDy1() - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

getDy1() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
getDy1() - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

getDy1() - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

getDy1() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getDy2() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Gets the offset within the parent coordinate space for the bottom right point.
getDy2() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The y offset withing the cell for the bottom-right corner of this shape.
getDy2() - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

getDy2() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
getDy2() - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

getDy2() - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

getDy2() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getDyaAbs() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dyaAbs field for the PAP record.
getDyaAbs() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Absolute vertical position.
getDyaAfter() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Space after paragraph.
getDyaBefore() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Space before paragraph.
getDyaBottom() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dyaBottom field for the SEP record.
getDyaCropBottom() - Method in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
getDyaCropTop() - Method in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
getDyaFromText() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Vertical distance between text and absolutely positioned object.
getDyaFromText() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Top distance from surrounding text when absolutely positioned.
getDyaFromTextBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Bottom distance from surrounding text when absolutely positioned.
getDyaGoal() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dyaGoal field for the PICF record.
getDyaGoal() - Method in class org.apache.poi.hwpf.usermodel.Picture
Gets the initial height of the picture, in twips, prior to cropping or scaling.
getDyaHdrBottom() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dyaHdrBottom field for the SEP record.
getDyaHdrTop() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dyaHdrTop field for the SEP record.
getDyaHeight() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the dyaHeight field for the PAP record.
getDyaLinePitch() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dyaLinePitch field for the SEP record.
getDyaPgn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dyaPgn field for the SEP record.
getDyaReserved1() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dyaReserved1 field for the PICF record.
getDyaReserved2() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dyaReserved2 field for the PICF record.
getDyaReserved3() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the dyaReserved3 field for the PICF record.
getDyaRowHeight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high.
getDyaTop() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dyaTop field for the SEP record.
getDynamicReference(String, String, String, String, boolean) - Method in class org.apache.poi.ss.formula.OperationEvaluationContext
Resolves a cell or area reference dynamically.
getDywDispPag() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the dywDispPag field for the DOP record.
getDzaGutter() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the dzaGutter field for the SEP record.
getEditTime() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the total time spent in editing the document (or 0).
getEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the Edn field for the DOP record.
getEdn1() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the Edn1 field for the DOP record.
getElement(int) - Method in class org.apache.poi.ddf.EscherArrayProperty

getElementType() - Method in interface org.apache.poi.xwpf.usermodel.IBodyElement

getElementType() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
returns the type of the BodyElement Paragraph
getElementType() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
returns the type of the BodyElement Table
getEmbeddedObjects() - Method in class org.apache.poi.hslf.HSLFSlideShow
Gets embedded object data from the slide show.
getEmbeddedObjects() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns the data of all the embedded OLE object in the SlideShow
getEmbeddedPictures() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Returns the embedded pictures of the run.
getEmbededDocsTextExtractors(POIOLE2TextExtractor) - Static method in class org.apache.poi.extractor.ExtractorFactory
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).
getEmbededDocsTextExtractors(POIXMLTextExtractor) - Static method in class org.apache.poi.extractor.ExtractorFactory
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).
getEmpty() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Get the empty field for the SheetProperties record.
getEmptyCellAllowed() - Method in class org.apache.poi.hssf.record.DVRecord

getEmptyCellAllowed() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getEmptyCellAllowed() - Method in interface org.apache.poi.ss.usermodel.DataValidation
Retrieve the settings for empty cells allowed
getEmptyCellAllowed() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getEnclosingCellRange() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

getEncodedSize(int) - Static method in class org.apache.poi.hssf.util.CellRangeAddress8Bit

getEncodedSize(Object[]) - Static method in class org.apache.poi.ss.formula.constant.ConstantValueParser

getEncodedSize() - Method in class org.apache.poi.ss.formula.Formula

getEncodedSize(Ptg[]) - Static method in class org.apache.poi.ss.formula.ptg.Ptg
This method will return the same result as Ptg.getEncodedSizeWithoutArrayData(Ptg[]) if there are no array tokens present.
getEncodedSize(int) - Static method in class org.apache.poi.ss.util.CellRangeAddress

getEncodedSize(int) - Static method in class org.apache.poi.ss.util.CellRangeAddressList

getEncodedSize(String) - Static method in class org.apache.poi.util.StringUtil

getEncodedSizeWithoutArrayData(Ptg[]) - Static method in class org.apache.poi.ss.formula.ptg.Ptg
Used to calculate value that should be encoded at the start of the encoded Ptg token array;
getEncodedTokenSize() - Method in class org.apache.poi.ss.formula.Formula
This method is often used when the formula length does not appear immediately before the encoded token data.
getEncryptedKey() - Method in class org.apache.poi.poifs.crypt.EncryptionVerifier

getEncryptionFlags() - Method in class org.apache.poi.poifs.crypt.EncryptionInfo

getEncryptionProviderName() - Method in class org.apache.poi.hslf.record.DocumentEncryptionAtom
Return the name of the encryption provider used
getEnd(int) - Method in class org.apache.poi.hwpf.model.FormattedDiskPage
Used to get the end of the text corresponding to a grpprl in this fkp.
getEnd() - Method in class org.apache.poi.hwpf.model.PropertyNode

getEnd() - Method in class org.apache.poi.hwpf.model.SinglentonTextPiece

getEnd() - Method in interface org.apache.poi.hwpf.usermodel.Bookmark

getEndBytes() - Method in class org.apache.poi.hwpf.model.BytePropertyNode
Deprecated. Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.
getEndCellReference() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getEndChar() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getEndIndex() - Method in class org.apache.poi.hslf.model.Hyperlink
Gets the ending character position
getEndIndex() - Method in class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Gets the ending character position
getEndIndex() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
The ending index, exclusive.
getEndnoteByID(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getEndnoteContNote() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getEndnoteContNoteSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getEndnoteContSeparator() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getEndnoteContSeparatorSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getEndnoteRange() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns the Range which covers all endnotes.
getEndnotes() - Method in class org.apache.poi.hwpf.HWPFDocument

getEndnoteSeparator() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getEndnoteSeparatorSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getEndnoteText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor

getEndOffset() - Method in class org.apache.poi.hwpf.usermodel.Range

getEndPos() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getEndRun() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getEndText() - Method in class org.apache.poi.xwpf.usermodel.TextSegement

getEngineId() - Method in class org.apache.poi.hssf.record.RecalcIdRecord

getEntries() - Method in class org.apache.poi.hwpf.model.RevisionMarkAuthorTable
Gets the entries.
getEntries() - Method in class org.apache.poi.hwpf.model.SavedByTable
Gets the entries.
getEntries() - Method in interface org.apache.poi.openxml4j.util.ZipEntrySource
Returns an Enumeration of all the Entries
getEntries() - Method in class org.apache.poi.openxml4j.util.ZipFileZipEntrySource

getEntries() - Method in class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource

getEntries() - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)
getEntries() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)
getEntries() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

getEntry(String) - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
get a specified Entry by name
getEntry(String) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
get a specified Entry by name
getEntry(String) - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

getEntryAt(int) - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
Return the string at a given index.
getEntryAt(int) - Method in class org.apache.poi.xssf.model.SharedStringsTable
Return a string item by index
getEntryCount() - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
find out how many Entry instances are contained directly within this DirectoryEntry
getEntryCount() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
find out how many Entry instances are contained directly within this DirectoryEntry
getEntryCount() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

getEntryName() - Method in class org.apache.poi.hsmf.datatypes.Chunk
Creates a string to use to identify this chunk in the POI file system object.
getEnvironment() - Method in class org.apache.poi.hslf.record.Document
Returns the Environment of this Notes, which lots of settings for the document in it
getEnvr() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value MUST be 0, and MUST be ignored.
getEpc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getError(int) - Static method in class org.apache.poi.ss.usermodel.CellValue

getErrorBoxText() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getErrorBoxText() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getErrorBoxText() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getErrorBoxTitle() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getErrorBoxTitle() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getErrorBoxTitle() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getErrorCellString() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns the error message, such as #VALUE!
getErrorCellValue() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
get the value of the cell as an error code.
getErrorCellValue() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getErrorCellValue() - Method in interface org.apache.poi.ss.usermodel.Cell
Get the value of the cell as an error code.
getErrorCellValue() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Get the value of the cell as an error code.
getErrorCellValue() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Get the value of the cell as an error code.
getErrorCode() - Method in class org.apache.poi.ss.formula.constant.ErrorConstant

getErrorCode() - Method in class org.apache.poi.ss.formula.eval.ErrorEval

getErrorCode() - Method in class org.apache.poi.ss.formula.ptg.ErrPtg

getErrorEval() - Method in exception org.apache.poi.ss.formula.eval.EvaluationException

getErrorStyle() - Method in class org.apache.poi.hssf.record.DVRecord

getErrorStyle() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getErrorStyle() - Method in interface org.apache.poi.ss.usermodel.DataValidation
o
getErrorStyle() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getErrorValue() - Method in class org.apache.poi.hssf.record.BoolErrRecord
get the error value for the cell
getErrorValue() - Method in class org.apache.poi.ss.usermodel.CellValue

getEscapementType() - Method in class org.apache.poi.hssf.record.cf.FontFormatting
get the type of super or subscript for the font
getEscapementType() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
get the type of super or subscript for the font
getEscapementType() - Method in interface org.apache.poi.ss.usermodel.FontFormatting
get the type of super or subscript for the font
getEscapementType() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
get the type of super or subscript for the font
getEscherBSERecord(int) - Method in class org.apache.poi.hslf.model.Fill

getEscherBSERecord() - Method in class org.apache.poi.hslf.model.Picture

getEscherChild(EscherContainerRecord, int) - Static method in class org.apache.poi.hslf.model.Shape
Helper method to return escher child by record ID
getEscherContainer() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord
If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.
getEscherContainer() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder
If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.
getEscherDelayStm() - Method in class org.apache.poi.hpbf.HPBFDocument

getEscherDggRecord() - Method in class org.apache.poi.hslf.record.PPDrawingGroup

getEscherDgRecord() - Method in class org.apache.poi.hslf.record.PPDrawing
Return EscherDgRecord which keeps track of the number of shapes and shapeId in this drawing group
getEscherProperties() - Method in class org.apache.poi.ddf.AbstractEscherOptRecord
The list of properties stored by this record.
getEscherProperty(int) - Method in class org.apache.poi.ddf.AbstractEscherOptRecord
The list of properties stored by this record.
getEscherProperty(EscherOptRecord, int) - Static method in class org.apache.poi.hslf.model.Shape
Returns escher property by id.
getEscherProperty(short) - Method in class org.apache.poi.hslf.model.Shape
Get the value of a simple escher property for this shape.
getEscherProperty(short, int) - Method in class org.apache.poi.hslf.model.Shape
Get the value of a simple escher property for this shape.
getEscherRecord() - Method in class org.apache.poi.hslf.record.EscherTextboxWrapper
Returns the underlying DDF Escher Record
getEscherRecord(int) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

getEscherRecordHolder() - Method in class org.apache.poi.hwpf.HWPFDocument

getEscherRecords() - Method in class org.apache.poi.hpbf.model.EscherPart

getEscherRecords() - Method in class org.apache.poi.hslf.record.PPDrawing
Get access to the underlying Escher Records
getEscherRecords() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

getEscherRecords() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder

getEscherStm() - Method in class org.apache.poi.hpbf.HPBFDocument

getEscherTextbox() - Method in class org.apache.poi.hssf.model.TextboxShape

getEscherTextboxWrapper() - Method in class org.apache.poi.hslf.model.TextShape

getEvenFooter() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getEvenFooter() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the even footer.
getEvenFooterSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getEvenHeader() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getEvenHeader() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the even header.
getEvenHeaderSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getEvenPageFooter() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

getEvenPageHeader() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

getExcelDate(Date) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given a Date, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900.
getExcelDate(Date, boolean) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given a Date, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900.
getExcelDate(Calendar, boolean) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given a Date in the form of a Calendar, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900.
getExControl() - Method in class org.apache.poi.hslf.model.ActiveXShape
Document-level container that specifies information about an ActiveX control
getExControlAtom() - Method in class org.apache.poi.hslf.record.ExControl
Gets the ExControlAtom.
getExEmbed() - Method in class org.apache.poi.hslf.model.OLEShape
Return the record container for this embedded object.
getExEmbedAtom() - Method in class org.apache.poi.hslf.record.ExEmbed
Gets the ExEmbedAtom.
getExFormatAt(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
gets the ExtendedFormatRecord at the given 0-based index
getExHyperlinkAtom() - Method in class org.apache.poi.hslf.record.ExHyperlink
Returns the ExHyperlinkAtom of this link
getExHyperlinks() - Method in class org.apache.poi.hslf.record.ExObjList
Returns all the ExHyperlinks
getExMediaAtom() - Method in class org.apache.poi.hslf.record.ExVideoContainer
Returns the ExMediaAtom of this link
getExObjList() - Method in class org.apache.poi.hslf.record.Document
Returns the ExObjList, which holds the references to external objects used in the slides.
getExObjListAtom() - Method in class org.apache.poi.hslf.record.ExObjList
Returns the ExObjListAtom of this list
getExOleObjAtom() - Method in class org.apache.poi.hslf.record.ExEmbed
Gets the ExOleObjAtom.
getExOleObjStg() - Method in class org.apache.poi.hslf.usermodel.ObjectData
Return the record that contains the object data.
getExplicitListValues() - Method in class org.apache.poi.hssf.usermodel.DVConstraint

getExplicitListValues() - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint

getExplicitListValues() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

getExpReference() - Method in class org.apache.poi.ss.formula.Formula
Gets the locator for the corresponding SharedFormulaRecord, ArrayRecord or TableRecord if this formula belongs to such a grouping.
getExtbookIndexFromRefIndex(int) - Method in class org.apache.poi.hssf.record.ExternSheetRecord

getExtendedProperties() - Method in class org.apache.poi.POIXMLProperties
Returns the extended document properties
getExtendedProperties() - Method in class org.apache.poi.POIXMLTextExtractor
Returns the extended document properties
getExtendedProperties() - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Returns the extended document properties
getExtendedPropertiesText() - Method in class org.apache.poi.POIXMLPropertiesTextExtractor
Returns the extended document properties, eg application
getExtendedRst() - Method in class org.apache.poi.hssf.record.common.UnicodeString

getExtension() - Method in class org.apache.poi.hmef.Attachment
Returns the file extension
getExtension() - Method in enum org.apache.poi.hwpf.usermodel.PictureType

getExtension() - Method in class org.apache.poi.openxml4j.opc.PackagePartName
Retrieves the extension of the part name if any.
getExternalName(int, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook

getExternalName(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getExternalName(int, int) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getExternalName(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getExternalSheet(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook

getExternalSheet(int) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getExternalSheet(int) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getExternalSheet(int) - Method in interface org.apache.poi.ss.formula.FormulaRenderingWorkbook

getExternalSheet(int) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getExternalSheetIndex(String, String) - Method in class org.apache.poi.hssf.model.InternalWorkbook

getExternalSheetIndex(String) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getExternalSheetIndex(String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getExternalSheetIndex(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. for POI internal use only (formula parsing). This method is likely to be removed in future versions of POI.
getExternalSheetIndex(String) - Method in interface org.apache.poi.ss.formula.FormulaParsingWorkbook
gets the externSheet index for a sheet from this workbook
getExternalSheetIndex(String, String) - Method in interface org.apache.poi.ss.formula.FormulaParsingWorkbook
gets the externSheet index for a sheet from an external workbook
getExternalSheetIndex(String) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getExternalSheetIndex(String, String) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getExternSheetIndex() - Method in interface org.apache.poi.ss.formula.ExternSheetReferenceToken

getExternSheetIndex() - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

getExternSheetIndex() - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

getExternSheetNumber() - Method in class org.apache.poi.hssf.record.NameRecord
gets the extern sheet number
getExternsheetPos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList
Returns the externsheetPos.
getExternSheetRecords() - Method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

getExtraDataSize() - Method in class org.apache.poi.hssf.record.ArrayRecord

getExtraDataSize() - Method in class org.apache.poi.hssf.record.SharedFormulaRecord

getExtraDataSize() - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

getExtraDataSize() - Method in class org.apache.poi.hssf.record.TableRecord

getExtraDataSz() - Method in class org.apache.poi.hwpf.model.FontTable

getExVideo() - Method in class org.apache.poi.hslf.record.ExMCIMovie
Returns the ExVideoContainer that specifies information about the MCI movie
getFAdjustRight() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fAdjustRight field for the PAP record.
getFamily() - Method in class org.apache.poi.hssf.record.FontRecord
get the font family (TODO)
getFamily() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the font family to use.
getFAutoPgn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Only for Macintosh compatibility, used only during open, when 1, sep.dxaPgn and sep.dyaPgn are valid page number locations.
getFAutoSpaceDE() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
auto space East Asian and alphabetic characters.
getFAutoSpaceDN() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
auto space East Asian and numeric characters.
getFBiDi() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fBiDi field for the PAP record.
getFBiDi() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table is right-to-left.
getFBorderWS() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used internally by Word.
getFBrLnAbove() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fBrLnAbove field for the PAP record.
getFBrLnBelow() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fBrLnBelow field for the PAP record.
getFc() - Method in class org.apache.poi.hwpf.model.SectionDescriptor

getFCantSplit() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table row may not be split across page bounds.
getFCantSplit90() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table row may not be split across page bounds.
getFcClx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcData() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Points to location of picture data, only if chp.fSpec is true..
getFcDggInfo() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcDop() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcEnd() - Method in class org.apache.poi.hwpf.model.PlexOfField

getFcMac() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value is undefined and MUST be ignored.
getFcMin() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value is undefined and MUST be ignored.
getFcObj() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..
getFcObjp() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Offset in the data stream indicating the location of OLE object data.
getFConflictOrig() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When chp.wConflict!=0, this is TRUE when text is part of the original version of text.
getFConflictOtherDel() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.
getFcPic() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..
getFcPlcfbkf() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcPlcfbkl() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcPlcfbteChpx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcPlcfbtePapx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcPlcffldAtn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlcffldEdn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlcffldFtn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlcffldHdr() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlcffldHdrtxbx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlcffldMom() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlcffldTxbx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlcfLst() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcPlcfsed() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcPlcspaMom() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getFcPlfLfo() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFCrLf() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fCrLf field for the PAP record.
getFcStart() - Method in class org.apache.poi.hwpf.model.PlexOfField

getFcStshf() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcSttbfbkmk() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcSttbfffn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcSttbfRMark() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFcSttbSavedBy() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFDblBdr() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used internally by Word.
getFDispFldRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
the number for a ListNum field is being tracked in xstDispFldRMark.
getFDyaAfterAuto() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Vertical spacing after is automatic.
getFDyaBeforeAuto() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Vertical spacing before is automatic.
getFEndNote() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the fEndNote field for the SEP record.
getFEvenlySpaced() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the fEvenlySpaced field for the SEP record.
getFHasOldProps() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used for character property revision marking.
getFHasOldProps() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Has old properties.
getFibBase() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFibDescriptorsFieldIndex() - Method in enum org.apache.poi.hwpf.model.NoteType

getFibFieldsField() - Method in enum org.apache.poi.hwpf.model.FieldsDocumentPart

getFibFieldsField() - Method in enum org.apache.poi.hwpf.model.FSPADocumentPart

getFibTextPositionsFieldIndex() - Method in enum org.apache.poi.hwpf.model.NoteType

getFieldByStartOffset(FieldsDocumentPart, int) - Method in interface org.apache.poi.hwpf.usermodel.Fields

getFieldByStartOffset(FieldsDocumentPart, int) - Method in class org.apache.poi.hwpf.usermodel.FieldsImpl

getFieldEndOffset() - Method in interface org.apache.poi.hwpf.usermodel.Field

getFieldName(int, String, int) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getFieldName(String, int) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getFieldName1stCap(String, int) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getFieldOffset(int) - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

getFields() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns user-friendly interface to access document Fields
getFields(FieldsDocumentPart) - Method in interface org.apache.poi.hwpf.usermodel.Fields

getFields(FieldsDocumentPart) - Method in class org.apache.poi.hwpf.usermodel.FieldsImpl

getFieldsCount() - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

getFieldSize(int) - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

getFieldsPLCF(FieldsDocumentPart) - Method in class org.apache.poi.hwpf.model.FieldsTables

getFieldsPLCF(int) - Method in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
getFieldsPlcfLength(FieldsDocumentPart) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFieldsPlcfOffset(FieldsDocumentPart) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFieldsTables() - Method in class org.apache.poi.hwpf.HWPFDocument
Deprecated.
getFieldStartOffset() - Method in interface org.apache.poi.hwpf.usermodel.Field

getFieldType() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

getFileIdClusters() - Method in class org.apache.poi.ddf.EscherDggRecord

getFileInformationBlock() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getFilename() - Method in class org.apache.poi.hmef.Attachment
Returns the short filename
getFilename(File) - Static method in class org.apache.poi.openxml4j.opc.internal.FileHelper
Get file name from the specified File object.
getFilename(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Get file name from the specified URI.
getFileName() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the fileName field - usually the name of the file being embedded including the full path.
getFileName(int) - Method in class org.apache.poi.POIXMLRelation
Returns the filename for the nth one of these, e.g.
getFileName() - Method in class org.apache.poi.xslf.usermodel.XSLFPictureData
Returns the file name of the image, eg image7.jpg .
getFileName() - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData
Returns the file name of the image, eg image7.jpg .
getFilenameWithoutExtension(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Get the file name without the trailing extension.
getFileOptions() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Options for a file link
getFilePosition() - Method in class org.apache.poi.hwpf.model.PieceDescriptor

getFileSharing() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getFileSystem() - Method in class org.apache.poi.hssf.extractor.EventBasedExcelExtractor
Deprecated. Use POIOLE2TextExtractor.getRoot() instead
getFileSystem() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode

getFileSystem() - Method in class org.apache.poi.POIOLE2TextExtractor
Deprecated. Use POIOLE2TextExtractor.getRoot() instead
getFill() - Method in class org.apache.poi.hslf.model.Shape
Fill properties of this shape
getFill() - Method in interface org.apache.poi.sl.usermodel.SimpleShape

getFillAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getFillBackground() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the background palette color index
getFillBackgroundColor() - Method in class org.apache.poi.hssf.record.cf.PatternFormatting

getFillBackgroundColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Get the background fill color.
getFillBackgroundColor() - Method in class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

getFillBackgroundColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the background fill color, if the fill is defined with an indexed color.
getFillBackgroundColor() - Method in interface org.apache.poi.ss.usermodel.PatternFormatting

getFillBackgroundColor() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Get the background fill color.
getFillBackgroundColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the background fill color.
getFillBackgroundColor() - Method in class org.apache.poi.xssf.usermodel.XSSFPatternFormatting

getFillBackgroundColorColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle

getFillBackgroundColorColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
Gets the color object representing the current background fill, resolving indexes using the supplied workbook.
getFillBackgroundColorColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle

getFillBackgroundXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the background fill color.
getFillByte() - Static method in class org.apache.poi.poifs.storage.DocumentBlock

getFillColor() - Method in class org.apache.poi.hslf.model.SimpleShape
The color used to fill this shape.
getFillColor() - Method in class org.apache.poi.hssf.usermodel.HSSFShape
The color used to fill this shape.
getFillColor() - Method in class org.apache.poi.xslf.usermodel.XSLFBackground

getFillColor() - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

getFillColor() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getFillColor() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getFillForeground() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the foreground palette color index
getFillForegroundColor() - Method in class org.apache.poi.hssf.record.cf.PatternFormatting

getFillForegroundColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Get the foreground fill color.
getFillForegroundColor() - Method in class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

getFillForegroundColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the foreground fill color, if the fill is defined with an indexed color.
getFillForegroundColor() - Method in interface org.apache.poi.ss.usermodel.PatternFormatting

getFillForegroundColor() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Get the foreground fill color.
getFillForegroundColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the foreground fill color.
getFillForegroundColor() - Method in class org.apache.poi.xssf.usermodel.XSSFPatternFormatting

getFillForegroundColorColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle

getFillForegroundColorColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook.
getFillForegroundColorColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle

getFillForegroundXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the foreground fill color.
getFillPaletteOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the fill palette options bitmask (see indivdual bit getters that reference this method)
getFillPattern() - Method in class org.apache.poi.hssf.record.cf.PatternFormatting

getFillPattern() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the fill pattern (??) - set to 1 to fill with foreground color
getFillPattern() - Method in class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

getFillPattern() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the fill pattern (??) - set to 1 to fill with foreground color
getFillPattern() - Method in interface org.apache.poi.ss.usermodel.PatternFormatting

getFillPattern() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the fill pattern
getFillPattern() - Method in class org.apache.poi.xssf.usermodel.XSSFPatternFormatting

getFillPatternEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the fill pattern
getFills() - Method in class org.apache.poi.xssf.model.StylesTable

getFillsColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Fills Colour
getFillType() - Method in class org.apache.poi.hslf.model.Fill
Returns fill type.
getFilter() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Filter should always be 0
getFInnerTableCell() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.
getFInTable() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Paragraph is in table flag.
getFinTableW97() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Archaic paragraph is in table flag.
getFirstCell() - Method in class org.apache.poi.ss.util.AreaReference

getFirstCellNum() - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

getFirstCellNum() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
get the number of the first cell contained in this row.
getFirstCellNum() - Method in interface org.apache.poi.ss.usermodel.Row
Get the number of the first cell contained in this row.
getFirstCellNum() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Get the number of the first cell contained in this row.
getFirstCellNum() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Get the number of the first cell contained in this row.
getFirstCol() - Method in class org.apache.poi.hssf.record.DimensionsRecord
get the first column number for the sheet
getFirstCol() - Method in class org.apache.poi.hssf.record.RowRecord
get the logical col number for the first cell this row (0 based index)
getFirstColumn() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
get the first column this record defines formatting info for
getFirstColumn() - Method in class org.apache.poi.hssf.record.DConRefRecord

getFirstColumn() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getFirstColumn() - Method in class org.apache.poi.hssf.record.MulBlankRecord

getFirstColumn() - Method in class org.apache.poi.hssf.record.MulRKRecord
starting column (first cell this holds in the row)
getFirstColumn() - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

getFirstColumn() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Return the column of the first cell that contains the hyperlink
getFirstColumn() - Method in interface org.apache.poi.ss.formula.eval.AreaEval
returns the 0-based index of the first col in this area.
getFirstColumn() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getFirstColumn() - Method in interface org.apache.poi.ss.formula.ptg.AreaI

getFirstColumn() - Method in class org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

getFirstColumn() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

getFirstColumn() - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Return the column of the first cell that contains the hyperlink
getFirstColumn() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

getFirstColumn() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Return the column of the first cell that contains the hyperlink
getFirstColumnRaw() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

getFirstFooter() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getFirstFooter() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the first page footer.
getFirstFooterSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getFirstHeader() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getFirstHeader() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the first page header.
getFirstHeaderSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getFirstLineIndent() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getFirstLineIndent() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getFirstPageFooter() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

getFirstPageHeader() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

getFirstRow() - Method in class org.apache.poi.hssf.record.DConRefRecord

getFirstRow() - Method in class org.apache.poi.hssf.record.DimensionsRecord
get the first row number for the sheet
getFirstRow() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getFirstRow() - Method in class org.apache.poi.hssf.record.IndexRecord

getFirstRow() - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

getFirstRow() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Return the row of the first cell that contains the hyperlink
getFirstRow() - Method in interface org.apache.poi.ss.formula.eval.AreaEval
returns the 0-based index of the first row in this area.
getFirstRow() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getFirstRow() - Method in interface org.apache.poi.ss.formula.ptg.AreaI

getFirstRow() - Method in class org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

getFirstRow() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

getFirstRow() - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Return the row of the first cell that contains the hyperlink
getFirstRow() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

getFirstRow() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Return the row of the first cell that contains the hyperlink
getFirstRowNum() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

getFirstRowNum() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Gets the first row on the sheet
getFirstRowNum() - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the first row on the sheet
getFirstRowNum() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the first row on the sheet
getFirstRowNum() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Gets the first row on the sheet
getFirstSection() - Method in class org.apache.poi.hpsf.PropertySet
Gets the PropertySet's first section.
getFirstSection() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getFirstSheetIndexFromRefIndex(int) - Method in class org.apache.poi.hssf.record.ExternSheetRecord

getFirstSlideNum() - Method in class org.apache.poi.hslf.record.DocumentAtom

getFirstVisibleTab() - Method in class org.apache.poi.hssf.record.WindowOneRecord

getFirstVisibleTab() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
sets the first tab that is displayed in the list of tabs in excel.
getFirstVisibleTab() - Method in interface org.apache.poi.ss.usermodel.Workbook
Gets the first tab that is displayed in the list of tabs in excel.
getFirstVisibleTab() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Gets the first tab that is displayed in the list of tabs in excel.
getFirstVisibleTab() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Gets the first tab that is displayed in the list of tabs in excel.
getFitHeight() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getFitHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the number of pages high to fit the sheet in.
getFitHeight() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the number of pages high to fit the sheet in.
getFitHeight() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the number of pages high to fit the sheet in.
getFitToPage() - Method in class org.apache.poi.hssf.record.WSBoolRecord
fit to page option is on
getFitToPage() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
fit to page option is on
getFitToPage() - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether the Fit to Page print option is enabled.
getFitToPage() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether the Fit to Page print option is enabled.
getFitToPage() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether the Fit to Page print option is enabled.
getFitWidth() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getFitWidth() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the number of pages wide to fit sheet in.
getFitWidth() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the number of pages wide to fit sheet in.
getFitWidth() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the number of pages wide to fit sheet in.
getFKeep() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fKeep field for the PAP record.
getFKeepFollow() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fKeepFollow field for the PAP record.
getFKinsoku() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
apply Kinsoku rules when performing line wrapping.
getFlag() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.
getFlag(int) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom

getFlag(int) - Method in class org.apache.poi.hslf.record.ExMediaAtom

getFlag(int) - Method in class org.apache.poi.hslf.record.HeadersFootersAtom

getFlag(int) - Static method in class org.apache.poi.hwpf.sprm.SprmUncompressor
Converts an int into a boolean.
getFlags() - Method in class org.apache.poi.ddf.EscherSpRecord
The flags that apply to this shape.
getFlags() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Flags
getFlags() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Get the flags field for the SheetProperties record.
getFlags() - Method in class org.apache.poi.hssf.record.NoteRecord
Options flags.
getFlags() - Method in class org.apache.poi.hssf.record.TableRecord

getFlags() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Get the flags field for the FSPA record.
getFlags() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Get the flags field for the LFOLVLBase record.
getFlags() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Get the flags field for the LSTF record.
getFlags() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getFlags1() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Get the flags1 field for the FibBase record.
getFlags1() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns flags1 - currently unknown - usually 0x0002.
getFlags2() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Get the flags2 field for the FibBase record.
getFlags2() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns flags2 - currently unknown - mostly 0x0000.
getFlags3() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the flags3 - currently unknown.
getFlattenedCells() - Method in interface org.apache.poi.ss.usermodel.CellRange

getFlattenedCells() - Method in class org.apache.poi.ss.util.SSCellRange

getFLayout() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the fLayout field for the SEP record.
getFLBetween() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the fLBetween field for the SEP record.
getFld() - Method in class org.apache.poi.hwpf.model.PlexOfField

getFlipHorizontal() - Method in class org.apache.poi.hslf.model.SimpleShape
Whether the shape is horizontally flipped
getFlipHorizontal() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame
Whether the shape is horizontally flipped
getFlipHorizontal() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getFlipHorizontal() - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Whether the shape is horizontally flipped
getFlipHorizontal() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getFlipVertical() - Method in class org.apache.poi.hslf.model.SimpleShape
Whether the shape is vertically flipped
getFlipVertical() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

getFlipVertical() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getFlipVertical() - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Whether the shape is vertically flipped
getFlipVertical() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getFloat(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get a float value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java float
getFloat(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get a float value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java float
getFLocked() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Anchor of an absolutely positioned frame is locked.
getFlt() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Field type when ch == 19 OR field flags when ch == 21 .
getFMinHeight() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Minimum height is exact or auto.
getFnGroup() - Method in class org.apache.poi.hssf.record.NameRecord

getFNoAllowOverlap() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
When 1, absolutely positioned paragraph cannot overlap with another paragraph.
getFNoAllowOverlap() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When set to 1, do not allow absolutely positioned table to overlap with other tables.
getFNoAutoHyph() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fNoAutoHyph field for the PAP record.
getFNoLnn() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
No line numbering.
getFNumRMIns() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fNumRMIns field for the PAP record.
getFollowColorScheme() - Method in class org.apache.poi.hslf.record.ExEmbedAtom
Gets whether the object follows the color scheme.
getFollowMasterBackground() - Method in class org.apache.poi.hslf.model.Slide
Whether this slide follows master sheet background
getFollowMasterBackground() - Method in class org.apache.poi.hslf.record.NotesAtom

getFollowMasterBackground() - Method in class org.apache.poi.hslf.record.SlideAtom

getFollowMasterBackground() - Method in interface org.apache.poi.sl.usermodel.Slide

getFollowMasterColourScheme() - Method in interface org.apache.poi.sl.usermodel.Slide

getFollowMasterGraphics() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getFollowMasterGraphics() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getFollowMasterGraphics() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout

getFollowMasterObjects() - Method in class org.apache.poi.hslf.model.Slide
Whether this slide draws master sheet objects
getFollowMasterObjects() - Method in class org.apache.poi.hslf.record.NotesAtom

getFollowMasterObjects() - Method in class org.apache.poi.hslf.record.SlideAtom

getFollowMasterObjects() - Method in interface org.apache.poi.sl.usermodel.Slide

getFollowMasterScheme() - Method in class org.apache.poi.hslf.model.Slide
Whether this slide follows master color scheme
getFollowMasterScheme() - Method in class org.apache.poi.hslf.record.NotesAtom

getFollowMasterScheme() - Method in class org.apache.poi.hslf.record.SlideAtom

getFont() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Gets the current font.
getFont(int) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Get a font by index
getFont() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getFont() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

getFont() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getFont(Workbook) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
gets the font for this style
getFont() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Gets the font for this style
getFontAlign() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Used internally by Word.
getFontAlignment() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getFontAlignment() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getFontAt(short) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Get the font at the given index number
getFontAt(short) - Method in interface org.apache.poi.ss.usermodel.Workbook
Get the font at the given index number
getFontAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getFontAt(short) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Get the font at the given index number
getFontAt(short) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the font at the given index number
getFontAtIndex(int) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Returns the font in use at a particular index.
getFontAtIndex(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Return a copy of the font in use at a particular index.
getFontCollection() - Method in class org.apache.poi.hslf.record.Environment
Returns the FontCollection of this Environment
getFontCollection() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Helper method for usermodel: Get the font collection
getFontCollection() - Method in interface org.apache.poi.sl.usermodel.Resources

getFontColor() - Method in class org.apache.poi.hslf.usermodel.RichTextRun

getFontColor() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getFontColorIndex() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

getFontColorIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

getFontColorIndex() - Method in interface org.apache.poi.ss.usermodel.FontFormatting

getFontColorIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting

getFontFamily() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getFontFamily() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies the fonts which shall be used to display the text contents of this run.
getFontFlags() - Method in class org.apache.poi.hslf.model.PPFont
get the character set Bit 1: If set, font is subsetted
getFontFlags() - Method in class org.apache.poi.hslf.record.FontEntityAtom
get the character set Bit 1: If set, font is subsetted
getFontFormatting() - Method in class org.apache.poi.hssf.record.CFRuleRecord

getFontFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

getFontFormatting() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule

getFontFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule

getFontFormattingBlock() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

getFontHeight() - Method in class org.apache.poi.hssf.record.cf.FontFormatting
gets the height of the font in 1/20th point units
getFontHeight() - Method in class org.apache.poi.hssf.record.FontRecord
gets the height of the font in 1/20th point units
getFontHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get the font height in unit's of 1/20th of a point.
getFontHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
gets the height of the font in 1/20th point units
getFontHeight() - Method in interface org.apache.poi.ss.usermodel.Font
get the font height in unit's of 1/20th of a point.
getFontHeight() - Method in interface org.apache.poi.ss.usermodel.FontFormatting
gets the height of the font in 1/20th point units
getFontHeight() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the font height in point.
getFontHeight() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
gets the height of the font in 1/20th point units
getFontHeightInPoints() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get the font height
getFontHeightInPoints() - Method in interface org.apache.poi.ss.usermodel.Font
get the font height
getFontHeightInPoints() - Method in class org.apache.poi.xssf.usermodel.XSSFFont

getFontIndex(String) - Method in class org.apache.poi.hslf.record.FontCollection

getFontIndex() - Method in class org.apache.poi.hslf.record.FontEntityAtom

getFontIndex() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Gets the font index
getFontIndex(FontRecord) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Retrieves the index of the given font
getFontIndex() - Method in class org.apache.poi.hssf.record.chart.FontIndexRecord
Get the font index field for the FontIndex record.
getFontIndex() - Method in class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

getFontIndex() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the index to the FONT record (which font to use 0 based)
getFontIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
gets the index of the font for this style
getFontIndex() - Method in interface org.apache.poi.ss.usermodel.CellStyle
gets the index of the font for this style
getFontIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Gets the index of the font for this style
getFontMetrics(Font) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Gets the font metrics for the specified font.
getFontMetrics() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getFontMetrics(Font) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getFontMetrics(Font) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

getFontMetrics(Font) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getFontName() - Method in class org.apache.poi.hslf.model.PPFont
get the name for the font (i.e.
getFontName() - Method in class org.apache.poi.hslf.record.FontEntityAtom
A null-terminated string that specifies the typeface name of the font.
getFontName() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Gets the font name
getFontName() - Method in class org.apache.poi.hssf.record.FontRecord
get the name of the font
getFontName() - Method in class org.apache.poi.hssf.usermodel.FontDetails

getFontName() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get the name for the font (i.e.
getFontName() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getFontName() - Method in interface org.apache.poi.ss.usermodel.Font
get the name for the font (i.e.
getFontName() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the name of the font (i.e.
getFontNames() - Method in class org.apache.poi.hwpf.model.FontTable

getFontOfFormattingRun(int) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Gets the font used in a particular formatting run.
getFontOfFormattingRun(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Gets a copy of the font used in a particular formatting run.
getFontpos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getFontRecordAt(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
gets the font record at the given index in the font table.
getFontRenderContext() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Get the rendering context of the Font within this Graphics2D context.
getFontRenderContext() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getFontRenderContext() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getFontReplacer() - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

getFontReplacer() - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

getFonts() - Method in class org.apache.poi.xssf.model.StylesTable

getFontSig() - Method in class org.apache.poi.hwpf.model.Ffn

getFontSize() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Gets the font size
getFontSize() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

getFontSize() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getFontSize() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getFontSize() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies the font size which shall be applied to all non complex script characters in the contents of this run when displayed.
getFontTable() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getFontType() - Method in class org.apache.poi.hslf.model.PPFont
get the font type
getFontType() - Method in class org.apache.poi.hslf.record.FontEntityAtom
get the font type
getFontWeight() - Method in class org.apache.poi.hssf.record.cf.FontFormatting
get the font weight for this font (100-1000dec or 0x64-0x3e8).
getFontWeight() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
get the font weight for this font (100-1000dec or 0x64-0x3e8).
getFontWithId(int) - Method in class org.apache.poi.hslf.record.FontCollection
Get the name of the font at the given ID, or null if there is no font at that ID.
getFooter() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Returns the FooterRecord.
getFooter() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getFooter(int) - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Returns the correct, defined footer for the given one based page
getFooter() - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the user model for the default document footer.
getFooter() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the user model for the default document footer.
getFooter() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the default footer for the sheet, creating one as needed.
getFooter(int) - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
Get the footer that applies to the given (1 based) page.
getFooterArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getFooterAtom() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
A CString record that stores the Footers's contents.
getFooterList() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getFooterMargin() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getFooterMargin() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the footer margin.
getFooterMargin() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the footer margin.
getFooterMargin() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the footer margin.
getFooterText() - Method in class org.apache.poi.hslf.model.HeadersFooters
Footer's text
getFooterText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor
Deprecated.
getFootnoteByID(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getFootnoteById(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes

getFootnoteContNote() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getFootnoteContNoteSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getFootnoteContSeparator() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getFootnoteContSeparatorSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getFootnoteInfo() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the footnoteInfo field for the DOP record.
getFootnoteRange() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns the Range which covers all the Footnotes.
getFootnotes() - Method in class org.apache.poi.hwpf.HWPFDocument

getFootnotes() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getFootnoteSeparator() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getFootnoteSeparatorSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getFootnotesList() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes

getFootnoteText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor

getFootnoteText() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Returns the footnote text of the paragraph
getFOpenTch() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Ensure the Table Cell char doesn't show up as zero height.
getForceFormulaRecalculation() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Whether a record must be inserted or not at generation to indicate that formula must be recalculated when workbook is opened.
getForceFormulaRecalculation() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
getForceFormulaRecalculation() - Method in interface org.apache.poi.ss.usermodel.Sheet
Whether Excel will be asked to recalculate all formulas in this sheet when the workbook is opened.
getForceFormulaRecalculation() - Method in interface org.apache.poi.ss.usermodel.Workbook
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
getForceFormulaRecalculation() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
getForceFormulaRecalculation() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
getForceFormulaRecalculation() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
getForceFormulaRecalculation() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
getForecolorIndex() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Get the forecolor index field for the AreaFormat record.
getForegroundColor() - Method in class org.apache.poi.hslf.model.Fill
Foreground color
getForegroundColor() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Get the foreground color field for the AreaFormat record.
getFormat() - Method in class org.apache.poi.hdgf.pointers.Pointer

getFormat() - Method in class org.apache.poi.hpsf.PropertySet
Returns the property set stream's low-level "format" field.
getFormat() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getFormat(String, boolean) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns a format index that matches the passed in format.
getFormat() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Get the format field for the LineFormat record.
getFormat(String) - Method in class org.apache.poi.hssf.usermodel.HSSFDataFormat
Get the format index that matches the given format string, creating a new format entry if required.
getFormat(short) - Method in class org.apache.poi.hssf.usermodel.HSSFDataFormat
get the format string that matches the given format index
getFormat() - Method in class org.apache.poi.hssf.usermodel.HSSFPictureData

getFormat(String) - Method in interface org.apache.poi.ss.usermodel.DataFormat
get the format index that matches the given format string.
getFormat(short) - Method in interface org.apache.poi.ss.usermodel.DataFormat
get the format string that matches the given format index
getFormat(String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataFormat
Get the format index that matches the given format string, creating a new format entry if required.
getFormat(short) - Method in class org.apache.poi.xssf.usermodel.XSSFDataFormat
get the format string that matches the given format index
getFormatCount() - Method in class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

getFormatFlags() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Get the format flags field for the AreaFormat record.
getFormatFlags() - Method in class org.apache.poi.hssf.record.chart.AreaRecord
Get the format flags field for the Area record.
getFormatFlags() - Method in class org.apache.poi.hssf.record.chart.BarRecord
Get the format flags field for the Bar record.
getFormatFlags() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Get the format flags field for the DataFormat record.
getFormatFlags() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Get the format flags field for the SeriesLabels record.
getFormatFlags() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the formatFlags field for the DOP record.
getFormatID() - Method in class org.apache.poi.hpsf.Section
Returns the format ID.
getFormatId() - Method in class org.apache.poi.hslf.record.HeadersFootersAtom
A signed integer that specifies the format ID to be used to style the datetime.
getFormatIndex(CellValueRecordInterface) - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Returns the index of the format string, used by your cell, or -1 if none found
getFormatIndex() - Method in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord
Get the format index field for the NumberFormatIndex record.
getFormatIndex() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the index to the Format record (which FORMAT to use 0-based)
getFormatRun(int) - Method in class org.apache.poi.hssf.record.common.UnicodeString

getFormatRunCount() - Method in class org.apache.poi.hssf.record.common.UnicodeString

getFormats() - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns the list of FormatRecords in the workbook.
getFormatString(int) - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Returns the format string, eg $##.##, for the given number format index.
getFormatString(CellValueRecordInterface) - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Returns the format string, eg $##.##, used by your cell
getFormatString() - Method in class org.apache.poi.hssf.record.FormatRecord
get the format string
getFormatted() - Method in class org.apache.poi.hssf.record.RowRecord
get whether the row has been formatted (even if its got all blank cells)
getFormattingFontIndex() - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

getFormattingOptions() - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

getFormattingRanges() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

getFormattingRanges() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormatting

getFormattingRanges() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormatting

getFormattingRegions() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting
Deprecated. (Aug-2008) use HSSFConditionalFormatting.getFormattingRanges()
getFormula() - Method in class org.apache.poi.hssf.record.FormulaRecord

getFormula() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord

getFormula1() - Method in class org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair

getFormula1() - Method in class org.apache.poi.hssf.usermodel.DVConstraint

getFormula1() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

getFormula1() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
The formula used to evaluate the first operand for the conditional formatting rule.
getFormula1() - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint

getFormula1() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
The formula used to evaluate the first operand for the conditional formatting rule.
getFormula1() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

getFormula2() - Method in class org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair

getFormula2() - Method in class org.apache.poi.hssf.usermodel.DVConstraint

getFormula2() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

getFormula2() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
The formula used to evaluate the second operand of the comparison when comparison type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN
getFormula2() - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint

getFormula2() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
The formula used to evaluate the second operand of the comparison when comparison type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN
getFormula2() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

getFormulaOfLink() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Get the formula of link field for the LinkedData record.
getFormulaRecord() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

getFormulaString() - Method in interface org.apache.poi.ss.usermodel.charts.ChartDataSource
Returns formula representation of the data source.
getFormulaTokens() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

getFormulaTokens() - Method in class org.apache.poi.hssf.record.ArrayRecord

getFormulaTokens(FormulaRecord) - Method in class org.apache.poi.hssf.record.SharedFormulaRecord

getFormulaTokens(EvaluationCell) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getFormulaTokens(EvaluationCell) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getFormulaTokens(EvaluationCell) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getFOutlineDirtySave() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the fOutlineDirtySave field for the DOP record.
getFOverflowPunct() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
apply overflow punctuation rules when performing line wrapping.
getFPageBreakBefore() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fPageBreakBefore field for the PAP record.
getFpc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getFPgnRestart() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the fPgnRestart field for the SEP record.
getFPropMark() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the fPropMark field for the SEP record.
getFPropRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
properties have been changed with revision marking on.
getFPropRMark() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fPropRMark field for the PAP record.
getFPropRMark() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set to 1 if property revision.
getFreeBlock() - Method in class org.apache.poi.poifs.filesystem.BlockStore
Finds a free block, and returns its offset.
getFreeBlock() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Finds a free block, and returns its offset.
getFreeBlock() - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore
Finds a free block, and returns its offset.
getFreezePanes() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get whether the window should freeze panes
getFreezePanesNoSplit() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
freeze unsplit panes or not
getFReserved() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the fReserved field for the PICF record.
getFReserved() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
This value MUST be 0 and MUST be ignored
getFReserved() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
This value MUST be zero and MUST be ignored
getFrom() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor
Return starting anchor point
getFromCompressedUnicode(byte[], int, int) - Static method in class org.apache.poi.util.StringUtil
Read 8 bit data (in ISO-8859-1 codepage) into a (unicode) Java String and return.
getFromUnicodeLE(byte[], int, int) - Static method in class org.apache.poi.util.StringUtil
Given a byte array of 16-bit unicode characters in Little Endian format (most important byte last), return a Java String representation of it.
getFromUnicodeLE(byte[]) - Static method in class org.apache.poi.util.StringUtil
Given a byte array of 16-bit unicode characters in little endian format (most important byte last), return a Java String representation of it.
getFRTL() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Word 2000 style right-to-left table.
getFSD() - Method in class org.apache.poi.hssf.record.common.FeatProtection

getFSdtVanish() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Mark the character as hidden..
getFSideBySide() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fSideBySide field for the PAP record.
getFspaFromCp(int) - Method in class org.apache.poi.hwpf.model.FSPATable

getFSPAPlcfLength(FSPADocumentPart) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFSPAPlcfOffset(FSPADocumentPart) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getFSpare() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97
getFSpare() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Not used.
getFSpare0() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated. This field should not be used according to specification
getFSpecSymbol() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used by Word internally.
getFSpecVanish() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Special hidden for leading emphasis (always hidden).
getFTableHeader() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table row is to be used as the header of the table.
getFtcAsci() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.
getFtcAscii() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for ASCII text.
getFtcBi() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for Complex Scripts text.
getFtcFE() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for East Asian text.
getFtcFE() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.
getFtcOther() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for non-East Asian text.
getFtcOther() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.
getFtcSym() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
an index into the rgffn structure.
getFTitlePage() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set to 1 when a title page is to be displayed.
getFTopLinePunct() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
perform top line punctuation processing.
getFtsCellPaddingBottom() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell margin/padding units.
getFtsCellPaddingDefaultBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell margin/padding units.
getFtsCellPaddingDefaultLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell margin/padding units.
getFtsCellPaddingDefaultRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell margin/padding units.
getFtsCellPaddingDefaultTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell margin/padding units.
getFtsCellPaddingLeft() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell margin/padding units.
getFtsCellPaddingOuterBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell margin/padding units.
getFtsCellPaddingOuterLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell margin/padding units.
getFtsCellPaddingOuterRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell margin/padding units.
getFtsCellPaddingOuterTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell margin/padding units.
getFtsCellPaddingRight() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell margin/padding units.
getFtsCellPaddingTop() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell margin/padding units.
getFtsCellSpacingBottom() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell spacing units.
getFtsCellSpacingDefaultBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell spacings units.
getFtsCellSpacingDefaultLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell spacings units.
getFtsCellSpacingDefaultRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell spacings units.
getFtsCellSpacingDefaultTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell spacings units.
getFtsCellSpacingLeft() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell spacing units.
getFtsCellSpacingOuterBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell spacings units.
getFtsCellSpacingOuterLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell spacings units.
getFtsCellSpacingOuterRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell spacings units.
getFtsCellSpacingOuterTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell spacings units.
getFtsCellSpacingRight() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell spacing units.
getFtsCellSpacingTop() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell spacing units.
getFtsWidth() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Units for wWidth: 0 -- null; 1 -- auto, ignores wWidth, 2 -- percentage (in 50ths of a percent), 3 -- twips
getFtsWidth() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Units for wWidth
getFtsWidthAfter() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Units for wWidthAfter: 0 -- null; 1 -- auto, ignores wWidthAfter, 2 -- percentage (in 50ths of a percent), 3 -- twips
getFtsWidthBefore() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Units for wWidthBefore: 0 -- null; 1 -- auto, ignores wWidthBefore, 2 -- percentage (in 50ths of a percent), 3 -- twips
getFtsWidthIndent() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Units for wWidthIndent: 0 -- null; 1 -- auto, ignores wWidthIndent, 2 -- percentage (in 50ths of a percent), 3 -- twips
getFTtp() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Table trailer paragraph (last in table row).
getFTtpEmbedded() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.
getFullName() - Method in class org.apache.poi.hslf.model.OLEShape
Returns the full name of the embedded object, e.g.
getFullPrecision() - Method in class org.apache.poi.hssf.record.PrecisionRecord
get whether to use full precision or just skew all you figures all to hell.
getFunction() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Indicates that the defined name refers to a user-defined function.
getFunctionByIndex(int) - Static method in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

getFunctionByName(String) - Static method in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

getFunctionGroupId() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Returns the function group index if the defined name refers to a function.
getFunctionIndex() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

getFunctionIndex(String) - Method in class org.apache.poi.xssf.model.IndexedUDFFinder

getFunctionName() - Method in class org.apache.poi.ss.formula.eval.NameEval

getFunctionName() - Method in class org.apache.poi.ss.formula.functions.NotImplementedFunction

getFunctionName(int) - Method in class org.apache.poi.xssf.model.IndexedUDFFinder

getFUndetermine() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Character is undetermined.
getFUnlocked() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the fUnlocked field for the SEP record.
getFUnused() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Not used
getFUsePgsuSettings() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the fUsePgsuSettings field for the PAP record.
getFWidowControl() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.
getFWordWrap() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
perform word wrap.
getGapHalf() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getGeometryType() - Method in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
Retrieve the geometry type
getGraphicFrame() - Method in class org.apache.poi.xssf.usermodel.XSSFChart
Returns the parent graphic frame.
getGrbitFrt() - Method in class org.apache.poi.hssf.record.common.FtrHeader

getGreen() - Method in class org.apache.poi.ddf.EscherRGBProperty

getGrf() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field MUST be ignored.
getGrfDocEvents() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the grfDocEvents field for the DOP record.
getGrfhic() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
HTML compatibility flags.
getGrfhic() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
HTML compatibility flags.
getGrfhic() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
A grfhic that specifies the HTML incompatibilities of the overriding level formatting
getGrfhic() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A grfhic that specifies the HTML incompatibilities of the list..
getGrfhic() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A grfhic that specifies the HTML incompatibilities of the level..
getGrfstd() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
A GRFSTD that specifies miscellaneous style properties.
getGrfSupression() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getGridset() - Method in class org.apache.poi.hssf.record.GridsetRecord
get whether the gridlines are shown during printing.
getGridsetRecord() - Method in class org.apache.poi.hssf.model.InternalSheet
Gets the gridset record for this sheet.
getGrpfChp() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Collection of the 32 flags.
getGrpfIhdt() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the grpfIhdt field for the SEP record.
getGrpfTap() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getGrpfTap_unused() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Not used
getGrpprl(int) - Method in class org.apache.poi.hwpf.model.CHPFormattedDiskPage
Gets the chpx for the character run at index in this fkp.
getGrpprl() - Method in class org.apache.poi.hwpf.model.CHPX

getGrpprl(int) - Method in class org.apache.poi.hwpf.model.FormattedDiskPage

getGrpprl(int) - Method in class org.apache.poi.hwpf.model.PAPFormattedDiskPage
Gets the papx grpprl for the paragraph at index in this fkp.
getGrpprl() - Method in class org.apache.poi.hwpf.model.PAPX

getGrpprl() - Method in class org.apache.poi.hwpf.model.SEPX

getGrpprl() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

getGrpprl(List<byte[]>, int) - Static method in class org.apache.poi.hwpf.sprm.SprmUtils

getGrpprlChpx() - Method in class org.apache.poi.hwpf.model.ListLevel

getGrpprlOffset() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

getGrpprlPapx() - Method in class org.apache.poi.hwpf.model.ListLevel

getGrpprls() - Method in class org.apache.poi.hwpf.model.ComplexFileTable

getGuid() - Method in class org.apache.poi.hssf.record.HeaderFooterRecord
If this header belongs to a specific sheet view , the sheet view?s GUID will be saved here.
getGuid() - Method in class org.apache.poi.hssf.record.UserSViewBegin

getH() - Method in class org.apache.poi.xslf.model.geom.Path

getHandoutMasterPersist() - Method in class org.apache.poi.hslf.record.DocumentAtom
Returns a reference to the HandoutMaster, or 0 if none
getHashAlgorithm() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getHasShapesOtherThanPlaceholders() - Method in class org.apache.poi.hslf.record.SlidePersistAtom

getHCenter() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

getHCenter() - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

getHCenter() - Method in class org.apache.poi.hssf.record.HCenterRecord
get whether or not to horizonatally center this sheet.
getHead() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

getHead() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

getHeader() - Method in class org.apache.poi.hdgf.chunks.Chunk

getHeader() - Method in class org.apache.poi.hslf.usermodel.PictureData
Return 24 byte header which preceeds the actual picture data.
getHeader() - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

getHeader() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Returns the HeaderRecord.
getHeader() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getHeader(int) - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Returns the correct, defined header for the given one based page
getHeader() - Method in class org.apache.poi.poifs.crypt.EncryptionInfo

getHeader() - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the user model for the default document header.
getHeader() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the user model for the default document header.
getHeader() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the default header for the sheet, creating one as needed.
getHeader(int) - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
Get the header that applies to the given (1 based) page.
getHeaderArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getHeaderAtom() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
A CString record that stores the Header's contents.
getHeaderColor() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get the palette index for the header color
getHeaderFooter() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
Returns the underlying CTHeaderFooter xml bean
getHeaderFooterPolicy() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Returns the policy on headers and footers, which also provides a way to get at them.
getHeaderList() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getHeaderMargin() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getHeaderMargin() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the header margin.
getHeaderMargin() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the header margin.
getHeaderMargin() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the header margin.
getHeaders() - Method in class org.apache.poi.hsmf.MAPIMessage
Returns all the headers, one entry per line
getHeadersFooters() - Method in class org.apache.poi.hslf.model.Slide
Header / Footer settings for this slide.
getHeadersFootersAtom() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
HeadersFootersAtom stores the basic information of the header and footer structure.
getHeaderSize(int) - Static method in class org.apache.poi.hdgf.chunks.ChunkHeader
Returns the size of a chunk header for the given document version.
getHeaderSize() - Static method in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

getHeaderSize() - Static method in class org.apache.poi.hdgf.chunks.ChunkHeaderV6

getHeaderStoryRange() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns the range which covers all "Header Stories".
getHeaderText() - Method in class org.apache.poi.hslf.model.HeadersFooters
Headers's text
getHeaderText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor
Deprecated.
getHeaderValue() - Method in class org.apache.poi.poifs.common.POIFSBigBlockSize
Returns the value that gets written into the header.
getHeadingPair() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the heading pair (or null) when this method is implemented.
getHeight() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the height of the metafile in EMU's (English Metric Units).
getHeight() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Get the height field for the AxisParent record.
getHeight() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

getHeight() - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Get the height field for the Chart record.
getHeight() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the height field for the Text record.
getHeight() - Method in class org.apache.poi.hssf.record.RowRecord
get the height of the row
getHeight() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get the height of the window
getHeight() - Method in class org.apache.poi.hssf.usermodel.FontDetails

getHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
get the row's height or ff (-1) for undefined/default-height in twips (1/20th of a point)
getHeight() - Method in class org.apache.poi.hwpf.usermodel.Picture
returns pixel height of the picture or -1 if dimensions determining was failed
getHeight() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
getHeight() - Method in interface org.apache.poi.ss.formula.eval.AreaEval

getHeight() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getHeight() - Method in interface org.apache.poi.ss.formula.TwoDEval

getHeight() - Method in interface org.apache.poi.ss.usermodel.CellRange

getHeight() - Method in interface org.apache.poi.ss.usermodel.Row
Get the row's height measured in twips (1/20th of a point).
getHeight() - Method in class org.apache.poi.ss.util.SSCellRange

getHeight() - Method in class org.apache.poi.xslf.usermodel.XSLFTableRow

getHeight() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Get the row's height measured in twips (1/20th of a point).
getHeight() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Get the row's height measured in twips (1/20th of a point).
getHeight() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
This element specifies the height of the current table row within the current table.
getHeightBasis() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Get the height basis field for the FontBasis record.
getHeightInPoints() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
get the row's height or ff (-1) for undefined/default-height in points (20*getHeight())
getHeightInPoints() - Method in interface org.apache.poi.ss.usermodel.Row
Returns row height measured in point size.
getHeightInPoints() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Returns row height measured in point size.
getHeightInPoints() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Returns row height measured in point size.
getHeightMode() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current height mode of this
getHeightMode() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getHeightRatio() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current fraction of the height of the chart.
getHeightRatio() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getHelpTopicText() - Method in class org.apache.poi.hssf.record.NameRecord
get the help topic text
getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.AQUA

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.BLACK

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.BROWN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.CORAL

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_RED

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.GOLD

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.GREEN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.INDIGO

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LAVENDER

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.LIME

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.MAROON

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.ORANGE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.ORCHID

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.PINK

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.PLUM

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.RED

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.ROSE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.TAN

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.TEAL

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.VIOLET

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.WHITE

getHexString() - Method in class org.apache.poi.hssf.util.HSSFColor.YELLOW

getHidden() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

getHidden() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get whether the window is hidden or not
getHidden() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get whether the cell's using this style are to be hidden
getHidden() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get whether the cell's using this style are to be hidden
getHidden() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get whether the cell's using this style are to be hidden
getHiddenCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the hidden count or 0 if the DocumentSummaryInformation does not contain a hidden count.
getHideObj() - Method in class org.apache.poi.hssf.record.HideObjRecord
get hide object options
getHighlight() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the Highlight field for the CHP record.
getHighlightedColor() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getHistoryBitMask() - Method in class org.apache.poi.hssf.record.BOFRecord
get the history bit mask (not very useful)
getHmtlBody() - Method in class org.apache.poi.hsmf.MAPIMessage
Deprecated.
getHorizontal() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Get the type of horizontal alignment for the cell
getHorizontalAlignment() - Method in class org.apache.poi.hslf.model.TextShape
Gets the type of horizontal alignment for the text.
getHorizontalAlignment() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the horizontal alignment field for the Text record.
getHorizontalAlignment() - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Gets the horizontal alignment.
getHorizontalBorder() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getHorizontalHold() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get the horizontal position of the window (in 1/20ths of a point)
getHorizontallyCenter() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Determine whether printed output for this sheet will be horizontally centered.
getHorizontallyCenter() - Method in interface org.apache.poi.ss.usermodel.Sheet
Determine whether printed output for this sheet will be horizontally centered.
getHorizontallyCenter() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Determine whether printed output for this sheet will be horizontally centered.
getHorizontallyCenter() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Determine whether printed output for this sheet will be horizontally centered.
getHorizontalPos() - Method in class org.apache.poi.hssf.record.DVALRecord

getHorizontalPositioning() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Returns the type of horizontal positioning to use for a shape
getHorizontalRelative() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Specifies a page element relative to which a shape is horizontally positioned
getHorizontalScale() - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord
Get the horizontalScale field for the PlotGrowth record.
getHorizontalScalingFactor() - Method in class org.apache.poi.hwpf.usermodel.Picture

getHorizontalSplitPosition() - Method in class org.apache.poi.hssf.util.PaneInformation
Returns the horizontal position of the split.
getHorizontalSplitTopRow() - Method in class org.apache.poi.hssf.util.PaneInformation
For a horizontal split returns the top row in the BOTTOM pane.
getHorizontalTextAlignment() - Method in class org.apache.poi.hssf.record.TextObjectRecord

getHps() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size in half points.
getHpsAsci() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size for ASCII font.
getHpsBi() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size for Complex Scripts text.
getHpsFE() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size for East Asian text.
getHpsKern() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Kerning distance for characters in run recorded in half points.
getHpsPos() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Reserved (actually used as vertical offset(?) value).
getHpsZoonFontPag() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the hpsZoonFontPag field for the DOP record.
getHres() - Method in class org.apache.poi.hwpf.model.types.HRESIAbstractType
Hyphenation rule.
getHresi() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the hresi field for the CHP record.
getHresiOld() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the hresiOld field for the CHP record.
getHResolution() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getHResolution() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the horizontal resolution.
getHResolution() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the horizontal resolution.
getHResolution() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the horizontal resolution.
getHSSFColor(HSSFWorkbook) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get the color value for the font
getHtmlBody() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the html body of this Outlook Message, if this email contains a html version.
getHyperlink(int) - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12
Returns the URL of the hyperlink at the given index.
getHyperlink() - Method in class org.apache.poi.hslf.model.Shape
Returns the hyperlink assigned to this shape
getHyperlink() - Method in class org.apache.poi.hslf.model.ShapeGroup
Returns null - shape groups can't have hyperlinks
getHyperlink() - Method in class org.apache.poi.hssf.usermodel.HSSFCell

getHyperlink() - Method in interface org.apache.poi.sl.usermodel.SimpleShape

getHyperlink() - Method in interface org.apache.poi.ss.usermodel.Cell

getHyperlink() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getHyperlink() - Method in class org.apache.poi.xssf.streaming.SXSSFCell

getHyperlink() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns hyperlink associated with this cell
getHyperlink(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getHyperlink(XWPFDocument) - Method in class org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun
If this Hyperlink is an external reference hyperlink, return the object for it.
getHyperlinkByID(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getHyperlinkID() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Gets the link number.
getHyperlinkId() - Method in class org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun
Returns the ID of the hyperlink, if one is set.
getHyperlinks() - Method in class org.apache.poi.hslf.model.TextRun
Returns the array of all hyperlinks in this text run
getHyperlinks() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getHyperlinks() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getHyperlinkType() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
hyperlink type
getIbkl() - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Index to BKL entry in plcfbkl that describes the ending position of this bookmark in the CP stream.
getIbstConflict() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Who made this change for this side of the conflict..
getIbstDispFldRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
getIbstFltAutoNum() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Used for AUTONUM field emulation.
getIbstPropRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
getIbstPropRMark() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the ibstPropRMark field for the PAP record.
getIbstPropRMark() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the ibstPropRMark field for the SEP record.
getIbstRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
getIbstRMarkDel() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
getIco() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Color of text for Word 97.
getIco24() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties
Get the ico24 field for the CHP record.
getIco24() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Get the ico24 field for the CHP record.
getIcoBack() - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Background color
getIcoFore() - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Foreground color
getIcoHighlight() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Highlight color (see chp.ico)
getIconic() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get whether the window has been iconized or not
getId() - Method in class org.apache.poi.ddf.EscherProperty

getId() - Method in class org.apache.poi.hdgf.chunks.ChunkHeader
Returns the ID/IX of the chunk
getID() - Method in class org.apache.poi.hpsf.Property
Returns the property's ID.
getId() - Method in class org.apache.poi.hslf.model.Hyperlink

getId() - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord
Get the id field for the SeriesText record.
getId() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
getId() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

getId() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getId() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

getId() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr
(see Open Office XML Part 4: chapter 3.5.1.3)
getId() - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Gets the frame id.
getId() - Method in class org.apache.poi.xwpf.usermodel.XWPFComment

getId() - Method in class org.apache.poi.xwpf.usermodel.XWPFHyperlink

getIdct() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Not stored in file.
getIdctHint() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Identifier of Character type.
getIdentifier() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getIdentifierProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get identifier.
getIdentifierProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get an unambiguous reference to the resource within a given context.
getIdentityKey() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getIdOfAbstractNum(XWPFAbstractNum) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
Compare AbstractNum with abstractNums of this numbering document.
getIdslReasonDel() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
getIdslRMReason() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
getIftcHtml() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
This field is undefined and MUST be ignored
getIgrpprl() - Method in class org.apache.poi.hwpf.model.PropertyModifier
"Index to a grpprl stored in CLX portion of file"
getIHeadingPgn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the iHeadingPgn field for the SEP record.
getIlfo() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
1-based index into the pllfo (lists structure), if non-zero.
getIlfo() - Method in class org.apache.poi.hwpf.usermodel.Paragraph
Returns the ilfo, an index to the document's hpllfo, which describes the automatic number formatting of the paragraph.
getILvl() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
An unsigned integer that specifies the zero-based level of the list that this overrides.
getIlvl() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
List level if non-zero.
getIlvl() - Method in class org.apache.poi.hwpf.usermodel.Paragraph
Returns the multi-level indent for the paragraph.
getIlvlRestartLim() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart.
getImageDimension() - Method in class org.apache.poi.hssf.usermodel.HSSFPicture
Return the dimension of this image
getImageDimension(InputStream, int) - Static method in class org.apache.poi.ss.util.ImageUtils
Return the dimension of this image
getImageDimension(PackagePart, int) - Static method in class org.apache.poi.xssf.usermodel.XSSFPicture
Return the dimension of this image
getImagePainter(int) - Static method in class org.apache.poi.hslf.usermodel.PictureData
Return ImagePainter for the specified image type
getIndent() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get indention (not sure of the units, think its spaces)
getIndent() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getIndent() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Get the number of spaces to indent the text in the cell
getIndentationFirstLine() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the additional indentation which shall be applied to the first line of the parent paragraph.
getIndentationHanging() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the indentation which shall be removed from the first line of the parent paragraph, by moving the indentation on the first line back towards the beginning of the direction of text flow.
getIndentationLeft() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the indentation which shall be placed between the left text margin for this paragraph and the left edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph
If this attribute is omitted, its value shall be assumed to be zero.
getIndentationRight() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the indentation which shall be placed between the right text margin for this paragraph and the right edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph
If this attribute is omitted, its value shall be assumed to be zero.
getIndentFromLeft() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getIndentFromLeft() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getIndentFromRight() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getIndentFromRight() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getIndention() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the number of spaces to indent the text in the cell
getIndention() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the number of spaces to indent the text in the cell
getIndention() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the number of spaces to indent the text in the cell
getIndentionOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the indent options bitmask (see corresponding bit getters that reference this field)
getIndentLevel() - Method in class org.apache.poi.hslf.usermodel.RichTextRun

getIndex() - Method in class org.apache.poi.hslf.model.TextRun

getIndex() - Method in class org.apache.poi.hssf.record.chart.SeriesIndexRecord
Get the index field for the SeriesIndex record.
getIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the index within the HSSFWorkbook (sequence within the collection of ExtnededFormat objects)
getIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get the index within the HSSFWorkbook (sequence within the collection of Font objects)
getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.AQUA

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.BLACK

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.BROWN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.CORAL

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_RED

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.GOLD

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.GREEN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.INDIGO

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LAVENDER

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.LIME

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.MAROON

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.ORANGE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.ORCHID

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.PINK

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.PLUM

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.RED

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.ROSE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.TAN

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.TEAL

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.VIOLET

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.WHITE

getIndex() - Method in class org.apache.poi.hssf.util.HSSFColor.YELLOW

getIndex() - Method in class org.apache.poi.poifs.property.Property
get the index for this Property
getIndex() - Method in class org.apache.poi.poifs.storage.BATBlock.BATBlockAndIndex

getIndex() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

getIndex() - Method in class org.apache.poi.ss.formula.ptg.NamePtg

getIndex() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the index within the Workbook (sequence within the collection of ExtnededFormat objects)
getIndex() - Method in interface org.apache.poi.ss.usermodel.Font
get the index within the XSSFWorkbook (sequence within the collection of Font objects)
getIndex() - Method in enum org.apache.poi.ss.usermodel.IndexedColors
Returns index of this color
getIndex(T) - Method in class org.apache.poi.util.IntMapper

getIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the index within the StylesTable (sequence within the collection of CTXf elements)
getIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the index within the XSSFWorkbook (sequence within the collection of Font objects)
getIndexCode() - Method in class org.apache.poi.hssf.record.FormatRecord
get the format index code (for built in formats)
getIndexed() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Indexed ctColor value.
getIndexHash() - Static method in class org.apache.poi.hssf.util.HSSFColor
This function returns all the colours in an unmodifiable Map.
getIndexNumberFmtRecord() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Get the index number fmt record field for the LinkedData record.
getIndexOfColorValue() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the index of color value field for the Text record.
getIndexOfColumn(CTCols, CTCol) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

getIndexOfFormattingRun(int) - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
The index within the string to which the specified formatting run applies.
getIndexOfFormattingRun(int) - Method in interface org.apache.poi.ss.usermodel.RichTextString
The index within the string to which the specified formatting run applies.
getIndexOfFormattingRun(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
The index within the string to which the specified formatting run applies.
getIndexToFontTable() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Get the index to font table field for the FontBasis record.
getInfo() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Get the info field for the LVLF record.
getInfo1() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Get the info1 field for the StdfBase record.
getInfo1() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Get the info1 field for the StdfPost2000 record.
getInfo2() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Get the info2 field for the StdfBase record.
getInfo3() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Get the info3 field for the StdfBase record.
getInfo3() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Get the info3 field for the StdfPost2000 record.
getInfo3() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
Get the info3 field for the Stshif record.
getInfoSubRecords() - Method in class org.apache.poi.hssf.record.ExtSSTRecord

getInitialResultValue() - Method in class org.apache.poi.ss.formula.functions.BooleanFunction

getInnerValueEval() - Method in interface org.apache.poi.ss.formula.eval.RefEval

getInputStream() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Get the input stream of this part to read its content.
getInputStream(ZipEntry) - Method in interface org.apache.poi.openxml4j.util.ZipEntrySource
Returns an InputStream of the decompressed data that makes up the entry
getInputStream(ZipEntry) - Method in class org.apache.poi.openxml4j.util.ZipFileZipEntrySource

getInputStream() - Method in class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry

getInputStream(ZipEntry) - Method in class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource

getInputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

getInputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

getInputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

getInputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Abtract method that get the input stream of this part.
getInputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

getInputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.ZipPackagePart
Implementation of the getInputStream() which return the inputStream of this part zip entry.
getInsideHBorderColor() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInsideHBorderSize() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInsideHBorderSpace() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInsideHBorderType() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInsideVBorderColor() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInsideVBorderSize() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInsideVBorderSpace() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInsideVBorderType() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getInstance() - Method in class org.apache.poi.ddf.EscherOptRecord

getInstance() - Method in class org.apache.poi.ddf.EscherRecord
Returns the instance part of the option record.
getInstance() - Static method in class org.apache.poi.hpsf.wellknown.SectionIDMap
Returns the singleton instance of the default SectionIDMap.
getInstance() - Method in class org.apache.poi.hslf.record.SlideListWithText

getInstance() - Static method in class org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

getInstance(EncryptionInfo) - Static method in class org.apache.poi.poifs.crypt.Decryptor

getInstance(String) - Static method in class org.apache.poi.ss.format.CellFormat
Returns a CellFormat that applies the given format.
getInstance(String, String) - Static method in class org.apache.poi.ss.format.CellFormatCondition
Returns an instance of a condition object.
getInstance(int) - Static method in class org.apache.poi.util.BitFieldFactory

getInstance() - Static method in class org.apache.poi.xslf.model.geom.PresetGeometries

getInstance() - Static method in class org.apache.poi.xslf.usermodel.XSLFFactory

getInstance(String) - Static method in class org.apache.poi.xslf.usermodel.XSLFRelation
Get POIXMLRelation by relation type
getInstance() - Static method in class org.apache.poi.xssf.usermodel.charts.XSSFChartDataFactory

getInstance() - Static method in class org.apache.poi.xssf.usermodel.XSSFFactory

getInstance(String) - Static method in class org.apache.poi.xssf.usermodel.XSSFRelation
Get POIXMLRelation by relation type
getInstance() - Static method in class org.apache.poi.xwpf.usermodel.XWPFFactory

getInstance(String) - Static method in class org.apache.poi.xwpf.usermodel.XWPFRelation
Get POIXMLRelation by relation type
getInstanceName() - Method in class org.apache.poi.hslf.model.OLEShape
Returns the instance name of the embedded object, e.g.
getInt(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get an int value from the beginning of a byte array
getInt(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get an int value from a byte array
getInteractiveInfoAtom() - Method in class org.apache.poi.hslf.record.InteractiveInfo
Returns the InteractiveInfoAtom of this InteractiveInfo
getInteriorAnchor() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getInternalFlags() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getIpat() - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Shading pattern
getIpat() - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType
Shading pattern.
getIpgp() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
HTML DIV ID for this paragraph.
getIPriority() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
An unsigned integer that specifies the priority value that is assigned to this style and that is used when ordering the styles by priority in the user interface
getIsBlank() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Gets whether the object's image is blank.
getIsf_sharedFeatureType() - Method in class org.apache.poi.hssf.record.FeatRecord

getIsprm() - Method in class org.apache.poi.hwpf.model.PropertyModifier

getIss() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Superscript/subscript indices.
getIsTable() - Method in class org.apache.poi.hslf.record.ExEmbedAtom
Getswhether the object is a Word table.
getIStartAt() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

getIStartAt() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL.
getIStartAt() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A signed integer that specifies the beginning number for the number sequence belonging to this level.
getIstd() - Method in class org.apache.poi.hwpf.model.PAPX

getIstd() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to character style descriptor in the stylesheet that tags this run of text.
getIstd() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Index to style descriptor.
getIstd() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Table style for the Table.
getIstdBase() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
base style
getIstdLink() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
An unsigned integer that specifies the istd of the style that is linked to this one, or 0x0000 if this style is not linked to any other style in the document.
getIstdMaxFixedWhenSaved() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles.
getIstdNext() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
next style
getItalic() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get whether to use italics or not
getItalic() - Method in interface org.apache.poi.ss.usermodel.Font
get whether to use italics or not
getItalic() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get a boolean value that specify whether to use italics or not
getItap() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Table nesting level.
getItbdMac() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Number of tabs stops defined for paragraph.
getItcFirst() - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
When bkf.fCol==1, this is the index to the first column of a table column bookmark
getItcLim() - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
When bkf.fCol==1, this is the index to limit column of a table column bookmark
getItcMac() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Count of cells defined for this row.
getItems() - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable

getItems() - Method in class org.apache.poi.xssf.model.SharedStringsTable
Provide low-level access to the underlying array of CTRst beans
getItems() - Method in class org.apache.poi.xssf.usermodel.XSSFVMLDrawing

getIteration() - Method in class org.apache.poi.hssf.record.IterationRecord
get whether or not to iterate for calculations
getIterations() - Method in class org.apache.poi.hssf.record.CalcCountRecord
get the number of iterations to perform
getIterator() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

getItl() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Get the itl field for the TLP record.
getItypFELayout() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType

getIWarichuBracket() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Bracket character for two-lines-in-one
getIx() - Method in class org.apache.poi.hssf.record.ExternalNameRecord
If this is a local name, then this is the (1 based) index of the name of the Sheet this refers to, as defined in the preceeding SupBookRecord.
getIx() - Method in class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName

getIxchFollow() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the character that follows the number text.
getJavaDate(double) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given an Excel date with using 1900 date windowing, and converts it to a java.util.Date.
getJavaDate(double, boolean) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given an Excel date with either 1900 or 1904 date windowing, converts it to a java.util.Date.
getJavaDatePattern(int, Locale) - Static method in class org.apache.poi.ss.util.DateFormatConverter

getJavaDateTimePattern(int, Locale) - Static method in class org.apache.poi.ss.util.DateFormatConverter

getJavaTimePattern(int, Locale) - Static method in class org.apache.poi.ss.util.DateFormatConverter

getJc() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the justification of this level
getJc() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the jc field for the PAP record.
getJc() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Justification code.
getJc() - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Justification code
getJump() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Jump
getJumpTable() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

getJustification(int) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getJustification() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getJustification() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getJustifyLast() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
Dunno.
getKcd() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Emphasis mark.
getKerning() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

getKerning() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getKeyboardShortcut() - Method in class org.apache.poi.hssf.record.NameRecord
returns the keyboard shortcut
getKeyForValue(Object) - Method in class org.apache.poi.util.BinaryTree
Returns the key to which this map maps the specified value.
getKeyLength() - Method in class org.apache.poi.hslf.record.DocumentEncryptionAtom
Return the length of the encryption key, in bits
getKeySalt() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getKeySize() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getKeyVirusSession30() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getKeywords() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the keywords (or null).
getKeywords() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getKeywordsProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get keywords.
getKeywordsProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get a delimited set of keywords to support searching and indexing.
getKnownSlideIDs() - Method in class org.apache.poi.hslf.record.PersistPtrHolder
Get the list of slides that this PersistPtrHolder knows about.
getKul() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Underline code.
getLabel() - Method in interface org.apache.poi.common.usermodel.Hyperlink
Return text label for this hyperlink
getLabel() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Return text label for this hyperlink
getLabel() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Return text label for this hyperlink
getLabel() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the label field - usually the name of the file (without directory) but probably may be any name specified during packaging/embedding the data.
getLabel() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Return text label for this hyperlink
getLabelColorRgb() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the label color rgb field for the Tick record.
getLabelFrequency() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Get the label frequency field for the CategorySeriesAxis record.
getLabelOptions() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Label options
getLabelPosition() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the label position field for the Tick record.
getLandscape() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getLandscape() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the landscape mode.
getLandscape() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the landscape mode.
getLandscape() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the landscape mode.
getLangId() - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun
Windows LANGID for this text.
getLanguage(int) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getLanguageCode() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getLanguageProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get the language.
getLanguageProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the language of the intellectual content of the resource.
getLastAuthor() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the last author (or null).
getLastCell() - Method in class org.apache.poi.ss.util.AreaReference
Note - if this area reference refers to a single cell, the return value of this method will be identical to that of getFirstCell()
getLastCellNum() - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

getLastCellNum() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Gets the index of the last cell contained in this row PLUS ONE.
getLastCellNum() - Method in interface org.apache.poi.ss.usermodel.Row
Gets the index of the last cell contained in this row PLUS ONE.
getLastCellNum() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Gets the index of the last cell contained in this row PLUS ONE.
getLastCellNum() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Gets the index of the last cell contained in this row PLUS ONE.
getLastCol() - Method in class org.apache.poi.hssf.record.DimensionsRecord
get the last col number for the sheet
getLastCol() - Method in class org.apache.poi.hssf.record.RowRecord
get the logical col number for the last cell this row (0 based index), plus one
getLastColumn() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
get the last column this record defines formatting info for
getLastColumn() - Method in class org.apache.poi.hssf.record.DConRefRecord

getLastColumn() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getLastColumn() - Method in class org.apache.poi.hssf.record.MulBlankRecord

getLastColumn() - Method in class org.apache.poi.hssf.record.MulRKRecord
ending column (last cell this holds in the row)
getLastColumn() - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

getLastColumn() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Return the column of the last cell that contains the hyperlink
getLastColumn() - Method in interface org.apache.poi.ss.formula.eval.AreaEval
returns the 0-based index of the last col in this area.
getLastColumn() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getLastColumn() - Method in interface org.apache.poi.ss.formula.ptg.AreaI

getLastColumn() - Method in class org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

getLastColumn() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

getLastColumn() - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Return the column of the last cell that contains the hyperlink
getLastColumn() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

getLastColumn() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Return the column of the last cell that contains the hyperlink
getLastColumnIndex() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getLastColumnName() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getLastColumnNumber() - Method in class org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord
Returns the (0 based) number of the last column seen for this row.
getLastColumnRaw() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

getLastEditUsername() - Method in class org.apache.poi.hslf.record.CurrentUserAtom

getLastModifiedByProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get the author of last modifications.
getLastModifiedByProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the user who performed the last modification.
getLastMSOSPID() - Method in class org.apache.poi.ddf.EscherDgRecord
The last shape id used in this drawing group.
getLastOnDiskOffset() - Method in class org.apache.poi.hslf.record.ExOleObjStg
Fetch our location on the disk, as of the last write out
getLastOnDiskOffset() - Method in interface org.apache.poi.hslf.record.PositionDependentRecord
Fetch our location on the disk, as of the last write out
getLastOnDiskOffset() - Method in class org.apache.poi.hslf.record.PositionDependentRecordAtom
Fetch our location on the disk, as of the last write out
getLastOnDiskOffset() - Method in class org.apache.poi.hslf.record.PositionDependentRecordContainer
Fetch our location on the disk, as of the last write out
getLastParagraph() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getLastPrinted() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the last printed time (or null).
getLastPrinted() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getLastPrintedProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get last printed date.
getLastPrintedProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the date and time of the last printing.
getLastPrintedPropertyString() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get last printed date formated into a String.
getLastRow() - Method in class org.apache.poi.hssf.record.DConRefRecord

getLastRow() - Method in class org.apache.poi.hssf.record.DimensionsRecord
get the last row number for the sheet
getLastRow() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getLastRow() - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

getLastRow() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Return the row of the last cell that contains the hyperlink
getLastRow() - Method in interface org.apache.poi.ss.formula.eval.AreaEval
returns the 0-based index of the last row in this area.
getLastRow() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getLastRow() - Method in interface org.apache.poi.ss.formula.ptg.AreaI

getLastRow() - Method in class org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

getLastRow() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

getLastRow() - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Return the row of the last cell that contains the hyperlink
getLastRow() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

getLastRow() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Return the row of the last cell that contains the hyperlink
getLastRowAdd1() - Method in class org.apache.poi.hssf.record.IndexRecord

getLastRowIndex() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getLastRowNum() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

getLastRowNum() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Gets the number last row on the sheet.
getLastRowNum() - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the last row on the sheet
getLastRowNum() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the last row on the sheet
getLastRowNum() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getLastSaveDateTime() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the last save time (or null).
getLastUserEditAtomOffset() - Method in class org.apache.poi.hslf.record.UserEditAtom

getLastViewedSlideID() - Method in class org.apache.poi.hslf.record.UserEditAtom

getLastViewType() - Method in class org.apache.poi.hslf.record.UserEditAtom

getLatentStyles() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
get latentstyles
getLayout(SlideLayout) - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getLbrCRJ() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Line BReak code for xchCRJ.
getLcb() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.
getLcbClx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbDggInfo() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbDop() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbPlcfbkf() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbPlcfbkl() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbPlcfbteChpx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbPlcfbtePapx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbPlcffldAtn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlcffldEdn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlcffldFtn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlcffldHdr() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlcffldHdrtxbx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlcffldMom() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlcffldTxbx() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlcfLst() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbPlcfsed() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbPlcspaMom() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
getLcbPlfLfo() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbStshf() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbSttbfbkmk() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbSttbfffn() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbSttbfRMark() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLcbSttbSavedBy() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getLeft() - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

getLeft() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
getLeft() - Method in interface org.apache.poi.ss.usermodel.Footer
Get the left side of the footer.
getLeft() - Method in interface org.apache.poi.ss.usermodel.Header
Get the left side of the header.
getLeft() - Method in interface org.apache.poi.ss.usermodel.HeaderFooter
Get the left side of the header or footer.
getLeft() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
get the text representing the left part of this element
getLeftBorder() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getLeftBorder() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getLeftBorder() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getLeftBorderColor() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the color to use for the left border
getLeftBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getLeftBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the color to use for the left border
getLeftBorderColor() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getLeftBorderColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the color to use for the left border
getLeftBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getLeftBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the left border
getLeftBorderPaletteIdx() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the palette index for the left border color
getLeftBorderXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the left border
getLeftCol() - Method in class org.apache.poi.hssf.model.InternalSheet

getLeftCol() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get the leftmost column displayed in the window
getLeftCol() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
The left col in the visible view when the sheet is first viewed after opening it in a viewer
getLeftCol() - Method in interface org.apache.poi.ss.usermodel.Sheet
The left col in the visible view when the sheet is first viewed after opening it in a viewer
getLeftCol() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
The left col in the visible view when the sheet is first viewed after opening it in a viewer
getLeftCol() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getLeftColumn() - Method in class org.apache.poi.hssf.record.PaneRecord
Get the left column field for the Pane record.
getLeftEdge() - Method in class org.apache.poi.hwpf.usermodel.TableCell

getLeftInset() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Returns the distance (in points) between the left edge of the text frame and the left edge of the inscribed rectangle of the shape that contains the text.
getLeftMargin() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getLeftRowGutter() - Method in class org.apache.poi.hssf.record.GutsRecord
get the size of the gutter that appears at the left of the rows
getLeftSection(String) - Method in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

getLeftToRight() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getLeftToRight() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the left to right print order.
getLeftToRight() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the left to right print order.
getLeftToRight() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the left to right print order.
getLength() - Method in class org.apache.poi.hdgf.chunks.ChunkHeader
Returns the length of the trunk, excluding the length of the header, trailer or separator.
getLength() - Method in class org.apache.poi.hdgf.pointers.Pointer

getLength() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

getLength() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Get the length of the text
getLength() - Method in class org.apache.poi.poifs.crypt.AgileDecryptor

getLength() - Method in class org.apache.poi.poifs.crypt.Decryptor
Returns the length of the encytpted data that can be safely read with Decryptor.getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode).
getLength() - Method in class org.apache.poi.poifs.crypt.EcmaDecryptor

getLengthOfFormattingRun(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Returns the number of characters this format run covers.
getLenRefSubexpression() - Method in class org.apache.poi.ss.formula.ptg.MemAreaPtg

getLenRefSubexpression() - Method in class org.apache.poi.ss.formula.ptg.MemFuncPtg

getLevel(int) - Method in class org.apache.poi.hwpf.model.ListData
Gets the level associated to a particular List at a particular index.
getLevel() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

getLevel(int, int) - Method in class org.apache.poi.hwpf.model.ListTables

getLevel() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getLevelNum() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

getLevelOverrides() - Method in class org.apache.poi.hwpf.model.ListFormatOverride

getLevelProperties() - Method in class org.apache.poi.hwpf.model.ListLevel

getLevels() - Method in class org.apache.poi.hwpf.model.ListData

getLevelStyle(int) - Method in class org.apache.poi.hwpf.model.ListData

getLid() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
A LID that specifies the install language of the application that is producing the document.
getLidDefault() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the lidDefault field for the CHP record.
getLidFE() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the lidFE field for the CHP record.
getLidFE() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
A LID whose meaning depends on the nFib value.
getLimit() - Method in class org.apache.poi.poifs.filesystem.POIFSWriterEvent

getLineCap() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineColor() - Method in class org.apache.poi.hslf.model.SimpleShape

getLineColor() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Get the line color field for the LineFormat record.
getLineColor() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the line count or 0 if the DocumentSummaryInformation does not contain a line count.
getLineDash() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineDashing() - Method in class org.apache.poi.hslf.model.SimpleShape
Gets line dashing.
getLineHeadDecoration() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineHeadLength() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineHeadWidth() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLinePattern() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Get the line pattern field for the LineFormat record.
getLineSpacing() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the line spacing
getLineSpacing() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getLineSpacing() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getLineSpacing() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Returns the vertical line spacing that is to be used within a paragraph.
getLineStyle() - Method in class org.apache.poi.hslf.model.SimpleShape
Returns line style.
getLineStyle() - Method in class org.apache.poi.hssf.usermodel.HSSFShape

getLineStyle() - Method in interface org.apache.poi.sl.usermodel.SimpleShape

getLineStyleColor() - Method in class org.apache.poi.hssf.usermodel.HSSFShape
The color applied to the lines of this shape.
getLineTailDecoration() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineTailLength() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineTailWidth() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLineWidth() - Method in class org.apache.poi.hslf.model.SimpleShape
Returns width of the line in in points
getLineWidth() - Method in class org.apache.poi.hssf.usermodel.HSSFShape

getLineWidth() - Method in class org.apache.poi.hwpf.usermodel.BorderCode
Width of a single line in 1/8 pt, max of 32 pt.
getLineWidth() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getLink1() - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord
Get the link 1 field for the ObjectLink record.
getLink2() - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord
Get the link 2 field for the ObjectLink record.
getLinkRefPtg() - Method in class org.apache.poi.hssf.record.TextObjectRecord

getLinksDirty() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns true if the custom links are dirty.
getLinkStyleID() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
get StyleID of the linked Style
getLinkTitle() - Method in class org.apache.poi.hslf.record.ExHyperlink
Returns the hyperlink's user-readable name
getLinkType() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Get the link type field for the LinkedData record.
getLinkURL() - Method in class org.apache.poi.hslf.record.ExHyperlink
Returns the URL of the link.
getListData(int) - Method in class org.apache.poi.hwpf.model.ListTables

getListData() - Method in class org.apache.poi.hwpf.usermodel.HWPFList

getListExplicitFormula() - Method in class org.apache.poi.hssf.record.DVRecord

getListItemNumberLabel(int, int) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getListParagraph() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
get a List of all Paragraphs
getListTables() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getLKey() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier.
getLKeyProtDoc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the lKeyProtDoc field for the DOP record.
getLnc() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the lnc field for the SEP record.
getLnnMin() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the lnnMin field for the SEP record.
getLocalXPath() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr
If the XPath is, for example, /Node1/Node2/Node3 and /Node1/Node2 is the common XPath for the table, the local XPath is /Node3
getLocation() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Location within target.
getLocked() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get whether the cell's using this style are to be locked
getLocked() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get whether the cell's using this style are to be locked
getLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get whether the cell's using this style are locked
getLogBase() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getLogBase() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getLogger(Class) - Static method in class org.apache.poi.util.POILogFactory
Get a logger, based on a class name
getLogger(String) - Static method in class org.apache.poi.util.POILogFactory
Get a logger, based on a String
getLogicalAnchor2D() - Method in class org.apache.poi.hslf.model.Shape

getLogicalAnchor2D() - Method in class org.apache.poi.hslf.model.SimpleShape

getLong(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get a long value from a byte array
getLong(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get a long value from a byte array
getLongFilename() - Method in class org.apache.poi.hmef.Attachment
Returns the long filename
getLooseMergedCells() - Method in class org.apache.poi.hssf.model.RowBlocksReader
Some unconventional apps place MergeCellsRecords within the row block.
getLowestIndexOfFlushedRows() - Method in class org.apache.poi.xssf.streaming.SheetDataWriter

getLsid() - Method in class org.apache.poi.hwpf.model.ListData

getLsid() - Method in class org.apache.poi.hwpf.model.ListFormatOverride

getLsid() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
List ID of corresponding LSTF (see LSTF).
getLsid() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A signed integer that specifies the list identifier.
getLspd() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Line spacing descriptor.
getLTagObj() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..
getLvl() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getLvl() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Outline level.
getLvl() - Method in class org.apache.poi.hwpf.usermodel.Paragraph
Returns the heading level (1-8), or 9 if the paragraph isn't in a heading style.
getMainChunks() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the main, core details chunks
getMainContents() - Method in class org.apache.poi.hpbf.HPBFDocument

getMainFont(int) - Method in class org.apache.poi.hwpf.model.FontTable

getMainFontName() - Method in class org.apache.poi.hwpf.model.Ffn

getMainTextboxRange() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns the Range which covers all textboxes.
getMainTextboxText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor

getMajorFont() - Method in class org.apache.poi.xslf.usermodel.XSLFTheme

getMajorIncrement() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Get the major increment field for the ValueRange record.
getMajorTickType() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the major tick type field for the Tick record.
getMajorUnit() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the major unit field for the AxisOptions record.
getMajorUnitValue() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the major unit value field for the AxisOptions record.
getManager() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the manager (or null).
getManualLayout() - Method in interface org.apache.poi.ss.usermodel.charts.ManuallyPositionable
Returns manual layout for the chart element.
getManualLayout() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartLegend

getManualLayout() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

getMAPIAttribute(MAPIProperty) - Method in class org.apache.poi.hmef.Attachment
Return the attachment MAPI Attribute with the given ID, or null if there isn't one.
getMAPIAttributes() - Method in class org.apache.poi.hmef.Attachment
Returns all MAPI attributes of the attachment, such as extension, encoding, size and position
getMAPIAttributes() - Method in class org.apache.poi.hmef.attribute.TNEFMAPIAttribute

getMapId() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell

getMapId() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr

getMAPIMessage() - Method in class org.apache.poi.hsmf.extractor.OutlookTextExtactor
Returns the underlying MAPI message
getMapInfo() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

getMargin(short) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Gets the size of the margin in inches.
getMargin() - Method in class org.apache.poi.hssf.record.BottomMarginRecord
Get the margin field for the BottomMargin record.
getMargin() - Method in class org.apache.poi.hssf.record.LeftMarginRecord
Get the margin field for the LeftMargin record.
getMargin() - Method in interface org.apache.poi.hssf.record.Margin
Get the margin field for the Margin.
getMargin() - Method in class org.apache.poi.hssf.record.RightMarginRecord
Get the margin field for the RightMargin record.
getMargin() - Method in class org.apache.poi.hssf.record.TopMarginRecord
Get the margin field for the TopMargin record.
getMargin(short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Gets the size of the margin in inches.
getMargin(short) - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the size of the margin in inches.
getMargin(short) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the size of the margin in inches.
getMargin(short) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Gets the size of the margin in inches.
getMarginBottom() - Method in class org.apache.poi.hslf.model.TextShape
Returns the distance (in points) between the bottom of the text frame and the bottom of the inscribed rectangle of the shape that contains the text.
getMarginBottom() - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Gets the bottom margin within the textbox.
getMarginBottom() - Method in class org.apache.poi.hwpf.usermodel.Section

getMarginBottom() - Method in interface org.apache.poi.ss.usermodel.Textbox
Gets the bottom margin within the textbox.
getMarginLeft() - Method in class org.apache.poi.hslf.model.TextShape
Returns the distance (in points) between the left edge of the text frame and the left edge of the inscribed rectangle of the shape that contains the text.
getMarginLeft() - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox

getMarginLeft() - Method in class org.apache.poi.hwpf.usermodel.Section

getMarginLeft() - Method in interface org.apache.poi.ss.usermodel.Textbox

getMarginRight() - Method in class org.apache.poi.hslf.model.TextShape
Returns the distance (in points) between the right edge of the text frame and the right edge of the inscribed rectangle of the shape that contains the text.
getMarginRight() - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox

getMarginRight() - Method in class org.apache.poi.hwpf.usermodel.Section

getMarginRight() - Method in interface org.apache.poi.ss.usermodel.Textbox

getMarginTop() - Method in class org.apache.poi.hslf.model.TextShape
Returns the distance (in points) between the top of the text frame and the top of the inscribed rectangle of the shape that contains the text.
getMarginTop() - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox

getMarginTop() - Method in class org.apache.poi.hwpf.usermodel.Section

getMarginTop() - Method in interface org.apache.poi.ss.usermodel.Textbox

getMarkEndCharacterRun(Range) - Method in interface org.apache.poi.hwpf.usermodel.Field

getMarkEndOffset() - Method in interface org.apache.poi.hwpf.usermodel.Field

getMarker() - Method in class org.apache.poi.ddf.EscherBitmapBlip

getMarkSeparatorCharacterRun(Range) - Method in interface org.apache.poi.hwpf.usermodel.Field

getMarkSeparatorOffset() - Method in interface org.apache.poi.hwpf.usermodel.Field

getMarkStartCharacterRun(Range) - Method in interface org.apache.poi.hwpf.usermodel.Field

getMarkStartOffset() - Method in interface org.apache.poi.hwpf.usermodel.Field

getMask() - Method in class org.apache.poi.hslf.model.textproperties.TextProp
Mask in the paragraph or character "contains" header field that indicates that this text property is present.
getMask() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A bit mask specifying options for displaying headers and footers
getMask() - Method in class org.apache.poi.hslf.record.ExMediaAtom
A bit mask specifying options for displaying headers and footers
getMask() - Method in class org.apache.poi.hslf.record.HeadersFootersAtom
A bit mask specifying options for displaying headers and footers A - HeadersFootersAtom.fHasDate (1 bit): A bit that specifies whether the date is displayed in the footer.
getMasterID() - Method in class org.apache.poi.hslf.record.SlideAtom
Get the ID of the master slide used.
getMasterSheet() - Method in class org.apache.poi.hslf.model.Notes
Return null - Notes Masters are not yet supported
getMasterSheet() - Method in class org.apache.poi.hslf.model.Sheet
Return the master sheet .
getMasterSheet() - Method in class org.apache.poi.hslf.model.Slide
Returns master sheet associated with this slide.
getMasterSheet() - Method in class org.apache.poi.hslf.model.SlideMaster
Returns null since SlideMasters doen't have master sheet.
getMasterSheet() - Method in class org.apache.poi.hslf.model.TitleMaster
Returns the slide master for this title master.
getMasterSheet() - Method in interface org.apache.poi.sl.usermodel.Sheet

getMasterSheet() - Method in interface org.apache.poi.sl.usermodel.SlideShow

getMasterSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFNotes

getMasterSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFNotesMaster

getMasterSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getMasterSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getMasterSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout

getMasterSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getMasterSlideListWithText() - Method in class org.apache.poi.hslf.record.Document
Returns the SlideListWithText that deals with the Master Slides
getMaxChange() - Method in class org.apache.poi.hssf.record.DeltaRecord
get the maximum change
getMaxColumns() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getMaxConditionalFormats() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getMaxDrawingGroupId() - Method in class org.apache.poi.ddf.EscherDggRecord

getMaxFunctionArgs() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getMaximum() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getMaximum() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getMaximumAxisValue() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Get the maximum axis value field for the ValueRange record.
getMaximumCategory() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the maximum category field for the AxisOptions record.
getMaxNumOperands() - Method in class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
Maximum number of operands accepted by this function.
getMaxOutlineLevel() - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

getMaxParams() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

getMaxPersistWritten() - Method in class org.apache.poi.hslf.record.UserEditAtom

getMaxRows() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getMaxTextLength() - Method in enum org.apache.poi.ss.SpreadsheetVersion

getMenuName() - Method in class org.apache.poi.hslf.record.ExEmbed
Gets the name used for menus and the Links dialog box.
getMergeCells() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether to merge cells
getMergedRange(CellRangeAddress[][], int, int) - Static method in class org.apache.poi.hssf.converter.AbstractExcelUtils

getMergedRegion(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getMergedRegion(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns the merged region at the specified index
getMergedRegion(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns the merged region at the specified index
getMergedRegion(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getMergedRegionAt(int) - Method in class org.apache.poi.hssf.model.InternalSheet

getMergedRegionAt(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Aug-2008) use HSSFSheet.getMergedRegion(int)
getMessageAttribute(TNEFProperty) - Method in class org.apache.poi.hmef.HMEFMessage
Return the message attribute with the given ID, or null if there isn't one.
getMessageAttributes() - Method in class org.apache.poi.hmef.HMEFMessage
Returns all HMEF/TNEF attributes of the message.
getMessageClass() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the message class of the parsed Outlook Message.
getMessageDate() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the date that the message was accepted by the server on.
getMessageMAPIAttribute(MAPIProperty) - Method in class org.apache.poi.hmef.HMEFMessage
Return the message MAPI Attribute with the given ID, or null if there isn't one.
getMessageMAPIAttributes() - Method in class org.apache.poi.hmef.HMEFMessage
Returns all MAPI attributes of the message.
getMetadataTextExtractor() - Method in class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor
Prevent recursion!
getMetadataTextExtractor() - Method in class org.apache.poi.POIOLE2TextExtractor
Returns an HPSF powered text extractor for the document properties metadata, such as title and author.
getMetadataTextExtractor() - Method in class org.apache.poi.POITextExtractor
Returns another text extractor, which is able to output the textual content of the document metadata / properties, such as author and title.
getMetadataTextExtractor() - Method in class org.apache.poi.POIXMLPropertiesTextExtractor

getMetadataTextExtractor() - Method in class org.apache.poi.POIXMLTextExtractor
Returns an OOXML properties text extractor for the document properties metadata, such as title and author.
getMime() - Method in enum org.apache.poi.hwpf.usermodel.PictureType

getMimeType() - Method in class org.apache.poi.hssf.usermodel.HSSFPictureData
Returns the mime type for the image
getMimeType() - Method in class org.apache.poi.hwpf.usermodel.Picture
Returns the MIME type for the image
getMimeType() - Method in interface org.apache.poi.ss.usermodel.PictureData
Returns the mime type for the image
getMimeType() - Method in class org.apache.poi.xssf.usermodel.XSSFPictureData

getMinimum() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getMinimum() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getMinimumAxisValue() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Get the minimum axis value field for the ValueRange record.
getMinimumCategory() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the minimum category field for the AxisOptions record.
getMiniStore() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Returns the MiniStore, which performs a similar low level function to this, except for the small blocks.
getMinorFont() - Method in class org.apache.poi.xslf.usermodel.XSLFTheme

getMinorIncrement() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Get the minor increment field for the ValueRange record.
getMinorTickType() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the minor tick type field for the Tick record.
getMinorUnit() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the minor unit field for the AxisOptions record.
getMinorUnitValue() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the minor unit value field for the AxisOptions record.
getMinParams() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

getMissingCellPolicy() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Retrieves the current policy on what to do when getting missing or blank cells from a row.
getMissingCellPolicy() - Method in interface org.apache.poi.ss.usermodel.Workbook
Retrieves the current policy on what to do when getting missing or blank cells from a row.
getMissingCellPolicy() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Retrieves the current policy on what to do when getting missing or blank cells from a row.
getMissingCellPolicy() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Retrieves the current policy on what to do when getting missing or blank cells from a row.
getMm() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
A signed integer that specifies the format of the picture data.
getMMClipCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the mmclip count or 0 if the DocumentSummaryInformation does not contain a mmclip count.
getMmPM() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field MUST be ignored.
getMode() - Method in class org.apache.poi.hssf.record.RefModeRecord
get the reference mode to use (HSSF uses/assumes A1)
getModified() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getModifiedDate() - Method in class org.apache.poi.hmef.Attachment
Return when the file was last modified, if known.
getModifiedHigh() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getModifiedLow() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getModifiedProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get modified date.
getModifiedProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the date on which the resource was changed.
getModifiedPropertyString() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get modified date formated into a String.
getMostRecentCoreRecords() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns an array of the most recent version of all the interesting records
getMutableIndexHash() - Static method in class org.apache.poi.hssf.util.HSSFColor
This function returns all the Colours, stored in a Hashtable that can be edited.
getMx() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the mx field for the PICF record.
getMy() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Get the my field for the PICF record.
getName() - Method in class org.apache.poi.ddf.EscherBSERecord
The length in characters of the blip name.
getName() - Method in class org.apache.poi.ddf.EscherProperty

getName() - Method in class org.apache.poi.hdgf.chunks.Chunk
Get the name of the chunk, as found from the CommandDefinitions
getName() - Method in class org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition

getName() - Method in class org.apache.poi.hpsf.CustomProperty
Gets the property's name.
getName() - Method in class org.apache.poi.hslf.model.textproperties.TextProp
Name of the text property
getName() - Method in class org.apache.poi.hssf.record.StyleRecord
get the style's name
getName(String, int) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook
Lookup a named range by its name.
getName(NamePtg) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getName(String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getName(int) - Method in class org.apache.poi.hwpf.model.BookmarksTables

getName() - Method in class org.apache.poi.hwpf.model.StyleDescription

getName() - Method in interface org.apache.poi.hwpf.usermodel.Bookmark

getName() - Method in class org.apache.poi.openxml4j.opc.PackagePartName
Get this part name.
getName() - Method in class org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent

getName() - Method in interface org.apache.poi.poifs.filesystem.Entry
get the name of the Entry
getName() - Method in class org.apache.poi.poifs.filesystem.EntryNode
get the name of the Entry
getName() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

getName() - Method in class org.apache.poi.poifs.filesystem.POIFSWriterEvent

getName() - Method in class org.apache.poi.poifs.property.Property
Get the name of this property
getName() - Method in class org.apache.poi.poifs.property.RootProperty
Returns the fixed name "Root Entry", as the raw property doesn't have a real name set
getName() - Method in class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName

getName(NamePtg) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getName(String, int) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getName(String, int) - Method in interface org.apache.poi.ss.formula.FormulaParsingWorkbook
named range name matching is case insensitive
getName() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

getName() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

getName(String) - Method in interface org.apache.poi.ss.usermodel.Workbook

getName() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout

getName() - Method in class org.apache.poi.xslf.usermodel.XSLFTheme

getName(String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook

getName(String, int) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getName(NamePtg) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getName() - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Returns the frame name.
getName() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getName(String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

getName() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle

getNameAt(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getNameAt(int) - Method in interface org.apache.poi.ss.usermodel.Workbook

getNameAt(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook

getNameAt(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

getNameCommentRecord(NameRecord) - Method in class org.apache.poi.hssf.model.InternalWorkbook
gets the name comment record
getNameDefinition() - Method in class org.apache.poi.hssf.record.NameRecord
gets the definition, reference (Formula)
getNameDefinition() - Method in interface org.apache.poi.ss.formula.EvaluationName

getNameIdChunks() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the Name ID chunks, or null if there aren't any
getNameIndex(String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getNameIndex() - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

getNameIndex(String) - Method in interface org.apache.poi.ss.usermodel.Workbook
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.
getNameIndex(String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.
getNameIndex(String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Gets the named range index by his name Note:Excel named ranges are case-insensitive and this method performs a case-insensitive search.
getNameName() - Method in class org.apache.poi.hssf.usermodel.HSSFName

getNameName(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
gets the named range name
getNameName() - Method in interface org.apache.poi.ss.usermodel.Name
Gets the name of the named range
getNameName() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Returns the name that will appear in the user interface for the defined name.
getNamepos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList
Returns the namepos.
getNameRecord(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
gets the name record
getNameRecord(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getNamesCount() - Method in class org.apache.poi.hwpf.model.BookmarksTables

getNameText() - Method in class org.apache.poi.hssf.record.NameCommentRecord

getNameText() - Method in class org.apache.poi.hssf.record.NameRecord
gets the name
getNameText(NamePtg) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getNameText() - Method in interface org.apache.poi.ss.formula.EvaluationName

getNameText(NamePtg) - Method in interface org.apache.poi.ss.formula.FormulaRenderingWorkbook

getNameText(NamePtg) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getNameXEval(NameXPtg) - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getNameXPtg(String, UDFFinder) - Method in class org.apache.poi.hssf.model.InternalWorkbook

getNameXPtg(String) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getNameXPtg(String) - Method in interface org.apache.poi.ss.formula.FormulaParsingWorkbook

getNameXPtg(String) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getNAuto() - Method in class org.apache.poi.hwpf.model.types.FRDAbstractType
If > 0, the note is an automatically numbered note, otherwise it has a custom mark.
getNEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getNeedRecalculation() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

getNext() - Method in class org.apache.poi.hssf.model.RecordStream

getNextBlock(int) - Method in class org.apache.poi.poifs.filesystem.BlockStore
Works out what block follows the specified one.
getNextBlock(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Works out what block follows the specified one.
getNextBlock(int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore
Works out what block follows the specified one.
getNextChild() - Method in interface org.apache.poi.poifs.property.Child
Get the next Child, if any
getNextChild() - Method in class org.apache.poi.poifs.property.Property
Get the next Child, if any
getNextPicNameNumber(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
get the next free ImageNumber
getNextRow() - Method in class org.apache.poi.hssf.model.InternalSheet
get the NEXT RowRecord (from LOC).
getNextSid() - Method in class org.apache.poi.hssf.record.RecordInputStream

getNextStyleID() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
get StyleID of the next style
getNextToken() - Method in class org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer

getNextXBATChainOffset() - Method in class org.apache.poi.poifs.common.POIFSBigBlockSize

getNfc() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list.
getNfcEdnRef() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the nfcEdnRef field for the DOP record.
getNfcEdnRef1() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getNfcFtnRef() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the nfcFtnRef field for the DOP record.
getNfcFtnRef1() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getNfcPgn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Page number format code.
getNFib() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getNFib() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
An unsigned integer that specifies the version number of the file format used.
getNFibBack() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value SHOULD be 0x00BF.
getNFileSystem() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode

getNFtn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getNLnnMod() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the nLnnMod field for the SEP record.
getNoColor() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getNoColor() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the black and white setting.
getNoColor() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the black and white setting.
getNoColor() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the black and white setting.
getNodesPart(CTSlideIdListEntry) - Method in class org.apache.poi.xslf.XSLFSlideShow
Gets the PackagePart of the notes for the given slide, or null if there isn't one.
getNoOrientation() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getNoOrientation() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the no orientation.
getNoOrientation() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the no orientation.
getNoOrientation() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the no orientation.
getNormalZoom() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get the zoom magnification in normal view
getNoSizeToServerB() - Method in class org.apache.poi.hslf.record.ExEmbedAtom
Gets whether it is not required to send the dimensions to the embedded object.
getNoteAnchorPosition(int) - Method in interface org.apache.poi.hwpf.usermodel.Notes
Returns the location of note anchor in main textspace
getNoteAnchorPosition(int) - Method in class org.apache.poi.hwpf.usermodel.NotesImpl

getNoteCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the note count or 0 if the DocumentSummaryInformation does not contain a note count.
getNoteIndexByAnchorPosition(int) - Method in interface org.apache.poi.hwpf.usermodel.Notes
Returns index of note (if exists, otherwise -1) with specified anchor position
getNoteIndexByAnchorPosition(int) - Method in class org.apache.poi.hwpf.usermodel.NotesImpl

getNoteRecord() - Method in class org.apache.poi.hssf.model.CommentShape
Return the NoteRecord holding the comment attributes
getNoteRecord() - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Returns the underlying Note record
getNoteRecords() - Method in class org.apache.poi.hssf.model.InternalSheet
Get the NoteRecords (related to cell comments) for this sheet
getNotes() - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Fetches all the notes text from the slideshow, but not the slide text
getNotes() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns an array of all the normal Notes found in the slideshow
getNotes() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getNotes() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the print notes.
getNotes() - Method in interface org.apache.poi.sl.usermodel.Slide

getNotes() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the print notes.
getNotes() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getNotes(CTSlideIdListEntry) - Method in class org.apache.poi.xslf.XSLFSlideShow
Returns the low level notes object for the given slide, as found from the supplied slide reference
getNotes() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the print notes.
getNotesAtom() - Method in class org.apache.poi.hslf.record.Notes
Returns the NotesAtom of this Notes
getNotesCount() - Method in interface org.apache.poi.hwpf.usermodel.Notes
Returns count of notes in document
getNotesCount() - Method in class org.apache.poi.hwpf.usermodel.NotesImpl

getNotesDescriptorsOffset(NoteType) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getNotesDescriptorsSize(NoteType) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getNotesHeadersFooters() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Return Header / Footer settings for notes
getNotesID() - Method in class org.apache.poi.hslf.record.SlideAtom
Get the ID of the notes for this slide.
getNotesMaster() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Return the Notes Master, if there is one.
getNotesMasterPersist() - Method in class org.apache.poi.hslf.record.DocumentAtom
Returns a reference to the NotesMaster, or 0 if none
getNotesSheet() - Method in class org.apache.poi.hslf.model.Slide
Returns the Notes Sheet for this slide, or null if there isn't one
getNotesSizeX() - Method in class org.apache.poi.hslf.record.DocumentAtom

getNotesSizeY() - Method in class org.apache.poi.hslf.record.DocumentAtom

getNotesSlideListWithText() - Method in class org.apache.poi.hslf.record.Document
Returns the SlideListWithText that deals with the notes, or null if there isn't one
getNotesTextPositionsOffset(NoteType) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getNotesTextPositionsSize(NoteType) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getNoteTextEndOffset(int) - Method in interface org.apache.poi.hwpf.usermodel.Notes
Returns the end offset of the text corresponding to the reference within the footnote text address space
getNoteTextEndOffset(int) - Method in class org.apache.poi.hwpf.usermodel.NotesImpl

getNoteTextStartOffset(int) - Method in interface org.apache.poi.hwpf.usermodel.Notes
Returns the start offset of the text corresponding to the reference within the footnote text address space
getNoteTextStartOffset(int) - Method in class org.apache.poi.hwpf.usermodel.NotesImpl

getNotSupportedFunctionNames() - Static method in class org.apache.poi.ss.formula.atp.AnalysisToolPak
Returns a collection of ATP function names NOT implemented by POI.
getNotSupportedFunctionNames() - Static method in class org.apache.poi.ss.formula.eval.FunctionEval
Returns an array of function names NOT implemented by POI.
getNotSupportedFunctionNames() - Static method in class org.apache.poi.ss.formula.WorkbookEvaluator
Return a collection of functions that POI does not support
getNRevision() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the nRevision field for the DOP record.
getNum(BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
get Num by NumID
getNumAreas() - Method in class org.apache.poi.hssf.record.MergeCellsRecord
get the number of merged areas.
getNumAxis() - Method in class org.apache.poi.hssf.record.chart.AxisUsedRecord
Get the num axis field for the AxisUsed record.
getNumber() - Method in class org.apache.poi.hslf.record.Comment2000Atom
Gets the comment number (note - each user normally has their own count).
getNumber() - Method in class org.apache.poi.hslf.record.ExHyperlinkAtom
Gets the link number.
getNumber(int, int) - Static method in class org.apache.poi.hwpf.converter.NumberFormatter

getNumber() - Method in class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName

getNumberArray(ValueEval[]) - Method in class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
Returns a double array that contains values for the numeric cells from among the list of operands.
getNumberColumnsSpanned(int[], int, TableCell) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

getNumberFormat() - Method in class org.apache.poi.hwpf.model.ListLevel
"Number format code (see anld.nfc for a list of options)"
getNumberFormat() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getNumberFormat() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getNumberFormatAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getNumberFormats() - Method in class org.apache.poi.xssf.model.StylesTable

getNumbering() - Method in class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

getNumbering() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
getNumbering
getNumbering() - Method in class org.apache.poi.xwpf.usermodel.XWPFNum

getNumberOfAuthors() - Method in class org.apache.poi.xssf.model.CommentsTable

getNumberOfBuiltinBuiltinFormats() - Static method in class org.apache.poi.hssf.usermodel.HSSFDataFormat
get the number of built-in and reserved builtinFormats
getNumberOfCells() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

getNumberOfCellsOfLastFlushedRow() - Method in class org.apache.poi.xssf.streaming.SheetDataWriter

getNumberOfColumns() - Method in class org.apache.poi.hslf.model.Table

getNumberOfColumns() - Method in class org.apache.poi.xslf.usermodel.XSLFTable

getNumberOfComments() - Method in class org.apache.poi.xslf.usermodel.XSLFComments

getNumberOfComments() - Method in class org.apache.poi.xssf.model.CommentsTable

getNumberOfComments() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getNumberOfConditionalFormats() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

getNumberOfCRNs() - Method in class org.apache.poi.hssf.record.CRNCountRecord

getNumberOfCRNs() - Method in class org.apache.poi.hssf.record.CRNRecord

getNumberOfCustomFormats() - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener

getNumberOfElementsInArray() - Method in class org.apache.poi.ddf.EscherArrayProperty

getNumberOfElementsInMemory() - Method in class org.apache.poi.ddf.EscherArrayProperty

getNumberOfExtendedFormats() - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener

getNumberOfFlushedRows() - Method in class org.apache.poi.xssf.streaming.SheetDataWriter

getNumberOfFontRecords() - Method in class org.apache.poi.hssf.model.InternalWorkbook
gets the number of font records
getNumberOfFonts() - Method in class org.apache.poi.hslf.record.FontCollection

getNumberOfFonts() - Method in class org.apache.poi.hslf.usermodel.SlideShow
get the number of fonts in the presentation
getNumberOfFonts() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
get the number of fonts in the font table
getNumberOfFonts() - Method in interface org.apache.poi.ss.usermodel.Workbook
Get the number of fonts in the font table
getNumberOfFonts() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Get the number of fonts in the font table
getNumberOfFonts() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the number of fonts in the this workbook
getNumberOfHyperlinks() - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12
Returns the number of hyperlinks, which should either be zero, or the number of PLC bits
getNumberOfInfoRecsForStrings(int) - Static method in class org.apache.poi.hssf.record.ExtSSTRecord

getNumberOfItems() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord

getNumberOfLevels() - Method in class org.apache.poi.hslf.record.TextRulerAtom
Number of indent levels (maximum 5).
getNumberOfMergedRegions() - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable

getNumberOfNames() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getNumberOfNames() - Method in interface org.apache.poi.ss.usermodel.Workbook

getNumberOfNames() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook

getNumberOfNames() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the number of named ranges in the this workbook
getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.AddPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.ConcatPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.DividePtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.EqualPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.GreaterEqualPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.GreaterThanPtg
Get the number of operands for the Less than operator
getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.IntersectionPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.LessEqualPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.LessThanPtg
Get the number of operands for the Less than operator
getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.MemFuncPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.MultiplyPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.NotEqualPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.OperationPtg
The number of operands expected by the operations
getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.PercentPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.PowerPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.RangePtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.SubtractPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.UnaryMinusPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.UnaryPlusPtg

getNumberOfOperands() - Method in class org.apache.poi.ss.formula.ptg.UnionPtg

getNumberOfPLCs() - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

getNumberOfRows() - Method in class org.apache.poi.hslf.model.Table

getNumberOfRows() - Method in class org.apache.poi.xslf.usermodel.XSLFTable

getNumberOfRows() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getNumberOfRules() - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

getNumberOfRules() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

getNumberOfRules() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormatting

getNumberOfRules() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormatting

getNumberOfRuns() - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

getNumberOfSheets() - Method in class org.apache.poi.hssf.record.SupBookRecord

getNumberOfSheets() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
get the number of spreadsheets in the workbook (this will be three after serialization)
getNumberOfSheets() - Method in interface org.apache.poi.ss.usermodel.Workbook
Get the number of spreadsheets in the workbook
getNumberOfSheets() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Get the number of spreadsheets in the workbook
getNumberOfSheets() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the number of worksheets in the this workbook
getNumberRowsSpanned(Table, int[], int, int, TableCell) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

getNumberText() - Method in class org.apache.poi.hwpf.model.ListLevel

getNumberValue() - Method in class org.apache.poi.ss.formula.eval.BoolEval

getNumberValue() - Method in class org.apache.poi.ss.formula.eval.NumberEval

getNumberValue() - Method in interface org.apache.poi.ss.formula.eval.NumericValueEval

getNumberValue() - Method in class org.apache.poi.ss.usermodel.CellValue

getNumBreaks() - Method in class org.apache.poi.hssf.record.PageBreakRecord

getNumBubbleValues() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Get the num bubble values field for the Series record.
getNumCategories() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Get the num categories field for the Series record.
getNumCellStyles() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
get the number of styles the workbook contains
getNumCellStyles() - Method in interface org.apache.poi.ss.usermodel.Workbook
Get the number of styles the workbook contains
getNumCellStyles() - Method in class org.apache.poi.xssf.model.StylesTable
get the size of cell styles
getNumCellStyles() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Get the number of styles the workbook contains
getNumCellStyles() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the number of styles the workbook contains
getNumColumnBreaks() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

getNumColumns() - Method in class org.apache.poi.hssf.record.MulBlankRecord
get the number of columns this contains (last-first +1)
getNumColumns() - Method in class org.apache.poi.hssf.record.MulRKRecord
get the number of columns this contains (last-first +1)
getNumColumns() - Method in class org.apache.poi.hwpf.usermodel.Section

getNumConditionalFormattings() - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

getNumConditionalFormattings() - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting

getNumConditionalFormattings() - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting

getNumDbcells() - Method in class org.apache.poi.hssf.record.IndexRecord

getNumEntries() - Method in class org.apache.poi.hssf.record.AutoFilterInfoRecord
get the number of AutoFilter drop-down arrows on the sheet
getNumerator() - Method in class org.apache.poi.hssf.record.SCLRecord
Get the numerator field for the SCL record.
getNumericCellValue() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Get the value of the cell as a number.
getNumericCellValue() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getNumericCellValue() - Method in interface org.apache.poi.ss.usermodel.Cell
Get the value of the cell as a number.
getNumericCellValue() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Get the value of the cell as a number.
getNumericCellValue() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Get the value of the cell as a number.
getNumerOfMappedColumns() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getNumExFormats() - Method in class org.apache.poi.hssf.model.InternalWorkbook
get the number of ExtendedFormat records contained in this workbook.
getNumHyperlinks() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getNumID() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
If style exist for this paragraph NumId of the paragraph will be returned.
getNumIdClusters() - Method in class org.apache.poi.ddf.EscherDggRecord
Number of id clusters + 1
getNumMergedRegions() - Method in class org.apache.poi.hssf.model.InternalSheet

getNumMergedRegions() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
returns the number of merged regions
getNumMergedRegions() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns the number of merged regions
getNumMergedRegions() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns the number of merged regions
getNumMergedRegions() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the number of merged regions defined in this worksheet
getNumNames() - Method in class org.apache.poi.hssf.model.InternalWorkbook
gets the total number of names
getNumOfREFRecords() - Method in class org.apache.poi.hssf.record.ExternSheetRecord
returns the number of REF Records, which is in model
getNumOfRefs() - Method in class org.apache.poi.hssf.record.ExternSheetRecord

getNumPlaceholderTexts() - Method in class org.apache.poi.hslf.record.SlidePersistAtom

getNumRecords() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getNumrm() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the numrm field for the PAP record.
getNumRowBreaks() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

getNumSelectedTabs() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get the number of selected tabs
getNumShapeIdsUsed() - Method in class org.apache.poi.ddf.EscherDggRecord.FileIdCluster

getNumShapes() - Method in class org.apache.poi.ddf.EscherDgRecord
The number of shapes in this drawing group.
getNumShapesSaved() - Method in class org.apache.poi.ddf.EscherDggRecord

getNumSheets() - Method in class org.apache.poi.hssf.model.InternalWorkbook
returns the number of boundsheet objects contained in this workbook.
getNumStrings() - Method in class org.apache.poi.hssf.record.SSTRecord

getNumUniqueStrings() - Method in class org.apache.poi.hssf.record.SSTRecord

getNumValues() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Get the num values field for the Series record.
getNumValues() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getNVerBuiltInNamesWhenSaved() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.
getNvPr() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getObjectById(String) - Method in class org.apache.poi.hwpf.usermodel.ObjectPoolImpl

getObjectById(String) - Method in interface org.apache.poi.hwpf.usermodel.ObjectsPool

getObjectData() - Method in class org.apache.poi.hslf.model.OLEShape
Returns unique identifier for the OLE object.
getObjectData() - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

getObjectData() - Method in class org.apache.poi.hssf.usermodel.HSSFObjectData
Returns the data portion, for an ObjectData that doesn't have an associated POIFS Directory Entry
getObjectID() - Method in class org.apache.poi.hslf.model.OLEShape
Returns unique identifier for the OLE object.
getObjectId() - Method in class org.apache.poi.hslf.record.ExMediaAtom
A 4-byte unsigned integer that specifies an ID for an external object.
getObjectId() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Get the object id field for the CommonObjectData record.
getObjectID() - Method in class org.apache.poi.hssf.record.DVALRecord
get Object ID of the drop down arrow object for list boxes
getObjectIDSeed() - Method in class org.apache.poi.hslf.record.ExObjListAtom
Gets the object ID seed, which will be used as the unique OLE identifier for the next OLE object added
getObjectProtect() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Answer whether object protection is enabled or disabled
getObjectsPool() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getObjectType() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Get the object type field for the CommonObjectData record.
getObjID() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Gets the unique identifier for the OLE object.
getObjOffset() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getObjRecord() - Method in class org.apache.poi.hssf.model.AbstractShape

getObjRecord() - Method in class org.apache.poi.hssf.model.ComboboxShape

getObjRecord() - Method in class org.apache.poi.hssf.model.LineShape

getObjRecord() - Method in class org.apache.poi.hssf.model.PictureShape

getObjRecord() - Method in class org.apache.poi.hssf.model.PolygonShape

getObjRecord() - Method in class org.apache.poi.hssf.model.SimpleFilledShape

getObjRecord() - Method in class org.apache.poi.hssf.model.TextboxShape

getObjStgDataRef() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Gets the reference to the persistent object
getOddFooter() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getOddFooter() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the odd footer.
getOddFooterSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getOddHeader() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Deprecated.
getOddHeader() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the odd header.
getOddHeaderSubrange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getOddPageFooter() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
Returns the odd page footer.
getOddPageHeader() - Method in class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
Returns the odd page header.
getOfficeArtSpContainer() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Returns escher record that represent shape container (record type is 0xF004).
getOfficeDrawingAt(int) - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawings

getOfficeDrawingAt(int) - Method in class org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl

getOfficeDrawings() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawings

getOfficeDrawings() - Method in class org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl

getOfficeDrawingsHeaders() - Method in class org.apache.poi.hwpf.HWPFDocument

getOfficeDrawingsMain() - Method in class org.apache.poi.hwpf.HWPFDocument

getOffset() - Method in class org.apache.poi.ddf.EscherBSERecord
File offset in the delay stream.
getOffset() - Method in class org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition

getOffset() - Method in class org.apache.poi.hdgf.pointers.Pointer

getOffset() - Method in class org.apache.poi.hpsf.Section
Returns the offset of the section in the stream.
getOffset() - Method in class org.apache.poi.hslf.usermodel.PictureData
File offset in the 'Pictures' stream
getOffset() - Method in class org.apache.poi.hwpf.model.io.HWPFOutputStream

getOLE2ClassName() - Method in class org.apache.poi.hssf.usermodel.HSSFObjectData
Returns the OLE2 Class Name of the object
getOLEClassName() - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

getOLEShapes() - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor

getOleVerb() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Only valid when action == OLEAction.
getOlstAnm() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the olstAnm field for the SEP record.
getOmitTitlePlace() - Method in class org.apache.poi.hslf.record.DocumentAtom
Have the placeholders on the title slide been omitted?
getOnDiskSize() - Method in class org.apache.poi.hdgf.chunks.Chunk
Returns the size of the chunk, including any headers, trailers and separators.
getOpacity(int) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

getOPCNameFromZipItemName(String) - Static method in class org.apache.poi.openxml4j.opc.internal.ZipHelper
Convert a zip name into an OPC name by adding a leading forward slash to the specified item name.
getOperand() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

getOperation() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

getOperationFromOpcode(short) - Static method in class org.apache.poi.hwpf.sprm.SprmOperation

getOperator() - Method in class org.apache.poi.hssf.usermodel.DVConstraint

getOperator() - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint

getOperator() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

getOptA() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

getOptB() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

getOptC() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

getOptimize() - Method in class org.apache.poi.hssf.record.RowRecord
get whether to optimize or not (set to 0)
getOption() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Get the option field for the CommonObjectData record.
getOptionFlag() - Method in class org.apache.poi.hssf.record.NameRecord
gets the option flag
getOptionFlags() - Method in class org.apache.poi.hssf.record.common.UnicodeString
get the option flags which among other things return if this is a 16-bit or 8 bit string
getOptionFlags() - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord
get the (currently unimportant to HSSF) option flags
getOptionFlags() - Method in class org.apache.poi.hssf.record.RowRecord
gets the option bitmask.
getOptions() - Method in class org.apache.poi.ddf.EscherOptRecord
Automatically recalculate the correct option
getOptions() - Method in class org.apache.poi.ddf.EscherRecord

options is an internal field.
getOptions() - Method in class org.apache.poi.hslf.record.CString
Grabs the count, from the first two bytes of the header.
getOptions() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Gets misc options (the last four bytes in the atom).
getOptions() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
Must be either HeadersFootersContainer.SlideHeadersFootersContainer or HeadersFootersContainer.NotesHeadersFootersContainer
getOptions() - Method in class org.apache.poi.hslf.record.OEShapeAtom
shape flags.
getOptions() - Method in class org.apache.poi.hssf.record.CFRuleRecord
get the option flags
getOptions() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Get the options field for the AxisOptions record.
getOptions() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Get the options field for the CategorySeriesAxis record.
getOptions() - Method in class org.apache.poi.hssf.record.chart.DatRecord
Get the options field for the Dat record.
getOptions() - Method in class org.apache.poi.hssf.record.chart.FrameRecord
Get the options field for the Frame record.
getOptions() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Get the options field for the Legend record.
getOptions() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Get the options field for the LinkedData record.
getOptions() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the options field for the Tick record.
getOptions() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Get the options field for the ValueRange record.
getOptions() - Method in class org.apache.poi.hssf.record.DVALRecord

getOptions() - Method in class org.apache.poi.hssf.record.FormulaRecord
get the option flags
getOptions() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getOptions() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get the options bitmask (see bit setters)
getOptions() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get the options bitmask or just use the bit setters.
getOptions() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the bit flags for the options.
getOptions1() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the options1 field for the Text record.
getOptions2() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the options2 field for the Text record.
getOrCreateColumn1Based(long, boolean) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper
Return the CTCol at the given (0 based) column index, creating it if required.
getOrCreateCssClass(String, String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

getOrCreateDataValidityTable() - Method in class org.apache.poi.hssf.model.InternalSheet

getOrCreateLegend() - Method in interface org.apache.poi.ss.usermodel.Chart

getOrCreateLegend() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

getOrCreatePropertiesRoot() - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

getOrderID() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A signed integer that specifies the order of the animation in the slide.
getOrdinalNumber() - Method in interface org.apache.poi.ss.util.cellwalk.CellWalkContext
Returns ordinal number of cell in range.
getOrientation() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getOrientation() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getOrientation() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Orientation of the page: landscape - portrait.
getOSVersion() - Method in class org.apache.poi.hpsf.PropertySet
Returns the property set stream's low-level "OS version" field.
getOSVersion() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getOurBlockIndex() - Method in class org.apache.poi.poifs.storage.BATBlock
Retrieve where in the file we live
getOutline() - Method in class org.apache.poi.hslf.model.AutoShape

getOutline() - Method in class org.apache.poi.hslf.model.Freeform

getOutline() - Method in class org.apache.poi.hslf.model.Line

getOutline() - Method in class org.apache.poi.hslf.model.Shape
Return shape outline as a java.awt.Shape object
getOutline(Shape) - Method in interface org.apache.poi.hslf.model.ShapeOutline

getOutline() - Method in class org.apache.poi.xslf.model.geom.Outline

getOutlineLevel() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

getOutlineLevel() - Method in class org.apache.poi.hssf.record.RowRecord
get the outline level of this row
getOutlineLevel() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Returns the rows outline level.
getOutputStream() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Get the output stream of this part.
getOutputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

getOutputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

getOutputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

getOutputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Abstract method that get the output stream of this part.
getOutputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

getOutputStreamImpl() - Method in class org.apache.poi.openxml4j.opc.ZipPackagePart
Implementation of the getOutputStream().
getOverallRange() - Method in class org.apache.poi.hwpf.HWPFDocument

getOverallRange() - Method in class org.apache.poi.hwpf.HWPFDocumentCore
Returns the range that covers all text in the file, including main text, footnotes, headers and comments
getOverallRange() - Method in class org.apache.poi.hwpf.HWPFOldDocument

getOverflow() - Method in class org.apache.poi.hwpf.model.CHPFormattedDiskPage

getOverlappingRange(long[], long[]) - Static method in class org.apache.poi.xssf.util.NumericRanges

getOverlappingType(long[], long[]) - Static method in class org.apache.poi.xssf.util.NumericRanges

getOverride(int) - Method in class org.apache.poi.hwpf.model.ListTables

getOverride() - Method in class org.apache.poi.hwpf.usermodel.HWPFList

getOverrideCount() - Method in class org.apache.poi.hwpf.model.ListTables

getOverrideIndexFromListID(int) - Method in class org.apache.poi.hwpf.model.ListTables

getOverrideLevel(int) - Method in class org.apache.poi.hwpf.model.ListFormatOverride

getOwner() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getOwner() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

getPackage() - Method in class org.apache.poi.openxml4j.opc.PackagePart

getPackage() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

getPackage() - Method in class org.apache.poi.POIXMLDocument

getPackage() - Method in class org.apache.poi.POIXMLTextExtractor
Returns the opened OPCPackage that contains the document
getPackage() - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Returns the opened OPCPackage container.
getPackageAccess() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Get the package access mode.
getPackagePart() - Method in class org.apache.poi.POIXMLDocumentPart
Provides access to the underlying PackagePart
getPackageProperties() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Retrieves or creates if none exists, core package property part.
getPackageRelationship() - Method in class org.apache.poi.POIXMLDocumentPart
Provides access to the PackageRelationship that identifies this POIXMLDocumentPart
getPackageRootUri() - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Gets the URI for the package root.
getPadding() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This value MUST be zero and MUST be ignored.
getPadding2() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This value MUST be zero and MUST be ignored.
getPageBreakZoom() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
zoom magification in page break view
getPageCount() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the page count or 0 if the SummaryInformation does not contain a page count.
getPaged() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
Deprecated. use isActive()
getPageHeight() - Method in class org.apache.poi.hwpf.usermodel.Section

getPageMarginInches() - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

getPageOrder() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
get print page order.
getPageSettings() - Method in class org.apache.poi.hssf.model.InternalSheet

getPageSize() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Return the current page size
getPageSize() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Returns the current page size
getPageStart() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getPageStart() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the page start.
getPageStart() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the page start.
getPageStart() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set the page numbering start.
getPageWidth() - Method in class org.apache.poi.hwpf.usermodel.Section

getPaint() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns the current Paint of the Graphics2D context.
getPaint() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getPaint() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getPaletteOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the palette options bitmask (see the individual bit getter methods that reference this one)
getPalettepos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getPane() - Method in class org.apache.poi.hssf.record.SelectionRecord

getPaneInformation() - Method in class org.apache.poi.hssf.model.InternalSheet
Returns the information regarding the currently configured pane (split or freeze).
getPaneInformation() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns the information regarding the currently configured pane (split or freeze).
getPaneInformation() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns the information regarding the currently configured pane (split or freeze)
getPaneInformation() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns the information regarding the currently configured pane (split or freeze)
getPaneInformation() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the information regarding the currently configured pane (split or freeze).
getPanose() - Method in class org.apache.poi.hwpf.model.Ffn

getPAP() - Method in class org.apache.poi.hwpf.model.StyleDescription
Deprecated.
getPaperSize() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getPaperSize() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the paper size.
getPaperSize() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the paper size.
getPaperSize() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the paper size.
getPaperSizeEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the paper size as enum.
getPAPX(int) - Method in class org.apache.poi.hwpf.model.PAPFormattedDiskPage
Gets the PAPX at index.
getPAPX() - Method in class org.apache.poi.hwpf.model.StyleDescription

getPAPX(int) - Method in class org.apache.poi.hwpf.model.StyleSheet

getPAPXs() - Method in class org.apache.poi.hwpf.model.PAPFormattedDiskPage

getParagraph(int) - Method in class org.apache.poi.hwpf.usermodel.Range
Gets the paragraph at index.
getParagraph(CTP) - Method in interface org.apache.poi.xwpf.usermodel.IBody
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
getParagraph(CTP) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
get the paragraph with the CTP class p
getParagraph(CTP) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
getParagraph(CTP) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
getParagraph() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Get the currenty referenced paragraph object
getParagraph(CTP) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this table the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
getParagraphArray(int) - Method in interface org.apache.poi.xwpf.usermodel.IBody
Returns the paragraph that of position pos
getParagraphArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Returns the paragraph that of position pos
getParagraphArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
Returns the paragraph that holds the text of the header or footer.
getParagraphArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
Returns the paragraph that holds the text of the header or footer.
getParagraphArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getParagraphHeight() - Method in class org.apache.poi.hwpf.model.PAPX

getParagraphInstance() - Static method in class org.apache.poi.hslf.record.TextRulerAtom

getParagraphPos(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Look up the paragraph at the specified position in the body elements list and return this paragraphs position in the paragraphs list
getParagraphProperties(StyleSheet) - Method in class org.apache.poi.hwpf.model.PAPX
Deprecated.
getParagraphProps(int, int) - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
Paragraph properties for the specified text type and indent level Depending on the level and type, it may be our special ones, or the standard StyleTextPropAtom ones
getParagraphs() - Method in class org.apache.poi.hwpf.model.PAPBinTable

getParagraphs() - Method in class org.apache.poi.xslf.usermodel.DrawingTextBody

getParagraphs() - Method in interface org.apache.poi.xwpf.usermodel.IBody
Returns the paragraph(s) that holds the text of the header or footer.
getParagraphs() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getParagraphs() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getParagraphs() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
Returns the paragraph(s) that holds the text of the header or footer.
getParagraphs() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
returns a list of paragraphs
getParagraphsIterator() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getParagraphStyle(int) - Method in class org.apache.poi.hwpf.model.StyleSheet
Deprecated.
getParagraphStyles() - Method in class org.apache.poi.hslf.record.StyleTextPropAtom

getParagraphStyles() - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
Returns array of paragraph styles defined in this record.
getParagraphTable() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getParagraphText() - Method in class org.apache.poi.hwpf.extractor.Word6Extractor
Deprecated.
getParagraphText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor
Get the text from the word file, as an array with one String per paragraph
getParagraphText(Range) - Static method in class org.apache.poi.hwpf.extractor.WordExtractor

getParagraphText() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Returns the text of the paragraph, but not of any objects in the paragraph
getParagraphTextLengthCovered() - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Returns how many characters the paragraph's TextPropCollections cover.
getParameterClass(int) - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

getParameterClassCodes() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

getParameters(String) - Method in class org.apache.poi.openxml4j.opc.internal.ContentType
Gets the value associated to the specified key.
getParCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the par count or 0 if the DocumentSummaryInformation does not contain a par count.
getParent() - Method in class org.apache.poi.hslf.model.Shape

getParent() - Method in class org.apache.poi.hssf.usermodel.HSSFShape
Gets the parent shape.
getParent() - Method in interface org.apache.poi.poifs.filesystem.Entry
get this Entry's parent (the DirectoryEntry that owns this Entry).
getParent() - Method in class org.apache.poi.poifs.filesystem.EntryNode
get this Entry's parent (the DocumentEntry that owns this Entry).
getParent() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

getParent() - Method in class org.apache.poi.poifs.filesystem.POIFSDocumentPath
Returns the path's parent or null if this path is the root path.
getParent() - Method in class org.apache.poi.POIXMLDocumentPart
Returns the parent POIXMLDocumentPart.
getParent() - Method in interface org.apache.poi.sl.usermodel.Shape

getParent() - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Gets the parent shape.
getParentIndex() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
for cell XF types this is the parent style (usually 0/normal).
getParentRecord() - Method in interface org.apache.poi.hslf.record.ParentAwareRecord

getParentRecord() - Method in class org.apache.poi.hslf.record.TextHeaderAtom

getParentStyle() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Return the parent style for this cell style.
getParsedExpression() - Method in class org.apache.poi.hssf.record.ExternalNameRecord

getParsedExpression() - Method in class org.apache.poi.hssf.record.FormulaRecord

getParsedExpression1() - Method in class org.apache.poi.hssf.record.CFRuleRecord
get the stack of the 1st expression as a list
getParsedExpression2() - Method in class org.apache.poi.hssf.record.CFRuleRecord
get the stack of the 2nd expression as a list
getPart(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Retrieve a part identified by its name.
getPart(PackageRelationship) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Get the target part from the specified relationship.
getPart() - Method in interface org.apache.poi.xwpf.usermodel.IBody
returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell.
getPart() - Method in interface org.apache.poi.xwpf.usermodel.IBodyElement

getPart() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell.
getPart() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
returns the Part, to which the body belongs, which you need for adding relationship to other parts
getPart() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
returns the Part, to which the body belongs, which you need for adding relationship to other parts
getPart() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
returns the part of the bodyElement
getPart() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
returns the part of the bodyElement
getPart() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
get the to which the TableCell belongs
getPartById(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Get the document part that's defined as the given relationship of the core document.
getPartImpl(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Get the package part mapped to the specified URI.
getPartImpl(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Implement the getPart() method to retrieve a part from its URI in the current package
getPartName() - Method in class org.apache.poi.openxml4j.opc.PackagePart

getParts() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Load the parts of the archive if it has not been done yet.
getPartsByContentType(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Retrieve parts by content type.
getPartsByName(Pattern) - Method in class org.apache.poi.openxml4j.opc.OPCPackage

getPartsByRelationshipType(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Retrieve parts by relationship type.
getPartsImpl() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Get all parts link to the package.
getPartsImpl() - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Retrieves the parts from this package.
getPartType() - Method in interface org.apache.poi.xwpf.usermodel.IBody
get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,
getPartType() - Method in interface org.apache.poi.xwpf.usermodel.IBodyElement

getPartType() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,
getPartType() - Method in class org.apache.poi.xwpf.usermodel.XWPFFooter
get the PartType of the body
getPartType() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
get the PartType of the body
getPartType() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeader
get the PartType of the body
getPartType() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
returns the partType of the bodyPart which owns the bodyElement
getPartType() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
returns the partType of the bodyPart which owns the bodyElement
getPartType() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getPassword() - Method in class org.apache.poi.hssf.record.FileSharingRecord

getPassword() - Method in class org.apache.poi.hssf.record.PasswordRecord
get the password
getPassword() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getPasswordHash() - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

getPasswordRecord() - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

getPasswordVerifier() - Method in class org.apache.poi.hssf.record.common.FeatProtection

getPath() - Method in class org.apache.poi.hpbf.model.HPBFPart
Returns
getPath() - Method in class org.apache.poi.hslf.model.Freeform
Gets the freeform path
getPath() - Method in class org.apache.poi.hslf.model.MovieShape

getPath() - Method in class org.apache.poi.hssf.record.DConRefRecord

getPath(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Get the directory path from the specified URI.
getPath() - Method in class org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent

getPath() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode

getPath() - Method in class org.apache.poi.poifs.filesystem.POIFSWriterEvent

getPath() - Method in class org.apache.poi.xslf.model.geom.Outline

getPath(Context) - Method in class org.apache.poi.xslf.model.geom.Path
Convert the internal represenation to java.awt.GeneralPath
getPath() - Method in class org.apache.poi.xslf.usermodel.XSLFFreeformShape
Gets the shape path.
getPathAtom() - Method in class org.apache.poi.hslf.record.ExVideoContainer
Returns the Path Atom (CString) of this link
getPathForXmlSchema() - Static method in class org.apache.poi.openxml4j.opc.Configuration

getPatriarch() - Method in class org.apache.poi.hssf.record.EscherAggregate

getPattern() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Get the pattern field for the AreaFormat record.
getPatternFormatting() - Method in class org.apache.poi.hssf.record.CFRuleRecord

getPatternFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

getPatternFormatting() - Method in interface org.apache.poi.ss.usermodel.ConditionalFormattingRule

getPatternFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule

getPatternFormattingBlock() - Method in class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

getPatternType() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
get the fill pattern
getPcHorz() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the pcHorz field for the PAP record.
getPcHorz() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Horizontal position code.
getPctCharWidth() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Character scale.
getPctWwd() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: percent of Window size for AutoFit in WebView.
getPcVert() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the pcVert field for the PAP record.
getPcVert() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Vertical position code.
getPerformDataValidation() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

getPersistId() - Method in class org.apache.poi.hslf.record.ExOleObjStg
Fetch our sheet ID, as found from a PersistPtrHolder.
getPersistId() - Method in interface org.apache.poi.hslf.record.PersistRecord
Fetch the persist ID
getPersistPointersOffset() - Method in class org.apache.poi.hslf.record.UserEditAtom

getPgbProp() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the pgbProp field for the SEP record.
getPgnStart() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the pgnStart field for the SEP record.
getPhe() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the phe field for the PAP record.
getPhoneticText() - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

getPhRuns() - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

getPhysicalNumberOfCells() - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

getPhysicalNumberOfCells() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
gets the number of defined cells (NOT number of cells in the actual row!).
getPhysicalNumberOfCells() - Method in interface org.apache.poi.ss.usermodel.Row
Gets the number of defined cells (NOT number of cells in the actual row!).
getPhysicalNumberOfCells() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Gets the number of defined cells (NOT number of cells in the actual row!).
getPhysicalNumberOfCells() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Gets the number of defined cells (NOT number of cells in the actual row!).
getPhysicalNumberOfRows() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

getPhysicalNumberOfRows() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns the number of physically defined rows (NOT the number of rows in the sheet)
getPhysicalNumberOfRows() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns the number of physically defined rows (NOT the number of rows in the sheet)
getPhysicalNumberOfRows() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns the number of physically defined rows (NOT the number of rows in the sheet)
getPhysicalNumberOfRows() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the number of phsyically defined rows (NOT the number of rows in the sheet)
getPicf() - Method in class org.apache.poi.hwpf.model.PICFAndOfficeArtData

getPicOffset() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getPicturedata() - Method in class org.apache.poi.ddf.EscherBlipRecord

getPictureData() - Method in class org.apache.poi.hslf.model.Fill
PictureData object used in a texture, pattern of picture fill.
getPictureData() - Method in class org.apache.poi.hslf.model.Picture
Returns the picture data for this picture.
getPictureData() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns the data of all the pictures attached to the SlideShow
getPictureData() - Method in class org.apache.poi.hssf.usermodel.HSSFPicture
Return picture data for this shape
getPictureData() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Returns picture data if this shape has (single?) associated picture data
getPictureData() - Method in interface org.apache.poi.sl.usermodel.Picture

getPictureData() - Method in interface org.apache.poi.sl.usermodel.Resources

getPictureData() - Method in interface org.apache.poi.ss.usermodel.Picture
Return picture data for this picture
getPictureData() - Method in class org.apache.poi.xslf.usermodel.XSLFPictureShape

getPictureData() - Method in class org.apache.poi.xssf.usermodel.XSSFPicture
Return picture data for this shape
getPictureData() - Method in class org.apache.poi.xwpf.usermodel.XWPFPicture
Get the PictureData of the Picture, if present.
getPictureDataByID(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
returns the PictureData by blipID
getPictureDataByID(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
returns the PictureData by blipID
getPictureIndex() - Method in class org.apache.poi.hslf.model.Picture
Returns index associated with this picture.
getPictureIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFPicture

getPictureName() - Method in class org.apache.poi.hslf.model.Picture
Name of this picture.
getPictures() - Method in class org.apache.poi.hslf.HSLFSlideShow
Return array of pictures contained in this presentation
getPictures() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getPicturesManager() - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

getPicturesTable() - Method in class org.apache.poi.hwpf.HWPFDocument

getPictureText() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Returns any text from any suitable pictures in the paragraph
getPictureText() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Returns text embedded in pictures
getPictureType() - Method in class org.apache.poi.xslf.usermodel.XSLFPictureData
Return an integer constant that specifies type of this picture
getPictureType() - Method in class org.apache.poi.xssf.usermodel.XSSFPictureData
Return an integer constant that specifies type of this picture
getPictureType() - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData
Return an integer constant that specifies type of this picture
getPIDString(long) - Method in class org.apache.poi.hpsf.Section
Returns the PID string associated with a property ID.
getPIDString(byte[], long) - Static method in class org.apache.poi.hpsf.wellknown.SectionIDMap
Returns the property ID string that is associated with a given property ID in a section format ID's namespace.
getPieceDescriptor() - Method in class org.apache.poi.hwpf.model.TextPiece

getPitchAndFamily() - Method in class org.apache.poi.hslf.model.PPFont
get lfPitchAndFamily
getPitchAndFamily() - Method in class org.apache.poi.hslf.record.FontEntityAtom
get lfPitchAndFamily
getPitchAndFamily() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getPlaceholder(int) - Method in class org.apache.poi.hslf.model.Sheet
Search text placeholer by its type
getPlaceholder(int) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getPlaceholderAtom() - Method in class org.apache.poi.hslf.model.TextShape
Return OEPlaceholderAtom, the atom that describes a placeholder.
getPlaceholderByTextType(int) - Method in class org.apache.poi.hslf.model.Sheet
Return placeholder by text type
getPlaceholderId() - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom
Returns the placeholder Id.
getPlaceholderId() - Method in class org.apache.poi.hslf.record.RoundTripHFPlaceholder12
Gets the comment number (note - each user normally has their own count).
getPlaceholders() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getPlaceholderSize() - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom
Returns the placeholder size.
getPlaceholderType() - Method in class org.apache.poi.xslf.usermodel.DrawingTextPlaceholder
What kind of placeholder is this?
getPlaceholderTypeEnum() - Method in class org.apache.poi.xslf.usermodel.DrawingTextPlaceholder
What kind of placeholder is this?
getPlacementId() - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom
Returns the placement Id.
getPlainRecordStream() - Method in class org.apache.poi.hssf.model.RowBlocksReader

getPlcfHdd() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getPlcfHddOffset() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Return the offset to the PlcfHdd, in the table stream, i.e.
getPlcfHddSize() - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Return the size of the PlcfHdd, in the table stream, i.e.
getPlcValA() - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

getPlcValB() - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

getPnNext() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.
getPOIFSDirectory() - Method in class org.apache.poi.hslf.HSLFSlideShow
Returns the directory in the underlying POIFSFileSystem for the document that is open.
getPOIFSFileSystem() - Method in class org.apache.poi.hslf.HSLFSlideShow
Returns the underlying POIFSFileSystem for the document that is open.
getPOIFSName() - Method in class org.apache.poi.hsmf.datatypes.AttachmentChunks

getPointAt(int) - Method in interface org.apache.poi.ss.usermodel.charts.ChartDataSource
Returns point value at specified index.
getPointCount() - Method in interface org.apache.poi.ss.usermodel.charts.ChartDataSource
Return number of points contained by data source.
getPointedToStreams() - Method in class org.apache.poi.hdgf.streams.PointerContainingStream
Returns all the "child" streams.
getPointer() - Method in class org.apache.poi.hdgf.streams.Stream

getPointNumber() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Get the point number field for the DataFormat record.
getPosition() - Method in class org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor

getPosition() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

getPosition() - Method in interface org.apache.poi.ss.usermodel.charts.ChartLegend

getPosition() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

getPosition() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartLegend

getPositionOfBof() - Method in class org.apache.poi.hssf.record.BoundSheetRecord
get the offset in bytes of the Beginning of File Marker within the HSSF Stream part of the POIFS file
getPosOfParagraph(XWPFParagraph) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Get the position of the paragraph, within the list of all the body elements.
getPosOfTable(XWPFTable) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Get the position of the table, within the list of all the body elements.
getPPDrawing() - Method in class org.apache.poi.hslf.model.Sheet
Fetch the PPDrawing from the underlying record
getPPDrawing() - Method in class org.apache.poi.hslf.record.MainMaster
Returns the PPDrawing of this Slide, which has all the interesting data in it
getPPDrawing() - Method in class org.apache.poi.hslf.record.Notes
Returns the PPDrawing of this Notes, which has all the interesting data in it
getPPDrawing() - Method in class org.apache.poi.hslf.record.SheetContainer
Returns the PPDrawing of this sheet, which has all the interesting data in it
getPPDrawing() - Method in class org.apache.poi.hslf.record.Slide
Returns the PPDrawing of this Slide, which has all the interesting data in it
getPPDrawingGroup() - Method in class org.apache.poi.hslf.record.Document
Returns the PPDrawingGroup, which holds an Escher Structure that contains information on pictures in the slides.
getPreData() - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

getPreferEventExtractor() - Static method in class org.apache.poi.extractor.ExtractorFactory
Should this thread use event based extractors is available? Checks the all-threads one first, then thread specific.
getPreferredEncoding() - Static method in class org.apache.poi.util.StringUtil

getPreferredSize() - Method in class org.apache.poi.hssf.usermodel.HSSFPicture
Calculate the preferred size for this picture.
getPreferredSize(double) - Method in class org.apache.poi.hssf.usermodel.HSSFPicture
Calculate the preferred size for this picture.
getPreferredSize() - Method in interface org.apache.poi.ss.usermodel.Picture

getPreferredSize() - Method in class org.apache.poi.xssf.usermodel.XSSFPicture
Calculate the preferred size for this picture.
getPreferredSize(double) - Method in class org.apache.poi.xssf.usermodel.XSSFPicture
Calculate the preferred size for this picture.
getPrefixForLocale(Locale) - Static method in class org.apache.poi.ss.util.DateFormatConverter

getPresentation() - Method in class org.apache.poi.xslf.XSLFSlideShow
Returns the low level presentation base object
getPresentationFormat() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the presentation format (or null).
getPreviousChild() - Method in interface org.apache.poi.poifs.property.Child
Get the previous Child, if any
getPreviousChild() - Method in class org.apache.poi.poifs.property.Property
Get the previous Child, if any
getPrimaryUID() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getPrintableRecordContents(Record) - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

getPrintArea(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
getPrintArea(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
getPrintArea(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
getPrintArea(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
getPrintGridlines() - Method in class org.apache.poi.hssf.model.InternalSheet
Returns the PrintGridlinesRecord.
getPrintGridlines() - Method in class org.apache.poi.hssf.record.PrintGridlinesRecord
get whether or not to print the gridlines (and make your spreadsheet ugly)
getPrintHeaders() - Method in class org.apache.poi.hssf.record.PrintHeadersRecord
get whether to print the headers - y/n
getPrintSetup() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Returns the PrintSetupRecord.
getPrintSetup() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Gets the print setup object.
getPrintSetup() - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the print setup object.
getPrintSetup() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the print setup object.
getPrintSetup() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Gets the print setup object.
getPrm() - Method in class org.apache.poi.hwpf.model.PieceDescriptor

getProgID() - Method in class org.apache.poi.hslf.model.OLEShape
Returns the ProgID that stores the OLE Programmatic Identifier.
getProgId() - Method in class org.apache.poi.hslf.record.ExEmbed
Gets the OLE Programmatic Identifier.
getProgrammableTag() - Method in class org.apache.poi.hslf.model.Sheet
Return programmable tag associated with this sheet, e.g.
getPromptBoxText() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getPromptBoxText() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getPromptBoxText() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getPromptBoxTitle() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getPromptBoxTitle() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getPromptBoxTitle() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getProperties() - Method in class org.apache.poi.hpsf.MutableSection
Gets this section's properties.
getProperties() - Method in class org.apache.poi.hpsf.PropertySet
Convenience method returning the Property array contained in this property set.
getProperties() - Method in class org.apache.poi.hpsf.Section
Returns this section's properties.
getProperties() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getProperties() - Method in class org.apache.poi.POIXMLDocument
Get the document properties.
getPropertiesPerBlock() - Method in class org.apache.poi.poifs.common.POIFSBigBlockSize

getProperty() - Method in class org.apache.poi.hmef.attribute.MAPIAttribute

getProperty() - Method in class org.apache.poi.hmef.attribute.TNEFAttribute

getProperty(long) - Method in class org.apache.poi.hpsf.MutableSection
Gets a property.
getProperty(int) - Method in class org.apache.poi.hpsf.PropertySet
Convenience method returning the value of the property with the specified ID.
getProperty(long) - Method in class org.apache.poi.hpsf.Section
Returns the value of the property with the specified ID.
getProperty(int) - Method in class org.apache.poi.hpsf.SpecialPropertySet

getProperty(int) - Method in class org.apache.poi.hwpf.model.PlexOfCps

getProperty() - Method in class org.apache.poi.poifs.filesystem.EntryNode
grant access to the property
getPropertyBooleanValue(int) - Method in class org.apache.poi.hpsf.PropertySet
Convenience method returning the value of a boolean property with the specified ID.
getPropertyBooleanValue(int) - Method in class org.apache.poi.hpsf.Section
Returns the value of the boolean property with the specified ID.
getPropertyBooleanValue(int) - Method in class org.apache.poi.hpsf.SpecialPropertySet

getPropertyCount() - Method in class org.apache.poi.hpsf.MutableSection
Overwrites the super class' method to cope with a redundancy: the property count is maintained in a separate member variable, but shouldn't.
getPropertyCount() - Method in class org.apache.poi.hpsf.Section
Returns the number of properties in this section.
getPropertyIntValue(int) - Method in class org.apache.poi.hpsf.PropertySet
Convenience method returning the value of the numeric property with the specified ID.
getPropertyIntValue(long) - Method in class org.apache.poi.hpsf.Section
Returns the value of the numeric property with the specified ID.
getPropertyIntValue(int) - Method in class org.apache.poi.hpsf.SpecialPropertySet

getPropertyName(short) - Static method in class org.apache.poi.ddf.EscherProperties

getPropertyNumber() - Method in class org.apache.poi.ddf.EscherProperty

getPropertySet(String) - Method in class org.apache.poi.POIDocument
For a given named property entry, either return it or null if if it wasn't found
getPropertySetIDMap() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation

getPropertySetIDMap() - Method in class org.apache.poi.hpsf.SpecialPropertySet
The id to name mapping of the properties in this set.
getPropertySetIDMap() - Method in class org.apache.poi.hpsf.SummaryInformation

getPropertySize() - Method in class org.apache.poi.ddf.EscherComplexProperty
Calculates the number of bytes required to serialize this property.
getPropertySize() - Method in class org.apache.poi.ddf.EscherProperty
Most properties are just 6 bytes in length.
getPropertyStart() - Method in class org.apache.poi.poifs.storage.HeaderBlock
get start of Property Table
getPropertyType(short) - Static method in class org.apache.poi.ddf.EscherProperties

getPropertyValue() - Method in class org.apache.poi.ddf.EscherSimpleProperty

getProtect() - Method in class org.apache.poi.hssf.record.ObjectProtectRecord
get whether the sheet is protected or not
getProtect() - Method in class org.apache.poi.hssf.record.ProtectionRev4Record
get whether the this is protected shared/tracked workbook or not
getProtect() - Method in class org.apache.poi.hssf.record.ProtectRecord
get whether the sheet is protected or not
getProtect() - Method in class org.apache.poi.hssf.record.ScenarioProtectRecord
get whether the sheet is protected or not
getProtect() - Method in class org.apache.poi.hssf.record.WindowProtectRecord
is this window protected or not
getProtect() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Answer whether protection is enabled or disabled
getProtect() - Method in interface org.apache.poi.ss.usermodel.Sheet
Answer whether protection is enabled or disabled
getProtect() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Answer whether protection is enabled or disabled
getProtect() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Answer whether protection is enabled or disabled
getProtectionBlock() - Method in class org.apache.poi.hssf.model.InternalSheet

getProtpos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getProviderType() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getPtap() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the ptap field for the PAP record.
getPtg() - Method in class org.apache.poi.ss.formula.eval.NameXEval

getPtgClass() - Method in class org.apache.poi.ss.formula.ptg.Ptg

getQuillContents() - Method in class org.apache.poi.hpbf.HPBFDocument

getRandomAccessWindowSize() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook

getRange() - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

getRange() - Method in class org.apache.poi.hwpf.HWPFDocument
Returns the range which covers the whole of the document, but excludes any headers and footers.
getRange() - Method in class org.apache.poi.hwpf.HWPFDocumentCore
Returns the range which covers the whole of the document, but excludes any headers and footers.
getRange() - Method in class org.apache.poi.hwpf.HWPFOldDocument

getRange() - Method in class org.apache.poi.hwpf.usermodel.HeaderStories

getRawBytes() - Method in class org.apache.poi.hwpf.model.TextPiece

getRawContent() - Method in class org.apache.poi.hwpf.usermodel.Picture
Returns picture's content as it stored in Word file, i.e.
getRawData() - Method in class org.apache.poi.hmef.attribute.MAPIRtfAttribute
Returns the original, compressed RTF
getRawData() - Method in class org.apache.poi.hslf.record.ExOleObjStg

getRawData() - Method in class org.apache.poi.hslf.usermodel.PictureData
Returns the raw binary data of this Picture excluding the first 8 bytes which hold image signature and size of the image data.
getRawData() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

getRawRecord() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

getRawRecord() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

getRawText() - Method in class org.apache.poi.hslf.model.TextRun
Returns the raw text content of the run.
getRawText() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Fetch the text, in raw storage form
getRawText() - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

getRawText() - Method in class org.apache.poi.hssf.usermodel.HSSFFooter

getRawText() - Method in class org.apache.poi.hssf.usermodel.HSSFHeader

getRawValue() - Method in class org.apache.poi.hsmf.datatypes.StringChunk

getRawValue(int) - Method in class org.apache.poi.util.BitField
Obtain the value for the specified BitField, unshifted
getRawValue() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns the raw, underlying ooxml value for the cell
getReadablePath() - Method in class org.apache.poi.hssf.record.DConRefRecord

getReadIndex() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

getReadingOrder() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the reading order for far east versions (0 - Context, 1 - Left to right, 2 - right to left) - We could use some help with support for the far east.
getReadOnly() - Method in class org.apache.poi.hssf.record.FileSharingRecord
get the readonly
getReason() - Method in exception org.apache.poi.hpsf.HPSFException
Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.
getReason() - Method in exception org.apache.poi.hpsf.HPSFRuntimeException
Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.
getReason() - Method in exception org.apache.poi.hssf.eventusermodel.HSSFUserException
Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.
getRecalc() - Method in class org.apache.poi.hssf.record.SaveRecalcRecord
get whether to recalculate formulas/etc before saving or not
getRecalcId() - Method in class org.apache.poi.hssf.model.InternalWorkbook
Get or create RecalcIdRecord
getRecipientDetailsChunks() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets all the recipient details chunks.
getRecipientEmailAddress() - Method in class org.apache.poi.hsmf.datatypes.RecipientChunks
Tries to find their email address, in whichever chunk holds it given the delivery type.
getRecipientEmailAddress() - Method in class org.apache.poi.hsmf.MAPIMessage
Returns all the recipients' email address, separated by semicolons.
getRecipientEmailAddressList() - Method in class org.apache.poi.hsmf.MAPIMessage
Returns an array of all the recipient's email address, normally in TO then CC then BCC order.
getRecipientName() - Method in class org.apache.poi.hsmf.datatypes.RecipientChunks
Tries to find their name, in whichever chunk holds it.
getRecipientNames() - Method in class org.apache.poi.hsmf.MAPIMessage
Returns all the recipients' names, separated by semicolons.
getRecipientNamesList() - Method in class org.apache.poi.hsmf.MAPIMessage
Returns an array of all the recipient's names, normally in TO then CC then BCC order.
getRecordClass(int) - Static method in class org.apache.poi.hssf.record.RecordFactory
Debug / diagnosis method
Gets the POI implementation class for a given sid.
getRecordForFirstCell(FormulaRecordAggregate) - Method in class org.apache.poi.hssf.record.aggregates.SharedValueManager
Gets the SharedValueRecordBase record if it should be encoded immediately after the formula record contained in the specified FormulaRecordAggregate agg.
getRecordId() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord

getRecordId() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord

getRecordId() - Method in class org.apache.poi.ddf.EscherClientDataRecord

getRecordId() - Method in class org.apache.poi.ddf.EscherDggRecord

getRecordId() - Method in class org.apache.poi.ddf.EscherDgRecord

getRecordId() - Method in class org.apache.poi.ddf.EscherRecord
Return the current record id.
getRecordId() - Method in class org.apache.poi.ddf.EscherSpgrRecord

getRecordId() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

getRecordId() - Method in class org.apache.poi.ddf.EscherSpRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherBlipRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherBSERecord

getRecordName() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherClientDataRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherContainerRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherDggRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherDgRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherOptRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherRecord
Subclasses should return the short name for this escher record.
getRecordName() - Method in class org.apache.poi.ddf.EscherSpgrRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherSpRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherTertiaryOptRecord

getRecordName() - Method in class org.apache.poi.ddf.EscherTextboxRecord

getRecordName() - Method in class org.apache.poi.ddf.UnknownEscherRecord

getRecordName() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

getRecordName() - Method in class org.apache.poi.hssf.record.BoolErrRecord

getRecordName() - Method in class org.apache.poi.hssf.record.CellRecord
Gets the debug info BIFF record type name (used by CellRecord.toString().
getRecordName() - Method in class org.apache.poi.hssf.record.DrawingGroupRecord

getRecordName() - Method in class org.apache.poi.hssf.record.DrawingRecordForBiffViewer

getRecordName() - Method in class org.apache.poi.hssf.record.EscherAggregate

getRecordName() - Method in class org.apache.poi.hssf.record.FormulaRecord

getRecordName() - Method in class org.apache.poi.hssf.record.LabelSSTRecord

getRecordName() - Method in class org.apache.poi.hssf.record.NumberRecord

getRecordName() - Method in class org.apache.poi.hssf.record.RKRecord

getRecords() - Method in class org.apache.poi.hslf.HSLFSlideShow
Returns an array of all the records found in the slideshow
getRecords() - Method in class org.apache.poi.hslf.model.TextRun
Returns records that make up this text run
getRecords() - Method in class org.apache.poi.hssf.model.InternalSheet

getRecords() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getRecords() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getRecordsById(short, List<EscherRecord>) - Method in class org.apache.poi.ddf.EscherContainerRecord
Recursively find records with the specified record ID
getRecordSize() - Method in class org.apache.poi.ddf.AbstractEscherOptRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherBitmapBlip

getRecordSize() - Method in class org.apache.poi.ddf.EscherBlipRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherBSERecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherClientDataRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherContainerRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherDggRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherDgRecord
Returns the number of bytes that are required to serialize this record.
getRecordSize() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getRecordSize() - Method in class org.apache.poi.ddf.EscherPictBlip

getRecordSize() - Method in class org.apache.poi.ddf.EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.
getRecordSize() - Method in class org.apache.poi.ddf.EscherSpgrRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherSpRecord

getRecordSize() - Method in class org.apache.poi.ddf.EscherTextboxRecord

getRecordSize() - Method in class org.apache.poi.ddf.UnknownEscherRecord

getRecordSize() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

getRecordSize() - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable

getRecordSize() - Method in class org.apache.poi.hssf.record.aggregates.RecordAggregate

getRecordSize() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecord

getRecordSize() - Method in class org.apache.poi.hssf.record.DrawingGroupRecord

getRecordSize() - Method in class org.apache.poi.hssf.record.EscherAggregate

getRecordSize() - Method in class org.apache.poi.hssf.record.LabelRecord

getRecordSize() - Method in class org.apache.poi.hssf.record.ObjRecord

getRecordSize() - Method in class org.apache.poi.hssf.record.RecordBase
gives the current serialized size of the record.
getRecordSize() - Method in class org.apache.poi.hssf.record.StandardRecord

getRecordSizeForBlockCount(int) - Static method in class org.apache.poi.hssf.record.IndexRecord

getRecordSizeForStrings(int) - Static method in class org.apache.poi.hssf.record.ExtSSTRecord
Given a number of strings (in the sst), returns the size of the extsst record
getRecordType() - Method in class org.apache.poi.hslf.record.AnimationInfo
We are of type 4103
getRecordType() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
We are of type 3999
getRecordType() - Method in class org.apache.poi.hslf.record.Comment2000
We are of type 1200
getRecordType() - Method in class org.apache.poi.hslf.record.Comment2000Atom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.CString
We are of type 4026
getRecordType() - Method in class org.apache.poi.hslf.record.Document
We are of type 1000
getRecordType() - Method in class org.apache.poi.hslf.record.DocumentAtom
We are of type 1001
getRecordType() - Method in class org.apache.poi.hslf.record.DocumentEncryptionAtom
We are of type 12052
getRecordType() - Method in class org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren
Return the value we were given at creation
getRecordType() - Method in class org.apache.poi.hslf.record.DummyRecordWithChildren
Return the value we were given at creation
getRecordType() - Method in class org.apache.poi.hslf.record.Environment
We are of type 1010
getRecordType() - Method in class org.apache.poi.hslf.record.EscherTextboxWrapper
Return the type of the escher record (normally in the 0xFnnn range)
getRecordType() - Method in class org.apache.poi.hslf.record.ExAviMovie
We are of type 4102
getRecordType() - Method in class org.apache.poi.hslf.record.ExControl
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
getRecordType() - Method in class org.apache.poi.hslf.record.ExControlAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.ExEmbed
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
getRecordType() - Method in class org.apache.poi.hslf.record.ExEmbedAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.ExHyperlink
We are of type 4055
getRecordType() - Method in class org.apache.poi.hslf.record.ExHyperlinkAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.ExMCIMovie
We are of type 4103
getRecordType() - Method in class org.apache.poi.hslf.record.ExMediaAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.ExObjList
We are of type 1033
getRecordType() - Method in class org.apache.poi.hslf.record.ExObjListAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
getRecordType() - Method in class org.apache.poi.hslf.record.ExOleObjStg
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.ExVideoContainer
We are of type 4103
getRecordType() - Method in class org.apache.poi.hslf.record.FontCollection
Return the type, which is 2005
getRecordType() - Method in class org.apache.poi.hslf.record.FontEntityAtom

getRecordType() - Method in class org.apache.poi.hslf.record.HeadersFootersAtom

getRecordType() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
Return the type, which is RecordTypes.HeadersFooters
getRecordType() - Method in class org.apache.poi.hslf.record.InteractiveInfo
We are of type 4802
getRecordType() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.MainMaster
We are of type 1016
getRecordType() - Method in class org.apache.poi.hslf.record.Notes
We are of type 1008
getRecordType() - Method in class org.apache.poi.hslf.record.NotesAtom
We are of type 1009
getRecordType() - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom

getRecordType() - Method in class org.apache.poi.hslf.record.OEShapeAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.OutlineTextRefAtom

getRecordType() - Method in class org.apache.poi.hslf.record.PersistPtrHolder
Return the value we were given at creation, be it 6001 or 6002
getRecordType() - Method in class org.apache.poi.hslf.record.PPDrawing
We are type 1036
getRecordType() - Method in class org.apache.poi.hslf.record.PPDrawingGroup
We are type 1035
getRecordType() - Method in class org.apache.poi.hslf.record.Record
Returns the type (held as a little endian in bytes 3 and 4) that this class handles
getRecordType() - Method in class org.apache.poi.hslf.record.RoundTripHFPlaceholder12
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.Slide
We are of type 1006
getRecordType() - Method in class org.apache.poi.hslf.record.SlideAtom
We are of type 1007
getRecordType() - Method in class org.apache.poi.hslf.record.SlideListWithText
Return the value we were given at creation
getRecordType() - Method in class org.apache.poi.hslf.record.SlidePersistAtom
We are of type 1011
getRecordType() - Method in class org.apache.poi.hslf.record.Sound
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
getRecordType() - Method in class org.apache.poi.hslf.record.SoundCollection
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
getRecordType() - Method in class org.apache.poi.hslf.record.SoundData
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
We are of type 4001
getRecordType() - Method in class org.apache.poi.hslf.record.TextBytesAtom
We are of type 4008
getRecordType() - Method in class org.apache.poi.hslf.record.TextCharsAtom
We are of type 4000
getRecordType() - Method in class org.apache.poi.hslf.record.TextHeaderAtom
We are of type 3999
getRecordType() - Method in class org.apache.poi.hslf.record.TextRulerAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Gets the record type.
getRecordType() - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
We are of type 4003
getRecordType() - Method in class org.apache.poi.hslf.record.UnknownRecordPlaceholder
Return the value we were given at creation
getRecordType() - Method in class org.apache.poi.hslf.record.UserEditAtom
We are of type 4085
getRecordType() - Method in class org.apache.poi.hssf.record.common.FtrHeader

getRecordType() - Method in class org.apache.poi.hssf.record.NameCommentRecord

getRectangleBottom() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Bottom of the rectangle enclosing shape relative to the origin of the shape
getRectangleLeft() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Left of rectangle enclosing shape relative to the origin of the shape
getRectangleRight() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Right of rectangle enclosing shape relative to the origin of the shape
getRectangleTop() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Top of rectangle enclosing shape relative to the origin of the shape
getRectX1() - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting top-left coordinate of child records.
getRectX2() - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting bottom-right coordinate of child records.
getRectY1() - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting top-left coordinate of child records.
getRectY2() - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting bottom-right coordinate of child records.
getRed() - Method in class org.apache.poi.ddf.EscherRGBProperty

getRef() - Method in class org.apache.poi.ddf.EscherBSERecord
The reference count of this blip.
getRef3DEval(int, int, int) - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getReference() - Method in class org.apache.poi.hssf.usermodel.HSSFName
Deprecated. (Nov 2008) Misleading name. Use HSSFName.getRefersToFormula() instead.
getReference() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns an A1 style reference to the location of this cell
getReferencedCell() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell
Gets the XSSFCell referenced by the R attribute or creates a new one if cell doesn't exists
getReferenceText() - Method in interface org.apache.poi.ss.usermodel.CellRange

getReferenceText() - Method in class org.apache.poi.ss.util.SSCellRange

getReferenceType() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Get the reference type field for the LinkedData record.
getRefersToFormula() - Method in class org.apache.poi.hssf.usermodel.HSSFName

getRefersToFormula() - Method in interface org.apache.poi.ss.usermodel.Name
Returns the formula that the name is defined to refer to.
getRefersToFormula() - Method in class org.apache.poi.xssf.usermodel.XSSFName

getRefEval(int, int) - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getRefEvaluatorForCurrentSheet() - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getRefID() - Method in class org.apache.poi.hslf.record.SlidePersistAtom

getRefIxForSheet(int, int) - Method in class org.apache.poi.hssf.record.ExternSheetRecord

getRefreshAll() - Method in class org.apache.poi.hssf.record.RefreshAllRecord
get whether to refresh all external data when loading a sheet
getRegionRef() - Method in class org.apache.poi.ss.util.Region
Deprecated.
getRegions() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getRegions() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getRegions() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getRelatedByType(String) - Method in class org.apache.poi.POIXMLDocument
Retrieves all the PackageParts which are defined as relationships of the base document with the specified content type.
getRelatedPart(PackageRelationship) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Get the PackagePart that is the target of a relationship.
getRelatedSingleXMLCell() - Method in class org.apache.poi.xssf.usermodel.XSSFMap

getRelatedTables() - Method in class org.apache.poi.xssf.usermodel.XSSFMap

getRelation() - Method in class org.apache.poi.POIXMLRelation
Return the relationship, the kind of connection between a source part and a target part in a package.
getRelationById(String) - Method in class org.apache.poi.POIXMLDocumentPart
Returns the target POIXMLDocumentPart, where a PackageRelationship is set from the PackagePart of this POIXMLDocumentPart to the PackagePart of the target POIXMLDocumentPart with a PackageRelationship.getId() matching the given parameter value.
getRelationClass() - Method in class org.apache.poi.POIXMLRelation
Return type of the obejct used to construct instances of this relationship
getRelationId(POIXMLDocumentPart) - Method in class org.apache.poi.POIXMLDocumentPart
Returns the PackageRelationship.getId() of the PackageRelationship, that sources from the PackagePart of this POIXMLDocumentPart to the PackagePart of the given parameter value.
getRelations() - Method in class org.apache.poi.POIXMLDocumentPart
Returns the list of child relations for this POIXMLDocumentPart
getRelationship(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage

getRelationship(String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Retrieves a package relationship from its id.
getRelationship(int) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Retrieves a relationship by its index in the collection.
getRelationship(String) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Retrieves a package relationship from its id.
getRelationshipByID(String) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Retrieves a package relationship based on its id.
getRelationshipPartName(PackagePartName) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Build a part name where the relationship should be stored ((ex /word/document.xml -> /word/_rels/document.xml.rels)
getRelationships() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Retrieves all package relationships.
getRelationships() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Retrieve all the relationships attached to this part.
getRelationships(String) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Retrieves all relations with the specified type.
getRelationships() - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Retrieve all the relationships attached to this.
getRelationshipsByType(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Retrieves all relationships with the specified type.
getRelationshipsByType(String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Retrieve all relationships attached to this part which have the specified type.
getRelationshipsByType(String) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Retrieve all relationships attached to this part which have the specified type.
getRelationshipType() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

getRelativeValue(int, int) - Method in interface org.apache.poi.ss.formula.eval.AreaEval

getRelativeValue(int, int) - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getReleaseVersion() - Method in class org.apache.poi.hslf.record.CurrentUserAtom

getRemainingData() - Method in class org.apache.poi.ddf.EscherBSERecord
Any remaining data in this record.
getRemainingData() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
Any remaining data in the record
getRemainingData() - Method in class org.apache.poi.ddf.EscherClientDataRecord
Any data recording this record.
getRemainingData() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getRemainingIdentifiers() - Method in class org.apache.poi.util.IdentifierManager

getRenderedMetaFile() - Method in class org.apache.poi.hmef.Attachment
Returns the Meta File rendered representation of the attachment, or null if not set.
getRendererableFont(String, int) - Method in interface org.apache.poi.xslf.usermodel.XSLFFontManager
select a font to be used to paint text
getRenderingHint(RenderingHints.Key) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns the value of a single preference for the rendering algorithms.
getRenderingHint(RenderingHints.Key) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getRenderingHint(RenderingHints.Key) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getRenderingHints() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Gets the preferences for the rendering algorithms.
getRenderingHints() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getRenderingHints() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getRequiredVersion() - Method in class org.apache.poi.hssf.record.BOFRecord
get the minimum version required to read this file
getReserved() - Method in class org.apache.poi.hssf.record.common.FtrHeader

getReserved() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get the reserved bits - why would you do this?
getReserved() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the reserved field for the DOP record.
getReserved() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Reserved
getReserved() - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType

getReserved1() - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Get the reserved1 field for the Axis record.
getReserved1() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Get the reserved1 field for the CommonObjectData record.
getReserved1() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the reserved1 field for the DOP record.
getReserved1() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the reserved1 field for the FibRgLw95 record.
getReserved1() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved1() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved1() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Reserved.
getReserved1() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Deprecated. This field should not be used according to specification
getReserved10() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved10() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved11() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved11() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved12() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value SHOULD be zero, and MUST be ignored.
getReserved12() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved13() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be zero and MUST be ignored.
getReserved13() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved14() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be zero and MUST be ignored.
getReserved2() - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Get the reserved2 field for the Axis record.
getReserved2() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Get the reserved2 field for the CommonObjectData record.
getReserved2() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the reserved2 field for the DOP record.
getReserved2() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the reserved2 field for the FibRgLw95 record.
getReserved2() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved2() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved2() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Reserved.
getReserved3() - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Get the reserved3 field for the Axis record.
getReserved3() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Get the reserved3 field for the CommonObjectData record.
getReserved3() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the reserved3 field for the FibRgLw95 record.
getReserved3() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved3() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved3() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Reserved.
getReserved4() - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Get the reserved4 field for the Axis record.
getReserved4() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the reserved4 field for the FibRgLw95 record.
getReserved4() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved4() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved5() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Get the reserved5 field for the FibRgLw95 record.
getReserved5() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved5() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved6() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx.
getReserved6() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved7() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved7() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved8() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
getReserved8() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReserved9() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx.
getReserved9() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
getReservedField() - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection

getResolution(ImageReader) - Static method in class org.apache.poi.ss.util.ImageUtils
The metadata of PNG and JPEG can contain the width of a pixel in millimeters.
getResources() - Method in interface org.apache.poi.sl.usermodel.SlideShow

getReturnClassCode() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

getRevision() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getRevisionMarkAuthorTable() - Method in class org.apache.poi.hwpf.HWPFDocument
Gets a reference to the revision mark author table, which holds the revision mark authors for the document.
getRevisionProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get revision.
getRevisionProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the revision number.
getRevNumber() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the revision number (or null).
getRgb() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Standard Red Green Blue ctColor value (RGB).
getRgbColor() - Method in class org.apache.poi.ddf.EscherRGBProperty

getRgbColor() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the rgbColor field for the Text record.
getRgbrcInsideDefault_0() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Border definition for inside horizontal borders.
getRgbrcInsideDefault_1() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Border definition for inside vertical borders.
getRgbWithTint() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Standard Red Green Blue ctColor value (RGB) with applied tint.
getRgbxchNums() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An array of 8-bit integers.
getRgdxaCenter() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..
getRgdxaCenterPrint() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getRgdxaColumn() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the rgdxaColumn field for the SEP record.
getRgdxaTab() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Array of positions of itbdMac tab stops.
getRgf() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Get the rgf field for the TC record.
getRgistdPara() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
An array of nine 16-bit signed integers.
getRgshd() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the rgshd field for the TAP record.
getRgtbd() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Array of itbdMac tab descriptors.
getRgtc() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the rgtc field for the TAP record.
getRichStringCellValue() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
get the value of the cell as a string - for numeric cells we throw an exception.
getRichStringCellValue() - Method in interface org.apache.poi.ss.usermodel.Cell
Get the value of the cell as a XSSFRichTextString
getRichStringCellValue() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Get the value of the cell as a XSSFRichTextString
getRichStringCellValue() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Get the value of the cell as a XSSFRichTextString
getRichTextRunAt(int) - Method in class org.apache.poi.hslf.model.TextRun
Fetch RichTextRun at a given position
getRichTextRuns() - Method in class org.apache.poi.hslf.model.TextRun
Fetch the rich text runs (runs of text with the same styling) that are contained within this block of text
getRight() - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

getRight() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
getRight() - Method in interface org.apache.poi.ss.usermodel.Footer
Get the right side of the footer.
getRight() - Method in interface org.apache.poi.ss.usermodel.Header
Get the right side of the header.
getRight() - Method in interface org.apache.poi.ss.usermodel.HeaderFooter
Get the right side of the header or footer.
getRight() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
get the text representing the right part of this element
getRightBorder() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getRightBorder() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getRightBorder() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getRightBorderColor() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the color to use for the right border
getRightBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getRightBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the color to use for the left border
getRightBorderColor() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getRightBorderColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the color to use for the left border
getRightBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getRightBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the right border
getRightBorderPaletteIdx() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the palette index for the right border color
getRightBorderXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the right border
getRightInset() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Returns the distance (in points) between the right edge of the text frame and the right edge of the inscribed rectangle of the shape that contains the text.
getRightSection(String) - Method in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

getRightToLeft() - Method in class org.apache.poi.hslf.record.DocumentAtom
Is this a Bi-Directional PPT Doc?
getRKNumber() - Method in class org.apache.poi.hssf.record.RKRecord
Extract the value of the number
getRKNumberAt(int) - Method in class org.apache.poi.hssf.record.MulRKRecord
returns the rk number for column (coffset = column - field_2_first_col)
getRncEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getRncFtn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getRoot() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Get the root entry
getRoot() - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
get the root entry
getRoot() - Method in class org.apache.poi.poifs.property.PropertyTableBase
Get the root property
getRoot() - Method in class org.apache.poi.POIOLE2TextExtractor

getRootElementName() - Method in class org.apache.poi.xslf.usermodel.XSLFNotes

getRootElementName() - Method in class org.apache.poi.xslf.usermodel.XSLFNotesMaster

getRootElementName() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getRootElementName() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getRootElementName() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout

getRootElementName() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getRotation() - Method in class org.apache.poi.hslf.model.SimpleShape
Rotation angle in degrees
getRotation() - Method in class org.apache.poi.hssf.record.chart.TextRecord

getRotation() - Method in class org.apache.poi.hssf.record.chart.TickRecord
rotate text (0=none, 1=normal, 2=90 degrees counterclockwise, 3=90 degrees clockwise)
getRotation() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the degree of rotation.
getRotation() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the degree of rotation for the text in the cell
getRotation() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the degree of rotation for the text in the cell
getRotation() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame
Rotation angle in degrees
getRotation() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getRotation() - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Rotation angle in degrees
getRotation() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getRotation() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the degree of rotation for the text in the cell
getRow() - Method in class org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord
Returns the (0 based) number of the row we are currently working on.
getRow() - Method in class org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord

getRow(int) - Method in class org.apache.poi.hssf.model.InternalSheet
get the NEXT (from LOC) RowRecord where rownumber matches the given rownum.
getRow() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

getRow(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

getRow() - Method in class org.apache.poi.hssf.record.BlankRecord
get the row this cell occurs on
getRow() - Method in class org.apache.poi.hssf.record.CellRecord

getRow() - Method in interface org.apache.poi.hssf.record.CellValueRecordInterface

getRow() - Method in class org.apache.poi.hssf.record.LabelRecord

getRow() - Method in class org.apache.poi.hssf.record.MulBlankRecord

getRow() - Method in class org.apache.poi.hssf.record.MulRKRecord

getRow() - Method in class org.apache.poi.hssf.record.NoteRecord
Return the row that contains the comment
getRow() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Returns the HSSFRow this cell belongs to
getRow() - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Return the row of the cell that contains the comment
getRow(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns the logical row (not physical) 0-based.
getRow(int, HSSFSheet) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
Get a row from the spreadsheet, and create it if it doesn't exist.
getRow(int) - Method in class org.apache.poi.hwpf.usermodel.Table

getRow() - Method in interface org.apache.poi.ss.formula.eval.RefEval
returns the zero based row index.
getRow() - Method in class org.apache.poi.ss.formula.eval.RefEvalBase

getRow() - Method in class org.apache.poi.ss.formula.ptg.ExpPtg

getRow() - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

getRow() - Method in class org.apache.poi.ss.formula.ptg.TblPtg

getRow(int) - Method in interface org.apache.poi.ss.formula.TwoDEval

getRow() - Method in interface org.apache.poi.ss.usermodel.Cell
Returns the Row this cell belongs to
getRow() - Method in interface org.apache.poi.ss.usermodel.Comment
Return the row of the cell that contains the comment
getRow(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns the logical row (not physical) 0-based.
getRow() - Method in class org.apache.poi.ss.util.CellReference

getRow(int, Sheet) - Static method in class org.apache.poi.ss.util.CellUtil
Get a row from the spreadsheet, and create it if it doesn't exist.
getRow() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Returns the Row this cell belongs to
getRow(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns the logical row (not physical) 0-based.
getRow() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns the row this cell belongs to
getRow() - Method in class org.apache.poi.xssf.usermodel.XSSFComment

getRow(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the logical row ( 0-based).
getRow(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getRow(CTRow) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
returns the XWPFRow which belongs to the CTRow row if this row is not existing in the table null will be returned
getRow1() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The row number for the top-left corner of the shape.
getRow1() - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

getRow1() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the row (0 based) of the first cell.
getRow1() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getRow2() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The row number for the bottom-right corner of the current shape.
getRow2() - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

getRow2() - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the row (0 based) of the second cell.
getRow2() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

getRowBandSize() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getRowBlockCount() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
Returns the number of row blocks.
getRowBreaks() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

getRowBreaks() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getRowBreaks() - Method in interface org.apache.poi.ss.usermodel.Sheet
Retrieves all the horizontal page breaks
getRowBreaks() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Retrieves all the horizontal page breaks
getRowBreaks() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Horizontal page break information used for print layout view, page layout view, drawing print breaks in normal view, and for printing the worksheet.
getRowCellBlockSize(int, int) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate
Tallies a count of the size of the cell records that are attached to the rows in the range specified.
getRowCount() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

getRowCount() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getRowCountForBlock(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
Returns the number of physical rows within a block
getRowFrom() - Method in class org.apache.poi.ss.util.Region
Deprecated. get the upper left hand corner row number
getRowHeight() - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord
get the default row height
getRowHeight() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getRowIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFCell

getRowIndex() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getRowIndex() - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getRowIndex() - Method in interface org.apache.poi.ss.usermodel.Cell
Returns row index of a row in the sheet that contains this cell
getRowIndex() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Returns row index of a row in the sheet that contains this cell
getRowIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns row index of a row in the sheet that contains this cell
getRowInputCol() - Method in class org.apache.poi.hssf.record.TableRecord

getRowInputRow() - Method in class org.apache.poi.hssf.record.TableRecord

getRowJustification() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getRowLevelMax() - Method in class org.apache.poi.hssf.record.GutsRecord
get the maximum outline level for the row gutter.
getRowName(HSSFRow) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter
Generates name for output as row number in case AbstractExcelConverter.isOutputRowNumbers() == true
getRowNum() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
get row number this row represents
getRowNum() - Method in interface org.apache.poi.ss.usermodel.Row
Get row number this row represents
getRowNum() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Get row number this row represents
getRowNum(SXSSFRow) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet

getRowNum() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Get row number this row represents
getRowNumber() - Method in class org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord

getRowNumber() - Method in class org.apache.poi.hssf.record.RowRecord
get the logical row number for this row (0 based index)
getRowNumber() - Method in interface org.apache.poi.ss.util.cellwalk.CellWalkContext
Returns number of current row.
getRowRecord() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
get the lowlevel RowRecord represented by this object - should only be called by other parts of the high level API
getRows() - Method in class org.apache.poi.xslf.usermodel.DrawingTable

getRows() - Method in class org.apache.poi.xslf.usermodel.XSLFTable

getRows() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getRowsAggregate() - Method in class org.apache.poi.hssf.model.InternalSheet

getRowStyle() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Returns the whole-row cell styles.
getRowStyle() - Method in interface org.apache.poi.ss.usermodel.Row
Returns the whole-row cell styles.
getRowStyle() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Returns the whole-row cell style.
getRowStyle() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Returns the whole-row cell style.
getRowSumsBelow() - Method in class org.apache.poi.hssf.record.WSBoolRecord
get if row summaries appear below detail in the outline
getRowSumsBelow() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get if row summaries appear below detail in the outline
getRowSumsBelow() - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
getRowSumsBelow() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
getRowSumsBelow() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
getRowSumsRight() - Method in class org.apache.poi.hssf.record.WSBoolRecord
get if col summaries appear right of the detail in the outline
getRowSumsRight() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get if col summaries appear right of the detail in the outline
getRowSumsRight() - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
getRowSumsRight() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
getRowSumsRight() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
getRowTo() - Method in class org.apache.poi.ss.util.Region
Deprecated. get the lower right hand corner row number
getRPr() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getRsid() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Save ID for last time this PAP was revised.
getRsid() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.
getRtfBody() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the RTF Rich Message body of this Outlook Message, if this email contains a RTF (rich) version.
getRule(int) - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

getRule(int) - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

getRule(int) - Method in interface org.apache.poi.ss.usermodel.ConditionalFormatting

getRule(int) - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormatting

getRun() - Method in class org.apache.poi.xwpf.usermodel.PositionInParagraph

getRun(CTR) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
return the XWPFRun-Element which owns the CTR run-Element
getRuns() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph

getRunType() - Method in class org.apache.poi.hslf.model.TextRun
Returns the type of the text, from the TextHeaderAtom.
getRVAType() - Method in class org.apache.poi.ss.formula.ptg.Ptg
Debug / diagnostic method to get this token's 'operand class' type.
getSalt() - Method in class org.apache.poi.poifs.crypt.EncryptionVerifier

getSaltData() - Method in class org.apache.poi.hssf.record.FilePassRecord

getSaltHash() - Method in class org.apache.poi.hssf.record.FilePassRecord

getSavedByTable() - Method in class org.apache.poi.hwpf.HWPFDocument
Gets a reference to the saved -by table, which holds the save history for the document.
getSavedInPageBreakPreview() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
was the sheet saved in page break view
getSaveLinkValues() - Method in class org.apache.poi.hssf.record.BookBoolRecord
get the save ext links flag
getSaveLocation() - Method in class org.apache.poi.hwpf.model.SavedByEntry

getSaveWithFonts() - Method in class org.apache.poi.hslf.record.DocumentAtom
Was the document saved with True Type fonts embeded?
getSBAT() - Method in class org.apache.poi.poifs.storage.SmallBlockTableWriter
Get the SBAT
getSBATBlockAndIndex(int, HeaderBlock, List<BATBlock>) - Static method in class org.apache.poi.poifs.storage.BATBlock
Returns the BATBlock that handles the specified offset, and the relative index within it, for the mini stream.
getSBATBlockCount() - Method in class org.apache.poi.poifs.storage.SmallBlockTableWriter
Get the number of SBAT blocks
getSBATCount() - Method in class org.apache.poi.poifs.storage.HeaderBlock

getSBATStart() - Method in class org.apache.poi.poifs.storage.HeaderBlock

getScale() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns true when scaling of the thumbnail is desired, false if cropping is desired.
getScale() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Get the scale field for the FontBasis record.
getScale() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getScale() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the scale.
getScale() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the scale.
getScale() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the scale.
getScenarioProtect() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Answer whether scenario protection is enabled or disabled
getScenarioProtect() - Method in interface org.apache.poi.ss.usermodel.Sheet
Answer whether scenario protection is enabled or disabled
getScenarioProtect() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Answer whether scenario protection is enabled or disabled
getScenarioProtect() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
A flag indicating whether scenarios are locked when the sheet is protected.
getSchema() - Method in class org.apache.poi.xssf.usermodel.XSSFMap

getScheme() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the font scheme property.
getSecondaryUID() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the secondary UID
getSection(int) - Method in class org.apache.poi.hwpf.usermodel.Range
Gets the section at index.
getSectionCount() - Method in class org.apache.poi.hpsf.PropertySet
Returns the number of Sections in the property set.
getSectionCount() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getSectionDescriptor() - Method in class org.apache.poi.hwpf.model.SEPX

getSectionProperties() - Method in class org.apache.poi.hwpf.model.SEPX

getSections() - Method in class org.apache.poi.hpsf.PropertySet
Returns the Sections in the property set.
getSections() - Method in class org.apache.poi.hpsf.SpecialPropertySet

getSections() - Method in class org.apache.poi.hwpf.model.SectionTable

getSectionTable() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getSecurity() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns a security code which is one of the following values:
getSelected() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
sheet tab is selected
getSelectedTab() - Method in class org.apache.poi.hssf.record.WindowOneRecord
Deprecated. - Misleading name - use getActiveSheetIndex()
getSelectedTab() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. - Misleading name - use getActiveSheetIndex()
getSelection() - Method in class org.apache.poi.hssf.model.InternalSheet

getSeparator() - Method in class org.apache.poi.hdgf.chunks.Chunk
Gets the separator between this chunk and the next, if it exists
getSeries() - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Returns the series of the chart
getSeries() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getSeries() - Method in interface org.apache.poi.ss.usermodel.charts.ScatterChartData

getSeries() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData

getSeriesIndex() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Get the series index field for the DataFormat record.
getSeriesNumber() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Get the series number field for the DataFormat record.
getSeriesNumbers() - Method in class org.apache.poi.hssf.record.chart.SeriesListRecord
Get the series numbers field for the SeriesList record.
getSeriesTitle() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries
Returns the series' title, if there is one, or null if not
getServerZoomFrom() - Method in class org.apache.poi.hslf.record.DocumentAtom

getServerZoomTo() - Method in class org.apache.poi.hslf.record.DocumentAtom

getSfxtText() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Text animation.
getShading() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getShading() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getShadow() - Method in class org.apache.poi.xslf.usermodel.XSLFConnectorShape
YK: shadows of lines are suppressed for now.
getShadow() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getShadowsColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Shadows Colour
getShape() - Method in class org.apache.poi.hwpf.model.PICFAndOfficeArtData

getShapeAnchor() - Method in class org.apache.poi.xslf.model.geom.Context

getShapeGroup() - Method in class org.apache.poi.hslf.model.PPGraphics2D

getShapeId() - Method in class org.apache.poi.ddf.EscherSpRecord

getShapeId() - Method in class org.apache.poi.hslf.model.Shape

getShapeId() - Method in class org.apache.poi.hslf.model.TextRun

getShapeId() - Method in class org.apache.poi.hslf.record.EscherTextboxWrapper

getShapeId() - Method in class org.apache.poi.hssf.record.NoteRecord
Object id for OBJ record that contains the comment
getShapeId() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Shape Identifier
getShapeId() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

getShapeId() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getShapeId() - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Returns a unique identifier for this shape within the current document.
getShapeId() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getShapeIdMax() - Method in class org.apache.poi.ddf.EscherDggRecord

getShapeName() - Method in class org.apache.poi.hslf.model.Shape

getShapeName() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

getShapeName() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getShapeName() - Method in class org.apache.poi.xslf.usermodel.XSLFShape

getShapeName() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getShapeOutline(int) - Static method in class org.apache.poi.hslf.model.AutoShapes
Return shape outline by shape type
getShapeProperties() - Method in class org.apache.poi.xssf.usermodel.XSSFConnector

getShapeProperties() - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame

getShapeProperties() - Method in class org.apache.poi.xssf.usermodel.XSSFPicture

getShapeProperties() - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Returns xml bean with shape properties.
getShapeProperties() - Method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup

getShapeProperties() - Method in class org.apache.poi.xssf.usermodel.XSSFSimpleShape

getShapes() - Method in class org.apache.poi.hslf.model.ShapeGroup

getShapes() - Method in class org.apache.poi.hslf.model.Sheet
Returns all shapes contained in this Sheet
getShapes() - Method in class org.apache.poi.hwpf.model.FSPATable

getShapes() - Method in interface org.apache.poi.sl.usermodel.ShapeContainer

getShapes() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getShapes() - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
Returns an array containing all of the elements in this container in proper sequence (from first to last element).
getShapes() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Returns an array containing all of the shapes in this sheet
getShapes() - Method in class org.apache.poi.xssf.usermodel.XSSFDrawing

getShapesTable() - Method in class org.apache.poi.hwpf.HWPFDocument
Deprecated. use HWPFDocument.getOfficeDrawingsMain() instead
getShapeType() - Method in class org.apache.poi.ddf.EscherSpRecord
Returns shape type.
getShapeType() - Method in class org.apache.poi.hslf.model.Shape

getShapeType() - Method in class org.apache.poi.hslf.model.ShapeGroup
Return type of the shape.
getShapeType() - Method in class org.apache.poi.hssf.usermodel.HSSFSimpleShape
Gets the shape type.
getShapeType() - Method in interface org.apache.poi.sl.usermodel.Shape

getShapeType() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

getShapeType() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getShapeType() - Method in class org.apache.poi.xssf.usermodel.XSSFConnector
Gets the shape type, one of the constants defined in ShapeTypes.
getShapeType() - Method in class org.apache.poi.xssf.usermodel.XSSFSimpleShape
Gets the shape type, one of the constants defined in ShapeTypes.
getSharedFeature() - Method in class org.apache.poi.hssf.record.FeatRecord

getSharedFormulaManager() - Method in class org.apache.poi.hssf.model.RowBlocksReader

getSharedStringsData() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Returns an InputStream to read the contents of the shared strings table.
getSharedStringSource() - Method in class org.apache.poi.xssf.usermodel.XSSFCell

getSharedStringSource() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Returns SharedStringsTable - tha cache of string for this workbook
getSharedStringsTable() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Opens up the Shared Strings Table, parses it, and returns a handy object for working with shared strings.
getShd() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Shading.
getShd() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the shd field for the PAP record.
getShd() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Cell shading.
getShdTable() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Table shading.
getSheet() - Method in class org.apache.poi.hslf.model.Shape

getSheet() - Method in class org.apache.poi.hslf.model.TextRun

getSheet() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Returns the HSSFSheet this cell belongs to
getSheet(int) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getSheet() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Returns the HSSFSheet this row belongs to
getSheet(String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Get sheet with the given name (case insensitive match)
getSheet() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getSheet(int) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getSheet() - Method in interface org.apache.poi.ss.usermodel.Cell
Returns the sheet this cell belongs to
getSheet() - Method in interface org.apache.poi.ss.usermodel.Row
Returns the Sheet this row belongs to
getSheet(String) - Method in interface org.apache.poi.ss.usermodel.Workbook
Get sheet with the given name
getSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

getSheet() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getSheet(String) - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Returns an InputStream to read the contents of the specified Sheet.
getSheet() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Returns the sheet this cell belongs to
getSheet() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Returns the Sheet this row belongs to
getSheet(String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Get sheet with the given name
getSheet() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns the sheet this cell belongs to
getSheet(int) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getSheet() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Returns the XSSFSheet this row belongs to
getSheet(String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get sheet with the given name (case insensitive match)
getSheetAt(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Get the HSSFSheet object at the given index.
getSheetAt(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Get the Sheet object at the given index.
getSheetAt(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Get the Sheet object at the given index.
getSheetAt(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the XSSFSheet object at the given index.
getSheetCharts(HSSFSheet) - Static method in class org.apache.poi.hssf.usermodel.HSSFChart
Returns all the charts for the given sheet.
getSheetComments() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator
Returns the comments associated with this sheet, or null if there aren't any
getSheetConditionalFormatting() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

getSheetConditionalFormatting() - Method in interface org.apache.poi.ss.usermodel.Sheet
The 'Conditional Formatting' facet for this Sheet
getSheetConditionalFormatting() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet

getSheetConditionalFormatting() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

getSheetContainer() - Method in class org.apache.poi.hslf.model.Sheet
Return record container for this sheet
getSheetId() - Method in class org.apache.poi.hslf.record.PositionDependentRecordContainer
Fetch our sheet ID, as found from a PersistPtrHolder.
getSheetIndex(String) - Method in class org.apache.poi.hssf.model.InternalWorkbook
get the sheet's index
getSheetIndex(EvaluationSheet) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getSheetIndex(String) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getSheetIndex() - Method in class org.apache.poi.hssf.usermodel.HSSFName
Returns the sheet index this name applies to.
getSheetIndex(String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Returns the index of the sheet by his name
getSheetIndex(Sheet) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Returns the index of the given sheet
getSheetIndex(EvaluationSheet) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getSheetIndex(String) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook
Finds a sheet index by case insensitive name.
getSheetIndex() - Method in interface org.apache.poi.ss.usermodel.Name
Returns the sheet index this name applies to.
getSheetIndex(String) - Method in interface org.apache.poi.ss.usermodel.Workbook
Returns the index of the sheet by his name
getSheetIndex(Sheet) - Method in interface org.apache.poi.ss.usermodel.Workbook
Returns the index of the given sheet
getSheetIndex(String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Returns the index of the sheet by his name
getSheetIndex(Sheet) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Returns the index of the given sheet
getSheetIndex(EvaluationSheet) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getSheetIndex(String) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getSheetIndex() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Returns the sheet index this name applies to.
getSheetIndex(String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Returns the index of the sheet by his name (case insensitive match)
getSheetIndex(Sheet) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Returns the index of the given sheet
getSheetIndexFromExternSheetIndex(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Finds the sheet index for a particular external sheet number.
getSheetIndexFromExternSheetIndex(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getSheetName(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
gets the name for a given sheet.
getSheetname() - Method in class org.apache.poi.hssf.record.BoundSheetRecord
get the sheetname for this sheet.
getSheetName(int) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getSheetName() - Method in class org.apache.poi.hssf.usermodel.HSSFName
Get the sheets name which this named range is referenced to
getSheetName() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns the name of this sheet
getSheetName(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

getSheetName() - Method in class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet

getSheetName(int) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getSheetName() - Method in interface org.apache.poi.ss.usermodel.Name
Get the sheets name which this named range is referenced to
getSheetName() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns the name of this sheet
getSheetName(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Get the sheet name
getSheetName() - Method in class org.apache.poi.ss.util.CellReference

getSheetName(int) - Method in class org.apache.poi.ss.util.SheetReferences

getSheetName() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator
Returns name of the current sheet
getSheetName() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns the name of this sheet
getSheetName(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Set the sheet name
getSheetName(int) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getSheetName() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Get the sheets name which this named range is referenced to
getSheetName() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the name of this sheet
getSheetName(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Get the sheet name
getSheetNameByExternSheet(int) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getSheetNameByExternSheet(int) - Method in interface org.apache.poi.ss.formula.FormulaRenderingWorkbook

getSheetNameByExternSheet(int) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getSheetNames() - Method in class org.apache.poi.hssf.record.SupBookRecord

getSheetNumber() - Method in class org.apache.poi.hssf.record.NameRecord
For named ranges, and built-in names
getSheetPart() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator

getSheetRefIndex() - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

getSheetsData() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Returns an Iterator which will let you get at all the different Sheets in turn.
getSheetTypeColumnBreaks() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypeHeaderFooter() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypePageMargins() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypePrintOptions() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypeProtection() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypeRowBreaks() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypeSheetFormatPr() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypeSheetPr() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getSheetTypeSheetViews() - Method in class org.apache.poi.xssf.usermodel.XSSFDialogsheet

getShort(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get a short value from the beginning of a byte array
getShort(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get a short value from a byte array
getShortArray(byte[], int, int) - Static method in class org.apache.poi.util.LittleEndian
Read short array
getShortDescription() - Method in interface org.apache.poi.poifs.dev.POIFSViewable
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortDescription() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortDescription() - Method in class org.apache.poi.poifs.filesystem.DocumentNode
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortDescription() - Method in class org.apache.poi.poifs.filesystem.NPOIFSDocument
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortDescription() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortDescription() - Method in class org.apache.poi.poifs.filesystem.POIFSDocument
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortDescription() - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortDescription() - Method in class org.apache.poi.poifs.property.Property
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
getShortFilename() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getShortFilename() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink

getShortRawValue(short) - Method in class org.apache.poi.util.BitField
Obtain the value for the specified BitField, unshifted
getShortValue(short) - Method in class org.apache.poi.util.BitField
Obtain the value for the specified BitField, appropriately shifted right, as a short.
getShowComments() - Method in class org.apache.poi.hslf.record.DocumentAtom
Are comment shapes visible?
getShowErrorBox() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getShowErrorBox() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getShowErrorBox() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getShowErrorOnInvalidValue() - Method in class org.apache.poi.hssf.record.DVRecord

getShowPromptBox() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getShowPromptBox() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getShowPromptBox() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getShowPromptOnCellSelected() - Method in class org.apache.poi.hssf.record.DVRecord

getShrinkToFit() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether to shrink the text to fit
getSid() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

getSid() - Method in class org.apache.poi.hssf.record.ArrayRecord

getSid() - Method in class org.apache.poi.hssf.record.AutoFilterInfoRecord

getSid() - Method in class org.apache.poi.hssf.record.BackupRecord

getSid() - Method in class org.apache.poi.hssf.record.BlankRecord
return the non static version of the id for this record.
getSid() - Method in class org.apache.poi.hssf.record.BOFRecord

getSid() - Method in class org.apache.poi.hssf.record.BookBoolRecord

getSid() - Method in class org.apache.poi.hssf.record.BoolErrRecord

getSid() - Method in class org.apache.poi.hssf.record.BottomMarginRecord

getSid() - Method in class org.apache.poi.hssf.record.BoundSheetRecord

getSid() - Method in class org.apache.poi.hssf.record.CalcCountRecord

getSid() - Method in class org.apache.poi.hssf.record.CalcModeRecord

getSid() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

getSid() - Method in class org.apache.poi.hssf.record.CFRuleRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.AreaRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.AxisRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.AxisUsedRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.BarRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.BeginRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.CatLabRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartEndObjectRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartStartObjectRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.DatRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.EndRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.FontIndexRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.FrameRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.LegendRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.PlotAreaRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SeriesIndexRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SeriesListRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.TextRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.TickRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.UnitsRecord

getSid() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord

getSid() - Method in class org.apache.poi.hssf.record.CodepageRecord

getSid() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

getSid() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

getSid() - Method in class org.apache.poi.hssf.record.ContinueRecord

getSid() - Method in class org.apache.poi.hssf.record.CountryRecord

getSid() - Method in class org.apache.poi.hssf.record.CRNCountRecord
return the non static version of the id for this record.
getSid() - Method in class org.apache.poi.hssf.record.CRNRecord
return the non static version of the id for this record.
getSid() - Method in class org.apache.poi.hssf.record.DateWindow1904Record

getSid() - Method in class org.apache.poi.hssf.record.DBCellRecord

getSid() - Method in class org.apache.poi.hssf.record.DConRefRecord

getSid() - Method in class org.apache.poi.hssf.record.DefaultColWidthRecord

getSid() - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord

getSid() - Method in class org.apache.poi.hssf.record.DeltaRecord

getSid() - Method in class org.apache.poi.hssf.record.DimensionsRecord

getSid() - Method in class org.apache.poi.hssf.record.DrawingGroupRecord

getSid() - Method in class org.apache.poi.hssf.record.DrawingRecord

getSid() - Method in class org.apache.poi.hssf.record.DrawingRecordForBiffViewer

getSid() - Method in class org.apache.poi.hssf.record.DrawingSelectionRecord

getSid() - Method in class org.apache.poi.hssf.record.DSFRecord

getSid() - Method in class org.apache.poi.hssf.record.DVALRecord

getSid() - Method in class org.apache.poi.hssf.record.DVRecord

getSid() - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

getSid() - Method in class org.apache.poi.hssf.record.EndSubRecord

getSid() - Method in class org.apache.poi.hssf.record.EOFRecord

getSid() - Method in class org.apache.poi.hssf.record.EscherAggregate

getSid() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord

getSid() - Method in class org.apache.poi.hssf.record.ExternalNameRecord

getSid() - Method in class org.apache.poi.hssf.record.ExternSheetRecord
return the non static version of the id for this record.
getSid() - Method in class org.apache.poi.hssf.record.ExtSSTRecord

getSid() - Method in class org.apache.poi.hssf.record.FeatHdrRecord

getSid() - Method in class org.apache.poi.hssf.record.FeatRecord

getSid() - Method in class org.apache.poi.hssf.record.FilePassRecord

getSid() - Method in class org.apache.poi.hssf.record.FileSharingRecord

getSid() - Method in class org.apache.poi.hssf.record.FnGroupCountRecord

getSid() - Method in class org.apache.poi.hssf.record.FontRecord

getSid() - Method in class org.apache.poi.hssf.record.FooterRecord

getSid() - Method in class org.apache.poi.hssf.record.FormatRecord

getSid() - Method in class org.apache.poi.hssf.record.FormulaRecord

getSid() - Method in class org.apache.poi.hssf.record.FtCblsSubRecord

getSid() - Method in class org.apache.poi.hssf.record.GridsetRecord

getSid() - Method in class org.apache.poi.hssf.record.GroupMarkerSubRecord

getSid() - Method in class org.apache.poi.hssf.record.GutsRecord

getSid() - Method in class org.apache.poi.hssf.record.HCenterRecord

getSid() - Method in class org.apache.poi.hssf.record.HeaderFooterRecord

getSid() - Method in class org.apache.poi.hssf.record.HeaderRecord

getSid() - Method in class org.apache.poi.hssf.record.HideObjRecord

getSid() - Method in class org.apache.poi.hssf.record.HorizontalPageBreakRecord

getSid() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getSid() - Method in class org.apache.poi.hssf.record.IndexRecord

getSid() - Method in class org.apache.poi.hssf.record.InterfaceEndRecord

getSid() - Method in class org.apache.poi.hssf.record.InterfaceHdrRecord

getSid() - Method in class org.apache.poi.hssf.record.IterationRecord

getSid() - Method in class org.apache.poi.hssf.record.LabelRecord

getSid() - Method in class org.apache.poi.hssf.record.LabelSSTRecord

getSid() - Method in class org.apache.poi.hssf.record.LeftMarginRecord

getSid() - Method in class org.apache.poi.hssf.record.MergeCellsRecord

getSid() - Method in class org.apache.poi.hssf.record.MMSRecord

getSid() - Method in class org.apache.poi.hssf.record.MulBlankRecord

getSid() - Method in class org.apache.poi.hssf.record.MulRKRecord

getSid() - Method in class org.apache.poi.hssf.record.NameCommentRecord
return the non static version of the id for this record.
getSid() - Method in class org.apache.poi.hssf.record.NameRecord
return the non static version of the id for this record.
getSid() - Method in class org.apache.poi.hssf.record.NoteRecord

getSid() - Method in class org.apache.poi.hssf.record.NoteStructureSubRecord

getSid() - Method in class org.apache.poi.hssf.record.NumberRecord

getSid() - Method in class org.apache.poi.hssf.record.ObjectProtectRecord

getSid() - Method in class org.apache.poi.hssf.record.ObjRecord

getSid() - Method in class org.apache.poi.hssf.record.PaletteRecord

getSid() - Method in class org.apache.poi.hssf.record.PaneRecord

getSid() - Method in class org.apache.poi.hssf.record.PasswordRecord

getSid() - Method in class org.apache.poi.hssf.record.PasswordRev4Record

getSid() - Method in class org.apache.poi.hssf.record.pivottable.DataItemRecord

getSid() - Method in class org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

getSid() - Method in class org.apache.poi.hssf.record.pivottable.PageItemRecord

getSid() - Method in class org.apache.poi.hssf.record.pivottable.StreamIDRecord

getSid() - Method in class org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

getSid() - Method in class org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

getSid() - Method in class org.apache.poi.hssf.record.pivottable.ViewSourceRecord

getSid() - Method in class org.apache.poi.hssf.record.PrecisionRecord

getSid() - Method in class org.apache.poi.hssf.record.PrintGridlinesRecord

getSid() - Method in class org.apache.poi.hssf.record.PrintHeadersRecord

getSid() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getSid() - Method in class org.apache.poi.hssf.record.ProtectionRev4Record

getSid() - Method in class org.apache.poi.hssf.record.ProtectRecord

getSid() - Method in class org.apache.poi.hssf.record.RecalcIdRecord

getSid() - Method in class org.apache.poi.hssf.record.Record
return the non static version of the id for this record.
getSid() - Method in class org.apache.poi.hssf.record.RecordInputStream

getSid() - Method in class org.apache.poi.hssf.record.RefModeRecord

getSid() - Method in class org.apache.poi.hssf.record.RefreshAllRecord

getSid() - Method in class org.apache.poi.hssf.record.RightMarginRecord

getSid() - Method in class org.apache.poi.hssf.record.RKRecord

getSid() - Method in class org.apache.poi.hssf.record.RowRecord

getSid() - Method in class org.apache.poi.hssf.record.SaveRecalcRecord

getSid() - Method in class org.apache.poi.hssf.record.ScenarioProtectRecord

getSid() - Method in class org.apache.poi.hssf.record.SCLRecord

getSid() - Method in class org.apache.poi.hssf.record.SelectionRecord

getSid() - Method in class org.apache.poi.hssf.record.SharedFormulaRecord

getSid() - Method in class org.apache.poi.hssf.record.SSTRecord

getSid() - Method in class org.apache.poi.hssf.record.StringRecord

getSid() - Method in class org.apache.poi.hssf.record.StyleRecord

getSid() - Method in class org.apache.poi.hssf.record.SupBookRecord

getSid() - Method in class org.apache.poi.hssf.record.TabIdRecord

getSid() - Method in class org.apache.poi.hssf.record.TableRecord

getSid() - Method in class org.apache.poi.hssf.record.TableStylesRecord

getSid() - Method in class org.apache.poi.hssf.record.TextObjectRecord

getSid() - Method in class org.apache.poi.hssf.record.TopMarginRecord

getSid() - Method in class org.apache.poi.hssf.record.UncalcedRecord

getSid() - Method in class org.apache.poi.hssf.record.UnknownRecord

getSid() - Method in class org.apache.poi.hssf.record.UserSViewBegin

getSid() - Method in class org.apache.poi.hssf.record.UserSViewEnd

getSid() - Method in class org.apache.poi.hssf.record.UseSelFSRecord

getSid() - Method in class org.apache.poi.hssf.record.VCenterRecord

getSid() - Method in class org.apache.poi.hssf.record.VerticalPageBreakRecord

getSid() - Method in class org.apache.poi.hssf.record.WindowOneRecord

getSid() - Method in class org.apache.poi.hssf.record.WindowProtectRecord

getSid() - Method in class org.apache.poi.hssf.record.WindowTwoRecord

getSid() - Method in class org.apache.poi.hssf.record.WriteAccessRecord

getSid() - Method in class org.apache.poi.hssf.record.WriteProtectRecord

getSid() - Method in class org.apache.poi.hssf.record.WSBoolRecord

getSid() - Method in enum org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType

getSid() - Method in class org.apache.poi.ss.formula.ptg.AddPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.Area2DPtgBase

getSid() - Method in class org.apache.poi.ss.formula.ptg.AreaNPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.AreaPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.ConcatPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.DividePtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.EqualPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.GreaterEqualPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.GreaterThanPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.LessEqualPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.LessThanPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.MultiplyPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.NotEqualPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.PercentPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.PowerPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.RefNPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.RefPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.SubtractPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.UnaryMinusPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.UnaryPlusPtg

getSid() - Method in class org.apache.poi.ss.formula.ptg.ValueOperatorPtg

getSignature() - Method in class org.apache.poi.ddf.EscherMetafileBlip
Return the blip signature
getSignature() - Method in class org.apache.poi.hslf.blip.DIB
DIB signature is 0x7A80
getSignature() - Method in class org.apache.poi.hslf.blip.EMF
EMF signature is 0x3D40
getSignature() - Method in class org.apache.poi.hslf.blip.JPEG
JPEG signature is 0x46A0
getSignature() - Method in class org.apache.poi.hslf.blip.PICT
PICT signature is 0x5430
getSignature() - Method in class org.apache.poi.hslf.blip.PNG
PNG signature is 0x6E00
getSignature() - Method in class org.apache.poi.hslf.blip.WMF
WMF signature is 0x2160
getSignature() - Method in class org.apache.poi.hslf.usermodel.PictureData
Blip signature.
getSignatures() - Method in enum org.apache.poi.hwpf.usermodel.PictureType

getSingleSection() - Method in class org.apache.poi.hpsf.PropertySet
If the PropertySet has only a single section this method returns it.
getSingleValue(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.eval.OperandResolver
Retrieves a single value from a variety of different argument types according to standard Excel rules.
getSize() - Method in class org.apache.poi.ddf.EscherBSERecord
Blip size in stream.
getSize(PackagePart) - Static method in class org.apache.poi.dev.OOXMLLister
Figures out how big a given PackagePart is.
getSize() - Method in class org.apache.poi.hpsf.MutableSection
Returns the section's size.
getSize() - Method in class org.apache.poi.hpsf.Property
Returns the property's size in bytes.
getSize() - Method in class org.apache.poi.hpsf.Section
Returns the section's size in bytes.
getSize() - Method in class org.apache.poi.hslf.blip.Metafile.Header

getSize() - Method in class org.apache.poi.hslf.blip.WMF.AldusHeader

getSize() - Method in class org.apache.poi.hslf.model.textproperties.TextProp
Size of the data section of the text property (2 or 4 bytes)
getSize() - Method in class org.apache.poi.hslf.usermodel.PictureData
Deprecated. Use getData().length instead.
getSize() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getSize() - Method in class org.apache.poi.hwpf.model.Ffn

getSize() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getSize() - Method in class org.apache.poi.hwpf.model.FontTable

getSize() - Method in class org.apache.poi.hwpf.model.RevisionMarkAuthorTable
Gets the number of entries.
getSize() - Static method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Size of record (exluding 4 byte header)
getSize() - Static method in class org.apache.poi.hwpf.model.types.FRDAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.HRESIAbstractType
Size of record (exluding 4 byte header)
getSize() - Static method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.SHDAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.StshifAbstractType
Size of record
getSize() - Static method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Size of record
getSize() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Size of record (exluding 4 byte header)
getSize() - Method in class org.apache.poi.hwpf.usermodel.Picture

getSize() - Method in interface org.apache.poi.poifs.filesystem.DocumentEntry
get the zize of the document, in bytes
getSize() - Method in class org.apache.poi.poifs.filesystem.DocumentNode
get the zize of the document, in bytes
getSize() - Method in class org.apache.poi.poifs.filesystem.NPOIFSDocument

getSize() - Method in class org.apache.poi.poifs.filesystem.POIFSDocument

getSize() - Method in class org.apache.poi.poifs.property.Property
find out the document size
getSize() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.Area2DPtgBase

getSize() - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.AreaErrPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg
This size includes the size of the array Ptg plus the Array Ptg Token value size
getSize() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.BoolPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.ErrPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.ExpPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.FuncPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.FuncVarPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.IntersectionPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.IntPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.MemAreaPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.MemErrPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.MemFuncPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.MissingArgPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.NamePtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.NumberPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.ParenthesisPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.Ptg

getSize() - Method in class org.apache.poi.ss.formula.ptg.RangePtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.RefErrorPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.StringPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.TblPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.UnionPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.UnknownPtg

getSize() - Method in class org.apache.poi.ss.formula.ptg.ValueOperatorPtg

getSize() - Method in class org.apache.poi.ss.util.CellRangeAddressList

getSizeCode() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

getSizeEMU() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getSizeEMU() - Method in class org.apache.poi.ddf.EscherPictBlip

getSizeExtra() - Method in class org.apache.poi.poifs.crypt.EncryptionHeader

getSizeInBytes() - Method in class org.apache.poi.hdgf.chunks.ChunkHeader

getSizeInBytes() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

getSizeInBytes() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV6

getSizeInBytes() - Method in class org.apache.poi.hdgf.pointers.Pointer

getSizeInBytes() - Method in class org.apache.poi.hdgf.pointers.PointerV6
With v6 pointers, the on-disk size is 18 bytes
getSizeInBytes() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

getSizeInBytes() - Method in class org.apache.poi.hwpf.model.ListLevel

getSizeInBytes() - Static method in class org.apache.poi.hwpf.model.PieceDescriptor

getSizeOfElements() - Method in class org.apache.poi.ddf.EscherArrayProperty

getSlide(CTSlideIdListEntry) - Method in class org.apache.poi.xslf.XSLFSlideShow
Returns the low level slide object from the supplied slide reference
getSlideAtom() - Method in class org.apache.poi.hslf.record.MainMaster
Returns the SlideAtom of this Slide
getSlideAtom() - Method in class org.apache.poi.hslf.record.Slide
Returns the SlideAtom of this Slide
getSlideAtomsSet() - Method in class org.apache.poi.hslf.model.Slide

getSlideAtomsSets() - Method in class org.apache.poi.hslf.record.SlideListWithText
Get access to the SlideAtomsSets of the children of this record
getSlideComments(CTSlideIdListEntry) - Method in class org.apache.poi.xslf.XSLFSlideShow
Returns all the comments for the given slide
getSlideCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Returns the slide count or 0 if the DocumentSummaryInformation does not contain a slide count.
getSlideCount() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
An unsigned integer that specifies the number of slides that this animation continues playing.
getSlideHeadersFooters() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Return Header / Footer settings for slides
getSlideId() - Method in class org.apache.poi.hslf.record.ExControlAtom
An integer that specifies which presentation slide is associated with the ActiveX control.
getSlideID() - Method in class org.apache.poi.hslf.record.NotesAtom

getSlideIdentifier() - Method in class org.apache.poi.hslf.record.SlidePersistAtom

getSlideLayout() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getSlideLayouts() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getSlideListWithTexts() - Method in class org.apache.poi.hslf.record.Document
Returns all the SlideListWithTexts that are defined for this Document.
getSlideLocationsLookup() - Method in class org.apache.poi.hslf.record.PersistPtrHolder
Get the lookup from slide numbers to byte offsets, for the slides known about by this PersistPtrHolder.
getSlideMaster() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getSlideMaster() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout
Slide master object associated with this layout.
getSlideMaster(CTSlideMasterIdListEntry) - Method in class org.apache.poi.xslf.XSLFSlideShow
Returns the low level slide master object from the supplied slide master reference
getSlideMasterPart(CTSlideMasterIdListEntry) - Method in class org.apache.poi.xslf.XSLFSlideShow

getSlideMasterReferences() - Method in class org.apache.poi.xslf.XSLFSlideShow
Returns the references from the presentation to its slide masters.
getSlideMasters() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow

getSlideNumber() - Method in class org.apache.poi.hslf.model.Slide
Returns the (public facing) page number of this slide
getSlideOffsetDataLocationsLookup() - Method in class org.apache.poi.hslf.record.PersistPtrHolder
Get the lookup from slide numbers to their offsets inside _ptrData, used when adding or moving slides.
getSlidePart(CTSlideIdListEntry) - Method in class org.apache.poi.xslf.XSLFSlideShow

getSlidePersistAtom() - Method in class org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet
Get the SlidePersistAtom, which gives details on the Slide this text is associated with
getSlideRecord() - Method in class org.apache.poi.hslf.model.Slide
Returns the underlying slide record
getSlideRecords() - Method in class org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet
Get the Text related records for this slide
getSlideReferences() - Method in class org.apache.poi.xslf.XSLFSlideShow
Returns the references from the presentation to its slides.
getSlides() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns an array of all the normal Slides found in the slideshow
getSlides() - Method in interface org.apache.poi.sl.usermodel.SlideShow

getSlides() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Return all the slides in the slideshow
getSlideShow() - Method in class org.apache.poi.hslf.model.Sheet
Fetch the SlideShow we're attached to
getSlideShow() - Method in interface org.apache.poi.sl.usermodel.Sheet

getSlideShow() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getSlideSizeType() - Method in class org.apache.poi.hslf.record.DocumentAtom
The Size of the Document's slides, @see DocumentAtom.SlideSize for values
getSlideSizeX() - Method in class org.apache.poi.hslf.record.DocumentAtom

getSlideSizeY() - Method in class org.apache.poi.hslf.record.DocumentAtom

getSlideSlideListWithText() - Method in class org.apache.poi.hslf.record.Document
Returns the SlideListWithText that deals with the Slides, or null if there isn't one
getSlidesMasters() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns an array of all the normal Slide Masters found in the slideshow
getSmallBlocks() - Method in class org.apache.poi.poifs.filesystem.POIFSDocument

getSmallDocumentBlocks(POIFSBigBlockSize, RawDataBlockList, RootProperty, int) - Static method in class org.apache.poi.poifs.storage.SmallBlockTableReader
fetch the small document block list from an existing file
getSoundData() - Method in class org.apache.poi.hslf.record.Sound
The sound data
getSoundData() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns the data of all the embedded sounds in the SlideShow
getSoundIdRef() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A 4-byte unsigned integer that specifies a reference to a sound in the SoundCollectionContainer record to locate the embedded audio
getSoundName() - Method in class org.apache.poi.hslf.record.Sound
Name of the sound (e.g.
getSoundName() - Method in class org.apache.poi.hslf.usermodel.SoundData
Name of the sound (e.g.
getSoundRef() - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
a reference to a sound in the sound collection.
getSoundType() - Method in class org.apache.poi.hslf.record.Sound
Type of the sound (e.g.
getSoundType() - Method in class org.apache.poi.hslf.usermodel.SoundData
Type of the sound (e.g.
getSource() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

getSourcePartUriFromRelationshipPartUri(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Get the source part URI from a specified relationships part.
getSourceURI() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

getSpace() - Method in class org.apache.poi.hwpf.usermodel.BorderCode
Width of space to maintain between border and text within border.
getSpaceAfter() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns spacing after a paragraph
getSpaceAfter() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
The amount of vertical white space after the paragraph This may be specified in two different ways, percentage spacing and font point spacing:
getSpaceBefore() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns spacing before a paragraph
getSpaceBefore() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
The amount of vertical white space before the paragraph This may be specified in two different ways, percentage spacing and font point spacing:
getSpacing() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Get the spacing field for the Legend record.
getSpacingAfter() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getSpacingAfter() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getSpacingAfter() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.
getSpacingAfterLines() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.
getSpacingBefore() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getSpacingBefore() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getSpacingBefore() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added above the first line in this paragraph in the document in absolute units.
getSpacingBeforeLines() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added before the first line in this paragraph in the document in line units.
getSpacingLineRule() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies how the spacing between lines is calculated as stored in the line attribute.
getSpare() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Unused
getSpare() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the Spare field for the DOP record.
getSpContainer() - Method in class org.apache.poi.hslf.model.Shape

getSpContainer() - Method in class org.apache.poi.hssf.model.AbstractShape

getSpContainer() - Method in class org.apache.poi.hssf.model.ComboboxShape

getSpContainer() - Method in class org.apache.poi.hssf.model.LineShape

getSpContainer() - Method in class org.apache.poi.hssf.model.PictureShape

getSpContainer() - Method in class org.apache.poi.hssf.model.PolygonShape

getSpContainer() - Method in class org.apache.poi.hssf.model.SimpleFilledShape

getSpContainer() - Method in class org.apache.poi.hssf.model.TextboxShape

getSpContainers() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder

getSpecialMask() - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection

getSpecificBuiltinRecord(byte, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Retrieves the Builtin NameRecord that matches the name and index There shouldn't be too many names to make the sequential search too slow
getSpellInfo() - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun
Spelling status of this text.
getSpgrContainers() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder

getSpid() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Shape Identifier.
getSpinCount() - Method in class org.apache.poi.poifs.crypt.EncryptionVerifier

getSpPr() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getSpreadsheetVersion() - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getSpreadsheetVersion() - Method in interface org.apache.poi.ss.formula.FormulaParsingWorkbook
Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)
getSpreadsheetVersion() - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getSprmBuf() - Method in class org.apache.poi.hwpf.model.CachedPropertyNode

getSprmBuf() - Method in class org.apache.poi.hwpf.model.CHPX

getSprmBuf() - Method in class org.apache.poi.hwpf.model.PAPX

getSpStyle() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getSpTree() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getSSlideLayoutAtom() - Method in class org.apache.poi.hslf.record.SlideAtom
Get the embeded SSlideLayoutAtom
getSSTIndex() - Method in class org.apache.poi.hssf.record.LabelSSTRecord
get the index to the string in the SSTRecord
getSSTRecord() - Method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

getSSTString(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
given an index into the SST table, this function returns the corresponding String value
getSSTString(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. Do not call this method from your applications. Use the methods available in the HSSFRow to get string HSSFCells
getStart(int) - Method in class org.apache.poi.hwpf.model.FormattedDiskPage
Used to get a text offset corresponding to a grpprl in this fkp.
getStart() - Method in class org.apache.poi.hwpf.model.PropertyNode

getStart() - Method in class org.apache.poi.hwpf.model.SinglentonTextPiece

getStart() - Method in interface org.apache.poi.hwpf.usermodel.Bookmark

getStartAt() - Method in class org.apache.poi.hwpf.model.ListLevel

getStartBlock() - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream
What block does this stream start at? Will be POIFSConstants.END_OF_CHAIN for a new stream that hasn't been written to yet.
getStartBlock() - Method in class org.apache.poi.poifs.property.Property

getStartBlock() - Method in class org.apache.poi.poifs.property.PropertyTableBase
Get the start block for the property table
getStartBlock() - Method in class org.apache.poi.poifs.storage.BlockAllocationTableWriter
get the starting block
getStartBytes() - Method in class org.apache.poi.hwpf.model.BytePropertyNode
Deprecated. Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.
getStartCellReference() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getStartIndex() - Method in class org.apache.poi.hslf.model.Hyperlink
Gets the beginning character position
getStartIndex() - Method in class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Gets the beginning character position
getStartIndex() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
The beginning index, inclusive.
getStartOffset() - Method in class org.apache.poi.hwpf.usermodel.Picture

getStartOffset() - Method in class org.apache.poi.hwpf.usermodel.Range

getStaticRecordSize() - Static method in class org.apache.poi.hssf.record.UncalcedRecord

getStatusBarText() - Method in class org.apache.poi.hssf.record.NameRecord
gets the status bar text
getSti() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
An unsigned integer that specifies the invariant style identifier for application-defined styles, or 0x0FFE for user-defined styles
getStiMaxWhenSaved() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style.
getStk() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
style kind
getStorageClsid() - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
Gets the storage clsid of the directory entry
getStorageClsid() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
Gets the storage clsid of the directory entry
getStorageClsid() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

getStorageClsid() - Method in class org.apache.poi.poifs.property.Property
Sets the storage clsid, which is the Class ID of a COM object which reads and writes this stream
getStore() - Method in class org.apache.poi.hdgf.streams.Stream

getStPicName() - Method in class org.apache.poi.hwpf.model.PICFAndOfficeArtData

getStr() - Method in class org.apache.poi.hssf.record.TextObjectRecord

getStream(String) - Method in class org.apache.poi.hwpf.model.io.HWPFFileSystem

getStream() - Method in class org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent

getStream() - Method in class org.apache.poi.poifs.filesystem.POIFSWriterEvent

getStreamId() - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord
Gets the stream ID containing the actual data.
getStreamPos() - Method in class org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord

getStrikeout() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get whether to use a strikeout horizontal line through the text or not
getStrikeout() - Method in interface org.apache.poi.ss.usermodel.Font
get whether to use a strikeout horizontal line through the text or not
getStrikeout() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get a boolean value that specify whether to use a strikeout horizontal line through the text or not
getString() - Method in class org.apache.poi.hmef.attribute.TNEFStringAttribute

getString() - Method in class org.apache.poi.hssf.record.common.UnicodeString

getString(int) - Method in class org.apache.poi.hssf.record.SSTRecord
Get a particular string by its index
getString() - Method in class org.apache.poi.hssf.record.StringRecord

getString() - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Returns the plain string representation.
getString() - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox

getString() - Method in interface org.apache.poi.ss.usermodel.Comment
Fetches the rich text string of the comment
getString() - Method in enum org.apache.poi.ss.usermodel.FormulaError

getString() - Method in interface org.apache.poi.ss.usermodel.RichTextString
Returns the plain string representation.
getString() - Method in interface org.apache.poi.ss.usermodel.Textbox

getString() - Method in class org.apache.poi.xssf.usermodel.XSSFComment

getString() - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Returns the plain string representation.
getStringBuffer() - Method in class org.apache.poi.hwpf.model.TextPiece
Deprecated.
getStringBuilder() - Method in class org.apache.poi.hwpf.model.TextPiece

getStringCellValue() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
get the value of the cell as a string - for numeric cells we throw an exception.
getStringCellValue() - Method in interface org.apache.poi.ss.formula.EvaluationCell

getStringCellValue() - Method in interface org.apache.poi.ss.usermodel.Cell
Get the value of the cell as a string
getStringCellValue() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Get the value of the cell as a string
getStringCellValue() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Get the value of the cell as a string
getStringCount() - Method in class org.apache.poi.hwpf.model.FontTable

getStringFromChunk(StringChunk) - Method in class org.apache.poi.hsmf.MAPIMessage
Gets a string value based on the passed chunk.
getStringLength() - Method in class org.apache.poi.hssf.record.LabelRecord
get the number of characters this string contains
getStringRecord() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate
debug only TODO - encapsulate
getStringValue() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

getStringValue() - Method in class org.apache.poi.ss.formula.eval.BoolEval

getStringValue() - Method in class org.apache.poi.ss.formula.eval.NumberEval

getStringValue() - Method in class org.apache.poi.ss.formula.eval.StringEval

getStringValue() - Method in interface org.apache.poi.ss.formula.eval.StringValueEval

getStringValue() - Method in class org.apache.poi.ss.usermodel.CellValue

getStringWidth(String) - Method in class org.apache.poi.hssf.usermodel.FontDetails
Gets the width of all characters in a string.
getStroke() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns the current Stroke in the Graphics2D context.
getStroke() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getStroke() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getStubHSSFWorkbook() - Method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

getStubWorkbook() - Method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

getStyle() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Returns the styles object used
getStyle() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph

getStyle(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
get style by a styleID
getStyleAt(int) - Method in class org.apache.poi.xssf.model.StylesTable

getStyleAttribute(int, int, String, boolean) - Method in class org.apache.poi.hslf.model.MasterSheet
Pickup a style attribute from the master.
getStyleAttribute(int, int, String, boolean) - Method in class org.apache.poi.hslf.model.SlideMaster
Pickup a style attribute from the master.
getStyleAttribute(int, int, String, boolean) - Method in class org.apache.poi.hslf.model.TitleMaster
Delegate the call to the underlying slide master.
getStyleClassName(HSSFWorkbook, HSSFCellStyle) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

getStyleDescription(int) - Method in class org.apache.poi.hwpf.model.StyleSheet
Gets the StyleDescription at index x.
getStyleId() - Method in class org.apache.poi.xslf.usermodel.XSLFTableStyle

getStyleID() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Return styleID of the paragraph if style exist for this paragraph if not, null will be returned
getStyleId() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
get StyleID of the style
getStyleID() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
get the StyleID of the table
getStyleIndex() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getStyleName() - Method in class org.apache.poi.xslf.usermodel.XSLFTableStyle

getStyleRecord(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Returns the StyleRecord for the given xfIndex, or null if that ExtendedFormat doesn't have a Style set.
getStyles() - Method in class org.apache.poi.xslf.usermodel.XSLFTableStyles

getStyles() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
get Styles
getStyles() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
get styles
getStylesData() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Returns an InputStream to read the contents of the styles table.
getStyleSheet() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getStylesSource() - Method in class org.apache.poi.xssf.usermodel.XSSFCell

getStylesSource() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Return a object representing a collection of shared objects used for styling content, e.g.
getStylesTable() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Opens up the Styles Table, parses it, and returns a handy object for working with cell styles
getStyleWithSameName(XWPFStyle) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
get the style with the same name if this style is not existing, return null
getStyleXf() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Used so that StylesSource can figure out our location
getSubdocumentTextStreamLength(SubdocumentType) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

getSubject() - Method in class org.apache.poi.hmef.HMEFMessage
Returns the Message Subject, or null if the mapi property for this isn't set
getSubject() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the subject (or null).
getSubject() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the subject line of the Outlook Message
getSubject() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getSubjectProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get subject.
getSubjectProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the topic of the content of the resource.
getSubmissionId() - Method in class org.apache.poi.hsmf.datatypes.MessageSubmissionChunk

getSubPropMatches() - Method in class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
Fetch the list of if the sub properties match or not
getSubPropNames() - Method in class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
Fetch the list of the names of the sub properties
getSubRecords() - Method in class org.apache.poi.hssf.record.ObjRecord

getSubscript() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text.
getSubSuperScriptIndex() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

getSubSuperScriptIndex() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getSubType() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Gets the type of OLE object.
getSubType() - Method in class org.apache.poi.openxml4j.opc.internal.ContentType
Get the subtype.
getSubValue(int) - Method in class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
Fetch the true/false status of the subproperty with the given index
getSummaryInformation() - Method in class org.apache.poi.hssf.extractor.EventBasedExcelExtractor
Would return the summary information metadata for the document, if we supported it
getSummaryInformation() - Method in class org.apache.poi.POIDocument
Fetch the Summary Information of the document
getSummaryInformation() - Method in class org.apache.poi.POIOLE2TextExtractor
Returns the summary information metadata for the document
getSummaryInformationProperties() - Static method in class org.apache.poi.hpsf.wellknown.PropertyIDMap

getSummaryInformationText() - Method in class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

getSumSingle() - Static method in class org.apache.poi.ss.formula.ptg.AttrPtg

getSupbookpos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList
Returns the supbookpos.
getSuperscript() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Gets the subscript/superscript option
getSuperSubScript() - Method in class org.apache.poi.hssf.record.FontRecord
get the type of super or subscript for the font
getSupportedFunctionNames() - Static method in class org.apache.poi.ss.formula.atp.AnalysisToolPak
Returns a collection of ATP function names implemented by POI.
getSupportedFunctionNames() - Static method in class org.apache.poi.ss.formula.eval.FunctionEval
Returns a collection of function names implemented by POI.
getSupportedFunctionNames() - Static method in class org.apache.poi.ss.formula.WorkbookEvaluator
Return a collection of functions that POI can evaluate
getSuppressDropdownArrow() - Method in class org.apache.poi.hssf.record.DVRecord

getSuppressDropDownArrow() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getSuppressDropDownArrow() - Method in interface org.apache.poi.ss.usermodel.DataValidation
Useful only list validation objects .
getSuppressDropDownArrow() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getSwHMF() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field is unused and MUST be ignored.
getSymbolCharacter() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Returns the symbol character, if this is a symbol character run.
getSymbolFont() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Returns the symbol font, if this is a symbol character run.
getTable(Paragraph) - Method in class org.apache.poi.hwpf.usermodel.Range
Gets the table that starts with paragraph.
getTable(CTTbl) - Method in interface org.apache.poi.xwpf.usermodel.IBody
if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
getTable(CTTbl) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
get a table by its CTTbl-Object
getTable(CTTbl) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
getTable(CTTbl) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
getTable(CTTbl) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
get a table by its CTTbl-Object
getTable() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow

getTableArray(int) - Method in interface org.apache.poi.xwpf.usermodel.IBody
Returns the table at position pos
getTableArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getTableArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getTableArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
Returns the table at position pos
getTableArray(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getTableCell(CTTc) - Method in interface org.apache.poi.xwpf.usermodel.IBody
returns the TableCell to which the Table belongs
getTableCell(CTTc) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
get the TableCell which belongs to the TableCell
getTableCell(CTTc) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
get the TableCell which belongs to the TableCell
getTableCell(CTTc) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
get the TableCell which belongs to the TableCell
getTableCell(CTTc) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
get the TableCell which belongs to the TableCell
getTableCell(CTTc) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
returns the XWPFTableCell which belongs to the CTTC cell if there is no XWPFTableCell which belongs to the parameter CTTc cell null will be returned
getTableCells() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
create and return a list of all XWPFTableCell who belongs to this row
getTableLevel() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getTableLevel() - Method in class org.apache.poi.hwpf.usermodel.Table

getTablePos(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
get with the position of a table in the bodyelement array list the position of this table in the table array list
getTableRow() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getTables() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns any tables associated with this Sheet
getTables() - Method in interface org.apache.poi.xwpf.usermodel.IBody
Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.
getTables() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getTables() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getTables() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
Return the table(s) that holds the text of the header or footer, for complex cases where a paragraph isn't used.
getTables() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getTablesIterator() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getTableStream() - Method in class org.apache.poi.hwpf.HWPFDocument

getTableStyles() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow

getTabpos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getTabStop(int) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getTabStops() - Method in class org.apache.poi.hslf.record.TextRulerAtom
Default distance between tab stops, in master coordinates (576 dpi).
getTabStopsNumber() - Method in class org.apache.poi.hwpf.usermodel.Paragraph
Returns number of tabs stops defined for paragraph.
getTabStopsPositions() - Method in class org.apache.poi.hwpf.usermodel.Paragraph
Returns array of positions of itbdMac tab stops
getTabWidthRatio() - Method in class org.apache.poi.hssf.record.WindowOneRecord
ratio of the width of the tabs to the horizontal scrollbar
getTag() - Method in class org.apache.poi.ddf.EscherBSERecord
unused
getTarget() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current layout target.
getTarget() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getTargetFrame() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getTargetMode() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship
public URI getSourceUri(){ }
getTargetPart(PackageRelationship) - Method in class org.apache.poi.POIXMLDocumentPart
Get the PackagePart that is the target of a relationship from this Part.
getTargetURI() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

getTargetURI() - Method in class org.apache.poi.xslf.usermodel.XSLFHyperlink

getTblStyle(XWPFTable) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getTemplate() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the template (or null).
getText() - Method in class org.apache.poi.hdgf.extractor.VisioTextExtractor
Returns the textual contents of the file.
getText() - Method in class org.apache.poi.hpbf.extractor.PublisherTextExtractor

getText() - Method in class org.apache.poi.hpbf.model.qcbits.QCTextBit
Returns the text.
getText() - Method in class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

getText() - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Fetches all the slide text from the slideshow, but not the notes, unless you've called setSlidesByDefault() and setNotesByDefault() to change this
getText(boolean, boolean) - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Fetches text from the slideshow, be it slide text or note text.
getText(boolean, boolean, boolean, boolean) - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor

getText() - Method in class org.apache.poi.hslf.model.Comment
Get the text of this comment
getText() - Method in class org.apache.poi.hslf.model.TextRun
Returns the text content of the run, which has been made safe for printing and other use.
getText() - Method in class org.apache.poi.hslf.model.TextShape
Returns the text contained in this text frame.
getText() - Method in class org.apache.poi.hslf.record.Comment2000
Get the text of this comment
getText() - Method in class org.apache.poi.hslf.record.CString
Grabs the text.
getText() - Method in class org.apache.poi.hslf.record.TextBytesAtom
Grabs the text.
getText() - Method in class org.apache.poi.hslf.record.TextCharsAtom
Grabs the text.
getText() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Fetch the text, in output suitable form
getText() - Method in class org.apache.poi.hsmf.extractor.OutlookTextExtactor
Outputs something a little like a RFC822 email
getText() - Method in class org.apache.poi.hssf.extractor.EventBasedExcelExtractor
Retreives the text contents of the file
getText() - Method in class org.apache.poi.hssf.extractor.ExcelExtractor
Retrieves the text contents of the file
getText() - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord
Get the text field for the SeriesText record.
getText() - Method in class org.apache.poi.hssf.record.ExternalNameRecord

getText() - Method in class org.apache.poi.hssf.record.HeaderFooterBase

getText(DirectoryNode) - Static method in class org.apache.poi.hwpf.converter.WordToTextConverter

getText(File) - Static method in class org.apache.poi.hwpf.converter.WordToTextConverter

getText(HWPFDocumentCore) - Static method in class org.apache.poi.hwpf.converter.WordToTextConverter

getText() - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

getText() - Method in class org.apache.poi.hwpf.extractor.Word6Extractor

getText() - Method in class org.apache.poi.hwpf.extractor.WordExtractor
Grab the text, based on the WordToTextConverter.
getText() - Method in class org.apache.poi.hwpf.HWPFDocument

getText() - Method in class org.apache.poi.hwpf.HWPFDocumentCore
Internal method to access document text
getText() - Method in class org.apache.poi.hwpf.HWPFOldDocument

getText() - Method in class org.apache.poi.hwpf.model.TextPieceTable

getText() - Method in class org.apache.poi.POITextExtractor
Retrieves all the text from the document.
getText() - Method in class org.apache.poi.POIXMLPropertiesTextExtractor

getText() - Method in interface org.apache.poi.sl.usermodel.TextRun

getText() - Method in interface org.apache.poi.ss.extractor.ExcelExtractor
Retreives the text contents of the file
getText() - Method in class org.apache.poi.ss.formula.constant.ErrorConstant

getText(int) - Static method in class org.apache.poi.ss.formula.eval.ErrorEval
Converts error codes to text.
getText(int) - Static method in class org.apache.poi.ss.usermodel.ErrorConstants

getText() - Method in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor
Gets the slide text, but not the notes text
getText(boolean, boolean) - Method in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor
Gets the requested text from the file
getText(boolean, boolean, boolean) - Method in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor
Gets the requested text from the file
getText() - Method in class org.apache.poi.xslf.usermodel.DrawingParagraph

getText() - Method in class org.apache.poi.xslf.usermodel.XSLFCommonSlideData

getText() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getText() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getText() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getText() - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Processes the file and returns the text
getText() - Method in class org.apache.poi.xssf.extractor.XSSFExcelExtractor
Retreives the text contents of the file
getText() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter

getText() - Method in class org.apache.poi.xssf.usermodel.XSSFEvenFooter
Get the content text representing the footer
getText() - Method in class org.apache.poi.xssf.usermodel.XSSFEvenHeader
Get the content text representing this header
getText() - Method in class org.apache.poi.xssf.usermodel.XSSFFirstFooter
Get the content text representing the footer
getText() - Method in class org.apache.poi.xssf.usermodel.XSSFFirstHeader
Get the content text representing this header
getText() - Method in class org.apache.poi.xssf.usermodel.XSSFOddFooter
Get the content text representing the footer
getText() - Method in class org.apache.poi.xssf.usermodel.XSSFOddHeader
Get the content text representing this header
getText() - Method in class org.apache.poi.xwpf.extractor.XWPFWordExtractor

getText() - Method in class org.apache.poi.xwpf.model.XWPFCommentsDecorator

getText() - Method in class org.apache.poi.xwpf.model.XWPFHyperlinkDecorator
Deprecated.
getText() - Method in class org.apache.poi.xwpf.model.XWPFParagraphDecorator

getText() - Method in class org.apache.poi.xwpf.usermodel.PositionInParagraph

getText() - Method in class org.apache.poi.xwpf.usermodel.XWPFComment

getText() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
Returns the textual content of the header/footer, by flattening out the text of its paragraph(s)
getText() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Return the textual content of the paragraph, including text from pictures in it.
getText(TextSegement) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
get a Text
getText(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Return the string content of this text run
getText() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getText() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getTextAlign() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Returns the alignment that is applied to the paragraph.
getTextAndLinesColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Text And Lines Colour
getTextAsString() - Method in class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
Fetches the ALL the text of the powerpoint file, as a single string
getTextAsVector() - Method in class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
Fetches the ALL the text of the powerpoint file, in a vector of strings, one per text record
getTextAutofit() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getTextBody() - Method in class org.apache.poi.hsmf.MAPIMessage
Gets the plain text body of this Outlook Message
getTextBody() - Method in class org.apache.poi.xslf.usermodel.DrawingTableCell

getTextBody(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFAutoShape

getTextBody(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getTextBody(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getTextBodyPr() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getTextBounds() - Method in class org.apache.poi.xslf.model.geom.CustomGeometry

getTextboxWrappers() - Method in class org.apache.poi.hslf.record.PPDrawing
Get access to the atoms inside Textboxes
getTextCap() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getTextDirection() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getTextElements(float, FontRenderContext) - Method in class org.apache.poi.hslf.model.TextPainter

getTextFromPieces() - Method in class org.apache.poi.hwpf.extractor.WordExtractor
Grab the text out of the text pieces.
getTextHeight() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Compute the cumulative height occupied by the text
getTextId() - Method in class org.apache.poi.hslf.model.TextShape

getTextIndex() - Method in class org.apache.poi.hslf.record.OutlineTextRefAtom
Return text's index within the SlideListWithText container (0 for title, 1..n for the nth body).
getTextMark() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

getTextMark() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink

getTextObjectRecord() - Method in class org.apache.poi.hssf.model.TextboxShape

getTextObjectRecord() - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Returns the underlying Text record
getTextOffset() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns the text offset
getTextOffsets() - Method in class org.apache.poi.hslf.record.TextRulerAtom
Paragraph's distance from shape's left margin, in master coordinates (576 dpi).
getTextOrientation() - Method in class org.apache.poi.hssf.record.TextObjectRecord
Get the text orientation field for the TextObjectBase record.
getTextParagraphs() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getTextPieces() - Method in class org.apache.poi.hwpf.model.TextPieceTable

getTextPieceTable() - Method in class org.apache.poi.hwpf.model.ComplexFileTable

getTextPosition(int) - Method in class org.apache.poi.hwpf.model.NotesTables

getTextPosition() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
This element specifies the amount by which text shall be raised or lowered for this run in relation to the default baseline of the surrounding non-positioned text.
getTextProperties(Placeholder) - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getTextPropList() - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection
Fetch the TextProps that define this styling
getTextRotation() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the text rotation field for the Text record.
getTextRotation() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Get the degree of rotation for the text in the cell
Expressed in degrees.
getTextRuler() - Method in class org.apache.poi.hslf.model.TextRun

getTextRun() - Method in class org.apache.poi.hslf.model.TextShape

getTextRun() - Method in interface org.apache.poi.sl.usermodel.AutoShape

getTextRun() - Method in interface org.apache.poi.sl.usermodel.Notes

getTextRuns() - Method in class org.apache.poi.hslf.model.Notes
Returns an array of all the TextRuns found
getTextRuns() - Method in class org.apache.poi.hslf.model.Sheet
Returns an array of all the TextRuns in the sheet.
getTextRuns() - Method in class org.apache.poi.hslf.model.Slide
Returns an array of all the TextRuns found
getTextRuns() - Method in class org.apache.poi.hslf.model.SlideMaster
Returns an array of all the TextRuns found
getTextRuns() - Method in class org.apache.poi.hslf.model.TitleMaster
Returns an array of all the TextRuns found
getTextRuns() - Method in class org.apache.poi.hwpf.model.CHPBinTable

getTextRuns() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getTextShapeByType(Placeholder) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getTextSpecInfoRuns() - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom

getTextStartAt(int) - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12
Returns where in the text (in characters) the hyperlink at the given index starts applying to.
getTextTable() - Method in class org.apache.poi.hwpf.HWPFDocument

getTextTable() - Method in class org.apache.poi.hwpf.HWPFDocumentCore

getTextTable() - Method in class org.apache.poi.hwpf.HWPFOldDocument

getTextType() - Method in class org.apache.poi.hslf.record.TextHeaderAtom

getTextType() - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
Return type of the text.
getTextType() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getTheme() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getTheme() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout

getTheme() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getTheme() - Method in class org.apache.poi.xssf.model.StylesTable

getTheme() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Index into the collection, referencing a particular or value expressed in the Theme part.
getTheme() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Returns the Theme of current workbook.
getThemeColor(int) - Method in class org.apache.poi.xssf.model.ThemesTable

getThemeColor() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the color value for the font References a color defined in theme.
getThemesData() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Returns an InputStream to read the contents of the themes table.
getThingType() - Method in class org.apache.poi.hpbf.model.qcbits.QCBit
Returns the type of the thing, eg TEXT, FONT or TOKN
getThreadPrefersEventExtractors() - Static method in class org.apache.poi.extractor.ExtractorFactory
Should this thread prefer event based over usermodel based extractors? (usermodel extractors tend to be more accurate, but use more memory) Default is false.
getThumbnail() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the thumbnail (or null) when this method is implemented.
getThumbnail() - Method in class org.apache.poi.hpsf.Thumbnail
Returns the thumbnail as a byte[] in VT_CF format.
getThumbnailAsWMF() - Method in class org.apache.poi.hpsf.Thumbnail
Returns the Thumbnail as a byte[] of WMF data if the Thumbnail's Clipboard Format Tag is CFTAG_WINDOWS and its Clipboard Format is CF_METAFILEPICT
getTickColor() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the tick color field for the Tick record.
getTickMarkFrequency() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Get the tick mark frequency field for the CategorySeriesAxis record.
getTint() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Specifies the tint value applied to the ctColor.
getTitle() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the title (or null).
getTitle() - Method in class org.apache.poi.hslf.model.Hyperlink
Gets the hyperlink user-friendly title (if different from URL)
getTitle() - Method in class org.apache.poi.hslf.model.Slide
Return title of this slide or null if the slide does not have title.
getTitle() - Method in class org.apache.poi.hssf.record.common.FeatProtection

getTitle() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

getTitle() - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

getTitle() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getTitle() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getTitle() - Method in class org.apache.poi.xssf.usermodel.XSSFChart
Returns the title, or null if none is set
getTitleMasters() - Method in class org.apache.poi.hslf.usermodel.SlideShow
Returns an array of all the normal Title Masters found in the slideshow
getTitleProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get title.
getTitleProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the name given to the resource.
getTitleTextColourRGB() - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Fetch the RGB value for Title Text Colour
getTlc() - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Tab leader code
getTlp() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Table look specifier.
getTlp_flags() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Get the tlp_flags field for the TLP record.
getTmEdited() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the tmEdited field for the DOP record.
getTo() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor
Return ending anchor point
getTokenArrayValues() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

getTokens() - Method in class org.apache.poi.ss.formula.Formula

getTokens(Formula) - Static method in class org.apache.poi.ss.formula.Formula
Gets the Ptg array from the supplied Formula.
getTooltip() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink

getTop() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
getTopBorder() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

getTopBorder() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

getTopBorder() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getTopBorderColor() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
get the color to use for the top border
getTopBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

getTopBorderColor() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the color to use for the top border
getTopBorderColor() - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

getTopBorderColor() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the color to use for the top border
getTopBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

getTopBorderColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the top border
getTopBorderPaletteIdx() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the palette index for the top border
getTopBorderXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the color to use for the top border
getTopColGutter() - Method in class org.apache.poi.hssf.record.GutsRecord
get the size of the gutter that appears at the above the columns
getTopInset() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Returns the distance (in points) between the top of the text frame and the top of the inscribed rectangle of the shape that contains the text.
getTopLeftCell() - Method in interface org.apache.poi.ss.usermodel.CellRange

getTopLeftCell() - Method in class org.apache.poi.ss.util.SSCellRange

getTopLevelStreams() - Method in class org.apache.poi.hdgf.HDGFDiagram
Returns all the top level streams, which are the streams pointed to by the TrailerStream.
getTopRow() - Method in class org.apache.poi.hssf.model.InternalSheet

getTopRow() - Method in class org.apache.poi.hssf.record.PaneRecord
Get the top row field for the Pane record.
getTopRow() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
get the top row visible in the window
getTopRow() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
The top row in the visible view when the sheet is first viewed after opening it in a viewer
getTopRow() - Method in interface org.apache.poi.ss.usermodel.Sheet
The top row in the visible view when the sheet is first viewed after opening it in a viewer
getTopRow() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
The top row in the visible view when the sheet is first viewed after opening it in a viewer
getTopRow() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
The top row in the visible view when the sheet is first viewed after opening it in a viewer
getTotalSize() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

getTotalSize() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the value of the totalSize field - the total length of the structure is totalSize + 4 (value of this field + size of this field).
getTplc() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes.
getTrailer() - Method in class org.apache.poi.hdgf.chunks.Chunk
Gets the trailer for this chunk, if it exists
getTrailerStream() - Method in class org.apache.poi.hdgf.HDGFDiagram
Returns the TrailerStream, which is at the root of the tree of Streams.
getTransform() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Returns a copy of the current Transform in the Graphics2D context.
getTransform() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

getTransform() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.AQUA

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.BLACK

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.BROWN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.CORAL

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_RED

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.GOLD

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.GREEN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.INDIGO

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LAVENDER

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.LIME

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.MAROON

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.ORANGE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.ORCHID

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.PINK

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.PLUM

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.RED

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.ROSE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.TAN

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.TEAL

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.VIOLET

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.WHITE

getTriplet() - Method in class org.apache.poi.hssf.util.HSSFColor.YELLOW

getTripletHash() - Static method in class org.apache.poi.hssf.util.HSSFColor
this function returns all colors in a hastable.
getTxMasterStyleAtom() - Method in class org.apache.poi.hslf.record.Environment

getTxMasterStyleAtoms() - Method in class org.apache.poi.hslf.model.SlideMaster

getTxMasterStyleAtoms() - Method in class org.apache.poi.hslf.record.MainMaster

getType() - Method in interface org.apache.poi.common.usermodel.Hyperlink
Return the type of this hyperlink
getType() - Method in class org.apache.poi.ddf.EscherPropertyMetaData

getType() - Method in class org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition

getType() - Method in class org.apache.poi.hdgf.chunks.ChunkHeader
Returns the type of the chunk, which affects the mandatory information
getType() - Method in class org.apache.poi.hdgf.pointers.Pointer

getType() - Method in class org.apache.poi.hmef.attribute.MAPIAttribute

getType() - Method in class org.apache.poi.hmef.attribute.TNEFAttribute

getType() - Method in class org.apache.poi.hpsf.Property
Returns the property's type.
getType() - Method in class org.apache.poi.hslf.blip.DIB

getType() - Method in class org.apache.poi.hslf.blip.EMF

getType() - Method in class org.apache.poi.hslf.blip.JPEG

getType() - Method in class org.apache.poi.hslf.blip.PICT

getType() - Method in class org.apache.poi.hslf.blip.PNG

getType() - Method in class org.apache.poi.hslf.blip.WMF
We are of type Picture.WMF
getType() - Method in class org.apache.poi.hslf.model.Hyperlink
Gets the type of the hyperlink action.
getType() - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Gets whether the object is embedded or linked.
getType() - Method in class org.apache.poi.hslf.usermodel.PictureData
Returns type of this picture.
getType() - Method in class org.apache.poi.hsmf.datatypes.Chunk
Gets the numeric type of this chunk.
getType() - Method in class org.apache.poi.hssf.record.BOFRecord
type of object this marks
getType() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Get the type field for the Legend record.
getType() - Method in class org.apache.poi.hssf.usermodel.HSSFChart

getType() - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Return the type of this hyperlink
getType() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

getType() - Method in interface org.apache.poi.hwpf.usermodel.Field

getType() - Method in class org.apache.poi.openxml4j.opc.internal.ContentType
Get the type.
getType() - Method in interface org.apache.poi.sl.usermodel.PictureData

getType() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

getType() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout

getType() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Return the type of this hyperlink
getType() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
get Type of the Style
getType1stCap(String, String, int) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

getTypeFromOpcode(short) - Static method in class org.apache.poi.hwpf.sprm.SprmOperation

getTypeOfCharFollowingTheNumber() - Method in class org.apache.poi.hwpf.model.ListLevel
"The type of character following the number text for the paragraph: 0 == tab, 1 == space, 2 == nothing."
getTypeOffset() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get normal,super or subscript.
getTypeOffset() - Method in interface org.apache.poi.ss.usermodel.Font
get normal,super or subscript.
getTypeOffset() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get normal,super or subscript.
getTypeOfPLCS() - Method in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

getUByte(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get the unsigned value of a byte.
getUByte(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get the unsigned value of a byte.
getUDFFinder() - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

getUDFFinder() - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

getUDFFinder() - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

getUfel() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Collection properties represented by itypFELayout and copt (East Asian layout properties).
getUID() - Method in class org.apache.poi.ddf.EscherBitmapBlip

getUid() - Method in class org.apache.poi.ddf.EscherBSERecord
16 byte MD4 checksum.
getUID() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getUID() - Method in class org.apache.poi.ddf.EscherPictBlip

getUID() - Method in class org.apache.poi.hslf.usermodel.PictureData
Returns 16-byte checksum of this picture
getUID() - Method in interface org.apache.poi.sl.usermodel.PictureData

getUInt(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get an unsigned int value from a byte array
getUInt(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get an unsigned int value from a byte array
getUncalced() - Method in class org.apache.poi.hssf.model.InternalSheet

getUncompressedSize() - Method in class org.apache.poi.ddf.EscherMetafileBlip

getUncompressedSize() - Method in class org.apache.poi.ddf.EscherPictBlip

getUnderline() - Method in class org.apache.poi.hssf.record.FontRecord
get the type of underlining for the font
getUnderline() - Method in class org.apache.poi.hssf.usermodel.HSSFFont
get type of text underlining to use
getUnderline() - Method in interface org.apache.poi.ss.usermodel.Font
get type of text underlining to use
getUnderline() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get type of text underlining to use
getUnderline() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh
getUnderlineCode() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

getUnderlineCode() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getUnderlineType() - Method in class org.apache.poi.hssf.record.cf.FontFormatting
get the type of underlining for the font
getUnderlineType() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
get the type of underlining for the font
getUnderlineType() - Method in interface org.apache.poi.ss.usermodel.FontFormatting
get the type of underlining for the font
getUnderlineType() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
get the type of underlining for the font
getUnderlyingBytes() - Method in class org.apache.poi.hslf.HSLFSlideShow
Returns an array of the bytes of the file.
getUnderlyingProperties() - Method in class org.apache.poi.POIXMLProperties.CoreProperties

getUnderlyingProperties() - Method in class org.apache.poi.POIXMLProperties.CustomProperties

getUnderlyingProperties() - Method in class org.apache.poi.POIXMLProperties.ExtendedProperties

getUniqueCount() - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
Returns an integer representing the total count of unique strings in the Shared String Table.
getUniqueCount() - Method in class org.apache.poi.xssf.model.SharedStringsTable
Returns an integer representing the total count of unique strings in the Shared String Table.
getUnits() - Method in class org.apache.poi.hssf.record.chart.UnitsRecord
Get the units field for the Units record.
getUnknown1() - Method in class org.apache.poi.hdgf.chunks.ChunkHeader

getUnknown1() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns unknown1 field - currently unknown.
getUnknown2() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

getUnknown2() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV6

getUnknown2() - Method in class org.apache.poi.poifs.filesystem.Ole10Native
Returns the unknown2 field - currently being a byte[3] - mostly {0, 0, 0}.
getUnknown3() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

getUnknown3() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV6

getUnsignedByte(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
Deprecated. Use LittleEndian.getUByte(byte[], int) instead
getUnused() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value is undefined and MUST be ignored.
getUnused1() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Deprecated. This field should not be used according to specification
getUnused2() - Method in class org.apache.poi.ddf.EscherBSERecord

getUnused2() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the unused2 field for the DOP record.
getUnused2() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Deprecated. This field should not be used according to specification
getUnused2() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
This field MUST be ignored.
getUnused2() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the unused2 field for the SEP record.
getUnused3() - Method in class org.apache.poi.ddf.EscherBSERecord

getUnused3() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the unused3 field for the SEP record.
getUnused4() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the unused4 field for the SEP record.
getUnused5() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getUnused5() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the unused5 field for the SEP record.
getUnused6() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the unused6 field for the SEP record.
getUPX() - Method in class org.apache.poi.hwpf.model.UPX

getURI() - Method in class org.apache.poi.openxml4j.opc.PackagePartName
Part name property getter.
getURIFromPath(String) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Get URI from a string path.
getURL() - Method in class org.apache.poi.hssf.record.SupBookRecord

getURL() - Method in class org.apache.poi.xwpf.usermodel.XWPFHyperlink

getUsage() - Method in class org.apache.poi.ddf.EscherBSERecord
Defines the way this blip is used.
getUsedStyleList(XWPFStyle) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
get the styles which are related to the parameter style and their relatives this method can be used to copy all styles from one document to another document
getUsePage() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getUsePage() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the use page numbers.
getUsePage() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the use page numbers.
getUsePage() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the use page numbers.
getUserDateAtom() - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
A CString record that stores the user's date.
getUsername() - Method in class org.apache.poi.hssf.record.FileSharingRecord

getUsername() - Method in class org.apache.poi.hssf.record.WriteAccessRecord
get the username for the user that created the report.
getUserName() - Method in class org.apache.poi.hwpf.model.SavedByEntry

getUserStyleName() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Gets the name of the user defined style.
getUShort(byte[]) - Static method in class org.apache.poi.util.LittleEndian
get an unsigned short value from the beginning of a byte array
getUShort(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
get an unsigned short value from a byte array
getVal() - Method in class org.apache.poi.hwpf.model.PropertyModifier

getValidationConstraint() - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

getValidationConstraint() - Method in interface org.apache.poi.ss.usermodel.DataValidation

getValidationConstraint() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

getValidationType() - Method in class org.apache.poi.hssf.usermodel.DVConstraint

getValidationType() - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint

getValidationType() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

getValidSettings() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getValidSettings() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the valid settings.
getValidSettings() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the valid settings.
getValidSettings() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Use the printer's defaults settings for page setup values and don't use the default values specified in the schema.
getValue() - Method in class org.apache.poi.hdgf.chunks.Chunk.Command

getValue() - Method in class org.apache.poi.hpsf.Property
Returns the property's value.
getValue() - Method in exception org.apache.poi.hpsf.VariantTypeException
Returns the value who's variant type caused the problem.
getValue() - Method in class org.apache.poi.hslf.model.textproperties.TextProp
Fetch the value of the text property (meaning is specific to each different kind of text property)
getValue() - Method in class org.apache.poi.hsmf.datatypes.ByteChunk

getValue() - Method in class org.apache.poi.hsmf.datatypes.StringChunk
Returns the Text value of the chunk
getValue() - Method in class org.apache.poi.hssf.record.FormulaRecord
get the calculated value of the formula
getValue() - Method in class org.apache.poi.hssf.record.LabelRecord
get the value
getValue() - Method in class org.apache.poi.hssf.record.NumberRecord
get the value for the cell
getValue() - Method in class org.apache.poi.hwpf.model.Colorref

getValue() - Method in class org.apache.poi.hwpf.model.Hyphenation

getValue() - Method in class org.apache.poi.hwpf.model.PropertyModifier

getValue() - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Get the value field for the SHD80 record.
getValue() - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Get the value field for the TBD record.
getValue() - Method in class org.apache.poi.openxml4j.util.Nullable
Get the store value if any.
getValue(int, int) - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getValue() - Method in class org.apache.poi.ss.formula.ptg.BoolPtg

getValue() - Method in class org.apache.poi.ss.formula.ptg.IntPtg

getValue() - Method in class org.apache.poi.ss.formula.ptg.NumberPtg

getValue() - Method in class org.apache.poi.ss.formula.ptg.StringPtg

getValue(int, int) - Method in interface org.apache.poi.ss.formula.TwoDEval

getValue() - Method in enum org.apache.poi.ss.usermodel.FontCharset
Returns value of this charset
getValue() - Method in enum org.apache.poi.ss.usermodel.FontFamily
Returns index of this font family
getValue() - Method in enum org.apache.poi.ss.usermodel.FontScheme

getValue() - Method in enum org.apache.poi.ss.usermodel.FontUnderline

getValue() - Method in enum org.apache.poi.ss.usermodel.PageOrder

getValue() - Method in enum org.apache.poi.ss.usermodel.PrintCellComments

getValue() - Method in enum org.apache.poi.ss.usermodel.PrintOrientation

getValue(int) - Method in class org.apache.poi.util.BitField
Obtain the value for the specified BitField, appropriately shifted right.
getValue(String) - Method in class org.apache.poi.xslf.model.geom.Context

getValue() - Method in class org.apache.poi.xslf.model.PropertyFetcher

getValue() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter

getValue() - Method in enum org.apache.poi.xwpf.usermodel.Borders

getValue() - Method in enum org.apache.poi.xwpf.usermodel.BreakClear

getValue() - Method in enum org.apache.poi.xwpf.usermodel.BreakType

getValue() - Method in enum org.apache.poi.xwpf.usermodel.LineSpacingRule

getValue() - Method in enum org.apache.poi.xwpf.usermodel.ParagraphAlignment

getValue() - Method in enum org.apache.poi.xwpf.usermodel.TextAlignment

getValue() - Method in enum org.apache.poi.xwpf.usermodel.UnderlinePatterns

getValue() - Method in enum org.apache.poi.xwpf.usermodel.VerticalAlign

getValue1() - Method in class org.apache.poi.hssf.usermodel.DVConstraint

getValue2() - Method in class org.apache.poi.hssf.usermodel.DVConstraint

getValueAt(int) - Method in class org.apache.poi.poifs.storage.BATBlock

getValueDataSize() - Method in class org.apache.poi.hssf.record.BoolErrRecord

getValueDataSize() - Method in class org.apache.poi.hssf.record.CellRecord

getValueDataSize() - Method in class org.apache.poi.hssf.record.FormulaRecord

getValueDataSize() - Method in class org.apache.poi.hssf.record.LabelSSTRecord

getValueDataSize() - Method in class org.apache.poi.hssf.record.NumberRecord

getValueDataSize() - Method in class org.apache.poi.hssf.record.RKRecord

getValueRecords() - Method in class org.apache.poi.hssf.model.InternalSheet
Deprecated. use InternalSheet.getCellValueIterator() instead
getValueRecords() - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
Deprecated. use RowRecordsAggregate.getCellValueIterator() instead
getValueRecords() - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate
Deprecated. use ValueRecordsAggregate.iterator() instead
getValuesCellRange() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

getValuesDataType() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Get the values data type field for the Series record.
getValueType() - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries
See SeriesRecord
getVariantLength(long) - Static method in class org.apache.poi.hpsf.Variant
Returns a variant type's length.
getVariantName(long) - Static method in class org.apache.poi.hpsf.Variant
Returns the variant type name associated with a variant type number.
getVariantType() - Method in exception org.apache.poi.hpsf.VariantTypeException
Returns the offending variant type.
getVaryDisplayPattern() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

getVCenter() - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

getVCenter() - Method in class org.apache.poi.hssf.record.VCenterRecord
get whether to center vertically or not
getVerifier() - Method in class org.apache.poi.poifs.crypt.EncryptionInfo

getVerifier() - Method in class org.apache.poi.poifs.crypt.EncryptionVerifier

getVerifierHash() - Method in class org.apache.poi.poifs.crypt.EncryptionVerifier

getVersion() - Method in class org.apache.poi.ddf.EscherOptRecord

getVersion() - Method in class org.apache.poi.ddf.EscherRecord
Returns the version part of the option record.
getVersion() - Method in class org.apache.poi.hdgf.chunks.ChunkFactory

getVersion() - Method in class org.apache.poi.hdgf.pointers.PointerFactory

getVersion() - Method in class org.apache.poi.hssf.record.BOFRecord
Version number - for BIFF8 should be 0x06
getVersionMajor() - Method in class org.apache.poi.poifs.crypt.EncryptionInfo

getVersionMinor() - Method in class org.apache.poi.poifs.crypt.EncryptionInfo

getVersionProperty() - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Get version.
getVersionProperty() - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the version number.
getVertAlign() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Specifies the alignment of the cell contents relative to text flow (e.g.
getVertAlign() - Method in class org.apache.poi.hwpf.usermodel.TableCell

getVertical() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Get the type of vertical alignment for the cell
getVerticalAlignment() - Method in class org.apache.poi.hslf.model.TextShape
Returns the type of vertical alignment for the text.
getVerticalAlignment() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the vertical alignment field for the Text record.
getVerticalAlignment() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get the vertical alignment of text in the cell
getVerticalAlignment() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get the type of vertical alignment for the cell
getVerticalAlignment() - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Gets the vertical alignment.
getVerticalAlignment() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get the type of vertical alignment for the cell
getVerticalAlignment() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getVerticalAlignment() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Returns the type of vertical alignment for the text.
getVerticalAlignment() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of vertical alignment for the cell
getVerticalAlignment() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Returns the text vertical alignment which shall be applied to text in this paragraph.
getVerticalAlignment() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
Get the vertical alignment of the cell.
getVerticalAlignmentEnum() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Get the type of vertical alignment for the cell
getVerticalBorder() - Method in class org.apache.poi.hwpf.usermodel.TableRow

getVerticalHold() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get the vertical position of the window (in 1/20ths of a point)
getVerticallyCenter(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Mar-2008) use getVerticallyCenter() instead
getVerticallyCenter() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Determine whether printed output for this sheet will be vertically centered.
getVerticallyCenter() - Method in interface org.apache.poi.ss.usermodel.Sheet
Determine whether printed output for this sheet will be vertically centered.
getVerticallyCenter() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Determine whether printed output for this sheet will be vertically centered.
getVerticallyCenter() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Determine whether printed output for this sheet will be vertically centered.
getVerticalOffset() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

getVerticalOffset() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

getVerticalPos() - Method in class org.apache.poi.hssf.record.DVALRecord

getVerticalPositioning() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Specifies the type of vertical positioning to use for a shape
getVerticalRelativeElement() - Method in interface org.apache.poi.hwpf.usermodel.OfficeDrawing
Specifies a page element relative to which a shape is vertically positioned
getVerticalScale() - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord
Get the verticalScale field for the PlotGrowth record.
getVerticalScalingFactor() - Method in class org.apache.poi.hwpf.usermodel.Picture

getVerticalSplitLeftColumn() - Method in class org.apache.poi.hssf.util.PaneInformation
For a vertical split returns the left column in the RIGHT pane.
getVerticalSplitPosition() - Method in class org.apache.poi.hssf.util.PaneInformation
Returns the vertical position of the split.
getVerticalTextAlignment() - Method in class org.apache.poi.hssf.record.TextObjectRecord

getView() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the view field for the DOP record.
getViewableArray() - Method in interface org.apache.poi.poifs.dev.POIFSViewable
Get an array of objects, some of which may implement POIFSViewable
getViewableArray() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
Get an array of objects, some of which may implement POIFSViewable
getViewableArray() - Method in class org.apache.poi.poifs.filesystem.DocumentNode
Get an array of objects, some of which may implement POIFSViewable
getViewableArray() - Method in class org.apache.poi.poifs.filesystem.NPOIFSDocument
Get an array of objects, some of which may implement POIFSViewable
getViewableArray() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Get an array of objects, some of which may implement POIFSViewable
getViewableArray() - Method in class org.apache.poi.poifs.filesystem.POIFSDocument
Get an array of objects, some of which may implement POIFSViewable
getViewableArray() - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Get an array of objects, some of which may implement POIFSViewable
getViewableArray() - Method in class org.apache.poi.poifs.property.Property
Get an array of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in interface org.apache.poi.poifs.dev.POIFSViewable
Get an Iterator of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
Get an Iterator of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in class org.apache.poi.poifs.filesystem.DocumentNode
Get an Iterator of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in class org.apache.poi.poifs.filesystem.NPOIFSDocument
Get an Iterator of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Get an Iterator of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in class org.apache.poi.poifs.filesystem.POIFSDocument
Get an Iterator of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Get an Iterator of objects, some of which may implement POIFSViewable
getViewableIterator() - Method in class org.apache.poi.poifs.property.Property
Get an Iterator of objects, some of which may implement POIFSViewable
getViewFlags() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
getViewFlags_unused2() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Not used
getVirusinfo() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the virusinfo field for the DOP record.
getVisibleShapes() - Method in class org.apache.poi.hwpf.model.ShapesTable
Deprecated.
getVjc() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the vjc field for the SEP record.
getVMLDrawing(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get VML drawing for this sheet (aka 'legacy' drawig)
getVResolution() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

getVResolution() - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Returns the vertical resolution.
getVResolution() - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Returns the vertical resolution.
getVResolution() - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Returns the vertical resolution.
getW() - Method in class org.apache.poi.xslf.model.geom.Path

getWAlignFont() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the wAlignFont field for the PAP record.
getWCellPaddingBottom() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell margin/padding.
getWCellPaddingDefaultBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell margin/padding.
getWCellPaddingDefaultLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell margin/padding.
getWCellPaddingDefaultRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell margin/padding.
getWCellPaddingDefaultTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell margin/padding.
getWCellPaddingLeft() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell margin/padding.
getWCellPaddingOuterBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell margin/padding.
getWCellPaddingOuterLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell margin/padding.
getWCellPaddingOuterRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell margin/padding.
getWCellPaddingOuterTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell margin/padding.
getWCellPaddingRight() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell margin/padding.
getWCellPaddingTop() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell margin/padding.
getWCellSpacingBottom() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell spacing.
getWCellSpacingDefaultBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell spacings.
getWCellSpacingDefaultLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell spacings.
getWCellSpacingDefaultRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell spacings.
getWCellSpacingDefaultTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell spacings.
getWCellSpacingLeft() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell spacing.
getWCellSpacingOuterBottom() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell spacing.
getWCellSpacingOuterLeft() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell spacing.
getWCellSpacingOuterRight() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell spacing.
getWCellSpacingOuterTop() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell spacing.
getWCellSpacingRight() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell spacing.
getWCellSpacingTop() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell spacing.
getWCharScale() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Get the wCharScale field for the CHP record.
getWConflict() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When != 0, index number that identifies all text participating in a particular conflict incident.
getWeight() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Get the weight field for the LineFormat record.
getWeight() - Method in class org.apache.poi.hwpf.model.Ffn

getWholeColumn(String, String) - Static method in class org.apache.poi.ss.util.AreaReference

getWholeRow(String, String) - Static method in class org.apache.poi.ss.util.AreaReference

getWIdent() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
An unsigned integer that specifies that this is a Word Binary File.
getWidth() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Retrieve the width of the metafile in EMU's (English Metric Units).
getWidth() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Get the width field for the AxisParent record.
getWidth() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

getWidth() - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Get the width field for the Chart record.
getWidth() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the width field for the Text record.
getWidth() - Method in class org.apache.poi.hssf.record.WindowOneRecord
get the width of the window
getWidth() - Method in class org.apache.poi.hwpf.usermodel.Picture
returns pixel width of the picture or -1 if dimensions determining was failed
getWidth() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
getWidth() - Method in class org.apache.poi.hwpf.usermodel.TableCell

getWidth() - Method in interface org.apache.poi.ss.formula.eval.AreaEval

getWidth() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

getWidth() - Method in interface org.apache.poi.ss.formula.TwoDEval

getWidth() - Method in interface org.apache.poi.ss.usermodel.CellRange

getWidth() - Method in class org.apache.poi.ss.util.SSCellRange

getWidth() - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

getWidthAndFitsFlags() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Get the widthAndFitsFlags field for the TAP record.
getWidthAndFitsFlags_empty1() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Not used
getWidthAndFitsFlags_empty2() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Not used
getWidthMode() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current width mode of this manual layout.
getWidthMode() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getWidthRatio() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current fraction of the width of the chart.
getWidthRatio() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getWindowing() - Method in class org.apache.poi.hssf.record.DateWindow1904Record
gets whether or not to use 1904 date windowing (which means you'll be screwed in 2004)
getWindowOne() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getWindowTwo() - Method in class org.apache.poi.hssf.model.InternalSheet

getWordCount() - Method in class org.apache.poi.hpsf.SummaryInformation
Returns the word count or 0 if the SummaryInformation does not contain a word count.
getWordWrap() - Method in class org.apache.poi.hslf.model.TextShape
Returns the value indicating word wrap.
getWordWrap() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

getWorkbook() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Return the parent workbook
getWorkbook() - Method in class org.apache.poi.ss.formula.OperationEvaluationContext

getWorkbook() - Method in interface org.apache.poi.ss.usermodel.Sheet
Return the parent workbook
getWorkbook() - Method in class org.apache.poi.xssf.model.MapInfo
Returns the parent XSSFWorkbook
getWorkbook() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Return the parent workbook
getWorkbook() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns the parent XSSFWorkbook
getWorkbookData() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader
Returns an InputStream to read the contents of the main Workbook, which contains key overall data for the file, including sheet definitions.
getWorkbookEvaluator(String) - Method in class org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment

getWorkbookName() - Method in class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet

getWorksheetXMLInputStream() - Method in class org.apache.poi.xssf.streaming.GZIPSheetDataWriter

getWorksheetXMLInputStream() - Method in class org.apache.poi.xssf.streaming.SheetDataWriter

getWorksheetXMLInputStream() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet

getWr() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Text wrapping mode
getWr() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Get the wr field for the PAP record.
getWrapText() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether to wrap the text in the cell
getWrapText() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
get whether the text should be wrapped
getWrapText() - Method in interface org.apache.poi.ss.usermodel.CellStyle
get whether the text should be wrapped
getWrapText() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Whether the text should be wrapped
getWrapText() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Whether the text should be wrapped
getWriteAccess() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getWriteIndex() - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

getWriteMask() - Method in class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
As we're purely mask based, just set flags for stuff that is set
getWriteMask() - Method in class org.apache.poi.hslf.model.textproperties.TextProp
Get the mask that's used at write time.
getWriteProtect() - Method in class org.apache.poi.hssf.model.InternalWorkbook

getWrk() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Text wrapping mode type (valid only for wrapping modes 2 and 4
getWSBool1() - Method in class org.apache.poi.hssf.record.WSBoolRecord
get first byte (see bit getters)
getWSBool2() - Method in class org.apache.poi.hssf.record.WSBoolRecord
get the second byte (see bit getters)
getWScaleSaved() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getWSpare() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the wSpare field for the DOP record.
getWSpare2() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Get the wSpare2 field for the DOP record.
getWTextFlow() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the wTextFlow field for the SEP record.
getWvkSaved() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getWWidth() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Preferred table width.
getWWidth() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Preferred cell width.
getWWidthAfter() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Width of invisible cell (used for layout purposes) after the last visible cell in the row..
getWWidthBefore() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Width of invisible cell (used for layout purposes) before the first visible cell in the row..
getWWidthIndent() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Left Indent.
getX() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Get the x field for the AxisParent record.
getX() - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Get the x field for the Chart record.
getX() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the x field for the Text record.
getX() - Method in class org.apache.poi.hssf.record.PaneRecord
Get the x field for the Pane record.
getX() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns the x location of the chart element.
getX() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getX1() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
The top left x coordinate of this group.
getX1() - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
The top left x coordinate of this group.
getX2() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
The bottom right x coordinate of this group.
getX2() - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
The bottom right x coordinate of this group.
getXaLeft() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Left of rectangle enclosing shape relative to the origin of the shape.
getXaPage() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the xaPage field for the SEP record.
getXaPageNUp() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the xaPageNUp field for the SEP record.
getXaRight() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Right of rectangle enclosing shape relative to the origin of the shape.
getXAxisUpperLeft() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Get the x axis upper left field for the Legend record.
getXBasis() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Get the x Basis field for the FontBasis record.
getXBATCount() - Method in class org.apache.poi.poifs.storage.HeaderBlock

getXBATEntriesPerBlock() - Method in class org.apache.poi.poifs.common.POIFSBigBlockSize

getXBATIndex() - Method in class org.apache.poi.poifs.storage.HeaderBlock

getXchSym() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..
getXExt() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field is unused and MUST be ignored.
getXFAt(int) - Method in class org.apache.poi.hssf.record.MulBlankRecord
returns the xf index for column (coffset = column - field_2_first_col)
getXFAt(int) - Method in class org.apache.poi.hssf.record.MulRKRecord
returns the xf index for column (coffset = column - field_2_first_col)
getXFIndex() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

getXFIndex() - Method in class org.apache.poi.hssf.record.BlankRecord
get the index of the extended format record to style this cell with
getXFIndex() - Method in class org.apache.poi.hssf.record.CellRecord
get the index to the ExtendedFormat
getXFIndex() - Method in interface org.apache.poi.hssf.record.CellValueRecordInterface

getXFIndex() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
get the columns' default format info
getXFIndex() - Method in class org.apache.poi.hssf.record.LabelRecord

getXFIndex() - Method in class org.apache.poi.hssf.record.RowRecord
if the row is formatted then this is the index to the extended format record
getXFIndex() - Method in class org.apache.poi.hssf.record.StyleRecord
get the actual index of the style extended format record
getXFIndexForColAt(short) - Method in class org.apache.poi.hssf.model.InternalSheet
get the index to the ExtendedFormatRecord "associated" with the column at specified 0-based index.
getXfpos() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

getXFType() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether the cell is a cell or style XFRecord
getXmlColumnPrs() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getXmlDataType() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell

getXmlDataType() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFColor

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFHyperlink

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFNotes

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFNotesMaster

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFShape

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideLayout
While developing only!
getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFSlideMaster

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFTableRow

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFTableStyle

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFTableStyles

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

getXmlObject() - Method in class org.apache.poi.xslf.usermodel.XSLFTheme
While developing only!
getXMode() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current x-coordinnate layout mode.
getXMode() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getXOffset() - Method in class org.apache.poi.hslf.record.Comment2000Atom
Gets the X offset of the comment on the page.
getXpath() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell

getXPath() - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr

getXPoints() - Method in class org.apache.poi.hssf.usermodel.HSSFPolygon

getXPosition() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

getXSize() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Get the x size field for the Legend record.
getXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFFont
get the color value for the font References a color defined as Standard Alpha Red Green Blue color value (ARGB).
getXSSFColor() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting

getXSSFMapById(int) - Method in class org.apache.poi.xssf.model.MapInfo

getXSSFMapByName(String) - Method in class org.apache.poi.xssf.model.MapInfo

getXSSFSheet() - Method in class org.apache.poi.xssf.model.SingleXmlCells

getXSSFSheet() - Method in class org.apache.poi.xssf.usermodel.XSSFTable

getXSSFWorkbook() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook

getXstDispFldRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
The string value of the ListNum field when revision mark tracking began.
getXValues() - Method in interface org.apache.poi.ss.usermodel.charts.ScatterChartSerie

getXWPFDocument() - Method in interface org.apache.poi.xwpf.usermodel.IBody
Return XWPFDocument
getXWPFDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

getXWPFDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

getXWPFDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes

getXWPFDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

getXWPFDocument() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

getY() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Get the y field for the AxisParent record.
getY() - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Get the y field for the Chart record.
getY() - Method in class org.apache.poi.hssf.record.chart.TextRecord
Get the y field for the Text record.
getY() - Method in class org.apache.poi.hssf.record.PaneRecord
Get the y field for the Pane record.
getY() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current y location of the chart element.
getY() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getY1() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
The top left y coordinate of this group.
getY1() - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
The top left y coordinate of this group.
getY2() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
The bottom right y coordinate of this group.
getY2() - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
The bottom right y coordinate of this group.
getYaBottom() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Bottom of the rectangle enclosing shape relative to the origin of the shape.
getYaPage() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the yaPage field for the SEP record.
getYaPageNUp() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Get the yaPageNUp field for the SEP record.
getYaTop() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Top of rectangle enclosing shape relative to the origin of the shape.
getYAxisUpperLeft() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Get the y axis upper left field for the Legend record.
getYBasis() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Get the y Basis field for the FontBasis record.
getYExt() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field is unused and MUST be ignored.
getYMode() - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Returns current y-coordinate layout mode.
getYMode() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

getYOffset() - Method in class org.apache.poi.hslf.record.Comment2000Atom
Gets the Y offset of the comment on the page.
getYPoints() - Method in class org.apache.poi.hssf.usermodel.HSSFPolygon

getYPosition() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

getYSize() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Get the y size field for the Legend record.
getYValues() - Method in interface org.apache.poi.ss.usermodel.charts.ScatterChartSerie

getZero1() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the zero 1 field for the Tick record.
getZero2() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the zero 2 field for the Tick record.
getZero3() - Method in class org.apache.poi.hssf.record.chart.TickRecord
Get the zero 3 field for the Tick record.
getZeroHeight() - Method in class org.apache.poi.hssf.record.RowRecord
get whether or not to display this row with 0 height
getZeroHeight() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
get whether or not to display this row with 0 height
getZeroHeight() - Method in interface org.apache.poi.ss.usermodel.Row
Get whether or not to display this row with 0 height
getZeroHeight() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Get whether or not to display this row with 0 height
getZeroHeight() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Get whether or not to display this row with 0 height
getZipArchive() - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Get the zip archive
getZipArchive() - Method in class org.apache.poi.openxml4j.opc.ZipPackagePart
Get the zip entry of this part.
getZipItemNameFromOPCName(String) - Static method in class org.apache.poi.openxml4j.opc.internal.ZipHelper
Convert an OPC item name into a zip item name by removing any leading forward slash if it exist.
getZipURIFromOPCName(String) - Static method in class org.apache.poi.openxml4j.opc.internal.ZipHelper
Convert an OPC item name into a zip URI by removing any leading forward slash if it exist.
getZkSaved() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

getZoomPercent() - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings
Set zoom.
In the zoom tag inside settings.xml file
it sets the value of zoom
sample snippet from settings.xml
GIF - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
GIVEN_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

GLOSSARY_DOCUMENT - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

GOVERNMENT_ID_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

GPopublicintAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

Graph - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a chart object.
GRatioAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

GRColorAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

GREATER_OR_EQUAL - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

GREATER_THAN - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

GreaterEqualEval - Static variable in class org.apache.poi.ss.formula.eval.RelationalOperationEval

GreaterEqualPtg - Class in org.apache.poi.ss.formula.ptg
PTG class to implement greater or equal to
GreaterThanEval - Static variable in class org.apache.poi.ss.formula.eval.RelationalOperationEval

GreaterThanPtg - Class in org.apache.poi.ss.formula.ptg
Greater than operator PTG ">"
GRESTORE - Static variable in class org.apache.poi.xslf.usermodel.XSLFRenderingHint

Grfhic - Class in org.apache.poi.hwpf.model
The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
Grfhic() - Constructor for class org.apache.poi.hwpf.model.Grfhic

Grfhic(byte[], int) - Constructor for class org.apache.poi.hwpf.model.Grfhic

GrfhicAbstractType - Class in org.apache.poi.hwpf.model.types
The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
GrfhicAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.GrfhicAbstractType

gridset - Variable in class org.apache.poi.hssf.model.InternalSheet

GridsetRecord - Class in org.apache.poi.hssf.record
Title: Gridset Record.
GridsetRecord() - Constructor for class org.apache.poi.hssf.record.GridsetRecord

GridsetRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.GridsetRecord

group(Matcher, int) - Static method in class org.apache.poi.ss.format.CellFormatPart
Returns the string from the group, or "" if the group is null.
groupColumn(short, short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.groupColumn(int, int)
groupColumn(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Create an outline for the provided column range.
groupColumn(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Create an outline for the provided column range.
groupColumn(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Create an outline for the provided column range.
groupColumn(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Group between (0 based) columns
groupColumnRange(int, int, boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
Creates an outline group for the specified columns.
groupColumnRange(int, int, boolean) - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate
Creates an outline group for the specified columns, by setting the level field for each col info record in the range.
GroupMarkerSubRecord - Class in org.apache.poi.hssf.record
ftGmo (0x0006)
The group marker record is used as a position holder for groups.
GroupMarkerSubRecord() - Constructor for class org.apache.poi.hssf.record.GroupMarkerSubRecord

GroupMarkerSubRecord(LittleEndianInput, int) - Constructor for class org.apache.poi.hssf.record.GroupMarkerSubRecord

groupRow(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Tie a range of cell together so that they can be collapsed or expanded
groupRow(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Tie a range of rows together so that they can be collapsed or expanded
groupRow(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Tie a range of rows together so that they can be collapsed or expanded
groupRow(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Tie a range of cell together so that they can be collapsed or expanded
groupRowRange(int, int, boolean) - Method in class org.apache.poi.hssf.model.InternalSheet

GROUPSHAPE__1DADJUSTMENT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__BEHINDDOCUMENT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__BORDERBOTTOMCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__BORDERLEFTCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__BORDERRIGHTCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__BORDERTOPCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__EDITEDWRAP - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__FLAGS - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__HIDDEN - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__HR_ALIGN - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__HR_HEIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__HR_PCT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__HR_WIDTH - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__HYPERLINK - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__ISBUTTON - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__METROBLOB - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__ONDBLCLICKNOTIFY - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__POSH - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__POSRELH - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__POSRELV - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__POSV - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__PRINT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__REGROUPID - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__SCRIPT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__SCRIPTEXT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__SCRIPTLANG - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__SHAPENAME - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__TABLEPROPERTIES - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__TABLEROWPROPERTIES - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__TOOLTIP - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__UNUSED906 - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__WEBBOT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__WRAPDISTBOTTOM - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__WRAPDISTLEFT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__WRAPDISTRIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__WRAPDISTTOP - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__WRAPPOLYGONVERTICES - Static variable in class org.apache.poi.ddf.EscherProperties

GROUPSHAPE__ZORDER - Static variable in class org.apache.poi.ddf.EscherProperties

GRPXSTATNOWNERS - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

GSAVE - Static variable in class org.apache.poi.xslf.usermodel.XSLFRenderingHint

GScalingAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

GT - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

GT - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Greater than' operator
guess7BitEncoding() - Method in class org.apache.poi.hsmf.MAPIMessage
Many messages store their strings as unicode, which is nice and easy.
Guide - Class in org.apache.poi.xslf.model.geom
Date: 10/24/11
Guide(CTGeomGuide) - Constructor for class org.apache.poi.xslf.model.geom.Guide

Guide(String, String) - Constructor for class org.apache.poi.xslf.model.geom.Guide

GuideAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

GutsRecord - Class in org.apache.poi.hssf.record
Title: Guts Record
GutsRecord() - Constructor for class org.apache.poi.hssf.record.GutsRecord

GutsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.GutsRecord

GZIPSheetDataWriter - Class in org.apache.poi.xssf.streaming
Sheet writer that supports gzip compression of the temp files.
GZIPSheetDataWriter() - Constructor for class org.apache.poi.xssf.streaming.GZIPSheetDataWriter

H

H_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

HAIR - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

HALF_BODY_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

HALF_FRAME - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

handle - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

handleEmails(StringBuffer, String, String, StringUtil.StringsIterator) - Method in class org.apache.poi.hsmf.extractor.OutlookTextExtactor
Takes a Display focused string, eg "Nick; Jim" and an iterator of emails, and does its best to return something like "Nick ; Jim "
handleParentAwareRecords(RecordContainer) - Static method in class org.apache.poi.hslf.record.RecordContainer
Find the records that are parent-aware, and tell them who their parent is
handlingClass - Variable in class org.apache.poi.hslf.record.RecordTypes.Type

HandOut - Static variable in class org.apache.poi.hslf.record.RecordTypes

HANDOUT - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

has7BitEncodingStrings() - Method in class org.apache.poi.hsmf.MAPIMessage
Does this file contain any strings that are stored as 7 bit rather than unicode?
HAS_SELF_RELATIVE_SECURITY_FEATURE - Static variable in class org.apache.poi.hssf.record.common.FeatProtection

HASATTACH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

hasCachedResultString() - Method in class org.apache.poi.hssf.record.FormulaRecord

hasChildOfType(short) - Method in class org.apache.poi.ddf.EscherContainerRecord
Do any of our (top level) children have the given recordId?
hasComments() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Does this sheet have any comments on it? We need to know, so we can decide about writing it to disk or not
hasCustomHeight() - Method in class org.apache.poi.xssf.streaming.SXSSFRow

hasData() - Method in class org.apache.poi.poifs.storage.RawDataBlock
Did we actually find any data to read? It's possible, in the event of a short last block, to both have hit the EoF, but also to have data
hasDirectoryEntry() - Method in class org.apache.poi.hssf.usermodel.HSSFObjectData
Does this ObjectData have an associated POIFS Directory Entry? (Not all do, those that don't have a data portion)
hasEntry(String) - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
Checks if entry with specified name present
hasEntry(String) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode

hasEntry(String) - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

hasEscherPicture(CharacterRun) - Method in class org.apache.poi.hwpf.model.PicturesTable

hasExactSharedBorder(CellRangeAddress, CellRangeAddress) - Static method in class org.apache.poi.hssf.record.cf.CellRangeUtil
Check if the specified cell range has a shared border with the current range.
hasFixedArgsLength() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

hasFormula() - Method in class org.apache.poi.hssf.record.NameRecord

hasFormula() - Method in interface org.apache.poi.ss.formula.EvaluationName

hasFreeSectors() - Method in class org.apache.poi.poifs.storage.BATBlock
Does this BATBlock have any free sectors in it, or is it full?
HASH_SHA1 - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

hashCode() - Method in class org.apache.poi.ddf.EscherComplexProperty

hashCode() - Method in class org.apache.poi.ddf.EscherSimpleProperty
Returns a hashcode so that this object can be stored in collections that require the use of such things.
hashCode() - Method in class org.apache.poi.hpsf.ClassID

hashCode() - Method in class org.apache.poi.hpsf.CustomProperty

hashCode() - Method in class org.apache.poi.hpsf.Property

hashCode() - Method in class org.apache.poi.hpsf.PropertySet

hashCode() - Method in class org.apache.poi.hpsf.Section

hashCode() - Method in class org.apache.poi.hpsf.SpecialPropertySet

hashCode() - Method in class org.apache.poi.hssf.record.common.UnicodeString

hashCode() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord

hashCode() - Method in class org.apache.poi.hssf.record.FontRecord

hashCode() - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle

hashCode() - Method in class org.apache.poi.hssf.usermodel.HSSFFont

hashCode() - Method in class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

hashCode() - Method in class org.apache.poi.hwpf.model.Colorref

hashCode() - Method in class org.apache.poi.hwpf.model.FibBase

hashCode() - Method in class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

hashCode() - Method in class org.apache.poi.hwpf.model.Hyphenation

hashCode() - Method in class org.apache.poi.hwpf.model.ListData

hashCode() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

hashCode() - Method in class org.apache.poi.hwpf.model.PICF

hashCode() - Method in class org.apache.poi.hwpf.model.PieceDescriptor

hashCode() - Method in class org.apache.poi.hwpf.model.PropertyModifier

hashCode() - Method in class org.apache.poi.hwpf.model.PropertyNode

hashCode() - Method in class org.apache.poi.hwpf.model.SavedByEntry
Generates a hash code for consistency with SavedByEntry.equals(Object).
hashCode() - Method in class org.apache.poi.hwpf.model.StyleDescription

hashCode() - Method in class org.apache.poi.hwpf.model.TextPieceTable

hashCode() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

hashCode() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

hashCode() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType

hashCode() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType

hashCode() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

hashCode() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType

hashCode() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType

hashCode() - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

hashCode() - Method in class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

hashCode() - Method in class org.apache.poi.openxml4j.opc.internal.ContentType

hashCode() - Method in class org.apache.poi.openxml4j.opc.PackagePartName

hashCode() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

hashCode() - Method in class org.apache.poi.poifs.filesystem.DocumentDescriptor
calculate and return the hashcode
hashCode() - Method in class org.apache.poi.poifs.filesystem.POIFSDocumentPath
calculate and return the hashcode
hashCode() - Method in class org.apache.poi.ss.format.CellFormat
Returns a hash code for the format.
hashCode() - Method in class org.apache.poi.util.IntList
Returns the hash code value for this list.
hashCode() - Method in class org.apache.poi.util.ShortList
Returns the hash code value for this list.
hashCode() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder

hashCode() - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill

hashCode() - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Returns a hash code value for the object.
hashCode() - Method in class org.apache.poi.xssf.usermodel.XSSFColor

hashCode() - Method in class org.apache.poi.xssf.usermodel.XSSFFont

hashCode() - Method in class org.apache.poi.xssf.usermodel.XSSFName

hashCode() - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData

hasHorizontalLine(CharacterRun) - Method in class org.apache.poi.hwpf.model.PicturesTable
determines whether specified CharacterRun contains reference to a picture
hashPassword(String) - Static method in class org.apache.poi.hssf.record.FileSharingRecord

hashPassword(String) - Static method in class org.apache.poi.hssf.record.PasswordRecord

hashPassword(EncryptionInfo, String) - Method in class org.apache.poi.poifs.crypt.Decryptor

hasMultibyte(String) - Static method in class org.apache.poi.util.StringUtil
check the parameter has multibyte character
hasNext() - Method in class org.apache.poi.hssf.model.RecordStream

hasNext() - Method in class org.apache.poi.hwpf.sprm.SprmIterator

hasNext() - Method in class org.apache.poi.hwpf.usermodel.TableIterator

hasNext() - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator

hasNext() - Method in class org.apache.poi.util.StringUtil.StringsIterator

hasNext() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator
Returns true if the iteration has more elements.
hasNext() - Method in class org.apache.poi.xssf.streaming.SXSSFRow.CellIterator

hasNext() - Method in class org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator

hasNextRecord() - Method in class org.apache.poi.hssf.record.RecordInputStream
Note - this method is expected to be called only when completed reading the current BIFF record.
hasOOXMLHeader(InputStream) - Static method in class org.apache.poi.POIXMLDocument
Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a OOXML (zip) header at the start of it.
hasPicture(CharacterRun) - Method in class org.apache.poi.hwpf.model.PicturesTable
determines whether specified CharacterRun contains reference to a picture
hasPOIFSHeader(InputStream) - Static method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a POIFS (OLE2) header at the start of it.
hasPOIFSHeader(InputStream) - Static method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a POIFS (OLE2) header at the start of it.
hasRelationships() - Method in class org.apache.poi.openxml4j.opc.OPCPackage

hasRelationships() - Method in class org.apache.poi.openxml4j.opc.PackagePart
Knows if the part have any relationships.
hasRelationships() - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Knows if the part have any relationships.
hasSameName(XWPFStyle) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
compares the names of the Styles
hasSeparator() - Method in class org.apache.poi.hdgf.chunks.ChunkHeader

hasSeparator() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV11
Does the chunk have a separator?
hasSeparator() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5
Does the chunk have a separator?
hasSeparator() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV6
Does the chunk have a separator?
hasSeparator() - Method in interface org.apache.poi.hwpf.usermodel.Field

hasTrailer() - Method in class org.apache.poi.hdgf.chunks.ChunkHeader

hasTrailer() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5
Does the chunk have a trailer?
hasTrailer() - Method in class org.apache.poi.hdgf.chunks.ChunkHeaderV6
Does the chunk have a trailer?
hasUnlimitedVarags() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata
Some varags functions (like VLOOKUP) have a specific limit to the number of arguments that can be passed.
hasValue() - Method in class org.apache.poi.openxml4j.util.Nullable
Get the status of this nullable.
HCenterRecord - Class in org.apache.poi.hssf.record
Title: HCenter record (0x0083)
HCenterRecord() - Constructor for class org.apache.poi.hssf.record.HCenterRecord

HCenterRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.HCenterRecord

HDFType - Interface in org.apache.poi.hwpf.model
Deprecated.
HDGFDiagram - Class in org.apache.poi.hdgf
See http://www.redferni.uklinux.net/visio/ http://www.gnome.ru/projects/docs/vsdocs.html http://www.gnome.ru/projects/docs/slide1.png http://www.gnome.ru/projects/docs/slide2.png
HDGFDiagram(POIFSFileSystem) - Constructor for class org.apache.poi.hdgf.HDGFDiagram

HDGFDiagram(NPOIFSFileSystem) - Constructor for class org.apache.poi.hdgf.HDGFDiagram

HDGFDiagram(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hdgf.HDGFDiagram
Deprecated. Use HDGFDiagram.HDGFDiagram(DirectoryNode) instead
HDGFDiagram(DirectoryNode) - Constructor for class org.apache.poi.hdgf.HDGFDiagram

HDGFException - Exception in org.apache.poi.hdgf.exceptions
The superclass of all HDGF exceptions
HDGFException() - Constructor for exception org.apache.poi.hdgf.exceptions.HDGFException

HDGFException(String) - Constructor for exception org.apache.poi.hdgf.exceptions.HDGFException

HDGFException(String, Throwable) - Constructor for exception org.apache.poi.hdgf.exceptions.HDGFException

HDGFException(Throwable) - Constructor for exception org.apache.poi.hdgf.exceptions.HDGFException

HDGFLZW - Class in org.apache.poi.hdgf
A decoder for the crazy LZW implementation used in Visio.
HDGFLZW() - Constructor for class org.apache.poi.hdgf.HDGFLZW

head - Variable in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

head - Variable in class org.apache.poi.hwpf.converter.TextDocumentFacade

Header - Interface in org.apache.poi.ss.usermodel
Common definition of a HSSF or XSSF page header.
HEADER - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

HEADER_FOLDER_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HEADER_FOOTER_089C - Static variable in class org.apache.poi.hssf.record.UnknownRecord

HEADER_SIGNATURE - Static variable in class org.apache.poi.hmef.HMEFMessage

HEADER_SIZE - Static variable in class org.apache.poi.hslf.blip.DIB
Size of the BITMAPFILEHEADER structure preceding the actual DIB bytes
HEADER_SIZE - Static variable in class org.apache.poi.hslf.dev.PPTXMLDump

HEADERATOM - Static variable in class org.apache.poi.hslf.record.HeadersFootersContainer

HeaderBlock - Class in org.apache.poi.poifs.storage
The block containing the archive header
HeaderBlock(InputStream) - Constructor for class org.apache.poi.poifs.storage.HeaderBlock
create a new HeaderBlockReader from an InputStream
HeaderBlock(ByteBuffer) - Constructor for class org.apache.poi.poifs.storage.HeaderBlock

HeaderBlock(POIFSBigBlockSize) - Constructor for class org.apache.poi.poifs.storage.HeaderBlock
Create a single instance initialized with default values
HeaderBlockConstants - Interface in org.apache.poi.poifs.storage
Constants used in reading/writing the Header block
HeaderBlockWriter - Class in org.apache.poi.poifs.storage
The block containing the archive header
HeaderBlockWriter(POIFSBigBlockSize) - Constructor for class org.apache.poi.poifs.storage.HeaderBlockWriter
Create a single instance initialized with default values
HeaderBlockWriter(HeaderBlock) - Constructor for class org.apache.poi.poifs.storage.HeaderBlockWriter
Create a single instance initialized with the specified existing values
HeaderFooter - Class in org.apache.poi.hssf.usermodel
Common class for HSSFHeader and HSSFFooter.
HeaderFooter() - Constructor for class org.apache.poi.hssf.usermodel.HeaderFooter

HeaderFooter - Interface in org.apache.poi.ss.usermodel
Common interface for Header and Footer.
headerFooter(String, boolean, String) - Method in interface org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler
A header or footer has been encountered
headerFooter(String, boolean, String) - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

HeaderFooterBase - Class in org.apache.poi.hssf.record
Common header/footer base class
HeaderFooterBase(String) - Constructor for class org.apache.poi.hssf.record.HeaderFooterBase

HeaderFooterBase(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.HeaderFooterBase

HeaderFooterEntity_Date - Static variable in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

HeaderFooterEntity_File - Static variable in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

HeaderFooterEntity_Time - Static variable in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

HeaderFooterHelper - Class in org.apache.poi.xssf.usermodel.helpers

HeaderFooterHelper() - Constructor for class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

HeaderFooterRecord - Class in org.apache.poi.hssf.record
The HEADERFOOTER record stores information added in Office Excel 2007 for headers/footers.
HeaderFooterRecord(byte[]) - Constructor for class org.apache.poi.hssf.record.HeaderFooterRecord

HeaderFooterRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.HeaderFooterRecord
construct a HeaderFooterRecord record.
HeaderMargin - Static variable in interface org.apache.poi.ss.usermodel.Sheet

HeaderRecord - Class in org.apache.poi.hssf.record
Title: Header Record
HeaderRecord(String) - Constructor for class org.apache.poi.hssf.record.HeaderRecord

HeaderRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.HeaderRecord

headers - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

HeadersFooters - Class in org.apache.poi.hslf.model
Header / Footer settings.
HeadersFooters(HeadersFootersContainer, SlideShow, boolean, boolean) - Constructor for class org.apache.poi.hslf.model.HeadersFooters

HeadersFooters(HeadersFootersContainer, Sheet, boolean, boolean) - Constructor for class org.apache.poi.hslf.model.HeadersFooters

HeadersFooters - Static variable in class org.apache.poi.hslf.record.RecordTypes

HeadersFootersAtom - Class in org.apache.poi.hslf.record
An atom record that specifies options for displaying headers and footers on a presentation slide or notes slide.
HeadersFootersAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.HeadersFootersAtom
Build an instance of HeadersFootersAtom from on-disk data
HeadersFootersAtom() - Constructor for class org.apache.poi.hslf.record.HeadersFootersAtom
Create a new instance of HeadersFootersAtom
HeadersFootersAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

HeadersFootersContainer - Class in org.apache.poi.hslf.record
A container record that specifies information about the footers on a presentation slide.
HeadersFootersContainer(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.HeadersFootersContainer

HeadersFootersContainer(short) - Constructor for class org.apache.poi.hslf.record.HeadersFootersContainer

HeaderStories - Class in org.apache.poi.hwpf.usermodel
A HeaderStory is a Header, a Footer, or footnote/endnote separator.
HeaderStories(HWPFDocument) - Constructor for class org.apache.poi.hwpf.usermodel.HeaderStories

headerToken - Static variable in class org.apache.poi.hslf.record.CurrentUserAtom
The PowerPoint magic number for a non-encrypted file
Heart - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

HEART - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

HEPTAGON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Hexagon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

HEXAGON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

HexDump - Class in org.apache.poi.util
dump data in hexadecimal format; derived from a HexDump utility I wrote in June 2001.
hexHeader - Variable in class org.apache.poi.hslf.dev.PPTXMLDump

HexRead - Class in org.apache.poi.util
Utilities to read hex from files.
HexRead() - Constructor for class org.apache.poi.util.HexRead

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.AQUA

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLACK

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.BROWN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.CORAL

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_RED

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.GOLD

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREEN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.INDIGO

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LAVENDER

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIME

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.MAROON

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.ORANGE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.ORCHID

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.PINK

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.PLUM

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.RED

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.ROSE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.TAN

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.TEAL

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.VIOLET

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.WHITE

hexString - Static variable in class org.apache.poi.hssf.util.HSSFColor.YELLOW

HH_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

HIDDEN - Static variable in class org.apache.poi.ss.util.CellUtil

Hide - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
whether the shape is hidden while the animation is not playing
HIDE_ALL - Static variable in class org.apache.poi.hssf.record.HideObjRecord

HideObjRecord - Class in org.apache.poi.hssf.record
Title: Hide Object Record
HideObjRecord() - Constructor for class org.apache.poi.hssf.record.HideObjRecord

HideObjRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.HideObjRecord

HISTORY_MASK - Static variable in class org.apache.poi.hssf.record.BOFRecord
suggested default for a normal sheet (0x41)
hit(Rectangle, Shape, boolean) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Checks whether or not the specified Shape intersects the specified Rectangle, which is in device space.
hit(Rectangle, Shape, boolean) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

hit(Rectangle, Shape, boolean) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

hitClip(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

Hlookup - Class in org.apache.poi.ss.formula.functions
Implementation of the HLOOKUP() function.
HLOOKUP finds a column in a lookup table by the first row value and returns the value from another row.
Syntax:
HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)
lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.
Hlookup() - Constructor for class org.apache.poi.ss.formula.functions.Hlookup

HMEFContentsExtractor - Class in org.apache.poi.hmef.extractor
A utility for extracting out the message body, and all attachments from a HMEF/TNEF/winmail.dat file
HMEFContentsExtractor(File) - Constructor for class org.apache.poi.hmef.extractor.HMEFContentsExtractor

HMEFContentsExtractor(HMEFMessage) - Constructor for class org.apache.poi.hmef.extractor.HMEFContentsExtractor

HMEFDumper - Class in org.apache.poi.hmef.dev
Developer focused raw dumper
HMEFDumper(InputStream) - Constructor for class org.apache.poi.hmef.dev.HMEFDumper

HMEFMessage - Class in org.apache.poi.hmef
HMEF - Implementation of the Microsoft TNEF message encoding format (aka winmail.dat) See: http://support.microsoft.com/kb/241538 http://en.wikipedia.org/wiki/Transport_Neutral_Encapsulation_Format http://search.cpan.org/dist/Convert-TNEF/
HMEFMessage(InputStream) - Constructor for class org.apache.poi.hmef.HMEFMessage

HOBBIES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME2_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_ADDRESS_CITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_ADDRESS_COUNTRY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_ADDRESS_POST_OFFICE_BOX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_ADDRESS_POSTAL_CODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_ADDRESS_STATE_OR_PROVINCE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_ADDRESS_STREET - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_FAX_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HOME_PLATE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

HOME_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

HomePlate - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

HORIZONTAL_ALIGNMENT_BOTTOM - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

HORIZONTAL_ALIGNMENT_CENTER - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

HORIZONTAL_ALIGNMENT_CENTERED - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

HORIZONTAL_ALIGNMENT_DISTRIBUTED - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

HORIZONTAL_ALIGNMENT_JUSTIFIED - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

HORIZONTAL_ALIGNMENT_JUSTIFY - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

HORIZONTAL_ALIGNMENT_LEFT - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

HORIZONTAL_ALIGNMENT_LEFT - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox
How to align text horizontally
HORIZONTAL_ALIGNMENT_RIGHT - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

HORIZONTAL_SCROLL - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

HORIZONTAL_TEXT_ALIGNMENT_CENTERED - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

HORIZONTAL_TEXT_ALIGNMENT_JUSTIFIED - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

HORIZONTAL_TEXT_ALIGNMENT_LEFT_ALIGNED - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

HORIZONTAL_TEXT_ALIGNMENT_RIGHT_ALIGNED - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

HorizontalAlignment - Enum in org.apache.poi.ss.usermodel
The enumeration value indicating horizontal alignment of a cell, i.e., whether it is aligned general, left, right, horizontally centered, filled (replicated), justified, centered across multiple cells, or distributed.
HorizontalPageBreakRecord - Class in org.apache.poi.hssf.record
HorizontalPageBreak (0x001B) record that stores page breaks at rows

HorizontalPageBreakRecord() - Constructor for class org.apache.poi.hssf.record.HorizontalPageBreakRecord
Creates an empty horizontal page break record
HorizontalPageBreakRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.HorizontalPageBreakRecord

HorizontalScroll - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

HostControl - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

HOUR - Static variable in class org.apache.poi.ss.formula.functions.CalendarFieldFunction

HPBFDocument - Class in org.apache.poi.hpbf
This class provides the basic functionality for HPBF, our implementation of the publisher file format.
HPBFDocument(POIFSFileSystem) - Constructor for class org.apache.poi.hpbf.HPBFDocument
Opens a new publisher document
HPBFDocument(NPOIFSFileSystem) - Constructor for class org.apache.poi.hpbf.HPBFDocument

HPBFDocument(InputStream) - Constructor for class org.apache.poi.hpbf.HPBFDocument

HPBFDocument(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hpbf.HPBFDocument
Deprecated. Use HPBFDocument.HPBFDocument(DirectoryNode) instead
HPBFDocument(DirectoryNode) - Constructor for class org.apache.poi.hpbf.HPBFDocument
Opens an embedded publisher document, at the given directory.
HPBFDumper - Class in org.apache.poi.hpbf.dev
For dumping out the contents of HPBF (Publisher) files, while we try to figure out how they're constructed.
HPBFDumper(POIFSFileSystem) - Constructor for class org.apache.poi.hpbf.dev.HPBFDumper

HPBFDumper(InputStream) - Constructor for class org.apache.poi.hpbf.dev.HPBFDumper

HPBFPart - Class in org.apache.poi.hpbf.model
Parent class of all HPBF sub-parts, handling the fiddly reading in / writing out bits for all of them.
HPBFPart(DirectoryNode, String[]) - Constructor for class org.apache.poi.hpbf.model.HPBFPart

HPSFException - Exception in org.apache.poi.hpsf
This exception is the superclass of all other checked exceptions thrown in this package.
HPSFException() - Constructor for exception org.apache.poi.hpsf.HPSFException
Creates an HPSFException.
HPSFException(String) - Constructor for exception org.apache.poi.hpsf.HPSFException
Creates an HPSFException with a message string.
HPSFException(Throwable) - Constructor for exception org.apache.poi.hpsf.HPSFException
Creates a new HPSFException with a reason.
HPSFException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.HPSFException
Creates an HPSFException with a message string and a reason.
HPSFPropertiesExtractor - Class in org.apache.poi.hpsf.extractor
Extracts all of the HPSF properties, both build in and custom, returning them in textual form.
HPSFPropertiesExtractor(POITextExtractor) - Constructor for class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

HPSFPropertiesExtractor(POIDocument) - Constructor for class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

HPSFPropertiesExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

HPSFPropertiesExtractor(NPOIFSFileSystem) - Constructor for class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

HPSFRuntimeException - Exception in org.apache.poi.hpsf
This exception is the superclass of all other unchecked exceptions thrown in this package.
HPSFRuntimeException() - Constructor for exception org.apache.poi.hpsf.HPSFRuntimeException
Creates a new HPSFRuntimeException.
HPSFRuntimeException(String) - Constructor for exception org.apache.poi.hpsf.HPSFRuntimeException
Creates a new HPSFRuntimeException with a message string.
HPSFRuntimeException(Throwable) - Constructor for exception org.apache.poi.hpsf.HPSFRuntimeException
Creates a new HPSFRuntimeException with a reason.
HPSFRuntimeException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.HPSFRuntimeException
Creates a new HPSFRuntimeException with a message string and a reason.
HRES_ADD_LETTER_BEFORE - Static variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

HRES_CHANGE_LETTER_AFTER - Static variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

HRES_CHANGE_LETTER_BEFORE - Static variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

HRES_DELETE_BEFORE_CHANGE_BEFORE - Static variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

HRES_DELETE_LETTER_BEFORE - Static variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

HRES_NO - Static variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

HRES_NORMAL - Static variable in class org.apache.poi.hwpf.model.types.HRESIAbstractType

HRESIAbstractType - Class in org.apache.poi.hwpf.model.types
Hyphenation (HRESI).
HRESIAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.HRESIAbstractType

HSLFException - Exception in org.apache.poi.hslf.exceptions
A generic exception that can be thrown by HSLF classes
HSLFException() - Constructor for exception org.apache.poi.hslf.exceptions.HSLFException

HSLFException(String) - Constructor for exception org.apache.poi.hslf.exceptions.HSLFException

HSLFException(String, Throwable) - Constructor for exception org.apache.poi.hslf.exceptions.HSLFException

HSLFException(Throwable) - Constructor for exception org.apache.poi.hslf.exceptions.HSLFException

HSLFSlideShow - Class in org.apache.poi.hslf
This class contains the main functionality for the Powerpoint file "reader".
HSLFSlideShow(String) - Constructor for class org.apache.poi.hslf.HSLFSlideShow
Constructs a Powerpoint document from fileName.
HSLFSlideShow(InputStream) - Constructor for class org.apache.poi.hslf.HSLFSlideShow
Constructs a Powerpoint document from an input stream.
HSLFSlideShow(POIFSFileSystem) - Constructor for class org.apache.poi.hslf.HSLFSlideShow
Constructs a Powerpoint document from a POIFS Filesystem.
HSLFSlideShow(NPOIFSFileSystem) - Constructor for class org.apache.poi.hslf.HSLFSlideShow
Constructs a Powerpoint document from a POIFS Filesystem.
HSLFSlideShow(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hslf.HSLFSlideShow
Deprecated. Use HSLFSlideShow.HSLFSlideShow(DirectoryNode) instead
HSLFSlideShow(DirectoryNode) - Constructor for class org.apache.poi.hslf.HSLFSlideShow
Constructs a Powerpoint document from a specific point in a POIFS Filesystem.
HSMFDump - Class in org.apache.poi.hsmf.dev
Dumps out the chunk details, and where possible contents
HSMFDump(POIFSFileSystem) - Constructor for class org.apache.poi.hsmf.dev.HSMFDump

HSSFAnchor - Class in org.apache.poi.hssf.usermodel
An anchor is what specifics the position of a shape within a client object or within another containing shape.
HSSFAnchor() - Constructor for class org.apache.poi.hssf.usermodel.HSSFAnchor

HSSFAnchor(int, int, int, int) - Constructor for class org.apache.poi.hssf.usermodel.HSSFAnchor

HSSFAutoFilter - Class in org.apache.poi.hssf.usermodel
Represents autofiltering for the specified worksheet.
HSSFBorderFormatting - Class in org.apache.poi.hssf.usermodel
High level representation for Border Formatting component of Conditional Formatting settings
HSSFBorderFormatting(CFRuleRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

HSSFCell - Class in org.apache.poi.hssf.usermodel
High level representation of a cell in a row of a spreadsheet.
HSSFCell(HSSFWorkbook, HSSFSheet, int, short) - Constructor for class org.apache.poi.hssf.usermodel.HSSFCell
Creates new Cell - Should only be called by HSSFRow.
HSSFCell(HSSFWorkbook, HSSFSheet, int, short, int) - Constructor for class org.apache.poi.hssf.usermodel.HSSFCell
Creates new Cell - Should only be called by HSSFRow.
HSSFCell(HSSFWorkbook, HSSFSheet, CellValueRecordInterface) - Constructor for class org.apache.poi.hssf.usermodel.HSSFCell
Creates an HSSFCell from a CellValueRecordInterface.
HSSFCellStyle - Class in org.apache.poi.hssf.usermodel
High level representation of the style of a cell in a sheet of a workbook.
HSSFCellStyle(short, ExtendedFormatRecord, HSSFWorkbook) - Constructor for class org.apache.poi.hssf.usermodel.HSSFCellStyle
Creates new HSSFCellStyle why would you want to do this??
HSSFCellStyle(short, ExtendedFormatRecord, InternalWorkbook) - Constructor for class org.apache.poi.hssf.usermodel.HSSFCellStyle

HSSFCellUtil - Class in org.apache.poi.hssf.util
Various utility functions that make working with a cells and rows easier.
HSSFChart - Class in org.apache.poi.hssf.usermodel
Has methods for construction of a chart object.
HSSFChart.HSSFChartType - Enum in org.apache.poi.hssf.usermodel

HSSFChart.HSSFSeries - Class in org.apache.poi.hssf.usermodel
A series in a chart
HSSFChildAnchor - Class in org.apache.poi.hssf.usermodel

HSSFChildAnchor() - Constructor for class org.apache.poi.hssf.usermodel.HSSFChildAnchor

HSSFChildAnchor(int, int, int, int) - Constructor for class org.apache.poi.hssf.usermodel.HSSFChildAnchor

HSSFClientAnchor - Class in org.apache.poi.hssf.usermodel
A client anchor is attached to an excel worksheet.
HSSFClientAnchor() - Constructor for class org.apache.poi.hssf.usermodel.HSSFClientAnchor
Creates a new client anchor and defaults all the anchor positions to 0.
HSSFClientAnchor(int, int, int, int, short, int, short, int) - Constructor for class org.apache.poi.hssf.usermodel.HSSFClientAnchor
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
HSSFColor - Class in org.apache.poi.hssf.util
Intends to provide support for the very evil index to triplet issue and will likely replace the color constants interface for HSSF 2.0.
HSSFColor() - Constructor for class org.apache.poi.hssf.util.HSSFColor
Creates a new instance of HSSFColor
HSSFColor.AQUA - Class in org.apache.poi.hssf.util
Class AQUA
HSSFColor.AQUA() - Constructor for class org.apache.poi.hssf.util.HSSFColor.AQUA

HSSFColor.AUTOMATIC - Class in org.apache.poi.hssf.util
Special Default/Normal/Automatic color.
HSSFColor.AUTOMATIC() - Constructor for class org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

HSSFColor.BLACK - Class in org.apache.poi.hssf.util
Class BLACK
HSSFColor.BLACK() - Constructor for class org.apache.poi.hssf.util.HSSFColor.BLACK

HSSFColor.BLUE - Class in org.apache.poi.hssf.util
Class BLUE
HSSFColor.BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.BLUE

HSSFColor.BLUE_GREY - Class in org.apache.poi.hssf.util
Class BLUE_GREY
HSSFColor.BLUE_GREY() - Constructor for class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

HSSFColor.BRIGHT_GREEN - Class in org.apache.poi.hssf.util
Class BRIGHT_GREEN
HSSFColor.BRIGHT_GREEN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

HSSFColor.BROWN - Class in org.apache.poi.hssf.util
Class BROWN
HSSFColor.BROWN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.BROWN

HSSFColor.CORAL - Class in org.apache.poi.hssf.util
Class CORAL
HSSFColor.CORAL() - Constructor for class org.apache.poi.hssf.util.HSSFColor.CORAL

HSSFColor.CORNFLOWER_BLUE - Class in org.apache.poi.hssf.util
Class CORNFLOWER_BLUE
HSSFColor.CORNFLOWER_BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

HSSFColor.DARK_BLUE - Class in org.apache.poi.hssf.util
Class DARK_BLUE
HSSFColor.DARK_BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

HSSFColor.DARK_GREEN - Class in org.apache.poi.hssf.util
Class DARK_GREEN
HSSFColor.DARK_GREEN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

HSSFColor.DARK_RED - Class in org.apache.poi.hssf.util
Class DARK_RED
HSSFColor.DARK_RED() - Constructor for class org.apache.poi.hssf.util.HSSFColor.DARK_RED

HSSFColor.DARK_TEAL - Class in org.apache.poi.hssf.util
Class DARK_TEAL
HSSFColor.DARK_TEAL() - Constructor for class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

HSSFColor.DARK_YELLOW - Class in org.apache.poi.hssf.util
Class DARK_YELLOW
HSSFColor.DARK_YELLOW() - Constructor for class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

HSSFColor.GOLD - Class in org.apache.poi.hssf.util
Class GOLD
HSSFColor.GOLD() - Constructor for class org.apache.poi.hssf.util.HSSFColor.GOLD

HSSFColor.GREEN - Class in org.apache.poi.hssf.util
Class GREEN
HSSFColor.GREEN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.GREEN

HSSFColor.GREY_25_PERCENT - Class in org.apache.poi.hssf.util
Class GREY_25_PERCENT
HSSFColor.GREY_25_PERCENT() - Constructor for class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

HSSFColor.GREY_40_PERCENT - Class in org.apache.poi.hssf.util
Class GREY_40_PERCENT
HSSFColor.GREY_40_PERCENT() - Constructor for class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

HSSFColor.GREY_50_PERCENT - Class in org.apache.poi.hssf.util
Class GREY_50_PERCENT
HSSFColor.GREY_50_PERCENT() - Constructor for class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

HSSFColor.GREY_80_PERCENT - Class in org.apache.poi.hssf.util
Class GREY_80_PERCENT
HSSFColor.GREY_80_PERCENT() - Constructor for class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

HSSFColor.INDIGO - Class in org.apache.poi.hssf.util
Class INDIGO
HSSFColor.INDIGO() - Constructor for class org.apache.poi.hssf.util.HSSFColor.INDIGO

HSSFColor.LAVENDER - Class in org.apache.poi.hssf.util
Class LAVENDER
HSSFColor.LAVENDER() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LAVENDER

HSSFColor.LEMON_CHIFFON - Class in org.apache.poi.hssf.util
Class LEMON_CHIFFON
HSSFColor.LEMON_CHIFFON() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

HSSFColor.LIGHT_BLUE - Class in org.apache.poi.hssf.util
Class LIGHT_BLUE
HSSFColor.LIGHT_BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

HSSFColor.LIGHT_CORNFLOWER_BLUE - Class in org.apache.poi.hssf.util
Class LIGHT_CORNFLOWER_BLUE
HSSFColor.LIGHT_CORNFLOWER_BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

HSSFColor.LIGHT_GREEN - Class in org.apache.poi.hssf.util
Class LIGHT_GREEN
HSSFColor.LIGHT_GREEN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

HSSFColor.LIGHT_ORANGE - Class in org.apache.poi.hssf.util
Class LIGHT_ORANGE
HSSFColor.LIGHT_ORANGE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

HSSFColor.LIGHT_TURQUOISE - Class in org.apache.poi.hssf.util
Class LIGHT_TURQUOISE
HSSFColor.LIGHT_TURQUOISE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

HSSFColor.LIGHT_YELLOW - Class in org.apache.poi.hssf.util
Class LIGHT_YELLOW
HSSFColor.LIGHT_YELLOW() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

HSSFColor.LIME - Class in org.apache.poi.hssf.util
Class LIME
HSSFColor.LIME() - Constructor for class org.apache.poi.hssf.util.HSSFColor.LIME

HSSFColor.MAROON - Class in org.apache.poi.hssf.util
Class MAROON
HSSFColor.MAROON() - Constructor for class org.apache.poi.hssf.util.HSSFColor.MAROON

HSSFColor.OLIVE_GREEN - Class in org.apache.poi.hssf.util
Class OLIVE_GREEN
HSSFColor.OLIVE_GREEN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

HSSFColor.ORANGE - Class in org.apache.poi.hssf.util
Class ORANGE
HSSFColor.ORANGE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.ORANGE

HSSFColor.ORCHID - Class in org.apache.poi.hssf.util
Class ORCHID
HSSFColor.ORCHID() - Constructor for class org.apache.poi.hssf.util.HSSFColor.ORCHID

HSSFColor.PALE_BLUE - Class in org.apache.poi.hssf.util
Class PALE_BLUE
HSSFColor.PALE_BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

HSSFColor.PINK - Class in org.apache.poi.hssf.util
Class PINK
HSSFColor.PINK() - Constructor for class org.apache.poi.hssf.util.HSSFColor.PINK

HSSFColor.PLUM - Class in org.apache.poi.hssf.util
Class PLUM
HSSFColor.PLUM() - Constructor for class org.apache.poi.hssf.util.HSSFColor.PLUM

HSSFColor.RED - Class in org.apache.poi.hssf.util
Class RED
HSSFColor.RED() - Constructor for class org.apache.poi.hssf.util.HSSFColor.RED

HSSFColor.ROSE - Class in org.apache.poi.hssf.util
Class ROSE
HSSFColor.ROSE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.ROSE

HSSFColor.ROYAL_BLUE - Class in org.apache.poi.hssf.util
Class ROYAL_BLUE
HSSFColor.ROYAL_BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

HSSFColor.SEA_GREEN - Class in org.apache.poi.hssf.util
Class SEA_GREEN
HSSFColor.SEA_GREEN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

HSSFColor.SKY_BLUE - Class in org.apache.poi.hssf.util
Class SKY_BLUE
HSSFColor.SKY_BLUE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

HSSFColor.TAN - Class in org.apache.poi.hssf.util
Class TAN
HSSFColor.TAN() - Constructor for class org.apache.poi.hssf.util.HSSFColor.TAN

HSSFColor.TEAL - Class in org.apache.poi.hssf.util
Class TEAL
HSSFColor.TEAL() - Constructor for class org.apache.poi.hssf.util.HSSFColor.TEAL

HSSFColor.TURQUOISE - Class in org.apache.poi.hssf.util
Class TURQUOISE
HSSFColor.TURQUOISE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

HSSFColor.VIOLET - Class in org.apache.poi.hssf.util
Class VIOLET
HSSFColor.VIOLET() - Constructor for class org.apache.poi.hssf.util.HSSFColor.VIOLET

HSSFColor.WHITE - Class in org.apache.poi.hssf.util
Class WHITE
HSSFColor.WHITE() - Constructor for class org.apache.poi.hssf.util.HSSFColor.WHITE

HSSFColor.YELLOW - Class in org.apache.poi.hssf.util
Class YELLOW
HSSFColor.YELLOW() - Constructor for class org.apache.poi.hssf.util.HSSFColor.YELLOW

HSSFComment - Class in org.apache.poi.hssf.usermodel
Represents a cell comment - a sticky note associated with a cell.
HSSFComment(HSSFShape, HSSFAnchor) - Constructor for class org.apache.poi.hssf.usermodel.HSSFComment
Construct a new comment with the given parent and anchor.
HSSFComment(NoteRecord, TextObjectRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFComment

HSSFConditionalFormatting - Class in org.apache.poi.hssf.usermodel
HSSFConditionalFormatting class encapsulates all settings of Conditional Formatting.
HSSFConditionalFormattingRule - Class in org.apache.poi.hssf.usermodel
High level representation of Conditional Formatting Rule.
HSSFCreationHelper - Class in org.apache.poi.hssf.usermodel

HSSFDataFormat - Class in org.apache.poi.hssf.usermodel
Identifies both built-in and user defined formats within a workbook.
See BuiltinFormats for a list of supported built-in formats.
International Formats
Since version 2003 Excel has supported international formats.
HSSFDataFormatter - Class in org.apache.poi.hssf.usermodel
HSSFDataFormatter contains methods for formatting the value stored in an HSSFCell.
HSSFDataFormatter(Locale) - Constructor for class org.apache.poi.hssf.usermodel.HSSFDataFormatter
Creates a formatter using the given locale.
HSSFDataFormatter() - Constructor for class org.apache.poi.hssf.usermodel.HSSFDataFormatter
Creates a formatter using the default locale.
HSSFDataValidation - Class in org.apache.poi.hssf.usermodel
Utility class for creating data validation cells
HSSFDataValidation(CellRangeAddressList, DataValidationConstraint) - Constructor for class org.apache.poi.hssf.usermodel.HSSFDataValidation
Constructor which initializes the cell range on which this object will be applied
HSSFDataValidationHelper - Class in org.apache.poi.hssf.usermodel

HSSFDataValidationHelper(HSSFSheet) - Constructor for class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

HSSFDateUtil - Class in org.apache.poi.hssf.usermodel
Contains methods for dealing with Excel dates.
HSSFDateUtil() - Constructor for class org.apache.poi.hssf.usermodel.HSSFDateUtil

HSSFErrorConstants - Class in org.apache.poi.hssf.usermodel
Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)
HSSFErrorConstants() - Constructor for class org.apache.poi.hssf.usermodel.HSSFErrorConstants

HSSFEvaluationWorkbook - Class in org.apache.poi.hssf.usermodel
Internal POI use only
HSSFEventFactory - Class in org.apache.poi.hssf.eventusermodel
Low level event based HSSF reader.
HSSFEventFactory() - Constructor for class org.apache.poi.hssf.eventusermodel.HSSFEventFactory
Creates a new instance of HSSFEventFactory
HSSFFont - Class in org.apache.poi.hssf.usermodel
Represents a Font used in a workbook.
HSSFFont(short, FontRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFFont
Creates a new instance of HSSFFont
HSSFFontFormatting - Class in org.apache.poi.hssf.usermodel
High level representation for Font Formatting component of Conditional Formatting settings
HSSFFontFormatting(CFRuleRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFFontFormatting

HSSFFooter - Class in org.apache.poi.hssf.usermodel
Class to read and manipulate the footer.
HSSFFooter(PageSettingsBlock) - Constructor for class org.apache.poi.hssf.usermodel.HSSFFooter

HSSFFormulaEvaluator - Class in org.apache.poi.hssf.usermodel
Evaluates formula cells.
For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.
HSSFFormulaEvaluator(HSSFSheet, HSSFWorkbook) - Constructor for class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Deprecated. (Sep 2008) HSSFSheet parameter is ignored
HSSFFormulaEvaluator(HSSFWorkbook) - Constructor for class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator

HSSFFormulaEvaluator(HSSFWorkbook, IStabilityClassifier) - Constructor for class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator

HSSFFormulaParser - Class in org.apache.poi.hssf.model
HSSF wrapper for the FormulaParser and FormulaRenderer
HSSFHeader - Class in org.apache.poi.hssf.usermodel
Class to read and manipulate the header.
HSSFHeader(PageSettingsBlock) - Constructor for class org.apache.poi.hssf.usermodel.HSSFHeader

HSSFHyperlink - Class in org.apache.poi.hssf.usermodel
Represents an Excel hyperlink.
HSSFHyperlink(int) - Constructor for class org.apache.poi.hssf.usermodel.HSSFHyperlink
Construct a new hyperlink
HSSFHyperlink(HyperlinkRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFHyperlink
Initialize the hyperlink by a HyperlinkRecord record
HSSFListener - Interface in org.apache.poi.hssf.eventusermodel
Interface for use with the HSSFRequest and HSSFEventFactory.
HSSFName - Class in org.apache.poi.hssf.usermodel
High Level Representation of a 'defined name' which could be a 'built-in' name, 'named range' or name of a user defined function.
HSSFObjectData - Class in org.apache.poi.hssf.usermodel
Represents binary object (i.e.
HSSFObjectData(ObjRecord, DirectoryEntry) - Constructor for class org.apache.poi.hssf.usermodel.HSSFObjectData
Constructs object data by wrapping a lower level object record.
HSSFOptimiser - Class in org.apache.poi.hssf.usermodel
Excel can get cranky if you give it files containing too many (especially duplicate) objects, and this class can help to avoid those.
HSSFOptimiser() - Constructor for class org.apache.poi.hssf.usermodel.HSSFOptimiser

HSSFPalette - Class in org.apache.poi.hssf.usermodel
Represents a workbook color palette.
HSSFPalette(PaletteRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFPalette

HSSFPatriarch - Class in org.apache.poi.hssf.usermodel
The patriarch is the toplevel container for shapes in a sheet.
HSSFPatternFormatting - Class in org.apache.poi.hssf.usermodel
High level representation for Conditional Formatting settings
HSSFPatternFormatting(CFRuleRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

HSSFPicture - Class in org.apache.poi.hssf.usermodel
Represents a escher picture.
HSSFPicture(HSSFShape, HSSFAnchor) - Constructor for class org.apache.poi.hssf.usermodel.HSSFPicture
Constructs a picture object.
HSSFPictureData - Class in org.apache.poi.hssf.usermodel
Represents binary data stored in the file.
HSSFPictureData(EscherBlipRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFPictureData
Constructs a picture object.
HSSFPolygon - Class in org.apache.poi.hssf.usermodel

HSSFPrintSetup - Class in org.apache.poi.hssf.usermodel
Used to modify the print setup.
HSSFPrintSetup(PrintSetupRecord) - Constructor for class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Constructor.
HSSFRegionUtil - Class in org.apache.poi.hssf.util
Various utility functions that make working with a region of cells easier.
HSSFRequest - Class in org.apache.poi.hssf.eventusermodel
An HSSFRequest object should be constructed registering an instance or multiple instances of HSSFListener with each Record.sid you wish to listen for.
HSSFRequest() - Constructor for class org.apache.poi.hssf.eventusermodel.HSSFRequest
Creates a new instance of HSSFRequest
HSSFRichTextString - Class in org.apache.poi.hssf.usermodel
Rich text unicode string.
HSSFRichTextString() - Constructor for class org.apache.poi.hssf.usermodel.HSSFRichTextString

HSSFRichTextString(String) - Constructor for class org.apache.poi.hssf.usermodel.HSSFRichTextString

HSSFRow - Class in org.apache.poi.hssf.usermodel
High level representation of a row of a spreadsheet.
HSSFShape - Class in org.apache.poi.hssf.usermodel
An abstract shape.
HSSFShapeContainer - Interface in org.apache.poi.hssf.usermodel
An interface that indicates whether a class can contain children.
HSSFShapeGroup - Class in org.apache.poi.hssf.usermodel
A shape group may contain other shapes.
HSSFShapeGroup(HSSFShape, HSSFAnchor) - Constructor for class org.apache.poi.hssf.usermodel.HSSFShapeGroup

HSSFSheet - Class in org.apache.poi.hssf.usermodel
High level representation of a worksheet.
HSSFSheet(HSSFWorkbook) - Constructor for class org.apache.poi.hssf.usermodel.HSSFSheet
Creates new HSSFSheet - called by HSSFWorkbook to create a sheet from scratch.
HSSFSheet(HSSFWorkbook, InternalSheet) - Constructor for class org.apache.poi.hssf.usermodel.HSSFSheet
Creates an HSSFSheet representing the given Sheet object.
HSSFSheetConditionalFormatting - Class in org.apache.poi.hssf.usermodel
The 'Conditional Formatting' facet of HSSFSheet
HSSFSimpleShape - Class in org.apache.poi.hssf.usermodel
Represents a simple shape such as a line, rectangle or oval.
HSSFSimpleShape(HSSFShape, HSSFAnchor) - Constructor for class org.apache.poi.hssf.usermodel.HSSFSimpleShape

HSSFTextbox - Class in org.apache.poi.hssf.usermodel
A textbox is a shape that may hold a rich text string.
HSSFTextbox(HSSFShape, HSSFAnchor) - Constructor for class org.apache.poi.hssf.usermodel.HSSFTextbox
Construct a new textbox with the given parent and anchor.
HSSFUserException - Exception in org.apache.poi.hssf.eventusermodel
This exception is provided as a way for API users to throw exceptions from their event handling code.
HSSFUserException() - Constructor for exception org.apache.poi.hssf.eventusermodel.HSSFUserException
Creates a new HSSFUserException.
HSSFUserException(String) - Constructor for exception org.apache.poi.hssf.eventusermodel.HSSFUserException
Creates a new HSSFUserException with a message string.
HSSFUserException(Throwable) - Constructor for exception org.apache.poi.hssf.eventusermodel.HSSFUserException
Creates a new HSSFUserException with a reason.
HSSFUserException(String, Throwable) - Constructor for exception org.apache.poi.hssf.eventusermodel.HSSFUserException
Creates a new HSSFUserException with a message string and a reason.
HSSFWorkbook - Class in org.apache.poi.hssf.usermodel
High level representation of a workbook.
HSSFWorkbook() - Constructor for class org.apache.poi.hssf.usermodel.HSSFWorkbook
Creates new HSSFWorkbook from scratch (start here!)
HSSFWorkbook(POIFSFileSystem) - Constructor for class org.apache.poi.hssf.usermodel.HSSFWorkbook

HSSFWorkbook(POIFSFileSystem, boolean) - Constructor for class org.apache.poi.hssf.usermodel.HSSFWorkbook
given a POI POIFSFileSystem object, read in its Workbook and populate the high and low level models.
HSSFWorkbook(DirectoryNode, POIFSFileSystem, boolean) - Constructor for class org.apache.poi.hssf.usermodel.HSSFWorkbook
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models.
HSSFWorkbook(DirectoryNode, boolean) - Constructor for class org.apache.poi.hssf.usermodel.HSSFWorkbook
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models.
HSSFWorkbook(InputStream) - Constructor for class org.apache.poi.hssf.usermodel.HSSFWorkbook

HSSFWorkbook(InputStream, boolean) - Constructor for class org.apache.poi.hssf.usermodel.HSSFWorkbook
Companion to HSSFWorkbook(POIFSFileSystem), this constructs the POI filesystem around your inputstream.
html - Variable in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

htmlBodyChunkBinary - Variable in class org.apache.poi.hsmf.datatypes.Chunks

htmlBodyChunkString - Variable in class org.apache.poi.hsmf.datatypes.Chunks
BODY Html Chunk, for html messages
HtmlDocumentFacade - Class in org.apache.poi.hwpf.converter

HtmlDocumentFacade(Document) - Constructor for class org.apache.poi.hwpf.converter.HtmlDocumentFacade

HWPFDocument - Class in org.apache.poi.hwpf
This class acts as the bucket that we throw all of the Word data structures into.
HWPFDocument() - Constructor for class org.apache.poi.hwpf.HWPFDocument

HWPFDocument(InputStream) - Constructor for class org.apache.poi.hwpf.HWPFDocument
This constructor loads a Word document from an InputStream.
HWPFDocument(POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.HWPFDocument
This constructor loads a Word document from a POIFSFileSystem
HWPFDocument(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.HWPFDocument
Deprecated. Use HWPFDocument.HWPFDocument(DirectoryNode) instead
HWPFDocument(DirectoryNode) - Constructor for class org.apache.poi.hwpf.HWPFDocument
This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default.
HWPFDocumentCore - Class in org.apache.poi.hwpf
This class holds much of the core of a Word document, but without some of the table structure information.
HWPFDocumentCore() - Constructor for class org.apache.poi.hwpf.HWPFDocumentCore

HWPFDocumentCore(InputStream) - Constructor for class org.apache.poi.hwpf.HWPFDocumentCore
This constructor loads a Word document from an InputStream.
HWPFDocumentCore(POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.HWPFDocumentCore
This constructor loads a Word document from a POIFSFileSystem
HWPFDocumentCore(DirectoryNode) - Constructor for class org.apache.poi.hwpf.HWPFDocumentCore
This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default.
HWPFFileSystem - Class in org.apache.poi.hwpf.model.io

HWPFFileSystem() - Constructor for class org.apache.poi.hwpf.model.io.HWPFFileSystem

HWPFList - Class in org.apache.poi.hwpf.usermodel
This class is used to create a list in a Word document.
HWPFList(boolean, StyleSheet) - Constructor for class org.apache.poi.hwpf.usermodel.HWPFList

HWPFLister - Class in org.apache.poi.hwpf.dev
Used by developers to list out key information on a HWPF file.
HWPFLister(HWPFDocumentCore) - Constructor for class org.apache.poi.hwpf.dev.HWPFLister

HWPFOldDocument - Class in org.apache.poi.hwpf
Provides very simple support for old (Word 6 / Word 95) files.
HWPFOldDocument(POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.HWPFOldDocument

HWPFOldDocument(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.HWPFOldDocument
Deprecated.
HWPFOldDocument(DirectoryNode) - Constructor for class org.apache.poi.hwpf.HWPFOldDocument

HWPFOutputStream - Class in org.apache.poi.hwpf.model.io

HWPFOutputStream() - Constructor for class org.apache.poi.hwpf.model.io.HWPFOutputStream

Hyperlink - Interface in org.apache.poi.common.usermodel
Represents a hyperlink.
Hyperlink - Class in org.apache.poi.hslf.model
Represents a hyperlink in a PowerPoint document
Hyperlink() - Constructor for class org.apache.poi.hslf.model.Hyperlink

Hyperlink - Interface in org.apache.poi.sl.usermodel
A PowerPoint hyperlink
Hyperlink - Class in org.apache.poi.ss.formula.functions
Implementation of Excel HYPERLINK function.
In Excel this function has special behaviour - it causes the displayed cell value to behave like a hyperlink in the GUI.
Hyperlink() - Constructor for class org.apache.poi.ss.formula.functions.Hyperlink

Hyperlink - Interface in org.apache.poi.ss.usermodel
Represents an Excel hyperlink.
HYPERLINK - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

HYPERLINK - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

HYPERLINK_PART - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Hyperlink type.
HyperlinkRecord - Class in org.apache.poi.hssf.record
The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format.
HyperlinkRecord() - Constructor for class org.apache.poi.hssf.record.HyperlinkRecord
Create a new hyperlink
HyperlinkRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.HyperlinkRecord

hyperlinks - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

Hyphenation - Class in org.apache.poi.hwpf.model
Hyphenation.
Hyphenation() - Constructor for class org.apache.poi.hwpf.model.Hyphenation

Hyphenation(short) - Constructor for class org.apache.poi.hwpf.model.Hyphenation

I

IAdjustableShape - Interface in org.apache.poi.xslf.model.geom
A bridge to the consumer application.
IBody - Interface in org.apache.poi.xwpf.usermodel
8 Jan 2010
IBodyElement - Interface in org.apache.poi.xwpf.usermodel
9 Jan 2010
ICON - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

id - Variable in class org.apache.poi.hdgf.chunks.ChunkHeader

id - Variable in class org.apache.poi.hmef.attribute.TNEFProperty
The TNEF Property ID
id - Variable in class org.apache.poi.hpsf.Property
The property's ID.
id - Variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

id - Variable in class org.apache.poi.ss.usermodel.Row.MissingCellPolicy

id - Variable in class org.apache.poi.xwpf.usermodel.XWPFComment

ID_AIDOWNER - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHCREATEDATE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHDATA - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHMENT - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHMETAFILE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHMODIFYDATE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHRENDERDATA - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHTITLE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTACHTRANSPORTFILENAME - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ATTRIBUTE_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackageRelationship

ID_BODY - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_CONVERSATIONID - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_DATEEND - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_DATEMODIFIED - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_DATERECEIVED - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_DATESENT - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_DATESTART - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_DELEGATE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_FROM - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_MAPIPROPERTIES - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_MESSAGECLASS - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_MESSAGEID - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_MESSAGESTATUS - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_NULL - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_OEMCODEPAGE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_ORIGINALMESSAGECLASS - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_OWNER - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_PARENTID - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_PRIORITY - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_RECIPIENTTABLE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_REQUESTRESPONSE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_SENTFOR - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_SUBJECT - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_TNEFVERSION - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

ID_UNKNOWN - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

identifier - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
An unambiguous reference to the resource within a given context.
IdentifierManager - Class in org.apache.poi.util
24.08.2009

IdentifierManager(long, long) - Constructor for class org.apache.poi.util.IdentifierManager

IDENTITY_DISPLAY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IDENTITY_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IDENTITY_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

idSet() - Method in class org.apache.poi.hpsf.CustomProperties
Returns a set of all the IDs of our custom properties
IfElseExpression - Class in org.apache.poi.xslf.model.geom
If Else Formula:
IfFunc - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function IF
IfFunc() - Constructor for class org.apache.poi.ss.formula.functions.IfFunc

IGNORED - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType
default value to supply when the operator type is not used
IHDR - Static variable in class org.apache.poi.hwpf.usermodel.Picture

IllegalPropertySetDataException - Exception in org.apache.poi.hpsf
This exception is thrown when there is an illegal value set in a PropertySet.
IllegalPropertySetDataException() - Constructor for exception org.apache.poi.hpsf.IllegalPropertySetDataException
Constructor
IllegalPropertySetDataException(String) - Constructor for exception org.apache.poi.hpsf.IllegalPropertySetDataException
Constructor
IllegalPropertySetDataException(Throwable) - Constructor for exception org.apache.poi.hpsf.IllegalPropertySetDataException
Constructor
IllegalPropertySetDataException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.IllegalPropertySetDataException
Constructor
IllegalVariantTypeException - Exception in org.apache.poi.hpsf
This exception is thrown if HPSF encounters a variant type that is illegal in the current context.
IllegalVariantTypeException(long, Object, String) - Constructor for exception org.apache.poi.hpsf.IllegalVariantTypeException
Constructor
IllegalVariantTypeException(long, Object) - Constructor for exception org.apache.poi.hpsf.IllegalVariantTypeException
Constructor
IMAGE_BMP - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_BMP - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_BMP - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_DIB - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_DIB - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_DIB - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_EMF - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_EMF - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_EMF - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation
Supported image formats
IMAGE_EPS - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_EPS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_EPS - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_GIF - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

IMAGE_GIF - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_GIF - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_GIF - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_JPEG - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

IMAGE_JPEG - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_JPEG - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_JPEG - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_PART - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Image type.
IMAGE_PICT - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Pict image format.
IMAGE_PICT - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_PICT - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_PICT - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_PNG - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes

IMAGE_PNG - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_PNG - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_PNG - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_RENDERER - Static variable in class org.apache.poi.xslf.usermodel.XSLFRenderingHint
Use a custom image rendener
IMAGE_TIFF - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
TIFF image format.
IMAGE_TIFF - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_TIFF - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_TIFF - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_WMF - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_WMF - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_WMF - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

IMAGE_WPG - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGE_WPG - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGE_WPG - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

ImageExtractor - Class in org.apache.poi.hslf.extractor
Utility to extract pictures from a PowerPoint file.
ImageExtractor() - Constructor for class org.apache.poi.hslf.extractor.ImageExtractor

ImagePainter - Interface in org.apache.poi.hslf.blip
A common interface for objects that can render ppt picture data.
IMAGES - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

IMAGES - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

IMAGES - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

ImageUtils - Class in org.apache.poi.ss.util

ImageUtils() - Constructor for class org.apache.poi.ss.util.ImageUtils

IMPLICIT_CONVERSION_PROHIBITED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IMPORTANCE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

importContent(XSLFSheet) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Set the contents of this sheet to be a copy of the source sheet.
importContent(XSLFSheet) - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

importFromXML(String) - Method in class org.apache.poi.xssf.extractor.XSSFImportFromXML
Imports an XML into the XLSX using the Custom XML mapping defined
IN_REPLY_TO_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

inch - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

INCOMPLETE_COPY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

incrementShapeCount() - Method in class org.apache.poi.ddf.EscherDgRecord

incrementShapeId() - Method in class org.apache.poi.ddf.EscherDggRecord.FileIdCluster

INDENTION - Static variable in class org.apache.poi.ss.util.CellUtil

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.AQUA

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLACK

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.BROWN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.CORAL

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_RED

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.GOLD

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREEN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.INDIGO

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LAVENDER

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIME

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.MAROON

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.ORANGE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.ORCHID

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.PINK

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.PLUM

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.RED

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.ROSE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.TAN

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.TEAL

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.VIOLET

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.WHITE

index - Static variable in class org.apache.poi.hssf.util.HSSFColor.YELLOW

Index - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function INDEX
Index() - Constructor for class org.apache.poi.ss.formula.functions.Index

index - Variable in enum org.apache.poi.ss.usermodel.IndexedColors

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLUE

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_RED

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.PINK

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.PLUM

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.TEAL

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.VIOLET

index2 - Static variable in class org.apache.poi.hssf.util.HSSFColor.YELLOW

IndexedColors - Enum in org.apache.poi.ss.usermodel
A deprecated indexing scheme for colours that is still required for some records, and for backwards compatibility with OLE2 formats.
IndexedUDFFinder - Class in org.apache.poi.xssf.model
A UDFFinder that can retrieve functions both by name and by fake index.
IndexedUDFFinder(UDFFinder...) - Constructor for class org.apache.poi.xssf.model.IndexedUDFFinder

indexOf(int) - Method in class org.apache.poi.util.IntList
Returns the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element.
indexOf(short) - Method in class org.apache.poi.util.ShortList
Returns the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element.
IndexRecord - Class in org.apache.poi.hssf.record
Title: Index Record (0x020B)
Description: Occurs right after BOF, tells you where the DBCELL records are for a sheet Important for locating cells
NOT USED IN THIS RELEASE REFERENCE: PG 323 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

IndexRecord() - Constructor for class org.apache.poi.hssf.record.IndexRecord

IndexRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.IndexRecord

Indirect - Class in org.apache.poi.ss.formula.functions
Implementation for Excel function INDIRECT
INDIRECT() returns the cell or area reference denoted by the text argument.
Syntax:
INDIRECT(ref_text,isA1Style)
ref_text a string representation of the desired reference as it would normally be written in a cell formula.
isA1Style (default TRUE) specifies whether the ref_text should be interpreted as A1-style or R1C1-style.
INET_MAIL_OVERRIDE_CHARSET - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INET_MAIL_OVERRIDE_FORMAT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INFO - Static variable in class org.apache.poi.ss.usermodel.DataValidation.ErrorStyle
INFO style
INFO - Static variable in class org.apache.poi.util.POILogger

inheritFromThemeAsRequired(XSSFColor) - Method in class org.apache.poi.xssf.model.ThemesTable
If the colour is based on a theme, then inherit information (currently just colours) from it as required.
init() - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
parse the record data and initialize styles
initAll() - Method in class org.apache.poi.hwpf.usermodel.Range
loads all of the list indexes.
INITIAL_CAPACITY - Static variable in class org.apache.poi.hssf.usermodel.HSSFRow

INITIAL_CAPACITY - Static variable in class org.apache.poi.hssf.usermodel.HSSFSheet
Used for compile-time optimization.
INITIAL_CAPACITY - Static variable in class org.apache.poi.hssf.usermodel.HSSFWorkbook
used for compile-time performance/memory optimization.
INITIAL_DETAILS_PANE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

initialize(String) - Method in class org.apache.poi.util.CommonsLogger

initialize(String) - Method in class org.apache.poi.util.NullLogger

initialize(String) - Method in class org.apache.poi.util.POILogger

initialize(String) - Method in class org.apache.poi.util.SystemOutLogger

INITIALS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

initTable() - Method in class org.apache.poi.hslf.model.Table

initTextRun() - Method in class org.apache.poi.hslf.model.TextShape

insert(int, int, SprmBuffer) - Method in class org.apache.poi.hwpf.model.CHPBinTable

insert(int, int, SprmBuffer) - Method in class org.apache.poi.hwpf.model.PAPBinTable

insertAfter(String) - Method in class org.apache.poi.hwpf.usermodel.Range
Inserts text onto the end of this range
insertAfter(String, CharacterProperties) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. User code should not work with CharacterProperties
insertAfter(ParagraphProperties, int) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Use code shall not work with ParagraphProperties
insertAfter(ParagraphProperties, int, String) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Use code shall not work with ParagraphProperties
insertAfter(ParagraphProperties, int, int, int) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Use code shall not work with ParagraphProperties
insertBefore(String) - Method in class org.apache.poi.hwpf.usermodel.Range
Inserts text into the front of this range.
insertBefore(String, CharacterProperties) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. User code should not work with CharacterProperties
insertBefore(ParagraphProperties, int) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Use code shall not work with ParagraphProperties
insertBefore(ParagraphProperties, int, String) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Use code shall not work with ParagraphProperties
insertBefore(TableProperties, int) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Use code shall not work with TableProperties. Use Range.insertTableBefore(short, int) instead
insertBefore(ParagraphProperties, int, int, int) - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Use code shall not work with ParagraphProperties
insertCell(CellValueRecordInterface) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

insertCell(CellValueRecordInterface) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

insertChartRecord() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Test only.
insertChartRecords(List<Record>) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

insertColumn(ColumnInfoRecord) - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate
Inserts a column into the aggregate (at the end of the list).
insertNewParagraph(XmlCursor) - Method in interface org.apache.poi.xwpf.usermodel.IBody
inserts a new paragraph at position of the cursor
insertNewParagraph(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Add a new paragraph at position of the cursor.
insertNewParagraph(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
add a new paragraph at position of the cursor
insertNewParagraph(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
add a new paragraph at position of the cursor
insertNewParagraph(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
add a new paragraph at position of the cursor
insertNewRun(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
insert a new Run in RunArray
insertNewTableRow(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
inserts a new tablerow
insertNewTbl(XmlCursor) - Method in interface org.apache.poi.xwpf.usermodel.IBody
inserts a new Table at the cursor position.
insertNewTbl(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

insertNewTbl(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

insertNewTbl(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

insertNewTbl(XmlCursor) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

insertRow(RowRecord) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

insertSST() - Method in class org.apache.poi.hssf.model.InternalWorkbook
use this function to add a Shared String Table to an existing sheet (say generated by a different java api) without an sst....
insertTable(int, XWPFTable) - Method in interface org.apache.poi.xwpf.usermodel.IBody
inserts a new Table at position pos
insertTable(int, XWPFTable) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
inserts an existing XWPFTable to the arrays bodyElements and tables
insertTable(int, XWPFTable) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote
inserts an existing XWPFTable to the arrays bodyElements and tables
insertTable(int, XWPFTable) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
inserts an existing XWPFTable to the arrays bodyElements and tables
insertTable(int, XWPFTable) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
inserts an existing XWPFTable to the arrays bodyElements and tables
insertTableBefore(short, int) - Method in class org.apache.poi.hwpf.usermodel.Range
Inserts a simple table into the beginning of this range.
INSIDE - Static variable in class org.apache.poi.hssf.record.cf.CellRangeUtil
first range is within the second range
inspectViewable(Object, boolean, int, String) - Static method in class org.apache.poi.poifs.dev.POIFSViewEngine
Inspect an object that may be viewable, and drill down if told to
instance - Static variable in class org.apache.poi.hssf.record.EOFRecord

instance - Static variable in class org.apache.poi.hssf.record.InterfaceEndRecord

instance - Static variable in class org.apache.poi.hwpf.model.PropertyNode.EndComparator

instance - Static variable in class org.apache.poi.hwpf.model.PropertyNode.StartComparator

instance - Static variable in class org.apache.poi.ss.formula.atp.AnalysisToolPak

instance - Variable in class org.apache.poi.ss.formula.atp.DateParser

instance - Static variable in class org.apache.poi.ss.formula.atp.WorkdayCalculator

instance - Static variable in class org.apache.poi.ss.formula.eval.BlankEval

INSTANCE - Static variable in class org.apache.poi.ss.formula.eval.BlankEval
Deprecated. (Nov 2009) use BlankEval.instance
instance - Static variable in class org.apache.poi.ss.formula.eval.ConcatEval

instance - Static variable in class org.apache.poi.ss.formula.eval.IntersectionEval

instance - Static variable in class org.apache.poi.ss.formula.eval.MissingArgEval

instance - Static variable in class org.apache.poi.ss.formula.eval.PercentEval

instance - Static variable in class org.apache.poi.ss.formula.eval.RangeEval

instance - Static variable in class org.apache.poi.ss.formula.eval.UnaryMinusEval

instance - Static variable in class org.apache.poi.ss.formula.eval.UnaryPlusEval

instance - Static variable in class org.apache.poi.ss.formula.functions.DateFunc

instance - Static variable in class org.apache.poi.ss.formula.functions.Indirect

instance - Static variable in class org.apache.poi.ss.formula.functions.Sumifs

instance - Static variable in class org.apache.poi.ss.formula.ptg.AddPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.ConcatPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.DividePtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.EqualPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.GreaterEqualPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.GreaterThanPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.IntersectionPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.LessEqualPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.LessThanPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.MissingArgPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.MultiplyPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.NotEqualPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.ParenthesisPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.PercentPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.PowerPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.RangePtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.SubtractPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.UnaryMinusPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.UnaryPlusPtg

instance - Static variable in class org.apache.poi.ss.formula.ptg.UnionPtg

INSTANCE_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INT - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

INT_SIZE - Static variable in interface org.apache.poi.util.LittleEndianConsts

INTEGER - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
Integer ('Whole number') type
IntegerField - Class in org.apache.poi.util
representation of an integer (32-bit) field at a fixed location within a byte array
IntegerField(int) - Constructor for class org.apache.poi.util.IntegerField
construct the IntegerField with its offset into its containing byte array
IntegerField(int, int) - Constructor for class org.apache.poi.util.IntegerField
construct the IntegerField with its offset into its containing byte array and initialize its value
IntegerField(int, byte[]) - Constructor for class org.apache.poi.util.IntegerField
Construct the IntegerField with its offset into its containing byte array and initialize its value from its byte array
IntegerField(int, int, byte[]) - Constructor for class org.apache.poi.util.IntegerField
construct the IntegerField with its offset into its containing byte array, initialize its value, and write the value to a byte array
InteractiveInfo - Class in org.apache.poi.hslf.record
This class represents the metadata of a link in a slide/notes/etc.
InteractiveInfo(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.InteractiveInfo
Set things up, and find our more interesting children
InteractiveInfo() - Constructor for class org.apache.poi.hslf.record.InteractiveInfo
Create a new InteractiveInfo, with blank fields
InteractiveInfo - Static variable in class org.apache.poi.hslf.record.RecordTypes

InteractiveInfoAtom - Class in org.apache.poi.hslf.record
Tne atom that holds metadata on Links in the document.
InteractiveInfoAtom() - Constructor for class org.apache.poi.hslf.record.InteractiveInfoAtom
Constructs a brand new link related atom record.
InteractiveInfoAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.InteractiveInfoAtom
Constructs the link related atom record from its source data.
InteractiveInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

InterfaceEndRecord - Class in org.apache.poi.hssf.record
Title: Interface End Record (0x00E2)
InterfaceHdrRecord - Class in org.apache.poi.hssf.record
Title: Interface Header Record (0x00E1)
InterfaceHdrRecord(int) - Constructor for class org.apache.poi.hssf.record.InterfaceHdrRecord

InterfaceHdrRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.InterfaceHdrRecord

Internal - Annotation Type in org.apache.poi.util
Program elements annotated @Internal are intended for POI internal use only.
InternalSheet - Class in org.apache.poi.hssf.model
Low level model implementation of a Sheet (one workbook contains many sheets) This file contains the low level binary records starting at the sheets BOF and ending with the sheets EOF.
InternalWorkbook - Class in org.apache.poi.hssf.model
Low level model implementation of a Workbook.
INTERNET_APPROVED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_ARTICLE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_CONTROL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_CPID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_DISTRIBUTION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_FOLLOWUP_TO - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_LINES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_MESSAGE_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_NEWSGROUPS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_NNTP_PATH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_ORGANIZATION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_PRECEDENCE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

INTERNET_REFERENCES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

intersect(CellRangeAddress, CellRangeAddress) - Static method in class org.apache.poi.hssf.record.cf.CellRangeUtil
Intersect this range with the specified range.
IntersectionEval - Class in org.apache.poi.ss.formula.eval

IntersectionPtg - Class in org.apache.poi.ss.formula.ptg

IntList - Class in org.apache.poi.util
A List of int's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows: if possible, operations designated 'optional' in the List interface are attempted wherever the List interface refers to an Object, substitute int wherever the List interface refers to a Collection or List, substitute IntList the mimicry is not perfect, however: operations involving Iterators or ListIterators are not supported remove(Object) becomes removeValue to distinguish it from remove(int index) subList is not supported
IntList() - Constructor for class org.apache.poi.util.IntList
create an IntList of default size
IntList(int) - Constructor for class org.apache.poi.util.IntList

IntList(IntList) - Constructor for class org.apache.poi.util.IntList
create a copy of an existing IntList
IntList(int, int) - Constructor for class org.apache.poi.util.IntList
create an IntList with a predefined initial size
IntMapper<T> - Class in org.apache.poi.util
A List of objects that are indexed AND keyed by an int; also allows for getting the index of a value in the list
IntMapper() - Constructor for class org.apache.poi.util.IntMapper
create an IntMapper of default size
IntMapper(int) - Constructor for class org.apache.poi.util.IntMapper

IntPtg - Class in org.apache.poi.ss.formula.ptg
Integer (unsigned short integer) Stores an unsigned short value (java int) in a formula
IntPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.IntPtg

IntPtg(int) - Constructor for class org.apache.poi.ss.formula.ptg.IntPtg

intToHex(int) - Static method in class org.apache.poi.util.HexDump

InvalidFormatException - Exception in org.apache.poi.openxml4j.exceptions

InvalidFormatException(String) - Constructor for exception org.apache.poi.openxml4j.exceptions.InvalidFormatException

InvalidOperationException - Exception in org.apache.poi.openxml4j.exceptions
Throw when an invalid operation is done.
InvalidOperationException(String) - Constructor for exception org.apache.poi.openxml4j.exceptions.InvalidOperationException

InvalidRecordFormatException - Exception in org.apache.poi.hslf.exceptions
This exception is thrown when we try to create a record, and the underlying data just doesn't match up
InvalidRecordFormatException(String) - Constructor for exception org.apache.poi.hslf.exceptions.InvalidRecordFormatException

invalidRef() - Static method in exception org.apache.poi.ss.formula.eval.EvaluationException
#REF! - Illegal or deleted cell reference
invalidValue() - Static method in exception org.apache.poi.ss.formula.eval.EvaluationException
#VALUE! - Wrong type of operand
IOUtils - Class in org.apache.poi.util

IPM_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_OUTBOX_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_OUTBOX_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_RETURN_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_SENTMAIL_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_SENTMAIL_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_SUBTREE_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_SUBTREE_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_WASTEBASKET_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

IPM_WASTEBASKET_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Irr - Class in org.apache.poi.ss.formula.functions
Calculates the internal rate of return.
Irr() - Constructor for class org.apache.poi.ss.formula.functions.Irr

irr(double[]) - Static method in class org.apache.poi.ss.formula.functions.Irr
Computes the internal rate of return using an estimated irr of 10 percent.
irr(double[], double) - Static method in class org.apache.poi.ss.formula.functions.Irr
Calculates IRR using the Newton-Raphson Method.
IRREGULAR_SEAL_1 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

IRREGULAR_SEAL_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

IrregularSeal1 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

IrregularSeal2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

is - Variable in class org.apache.poi.util.BlockingInputStream

isActive() - Method in class org.apache.poi.hssf.record.WindowTwoRecord
is the sheet currently displayed in the window
isActive() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

isADateFormat(int, String) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given a format ID and its format String, will check to see if the format represents a date format or not.
isAddInFunctions() - Method in class org.apache.poi.hssf.record.SupBookRecord

isAdjacentBefore(ColumnInfoRecord) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

isAllSet(int) - Method in class org.apache.poi.util.BitField
Are all of the bits set or not? This is a stricter test than isSet, in that all of the bits in a multi-bit set must be set for this method to return true
isAlwaysCalc() - Method in class org.apache.poi.hssf.record.FormulaRecord

isAlwaysCalc() - Method in class org.apache.poi.hssf.record.TableRecord

isAlwaysRecalculate() - Method in class org.apache.poi.hssf.record.ArrayRecord

isAnAtom() - Method in class org.apache.poi.hslf.record.Record
Is this record type an Atom record (only has data), or is it a non-Atom record (has other records)?
isAnAtom() - Method in class org.apache.poi.hslf.record.RecordAtom
We are an atom
isAnAtom() - Method in class org.apache.poi.hslf.record.RecordContainer
We're not an atom
isATPFunction(String) - Static method in class org.apache.poi.ss.formula.atp.AnalysisToolPak

isAuto() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
automatic format
isAuto() - Method in class org.apache.poi.xssf.usermodel.XSSFColor
A boolean value indicating the ctColor is automatic and system ctColor dependent.
isAutoBackground() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isAutoColor() - Method in class org.apache.poi.hssf.record.chart.TextRecord
true = automaticly selected colour, false = user-selected
isAutofill() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
whether object uses an automatic fill style
isAutoFilterLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isAutoGeneratedText() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isAutoHyphenated() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isAutoHyphenated() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isAutoLabelDeleted() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isAutoline() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
whether object uses an automatic line style
isAutomatic() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
automatic formatting
isAutomaticCategoryCrossing() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
category crossing point is automatically selected
isAutomaticLink() - Method in class org.apache.poi.hssf.record.ExternalNameRecord
For OLE and DDE, links can be either 'automatic' or 'manual'
isAutomaticMajor() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
automatic major unit selected
isAutomaticMaximum() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
automatic maximum value selected
isAutomaticMinimum() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
automatic minimum value selected
isAutomaticMinor() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
automatic minor unit selected
isAutoPlay() - Method in class org.apache.poi.hslf.model.MovieShape

isAutoPlotArea() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
??
isAutoPosition() - Method in class org.apache.poi.hssf.record.chart.FrameRecord
excel calculates the position automatically
isAutoPosition() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
automatic positioning (1=docked)
isAutorotate() - Method in class org.apache.poi.hssf.record.chart.TickRecord
automatically rotate the text
isAutoSeries() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
excel 5 only (true)
isAutoSize() - Method in class org.apache.poi.hssf.record.chart.FrameRecord
excel calculates the size automatically if true
isAutoTextBackground() - Method in class org.apache.poi.hssf.record.chart.TickRecord
use the quote unquote automatic color for text background
isAutoTextColor() - Method in class org.apache.poi.hssf.record.chart.TickRecord
use the quote unquote automatic color for text
isAutoXPositioning() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
position of legend on the x axis is automatic
isAutoYPositioning() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
position of legend on the y axis is automatic
isBackward() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isBackward() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isBackward() - Method in class org.apache.poi.hwpf.usermodel.TableCell

isBackwardDiagonalOn() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting

isBackwardDiagonalOn() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.ControlPtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.IntersectionPtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.OperandPtg
All Operand Ptgs are classified ('relative', 'value', 'array')
isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.Ptg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.RangePtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.ScalarConstantPtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.UnionPtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.UnknownPtg

isBaseToken() - Method in class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
All Operator Ptgs are base tokens (i.e.
isBeginRecord(int) - Static method in class org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

isBiff5BookStreamPresent() - Method in class org.apache.poi.hssf.record.DSFRecord

ISBLANK - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction

isBlipId() - Method in class org.apache.poi.ddf.EscherProperty

isBold() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is the text bold?
isBold() - Method in class org.apache.poi.hssf.record.cf.FontFormatting
get whether the font weight is set to bold or not
isBold() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
get whether the font weight is set to bold or not
isBold() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isBold() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isBold() - Method in interface org.apache.poi.ss.usermodel.FontFormatting
get whether the font weight is set to bold or not
isBold() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

isBold() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
get whether the font weight is set to bold or not
isBold() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document
isBoolean() - Method in class org.apache.poi.hssf.record.BoolErrRecord
Indicates whether the call holds a boolean value
isBorder() - Method in class org.apache.poi.hssf.record.chart.DatRecord
data table has a border
isBottomBorderModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isBottomLeftTopRightBorderModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isBuiltin() - Method in class org.apache.poi.hssf.record.StyleRecord

isBuiltInFunctionName(String) - Static method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
Used to detect whether a function name found in a formula is one of the standard excel functions
isBuiltInName() - Method in class org.apache.poi.hssf.record.ExternalNameRecord
Convenience Function to determine if the name is a built-in name
isBuiltInName() - Method in class org.apache.poi.hssf.record.NameRecord
Convenience Function to determine if the name is a built-in name
isBullet() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns whether this rich text run has bullets
isBullet() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Returns whether this paragraph has bullets
isBulletHard() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Returns whether this rich text run has bullets
isCalcOnLoad() - Method in class org.apache.poi.hssf.record.FormulaRecord

isCalculateOnOpen() - Method in class org.apache.poi.hssf.record.ArrayRecord

isCantSplitRow() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
Return true if the "can't split row" value is true.
isCapitalized() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isCapitalized() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isCellDateFormatted(Cell) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Check if a cell contains a date Since dates are stored internally in Excel as double values we infer it is a date if it is formatted as such.
isCellFinal(int, int, int) - Method in interface org.apache.poi.ss.formula.IStabilityClassifier
Checks if a cell's value(/formula) is fixed - in other words - not expected to be modified between calls to the evaluator.
isCellInternalDateFormatted(Cell) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Check if a cell contains a date, checking only for internal excel date formats.
isChartTypeManuallyFormatted() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Has the chart type been manually formatted?
isColAbsolute() - Method in class org.apache.poi.ss.util.CellReference

isColDeleted() - Method in class org.apache.poi.hssf.record.TableRecord

isColRelative() - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

isColumn() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

isColumn() - Method in interface org.apache.poi.ss.formula.TwoDEval

isColumnBroken(int) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Queries if the specified column has a page break
isColumnBroken(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Determines if there is a page break at the indicated column
isColumnBroken(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Determines if there is a page break at the indicated column
isColumnBroken(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Determines if there is a page break at the indicated column
isColumnBroken(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Determines if there is a page break at the indicated column
isColumnHidden(int) - Method in class org.apache.poi.hssf.model.InternalSheet
Get the hidden property for a given column.
isColumnHidden(short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.isColumnHidden(int)
isColumnHidden(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Get the hidden state for a given column.
isColumnHidden(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Get the hidden state for a given column
isColumnHidden(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Get the hidden state for a given column
isColumnHidden(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get the hidden state for a given column.
isColumnsEvenlySpaced() - Method in class org.apache.poi.hwpf.usermodel.Section

isColumnWithnRange(String, SpreadsheetVersion) - Static method in class org.apache.poi.ss.util.CellReference

isCommandName() - Method in class org.apache.poi.hssf.record.NameRecord

isCompatibleValue(Object) - Method in class org.apache.poi.xslf.usermodel.XSLFRenderingHint

isComplex() - Method in class org.apache.poi.ddf.EscherProperty

isComplex() - Method in class org.apache.poi.hwpf.model.PropertyModifier

isComplexFunction() - Method in class org.apache.poi.hssf.record.NameRecord

isComponentRecord(int) - Static method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

isComponentRecord(int) - Static method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

isCompressed() - Method in class org.apache.poi.ddf.EscherMetafileBlip

isCompressed() - Method in class org.apache.poi.ddf.EscherPictBlip

isCompressed() - Method in class org.apache.poi.hslf.record.ExOleObjStg

isContainerRecord() - Method in class org.apache.poi.ddf.EscherRecord
Determine whether this is a container record by inspecting the option field.
isContentTypeRegister(String) - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Check if the specified content type is already register.
isContiguous(String) - Static method in class org.apache.poi.ss.util.AreaReference
Is the reference for a contiguous (i.e.
isCrossCategoryAxisAtMaximum() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
category axis to cross at maximum value
isCrossesFarRight() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
axis crosses at the far right
isCurrentSheet() - Method in class org.apache.poi.hssf.record.HeaderFooterRecord

isCustomNumberFormat() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
true if this object has a custom number format
isData() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Does the picture offset represent picture or binary data? If it's set, then the picture offset refers to a NilPICFAndBinData structure, otherwise to a PICFAndOfficeArtData
isDataTable() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
1 if chart contains data table
isDate1904() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Gets a boolean value that indicates whether the date systems used in the workbook starts in 1904.
isDateTimeVisible() - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the date is displayed in the footer.
isDefaultBase() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
use the default base unit
isDefaultCross() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
use the default crossing point
isDefaultDateSettings() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
use default date setttings for this axis
isDefaultMajor() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
use the default major unit
isDefaultMaximum() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
use the default maximum category
isDefaultMinimum() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
use the default minimum category
isDefaultMinorUnit() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
use the default minor unit
isDefaultPlotDimensions() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Indicates that the default area dimensions should be used.
isDeleteColumnsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isDeleted() - Method in class org.apache.poi.hssf.usermodel.HSSFName

isDeleted() - Method in class org.apache.poi.openxml4j.opc.PackagePart

isDeleted() - Method in interface org.apache.poi.ss.usermodel.Name
Checks if this name points to a cell that no longer exists
isDeleted() - Method in class org.apache.poi.xssf.usermodel.XSSFName

isDeleteOK() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
extensions use this method to verify internal rules regarding deletion of the underlying store.
isDeleteOK() - Method in class org.apache.poi.poifs.filesystem.DocumentNode
extensions use this method to verify internal rules regarding deletion of the underlying store.
isDeleteOK() - Method in class org.apache.poi.poifs.filesystem.EntryNode
extensions use this method to verify internal rules regarding deletion of the underlying store.
isDeleteRowsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isDirectory() - Method in class org.apache.poi.poifs.property.DirectoryProperty

isDirectory() - Method in class org.apache.poi.poifs.property.DocumentProperty

isDirectory() - Method in class org.apache.poi.poifs.property.Property

isDirectoryEntry() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
is this a DirectoryEntry?
isDirectoryEntry() - Method in interface org.apache.poi.poifs.filesystem.Entry
is this a DirectoryEntry?
isDirectoryEntry() - Method in class org.apache.poi.poifs.filesystem.EntryNode
is this a DirectoryEntry?
isDirectoryEntry() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

isDirty - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Flag if a modification is done to the document.
isDisplayAsPercentage() - Method in class org.apache.poi.hssf.record.chart.AreaRecord
results displayed as percentages
isDisplayAsPercentage() - Method in class org.apache.poi.hssf.record.chart.BarRecord
display chart values as a percentage
isDisplayFormulas() - Method in class org.apache.poi.hssf.model.InternalSheet
Returns if formulas are displayed.
isDisplayFormulas() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns if formulas are displayed.
isDisplayFormulas() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns if formulas are displayed
isDisplayFormulas() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns if formulas are displayed
isDisplayFormulas() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Gets the flag indicating whether this sheet should display formulas.
isDisplayGridlines() - Method in class org.apache.poi.hssf.model.InternalSheet

isDisplayGridlines() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns if gridlines are displayed.
isDisplayGridlines() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns if gridlines are displayed
isDisplayGridlines() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns if gridlines are displayed
isDisplayGridlines() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.
isDisplayRowColHeadings() - Method in class org.apache.poi.hssf.model.InternalSheet
Returns if RowColHeadings are displayed.
isDisplayRowColHeadings() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns if RowColHeadings are displayed.
isDisplayRowColHeadings() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns if RowColHeadings are displayed.
isDisplayRowColHeadings() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns if RowColHeadings are displayed.
isDisplayRowColHeadings() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Gets the flag indicating whether this sheet should display row and column headings.
isDisplayZeros() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
isDisplayZeros() - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
isDisplayZeros() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
isDisplayZeros() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
ISDN_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

isDocumentEntry() - Method in class org.apache.poi.poifs.filesystem.DocumentNode
is this a DocumentEntry?
isDocumentEntry() - Method in interface org.apache.poi.poifs.filesystem.Entry
is this a DocumentEntry?
isDocumentEntry() - Method in class org.apache.poi.poifs.filesystem.EntryNode
is this a DocumentEntry?
isDocumentEntry() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

isDocumentLink() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Based on the link options, is this a document?
isDocumentSummaryInformation() - Method in class org.apache.poi.hpsf.PropertySet
Checks whether this PropertySet is a Document Summary Information.
isDocumentSummaryInformation() - Method in class org.apache.poi.hpsf.SpecialPropertySet

isDoNotSizeWithWindow() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Do not size the chart when the window changes size
isDoubleStrikeThrough() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isDoubleStrikeThrough() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isDrawTicks() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
draw tick marks
isEmbeddedCellMark() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isEmbossed() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is this text embossed?
isEmbossed() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isEmbossed() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isEmpty() - Method in class org.apache.poi.hssf.record.PageBreakRecord

isEmpty() - Method in class org.apache.poi.hssf.record.RowRecord

isEmpty() - Method in class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

isEmpty() - Method in class org.apache.poi.hwpf.model.Colorref

isEmpty() - Method in class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

isEmpty() - Method in class org.apache.poi.hwpf.model.Hyphenation

isEmpty() - Method in class org.apache.poi.hwpf.usermodel.BorderCode

isEmpty() - Method in class org.apache.poi.hwpf.usermodel.DateAndTime

isEmpty() - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

isEmpty() - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

isEmpty() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor

isEmpty() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

isEmpty() - Method in class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

isEmpty() - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
is this DirectoryEntry empty?
isEmpty() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
is this DirectoryEntry empty?
isEmpty() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

isEmpty() - Method in class org.apache.poi.util.IntList
Returns true if this list contains no elements.
isEmpty() - Method in class org.apache.poi.util.ShortList
Returns true if this list contains no elements.
isEmpty() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph

isEmptyStyle(CellStyle) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter
Returns false if cell style by itself (without text, i.e.
isEnforcedCommentsProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is comments (w:edit="comments")

sample snippet from settings.xml
isEnforcedFillingFormsProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is forms (w:edit="forms")

sample snippet from settings.xml
isEnforcedReadonlyProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is readOnly (w:edit="readOnly")

sample snippet from settings.xml
isEnforcedTrackedChangesProtection() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is trackedChanges (w:edit="trackedChanges")

sample snippet from settings.xml
isEnforcedUpdateFields() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

isEnforcedWith(STDocProtect.Enum) - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings
Verifies the documentProtection tag inside settings.xml file
if the protection is enforced (w:enforcement="1")
and if the kind of protection equals to passed (STDocProtect.Enum editValue)

sample snippet from settings.xml
isError() - Method in class org.apache.poi.hssf.record.BoolErrRecord
Indicates whether the call holds an error value
ISERROR - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction

isEscapementTypeModified() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isEscapementTypeModified() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isExplicitList() - Method in class org.apache.poi.hssf.usermodel.DVConstraint
Convenience method
isExternalFunction() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
external functions get some special processing
isExternalRef() - Method in class org.apache.poi.hssf.record.DConRefRecord
Checks if the data source in this reference record is external to this sheet or internal.
isExternalReferences() - Method in class org.apache.poi.hssf.record.SupBookRecord

isF97LidsSet() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether sprmCRgLid0_80 and sprmCRgLid1_80 were applied, as appropriate, to this paragraph or character style for compatibility with applications that do not support sprmCRgLid0, sprmCRgLid1, and sprmCFNoProof
isFAdjusted() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word
isFalse() - Method in class org.apache.poi.ddf.EscherBoolProperty
Whether this boolean property is false
isFAnchorLock() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType

isFAutofit() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When set to 1, AutoFit this table
isFAutoHyphen() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFAutoNum() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A bit that specifies whether the list that this LSTF represents is used for the AUTONUMOUT, AUTONUMLGL, and AUTONUM fields (see AUTONUMOUT, AUTONUMLGL, and AUTONUM in flt)
isFAutoRedef() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
number of UPXs (and UPEs)
isFAutoVersions() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFBackup() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFBackward() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType

isFBackward() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
For a vertical table cell, text flow is bottom to top when 1 and is bottom to top when 0
isFBelowText() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType

isFBestFit() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
When == 1, do best fit from the selected table look
isFBiDi() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Complex Scripts right-to-left text that requires special processing to display and process (character reordering; contextual shaping; display of combining characters and diacritics; specialized justification rules; cursor positioning)
isFBold() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Text is bold
isFBoldBi() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Complex Scripts text is bold
isFBorders() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
When == 1, use the border properties from the selected table look
isFCaps() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Displayed with caps
isFCellFitText() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Fit text in cell
isFCellSpacing() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: When set to 1 cell spacing is allowed
isFChsDiff() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Pre-Unicode files, char's char set different from FIB char set
isFCol() - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
When 1, this bookmark marks a range of columns in a table specified by (bkf.itcFirst, bkf.itcLim)
isFColor() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
When == 1, use the color from the selected table look
isFComplex() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies that the last save operation that was performed on this document was an incremental save operation
isFComplexScripts() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Complex Scripts text that requires special processing to display and process
isFConverted() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A bit that specifies whether the nfc of this LVLF structure was previously a temporary value used for bidirectional compatibility that was converted into a standard MSONFC
isFConvMailMergeEsc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFCopyLang() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
If f97LidsSet is 1, this value specifies whether the applied compatibility sprmCRgLid0_80 or sprmCRgLid1_80 specified an actual language or a special LID value (0x0400) signifying that no proofing is needed for the text.
isFData() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
chp.fcPic points to an FFDATA, the data structure binary data used by Word to describe a form field.
isFDfltTrueType() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFDiffer() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Ignored for saved file
isFDispFormFldSel() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFDot() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether this is a document template
isFDStrike() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Displayed with double strikethrough
isFEmbedFonts() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFEmboss() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Text is embossed
isFEmptySpecial() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated. This field should not be used according to specification
isFEncrypted() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether the document is encrypted or obfuscated as specified in Encryption and Obfuscation
isFetchingFromMaster - Variable in class org.apache.poi.xslf.model.CharacterPropertyFetcher

isFExactCWords() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFExtChar() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value MUST be 1
isFFacingPages() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFFarEast() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether the installation language of the application that created the document was an East Asian language
isFFirstMerged() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, cell is first cell of a range of cells that have been merged.
isFFirstRow() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: first row
isFFitText() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, make the text fit the table cell
isFFldVanish() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used internally by Word
isFFont() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
When == 1, use the font from the selected table look
isFForcePageSizePag() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFFormatting() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
A bit that specifies whether lvl is an LVL that overrides the corresponding LVL
isFFormNoFields() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFGlsy() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether this is a document that contains only AutoText items
isFGramAllClean() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFGramAllDone() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFHasOriginalStyle() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Specifies whether the style is revision-marked.
isFHasOriginalStyle() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
This value MUST be 1 and MUST be ignored
isFHasPic() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
When set to 0, there SHOULD be no pictures in the document
isFHasSep() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
==1 when field has a field separator
isFHasUpe() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
This bit is undefined and MUST be ignored
isFHaveVersions() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFHdr() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
1 in the undo doc when shape is from the header doc, 0 otherwise (undefined when not in the undo doc)
isFHdrRows() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
When == 1, apply properties from the selected table look to the header rows in the table
isFHidden() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether this style is not shown in the application UI
isFHideLastVersion() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFHighlight() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When 1, characters are highlighted with color specified by chp.icoHighlight
isFHtmlBuiltInBullet() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
A built-in HTML bullet
isFHtmlChecked() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Checked
isFHtmlDoc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFHtmlFirstLineMismatch() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
First line indent mismatch
isFHtmlHangingIndentBeneathNumber() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
The hanging indent falls beneath the number (need plain text)
isFHtmlListTextNotSharpDot() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
The list text is not "#."
isFHtmlNotPeriod() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Something other than a period is used
isFHtmlTabLeftIndentMismatch() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
The list tab and the dxaLeft don't match (need table?)
isFHtmlUnsupported() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
The numbering sequence or format is unsupported (includes tab & size)
isFHybrid() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A bit that specifies whether the list this LSTF defines is a hybrid list
isFHyphCapitals() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFileLink() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Based on the link options, is this a file?
isFilled() - Method in class org.apache.poi.xslf.model.geom.Path

isFImprint() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Text is engraved
isFIncludeFooter() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFIncludeHeader() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFIndentSav() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A bit that specifies whether the level indented the text it was applied to and that the indent needs to be removed when numbering is removed.
isFInternalUse() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
This bit is undefined and MUST be ignored
isFInvalAutofit() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, TAP is still valid, but autofit properties aren't
isFInvalHeight() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97, for any paragraphs having this paragraph style, MUST be ignored.
isFirstCell(int, int) - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

isFirstColRelative() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

isFirstMerged() - Method in class org.apache.poi.hwpf.usermodel.TableCell

isFirstRowRelative() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

isFirstVerticallyMerged() - Method in class org.apache.poi.hwpf.usermodel.TableCell

isFItalic() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Italic
isFItalicBi() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Complex Scripts text is italics
isFKeepFollow() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When set to 1, keep this row with the following row
isFKumimoji() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
combine characters
isFLabelDoc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFLastRow() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: last row
isFLastRow() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
When == 1, apply properties from the selected table look to the last row in the table
isFldVanished() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isFldVanished() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isFLegal() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A bit that specifies whether this level overrides the nfc of all inherited level numbers.
isFLinkStyles() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFLoadOverride() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether to override the language information and font that are specified in the paragraph style at istd 0 (the normal style) with the defaults that are appropriate for the installation language of the application
isFLoadOverridePage() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether to override the section properties for page size, orientation, and margins with the defaults that are appropriate for the installation language of the application
isFLockAtn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFLocked() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
==1 when field is locked from recalculation
isFLocked() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether this style is prevented from being applied by using the application UI
isFLockRev() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFLowerCase() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Character is displayed in lower case.
isFLSFitText() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
fit text
isFMac() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated. This field should not be used according to specification
isFMacChs() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
fTrue if char's are Macintosh char set
isFMapPrintTextColor() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFMassCopy() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
This bit is undefined and MUST be ignored
isFMerged() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, cell has been merged with preceding cell
isFMinFontSizePag() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFMirrorMargins() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFMWSmallCaps() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFNested() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
==1 when field is nested within another field
isFNeverBeenAutofit() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table has never been autofit
isFNoColumnBalance() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFNoHtmlExport() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
This value MUST be 0 and MUST be ignored
isFNoLeading() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFNoRestart() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A bit that specifies whether the number sequence of the level does not restart after a level is encountered that is more significant than the level to which this LVLF corresponds
isFNoSpaceRaiseLower() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFNoTabForInd() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFNotPageView() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: when set to 1 we are not in Page View
isFNoWrap() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, do not allow text to wrap in the table cell
isFObfuscated() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
If fEncrypted is 1, this bit specifies whether the document is obfuscated by using XOR obfuscation; otherwise, this bit MUST be ignored
isFObj() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Embedded objec
isFOle2() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
chp.lTagObj specifies a particular object in the object stream that specifies the particular OLE object in the stream that should be displayed when the chPicture fSpec character that is tagged with the fOle2 is encountered.
isFOnlyMacPics() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFOnlyWinPics() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFontCancellationModified() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isFontCancellationModified() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isFontOutlineModified() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isFontOutlineModified() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isFontShadowModified() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isFontShadowModified() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isFontStyleModified() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isFontStyleModified() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isFontWeightModified() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isFontWeightModified() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isFooterVisible() - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the footer text is displayed.
isFOrigWordTableRules() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFOrigWordTableRules() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: table combining like Word 5.x for the Macintosh and WinWord 1.x
isFormatCellsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isFormatColumnsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isFormatRowsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isFormatted() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Is this row formatted? Most aren't, but some rows do have whole-row styles.
isFormatted() - Method in interface org.apache.poi.ss.usermodel.Row
Is this row formatted? Most aren't, but some rows do have whole-row styles.
isFormatted() - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Is this row formatted? Most aren't, but some rows do have whole-row styles.
isFormatted() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Is this row formatted? Most aren't, but some rows do have whole-row styles.
isFormatting() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

isFormulaEmpty(String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

isFormulaSame(SharedFormulaRecord) - Method in class org.apache.poi.hssf.record.SharedFormulaRecord

isForwardDiagonalOn() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting

isForwardDiagonalOn() - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

isFOutline() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Outlined
isFOutline() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: row was cached for outline mode
isFPagHidden() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFPagResults() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFPagSupressTopSpacing() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFPersonal() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether this character style was applied to format all message text from one or more users in an e-mail
isFPersonalCompose() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether this character style can be used to automatically format the new message text in a new e-mail
isFPersonalReply() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether this character style can be used to automatically format the new message text when replying to an e-mail
isFPMHMainDoc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFPrintBodyBeforeHdr() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFPrintFormData() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFPrivateResult() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
==1 whenever the result of the field is never to be shown
isFProtEnabled() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFPub() - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
When 1, this indicates that this bookmark is marking the range of a Macintosh Publisher section
isFQFormat() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether this style is shown in the Ribbon Style gallery
isFrame() - Method in class org.apache.poi.hwpf.usermodel.BorderCode
Don't reverse the border.
isFRcaSimple() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
When set, temporarily overrides bx, by, forcing the xaLeft, xaRight, yaTop, and yaBottom fields to all be page relative.
isFReadOnlyRecommended() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether the document author recommended that the document be opened in read-only mode
isFreezePane() - Method in class org.apache.poi.hssf.util.PaneInformation
Returns true if this is a Freeze pane, false if it is a split pane.
isFResultDirty() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
==1 when user has edited or formatted the result.
isFResultEdited() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
==1 when user has inserted text into or deleted text from the result
isFRevMarking() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFRMark() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
text is newly typed since the last time revision marks have been accepted and will be displayed with an underline when revision marked text is to be displayed
isFRMarkDel() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
has been deleted and will be displayed with strikethrough when revision marked text is to be displayed
isFRMPrint() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFRMView() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFRotateFont() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType

isFRotateFont() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, cell has rotated characters (i.e.
isFRotateFontW6() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFRuby() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Phonetic guide
isFSaveFormData() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFScratch() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
spare field for any temporary use, always reset back to zero!
isFSemiHidden() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether this style is not shown in the simplified main styles UI of the application
isFShadeFormData() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFShading() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
When == 1, use the shading properties from the selected table look
isFShadow() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Character is drawn with a shadow
isFShowBreaksInFrames() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFSimpleList() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A bit that, when set to 0x1, specifies that this LSTF represents a simple (one-level) list that has one corresponding LVL (see the fcPlfLst field of FibRgFcLcb97).
isFSmallCaps() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Displayed with small caps
isFSnapBorder() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFSpec() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Character is a Word special character
isFStartAt() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
A bit that specifies whether this LFOLVL overrides the start-at value of the level.
isFStrike() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Displayed with strikethrough
isFSubsetFonts() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFSuppressTopSPacingMac5() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFSupressSpdfAfterPageBreak() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFSupressTopSpacing() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFSwapBordersFacingPgs() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFTentative() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A bit that specifies whether the format of the level is tentative
isFTNY() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Tatenakayoko: Horizontal-in-vertical (range of text in a direction perpendicular to the text flow) is used
isFTNYCompress() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
fit text in line
isFTNYFetchTxm() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
fetch text metrics
isFTransparentMetafiles() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFTruncDxaExpand() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFullColumnRange() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

isFullRowRange() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

isFunctionName() - Method in class org.apache.poi.hssf.record.NameRecord

isFunctionName() - Method in class org.apache.poi.hssf.usermodel.HSSFName
Checks if this name is a function name
isFunctionName() - Method in interface org.apache.poi.ss.formula.EvaluationName

isFunctionName() - Method in interface org.apache.poi.ss.usermodel.Name
Checks if this name is a function name
isFunctionName() - Method in class org.apache.poi.xssf.usermodel.XSSFName
Is the name refers to a user-defined function ?
isFUnhideWhenUsed() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Specifies whether the fSemiHidden property is to be set to 0 when this style is used
isFUsePgsuSettings() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used internally by Word
isFVanish() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
text has hidden format, and is not displayed unless fPagHidden is set in the DOP
isFVert() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, positioned in vertical text flow
isFVertical() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType

isFVertical() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, cell has vertical text flow
isFVertMerge() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, cell is vertically merged with the cell(s) above and/or below.
isFVertRestart() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
When 1, the cell is the first of a set of vertically merged cells.
isFVirusLoadSafe() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFVirusPrompted() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFWarichu() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Two lines in one (text in the group is displayed as two half-height lines within a line)
isFWarichuNoOpenBracket() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Two-lines-in-one uses no open
isFWCFtnEdn() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFWebView() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: Web View is on when set to 1
isFWhichTblStm() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies the Table stream to which the FIB refers.
isFWidowControl() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFWrapToWwd() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: Wrap to window is on when set to 1
isFWrapTrailSpaces() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isFWriteReservation() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Specifies whether the document has a write-reservation password
isFZombieEmbed() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
==1 when result still believes this field is an EMBED or LINK field
isGenerated() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isGridsPrinted() - Method in class org.apache.poi.hssf.model.InternalSheet

isGridsPrinted() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
get whether gridlines are printed.
isHasSep() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

isHasSep() - Method in interface org.apache.poi.hwpf.usermodel.Field

isHeaderVisible() - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the header text is displayed.
isHidden() - Method in class org.apache.poi.hssf.record.BoundSheetRecord
Is the sheet hidden? Different from very hidden
isHidden() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether the cell is hidden or not
isHidden() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

isHidden() - Method in interface org.apache.poi.ss.usermodel.Workbook

isHidden() - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook

isHidden() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

isHiddenName() - Method in class org.apache.poi.hssf.record.NameRecord

isHighlighted() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isHighlighted() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isHoliday(double, double[]) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator

isHorizontal() - Method in class org.apache.poi.hssf.record.chart.BarRecord
true to display horizontal bar charts, false for vertical
isHorizontalBorder() - Method in class org.apache.poi.hssf.record.chart.DatRecord
has a horizontal border
isHorizontallyFlipped() - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

isHorizontallyFlipped() - Method in class org.apache.poi.hssf.usermodel.HSSFChildAnchor

isHorizontallyFlipped() - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

isIconifiedPictureLink() - Method in class org.apache.poi.hssf.record.ExternalNameRecord

isIGutterPos() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isImprinted() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isImprinted() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isInARange(double, double, double) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator

isIndentNotParentAlignment() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether or not to use the alignment in this XF instead of the parent XF.
isIndentNotParentBorder() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether or not to use the border in this XF instead of the parent XF.
isIndentNotParentCellOptions() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether or not to use the locking/hidden in this XF instead of the parent XF.
isIndentNotParentFont() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether or not to use the font in this XF instead of the parent XF.
isIndentNotParentFormat() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether or not to use the format in this XF instead of the parent XF.
isIndentNotParentPattern() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether or not to use the pattern in this XF instead of the parent XF.
isIndexInTable(int) - Method in interface org.apache.poi.hwpf.model.CharIndexTranslator
Check if index is in table
isIndexInTable(int) - Method in class org.apache.poi.hwpf.model.TextPieceTable

isInRange(int, int) - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

isInRange(int) - Static method in class org.apache.poi.ss.formula.ptg.IntPtg
Excel represents integers 0..65535 with the tInt token.
isInRange(int, int) - Method in class org.apache.poi.ss.util.CellRangeAddressBase

isInsertColumnsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isInsertHyperlinksLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isInsertRowsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isInTable() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isInternalDateFormat(int) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given a format ID this will check whether the format represents an internal excel date format or not.
isInternalReferences() - Method in class org.apache.poi.hssf.record.SupBookRecord

isInvert() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
swap foreground and background colours when data is negative
isIsDate() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
this is a date axis
isItalic() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is the text italic?
isItalic() - Method in class org.apache.poi.hssf.record.cf.FontFormatting
get whether the font is to be italics or not
isItalic() - Method in class org.apache.poi.hssf.record.FontRecord
get whether the font is to be italics or not
isItalic() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isItalic() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isItalic() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isItalic() - Method in interface org.apache.poi.ss.usermodel.FontFormatting

isItalic() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

isItalic() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting

isItalic() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Whether the italic property should be applied to all non-complex script characters in the contents of this run when displayed in a document.
isKinsoku() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isKinsoku() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isLabelAsPercentage() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
show category label/value as percentage (pie charts only)
isLastColRelative() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

isLastRowRelative() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

isLatentStyle(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFLatentStyles
checks wheter specific LatentStyleID is a latentStyle
isLeftBorderModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isLineNotNumbered() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isLineNotNumbered() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isListValidationType() - Method in class org.apache.poi.hssf.usermodel.DVConstraint
Convenience method
isLocked() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
true if object is locked when sheet has been protected
isLocked() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
get whether the cell is locked or not
isLocked() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

isLocked() - Method in interface org.apache.poi.hwpf.usermodel.Field

isLogarithmicScale() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
use logarithmic scale
ISLOGICAL - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction

isLogUnsupportedTypes() - Static method in class org.apache.poi.hpsf.VariantSupport
Checks whether logging of unsupported variant types warning is turned on or off.
isMacoutlined() - Method in class org.apache.poi.hssf.record.FontRecord
whether to use the mac outline font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
isMacro() - Method in class org.apache.poi.hssf.record.NameRecord

isMacroEnabled() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Are we a normal workbook (.xlsx), or a macro enabled workbook (.xlsm)?
isMacshadowed() - Method in class org.apache.poi.hssf.record.FontRecord
whether to use the mac shado font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
isMarkedDeleted() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isMarkedDeleted() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isMarkedInserted() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isMarkedInserted() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isMerged() - Method in class org.apache.poi.hwpf.usermodel.TableCell

ISNA - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction
Implementation for Excel ISNA() function.
Syntax:
ISNA(value)
value The value to be tested

Returns TRUE if the specified value is '#N/A', FALSE otherwise.
isNeeded() - Method in class org.apache.poi.hssf.record.RecalcIdRecord

isNested() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

isNested() - Method in interface org.apache.poi.hwpf.usermodel.Field

isNoFill() - Method in class org.apache.poi.hssf.usermodel.HSSFShape

isNoFill() - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Whether this shape is not filled with a color
ISNONTEXT - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction

isNonWorkday(double, double[]) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator

ISNUMBER - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction

isNumeric() - Method in interface org.apache.poi.ss.usermodel.charts.ChartDataSource
Returns true if data source points should be treated as numbers.
isObj() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isObjectProtected() - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

isObjectsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

IsocelesTriangle - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

isOldfConvMailMergeEsc() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfMapPrintTextColor() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfNoColumnBalance() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfNoSpaceRaiseLower() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfNoTabForInd() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfOrigWordTableRules() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfShowBreaksInFrames() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfSuppressSpbfAfterPageBreak() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfSupressTopSpacing() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfSwapBordersFacingPgs() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfTransparentMetafiles() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOldfWrapTrailSpaces() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isOle2() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isOLELink() - Method in class org.apache.poi.hssf.record.ExternalNameRecord

isOneNotTwoVar() - Method in class org.apache.poi.hssf.record.TableRecord

isOptimizedChoose() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

isOptimizedIf() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

isOutlined() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isOutlined() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isOutlineOn() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isOutlineOn() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isOutputCharactersLanguage() - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

isOutputColumnHeaders() - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

isOutputHiddenColumns() - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

isOutputHiddenRows() - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

isOutputLeadingSpacesAsNonBreaking() - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

isOutputRowNumbers() - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

isOutputSummaryInformation() - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

isPageBreak() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies that when rendering this document in a paginated view, the contents of this paragraph are rendered on the start of a new page in the document.
isPartAbsolute(String) - Static method in class org.apache.poi.ss.util.CellReference

isPartOfArrayFormula() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

isPartOfArrayFormulaGroup() - Method in class org.apache.poi.hssf.usermodel.HSSFCell

isPartOfArrayFormulaGroup() - Method in interface org.apache.poi.ss.usermodel.Cell

isPartOfArrayFormulaGroup() - Method in class org.apache.poi.xssf.streaming.SXSSFCell

isPartOfArrayFormulaGroup() - Method in class org.apache.poi.xssf.usermodel.XSSFCell

isPatternBackgroundColorModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isPatternColorModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isPatternStyleModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isPicureLink() - Method in class org.apache.poi.hssf.record.ExternalNameRecord
only for OLE and DDE
isPivotTablesLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isPlaceholder(Shape) - Static method in class org.apache.poi.hslf.model.MasterSheet
Checks if the shape is a placeholder.
isPlaceholderCustom() - Method in class org.apache.poi.xslf.usermodel.DrawingTextPlaceholder
Is the PlaceHolder text customised?
isPlotOnlyVisibleCells() - Method in class org.apache.poi.xssf.usermodel.XSSFChart

isPlotVisibleOnly() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Only show visible cells on the chart.
isPrintable() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
object appears when printed
isPrintGridlines() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Returns whether gridlines are printed.
isPrintGridlines() - Method in interface org.apache.poi.ss.usermodel.Sheet
Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.
isPrintGridlines() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.
isPrintGridlines() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns whether gridlines are printed.
isPrivateResult() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

isPrivateResult() - Method in interface org.apache.poi.hwpf.usermodel.Field

isPropertySetStream(InputStream) - Static method in class org.apache.poi.hpsf.PropertySet
Checks whether an InputStream is in the Horrible Property Set Format.
isPropertySetStream(byte[], int, int) - Static method in class org.apache.poi.hpsf.PropertySet
Checks whether a byte array is in the Horrible Property Set Format.
isPure() - Method in class org.apache.poi.hpsf.CustomProperties
Tells whether this CustomProperties instance is pure or one or more properties of the underlying low-level property set has been dropped.
isRange() - Method in interface org.apache.poi.ss.formula.EvaluationName

ISREF - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction

isReference() - Method in interface org.apache.poi.ss.usermodel.charts.ChartDataSource
Returns true if charts data source is valid cell range.
isRelationshipExists(PackageRelationship) - Method in class org.apache.poi.openxml4j.opc.OPCPackage

isRelationshipExists(PackageRelationship) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Checks if the specified relationship is part of this package part.
isRelationshipExists(PackageRelationship) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Checks if the specified relationship is part of this package part.
isRelationshipPart() - Method in class org.apache.poi.openxml4j.opc.PackagePart

isRelationshipPartURI() - Method in class org.apache.poi.openxml4j.opc.PackagePartName
Know if this part name is a relationship part name.
isRelationshipPartURI(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Know if the specified URI is a relationship part name.
isRepeatHeader() - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
Return true if a table's header row should be repeated at the top of a table split across pages.
isReserved() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
reserved, must equal 1 (excel dev.
isReserved1() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated. This field should not be used according to specification
isReserved2() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Deprecated. This field should not be used according to specification
isResultDirty() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

isResultDirty() - Method in interface org.apache.poi.hwpf.usermodel.Field

isResultEdited() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

isResultEdited() - Method in interface org.apache.poi.hwpf.usermodel.Field

isReturnNullOnMissingChunk() - Method in class org.apache.poi.hsmf.MAPIMessage
Will you get a null on a missing chunk, or a ChunkNotFoundException (default is the exception).
isReversed() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
categories are displayed in reverse order
isRevisionLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Specifies a boolean value that indicates whether the workbook is locked for revisions.
isRightBorderModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isRightToLeft() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Whether the text is displayed in right-to-left mode in the window
isRightToLeft() - Method in interface org.apache.poi.ss.usermodel.Sheet
Whether the text is displayed in right-to-left mode in the window
isRightToLeft() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Whether the text is displayed in right-to-left mode in the window
isRightToLeft() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Whether the text is displayed in right-to-left mode in the window
isRoot() - Method in class org.apache.poi.poifs.filesystem.EntryNode
is this the root of the tree?
isRotateFont() - Method in class org.apache.poi.hwpf.usermodel.TableCell

isRow() - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

isRow() - Method in interface org.apache.poi.ss.formula.TwoDEval

isRowAbsolute() - Method in class org.apache.poi.ss.util.CellReference

isRowBroken(int) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Queries if the specified row has a page break
isRowBroken(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

isRowBroken(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Determines if there is a page break at the indicated row
isRowBroken(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Determines if there is a page break at the indicated row
isRowBroken(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Tests if there is a page break at the indicated row
isRowDeleted() - Method in class org.apache.poi.hssf.record.TableRecord

isRowGroupCollapsed(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

isRowGroupHiddenByParent(int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

isRowOrColInpCell() - Method in class org.apache.poi.hssf.record.TableRecord

isRowRelative() - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

isRowWithnRange(String, SpreadsheetVersion) - Static method in class org.apache.poi.ss.util.CellReference

ISS_NONE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

ISS_SUBSCRIPTED - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

ISS_SUPERSCRIPTED - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

isSame(Formula) - Method in class org.apache.poi.ss.formula.Formula

isScenarioProtected() - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

isScenariosLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isSelected() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Note - this is not the same as whether the sheet is focused (isActive)
isSelected() - Method in interface org.apache.poi.ss.usermodel.Sheet
Note - this is not the same as whether the sheet is focused (isActive)
isSelected() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Note - this is not the same as whether the sheet is focused (isActive)
isSelected() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Returns a flag indicating whether this sheet is selected.
isSelectLockedCellsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isSelectUnlockedCellsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isSemiVolatile() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

isSet(int) - Method in class org.apache.poi.util.BitField
Is the field set or not? This is most commonly used for a single-bit field, which is often used to represent a boolean value; the results of using it for a multi-bit field is to determine whether *any* of its bits are set
isSet() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

isSetLogBase() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

isSetLogBase() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

isSetMaximum() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

isSetMaximum() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

isSetMinimum() - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

isSetMinimum() - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

isShadow() - Method in class org.apache.poi.hssf.record.chart.AreaRecord
display a shadow for the chart
isShadow() - Method in class org.apache.poi.hssf.record.chart.BarRecord
display a shadow for the chart
isShadow() - Method in class org.apache.poi.hwpf.usermodel.BorderCode
When true, border is drawn with shadow Must be false when BRC is a substructure of the TC.
isShadowed() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Does the text have a shadow?
isShadowed() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isShadowed() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isShadowOn() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isShadowOn() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isSharedFormula() - Method in class org.apache.poi.hssf.record.FormulaRecord

isSheetHidden(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Gets the hidden flag for a given sheet.
isSheetHidden(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

isSheetHidden(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Check whether a sheet is hidden.
isSheetHidden(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Check whether a sheet is hidden.
isSheetHidden(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Check whether a sheet is hidden.
isSheetLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isSheetProtected() - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

isSheetVeryHidden(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Gets the very hidden flag for a given sheet.
isSheetVeryHidden(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

isSheetVeryHidden(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Check whether a sheet is very hidden.
isSheetVeryHidden(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Check whether a sheet is very hidden.
isSheetVeryHidden(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Check whether a sheet is very hidden.
isShowActual() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
show actual value of the data point
isShowBubbleSizes() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
??
isShowBubbleSizes() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isShowCategoryLabelAsPercentage() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isShowKey() - Method in class org.apache.poi.hssf.record.chart.TextRecord
true = draw legend
isShowLabel() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
display category label
isShowLabel() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isShowPercent() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
show value as percentage of total (pie charts only)
isShowSeriesKey() - Method in class org.apache.poi.hssf.record.chart.DatRecord
shows the series key
isShowValue() - Method in class org.apache.poi.hssf.record.chart.TextRecord
false = text is category label
isShowValueAsPercentage() - Method in class org.apache.poi.hssf.record.chart.TextRecord

isSideBySide() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isSideBySide() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isSingleCell() - Method in class org.apache.poi.ss.util.AreaReference

isSkip() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

isSlideNumberVisible() - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the slide number is displayed in the footer.
isSmall(int) - Static method in class org.apache.poi.poifs.property.Property
does the length indicate a small document?
isSmallCaps() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isSmallCaps() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isSmoothedLine() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
show smooth line
isSortLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

isSpace() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

isSpecialCharacter() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isStacked() - Method in class org.apache.poi.hssf.record.chart.AreaRecord
series is stacked
isStacked() - Method in class org.apache.poi.hssf.record.chart.BarRecord
stack displayed values
isStartAt() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

isStdDocumentNameIdentifier() - Method in class org.apache.poi.hssf.record.ExternalNameRecord
DDE links only.
isStrike() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that the contents of this run shall be displayed with a single horizontal line through the center of the line.
isStrikethrough() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Gets the strikethrough flag
isStrikeThrough() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isStrikeThrough() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isStrikethrough() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

isStroked() - Method in class org.apache.poi.xslf.model.geom.Path

isStruckout() - Method in class org.apache.poi.hssf.record.cf.FontFormatting
get whether the font is to be stricken out or not
isStruckout() - Method in class org.apache.poi.hssf.record.FontRecord
get whether the font is to be stricken out or not
isStruckout() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isStructureLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Specifies a boolean value that indicates whether structure of workbook is locked.
isSubscript() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

isSubTotal(int, int) - Method in class org.apache.poi.ss.formula.eval.AreaEvalBase

isSubTotal(int, int) - Method in interface org.apache.poi.ss.formula.TwoDEval

isSubtotalCounted() - Method in class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
Whether to count nested subtotals.
isSum() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

isSummaryInformation() - Method in class org.apache.poi.hpsf.PropertySet
Checks whether this PropertySet represents a Summary Information.
isSummaryInformation() - Method in class org.apache.poi.hpsf.SpecialPropertySet

isSuperscript() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

isSupportedType(int) - Method in class org.apache.poi.hpsf.VariantSupport
Checks whether HPSF supports the specified variant type.
isSymbol() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Returns true, if the CharacterRun is a special character run containing a symbol, otherwise false.
IStabilityClassifier - Interface in org.apache.poi.ss.formula
Used to help optimise cell evaluation result caching by allowing applications to specify which parts of a workbook are final.
The term final is introduced here to denote immutability or 'having constant definition'.
isTableHeader() - Method in class org.apache.poi.hwpf.usermodel.TableRow

isTableRowEnd() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isTerminating() - Method in class org.apache.poi.hssf.record.EndSubRecord

isTerminating() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord

isTerminating() - Method in class org.apache.poi.hssf.record.SubRecord
Wether this record terminates the sub-record stream.
ISTEXT - Static variable in class org.apache.poi.ss.formula.functions.LogicalFunction

isTextEmpty(HSSFCell) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

isTextLocked() - Method in class org.apache.poi.hssf.record.TextObjectRecord

isTopBorderModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isTopLeftBottomRightBorderModified() - Method in class org.apache.poi.hssf.record.CFRuleRecord

isTraverseEmptyCells() - Method in class org.apache.poi.ss.util.cellwalk.CellWalk
Should we call handler on empty (blank) cells.
isTrue() - Method in class org.apache.poi.ddf.EscherBoolProperty
Whether this boolean property is true
isUnCompressedUnicode() - Method in class org.apache.poi.hssf.record.LabelRecord
is this uncompressed unicode (16bit)? Or just 8-bit compressed?
isUnderline() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

isUnderlined() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is the text underlined?
isUnderlineTypeModified() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

isUnderlineTypeModified() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

isUnicode() - Method in class org.apache.poi.hwpf.model.PieceDescriptor

isUnicode() - Method in class org.apache.poi.hwpf.model.TextPiece

isUnicodeString(String) - Static method in class org.apache.poi.util.StringUtil
Checks to see if a given String needs to be represented as Unicode
isUnknown() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
book marks this as reserved = 0 but it seems to do something
isUnused() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Not used
isUnused() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
This value MUST be zero and MUST be ignored
isUnused1() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isUnused1() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Deprecated. This field should not be used according to specification
isUnused1() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Deprecated. This field should not be used according to specification
isUnused2() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Deprecated. This field should not be used according to specification
isUnused3() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isUnused4() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

isUrlLink() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Based on the link options, is this a url?
isUseDivsToSpan() - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

isUseExcel4Colors() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
set true to use excel 4 colors.
isUserDateVisible() - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the custom user date is used instead of today's date.
isUsing1904DateWindowing() - Method in class org.apache.poi.hssf.model.InternalWorkbook
Whether date windowing is based on 1/2/1904 or 1/1/1900.
isValidCode(int) - Static method in class org.apache.poi.ss.usermodel.ErrorConstants

isValidExcelDate(double) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Given a double, checks if it is a valid Excel date.
isValidPartName(URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Validate a part URI by returning a boolean.
isValueAxisCrossing() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
set true to indicate axis crosses between categories and false to cross axis midway
isValuesInReverse() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
values are reverses in graph
isVanished() - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

isVanished() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

isVertical() - Method in class org.apache.poi.hssf.record.chart.LegendRecord
vertical or horizontal legend (1 or 0 respectively).
isVertical() - Method in class org.apache.poi.hssf.record.chart.TextRecord
true = text is vertical
isVertical() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isVertical() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isVertical() - Method in class org.apache.poi.hwpf.usermodel.TableCell

isVerticalBorder() - Method in class org.apache.poi.hssf.record.chart.DatRecord
has vertical border
isVerticallyFlipped() - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

isVerticallyFlipped() - Method in class org.apache.poi.hssf.usermodel.HSSFChildAnchor

isVerticallyFlipped() - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

isVerticallyMerged() - Method in class org.apache.poi.hwpf.usermodel.TableCell

isVeryHidden() - Method in class org.apache.poi.hssf.record.BoundSheetRecord
Is the sheet very hidden? Different from (normal) hidden
isViewFlags_unused1() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Not used
isVisible() - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Sets whether this comment is visible.
isVisible() - Method in interface org.apache.poi.ss.usermodel.Comment
Sets whether this comment is visible.
isVisible() - Method in class org.apache.poi.xssf.usermodel.XSSFComment

isWeekend(double) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator

isWholeColumnReference(CellReference, CellReference) - Static method in class org.apache.poi.ss.util.AreaReference
Is the reference for a whole-column reference, such as C:C or D:G ?
isWholeColumnReference() - Method in class org.apache.poi.ss.util.AreaReference

isWidowControlled() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isWidowControlled() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isWindowsLocked() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Specifies a boolean value that indicates whether the windows that comprise the workbook are locked.
isWithinDocument() - Method in class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
isWordWrap() - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
This element specifies whether a consumer shall break Latin text which exceeds the text extents of a line by breaking the word across two lines (breaking on the character level) or by moving the word to the following line (breaking on the word level).
isWordWrapped() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

isWordWrapped() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

isWriteProtected() - Method in class org.apache.poi.hssf.model.InternalWorkbook
is the workbook protected with a password (not encrypted)?
isWriteProtected() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Is the workbook protected with a password (not encrypted)?
isZombieEmbed() - Method in class org.apache.poi.hwpf.model.FieldDescriptor

isZombieEmbed() - Method in interface org.apache.poi.hwpf.usermodel.Field

italic - Variable in class org.apache.poi.hwpf.converter.FontReplacer.Triplet

ITALIC_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

IterationRecord - Class in org.apache.poi.hssf.record
Title: Iteration Record (0x0011)
Description: Tells whether to iterate over forumla calculations or not (if a formula is dependant upon another formula's result) (odd feature for something that can only have 32 elements in a formula!)
IterationRecord(boolean) - Constructor for class org.apache.poi.hssf.record.IterationRecord

IterationRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.IterationRecord

iterator() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

iterator() - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate
value iterator
iterator() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Alias for HSSFRow.cellIterator() to allow foreach loops
iterator() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Alias for HSSFSheet.rowIterator() to allow foreach loops
iterator() - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

iterator() - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Get this collection's iterator.
iterator(String) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Get an iterator of a collection with all relationship with the specified type.
iterator() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
Returns an Iterator over all the entries
iterator() - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

iterator() - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream
Returns an iterator that'll supply one ByteBuffer per block in the stream.
iterator() - Method in interface org.apache.poi.ss.usermodel.CellRange

iterator() - Method in class org.apache.poi.ss.util.SSCellRange

iterator() - Method in class org.apache.poi.util.IntMapper

iterator() - Method in class org.apache.poi.xslf.model.geom.CustomGeometry

iterator() - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape
Returns an iterator over the shapes in this sheet
iterator() - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Returns an iterator over the shapes in this sheet
iterator() - Method in class org.apache.poi.xslf.usermodel.XSLFTable

iterator() - Method in class org.apache.poi.xslf.usermodel.XSLFTableRow

iterator() - Method in class org.apache.poi.xslf.usermodel.XSLFTableStyles

iterator() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

iterator() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

iterator() - Method in class org.apache.poi.xssf.streaming.SXSSFRow

iterator() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet

iterator() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Alias for XSSFRow.cellIterator() to allow foreach loops:
iterator() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Alias for XSSFSheet.rowIterator() to allow foreach loops
iterator() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Allows foreach loops:
iterator() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

J

join(AbstractEscherHolderRecord) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord
Big drawing group records are split but it's easier to deal with them as a whole group so we need to join them together.
joinRGB(byte, byte, byte) - Static method in class org.apache.poi.hslf.record.ColorSchemeAtom
Convert from split R, G, B values to an integer RGB value
joinRGB(byte[]) - Static method in class org.apache.poi.hslf.record.ColorSchemeAtom
Convert from split R, G, B values to an integer RGB value
JPEG - Class in org.apache.poi.hslf.blip
Represents a JPEG picture data in a PPT file
JPEG() - Constructor for class org.apache.poi.hslf.blip.JPEG

JPEG - Static variable in class org.apache.poi.hslf.model.Picture
JPEG
JPG - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
JUMP_ENDSHOW - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

JUMP_FIRSTSLIDE - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

JUMP_LASTSLIDE - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

JUMP_LASTSLIDEVIEWED - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

JUMP_NEXTSLIDE - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

JUMP_NONE - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom
Jump Table
JUMP_PREVIOUSSLIDE - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

JUSTIFY - Static variable in class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

JUSTIFY - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

JUSTIFYLOW - Static variable in class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

K

KCD_CIRCLE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KCD_COMMA - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KCD_DOT - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KCD_NON - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KCD_UNDER_DOT - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

keepOnPage() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

keepOnPage() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

keepWithNext() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

keepWithNext() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

keySet() - Method in class org.apache.poi.hpsf.CustomProperties
Returns a set of all the names of our custom properties.
keySet() - Method in class org.apache.poi.util.BinaryTree
Returns a set view of the keys contained in this map.
keySetByValue() - Method in class org.apache.poi.util.BinaryTree
Returns a set view of the keys contained in this map.
KEYWORD - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

KEYWORD_CATEGORY - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_CATEGORY - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_CONTENT_STATUS - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_CONTENT_STATUS - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_CONTENT_TYPE - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_CONTENT_TYPE - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_CREATED - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_CREATED - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_CREATOR - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_CREATOR - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_DESCRIPTION - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_DESCRIPTION - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_IDENTIFIER - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_IDENTIFIER - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_KEYWORDS - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_KEYWORDS - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_LANGUAGE - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_LANGUAGE - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_LAST_MODIFIED_BY - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_LAST_MODIFIED_BY - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_LAST_PRINTED - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_LAST_PRINTED - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_MODIFIED - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_MODIFIED - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_REVISION - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_REVISION - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_SUBJECT - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_SUBJECT - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_TITLE - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_TITLE - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

KEYWORD_VERSION - Static variable in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

KEYWORD_VERSION - Static variable in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

keywords - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
A delimited set of keywords to support searching and indexing.
KUL_BY_WORD - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DASH - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DASH_LONG - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DASH_LONG_HEAVY - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DASHED_HEAVY - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOT - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOT_DASH - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOT_DASH_HEAVY - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOT_DOT_DASH - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOT_DOT_DASH_HEAVY - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOTTED - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOTTED_HEAVY - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_DOUBLE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_HIDDEN - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_NONE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_SINGLE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_THICK - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_WAVE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_WAVE_DOUBLE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

KUL_WAVE_HEAVY - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

L

L_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

LABELRANGES_015F - Static variable in class org.apache.poi.hssf.record.UnknownRecord

LabelRecord - Class in org.apache.poi.hssf.record
Label Record (0x0204) - read only support for strings stored directly in the cell..
LabelRecord() - Constructor for class org.apache.poi.hssf.record.LabelRecord
Creates new LabelRecord
LabelRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.LabelRecord

LabelSSTRecord - Class in org.apache.poi.hssf.record
Title: Label SST Record
LabelSSTRecord() - Constructor for class org.apache.poi.hssf.record.LabelSSTRecord

LabelSSTRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.LabelSSTRecord

langId - Variable in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

LANGUAGE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

language - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The language of the intellectual content of the resource.
LANGUAGES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LARGE - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

LARGER_BIG_BLOCK_SIZE - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
Some use 4096 bytes
LARGER_BIG_BLOCK_SIZE_DETAILS - Static variable in interface org.apache.poi.poifs.common.POIFSConstants

LARGEST_REGULAR_SECTOR_NUMBER - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
The highest sector number you're allowed, 0xFFFFFFFA
LAST_COLUMN_NUMBER - Static variable in class org.apache.poi.hssf.usermodel.HSSFCell
The maximum number of columns in BIFF8
LAST_MODIFICATION_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LAST_VIEW_NONE - Static variable in class org.apache.poi.hslf.record.UserEditAtom

LAST_VIEW_NOTES - Static variable in class org.apache.poi.hslf.record.UserEditAtom

LAST_VIEW_OUTLINE_VIEW - Static variable in class org.apache.poi.hslf.record.UserEditAtom

LAST_VIEW_SLIDE_VIEW - Static variable in class org.apache.poi.hslf.record.UserEditAtom

LastCellOfRowDummyRecord - Class in org.apache.poi.hssf.eventusermodel.dummyrecord
A dummy record to indicate that we've now had the last cell record for this row.
LastCellOfRowDummyRecord(int, int) - Constructor for class org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord

lastIndexOf(int) - Method in class org.apache.poi.util.IntList
Returns the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element.
lastIndexOf(short) - Method in class org.apache.poi.util.ShortList
Returns the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element.
lastModifiedBy - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The user who performed the last modification.
lastPrinted - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The date and time of the last printing.
LATEST_DELIVERY_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

layoutMasterSet - Variable in class org.apache.poi.hwpf.converter.FoDocumentFacade

LayoutMode - Enum in org.apache.poi.ss.usermodel.charts
Specifies the possible ways to store a chart element's position.
LayoutTarget - Enum in org.apache.poi.ss.usermodel.charts
Specifies whether to layout the plot area by its inside (not including axis and axis labels) or outside (including axis and axis labels).
LazilyConcatenatedByteArray - Class in org.apache.poi.hssf.util
Utility for delaying the concatenation of multiple byte arrays.
LazilyConcatenatedByteArray() - Constructor for class org.apache.poi.hssf.util.LazilyConcatenatedByteArray

LBRCRJ_BOTH - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

LBRCRJ_LEFT - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

LBRCRJ_NONE - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

LBRCRJ_RIGHT - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

LbsDataSubRecord - Class in org.apache.poi.hssf.record
This structure specifies the properties of a list or drop-down list embedded object in a sheet.
LbsDataSubRecord(LittleEndianInput, int, int) - Constructor for class org.apache.poi.hssf.record.LbsDataSubRecord

LbsDataSubRecord.LbsDropData - Class in org.apache.poi.hssf.record
This structure specifies properties of the dropdown list control
LbsDataSubRecord.LbsDropData() - Constructor for class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

LbsDataSubRecord.LbsDropData(LittleEndianInput) - Constructor for class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

LE - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

LE - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Less than or equal to' operator
LEAST_DOTS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Least Dots
LEAST_DOTS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Least Dots
LEAST_DOTS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Least Dots
LEDGER_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Ledger 17 x 11 in
left - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

LEFT - Static variable in class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

LEFT - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

LEFT - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

LEFT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_ARROW_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_BORDER_COLOR - Static variable in class org.apache.poi.ss.util.CellUtil

LEFT_BRACE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_BRACKET - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_CIRCULAR_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_RIGHT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_RIGHT_ARROW_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_RIGHT_CIRCULAR_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_RIGHT_RIBBON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_RIGHT_UP_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LEFT_UP_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LeftArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LeftArrowCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LeftBrace - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LeftBracket - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LeftMargin - Static variable in class org.apache.poi.hssf.model.InternalSheet

LeftMargin - Static variable in interface org.apache.poi.ss.usermodel.Sheet

LeftMarginRecord - Class in org.apache.poi.hssf.record
Record for the left margin.

LeftMarginRecord() - Constructor for class org.apache.poi.hssf.record.LeftMarginRecord

LeftMarginRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.LeftMarginRecord

LeftRightArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LeftRightArrowCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LeftRightUpArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LeftUpArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LEGAL_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Legal 8 1/2 x 14 in
LegendPosition - Enum in org.apache.poi.ss.usermodel.charts
Enumeration of all possible chart legend positions.
LegendRecord - Class in org.apache.poi.hssf.record.chart
Defines a legend for a chart.

LegendRecord() - Constructor for class org.apache.poi.hssf.record.chart.LegendRecord

LegendRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.LegendRecord

len - Variable in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

LEN - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

length - Variable in class org.apache.poi.hdgf.chunks.ChunkHeader

length - Variable in class org.apache.poi.hdgf.pointers.Pointer

LENGTH - Static variable in class org.apache.poi.hpsf.ClassID
The number of bytes occupied by this object in the byte stream.
length() - Method in class org.apache.poi.hpsf.ClassID

length() - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

length() - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString

length() - Method in class org.apache.poi.hwpf.model.PlexOfCps
returns the number of data structures in this PlexofCps.
length - Variable in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart
Size of data.
length() - Method in class org.apache.poi.poifs.filesystem.POIFSDocumentPath

length() - Method in interface org.apache.poi.ss.usermodel.RichTextString

length() - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Returns the number of characters in this string.
LENGTH_0 - Static variable in class org.apache.poi.hpsf.Variant
Denotes a variant type with a length of 0 bytes.
LENGTH_2 - Static variable in class org.apache.poi.hpsf.Variant
Denotes a variant type with a length of 2 bytes.
LENGTH_4 - Static variable in class org.apache.poi.hpsf.Variant
Denotes a variant type with a length of 4 bytes.
LENGTH_8 - Static variable in class org.apache.poi.hpsf.Variant
Denotes a variant type with a length of 8 bytes.
LENGTH_UNKNOWN - Static variable in class org.apache.poi.hpsf.Variant
Denotes a variant type with a length that is unknown to HPSF yet.
LENGTH_VARIABLE - Static variable in class org.apache.poi.hpsf.Variant
Denotes a variant type with a variable length.
LESS_DOTS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Less Dots
LESS_DOTS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Less Dots
LESS_DOTS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Less Dots
LESS_OR_EQUAL - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

LESS_THAN - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

LessEqualEval - Static variable in class org.apache.poi.ss.formula.eval.RelationalOperationEval

LessEqualPtg - Class in org.apache.poi.ss.formula.ptg
Ptg class to implement less than or equal
LessThanEval - Static variable in class org.apache.poi.ss.formula.eval.RelationalOperationEval

LessThanPtg - Class in org.apache.poi.ss.formula.ptg
Less than operator PTG "<".
LETTER_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Letter 8 1/2 x 11 in
LETTER_ROTATED_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Letter Rotated 11 x 8 1/2 in
LETTER_SIZED_PAPER - Static variable in class org.apache.poi.hslf.record.DocumentAtom.SlideSize

LETTER_SMALL_PAGESIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Letter Small 8 1/2 x 11 in
LEVEL_ATTACHMENT - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

LEVEL_END_OF_FILE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

LEVEL_MESSAGE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

LFOAbstractType - Class in org.apache.poi.hwpf.model.types
List Format Override (LFO).
LFOAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.LFOAbstractType

LFOLVLBaseAbstractType - Class in org.apache.poi.hwpf.model.types
The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.
LFOLVLBaseAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

LIGHTNING_BOLT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LightningBolt - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

limitsAreEqual(Object) - Method in class org.apache.poi.hwpf.model.PropertyNode

Line - Class in org.apache.poi.hslf.model
Represents a line in a PowerPoint drawing
Line(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Line

Line(Shape) - Constructor for class org.apache.poi.hslf.model.Line

Line() - Constructor for class org.apache.poi.hslf.model.Line

Line - Interface in org.apache.poi.sl.usermodel

Line - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

LINE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LINE_DOUBLE - Static variable in class org.apache.poi.hslf.model.Line
Double lines of equal width
LINE_INV - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

LINE_OF_STRAIGHT_SEGMENTS - Static variable in class org.apache.poi.ddf.EscherShapePathProperty

LINE_PATTERN_DARK_GRAY_PATTERN - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_DASH - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_DASH_DOT - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_DASH_DOT_DOT - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_DOT - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_LIGHT_GRAY_PATTERN - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_MEDIUM_GRAY_PATTERN - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_NONE - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_PATTERN_SOLID - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

LINE_SIMPLE - Static variable in class org.apache.poi.hslf.model.Line
Single line (of width lineWidth)
LINE_THICKTHIN - Static variable in class org.apache.poi.hslf.model.Line
Double lines, one thick, one thin
LINE_THINTHICK - Static variable in class org.apache.poi.hslf.model.Line
Double lines, reverse order
LINE_TRIPLE - Static variable in class org.apache.poi.hslf.model.Line
Three lines, thin, thick, thin
LineCap - Enum in org.apache.poi.xslf.usermodel

LineDash - Enum in org.apache.poi.xslf.usermodel

LineDecoration - Enum in org.apache.poi.xslf.usermodel
Represents the shape decoration that appears at the ends of lines.
LineEndLength - Enum in org.apache.poi.xslf.usermodel

LineEndWidth - Enum in org.apache.poi.xslf.usermodel

LineFormatRecord - Class in org.apache.poi.hssf.record.chart
Describes a line format record.
LineFormatRecord() - Constructor for class org.apache.poi.hssf.record.chart.LineFormatRecord

LineFormatRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.LineFormatRecord

LineShape - Class in org.apache.poi.hssf.model
Represents a line shape and creates all the line specific low level records.
LineSpacingDescriptor - Class in org.apache.poi.hwpf.usermodel
This class is used to determine line spacing for a paragraph.
LineSpacingDescriptor() - Constructor for class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

LineSpacingDescriptor(byte[], int) - Constructor for class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

LineSpacingRule - Enum in org.apache.poi.xwpf.usermodel
Specifies the logic which shall be used to calculate the line spacing of the parent object when it is displayed in the document.
LineStyle - Interface in org.apache.poi.common.usermodel

LineStyle - Interface in org.apache.poi.sl.usermodel

LINESTYLE__ANYLINE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__ARROWHEADSOK - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__BACKCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__COLOR - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__CRMOD - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__FILLBLIP - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__FILLBLIPFLAGS - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__FILLBLIPNAME - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__FILLDZTYPE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__FILLHEIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__FILLWIDTH - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__HITLINETEST - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEDASHING - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEDASHSTYLE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEENDARROWHEAD - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEENDARROWLENGTH - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEENDARROWWIDTH - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEENDCAPSTYLE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEESTARTARROWLENGTH - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEFILLSHAPE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEJOINSTYLE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEMITERLIMIT - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINESTARTARROWHEAD - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINESTARTARROWWIDTH - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINESTYLE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINETYPE - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__LINEWIDTH - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__NOLINEDRAWDASH - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE__OPACITY - Static variable in class org.apache.poi.ddf.EscherProperties

LINESTYLE_DASHDOTDOTSYS - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_DASHDOTGEL - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_DASHDOTSYS - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_DASHGEL - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_DASHSYS - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_DOTGEL - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_DOTSYS - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_LONGDASHDOTDOTGEL - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_LONGDASHDOTGEL - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_LONGDASHGEL - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_NONE - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINESTYLE_SOLID - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LineToCommand - Class in org.apache.poi.xslf.model.geom
Date: 10/25/11
LINEWIDTH_DEFAULT - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINEWIDTH_ONE_PT - Static variable in class org.apache.poi.hssf.usermodel.HSSFShape

LINK_CustomShow - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_DOCUMENT - Static variable in interface org.apache.poi.common.usermodel.Hyperlink
Link to a place in this document
LINK_DOCUMENT - Static variable in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Link to a place in this document
LINK_EMAIL - Static variable in interface org.apache.poi.common.usermodel.Hyperlink
Link to an E-mail address
LINK_EMAIL - Static variable in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Link to an E-mail address
LINK_FILE - Static variable in interface org.apache.poi.common.usermodel.Hyperlink
Link to a file
LINK_FILE - Static variable in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Link to a file
LINK_FIRSTSLIDE - Static variable in class org.apache.poi.hslf.model.Hyperlink

LINK_FirstSlide - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_LASTSLIDE - Static variable in class org.apache.poi.hslf.model.Hyperlink

LINK_LastSlide - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_NEXTSLIDE - Static variable in class org.apache.poi.hslf.model.Hyperlink

LINK_NextSlide - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom
Types of hyperlinks
LINK_NULL - Static variable in class org.apache.poi.hslf.model.Hyperlink

LINK_NULL - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_OtherFile - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_OtherPresentation - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_PREVIOUSSLIDE - Static variable in class org.apache.poi.hslf.model.Hyperlink

LINK_PreviousSlide - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_SlideNumber - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

link_type - Variable in class org.apache.poi.hssf.usermodel.HSSFHyperlink
If we create a new hypelrink remember its type
LINK_TYPE_CATEGORIES - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

LINK_TYPE_TITLE_OR_TEXT - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

LINK_TYPE_VALUES - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

LINK_URL - Static variable in interface org.apache.poi.common.usermodel.Hyperlink
Link to a existing file or web page
LINK_URL - Static variable in class org.apache.poi.hslf.model.Hyperlink

LINK_Url - Static variable in class org.apache.poi.hslf.record.InteractiveInfoAtom

LINK_URL - Static variable in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Link to a existing file or web page
LinkedDataRecord - Class in org.apache.poi.hssf.record.chart
Describes a linked data record.
LinkedDataRecord() - Constructor for class org.apache.poi.hssf.record.chart.LinkedDataRecord

LinkedDataRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.LinkedDataRecord

linkSharedFormulaRecord(CellReference, FormulaRecordAggregate) - Method in class org.apache.poi.hssf.record.aggregates.SharedValueManager

List - Static variable in class org.apache.poi.hslf.record.RecordTypes

LIST - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
List type ( combo box type )
LIST_HELP - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LIST_SUBSCRIBE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LIST_UNSUBSCRIBE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ListAutoNumber - Enum in org.apache.poi.xslf.usermodel
Specifies type of automatic numbered bullet points that should be applied to a paragraph.
listById(PrintStream) - Method in class org.apache.poi.hsmf.dev.TypesLister

listByName(PrintStream) - Method in class org.apache.poi.hsmf.dev.TypesLister

ListData - Class in org.apache.poi.hwpf.model

ListData(int, boolean) - Constructor for class org.apache.poi.hwpf.model.ListData

ListEntry - Class in org.apache.poi.hwpf.usermodel

ListFormatOverride - Class in org.apache.poi.hwpf.model

ListFormatOverride(byte[], int) - Constructor for class org.apache.poi.hwpf.model.ListFormatOverride

ListFormatOverride(int) - Constructor for class org.apache.poi.hwpf.model.ListFormatOverride

ListFormatOverrideLevel - Class in org.apache.poi.hwpf.model
The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.
ListFormatOverrideLevel(byte[], int) - Constructor for class org.apache.poi.hwpf.model.ListFormatOverrideLevel

ListLevel - Class in org.apache.poi.hwpf.model
"The LVL structure contains formatting information about a specific level in a list.
ListLevel(byte[], int) - Constructor for class org.apache.poi.hwpf.model.ListLevel
Deprecated.
ListLevel(int, boolean) - Constructor for class org.apache.poi.hwpf.model.ListLevel

ListLevel(int, int, int, byte[], byte[], String) - Constructor for class org.apache.poi.hwpf.model.ListLevel

ListManagedBlock - Interface in org.apache.poi.poifs.storage
An interface for blocks managed by a list that works with a BlockAllocationTable to keep block sequences straight
ListTables - Class in org.apache.poi.hwpf.model

ListTables() - Constructor for class org.apache.poi.hwpf.model.ListTables

ListTables(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.ListTables

LiteralValueExpression - Class in org.apache.poi.xslf.model.geom
Date: 10/24/11
LittleEndian - Class in org.apache.poi.util
a utility class for handling little-endian numbers, which the 80x86 world is replete with.
LittleEndian.BufferUnderrunException - Exception in org.apache.poi.util
Exception to handle buffer underruns
LittleEndianByteArrayInputStream - Class in org.apache.poi.util
Adapts a plain byte array to LittleEndianInput
LittleEndianByteArrayInputStream(byte[], int, int) - Constructor for class org.apache.poi.util.LittleEndianByteArrayInputStream

LittleEndianByteArrayInputStream(byte[], int) - Constructor for class org.apache.poi.util.LittleEndianByteArrayInputStream

LittleEndianByteArrayInputStream(byte[]) - Constructor for class org.apache.poi.util.LittleEndianByteArrayInputStream

LittleEndianByteArrayOutputStream - Class in org.apache.poi.util
Adapts a plain byte array to LittleEndianOutput
LittleEndianByteArrayOutputStream(byte[], int, int) - Constructor for class org.apache.poi.util.LittleEndianByteArrayOutputStream

LittleEndianByteArrayOutputStream(byte[], int) - Constructor for class org.apache.poi.util.LittleEndianByteArrayOutputStream

LittleEndianConsts - Interface in org.apache.poi.util
a repository for constants shared by classes within this package
LittleEndianInput - Interface in org.apache.poi.util

LittleEndianInputStream - Class in org.apache.poi.util
Wraps an InputStream providing LittleEndianInput
This class does not buffer any input, so the stream read position maintained by this class is consistent with that of the inner stream.
LittleEndianInputStream(InputStream) - Constructor for class org.apache.poi.util.LittleEndianInputStream

LittleEndianOutput - Interface in org.apache.poi.util

LittleEndianOutputStream - Class in org.apache.poi.util

LittleEndianOutputStream(OutputStream) - Constructor for class org.apache.poi.util.LittleEndianOutputStream

LL_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

LN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

load(InputStream) - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

load(InputStream) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

load(InputStream) - Method in class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

load(InputStream) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Load the content of this part.
load(InputStream) - Method in class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

load(InputStream) - Method in class org.apache.poi.openxml4j.opc.ZipPackagePart

load(POIXMLFactory) - Method in class org.apache.poi.POIXMLDocument

loadDoc(DirectoryNode) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

loadDoc(File) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

loadDoc(InputStream) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

loadDoc(POIFSFileSystem) - Static method in class org.apache.poi.hwpf.converter.AbstractWordUtils

loadXls(File) - Static method in class org.apache.poi.hssf.converter.AbstractExcelUtils

LOCALE - Static variable in class org.apache.poi.ss.format.CellFormatter
This is the locale used to get a consistent format result from which to work.
LOCALITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCALLY_DELIVERED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCATION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_BRANCH_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_DEPTH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_ENLISTMENT_CONTEXT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_EXPIRY_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_PERSISTENT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_RESOURCE_DID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_RESOURCE_FID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_RESOURCE_MID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_SCOPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_TIMEOUT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

LOCK_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

lockAutoFilter() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Autofilters locking.
lockDeleteColumns() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Deleting columns locking.
lockDeleteRows() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Deleting rows locking.
LOCKED - Static variable in class org.apache.poi.ss.util.CellUtil

lockFormatCells() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Formatting cells locking.
lockFormatColumns() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Formatting columns locking.
lockFormatRows() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Formatting rows locking.
lockInsertColumns() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Inserting columns locking.
lockInsertHyperlinks() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Inserting hyperlinks locking.
lockInsertRows() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Inserting rows locking.
lockObjects() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Objects locking.
lockPivotTables() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Pivot Tables locking.
lockRevision() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Locks the workbook for revisions.
lockScenarios() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Scenarios locking.
lockSelectLockedCells() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Selection of locked cells locking.
lockSelectUnlockedCells() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Selection of unlocked cells locking.
lockSort() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enable Sort locking.
lockStructure() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Locks the structure of workbook.
lockWindows() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Locks the windows that comprise the workbook.
log - Variable in class org.apache.poi.hslf.model.PPGraphics2D

LOG - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

log(int, Object) - Method in class org.apache.poi.util.CommonsLogger
Log a message
log(int, Object, Throwable) - Method in class org.apache.poi.util.CommonsLogger
Log a message
log(int, Object) - Method in class org.apache.poi.util.NullLogger
Log a message
log(int, Object, Object) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message
log(int, Object, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.NullLogger
Log a message.
log(int, Object) - Method in class org.apache.poi.util.POILogger
Log a message
log(int, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message
log(int, Object, Object) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Throwable) - Method in class org.apache.poi.util.POILogger
Log an exception, without a message
log(int, Object, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object, Object, Object, Object, Object, Object, Object, Object, Throwable) - Method in class org.apache.poi.util.POILogger
Log a message.
log(int, Object) - Method in class org.apache.poi.util.SystemOutLogger
Log a message
log(int, Object, Throwable) - Method in class org.apache.poi.util.SystemOutLogger
Log a message
LOG10 - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

logFormatted(int, String, Object) - Method in class org.apache.poi.util.NullLogger
Logs a formated message.
logFormatted(int, String, Object, Object) - Method in class org.apache.poi.util.NullLogger
Logs a formated message.
logFormatted(int, String, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Logs a formated message.
logFormatted(int, String, Object, Object, Object, Object) - Method in class org.apache.poi.util.NullLogger
Logs a formated message.
logFormatted(int, String, Object) - Method in class org.apache.poi.util.POILogger
Logs a formated message.
logFormatted(int, String, Object, Object) - Method in class org.apache.poi.util.POILogger
Logs a formated message.
logFormatted(int, String, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Logs a formated message.
logFormatted(int, String, Object, Object, Object, Object) - Method in class org.apache.poi.util.POILogger
Logs a formated message.
logger - Variable in class org.apache.poi.hslf.blip.BitmapPainter

logger - Variable in class org.apache.poi.hslf.model.Fill

logger - Variable in class org.apache.poi.hslf.model.Shape

logger - Static variable in class org.apache.poi.hslf.model.ShapeFactory

logger - Static variable in class org.apache.poi.hslf.model.ShapePainter

logger - Variable in class org.apache.poi.hslf.model.TextPainter

logger - Variable in class org.apache.poi.hslf.record.Record

logger - Variable in class org.apache.poi.hslf.usermodel.PictureData

logger - Variable in class org.apache.poi.hslf.usermodel.RichTextRun

logger - Static variable in class org.apache.poi.hwpf.model.FileInformationBlock

LogicalFunction - Class in org.apache.poi.ss.formula.functions

LogicalFunction() - Constructor for class org.apache.poi.ss.formula.functions.LogicalFunction

LONG - Static variable in class org.apache.poi.hsmf.datatypes.Types
Long - signed 32-bit value
LONG_LONG - Static variable in class org.apache.poi.hsmf.datatypes.Types
I8 - 8-byte signed integer
LONG_SIZE - Static variable in interface org.apache.poi.util.LittleEndianConsts

LongField - Class in org.apache.poi.util
representation of a long (16-bit) field at a fixed location within a byte array
LongField(int) - Constructor for class org.apache.poi.util.LongField
construct the LongField with its offset into its containing byte array
LongField(int, long) - Constructor for class org.apache.poi.util.LongField
construct the LongField with its offset into its containing byte array and initialize its value
LongField(int, byte[]) - Constructor for class org.apache.poi.util.LongField
Construct the LongField with its offset into its containing byte array and initialize its value from its byte array
LongField(int, long, byte[]) - Constructor for class org.apache.poi.util.LongField
construct the LongField with its offset into its containing byte array, initialize its value, and write the value to a byte array
longToHex(long) - Static method in class org.apache.poi.util.HexDump

lookIndexBackward(int) - Method in interface org.apache.poi.hwpf.model.CharIndexTranslator
Return last index <= bytePos that is in table
lookIndexBackward(int) - Method in class org.apache.poi.hwpf.model.TextPieceTable

lookIndexForward(int) - Method in interface org.apache.poi.hwpf.model.CharIndexTranslator
Return first index >= bytePos that is in table
lookIndexForward(int) - Method in class org.apache.poi.hwpf.model.TextPieceTable

lookup(int) - Method in class org.apache.poi.ddf.AbstractEscherOptRecord

Lookup - Class in org.apache.poi.ss.formula.functions
Implementation of Excel function LOOKUP.
LOOKUP finds an index row in a lookup table by the first column value and returns the value from another column.
Lookup() - Constructor for class org.apache.poi.ss.formula.functions.Lookup

lookup(Comparable, int) - Method in class org.apache.poi.util.BinaryTree
do the actual lookup of a piece of data
lookupIndex(String) - Static method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
Resolves internal function names into function indexes.
lookupIndexByName(String) - Static method in class org.apache.poi.ss.formula.function.FunctionMetadataRegistry
Resolves a built-in function index.
lookupName(short) - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

LOWER - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

LSTFAbstractType - Class in org.apache.poi.hwpf.model.types
The LSTF structure contains formatting properties that apply to an entire list.
LSTFAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.LSTFAbstractType

LT - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

LT - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Less than' operator
LVLFAbstractType - Class in org.apache.poi.hwpf.model.types
The LVLF structure contains formatting properties for an individual level in a list.
LVLFAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.LVLFAbstractType

LZW_RTF_PRELOAD - Static variable in class org.apache.poi.hmef.CompressedRTF

LZWDecompresser - Class in org.apache.poi.util
This class provides common functionality for the various LZW implementations in the different file formats.
LZWDecompresser(boolean, int, boolean) - Constructor for class org.apache.poi.util.LZWDecompresser

M

M_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

MACRO - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

MACRO_ADDIN_WORKBOOK - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

MACRO_DOCUMENT - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

MACRO_TEMPLATE - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

MACRO_TEMPLATE_DOCUMENT - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

MACRO_TEMPLATE_WORKBOOK - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

MACROS_WORKBOOK - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

MAIL_PERMISSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

main(String[]) - Static method in class org.apache.poi.ddf.EscherDump
A simple test stub.
main(String[]) - Static method in class org.apache.poi.dev.OOXMLLister

main(String[]) - Static method in class org.apache.poi.dev.RecordGenerator
The main program for the RecordGenerator class
main(String[]) - Static method in class org.apache.poi.extractor.CommandLineTextExtractor

main(String[]) - Static method in class org.apache.poi.hdgf.dev.VSDDumper

main(String[]) - Static method in class org.apache.poi.hdgf.extractor.VisioTextExtractor

main(String[]) - Static method in class org.apache.poi.hdgf.HDGFDiagram
For testing only
main(String[]) - Static method in class org.apache.poi.hmef.dev.HMEFDumper

main(String[]) - Static method in class org.apache.poi.hmef.extractor.HMEFContentsExtractor

main(String[]) - Static method in class org.apache.poi.hpbf.dev.HPBFDumper

main(String[]) - Static method in class org.apache.poi.hpbf.dev.PLCDumper

main(String[]) - Static method in class org.apache.poi.hpbf.extractor.PublisherTextExtractor

main(String[]) - Static method in class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

main(String[]) - Static method in class org.apache.poi.hpsf.wellknown.PropertyIDMap
For the most basic testing.
main(String[]) - Static method in class org.apache.poi.hslf.dev.PPDrawingTextListing

main(String[]) - Static method in class org.apache.poi.hslf.dev.PPTXMLDump

main(String[]) - Static method in class org.apache.poi.hslf.dev.SlideAndNotesAtomListing

main(String[]) - Static method in class org.apache.poi.hslf.dev.SlideIdListing

main(String[]) - Static method in class org.apache.poi.hslf.dev.SlideShowDumper
right now this function takes one parameter: a ppt file, and outputs a dump of what it contains
main(String[]) - Static method in class org.apache.poi.hslf.dev.SlideShowRecordDumper
right now this function takes one parameter: a ppt file, and outputs a dump of what it contains
main(String[]) - Static method in class org.apache.poi.hslf.dev.SLWTListing

main(String[]) - Static method in class org.apache.poi.hslf.dev.SLWTTextListing

main(String[]) - Static method in class org.apache.poi.hslf.dev.TextStyleListing

main(String[]) - Static method in class org.apache.poi.hslf.dev.UserEditAndPersistListing

main(String[]) - Static method in class org.apache.poi.hslf.extractor.ImageExtractor

main(String[]) - Static method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Basic extractor.
main(String[]) - Static method in class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
Really basic text extractor, that will also return lots of crud text.
main(String[]) - Static method in class org.apache.poi.hsmf.dev.HSMFDump

main(String[]) - Static method in class org.apache.poi.hsmf.dev.TypesLister

main(String[]) - Static method in class org.apache.poi.hsmf.extractor.OutlookTextExtactor

main(String[]) - Static method in class org.apache.poi.hssf.converter.ExcelToFoConverter
Java main() interface to interact with ExcelToFoConverter
main(String[]) - Static method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter
Java main() interface to interact with ExcelToHtmlConverter
main(String[]) - Static method in class org.apache.poi.hssf.dev.BiffViewer
Method main with 1 argument just run straight biffview against given file
main(String[]) - Static method in class org.apache.poi.hssf.dev.EFBiffViewer

main(String[]) - Static method in class org.apache.poi.hssf.dev.FormulaViewer
Method main pass me a filename and I'll try and parse the formulas from it
main(String[]) - Static method in class org.apache.poi.hssf.dev.RecordLister

main(String[]) - Static method in class org.apache.poi.hssf.extractor.ExcelExtractor
Command line extractor.
main - Variable in class org.apache.poi.hssf.record.PageBreakRecord.Break

main(String[]) - Static method in class org.apache.poi.hwpf.converter.WordToFoConverter
Java main() interface to interact with WordToFoConverter
main(String[]) - Static method in class org.apache.poi.hwpf.converter.WordToHtmlConverter
Java main() interface to interact with WordToHtmlConverter
main(String[]) - Static method in class org.apache.poi.hwpf.converter.WordToTextConverter
Java main() interface to interact with WordToTextConverter
main(String[]) - Static method in class org.apache.poi.hwpf.dev.HWPFLister

main(String[]) - Static method in class org.apache.poi.hwpf.extractor.WordExtractor
Command line extractor, so people will stop moaning that they can't just run this.
main(String[]) - Static method in class org.apache.poi.hwpf.QuickTest

main(String[]) - Static method in class org.apache.poi.poifs.dev.POIFSDump

main(String[]) - Static method in class org.apache.poi.poifs.dev.POIFSHeaderDumper
Display the entries of multiple POIFS files
main(String[]) - Static method in class org.apache.poi.poifs.dev.POIFSLister
Display the entries of multiple POIFS files
main(String[]) - Static method in class org.apache.poi.poifs.dev.POIFSViewer
Display the contents of multiple POIFS files
main(String[]) - Static method in class org.apache.poi.poifs.eventfilesystem.POIFSReader
read in files
main(String[]) - Static method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
read in a file and write it back out again
main(String[]) - Static method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
read in a file and write it back out again
main(String[]) - Static method in class org.apache.poi.util.DrawingDump

main(String[]) - Static method in class org.apache.poi.util.FontMetricsDumper

main(String[]) - Static method in class org.apache.poi.util.HexDump

main(String[]) - Static method in class org.apache.poi.util.OOXMLLite

main(String[]) - Static method in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

MAIN - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

main(String[]) - Static method in class org.apache.poi.xslf.util.PPTX2PNG

main(String[]) - Static method in class org.apache.poi.xssf.dev.XSSFDump

main(String[]) - Static method in class org.apache.poi.xssf.dev.XSSFSave

main(String[]) - Static method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

main(String[]) - Static method in class org.apache.poi.xssf.extractor.XSSFExcelExtractor

main(String[]) - Static method in class org.apache.poi.xwpf.extractor.XWPFWordExtractor

MainContents - Class in org.apache.poi.hpbf.model
The main Contents.
MainContents(DirectoryNode) - Constructor for class org.apache.poi.hpbf.model.MainContents

MainMaster - Class in org.apache.poi.hslf.record
Master slide
MainMaster(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.MainMaster
Set things up, and find our more interesting children
MainMaster - Static variable in class org.apache.poi.hslf.record.RecordTypes

makeHex(short) - Method in class org.apache.poi.hslf.dev.SlideShowDumper

makeHex(int) - Method in class org.apache.poi.hslf.dev.SlideShowDumper

makeHex(int, int) - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

MANAGER_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MANUAL - Static variable in class org.apache.poi.hssf.record.CalcModeRecord
manually calculate formulas (0)
ManualLayout - Interface in org.apache.poi.ss.usermodel.charts
High level representation of chart element manual layout.
ManuallyPositionable - Interface in org.apache.poi.ss.usermodel.charts
Abstraction of chart element that can be positioned with manual layout.
MAPIAttribute - Class in org.apache.poi.hmef.attribute
A pure-MAPI attribute which applies to a HMEFMessage or one of its Attachments.
MAPIAttribute(MAPIProperty, int, byte[]) - Constructor for class org.apache.poi.hmef.attribute.MAPIAttribute
Constructs a single new attribute from the contents of the stream
MAPIDateAttribute - Class in org.apache.poi.hmef.attribute
A pure-MAPI attribute holding a Date, which applies to a HMEFMessage or one of its Attachments.
MAPIDateAttribute(MAPIProperty, int, byte[]) - Constructor for class org.apache.poi.hmef.attribute.MAPIDateAttribute
Constructs a single new date attribute from the id, type, and the contents of the stream
MAPIMessage - Class in org.apache.poi.hsmf
Reads an Outlook MSG File in and provides hooks into its data structure.
MAPIMessage() - Constructor for class org.apache.poi.hsmf.MAPIMessage
Constructor for creating new files.
MAPIMessage(String) - Constructor for class org.apache.poi.hsmf.MAPIMessage
Constructor for reading MSG Files from the file system.
MAPIMessage(InputStream) - Constructor for class org.apache.poi.hsmf.MAPIMessage
Constructor for reading MSG Files from an input stream.
MAPIMessage(POIFSFileSystem) - Constructor for class org.apache.poi.hsmf.MAPIMessage
Constructor for reading MSG Files from a POIFS filesystem
MAPIMessage(NPOIFSFileSystem) - Constructor for class org.apache.poi.hsmf.MAPIMessage
Constructor for reading MSG Files from a POIFS filesystem
MAPIMessage(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hsmf.MAPIMessage
Deprecated. Use MAPIMessage.MAPIMessage(DirectoryNode) instead
MAPIMessage(DirectoryNode) - Constructor for class org.apache.poi.hsmf.MAPIMessage
Constructor for reading MSG Files from a certain point within a POIFS filesystem
MapInfo - Class in org.apache.poi.xssf.model
This class implements the Custom XML Mapping Part (Open Office XML Part 1: chapter 12.3.6) An instance of this part type contains a schema for an XML file, and information on the behavior that is used when allowing this custom XML schema to be mapped into the spreadsheet.
MapInfo() - Constructor for class org.apache.poi.xssf.model.MapInfo

MapInfo(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.model.MapInfo

mapiProperty - Variable in class org.apache.poi.hmef.attribute.TNEFProperty
Equivalent MAPI Property
MAPIProperty - Class in org.apache.poi.hsmf.datatypes
Holds the list of MAPI Attributes, and allows lookup by friendly name, ID and MAPI Property Name.
mapiProperty - Variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MAPIRtfAttribute - Class in org.apache.poi.hmef.attribute
A pure-MAPI attribute holding RTF (compressed or not), which applies to a HMEFMessage or one of its Attachments.
MAPIRtfAttribute(MAPIProperty, int, byte[]) - Constructor for class org.apache.poi.hmef.attribute.MAPIRtfAttribute

MAPIStringAttribute - Class in org.apache.poi.hmef.attribute
A pure-MAPI attribute holding a String, which applies to a HMEFMessage or one of its Attachments.
MAPIStringAttribute(MAPIProperty, int, byte[]) - Constructor for class org.apache.poi.hmef.attribute.MAPIStringAttribute

MAPPING_SIGNATURE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

mapsTo(long) - Method in class org.apache.poi.xssf.usermodel.XSSFTable
Checks if this Table element contains even a single mapping to the map identified by id
Margin - Interface in org.apache.poi.hssf.record
The margin interface is a parent used to define left, right, top and bottom margins.
mark(int) - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

mark(int) - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

mark(int) - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

mark(int) - Method in class org.apache.poi.util.BlockingInputStream

markDeleted(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

markDeleted(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

markInserted(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

markInserted(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

markSupported() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream
Tests if this input stream supports the mark and reset methods.
markSupported() - Method in class org.apache.poi.util.BlockingInputStream

MarkUnsupportedException - Exception in org.apache.poi.hpsf
This exception is thrown if an InputStream does not support the InputStream.mark(int) operation.
MarkUnsupportedException() - Constructor for exception org.apache.poi.hpsf.MarkUnsupportedException
Constructor
MarkUnsupportedException(String) - Constructor for exception org.apache.poi.hpsf.MarkUnsupportedException
Constructor
MarkUnsupportedException(Throwable) - Constructor for exception org.apache.poi.hpsf.MarkUnsupportedException
Constructor
MarkUnsupportedException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.MarkUnsupportedException
Constructor
MARKUP_COMPATIBILITY - Static variable in interface org.apache.poi.openxml4j.opc.PackageNamespaces
Markup Compatibility.
marshall(PackagePart, OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller
Save part in the output stream by using the save() method of the part.
marshall(PackagePart, OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller
Marshall package core properties to an XML document.
marshall(PackagePart, OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller

marshall(PackagePart, OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller
Save the specified part.
marshall(PackagePart, OutputStream) - Method in interface org.apache.poi.openxml4j.opc.internal.PartMarshaller
Save the content of the package in the stream
marshallRelationshipPart(PackageRelationshipCollection, PackagePartName, ZipOutputStream) - Static method in class org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller
Save relationships into the part.
mask - Variable in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

maskInHeader - Variable in class org.apache.poi.hslf.model.textproperties.TextProp

MASTER - Static variable in class org.apache.poi.hslf.record.SlideListWithText
Instance filed of the record header indicates that this SlideListWithText stores references to master slides
MASTER_DPI - Static variable in class org.apache.poi.hslf.model.Shape
Master DPI (576 pixels per inch).
MASTER_NOTES - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

MASTER_SLIDE - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

MASTER_SLIDE_ID - Static variable in class org.apache.poi.hslf.record.SlideAtom

MasterBody - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the master body text.
MasterCenteredTitle - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the master center title text.
MasterDate - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the date text field.
MasterFooter - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a footer text field.
MasterHeader - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a header text field.
MasterNotesBody - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the master body text.
MasterNotesSlideImage - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the shared properties for slide image shapes.
MasterSheet - Class in org.apache.poi.hslf.model
The superclass of all master sheets - Slide masters, Notes masters, etc.
MasterSheet(SheetContainer, int) - Constructor for class org.apache.poi.hslf.model.MasterSheet

MasterSheet - Interface in org.apache.poi.sl.usermodel

MasterSlideNumber - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a slide number text field.
MasterSubTitle - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the master sub-title text.
MasterTitle - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the master title text.
Match - Class in org.apache.poi.ss.formula.functions
Implementation for the MATCH() Excel function.
Syntax:
MATCH(lookup_value, lookup_array, match_type)
Returns a 1-based index specifying at what position in the lookup_array the specified lookup_value is found.
Specific matching behaviour can be modified with the optional match_type parameter.
Match() - Constructor for class org.apache.poi.ss.formula.functions.Match

matchSignature(byte[]) - Method in enum org.apache.poi.hwpf.usermodel.PictureType

MATH_DIVIDE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

MATH_EQUAL - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

MATH_MINUS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

MATH_MULTIPLY - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

MATH_NOT_EQUAL - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

MATH_PLUS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

MAX - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

MAX_BUCKETS - Static variable in class org.apache.poi.hssf.record.ExtSSTRecord

MAX_ID - Static variable in class org.apache.poi.util.IdentifierManager

MAX_RECORD_DATA_SIZE - Static variable in class org.apache.poi.hssf.record.RecordInputStream
Maximum size of a single record (minus the 4 byte header) without a continue
MAXA - Static variable in class org.apache.poi.ss.formula.functions.MinaMaxa

MaxExpression - Class in org.apache.poi.xslf.model.geom
Maximum Value Formula
MDB_PROVIDER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MediaClip - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a media object.
MEDIAN - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

MEDIUM - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

MEDIUM_DASH_DOT - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

MEDIUM_DASH_DOT_DOT - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

MEDIUM_DASHED - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

MemAreaPtg - Class in org.apache.poi.ss.formula.ptg

MemAreaPtg(int) - Constructor for class org.apache.poi.ss.formula.ptg.MemAreaPtg
Creates new MemAreaPtg
MemAreaPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.MemAreaPtg

MemErrPtg - Class in org.apache.poi.ss.formula.ptg

MemErrPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.MemErrPtg

MemFuncPtg - Class in org.apache.poi.ss.formula.ptg

MemFuncPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.MemFuncPtg
Creates new function pointer from a byte array usually called while reading an excel file.
MemFuncPtg(int) - Constructor for class org.apache.poi.ss.formula.ptg.MemFuncPtg

MemoryPackagePart - Class in org.apache.poi.openxml4j.opc.internal
Memory version of a package part.
MemoryPackagePart(OPCPackage, PackagePartName, String) - Constructor for class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart
Constructor.
MemoryPackagePart(OPCPackage, PackagePartName, String, boolean) - Constructor for class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart
Constructor.
MemoryPackagePartOutputStream - Class in org.apache.poi.openxml4j.opc.internal
Build an output stream for MemoryPackagePart.
MemoryPackagePartOutputStream(MemoryPackagePart) - Constructor for class org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream

mergeCellRanges(CellRangeAddress[]) - Static method in class org.apache.poi.hssf.record.cf.CellRangeUtil
Do all possible cell merges between cells of the list so that:
if a cell range is completely inside of another cell range, it gets removed from the list if two cells have a shared border, merge them into one bigger cell range
mergeCells(int, int, int, int) - Method in class org.apache.poi.xslf.usermodel.XSLFTable
Merge cells of a table
MergeCellsRecord - Class in org.apache.poi.hssf.record
Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.
MergeCellsRecord(CellRangeAddress[], int, int) - Constructor for class org.apache.poi.hssf.record.MergeCellsRecord

MergeCellsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.MergeCellsRecord
Constructs a MergedCellsRecord and sets its fields appropriately
MergedCellsTable - Class in org.apache.poi.hssf.record.aggregates

MergedCellsTable() - Constructor for class org.apache.poi.hssf.record.aggregates.MergedCellsTable
Creates an empty aggregate
MESSAGE_ATTACHMENTS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_CC_ME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_CLASS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_CODEPAGE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_DELIVERY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_DELIVERY_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_DOWNLOAD_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_FLAGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_RECIP_ME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_RECIPIENTS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_SECURITY_LABEL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_SIZE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_SUBMISSION_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_TO_ME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MESSAGE_TOKEN - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

messageClass - Variable in class org.apache.poi.hsmf.datatypes.Chunks
Type of message that the MSG represents (ie.
messageHeaders - Variable in class org.apache.poi.hsmf.datatypes.Chunks
The email headers
messageId - Variable in class org.apache.poi.hsmf.datatypes.Chunks
The message ID
MessageSubmissionChunk - Class in org.apache.poi.hsmf.datatypes
A Chunk that holds the details given back by the server at submission time.
MessageSubmissionChunk(String, int, int) - Constructor for class org.apache.poi.hsmf.datatypes.MessageSubmissionChunk
Creates a Byte Chunk.
MessageSubmissionChunk(int, int) - Constructor for class org.apache.poi.hsmf.datatypes.MessageSubmissionChunk
Create a Byte Chunk, with the specified type.
Metafile - Class in org.apache.poi.hslf.blip
Represents a metafile picture which can be one of the following types: EMF, WMF, or PICT.
Metafile() - Constructor for class org.apache.poi.hslf.blip.Metafile

MetaFile - Static variable in class org.apache.poi.hslf.record.RecordTypes

Metafile.Header - Class in org.apache.poi.hslf.blip
A structure which represents a 34-byte header preceeding the compressed metafile data
Metafile.Header() - Constructor for class org.apache.poi.hslf.blip.Metafile.Header

MHS_COMMON_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MID - Static variable in class org.apache.poi.ss.formula.functions.TextFunction
An implementation of the MID function
MID returns a specific number of characters from a text string, starting at the specified position.
Syntax:
MID(text, start_num, num_chars)
Author: Manda Wilson < wilson at c bio dot msk cc dot org >
MIDDLE_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MIN - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

MIN_ID - Static variable in class org.apache.poi.util.IdentifierManager

MINA - Static variable in class org.apache.poi.ss.formula.functions.MinaMaxa

MinaMaxa - Class in org.apache.poi.ss.formula.functions

MinaMaxa() - Constructor for class org.apache.poi.ss.formula.functions.MinaMaxa

MinExpression - Class in org.apache.poi.xslf.model.geom
Minimum Value Formula
MINI_ICON - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MINUTE - Static variable in class org.apache.poi.ss.formula.functions.CalendarFieldFunction

MissingArgEval - Class in org.apache.poi.ss.formula.eval
Represents the (intermediate) evaluated result of a missing function argument.
MissingArgPtg - Class in org.apache.poi.ss.formula.ptg
Missing Function Arguments Avik Sengupta <avik at apache.org>
MissingCellDummyRecord - Class in org.apache.poi.hssf.eventusermodel.dummyrecord
A dummy record for when we're missing a cell in a row, but still want to trigger something
MissingCellDummyRecord(int, int) - Constructor for class org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord

MissingRecordAwareHSSFListener - Class in org.apache.poi.hssf.eventusermodel
A HSSFListener which tracks rows and columns, and will trigger your HSSFListener for all rows and cells, even the ones that aren't actually stored in the file.
MissingRecordAwareHSSFListener(HSSFListener) - Constructor for class org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener
Constructs a new MissingRecordAwareHSSFListener, which will fire processRecord on the supplied child HSSFListener for all Records, and missing records.
MissingRowDummyRecord - Class in org.apache.poi.hssf.eventusermodel.dummyrecord
A dummy record for when we're missing a row, but still want to trigger something
MissingRowDummyRecord(int) - Constructor for class org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord

MissingSectionException - Exception in org.apache.poi.hpsf
This exception is thrown if one of the PropertySet's convenience methods does not find a required Section.
MissingSectionException() - Constructor for exception org.apache.poi.hpsf.MissingSectionException
Constructor
MissingSectionException(String) - Constructor for exception org.apache.poi.hpsf.MissingSectionException
Constructor
MissingSectionException(Throwable) - Constructor for exception org.apache.poi.hpsf.MissingSectionException
Constructor
MissingSectionException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.MissingSectionException
Constructor
MM_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

MMMMM_START_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

MMMMM_TRUNCATE_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

MMSRecord - Class in org.apache.poi.hssf.record
Title: MMS Record
MMSRecord() - Constructor for class org.apache.poi.hssf.record.MMSRecord

MMSRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.MMSRecord

MOBILE_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MOD - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

Mode - Class in org.apache.poi.ss.formula.functions

Mode() - Constructor for class org.apache.poi.ss.formula.functions.Mode

MODE_CBC - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

MODE_CFB - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

MODE_ECB - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

ModExpression - Class in org.apache.poi.xslf.model.geom
Modulo Formula:
MODIFIED - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

modified - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Date on which the resource was changed.
MODIFY_VERSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

modifyFormatRun(short, short) - Method in class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

MONTH - Static variable in class org.apache.poi.ss.formula.functions.CalendarFieldFunction

Moon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

MOON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

MOVE_AND_RESIZE - Static variable in interface org.apache.poi.ss.usermodel.ClientAnchor
Move and Resize With Anchor Cells
MOVE_DONT_RESIZE - Static variable in interface org.apache.poi.ss.usermodel.ClientAnchor
Move With Cells but Do Not Resize
moveCell(HSSFCell, short) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Moves the supplied cell to a new column, which must not already have a cell there!
moveChildBefore(Record, Record) - Method in class org.apache.poi.hslf.record.RecordContainer
Moves the given Child Record to before the supplied record
moveChildrenAfter(Record, int, Record) - Method in class org.apache.poi.hslf.record.RecordContainer
Moves the given Child Records to after the supplied record
moveChildrenBefore(Record, int, Record) - Method in class org.apache.poi.hslf.record.RecordContainer
Moves the given Child Records to before the supplied record
moveTo(float, float) - Method in class org.apache.poi.hslf.model.Shape
Moves the top left corner of the shape to the specified point.
moveTo(int, int) - Method in class org.apache.poi.hslf.model.ShapeGroup
Moves this ShapeGroup to the specified location.
moveTo(float, float) - Method in interface org.apache.poi.sl.usermodel.Shape

MoveToCommand - Class in org.apache.poi.xslf.model.geom
Date: 10/25/11
MOVIE_AVI - Static variable in class org.apache.poi.hslf.model.MovieShape

MOVIE_MPEG - Static variable in class org.apache.poi.hslf.model.MovieShape

MovieShape - Class in org.apache.poi.hslf.model
Represents a movie in a PowerPoint document.
MovieShape(int, int) - Constructor for class org.apache.poi.hslf.model.MovieShape
Create a new Picture
MovieShape(int, int, Shape) - Constructor for class org.apache.poi.hslf.model.MovieShape
Create a new Picture
MovieShape(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.MovieShape
Create a Picture object
MSG_STATUS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

MSOBI_DIB - Static variable in class org.apache.poi.hssf.usermodel.HSSFPictureData

MSOBI_EMF - Static variable in class org.apache.poi.hssf.usermodel.HSSFPictureData

MSOBI_JPEG - Static variable in class org.apache.poi.hssf.usermodel.HSSFPictureData

MSOBI_PICT - Static variable in class org.apache.poi.hssf.usermodel.HSSFPictureData

MSOBI_PNG - Static variable in class org.apache.poi.hssf.usermodel.HSSFPictureData

MSOBI_WMF - Static variable in class org.apache.poi.hssf.usermodel.HSSFPictureData

MulBlankRecord - Class in org.apache.poi.hssf.record
Title: Multiple Blank cell record(0x00BE)
Description: Represents a set of columns in a row with no value but with styling.
MulBlankRecord(int, int, short[]) - Constructor for class org.apache.poi.hssf.record.MulBlankRecord

MulBlankRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.MulBlankRecord

MulRKRecord - Class in org.apache.poi.hssf.record
MULRK (0x00BD)
Used to store multiple RK numbers on a row.
MulRKRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.MulRKRecord

MultiOperandNumericFunction - Class in org.apache.poi.ss.formula.functions

MultiOperandNumericFunction(boolean, boolean) - Constructor for class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction

MultiplyDivideExpression - Class in org.apache.poi.xslf.model.geom
Multiply Divide Formula
MultiplyEval - Static variable in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

MultiplyPtg - Class in org.apache.poi.ss.formula.ptg
Implements the standard mathmatical multiplication - *
MULTIVALUED_FLAG - Static variable in class org.apache.poi.hsmf.datatypes.Types
MultiValued - Value part contains multiple values
MutableByteArrayOutputStream - Class in org.apache.poi.hslf.util
This class doesn't work yet, but is here to show the idea of a ByteArrayOutputStream where you can track how many bytes you've already written, and go back and write over a previous part of the stream
MutableByteArrayOutputStream() - Constructor for class org.apache.poi.hslf.util.MutableByteArrayOutputStream

MutableProperty - Class in org.apache.poi.hpsf
Adds writing capability to the Property class.
MutableProperty() - Constructor for class org.apache.poi.hpsf.MutableProperty
Creates an empty property.
MutableProperty(Property) - Constructor for class org.apache.poi.hpsf.MutableProperty
Creates a MutableProperty as a copy of an existing Property.
MutablePropertySet - Class in org.apache.poi.hpsf
Adds writing support to the PropertySet class.
MutablePropertySet() - Constructor for class org.apache.poi.hpsf.MutablePropertySet
Constructs a MutablePropertySet instance.
MutablePropertySet(PropertySet) - Constructor for class org.apache.poi.hpsf.MutablePropertySet
Constructs a MutablePropertySet by doing a deep copy of an existing PropertySet.
MutableSection - Class in org.apache.poi.hpsf
Adds writing capability to the Section class.
MutableSection() - Constructor for class org.apache.poi.hpsf.MutableSection
Creates an empty mutable section.
MutableSection(Section) - Constructor for class org.apache.poi.hpsf.MutableSection
Constructs a MutableSection by doing a deep copy of an existing Section.
myLastOnDiskOffset - Variable in class org.apache.poi.hslf.record.ExOleObjStg
Our location on the disk, as of the last write out
myLastOnDiskOffset - Variable in class org.apache.poi.hslf.record.PositionDependentRecordAtom
Our location on the disk, as of the last write out
myLastOnDiskOffset - Variable in class org.apache.poi.hslf.record.PositionDependentRecordContainer
Our location on the disk, as of the last write out

N

N_A - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg
#N/A - Argument or function not available
NA - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval
#N/A - Argument or function not available
Na - Class in org.apache.poi.ss.formula.functions
Implementation of Excel function NA()
Na() - Constructor for class org.apache.poi.ss.formula.functions.Na

name - Variable in class org.apache.poi.hmef.attribute.TNEFProperty
Property Name
name - Variable in class org.apache.poi.hslf.model.PPFont

NAME - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

NAME - Static variable in class org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

name - Variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Name - Interface in org.apache.poi.ss.usermodel
Represents a defined name for a range of cells.
NAME_INVALID - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval
#NAME? - Wrong function or range name
NAME_INVALID - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg
#NAME? - Wrong function or range name
NameCommentRecord - Class in org.apache.poi.hssf.record
Title: NAMECMT Record (0x0894)
Description: Defines a comment associated with a specified name.
NameCommentRecord(String, String) - Constructor for class org.apache.poi.hssf.record.NameCommentRecord

NameCommentRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.NameCommentRecord

NAMEDRANGE - Static variable in class org.apache.poi.ss.formula.FormulaType

NamedShow - Static variable in class org.apache.poi.hslf.record.RecordTypes

NamedShows - Static variable in class org.apache.poi.hslf.record.RecordTypes

NamedShowSlides - Static variable in class org.apache.poi.hslf.record.RecordTypes

NameEval - Class in org.apache.poi.ss.formula.eval

NameEval(String) - Constructor for class org.apache.poi.ss.formula.eval.NameEval
Creates a NameEval representing a function name
NameIdChunks - Class in org.apache.poi.hsmf.datatypes
Collection of convenience chunks for the NameID part of an outlook file
NameIdChunks() - Constructor for class org.apache.poi.hsmf.datatypes.NameIdChunks

namePrefix - Variable in class org.apache.poi.hsmf.datatypes.Chunk

NamePtg - Class in org.apache.poi.ss.formula.ptg

NamePtg(int) - Constructor for class org.apache.poi.ss.formula.ptg.NamePtg

NamePtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.NamePtg
Creates new NamePtg
NameRecord - Class in org.apache.poi.hssf.record
Title: DEFINEDNAME Record (0x0018)
Description: Defines a named range within a workbook.
NameRecord() - Constructor for class org.apache.poi.hssf.record.NameRecord
Creates new NameRecord
NameRecord(byte, int) - Constructor for class org.apache.poi.hssf.record.NameRecord
Constructor to create a built-in named region
NameRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.NameRecord
called by the constructor, should set class level fields.
nameSet() - Method in class org.apache.poi.hpsf.CustomProperties
Returns a set of all the names of our custom properties
NAMESPACE_A - Static variable in class org.apache.poi.xssf.usermodel.XSSFDrawing

NAMESPACE_C - Static variable in class org.apache.poi.xssf.usermodel.XSSFDrawing

NAMESPACE_CP_URI - Static variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

NAMESPACE_DC - Static variable in interface org.apache.poi.openxml4j.opc.PackageProperties
Dublin Core namespace URI.
NAMESPACE_DC_URI - Static variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

NAMESPACE_DCTERMS - Static variable in interface org.apache.poi.openxml4j.opc.PackageProperties
Dublin Core Terms URI.
NAMESPACE_DCTERMS_URI - Static variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

NAMESPACE_XSI_URI - Static variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

NameXEval - Class in org.apache.poi.ss.formula.eval

NameXEval(NameXPtg) - Constructor for class org.apache.poi.ss.formula.eval.NameXEval

NameXPtg - Class in org.apache.poi.ss.formula.ptg

NameXPtg(int, int) - Constructor for class org.apache.poi.ss.formula.ptg.NameXPtg

NameXPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.NameXPtg

NDocumentInputStream - Class in org.apache.poi.poifs.filesystem
This class provides methods to read a DocumentEntry managed by a NPOIFSFileSystem instance.
NDocumentInputStream(DocumentEntry) - Constructor for class org.apache.poi.poifs.filesystem.NDocumentInputStream
Create an InputStream from the specified DocumentEntry
NDocumentInputStream(NPOIFSDocument) - Constructor for class org.apache.poi.poifs.filesystem.NDocumentInputStream
Create an InputStream from the specified Document
NDR_DIAG_CODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NDR_REASON_CODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NDR_STATUS_CODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

needsRelationToo() - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Do we need to a relation too, to represent this hyperlink?
newAutoFilterInstance() - Static method in class org.apache.poi.hssf.record.LbsDataSubRecord

newComment() - Method in class org.apache.poi.xssf.model.CommentsTable

newCommentShape() - Method in class org.apache.poi.xssf.usermodel.XSSFVMLDrawing

newDocumentLink() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Initialize a new document link
newDocumentPart(POIXMLRelation) - Method in class org.apache.poi.POIXMLFactory
Create a new POIXMLDocumentPart using the supplied descriptor.
newDocumentPart(POIXMLRelation) - Method in class org.apache.poi.xslf.usermodel.XSLFFactory

newDocumentPart(POIXMLRelation) - Method in class org.apache.poi.xssf.usermodel.XSSFFactory

newDocumentPart(POIXMLRelation) - Method in class org.apache.poi.xwpf.usermodel.XWPFFactory

newDocumentSummaryInformation() - Static method in class org.apache.poi.hpsf.PropertySetFactory
Creates a new document summary information.
newFileLink() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Initialize a new file link
newPackage() - Static method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Create a new SpreadsheetML package and setup the default minimal content
newPackage() - Static method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Create a new WordProcessingML package and setup the default minimal content
newParagraph_applyStyleProperties(StyleSheet, PAPX, ParagraphProperties) - Static method in class org.apache.poi.hwpf.usermodel.Paragraph

NEWSGROUP_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

newSummaryInformation() - Static method in class org.apache.poi.hpsf.PropertySetFactory
Creates a new summary information.
newUrlLink() - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Initialize a new url link
next() - Method in class org.apache.poi.hwpf.sprm.SprmIterator

next() - Method in class org.apache.poi.hwpf.usermodel.TableIterator

next() - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator

next() - Method in class org.apache.poi.util.StringUtil.StringsIterator

next() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator
Returns input stream of the next sheet in the iteration
next() - Method in class org.apache.poi.xssf.streaming.SXSSFRow.CellIterator

next() - Method in class org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator

nextDecorator - Variable in class org.apache.poi.xwpf.model.XWPFParagraphDecorator

nextPid() - Method in class org.apache.poi.POIXMLProperties.CustomProperties
Generate next id that uniquely relates a custom property
nextRecord() - Method in class org.apache.poi.hssf.record.RecordFactoryInputStream
Returns the next (complete) record from the stream, or null if there are no more.
nextRecord() - Method in class org.apache.poi.hssf.record.RecordInputStream
Moves to the next record in the stream.
NFCPGN_ARABIC - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

NFCPGN_LETTER_LOWER_CASE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

NFCPGN_LETTER_UPPER_CASE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

NFCPGN_ROMAN_LOWER_CASE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

NFCPGN_ROMAN_UPPER_CASE - Static variable in class org.apache.poi.hwpf.model.types.SEPAbstractType

NICKNAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NIL_STYLE - Static variable in class org.apache.poi.hwpf.model.StyleSheet

NNTP_XREF - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NO_COMPARISON - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

NO_COMPARISON - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator

NO_FILL - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
No background
NO_FILL - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

NO_FILL - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
No background
NO_FILL - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
No background
NO_FONT - Static variable in class org.apache.poi.hssf.usermodel.HSSFRichTextString
Place holder for indicating that NO_FONT has been applied here
NO_INTERSECTION - Static variable in class org.apache.poi.hssf.record.cf.CellRangeUtil

NO_OVERLAPS - Static variable in class org.apache.poi.xssf.util.NumericRanges

NO_SELF_RELATIVE_SECURITY_FEATURE - Static variable in class org.apache.poi.hssf.record.common.FeatProtection

NO_SMOKING - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

NoFormatIDException - Exception in org.apache.poi.hpsf
This exception is thrown if a MutablePropertySet is to be written but does not have a formatID set (see MutableSection.setFormatID(ClassID) or MutableSection.setFormatID(byte[]).
NoFormatIDException() - Constructor for exception org.apache.poi.hpsf.NoFormatIDException
Constructor
NoFormatIDException(String) - Constructor for exception org.apache.poi.hpsf.NoFormatIDException
Constructor
NoFormatIDException(Throwable) - Constructor for exception org.apache.poi.hpsf.NoFormatIDException
Constructor
NoFormatIDException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.NoFormatIDException
Constructor
NON_ISOSCELES_TRAPEZOID - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

NON_RECEIPT_NOTIFICATION_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NON_RECEIPT_REASON - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

None - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
MUST NOT be used for this field.
NONE - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

NoPropertySetStreamException - Exception in org.apache.poi.hpsf
This exception is thrown if a format error in a property set stream is detected or when the input data do not constitute a property set stream.
NoPropertySetStreamException() - Constructor for exception org.apache.poi.hpsf.NoPropertySetStreamException
Constructor
NoPropertySetStreamException(String) - Constructor for exception org.apache.poi.hpsf.NoPropertySetStreamException
Constructor
NoPropertySetStreamException(Throwable) - Constructor for exception org.apache.poi.hpsf.NoPropertySetStreamException
Constructor
NoPropertySetStreamException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.NoPropertySetStreamException
Constructor
normalize(String) - Method in class org.apache.poi.hslf.model.TextRun
Returns a new string with line breaks converted into internal ppt representation
NORMALIZED_SUBJECT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NoSingleSectionException - Exception in org.apache.poi.hpsf
This exception is thrown if one of the PropertySet's convenience methods that require a single Section is called and the PropertySet does not contain exactly one Section.
NoSingleSectionException() - Constructor for exception org.apache.poi.hpsf.NoSingleSectionException
Constructor
NoSingleSectionException(String) - Constructor for exception org.apache.poi.hpsf.NoSingleSectionException
Constructor
NoSingleSectionException(Throwable) - Constructor for exception org.apache.poi.hpsf.NoSingleSectionException
Constructor
NoSingleSectionException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.NoSingleSectionException
Constructor
NoSmoking - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

NOT - Static variable in class org.apache.poi.ss.formula.functions.BooleanFunction

NOT_BETWEEN - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

NOT_BETWEEN - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Not between' operator
NOT_BETWEEN - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

NOT_EQUAL - Static variable in class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

NOT_EQUAL - Static variable in class org.apache.poi.ss.usermodel.ComparisonOperator
'Not equal to' operator
NOT_EQUAL - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

NOTCHED_RIGHT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

NotchedCircularArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

NotchedRightArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

NOTE8_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Note 8 1/2 x 11 in
NOTE_HIDDEN - Static variable in class org.apache.poi.hssf.record.NoteRecord
Flag indicating that the comment is hidden (default)
NOTE_VISIBLE - Static variable in class org.apache.poi.hssf.record.NoteRecord
Flag indicating that the comment is visible
NotEqualEval - Static variable in class org.apache.poi.ss.formula.eval.RelationalOperationEval

NotEqualPtg - Class in org.apache.poi.ss.formula.ptg
Ptg class to implement not equal
NoteRecord - Class in org.apache.poi.hssf.record
NOTE: Comment Associated with a Cell (0x001C)

NoteRecord() - Constructor for class org.apache.poi.hssf.record.NoteRecord
Construct a new NoteRecord and fill its data with the default values
NoteRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.NoteRecord
Read the record data from the supplied RecordInputStream
Notes - Class in org.apache.poi.hslf.model
This class represents a slide's notes in a PowerPoint Document.
Notes(Notes) - Constructor for class org.apache.poi.hslf.model.Notes
Constructs a Notes Sheet from the given Notes record.
Notes - Class in org.apache.poi.hslf.record
Master container for Notes.
Notes(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.Notes
Set things up, and find our more interesting children
Notes - Static variable in class org.apache.poi.hslf.record.RecordTypes

NOTES - Static variable in class org.apache.poi.hslf.record.SlideListWithText
Instance filed of the record header indicates that this SlideListWithText stores references to notes
Notes - Interface in org.apache.poi.hwpf.usermodel
User-friendly interface to access document notes information
Notes - Interface in org.apache.poi.sl.usermodel

NOTES - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

NOTES_MASTER - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

NOTES_TITLE_BODY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

NOTES_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

NotesAtom - Class in org.apache.poi.hslf.record
A Notes Atom (type 1009).
NotesAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.NotesAtom
For the Notes Atom
NotesAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

NotesBody - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the notes text.
NotesHeadersFootersContainer - Static variable in class org.apache.poi.hslf.record.HeadersFootersContainer
"instance" field in the record header indicating that this HeadersFootersContaine is applied for notes and handouts
NotesImpl - Class in org.apache.poi.hwpf.usermodel
Default implementation of Notes interface
NotesImpl(NotesTables) - Constructor for class org.apache.poi.hwpf.usermodel.NotesImpl

NotesSlideImage - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a presentation slide image.
NotesTables - Class in org.apache.poi.hwpf.model
Holds information about document notes (footnotes or ending notes)
NotesTables(NoteType) - Constructor for class org.apache.poi.hwpf.model.NotesTables

NotesTables(NoteType, byte[], FileInformationBlock) - Constructor for class org.apache.poi.hwpf.model.NotesTables

NoteStructureSubRecord - Class in org.apache.poi.hssf.record
ftNts (0x000D)
Represents a NoteStructure sub record.
NoteStructureSubRecord() - Constructor for class org.apache.poi.hssf.record.NoteStructureSubRecord
Construct a new NoteStructureSubRecord and fill its data with the default values
NoteStructureSubRecord(LittleEndianInput, int) - Constructor for class org.apache.poi.hssf.record.NoteStructureSubRecord
Read the record data from the supplied RecordInputStream
NoteType - Enum in org.apache.poi.hwpf.model

notifyDeleteCell(HSSFCell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Should be called to tell the cell value cache that the specified cell has just been deleted.
notifyDeleteCell(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator

notifyDeleteCell(EvaluationCell) - Method in class org.apache.poi.ss.formula.WorkbookEvaluator
Should be called to tell the cell value cache that the specified cell has just been deleted.
notifyDeleteCell(Cell) - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed
notifyDeleteCell(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator

notifyFormulaChanging() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate
Should be called by any code which is either deleting this formula cell, or changing its type.
notifySetFormula(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
notifySetFormula(Cell) - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
notifySetFormula(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator

notifyUpdateCell(HSSFCell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
notifyUpdateCell(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator

notifyUpdateCell(EvaluationCell) - Method in class org.apache.poi.ss.formula.WorkbookEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
notifyUpdateCell(Cell) - Method in interface org.apache.poi.ss.usermodel.FormulaEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
notifyUpdateCell(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator

notImplemented() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
TODO - (May-2008) fix subclasses of AreaPtg 'AreaN~' which are used in shared formulas.
NotImplementedException - Exception in org.apache.poi.ss.formula.eval
An exception thrown by implementors of FormulaEvaluator when attempting to evaluate a formula which requires features that POI does not (yet) support.
NotImplementedException(String) - Constructor for exception org.apache.poi.ss.formula.eval.NotImplementedException

NotImplementedException(String, NotImplementedException) - Constructor for exception org.apache.poi.ss.formula.eval.NotImplementedException

NotImplementedFunction - Class in org.apache.poi.ss.formula.functions

NotImplementedFunction() - Constructor for class org.apache.poi.ss.formula.functions.NotImplementedFunction

NotImplementedFunction(String) - Constructor for class org.apache.poi.ss.formula.functions.NotImplementedFunction

NotPrimitive - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Now - Class in org.apache.poi.ss.formula.functions
Implementation of Excel NOW() Function
Now() - Constructor for class org.apache.poi.ss.formula.functions.Now

NPER - Static variable in class org.apache.poi.ss.formula.functions.FinanceFunction

nper(double, double, double, double, boolean) - Static method in class org.apache.poi.ss.formula.functions.FinanceLib

NPOIFSDocument - Class in org.apache.poi.poifs.filesystem
This class manages a document in the NIO POIFS filesystem.
NPOIFSDocument(DocumentProperty, NPOIFSFileSystem) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSDocument
Constructor for an existing Document
NPOIFSDocument(String, NPOIFSFileSystem, InputStream) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSDocument
Constructor for a new Document
NPOIFSFileSystem - Class in org.apache.poi.poifs.filesystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
NPOIFSFileSystem() - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Constructor, intended for writing
NPOIFSFileSystem(File) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Creates a POIFSFileSystem from a File.
NPOIFSFileSystem(File, boolean) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Creates a POIFSFileSystem from a File.
NPOIFSFileSystem(FileChannel) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Creates a POIFSFileSystem from an open FileChannel.
NPOIFSFileSystem(InputStream) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Create a POIFSFileSystem from an InputStream.
NPOIFSMiniStore - Class in org.apache.poi.poifs.filesystem
This class handles the MiniStream (small block store) in the NIO case for NPOIFSFileSystem
NPOIFSMiniStore(NPOIFSFileSystem, RootProperty, List<BATBlock>, HeaderBlock) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSMiniStore

NPOIFSStream - Class in org.apache.poi.poifs.filesystem
This handles reading and writing a stream within a NPOIFSFileSystem.
NPOIFSStream(BlockStore, int) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSStream
Constructor for an existing stream.
NPOIFSStream(BlockStore) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSStream
Constructor for a new stream.
NPOIFSStream.StreamBlockByteBufferIterator - Class in org.apache.poi.poifs.filesystem
Class that handles a streaming read of one stream
NPOIFSStream.StreamBlockByteBufferIterator(int) - Constructor for class org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator

NPropertyTable - Class in org.apache.poi.poifs.property
This class embodies the Property Table for a NPOIFSFileSystem; this is basically the directory for all of the documents in the filesystem.
NPropertyTable(HeaderBlock) - Constructor for class org.apache.poi.poifs.property.NPropertyTable

NPropertyTable(HeaderBlock, NPOIFSFileSystem) - Constructor for class org.apache.poi.poifs.property.NPropertyTable
reading constructor (used when we've read in a file and we want to extract the property table from it).
npv(double, double[]) - Static method in class org.apache.poi.ss.formula.functions.FinanceLib
calculates the Net Present Value of a principal amount given the discount rate and a sequence of cash flows (supplied as an array).
Npv - Class in org.apache.poi.ss.formula.functions
Calculates the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values).
Npv() - Constructor for class org.apache.poi.ss.formula.functions.Npv

NT_SECURITY_DESCRIPTOR - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NULL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

NULL - Static variable in class org.apache.poi.hsmf.datatypes.Types
Null - NULL property value
NULL - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

NULL_INTERSECTION - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval
#NULL! - Intersection of two cell ranges is empty
NULL_INTERSECTION - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg
#NULL! - Intersection of two cell ranges is empty
Nullable<E> - Class in org.apache.poi.openxml4j.util
An immutable object that could be defined as null.
Nullable() - Constructor for class org.apache.poi.openxml4j.util.Nullable
Constructor.
Nullable(E) - Constructor for class org.apache.poi.openxml4j.util.Nullable
Constructor.
NullEscherSerializationListener - Class in org.apache.poi.ddf
Ignores all serialization events.
NullEscherSerializationListener() - Constructor for class org.apache.poi.ddf.NullEscherSerializationListener

nullify() - Method in class org.apache.poi.openxml4j.util.Nullable
Set the stored value to null.
NullLogger - Class in org.apache.poi.util
A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
NullLogger() - Constructor for class org.apache.poi.util.NullLogger

NUM_ERROR - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval
#NUM! - Value range overflow
NUM_ERROR - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg
#NUM! - Value range overflow
NumberComparer - Class in org.apache.poi.ss.util
Excel compares numbers using different rules to those of java, so Double.compare(double, double) won't do.
NumberComparer() - Constructor for class org.apache.poi.ss.util.NumberComparer

numberError() - Static method in exception org.apache.poi.ss.formula.eval.EvaluationException
#NUM! - Value range overflow
NumberEval - Class in org.apache.poi.ss.formula.eval

NumberEval(Ptg) - Constructor for class org.apache.poi.ss.formula.eval.NumberEval

NumberEval(double) - Constructor for class org.apache.poi.ss.formula.eval.NumberEval

NumberFormatIndexRecord - Class in org.apache.poi.hssf.record.chart
The number format index record indexes format table.
NumberFormatIndexRecord() - Constructor for class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

NumberFormatIndexRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

NumberFormatter - Class in org.apache.poi.hwpf.converter
Utility class to translate numbers in letters, usually for lists.
NumberFormatter() - Constructor for class org.apache.poi.hwpf.converter.NumberFormatter

numbering - Variable in class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

numbering - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

numbering - Variable in class org.apache.poi.xwpf.usermodel.XWPFNum

NUMBERING - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

numberOfPLCs - Variable in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

NumberPtg - Class in org.apache.poi.ss.formula.ptg
Number Stores a floating point value in a formula value stored in a 8 byte field using IEEE notation
NumberPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.NumberPtg

NumberPtg(String) - Constructor for class org.apache.poi.ss.formula.ptg.NumberPtg
Create a NumberPtg from a string representation of the number Number format is not checked, it is expected to be validated in the parser that calls this method.
NumberPtg(double) - Constructor for class org.apache.poi.ss.formula.ptg.NumberPtg

NumberRecord - Class in org.apache.poi.hssf.record
NUMBER (0x0203) Contains a numeric cell value.
NumberRecord() - Constructor for class org.apache.poi.hssf.record.NumberRecord
Creates new NumberRecord
NumberRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.NumberRecord

NumberToTextConverter - Class in org.apache.poi.ss.util
Excel converts numbers to text with different rules to those of java, so Double.toString(value) won't do.
numCells() - Method in class org.apache.poi.hwpf.usermodel.TableRow

numCharacterRuns() - Method in class org.apache.poi.hwpf.usermodel.Range

NumericFunction - Class in org.apache.poi.ss.formula.functions

NumericFunction() - Constructor for class org.apache.poi.ss.formula.functions.NumericFunction

NumericFunction.OneArg - Class in org.apache.poi.ss.formula.functions

NumericFunction.OneArg() - Constructor for class org.apache.poi.ss.formula.functions.NumericFunction.OneArg

NumericFunction.TwoArg - Class in org.apache.poi.ss.formula.functions

NumericFunction.TwoArg() - Constructor for class org.apache.poi.ss.formula.functions.NumericFunction.TwoArg

NumericRanges - Class in org.apache.poi.xssf.util

NumericRanges() - Constructor for class org.apache.poi.xssf.util.NumericRanges

NumericValueEval - Interface in org.apache.poi.ss.formula.eval

numExist(BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
Checks whether number with numID exists
numFormattingRuns() - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString

numFormattingRuns() - Method in interface org.apache.poi.ss.usermodel.RichTextString

numFormattingRuns() - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString

numLevels() - Method in class org.apache.poi.hwpf.model.ListData

numOverrides() - Method in class org.apache.poi.hwpf.model.ListFormatOverride

numPages() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

numParagraphs() - Method in class org.apache.poi.hwpf.usermodel.Range
Used to get the number of paragraphs in a range.
numRows() - Method in class org.apache.poi.hwpf.usermodel.Table

nums - Variable in class org.apache.poi.xwpf.usermodel.XWPFNumbering

numSections() - Method in class org.apache.poi.hwpf.usermodel.Range
Used to get the number of sections in a range.
numStyles() - Method in class org.apache.poi.hwpf.model.StyleSheet
Gets the number of styles in the style sheet.

O

Object - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a generic object.
OBJECT_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OBJECT_TYPE_ARC - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_BUTTON - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_CHART - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_CHECKBOX - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_COMBO_BOX - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_COMBO_BOX - Static variable in class org.apache.poi.hssf.usermodel.HSSFSimpleShape

OBJECT_TYPE_COMMENT - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_COMMENT - Static variable in class org.apache.poi.hssf.usermodel.HSSFSimpleShape

OBJECT_TYPE_DIALOG_BOX - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_EDIT_BOX - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_GROUP - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_GROUP_BOX - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_LABEL - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_LINE - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_LINE - Static variable in class org.apache.poi.hssf.usermodel.HSSFSimpleShape

OBJECT_TYPE_LIST_BOX - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING - Static variable in class org.apache.poi.hssf.model.PolygonShape

OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_OPTION_BUTTON - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_OVAL - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_OVAL - Static variable in class org.apache.poi.hssf.usermodel.HSSFSimpleShape

OBJECT_TYPE_PICTURE - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_PICTURE - Static variable in class org.apache.poi.hssf.usermodel.HSSFSimpleShape

OBJECT_TYPE_POLYGON - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RECTANGLE - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RECTANGLE - Static variable in class org.apache.poi.hssf.usermodel.HSSFSimpleShape

OBJECT_TYPE_RESERVED1 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED2 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED3 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED4 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED5 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED6 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED7 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED8 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_RESERVED9 - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_SCROLL_BAR - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_SPINNER - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_TEXT - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

OBJECT_TYPE_TEXT - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

OBJECT_TYPE_TEXT - Static variable in interface org.apache.poi.ss.usermodel.Textbox

ObjectData - Class in org.apache.poi.hslf.usermodel
A class that represents object data embedded in a slide show.
ObjectData(ExOleObjStg) - Constructor for class org.apache.poi.hslf.usermodel.ObjectData
Creates the object data wrapping the record that contains the object data.
ObjectLinkRecord - Class in org.apache.poi.hssf.record.chart
Links text to an object on the chart or identifies it as the title.

ObjectLinkRecord() - Constructor for class org.apache.poi.hssf.record.chart.ObjectLinkRecord

ObjectLinkRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ObjectLinkRecord

ObjectPoolImpl - Class in org.apache.poi.hwpf.usermodel

ObjectPoolImpl(DirectoryEntry) - Constructor for class org.apache.poi.hwpf.usermodel.ObjectPoolImpl

ObjectProtectRecord - Class in org.apache.poi.hssf.record
Title: Object Protect Record
ObjectProtectRecord() - Constructor for class org.apache.poi.hssf.record.ObjectProtectRecord

ObjectProtectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ObjectProtectRecord

ObjectsPool - Interface in org.apache.poi.hwpf.usermodel

ObjRecord - Class in org.apache.poi.hssf.record
OBJRECORD (0x005D)
The obj record is used to hold various graphic objects and controls.
ObjRecord() - Constructor for class org.apache.poi.hssf.record.ObjRecord

ObjRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ObjRecord

OBSOLETED_IPMS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Octagon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

OCTAGON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Odd - Class in org.apache.poi.ss.formula.functions

Odd() - Constructor for class org.apache.poi.ss.formula.functions.Odd

ODocumentInputStream - Class in org.apache.poi.poifs.filesystem
This class provides methods to read a DocumentEntry managed by a POIFSFileSystem instance.
ODocumentInputStream(DocumentEntry) - Constructor for class org.apache.poi.poifs.filesystem.ODocumentInputStream
Create an InputStream from the specified DocumentEntry
ODocumentInputStream(POIFSDocument) - Constructor for class org.apache.poi.poifs.filesystem.ODocumentInputStream
Create an InputStream from the specified Document
OEPlaceholderAtom - Class in org.apache.poi.hslf.record
OEPlaceholderAtom (3011).
OEPlaceholderAtom() - Constructor for class org.apache.poi.hslf.record.OEPlaceholderAtom
Create a new instance of OEPlaceholderAtom
OEPlaceholderAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.OEPlaceholderAtom
Build an instance of OEPlaceholderAtom from on-disk data
OEPlaceholderAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

OEShapeAtom - Class in org.apache.poi.hslf.record
Atom that contains information that describes shape client data.
OEShapeAtom() - Constructor for class org.apache.poi.hslf.record.OEShapeAtom
Constructs a brand new link related atom record.
OEShapeAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.OEShapeAtom
Constructs the link related atom record from its source data.
OEShapeAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

OFFICE2_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OFFICE_LOCATION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OFFICE_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OfficeDrawing - Interface in org.apache.poi.hwpf.usermodel
User-friendly interface to office drawing objects.
OfficeDrawing.HorizontalPositioning - Enum in org.apache.poi.hwpf.usermodel

OfficeDrawing.HorizontalRelativeElement - Enum in org.apache.poi.hwpf.usermodel

OfficeDrawing.VerticalPositioning - Enum in org.apache.poi.hwpf.usermodel

OfficeDrawing.VerticalRelativeElement - Enum in org.apache.poi.hwpf.usermodel

OfficeDrawings - Interface in org.apache.poi.hwpf.usermodel
User-friendly interface to access document part's office drawings
OfficeDrawingsImpl - Class in org.apache.poi.hwpf.usermodel

OfficeDrawingsImpl(FSPATable, EscherRecordHolder, byte[]) - Constructor for class org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl

OfficeXmlFileException - Exception in org.apache.poi.poifs.filesystem
This exception is thrown when we try to open a file that's actually an Office 2007+ XML file, rather than an OLE2 file (which is what POI works with)
OfficeXmlFileException(String) - Constructor for exception org.apache.poi.poifs.filesystem.OfficeXmlFileException

offset - Variable in class org.apache.poi.hdgf.pointers.Pointer

offset - Variable in class org.apache.poi.hpsf.Section

offset - Variable in class org.apache.poi.hslf.usermodel.PictureData
The offset to the picture in the stream
offset - Variable in class org.apache.poi.hwpf.dev.FieldIterator

offset(int, int, int, int) - Method in interface org.apache.poi.ss.formula.eval.AreaEval
Creates an AreaEval offset by a relative amount from from the upper left cell of this area
offset(int, int, int, int) - Method in interface org.apache.poi.ss.formula.eval.RefEval
Creates an AreaEval offset by a relative amount from this RefEval
Offset - Class in org.apache.poi.ss.formula.functions
Implementation for Excel function OFFSET()
OFFSET returns an area reference that is a specified number of rows and columns from a reference cell or area.
Syntax:
OFFSET(reference, rows, cols, height, width)
reference is the base reference.
rows is the number of rows up or down from the base reference.
cols is the number of columns left or right from the base reference.
height (default same height as base reference) is the row count for the returned area reference.
width (default same width as base reference) is the column count for the returned area reference.

Offset() - Constructor for class org.apache.poi.ss.formula.functions.Offset

OFFSET_CF - Static variable in class org.apache.poi.hpsf.Thumbnail
Offset in bytes where the Clipboard Format starts in the byte[] returned by SummaryInformation.getThumbnail()
OFFSET_CFTAG - Static variable in class org.apache.poi.hpsf.Thumbnail
Offset in bytes where the Clipboard Format Tag starts in the byte[] returned by SummaryInformation.getThumbnail()
OFFSET_WMFDATA - Static variable in class org.apache.poi.hpsf.Thumbnail
Offset in bytes where the Windows Metafile (WMF) image data starts in the byte[] returned by SummaryInformation.getThumbnail()
OldCHPBinTable - Class in org.apache.poi.hwpf.model
This class holds all of the character formatting properties from Old (Word 6 / Word 95) documents.
OldCHPBinTable(byte[], int, int, int, TextPieceTable) - Constructor for class org.apache.poi.hwpf.model.OldCHPBinTable
Constructor used to read an old-style binTable in from a Word document.
OldExcelFormatException - Exception in org.apache.poi.hssf

OldExcelFormatException(String) - Constructor for exception org.apache.poi.hssf.OldExcelFormatException

OldFileFormatException - Exception in org.apache.poi
Base class of all the exceptions that POI throws in the event that it's given a file that's older than currently supported.
OldFileFormatException(String) - Constructor for exception org.apache.poi.OldFileFormatException

OldPAPBinTable - Class in org.apache.poi.hwpf.model
This class holds all of the paragraph formatting properties from Old (Word 6 / Word 95) documents.
OldPAPBinTable(byte[], int, int, int, TextPieceTable) - Constructor for class org.apache.poi.hwpf.model.OldPAPBinTable

OldPowerPointFormatException - Exception in org.apache.poi.hslf.exceptions
This exception is thrown when we try to open a PowerPoint file, and it's too old for us.
OldPowerPointFormatException(String) - Constructor for exception org.apache.poi.hslf.exceptions.OldPowerPointFormatException

OldSectionTable - Class in org.apache.poi.hwpf.model
This class holds all of the section formatting properties from Old (Word 6 / Word 95) documents.
OldSectionTable(byte[], int, int, int, TextPieceTable) - Constructor for class org.apache.poi.hwpf.model.OldSectionTable
Deprecated. Use OldSectionTable.OldSectionTable(byte[],int,int) instead
OldSectionTable(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.OldSectionTable

OldWordFileFormatException - Exception in org.apache.poi.hwpf

OldWordFileFormatException(String) - Constructor for exception org.apache.poi.hwpf.OldWordFileFormatException

OLE10_NATIVE - Static variable in class org.apache.poi.poifs.filesystem.Ole10Native

Ole10Native - Class in org.apache.poi.poifs.filesystem
Represents an Ole10Native record which is wrapped around certain binary files being embedded in OLE2 documents.
Ole10Native(byte[], int) - Constructor for class org.apache.poi.poifs.filesystem.Ole10Native
Creates an instance and fills the fields based on the data in the given buffer.
Ole10Native(byte[], int, boolean) - Constructor for class org.apache.poi.poifs.filesystem.Ole10Native
Creates an instance and fills the fields based on the data in the given buffer.
Ole10NativeException - Exception in org.apache.poi.poifs.filesystem

Ole10NativeException(String) - Constructor for exception org.apache.poi.poifs.filesystem.Ole10NativeException

OLE_OBJECT_REL_TYPE - Static variable in class org.apache.poi.POIXMLDocument

OLEEMBEDDINGS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

OLEShape - Class in org.apache.poi.hslf.model
A shape representing embedded OLE obejct.
OLEShape(int) - Constructor for class org.apache.poi.hslf.model.OLEShape
Create a new OLEShape
OLEShape(int, Shape) - Constructor for class org.apache.poi.hslf.model.OLEShape
Create a new OLEShape
OLEShape(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.OLEShape
Create a OLEShape object
ON_35MM - Static variable in class org.apache.poi.hslf.record.DocumentAtom.SlideSize

ON_SCREEN - Static variable in class org.apache.poi.hslf.record.DocumentAtom.SlideSize

onAddTextShape(TextShape) - Method in class org.apache.poi.hslf.model.Sheet
Subclasses should call this method and update the array of text runs when a text shape is added
onAddTextShape(TextShape) - Method in class org.apache.poi.hslf.model.Slide

onAddTextShape(TextShape) - Method in class org.apache.poi.hslf.model.SlideMaster

onCell(Cell, CellWalkContext) - Method in interface org.apache.poi.ss.util.cellwalk.CellHandler

onCreate() - Method in class org.apache.poi.hslf.model.Sheet
Called by SlideShow ater a new sheet is created
onCreate() - Method in class org.apache.poi.hslf.model.Slide
Called by SlideShow ater a new slide is created.
onDeleteFormula(XSSFCell) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Fired when a formula is deleted from this workbook, for example when calling cell.setCellFormula(null)
onDocumentCreate() - Method in class org.apache.poi.POIXMLDocumentPart
Fired when a new package part is created
onDocumentCreate() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Initialize worksheet data when creating a new sheet.
onDocumentCreate() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Create a new CTWorkbook with all values set to default
onDocumentRead() - Method in class org.apache.poi.POIXMLDocumentPart
Fired when a package part is read
onDocumentRead() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow

onDocumentRead() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Initialize worksheet data when reading in an exisiting file.
onDocumentRead() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument

onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFFooter

onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes
Read document
onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeader
reads the document
onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
read numbering form an existing package
onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData

onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings

onDocumentRead() - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
Read document
onDocumentRemove() - Method in class org.apache.poi.POIXMLDocumentPart
Fired when a package part is about to be removed from the package
onDocumentWrite() - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Fired when the document is written to an output stream.
onSave(Set<PackagePart>) - Method in class org.apache.poi.POIXMLDocumentPart
Save changes in the underlying OOXML package.
OOF_REPLY_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OOXML_FILE_HEADER - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
The first 4 bytes of an OOXML file, used in detection
OOXMLLister - Class in org.apache.poi.dev
Prints out the contents of a OOXML container.
OOXMLLister(OPCPackage) - Constructor for class org.apache.poi.dev.OOXMLLister

OOXMLLister(OPCPackage, PrintStream) - Constructor for class org.apache.poi.dev.OOXMLLister

OOXMLLite - Class in org.apache.poi.util
Build a 'lite' version of the ooxml-schemas.jar
OPCPackage - Class in org.apache.poi.openxml4j.opc
Represents a container that can store multiple data objects.
open(String) - Static method in class org.apache.poi.openxml4j.opc.OPCPackage
Open a package with read/write permission.
open(String, PackageAccess) - Static method in class org.apache.poi.openxml4j.opc.OPCPackage
Open a package.
open(InputStream) - Static method in class org.apache.poi.openxml4j.opc.OPCPackage
Open a package.
open(String) - Static method in class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage.open(String)
open(String, PackageAccess) - Static method in class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage.open(String,PackageAccess)
open(InputStream) - Static method in class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage.open(InputStream)
open(InputStream) - Static method in class org.apache.poi.util.PackageHelper

openOrCreate(File) - Static method in class org.apache.poi.openxml4j.opc.OPCPackage
Opens a package if it exists, else it creates one.
openOrCreate(File) - Static method in class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage.openOrCreate(java.io.File)
openPackage(String) - Static method in class org.apache.poi.POIXMLDocument
Wrapper to open a package, returning an IOException in the event of a problem.
OpenXML4JException - Exception in org.apache.poi.openxml4j.exceptions
Global exception throws when a critical error occurs.
OpenXML4JException(String) - Constructor for exception org.apache.poi.openxml4j.exceptions.OpenXML4JException

OpenXML4JRuntimeException - Exception in org.apache.poi.openxml4j.exceptions
Global exception throws when a critical error occurs (this exception is set as Runtime in order not to force the user to manage the exception in a try/catch).
OpenXML4JRuntimeException(String) - Constructor for exception org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException

OpenXML4JRuntimeException(String, Throwable) - Constructor for exception org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException

openZipFile(String) - Static method in class org.apache.poi.openxml4j.opc.internal.ZipHelper
Retrieve and open a zip file with the specified path.
OperandPtg - Class in org.apache.poi.ss.formula.ptg

OperandPtg() - Constructor for class org.apache.poi.ss.formula.ptg.OperandPtg

OperandResolver - Class in org.apache.poi.ss.formula.eval
Provides functionality for evaluating arguments to functions and operators.
OperationEvaluationContext - Class in org.apache.poi.ss.formula
Contains all the contextual information required to evaluate an operation within a formula For POI internal use only
OperationEvaluationContext(WorkbookEvaluator, EvaluationWorkbook, int, int, int, EvaluationTracker) - Constructor for class org.apache.poi.ss.formula.OperationEvaluationContext

OperationPtg - Class in org.apache.poi.ss.formula.ptg
defines a Ptg that is an operation instead of an operand
OperationPtg() - Constructor for class org.apache.poi.ss.formula.ptg.OperationPtg

optA - Variable in class org.apache.poi.hpbf.model.qcbits.QCBit

optB - Variable in class org.apache.poi.hpbf.model.qcbits.QCBit

optC - Variable in class org.apache.poi.hpbf.model.qcbits.QCBit

optimiseCellStyles(HSSFWorkbook) - Static method in class org.apache.poi.hssf.usermodel.HSSFOptimiser
Goes through the Wokrbook, optimising the cell styles by removing duplicate ones.
optimiseFonts(HSSFWorkbook) - Static method in class org.apache.poi.hssf.usermodel.HSSFOptimiser
Goes through the Workbook, optimising the fonts by removing duplicate ones.
OR - Static variable in class org.apache.poi.ss.formula.functions.BooleanFunction

orderByBofPosition(List<BoundSheetRecord>) - Static method in class org.apache.poi.hssf.record.BoundSheetRecord
Converts a List of BoundSheetRecords to an array and sorts by the position of their BOFs.
ORDERED - Static variable in enum org.apache.poi.hwpf.model.SubdocumentType
Array of SubdocumentTypes ordered by document position and FIB field order
org.apache.poi - package org.apache.poi

org.apache.poi.common.usermodel - package org.apache.poi.common.usermodel

org.apache.poi.ddf - package org.apache.poi.ddf
This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.dev - package org.apache.poi.dev

org.apache.poi.extractor - package org.apache.poi.extractor

org.apache.poi.hdgf - package org.apache.poi.hdgf

org.apache.poi.hdgf.chunks - package org.apache.poi.hdgf.chunks

org.apache.poi.hdgf.dev - package org.apache.poi.hdgf.dev

org.apache.poi.hdgf.exceptions - package org.apache.poi.hdgf.exceptions

org.apache.poi.hdgf.extractor - package org.apache.poi.hdgf.extractor

org.apache.poi.hdgf.pointers - package org.apache.poi.hdgf.pointers

org.apache.poi.hdgf.streams - package org.apache.poi.hdgf.streams

org.apache.poi.hmef - package org.apache.poi.hmef

org.apache.poi.hmef.attribute - package org.apache.poi.hmef.attribute

org.apache.poi.hmef.dev - package org.apache.poi.hmef.dev

org.apache.poi.hmef.extractor - package org.apache.poi.hmef.extractor

org.apache.poi.hpbf - package org.apache.poi.hpbf

org.apache.poi.hpbf.dev - package org.apache.poi.hpbf.dev

org.apache.poi.hpbf.extractor - package org.apache.poi.hpbf.extractor

org.apache.poi.hpbf.model - package org.apache.poi.hpbf.model

org.apache.poi.hpbf.model.qcbits - package org.apache.poi.hpbf.model.qcbits

org.apache.poi.hpsf - package org.apache.poi.hpsf

org.apache.poi.hpsf.extractor - package org.apache.poi.hpsf.extractor

org.apache.poi.hpsf.wellknown - package org.apache.poi.hpsf.wellknown

Specific support for DocumentSummaryInformation, SummaryInformation types.
org.apache.poi.hslf - package org.apache.poi.hslf

org.apache.poi.hslf.blip - package org.apache.poi.hslf.blip

org.apache.poi.hslf.dev - package org.apache.poi.hslf.dev

org.apache.poi.hslf.exceptions - package org.apache.poi.hslf.exceptions

org.apache.poi.hslf.extractor - package org.apache.poi.hslf.extractor

org.apache.poi.hslf.model - package org.apache.poi.hslf.model

org.apache.poi.hslf.model.textproperties - package org.apache.poi.hslf.model.textproperties

org.apache.poi.hslf.record - package org.apache.poi.hslf.record

org.apache.poi.hslf.usermodel - package org.apache.poi.hslf.usermodel

org.apache.poi.hslf.util - package org.apache.poi.hslf.util

org.apache.poi.hsmf - package org.apache.poi.hsmf

org.apache.poi.hsmf.datatypes - package org.apache.poi.hsmf.datatypes

org.apache.poi.hsmf.dev - package org.apache.poi.hsmf.dev

org.apache.poi.hsmf.exceptions - package org.apache.poi.hsmf.exceptions

org.apache.poi.hsmf.extractor - package org.apache.poi.hsmf.extractor

org.apache.poi.hsmf.parsers - package org.apache.poi.hsmf.parsers

org.apache.poi.hssf - package org.apache.poi.hssf
Horrible SpreadSheet Format API's for reading/writting Excel files using pure Java.
org.apache.poi.hssf.converter - package org.apache.poi.hssf.converter

org.apache.poi.hssf.dev - package org.apache.poi.hssf.dev
DEV package serves two purposes.
org.apache.poi.hssf.eventmodel - package org.apache.poi.hssf.eventmodel

org.apache.poi.hssf.eventusermodel - package org.apache.poi.hssf.eventusermodel
HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.eventusermodel.dummyrecord - package org.apache.poi.hssf.eventusermodel.dummyrecord

org.apache.poi.hssf.extractor - package org.apache.poi.hssf.extractor

org.apache.poi.hssf.model - package org.apache.poi.hssf.model
Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record - package org.apache.poi.hssf.record
Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates - package org.apache.poi.hssf.record.aggregates
record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.cf - package org.apache.poi.hssf.record.cf

org.apache.poi.hssf.record.chart - package org.apache.poi.hssf.record.chart

org.apache.poi.hssf.record.common - package org.apache.poi.hssf.record.common

org.apache.poi.hssf.record.cont - package org.apache.poi.hssf.record.cont

org.apache.poi.hssf.record.crypto - package org.apache.poi.hssf.record.crypto

org.apache.poi.hssf.record.pivottable - package org.apache.poi.hssf.record.pivottable

org.apache.poi.hssf.usermodel - package org.apache.poi.hssf.usermodel
usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util - package org.apache.poi.hssf.util
util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.hwpf - package org.apache.poi.hwpf

org.apache.poi.hwpf.converter - package org.apache.poi.hwpf.converter

org.apache.poi.hwpf.dev - package org.apache.poi.hwpf.dev

org.apache.poi.hwpf.extractor - package org.apache.poi.hwpf.extractor

org.apache.poi.hwpf.model - package org.apache.poi.hwpf.model

org.apache.poi.hwpf.model.io - package org.apache.poi.hwpf.model.io

org.apache.poi.hwpf.model.types - package org.apache.poi.hwpf.model.types

org.apache.poi.hwpf.sprm - package org.apache.poi.hwpf.sprm

org.apache.poi.hwpf.usermodel - package org.apache.poi.hwpf.usermodel

org.apache.poi.openxml4j.exceptions - package org.apache.poi.openxml4j.exceptions

org.apache.poi.openxml4j.opc - package org.apache.poi.openxml4j.opc

org.apache.poi.openxml4j.opc.internal - package org.apache.poi.openxml4j.opc.internal

org.apache.poi.openxml4j.opc.internal.marshallers - package org.apache.poi.openxml4j.opc.internal.marshallers

org.apache.poi.openxml4j.opc.internal.signature - package org.apache.poi.openxml4j.opc.internal.signature

org.apache.poi.openxml4j.opc.internal.unmarshallers - package org.apache.poi.openxml4j.opc.internal.unmarshallers

org.apache.poi.openxml4j.opc.signature - package org.apache.poi.openxml4j.opc.signature

org.apache.poi.openxml4j.util - package org.apache.poi.openxml4j.util

org.apache.poi.poifs.common - package org.apache.poi.poifs.common
common package contains constants and other classes shared across all POIFS subpackages
org.apache.poi.poifs.crypt - package org.apache.poi.poifs.crypt

org.apache.poi.poifs.dev - package org.apache.poi.poifs.dev
DEV package serves two purposes.
org.apache.poi.poifs.eventfilesystem - package org.apache.poi.poifs.eventfilesystem
The eventfilesystem is an efficient method for reading OLE 2 CDF files.
org.apache.poi.poifs.filesystem - package org.apache.poi.poifs.filesystem
filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.nio - package org.apache.poi.poifs.nio

org.apache.poi.poifs.property - package org.apache.poi.poifs.property
property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage - package org.apache.poi.poifs.storage
storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.
org.apache.poi.sl.usermodel - package org.apache.poi.sl.usermodel

org.apache.poi.ss - package org.apache.poi.ss

org.apache.poi.ss.extractor - package org.apache.poi.ss.extractor

org.apache.poi.ss.format - package org.apache.poi.ss.format
This package contains classes that implement cell formatting
org.apache.poi.ss.formula - package org.apache.poi.ss.formula
This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.atp - package org.apache.poi.ss.formula.atp

org.apache.poi.ss.formula.constant - package org.apache.poi.ss.formula.constant

org.apache.poi.ss.formula.eval - package org.apache.poi.ss.formula.eval

org.apache.poi.ss.formula.eval.forked - package org.apache.poi.ss.formula.eval.forked

org.apache.poi.ss.formula.function - package org.apache.poi.ss.formula.function

org.apache.poi.ss.formula.functions - package org.apache.poi.ss.formula.functions

org.apache.poi.ss.formula.ptg - package org.apache.poi.ss.formula.ptg
formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.formula.udf - package org.apache.poi.ss.formula.udf

org.apache.poi.ss.usermodel - package org.apache.poi.ss.usermodel

org.apache.poi.ss.usermodel.charts - package org.apache.poi.ss.usermodel.charts

org.apache.poi.ss.util - package org.apache.poi.ss.util

org.apache.poi.ss.util.cellwalk - package org.apache.poi.ss.util.cellwalk

org.apache.poi.util - package org.apache.poi.util
Top-level util package are classes that are useful throughout the project.
org.apache.poi.xslf - package org.apache.poi.xslf

org.apache.poi.xslf.extractor - package org.apache.poi.xslf.extractor

org.apache.poi.xslf.model - package org.apache.poi.xslf.model

org.apache.poi.xslf.model.geom - package org.apache.poi.xslf.model.geom

org.apache.poi.xslf.usermodel - package org.apache.poi.xslf.usermodel

org.apache.poi.xslf.util - package org.apache.poi.xslf.util

org.apache.poi.xssf.dev - package org.apache.poi.xssf.dev

org.apache.poi.xssf.eventusermodel - package org.apache.poi.xssf.eventusermodel

org.apache.poi.xssf.extractor - package org.apache.poi.xssf.extractor

org.apache.poi.xssf.model - package org.apache.poi.xssf.model

org.apache.poi.xssf.streaming - package org.apache.poi.xssf.streaming

org.apache.poi.xssf.usermodel - package org.apache.poi.xssf.usermodel

org.apache.poi.xssf.usermodel.charts - package org.apache.poi.xssf.usermodel.charts

org.apache.poi.xssf.usermodel.extensions - package org.apache.poi.xssf.usermodel.extensions

org.apache.poi.xssf.usermodel.helpers - package org.apache.poi.xssf.usermodel.helpers

org.apache.poi.xssf.util - package org.apache.poi.xssf.util

org.apache.poi.xwpf.extractor - package org.apache.poi.xwpf.extractor

org.apache.poi.xwpf.model - package org.apache.poi.xwpf.model

org.apache.poi.xwpf.usermodel - package org.apache.poi.xwpf.usermodel

ORGANIZATIONAL_ID_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OrganizationChart - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains an organization chart object.
ORIG_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIG_MESSAGE_CLASS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGIN_CHECK - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_AUTHOR_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_AUTHOR_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_AUTHOR_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_AUTHOR_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_AUTHOR_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_DELIVERY_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_DISPLAY_BCC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_DISPLAY_CC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_DISPLAY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_DISPLAY_TO - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_EITS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENDER_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENDER_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENDER_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENDER_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENDER_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENSITIVITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENT_REPRESENTING_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENT_REPRESENTING_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENT_REPRESENTING_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SENT_REPRESENTING_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SUBJECT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINAL_SUBMIT_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINALLY_INTENDED_RECIP_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINALLY_INTENDED_RECIP_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINALLY_INTENDED_RECIPIENT_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OriginalMainMasterId - Static variable in class org.apache.poi.hslf.record.RecordTypes

originalPackagePath - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
File path of this package.
ORIGINATING_MTA_CERTIFICATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINATOR_AND_DL_EXPANSION_HISTORY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINATOR_CERTIFICATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINATOR_DELIVERY_REPORT_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ORIGINATOR_RETURN_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OS_MACINTOSH - Static variable in class org.apache.poi.hpsf.PropertySet
If the OS version field holds this value the property set stream was created on a Macintosh system.
OS_WIN16 - Static variable in class org.apache.poi.hpsf.PropertySet
If the OS version field holds this value the property set stream was created on a 16-bit Windows system.
OS_WIN32 - Static variable in class org.apache.poi.hpsf.PropertySet
If the OS version field holds this value the property set stream was created on a 32-bit Windows system.
osVersion - Variable in class org.apache.poi.hpsf.PropertySet
Specifies the version of the operating system that created this PropertySet.
OTHER_ADDRESS_CITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OTHER_ADDRESS_COUNTRY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OTHER_ADDRESS_POST_OFFICE_BOX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OTHER_ADDRESS_POSTAL_CODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OTHER_ADDRESS_STATE_OR_PROVINCE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OTHER_ADDRESS_STREET - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OTHER_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OTHER_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

out - Variable in class org.apache.poi.hslf.dev.PPTXMLDump

Outline - Class in org.apache.poi.xslf.model.geom
Date: 11/6/11
Outline(Shape, Path) - Constructor for class org.apache.poi.xslf.model.geom.Outline

OutlineTextRefAtom - Class in org.apache.poi.hslf.record
OEPlaceholderAtom (3998).
OutlineTextRefAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.OutlineTextRefAtom
Build an instance of OutlineTextRefAtom from on-disk data
OutlineTextRefAtom() - Constructor for class org.apache.poi.hslf.record.OutlineTextRefAtom
Create a new instance of FontEntityAtom
OutlineTextRefAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

OutlineViewInfo - Static variable in class org.apache.poi.hslf.record.RecordTypes

OutlookTextExtactor - Class in org.apache.poi.hsmf.extractor
A text extractor for HSMF (Outlook) .msg files.
OutlookTextExtactor(MAPIMessage) - Constructor for class org.apache.poi.hsmf.extractor.OutlookTextExtactor

OutlookTextExtactor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hsmf.extractor.OutlookTextExtactor
Deprecated.
OutlookTextExtactor(DirectoryNode) - Constructor for class org.apache.poi.hsmf.extractor.OutlookTextExtactor

OutlookTextExtactor(POIFSFileSystem) - Constructor for class org.apache.poi.hsmf.extractor.OutlookTextExtactor

OutlookTextExtactor(NPOIFSFileSystem) - Constructor for class org.apache.poi.hsmf.extractor.OutlookTextExtactor

OutlookTextExtactor(InputStream) - Constructor for class org.apache.poi.hsmf.extractor.OutlookTextExtactor

output - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Output stream for writing this package.
outputCharacters(Element, CharacterRun, String) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

outputCharacters(Element, CharacterRun, String) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

outputCharacters(Element, CharacterRun, String) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

outputCharacters(Element, CharacterRun, String) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

outputQuotedString(String) - Method in class org.apache.poi.xssf.streaming.SheetDataWriter

OVERHEAD - Static variable in class org.apache.poi.hslf.record.DocumentAtom.SlideSize

OVERLAP - Static variable in class org.apache.poi.hssf.record.cf.CellRangeUtil

OVERLAPS_1_MINOR - Static variable in class org.apache.poi.xssf.util.NumericRanges

OVERLAPS_1_WRAPS - Static variable in class org.apache.poi.xssf.util.NumericRanges

OVERLAPS_2_MINOR - Static variable in class org.apache.poi.xssf.util.NumericRanges

OVERLAPS_2_WRAPS - Static variable in class org.apache.poi.xssf.util.NumericRanges

overwrite(byte[], int) - Method in class org.apache.poi.hslf.util.MutableByteArrayOutputStream
Write some bytes to an earlier bit of the array
OWN_STORE_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

OWNER_APPT_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

P

PACK_OBJECT_REL_TYPE - Static variable in class org.apache.poi.POIXMLDocument

Package - Class in org.apache.poi.openxml4j.opc
Deprecated. (name clash with Package use OPCPackage instead.
Package(PackageAccess) - Constructor for class org.apache.poi.openxml4j.opc.Package
Deprecated. use OPCPackage
PACKAGE_CORE_PROPERTIES_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Core package properties art name.
PACKAGE_PROPERTIES_SEGMENT_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Segment name of the package properties folder.
PACKAGE_RELATIONSHIPS_ROOT_PART_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Package relationships part name.
PACKAGE_RELATIONSHIPS_ROOT_URI - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Package relationships part URI
PACKAGE_ROOT_PART_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Root package part name.
PACKAGE_ROOT_URI - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Root package URI.
PackageAccess - Enum in org.apache.poi.openxml4j.opc
Specifies package access.
PackageDigitalSignature - Class in org.apache.poi.openxml4j.opc.signature

PackageDigitalSignature() - Constructor for class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

PackageDigitalSignatureManager - Class in org.apache.poi.openxml4j.opc.signature

PackageDigitalSignatureManager() - Constructor for class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignatureManager

PackageHelper - Class in org.apache.poi.util
Provides handy methods to work with OOXML packages
PackageHelper() - Constructor for class org.apache.poi.util.PackageHelper

PackageNamespaces - Interface in org.apache.poi.openxml4j.opc
Open Packaging Convention namespaces URI.
PackagePart - Class in org.apache.poi.openxml4j.opc
Provides a base class for parts stored in a Package.
PackagePart(OPCPackage, PackagePartName, ContentType) - Constructor for class org.apache.poi.openxml4j.opc.PackagePart
Constructor.
PackagePart(OPCPackage, PackagePartName, ContentType, boolean) - Constructor for class org.apache.poi.openxml4j.opc.PackagePart
Constructor.
PackagePart(OPCPackage, PackagePartName, String) - Constructor for class org.apache.poi.openxml4j.opc.PackagePart
Constructor.
PackagePartCollection - Class in org.apache.poi.openxml4j.opc
A package part collection.
PackagePartCollection() - Constructor for class org.apache.poi.openxml4j.opc.PackagePartCollection

PackagePartName - Class in org.apache.poi.openxml4j.opc
An immutable Open Packaging Convention compliant part name.
packagePictures - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

packageProperties - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Core package properties.
PackageProperties - Interface in org.apache.poi.openxml4j.opc
Represents the core properties of an OPC package.
PackagePropertiesMarshaller - Class in org.apache.poi.openxml4j.opc.internal.marshallers
Package properties marshaller.
PackagePropertiesMarshaller() - Constructor for class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

PackagePropertiesPart - Class in org.apache.poi.openxml4j.opc.internal
Represents the core properties part of a package.
PackagePropertiesPart(OPCPackage, PackagePartName) - Constructor for class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Constructor.
PackagePropertiesUnmarshaller - Class in org.apache.poi.openxml4j.opc.internal.unmarshallers
Package properties unmarshaller.
PackagePropertiesUnmarshaller() - Constructor for class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

PackageRelationship - Class in org.apache.poi.openxml4j.opc
A part relationship.
PackageRelationship(OPCPackage, PackagePart, URI, TargetMode, String, String) - Constructor for class org.apache.poi.openxml4j.opc.PackageRelationship
Constructor.
PackageRelationshipCollection - Class in org.apache.poi.openxml4j.opc
Represents a collection of PackageRelationship elements that are owned by a given PackagePart or the Package.
PackageRelationshipCollection(PackageRelationshipCollection, String) - Constructor for class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Copy constructor.
PackageRelationshipCollection(OPCPackage) - Constructor for class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Constructor.
PackageRelationshipCollection(PackagePart) - Constructor for class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Constructor.
PackageRelationshipCollection(OPCPackage, PackagePart) - Constructor for class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Constructor.
PackageRelationshipTypes - Interface in org.apache.poi.openxml4j.opc
Relationship types.
PackagingURIHelper - Class in org.apache.poi.openxml4j.opc
Helper for part and pack URI.
PackagingURIHelper() - Constructor for class org.apache.poi.openxml4j.opc.PackagingURIHelper

PACKEMBEDDINGS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

pad(StringBuffer, int) - Static method in class org.apache.poi.hwpf.dev.RecordUtil

pad4(byte[]) - Static method in class org.apache.poi.hpsf.Util
Pads a byte array with 0x00 bytes so that its length is a multiple of 4.
pad4(char[]) - Static method in class org.apache.poi.hpsf.Util
Pads a character array with 0x0000 characters so that its length is a multiple of 4.
pad4(String) - Static method in class org.apache.poi.hpsf.Util
Pads a string with 0x0000 characters so that its length is a multiple of 4.
page() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

pageBreakBefore() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

pageBreakBefore() - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

PageBreakRecord - Class in org.apache.poi.hssf.record
Record that contains the functionality page breaks (horizontal and vertical)
PageBreakRecord() - Constructor for class org.apache.poi.hssf.record.PageBreakRecord

PageBreakRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PageBreakRecord

PageBreakRecord.Break - Class in org.apache.poi.hssf.record
Since both records store 2byte integers (short), no point in differentiating it in the records.
PageBreakRecord.Break(int, int, int) - Constructor for class org.apache.poi.hssf.record.PageBreakRecord.Break

PageBreakRecord.Break(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PageBreakRecord.Break

PageItemRecord - Class in org.apache.poi.hssf.record.pivottable
SXPI - Page Item (0x00B6)

PageItemRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.pivottable.PageItemRecord

PageOrder - Enum in org.apache.poi.ss.usermodel
Specifies printed page order.
PAGER_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PageSettingsBlock - Class in org.apache.poi.hssf.record.aggregates
Groups the page settings records for a worksheet.
See OOO excelfileformat.pdf sec 4.4 'Page Settings Block'
PageSettingsBlock(RecordStream) - Constructor for class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

PageSettingsBlock() - Constructor for class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Creates a PageSettingsBlock with default settings
paint(Graphics2D, PictureData, Picture) - Method in class org.apache.poi.hslf.blip.BitmapPainter

paint(Graphics2D, PictureData, Picture) - Method in interface org.apache.poi.hslf.blip.ImagePainter
Paints the specified picture data
paint(SimpleShape, Graphics2D) - Static method in class org.apache.poi.hslf.model.ShapePainter

paint(Graphics2D) - Method in class org.apache.poi.hslf.model.TextPainter

painters - Static variable in class org.apache.poi.hslf.usermodel.PictureData

PaletteRecord - Class in org.apache.poi.hssf.record
PaletteRecord (0x0092) - Supports custom palettes.
PaletteRecord() - Constructor for class org.apache.poi.hssf.record.PaletteRecord

PaletteRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PaletteRecord

PANE_LOWER_LEFT - Static variable in class org.apache.poi.hssf.model.InternalSheet

PANE_LOWER_LEFT - Static variable in class org.apache.poi.hssf.util.PaneInformation
Constant for active pane being the lower left
PANE_LOWER_LEFT - Static variable in interface org.apache.poi.ss.usermodel.Sheet

PANE_LOWER_RIGHT - Static variable in class org.apache.poi.hssf.model.InternalSheet

PANE_LOWER_RIGHT - Static variable in class org.apache.poi.hssf.util.PaneInformation
Constant for active pane being the lower right
PANE_LOWER_RIGHT - Static variable in interface org.apache.poi.ss.usermodel.Sheet

PANE_UPPER_LEFT - Static variable in class org.apache.poi.hssf.model.InternalSheet

PANE_UPPER_LEFT - Static variable in class org.apache.poi.hssf.util.PaneInformation
Constant for active pane being the upper left
PANE_UPPER_LEFT - Static variable in interface org.apache.poi.ss.usermodel.Sheet

PANE_UPPER_RIGHT - Static variable in class org.apache.poi.hssf.model.InternalSheet

PANE_UPPER_RIGHT - Static variable in class org.apache.poi.hssf.util.PaneInformation
Constant for active pane being the upper right
PANE_UPPER_RIGHT - Static variable in interface org.apache.poi.ss.usermodel.Sheet

PaneInformation - Class in org.apache.poi.hssf.util
Holds information regarding a split plane or freeze plane for a sheet.
PaneInformation(short, short, short, short, byte, boolean) - Constructor for class org.apache.poi.hssf.util.PaneInformation

PaneRecord - Class in org.apache.poi.hssf.record
Describes the frozen and unfozen panes.

PaneRecord() - Constructor for class org.apache.poi.hssf.record.PaneRecord

PaneRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PaneRecord

PAP_TYPE - Static variable in class org.apache.poi.hwpf.sprm.SprmOperation
Deprecated.
PAPAbstractType - Class in org.apache.poi.hwpf.model.types
Paragraph Properties.
PAPAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.PAPAbstractType

PAPBinTable - Class in org.apache.poi.hwpf.model
This class represents the bin table of Word document but it also serves as a holder for all of the paragraphs of document that have been loaded into memory.
PAPBinTable() - Constructor for class org.apache.poi.hwpf.model.PAPBinTable

PAPBinTable(byte[], byte[], byte[], int, int, int, TextPieceTable) - Constructor for class org.apache.poi.hwpf.model.PAPBinTable
Deprecated. Use PAPBinTable.PAPBinTable(byte[], byte[], byte[], int, int, CharIndexTranslator) instead
PAPBinTable(byte[], byte[], byte[], int, int, CharIndexTranslator) - Constructor for class org.apache.poi.hwpf.model.PAPBinTable

PaperSize - Enum in org.apache.poi.ss.usermodel
The enumeration value indicating the possible paper size for a sheet
PAPFormattedDiskPage - Class in org.apache.poi.hwpf.model
Represents a PAP FKP.
PAPFormattedDiskPage(byte[]) - Constructor for class org.apache.poi.hwpf.model.PAPFormattedDiskPage
Deprecated. Use PAPFormattedDiskPage.PAPFormattedDiskPage() instead
PAPFormattedDiskPage() - Constructor for class org.apache.poi.hwpf.model.PAPFormattedDiskPage

PAPFormattedDiskPage(byte[], byte[], int, int, TextPieceTable) - Constructor for class org.apache.poi.hwpf.model.PAPFormattedDiskPage
Deprecated. Use PAPFormattedDiskPage.PAPFormattedDiskPage(byte[], byte[], int, CharIndexTranslator) instead
PAPFormattedDiskPage(byte[], byte[], int, CharIndexTranslator) - Constructor for class org.apache.poi.hwpf.model.PAPFormattedDiskPage
Creates a PAPFormattedDiskPage from a 512 byte array
PAPX - Class in org.apache.poi.hwpf.model
DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
PAPX(int, int, CharIndexTranslator, byte[], ParagraphHeight, byte[]) - Constructor for class org.apache.poi.hwpf.model.PAPX

PAPX(int, int, byte[], ParagraphHeight, byte[]) - Constructor for class org.apache.poi.hwpf.model.PAPX

PAPX(int, int, CharIndexTranslator, SprmBuffer, byte[]) - Constructor for class org.apache.poi.hwpf.model.PAPX
Deprecated.
PAPX(int, int, SprmBuffer) - Constructor for class org.apache.poi.hwpf.model.PAPX

ParaFormatAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

Paragraph - Class in org.apache.poi.hwpf.usermodel

Paragraph(int, int, Table) - Constructor for class org.apache.poi.hwpf.usermodel.Paragraph
Deprecated.
Paragraph(PAPX, Range) - Constructor for class org.apache.poi.hwpf.usermodel.Paragraph
Deprecated.
Paragraph(PAPX, Range, int) - Constructor for class org.apache.poi.hwpf.usermodel.Paragraph
Deprecated.
paragraph - Variable in class org.apache.poi.xwpf.model.XMLParagraph

paragraph - Variable in class org.apache.poi.xwpf.model.XWPFParagraphDecorator

ParagraphAlignment - Enum in org.apache.poi.xwpf.usermodel
Specifies all types of alignment which are available to be applied to objects in a WordprocessingML document
ParagraphFlagsTextProp - Class in org.apache.poi.hslf.model.textproperties
Definition for the common paragraph text property bitset.
ParagraphFlagsTextProp() - Constructor for class org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

ParagraphHeight - Class in org.apache.poi.hwpf.model

ParagraphHeight(byte[], int) - Constructor for class org.apache.poi.hwpf.model.ParagraphHeight

ParagraphHeight() - Constructor for class org.apache.poi.hwpf.model.ParagraphHeight

ParagraphProperties - Class in org.apache.poi.hwpf.usermodel

ParagraphProperties() - Constructor for class org.apache.poi.hwpf.usermodel.ParagraphProperties

ParagraphPropertyFetcher<T> - Class in org.apache.poi.xslf.model

ParagraphPropertyFetcher(int) - Constructor for class org.apache.poi.xslf.model.ParagraphPropertyFetcher

paragraphs - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

paragraphs - Variable in class org.apache.poi.xwpf.usermodel.XWPFTableCell

ParagraphSprmCompressor - Class in org.apache.poi.hwpf.sprm

ParagraphSprmCompressor() - Constructor for class org.apache.poi.hwpf.sprm.ParagraphSprmCompressor

ParagraphSprmUncompressor - Class in org.apache.poi.hwpf.sprm

ParagraphSprmUncompressor() - Constructor for class org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor

paragraphTextPropTypes - Static variable in class org.apache.poi.hslf.record.StyleTextPropAtom
All the different kinds of paragraph properties we might handle
Parallelogram - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

PARALLELOGRAM - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Parent - Interface in org.apache.poi.poifs.property
Behavior for parent (directory) properties
parent - Variable in class org.apache.poi.xssf.usermodel.XSSFShape
The parent shape, always not-null for shapes in groups
PARENT_DISPLAY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PARENT_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PARENT_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ParentAwareRecord - Interface in org.apache.poi.hslf.record
Interface to define how a record can indicate it cares about what its parent is, and how it wants to be told which record is its parent.
ParenthesisPtg - Class in org.apache.poi.ss.formula.ptg
While formula tokens are stored in RPN order and thus do not need parenthesis for precedence reasons, Parenthesis tokens ARE written to ensure that user entered parenthesis are displayed as-is on reading back Avik Sengupta <lists@aviksengupta.com> Andrew C.
parse(POIFSFileSystem) - Static method in class org.apache.poi.hsmf.parsers.POIFSChunkParser

parse(DirectoryNode) - Static method in class org.apache.poi.hsmf.parsers.POIFSChunkParser

parse(String, HSSFWorkbook) - Static method in class org.apache.poi.hssf.model.HSSFFormulaParser
Convenience method for parsing cell formulas.
parse(String, HSSFWorkbook, int) - Static method in class org.apache.poi.hssf.model.HSSFFormulaParser

parse(String, HSSFWorkbook, int, int) - Static method in class org.apache.poi.hssf.model.HSSFFormulaParser

parse(LittleEndianInput, int) - Static method in class org.apache.poi.ss.formula.constant.ConstantValueParser

parse(String, FormulaParsingWorkbook, int, int) - Static method in class org.apache.poi.ss.formula.FormulaParser
Parse a formula into a array of tokens
parse(String) - Static method in class org.apache.poi.xslf.model.geom.ExpressionParser

parseAs7BitData(byte[]) - Static method in class org.apache.poi.hsmf.datatypes.StringChunk
Parses as non-unicode, supposedly 7 bit CP1252 data and returns the string that that yields.
parseAs7BitData(byte[], String) - Static method in class org.apache.poi.hsmf.datatypes.StringChunk
Parses as non-unicode, supposedly 7 bit data and returns the string that that yields.
parseDate(String) - Static method in class org.apache.poi.ss.formula.atp.DateParser
Parses a date from a string.
parseDouble(String) - Static method in class org.apache.poi.ss.formula.eval.OperandResolver
Converts a string to a double using standard rules that Excel would use.
Tolerates leading and trailing spaces,
Doesn't support currency prefixes, commas, percentage signs or arithmetic operations strings.
parseFormat(String, CellFormatType, CellFormatPart.PartHandler) - Static method in class org.apache.poi.ss.format.CellFormatPart

parseFormulaRecord(FormulaRecord) - Method in class org.apache.poi.hssf.dev.FormulaViewer
Method parseFormulaRecord
parseYYYYMMDDDate(String) - Static method in class org.apache.poi.ss.usermodel.DateUtil
Converts a string of format "YYYY/MM/DD" to its (Excel) numeric equivalent
part - Variable in class org.apache.poi.xwpf.usermodel.XWPFParagraph

part - Variable in class org.apache.poi.xwpf.usermodel.XWPFTable

part - Variable in class org.apache.poi.xwpf.usermodel.XWPFTableCell

PartAlreadyExistsException - Exception in org.apache.poi.openxml4j.exceptions
Throw when trying to create a PackagePart but one already exists with that name.
PartAlreadyExistsException(String) - Constructor for exception org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException

partialEvaluate(boolean, boolean) - Method in class org.apache.poi.ss.formula.functions.BooleanFunction

partiallyRead() - Method in class org.apache.poi.poifs.storage.DocumentBlock
Was this a partially read block?
partList - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Package parts collection.
PartMarshaller - Interface in org.apache.poi.openxml4j.opc.internal
Object implemented this interface are considered as part marshaller.
partMarshallers - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Part marshallers by content type.
PartUnmarshaller - Interface in org.apache.poi.openxml4j.opc.internal
Object implemented this interface are considered as part unmarshaller.
partUnmarshallers - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Part unmarshallers by content type.
pass(double) - Method in class org.apache.poi.ss.format.CellFormatCondition
Returns true if the given value passes the constraint's test.
PasswordRecord - Class in org.apache.poi.hssf.record
Title: Password Record (0x0013)
Description: stores the encrypted password for a sheet or workbook (HSSF doesn't support encryption) REFERENCE: PG 371 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

PasswordRecord(int) - Constructor for class org.apache.poi.hssf.record.PasswordRecord

PasswordRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PasswordRecord

PasswordRev4Record - Class in org.apache.poi.hssf.record
Title: Protection Revision 4 password Record (0x01BC)
Description: Stores the (2 byte??!!) encrypted password for a shared workbook
REFERENCE: PG 374 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

PasswordRev4Record(int) - Constructor for class org.apache.poi.hssf.record.PasswordRev4Record

PasswordRev4Record(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PasswordRev4Record

pastDaysOfWeek(double, double, int) - Method in class org.apache.poi.ss.formula.atp.WorkdayCalculator
Calculates how many days of week past between a start and an end date.
Path - Class in org.apache.poi.xslf.model.geom
Specifies a creation path consisting of a series of moves, lines and curves that when combined forms a geometric shape
Path() - Constructor for class org.apache.poi.xslf.model.geom.Path

Path(boolean, boolean) - Constructor for class org.apache.poi.xslf.model.geom.Path

Path(CTPath2D) - Constructor for class org.apache.poi.xslf.model.geom.Path

PATH_SEPERATOR - Static variable in class org.apache.poi.hssf.record.SupBookRecord

PathCommand - Interface in org.apache.poi.xslf.model.geom
A path command in DrawingML.
patriarch - Variable in class org.apache.poi.hssf.record.EscherAggregate

PatternFormatting - Class in org.apache.poi.hssf.record.cf
Pattern Formatting Block of the Conditional Formatting Rule Record.
PatternFormatting() - Constructor for class org.apache.poi.hssf.record.cf.PatternFormatting

PatternFormatting(LittleEndianInput) - Constructor for class org.apache.poi.hssf.record.cf.PatternFormatting
Creates new FontFormatting
PatternFormatting - Interface in org.apache.poi.ss.usermodel

peekNextClass() - Method in class org.apache.poi.hssf.model.RecordStream

peekNextSid() - Method in class org.apache.poi.hssf.model.RecordStream

PEN_DASH - Static variable in class org.apache.poi.hslf.model.Line
dash style
PEN_DASHDOT - Static variable in class org.apache.poi.hslf.model.Line
PS_DASHDOT system dash style
PEN_DASHDOTDOT - Static variable in class org.apache.poi.hslf.model.Line
PS_DASHDOTDOT system dash style
PEN_DASHDOTGEL - Static variable in class org.apache.poi.hslf.model.Line
dash short dash
PEN_DOT - Static variable in class org.apache.poi.hslf.model.Line
PS_DOT system dash style
PEN_DOTGEL - Static variable in class org.apache.poi.hslf.model.Line
square dot style
PEN_LONGDASHDOTDOTGEL - Static variable in class org.apache.poi.hslf.model.Line
long dash short dash short dash
PEN_LONGDASHDOTGEL - Static variable in class org.apache.poi.hslf.model.Line
long dash short dash
PEN_LONGDASHGEL - Static variable in class org.apache.poi.hslf.model.Line
long dash style
PEN_PS_DASH - Static variable in class org.apache.poi.hslf.model.Line
PS_DASH system dash style
PEN_SOLID - Static variable in class org.apache.poi.hslf.model.Line
Solid (continuous) pen
Pentagon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

PENTAGON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

PercentEval - Class in org.apache.poi.ss.formula.eval
Implementation of Excel formula token '%'.
PercentPtg - Class in org.apache.poi.ss.formula.ptg
Percent PTG.
PersistPtrFullBlock - Static variable in class org.apache.poi.hslf.record.RecordTypes

PersistPtrHolder - Class in org.apache.poi.hslf.record
General holder for PersistPtrFullBlock and PersistPtrIncrementalBlock records.
PersistPtrHolder(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.PersistPtrHolder
Create a new holder for a PersistPtr record
PersistPtrIncrementalBlock - Static variable in class org.apache.poi.hslf.record.RecordTypes

PersistRecord - Interface in org.apache.poi.hslf.record
A record that can be referenced in PersistPtr storage.
PERSONAL_HOME_PAGE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PERSPECTIVE__OFFSETX - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__OFFSETY - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__ORIGINX - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__ORIGINY - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__PERSPECTIVEON - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__PERSPECTIVEX - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__PERSPECTIVEY - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__SCALEXTOX - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__SCALEXTOY - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__SCALEYTOX - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__SCALEYTOY - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__TYPE - Static variable in class org.apache.poi.ddf.EscherProperties

PERSPECTIVE__WEIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

PGDEDN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PGDFTN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PGDMOTHER - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PHONETICPR_00EF - Static variable in class org.apache.poi.hssf.record.UnknownRecord

PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PHYSICAL_DELIVERY_MODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PHYSICAL_DELIVERY_REPORT_REQUEST - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PHYSICAL_FORWARDING_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PHYSICAL_FORWARDING_ADDRESS_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PHYSICAL_FORWARDING_PROHIBITED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PHYSICAL_RENDITION_ATTRIBUTES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PI - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

PICF - Class in org.apache.poi.hwpf.model
The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
PICF() - Constructor for class org.apache.poi.hwpf.model.PICF

PICF(byte[], int) - Constructor for class org.apache.poi.hwpf.model.PICF

PICFAbstractType - Class in org.apache.poi.hwpf.model.types
The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
PICFAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.PICFAbstractType

PICFAndOfficeArtData - Class in org.apache.poi.hwpf.model

PICFAndOfficeArtData(byte[], int) - Constructor for class org.apache.poi.hwpf.model.PICFAndOfficeArtData

PICT - Class in org.apache.poi.hslf.blip
Represents Macintosh PICT picture data.
PICT() - Constructor for class org.apache.poi.hslf.blip.PICT

PICT - Static variable in class org.apache.poi.hslf.model.Picture
Macintosh PICT
PICT_HEADER_SIZE - Static variable in class org.apache.poi.hslf.dev.PPTXMLDump

pictstream - Variable in class org.apache.poi.hslf.dev.PPTXMLDump

Picture - Class in org.apache.poi.hslf.model
Represents a picture in a PowerPoint document.
Picture(int) - Constructor for class org.apache.poi.hslf.model.Picture
Create a new Picture
Picture(int, Shape) - Constructor for class org.apache.poi.hslf.model.Picture
Create a new Picture
Picture(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Picture
Create a Picture object
Picture - Class in org.apache.poi.hwpf.usermodel
Represents embedded picture extracted from Word Document
Picture(EscherBlipRecord) - Constructor for class org.apache.poi.hwpf.usermodel.Picture
Builds a Picture object for a Picture stored as Escher.
Picture(int, byte[], boolean) - Constructor for class org.apache.poi.hwpf.usermodel.Picture
Builds a Picture object for a Picture stored in the DataStream
Picture - Interface in org.apache.poi.sl.usermodel

Picture - Interface in org.apache.poi.ss.usermodel
Repersents a picture in a SpreadsheetML document
PICTURE_TYPE_BMP - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Windows Bitmap (.bmp)
PICTURE_TYPE_BMP - Static variable in class org.apache.poi.xssf.usermodel.XSSFWorkbook

PICTURE_TYPE_BMP - Static variable in interface org.apache.poi.xwpf.usermodel.Document
Windows Bitmap (.bmp)
PICTURE_TYPE_DIB - Static variable in class org.apache.poi.hssf.usermodel.HSSFPicture

PICTURE_TYPE_DIB - Static variable in interface org.apache.poi.ss.usermodel.Workbook
Device independent bitmap
PICTURE_TYPE_DIB - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Device independent bitmap
PICTURE_TYPE_DIB - Static variable in interface org.apache.poi.xwpf.usermodel.Document
Device independent bitmap
PICTURE_TYPE_EMF - Static variable in class org.apache.poi.hssf.usermodel.HSSFPicture

PICTURE_TYPE_EMF - Static variable in interface org.apache.poi.ss.usermodel.Workbook
Extended windows meta file
PICTURE_TYPE_EMF - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Extended windows meta file
PICTURE_TYPE_EMF - Static variable in interface org.apache.poi.xwpf.usermodel.Document
Extended windows meta file
PICTURE_TYPE_EPS - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Encapsulated Postscript (.eps)
PICTURE_TYPE_EPS - Static variable in class org.apache.poi.xssf.usermodel.XSSFWorkbook

PICTURE_TYPE_EPS - Static variable in interface org.apache.poi.xwpf.usermodel.Document
Encapsulated Postscript (.eps)
PICTURE_TYPE_GIF - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
GIF image format
PICTURE_TYPE_GIF - Static variable in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Images formats supported by XSSF but not by HSSF
PICTURE_TYPE_GIF - Static variable in interface org.apache.poi.xwpf.usermodel.Document
GIF image format
PICTURE_TYPE_JPEG - Static variable in class org.apache.poi.hssf.usermodel.HSSFPicture

PICTURE_TYPE_JPEG - Static variable in interface org.apache.poi.ss.usermodel.Workbook
JPEG format
PICTURE_TYPE_JPEG - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
JPEG format
PICTURE_TYPE_JPEG - Static variable in interface org.apache.poi.xwpf.usermodel.Document
JPEG format
PICTURE_TYPE_PICT - Static variable in class org.apache.poi.hssf.usermodel.HSSFPicture

PICTURE_TYPE_PICT - Static variable in interface org.apache.poi.ss.usermodel.Workbook
Mac PICT format
PICTURE_TYPE_PICT - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Mac PICT format
PICTURE_TYPE_PICT - Static variable in interface org.apache.poi.xwpf.usermodel.Document
Mac PICT format
PICTURE_TYPE_PNG - Static variable in class org.apache.poi.hssf.usermodel.HSSFPicture

PICTURE_TYPE_PNG - Static variable in interface org.apache.poi.ss.usermodel.Workbook
PNG format
PICTURE_TYPE_PNG - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
PNG format
PICTURE_TYPE_PNG - Static variable in interface org.apache.poi.xwpf.usermodel.Document
PNG format
PICTURE_TYPE_TIFF - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Tag Image File (.tiff)
PICTURE_TYPE_TIFF - Static variable in class org.apache.poi.xssf.usermodel.XSSFWorkbook

PICTURE_TYPE_TIFF - Static variable in interface org.apache.poi.xwpf.usermodel.Document
Tag Image File (.tiff)
PICTURE_TYPE_WMF - Static variable in class org.apache.poi.hssf.usermodel.HSSFPicture

PICTURE_TYPE_WMF - Static variable in interface org.apache.poi.ss.usermodel.Workbook
Windows Meta File
PICTURE_TYPE_WMF - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Windows Meta File
PICTURE_TYPE_WMF - Static variable in interface org.apache.poi.xwpf.usermodel.Document
Windows Meta File
PICTURE_TYPE_WPG - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
WordPerfect graphics (.wpg)
PICTURE_TYPE_WPG - Static variable in class org.apache.poi.xssf.usermodel.XSSFWorkbook

PICTURE_TYPE_WPG - Static variable in interface org.apache.poi.xwpf.usermodel.Document
WordPerfect graphics (.wpg)
PictureData - Class in org.apache.poi.hslf.usermodel
A class that represents image data contained in a slide show.
PictureData() - Constructor for class org.apache.poi.hslf.usermodel.PictureData

PictureData - Interface in org.apache.poi.sl.usermodel

PictureData - Interface in org.apache.poi.ss.usermodel

PictureFrame - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

pictures - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

PICTURES_ENTRY - Static variable in class org.apache.poi.hslf.dev.PPTXMLDump

PictureShape - Class in org.apache.poi.hssf.model
Represents a picture shape and creates all specific low level records.
PicturesManager - Interface in org.apache.poi.hwpf.converter
User-implemented pictures manager to store images on-disk
PicturesTable - Class in org.apache.poi.hwpf.model
Holds information about all pictures embedded in Word Document either via "Insert -> Picture -> From File" or via clipboard.
PicturesTable(HWPFDocument, byte[], byte[], FSPATable, EscherRecordHolder) - Constructor for class org.apache.poi.hwpf.model.PicturesTable
Deprecated.
PicturesTable(HWPFDocument, byte[], byte[]) - Constructor for class org.apache.poi.hwpf.model.PicturesTable

PictureType - Enum in org.apache.poi.hwpf.usermodel
Picture types supported by MS Word format
PID_APPNAME - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the application that created the document
PID_AUTHOR - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's author
PID_BYTECOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Number of bytes.
PID_CATEGORY - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
The entry is a string denoting the category the file belongs to, e.g.
PID_CHARCOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the number of characters in the document
PID_CODEPAGE - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
The entry denotes a code page.
PID_COMMENTS - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's comments
PID_COMPANY - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
This entry contains the company name.
PID_CREATE_DTM - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the date and time the document was created.
PID_DICTIONARY - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
The entry is a dictionary.
PID_DOCPARTS - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
This entry contains the names of document parts (word: names of the documents in the master document, excel: sheet names, power point: slide titles, binder: document names).
PID_EDITTIME - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's edit time
PID_HEADINGPAIR - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
This entry denotes an internally used property.
PID_HIDDENCOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Number of hidden slides.
PID_KEYWORDS - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's keywords
PID_LASTAUTHOR - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's last author
PID_LASTPRINTED - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the date and time the document was last printed
PID_LASTSAVE_DTM - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the date and time the document was saved
PID_LINECOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Number of lines.
PID_LINKSDIRTY - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
If this entry is -1 the links are dirty and should be re-evaluated.
PID_MANAGER - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
This entry contains the name of the project manager.
PID_MAX - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
The highest well-known property ID.
PID_MMCLIPCOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Number of multimedia clips, e.g.
PID_NOTECOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Number of slides with notes.
PID_PAGECOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the number of pages in the document
PID_PARCOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Number of paragraphs.
PID_PRESFORMAT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Target format for power point presentation, e.g.
PID_REVNUMBER - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's revision number
PID_SCALE - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
This entry is set to -1 when scaling of the thumbnail is desired.
PID_SECURITY - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes whether read/write access to the document is allowed or whether is should be opened as read-only.
PID_SLIDECOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Number of slides in a power point presentation.
PID_SUBJECT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's subject
PID_TEMPLATE - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's template
PID_THUMBNAIL - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's thumbnail
PID_TITLE - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the document's title
PID_WORDCOUNT - Static variable in class org.apache.poi.hpsf.wellknown.PropertyIDMap
ID of the property that denotes the number of words in the document
PIE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

PIE_WEDGE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

PieceDescriptor - Class in org.apache.poi.hwpf.model

PieceDescriptor(byte[], int) - Constructor for class org.apache.poi.hwpf.model.PieceDescriptor

PinExpression - Class in org.apache.poi.xslf.model.geom
Pin To Formula:
pitch - Variable in class org.apache.poi.hslf.model.PPFont

PIXEL_DPI - Static variable in class org.apache.poi.hslf.model.Shape
Pixels DPI (96 pixels per inch)
PIXEL_DPI - Static variable in class org.apache.poi.ss.util.ImageUtils

PIXEL_DPI - Static variable in class org.apache.poi.xssf.usermodel.XSSFShape

Placeholder - Class in org.apache.poi.hslf.model
Represents a Placeholder in PowerPoint.
Placeholder(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Placeholder

Placeholder(Shape) - Constructor for class org.apache.poi.hslf.model.Placeholder

Placeholder() - Constructor for class org.apache.poi.hslf.model.Placeholder

Placeholder - Enum in org.apache.poi.xslf.usermodel

PLACEHOLDER_FULLSIZE - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The full size of the master body text placeholder shape.
PLACEHOLDER_HALFSIZE - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
Half of the size of the master body text placeholder shape.
PLACEHOLDER_QUARTSIZE - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
A quarter of the size of the master body text placeholder shape.
PLAIN_OLD_XML - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Plain old xml.
PLAIN_TOKEN_SIZE - Static variable in class org.apache.poi.ss.formula.ptg.ArrayPtg
The size of the plain tArray token written within the standard formula tokens (not including the data which comes after all formula tokens)
Plaque - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

PLAQUE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

PLAQUE_TABS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Play - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
whether an associated sound, media or action verb is activated when the shape is clicked.
PLCASUMY - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCDOAHDR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCDumper - Class in org.apache.poi.hpbf.dev
For dumping out the PLC contents of QC Bits of a HPBF (Publisher) file, while we try to figure out what the format of them is.
PLCDumper(HPBFDocument) - Constructor for class org.apache.poi.hpbf.dev.PLCDumper

PLCDumper(POIFSFileSystem) - Constructor for class org.apache.poi.hpbf.dev.PLCDumper

PLCDumper(InputStream) - Constructor for class org.apache.poi.hpbf.dev.PLCDumper

PLCFANDREF - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFANDTXT - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFATNBKF - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFATNBKL - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFBKF - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFBKL - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFBTECHPX - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFBTELVC - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFBTEPAPX - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFDOAMOM - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFENDREF - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFENDTXT - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDATN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDATN - Static variable in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
PLCFFLDEDN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDEDN - Static variable in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
PLCFFLDFTN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDFTN - Static variable in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
PLCFFLDHDR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDHDR - Static variable in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
PLCFFLDHDRTXBX - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDHDRTXBX - Static variable in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
PLCFFLDMCR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDMOM - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDMOM - Static variable in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
PLCFFLDTXBX - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFLDTXBX - Static variable in class org.apache.poi.hwpf.model.FieldsTables
Deprecated.
PLCFFNDREF - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFFNDTXT - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFGLSY - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFGRAM - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFHDD - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFHDRTXBXTXT - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFLST - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFLVC - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFPAD - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFPGDEDN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFPGDFTN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFPHE - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFSEA - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFSED - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFSPL - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFTXBXBKD - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFTXBXHDRBKD - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFTXBXTXT - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCFWKB - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCMCR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCOCX - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCSPAHDR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCSPAMOM - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCUPCRGBUSE - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLCUPCUSP - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

plcValA - Variable in class org.apache.poi.hpbf.model.qcbits.QCPLCBit
The first value of each PLC, normally 4 bytes
plcValB - Variable in class org.apache.poi.hpbf.model.qcbits.QCPLCBit
The second value of each PLC, normally 4 bytes
PlexOfCps - Class in org.apache.poi.hwpf.model
Plex of CPs stored in File (PLCF) common data structure in a Word file.
PlexOfCps(int) - Constructor for class org.apache.poi.hwpf.model.PlexOfCps

PlexOfCps(byte[], int, int, int) - Constructor for class org.apache.poi.hwpf.model.PlexOfCps
Constructor
PlexOfField - Class in org.apache.poi.hwpf.model
Structure describing the Plex for fields (contained plclfd* in the spec).
PlexOfField(int, int, byte[]) - Constructor for class org.apache.poi.hwpf.model.PlexOfField
Deprecated.
PlexOfField(GenericPropertyNode) - Constructor for class org.apache.poi.hwpf.model.PlexOfField

PLFLFO - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PLGOSL - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

plot(ChartData, ChartAxis...) - Method in interface org.apache.poi.ss.usermodel.Chart
Plots specified data on the chart.
plot(ChartData, ChartAxis...) - Method in class org.apache.poi.xssf.usermodel.XSSFChart

PlotAreaRecord - Class in org.apache.poi.hssf.record.chart
preceeds and identifies a frame as belonging to the plot area.

PlotAreaRecord() - Constructor for class org.apache.poi.hssf.record.chart.PlotAreaRecord

PlotAreaRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.PlotAreaRecord

PlotGrowthRecord - Class in org.apache.poi.hssf.record.chart
The plot growth record specifies the scaling factors used when a font is scaled.

PlotGrowthRecord() - Constructor for class org.apache.poi.hssf.record.chart.PlotGrowthRecord

PlotGrowthRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.PlotGrowthRecord

PLS_004D - Static variable in class org.apache.poi.hssf.record.UnknownRecord
Environment-Specific Print Record
Plus - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

PLUS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

PMS - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PMT - Static variable in class org.apache.poi.ss.formula.functions.FinanceFunction

pmt(double, double, double, double, boolean) - Static method in class org.apache.poi.ss.formula.functions.FinanceLib

PNG - Class in org.apache.poi.hslf.blip
Represents a PNG picture data in a PPT file
PNG() - Constructor for class org.apache.poi.hslf.blip.PNG

PNG - Static variable in class org.apache.poi.hslf.model.Picture
PNG
PNG - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
POIDocument - Class in org.apache.poi
This holds the common functionality for all POI Document classes.
POIDocument(DirectoryNode) - Constructor for class org.apache.poi.POIDocument

POIDocument(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.POIDocument
Deprecated. use POIDocument.POIDocument(DirectoryNode) instead
POIDocument(POIFSFileSystem) - Constructor for class org.apache.poi.POIDocument

POIDocument(NPOIFSFileSystem) - Constructor for class org.apache.poi.POIDocument

POIFSBigBlockSize - Class in org.apache.poi.poifs.common
A class describing attributes of the Big Block Size
POIFSBigBlockSize(int, short) - Constructor for class org.apache.poi.poifs.common.POIFSBigBlockSize

POIFSChunkParser - Class in org.apache.poi.hsmf.parsers
Processes a POIFS of a .msg file into groups of Chunks, such as core data, attachment #1 data, attachment #2 data, recipient data and so on.
POIFSChunkParser() - Constructor for class org.apache.poi.hsmf.parsers.POIFSChunkParser

POIFSConstants - Interface in org.apache.poi.poifs.common
A repository for constants shared by POI classes.
POIFSDocument - Class in org.apache.poi.poifs.filesystem
This class manages a document in the POIFS filesystem.
POIFSDocument(String, RawDataBlock[], int) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument
Constructor from large blocks
POIFSDocument(String, SmallDocumentBlock[], int) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument
Constructor from small blocks
POIFSDocument(String, POIFSBigBlockSize, ListManagedBlock[], int) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument
Constructor from small blocks
POIFSDocument(String, ListManagedBlock[], int) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument

POIFSDocument(String, POIFSBigBlockSize, InputStream) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument
Constructor
POIFSDocument(String, InputStream) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument

POIFSDocument(String, int, POIFSBigBlockSize, POIFSDocumentPath, POIFSWriterListener) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument
Constructor
POIFSDocument(String, int, POIFSDocumentPath, POIFSWriterListener) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocument

POIFSDocumentPath - Class in org.apache.poi.poifs.filesystem
Class POIFSDocumentPath
POIFSDocumentPath(String[]) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocumentPath
constructor for the path of a document that is not in the root of the POIFSFileSystem
POIFSDocumentPath() - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocumentPath
simple constructor for the path of a document that is in the root of the POIFSFileSystem.
POIFSDocumentPath(POIFSDocumentPath, String[]) - Constructor for class org.apache.poi.poifs.filesystem.POIFSDocumentPath
constructor that adds additional subdirectories to an existing path
POIFSDump - Class in org.apache.poi.poifs.dev
Dump internal structure of a OLE2 file into file system
POIFSDump() - Constructor for class org.apache.poi.poifs.dev.POIFSDump

POIFSFileSystem - Class in org.apache.poi.poifs.filesystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem() - Constructor for class org.apache.poi.poifs.filesystem.POIFSFileSystem
Constructor, intended for writing
POIFSFileSystem(InputStream) - Constructor for class org.apache.poi.poifs.filesystem.POIFSFileSystem
Create a POIFSFileSystem from an InputStream.
POIFSHeaderDumper - Class in org.apache.poi.poifs.dev
A very low level debugging tool, for printing out core information on the headers and FAT blocks.
POIFSHeaderDumper() - Constructor for class org.apache.poi.poifs.dev.POIFSHeaderDumper

POIFSLister - Class in org.apache.poi.poifs.dev
A lister of the entries in POIFS files.
POIFSLister() - Constructor for class org.apache.poi.poifs.dev.POIFSLister

POIFSReader - Class in org.apache.poi.poifs.eventfilesystem
An event-driven reader for POIFS file systems.
POIFSReader() - Constructor for class org.apache.poi.poifs.eventfilesystem.POIFSReader
Create a POIFSReader
POIFSReaderEvent - Class in org.apache.poi.poifs.eventfilesystem
Class POIFSReaderEvent
POIFSReaderListener - Interface in org.apache.poi.poifs.eventfilesystem
Interface POIFSReaderListener
POIFSViewable - Interface in org.apache.poi.poifs.dev
Interface for a drill-down viewable object.
POIFSViewEngine - Class in org.apache.poi.poifs.dev
This class contains methods used to inspect POIFSViewable objects
POIFSViewEngine() - Constructor for class org.apache.poi.poifs.dev.POIFSViewEngine

POIFSViewer - Class in org.apache.poi.poifs.dev
A simple viewer for POIFS files
POIFSViewer() - Constructor for class org.apache.poi.poifs.dev.POIFSViewer

POIFSWriterEvent - Class in org.apache.poi.poifs.filesystem
Class POIFSWriterEvent
POIFSWriterListener - Interface in org.apache.poi.poifs.filesystem
Interface POIFSWriterListener
POILogFactory - Class in org.apache.poi.util
Provides logging without clients having to mess with configuration/initialization.
POILogger - Class in org.apache.poi.util
A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
POINT_DPI - Static variable in class org.apache.poi.hslf.model.Shape
Points DPI (72 pixels per inch)
POINT_DPI - Static variable in class org.apache.poi.xssf.usermodel.XSSFShape

Pointer - Class in org.apache.poi.hdgf.pointers
Base class of pointers, which hold metadata and offsets about blocks elsewhere in the file
Pointer() - Constructor for class org.apache.poi.hdgf.pointers.Pointer

PointerContainingStream - Class in org.apache.poi.hdgf.streams
A stream that holds pointers, possibly in addition to some other data too.
PointerContainingStream(Pointer, StreamStore, ChunkFactory, PointerFactory) - Constructor for class org.apache.poi.hdgf.streams.PointerContainingStream

PointerFactory - Class in org.apache.poi.hdgf.pointers
Factor class to create the appropriate pointers, based on the version of the file
PointerFactory(int) - Constructor for class org.apache.poi.hdgf.pointers.PointerFactory

PointerV6 - Class in org.apache.poi.hdgf.pointers
A Pointer from v6+
PointerV6() - Constructor for class org.apache.poi.hdgf.pointers.PointerV6

POIOLE2TextExtractor - Class in org.apache.poi
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POIOLE2TextExtractor(POIDocument) - Constructor for class org.apache.poi.POIOLE2TextExtractor
Creates a new text extractor for the given document
POISSON - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

POITextExtractor - Class in org.apache.poi
Common Parent for Text Extractors of POI Documents.
POITextExtractor(POIDocument) - Constructor for class org.apache.poi.POITextExtractor
Creates a new text extractor for the given document
POITextExtractor(POITextExtractor) - Constructor for class org.apache.poi.POITextExtractor
Creates a new text extractor, using the same document as another text extractor.
POIXMLDocument - Class in org.apache.poi

POIXMLDocument(OPCPackage) - Constructor for class org.apache.poi.POIXMLDocument

POIXMLDocumentPart - Class in org.apache.poi
Represents an entry of a OOXML package.
POIXMLDocumentPart(OPCPackage) - Constructor for class org.apache.poi.POIXMLDocumentPart
Construct POIXMLDocumentPart representing a "core document" package part.
POIXMLDocumentPart() - Constructor for class org.apache.poi.POIXMLDocumentPart
Creates new POIXMLDocumentPart - called by client code to create new parts from scratch.
POIXMLDocumentPart(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.POIXMLDocumentPart
Creates an POIXMLDocumentPart representing the given package part and relationship.
POIXMLDocumentPart(POIXMLDocumentPart, PackagePart, PackageRelationship) - Constructor for class org.apache.poi.POIXMLDocumentPart
Creates an POIXMLDocumentPart representing the given package part, relationship and parent Called by POIXMLDocumentPart.read(POIXMLFactory, java.util.Map) when reading in an exisiting file.
POIXMLException - Exception in org.apache.poi
Indicates a generic OOXML error.
POIXMLException() - Constructor for exception org.apache.poi.POIXMLException
Create a new POIXMLException with no detail mesage.
POIXMLException(String) - Constructor for exception org.apache.poi.POIXMLException
Create a new POIXMLException with the String specified as an error message.
POIXMLException(String, Throwable) - Constructor for exception org.apache.poi.POIXMLException
Create a new POIXMLException with the String specified as an error message and the cause.
POIXMLException(Throwable) - Constructor for exception org.apache.poi.POIXMLException
Create a new POIXMLException with the specified cause.
POIXMLFactory - Class in org.apache.poi
Defines a factory API that enables sub-classes to create instances of POIXMLDocumentPart
POIXMLFactory() - Constructor for class org.apache.poi.POIXMLFactory

POIXMLProperties - Class in org.apache.poi
Wrapper around the two different kinds of OOXML properties a document can have
POIXMLProperties(OPCPackage) - Constructor for class org.apache.poi.POIXMLProperties

POIXMLProperties.CoreProperties - Class in org.apache.poi
The core document properties
POIXMLProperties.CustomProperties - Class in org.apache.poi
Custom document properties
POIXMLProperties.ExtendedProperties - Class in org.apache.poi
Extended document properties
POIXMLPropertiesTextExtractor - Class in org.apache.poi
A POITextExtractor for returning the textual content of the OOXML file properties, eg author and title.
POIXMLPropertiesTextExtractor(POIXMLDocument) - Constructor for class org.apache.poi.POIXMLPropertiesTextExtractor
Creates a new POIXMLPropertiesTextExtractor for the given open document.
POIXMLPropertiesTextExtractor(POIXMLTextExtractor) - Constructor for class org.apache.poi.POIXMLPropertiesTextExtractor
Creates a new POIXMLPropertiesTextExtractor, for the same file that another TextExtractor is already working on.
POIXMLRelation - Class in org.apache.poi
Represents a descriptor of a OOXML relation.
POIXMLRelation(String, String, String, Class<? extends POIXMLDocumentPart>) - Constructor for class org.apache.poi.POIXMLRelation
Instantiates a POIXMLRelation.
POIXMLRelation(String, String, String) - Constructor for class org.apache.poi.POIXMLRelation
Instantiates a POIXMLRelation.
POIXMLTextExtractor - Class in org.apache.poi

POIXMLTextExtractor(POIXMLDocument) - Constructor for class org.apache.poi.POIXMLTextExtractor
Creates a new text extractor for the given document
Polygon - Class in org.apache.poi.hslf.model
A simple closed polygon shape
Polygon(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Polygon
Create a Polygon object and initialize it from the supplied Record container.
Polygon(Shape) - Constructor for class org.apache.poi.hslf.model.Polygon
Create a new Polygon.
Polygon() - Constructor for class org.apache.poi.hslf.model.Polygon
Create a new Polygon.
PolygonShape - Class in org.apache.poi.hssf.model

populateDictionary(byte[]) - Method in class org.apache.poi.hdgf.HDGFLZW
We want an empty dictionary, so do nothing
populateDictionary(byte[]) - Method in class org.apache.poi.hmef.CompressedRTF

populateDictionary(byte[]) - Method in class org.apache.poi.util.LZWDecompresser
Populates the dictionary, and returns where in it to begin writing new codes.
PositionDependentRecord - Interface in org.apache.poi.hslf.record
Records which either care about where they are on disk, or have other records who care about where they are, will implement this interface.
PositionDependentRecordAtom - Class in org.apache.poi.hslf.record
A special (and dangerous) kind of Record Atom that cares about where it lives on the disk, or who has other Atoms that care about where this is on the disk.
PositionDependentRecordAtom() - Constructor for class org.apache.poi.hslf.record.PositionDependentRecordAtom

PositionDependentRecordContainer - Class in org.apache.poi.hslf.record
A special (and dangerous) kind of Record Container, for which other Atoms care about where this one lives on disk.
PositionDependentRecordContainer() - Constructor for class org.apache.poi.hslf.record.PositionDependentRecordContainer

PositionInParagraph - Class in org.apache.poi.xwpf.usermodel
postion of a character in a paragrapho 1st RunPositon 2nd TextPosition 3rd CharacterPosition
PositionInParagraph() - Constructor for class org.apache.poi.xwpf.usermodel.PositionInParagraph

PositionInParagraph(int, int, int) - Constructor for class org.apache.poi.xwpf.usermodel.PositionInParagraph

positionRecords(List<RecordBase>) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Some apps can define multiple HeaderFooterRecord records for a sheet.
POST_FOLDER_ENTRIES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POST_FOLDER_NAMES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POST_OFFICE_BOX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POST_REPLY_DENIED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POST_REPLY_FOLDER_ENTRIES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POST_REPLY_FOLDER_NAMES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POSTAL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POSTAL_CODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

POWER - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

PowerEval - Static variable in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

PowerPointExtractor - Class in org.apache.poi.hslf.extractor
This class can be used to extract text from a PowerPoint file.
PowerPointExtractor(String) - Constructor for class org.apache.poi.hslf.extractor.PowerPointExtractor
Creates a PowerPointExtractor, from a file
PowerPointExtractor(InputStream) - Constructor for class org.apache.poi.hslf.extractor.PowerPointExtractor
Creates a PowerPointExtractor, from an Input Stream
PowerPointExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hslf.extractor.PowerPointExtractor
Creates a PowerPointExtractor, from an open POIFSFileSystem
PowerPointExtractor(NPOIFSFileSystem) - Constructor for class org.apache.poi.hslf.extractor.PowerPointExtractor
Creates a PowerPointExtractor, from an open NPOIFSFileSystem
PowerPointExtractor(DirectoryNode) - Constructor for class org.apache.poi.hslf.extractor.PowerPointExtractor
Creates a PowerPointExtractor, from a specific place inside an open NPOIFSFileSystem
PowerPointExtractor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hslf.extractor.PowerPointExtractor
Deprecated. Use PowerPointExtractor.PowerPointExtractor(DirectoryNode) instead
PowerPointExtractor(HSLFSlideShow) - Constructor for class org.apache.poi.hslf.extractor.PowerPointExtractor
Creates a PowerPointExtractor, from a HSLFSlideShow
PowerPtg - Class in org.apache.poi.ss.formula.ptg

PPDOC_ENTRY - Static variable in class org.apache.poi.hslf.dev.PPTXMLDump

PPDrawing - Class in org.apache.poi.hslf.record
These are actually wrappers onto Escher drawings.
PPDrawing(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.PPDrawing
Sets everything up, groks the escher etc
PPDrawing() - Constructor for class org.apache.poi.hslf.record.PPDrawing
Creates a new, empty, PPDrawing (typically for use with a new Slide or Notes)
PPDrawing - Static variable in class org.apache.poi.hslf.record.RecordTypes

PPDrawingGroup - Class in org.apache.poi.hslf.record
Container records which always exists inside Document.
PPDrawingGroup(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.PPDrawingGroup

PPDrawingGroup - Static variable in class org.apache.poi.hslf.record.RecordTypes

PPDrawingTextListing - Class in org.apache.poi.hslf.dev
Uses record level code to locate PPDrawing entries.
PPDrawingTextListing() - Constructor for class org.apache.poi.hslf.dev.PPDrawingTextListing

PPFont - Class in org.apache.poi.hslf.model
Represents a Font used in a presenation.
PPFont() - Constructor for class org.apache.poi.hslf.model.PPFont
Creates a new instance of PPFont
PPFont(FontEntityAtom) - Constructor for class org.apache.poi.hslf.model.PPFont
Creates a new instance of PPFont and initialize it from the supplied font atom
PPGraphics2D - Class in org.apache.poi.hslf.model
Translates Graphics2D calls into PowerPoint.
PPGraphics2D(ShapeGroup) - Constructor for class org.apache.poi.hslf.model.PPGraphics2D
Construct Java Graphics object which translates graphic calls in ppt drawing layer.
ppt97FileVer - Static variable in class org.apache.poi.hslf.record.CurrentUserAtom
The Powerpoint 97 version, major and minor numbers
PPTX2PNG - Class in org.apache.poi.xslf.util
An utulity to convert slides of a .pptx slide show to a PNG image
PPTX2PNG() - Constructor for class org.apache.poi.xslf.util.PPTX2PNG

PPTXMLDump - Class in org.apache.poi.hslf.dev
Utility class which dumps raw contents of a ppt file into XML format
PPTXMLDump(File) - Constructor for class org.apache.poi.hslf.dev.PPTXMLDump

PRDRVR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PrecisionRecord - Class in org.apache.poi.hssf.record
Title: Precision Record
PrecisionRecord() - Constructor for class org.apache.poi.hssf.record.PrecisionRecord

PrecisionRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PrecisionRecord

preData - Variable in class org.apache.poi.hpbf.model.qcbits.QCPLCBit
The data which goes before the main PLC entries.
preferArray() - Method in interface org.apache.poi.poifs.dev.POIFSViewable
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
preferArray() - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
preferArray() - Method in class org.apache.poi.poifs.filesystem.DocumentNode
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
preferArray() - Method in class org.apache.poi.poifs.filesystem.NPOIFSDocument
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
preferArray() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
preferArray() - Method in class org.apache.poi.poifs.filesystem.POIFSDocument
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
preferArray() - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
preferArray() - Method in class org.apache.poi.poifs.property.Property
Give viewers a hint as to whether to call getViewableArray or getViewableIterator
PREFIX - Static variable in class org.apache.poi.hsmf.datatypes.AttachmentChunks

PREFIX - Static variable in class org.apache.poi.hsmf.datatypes.NameIdChunks

PREFIX - Static variable in class org.apache.poi.hsmf.datatypes.RecipientChunks

PRENVLAND - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

PRENVPORT - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

prependContentsWith(byte[]) - Method in class org.apache.poi.hdgf.streams.StreamStore

PREPROCESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PRESENTATION_MACRO - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

PRESENTATIONML - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

PRESENTATIONML_TEMPLATE - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

preSerialize() - Method in class org.apache.poi.hssf.model.InternalSheet
Perform any work necessary before the sheet is about to be serialized.
preserveSpaces(STXstring) - Static method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Add the xml:spaces="preserve" attribute if the string has leading or trailing spaces
PresetGeometries - Class in org.apache.poi.xslf.model.geom
Date: 10/25/11
prettyPrint() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

prettyPrint() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

preWrite() - Method in class org.apache.poi.poifs.property.DirectoryProperty
Perform whatever activities need to be performed prior to writing
preWrite() - Method in class org.apache.poi.poifs.property.DocumentProperty
Perform whatever activities need to be performed prior to writing
preWrite() - Method in class org.apache.poi.poifs.property.Property
Perform whatever activities need to be performed prior to writing
preWrite() - Method in class org.apache.poi.poifs.property.PropertyTable
Prepare to be written
PRIMARY_CAPABILITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PRIMARY_FAX_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PRIMARY_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PrintCellComments - Enum in org.apache.poi.ss.usermodel
These enumerations specify how cell comments shall be displayed for paper printing purposes.
printDump() - Method in class org.apache.poi.hslf.dev.SlideShowDumper

printDump() - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

PRINTER_SETTINGS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

printEscherContainerRecord(EscherContainerRecord) - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

printEscherRecord(EscherRecord) - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

printGridlines - Variable in class org.apache.poi.hssf.model.InternalSheet

PrintGridlinesRecord - Class in org.apache.poi.hssf.record
Title: Print Gridlines Record
PrintGridlinesRecord() - Constructor for class org.apache.poi.hssf.record.PrintGridlinesRecord

PrintGridlinesRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PrintGridlinesRecord

PrintHeadersRecord - Class in org.apache.poi.hssf.record
Title: Print Headers Record
PrintHeadersRecord() - Constructor for class org.apache.poi.hssf.record.PrintHeadersRecord

PrintHeadersRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PrintHeadersRecord

PrintOrientation - Enum in org.apache.poi.ss.usermodel
The enumeration value indicating the print orientation for a sheet.
PrintSetup - Interface in org.apache.poi.ss.usermodel

PrintSetupRecord - Class in org.apache.poi.hssf.record
Title: PAGESETUP (0x00A1)
Description: Stores print setup options -- bogus for HSSF (and marked as such)
REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214

PrintSetupRecord() - Constructor for class org.apache.poi.hssf.record.PrintSetupRecord

PrintSetupRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.PrintSetupRecord

PRINTSIZE_0033 - Static variable in class org.apache.poi.hssf.record.UnknownRecord
seems to be part of the PageSettingsBlock.
printStackTrace() - Method in exception org.apache.poi.hpsf.HPSFRuntimeException

printStackTrace(PrintStream) - Method in exception org.apache.poi.hpsf.HPSFRuntimeException

printStackTrace(PrintWriter) - Method in exception org.apache.poi.hpsf.HPSFRuntimeException

printUsage() - Static method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

PRIORITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

process(Entry, ChunkGroup) - Static method in class org.apache.poi.hsmf.parsers.POIFSChunkParser
Creates a chunk, and gives it to its parent group
process(File) - Static method in class org.apache.poi.hssf.converter.ExcelToFoConverter
Converts Excel file (97-2007) into XSL FO file.
process(File) - Static method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter
Converts Excel file (97-2007) into HTML file.
processBookmarks(HWPFDocumentCore, Element, Range, int, List<Bookmark>) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter
Wrap range into bookmark(s) and process it.
processBookmarks(HWPFDocumentCore, Element, Range, int, List<Bookmark>) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processBookmarks(HWPFDocumentCore, Element, Range, int, List<Bookmark>) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processBookmarks(HWPFDocumentCore, Element, Range, int, List<Bookmark>) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processCell(HSSFWorkbook, HSSFCell, Element, int, int, float) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processCell(HSSFCell, Element, int, int, float) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processCellStyle(HSSFWorkbook, HSSFCellStyle, Element, Element) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processCellStyleBorder(HSSFWorkbook, Element, String, short, short) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processCellStyleFont(HSSFWorkbook, Element, HSSFFont) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processCharacters(HWPFDocumentCore, int, Range, Element) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processChildRecords() - Method in class org.apache.poi.hssf.record.DrawingGroupRecord
Process the bytes into escher records.
processChunks(DirectoryNode, ChunkGroup) - Static method in class org.apache.poi.hsmf.parsers.POIFSChunkParser
Creates all the chunks for a given Directory, but doesn't recurse or descend
processColumnHeaders(HSSFSheet, int, Element) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processColumnHeaders(HSSFSheet, int, Element) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processColumnWidths(HSSFSheet, int, Element) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter
Creates COLGROUP element with width specified for all columns.
processColumnWidths(HSSFSheet, int, Element) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter
Creates COLGROUP element with width specified for all columns.
processCommands() - Method in class org.apache.poi.hdgf.chunks.Chunk
Uses our CommandDefinitions to process the commands our chunk type has, and figure out the values for them.
processContinueRecord(byte[]) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

processContinueRecord(byte[]) - Method in class org.apache.poi.hssf.record.DrawingRecord

processDeadField(HWPFDocumentCore, Element, Range, int, int, int, int) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processDocument(HWPFDocumentCore) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processDocumentInformation(SummaryInformation) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processDocumentInformation(SummaryInformation) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processDocumentInformation(SummaryInformation) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processDocumentInformation(SummaryInformation) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processDocumentInformation(SummaryInformation) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processDocumentInformation(SummaryInformation) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processDocumentPart(HWPFDocumentCore, Range) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processDocumentPart(HWPFDocumentCore, Range) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processDocumentPart(HWPFDocumentCore, Range) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processDrawnObject(HWPFDocument, CharacterRun, Element) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processDrawnObject(HWPFDocument, CharacterRun, OfficeDrawing, String, Element) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processDrawnObject(HWPFDocument, CharacterRun, OfficeDrawing, String, Element) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processDrawnObject(HWPFDocument, CharacterRun, OfficeDrawing, String, Element) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processDrawnObject(HWPFDocument, CharacterRun, OfficeDrawing, String, Element) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processEndnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processEndnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processEndnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processEndnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processEvents(HSSFRequest, InputStream) - Method in class org.apache.poi.hssf.eventusermodel.HSSFEventFactory
Processes a DocumentInputStream into essentially Record events.
processField(HWPFDocument, Range, int, Field, Element) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processFootnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processFootnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processFootnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processFootnoteAutonumbered(HWPFDocument, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processHyperlink(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processHyperlink(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processHyperlink(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processHyperlink(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processImage(Element, boolean, Picture) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processImage(Element, boolean, Picture, String) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processImage(Element, boolean, Picture, String) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processImage(Element, boolean, Picture, String) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processImage(Element, boolean, Picture) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processImage(Element, boolean, Picture, String) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processImageWithoutPicturesManager(Element, boolean, Picture) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processImageWithoutPicturesManager(Element, boolean, Picture) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processImageWithoutPicturesManager(Element, boolean, Picture) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processImageWithoutPicturesManager(Element, boolean, Picture) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processLineBreak(Element, CharacterRun) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processLineBreak(Element, CharacterRun) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processLineBreak(Element, CharacterRun) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processLineBreak(Element, CharacterRun) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processNote(HWPFDocument, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processNoteAnchor(HWPFDocument, CharacterRun, Element) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processNoteAutonumbered(HWPFDocument, String, int, Element, Range) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processOle2(HWPFDocument, Element, Entry) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processOle2(HWPFDocument, Element, Entry) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processPageBreak(HWPFDocumentCore, Element) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processPageBreak(HWPFDocumentCore, Element) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processPageBreak(HWPFDocumentCore, Element) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processPageBreak(HWPFDocumentCore, Element) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processPageref(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processPageref(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processPageref(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processPageref(HWPFDocumentCore, Element, Range, int, String) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processParagraph(HWPFDocumentCore, Element, int, Paragraph, String) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processParagraph(HWPFDocumentCore, Element, int, Paragraph, String) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processParagraph(HWPFDocumentCore, Element, int, Paragraph, String) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processParagraph(HWPFDocumentCore, Element, int, Paragraph, String) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processParagraphes(HWPFDocumentCore, Element, Range, int) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processPOIFSReaderEvent(POIFSReaderEvent) - Method in interface org.apache.poi.poifs.eventfilesystem.POIFSReaderListener
Process a POIFSReaderEvent that this listener had registered for
processPOIFSWriterEvent(POIFSWriterEvent) - Method in interface org.apache.poi.poifs.filesystem.POIFSWriterListener
Process a POIFSWriterEvent that this listener had registered for
processRecord(Record) - Method in interface org.apache.poi.hssf.eventmodel.ERFListener
Process a Record.
processRecord(Record) - Method in class org.apache.poi.hssf.eventusermodel.AbortableHSSFListener
This method, inherited from HSSFListener is implemented as a stub.
processRecord(Record) - Method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener
Process this record ourselves, and then pass it on to our child listener
processRecord(Record) - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Process this record ourselves, and then pass it on to our child listener
processRecord(Record) - Method in interface org.apache.poi.hssf.eventusermodel.HSSFListener
process an HSSF Record.
processRecord(Record) - Method in class org.apache.poi.hssf.eventusermodel.HSSFRequest
Called by HSSFEventFactory, passes the Record to each listener associated with a record.sid.
processRecord(Record) - Method in class org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener

processRecordInternally(Record) - Method in class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener
Process the record ourselves, but do not pass it on to the child Listener.
processRecordInternally(Record) - Method in class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
Process the record ourselves, but do not pass it on to the child Listener.
processRecords(InputStream) - Method in class org.apache.poi.hssf.eventmodel.EventRecordFactory
Create an array of records from an input stream
processRow(HSSFWorkbook, CellRangeAddress[][], HSSFRow, Element) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processRow(CellRangeAddress[][], HSSFRow, Element) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processRowNumber(HSSFRow) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processRowNumber(HSSFRow, Element) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processSection(HWPFDocumentCore, Section, int) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processSection(HWPFDocumentCore, Section, int) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processSection(HWPFDocumentCore, Section, int) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processSection(HWPFDocumentCore, Section, int) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processSheet(HSSFWorkbook, HSSFSheet, Element) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processSheet(HSSFWorkbook, int) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter
Process single sheet (as specified by 0-based sheet index)
processSheet(HSSFSheet) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processSheet(XSSFSheetXMLHandler.SheetContentsHandler, StylesTable, ReadOnlySharedStringsTable, InputStream) - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Processes the given sheet
processSheetHeader(Element, HSSFSheet) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processSheetName(HSSFSheet, Element) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processSingleSection(HWPFDocumentCore, Section) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processSingleSection(HWPFDocumentCore, Section) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processTable(HWPFDocumentCore, Element, Table) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

processTable(HWPFDocumentCore, Element, Table) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

processTable(HWPFDocumentCore, Element, Table) - Method in class org.apache.poi.hwpf.converter.WordToHtmlConverter

processTable(HWPFDocumentCore, Element, Table) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

processWorkbook(HSSFWorkbook) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

processWorkbook(HSSFWorkbook) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

processWorkbookEvents(HSSFRequest, POIFSFileSystem) - Method in class org.apache.poi.hssf.eventusermodel.HSSFEventFactory
Processes a file into essentially record events.
processWorkbookEvents(HSSFRequest, DirectoryNode) - Method in class org.apache.poi.hssf.eventusermodel.HSSFEventFactory
Processes a file into essentially record events.
PRODUCT - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

PROFESSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROFILE_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ProgBinaryTag - Static variable in class org.apache.poi.hslf.record.RecordTypes

ProgStringTag - Static variable in class org.apache.poi.hslf.record.RecordTypes

ProgTags - Static variable in class org.apache.poi.hslf.record.RecordTypes

PROOF_OF_DELIVERY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROOF_OF_DELIVERY_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROOF_OF_SUBMISSION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROOF_OF_SUBMISSION_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROP_ID_SECURE_MAX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROP_ID_SECURE_MIN - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

properties - Variable in class org.apache.poi.ddf.AbstractEscherOptRecord

properties - Variable in class org.apache.poi.hpsf.Section

propertiesRoot - Variable in class org.apache.poi.hwpf.converter.FoDocumentFacade

Property - Class in org.apache.poi.hpsf
A property in a Section of a PropertySet.
Property(long, long, Object) - Constructor for class org.apache.poi.hpsf.Property
Creates a property.
Property(long, byte[], long, int, int) - Constructor for class org.apache.poi.hpsf.Property
Creates a Property instance by reading its bytes from the property set stream.
Property() - Constructor for class org.apache.poi.hpsf.Property
Creates an empty property.
Property - Class in org.apache.poi.poifs.property
This abstract base class is the ancestor of all classes implementing POIFS Property behavior.
Property() - Constructor for class org.apache.poi.poifs.property.Property

Property(int, byte[], int) - Constructor for class org.apache.poi.poifs.property.Property
Constructor from byte data
PROPERTY_SIZE - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
How big a single property is
PROPERTY_TYPE_OFFSET - Static variable in interface org.apache.poi.poifs.property.PropertyConstants

PropertyBlock - Class in org.apache.poi.poifs.storage
A block of Property instances
PropertyConstants - Interface in org.apache.poi.poifs.property
Interface PropertyConstants
PropertyFetcher<T> - Class in org.apache.poi.xslf.model
Used internally to navigate the PresentationML text style hierarchy and fetch properties
PropertyFetcher() - Constructor for class org.apache.poi.xslf.model.PropertyFetcher

PropertyIDMap - Class in org.apache.poi.hpsf.wellknown
This is a dictionary which maps property ID values to property ID strings.
PropertyIDMap(int, float) - Constructor for class org.apache.poi.hpsf.wellknown.PropertyIDMap
Creates a PropertyIDMap.
PropertyIDMap(Map) - Constructor for class org.apache.poi.hpsf.wellknown.PropertyIDMap
Creates a PropertyIDMap backed by another map.
PropertyModifier - Class in org.apache.poi.hwpf.model

PropertyModifier(short) - Constructor for class org.apache.poi.hwpf.model.PropertyModifier

PropertyNode<T extends PropertyNode<T>> - Class in org.apache.poi.hwpf.model
Represents a lightweight node in the Trees used to store content properties.
PropertyNode(int, int, Object) - Constructor for class org.apache.poi.hwpf.model.PropertyNode

PropertyNode.EndComparator - Class in org.apache.poi.hwpf.model

PropertyNode.EndComparator() - Constructor for class org.apache.poi.hwpf.model.PropertyNode.EndComparator

PropertyNode.StartComparator - Class in org.apache.poi.hwpf.model

PropertyNode.StartComparator() - Constructor for class org.apache.poi.hwpf.model.PropertyNode.StartComparator

PropertySet - Class in org.apache.poi.hpsf
Represents a property set in the Horrible Property Set Format (HPSF).
PropertySet() - Constructor for class org.apache.poi.hpsf.PropertySet
Creates an empty (uninitialized) PropertySet.
PropertySet(InputStream) - Constructor for class org.apache.poi.hpsf.PropertySet
Creates a PropertySet instance from an InputStream in the Horrible Property Set Format.
PropertySet(byte[], int, int) - Constructor for class org.apache.poi.hpsf.PropertySet
Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.
PropertySet(byte[]) - Constructor for class org.apache.poi.hpsf.PropertySet
Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.
PropertySetFactory - Class in org.apache.poi.hpsf
Factory class to create instances of SummaryInformation, DocumentSummaryInformation and PropertySet.
PropertySetFactory() - Constructor for class org.apache.poi.hpsf.PropertySetFactory

PropertyTable - Class in org.apache.poi.poifs.property
This class embodies the Property Table for the POIFSFileSystem; this is basically the directory for all of the documents in the filesystem.
PropertyTable(HeaderBlock) - Constructor for class org.apache.poi.poifs.property.PropertyTable

PropertyTable(HeaderBlock, RawDataBlockList) - Constructor for class org.apache.poi.poifs.property.PropertyTable
reading constructor (used when we've read in a file and we want to extract the property table from it).
PropertyTableBase - Class in org.apache.poi.poifs.property
This class embodies the Property Table for the filesystem, which looks up entries in the filesystem to their chain of blocks.
PropertyTableBase(HeaderBlock) - Constructor for class org.apache.poi.poifs.property.PropertyTableBase

PropertyTableBase(HeaderBlock, List<Property>) - Constructor for class org.apache.poi.poifs.property.PropertyTableBase
Reading constructor (used when we've read in a file and we want to extract the property table from it).
propertyValue - Variable in class org.apache.poi.ddf.EscherSimpleProperty

propName - Variable in class org.apache.poi.hslf.model.textproperties.TextProp

PROTECTION__LOCKADJUSTHANDLES - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKAGAINSTGROUPING - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKAGAINSTSELECT - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKASPECTRATIO - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKCROPPING - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKPOSITION - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKROTATION - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKTEXT - Static variable in class org.apache.poi.ddf.EscherProperties

PROTECTION__LOCKVERTICES - Static variable in class org.apache.poi.ddf.EscherProperties

ProtectionRev4Record - Class in org.apache.poi.hssf.record
Title: Protection Revision 4 Record (0x01AF)
Description: describes whether this is a protected shared/tracked workbook
REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

ProtectionRev4Record(boolean) - Constructor for class org.apache.poi.hssf.record.ProtectionRev4Record

ProtectionRev4Record(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ProtectionRev4Record

ProtectRecord - Class in org.apache.poi.hssf.record
Title: Protect Record (0x0012)
Description: defines whether a sheet or workbook is protected (HSSF DOES NOT SUPPORT ENCRYPTION)
HSSF now supports the simple "protected" sheets (where they are not encrypted and open office et al ignore the password record entirely).
ProtectRecord(boolean) - Constructor for class org.apache.poi.hssf.record.ProtectRecord

ProtectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ProtectRecord

protectSheet(String, boolean, boolean) - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock
protect a spreadsheet with a password (not encrypted, just sets protect flags and the password.
protectSheet(String) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets the protection enabled as well as the password
protectSheet(String) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets the protection enabled as well as the password
protectSheet(String) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets the protection enabled as well as the password
protectSheet(String) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Enables sheet protection and sets the password for the sheet.
prototype() - Static method in class org.apache.poi.xssf.usermodel.XSSFConnector
Initialize default structure of a new auto-shape
prototype() - Static method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Initialize default structure of a new graphic frame
prototype() - Static method in class org.apache.poi.xssf.usermodel.XSSFPicture
Returns a prototype that is used to construct new shapes
prototype() - Static method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup
Initialize default structure of a new shape group
prototype() - Static method in class org.apache.poi.xssf.usermodel.XSSFSimpleShape
Prototype with the default structure of a new auto-shape.
PROVIDER_AES - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

PROVIDER_DISPLAY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROVIDER_DLL_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROVIDER_ORDINAL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROVIDER_RC4 - Static variable in class org.apache.poi.poifs.crypt.EncryptionHeader

PROVIDER_SUBMIT_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PROVIDER_UID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

PrpublicintOptions - Static variable in class org.apache.poi.hslf.record.RecordTypes

Ptg - Class in org.apache.poi.ss.formula.ptg
Ptg represents a syntactic token in a formula.
Ptg() - Constructor for class org.apache.poi.ss.formula.ptg.Ptg

PTYPE_APPTIME - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
AppTime - application time value
PTYPE_BINARY - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Binary - counted byte array
PTYPE_BOOLEAN - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Boolean - 16-bit Boolean value.
PTYPE_CLASSID - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
ClassId - OLE GUID
PTYPE_CURRENCY - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Currency - signed 64-bit integer that represents a base ten decimal with four digits to the right of the decimal point
PTYPE_DOUBLE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Double - floating point double
PTYPE_ERROR - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Error - 32-bit error value
PTYPE_I2 - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
I2 - signed 16-bit value
PTYPE_I8 - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
I8 - 8-byte signed integer
PTYPE_LONG - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Long - signed 32-bit value
PTYPE_MULTIVALUED - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
MultiValued - Value part contains multiple values
PTYPE_NULL - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Null - NULL property value
PTYPE_OBJECT - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Object - embedded object in a property
PTYPE_R4 - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
R4 - 4-byte floating point value
PTYPE_STRING8 - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
String8 - null-terminated 8-bit character string
PTYPE_SYSTIME - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
SysTime - FILETIME 64-bit integer specifying the number of 100ns periods since Jan 1, 1601
PTYPE_UNICODE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Unicode - null-terminated Unicode string
PTYPE_UNSPECIFIED - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty
Unspecified
PublisherTextExtractor - Class in org.apache.poi.hpbf.extractor
Extract text from HPBF Publisher files
PublisherTextExtractor(HPBFDocument) - Constructor for class org.apache.poi.hpbf.extractor.PublisherTextExtractor

PublisherTextExtractor(DirectoryNode) - Constructor for class org.apache.poi.hpbf.extractor.PublisherTextExtractor

PublisherTextExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hpbf.extractor.PublisherTextExtractor

PublisherTextExtractor(NPOIFSFileSystem) - Constructor for class org.apache.poi.hpbf.extractor.PublisherTextExtractor

PublisherTextExtractor(InputStream) - Constructor for class org.apache.poi.hpbf.extractor.PublisherTextExtractor

PublisherTextExtractor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hpbf.extractor.PublisherTextExtractor
Deprecated.
PUID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

put(String, CustomProperty) - Method in class org.apache.poi.hpsf.CustomProperties
Puts a CustomProperty into this map.
put(String, String) - Method in class org.apache.poi.hpsf.CustomProperties
Adds a named string property.
put(String, Long) - Method in class org.apache.poi.hpsf.CustomProperties
Adds a named long property.
put(String, Double) - Method in class org.apache.poi.hpsf.CustomProperties
Adds a named double property.
put(String, Integer) - Method in class org.apache.poi.hpsf.CustomProperties
Adds a named integer property.
put(String, Boolean) - Method in class org.apache.poi.hpsf.CustomProperties
Adds a named boolean property.
put(String, Date) - Method in class org.apache.poi.hpsf.CustomProperties
Adds a named date property.
put(long, String) - Method in class org.apache.poi.hpsf.wellknown.PropertyIDMap
Puts a ID string for an ID into the PropertyIDMap.
put(byte[], PropertyIDMap) - Method in class org.apache.poi.hpsf.wellknown.SectionIDMap
Associates a section format ID with a PropertyIDMap.
put(Object, Object) - Method in class org.apache.poi.hpsf.wellknown.SectionIDMap
Deprecated. Use SectionIDMap.put(byte[], PropertyIDMap) instead!
put(PackagePartName, PackagePart) - Method in class org.apache.poi.openxml4j.opc.PackagePartCollection
Check rule [M1.11]: a package implementer shall neither create nor recognize a part with a part name derived from another part name by appending segments to it.
put(Object, Object) - Method in class org.apache.poi.util.BinaryTree
Associates the specified value with the specified key in this map.
putBorder(XSSFCellBorder) - Method in class org.apache.poi.xssf.model.StylesTable

putByte(byte[], int, int) - Static method in class org.apache.poi.util.LittleEndian
executes:
data[offset] = (byte)value;
putCellStyleXf(CTXf) - Method in class org.apache.poi.xssf.model.StylesTable

putCellXf(CTXf) - Method in class org.apache.poi.xssf.model.StylesTable

putCompressedUnicode(String, byte[], int) - Static method in class org.apache.poi.util.StringUtil
Takes a unicode (java) string, and returns it as 8 bit data (in ISO-8859-1 codepage).
putCompressedUnicode(String, LittleEndianOutput) - Static method in class org.apache.poi.util.StringUtil

putDouble(byte[], int, double) - Static method in class org.apache.poi.util.LittleEndian
put a double value into a byte array
putDouble(double, OutputStream) - Static method in class org.apache.poi.util.LittleEndian
put a double value into a byte array
putDxf(CTDxf) - Method in class org.apache.poi.xssf.model.StylesTable

putFill(XSSFCellFill) - Method in class org.apache.poi.xssf.model.StylesTable

putFloat(byte[], int, float) - Static method in class org.apache.poi.util.LittleEndian
put a float value into a byte array
putFloat(float, OutputStream) - Static method in class org.apache.poi.util.LittleEndian
put a float value into a byte array
putFont(XSSFFont, boolean) - Method in class org.apache.poi.xssf.model.StylesTable
Records the given font in the font table.
putFont(XSSFFont) - Method in class org.apache.poi.xssf.model.StylesTable

putInt(byte[], int) - Static method in class org.apache.poi.util.LittleEndian
Deprecated. Use LittleEndian.putInt(byte[], int, int) instead
putInt(byte[], int, int) - Static method in class org.apache.poi.util.LittleEndian
put an int value into a byte array
putInt(int, OutputStream) - Static method in class org.apache.poi.util.LittleEndian
Put int into output stream
putLong(byte[], int, long) - Static method in class org.apache.poi.util.LittleEndian
put a long value into a byte array
putLong(long, OutputStream) - Static method in class org.apache.poi.util.LittleEndian
Put long into output stream
putNumberFormat(String) - Method in class org.apache.poi.xssf.model.StylesTable

putShort(byte[], int, short) - Static method in class org.apache.poi.util.LittleEndian
put a short value into a byte array
putShort(byte[], short) - Static method in class org.apache.poi.util.LittleEndian
Deprecated. Use LittleEndian.putShort(byte[], int, short) instead
putShort(OutputStream, short) - Static method in class org.apache.poi.util.LittleEndian
Put signed short into output stream
putShortArray(byte[], int, short[]) - Static method in class org.apache.poi.util.LittleEndian
Stores short array in buffer
putStyle(XSSFCellStyle) - Method in class org.apache.poi.xssf.model.StylesTable

putUByte(byte[], int, short) - Static method in class org.apache.poi.util.LittleEndian
put an unsigned byte value into a byte array
putUInt(byte[], int, long) - Static method in class org.apache.poi.util.LittleEndian
put an unsigned int value into a byte array
putUInt(byte[], long) - Static method in class org.apache.poi.util.LittleEndian
Deprecated. Use LittleEndian.putUInt(byte[], int, long) instead
putUInt(long, OutputStream) - Static method in class org.apache.poi.util.LittleEndian
Put unsigned int into output stream
putUnicodeLE(String, byte[], int) - Static method in class org.apache.poi.util.StringUtil
Takes a unicode string, and returns it as little endian (most important byte last) bytes in the supplied byte array.
putUnicodeLE(String, LittleEndianOutput) - Static method in class org.apache.poi.util.StringUtil

putUShort(byte[], int, int) - Static method in class org.apache.poi.util.LittleEndian
put an unsigned short value into a byte array
putUShort(int, OutputStream) - Static method in class org.apache.poi.util.LittleEndian
Put unsigned short into output stream
PV - Static variable in class org.apache.poi.ss.formula.functions.FinanceFunction

pv(double, double, double, double, boolean) - Static method in class org.apache.poi.ss.formula.functions.FinanceLib
Present value of an amount given the number of future payments, rate, amount of individual payment, future value and boolean value indicating whether payments are due at the beginning of period (false => payments are due at end of period)

Q

QCBit - Class in org.apache.poi.hpbf.model.qcbits
Parent of all Quill CONTENTS bits
QCBit(String, String, byte[]) - Constructor for class org.apache.poi.hpbf.model.qcbits.QCBit

QCPLCBit - Class in org.apache.poi.hpbf.model.qcbits
A "PLC " (PLC) based bit of Quill Contents.
QCPLCBit.Type0 - Class in org.apache.poi.hpbf.model.qcbits
Type 0 seem to be somewhat rare.
QCPLCBit.Type12 - Class in org.apache.poi.hpbf.model.qcbits
Type 12 holds hyperlinks, and is very complex.
QCPLCBit.Type4 - Class in org.apache.poi.hpbf.model.qcbits
Type 4 is quite common.
QCPLCBit.Type8 - Class in org.apache.poi.hpbf.model.qcbits
Type 8 is quite common.
QCTextBit - Class in org.apache.poi.hpbf.model.qcbits
A Text based bit of Quill Contents
QCTextBit(String, String, byte[]) - Constructor for class org.apache.poi.hpbf.model.qcbits.QCTextBit

QUAD_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

QUAD_ARROW_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

QuadArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

QuadArrowCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

QuadToCommand - Class in org.apache.poi.xslf.model.geom
Date: 10/25/11
QUARTER_BODY_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

QUARTO_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
Quarto 215x275 mm
QuickButCruddyTextExtractor - Class in org.apache.poi.hslf.extractor
This class will get all the text from a Powerpoint Document, including all the bits you didn't want, and in a somewhat random order, but will do it very fast.
QuickButCruddyTextExtractor(String) - Constructor for class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
Creates an extractor from a given file name
QuickButCruddyTextExtractor(InputStream) - Constructor for class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
Creates an extractor from a given input stream
QuickButCruddyTextExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
Creates an extractor from a POIFS Filesystem
QuickTest - Class in org.apache.poi.hwpf

QuickTest() - Constructor for class org.apache.poi.hwpf.QuickTest

QUICKTIP_0800 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

QuillContents - Class in org.apache.poi.hpbf.model
Quill -> QuillSub -> CONTENTS
QuillContents(DirectoryNode) - Constructor for class org.apache.poi.hpbf.model.QuillContents

R

RADIANS - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

RADIO_TELEPHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RAND - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

Range - Class in org.apache.poi.hwpf.usermodel
This class is the central class of the HWPF object model.
Range(int, int, HWPFDocumentCore) - Constructor for class org.apache.poi.hwpf.usermodel.Range
Used to construct a Range from a document.
Range(int, int, Range) - Constructor for class org.apache.poi.hwpf.usermodel.Range
Used to create Ranges that are children of other Ranges.
Range(int, int, int, Range) - Constructor for class org.apache.poi.hwpf.usermodel.Range
Deprecated.
RangeEval - Class in org.apache.poi.ss.formula.eval

RangePtg - Class in org.apache.poi.ss.formula.ptg

Rank - Class in org.apache.poi.ss.formula.functions
Returns the rank of a number in a list of numbers.
Rank() - Constructor for class org.apache.poi.ss.formula.functions.Rank

Rate - Class in org.apache.poi.ss.formula.functions
Implements the Excel Rate function
Rate() - Constructor for class org.apache.poi.ss.formula.functions.Rate

RawDataBlock - Class in org.apache.poi.poifs.storage
A big block created from an InputStream, holding the raw data
RawDataBlock(InputStream) - Constructor for class org.apache.poi.poifs.storage.RawDataBlock
Constructor RawDataBlock
RawDataBlock(InputStream, int) - Constructor for class org.apache.poi.poifs.storage.RawDataBlock
Constructor RawDataBlock
RawDataBlockList - Class in org.apache.poi.poifs.storage
A list of RawDataBlocks instances, and methods to manage the list
RawDataBlockList(InputStream, POIFSBigBlockSize) - Constructor for class org.apache.poi.poifs.storage.RawDataBlockList
Constructor RawDataBlockList
RCVD_REPRESENTING_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RCVD_REPRESENTING_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RCVD_REPRESENTING_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RCVD_REPRESENTING_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RCVD_REPRESENTING_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

read(byte[], int) - Method in class org.apache.poi.hpsf.ClassID
Reads the class ID's value from a byte array by turning little-endian into big-endian.
read(byte[], int, int, long, int) - Static method in class org.apache.poi.hpsf.VariantSupport
Reads a variant type from a byte array.
read(byte[], int) - Method in class org.apache.poi.hslf.blip.Metafile.Header

read(byte[], int) - Method in class org.apache.poi.hslf.blip.WMF.AldusHeader

read(RecordStream) - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable
reads zero or more consecutive MergeCellsRecords
read(byte[], int, int) - Method in class org.apache.poi.hssf.record.RecordInputStream

read(InputStream) - Method in class org.apache.poi.poifs.eventfilesystem.POIFSReader
Read from an InputStream and process the documents we get
read() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

read(byte[]) - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

read(byte[], int, int) - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

read() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

read(byte[], int, int) - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

read() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

read(byte[], int, int) - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

read(int, long) - Method in class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

read(int, long) - Method in class org.apache.poi.poifs.nio.DataSource

read(int, long) - Method in class org.apache.poi.poifs.nio.FileBackedDataSource

read(POIXMLFactory, Map<PackagePart, POIXMLDocumentPart>) - Method in class org.apache.poi.POIXMLDocumentPart
Iterate through the underlying PackagePart and create child POIXMLFactory instances using the specified factory
read(int, LittleEndianInput) - Static method in class org.apache.poi.ss.formula.Formula
Convenience method for Formula.read(int, LittleEndianInput, int)
read(int, LittleEndianInput, int) - Static method in class org.apache.poi.ss.formula.Formula
When there are no array constants present, encodedTokenLen==totalEncodedLen
read(LittleEndianInput) - Static method in class org.apache.poi.ss.formula.ptg.BoolPtg

read(LittleEndianInput) - Static method in class org.apache.poi.ss.formula.ptg.ErrPtg

read() - Method in class org.apache.poi.util.BlockingInputStream

read(byte[]) - Method in class org.apache.poi.util.BlockingInputStream
We had to revert to byte per byte reading to keep with slow network connections on one hand, without missing the end-of-file.
read(byte[], int, int) - Method in class org.apache.poi.util.BlockingInputStream

read(InputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFChartSheet

read(InputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

read(InputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFVMLDrawing

read() - Method in class org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream
Warning - doesn't fix!
read(byte[], int, int) - Method in class org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream

read(byte[]) - Method in class org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream

READ_RECEIPT_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

READ_RECEIPT_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

READ_RECEIPT_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

READ_WRITE_FILE_BUFFER_SIZE - Static variable in class org.apache.poi.openxml4j.opc.internal.ZipHelper
Buffer to read data from file.
readAllContinuedRemainder() - Method in class org.apache.poi.hssf.record.RecordInputStream
Deprecated. Best to write a input stream that wraps this one where there is special sub record that may overlap continue records.
readByte() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readByte() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readByte() - Method in class org.apache.poi.hssf.record.RecordInputStream
Reads an 8 bit, signed value
readByte() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readByte() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readByte() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readByte() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readByte() - Method in interface org.apache.poi.util.LittleEndianInput

readByte() - Method in class org.apache.poi.util.LittleEndianInputStream

readCompressedUnicode(int) - Method in class org.apache.poi.hssf.record.RecordInputStream

readCompressedUnicode(LittleEndianInput, int) - Static method in class org.apache.poi.util.StringUtil

readCoordinates(LittleEndianInput) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

readCoordinates(LittleEndianInput) - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

readData(String) - Static method in class org.apache.poi.util.HexRead
This method reads hex data from a filename and returns a byte array.
readData(InputStream, String) - Static method in class org.apache.poi.util.HexRead
Same as readData(String) except that this method allows you to specify sections within a file.
readData(String, String) - Static method in class org.apache.poi.util.HexRead

readData(InputStream, int) - Static method in class org.apache.poi.util.HexRead

readDataSize() - Method in interface org.apache.poi.hssf.record.BiffHeaderInput
Read an unsigned short from the stream without decrypting
readDataSize() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream
Reads an unsigned short value without decrypting
readDictionary(byte[], long, int, int) - Method in class org.apache.poi.hpsf.Property
Reads a dictionary.
readDouble() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readDouble() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readDouble() - Method in class org.apache.poi.hssf.record.RecordInputStream

readDouble() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readDouble() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readDouble() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readDouble() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readDouble() - Method in interface org.apache.poi.util.LittleEndianInput

readDouble() - Method in class org.apache.poi.util.LittleEndianInputStream

readFrom(InputStream) - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
Read this shared strings table from an XML file.
readFrom(InputStream) - Method in class org.apache.poi.xssf.model.CalculationChain

readFrom(InputStream) - Method in class org.apache.poi.xssf.model.CommentsTable

readFrom(InputStream) - Method in class org.apache.poi.xssf.model.MapInfo

readFrom(InputStream) - Method in class org.apache.poi.xssf.model.SharedStringsTable
Read this shared strings table from an XML file.
readFrom(InputStream) - Method in class org.apache.poi.xssf.model.SingleXmlCells

readFrom(InputStream) - Method in class org.apache.poi.xssf.model.StylesTable
Read this shared styles table from an XML file.
readFrom(InputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFTable

readFromBytes(byte[]) - Method in class org.apache.poi.util.ByteField
set the value from its offset into an array of bytes
readFromBytes(byte[]) - Method in interface org.apache.poi.util.FixedField
set the value from its offset into an array of bytes
readFromBytes(byte[]) - Method in class org.apache.poi.util.IntegerField
set the value from its offset into an array of bytes
readFromBytes(byte[]) - Method in class org.apache.poi.util.LongField
set the value from its offset into an array of bytes
readFromBytes(byte[]) - Method in class org.apache.poi.util.ShortField
set the value from its offset into an array of bytes
readFromStream(InputStream) - Method in class org.apache.poi.util.ByteField
set the value from an InputStream
readFromStream(InputStream) - Method in interface org.apache.poi.util.FixedField
set the value from an InputStream
readFromStream(InputStream) - Method in class org.apache.poi.util.IntegerField
set the value from an InputStream
readFromStream(InputStream) - Method in class org.apache.poi.util.LongField
set the value from an InputStream
readFromStream(InputStream) - Method in class org.apache.poi.util.ShortField
set the value from an InputStream
readFromString(String) - Static method in class org.apache.poi.util.HexRead

readFully(byte[]) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readFully(byte[], int, int) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readFully(byte[]) - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readFully(byte[], int, int) - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readFully(byte[]) - Method in class org.apache.poi.hssf.record.RecordInputStream

readFully(byte[], int, int) - Method in class org.apache.poi.hssf.record.RecordInputStream

readFully(byte[]) - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readFully(byte[], int, int) - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readFully(byte[], int, int) - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readFully(byte[], int, int) - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readFully(byte[], int, int) - Method in class org.apache.poi.poifs.storage.DataInputBlock
Reads len bytes from this block into the supplied buffer.
readFully(InputStream, byte[]) - Static method in class org.apache.poi.util.IOUtils
Helper method, just calls readFully(in, b, 0, b.length)
readFully(InputStream, byte[], int, int) - Static method in class org.apache.poi.util.IOUtils
Same as the normal in.read(b, off, len), but tries to ensure that the entire len number of bytes is read.
readFully(ReadableByteChannel, ByteBuffer) - Static method in class org.apache.poi.util.IOUtils
Same as the normal channel.read(b), but tries to ensure that the entire len number of bytes is read.
readFully(byte[], int, int) - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readFully(byte[]) - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readFully(byte[]) - Method in interface org.apache.poi.util.LittleEndianInput

readFully(byte[], int, int) - Method in interface org.apache.poi.util.LittleEndianInput

readFully(byte[]) - Method in class org.apache.poi.util.LittleEndianInputStream

readFully(byte[], int, int) - Method in class org.apache.poi.util.LittleEndianInputStream

readHdrFtr() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

readHeader(byte[], int) - Method in class org.apache.poi.ddf.EscherRecord
Reads the 8 byte header information and populates the options and recordId records.
readImage(PackagePart) - Method in class org.apache.poi.xslf.usermodel.XSLFImageRenderer
Create a buffered image from the supplied package part.
ReadingNotSupportedException - Exception in org.apache.poi.hpsf
This exception is thrown when HPSF tries to read a (yet) unsupported variant type.
ReadingNotSupportedException(long, Object) - Constructor for exception org.apache.poi.hpsf.ReadingNotSupportedException
Constructor
readInstance(byte[], int) - Static method in class org.apache.poi.ddf.EscherRecord
Read the options field from header and return instance part of it.
readInt() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readInt() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readInt() - Method in class org.apache.poi.hssf.record.RecordInputStream
Reads a 32 bit, signed value
readInt() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readInt() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readInt() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readInt(InputStream) - Static method in class org.apache.poi.util.LittleEndian
get an int value from an InputStream
readInt() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readInt() - Method in interface org.apache.poi.util.LittleEndianInput

readInt() - Method in class org.apache.poi.util.LittleEndianInputStream

readIntLE() - Method in class org.apache.poi.poifs.storage.DataInputBlock
Reads an int which was encoded in little endian format.
readIntLE(DataInputBlock, int) - Method in class org.apache.poi.poifs.storage.DataInputBlock
Reads an int which spans the end of prevBlock and the start of this block.
readLong() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readLong() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readLong() - Method in class org.apache.poi.hssf.record.RecordInputStream
Reads a 64 bit, signed value
readLong() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readLong() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readLong() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readLong(InputStream) - Static method in class org.apache.poi.util.LittleEndian
get a long value from an InputStream
readLong() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readLong() - Method in interface org.apache.poi.util.LittleEndianInput

readLong() - Method in class org.apache.poi.util.LittleEndianInputStream

readLongLE() - Method in class org.apache.poi.poifs.storage.DataInputBlock
Reads a long which was encoded in little endian format.
readLongLE(DataInputBlock, int) - Method in class org.apache.poi.poifs.storage.DataInputBlock
Reads a long which spans the end of prevBlock and the start of this block.
ReadOnlySharedStringsTable - Class in org.apache.poi.xssf.eventusermodel
This is a lightweight way to process the Shared Strings table.
ReadOnlySharedStringsTable(OPCPackage) - Constructor for class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable

ReadOnlySharedStringsTable(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
Like POIXMLDocumentPart constructor
readProperties() - Method in class org.apache.poi.POIDocument
Find, and create objects for, the standard Documment Information Properties (HPSF).
readRecordSID() - Method in interface org.apache.poi.hssf.record.BiffHeaderInput
Read an unsigned short from the stream without decrypting
readRecordSID() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream
Reads an unsigned short value without decrypting
readRemainder() - Method in class org.apache.poi.hssf.record.RecordInputStream
Returns the remaining bytes for the current record.
readShort() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readShort() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readShort() - Method in class org.apache.poi.hssf.record.RecordInputStream
Reads a 16 bit, signed value
readShort() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readShort() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readShort() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readShort(InputStream) - Static method in class org.apache.poi.util.LittleEndian
get a short value from an InputStream
readShort() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readShort() - Method in interface org.apache.poi.util.LittleEndianInput

readShort() - Method in class org.apache.poi.util.LittleEndianInputStream

readString() - Method in class org.apache.poi.hssf.record.RecordInputStream

readTokens(int, LittleEndianInput) - Static method in class org.apache.poi.ss.formula.ptg.Ptg
Reads size bytes of the input stream, to create an array of Ptgs.
readUByte() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readUByte() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readUByte() - Method in class org.apache.poi.hssf.record.RecordInputStream
Reads an 8 bit, unsigned value
readUByte() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readUByte() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readUByte() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readUByte() - Method in class org.apache.poi.poifs.storage.DataInputBlock

readUByte() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readUByte() - Method in interface org.apache.poi.util.LittleEndianInput

readUByte() - Method in class org.apache.poi.util.LittleEndianInputStream

readUnicodeLE(LittleEndianInput, int) - Static method in class org.apache.poi.util.StringUtil

readUnicodeLEString(int) - Method in class org.apache.poi.hssf.record.RecordInputStream
given a byte array of 16-bit unicode characters, compress to 8-bit and return a string { 0x16, 0x00 } -0x16
readUnicodeString(LittleEndianInput) - Static method in class org.apache.poi.util.StringUtil
InputStream in is expected to contain: ushort nChars byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
readUnicodeString(LittleEndianInput, int) - Static method in class org.apache.poi.util.StringUtil
InputStream in is expected to contain: byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
readUShort() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordInput

readUShort() - Method in class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

readUShort() - Method in class org.apache.poi.hssf.record.RecordInputStream
Reads a 16 bit, unsigned value.
readUShort() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

readUShort() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

readUShort() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

readUShort(InputStream) - Static method in class org.apache.poi.util.LittleEndian

readUShort() - Method in class org.apache.poi.util.LittleEndianByteArrayInputStream

readUShort() - Method in interface org.apache.poi.util.LittleEndianInput

readUShort() - Method in class org.apache.poi.util.LittleEndianInputStream

readUShortLE() - Method in class org.apache.poi.poifs.storage.DataInputBlock
Reads a short which was encoded in little endian format.
readUShortLE(DataInputBlock) - Method in class org.apache.poi.poifs.storage.DataInputBlock
Reads a short which spans the end of prevBlock and the start of this block.
readValue(InputStream) - Method in class org.apache.poi.hsmf.datatypes.ByteChunk

readValue(InputStream) - Method in class org.apache.poi.hsmf.datatypes.Chunk
Reads the value of this chunk using an InputStream
readValue(InputStream) - Method in class org.apache.poi.hsmf.datatypes.DirectoryChunk

readValue(InputStream) - Method in class org.apache.poi.hsmf.datatypes.MessageSubmissionChunk

readValue(InputStream) - Method in class org.apache.poi.hsmf.datatypes.StringChunk

rebase(OPCPackage) - Method in class org.apache.poi.POIXMLDocumentPart
When you open something like a theme, call this to re-base the XML Document onto the core child of the current core document
rebuild(ComplexFileTable) - Method in class org.apache.poi.hwpf.model.CHPBinTable

rebuild(StringBuilder, ComplexFileTable) - Method in class org.apache.poi.hwpf.model.PAPBinTable

RecalcIdRecord - Class in org.apache.poi.hssf.record
Title: Recalc Id Record (0x01C1)
Description: This record contains an ID that marks when a worksheet was last recalculated.
RecalcIdRecord() - Constructor for class org.apache.poi.hssf.record.RecalcIdRecord

RecalcIdRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.RecalcIdRecord

RECEIPT_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECEIVE_FOLDER_SETTINGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECEIVED_BY_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECEIVED_BY_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECEIVED_BY_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECEIVED_BY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECEIVED_BY_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_CERTIFICATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_DISPLAY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_DISPLAY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.RecipientChunks

RECIPIENT_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.RecipientChunks

RECIPIENT_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_FLAGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_NAME - Static variable in class org.apache.poi.hsmf.datatypes.RecipientChunks

RECIPIENT_NUMBER_FOR_ADVICE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_REASSIGNMENT_PROHIBITED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_SEARCH - Static variable in class org.apache.poi.hsmf.datatypes.RecipientChunks

RECIPIENT_SMTP_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.RecipientChunks

RECIPIENT_STATUS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RECIPIENT_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RecipientChunks - Class in org.apache.poi.hsmf.datatypes
Collection of convenience chunks for the Recip(ient) part of an outlook file.
RecipientChunks(String) - Constructor for class org.apache.poi.hsmf.datatypes.RecipientChunks

RecipientChunks.RecipientChunksSorter - Class in org.apache.poi.hsmf.datatypes
Orders by the recipient number.
RecipientChunks.RecipientChunksSorter() - Constructor for class org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter

recipientDisplayNameChunk - Variable in class org.apache.poi.hsmf.datatypes.RecipientChunks
The display name of the recipient.
recipientEmailChunk - Variable in class org.apache.poi.hsmf.datatypes.RecipientChunks
The email address of the recipient, which could be in SMTP or SEARCH format, but isn't always present...
recipientNameChunk - Variable in class org.apache.poi.hsmf.datatypes.RecipientChunks
The "name", which could be their name if an internal person, or their email address if an external person
recipientNumber - Variable in class org.apache.poi.hsmf.datatypes.RecipientChunks
Our 0 based position in the list of recipients
recipientSearchChunk - Variable in class org.apache.poi.hsmf.datatypes.RecipientChunks
TODO
recipientSMTPChunk - Variable in class org.apache.poi.hsmf.datatypes.RecipientChunks
The smtp destination email address of the recipient, but isn't always present...
RecolorInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

Record - Class in org.apache.poi.hslf.record
This abstract class represents a record in the PowerPoint document.
Record() - Constructor for class org.apache.poi.hslf.record.Record

record(Chunk) - Method in class org.apache.poi.hsmf.datatypes.AttachmentChunks
Called by the parser whenever a chunk is found.
record(Chunk) - Method in interface org.apache.poi.hsmf.datatypes.ChunkGroup
Called by the parser whenever a chunk is found.
record(Chunk) - Method in class org.apache.poi.hsmf.datatypes.Chunks
Called by the parser whenever a chunk is found.
record(Chunk) - Method in class org.apache.poi.hsmf.datatypes.NameIdChunks
Called by the parser whenever a chunk is found.
record(Chunk) - Method in class org.apache.poi.hsmf.datatypes.RecipientChunks
Called by the parser whenever a chunk is found.
Record - Class in org.apache.poi.hssf.record
Title: Record Description: All HSSF Records inherit from this class.
Record() - Constructor for class org.apache.poi.hssf.record.Record

record - Variable in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Low-level record object that stores the actual hyperlink data
RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherBlipRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherBlipWMFRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherBSERecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherChildAnchorRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherClientAnchorRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherClientDataRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherDggRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherDgRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherOptRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherSpgrRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherSpRecord

RECORD_DESCRIPTION - Static variable in class org.apache.poi.ddf.EscherTextboxRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherBSERecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherChildAnchorRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherClientAnchorRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherClientDataRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherDggRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherDgRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherOptRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherSpgrRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherSpRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherTertiaryOptRecord

RECORD_ID - Static variable in class org.apache.poi.ddf.EscherTextboxRecord

RECORD_ID_DIB - Static variable in class org.apache.poi.ddf.EscherBitmapBlip

RECORD_ID_EMF - Static variable in class org.apache.poi.ddf.EscherMetafileBlip

RECORD_ID_EMF - Static variable in class org.apache.poi.ddf.EscherPictBlip

RECORD_ID_END - Static variable in class org.apache.poi.ddf.EscherBlipRecord

RECORD_ID_JPEG - Static variable in class org.apache.poi.ddf.EscherBitmapBlip

RECORD_ID_PICT - Static variable in class org.apache.poi.ddf.EscherMetafileBlip

RECORD_ID_PICT - Static variable in class org.apache.poi.ddf.EscherPictBlip

RECORD_ID_PNG - Static variable in class org.apache.poi.ddf.EscherBitmapBlip

RECORD_ID_START - Static variable in class org.apache.poi.ddf.EscherBlipRecord

RECORD_ID_WMF - Static variable in class org.apache.poi.ddf.EscherMetafileBlip

RECORD_ID_WMF - Static variable in class org.apache.poi.ddf.EscherPictBlip

RECORD_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RecordAggregate - Class in org.apache.poi.hssf.record.aggregates
RecordAggregates are groups of of BIFF Records that are typically stored together and/or updated together.
RecordAggregate() - Constructor for class org.apache.poi.hssf.record.aggregates.RecordAggregate

RecordAggregate.PositionTrackingVisitor - Class in org.apache.poi.hssf.record.aggregates
A wrapper for RecordAggregate.RecordVisitor which accumulates the sizes of all records visited.
RecordAggregate.PositionTrackingVisitor(RecordAggregate.RecordVisitor, int) - Constructor for class org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor

RecordAggregate.RecordVisitor - Interface in org.apache.poi.hssf.record.aggregates

RecordAtom - Class in org.apache.poi.hslf.record
Abstract class which all atom records will extend.
RecordAtom() - Constructor for class org.apache.poi.hslf.record.RecordAtom

RecordBase - Class in org.apache.poi.hssf.record
Common base class of Record and RecordAggregate
RecordBase() - Constructor for class org.apache.poi.hssf.record.RecordBase

RecordContainer - Class in org.apache.poi.hslf.record
Abstract class which all container records will extend.
RecordContainer() - Constructor for class org.apache.poi.hslf.record.RecordContainer

RecordFactory - Class in org.apache.poi.hssf.record
Title: Record Factory
RecordFactory() - Constructor for class org.apache.poi.hssf.record.RecordFactory

RecordFactoryInputStream - Class in org.apache.poi.hssf.record
A stream based way to get at complete records, with as low a memory footprint as possible.
RecordFactoryInputStream(InputStream, boolean) - Constructor for class org.apache.poi.hssf.record.RecordFactoryInputStream

RecordFormatException - Exception in org.apache.poi.hssf.record
Title: Record Format Exception Description: Used by records to indicate invalid format/data.
RecordFormatException(String) - Constructor for exception org.apache.poi.hssf.record.RecordFormatException

RecordFormatException(String, Throwable) - Constructor for exception org.apache.poi.hssf.record.RecordFormatException

RecordFormatException(Throwable) - Constructor for exception org.apache.poi.hssf.record.RecordFormatException

RecordFormatException - Exception in org.apache.poi.util
A common exception thrown by our binary format parsers (especially HSSF and DDF), when they hit invalid format or data when processing a record.
RecordFormatException(String) - Constructor for exception org.apache.poi.util.RecordFormatException

RecordFormatException(String, Throwable) - Constructor for exception org.apache.poi.util.RecordFormatException

RecordFormatException(Throwable) - Constructor for exception org.apache.poi.util.RecordFormatException

RecordGenerator - Class in org.apache.poi.dev
Description of the Class
RecordGenerator() - Constructor for class org.apache.poi.dev.RecordGenerator

recordHandlingClass(int) - Static method in class org.apache.poi.hslf.record.RecordTypes
Returns the class handling a record by its type.
RecordInputStream - Class in org.apache.poi.hssf.record
Title: Record Input Stream
RecordInputStream(InputStream) - Constructor for class org.apache.poi.hssf.record.RecordInputStream

RecordInputStream(InputStream, Biff8EncryptionKey, int) - Constructor for class org.apache.poi.hssf.record.RecordInputStream

RecordInputStream.LeftoverDataException - Exception in org.apache.poi.hssf.record
For use in BiffViewer which may construct Records that don't completely read all available data.
RecordInputStream.LeftoverDataException(int, int) - Constructor for exception org.apache.poi.hssf.record.RecordInputStream.LeftoverDataException

RecordLister - Class in org.apache.poi.hssf.dev
This is a low-level debugging class, which simply prints out what records come in what order.
RecordLister() - Constructor for class org.apache.poi.hssf.dev.RecordLister

recordName(int) - Static method in class org.apache.poi.hslf.record.RecordTypes
Returns name of the record by its type
RecordStream - Class in org.apache.poi.hssf.model
Simplifies iteration over a sequence of Record objects.
RecordStream(List<Record>, int, int) - Constructor for class org.apache.poi.hssf.model.RecordStream
Creates a RecordStream bounded by startIndex and endIndex
RecordStream(List<Record>, int) - Constructor for class org.apache.poi.hssf.model.RecordStream

RecordTypes - Class in org.apache.poi.hslf.record
List of all known record types in a PowerPoint document, and the classes that handle them.
RecordTypes() - Constructor for class org.apache.poi.hslf.record.RecordTypes

RecordTypes.Type - Class in org.apache.poi.hslf.record
Wrapper for the details of a PowerPoint or Escher record type.
RecordTypes.Type(int, Class<? extends Record>) - Constructor for class org.apache.poi.hslf.record.RecordTypes.Type

RecordUtil - Class in org.apache.poi.hwpf.dev
Helper functions for the record transformations.
RecordUtil() - Constructor for class org.apache.poi.hwpf.dev.RecordUtil

RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Rectangle - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

REDIRECTION_HISTORY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Ref3DPtg - Class in org.apache.poi.ss.formula.ptg
Title: Reference 3D Ptg
Ref3DPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.Ref3DPtg

Ref3DPtg(String, int) - Constructor for class org.apache.poi.ss.formula.ptg.Ref3DPtg

Ref3DPtg(CellReference, int) - Constructor for class org.apache.poi.ss.formula.ptg.Ref3DPtg

REF_ABSOLUTE - Static variable in class org.apache.poi.ss.formula.functions.Address

REF_INVALID - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval
#REF! - Illegal or deleted cell reference
REF_INVALID - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg
#REF! - Illegal or deleted cell reference
REF_RELATIVE - Static variable in class org.apache.poi.ss.formula.functions.Address

REF_ROW_ABSOLUTE_COLUMN_RELATIVE - Static variable in class org.apache.poi.ss.formula.functions.Address

REF_ROW_RELATIVE_RELATIVE_ABSOLUTE - Static variable in class org.apache.poi.ss.formula.functions.Address

REFERENCE_TYPE_DEFAULT_CATEGORIES - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

REFERENCE_TYPE_DIRECT - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

REFERENCE_TYPE_ERROR_REPORTED - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

REFERENCE_TYPE_NOT_USED - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

REFERENCE_TYPE_WORKSHEET - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

referenceUpdated(String, CTComment) - Method in class org.apache.poi.xssf.model.CommentsTable
Called after the reference is updated, so that we can reflect that in our cache
REFERRED_BY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RefErrorPtg - Class in org.apache.poi.ss.formula.ptg
RefError - handles deleted cell reference
RefErrorPtg() - Constructor for class org.apache.poi.ss.formula.ptg.RefErrorPtg

RefErrorPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.RefErrorPtg

RefEval - Interface in org.apache.poi.ss.formula.eval

RefEvalBase - Class in org.apache.poi.ss.formula.eval
Common base class for implementors of RefEval
RefEvalBase(int, int) - Constructor for class org.apache.poi.ss.formula.eval.RefEvalBase

RefModeRecord - Class in org.apache.poi.hssf.record
Title: RefMode Record
RefModeRecord() - Constructor for class org.apache.poi.hssf.record.RefModeRecord

RefModeRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.RefModeRecord

RefNPtg - Class in org.apache.poi.ss.formula.ptg
RefNPtg
RefNPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.RefNPtg

RefPtg - Class in org.apache.poi.ss.formula.ptg
ReferencePtg - handles references (such as A1, A2, IA4)
RefPtg(String) - Constructor for class org.apache.poi.ss.formula.ptg.RefPtg
Takes in a String representation of a cell reference and fills out the numeric fields.
RefPtg(int, int, boolean, boolean) - Constructor for class org.apache.poi.ss.formula.ptg.RefPtg

RefPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.RefPtg

RefPtg(CellReference) - Constructor for class org.apache.poi.ss.formula.ptg.RefPtg

RefPtgBase - Class in org.apache.poi.ss.formula.ptg
ReferencePtgBase - handles references (such as A1, A2, IA4)
RefPtgBase() - Constructor for class org.apache.poi.ss.formula.ptg.RefPtgBase

RefPtgBase(CellReference) - Constructor for class org.apache.poi.ss.formula.ptg.RefPtgBase

RefreshAllRecord - Class in org.apache.poi.hssf.record
Title: Refresh All Record (0x01B7)
Description: Flag whether to refresh all external data when loading a sheet.
RefreshAllRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.RefreshAllRecord

RefreshAllRecord(boolean) - Constructor for class org.apache.poi.hssf.record.RefreshAllRecord

Region - Class in org.apache.poi.hssf.util
Deprecated. (Aug-2008) use CellRangeAddress
Region() - Constructor for class org.apache.poi.hssf.util.Region
Deprecated. Creates a new instance of Region (0,0 - 0,0)
Region(int, short, int, short) - Constructor for class org.apache.poi.hssf.util.Region
Deprecated.
Region(String) - Constructor for class org.apache.poi.hssf.util.Region
Deprecated.
Region - Class in org.apache.poi.ss.util
Deprecated. (Aug-2008) use CellRangeAddress
Region() - Constructor for class org.apache.poi.ss.util.Region
Deprecated. Creates a new instance of Region (0,0 - 0,0)
Region(int, short, int, short) - Constructor for class org.apache.poi.ss.util.Region
Deprecated.
Region(String) - Constructor for class org.apache.poi.ss.util.Region
Deprecated.
RegionUtil - Class in org.apache.poi.ss.util
Various utility functions that make working with a region of cells easier.
REGISTERED_MAIL_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

registerFunction(String, FreeRefFunction) - Static method in class org.apache.poi.ss.formula.atp.AnalysisToolPak
Register a ATP function in runtime.
registerFunction(String, Function) - Static method in class org.apache.poi.ss.formula.eval.FunctionEval
Register a new function in runtime.
registerFunction(String, FreeRefFunction) - Static method in class org.apache.poi.ss.formula.WorkbookEvaluator
Register a ATP function in runtime.
registerFunction(String, Function) - Static method in class org.apache.poi.ss.formula.WorkbookEvaluator
Register a function in runtime.
registerList(HWPFList) - Method in class org.apache.poi.hwpf.HWPFDocument

registerListener(POIFSReaderListener) - Method in class org.apache.poi.poifs.eventfilesystem.POIFSReader
Register a POIFSReaderListener for all documents
registerListener(POIFSReaderListener, String) - Method in class org.apache.poi.poifs.eventfilesystem.POIFSReader
Register a POIFSReaderListener for a document in the root directory
registerListener(POIFSReaderListener, POIFSDocumentPath, String) - Method in class org.apache.poi.poifs.eventfilesystem.POIFSReader
Register a POIFSReaderListener for a document in the specified directory
registerTo(StylesTable) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
Perform a registration of ourselves to the style table
RELATED_IPMS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RelationalOperationEval - Class in org.apache.poi.ss.formula.eval
Base class for all comparison operator evaluators
RelationalOperationEval() - Constructor for class org.apache.poi.ss.formula.eval.RelationalOperationEval

RELATIONS - Static variable in class org.apache.poi.xslf.usermodel.XSLFPictureData
Relationships for each known picture type
RELATIONS - Static variable in class org.apache.poi.xssf.usermodel.XSSFPictureData
Relationships for each known picture type
RELATIONS - Static variable in class org.apache.poi.xwpf.usermodel.XWPFPictureData
Relationships for each known picture type
RELATIONSHIP_PART_EXTENSION_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Extension name of a relationship part.
RELATIONSHIP_PART_SEGMENT_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Segment name of a relationship part.
RELATIONSHIP_TAG_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackageRelationship

relationships - Variable in class org.apache.poi.openxml4j.opc.OPCPackage
Package relationships.
RELATIONSHIPS - Static variable in interface org.apache.poi.openxml4j.opc.PackageNamespaces
Relationships.
RELATIONSHIPS_PART - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
Relationships part.
RELATIONSHIPS_TAG_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackageRelationship

RelationshipSource - Interface in org.apache.poi.openxml4j.opc

relativizeURI(URI, URI, boolean) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Fully relativize the source part URI against the target part URI.
relativizeURI(URI, URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Fully relativize the source part URI against the target part URI.
release(long) - Method in class org.apache.poi.util.IdentifierManager

RELIEF_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

remaining() - Method in class org.apache.poi.hssf.record.RecordInputStream
The remaining number of bytes in the current record.
REMOTE_PROGRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REMOTE_PROGRESS_TEXT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REMOTE_VALIDATE_OK - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

remove(String) - Method in class org.apache.poi.hpsf.CustomProperties
Removes a custom property.
remove(Object) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

remove(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

remove(int) - Method in class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

remove(int) - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable

remove(int) - Method in class org.apache.poi.hwpf.model.BookmarksTables

remove(int) - Method in interface org.apache.poi.hwpf.usermodel.Bookmarks
Remove bookmark from document (but not the bookmark text)
remove(int) - Method in class org.apache.poi.hwpf.usermodel.BookmarksImpl

remove(Object) - Method in class org.apache.poi.openxml4j.opc.PackagePartCollection

remove() - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator

remove(int) - Method in interface org.apache.poi.poifs.storage.BlockList
remove and return the specified block from the list
remove(int) - Method in class org.apache.poi.ss.util.CellRangeAddressList

remove(Object) - Method in class org.apache.poi.util.BinaryTree
Removes the mapping for this key from this map if present
remove(int) - Method in class org.apache.poi.util.IntList
Removes the element at the specified position in this list.
remove(int) - Method in class org.apache.poi.util.ShortList
Removes the element at the specified position in this list.
remove() - Method in class org.apache.poi.util.StringUtil.StringsIterator

remove() - Method in class org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator
We're read only, so remove isn't supported
remove() - Method in class org.apache.poi.xssf.streaming.SXSSFRow.CellIterator

remove() - Method in class org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator

removeAbstractNum(BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
remove an existing abstractNum
removeAll(IntList) - Method in class org.apache.poi.util.IntList
Removes from this list all the elements that are contained in the specified collection
removeAll(ShortList) - Method in class org.apache.poi.util.ShortList
Removes from this list all the elements that are contained in the specified collection
removeAllCells() - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Removes all the cells from the row, and their records too.
removeAllCellsValuesForRow(int) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

removeApplicationName() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the application name.
removeArrayFormula(int, int) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate
Removes an array formula
removeArrayFormula(int, int) - Method in class org.apache.poi.hssf.record.aggregates.SharedValueManager
Removes the ArrayRecord for the cell group containing the specified cell.
removeArrayFormula(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

removeArrayFormula(Cell) - Method in interface org.apache.poi.ss.usermodel.Sheet
Remove a Array Formula from this sheet.
removeArrayFormula(Cell) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Remove a Array Formula from this sheet.
removeArrayFormula(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

removeAuthor() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the author.
removeBodyElement(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
remove a BodyElement from bodyElements array list
removeBreak(int) - Method in class org.apache.poi.hssf.record.PageBreakRecord
Removes the break indicated by the parameter
removeBreak() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun

removeBuiltinRecord(byte, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Removes the specified Builtin NameRecord that matches the name and index
removeByteCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the byte count.
removeCarriageReturn() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun

removeCategory() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the category.
removeCell(CellValueRecordInterface) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

removeCell(CellValueRecordInterface) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

removeCell(Cell) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
remove the HSSFCell from this row.
removeCell(Cell) - Method in interface org.apache.poi.ss.usermodel.Row
Remove the Cell from this row.
removeCell(Cell) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Remove the Cell from this row.
removeCell(Cell) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Remove the Cell from this row.
removeCell(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow

removeCellComment() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Removes the comment for this cell, if there is one.
removeCellComment() - Method in interface org.apache.poi.ss.usermodel.Cell
Removes the comment for this cell, if there is one.
removeCellComment() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Removes the comment for this cell, if there is one.
removeCellComment() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Removes the comment for this cell, if there is one.
removeCharCount() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the character count.
removeChild(Record) - Method in class org.apache.poi.hslf.record.RecordContainer
Remove a child record from this record container
removeChildRecord(EscherRecord) - Method in class org.apache.poi.ddf.EscherContainerRecord

removeColumnBreak(int) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Removes a page break at the indicated column
removeColumnBreak(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Removes a page break at the indicated column
removeColumnBreak(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Removes a page break at the indicated column
removeColumnBreak(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Removes a page break at the indicated column
removeColumnBreak(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Removes a page break at the indicated column
removeComment(String) - Method in class org.apache.poi.xssf.model.CommentsTable

removeComments() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the comments.
removeCommentShape(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFVMLDrawing

removeCompany() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the company.
removeConditionalFormatting(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
removes a Conditional Formatting object by index
removeConditionalFormatting(int) - Method in interface org.apache.poi.ss.usermodel.SheetConditionalFormatting
Removes a Conditional Formatting object by index
removeConditionalFormatting(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting
removes a Conditional Formatting object by index
removeContentType(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Delete a content type based on the specified part name.
removeCreateDateTime() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the creation time.
removeCustomProperties() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the custom properties.
removeDocparts() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the doc parts.
removeEditTime() - Method in class org.apache.poi.hpsf.SummaryInformation
Remove the total time spent in editing the document.
removeEnforcement() - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings
Removes protection enforcement.
In the documentProtection tag inside settings.xml file
it sets the value of enforcement to "0" (w:enforcement="0")

removeExFormatRecord(ExtendedFormatRecord) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Removes the given ExtendedFormatRecord record from the file's list.
removeFontRecord(FontRecord) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Removes the given font record from the file's list.
removeFormatRun(UnicodeString.FormatRun) - Method in class org.apache.poi.hssf.record.common.UnicodeString

removeHeadingPair() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the heading pair.
removeHiddenCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the hidden count.
removeItem(int, String) - Method in class org.apache.poi.xssf.model.CalculationChain
Remove a formula reference from the calculation chain
removeKeywords() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the keywords.
removeLastAuthor() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the last author.
removeLastPrinted() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the lastPrinted.
removeLastSaveDateTime() - Method in class org.apache.poi.hpsf.SummaryInformation
Remove the total time spent in editing the document.
removeLeadingEquals(String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

removeLineCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the line count.
removeLinksDirty() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the links dirty.
removeManager() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the manager.
removeMarshaller(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Remove a marshaller by its content type.
removeMergedRegion(int) - Method in class org.apache.poi.hssf.model.InternalSheet

removeMergedRegion(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
removes a merged region of cells (hence letting them free)
removeMergedRegion(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Removes a merged region of cells (hence letting them free)
removeMergedRegion(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Removes a merged region of cells (hence letting them free)
removeMergedRegion(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Removes a merged region of cells (hence letting them free)
removeMMClipCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the mmclip count.
removeName(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
removes the name
removeName(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

removeName(String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

removeName(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Remove the defined name at the specified index
removeName(String) - Method in interface org.apache.poi.ss.usermodel.Workbook
Remove a defined name by name
removeName(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Remove the defined name at the specified index
removeName(String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Remove a defined name by name
removeName(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

removeName(String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

removeNoteCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the noteCount.
removePageCount() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the page count.
removeParagraph(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
removes a paragraph of this tablecell
removeParCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the par count.
removePart(PackagePart) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Remove the specified part in this package.
removePart(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Remove a part in this package.
removePartImpl(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Core method to delete a package part.
removePartImpl(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Delete a part from the package
removePartRecursive(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Remove a part from this package as well as its relationship part, if one exists, and all parts listed in the relationship part.
removePresentationFormat() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the presentation format.
removePrintArea(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Delete the printarea for the sheet specified
removePrintArea(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Delete the printarea for the sheet specified
removePrintArea(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Delete the printarea for the sheet specified
removePrintArea(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Delete the printarea for the sheet specified
removeProperty(long) - Method in class org.apache.poi.hpsf.MutableSection
Removes a property.
removeProperty(Property) - Method in class org.apache.poi.poifs.property.PropertyTableBase
Remove a property from the list of properties we manage
removeProtectionEnforcement() - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Remove protection enforcement.
In the documentProtection tag inside settings.xml file
it sets the value of enforcement to "0" (w:enforcement="0")

removeRelation(POIXMLDocumentPart) - Method in class org.apache.poi.POIXMLDocumentPart
Remove the relation to the specified part in this package and remove the part, if it is no longer needed.
removeRelation(POIXMLDocumentPart, boolean) - Method in class org.apache.poi.POIXMLDocumentPart
Remove the relation to the specified part in this package and remove the part, if it is no longer needed and flag is set to true.
removeRelationship(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Delete a relationship from this package.
removeRelationship(String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Delete the relationship specified by its id.
removeRelationship(String) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Remove a relationship by its ID.
removeRelationship(PackageRelationship) - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Remove a relationship by its reference.
removeRelationship(String) - Method in interface org.apache.poi.openxml4j.opc.RelationshipSource
Delete the relationship specified by its id.
removeRevNumber() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the revision number.
removeRow(RowRecord) - Method in class org.apache.poi.hssf.model.InternalSheet
Removes a row record This method is not loc sensitive, it resets loc to = dimsloc so no worries.
removeRow(RowRecord) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

removeRow(Row) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Remove a row from this sheet.
removeRow(Row) - Method in interface org.apache.poi.ss.usermodel.Sheet
Remove a row from this sheet.
removeRow(Row) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Remove a row from this sheet.
removeRow(Row) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Remove a row from this sheet.
removeRow(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
Remove a row at position pos from the table
removeRowBreak(int) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Removes a page break at the indicated row
removeRowBreak(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Removes the page break at the indicated row
removeRowBreak(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Removes the page break at the indicated row
removeRowBreak(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Removes the page break at the indicated row
removeRowBreak(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Removes the page break at the indicated row
removeRun(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
removes a Run at the position pos in the paragraph
removeScale() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the scale.
removeSecurity() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the security code.
removeSeries(HSSFChart.HSSFSeries) - Method in class org.apache.poi.hssf.usermodel.HSSFChart

removeShape(Shape) - Method in class org.apache.poi.hslf.model.Sheet
Removes the specified shape from this sheet.
removeShape(Shape) - Method in interface org.apache.poi.sl.usermodel.ShapeContainer

removeShape(XSLFShape) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape
Remove the specified shape from this group
removeShape(XSLFShape) - Method in interface org.apache.poi.xslf.usermodel.XSLFShapeContainer
Removes the specified shape from this sheet, if it is present (optional operation).
removeShape(XSLFShape) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet
Removes the specified shape from this sheet, if it is present (optional operation).
removeSheet(int) - Method in class org.apache.poi.hssf.model.InternalWorkbook

removeSheetAt(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Removes sheet at the given index.
Care must be taken if the removed sheet is the currently active or only selected sheet in the workbook.
removeSheetAt(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Removes sheet at the given index
removeSheetAt(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Removes sheet at the given index
removeSheetAt(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Removes sheet at the given index.
Care must be taken if the removed sheet is the currently active or only selected sheet in the workbook.
removeSlide(int) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Removes the slide at the given index (0-based).
removeSlide(int) - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow

removeSlideCount() - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Removes the slide count.
removeSlideListWithText(SlideListWithText) - Method in class org.apache.poi.hslf.record.Document

removeSubject() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the subject.
removeTemplate() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the template.
removeThumbnail() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the thumbnail.
removeTitle() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the title.
removeUnmarshaller(String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Remove an unmarshaller by its content type.
removeValue(Object) - Method in class org.apache.poi.util.BinaryTree
Removes the mapping for this value from this map if present
removeValue(int) - Method in class org.apache.poi.util.IntList
Removes the first occurrence in this list of the specified element (optional operation).
removeValue(short) - Method in class org.apache.poi.util.ShortList
Removes the first occurrence in this list of the specified element (optional operation).
removeValueRecord(int, CellValueRecordInterface) - Method in class org.apache.poi.hssf.model.InternalSheet
remove a value record from the records array.
removeWordCount() - Method in class org.apache.poi.hpsf.SummaryInformation
Removes the word count.
renameTo(String) - Method in interface org.apache.poi.poifs.filesystem.Entry
Rename this Entry.
renameTo(String) - Method in class org.apache.poi.poifs.filesystem.EntryNode
Rename this Entry.
renameTo(String) - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

RENDERING_POSITION - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

reorderSlide(int, int) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Re-orders a slide, to a new position.
Replace - Class in org.apache.poi.ss.formula.functions
An implementation of the Excel REPLACE() function:
Replaces part of a text string based on the number of characters you specify, with another text string.
Syntax:
REPLACE(oldText, startNum, numChars, newText)
oldText The text string containing characters to replace
startNum The position of the first character to replace (1-based)
numChars The number of characters to replace
newText The new text value to replace the removed section

Replace() - Constructor for class org.apache.poi.ss.formula.functions.Replace

replaceCellStyleXfAt(int, CTXf) - Method in class org.apache.poi.xssf.model.StylesTable

replaceCellXfAt(int, CTXf) - Method in class org.apache.poi.xssf.model.StylesTable

replaceContentType(String, String) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Replace a content type in this package.
replaceText(String, boolean) - Method in class org.apache.poi.hwpf.usermodel.Range
Replace range text with new one, adding it to the range and deleting original text from document
replaceText(String, String, int) - Method in class org.apache.poi.hwpf.usermodel.Range
Replace (one instance of) a piece of text with another...
replaceText(String, String) - Method in class org.apache.poi.hwpf.usermodel.Range
Replace (all instances of) a piece of text with another...
replaceValueRecord(CellValueRecordInterface) - Method in class org.apache.poi.hssf.model.InternalSheet
replace a value record from the records array.
REPLY_RECIPIENT_ENTRIES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPLY_RECIPIENT_NAMES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPLY_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPLY_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORT_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORT_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORT_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORT_TAG - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORT_TEXT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORT_TIME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORTING_DL_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REPORTING_MTA_CERTIFICATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

REQUESTED_DELIVERY_METHOD - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

reserve(long) - Method in class org.apache.poi.util.IdentifierManager

reserved - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

reserveNew() - Method in class org.apache.poi.util.IdentifierManager

reset(int) - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom
Reset the content to one info run with the default values
reset() - Method in class org.apache.poi.hwpf.model.io.HWPFOutputStream

reset() - Method in class org.apache.poi.hwpf.usermodel.Range
resets the list indexes.
reset() - Method in class org.apache.poi.hwpf.usermodel.Table

reset() - Method in class org.apache.poi.hwpf.usermodel.TableRow

reset() - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream
Repositions this stream to the position at the time the mark() method was last called on this input stream.
reset() - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream
Repositions this stream to the position at the time the mark() method was last called on this input stream.
reset() - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream
Repositions this stream to the position at the time the mark() method was last called on this input stream.
reset() - Method in class org.apache.poi.util.BlockingInputStream

RESET_NUMBERING_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

resetFontCache() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Reset the fonts cache, causing all new calls to getFontAt() to create new objects.
resetFontStyle() - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
set font style options to default values (non-italic, non-bold)
resetFontStyle() - Method in interface org.apache.poi.ss.usermodel.FontFormatting
set font style options to default values (non-italic, non-bold)
resetFontStyle() - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
set font style options to default values (non-italic, non-bold)
resize(double) - Method in class org.apache.poi.hssf.usermodel.HSSFPicture
Resize the image
resize() - Method in class org.apache.poi.hssf.usermodel.HSSFPicture
Reset the image to the original size.
resize() - Method in interface org.apache.poi.ss.usermodel.Picture
Reset the image to the original size.
resize(double) - Method in interface org.apache.poi.ss.usermodel.Picture
Reset the image to the original size.
resize() - Method in class org.apache.poi.xslf.usermodel.XSLFPictureShape
Resize this picture to the default size.
resize() - Method in class org.apache.poi.xssf.usermodel.XSSFPicture
Reset the image to the original size.
resize(double) - Method in class org.apache.poi.xssf.usermodel.XSSFPicture
Reset the image to the original size.
resizeToFitText() - Method in class org.apache.poi.hslf.model.TextShape
Adjust the size of the TextShape so it encompasses the text inside it.
resizeToFitText() - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Adjust the size of the shape so it encompasses the text inside it.
resolveNameXText(int, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook

resolveNameXText(NameXPtg) - Method in class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

resolveNameXText(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.
resolveNameXText(NameXPtg) - Method in interface org.apache.poi.ss.formula.EvaluationWorkbook

resolveNameXText(NameXPtg) - Method in interface org.apache.poi.ss.formula.FormulaRenderingWorkbook

resolveNameXText(NameXPtg) - Method in class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

resolvePartUri(URI, URI) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Resolve a source uri against a target.
RESOURCE_FLAGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RESOURCE_METHODS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RESOURCE_PATH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RESOURCE_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Resources - Interface in org.apache.poi.sl.usermodel
Common SlideShow resources, such as fonts, pictures and multimedia data
RESPONSE_REQUESTED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RESPONSIBILITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

retainAll(IntList) - Method in class org.apache.poi.util.IntList
Retains only the elements in this list that are contained in the specified collection.
retainAll(ShortList) - Method in class org.apache.poi.util.ShortList
Retains only the elements in this list that are contained in the specified collection.
RETURN_BLANK_AS_NULL - Static variable in interface org.apache.poi.ss.usermodel.Row
Missing cells are returned as null, as are blank cells
RETURN_NULL_AND_BLANK - Static variable in interface org.apache.poi.ss.usermodel.Row
Missing cells are returned as null, Blank cells are returned as normal
RETURNED_IPM - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Reverse - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
whether the animation plays in the reverse direction
reverseHex(String) - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

revert() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Close the package WITHOUT saving its content.
revertImpl() - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Close the package without saving the document.
revertImpl() - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Close the package without saving the document.
revision - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The revision number.
RevisionMarkAuthorTable - Class in org.apache.poi.hwpf.model
String table containing the names of authors of revision marks, e-mails and comments in this document.
RevisionMarkAuthorTable(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.RevisionMarkAuthorTable
Constructor to read the table from the table stream.
RGBUSE - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

Ribbon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

RIBBON - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

Ribbon2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

RIBBON_2 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

RichTextRun - Class in org.apache.poi.hslf.usermodel
Represents a run of text, all with the same style
RichTextRun(TextRun, int, int) - Constructor for class org.apache.poi.hslf.usermodel.RichTextRun
Create a new wrapper around a (currently not) rich text string
RichTextRun(TextRun, int, int, TextPropCollection, TextPropCollection, boolean, boolean) - Constructor for class org.apache.poi.hslf.usermodel.RichTextRun
Create a new wrapper around a rich text string
RichTextString - Interface in org.apache.poi.ss.usermodel
Rich text unicode string.
right - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

RIGHT - Static variable in class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

RIGHT - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

RIGHT - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

RIGHT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

RIGHT_ARROW_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

RIGHT_BORDER_COLOR - Static variable in class org.apache.poi.ss.util.CellUtil

RIGHT_BRACE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

RIGHT_BRACKET - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

RightArrowCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

RightBrace - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

RightBracket - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

RightMargin - Static variable in class org.apache.poi.hssf.model.InternalSheet

RightMargin - Static variable in interface org.apache.poi.ss.usermodel.Sheet

RightMarginRecord - Class in org.apache.poi.hssf.record
Record for the right margin.

RightMarginRecord() - Constructor for class org.apache.poi.hssf.record.RightMarginRecord

RightMarginRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.RightMarginRecord

RightTriangle - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

RK_IEEE_NUMBER - Static variable in class org.apache.poi.hssf.record.RKRecord

RK_IEEE_NUMBER_TIMES_100 - Static variable in class org.apache.poi.hssf.record.RKRecord

RK_INTEGER - Static variable in class org.apache.poi.hssf.record.RKRecord

RK_INTEGER_TIMES_100 - Static variable in class org.apache.poi.hssf.record.RKRecord

RKRecord - Class in org.apache.poi.hssf.record
Title: RK Record (0x027E)
Description: An internal 32 bit number with the two most significant bits storing the type.
RKRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.RKRecord

RKUtil - Class in org.apache.poi.hssf.util
Utility class for helping convert RK numbers.
root - Variable in class org.apache.poi.hwpf.converter.FoDocumentFacade

root - Variable in class org.apache.poi.hwpf.converter.TextDocumentFacade

ROOT_TYPE - Static variable in interface org.apache.poi.poifs.property.PropertyConstants

RootProperty - Class in org.apache.poi.poifs.property
Root property
RootProperty(int, byte[], int) - Constructor for class org.apache.poi.poifs.property.RootProperty
reader constructor
rotate(double) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Concatenates the current Graphics2D Transform with a rotation transform.
rotate(double, double, double) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Concatenates the current Graphics2D Transform with a translated rotation transform.
rotate(double) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

rotate(double, double, double) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

rotate(double) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

rotate(double, double, double) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

ROTATION - Static variable in class org.apache.poi.ss.util.CellUtil

ROTATION_NONE - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

ROTATION_ROTATED_90_DEGREES - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

ROTATION_ROTATED_90_DEGREES_CLOCKWISE - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

ROTATION_TOP_TO_BOTTOM - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

ROUND - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

ROUND_1_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ROUND_2_DIAG_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ROUND_2_SAME_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ROUND_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

ROUNDDOWN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

RoundRectangle - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

RoundTripContentMasterId - Static variable in class org.apache.poi.hslf.record.RecordTypes

RoundTripContentMasterInfo12 - Static variable in class org.apache.poi.hslf.record.RecordTypes

RoundTripCustomTableStyles12 - Static variable in class org.apache.poi.hslf.record.RecordTypes

RoundTripHFPlaceholder12 - Static variable in class org.apache.poi.hslf.record.RecordTypes

RoundTripHFPlaceholder12 - Class in org.apache.poi.hslf.record
An atom record that specifies that a shape is a header or footer placeholder shape
RoundTripHFPlaceholder12(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.RoundTripHFPlaceholder12
Constructs the comment atom record from its source data.
RoundTripNotesMasterTextStyles12 - Static variable in class org.apache.poi.hslf.record.RecordTypes

RoundTripOArtTextStyles12 - Static variable in class org.apache.poi.hslf.record.RecordTypes

RoundTripShapeCheckSumForCustomLayouts12 - Static variable in class org.apache.poi.hslf.record.RecordTypes

RoundTripShapeId12 - Static variable in class org.apache.poi.hslf.record.RecordTypes

ROUNDUP - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

ROUTESLIP - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

Row - Interface in org.apache.poi.ss.usermodel
High level representation of a row of a spreadsheet.
Row.MissingCellPolicy - Class in org.apache.poi.ss.usermodel
Used to specify the different possible policies if for the case of null and blank cells
ROW_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RowBlocksReader - Class in org.apache.poi.hssf.model
Segregates the 'Row Blocks' section of a single sheet into plain row/cell records and shared formula records.
RowBlocksReader(RecordStream) - Constructor for class org.apache.poi.hssf.model.RowBlocksReader
Also collects any loose MergeCellRecords and puts them in the supplied mergedCellsTable
RowFunc - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function ROW
RowFunc() - Constructor for class org.apache.poi.ss.formula.functions.RowFunc

rowHasCells(int) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate
Returns true if the row has cells attached to it
ROWID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

rowIterator() - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

rowIterator() - Method in interface org.apache.poi.ss.usermodel.Sheet
Returns an iterator of the physical rows
rowIterator() - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Returns an iterator of the physical rows
rowIterator() - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

RowRecord - Class in org.apache.poi.hssf.record
Title: Row Record (0x0208)
Description: stores the row information for the sheet.
RowRecord(int) - Constructor for class org.apache.poi.hssf.record.RowRecord

RowRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.RowRecord

RowRecordsAggregate - Class in org.apache.poi.hssf.record.aggregates

RowRecordsAggregate() - Constructor for class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
Creates a new instance of ValueRecordsAggregate
RowRecordsAggregate(RecordStream, SharedValueManager) - Constructor for class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

Rows - Class in org.apache.poi.ss.formula.functions
Implementation for Excel ROWS function.
Rows() - Constructor for class org.apache.poi.ss.formula.functions.Rows

RT_TRIANGLE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

RTF_COMPRESSED - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RTF_IN_SYNC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RTF_SYNC_BODY_COUNT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RTF_SYNC_BODY_CRC - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RTF_SYNC_BODY_TAG - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RTF_SYNC_PREFIX_COUNT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

RTF_SYNC_TRAILING_COUNT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

rtfBodyChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
BODY Rtf Chunk, for Rtf (Rich) messages
RTFDateTimeMCAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

run() - Method in class org.apache.poi.hssf.dev.EFBiffViewer

run() - Method in class org.apache.poi.hssf.dev.FormulaViewer
Method run
run() - Method in class org.apache.poi.hssf.dev.RecordLister

runs - Variable in class org.apache.poi.xwpf.usermodel.XWPFParagraph

S

S_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

sameProperties(FontRecord) - Method in class org.apache.poi.hssf.record.FontRecord
Does this FontRecord have all the same font properties as the supplied FontRecord? Note that Object.equals(Object) will check for exact objects, while this will check for exact contents, because normally the font record's position makes a big difference too.
sanityCheck() - Method in class org.apache.poi.hwpf.usermodel.Range
Method for debug purposes.
sanityCheckBlockCount(int) - Static method in class org.apache.poi.poifs.storage.BlockAllocationTableReader

save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Save the contents type part.
save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

save(File) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Save the document in the specified file.
save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Save the document in the specified output stream.
save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.
save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

save(OutputStream) - Method in class org.apache.poi.openxml4j.opc.ZipPackagePart

SavedByEntry - Class in org.apache.poi.hwpf.model
A single entry in the SavedByTable.
SavedByEntry(String, String) - Constructor for class org.apache.poi.hwpf.model.SavedByEntry

SavedByTable - Class in org.apache.poi.hwpf.model
String table containing the history of the last few revisions ("saves") of the document.
SavedByTable(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.SavedByTable
Constructor to read the table from the table stream.
saveImpl(Document, OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Specific implementation of the save method.
saveImpl(Document, OutputStream) - Method in class org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager

saveImpl(OutputStream) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Save the package into the specified output stream.
saveImpl(OutputStream) - Method in class org.apache.poi.openxml4j.opc.ZipPackage
Save this package into the specified stream
savePicture(byte[], PictureType, String, float, float) - Method in interface org.apache.poi.hwpf.converter.PicturesManager
Stores image (probably on disk).
SaveRecalcRecord - Class in org.apache.poi.hssf.record
Title: Save Recalc Record
SaveRecalcRecord() - Constructor for class org.apache.poi.hssf.record.SaveRecalcRecord

SaveRecalcRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.SaveRecalcRecord

saveXmlInStream(Document, OutputStream) - Static method in class org.apache.poi.openxml4j.opc.StreamHelper
Turning the DOM4j object in the specified output stream.
ScalarConstantPtg - Class in org.apache.poi.ss.formula.ptg
Common superclass of all Ptgs that represent simple constant values.
ScalarConstantPtg() - Constructor for class org.apache.poi.ss.formula.ptg.ScalarConstantPtg

scale(double, double) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Concatenates the current Graphics2D Transform with a scaling transformation Subsequent rendering is resized according to the specified scaling factors relative to the previous scaling.
scale(double, double) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

scale(double, double) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

ScatterChartData - Interface in org.apache.poi.ss.usermodel.charts

ScatterChartSerie - Interface in org.apache.poi.ss.usermodel.charts
Represents scatter charts serie.
ScenarioProtectRecord - Class in org.apache.poi.hssf.record
Title: Scenario Protect Record
ScenarioProtectRecord() - Constructor for class org.apache.poi.hssf.record.ScenarioProtectRecord

ScenarioProtectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.ScenarioProtectRecord

SCL_00A0 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

SCLRecord - Class in org.apache.poi.hssf.record
Specifies the window's zoom magnification.
SCLRecord() - Constructor for class org.apache.poi.hssf.record.SCLRecord

SCLRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.SCLRecord

Seal - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

SEARCH - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SEARCH - Static variable in class org.apache.poi.ss.formula.functions.TextFunction
Implementation of the FIND() function.
Syntax:
SEARCH(find_text, within_text, start_num)
SEARCH is a case-insensitive version of FIND()
SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

searchText(String, PositionInParagraph) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
this methods parse the paragraph and search for the string searched.
SECOND - Static variable in class org.apache.poi.ss.formula.functions.CalendarFieldFunction

secondSubrange(Range) - Method in interface org.apache.poi.hwpf.usermodel.Field

Section - Class in org.apache.poi.hpsf
Represents a section in a PropertySet.
Section() - Constructor for class org.apache.poi.hpsf.Section
Creates an empty and uninitialized Section.
Section(byte[], int) - Constructor for class org.apache.poi.hpsf.Section
Creates a Section instance from a byte array.
Section - Class in org.apache.poi.hwpf.usermodel

Section(SEPX, Range) - Constructor for class org.apache.poi.hwpf.usermodel.Section

SectionDescriptor - Class in org.apache.poi.hwpf.model
Section Descriptor (SED) See page 186 for details.
SectionDescriptor() - Constructor for class org.apache.poi.hwpf.model.SectionDescriptor

SectionDescriptor(byte[], int) - Constructor for class org.apache.poi.hwpf.model.SectionDescriptor

SectionIDMap - Class in org.apache.poi.hpsf.wellknown
Maps section format IDs to PropertyIDMaps.
SectionIDMap() - Constructor for class org.apache.poi.hpsf.wellknown.SectionIDMap

SectionProperties - Class in org.apache.poi.hwpf.usermodel

SectionProperties() - Constructor for class org.apache.poi.hwpf.usermodel.SectionProperties

sections - Variable in class org.apache.poi.hpsf.PropertySet
The sections in this PropertySet.
SectionSprmCompressor - Class in org.apache.poi.hwpf.sprm

SectionSprmCompressor() - Constructor for class org.apache.poi.hwpf.sprm.SectionSprmCompressor

SectionSprmUncompressor - Class in org.apache.poi.hwpf.sprm

SectionSprmUncompressor() - Constructor for class org.apache.poi.hwpf.sprm.SectionSprmUncompressor

SectionTable - Class in org.apache.poi.hwpf.model

SectionTable() - Constructor for class org.apache.poi.hwpf.model.SectionTable

SectionTable(byte[], byte[], int, int, int, TextPieceTable, int) - Constructor for class org.apache.poi.hwpf.model.SectionTable

SECURITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SEGMENTINFO_CLOSE - Static variable in class org.apache.poi.hslf.model.Freeform

SEGMENTINFO_CUBICTO - Static variable in class org.apache.poi.hslf.model.Freeform

SEGMENTINFO_CUBICTO2 - Static variable in class org.apache.poi.hslf.model.Freeform

SEGMENTINFO_END - Static variable in class org.apache.poi.hslf.model.Freeform

SEGMENTINFO_ESCAPE - Static variable in class org.apache.poi.hslf.model.Freeform

SEGMENTINFO_ESCAPE2 - Static variable in class org.apache.poi.hslf.model.Freeform

SEGMENTINFO_LINETO - Static variable in class org.apache.poi.hslf.model.Freeform

SEGMENTINFO_MOVETO - Static variable in class org.apache.poi.hslf.model.Freeform

SELECTABLE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SelectionRecord - Class in org.apache.poi.hssf.record
Title: Selection Record (0x001D)
SelectionRecord(int, int) - Constructor for class org.apache.poi.hssf.record.SelectionRecord
Creates a default selection record (cell A1, in pane ID 3)
SelectionRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.SelectionRecord

SEND_INTERNET_ENCODING - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SEND_RECALL_REPORT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SEND_RICH_INFO - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENDER_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENDER_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENDER_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENDER_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENDER_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENSITIVITY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENT_REPRESENTING_ADDRTYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENT_REPRESENTING_EMAIL_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENT_REPRESENTING_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENT_REPRESENTING_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SENT_REPRESENTING_SEARCH_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

sentByServerType - Variable in class org.apache.poi.hsmf.datatypes.Chunks
Type of server that the message originated from (SMTP, etc).
SENTMAIL_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SEPAbstractType - Class in org.apache.poi.hwpf.model.types
Section Properties.
SEPAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.SEPAbstractType

separatorData - Variable in class org.apache.poi.hdgf.chunks.ChunkSeparator

SEPX - Class in org.apache.poi.hwpf.model

SEPX(SectionDescriptor, int, int, byte[]) - Constructor for class org.apache.poi.hwpf.model.SEPX

serialiseEncoder(int, String, String, String) - Method in class org.apache.poi.hwpf.dev.FieldIterator

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.AbstractEscherOptRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherBitmapBlip

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherBlipRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherBSERecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherChildAnchorRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherClientDataRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherContainerRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherDggRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherDgRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherMetafileBlip

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherPictBlip

serialize() - Method in class org.apache.poi.ddf.EscherRecord
Serializes to a new byte array.
serialize(int, byte[]) - Method in class org.apache.poi.ddf.EscherRecord
Serializes to an existing byte array without serialization listener.
serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherRecord
Serializes the record to an existing byte array.
serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherSpgrRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherSpRecord
This method serializes this escher record into a byte array.
serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.EscherTextboxRecord

serialize(int, byte[], EscherSerializationListener) - Method in class org.apache.poi.ddf.UnknownEscherRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Serializes all records int the worksheet section into a big byte array.
serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.aggregates.RecordAggregate

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.AutoFilterInfoRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.BackupRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.BlankRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.BOFRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.BookBoolRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.BottomMarginRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.BoundSheetRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CalcCountRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CalcModeRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CellRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.cf.PatternFormatting

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CFHeaderRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CFRuleRecord
called by the class that is responsible for writing this sucker.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.AreaRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.AxisRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.AxisUsedRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.BarRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.BeginRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.CatLabRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartEndObjectRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartStartObjectRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.DatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.EndRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.FontIndexRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.FrameRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.LegendRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.PlotAreaRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SeriesIndexRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SeriesListRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SeriesRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.TextRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.TickRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.UnitsRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CodepageRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.common.FeatProtection

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.common.FeatSmartTag

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.common.FtrHeader

serialize(LittleEndianOutput) - Method in interface org.apache.poi.hssf.record.common.SharedFeature

serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.common.UnicodeString
Serialises out the String.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecord
Serializes this record's content to the supplied data output.
The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method.
serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ContinueRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CountryRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CRNCountRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CRNRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DateWindow1904Record

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DBCellRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DConRefRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DefaultColWidthRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DeltaRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DimensionsRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.DrawingGroupRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DrawingRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DrawingSelectionRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DSFRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DVALRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.DVRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.EndSubRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.EOFRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.EscherAggregate
Serializes this aggregate to a byte array.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ExternalNameRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ExternSheetRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord

serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.ExtSSTRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FeatHdrRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FeatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FilePassRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FileSharingRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FnGroupCountRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FontRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FormatRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FtCblsSubRecord
Serialize the record data into the supplied array of bytes
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.GridsetRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.GroupMarkerSubRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.GutsRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.HCenterRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.HeaderFooterBase

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.HeaderFooterRecord
spit the record out AS IS.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.HideObjRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.HyperlinkRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.IndexRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.InterfaceEndRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.InterfaceHdrRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.IterationRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.LabelRecord
THROWS A RUNTIME EXCEPTION..
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.LbsDataSubRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.LeftMarginRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.MergeCellsRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.MMSRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.MulBlankRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.MulRKRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.NameCommentRecord

serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.NameRecord
NameRecord can span into
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.NoteRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.NoteStructureSubRecord
Serialize the record data into the supplied array of bytes
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ObjectProtectRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.ObjRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PageBreakRecord.Break

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PageBreakRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PaletteRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PaneRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PasswordRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PasswordRev4Record

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.pivottable.DataItemRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.pivottable.PageItemRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.pivottable.StreamIDRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.pivottable.ViewSourceRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PrecisionRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PrintGridlinesRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PrintHeadersRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ProtectionRev4Record

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ProtectRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.RecalcIdRecord

serialize() - Method in class org.apache.poi.hssf.record.Record
called by the class that is responsible for writing this sucker.
serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.RecordBase
called by the class that is responsible for writing this sucker.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.RefModeRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.RefreshAllRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.RightMarginRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.RowRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SaveRecalcRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ScenarioProtectRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SCLRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SelectionRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.SSTRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.record.StandardRecord
Write the data content of this BIFF record including the sid and record length.
The subclass must write the exact number of bytes as reported by RecordBase.getRecordSize()}
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.StandardRecord
Write the data content of this BIFF record.
serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.StringRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.StyleRecord

serialize() - Method in class org.apache.poi.hssf.record.SubRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SubRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SupBookRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.TabIdRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.TableStylesRecord

serialize(ContinuableRecordOutput) - Method in class org.apache.poi.hssf.record.TextObjectRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.TopMarginRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.UncalcedRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.UnknownRecord
spit the record out AS IS.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.UserSViewBegin
spit the record out AS IS.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.UserSViewEnd
spit the record out AS IS.
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.UseSelFSRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.VCenterRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.WindowOneRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.WindowProtectRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.WindowTwoRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.WriteAccessRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.WriteProtectRecord

serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.WSBoolRecord

serialize(int, byte[]) - Method in class org.apache.poi.hssf.util.CellRangeAddress8Bit
Deprecated. use CellRangeAddress8Bit.serialize(LittleEndianOutput)
serialize(LittleEndianOutput) - Method in class org.apache.poi.hssf.util.CellRangeAddress8Bit

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.Colorref

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.DocumentProperties

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FRDAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.HRESIAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType

serialize() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType

serialize(byte[], int) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

serialize(byte[], int) - Method in class org.apache.poi.hwpf.usermodel.DateAndTime

serialize(byte[], int) - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

serialize() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor

serialize() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

serialize(byte[], int) - Method in class org.apache.poi.hwpf.usermodel.TableCellDescriptor

serialize(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.Formula
Writes The formula encoding is includes: ushort tokenDataLen tokenData arrayConstantData (if present)
serialize(int, byte[]) - Method in class org.apache.poi.ss.util.CellRangeAddress
Deprecated. use CellRangeAddress.serialize(LittleEndianOutput)
serialize(LittleEndianOutput) - Method in class org.apache.poi.ss.util.CellRangeAddress

serialize(int, byte[]) - Method in class org.apache.poi.ss.util.CellRangeAddressList

serialize(LittleEndianOutput) - Method in class org.apache.poi.ss.util.CellRangeAddressList

serializeArrayConstantData(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.Formula

serializeComplexPart(byte[], int) - Method in class org.apache.poi.ddf.EscherComplexProperty
Serializes the complex part of this property
serializeComplexPart(byte[], int) - Method in class org.apache.poi.ddf.EscherProperty
Escher properties consist of a simple fixed length part and a complex variable length part.
serializeComplexPart(byte[], int) - Method in class org.apache.poi.ddf.EscherSimpleProperty
Escher properties consist of a simple fixed length part and a complex variable length part.
serializeExtraData(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.ArrayRecord

serializeExtraData(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SharedFormulaRecord

serializeExtraData(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.SharedValueRecordBase

serializeExtraData(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.TableRecord

serializePtgs(Ptg[], byte[], int) - Static method in class org.apache.poi.ss.formula.ptg.Ptg
Writes the ptgs to the data buffer, starting at the specified offset.
serializeSimplePart(byte[], int) - Method in class org.apache.poi.ddf.EscherArrayProperty
Serializes the simple part of this property.
serializeSimplePart(byte[], int) - Method in class org.apache.poi.ddf.EscherComplexProperty
Serializes the simple part of this property.
serializeSimplePart(byte[], int) - Method in class org.apache.poi.ddf.EscherProperty
Escher properties consist of a simple fixed length part and a complex variable length part.
serializeSimplePart(byte[], int) - Method in class org.apache.poi.ddf.EscherSimpleProperty
Serialize the simple part of the escher record.
serializeTokens(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.Formula

serializeValue(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.BoolErrRecord

serializeValue(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.CellRecord
writes out the value data for this cell record
serializeValue(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.FormulaRecord

serializeValue(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.LabelSSTRecord

serializeValue(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.NumberRecord

serializeValue(LittleEndianOutput) - Method in class org.apache.poi.hssf.record.RKRecord

SeriesChartGroupIndexRecord - Class in org.apache.poi.hssf.record.chart
The series chart group index record stores the index to the CHARTFORMAT record (0 based).

SeriesChartGroupIndexRecord() - Constructor for class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

SeriesChartGroupIndexRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

SeriesIndexRecord - Class in org.apache.poi.hssf.record.chart
links a series to its position in the series list.

SeriesIndexRecord() - Constructor for class org.apache.poi.hssf.record.chart.SeriesIndexRecord

SeriesIndexRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SeriesIndexRecord

SeriesLabelsRecord - Class in org.apache.poi.hssf.record.chart
The series label record defines the type of label associated with the data format record.

SeriesLabelsRecord() - Constructor for class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

SeriesLabelsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

SeriesListRecord - Class in org.apache.poi.hssf.record.chart
SERIESLIST (0x1016)
The series list record defines the series displayed as an overlay to the main chart record.
(As with all chart related records, documentation is lacking.
SeriesListRecord(short[]) - Constructor for class org.apache.poi.hssf.record.chart.SeriesListRecord

SeriesListRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SeriesListRecord

SeriesRecord - Class in org.apache.poi.hssf.record.chart
The series record describes the overall data for a series.

SeriesRecord() - Constructor for class org.apache.poi.hssf.record.chart.SeriesRecord

SeriesRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SeriesRecord

SeriesTextRecord - Class in org.apache.poi.hssf.record.chart
SERIESTEXT (0x100D)
SeriesTextRecord() - Constructor for class org.apache.poi.hssf.record.chart.SeriesTextRecord

SeriesTextRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SeriesTextRecord

SeriesToChartGroupRecord - Class in org.apache.poi.hssf.record.chart
Indicates the chart-group index for a series.
SeriesToChartGroupRecord() - Constructor for class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

SeriesToChartGroupRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

SERVICE_DELETE_FILES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SERVICE_DLL_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SERVICE_ENTRY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SERVICE_EXTRA_UIDS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SERVICE_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SERVICE_SUPPORT_FILES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SERVICE_UID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SERVICES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

set(int) - Method in class org.apache.poi.util.BitField
Set the bits.
set(byte) - Method in class org.apache.poi.util.ByteField
set the ByteField's current value
set(byte, byte[]) - Method in class org.apache.poi.util.ByteField
set the ByteField's current value and write it to a byte array
set(int) - Method in class org.apache.poi.util.IntegerField
set the IntegerField's current value
set(int, byte[]) - Method in class org.apache.poi.util.IntegerField
set the IntegerField's current value and write it to a byte array
set(int, int) - Method in class org.apache.poi.util.IntList
Replaces the element at the specified position in this list with the specified element
set(long) - Method in class org.apache.poi.util.LongField
set the LongField's current value
set(long, byte[]) - Method in class org.apache.poi.util.LongField
set the LongField's current value and write it to a byte array
set(short) - Method in class org.apache.poi.util.ShortField
set the ShortField's current value
set(short, byte[]) - Method in class org.apache.poi.util.ShortField
set the ShortField's current value and write it to a byte array
set(int, short) - Method in class org.apache.poi.util.ShortList
Replaces the element at the specified position in this list with the specified element
set123Prefix(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set some old holdover from lotus 123.
set7BitEncoding(String) - Method in class org.apache.poi.hsmf.datatypes.StringChunk
Sets the Encoding that will be used to decode any "7 bit" (non unicode) data.
set7BitEncoding(String) - Method in class org.apache.poi.hsmf.MAPIMessage
Many messages store their strings as unicode, which is nice and easy.
set_cbFfnM1(int) - Method in class org.apache.poi.hwpf.model.Ffn

setAccentAndFollowingHyperlinkColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Accent And Following Hyperlink Colour
setAccentAndHyperlinkColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Accent And Hyperlink Colour
setAccentColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Accent Colour
setAction(byte) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Hyperlink Action
setActive(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
is the sheet currently displayed in the window
setActive(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets whether sheet is selected.
setActiveCell(String) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets location of the active cell
setActiveCellCol(short) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets the active column
setActiveCellCol(short) - Method in class org.apache.poi.hssf.record.SelectionRecord
set the active cell's col
setActiveCellRef(short) - Method in class org.apache.poi.hssf.record.SelectionRecord
set the active cell's reference number
setActiveCellRow(int) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets the active row
setActiveCellRow(int) - Method in class org.apache.poi.hssf.record.SelectionRecord
set the active cell's row
setActivePane(short) - Method in class org.apache.poi.hssf.record.PaneRecord
Set the active pane field for the Pane record.
setActiveSheet(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Convenience method to set the active sheet.
setActiveSheet(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Convenience method to set the active sheet.
setActiveSheet(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Convenience method to set the active sheet.
setActiveSheet(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Convenience method to set the active sheet.
setActiveSheetIndex(int) - Method in class org.apache.poi.hssf.record.WindowOneRecord

setActiveXIndex(int) - Method in class org.apache.poi.hslf.model.ActiveXShape
Assign a control to this shape
setAddMenuCount(byte) - Method in class org.apache.poi.hssf.record.MMSRecord
set number of add menu options (set to 0)
setAddress(String) - Method in interface org.apache.poi.common.usermodel.Hyperlink
Hypelink address.
setAddress(String) - Method in class org.apache.poi.hslf.model.Hyperlink

setAddress(String) - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Hyperlink address.
setAddress(String) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Hypelink address.
setAddress(String) - Method in class org.apache.poi.xslf.usermodel.XSLFHyperlink

setAddress(XSLFSlide) - Method in class org.apache.poi.xslf.usermodel.XSLFHyperlink

setAddress(String) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Hyperlink address.
setAdjustmentValue(int, int) - Method in class org.apache.poi.hslf.model.AutoShape
Sets adjust value which controls smart resizing of the auto-shape.
setAdt(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the adt field for the DOP record.
setAdtlDiag(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set for diagonal borders? No idea (its a palette color for the other function we didn't know what was?)
setAdtlDiagLineStyle(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the diagonal border line style? Who the heck ever heard of a diagonal border?
setAdtlFillPattern(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the fill pattern
setAdtlPaletteOptions(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the additional palette options bitmask (see individual bitsetter methods that reference this method)
setAlignFormattingUnchanged() - Method in class org.apache.poi.hssf.record.CFRuleRecord

setAlignment(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the type of horizontal alignment for the text.
setAlignment(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the horizontal alignment of the cell.
setAlignment(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the type of horizontal alignment for the cell
setAlignment(HSSFCell, HSSFWorkbook, short) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
Take a cell, and align it.
setAlignment(int) - Method in class org.apache.poi.hwpf.model.ListLevel

setAlignment(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the type of horizontal alignment for the cell
setAlignment(Cell, Workbook, short) - Static method in class org.apache.poi.ss.util.CellUtil
Take a cell, and align it.
setAlignment(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of horizontal alignment for the cell
setAlignment(HorizontalAlignment) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of horizontal alignment for the cell
setAlignment(ParagraphAlignment) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the paragraph alignment which shall be applied to text in this paragraph.
setAlignmentOptions(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the alignment options bitmask.
setAllBorders(Line) - Method in class org.apache.poi.hslf.model.Table
Format the table and apply the specified Line to all cell boundaries, both outside and inside
setAllThreadsPreferEventExtractors(Boolean) - Static method in class org.apache.poi.extractor.ExtractorFactory
Should all threads prefer event based over usermodel based extractors? If set, will take preference over the Thread level setting.
setAlternateExpression(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
whether alternate expression evaluation is on
setAlternateFormula(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
whether alternative formula entry is on
setAlternativeExpression(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
whether alternate expression evaluation is on
setAlternativeFormula(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
whether alternative formula entry is on
setAlwaysCalc(boolean) - Method in class org.apache.poi.hssf.record.FormulaRecord

setAlwaysCalc(boolean) - Method in class org.apache.poi.hssf.record.TableRecord

setAnchor(Rectangle2D) - Method in class org.apache.poi.hslf.model.Shape
Sets the anchor (the bounding box rectangle) of this shape.
setAnchor(Rectangle) - Method in class org.apache.poi.hslf.model.ShapeGroup
Sets the anchor (the bounding box rectangle) of this shape.
setAnchor(Rectangle) - Method in class org.apache.poi.hslf.model.TableCell

setAnchor(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFChildAnchor

setAnchor(short, int, int, int, short, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor
Dets the top-left and bottom-right coordinates of the anchor.
setAnchor(HSSFAnchor) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
Sets a particular anchor.
setAnchor(Rectangle2D) - Method in interface org.apache.poi.sl.usermodel.Shape

setAnchor(Rectangle2D) - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

setAnchor(Rectangle2D) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

setAnchor(Rectangle2D) - Method in class org.apache.poi.xslf.usermodel.XSLFShadow

setAnchor(Rectangle2D) - Method in class org.apache.poi.xslf.usermodel.XSLFShape

setAnchor(Rectangle2D) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setAnchor(XSSFClientAnchor) - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Attaches frame to an anchor.
setAnchorId(short) - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord
Set the anchor id field for the ObjectLink record.
setAnchorType(int) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor
Sets the anchor type
setAnchorType(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Sets the anchor type
setAnchorType(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor
Sets the anchor type
setAnld(byte[]) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the anld field for the PAP record.
setApplicationName(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the application name.
setArabic(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
is this arabic?
setAreFieldsStripped(boolean) - Method in class org.apache.poi.hwpf.usermodel.HeaderStories
Should fields (eg macros) be stripped from the text that this class returns? Default is not to strip.
setAreFieldsStripped(boolean) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
Should fields (eg macros) be stripped from the text that this class returns? Default is not to strip.
setArrayData(byte[], int) - Method in class org.apache.poi.ddf.EscherArrayProperty
We have this method because the way in which arrays in escher works is screwed for seemly arbitary reasons.
setArrayFormula(CellRangeAddress, Ptg[]) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setArrayFormula(String, CellRangeAddress) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

setArrayFormula(String, CellRangeAddress) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets array formula to specified region for result.
setArrayFormula(String, CellRangeAddress) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets array formula to specified region for result.
setArrayFormula(String, CellRangeAddress) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

setAsActiveCell() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Sets this cell as the active cell for the worksheet
setAsActiveCell() - Method in interface org.apache.poi.ss.usermodel.Cell
Sets this cell as the active cell for the worksheet
setAsActiveCell() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Sets this cell as the active cell for the worksheet
setAsActiveCell() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Sets this cell as the active cell for the worksheet.
setAsumyi(byte[]) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the asumyi field for the DOP record.
setAttributes(short) - Method in class org.apache.poi.hssf.record.FontRecord
set the font attributes (see individual bit setters that reference this method)
setAuthor(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the author.
setAuthor(String) - Method in class org.apache.poi.hslf.model.Comment
Set the Author of this comment
setAuthor(String) - Method in class org.apache.poi.hslf.record.Comment2000
Set the Author of this comment
setAuthor(String) - Method in class org.apache.poi.hssf.record.NoteRecord
Name of the original comment author
setAuthor(String) - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Name of the original comment author
setAuthor(String) - Method in interface org.apache.poi.ss.usermodel.Comment
Name of the original comment author
setAuthor(String) - Method in class org.apache.poi.xssf.usermodel.XSSFComment
Name of the original comment author.
setAuthorInitials(String) - Method in class org.apache.poi.hslf.model.Comment
Set the Author's Initials of this comment
setAuthorInitials(String) - Method in class org.apache.poi.hslf.record.Comment2000
Set the Author's Initials of this comment
setAuto(boolean) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Sets the auto field value.
setAuto(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFColor
A boolean value indicating the ctColor is automatic and system ctColor dependent.
setAutoBackground(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the auto background field value.
setAutobreaks(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
show automatic page breaks or not
setAutobreaks(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
show automatic page breaks or not
setAutobreaks(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether the sheet displays Automatic Page Breaks.
setAutobreaks(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether the sheet displays Automatic Page Breaks.
setAutobreaks(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether the sheet displays Automatic Page Breaks.
setAutoColor(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the auto color field value.
setAutofill(boolean) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Sets the autofill field value.
setAutoFilter(CellRangeAddress) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

setAutoFilter(CellRangeAddress) - Method in interface org.apache.poi.ss.usermodel.Sheet
Enable filtering for a range of cells
setAutoFilter(CellRangeAddress) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Enable filtering for a range of cells
setAutoFilter(CellRangeAddress) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

setAutoGeneratedText(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the auto generated text field value.
setAutoHyphenated(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setAutoHyphenated(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setAutoLabelDeleted(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the auto label deleted field value.
setAutoline(boolean) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Sets the autoline field value.
setAutomatic(boolean) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Sets the automatic field value.
setAutomaticCategoryCrossing(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the automatic category crossing field value.
setAutomaticMajor(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the automatic major field value.
setAutomaticMaximum(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the automatic maximum field value.
setAutomaticMinimum(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the automatic minimum field value.
setAutomaticMinor(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the automatic minor field value.
setAutoPlay(boolean) - Method in class org.apache.poi.hslf.model.MovieShape

setAutoPlotArea(boolean) - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Sets the auto plot area field value.
setAutoPosition(boolean) - Method in class org.apache.poi.hssf.record.chart.FrameRecord
Sets the auto position field value.
setAutoPosition(boolean) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Sets the auto position field value.
setAutorotate(boolean) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Sets the autorotate field value.
setAutoSeries(boolean) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Sets the auto series field value.
setAutoSize(boolean) - Method in class org.apache.poi.hssf.record.chart.FrameRecord
Sets the auto size field value.
setAutoTextBackground(boolean) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Sets the auto text background field value.
setAutoTextColor(boolean) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Sets the auto text color field value.
setAutoXPositioning(boolean) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Sets the auto x positioning field value.
setAutoYPositioning(boolean) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Sets the auto y positioning field value.
setAxisType(short) - Method in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord
Set the axis type field for the AxisLineFormat record.
setAxisType(short) - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Set the axis type field for the AxisParent record.
setAxisType(short) - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Set the axis type field for the Axis record.
setBackcolorIndex(short) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Set the backcolor index field for the AreaFormat record.
setBackground(Color) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the background color for the Graphics2D context.
setBackground(byte) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the background field for the Tick record.
setBackground(Color) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setBackground(Color) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

setBackground(Color) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setBackgroundColor(Color) - Method in class org.apache.poi.hslf.model.Fill
Background color
setBackgroundColor(int) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Set the background color field for the AreaFormat record.
setBackgroundColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Background Colour
setBackup(short) - Method in class org.apache.poi.hssf.record.BackupRecord
set the backup flag (0,1)
setBackupFlag(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
determine whether the Excel GUI will backup the workbook when saving.
setBackuppos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setBackward(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setBackward(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setBackwardDiagonalOn(boolean) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
Of/off top left to bottom right line
setBackwardDiagonalOn(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setBadFontHeight(boolean) - Method in class org.apache.poi.hssf.record.RowRecord
set whether the font and row height are not compatible
setBarBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setBarBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setBarSpace(short) - Method in class org.apache.poi.hssf.record.chart.BarRecord
Set the bar space field for the Bar record.
setBaseUnit(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the base unit field for the AxisOptions record.
setBasicEscher(boolean) - Method in class org.apache.poi.hslf.dev.SlideShowDumper
Control dumping of any Escher records found - should our built in basic groker be used?
setBAT(BlockAllocationTableReader) - Method in interface org.apache.poi.poifs.storage.BlockList
set the associated BlockAllocationTable
setBATArray(int[]) - Method in class org.apache.poi.poifs.storage.HeaderBlock
Sets the offsets of the first (up to) 109 BAT sectors.
setBATBlocks(int, int) - Method in class org.apache.poi.poifs.storage.HeaderBlockWriter
Set BAT block parameters.
setBATCount(int) - Method in class org.apache.poi.poifs.storage.HeaderBlock
Sets the number of BAT blocks that are used.
setBchUpe(int) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
An unsigned integer that specifies the size, in bytes, of std in LPStd.
setBeginChar(int) - Method in class org.apache.poi.xwpf.usermodel.TextSegement

setBeginRun(int) - Method in class org.apache.poi.xwpf.usermodel.TextSegement

setBeginText(int) - Method in class org.apache.poi.xwpf.usermodel.TextSegement

setBkc(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Break code.
setBkf_flags(short) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Set the bkf_flags field for the BKF record.
setBlipRecord(EscherBlipRecord) - Method in class org.apache.poi.ddf.EscherBSERecord

setBlipTypeMacOS(byte) - Method in class org.apache.poi.ddf.EscherBSERecord
Set the expected MacOS blip type
setBlipTypeWin32(byte) - Method in class org.apache.poi.ddf.EscherBSERecord
Set the expected win32 blip type
setBold(boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is the text bold?
setBold(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting
set the font weight to bold (weight=700) or to normal(weight=400) boldness.
setBold(Element, boolean) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setBold(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setBold(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setBold(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun
Specifies whether this run of text will be formatted as bold text
setBold(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set a boolean value for the boldness to use.
setBold(boolean) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document.
setBoldWeight(short) - Method in class org.apache.poi.hssf.record.FontRecord
set the bold weight for this font (100-1000dec or 0x64-0x3e8).
setBoldweight(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set the boldness to use
setBoldweight(short) - Method in interface org.apache.poi.ss.usermodel.Font

setBoldweight(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFont

setBoolean(int, boolean) - Method in class org.apache.poi.util.BitField
Set a boolean BitField
setBorder(boolean) - Method in class org.apache.poi.hssf.record.chart.DatRecord
Sets the border field value.
setBorder(Element, BorderCode, String) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setBorderBetween(Borders) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.
setBorderBottom(Line) - Method in class org.apache.poi.hslf.model.TableCell

setBorderBottom(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the type of border to use for the bottom border of the cell
setBorderBottom(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the border line style for the bottom border
setBorderBottom(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setBorderBottom(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the type of border to use for the bottom border of the cell
setBorderBottom(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setBorderBottom(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the borderBottom attribute of the HSSFRegionUtil object
setBorderBottom(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

setBorderBottom(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the type of border to use for the bottom border of the cell
setBorderBottom(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the borderBottom attribute of the RegionUtil object
setBorderBottom(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderBottom(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setBorderBottom(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the bottom border of the cell
setBorderBottom(BorderStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the bottom border of the cell
setBorderBottom(Borders) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.
setBorderBottomColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderColor(XSSFCellBorder.BorderSide, XSSFColor) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Set the color to use for the selected border
setBorderColor(XSSFCellBorder.BorderSide, XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the selected border
setBorderDiagonal(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the type of border to use for the diagonal border of the cell
setBorderDiagonal(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setBorderDiagonal(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting
Set diagonal border.
setBorderDiagonal(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setBorderFormatting(BorderFormatting) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setBorderLeft(Line) - Method in class org.apache.poi.hslf.model.TableCell

setBorderLeft(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the type of border to use for the left border of the cell
setBorderLeft(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the borderline style for the left border
setBorderLeft(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setBorderLeft(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the type of border to use for the left border of the cell
setBorderLeft(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setBorderLeft(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
setBorderLeft(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting
Set left border.
setBorderLeft(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the type of border to use for the left border of the cell
setBorderLeft(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
setBorderLeft(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderLeft(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setBorderLeft(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the left border of the cell
setBorderLeft(BorderStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the left border of the cell
setBorderLeft(Borders) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed on the left side of the page around the specified paragraph.
setBorderLeftColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderOptions(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the border options bitmask (see the corresponding bitsetter methods that reference back to this one)
setBorderRight(Line) - Method in class org.apache.poi.hslf.model.TableCell

setBorderRight(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the type of border to use for the right border of the cell
setBorderRight(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the border line style for the right border
setBorderRight(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setBorderRight(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the type of border to use for the right border of the cell
setBorderRight(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setBorderRight(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the borderRight attribute of the HSSFRegionUtil object
setBorderRight(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting
Set right border.
setBorderRight(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the type of border to use for the right border of the cell
setBorderRight(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the borderRight attribute of the RegionUtil object
setBorderRight(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderRight(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setBorderRight(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the right border of the cell
setBorderRight(BorderStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the right border of the cell
setBorderRight(Borders) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed on the right side of the page around the specified paragraph.
setBorderRightColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderStyle(XSSFCellBorder.BorderSide, BorderStyle) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Set the type of border to use for the selected border
setBorderTop(Line) - Method in class org.apache.poi.hslf.model.TableCell

setBorderTop(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the type of border to use for the top border of the cell
setBorderTop(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the border line style for the top border
setBorderTop(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setBorderTop(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the type of border to use for the top border of the cell
setBorderTop(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setBorderTop(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the borderBottom attribute of the HSSFRegionUtil object
setBorderTop(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting
Set top border.
setBorderTop(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the type of border to use for the top border of the cell
setBorderTop(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the borderBottom attribute of the RegionUtil object
setBorderTop(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderTop(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setBorderTop(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the top border of the cell
setBorderTop(BorderStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of border to use for the top border of the cell
setBorderTop(Borders) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.
setBorderTopColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBorderType(short) - Method in class org.apache.poi.hssf.record.chart.FrameRecord
Set the border type field for the Frame record.
setBorderType(int) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

setBottomBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setBottomBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setBottomBorderColor(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the color to use for the bottom border
setBottomBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setBottomBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the color to use for the bottom border
setBottomBorderColor(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setBottomBorderColor(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the bottomBorderColor attribute of the HSSFRegionUtil object
setBottomBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

setBottomBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the color to use for the bottom border
setBottomBorderColor(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the bottomBorderColor attribute of the RegionUtil object
setBottomBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setBottomBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the bottom border
setBottomBorderColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the bottom border
setBottomBorderModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setBottomBorderPaletteIdx(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the palette index for the bottom border
setBottomInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setBottomInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Sets the botom margin.
setBottomLeftTopRightBorderModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setBoundaryHeight(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the boundary height of the metafile drawing commands
setBoundaryLeft(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the left boundary of the metafile drawing commands
setBoundaryTop(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the top boundary of the metafile drawing commands
setBoundaryWidth(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the boundary width of the metafile drawing commands
setBounds(Rectangle) - Method in class org.apache.poi.ddf.EscherMetafileBlip

setBounds(Rectangle) - Method in class org.apache.poi.ddf.EscherPictBlip

setBpp(byte) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the bpp field for the PICF record.
setBrc(BorderCode) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Border.
setBrcBar(BorderCode) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the brcBar field for the PAP record.
setBrcBetween(BorderCode) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the brcBetween field for the PAP record.
setBrcBottom(BorderCode) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the brcBottom field for the PAP record.
setBrcBottom(BorderCode) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the brcBottom field for the SEP record.
setBrcBottom(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the brcBottom field for the TAP record.
setBrcBottom(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom border.
setBrcBottom80(byte[]) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the brcBottom80 field for the PICF record.
setBrcHorizontal(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the brcHorizontal field for the TAP record.
setBrcl(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Border line style.
setBrcLeft(BorderCode) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the brcLeft field for the PAP record.
setBrcLeft(BorderCode) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the brcLeft field for the SEP record.
setBrcLeft(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the brcLeft field for the TAP record.
setBrcLeft(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left border.
setBrcLeft80(byte[]) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the brcLeft80 field for the PICF record.
setBrcp(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Rectangle border codes.
setBrcRight(BorderCode) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the brcRight field for the PAP record.
setBrcRight(BorderCode) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the brcRight field for the SEP record.
setBrcRight(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the brcRight field for the TAP record.
setBrcRight(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right border.
setBrcRight80(byte[]) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the brcRight80 field for the PICF record.
setBrcTop(BorderCode) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the brcTop field for the PAP record.
setBrcTop(BorderCode) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the brcTop field for the SEP record.
setBrcTop(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the brcTop field for the TAP record.
setBrcTop(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top border.
setBrcTop80(byte[]) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the brcTop80 field for the PICF record.
setBrcVertical(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the brcVertical field for the TAP record.
setBspos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setBubbleSeriesType(short) - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Set the bubble series type field for the Series record.
setBucketOffsets(int[], int[]) - Method in class org.apache.poi.hssf.record.ExtSSTRecord

setBuild(int) - Method in class org.apache.poi.hssf.record.BOFRecord
build that wrote this file
setBuildYear(int) - Method in class org.apache.poi.hssf.record.BOFRecord
Year of the build that wrote this file
setBuiltinStyle(int) - Method in class org.apache.poi.hssf.record.StyleRecord
if this is a builtin style set the number of the built in style
setBullet(boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets whether this rich text run has bullets
setBullet(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

setBulletAutoNumber(ListAutoNumber, int) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Specifies that automatic numbered bullet points should be applied to this paragraph
setBulletChar(char) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the bullet character
setBulletCharacter(String) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

setBulletColor(Color) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the bullet color
setBulletFont(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the bullet font
setBulletFont(String) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

setBulletFontColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Set the color to be used on bullet characters within a given paragraph.
setBulletFontSize(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Sets the bullet size that is to be used within a paragraph.
setBulletOffset(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the bullet offset
setBulletSize(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the bullet size
setBx(byte) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the bx field value.
setBy(byte) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the by field value.
setByte(byte) - Method in class org.apache.poi.util.BitField
Set the bits.
setByteBoolean(byte, boolean) - Method in class org.apache.poi.util.BitField
Set a boolean BitField
setByteCount(int) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the byte count.
setByteOrder(int) - Method in class org.apache.poi.hpsf.MutablePropertySet
Sets the "byteOrder" property.
setByteOrder(int) - Method in class org.apache.poi.hpsf.SpecialPropertySet

setBytes(byte[]) - Method in class org.apache.poi.hpsf.ClassID
Sets the bytes making out the class ID.
setCachedBooleanResult(boolean) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setCachedDoubleResult(double) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setCachedErrorResult(int) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setCachedResultBoolean(boolean) - Method in class org.apache.poi.hssf.record.FormulaRecord

setCachedResultErrorCode(int) - Method in class org.apache.poi.hssf.record.FormulaRecord

setCachedResultTypeEmptyString() - Method in class org.apache.poi.hssf.record.FormulaRecord

setCachedResultTypeString() - Method in class org.apache.poi.hssf.record.FormulaRecord

setCachedStringResult(String) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setCacheOfSavedSize(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the cache of the saved size
setCacheOfSize(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the cache of the metafile size
setCalcMode(short) - Method in class org.apache.poi.hssf.record.CalcModeRecord
set the calc mode flag for formulas
setCalcOnLoad(boolean) - Method in class org.apache.poi.hssf.record.FormulaRecord

setCalendar(Calendar, int, int, boolean) - Static method in class org.apache.poi.ss.usermodel.DateUtil

setCantSplit(boolean) - Method in class org.apache.poi.hwpf.usermodel.TableRow

setCantSplitRow(boolean) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
This attribute controls whether to allow table rows to split across pages.
setCapitalized(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setCapitalized(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setCategory(String) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the category.
setCategory(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setCategoryAxisCross(double) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Set the category axis cross field for the ValueRange record.
setCategoryDataType(short) - Method in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord
Set the category data type field for the DefaultDataLabelTextProperties record.
setCategoryDataType(short) - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Set the category data type field for the Series record.
setCategoryLabelsCellRange(CellRangeAddressBase) - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

setCategoryProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set the category.
setCategoryProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the category of the content of this package.
setCategorySpace(short) - Method in class org.apache.poi.hssf.record.chart.BarRecord
Set the category space field for the Bar record.
setCbFeatData(long) - Method in class org.apache.poi.hssf.record.FeatRecord

setCbGrpprlChpx(short) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.
setCbGrpprlPapx(short) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.
setCbHeader(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
An unsigned integer that specifies the size, in bytes, of this PICF structure.
setCbMac(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Updates the count of the number of bytes in the main stream which contain real data
setCbMac(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the cbMac field for the FibRgLw95 record.
setCbMac(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning.
setCbSTDBaseInFile(int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the size, in bytes, of the Stdf structure.
setCCh(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cCh field for the DOP record.
setCChFtnEdn(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cChFtnEdn field for the DOP record.
setCChWS(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cChWS field for the DOP record.
setCChWSFtnEdn(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cChWSFtnEdn field for the DOP record.
setCcolM1(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the ccolM1 field for the SEP record.
setCConsexHypLim(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cConsexHypLim field for the DOP record.
setCcpAtn(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpAtn field for the FibRgLw95 record.
setCcpAtn(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the comment subdocument.
setCcpEdn(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpEdn field for the FibRgLw95 record.
setCcpEdn(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the endnote subdocument.
setCcpFtn(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpFtn field for the FibRgLw95 record.
setCcpFtn(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the footnote subdocument.
setCcpHdd(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpHdd field for the FibRgLw95 record.
setCcpHdd(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the header subdocument.
setCcpHdrTxbx(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpHdrTxbx field for the FibRgLw95 record.
setCcpHdrTxbx(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the textbox subdocument of the header.
setCcpMcr(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpMcr field for the FibRgLw95 record.
setCcpText(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpText field for the FibRgLw95 record.
setCcpText(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the main document.
setCcpTxbx(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the ccpTxbx field for the FibRgLw95 record.
setCcpTxbx(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
A signed integer that specifies the count of CPs in the textbox subdocument of the main document.
setCDBC(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cDBC field for the DOP record.
setCDBCFtnEdn(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cDBCFtnEdn field for the DOP record.
setCellComment(Comment) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Assign a comment to this cell.
setCellComment(Comment) - Method in interface org.apache.poi.ss.usermodel.Cell
Assign a comment to this cell
setCellComment(Comment) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Assign a comment to this cell
setCellComment(Comment) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Assign a comment to this cell.
setCellComment(String, XSSFComment) - Static method in class org.apache.poi.xssf.usermodel.XSSFSheet
Deprecated. since Nov 2009 use XSSFCell.setCellComment(org.apache.poi.ss.usermodel.Comment) instead
setCellErrorValue(byte) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set a error value for the cell
setCellErrorValue(byte) - Method in interface org.apache.poi.ss.usermodel.Cell
Set a error value for the cell
setCellErrorValue(byte) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set a error value for the cell
setCellErrorValue(byte) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a error value for the cell
setCellErrorValue(FormulaError) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a error value for the cell
setCellFormula(String) - Method in class org.apache.poi.hssf.usermodel.HSSFCell

setCellFormula(String) - Method in interface org.apache.poi.ss.usermodel.Cell
Sets formula for this cell.
setCellFormula(String) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Sets formula for this cell.
setCellFormula(String) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Sets formula for this cell.
setCellMargins(int, int, int, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

setCellNum(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Deprecated. (Jan 2008) Doesn't update the row's idea of what cell this is, use HSSFRow.moveCell(HSSFCell, short) instead
setCellNum(int) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Sets column index of this cell
setCellOptions(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
sets the options bitmask - you can also use corresponding option bit setters (see other methods that reference this one)
setCellRanges(CellRangeAddress[]) - Method in class org.apache.poi.hssf.record.CFHeaderRecord
Set cell ranges list to a single cell range and modify the enclosing cell range accordingly.
setCellReference(String) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Assigns this hyperlink to the given cell reference
setCellRefs(CellRangeAddress[]) - Method in class org.apache.poi.hssf.record.FeatRecord

setCellStyle(CellStyle) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set the style for the cell.
setCellStyle(HSSFCellStyle) - Method in class org.apache.poi.hssf.usermodel.HSSFCell

setCellStyle(CellStyle) - Method in interface org.apache.poi.ss.usermodel.Cell
Set the style for the cell.
setCellStyle(CellStyle) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set the style for the cell.
setCellStyle(CellStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set the style for the cell.
setCellStyleProperty(HSSFCell, HSSFWorkbook, String, Object) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
This method attempt to find an already existing HSSFCellStyle that matches what you want the style to be.
setCellStyleProperty(Cell, Workbook, String, Object) - Static method in class org.apache.poi.ss.util.CellUtil
This method attempt to find an already existing CellStyle that matches what you want the style to be.
setCellType(int) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set the cells type (numeric, formula or string)
setCellType(int) - Method in interface org.apache.poi.ss.usermodel.Cell
Set the cells type (numeric, formula or string)
setCellType(int) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set the cells type (numeric, formula or string)
setCellType(int) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set the cells type (numeric, formula or string)
setCellValue(double) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set a numeric value for the cell
setCellValue(Date) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set a date value for the cell.
setCellValue(Calendar) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set a date value for the cell.
setCellValue(String) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set a string value for the cell.
setCellValue(RichTextString) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Set a string value for the cell.
setCellValue(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
set a boolean value for the cell
setCellValue(double) - Method in interface org.apache.poi.ss.usermodel.Cell
Set a numeric value for the cell
setCellValue(Date) - Method in interface org.apache.poi.ss.usermodel.Cell
Converts the supplied date to its equivalent Excel numeric value and sets that into the cell.
setCellValue(Calendar) - Method in interface org.apache.poi.ss.usermodel.Cell
Set a date value for the cell.
setCellValue(RichTextString) - Method in interface org.apache.poi.ss.usermodel.Cell
Set a rich string value for the cell.
setCellValue(String) - Method in interface org.apache.poi.ss.usermodel.Cell
Set a string value for the cell.
setCellValue(boolean) - Method in interface org.apache.poi.ss.usermodel.Cell
Set a boolean value for the cell
setCellValue(double) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set a numeric value for the cell
setCellValue(Date) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Converts the supplied date to its equivalent Excel numeric value and sets that into the cell.
setCellValue(Calendar) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set a date value for the cell.
setCellValue(RichTextString) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set a rich string value for the cell.
setCellValue(String) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set a string value for the cell.
setCellValue(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Set a boolean value for the cell
setCellValue(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a boolean value for the cell
setCellValue(double) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a numeric value for the cell
setCellValue(String) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a string value for the cell.
setCellValue(RichTextString) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a string value for the cell.
setCellValue(Date) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a date value for the cell.
setCellValue(Calendar) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Set a date value for the cell.
setCenter(String) - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

setCenter(String) - Method in interface org.apache.poi.ss.usermodel.Footer
Sets the center string.
setCenter(String) - Method in interface org.apache.poi.ss.usermodel.Header
Sets the center string.
setCenter(String) - Method in interface org.apache.poi.ss.usermodel.HeaderFooter
Sets the center string.
setCenter(String) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
set a centered string value for this element
setCenterSection(String, String) - Method in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

setCh(byte) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the ch field value.
setChar(int) - Method in class org.apache.poi.xwpf.usermodel.PositionInParagraph

setCharacterSpacing(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setCharacterSpacing(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setCharacterSpacing(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun
Set the spacing between characters within a text run.
setCharactersProperties(CharacterRun, Element) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setCharacterStyles(LinkedList<TextPropCollection>) - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Updates the link list of TextPropCollections which make up the character stylings
setCharCount(int) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the character count.
setCharCount(short) - Method in class org.apache.poi.hssf.record.common.UnicodeString
set the number of characters in the string
setCharSet(int) - Method in class org.apache.poi.hslf.model.PPFont
set the character set
setCharSet(int) - Method in class org.apache.poi.hslf.record.FontEntityAtom
set the character set
setCharset(byte) - Method in class org.apache.poi.hssf.record.FontRecord
set the character set
setCharSet(int) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set character-set to use.
setCharSet(byte) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set character-set to use.
setCharSet(byte) - Method in interface org.apache.poi.ss.usermodel.Font
set character-set to use.
setCharSet(int) - Method in interface org.apache.poi.ss.usermodel.Font
set character-set to use.
setCharSet(byte) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set character-set to use.
setCharSet(int) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set character-set to use.
setCharSet(FontCharset) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set character-set to use.
setCharsetFlags(short) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the CharsetFlags field for the CHP record.
setChart(XSSFChart, String) - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Assign a DrawingML chart to the graphic frame.
setCharTextPropVal(String, int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the value of the given Paragraph TextProp, add if required
setChartGroupIndex(short) - Method in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord
Set the chart group index field for the SeriesChartGroupIndex record.
setChartGroupIndex(short) - Method in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord
Set the chart group index field for the SeriesToChartGroup record.
setChartHeight(int) - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Sets the height of the chart.
setChartTitle(String) - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Changes the chart's title, but only if there was one already.
setChartTypeManuallyFormatted(boolean) - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Sets the chart type manually formatted field value.
setChartWidth(int) - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Sets the width of the chart.
setChartX(int) - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Sets the X offset of the chart
setChartY(int) - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Sets the Y offset of the chart
setCheckCalculationErrors(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setCheckDateTimeFormats(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setCheckEmptyCellRef(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setCheckInconsistentFormulas(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setCheckInconsistentRanges(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setCheckNumbersAsText(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setCheckUnprotectedFormulas(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setChHolder(byte) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
ch field holder (along with reserved bits).
setChHres(byte) - Method in class org.apache.poi.hwpf.model.types.HRESIAbstractType
The character that will be used to add or change a letter when hres is 2, 3, 5 or 6.
setChildProperty(int) - Method in class org.apache.poi.poifs.property.Property
Set the child property.
setChildRecord(Record[]) - Method in class org.apache.poi.hslf.record.RecordContainer
Set child records.
setChildRecords(List<EscherRecord>) - Method in class org.apache.poi.ddf.EscherContainerRecord
replaces the internal child list with the contents of the supplied childRecords
setChildRecords(List<EscherRecord>) - Method in class org.apache.poi.ddf.EscherRecord
Sets the child records for this record.
setChildRecords(List<EscherRecord>) - Method in class org.apache.poi.ddf.UnknownEscherRecord

setCHorzBands(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Size of each horizontal style band, in number of rows.
setChs(short) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value MUST be 0 and MUST be ignored.
setChse(short) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the chse field for the CHP record.
setChsTables(short) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value MUST be 0 and MUST be ignored.
setClass(byte) - Method in class org.apache.poi.ss.formula.ptg.Ptg

setClassID(ClassID) - Method in class org.apache.poi.hpsf.MutablePropertySet
Sets the property set stream's low-level "class ID" field.
setClassID(ClassID) - Method in class org.apache.poi.hpsf.SpecialPropertySet

setClfolvl(byte) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Count of levels whose format is overridden (see LFOLVL).
setCLines(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cLines field for the DOP record.
setCLinesFtnEdn(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cLinesFtnEdn field for the DOP record.
setClip(Shape) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the current clipping area to an arbitrary clip shape.
setClip(int, int, int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the current clip to the rectangle specified by the given coordinates.
setClip(Shape) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setClip(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setClip(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

setClip(Shape) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

setClip(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setClip(Shape) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setClipboardName(String) - Method in class org.apache.poi.hslf.record.ExEmbed

setClm(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the clm field for the SEP record.
setCnsPgn(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the cnsPgn field for the SEP record.
setCodepage(int) - Method in class org.apache.poi.hpsf.CustomProperties
Sets the codepage.
setCodepage(int) - Method in class org.apache.poi.hpsf.MutableSection
Sets the codepage.
setCodepage(short) - Method in class org.apache.poi.hssf.record.CodepageRecord
set the codepage for this workbook
setCol1(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The column number for the top-left position.
setCol1(short) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

setCol1(int) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

setCol1(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Sets the column (0 based) of the first cell.
setCol1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setCol2(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The column of the bottom right corner of this shape.
setCol2(short) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

setCol2(int) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

setCol2(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the column (0 based) of the second cell.
setCol2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setColapsed(boolean) - Method in class org.apache.poi.hssf.record.RowRecord
set whether or not to collapse this row
setColBandSize(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

setColBestFit(long, boolean) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

setColDefaultStyle(long, CellStyle) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

setColDefaultStyle(long, int) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

setColDeleted(boolean) - Method in class org.apache.poi.hssf.record.TableRecord

setColHidden(long, boolean) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

setColInputCol(int) - Method in class org.apache.poi.hssf.record.TableRecord

setColInputRow(int) - Method in class org.apache.poi.hssf.record.TableRecord

setCollapsed(boolean) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
set whether the cells are collapsed
setColLevelMax(short) - Method in class org.apache.poi.hssf.record.GutsRecord
set the maximum outline level for the col gutter.
setColor(Color) - Method in interface org.apache.poi.common.usermodel.Fill

setColor(Color) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets this graphics context's current color to the specified color.
setColor(short, byte, byte, byte) - Method in class org.apache.poi.hssf.record.PaletteRecord
Sets the color value at a given index If the given index is greater than the current last color index, then black is inserted at every index required to make the palette continuous.
setColor(Color) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setColor(Color) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

setColor(Color) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set the color for the font
setColor(short) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

setColor(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setColor(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setColor(short) - Method in interface org.apache.poi.ss.usermodel.Font
set the color for the font
setColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the indexed color for the font
setColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the color for the font in Standard Alpha Red Green Blue color value
setColor(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Set text color.
setColor(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
Set cell color.
setColor1(int) - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

setColor2(int) - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

setColor3(int) - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

setColor4(int) - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

setColorAtIndex(short, byte, byte, byte) - Method in class org.apache.poi.hssf.usermodel.HSSFPalette
Sets the color at the given offset
setColorPaletteIndex(short) - Method in class org.apache.poi.hssf.record.FontRecord
set the font's color palette index
setColourPaletteIndex(short) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Set the colour palette index field for the LineFormat record.
setColRelative(boolean) - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

setColumn(int, Short, Integer, Integer, Boolean, Boolean) - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

setColumn(short) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setColumn(short) - Method in class org.apache.poi.hssf.record.BlankRecord
set the column this cell defines within the row
setColumn(short) - Method in class org.apache.poi.hssf.record.CellRecord

setColumn(short) - Method in interface org.apache.poi.hssf.record.CellValueRecordInterface

setColumn(short) - Method in class org.apache.poi.hssf.record.LabelRecord
NO-OP!
setColumn(int) - Method in class org.apache.poi.hssf.record.NoteRecord
Specify the column that contains the comment
setColumn(int) - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Set the column of the cell that contains the comment
setColumn(short) - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Deprecated. (Nov 2009) use HSSFComment.setColumn(int) }
setColumn(int) - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

setColumn(int) - Method in interface org.apache.poi.ss.usermodel.Comment
Set the column of the cell that contains the comment
setColumn(int) - Method in class org.apache.poi.xssf.usermodel.XSSFComment
Set the column of the cell that contains the comment
setColumnAttributes(CTCol, CTCol) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

setColumnBreak(short, short, short) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Sets a page break at the indicated column
setColumnBreak(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets a page break at the indicated column.
setColumnBreak(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets a page break at the indicated column.
setColumnBreak(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets a page break at the indicated column
setColumnBreak(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets a page break at the indicated column.
setColumnFrom(short) - Method in class org.apache.poi.ss.util.Region
Deprecated. set the upper left hand corner column number
setColumnGroupCollapsed(int, boolean) - Method in class org.apache.poi.hssf.model.InternalSheet

setColumnGroupCollapsed(short, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.setColumnGroupCollapsed(int, boolean)
setColumnGroupCollapsed(int, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Expands or collapses a column group.
setColumnGroupCollapsed(int, boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Expands or collapses a column group.
setColumnGroupCollapsed(int, boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Expands or collapses a column group.
setColumnGroupCollapsed(int, boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

setColumnHidden(int, boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
Get the hidden property for a given column.
setColumnHidden(short, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.setColumnHidden(int, boolean)
setColumnHidden(int, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Get the visibility state for a given column.
setColumnHidden(int, boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Get the visibility state for a given column
setColumnHidden(int, boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Get the visibility state for a given column
setColumnHidden(int, boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Get the visibility state for a given column.
setColumnTo(short) - Method in class org.apache.poi.ss.util.Region
Deprecated. set the lower right hand corner column number
setColumnWidth(int, int) - Method in class org.apache.poi.hslf.model.Table
Sets the column width.
setColumnWidth(int, int) - Method in class org.apache.poi.hssf.model.InternalSheet
set the width for a given column in 1/256th of a character width units
setColumnWidth(int) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
set the columns' width in 1/256 of a character width
setColumnWidth(short, short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.setColumnWidth(int, int)
setColumnWidth(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Set the width (in units of 1/256th of a character width)
setColumnWidth(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Set the width (in units of 1/256th of a character width)
setColumnWidth(int, double) - Method in class org.apache.poi.xslf.usermodel.XSLFTable

setColumnWidth(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Set the width (in units of 1/256th of a character width)
setColumnWidth(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Set the width (in units of 1/256th of a character width)
setColWidth(int) - Method in class org.apache.poi.hssf.record.DefaultColWidthRecord
set the default column width
setColWidth(long, double) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

setComment(String) - Method in class org.apache.poi.hssf.usermodel.HSSFName
Sets the comment the user provided when the name was created.
setComment(String) - Method in interface org.apache.poi.ss.usermodel.Name
Sets the comment the user provided when the name was created.
setComment(String) - Method in class org.apache.poi.xssf.usermodel.XSSFName
Specifies the comment the user provided when the name was created.
setComments(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the comments.
setCommentsByDefault(boolean) - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Should a call to getText() return comments text? Default is no
setCommentText(String) - Method in class org.apache.poi.hssf.record.NameCommentRecord

setCommonSlideData(CTCommonSlideData) - Method in class org.apache.poi.xslf.usermodel.XSLFSheet

setCompany(String) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the company.
setComparisonOperation(byte) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setComposite(Composite) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the Composite for the Graphics2D context.
setComposite(Composite) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setComposite(Composite) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setCompressed(boolean) - Method in class org.apache.poi.ddf.EscherMetafileBlip

setCompressed(boolean) - Method in class org.apache.poi.ddf.EscherPictBlip

setCompressedSize(int) - Method in class org.apache.poi.ddf.EscherMetafileBlip

setCompressedSize(int) - Method in class org.apache.poi.ddf.EscherPictBlip

setCompressionFlag(byte) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set whether the contents of the blip is compressed
setCompressTempFiles(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Set whether temp files should be compressed.
setContentStatus(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setContentStatusProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set the content status.
setContentStatusProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Get the status of the content.
setContentType(String) - Method in class org.apache.poi.openxml4j.opc.PackagePart
Set the content type.
setContentType(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setContentTypeProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set the content type.
setContentTypeProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the type of content represented, generally defined by a specific use and intended audience.
setCoordinates(Rectangle2D) - Method in class org.apache.poi.hslf.model.ShapeGroup
Sets the coordinate space of this group.
setCoordinates(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Sets the coordinate space of this group.
setCoordinates(int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFShapeGroup
Sets the coordinate space of this group.
setCoordinates(int, int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFShapeGroup
Sets the coordinate space of this group.
setCopies(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setCopies(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Sets the number of copies.
setCopies(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Sets the number of copies.
setCopies(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Sets the number of copies.
setCopt(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Collection of the 5 flags.
setCount(short) - Method in class org.apache.poi.hssf.record.FnGroupCountRecord
set the number of built-in functions
setCountOfLinesToDrop(byte) - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

setCParas(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cParas field for the DOP record.
setCParasFtnEdn(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cParasFtnEdn field for the DOP record.
setCpg(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Code page of run in pre-Unicode files.
setCPg(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cPg field for the DOP record.
setCPgFtnEdn(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cPgFtnEdn field for the DOP record.
setCProps(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This value MUST be 0 and MUST be ignored.
setCQuickSaves(byte) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the cQuickSaves field value.
setCreated(Nullable<Date>) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setCreated(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setCreateDateTime(Date) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the creation time.
setCreatedProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set the created date.
setCreatedProperty(Nullable<Date>) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set the created date.
setCreatedProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the date of creation of the resource.
setCreatedProperty(Nullable<Date>) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the date of creation of the resource.
setCreateEmptyCells(boolean) - Method in class org.apache.poi.ss.util.SheetBuilder
Specifies if null array elements should be treated as empty cells.
setCreator(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setCreator(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setCreatorProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set the creator.
setCreatorProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the entity primarily responsible for making the content of the resource.
setCreatorTool(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setCrossBetween(AxisCrossBetween) - Method in interface org.apache.poi.ss.usermodel.charts.ValueAxis

setCrossBetween(AxisCrossBetween) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

setCrossCategoryAxisAtMaximum(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the cross category axis at maximum field value.
setCrosses(AxisCrosses) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

setCrosses(AxisCrosses) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

setCrossesFarRight(boolean) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Sets the crosses far right field value.
setCrossingPoint(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the crossing point field for the AxisOptions record.
setCrossingPoint(short) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Set the crossing point field for the CategorySeriesAxis record.
setCssClassPrefixCell(String) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

setCssClassPrefixDiv(String) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

setCssClassPrefixRow(String) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

setCssClassPrefixTable(String) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter

setCstd(int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the count of elements in STSH.rglpstd.
setCTFtnEdn(CTFtnEdn) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnote

setCTNum(CTNum) - Method in class org.apache.poi.xwpf.usermodel.XWPFNum

setCTxbx(int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Count of textboxes in shape (undo doc only).
setCupx(byte) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the cupx field value.
setCurrentCountry(short) - Method in class org.apache.poi.hssf.record.CountryRecord
sets the current country
setCurrentEditOffset(long) - Method in class org.apache.poi.hslf.record.CurrentUserAtom

setCurrentRow(HSSFRow) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Deprecated. (Aug 2008) - not needed, since the current row can be derived from the cell
setCurrentUserPassword(String) - Static method in class org.apache.poi.hssf.record.crypto.Biff8EncryptionKey
Sets the BIFF8 encryption/decryption password for the current thread.
setCustomMenuText(String) - Method in class org.apache.poi.hssf.record.NameRecord
sets the custom menu text
setCustomNumberFormat(boolean) - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Sets the custom number format field value.
setCustomProperties(CustomProperties) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the custom properties.
setCustomWidth(long, boolean) - Method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

setCv(Colorref) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
24-bit color.
setCvBack(Colorref) - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType
24-bit background color.
setCVertBands(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Size of a vertical style band, in number of columns.
setCvFore(Colorref) - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType
24-bit foreground color.
setCWords(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cWords field for the DOP record.
setCWordsFtnEnd(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the cWordsFtnEnd field for the DOP record.
setData(byte[]) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
The BLIP data
setData(byte[], int, int) - Method in class org.apache.poi.ddf.EscherTextboxRecord
Sets the extra data (in the parent application's format) to be contained by the record.
setData(byte[]) - Method in class org.apache.poi.ddf.EscherTextboxRecord

setData(byte[]) - Method in class org.apache.poi.hslf.blip.Bitmap

setData(byte[]) - Method in class org.apache.poi.hslf.blip.DIB

setData(byte[]) - Method in class org.apache.poi.hslf.blip.EMF

setData(byte[]) - Method in class org.apache.poi.hslf.blip.PICT

setData(byte[]) - Method in class org.apache.poi.hslf.blip.WMF

setData(byte[]) - Method in class org.apache.poi.hslf.record.ExOleObjStg
Sets the embedded data.
setData(byte[]) - Method in class org.apache.poi.hslf.usermodel.ObjectData
Sets the embedded data.
setData(byte[]) - Method in class org.apache.poi.hslf.usermodel.PictureData
Set picture data
setData(byte[]) - Method in class org.apache.poi.hssf.record.DrawingRecord

setData(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setData(byte[]) - Method in interface org.apache.poi.sl.usermodel.PictureData

setDataFormat(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the data format (must be a valid format)
setDataFormat(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the data format (must be a valid format)
setDataFormat(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the index of a data format
setDataLabelPlacement(short) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the data label placement field value.
setDataOffset(int) - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

setDataTable(boolean) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Sets the data table field value.
setDate(Date) - Method in class org.apache.poi.hslf.record.Comment2000Atom
Sets the date the comment was made.
setDateTimeFormat(int) - Method in class org.apache.poi.hslf.model.HeadersFooters
An integer that specifies the format ID to be used to style the datetime.
setDateTimeText(String) - Method in class org.apache.poi.hslf.model.HeadersFooters
Sets custom user date to be displayed instead of today's date.
setDateTimeVisible(boolean) - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the date is displayed in the footer.
setDateToBeFormatted(double) - Method in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter
Used to let us know what the date being formatted is, in Excel terms, which we may wish to use when handling elapsed times.
setDbcell(int, int) - Method in class org.apache.poi.hssf.record.IndexRecord

setDcs(DropCapSpecifier) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dcs field for the PAP record.
setDDFEscher(boolean) - Method in class org.apache.poi.hslf.dev.SlideShowDumper
Control dumping of any Escher records found - should DDF be used?
setDefaultBase(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the default base field value.
setDefaultColumnStyle(int, int) - Method in class org.apache.poi.hssf.model.InternalSheet

setDefaultColumnStyle(int, CellStyle) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets the default column style for a given column.
setDefaultColumnStyle(int, CellStyle) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets the default column style for a given column.
setDefaultColumnStyle(int, CellStyle) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets the default column style for a given column.
setDefaultColumnStyle(int, CellStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

setDefaultColumnWidth(int) - Method in class org.apache.poi.hssf.model.InternalSheet
set the default column width for the sheet (if the columns do not define their own width)
setDefaultColumnWidth(short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.setDefaultColumnWidth(int)
setDefaultColumnWidth(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set the default column width for the sheet (if the columns do not define their own width) in characters
setDefaultColumnWidth(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Set the default column width for the sheet (if the columns do not define their own width) in characters
setDefaultColumnWidth(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Set the default column width for the sheet (if the columns do not define their own width) in characters
setDefaultColumnWidth(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Specifies the number of characters of the maximum digit width of the normal style's font.
setDefaultCountry(short) - Method in class org.apache.poi.hssf.record.CountryRecord
sets the default country
setDefaultCross(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the default cross field value.
setDefaultDateSettings(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the default date settings field value.
setDefaultFonts(CTFonts) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
Sets the default font on ctStyles DocDefaults parameter
setDefaultHeader(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set whether the window should display a default header
setDefaultMajor(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the default major field value.
setDefaultMaximum(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the default maximum field value.
setDefaultMinimum(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the default minimum field value.
setDefaultMinorUnit(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the default minor unit field value.
setDefaultNumberFormat(Format) - Method in class org.apache.poi.ss.usermodel.DataFormatter
Sets a default number format to be used when the Excel format cannot be parsed successfully.
setDefaultPlotDimensions(boolean) - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Sets the default plot dimensions field value.
setDefaultRowHeight(short) - Method in class org.apache.poi.hssf.model.InternalSheet
set the default row height for the sheet (if the rows do not define their own height)
setDefaultRowHeight(short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
setDefaultRowHeight(short) - Method in interface org.apache.poi.ss.usermodel.Sheet
Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
setDefaultRowHeight(short) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
setDefaultRowHeight(short) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
setDefaultRowHeightInPoints(float) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set the default row height for the sheet (if the rows do not define their own height) in points
setDefaultRowHeightInPoints(float) - Method in interface org.apache.poi.ss.usermodel.Sheet
Set the default row height for the sheet (if the rows do not define their own height) in points
setDefaultRowHeightInPoints(float) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Set the default row height for the sheet (if the rows do not define their own height) in points
setDefaultRowHeightInPoints(float) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets default row height measured in point size.
setDefaultSize() - Method in class org.apache.poi.hslf.model.Picture
Resize this picture to the default size.
setDefaultTextProperties(TextRun) - Method in class org.apache.poi.hslf.model.AutoShape

setDefaultTextProperties(TextRun) - Method in class org.apache.poi.hslf.model.TextBox

setDefaultTextProperties(TextRun) - Method in class org.apache.poi.hslf.model.TextShape
Set default properties for the TextRun.
setDelayTime(int) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A signed integer that specifies the delay time, in milliseconds, before the animation starts to play.
setDeleted(boolean) - Method in class org.apache.poi.openxml4j.opc.PackagePart

setDelMenuCount(byte) - Method in class org.apache.poi.hssf.record.MMSRecord
set number of del menu options (set to 0)
setDenominator(short) - Method in class org.apache.poi.hssf.record.SCLRecord
Set the denominator field for the SCL record.
setDescription(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setDescription(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setDescriptionProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set the description.
setDescriptionProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the explanation of the content of the resource.
setDescriptionText(String) - Method in class org.apache.poi.hssf.record.NameRecord
sets the description text
setDiag(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
Not sure what this is for (maybe fill lines?) 1 = down, 2 = up, 3 = both, 0 for none..
setDiagonalBorderColor(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the color to use for the diagonal borders
setDiagonalBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setDiagonalBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

setDiagonalBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setDialog(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
set whether sheet is a dialog sheet or not
setDialog(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set whether sheet is a dialog sheet or not
setDictionary(Map<Long, String>) - Method in class org.apache.poi.hpsf.MutableSection
Sets the section's dictionary.
setDimColor(int) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A rgb structure that specifies a color for the dim effect after the animation is complete.
setDimensions(int, short, int, short) - Method in class org.apache.poi.hssf.model.InternalSheet
Per an earlier reported bug in working with Andy Khan's excel read library.
setDisplayAsPercentage(boolean) - Method in class org.apache.poi.hssf.record.chart.AreaRecord
Sets the display as percentage field value.
setDisplayAsPercentage(boolean) - Method in class org.apache.poi.hssf.record.chart.BarRecord
Sets the display as percentage field value.
setDisplayedTab(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
Deprecated. - Misleading name - use setFirstVisibleTab()
setDisplayedTab(short) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. - Misleading name - use setFirstVisibleTab()
setDisplayFormulas(boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets whether the formulas are shown in a viewer.
setDisplayFormulas(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set whether the window should display formulas
setDisplayFormulas(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets whether the formulas are shown in a viewer.
setDisplayFormulas(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets whether the formulas are shown in a viewer
setDisplayFormulas(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets whether the formulas are shown in a viewer
setDisplayFormulas(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets the flag indicating whether this sheet should display formulas.
setDisplayGridlines(boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets whether the gridlines are shown in a viewer.
setDisplayGridlines(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set whether the window should display gridlines
setDisplayGridlines(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets whether the gridlines are shown in a viewer.
setDisplayGridlines(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets whether the gridlines are shown in a viewer
setDisplayGridlines(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets whether the gridlines are shown in a viewer
setDisplayGridlines(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier.
setDisplayGuts(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set whether the outline symbols are displaed
setDisplayGuts(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
set whether to display the guts or not
setDisplayGuts(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set whether to display the guts or not
setDisplayGuts(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Set whether to display the guts or not
setDisplayGuts(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Set whether to display the guts or not
setDisplayGuts(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Set whether to display the guts or not
setDisplayHorizonalScrollbar(boolean) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set whether to display the horizontal scrollbar or not
setDisplayMode(short) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the display mode field for the Text record.
setDisplayName(String) - Method in class org.apache.poi.xssf.usermodel.XSSFTable
Changes the display name of the Table
setDisplayRowColHeadings(boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets whether the RowColHeadings are shown in a viewer.
setDisplayRowColHeadings(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set whether the window should display row and column headings
setDisplayRowColHeadings(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets whether the RowColHeadings are shown in a viewer.
setDisplayRowColHeadings(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets whether the RowColHeadings are shown in a viewer
setDisplayRowColHeadings(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets whether the RowColHeadings are shown in a viewer
setDisplayRowColHeadings(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets the flag indicating whether this sheet should display row and column headings.
setDisplayTabs(boolean) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set whether to display the tabs or not
setDisplayVerticalScrollbar(boolean) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set whether to display the vertical scrollbar or not
setDisplayZeros(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set whether the window should display zero values
setDisplayZeros(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Set whether the window should show 0 (zero) in cells containing zero value.
setDisplayZeros(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Set whether the window should show 0 (zero) in cells containing zero value.
setDisplayZeros(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Set whether the window should show 0 (zero) in cells containing zero value.
setDisplayZeros(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Set whether the window should show 0 (zero) in cells containing zero value.
setDmBinFirst(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dmBinFirst field for the SEP record.
setDmBinOther(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dmBinOther field for the SEP record.
setDmOrientFirst(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dmOrientFirst field for the SEP record.
setDmOrientPage(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dmOrientPage field for the SEP record.
setDmPaperReq(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dmPaperReq field for the SEP record.
setDocId(byte[]) - Method in class org.apache.poi.hssf.record.FilePassRecord

setDocinfo(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the docinfo field for the DOP record.
setDocinfo1(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the docinfo1 field for the DOP record.
setDocinfo2(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the docinfo2 field for the DOP record.
setDocinfo3(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the docinfo3 field for the DOP record.
setDocinfo4(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the docinfo4 field for the DOP record.
setDocinfo5(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the docinfo5 field for the DOP record.
setDocinfo6(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the docinfo6 field for the DOP record.
setDocparts(byte[]) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the doc parts.
setDocument(POIFSDocument) - Method in class org.apache.poi.poifs.property.DocumentProperty
set the POIFSDocument
setDogrid(byte[]) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the dogrid field for the DOP record.
setDoNotSizeWithWindow(boolean) - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Sets the do not size with window field value.
setDoptypography(byte[]) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the doptypography field for the DOP record.
setDoubleStrikeThrough(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setDoubleStrikethrough(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setDraft(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setDraft(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set whether it is in draft mode
setDraft(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set whether it is in draft mode
setDraft(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set whether it is in draft mode
setDrawAspect(int) - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Sets whether the object can be completely seen, or if only the icon is visible.
setDrawingsSaved(int) - Method in class org.apache.poi.ddf.EscherDggRecord

setDrawTicks(boolean) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Sets the draw ticks field value.
setDropCap(DropCapSpecifier) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setDropCap(DropCapSpecifier) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setDropCapType(byte) - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

setDttmConflict(DateAndTime) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When the change was made.
setDttmCreated(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the dttmCreated field for the DOP record.
setDttmDispFldRMark(DateAndTime) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
The date for the ListNum field number change.
setDttmLastPrint(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the dttmLastPrint field for the DOP record.
setDttmPropRMark(DateAndTime) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Date/time at which properties of this were changed for this run of text by the author.
setDttmPropRMark(DateAndTime) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dttmPropRMark field for the PAP record.
setDttmPropRMark(DateAndTime) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dttmPropRMark field for the SEP record.
setDttmRevised(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the dttmRevised field for the DOP record.
setDttmRMark(DateAndTime) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
setDttmRMarkDel(DateAndTime) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).
setDublinCoreProperty(String, String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setDVRecNo(int) - Method in class org.apache.poi.hssf.record.DVALRecord
Set the number of following DV records
setDx1(int) - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Sets offset within the parent coordinate space for the top left point.
setDx1(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The x offset within the top-left cell.
setDx1(int) - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

setDx1(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Sets the x coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
setDx1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

setDx1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

setDx1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setDx2(int) - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Sets offset within the parent coordinate space for the bottom right point.
setDx2(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The x offset withing the cell for the bottom-right corner of this shape.
setDx2(int) - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

setDx2(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Sets the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
setDx2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

setDx2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

setDx2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setDxaAbs(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dxaAbs field for the PAP record.
setDxaAbs(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Absolute horizontal position.
setDxaAdjust(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setDxaColumns(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dxaColumns field for the SEP record.
setDxaColumnWidth(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dxaColumnWidth field for the SEP record.
setDxaColWidthWwd(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setDxaFromText(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Horizontal distance between text and absolutely positioned object.
setDxaFromText(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Left distance from surrounding text when absolutely positioned.
setDxaFromTextRight(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Right distance from surrounding text when absolutely positioned.
setDxaGapHalf(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Measures half of the white space that will be maintained between text in adjacent columns of a table row.
setDxaGoal(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dxaGoal field for the PICF record.
setDxaHotz(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the dxaHotz field for the DOP record.
setDxaIndentSav(int) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed.
setDxaLeft(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dxaLeft field for the PAP record.
setDxaLeft(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dxaLeft field for the SEP record.
setDxaLeft1(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dxaLeft1 field for the PAP record.
setDxaLnn(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dxaLnn field for the SEP record.
setDxaPgn(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dxaPgn field for the SEP record.
setDxaReserved1(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dxaReserved1 field for the PICF record.
setDxaReserved2(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dxaReserved2 field for the PICF record.
setDxaReserved3(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dxaReserved3 field for the PICF record.
setDxaRight(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dxaRight field for the PAP record.
setDxaRight(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dxaRight field for the SEP record.
setDxaRTEWrapWidth(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setDxaSpace(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Space following each character in the run expressed in twip units..
setDxaTab(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the dxaTab field for the DOP record.
setDxaWebView(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setDxaWidth(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dxaWidth field for the PAP record.
setDxcLeft(short) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Left indent in character units.
setDxcLeft1(short) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
First line indent in character units.
setDxcRight(short) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Right indent in character units.
setDxtCharSpace(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dxtCharSpace field for the SEP record.
setDy1(int) - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Sets offset within the parent coordinate space for the top left point.
setDy1(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The y offset within the top-left corner of the current shape.
setDy1(int) - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

setDy1(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Sets the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
setDy1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

setDy1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

setDy1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setDy2(int) - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
Sets the offset within the parent coordinate space for the bottom right point.
setDy2(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The y offset withing the cell for the bottom-right corner of this shape.
setDy2(int) - Method in class org.apache.poi.hssf.usermodel.HSSFAnchor

setDy2(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
setDy2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFAnchor

setDy2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFChildAnchor

setDy2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setDyaAbs(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dyaAbs field for the PAP record.
setDyaAbs(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Absolute vertical position.
setDyaAfter(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Space after paragraph.
setDyaBefore(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Space before paragraph.
setDyaBottom(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dyaBottom field for the SEP record.
setDyaFromText(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Vertical distance between text and absolutely positioned object.
setDyaFromText(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Top distance from surrounding text when absolutely positioned.
setDyaFromTextBottom(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Bottom distance from surrounding text when absolutely positioned.
setDyaGoal(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dyaGoal field for the PICF record.
setDyaHdrBottom(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dyaHdrBottom field for the SEP record.
setDyaHdrTop(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dyaHdrTop field for the SEP record.
setDyaHeight(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the dyaHeight field for the PAP record.
setDyaLine(short) - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

setDyaLinePitch(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dyaLinePitch field for the SEP record.
setDyaPgn(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dyaPgn field for the SEP record.
setDyaReserved1(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dyaReserved1 field for the PICF record.
setDyaReserved2(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dyaReserved2 field for the PICF record.
setDyaReserved3(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the dyaReserved3 field for the PICF record.
setDyaRowHeight(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high.
setDyaTop(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dyaTop field for the SEP record.
setDywDispPag(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the dywDispPag field for the DOP record.
setDzaGutter(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the dzaGutter field for the SEP record.
setEastAsia(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
Sets the default East Asia spelling language on ctStyles DocDefaults parameter
setEditTime(long) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the total time spent in editing the document.
setEdn(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the Edn field for the DOP record.
setEdn1(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the Edn1 field for the DOP record.
setElement(int, byte[]) - Method in class org.apache.poi.ddf.EscherArrayProperty

setEmbossed(boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is this text embossed?
setEmbossed(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setEmbossed(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setEmpty(byte) - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Set the empty field for the SheetProperties record.
setEmpty() - Method in class org.apache.poi.hssf.record.RowRecord
Updates the firstCol and lastCol fields to the reserved value (-1) to signify that this row is empty
setEmptyCellAllowed(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

setEmptyCellAllowed(boolean) - Method in interface org.apache.poi.ss.usermodel.DataValidation
Sets if this object allows empty as a valid value
setEmptyCellAllowed(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

setEnclosingCellRange(CellRangeAddress) - Method in class org.apache.poi.hssf.record.CFHeaderRecord

setEnd(int) - Method in class org.apache.poi.hwpf.model.PropertyNode

setEndChar(int) - Method in class org.apache.poi.xwpf.usermodel.TextSegement

setEndIndex(int) - Method in class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Sets the ending character position
setEndRun(int) - Method in class org.apache.poi.xwpf.usermodel.TextSegement

setEndText(int) - Method in class org.apache.poi.xwpf.usermodel.TextSegement

setEnforcementEditValue(STDocProtect.Enum) - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings
Enforces the protection with the option specified by passed editValue.

In the documentProtection tag inside settings.xml file
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to the passed editValue (w:edit="[passed editValue]")

sample snippet from settings.xml
setEngineId(int) - Method in class org.apache.poi.hssf.record.RecalcIdRecord

setEnvr(byte) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value MUST be 0, and MUST be ignored.
setEpc(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the epc field value.
setErrorStyle(int) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

setErrorStyle(int) - Method in interface org.apache.poi.ss.usermodel.DataValidation
Sets the error style for error box
setErrorStyle(int) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

setEscapementType(short) - Method in class org.apache.poi.hssf.record.cf.FontFormatting
set the escapement type for the font
setEscapementType(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
set the escapement type for the font
setEscapementType(short) - Method in interface org.apache.poi.ss.usermodel.FontFormatting
set the escapement type for the font
setEscapementType(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
set the escapement type for the font
setEscapementTypeModified(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setEscapementTypeModified(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setEscherProperty(EscherOptRecord, short, int) - Static method in class org.apache.poi.hslf.model.Shape
Set an escher property for this shape.
setEscherProperty(short, int) - Method in class org.apache.poi.hslf.model.Shape
Set an simple escher property for this shape.
setExcelStyleRoundingMode(DecimalFormat) - Static method in class org.apache.poi.ss.usermodel.DataFormatter
Enables excel style rounding mode (round half up) on the Decimal Format if possible.
setExcelStyleRoundingMode(DecimalFormat, RoundingMode) - Static method in class org.apache.poi.ss.usermodel.DataFormatter
Enables custom rounding mode on the Decimal Format if possible.
setExplicitListValues(String[]) - Method in class org.apache.poi.hssf.usermodel.DVConstraint

setExplicitListValues(String[]) - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint

setExplicitListValues(String[]) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

setExternSheetIndex(int) - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

setExternSheetIndex(int) - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

setExternsheetPos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList
Sets the externsheetPos.
setF97LidsSet(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the f97LidsSet field value.
setFAdjusted(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fAdjusted field value.
setFAdjustRight(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fAdjustRight field for the PAP record.
setFamily(byte) - Method in class org.apache.poi.hssf.record.FontRecord
set the font family (TODO)
setFamily(int) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
Set the font family this font belongs to.
setFamily(FontFamily) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set an enumeration representing the font family this font belongs to.
setFAnchorLock(boolean) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the fAnchorLock field value.
setFAutofit(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fAutofit field value.
setFAutoHyphen(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fAutoHyphen field value.
setFAutoNum(boolean) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Sets the fAutoNum field value.
setFAutoPgn(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Only for Macintosh compatibility, used only during open, when 1, sep.dxaPgn and sep.dyaPgn are valid page number locations.
setFAutoRedef(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fAutoRedef field value.
setFAutoSpaceDE(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
auto space East Asian and alphabetic characters.
setFAutoSpaceDN(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
auto space East Asian and numeric characters.
setFAutoVersions(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fAutoVersions field value.
setFBackup(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fBackup field value.
setFBackward(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Sets the fBackward field value.
setFBackward(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fBackward field value.
setFBelowText(boolean) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the fBelowText field value.
setFBestFit(boolean) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Sets the fBestFit field value.
setFBiDi(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fBiDi field value.
setFBiDi(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fBiDi field for the PAP record.
setFBiDi(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table is right-to-left.
setFBold(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fBold field value.
setFBoldBi(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fBoldBi field value.
setFBorders(boolean) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Sets the fBorders field value.
setFBorderWS(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used internally by Word.
setFBrLnAbove(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fBrLnAbove field for the PAP record.
setFBrLnBelow(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fBrLnBelow field for the PAP record.
setFc(int) - Method in class org.apache.poi.hwpf.model.SectionDescriptor

setFCantSplit(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table row may not be split across page bounds.
setFCantSplit90(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table row may not be split across page bounds.
setFCaps(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fCaps field value.
setFcClx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcData(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Points to location of picture data, only if chp.fSpec is true..
setFcDop(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFCellFitText(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fCellFitText field value.
setFCellSpacing(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fCellSpacing field value.
setFChsDiff(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fChsDiff field value.
setFcMac(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value is undefined and MUST be ignored.
setFcMin(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value is undefined and MUST be ignored.
setFcObj(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..
setFcObjp(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Offset in the data stream indicating the location of OLE object data.
setFCol(boolean) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Sets the fCol field value.
setFColor(boolean) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Sets the fColor field value.
setFComplex(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fComplex field value.
setFComplexScripts(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fComplexScripts field value.
setFConflictOrig(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When chp.wConflict!=0, this is TRUE when text is part of the original version of text.
setFConflictOtherDel(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.
setFConverted(boolean) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Sets the fConverted field value.
setFConvMailMergeEsc(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fConvMailMergeEsc field value.
setFCopyLang(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fCopyLang field value.
setFcPic(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..
setFcPlcfbkf(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcPlcfbkl(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcPlcfbteChpx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcPlcfbtePapx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcPlcffldAtn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setFcPlcffldEdn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setFcPlcffldFtn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setFcPlcffldHdr(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setFcPlcffldHdrtxbx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setFcPlcffldMom(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setFcPlcffldTxbx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setFcPlcfLst(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcPlcfsed(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcPlfLfo(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFCrLf(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fCrLf field for the PAP record.
setFcStshf(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcSttbfbkmk(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcSttbfffn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcSttbfRMark(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFcSttbSavedBy(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFData(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fData field value.
setFDblBdr(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used internally by Word.
setFDfltTrueType(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fDfltTrueType field value.
setFDiffer(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fDiffer field value.
setFDispFldRMark(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
the number for a ListNum field is being tracked in xstDispFldRMark.
setFDispFormFldSel(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fDispFormFldSel field value.
setFDot(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fDot field value.
setFDStrike(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fDStrike field value.
setFDyaAfterAuto(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Vertical spacing after is automatic.
setFDyaBeforeAuto(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Vertical spacing before is automatic.
setFEmbedFonts(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fEmbedFonts field value.
setFEmboss(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fEmboss field value.
setFEmptySpecial(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fEmptySpecial field value.
setFEncrypted(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fEncrypted field value.
setFEndNote(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the fEndNote field for the SEP record.
setFetchHyperlinks(boolean) - Method in class org.apache.poi.xwpf.extractor.XWPFWordExtractor
Should we also fetch the hyperlinks, when fetching the text content? Default is to only output the hyperlink label, and not the contents
setFEvenlySpaced(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the fEvenlySpaced field for the SEP record.
setFExactCWords(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fExactCWords field value.
setFExtChar(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fExtChar field value.
setFFacingPages(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fFacingPages field value.
setFFarEast(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fFarEast field value.
setFFirstMerged(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fFirstMerged field value.
setFFirstRow(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fFirstRow field value.
setFFitText(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fFitText field value.
setFFldVanish(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fFldVanish field value.
setFFont(boolean) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Sets the fFont field value.
setFForcePageSizePag(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fForcePageSizePag field value.
setFFormatting(boolean) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Sets the fFormatting field value.
setFFormNoFields(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fFormNoFields field value.
setFGlsy(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fGlsy field value.
setFGramAllClean(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fGramAllClean field value.
setFGramAllDone(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fGramAllDone field value.
setFHasOldProps(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used for character property revision marking.
setFHasOldProps(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Has old properties.
setFHasOriginalStyle(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Sets the fHasOriginalStyle field value.
setFHasOriginalStyle(boolean) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
Sets the fHasOriginalStyle field value.
setFHasPic(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fHasPic field value.
setFHasSep(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fHasSep field value.
setFHasUpe(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fHasUpe field value.
setFHaveVersions(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fHaveVersions field value.
setFHdr(boolean) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the fHdr field value.
setFHdrRows(boolean) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Sets the fHdrRows field value.
setFHidden(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fHidden field value.
setFHideLastVersion(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fHideLastVersion field value.
setFHighlight(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fHighlight field value.
setFHtmlBuiltInBullet(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlBuiltInBullet field value.
setFHtmlChecked(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlChecked field value.
setFHtmlDoc(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fHtmlDoc field value.
setFHtmlFirstLineMismatch(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlFirstLineMismatch field value.
setFHtmlHangingIndentBeneathNumber(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlHangingIndentBeneathNumber field value.
setFHtmlListTextNotSharpDot(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlListTextNotSharpDot field value.
setFHtmlNotPeriod(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlNotPeriod field value.
setFHtmlTabLeftIndentMismatch(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlTabLeftIndentMismatch field value.
setFHtmlUnsupported(boolean) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
Sets the fHtmlUnsupported field value.
setFHybrid(boolean) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Sets the fHybrid field value.
setFHyphCapitals(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fHyphCapitals field value.
setFieldOffset(int, int) - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

setFieldSize(int, int) - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

setFieldsPlcfLength(FieldsDocumentPart, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFieldsPlcfOffset(FieldsDocumentPart, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFile(String) - Method in class org.apache.poi.hssf.dev.EFBiffViewer

setFile(String) - Method in class org.apache.poi.hssf.dev.FormulaViewer
Method setFile
setFile(String) - Method in class org.apache.poi.hssf.dev.RecordLister

setFileIdClusters(EscherDggRecord.FileIdCluster[]) - Method in class org.apache.poi.ddf.EscherDggRecord

setFilePosition(int) - Method in class org.apache.poi.hwpf.model.PieceDescriptor

setFillBackground(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the background palette color index
setFillBackgroundColor(int) - Method in class org.apache.poi.hssf.record.cf.PatternFormatting
set the background fill color.
setFillBackgroundColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the background fill color.
setFillBackgroundColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

setFillBackgroundColor(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the background fill color.
setFillBackgroundColor(short) - Method in interface org.apache.poi.ss.usermodel.PatternFormatting

setFillBackgroundColor(int) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Set the background fill color represented as a indexed color value.
setFillBackgroundColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Set the background fill color represented as a XSSFColor value.
setFillBackgroundColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the background fill color represented as a XSSFColor value.
setFillBackgroundColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the background fill color represented as a indexed color value.
setFillBackgroundColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPatternFormatting

setFillColor(Color) - Method in class org.apache.poi.hslf.model.SimpleShape
The color used to fill this shape.
setFillColor(int) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
The color used to fill this shape.
setFillColor(int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
The color used to fill this shape.
setFillColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
Specifies a solid color fill.
setFillColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell
Specifies a solid color fill.
setFillColor(int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Sets the color used to fill this shape using the solid fill pattern.
setFillForeground(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the foreground palette color index
setFillForegroundColor(int) - Method in class org.apache.poi.hssf.record.cf.PatternFormatting
set the foreground fill color
setFillForegroundColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the foreground fill color Note: Ensure Foreground color is set prior to background color.
setFillForegroundColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

setFillForegroundColor(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the foreground fill color Note: Ensure Foreground color is set prior to background color.
setFillForegroundColor(short) - Method in interface org.apache.poi.ss.usermodel.PatternFormatting

setFillForegroundColor(int) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Set the foreground fill color as a indexed color value
setFillForegroundColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Set the foreground fill color represented as a XSSFColor value.
setFillForegroundColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the foreground fill color represented as a XSSFColor value.
setFillForegroundColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the foreground fill color as a indexed color value
Note: Ensure Foreground color is set prior to background color.
setFillForegroundColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPatternFormatting

setFillPaletteOptions(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the fill palette options bitmask (see
setFillPattern(int) - Method in class org.apache.poi.hssf.record.cf.PatternFormatting
setting fill pattern
setFillPattern(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
setting to one fills the cell with the foreground color...
setFillPattern(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

setFillPattern(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
setting to one fills the cell with the foreground color...
setFillPattern(short) - Method in interface org.apache.poi.ss.usermodel.PatternFormatting

setFillPattern(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
This element is used to specify cell fill information for pattern and solid color cell fills.
setFillPattern(FillPatternType) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
This element is used to specify cell fill information for pattern and solid color cell fills.
setFillPattern(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPatternFormatting

setFillsColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Fills Colour
setFillType(int) - Method in class org.apache.poi.hslf.model.Fill
Sets fill type.
setFilter(byte) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Filter should always be 0
setFImprint(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fImprint field value.
setFIncludeFooter(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fIncludeFooter field value.
setFIncludeHeader(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fIncludeHeader field value.
setFIndentSav(boolean) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Sets the fIndentSav field value.
setFInnerTableCell(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.
setFInTable(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Paragraph is in table flag.
setFinTableW97(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Archaic paragraph is in table flag.
setFInternalUse(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fInternalUse field value.
setFInvalAutofit(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fInvalAutofit field value.
setFInvalHeight(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fInvalHeight field value.
setFirstCol(short) - Method in class org.apache.poi.hssf.record.DimensionsRecord
set the first column number for the sheet
setFirstCol(int) - Method in class org.apache.poi.hssf.record.RowRecord
set the logical col number for the first cell this row (0 based index)
setFirstColRelative(boolean) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
set whether the first column is relative
setFirstColumn(int) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
set the first column this record defines formatting info for
setFirstColumn(int) - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Set the first column (zero-based)of the range that contains this hyperlink
setFirstColumn(int) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Set the column of the first cell that contains the hyperlink
setFirstColumn(int) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
set the first column in the area
setFirstColumn(int) - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Set the column of the first cell that contains the hyperlink
setFirstColumn(int) - Method in class org.apache.poi.ss.util.CellRangeAddressBase

setFirstColumn(int) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Set the column of the first cell that contains the hyperlink
setFirstColumnRaw(int) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
set the first column irrespective of the bitmasks
setFirstLineIndent(int) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setFirstLineIndent(int) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setFirstRow(int) - Method in class org.apache.poi.hssf.record.DimensionsRecord
set the first row number for the sheet
setFirstRow(int) - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Set the first row (zero-based)of the range that contains this hyperlink
setFirstRow(int) - Method in class org.apache.poi.hssf.record.IndexRecord

setFirstRow(int) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Set the row of the first cell that contains the hyperlink
setFirstRow(int) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
sets the first row
setFirstRow(int) - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Set the row of the first cell that contains the hyperlink
setFirstRow(int) - Method in class org.apache.poi.ss.util.CellRangeAddressBase

setFirstRow(int) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Set the row of the first cell that contains the hyperlink
setFirstRowRelative(boolean) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
sets the first row to relative or not
setFirstVisibleTab(int) - Method in class org.apache.poi.hssf.record.WindowOneRecord
Sets the first visible sheet in the worksheet tab-bar.
setFirstVisibleTab(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
sets the first tab that is displayed in the list of tabs in excel.
setFirstVisibleTab(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Sets the first tab that is displayed in the list of tabs in excel.
setFirstVisibleTab(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Sets the first tab that is displayed in the list of tabs in excel.
setFirstVisibleTab(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Sets the first tab that is displayed in the list of tabs in excel.
setFItalic(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fItalic field value.
setFItalicBi(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fItalicBi field value.
setFitHeight(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setFitHeight(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set the number of pages high to fit the sheet in
setFitHeight(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set the number of pages high to fit the sheet in
setFitHeight(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set the number of pages high to fit the sheet in
setFitToPage(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
fit to page option is on
setFitToPage(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
fit to page option is on
setFitToPage(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether the Fit to Page print option is enabled.
setFitToPage(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether the Fit to Page print option is enabled.
setFitToPage(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether the Fit to Page print option is enabled.
setFitWidth(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setFitWidth(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set the number of pages wide to fit the sheet in
setFitWidth(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set the number of pages wide to fit the sheet in
setFitWidth(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set the number of pages wide to fit the sheet in
setFKeep(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fKeep field for the PAP record.
setFKeepFollow(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fKeepFollow field for the PAP record.
setFKeepFollow(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fKeepFollow field value.
setFKinsoku(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
apply Kinsoku rules when performing line wrapping.
setFKumimoji(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fKumimoji field value.
setFLabelDoc(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fLabelDoc field value.
setFlag(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.
setFlag(int, boolean) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom

setFlag(int, boolean) - Method in class org.apache.poi.hslf.record.ExMediaAtom

setFlag(int, boolean) - Method in class org.apache.poi.hslf.record.HeadersFootersAtom

setFlag(boolean, int, boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun

setFlags(int) - Method in class org.apache.poi.ddf.EscherSpRecord
The flags that apply to this shape.
setFlags(byte) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Flags
setFlags(short) - Method in class org.apache.poi.hssf.record.NoteRecord
Options flag
setFlags(int) - Method in class org.apache.poi.hssf.record.TableRecord

setFlags(short) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Set the flags field for the FSPA record.
setFlags(int) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Set the flags field for the LFOLVLBase record.
setFlags(byte) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Set the flags field for the LSTF record.
setFlags1(short) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Set the flags1 field for the FibBase record.
setFlags2(byte) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Set the flags2 field for the FibBase record.
setFLastRow(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fLastRow field value.
setFLastRow(boolean) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Sets the fLastRow field value.
setFLayout(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the fLayout field for the SEP record.
setFLBetween(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the fLBetween field for the SEP record.
setFldVanish(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setFldVanish(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setFLegal(boolean) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Sets the fLegal field value.
setFLinkStyles(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fLinkStyles field value.
setFlipHorizontal(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

setFlipHorizontal(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

setFlipHorizontal(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFShape

setFlipHorizontal(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setFlipVertical(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

setFlipVertical(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

setFlipVertical(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Whether the shape is vertically flipped
setFlipVertical(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setFLoadOverride(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fLoadOverride field value.
setFLoadOverridePage(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fLoadOverridePage field value.
setFLockAtn(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fLockAtn field value.
setFLocked(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fLocked field value.
setFLocked(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Anchor of an absolutely positioned frame is locked.
setFLocked(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fLocked field value.
setFLockRev(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fLockRev field value.
setFLowerCase(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fLowerCase field value.
setFLSFitText(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fLSFitText field value.
setFlt(byte) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Field type when ch == 19 OR field flags when ch == 21 .
setFMac(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fMac field value.
setFMacChs(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fMacChs field value.
setFMapPrintTextColor(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fMapPrintTextColor field value.
setFMassCopy(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fMassCopy field value.
setFMerged(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fMerged field value.
setFMinFontSizePag(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fMinFontSizePag field value.
setFMinHeight(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Minimum height is exact or auto.
setFMirrorMargins(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fMirrorMargins field value.
setFMWSmallCaps(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fMWSmallCaps field value.
setFNested(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fNested field value.
setFNeverBeenAutofit(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fNeverBeenAutofit field value.
setFNoAllowOverlap(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
When 1, absolutely positioned paragraph cannot overlap with another paragraph.
setFNoAllowOverlap(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When set to 1, do not allow absolutely positioned table to overlap with other tables.
setFNoAutoHyph(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fNoAutoHyph field for the PAP record.
setFNoColumnBalance(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fNoColumnBalance field value.
setFNoHtmlExport(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fNoHtmlExport field value.
setFNoLeading(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fNoLeading field value.
setFNoLnn(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
No line numbering.
setFNoRestart(boolean) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Sets the fNoRestart field value.
setFNoSpaceRaiseLower(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fNoSpaceRaiseLower field value.
setFNoTabForInd(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fNoTabForInd field value.
setFNotPageView(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fNotPageView field value.
setFNoWrap(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fNoWrap field value.
setFNumRMIns(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fNumRMIns field for the PAP record.
setFObfuscated(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fObfuscated field value.
setFObj(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fObj field value.
setFOle2(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fOle2 field value.
setFollowMasterBackground(boolean) - Method in class org.apache.poi.hslf.model.Slide
Sets whether this slide follows master background
setFollowMasterBackground(boolean) - Method in class org.apache.poi.hslf.record.NotesAtom

setFollowMasterBackground(boolean) - Method in class org.apache.poi.hslf.record.SlideAtom

setFollowMasterBackground(boolean) - Method in interface org.apache.poi.sl.usermodel.Slide

setFollowMasterColourScheme(boolean) - Method in interface org.apache.poi.sl.usermodel.Slide

setFollowMasterGraphics(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFSlide

setFollowMasterObjects(boolean) - Method in class org.apache.poi.hslf.model.Slide
Sets whether this slide draws master sheet objects
setFollowMasterObjects(boolean) - Method in class org.apache.poi.hslf.record.NotesAtom

setFollowMasterObjects(boolean) - Method in class org.apache.poi.hslf.record.SlideAtom

setFollowMasterObjects(boolean) - Method in interface org.apache.poi.sl.usermodel.Slide

setFollowMasterScheme(boolean) - Method in class org.apache.poi.hslf.model.Slide
Sets whether this slide draws master color scheme
setFollowMasterScheme(boolean) - Method in class org.apache.poi.hslf.record.NotesAtom

setFollowMasterScheme(boolean) - Method in class org.apache.poi.hslf.record.SlideAtom

setFOnlyMacPics(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fOnlyMacPics field value.
setFOnlyWinPics(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fOnlyWinPics field value.
setFont(Font) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets this graphics context's font to the specified font.
setFont(Font) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setFont(Font) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

setFont(Font) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setFont(Font) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the font for this style
setFont(HSSFFont) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle

setFont(HSSFCell, HSSFWorkbook, HSSFFont) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
Take a cell, and apply a font to it
setFont(Font) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the font for this style
setFont(Cell, Workbook, Font) - Static method in class org.apache.poi.ss.util.CellUtil
Take a cell, and apply a font to it
setFont(Font) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the font for this style
setFontAlign(short) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Used internally by Word.
setFontAlignment(int) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setFontAlignment(int) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setFontCancellationModified(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setFontCancellationModified(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setFontColor(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets color of the text, as a int bgr.
setFontColor(Color) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets color of the text, as a java.awt.Color
setFontColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

setFontColorIndex(short) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setFontColorIndex(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setFontColorIndex(short) - Method in interface org.apache.poi.ss.usermodel.FontFormatting

setFontColorIndex(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting

setFontFamily(Element, String) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setFontFamily(String) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun
Specifies the typeface, or name of the font that is to be used for this text run.
setFontFamily(String, byte, byte, boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

setFontFamily(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies the fonts which shall be used to display the text contents of this run.
setFontFlags(int) - Method in class org.apache.poi.hslf.model.PPFont
set the font flags Bit 1: If set, font is subsetted
setFontFlags(int) - Method in class org.apache.poi.hslf.record.FontEntityAtom
set the font flags Bit 1: If set, font is subsetted
setFontFormatting(FontFormatting) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setFontHeight(int) - Method in class org.apache.poi.hssf.record.cf.FontFormatting
sets the height of the font in 1/20th point units
setFontHeight(short) - Method in class org.apache.poi.hssf.record.FontRecord
sets the height of the font in 1/20th point units
setFontHeight(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set the font height in unit's of 1/20th of a point.
setFontHeight(int) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setFontHeight(short) - Method in interface org.apache.poi.ss.usermodel.Font
set the font height in unit's of 1/20th of a point.
setFontHeight(int) - Method in interface org.apache.poi.ss.usermodel.FontFormatting
Sets the height of the font in 1/20th point units
setFontHeight(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the font height in points.
setFontHeight(double) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the font height in points.
setFontHeight(int) - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
Sets the height of the font in 1/20th point units
setFontHeightInPoints(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set the font height
setFontHeightInPoints(short) - Method in interface org.apache.poi.ss.usermodel.Font
set the font height
setFontHeightInPoints(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the font height in points.
setFontIndex(int) - Method in class org.apache.poi.hslf.record.FontEntityAtom

setFontIndex(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the font index
setFontIndex(short) - Method in class org.apache.poi.hssf.record.chart.FontIndexRecord
Set the font index field for the FontIndex record.
setFontIndex(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the index to the FONT record (which font to use 0 based)
setFontName(String) - Method in class org.apache.poi.hslf.model.PPFont
set the name for the font (i.e.
setFontName(String) - Method in class org.apache.poi.hslf.record.FontEntityAtom
Set the name of the font.
setFontName(String) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the font name to use
setFontName(String) - Method in class org.apache.poi.hssf.record.FontRecord
set the name of the font
setFontName(String) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set the name for the font (i.e.
setFontName(String) - Method in interface org.apache.poi.ss.usermodel.Font
set the name for the font (i.e.
setFontName(String) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the name for the font (i.e.
setFontOutlineModified(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setFontOutlineModified(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setFontpos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setFontReplacer(FontReplacer) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

setFontReplacer(FontReplacer) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

setFontShadowModified(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setFontShadowModified(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setFontSize(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the font size
setFontSize(Element, int) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setFontSize(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setFontSize(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setFontSize(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

setFontSize(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies the font size which shall be applied to all non complex script characters in the contents of this run when displayed.
setFontStyle(boolean, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
set font style options.
setFontStyle(boolean, boolean) - Method in interface org.apache.poi.ss.usermodel.FontFormatting
set font style options.
setFontStyle(boolean, boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
set font style options.
setFontStyleModified(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setFontStyleModified(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setFontType(int) - Method in class org.apache.poi.hslf.model.PPFont
set the font type
setFontType(int) - Method in class org.apache.poi.hslf.record.FontEntityAtom
set the font type
setFontWieghtModified(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setFooter(FooterRecord) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Sets the FooterRecord.
setFooterMargin(double) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setFooterMargin(double) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Sets the footer margin.
setFooterMargin(double) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Sets the footer margin.
setFooterMargin(double) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Sets the footer margin.
setFootersText(String) - Method in class org.apache.poi.hslf.model.HeadersFooters
Sets footers's text
setFooterVisible(boolean) - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the footer text is displayed.
setFootnoteInfo(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the footnoteInfo field for the DOP record.
setFootnotes(CTFootnotes) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes
Sets the ctFootnotes
setFOpenTch(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Ensure the Table Cell char doesn't show up as zero height.
setForceFormulaRecalculation(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.
setForceFormulaRecalculation(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Whether the application shall perform a full recalculation when the workbook is opened.
setForceFormulaRecalculation(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.
setForceFormulaRecalculation(boolean) - Method in interface org.apache.poi.ss.usermodel.Workbook
Whether the application shall perform a full recalculation when the workbook is opened.
setForceFormulaRecalculation(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Control if Excel should be asked to recalculate all formulas when the workbook is opened, via the "sheetCalcPr fullCalcOnLoad" option.
setForceFormulaRecalculation(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Whether the application shall perform a full recalculation when the workbook is opened.
setForceFormulaRecalculation(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.
setForceFormulaRecalculation(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Whether the application shall perform a full recalculation when the workbook is opened.
setForecolorIndex(short) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Set the forecolor index field for the AreaFormat record.
setForegroundColor(Color) - Method in class org.apache.poi.hslf.model.Fill
Foreground color
setForegroundColor(int) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Set the foreground color field for the AreaFormat record.
setFOrigWordTableRules(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fOrigWordTableRules field value.
setFOrigWordTableRules(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fOrigWordTableRules field value.
setFormat(int) - Method in class org.apache.poi.hpsf.MutablePropertySet
Sets the "format" property.
setFormat(int) - Method in class org.apache.poi.hpsf.SpecialPropertySet

setFormat(short) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Set the format field for the LineFormat record.
setFormatFlags(short) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Set the format flags field for the AreaFormat record.
setFormatFlags(short) - Method in class org.apache.poi.hssf.record.chart.AreaRecord
Set the format flags field for the Area record.
setFormatFlags(short) - Method in class org.apache.poi.hssf.record.chart.BarRecord
Set the format flags field for the Bar record.
setFormatFlags(short) - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Set the format flags field for the DataFormat record.
setFormatFlags(short) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Set the format flags field for the SeriesLabels record.
setFormatFlags(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the formatFlags field for the DOP record.
setFormatID(ClassID) - Method in class org.apache.poi.hpsf.MutableSection
Sets the section's format ID.
setFormatID(byte[]) - Method in class org.apache.poi.hpsf.MutableSection
Sets the section's format ID.
setFormatId(int) - Method in class org.apache.poi.hslf.record.HeadersFootersAtom
A signed integer that specifies the format ID to be used to style the datetime.
setFormatIndex(short) - Method in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord
Set the format index field for the NumberFormatIndex record.
setFormatIndex(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the index to the Format record (which FORMAT to use 0-based)
setFormatted(boolean) - Method in class org.apache.poi.hssf.record.RowRecord
set whether the row has been formatted (even if its got all blank cells)
setFormula1(String) - Method in class org.apache.poi.hssf.usermodel.DVConstraint

setFormula1(String) - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint
Sets a formula for expression 1.
setFormula1(String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

setFormula2(String) - Method in class org.apache.poi.hssf.usermodel.DVConstraint

setFormula2(String) - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint
Sets a formula for expression 2.
setFormula2(String) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

setFormulaOfLink(Ptg[]) - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Set the formula of link field for the LinkedData record.
setFormulasNotResults(boolean) - Method in class org.apache.poi.hssf.extractor.EventBasedExcelExtractor
Should we return the formula itself, and not the result it produces? Default is false
setFormulasNotResults(boolean) - Method in class org.apache.poi.hssf.extractor.ExcelExtractor
Should we return the formula itself, and not the result it produces? Default is false
setFormulasNotResults(boolean) - Method in interface org.apache.poi.ss.extractor.ExcelExtractor
Should we return the formula itself, and not the result it produces? Default is false
setFormulasNotResults(boolean) - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Should we return the formula itself, and not the result it produces? Default is false
setFormulasNotResults(boolean) - Method in class org.apache.poi.xssf.extractor.XSSFExcelExtractor
Should we return the formula itself, and not the result it produces? Default is false
setForwardDiagonalOn(boolean) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
Of/off bottom left to top right line
setForwardDiagonalOn(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setFOutline(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fOutline field value.
setFOutline(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fOutline field value.
setFOutlineDirtySave(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the fOutlineDirtySave field for the DOP record.
setFOverflowPunct(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
apply overflow punctuation rules when performing line wrapping.
setFPageBreakBefore(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fPageBreakBefore field for the PAP record.
setFPagHidden(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fPagHidden field value.
setFPagResults(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fPagResults field value.
setFPagSupressTopSpacing(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fPagSupressTopSpacing field value.
setFpc(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fpc field value.
setFPersonal(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fPersonal field value.
setFPersonalCompose(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fPersonalCompose field value.
setFPersonalReply(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fPersonalReply field value.
setFPgnRestart(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the fPgnRestart field for the SEP record.
setFPMHMainDoc(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fPMHMainDoc field value.
setFPrintBodyBeforeHdr(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fPrintBodyBeforeHdr field value.
setFPrintFormData(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fPrintFormData field value.
setFPrivateResult(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fPrivateResult field value.
setFPropMark(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the fPropMark field for the SEP record.
setFPropRMark(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
properties have been changed with revision marking on.
setFPropRMark(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fPropRMark field for the PAP record.
setFPropRMark(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set to 1 if property revision.
setFProtEnabled(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fProtEnabled field value.
setFPub(boolean) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Sets the fPub field value.
setFQFormat(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fQFormat field value.
setFrame(boolean) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

setFRcaSimple(boolean) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the fRcaSimple field value.
setFReadOnlyRecommended(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fReadOnlyRecommended field value.
setFreezePanes(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set whether the window should freeze panes
setFreezePanesNoSplit(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
freeze unsplit panes or not
setFReserved(byte) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the fReserved field for the PICF record.
setFReserved(byte) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fReserved field value.
setFReserved(short) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
Sets the fReserved field value.
setFResultDirty(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fResultDirty field value.
setFResultEdited(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fResultEdited field value.
setFRevMarking(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fRevMarking field value.
setFRMark(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fRMark field value.
setFRMarkDel(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fRMarkDel field value.
setFRMPrint(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fRMPrint field value.
setFRMView(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fRMView field value.
setFrom(CTMarker) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setFRotateFont(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Sets the fRotateFont field value.
setFRotateFont(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fRotateFont field value.
setFRotateFontW6(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fRotateFontW6 field value.
setFRTL(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Word 2000 style right-to-left table.
setFRuby(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fRuby field value.
setFSaveFormData(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fSaveFormData field value.
setFScratch(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fScratch field value.
setFSdtVanish(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Mark the character as hidden..
setFSemiHidden(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fSemiHidden field value.
setFShadeFormData(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fShadeFormData field value.
setFShading(boolean) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Sets the fShading field value.
setFShadow(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fShadow field value.
setFShowBreaksInFrames(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fShowBreaksInFrames field value.
setFSideBySide(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fSideBySide field for the PAP record.
setFSimpleList(boolean) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Sets the fSimpleList field value.
setFSmallCaps(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fSmallCaps field value.
setFSnapBorder(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fSnapBorder field value.
setFSPAPlcfLength(FSPADocumentPart, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFSPAPlcfOffset(FSPADocumentPart, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setFSpare(byte) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Sets the fSpare field value.
setFSpare(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Not used.
setFSpare0(byte) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fSpare0 field value.
setFSpec(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fSpec field value.
setFSpecSymbol(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Used by Word internally.
setFSpecVanish(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Special hidden for leading emphasis (always hidden).
setFStartAt(boolean) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Sets the fStartAt field value.
setFStrike(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fStrike field value.
setFSubsetFonts(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fSubsetFonts field value.
setFSuppressTopSPacingMac5(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fSuppressTopSPacingMac5 field value.
setFSupressSpdfAfterPageBreak(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fSupressSpdfAfterPageBreak field value.
setFSupressTopSpacing(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fSupressTopSpacing field value.
setFSwapBordersFacingPgs(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fSwapBordersFacingPgs field value.
setFTableHeader(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
When 1, table row is to be used as the header of the table.
setFtcAsci(short) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.
setFtcAscii(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for ASCII text.
setFtcAscii(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setFtcBi(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for Complex Scripts text.
setFtcFE(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for East Asian text.
setFtcFE(short) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.
setFtcFE(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setFtcOther(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font for non-East Asian text.
setFtcOther(short) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.
setFtcOther(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setFtcSym(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
an index into the rgffn structure.
setFTentative(boolean) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Sets the fTentative field value.
setFTitlePage(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set to 1 when a title page is to be displayed.
setFTNY(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fTNY field value.
setFTNYCompress(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fTNYCompress field value.
setFTNYFetchTxm(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fTNYFetchTxm field value.
setFTopLinePunct(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
perform top line punctuation processing.
setFTransparentMetafiles(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fTransparentMetafiles field value.
setFTruncDxaExpand(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fTruncDxaExpand field value.
setFtsCellPaddingBottom(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell margin/padding units.
setFtsCellPaddingDefaultBottom(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell margin/padding units.
setFtsCellPaddingDefaultLeft(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell margin/padding units.
setFtsCellPaddingDefaultRight(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell margin/padding units.
setFtsCellPaddingDefaultTop(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell margin/padding units.
setFtsCellPaddingLeft(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell margin/padding units.
setFtsCellPaddingOuterBottom(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell margin/padding units.
setFtsCellPaddingOuterLeft(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell margin/padding units.
setFtsCellPaddingOuterRight(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell margin/padding units.
setFtsCellPaddingOuterTop(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell margin/padding units.
setFtsCellPaddingRight(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell margin/padding units.
setFtsCellPaddingTop(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell margin/padding units.
setFtsCellSpacingBottom(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell spacing units.
setFtsCellSpacingDefaultBottom(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell spacings units.
setFtsCellSpacingDefaultLeft(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell spacings units.
setFtsCellSpacingDefaultRight(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell spacings units.
setFtsCellSpacingDefaultTop(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell spacings units.
setFtsCellSpacingLeft(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell spacing units.
setFtsCellSpacingOuterBottom(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell spacings units.
setFtsCellSpacingOuterLeft(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell spacings units.
setFtsCellSpacingOuterRight(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell spacings units.
setFtsCellSpacingOuterTop(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell spacings units.
setFtsCellSpacingRight(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell spacing units.
setFtsCellSpacingTop(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell spacing units.
setFtsWidth(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the ftsWidth field value.
setFtsWidth(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the ftsWidth field value.
setFtsWidthAfter(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the ftsWidthAfter field value.
setFtsWidthBefore(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the ftsWidthBefore field value.
setFtsWidthIndent(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the ftsWidthIndent field value.
setFTtp(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Table trailer paragraph (last in table row).
setFTtpEmbedded(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.
setFullPrecision(boolean) - Method in class org.apache.poi.hssf.record.PrecisionRecord
set whether to use full precision or just skew all you figures all to hell.
setFunction(boolean) - Method in class org.apache.poi.hssf.record.NameRecord
Indicates that the defined name refers to a user-defined function.
setFunction(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFName
Indicates that the defined name refers to a user-defined function.
setFunction(boolean) - Method in interface org.apache.poi.ss.usermodel.Name
Indicates that the defined name refers to a user-defined function.
setFunction(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFName
Indicates that the defined name refers to a user-defined function.
setFunctionGroupId(int) - Method in class org.apache.poi.xssf.usermodel.XSSFName
Specifies the function group index if the defined name refers to a function.
setFUndetermine(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Character is undetermined.
setFUnhideWhenUsed(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the fUnhideWhenUsed field value.
setFUnlocked(boolean) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the fUnlocked field for the SEP record.
setFUnused(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fUnused field value.
setFUsePgsuSettings(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fUsePgsuSettings field value.
setFUsePgsuSettings(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the fUsePgsuSettings field for the PAP record.
setFVanish(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fVanish field value.
setFVert(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fVert field value.
setFVertical(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Sets the fVertical field value.
setFVertical(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fVertical field value.
setFVertMerge(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fVertMerge field value.
setFVertRestart(boolean) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the fVertRestart field value.
setFVirusLoadSafe(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fVirusLoadSafe field value.
setFVirusPrompted(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fVirusPrompted field value.
setFWarichu(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fWarichu field value.
setFWarichuNoOpenBracket(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the fWarichuNoOpenBracket field value.
setFWCFtnEdn(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fWCFtnEdn field value.
setFWebView(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fWebView field value.
setFWhichTblStm(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fWhichTblStm field value.
setFWidowControl(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fWidowControl field value.
setFWidowControl(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.
setFWordWrap(boolean) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
perform word wrap.
setFWrapToWwd(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the fWrapToWwd field value.
setFWrapTrailSpaces(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the fWrapTrailSpaces field value.
setFWriteReservation(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the fWriteReservation field value.
setFZombieEmbed(boolean) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the fZombieEmbed field value.
setGapHalf(int) - Method in class org.apache.poi.hwpf.usermodel.TableRow

setGenerated(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the generated field value.
setGeometryType(int) - Method in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
Set the geometry type
setGraphicFrame(XSSFGraphicFrame) - Method in class org.apache.poi.xssf.usermodel.XSSFChart
Sets the parent graphic frame.
setGrbitFrt(short) - Method in class org.apache.poi.hssf.record.common.FtrHeader

setGrf(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field MUST be ignored.
setGrfDocEvents(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the grfDocEvents field for the DOP record.
setGrfhic(byte) - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType
HTML compatibility flags.
setGrfhic(Grfhic) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
HTML compatibility flags.
setGrfhic(short) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Sets the grfhic field value.
setGrfhic(Grfhic) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A grfhic that specifies the HTML incompatibilities of the list..
setGrfhic(Grfhic) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A grfhic that specifies the HTML incompatibilities of the level..
setGrfstd(short) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
A GRFSTD that specifies miscellaneous style properties.
setGrfSupression(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the grfSupression field value.
setGridset(boolean) - Method in class org.apache.poi.hssf.record.GridsetRecord
set whether gridlines are visible when printing
setGridsPrinted(boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
set whether gridlines printed or not.
setGridsPrinted(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set whether gridlines printed.
setGrpfChp(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Collection of the 32 flags.
setGrpfIhdt(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the grpfIhdt field for the SEP record.
setGrpfTap(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setGrpfTap_unused(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the grpfTap_unused field value.
setHCenter(boolean) - Method in class org.apache.poi.hssf.record.HCenterRecord
set whether or not to horizonatally center this sheet.
setHeader(HeaderRecord) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Sets the HeaderRecord.
setHeaderColor(int) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set the palette index for the header color
setHeaderFooter(CTHdrFtr) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
set a new headerFooter
setHeaderFooterText(String) - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

setHeaderFooterText(String) - Method in class org.apache.poi.hssf.usermodel.HSSFFooter

setHeaderFooterText(String) - Method in class org.apache.poi.hssf.usermodel.HSSFHeader

setHeaderMargin(double) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setHeaderMargin(double) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Sets the header margin.
setHeaderMargin(double) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Sets the header margin.
setHeaderMargin(double) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Sets the header margin.
setHeaderText(String) - Method in class org.apache.poi.hslf.model.HeadersFooters
Sets headers's text
setHeaderVisible(boolean) - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the header text is displayed.
setHeadingPair(byte[]) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the heading pair.
setHeight(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the height of the metafile in EMU's (English Metric Units).
setHeight(int) - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Set the height field for the AxisParent record.
setHeight(int) - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

setHeight(int) - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Set the height field for the Chart record.
setHeight(int) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the height field for the Text record.
setHeight(short) - Method in class org.apache.poi.hssf.record.RowRecord
set the height of the row
setHeight(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set teh height of the window
setHeight(short) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
set the row's height or set to ff (-1) for undefined/default-height.
setHeight(short) - Method in interface org.apache.poi.ss.usermodel.Row
Set the row's height or set to ff (-1) for undefined/default-height.
setHeight(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableRow

setHeight(short) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Set the row's height or set to ff (-1) for undefined/default-height.
setHeight(short) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Set the height in "twips" or 1/20th of a point.
setHeight(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
This element specifies the height of the current table row within the current table.
setHeightBasis(short) - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Set the height basis field for the FontBasis record.
setHeightInPoints(float) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
set the row's height in points.
setHeightInPoints(float) - Method in interface org.apache.poi.ss.usermodel.Row
Set the row's height in points.
setHeightInPoints(float) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Set the row's height in points.
setHeightInPoints(float) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Set the row's height in points.
setHeightMode(LayoutMode) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Specifies how to interpret the Height element for this manual layout.
setHeightMode(LayoutMode) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setHeightRatio(double) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Specifies the height (if Height Mode is Factor) or bottom (if Height Mode is edge) of the chart element as a fraction of the height of the chart.
setHeightRatio(double) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setHelpTopicText(String) - Method in class org.apache.poi.hssf.record.NameRecord
sets the help topic text
setHidden(boolean) - Method in class org.apache.poi.hssf.record.BoundSheetRecord
Is the sheet hidden? Different from very hidden
setHidden(boolean) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
set whether or not these cells are hidden
setHidden(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether the cell is hidden or not
setHidden(boolean) - Method in class org.apache.poi.hssf.record.NameRecord

setHidden(boolean) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set whether the window is hidden or not
setHidden(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the cell's using this style to be hidden
setHidden(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

setHidden(boolean) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the cell's using this style to be hidden
setHidden(boolean) - Method in interface org.apache.poi.ss.usermodel.Workbook

setHidden(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook

setHidden(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the cell's using this style to be hidden
setHidden(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook

setHiddenCount(int) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the hidden count.
setHideObj(short) - Method in class org.apache.poi.hssf.record.HideObjRecord
set hide object options
setHighlight(short) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the Highlight field for the CHP record.
setHighlighted(byte) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setHighlighted(byte) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setHistoryBitMask(int) - Method in class org.apache.poi.hssf.record.BOFRecord
set the history bit mask (not very useful)
setHorizontal(boolean) - Method in class org.apache.poi.hssf.record.chart.BarRecord
Sets the horizontal field value.
setHorizontal(HorizontalAlignment) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Set the type of horizontal alignment for the cell
setHorizontalAlignment(int) - Method in class org.apache.poi.hslf.model.TextShape
Sets the type of horizontal alignment for the text.
setHorizontalAlignment(byte) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the horizontal alignment field for the Text record.
setHorizontalAlignment(short) - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Sets the horizontal alignment.
setHorizontalBorder(boolean) - Method in class org.apache.poi.hssf.record.chart.DatRecord
Sets the horizontal border field value.
setHorizontalHold(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set the horizontal position of the window (in 1/20ths of a point)
setHorizontallyCenter(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
determines whether the output is horizontally centered on the page.
setHorizontallyCenter(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Determines whether the output is horizontally centered on the page.
setHorizontallyCenter(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Determines whether the output is horizontally centered on the page.
setHorizontallyCenter(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Center on page horizontally when printing.
setHorizontalPos(int) - Method in class org.apache.poi.hssf.record.DVALRecord

setHorizontalScale(int) - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord
Set the horizontalScale field for the PlotGrowth record.
setHorizontalTextAlignment(int) - Method in class org.apache.poi.hssf.record.TextObjectRecord
Sets the Horizontal text alignment field value.
setHps(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size in half points.
setHpsAsci(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size for ASCII font.
setHpsBi(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size for Complex Scripts text.
setHpsFE(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Font size for East Asian text.
setHpsKern(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Kerning distance for characters in run recorded in half points.
setHpsPos(short) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Reserved (actually used as vertical offset(?) value).
setHpsZoonFontPag(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the hpsZoonFontPag field for the DOP record.
setHres(byte) - Method in class org.apache.poi.hwpf.model.types.HRESIAbstractType
Hyphenation rule.
setHresi(Hyphenation) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the hresi field for the CHP record.
setHresiOld(Hyphenation) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the hresiOld field for the CHP record.
setHResolution(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setHResolution(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Sets the horizontal resolution.
setHResolution(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Sets the horizontal resolution.
setHResolution(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Sets the horizontal resolution.
setHyperlink(Hyperlink) - Method in class org.apache.poi.hslf.model.SimpleShape

setHyperlink(int, int, int) - Method in class org.apache.poi.hslf.model.TextShape
Assigns a hyperlink to this text shape
setHyperlink(Hyperlink) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Assign a hyperlink to this cell
setHyperlink(Hyperlink) - Method in interface org.apache.poi.sl.usermodel.SimpleShape

setHyperlink(Hyperlink) - Method in interface org.apache.poi.ss.usermodel.Cell
Assign a hyperlink to this cell
setHyperlink(Hyperlink) - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Assign a hyperlink to this cell
setHyperlink(Hyperlink) - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Assign a hypelrink to this cell
setHyperlinkID(int) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Sets the persistent unique identifier of the link
setHyperlinkId(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

setHyperlinksByDefault(boolean) - Method in class org.apache.poi.hpbf.extractor.PublisherTextExtractor
Should a call to getText() return hyperlinks inline with the text? Default is no
setHyperlinkType(byte) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
hyperlink type
setIbkl(short) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Index to BKL entry in plcfbkl that describes the ending position of this bookmark in the CP stream.
setIbstConflict(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Who made this change for this side of the conflict..
setIbstDispFldRMark(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
setIbstFltAutoNum(byte) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Used for AUTONUM field emulation.
setIbstPropRMark(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
setIbstPropRMark(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the ibstPropRMark field for the PAP record.
setIbstPropRMark(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the ibstPropRMark field for the SEP record.
setIbstRMark(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
setIbstRMarkDel(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to author IDs stored in hsttbfRMark.
setIco(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Color of text for Word 97.
setIco24(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties
Set the ico24 field for the CHP record.
setIco24(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Set the ico24 field for the CHP record.
setIcoBack(byte) - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Sets the icoBack field value.
setIcoFore(byte) - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Sets the icoFore field value.
setIcoHighlight(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the icoHighlight field value.
setIconic(boolean) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set whether the window has been iconized or not
setID(long) - Method in class org.apache.poi.hpsf.MutableProperty
Sets the property's ID.
setId(int) - Method in class org.apache.poi.hslf.model.Hyperlink

setId(int) - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord
Set the id field for the SeriesText record.
setId(Element, String) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

setId(long) - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Sets the frame id.
setIdct(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Not stored in file.
setIdctHint(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Identifier of Character type.
setIdentifier(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setIdentifierProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set identifier.
setIdentifierProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set an unambiguous reference to the resource within a given context.
setIdslReasonDel(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
setIdslRMReason(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
setIftcHtml(byte) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Sets the iftcHtml field value.
setIgnoreMissingWorkbooks(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Whether to ignore missing references to external workbooks and use cached formula results in the main workbook instead.
setIgnoreMissingWorkbooks(boolean) - Method in class org.apache.poi.ss.formula.WorkbookEvaluator
Whether to ignore missing references to external workbooks and use cached formula results in the main workbook instead.
setIGutterPos(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the iGutterPos field value.
setIHeadingPgn(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the iHeadingPgn field for the SEP record.
setIlfo(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
1-based index into the pllfo (lists structure), if non-zero.
setILvl(byte) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Sets the iLvl field value.
setIlvl(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
List level if non-zero.
setIlvlRestartLim(short) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart.
setImagePainter(int, ImagePainter) - Static method in class org.apache.poi.hslf.usermodel.PictureData
Register ImagePainter for the specified image type
setImprinted(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setImprinted(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setIncludeBlankCells(boolean) - Method in class org.apache.poi.hssf.extractor.ExcelExtractor
Should blank cells be output? Default is to only output cells that are present in the file and are non-blank.
setIncludeCellComments(boolean) - Method in class org.apache.poi.hssf.extractor.ExcelExtractor
Should cell comments be included? Default is false
setIncludeCellComments(boolean) - Method in interface org.apache.poi.ss.extractor.ExcelExtractor
Should cell comments be included? Default is false
setIncludeCellComments(boolean) - Method in class org.apache.poi.xssf.extractor.XSSFExcelExtractor
Should cell comments be included? Default is true
setIncludeHeadersFooters(boolean) - Method in class org.apache.poi.hssf.extractor.ExcelExtractor
Should headers and footers be included in the output? Default is to include them.
setIncludeHeadersFooters(boolean) - Method in class org.apache.poi.xssf.extractor.XSSFExcelExtractor
Should headers and footers be included? Default is true
setIncludeSheetNames(boolean) - Method in class org.apache.poi.hssf.extractor.EventBasedExcelExtractor
Should sheet names be included? Default is true
setIncludeSheetNames(boolean) - Method in class org.apache.poi.hssf.extractor.ExcelExtractor
Should sheet names be included? Default is true
setIncludeSheetNames(boolean) - Method in interface org.apache.poi.ss.extractor.ExcelExtractor
Should sheet names be included? Default is true
setIncludeSheetNames(boolean) - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
Should sheet names be included? Default is true
setIncludeSheetNames(boolean) - Method in class org.apache.poi.xssf.extractor.XSSFExcelExtractor
Should sheet names be included? Default is true
setIndent(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set indention (not sure of the units, think its spaces)
setIndent(Paragraph, Element) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setIndent(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Specifies the indent size that will be applied to the first line of text in the paragraph.
setIndent(long) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Set the number of spaces to indent the text in the cell
setIndentationFirstLine(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the additional indentation which shall be applied to the first line of the parent paragraph.
setIndentationHanging(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the indentation which shall be removed from the first line of the parent paragraph, by moving the indentation on the first line back towards the beginning of the direction of text flow.
setIndentationLeft(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the indentation which shall be placed between the left text margin for this paragraph and the left edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph
If this attribute is omitted, its value shall be assumed to be zero.
setIndentationRight(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the indentation which shall be placed between the right text margin for this paragraph and the right edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph
If this attribute is omitted, its value shall be assumed to be zero.
setIndentFromLeft(int) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setIndentFromLeft(int) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setIndentFromRight(int) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setIndentFromRight(int) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setIndention(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the number of spaces to indent the text in the cell
setIndention(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the number of spaces to indent the text in the cell
setIndention(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the number of spaces to indent the text in the cell
setIndentionOptions(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the indent options bitmask (see corresponding bitmask setters that reference this field)
setIndentLevel(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets indentation level
setIndentNotParentAlignment(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether or not to use the alignment in this XF instead of the parent XF.
setIndentNotParentBorder(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether or not to use the border in this XF instead of the parent XF.
setIndentNotParentCellOptions(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether or not to use the locking/hidden in this XF instead of the parent XF.
setIndentNotParentFont(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether or not to use the font in this XF instead of the parent XF.
setIndentNotParentFormat(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether or not to use the format in this XF instead of the parent XF.
setIndentNotParentPattern(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
Sets whether or not to use the pattern in this XF instead of the parent XF (foreground/background).
setIndex(int) - Method in class org.apache.poi.hslf.model.TextRun

setIndex(short) - Method in class org.apache.poi.hssf.record.chart.SeriesIndexRecord
Set the index field for the SeriesIndex record.
setIndex(int) - Method in class org.apache.poi.poifs.property.Property
Set the index for this Property
setIndexed(int) - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Indexed ctColor value.
setIndexNumberFmtRecord(short) - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Set the index number fmt record field for the LinkedData record.
setIndexOfColorValue(short) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the index of color value field for the Text record.
setIndexToFontTable(short) - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Set the index to font table field for the FontBasis record.
setInfo(byte) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Set the info field for the LVLF record.
setInfo1(short) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Set the info1 field for the StdfBase record.
setInfo1(short) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Set the info1 field for the StdfPost2000 record.
setInfo2(short) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Set the info2 field for the StdfBase record.
setInfo3(short) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Set the info3 field for the StdfBase record.
setInfo3(short) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Set the info3 field for the StdfPost2000 record.
setInfo3(int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
Set the info3 field for the Stshif record.
setInsideBorders(Line) - Method in class org.apache.poi.hslf.model.Table
Format the inside border using the specified Line object
setInsideHBorder(XWPFTable.XWPFBorderType, int, int, String) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

setInsideVBorder(XWPFTable.XWPFBorderType, int, int, String) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

setInstance(short) - Method in class org.apache.poi.ddf.EscherRecord
Sets the instance part of record
setInstance(int) - Method in class org.apache.poi.hslf.record.SlideListWithText

setInteriorAnchor(Rectangle2D) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

setInternalFlags(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setInvert(boolean) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Sets the invert field value.
setIpat(byte) - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Sets the ipat field value.
setIpat(int) - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType
Shading pattern.
setIpgp(long) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
HTML DIV ID for this paragraph.
setIPriority(short) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Sets the iPriority field value.
setIsDate(boolean) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Sets the isDate field value.
setIss(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Superscript/subscript indices.
setIStartAt(int) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL.
setIStartAt(int) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
A signed integer that specifies the beginning number for the number sequence belonging to this level.
setIstd(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Index to character style descriptor in the stylesheet that tags this run of text.
setIstd(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Index to style descriptor.
setIstd(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Table style for the Table.
setIstdBase(short) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the istdBase field value.
setIstdLink(short) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Sets the istdLink field value.
setIstdMaxFixedWhenSaved(int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles.
setIstdNext(short) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the istdNext field value.
setItalic(boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is the text italic?
setItalic(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting
set the font to be italics or not
setItalic(boolean) - Method in class org.apache.poi.hssf.record.FontRecord
set the font to be italics or not
setItalic(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set whether to use italics or not
setItalic(Element, boolean) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setItalic(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setItalic(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setItalic(boolean) - Method in interface org.apache.poi.ss.usermodel.Font
set whether to use italics or not
setItalic(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

setItalic(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set a boolean value for the property specifying whether to use italics or not If omitted, the default value is true.
setItalic(boolean) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document

This formatting property is a toggle property, which specifies that its behavior differs between its use within a style definition and its use as direct formatting.
setItap(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Table nesting level.
setItbdMac(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Number of tabs stops defined for paragraph.
setItcFirst(byte) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Sets the itcFirst field value.
setItcLim(byte) - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType
Sets the itcLim field value.
setItcMac(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Count of cells defined for this row.
setIteration(boolean) - Method in class org.apache.poi.hssf.record.IterationRecord
set whether or not to iterate for calculations
setIterations(short) - Method in class org.apache.poi.hssf.record.CalcCountRecord
set the number of iterations to perform
setItl(short) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Set the itl field for the TLP record.
setItypFELayout(short) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the itypFELayout field value.
setIWarichuBracket(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the iWarichuBracket field value.
setIx(short) - Method in class org.apache.poi.hssf.record.ExternalNameRecord

setIxchFollow(byte) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An unsigned integer that specifies the character that follows the number text.
setJc(byte) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Sets the jc field value.
setJc(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the jc field for the PAP record.
setJc(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Justification code.
setJc(byte) - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Sets the jc field value.
setJump(byte) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Jump
setJustification(Paragraph, Element) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setJustification(byte) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setJustification(byte) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setJustificationLogical(byte) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setJustifyLast(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
Dunno.
setKcd(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Emphasis mark.
setKeepOnPage(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setKeepOnPage(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setKeepWithNext(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setKeepWithNext(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setKerning(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setKerning(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setKeyboardShortcut(byte) - Method in class org.apache.poi.hssf.record.NameRecord
sets the keyboard shortcut
setKeyVirusSession30(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the KeyVirusSession30 field value.
setKeywords(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the keywords.
setKeywords(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setKeywords(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setKeywordsProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set keywords.
setKeywordsProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set a delimited set of keywords to support searching and indexing.
setKinsoku(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setKinsoku(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setKul(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Underline code.
setLabel(String) - Method in interface org.apache.poi.common.usermodel.Hyperlink
Sets text label for this hyperlink
setLabel(String) - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Sets text label for this hyperlink
setLabel(String) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Sets text label for this hyperlink
setLabel(String) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Sets text label for this hyperlink
setLabelAsPercentage(boolean) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Sets the label as percentage field value.
setLabelColorRgb(int) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the label color rgb field for the Tick record.
setLabelFrequency(short) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Set the label frequency field for the CategorySeriesAxis record.
setLabelPosition(byte) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the label position field for the Tick record.
setLandscape(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setLandscape(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set whether to print in landscape
setLandscape(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set whether to print in landscape
setLandscape(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set whether to print in landscape
setLanguage(CharacterRun, Element) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setLanguageProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set language.
setLanguageProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the language of the intellectual content of the resource.
setLastAuthor(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the last author.
setLastCol(short) - Method in class org.apache.poi.hssf.record.DimensionsRecord
set the last col number for the sheet
setLastCol(int) - Method in class org.apache.poi.hssf.record.RowRecord

setLastColRelative(boolean) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
set whether the last column should be relative or not
setLastColumn(int) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
set the last column this record defines formatting info for
setLastColumn(int) - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Set the last column (zero-based)of the range that contains this hyperlink
setLastColumn(int) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Set the column of the last cell that contains the hyperlink
setLastColumn(int) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
set the last column in the area
setLastColumn(int) - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Set the column of the last cell that contains the hyperlink
setLastColumn(int) - Method in class org.apache.poi.ss.util.CellRangeAddressBase

setLastColumn(int) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Set the column of the last cell that contains the hyperlink
setLastColumnRaw(short) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
set the last column irrespective of the bitmasks
setLastEditUsername(String) - Method in class org.apache.poi.hslf.record.CurrentUserAtom

setLastModifiedByProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set last modifications author.
setLastModifiedByProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the user who performed the last modification.
setLastMSOSPID(int) - Method in class org.apache.poi.ddf.EscherDgRecord
The last shape id used in this drawing group.
setLastOnDiskOffset(int) - Method in class org.apache.poi.hslf.record.ExOleObjStg
Update the Record's idea of where on disk it lives, after a write out.
setLastOnDiskOffset(int) - Method in interface org.apache.poi.hslf.record.PositionDependentRecord
Update the Record's idea of where on disk it lives, after a write out.
setLastOnDiskOffset(int) - Method in class org.apache.poi.hslf.record.PositionDependentRecordAtom
Update the Record's idea of where on disk it lives, after a write out.
setLastOnDiskOffset(int) - Method in class org.apache.poi.hslf.record.PositionDependentRecordContainer
Update the Record's idea of where on disk it lives, after a write out.
setLastPrinted(Date) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the lastPrinted.
setLastPrinted(Nullable<Date>) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setLastPrinted(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setLastPrintedProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set last printed date.
setLastPrintedProperty(Nullable<Date>) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set last printed date.
setLastPrintedProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the date and time of the last printing.
setLastPrintedProperty(Nullable<Date>) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the date and time of the last printing.
setLastRow(int) - Method in class org.apache.poi.hssf.record.DimensionsRecord
set the last row number for the sheet
setLastRow(int) - Method in class org.apache.poi.hssf.record.HyperlinkRecord
Set the last row (zero-based)of the range that contains this hyperlink
setLastRow(int) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Set the row of the last cell that contains the hyperlink
setLastRow(int) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

setLastRow(int) - Method in interface org.apache.poi.ss.usermodel.Hyperlink
Set the row of the last cell that contains the hyperlink
setLastRow(int) - Method in class org.apache.poi.ss.util.CellRangeAddressBase

setLastRow(int) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Set the row of the last cell that contains the hyperlink
setLastRowAdd1(int) - Method in class org.apache.poi.hssf.record.IndexRecord

setLastRowRelative(boolean) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase
set whether the last row is relative or not
setLastSaveDateTime(Date) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the total time spent in editing the document.
setLastUserEditAtomOffset(int) - Method in class org.apache.poi.hslf.record.UserEditAtom

setLastViewType(short) - Method in class org.apache.poi.hslf.record.UserEditAtom

setLbrCRJ(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Line BReak code for xchCRJ.
setLcb(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.
setLcbClx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbDop(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbPlcfbkf(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbPlcfbkl(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbPlcfbteChpx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbPlcfbtePapx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbPlcffldAtn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setLcbPlcffldEdn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setLcbPlcffldFtn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setLcbPlcffldHdr(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setLcbPlcffldHdrtxbx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setLcbPlcffldMom(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setLcbPlcffldTxbx(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock
Deprecated.
setLcbPlcfLst(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbPlcfsed(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbPlfLfo(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbStshf(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbSttbfbkmk(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbSttbfffn(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbSttbfRMark(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLcbSttbSavedBy(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setLeft(String) - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

setLeft(String) - Method in interface org.apache.poi.ss.usermodel.Footer
Sets the left string.
setLeft(String) - Method in interface org.apache.poi.ss.usermodel.Header
Sets the left string.
setLeft(String) - Method in interface org.apache.poi.ss.usermodel.HeaderFooter
Sets the left string.
setLeft(String) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
set a left string value for this element
setLeftBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setLeftBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setLeftBorderColor(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the color to use for the left border
setLeftBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setLeftBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the color to use for the left border
setLeftBorderColor(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setLeftBorderColor(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the leftBorderColor attribute of the HSSFRegionUtil object
setLeftBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

setLeftBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the color to use for the left border
setLeftBorderColor(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the leftBorderColor attribute of the RegionUtil object
setLeftBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setLeftBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the left border as a indexed color value
setLeftBorderColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the left border as a XSSFColor value
setLeftBorderModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setLeftBorderPaletteIdx(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the palette index for the left border color
setLeftCol(short) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets the left column to show in desktop window pane.
setLeftCol(short) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set the leftmost column displayed in the window
setLeftColumn(short) - Method in class org.apache.poi.hssf.record.PaneRecord
Set the left column field for the Pane record.
setLeftInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setLeftInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Sets the left margin.
setLeftMargin(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Specifies the left margin of the paragraph.
setLeftRowGutter(short) - Method in class org.apache.poi.hssf.record.GutsRecord
set the size of the gutter that appears at the left of the rows
setLeftSection(String, String) - Method in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

setLeftToRight(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setLeftToRight(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set whether to go left to right or top down in ordering
setLeftToRight(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set whether to go left to right or top down in ordering
setLeftToRight(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set whether to go left to right or top down in ordering
setLevel(int, ListLevel) - Method in class org.apache.poi.hwpf.model.ListData

setLevel(int) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Specifies the particular level text properties that this paragraph will follow.
setLevelNumberProperties(int, CharacterProperties) - Method in class org.apache.poi.hwpf.usermodel.HWPFList
Sets the character properties of the list numbers.
setLevelParagraphProperties(int, ParagraphProperties) - Method in class org.apache.poi.hwpf.usermodel.HWPFList
Sets the paragraph properties for a particular level of the list.
setLevelProperties(byte[]) - Method in class org.apache.poi.hwpf.model.ListLevel

setLevelStyle(int, int) - Method in class org.apache.poi.hwpf.model.ListData

setLevelStyle(int, int) - Method in class org.apache.poi.hwpf.usermodel.HWPFList

setLid(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
A LID that specifies the install language of the application that is producing the document.
setLidDefault(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the lidDefault field for the CHP record.
setLidFE(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the lidFE field for the CHP record.
setLidFE(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
A LID whose meaning depends on the nFib value.
setLineCap(LineCap) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setLineColor(Color) - Method in class org.apache.poi.hslf.model.SimpleShape
Sets the color of line
setLineColor(int) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Set the line color field for the LineFormat record.
setLineColor(Color) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setLineCount(int) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the line count.
setLineDash(LineDash) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setLineDashing(int) - Method in class org.apache.poi.hslf.model.SimpleShape
Sets line dashing.
setLineHeadDecoration(LineDecoration) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
Specifies the line end decoration, such as a triangle or arrowhead.
setLineHeadLength(LineEndLength) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
Specifies the line end width in relation to the line width.
setLineHeadWidth(LineEndWidth) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
specifies decorations which can be added to the head of a line.
setLineNotNumbered(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setLineNotNumbered(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setLinePattern(short) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Set the line pattern field for the LineFormat record.
setLineSpacing(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the line spacing.
setLineSpacing(LineSpacingDescriptor) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setLineSpacing(LineSpacingDescriptor) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setLineSpacing(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
This element specifies the vertical line spacing that is to be used within a paragraph.
setLineStyle(int) - Method in class org.apache.poi.hslf.model.SimpleShape
Sets line style.
setLineStyle(int) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
Sets the line style.
setLineStyle(int) - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Sets the line style.
setLineStyleColor(int) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
The color applied to the lines of this shape.
setLineStyleColor(int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
The color applied to the lines of this shape.
setLineStyleColor(int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFShape
The color applied to the lines of this shape.
setLineTailDecoration(LineDecoration) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
Specifies the line end decoration, such as a triangle or arrowhead.
setLineTailLength(LineEndLength) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
Specifies the line end width in relation to the line width.
setLineTailWidth(LineEndWidth) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape
specifies decorations which can be added to the tail of a line.
setLineWidth(double) - Method in class org.apache.poi.hslf.model.SimpleShape
Sets the width of line in in points
setLineWidth(int) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
Sets the width of the line.
setLineWidth(int) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

setLineWidth(double) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setLineWidth(double) - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Specifies the width to be used for the underline stroke.
setLink1(short) - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord
Set the link 1 field for the ObjectLink record.
setLink2(short) - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord
Set the link 2 field for the ObjectLink record.
setLinksDirty(boolean) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the linksDirty.
setLinkTitle(String) - Method in class org.apache.poi.hslf.record.ExHyperlink

setLinkType(byte) - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Set the link type field for the LinkedData record.
setLinkURL(String) - Method in class org.apache.poi.hslf.record.ExHyperlink
Sets the URL of the link TODO: Figure out if we should always set both
setList(boolean) - Method in class org.apache.poi.hssf.dev.FormulaViewer

setLKey(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier.
setLKeyProtDoc(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the lKeyProtDoc field for the DOP record.
setLnc(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the lnc field for the SEP record.
setLnnMin(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the lnnMin field for the SEP record.
setLocale(Locale) - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

setLocale(Locale) - Method in class org.apache.poi.xssf.extractor.XSSFExcelExtractor
What Locale should be used for formatting numbers (based on the styles applied to the cells)
setLocation(String) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink
Location within target.
setLocked(boolean) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Sets the locked field value.
setLocked(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether the cell is locked or not
setLocked(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the cell's using this style to be locked
setLocked(boolean) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the cell's using this style to be locked
setLocked(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the cell's using this style to be locked
setLogarithmicScale(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the logarithmic scale field value.
setLogBase(double) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

setLogBase(double) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

setLogUnsupportedTypes(boolean) - Static method in class org.apache.poi.hpsf.VariantSupport
Specifies whether warnings about unsupported variant types are to be written to System.err or not.
setLsid(int) - Method in class org.apache.poi.hwpf.model.ListFormatOverride

setLsid(int) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
List ID of corresponding LSTF (see LSTF).
setLsid(int) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A signed integer that specifies the list identifier.
setLspd(LineSpacingDescriptor) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Line spacing descriptor.
setLTagObj(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..
setLvl(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the lvl field value.
setLvl(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Outline level.
setMacoutline(boolean) - Method in class org.apache.poi.hssf.record.FontRecord
whether to use the mac outline font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
setMacro(String) - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Sets the frame macro.
setMacshadow(boolean) - Method in class org.apache.poi.hssf.record.FontRecord
whether to use the mac shado font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
setMajorIncrement(double) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Set the major increment field for the ValueRange record.
setMajorTickType(byte) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the major tick type field for the Tick record.
setMajorUnit(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the major unit field for the AxisOptions record.
setMajorUnitValue(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the major unit value field for the AxisOptions record.
setManager(String) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the manager.
setMargin(short, double) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Sets the size of the margin in inches.
setMargin(double) - Method in class org.apache.poi.hssf.record.BottomMarginRecord
Set the margin field for the BottomMargin record.
setMargin(double) - Method in class org.apache.poi.hssf.record.LeftMarginRecord
Set the margin field for the LeftMargin record.
setMargin(double) - Method in interface org.apache.poi.hssf.record.Margin
Set the margin field for the Margin.
setMargin(double) - Method in class org.apache.poi.hssf.record.RightMarginRecord
Set the margin field for the RightMargin record.
setMargin(double) - Method in class org.apache.poi.hssf.record.TopMarginRecord
Set the margin field for the TopMargin record.
setMargin(short, double) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets the size of the margin in inches.
setMargin(short, double) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets the size of the margin in inches.
setMargin(short, double) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets the size of the margin in inches.
setMargin(short, double) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets the size of the margin in inches.
setMarginBottom(float) - Method in class org.apache.poi.hslf.model.TextShape
Sets the botom margin.
setMarginBottom(int) - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Sets the bottom margin within the textbox.
setMarginBottom(int) - Method in interface org.apache.poi.ss.usermodel.Textbox
Sets the bottom margin within the textbox.
setMarginLeft(float) - Method in class org.apache.poi.hslf.model.TextShape
Sets the left margin.
setMarginLeft(int) - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Sets the left margin within the textbox.
setMarginLeft(int) - Method in interface org.apache.poi.ss.usermodel.Textbox
Sets the left margin within the textbox.
setMarginRight(float) - Method in class org.apache.poi.hslf.model.TextShape
Sets the right margin.
setMarginRight(int) - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Sets the right margin within the textbox.
setMarginRight(int) - Method in interface org.apache.poi.ss.usermodel.Textbox
Sets the right margin within the textbox.
setMarginTop(float) - Method in class org.apache.poi.hslf.model.TextShape
Sets the top margin.
setMarginTop(int) - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Sets the top margin within the textbox.
setMarginTop(int) - Method in interface org.apache.poi.ss.usermodel.Textbox
Sets the top margin within the textbox.
setMarker(byte) - Method in class org.apache.poi.ddf.EscherBitmapBlip

setMask(int) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A bit mask specifying options for displaying video
setMask(int) - Method in class org.apache.poi.hslf.record.ExMediaAtom
A bit mask specifying options for displaying video
setMask(int) - Method in class org.apache.poi.hslf.record.HeadersFootersAtom
A bit mask specifying options for displaying headers and footers
setMasterByDefault(boolean) - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Should a call to getText() return text from master? Default is no
setMasterByDefault(boolean) - Method in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor
Should a call to getText() return text from master? Default is no
setMasterID(int) - Method in class org.apache.poi.hslf.record.SlideAtom
Change slide master.
setMasterSheet(MasterSheet) - Method in class org.apache.poi.hslf.model.Slide
Change Master of this slide.
setMaxDrawingGroupId(int) - Method in class org.apache.poi.ddf.EscherDggRecord

setMaximum(double) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

setMaximum(double) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

setMaximumAxisValue(double) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Set the maximum axis value field for the ValueRange record.
setMaximumCategory(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the maximum category field for the AxisOptions record.
setMaxPersistWritten(int) - Method in class org.apache.poi.hslf.record.UserEditAtom

setMenuName(String) - Method in class org.apache.poi.hslf.record.ExEmbed

setMergeCells(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether to merge cells
setMinimum(double) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

setMinimum(double) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

setMinimumAxisValue(double) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Set the minimum axis value field for the ValueRange record.
setMinimumCategory(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the minimum category field for the AxisOptions record.
setMinorIncrement(double) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Set the minor increment field for the ValueRange record.
setMinorTickType(byte) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the minor tick type field for the Tick record.
setMinorUnit(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the minor unit field for the AxisOptions record.
setMinorUnitValue(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the minor unit value field for the AxisOptions record.
setMissingCellPolicy(Row.MissingCellPolicy) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Sets the policy on what to do when getting missing or blank cells from a row.
setMissingCellPolicy(Row.MissingCellPolicy) - Method in interface org.apache.poi.ss.usermodel.Workbook
Sets the policy on what to do when getting missing or blank cells from a row.
setMissingCellPolicy(Row.MissingCellPolicy) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Sets the policy on what to do when getting missing or blank cells from a row.
setMissingCellPolicy(Row.MissingCellPolicy) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Sets the policy on what to do when getting missing or blank cells from a row.
setMm(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
A signed integer that specifies the format of the picture data.
setMMClipCount(int) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the mmclip count.
setMmPM(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field MUST be ignored.
setMode(short) - Method in class org.apache.poi.hssf.record.RefModeRecord
set the reference mode to use (HSSF uses/assumes A1)
setModified(Nullable<Date>) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setModified(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setModifiedHigh(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setModifiedLow(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setModifiedProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set last modification date.
setModifiedProperty(Nullable<Date>) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set last modification date.
setModifiedProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the date on which the resource was changed.
setModifiedProperty(Nullable<Date>) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the date on which the resource was changed.
setMovieIndex(int) - Method in class org.apache.poi.hslf.model.MovieShape
Assign a movie to this shape
setMultiLinespace(short) - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

setMx(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the mx field for the PICF record.
setMy(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
Set the my field for the PICF record.
setName(byte) - Method in class org.apache.poi.ddf.EscherBSERecord
The length in characters of the blip name.
setName(String) - Method in class org.apache.poi.hpsf.CustomProperty
Sets the property's name.
setName(String) - Method in class org.apache.poi.hssf.record.StyleRecord
set the style's name
setName(int, String) - Method in class org.apache.poi.hwpf.model.BookmarksTables

setName(String) - Method in interface org.apache.poi.hwpf.usermodel.Bookmark

setName(String) - Method in class org.apache.poi.poifs.property.Property
Set the name; silently truncates the name if it's too long.
setName(String) - Method in class org.apache.poi.xslf.usermodel.XSLFTheme
Set name of this theme
setName(String) - Method in class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Sets the frame name.
setName(String) - Method in class org.apache.poi.xssf.usermodel.XSSFTable
Changes the name of the Table
setNameDefinition(Ptg[]) - Method in class org.apache.poi.hssf.record.NameRecord

setNameName(String) - Method in class org.apache.poi.hssf.usermodel.HSSFName
Sets the name of the named range
setNameName(String) - Method in interface org.apache.poi.ss.usermodel.Name
Sets the name of the named range
setNameName(String) - Method in class org.apache.poi.xssf.usermodel.XSSFName
Sets the name that will appear in the user interface for the defined name.
setNamepos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList
Sets the namepos.
setNameText(String) - Method in class org.apache.poi.hssf.record.NameCommentRecord
Updates the name we're associated with, normally used when renaming that Name
setNameText(String) - Method in class org.apache.poi.hssf.record.NameRecord
sets the name of the named range
setNAuto(short) - Method in class org.apache.poi.hwpf.model.types.FRDAbstractType
If > 0, the note is an automatically numbered note, otherwise it has a custom mark.
setNEdn(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the nEdn field value.
setNeedRecalculation(boolean) - Method in class org.apache.poi.hssf.record.CFHeaderRecord

setNextBlock(int, int) - Method in class org.apache.poi.poifs.filesystem.BlockStore
Changes the record of what block follows the specified one.
setNextBlock(int, int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Changes the record of what block follows the specified one.
setNextBlock(int, int) - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore
Changes the record of what block follows the specified one.
setNextChild(Child) - Method in interface org.apache.poi.poifs.property.Child
Set the next Child
setNextChild(Child) - Method in interface org.apache.poi.poifs.property.Parent
Set the next Child
setNextChild(Child) - Method in class org.apache.poi.poifs.property.Property
Set the next Child
setNfc(byte) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list.
setNfcEdnRef(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the nfcEdnRef field for the DOP record.
setNfcEdnRef1(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the nfcEdnRef1 field value.
setNfcFtnRef(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the nfcFtnRef field for the DOP record.
setNfcFtnRef1(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the nfcFtnRef1 field value.
setNfcPgn(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Page number format code.
setNFib(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
An unsigned integer that specifies the version number of the file format used.
setNFibBack(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value SHOULD be 0x00BF.
setNFtn(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the nFtn field value.
setNLnnMod(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the nLnnMod field for the SEP record.
setNoColor(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setNoColor(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set whether it is black and white
setNoColor(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set whether it is black and white
setNoColor(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set whether it is black and white
setNodeColor(byte) - Method in class org.apache.poi.poifs.property.Property
Set the node color.
setNoFill(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFShape
Sets whether this shape is filled or transparent.
setNoFill(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFShape
Sets whether this shape is filled or transparent.
setNoOrientation(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setNoOrientation(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set no orientation.
setNoOrientation(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set no orientation.
setNoOrientation(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set no orientation.
setNormalZoom(short) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set the zoom magnification in normal view
setNoteCount(int) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the note count.
setNotes(Notes) - Method in class org.apache.poi.hslf.model.Slide
Sets the Notes that are associated with this.
setNotes(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setNotes(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Print the include notes
setNotes(Notes) - Method in interface org.apache.poi.sl.usermodel.Slide

setNotes(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Print the include notes
setNotes(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Print the include notes
setNotesByDefault(boolean) - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Should a call to getText() return notes text? Default is no
setNotesByDefault(boolean) - Method in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor
Should a call to getText() return notes text? Default is no
setNotesDescriptorsOffset(NoteType, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setNotesDescriptorsSize(NoteType, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setNotesID(int) - Method in class org.apache.poi.hslf.record.SlideAtom
Change the ID of the notes for this slide.
setNotesSizeX(long) - Method in class org.apache.poi.hslf.record.DocumentAtom

setNotesSizeY(long) - Method in class org.apache.poi.hslf.record.DocumentAtom

setNotesTextPositionsOffset(NoteType, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setNotesTextPositionsSize(NoteType, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setNRevision(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the nRevision field for the DOP record.
setNumAxis(short) - Method in class org.apache.poi.hssf.record.chart.AxisUsedRecord
Set the num axis field for the AxisUsed record.
setNumber(int) - Method in class org.apache.poi.hslf.record.Comment2000Atom
Sets the comment number (note - each user normally has their own count).
setNumber(int) - Method in class org.apache.poi.hslf.record.ExHyperlinkAtom
Sets the link number
setNumberFormat(int) - Method in class org.apache.poi.hwpf.model.ListLevel

setNumberFormat(String) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

setNumberFormat(String) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

setNumbering(XWPFNumbering) - Method in class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

setNumbering(XWPFNumbering) - Method in class org.apache.poi.xwpf.usermodel.XWPFNum

setNumbering(CTNumbering) - Method in class org.apache.poi.xwpf.usermodel.XWPFNumbering
Sets the ctNumbering
setNumberOfConditionalFormats(int) - Method in class org.apache.poi.hssf.record.CFHeaderRecord

setNumberOfElementsInArray(int) - Method in class org.apache.poi.ddf.EscherArrayProperty

setNumberOfElementsInMemory(int) - Method in class org.apache.poi.ddf.EscherArrayProperty

setNumberOfSheets(short) - Method in class org.apache.poi.hssf.record.SupBookRecord

setNumberProperties(byte[]) - Method in class org.apache.poi.hwpf.model.ListLevel

setNumBubbleValues(short) - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Set the num bubble values field for the Series record.
setNumCategories(short) - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Set the num categories field for the Series record.
setNumEntries(short) - Method in class org.apache.poi.hssf.record.AutoFilterInfoRecord
set the number of AutoFilter drop-down arrows on the sheet
setNumerator(short) - Method in class org.apache.poi.hssf.record.SCLRecord
Set the numerator field for the SCL record.
setNumID(BigInteger) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
setNumID of Paragraph
setNumLines(int) - Method in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
Set the number of lines to be displayed in the dropdown.
setNumrm(byte[]) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the numrm field for the PAP record.
setNumSelectedTabs(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set the number of selected tabs
setNumShapes(int) - Method in class org.apache.poi.ddf.EscherDgRecord
The number of shapes in this drawing group.
setNumShapesSaved(int) - Method in class org.apache.poi.ddf.EscherDggRecord

setNumStringsPerBucket(short) - Method in class org.apache.poi.hssf.record.ExtSSTRecord

setNumValues(short) - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Set the num values field for the Series record.
setNVerBuiltInNamesWhenSaved(int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.
setObj(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setObjectId(int) - Method in class org.apache.poi.hslf.record.ExMediaAtom
A 4-byte unsigned integer that specifies an ID for an external object.
setObjectId(int) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Set the object id field for the CommonObjectData record.
setObjectID(int) - Method in class org.apache.poi.hssf.record.DVALRecord
set the object ID of the drop down arrow object for list boxes
setObjectIDSeed(int) - Method in class org.apache.poi.hslf.record.ExObjListAtom
Sets the object ID seed
setObjectType(short) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Set the object type field for the CommonObjectData record.
setObjID(int) - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Sets the unique identifier for the OLE object.
setObjOffset(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setObjStgDataRef(int) - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Sets the reference to the persistent object
setOffset(int) - Method in class org.apache.poi.ddf.EscherBSERecord
File offset in the delay stream.
setOffset(int) - Method in class org.apache.poi.hslf.usermodel.PictureData
Set offset of this picture in the 'Pictures' stream.
setOldfConvMailMergeEsc(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfConvMailMergeEsc field value.
setOldfMapPrintTextColor(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfMapPrintTextColor field value.
setOldfNoColumnBalance(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfNoColumnBalance field value.
setOldfNoSpaceRaiseLower(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfNoSpaceRaiseLower field value.
setOldfNoTabForInd(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfNoTabForInd field value.
setOldfOrigWordTableRules(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfOrigWordTableRules field value.
setOldfShowBreaksInFrames(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfShowBreaksInFrames field value.
setOldfSuppressSpbfAfterPageBreak(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfSuppressSpbfAfterPageBreak field value.
setOldfSupressTopSpacing(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfSupressTopSpacing field value.
setOldfSwapBordersFacingPgs(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfSwapBordersFacingPgs field value.
setOldfTransparentMetafiles(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfTransparentMetafiles field value.
setOldfWrapTrailSpaces(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the oldfWrapTrailSpaces field value.
setOle2(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setOleVerb(byte) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Only valid when action == OLEAction.
setOlstAnm(byte[]) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the olstAnm field for the SEP record.
setOneNotTwoVar(boolean) - Method in class org.apache.poi.hssf.record.TableRecord

setOperator(int) - Method in class org.apache.poi.hssf.usermodel.DVConstraint

setOperator(int) - Method in interface org.apache.poi.ss.usermodel.DataValidationConstraint
Sets the comparison operator for this constraint
setOperator(int) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

setOptA(int) - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

setOptB(int) - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

setOptC(int) - Method in class org.apache.poi.hpbf.model.qcbits.QCBit

setOptimize(short) - Method in class org.apache.poi.hssf.record.RowRecord
set whether to optimize or not (set to 0)
setOption(short) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Set the option field for the CommonObjectData record.
setOptionFlag(short) - Method in class org.apache.poi.hssf.record.NameRecord
sets the option flag for the named range
setOptionFlags(byte) - Method in class org.apache.poi.hssf.record.common.UnicodeString
set the option flags which among other things return if this is a 16-bit or 8 bit string
setOptionFlags(short) - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord
set the (currently unimportant to HSSF) option flags
setOptions(short) - Method in class org.apache.poi.ddf.EscherRecord
Set the options this this record.
setOptions(int) - Method in class org.apache.poi.hslf.record.CString
Sets the count The meaning of the count is specific to the type of the parent record
setOptions(int) - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Sets misc options (the last four bytes in the atom).
setOptions(int) - Method in class org.apache.poi.hslf.record.OEShapeAtom
shape flags.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord
Set the options field for the AxisOptions record.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Set the options field for the CategorySeriesAxis record.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.DatRecord
Set the options field for the Dat record.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.FrameRecord
Set the options field for the Frame record.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Set the options field for the Legend record.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Set the options field for the LinkedData record.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the options field for the Tick record.
setOptions(short) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Set the options field for the ValueRange record.
setOptions(short) - Method in class org.apache.poi.hssf.record.DVALRecord

setOptions(short) - Method in class org.apache.poi.hssf.record.FormulaRecord
set the option flags
setOptions(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setOptions(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set the options bitmask (see bit setters)
setOptions(short) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set the options bitmask or just use the bit setters.
setOptions(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Sets the options flags.
setOptions1(short) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the options1 field for the Text record.
setOptions2(short) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the options2 field for the Text record.
setOrderID(int) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A signed integer that specifies the order of the animation in the slide.
setOrientation(AxisOrientation) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

setOrientation(AxisOrientation) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

setOrientation(PrintOrientation) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Orientation of the page: landscape - portrait.
setOSVersion(int) - Method in class org.apache.poi.hpsf.MutablePropertySet
Sets the "osVersion" property.
setOSVersion(int) - Method in class org.apache.poi.hpsf.SpecialPropertySet

setOurBlockIndex(int) - Method in class org.apache.poi.poifs.storage.BATBlock
Record where in the file we live
setOutline(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setOutline(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setOutline(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setOutline(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setOutlineLevel(int) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
set the outline level for the cells
setOutlineLevel(short) - Method in class org.apache.poi.hssf.record.RowRecord
set the outline level of this row
setOutlineStyleLevel(int) - Method in class org.apache.poi.hssf.record.StyleRecord
set the row or column level of the style (if builtin 1||2)
setOutputCharactersLanguage(boolean) - Method in class org.apache.poi.hwpf.converter.WordToFoConverter

setOutputColumnHeaders(boolean) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

setOutputHiddenColumns(boolean) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

setOutputHiddenRows(boolean) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

setOutputLeadingSpacesAsNonBreaking(boolean) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

setOutputRowNumbers(boolean) - Method in class org.apache.poi.hssf.converter.AbstractExcelConverter

setOutputSummaryInformation(boolean) - Method in class org.apache.poi.hwpf.converter.WordToTextConverter

setOutsideBorders(Line) - Method in class org.apache.poi.hslf.model.Table
Format the outside border using the specified Line object
setOverride(int, ListFormatOverrideLevel) - Method in class org.apache.poi.hwpf.model.ListFormatOverride

setPackage(OPCPackage) - Method in class org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext

setPadding(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This value MUST be zero and MUST be ignored.
setPadding2(int) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This value MUST be zero and MUST be ignored.
setPageBreak(boolean) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies that when rendering this document in a paginated view, the contents of this paragraph are rendered on the start of a new page in the document.
setPageBreakBefore(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setPageBreakBefore(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setPageBreakZoom(short) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
zoom magification in page break view
setPageCount(int) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the page count.
setPaged(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
Deprecated. use setActive()
setPageMarginInches(float) - Method in class org.apache.poi.hssf.converter.ExcelToFoConverter

setPageOrder(PageOrder) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set print page order.
setPageSize(Dimension) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Change the current page size
setPageSize(Dimension) - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Sets the page size to the given Dimension object.
setPageStart(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setPageStart(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set the page numbering start.
setPageStart(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set the page numbering start.
setPageStart(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set the page numbering start.
setPaint(Paint) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the Paint attribute for the Graphics2D context.
setPaint(Paint) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setPaint(Paint) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setPaintMode() - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the paint mode of this graphics context to overwrite the destination with this graphics context's current color.
setPaintMode() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setPaintMode() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

setPaintMode() - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setPaletteOptions(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the palette options bitmask (see the individual bitsetter methods that reference this one)
setPalettepos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setPane(byte) - Method in class org.apache.poi.hssf.record.SelectionRecord
set which window pane this is for
setPaperSize(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setPaperSize(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set the paper size.
setPaperSize(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set the paper size.
setPaperSize(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set the paper size.
setPaperSize(PaperSize) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set the paper size as enum value.
setParagraph(XWPFParagraph, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
copies content of a paragraph to a existing paragraph in the list paragraphs at position pos
setParagraph(XWPFParagraph) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

setParagraphIndent(short, short) - Method in class org.apache.poi.hslf.record.TextRulerAtom

setParagraphProperties(Paragraph, Element) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setParagraphStyles(LinkedList<TextPropCollection>) - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Updates the link list of TextPropCollections which make up the paragraph stylings
setParaTextPropVal(String, int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the value of the given Character TextProp, add if required
setParCount(int) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the par count.
setParentIndex(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
for cell XF types this is the parent style (usually 0/normal).
setParentRecord(RecordContainer) - Method in interface org.apache.poi.hslf.record.ParentAwareRecord

setParentRecord(RecordContainer) - Method in class org.apache.poi.hslf.record.TextHeaderAtom

setParentTextSize(int) - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Tell us how much text the parent TextCharsAtom or TextBytesAtom contains, so we can go ahead and initialise ourselves.
setParsedExpression(Ptg[]) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate
Also checks for a related shared formula and unlinks it if found
setParsedExpression(Ptg[]) - Method in class org.apache.poi.hssf.record.ExternalNameRecord

setParsedExpression(Ptg[]) - Method in class org.apache.poi.hssf.record.FormulaRecord

setParsedExpression1(Ptg[]) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setParsedExpression2(Ptg[]) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setPartName(PackagePartName) - Method in class org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext

setPassword(short) - Method in class org.apache.poi.hssf.record.FileSharingRecord

setPassword(int) - Method in class org.apache.poi.hssf.record.PasswordRecord
set the password
setPassword(short) - Method in class org.apache.poi.hssf.record.PasswordRev4Record
set the password
setPasswordVerifier(int) - Method in class org.apache.poi.hssf.record.common.FeatProtection

setPath(GeneralPath) - Method in class org.apache.poi.hslf.model.Freeform
Set the shape path
setPath(GeneralPath) - Method in class org.apache.poi.xslf.usermodel.XSLFFreeformShape
Set the shape path
setPathForXmlSchema(String) - Static method in class org.apache.poi.openxml4j.opc.Configuration

setPatriarch(HSSFPatriarch) - Method in class org.apache.poi.hssf.record.EscherAggregate

setPattern(short) - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord
Set the pattern field for the AreaFormat record.
setPatternBackgroundColorModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setPatternColorModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setPatternFormatting(PatternFormatting) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setPatternStyleModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setPatternType(STPatternType.Enum) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
set the fill pattern
setPcHorz(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the pcHorz field for the PAP record.
setPcHorz(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the pcHorz field value.
setPctCharWidth(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Character scale.
setPctWwd(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word: percent of Window size for AutoFit in WebView.
setPcVert(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the pcVert field for the PAP record.
setPcVert(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the pcVert field value.
setPdfProperty(String, String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setPerformDataValidation(boolean) - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

setPersistId(int) - Method in class org.apache.poi.hslf.record.ExOleObjStg
Set our sheet ID, as found from a PersistPtrHolder
setPersistId(int) - Method in interface org.apache.poi.hslf.record.PersistRecord
Set the persist ID
setPersistPointersOffset(int) - Method in class org.apache.poi.hslf.record.UserEditAtom

setPgbProp(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the pgbProp field for the SEP record.
setPgnStart(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the pgnStart field for the SEP record.
setPhe(byte[]) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the phe field for the PAP record.
setPicOffset(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setPictureData(byte[]) - Method in class org.apache.poi.ddf.EscherBlipRecord

setPictureData(int) - Method in class org.apache.poi.hslf.model.Fill
Assign picture used to fill the underlying shape.
setPictureIndex(int) - Method in class org.apache.poi.hssf.usermodel.HSSFPicture

setPictureName(String) - Method in class org.apache.poi.hslf.model.Picture
Name of this picture.
setPictureProperties(Picture, Element) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setPictureReference(PackageRelationship) - Method in class org.apache.poi.xssf.usermodel.XSSFPicture
Link this shape with the picture data
setPictureReference(PackageRelationship) - Method in class org.apache.poi.xwpf.usermodel.XWPFPicture
Link Picture with PictureData
setPicturesManager(PicturesManager) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

setPitchAndFamily(int) - Method in class org.apache.poi.hslf.model.PPFont
set lfPitchAndFamily
setPitchAndFamily(int) - Method in class org.apache.poi.hslf.record.FontEntityAtom
set lfPitchAndFamily
setPlaceholder(Placeholder) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Specifies that the corresponding shape should be represented by the generating application as a placeholder.
setPlaceholderId(byte) - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom
Sets the placeholder Id.
setPlaceholderId(int) - Method in class org.apache.poi.hslf.record.RoundTripHFPlaceholder12
Sets the comment number (note - each user normally has their own count).
setPlaceholderSize(byte) - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom
Sets the placeholder size.
setPlacementId(int) - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom
Sets the placement Id.
setPlcfHddOffset(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setPlcfHddSize(int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setPlotOnlyVisibleCells(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFChart

setPlotVisibleOnly(boolean) - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord
Sets the plot visible only field value.
setPnNext(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.
setPointNumber(short) - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Set the point number field for the DataFormat record.
setPoints(float[], float[]) - Method in class org.apache.poi.hslf.model.Polygon
Set the polygon vertices
setPoints(Point2D[]) - Method in class org.apache.poi.hslf.model.Polygon
Set the polygon vertices
setPoints(int[], int[]) - Method in class org.apache.poi.hssf.usermodel.HSSFPolygon

setPolygonDrawArea(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFPolygon
Defines the width and height of the points in the polygon
setPosition(int) - Method in class org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor

setPosition(AxisPosition) - Method in interface org.apache.poi.ss.usermodel.charts.ChartAxis

setPosition(LegendPosition) - Method in interface org.apache.poi.ss.usermodel.charts.ChartLegend

setPosition(AxisPosition) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

setPosition(LegendPosition) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFChartLegend

setPositionOfBof(int) - Method in class org.apache.poi.hssf.record.BoundSheetRecord
set the offset in bytes of the Beginning of File Marker within the HSSF Stream part of the POIFS file
setPresentationFormat(String) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the presentation format.
setPreviousChild(Child) - Method in interface org.apache.poi.poifs.property.Child
Set the previous Child
setPreviousChild(Child) - Method in interface org.apache.poi.poifs.property.Parent
Set the previous Child
setPreviousChild(Child) - Method in class org.apache.poi.poifs.property.Property
Set the previous Child
setPrimaryUID(byte[]) - Method in class org.apache.poi.ddf.EscherMetafileBlip

setPrintable(boolean) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Sets the printable field value.
setPrintArea(int, String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Sets the printarea for the sheet provided
setPrintArea(int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
For the Convenience of Java Programmers maintaining pointers.
setPrintArea(int, String) - Method in interface org.apache.poi.ss.usermodel.Workbook
Sets the printarea for the sheet provided
setPrintArea(int, int, int, int, int) - Method in interface org.apache.poi.ss.usermodel.Workbook
For the Convenience of Java Programmers maintaining pointers.
setPrintArea(int, String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Sets the printarea for the sheet provided
setPrintArea(int, int, int, int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
For the Convenience of Java Programmers maintaining pointers.
setPrintArea(int, String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Sets the printarea for the sheet provided
setPrintArea(int, int, int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
For the Convenience of Java Programmers maintaining pointers.
setPrintGridlines(PrintGridlinesRecord) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets the PrintGridlinesRecord.
setPrintGridlines(boolean) - Method in class org.apache.poi.hssf.record.PrintGridlinesRecord
set whether or not to print the gridlines (and make your spreadsheet ugly)
setPrintGridlines(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Turns on or off the printing of gridlines.
setPrintGridlines(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier.
setPrintGridlines(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier.
setPrintGridlines(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Turns on or off the printing of gridlines.
setPrintHeaders(boolean) - Method in class org.apache.poi.hssf.record.PrintHeadersRecord
set to print the headers - y/n
setPrintSetup(PrintSetupRecord) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Sets the PrintSetupRecord.
setProducer(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setProgId(String) - Method in class org.apache.poi.hslf.record.ExEmbed

setProperties(Property[]) - Method in class org.apache.poi.hpsf.MutableSection
Sets this section's properties.
setProperty(int, String) - Method in class org.apache.poi.hpsf.MutableSection
Sets the string value of the property with the specified ID.
setProperty(int, int) - Method in class org.apache.poi.hpsf.MutableSection
Sets the int value of the property with the specified ID.
setProperty(int, long) - Method in class org.apache.poi.hpsf.MutableSection
Sets the long value of the property with the specified ID.
setProperty(int, boolean) - Method in class org.apache.poi.hpsf.MutableSection
Sets the boolean value of the property with the specified ID.
setProperty(int, long, Object) - Method in class org.apache.poi.hpsf.MutableSection
Sets the value and the variant type of the property with the specified ID.
setProperty(Property) - Method in class org.apache.poi.hpsf.MutableSection
Sets a property.
setProperty(int, Object) - Method in class org.apache.poi.hpsf.MutableSection
Sets a property.
setProperty(String, String) - Method in class org.apache.poi.hslf.model.ActiveXShape
Set a property of this ActiveX control
setProperty(String, String, String, String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setPropertyBooleanValue(int, boolean) - Method in class org.apache.poi.hpsf.MutableSection
Sets the value of the boolean property with the specified ID.
setPropertyStart(int) - Method in class org.apache.poi.poifs.storage.HeaderBlock
Set start of Property Table
setPropertyStart(int) - Method in class org.apache.poi.poifs.storage.HeaderBlockWriter
Set start of Property Table
setPropertyType(byte) - Method in class org.apache.poi.poifs.property.Property
Set the property type.
setProtect(boolean) - Method in class org.apache.poi.hssf.record.ObjectProtectRecord
set whether the sheet is protected or not
setProtect(boolean) - Method in class org.apache.poi.hssf.record.ProtectionRev4Record
set whether the this is protected shared/tracked workbook or not
setProtect(boolean) - Method in class org.apache.poi.hssf.record.ProtectRecord
set whether the sheet is protected or not
setProtect(boolean) - Method in class org.apache.poi.hssf.record.ScenarioProtectRecord
set whether the sheet is protected or not
setProtect(boolean) - Method in class org.apache.poi.hssf.record.WindowProtectRecord
set whether this window should be protected or not
setProtectionFormattingUnchanged() - Method in class org.apache.poi.hssf.record.CFRuleRecord

setProtpos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setPtap(byte[]) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the ptap field for the PAP record.
setPure(boolean) - Method in class org.apache.poi.hpsf.CustomProperties
Sets the purity of the custom property set.
setRandomAccessWindowSize(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Specifies how many rows can be accessed at most via getRow().
setRawContents(byte[]) - Method in class org.apache.poi.hslf.record.StyleTextPropAtom

setRawData(byte[]) - Method in class org.apache.poi.hslf.usermodel.PictureData

setRawData(byte[]) - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

setRawText(String) - Method in class org.apache.poi.hslf.model.TextRun
Changes the text, and sets it all to have the same styling as the the first character has.
setRawText(String) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Change the text
setReadingOrder(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the reading order for far east versions (0 - Context, 1 - Left to right, 2 - right to left) - We could use some help with support for the far east.
setReadOnly(short) - Method in class org.apache.poi.hssf.record.FileSharingRecord
set the readonly flag
setRecalc(boolean) - Method in class org.apache.poi.hssf.record.SaveRecalcRecord
set whether to recalculate formulas/etc before saving or not
setRecordId(short) - Method in class org.apache.poi.ddf.EscherRecord
Sets the record id for this record.
setRecords(List<Record>) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setRecordType(short) - Method in class org.apache.poi.hssf.record.common.FtrHeader

setRectX1(int) - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting top-left coordinate of child records.
setRectX2(int) - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting bottom-right coordinate of child records.
setRectY1(int) - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting top-left coordinate of child records.
setRectY2(int) - Method in class org.apache.poi.ddf.EscherSpgrRecord
The starting bottom-right coordinate of child records.
setRef(int) - Method in class org.apache.poi.ddf.EscherBSERecord
The reference count of this blip.
setReference(String) - Method in class org.apache.poi.hssf.usermodel.HSSFName
Deprecated. (Nov 2008) Misleading name. Use HSSFName.setRefersToFormula(String) instead.
setReferenceType(byte) - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord
Set the reference type field for the LinkedData record.
setRefersToFormula(String) - Method in class org.apache.poi.hssf.usermodel.HSSFName

setRefersToFormula(String) - Method in interface org.apache.poi.ss.usermodel.Name
Sets the formula that the name is defined to refer to.
setRefersToFormula(String) - Method in class org.apache.poi.xssf.usermodel.XSSFName

setRefID(int) - Method in class org.apache.poi.hslf.record.SlidePersistAtom

setRefreshAll(boolean) - Method in class org.apache.poi.hssf.record.RefreshAllRecord
set whether to refresh all external data when loading a sheet
setReleaseVersion(long) - Method in class org.apache.poi.hslf.record.CurrentUserAtom

setRemainingData(byte[]) - Method in class org.apache.poi.ddf.EscherBSERecord
Any remaining data in this record.
setRemainingData(byte[]) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
Any remaining data in the record
setRemainingData(byte[]) - Method in class org.apache.poi.ddf.EscherClientDataRecord
Any data recording this record.
setRenderingHint(RenderingHints.Key, Object) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the value of a single preference for the rendering algorithms.
setRenderingHint(RenderingHints.Key, Object) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setRenderingHint(RenderingHints.Key, Object) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setRenderingHints(Map) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Replaces the values of all preferences for the rendering algorithms with the specified hints.
setRenderingHints(Map) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setRenderingHints(Map) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setRepeatHeader(boolean) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableRow
This attribute controls whether to repeat a table's header row at the top of a table split across pages.
setRepeatingRowsAndColumns(int, int, int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Sets the repeating rows and columns for a sheet (as found in 2003:File->PageSetup->Sheet, 2007:Page Layout->Print Titles).
setRepeatingRowsAndColumns(int, int, int, int, int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Sets the repeating rows and columns for a sheet (as found in File->PageSetup->Sheet).
setRepeatingRowsAndColumns(int, int, int, int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Sets the repeating rows and columns for a sheet (as found in File->PageSetup->Sheet).
setRepeatingRowsAndColumns(int, int, int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Sets the repeating rows and columns for a sheet.
setRequiredVersion(int) - Method in class org.apache.poi.hssf.record.BOFRecord
set the minimum version required to read this file
setReserved(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the reserved field value.
setReserved(byte[]) - Method in class org.apache.poi.hssf.record.common.FtrHeader

setReserved(int) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set the reserved (don't do this) value
setReserved(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the reserved field for the DOP record.
setReserved(byte) - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType
Sets the reserved field value.
setReserved(byte) - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Sets the reserved field value.
setReserved1(int) - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Set the reserved1 field for the Axis record.
setReserved1(int) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Set the reserved1 field for the CommonObjectData record.
setReserved1(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the reserved1 field for the DOP record.
setReserved1(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the reserved1 field value.
setReserved1(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the reserved1 field for the FibRgLw95 record.
setReserved1(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved1(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved1(int) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Reserved.
setReserved1(byte) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Sets the reserved1 field value.
setReserved10(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved10(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved11(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved11(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved12(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value SHOULD be zero, and MUST be ignored.
setReserved12(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved13(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be zero and MUST be ignored.
setReserved13(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved14(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be zero and MUST be ignored.
setReserved2(int) - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Set the reserved2 field for the Axis record.
setReserved2(int) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Set the reserved2 field for the CommonObjectData record.
setReserved2(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the reserved2 field for the DOP record.
setReserved2(boolean) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
Sets the reserved2 field value.
setReserved2(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the reserved2 field for the FibRgLw95 record.
setReserved2(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved2(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved2(int) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Reserved.
setReserved3(int) - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Set the reserved3 field for the Axis record.
setReserved3(int) - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord
Set the reserved3 field for the CommonObjectData record.
setReserved3(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the reserved3 field for the FibRgLw95 record.
setReserved3(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved3(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved3(byte) - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType
Reserved.
setReserved4(int) - Method in class org.apache.poi.hssf.record.chart.AxisRecord
Set the reserved4 field for the Axis record.
setReserved4(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the reserved4 field for the FibRgLw95 record.
setReserved4(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved4(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved5(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
Set the reserved5 field for the FibRgLw95 record.
setReserved5(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved5(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved6(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx.
setReserved6(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved7(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved7(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved8(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value is undefined and MUST be ignored.
setReserved8(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReserved9(int) - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx.
setReserved9(short) - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType
This value is undefined and MUST be ignored.
setReservedField(short) - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection

setReturnNullOnMissingChunk(boolean) - Method in class org.apache.poi.hsmf.MAPIMessage
Sets whether on asking for a missing chunk, you get back null or a ChunkNotFoundException (default is the exception).
setReversed(boolean) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Sets the reversed field value.
setRevision(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setRevisionProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set revision.
setRevisionProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the revision number.
setRevNumber(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the revision number.
setRgb(byte[]) - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Standard Alpha Red Green Blue ctColor value (ARGB).
setRgbColor(int) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the rgbColor field for the Text record.
setRgbrcInsideDefault_0(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Border definition for inside horizontal borders.
setRgbrcInsideDefault_1(BorderCode) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Border definition for inside vertical borders.
setRgbxchNums(byte[]) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
An array of 8-bit integers.
setRgdxaCenter(short[]) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..
setRgdxaCenterPrint(short[]) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setRgdxaColumn(int[]) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the rgdxaColumn field for the SEP record.
setRgdxaTab(int[]) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Array of positions of itbdMac tab stops.
setRgf(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Set the rgf field for the TC record.
setRgistdPara(short[]) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
An array of nine 16-bit signed integers.
setRgshd(ShadingDescriptor[]) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the rgshd field for the TAP record.
setRgtbd(TabDescriptor[]) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Array of itbdMac tab descriptors.
setRgtc(TableCellDescriptor[]) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the rgtc field for the TAP record.
setRight(String) - Method in class org.apache.poi.hssf.usermodel.HeaderFooter

setRight(String) - Method in interface org.apache.poi.ss.usermodel.Footer
Sets the right string.
setRight(String) - Method in interface org.apache.poi.ss.usermodel.Header
Sets the right string.
setRight(String) - Method in interface org.apache.poi.ss.usermodel.HeaderFooter
Sets the right string or footer.
setRight(String) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
set a right string value for this element
setRightBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setRightBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setRightBorderColor(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the color to use for the right border
setRightBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setRightBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the color to use for the right border
setRightBorderColor(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setRightBorderColor(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the rightBorderColor attribute of the HSSFRegionUtil object
setRightBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

setRightBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the color to use for the right border
setRightBorderColor(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the rightBorderColor attribute of the RegionUtil object
setRightBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setRightBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the right border
setRightBorderColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the right border as a XSSFColor value
setRightBorderModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setRightBorderPaletteIdx(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the palette index for the right border color
setRightInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setRightInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Sets the right margin.
setRightSection(String, String) - Method in class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

setRightToLeft(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets whether the worksheet is displayed from right to left instead of from left to right.
setRightToLeft(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets whether the worksheet is displayed from right to left instead of from left to right.
setRightToLeft(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets whether the worksheet is displayed from right to left instead of from left to right.
setRightToLeft(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets whether the worksheet is displayed from right to left instead of from left to right.
setRncEdn(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the rncEdn field value.
setRncFtn(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the rncFtn field value.
setRotation(int) - Method in class org.apache.poi.hslf.model.SimpleShape
Rotate this shape
setRotation(short) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the rotation field value.
setRotation(short) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Sets the rotation field value.
setRotation(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the degree of rotation.
setRotation(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the degree of rotation for the text in the cell
setRotation(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the degree of rotation for the text in the cell
setRotation(double) - Method in class org.apache.poi.xslf.usermodel.XSLFGraphicFrame
Rotate this shape.
setRotation(double) - Method in class org.apache.poi.xslf.usermodel.XSLFGroupShape

setRotation(double) - Method in class org.apache.poi.xslf.usermodel.XSLFShape
Rotate this shape.
setRotation(double) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setRotation(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the degree of rotation for the text in the cell
setRow(int) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setRow(int) - Method in class org.apache.poi.hssf.record.BlankRecord
set the row this cell occurs on
setRow(int) - Method in class org.apache.poi.hssf.record.CellRecord

setRow(int) - Method in interface org.apache.poi.hssf.record.CellValueRecordInterface

setRow(int) - Method in class org.apache.poi.hssf.record.LabelRecord
NO-OP!
setRow(int) - Method in class org.apache.poi.hssf.record.NoteRecord
Specify the row that contains the comment
setRow(int) - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Set the row of the cell that contains the comment
setRow(int) - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

setRow(int) - Method in interface org.apache.poi.ss.usermodel.Comment
Set the row of the cell that contains the comment
setRow(int) - Method in class org.apache.poi.xssf.usermodel.XSSFComment
Set the row of the cell that contains the comment
setRow1(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The row number for the top-left corner of the shape.
setRow1(int) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

setRow1(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the row (0 based) of the first cell.
setRow1(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setRow2(short) - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
The row number for the bottom-right corner of the current shape.
setRow2(int) - Method in class org.apache.poi.hssf.usermodel.HSSFClientAnchor

setRow2(int) - Method in interface org.apache.poi.ss.usermodel.ClientAnchor
Returns the row (0 based) of the first cell.
setRow2(int) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setRowBandSize(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

setRowBreak(int, short, short) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Sets a page break at the indicated row
setRowBreak(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive.
setRowBreak(int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive.
setRowBreak(int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets a page break at the indicated row
setRowBreak(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive.
setRowDeleted(boolean) - Method in class org.apache.poi.hssf.record.TableRecord

setRowFrom(int) - Method in class org.apache.poi.ss.util.Region
Deprecated. set the upper left hand corner row number
setRowGroupCollapsed(int, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

setRowGroupCollapsed(int, boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Set view state of a groupped range of rows
setRowGroupCollapsed(int, boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Set view state of a groupped range of rows
setRowGroupCollapsed(int, boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
group the row It is possible for collapsed to be false and yet still have the rows in question hidden.
setRowHeight(int, int) - Method in class org.apache.poi.hslf.model.Table
Sets the row height.
setRowHeight(short) - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord
set the default row height
setRowHeight(int) - Method in class org.apache.poi.hwpf.usermodel.TableRow

setRowInputCol(int) - Method in class org.apache.poi.hssf.record.TableRecord

setRowInputRow(int) - Method in class org.apache.poi.hssf.record.TableRecord

setRowJustification(int) - Method in class org.apache.poi.hwpf.usermodel.TableRow

setRowLevelMax(short) - Method in class org.apache.poi.hssf.record.GutsRecord
set the maximum outline level for the row gutter.
setRowNum(int) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
set the row number of this row.
setRowNum(int) - Method in interface org.apache.poi.ss.usermodel.Row
Set the row number of this row.
setRowNum(int) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Set the row number of this row.
setRowNum(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Set the row number of this row.
setRowNumber(int) - Method in class org.apache.poi.hssf.record.RowRecord
set the logical row number for this row (0 based index)
setRowOrColInpCell(boolean) - Method in class org.apache.poi.hssf.record.TableRecord

setRowRelative(boolean) - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

setRowStyle(HSSFCellStyle) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Applies a whole-row cell styling to the row.
setRowStyle(CellStyle) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
Applies a whole-row cell styling to the row.
setRowStyle(CellStyle) - Method in interface org.apache.poi.ss.usermodel.Row
Applies a whole-row cell styling to the row.
setRowStyle(CellStyle) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Applies a whole-row cell styling to the row.
setRowStyle(CellStyle) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Applies a whole-row cell styling to the row.
setRowSumsBelow(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
set if row summaries appear below detail in the outline
setRowSumsBelow(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set if row summaries appear below detail in the outline
setRowSumsBelow(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
setRowSumsBelow(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
setRowSumsBelow(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
setRowSumsRight(boolean) - Method in class org.apache.poi.hssf.record.WSBoolRecord
set if col summaries appear right of the detail in the outline
setRowSumsRight(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
set if col summaries appear right of the detail in the outline
setRowSumsRight(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
setRowSumsRight(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
setRowSumsRight(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
setRowTo(int) - Method in class org.apache.poi.ss.util.Region
Deprecated. get the lower right hand corner row number
setRsid(long) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Save ID for last time this PAP was revised.
setRsid(long) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.
setRule(int, CFRuleRecord) - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

setRule(int, HSSFConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting
Replaces an existing Conditional Formatting rule at position idx.
setRule(int, ConditionalFormattingRule) - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

setRule(int, ConditionalFormattingRule) - Method in interface org.apache.poi.ss.usermodel.ConditionalFormatting
Replaces an existing Conditional Formatting rule at position idx.
setRule(int, ConditionalFormattingRule) - Method in class org.apache.poi.xssf.usermodel.XSSFConditionalFormatting
Replaces an existing Conditional Formatting rule at position idx.
setRun(int) - Method in class org.apache.poi.xwpf.usermodel.PositionInParagraph

setRunType(int) - Method in class org.apache.poi.hslf.model.TextRun
Changes the type of the text.
setSaltData(byte[]) - Method in class org.apache.poi.hssf.record.FilePassRecord

setSaltHash(byte[]) - Method in class org.apache.poi.hssf.record.FilePassRecord

setSavedInPageBreakPreview(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
was the sheet saved in page break view
setSaveLinkValues(short) - Method in class org.apache.poi.hssf.record.BookBoolRecord
set the save ext links flag
setSBATBlockCount(int) - Method in class org.apache.poi.poifs.storage.HeaderBlock
Set count of SBAT blocks
setSBATBlockCount(int) - Method in class org.apache.poi.poifs.storage.HeaderBlockWriter
Set count of SBAT blocks
setSBATStart(int) - Method in class org.apache.poi.poifs.storage.HeaderBlock
Set start of small block allocation table
setSBATStart(int) - Method in class org.apache.poi.poifs.storage.HeaderBlockWriter
Set start of small block allocation table
setScale(boolean) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the scale.
setScale(short) - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Set the scale field for the FontBasis record.
setScale(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setScale(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set the scale.
setScale(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set the scale.
setScale(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set the scale.
setScheme(FontScheme) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set font scheme property
setSCLRecord(SCLRecord) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets the SCL record or creates it in the correct place if it does not already exist.
setSecondaryUID(byte[]) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the secondary UID
setSecurity(int) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the security code.
setSelected(boolean) - Method in class org.apache.poi.hssf.model.InternalSheet
Sets whether the sheet is selected
setSelected(boolean) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
sheet tab is selected
setSelected(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets whether sheet is selected.
setSelected(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets a flag indicating whether this sheet is selected.
setSelected(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets a flag indicating whether this sheet is selected.
setSelected(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets a flag indicating whether this sheet is selected.
setSelectedTab(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
Deprecated. - Misleading name - use setActiveSheetIndex()
setSelectedTab(int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Selects a single sheet.
setSelectedTab(short) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Deprecated. use setSelectedTab(int)
setSelectedTab(int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Sets the tab whose data is actually seen when the sheet is opened.
setSelectedTab(int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Sets the tab whose data is actually seen when the sheet is opened.
setSelectedTab(int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
We only set one sheet as selected for compatibility with HSSF.
setSelectedTabs(int[]) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

setSelection(SelectionRecord) - Method in class org.apache.poi.hssf.model.InternalSheet

setSeriesIndex(short) - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Set the series index field for the DataFormat record.
setSeriesNumber(short) - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Set the series number field for the DataFormat record.
setSeriesTitle(String) - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries
Changes the series' title, but only if there was one already.
setServerZoomFrom(long) - Method in class org.apache.poi.hslf.record.DocumentAtom

setServerZoomTo(long) - Method in class org.apache.poi.hslf.record.DocumentAtom

setSfxtText(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Text animation.
setShading(ShadingDescriptor) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setShading(ShadingDescriptor) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setShadow(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setShadow(boolean) - Method in class org.apache.poi.hssf.record.chart.AreaRecord
Sets the shadow field value.
setShadow(boolean) - Method in class org.apache.poi.hssf.record.chart.BarRecord
Sets the shadow field value.
setShadow(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setShadow(boolean) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

setShadow(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setShadow(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setShadowed(boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Does the text have a shadow?
setShadowsColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Shadows Colour
setShapeId(int) - Method in class org.apache.poi.ddf.EscherSpRecord
Sets a number that identifies this shape.
setShapeId(int) - Method in class org.apache.poi.hslf.model.Shape
Sets shape ID
setShapeId(int) - Method in class org.apache.poi.hslf.model.TextRun

setShapeId(int) - Method in class org.apache.poi.hslf.record.EscherTextboxWrapper

setShapeId(int) - Method in class org.apache.poi.hssf.record.NoteRecord
Object id for OBJ record that contains the comment
setShapeIdMax(int) - Method in class org.apache.poi.ddf.EscherDggRecord
The maximum is actually the next available.
setShapeType(short) - Method in class org.apache.poi.ddf.EscherSpRecord
Sets shape type.
setShapeType(int) - Method in class org.apache.poi.hslf.model.Shape

setShapeType(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSimpleShape
Sets the shape types.
setShapeType(XSLFShapeType) - Method in class org.apache.poi.xslf.usermodel.XSLFSimpleShape

setShapeType(int) - Method in class org.apache.poi.xssf.usermodel.XSSFConnector
Sets the shape types.
setShapeType(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSimpleShape
Sets the shape types.
setSharedFeature(SharedFeature) - Method in class org.apache.poi.hssf.record.FeatRecord

setSharedFormula(boolean) - Method in class org.apache.poi.hssf.record.FormulaRecord

setShd(ShadingDescriptor) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Shading.
setShd(ShadingDescriptor) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the shd field for the PAP record.
setShd(ShadingDescriptor) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Cell shading.
setShdTable(ShadingDescriptor) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Table shading.
setSheet(Sheet) - Method in class org.apache.poi.hslf.model.Shape
Assign the SlideShow this shape belongs to
setSheet(Sheet) - Method in class org.apache.poi.hslf.model.Table
Assign the SlideShow this shape belongs to
setSheet(Sheet) - Method in class org.apache.poi.hslf.model.TextRun

setSheet(Sheet) - Method in class org.apache.poi.hslf.model.TextShape

setSheetBof(int, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Sets the BOF for a given sheet
setSheetHidden(int, boolean) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Hide or unhide a sheet
setSheetHidden(int, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Hide or unhide a sheet.
setSheetHidden(int, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

setSheetHidden(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook

setSheetHidden(int, boolean) - Method in interface org.apache.poi.ss.usermodel.Workbook
Hide or unhide a sheet
setSheetHidden(int, int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Hide or unhide a sheet.
setSheetHidden(int, boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Hide or unhide a sheet
setSheetHidden(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Hide or unhide a sheet.
setSheetHidden(int, boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Sets the visible state of this sheet.
setSheetHidden(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Hide or unhide a sheet.
setSheetId(int) - Method in class org.apache.poi.hslf.record.PositionDependentRecordContainer
Set our sheet ID, as found from a PersistPtrHolder
setSheetIndex(int) - Method in class org.apache.poi.hssf.usermodel.HSSFName
Specifies if the defined name is a local name, and if so, which sheet it is on.
setSheetIndex(int) - Method in interface org.apache.poi.ss.usermodel.Name
Tell Excel that this name applies to the worksheet with the specified index instead of the entire workbook.
setSheetIndex(int) - Method in class org.apache.poi.xssf.usermodel.XSSFName
Tell Excel that this name applies to the worksheet with the specified index instead of the entire workbook.
setSheetName(int, String) - Method in class org.apache.poi.hssf.model.InternalWorkbook
sets the name for a given sheet.
setSheetname(String) - Method in class org.apache.poi.hssf.record.BoundSheetRecord
Set the sheetname for this sheet.
setSheetName(int, String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Set the sheet name.
setSheetName(int, String) - Method in interface org.apache.poi.ss.usermodel.Workbook
Set the sheet name.
setSheetName(String) - Method in class org.apache.poi.ss.util.SheetBuilder
Specifies name of the sheet to build.
setSheetName(int, String) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Set the sheet name.
setSheetName(int, String) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Set the sheet name.
setSheetNumber(int) - Method in class org.apache.poi.hssf.record.NameRecord

setSheetOrder(String, int) - Method in class org.apache.poi.hssf.model.InternalWorkbook
sets the order of appearance for a given sheet.
setSheetOrder(String, int) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
sets the order of appearance for a given sheet.
setSheetOrder(String, int) - Method in interface org.apache.poi.ss.usermodel.Workbook
Sets the order of appearance for a given sheet.
setSheetOrder(String, int) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Sets the order of appearance for a given sheet.
setSheetOrder(String, int) - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
sets the order of appearance for a given sheet.
setShort(short) - Method in class org.apache.poi.util.BitField
Set the bits.
setShortBoolean(short, boolean) - Method in class org.apache.poi.util.BitField
Set a boolean BitField
setShortFilename(String) - Method in class org.apache.poi.hssf.record.HyperlinkRecord

setShortFilename(String) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Convenience method equivalent to HSSFHyperlink.setAddress(String)
setShortValue(short, short) - Method in class org.apache.poi.util.BitField
Replace the bits with new values.
setShowActual(boolean) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Sets the show actual field value.
setShowBubbleSizes(boolean) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Sets the show bubble sizes field value.
setShowBubbleSizes(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the show bubble sizes field value.
setShowCategoryLabelAsPercentage(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the show category label as percentage field value.
setShowErrorBox(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

setShowErrorBox(boolean) - Method in interface org.apache.poi.ss.usermodel.DataValidation
Sets the behaviour when an invalid value is entered
setShowErrorBox(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

setShowKey(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the show key field value.
setShowLabel(boolean) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Sets the show label field value.
setShowLabel(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the show label field value.
setShowPercent(boolean) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Sets the show percent field value.
setShowPromptBox(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

setShowPromptBox(boolean) - Method in interface org.apache.poi.ss.usermodel.DataValidation
Sets the behaviour when a cell which belongs to this object is selected
setShowPromptBox(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

setShowSeriesKey(boolean) - Method in class org.apache.poi.hssf.record.chart.DatRecord
Sets the show series key field value.
setShowValue(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the show value field value.
setShowValueAsPercentage(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the show value as percentage field value.
setShrinkToFit(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether to shrink the text to fit
setSideBySide(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setSideBySide(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setSize(int) - Method in class org.apache.poi.ddf.EscherBSERecord
Blip size in stream.
setSize(int) - Method in class org.apache.poi.poifs.property.Property
Set the size of the document associated with this Property
setSize(int) - Method in class org.apache.poi.poifs.property.RootProperty
set size
setSizeEMU(Dimension) - Method in class org.apache.poi.ddf.EscherMetafileBlip

setSizeEMU(Dimension) - Method in class org.apache.poi.ddf.EscherPictBlip

setSizeOfElements(int) - Method in class org.apache.poi.ddf.EscherArrayProperty

setSlideAtomsSets(SlideListWithText.SlideAtomsSet[]) - Method in class org.apache.poi.hslf.record.SlideListWithText
Get access to the SlideAtomsSets of the children of this record
setSlideCount(int) - Method in class org.apache.poi.hpsf.DocumentSummaryInformation
Sets the slideCount.
setSlideCount(int) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
An unsigned integer that specifies the number of slides that this animation continues playing.
setSlideId(int) - Method in class org.apache.poi.hslf.record.ExControlAtom
Sets which presentation slide is associated with the ActiveX control.
setSlideID(int) - Method in class org.apache.poi.hslf.record.NotesAtom

setSlideIdentifier(int) - Method in class org.apache.poi.hslf.record.SlidePersistAtom

setSlideNumber(int) - Method in class org.apache.poi.hslf.model.Slide
Changes the Slide's (external facing) page number.
setSlideNumberVisible(boolean) - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the slide number is displayed in the footer.
setSlideOrder(XSLFSlide, int) - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow

setSlidesByDefault(boolean) - Method in class org.apache.poi.hslf.extractor.PowerPointExtractor
Should a call to getText() return slide text? Default is yes
setSlidesByDefault(boolean) - Method in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor
Should a call to getText() return slide text? Default is yes
setSlideShow(SlideShow) - Method in class org.apache.poi.hslf.model.Sheet
Set the SlideShow we're attached to.
setSlideShow(SlideShow) - Method in class org.apache.poi.hslf.model.SlideMaster
Assign SlideShow for this slide master.
setSlideSizeX(long) - Method in class org.apache.poi.hslf.record.DocumentAtom

setSlideSizeY(long) - Method in class org.apache.poi.hslf.record.DocumentAtom

setSmallCaps(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setSmallCaps(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setSmoothedLine(boolean) - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord
Sets the smoothed line field value.
setSoundIdRef(int) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
A 4-byte unsigned integer that specifies a reference to a sound in the SoundCollectionContainer record to locate the embedded audio
setSoundRef(int) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
a reference to a sound in the sound collection.
setSpace(int) - Method in class org.apache.poi.hwpf.usermodel.BorderCode

setSpaceAfter(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets spacing after a paragraph.
setSpaceAfter(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Set the amount of vertical white space that will be present after the paragraph.
setSpaceBefore(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets spacing before a paragraph.
setSpaceBefore(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Set the amount of vertical white space that will be present before the paragraph.
setSpacing(byte) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Set the spacing field for the Legend record.
setSpacingAfter(int) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setSpacingAfter(int) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setSpacingAfter(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.
setSpacingAfterLines(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added after the last line in this paragraph in the document in line units.
setSpacingBefore(int) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setSpacingBefore(int) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setSpacingBefore(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added above the first line in this paragraph in the document in absolute units.
setSpacingBeforeLines(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the spacing that should be added before the first line in this paragraph in the document in line units.
setSpacingLineRule(LineSpacingRule) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies how the spacing between lines is calculated as stored in the line attribute.
setSpare(byte) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the spare field value.
setSpare(byte[]) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the Spare field for the DOP record.
setSpecialCharacter(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setSpellingLanguage(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
Sets the default spelling language on ctStyles DocDefaults parameter
setSpid(int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Shape Identifier.
setSSTIndex(int) - Method in class org.apache.poi.hssf.record.LabelSSTRecord
set the index to the string in the SSTRecord
setStacked(boolean) - Method in class org.apache.poi.hssf.record.chart.AreaRecord
Sets the stacked field value.
setStacked(boolean) - Method in class org.apache.poi.hssf.record.chart.BarRecord
Sets the stacked field value.
setStart(int) - Method in class org.apache.poi.hwpf.model.PropertyNode

setStartAt(int) - Method in class org.apache.poi.hwpf.model.ListLevel

setStartBlock(int) - Method in interface org.apache.poi.poifs.filesystem.BATManaged
Set the start block for this instance
setStartBlock(int) - Method in class org.apache.poi.poifs.filesystem.POIFSDocument
Set the start block for this instance
setStartBlock(int) - Method in class org.apache.poi.poifs.property.Property
Set the start block for the document referred to by this Property.
setStartBlock(int) - Method in class org.apache.poi.poifs.property.PropertyTableBase
Set the start block for this instance
setStartBlock(int) - Method in class org.apache.poi.poifs.storage.BlockAllocationTableWriter
Set the start block for this instance
setStartBlock(int) - Method in class org.apache.poi.poifs.storage.SmallBlockTableWriter
Set the start block for this instance
setStartIndex(int) - Method in class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Sets the beginning character position
setStatusBarText(String) - Method in class org.apache.poi.hssf.record.NameRecord
sets the status bar text
setSti(short) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the sti field value.
setStiMaxWhenSaved(int) - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType
An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style.
setStk(byte) - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType
Sets the stk field value.
setStorageClsid(ClassID) - Method in interface org.apache.poi.poifs.filesystem.DirectoryEntry
Sets the storage clsid for the directory entry
setStorageClsid(ClassID) - Method in class org.apache.poi.poifs.filesystem.DirectoryNode
Sets the storage clsid for the directory entry
setStorageClsid(ClassID) - Method in class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

setStorageClsid(ClassID) - Method in class org.apache.poi.poifs.property.Property
Sets the storage class ID for this property stream.
setStr(HSSFRichTextString) - Method in class org.apache.poi.hssf.record.TextObjectRecord

setStrike(boolean) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that the contents of this run shall be displayed with a single horizontal line through the center of the line.
setStrikeout(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting
set the font to be stricken out or not
setStrikeout(boolean) - Method in class org.apache.poi.hssf.record.FontRecord
set the font to be stricken out or not
setStrikeout(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set whether to use a strikeout horizontal line through the text or not
setStrikeout(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setStrikeout(boolean) - Method in interface org.apache.poi.ss.usermodel.Font
set whether to use a strikeout horizontal line through the text or not
setStrikeout(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set a boolean value for the property specifying whether to use a strikeout horizontal line through the text or not If omitted, the default value is true.
setStrikethrough(boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the strikethrough flag
setStrikethrough(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun
Specifies whether a run of text will be formatted as strikethrough text.
setString(String) - Method in class org.apache.poi.hssf.record.common.UnicodeString
set the actual string this contains
setString(String) - Method in class org.apache.poi.hssf.record.StringRecord
Sets the string represented by this record.
setString(RichTextString) - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Sets the rich text string used by this comment.
setString(RichTextString) - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox

setString(RichTextString) - Method in interface org.apache.poi.ss.usermodel.Comment
Sets the rich text string used by this comment.
setString(RichTextString) - Method in interface org.apache.poi.ss.usermodel.Textbox

setString(RichTextString) - Method in class org.apache.poi.xssf.usermodel.XSSFComment
Sets the rich text string used by this comment.
setString(String) - Method in class org.apache.poi.xssf.usermodel.XSSFComment

setString(String) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Removes any formatting and sets new string value
setStringCount(short) - Method in class org.apache.poi.hwpf.model.FontTable

setStroke(Stroke) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the Stroke for the Graphics2D context.
setStroke(Stroke) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setStroke(Stroke) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setStyle(int) - Method in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
Set the style of this dropdown.
setStyle(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
This method provides a style to the paragraph This is useful when, e.g.
setStyle(CTStyle) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
set style
setStyleId(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
set styleID
setStyleID(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable
Set the table style.
setStyles(CTStyles) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
Sets the ctStyles
setStylesTableReference(StylesTable) - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString

setSubdocumentTextStreamLength(SubdocumentType, int) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

setSubject(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the subject.
setSubject(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setSubjectProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set subject.
setSubjectProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the topic of the content of the resource.
setSubjectProperty(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setSubscript(VerticalAlign) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text.
setSubSuperScriptIndex(short) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setSubSuperScriptIndex(short) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setSubType(int) - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Sets the type of OLE object.
setSubValue(boolean, int) - Method in class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
Set the true/false status of the subproperty with the given index
setSupbookpos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList
Sets the supbookpos.
setSuperscript(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the subscript/superscript option
setSuperSubScript(short) - Method in class org.apache.poi.hssf.record.FontRecord
set the type of super or subscript for the font
setSuppressDropDownArrow(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFDataValidation

setSuppressDropDownArrow(boolean) - Method in interface org.apache.poi.ss.usermodel.DataValidation
Useful for list validation objects .
setSuppressDropDownArrow(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidation

setSwHMF(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field is unused and MUST be ignored.
setTabColor(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Set background color of the sheet tab
setTabIdArray(short[]) - Method in class org.apache.poi.hssf.record.TabIdRecord
set the tab array.
setTable(int, XWPFTable) - Method in class org.apache.poi.xwpf.usermodel.XWPFDocument
Replace content of table in array tables at position pos with a
setTableCellProperties(TableRow, TableCell, Element, boolean, boolean, boolean, boolean) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setTableHeader(boolean) - Method in class org.apache.poi.hwpf.usermodel.TableRow

setTableRowProperties(TableRow, Element) - Static method in class org.apache.poi.hwpf.converter.WordToFoUtils

setTabpos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setTabWidthRatio(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
ratio of the width of the tabs to the horizontal scrollbar
setTag(short) - Method in class org.apache.poi.ddf.EscherBSERecord
unused
setTarget(LayoutTarget) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Sets the layout target.
setTarget(LayoutTarget) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setTemplate(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the template.
setText(String) - Method in class org.apache.poi.hpbf.model.qcbits.QCTextBit

setText(String) - Method in class org.apache.poi.hslf.model.Comment
Set the text of this comment
setText(String) - Method in class org.apache.poi.hslf.model.TextRun
Changes the text.
setText(String) - Method in class org.apache.poi.hslf.model.TextShape
Sets the text contained in this text frame.
setText(String) - Method in class org.apache.poi.hslf.record.Comment2000
Set the text of this comment
setText(String) - Method in class org.apache.poi.hslf.record.CString
Updates the text in the Atom.
setText(byte[]) - Method in class org.apache.poi.hslf.record.TextBytesAtom
Updates the text in the Atom.
setText(String) - Method in class org.apache.poi.hslf.record.TextCharsAtom
Updates the text in the Atom.
setText(String) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Change the text
setText(String) - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord
Set the text field for the SeriesText record.
setText(String) - Method in class org.apache.poi.hssf.record.ExternalNameRecord

setText(String) - Method in class org.apache.poi.hssf.record.HeaderFooterBase
set the footer string
setText(String) - Method in interface org.apache.poi.sl.usermodel.TextRun

setText(String) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

setText(String) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

setText(String) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter

setText(String) - Method in class org.apache.poi.xssf.usermodel.XSSFEvenFooter
Set a text for the footer.
setText(String) - Method in class org.apache.poi.xssf.usermodel.XSSFEvenHeader
Set a text for the header.
setText(String) - Method in class org.apache.poi.xssf.usermodel.XSSFFirstFooter
Set a text for the footer.
setText(String) - Method in class org.apache.poi.xssf.usermodel.XSSFFirstHeader
Set a text for the header.
setText(String) - Method in class org.apache.poi.xssf.usermodel.XSSFOddFooter
Set a text for the footer.
setText(String) - Method in class org.apache.poi.xssf.usermodel.XSSFOddHeader
Set a text for the header.
setText(XSSFRichTextString) - Method in class org.apache.poi.xssf.usermodel.XSSFSimpleShape

setText(int) - Method in class org.apache.poi.xwpf.usermodel.PositionInParagraph

setText(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Sets the text of this text run
setText(String, int) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Sets the text of this text run in the
setText(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell

setTextAlign(TextAlign) - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph
Specifies the alignment that is to be applied to the paragraph.
setTextAndLinesColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Text And Lines Colour
setTextAutofit(TextAutofit) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Specifies that a shape should be auto-fit to fully contain the text described within it.
setTextDirection(TextDirection) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

setTextId(int) - Method in class org.apache.poi.hslf.model.TextShape
Sets text ID
setTextIndex(int) - Method in class org.apache.poi.hslf.record.OutlineTextRefAtom
Sets text's index within the SlideListWithText container (0 for title, 1..n for the nth body).
setTextLocked(boolean) - Method in class org.apache.poi.hssf.record.TextObjectRecord
Sets the text locked field value.
setTextMark(String) - Method in class org.apache.poi.hssf.record.HyperlinkRecord

setTextMark(String) - Method in class org.apache.poi.hssf.usermodel.HSSFHyperlink
Convenience method equivalent to HSSFHyperlink.setAddress(String)
setTextOffset(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Sets the text offset
setTextOrientation(int) - Method in class org.apache.poi.hssf.record.TextObjectRecord
Set the text orientation field for the TextObjectBase record.
setTextPosition(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
This element specifies the amount by which text shall be raised or lowered for this run in relation to the default baseline of the surrounding non-positioned text.
setTextRotation(short) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the text rotation field for the Text record.
setTextRotation(long) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Set the degree of rotation for the text in the cell
Expressed in degrees.
setTextSize(int) - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom
Update the text length
setTextType(int) - Method in class org.apache.poi.hslf.record.TextHeaderAtom

setTheme(ThemesTable) - Method in class org.apache.poi.xssf.model.StylesTable

setTheme(int) - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Index into the collection, referencing a particular or value expressed in the Theme part.
setThemeColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the theme color for the font to use
setThemesTable(ThemesTable) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.
setThemesTable(ThemesTable) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.
setThreadPrefersEventExtractors(boolean) - Static method in class org.apache.poi.extractor.ExtractorFactory
Should this thread prefer event based over usermodel based extractors? Will only be used if the All Threads setting is null.
setThumbnail(byte[]) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the thumbnail.
setThumbnail(byte[]) - Method in class org.apache.poi.hpsf.Thumbnail
Sets the Thumbnail's underlying byte[] in VT_CF format.
setTickColor(short) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the tick color field for the Tick record.
setTickMarkFrequency(short) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Set the tick mark frequency field for the CategorySeriesAxis record.
SETTINGS - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

setTint(double) - Method in class org.apache.poi.xssf.usermodel.XSSFColor
Specifies the tint value applied to the ctColor.
setTitle(String) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the title.
setTitle(String) - Method in class org.apache.poi.hslf.model.Hyperlink

setTitle(String) - Method in class org.apache.poi.hssf.record.common.FeatProtection

setTitle(String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setTitle(String) - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

setTitle(String) - Method in class org.apache.poi.hwpf.converter.TextDocumentFacade

setTitle(String) - Method in class org.apache.poi.POIXMLProperties.CoreProperties

setTitleProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set title.
setTitleProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the name given to the resource.
setTitleTextColourRGB(int) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Set the RGB value for Title Text Colour
setTlc(byte) - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Sets the tlc field value.
setTlp(TableAutoformatLookSpecifier) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Table look specifier.
setTlp_flags(byte) - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType
Set the tlp_flags field for the TLP record.
setTmEdited(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the tmEdited field for the DOP record.
setTo(CTMarker) - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

setTooltip(String) - Method in class org.apache.poi.xssf.usermodel.XSSFHyperlink

setTopBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setTopBorder(BorderCode) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setTopBorderColor(int) - Method in class org.apache.poi.hssf.record.cf.BorderFormatting
set the color to use for the top border
setTopBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

setTopBorderColor(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the color to use for the top border
setTopBorderColor(short, Region, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Deprecated. (Aug 2008) use CellRangeAddress instead of Region
setTopBorderColor(int, CellRangeAddress, HSSFSheet, HSSFWorkbook) - Static method in class org.apache.poi.hssf.util.HSSFRegionUtil
Sets the topBorderColor attribute of the HSSFRegionUtil object
setTopBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.BorderFormatting

setTopBorderColor(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the color to use for the top border
setTopBorderColor(int, CellRangeAddress, Sheet, Workbook) - Static method in class org.apache.poi.ss.util.RegionUtil
Sets the topBorderColor attribute of the RegionUtil object
setTopBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

setTopBorderColor(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the top border
setTopBorderColor(XSSFColor) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the color to use for the top border as a XSSFColor value
setTopBorderModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setTopBorderPaletteIdx(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the palette index for the top border
setTopColGutter(short) - Method in class org.apache.poi.hssf.record.GutsRecord
set the size of the gutter that appears at the above the columns
setTopInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setTopInset(double) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Sets the top margin.
setTopLeftBottomRightBorderModified(boolean) - Method in class org.apache.poi.hssf.record.CFRuleRecord

setTopRow(short) - Method in class org.apache.poi.hssf.model.InternalSheet

setTopRow(short) - Method in class org.apache.poi.hssf.record.PaneRecord
Set the top row field for the Pane record.
setTopRow(short) - Method in class org.apache.poi.hssf.record.WindowTwoRecord
set the top row visible in the window
setTplc(int) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes.
setTransform(AffineTransform) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the Transform in the Graphics2D context.
setTransform(AffineTransform) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setTransform(AffineTransform) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setTraverseEmptyCells(boolean) - Method in class org.apache.poi.ss.util.cellwalk.CellWalk
Sets the traverseEmptyCells property.
setTruncatePropertyData(boolean) - Method in class org.apache.poi.hmef.dev.HMEFDumper

setType(long) - Method in class org.apache.poi.hpsf.MutableProperty
Sets the property's type.
setType(int) - Method in class org.apache.poi.hslf.model.Hyperlink

setType(int) - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Sets whether the object is embedded or linked.
setType(int) - Method in class org.apache.poi.hssf.record.BOFRecord
type of object this marks
setType(byte) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Set the type field for the Legend record.
setType(STStyleType.Enum) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyle
set styleType
setTypeOfCharFollowingTheNumber(byte) - Method in class org.apache.poi.hwpf.model.ListLevel

setTypeOffset(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set normal,super or subscript.
setTypeOffset(short) - Method in interface org.apache.poi.ss.usermodel.Font
set normal,super or subscript.
setTypeOffset(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set normal,super or subscript, that representing the vertical-alignment setting.
setUfel(short) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Collection properties represented by itypFELayout and copt (East Asian layout properties).
setUID(byte[]) - Method in class org.apache.poi.ddf.EscherBitmapBlip

setUid(byte[]) - Method in class org.apache.poi.ddf.EscherBSERecord
16 byte MD4 checksum.
setUID(byte[]) - Method in class org.apache.poi.ddf.EscherMetafileBlip

setUID(byte[]) - Method in class org.apache.poi.ddf.EscherPictBlip

setUncalced(boolean) - Method in class org.apache.poi.hssf.model.InternalSheet

setUncompressedSize(int) - Method in class org.apache.poi.ddf.EscherMetafileBlip

setUncompressedSize(int) - Method in class org.apache.poi.ddf.EscherPictBlip

setUnderline(byte) - Method in class org.apache.poi.hssf.record.FontRecord
set the type of underlining for the font
setUnderline(byte) - Method in class org.apache.poi.hssf.usermodel.HSSFFont
set type of text underlining to use
setUnderline(byte) - Method in interface org.apache.poi.ss.usermodel.Font
set type of text underlining to use
setUnderline(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

setUnderline(byte) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set the style of underlining that is used.
setUnderline(FontUnderline) - Method in class org.apache.poi.xssf.usermodel.XSSFFont
set an enumeration representing the style of underlining that is used.
setUnderline(UnderlinePatterns) - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy.
setUnderlineCode(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setUnderlineCode(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setUnderlined(boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Is the text underlined?
setUnderlineType(short) - Method in class org.apache.poi.hssf.record.cf.FontFormatting
set the type of underlining type for the font
setUnderlineType(short) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
set the type of underlining type for the font
setUnderlineType(short) - Method in interface org.apache.poi.ss.usermodel.FontFormatting
set the type of underlining type for the font
setUnderlineType(short) - Method in class org.apache.poi.xssf.usermodel.XSSFFontFormatting
set the type of underlining type for the font
setUnderlineTypeModified(boolean) - Method in class org.apache.poi.hssf.record.cf.FontFormatting

setUnderlineTypeModified(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFFontFormatting

setUnits(short) - Method in class org.apache.poi.hssf.record.chart.UnitsRecord
Set the units field for the Units record.
setUnknown(boolean) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Sets the unknown field value.
setUnused(boolean) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Sets the unused field value.
setUnused(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
This value is undefined and MUST be ignored.
setUnused(boolean) - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
Sets the unused field value.
setUnused1(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the unused1 field value.
setUnused1(short) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Sets the unused1 field value.
setUnused1(boolean) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Sets the unused1 field value.
setUnused1(boolean) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
Sets the unused1 field value.
setUnused2(byte) - Method in class org.apache.poi.ddf.EscherBSERecord

setUnused2(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the unused2 field for the DOP record.
setUnused2(byte) - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
Sets the unused2 field value.
setUnused2(boolean) - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType
Sets the unused2 field value.
setUnused2(int) - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType
This field MUST be ignored.
setUnused2(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the unused2 field for the SEP record.
setUnused3(byte) - Method in class org.apache.poi.ddf.EscherBSERecord

setUnused3(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the unused3 field value.
setUnused3(short) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the unused3 field for the SEP record.
setUnused4(boolean) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the unused4 field value.
setUnused4(short) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the unused4 field for the SEP record.
setUnused5(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the unused5 field value.
setUnused5(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the unused5 field for the SEP record.
setUnused6(short) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the unused6 field for the SEP record.
setup(String[], WorkbookEvaluator[]) - Static method in class org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment

setUpdateFields() - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings
Enforces fields update on document open (in Word).
setupEnvironment(String[], HSSFFormulaEvaluator[]) - Static method in class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.
setupEnvironment(String[], ForkedEvaluator[]) - Static method in class org.apache.poi.ss.formula.eval.forked.ForkedEvaluator
Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.
setURL(String) - Method in class org.apache.poi.hssf.record.SupBookRecord

setUsage(byte) - Method in class org.apache.poi.ddf.EscherBSERecord
Defines the way this blip is used.
setUseDivsToSpan(boolean) - Method in class org.apache.poi.hssf.converter.ExcelToHtmlConverter
Allows converter to wrap content into two additional DIVs with tricky styles, so it will wrap across empty cells (like in Excel).
setUseExcel4Colors(boolean) - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord
Sets the use excel 4 colors field value.
setUsePage(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setUsePage(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Set whether to use page start
setUsePage(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Set whether to use page start
setUsePage(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Set whether to use page start
setUserDateVisible(boolean) - Method in class org.apache.poi.hslf.model.HeadersFooters
whether the date is displayed in the footer.
setUsername(String) - Method in class org.apache.poi.hssf.record.FileSharingRecord

setUsername(String) - Method in class org.apache.poi.hssf.record.WriteAccessRecord
set the username for the user that created the report.
setUserStyleName(String) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Sets the name of the user defined style.
setValidSettings(boolean) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setValidSettings(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Valid settings.
setValidSettings(boolean) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Valid settings.
setValidSettings(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Use the printer's defaults settings for page setup values and don't use the default values specified in the schema.
setValue(Object) - Method in class org.apache.poi.hpsf.MutableProperty
Sets the property's value.
setValue(int) - Method in class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
Set the value of the text property, and recompute the sub properties based on it
setValue(int) - Method in class org.apache.poi.hslf.model.textproperties.TextProp
Set the value of the text property.
setValue(byte[]) - Method in class org.apache.poi.hsmf.datatypes.ByteChunk

setValue(String) - Method in class org.apache.poi.hsmf.datatypes.StringChunk

setValue(boolean) - Method in class org.apache.poi.hssf.record.BoolErrRecord
set the boolean value for the cell
setValue(byte) - Method in class org.apache.poi.hssf.record.BoolErrRecord
set the error value for the cell
setValue(double) - Method in class org.apache.poi.hssf.record.FormulaRecord
set the calculated value of the formula
setValue(double) - Method in class org.apache.poi.hssf.record.NumberRecord
set the value for the cell
setValue(int) - Method in class org.apache.poi.hwpf.model.Colorref

setValue(short) - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType
Set the value field for the SHD80 record.
setValue(byte) - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType
Set the value field for the TBD record.
setValue(int, int) - Method in class org.apache.poi.util.BitField
Replace the bits with new values.
setValue(T) - Method in class org.apache.poi.xslf.model.PropertyFetcher

setValue1(double) - Method in class org.apache.poi.hssf.usermodel.DVConstraint
Sets a numeric value for expression 1.
setValue2(double) - Method in class org.apache.poi.hssf.usermodel.DVConstraint
Sets a numeric value for expression 2.
setValueAt(int, int) - Method in class org.apache.poi.poifs.storage.BATBlock

setValueAxisCrossing(boolean) - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
Sets the value axis crossing field value.
setValueRange(int, Double, Double, Double, Double) - Method in class org.apache.poi.hssf.usermodel.HSSFChart
Set value range (basic Axis Options)
setValuesCellRange(CellRangeAddressBase) - Method in class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

setValuesDataType(short) - Method in class org.apache.poi.hssf.record.chart.SeriesRecord
Set the values data type field for the Series record.
setValuesInReverse(boolean) - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord
Sets the values in reverse field value.
setVanished(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setVanished(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setVaryDisplayPattern(boolean) - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

setVCenter(boolean) - Method in class org.apache.poi.hssf.record.VCenterRecord
set whether to center vertically or not
setVersion(short) - Method in class org.apache.poi.ddf.EscherOptRecord

setVersion(short) - Method in class org.apache.poi.ddf.EscherRecord
Sets the version part of record
setVersion(int) - Method in class org.apache.poi.hssf.record.BOFRecord
Version number - for BIFF8 should be 0x06
setVersionProperty(String) - Method in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
Set version.
setVersionProperty(String) - Method in interface org.apache.poi.openxml4j.opc.PackageProperties
Set the version number.
setVertAlign(byte) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Sets the vertAlign field value.
setVertical(boolean) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Sets the vertical field value.
setVertical(boolean) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Sets the vertical field value.
setVertical(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setVertical(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setVertical(VerticalAlignment) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Set the type of vertical alignment for the cell
setVerticalAlignment(int) - Method in class org.apache.poi.hslf.model.TextShape
Sets the type of vertical alignment for the text.
setVerticalAlignment(byte) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the vertical alignment field for the Text record.
setVerticalAlignment(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set the vertical alignment of text in the cell
setVerticalAlignment(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set the type of vertical alignment for the cell
setVerticalAlignment(short) - Method in class org.apache.poi.hssf.usermodel.HSSFTextbox
Sets the vertical alignment.
setVerticalAlignment(short) - Method in interface org.apache.poi.ss.usermodel.CellStyle
set the type of vertical alignment for the cell
setVerticalAlignment(VerticalAlignment) - Method in class org.apache.poi.xslf.usermodel.XSLFTableCell

setVerticalAlignment(VerticalAlignment) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape
Sets the type of vertical alignment for the text.
setVerticalAlignment(short) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of vertical alignment for the cell
setVerticalAlignment(VerticalAlignment) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set the type of vertical alignment for the cell
setVerticalAlignment(TextAlignment) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
Specifies the text vertical alignment which shall be applied to text in this paragraph.
setVerticalAlignment(XWPFTableCell.XWPFVertAlign) - Method in class org.apache.poi.xwpf.usermodel.XWPFTableCell
Set the vertical alignment of the cell.
setVerticalBorder(boolean) - Method in class org.apache.poi.hssf.record.chart.DatRecord
Sets the vertical border field value.
setVerticalHold(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set the vertical position of the window (in 1/20ths of a point)
setVerticallyCenter(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
determines whether the output is vertically centered on the page.
setVerticallyCenter(boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Determines whether the output is vertically centered on the page.
setVerticallyCenter(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Determines whether the output is vertically centered on the page.
setVerticallyCenter(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Whether the output is vertically centered on the page.
setVerticalOffset(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

setVerticalOffset(int) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

setVerticalPos(int) - Method in class org.apache.poi.hssf.record.DVALRecord

setVerticalScale(int) - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord
Set the verticalScale field for the PlotGrowth record.
setVerticalTextAlignment(int) - Method in class org.apache.poi.hssf.record.TextObjectRecord
Sets the Vertical text alignment field value.
setVeryHidden(boolean) - Method in class org.apache.poi.hssf.record.BoundSheetRecord
Is the sheet very hidden? Different from (normal) hidden
setView(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the view field for the DOP record.
setViewFlags(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Used internally by Word.
setViewFlags_unused1(boolean) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the viewFlags_unused1 field value.
setViewFlags_unused2(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the viewFlags_unused2 field value.
setVirusinfo(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the virusinfo field for the DOP record.
setVisible(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFComment
Returns whether this comment is visible.
setVisible(boolean) - Method in interface org.apache.poi.ss.usermodel.Comment
Returns whether this comment is visible.
setVisible(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFComment

setVjc(byte) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the vjc field for the SEP record.
setVResolution(short) - Method in class org.apache.poi.hssf.record.PrintSetupRecord

setVResolution(short) - Method in class org.apache.poi.hssf.usermodel.HSSFPrintSetup
Sets the vertical resolution.
setVResolution(short) - Method in interface org.apache.poi.ss.usermodel.PrintSetup
Sets the vertical resolution.
setVResolution(short) - Method in class org.apache.poi.xssf.usermodel.XSSFPrintSetup
Sets the vertical resolution.
setWAlignFont(int) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the wAlignFont field for the PAP record.
setWCellPaddingBottom(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell margin/padding.
setWCellPaddingDefaultBottom(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell margin/padding.
setWCellPaddingDefaultLeft(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell margin/padding.
setWCellPaddingDefaultRight(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell margin/padding.
setWCellPaddingDefaultTop(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell margin/padding.
setWCellPaddingLeft(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell margin/padding.
setWCellPaddingOuterBottom(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell margin/padding.
setWCellPaddingOuterLeft(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell margin/padding.
setWCellPaddingOuterRight(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell margin/padding.
setWCellPaddingOuterTop(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell margin/padding.
setWCellPaddingRight(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell margin/padding.
setWCellPaddingTop(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell margin/padding.
setWCellSpacingBottom(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Bottom cell spacing.
setWCellSpacingDefaultBottom(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default bottom cell spacings.
setWCellSpacingDefaultLeft(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default left cell spacings.
setWCellSpacingDefaultRight(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default right cell spacings.
setWCellSpacingDefaultTop(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default top cell spacings.
setWCellSpacingLeft(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Left cell spacing.
setWCellSpacingOuterBottom(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer bottom cell spacing.
setWCellSpacingOuterLeft(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer left cell spacing.
setWCellSpacingOuterRight(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer right cell spacing.
setWCellSpacingOuterTop(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Default outer top cell spacing.
setWCellSpacingRight(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Right cell spacing.
setWCellSpacingTop(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Top cell spacing.
setWCharScale(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
Set the wCharScale field for the CHP record.
setWConflict(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When != 0, index number that identifies all text participating in a particular conflict incident.
setWeight(short) - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord
Set the weight field for the LineFormat record.
setWIdent(int) - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType
An unsigned integer that specifies that this is a Word Binary File.
setWidowControl(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setWidowControl(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setWidth(int) - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
Set the width of the metafile in EMU's (English Metric Units).
setWidth(int) - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Set the width field for the AxisParent record.
setWidth(int) - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

setWidth(int) - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Set the width field for the Chart record.
setWidth(int) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the width field for the Text record.
setWidth(short) - Method in class org.apache.poi.hssf.record.WindowOneRecord
set the width of the window
setWidth(int) - Method in class org.apache.poi.xwpf.usermodel.XWPFTable

setWidthAndFitsFlags(int) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Set the widthAndFitsFlags field for the TAP record.
setWidthAndFitsFlags_empty1(byte) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the widthAndFitsFlags_empty1 field value.
setWidthAndFitsFlags_empty2(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Sets the widthAndFitsFlags_empty2 field value.
setWidthMode(LayoutMode) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Specifies how to interpret the Width element for this manual layout.
setWidthMode(LayoutMode) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setWidthRatio(double) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Specifies the width (if Width Mode is Factor) or right (if Width Mode is Edge) of the chart element as a fraction of the width of the chart.
setWidthRatio(double) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setWindowing(short) - Method in class org.apache.poi.hssf.record.DateWindow1904Record
sets whether or not to use 1904 date windowing (which means you'll be screwed in 2004)
setWordCount(int) - Method in class org.apache.poi.hpsf.SummaryInformation
Sets the word count.
setWordWrap(int) - Method in class org.apache.poi.hslf.model.TextShape
Specifies how the text should be wrapped
setWordWrap(boolean) - Method in class org.apache.poi.xslf.usermodel.XSLFTextShape

setWordWrap(boolean) - Method in class org.apache.poi.xwpf.usermodel.XWPFParagraph
This element specifies whether a consumer shall break Latin text which exceeds the text extents of a line by breaking the word across two lines (breaking on the character level) or by moving the word to the following line (breaking on the word level).
setWordWrapped(boolean) - Method in class org.apache.poi.hwpf.usermodel.Paragraph

setWordWrapped(boolean) - Method in class org.apache.poi.hwpf.usermodel.ParagraphProperties

setWr(byte) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the wr field value.
setWr(byte) - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType
Set the wr field for the PAP record.
setWrapText(boolean) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether to wrap the text in the cell
setWrapText(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
set whether the text should be wrapped
setWrapText(boolean) - Method in interface org.apache.poi.ss.usermodel.CellStyle
Set whether the text should be wrapped.
setWrapText(boolean) - Method in class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Set whether the text should be wrapped
setWrapText(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Set whether the text should be wrapped.
setWrk(byte) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Sets the wrk field value.
setWSBool1(byte) - Method in class org.apache.poi.hssf.record.WSBoolRecord
set first byte (see bit setters)
setWSBool2(byte) - Method in class org.apache.poi.hssf.record.WSBoolRecord
set the second byte (see bit setters)
setWScaleSaved(short) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the wScaleSaved field value.
setWSpare(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the wSpare field for the DOP record.
setWSpare2(int) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Set the wSpare2 field for the DOP record.
setWTextFlow(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the wTextFlow field for the SEP record.
setWvkSaved(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the wvkSaved field value.
setWWidth(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Preferred table width.
setWWidth(short) - Method in class org.apache.poi.hwpf.model.types.TCAbstractType
Preferred cell width.
setWWidthAfter(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Width of invisible cell (used for layout purposes) after the last visible cell in the row..
setWWidthBefore(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Width of invisible cell (used for layout purposes) before the first visible cell in the row..
setWWidthIndent(short) - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType
Left Indent.
setX(int) - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Set the x field for the AxisParent record.
setX(int) - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Set the x field for the Chart record.
setX(int) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the x field for the Text record.
setX(short) - Method in class org.apache.poi.hssf.record.PaneRecord
Set the x field for the Pane record.
setX(double) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Specifies the x location (left) of the chart element as a fraction of the width of the chart.
setX(double) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setXaLeft(int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Left of rectangle enclosing shape relative to the origin of the shape.
setXaPage(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the xaPage field for the SEP record.
setXaPageNUp(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the xaPageNUp field for the SEP record.
setXaRight(int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Right of rectangle enclosing shape relative to the origin of the shape.
setXAxisUpperLeft(int) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Set the x axis upper left field for the Legend record.
setXBasis(short) - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Set the x Basis field for the FontBasis record.
setXBATCount(int) - Method in class org.apache.poi.poifs.storage.HeaderBlock
Sets the number of XBAT (DIFAT) blocks used
setXBATStart(int) - Method in class org.apache.poi.poifs.storage.HeaderBlock
Sets the first XBAT (DIFAT) block location
setXchSym(int) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..
setXExt(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field is unused and MUST be ignored.
setXFIndex(short) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

setXFIndex(short) - Method in class org.apache.poi.hssf.record.BlankRecord
set the index of the extended format record to style this cell with
setXFIndex(short) - Method in class org.apache.poi.hssf.record.CellRecord
set the index to the ExtendedFormat
setXFIndex(short) - Method in interface org.apache.poi.hssf.record.CellValueRecordInterface

setXFIndex(int) - Method in class org.apache.poi.hssf.record.ColumnInfoRecord
set the columns' default format info
setXFIndex(short) - Method in class org.apache.poi.hssf.record.LabelRecord
no op!
setXFIndex(short) - Method in class org.apache.poi.hssf.record.RowRecord
if the row is formatted then this is the index to the extended format record
setXFIndex(int) - Method in class org.apache.poi.hssf.record.StyleRecord
set the actual index of the style extended format record
setXfpos(int) - Method in class org.apache.poi.hssf.model.WorkbookRecordList

setXFType(short) - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord
set whether the cell is a cell or style XFRecord
setXMode(LayoutMode) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Sets the x-coordinate layout mode.
setXMode(LayoutMode) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setXmpProperty(String, String) - Method in class org.apache.poi.hwpf.converter.FoDocumentFacade

setXOffset(int) - Method in class org.apache.poi.hslf.record.Comment2000Atom
Sets the X offset of the comment on the page.
setXORMode(Color) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Sets the paint mode of this graphics context to alternate between this graphics context's current color and the new specified color.
setXORMode(Color) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

setXORMode(Color) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

setXORMode(Color) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

setXPosition(int) - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

setXSize(int) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Set the x size field for the Legend record.
setXstDispFldRMark(byte[]) - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType
The string value of the ListNum field when revision mark tracking began.
setXWPFDocument(XWPFDocument) - Method in class org.apache.poi.xwpf.usermodel.XWPFFootnotes

setXWPFDocument(XWPFDocument) - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

setY(int) - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord
Set the y field for the AxisParent record.
setY(int) - Method in class org.apache.poi.hssf.record.chart.ChartRecord
Set the y field for the Chart record.
setY(int) - Method in class org.apache.poi.hssf.record.chart.TextRecord
Set the y field for the Text record.
setY(short) - Method in class org.apache.poi.hssf.record.PaneRecord
Set the y field for the Pane record.
setY(double) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Specifies the y location (top) of the chart element as a fraction of the height of the chart.
setY(double) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setYaBottom(int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Bottom of the rectangle enclosing shape relative to the origin of the shape.
setYaPage(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the yaPage field for the SEP record.
setYaPageNUp(int) - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType
Set the yaPageNUp field for the SEP record.
setYaTop(int) - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType
Top of rectangle enclosing shape relative to the origin of the shape.
setYAxisUpperLeft(int) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Set the y axis upper left field for the Legend record.
setYBasis(short) - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord
Set the y Basis field for the FontBasis record.
setYExt(short) - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType
This field is unused and MUST be ignored.
setYMode(LayoutMode) - Method in interface org.apache.poi.ss.usermodel.charts.ManualLayout
Sets the y-coordinate layout mode.
setYMode(LayoutMode) - Method in class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

setYOffset(int) - Method in class org.apache.poi.hslf.record.Comment2000Atom
Sets the Y offset of the comment on the page.
setYPosition(int) - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

setYSize(int) - Method in class org.apache.poi.hssf.record.chart.LegendRecord
Set the y size field for the Legend record.
setZero1(int) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the zero 1 field for the Tick record.
setZero2(int) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the zero 2 field for the Tick record.
setZero3(short) - Method in class org.apache.poi.hssf.record.chart.TickRecord
Set the zero 3 field for the Tick record.
setZeroHeight(boolean) - Method in class org.apache.poi.hssf.record.RowRecord
set whether or not to display this row with 0 height
setZeroHeight(boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFRow
set whether or not to display this row with 0 height
setZeroHeight(boolean) - Method in interface org.apache.poi.ss.usermodel.Row
Set whether or not to display this row with 0 height
setZeroHeight(boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFRow
Set whether or not to display this row with 0 height
setZeroHeight(boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
Set whether or not to display this row with 0 height
setZipEntry(ZipEntry) - Method in class org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext

setZkSaved(byte) - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType
Sets the zkSaved field value.
setZoom(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets the zoom magnification for the sheet.
setZoom(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets the zoom magnication for the sheet.
setZoom(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets the zoom magnication for the sheet.
setZoom(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Sets the zoom magnication for the sheet.
setZoom(int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Window zoom magnification for current view representing percent values.
setZoomPercent(long) - Method in class org.apache.poi.xwpf.usermodel.XWPFSettings
Set zoom.
In the zoom tag inside settings.xml file
it sets the value of zoom
sample snippet from settings.xml
SEVEN_BIT_DISPLAY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SFXTTEXT_BACKGROUND_BLINK - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

SFXTTEXT_LAS_VEGAS_LIGHTS - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

SFXTTEXT_MARCHING_ANTS - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

SFXTTEXT_MARCHING_RED_ANTS - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

SFXTTEXT_NO - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

SFXTTEXT_SHIMMER - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

SFXTTEXT_SPARKLE_TEXT - Static variable in class org.apache.poi.hwpf.model.types.CHPAbstractType

ShadingDescriptor - Class in org.apache.poi.hwpf.usermodel
The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
ShadingDescriptor() - Constructor for class org.apache.poi.hwpf.usermodel.ShadingDescriptor

ShadingDescriptor(byte[], int) - Constructor for class org.apache.poi.hwpf.usermodel.ShadingDescriptor

ShadingDescriptor80 - Class in org.apache.poi.hwpf.usermodel
The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.
ShadingDescriptor80() - Constructor for class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

ShadingDescriptor80(byte[], int) - Constructor for class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

ShadingDescriptor80(short) - Constructor for class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

SHADOW_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

SHADOWSTYLE__COLOR - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__CRMOD - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__HIGHLIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__OFFSETX - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__OFFSETY - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__OPACITY - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__ORIGINX - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__ORIGINY - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__PERSPECTIVEX - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__PERSPECTIVEY - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SCALEXTOX - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SCALEXTOY - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SCALEYTOX - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SCALEYTOY - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SECONDOFFSETX - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SECONDOFFSETY - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SHADOW - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__SHADOWOBSURED - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__TYPE - Static variable in class org.apache.poi.ddf.EscherProperties

SHADOWSTYLE__WEIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

shape - Variable in class org.apache.poi.hslf.model.Fill
The shape this background applies to
Shape - Class in org.apache.poi.hslf.model
Represents a Shape which is the elemental object that composes a drawing.
Shape(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Shape
Create a Shape object.
Shape - Class in org.apache.poi.hwpf.usermodel
Deprecated. Use OfficeDrawing instead
Shape(GenericPropertyNode) - Constructor for class org.apache.poi.hwpf.usermodel.Shape
Deprecated.
Shape - Interface in org.apache.poi.sl.usermodel

SHAPE__BACKGROUNDSHAPE - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__BLACKANDWHITESETTINGS - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__CONNECTORSTYLE - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__DELETEATTACHEDOBJECT - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__LOCKSHAPETYPE - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__MASTER - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__OLEICON - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__PREFERRELATIVERESIZE - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__WMODEBW - Static variable in class org.apache.poi.ddf.EscherProperties

SHAPE__WMODEPUREBW - Static variable in class org.apache.poi.ddf.EscherProperties

ShapeContainer - Interface in org.apache.poi.sl.usermodel

ShapeFactory - Class in org.apache.poi.hslf.model
Create a Shape object depending on its type
ShapeFactory() - Constructor for class org.apache.poi.hslf.model.ShapeFactory

ShapeGroup - Class in org.apache.poi.hslf.model
Represents a group of shapes.
ShapeGroup() - Constructor for class org.apache.poi.hslf.model.ShapeGroup
Create a new ShapeGroup.
ShapeGroup(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.ShapeGroup
Create a ShapeGroup object and initilize it from the supplied Record container.
ShapeGroup - Interface in org.apache.poi.sl.usermodel

ShapeOutline - Interface in org.apache.poi.hslf.model
Date: Apr 17, 2008
ShapePainter - Class in org.apache.poi.hslf.model
Paint a shape into java.awt.Graphics2D
ShapePainter() - Constructor for class org.apache.poi.hslf.model.ShapePainter

shapes - Static variable in class org.apache.poi.hslf.model.AutoShapes

ShapesTable - Class in org.apache.poi.hwpf.model
Deprecated.
ShapesTable(byte[], FileInformationBlock) - Constructor for class org.apache.poi.hwpf.model.ShapesTable
Deprecated.
ShapeTypes - Class in org.apache.poi.hslf.model
Contains all known shape types in PowerPoint
ShapeTypes() - Constructor for class org.apache.poi.hslf.model.ShapeTypes

ShapeTypes - Interface in org.apache.poi.sl.usermodel

ShapeTypes - Class in org.apache.poi.ss.usermodel
All known types of automatic shapes in DrawingML
ShapeTypes() - Constructor for class org.apache.poi.ss.usermodel.ShapeTypes

SHARED - Static variable in class org.apache.poi.ss.formula.FormulaType

SHARED_STRINGS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

SharedFeature - Interface in org.apache.poi.hssf.record.common
Common Interface for all Shared Features
SHAREDFEATURES_ISFFACTOID - Static variable in class org.apache.poi.hssf.record.FeatHdrRecord
Specifies the smart tag type.
SHAREDFEATURES_ISFFEC2 - Static variable in class org.apache.poi.hssf.record.FeatHdrRecord
Specifies that formula errors should be ignored
SHAREDFEATURES_ISFLIST - Static variable in class org.apache.poi.hssf.record.FeatHdrRecord
Specifies the shared list type.
SHAREDFEATURES_ISFPROTECTION - Static variable in class org.apache.poi.hssf.record.FeatHdrRecord
Specifies the enhanced protection type.
SharedFormula - Class in org.apache.poi.ss.formula
Encapsulates logic to convert shared formulaa into non shared equivalent
SharedFormula(SpreadsheetVersion) - Constructor for class org.apache.poi.ss.formula.SharedFormula

SharedFormulaRecord - Class in org.apache.poi.hssf.record
Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
SharedFormulaRecord() - Constructor for class org.apache.poi.hssf.record.SharedFormulaRecord

SharedFormulaRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.SharedFormulaRecord

SharedStringsTable - Class in org.apache.poi.xssf.model
Table of strings shared across all sheets in a workbook.
SharedStringsTable() - Constructor for class org.apache.poi.xssf.model.SharedStringsTable

SharedStringsTable(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.model.SharedStringsTable

SharedValueManager - Class in org.apache.poi.hssf.record.aggregates
Manages various auxiliary records while constructing a RowRecordsAggregate: SharedFormulaRecords ArrayRecords TableRecords
SharedValueRecordBase - Class in org.apache.poi.hssf.record
Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.
SharedValueRecordBase(CellRangeAddress8Bit) - Constructor for class org.apache.poi.hssf.record.SharedValueRecordBase

SharedValueRecordBase() - Constructor for class org.apache.poi.hssf.record.SharedValueRecordBase

SharedValueRecordBase(LittleEndianInput) - Constructor for class org.apache.poi.hssf.record.SharedValueRecordBase
reads only the range (1 CellRangeAddress8Bit) from the stream
SHD80AbstractType - Class in org.apache.poi.hwpf.model.types
The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.
SHD80AbstractType() - Constructor for class org.apache.poi.hwpf.model.types.SHD80AbstractType

SHDAbstractType - Class in org.apache.poi.hwpf.model.types
The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
SHDAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.SHDAbstractType

shear(double, double) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Concatenates the current Graphics2D Transform with a shearing transform.
shear(double, double) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

shear(double, double) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

Sheet - Class in org.apache.poi.hslf.model
This class defines the common format of "Sheets" in a powerpoint document.
Sheet(SheetContainer, int) - Constructor for class org.apache.poi.hslf.model.Sheet

Sheet - Interface in org.apache.poi.sl.usermodel
Common parent of Slides, Notes and Masters
Sheet - Interface in org.apache.poi.ss.usermodel
High level representation of a Excel worksheet.
sheet - Variable in class org.apache.poi.xssf.usermodel.XSSFSheet

SHEET_COMMENTS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

SHEET_HYPERLINKS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

SHEET_STATE_HIDDEN - Static variable in interface org.apache.poi.ss.usermodel.Workbook
Indicates the book window is hidden, but can be shown by the user via the user interface.
SHEET_STATE_VERY_HIDDEN - Static variable in interface org.apache.poi.ss.usermodel.Workbook
Indicates the sheet is hidden and cannot be shown in the user interface (UI).
SHEET_STATE_VISIBLE - Static variable in interface org.apache.poi.ss.usermodel.Workbook
Indicates the sheet is visible.
SheetBuilder - Class in org.apache.poi.ss.util
Class SheetBuilder provides an easy way of building workbook sheets from 2D array of Objects.
SheetBuilder(Workbook, Object[][]) - Constructor for class org.apache.poi.ss.util.SheetBuilder

SheetConditionalFormatting - Interface in org.apache.poi.ss.usermodel
The 'Conditional Formatting' facet of Sheet
SheetContainer - Class in org.apache.poi.hslf.record
The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
SheetContainer() - Constructor for class org.apache.poi.hslf.record.SheetContainer

SheetDataWriter - Class in org.apache.poi.xssf.streaming
Initially copied from BigGridDemo "SpreadsheetWriter".
SheetDataWriter() - Constructor for class org.apache.poi.xssf.streaming.SheetDataWriter

SHEETEXT_0862 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

SheetNameFormatter - Class in org.apache.poi.ss.formula
Formats sheet names for use in formula expressions.
SHEETPR_0081 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

SheetProperties - Static variable in class org.apache.poi.hslf.record.RecordTypes

SheetPropertiesRecord - Class in org.apache.poi.hssf.record.chart
Describes a chart sheet properties record.
SheetPropertiesRecord() - Constructor for class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

SheetPropertiesRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

SHEETPROTECTION_0867 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

SheetReferences - Class in org.apache.poi.ss.util
Holds a collection of Sheet names and their associated reference numbers.
SheetReferences() - Constructor for class org.apache.poi.ss.util.SheetReferences

SheetUtil - Class in org.apache.poi.ss.util
Helper methods for when working with Usermodel sheets
SheetUtil() - Constructor for class org.apache.poi.ss.util.SheetUtil

shift(int) - Method in class org.apache.poi.xssf.usermodel.XSSFRow
update cell references when shifting rows
shiftColumnBreaks(short, short, short) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Shifts the vertical page breaks for the indicated count
shiftMerged(int, int, int, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Shifts the merged regions left or right depending on mode
shiftMerged(int, int, int) - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter
Shift merged regions
shiftRowBreaks(int, int, int) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock
Shifts the horizontal page breaks for the indicated count
shiftRows(int, int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int, boolean, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int, boolean, boolean, boolean) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int, boolean, boolean) - Method in interface org.apache.poi.ss.usermodel.Sheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int, boolean, boolean) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Shifts rows between startRow and endRow n number of rows.
shiftRows(int, int, int, boolean, boolean) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Shifts rows between startRow and endRow n number of rows.
SHORT - Static variable in class org.apache.poi.hsmf.datatypes.Types
I2 - signed 16-bit value
SHORT_SIZE - Static variable in interface org.apache.poi.util.LittleEndianConsts

shortArrayToByteArray(short[]) - Static method in class org.apache.poi.hwpf.sprm.SprmUtils

ShortField - Class in org.apache.poi.util
representation of a short (16-bit) field at a fixed location within a byte array
ShortField(int) - Constructor for class org.apache.poi.util.ShortField
construct the ShortField with its offset into its containing byte array
ShortField(int, short) - Constructor for class org.apache.poi.util.ShortField
construct the ShortField with its offset into its containing byte array and initialize its value
ShortField(int, byte[]) - Constructor for class org.apache.poi.util.ShortField
Construct the ShortField with its offset into its containing byte array and initialize its value from its byte array
ShortField(int, short, byte[]) - Constructor for class org.apache.poi.util.ShortField
construct the ShortField with its offset into its containing byte array, initialize its value, and write its value to its byte array
ShortList - Class in org.apache.poi.util
A List of short's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows: if possible, operations designated 'optional' in the List interface are attempted wherever the List interface refers to an Object, substitute short wherever the List interface refers to a Collection or List, substitute ShortList the mimicry is not perfect, however: operations involving Iterators or ListIterators are not supported remove(Object) becomes removeValue to distinguish it from remove(short index) subList is not supported
ShortList() - Constructor for class org.apache.poi.util.ShortList
create an ShortList of default size
ShortList(ShortList) - Constructor for class org.apache.poi.util.ShortList
create a copy of an existing ShortList
ShortList(int) - Constructor for class org.apache.poi.util.ShortList
create an ShortList with a predefined initial size
shortToHex(int) - Static method in class org.apache.poi.util.HexDump

shouldUseSmallBlocks() - Method in class org.apache.poi.poifs.property.DocumentProperty
give method more visibility
shouldUseSmallBlocks() - Method in class org.apache.poi.poifs.property.Property
Based on the currently defined size, should this property use small blocks?
SHOW_ALL - Static variable in class org.apache.poi.hssf.record.HideObjRecord

SHOW_PLACEHOLDERS - Static variable in class org.apache.poi.hssf.record.HideObjRecord

showInPane(short, short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Sets desktop window pane display area, when the file is first opened in a viewer.
showInPane(short, short) - Method in interface org.apache.poi.ss.usermodel.Sheet
Sets desktop window pane display area, when the file is first opened in a viewer.
showInPane(short, short) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Sets desktop window pane display area, when the file is first opened in a viewer.
showInPane(short, short) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Location of the top left visible cell Location of the top left visible cell in the bottom right pane (when in Left-to-Right mode).
showStyleTextPropAtom(StyleTextPropAtom) - Static method in class org.apache.poi.hslf.dev.TextStyleListing

showTextProps(TextPropCollection) - Static method in class org.apache.poi.hslf.dev.TextStyleListing

sid - Static variable in class org.apache.poi.hssf.record.ArrayRecord

sid - Static variable in class org.apache.poi.hssf.record.AutoFilterInfoRecord

sid - Static variable in class org.apache.poi.hssf.record.BackupRecord

sid - Static variable in class org.apache.poi.hssf.record.BlankRecord

sid - Static variable in class org.apache.poi.hssf.record.BOFRecord
for BIFF8 files the BOF is 0x809.
sid - Static variable in class org.apache.poi.hssf.record.BookBoolRecord

sid - Static variable in class org.apache.poi.hssf.record.BoolErrRecord

sid - Static variable in class org.apache.poi.hssf.record.BottomMarginRecord

sid - Static variable in class org.apache.poi.hssf.record.BoundSheetRecord

sid - Static variable in class org.apache.poi.hssf.record.CalcCountRecord

sid - Static variable in class org.apache.poi.hssf.record.CalcModeRecord

sid - Static variable in class org.apache.poi.hssf.record.CFHeaderRecord

sid - Static variable in class org.apache.poi.hssf.record.CFRuleRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.AreaFormatRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.AreaRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.AxisOptionsRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.AxisParentRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.AxisRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.AxisUsedRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.BarRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.BeginRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.CatLabRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartEndObjectRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartFormatRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartStartObjectRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.DataFormatRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.DatRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.EndRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.FontBasisRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.FontIndexRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.FrameRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.LinkedDataRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.PlotAreaRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.PlotGrowthRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SeriesIndexRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SeriesListRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SeriesTextRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.TickRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.UnitsRecord

sid - Static variable in class org.apache.poi.hssf.record.chart.ValueRangeRecord

sid - Static variable in class org.apache.poi.hssf.record.CodepageRecord

sid - Static variable in class org.apache.poi.hssf.record.ColumnInfoRecord

sid - Static variable in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

sid - Static variable in class org.apache.poi.hssf.record.ContinueRecord

sid - Static variable in class org.apache.poi.hssf.record.CountryRecord

sid - Static variable in class org.apache.poi.hssf.record.CRNCountRecord

sid - Static variable in class org.apache.poi.hssf.record.CRNRecord

sid - Static variable in class org.apache.poi.hssf.record.DateWindow1904Record

sid - Static variable in class org.apache.poi.hssf.record.DBCellRecord

sid - Static variable in class org.apache.poi.hssf.record.DConRefRecord
The id of the record type, sid = 81
sid - Static variable in class org.apache.poi.hssf.record.DefaultColWidthRecord

sid - Static variable in class org.apache.poi.hssf.record.DefaultRowHeightRecord

sid - Static variable in class org.apache.poi.hssf.record.DeltaRecord

sid - Static variable in class org.apache.poi.hssf.record.DimensionsRecord

sid - Static variable in class org.apache.poi.hssf.record.DrawingGroupRecord

sid - Static variable in class org.apache.poi.hssf.record.DrawingRecord

sid - Static variable in class org.apache.poi.hssf.record.DrawingRecordForBiffViewer

sid - Static variable in class org.apache.poi.hssf.record.DrawingSelectionRecord

sid - Static variable in class org.apache.poi.hssf.record.DSFRecord

sid - Static variable in class org.apache.poi.hssf.record.DVALRecord

sid - Static variable in class org.apache.poi.hssf.record.DVRecord

sid - Static variable in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

sid - Static variable in class org.apache.poi.hssf.record.EndSubRecord

sid - Static variable in class org.apache.poi.hssf.record.EOFRecord

sid - Static variable in class org.apache.poi.hssf.record.EscherAggregate

sid - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

sid - Static variable in class org.apache.poi.hssf.record.ExternalNameRecord

sid - Static variable in class org.apache.poi.hssf.record.ExternSheetRecord

sid - Static variable in class org.apache.poi.hssf.record.ExtSSTRecord

sid - Static variable in class org.apache.poi.hssf.record.FeatHdrRecord

sid - Static variable in class org.apache.poi.hssf.record.FeatRecord

sid - Static variable in class org.apache.poi.hssf.record.FilePassRecord

sid - Static variable in class org.apache.poi.hssf.record.FileSharingRecord

sid - Static variable in class org.apache.poi.hssf.record.FnGroupCountRecord

sid - Static variable in class org.apache.poi.hssf.record.FontRecord

sid - Static variable in class org.apache.poi.hssf.record.FooterRecord

sid - Static variable in class org.apache.poi.hssf.record.FormatRecord

sid - Static variable in class org.apache.poi.hssf.record.FormulaRecord

sid - Static variable in class org.apache.poi.hssf.record.FtCblsSubRecord

sid - Static variable in class org.apache.poi.hssf.record.GridsetRecord

sid - Static variable in class org.apache.poi.hssf.record.GroupMarkerSubRecord

sid - Static variable in class org.apache.poi.hssf.record.GutsRecord

sid - Static variable in class org.apache.poi.hssf.record.HCenterRecord

sid - Static variable in class org.apache.poi.hssf.record.HeaderFooterRecord

sid - Static variable in class org.apache.poi.hssf.record.HeaderRecord

sid - Static variable in class org.apache.poi.hssf.record.HideObjRecord

sid - Static variable in class org.apache.poi.hssf.record.HorizontalPageBreakRecord

sid - Static variable in class org.apache.poi.hssf.record.HyperlinkRecord

sid - Static variable in class org.apache.poi.hssf.record.IndexRecord

sid - Static variable in class org.apache.poi.hssf.record.InterfaceEndRecord

sid - Static variable in class org.apache.poi.hssf.record.InterfaceHdrRecord

sid - Static variable in class org.apache.poi.hssf.record.IterationRecord

sid - Static variable in class org.apache.poi.hssf.record.LabelRecord

sid - Static variable in class org.apache.poi.hssf.record.LabelSSTRecord

sid - Static variable in class org.apache.poi.hssf.record.LbsDataSubRecord

sid - Static variable in class org.apache.poi.hssf.record.LeftMarginRecord

sid - Static variable in class org.apache.poi.hssf.record.MergeCellsRecord

sid - Static variable in class org.apache.poi.hssf.record.MMSRecord

sid - Static variable in class org.apache.poi.hssf.record.MulBlankRecord

sid - Static variable in class org.apache.poi.hssf.record.MulRKRecord

sid - Static variable in class org.apache.poi.hssf.record.NameCommentRecord

sid - Static variable in class org.apache.poi.hssf.record.NameRecord

sid - Static variable in class org.apache.poi.hssf.record.NoteRecord

sid - Static variable in class org.apache.poi.hssf.record.NoteStructureSubRecord

sid - Static variable in class org.apache.poi.hssf.record.NumberRecord

sid - Static variable in class org.apache.poi.hssf.record.ObjectProtectRecord

sid - Static variable in class org.apache.poi.hssf.record.ObjRecord

sid - Static variable in class org.apache.poi.hssf.record.PaletteRecord

sid - Static variable in class org.apache.poi.hssf.record.PaneRecord

sid - Static variable in class org.apache.poi.hssf.record.PasswordRecord

sid - Static variable in class org.apache.poi.hssf.record.PasswordRev4Record

sid - Static variable in class org.apache.poi.hssf.record.pivottable.DataItemRecord

sid - Static variable in class org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

sid - Static variable in class org.apache.poi.hssf.record.pivottable.PageItemRecord

sid - Static variable in class org.apache.poi.hssf.record.pivottable.StreamIDRecord

sid - Static variable in class org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

sid - Static variable in class org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

sid - Static variable in class org.apache.poi.hssf.record.pivottable.ViewSourceRecord

sid - Static variable in class org.apache.poi.hssf.record.PrecisionRecord

sid - Static variable in class org.apache.poi.hssf.record.PrintGridlinesRecord

sid - Static variable in class org.apache.poi.hssf.record.PrintHeadersRecord

sid - Static variable in class org.apache.poi.hssf.record.PrintSetupRecord

sid - Static variable in class org.apache.poi.hssf.record.ProtectionRev4Record

sid - Static variable in class org.apache.poi.hssf.record.ProtectRecord

sid - Static variable in class org.apache.poi.hssf.record.RecalcIdRecord

sid - Static variable in class org.apache.poi.hssf.record.RefModeRecord

sid - Static variable in class org.apache.poi.hssf.record.RefreshAllRecord

sid - Static variable in class org.apache.poi.hssf.record.RightMarginRecord

sid - Static variable in class org.apache.poi.hssf.record.RKRecord

sid - Static variable in class org.apache.poi.hssf.record.RowRecord

sid - Static variable in class org.apache.poi.hssf.record.SaveRecalcRecord

sid - Static variable in class org.apache.poi.hssf.record.ScenarioProtectRecord

sid - Static variable in class org.apache.poi.hssf.record.SCLRecord

sid - Static variable in class org.apache.poi.hssf.record.SelectionRecord

sid - Static variable in class org.apache.poi.hssf.record.SharedFormulaRecord

sid - Static variable in class org.apache.poi.hssf.record.SSTRecord

sid - Static variable in class org.apache.poi.hssf.record.StringRecord

sid - Static variable in class org.apache.poi.hssf.record.StyleRecord

sid - Static variable in class org.apache.poi.hssf.record.SupBookRecord

sid - Static variable in class org.apache.poi.hssf.record.TabIdRecord

sid - Static variable in class org.apache.poi.hssf.record.TableRecord

sid - Static variable in class org.apache.poi.hssf.record.TableStylesRecord

sid - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

sid - Static variable in class org.apache.poi.hssf.record.TopMarginRecord

sid - Static variable in class org.apache.poi.hssf.record.UncalcedRecord

sid - Static variable in class org.apache.poi.hssf.record.UserSViewBegin

sid - Static variable in class org.apache.poi.hssf.record.UserSViewEnd

sid - Static variable in class org.apache.poi.hssf.record.UseSelFSRecord

sid - Static variable in class org.apache.poi.hssf.record.VCenterRecord

sid - Static variable in class org.apache.poi.hssf.record.VerticalPageBreakRecord

sid - Static variable in class org.apache.poi.hssf.record.WindowOneRecord

sid - Static variable in class org.apache.poi.hssf.record.WindowProtectRecord

sid - Static variable in class org.apache.poi.hssf.record.WindowTwoRecord

sid - Static variable in class org.apache.poi.hssf.record.WriteAccessRecord

sid - Static variable in class org.apache.poi.hssf.record.WriteProtectRecord

sid - Static variable in class org.apache.poi.hssf.record.WSBoolRecord

sid - Static variable in class org.apache.poi.ss.formula.ptg.AddPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.Area3DPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.AreaErrPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.AreaNPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.AreaPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.ArrayPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.BoolPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.ConcatPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.DividePtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.EqualPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.ExpPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.FuncPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.FuncVarPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.GreaterEqualPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.GreaterThanPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.IntersectionPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.IntPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.LessEqualPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.LessThanPtg
the sid for the less than operator as hex
sid - Static variable in class org.apache.poi.ss.formula.ptg.MemAreaPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.MemErrPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.MemFuncPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.MissingArgPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.MultiplyPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.NamePtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.NameXPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.NotEqualPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.NumberPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.ParenthesisPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.PercentPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.PowerPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.RangePtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.Ref3DPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.RefErrorPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.RefNPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.RefPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.StringPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.SubtractPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.TblPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.UnaryMinusPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.UnaryPlusPtg

sid - Static variable in class org.apache.poi.ss.formula.ptg.UnionPtg

SIGN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

SIGNATURE_EMF - Static variable in class org.apache.poi.ddf.EscherMetafileBlip
BLIP signatures as defined in the escher spec
SIGNATURE_PICT - Static variable in class org.apache.poi.ddf.EscherMetafileBlip

SIGNATURE_WMF - Static variable in class org.apache.poi.ddf.EscherMetafileBlip

SimpleFilledShape - Class in org.apache.poi.hssf.model

simpleFormat(Object) - Method in class org.apache.poi.ss.format.CellFormatter
Formats the value in the most basic way, returning the resulting string.
SimpleShape - Class in org.apache.poi.hslf.model
An abstract simple (non-group) shape.
SimpleShape(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.SimpleShape
Create a SimpleShape object and initialize it from the supplied Record container.
SimpleShape - Interface in org.apache.poi.sl.usermodel

simpleValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellDateFormatter
Format a value according to the type, in the most basic way.
simpleValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellElapsedFormatter
Format a value according to the type, in the most basic way.
simpleValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellFormatter
Format a value according to the type, in the most basic way.
simpleValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellGeneralFormatter
Equivalent to CellGeneralFormatter.formatValue(StringBuffer,Object).
simpleValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellNumberFormatter
Format a value according to the type, in the most basic way.
simpleValue(StringBuffer, Object) - Method in class org.apache.poi.ss.format.CellTextFormatter
Format a value according to the type, in the most basic way.
SIN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

SinArcTanExpression - Class in org.apache.poi.xslf.model.geom
Sine ArcTan Formula:
SinExpression - Class in org.apache.poi.xslf.model.geom
Sine Formula:
SINGLE_XML_CELLS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

SinglentonTextPiece - Class in org.apache.poi.hwpf.model

SinglentonTextPiece(StringBuilder) - Constructor for class org.apache.poi.hwpf.model.SinglentonTextPiece

singleOperandEvaluate(ValueEval, int, int) - Method in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

singleOperandEvaluate(ValueEval, int, int) - Static method in class org.apache.poi.ss.formula.functions.NumericFunction

SingleXmlCells - Class in org.apache.poi.xssf.model
This class implements the Single Cell Tables Part (Open Office XML Part 4: chapter 3.5.2)
SingleXmlCells() - Constructor for class org.apache.poi.xssf.model.SingleXmlCells

SingleXmlCells(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.model.SingleXmlCells

SINH - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

size - Variable in class org.apache.poi.hpsf.Section

size - Variable in class org.apache.poi.hslf.blip.Metafile.Header
Size of the metafile in EMUs
size() - Method in class org.apache.poi.hssf.model.WorkbookRecordList

size() - Method in class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

size() - Method in class org.apache.poi.hwpf.model.FormattedDiskPage
Used to get the total number of grrprl's stored int this FKP
size() - Method in class org.apache.poi.hwpf.model.UPX

size() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

SIZE - Static variable in class org.apache.poi.hwpf.usermodel.BorderCode

SIZE - Static variable in class org.apache.poi.hwpf.usermodel.DateAndTime

SIZE - Static variable in class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

SIZE - Static variable in class org.apache.poi.hwpf.usermodel.TableCellDescriptor

size() - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection
Get the numbe rof relationships in the collection.
size() - Method in class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

size() - Method in class org.apache.poi.poifs.nio.DataSource

size() - Method in class org.apache.poi.poifs.nio.FileBackedDataSource

size() - Method in class org.apache.poi.poifs.storage.DocumentBlock
Get the number of bytes read for this block
SIZE - Static variable in class org.apache.poi.ss.formula.ptg.BoolPtg

SIZE - Static variable in class org.apache.poi.ss.formula.ptg.FuncPtg

SIZE - Static variable in class org.apache.poi.ss.formula.ptg.GreaterEqualPtg

SIZE - Static variable in class org.apache.poi.ss.formula.ptg.IntPtg

SIZE - Static variable in class org.apache.poi.ss.formula.ptg.NumberPtg

SIZE - Static variable in class org.apache.poi.ss.formula.ptg.PercentPtg

SIZE - Static variable in class org.apache.poi.ss.formula.ptg.RangePtg

size() - Method in interface org.apache.poi.ss.usermodel.CellRange
Gets the number of cells in this range.
size() - Method in class org.apache.poi.ss.util.SSCellRange

size() - Method in class org.apache.poi.util.BinaryTree
Returns the number of key-value mappings in this map.
size() - Method in class org.apache.poi.util.IntList
Returns the number of elements in this list.
size() - Method in class org.apache.poi.util.IntMapper

size() - Method in class org.apache.poi.util.ShortList
Returns the number of elements in this list.
SIZE_INT - Static variable in class org.apache.poi.poifs.filesystem.DocumentInputStream

SIZE_LONG - Static variable in class org.apache.poi.poifs.filesystem.DocumentInputStream

SIZE_SHORT - Static variable in class org.apache.poi.poifs.filesystem.DocumentInputStream

sizeInBytes() - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

sizeOfDataBlock - Variable in class org.apache.poi.hslf.model.textproperties.TextProp

skip(long) - Method in class org.apache.poi.poifs.filesystem.DocumentInputStream

skip(long) - Method in class org.apache.poi.poifs.filesystem.NDocumentInputStream

skip(long) - Method in class org.apache.poi.poifs.filesystem.ODocumentInputStream

skip(long) - Method in class org.apache.poi.util.BlockingInputStream

SLANTED_DASH_DOT - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

Slide - Class in org.apache.poi.hslf.model
This class represents a slide in a PowerPoint Document.
Slide(Slide, Notes, SlideListWithText.SlideAtomsSet, int, int) - Constructor for class org.apache.poi.hslf.model.Slide
Constructs a Slide from the Slide record, and the SlideAtomsSet containing the text.
Slide(int, int, int) - Constructor for class org.apache.poi.hslf.model.Slide
Create a new Slide instance
Slide - Static variable in class org.apache.poi.hslf.record.RecordTypes

Slide - Class in org.apache.poi.hslf.record
Master container for Slides.
Slide(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.Slide
Set things up, and find our more interesting children
Slide() - Constructor for class org.apache.poi.hslf.record.Slide
Create a new, empty, Slide, along with its required child records.
Slide - Interface in org.apache.poi.sl.usermodel

SLIDE - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

SLIDE_LAYOUT - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

SLIDE_MASTER - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

SlideAndNotesAtomListing - Class in org.apache.poi.hslf.dev
Uses record level code to locate Notes and Slide records.
SlideAndNotesAtomListing() - Constructor for class org.apache.poi.hslf.dev.SlideAndNotesAtomListing

SlideAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SlideAtom - Class in org.apache.poi.hslf.record
A Slide Atom (type 1007).
SlideAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.SlideAtom
For the Slide Atom
SlideAtom() - Constructor for class org.apache.poi.hslf.record.SlideAtom
Create a new SlideAtom, to go with a new Slide
SlideAtom.SSlideLayoutAtom - Class in org.apache.poi.hslf.record
Holds the geometry of the Slide, and the ID of the placeholders on the slide.
SlideAtom.SSlideLayoutAtom(byte[]) - Constructor for class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
Create a new Embeded SSlideLayoutAtom, from 12 bytes of data
SlideHeadersFootersContainer - Static variable in class org.apache.poi.hslf.record.HeadersFootersContainer
"instance" field in the record header indicating that this HeadersFootersContaine is applied for slides
SlideIdListing - Class in org.apache.poi.hslf.dev
Gets all the different things that have Slide IDs (of sorts) in them, and displays them, so you can try to guess what they all mean
SlideIdListing() - Constructor for class org.apache.poi.hslf.dev.SlideIdListing

SlideLayout - Enum in org.apache.poi.xslf.usermodel
Date: 11/5/11
SlideListWithText - Static variable in class org.apache.poi.hslf.record.RecordTypes

SlideListWithText - Class in org.apache.poi.hslf.record
These are tricky beasts.
SlideListWithText(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.SlideListWithText
Create a new holder for slide records
SlideListWithText() - Constructor for class org.apache.poi.hslf.record.SlideListWithText
Create a new, empty, SlideListWithText
SlideListWithText.SlideAtomsSet - Class in org.apache.poi.hslf.record
Inner class to wrap up a matching set of records that hold the text for a given sheet.
SlideListWithText.SlideAtomsSet(SlidePersistAtom, Record[]) - Constructor for class org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet
Create one to hold the Records for one Slide's text
SlideMaster - Class in org.apache.poi.hslf.model
SlideMaster determines the graphics, layout, and formatting for all the slides in a given presentation.
SlideMaster(MainMaster, int) - Constructor for class org.apache.poi.hslf.model.SlideMaster
Constructs a SlideMaster from the MainMaster record,
SlideNumberMCAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SlidePersistAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SlidePersistAtom - Class in org.apache.poi.hslf.record
A SlidePersist Atom (type 1011).
SlidePersistAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.SlidePersistAtom
For the SlidePersist Atom
SlidePersistAtom() - Constructor for class org.apache.poi.hslf.record.SlidePersistAtom
Create a new SlidePersistAtom, for use with a new Slide
SLIDES - Static variable in class org.apache.poi.hslf.record.SlideListWithText
Instance filed of the record header indicates that this SlideListWithText stores references to slides
SlideShow - Class in org.apache.poi.hslf.usermodel
This class is a friendly wrapper on top of the more scary HSLFSlideShow.
SlideShow(HSLFSlideShow) - Constructor for class org.apache.poi.hslf.usermodel.SlideShow
Constructs a Powerpoint document from the underlying HSLFSlideShow object.
SlideShow() - Constructor for class org.apache.poi.hslf.usermodel.SlideShow
Constructs a new, empty, Powerpoint document.
SlideShow(InputStream) - Constructor for class org.apache.poi.hslf.usermodel.SlideShow
Constructs a Powerpoint document from an input stream.
SlideShow - Interface in org.apache.poi.sl.usermodel

SlideShowDumper - Class in org.apache.poi.hslf.dev
This class provides a way to "peek" inside a powerpoint file.
SlideShowDumper(String) - Constructor for class org.apache.poi.hslf.dev.SlideShowDumper
Constructs a Powerpoint dump from fileName.
SlideShowDumper(InputStream) - Constructor for class org.apache.poi.hslf.dev.SlideShowDumper
Constructs a Powerpoint dump from an input stream.
SlideShowDumper(POIFSFileSystem) - Constructor for class org.apache.poi.hslf.dev.SlideShowDumper
Constructs a Powerpoint dump from a POIFS Filesystem.
SlideShowRecordDumper - Class in org.apache.poi.hslf.dev
This class provides a way to view the contents of a powerpoint file.
SlideShowRecordDumper(String, boolean, boolean) - Constructor for class org.apache.poi.hslf.dev.SlideShowRecordDumper
Constructs a Powerpoint dump from fileName.
SlideViewInfo - Static variable in class org.apache.poi.hslf.record.RecordTypes

SlideViewInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SLWTListing - Class in org.apache.poi.hslf.dev
Uses record level code to Documents.
SLWTListing() - Constructor for class org.apache.poi.hslf.dev.SLWTListing

SLWTTextListing - Class in org.apache.poi.hslf.dev
Uses record level code to locate SlideListWithText entries.
SLWTTextListing() - Constructor for class org.apache.poi.hslf.dev.SLWTTextListing

SMALL - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

SMALL_BLOCK_SIZE - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
How big a block in the small block stream is.
SmallBlockTableReader - Class in org.apache.poi.poifs.storage
This class implements reading the small document block list from an existing file
SmallBlockTableReader() - Constructor for class org.apache.poi.poifs.storage.SmallBlockTableReader

SmallBlockTableWriter - Class in org.apache.poi.poifs.storage
This class implements storage for writing the small blocks used by small documents.
SmallBlockTableWriter(POIFSBigBlockSize, List, RootProperty) - Constructor for class org.apache.poi.poifs.storage.SmallBlockTableWriter
Creates new SmallBlockTable
SmallDocumentBlock - Class in org.apache.poi.poifs.storage
Storage for documents that are too small to use regular DocumentBlocks for their data
SmallDocumentBlockList - Class in org.apache.poi.poifs.storage
A list of SmallDocumentBlocks instances, and methods to manage the list
SmallDocumentBlockList(List) - Constructor for class org.apache.poi.poifs.storage.SmallDocumentBlockList
Constructor SmallDocumentBlockList
SMALLER_BIG_BLOCK_SIZE - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
Most files use 512 bytes as their big block size
SMALLER_BIG_BLOCK_SIZE_DETAILS - Static variable in interface org.apache.poi.poifs.common.POIFSConstants

SMILEY_FACE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SmileyFace - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

SMTP_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SNIP_1_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SNIP_2_DIAG_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SNIP_2_SAME_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SNIP_ROUND_RECT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SOLID_FILL - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

SOLID_FOREGROUND - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Solidly filled
SOLID_FOREGROUND - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Solidly filled
SOLID_FOREGROUND - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Solidly filled
SOLVER_CONTAINER - Static variable in class org.apache.poi.ddf.EscherContainerRecord

SORT_0090 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

sortColumns(CTCols) - Static method in class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

SorterViewInfo - Static variable in class org.apache.poi.hslf.record.RecordTypes

sortProperties() - Method in class org.apache.poi.ddf.AbstractEscherOptRecord
Records should be sorted by property number before being stored.
Sound - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
whether the animation has an associated sound
Sound - Static variable in class org.apache.poi.hslf.record.RecordTypes

Sound - Class in org.apache.poi.hslf.record
A container holding information about a sound.
Sound(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.Sound
Set things up, and find our more interesting children
SoundCollAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SoundCollection - Static variable in class org.apache.poi.hslf.record.RecordTypes

SoundCollection - Class in org.apache.poi.hslf.record
Is a container for all sound related atoms and containers.
SoundCollection(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.SoundCollection
Set things up, and find our more interesting children
SoundData - Static variable in class org.apache.poi.hslf.record.RecordTypes

SoundData - Class in org.apache.poi.hslf.record
Storage for embedded sounds.
SoundData() - Constructor for class org.apache.poi.hslf.record.SoundData
Constructs a new empty sound container.
SoundData(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.SoundData
Constructs the link related atom record from its source data.
SoundData - Class in org.apache.poi.hslf.usermodel
A class that represents sound data embedded in a slide show.
SoundData(Sound) - Constructor for class org.apache.poi.hslf.usermodel.SoundData
Creates the object data wrapping the record that contains the sound data.
SP_CONTAINER - Static variable in class org.apache.poi.ddf.EscherContainerRecord

SPACE_AFTER_EQUALITY - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
06H = Spaces following the equality sign (only in macro sheets)
SPACE_BEFORE - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
00H = Spaces before the next token (not allowed before tParen token)
SPACE_BEFORE_CLOSE_PAREN - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
04H = Spaces before closing parenthesis (only allowed before tParen, tFunc, and tFuncVar tokens)
SPACE_BEFORE_OPEN_PAREN - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
02H = Spaces before opening parenthesis (only allowed before tParen token)
SPACING_CLOSE - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

SPACING_MEDIUM - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

SPACING_OPEN - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

SPARSE_DOTS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Sparse dots
SPARSE_DOTS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

SPARSE_DOTS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Sparse dots
SPARSE_DOTS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Sparse dots
SpecialPropertySet - Class in org.apache.poi.hpsf
Abstract superclass for the convenience classes SummaryInformation and DocumentSummaryInformation.
SpecialPropertySet(PropertySet) - Constructor for class org.apache.poi.hpsf.SpecialPropertySet
Creates a SpecialPropertySet.
SpecialPropertySet(MutablePropertySet) - Constructor for class org.apache.poi.hpsf.SpecialPropertySet
Creates a SpecialPropertySet.
SPECIFICATION_GROUP - Static variable in class org.apache.poi.ss.format.CellFormatPart
Within CellFormatPart.FORMAT_PAT, the group number for the format specification.
SPECIFICATION_PAT - Static variable in class org.apache.poi.ss.format.CellFormatPart
Pattern for the format specification part of a cell format part.
spellInfo - Variable in class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

SPGR_CONTAINER - Static variable in class org.apache.poi.ddf.EscherContainerRecord

splitRGB(int) - Static method in class org.apache.poi.hslf.record.ColorSchemeAtom
Convert from an integer RGB value to individual R, G, B 0-255 values
SPOOLER_STATUS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SPOUSE_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SpreadsheetVersion - Enum in org.apache.poi.ss
This enum allows spreadsheets from multiple Excel versions to be handled by the common code.
SPRM_ANLD - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_AUTOSPACEDE - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_AUTOSPACEDN - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_BRC - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_BRC - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_BRCBAR - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_BRCBOTTOM - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_BRCL - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_BRCLEFT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_BRCP - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_BRCRIGHT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_BRCTOP - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_CCV - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties
change chp.cv
SPRM_CHARSCALE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_CHARSCALE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_CHGTABS - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_CHGTABSPAPX - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_CPG - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_CPG - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_CRLF - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DCS - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DISPFLDRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_DISPFLDRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_DTTMRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_DTTMRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_DTTMRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_DTTMRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_DXAABS - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DXAFROMTEXT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DXALEFT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DXALEFT1 - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DXARIGHT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DXASPACE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_DXASPACE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_DXAWIDTH - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DYAABS - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DYAAFTER - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DYABEFORE - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DYAFROMTEXT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_DYALINE - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FADJUSTRIGHT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FBIDI - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FBOLD - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FBOLD - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FCAPS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FCAPS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FDATA - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FDATA - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FDSTRIKE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FDSTRIKE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FELID - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FELID - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FEMBOSS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FEMBOSS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FFLDVANISH - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FFLDVANISH - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FIMPRINT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FIMPRINT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FINTABLE - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FITALIC - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FITALIC - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FKEEP - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FKEEPFOLLOW - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FKINSOKU - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FLOCKED - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FNOAUTOHYPH - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FNOLINENUMB - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FNUMRMLNS - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FOBJ - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FOBJ - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FOLE2 - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FOLE2 - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FOUTLINE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FOUTLINE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FOVERFLOWPUNCT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FPAGEBREAKBEFORE - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FRAMETEXTFLOW - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FSHADOW - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FSHADOW - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FSIDEBYSIDE - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FSMALLCAPS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FSMALLCAPS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FSPEC - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FSPEC - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FSTRIKE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FSTRIKE - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FTOPLINEPUNCT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FTTP - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FVANISH - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_FVANISH - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_FWIDOWCONTROL - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_FWORDWRAP - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_HIGHLIGHT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_HIGHLIGHT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_HPS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_HPS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_HPSKERN - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_HPSKERN - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_HPSPOS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_HPSPOS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_IBSTRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_IBSTRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_IBSTRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_IBSTRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_ICO - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_ICO - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_IDCTHINT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_IDCTHINT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_IDSIRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_IDSIRMARKDEL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_ILFO - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_ILVL - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_ISS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_ISS - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_ISTD - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_ISTD - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_JC - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_KUL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_KUL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_LID - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_LID - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_NONFELID - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_NONFELID - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_NUMRM - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_OBJLOCATION - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_OBJLOCATION - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_OUTLVL - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_PC - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_PICLOCATION - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_PICLOCATION - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_PROPRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_PROPRMARK - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_PROPRMARK - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_RGFTCASCII - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_RGFTCASCII - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_RGFTCFAREAST - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_RGFTCFAREAST - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_RGFTCNOTFAREAST - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_RGFTCNOTFAREAST - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_RULER - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_SFXTEXT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_SFXTEXT - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_SHD - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_SHD - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_SHD - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_SHD80 - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_SYMBOL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_SYMBOL - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SPRM_USEPGSUSETTINGS - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_WALIGNFONT - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_WHEIGHTABS - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_WR - Static variable in class org.apache.poi.hwpf.usermodel.Paragraph

SPRM_YSRI - Static variable in class org.apache.poi.hwpf.usermodel.CharacterProperties

SPRM_YSRI - Static variable in class org.apache.poi.hwpf.usermodel.CharacterRun

SprmBuffer - Class in org.apache.poi.hwpf.sprm

SprmBuffer() - Constructor for class org.apache.poi.hwpf.sprm.SprmBuffer
Deprecated. Use SprmBuffer.SprmBuffer(int) instead
SprmBuffer(byte[]) - Constructor for class org.apache.poi.hwpf.sprm.SprmBuffer
Deprecated. Use SprmBuffer.SprmBuffer(byte[],int) instead
SprmBuffer(byte[], boolean) - Constructor for class org.apache.poi.hwpf.sprm.SprmBuffer
Deprecated. Use SprmBuffer.SprmBuffer(byte[],boolean,int) instead
SprmBuffer(byte[], boolean, int) - Constructor for class org.apache.poi.hwpf.sprm.SprmBuffer

SprmBuffer(byte[], int) - Constructor for class org.apache.poi.hwpf.sprm.SprmBuffer

SprmBuffer(int) - Constructor for class org.apache.poi.hwpf.sprm.SprmBuffer

SprmIterator - Class in org.apache.poi.hwpf.sprm
This class is used to iterate through a list of sprms from a Word 97/2000/XP document.
SprmIterator(byte[], int) - Constructor for class org.apache.poi.hwpf.sprm.SprmIterator

SprmOperation - Class in org.apache.poi.hwpf.sprm
This class is used to represent a sprm operation from a Word 97/2000/XP document.
SprmOperation(byte[], int) - Constructor for class org.apache.poi.hwpf.sprm.SprmOperation

SprmUncompressor - Class in org.apache.poi.hwpf.sprm

SprmUncompressor() - Constructor for class org.apache.poi.hwpf.sprm.SprmUncompressor

SprmUtils - Class in org.apache.poi.hwpf.sprm

SprmUtils() - Constructor for class org.apache.poi.hwpf.sprm.SprmUtils

SQRT - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

SqrtExpression - Class in org.apache.poi.xslf.model.geom
Square Root Formula:
SQUARE_TABS - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SQUARES - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Squares
SQUARES - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

SQUARES - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Squares
SQUARES - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Squares
SrKinsoku - Static variable in class org.apache.poi.hslf.record.RecordTypes

SrKinsokuAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SS_BRACKET_SYMBOL - Static variable in class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

SS_NONE - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Escapement type - None
SS_NONE - Static variable in class org.apache.poi.hssf.record.FontRecord

SS_NONE - Static variable in interface org.apache.poi.ss.usermodel.Font
no type offsetting (not super or subscript)
SS_NONE - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Escapement type - None
SS_SUB - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Escapement type - Subscript
SS_SUB - Static variable in class org.apache.poi.hssf.record.FontRecord

SS_SUB - Static variable in interface org.apache.poi.ss.usermodel.Font
subscript
SS_SUB - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Escapement type - Subscript
SS_SUPER - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Escapement type - Superscript
SS_SUPER - Static variable in class org.apache.poi.hssf.record.FontRecord

SS_SUPER - Static variable in interface org.apache.poi.ss.usermodel.Font
superscript
SS_SUPER - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Escapement type - Superscript
SSCellRange<K extends Cell> - Class in org.apache.poi.ss.util
For POI internal use only
SSDocInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SSlideLayoutAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

SSSlideInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

sst - Variable in class org.apache.poi.hssf.model.InternalWorkbook
this contains a reference to the SSTRecord so that new stings can be added to it.
SSTRecord - Class in org.apache.poi.hssf.record
Title: Static String Table Record (0x00FC)
Description: This holds all the strings for LabelSSTRecords.
SSTRecord() - Constructor for class org.apache.poi.hssf.record.SSTRecord

SSTRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.SSTRecord
Fill the fields from the data
ST_ACCENTBORDERCALLOUT1 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACCENTBORDERCALLOUT2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACCENTBORDERCALLOUT3 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACCENTBORDERCALLOUT90 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACCENTCALLOUT1 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACCENTCALLOUT2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACCENTCALLOUT3 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACCENTCALLOUT90 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONBACKPREVIOUS - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONBEGINNING - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONBLANK - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONDOCUMENT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONEND - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONFORWARDNEXT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONHELP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONHOME - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONINFORMATION - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONMOVIE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONRETURN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ACTIONBUTTONSOUND - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ARC - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BALLOON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BENTARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BENTCONNECTOR2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BENTCONNECTOR3 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BENTCONNECTOR4 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BENTCONNECTOR5 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BENTUPARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BEVEL - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BLOCKARC - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BORDERCALLOUT1 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BORDERCALLOUT2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BORDERCALLOUT3 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BORDERCALLOUT90 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BRACEPAIR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_BRACKETPAIR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CALLOUT1 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CALLOUT2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CALLOUT3 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CALLOUT90 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CAN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CHEVRON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CIRCULARARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CLOUDCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CUBE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDCONNECTOR2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDCONNECTOR3 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDCONNECTOR4 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDCONNECTOR5 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDDOWNARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDLEFTARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDRIGHTARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_CURVEDUPARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_DIAMOND - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_DONUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_DOUBLEWAVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_DOWNARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_DOWNARROWCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ELLIPSE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ELLIPSERIBBON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ELLIPSERIBBON2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTALTERNATEPROCESS - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTCOLLATE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTCONNECTOR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTDECISION - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTDELAY - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTDISPLAY - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTDOCUMENT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTEXTRACT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTINPUTOUTPUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTINTERNALSTORAGE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTMAGNETICDISK - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTMAGNETICDRUM - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTMAGNETICTAPE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTMANUALINPUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTMANUALOPERATION - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTMERGE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTMULTIDOCUMENT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTOFFLINESTORAGE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTOFFPAGECONNECTOR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTONLINESTORAGE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTOR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTPREDEFINEDPROCESS - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTPREPARATION - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTPROCESS - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTPUNCHEDCARD - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTPUNCHEDTAPE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTSORT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTSUMMINGJUNCTION - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FLOWCHARTTERMINATOR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_FOLDEDCORNER - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_HEART - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_HEXAGON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_HOMEPLATE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_HORIZONTALSCROLL - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_HOSTCONTROL - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_IRREGULARSEAL1 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_IRREGULARSEAL2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ISOCELESTRIANGLE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTARROWCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTBRACE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTBRACKET - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTRIGHTARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTRIGHTARROWCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTRIGHTUPARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LEFTUPARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LIGHTNINGBOLT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_LINE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_MIN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_MOON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_NIL - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_NOSMOKING - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_NOT_PRIMATIVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_NOTCHEDCIRCULARARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_NOTCHEDRIGHTARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_OCTAGON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_PARALLELOGRAM - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_PENTAGON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_PICTUREFRAME - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_PLAQUE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_PLUS - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_QUADARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_QUADARROWCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_RECTANGLE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_RIBBON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_RIBBON2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_RIGHTARROWCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_RIGHTBRACE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_RIGHTBRACKET - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_RIGHTTRIANGLE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_ROUNDRECTANGLE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SEAL - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SEAL16 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SEAL24 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SEAL32 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SEAL4 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SEAL8 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SMILEYFACE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_STAR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_STRAIGHTCONNECTOR1 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_STRIPEDRIGHTARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_SUN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTARCHDOWNCURVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTARCHDOWNPOUR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTARCHUPCURVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTARCHUPPOUR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTBOX - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTBUTTONCURVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTBUTTONPOUR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCANDOWN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCANUP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCASCADEDOWN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCASCADEUP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCHEVRON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCHEVRONINVERTED - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCIRCLECURVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCIRCLEPOUR - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCURVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCURVEDOWN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTCURVEUP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTDEFLATE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTDEFLATEBOTTOM - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTDEFLATEINFLATE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTDEFLATEINFLATEDEFLATE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTDEFLATETOP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTFADEDOWN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTFADELEFT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTFADERIGHT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTFADEUP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTHEXAGON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTINFLATE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTINFLATEBOTTOM - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTINFLATETOP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTOCTAGON - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTONCURVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTONRING - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTPLAINTEXT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTRING - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTRINGINSIDE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTRINGOUTSIDE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTSIMPLE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTSLANTDOWN - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTSLANTUP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTSTOP - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTTRIANGLE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTTRIANGLEINVERTED - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTWAVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTWAVE1 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTWAVE2 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTWAVE3 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TEXTWAVE4 - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_THICKARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_TRAPEZOID - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_UPARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_UPARROWCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_UPDOWNARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_UPDOWNARROWCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_UTURNARROW - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_VERTICALSCROLL - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_WAVE - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_WEDGEELLIPSECALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_WEDGERECTCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

ST_WEDGERRECTCALLOUT - Static variable in class org.apache.poi.hssf.record.EscherAggregate

STANDARD_PALETTE_SIZE - Static variable in class org.apache.poi.hssf.record.PaletteRecord
The standard size of an XLS palette
StandardRecord - Class in org.apache.poi.hssf.record
Subclasses of this class (the majority of BIFF records) are non-continuable.
StandardRecord() - Constructor for class org.apache.poi.hssf.record.StandardRecord

STANDARDWIDTH_0099 - Static variable in class org.apache.poi.hssf.record.UnknownRecord

Star - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Star16 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Star24 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Star32 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Star4 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Star8 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

STAR_10 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_12 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_16 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_24 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_32 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_4 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_5 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_6 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_7 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

STAR_8 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

START_DATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

startBold() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

startDoubleUnderline() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

startElement(String, String, String, Attributes) - Method in class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable

startElement(String, String, String, Attributes) - Method in class org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler

startRow(int) - Method in interface org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler
A row with the (zero based) row number has started
startRow(int) - Method in class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

startUnderline() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

STATE_OR_PROVINCE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STATEMENT_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Statement 5 1/2 x 8 1/2 in
STATUS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STATUS_CODE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STATUS_STRING - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STDEV - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

StdfBaseAbstractType - Class in org.apache.poi.hwpf.model.types
The StdfBase structure specifies general information about a style.
StdfBaseAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

StdfPost2000AbstractType - Class in org.apache.poi.hwpf.model.types
The StdfPost2000 structure specifies general information about a style.
StdfPost2000AbstractType() - Constructor for class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

STOP - Static variable in class org.apache.poi.ss.usermodel.DataValidation.ErrorStyle
STOP style
StopSound - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
whether all playing sounds are stopped when this animation begins
STORE_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STORE_PROVIDERS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STORE_RECORD_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STORE_STATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

STORE_SUPPORT_MASK - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

storeDate(Date, byte[]) - Static method in class org.apache.poi.hslf.util.SystemTimeUtils
Convert the supplied java Date into a SystemTime struct, and write it into the supplied byte array.
storeDate(Date, byte[], int) - Static method in class org.apache.poi.hslf.util.SystemTimeUtils
Convert the supplied java Date into a SystemTime struct, and write it into the supplied byte array.
STRAIGHT_CONNECTOR_1 - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

StraightConnector1 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

Stream - Class in org.apache.poi.hdgf.streams
Base of all Streams within a HDGF document.
Stream(Pointer, StreamStore) - Constructor for class org.apache.poi.hdgf.streams.Stream
Creates a new Stream, having already used the pointer to build a store
STREAM_OBJECT_POOL - Static variable in class org.apache.poi.hwpf.HWPFDocumentCore

STREAM_WORD_DOCUMENT - Static variable in class org.apache.poi.hwpf.HWPFDocumentCore

StreamHelper - Class in org.apache.poi.openxml4j.opc

StreamIDRecord - Class in org.apache.poi.hssf.record.pivottable
SXIDSTM - Stream ID (0x00D5)

StreamIDRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.pivottable.StreamIDRecord

StreamStore - Class in org.apache.poi.hdgf.streams
Holds the representation of the stream on-disk, and handles de-compressing it as required.
StreamStore(byte[], int, int) - Constructor for class org.apache.poi.hdgf.streams.StreamStore
Creates a new, non compressed Stream Store
STREET_ADDRESS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

strikeThrough(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterProperties

strikeThrough(boolean) - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

STRIKETHROUGH_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

StringChunk - Class in org.apache.poi.hsmf.datatypes
A Chunk made up of a single string.
StringChunk(String, int, int) - Constructor for class org.apache.poi.hsmf.datatypes.StringChunk
Creates a String Chunk.
StringChunk(int, int) - Constructor for class org.apache.poi.hsmf.datatypes.StringChunk
Create a String Chunk, with the specified type.
StringEval - Class in org.apache.poi.ss.formula.eval

StringEval(Ptg) - Constructor for class org.apache.poi.ss.formula.eval.StringEval

StringEval(String) - Constructor for class org.apache.poi.ss.formula.eval.StringEval

StringPtg - Class in org.apache.poi.ss.formula.ptg
String Stores a String value in a formula value stored in the format <length 2 bytes>char[]
StringPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.StringPtg
Create a StringPtg from a stream
StringPtg(String) - Constructor for class org.apache.poi.ss.formula.ptg.StringPtg
Create a StringPtg from a string representation of the number Number format is not checked, it is expected to be validated in the parser that calls this method.
StringRecord - Class in org.apache.poi.hssf.record
STRING (0x0207)
Stores the cached result of a text formula
StringRecord() - Constructor for class org.apache.poi.hssf.record.StringRecord

StringRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.StringRecord

StringsStream - Class in org.apache.poi.hdgf.streams
A Stream which holds Strings.
StringsStream(Pointer, StreamStore, ChunkFactory) - Constructor for class org.apache.poi.hdgf.streams.StringsStream

StringUtil - Class in org.apache.poi.util
Title: String Utility Description: Collection of string handling utilities
Note - none of the methods in this class deals with ContinueRecords.
StringUtil.StringsIterator - Class in org.apache.poi.util
An Iterator over an array of Strings.
StringUtil.StringsIterator(String[]) - Constructor for class org.apache.poi.util.StringUtil.StringsIterator

StringValueEval - Interface in org.apache.poi.ss.formula.eval

STRIPED_RIGHT_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

StripedRightArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

stripFields(String) - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter
Removes any fields (eg macros, page markers etc) from the string.
stripFields(String) - Static method in class org.apache.poi.hwpf.extractor.WordExtractor
Removes any fields (eg macros, page markers etc) from the string.
stripFields(String) - Static method in class org.apache.poi.hwpf.usermodel.Range
Removes any fields (eg macros, page markers etc) from the string.
stripFields(String) - Static method in class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
Removes any fields (eg macros, page markers etc) from the string.
STSHF - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STSHFORIG - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

StshifAbstractType - Class in org.apache.poi.hwpf.model.types
The Stshif structure specifies general stylesheet information.
StshifAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.StshifAbstractType

STTBAUTOCAPTION - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBCAPTION - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFASSOC - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFATNBKMK - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFBKMK - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFFFN - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFINTFLD - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFMCR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFNM - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFRMARK - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBFUSSR - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBGLSY - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBGLSYSTYLE - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBLISTNAMES - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBSAVEDBY - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STTBTTMBD - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STWUSER - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

STYLE_COMBO_DROPDOWN - Static variable in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
Combo dropdown control
STYLE_COMBO_EDIT_DROPDOWN - Static variable in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
Combo Edit dropdown control
STYLE_COMBO_SIMPLE_DROPDOWN - Static variable in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
Simple dropdown control (just the dropdown button)
STYLE_PART - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Style type.
StyleDescription - Class in org.apache.poi.hwpf.model
Comment me
StyleDescription() - Constructor for class org.apache.poi.hwpf.model.StyleDescription

StyleDescription(byte[], int, int, boolean) - Constructor for class org.apache.poi.hwpf.model.StyleDescription

styleExist(String) - Method in class org.apache.poi.xwpf.usermodel.XWPFStyles
checks whether style with styleID exist
styleIDs - Variable in class org.apache.poi.xwpf.usermodel.XWPFTable

StyleRecord - Class in org.apache.poi.hssf.record
Title: Style Record (0x0293)
Description: Describes a builtin to the gui or user defined style
StyleRecord() - Constructor for class org.apache.poi.hssf.record.StyleRecord
creates a new style record, initially set to 'built-in'
StyleRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.StyleRecord

STYLES - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

styles - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

styles - Variable in class org.apache.poi.xwpf.usermodel.XWPFLatentStyles

STYLES - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

styles - Variable in class org.apache.poi.xwpf.usermodel.XWPFStyle

StyleSheet - Class in org.apache.poi.hwpf.model
Represents a document's stylesheet.
StyleSheet(byte[], int) - Constructor for class org.apache.poi.hwpf.model.StyleSheet
StyleSheet constructor.
StylesTable - Class in org.apache.poi.xssf.model
Table of styles shared across all sheets in a workbook.
StylesTable() - Constructor for class org.apache.poi.xssf.model.StylesTable
Create a new, empty StylesTable
StylesTable(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.model.StylesTable

StyleTextPropAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

StyleTextPropAtom - Class in org.apache.poi.hslf.record
A StyleTextPropAtom (type 4001).
StyleTextPropAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.StyleTextPropAtom
For the Text Style Properties (StyleTextProp) Atom
StyleTextPropAtom(int) - Constructor for class org.apache.poi.hslf.record.StyleTextPropAtom
A new set of text style properties for some text without any.
SubdocumentType - Enum in org.apache.poi.hwpf.model
Document text parts that can have text pieces (CPs)
SUBFOLDERS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

subFrom - Variable in class org.apache.poi.hssf.record.PageBreakRecord.Break

SUBJECT - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

subject - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The topic of the content of the resource.
SUBJECT_IPM - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SUBJECT_PREFIX - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

subjectChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
Subject link chunk, in plain/text
submissionChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
TODO
SUBMIT_FLAGS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SubRecord - Class in org.apache.poi.hssf.record
Subrecords are part of the OBJ class.
SubRecord() - Constructor for class org.apache.poi.hssf.record.SubRecord

Substitute - Class in org.apache.poi.ss.formula.functions
An implementation of the SUBSTITUTE function:
Substitutes text in a text string with new text, some number of times.
Substitute() - Constructor for class org.apache.poi.ss.formula.functions.Substitute

substring(int, int) - Method in class org.apache.poi.hwpf.model.TextPiece
Deprecated.
Subtitle - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the sub-title text.
subTo - Variable in class org.apache.poi.hssf.record.PageBreakRecord.Break

Subtotal - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function SUBTOTAL
Subtotal() - Constructor for class org.apache.poi.ss.formula.functions.Subtotal

subtotalInstance() - Static method in class org.apache.poi.ss.formula.functions.Count
Create an instance of Count to use in Subtotal
subtotalInstance() - Static method in class org.apache.poi.ss.formula.functions.Counta

SubtractEval - Static variable in class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

SubtractPtg - Class in org.apache.poi.ss.formula.ptg

SUBTYPE_CLIPART_GALLERY - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_DEFAULT - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_EQUATION - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_EXCEL - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_EXCEL_CHART - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_GRAPH - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_IMAGE - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_MEDIA_PLAYER - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_NOTEIT - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_ORGANIZATION_CHART - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_POWERPOINT_PRESENTATION - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_POWERPOINT_SLIDE - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_PROJECT - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_SOUND - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_WORD_TABLE - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

SUBTYPE_WORDART - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom

suggestFileExtension() - Method in class org.apache.poi.hssf.usermodel.HSSFPictureData

suggestFileExtension() - Method in class org.apache.poi.hwpf.usermodel.Picture
tries to suggest extension for picture's file by matching signatures of popular image formats to first bytes of picture's contents
suggestFileExtension() - Method in interface org.apache.poi.ss.usermodel.PictureData
Suggests a file extension for this image.
suggestFileExtension() - Method in class org.apache.poi.xslf.usermodel.XSLFPictureData
Suggests a file extension for this image.
suggestFileExtension() - Method in class org.apache.poi.xssf.usermodel.XSSFPictureData
Suggests a file extension for this image.
suggestFileExtension() - Method in class org.apache.poi.xwpf.usermodel.XWPFPictureData
Suggests a file extension for this image.
suggestFullFileName() - Method in class org.apache.poi.hwpf.usermodel.Picture
Tries to suggest a filename: hex representation of picture structure offset in "Data" stream plus extension that is tried to determine from first byte of picture's content.
suggestPictureType() - Method in class org.apache.poi.hwpf.usermodel.Picture

SUM - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

SUM - Static variable in class org.apache.poi.ss.formula.ptg.AttrPtg

SUM - Static variable in class org.apache.poi.ss.formula.ptg.FuncVarPtg
Single instance of this token for 'sum() taking a single argument'
Sumif - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function SUMIF
Sumif() - Constructor for class org.apache.poi.ss.formula.functions.Sumif

Sumifs - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function SUMIFS
Sumifs() - Constructor for class org.apache.poi.ss.formula.functions.Sumifs

Summary - Static variable in class org.apache.poi.hslf.record.RecordTypes

SUMMARY_INFORMATION_ID - Static variable in class org.apache.poi.hpsf.wellknown.SectionIDMap
The SummaryInformation's section's format ID.
SummaryInformation - Class in org.apache.poi.hpsf
Convenience class representing a Summary Information stream in a Microsoft Office document.
SummaryInformation(PropertySet) - Constructor for class org.apache.poi.hpsf.SummaryInformation
Creates a SummaryInformation from a given PropertySet.
Sumproduct - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function SUMPRODUCT
Sumproduct() - Constructor for class org.apache.poi.ss.formula.functions.Sumproduct

SUMSQ - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

Sumx2my2 - Class in org.apache.poi.ss.formula.functions
Implementation of Excel function SUMX2MY2()
Calculates the sum of differences of squares in two arrays of the same size.
Syntax:
SUMX2MY2(arrayX, arrayY)
result = Σi: 0..n(xi2-yi2)
Sumx2my2() - Constructor for class org.apache.poi.ss.formula.functions.Sumx2my2

Sumx2py2 - Class in org.apache.poi.ss.formula.functions
Implementation of Excel function SUMX2PY2()
Calculates the sum of squares in two arrays of the same size.
Syntax:
SUMX2PY2(arrayX, arrayY)
result = Σi: 0..n(xi2+yi2)
Sumx2py2() - Constructor for class org.apache.poi.ss.formula.functions.Sumx2py2

Sumxmy2 - Class in org.apache.poi.ss.formula.functions
Implementation of Excel function SUMXMY2()
Calculates the sum of squares of differences between two arrays of the same size.
Syntax:
SUMXMY2(arrayX, arrayY)
result = Σi: 0..n(xi-yi)2
Sumxmy2() - Constructor for class org.apache.poi.ss.formula.functions.Sumxmy2

Sun - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

SUN - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SupBookRecord - Class in org.apache.poi.hssf.record
Title: Sup Book - EXTERNALBOOK (0x01AE)
Description: A External Workbook Description (Supplemental Book) Its only a dummy record for making new ExternSheet Record
SupBookRecord(String, String[]) - Constructor for class org.apache.poi.hssf.record.SupBookRecord

SupBookRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.SupBookRecord
called by the constructor, should set class level fields.
SUPERSEDES - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

SUPPLEMENTARY_INFO - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

supplySlideShow(SlideShow) - Method in class org.apache.poi.hslf.model.TextRun
Supply the SlideShow we belong to.
supplySlideShow(SlideShow) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Supply the SlideShow we belong to
supplyTextProps(TextPropCollection, TextPropCollection, boolean, boolean) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Supply (normally default) textprops, and if they're shared, when a run gets them
SUPPORTED_TYPES - Static variable in class org.apache.poi.hpsf.VariantSupport
HPSF is able to read these Variant types.
SUPPORTED_TYPES - Static variable in class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

SUPPORTED_TYPES - Static variable in class org.apache.poi.xssf.extractor.XSSFExcelExtractor

SUPPORTED_TYPES - Static variable in class org.apache.poi.xwpf.extractor.XWPFWordExtractor

SURNAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

swapFontUse(short, short) - Method in class org.apache.poi.hssf.record.common.UnicodeString
Swaps all use in the string of one font index for use of a different font index.
SWOOSH_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

SXSSFCell - Class in org.apache.poi.xssf.streaming
Streaming version of XSSFRow implementing the "BigGridDemo" strategy.
SXSSFCell(SXSSFRow, int) - Constructor for class org.apache.poi.xssf.streaming.SXSSFCell

SXSSFRow - Class in org.apache.poi.xssf.streaming
Streaming version of XSSFRow implementing the "BigGridDemo" strategy.
SXSSFRow(SXSSFSheet, int) - Constructor for class org.apache.poi.xssf.streaming.SXSSFRow

SXSSFRow.CellIterator - Class in org.apache.poi.xssf.streaming
returns all cells including empty cells in which case "null" is returned
SXSSFRow.CellIterator() - Constructor for class org.apache.poi.xssf.streaming.SXSSFRow.CellIterator

SXSSFRow.FilledCellIterator - Class in org.apache.poi.xssf.streaming
returns all filled cells (created via Row.createCell())
SXSSFSheet - Class in org.apache.poi.xssf.streaming
Streaming version of XSSFSheet implementing the "BigGridDemo" strategy.
SXSSFSheet(SXSSFWorkbook, XSSFSheet) - Constructor for class org.apache.poi.xssf.streaming.SXSSFSheet

SXSSFWorkbook - Class in org.apache.poi.xssf.streaming
Streaming version of XSSFWorkbook implementing the "BigGridDemo" strategy.
SXSSFWorkbook() - Constructor for class org.apache.poi.xssf.streaming.SXSSFWorkbook
Construct a new workbook
SXSSFWorkbook(XSSFWorkbook) - Constructor for class org.apache.poi.xssf.streaming.SXSSFWorkbook
Construct a workbook from a template.
SXSSFWorkbook(XSSFWorkbook, int) - Constructor for class org.apache.poi.xssf.streaming.SXSSFWorkbook
Constructs an workbook from an existing workbook.
SXSSFWorkbook(XSSFWorkbook, int, boolean) - Constructor for class org.apache.poi.xssf.streaming.SXSSFWorkbook
Constructs an workbook from an existing workbook.
SXSSFWorkbook(int) - Constructor for class org.apache.poi.xssf.streaming.SXSSFWorkbook
Construct an empty workbook and specify the window for row access.
SYMBOL_CHARSET - Static variable in class org.apache.poi.hslf.model.PPFont
Symbol character set
SYMBOL_CHARSET - Static variable in interface org.apache.poi.ss.usermodel.Font
Symbol character set
Synchronous - Static variable in class org.apache.poi.hslf.record.AnimationInfoAtom
specifies that the animation, while playing, stops other slide show actions.
syncWithDataSource() - Method in class org.apache.poi.poifs.filesystem.NPOIFSMiniStore
Writes the SBATs to their backing blocks
SystemOutLogger - Class in org.apache.poi.util
A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
SystemOutLogger() - Constructor for class org.apache.poi.util.SystemOutLogger

SystemTimeUtils - Class in org.apache.poi.hslf.util
A helper class for dealing with SystemTime Structs, as defined at http://msdn.microsoft.com/library/en-us/sysinfo/base/systemtime_str.asp .
SystemTimeUtils() - Constructor for class org.apache.poi.hslf.util.SystemTimeUtils

T

T - Class in org.apache.poi.ss.formula.functions
Implementation of Excel T() function
If the argument is a text or error value it is returned unmodified.
T() - Constructor for class org.apache.poi.ss.formula.functions.T

tab() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

TabDescriptor - Class in org.apache.poi.hwpf.model
Tab descriptor.
TabDescriptor() - Constructor for class org.apache.poi.hwpf.model.TabDescriptor

TabDescriptor(byte[], int) - Constructor for class org.apache.poi.hwpf.model.TabDescriptor

TabIdRecord - Class in org.apache.poi.hssf.record
Title: Sheet Tab Index Array Record (0x013D)
Description: Contains an array of sheet id's.
TabIdRecord() - Constructor for class org.apache.poi.hssf.record.TabIdRecord

TabIdRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.TabIdRecord

Table - Class in org.apache.poi.hslf.model
Represents a table in a PowerPoint presentation
Table(int, int) - Constructor for class org.apache.poi.hslf.model.Table
Create a new Table of the given number of rows and columns
Table(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.Table
Create a Table object and initilize it from the supplied Record container.
Table - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains a table object.
Table - Class in org.apache.poi.hwpf.usermodel

TABLE - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

TABLE_STYLES - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

TableAutoformatLookSpecifier - Class in org.apache.poi.hwpf.usermodel

TableAutoformatLookSpecifier() - Constructor for class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

TableAutoformatLookSpecifier(byte[], int) - Constructor for class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

TableCell - Class in org.apache.poi.hslf.model
Represents a cell in a ppt table
TableCell(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.TableCell
Create a TableCell object and initialize it from the supplied Record container.
TableCell(Shape) - Constructor for class org.apache.poi.hslf.model.TableCell
Create a new TableCell.
TableCell - Class in org.apache.poi.hwpf.usermodel

TableCell(int, int, TableRow, int, TableCellDescriptor, int, int) - Constructor for class org.apache.poi.hwpf.usermodel.TableCell

TableCellDescriptor - Class in org.apache.poi.hwpf.usermodel

TableCellDescriptor() - Constructor for class org.apache.poi.hwpf.usermodel.TableCellDescriptor

TableIterator - Class in org.apache.poi.hwpf.usermodel

TableIterator(Range) - Constructor for class org.apache.poi.hwpf.usermodel.TableIterator

TableProperties - Class in org.apache.poi.hwpf.usermodel

TableProperties() - Constructor for class org.apache.poi.hwpf.usermodel.TableProperties

TableProperties(short) - Constructor for class org.apache.poi.hwpf.usermodel.TableProperties

TableRecord - Class in org.apache.poi.hssf.record
DATATABLE (0x0236)
TableRecord - The record specifies a data table.
TableRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.TableRecord

TableRecord(CellRangeAddress8Bit) - Constructor for class org.apache.poi.hssf.record.TableRecord

TableRow - Class in org.apache.poi.hwpf.usermodel

TableRow(int, int, Table, int) - Constructor for class org.apache.poi.hwpf.usermodel.TableRow

tableRows - Variable in class org.apache.poi.xwpf.usermodel.XWPFTable

tables - Variable in class org.apache.poi.xwpf.usermodel.XWPFDocument

tables - Variable in class org.apache.poi.xwpf.usermodel.XWPFTableCell

TableSprmCompressor - Class in org.apache.poi.hwpf.sprm

TableSprmCompressor() - Constructor for class org.apache.poi.hwpf.sprm.TableSprmCompressor

TableSprmUncompressor - Class in org.apache.poi.hwpf.sprm

TableSprmUncompressor() - Constructor for class org.apache.poi.hwpf.sprm.TableSprmUncompressor

TableStylesRecord - Class in org.apache.poi.hssf.record
TABLESTYLES (0x088E)

TableStylesRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.TableStylesRecord

TABLOID_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
US Tabloid 11 x 17 in
TAN - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

TanExpression - Class in org.apache.poi.xslf.model.geom
Tangent Formula:
TANH - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

TAP_TYPE - Static variable in class org.apache.poi.hwpf.sprm.SprmOperation
Deprecated.
TAPAbstractType - Class in org.apache.poi.hwpf.model.types
Table Properties.
TAPAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.TAPAbstractType

TARGET_ATTRIBUTE_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackageRelationship

TARGET_MODE_ATTRIBUTE_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackageRelationship

TargetMode - Enum in org.apache.poi.openxml4j.opc
Specifies whether the target of a PackageRelationship is inside or outside a Package.
TBDAbstractType - Class in org.apache.poi.hwpf.model.types
The TBD is a substructure of the PAP.
TBDAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.TBDAbstractType

TblPtg - Class in org.apache.poi.ss.formula.ptg
This ptg indicates a data table.
TblPtg(LittleEndianInput) - Constructor for class org.apache.poi.ss.formula.ptg.TblPtg

TCAbstractType - Class in org.apache.poi.hwpf.model.types
Table Cell Descriptor.
TCAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.TCAbstractType

TEARDROP - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

TELEX_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TempFile - Class in org.apache.poi.util
Interface for creating temporary files.
TempFile() - Constructor for class org.apache.poi.util.TempFile

TEMPLATE - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

TEMPLATE_WORKBOOK - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

TEMPLATEID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TEN_BY_FOURTEEN_PAPERSIZE - Static variable in interface org.apache.poi.ss.usermodel.PrintSetup
10 x 14 in
text() - Method in class org.apache.poi.hwpf.usermodel.Range
Gets the text that this Range contains.
text - Variable in class org.apache.poi.ss.format.CellFormatResult
The resulting text.
TEXT - Static variable in class org.apache.poi.ss.formula.functions.TextFunction
An implementation of the TEXT function
TEXT returns a number value formatted with the given number formatting string.
text - Variable in class org.apache.poi.xwpf.usermodel.XWPFComment

text - Variable in class org.apache.poi.xwpf.usermodel.XWPFTable

TEXT__ANCHORTEXT - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__BIDIR - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__FONTROTATION - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__IDOFNEXTSHAPE - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__ROTATETEXTWITHSHAPE - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__SCALETEXT - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__SINGLECLICKSELECTS - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__SIZE_TEXT_TO_FIT_SHAPE - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__SIZESHAPETOFITTEXT - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__TEXTBOTTOM - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__TEXTFLOW - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__TEXTID - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__TEXTLEFT - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__TEXTRIGHT - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__TEXTTOP - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__USEHOSTMARGINS - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT__WRAPTEXT - Static variable in class org.apache.poi.ddf.EscherProperties

TEXT_AS_CHARACTERS - Static variable in class org.apache.poi.xslf.usermodel.XSLFRenderingHint
draw text via Graphics2D.drawString(java.text.AttributedCharacterIterator, float, float)
TEXT_AS_SHAPES - Static variable in class org.apache.poi.xslf.usermodel.XSLFRenderingHint
draw text via TextLayout.draw(java.awt.Graphics2D, float, float)
TEXT_LENGTH - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
String length type
TEXT_ORIENTATION_NONE - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

TEXT_ORIENTATION_ROT_LEFT - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

TEXT_ORIENTATION_ROT_RIGHT - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

TEXT_ORIENTATION_TOP_TO_BOTTOM - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

TEXT_RENDERING_MODE - Static variable in class org.apache.poi.xslf.usermodel.XSLFRenderingHint
how to render text: XSLFRenderingHint.TEXT_AS_CHARACTERS (default) means to draw via Graphics2D.drawString(java.text.AttributedCharacterIterator, float, float).
TextAlign - Enum in org.apache.poi.xslf.usermodel
Specified a list of text alignment types
TextAlignment - Enum in org.apache.poi.xwpf.usermodel
Specifies all types of vertical alignment which are available to be applied to of all text on each line displayed within a paragraph.
TextArchDownCurve - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextArchDownPour - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextArchUpCurve - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextArchUpPour - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextAutofit - Enum in org.apache.poi.xslf.usermodel
Specifies alist of auto-fit types.
textBodyChunk - Variable in class org.apache.poi.hsmf.datatypes.Chunks
BODY Chunk, for plain/text messages
TextBodyPropertyFetcher<T> - Class in org.apache.poi.xslf.model
Created by IntelliJ IDEA.
TextBodyPropertyFetcher() - Constructor for class org.apache.poi.xslf.model.TextBodyPropertyFetcher

TextBookmarkAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TextBox - Class in org.apache.poi.hslf.model
Represents a TextFrame shape in PowerPoint.
TextBox(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.TextBox
Create a TextBox object and initialize it from the supplied Record container.
TextBox(Shape) - Constructor for class org.apache.poi.hslf.model.TextBox
Create a new TextBox.
TextBox() - Constructor for class org.apache.poi.hslf.model.TextBox
Create a new TextBox.
TextBox - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextBox - Interface in org.apache.poi.sl.usermodel

Textbox - Interface in org.apache.poi.ss.usermodel

TextboxShape - Class in org.apache.poi.hssf.model
Represents an textbox shape and converts between the highlevel records and lowlevel records for an oval.
TextButtonCurve - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextButtonPour - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextBytesAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TextBytesAtom - Class in org.apache.poi.hslf.record
A TextBytesAtom (type 4008).
TextBytesAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.TextBytesAtom
For the TextBytes Atom
TextBytesAtom() - Constructor for class org.apache.poi.hslf.record.TextBytesAtom
Create an empty TextBytes Atom
TextCanDown - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCanUp - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCap - Enum in org.apache.poi.xslf.usermodel

TextCascadeDown - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCascadeUp - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCharsAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TextCharsAtom - Class in org.apache.poi.hslf.record
A TextCharsAtom (type 4000).
TextCharsAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.TextCharsAtom
For the TextChars Atom
TextCharsAtom() - Constructor for class org.apache.poi.hslf.record.TextCharsAtom
Create an empty TextCharsAtom
TextChevron - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextChevronInverted - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCircleCurve - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCirclePour - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

textColor - Variable in class org.apache.poi.ss.format.CellFormatResult
The color the format sets, or null if the format sets no color.
TextCurve - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCurveDown - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextCurveUp - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextDeflate - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextDeflateBottom - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextDeflateInflate - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextDeflateInflateDeflate - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextDeflateTop - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextDirection - Enum in org.apache.poi.xslf.usermodel
Vertical Text Types
TextDocumentFacade - Class in org.apache.poi.hwpf.converter

TextDocumentFacade(Document) - Constructor for class org.apache.poi.hwpf.converter.TextDocumentFacade

textEndIndex - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

TextFadeDown - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextFadeLeft - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextFadeRight - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextFadeUp - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextFunction - Class in org.apache.poi.ss.formula.functions

TextFunction() - Constructor for class org.apache.poi.ss.formula.functions.TextFunction

TextHeaderAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TextHeaderAtom - Class in org.apache.poi.hslf.record
A TextHeaderAtom (type 3999).
TextHeaderAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.TextHeaderAtom
For the TextHeader Atom
TextHeaderAtom() - Constructor for class org.apache.poi.hslf.record.TextHeaderAtom
Create a new TextHeader Atom, for an unknown type of text
TextHexagon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextInflate - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextInflateBottom - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextInflateTop - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextObjectRecord - Class in org.apache.poi.hssf.record
The TXO record (0x01B6) is used to define the properties of a text box.
TextObjectRecord() - Constructor for class org.apache.poi.hssf.record.TextObjectRecord

TextObjectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.TextObjectRecord

TextOctagon - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextOnCurve - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextOnRing - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextPainter - Class in org.apache.poi.hslf.model
Paint text into java.awt.Graphics2D
TextPainter(TextShape) - Constructor for class org.apache.poi.hslf.model.TextPainter

TextPainter.TextElement - Class in org.apache.poi.hslf.model

TextPainter.TextElement() - Constructor for class org.apache.poi.hslf.model.TextPainter.TextElement

TextPiece - Class in org.apache.poi.hwpf.model
Lightweight representation of a text piece.
TextPiece(int, int, byte[], PieceDescriptor, int) - Constructor for class org.apache.poi.hwpf.model.TextPiece
Deprecated. Use TextPiece.TextPiece(int,int,byte[],PieceDescriptor) instead
TextPiece(int, int, byte[], PieceDescriptor) - Constructor for class org.apache.poi.hwpf.model.TextPiece

TextPieceTable - Class in org.apache.poi.hwpf.model
The piece table for matching up character positions to bits of text.
TextPieceTable() - Constructor for class org.apache.poi.hwpf.model.TextPieceTable

TextPieceTable(byte[], byte[], int, int, int) - Constructor for class org.apache.poi.hwpf.model.TextPieceTable

TextPlainText - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextProp - Class in org.apache.poi.hslf.model.textproperties
Definition of a property of some text, or its paragraph.
TextProp(int, int, String) - Constructor for class org.apache.poi.hslf.model.textproperties.TextProp
Generate the definition of a given type of text property.
TextPropCollection - Class in org.apache.poi.hslf.model.textproperties
For a given run of characters, holds the properties (which could be paragraph properties or character properties).
TextPropCollection(int, short) - Constructor for class org.apache.poi.hslf.model.textproperties.TextPropCollection
Create a new collection of text properties (be they paragraph or character) which will be groked via a subsequent call to buildTextPropList().
TextPropCollection(int) - Constructor for class org.apache.poi.hslf.model.textproperties.TextPropCollection
Create a new collection of text properties (be they paragraph or character) for a run of text without any
TextRecord - Class in org.apache.poi.hssf.record.chart
The text record is used to define text stored on a chart.

TextRecord() - Constructor for class org.apache.poi.hssf.record.chart.TextRecord

TextRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.TextRecord

TextRing - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextRingInside - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextRingOutside - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextRulerAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TextRulerAtom - Class in org.apache.poi.hslf.record
Ruler of a text as it differs from the style's ruler settings.
TextRulerAtom() - Constructor for class org.apache.poi.hslf.record.TextRulerAtom
Constructs a new empty ruler atom.
TextRulerAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.TextRulerAtom
Constructs the ruler atom record from its source data.
TextRun - Class in org.apache.poi.hslf.model
This class represents a run of text in a powerpoint document.
TextRun(TextHeaderAtom, TextCharsAtom, StyleTextPropAtom) - Constructor for class org.apache.poi.hslf.model.TextRun
Constructs a Text Run from a Unicode text block
TextRun(TextHeaderAtom, TextBytesAtom, StyleTextPropAtom) - Constructor for class org.apache.poi.hslf.model.TextRun
Constructs a Text Run from a Ascii text block
TextRun - Interface in org.apache.poi.sl.usermodel
Some text.
TextSegement - Class in org.apache.poi.xwpf.usermodel
saves the begin and end position of a text in a Paragraph
TextSegement() - Constructor for class org.apache.poi.xwpf.usermodel.TextSegement

TextSegement(int, int, int, int, int, int) - Constructor for class org.apache.poi.xwpf.usermodel.TextSegement

TextSegement(PositionInParagraph, PositionInParagraph) - Constructor for class org.apache.poi.xwpf.usermodel.TextSegement

TextShape - Class in org.apache.poi.hslf.model
A common superclass of all shapes that can hold text.
TextShape(EscherContainerRecord, Shape) - Constructor for class org.apache.poi.hslf.model.TextShape
Create a TextBox object and initialize it from the supplied Record container.
TextShape(Shape) - Constructor for class org.apache.poi.hslf.model.TextShape
Create a new TextBox.
TextShape() - Constructor for class org.apache.poi.hslf.model.TextShape
Create a new TextBox.
TextSimple - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextSlantDown - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextSlantUp - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextSpecInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TextSpecInfoAtom - Class in org.apache.poi.hslf.record
The special info runs contained in this text.
TextSpecInfoAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.TextSpecInfoAtom
Constructs the link related atom record from its source data.
TextSpecInfoAtom.TextSpecInfoRun - Class in org.apache.poi.hslf.record

TextSpecInfoAtom.TextSpecInfoRun() - Constructor for class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

textStartIndex - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

TextStop - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextStyleListing - Class in org.apache.poi.hslf.dev
Uses record level code to locate StyleTextPropAtom entries.
TextStyleListing() - Constructor for class org.apache.poi.hslf.dev.TextStyleListing

TextTriangle - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextTriangleInverted - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextWave - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextWave1 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextWave2 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextWave3 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TextWave4 - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

THAIDISTRIBUTED - Static variable in class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

THEME - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

THEME - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

THEME_MANAGER - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

ThemesTable - Class in org.apache.poi.xssf.model
Class that represents theme of XLSX document.
ThemesTable(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.model.ThemesTable

ThemesTable(ThemeDocument) - Constructor for class org.apache.poi.xssf.model.ThemesTable

THICK - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THICK_BACKWARD_DIAG - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thick backward facing diagonals
THICK_BACKWARD_DIAG - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THICK_BACKWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thick backward facing diagonals
THICK_BACKWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thick backward facing diagonals
THICK_FORWARD_DIAG - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thick forward facing diagonals
THICK_FORWARD_DIAG - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THICK_FORWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thick forward facing diagonals
THICK_FORWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thick forward facing diagonals
THICK_HORZ_BANDS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thick horizontal bands
THICK_HORZ_BANDS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THICK_HORZ_BANDS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thick horizontal bands
THICK_HORZ_BANDS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thick horizontal bands
THICK_VERT_BANDS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thick vertical bands
THICK_VERT_BANDS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THICK_VERT_BANDS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thick vertical bands
THICK_VERT_BANDS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thick vertical bands
ThickArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

THIN - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THIN_BACKWARD_DIAG - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thin backward diagonal
THIN_BACKWARD_DIAG - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THIN_BACKWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thin backward diagonal
THIN_BACKWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thin backward diagonal
THIN_FORWARD_DIAG - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thin forward diagonal
THIN_FORWARD_DIAG - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THIN_FORWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thin forward diagonal
THIN_FORWARD_DIAG - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thin forward diagonal
THIN_HORZ_BANDS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thin horizontal bands
THIN_HORZ_BANDS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THIN_HORZ_BANDS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thin horizontal bands
THIN_HORZ_BANDS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thin horizontal bands
THIN_VERT_BANDS - Static variable in class org.apache.poi.hssf.record.cf.PatternFormatting
Thin vertical bands
THIN_VERT_BANDS - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

THIN_VERT_BANDS - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
Thin vertical bands
THIN_VERT_BANDS - Static variable in interface org.apache.poi.ss.usermodel.PatternFormatting
Thin vertical bands
thingType - Variable in class org.apache.poi.hpbf.model.qcbits.QCBit

THREED__3DEFFECT - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__CRMOD - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__DIFFUSEAMOUNT - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__EDGETHICKNESS - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__EXTRUDEBACKWARD - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__EXTRUDEFORWARD - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__EXTRUDEPLANE - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__EXTRUSIONCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__LIGHTFACE - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__METALLIC - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__SHININESS - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__SPECULARAMOUNT - Static variable in class org.apache.poi.ddf.EscherProperties

THREED__USEEXTRUSIONCOLOR - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__AMBIENTINTENSITY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__CONSTRAINROTATION - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__FILLHARSH - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__FILLINTENSITY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__FILLX - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__FILLY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__FILLZ - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__KEYHARSH - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__KEYINTENSITY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__KEYX - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__KEYY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__KEYZ - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ORIGINX - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ORIGINY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__PARALLEL - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__RENDERMODE - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONANGLE - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONAXISX - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONAXISY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONAXISZ - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONCENTERAUTO - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONCENTERX - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONCENTERY - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ROTATIONCENTERZ - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__SKEWAMOUNT - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__SKEWANGLE - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__TOLERANCE - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__XROTATIONANGLE - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__XVIEWPOINT - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__YROTATIONANGLE - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__YVIEWPOINT - Static variable in class org.apache.poi.ddf.EscherProperties

THREEDSTYLE__ZVIEWPOINT - Static variable in class org.apache.poi.ddf.EscherProperties

Thumbnail - Class in org.apache.poi.hpsf
Class to manipulate data in the Clipboard Variant (VT_CF) format.
Thumbnail() - Constructor for class org.apache.poi.hpsf.Thumbnail
Default Constructor.
Thumbnail(byte[]) - Constructor for class org.apache.poi.hpsf.Thumbnail
Creates a Thumbnail instance and initializes with the specified image bytes.
THUMBNAIL - Static variable in interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes
Thumbnail relationship type.
TickRecord - Class in org.apache.poi.hssf.record.chart
The Tick record defines how tick marks and label positioning/formatting

TickRecord() - Constructor for class org.apache.poi.hssf.record.chart.TickRecord

TickRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.TickRecord

TIFF - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
TIFF1 - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
TIME - Static variable in class org.apache.poi.hsmf.datatypes.Types
SysTime - FILETIME 64-bit integer specifying the number of 100ns periods since Jan 1, 1601
time() - Static method in class org.apache.poi.hssf.usermodel.HeaderFooter

TIME - Static variable in class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
Time type
TimeFunc - Class in org.apache.poi.ss.formula.functions
Implementation for the Excel function TIME
TimeFunc() - Constructor for class org.apache.poi.ss.formula.functions.TimeFunc

TIMES_NEW_ROMAN - Static variable in class org.apache.poi.hslf.model.PPFont

Title - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the title text.
TITLE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

title - Variable in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

title - Variable in class org.apache.poi.hwpf.converter.TextDocumentFacade

title - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The name given to the resource.
TITLE_2_COLUMN_BODY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_2_COLUNM_LEFT_2_ROW_BODY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_2_COLUNM_RIGHT_2_ROW_BODY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_2_ROW_BODY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_2_ROW_BOTTOM_2_COLUMN_BODY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_2_ROW_TOP_2_COLUMN_BODY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_BODY_SLIDE - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_MASTER_SLIDE - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_ONLY - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_SLIDE - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

TITLE_TYPE - Static variable in class org.apache.poi.hslf.record.TextHeaderAtom

TitleMaster - Class in org.apache.poi.hslf.model
Title masters define the design template for slides with a Title Slide layout.
TitleMaster(Slide, int) - Constructor for class org.apache.poi.hslf.model.TitleMaster
Constructs a TitleMaster
titleText - Variable in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

titleText - Variable in class org.apache.poi.hwpf.converter.TextDocumentFacade

TLPAbstractType - Class in org.apache.poi.hwpf.model.types
Table Autoformat Look sPecifier (TLP).
TLPAbstractType() - Constructor for class org.apache.poi.hwpf.model.types.TLPAbstractType

TNEF_CORRELATION_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TNEFAttribute - Class in org.apache.poi.hmef.attribute
An attribute which applies to a HMEFMessage or one of its Attachments.
TNEFAttribute(int, int, InputStream) - Constructor for class org.apache.poi.hmef.attribute.TNEFAttribute
Constructs a single new attribute from the id, type, and the contents of the stream
TNEFDateAttribute - Class in org.apache.poi.hmef.attribute
A Date attribute which applies to a HMEFMessage or one of its Attachments.
TNEFDateAttribute(int, int, InputStream) - Constructor for class org.apache.poi.hmef.attribute.TNEFDateAttribute
Constructs a single new date attribute from the id, type, and the contents of the stream
TNEFMAPIAttribute - Class in org.apache.poi.hmef.attribute
A TNEF Attribute holding MAPI Attributes, which applies to a HMEFMessage or one of its Attachments.
TNEFMAPIAttribute(int, int, InputStream) - Constructor for class org.apache.poi.hmef.attribute.TNEFMAPIAttribute
Constructs a single new mapi containing attribute from the id, type, and the contents of the stream
TNEFProperty - Class in org.apache.poi.hmef.attribute
Holds the list of TNEF Attributes, and allows lookup by friendly name, ID and MAPI Property Name.
TNEFStringAttribute - Class in org.apache.poi.hmef.attribute
A String attribute which applies to a HMEFMessage or one of its Attachments.
TNEFStringAttribute(int, int, InputStream) - Constructor for class org.apache.poi.hmef.attribute.TNEFStringAttribute
Constructs a single new string attribute from the id, type, and the contents of the stream
toArray() - Method in class org.apache.poi.hssf.util.LazilyConcatenatedByteArray
Gets the concatenated contents as a single byte array.
toArray() - Method in class org.apache.poi.util.IntList
Returns an array containing all of the elements in this list in proper sequence.
toArray(int[]) - Method in class org.apache.poi.util.IntList
Returns an array containing all of the elements in this list in proper sequence.
toArray() - Method in class org.apache.poi.util.ShortList
Returns an array containing all of the elements in this list in proper sequence.
toArray(short[]) - Method in class org.apache.poi.util.ShortList
Returns an array containing all of the elements in this list in proper sequence.
toByteArray(CharIndexTranslator, int) - Method in class org.apache.poi.hwpf.model.CHPFormattedDiskPage
Deprecated. Use CHPFormattedDiskPage.toByteArray(CharIndexTranslator) instead
toByteArray(CharIndexTranslator) - Method in class org.apache.poi.hwpf.model.CHPFormattedDiskPage

toByteArray() - Method in class org.apache.poi.hwpf.model.Colorref

toByteArray() - Method in class org.apache.poi.hwpf.model.Ffn

toByteArray() - Method in class org.apache.poi.hwpf.model.FSPA

toByteArray() - Method in class org.apache.poi.hwpf.model.Grfhic

toByteArray() - Method in class org.apache.poi.hwpf.model.ListData

toByteArray() - Method in class org.apache.poi.hwpf.model.ListFormatOverride

toByteArray() - Method in class org.apache.poi.hwpf.model.ListFormatOverrideLevel

toByteArray() - Method in class org.apache.poi.hwpf.model.ListLevel

toByteArray(HWPFOutputStream, CharIndexTranslator) - Method in class org.apache.poi.hwpf.model.PAPFormattedDiskPage
Creates a byte array representation of this data structure.
toByteArray() - Method in class org.apache.poi.hwpf.model.ParagraphHeight

toByteArray() - Method in class org.apache.poi.hwpf.model.PieceDescriptor

toByteArray() - Method in class org.apache.poi.hwpf.model.PlexOfCps

toByteArray() - Method in class org.apache.poi.hwpf.model.SectionDescriptor

toByteArray() - Method in class org.apache.poi.hwpf.model.StyleDescription

toByteArray() - Method in class org.apache.poi.hwpf.model.TabDescriptor

toByteArray() - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

toByteArray() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

toByteArray(InputStream) - Static method in class org.apache.poi.util.IOUtils
Reads all the data from the input stream, and returns the bytes read.
toByteArray(ByteBuffer, int) - Static method in class org.apache.poi.util.IOUtils
Returns an array (that shouldn't be written to!) of the ByteBuffer.
TOC - Class in org.apache.poi.xwpf.usermodel

TOC() - Constructor for class org.apache.poi.xwpf.usermodel.TOC

TOC(CTSdtBlock) - Constructor for class org.apache.poi.xwpf.usermodel.TOC

toCTFont(CTRPrElt) - Static method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
CTRPrElt --> CTFont adapter
Today - Class in org.apache.poi.ss.formula.functions
Implementation of Excel TODAY() Function

Today() - Constructor for class org.apache.poi.ss.formula.functions.Today

toEMU(double) - Static method in class org.apache.poi.util.Units

toFormulaString(HSSFWorkbook, Ptg[]) - Static method in class org.apache.poi.hssf.model.HSSFFormulaParser
Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.
toFormulaString(FormulaRenderingWorkbook, Ptg[]) - Static method in class org.apache.poi.ss.formula.FormulaRenderer
Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.AddPtg
implementation of method from OperationsPtg
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.Area2DPtgBase

toFormulaString(FormulaRenderingWorkbook) - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.AreaErrPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.BoolPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.ConcatPtg

toFormulaString(FormulaRenderingWorkbook) - Method in class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

toFormulaString(FormulaRenderingWorkbook) - Method in class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.DividePtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.EqualPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.ErrPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.ExpPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.GreaterEqualPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.GreaterThanPtg
Implementation of method from OperationsPtg
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.IntersectionPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.IntersectionPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.IntPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.LessEqualPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.LessThanPtg
Implementation of method from OperationsPtg
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.MemAreaPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.MemErrPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.MemFuncPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.MissingArgPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.MultiplyPtg

toFormulaString(FormulaRenderingWorkbook) - Method in class org.apache.poi.ss.formula.ptg.NamePtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.NamePtg

toFormulaString(FormulaRenderingWorkbook) - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.NotEqualPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.NumberPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.ParenthesisPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.ParenthesisPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.PercentPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.PowerPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.Ptg
return a string representation of this token alone
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.RangePtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.RangePtg
implementation of method from OperationsPtg
toFormulaString(FormulaRenderingWorkbook) - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.RefErrorPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.StringPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.SubtractPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.TblPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.UnaryMinusPtg
implementation of method from OperationsPtg
toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.UnaryPlusPtg
implementation of method from OperationsPtg
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.UnionPtg

toFormulaString(String[]) - Method in class org.apache.poi.ss.formula.ptg.UnionPtg
implementation of method from OperationsPtg
toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.UnknownPtg

toFormulaString() - Method in class org.apache.poi.ss.formula.ptg.ValueOperatorPtg

toFormulaString(FormulaRenderingWorkbook) - Method in interface org.apache.poi.ss.formula.WorkbookDependentFormula

toHex(byte[]) - Static method in class org.apache.poi.util.HexDump
Converts the parameter to a hex value.
toHex(short[]) - Static method in class org.apache.poi.util.HexDump
Converts the parameter to a hex value.
toHex(byte[], int) - Static method in class org.apache.poi.util.HexDump
Converts the parameter to a hex value breaking the results into lines.
toHex(short) - Static method in class org.apache.poi.util.HexDump
Converts the parameter to a hex value.
toHex(byte) - Static method in class org.apache.poi.util.HexDump
Converts the parameter to a hex value.
toHex(int) - Static method in class org.apache.poi.util.HexDump
Converts the parameter to a hex value.
toHex(long) - Static method in class org.apache.poi.util.HexDump
Converts the parameter to a hex value.
toInputStream() - Method in class org.apache.poi.hpsf.MutablePropertySet
Returns the contents of this property set stream as an input stream.
toInputStream() - Method in class org.apache.poi.hpsf.SpecialPropertySet

toInt() - Method in class org.apache.poi.hwpf.usermodel.BorderCode

toInt() - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

tokenize(String) - Static method in class org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer

top - Variable in class org.apache.poi.hslf.blip.WMF.AldusHeader

TOP_BORDER_COLOR - Static variable in class org.apache.poi.ss.util.CellUtil

TopMargin - Static variable in class org.apache.poi.hssf.model.InternalSheet

TopMargin - Static variable in interface org.apache.poi.ss.usermodel.Sheet

TopMarginRecord - Class in org.apache.poi.hssf.record
Record for the top margin.

TopMarginRecord() - Constructor for class org.apache.poi.hssf.record.TopMarginRecord

TopMarginRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.TopMarginRecord

toPoints(long) - Static method in class org.apache.poi.util.Units

toShadingDescriptor() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

toShort() - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

toString() - Method in class org.apache.poi.ddf.AbstractEscherOptRecord
Retrieve the string representation of this record.
toString() - Method in class org.apache.poi.ddf.EscherArrayProperty

toString() - Method in class org.apache.poi.ddf.EscherBitmapBlip

toString() - Method in class org.apache.poi.ddf.EscherBlipRecord

toString() - Method in class org.apache.poi.ddf.EscherBlipWMFRecord
The string representation of this record.
toString() - Method in class org.apache.poi.ddf.EscherBSERecord

toString() - Method in class org.apache.poi.ddf.EscherChildAnchorRecord
The string representation of this record
toString() - Method in class org.apache.poi.ddf.EscherClientAnchorRecord
Returns the string representation for this record.
toString() - Method in class org.apache.poi.ddf.EscherClientDataRecord
Returns the string representation of this record.
toString() - Method in class org.apache.poi.ddf.EscherComplexProperty
Retrieves the string representation for this property.
toString() - Method in class org.apache.poi.ddf.EscherContainerRecord

toString() - Method in class org.apache.poi.ddf.EscherDggRecord

toString() - Method in class org.apache.poi.ddf.EscherDgRecord
Returns the string representation of this record.
toString() - Method in class org.apache.poi.ddf.EscherMetafileBlip

toString() - Method in class org.apache.poi.ddf.EscherPictBlip

toString() - Method in class org.apache.poi.ddf.EscherSimpleProperty

toString() - Method in class org.apache.poi.ddf.EscherSpgrRecord

toString() - Method in class org.apache.poi.ddf.EscherSplitMenuColorsRecord

toString() - Method in class org.apache.poi.ddf.EscherSpRecord

toString() - Method in class org.apache.poi.ddf.EscherTextboxRecord

toString() - Method in class org.apache.poi.ddf.UnknownEscherRecord

toString() - Method in class org.apache.poi.hdgf.chunks.ChunkSeparator

toString() - Method in class org.apache.poi.hdgf.chunks.ChunkTrailer

toString() - Method in class org.apache.poi.hmef.attribute.MAPIAttribute

toString() - Method in class org.apache.poi.hmef.attribute.MAPIDateAttribute

toString() - Method in class org.apache.poi.hmef.attribute.MAPIRtfAttribute

toString() - Method in class org.apache.poi.hmef.attribute.MAPIStringAttribute

toString() - Method in class org.apache.poi.hmef.attribute.TNEFAttribute

toString() - Method in class org.apache.poi.hmef.attribute.TNEFDateAttribute

toString() - Method in class org.apache.poi.hmef.attribute.TNEFMAPIAttribute

toString() - Method in class org.apache.poi.hmef.attribute.TNEFProperty

toString() - Method in class org.apache.poi.hmef.attribute.TNEFStringAttribute

toString() - Method in class org.apache.poi.hpsf.ClassID
Returns a human-readable representation of the Class ID in standard format "{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}".
toString() - Method in class org.apache.poi.hpsf.Property

toString() - Method in class org.apache.poi.hpsf.PropertySet

toString() - Method in class org.apache.poi.hpsf.Section

toString() - Method in class org.apache.poi.hpsf.SpecialPropertySet

toString(Throwable) - Static method in class org.apache.poi.hpsf.Util
Returns a textual representation of a Throwable, including a stacktrace.
toString() - Method in class org.apache.poi.hslf.record.AnimationInfoAtom

toString() - Method in class org.apache.poi.hslf.record.CString
Gets a string representation of this object, primarily for debugging.
toString() - Method in class org.apache.poi.hslf.record.ExMediaAtom

toString() - Method in class org.apache.poi.hslf.record.ExOleObjAtom

toString() - Method in class org.apache.poi.hslf.record.HeadersFootersAtom

toString() - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Dump the record content into StringBuffer
toString() - Method in class org.apache.poi.hslf.record.TextBytesAtom
dump debug info; use getText() to return a string representation of the atom
toString() - Method in class org.apache.poi.hslf.record.TextCharsAtom
dump debug info; use getText() to return a string representation of the atom
toString() - Method in class org.apache.poi.hsmf.datatypes.MAPIProperty

toString() - Method in class org.apache.poi.hsmf.datatypes.StringChunk

toString() - Method in class org.apache.poi.hssf.record.AbstractEscherHolderRecord

toString() - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate
String representation of CFRecordsAggregate
toString() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

toString() - Method in class org.apache.poi.hssf.record.ArrayRecord

toString() - Method in class org.apache.poi.hssf.record.AutoFilterInfoRecord

toString() - Method in class org.apache.poi.hssf.record.BackupRecord

toString() - Method in class org.apache.poi.hssf.record.BlankRecord

toString() - Method in class org.apache.poi.hssf.record.BOFRecord

toString() - Method in class org.apache.poi.hssf.record.BookBoolRecord

toString() - Method in class org.apache.poi.hssf.record.BottomMarginRecord

toString() - Method in class org.apache.poi.hssf.record.BoundSheetRecord

toString() - Method in class org.apache.poi.hssf.record.CalcCountRecord

toString() - Method in class org.apache.poi.hssf.record.CalcModeRecord

toString() - Method in class org.apache.poi.hssf.record.CellRecord

toString() - Method in class org.apache.poi.hssf.record.cf.BorderFormatting

toString() - Method in class org.apache.poi.hssf.record.cf.FontFormatting

toString() - Method in class org.apache.poi.hssf.record.cf.PatternFormatting

toString() - Method in class org.apache.poi.hssf.record.CFHeaderRecord

toString() - Method in class org.apache.poi.hssf.record.CFRuleRecord

toString() - Method in class org.apache.poi.hssf.record.chart.AreaFormatRecord

toString() - Method in class org.apache.poi.hssf.record.chart.AreaRecord

toString() - Method in class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

toString() - Method in class org.apache.poi.hssf.record.chart.AxisOptionsRecord

toString() - Method in class org.apache.poi.hssf.record.chart.AxisParentRecord

toString() - Method in class org.apache.poi.hssf.record.chart.AxisRecord

toString() - Method in class org.apache.poi.hssf.record.chart.AxisUsedRecord

toString() - Method in class org.apache.poi.hssf.record.chart.BarRecord

toString() - Method in class org.apache.poi.hssf.record.chart.BeginRecord

toString() - Method in class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

toString() - Method in class org.apache.poi.hssf.record.chart.CatLabRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartEndObjectRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartFormatRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartStartObjectRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

toString() - Method in class org.apache.poi.hssf.record.chart.DataFormatRecord

toString() - Method in class org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

toString() - Method in class org.apache.poi.hssf.record.chart.DatRecord

toString() - Method in class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

toString() - Method in class org.apache.poi.hssf.record.chart.EndRecord

toString() - Method in class org.apache.poi.hssf.record.chart.FontBasisRecord

toString() - Method in class org.apache.poi.hssf.record.chart.FontIndexRecord

toString() - Method in class org.apache.poi.hssf.record.chart.FrameRecord

toString() - Method in class org.apache.poi.hssf.record.chart.LegendRecord

toString() - Method in class org.apache.poi.hssf.record.chart.LineFormatRecord

toString() - Method in class org.apache.poi.hssf.record.chart.LinkedDataRecord

toString() - Method in class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ObjectLinkRecord

toString() - Method in class org.apache.poi.hssf.record.chart.PlotAreaRecord

toString() - Method in class org.apache.poi.hssf.record.chart.PlotGrowthRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SeriesIndexRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SeriesListRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SeriesRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SeriesTextRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

toString() - Method in class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

toString() - Method in class org.apache.poi.hssf.record.chart.TextRecord

toString() - Method in class org.apache.poi.hssf.record.chart.TickRecord

toString() - Method in class org.apache.poi.hssf.record.chart.UnitsRecord

toString() - Method in class org.apache.poi.hssf.record.chart.ValueRangeRecord

toString() - Method in class org.apache.poi.hssf.record.CodepageRecord

toString() - Method in class org.apache.poi.hssf.record.ColumnInfoRecord

toString() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

toString() - Method in class org.apache.poi.hssf.record.common.FeatProtection

toString() - Method in class org.apache.poi.hssf.record.common.FeatSmartTag

toString() - Method in class org.apache.poi.hssf.record.common.FtrHeader

toString() - Method in interface org.apache.poi.hssf.record.common.SharedFeature

toString() - Method in class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

toString() - Method in class org.apache.poi.hssf.record.common.UnicodeString
unlike the real records we return the same as "getString()" rather than debug info
toString() - Method in class org.apache.poi.hssf.record.CommonObjectDataSubRecord

toString() - Method in class org.apache.poi.hssf.record.ContinueRecord

toString() - Method in class org.apache.poi.hssf.record.CountryRecord

toString() - Method in class org.apache.poi.hssf.record.CRNCountRecord

toString() - Method in class org.apache.poi.hssf.record.CRNRecord

toString() - Method in class org.apache.poi.hssf.record.DateWindow1904Record

toString() - Method in class org.apache.poi.hssf.record.DBCellRecord

toString() - Method in class org.apache.poi.hssf.record.DConRefRecord

toString() - Method in class org.apache.poi.hssf.record.DefaultColWidthRecord

toString() - Method in class org.apache.poi.hssf.record.DefaultRowHeightRecord

toString() - Method in class org.apache.poi.hssf.record.DeltaRecord

toString() - Method in class org.apache.poi.hssf.record.DimensionsRecord

toString() - Method in class org.apache.poi.hssf.record.DrawingSelectionRecord

toString() - Method in class org.apache.poi.hssf.record.DSFRecord

toString() - Method in class org.apache.poi.hssf.record.DVALRecord

toString() - Method in class org.apache.poi.hssf.record.DVRecord

toString() - Method in class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

toString() - Method in class org.apache.poi.hssf.record.EndSubRecord

toString() - Method in class org.apache.poi.hssf.record.EOFRecord

toString() - Method in class org.apache.poi.hssf.record.EscherAggregate
Calculates the string representation of this record.
toString() - Method in class org.apache.poi.hssf.record.ExtendedFormatRecord

toString() - Method in class org.apache.poi.hssf.record.ExternalNameRecord

toString() - Method in class org.apache.poi.hssf.record.ExternSheetRecord

toString() - Method in class org.apache.poi.hssf.record.ExtSSTRecord

toString() - Method in class org.apache.poi.hssf.record.FeatHdrRecord

toString() - Method in class org.apache.poi.hssf.record.FeatRecord

toString() - Method in class org.apache.poi.hssf.record.FilePassRecord

toString() - Method in class org.apache.poi.hssf.record.FileSharingRecord

toString() - Method in class org.apache.poi.hssf.record.FnGroupCountRecord

toString() - Method in class org.apache.poi.hssf.record.FontRecord

toString() - Method in class org.apache.poi.hssf.record.FooterRecord

toString() - Method in class org.apache.poi.hssf.record.FormatRecord

toString() - Method in class org.apache.poi.hssf.record.FtCblsSubRecord
Convert this record to string.
toString() - Method in class org.apache.poi.hssf.record.GridsetRecord

toString() - Method in class org.apache.poi.hssf.record.GroupMarkerSubRecord

toString() - Method in class org.apache.poi.hssf.record.GutsRecord

toString() - Method in class org.apache.poi.hssf.record.HCenterRecord

toString() - Method in class org.apache.poi.hssf.record.HeaderFooterRecord

toString() - Method in class org.apache.poi.hssf.record.HeaderRecord

toString() - Method in class org.apache.poi.hssf.record.HideObjRecord

toString() - Method in class org.apache.poi.hssf.record.HyperlinkRecord

toString() - Method in class org.apache.poi.hssf.record.IndexRecord

toString() - Method in class org.apache.poi.hssf.record.InterfaceEndRecord

toString() - Method in class org.apache.poi.hssf.record.InterfaceHdrRecord

toString() - Method in class org.apache.poi.hssf.record.IterationRecord

toString() - Method in class org.apache.poi.hssf.record.LabelRecord

toString() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

toString() - Method in class org.apache.poi.hssf.record.LbsDataSubRecord

toString() - Method in class org.apache.poi.hssf.record.LeftMarginRecord

toString() - Method in class org.apache.poi.hssf.record.MergeCellsRecord

toString() - Method in class org.apache.poi.hssf.record.MMSRecord

toString() - Method in class org.apache.poi.hssf.record.MulBlankRecord

toString() - Method in class org.apache.poi.hssf.record.MulRKRecord

toString() - Method in class org.apache.poi.hssf.record.NameCommentRecord

toString() - Method in class org.apache.poi.hssf.record.NameRecord

toString() - Method in class org.apache.poi.hssf.record.NoteRecord
Convert this record to string.
toString() - Method in class org.apache.poi.hssf.record.NoteStructureSubRecord
Convert this record to string.
toString() - Method in class org.apache.poi.hssf.record.ObjectProtectRecord

toString() - Method in class org.apache.poi.hssf.record.ObjRecord

toString() - Method in class org.apache.poi.hssf.record.PageBreakRecord

toString() - Method in class org.apache.poi.hssf.record.PaletteRecord

toString() - Method in class org.apache.poi.hssf.record.PaneRecord

toString() - Method in class org.apache.poi.hssf.record.PasswordRecord

toString() - Method in class org.apache.poi.hssf.record.PasswordRev4Record

toString() - Method in class org.apache.poi.hssf.record.pivottable.DataItemRecord

toString() - Method in class org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

toString() - Method in class org.apache.poi.hssf.record.pivottable.PageItemRecord

toString() - Method in class org.apache.poi.hssf.record.pivottable.StreamIDRecord

toString() - Method in class org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

toString() - Method in class org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

toString() - Method in class org.apache.poi.hssf.record.pivottable.ViewSourceRecord

toString() - Method in class org.apache.poi.hssf.record.PrecisionRecord

toString() - Method in class org.apache.poi.hssf.record.PrintGridlinesRecord

toString() - Method in class org.apache.poi.hssf.record.PrintHeadersRecord

toString() - Method in class org.apache.poi.hssf.record.PrintSetupRecord

toString() - Method in class org.apache.poi.hssf.record.ProtectionRev4Record

toString() - Method in class org.apache.poi.hssf.record.ProtectRecord

toString() - Method in class org.apache.poi.hssf.record.RecalcIdRecord

toString() - Method in class org.apache.poi.hssf.record.Record
get a string representation of the record (for biffview/debugging)
toString() - Method in class org.apache.poi.hssf.record.RefModeRecord

toString() - Method in class org.apache.poi.hssf.record.RefreshAllRecord

toString() - Method in class org.apache.poi.hssf.record.RightMarginRecord

toString() - Method in class org.apache.poi.hssf.record.RowRecord

toString() - Method in class org.apache.poi.hssf.record.SaveRecalcRecord

toString() - Method in class org.apache.poi.hssf.record.ScenarioProtectRecord

toString() - Method in class org.apache.poi.hssf.record.SCLRecord

toString() - Method in class org.apache.poi.hssf.record.SelectionRecord

toString() - Method in class org.apache.poi.hssf.record.SharedFormulaRecord
print a sort of string representation ([SHARED FORMULA RECORD] id = x [/SHARED FORMULA RECORD])
toString() - Method in class org.apache.poi.hssf.record.SSTRecord
Return a debugging string representation
toString() - Method in class org.apache.poi.hssf.record.StringRecord

toString() - Method in class org.apache.poi.hssf.record.StyleRecord

toString() - Method in class org.apache.poi.hssf.record.SupBookRecord

toString() - Method in class org.apache.poi.hssf.record.TabIdRecord

toString() - Method in class org.apache.poi.hssf.record.TableRecord

toString() - Method in class org.apache.poi.hssf.record.TableStylesRecord

toString() - Method in class org.apache.poi.hssf.record.TextObjectRecord

toString() - Method in class org.apache.poi.hssf.record.TopMarginRecord

toString() - Method in class org.apache.poi.hssf.record.UncalcedRecord

toString() - Method in class org.apache.poi.hssf.record.UnknownRecord
print a sort of string representation ([UNKNOWN RECORD] id = x [/UNKNOWN RECORD])
toString() - Method in class org.apache.poi.hssf.record.UserSViewBegin

toString() - Method in class org.apache.poi.hssf.record.UserSViewEnd

toString() - Method in class org.apache.poi.hssf.record.UseSelFSRecord

toString() - Method in class org.apache.poi.hssf.record.VCenterRecord

toString() - Method in class org.apache.poi.hssf.record.WindowOneRecord

toString() - Method in class org.apache.poi.hssf.record.WindowProtectRecord

toString() - Method in class org.apache.poi.hssf.record.WindowTwoRecord

toString() - Method in class org.apache.poi.hssf.record.WriteAccessRecord

toString() - Method in class org.apache.poi.hssf.record.WriteProtectRecord

toString() - Method in class org.apache.poi.hssf.record.WSBoolRecord

toString() - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

toString() - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Returns a string representation of the cell This method returns a simple representation, anthing more complex should be in user code, with knowledge of the semantics of the sheet being processed.
toString() - Method in class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

toString() - Method in class org.apache.poi.hssf.usermodel.HSSFFont

toString() - Method in class org.apache.poi.hssf.usermodel.HSSFName

toString() - Method in class org.apache.poi.hssf.usermodel.HSSFRichTextString

toString() - Method in class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

toString() - Method in class org.apache.poi.hwpf.model.CHPX

toString() - Method in class org.apache.poi.hwpf.model.Colorref

toString() - Method in class org.apache.poi.hwpf.model.EscherRecordHolder

toString() - Method in class org.apache.poi.hwpf.model.FIBFieldHandler

toString() - Method in class org.apache.poi.hwpf.model.FileInformationBlock

toString() - Method in class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

toString() - Method in class org.apache.poi.hwpf.model.FSPATable

toString() - Method in class org.apache.poi.hwpf.model.GenericPropertyNode

toString() - Method in class org.apache.poi.hwpf.model.Hyphenation

toString() - Method in class org.apache.poi.hwpf.model.ListLevel

toString() - Method in class org.apache.poi.hwpf.model.PAPX

toString() - Method in class org.apache.poi.hwpf.model.PieceDescriptor

toString() - Method in class org.apache.poi.hwpf.model.PlexOfCps

toString() - Method in class org.apache.poi.hwpf.model.PlexOfField

toString() - Method in class org.apache.poi.hwpf.model.PropertyModifier

toString() - Method in class org.apache.poi.hwpf.model.SavedByEntry
Returns a string for display.
toString() - Method in class org.apache.poi.hwpf.model.SectionDescriptor

toString() - Method in class org.apache.poi.hwpf.model.SEPX

toString() - Method in class org.apache.poi.hwpf.model.SinglentonTextPiece

toString() - Method in class org.apache.poi.hwpf.model.StyleDescription

toString() - Method in class org.apache.poi.hwpf.model.TextPiece

toString() - Method in class org.apache.poi.hwpf.model.types.BKFAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.CHPAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.DOPAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.FibBaseAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.FibRgW97AbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.FLDAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.FRDAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.FSPAAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.GrfhicAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.HRESIAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.LFOAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.LSTFAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.LVLFAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.PAPAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.PICFAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.SEPAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.SHD80AbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.SHDAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.StshifAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.TAPAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.TBDAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.TCAbstractType

toString() - Method in class org.apache.poi.hwpf.model.types.TLPAbstractType

toString() - Method in class org.apache.poi.hwpf.model.UPX

toString() - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

toString() - Method in class org.apache.poi.hwpf.sprm.SprmOperation

toString() - Method in class org.apache.poi.hwpf.usermodel.BorderCode

toString() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun

toString() - Method in class org.apache.poi.hwpf.usermodel.DateAndTime

toString() - Method in class org.apache.poi.hwpf.usermodel.DropCapSpecifier

toString() - Method in class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

toString() - Method in class org.apache.poi.hwpf.usermodel.Paragraph

toString() - Method in class org.apache.poi.hwpf.usermodel.Range

toString() - Method in class org.apache.poi.hwpf.usermodel.Section

toString() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor

toString() - Method in class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

toString() - Method in class org.apache.poi.openxml4j.opc.internal.ContentType

toString() - Method in class org.apache.poi.openxml4j.opc.PackagePart

toString() - Method in class org.apache.poi.openxml4j.opc.PackagePartName

toString() - Method in class org.apache.poi.openxml4j.opc.PackageRelationship

toString() - Method in class org.apache.poi.openxml4j.opc.PackageRelationshipCollection

toString() - Method in class org.apache.poi.poifs.filesystem.DocumentDescriptor

toString() - Method in class org.apache.poi.poifs.filesystem.POIFSDocumentPath
Returns a string representation of the path.
toString() - Method in class org.apache.poi.poifs.storage.RawDataBlock

toString() - Method in class org.apache.poi.POIXMLDocumentPart

toString() - Method in class org.apache.poi.ss.formula.constant.ErrorConstant

toString() - Method in class org.apache.poi.ss.formula.eval.BoolEval

toString() - Method in class org.apache.poi.ss.formula.eval.ErrorEval

toString() - Method in class org.apache.poi.ss.formula.eval.NameEval

toString() - Method in class org.apache.poi.ss.formula.eval.NameXEval

toString() - Method in class org.apache.poi.ss.formula.eval.NumberEval

toString() - Method in class org.apache.poi.ss.formula.eval.StringEval

toString() - Method in class org.apache.poi.ss.formula.FormulaShifter

toString() - Method in class org.apache.poi.ss.formula.function.FunctionMetadata

toString() - Method in class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.Area2DPtgBase

toString() - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.ExpPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.MemAreaPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.MemFuncPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.Ptg
Overridden toString method to ensure object hash is not printed.
toString() - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.RefErrorPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.ScalarConstantPtg

toString() - Method in class org.apache.poi.ss.formula.ptg.TblPtg

toString() - Method in class org.apache.poi.ss.usermodel.CellValue

toString() - Method in class org.apache.poi.ss.util.AreaReference

toString() - Method in class org.apache.poi.ss.util.CellRangeAddressBase

toString() - Method in class org.apache.poi.ss.util.CellReference

toString() - Method in class org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer

toString() - Method in class org.apache.poi.util.ByteField
return the value as a String
toString() - Method in interface org.apache.poi.util.FixedField
return the value as a String
toString() - Method in class org.apache.poi.util.IntegerField
return the value as a String
toString() - Method in class org.apache.poi.util.LongField
return the value as a String
toString() - Method in class org.apache.poi.util.ShortField
return the value as a String
toString() - Method in class org.apache.poi.xslf.usermodel.XSLFAutoShape

toString() - Method in class org.apache.poi.xslf.usermodel.XSLFTextParagraph

toString() - Method in class org.apache.poi.xslf.usermodel.XSLFTextRun

toString() - Method in class org.apache.poi.xssf.streaming.SXSSFCell
Returns a string representation of the cell
toString() - Method in class org.apache.poi.xssf.usermodel.XSSFCell
Returns a string representation of the cell
toString() - Method in class org.apache.poi.xssf.usermodel.XSSFClientAnchor

toString() - Method in class org.apache.poi.xssf.usermodel.XSSFFont

toString() - Method in class org.apache.poi.xssf.usermodel.XSSFRichTextString
Returns the plain string representation.
toString() - Method in class org.apache.poi.xssf.usermodel.XSSFRow

toString() - Method in class org.apache.poi.xwpf.usermodel.XWPFRun
Returns the string version of the text, with tabs and carriage returns in place of their xml equivalents.
TOTALLY_IMMUTABLE - Static variable in interface org.apache.poi.ss.formula.IStabilityClassifier
Convenience implementation for situations where all cell definitions remain fixed after evaluation begins.
toText(double) - Static method in class org.apache.poi.ss.util.NumberToTextConverter
Converts the supplied value to the text representation that Excel would give if the value were to appear in an unformatted cell, or as a literal number in a formula.
Note - the results from this method differ slightly from those of Double.toString() In some special cases Excel behaves quite differently.
toURI(String) - Static method in class org.apache.poi.openxml4j.opc.PackagingURIHelper
Convert a string to URI If part name is not a valid URI, it is resolved as follows:
trailerData - Variable in class org.apache.poi.hdgf.chunks.ChunkTrailer

TrailerStream - Class in org.apache.poi.hdgf.streams
The TrailerStream is a special kind of Stream containing pointers, and some core document settings.
TrailerStream(Pointer, StreamStore, ChunkFactory, PointerFactory) - Constructor for class org.apache.poi.hdgf.streams.TrailerStream

transform(Shape, Rectangle2D) - Static method in class org.apache.poi.hslf.model.AutoShapes
Auto-shapes are defined in the [0,21600] coordinate system.
transform(AffineTransform) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Composes an AffineTransform object with the Transform in this Graphics2D according to the rule last-specified-first-applied.
transform(AffineTransform) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

transform(AffineTransform) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

TRANSFORM__ROTATION - Static variable in class org.apache.poi.ddf.EscherProperties

translate(int, int) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Translates the origin of the graphics context to the point (x, y) in the current coordinate system.
translate(double, double) - Method in class org.apache.poi.hslf.model.PPGraphics2D
Concatenates the current Graphics2D Transform with a translation transform.
translate(double, double) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

translate(int, int) - Method in class org.apache.poi.hssf.usermodel.DummyGraphics2d

translate(int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics

translate(double, double) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

translate(int, int) - Method in class org.apache.poi.hssf.usermodel.EscherGraphics2d

translateUnicodeValues(HSSFCell) - Static method in class org.apache.poi.hssf.util.HSSFCellUtil
Looks for text in the cell that should be unicode, like α and provides the unicode version of it.
translateUnicodeValues(Cell) - Static method in class org.apache.poi.ss.util.CellUtil
Looks for text in the cell that should be unicode, like α and provides the unicode version of it.
TRANSMITABLE_DISPLAY_NAME - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TRANSPORT_KEY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TRANSPORT_MESSAGE_HEADERS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TRANSPORT_PROVIDERS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TRANSPORT_STATUS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Trapezoid - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

TRAPEZOID - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

traverse(CellHandler) - Method in class org.apache.poi.ss.util.cellwalk.CellWalk
Traverse cell range from top left to bottom right cell.
TRIANGLE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

TRIM - Static variable in class org.apache.poi.ss.formula.functions.TextFunction
An implementation of the TRIM function: Removes leading and trailing spaces from value if evaluated operand value is string.
triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.AQUA

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLACK

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.BROWN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.CORAL

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_RED

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.GOLD

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREEN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.INDIGO

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LAVENDER

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.LIME

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.MAROON

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.ORANGE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.ORCHID

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.PINK

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.PLUM

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.RED

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.ROSE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.TAN

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.TEAL

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.VIOLET

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.WHITE

triplet - Static variable in class org.apache.poi.hssf.util.HSSFColor.YELLOW

TRUE - Static variable in class org.apache.poi.ss.formula.eval.BoolEval

TRUE - Static variable in class org.apache.poi.ss.formula.functions.BooleanFunction

TRUE - Static variable in class org.apache.poi.ss.usermodel.CellValue

TRUNC - Static variable in class org.apache.poi.ss.formula.functions.NumericFunction

tryDeadField(HWPFDocumentCore, Range, int, int, Element) - Method in class org.apache.poi.hwpf.converter.AbstractWordConverter

TTYTDD_PHONE_NUMBER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TWIPS_PER_INCH - Static variable in class org.apache.poi.hwpf.converter.AbstractWordUtils

TWIPS_PER_PT - Static variable in class org.apache.poi.hwpf.converter.AbstractWordUtils

TwoDEval - Interface in org.apache.poi.ss.formula
Common interface of AreaEval and AreaEvalBase
TwoOperandNumericOperation - Class in org.apache.poi.ss.formula.eval

TwoOperandNumericOperation() - Constructor for class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

TxCFStyleAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TxInteractiveInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TxInteractiveInfoAtom - Class in org.apache.poi.hslf.record
Tne atom that holds starting and ending character positions of a hyperlink
TxInteractiveInfoAtom() - Constructor for class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Constructs a brand new link related atom record.
TxInteractiveInfoAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Constructs the link related atom record from its source data.
TxMasterStyleAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TxMasterStyleAtom - Class in org.apache.poi.hslf.record
TxMasterStyleAtom atom (4003).
TxMasterStyleAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.TxMasterStyleAtom

TxPFStyleAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

TxSIStyleAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

type - Variable in class org.apache.poi.hdgf.chunks.ChunkHeader

type - Variable in class org.apache.poi.hdgf.pointers.Pointer

type - Variable in class org.apache.poi.hpsf.Property
The property's type.
type - Variable in class org.apache.poi.hslf.model.PPFont

type - Variable in class org.apache.poi.hsmf.datatypes.Chunk

type() - Method in class org.apache.poi.hwpf.usermodel.CharacterRun
Here for runtime type determination using a switch statement convenient.
type() - Method in class org.apache.poi.hwpf.usermodel.ListEntry
Deprecated.
type() - Method in class org.apache.poi.hwpf.usermodel.Paragraph
Deprecated.
type() - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
type() - Method in class org.apache.poi.hwpf.usermodel.Section

type() - Method in class org.apache.poi.hwpf.usermodel.Table

TYPE_ARRAY - Static variable in class org.apache.poi.ddf.EscherPropertyMetaData

TYPE_ATTRIBUTE_NAME - Static variable in class org.apache.poi.openxml4j.opc.PackageRelationship

TYPE_BINARY - Static variable in class org.apache.poi.ss.formula.ptg.OperationPtg

TYPE_BOOLEAN - Static variable in class org.apache.poi.ddf.EscherPropertyMetaData

TYPE_BOTTOM - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

TYPE_BYTE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_CHARACTER - Static variable in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
TYPE_CHART - Static variable in class org.apache.poi.hssf.record.BOFRecord

TYPE_CHP - Static variable in class org.apache.poi.hwpf.sprm.SprmOperation

TYPE_CONTROL - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom
The OLE object is an ActiveX control.
TYPE_CORNER - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

TYPE_DATE - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_DWORD - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_EMBEDDED - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom
An embedded OLE object; the object is serialized and saved within the file.
TYPE_EXCEL_4_MACRO - Static variable in class org.apache.poi.hssf.record.BOFRecord

TYPE_FUNCTION - Static variable in class org.apache.poi.ss.formula.ptg.OperationPtg

TYPE_LEFT - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

TYPE_LINKED - Static variable in class org.apache.poi.hslf.record.ExOleObjAtom
A linked OLE object; the object is saved outside of the file.
TYPE_LISTENTRY - Static variable in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
TYPE_LONG - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_MAX - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_OF_MTS_USER - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

TYPE_PAP - Static variable in class org.apache.poi.hwpf.sprm.SprmOperation

TYPE_PARAGRAPH - Static variable in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
TYPE_PIC - Static variable in class org.apache.poi.hwpf.sprm.SprmOperation

TYPE_RGB - Static variable in class org.apache.poi.ddf.EscherPropertyMetaData

TYPE_RIGHT - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

TYPE_SECTION - Static variable in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
TYPE_SEP - Static variable in class org.apache.poi.hwpf.sprm.SprmOperation

TYPE_SHAPEPATH - Static variable in class org.apache.poi.ddf.EscherPropertyMetaData

TYPE_SHORT - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_SIMPLE - Static variable in class org.apache.poi.ddf.EscherPropertyMetaData

TYPE_STRING - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_TABLE - Static variable in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
TYPE_TAP - Static variable in class org.apache.poi.hwpf.sprm.SprmOperation

TYPE_TEXT - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_TEXT - Static variable in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
TYPE_TOP - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

TYPE_TRIPLES - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_UNARY - Static variable in class org.apache.poi.ss.formula.ptg.OperationPtg

TYPE_UNDEFINED - Static variable in class org.apache.poi.hwpf.usermodel.Range
Deprecated.
TYPE_UNDOCKED - Static variable in class org.apache.poi.hssf.record.chart.LegendRecord

TYPE_UNKNOWN - Static variable in class org.apache.poi.ddf.EscherPropertyMetaData

TYPE_VB_MODULE - Static variable in class org.apache.poi.hssf.record.BOFRecord

TYPE_WORD - Static variable in class org.apache.poi.hmef.attribute.TNEFProperty

TYPE_WORKBOOK - Static variable in class org.apache.poi.hssf.record.BOFRecord

TYPE_WORKSHEET - Static variable in class org.apache.poi.hssf.record.BOFRecord

TYPE_WORKSPACE_FILE - Static variable in class org.apache.poi.hssf.record.BOFRecord

typeID - Variable in class org.apache.poi.hslf.record.RecordTypes.Type

typeName(int) - Static method in class org.apache.poi.hslf.model.ShapeTypes
Return name of the shape by id
typeOfPLCS - Variable in class org.apache.poi.hpbf.model.qcbits.QCPLCBit

types - Static variable in class org.apache.poi.hslf.model.ShapeTypes

Types - Class in org.apache.poi.hsmf.datatypes
The types list and details are available from http://msdn.microsoft.com/en-us/library/microsoft.exchange.data.contenttypes.tnef.tnefpropertytype%28v=EXCHG.140%29.aspx
Types() - Constructor for class org.apache.poi.hsmf.datatypes.Types

TYPES_NAMESPACE_URI - Static variable in class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Content type namespace
TypesLister - Class in org.apache.poi.hsmf.dev
Lists the different MAPI types
TypesLister() - Constructor for class org.apache.poi.hsmf.dev.TypesLister

typeToClass - Static variable in class org.apache.poi.hslf.record.RecordTypes

typeToName - Static variable in class org.apache.poi.hslf.record.RecordTypes

TypeWriter - Class in org.apache.poi.hpsf
Class for writing little-endian data and more.
TypeWriter() - Constructor for class org.apache.poi.hpsf.TypeWriter

U

U_DOUBLE - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Underline type - Double
U_DOUBLE - Static variable in class org.apache.poi.hssf.record.FontRecord

U_DOUBLE - Static variable in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
Underline type - Double
U_DOUBLE - Static variable in interface org.apache.poi.ss.usermodel.Font
double underlined
U_DOUBLE - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Underline type - Double
U_DOUBLE_ACCOUNTING - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Underline type - Double Accounting
U_DOUBLE_ACCOUNTING - Static variable in class org.apache.poi.hssf.record.FontRecord

U_DOUBLE_ACCOUNTING - Static variable in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
Underline type - Double Accounting
U_DOUBLE_ACCOUNTING - Static variable in interface org.apache.poi.ss.usermodel.Font
accounting style double underline
U_DOUBLE_ACCOUNTING - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Underline type - Double Accounting
U_NONE - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Underline type - None
U_NONE - Static variable in class org.apache.poi.hssf.record.FontRecord

U_NONE - Static variable in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
Underline type - None
U_NONE - Static variable in interface org.apache.poi.ss.usermodel.Font
not underlined
U_NONE - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Underline type - None
U_SINGLE - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Underline type - Single
U_SINGLE - Static variable in class org.apache.poi.hssf.record.FontRecord

U_SINGLE - Static variable in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
Underline type - Single
U_SINGLE - Static variable in interface org.apache.poi.ss.usermodel.Font
single (normal) underline
U_SINGLE - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Underline type - Single
U_SINGLE_ACCOUNTING - Static variable in class org.apache.poi.hssf.record.cf.FontFormatting
Underline type - Single Accounting
U_SINGLE_ACCOUNTING - Static variable in class org.apache.poi.hssf.record.FontRecord

U_SINGLE_ACCOUNTING - Static variable in class org.apache.poi.hssf.usermodel.HSSFFontFormatting
Underline type - Single Accounting
U_SINGLE_ACCOUNTING - Static variable in interface org.apache.poi.ss.usermodel.Font
accounting style single underline
U_SINGLE_ACCOUNTING - Static variable in interface org.apache.poi.ss.usermodel.FontFormatting
Underline type - Single Accounting
ubyteToInt(byte) - Static method in class org.apache.poi.util.LittleEndian
Convert an 'unsigned' byte to an integer.
UDF - Static variable in class org.apache.poi.ss.formula.OperationEvaluationContext

UDFFinder - Interface in org.apache.poi.ss.formula.udf
Common interface for "Add-in" libraries and user defined function libraries.
ultimateType(Cell) - Static method in class org.apache.poi.ss.format.CellFormat
Returns the ultimate cell type, following the results of formulas.
UnaryMinusEval - Class in org.apache.poi.ss.formula.eval

UnaryMinusPtg - Class in org.apache.poi.ss.formula.ptg
Unary Plus operator does not have any effect on the operand
UnaryPlusEval - Class in org.apache.poi.ss.formula.eval

UnaryPlusPtg - Class in org.apache.poi.ss.formula.ptg
Unary Plus operator does not have any effect on the operand
UncalcedRecord - Class in org.apache.poi.hssf.record
Title: Uncalced Record
UncalcedRecord() - Constructor for class org.apache.poi.hssf.record.UncalcedRecord

UncalcedRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.UncalcedRecord

uncompressCHP(CharacterProperties, byte[], int) - Static method in class org.apache.poi.hwpf.sprm.CharacterSprmUncompressor

UNCOMPRESSED_SIGNATURE - Static variable in class org.apache.poi.hmef.CompressedRTF

UNCOMPRESSED_SIGNATURE_INT - Static variable in class org.apache.poi.hmef.CompressedRTF

uncompressPAP(ParagraphProperties, byte[], int) - Static method in class org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor

uncompressSEP(byte[], int) - Static method in class org.apache.poi.hwpf.sprm.SectionSprmUncompressor

uncompressTAP(byte[], int) - Static method in class org.apache.poi.hwpf.sprm.TableSprmUncompressor
Deprecated.
uncompressTAP(SprmBuffer) - Static method in class org.apache.poi.hwpf.sprm.TableSprmUncompressor

UNDEFINED - Static variable in class org.apache.poi.hpsf.wellknown.SectionIDMap
A property without a known name is described by this string.
UNDERLINE_IDX - Static variable in class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

UnderlinePatterns - Enum in org.apache.poi.xwpf.usermodel
Specifies the types of patterns which may be used to create the underline applied beneath the text in a run.
UnexpectedPropertySetTypeException - Exception in org.apache.poi.hpsf
This exception is thrown if a certain type of property set is expected (e.g.
UnexpectedPropertySetTypeException() - Constructor for exception org.apache.poi.hpsf.UnexpectedPropertySetTypeException
Creates an UnexpectedPropertySetTypeException.
UnexpectedPropertySetTypeException(String) - Constructor for exception org.apache.poi.hpsf.UnexpectedPropertySetTypeException
Creates an UnexpectedPropertySetTypeException with a message string.
UnexpectedPropertySetTypeException(Throwable) - Constructor for exception org.apache.poi.hpsf.UnexpectedPropertySetTypeException
Creates a new UnexpectedPropertySetTypeException with a reason.
UnexpectedPropertySetTypeException(String, Throwable) - Constructor for exception org.apache.poi.hpsf.UnexpectedPropertySetTypeException
Creates an UnexpectedPropertySetTypeException with a message string and a reason.
ungroupColumn(short, short) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Deprecated. (Sep 2008) use HSSFSheet.ungroupColumn(int, int)
ungroupColumn(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

ungroupColumn(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Ungroup a range of columns that were previously groupped
ungroupColumn(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Ungroup a range of columns that were previously groupped
ungroupColumn(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

ungroupRow(int, int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet

ungroupRow(int, int) - Method in interface org.apache.poi.ss.usermodel.Sheet
Ungroup a range of rows that were previously groupped
ungroupRow(int, int) - Method in class org.apache.poi.xssf.streaming.SXSSFSheet
Ungroup a range of rows that were previously groupped
ungroupRow(int, int) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet
Ungroup a range of rows that were previously groupped
UnhandledDataStructure - Class in org.apache.poi.hwpf.model

UnhandledDataStructure(byte[], int, int) - Constructor for class org.apache.poi.hwpf.model.UnhandledDataStructure

UNICODE_STRING - Static variable in class org.apache.poi.hsmf.datatypes.Types
A string, from Outlook 3.0 onwards.
UNICODECHAR_NO_BREAK_SPACE - Static variable in class org.apache.poi.hwpf.converter.AbstractWordConverter

UNICODECHAR_NONBREAKING_HYPHEN - Static variable in class org.apache.poi.hwpf.converter.AbstractWordConverter

UNICODECHAR_ZERO_WIDTH_SPACE - Static variable in class org.apache.poi.hwpf.converter.AbstractWordConverter

UnicodeString - Class in org.apache.poi.hssf.record.common
Title: Unicode String
Description: Unicode String - just standard fields that are in several records.
UnicodeString(String) - Constructor for class org.apache.poi.hssf.record.common.UnicodeString

UnicodeString(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.common.UnicodeString
construct a unicode string record and fill its fields, ID is ignored
UnicodeString - Class in org.apache.poi.hssf.record
Deprecated. Use UnicodeString instead
UnicodeString(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.UnicodeString
Deprecated. Use UnicodeString instead
UnicodeString(String) - Constructor for class org.apache.poi.hssf.record.UnicodeString
Deprecated. Use UnicodeString instead
UnicodeString.ExtRst - Class in org.apache.poi.hssf.record.common

UnicodeString.ExtRst() - Constructor for class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

UnicodeString.ExtRst(LittleEndianInput, int) - Constructor for class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

UnicodeString.FormatRun - Class in org.apache.poi.hssf.record.common

UnicodeString.FormatRun(short, short) - Constructor for class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

UnicodeString.FormatRun(LittleEndianInput) - Constructor for class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

UnicodeString.PhRun - Class in org.apache.poi.hssf.record.common

UnicodeString.PhRun(int, int, int) - Constructor for class org.apache.poi.hssf.record.common.UnicodeString.PhRun

UnionPtg - Class in org.apache.poi.ss.formula.ptg

Units - Class in org.apache.poi.util

Units() - Constructor for class org.apache.poi.util.Units

UnitsRecord - Class in org.apache.poi.hssf.record.chart
The units record describes units.

UnitsRecord() - Constructor for class org.apache.poi.hssf.record.chart.UnitsRecord

UnitsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.UnitsRecord

Unknown - Static variable in class org.apache.poi.hslf.record.RecordTypes

UNKNOWN - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

unknown1 - Variable in class org.apache.poi.hdgf.chunks.ChunkHeader

unknown2 - Variable in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

unknown2 - Variable in class org.apache.poi.hdgf.chunks.ChunkHeaderV6

unknown3 - Variable in class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

unknown3 - Variable in class org.apache.poi.hdgf.chunks.ChunkHeaderV6

UnknownEscherRecord - Class in org.apache.poi.ddf
This record is used whenever a escher record is encountered that we do not explicitly support.
UnknownEscherRecord() - Constructor for class org.apache.poi.ddf.UnknownEscherRecord

UnknownPtg - Class in org.apache.poi.ss.formula.ptg

UnknownPtg(int) - Constructor for class org.apache.poi.ss.formula.ptg.UnknownPtg

UnknownQCBit - Class in org.apache.poi.hpbf.model.qcbits
Any Quill Contents bits we don't know how to handle explicitly
UnknownQCBit(String, String, byte[]) - Constructor for class org.apache.poi.hpbf.model.qcbits.UnknownQCBit

UnknownRecord - Class in org.apache.poi.hssf.record
Title: Unknown Record (for debugging)
Description: Unknown record just tells you the sid so you can figure out what records you are missing.
UnknownRecord(int, byte[]) - Constructor for class org.apache.poi.hssf.record.UnknownRecord

UnknownRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.UnknownRecord
construct an unknown record.
UnknownRecordPlaceholder - Class in org.apache.poi.hslf.record
If we come across a record we don't know about, we create one of these.
UnknownRecordPlaceholder(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.UnknownRecordPlaceholder
Create a new holder for a record we don't grok
UnknownStream - Class in org.apache.poi.hdgf.streams
A placeholder for a stream where we don't known anything about how to process / handle it
UnknownStream(Pointer, StreamStore) - Constructor for class org.apache.poi.hdgf.streams.UnknownStream

unlink(SharedFormulaRecord) - Method in class org.apache.poi.hssf.record.aggregates.SharedValueManager
Converts all FormulaRecords handled by sharedFormulaRecord to plain unshared formulas
unlinkSharedFormula() - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

unLockRevision() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Unlocks the workbook for revisions.
unLockStructure() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Unlocks the structure of workbook.
unLockWindows() - Method in class org.apache.poi.xssf.usermodel.XSSFWorkbook
Unlocks the windows that comprise the workbook.
unmarshall(UnmarshallContext, InputStream) - Method in interface org.apache.poi.openxml4j.opc.internal.PartUnmarshaller
Save the content of the package in the stream
unmarshall(UnmarshallContext, InputStream) - Method in class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

UnmarshallContext - Class in org.apache.poi.openxml4j.opc.internal.unmarshallers
Context needed for the unmarshall process of a part.
UnmarshallContext(OPCPackage, PackagePartName) - Constructor for class org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext
Constructor.
UNSPECIFIED - Static variable in class org.apache.poi.hsmf.datatypes.Types
Unspecified
unsupportedMessage - Static variable in class org.apache.poi.hpsf.VariantSupport
Keeps a list of the variant types an "unsupported" message has already been issued for.
UnsupportedVariantTypeException - Exception in org.apache.poi.hpsf
This exception is thrown if HPSF encounters a variant type that isn't supported yet.
UnsupportedVariantTypeException(long, Object) - Constructor for exception org.apache.poi.hpsf.UnsupportedVariantTypeException
Constructor.
UNUSED - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

UNUSED_BLOCK - Static variable in interface org.apache.poi.poifs.common.POIFSConstants
Indicates the sector is not used (0xFFFFFFFF)
unwriteProtectWorkbook() - Method in class org.apache.poi.hssf.model.InternalWorkbook
removes the write protect flag
unwriteProtectWorkbook() - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
removes the write protect flag
UP_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

UP_ARROW_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

UP_DOWN_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

UP_DOWN_ARROW_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

UpArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

UpArrowCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

update(FontReplacer.Triplet) - Method in class org.apache.poi.hwpf.converter.DefaultFontReplacer

update(FontReplacer.Triplet) - Method in interface org.apache.poi.hwpf.converter.FontReplacer

updateCell(String, int, int, ValueEval) - Method in class org.apache.poi.ss.formula.eval.forked.ForkedEvaluator
Sets the specified cell to the supplied value
updateCellNum(short) - Method in class org.apache.poi.hssf.usermodel.HSSFCell
Updates the cell record's idea of what column it belongs in (0 based)
updateClientData() - Method in class org.apache.poi.hslf.model.SimpleShape

updateConditionalFormatting(FormulaShifter) - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter

updateContents(byte[]) - Method in class org.apache.poi.poifs.filesystem.NPOIFSStream
Updates the contents of the stream to the new set of bytes.
updateFormulas(FormulaShifter) - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter
Update formulas.
updateFormulasAfterCellShift(FormulaShifter, int) - Method in class org.apache.poi.hssf.model.InternalSheet
Updates formulas in cells and conditional formats due to moving of cells
updateFormulasAfterCellShift(FormulaShifter, int) - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

updateFormulasAfterCellShift(FormulaShifter, int) - Method in class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

updateFormulasAfterRowShift(FormulaShifter, int) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

updateFormulasAfterRowShift(FormulaShifter, int) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

updateNameCommentRecordCache(NameCommentRecord) - Method in class org.apache.poi.hssf.model.InternalWorkbook
If a NameCommentRecord is added or the name it references is renamed, then this will update the lookup cache for it.
updateNamedRanges(FormulaShifter) - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter
Updated named ranges
updateNamesAfterCellShift(FormulaShifter) - Method in class org.apache.poi.hssf.model.InternalWorkbook
Updates named ranges due to moving of cells
updateOtherRecordReferences(Hashtable<Integer, Integer>) - Method in class org.apache.poi.hslf.record.ExOleObjStg

updateOtherRecordReferences(Hashtable<Integer, Integer>) - Method in class org.apache.poi.hslf.record.PersistPtrHolder
At write-out time, update the references to the sheets to their new positions
updateOtherRecordReferences(Hashtable<Integer, Integer>) - Method in interface org.apache.poi.hslf.record.PositionDependentRecord
Offer the record the list of records that have changed their location as part of the writeout.
updateOtherRecordReferences(Hashtable<Integer, Integer>) - Method in class org.apache.poi.hslf.record.PositionDependentRecordAtom
Offer the record the list of records that have changed their location as part of the writeout.
updateOtherRecordReferences(Hashtable<Integer, Integer>) - Method in class org.apache.poi.hslf.record.PositionDependentRecordContainer
Since we're a container, we don't mind if other records move about.
updateOtherRecordReferences(Hashtable<Integer, Integer>) - Method in class org.apache.poi.hslf.record.UserEditAtom
At write-out time, update the references to PersistPtrs and other UserEditAtoms to point to their new positions
updateSheetName(int, String) - Method in class org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils
Update sheet name in all formulas and named ranges.
updateSprm(short, byte) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

updateSprm(short, boolean) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

updateSprm(short, int) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

updateSprm(short, short) - Method in class org.apache.poi.hwpf.sprm.SprmBuffer

updateStartPosition(int) - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Tells the RichTextRun its new position in the parent TextRun
updateStylesheet() - Method in class org.apache.poi.hwpf.converter.HtmlDocumentFacade

updateTextSize(int) - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection
Update the size of the text that this set of properties applies to
UpDownArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

UpDownArrowCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

UPPER - Static variable in class org.apache.poi.ss.formula.functions.TextFunction

UPX - Class in org.apache.poi.hwpf.model

UPX(byte[]) - Constructor for class org.apache.poi.hwpf.model.UPX

USE_A1_MODE - Static variable in class org.apache.poi.hssf.record.RefModeRecord

USE_R1C1_MODE - Static variable in class org.apache.poi.hssf.record.RefModeRecord

USER_CERTIFICATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

USER_X509_CERTIFICATE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

USERDATEATOM - Static variable in class org.apache.poi.hslf.record.HeadersFootersContainer

UserEditAndPersistListing - Class in org.apache.poi.hslf.dev
Uses record level code to locate UserEditAtom records, and other persistence related atoms.
UserEditAndPersistListing() - Constructor for class org.apache.poi.hslf.dev.UserEditAndPersistListing

UserEditAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

UserEditAtom - Class in org.apache.poi.hslf.record
A UserEdit Atom (type 4085).
UserEditAtom(byte[], int, int) - Constructor for class org.apache.poi.hslf.record.UserEditAtom
For the UserEdit Atom
UserSViewBegin - Class in org.apache.poi.hssf.record
The UserSViewBegin record specifies settings for a custom view associated with the sheet.
UserSViewBegin(byte[]) - Constructor for class org.apache.poi.hssf.record.UserSViewBegin

UserSViewBegin(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.UserSViewBegin
construct an UserSViewBegin record.
UserSViewEnd - Class in org.apache.poi.hssf.record
The UserSViewEnd record marks the end of the settings for a custom view associated with the sheet
UserSViewEnd(byte[]) - Constructor for class org.apache.poi.hssf.record.UserSViewEnd

UserSViewEnd(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.UserSViewEnd
construct an UserSViewEnd record.
USES_MASTER_SLIDE_ID - Static variable in class org.apache.poi.hslf.record.SlideAtom

UseSelFSRecord - Class in org.apache.poi.hssf.record
Title: USESELFS (0x0160) - Use Natural Language Formulas Flag
Description: Tells the GUI if this was written by something that can use "natural language" formulas.
UseSelFSRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.UseSelFSRecord

UseSelFSRecord(boolean) - Constructor for class org.apache.poi.hssf.record.UseSelFSRecord

usesUnicode() - Method in class org.apache.poi.hwpf.usermodel.Range
Deprecated. Range is not linked to any text piece anymore, so to check if unicode is used please access TextPieceTable during document load time
USKF - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

USP - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

usualType - Variable in class org.apache.poi.hmef.attribute.TNEFProperty
Usual Type
usualType - Variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Util - Class in org.apache.poi.hpsf
Provides various static utility methods.
Util() - Constructor for class org.apache.poi.hpsf.Util

UTURN_ARROW - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

UturnArrow - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

V

VALID_FOLDER_MASK - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

validate(byte[], byte[]) - Method in class org.apache.poi.hssf.record.crypto.Biff8EncryptionKey

validate(SpreadsheetVersion) - Method in class org.apache.poi.ss.util.CellRangeAddressBase
Validate the range limits against the supplied version of Excel
validate() - Method in class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

validateColumn(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Runs a bounds check for column numbers
validatePackage(OPCPackage) - Method in class org.apache.poi.openxml4j.opc.OPCPackage
Validates the package compliance with the OPC specifications.
validateRow(int) - Method in class org.apache.poi.hssf.usermodel.HSSFSheet
Runs a bounds check for row numbers
validateSecondArg(int, String) - Static method in class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

validateSheetName(String) - Static method in class org.apache.poi.ss.util.WorkbookUtil
Validates sheet name.
validateSheetState(int) - Static method in class org.apache.poi.ss.util.WorkbookUtil

value - Variable in class org.apache.poi.hdgf.chunks.Chunk.Command

value - Variable in class org.apache.poi.hpsf.Property
The property's value.
value() - Method in enum org.apache.poi.openxml4j.opc.CompressionOption

Value - Class in org.apache.poi.ss.formula.functions
Implementation for Excel VALUE() function.
Syntax:
VALUE(text)
Converts the text argument to a number.
Value() - Constructor for class org.apache.poi.ss.formula.functions.Value

VALUE_INVALID - Static variable in class org.apache.poi.ss.formula.eval.ErrorEval
#VALUE! - Wrong type of operand
VALUE_INVALID - Static variable in class org.apache.poi.ss.formula.ptg.ErrPtg
#VALUE! - Wrong type of operand
ValueAxis - Interface in org.apache.poi.ss.usermodel.charts

ValueEval - Interface in org.apache.poi.ss.formula.eval

valueOf(String) - Static method in enum org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.model.FieldsDocumentPart
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.model.FSPADocumentPart
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.model.NoteType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.model.SubdocumentType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalPositioning
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalRelativeElement
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalPositioning
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalRelativeElement
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.hwpf.usermodel.PictureType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.openxml4j.opc.CertificateEmbeddingOption
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.openxml4j.opc.CompressionOption
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.openxml4j.opc.EncryptionOption
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.openxml4j.opc.PackageAccess
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.openxml4j.opc.TargetMode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.format.CellFormatType
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in class org.apache.poi.ss.formula.constant.ErrorConstant

valueOf(boolean) - Static method in class org.apache.poi.ss.formula.eval.BoolEval
Convenience method for the following:
(b ? BoolEval.TRUE : BoolEval.FALSE)
valueOf(int) - Static method in class org.apache.poi.ss.formula.eval.ErrorEval
Translates an Excel internal error code into the corresponding POI ErrorEval instance
valueOf(boolean) - Static method in class org.apache.poi.ss.formula.ptg.BoolPtg

valueOf(int) - Static method in class org.apache.poi.ss.formula.ptg.ErrPtg

valueOf(String) - Static method in enum org.apache.poi.ss.SpreadsheetVersion
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.BorderStyle
Returns the enum constant of this type with the specified name.
valueOf(boolean) - Static method in class org.apache.poi.ss.usermodel.CellValue

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.charts.AxisCrossBetween
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.charts.AxisCrosses
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.charts.AxisOrientation
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.charts.AxisPosition
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.charts.LayoutMode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.charts.LayoutTarget
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.charts.LegendPosition
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.FillPatternType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.FontCharset
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.ss.usermodel.FontCharset

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.FontFamily
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.ss.usermodel.FontFamily

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.FontScheme
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.ss.usermodel.FontScheme

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.FontUnderline
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.ss.usermodel.FontUnderline

valueOf(byte) - Static method in enum org.apache.poi.ss.usermodel.FontUnderline

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.FormulaError
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.HorizontalAlignment
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.IndexedColors
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.PageOrder
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.ss.usermodel.PageOrder

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.PaperSize
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.PrintCellComments
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.ss.usermodel.PrintCellComments

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.PrintOrientation
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.ss.usermodel.PrintOrientation

valueOf(String) - Static method in enum org.apache.poi.ss.usermodel.VerticalAlignment
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in class org.apache.poi.ss.util.CellRangeAddress

valueOf(String) - Static method in enum org.apache.poi.ss.util.CellReference.NameType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.LineCap
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.LineDash
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.LineDecoration
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.LineEndLength
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.LineEndWidth
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.ListAutoNumber
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.Placeholder
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.SlideLayout
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.TextAlign
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.TextAutofit
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.TextCap
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.TextDirection
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.VerticalAlignment
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xslf.usermodel.XSLFShapeType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder.BorderSide
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.BodyElementType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.BodyType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.Borders
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.Borders

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.BreakClear
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.BreakClear

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.BreakType
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.BreakType

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.LineSpacingRule
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.LineSpacingRule

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.ParagraphAlignment
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.ParagraphAlignment

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.TextAlignment
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.TextAlignment

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.UnderlinePatterns
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.UnderlinePatterns

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.VerticalAlign
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum org.apache.poi.xwpf.usermodel.VerticalAlign

valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.XWPFTable.XWPFBorderType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum org.apache.poi.xwpf.usermodel.XWPFTableCell.XWPFVertAlign
Returns the enum constant of this type with the specified name.
valueOfIco(int) - Static method in class org.apache.poi.hwpf.model.Colorref

ValueOperatorPtg - Class in org.apache.poi.ss.formula.ptg
Common superclass of all value operators.
ValueOperatorPtg() - Constructor for class org.apache.poi.ss.formula.ptg.ValueOperatorPtg

ValueRangeRecord - Class in org.apache.poi.hssf.record.chart
The value range record defines the range of the value axis.

ValueRangeRecord() - Constructor for class org.apache.poi.hssf.record.chart.ValueRangeRecord

ValueRangeRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.chart.ValueRangeRecord

ValueRecordsAggregate - Class in org.apache.poi.hssf.record.aggregates
Aggregate value records together.
ValueRecordsAggregate() - Constructor for class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate
Creates a new instance of ValueRecordsAggregate
values() - Static method in enum org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.model.FieldsDocumentPart
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.model.FSPADocumentPart
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.model.NoteType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.model.SubdocumentType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalPositioning
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalRelativeElement
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalPositioning
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalRelativeElement
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.hwpf.usermodel.PictureType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.openxml4j.opc.CertificateEmbeddingOption
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.openxml4j.opc.CompressionOption
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.openxml4j.opc.EncryptionOption
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.openxml4j.opc.PackageAccess
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.openxml4j.opc.TargetMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.format.CellFormatType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.SpreadsheetVersion
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.BorderStyle
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.charts.AxisCrossBetween
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.charts.AxisCrosses
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.charts.AxisOrientation
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.charts.AxisPosition
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.charts.LayoutMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.charts.LayoutTarget
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.charts.LegendPosition
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.FillPatternType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.FontCharset
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.FontFamily
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.FontScheme
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.FontUnderline
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.FormulaError
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.HorizontalAlignment
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.IndexedColors
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.PageOrder
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.PaperSize
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.PrintCellComments
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.PrintOrientation
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.usermodel.VerticalAlignment
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.ss.util.CellReference.NameType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class org.apache.poi.util.BinaryTree
Returns a collection view of the values contained in this map.
values() - Static method in enum org.apache.poi.xslf.usermodel.LineCap
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.LineDash
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.LineDecoration
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.LineEndLength
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.LineEndWidth
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.ListAutoNumber
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.Placeholder
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.SlideLayout
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.TextAlign
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.TextAutofit
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.TextCap
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.TextDirection
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.VerticalAlignment
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xslf.usermodel.XSLFShapeType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder.BorderSide
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.BodyElementType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.BodyType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.Borders
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.BreakClear
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.BreakType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.LineSpacingRule
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.ParagraphAlignment
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.TextAlignment
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.UnderlinePatterns
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.VerticalAlign
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.XWPFTable.XWPFBorderType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum org.apache.poi.xwpf.usermodel.XWPFTableCell.XWPFVertAlign
Returns an array containing the constants of this enum type, in the order they are declared.
VALUES_DATA_TYPE_DATES - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

VALUES_DATA_TYPE_NUMERIC - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

VALUES_DATA_TYPE_SEQUENCE - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

VALUES_DATA_TYPE_TEXT - Static variable in class org.apache.poi.hssf.record.chart.SeriesRecord

valuesByValue() - Method in class org.apache.poi.util.BinaryTree
Returns a collection view of the values contained in this map.
VAR - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

VARIABLE_PITCH - Static variable in class org.apache.poi.hslf.model.PPFont

Variant - Class in org.apache.poi.hpsf
The Variant types as defined by Microsoft's COM.
Variant() - Constructor for class org.apache.poi.hpsf.Variant

VariantSupport - Class in org.apache.poi.hpsf
Supports reading and writing of variant data.
VariantSupport() - Constructor for class org.apache.poi.hpsf.VariantSupport

VariantTypeException - Exception in org.apache.poi.hpsf
This exception is thrown if HPSF encounters a problem with a variant type.
VariantTypeException(long, Object, String) - Constructor for exception org.apache.poi.hpsf.VariantTypeException
Constructor.
VARP - Static variable in class org.apache.poi.ss.formula.functions.AggregateFunction

VBA_MACROS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

VBAInfo - Static variable in class org.apache.poi.hslf.record.RecordTypes

VBAInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

VCenterRecord - Class in org.apache.poi.hssf.record
Title: VCenter record
VCenterRecord() - Constructor for class org.apache.poi.hssf.record.VCenterRecord

VCenterRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.VCenterRecord

verifyAndBuildPOIFS(InputStream) - Static method in class org.apache.poi.hwpf.HWPFDocumentCore
Takens an InputStream, verifies that it's not RTF, builds a POIFSFileSystem from it, and returns that.
verifyBelongsToStylesSource(StylesTable) - Method in class org.apache.poi.xssf.usermodel.XSSFCellStyle
Verifies that this style belongs to the supplied Workbook Styles Source.
verifyBelongsToWorkbook(HSSFWorkbook) - Method in class org.apache.poi.hssf.usermodel.HSSFCellStyle
Verifies that this style belongs to the supplied Workbook.
verifyPassword(String) - Method in class org.apache.poi.poifs.crypt.AgileDecryptor

verifyPassword(String) - Method in class org.apache.poi.poifs.crypt.Decryptor

verifyPassword(String) - Method in class org.apache.poi.poifs.crypt.EcmaDecryptor

VERSION - Static variable in class org.apache.poi.hssf.record.BOFRecord
suggested default (0x0600 - BIFF8)
version - Variable in class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
The version number.
VERTICAL_ALIGNMENT - Static variable in class org.apache.poi.ss.util.CellUtil

VERTICAL_ALIGNMENT_BOTTOM - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

VERTICAL_ALIGNMENT_BOTTOM - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

VERTICAL_ALIGNMENT_CENTER - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

VERTICAL_ALIGNMENT_CENTER - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

VERTICAL_ALIGNMENT_DISTRIBUTED - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

VERTICAL_ALIGNMENT_JUSTIFY - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

VERTICAL_ALIGNMENT_JUSTIFY - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox

VERTICAL_ALIGNMENT_TOP - Static variable in class org.apache.poi.hssf.record.chart.TextRecord

VERTICAL_ALIGNMENT_TOP - Static variable in class org.apache.poi.hssf.usermodel.HSSFTextbox
How to align text vertically
VERTICAL_BOTTOM - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

VERTICAL_BOTTOM - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
bottom-aligned vertical alignment
VERTICAL_CENTER - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

VERTICAL_CENTER - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
center-aligned vertical alignment
VERTICAL_JUSTIFY - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

VERTICAL_JUSTIFY - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
vertically justified vertical alignment
VERTICAL_SCROLL - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

VERTICAL_TEXT_ALIGNMENT_BOTTOM - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

VERTICAL_TEXT_ALIGNMENT_CENTER - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

VERTICAL_TEXT_ALIGNMENT_JUSTIFY - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

VERTICAL_TEXT_ALIGNMENT_TOP - Static variable in class org.apache.poi.hssf.record.TextObjectRecord

VERTICAL_TITLE_2_ROW_BODY_LEFT - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

VERTICAL_TITLE_BODY_LEFT - Static variable in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

VERTICAL_TOP - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

VERTICAL_TOP - Static variable in interface org.apache.poi.ss.usermodel.CellStyle
top-aligned vertical alignment
VerticalAlign - Enum in org.apache.poi.xwpf.usermodel
Specifies possible values for the alignment of the contents of this run in relation to the default appearance of the run's text.
VerticalAlignment - Enum in org.apache.poi.ss.usermodel
This enumeration value indicates the type of vertical alignment for a cell, i.e., whether it is aligned top, bottom, vertically centered, justified or distributed.
VerticalAlignment - Enum in org.apache.poi.xslf.usermodel
Specifies a list of available anchoring types for text
VerticalPageBreakRecord - Class in org.apache.poi.hssf.record
VerticalPageBreak (0x001A) record that stores page breaks at columns

VerticalPageBreakRecord() - Constructor for class org.apache.poi.hssf.record.VerticalPageBreakRecord
Creates an empty vertical page break record
VerticalPageBreakRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.VerticalPageBreakRecord

VerticalScroll - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

VerticalTextBody - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the body text with vertical text flow.
VerticalTextTitle - Static variable in class org.apache.poi.hslf.record.OEPlaceholderAtom
The corresponding shape contains the title text with vertical text flow.
ViewDefinitionRecord - Class in org.apache.poi.hssf.record.pivottable
SXVIEW - View Definition (0x00B0)

ViewDefinitionRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

ViewFieldsRecord - Class in org.apache.poi.hssf.record.pivottable
SXVD - View Fields (0x00B1)

ViewFieldsRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

viewFile(String) - Static method in class org.apache.poi.poifs.dev.POIFSHeaderDumper

viewFile(String, boolean) - Static method in class org.apache.poi.poifs.dev.POIFSLister

viewFileOld(String, boolean) - Static method in class org.apache.poi.poifs.dev.POIFSLister

ViewInfo - Static variable in class org.apache.poi.hslf.record.RecordTypes

ViewInfoAtom - Static variable in class org.apache.poi.hslf.record.RecordTypes

VIEWS_ENTRY_ID - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

ViewSourceRecord - Class in org.apache.poi.hssf.record.pivottable
SXVS - View Source (0x00E3)

ViewSourceRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.pivottable.ViewSourceRecord

VisioTextExtractor - Class in org.apache.poi.hdgf.extractor
Class to find all the text in a Visio file, and return it.
VisioTextExtractor(HDGFDiagram) - Constructor for class org.apache.poi.hdgf.extractor.VisioTextExtractor

VisioTextExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hdgf.extractor.VisioTextExtractor

VisioTextExtractor(NPOIFSFileSystem) - Constructor for class org.apache.poi.hdgf.extractor.VisioTextExtractor

VisioTextExtractor(DirectoryNode) - Constructor for class org.apache.poi.hdgf.extractor.VisioTextExtractor

VisioTextExtractor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hdgf.extractor.VisioTextExtractor
Deprecated. Use VisioTextExtractor.VisioTextExtractor(DirectoryNode) instead
VisioTextExtractor(InputStream) - Constructor for class org.apache.poi.hdgf.extractor.VisioTextExtractor

visitCellsForRow(int, RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

visitContainedRecords(RecordAggregate.RecordVisitor, int) - Method in class org.apache.poi.hssf.model.InternalSheet

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.DataValidityTable

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.MergedCellsTable

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

visitContainedRecords(RecordAggregate.RecordVisitor) - Method in class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

visitRecord(Record) - Method in class org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor

visitRecord(Record) - Method in interface org.apache.poi.hssf.record.aggregates.RecordAggregate.RecordVisitor
Implementors may call non-mutating methods on Record r.
Vlookup - Class in org.apache.poi.ss.formula.functions
Implementation of the VLOOKUP() function.
VLOOKUP finds a row in a lookup table by the first column value and returns the value from another column.
Syntax:
VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)
lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.
Vlookup() - Constructor for class org.apache.poi.ss.formula.functions.Vlookup

VML_DRAWING - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation

VML_DRAWINGS - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

VSDDumper - Class in org.apache.poi.hdgf.dev
Developer helper class to dump out the pointer+stream structure of a Visio file
VSDDumper() - Constructor for class org.apache.poi.hdgf.dev.VSDDumper

VT_ARRAY - Static variable in class org.apache.poi.hpsf.Variant
[V] SAFEARRAY*.
VT_BLOB - Static variable in class org.apache.poi.hpsf.Variant
[P] Length prefixed bytes.
VT_BLOB_OBJECT - Static variable in class org.apache.poi.hpsf.Variant
[P] Blob contains an object.
VT_BOOL - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] True=-1, False=0.
VT_BSTR - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] OLE Automation string.
VT_BYREF - Static variable in class org.apache.poi.hpsf.Variant
[V] void* for local use.
VT_CARRAY - Static variable in class org.apache.poi.hpsf.Variant
[T] C style array.
VT_CF - Static variable in class org.apache.poi.hpsf.Variant
[P] Clipboard format.
VT_CLSID - Static variable in class org.apache.poi.hpsf.Variant
[P] A Class ID.
VT_CY - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] currency.
VT_DATE - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] date.
VT_DECIMAL - Static variable in class org.apache.poi.hpsf.Variant
[V][T][S] 16 byte fixed point.
VT_DISPATCH - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] IDispatch *.
VT_EMPTY - Static variable in class org.apache.poi.hpsf.Variant
[V][P] Nothing, i.e.
VT_ERROR - Static variable in class org.apache.poi.hpsf.Variant
[V][T][S] SCODE.
VT_FILETIME - Static variable in class org.apache.poi.hpsf.Variant
[P] FILETIME.
VT_HRESULT - Static variable in class org.apache.poi.hpsf.Variant
[T] Standard return type.
VT_I1 - Static variable in class org.apache.poi.hpsf.Variant
[T] signed char.
VT_I2 - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] 2 byte signed int.
VT_I4 - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] 4 byte signed int.
VT_I8 - Static variable in class org.apache.poi.hpsf.Variant
[T][P] signed 64-bit int.
VT_ILLEGAL - Static variable in class org.apache.poi.hpsf.Variant
FIXME (3): Document this!
VT_ILLEGALMASKED - Static variable in class org.apache.poi.hpsf.Variant
FIXME (3): Document this!
VT_INT - Static variable in class org.apache.poi.hpsf.Variant
[T] signed machine int.
VT_LPSTR - Static variable in class org.apache.poi.hpsf.Variant
[T][P] null terminated string.
VT_LPWSTR - Static variable in class org.apache.poi.hpsf.Variant
[T][P] wide (Unicode) null terminated string.
VT_NULL - Static variable in class org.apache.poi.hpsf.Variant
[V][P] SQL style Null.
VT_PTR - Static variable in class org.apache.poi.hpsf.Variant
[T] pointer type.
VT_R4 - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] 4 byte real.
VT_R8 - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] 8 byte real.
VT_RESERVED - Static variable in class org.apache.poi.hpsf.Variant
FIXME (3): Document this!
VT_SAFEARRAY - Static variable in class org.apache.poi.hpsf.Variant
[T] (use VT_ARRAY in VARIANT).
VT_STORAGE - Static variable in class org.apache.poi.hpsf.Variant
[P] Name of the storage follows.
VT_STORED_OBJECT - Static variable in class org.apache.poi.hpsf.Variant
[P] Storage contains an object.
VT_STREAM - Static variable in class org.apache.poi.hpsf.Variant
[P] Name of the stream follows.
VT_STREAMED_OBJECT - Static variable in class org.apache.poi.hpsf.Variant
[P] Stream contains an object.
VT_TYPEMASK - Static variable in class org.apache.poi.hpsf.Variant
FIXME (3): Document this!
VT_UI1 - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] unsigned char.
VT_UI2 - Static variable in class org.apache.poi.hpsf.Variant
[T][P] unsigned short.
VT_UI4 - Static variable in class org.apache.poi.hpsf.Variant
[T][P] unsigned int.
VT_UI8 - Static variable in class org.apache.poi.hpsf.Variant
[T][P] unsigned 64-bit int.
VT_UINT - Static variable in class org.apache.poi.hpsf.Variant
[T] unsigned machine int.
VT_UNKNOWN - Static variable in class org.apache.poi.hpsf.Variant
[V][T][S] IUnknown *.
VT_USERDEFINED - Static variable in class org.apache.poi.hpsf.Variant
[T] user defined type.
VT_VARIANT - Static variable in class org.apache.poi.hpsf.Variant
[V][T][P][S] VARIANT *.
VT_VECTOR - Static variable in class org.apache.poi.hpsf.Variant
[P] simple counted array.
VT_VERSIONED_STREAM - Static variable in class org.apache.poi.hpsf.Variant
"MUST be a VersionedStream.
VT_VOID - Static variable in class org.apache.poi.hpsf.Variant
[T] C style void.

W

WALIGNFONT_AUTO - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

WALIGNFONT_CENTERED - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

WALIGNFONT_HANGING - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

WALIGNFONT_ROMAN - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

WALIGNFONT_VARIABLE - Static variable in class org.apache.poi.hwpf.model.types.PAPAbstractType

walkEscherBasic(int, int, int) - Method in class org.apache.poi.hslf.dev.SlideShowDumper
Use the basic record format groking code to walk the Escher records
walkEscherDDF(int, int, int) - Method in class org.apache.poi.hslf.dev.SlideShowDumper
Use the DDF code to walk the Escher records
walkTree(int, int, int) - Method in class org.apache.poi.hslf.dev.SlideShowDumper

walkTree(int, int, Record[]) - Method in class org.apache.poi.hslf.dev.SlideShowRecordDumper

WARN - Static variable in class org.apache.poi.util.POILogger

WARNING - Static variable in class org.apache.poi.ss.usermodel.DataValidation.ErrorStyle
WARNING style
wasNull() - Method in class org.apache.poi.hpsf.PropertySet
Checks whether the property which the last call to PropertySet.getPropertyIntValue(int) or PropertySet.getProperty(int) tried to access was available or not.
wasNull() - Method in class org.apache.poi.hpsf.Section
Checks whether the property which the last call to Section.getPropertyIntValue(long) or Section.getProperty(long) tried to access was available or not.
wasNull() - Method in class org.apache.poi.hpsf.SpecialPropertySet

Wave - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

WAVE - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

WEB_SETTINGS - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation

WEDDING_ANNIVERSARY - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

WEDGE_ELLIPSE_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

WEDGE_RECT_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

WEDGE_ROUND_RECT_CALLOUT - Static variable in class org.apache.poi.ss.usermodel.ShapeTypes

WedgeEllipseCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

WedgeRectCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

WedgeRRectCallout - Static variable in interface org.apache.poi.sl.usermodel.ShapeTypes

WEIGHT_HAIRLINE - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

WEIGHT_MEDIUM - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

WEIGHT_NARROW - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

WEIGHT_WIDE - Static variable in class org.apache.poi.hssf.record.chart.LineFormatRecord

WindowOneRecord - Class in org.apache.poi.hssf.record
Title: Window1 Record
WindowOneRecord() - Constructor for class org.apache.poi.hssf.record.WindowOneRecord

WindowOneRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.WindowOneRecord

WindowProtectRecord - Class in org.apache.poi.hssf.record
Title: Window Protect Record (0x0019)
Description: flags whether workbook windows are protected
REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

WindowProtectRecord(int) - Constructor for class org.apache.poi.hssf.record.WindowProtectRecord

WindowProtectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.WindowProtectRecord

WindowProtectRecord(boolean) - Constructor for class org.apache.poi.hssf.record.WindowProtectRecord

windowTwo - Variable in class org.apache.poi.hssf.model.InternalSheet

WindowTwoRecord - Class in org.apache.poi.hssf.record
Title: Window Two Record
WindowTwoRecord() - Constructor for class org.apache.poi.hssf.record.WindowTwoRecord

WindowTwoRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.WindowTwoRecord

WINGDINGS - Static variable in class org.apache.poi.hslf.model.PPFont

WMF - Class in org.apache.poi.hslf.blip
Represents a WMF (Windows Metafile) picture data.
WMF() - Constructor for class org.apache.poi.hslf.blip.WMF

WMF - Static variable in class org.apache.poi.hslf.model.Picture
Windows Metafile (WMF)
WMF.AldusHeader - Class in org.apache.poi.hslf.blip
Aldus Placeable Metafile header - 22 byte structure before WMF data.
WMF.AldusHeader() - Constructor for class org.apache.poi.hslf.blip.WMF.AldusHeader

WMF1 - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
WMF2 - Static variable in class org.apache.poi.hwpf.usermodel.Picture
Deprecated.
wmfsize - Variable in class org.apache.poi.hslf.blip.Metafile.Header
size of the original file
Word6Extractor - Class in org.apache.poi.hwpf.extractor
Class to extract the text from old (Word 6 / Word 95) Word Documents.
Word6Extractor(InputStream) - Constructor for class org.apache.poi.hwpf.extractor.Word6Extractor
Create a new Word Extractor
Word6Extractor(POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.extractor.Word6Extractor
Create a new Word Extractor
Word6Extractor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.extractor.Word6Extractor
Deprecated. Use Word6Extractor.Word6Extractor(DirectoryNode) instead
Word6Extractor(DirectoryNode) - Constructor for class org.apache.poi.hwpf.extractor.Word6Extractor

Word6Extractor(HWPFOldDocument) - Constructor for class org.apache.poi.hwpf.extractor.Word6Extractor
Create a new Word Extractor
WordExtractor - Class in org.apache.poi.hwpf.extractor
Class to extract the text from a Word Document.
WordExtractor(InputStream) - Constructor for class org.apache.poi.hwpf.extractor.WordExtractor
Create a new Word Extractor
WordExtractor(POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.extractor.WordExtractor
Create a new Word Extractor
WordExtractor(DirectoryNode, POIFSFileSystem) - Constructor for class org.apache.poi.hwpf.extractor.WordExtractor
Deprecated. Use WordExtractor.WordExtractor(DirectoryNode) instead
WordExtractor(DirectoryNode) - Constructor for class org.apache.poi.hwpf.extractor.WordExtractor

WordExtractor(HWPFDocument) - Constructor for class org.apache.poi.hwpf.extractor.WordExtractor
Create a new Word Extractor
WordToFoConverter - Class in org.apache.poi.hwpf.converter

WordToFoConverter(Document) - Constructor for class org.apache.poi.hwpf.converter.WordToFoConverter
Creates new instance of WordToFoConverter.
WordToFoConverter(FoDocumentFacade) - Constructor for class org.apache.poi.hwpf.converter.WordToFoConverter

WordToFoUtils - Class in org.apache.poi.hwpf.converter

WordToFoUtils() - Constructor for class org.apache.poi.hwpf.converter.WordToFoUtils

WordToHtmlConverter - Class in org.apache.poi.hwpf.converter
Converts Word files (95-2007) into HTML files.
WordToHtmlConverter(Document) - Constructor for class org.apache.poi.hwpf.converter.WordToHtmlConverter
Creates new instance of WordToHtmlConverter.
WordToHtmlConverter(HtmlDocumentFacade) - Constructor for class org.apache.poi.hwpf.converter.WordToHtmlConverter

WordToHtmlUtils - Class in org.apache.poi.hwpf.converter

WordToHtmlUtils() - Constructor for class org.apache.poi.hwpf.converter.WordToHtmlUtils

WordToTextConverter - Class in org.apache.poi.hwpf.converter

WordToTextConverter() - Constructor for class org.apache.poi.hwpf.converter.WordToTextConverter
Creates new instance of WordToTextConverter.
WordToTextConverter(Document) - Constructor for class org.apache.poi.hwpf.converter.WordToTextConverter
Creates new instance of WordToTextConverter.
WordToTextConverter(TextDocumentFacade) - Constructor for class org.apache.poi.hwpf.converter.WordToTextConverter

Workbook - Interface in org.apache.poi.ss.usermodel
High level representation of a Excel workbook.
WORKBOOK - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

WorkbookDependentFormula - Interface in org.apache.poi.ss.formula
Should be implemented by any Ptg subclass that needs a workbook to render its formula.
WorkbookEvaluator - Class in org.apache.poi.ss.formula
Evaluates formula cells.
For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.
WorkbookEvaluator(EvaluationWorkbook, IStabilityClassifier, UDFFinder) - Constructor for class org.apache.poi.ss.formula.WorkbookEvaluator

WorkbookFactory - Class in org.apache.poi.ss.usermodel
Factory for creating the appropriate kind of Workbook (be it HSSFWorkbook or XSSFWorkbook), from the given input
WorkbookFactory() - Constructor for class org.apache.poi.ss.usermodel.WorkbookFactory

WorkbookRecordList - Class in org.apache.poi.hssf.model

WorkbookRecordList() - Constructor for class org.apache.poi.hssf.model.WorkbookRecordList

WorkbookUtil - Class in org.apache.poi.ss.util
Helper methods for when working with Usermodel Workbooks
WorkbookUtil() - Constructor for class org.apache.poi.ss.util.WorkbookUtil

WorkdayCalculator - Class in org.apache.poi.ss.formula.atp
A calculator for workdays, considering dates as excel representations.
WORKSHEET - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation

worksheet - Variable in class org.apache.poi.xssf.usermodel.XSSFSheet

WorksheetProtectionBlock - Class in org.apache.poi.hssf.record.aggregates
Groups the sheet protection records for a worksheet.
WorksheetProtectionBlock() - Constructor for class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock
Creates an empty WorksheetProtectionBlock
WRAP_TEXT - Static variable in class org.apache.poi.ss.util.CellUtil

WrapByPoints - Static variable in class org.apache.poi.hslf.model.TextShape

WrapNone - Static variable in class org.apache.poi.hslf.model.TextShape

WrapSquare - Static variable in class org.apache.poi.hslf.model.TextShape
How to wrap the text
WrapThrough - Static variable in class org.apache.poi.hslf.model.TextShape

WrapTopBottom - Static variable in class org.apache.poi.hslf.model.TextShape

write(OutputStream) - Method in class org.apache.poi.hdgf.HDGFDiagram

write(OutputStream) - Method in class org.apache.poi.hpbf.HPBFDocument

write(byte[], int) - Method in class org.apache.poi.hpsf.ClassID
Writes the class ID to a byte array in the little-endian format.
write(OutputStream, int) - Method in class org.apache.poi.hpsf.MutableProperty
Writes the property to an output stream.
write(OutputStream) - Method in class org.apache.poi.hpsf.MutablePropertySet
Writes the property set to an output stream.
write(DirectoryEntry, String) - Method in class org.apache.poi.hpsf.MutablePropertySet
Writes a property set to a document in a POI filesystem directory.
write(OutputStream) - Method in class org.apache.poi.hpsf.MutableSection
Writes this section into an output stream.
write(DirectoryEntry, String) - Method in class org.apache.poi.hpsf.SpecialPropertySet

write(OutputStream) - Method in class org.apache.poi.hpsf.SpecialPropertySet

write(OutputStream, long, Object, int) - Static method in class org.apache.poi.hpsf.VariantSupport
Writes a variant value to an output stream.
write(OutputStream) - Method in class org.apache.poi.hslf.blip.Metafile.Header

write(OutputStream) - Method in class org.apache.poi.hslf.blip.WMF.AldusHeader

write(OutputStream) - Method in class org.apache.poi.hslf.HSLFSlideShow
Writes out the slideshow file the is represented by an instance of this class.
write(OutputStream, boolean) - Method in class org.apache.poi.hslf.HSLFSlideShow
Writes out the slideshow file the is represented by an instance of this class.
write(OutputStream) - Method in class org.apache.poi.hslf.usermodel.PictureData
Write this picture into OutputStream
write(OutputStream) - Method in class org.apache.poi.hslf.usermodel.SlideShow
Writes out the slideshow file the is represented by an instance of this class
write(byte[]) - Method in class org.apache.poi.hslf.util.MutableByteArrayOutputStream
Write some bytes to the array
write(int) - Method in class org.apache.poi.hslf.util.MutableByteArrayOutputStream

write(OutputStream) - Method in class org.apache.poi.hsmf.MAPIMessage
Note - not yet supported, sorry.
write(byte[]) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

write(byte[], int, int) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

write(OutputStream) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
Method write - write out this workbook to an Outputstream.
write(OutputStream) - Method in class org.apache.poi.hwpf.HWPFDocument
Writes out the word file that is represented by an instance of this class.
write(OutputStream) - Method in class org.apache.poi.hwpf.HWPFOldDocument

write(FileInformationBlock, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.FieldsTables

write(byte[], int, int) - Method in class org.apache.poi.hwpf.model.io.HWPFOutputStream

write(int) - Method in class org.apache.poi.hwpf.model.io.HWPFOutputStream

write(OutputStream) - Method in class org.apache.poi.hwpf.model.ParagraphHeight

write(int) - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream

write(byte[], int, int) - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream

write(byte[]) - Method in class org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream

write(OutputStream) - Method in class org.apache.poi.POIDocument
Writes the document out to the specified output stream
write(int) - Method in class org.apache.poi.poifs.filesystem.DocumentOutputStream
Writes the specified byte to this output stream.
write(byte[]) - Method in class org.apache.poi.poifs.filesystem.DocumentOutputStream
Writes b.length bytes from the specified byte array to this output stream.
write(byte[], int, int) - Method in class org.apache.poi.poifs.filesystem.DocumentOutputStream
Writes len bytes from the specified byte array starting at offset off to this output stream.
write(ByteBuffer, long) - Method in class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

write(ByteBuffer, long) - Method in class org.apache.poi.poifs.nio.DataSource

write(ByteBuffer, long) - Method in class org.apache.poi.poifs.nio.FileBackedDataSource

write(NPOIFSStream) - Method in class org.apache.poi.poifs.property.NPropertyTable
Writes the properties out into the given low-level stream
write(OutputStream) - Method in class org.apache.poi.POIXMLDocument
Write out this document to an Outputstream.
write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.Area2DPtgBase

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.Area3DPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.AreaErrPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.AttrPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.BoolPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.ErrPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.ExpPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.FuncPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.FuncVarPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.IntersectionPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.IntPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.MemAreaPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.MemErrPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.MemFuncPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.MissingArgPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.NamePtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.NameXPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.NumberPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.ParenthesisPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.Ptg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.RangePtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.Ref3DPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.RefErrorPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.StringPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.TblPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.UnionPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.UnknownPtg

write(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.ValueOperatorPtg

write(OutputStream) - Method in interface org.apache.poi.ss.usermodel.Workbook
Write out this workbook to an Outputstream.
write(byte[]) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

write(byte[], int, int) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

write(byte[]) - Method in interface org.apache.poi.util.LittleEndianOutput

write(byte[], int, int) - Method in interface org.apache.poi.util.LittleEndianOutput

write(byte[]) - Method in class org.apache.poi.util.LittleEndianOutputStream

write(byte[], int, int) - Method in class org.apache.poi.util.LittleEndianOutputStream

write(OutputStream) - Method in class org.apache.poi.xssf.streaming.SXSSFWorkbook
Write out this workbook to an Outputstream.
write(OutputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFChartSheet

write(OutputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFSheet

write(OutputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFVMLDrawing

WriteAccessRecord - Class in org.apache.poi.hssf.record
Title: Write Access Record (0x005C)
Description: Stores the username of that who owns the spreadsheet generator (on unix the user's login, on Windoze its the name you typed when you installed the thing)
REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

WriteAccessRecord() - Constructor for class org.apache.poi.hssf.record.WriteAccessRecord

WriteAccessRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.WriteAccessRecord

writeBlock(BATBlock, ByteBuffer) - Static method in class org.apache.poi.poifs.storage.BlockAllocationTableWriter
Write the BAT into its associated block
writeBlock(ByteBuffer) - Method in class org.apache.poi.poifs.storage.HeaderBlockWriter
Write the block's data to an existing block
writeBlocks(OutputStream) - Method in class org.apache.poi.poifs.filesystem.POIFSDocument
Write the storage to an OutputStream
writeBlocks(OutputStream) - Method in class org.apache.poi.poifs.property.PropertyTable
Write the storage to an OutputStream
writeBlocks(OutputStream) - Method in class org.apache.poi.poifs.storage.BlockAllocationTableWriter
Write the storage to an OutputStream
writeBlocks(OutputStream) - Method in interface org.apache.poi.poifs.storage.BlockWritable
Write the storage to an OutputStream
writeBlocks(OutputStream) - Method in class org.apache.poi.poifs.storage.HeaderBlockWriter
Write the block's data to an OutputStream
writeBlocks(OutputStream) - Method in class org.apache.poi.poifs.storage.SmallBlockTableWriter
Write the storage to an OutputStream
writeBlocks(OutputStream) - Method in class org.apache.poi.poifs.storage.SmallDocumentBlock
Write the storage to an OutputStream
writeByte(int) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

writeByte(int) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

writeByte(int) - Method in interface org.apache.poi.util.LittleEndianOutput

writeByte(int) - Method in class org.apache.poi.util.LittleEndianOutputStream

writeCell(int, Cell) - Method in class org.apache.poi.xssf.streaming.SheetDataWriter

writeContinue() - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput
Terminates the current record and starts a new ContinueRecord (regardless of how much space is still available in the current record).
writeContinueIfRequired(int) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput
Will terminate the current record and start a new ContinueRecord if there isn't space for the requested number of bytes
writeCoordinates(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.AreaPtgBase

writeCoordinates(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.RefPtgBase

writeData(OutputStream) - Method in class org.apache.poi.poifs.property.Property
Write the raw data to an OutputStream.
writeDouble(double) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

writeDouble(double) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

writeDouble(double) - Method in interface org.apache.poi.util.LittleEndianOutput

writeDouble(double) - Method in class org.apache.poi.util.LittleEndianOutputStream

writeFilesystem() - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Write the filesystem out to the open file.
writeFilesystem(OutputStream) - Method in class org.apache.poi.poifs.filesystem.NPOIFSFileSystem
Write the filesystem out
writeFilesystem(OutputStream) - Method in class org.apache.poi.poifs.filesystem.POIFSFileSystem
Write the filesystem out
writeImageContent(OutputStream) - Method in class org.apache.poi.hwpf.usermodel.Picture
Writes Picture's content bytes to specified OutputStream.
writeInt(int) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

writeInt(int) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

writeInt(int) - Method in interface org.apache.poi.util.LittleEndianOutput

writeInt(int) - Method in class org.apache.poi.util.LittleEndianOutputStream

writeListDataTo(FileInformationBlock, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.ListTables

writeListOverridesTo(HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.ListTables

writeLittleEndian(int, OutputStream) - Static method in class org.apache.poi.hslf.record.Record
When writing out, write out a signed int (32bit) in Little Endian format
writeLittleEndian(short, OutputStream) - Static method in class org.apache.poi.hslf.record.Record
When writing out, write out a signed short (16bit) in Little Endian format
writeLong(long) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

writeLong(long) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

writeLong(long) - Method in interface org.apache.poi.util.LittleEndianOutput

writeLong(long) - Method in class org.apache.poi.util.LittleEndianOutputStream

writeOut(DirectoryNode) - Method in class org.apache.poi.hpbf.model.HPBFPart

writeOut(OutputStream) - Method in class org.apache.poi.hslf.model.textproperties.TextPropCollection
Writes out to disk the header, and then all the properties
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.AnimationInfo
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.AnimationInfoAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ColorSchemeAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Comment2000
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Comment2000Atom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.CString
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.CurrentUserAtom
Writes ourselves back out
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Document
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.DocumentAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.DocumentEncryptionAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.DummyRecordWithChildren
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Environment
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.EscherTextboxWrapper
Stores the data for the child records back into the Escher layer.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExControlAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExEmbed
Have the contents printer out into an OutputStream, used when writing a file back out to disk.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExEmbedAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExHyperlink
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExHyperlinkAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExMCIMovie
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExMediaAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExObjList
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExObjListAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExOleObjAtom
Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExOleObjStg
Write the contents of the record back, so it can be written to disk.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.ExVideoContainer
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.FontCollection
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.FontEntityAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.HeadersFootersAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.HeadersFootersContainer
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.InteractiveInfo
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.InteractiveInfoAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.MainMaster
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Notes
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.NotesAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.OEPlaceholderAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.OEShapeAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.OutlineTextRefAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.PersistPtrHolder
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.PPDrawing
Write the contents of the record back, so it can be written to disk Walks the escher layer to get the contents
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.PPDrawingGroup

writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Record
Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)
writeOut(byte, byte, long, Record[], OutputStream) - Method in class org.apache.poi.hslf.record.RecordContainer
Write out our header, and our children.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.RoundTripHFPlaceholder12
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Slide
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
Write the contents of the record back, so it can be written to disk.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.SlideAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.SlideListWithText
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.SlidePersistAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.Sound
Have the contents printer out into an OutputStream, used when writing a file back out to disk.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.SoundCollection
Have the contents printer out into an OutputStream, used when writing a file back out to disk.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.SoundData
Write the contents of the record back, so it can be written to disk.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.StyleTextPropAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.TextBytesAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.TextCharsAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.TextHeaderAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.TextRulerAtom
Write the contents of the record back, so it can be written to disk.
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.TextSpecInfoAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.TxInteractiveInfoAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.TxMasterStyleAtom
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.UnknownRecordPlaceholder
Write the contents of the record back, so it can be written to disk
writeOut(OutputStream) - Method in class org.apache.poi.hslf.record.UserEditAtom
Write the contents of the record back, so it can be written to disk
writePlcfBkmkf(FileInformationBlock, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.BookmarksTables

writePlcfBkmkl(FileInformationBlock, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.BookmarksTables

writeProperties(POIFSFileSystem) - Method in class org.apache.poi.POIDocument
Writes out the standard Documment Information Properties (HPSF)
writeProperties(POIFSFileSystem, List<String>) - Method in class org.apache.poi.POIDocument
Writes out the standard Documment Information Properties (HPSF)
writePropertySet(String, PropertySet, POIFSFileSystem) - Method in class org.apache.poi.POIDocument
Writes out a given ProperySet
WriteProtectRecord - Class in org.apache.poi.hssf.record
Title: Write Protect Record
WriteProtectRecord() - Constructor for class org.apache.poi.hssf.record.WriteProtectRecord

WriteProtectRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.WriteProtectRecord

writeProtectWorkbook(String, String) - Method in class org.apache.poi.hssf.model.InternalWorkbook
protect a workbook with a password (not encypted, just sets writeprotect flags and the password.
writeProtectWorkbook(String, String) - Method in class org.apache.poi.hssf.usermodel.HSSFWorkbook
protect a workbook with a password (not encypted, just sets writeprotect flags and the password.
writeRef(FileInformationBlock, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.NotesTables

writeRow(int, SXSSFRow) - Method in class org.apache.poi.xssf.streaming.SheetDataWriter
Write a row to the file
writeShort(int) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

writeShort(int) - Method in class org.apache.poi.util.LittleEndianByteArrayOutputStream

writeShort(int) - Method in interface org.apache.poi.util.LittleEndianOutput

writeShort(int) - Method in class org.apache.poi.util.LittleEndianOutputStream

writeString(String, int, int) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput
Writes a unicode string complete with header and character data.
writeStringData(String) - Method in class org.apache.poi.hssf.record.cont.ContinuableRecordOutput
Writes the 'optionFlags' byte and encoded character data of a unicode string.
writeSttbfBkmk(FileInformationBlock, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.BookmarksTables

writeTo(HWPFFileSystem, int, CharIndexTranslator) - Method in class org.apache.poi.hwpf.model.CHPBinTable
Deprecated.
writeTo(HWPFOutputStream, HWPFOutputStream, int, CharIndexTranslator) - Method in class org.apache.poi.hwpf.model.CHPBinTable

writeTo(HWPFFileSystem) - Method in class org.apache.poi.hwpf.model.ComplexFileTable
Deprecated.
writeTo(HWPFOutputStream, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.ComplexFileTable

writeTo(HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.DocumentProperties

writeTo(byte[], HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.FileInformationBlock

writeTo(HWPFFileSystem) - Method in class org.apache.poi.hwpf.model.FontTable
Deprecated.
writeTo(HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.FontTable

writeTo(HWPFFileSystem, CharIndexTranslator) - Method in class org.apache.poi.hwpf.model.PAPBinTable
Deprecated.
writeTo(HWPFOutputStream, HWPFOutputStream, CharIndexTranslator) - Method in class org.apache.poi.hwpf.model.PAPBinTable

writeTo(HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.RevisionMarkAuthorTable
Writes this table to the table stream.
writeTo(HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.SavedByTable
Writes this table to the table stream.
writeTo(HWPFFileSystem, int) - Method in class org.apache.poi.hwpf.model.SectionTable
Deprecated.
writeTo(HWPFOutputStream, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.SectionTable

writeTo(HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.StyleSheet

writeTo(HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.TextPieceTable

writeTo(DirectoryEntry) - Method in class org.apache.poi.hwpf.usermodel.ObjectPoolImpl

writeTo(OutputStream) - Method in class org.apache.poi.xssf.model.CalculationChain

writeTo(OutputStream) - Method in class org.apache.poi.xssf.model.CommentsTable

writeTo(OutputStream) - Method in class org.apache.poi.xssf.model.MapInfo

writeTo(OutputStream) - Method in class org.apache.poi.xssf.model.SharedStringsTable
Write this table out as XML.
writeTo(OutputStream) - Method in class org.apache.poi.xssf.model.SingleXmlCells

writeTo(OutputStream) - Method in class org.apache.poi.xssf.model.StylesTable
Write this table out as XML.
writeTo(OutputStream) - Method in class org.apache.poi.xssf.usermodel.XSSFTable

writeToBytes(byte[]) - Method in class org.apache.poi.util.ByteField
write the value out to an array of bytes at the appropriate offset
writeToBytes(byte[]) - Method in interface org.apache.poi.util.FixedField
write the value out to an array of bytes at the appropriate offset
writeToBytes(byte[]) - Method in class org.apache.poi.util.IntegerField
write the value out to an array of bytes at the appropriate offset
writeToBytes(byte[]) - Method in class org.apache.poi.util.LongField
write the value out to an array of bytes at the appropriate offset
writeToBytes(byte[]) - Method in class org.apache.poi.util.ShortField
write the value out to an array of bytes at the appropriate offset
writeToFS(POIFSFileSystem) - Method in class org.apache.poi.hslf.record.CurrentUserAtom
Writes ourselves back out to a filesystem
writeTokenValueBytes(LittleEndianOutput) - Method in class org.apache.poi.ss.formula.ptg.ArrayPtg

writeToStream(OutputStream, short) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes a two-byte value (short) to an output stream.
writeToStream(OutputStream, int) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes a four-byte value to an output stream.
writeToStream(OutputStream, long) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes a eight-byte value to an output stream.
writeToStream(OutputStream, ClassID) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes a 16-byte ClassID to an output stream.
writeToStream(OutputStream, Property[], int) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes an array of Property instances to an output stream according to the Horrible Property Stream Format.
writeToStream(OutputStream, double) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes a double value value to an output stream.
writeTxt(FileInformationBlock, HWPFOutputStream) - Method in class org.apache.poi.hwpf.model.NotesTables

writeUIntToStream(OutputStream, long) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes an unsigned four-byte value to an output stream.
writeUnicodeString(LittleEndianOutput, String) - Static method in class org.apache.poi.util.StringUtil
OutputStream out will get: ushort nChars byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
writeUnicodeStringFlagAndData(LittleEndianOutput, String) - Static method in class org.apache.poi.util.StringUtil
OutputStream out will get: byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
writeUnsupportedTypeMessage(UnsupportedVariantTypeException) - Static method in class org.apache.poi.hpsf.VariantSupport
Writes a warning to System.err that a variant type is unsupported by HPSF.
writeUShortToStream(OutputStream, int) - Static method in class org.apache.poi.hpsf.TypeWriter
Writes an unsigned two-byte value to an output stream.
writeValue(OutputStream) - Method in class org.apache.poi.hsmf.datatypes.ByteChunk

writeValue(OutputStream) - Method in class org.apache.poi.hsmf.datatypes.Chunk
Writes the value of this chunk back out again.
writeValue(OutputStream) - Method in class org.apache.poi.hsmf.datatypes.DirectoryChunk

writeValue(OutputStream) - Method in class org.apache.poi.hsmf.datatypes.MessageSubmissionChunk

writeValue(OutputStream) - Method in class org.apache.poi.hsmf.datatypes.StringChunk

WritingNotSupportedException - Exception in org.apache.poi.hpsf
This exception is thrown when trying to write a (yet) unsupported variant type.
WritingNotSupportedException(long, Object) - Constructor for exception org.apache.poi.hpsf.WritingNotSupportedException
Constructor
WSBoolRecord - Class in org.apache.poi.hssf.record
Title: WSBOOL (0x0081) (called SHEETPR in OOO doc)
Description: stores workbook settings (aka its a big "everything we didn't put somewhere else")
WSBoolRecord() - Constructor for class org.apache.poi.hssf.record.WSBoolRecord

WSBoolRecord(RecordInputStream) - Constructor for class org.apache.poi.hssf.record.WSBoolRecord

WSS - Static variable in class org.apache.poi.hwpf.model.FIBFieldHandler

X

X400_CONTENT_TYPE - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

X400_DEFERRED_DELIVERY_CANCEL - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

XF_CELL - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

XF_STYLE - Static variable in class org.apache.poi.hssf.record.ExtendedFormatRecord

XML - Static variable in class org.apache.poi.openxml4j.opc.ContentTypes
XML file.
XMLParagraph - Class in org.apache.poi.xwpf.model
Base class for XWPF paragraphs
XMLParagraph(CTP) - Constructor for class org.apache.poi.xwpf.model.XMLParagraph

XMLSlideShow - Class in org.apache.poi.xslf.usermodel
High level representation of a ooxml slideshow.
XMLSlideShow() - Constructor for class org.apache.poi.xslf.usermodel.XMLSlideShow

XMLSlideShow(OPCPackage) - Constructor for class org.apache.poi.xslf.usermodel.XMLSlideShow

XMLSlideShow(InputStream) - Constructor for class org.apache.poi.xslf.usermodel.XMLSlideShow

XPOS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

XSLFAutoShape - Class in org.apache.poi.xslf.usermodel
Represents a shape with a preset geometry.
XSLFBackground - Class in org.apache.poi.xslf.usermodel
Background shape
XSLFColor - Class in org.apache.poi.xslf.usermodel
Encapsulates logic to read color definitions from DrawingML and convert them to java.awt.Color
XSLFColor(XmlObject, XSLFTheme, CTSchemeColor) - Constructor for class org.apache.poi.xslf.usermodel.XSLFColor

XSLFCommentAuthors - Class in org.apache.poi.xslf.usermodel

XSLFComments - Class in org.apache.poi.xslf.usermodel

XSLFCommonSlideData - Class in org.apache.poi.xslf.usermodel

XSLFCommonSlideData(CTCommonSlideData) - Constructor for class org.apache.poi.xslf.usermodel.XSLFCommonSlideData

XSLFConnectorShape - Class in org.apache.poi.xslf.usermodel
Specifies a connection shape.
XSLFDrawing - Class in org.apache.poi.xslf.usermodel

XSLFFactory - Class in org.apache.poi.xslf.usermodel
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSLFFontManager - Interface in org.apache.poi.xslf.usermodel
Manages fonts when rendering slides.
XSLFFreeformShape - Class in org.apache.poi.xslf.usermodel
Represents a custom geometric shape.
XSLFGraphicFrame - Class in org.apache.poi.xslf.usermodel

XSLFGroupShape - Class in org.apache.poi.xslf.usermodel
Represents a group shape that consists of many shapes grouped together.
XSLFHyperlink - Class in org.apache.poi.xslf.usermodel

XSLFImageRenderer - Class in org.apache.poi.xslf.usermodel
For now this class renders only images supported by the javax.imageio.ImageIO framework.
XSLFImageRenderer() - Constructor for class org.apache.poi.xslf.usermodel.XSLFImageRenderer

XSLFNotes - Class in org.apache.poi.xslf.usermodel

XSLFNotesMaster - Class in org.apache.poi.xslf.usermodel
Notes master object associated with this layout.
XSLFNotesMaster(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xslf.usermodel.XSLFNotesMaster

XSLFPictureData - Class in org.apache.poi.xslf.usermodel
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSLFPictureData() - Constructor for class org.apache.poi.xslf.usermodel.XSLFPictureData
Create a new XSLFGraphicData node
XSLFPictureData(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xslf.usermodel.XSLFPictureData
Construct XSLFPictureData from a package part
XSLFPictureShape - Class in org.apache.poi.xslf.usermodel
Represents a picture shape
XSLFPowerPointExtractor - Class in org.apache.poi.xslf.extractor

XSLFPowerPointExtractor(XMLSlideShow) - Constructor for class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

XSLFPowerPointExtractor(XSLFSlideShow) - Constructor for class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

XSLFPowerPointExtractor(OPCPackage) - Constructor for class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

XSLFRelation - Class in org.apache.poi.xslf.usermodel

XSLFRenderingHint - Class in org.apache.poi.xslf.usermodel

XSLFRenderingHint(int) - Constructor for class org.apache.poi.xslf.usermodel.XSLFRenderingHint

XSLFShadow - Class in org.apache.poi.xslf.usermodel
Represents a shadow of a shape.
XSLFShape - Class in org.apache.poi.xslf.usermodel
Base super-class class for all shapes in PresentationML
XSLFShape() - Constructor for class org.apache.poi.xslf.usermodel.XSLFShape

XSLFShapeContainer - Interface in org.apache.poi.xslf.usermodel
Common interface for shape containers, e.g.
XSLFShapeType - Enum in org.apache.poi.xslf.usermodel
known preset shape geometries in PresentationML
XSLFSheet - Class in org.apache.poi.xslf.usermodel

XSLFSheet() - Constructor for class org.apache.poi.xslf.usermodel.XSLFSheet

XSLFSheet(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xslf.usermodel.XSLFSheet

XSLFSimpleShape - Class in org.apache.poi.xslf.usermodel
Represents a single (non-group) shape in a .pptx slide show
XSLFSlide - Class in org.apache.poi.xslf.usermodel

XSLFSlideLayout - Class in org.apache.poi.xslf.usermodel

XSLFSlideLayout(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xslf.usermodel.XSLFSlideLayout

XSLFSlideMaster - Class in org.apache.poi.xslf.usermodel
Slide master object associated with this layout.
XSLFSlideMaster(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xslf.usermodel.XSLFSlideMaster

XSLFSlideShow - Class in org.apache.poi.xslf
Experimental class to do low level processing of pptx files.
XSLFSlideShow(OPCPackage) - Constructor for class org.apache.poi.xslf.XSLFSlideShow

XSLFSlideShow(String) - Constructor for class org.apache.poi.xslf.XSLFSlideShow

XSLFTable - Class in org.apache.poi.xslf.usermodel
Represents a table in a .pptx presentation
XSLFTableCell - Class in org.apache.poi.xslf.usermodel
Represents a cell of a table in a .pptx presentation
XSLFTableRow - Class in org.apache.poi.xslf.usermodel
Represents a table in a .pptx presentation
XSLFTableStyle - Class in org.apache.poi.xslf.usermodel
Represents a table in a .pptx presentation
XSLFTableStyles - Class in org.apache.poi.xslf.usermodel

XSLFTableStyles() - Constructor for class org.apache.poi.xslf.usermodel.XSLFTableStyles

XSLFTableStyles(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xslf.usermodel.XSLFTableStyles

XSLFTextBox - Class in org.apache.poi.xslf.usermodel

XSLFTextParagraph - Class in org.apache.poi.xslf.usermodel
Represents a paragraph of text within the containing text body.
XSLFTextRun - Class in org.apache.poi.xslf.usermodel
Represents a run of text within the containing text body.
XSLFTextShape - Class in org.apache.poi.xslf.usermodel
Represents a shape that can hold text.
XSLFTheme - Class in org.apache.poi.xslf.usermodel
A shared style sheet in a .pptx slide show
XSLFTheme(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xslf.usermodel.XSLFTheme

XSSFAnchor - Class in org.apache.poi.xssf.usermodel
An anchor is what specifics the position of a shape within a client object or within another containing shape.
XSSFAnchor() - Constructor for class org.apache.poi.xssf.usermodel.XSSFAnchor

XSSFAutoFilter - Class in org.apache.poi.xssf.usermodel
Represents autofiltering for the specified worksheet.
XSSFBorderFormatting - Class in org.apache.poi.xssf.usermodel

XSSFCell - Class in org.apache.poi.xssf.usermodel
High level representation of a cell in a row of a spreadsheet.
XSSFCell(XSSFRow, CTCell) - Constructor for class org.apache.poi.xssf.usermodel.XSSFCell
Construct a XSSFCell.
XSSFCellAlignment - Class in org.apache.poi.xssf.usermodel.extensions
Cell settings avaiable in the Format/Alignment tab
XSSFCellAlignment(CTCellAlignment) - Constructor for class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
Creates a Cell Alignment from the supplied XML definition
XSSFCellBorder - Class in org.apache.poi.xssf.usermodel.extensions
This element contains border formatting information, specifying border definition formats (left, right, top, bottom, diagonal) for cells in the workbook.
XSSFCellBorder(CTBorder, ThemesTable) - Constructor for class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Creates a Cell Border from the supplied XML definition
XSSFCellBorder(CTBorder) - Constructor for class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Creates a Cell Border from the supplied XML definition
XSSFCellBorder() - Constructor for class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
Creates a new, empty Cell Border.
XSSFCellBorder.BorderSide - Enum in org.apache.poi.xssf.usermodel.extensions
The enumeration value indicating the side being used for a cell border.
XSSFCellFill - Class in org.apache.poi.xssf.usermodel.extensions
This element specifies fill formatting.
XSSFCellFill(CTFill) - Constructor for class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Creates a CellFill from the supplied parts
XSSFCellFill() - Constructor for class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
Creates an empty CellFill
XSSFCellStyle - Class in org.apache.poi.xssf.usermodel
High level representation of the the possible formatting information for the contents of the cells on a sheet in a SpreadsheetML document.
XSSFCellStyle(int, int, StylesTable, ThemesTable) - Constructor for class org.apache.poi.xssf.usermodel.XSSFCellStyle
Creates a Cell Style from the supplied parts
XSSFCellStyle(StylesTable) - Constructor for class org.apache.poi.xssf.usermodel.XSSFCellStyle
Creates an empty Cell Style
XSSFChart - Class in org.apache.poi.xssf.usermodel
Represents a SpreadsheetML Chart
XSSFChart() - Constructor for class org.apache.poi.xssf.usermodel.XSSFChart
Create a new SpreadsheetML chart
XSSFChart(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFChart
Construct a SpreadsheetML chart from a package part.
XSSFChartAxis - Class in org.apache.poi.xssf.usermodel.charts
Base class for all axis types.
XSSFChartAxis(XSSFChart) - Constructor for class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

XSSFChartDataFactory - Class in org.apache.poi.xssf.usermodel.charts

XSSFChartLegend - Class in org.apache.poi.xssf.usermodel.charts
Represents a SpreadsheetML chart legend
XSSFChartLegend(XSSFChart) - Constructor for class org.apache.poi.xssf.usermodel.charts.XSSFChartLegend
Create a new SpreadsheetML chart legend
XSSFChartSheet - Class in org.apache.poi.xssf.usermodel
High level representation of Sheet Parts that are of type 'chartsheet'.
XSSFChartSheet(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFChartSheet

XSSFChildAnchor - Class in org.apache.poi.xssf.usermodel

XSSFChildAnchor(int, int, int, int) - Constructor for class org.apache.poi.xssf.usermodel.XSSFChildAnchor

XSSFChildAnchor(CTTransform2D) - Constructor for class org.apache.poi.xssf.usermodel.XSSFChildAnchor

XSSFClientAnchor - Class in org.apache.poi.xssf.usermodel
A client anchor is attached to an excel worksheet.
XSSFClientAnchor() - Constructor for class org.apache.poi.xssf.usermodel.XSSFClientAnchor
Creates a new client anchor and defaults all the anchor positions to 0.
XSSFClientAnchor(int, int, int, int, int, int, int, int) - Constructor for class org.apache.poi.xssf.usermodel.XSSFClientAnchor
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
XSSFClientAnchor(CTMarker, CTMarker) - Constructor for class org.apache.poi.xssf.usermodel.XSSFClientAnchor
Create XSSFClientAnchor from existing xml beans
XSSFColor - Class in org.apache.poi.xssf.usermodel
Represents a color in SpreadsheetML
XSSFColor(CTColor) - Constructor for class org.apache.poi.xssf.usermodel.XSSFColor
Create an instance of XSSFColor from the supplied XML bean
XSSFColor() - Constructor for class org.apache.poi.xssf.usermodel.XSSFColor
Create an new instance of XSSFColor
XSSFColor(Color) - Constructor for class org.apache.poi.xssf.usermodel.XSSFColor

XSSFColor(byte[]) - Constructor for class org.apache.poi.xssf.usermodel.XSSFColor

XSSFComment - Class in org.apache.poi.xssf.usermodel

XSSFComment(CommentsTable, CTComment, CTShape) - Constructor for class org.apache.poi.xssf.usermodel.XSSFComment
Creates a new XSSFComment, associated with a given low level comment object.
XSSFConditionalFormatting - Class in org.apache.poi.xssf.usermodel

XSSFConditionalFormattingRule - Class in org.apache.poi.xssf.usermodel

XSSFConnector - Class in org.apache.poi.xssf.usermodel
A connection shape drawing element.
XSSFConnector(XSSFDrawing, CTConnector) - Constructor for class org.apache.poi.xssf.usermodel.XSSFConnector
Construct a new XSSFConnector object.
XSSFCreationHelper - Class in org.apache.poi.xssf.usermodel

XSSFDataFormat - Class in org.apache.poi.xssf.usermodel
Handles data formats for XSSF.
XSSFDataFormat(StylesTable) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDataFormat

XSSFDataValidation - Class in org.apache.poi.xssf.usermodel

XSSFDataValidation(XSSFDataValidationConstraint, CellRangeAddressList, CTDataValidation) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDataValidation

XSSFDataValidationConstraint - Class in org.apache.poi.xssf.usermodel

XSSFDataValidationConstraint(String[]) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

XSSFDataValidationConstraint(int, String) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

XSSFDataValidationConstraint(int, int, String) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

XSSFDataValidationConstraint(int, int, String, String) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

XSSFDataValidationHelper - Class in org.apache.poi.xssf.usermodel

XSSFDataValidationHelper(XSSFSheet) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

XSSFDialogsheet - Class in org.apache.poi.xssf.usermodel

XSSFDialogsheet(XSSFSheet) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDialogsheet

XSSFDrawing - Class in org.apache.poi.xssf.usermodel
Represents a SpreadsheetML drawing
XSSFDrawing() - Constructor for class org.apache.poi.xssf.usermodel.XSSFDrawing
Create a new SpreadsheetML drawing
XSSFDrawing(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFDrawing
Construct a SpreadsheetML drawing from a package part
XSSFDump - Class in org.apache.poi.xssf.dev
Utility class which dumps the contents of a *.xlsx file into file system.
XSSFDump() - Constructor for class org.apache.poi.xssf.dev.XSSFDump

XSSFEvaluationWorkbook - Class in org.apache.poi.xssf.usermodel
Internal POI use only
XSSFEvenFooter - Class in org.apache.poi.xssf.usermodel
Even page footer value.
XSSFEvenFooter(CTHeaderFooter) - Constructor for class org.apache.poi.xssf.usermodel.XSSFEvenFooter
Create an instance of XSSFEvenFooter from the supplied XML bean
XSSFEvenHeader - Class in org.apache.poi.xssf.usermodel
Even page header value.
XSSFEvenHeader(CTHeaderFooter) - Constructor for class org.apache.poi.xssf.usermodel.XSSFEvenHeader
Create an instance of XSSFEvenHeader from the supplied XML bean
XSSFEventBasedExcelExtractor - Class in org.apache.poi.xssf.extractor
Implementation of a text extractor from OOXML Excel files that uses SAX event based parsing.
XSSFEventBasedExcelExtractor(String) - Constructor for class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

XSSFEventBasedExcelExtractor(OPCPackage) - Constructor for class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

XSSFEventBasedExcelExtractor.SheetTextExtractor - Class in org.apache.poi.xssf.extractor

XSSFEventBasedExcelExtractor.SheetTextExtractor(StringBuffer) - Constructor for class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

XSSFExcelExtractor - Class in org.apache.poi.xssf.extractor
Helper class to extract text from an OOXML Excel file
XSSFExcelExtractor(String) - Constructor for class org.apache.poi.xssf.extractor.XSSFExcelExtractor
Deprecated. Use XSSFExcelExtractor.XSSFExcelExtractor(org.apache.poi.openxml4j.opc.OPCPackage) instead.
XSSFExcelExtractor(OPCPackage) - Constructor for class org.apache.poi.xssf.extractor.XSSFExcelExtractor

XSSFExcelExtractor(XSSFWorkbook) - Constructor for class org.apache.poi.xssf.extractor.XSSFExcelExtractor

XSSFExportToXml - Class in org.apache.poi.xssf.extractor
Maps an XLSX to an XML according to one of the mapping defined.
XSSFExportToXml(XSSFMap) - Constructor for class org.apache.poi.xssf.extractor.XSSFExportToXml
Creates a new exporter and sets the mapping to be used when generating the XML output document
XSSFFactory - Class in org.apache.poi.xssf.usermodel
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSSFFirstFooter - Class in org.apache.poi.xssf.usermodel
First page footer content.
XSSFFirstFooter(CTHeaderFooter) - Constructor for class org.apache.poi.xssf.usermodel.XSSFFirstFooter
Create an instance of XSSFFirstFooter from the supplied XML bean
XSSFFirstHeader - Class in org.apache.poi.xssf.usermodel
First page header content.
XSSFFirstHeader(CTHeaderFooter) - Constructor for class org.apache.poi.xssf.usermodel.XSSFFirstHeader
Create an instance of XSSFFirstHeader from the supplied XML bean
XSSFFont - Class in org.apache.poi.xssf.usermodel
Represents a font used in a workbook.
XSSFFont(CTFont) - Constructor for class org.apache.poi.xssf.usermodel.XSSFFont
Create a new XSSFFont
XSSFFont(CTFont, int) - Constructor for class org.apache.poi.xssf.usermodel.XSSFFont

XSSFFont() - Constructor for class org.apache.poi.xssf.usermodel.XSSFFont
Create a new XSSFont.
XSSFFontFormatting - Class in org.apache.poi.xssf.usermodel

XSSFFormulaEvaluator - Class in org.apache.poi.xssf.usermodel
Evaluates formula cells.
For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.
XSSFFormulaEvaluator(XSSFWorkbook) - Constructor for class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator

XSSFFormulaEvaluator(XSSFWorkbook, IStabilityClassifier) - Constructor for class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
Deprecated. (Sep 2009) (reduce overloading) use XSSFFormulaEvaluator.create(XSSFWorkbook, org.apache.poi.ss.formula.IStabilityClassifier, org.apache.poi.ss.formula.udf.UDFFinder)
XSSFFormulaUtils - Class in org.apache.poi.xssf.usermodel.helpers
Utility to update formulas and named ranges when a sheet name was changed
XSSFFormulaUtils(XSSFWorkbook) - Constructor for class org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils

XSSFGraphicFrame - Class in org.apache.poi.xssf.usermodel
Represents DrawingML GraphicalObjectFrame.
XSSFGraphicFrame(XSSFDrawing, CTGraphicalObjectFrame) - Constructor for class org.apache.poi.xssf.usermodel.XSSFGraphicFrame
Construct a new XSSFGraphicFrame object.
XSSFHeaderFooter - Class in org.apache.poi.xssf.usermodel.extensions
Parent class of all XSSF headers and footers.
XSSFHeaderFooter(CTHeaderFooter) - Constructor for class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
Create an instance of XSSFHeaderFooter from the supplied XML bean
XSSFHyperlink - Class in org.apache.poi.xssf.usermodel
XSSF Implementation of a Hyperlink.
XSSFHyperlink(int) - Constructor for class org.apache.poi.xssf.usermodel.XSSFHyperlink
Create a new XSSFHyperlink.
XSSFHyperlink(CTHyperlink, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFHyperlink
Create a XSSFHyperlink amd initialize it from the supplied CTHyperlink bean and package relationship
XSSFImportFromXML - Class in org.apache.poi.xssf.extractor
Imports data from an external XML to an XLSX according to one of the mappings defined.The output XML Schema must respect this limitations: the input XML must be valid according to the XML Schema used in the mapping denormalized table mapping is not supported (see OpenOffice part 4: chapter 3.5.1.7) all the namespaces used in the document must be declared in the root node
XSSFImportFromXML(XSSFMap) - Constructor for class org.apache.poi.xssf.extractor.XSSFImportFromXML

XSSFManualLayout - Class in org.apache.poi.xssf.usermodel.charts
Represents a SpreadsheetML manual layout.
XSSFManualLayout(CTLayout) - Constructor for class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout
Create a new SpreadsheetML manual layout.
XSSFManualLayout(XSSFChart) - Constructor for class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout
Create a new SpreadsheetML manual layout for chart.
XSSFMap - Class in org.apache.poi.xssf.usermodel
This class implements the Map element (Open Office XML Part 4: chapter 3.16.2)
This element contains all of the properties related to the XML map, and the behaviors expected during data refresh operations.
XSSFMap(CTMap, MapInfo) - Constructor for class org.apache.poi.xssf.usermodel.XSSFMap

XSSFName - Class in org.apache.poi.xssf.usermodel
Represents a defined named range in a SpreadsheetML workbook.
XSSFName(CTDefinedName, XSSFWorkbook) - Constructor for class org.apache.poi.xssf.usermodel.XSSFName
Creates an XSSFName object - called internally by XSSFWorkbook.
XSSFOddFooter - Class in org.apache.poi.xssf.usermodel
Odd page footer value.
XSSFOddFooter(CTHeaderFooter) - Constructor for class org.apache.poi.xssf.usermodel.XSSFOddFooter
Create an instance of XSSFOddFooter from the supplied XML bean
XSSFOddHeader - Class in org.apache.poi.xssf.usermodel
Odd page header value.
XSSFOddHeader(CTHeaderFooter) - Constructor for class org.apache.poi.xssf.usermodel.XSSFOddHeader
Create an instance of XSSFOddHeader from the supplied XML bean
XSSFPatternFormatting - Class in org.apache.poi.xssf.usermodel

XSSFPicture - Class in org.apache.poi.xssf.usermodel
Represents a picture shape in a SpreadsheetML drawing.
XSSFPicture(XSSFDrawing, CTPicture) - Constructor for class org.apache.poi.xssf.usermodel.XSSFPicture
Construct a new XSSFPicture object.
XSSFPictureData - Class in org.apache.poi.xssf.usermodel
Raw picture data, normally attached to a SpreadsheetML Drawing.
XSSFPictureData() - Constructor for class org.apache.poi.xssf.usermodel.XSSFPictureData
Create a new XSSFPictureData node
XSSFPictureData(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFPictureData
Construct XSSFPictureData from a package part
XSSFPrintSetup - Class in org.apache.poi.xssf.usermodel
Page setup and page margins settings for the worksheet.
XSSFPrintSetup(CTWorksheet) - Constructor for class org.apache.poi.xssf.usermodel.XSSFPrintSetup

XSSFReader - Class in org.apache.poi.xssf.eventusermodel
This class makes it easy to get at individual parts of an OOXML .xlsx file, suitable for low memory sax parsing or similar.
XSSFReader(OPCPackage) - Constructor for class org.apache.poi.xssf.eventusermodel.XSSFReader
Creates a new XSSFReader, for the given package
XSSFReader.SheetIterator - Class in org.apache.poi.xssf.eventusermodel
Iterator over sheet data.
XSSFRelation - Class in org.apache.poi.xssf.usermodel

XSSFRichTextString - Class in org.apache.poi.xssf.usermodel
Rich text unicode string.
XSSFRichTextString(String) - Constructor for class org.apache.poi.xssf.usermodel.XSSFRichTextString
Create a rich text string
XSSFRichTextString() - Constructor for class org.apache.poi.xssf.usermodel.XSSFRichTextString
Create empty rich text string and initialize it with empty string
XSSFRichTextString(CTRst) - Constructor for class org.apache.poi.xssf.usermodel.XSSFRichTextString
Create a rich text string from the supplied XML bean
XSSFRow - Class in org.apache.poi.xssf.usermodel
High level representation of a row of a spreadsheet.
XSSFRow(CTRow, XSSFSheet) - Constructor for class org.apache.poi.xssf.usermodel.XSSFRow
Construct a XSSFRow.
XSSFRowShifter - Class in org.apache.poi.xssf.usermodel.helpers

XSSFRowShifter(XSSFSheet) - Constructor for class org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter

XSSFSave - Class in org.apache.poi.xssf.dev
Utility which loads a SpreadsheetML file and saves it back.
XSSFSave() - Constructor for class org.apache.poi.xssf.dev.XSSFSave

XSSFScatterChartData - Class in org.apache.poi.xssf.usermodel.charts
Represents DrawingML scatter charts.
XSSFScatterChartData() - Constructor for class org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData

XSSFShape - Class in org.apache.poi.xssf.usermodel
Represents a shape in a SpreadsheetML drawing.
XSSFShape() - Constructor for class org.apache.poi.xssf.usermodel.XSSFShape

XSSFShapeGroup - Class in org.apache.poi.xssf.usermodel
This object specifies a group shape that represents many shapes grouped together.
XSSFShapeGroup(XSSFDrawing, CTGroupShape) - Constructor for class org.apache.poi.xssf.usermodel.XSSFShapeGroup
Construct a new XSSFSimpleShape object.
XSSFSheet - Class in org.apache.poi.xssf.usermodel
High level representation of a SpreadsheetML worksheet.
XSSFSheet() - Constructor for class org.apache.poi.xssf.usermodel.XSSFSheet
Creates new XSSFSheet - called by XSSFWorkbook to create a sheet from scratch.
XSSFSheet(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFSheet
Creates an XSSFSheet representing the given package part and relationship.
XSSFSheetConditionalFormatting - Class in org.apache.poi.xssf.usermodel

XSSFSheetXMLHandler - Class in org.apache.poi.xssf.eventusermodel
This class handles the processing of a sheet#.xml sheet part of a XSSF .xlsx file, and generates row and cell events for it.
XSSFSheetXMLHandler(StylesTable, ReadOnlySharedStringsTable, XSSFSheetXMLHandler.SheetContentsHandler, DataFormatter, boolean) - Constructor for class org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler
Accepts objects needed while parsing.
XSSFSheetXMLHandler(StylesTable, ReadOnlySharedStringsTable, XSSFSheetXMLHandler.SheetContentsHandler, boolean) - Constructor for class org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler
Accepts objects needed while parsing.
XSSFSheetXMLHandler.SheetContentsHandler - Interface in org.apache.poi.xssf.eventusermodel
You need to implement this to handle the results of the sheet parsing.
XSSFSimpleShape - Class in org.apache.poi.xssf.usermodel
Represents a shape with a predefined geometry in a SpreadsheetML drawing.
XSSFSimpleShape(XSSFDrawing, CTShape) - Constructor for class org.apache.poi.xssf.usermodel.XSSFSimpleShape

XSSFSingleXmlCell - Class in org.apache.poi.xssf.usermodel.helpers
This class is a wrapper around the CTSingleXmlCell (Open Office XML Part 4: chapter 3.5.2.1)
XSSFSingleXmlCell(CTSingleXmlCell, SingleXmlCells) - Constructor for class org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell

XSSFTable - Class in org.apache.poi.xssf.usermodel
This class implements the Table Part (Open Office XML Part 4: chapter 3.5.1) This implementation works under the assumption that a table contains mappings to a subtree of an XML.
XSSFTable() - Constructor for class org.apache.poi.xssf.usermodel.XSSFTable

XSSFTable(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFTable

XSSFTextBox - Class in org.apache.poi.xssf.usermodel
Represents a text box in a SpreadsheetML drawing.
XSSFTextBox(XSSFDrawing, CTShape) - Constructor for class org.apache.poi.xssf.usermodel.XSSFTextBox

XSSFValueAxis - Class in org.apache.poi.xssf.usermodel.charts
Value axis type.
XSSFValueAxis(XSSFChart, long, AxisPosition) - Constructor for class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

XSSFValueAxis(XSSFChart, CTValAx) - Constructor for class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

XSSFVMLDrawing - Class in org.apache.poi.xssf.usermodel
Represents a SpreadsheetML VML drawing.
XSSFVMLDrawing() - Constructor for class org.apache.poi.xssf.usermodel.XSSFVMLDrawing
Create a new SpreadsheetML drawing
XSSFVMLDrawing(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xssf.usermodel.XSSFVMLDrawing
Construct a SpreadsheetML drawing from a package part
XSSFWorkbook - Class in org.apache.poi.xssf.usermodel
High level representation of a SpreadsheetML workbook.
XSSFWorkbook() - Constructor for class org.apache.poi.xssf.usermodel.XSSFWorkbook
Create a new SpreadsheetML workbook.
XSSFWorkbook(OPCPackage) - Constructor for class org.apache.poi.xssf.usermodel.XSSFWorkbook
Constructs a XSSFWorkbook object given a OpenXML4J Package object, see www.openxml4j.org.
XSSFWorkbook(InputStream) - Constructor for class org.apache.poi.xssf.usermodel.XSSFWorkbook

XSSFWorkbook(String) - Constructor for class org.apache.poi.xssf.usermodel.XSSFWorkbook
Deprecated.
XSSFXmlColumnPr - Class in org.apache.poi.xssf.usermodel.helpers
This class is a wrapper around the CTXmlColumnPr (Open Office XML Part 4: chapter 3.5.1.7)
XSSFXmlColumnPr(XSSFTable, CTTableColumn, CTXmlColumnPr) - Constructor for class org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr

XWPFAbstractNum - Class in org.apache.poi.xwpf.usermodel

XWPFAbstractNum() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

XWPFAbstractNum(CTAbstractNum) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

XWPFAbstractNum(CTAbstractNum, XWPFNumbering) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

XWPFComment - Class in org.apache.poi.xwpf.usermodel
Sketch of XWPF comment class
XWPFComment(CTComment, XWPFDocument) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFComment

XWPFCommentsDecorator - Class in org.apache.poi.xwpf.model
Decorator class for XWPFParagraph allowing to add comments found in paragraph to its text
XWPFCommentsDecorator(XWPFParagraphDecorator) - Constructor for class org.apache.poi.xwpf.model.XWPFCommentsDecorator

XWPFCommentsDecorator(XWPFParagraph, XWPFParagraphDecorator) - Constructor for class org.apache.poi.xwpf.model.XWPFCommentsDecorator

XWPFDocument - Class in org.apache.poi.xwpf.usermodel
Experimental class to do low level processing of docx files.
XWPFDocument(OPCPackage) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFDocument

XWPFDocument(InputStream) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFDocument

XWPFDocument() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFDocument

XWPFFactory - Class in org.apache.poi.xwpf.usermodel

XWPFFooter - Class in org.apache.poi.xwpf.usermodel
Sketch of XWPF footer class
XWPFFooter() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFFooter

XWPFFooter(XWPFDocument, CTHdrFtr) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFFooter

XWPFFooter(POIXMLDocumentPart, PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFFooter

XWPFFootnote - Class in org.apache.poi.xwpf.usermodel

XWPFFootnote(CTFtnEdn, XWPFFootnotes) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFFootnote

XWPFFootnote(XWPFDocument, CTFtnEdn) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFFootnote

XWPFFootnotes - Class in org.apache.poi.xwpf.usermodel
Looks after the collection of Footnotes for a document
XWPFFootnotes(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFFootnotes
Construct XWPFFootnotes from a package part
XWPFFootnotes() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFFootnotes
Construct XWPFFootnotes from scratch for a new document.
XWPFHeader - Class in org.apache.poi.xwpf.usermodel
Sketch of XWPF header class
XWPFHeader() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFHeader

XWPFHeader(POIXMLDocumentPart, PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFHeader

XWPFHeader(XWPFDocument, CTHdrFtr) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFHeader

XWPFHeaderFooter - Class in org.apache.poi.xwpf.usermodel
Parent of XWPF headers and footers
XWPFHeaderFooter() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

XWPFHeaderFooter(POIXMLDocumentPart, PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

XWPFHeaderFooterPolicy - Class in org.apache.poi.xwpf.model
A .docx file can have no headers/footers, the same header/footer on each page, odd/even page footers, and optionally also a different header/footer on the first page.
XWPFHeaderFooterPolicy(XWPFDocument) - Constructor for class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
Figures out the policy for the given document, and creates any header and footer objects as required.
XWPFHeaderFooterPolicy(XWPFDocument, CTSectPr) - Constructor for class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
Figures out the policy for the given document, and creates any header and footer objects as required.
XWPFHyperlink - Class in org.apache.poi.xwpf.usermodel
Sketch of XWPF hyperlink class
XWPFHyperlink(String, String) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFHyperlink

XWPFHyperlinkDecorator - Class in org.apache.poi.xwpf.model
Deprecated. Use XWPFHyperlinkRun instead
XWPFHyperlinkDecorator(XWPFParagraphDecorator, boolean) - Constructor for class org.apache.poi.xwpf.model.XWPFHyperlinkDecorator
Deprecated.
XWPFHyperlinkDecorator(XWPFParagraph, XWPFParagraphDecorator, boolean) - Constructor for class org.apache.poi.xwpf.model.XWPFHyperlinkDecorator
Deprecated.
XWPFHyperlinkRun - Class in org.apache.poi.xwpf.usermodel
A run of text with a Hyperlink applied to it.
XWPFHyperlinkRun(CTHyperlink, CTR, XWPFParagraph) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

XWPFLatentStyles - Class in org.apache.poi.xwpf.usermodel

XWPFLatentStyles() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFLatentStyles

XWPFLatentStyles(CTLatentStyles) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFLatentStyles

XWPFLatentStyles(CTLatentStyles, XWPFStyles) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFLatentStyles

XWPFNum - Class in org.apache.poi.xwpf.usermodel

XWPFNum() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFNum

XWPFNum(CTNum) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFNum

XWPFNum(XWPFNumbering) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFNum

XWPFNum(CTNum, XWPFNumbering) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFNum

XWPFNumbering - Class in org.apache.poi.xwpf.usermodel

XWPFNumbering(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFNumbering
create a new styles object with an existing document
XWPFNumbering() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFNumbering
create a new XWPFNumbering object for use in a new document
XWPFParagraph - Class in org.apache.poi.xwpf.usermodel
Sketch of XWPF paragraph class
XWPFParagraph(CTP, IBody) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFParagraph

XWPFParagraphDecorator - Class in org.apache.poi.xwpf.model
Base decorator class for XWPFParagraph
XWPFParagraphDecorator(XWPFParagraph) - Constructor for class org.apache.poi.xwpf.model.XWPFParagraphDecorator

XWPFParagraphDecorator(XWPFParagraph, XWPFParagraphDecorator) - Constructor for class org.apache.poi.xwpf.model.XWPFParagraphDecorator

XWPFPicture - Class in org.apache.poi.xwpf.usermodel

XWPFPicture(CTPicture, XWPFRun) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFPicture

XWPFPictureData - Class in org.apache.poi.xwpf.usermodel

XWPFPictureData() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFPictureData
Create a new XWPFGraphicData node
XWPFPictureData(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFPictureData
Construct XWPFPictureData from a package part
XWPFRelation - Class in org.apache.poi.xwpf.usermodel

XWPFRun - Class in org.apache.poi.xwpf.usermodel
XWPFRun object defines a region of text with a common set of properties
XWPFRun(CTR, XWPFParagraph) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFRun

XWPFSettings - Class in org.apache.poi.xwpf.usermodel

XWPFSettings(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFSettings

XWPFSettings() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFSettings

XWPFStyle - Class in org.apache.poi.xwpf.usermodel

XWPFStyle(CTStyle) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFStyle
constructor
XWPFStyle(CTStyle, XWPFStyles) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFStyle
constructor
XWPFStyles - Class in org.apache.poi.xwpf.usermodel

XWPFStyles(PackagePart, PackageRelationship) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFStyles
Construct XWPFStyles from a package part
XWPFStyles() - Constructor for class org.apache.poi.xwpf.usermodel.XWPFStyles
Construct XWPFStyles from scratch for a new document.
XWPFTable - Class in org.apache.poi.xwpf.usermodel
Sketch of XWPFTable class.
XWPFTable(CTTbl, IBody, int, int) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFTable

XWPFTable(CTTbl, IBody) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFTable

XWPFTable.XWPFBorderType - Enum in org.apache.poi.xwpf.usermodel

XWPFTableCell - Class in org.apache.poi.xwpf.usermodel
XWPFTableCell class.
XWPFTableCell(CTTc, XWPFTableRow, IBody) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFTableCell
If a table cell does not include at least one block-level element, then this document shall be considered corrupt
XWPFTableCell.XWPFVertAlign - Enum in org.apache.poi.xwpf.usermodel

XWPFTableRow - Class in org.apache.poi.xwpf.usermodel

XWPFTableRow(CTRow, XWPFTable) - Constructor for class org.apache.poi.xwpf.usermodel.XWPFTableRow

XWPFWordExtractor - Class in org.apache.poi.xwpf.extractor
Helper class to extract text from an OOXML Word file
XWPFWordExtractor(OPCPackage) - Constructor for class org.apache.poi.xwpf.extractor.XWPFWordExtractor

XWPFWordExtractor(XWPFDocument) - Constructor for class org.apache.poi.xwpf.extractor.XWPFWordExtractor

XYNumericFunction - Class in org.apache.poi.ss.formula.functions

XYNumericFunction() - Constructor for class org.apache.poi.ss.formula.functions.XYNumericFunction

XYNumericFunction.Accumulator - Interface in org.apache.poi.ss.formula.functions

Y

YEAR - Static variable in class org.apache.poi.ss.formula.functions.CalendarFieldFunction

YPOS - Static variable in class org.apache.poi.hsmf.datatypes.MAPIProperty

Z

zap(int) - Method in interface org.apache.poi.poifs.storage.BlockList
remove the specified block from the list
ZERO - Static variable in class org.apache.poi.ss.formula.eval.NumberEval

ZipContentTypeManager - Class in org.apache.poi.openxml4j.opc.internal
Zip implementation of the ContentTypeManager.
ZipContentTypeManager(InputStream, OPCPackage) - Constructor for class org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager
Delegate constructor to the super constructor.
ZipEntrySource - Interface in org.apache.poi.openxml4j.util
An Interface to make getting the different bits of a Zip File easy.
ZipFileZipEntrySource - Class in org.apache.poi.openxml4j.util
A ZipEntrySource wrapper around a ZipFile.
ZipFileZipEntrySource(ZipFile) - Constructor for class org.apache.poi.openxml4j.util.ZipFileZipEntrySource

ZipHelper - Class in org.apache.poi.openxml4j.opc.internal

ZipInputStreamZipEntrySource - Class in org.apache.poi.openxml4j.util
Provides a way to get at all the ZipEntries from a ZipInputStream, as many times as required.
ZipInputStreamZipEntrySource(ZipInputStream) - Constructor for class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource
Reads all the entries from the ZipInputStream into memory, and closes the source stream.
ZipInputStreamZipEntrySource.FakeZipEntry - Class in org.apache.poi.openxml4j.util
So we can close the real zip entry and still effectively work with it.
ZipInputStreamZipEntrySource.FakeZipEntry(ZipEntry, ZipInputStream) - Constructor for class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry

ZipPackage - Class in org.apache.poi.openxml4j.opc
Physical zip package.
ZipPackage() - Constructor for class org.apache.poi.openxml4j.opc.ZipPackage
Constructor.
ZipPackagePart - Class in org.apache.poi.openxml4j.opc
Zip implementation of a PackagePart.
ZipPackagePart(OPCPackage, PackagePartName, String) - Constructor for class org.apache.poi.openxml4j.opc.ZipPackagePart
Constructor.
ZipPackagePart(OPCPackage, ZipEntry, PackagePartName, String) - Constructor for class org.apache.poi.openxml4j.opc.ZipPackagePart
Constructor.
ZipPackagePropertiesMarshaller - Class in org.apache.poi.openxml4j.opc.internal.marshallers
Package core properties marshaller specialized for zipped package.
ZipPackagePropertiesMarshaller() - Constructor for class org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller

ZipPartMarshaller - Class in org.apache.poi.openxml4j.opc.internal.marshallers
Zip part marshaller.
ZipPartMarshaller() - Constructor for class org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller

zipsize - Variable in class org.apache.poi.hslf.blip.Metafile.Header
size of the compressed metafile data

_

_align - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

_bat_array_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_bat_count_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_book - Variable in class org.apache.poi.hssf.usermodel.HSSFSheet

_bookmarks - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the bookmarks
_bookmarksTables - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the bookmarks tables
_buf - Variable in class org.apache.poi.hwpf.model.PropertyNode

_bullet - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

_bulletOffset - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

_byteAtom - Variable in class org.apache.poi.hslf.model.TextRun

_cbt - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
Contains formatting properties for text
_cft - Variable in class org.apache.poi.hwpf.HWPFDocument
Contains text of the document wrapped in a obfuscated Word data structure
_characters - Variable in class org.apache.poi.hwpf.usermodel.Range
All CharacterRuns that belong to the document this Range belongs to.
_charAtom - Variable in class org.apache.poi.hslf.model.TextRun

_charEnd - Variable in class org.apache.poi.hwpf.usermodel.Range
The end index in the characterRuns list for this Range.
_charRangeFound - Variable in class org.apache.poi.hwpf.usermodel.Range
Have we loaded the characterRun indexes yet.
_charStart - Variable in class org.apache.poi.hwpf.usermodel.Range
The start index in the characterRuns list for this Range
_children - Variable in class org.apache.poi.hslf.record.RecordContainer

_clientData - Variable in class org.apache.poi.hslf.model.SimpleShape

_clientRecords - Variable in class org.apache.poi.hslf.model.SimpleShape
Records stored in EscherClientDataRecord
_complexData - Variable in class org.apache.poi.ddf.EscherComplexProperty

_container - Variable in class org.apache.poi.openxml4j.opc.PackagePart
This part's container.
_contentType - Variable in class org.apache.poi.openxml4j.opc.PackagePart
The type of content of this part.
_crun - Variable in class org.apache.poi.hwpf.model.FormattedDiskPage

_dataStream - Variable in class org.apache.poi.hwpf.HWPFDocument
data stream buffer
_defaultName - Variable in class org.apache.poi.POIXMLRelation
The path component of a pack URI.
_doc - Variable in class org.apache.poi.hwpf.usermodel.Range
The document this range blongs to.
_dop - Variable in class org.apache.poi.hwpf.HWPFDocument
Document wide Properties
_end - Variable in class org.apache.poi.hwpf.usermodel.Range
The ending character offset of this range.
_endnotes - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the footnotes
_endnotesTables - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the ending notes tables
_escherContainer - Variable in class org.apache.poi.hslf.model.Shape
Either EscherSpContainer or EscheSpgrContainer record which holds information about this shape.
_escherRecordHolder - Variable in class org.apache.poi.hwpf.HWPFDocument
Escher Drawing Group information
_exEmbed - Variable in class org.apache.poi.hslf.model.OLEShape

_extractHeaderFooter(HeaderFooter) - Static method in class org.apache.poi.hssf.extractor.ExcelExtractor

_fib - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
The FIB
_fields - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the fields
_fieldsTables - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the fields PLCFs
_fill - Variable in class org.apache.poi.hslf.model.Shape
Fill
_fkp - Variable in class org.apache.poi.hwpf.model.FormattedDiskPage

_footnotes - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the footnotes
_footnotesTables - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the footnotes tables
_formatter - Variable in class org.apache.poi.hssf.converter.AbstractExcelConverter

_frc - Static variable in class org.apache.poi.hslf.model.TextShape
Used to calculate text bounds
_ft - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
Holds fonts for this document.
_getBlockHeader() - Method in class org.apache.poi.hdgf.streams.CompressedStreamStore

_getBoundAggregate() - Method in class org.apache.poi.hssf.usermodel.HSSFPatriarch
Returns the aggregate escher record we're bound to
_getCompressedContents() - Method in class org.apache.poi.hdgf.streams.CompressedStreamStore

_getContents() - Method in class org.apache.poi.hdgf.chunks.Chunk

_getContents() - Method in class org.apache.poi.hdgf.streams.StreamStore

_getContentsLength() - Method in class org.apache.poi.hdgf.streams.Stream

_getDetailsA() - Method in class org.apache.poi.hslf.record.ExHyperlink
Get the link details (field A)
_getDetailsB() - Method in class org.apache.poi.hslf.record.ExHyperlink
Get the link details (field B)
_getDXfsSize() - Method in class org.apache.poi.xssf.model.StylesTable

_getHdrFtr() - Method in class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

_getNumberFormatSize() - Method in class org.apache.poi.xssf.model.StylesTable
For unit testing only
_getRawCharacterStyle() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Internal Use Only - get the underlying character style collection.
_getRawErrorCheckValue() - Method in class org.apache.poi.hssf.record.common.FeatFormulaErr2

_getRawParagraphStyle() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Internal Use Only - get the underlying paragraph style collection.
_getSheetNumber() - Method in class org.apache.poi.hslf.model.Sheet
Returns the (internal, SlideIdentifier based) sheet number, as used to reference this sheet from other records.
_getSheetRefId() - Method in class org.apache.poi.hslf.model.Sheet
Returns the (internal, RefID based) sheet number, as used to in PersistPtr stuff.
_getStore() - Method in class org.apache.poi.hdgf.streams.Stream

_getStyleXfsSize() - Method in class org.apache.poi.xssf.model.StylesTable
For unit testing only
_getXfsSize() - Method in class org.apache.poi.xssf.model.StylesTable
For unit testing only
_getXSLFSlideShow() - Method in class org.apache.poi.xslf.usermodel.XMLSlideShow
Deprecated.
_headerAtom - Variable in class org.apache.poi.hslf.model.TextRun

_isCharacterStyleShared() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Internal Use Only - are the Character styles shared?
_isParagraphStyleShared() - Method in class org.apache.poi.hslf.usermodel.RichTextRun
Internal Use Only - are the Paragraph styles shared?
_istd - Variable in class org.apache.poi.hwpf.usermodel.Paragraph

_isUncalced - Variable in class org.apache.poi.hssf.model.InternalSheet
Add an UncalcedRecord if not true indicating formulas have not been calculated
_isUnicode - Variable in class org.apache.poi.hslf.model.TextRun

_list - Variable in class org.apache.poi.ss.util.CellRangeAddressList
List of CellRangeAddresses.
_lt - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
Hold list tables
_mainStream - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
main document stream buffer
_max_bats_in_header - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_NO_INDEX - Static variable in class org.apache.poi.poifs.property.Property

_NODE_BLACK - Static variable in class org.apache.poi.poifs.property.Property

_NODE_RED - Static variable in class org.apache.poi.poifs.property.Property

_objectPool - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
Holds OLE2 objects
_officeArts - Variable in class org.apache.poi.hwpf.HWPFDocument
Deprecated.
_officeDrawingsHeaders - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds Office Art objects
_officeDrawingsMain - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds Office Art objects
_offset - Variable in class org.apache.poi.hwpf.model.FormattedDiskPage

_papx - Variable in class org.apache.poi.hwpf.usermodel.Paragraph

_paragraphs - Variable in class org.apache.poi.hwpf.model.PAPBinTable

_paragraphs - Variable in class org.apache.poi.hwpf.usermodel.Range
All paragraphs that belong to the document this Range belongs to.
_parEnd - Variable in class org.apache.poi.hwpf.usermodel.Range
The end index in the paragraphs list for this Range, exclusive
_parent - Variable in class org.apache.poi.hslf.model.Shape
Parent of this shape.
_parRangeFound - Variable in class org.apache.poi.hwpf.usermodel.Range
Have we loaded the paragraph indexes yet.
_parStart - Variable in class org.apache.poi.hwpf.usermodel.Range
The start index in the paragraphs list for this Range, inclusive
_partName - Variable in class org.apache.poi.openxml4j.opc.PackagePart
The part name.
_pbt - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
Contains formatting properties for paragraphs
_pictures - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds pictures table
_propCache - Variable in class org.apache.poi.hwpf.model.CachedPropertyNode

_properties - Variable in class org.apache.poi.poifs.property.PropertyTableBase

_property_start_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_props - Variable in class org.apache.poi.hwpf.usermodel.Paragraph

_records - Variable in class org.apache.poi.hslf.model.TextRun
all text run records that follow TextHeaderAtom.
_relation - Variable in class org.apache.poi.POIXMLRelation
The kind of connection between a source part and a target part in a package.
_rmat - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the revision mark authors for this document.
_rowsAggregate - Variable in class org.apache.poi.hssf.model.InternalSheet
always present
_rtRuns - Variable in class org.apache.poi.hslf.model.TextRun

_ruler - Variable in class org.apache.poi.hslf.model.TextRun

_sbat_block_count_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_sbat_start_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_sbt - Variable in class org.apache.poi.hwpf.HWPFDocument
Holds the save history for this document.
_sectionEnd - Variable in class org.apache.poi.hwpf.usermodel.Range
The end index in the sections list for this Range.
_sections - Variable in class org.apache.poi.hwpf.model.SectionTable

_sections - Variable in class org.apache.poi.hwpf.usermodel.Range
All sections that belong to the document this Range belongs to.
_sectionStart - Variable in class org.apache.poi.hwpf.usermodel.Range
The start index in the sections list for this Range
_selection - Variable in class org.apache.poi.hssf.model.InternalSheet

_shape - Variable in class org.apache.poi.hslf.model.TextPainter

_sheet - Variable in class org.apache.poi.hslf.model.Shape
The Sheet this shape belongs to
_sheets - Variable in class org.apache.poi.hssf.usermodel.HSSFWorkbook
this holds the HSSFSheet objects attached to this workbook
_signature - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_signature_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_ss - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
Holds styles for this document.
_st - Variable in class org.apache.poi.hwpf.HWPFDocumentCore
Contains formatting properties for sections.
_start - Variable in class org.apache.poi.hwpf.usermodel.Range
The starting character offset of this range.
_styleAtom - Variable in class org.apache.poi.hslf.model.TextRun

_tabids - Variable in class org.apache.poi.hssf.record.TabIdRecord

_table - Static variable in class org.apache.poi.xslf.usermodel.XSLFRelation
A map to lookup POIXMLRelation by its relation type
_table - Static variable in class org.apache.poi.xssf.usermodel.XSSFRelation
A map to lookup POIXMLRelation by its relation type
_table - Static variable in class org.apache.poi.xwpf.usermodel.XWPFRelation
A map to lookup POIXMLRelation by its relation type
_tableStream - Variable in class org.apache.poi.hwpf.HWPFDocument
table stream buffer
_text - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

_text - Variable in class org.apache.poi.hwpf.HWPFDocument
Contains text buffer linked directly to single-piece document text piece
_text - Variable in class org.apache.poi.hwpf.model.SectionTable

_text - Variable in class org.apache.poi.hwpf.usermodel.Range

_textOffset - Variable in class org.apache.poi.hslf.model.TextPainter.TextElement

_textPieces - Variable in class org.apache.poi.hwpf.model.TextPieceTable

_textPiecesFCOrder - Variable in class org.apache.poi.hwpf.model.TextPieceTable

_textRuns - Variable in class org.apache.poi.hwpf.model.CHPBinTable
List of character properties.
_tpt - Variable in class org.apache.poi.hwpf.model.ComplexFileTable

_txtbox - Variable in class org.apache.poi.hslf.model.TextShape
Escher container which holds text attributes such as TextHeaderAtom, TextBytesAtom ot TextCharsAtom, StyleTextPropAtom etc.
_txtrun - Variable in class org.apache.poi.hslf.model.TextShape
TextRun object which holds actual text and format data
_type - Variable in class org.apache.poi.POIXMLRelation
Describes the content stored in a part.
_workbook - Variable in class org.apache.poi.hssf.usermodel.HSSFSheet

_xbat_count_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

_xbat_start_offset - Static variable in interface org.apache.poi.poifs.storage.HeaderBlockConstants

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV NEXT

FRAMES NO FRAMES


Overview List

All Classes

Packages
org.apache.poi
org.apache.poi.common.usermodel
org.apache.poi.ddf
org.apache.poi.dev
org.apache.poi.extractor
org.apache.poi.hdgf
org.apache.poi.hdgf.chunks
org.apache.poi.hdgf.dev
org.apache.poi.hdgf.exceptions
org.apache.poi.hdgf.extractor
org.apache.poi.hdgf.pointers
org.apache.poi.hdgf.streams
org.apache.poi.hmef
org.apache.poi.hmef.attribute
org.apache.poi.hmef.dev
org.apache.poi.hmef.extractor
org.apache.poi.hpbf
org.apache.poi.hpbf.dev
org.apache.poi.hpbf.extractor
org.apache.poi.hpbf.model
org.apache.poi.hpbf.model.qcbits
org.apache.poi.hpsf
org.apache.poi.hpsf.extractor
org.apache.poi.hpsf.wellknown
org.apache.poi.hslf
org.apache.poi.hslf.blip
org.apache.poi.hslf.dev
org.apache.poi.hslf.exceptions
org.apache.poi.hslf.extractor
org.apache.poi.hslf.model
org.apache.poi.hslf.model.textproperties
org.apache.poi.hslf.record
org.apache.poi.hslf.usermodel
org.apache.poi.hslf.util
org.apache.poi.hsmf
org.apache.poi.hsmf.datatypes
org.apache.poi.hsmf.dev
org.apache.poi.hsmf.exceptions
org.apache.poi.hsmf.extractor
org.apache.poi.hsmf.parsers
org.apache.poi.hssf
org.apache.poi.hssf.converter
org.apache.poi.hssf.dev
org.apache.poi.hssf.eventmodel
org.apache.poi.hssf.eventusermodel
org.apache.poi.hssf.eventusermodel.dummyrecord
org.apache.poi.hssf.extractor
org.apache.poi.hssf.model
org.apache.poi.hssf.record
org.apache.poi.hssf.record.aggregates
org.apache.poi.hssf.record.cf
org.apache.poi.hssf.record.chart
org.apache.poi.hssf.record.common
org.apache.poi.hssf.record.cont
org.apache.poi.hssf.record.crypto
org.apache.poi.hssf.record.pivottable
org.apache.poi.hssf.usermodel
org.apache.poi.hssf.util
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.extractor
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.io
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel
org.apache.poi.openxml4j.exceptions
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.marshallers
org.apache.poi.openxml4j.opc.internal.signature
org.apache.poi.openxml4j.opc.internal.unmarshallers
org.apache.poi.openxml4j.opc.signature
org.apache.poi.openxml4j.util
org.apache.poi.poifs.common
org.apache.poi.poifs.crypt
org.apache.poi.poifs.dev
org.apache.poi.poifs.eventfilesystem
org.apache.poi.poifs.filesystem
org.apache.poi.poifs.nio
org.apache.poi.poifs.property
org.apache.poi.poifs.storage
org.apache.poi.sl.usermodel
org.apache.poi.ss
org.apache.poi.ss.extractor
org.apache.poi.ss.format
org.apache.poi.ss.formula
org.apache.poi.ss.formula.atp
org.apache.poi.ss.formula.constant
org.apache.poi.ss.formula.eval
org.apache.poi.ss.formula.eval.forked
org.apache.poi.ss.formula.function
org.apache.poi.ss.formula.functions
org.apache.poi.ss.formula.ptg
org.apache.poi.ss.formula.udf
org.apache.poi.ss.usermodel
org.apache.poi.ss.usermodel.charts
org.apache.poi.ss.util
org.apache.poi.ss.util.cellwalk
org.apache.poi.util
org.apache.poi.xslf
org.apache.poi.xslf.extractor
org.apache.poi.xslf.model
org.apache.poi.xslf.model.geom
org.apache.poi.xslf.usermodel
org.apache.poi.xslf.util
org.apache.poi.xssf.dev
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.extractor
org.apache.poi.xssf.model
org.apache.poi.xssf.streaming
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts
org.apache.poi.xssf.usermodel.extensions
org.apache.poi.xssf.usermodel.helpers
org.apache.poi.xssf.util
org.apache.poi.xwpf.extractor
org.apache.poi.xwpf.model
org.apache.poi.xwpf.usermodel


Overview

PREV NEXT FRAMES NO FRAMES

POI API Documentation

DDF - Dreadful Drawing Format
org.apache.poi.ddf This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

HPSF - Horrible Property Set Format
org.apache.poi.hpsf |
org.apache.poi.hpsf.extractor |
org.apache.poi.hpsf.wellknown | Specific support for DocumentSummaryInformation, SummaryInformation types.

HSSF - Horrible Spreadsheet Format
org.apache.poi.hssf | Horrible SpreadSheet Format API's for reading/writting Excel files using pure Java.
org.apache.poi.hssf.converter |
org.apache.poi.hssf.dev | DEV package serves two purposes.
org.apache.poi.hssf.eventmodel |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.eventusermodel.dummyrecord |
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.crypto |
org.apache.poi.hssf.record.pivottable |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

HWPF - Horrible Word Processor Format
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.extractor
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.io
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel

POIFS - POI File System
org.apache.poi.poifs.common | common package contains constants and other classes shared across all POIFS subpackages
org.apache.poi.poifs.crypt |
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.eventfilesystem | The eventfilesystem is an efficient method for reading OLE 2 CDF files.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.nio |
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Utilities
org.apache.poi.util Top-level util package are classes that are useful throughout the project.

Other Packages
org.apache.poi |
org.apache.poi.common.usermodel |
org.apache.poi.dev |
org.apache.poi.extractor |
org.apache.poi.hdgf |
org.apache.poi.hdgf.chunks |
org.apache.poi.hdgf.dev |
org.apache.poi.hdgf.exceptions |
org.apache.poi.hdgf.extractor |
org.apache.poi.hdgf.pointers |
org.apache.poi.hdgf.streams |
org.apache.poi.hmef |
org.apache.poi.hmef.attribute |
org.apache.poi.hmef.dev |
org.apache.poi.hmef.extractor |
org.apache.poi.hpbf |
org.apache.poi.hpbf.dev |
org.apache.poi.hpbf.extractor |
org.apache.poi.hpbf.model |
org.apache.poi.hpbf.model.qcbits |
org.apache.poi.hslf |
org.apache.poi.hslf.blip |
org.apache.poi.hslf.dev |
org.apache.poi.hslf.exceptions |
org.apache.poi.hslf.extractor |
org.apache.poi.hslf.model |
org.apache.poi.hslf.model.textproperties |
org.apache.poi.hslf.record |
org.apache.poi.hslf.usermodel |
org.apache.poi.hslf.util |
org.apache.poi.hsmf |
org.apache.poi.hsmf.datatypes |
org.apache.poi.hsmf.dev |
org.apache.poi.hsmf.exceptions |
org.apache.poi.hsmf.extractor |
org.apache.poi.hsmf.parsers |
org.apache.poi.openxml4j.exceptions |
org.apache.poi.openxml4j.opc |
org.apache.poi.openxml4j.opc.internal |
org.apache.poi.openxml4j.opc.internal.marshallers |
org.apache.poi.openxml4j.opc.internal.signature |
org.apache.poi.openxml4j.opc.internal.unmarshallers |
org.apache.poi.openxml4j.opc.signature |
org.apache.poi.openxml4j.util |
org.apache.poi.sl.usermodel |
org.apache.poi.ss |
org.apache.poi.ss.extractor |
org.apache.poi.ss.format | This package contains classes that implement cell formatting
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.atp |
org.apache.poi.ss.formula.constant |
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.formula.function |
org.apache.poi.ss.formula.functions |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.formula.udf |
org.apache.poi.ss.usermodel |
org.apache.poi.ss.usermodel.charts |
org.apache.poi.ss.util |
org.apache.poi.ss.util.cellwalk |
org.apache.poi.xslf |
org.apache.poi.xslf.extractor |
org.apache.poi.xslf.model |
org.apache.poi.xslf.model.geom |
org.apache.poi.xslf.usermodel |
org.apache.poi.xslf.util |
org.apache.poi.xssf.dev |
org.apache.poi.xssf.eventusermodel |
org.apache.poi.xssf.extractor |
org.apache.poi.xssf.model |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.charts |
org.apache.poi.xssf.usermodel.extensions |
org.apache.poi.xssf.usermodel.helpers |
org.apache.poi.xssf.util |
org.apache.poi.xwpf.extractor |
org.apache.poi.xwpf.model |
org.apache.poi.xwpf.usermodel |

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
org.apache.poi, org.apache.poi.common.usermodel, org.apache.poi.ddf, org.apache.poi.dev, org.apache.poi.extractor, org.apache.poi.hdgf, org.apache.poi.hdgf.chunks, org.apache.poi.hdgf.dev, org.apache.poi.hdgf.exceptions, org.apache.poi.hdgf.extractor, org.apache.poi.hdgf.pointers, org.apache.poi.hdgf.streams, org.apache.poi.hmef, org.apache.poi.hmef.attribute, org.apache.poi.hmef.dev, org.apache.poi.hmef.extractor, org.apache.poi.hpbf, org.apache.poi.hpbf.dev, org.apache.poi.hpbf.extractor, org.apache.poi.hpbf.model, org.apache.poi.hpbf.model.qcbits, org.apache.poi.hpsf, org.apache.poi.hpsf.extractor, org.apache.poi.hpsf.wellknown, org.apache.poi.hslf, org.apache.poi.hslf.blip, org.apache.poi.hslf.dev, org.apache.poi.hslf.exceptions, org.apache.poi.hslf.extractor, org.apache.poi.hslf.model, org.apache.poi.hslf.model.textproperties, org.apache.poi.hslf.record, org.apache.poi.hslf.usermodel, org.apache.poi.hslf.util, org.apache.poi.hsmf, org.apache.poi.hsmf.datatypes, org.apache.poi.hsmf.dev, org.apache.poi.hsmf.exceptions, org.apache.poi.hsmf.extractor, org.apache.poi.hsmf.parsers, org.apache.poi.hssf, org.apache.poi.hssf.converter, org.apache.poi.hssf.dev, org.apache.poi.hssf.eventmodel, org.apache.poi.hssf.eventusermodel, org.apache.poi.hssf.eventusermodel.dummyrecord, org.apache.poi.hssf.extractor, org.apache.poi.hssf.model, org.apache.poi.hssf.record, org.apache.poi.hssf.record.aggregates, org.apache.poi.hssf.record.cf, org.apache.poi.hssf.record.chart, org.apache.poi.hssf.record.common, org.apache.poi.hssf.record.cont, org.apache.poi.hssf.record.crypto, org.apache.poi.hssf.record.pivottable, org.apache.poi.hssf.usermodel, org.apache.poi.hssf.util, org.apache.poi.hwpf, org.apache.poi.hwpf.converter, org.apache.poi.hwpf.dev, org.apache.poi.hwpf.extractor, org.apache.poi.hwpf.model, org.apache.poi.hwpf.model.io, org.apache.poi.hwpf.model.types, org.apache.poi.hwpf.sprm, org.apache.poi.hwpf.usermodel, org.apache.poi.openxml4j.exceptions, org.apache.poi.openxml4j.opc, org.apache.poi.openxml4j.opc.internal, org.apache.poi.openxml4j.opc.internal.marshallers, org.apache.poi.openxml4j.opc.internal.signature, org.apache.poi.openxml4j.opc.internal.unmarshallers, org.apache.poi.openxml4j.opc.signature, org.apache.poi.openxml4j.util, org.apache.poi.poifs.common, org.apache.poi.poifs.crypt, org.apache.poi.poifs.dev, org.apache.poi.poifs.eventfilesystem, org.apache.poi.poifs.filesystem, org.apache.poi.poifs.nio, org.apache.poi.poifs.property, org.apache.poi.poifs.storage, org.apache.poi.sl.usermodel, org.apache.poi.ss, org.apache.poi.ss.extractor, org.apache.poi.ss.format, org.apache.poi.ss.formula, org.apache.poi.ss.formula.atp, org.apache.poi.ss.formula.constant, org.apache.poi.ss.formula.eval, org.apache.poi.ss.formula.eval.forked, org.apache.poi.ss.formula.function, org.apache.poi.ss.formula.functions, org.apache.poi.ss.formula.ptg, org.apache.poi.ss.formula.udf, org.apache.poi.ss.usermodel, org.apache.poi.ss.usermodel.charts, org.apache.poi.ss.util, org.apache.poi.ss.util.cellwalk, org.apache.poi.util, org.apache.poi.xslf, org.apache.poi.xslf.extractor, org.apache.poi.xslf.model, org.apache.poi.xslf.model.geom, org.apache.poi.xslf.usermodel, org.apache.poi.xslf.util, org.apache.poi.xssf.dev, org.apache.poi.xssf.eventusermodel, org.apache.poi.xssf.extractor, org.apache.poi.xssf.model, org.apache.poi.xssf.streaming, org.apache.poi.xssf.usermodel, org.apache.poi.xssf.usermodel.charts, org.apache.poi.xssf.usermodel.extensions, org.apache.poi.xssf.usermodel.helpers, org.apache.poi.xssf.util, org.apache.poi.xwpf.extractor, org.apache.poi.xwpf.model, org.apache.poi.xwpf.usermodel

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.eventusermodel.AbortableHSSFListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • org.apache.poi.xslf.model.geom.AbsExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.hssf.converter.AbstractExcelConverter
      • org.apache.poi.hssf.converter.ExcelToFoConverter
      • org.apache.poi.hssf.converter.ExcelToHtmlConverter
    • org.apache.poi.hssf.converter.AbstractExcelUtils
      • org.apache.poi.hssf.converter.ExcelToFoUtils
      • org.apache.poi.hssf.converter.ExcelToHtmlUtils
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • org.apache.poi.util.BinaryTree
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • org.apache.poi.hpsf.CustomProperties
        • java.util.LinkedHashMap<K,V> (implements java.util.Map<K,V>)
          • org.apache.poi.xslf.model.geom.PresetGeometries
        • org.apache.poi.hpsf.wellknown.PropertyIDMap
        • org.apache.poi.hpsf.wellknown.SectionIDMap
      • java.util.TreeMap<K,V> (implements java.lang.Cloneable, java.util.NavigableMap<K,V>, java.io.Serializable)
        • org.apache.poi.openxml4j.opc.PackagePartCollection
    • org.apache.poi.hssf.model.AbstractShape
      • org.apache.poi.hssf.model.ComboboxShape
      • org.apache.poi.hssf.model.LineShape
      • org.apache.poi.hssf.model.PictureShape
      • org.apache.poi.hssf.model.PolygonShape
      • org.apache.poi.hssf.model.SimpleFilledShape
      • org.apache.poi.hssf.model.TextboxShape
        • org.apache.poi.hssf.model.CommentShape
    • org.apache.poi.hwpf.converter.AbstractWordConverter
      • org.apache.poi.hwpf.converter.WordToFoConverter
      • org.apache.poi.hwpf.converter.WordToHtmlConverter
      • org.apache.poi.hwpf.converter.WordToTextConverter
    • org.apache.poi.hwpf.converter.AbstractWordUtils
      • org.apache.poi.hwpf.converter.WordToFoUtils
      • org.apache.poi.hwpf.converter.WordToHtmlUtils
    • org.apache.poi.xslf.model.geom.AddDivideExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.ss.formula.functions.Address (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.xslf.model.geom.AddSubtractExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.ss.formula.udf.AggregatingUDFFinder (implements org.apache.poi.ss.formula.udf.UDFFinder)
      • org.apache.poi.xssf.model.IndexedUDFFinder
    • org.apache.poi.ss.formula.atp.AnalysisToolPak (implements org.apache.poi.ss.formula.udf.UDFFinder)
    • org.apache.poi.xslf.model.geom.ArcTanExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.ArcToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.ss.formula.eval.AreaEvalBase (implements org.apache.poi.ss.formula.eval.AreaEval)
    • org.apache.poi.ss.formula.ptg.AreaI.OffsetArea (implements org.apache.poi.ss.formula.ptg.AreaI)
    • org.apache.poi.ss.util.AreaReference
      • org.apache.poi.hssf.util.AreaReference
    • org.apache.poi.util.ArrayUtil
    • org.apache.poi.hmef.Attachment
    • org.apache.poi.hsmf.datatypes.AttachmentChunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter (implements java.util.Comparator<T>)
    • org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
    • org.apache.poi.hslf.model.AutoShapes
    • org.apache.poi.poifs.storage.BATBlock
    • org.apache.poi.poifs.storage.BATBlock.BATBlockAndIndex
    • org.apache.poi.hssf.record.crypto.Biff8DecryptingStream (implements org.apache.poi.hssf.record.BiffHeaderInput, org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.hssf.record.crypto.Biff8EncryptionKey
    • org.apache.poi.hssf.dev.BiffViewer
    • org.apache.poi.util.BitField
    • org.apache.poi.util.BitFieldFactory
    • org.apache.poi.hslf.blip.BitmapPainter (implements org.apache.poi.hslf.blip.ImagePainter)
    • org.apache.poi.hwpf.model.types.BKFAbstractType
      • org.apache.poi.hwpf.model.BookmarkFirstDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.ss.formula.eval.BlankEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.poifs.storage.BlockAllocationTableReader
    • org.apache.poi.poifs.storage.BlockAllocationTableWriter (implements org.apache.poi.poifs.filesystem.BATManaged, org.apache.poi.poifs.storage.BlockWritable)
    • org.apache.poi.poifs.filesystem.BlockStore
      • org.apache.poi.poifs.filesystem.NPOIFSFileSystem (implements java.io.Closeable, org.apache.poi.poifs.dev.POIFSViewable)
      • org.apache.poi.poifs.filesystem.NPOIFSMiniStore
    • org.apache.poi.poifs.filesystem.BlockStore.ChainLoopDetector
    • org.apache.poi.hwpf.usermodel.BookmarksImpl (implements org.apache.poi.hwpf.usermodel.Bookmarks)
    • org.apache.poi.hwpf.model.BookmarksTables
    • org.apache.poi.ss.formula.functions.BooleanFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.eval.BoolEval (implements org.apache.poi.ss.formula.eval.NumericValueEval, org.apache.poi.ss.formula.eval.StringValueEval)
    • org.apache.poi.hwpf.usermodel.BorderCode (implements java.lang.Cloneable)
    • org.apache.poi.hssf.record.cf.BorderFormatting
    • org.apache.poi.ss.usermodel.BuiltinFormats
    • org.apache.poi.util.ByteField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.ss.format.CellFormat
    • org.apache.poi.ss.format.CellFormatCondition
    • org.apache.poi.ss.format.CellFormatPart
    • org.apache.poi.ss.format.CellFormatResult
    • org.apache.poi.ss.format.CellFormatter
      • org.apache.poi.ss.format.CellDateFormatter
      • org.apache.poi.ss.format.CellElapsedFormatter
      • org.apache.poi.ss.format.CellGeneralFormatter
      • org.apache.poi.ss.format.CellNumberFormatter
      • org.apache.poi.ss.format.CellTextFormatter
    • org.apache.poi.ss.util.CellRangeAddressBase
      • org.apache.poi.ss.util.CellRangeAddress
        • org.apache.poi.hssf.util.CellRangeAddress
      • org.apache.poi.hssf.util.CellRangeAddress8Bit
    • org.apache.poi.ss.util.CellRangeAddressList
      • org.apache.poi.hssf.util.CellRangeAddressList
    • org.apache.poi.hssf.record.cf.CellRangeUtil
    • org.apache.poi.ss.util.CellReference
      • org.apache.poi.hssf.util.CellReference
    • org.apache.poi.ss.util.CellUtil
    • org.apache.poi.ss.usermodel.CellValue
    • org.apache.poi.ss.util.cellwalk.CellWalk
    • org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator
    • org.apache.poi.hwpf.sprm.CharacterSprmCompressor
    • org.apache.poi.ss.formula.functions.Choose (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.hwpf.model.types.CHPAbstractType
      • org.apache.poi.hwpf.usermodel.CharacterProperties (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.CHPBinTable
      • org.apache.poi.hwpf.model.OldCHPBinTable
    • org.apache.poi.hdgf.chunks.Chunk
    • org.apache.poi.hsmf.datatypes.Chunk
      • org.apache.poi.hsmf.datatypes.ByteChunk
      • org.apache.poi.hsmf.datatypes.DirectoryChunk
      • org.apache.poi.hsmf.datatypes.MessageSubmissionChunk
      • org.apache.poi.hsmf.datatypes.StringChunk
    • org.apache.poi.hdgf.chunks.Chunk.Command
      • org.apache.poi.hdgf.chunks.Chunk.BlockOffsetCommand
    • org.apache.poi.hdgf.chunks.ChunkFactory
    • org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition
    • org.apache.poi.hdgf.chunks.ChunkHeader
      • org.apache.poi.hdgf.chunks.ChunkHeaderV4V5
      • org.apache.poi.hdgf.chunks.ChunkHeaderV6
        • org.apache.poi.hdgf.chunks.ChunkHeaderV11
    • org.apache.poi.hsmf.datatypes.Chunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.hdgf.chunks.ChunkSeparator
    • org.apache.poi.hdgf.chunks.ChunkTrailer
    • org.apache.poi.hpsf.ClassID
    • org.apache.poi.xslf.model.geom.ClosePathCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment
    • org.apache.poi.hwpf.model.Colorref (implements java.lang.Cloneable)
    • org.apache.poi.ss.formula.functions.Column (implements org.apache.poi.ss.formula.functions.Function0Arg, org.apache.poi.ss.formula.functions.Function1Arg)
    • org.apache.poi.xssf.usermodel.helpers.ColumnHelper
    • org.apache.poi.extractor.CommandLineTextExtractor
    • org.apache.poi.hslf.model.Comment
    • org.apache.poi.ss.usermodel.ComparisonOperator
    • org.apache.poi.hwpf.model.ComplexFileTable
    • org.apache.poi.openxml4j.opc.Configuration
    • org.apache.poi.hpsf.Constants
    • org.apache.poi.ss.formula.constant.ConstantValueParser
    • org.apache.poi.openxml4j.opc.internal.ContentType
    • org.apache.poi.openxml4j.opc.internal.ContentTypeManager
      • org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager
    • org.apache.poi.openxml4j.opc.ContentTypes
    • org.apache.poi.xslf.model.geom.Context
    • org.apache.poi.hssf.record.cont.ContinuableRecordInput (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.hssf.record.cont.ContinuableRecordOutput (implements org.apache.poi.util.LittleEndianOutput)
    • org.apache.poi.hssf.model.ConvertAnchor
    • org.apache.poi.xslf.model.geom.CosExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.CosineArcTanExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.ss.formula.functions.Count (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Counta (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.xssf.util.CTColComparator (implements java.util.Comparator<T>)
    • org.apache.poi.hslf.record.CurrentUserAtom
    • org.apache.poi.xslf.model.geom.CurveToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.xslf.model.geom.CustomGeometry (implements java.lang.Iterable<T>)
    • org.apache.poi.ss.usermodel.DataFormatter
      • org.apache.poi.hssf.usermodel.HSSFDataFormatter
    • org.apache.poi.poifs.storage.DataInputBlock
    • org.apache.poi.poifs.nio.DataSource
      • org.apache.poi.poifs.nio.ByteArrayBackedDataSource
      • org.apache.poi.poifs.nio.FileBackedDataSource
    • org.apache.poi.ss.usermodel.charts.DataSources
    • org.apache.poi.ss.usermodel.DataValidation.ErrorStyle
    • org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType
    • org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
    • org.apache.poi.hwpf.usermodel.DateAndTime (implements java.lang.Cloneable)
    • org.apache.poi.ss.util.DateFormatConverter
    • org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer
    • org.apache.poi.ss.formula.atp.DateParser
    • org.apache.poi.ss.usermodel.DateUtil
      • org.apache.poi.hssf.usermodel.HSSFDateUtil
    • org.apache.poi.ss.formula.functions.Days360
    • org.apache.poi.hssf.record.DBCellRecord.Builder
    • org.apache.poi.poifs.crypt.Decryptor
      • org.apache.poi.poifs.crypt.AgileDecryptor
      • org.apache.poi.poifs.crypt.EcmaDecryptor
    • org.apache.poi.ddf.DefaultEscherRecordFactory (implements org.apache.poi.ddf.EscherRecordFactory)
    • org.apache.poi.hwpf.converter.DefaultFontReplacer (implements org.apache.poi.hwpf.converter.FontReplacer)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
      • org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler
    • org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller (implements org.apache.poi.openxml4j.opc.internal.PartMarshaller)
    • org.apache.poi.ss.formula.udf.DefaultUDFFinder (implements org.apache.poi.ss.formula.udf.UDFFinder)
    • org.apache.poi.openxml4j.opc.internal.signature.DigitalSignatureOriginPart
    • org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator (implements java.util.Comparator<T>)
    • org.apache.poi.hslf.record.DocumentAtom.SlideSize
    • org.apache.poi.poifs.storage.DocumentBlock
    • org.apache.poi.poifs.filesystem.DocumentDescriptor
    • org.apache.poi.hwpf.model.types.DOPAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
      • org.apache.poi.hwpf.model.DocumentProperties
    • org.apache.poi.util.DrawingDump
    • org.apache.poi.hssf.model.DrawingManager
    • org.apache.poi.hssf.model.DrawingManager2
    • org.apache.poi.xslf.usermodel.DrawingParagraph
    • org.apache.poi.xslf.usermodel.DrawingTable
    • org.apache.poi.xslf.usermodel.DrawingTableCell
    • org.apache.poi.xslf.usermodel.DrawingTableRow
    • org.apache.poi.xslf.usermodel.DrawingTextBody
      • org.apache.poi.xslf.usermodel.DrawingTextPlaceholder
    • org.apache.poi.hwpf.usermodel.DropCapSpecifier (implements java.lang.Cloneable)
    • org.apache.poi.hssf.usermodel.DVConstraint (implements org.apache.poi.ss.usermodel.DataValidationConstraint)
    • org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair
    • org.apache.poi.hssf.dev.EFBiffViewer
    • org.apache.poi.hslf.EncryptedSlideShow
    • org.apache.poi.poifs.crypt.EncryptionHeader
    • org.apache.poi.poifs.crypt.EncryptionInfo
    • org.apache.poi.poifs.crypt.EncryptionVerifier
    • org.apache.poi.poifs.filesystem.EntryNode (implements org.apache.poi.poifs.filesystem.Entry)
      • org.apache.poi.poifs.filesystem.DirectoryNode (implements org.apache.poi.poifs.filesystem.DirectoryEntry, java.lang.Iterable<T>, org.apache.poi.poifs.dev.POIFSViewable)
      • org.apache.poi.poifs.filesystem.DocumentNode (implements org.apache.poi.poifs.filesystem.DocumentEntry, org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.filesystem.EntryUtils
    • org.apache.poi.ss.formula.constant.ErrorConstant
    • org.apache.poi.ss.usermodel.ErrorConstants
      • org.apache.poi.hssf.usermodel.HSSFErrorConstants
    • org.apache.poi.ss.formula.eval.ErrorEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.ddf.EscherDggRecord.FileIdCluster
    • org.apache.poi.ddf.EscherDump
    • org.apache.poi.ddf.EscherProperties
    • org.apache.poi.ddf.EscherProperty
      • org.apache.poi.ddf.EscherComplexProperty
        • org.apache.poi.ddf.EscherArrayProperty
      • org.apache.poi.ddf.EscherSimpleProperty
        • org.apache.poi.ddf.EscherBoolProperty
        • org.apache.poi.ddf.EscherRGBProperty
        • org.apache.poi.ddf.EscherShapePathProperty
    • org.apache.poi.ddf.EscherPropertyFactory
    • org.apache.poi.ddf.EscherPropertyMetaData
    • org.apache.poi.ddf.EscherRecord
      • org.apache.poi.ddf.AbstractEscherOptRecord
        • org.apache.poi.ddf.EscherOptRecord
        • org.apache.poi.ddf.EscherTertiaryOptRecord
      • org.apache.poi.ddf.EscherBlipRecord
        • org.apache.poi.ddf.EscherBitmapBlip
        • org.apache.poi.ddf.EscherBlipWMFRecord
        • org.apache.poi.ddf.EscherMetafileBlip
        • org.apache.poi.ddf.EscherPictBlip
      • org.apache.poi.ddf.EscherBSERecord
      • org.apache.poi.ddf.EscherChildAnchorRecord
      • org.apache.poi.ddf.EscherClientAnchorRecord
      • org.apache.poi.ddf.EscherClientDataRecord
      • org.apache.poi.ddf.EscherContainerRecord
      • org.apache.poi.ddf.EscherDggRecord
      • org.apache.poi.ddf.EscherDgRecord
      • org.apache.poi.ddf.EscherSpgrRecord
      • org.apache.poi.ddf.EscherSplitMenuColorsRecord
      • org.apache.poi.ddf.EscherSpRecord
      • org.apache.poi.ddf.EscherTextboxRecord
      • org.apache.poi.ddf.UnknownEscherRecord
    • org.apache.poi.hwpf.model.EscherRecordHolder
    • org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName
    • org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet
    • org.apache.poi.hssf.eventmodel.EventRecordFactory
    • org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder
    • org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • org.apache.poi.xslf.model.geom.ExpressionParser
    • org.apache.poi.extractor.ExtractorFactory
    • org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord
    • org.apache.poi.hssf.record.common.FeatFormulaErr2 (implements org.apache.poi.hssf.record.common.SharedFeature)
    • org.apache.poi.hssf.record.common.FeatProtection (implements org.apache.poi.hssf.record.common.SharedFeature)
    • org.apache.poi.hssf.record.common.FeatSmartTag (implements org.apache.poi.hssf.record.common.SharedFeature)
    • org.apache.poi.hwpf.model.Ffn
    • org.apache.poi.hwpf.model.types.FibBaseAbstractType
      • org.apache.poi.hwpf.model.FibBase
    • org.apache.poi.hwpf.model.FIBFieldHandler
    • org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
    • org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
    • org.apache.poi.hwpf.model.types.FibRgW97AbstractType
    • org.apache.poi.hwpf.dev.FieldIterator
    • org.apache.poi.hwpf.usermodel.FieldsImpl (implements org.apache.poi.hwpf.usermodel.Fields)
    • org.apache.poi.hwpf.model.FieldsTables
    • org.apache.poi.openxml4j.opc.internal.FileHelper
    • org.apache.poi.hwpf.model.FileInformationBlock (implements java.lang.Cloneable)
    • org.apache.poi.hslf.model.Fill
    • org.apache.poi.poifs.filesystem.FilteringDirectoryNode (implements org.apache.poi.poifs.filesystem.DirectoryEntry)
    • org.apache.poi.ss.formula.functions.FinanceFunction (implements org.apache.poi.ss.formula.functions.Function3Arg, org.apache.poi.ss.formula.functions.Function4Arg)
    • org.apache.poi.ss.formula.functions.FinanceLib
    • org.apache.poi.ss.formula.functions.Fixed0ArgFunction (implements org.apache.poi.ss.formula.functions.Function0Arg)
      • org.apache.poi.ss.formula.functions.Na
      • org.apache.poi.ss.formula.functions.Now
      • org.apache.poi.ss.formula.functions.Today
    • org.apache.poi.ss.formula.functions.Fixed1ArgFunction (implements org.apache.poi.ss.formula.functions.Function1Arg)
      • org.apache.poi.ss.formula.functions.CalendarFieldFunction
      • org.apache.poi.ss.formula.functions.Columns
      • org.apache.poi.ss.formula.functions.Countblank
      • org.apache.poi.ss.formula.functions.Errortype
      • org.apache.poi.ss.formula.functions.LogicalFunction
      • org.apache.poi.ss.formula.functions.NumericFunction.OneArg
        • org.apache.poi.ss.formula.functions.Even
        • org.apache.poi.ss.formula.functions.Odd
      • org.apache.poi.ss.formula.eval.PercentEval
      • org.apache.poi.ss.formula.functions.Rows
      • org.apache.poi.ss.formula.functions.T
      • org.apache.poi.ss.formula.eval.UnaryMinusEval
      • org.apache.poi.ss.formula.eval.UnaryPlusEval
      • org.apache.poi.ss.formula.functions.Value
    • org.apache.poi.ss.formula.functions.Fixed2ArgFunction (implements org.apache.poi.ss.formula.functions.Function2Arg)
      • org.apache.poi.ss.formula.eval.ConcatEval
      • org.apache.poi.ss.formula.functions.Countif
      • org.apache.poi.ss.formula.eval.IntersectionEval
      • org.apache.poi.ss.formula.functions.NumericFunction.TwoArg
      • org.apache.poi.ss.formula.eval.RangeEval
      • org.apache.poi.ss.formula.eval.RelationalOperationEval
      • org.apache.poi.ss.formula.eval.TwoOperandNumericOperation
      • org.apache.poi.ss.formula.functions.XYNumericFunction
        • org.apache.poi.ss.formula.functions.Sumx2my2
        • org.apache.poi.ss.formula.functions.Sumx2py2
        • org.apache.poi.ss.formula.functions.Sumxmy2
    • org.apache.poi.ss.formula.functions.Fixed3ArgFunction (implements org.apache.poi.ss.formula.functions.Function3Arg)
      • org.apache.poi.ss.formula.functions.DateFunc
      • org.apache.poi.ss.formula.functions.TimeFunc
    • org.apache.poi.ss.formula.functions.Fixed4ArgFunction (implements org.apache.poi.ss.formula.functions.Function4Arg)
      • org.apache.poi.ss.formula.functions.Replace
    • org.apache.poi.hwpf.model.types.FLDAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
      • org.apache.poi.hwpf.model.FieldDescriptor
    • org.apache.poi.hwpf.converter.FoDocumentFacade
    • org.apache.poi.hssf.usermodel.FontDetails
    • org.apache.poi.hssf.record.cf.FontFormatting
    • org.apache.poi.util.FontMetricsDumper
    • org.apache.poi.hwpf.converter.FontReplacer.Triplet
    • org.apache.poi.hwpf.model.FontTable
    • org.apache.poi.ss.formula.eval.forked.ForkedEvaluator
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
          • org.apache.poi.ss.usermodel.ExcelStyleDateFormatter
    • org.apache.poi.hwpf.model.FormattedDiskPage
      • org.apache.poi.hwpf.model.CHPFormattedDiskPage
      • org.apache.poi.hwpf.model.PAPFormattedDiskPage
    • org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • org.apache.poi.ss.formula.Formula
    • org.apache.poi.xslf.model.geom.Formula
      • org.apache.poi.xslf.model.geom.Guide
        • org.apache.poi.xslf.model.geom.AdjustValue
    • org.apache.poi.ss.formula.FormulaParser
    • org.apache.poi.ss.formula.FormulaRenderer
    • org.apache.poi.ss.formula.FormulaShifter
    • org.apache.poi.ss.formula.FormulaType
    • org.apache.poi.hssf.dev.FormulaViewer
    • org.apache.poi.hwpf.model.types.FRDAbstractType
      • org.apache.poi.hwpf.model.FootnoteReferenceDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.FSPAAbstractType
      • org.apache.poi.hwpf.model.FSPA
    • org.apache.poi.hwpf.model.FSPATable
    • org.apache.poi.hssf.record.common.FtrHeader
    • org.apache.poi.ss.formula.eval.FunctionEval
    • org.apache.poi.ss.formula.function.FunctionMetadata
    • org.apache.poi.ss.formula.function.FunctionMetadataRegistry
    • java.awt.Graphics
      • org.apache.poi.hssf.usermodel.EscherGraphics
      • java.awt.Graphics2D
        • org.apache.poi.hssf.usermodel.DummyGraphics2d
        • org.apache.poi.hssf.usermodel.EscherGraphics2d
        • org.apache.poi.hslf.model.PPGraphics2D (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.GrfhicAbstractType
      • org.apache.poi.hwpf.model.Grfhic
    • org.apache.poi.poifs.storage.HeaderBlock (implements org.apache.poi.poifs.storage.HeaderBlockConstants)
    • org.apache.poi.poifs.storage.HeaderBlockWriter (implements org.apache.poi.poifs.storage.BlockWritable, org.apache.poi.poifs.storage.HeaderBlockConstants)
    • org.apache.poi.hssf.usermodel.HeaderFooter (implements org.apache.poi.ss.usermodel.HeaderFooter)
      • org.apache.poi.hssf.usermodel.HSSFFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.hssf.usermodel.HSSFHeader (implements org.apache.poi.ss.usermodel.Header)
    • org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper
    • org.apache.poi.hslf.model.HeadersFooters
    • org.apache.poi.hwpf.usermodel.HeaderStories
    • org.apache.poi.util.HexDump
    • org.apache.poi.util.HexRead
    • org.apache.poi.ss.formula.functions.Hlookup
    • org.apache.poi.hmef.extractor.HMEFContentsExtractor
    • org.apache.poi.hmef.dev.HMEFDumper
    • org.apache.poi.hmef.HMEFMessage
    • org.apache.poi.hpbf.dev.HPBFDumper
    • org.apache.poi.hpbf.model.HPBFPart
      • org.apache.poi.hpbf.model.EscherPart
        • org.apache.poi.hpbf.model.EscherDelayStm
        • org.apache.poi.hpbf.model.EscherStm
      • org.apache.poi.hpbf.model.MainContents
      • org.apache.poi.hpbf.model.QuillContents
    • org.apache.poi.hwpf.model.types.HRESIAbstractType
      • org.apache.poi.hwpf.model.Hyphenation (implements java.lang.Cloneable)
    • org.apache.poi.hsmf.dev.HSMFDump
    • org.apache.poi.hssf.usermodel.HSSFAnchor
      • org.apache.poi.hssf.usermodel.HSSFChildAnchor
      • org.apache.poi.hssf.usermodel.HSSFClientAnchor (implements org.apache.poi.ss.usermodel.ClientAnchor)
    • org.apache.poi.hssf.usermodel.HSSFAutoFilter (implements org.apache.poi.ss.usermodel.AutoFilter)
    • org.apache.poi.hssf.usermodel.HSSFBorderFormatting (implements org.apache.poi.ss.usermodel.BorderFormatting)
    • org.apache.poi.hssf.usermodel.HSSFCell (implements org.apache.poi.ss.usermodel.Cell)
    • org.apache.poi.hssf.usermodel.HSSFCellStyle (implements org.apache.poi.ss.usermodel.CellStyle)
    • org.apache.poi.hssf.util.HSSFCellUtil
    • org.apache.poi.hssf.usermodel.HSSFChart
    • org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries
    • org.apache.poi.hssf.util.HSSFColor (implements org.apache.poi.ss.usermodel.Color)
      • org.apache.poi.hssf.util.HSSFColor.AQUA
      • org.apache.poi.hssf.util.HSSFColor.AUTOMATIC
      • org.apache.poi.hssf.util.HSSFColor.BLACK
      • org.apache.poi.hssf.util.HSSFColor.BLUE
      • org.apache.poi.hssf.util.HSSFColor.BLUE_GREY
      • org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN
      • org.apache.poi.hssf.util.HSSFColor.BROWN
      • org.apache.poi.hssf.util.HSSFColor.CORAL
      • org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE
      • org.apache.poi.hssf.util.HSSFColor.DARK_BLUE
      • org.apache.poi.hssf.util.HSSFColor.DARK_GREEN
      • org.apache.poi.hssf.util.HSSFColor.DARK_RED
      • org.apache.poi.hssf.util.HSSFColor.DARK_TEAL
      • org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW
      • org.apache.poi.hssf.util.HSSFColor.GOLD
      • org.apache.poi.hssf.util.HSSFColor.GREEN
      • org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.INDIGO
      • org.apache.poi.hssf.util.HSSFColor.LAVENDER
      • org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW
      • org.apache.poi.hssf.util.HSSFColor.LIME
      • org.apache.poi.hssf.util.HSSFColor.MAROON
      • org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN
      • org.apache.poi.hssf.util.HSSFColor.ORANGE
      • org.apache.poi.hssf.util.HSSFColor.ORCHID
      • org.apache.poi.hssf.util.HSSFColor.PALE_BLUE
      • org.apache.poi.hssf.util.HSSFColor.PINK
      • org.apache.poi.hssf.util.HSSFColor.PLUM
      • org.apache.poi.hssf.util.HSSFColor.RED
      • org.apache.poi.hssf.util.HSSFColor.ROSE
      • org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE
      • org.apache.poi.hssf.util.HSSFColor.SEA_GREEN
      • org.apache.poi.hssf.util.HSSFColor.SKY_BLUE
      • org.apache.poi.hssf.util.HSSFColor.TAN
      • org.apache.poi.hssf.util.HSSFColor.TEAL
      • org.apache.poi.hssf.util.HSSFColor.TURQUOISE
      • org.apache.poi.hssf.util.HSSFColor.VIOLET
      • org.apache.poi.hssf.util.HSSFColor.WHITE
      • org.apache.poi.hssf.util.HSSFColor.YELLOW
    • org.apache.poi.hssf.usermodel.HSSFConditionalFormatting (implements org.apache.poi.ss.usermodel.ConditionalFormatting)
    • org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule (implements org.apache.poi.ss.usermodel.ConditionalFormattingRule)
    • org.apache.poi.hssf.usermodel.HSSFCreationHelper (implements org.apache.poi.ss.usermodel.CreationHelper)
    • org.apache.poi.hssf.usermodel.HSSFDataFormat (implements org.apache.poi.ss.usermodel.DataFormat)
    • org.apache.poi.hssf.usermodel.HSSFDataValidation (implements org.apache.poi.ss.usermodel.DataValidation)
    • org.apache.poi.hssf.usermodel.HSSFDataValidationHelper (implements org.apache.poi.ss.usermodel.DataValidationHelper)
    • org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook (implements org.apache.poi.ss.formula.EvaluationWorkbook, org.apache.poi.ss.formula.FormulaParsingWorkbook, org.apache.poi.ss.formula.FormulaRenderingWorkbook)
    • org.apache.poi.hssf.eventusermodel.HSSFEventFactory
    • org.apache.poi.hssf.usermodel.HSSFFont (implements org.apache.poi.ss.usermodel.Font)
    • org.apache.poi.hssf.usermodel.HSSFFontFormatting (implements org.apache.poi.ss.usermodel.FontFormatting)
    • org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator (implements org.apache.poi.ss.usermodel.FormulaEvaluator)
    • org.apache.poi.hssf.model.HSSFFormulaParser
    • org.apache.poi.hssf.usermodel.HSSFHyperlink (implements org.apache.poi.ss.usermodel.Hyperlink)
    • org.apache.poi.hssf.usermodel.HSSFName (implements org.apache.poi.ss.usermodel.Name)
    • org.apache.poi.hssf.usermodel.HSSFObjectData
    • org.apache.poi.hssf.usermodel.HSSFOptimiser
    • org.apache.poi.hssf.usermodel.HSSFPalette
    • org.apache.poi.hssf.usermodel.HSSFPatriarch (implements org.apache.poi.ss.usermodel.Drawing, org.apache.poi.hssf.usermodel.HSSFShapeContainer)
    • org.apache.poi.hssf.usermodel.HSSFPatternFormatting (implements org.apache.poi.ss.usermodel.PatternFormatting)
    • org.apache.poi.hssf.usermodel.HSSFPictureData (implements org.apache.poi.ss.usermodel.PictureData)
    • org.apache.poi.hssf.usermodel.HSSFPrintSetup (implements org.apache.poi.ss.usermodel.PrintSetup)
    • org.apache.poi.hssf.util.HSSFRegionUtil
    • org.apache.poi.hssf.eventusermodel.HSSFRequest
    • org.apache.poi.hssf.usermodel.HSSFRichTextString (implements java.lang.Comparable<T>, org.apache.poi.ss.usermodel.RichTextString)
    • org.apache.poi.hssf.usermodel.HSSFRow (implements org.apache.poi.ss.usermodel.Row)
    • org.apache.poi.hssf.usermodel.HSSFShape
      • org.apache.poi.hssf.usermodel.HSSFPolygon
      • org.apache.poi.hssf.usermodel.HSSFShapeGroup (implements org.apache.poi.hssf.usermodel.HSSFShapeContainer)
      • org.apache.poi.hssf.usermodel.HSSFSimpleShape
        • org.apache.poi.hssf.usermodel.HSSFPicture (implements org.apache.poi.ss.usermodel.Picture)
        • org.apache.poi.hssf.usermodel.HSSFTextbox
          • org.apache.poi.hssf.usermodel.HSSFComment (implements org.apache.poi.ss.usermodel.Comment)
    • org.apache.poi.hssf.usermodel.HSSFSheet (implements org.apache.poi.ss.usermodel.Sheet)
    • org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting (implements org.apache.poi.ss.usermodel.SheetConditionalFormatting)
    • org.apache.poi.hwpf.converter.HtmlDocumentFacade
    • org.apache.poi.hwpf.model.io.HWPFFileSystem
    • org.apache.poi.hwpf.usermodel.HWPFList
    • org.apache.poi.hwpf.dev.HWPFLister
    • org.apache.poi.ss.formula.functions.Hyperlink
    • org.apache.poi.hslf.model.Hyperlink
    • org.apache.poi.util.IdentifierManager
    • org.apache.poi.xslf.model.geom.IfElseExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.ss.formula.functions.IfFunc
    • org.apache.poi.hslf.extractor.ImageExtractor
    • org.apache.poi.ss.util.ImageUtils
    • org.apache.poi.ss.formula.functions.Index (implements org.apache.poi.ss.formula.functions.Function2Arg, org.apache.poi.ss.formula.functions.Function3Arg, org.apache.poi.ss.formula.functions.Function4Arg)
    • org.apache.poi.ss.formula.functions.Indirect (implements org.apache.poi.ss.formula.functions.FreeRefFunction)
    • java.io.InputStream (implements java.io.Closeable)
      • org.apache.poi.util.BlockingInputStream
      • org.apache.poi.poifs.filesystem.DocumentInputStream (implements org.apache.poi.util.LittleEndianInput)
        • org.apache.poi.poifs.filesystem.NDocumentInputStream
        • org.apache.poi.poifs.filesystem.ODocumentInputStream
      • org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream
      • java.io.FilterInputStream
        • org.apache.poi.util.CloseIgnoringInputStream
        • org.apache.poi.util.LittleEndianInputStream (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.util.IntegerField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.hssf.model.InternalSheet
    • org.apache.poi.hssf.model.InternalWorkbook
    • org.apache.poi.util.IntList
    • org.apache.poi.util.IntMapper<T>
    • org.apache.poi.util.IOUtils
    • org.apache.poi.ss.formula.functions.Irr (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.hssf.util.LazilyConcatenatedByteArray
    • org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
    • org.apache.poi.hwpf.model.types.LFOAbstractType
    • org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
    • org.apache.poi.hwpf.usermodel.LineSpacingDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.xslf.model.geom.LineToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.hwpf.model.ListData
    • org.apache.poi.hwpf.model.ListFormatOverride
    • org.apache.poi.hwpf.model.ListFormatOverrideLevel
    • org.apache.poi.hwpf.model.ListLevel
    • org.apache.poi.hwpf.model.ListTables
    • org.apache.poi.xslf.model.geom.LiteralValueExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.util.LittleEndian (implements org.apache.poi.util.LittleEndianConsts)
    • org.apache.poi.util.LittleEndianByteArrayInputStream (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.util.LittleEndianByteArrayOutputStream (implements org.apache.poi.util.DelayableLittleEndianOutput, org.apache.poi.util.LittleEndianOutput)
    • org.apache.poi.util.LongField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.ss.formula.functions.Lookup
    • org.apache.poi.hwpf.model.types.LSTFAbstractType
    • org.apache.poi.hwpf.model.types.LVLFAbstractType
    • org.apache.poi.util.LZWDecompresser
      • org.apache.poi.hmef.CompressedRTF
      • org.apache.poi.hdgf.HDGFLZW
    • org.apache.poi.hmef.attribute.MAPIAttribute
      • org.apache.poi.hmef.attribute.MAPIDateAttribute
      • org.apache.poi.hmef.attribute.MAPIRtfAttribute
      • org.apache.poi.hmef.attribute.MAPIStringAttribute
    • org.apache.poi.hsmf.datatypes.MAPIProperty
    • org.apache.poi.ss.formula.functions.Match
    • org.apache.poi.xslf.model.geom.MaxExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.hslf.blip.Metafile.Header
    • org.apache.poi.xslf.model.geom.MinExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.ss.formula.eval.MissingArgEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • org.apache.poi.ss.formula.functions.Mode (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.xslf.model.geom.ModExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.MoveToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.ss.formula.functions.MultiOperandNumericFunction (implements org.apache.poi.ss.formula.functions.Function)
      • org.apache.poi.ss.formula.functions.AggregateFunction
      • org.apache.poi.ss.formula.functions.MinaMaxa
    • org.apache.poi.xslf.model.geom.MultiplyDivideExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.ss.formula.eval.NameEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.hsmf.datatypes.NameIdChunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.ss.formula.eval.NameXEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.hwpf.usermodel.NotesImpl (implements org.apache.poi.hwpf.usermodel.Notes)
    • org.apache.poi.hwpf.model.NotesTables
    • org.apache.poi.ss.formula.functions.NotImplementedFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.poifs.filesystem.NPOIFSDocument (implements org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.filesystem.NPOIFSStream (implements java.lang.Iterable<T>)
    • org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator (implements java.util.Iterator<E>)
    • org.apache.poi.ss.formula.functions.Npv (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.openxml4j.util.Nullable<E>
    • org.apache.poi.ddf.NullEscherSerializationListener (implements org.apache.poi.ddf.EscherSerializationListener)
    • org.apache.poi.ss.util.NumberComparer
    • org.apache.poi.ss.formula.eval.NumberEval (implements org.apache.poi.ss.formula.eval.NumericValueEval, org.apache.poi.ss.formula.eval.StringValueEval)
    • org.apache.poi.hwpf.converter.NumberFormatter
    • org.apache.poi.ss.util.NumberToTextConverter
    • org.apache.poi.ss.formula.functions.NumericFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.xssf.util.NumericRanges
    • org.apache.poi.hslf.usermodel.ObjectData
    • org.apache.poi.hwpf.usermodel.ObjectPoolImpl (implements org.apache.poi.hwpf.usermodel.ObjectsPool)
    • org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl (implements org.apache.poi.hwpf.usermodel.OfficeDrawings)
    • org.apache.poi.ss.formula.functions.Offset (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.poifs.filesystem.Ole10Native
    • org.apache.poi.dev.OOXMLLister
    • org.apache.poi.util.OOXMLLite
    • org.apache.poi.openxml4j.opc.OPCPackage (implements java.io.Closeable, org.apache.poi.openxml4j.opc.RelationshipSource)
      • org.apache.poi.openxml4j.opc.Package
        • org.apache.poi.openxml4j.opc.ZipPackage
    • org.apache.poi.ss.formula.eval.OperandResolver
    • org.apache.poi.ss.formula.OperationEvaluationContext
    • org.apache.poi.xslf.model.geom.Outline
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
        • org.apache.poi.hwpf.model.io.HWPFOutputStream
        • org.apache.poi.hslf.util.MutableByteArrayOutputStream
      • org.apache.poi.poifs.filesystem.DocumentOutputStream
      • java.io.FilterOutputStream
        • org.apache.poi.util.LittleEndianOutputStream (implements org.apache.poi.util.LittleEndianOutput)
      • org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream
    • org.apache.poi.openxml4j.opc.signature.PackageDigitalSignatureManager
    • org.apache.poi.util.PackageHelper
    • org.apache.poi.openxml4j.opc.PackagePart (implements org.apache.poi.openxml4j.opc.RelationshipSource)
      • org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart
      • org.apache.poi.openxml4j.opc.internal.MemoryPackagePart
      • org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature
      • org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart (implements org.apache.poi.openxml4j.opc.PackageProperties)
      • org.apache.poi.openxml4j.opc.ZipPackagePart
    • org.apache.poi.openxml4j.opc.PackagePartName (implements java.lang.Comparable<T>)
    • org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller (implements org.apache.poi.openxml4j.opc.internal.PartMarshaller)
      • org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller
    • org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller (implements org.apache.poi.openxml4j.opc.internal.PartUnmarshaller)
    • org.apache.poi.openxml4j.opc.PackageRelationship
    • org.apache.poi.openxml4j.opc.PackageRelationshipCollection (implements java.lang.Iterable<T>)
    • org.apache.poi.openxml4j.opc.PackagingURIHelper
    • org.apache.poi.hssf.record.PageBreakRecord.Break
    • org.apache.poi.hssf.util.PaneInformation
    • org.apache.poi.hwpf.model.types.PAPAbstractType
      • org.apache.poi.hwpf.usermodel.ParagraphProperties (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.PAPBinTable
      • org.apache.poi.hwpf.model.OldPAPBinTable
    • org.apache.poi.hwpf.model.ParagraphHeight
    • org.apache.poi.hwpf.sprm.ParagraphSprmCompressor
    • org.apache.poi.xslf.model.geom.Path
    • org.apache.poi.hssf.record.cf.PatternFormatting (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.PICFAbstractType
      • org.apache.poi.hwpf.model.PICF
    • org.apache.poi.hwpf.model.PICFAndOfficeArtData
    • org.apache.poi.hwpf.usermodel.Picture
    • org.apache.poi.hslf.usermodel.PictureData
      • org.apache.poi.hslf.blip.Bitmap
        • org.apache.poi.hslf.blip.DIB
        • org.apache.poi.hslf.blip.JPEG
        • org.apache.poi.hslf.blip.PNG
      • org.apache.poi.hslf.blip.Metafile
        • org.apache.poi.hslf.blip.EMF
        • org.apache.poi.hslf.blip.PICT
        • org.apache.poi.hslf.blip.WMF
    • org.apache.poi.hwpf.model.PicturesTable
    • org.apache.poi.hwpf.model.PieceDescriptor
    • org.apache.poi.xslf.model.geom.PinExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.hpbf.dev.PLCDumper
    • org.apache.poi.hwpf.model.PlexOfCps
    • org.apache.poi.hwpf.model.PlexOfField
    • org.apache.poi.POIDocument
      • org.apache.poi.hdgf.HDGFDiagram
      • org.apache.poi.hpbf.HPBFDocument
      • org.apache.poi.hslf.HSLFSlideShow
      • org.apache.poi.hssf.usermodel.HSSFWorkbook (implements org.apache.poi.ss.usermodel.Workbook)
      • org.apache.poi.hwpf.HWPFDocumentCore
        • org.apache.poi.hwpf.HWPFDocument
        • org.apache.poi.hwpf.HWPFOldDocument
      • org.apache.poi.hsmf.MAPIMessage
    • org.apache.poi.poifs.common.POIFSBigBlockSize
    • org.apache.poi.hsmf.parsers.POIFSChunkParser
    • org.apache.poi.poifs.filesystem.POIFSDocument (implements org.apache.poi.poifs.filesystem.BATManaged, org.apache.poi.poifs.storage.BlockWritable, org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.filesystem.POIFSDocumentPath
    • org.apache.poi.poifs.dev.POIFSDump
    • org.apache.poi.poifs.filesystem.POIFSFileSystem (implements org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.dev.POIFSHeaderDumper
    • org.apache.poi.poifs.dev.POIFSLister
    • org.apache.poi.poifs.eventfilesystem.POIFSReader
    • org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent
    • org.apache.poi.poifs.dev.POIFSViewEngine
    • org.apache.poi.poifs.dev.POIFSViewer
    • org.apache.poi.poifs.filesystem.POIFSWriterEvent
    • org.apache.poi.util.POILogFactory
    • org.apache.poi.util.POILogger
      • org.apache.poi.util.CommonsLogger
      • org.apache.poi.util.NullLogger
      • org.apache.poi.util.SystemOutLogger
    • org.apache.poi.hdgf.pointers.Pointer
      • org.apache.poi.hdgf.pointers.PointerV6
    • org.apache.poi.hdgf.pointers.PointerFactory
    • org.apache.poi.POITextExtractor
      • org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor
      • org.apache.poi.POIOLE2TextExtractor
        • org.apache.poi.hssf.extractor.EventBasedExcelExtractor
        • org.apache.poi.hssf.extractor.ExcelExtractor (implements org.apache.poi.ss.extractor.ExcelExtractor)
        • org.apache.poi.hsmf.extractor.OutlookTextExtactor
        • org.apache.poi.hslf.extractor.PowerPointExtractor
        • org.apache.poi.hpbf.extractor.PublisherTextExtractor
        • org.apache.poi.hdgf.extractor.VisioTextExtractor
        • org.apache.poi.hwpf.extractor.Word6Extractor
        • org.apache.poi.hwpf.extractor.WordExtractor
      • org.apache.poi.POIXMLTextExtractor
        • org.apache.poi.POIXMLPropertiesTextExtractor
        • org.apache.poi.xslf.extractor.XSLFPowerPointExtractor
        • org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
        • org.apache.poi.xssf.extractor.XSSFExcelExtractor (implements org.apache.poi.ss.extractor.ExcelExtractor)
        • org.apache.poi.xwpf.extractor.XWPFWordExtractor
    • org.apache.poi.POIXMLDocumentPart
      • org.apache.poi.xssf.model.CalculationChain
      • org.apache.poi.xssf.model.CommentsTable
      • org.apache.poi.xssf.model.MapInfo
      • org.apache.poi.POIXMLDocument
        • org.apache.poi.xslf.usermodel.XMLSlideShow
        • org.apache.poi.xslf.XSLFSlideShow
        • org.apache.poi.xssf.usermodel.XSSFWorkbook (implements java.lang.Iterable<T>, org.apache.poi.ss.usermodel.Workbook)
        • org.apache.poi.xwpf.usermodel.XWPFDocument (implements org.apache.poi.xwpf.usermodel.Document, org.apache.poi.xwpf.usermodel.IBody)
      • org.apache.poi.xssf.model.SharedStringsTable
      • org.apache.poi.xssf.model.SingleXmlCells
      • org.apache.poi.xssf.model.StylesTable
      • org.apache.poi.xssf.model.ThemesTable
      • org.apache.poi.xslf.usermodel.XSLFCommentAuthors
      • org.apache.poi.xslf.usermodel.XSLFComments
      • org.apache.poi.xslf.usermodel.XSLFPictureData
      • org.apache.poi.xslf.usermodel.XSLFSheet (implements org.apache.poi.xslf.usermodel.XSLFShapeContainer)
        • org.apache.poi.xslf.usermodel.XSLFNotes
        • org.apache.poi.xslf.usermodel.XSLFNotesMaster
        • org.apache.poi.xslf.usermodel.XSLFSlide
        • org.apache.poi.xslf.usermodel.XSLFSlideLayout
        • org.apache.poi.xslf.usermodel.XSLFSlideMaster
      • org.apache.poi.xslf.usermodel.XSLFTableStyles (implements java.lang.Iterable<T>)
      • org.apache.poi.xslf.usermodel.XSLFTheme
      • org.apache.poi.xssf.usermodel.XSSFChart (implements org.apache.poi.ss.usermodel.Chart, org.apache.poi.ss.usermodel.charts.ChartAxisFactory)
      • org.apache.poi.xssf.usermodel.XSSFDrawing (implements org.apache.poi.ss.usermodel.Drawing)
      • org.apache.poi.xssf.usermodel.XSSFPictureData (implements org.apache.poi.ss.usermodel.PictureData)
      • org.apache.poi.xssf.usermodel.XSSFSheet (implements org.apache.poi.ss.usermodel.Sheet)
        • org.apache.poi.xssf.usermodel.XSSFChartSheet
        • org.apache.poi.xssf.usermodel.XSSFDialogsheet (implements org.apache.poi.ss.usermodel.Sheet)
      • org.apache.poi.xssf.usermodel.XSSFTable
      • org.apache.poi.xssf.usermodel.XSSFVMLDrawing
      • org.apache.poi.xwpf.usermodel.XWPFFootnotes
      • org.apache.poi.xwpf.usermodel.XWPFHeaderFooter (implements org.apache.poi.xwpf.usermodel.IBody)
        • org.apache.poi.xwpf.usermodel.XWPFFooter
        • org.apache.poi.xwpf.usermodel.XWPFHeader
      • org.apache.poi.xwpf.usermodel.XWPFNumbering
      • org.apache.poi.xwpf.usermodel.XWPFPictureData
      • org.apache.poi.xwpf.usermodel.XWPFSettings
      • org.apache.poi.xwpf.usermodel.XWPFStyles
    • org.apache.poi.POIXMLFactory
      • org.apache.poi.xslf.usermodel.XSLFFactory
      • org.apache.poi.xssf.usermodel.XSSFFactory
      • org.apache.poi.xwpf.usermodel.XWPFFactory
    • org.apache.poi.POIXMLProperties
    • org.apache.poi.POIXMLProperties.CoreProperties
    • org.apache.poi.POIXMLProperties.CustomProperties
    • org.apache.poi.POIXMLProperties.ExtendedProperties
    • org.apache.poi.POIXMLRelation
      • org.apache.poi.xslf.usermodel.XSLFRelation
      • org.apache.poi.xssf.usermodel.XSSFRelation
      • org.apache.poi.xwpf.usermodel.XWPFRelation
    • org.apache.poi.xwpf.usermodel.PositionInParagraph
    • org.apache.poi.hslf.dev.PPDrawingTextListing
    • org.apache.poi.hslf.model.PPFont
    • org.apache.poi.xslf.util.PPTX2PNG
    • org.apache.poi.hslf.dev.PPTXMLDump
    • org.apache.poi.hpsf.Property
      • org.apache.poi.hpsf.MutableProperty
        • org.apache.poi.hpsf.CustomProperty
    • org.apache.poi.poifs.property.Property (implements org.apache.poi.poifs.property.Child, org.apache.poi.poifs.dev.POIFSViewable)
      • org.apache.poi.poifs.property.DirectoryProperty (implements org.apache.poi.poifs.property.Parent)
        • org.apache.poi.poifs.property.RootProperty
      • org.apache.poi.poifs.property.DocumentProperty
    • org.apache.poi.poifs.storage.PropertyBlock
    • org.apache.poi.xslf.model.PropertyFetcher<T>
      • org.apache.poi.xslf.model.ParagraphPropertyFetcher<T>
        • org.apache.poi.xslf.model.CharacterPropertyFetcher<T>
      • org.apache.poi.xslf.model.TextBodyPropertyFetcher<T>
    • org.apache.poi.hwpf.model.PropertyModifier (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.PropertyNode<T> (implements java.lang.Cloneable, java.lang.Comparable<T>)
      • org.apache.poi.hwpf.model.BytePropertyNode<T>
        • org.apache.poi.hwpf.model.CHPX
        • org.apache.poi.hwpf.model.PAPX
      • org.apache.poi.hwpf.model.CachedPropertyNode
      • org.apache.poi.hwpf.model.GenericPropertyNode
      • org.apache.poi.hwpf.model.SEPX
      • org.apache.poi.hwpf.model.TextPiece
        • org.apache.poi.hwpf.model.SinglentonTextPiece
    • org.apache.poi.hwpf.model.PropertyNode.EndComparator (implements java.util.Comparator<T>)
    • org.apache.poi.hwpf.model.PropertyNode.StartComparator (implements java.util.Comparator<T>)
    • org.apache.poi.hpsf.PropertySet
      • org.apache.poi.hpsf.MutablePropertySet
        • org.apache.poi.hpsf.SpecialPropertySet
          • org.apache.poi.hpsf.DocumentSummaryInformation
          • org.apache.poi.hpsf.SummaryInformation
    • org.apache.poi.hpsf.PropertySetFactory
    • org.apache.poi.poifs.property.PropertyTableBase (implements org.apache.poi.poifs.filesystem.BATManaged)
      • org.apache.poi.poifs.property.NPropertyTable
      • org.apache.poi.poifs.property.PropertyTable (implements org.apache.poi.poifs.storage.BlockWritable)
    • org.apache.poi.ss.formula.ptg.Ptg
      • org.apache.poi.ss.formula.ptg.ArrayPtg
      • org.apache.poi.ss.formula.ptg.ControlPtg
        • org.apache.poi.ss.formula.ptg.AttrPtg
        • org.apache.poi.ss.formula.ptg.ExpPtg
        • org.apache.poi.ss.formula.ptg.ParenthesisPtg
        • org.apache.poi.ss.formula.ptg.TblPtg
      • org.apache.poi.ss.formula.ptg.OperandPtg (implements java.lang.Cloneable)
        • org.apache.poi.ss.formula.ptg.AreaErrPtg
        • org.apache.poi.ss.formula.ptg.AreaPtgBase (implements org.apache.poi.ss.formula.ptg.AreaI)
          • org.apache.poi.ss.formula.ptg.Area2DPtgBase
            • org.apache.poi.ss.formula.ptg.AreaNPtg
            • org.apache.poi.ss.formula.ptg.AreaPtg
          • org.apache.poi.ss.formula.ptg.Area3DPtg (implements org.apache.poi.ss.formula.ExternSheetReferenceToken, org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.DeletedArea3DPtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.DeletedRef3DPtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.MemAreaPtg
        • org.apache.poi.ss.formula.ptg.MemErrPtg
        • org.apache.poi.ss.formula.ptg.MemFuncPtg
        • org.apache.poi.ss.formula.ptg.NamePtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.NameXPtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.RefErrorPtg
        • org.apache.poi.ss.formula.ptg.RefPtgBase
          • org.apache.poi.ss.formula.ptg.Ref3DPtg (implements org.apache.poi.ss.formula.ExternSheetReferenceToken, org.apache.poi.ss.formula.WorkbookDependentFormula)
          • org.apache.poi.ss.formula.ptg.RefNPtg
          • org.apache.poi.ss.formula.ptg.RefPtg
      • org.apache.poi.ss.formula.ptg.OperationPtg
        • org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
          • org.apache.poi.ss.formula.ptg.FuncPtg
          • org.apache.poi.ss.formula.ptg.FuncVarPtg
        • org.apache.poi.ss.formula.ptg.IntersectionPtg
        • org.apache.poi.ss.formula.ptg.RangePtg
        • org.apache.poi.ss.formula.ptg.UnionPtg
        • org.apache.poi.ss.formula.ptg.ValueOperatorPtg
          • org.apache.poi.ss.formula.ptg.AddPtg
          • org.apache.poi.ss.formula.ptg.ConcatPtg
          • org.apache.poi.ss.formula.ptg.DividePtg
          • org.apache.poi.ss.formula.ptg.EqualPtg
          • org.apache.poi.ss.formula.ptg.GreaterEqualPtg
          • org.apache.poi.ss.formula.ptg.GreaterThanPtg
          • org.apache.poi.ss.formula.ptg.LessEqualPtg
          • org.apache.poi.ss.formula.ptg.LessThanPtg
          • org.apache.poi.ss.formula.ptg.MultiplyPtg
          • org.apache.poi.ss.formula.ptg.NotEqualPtg
          • org.apache.poi.ss.formula.ptg.PercentPtg
          • org.apache.poi.ss.formula.ptg.PowerPtg
          • org.apache.poi.ss.formula.ptg.SubtractPtg
          • org.apache.poi.ss.formula.ptg.UnaryMinusPtg
          • org.apache.poi.ss.formula.ptg.UnaryPlusPtg
      • org.apache.poi.ss.formula.ptg.ScalarConstantPtg
        • org.apache.poi.ss.formula.ptg.BoolPtg
        • org.apache.poi.ss.formula.ptg.ErrPtg
        • org.apache.poi.ss.formula.ptg.IntPtg
        • org.apache.poi.ss.formula.ptg.MissingArgPtg
        • org.apache.poi.ss.formula.ptg.NumberPtg
        • org.apache.poi.ss.formula.ptg.StringPtg
      • org.apache.poi.ss.formula.ptg.UnknownPtg
    • org.apache.poi.hpbf.model.qcbits.QCBit
      • org.apache.poi.hpbf.model.qcbits.QCPLCBit
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type0
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type4
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type8
      • org.apache.poi.hpbf.model.qcbits.QCTextBit
      • org.apache.poi.hpbf.model.qcbits.UnknownQCBit
    • org.apache.poi.xslf.model.geom.QuadToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor
    • org.apache.poi.hwpf.QuickTest
    • org.apache.poi.hwpf.usermodel.Range
      • org.apache.poi.hwpf.usermodel.CharacterRun (implements java.lang.Cloneable)
      • org.apache.poi.hwpf.usermodel.DocumentPosition
      • org.apache.poi.hwpf.usermodel.Paragraph (implements java.lang.Cloneable)
        • org.apache.poi.hwpf.usermodel.ListEntry
      • org.apache.poi.hwpf.usermodel.Section
      • org.apache.poi.hwpf.usermodel.Table
      • org.apache.poi.hwpf.usermodel.TableCell
      • org.apache.poi.hwpf.usermodel.TableRow
    • org.apache.poi.ss.formula.functions.Rank
    • org.apache.poi.ss.formula.functions.Rate (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.poifs.storage.RawDataBlock (implements org.apache.poi.poifs.storage.ListManagedBlock)
    • org.apache.poi.poifs.storage.RawDataBlockList
    • org.apache.poi.hsmf.datatypes.RecipientChunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter (implements java.util.Comparator<T>)
    • org.apache.poi.hslf.record.Record
      • org.apache.poi.hslf.record.RecordAtom
        • org.apache.poi.hslf.record.AnimationInfoAtom
        • org.apache.poi.hslf.record.ColorSchemeAtom
        • org.apache.poi.hslf.record.Comment2000Atom
        • org.apache.poi.hslf.record.CString
        • org.apache.poi.hslf.record.DocumentAtom
        • org.apache.poi.hslf.record.DocumentEncryptionAtom
        • org.apache.poi.hslf.record.ExControlAtom
        • org.apache.poi.hslf.record.ExEmbedAtom
        • org.apache.poi.hslf.record.ExHyperlinkAtom
        • org.apache.poi.hslf.record.ExMediaAtom
        • org.apache.poi.hslf.record.ExObjListAtom
        • org.apache.poi.hslf.record.ExOleObjAtom
        • org.apache.poi.hslf.record.ExOleObjStg (implements org.apache.poi.hslf.record.PersistRecord, org.apache.poi.hslf.record.PositionDependentRecord)
        • org.apache.poi.hslf.record.FontEntityAtom
        • org.apache.poi.hslf.record.HeadersFootersAtom
        • org.apache.poi.hslf.record.InteractiveInfoAtom
        • org.apache.poi.hslf.record.NotesAtom
        • org.apache.poi.hslf.record.OEPlaceholderAtom
        • org.apache.poi.hslf.record.OEShapeAtom
        • org.apache.poi.hslf.record.OutlineTextRefAtom
        • org.apache.poi.hslf.record.PositionDependentRecordAtom (implements org.apache.poi.hslf.record.PositionDependentRecord)
          • org.apache.poi.hslf.record.PersistPtrHolder
          • org.apache.poi.hslf.record.UserEditAtom
        • org.apache.poi.hslf.record.PPDrawing
        • org.apache.poi.hslf.record.PPDrawingGroup
        • org.apache.poi.hslf.record.RoundTripHFPlaceholder12
        • org.apache.poi.hslf.record.SlideAtom
        • org.apache.poi.hslf.record.SlidePersistAtom
        • org.apache.poi.hslf.record.SoundData
        • org.apache.poi.hslf.record.StyleTextPropAtom
        • org.apache.poi.hslf.record.TextBytesAtom
        • org.apache.poi.hslf.record.TextCharsAtom
        • org.apache.poi.hslf.record.TextHeaderAtom (implements org.apache.poi.hslf.record.ParentAwareRecord)
        • org.apache.poi.hslf.record.TextRulerAtom
        • org.apache.poi.hslf.record.TextSpecInfoAtom
        • org.apache.poi.hslf.record.TxInteractiveInfoAtom
        • org.apache.poi.hslf.record.TxMasterStyleAtom
        • org.apache.poi.hslf.record.UnknownRecordPlaceholder
      • org.apache.poi.hslf.record.RecordContainer
        • org.apache.poi.hslf.record.AnimationInfo
        • org.apache.poi.hslf.record.Comment2000
        • org.apache.poi.hslf.record.DummyRecordWithChildren
        • org.apache.poi.hslf.record.EscherTextboxWrapper
        • org.apache.poi.hslf.record.ExEmbed
          • org.apache.poi.hslf.record.ExControl
        • org.apache.poi.hslf.record.ExHyperlink
        • org.apache.poi.hslf.record.ExMCIMovie
          • org.apache.poi.hslf.record.ExAviMovie
        • org.apache.poi.hslf.record.ExObjList
        • org.apache.poi.hslf.record.ExVideoContainer
        • org.apache.poi.hslf.record.FontCollection
        • org.apache.poi.hslf.record.HeadersFootersContainer
        • org.apache.poi.hslf.record.InteractiveInfo
        • org.apache.poi.hslf.record.PositionDependentRecordContainer (implements org.apache.poi.hslf.record.PositionDependentRecord)
          • org.apache.poi.hslf.record.Document
          • org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren
          • org.apache.poi.hslf.record.Environment
          • org.apache.poi.hslf.record.SheetContainer
            • org.apache.poi.hslf.record.MainMaster
            • org.apache.poi.hslf.record.Notes
            • org.apache.poi.hslf.record.Slide
        • org.apache.poi.hslf.record.SlideListWithText
        • org.apache.poi.hslf.record.Sound
        • org.apache.poi.hslf.record.SoundCollection
    • org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor (implements org.apache.poi.hssf.record.aggregates.RecordAggregate.RecordVisitor)
    • org.apache.poi.hssf.record.RecordBase
      • org.apache.poi.hssf.record.Record
        • org.apache.poi.hssf.record.AbstractEscherHolderRecord
          • org.apache.poi.hssf.record.DrawingGroupRecord
          • org.apache.poi.hssf.record.DrawingRecordForBiffViewer
          • org.apache.poi.hssf.record.EscherAggregate
        • org.apache.poi.hssf.record.cont.ContinuableRecord
          • org.apache.poi.hssf.record.ExtSSTRecord
          • org.apache.poi.hssf.record.NameRecord
          • org.apache.poi.hssf.record.SSTRecord
          • org.apache.poi.hssf.record.StringRecord
          • org.apache.poi.hssf.record.TextObjectRecord
        • org.apache.poi.hssf.record.LabelRecord (implements org.apache.poi.hssf.record.CellValueRecordInterface)
        • org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord
        • org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord
        • org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord
        • org.apache.poi.hssf.record.ObjRecord
        • org.apache.poi.hssf.record.StandardRecord
          • org.apache.poi.hssf.record.chart.AreaFormatRecord
          • org.apache.poi.hssf.record.chart.AreaRecord
          • org.apache.poi.hssf.record.AutoFilterInfoRecord
          • org.apache.poi.hssf.record.chart.AxisLineFormatRecord
          • org.apache.poi.hssf.record.chart.AxisOptionsRecord
          • org.apache.poi.hssf.record.chart.AxisParentRecord
          • org.apache.poi.hssf.record.chart.AxisRecord
          • org.apache.poi.hssf.record.chart.AxisUsedRecord
          • org.apache.poi.hssf.record.BackupRecord
          • org.apache.poi.hssf.record.chart.BarRecord
          • org.apache.poi.hssf.record.chart.BeginRecord
          • org.apache.poi.hssf.record.BlankRecord (implements org.apache.poi.hssf.record.CellValueRecordInterface)
          • org.apache.poi.hssf.record.BOFRecord
          • org.apache.poi.hssf.record.BookBoolRecord
          • org.apache.poi.hssf.record.BottomMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.BoundSheetRecord
          • org.apache.poi.hssf.record.CalcCountRecord
          • org.apache.poi.hssf.record.CalcModeRecord
          • org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
          • org.apache.poi.hssf.record.chart.CatLabRecord
          • org.apache.poi.hssf.record.CellRecord (implements org.apache.poi.hssf.record.CellValueRecordInterface)
            • org.apache.poi.hssf.record.BoolErrRecord
            • org.apache.poi.hssf.record.FormulaRecord
            • org.apache.poi.hssf.record.LabelSSTRecord
            • org.apache.poi.hssf.record.NumberRecord
            • org.apache.poi.hssf.record.RKRecord
          • org.apache.poi.hssf.record.CFHeaderRecord
          • org.apache.poi.hssf.record.CFRuleRecord
          • org.apache.poi.hssf.record.chart.ChartEndBlockRecord
          • org.apache.poi.hssf.record.chart.ChartEndObjectRecord
          • org.apache.poi.hssf.record.chart.ChartFormatRecord
          • org.apache.poi.hssf.record.chart.ChartFRTInfoRecord
          • org.apache.poi.hssf.record.chart.ChartRecord
          • org.apache.poi.hssf.record.chart.ChartStartBlockRecord
          • org.apache.poi.hssf.record.chart.ChartStartObjectRecord
          • org.apache.poi.hssf.record.chart.ChartTitleFormatRecord
          • org.apache.poi.hssf.record.CodepageRecord
          • org.apache.poi.hssf.record.ColumnInfoRecord
          • org.apache.poi.hssf.record.ContinueRecord
          • org.apache.poi.hssf.record.CountryRecord
          • org.apache.poi.hssf.record.CRNCountRecord
          • org.apache.poi.hssf.record.CRNRecord
          • org.apache.poi.hssf.record.chart.DataFormatRecord
          • org.apache.poi.hssf.record.pivottable.DataItemRecord
          • org.apache.poi.hssf.record.chart.DataLabelExtensionRecord
          • org.apache.poi.hssf.record.DateWindow1904Record
          • org.apache.poi.hssf.record.chart.DatRecord
          • org.apache.poi.hssf.record.DBCellRecord
          • org.apache.poi.hssf.record.DConRefRecord
          • org.apache.poi.hssf.record.DefaultColWidthRecord
          • org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord
          • org.apache.poi.hssf.record.DefaultRowHeightRecord
          • org.apache.poi.hssf.record.DeltaRecord
          • org.apache.poi.hssf.record.DimensionsRecord
          • org.apache.poi.hssf.record.DrawingRecord
          • org.apache.poi.hssf.record.DrawingSelectionRecord
          • org.apache.poi.hssf.record.DSFRecord
          • org.apache.poi.hssf.record.DVALRecord
          • org.apache.poi.hssf.record.DVRecord
          • org.apache.poi.hssf.record.chart.EndRecord
          • org.apache.poi.hssf.record.EOFRecord
          • org.apache.poi.hssf.record.ExtendedFormatRecord
          • org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord
          • org.apache.poi.hssf.record.ExternalNameRecord
          • org.apache.poi.hssf.record.ExternSheetRecord
          • org.apache.poi.hssf.record.FeatHdrRecord
          • org.apache.poi.hssf.record.FeatRecord
          • org.apache.poi.hssf.record.FilePassRecord
          • org.apache.poi.hssf.record.FileSharingRecord
          • org.apache.poi.hssf.record.FnGroupCountRecord
          • org.apache.poi.hssf.record.chart.FontBasisRecord
          • org.apache.poi.hssf.record.chart.FontIndexRecord
          • org.apache.poi.hssf.record.FontRecord
          • org.apache.poi.hssf.record.FormatRecord
          • org.apache.poi.hssf.record.chart.FrameRecord
          • org.apache.poi.hssf.record.GridsetRecord
          • org.apache.poi.hssf.record.GutsRecord
          • org.apache.poi.hssf.record.HCenterRecord
          • org.apache.poi.hssf.record.HeaderFooterBase
            • org.apache.poi.hssf.record.FooterRecord
            • org.apache.poi.hssf.record.HeaderRecord
          • org.apache.poi.hssf.record.HeaderFooterRecord
          • org.apache.poi.hssf.record.HideObjRecord
          • org.apache.poi.hssf.record.HyperlinkRecord
          • org.apache.poi.hssf.record.IndexRecord
          • org.apache.poi.hssf.record.InterfaceEndRecord
          • org.apache.poi.hssf.record.InterfaceHdrRecord
          • org.apache.poi.hssf.record.IterationRecord
          • org.apache.poi.hssf.record.LeftMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.chart.LegendRecord
          • org.apache.poi.hssf.record.chart.LineFormatRecord
          • org.apache.poi.hssf.record.chart.LinkedDataRecord
          • org.apache.poi.hssf.record.MergeCellsRecord
          • org.apache.poi.hssf.record.MMSRecord
          • org.apache.poi.hssf.record.MulBlankRecord
          • org.apache.poi.hssf.record.MulRKRecord
          • org.apache.poi.hssf.record.NameCommentRecord
          • org.apache.poi.hssf.record.NoteRecord
          • org.apache.poi.hssf.record.chart.NumberFormatIndexRecord
          • org.apache.poi.hssf.record.chart.ObjectLinkRecord
          • org.apache.poi.hssf.record.ObjectProtectRecord
          • org.apache.poi.hssf.record.PageBreakRecord
            • org.apache.poi.hssf.record.HorizontalPageBreakRecord
            • org.apache.poi.hssf.record.VerticalPageBreakRecord
          • org.apache.poi.hssf.record.pivottable.PageItemRecord
          • org.apache.poi.hssf.record.PaletteRecord
          • org.apache.poi.hssf.record.PaneRecord
          • org.apache.poi.hssf.record.PasswordRecord
          • org.apache.poi.hssf.record.PasswordRev4Record
          • org.apache.poi.hssf.record.chart.PlotAreaRecord
          • org.apache.poi.hssf.record.chart.PlotGrowthRecord
          • org.apache.poi.hssf.record.PrecisionRecord
          • org.apache.poi.hssf.record.PrintGridlinesRecord
          • org.apache.poi.hssf.record.PrintHeadersRecord
          • org.apache.poi.hssf.record.PrintSetupRecord
          • org.apache.poi.hssf.record.ProtectionRev4Record
          • org.apache.poi.hssf.record.ProtectRecord
          • org.apache.poi.hssf.record.RecalcIdRecord
          • org.apache.poi.hssf.record.RefModeRecord
          • org.apache.poi.hssf.record.RefreshAllRecord
          • org.apache.poi.hssf.record.RightMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.RowRecord
          • org.apache.poi.hssf.record.SaveRecalcRecord
          • org.apache.poi.hssf.record.ScenarioProtectRecord
          • org.apache.poi.hssf.record.SCLRecord
          • org.apache.poi.hssf.record.SelectionRecord
          • org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord
          • org.apache.poi.hssf.record.chart.SeriesIndexRecord
          • org.apache.poi.hssf.record.chart.SeriesLabelsRecord
          • org.apache.poi.hssf.record.chart.SeriesListRecord
          • org.apache.poi.hssf.record.chart.SeriesRecord
          • org.apache.poi.hssf.record.chart.SeriesTextRecord
          • org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord
          • org.apache.poi.hssf.record.SharedValueRecordBase
            • org.apache.poi.hssf.record.ArrayRecord
            • org.apache.poi.hssf.record.SharedFormulaRecord
            • org.apache.poi.hssf.record.TableRecord
          • org.apache.poi.hssf.record.chart.SheetPropertiesRecord
          • org.apache.poi.hssf.record.pivottable.StreamIDRecord
          • org.apache.poi.hssf.record.StyleRecord
          • org.apache.poi.hssf.record.SupBookRecord
          • org.apache.poi.hssf.record.TabIdRecord
          • org.apache.poi.hssf.record.TableStylesRecord
          • org.apache.poi.hssf.record.chart.TextRecord
          • org.apache.poi.hssf.record.chart.TickRecord
          • org.apache.poi.hssf.record.TopMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.UncalcedRecord
          • org.apache.poi.hssf.record.chart.UnitsRecord
          • org.apache.poi.hssf.record.UnknownRecord
          • org.apache.poi.hssf.record.UserSViewBegin
          • org.apache.poi.hssf.record.UserSViewEnd
          • org.apache.poi.hssf.record.UseSelFSRecord
          • org.apache.poi.hssf.record.chart.ValueRangeRecord
          • org.apache.poi.hssf.record.VCenterRecord
          • org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord
          • org.apache.poi.hssf.record.pivottable.ViewFieldsRecord
          • org.apache.poi.hssf.record.pivottable.ViewSourceRecord
          • org.apache.poi.hssf.record.WindowOneRecord
          • org.apache.poi.hssf.record.WindowProtectRecord
          • org.apache.poi.hssf.record.WindowTwoRecord
          • org.apache.poi.hssf.record.WriteAccessRecord
          • org.apache.poi.hssf.record.WriteProtectRecord
          • org.apache.poi.hssf.record.WSBoolRecord
      • org.apache.poi.hssf.record.aggregates.RecordAggregate
        • org.apache.poi.hssf.record.aggregates.CFRecordsAggregate
        • org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate
        • org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate
        • org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable
        • org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate
        • org.apache.poi.hssf.record.aggregates.DataValidityTable
        • org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate (implements org.apache.poi.hssf.record.CellValueRecordInterface)
        • org.apache.poi.hssf.record.aggregates.MergedCellsTable
        • org.apache.poi.hssf.record.aggregates.PageSettingsBlock
        • org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
        • org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock
    • org.apache.poi.hssf.record.RecordFactory
    • org.apache.poi.hssf.record.RecordFactoryInputStream
    • org.apache.poi.dev.RecordGenerator
    • org.apache.poi.hssf.record.RecordInputStream (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.hssf.dev.RecordLister
    • org.apache.poi.hssf.model.RecordStream
    • org.apache.poi.hslf.record.RecordTypes
    • org.apache.poi.hslf.record.RecordTypes.Type
    • org.apache.poi.hwpf.dev.RecordUtil
    • org.apache.poi.ss.formula.eval.RefEvalBase (implements org.apache.poi.ss.formula.eval.RefEval)
    • org.apache.poi.ss.util.Region (implements java.lang.Comparable<T>)
      • org.apache.poi.hssf.util.Region
    • org.apache.poi.ss.util.RegionUtil
    • java.awt.RenderingHints.Key
      • org.apache.poi.xslf.usermodel.XSLFRenderingHint
    • org.apache.poi.hwpf.model.RevisionMarkAuthorTable
    • org.apache.poi.hslf.usermodel.RichTextRun
    • org.apache.poi.hssf.util.RKUtil
    • org.apache.poi.ss.usermodel.Row.MissingCellPolicy
    • org.apache.poi.hssf.model.RowBlocksReader
    • org.apache.poi.ss.formula.functions.RowFunc (implements org.apache.poi.ss.formula.functions.Function0Arg, org.apache.poi.ss.formula.functions.Function1Arg)
    • org.apache.poi.hwpf.model.SavedByEntry
    • org.apache.poi.hwpf.model.SavedByTable
    • org.apache.poi.hpsf.Section
      • org.apache.poi.hpsf.MutableSection
    • org.apache.poi.hwpf.model.SectionDescriptor
    • org.apache.poi.hwpf.sprm.SectionSprmCompressor
    • org.apache.poi.hwpf.model.SectionTable
      • org.apache.poi.hwpf.model.OldSectionTable
    • org.apache.poi.hwpf.model.types.SEPAbstractType
      • org.apache.poi.hwpf.usermodel.SectionProperties
    • org.apache.poi.hslf.model.Shape
      • org.apache.poi.hslf.model.Background
      • org.apache.poi.hslf.model.ShapeGroup
        • org.apache.poi.hslf.model.Table
      • org.apache.poi.hslf.model.SimpleShape
        • org.apache.poi.hslf.model.Line
        • org.apache.poi.hslf.model.Picture
          • org.apache.poi.hslf.model.ActiveXShape
          • org.apache.poi.hslf.model.MovieShape
          • org.apache.poi.hslf.model.OLEShape
        • org.apache.poi.hslf.model.TextShape
          • org.apache.poi.hslf.model.AutoShape
            • org.apache.poi.hslf.model.Freeform
            • org.apache.poi.hslf.model.Polygon
          • org.apache.poi.hslf.model.TextBox
            • org.apache.poi.hslf.model.Placeholder
            • org.apache.poi.hslf.model.TableCell
    • org.apache.poi.hwpf.usermodel.Shape
    • org.apache.poi.hslf.model.ShapeFactory
    • org.apache.poi.hslf.model.ShapePainter
    • org.apache.poi.hwpf.model.ShapesTable
    • org.apache.poi.ss.usermodel.ShapeTypes
    • org.apache.poi.hslf.model.ShapeTypes (implements org.apache.poi.sl.usermodel.ShapeTypes)
    • org.apache.poi.ss.formula.SharedFormula
    • org.apache.poi.hssf.record.aggregates.SharedValueManager
    • org.apache.poi.hwpf.model.types.SHD80AbstractType
      • org.apache.poi.hwpf.usermodel.ShadingDescriptor80 (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.SHDAbstractType
      • org.apache.poi.hwpf.usermodel.ShadingDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.hslf.model.Sheet
      • org.apache.poi.hslf.model.MasterSheet
        • org.apache.poi.hslf.model.SlideMaster
        • org.apache.poi.hslf.model.TitleMaster
      • org.apache.poi.hslf.model.Notes
      • org.apache.poi.hslf.model.Slide
    • org.apache.poi.ss.util.SheetBuilder
    • org.apache.poi.xssf.streaming.SheetDataWriter
      • org.apache.poi.xssf.streaming.GZIPSheetDataWriter
    • org.apache.poi.ss.formula.SheetNameFormatter
    • org.apache.poi.ss.util.SheetReferences
    • org.apache.poi.ss.util.SheetUtil
    • org.apache.poi.util.ShortField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.util.ShortList
    • org.apache.poi.xslf.model.geom.SinArcTanExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.SinExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.hslf.dev.SlideAndNotesAtomListing
    • org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
    • org.apache.poi.hslf.dev.SlideIdListing
    • org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet
    • org.apache.poi.hslf.usermodel.SlideShow
    • org.apache.poi.hslf.dev.SlideShowDumper
    • org.apache.poi.hslf.dev.SlideShowRecordDumper
    • org.apache.poi.hslf.dev.SLWTListing
    • org.apache.poi.hslf.dev.SLWTTextListing
    • org.apache.poi.poifs.storage.SmallBlockTableReader
    • org.apache.poi.poifs.storage.SmallBlockTableWriter (implements org.apache.poi.poifs.filesystem.BATManaged, org.apache.poi.poifs.storage.BlockWritable)
    • org.apache.poi.poifs.storage.SmallDocumentBlock (implements org.apache.poi.poifs.storage.BlockWritable, org.apache.poi.poifs.storage.ListManagedBlock)
    • org.apache.poi.poifs.storage.SmallDocumentBlockList
    • org.apache.poi.hslf.usermodel.SoundData
    • org.apache.poi.hwpf.sprm.SprmBuffer (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.sprm.SprmIterator
    • org.apache.poi.hwpf.sprm.SprmOperation
    • org.apache.poi.hwpf.sprm.SprmUncompressor
      • org.apache.poi.hwpf.sprm.CharacterSprmUncompressor
      • org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor
      • org.apache.poi.hwpf.sprm.SectionSprmUncompressor
      • org.apache.poi.hwpf.sprm.TableSprmUncompressor
    • org.apache.poi.hwpf.sprm.SprmUtils
    • org.apache.poi.xslf.model.geom.SqrtExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.ss.util.SSCellRange<K> (implements org.apache.poi.ss.usermodel.CellRange<C>)
    • org.apache.poi.hwpf.model.types.StdfBaseAbstractType
    • org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
    • org.apache.poi.hdgf.streams.Stream
      • org.apache.poi.hdgf.streams.ChunkStream
      • org.apache.poi.hdgf.streams.PointerContainingStream
        • org.apache.poi.hdgf.streams.TrailerStream
      • org.apache.poi.hdgf.streams.StringsStream
      • org.apache.poi.hdgf.streams.UnknownStream
    • org.apache.poi.openxml4j.opc.StreamHelper
    • org.apache.poi.hdgf.streams.StreamStore
      • org.apache.poi.hdgf.streams.CompressedStreamStore
    • org.apache.poi.ss.formula.eval.StringEval (implements org.apache.poi.ss.formula.eval.StringValueEval)
    • org.apache.poi.util.StringUtil
    • org.apache.poi.util.StringUtil.StringsIterator (implements java.util.Iterator<E>)
    • org.apache.poi.hwpf.model.types.StshifAbstractType
    • org.apache.poi.hwpf.model.StyleDescription (implements org.apache.poi.hwpf.model.HDFType)
    • org.apache.poi.hwpf.model.StyleSheet (implements org.apache.poi.hwpf.model.HDFType)
    • org.apache.poi.hssf.record.SubRecord
      • org.apache.poi.hssf.record.CommonObjectDataSubRecord
      • org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord
      • org.apache.poi.hssf.record.EndSubRecord
      • org.apache.poi.hssf.record.FtCblsSubRecord
      • org.apache.poi.hssf.record.GroupMarkerSubRecord
      • org.apache.poi.hssf.record.LbsDataSubRecord
      • org.apache.poi.hssf.record.NoteStructureSubRecord
    • org.apache.poi.ss.formula.functions.Substitute
    • org.apache.poi.ss.formula.functions.Subtotal (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Sumif
    • org.apache.poi.ss.formula.functions.Sumifs (implements org.apache.poi.ss.formula.functions.FreeRefFunction)
    • org.apache.poi.ss.formula.functions.Sumproduct (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.xssf.streaming.SXSSFCell (implements org.apache.poi.ss.usermodel.Cell)
    • org.apache.poi.xssf.streaming.SXSSFRow (implements org.apache.poi.ss.usermodel.Row)
    • org.apache.poi.xssf.streaming.SXSSFRow.CellIterator (implements java.util.Iterator<E>)
    • org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator (implements java.util.Iterator<E>)
    • org.apache.poi.xssf.streaming.SXSSFSheet (implements java.lang.Cloneable, org.apache.poi.ss.usermodel.Sheet)
    • org.apache.poi.xssf.streaming.SXSSFWorkbook (implements org.apache.poi.ss.usermodel.Workbook)
    • org.apache.poi.hslf.util.SystemTimeUtils
    • org.apache.poi.hwpf.usermodel.TableIterator
    • org.apache.poi.hwpf.sprm.TableSprmCompressor
    • org.apache.poi.xslf.model.geom.TanExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.hwpf.model.types.TAPAbstractType
      • org.apache.poi.hwpf.usermodel.TableProperties (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.TBDAbstractType
      • org.apache.poi.hwpf.model.TabDescriptor
    • org.apache.poi.hwpf.model.types.TCAbstractType
      • org.apache.poi.hwpf.usermodel.TableCellDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.util.TempFile
    • org.apache.poi.hwpf.converter.TextDocumentFacade
    • org.apache.poi.ss.formula.functions.TextFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.hslf.model.TextPainter
    • org.apache.poi.hslf.model.TextPainter.TextElement
    • org.apache.poi.hwpf.model.TextPieceTable (implements org.apache.poi.hwpf.model.CharIndexTranslator)
    • org.apache.poi.hslf.model.textproperties.TextProp (implements java.lang.Cloneable)
      • org.apache.poi.hslf.model.textproperties.AlignmentTextProp
      • org.apache.poi.hslf.model.textproperties.BitMaskTextProp (implements java.lang.Cloneable)
        • org.apache.poi.hslf.model.textproperties.CharFlagsTextProp
        • org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp
    • org.apache.poi.hslf.model.textproperties.TextPropCollection
    • org.apache.poi.hslf.model.TextRun
    • org.apache.poi.xwpf.usermodel.TextSegement
    • org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun
    • org.apache.poi.hslf.dev.TextStyleListing
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.hsmf.exceptions.ChunkNotFoundException
        • org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
        • org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException
        • org.apache.poi.ss.formula.eval.EvaluationException
        • org.apache.poi.hpsf.HPSFException
          • org.apache.poi.hpsf.MarkUnsupportedException
          • org.apache.poi.hpsf.NoPropertySetStreamException
          • org.apache.poi.hpsf.UnexpectedPropertySetTypeException
          • org.apache.poi.hpsf.VariantTypeException
            • org.apache.poi.hpsf.IllegalVariantTypeException
            • org.apache.poi.hpsf.UnsupportedVariantTypeException
              • org.apache.poi.hpsf.ReadingNotSupportedException
              • org.apache.poi.hpsf.WritingNotSupportedException
        • org.apache.poi.hssf.eventusermodel.HSSFUserException
        • org.apache.poi.hslf.exceptions.InvalidRecordFormatException
        • java.io.IOException
          • org.apache.poi.util.LittleEndian.BufferUnderrunException
        • org.apache.poi.poifs.filesystem.Ole10NativeException
        • org.apache.poi.openxml4j.exceptions.OpenXML4JException
          • org.apache.poi.openxml4j.exceptions.InvalidFormatException
        • java.lang.RuntimeException
          • org.apache.poi.ss.formula.FormulaParseException
          • org.apache.poi.hdgf.exceptions.HDGFException
          • org.apache.poi.hpsf.HPSFRuntimeException
            • org.apache.poi.hpsf.IllegalPropertySetDataException
            • org.apache.poi.hpsf.MissingSectionException
            • org.apache.poi.hpsf.NoFormatIDException
            • org.apache.poi.hpsf.NoSingleSectionException
          • org.apache.poi.hslf.exceptions.HSLFException
          • java.lang.IllegalArgumentException
            • org.apache.poi.poifs.filesystem.OfficeXmlFileException
            • org.apache.poi.OldFileFormatException
              • org.apache.poi.hssf.OldExcelFormatException
              • org.apache.poi.hslf.exceptions.OldPowerPointFormatException
              • org.apache.poi.hwpf.OldWordFileFormatException
          • java.lang.IllegalStateException
            • org.apache.poi.hslf.exceptions.CorruptPowerPointFileException
            • org.apache.poi.EncryptedDocumentException
              • org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException
          • org.apache.poi.ss.formula.eval.NotImplementedException
          • org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException
            • org.apache.poi.openxml4j.exceptions.InvalidOperationException
              • org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException
          • org.apache.poi.POIXMLException
          • org.apache.poi.util.RecordFormatException
            • org.apache.poi.hssf.record.RecordFormatException
          • org.apache.poi.hssf.record.RecordInputStream.LeftoverDataException
    • org.apache.poi.hpsf.Thumbnail
    • org.apache.poi.hwpf.model.types.TLPAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
      • org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier (implements java.lang.Cloneable)
    • org.apache.poi.hmef.attribute.TNEFAttribute
      • org.apache.poi.hmef.attribute.TNEFDateAttribute
      • org.apache.poi.hmef.attribute.TNEFMAPIAttribute
      • org.apache.poi.hmef.attribute.TNEFStringAttribute
    • org.apache.poi.hmef.attribute.TNEFProperty
    • org.apache.poi.xwpf.usermodel.TOC
    • org.apache.poi.hsmf.datatypes.Types
    • org.apache.poi.hsmf.dev.TypesLister
    • org.apache.poi.hpsf.TypeWriter
    • org.apache.poi.hwpf.model.UnhandledDataStructure
    • org.apache.poi.hssf.record.common.UnicodeString (implements java.lang.Comparable<T>)
      • org.apache.poi.hssf.record.UnicodeString
    • org.apache.poi.hssf.record.common.UnicodeString.ExtRst (implements java.lang.Comparable<T>)
    • org.apache.poi.hssf.record.common.UnicodeString.FormatRun (implements java.lang.Comparable<T>)
    • org.apache.poi.hssf.record.common.UnicodeString.PhRun
    • org.apache.poi.util.Units
    • org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext
    • org.apache.poi.hwpf.model.UPX
    • org.apache.poi.hslf.dev.UserEditAndPersistListing
    • org.apache.poi.hpsf.Util
    • org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate (implements java.lang.Iterable<T>)
    • org.apache.poi.hpsf.Variant
      • org.apache.poi.hpsf.VariantSupport
    • org.apache.poi.ss.formula.functions.Vlookup
    • org.apache.poi.hdgf.dev.VSDDumper
    • org.apache.poi.hslf.blip.WMF.AldusHeader
    • org.apache.poi.ss.formula.WorkbookEvaluator
    • org.apache.poi.ss.usermodel.WorkbookFactory
    • org.apache.poi.hssf.model.WorkbookRecordList (implements java.lang.Iterable<T>)
    • org.apache.poi.ss.util.WorkbookUtil
    • org.apache.poi.ss.formula.atp.WorkdayCalculator
    • org.apache.poi.xwpf.model.XMLParagraph
    • org.apache.poi.xslf.usermodel.XSLFColor
    • org.apache.poi.xslf.usermodel.XSLFCommonSlideData
    • org.apache.poi.xslf.usermodel.XSLFDrawing
    • org.apache.poi.xslf.usermodel.XSLFHyperlink
    • org.apache.poi.xslf.usermodel.XSLFImageRenderer
    • org.apache.poi.xslf.usermodel.XSLFShape
      • org.apache.poi.xslf.usermodel.XSLFGraphicFrame
        • org.apache.poi.xslf.usermodel.XSLFTable (implements java.lang.Iterable<T>)
      • org.apache.poi.xslf.usermodel.XSLFGroupShape (implements org.apache.poi.xslf.usermodel.XSLFShapeContainer)
      • org.apache.poi.xslf.usermodel.XSLFSimpleShape
        • org.apache.poi.xslf.usermodel.XSLFBackground
        • org.apache.poi.xslf.usermodel.XSLFConnectorShape
        • org.apache.poi.xslf.usermodel.XSLFPictureShape
        • org.apache.poi.xslf.usermodel.XSLFShadow
        • org.apache.poi.xslf.usermodel.XSLFTextShape (implements java.lang.Iterable<T>)
          • org.apache.poi.xslf.usermodel.XSLFAutoShape
            • org.apache.poi.xslf.usermodel.XSLFFreeformShape
            • org.apache.poi.xslf.usermodel.XSLFTextBox
          • org.apache.poi.xslf.usermodel.XSLFTableCell
    • org.apache.poi.xslf.usermodel.XSLFTableRow (implements java.lang.Iterable<T>)
    • org.apache.poi.xslf.usermodel.XSLFTableStyle
    • org.apache.poi.xslf.usermodel.XSLFTextParagraph (implements java.lang.Iterable<T>)
    • org.apache.poi.xslf.usermodel.XSLFTextRun
    • org.apache.poi.xssf.usermodel.XSSFAnchor
      • org.apache.poi.xssf.usermodel.XSSFChildAnchor
      • org.apache.poi.xssf.usermodel.XSSFClientAnchor (implements org.apache.poi.ss.usermodel.ClientAnchor)
    • org.apache.poi.xssf.usermodel.XSSFAutoFilter (implements org.apache.poi.ss.usermodel.AutoFilter)
    • org.apache.poi.xssf.usermodel.XSSFBorderFormatting (implements org.apache.poi.ss.usermodel.BorderFormatting)
    • org.apache.poi.xssf.usermodel.XSSFCell (implements org.apache.poi.ss.usermodel.Cell)
    • org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
    • org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
    • org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
    • org.apache.poi.xssf.usermodel.XSSFCellStyle (implements org.apache.poi.ss.usermodel.CellStyle)
    • org.apache.poi.xssf.usermodel.charts.XSSFChartAxis (implements org.apache.poi.ss.usermodel.charts.ChartAxis)
      • org.apache.poi.xssf.usermodel.charts.XSSFValueAxis (implements org.apache.poi.ss.usermodel.charts.ValueAxis)
    • org.apache.poi.xssf.usermodel.charts.XSSFChartDataFactory (implements org.apache.poi.ss.usermodel.charts.ChartDataFactory)
    • org.apache.poi.xssf.usermodel.charts.XSSFChartLegend (implements org.apache.poi.ss.usermodel.charts.ChartLegend)
    • org.apache.poi.xssf.usermodel.XSSFColor (implements org.apache.poi.ss.usermodel.Color)
    • org.apache.poi.xssf.usermodel.XSSFComment (implements org.apache.poi.ss.usermodel.Comment)
    • org.apache.poi.xssf.usermodel.XSSFConditionalFormatting (implements org.apache.poi.ss.usermodel.ConditionalFormatting)
    • org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule (implements org.apache.poi.ss.usermodel.ConditionalFormattingRule)
    • org.apache.poi.xssf.usermodel.XSSFCreationHelper (implements org.apache.poi.ss.usermodel.CreationHelper)
    • org.apache.poi.xssf.usermodel.XSSFDataFormat (implements org.apache.poi.ss.usermodel.DataFormat)
    • org.apache.poi.xssf.usermodel.XSSFDataValidation (implements org.apache.poi.ss.usermodel.DataValidation)
    • org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint (implements org.apache.poi.ss.usermodel.DataValidationConstraint)
    • org.apache.poi.xssf.usermodel.XSSFDataValidationHelper (implements org.apache.poi.ss.usermodel.DataValidationHelper)
    • org.apache.poi.xssf.dev.XSSFDump
    • org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook (implements org.apache.poi.ss.formula.EvaluationWorkbook, org.apache.poi.ss.formula.FormulaParsingWorkbook, org.apache.poi.ss.formula.FormulaRenderingWorkbook)
    • org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor (implements org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler)
    • org.apache.poi.xssf.extractor.XSSFExportToXml (implements java.util.Comparator<T>)
    • org.apache.poi.xssf.usermodel.XSSFFont (implements org.apache.poi.ss.usermodel.Font)
    • org.apache.poi.xssf.usermodel.XSSFFontFormatting (implements org.apache.poi.ss.usermodel.FontFormatting)
    • org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator (implements org.apache.poi.ss.usermodel.FormulaEvaluator)
    • org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils
    • org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter (implements org.apache.poi.ss.usermodel.HeaderFooter)
      • org.apache.poi.xssf.usermodel.XSSFEvenFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.xssf.usermodel.XSSFEvenHeader (implements org.apache.poi.ss.usermodel.Header)
      • org.apache.poi.xssf.usermodel.XSSFFirstFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.xssf.usermodel.XSSFFirstHeader (implements org.apache.poi.ss.usermodel.Header)
      • org.apache.poi.xssf.usermodel.XSSFOddFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.xssf.usermodel.XSSFOddHeader (implements org.apache.poi.ss.usermodel.Header)
    • org.apache.poi.xssf.usermodel.XSSFHyperlink (implements org.apache.poi.ss.usermodel.Hyperlink)
    • org.apache.poi.xssf.extractor.XSSFImportFromXML
    • org.apache.poi.xssf.usermodel.charts.XSSFManualLayout (implements org.apache.poi.ss.usermodel.charts.ManualLayout)
    • org.apache.poi.xssf.usermodel.XSSFMap
    • org.apache.poi.xssf.usermodel.XSSFName (implements org.apache.poi.ss.usermodel.Name)
    • org.apache.poi.xssf.usermodel.XSSFPatternFormatting (implements org.apache.poi.ss.usermodel.PatternFormatting)
    • org.apache.poi.xssf.usermodel.XSSFPrintSetup (implements org.apache.poi.ss.usermodel.PrintSetup)
    • org.apache.poi.xssf.eventusermodel.XSSFReader
    • org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator (implements java.util.Iterator<E>)
    • org.apache.poi.xssf.usermodel.XSSFRichTextString (implements org.apache.poi.ss.usermodel.RichTextString)
    • org.apache.poi.xssf.usermodel.XSSFRow (implements java.lang.Comparable<T>, org.apache.poi.ss.usermodel.Row)
    • org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter
    • org.apache.poi.xssf.dev.XSSFSave
    • org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData (implements org.apache.poi.ss.usermodel.charts.ScatterChartData)
    • org.apache.poi.xssf.usermodel.XSSFShape
      • org.apache.poi.xssf.usermodel.XSSFConnector
      • org.apache.poi.xssf.usermodel.XSSFGraphicFrame
      • org.apache.poi.xssf.usermodel.XSSFPicture (implements org.apache.poi.ss.usermodel.Picture)
      • org.apache.poi.xssf.usermodel.XSSFShapeGroup
      • org.apache.poi.xssf.usermodel.XSSFSimpleShape
        • org.apache.poi.xssf.usermodel.XSSFTextBox
    • org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting (implements org.apache.poi.ss.usermodel.SheetConditionalFormatting)
    • org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell
    • org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr
    • org.apache.poi.xwpf.usermodel.XWPFAbstractNum
    • org.apache.poi.xwpf.usermodel.XWPFComment
    • org.apache.poi.xwpf.usermodel.XWPFFootnote (implements org.apache.poi.xwpf.usermodel.IBody, java.lang.Iterable<T>)
    • org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
    • org.apache.poi.xwpf.usermodel.XWPFHyperlink
    • org.apache.poi.xwpf.usermodel.XWPFLatentStyles
    • org.apache.poi.xwpf.usermodel.XWPFNum
    • org.apache.poi.xwpf.usermodel.XWPFParagraph (implements org.apache.poi.xwpf.usermodel.IBodyElement)
    • org.apache.poi.xwpf.model.XWPFParagraphDecorator
      • org.apache.poi.xwpf.model.XWPFCommentsDecorator
      • org.apache.poi.xwpf.model.XWPFHyperlinkDecorator
    • org.apache.poi.xwpf.usermodel.XWPFPicture
    • org.apache.poi.xwpf.usermodel.XWPFRun
      • org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun
    • org.apache.poi.xwpf.usermodel.XWPFStyle
    • org.apache.poi.xwpf.usermodel.XWPFTable (implements org.apache.poi.xwpf.usermodel.IBodyElement)
    • org.apache.poi.xwpf.usermodel.XWPFTableCell (implements org.apache.poi.xwpf.usermodel.IBody)
    • org.apache.poi.xwpf.usermodel.XWPFTableRow
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
      • org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry
    • org.apache.poi.openxml4j.util.ZipFileZipEntrySource (implements org.apache.poi.openxml4j.util.ZipEntrySource)
    • org.apache.poi.openxml4j.opc.internal.ZipHelper
    • org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource (implements org.apache.poi.openxml4j.util.ZipEntrySource)
    • org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller (implements org.apache.poi.openxml4j.opc.internal.PartMarshaller)

Interface Hierarchy

  • org.apache.poi.ss.formula.ptg.AreaI
  • org.apache.poi.ss.usermodel.AutoFilter
  • org.apache.poi.poifs.filesystem.BATManaged
  • org.apache.poi.hssf.record.BiffHeaderInput
  • org.apache.poi.poifs.storage.BlockList
  • org.apache.poi.poifs.storage.BlockWritable
  • org.apache.poi.hwpf.usermodel.Bookmark
  • org.apache.poi.hwpf.usermodel.Bookmarks
  • org.apache.poi.ss.usermodel.BorderFormatting
  • org.apache.poi.ss.usermodel.Cell
  • org.apache.poi.ss.util.cellwalk.CellHandler
  • org.apache.poi.ss.usermodel.CellStyle
  • org.apache.poi.hssf.record.CellValueRecordInterface
  • org.apache.poi.ss.util.cellwalk.CellWalkContext
  • org.apache.poi.hwpf.model.CharIndexTranslator
  • org.apache.poi.ss.usermodel.charts.ChartAxis
    • org.apache.poi.ss.usermodel.charts.ValueAxis
  • org.apache.poi.ss.usermodel.charts.ChartAxisFactory
  • org.apache.poi.ss.usermodel.charts.ChartData
    • org.apache.poi.ss.usermodel.charts.ScatterChartData
  • org.apache.poi.ss.usermodel.charts.ChartDataFactory
  • org.apache.poi.ss.usermodel.charts.ChartDataSource<T>
  • org.apache.poi.poifs.property.Child
    • org.apache.poi.poifs.property.Parent
  • org.apache.poi.hsmf.datatypes.ChunkGroup
  • org.apache.poi.ss.usermodel.ClientAnchor
  • org.apache.poi.ss.usermodel.Color
  • org.apache.poi.ss.usermodel.Comment
  • org.apache.poi.ss.usermodel.ConditionalFormatting
  • org.apache.poi.ss.usermodel.ConditionalFormattingRule
  • org.apache.poi.ss.usermodel.CreationHelper
  • org.apache.poi.ss.usermodel.DataFormat
  • org.apache.poi.ss.usermodel.DataValidation
  • org.apache.poi.ss.usermodel.DataValidationConstraint
  • org.apache.poi.ss.usermodel.DataValidationHelper
  • org.apache.poi.xwpf.usermodel.Document
  • org.apache.poi.ss.usermodel.Drawing
  • org.apache.poi.poifs.filesystem.Entry
    • org.apache.poi.poifs.filesystem.DirectoryEntry (also extends java.lang.Iterable<T>)
    • org.apache.poi.poifs.filesystem.DocumentEntry
  • org.apache.poi.hssf.eventmodel.ERFListener
  • org.apache.poi.ddf.EscherRecordFactory
  • org.apache.poi.ddf.EscherSerializationListener
  • org.apache.poi.ss.formula.EvaluationCell
  • org.apache.poi.ss.formula.EvaluationName
  • org.apache.poi.ss.formula.EvaluationSheet
  • org.apache.poi.ss.formula.EvaluationWorkbook
  • org.apache.poi.ss.extractor.ExcelExtractor
  • org.apache.poi.xslf.model.geom.Expression
  • org.apache.poi.ss.formula.ExternSheetReferenceToken
  • org.apache.poi.hwpf.usermodel.Field
  • org.apache.poi.hwpf.usermodel.Fields
  • org.apache.poi.common.usermodel.Fill
    • org.apache.poi.sl.usermodel.Fill
  • org.apache.poi.util.FixedField
  • org.apache.poi.ss.usermodel.Font
  • org.apache.poi.sl.usermodel.FontCollection
  • org.apache.poi.ss.usermodel.FontFormatting
  • org.apache.poi.hwpf.converter.FontReplacer
  • org.apache.poi.ss.usermodel.FormulaEvaluator
  • org.apache.poi.ss.formula.FormulaParsingWorkbook
  • org.apache.poi.ss.formula.FormulaRenderingWorkbook
  • org.apache.poi.ss.formula.functions.FreeRefFunction
  • org.apache.poi.ss.formula.functions.Function
    • org.apache.poi.ss.formula.functions.Function0Arg
    • org.apache.poi.ss.formula.functions.Function1Arg
    • org.apache.poi.ss.formula.functions.Function2Arg
    • org.apache.poi.ss.formula.functions.Function3Arg
    • org.apache.poi.ss.formula.functions.Function4Arg
  • org.apache.poi.hwpf.model.HDFType
  • org.apache.poi.poifs.storage.HeaderBlockConstants
  • org.apache.poi.ss.usermodel.HeaderFooter
    • org.apache.poi.ss.usermodel.Footer
    • org.apache.poi.ss.usermodel.Header
  • org.apache.poi.hssf.eventusermodel.HSSFListener
  • org.apache.poi.hssf.usermodel.HSSFShapeContainer
  • org.apache.poi.common.usermodel.Hyperlink
    • org.apache.poi.ss.usermodel.Hyperlink
    • org.apache.poi.sl.usermodel.Hyperlink
  • org.apache.poi.xslf.model.geom.IAdjustableShape
  • org.apache.poi.xwpf.usermodel.IBody
  • org.apache.poi.xwpf.usermodel.IBodyElement
  • org.apache.poi.hslf.blip.ImagePainter
  • org.apache.poi.ss.formula.IStabilityClassifier
  • java.lang.Iterable<T>
    • org.apache.poi.ss.usermodel.CellRange<C>
    • org.apache.poi.poifs.filesystem.DirectoryEntry (also extends org.apache.poi.poifs.filesystem.Entry)
    • org.apache.poi.ss.usermodel.Row
    • org.apache.poi.ss.usermodel.Sheet
    • org.apache.poi.xslf.usermodel.XSLFShapeContainer
  • org.apache.poi.common.usermodel.LineStyle
    • org.apache.poi.sl.usermodel.LineStyle
  • org.apache.poi.poifs.storage.ListManagedBlock
  • org.apache.poi.util.LittleEndianConsts
  • org.apache.poi.util.LittleEndianInput
  • org.apache.poi.util.LittleEndianOutput
    • org.apache.poi.util.DelayableLittleEndianOutput
  • org.apache.poi.ss.usermodel.charts.ManualLayout
  • org.apache.poi.ss.usermodel.charts.ManuallyPositionable
    • org.apache.poi.ss.usermodel.Chart
    • org.apache.poi.ss.usermodel.charts.ChartLegend
  • org.apache.poi.hssf.record.Margin
  • org.apache.poi.ss.usermodel.Name
  • org.apache.poi.hwpf.usermodel.Notes
  • org.apache.poi.hwpf.usermodel.ObjectsPool
  • org.apache.poi.hwpf.usermodel.OfficeDrawing
  • org.apache.poi.hwpf.usermodel.OfficeDrawings
  • org.apache.poi.openxml4j.opc.PackageNamespaces
  • org.apache.poi.openxml4j.opc.PackageProperties
  • org.apache.poi.openxml4j.opc.PackageRelationshipTypes
  • org.apache.poi.hslf.record.ParentAwareRecord
  • org.apache.poi.openxml4j.opc.internal.PartMarshaller
  • org.apache.poi.openxml4j.opc.internal.PartUnmarshaller
  • org.apache.poi.xslf.model.geom.PathCommand
  • org.apache.poi.ss.usermodel.PatternFormatting
  • org.apache.poi.hslf.record.PersistRecord
  • org.apache.poi.ss.usermodel.Picture
  • org.apache.poi.ss.usermodel.PictureData
  • org.apache.poi.sl.usermodel.PictureData
  • org.apache.poi.hwpf.converter.PicturesManager
  • org.apache.poi.poifs.common.POIFSConstants
  • org.apache.poi.poifs.eventfilesystem.POIFSReaderListener
  • org.apache.poi.poifs.dev.POIFSViewable
  • org.apache.poi.poifs.filesystem.POIFSWriterListener
  • org.apache.poi.hslf.record.PositionDependentRecord
  • org.apache.poi.ss.usermodel.PrintSetup
  • org.apache.poi.poifs.property.PropertyConstants
  • org.apache.poi.hssf.record.aggregates.RecordAggregate.RecordVisitor
  • org.apache.poi.openxml4j.opc.RelationshipSource
  • org.apache.poi.sl.usermodel.Resources
  • org.apache.poi.ss.usermodel.RichTextString
  • org.apache.poi.ss.usermodel.charts.ScatterChartSerie
  • org.apache.poi.sl.usermodel.Shape
    • org.apache.poi.sl.usermodel.AutoShape
      • org.apache.poi.sl.usermodel.Line
      • org.apache.poi.sl.usermodel.TextBox
    • org.apache.poi.sl.usermodel.Background
    • org.apache.poi.sl.usermodel.Line
    • org.apache.poi.sl.usermodel.Picture
    • org.apache.poi.sl.usermodel.SimpleShape
      • org.apache.poi.sl.usermodel.AutoShape
        • org.apache.poi.sl.usermodel.Line
        • org.apache.poi.sl.usermodel.TextBox
      • org.apache.poi.sl.usermodel.Line
      • org.apache.poi.sl.usermodel.Picture
      • org.apache.poi.sl.usermodel.TextBox
    • org.apache.poi.sl.usermodel.TextBox
  • org.apache.poi.sl.usermodel.ShapeContainer
    • org.apache.poi.sl.usermodel.MasterSheet
    • org.apache.poi.sl.usermodel.Notes
    • org.apache.poi.sl.usermodel.ShapeGroup
    • org.apache.poi.sl.usermodel.Sheet
      • org.apache.poi.sl.usermodel.MasterSheet
      • org.apache.poi.sl.usermodel.Notes
      • org.apache.poi.sl.usermodel.Slide
    • org.apache.poi.sl.usermodel.Slide
  • org.apache.poi.hslf.model.ShapeOutline
  • org.apache.poi.sl.usermodel.ShapeTypes
  • org.apache.poi.hssf.record.common.SharedFeature
  • org.apache.poi.ss.usermodel.SheetConditionalFormatting
  • org.apache.poi.sl.usermodel.SlideShow
  • org.apache.poi.ss.usermodel.Textbox
  • org.apache.poi.sl.usermodel.TextRun
  • org.apache.poi.ss.formula.udf.UDFFinder
  • org.apache.poi.ss.formula.eval.ValueEval
    • org.apache.poi.ss.formula.eval.AreaEval
    • org.apache.poi.ss.formula.eval.NumericValueEval
    • org.apache.poi.ss.formula.eval.RefEval
    • org.apache.poi.ss.formula.eval.StringValueEval
    • org.apache.poi.ss.formula.TwoDEval
      • org.apache.poi.ss.formula.eval.AreaEval
  • org.apache.poi.ss.usermodel.Workbook
  • org.apache.poi.ss.formula.WorkbookDependentFormula
  • org.apache.poi.xslf.usermodel.XSLFFontManager
  • org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler
  • org.apache.poi.ss.formula.functions.XYNumericFunction.Accumulator
  • org.apache.poi.openxml4j.util.ZipEntrySource

Annotation Type Hierarchy

  • org.apache.poi.util.Internal (implements java.lang.annotation.Annotation)
  • org.apache.poi.util.Beta (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType
      • org.apache.poi.ss.SpreadsheetVersion
      • org.apache.poi.ss.format.CellFormatType
      • org.apache.poi.ss.usermodel.VerticalAlignment
      • org.apache.poi.ss.usermodel.PrintOrientation
      • org.apache.poi.ss.usermodel.PrintCellComments
      • org.apache.poi.ss.usermodel.PaperSize
      • org.apache.poi.ss.usermodel.PageOrder
      • org.apache.poi.ss.usermodel.IndexedColors
      • org.apache.poi.ss.usermodel.HorizontalAlignment
      • org.apache.poi.ss.usermodel.FormulaError
      • org.apache.poi.ss.usermodel.FontUnderline
      • org.apache.poi.ss.usermodel.FontScheme
      • org.apache.poi.ss.usermodel.FontFamily
      • org.apache.poi.ss.usermodel.FontCharset
      • org.apache.poi.ss.usermodel.FillPatternType
      • org.apache.poi.ss.usermodel.BorderStyle
      • org.apache.poi.ss.usermodel.charts.LegendPosition
      • org.apache.poi.ss.usermodel.charts.LayoutTarget
      • org.apache.poi.ss.usermodel.charts.LayoutMode
      • org.apache.poi.ss.usermodel.charts.AxisPosition
      • org.apache.poi.ss.usermodel.charts.AxisOrientation
      • org.apache.poi.ss.usermodel.charts.AxisCrosses
      • org.apache.poi.ss.usermodel.charts.AxisCrossBetween
      • org.apache.poi.ss.util.CellReference.NameType
      • org.apache.poi.hwpf.model.SubdocumentType
      • org.apache.poi.hwpf.model.NoteType
      • org.apache.poi.hwpf.model.FSPADocumentPart
      • org.apache.poi.hwpf.model.FieldsDocumentPart
      • org.apache.poi.hwpf.usermodel.PictureType
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalPositioning
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalRelativeElement
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalPositioning
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalRelativeElement
      • org.apache.poi.openxml4j.opc.TargetMode
      • org.apache.poi.openxml4j.opc.PackageAccess
      • org.apache.poi.openxml4j.opc.EncryptionOption
      • org.apache.poi.openxml4j.opc.CompressionOption
      • org.apache.poi.openxml4j.opc.CertificateEmbeddingOption
      • org.apache.poi.xslf.usermodel.XSLFShapeType
      • org.apache.poi.xslf.usermodel.VerticalAlignment
      • org.apache.poi.xslf.usermodel.TextDirection
      • org.apache.poi.xslf.usermodel.TextCap
      • org.apache.poi.xslf.usermodel.TextAutofit
      • org.apache.poi.xslf.usermodel.TextAlign
      • org.apache.poi.xslf.usermodel.SlideLayout
      • org.apache.poi.xslf.usermodel.Placeholder
      • org.apache.poi.xslf.usermodel.ListAutoNumber
      • org.apache.poi.xslf.usermodel.LineEndWidth
      • org.apache.poi.xslf.usermodel.LineEndLength
      • org.apache.poi.xslf.usermodel.LineDecoration
      • org.apache.poi.xslf.usermodel.LineDash
      • org.apache.poi.xslf.usermodel.LineCap
      • org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder.BorderSide
      • org.apache.poi.xwpf.usermodel.XWPFTableCell.XWPFVertAlign
      • org.apache.poi.xwpf.usermodel.XWPFTable.XWPFBorderType
      • org.apache.poi.xwpf.usermodel.VerticalAlign
      • org.apache.poi.xwpf.usermodel.UnderlinePatterns
      • org.apache.poi.xwpf.usermodel.TextAlignment
      • org.apache.poi.xwpf.usermodel.ParagraphAlignment
      • org.apache.poi.xwpf.usermodel.LineSpacingRule
      • org.apache.poi.xwpf.usermodel.BreakType
      • org.apache.poi.xwpf.usermodel.BreakClear
      • org.apache.poi.xwpf.usermodel.Borders
      • org.apache.poi.xwpf.usermodel.BodyType
      • org.apache.poi.xwpf.usermodel.BodyElementType
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Serialized Form

Package org.apache.poi

Class org.apache.poi.EncryptedDocumentException extends java.lang.IllegalStateException implements Serializable

Class org.apache.poi.OldFileFormatException extends java.lang.IllegalArgumentException implements Serializable

Class org.apache.poi.POIXMLException extends java.lang.RuntimeException implements Serializable

Package org.apache.poi.hdgf.exceptions

Class org.apache.poi.hdgf.exceptions.HDGFException extends java.lang.RuntimeException implements Serializable

Package org.apache.poi.hpsf

Class org.apache.poi.hpsf.CustomProperties extends java.util.HashMap<java.lang.Object,CustomProperty> implements Serializable

Serialized Fields

dictionaryIDToName

java.util.Map<K,V> dictionaryIDToName

Maps property IDs to property names.

dictionaryNameToID

java.util.Map<K,V> dictionaryNameToID

Maps property names to property IDs.

isPure

boolean isPure

Tells whether this object is pure or not.

Class org.apache.poi.hpsf.HPSFException extends java.lang.Exception implements Serializable

Serialized Fields

reason

java.lang.Throwable reason

The underlying reason for this exception - may be null.

Class org.apache.poi.hpsf.HPSFRuntimeException extends java.lang.RuntimeException implements Serializable

Serialized Fields

reason

java.lang.Throwable reason

The underlying reason for this exception - may be null.

Class org.apache.poi.hpsf.IllegalPropertySetDataException extends HPSFRuntimeException implements Serializable

Class org.apache.poi.hpsf.IllegalVariantTypeException extends VariantTypeException implements Serializable

Class org.apache.poi.hpsf.MarkUnsupportedException extends HPSFException implements Serializable

Class org.apache.poi.hpsf.MissingSectionException extends HPSFRuntimeException implements Serializable

Class org.apache.poi.hpsf.NoFormatIDException extends HPSFRuntimeException implements Serializable

Class org.apache.poi.hpsf.NoPropertySetStreamException extends HPSFException implements Serializable

Class org.apache.poi.hpsf.NoSingleSectionException extends HPSFRuntimeException implements Serializable

Class org.apache.poi.hpsf.ReadingNotSupportedException extends UnsupportedVariantTypeException implements Serializable

Class org.apache.poi.hpsf.UnexpectedPropertySetTypeException extends HPSFException implements Serializable

Class org.apache.poi.hpsf.UnsupportedVariantTypeException extends VariantTypeException implements Serializable

Class org.apache.poi.hpsf.VariantTypeException extends HPSFException implements Serializable

Serialized Fields

value

java.lang.Object value

variantType

long variantType

Class org.apache.poi.hpsf.WritingNotSupportedException extends UnsupportedVariantTypeException implements Serializable

Package org.apache.poi.hpsf.wellknown

Class org.apache.poi.hpsf.wellknown.PropertyIDMap extends java.util.HashMap implements Serializable

Class org.apache.poi.hpsf.wellknown.SectionIDMap extends java.util.HashMap implements Serializable

Package org.apache.poi.hslf.exceptions

Class org.apache.poi.hslf.exceptions.CorruptPowerPointFileException extends java.lang.IllegalStateException implements Serializable

Class org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException extends EncryptedDocumentException implements Serializable

Class org.apache.poi.hslf.exceptions.HSLFException extends java.lang.RuntimeException implements Serializable

Class org.apache.poi.hslf.exceptions.InvalidRecordFormatException extends java.lang.Exception implements Serializable

Class org.apache.poi.hslf.exceptions.OldPowerPointFormatException extends OldFileFormatException implements Serializable

Package org.apache.poi.hsmf.exceptions

Class org.apache.poi.hsmf.exceptions.ChunkNotFoundException extends java.lang.Exception implements Serializable

serialVersionUID: 1L

Class org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException extends java.lang.Exception implements Serializable

serialVersionUID: 1L

Package org.apache.poi.hssf

Class org.apache.poi.hssf.OldExcelFormatException extends OldFileFormatException implements Serializable

Package org.apache.poi.hssf.eventusermodel

Class org.apache.poi.hssf.eventusermodel.HSSFUserException extends java.lang.Exception implements Serializable

Serialized Fields

reason

java.lang.Throwable reason
Package org.apache.poi.hssf.record

Class org.apache.poi.hssf.record.RecordFormatException extends RecordFormatException implements Serializable

Class org.apache.poi.hssf.record.RecordInputStream.LeftoverDataException extends java.lang.RuntimeException implements Serializable

Package org.apache.poi.hwpf

Class org.apache.poi.hwpf.OldWordFileFormatException extends OldFileFormatException implements Serializable

Package org.apache.poi.openxml4j.exceptions

Class org.apache.poi.openxml4j.exceptions.InvalidFormatException extends OpenXML4JException implements Serializable

Class org.apache.poi.openxml4j.exceptions.InvalidOperationException extends OpenXML4JRuntimeException implements Serializable

Class org.apache.poi.openxml4j.exceptions.OpenXML4JException extends java.lang.Exception implements Serializable

Class org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException extends java.lang.RuntimeException implements Serializable

Class org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException extends InvalidOperationException implements Serializable

Package org.apache.poi.openxml4j.opc

Class org.apache.poi.openxml4j.opc.PackagePartCollection extends java.util.TreeMap<PackagePartName,PackagePart> implements Serializable

serialVersionUID: 2515031135957635515L

Serialized Fields

registerPartNameStr

java.util.ArrayList<E> registerPartNameStr
Arraylist use to store this collection part names as string for rule M1.11 optimized checking.

Package org.apache.poi.poifs.filesystem

Class org.apache.poi.poifs.filesystem.OfficeXmlFileException extends java.lang.IllegalArgumentException implements Serializable

Class org.apache.poi.poifs.filesystem.Ole10NativeException extends java.lang.Exception implements Serializable

Package org.apache.poi.ss.formula

Class org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment.WorkbookNotFoundException extends java.lang.Exception implements Serializable

Class org.apache.poi.ss.formula.FormulaParseException extends java.lang.RuntimeException implements Serializable

Package org.apache.poi.ss.formula.eval

Class org.apache.poi.ss.formula.eval.EvaluationException extends java.lang.Exception implements Serializable

Serialized Fields

_errorEval

ErrorEval _errorEval

Class org.apache.poi.ss.formula.eval.NotImplementedException extends java.lang.RuntimeException implements Serializable

Package org.apache.poi.ss.usermodel

Class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter extends java.text.SimpleDateFormat implements Serializable

Serialized Fields

format1digit

java.text.DecimalFormat format1digit

format2digits

java.text.DecimalFormat format2digits

format3digit

java.text.DecimalFormat format3digit

format4digits

java.text.DecimalFormat format4digits

dateToBeFormatted

double dateToBeFormatted
Package org.apache.poi.util

Class org.apache.poi.util.LittleEndian.BufferUnderrunException extends java.io.IOException implements Serializable

serialVersionUID: 8736973884877006145L

Class org.apache.poi.util.RecordFormatException extends java.lang.RuntimeException implements Serializable

Package org.apache.poi.xslf.model.geom

Class org.apache.poi.xslf.model.geom.PresetGeometries extends java.util.LinkedHashMap<java.lang.String,CustomGeometry> implements Serializable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


EncryptedDocumentException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class EncryptedDocumentException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalStateException
                    extended by  org.apache.poi.EncryptedDocumentException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
EncryptedPowerPointFileException
public class EncryptedDocumentException
extends java.lang.IllegalStateException

See Also:
Serialized Form

Constructor Summary
EncryptedDocumentException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EncryptedDocumentException

public EncryptedDocumentException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


OldFileFormatException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class OldFileFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalArgumentException
                    extended by  org.apache.poi.OldFileFormatException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
OldExcelFormatException, OldPowerPointFormatException, OldWordFileFormatException
public abstract class OldFileFormatException
extends java.lang.IllegalArgumentException

Base class of all the exceptions that POI throws in the event that it's given a file that's older than currently supported.

See Also:
Serialized Form

Constructor Summary
OldFileFormatException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OldFileFormatException

public OldFileFormatException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi
Classes
POIDocument
POIOLE2TextExtractor
POITextExtractor
POIXMLDocument
POIXMLDocumentPart
POIXMLFactory
POIXMLProperties
POIXMLPropertiesTextExtractor
POIXMLRelation
POIXMLTextExtractor
Exceptions
EncryptedDocumentException
OldFileFormatException
POIXMLException


org.apache.poi

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi

Class Summary
POIDocument | This holds the common functionality for all POI Document classes.
POIOLE2TextExtractor | Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor | Common Parent for Text Extractors of POI Documents.
POIXMLDocument |
POIXMLDocumentPart | Represents an entry of a OOXML package.
POIXMLFactory | Defines a factory API that enables sub-classes to create instances of POIXMLDocumentPart
POIXMLProperties | Wrapper around the two different kinds of OOXML properties a document can have
POIXMLPropertiesTextExtractor | A POITextExtractor for returning the textual content of the OOXML file properties, eg author and title.
POIXMLRelation | Represents a descriptor of a OOXML relation.
POIXMLTextExtractor |

Exception Summary
EncryptedDocumentException |
OldFileFormatException | Base class of all the exceptions that POI throws in the event that it's given a file that's older than currently supported.
POIXMLException | Indicates a generic OOXML error.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.apache.poi Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POIDocument
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIOLE2TextExtractor
      • org.apache.poi.POIXMLTextExtractor
        • org.apache.poi.POIXMLPropertiesTextExtractor
    • org.apache.poi.POIXMLDocumentPart
      • org.apache.poi.POIXMLDocument
    • org.apache.poi.POIXMLFactory
    • org.apache.poi.POIXMLProperties
    • org.apache.poi.POIXMLProperties.CoreProperties
    • org.apache.poi.POIXMLProperties.CustomProperties
    • org.apache.poi.POIXMLProperties.ExtendedProperties
    • org.apache.poi.POIXMLRelation
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • org.apache.poi.OldFileFormatException
          • java.lang.IllegalStateException
            • org.apache.poi.EncryptedDocumentException
          • org.apache.poi.POIXMLException
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.apache.poi

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi

Packages that use org.apache.poi
org.apache.poi |
org.apache.poi.extractor |
org.apache.poi.hdgf |
org.apache.poi.hdgf.extractor |
org.apache.poi.hpbf |
org.apache.poi.hpbf.extractor |
org.apache.poi.hpsf.extractor |
org.apache.poi.hslf |
org.apache.poi.hslf.exceptions |
org.apache.poi.hslf.extractor |
org.apache.poi.hsmf |
org.apache.poi.hsmf.extractor |
org.apache.poi.hssf | Horrible SpreadSheet Format API's for reading/writting Excel files using pure Java.
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf |
org.apache.poi.hwpf.extractor |
org.apache.poi.xslf |
org.apache.poi.xslf.extractor |
org.apache.poi.xslf.usermodel |
org.apache.poi.xssf.extractor |
org.apache.poi.xssf.model |
org.apache.poi.xssf.usermodel |
org.apache.poi.xwpf.extractor |
org.apache.poi.xwpf.usermodel |

Classes in org.apache.poi used by org.apache.poi
POIDocument
This holds the common functionality for all POI Document classes.
POITextExtractor
Common Parent for Text Extractors of POI Documents.
POIXMLDocument
POIXMLDocumentPart
Represents an entry of a OOXML package.
POIXMLFactory
Defines a factory API that enables sub-classes to create instances of POIXMLDocumentPart
POIXMLProperties
Wrapper around the two different kinds of OOXML properties a document can have
POIXMLProperties.CoreProperties
The core document properties
POIXMLProperties.CustomProperties
Custom document properties
POIXMLProperties.ExtendedProperties
Extended document properties
POIXMLPropertiesTextExtractor
A POITextExtractor for returning the textual content of the OOXML file properties, eg author and title.
POIXMLRelation
Represents a descriptor of a OOXML relation.
POIXMLTextExtractor

Classes in org.apache.poi used by org.apache.poi.extractor
POIOLE2TextExtractor
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor
Common Parent for Text Extractors of POI Documents.
POIXMLTextExtractor

Classes in org.apache.poi used by org.apache.poi.hdgf
POIDocument
This holds the common functionality for all POI Document classes.

Classes in org.apache.poi used by org.apache.poi.hdgf.extractor
POIOLE2TextExtractor
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor
Common Parent for Text Extractors of POI Documents.

Classes in org.apache.poi used by org.apache.poi.hpbf
POIDocument
This holds the common functionality for all POI Document classes.

Classes in org.apache.poi used by org.apache.poi.hpbf.extractor
POIOLE2TextExtractor
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor
Common Parent for Text Extractors of POI Documents.

Classes in org.apache.poi used by org.apache.poi.hpsf.extractor
POIDocument
This holds the common functionality for all POI Document classes.
POITextExtractor
Common Parent for Text Extractors of POI Documents.

Classes in org.apache.poi used by org.apache.poi.hslf
POIDocument
This holds the common functionality for all POI Document classes.

Classes in org.apache.poi used by org.apache.poi.hslf.exceptions
EncryptedDocumentException
OldFileFormatException
Base class of all the exceptions that POI throws in the event that it's given a file that's older than currently supported.

Classes in org.apache.poi used by org.apache.poi.hslf.extractor
POIOLE2TextExtractor
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor
Common Parent for Text Extractors of POI Documents.

Classes in org.apache.poi used by org.apache.poi.hsmf
POIDocument
This holds the common functionality for all POI Document classes.

Classes in org.apache.poi used by org.apache.poi.hsmf.extractor
POIOLE2TextExtractor
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor
Common Parent for Text Extractors of POI Documents.

Classes in org.apache.poi used by org.apache.poi.hssf
OldFileFormatException
Base class of all the exceptions that POI throws in the event that it's given a file that's older than currently supported.

Classes in org.apache.poi used by org.apache.poi.hssf.extractor
POIOLE2TextExtractor
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor
Common Parent for Text Extractors of POI Documents.

Classes in org.apache.poi used by org.apache.poi.hssf.usermodel
POIDocument
This holds the common functionality for all POI Document classes.

Classes in org.apache.poi used by org.apache.poi.hwpf
OldFileFormatException
Base class of all the exceptions that POI throws in the event that it's given a file that's older than currently supported.
POIDocument
This holds the common functionality for all POI Document classes.

Classes in org.apache.poi used by org.apache.poi.hwpf.extractor
POIOLE2TextExtractor
Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
POITextExtractor
Common Parent for Text Extractors of POI Documents.

Classes in org.apache.poi used by org.apache.poi.xslf
POIXMLDocument
POIXMLDocumentPart
Represents an entry of a OOXML package.

Classes in org.apache.poi used by org.apache.poi.xslf.extractor
POITextExtractor
Common Parent for Text Extractors of POI Documents.
POIXMLTextExtractor

Classes in org.apache.poi used by org.apache.poi.xslf.usermodel
POIXMLDocument
POIXMLDocumentPart
Represents an entry of a OOXML package.
POIXMLFactory
Defines a factory API that enables sub-classes to create instances of POIXMLDocumentPart
POIXMLRelation
Represents a descriptor of a OOXML relation.

Classes in org.apache.poi used by org.apache.poi.xssf.extractor
POITextExtractor
Common Parent for Text Extractors of POI Documents.
POIXMLProperties.CoreProperties
The core document properties
POIXMLProperties.CustomProperties
Custom document properties
POIXMLProperties.ExtendedProperties
Extended document properties
POIXMLTextExtractor

Classes in org.apache.poi used by org.apache.poi.xssf.model
POIXMLDocumentPart
Represents an entry of a OOXML package.

Classes in org.apache.poi used by org.apache.poi.xssf.usermodel
POIXMLDocument
POIXMLDocumentPart
Represents an entry of a OOXML package.
POIXMLFactory
Defines a factory API that enables sub-classes to create instances of POIXMLDocumentPart
POIXMLRelation
Represents a descriptor of a OOXML relation.

Classes in org.apache.poi used by org.apache.poi.xwpf.extractor
POITextExtractor
Common Parent for Text Extractors of POI Documents.
POIXMLTextExtractor

Classes in org.apache.poi used by org.apache.poi.xwpf.usermodel
POIXMLDocument
POIXMLDocumentPart
Represents an entry of a OOXML package.
POIXMLFactory
Defines a factory API that enables sub-classes to create instances of POIXMLDocumentPart
POIXMLRelation
Represents a descriptor of a OOXML relation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POIDocument

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIDocument

java.lang.Object
    extended by  org.apache.poi.POIDocument
Direct Known Subclasses:
HDGFDiagram, HPBFDocument, HSLFSlideShow, HSSFWorkbook, HWPFDocumentCore, MAPIMessage
public abstract class POIDocument
extends java.lang.Object

This holds the common functionality for all POI Document classes. Currently, this relates to Document Information Properties

Author:
Nick Burch

Field Summary
protected  DirectoryNode directory
The directory that our document lives in
Constructor Summary
protected | POIDocument(DirectoryNode dir)
protected | POIDocument(DirectoryNode dir, POIFSFileSystem fs) Deprecated. use POIDocument(DirectoryNode) instead
protected | POIDocument(NPOIFSFileSystem fs)
protected | POIDocument(POIFSFileSystem fs)
Method Summary
protected void | copyNodeRecursively(Entry entry, DirectoryEntry target) Deprecated.
protected void | copyNodes(DirectoryNode sourceRoot, DirectoryNode targetRoot, java.util.List<java.lang.String> excepts) Deprecated.
protected void | copyNodes(POIFSFileSystem source, POIFSFileSystem target, java.util.List<java.lang.String> excepts) Deprecated.
void | createInformationProperties() Will create whichever of SummaryInformation and DocumentSummaryInformation (HPSF) properties are not already part of your document.
DocumentSummaryInformation | getDocumentSummaryInformation() Fetch the Document Summary Information of the document
protected PropertySet | getPropertySet(java.lang.String setName) For a given named property entry, either return it or null if if it wasn't found
SummaryInformation | getSummaryInformation() Fetch the Summary Information of the document
protected void | readProperties() Find, and create objects for, the standard Documment Information Properties (HPSF).
abstract void | write(java.io.OutputStream out) Writes the document out to the specified output stream
protected void | writeProperties(POIFSFileSystem outFS) Writes out the standard Documment Information Properties (HPSF)
protected void | writeProperties(POIFSFileSystem outFS, java.util.List<java.lang.String> writtenEntries) Writes out the standard Documment Information Properties (HPSF)
protected void | writePropertySet(java.lang.String name, PropertySet set, POIFSFileSystem outFS) Writes out a given ProperySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

directory

protected DirectoryNode directory
The directory that our document lives in

Constructor Detail

POIDocument

protected POIDocument(DirectoryNode dir)

POIDocument

@Deprecated
protected POIDocument(DirectoryNode dir,
                                 POIFSFileSystem fs)
Deprecated. use POIDocument(DirectoryNode) instead

POIDocument

protected POIDocument(POIFSFileSystem fs)

POIDocument

protected POIDocument(NPOIFSFileSystem fs)
Method Detail

getDocumentSummaryInformation

public DocumentSummaryInformation getDocumentSummaryInformation()
Fetch the Document Summary Information of the document

getSummaryInformation

public SummaryInformation getSummaryInformation()
Fetch the Summary Information of the document

createInformationProperties

public void createInformationProperties()
Will create whichever of SummaryInformation and DocumentSummaryInformation (HPSF) properties are not already part of your document. This is normally useful when creating a new document from scratch. If the information properties are already there, then nothing will happen.

readProperties

protected void readProperties()
Find, and create objects for, the standard Documment Information Properties (HPSF). If a given property set is missing or corrupt, it will remain null;

getPropertySet

protected PropertySet getPropertySet(java.lang.String setName)
For a given named property entry, either return it or null if if it wasn't found

writeProperties

protected void writeProperties(POIFSFileSystem outFS)
                        throws java.io.IOException
Writes out the standard Documment Information Properties (HPSF)

Parameters:
outFS - the POIFSFileSystem to write the properties into
Throws:
java.io.IOException

writeProperties

protected void writeProperties(POIFSFileSystem outFS,
                               java.util.List<java.lang.String> writtenEntries)
                        throws java.io.IOException
Writes out the standard Documment Information Properties (HPSF)

Parameters:
outFS - the POIFSFileSystem to write the properties into
writtenEntries - a list of POIFS entries to add the property names too
Throws:
java.io.IOException

writePropertySet

protected void writePropertySet(java.lang.String name,
                                PropertySet set,
                                POIFSFileSystem outFS)
                         throws java.io.IOException
Writes out a given ProperySet

Parameters:
name - the (POIFS Level) name of the property to write
set - the PropertySet to write out
outFS - the POIFSFileSystem to write the property into
Throws:
java.io.IOException

write

public abstract void write(java.io.OutputStream out)
                    throws java.io.IOException
Writes the document out to the specified output stream

Throws:
java.io.IOException

copyNodes

@Deprecated
protected void copyNodes(POIFSFileSystem source,
                                    POIFSFileSystem target,
                                    java.util.List<java.lang.String> excepts)
                  throws java.io.IOException
Deprecated.

Copies nodes from one POIFS to the other minus the excepts

Parameters:
source - is the source POIFS to copy from
target - is the target POIFS to copy to
excepts - is a list of Strings specifying what nodes NOT to copy
Throws:
java.io.IOException

copyNodes

@Deprecated
protected void copyNodes(DirectoryNode sourceRoot,
                                    DirectoryNode targetRoot,
                                    java.util.List<java.lang.String> excepts)
                  throws java.io.IOException
Deprecated.

Copies nodes from one POIFS to the other minus the excepts

Parameters:
sourceRoot - is the source POIFS to copy from
targetRoot - is the target POIFS to copy to
excepts - is a list of Strings specifying what nodes NOT to copy
Throws:
java.io.IOException

copyNodeRecursively

@Internal
@Deprecated
protected void copyNodeRecursively(Entry entry,
                                                       DirectoryEntry target)
                            throws java.io.IOException
Deprecated.

Copies an Entry into a target POIFS directory, recursively

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIOLE2TextExtractor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIOLE2TextExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
Direct Known Subclasses:
EventBasedExcelExtractor, ExcelExtractor, OutlookTextExtactor, PowerPointExtractor, PublisherTextExtractor, VisioTextExtractor, Word6Extractor, WordExtractor
public abstract class POIOLE2TextExtractor
extends POITextExtractor

Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .

See Also:
ExcelExtractor, PowerPointExtractor, VisioTextExtractor, WordExtractor

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
POIOLE2TextExtractor(POIDocument document)
Creates a new text extractor for the given document
Method Summary
 DocumentSummaryInformation getDocSummaryInformation()
Returns the document information metadata for the document
 POIFSFileSystem getFileSystem()
Deprecated. Use getRoot() instead
 POITextExtractor getMetadataTextExtractor()
Returns an HPSF powered text extractor for the document properties metadata, such as title and author.
 DirectoryEntry getRoot()
 SummaryInformation getSummaryInformation()
Returns the summary information metadata for the document
Methods inherited from class org.apache.poi.POITextExtractor
getText
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIOLE2TextExtractor

public POIOLE2TextExtractor(POIDocument document)
Creates a new text extractor for the given document

Method Detail

getDocSummaryInformation

public DocumentSummaryInformation getDocSummaryInformation()
Returns the document information metadata for the document

getSummaryInformation

public SummaryInformation getSummaryInformation()
Returns the summary information metadata for the document

getMetadataTextExtractor

public POITextExtractor getMetadataTextExtractor()
Returns an HPSF powered text extractor for the document properties metadata, such as title and author.

Specified by:
getMetadataTextExtractor in class POITextExtractor

getRoot

public DirectoryEntry getRoot()

getFileSystem

@Deprecated
public POIFSFileSystem getFileSystem()
Deprecated. Use getRoot() instead

Return the underlying POIFS FileSystem of this document.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POITextExtractor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POITextExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
Direct Known Subclasses:
HPSFPropertiesExtractor, POIOLE2TextExtractor, POIXMLTextExtractor
public abstract class POITextExtractor
extends java.lang.Object

Common Parent for Text Extractors of POI Documents. You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .

See Also:
ExcelExtractor, PowerPointExtractor, VisioTextExtractor, WordExtractor

Field Summary
protected  POIDocument document
The POIDocument that's open
Constructor Summary
 | POITextExtractor(POIDocument document) Creates a new text extractor for the given document
protected | POITextExtractor(POITextExtractor otherExtractor) Creates a new text extractor, using the same document as another text extractor.
Method Summary
abstract POITextExtractor | getMetadataTextExtractor() Returns another text extractor, which is able to output the textual content of the document metadata / properties, such as author and title.
abstract java.lang.String | getText() Retrieves all the text from the document.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

document

protected POIDocument document
The POIDocument that's open

Constructor Detail

POITextExtractor

public POITextExtractor(POIDocument document)
Creates a new text extractor for the given document

POITextExtractor

protected POITextExtractor(POITextExtractor otherExtractor)
Creates a new text extractor, using the same document as another text extractor. Normally only used by properties extractors.

Method Detail

getText

public abstract java.lang.String getText()
Retrieves all the text from the document. How cells, paragraphs etc are separated in the text is implementation specific - see the javadocs for a specific project for details.

Returns:
All the text from the document

getMetadataTextExtractor

public abstract POITextExtractor getMetadataTextExtractor()
Returns another text extractor, which is able to output the textual content of the document metadata / properties, such as author and title.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLDocument

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLDocument

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.POIXMLDocument
Direct Known Subclasses:
XMLSlideShow, XSLFSlideShow, XSSFWorkbook, XWPFDocument
public abstract class POIXMLDocument
extends POIXMLDocumentPart

Field Summary
static java.lang.String | DOCUMENT_CREATOR
static java.lang.String | OLE_OBJECT_REL_TYPE
static java.lang.String | PACK_OBJECT_REL_TYPE
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected POIXMLDocument(OPCPackage pkg)
Method Summary
abstract java.util.List<PackagePart> | getAllEmbedds() Get the document's embedded files.
protected PackagePart | getCorePart()
OPCPackage | getPackage()
POIXMLProperties | getProperties() Get the document properties.
protected PackagePart[] | getRelatedByType(java.lang.String contentType) Retrieves all the PackageParts which are defined as relationships of the base document with the specified content type.
static boolean | hasOOXMLHeader(java.io.InputStream inp) Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a OOXML (zip) header at the start of it.
protected void | load(POIXMLFactory factory)
static OPCPackage | openPackage(java.lang.String path) Wrapper to open a package, returning an IOException in the event of a problem.
void | write(java.io.OutputStream stream) Write out this document to an Outputstream.
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DOCUMENT_CREATOR

public static final java.lang.String DOCUMENT_CREATOR
See Also:
Constant Field Values

OLE_OBJECT_REL_TYPE

public static final java.lang.String OLE_OBJECT_REL_TYPE
See Also:
Constant Field Values

PACK_OBJECT_REL_TYPE

public static final java.lang.String PACK_OBJECT_REL_TYPE
See Also:
Constant Field Values
Constructor Detail

POIXMLDocument

protected POIXMLDocument(OPCPackage pkg)
Method Detail

openPackage

public static OPCPackage openPackage(java.lang.String path)
                              throws java.io.IOException
Wrapper to open a package, returning an IOException in the event of a problem. Works around shortcomings in java's this() constructor calls

Throws:
java.io.IOException

getPackage

public OPCPackage getPackage()

getCorePart

protected PackagePart getCorePart()

getRelatedByType

protected PackagePart[] getRelatedByType(java.lang.String contentType)
                                  throws InvalidFormatException
Retrieves all the PackageParts which are defined as relationships of the base document with the specified content type.

Throws:
InvalidFormatException

hasOOXMLHeader

public static boolean hasOOXMLHeader(java.io.InputStream inp)
                              throws java.io.IOException
Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a OOXML (zip) header at the start of it. If your InputStream does not support mark / reset, then wrap it in a PushBackInputStream, then be sure to always use that, and not the original!

Parameters:
inp - An InputStream which supports either mark/reset, or is a PushbackInputStream
Throws:
java.io.IOException

getProperties

public POIXMLProperties getProperties()
Get the document properties. This gives you access to the core ooxml properties, and the extended ooxml properties.

getAllEmbedds

public abstract java.util.List<PackagePart> getAllEmbedds()
                                                   throws OpenXML4JException
Get the document's embedded files.

Throws:
OpenXML4JException

load

protected final void load(POIXMLFactory factory)
                   throws java.io.IOException
Throws:
java.io.IOException

write

public final void write(java.io.OutputStream stream)
                 throws java.io.IOException
Write out this document to an Outputstream.

Parameters:
stream - - the java OutputStream you wish to write the file to
Throws:
java.io.IOException - if anything can't be written.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLDocumentPart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLDocumentPart

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
Direct Known Subclasses:
CalculationChain, CommentsTable, MapInfo, POIXMLDocument, SharedStringsTable, SingleXmlCells, StylesTable, ThemesTable, XSLFCommentAuthors, XSLFComments, XSLFPictureData, XSLFSheet, XSLFTableStyles, XSLFTheme, XSSFChart, XSSFDrawing, XSSFPictureData, XSSFSheet, XSSFTable, XSSFVMLDrawing, XWPFFootnotes, XWPFHeaderFooter, XWPFNumbering, XWPFPictureData, XWPFSettings, XWPFStyles
public class POIXMLDocumentPart
extends java.lang.Object

Represents an entry of a OOXML package.

Each POIXMLDocumentPart keeps a reference to the underlying a PackagePart.

Author:
Yegor Kozlov

Field Summary
static org.apache.xmlbeans.XmlOptions DEFAULT_XML_OPTIONS
Constructor Summary
POIXMLDocumentPart()
Creates new POIXMLDocumentPart - called by client code to create new parts from scratch.
POIXMLDocumentPart(OPCPackage pkg)
Construct POIXMLDocumentPart representing a "core document" package part.
POIXMLDocumentPart(PackagePart part, PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part and relationship.
POIXMLDocumentPart(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part, relationship and parent Called by read(POIXMLFactory, java.util.Map) when reading in an exisiting file.
Method Summary
 void addRelation(java.lang.String id, POIXMLDocumentPart part)
Add a new child POIXMLDocumentPart
protected  void commit()
Save the content in the underlying package part.
 POIXMLDocumentPart createRelationship(POIXMLRelation descriptor, POIXMLFactory factory)
Create a new child POIXMLDocumentPart
 POIXMLDocumentPart createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx)
protected  POIXMLDocumentPart createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx, boolean noRelation)
Create a new child POIXMLDocumentPart
 PackagePart getPackagePart()
Provides access to the underlying PackagePart
 PackageRelationship getPackageRelationship()
Provides access to the PackageRelationship that identifies this POIXMLDocumentPart
 POIXMLDocumentPart getParent()
Returns the parent POIXMLDocumentPart.
 POIXMLDocumentPart getRelationById(java.lang.String id)
Returns the target POIXMLDocumentPart, where a PackageRelationship is set from the PackagePart of this POIXMLDocumentPart to the PackagePart of the target POIXMLDocumentPart with a PackageRelationship.getId() matching the given parameter value.
 java.lang.String getRelationId(POIXMLDocumentPart part)
Returns the PackageRelationship.getId() of the PackageRelationship, that sources from the PackagePart of this POIXMLDocumentPart to the PackagePart of the given parameter value.
 java.util.List<POIXMLDocumentPart> getRelations()
Returns the list of child relations for this POIXMLDocumentPart
protected  PackagePart getTargetPart(PackageRelationship rel)
Get the PackagePart that is the target of a relationship from this Part.
protected  void onDocumentCreate()
Fired when a new package part is created
protected  void onDocumentRead()
Fired when a package part is read
protected  void onDocumentRemove()
Fired when a package part is about to be removed from the package
protected  void onSave(java.util.Set<PackagePart> alreadySaved)
Save changes in the underlying OOXML package.
protected  void read(POIXMLFactory factory, java.util.Map<PackagePart,POIXMLDocumentPart> context)
Iterate through the underlying PackagePart and create child POIXMLFactory instances using the specified factory
protected  void rebase(OPCPackage pkg)
When you open something like a theme, call this to re-base the XML Document onto the core child of the current core document
protected  void removeRelation(POIXMLDocumentPart part)
Remove the relation to the specified part in this package and remove the part, if it is no longer needed.
protected  boolean removeRelation(POIXMLDocumentPart part, boolean removeUnusedParts)
Remove the relation to the specified part in this package and remove the part, if it is no longer needed and flag is set to true.
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT_XML_OPTIONS

public static final org.apache.xmlbeans.XmlOptions DEFAULT_XML_OPTIONS
Constructor Detail

POIXMLDocumentPart

public POIXMLDocumentPart(OPCPackage pkg)
Construct POIXMLDocumentPart representing a "core document" package part.

POIXMLDocumentPart

public POIXMLDocumentPart()
Creates new POIXMLDocumentPart - called by client code to create new parts from scratch.

See Also:
createRelationship(POIXMLRelation, POIXMLFactory, int, boolean)

POIXMLDocumentPart

public POIXMLDocumentPart(PackagePart part,
                          PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part and relationship. Called by read(POIXMLFactory, java.util.Map) when reading in an exisiting file.

Parameters:
part - - The package part that holds xml data represenring this sheet.
rel - - the relationship of the given package part
See Also:
read(POIXMLFactory, java.util.Map)

POIXMLDocumentPart

public POIXMLDocumentPart(POIXMLDocumentPart parent,
                          PackagePart part,
                          PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part, relationship and parent Called by read(POIXMLFactory, java.util.Map) when reading in an exisiting file.

Parameters:
parent - - Parent part
part - - The package part that holds xml data represenring this sheet.
rel - - the relationship of the given package part
See Also:
read(POIXMLFactory, java.util.Map)
Method Detail

rebase

protected final void rebase(OPCPackage pkg)
                     throws InvalidFormatException
When you open something like a theme, call this to re-base the XML Document onto the core child of the current core document

Throws:
InvalidFormatException

getPackagePart

public final PackagePart getPackagePart()
Provides access to the underlying PackagePart

Returns:
the underlying PackagePart

getPackageRelationship

public final PackageRelationship getPackageRelationship()
Provides access to the PackageRelationship that identifies this POIXMLDocumentPart

Returns:
the PackageRelationship that identifies this POIXMLDocumentPart

getRelations

public final java.util.List<POIXMLDocumentPart> getRelations()
Returns the list of child relations for this POIXMLDocumentPart

Returns:
child relations

getRelationById

public final POIXMLDocumentPart getRelationById(java.lang.String id)
Returns the target POIXMLDocumentPart, where a PackageRelationship is set from the PackagePart of this POIXMLDocumentPart to the PackagePart of the target POIXMLDocumentPart with a PackageRelationship.getId() matching the given parameter value.

Parameters:
id - The relation id to look for
Returns:
the target part of the relation, or null, if none exists

getRelationId

public final java.lang.String getRelationId(POIXMLDocumentPart part)
Returns the PackageRelationship.getId() of the PackageRelationship, that sources from the PackagePart of this POIXMLDocumentPart to the PackagePart of the given parameter value.

Parameters:
part - The POIXMLDocumentPart for which the according relation-id shall be found.
Returns:
The value of the PackageRelationship.getId() or null, if parts are not related.

addRelation

public final void addRelation(java.lang.String id,
                              POIXMLDocumentPart part)
Add a new child POIXMLDocumentPart

Parameters:
part - the child to add

removeRelation

protected final void removeRelation(POIXMLDocumentPart part)
Remove the relation to the specified part in this package and remove the part, if it is no longer needed.

removeRelation

protected final boolean removeRelation(POIXMLDocumentPart part,
                                       boolean removeUnusedParts)
Remove the relation to the specified part in this package and remove the part, if it is no longer needed and flag is set to true.

Parameters:
part - The related part, to which the relation shall be removed.
removeUnusedParts - true, if the part shall be removed from the package if not needed any longer.

getParent

public final POIXMLDocumentPart getParent()
Returns the parent POIXMLDocumentPart. All parts except root have not-null parent.

Returns:
the parent POIXMLDocumentPart or null for the root element.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

commit

protected void commit()
               throws java.io.IOException
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Throws:
java.io.IOException

onSave

protected final void onSave(java.util.Set<PackagePart> alreadySaved)
                     throws java.io.IOException
Save changes in the underlying OOXML package. Recursively fires commit() for each package part

Parameters:
alreadySaved - context set containing already visited nodes
Throws:
java.io.IOException

createRelationship

public final POIXMLDocumentPart createRelationship(POIXMLRelation descriptor,
                                                   POIXMLFactory factory)
Create a new child POIXMLDocumentPart

Parameters:
descriptor - the part descriptor
factory - the factory that will create an instance of the requested relation
Returns:
the created child POIXMLDocumentPart

createRelationship

public final POIXMLDocumentPart createRelationship(POIXMLRelation descriptor,
                                                   POIXMLFactory factory,
                                                   int idx)

createRelationship

protected final POIXMLDocumentPart createRelationship(POIXMLRelation descriptor,
                                                      POIXMLFactory factory,
                                                      int idx,
                                                      boolean noRelation)
Create a new child POIXMLDocumentPart

Parameters:
descriptor - the part descriptor
factory - the factory that will create an instance of the requested relation
idx - part number
noRelation - if true, then no relationship is added.
Returns:
the created child POIXMLDocumentPart

read

protected void read(POIXMLFactory factory,
                    java.util.Map<PackagePart,POIXMLDocumentPart> context)
             throws OpenXML4JException
Iterate through the underlying PackagePart and create child POIXMLFactory instances using the specified factory

Parameters:
factory - the factory object that creates POIXMLFactory instances
context - context map containing already visited noted keyed by targetURI
Throws:
OpenXML4JException

getTargetPart

protected PackagePart getTargetPart(PackageRelationship rel)
                             throws InvalidFormatException
Get the PackagePart that is the target of a relationship from this Part.

Parameters:
rel - The relationship
Returns:
The target part
Throws:
InvalidFormatException

onDocumentCreate

protected void onDocumentCreate()
                         throws java.io.IOException
Fired when a new package part is created

Throws:
java.io.IOException

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Fired when a package part is read

Throws:
java.io.IOException

onDocumentRemove

protected void onDocumentRemove()
                         throws java.io.IOException
Fired when a package part is about to be removed from the package

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.POIXMLException
All Implemented Interfaces:
java.io.Serializable
public final class POIXMLException
extends java.lang.RuntimeException

Indicates a generic OOXML error.

Author:
Yegor Kozlov
See Also:
Serialized Form

Constructor Summary
POIXMLException()
Create a new POIXMLException with no detail mesage.
POIXMLException(java.lang.String msg)
Create a new POIXMLException with the String specified as an error message.
POIXMLException(java.lang.String msg, java.lang.Throwable cause)
Create a new POIXMLException with the String specified as an error message and the cause.
POIXMLException(java.lang.Throwable cause)
Create a new POIXMLException with the specified cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

POIXMLException

public POIXMLException()
Create a new POIXMLException with no detail mesage.

POIXMLException

public POIXMLException(java.lang.String msg)
Create a new POIXMLException with the String specified as an error message.

Parameters:
msg - The error message for the exception.

POIXMLException

public POIXMLException(java.lang.String msg,
                       java.lang.Throwable cause)
Create a new POIXMLException with the String specified as an error message and the cause.

Parameters:
msg - The error message for the exception.
cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

POIXMLException

public POIXMLException(java.lang.Throwable cause)
Create a new POIXMLException with the specified cause.

Parameters:
cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLFactory

java.lang.Object
    extended by  org.apache.poi.POIXMLFactory
Direct Known Subclasses:
XSLFFactory, XSSFFactory, XWPFFactory
public abstract class POIXMLFactory
extends java.lang.Object

Defines a factory API that enables sub-classes to create instances of POIXMLDocumentPart

Author:
Yegor Kozlov

Constructor Summary
POIXMLFactory()
Method Summary
abstract POIXMLDocumentPart | createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part) Create a POIXMLDocumentPart from existing package part and relation.
abstract POIXMLDocumentPart | newDocumentPart(POIXMLRelation descriptor) Create a new POIXMLDocumentPart using the supplied descriptor.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIXMLFactory

public POIXMLFactory()
Method Detail

createDocumentPart

public abstract POIXMLDocumentPart createDocumentPart(POIXMLDocumentPart parent,
                                                      PackageRelationship rel,
                                                      PackagePart part)
Create a POIXMLDocumentPart from existing package part and relation. This method is called from POIXMLDocument.load(POIXMLFactory) when parsing a document

Parameters:
parent - parent part
rel - the package part relationship
part - the PackagePart representing the created instance
Returns:
A new instance of a POIXMLDocumentPart.

newDocumentPart

public abstract POIXMLDocumentPart newDocumentPart(POIXMLRelation descriptor)
Create a new POIXMLDocumentPart using the supplied descriptor. This method is used when adding new parts to a document, for example, when adding a sheet to a workbook, slide to a presentation, etc.

Parameters:
descriptor - describes the object to create
Returns:
A new instance of a POIXMLDocumentPart.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLProperties.CoreProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLProperties.CoreProperties

java.lang.Object
    extended by  org.apache.poi.POIXMLProperties.CoreProperties
Enclosing class:
POIXMLProperties
public class POIXMLProperties.CoreProperties
extends java.lang.Object

The core document properties

Method Summary
java.lang.String | getCategory()
java.lang.String | getContentStatus()
java.lang.String | getContentType()
java.util.Date | getCreated()
java.lang.String | getCreator()
java.lang.String | getDescription()
java.lang.String | getIdentifier()
java.lang.String | getKeywords()
java.util.Date | getLastPrinted()
java.util.Date | getModified()
java.lang.String | getRevision()
java.lang.String | getSubject()
java.lang.String | getTitle()
PackagePropertiesPart | getUnderlyingProperties()
void | setCategory(java.lang.String category)
void | setContentStatus(java.lang.String contentStatus)
void | setContentType(java.lang.String contentType)
void | setCreated(Nullable<java.util.Date> date)
void | setCreated(java.lang.String date)
void | setCreator(java.lang.String creator)
void | setDescription(java.lang.String description)
void | setIdentifier(java.lang.String identifier)
void | setKeywords(java.lang.String keywords)
void | setLastPrinted(Nullable<java.util.Date> date)
void | setLastPrinted(java.lang.String date)
void | setModified(Nullable<java.util.Date> date)
void | setModified(java.lang.String date)
void | setRevision(java.lang.String revision)
void | setSubjectProperty(java.lang.String subject)
void | setTitle(java.lang.String title)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getCategory

public java.lang.String getCategory()

setCategory

public void setCategory(java.lang.String category)

getContentStatus

public java.lang.String getContentStatus()

setContentStatus

public void setContentStatus(java.lang.String contentStatus)

getContentType

public java.lang.String getContentType()

setContentType

public void setContentType(java.lang.String contentType)

getCreated

public java.util.Date getCreated()

setCreated

public void setCreated(Nullable<java.util.Date> date)

setCreated

public void setCreated(java.lang.String date)

getCreator

public java.lang.String getCreator()

setCreator

public void setCreator(java.lang.String creator)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getIdentifier

public java.lang.String getIdentifier()

setIdentifier

public void setIdentifier(java.lang.String identifier)

getKeywords

public java.lang.String getKeywords()

setKeywords

public void setKeywords(java.lang.String keywords)

getLastPrinted

public java.util.Date getLastPrinted()

setLastPrinted

public void setLastPrinted(Nullable<java.util.Date> date)

setLastPrinted

public void setLastPrinted(java.lang.String date)

getModified

public java.util.Date getModified()

setModified

public void setModified(Nullable<java.util.Date> date)

setModified

public void setModified(java.lang.String date)

getSubject

public java.lang.String getSubject()

setSubjectProperty

public void setSubjectProperty(java.lang.String subject)

setTitle

public void setTitle(java.lang.String title)

getTitle

public java.lang.String getTitle()

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getUnderlyingProperties

public PackagePropertiesPart getUnderlyingProperties()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLProperties.CustomProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLProperties.CustomProperties

java.lang.Object
    extended by  org.apache.poi.POIXMLProperties.CustomProperties
Enclosing class:
POIXMLProperties
public class POIXMLProperties.CustomProperties
extends java.lang.Object

Custom document properties

Field Summary
static java.lang.String FORMAT_ID
Each custom property element contains an fmtid attribute with the same GUID value ({D5CDD505-2E9C-101B-9397-08002B2CF9AE}).
Method Summary
void | addProperty(java.lang.String name, boolean value) Add a new boolean property
void | addProperty(java.lang.String name, double value) Add a new double property
void | addProperty(java.lang.String name, int value) Add a new integer property
void | addProperty(java.lang.String name, java.lang.String value) Add a new string property
boolean | contains(java.lang.String name) Check if a property with this name already exists in the collection of custom properties
org.openxmlformats.schemas.officeDocument.x2006.customProperties.CTProperties | getUnderlyingProperties()
protected int | nextPid() Generate next id that uniquely relates a custom property
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FORMAT_ID

public static final java.lang.String FORMAT_ID
Each custom property element contains an fmtid attribute with the same GUID value ({D5CDD505-2E9C-101B-9397-08002B2CF9AE}).

See Also:
Constant Field Values
Method Detail

getUnderlyingProperties

public org.openxmlformats.schemas.officeDocument.x2006.customProperties.CTProperties getUnderlyingProperties()

addProperty

public void addProperty(java.lang.String name,
                        java.lang.String value)
Add a new string property

Throws:
java.lang.IllegalArgumentException - if a property with this name already exists

addProperty

public void addProperty(java.lang.String name,
                        double value)
Add a new double property

Throws:
java.lang.IllegalArgumentException - if a property with this name already exists

addProperty

public void addProperty(java.lang.String name,
                        int value)
Add a new integer property

Throws:
java.lang.IllegalArgumentException - if a property with this name already exists

addProperty

public void addProperty(java.lang.String name,
                        boolean value)
Add a new boolean property

Throws:
java.lang.IllegalArgumentException - if a property with this name already exists

nextPid

protected int nextPid()
Generate next id that uniquely relates a custom property

Returns:
next property id starting with 2

contains

public boolean contains(java.lang.String name)
Check if a property with this name already exists in the collection of custom properties

Parameters:
name - the name to check
Returns:
whether a property with the given name exists in the custom properties
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLProperties.ExtendedProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLProperties.ExtendedProperties

java.lang.Object
    extended by  org.apache.poi.POIXMLProperties.ExtendedProperties
Enclosing class:
POIXMLProperties
public class POIXMLProperties.ExtendedProperties
extends java.lang.Object

Extended document properties

Method Summary
 org.openxmlformats.schemas.officeDocument.x2006.extendedProperties.CTProperties getUnderlyingProperties()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getUnderlyingProperties

public org.openxmlformats.schemas.officeDocument.x2006.extendedProperties.CTProperties getUnderlyingProperties()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLProperties

java.lang.Object
    extended by  org.apache.poi.POIXMLProperties

public class POIXMLProperties
extends java.lang.Object

Wrapper around the two different kinds of OOXML properties a document can have

Nested Class Summary
class | POIXMLProperties.CoreProperties The core document properties
class | POIXMLProperties.CustomProperties Custom document properties
class | POIXMLProperties.ExtendedProperties Extended document properties
Constructor Summary
POIXMLProperties(OPCPackage docPackage)
Method Summary
void | commit() Commit changes to the underlying OPC package
POIXMLProperties.CoreProperties | getCoreProperties() Returns the core document properties
POIXMLProperties.CustomProperties | getCustomProperties() Returns the custom document properties
POIXMLProperties.ExtendedProperties | getExtendedProperties() Returns the extended document properties
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIXMLProperties

public POIXMLProperties(OPCPackage docPackage)
                 throws java.io.IOException,
                        OpenXML4JException,
                        org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
OpenXML4JException
org.apache.xmlbeans.XmlException
Method Detail

getCoreProperties

public POIXMLProperties.CoreProperties getCoreProperties()
Returns the core document properties

getExtendedProperties

public POIXMLProperties.ExtendedProperties getExtendedProperties()
Returns the extended document properties

getCustomProperties

public POIXMLProperties.CustomProperties getCustomProperties()
Returns the custom document properties

commit

public void commit()
            throws java.io.IOException
Commit changes to the underlying OPC package

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLPropertiesTextExtractor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLPropertiesTextExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIXMLTextExtractor
            extended by  org.apache.poi.POIXMLPropertiesTextExtractor

public class POIXMLPropertiesTextExtractor
extends POIXMLTextExtractor

A POITextExtractor for returning the textual content of the OOXML file properties, eg author and title.

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
POIXMLPropertiesTextExtractor(POIXMLDocument doc)
Creates a new POIXMLPropertiesTextExtractor for the given open document.
POIXMLPropertiesTextExtractor(POIXMLTextExtractor otherExtractor)
Creates a new POIXMLPropertiesTextExtractor, for the same file that another TextExtractor is already working on.
Method Summary
java.lang.String | getCorePropertiesText() Returns the core document properties, eg author
java.lang.String | getCustomPropertiesText() Returns the custom document properties, if there are any
java.lang.String | getExtendedPropertiesText() Returns the extended document properties, eg application
POIXMLPropertiesTextExtractor | getMetadataTextExtractor() Returns an OOXML properties text extractor for the document properties metadata, such as title and author.
java.lang.String | getText() Retrieves all the text from the document.
Methods inherited from class org.apache.poi.POIXMLTextExtractor
getCoreProperties, getCustomProperties, getDocument, getExtendedProperties, getPackage
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIXMLPropertiesTextExtractor

public POIXMLPropertiesTextExtractor(POIXMLDocument doc)
Creates a new POIXMLPropertiesTextExtractor for the given open document.

POIXMLPropertiesTextExtractor

public POIXMLPropertiesTextExtractor(POIXMLTextExtractor otherExtractor)
Creates a new POIXMLPropertiesTextExtractor, for the same file that another TextExtractor is already working on.

Method Detail

getCorePropertiesText

public java.lang.String getCorePropertiesText()
Returns the core document properties, eg author

getExtendedPropertiesText

public java.lang.String getExtendedPropertiesText()
Returns the extended document properties, eg application

getCustomPropertiesText

public java.lang.String getCustomPropertiesText()
Returns the custom document properties, if there are any

getText

public java.lang.String getText()
Description copied from class: POITextExtractor
Retrieves all the text from the document. How cells, paragraphs etc are separated in the text is implementation specific - see the javadocs for a specific project for details.

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

getMetadataTextExtractor

public POIXMLPropertiesTextExtractor getMetadataTextExtractor()
Description copied from class: POIXMLTextExtractor
Returns an OOXML properties text extractor for the document properties metadata, such as title and author.

Overrides:
getMetadataTextExtractor in class POIXMLTextExtractor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLRelation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLRelation

java.lang.Object
    extended by  org.apache.poi.POIXMLRelation
Direct Known Subclasses:
XSLFRelation, XSSFRelation, XWPFRelation
public abstract class POIXMLRelation
extends java.lang.Object

Represents a descriptor of a OOXML relation.

Author:
Yegor Kozlov

Field Summary
protected java.lang.String | _defaultName The path component of a pack URI.
protected java.lang.String | _relation The kind of connection between a source part and a target part in a package.
protected java.lang.String | _type Describes the content stored in a part.
Constructor Summary
POIXMLRelation(java.lang.String type, java.lang.String rel, java.lang.String defaultName)
Instantiates a POIXMLRelation.
POIXMLRelation(java.lang.String type, java.lang.String rel, java.lang.String defaultName, java.lang.Class<? extends POIXMLDocumentPart> cls)
Instantiates a POIXMLRelation.
Method Summary
java.lang.String | getContentType() Return the content type.
java.lang.String | getDefaultFileName() Return the default part name.
java.lang.String | getFileName(int index) Returns the filename for the nth one of these, e.g.
java.lang.String | getRelation() Return the relationship, the kind of connection between a source part and a target part in a package.
java.lang.Class<? extends POIXMLDocumentPart> | getRelationClass() Return type of the obejct used to construct instances of this relationship
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_type

protected java.lang.String _type
Describes the content stored in a part.

_relation

protected java.lang.String _relation
The kind of connection between a source part and a target part in a package.

_defaultName

protected java.lang.String _defaultName
The path component of a pack URI.

Constructor Detail

POIXMLRelation

public POIXMLRelation(java.lang.String type,
                      java.lang.String rel,
                      java.lang.String defaultName,
                      java.lang.Class<? extends POIXMLDocumentPart> cls)
Instantiates a POIXMLRelation.

Parameters:
type - content type
rel - relationship
defaultName - default item name
cls - defines what object is used to construct instances of this relationship

POIXMLRelation

public POIXMLRelation(java.lang.String type,
                      java.lang.String rel,
                      java.lang.String defaultName)
Instantiates a POIXMLRelation.

Parameters:
type - content type
rel - relationship
defaultName - default item name
Method Detail

getContentType

public java.lang.String getContentType()
Return the content type. Content types define a media type, a subtype, and an optional set of parameters, as defined in RFC 2616.

Returns:
the content type

getRelation

public java.lang.String getRelation()
Return the relationship, the kind of connection between a source part and a target part in a package. Relationships make the connections between parts directly discoverable without looking at the content in the parts, and without altering the parts themselves.

Returns:
the relationship

getDefaultFileName

public java.lang.String getDefaultFileName()
Return the default part name. Part names are used to refer to a part in the context of a package, typically as part of a URI.

Returns:
the default part name

getFileName

public java.lang.String getFileName(int index)
Returns the filename for the nth one of these, e.g. /xl/comments4.xml

getRelationClass

public java.lang.Class<? extends POIXMLDocumentPart> getRelationClass()
Return type of the obejct used to construct instances of this relationship

Returns:
the class of the object used to construct instances of this relation
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIXMLTextExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi
Class POIXMLTextExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIXMLTextExtractor
Direct Known Subclasses:
POIXMLPropertiesTextExtractor, XSLFPowerPointExtractor, XSSFEventBasedExcelExtractor, XSSFExcelExtractor, XWPFWordExtractor
public abstract class POIXMLTextExtractor
extends POITextExtractor

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
POIXMLTextExtractor(POIXMLDocument document)
Creates a new text extractor for the given document
Method Summary
POIXMLProperties.CoreProperties | getCoreProperties() Returns the core document properties
POIXMLProperties.CustomProperties | getCustomProperties() Returns the custom document properties
POIXMLDocument | getDocument() Returns opened document
POIXMLProperties.ExtendedProperties | getExtendedProperties() Returns the extended document properties
POIXMLPropertiesTextExtractor | getMetadataTextExtractor() Returns an OOXML properties text extractor for the document properties metadata, such as title and author.
OPCPackage | getPackage() Returns the opened OPCPackage that contains the document
Methods inherited from class org.apache.poi.POITextExtractor
getText
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIXMLTextExtractor

public POIXMLTextExtractor(POIXMLDocument document)
Creates a new text extractor for the given document

Method Detail

getCoreProperties

public POIXMLProperties.CoreProperties getCoreProperties()
Returns the core document properties

getExtendedProperties

public POIXMLProperties.ExtendedProperties getExtendedProperties()
Returns the extended document properties

getCustomProperties

public POIXMLProperties.CustomProperties getCustomProperties()
Returns the custom document properties

getDocument

public final POIXMLDocument getDocument()
Returns opened document

getPackage

public OPCPackage getPackage()
Returns the opened OPCPackage that contains the document

getMetadataTextExtractor

public POIXMLPropertiesTextExtractor getMetadataTextExtractor()
Returns an OOXML properties text extractor for the document properties metadata, such as title and author.

Specified by:
getMetadataTextExtractor in class POITextExtractor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.EncryptedDocumentException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.EncryptedDocumentException

Packages that use EncryptedDocumentException
org.apache.poi.hslf.exceptions

Uses of EncryptedDocumentException in org.apache.poi.hslf.exceptions

Subclasses of EncryptedDocumentException in org.apache.poi.hslf.exceptions
 class EncryptedPowerPointFileException
This exception is thrown when we try to open a PowerPoint file, and discover that it is encrypted

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.OldFileFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.OldFileFormatException

Packages that use OldFileFormatException
org.apache.poi.hslf.exceptions |
org.apache.poi.hssf | Horrible SpreadSheet Format API's for reading/writting Excel files using pure Java.
org.apache.poi.hwpf |

Uses of OldFileFormatException in org.apache.poi.hslf.exceptions

Subclasses of OldFileFormatException in org.apache.poi.hslf.exceptions
 class OldPowerPointFormatException
This exception is thrown when we try to open a PowerPoint file, and it's too old for us.

Uses of OldFileFormatException in org.apache.poi.hssf

Subclasses of OldFileFormatException in org.apache.poi.hssf
 class OldExcelFormatException

Uses of OldFileFormatException in org.apache.poi.hwpf

Subclasses of OldFileFormatException in org.apache.poi.hwpf
 class OldWordFileFormatException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIDocument

Packages that use POIDocument
org.apache.poi |
org.apache.poi.hdgf |
org.apache.poi.hpbf |
org.apache.poi.hpsf.extractor |
org.apache.poi.hslf |
org.apache.poi.hsmf |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf |

Uses of POIDocument in org.apache.poi

Fields in org.apache.poi declared as POIDocument
protected  POIDocument POITextExtractor.document
The POIDocument that's open

Constructors in org.apache.poi with parameters of type POIDocument
POIOLE2TextExtractor(POIDocument document)
Creates a new text extractor for the given document
POITextExtractor(POIDocument document)
Creates a new text extractor for the given document

Uses of POIDocument in org.apache.poi.hdgf

Subclasses of POIDocument in org.apache.poi.hdgf
 class HDGFDiagram
See http://www.redferni.uklinux.net/visio/ http://www.gnome.ru/projects/docs/vsdocs.html http://www.gnome.ru/projects/docs/slide1.png http://www.gnome.ru/projects/docs/slide2.png

Uses of POIDocument in org.apache.poi.hpbf

Subclasses of POIDocument in org.apache.poi.hpbf
 class HPBFDocument
This class provides the basic functionality for HPBF, our implementation of the publisher file format.

Uses of POIDocument in org.apache.poi.hpsf.extractor

Constructors in org.apache.poi.hpsf.extractor with parameters of type POIDocument
HPSFPropertiesExtractor(POIDocument doc)

Uses of POIDocument in org.apache.poi.hslf

Subclasses of POIDocument in org.apache.poi.hslf
 class HSLFSlideShow
This class contains the main functionality for the Powerpoint file "reader".

Uses of POIDocument in org.apache.poi.hsmf

Subclasses of POIDocument in org.apache.poi.hsmf
 class MAPIMessage
Reads an Outlook MSG File in and provides hooks into its data structure.

Uses of POIDocument in org.apache.poi.hssf.usermodel

Subclasses of POIDocument in org.apache.poi.hssf.usermodel
 class HSSFWorkbook
High level representation of a workbook.

Uses of POIDocument in org.apache.poi.hwpf

Subclasses of POIDocument in org.apache.poi.hwpf
class | HWPFDocument This class acts as the bucket that we throw all of the Word data structures into.
class | HWPFDocumentCore This class holds much of the core of a Word document, but without some of the table structure information.
class | HWPFOldDocument Provides very simple support for old (Word 6 / Word 95) files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIOLE2TextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIOLE2TextExtractor

Packages that use POIOLE2TextExtractor
org.apache.poi.extractor
org.apache.poi.hdgf.extractor
org.apache.poi.hpbf.extractor
org.apache.poi.hslf.extractor
org.apache.poi.hsmf.extractor
org.apache.poi.hssf.extractor
org.apache.poi.hwpf.extractor

Uses of POIOLE2TextExtractor in org.apache.poi.extractor

Methods in org.apache.poi.extractor that return POIOLE2TextExtractor
static POIOLE2TextExtractor ExtractorFactory.createExtractor(POIFSFileSystem fs)

Methods in org.apache.poi.extractor with parameters of type POIOLE2TextExtractor
static POITextExtractor[] ExtractorFactory.getEmbededDocsTextExtractors(POIOLE2TextExtractor ext)
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).

Uses of POIOLE2TextExtractor in org.apache.poi.hdgf.extractor

Subclasses of POIOLE2TextExtractor in org.apache.poi.hdgf.extractor
 class VisioTextExtractor
Class to find all the text in a Visio file, and return it.

Uses of POIOLE2TextExtractor in org.apache.poi.hpbf.extractor

Subclasses of POIOLE2TextExtractor in org.apache.poi.hpbf.extractor
 class PublisherTextExtractor
Extract text from HPBF Publisher files

Uses of POIOLE2TextExtractor in org.apache.poi.hslf.extractor

Subclasses of POIOLE2TextExtractor in org.apache.poi.hslf.extractor
 class PowerPointExtractor
This class can be used to extract text from a PowerPoint file.

Uses of POIOLE2TextExtractor in org.apache.poi.hsmf.extractor

Subclasses of POIOLE2TextExtractor in org.apache.poi.hsmf.extractor
 class OutlookTextExtactor
A text extractor for HSMF (Outlook) .msg files.

Uses of POIOLE2TextExtractor in org.apache.poi.hssf.extractor

Subclasses of POIOLE2TextExtractor in org.apache.poi.hssf.extractor
class | EventBasedExcelExtractor A text extractor for Excel files, that is based on the hssf eventusermodel api.
class | ExcelExtractor A text extractor for Excel files.

Uses of POIOLE2TextExtractor in org.apache.poi.hwpf.extractor

Subclasses of POIOLE2TextExtractor in org.apache.poi.hwpf.extractor
class | Word6Extractor Class to extract the text from old (Word 6 / Word 95) Word Documents.
class | WordExtractor Class to extract the text from a Word Document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POITextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POITextExtractor

Packages that use POITextExtractor
org.apache.poi
org.apache.poi.extractor
org.apache.poi.hdgf.extractor
org.apache.poi.hpbf.extractor
org.apache.poi.hpsf.extractor
org.apache.poi.hslf.extractor
org.apache.poi.hsmf.extractor
org.apache.poi.hssf.extractor
org.apache.poi.hwpf.extractor
org.apache.poi.xslf.extractor
org.apache.poi.xssf.extractor
org.apache.poi.xwpf.extractor

Uses of POITextExtractor in org.apache.poi

Subclasses of POITextExtractor in org.apache.poi
class | POIOLE2TextExtractor Common Parent for OLE2 based Text Extractors of POI Documents, such as .doc, .xls You will typically find the implementation of a given format's text extractor under org.apache.poi.[format].extractor .
class | POIXMLPropertiesTextExtractor A POITextExtractor for returning the textual content of the OOXML file properties, eg author and title.
class | POIXMLTextExtractor

Methods in org.apache.poi that return POITextExtractor
abstract POITextExtractor | POITextExtractor.getMetadataTextExtractor() Returns another text extractor, which is able to output the textual content of the document metadata / properties, such as author and title.
POITextExtractor | POIOLE2TextExtractor.getMetadataTextExtractor() Returns an HPSF powered text extractor for the document properties metadata, such as title and author.

Constructors in org.apache.poi with parameters of type POITextExtractor
POITextExtractor(POITextExtractor otherExtractor)
Creates a new text extractor, using the same document as another text extractor.

Uses of POITextExtractor in org.apache.poi.extractor

Methods in org.apache.poi.extractor that return POITextExtractor
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir)
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use ExtractorFactory.createExtractor(DirectoryNode) instead
static POITextExtractor ExtractorFactory.createExtractor(java.io.File f)
static POITextExtractor ExtractorFactory.createExtractor(java.io.InputStream inp)
static POITextExtractor[] ExtractorFactory.getEmbededDocsTextExtractors(POIOLE2TextExtractor ext)
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).
static POITextExtractor[] ExtractorFactory.getEmbededDocsTextExtractors(POIXMLTextExtractor ext)
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).

Uses of POITextExtractor in org.apache.poi.hdgf.extractor

Subclasses of POITextExtractor in org.apache.poi.hdgf.extractor
 class VisioTextExtractor
Class to find all the text in a Visio file, and return it.

Uses of POITextExtractor in org.apache.poi.hpbf.extractor

Subclasses of POITextExtractor in org.apache.poi.hpbf.extractor
 class PublisherTextExtractor
Extract text from HPBF Publisher files

Uses of POITextExtractor in org.apache.poi.hpsf.extractor

Subclasses of POITextExtractor in org.apache.poi.hpsf.extractor
 class HPSFPropertiesExtractor
Extracts all of the HPSF properties, both build in and custom, returning them in textual form.

Methods in org.apache.poi.hpsf.extractor that return POITextExtractor
 POITextExtractor HPSFPropertiesExtractor.getMetadataTextExtractor()
Prevent recursion!

Constructors in org.apache.poi.hpsf.extractor with parameters of type POITextExtractor
HPSFPropertiesExtractor(POITextExtractor mainExtractor)

Uses of POITextExtractor in org.apache.poi.hslf.extractor

Subclasses of POITextExtractor in org.apache.poi.hslf.extractor
 class PowerPointExtractor
This class can be used to extract text from a PowerPoint file.

Uses of POITextExtractor in org.apache.poi.hsmf.extractor

Subclasses of POITextExtractor in org.apache.poi.hsmf.extractor
 class OutlookTextExtactor
A text extractor for HSMF (Outlook) .msg files.

Uses of POITextExtractor in org.apache.poi.hssf.extractor

Subclasses of POITextExtractor in org.apache.poi.hssf.extractor
class | EventBasedExcelExtractor A text extractor for Excel files, that is based on the hssf eventusermodel api.
class | ExcelExtractor A text extractor for Excel files.

Uses of POITextExtractor in org.apache.poi.hwpf.extractor

Subclasses of POITextExtractor in org.apache.poi.hwpf.extractor
class | Word6Extractor Class to extract the text from old (Word 6 / Word 95) Word Documents.
class | WordExtractor Class to extract the text from a Word Document.

Uses of POITextExtractor in org.apache.poi.xslf.extractor

Subclasses of POITextExtractor in org.apache.poi.xslf.extractor
 class XSLFPowerPointExtractor

Uses of POITextExtractor in org.apache.poi.xssf.extractor

Subclasses of POITextExtractor in org.apache.poi.xssf.extractor
class | XSSFEventBasedExcelExtractor Implementation of a text extractor from OOXML Excel files that uses SAX event based parsing.
class | XSSFExcelExtractor Helper class to extract text from an OOXML Excel file

Uses of POITextExtractor in org.apache.poi.xwpf.extractor

Subclasses of POITextExtractor in org.apache.poi.xwpf.extractor
 class XWPFWordExtractor
Helper class to extract text from an OOXML Word file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLDocument

Packages that use POIXMLDocument
org.apache.poi
org.apache.poi.xslf
org.apache.poi.xslf.usermodel
org.apache.poi.xssf.usermodel
org.apache.poi.xwpf.usermodel

Uses of POIXMLDocument in org.apache.poi

Methods in org.apache.poi that return POIXMLDocument
 POIXMLDocument POIXMLTextExtractor.getDocument()
Returns opened document

Constructors in org.apache.poi with parameters of type POIXMLDocument
POIXMLPropertiesTextExtractor(POIXMLDocument doc)
Creates a new POIXMLPropertiesTextExtractor for the given open document.
POIXMLTextExtractor(POIXMLDocument document)
Creates a new text extractor for the given document

Uses of POIXMLDocument in org.apache.poi.xslf

Subclasses of POIXMLDocument in org.apache.poi.xslf
 class XSLFSlideShow
Experimental class to do low level processing of pptx files.

Uses of POIXMLDocument in org.apache.poi.xslf.usermodel

Subclasses of POIXMLDocument in org.apache.poi.xslf.usermodel
 class XMLSlideShow
High level representation of a ooxml slideshow.

Uses of POIXMLDocument in org.apache.poi.xssf.usermodel

Subclasses of POIXMLDocument in org.apache.poi.xssf.usermodel
 class XSSFWorkbook
High level representation of a SpreadsheetML workbook.

Uses of POIXMLDocument in org.apache.poi.xwpf.usermodel

Subclasses of POIXMLDocument in org.apache.poi.xwpf.usermodel
 class XWPFDocument
Experimental class to do low level processing of docx files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLDocumentPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLDocumentPart

Packages that use POIXMLDocumentPart
org.apache.poi
org.apache.poi.xslf
org.apache.poi.xslf.usermodel
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel
org.apache.poi.xwpf.usermodel

Uses of POIXMLDocumentPart in org.apache.poi

Subclasses of POIXMLDocumentPart in org.apache.poi
 class POIXMLDocument

Methods in org.apache.poi that return POIXMLDocumentPart
abstract  POIXMLDocumentPart POIXMLFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
Create a POIXMLDocumentPart from existing package part and relation.
 POIXMLDocumentPart POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory)
Create a new child POIXMLDocumentPart
 POIXMLDocumentPart POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx)
protected  POIXMLDocumentPart POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx, boolean noRelation)
Create a new child POIXMLDocumentPart
 POIXMLDocumentPart POIXMLDocumentPart.getParent()
Returns the parent POIXMLDocumentPart.
 POIXMLDocumentPart POIXMLDocumentPart.getRelationById(java.lang.String id)
Returns the target POIXMLDocumentPart, where a PackageRelationship is set from the PackagePart of this POIXMLDocumentPart to the PackagePart of the target POIXMLDocumentPart with a PackageRelationship.getId() matching the given parameter value.
abstract  POIXMLDocumentPart POIXMLFactory.newDocumentPart(POIXMLRelation descriptor)
Create a new POIXMLDocumentPart using the supplied descriptor.

Methods in org.apache.poi that return types with arguments of type POIXMLDocumentPart
java.lang.Class<? extends POIXMLDocumentPart> | POIXMLRelation.getRelationClass() Return type of the obejct used to construct instances of this relationship
java.util.List<POIXMLDocumentPart> | POIXMLDocumentPart.getRelations() Returns the list of child relations for this POIXMLDocumentPart

Methods in org.apache.poi with parameters of type POIXMLDocumentPart
 void POIXMLDocumentPart.addRelation(java.lang.String id, POIXMLDocumentPart part)
Add a new child POIXMLDocumentPart
abstract  POIXMLDocumentPart POIXMLFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
Create a POIXMLDocumentPart from existing package part and relation.
 java.lang.String POIXMLDocumentPart.getRelationId(POIXMLDocumentPart part)
Returns the PackageRelationship.getId() of the PackageRelationship, that sources from the PackagePart of this POIXMLDocumentPart to the PackagePart of the given parameter value.
protected  void POIXMLDocumentPart.removeRelation(POIXMLDocumentPart part)
Remove the relation to the specified part in this package and remove the part, if it is no longer needed.
protected  boolean POIXMLDocumentPart.removeRelation(POIXMLDocumentPart part, boolean removeUnusedParts)
Remove the relation to the specified part in this package and remove the part, if it is no longer needed and flag is set to true.

Method parameters in org.apache.poi with type arguments of type POIXMLDocumentPart
protected  void POIXMLDocumentPart.read(POIXMLFactory factory, java.util.Map<PackagePart,POIXMLDocumentPart> context)
Iterate through the underlying PackagePart and create child POIXMLFactory instances using the specified factory

Constructors in org.apache.poi with parameters of type POIXMLDocumentPart
POIXMLDocumentPart(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part, relationship and parent Called by read(POIXMLFactory, java.util.Map) when reading in an exisiting file.

Constructor parameters in org.apache.poi with type arguments of type POIXMLDocumentPart
POIXMLRelation(java.lang.String type, java.lang.String rel, java.lang.String defaultName, java.lang.Class<? extends POIXMLDocumentPart> cls)
Instantiates a POIXMLRelation.

Uses of POIXMLDocumentPart in org.apache.poi.xslf

Subclasses of POIXMLDocumentPart in org.apache.poi.xslf
 class XSLFSlideShow
Experimental class to do low level processing of pptx files.

Uses of POIXMLDocumentPart in org.apache.poi.xslf.usermodel

Subclasses of POIXMLDocumentPart in org.apache.poi.xslf.usermodel
class | XMLSlideShow High level representation of a ooxml slideshow.
class | XSLFCommentAuthors
class | XSLFComments
class | XSLFNotes
class | XSLFNotesMaster Notes master object associated with this layout.
class | XSLFPictureData Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
class | XSLFSheet
class | XSLFSlide
class | XSLFSlideLayout
class | XSLFSlideMaster Slide master object associated with this layout.
class | XSLFTableStyles
class | XSLFTheme A shared style sheet in a .pptx slide show

Methods in org.apache.poi.xslf.usermodel that return POIXMLDocumentPart
POIXMLDocumentPart | XSLFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
POIXMLDocumentPart | XSLFFactory.newDocumentPart(POIXMLRelation descriptor)

Methods in org.apache.poi.xslf.usermodel with parameters of type POIXMLDocumentPart
 POIXMLDocumentPart XSLFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)

Uses of POIXMLDocumentPart in org.apache.poi.xssf.model

Subclasses of POIXMLDocumentPart in org.apache.poi.xssf.model
class | CalculationChain The cells in a workbook can be calculated in different orders depending on various optimizations and dependencies.
class | CommentsTable
class | MapInfo This class implements the Custom XML Mapping Part (Open Office XML Part 1: chapter 12.3.6) An instance of this part type contains a schema for an XML file, and information on the behavior that is used when allowing this custom XML schema to be mapped into the spreadsheet.
class | SharedStringsTable Table of strings shared across all sheets in a workbook.
class | SingleXmlCells This class implements the Single Cell Tables Part (Open Office XML Part 4: chapter 3.5.2)
class | StylesTable Table of styles shared across all sheets in a workbook.
class | ThemesTable Class that represents theme of XLSX document.

Uses of POIXMLDocumentPart in org.apache.poi.xssf.usermodel

Subclasses of POIXMLDocumentPart in org.apache.poi.xssf.usermodel
class | XSSFChart Represents a SpreadsheetML Chart
class | XSSFChartSheet High level representation of Sheet Parts that are of type 'chartsheet'.
class | XSSFDialogsheet
class | XSSFDrawing Represents a SpreadsheetML drawing
class | XSSFPictureData Raw picture data, normally attached to a SpreadsheetML Drawing.
class | XSSFSheet High level representation of a SpreadsheetML worksheet.
class | XSSFTable This class implements the Table Part (Open Office XML Part 4: chapter 3.5.1) This implementation works under the assumption that a table contains mappings to a subtree of an XML.
class | XSSFVMLDrawing Represents a SpreadsheetML VML drawing.
class | XSSFWorkbook High level representation of a SpreadsheetML workbook.

Methods in org.apache.poi.xssf.usermodel that return POIXMLDocumentPart
POIXMLDocumentPart | XSSFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
POIXMLDocumentPart | XSSFFactory.newDocumentPart(POIXMLRelation descriptor)

Methods in org.apache.poi.xssf.usermodel with parameters of type POIXMLDocumentPart
 POIXMLDocumentPart XSSFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)

Uses of POIXMLDocumentPart in org.apache.poi.xwpf.usermodel

Subclasses of POIXMLDocumentPart in org.apache.poi.xwpf.usermodel
class | XWPFDocument Experimental class to do low level processing of docx files.
class | XWPFFooter Sketch of XWPF footer class
class | XWPFFootnotes Looks after the collection of Footnotes for a document
class | XWPFHeader Sketch of XWPF header class
class | XWPFHeaderFooter Parent of XWPF headers and footers
class | XWPFNumbering
class | XWPFPictureData
class | XWPFSettings
class | XWPFStyles

Methods in org.apache.poi.xwpf.usermodel that return POIXMLDocumentPart
POIXMLDocumentPart | XWPFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
POIXMLDocumentPart | XWPFHeaderFooter.getOwner()
POIXMLDocumentPart | XWPFFootnote.getOwner()
POIXMLDocumentPart | XWPFTableCell.getPart() get the to which the TableCell belongs
POIXMLDocumentPart | XWPFTable.getPart() returns the part of the bodyElement
POIXMLDocumentPart | XWPFParagraph.getPart() returns the part of the bodyElement
POIXMLDocumentPart | XWPFHeaderFooter.getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts
POIXMLDocumentPart | XWPFFootnote.getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts
POIXMLDocumentPart | XWPFDocument.getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell.
POIXMLDocumentPart | IBodyElement.getPart()
POIXMLDocumentPart | IBody.getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell.
POIXMLDocumentPart | XWPFFactory.newDocumentPart(POIXMLRelation descriptor)

Methods in org.apache.poi.xwpf.usermodel with parameters of type POIXMLDocumentPart
 POIXMLDocumentPart XWPFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)

Constructors in org.apache.poi.xwpf.usermodel with parameters of type POIXMLDocumentPart
XWPFFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFHeader(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFHeaderFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLException

No usage of org.apache.poi.POIXMLException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLFactory

Packages that use POIXMLFactory
org.apache.poi
org.apache.poi.xslf.usermodel
org.apache.poi.xssf.usermodel
org.apache.poi.xwpf.usermodel

Uses of POIXMLFactory in org.apache.poi

Methods in org.apache.poi with parameters of type POIXMLFactory
POIXMLDocumentPart | POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory) Create a new child POIXMLDocumentPart
POIXMLDocumentPart | POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx)
protected POIXMLDocumentPart | POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx, boolean noRelation) Create a new child POIXMLDocumentPart
protected void | POIXMLDocument.load(POIXMLFactory factory)
protected void | POIXMLDocumentPart.read(POIXMLFactory factory, java.util.Map<PackagePart,POIXMLDocumentPart> context) Iterate through the underlying PackagePart and create child POIXMLFactory instances using the specified factory

Uses of POIXMLFactory in org.apache.poi.xslf.usermodel

Subclasses of POIXMLFactory in org.apache.poi.xslf.usermodel
 class XSLFFactory
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type

Uses of POIXMLFactory in org.apache.poi.xssf.usermodel

Subclasses of POIXMLFactory in org.apache.poi.xssf.usermodel
 class XSSFFactory
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type

Uses of POIXMLFactory in org.apache.poi.xwpf.usermodel

Subclasses of POIXMLFactory in org.apache.poi.xwpf.usermodel
 class XWPFFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLProperties.CoreProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLProperties.CoreProperties

Packages that use POIXMLProperties.CoreProperties
org.apache.poi
org.apache.poi.xssf.extractor

Uses of POIXMLProperties.CoreProperties in org.apache.poi

Methods in org.apache.poi that return POIXMLProperties.CoreProperties
POIXMLProperties.CoreProperties | POIXMLTextExtractor.getCoreProperties() Returns the core document properties
POIXMLProperties.CoreProperties | POIXMLProperties.getCoreProperties() Returns the core document properties

Uses of POIXMLProperties.CoreProperties in org.apache.poi.xssf.extractor

Methods in org.apache.poi.xssf.extractor that return POIXMLProperties.CoreProperties
 POIXMLProperties.CoreProperties XSSFEventBasedExcelExtractor.getCoreProperties()
Returns the core document properties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLProperties.CustomProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLProperties.CustomProperties

Packages that use POIXMLProperties.CustomProperties
org.apache.poi
org.apache.poi.xssf.extractor

Uses of POIXMLProperties.CustomProperties in org.apache.poi

Methods in org.apache.poi that return POIXMLProperties.CustomProperties
POIXMLProperties.CustomProperties | POIXMLTextExtractor.getCustomProperties() Returns the custom document properties
POIXMLProperties.CustomProperties | POIXMLProperties.getCustomProperties() Returns the custom document properties

Uses of POIXMLProperties.CustomProperties in org.apache.poi.xssf.extractor

Methods in org.apache.poi.xssf.extractor that return POIXMLProperties.CustomProperties
 POIXMLProperties.CustomProperties XSSFEventBasedExcelExtractor.getCustomProperties()
Returns the custom document properties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLProperties.ExtendedProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLProperties.ExtendedProperties

Packages that use POIXMLProperties.ExtendedProperties
org.apache.poi
org.apache.poi.xssf.extractor

Uses of POIXMLProperties.ExtendedProperties in org.apache.poi

Methods in org.apache.poi that return POIXMLProperties.ExtendedProperties
POIXMLProperties.ExtendedProperties | POIXMLTextExtractor.getExtendedProperties() Returns the extended document properties
POIXMLProperties.ExtendedProperties | POIXMLProperties.getExtendedProperties() Returns the extended document properties

Uses of POIXMLProperties.ExtendedProperties in org.apache.poi.xssf.extractor

Methods in org.apache.poi.xssf.extractor that return POIXMLProperties.ExtendedProperties
 POIXMLProperties.ExtendedProperties XSSFEventBasedExcelExtractor.getExtendedProperties()
Returns the extended document properties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLProperties

Packages that use POIXMLProperties
org.apache.poi

Uses of POIXMLProperties in org.apache.poi

Methods in org.apache.poi that return POIXMLProperties
 POIXMLProperties POIXMLDocument.getProperties()
Get the document properties.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLPropertiesTextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLPropertiesTextExtractor

Packages that use POIXMLPropertiesTextExtractor
org.apache.poi

Uses of POIXMLPropertiesTextExtractor in org.apache.poi

Methods in org.apache.poi that return POIXMLPropertiesTextExtractor
POIXMLPropertiesTextExtractor | POIXMLTextExtractor.getMetadataTextExtractor() Returns an OOXML properties text extractor for the document properties metadata, such as title and author.
POIXMLPropertiesTextExtractor | POIXMLPropertiesTextExtractor.getMetadataTextExtractor()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLRelation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLRelation

Packages that use POIXMLRelation
org.apache.poi
org.apache.poi.xslf.usermodel
org.apache.poi.xssf.usermodel
org.apache.poi.xwpf.usermodel

Uses of POIXMLRelation in org.apache.poi

Methods in org.apache.poi with parameters of type POIXMLRelation
POIXMLDocumentPart | POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory) Create a new child POIXMLDocumentPart
POIXMLDocumentPart | POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx)
protected POIXMLDocumentPart | POIXMLDocumentPart.createRelationship(POIXMLRelation descriptor, POIXMLFactory factory, int idx, boolean noRelation) Create a new child POIXMLDocumentPart
abstract POIXMLDocumentPart | POIXMLFactory.newDocumentPart(POIXMLRelation descriptor) Create a new POIXMLDocumentPart using the supplied descriptor.

Uses of POIXMLRelation in org.apache.poi.xslf.usermodel

Subclasses of POIXMLRelation in org.apache.poi.xslf.usermodel
 class XSLFRelation

Fields in org.apache.poi.xslf.usermodel declared as POIXMLRelation
protected static POIXMLRelation[] XSLFPictureData.RELATIONS
Relationships for each known picture type

Methods in org.apache.poi.xslf.usermodel with parameters of type POIXMLRelation
 POIXMLDocumentPart XSLFFactory.newDocumentPart(POIXMLRelation descriptor)

Uses of POIXMLRelation in org.apache.poi.xssf.usermodel

Subclasses of POIXMLRelation in org.apache.poi.xssf.usermodel
 class XSSFRelation

Fields in org.apache.poi.xssf.usermodel declared as POIXMLRelation
protected static POIXMLRelation[] XSSFPictureData.RELATIONS
Relationships for each known picture type

Methods in org.apache.poi.xssf.usermodel with parameters of type POIXMLRelation
 POIXMLDocumentPart XSSFFactory.newDocumentPart(POIXMLRelation descriptor)

Uses of POIXMLRelation in org.apache.poi.xwpf.usermodel

Subclasses of POIXMLRelation in org.apache.poi.xwpf.usermodel
 class XWPFRelation

Fields in org.apache.poi.xwpf.usermodel declared as POIXMLRelation
protected static POIXMLRelation[] XWPFPictureData.RELATIONS
Relationships for each known picture type

Methods in org.apache.poi.xwpf.usermodel with parameters of type POIXMLRelation
 POIXMLDocumentPart XWPFFactory.newDocumentPart(POIXMLRelation descriptor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.POIXMLTextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.POIXMLTextExtractor

Packages that use POIXMLTextExtractor
org.apache.poi
org.apache.poi.extractor
org.apache.poi.xslf.extractor
org.apache.poi.xssf.extractor
org.apache.poi.xwpf.extractor

Uses of POIXMLTextExtractor in org.apache.poi

Subclasses of POIXMLTextExtractor in org.apache.poi
 class POIXMLPropertiesTextExtractor
A POITextExtractor for returning the textual content of the OOXML file properties, eg author and title.

Constructors in org.apache.poi with parameters of type POIXMLTextExtractor
POIXMLPropertiesTextExtractor(POIXMLTextExtractor otherExtractor)
Creates a new POIXMLPropertiesTextExtractor, for the same file that another TextExtractor is already working on.

Uses of POIXMLTextExtractor in org.apache.poi.extractor

Methods in org.apache.poi.extractor that return POIXMLTextExtractor
static POIXMLTextExtractor ExtractorFactory.createExtractor(OPCPackage pkg)

Methods in org.apache.poi.extractor with parameters of type POIXMLTextExtractor
static POITextExtractor[] ExtractorFactory.getEmbededDocsTextExtractors(POIXMLTextExtractor ext)
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).

Uses of POIXMLTextExtractor in org.apache.poi.xslf.extractor

Subclasses of POIXMLTextExtractor in org.apache.poi.xslf.extractor
 class XSLFPowerPointExtractor

Uses of POIXMLTextExtractor in org.apache.poi.xssf.extractor

Subclasses of POIXMLTextExtractor in org.apache.poi.xssf.extractor
class | XSSFEventBasedExcelExtractor Implementation of a text extractor from OOXML Excel files that uses SAX event based parsing.
class | XSSFExcelExtractor Helper class to extract text from an OOXML Excel file

Uses of POIXMLTextExtractor in org.apache.poi.xwpf.extractor

Subclasses of POIXMLTextExtractor in org.apache.poi.xwpf.extractor
 class XWPFWordExtractor
Helper class to extract text from an OOXML Word file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Fill

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.common.usermodel
Interface Fill

All Known Subinterfaces:
Fill
public interface Fill

Method Summary
java.awt.Color | getColor()
void | setColor(java.awt.Color color)

Method Detail

getColor

java.awt.Color getColor()

setColor

void setColor(java.awt.Color color)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Hyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.common.usermodel
Interface Hyperlink

All Known Subinterfaces:
Hyperlink, Hyperlink
All Known Implementing Classes:
HSSFHyperlink, XSSFHyperlink
public interface Hyperlink

Represents a hyperlink.

Field Summary
static int | LINK_DOCUMENT Link to a place in this document
static int | LINK_EMAIL Link to an E-mail address
static int | LINK_FILE Link to a file
static int | LINK_URL Link to a existing file or web page
Method Summary
java.lang.String | getAddress() Hypelink address.
java.lang.String | getLabel() Return text label for this hyperlink
int | getType() Return the type of this hyperlink
void | setAddress(java.lang.String address) Hypelink address.
void | setLabel(java.lang.String label) Sets text label for this hyperlink

Field Detail

LINK_URL

static final int LINK_URL
Link to a existing file or web page

See Also:
Constant Field Values

LINK_DOCUMENT

static final int LINK_DOCUMENT
Link to a place in this document

See Also:
Constant Field Values

LINK_EMAIL

static final int LINK_EMAIL
Link to an E-mail address

See Also:
Constant Field Values

LINK_FILE

static final int LINK_FILE
Link to a file

See Also:
Constant Field Values
Method Detail

getAddress

java.lang.String getAddress()
Hypelink address. Depending on the hyperlink type it can be URL, e-mail, patrh to a file, etc.

Returns:
the address of this hyperlink

setAddress

void setAddress(java.lang.String address)
Hypelink address. Depending on the hyperlink type it can be URL, e-mail, patrh to a file, etc.

Parameters:
address - the address of this hyperlink

getLabel

java.lang.String getLabel()
Return text label for this hyperlink

Returns:
text to display

setLabel

void setLabel(java.lang.String label)
Sets text label for this hyperlink

Parameters:
label - text label for this hyperlink

getType

int getType()
Return the type of this hyperlink

Returns:
the type of this hyperlink
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineStyle

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.common.usermodel
Interface LineStyle

All Known Subinterfaces:
LineStyle
public interface LineStyle

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.common.usermodel
Interfaces
Fill
Hyperlink
LineStyle


org.apache.poi.common.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.common.usermodel

Interface Summary
Fill |
Hyperlink | Represents a hyperlink.
LineStyle |

Overview Package Class Use Tree Deprecated Index Help


org.apache.poi.common.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.common.usermodel

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.apache.poi.common.usermodel.Fill
  • org.apache.poi.common.usermodel.Hyperlink
  • org.apache.poi.common.usermodel.LineStyle


Uses of Package org.apache.poi.common.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.common.usermodel

Packages that use org.apache.poi.common.usermodel
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.sl.usermodel |
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Classes in org.apache.poi.common.usermodel used by org.apache.poi.hssf.usermodel
Hyperlink
Represents a hyperlink.

Classes in org.apache.poi.common.usermodel used by org.apache.poi.sl.usermodel
Fill
LineStyle

Classes in org.apache.poi.common.usermodel used by org.apache.poi.ss.usermodel
Hyperlink
Represents a hyperlink.

Classes in org.apache.poi.common.usermodel used by org.apache.poi.xssf.usermodel
Hyperlink
Represents a hyperlink.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.common.usermodel.Fill

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.common.usermodel.Fill

Packages that use Fill
org.apache.poi.sl.usermodel

Uses of Fill in org.apache.poi.sl.usermodel

Subinterfaces of Fill in org.apache.poi.sl.usermodel
 interface Fill

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.common.usermodel.Hyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.common.usermodel.Hyperlink

Packages that use Hyperlink
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of Hyperlink in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Hyperlink
 class HSSFHyperlink
Represents an Excel hyperlink.

Uses of Hyperlink in org.apache.poi.ss.usermodel

Subinterfaces of Hyperlink in org.apache.poi.ss.usermodel
 interface Hyperlink
Represents an Excel hyperlink.

Uses of Hyperlink in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Hyperlink
 class XSSFHyperlink
XSSF Implementation of a Hyperlink.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.common.usermodel.LineStyle

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.common.usermodel.LineStyle

Packages that use LineStyle
org.apache.poi.sl.usermodel

Uses of LineStyle in org.apache.poi.sl.usermodel

Subinterfaces of LineStyle in org.apache.poi.sl.usermodel
 interface LineStyle

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractEscherOptRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class AbstractEscherOptRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.AbstractEscherOptRecord
Direct Known Subclasses:
EscherOptRecord, EscherTertiaryOptRecord
public abstract class AbstractEscherOptRecord
extends EscherRecord

Common abstract class for EscherOptRecord and EscherTertiaryOptRecord

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com), Glen Stampoultzis

Field Summary
protected  java.util.List<EscherProperty> properties
Constructor Summary
AbstractEscherOptRecord()
Method Summary
 void addEscherProperty(EscherProperty prop)
Add a property to this record.
 int fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
The contract of this method is to deserialize an escher record including it's children.
 java.util.List<EscherProperty> getEscherProperties()
The list of properties stored by this record.
 EscherProperty getEscherProperty(int index)
The list of properties stored by this record.
 int getRecordSize()
Subclasses should effeciently return the number of bytes required to serialize the record.
<T extends EscherProperty>
T
lookup(int propId)
 int serialize(int offset, byte[] data, EscherSerializationListener listener)
Serializes the record to an existing byte array.
 void sortProperties()
Records should be sorted by property number before being stored.
 java.lang.String toString()
Retrieve the string representation of this record.
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getRecordName, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

properties

protected java.util.List<EscherProperty> properties
Constructor Detail

AbstractEscherOptRecord

public AbstractEscherOptRecord()
Method Detail

addEscherProperty

public void addEscherProperty(EscherProperty prop)
Add a property to this record.

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

getEscherProperties

public java.util.List<EscherProperty> getEscherProperties()
The list of properties stored by this record.

getEscherProperty

public EscherProperty getEscherProperty(int index)
The list of properties stored by this record.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

lookup

public <T extends EscherProperty> T lookup(int propId)

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

sortProperties

public void sortProperties()
Records should be sorted by property number before being stored.

toString

public java.lang.String toString()
Retrieve the string representation of this record.

Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultEscherRecordFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class DefaultEscherRecordFactory

java.lang.Object
    extended by  org.apache.poi.ddf.DefaultEscherRecordFactory
All Implemented Interfaces:
EscherRecordFactory
public class DefaultEscherRecordFactory
extends java.lang.Object
implements EscherRecordFactory

Generates escher records when provided the byte array containing those records.

Author:
Glen Stampoultzis, Nick Burch (nick at torchbox . com)
See Also:
EscherRecordFactory

Constructor Summary
DefaultEscherRecordFactory()
Creates an instance of the escher record factory
Method Summary
 EscherRecord createRecord(byte[] data, int offset)
Generates an escher record including the any children contained under that record.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultEscherRecordFactory

public DefaultEscherRecordFactory()
Creates an instance of the escher record factory

Method Detail

createRecord

public EscherRecord createRecord(byte[] data,
                                 int offset)
Generates an escher record including the any children contained under that record. An exception is thrown if the record could not be generated.

Specified by:
createRecord in interface EscherRecordFactory
Parameters:
data - The byte array containing the records
offset - The starting offset into the byte array
Returns:
The generated escher record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherArrayProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherArrayProperty

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperty
        extended by  org.apache.poi.ddf.EscherComplexProperty
            extended by  org.apache.poi.ddf.EscherArrayProperty

public final class EscherArrayProperty
extends EscherComplexProperty

Escher array properties are the most wierd construction ever invented with all sorts of special cases. I'm hopeful I've got them all.

Author:
Glen Stampoultzis (glens at superlinksoftware.com)

Field Summary
Fields inherited from class org.apache.poi.ddf.EscherComplexProperty
_complexData
Constructor Summary
EscherArrayProperty(short propertyNumber, boolean isBlipId, byte[] complexData)
EscherArrayProperty(short id, byte[] complexData)
Method Summary
static int | getActualSizeOfElements(short sizeOfElements) Sometimes the element size is stored as a negative number.
byte[] | getElement(int index)
int | getNumberOfElementsInArray()
int | getNumberOfElementsInMemory()
short | getSizeOfElements()
int | serializeSimplePart(byte[] data, int pos) Serializes the simple part of this property.
int | setArrayData(byte[] data, int offset) We have this method because the way in which arrays in escher works is screwed for seemly arbitary reasons.
void | setElement(int index, byte[] element)
void | setNumberOfElementsInArray(int numberOfElements)
void | setNumberOfElementsInMemory(int numberOfElements)
void | setSizeOfElements(int sizeOfElements)
java.lang.String | toString() Retrieves the string representation for this property.
Methods inherited from class org.apache.poi.ddf.EscherComplexProperty
equals, getComplexData, getPropertySize, hashCode, serializeComplexPart
Methods inherited from class org.apache.poi.ddf.EscherProperty
getId, getName, getPropertyNumber, isBlipId, isComplex
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EscherArrayProperty

public EscherArrayProperty(short id,
                           byte[] complexData)

EscherArrayProperty

public EscherArrayProperty(short propertyNumber,
                           boolean isBlipId,
                           byte[] complexData)
Method Detail

getNumberOfElementsInArray

public int getNumberOfElementsInArray()

setNumberOfElementsInArray

public void setNumberOfElementsInArray(int numberOfElements)

getNumberOfElementsInMemory

public int getNumberOfElementsInMemory()

setNumberOfElementsInMemory

public void setNumberOfElementsInMemory(int numberOfElements)

getSizeOfElements

public short getSizeOfElements()

setSizeOfElements

public void setSizeOfElements(int sizeOfElements)

getElement

public byte[] getElement(int index)

setElement

public void setElement(int index,
                       byte[] element)

toString

public java.lang.String toString()
Description copied from class: EscherComplexProperty
Retrieves the string representation for this property.

Overrides:
toString in class EscherComplexProperty

setArrayData

public int setArrayData(byte[] data,
                        int offset)
We have this method because the way in which arrays in escher works is screwed for seemly arbitary reasons. While most properties are fairly consistent and have a predictable array size, escher arrays have special cases.

Parameters:
data - The data array containing the escher array information
offset - The offset into the array to start reading from.
Returns:
the number of bytes used by this complex property.

serializeSimplePart

public int serializeSimplePart(byte[] data,
                               int pos)
Serializes the simple part of this property. ie the first 6 bytes. Needs special code to handle the case when the size doesn't include the size of the header block

Overrides:
serializeSimplePart in class EscherComplexProperty

getActualSizeOfElements

public static int getActualSizeOfElements(short sizeOfElements)
Sometimes the element size is stored as a negative number. We negate it and shift it to get the real value.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherBitmapBlip

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherBitmapBlip

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherBlipRecord
            extended by  org.apache.poi.ddf.EscherBitmapBlip

public class EscherBitmapBlip
extends EscherBlipRecord

Author:
Glen Stampoultzis

Field Summary
static short | RECORD_ID_DIB
static short | RECORD_ID_JPEG
static short | RECORD_ID_PNG
Fields inherited from class org.apache.poi.ddf.EscherBlipRecord
field_pictureData, RECORD_DESCRIPTION, RECORD_ID_END, RECORD_ID_START
Constructor Summary
EscherBitmapBlip()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
byte | getMarker()
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
byte[] | getUID()
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setMarker(byte field_2_marker)
void | setUID(byte[] field_1_UID)
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherBlipRecord
getPicturedata, getRecordName, setPictureData
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID_JPEG

public static final short RECORD_ID_JPEG
See Also:
Constant Field Values

RECORD_ID_PNG

public static final short RECORD_ID_PNG
See Also:
Constant Field Values

RECORD_ID_DIB

public static final short RECORD_ID_DIB
See Also:
Constant Field Values
Constructor Detail

EscherBitmapBlip

public EscherBitmapBlip()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Overrides:
fillFields in class EscherBlipRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Overrides:
serialize in class EscherBlipRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Overrides:
getRecordSize in class EscherBlipRecord
Returns:
number of bytes

getUID

public byte[] getUID()

setUID

public void setUID(byte[] field_1_UID)

getMarker

public byte getMarker()

setMarker

public void setMarker(byte field_2_marker)

toString

public java.lang.String toString()
Overrides:
toString in class EscherBlipRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherBlipRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherBlipRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherBlipRecord
Direct Known Subclasses:
EscherBitmapBlip, EscherBlipWMFRecord, EscherMetafileBlip, EscherPictBlip
public class EscherBlipRecord
extends EscherRecord

Author:
Glen Stampoultzis

Field Summary
protected byte[] | field_pictureData
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID_END
static short | RECORD_ID_START
Constructor Summary
EscherBlipRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
byte[] | getPicturedata()
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setPictureData(byte[] pictureData)
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID_START

public static final short RECORD_ID_START
See Also:
Constant Field Values

RECORD_ID_END

public static final short RECORD_ID_END
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values

field_pictureData

protected byte[] field_pictureData
Constructor Detail

EscherBlipRecord

public EscherBlipRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

getPicturedata

public byte[] getPicturedata()

setPictureData

public void setPictureData(byte[] pictureData)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherBlipWMFRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherBlipWMFRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherBlipRecord
            extended by  org.apache.poi.ddf.EscherBlipWMFRecord

public class EscherBlipWMFRecord
extends EscherBlipRecord

The blip record is used to hold details about large binary objects that occur in escher such as JPEG, GIF, PICT and WMF files. The contents of the stream is usually compressed. Inflate can be used to decompress the data.

Author:
Glen Stampoultzis
See Also:
Inflater

Field Summary
static java.lang.String RECORD_DESCRIPTION
Fields inherited from class org.apache.poi.ddf.EscherBlipRecord
field_pictureData, RECORD_ID_END, RECORD_ID_START
Constructor Summary
EscherBlipWMFRecord()
Method Summary
static byte[] | compress(byte[] data) Compress the contents of the provided array
static byte[] | decompress(byte[] data, int pos, int length) Decompresses a byte array.
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
int | getBoundaryHeight() Retrieve the boundary height of the metafile drawing commands
int | getBoundaryLeft() Retrieve the left boundary of the metafile drawing commands
int | getBoundaryTop() Retrieve the top boundary of the metafile drawing commands
int | getBoundaryWidth() Retrieve the boundary width of the metafile drawing commands
int | getCacheOfSavedSize() Retrieve the cache of the saved size
int | getCacheOfSize() Retrieve the cache of the metafile size
byte | getCompressionFlag() Is the contents of the blip compressed?
byte[] | getData() The BLIP data
byte | getFilter() Filter should always be 0
int | getHeight() Retrieve the height of the metafile in EMU's (English Metric Units).
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
byte[] | getSecondaryUID() Retrieve the secondary UID
int | getWidth() Retrieve the width of the metafile in EMU's (English Metric Units).
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setBoundaryHeight(int field_6_boundaryHeight) Set the boundary height of the metafile drawing commands
void | setBoundaryLeft(int field_4_boundaryLeft) Set the left boundary of the metafile drawing commands
void | setBoundaryTop(int field_3_boundaryTop) Set the top boundary of the metafile drawing commands
void | setBoundaryWidth(int field_5_boundaryWidth) Set the boundary width of the metafile drawing commands
void | setCacheOfSavedSize(int field_9_cacheOfSavedSize) Set the cache of the saved size
void | setCacheOfSize(int field_2_cacheOfSize) Set the cache of the metafile size
void | setCompressionFlag(byte field_10_compressionFlag) Set whether the contents of the blip is compressed
void | setData(byte[] field_12_data) The BLIP data
void | setFilter(byte field_11_filter) Filter should always be 0
void | setHeight(int height) Set the height of the metafile in EMU's (English Metric Units).
void | setSecondaryUID(byte[] field_1_secondaryUID) Set the secondary UID
void | setWidth(int width) Set the width of the metafile in EMU's (English Metric Units).
java.lang.String | toString() The string representation of this record.
Methods inherited from class org.apache.poi.ddf.EscherBlipRecord
getPicturedata, setPictureData
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherBlipWMFRecord

public EscherBlipWMFRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Overrides:
fillFields in class EscherBlipRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Overrides:
serialize in class EscherBlipRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Overrides:
getRecordSize in class EscherBlipRecord
Returns:
number of bytes

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Overrides:
getRecordName in class EscherBlipRecord

getSecondaryUID

public byte[] getSecondaryUID()
Retrieve the secondary UID

setSecondaryUID

public void setSecondaryUID(byte[] field_1_secondaryUID)
Set the secondary UID

getCacheOfSize

public int getCacheOfSize()
Retrieve the cache of the metafile size

setCacheOfSize

public void setCacheOfSize(int field_2_cacheOfSize)
Set the cache of the metafile size

getBoundaryTop

public int getBoundaryTop()
Retrieve the top boundary of the metafile drawing commands

setBoundaryTop

public void setBoundaryTop(int field_3_boundaryTop)
Set the top boundary of the metafile drawing commands

getBoundaryLeft

public int getBoundaryLeft()
Retrieve the left boundary of the metafile drawing commands

setBoundaryLeft

public void setBoundaryLeft(int field_4_boundaryLeft)
Set the left boundary of the metafile drawing commands

getBoundaryWidth

public int getBoundaryWidth()
Retrieve the boundary width of the metafile drawing commands

setBoundaryWidth

public void setBoundaryWidth(int field_5_boundaryWidth)
Set the boundary width of the metafile drawing commands

getBoundaryHeight

public int getBoundaryHeight()
Retrieve the boundary height of the metafile drawing commands

setBoundaryHeight

public void setBoundaryHeight(int field_6_boundaryHeight)
Set the boundary height of the metafile drawing commands

getWidth

public int getWidth()
Retrieve the width of the metafile in EMU's (English Metric Units).

setWidth

public void setWidth(int width)
Set the width of the metafile in EMU's (English Metric Units).

getHeight

public int getHeight()
Retrieve the height of the metafile in EMU's (English Metric Units).

setHeight

public void setHeight(int height)
Set the height of the metafile in EMU's (English Metric Units).

getCacheOfSavedSize

public int getCacheOfSavedSize()
Retrieve the cache of the saved size

setCacheOfSavedSize

public void setCacheOfSavedSize(int field_9_cacheOfSavedSize)
Set the cache of the saved size

getCompressionFlag

public byte getCompressionFlag()
Is the contents of the blip compressed?

setCompressionFlag

public void setCompressionFlag(byte field_10_compressionFlag)
Set whether the contents of the blip is compressed

getFilter

public byte getFilter()
Filter should always be 0

setFilter

public void setFilter(byte field_11_filter)
Filter should always be 0

getData

public byte[] getData()
The BLIP data

setData

public void setData(byte[] field_12_data)
The BLIP data

toString

public java.lang.String toString()
The string representation of this record.

Overrides:
toString in class EscherBlipRecord
Returns:
A string

compress

public static byte[] compress(byte[] data)
Compress the contents of the provided array

Parameters:
data - An uncompressed byte array
See Also:
DeflaterOutputStream.write(int b)

decompress

public static byte[] decompress(byte[] data,
                                int pos,
                                int length)
Decompresses a byte array.

Parameters:
data - The compressed byte array
pos - The starting position into the byte array
length - The number of compressed bytes to decompress
Returns:
An uncompressed byte array
See Also:
InflaterInputStream.read()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherBoolProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherBoolProperty

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperty
        extended by  org.apache.poi.ddf.EscherSimpleProperty
            extended by  org.apache.poi.ddf.EscherBoolProperty

public class EscherBoolProperty
extends EscherSimpleProperty

Represents a boolean property. The actual utility of this property is in doubt because many of the properties marked as boolean seem to actually contain special values. In other words they're not true booleans.

Author:
Glen Stampoultzis
See Also:
EscherSimpleProperty, EscherProperty

Field Summary
Fields inherited from class org.apache.poi.ddf.EscherSimpleProperty
propertyValue
Constructor Summary
EscherBoolProperty(short propertyNumber, int value)
Create an instance of an escher boolean property.
Method Summary
boolean | isFalse() Whether this boolean property is false
boolean | isTrue() Whether this boolean property is true
Methods inherited from class org.apache.poi.ddf.EscherSimpleProperty
equals, getPropertyValue, hashCode, serializeComplexPart, serializeSimplePart, toString
Methods inherited from class org.apache.poi.ddf.EscherProperty
getId, getName, getPropertyNumber, getPropertySize, isBlipId, isComplex
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EscherBoolProperty

public EscherBoolProperty(short propertyNumber,
                          int value)
Create an instance of an escher boolean property.

Parameters:
propertyNumber - The property number (or id)
value - The 32 bit value of this bool property
Method Detail

isTrue

public boolean isTrue()
Whether this boolean property is true

isFalse

public boolean isFalse()
Whether this boolean property is false

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherBSERecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherBSERecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherBSERecord

public final class EscherBSERecord
extends EscherRecord

The BSE record is related closely to the EscherBlipRecord and stores extra information about the blip. A blip record is actually stored inside the BSE record even though the BSE record isn't actually a container record.

Author:
Glen Stampoultzis
See Also:
EscherBlipRecord

Field Summary
static byte | BT_DIB
static byte | BT_EMF
static byte | BT_ERROR
static byte | BT_JPEG
static byte | BT_PICT
static byte | BT_PNG
static byte | BT_UNKNOWN
static byte | BT_WMF
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherBSERecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
EscherBlipRecord | getBlipRecord()
static java.lang.String | getBlipType(byte b) Retrieve the string representation given a blip id.
byte | getBlipTypeMacOS() The expected blip type under MacOS (failure to match this blip type will result in Excel converting to this format).
byte | getBlipTypeWin32() The expected blip type under windows (failure to match this blip type will result in Excel converting to this format).
byte | getName() The length in characters of the blip name.
int | getOffset() File offset in the delay stream.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | getRef() The reference count of this blip.
byte[] | getRemainingData() Any remaining data in this record.
int | getSize() Blip size in stream.
short | getTag() unused
byte[] | getUid() 16 byte MD4 checksum.
byte | getUnused2()
byte | getUnused3()
byte | getUsage() Defines the way this blip is used.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setBlipRecord(EscherBlipRecord blipRecord)
void | setBlipTypeMacOS(byte blipTypeMacOS) Set the expected MacOS blip type
void | setBlipTypeWin32(byte blipTypeWin32) Set the expected win32 blip type
void | setName(byte name) The length in characters of the blip name.
void | setOffset(int offset) File offset in the delay stream.
void | setRef(int ref) The reference count of this blip.
void | setRemainingData(byte[] remainingData) Any remaining data in this record.
void | setSize(int size) Blip size in stream.
void | setTag(short tag) unused
void | setUid(byte[] uid) 16 byte MD4 checksum.
void | setUnused2(byte unused2)
void | setUnused3(byte unused3)
void | setUsage(byte usage) Defines the way this blip is used.
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values

BT_ERROR

public static final byte BT_ERROR
See Also:
Constant Field Values

BT_UNKNOWN

public static final byte BT_UNKNOWN
See Also:
Constant Field Values

BT_EMF

public static final byte BT_EMF
See Also:
Constant Field Values

BT_WMF

public static final byte BT_WMF
See Also:
Constant Field Values

BT_PICT

public static final byte BT_PICT
See Also:
Constant Field Values

BT_JPEG

public static final byte BT_JPEG
See Also:
Constant Field Values

BT_PNG

public static final byte BT_PNG
See Also:
Constant Field Values

BT_DIB

public static final byte BT_DIB
See Also:
Constant Field Values
Constructor Detail

EscherBSERecord

public EscherBSERecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

getBlipTypeWin32

public byte getBlipTypeWin32()
The expected blip type under windows (failure to match this blip type will result in Excel converting to this format).

setBlipTypeWin32

public void setBlipTypeWin32(byte blipTypeWin32)
Set the expected win32 blip type

getBlipTypeMacOS

public byte getBlipTypeMacOS()
The expected blip type under MacOS (failure to match this blip type will result in Excel converting to this format).

setBlipTypeMacOS

public void setBlipTypeMacOS(byte blipTypeMacOS)
Set the expected MacOS blip type

getUid

public byte[] getUid()
16 byte MD4 checksum.

setUid

public void setUid(byte[] uid)
16 byte MD4 checksum.

getTag

public short getTag()
unused

setTag

public void setTag(short tag)
unused

getSize

public int getSize()
Blip size in stream.

setSize

public void setSize(int size)
Blip size in stream.

getRef

public int getRef()
The reference count of this blip.

setRef

public void setRef(int ref)
The reference count of this blip.

getOffset

public int getOffset()
File offset in the delay stream.

setOffset

public void setOffset(int offset)
File offset in the delay stream.

getUsage

public byte getUsage()
Defines the way this blip is used.

setUsage

public void setUsage(byte usage)
Defines the way this blip is used.

getName

public byte getName()
The length in characters of the blip name.

setName

public void setName(byte name)
The length in characters of the blip name.

getUnused2

public byte getUnused2()

setUnused2

public void setUnused2(byte unused2)

getUnused3

public byte getUnused3()

setUnused3

public void setUnused3(byte unused3)

getBlipRecord

public EscherBlipRecord getBlipRecord()

setBlipRecord

public void setBlipRecord(EscherBlipRecord blipRecord)

getRemainingData

public byte[] getRemainingData()
Any remaining data in this record.

setRemainingData

public void setRemainingData(byte[] remainingData)
Any remaining data in this record.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getBlipType

public static java.lang.String getBlipType(byte b)
Retrieve the string representation given a blip id.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherChildAnchorRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherChildAnchorRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherChildAnchorRecord

public class EscherChildAnchorRecord
extends EscherRecord

The escher child achor record is used to specify the position of a shape under an existing group. The first level of shape records use a EscherClientAnchor record instead.

Author:
Glen Stampoultzis
See Also:
EscherChildAnchorRecord

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherChildAnchorRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
int | getDx1() Retrieves offset within the parent coordinate space for the top left point.
int | getDx2() Retrieves offset within the parent coordinate space for the bottom right point.
int | getDy1() Gets offset within the parent coordinate space for the top left point.
int | getDy2() Gets the offset within the parent coordinate space for the bottom right point.
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setDx1(int field_1_dx1) Sets offset within the parent coordinate space for the top left point.
void | setDx2(int field_3_dx2) Sets offset within the parent coordinate space for the bottom right point.
void | setDy1(int field_2_dy1) Sets offset within the parent coordinate space for the top left point.
void | setDy2(int field_4_dy2) Sets the offset within the parent coordinate space for the bottom right point.
java.lang.String | toString() The string representation of this record
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherChildAnchorRecord

public EscherChildAnchorRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
The string representation of this record

Overrides:
toString in class java.lang.Object

getDx1

public int getDx1()
Retrieves offset within the parent coordinate space for the top left point.

setDx1

public void setDx1(int field_1_dx1)
Sets offset within the parent coordinate space for the top left point.

getDy1

public int getDy1()
Gets offset within the parent coordinate space for the top left point.

setDy1

public void setDy1(int field_2_dy1)
Sets offset within the parent coordinate space for the top left point.

getDx2

public int getDx2()
Retrieves offset within the parent coordinate space for the bottom right point.

setDx2

public void setDx2(int field_3_dx2)
Sets offset within the parent coordinate space for the bottom right point.

getDy2

public int getDy2()
Gets the offset within the parent coordinate space for the bottom right point.

setDy2

public void setDy2(int field_4_dy2)
Sets the offset within the parent coordinate space for the bottom right point.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherClientAnchorRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherClientAnchorRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherClientAnchorRecord

public class EscherClientAnchorRecord
extends EscherRecord

The escher client anchor specifies which rows and cells the shape is bound to as well as the offsets within those cells. Each cell is 1024 units wide by 256 units long regardless of the actual size of the cell. The EscherClientAnchorRecord only applies to the top-most shapes. Shapes contained in groups are bound using the EscherChildAnchorRecords.

Author:
Glen Stampoultzis
See Also:
EscherChildAnchorRecord

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherClientAnchorRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
short | getCol1() The column number for the top-left position.
short | getCol2() The column of the bottom right corner of this shape.
short | getDx1() The x offset within the top-left cell.
short | getDx2() The x offset withing the cell for the bottom-right corner of this shape.
short | getDy1() The y offset within the top-left corner of the current shape.
short | getDy2() The y offset withing the cell for the bottom-right corner of this shape.
short | getFlag() 0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
byte[] | getRemainingData() Any remaining data in the record
short | getRow1() The row number for the top-left corner of the shape.
short | getRow2() The row number for the bottom-right corner of the current shape.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setCol1(short field_2_col1) The column number for the top-left position.
void | setCol2(short field_6_col2) The column of the bottom right corner of this shape.
void | setDx1(short field_3_dx1) The x offset within the top-left cell.
void | setDx2(short field_7_dx2) The x offset withing the cell for the bottom-right corner of this shape.
void | setDy1(short field_5_dy1) The y offset within the top-left corner of the current shape.
void | setDy2(short field_9_dy2) The y offset withing the cell for the bottom-right corner of this shape.
void | setFlag(short field_1_flag) 0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.
void | setRemainingData(byte[] remainingData) Any remaining data in the record
void | setRow1(short field_4_row1) The row number for the top-left corner of the shape.
void | setRow2(short field_8_row2) The row number for the bottom-right corner of the current shape.
java.lang.String | toString() Returns the string representation for this record.
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherClientAnchorRecord

public EscherClientAnchorRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Returns the string representation for this record.

Overrides:
toString in class java.lang.Object
Returns:
A string

getFlag

public short getFlag()
0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

setFlag

public void setFlag(short field_1_flag)
0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

getCol1

public short getCol1()
The column number for the top-left position. 0 based.

setCol1

public void setCol1(short field_2_col1)
The column number for the top-left position. 0 based.

getDx1

public short getDx1()
The x offset within the top-left cell. Range is from 0 to 1023.

setDx1

public void setDx1(short field_3_dx1)
The x offset within the top-left cell. Range is from 0 to 1023.

getRow1

public short getRow1()
The row number for the top-left corner of the shape.

setRow1

public void setRow1(short field_4_row1)
The row number for the top-left corner of the shape.

getDy1

public short getDy1()
The y offset within the top-left corner of the current shape.

setDy1

public void setDy1(short field_5_dy1)
The y offset within the top-left corner of the current shape.

getCol2

public short getCol2()
The column of the bottom right corner of this shape.

setCol2

public void setCol2(short field_6_col2)
The column of the bottom right corner of this shape.

getDx2

public short getDx2()
The x offset withing the cell for the bottom-right corner of this shape.

setDx2

public void setDx2(short field_7_dx2)
The x offset withing the cell for the bottom-right corner of this shape.

getRow2

public short getRow2()
The row number for the bottom-right corner of the current shape.

setRow2

public void setRow2(short field_8_row2)
The row number for the bottom-right corner of the current shape.

getDy2

public short getDy2()
The y offset withing the cell for the bottom-right corner of this shape.

setDy2

public void setDy2(short field_9_dy2)
The y offset withing the cell for the bottom-right corner of this shape.

getRemainingData

public byte[] getRemainingData()
Any remaining data in the record

setRemainingData

public void setRemainingData(byte[] remainingData)
Any remaining data in the record

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherClientDataRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherClientDataRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherClientDataRecord

public class EscherClientDataRecord
extends EscherRecord

The EscherClientDataRecord is used to store client specific data about the position of a shape within a container.

Author:
Glen Stampoultzis

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherClientDataRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
byte[] | getRemainingData() Any data recording this record.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setRemainingData(byte[] remainingData) Any data recording this record.
java.lang.String | toString() Returns the string representation of this record.
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherClientDataRecord

public EscherClientDataRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Returns the string representation of this record.

Overrides:
toString in class java.lang.Object

getRemainingData

public byte[] getRemainingData()
Any data recording this record.

setRemainingData

public void setRemainingData(byte[] remainingData)
Any data recording this record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherComplexProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherComplexProperty

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperty
        extended by  org.apache.poi.ddf.EscherComplexProperty
Direct Known Subclasses:
EscherArrayProperty
public class EscherComplexProperty
extends EscherProperty

A complex property differs from a simple property in that the data can not fit inside a 32 bit integer. See the specification for more detailed information regarding exactly what is stored here.

Author:
Glen Stampoultzis

Field Summary
protected  byte[] _complexData
Constructor Summary
EscherComplexProperty(short propertyNumber, boolean isBlipId, byte[] complexData)
Create a complex property using the property number, a flag to indicate whether this is a blip reference and the complex property data.
EscherComplexProperty(short id, byte[] complexData)
Create a complex property using the property id and a byte array containing the complex data value.
Method Summary
boolean | equals(java.lang.Object o) Determine whether this property is equal to another property.
byte[] | getComplexData() Get the complex data value.
int | getPropertySize() Calculates the number of bytes required to serialize this property.
int | hashCode()
int | serializeComplexPart(byte[] data, int pos) Serializes the complex part of this property
int | serializeSimplePart(byte[] data, int pos) Serializes the simple part of this property.
java.lang.String | toString() Retrieves the string representation for this property.
Methods inherited from class org.apache.poi.ddf.EscherProperty
getId, getName, getPropertyNumber, isBlipId, isComplex
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

_complexData

protected byte[] _complexData
Constructor Detail

EscherComplexProperty

public EscherComplexProperty(short id,
                             byte[] complexData)
Create a complex property using the property id and a byte array containing the complex data value.

Parameters:
id - The id consists of the property number, a flag indicating whether this is a blip id and a flag indicating that this is a complex property.
complexData - The value of this property.

EscherComplexProperty

public EscherComplexProperty(short propertyNumber,
                             boolean isBlipId,
                             byte[] complexData)
Create a complex property using the property number, a flag to indicate whether this is a blip reference and the complex property data.

Parameters:
propertyNumber - The property number
isBlipId - Whether this is a blip id. Should be false.
complexData - The value of this complex property.
Method Detail

serializeSimplePart

public int serializeSimplePart(byte[] data,
                               int pos)
Serializes the simple part of this property. i.e. the first 6 bytes.

Specified by:
serializeSimplePart in class EscherProperty

serializeComplexPart

public int serializeComplexPart(byte[] data,
                                int pos)
Serializes the complex part of this property

Specified by:
serializeComplexPart in class EscherProperty
Parameters:
data - The data array to serialize to
pos - The offset within data to start serializing to.
Returns:
The number of bytes serialized.

getComplexData

public byte[] getComplexData()
Get the complex data value.

equals

public boolean equals(java.lang.Object o)
Determine whether this property is equal to another property.

Overrides:
equals in class java.lang.Object
Parameters:
o - The object to compare to.
Returns:
True if the objects are equal.

getPropertySize

public int getPropertySize()
Calculates the number of bytes required to serialize this property.

Overrides:
getPropertySize in class EscherProperty
Returns:
Number of bytes

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Retrieves the string representation for this property.

Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherContainerRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherContainerRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherContainerRecord

public final class EscherContainerRecord
extends EscherRecord

Escher container records store other escher records as children. The container records themselves never store any information beyond the standard header used by all escher records. This one record is used to represent many different types of records.

Author:
Glen Stampoultzis

Field Summary
static short | BSTORE_CONTAINER
static short | DG_CONTAINER
static short | DGG_CONTAINER
static short | SOLVER_CONTAINER
static short | SP_CONTAINER
static short | SPGR_CONTAINER
Constructor Summary
EscherContainerRecord()
Method Summary
 void addChildBefore(EscherRecord record, int insertBeforeRecordId)
 void addChildRecord(EscherRecord record)
 void display(java.io.PrintWriter w, int indent)
The display methods allows escher variables to print the record names according to their hierarchy.
 int fillFields(byte[] data, int pOffset, EscherRecordFactory recordFactory)
The contract of this method is to deserialize an escher record including it's children.
 EscherRecord getChild(int index)
Returns the indexed child record.
<T extends EscherRecord>
T
getChildById(short recordId)
 java.util.List<EscherContainerRecord> getChildContainers()
Returns all of our children which are also EscherContainers (may be 0, 1, or vary rarely 2 or 3)
 java.util.Iterator<EscherRecord> getChildIterator()
 java.util.List<EscherRecord> getChildRecords()
 java.lang.String getRecordName()
Subclasses should return the short name for this escher record.
 void getRecordsById(short recordId, java.util.List<EscherRecord> out)
Recursively find records with the specified record ID
 int getRecordSize()
Subclasses should effeciently return the number of bytes required to serialize the record.
 boolean hasChildOfType(short recordId)
Do any of our (top level) children have the given recordId?
 boolean removeChildRecord(EscherRecord toBeRemoved)
 int serialize(int offset, byte[] data, EscherSerializationListener listener)
Serializes the record to an existing byte array.
 void setChildRecords(java.util.List<EscherRecord> childRecords)
replaces the internal child list with the contents of the supplied childRecords
 java.lang.String toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, fillFields, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DGG_CONTAINER

public static final short DGG_CONTAINER
See Also:
Constant Field Values

BSTORE_CONTAINER

public static final short BSTORE_CONTAINER
See Also:
Constant Field Values

DG_CONTAINER

public static final short DG_CONTAINER
See Also:
Constant Field Values

SPGR_CONTAINER

public static final short SPGR_CONTAINER
See Also:
Constant Field Values

SP_CONTAINER

public static final short SP_CONTAINER
See Also:
Constant Field Values

SOLVER_CONTAINER

public static final short SOLVER_CONTAINER
See Also:
Constant Field Values
Constructor Detail

EscherContainerRecord

public EscherContainerRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int pOffset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
pOffset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

hasChildOfType

public boolean hasChildOfType(short recordId)
Do any of our (top level) children have the given recordId?

getChild

public EscherRecord getChild(int index)
Description copied from class: EscherRecord
Returns the indexed child record.

Overrides:
getChild in class EscherRecord

getChildRecords

public java.util.List<EscherRecord> getChildRecords()
Overrides:
getChildRecords in class EscherRecord
Returns:
a copy of the list of all the child records of the container.
See Also:
EscherContainerRecord

getChildIterator

public java.util.Iterator<EscherRecord> getChildIterator()

setChildRecords

public void setChildRecords(java.util.List<EscherRecord> childRecords)
replaces the internal child list with the contents of the supplied childRecords

Overrides:
setChildRecords in class EscherRecord
Parameters:
childRecords - Not used in base implementation.

removeChildRecord

public boolean removeChildRecord(EscherRecord toBeRemoved)

getChildContainers

public java.util.List<EscherContainerRecord> getChildContainers()
Returns all of our children which are also EscherContainers (may be 0, 1, or vary rarely 2 or 3)

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

display

public void display(java.io.PrintWriter w,
                    int indent)
Description copied from class: EscherRecord
The display methods allows escher variables to print the record names according to their hierarchy.

Overrides:
display in class EscherRecord
Parameters:
w - The print writer to output to.
indent - The current indent level.

addChildRecord

public void addChildRecord(EscherRecord record)

addChildBefore

public void addChildBefore(EscherRecord record,
                           int insertBeforeRecordId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getChildById

public <T extends EscherRecord> T getChildById(short recordId)

getRecordsById

public void getRecordsById(short recordId,
                           java.util.List<EscherRecord> out)
Recursively find records with the specified record ID

Parameters:
out - - list to store found records
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherDggRecord.FileIdCluster

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherDggRecord.FileIdCluster

java.lang.Object
    extended by  org.apache.poi.ddf.EscherDggRecord.FileIdCluster
Enclosing class:
EscherDggRecord
public static class EscherDggRecord.FileIdCluster
extends java.lang.Object

Constructor Summary
EscherDggRecord.FileIdCluster(int drawingGroupId, int numShapeIdsUsed)
Method Summary
int | getDrawingGroupId()
int | getNumShapeIdsUsed()
void | incrementShapeId()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherDggRecord.FileIdCluster

public EscherDggRecord.FileIdCluster(int drawingGroupId,
                                     int numShapeIdsUsed)
Method Detail

getDrawingGroupId

public int getDrawingGroupId()

getNumShapeIdsUsed

public int getNumShapeIdsUsed()

incrementShapeId

public void incrementShapeId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherDggRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherDggRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherDggRecord

public final class EscherDggRecord
extends EscherRecord

This record defines the drawing groups used for a particular sheet.

Nested Class Summary
static class EscherDggRecord.FileIdCluster
Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherDggRecord()
Method Summary
void | addCluster(int dgId, int numShapedUsed)
void | addCluster(int dgId, int numShapedUsed, boolean sort) Add a new cluster
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
int | getDrawingsSaved()
EscherDggRecord.FileIdCluster[] | getFileIdClusters()
int | getMaxDrawingGroupId()
int | getNumIdClusters() Number of id clusters + 1
int | getNumShapesSaved()
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | getShapeIdMax()
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setDrawingsSaved(int drawingsSaved)
void | setFileIdClusters(EscherDggRecord.FileIdCluster[] fileIdClusters)
void | setMaxDrawingGroupId(int id)
void | setNumShapesSaved(int numShapesSaved)
void | setShapeIdMax(int shapeIdMax) The maximum is actually the next available.
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherDggRecord

public EscherDggRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getShapeIdMax

public int getShapeIdMax()

setShapeIdMax

public void setShapeIdMax(int shapeIdMax)
The maximum is actually the next available. shape id.

getNumIdClusters

public int getNumIdClusters()
Number of id clusters + 1

getNumShapesSaved

public int getNumShapesSaved()

setNumShapesSaved

public void setNumShapesSaved(int numShapesSaved)

getDrawingsSaved

public int getDrawingsSaved()

setDrawingsSaved

public void setDrawingsSaved(int drawingsSaved)

getMaxDrawingGroupId

public int getMaxDrawingGroupId()
Returns:
The maximum drawing group ID

setMaxDrawingGroupId

public void setMaxDrawingGroupId(int id)

getFileIdClusters

public EscherDggRecord.FileIdCluster[] getFileIdClusters()

setFileIdClusters

public void setFileIdClusters(EscherDggRecord.FileIdCluster[] fileIdClusters)

addCluster

public void addCluster(int dgId,
                       int numShapedUsed)

addCluster

public void addCluster(int dgId,
                       int numShapedUsed,
                       boolean sort)
Add a new cluster

Parameters:
dgId - id of the drawing group (stored in the record options)
numShapedUsed - initial value of the numShapedUsed field
sort - if true then sort clusters by drawing group id.( In Excel the clusters are sorted but in PPT they are not)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherDgRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherDgRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherDgRecord

public class EscherDgRecord
extends EscherRecord

This record simply holds the number of shapes in the drawing group and the last shape id used for this drawing group.

Author:
Glen Stampoultzis

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherDgRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
short | getDrawingGroupId() Gets the drawing group id for this record.
int | getLastMSOSPID() The last shape id used in this drawing group.
int | getNumShapes() The number of shapes in this drawing group.
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Returns the number of bytes that are required to serialize this record.
void | incrementShapeCount()
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setLastMSOSPID(int field_2_lastMSOSPID) The last shape id used in this drawing group.
void | setNumShapes(int field_1_numShapes) The number of shapes in this drawing group.
java.lang.String | toString() Returns the string representation of this record.
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherDgRecord

public EscherDgRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Returns the number of bytes that are required to serialize this record.

Specified by:
getRecordSize in class EscherRecord
Returns:
Number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Returns the string representation of this record.

Overrides:
toString in class java.lang.Object

getNumShapes

public int getNumShapes()
The number of shapes in this drawing group.

setNumShapes

public void setNumShapes(int field_1_numShapes)
The number of shapes in this drawing group.

getLastMSOSPID

public int getLastMSOSPID()
The last shape id used in this drawing group.

setLastMSOSPID

public void setLastMSOSPID(int field_2_lastMSOSPID)
The last shape id used in this drawing group.

getDrawingGroupId

public short getDrawingGroupId()
Gets the drawing group id for this record. This is encoded in the instance part of the option record.

Returns:
a drawing group id.

incrementShapeCount

public void incrementShapeCount()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherDump

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherDump

java.lang.Object
    extended by  org.apache.poi.ddf.EscherDump

public final class EscherDump
extends java.lang.Object

Used to dump the contents of escher records to a PrintStream.

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
EscherDump()
Method Summary
void | dump(byte[] data, int offset, int size, java.io.PrintStream out) Decodes the escher stream from a byte array and dumps the results to a print stream.
void | dump(int recordSize, byte[] data, java.io.PrintStream out)
void | dumpOld(long maxLength, java.io.InputStream in, java.io.PrintStream out) This version of dump is a translation from the open office escher dump routine.
static void | main(java.lang.String[] args) A simple test stub.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherDump

public EscherDump()
Method Detail

dump

public void dump(byte[] data,
                 int offset,
                 int size,
                 java.io.PrintStream out)
Decodes the escher stream from a byte array and dumps the results to a print stream.

Parameters:
data - The data array containing the escher records.
offset - The starting offset within the data array.
size - The number of bytes to read.
out - The output stream to write the results to.

dumpOld

public void dumpOld(long maxLength,
                    java.io.InputStream in,
                    java.io.PrintStream out)
             throws java.io.IOException,
                    LittleEndian.BufferUnderrunException
This version of dump is a translation from the open office escher dump routine.

Parameters:
maxLength - The number of bytes to read
in - An input stream to read from.
out - An output stream to write to.
Throws:
java.io.IOException
LittleEndian.BufferUnderrunException

main

public static void main(java.lang.String[] args)
A simple test stub.

dump

public void dump(int recordSize,
                 byte[] data,
                 java.io.PrintStream out)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherMetafileBlip

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherMetafileBlip

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherBlipRecord
            extended by  org.apache.poi.ddf.EscherMetafileBlip

public final class EscherMetafileBlip
extends EscherBlipRecord

Author:
Daniel Noll

Field Summary
static short | RECORD_ID_EMF
static short | RECORD_ID_PICT
static short | RECORD_ID_WMF
static short | SIGNATURE_EMF BLIP signatures as defined in the escher spec
static short | SIGNATURE_PICT
static short | SIGNATURE_WMF
Fields inherited from class org.apache.poi.ddf.EscherBlipRecord
field_pictureData, RECORD_DESCRIPTION, RECORD_ID_END, RECORD_ID_START
Constructor Summary
EscherMetafileBlip()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
java.awt.Rectangle | getBounds()
int | getCompressedSize()
byte[] | getPrimaryUID()
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
byte[] | getRemainingData()
short | getSignature() Return the blip signature
java.awt.Dimension | getSizeEMU()
byte[] | getUID()
int | getUncompressedSize()
boolean | isCompressed()
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setBounds(java.awt.Rectangle bounds)
void | setCompressed(boolean compressed)
void | setCompressedSize(int compressedSize)
void | setPrimaryUID(byte[] primaryUID)
void | setSizeEMU(java.awt.Dimension sizeEMU)
void | setUID(byte[] uid)
void | setUncompressedSize(int uncompressedSize)
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherBlipRecord
getPicturedata, getRecordName, setPictureData
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID_EMF

public static final short RECORD_ID_EMF
See Also:
Constant Field Values

RECORD_ID_WMF

public static final short RECORD_ID_WMF
See Also:
Constant Field Values

RECORD_ID_PICT

public static final short RECORD_ID_PICT
See Also:
Constant Field Values

SIGNATURE_EMF

public static final short SIGNATURE_EMF
BLIP signatures as defined in the escher spec

See Also:
Constant Field Values

SIGNATURE_WMF

public static final short SIGNATURE_WMF
See Also:
Constant Field Values

SIGNATURE_PICT

public static final short SIGNATURE_PICT
See Also:
Constant Field Values
Constructor Detail

EscherMetafileBlip

public EscherMetafileBlip()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Overrides:
fillFields in class EscherBlipRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Overrides:
serialize in class EscherBlipRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Overrides:
getRecordSize in class EscherBlipRecord
Returns:
number of bytes

getUID

public byte[] getUID()

setUID

public void setUID(byte[] uid)

getPrimaryUID

public byte[] getPrimaryUID()

setPrimaryUID

public void setPrimaryUID(byte[] primaryUID)

getUncompressedSize

public int getUncompressedSize()

setUncompressedSize

public void setUncompressedSize(int uncompressedSize)

getBounds

public java.awt.Rectangle getBounds()

setBounds

public void setBounds(java.awt.Rectangle bounds)

getSizeEMU

public java.awt.Dimension getSizeEMU()

setSizeEMU

public void setSizeEMU(java.awt.Dimension sizeEMU)

getCompressedSize

public int getCompressedSize()

setCompressedSize

public void setCompressedSize(int compressedSize)

isCompressed

public boolean isCompressed()

setCompressed

public void setCompressed(boolean compressed)

getRemainingData

public byte[] getRemainingData()

toString

public java.lang.String toString()
Overrides:
toString in class EscherBlipRecord

getSignature

public short getSignature()
Return the blip signature

Returns:
the blip signature
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherOptRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherOptRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.AbstractEscherOptRecord
            extended by  org.apache.poi.ddf.EscherOptRecord

public class EscherOptRecord
extends AbstractEscherOptRecord

The opt record is used to store property values for a shape. It is the key to determining the attributes of a shape. Properties can be of two types: simple or complex. Simple types are fixed length. Complex properties are variable length.

Author:
Glen Stampoultzis

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Fields inherited from class org.apache.poi.ddf.AbstractEscherOptRecord
properties
Constructor Summary
EscherOptRecord()
Method Summary
short | getInstance() Returns the instance part of the option record.
short | getOptions() Automatically recalculate the correct option
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
short | getVersion() Returns the version part of the option record.
void | setVersion(short value) Sets the version part of record
Methods inherited from class org.apache.poi.ddf.AbstractEscherOptRecord
addEscherProperty, fillFields, getEscherProperties, getEscherProperty, getRecordSize, lookup, serialize, sortProperties, toString
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getRecordId, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values
Constructor Detail

EscherOptRecord

public EscherOptRecord()
Method Detail

getInstance

public short getInstance()
Description copied from class: EscherRecord
Returns the instance part of the option record.

Overrides:
getInstance in class EscherRecord
Returns:
The instance part of the record

getOptions

@Internal
public short getOptions()
Automatically recalculate the correct option

Overrides:
getOptions in class EscherRecord
Returns:
The options field for this record. All records have one.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

getVersion

public short getVersion()
Description copied from class: EscherRecord
Returns the version part of the option record.

Overrides:
getVersion in class EscherRecord
Returns:
The version part of the option record

setVersion

public void setVersion(short value)
Description copied from class: EscherRecord
Sets the version part of record

Overrides:
setVersion in class EscherRecord
Parameters:
value - version part value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherPictBlip

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherPictBlip

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherBlipRecord
            extended by  org.apache.poi.ddf.EscherPictBlip

public final class EscherPictBlip
extends EscherBlipRecord

Author:
Daniel Noll

Field Summary
static short | RECORD_ID_EMF
static short | RECORD_ID_PICT
static short | RECORD_ID_WMF
Fields inherited from class org.apache.poi.ddf.EscherBlipRecord
field_pictureData, RECORD_DESCRIPTION, RECORD_ID_END, RECORD_ID_START
Constructor Summary
EscherPictBlip()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
java.awt.Rectangle | getBounds()
int | getCompressedSize()
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
java.awt.Dimension | getSizeEMU()
byte[] | getUID()
int | getUncompressedSize()
boolean | isCompressed()
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setBounds(java.awt.Rectangle bounds)
void | setCompressed(boolean compressed)
void | setCompressedSize(int compressedSize)
void | setSizeEMU(java.awt.Dimension sizeEMU)
void | setUID(byte[] uid)
void | setUncompressedSize(int uncompressedSize)
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherBlipRecord
getPicturedata, getRecordName, setPictureData
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID_EMF

public static final short RECORD_ID_EMF
See Also:
Constant Field Values

RECORD_ID_WMF

public static final short RECORD_ID_WMF
See Also:
Constant Field Values

RECORD_ID_PICT

public static final short RECORD_ID_PICT
See Also:
Constant Field Values
Constructor Detail

EscherPictBlip

public EscherPictBlip()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Overrides:
fillFields in class EscherBlipRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Overrides:
serialize in class EscherBlipRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Overrides:
getRecordSize in class EscherBlipRecord
Returns:
number of bytes

getUID

public byte[] getUID()

setUID

public void setUID(byte[] uid)

getUncompressedSize

public int getUncompressedSize()

setUncompressedSize

public void setUncompressedSize(int uncompressedSize)

getBounds

public java.awt.Rectangle getBounds()

setBounds

public void setBounds(java.awt.Rectangle bounds)

getSizeEMU

public java.awt.Dimension getSizeEMU()

setSizeEMU

public void setSizeEMU(java.awt.Dimension sizeEMU)

getCompressedSize

public int getCompressedSize()

setCompressedSize

public void setCompressedSize(int compressedSize)

isCompressed

public boolean isCompressed()

setCompressed

public void setCompressed(boolean compressed)

toString

public java.lang.String toString()
Overrides:
toString in class EscherBlipRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherProperties

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperties

public final class EscherProperties
extends java.lang.Object

Provides a list of all known escher properties including the description and type.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | BLIP__BLIPFILENAME
static short | BLIP__BLIPFLAGS
static short | BLIP__BLIPTODISPLAY
static short | BLIP__BRIGHTNESSSETTING
static short | BLIP__CONTRASTSETTING
static short | BLIP__CROPFROMBOTTOM
static short | BLIP__CROPFROMLEFT
static short | BLIP__CROPFROMRIGHT
static short | BLIP__CROPFROMTOP
static short | BLIP__DOUBLEMOD
static short | BLIP__GAMMA
static short | BLIP__NOHITTESTPICTURE
static short | BLIP__PICTUREACTIVE
static short | BLIP__PICTUREBILEVEL
static short | BLIP__PICTUREFILLMOD
static short | BLIP__PICTUREGRAY
static short | BLIP__PICTUREID
static short | BLIP__PICTURELINE
static short | BLIP__PRINTBLIP
static short | BLIP__PRINTBLIPFILENAME
static short | BLIP__PRINTFLAGS
static short | BLIP__TRANSPARENTCOLOR
static short | CALLOUT__CALLOUTACCENTBAR
static short | CALLOUT__CALLOUTANGLE
static short | CALLOUT__CALLOUTDROPSPECIFIED
static short | CALLOUT__CALLOUTDROPTYPE
static short | CALLOUT__CALLOUTLENGTHSPECIFIED
static short | CALLOUT__CALLOUTMINUSX
static short | CALLOUT__CALLOUTMINUSY
static short | CALLOUT__CALLOUTTEXTBORDER
static short | CALLOUT__CALLOUTTYPE
static short | CALLOUT__DROPAUTO
static short | CALLOUT__ISCALLOUT
static short | CALLOUT__LENGTHSPECIFIED
static short | CALLOUT__XYCALLOUTGAP
static short | FILL__ANGLE
static short | FILL__BACKOPACITY
static short | FILL__BLIPFILENAME
static short | FILL__BLIPFLAGS
static short | FILL__CRMOD
static short | FILL__DZTYPE
static short | FILL__FILLBACKCOLOR
static short | FILL__FILLCOLOR
static short | FILL__FILLED
static short | FILL__FILLOPACITY
static short | FILL__FILLTYPE
static short | FILL__FOCUS
static short | FILL__HEIGHT
static short | FILL__HITTESTFILL
static short | FILL__NOFILLHITTEST
static short | FILL__ORIGINX
static short | FILL__ORIGINY
static short | FILL__PATTERNTEXTURE
static short | FILL__RECTBOTTOM
static short | FILL__RECTLEFT
static short | FILL__RECTRIGHT
static short | FILL__RECTTOP
static short | FILL__SHADECOLORS
static short | FILL__SHADEPRESET
static short | FILL__SHADETYPE
static short | FILL__SHAPE
static short | FILL__SHAPEORIGINX
static short | FILL__SHAPEORIGINY
static short | FILL__TOBOTTOM
static short | FILL__TOLEFT
static short | FILL__TORIGHT
static short | FILL__TOTOP
static short | FILL__USERECT
static short | FILL__WIDTH
static short | GEOMETRY__3DOK
static short | GEOMETRY__ADJUST10VALUE
static short | GEOMETRY__ADJUST2VALUE
static short | GEOMETRY__ADJUST3VALUE
static short | GEOMETRY__ADJUST4VALUE
static short | GEOMETRY__ADJUST5VALUE
static short | GEOMETRY__ADJUST6VALUE
static short | GEOMETRY__ADJUST7VALUE
static short | GEOMETRY__ADJUST8VALUE
static short | GEOMETRY__ADJUST9VALUE
static short | GEOMETRY__ADJUSTVALUE
static short | GEOMETRY__BOTTOM
static short | GEOMETRY__FILLOK
static short | GEOMETRY__FILLSHADESHAPEOK
static short | GEOMETRY__GEOTEXTOK
static short | GEOMETRY__LEFT
static short | GEOMETRY__LINEOK
static short | GEOMETRY__RIGHT
static short | GEOMETRY__SEGMENTINFO
static short | GEOMETRY__SHADOWok
static short | GEOMETRY__SHAPEPATH
static short | GEOMETRY__TOP
static short | GEOMETRY__VERTICES
static short | GEOTEXT__ALIGNMENTONCURVE
static short | GEOTEXT__BOLDFONT
static short | GEOTEXT__CHARBOUNDINGBOX
static short | GEOTEXT__DEFAULTPOINTSIZE
static short | GEOTEXT__FONTFAMILYNAME
static short | GEOTEXT__HASTEXTEFFECT
static short | GEOTEXT__ITALICFONT
static short | GEOTEXT__KERNCHARACTERS
static short | GEOTEXT__NOMEASUREALONGPATH
static short | GEOTEXT__REVERSEROWORDER
static short | GEOTEXT__ROTATECHARACTERS
static short | GEOTEXT__RTFTEXT
static short | GEOTEXT__SCALETEXTONPATH
static short | GEOTEXT__SHADOWFONT
static short | GEOTEXT__SMALLCAPSFONT
static short | GEOTEXT__STRETCHCHARHEIGHT
static short | GEOTEXT__STRETCHTOFITSHAPE
static short | GEOTEXT__STRIKETHROUGHFONT
static short | GEOTEXT__TEXTSPACING
static short | GEOTEXT__TIGHTORTRACK
static short | GEOTEXT__UNDERLINEFONT
static short | GEOTEXT__UNICODE
static short | GROUPSHAPE__1DADJUSTMENT
static short | GROUPSHAPE__BEHINDDOCUMENT
static short | GROUPSHAPE__BORDERBOTTOMCOLOR
static short | GROUPSHAPE__BORDERLEFTCOLOR
static short | GROUPSHAPE__BORDERRIGHTCOLOR
static short | GROUPSHAPE__BORDERTOPCOLOR
static short | GROUPSHAPE__DESCRIPTION
static short | GROUPSHAPE__EDITEDWRAP
static short | GROUPSHAPE__FLAGS
static short | GROUPSHAPE__HIDDEN
static short | GROUPSHAPE__HR_ALIGN
static short | GROUPSHAPE__HR_HEIGHT
static short | GROUPSHAPE__HR_PCT
static short | GROUPSHAPE__HR_WIDTH
static short | GROUPSHAPE__HYPERLINK
static short | GROUPSHAPE__ISBUTTON
static short | GROUPSHAPE__METROBLOB
static short | GROUPSHAPE__ONDBLCLICKNOTIFY
static short | GROUPSHAPE__POSH
static short | GROUPSHAPE__POSRELH
static short | GROUPSHAPE__POSRELV
static short | GROUPSHAPE__POSV
static short | GROUPSHAPE__PRINT
static short | GROUPSHAPE__REGROUPID
static short | GROUPSHAPE__SCRIPT
static short | GROUPSHAPE__SCRIPTEXT
static short | GROUPSHAPE__SCRIPTLANG
static short | GROUPSHAPE__SHAPENAME
static short | GROUPSHAPE__TABLEPROPERTIES
static short | GROUPSHAPE__TABLEROWPROPERTIES
static short | GROUPSHAPE__TOOLTIP
static short | GROUPSHAPE__UNUSED906
static short | GROUPSHAPE__WEBBOT
static short | GROUPSHAPE__WRAPDISTBOTTOM
static short | GROUPSHAPE__WRAPDISTLEFT
static short | GROUPSHAPE__WRAPDISTRIGHT
static short | GROUPSHAPE__WRAPDISTTOP
static short | GROUPSHAPE__WRAPPOLYGONVERTICES
static short | GROUPSHAPE__ZORDER
static short | LINESTYLE__ANYLINE
static short | LINESTYLE__ARROWHEADSOK
static short | LINESTYLE__BACKCOLOR
static short | LINESTYLE__COLOR
static short | LINESTYLE__CRMOD
static short | LINESTYLE__FILLBLIP
static short | LINESTYLE__FILLBLIPFLAGS
static short | LINESTYLE__FILLBLIPNAME
static short | LINESTYLE__FILLDZTYPE
static short | LINESTYLE__FILLHEIGHT
static short | LINESTYLE__FILLWIDTH
static short | LINESTYLE__HITLINETEST
static short | LINESTYLE__LINEDASHING
static short | LINESTYLE__LINEDASHSTYLE
static short | LINESTYLE__LINEENDARROWHEAD
static short | LINESTYLE__LINEENDARROWLENGTH
static short | LINESTYLE__LINEENDARROWWIDTH
static short | LINESTYLE__LINEENDCAPSTYLE
static short | LINESTYLE__LINEESTARTARROWLENGTH
static short | LINESTYLE__LINEFILLSHAPE
static short | LINESTYLE__LINEJOINSTYLE
static short | LINESTYLE__LINEMITERLIMIT
static short | LINESTYLE__LINESTARTARROWHEAD
static short | LINESTYLE__LINESTARTARROWWIDTH
static short | LINESTYLE__LINESTYLE
static short | LINESTYLE__LINETYPE
static short | LINESTYLE__LINEWIDTH
static short | LINESTYLE__NOLINEDRAWDASH
static short | LINESTYLE__OPACITY
static short | PERSPECTIVE__OFFSETX
static short | PERSPECTIVE__OFFSETY
static short | PERSPECTIVE__ORIGINX
static short | PERSPECTIVE__ORIGINY
static short | PERSPECTIVE__PERSPECTIVEON
static short | PERSPECTIVE__PERSPECTIVEX
static short | PERSPECTIVE__PERSPECTIVEY
static short | PERSPECTIVE__SCALEXTOX
static short | PERSPECTIVE__SCALEXTOY
static short | PERSPECTIVE__SCALEYTOX
static short | PERSPECTIVE__SCALEYTOY
static short | PERSPECTIVE__TYPE
static short | PERSPECTIVE__WEIGHT
static short | PROTECTION__LOCKADJUSTHANDLES
static short | PROTECTION__LOCKAGAINSTGROUPING
static short | PROTECTION__LOCKAGAINSTSELECT
static short | PROTECTION__LOCKASPECTRATIO
static short | PROTECTION__LOCKCROPPING
static short | PROTECTION__LOCKPOSITION
static short | PROTECTION__LOCKROTATION
static short | PROTECTION__LOCKTEXT
static short | PROTECTION__LOCKVERTICES
static short | SHADOWSTYLE__COLOR
static short | SHADOWSTYLE__CRMOD
static short | SHADOWSTYLE__HIGHLIGHT
static short | SHADOWSTYLE__OFFSETX
static short | SHADOWSTYLE__OFFSETY
static short | SHADOWSTYLE__OPACITY
static short | SHADOWSTYLE__ORIGINX
static short | SHADOWSTYLE__ORIGINY
static short | SHADOWSTYLE__PERSPECTIVEX
static short | SHADOWSTYLE__PERSPECTIVEY
static short | SHADOWSTYLE__SCALEXTOX
static short | SHADOWSTYLE__SCALEXTOY
static short | SHADOWSTYLE__SCALEYTOX
static short | SHADOWSTYLE__SCALEYTOY
static short | SHADOWSTYLE__SECONDOFFSETX
static short | SHADOWSTYLE__SECONDOFFSETY
static short | SHADOWSTYLE__SHADOW
static short | SHADOWSTYLE__SHADOWOBSURED
static short | SHADOWSTYLE__TYPE
static short | SHADOWSTYLE__WEIGHT
static short | SHAPE__BACKGROUNDSHAPE
static short | SHAPE__BLACKANDWHITESETTINGS
static short | SHAPE__CONNECTORSTYLE
static short | SHAPE__DELETEATTACHEDOBJECT
static short | SHAPE__LOCKSHAPETYPE
static short | SHAPE__MASTER
static short | SHAPE__OLEICON
static short | SHAPE__PREFERRELATIVERESIZE
static short | SHAPE__WMODEBW
static short | SHAPE__WMODEPUREBW
static short | TEXT__ANCHORTEXT
static short | TEXT__BIDIR
static short | TEXT__FONTROTATION
static short | TEXT__IDOFNEXTSHAPE
static short | TEXT__ROTATETEXTWITHSHAPE
static short | TEXT__SCALETEXT
static short | TEXT__SINGLECLICKSELECTS
static short | TEXT__SIZE_TEXT_TO_FIT_SHAPE
static short | TEXT__SIZESHAPETOFITTEXT
static short | TEXT__TEXTBOTTOM
static short | TEXT__TEXTFLOW
static short | TEXT__TEXTID
static short | TEXT__TEXTLEFT
static short | TEXT__TEXTRIGHT
static short | TEXT__TEXTTOP
static short | TEXT__USEHOSTMARGINS
static short | TEXT__WRAPTEXT
static short | THREED__3DEFFECT
static short | THREED__CRMOD
static short | THREED__DIFFUSEAMOUNT
static short | THREED__EDGETHICKNESS
static short | THREED__EXTRUDEBACKWARD
static short | THREED__EXTRUDEFORWARD
static short | THREED__EXTRUDEPLANE
static short | THREED__EXTRUSIONCOLOR
static short | THREED__LIGHTFACE
static short | THREED__METALLIC
static short | THREED__SHININESS
static short | THREED__SPECULARAMOUNT
static short | THREED__USEEXTRUSIONCOLOR
static short | THREEDSTYLE__AMBIENTINTENSITY
static short | THREEDSTYLE__CONSTRAINROTATION
static short | THREEDSTYLE__FILLHARSH
static short | THREEDSTYLE__FILLINTENSITY
static short | THREEDSTYLE__FILLX
static short | THREEDSTYLE__FILLY
static short | THREEDSTYLE__FILLZ
static short | THREEDSTYLE__KEYHARSH
static short | THREEDSTYLE__KEYINTENSITY
static short | THREEDSTYLE__KEYX
static short | THREEDSTYLE__KEYY
static short | THREEDSTYLE__KEYZ
static short | THREEDSTYLE__ORIGINX
static short | THREEDSTYLE__ORIGINY
static short | THREEDSTYLE__PARALLEL
static short | THREEDSTYLE__RENDERMODE
static short | THREEDSTYLE__ROTATIONANGLE
static short | THREEDSTYLE__ROTATIONAXISX
static short | THREEDSTYLE__ROTATIONAXISY
static short | THREEDSTYLE__ROTATIONAXISZ
static short | THREEDSTYLE__ROTATIONCENTERAUTO
static short | THREEDSTYLE__ROTATIONCENTERX
static short | THREEDSTYLE__ROTATIONCENTERY
static short | THREEDSTYLE__ROTATIONCENTERZ
static short | THREEDSTYLE__SKEWAMOUNT
static short | THREEDSTYLE__SKEWANGLE
static short | THREEDSTYLE__TOLERANCE
static short | THREEDSTYLE__XROTATIONANGLE
static short | THREEDSTYLE__XVIEWPOINT
static short | THREEDSTYLE__YROTATIONANGLE
static short | THREEDSTYLE__YVIEWPOINT
static short | THREEDSTYLE__ZVIEWPOINT
static short | TRANSFORM__ROTATION
Constructor Summary
EscherProperties()
Method Summary
static java.lang.String | getPropertyName(short propertyId)
static byte | getPropertyType(short propertyId)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TRANSFORM__ROTATION

public static final short TRANSFORM__ROTATION
See Also:
Constant Field Values

PROTECTION__LOCKROTATION

public static final short PROTECTION__LOCKROTATION
See Also:
Constant Field Values

PROTECTION__LOCKASPECTRATIO

public static final short PROTECTION__LOCKASPECTRATIO
See Also:
Constant Field Values

PROTECTION__LOCKPOSITION

public static final short PROTECTION__LOCKPOSITION
See Also:
Constant Field Values

PROTECTION__LOCKAGAINSTSELECT

public static final short PROTECTION__LOCKAGAINSTSELECT
See Also:
Constant Field Values

PROTECTION__LOCKCROPPING

public static final short PROTECTION__LOCKCROPPING
See Also:
Constant Field Values

PROTECTION__LOCKVERTICES

public static final short PROTECTION__LOCKVERTICES
See Also:
Constant Field Values

PROTECTION__LOCKTEXT

public static final short PROTECTION__LOCKTEXT
See Also:
Constant Field Values

PROTECTION__LOCKADJUSTHANDLES

public static final short PROTECTION__LOCKADJUSTHANDLES
See Also:
Constant Field Values

PROTECTION__LOCKAGAINSTGROUPING

public static final short PROTECTION__LOCKAGAINSTGROUPING
See Also:
Constant Field Values

TEXT__TEXTID

public static final short TEXT__TEXTID
See Also:
Constant Field Values

TEXT__TEXTLEFT

public static final short TEXT__TEXTLEFT
See Also:
Constant Field Values

TEXT__TEXTTOP

public static final short TEXT__TEXTTOP
See Also:
Constant Field Values

TEXT__TEXTRIGHT

public static final short TEXT__TEXTRIGHT
See Also:
Constant Field Values

TEXT__TEXTBOTTOM

public static final short TEXT__TEXTBOTTOM
See Also:
Constant Field Values

TEXT__WRAPTEXT

public static final short TEXT__WRAPTEXT
See Also:
Constant Field Values

TEXT__SCALETEXT

public static final short TEXT__SCALETEXT
See Also:
Constant Field Values

TEXT__ANCHORTEXT

public static final short TEXT__ANCHORTEXT
See Also:
Constant Field Values

TEXT__TEXTFLOW

public static final short TEXT__TEXTFLOW
See Also:
Constant Field Values

TEXT__FONTROTATION

public static final short TEXT__FONTROTATION
See Also:
Constant Field Values

TEXT__IDOFNEXTSHAPE

public static final short TEXT__IDOFNEXTSHAPE
See Also:
Constant Field Values

TEXT__BIDIR

public static final short TEXT__BIDIR
See Also:
Constant Field Values

TEXT__SINGLECLICKSELECTS

public static final short TEXT__SINGLECLICKSELECTS
See Also:
Constant Field Values

TEXT__USEHOSTMARGINS

public static final short TEXT__USEHOSTMARGINS
See Also:
Constant Field Values

TEXT__ROTATETEXTWITHSHAPE

public static final short TEXT__ROTATETEXTWITHSHAPE
See Also:
Constant Field Values

TEXT__SIZESHAPETOFITTEXT

public static final short TEXT__SIZESHAPETOFITTEXT
See Also:
Constant Field Values

TEXT__SIZE_TEXT_TO_FIT_SHAPE

public static final short TEXT__SIZE_TEXT_TO_FIT_SHAPE
See Also:
Constant Field Values

GEOTEXT__UNICODE

public static final short GEOTEXT__UNICODE
See Also:
Constant Field Values

GEOTEXT__RTFTEXT

public static final short GEOTEXT__RTFTEXT
See Also:
Constant Field Values

GEOTEXT__ALIGNMENTONCURVE

public static final short GEOTEXT__ALIGNMENTONCURVE
See Also:
Constant Field Values

GEOTEXT__DEFAULTPOINTSIZE

public static final short GEOTEXT__DEFAULTPOINTSIZE
See Also:
Constant Field Values

GEOTEXT__TEXTSPACING

public static final short GEOTEXT__TEXTSPACING
See Also:
Constant Field Values

GEOTEXT__FONTFAMILYNAME

public static final short GEOTEXT__FONTFAMILYNAME
See Also:
Constant Field Values

GEOTEXT__REVERSEROWORDER

public static final short GEOTEXT__REVERSEROWORDER
See Also:
Constant Field Values

GEOTEXT__HASTEXTEFFECT

public static final short GEOTEXT__HASTEXTEFFECT
See Also:
Constant Field Values

GEOTEXT__ROTATECHARACTERS

public static final short GEOTEXT__ROTATECHARACTERS
See Also:
Constant Field Values

GEOTEXT__KERNCHARACTERS

public static final short GEOTEXT__KERNCHARACTERS
See Also:
Constant Field Values

GEOTEXT__TIGHTORTRACK

public static final short GEOTEXT__TIGHTORTRACK
See Also:
Constant Field Values

GEOTEXT__STRETCHTOFITSHAPE

public static final short GEOTEXT__STRETCHTOFITSHAPE
See Also:
Constant Field Values

GEOTEXT__CHARBOUNDINGBOX

public static final short GEOTEXT__CHARBOUNDINGBOX
See Also:
Constant Field Values

GEOTEXT__SCALETEXTONPATH

public static final short GEOTEXT__SCALETEXTONPATH
See Also:
Constant Field Values

GEOTEXT__STRETCHCHARHEIGHT

public static final short GEOTEXT__STRETCHCHARHEIGHT
See Also:
Constant Field Values

GEOTEXT__NOMEASUREALONGPATH

public static final short GEOTEXT__NOMEASUREALONGPATH
See Also:
Constant Field Values

GEOTEXT__BOLDFONT

public static final short GEOTEXT__BOLDFONT
See Also:
Constant Field Values

GEOTEXT__ITALICFONT

public static final short GEOTEXT__ITALICFONT
See Also:
Constant Field Values

GEOTEXT__UNDERLINEFONT

public static final short GEOTEXT__UNDERLINEFONT
See Also:
Constant Field Values

GEOTEXT__SHADOWFONT

public static final short GEOTEXT__SHADOWFONT
See Also:
Constant Field Values

GEOTEXT__SMALLCAPSFONT

public static final short GEOTEXT__SMALLCAPSFONT
See Also:
Constant Field Values

GEOTEXT__STRIKETHROUGHFONT

public static final short GEOTEXT__STRIKETHROUGHFONT
See Also:
Constant Field Values

BLIP__CROPFROMTOP

public static final short BLIP__CROPFROMTOP
See Also:
Constant Field Values

BLIP__CROPFROMBOTTOM

public static final short BLIP__CROPFROMBOTTOM
See Also:
Constant Field Values

BLIP__CROPFROMLEFT

public static final short BLIP__CROPFROMLEFT
See Also:
Constant Field Values

BLIP__CROPFROMRIGHT

public static final short BLIP__CROPFROMRIGHT
See Also:
Constant Field Values

BLIP__BLIPTODISPLAY

public static final short BLIP__BLIPTODISPLAY
See Also:
Constant Field Values

BLIP__BLIPFILENAME

public static final short BLIP__BLIPFILENAME
See Also:
Constant Field Values

BLIP__BLIPFLAGS

public static final short BLIP__BLIPFLAGS
See Also:
Constant Field Values

BLIP__TRANSPARENTCOLOR

public static final short BLIP__TRANSPARENTCOLOR
See Also:
Constant Field Values

BLIP__CONTRASTSETTING

public static final short BLIP__CONTRASTSETTING
See Also:
Constant Field Values

BLIP__BRIGHTNESSSETTING

public static final short BLIP__BRIGHTNESSSETTING
See Also:
Constant Field Values

BLIP__GAMMA

public static final short BLIP__GAMMA
See Also:
Constant Field Values

BLIP__PICTUREID

public static final short BLIP__PICTUREID
See Also:
Constant Field Values

BLIP__DOUBLEMOD

public static final short BLIP__DOUBLEMOD
See Also:
Constant Field Values

BLIP__PICTUREFILLMOD

public static final short BLIP__PICTUREFILLMOD
See Also:
Constant Field Values

BLIP__PICTURELINE

public static final short BLIP__PICTURELINE
See Also:
Constant Field Values

BLIP__PRINTBLIP

public static final short BLIP__PRINTBLIP
See Also:
Constant Field Values

BLIP__PRINTBLIPFILENAME

public static final short BLIP__PRINTBLIPFILENAME
See Also:
Constant Field Values

BLIP__PRINTFLAGS

public static final short BLIP__PRINTFLAGS
See Also:
Constant Field Values

BLIP__NOHITTESTPICTURE

public static final short BLIP__NOHITTESTPICTURE
See Also:
Constant Field Values

BLIP__PICTUREGRAY

public static final short BLIP__PICTUREGRAY
See Also:
Constant Field Values

BLIP__PICTUREBILEVEL

public static final short BLIP__PICTUREBILEVEL
See Also:
Constant Field Values

BLIP__PICTUREACTIVE

public static final short BLIP__PICTUREACTIVE
See Also:
Constant Field Values

GEOMETRY__LEFT

public static final short GEOMETRY__LEFT
See Also:
Constant Field Values

GEOMETRY__TOP

public static final short GEOMETRY__TOP
See Also:
Constant Field Values

GEOMETRY__RIGHT

public static final short GEOMETRY__RIGHT
See Also:
Constant Field Values

GEOMETRY__BOTTOM

public static final short GEOMETRY__BOTTOM
See Also:
Constant Field Values

GEOMETRY__SHAPEPATH

public static final short GEOMETRY__SHAPEPATH
See Also:
Constant Field Values

GEOMETRY__VERTICES

public static final short GEOMETRY__VERTICES
See Also:
Constant Field Values

GEOMETRY__SEGMENTINFO

public static final short GEOMETRY__SEGMENTINFO
See Also:
Constant Field Values

GEOMETRY__ADJUSTVALUE

public static final short GEOMETRY__ADJUSTVALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST2VALUE

public static final short GEOMETRY__ADJUST2VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST3VALUE

public static final short GEOMETRY__ADJUST3VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST4VALUE

public static final short GEOMETRY__ADJUST4VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST5VALUE

public static final short GEOMETRY__ADJUST5VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST6VALUE

public static final short GEOMETRY__ADJUST6VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST7VALUE

public static final short GEOMETRY__ADJUST7VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST8VALUE

public static final short GEOMETRY__ADJUST8VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST9VALUE

public static final short GEOMETRY__ADJUST9VALUE
See Also:
Constant Field Values

GEOMETRY__ADJUST10VALUE

public static final short GEOMETRY__ADJUST10VALUE
See Also:
Constant Field Values

GEOMETRY__SHADOWok

public static final short GEOMETRY__SHADOWok
See Also:
Constant Field Values

GEOMETRY__3DOK

public static final short GEOMETRY__3DOK
See Also:
Constant Field Values

GEOMETRY__LINEOK

public static final short GEOMETRY__LINEOK
See Also:
Constant Field Values

GEOMETRY__GEOTEXTOK

public static final short GEOMETRY__GEOTEXTOK
See Also:
Constant Field Values

GEOMETRY__FILLSHADESHAPEOK

public static final short GEOMETRY__FILLSHADESHAPEOK
See Also:
Constant Field Values

GEOMETRY__FILLOK

public static final short GEOMETRY__FILLOK
See Also:
Constant Field Values

FILL__FILLTYPE

public static final short FILL__FILLTYPE
See Also:
Constant Field Values

FILL__FILLCOLOR

public static final short FILL__FILLCOLOR
See Also:
Constant Field Values

FILL__FILLOPACITY

public static final short FILL__FILLOPACITY
See Also:
Constant Field Values

FILL__FILLBACKCOLOR

public static final short FILL__FILLBACKCOLOR
See Also:
Constant Field Values

FILL__BACKOPACITY

public static final short FILL__BACKOPACITY
See Also:
Constant Field Values

FILL__CRMOD

public static final short FILL__CRMOD
See Also:
Constant Field Values

FILL__PATTERNTEXTURE

public static final short FILL__PATTERNTEXTURE
See Also:
Constant Field Values

FILL__BLIPFILENAME

public static final short FILL__BLIPFILENAME
See Also:
Constant Field Values

FILL__BLIPFLAGS

public static final short FILL__BLIPFLAGS
See Also:
Constant Field Values

FILL__WIDTH

public static final short FILL__WIDTH
See Also:
Constant Field Values

FILL__HEIGHT

public static final short FILL__HEIGHT
See Also:
Constant Field Values

FILL__ANGLE

public static final short FILL__ANGLE
See Also:
Constant Field Values

FILL__FOCUS

public static final short FILL__FOCUS
See Also:
Constant Field Values

FILL__TOLEFT

public static final short FILL__TOLEFT
See Also:
Constant Field Values

FILL__TOTOP

public static final short FILL__TOTOP
See Also:
Constant Field Values

FILL__TORIGHT

public static final short FILL__TORIGHT
See Also:
Constant Field Values

FILL__TOBOTTOM

public static final short FILL__TOBOTTOM
See Also:
Constant Field Values

FILL__RECTLEFT

public static final short FILL__RECTLEFT
See Also:
Constant Field Values

FILL__RECTTOP

public static final short FILL__RECTTOP
See Also:
Constant Field Values

FILL__RECTRIGHT

public static final short FILL__RECTRIGHT
See Also:
Constant Field Values

FILL__RECTBOTTOM

public static final short FILL__RECTBOTTOM
See Also:
Constant Field Values

FILL__DZTYPE

public static final short FILL__DZTYPE
See Also:
Constant Field Values

FILL__SHADEPRESET

public static final short FILL__SHADEPRESET
See Also:
Constant Field Values

FILL__SHADECOLORS

public static final short FILL__SHADECOLORS
See Also:
Constant Field Values

FILL__ORIGINX

public static final short FILL__ORIGINX
See Also:
Constant Field Values

FILL__ORIGINY

public static final short FILL__ORIGINY
See Also:
Constant Field Values

FILL__SHAPEORIGINX

public static final short FILL__SHAPEORIGINX
See Also:
Constant Field Values

FILL__SHAPEORIGINY

public static final short FILL__SHAPEORIGINY
See Also:
Constant Field Values

FILL__SHADETYPE

public static final short FILL__SHADETYPE
See Also:
Constant Field Values

FILL__FILLED

public static final short FILL__FILLED
See Also:
Constant Field Values

FILL__HITTESTFILL

public static final short FILL__HITTESTFILL
See Also:
Constant Field Values

FILL__SHAPE

public static final short FILL__SHAPE
See Also:
Constant Field Values

FILL__USERECT

public static final short FILL__USERECT
See Also:
Constant Field Values

FILL__NOFILLHITTEST

public static final short FILL__NOFILLHITTEST
See Also:
Constant Field Values

LINESTYLE__COLOR

public static final short LINESTYLE__COLOR
See Also:
Constant Field Values

LINESTYLE__OPACITY

public static final short LINESTYLE__OPACITY
See Also:
Constant Field Values

LINESTYLE__BACKCOLOR

public static final short LINESTYLE__BACKCOLOR
See Also:
Constant Field Values

LINESTYLE__CRMOD

public static final short LINESTYLE__CRMOD
See Also:
Constant Field Values

LINESTYLE__LINETYPE

public static final short LINESTYLE__LINETYPE
See Also:
Constant Field Values

LINESTYLE__FILLBLIP

public static final short LINESTYLE__FILLBLIP
See Also:
Constant Field Values

LINESTYLE__FILLBLIPNAME

public static final short LINESTYLE__FILLBLIPNAME
See Also:
Constant Field Values

LINESTYLE__FILLBLIPFLAGS

public static final short LINESTYLE__FILLBLIPFLAGS
See Also:
Constant Field Values

LINESTYLE__FILLWIDTH

public static final short LINESTYLE__FILLWIDTH
See Also:
Constant Field Values

LINESTYLE__FILLHEIGHT

public static final short LINESTYLE__FILLHEIGHT
See Also:
Constant Field Values

LINESTYLE__FILLDZTYPE

public static final short LINESTYLE__FILLDZTYPE
See Also:
Constant Field Values

LINESTYLE__LINEWIDTH

public static final short LINESTYLE__LINEWIDTH
See Also:
Constant Field Values

LINESTYLE__LINEMITERLIMIT

public static final short LINESTYLE__LINEMITERLIMIT
See Also:
Constant Field Values

LINESTYLE__LINESTYLE

public static final short LINESTYLE__LINESTYLE
See Also:
Constant Field Values

LINESTYLE__LINEDASHING

public static final short LINESTYLE__LINEDASHING
See Also:
Constant Field Values

LINESTYLE__LINEDASHSTYLE

public static final short LINESTYLE__LINEDASHSTYLE
See Also:
Constant Field Values

LINESTYLE__LINESTARTARROWHEAD

public static final short LINESTYLE__LINESTARTARROWHEAD
See Also:
Constant Field Values

LINESTYLE__LINEENDARROWHEAD

public static final short LINESTYLE__LINEENDARROWHEAD
See Also:
Constant Field Values

LINESTYLE__LINESTARTARROWWIDTH

public static final short LINESTYLE__LINESTARTARROWWIDTH
See Also:
Constant Field Values

LINESTYLE__LINEESTARTARROWLENGTH

public static final short LINESTYLE__LINEESTARTARROWLENGTH
See Also:
Constant Field Values

LINESTYLE__LINEENDARROWWIDTH

public static final short LINESTYLE__LINEENDARROWWIDTH
See Also:
Constant Field Values

LINESTYLE__LINEENDARROWLENGTH

public static final short LINESTYLE__LINEENDARROWLENGTH
See Also:
Constant Field Values

LINESTYLE__LINEJOINSTYLE

public static final short LINESTYLE__LINEJOINSTYLE
See Also:
Constant Field Values

LINESTYLE__LINEENDCAPSTYLE

public static final short LINESTYLE__LINEENDCAPSTYLE
See Also:
Constant Field Values

LINESTYLE__ARROWHEADSOK

public static final short LINESTYLE__ARROWHEADSOK
See Also:
Constant Field Values

LINESTYLE__ANYLINE

public static final short LINESTYLE__ANYLINE
See Also:
Constant Field Values

LINESTYLE__HITLINETEST

public static final short LINESTYLE__HITLINETEST
See Also:
Constant Field Values

LINESTYLE__LINEFILLSHAPE

public static final short LINESTYLE__LINEFILLSHAPE
See Also:
Constant Field Values

LINESTYLE__NOLINEDRAWDASH

public static final short LINESTYLE__NOLINEDRAWDASH
See Also:
Constant Field Values

SHADOWSTYLE__TYPE

public static final short SHADOWSTYLE__TYPE
See Also:
Constant Field Values

SHADOWSTYLE__COLOR

public static final short SHADOWSTYLE__COLOR
See Also:
Constant Field Values

SHADOWSTYLE__HIGHLIGHT

public static final short SHADOWSTYLE__HIGHLIGHT
See Also:
Constant Field Values

SHADOWSTYLE__CRMOD

public static final short SHADOWSTYLE__CRMOD
See Also:
Constant Field Values

SHADOWSTYLE__OPACITY

public static final short SHADOWSTYLE__OPACITY
See Also:
Constant Field Values

SHADOWSTYLE__OFFSETX

public static final short SHADOWSTYLE__OFFSETX
See Also:
Constant Field Values

SHADOWSTYLE__OFFSETY

public static final short SHADOWSTYLE__OFFSETY
See Also:
Constant Field Values

SHADOWSTYLE__SECONDOFFSETX

public static final short SHADOWSTYLE__SECONDOFFSETX
See Also:
Constant Field Values

SHADOWSTYLE__SECONDOFFSETY

public static final short SHADOWSTYLE__SECONDOFFSETY
See Also:
Constant Field Values

SHADOWSTYLE__SCALEXTOX

public static final short SHADOWSTYLE__SCALEXTOX
See Also:
Constant Field Values

SHADOWSTYLE__SCALEYTOX

public static final short SHADOWSTYLE__SCALEYTOX
See Also:
Constant Field Values

SHADOWSTYLE__SCALEXTOY

public static final short SHADOWSTYLE__SCALEXTOY
See Also:
Constant Field Values

SHADOWSTYLE__SCALEYTOY

public static final short SHADOWSTYLE__SCALEYTOY
See Also:
Constant Field Values

SHADOWSTYLE__PERSPECTIVEX

public static final short SHADOWSTYLE__PERSPECTIVEX
See Also:
Constant Field Values

SHADOWSTYLE__PERSPECTIVEY

public static final short SHADOWSTYLE__PERSPECTIVEY
See Also:
Constant Field Values

SHADOWSTYLE__WEIGHT

public static final short SHADOWSTYLE__WEIGHT
See Also:
Constant Field Values

SHADOWSTYLE__ORIGINX

public static final short SHADOWSTYLE__ORIGINX
See Also:
Constant Field Values

SHADOWSTYLE__ORIGINY

public static final short SHADOWSTYLE__ORIGINY
See Also:
Constant Field Values

SHADOWSTYLE__SHADOW

public static final short SHADOWSTYLE__SHADOW
See Also:
Constant Field Values

SHADOWSTYLE__SHADOWOBSURED

public static final short SHADOWSTYLE__SHADOWOBSURED
See Also:
Constant Field Values

PERSPECTIVE__TYPE

public static final short PERSPECTIVE__TYPE
See Also:
Constant Field Values

PERSPECTIVE__OFFSETX

public static final short PERSPECTIVE__OFFSETX
See Also:
Constant Field Values

PERSPECTIVE__OFFSETY

public static final short PERSPECTIVE__OFFSETY
See Also:
Constant Field Values

PERSPECTIVE__SCALEXTOX

public static final short PERSPECTIVE__SCALEXTOX
See Also:
Constant Field Values

PERSPECTIVE__SCALEYTOX

public static final short PERSPECTIVE__SCALEYTOX
See Also:
Constant Field Values

PERSPECTIVE__SCALEXTOY

public static final short PERSPECTIVE__SCALEXTOY
See Also:
Constant Field Values

PERSPECTIVE__SCALEYTOY

public static final short PERSPECTIVE__SCALEYTOY
See Also:
Constant Field Values

PERSPECTIVE__PERSPECTIVEX

public static final short PERSPECTIVE__PERSPECTIVEX
See Also:
Constant Field Values

PERSPECTIVE__PERSPECTIVEY

public static final short PERSPECTIVE__PERSPECTIVEY
See Also:
Constant Field Values

PERSPECTIVE__WEIGHT

public static final short PERSPECTIVE__WEIGHT
See Also:
Constant Field Values

PERSPECTIVE__ORIGINX

public static final short PERSPECTIVE__ORIGINX
See Also:
Constant Field Values

PERSPECTIVE__ORIGINY

public static final short PERSPECTIVE__ORIGINY
See Also:
Constant Field Values

PERSPECTIVE__PERSPECTIVEON

public static final short PERSPECTIVE__PERSPECTIVEON
See Also:
Constant Field Values

THREED__SPECULARAMOUNT

public static final short THREED__SPECULARAMOUNT
See Also:
Constant Field Values

THREED__DIFFUSEAMOUNT

public static final short THREED__DIFFUSEAMOUNT
See Also:
Constant Field Values

THREED__SHININESS

public static final short THREED__SHININESS
See Also:
Constant Field Values

THREED__EDGETHICKNESS

public static final short THREED__EDGETHICKNESS
See Also:
Constant Field Values

THREED__EXTRUDEFORWARD

public static final short THREED__EXTRUDEFORWARD
See Also:
Constant Field Values

THREED__EXTRUDEBACKWARD

public static final short THREED__EXTRUDEBACKWARD
See Also:
Constant Field Values

THREED__EXTRUDEPLANE

public static final short THREED__EXTRUDEPLANE
See Also:
Constant Field Values

THREED__EXTRUSIONCOLOR

public static final short THREED__EXTRUSIONCOLOR
See Also:
Constant Field Values

THREED__CRMOD

public static final short THREED__CRMOD
See Also:
Constant Field Values

THREED__3DEFFECT

public static final short THREED__3DEFFECT
See Also:
Constant Field Values

THREED__METALLIC

public static final short THREED__METALLIC
See Also:
Constant Field Values

THREED__USEEXTRUSIONCOLOR

public static final short THREED__USEEXTRUSIONCOLOR
See Also:
Constant Field Values

THREED__LIGHTFACE

public static final short THREED__LIGHTFACE
See Also:
Constant Field Values

THREEDSTYLE__YROTATIONANGLE

public static final short THREEDSTYLE__YROTATIONANGLE
See Also:
Constant Field Values

THREEDSTYLE__XROTATIONANGLE

public static final short THREEDSTYLE__XROTATIONANGLE
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONAXISX

public static final short THREEDSTYLE__ROTATIONAXISX
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONAXISY

public static final short THREEDSTYLE__ROTATIONAXISY
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONAXISZ

public static final short THREEDSTYLE__ROTATIONAXISZ
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONANGLE

public static final short THREEDSTYLE__ROTATIONANGLE
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONCENTERX

public static final short THREEDSTYLE__ROTATIONCENTERX
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONCENTERY

public static final short THREEDSTYLE__ROTATIONCENTERY
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONCENTERZ

public static final short THREEDSTYLE__ROTATIONCENTERZ
See Also:
Constant Field Values

THREEDSTYLE__RENDERMODE

public static final short THREEDSTYLE__RENDERMODE
See Also:
Constant Field Values

THREEDSTYLE__TOLERANCE

public static final short THREEDSTYLE__TOLERANCE
See Also:
Constant Field Values

THREEDSTYLE__XVIEWPOINT

public static final short THREEDSTYLE__XVIEWPOINT
See Also:
Constant Field Values

THREEDSTYLE__YVIEWPOINT

public static final short THREEDSTYLE__YVIEWPOINT
See Also:
Constant Field Values

THREEDSTYLE__ZVIEWPOINT

public static final short THREEDSTYLE__ZVIEWPOINT
See Also:
Constant Field Values

THREEDSTYLE__ORIGINX

public static final short THREEDSTYLE__ORIGINX
See Also:
Constant Field Values

THREEDSTYLE__ORIGINY

public static final short THREEDSTYLE__ORIGINY
See Also:
Constant Field Values

THREEDSTYLE__SKEWANGLE

public static final short THREEDSTYLE__SKEWANGLE
See Also:
Constant Field Values

THREEDSTYLE__SKEWAMOUNT

public static final short THREEDSTYLE__SKEWAMOUNT
See Also:
Constant Field Values

THREEDSTYLE__AMBIENTINTENSITY

public static final short THREEDSTYLE__AMBIENTINTENSITY
See Also:
Constant Field Values

THREEDSTYLE__KEYX

public static final short THREEDSTYLE__KEYX
See Also:
Constant Field Values

THREEDSTYLE__KEYY

public static final short THREEDSTYLE__KEYY
See Also:
Constant Field Values

THREEDSTYLE__KEYZ

public static final short THREEDSTYLE__KEYZ
See Also:
Constant Field Values

THREEDSTYLE__KEYINTENSITY

public static final short THREEDSTYLE__KEYINTENSITY
See Also:
Constant Field Values

THREEDSTYLE__FILLX

public static final short THREEDSTYLE__FILLX
See Also:
Constant Field Values

THREEDSTYLE__FILLY

public static final short THREEDSTYLE__FILLY
See Also:
Constant Field Values

THREEDSTYLE__FILLZ

public static final short THREEDSTYLE__FILLZ
See Also:
Constant Field Values

THREEDSTYLE__FILLINTENSITY

public static final short THREEDSTYLE__FILLINTENSITY
See Also:
Constant Field Values

THREEDSTYLE__CONSTRAINROTATION

public static final short THREEDSTYLE__CONSTRAINROTATION
See Also:
Constant Field Values

THREEDSTYLE__ROTATIONCENTERAUTO

public static final short THREEDSTYLE__ROTATIONCENTERAUTO
See Also:
Constant Field Values

THREEDSTYLE__PARALLEL

public static final short THREEDSTYLE__PARALLEL
See Also:
Constant Field Values

THREEDSTYLE__KEYHARSH

public static final short THREEDSTYLE__KEYHARSH
See Also:
Constant Field Values

THREEDSTYLE__FILLHARSH

public static final short THREEDSTYLE__FILLHARSH
See Also:
Constant Field Values

SHAPE__MASTER

public static final short SHAPE__MASTER
See Also:
Constant Field Values

SHAPE__CONNECTORSTYLE

public static final short SHAPE__CONNECTORSTYLE
See Also:
Constant Field Values

SHAPE__BLACKANDWHITESETTINGS

public static final short SHAPE__BLACKANDWHITESETTINGS
See Also:
Constant Field Values

SHAPE__WMODEPUREBW

public static final short SHAPE__WMODEPUREBW
See Also:
Constant Field Values

SHAPE__WMODEBW

public static final short SHAPE__WMODEBW
See Also:
Constant Field Values

SHAPE__OLEICON

public static final short SHAPE__OLEICON
See Also:
Constant Field Values

SHAPE__PREFERRELATIVERESIZE

public static final short SHAPE__PREFERRELATIVERESIZE
See Also:
Constant Field Values

SHAPE__LOCKSHAPETYPE

public static final short SHAPE__LOCKSHAPETYPE
See Also:
Constant Field Values

SHAPE__DELETEATTACHEDOBJECT

public static final short SHAPE__DELETEATTACHEDOBJECT
See Also:
Constant Field Values

SHAPE__BACKGROUNDSHAPE

public static final short SHAPE__BACKGROUNDSHAPE
See Also:
Constant Field Values

CALLOUT__CALLOUTTYPE

public static final short CALLOUT__CALLOUTTYPE
See Also:
Constant Field Values

CALLOUT__XYCALLOUTGAP

public static final short CALLOUT__XYCALLOUTGAP
See Also:
Constant Field Values

CALLOUT__CALLOUTANGLE

public static final short CALLOUT__CALLOUTANGLE
See Also:
Constant Field Values

CALLOUT__CALLOUTDROPTYPE

public static final short CALLOUT__CALLOUTDROPTYPE
See Also:
Constant Field Values

CALLOUT__CALLOUTDROPSPECIFIED

public static final short CALLOUT__CALLOUTDROPSPECIFIED
See Also:
Constant Field Values

CALLOUT__CALLOUTLENGTHSPECIFIED

public static final short CALLOUT__CALLOUTLENGTHSPECIFIED
See Also:
Constant Field Values

CALLOUT__ISCALLOUT

public static final short CALLOUT__ISCALLOUT
See Also:
Constant Field Values

CALLOUT__CALLOUTACCENTBAR

public static final short CALLOUT__CALLOUTACCENTBAR
See Also:
Constant Field Values

CALLOUT__CALLOUTTEXTBORDER

public static final short CALLOUT__CALLOUTTEXTBORDER
See Also:
Constant Field Values

CALLOUT__CALLOUTMINUSX

public static final short CALLOUT__CALLOUTMINUSX
See Also:
Constant Field Values

CALLOUT__CALLOUTMINUSY

public static final short CALLOUT__CALLOUTMINUSY
See Also:
Constant Field Values

CALLOUT__DROPAUTO

public static final short CALLOUT__DROPAUTO
See Also:
Constant Field Values

CALLOUT__LENGTHSPECIFIED

public static final short CALLOUT__LENGTHSPECIFIED
See Also:
Constant Field Values

GROUPSHAPE__SHAPENAME

public static final short GROUPSHAPE__SHAPENAME
See Also:
Constant Field Values

GROUPSHAPE__DESCRIPTION

public static final short GROUPSHAPE__DESCRIPTION
See Also:
Constant Field Values

GROUPSHAPE__HYPERLINK

public static final short GROUPSHAPE__HYPERLINK
See Also:
Constant Field Values

GROUPSHAPE__WRAPPOLYGONVERTICES

public static final short GROUPSHAPE__WRAPPOLYGONVERTICES
See Also:
Constant Field Values

GROUPSHAPE__WRAPDISTLEFT

public static final short GROUPSHAPE__WRAPDISTLEFT
See Also:
Constant Field Values

GROUPSHAPE__WRAPDISTTOP

public static final short GROUPSHAPE__WRAPDISTTOP
See Also:
Constant Field Values

GROUPSHAPE__WRAPDISTRIGHT

public static final short GROUPSHAPE__WRAPDISTRIGHT
See Also:
Constant Field Values

GROUPSHAPE__WRAPDISTBOTTOM

public static final short GROUPSHAPE__WRAPDISTBOTTOM
See Also:
Constant Field Values

GROUPSHAPE__REGROUPID

public static final short GROUPSHAPE__REGROUPID
See Also:
Constant Field Values

GROUPSHAPE__UNUSED906

public static final short GROUPSHAPE__UNUSED906
See Also:
Constant Field Values

GROUPSHAPE__TOOLTIP

public static final short GROUPSHAPE__TOOLTIP
See Also:
Constant Field Values

GROUPSHAPE__SCRIPT

public static final short GROUPSHAPE__SCRIPT
See Also:
Constant Field Values

GROUPSHAPE__POSH

public static final short GROUPSHAPE__POSH
See Also:
Constant Field Values

GROUPSHAPE__POSRELH

public static final short GROUPSHAPE__POSRELH
See Also:
Constant Field Values

GROUPSHAPE__POSV

public static final short GROUPSHAPE__POSV
See Also:
Constant Field Values

GROUPSHAPE__POSRELV

public static final short GROUPSHAPE__POSRELV
See Also:
Constant Field Values

GROUPSHAPE__HR_PCT

public static final short GROUPSHAPE__HR_PCT
See Also:
Constant Field Values

GROUPSHAPE__HR_ALIGN

public static final short GROUPSHAPE__HR_ALIGN
See Also:
Constant Field Values

GROUPSHAPE__HR_HEIGHT

public static final short GROUPSHAPE__HR_HEIGHT
See Also:
Constant Field Values

GROUPSHAPE__HR_WIDTH

public static final short GROUPSHAPE__HR_WIDTH
See Also:
Constant Field Values

GROUPSHAPE__SCRIPTEXT

public static final short GROUPSHAPE__SCRIPTEXT
See Also:
Constant Field Values

GROUPSHAPE__SCRIPTLANG

public static final short GROUPSHAPE__SCRIPTLANG
See Also:
Constant Field Values

GROUPSHAPE__BORDERTOPCOLOR

public static final short GROUPSHAPE__BORDERTOPCOLOR
See Also:
Constant Field Values

GROUPSHAPE__BORDERLEFTCOLOR

public static final short GROUPSHAPE__BORDERLEFTCOLOR
See Also:
Constant Field Values

GROUPSHAPE__BORDERBOTTOMCOLOR

public static final short GROUPSHAPE__BORDERBOTTOMCOLOR
See Also:
Constant Field Values

GROUPSHAPE__BORDERRIGHTCOLOR

public static final short GROUPSHAPE__BORDERRIGHTCOLOR
See Also:
Constant Field Values

GROUPSHAPE__TABLEPROPERTIES

public static final short GROUPSHAPE__TABLEPROPERTIES
See Also:
Constant Field Values

GROUPSHAPE__TABLEROWPROPERTIES

public static final short GROUPSHAPE__TABLEROWPROPERTIES
See Also:
Constant Field Values

GROUPSHAPE__WEBBOT

public static final short GROUPSHAPE__WEBBOT
See Also:
Constant Field Values

GROUPSHAPE__METROBLOB

public static final short GROUPSHAPE__METROBLOB
See Also:
Constant Field Values

GROUPSHAPE__ZORDER

public static final short GROUPSHAPE__ZORDER
See Also:
Constant Field Values

GROUPSHAPE__FLAGS

public static final short GROUPSHAPE__FLAGS
See Also:
Constant Field Values

GROUPSHAPE__EDITEDWRAP

public static final short GROUPSHAPE__EDITEDWRAP
See Also:
Constant Field Values

GROUPSHAPE__BEHINDDOCUMENT

public static final short GROUPSHAPE__BEHINDDOCUMENT
See Also:
Constant Field Values

GROUPSHAPE__ONDBLCLICKNOTIFY

public static final short GROUPSHAPE__ONDBLCLICKNOTIFY
See Also:
Constant Field Values

GROUPSHAPE__ISBUTTON

public static final short GROUPSHAPE__ISBUTTON
See Also:
Constant Field Values

GROUPSHAPE__1DADJUSTMENT

public static final short GROUPSHAPE__1DADJUSTMENT
See Also:
Constant Field Values

GROUPSHAPE__HIDDEN

public static final short GROUPSHAPE__HIDDEN
See Also:
Constant Field Values

GROUPSHAPE__PRINT

public static final short GROUPSHAPE__PRINT
See Also:
Constant Field Values
Constructor Detail

EscherProperties

public EscherProperties()
Method Detail

getPropertyName

public static java.lang.String getPropertyName(short propertyId)

getPropertyType

public static byte getPropertyType(short propertyId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherProperty

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperty
Direct Known Subclasses:
EscherComplexProperty, EscherSimpleProperty
public abstract class EscherProperty
extends java.lang.Object

This is the abstract base class for all escher properties.

Author:
Glen Stampoultzis (glens at apache.org)
See Also:
EscherOptRecord

Constructor Summary
EscherProperty(short id)
The id is distinct from the actual property number.
EscherProperty(short propertyNumber, boolean isComplex, boolean isBlipId)
Constructs a new escher property.
Method Summary
short | getId()
java.lang.String | getName()
short | getPropertyNumber()
int | getPropertySize() Most properties are just 6 bytes in length.
boolean | isBlipId()
boolean | isComplex()
abstract int | serializeComplexPart(byte[] data, int pos) Escher properties consist of a simple fixed length part and a complex variable length part.
abstract int | serializeSimplePart(byte[] data, int pos) Escher properties consist of a simple fixed length part and a complex variable length part.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherProperty

public EscherProperty(short id)
The id is distinct from the actual property number. The id includes the property number the blip id flag and an indicator whether the property is complex or not.

EscherProperty

public EscherProperty(short propertyNumber,
                      boolean isComplex,
                      boolean isBlipId)
Constructs a new escher property. The three parameters are combined to form a property id.

Method Detail

getId

public short getId()

getPropertyNumber

public short getPropertyNumber()

isComplex

public boolean isComplex()

isBlipId

public boolean isBlipId()

getName

public java.lang.String getName()

getPropertySize

public int getPropertySize()
Most properties are just 6 bytes in length. Override this if we're dealing with complex properties.

serializeSimplePart

public abstract int serializeSimplePart(byte[] data,
                                        int pos)
Escher properties consist of a simple fixed length part and a complex variable length part. The fixed length part is serialized first.

serializeComplexPart

public abstract int serializeComplexPart(byte[] data,
                                         int pos)
Escher properties consist of a simple fixed length part and a complex variable length part. The fixed length part is serialized first.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherPropertyFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherPropertyFactory

java.lang.Object
    extended by  org.apache.poi.ddf.EscherPropertyFactory

public final class EscherPropertyFactory
extends java.lang.Object

Generates a property given a reference into the byte array storing that property.

Author:
Glen Stampoultzis

Constructor Summary
EscherPropertyFactory()
Method Summary
 java.util.List<EscherProperty> createProperties(byte[] data, int offset, short numProperties)
Create new properties from a byte array.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherPropertyFactory

public EscherPropertyFactory()
Method Detail

createProperties

public java.util.List<EscherProperty> createProperties(byte[] data,
                                                       int offset,
                                                       short numProperties)
Create new properties from a byte array.

Parameters:
data - The byte array containing the property
offset - The starting offset into the byte array
Returns:
The new properties
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherPropertyMetaData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherPropertyMetaData

java.lang.Object
    extended by  org.apache.poi.ddf.EscherPropertyMetaData

public class EscherPropertyMetaData
extends java.lang.Object

This class stores the type and description of an escher property.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static byte | TYPE_ARRAY
static byte | TYPE_BOOLEAN
static byte | TYPE_RGB
static byte | TYPE_SHAPEPATH
static byte | TYPE_SIMPLE
static byte | TYPE_UNKNOWN
Constructor Summary
EscherPropertyMetaData(java.lang.String description)
EscherPropertyMetaData(java.lang.String description, byte type)
Method Summary
java.lang.String | getDescription()
byte | getType()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TYPE_UNKNOWN

public static final byte TYPE_UNKNOWN
See Also:
Constant Field Values

TYPE_BOOLEAN

public static final byte TYPE_BOOLEAN
See Also:
Constant Field Values

TYPE_RGB

public static final byte TYPE_RGB
See Also:
Constant Field Values

TYPE_SHAPEPATH

public static final byte TYPE_SHAPEPATH
See Also:
Constant Field Values

TYPE_SIMPLE

public static final byte TYPE_SIMPLE
See Also:
Constant Field Values

TYPE_ARRAY

public static final byte TYPE_ARRAY
See Also:
Constant Field Values
Constructor Detail

EscherPropertyMetaData

public EscherPropertyMetaData(java.lang.String description)
Parameters:
description - The description of the escher property.

EscherPropertyMetaData

public EscherPropertyMetaData(java.lang.String description,
                              byte type)
Parameters:
description - The description of the escher property.
type - The type of the property.
Method Detail

getDescription

public java.lang.String getDescription()

getType

public byte getType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
Direct Known Subclasses:
AbstractEscherOptRecord, EscherBlipRecord, EscherBSERecord, EscherChildAnchorRecord, EscherClientAnchorRecord, EscherClientDataRecord, EscherContainerRecord, EscherDggRecord, EscherDgRecord, EscherSpgrRecord, EscherSplitMenuColorsRecord, EscherSpRecord, EscherTextboxRecord, UnknownEscherRecord
public abstract class EscherRecord
extends java.lang.Object

The base abstract record from which all escher records are defined. Subclasses will need to define methods for serialization/deserialization and for determining the record size.

Author:
Glen Stampoultzis

Constructor Summary
EscherRecord()
Create a new instance
Method Summary
 java.lang.Object clone()
Escher records may need to be clonable in the future.
 void display(java.io.PrintWriter w, int indent)
The display methods allows escher variables to print the record names according to their hierarchy.
protected  int fillFields(byte[] data, EscherRecordFactory f)
Delegates to fillFields(byte[], int, EscherRecordFactory)
abstract  int fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
The contract of this method is to deserialize an escher record including it's children.
 EscherRecord getChild(int index)
Returns the indexed child record.
 java.util.List<EscherRecord> getChildRecords()
 short getInstance()
Returns the instance part of the option record.
 short getOptions()

options is an internal field.

 short getRecordId()
Return the current record id.
abstract  java.lang.String getRecordName()
Subclasses should return the short name for this escher record.
abstract  int getRecordSize()
Subclasses should effeciently return the number of bytes required to serialize the record.
 short getVersion()
Returns the version part of the option record.
 boolean isContainerRecord()
Determine whether this is a container record by inspecting the option field.
protected  int readHeader(byte[] data, int offset)
Reads the 8 byte header information and populates the options and recordId records.
protected static short readInstance(byte[] data, int offset)
Read the options field from header and return instance part of it.
 byte[] serialize()
Serializes to a new byte array.
 int serialize(int offset, byte[] data)
Serializes to an existing byte array without serialization listener.
abstract  int serialize(int offset, byte[] data, EscherSerializationListener listener)
Serializes the record to an existing byte array.
 void setChildRecords(java.util.List<EscherRecord> childRecords)
Sets the child records for this record.
 void setInstance(short value)
Sets the instance part of record
 void setOptions(short options)
Set the options this this record.
 void setRecordId(short recordId)
Sets the record id for this record.
 void setVersion(short value)
Sets the version part of record
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherRecord

public EscherRecord()
Create a new instance

Method Detail

fillFields

protected int fillFields(byte[] data,
                         EscherRecordFactory f)
Delegates to fillFields(byte[], int, EscherRecordFactory)

See Also:
fillFields(byte[], int, org.apache.poi.ddf.EscherRecordFactory)

fillFields

public abstract int fillFields(byte[] data,
                               int offset,
                               EscherRecordFactory recordFactory)
The contract of this method is to deserialize an escher record including it's children.

Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

readHeader

protected int readHeader(byte[] data,
                         int offset)
Reads the 8 byte header information and populates the options and recordId records.

Parameters:
data - the byte array to read from
offset - the offset to start reading from
Returns:
the number of bytes remaining in this record. This may include the children if this is a container.

readInstance

protected static short readInstance(byte[] data,
                                    int offset)
Read the options field from header and return instance part of it.

Parameters:
data - the byte array to read from
offset - the offset to start reading from
Returns:
value of instance part of options field

isContainerRecord

public boolean isContainerRecord()
Determine whether this is a container record by inspecting the option field.

Returns:
true is this is a container field.

getOptions

@Internal
public short getOptions()

options is an internal field. Use setInstance(short) ()} and setVersion(short) ()} to set the actual fields.

Returns:
The options field for this record. All records have one.

setOptions

@Internal
public void setOptions(short options)
Set the options this this record. Container records should have the last nibble set to 0xF.

options is an internal field. Use getInstance() and getVersion() to access actual fields.

serialize

public byte[] serialize()
Serializes to a new byte array. This is done by delegating to serialize(int, byte[]);

Returns:
the serialized record.
See Also:
serialize(int, byte[])

serialize

public int serialize(int offset,
                     byte[] data)
Serializes to an existing byte array without serialization listener. This is done by delegating to serialize(int, byte[], EscherSerializationListener).

Parameters:
offset - the offset within the data byte array.
data - the data array to serialize to.
Returns:
The number of bytes written.
See Also:
serialize(int, byte[], org.apache.poi.ddf.EscherSerializationListener)

serialize

public abstract int serialize(int offset,
                              byte[] data,
                              EscherSerializationListener listener)
Serializes the record to an existing byte array.

Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public abstract int getRecordSize()
Subclasses should effeciently return the number of bytes required to serialize the record.

Returns:
number of bytes

getRecordId

public short getRecordId()
Return the current record id.

Returns:
The 16 bit record id.

setRecordId

public void setRecordId(short recordId)
Sets the record id for this record.

getChildRecords

public java.util.List<EscherRecord> getChildRecords()
Returns:
Returns the children of this record. By default this will be an empty list. EscherCotainerRecord is the only record that may contain children.
See Also:
EscherContainerRecord

setChildRecords

public void setChildRecords(java.util.List<EscherRecord> childRecords)
Sets the child records for this record. By default this will throw an exception as only EscherContainerRecords may have children.

Parameters:
childRecords - Not used in base implementation.

clone

public java.lang.Object clone()
Escher records may need to be clonable in the future.

Overrides:
clone in class java.lang.Object

getChild

public EscherRecord getChild(int index)
Returns the indexed child record.

display

public void display(java.io.PrintWriter w,
                    int indent)
The display methods allows escher variables to print the record names according to their hierarchy.

Parameters:
w - The print writer to output to.
indent - The current indent level.

getRecordName

public abstract java.lang.String getRecordName()
Subclasses should return the short name for this escher record.

getInstance

public short getInstance()
Returns the instance part of the option record.

Returns:
The instance part of the record

setInstance

public void setInstance(short value)
Sets the instance part of record

Parameters:
value - instance part value

getVersion

public short getVersion()
Returns the version part of the option record.

Returns:
The version part of the option record

setVersion

public void setVersion(short value)
Sets the version part of record

Parameters:
value - version part value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherRecordFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Interface EscherRecordFactory

All Known Implementing Classes:
DefaultEscherRecordFactory
public interface EscherRecordFactory

The escher record factory interface allows for the creation of escher records from a pointer into a data array.

Author:
Glen Stampoultzis (glens at apache.org)

Method Summary
 EscherRecord createRecord(byte[] data, int offset)
Create a new escher record from the data provided.

Method Detail

createRecord

EscherRecord createRecord(byte[] data,
                          int offset)
Create a new escher record from the data provided. Does not attempt to fill the contents of the record however.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherRGBProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherRGBProperty

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperty
        extended by  org.apache.poi.ddf.EscherSimpleProperty
            extended by  org.apache.poi.ddf.EscherRGBProperty

public class EscherRGBProperty
extends EscherSimpleProperty

A color property.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
Fields inherited from class org.apache.poi.ddf.EscherSimpleProperty
propertyValue
Constructor Summary
EscherRGBProperty(short propertyNumber, int rgbColor)
Method Summary
byte | getBlue()
byte | getGreen()
byte | getRed()
int | getRgbColor()
Methods inherited from class org.apache.poi.ddf.EscherSimpleProperty
equals, getPropertyValue, hashCode, serializeComplexPart, serializeSimplePart, toString
Methods inherited from class org.apache.poi.ddf.EscherProperty
getId, getName, getPropertyNumber, getPropertySize, isBlipId, isComplex
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EscherRGBProperty

public EscherRGBProperty(short propertyNumber,
                         int rgbColor)
Method Detail

getRgbColor

public int getRgbColor()

getRed

public byte getRed()

getGreen

public byte getGreen()

getBlue

public byte getBlue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherSerializationListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Interface EscherSerializationListener

All Known Implementing Classes:
NullEscherSerializationListener
public interface EscherSerializationListener

Interface for listening to escher serialization events.

Author:
Glen Stampoultzis (glens at apache.org)

Method Summary
void | afterRecordSerialize(int offset, short recordId, int size, EscherRecord record) Fired after a record has been serialized.
void | beforeRecordSerialize(int offset, short recordId, EscherRecord record) Fired before a given escher record is serialized.

Method Detail

beforeRecordSerialize

void beforeRecordSerialize(int offset,
                           short recordId,
                           EscherRecord record)
Fired before a given escher record is serialized.

Parameters:
offset - The position in the data array at which the record will be serialized.
recordId - The id of the record about to be serialized.

afterRecordSerialize

void afterRecordSerialize(int offset,
                          short recordId,
                          int size,
                          EscherRecord record)
Fired after a record has been serialized.

Parameters:
offset - The position of the end of the serialized record + 1
recordId - The id of the record about to be serialized
size - The number of bytes written for this record. If it is a container record then this will include the size of any included records.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherShapePathProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherShapePathProperty

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperty
        extended by  org.apache.poi.ddf.EscherSimpleProperty
            extended by  org.apache.poi.ddf.EscherShapePathProperty

public class EscherShapePathProperty
extends EscherSimpleProperty

Defines the constants for the various possible shape paths.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static int | CLOSED_CURVES
static int | CLOSED_POLYGON
static int | COMPLEX
static int | CURVES
static int | LINE_OF_STRAIGHT_SEGMENTS
Fields inherited from class org.apache.poi.ddf.EscherSimpleProperty
propertyValue
Constructor Summary
EscherShapePathProperty(short propertyNumber, int shapePath)
Method Summary
Methods inherited from class org.apache.poi.ddf.EscherSimpleProperty
equals, getPropertyValue, hashCode, serializeComplexPart, serializeSimplePart, toString
Methods inherited from class org.apache.poi.ddf.EscherProperty
getId, getName, getPropertyNumber, getPropertySize, isBlipId, isComplex
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

LINE_OF_STRAIGHT_SEGMENTS

public static final int LINE_OF_STRAIGHT_SEGMENTS
See Also:
Constant Field Values

CLOSED_POLYGON

public static final int CLOSED_POLYGON
See Also:
Constant Field Values

CURVES

public static final int CURVES
See Also:
Constant Field Values

CLOSED_CURVES

public static final int CLOSED_CURVES
See Also:
Constant Field Values

COMPLEX

public static final int COMPLEX
See Also:
Constant Field Values
Constructor Detail

EscherShapePathProperty

public EscherShapePathProperty(short propertyNumber,
                               int shapePath)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherSimpleProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherSimpleProperty

java.lang.Object
    extended by  org.apache.poi.ddf.EscherProperty
        extended by  org.apache.poi.ddf.EscherSimpleProperty
Direct Known Subclasses:
EscherBoolProperty, EscherRGBProperty, EscherShapePathProperty
public class EscherSimpleProperty
extends EscherProperty

A simple property is of fixed length and as a property number in addition to a 32-bit value. Properties that can't be stored in only 32-bits are stored as EscherComplexProperty objects.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
protected  int propertyValue
Constructor Summary
EscherSimpleProperty(short propertyNumber, boolean isComplex, boolean isBlipId, int propertyValue)
Constructs a new escher property.
EscherSimpleProperty(short id, int propertyValue)
The id is distinct from the actual property number.
Method Summary
boolean | equals(java.lang.Object o) Returns true if one escher property is equal to another.
int | getPropertyValue()
int | hashCode() Returns a hashcode so that this object can be stored in collections that require the use of such things.
int | serializeComplexPart(byte[] data, int pos) Escher properties consist of a simple fixed length part and a complex variable length part.
int | serializeSimplePart(byte[] data, int offset) Serialize the simple part of the escher record.
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherProperty
getId, getName, getPropertyNumber, getPropertySize, isBlipId, isComplex
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

propertyValue

protected int propertyValue
Constructor Detail

EscherSimpleProperty

public EscherSimpleProperty(short id,
                            int propertyValue)
The id is distinct from the actual property number. The id includes the property number the blip id flag and an indicator whether the property is complex or not.

EscherSimpleProperty

public EscherSimpleProperty(short propertyNumber,
                            boolean isComplex,
                            boolean isBlipId,
                            int propertyValue)
Constructs a new escher property. The three parameters are combined to form a property id.

Method Detail

serializeSimplePart

public int serializeSimplePart(byte[] data,
                               int offset)
Serialize the simple part of the escher record.

Specified by:
serializeSimplePart in class EscherProperty
Returns:
the number of bytes serialized.

serializeComplexPart

public int serializeComplexPart(byte[] data,
                                int pos)
Escher properties consist of a simple fixed length part and a complex variable length part. The fixed length part is serialized first.

Specified by:
serializeComplexPart in class EscherProperty

getPropertyValue

public int getPropertyValue()
Returns:
Return the 32 bit value of this property.

equals

public boolean equals(java.lang.Object o)
Returns true if one escher property is equal to another.

Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Returns a hashcode so that this object can be stored in collections that require the use of such things.

Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Returns:
the string representation of this property.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherSpgrRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherSpgrRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherSpgrRecord

public class EscherSpgrRecord
extends EscherRecord

The spgr record defines information about a shape group. Groups in escher are simply another form of shape that you can't physically see.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherSpgrRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | getRectX1() The starting top-left coordinate of child records.
int | getRectX2() The starting bottom-right coordinate of child records.
int | getRectY1() The starting top-left coordinate of child records.
int | getRectY2() The starting bottom-right coordinate of child records.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setRectX1(int x1) The starting top-left coordinate of child records.
void | setRectX2(int x2) The starting bottom-right coordinate of child records.
void | setRectY1(int y1) The starting top-left coordinate of child records.
void | setRectY2(int rectY2) The starting bottom-right coordinate of child records.
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherSpgrRecord

public EscherSpgrRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Returns:
the string representation of this record.

getRectX1

public int getRectX1()
The starting top-left coordinate of child records.

setRectX1

public void setRectX1(int x1)
The starting top-left coordinate of child records.

getRectY1

public int getRectY1()
The starting top-left coordinate of child records.

setRectY1

public void setRectY1(int y1)
The starting top-left coordinate of child records.

getRectX2

public int getRectX2()
The starting bottom-right coordinate of child records.

setRectX2

public void setRectX2(int x2)
The starting bottom-right coordinate of child records.

getRectY2

public int getRectY2()
The starting bottom-right coordinate of child records.

setRectY2

public void setRectY2(int rectY2)
The starting bottom-right coordinate of child records.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherSplitMenuColorsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherSplitMenuColorsRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherSplitMenuColorsRecord

public class EscherSplitMenuColorsRecord
extends EscherRecord

A list of the most recently used colours for the drawings contained in this document.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherSplitMenuColorsRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
int | getColor1()
int | getColor2()
int | getColor3()
int | getColor4()
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setColor1(int field_1_color1)
void | setColor2(int field_2_color2)
void | setColor3(int field_3_color3)
void | setColor4(int field_4_color4)
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherSplitMenuColorsRecord

public EscherSplitMenuColorsRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Returns:
a string representation of this record.

getColor1

public int getColor1()

setColor1

public void setColor1(int field_1_color1)

getColor2

public int getColor2()

setColor2

public void setColor2(int field_2_color2)

getColor3

public int getColor3()

setColor3

public void setColor3(int field_3_color3)

getColor4

public int getColor4()

setColor4

public void setColor4(int field_4_color4)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherSpRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherSpRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherSpRecord

public class EscherSpRecord
extends EscherRecord

Together the the EscherOptRecord this record defines some of the basic properties of a shape.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static int | FLAG_BACKGROUND
static int | FLAG_CHILD
static int | FLAG_CONNECTOR
static int | FLAG_DELETED
static int | FLAG_FLIPHORIZ
static int | FLAG_FLIPVERT
static int | FLAG_GROUP
static int | FLAG_HASSHAPETYPE
static int | FLAG_HAVEANCHOR
static int | FLAG_HAVEMASTER
static int | FLAG_OLESHAPE
static int | FLAG_PATRIARCH
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherSpRecord()
Method Summary
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
int | getFlags() The flags that apply to this shape.
short | getRecordId() Return the current record id.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | getShapeId()
short | getShapeType() Returns shape type.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) This method serializes this escher record into a byte array.
void | setFlags(int field_2_flags) The flags that apply to this shape.
void | setShapeId(int field_1_shapeId) Sets a number that identifies this shape.
void | setShapeType(short value) Sets shape type.
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values

FLAG_GROUP

public static final int FLAG_GROUP
See Also:
Constant Field Values

FLAG_CHILD

public static final int FLAG_CHILD
See Also:
Constant Field Values

FLAG_PATRIARCH

public static final int FLAG_PATRIARCH
See Also:
Constant Field Values

FLAG_DELETED

public static final int FLAG_DELETED
See Also:
Constant Field Values

FLAG_OLESHAPE

public static final int FLAG_OLESHAPE
See Also:
Constant Field Values

FLAG_HAVEMASTER

public static final int FLAG_HAVEMASTER
See Also:
Constant Field Values

FLAG_FLIPHORIZ

public static final int FLAG_FLIPHORIZ
See Also:
Constant Field Values

FLAG_FLIPVERT

public static final int FLAG_FLIPVERT
See Also:
Constant Field Values

FLAG_CONNECTOR

public static final int FLAG_CONNECTOR
See Also:
Constant Field Values

FLAG_HAVEANCHOR

public static final int FLAG_HAVEANCHOR
See Also:
Constant Field Values

FLAG_BACKGROUND

public static final int FLAG_BACKGROUND
See Also:
Constant Field Values

FLAG_HASSHAPETYPE

public static final int FLAG_HASSHAPETYPE
See Also:
Constant Field Values
Constructor Detail

EscherSpRecord

public EscherSpRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
This method serializes this escher record into a byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - The offset into data to start writing the record data to.
data - The byte array to serialize to.
listener - A listener to retrieve start and end callbacks. Use a NullEscherSerailizationListener to ignore these events.
Returns:
The number of bytes written.
See Also:
NullEscherSerializationListener

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getRecordId

public short getRecordId()
Description copied from class: EscherRecord
Return the current record id.

Overrides:
getRecordId in class EscherRecord
Returns:
The 16 bit record id.

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Returns:
the string representing this shape.

getShapeId

public int getShapeId()
Returns:
A number that identifies this shape

setShapeId

public void setShapeId(int field_1_shapeId)
Sets a number that identifies this shape.

getFlags

public int getFlags()
The flags that apply to this shape.

See Also:
FLAG_GROUP, FLAG_CHILD, FLAG_PATRIARCH, FLAG_DELETED, FLAG_OLESHAPE, FLAG_HAVEMASTER, FLAG_FLIPHORIZ, FLAG_FLIPVERT, FLAG_CONNECTOR, FLAG_HAVEANCHOR, FLAG_BACKGROUND, FLAG_HASSHAPETYPE

setFlags

public void setFlags(int field_2_flags)
The flags that apply to this shape.

See Also:
FLAG_GROUP, FLAG_CHILD, FLAG_PATRIARCH, FLAG_DELETED, FLAG_OLESHAPE, FLAG_HAVEMASTER, FLAG_FLIPHORIZ, FLAG_FLIPVERT, FLAG_CONNECTOR, FLAG_HAVEANCHOR, FLAG_BACKGROUND, FLAG_HASSHAPETYPE

getShapeType

public short getShapeType()
Returns shape type. Must be one of MSOSPT values (see [MS-ODRAW] for details).

Returns:
shape type

setShapeType

public void setShapeType(short value)
Sets shape type. Must be one of MSOSPT values (see [MS-ODRAW] for details).

Parameters:
value - new shape type
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherTertiaryOptRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherTertiaryOptRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.AbstractEscherOptRecord
            extended by  org.apache.poi.ddf.EscherTertiaryOptRecord

public class EscherTertiaryOptRecord
extends AbstractEscherOptRecord

"The OfficeArtTertiaryFOPT record specifies a table of OfficeArtRGFOPTE properties, as defined in section 2.3.1." -- [MS-ODRAW] -- v20110608; Office Drawing Binary File Format

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Field Summary
static short RECORD_ID
Fields inherited from class org.apache.poi.ddf.AbstractEscherOptRecord
properties
Constructor Summary
EscherTertiaryOptRecord()
Method Summary
 java.lang.String getRecordName()
Subclasses should return the short name for this escher record.
Methods inherited from class org.apache.poi.ddf.AbstractEscherOptRecord
addEscherProperty, fillFields, getEscherProperties, getEscherProperty, getRecordSize, lookup, serialize, sortProperties, toString
Methods inherited from class org.apache.poi.ddf.EscherRecord
clone, display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values
Constructor Detail

EscherTertiaryOptRecord

public EscherTertiaryOptRecord()
Method Detail

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherTextboxRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class EscherTextboxRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.EscherTextboxRecord

public class EscherTextboxRecord
extends EscherRecord

Holds data from the parent application. Most commonly used to store text in the format of the parent application, rather than in Escher format. We don't attempt to understand the contents, since they will be in the parent's format, not Escher format.

Author:
Glen Stampoultzis (glens at apache.org), Nick Burch (nick at torchbox dot com)

Field Summary
static java.lang.String | RECORD_DESCRIPTION
static short | RECORD_ID
Constructor Summary
EscherTextboxRecord()
Method Summary
java.lang.Object | clone() Escher records may need to be clonable in the future.
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
byte[] | getData() Returns any extra data associated with this record.
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setData(byte[] b)
void | setData(byte[] b, int start, int length) Sets the extra data (in the parent application's format) to be contained by the record.
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
display, fillFields, getChild, getChildRecords, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setChildRecords, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RECORD_ID

public static final short RECORD_ID
See Also:
Constant Field Values

RECORD_DESCRIPTION

public static final java.lang.String RECORD_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EscherTextboxRecord

public EscherTextboxRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getData

public byte[] getData()
Returns any extra data associated with this record. In practice excel does not seem to put anything here, but with PowerPoint this will contain the bytes that make up a TextHeaderAtom followed by a TextBytesAtom/TextCharsAtom

setData

public void setData(byte[] b,
                    int start,
                    int length)
Sets the extra data (in the parent application's format) to be contained by the record. Used when the parent application changes the contents.

setData

public void setData(byte[] b)

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

clone

public java.lang.Object clone()
Description copied from class: EscherRecord
Escher records may need to be clonable in the future.

Overrides:
clone in class EscherRecord

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NullEscherSerializationListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class NullEscherSerializationListener

java.lang.Object
    extended by  org.apache.poi.ddf.NullEscherSerializationListener
All Implemented Interfaces:
EscherSerializationListener
public class NullEscherSerializationListener
extends java.lang.Object
implements EscherSerializationListener

Ignores all serialization events.

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
NullEscherSerializationListener()
Method Summary
void | afterRecordSerialize(int offset, short recordId, int size, EscherRecord record) Fired after a record has been serialized.
void | beforeRecordSerialize(int offset, short recordId, EscherRecord record) Fired before a given escher record is serialized.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NullEscherSerializationListener

public NullEscherSerializationListener()
Method Detail

beforeRecordSerialize

public void beforeRecordSerialize(int offset,
                                  short recordId,
                                  EscherRecord record)
Description copied from interface: EscherSerializationListener
Fired before a given escher record is serialized.

Specified by:
beforeRecordSerialize in interface EscherSerializationListener
Parameters:
offset - The position in the data array at which the record will be serialized.
recordId - The id of the record about to be serialized.

afterRecordSerialize

public void afterRecordSerialize(int offset,
                                 short recordId,
                                 int size,
                                 EscherRecord record)
Description copied from interface: EscherSerializationListener
Fired after a record has been serialized.

Specified by:
afterRecordSerialize in interface EscherSerializationListener
Parameters:
offset - The position of the end of the serialized record + 1
recordId - The id of the record about to be serialized
size - The number of bytes written for this record. If it is a container record then this will include the size of any included records.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ddf
Interfaces
EscherRecordFactory
EscherSerializationListener
Classes
AbstractEscherOptRecord
DefaultEscherRecordFactory
EscherArrayProperty
EscherBitmapBlip
EscherBlipRecord
EscherBlipWMFRecord
EscherBoolProperty
EscherBSERecord
EscherChildAnchorRecord
EscherClientAnchorRecord
EscherClientDataRecord
EscherComplexProperty
EscherContainerRecord
EscherDggRecord
EscherDggRecord.FileIdCluster
EscherDgRecord
EscherDump
EscherMetafileBlip
EscherOptRecord
EscherPictBlip
EscherProperties
EscherProperty
EscherPropertyFactory
EscherPropertyMetaData
EscherRecord
EscherRGBProperty
EscherShapePathProperty
EscherSimpleProperty
EscherSpgrRecord
EscherSplitMenuColorsRecord
EscherSpRecord
EscherTertiaryOptRecord
EscherTextboxRecord
NullEscherSerializationListener
UnknownEscherRecord


org.apache.poi.ddf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ddf

This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

See:
Description

Interface Summary
EscherRecordFactory | The escher record factory interface allows for the creation of escher records from a pointer into a data array.
EscherSerializationListener | Interface for listening to escher serialization events.

Class Summary
AbstractEscherOptRecord | Common abstract class for EscherOptRecord and EscherTertiaryOptRecord
DefaultEscherRecordFactory | Generates escher records when provided the byte array containing those records.
EscherArrayProperty | Escher array properties are the most wierd construction ever invented with all sorts of special cases.
EscherBitmapBlip |
EscherBlipRecord |
EscherBlipWMFRecord | The blip record is used to hold details about large binary objects that occur in escher such as JPEG, GIF, PICT and WMF files.
EscherBoolProperty | Represents a boolean property.
EscherBSERecord | The BSE record is related closely to the EscherBlipRecord and stores extra information about the blip.
EscherChildAnchorRecord | The escher child achor record is used to specify the position of a shape under an existing group.
EscherClientAnchorRecord | The escher client anchor specifies which rows and cells the shape is bound to as well as the offsets within those cells.
EscherClientDataRecord | The EscherClientDataRecord is used to store client specific data about the position of a shape within a container.
EscherComplexProperty | A complex property differs from a simple property in that the data can not fit inside a 32 bit integer.
EscherContainerRecord | Escher container records store other escher records as children.
EscherDggRecord | This record defines the drawing groups used for a particular sheet.
EscherDggRecord.FileIdCluster |
EscherDgRecord | This record simply holds the number of shapes in the drawing group and the last shape id used for this drawing group.
EscherDump | Used to dump the contents of escher records to a PrintStream.
EscherMetafileBlip |
EscherOptRecord | The opt record is used to store property values for a shape.
EscherPictBlip |
EscherProperties | Provides a list of all known escher properties including the description and type.
EscherProperty | This is the abstract base class for all escher properties.
EscherPropertyFactory | Generates a property given a reference into the byte array storing that property.
EscherPropertyMetaData | This class stores the type and description of an escher property.
EscherRecord | The base abstract record from which all escher records are defined.
EscherRGBProperty | A color property.
EscherShapePathProperty | Defines the constants for the various possible shape paths.
EscherSimpleProperty | A simple property is of fixed length and as a property number in addition to a 32-bit value.
EscherSpgrRecord | The spgr record defines information about a shape group.
EscherSplitMenuColorsRecord | A list of the most recently used colours for the drawings contained in this document.
EscherSpRecord | Together the the EscherOptRecord this record defines some of the basic properties of a shape.
EscherTertiaryOptRecord | "The OfficeArtTertiaryFOPT record specifies a table of OfficeArtRGFOPTE properties, as defined in section 2.3.1." -- [MS-ODRAW] -- v20110608; Office Drawing Binary File Format
EscherTextboxRecord | Holds data from the parent application.
NullEscherSerializationListener | Ignores all serialization events.
UnknownEscherRecord | This record is used whenever a escher record is encountered that we do not explicitly support.

Package org.apache.poi.ddf Description

This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.


org.apache.poi.ddf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ddf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ddf.DefaultEscherRecordFactory (implements org.apache.poi.ddf.EscherRecordFactory)
    • org.apache.poi.ddf.EscherDggRecord.FileIdCluster
    • org.apache.poi.ddf.EscherDump
    • org.apache.poi.ddf.EscherProperties
    • org.apache.poi.ddf.EscherProperty
      • org.apache.poi.ddf.EscherComplexProperty
        • org.apache.poi.ddf.EscherArrayProperty
      • org.apache.poi.ddf.EscherSimpleProperty
        • org.apache.poi.ddf.EscherBoolProperty
        • org.apache.poi.ddf.EscherRGBProperty
        • org.apache.poi.ddf.EscherShapePathProperty
    • org.apache.poi.ddf.EscherPropertyFactory
    • org.apache.poi.ddf.EscherPropertyMetaData
    • org.apache.poi.ddf.EscherRecord
      • org.apache.poi.ddf.AbstractEscherOptRecord
        • org.apache.poi.ddf.EscherOptRecord
        • org.apache.poi.ddf.EscherTertiaryOptRecord
      • org.apache.poi.ddf.EscherBlipRecord
        • org.apache.poi.ddf.EscherBitmapBlip
        • org.apache.poi.ddf.EscherBlipWMFRecord
        • org.apache.poi.ddf.EscherMetafileBlip
        • org.apache.poi.ddf.EscherPictBlip
      • org.apache.poi.ddf.EscherBSERecord
      • org.apache.poi.ddf.EscherChildAnchorRecord
      • org.apache.poi.ddf.EscherClientAnchorRecord
      • org.apache.poi.ddf.EscherClientDataRecord
      • org.apache.poi.ddf.EscherContainerRecord
      • org.apache.poi.ddf.EscherDggRecord
      • org.apache.poi.ddf.EscherDgRecord
      • org.apache.poi.ddf.EscherSpgrRecord
      • org.apache.poi.ddf.EscherSplitMenuColorsRecord
      • org.apache.poi.ddf.EscherSpRecord
      • org.apache.poi.ddf.EscherTextboxRecord
      • org.apache.poi.ddf.UnknownEscherRecord
    • org.apache.poi.ddf.NullEscherSerializationListener (implements org.apache.poi.ddf.EscherSerializationListener)

Interface Hierarchy

  • org.apache.poi.ddf.EscherRecordFactory
  • org.apache.poi.ddf.EscherSerializationListener


Uses of Package org.apache.poi.ddf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ddf

Packages that use org.apache.poi.ddf
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.hpbf.model |
org.apache.poi.hslf.dev |
org.apache.poi.hslf.model |
org.apache.poi.hslf.record |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf.model |
org.apache.poi.hwpf.usermodel |

Classes in org.apache.poi.ddf used by org.apache.poi.ddf
AbstractEscherOptRecord
Common abstract class for EscherOptRecord and EscherTertiaryOptRecord
EscherBlipRecord
EscherComplexProperty
A complex property differs from a simple property in that the data can not fit inside a 32 bit integer.
EscherContainerRecord
Escher container records store other escher records as children.
EscherDggRecord.FileIdCluster
EscherProperty
This is the abstract base class for all escher properties.
EscherRecord
The base abstract record from which all escher records are defined.
EscherRecordFactory
The escher record factory interface allows for the creation of escher records from a pointer into a data array.
EscherSerializationListener
Interface for listening to escher serialization events.
EscherSimpleProperty
A simple property is of fixed length and as a property number in addition to a 32-bit value.

Classes in org.apache.poi.ddf used by org.apache.poi.hpbf.model
EscherRecord
The base abstract record from which all escher records are defined.

Classes in org.apache.poi.ddf used by org.apache.poi.hslf.dev
EscherContainerRecord
Escher container records store other escher records as children.
EscherRecord
The base abstract record from which all escher records are defined.

Classes in org.apache.poi.ddf used by org.apache.poi.hslf.model
EscherBSERecord
The BSE record is related closely to the EscherBlipRecord and stores extra information about the blip.
EscherClientDataRecord
The EscherClientDataRecord is used to store client specific data about the position of a shape within a container.
EscherContainerRecord
Escher container records store other escher records as children.
EscherOptRecord
The opt record is used to store property values for a shape.
EscherProperty
This is the abstract base class for all escher properties.
EscherRecord
The base abstract record from which all escher records are defined.

Classes in org.apache.poi.ddf used by org.apache.poi.hslf.record
EscherContainerRecord
Escher container records store other escher records as children.
EscherDggRecord
This record defines the drawing groups used for a particular sheet.
EscherDgRecord
This record simply holds the number of shapes in the drawing group and the last shape id used for this drawing group.
EscherRecord
The base abstract record from which all escher records are defined.
EscherTextboxRecord
Holds data from the parent application.

Classes in org.apache.poi.ddf used by org.apache.poi.hssf.model
EscherBSERecord
The BSE record is related closely to the EscherBlipRecord and stores extra information about the blip.
EscherContainerRecord
Escher container records store other escher records as children.
EscherDggRecord
This record defines the drawing groups used for a particular sheet.
EscherDgRecord
This record simply holds the number of shapes in the drawing group and the last shape id used for this drawing group.
EscherOptRecord
The opt record is used to store property values for a shape.
EscherRecord
The base abstract record from which all escher records are defined.

Classes in org.apache.poi.ddf used by org.apache.poi.hssf.record
EscherContainerRecord
Escher container records store other escher records as children.
EscherRecord
The base abstract record from which all escher records are defined.

Classes in org.apache.poi.ddf used by org.apache.poi.hssf.usermodel
EscherBlipRecord

Classes in org.apache.poi.ddf used by org.apache.poi.hwpf.model
EscherContainerRecord
Escher container records store other escher records as children.
EscherRecord
The base abstract record from which all escher records are defined.

Classes in org.apache.poi.ddf used by org.apache.poi.hwpf.usermodel
EscherBlipRecord
EscherContainerRecord
Escher container records store other escher records as children.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


UnknownEscherRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ddf
Class UnknownEscherRecord

java.lang.Object
    extended by  org.apache.poi.ddf.EscherRecord
        extended by  org.apache.poi.ddf.UnknownEscherRecord

public final class UnknownEscherRecord
extends EscherRecord

This record is used whenever a escher record is encountered that we do not explicitly support.

Author:
Glen Stampoultzis (glens at apache.org), Zhang Zhang (zhangzzh at gmail.com)

Constructor Summary
UnknownEscherRecord()
Method Summary
void | addChildRecord(EscherRecord childRecord)
java.lang.Object | clone() Escher records may need to be clonable in the future.
int | fillFields(byte[] data, int offset, EscherRecordFactory recordFactory) The contract of this method is to deserialize an escher record including it's children.
java.util.List<EscherRecord> | getChildRecords()
byte[] | getData()
java.lang.String | getRecordName() Subclasses should return the short name for this escher record.
int | getRecordSize() Subclasses should effeciently return the number of bytes required to serialize the record.
int | serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
void | setChildRecords(java.util.List<EscherRecord> childRecords) Sets the child records for this record.
java.lang.String | toString()
Methods inherited from class org.apache.poi.ddf.EscherRecord
display, fillFields, getChild, getInstance, getOptions, getRecordId, getVersion, isContainerRecord, readHeader, readInstance, serialize, serialize, setInstance, setOptions, setRecordId, setVersion
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnknownEscherRecord

public UnknownEscherRecord()
Method Detail

fillFields

public int fillFields(byte[] data,
                      int offset,
                      EscherRecordFactory recordFactory)
Description copied from class: EscherRecord
The contract of this method is to deserialize an escher record including it's children.

Specified by:
fillFields in class EscherRecord
Parameters:
data - The byte array containing the serialized escher records.
offset - The offset into the byte array.
recordFactory - A factory for creating new escher records.
Returns:
The number of bytes written.

serialize

public int serialize(int offset,
                     byte[] data,
                     EscherSerializationListener listener)
Description copied from class: EscherRecord
Serializes the record to an existing byte array.

Specified by:
serialize in class EscherRecord
Parameters:
offset - the offset within the byte array
data - the data array to serialize to
listener - a listener for begin and end serialization events. This is useful because the serialization is hierarchical/recursive and sometimes you need to be able break into that.
Returns:
the number of bytes written.

getData

public byte[] getData()

getRecordSize

public int getRecordSize()
Description copied from class: EscherRecord
Subclasses should effeciently return the number of bytes required to serialize the record.

Specified by:
getRecordSize in class EscherRecord
Returns:
number of bytes

getChildRecords

public java.util.List<EscherRecord> getChildRecords()
Overrides:
getChildRecords in class EscherRecord
Returns:
Returns the children of this record. By default this will be an empty list. EscherCotainerRecord is the only record that may contain children.
See Also:
EscherContainerRecord

setChildRecords

public void setChildRecords(java.util.List<EscherRecord> childRecords)
Description copied from class: EscherRecord
Sets the child records for this record. By default this will throw an exception as only EscherContainerRecords may have children.

Overrides:
setChildRecords in class EscherRecord
Parameters:
childRecords - Not used in base implementation.

clone

public java.lang.Object clone()
Description copied from class: EscherRecord
Escher records may need to be clonable in the future.

Overrides:
clone in class EscherRecord

getRecordName

public java.lang.String getRecordName()
Description copied from class: EscherRecord
Subclasses should return the short name for this escher record.

Specified by:
getRecordName in class EscherRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

addChildRecord

public void addChildRecord(EscherRecord childRecord)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.ddf.AbstractEscherOptRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.AbstractEscherOptRecord

Packages that use AbstractEscherOptRecord
org.apache.poi.ddf This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

Uses of AbstractEscherOptRecord in org.apache.poi.ddf

Subclasses of AbstractEscherOptRecord in org.apache.poi.ddf
class | EscherOptRecord The opt record is used to store property values for a shape.
class | EscherTertiaryOptRecord "The OfficeArtTertiaryFOPT record specifies a table of OfficeArtRGFOPTE properties, as defined in section 2.3.1." -- [MS-ODRAW] -- v20110608; Office Drawing Binary File Format

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.DefaultEscherRecordFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.DefaultEscherRecordFactory

No usage of org.apache.poi.ddf.DefaultEscherRecordFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherArrayProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherArrayProperty

No usage of org.apache.poi.ddf.EscherArrayProperty

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherBitmapBlip

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherBitmapBlip

No usage of org.apache.poi.ddf.EscherBitmapBlip

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherBlipRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherBlipRecord

Packages that use EscherBlipRecord
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf.usermodel |

Uses of EscherBlipRecord in org.apache.poi.ddf

Subclasses of EscherBlipRecord in org.apache.poi.ddf
class | EscherBitmapBlip
class | EscherBlipWMFRecord The blip record is used to hold details about large binary objects that occur in escher such as JPEG, GIF, PICT and WMF files.
class | EscherMetafileBlip
class | EscherPictBlip

Methods in org.apache.poi.ddf that return EscherBlipRecord
 EscherBlipRecord EscherBSERecord.getBlipRecord()

Methods in org.apache.poi.ddf with parameters of type EscherBlipRecord
 void EscherBSERecord.setBlipRecord(EscherBlipRecord blipRecord)

Uses of EscherBlipRecord in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type EscherBlipRecord
HSSFPictureData(EscherBlipRecord blip)
Constructs a picture object.

Uses of EscherBlipRecord in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type EscherBlipRecord
Picture(EscherBlipRecord blipRecord)
Builds a Picture object for a Picture stored as Escher.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherBlipWMFRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherBlipWMFRecord

No usage of org.apache.poi.ddf.EscherBlipWMFRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherBoolProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherBoolProperty

No usage of org.apache.poi.ddf.EscherBoolProperty

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherBSERecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherBSERecord

Packages that use EscherBSERecord
org.apache.poi.hslf.model |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.

Uses of EscherBSERecord in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return EscherBSERecord
protected EscherBSERecord | Picture.getEscherBSERecord()
protected EscherBSERecord | Fill.getEscherBSERecord(int idx)

Uses of EscherBSERecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return EscherBSERecord
 EscherBSERecord InternalWorkbook.getBSERecord(int pictureIndex)

Methods in org.apache.poi.hssf.model with parameters of type EscherBSERecord
 int InternalWorkbook.addBSERecord(EscherBSERecord e)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherChildAnchorRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherChildAnchorRecord

No usage of org.apache.poi.ddf.EscherChildAnchorRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherClientAnchorRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherClientAnchorRecord

No usage of org.apache.poi.ddf.EscherClientAnchorRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherClientDataRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherClientDataRecord

Packages that use EscherClientDataRecord
org.apache.poi.hslf.model

Uses of EscherClientDataRecord in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as EscherClientDataRecord
protected  EscherClientDataRecord SimpleShape._clientData

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherComplexProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherComplexProperty

Packages that use EscherComplexProperty
org.apache.poi.ddf This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

Uses of EscherComplexProperty in org.apache.poi.ddf

Subclasses of EscherComplexProperty in org.apache.poi.ddf
 class EscherArrayProperty
Escher array properties are the most wierd construction ever invented with all sorts of special cases.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherContainerRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherContainerRecord

Packages that use EscherContainerRecord
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.hslf.dev |
org.apache.poi.hslf.model |
org.apache.poi.hslf.record |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hwpf.model |
org.apache.poi.hwpf.usermodel |

Uses of EscherContainerRecord in org.apache.poi.ddf

Methods in org.apache.poi.ddf that return types with arguments of type EscherContainerRecord
 java.util.List<EscherContainerRecord> EscherContainerRecord.getChildContainers()
Returns all of our children which are also EscherContainers (may be 0, 1, or vary rarely 2 or 3)

Uses of EscherContainerRecord in org.apache.poi.hslf.dev

Methods in org.apache.poi.hslf.dev with parameters of type EscherContainerRecord
 java.lang.String SlideShowRecordDumper.printEscherContainerRecord(EscherContainerRecord ecr)

Uses of EscherContainerRecord in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as EscherContainerRecord
protected  EscherContainerRecord Shape._escherContainer
Either EscherSpContainer or EscheSpgrContainer record which holds information about this shape.

Methods in org.apache.poi.hslf.model that return EscherContainerRecord
protected EscherContainerRecord | TextBox.createSpContainer(boolean isChild) Create a new TextBox and initialize its internal structures
protected EscherContainerRecord | TableCell.createSpContainer(boolean isChild)
protected EscherContainerRecord | SimpleShape.createSpContainer(boolean isChild) Create a new Shape
protected EscherContainerRecord | ShapeGroup.createSpContainer(boolean isChild) Create a new ShapeGroup and create an instance of EscherSpgrContainer which represents a group of shapes
protected abstract EscherContainerRecord | Shape.createSpContainer(boolean isChild) Creates the lowerlevel escher records for this shape.
protected EscherContainerRecord | Placeholder.createSpContainer(boolean isChild) Create a new Placeholder and initialize internal structures
protected EscherContainerRecord | Line.createSpContainer(boolean isChild)
protected EscherContainerRecord | Background.createSpContainer(boolean isChild)
protected EscherContainerRecord | Picture.createSpContainer(int idx, boolean isChild) Create a new Picture and populate the inital structure of the EscherSp record which holds information about this picture.
protected EscherContainerRecord | MovieShape.createSpContainer(int idx, boolean isChild) Create a new Placeholder and initialize internal structures
protected EscherContainerRecord | AutoShape.createSpContainer(int shapeType, boolean isChild)
protected EscherContainerRecord | ActiveXShape.createSpContainer(int idx, boolean isChild) Create a new Placeholder and initialize internal structures
EscherContainerRecord | Shape.getSpContainer()

Methods in org.apache.poi.hslf.model with parameters of type EscherContainerRecord
static Shape | ShapeFactory.createShape(EscherContainerRecord spContainer, Shape parent) Create a new shape from the data provided.
static ShapeGroup | ShapeFactory.createShapeGroup(EscherContainerRecord spContainer, Shape parent)
static Shape | ShapeFactory.createSimpeShape(EscherContainerRecord spContainer, Shape parent)
protected static Record | ShapeFactory.getClientDataRecord(EscherContainerRecord spContainer, int recordType)
static EscherRecord | Shape.getEscherChild(EscherContainerRecord owner, int recordId) Helper method to return escher child by record ID

Constructors in org.apache.poi.hslf.model with parameters of type EscherContainerRecord
ActiveXShape(EscherContainerRecord escherRecord, Shape parent)
Create a Picture object
AutoShape(EscherContainerRecord escherRecord, Shape parent)
Background(EscherContainerRecord escherRecord, Shape parent)
Freeform(EscherContainerRecord escherRecord, Shape parent)
Create a Freeform object and initialize it from the supplied Record container.
Line(EscherContainerRecord escherRecord, Shape parent)
MovieShape(EscherContainerRecord escherRecord, Shape parent)
Create a Picture object
OLEShape(EscherContainerRecord escherRecord, Shape parent)
Create a OLEShape object
Picture(EscherContainerRecord escherRecord, Shape parent)
Create a Picture object
Placeholder(EscherContainerRecord escherRecord, Shape parent)
Polygon(EscherContainerRecord escherRecord, Shape parent)
Create a Polygon object and initialize it from the supplied Record container.
Shape(EscherContainerRecord escherRecord, Shape parent)
Create a Shape object.
ShapeGroup(EscherContainerRecord escherRecord, Shape parent)
Create a ShapeGroup object and initilize it from the supplied Record container.
SimpleShape(EscherContainerRecord escherRecord, Shape parent)
Create a SimpleShape object and initialize it from the supplied Record container.
Table(EscherContainerRecord escherRecord, Shape parent)
Create a Table object and initilize it from the supplied Record container.
TableCell(EscherContainerRecord escherRecord, Shape parent)
Create a TableCell object and initialize it from the supplied Record container.
TextBox(EscherContainerRecord escherRecord, Shape parent)
Create a TextBox object and initialize it from the supplied Record container.
TextShape(EscherContainerRecord escherRecord, Shape parent)
Create a TextBox object and initialize it from the supplied Record container.

Uses of EscherContainerRecord in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return EscherContainerRecord
 EscherContainerRecord PPDrawingGroup.getDggContainer()

Uses of EscherContainerRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return EscherContainerRecord
EscherContainerRecord | TextboxShape.getSpContainer()
EscherContainerRecord | SimpleFilledShape.getSpContainer()
EscherContainerRecord | PolygonShape.getSpContainer()
EscherContainerRecord | PictureShape.getSpContainer()
EscherContainerRecord | LineShape.getSpContainer()
EscherContainerRecord | ComboboxShape.getSpContainer()
abstract EscherContainerRecord | AbstractShape.getSpContainer()

Uses of EscherContainerRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return EscherContainerRecord
 EscherContainerRecord AbstractEscherHolderRecord.getEscherContainer()
If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.

Uses of EscherContainerRecord in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return EscherContainerRecord
EscherContainerRecord | EscherRecordHolder.getEscherContainer() If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.
EscherContainerRecord | PICFAndOfficeArtData.getShape()

Methods in org.apache.poi.hwpf.model that return types with arguments of type EscherContainerRecord
java.util.List<? extends EscherContainerRecord> | EscherRecordHolder.getBStoreContainers()
java.util.List<? extends EscherContainerRecord> | EscherRecordHolder.getDgContainers()
java.util.List<? extends EscherContainerRecord> | EscherRecordHolder.getDggContainers()
java.util.List<? extends EscherContainerRecord> | EscherRecordHolder.getSpContainers()
java.util.List<? extends EscherContainerRecord> | EscherRecordHolder.getSpgrContainers()

Uses of EscherContainerRecord in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return EscherContainerRecord
 EscherContainerRecord OfficeDrawing.getOfficeArtSpContainer()
Returns escher record that represent shape container (record type is 0xF004).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherDggRecord.FileIdCluster

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherDggRecord.FileIdCluster

Packages that use EscherDggRecord.FileIdCluster
org.apache.poi.ddf This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

Uses of EscherDggRecord.FileIdCluster in org.apache.poi.ddf

Methods in org.apache.poi.ddf that return EscherDggRecord.FileIdCluster
 EscherDggRecord.FileIdCluster[] EscherDggRecord.getFileIdClusters()

Methods in org.apache.poi.ddf with parameters of type EscherDggRecord.FileIdCluster
 void EscherDggRecord.setFileIdClusters(EscherDggRecord.FileIdCluster[] fileIdClusters)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherDggRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherDggRecord

Packages that use EscherDggRecord
org.apache.poi.hslf.record |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.

Uses of EscherDggRecord in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return EscherDggRecord
 EscherDggRecord PPDrawingGroup.getEscherDggRecord()

Uses of EscherDggRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return EscherDggRecord
EscherDggRecord | DrawingManager2.getDgg()
EscherDggRecord | DrawingManager.getDgg()

Constructors in org.apache.poi.hssf.model with parameters of type EscherDggRecord
DrawingManager(EscherDggRecord dgg)
DrawingManager2(EscherDggRecord dgg)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherDgRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherDgRecord

Packages that use EscherDgRecord
org.apache.poi.hslf.record |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.

Uses of EscherDgRecord in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return EscherDgRecord
 EscherDgRecord PPDrawing.getEscherDgRecord()
Return EscherDgRecord which keeps track of the number of shapes and shapeId in this drawing group

Uses of EscherDgRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return EscherDgRecord
EscherDgRecord | DrawingManager2.createDgRecord()
EscherDgRecord | DrawingManager.createDgRecord()

Methods in org.apache.poi.hssf.model with parameters of type EscherDgRecord
 int DrawingManager2.allocateShapeId(short drawingGroupId, EscherDgRecord dg)
Allocates new shape id for the new drawing group id.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherDump

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherDump

No usage of org.apache.poi.ddf.EscherDump

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherMetafileBlip

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherMetafileBlip

No usage of org.apache.poi.ddf.EscherMetafileBlip

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherOptRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherOptRecord

Packages that use EscherOptRecord
org.apache.poi.hslf.model |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.

Uses of EscherOptRecord in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model with parameters of type EscherOptRecord
static EscherProperty | Shape.getEscherProperty(EscherOptRecord opt, int propId) Returns escher property by id.
static void | Shape.setEscherProperty(EscherOptRecord opt, short propId, int value) Set an escher property for this shape.

Uses of EscherOptRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type EscherOptRecord
protected int | CommentShape.addStandardOptions(HSSFShape shape, EscherOptRecord opt) Sets standard escher options for a comment.
protected int | AbstractShape.addStandardOptions(HSSFShape shape, EscherOptRecord opt) Add standard properties to the opt record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherPictBlip

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherPictBlip

No usage of org.apache.poi.ddf.EscherPictBlip

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherProperties

No usage of org.apache.poi.ddf.EscherProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherProperty

Packages that use EscherProperty
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.hslf.model |

Uses of EscherProperty in org.apache.poi.ddf

Subclasses of EscherProperty in org.apache.poi.ddf
class | EscherArrayProperty Escher array properties are the most wierd construction ever invented with all sorts of special cases.
class | EscherBoolProperty Represents a boolean property.
class | EscherComplexProperty A complex property differs from a simple property in that the data can not fit inside a 32 bit integer.
class | EscherRGBProperty A color property.
class | EscherShapePathProperty Defines the constants for the various possible shape paths.
class | EscherSimpleProperty A simple property is of fixed length and as a property number in addition to a 32-bit value.

Fields in org.apache.poi.ddf with type parameters of type EscherProperty
protected  java.util.List<EscherProperty> AbstractEscherOptRecord.properties

Methods in org.apache.poi.ddf with type parameters of type EscherProperty
<T extends EscherProperty>
T
AbstractEscherOptRecord.lookup(int propId)

Methods in org.apache.poi.ddf that return EscherProperty
 EscherProperty AbstractEscherOptRecord.getEscherProperty(int index)
The list of properties stored by this record.

Methods in org.apache.poi.ddf that return types with arguments of type EscherProperty
java.util.List<EscherProperty> | EscherPropertyFactory.createProperties(byte[] data, int offset, short numProperties) Create new properties from a byte array.
java.util.List<EscherProperty> | AbstractEscherOptRecord.getEscherProperties() The list of properties stored by this record.

Methods in org.apache.poi.ddf with parameters of type EscherProperty
 void AbstractEscherOptRecord.addEscherProperty(EscherProperty prop)
Add a property to this record.

Uses of EscherProperty in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return EscherProperty
static EscherProperty Shape.getEscherProperty(EscherOptRecord opt, int propId)
Returns escher property by id.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherPropertyFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherPropertyFactory

No usage of org.apache.poi.ddf.EscherPropertyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherPropertyMetaData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherPropertyMetaData

No usage of org.apache.poi.ddf.EscherPropertyMetaData

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherRecord

Packages that use EscherRecord
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.hpbf.model |
org.apache.poi.hslf.dev |
org.apache.poi.hslf.model |
org.apache.poi.hslf.record |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hwpf.model |

Uses of EscherRecord in org.apache.poi.ddf

Subclasses of EscherRecord in org.apache.poi.ddf
class | AbstractEscherOptRecord Common abstract class for EscherOptRecord and EscherTertiaryOptRecord
class | EscherBitmapBlip
class | EscherBlipRecord
class | EscherBlipWMFRecord The blip record is used to hold details about large binary objects that occur in escher such as JPEG, GIF, PICT and WMF files.
class | EscherBSERecord The BSE record is related closely to the EscherBlipRecord and stores extra information about the blip.
class | EscherChildAnchorRecord The escher child achor record is used to specify the position of a shape under an existing group.
class | EscherClientAnchorRecord The escher client anchor specifies which rows and cells the shape is bound to as well as the offsets within those cells.
class | EscherClientDataRecord The EscherClientDataRecord is used to store client specific data about the position of a shape within a container.
class | EscherContainerRecord Escher container records store other escher records as children.
class | EscherDggRecord This record defines the drawing groups used for a particular sheet.
class | EscherDgRecord This record simply holds the number of shapes in the drawing group and the last shape id used for this drawing group.
class | EscherMetafileBlip
class | EscherOptRecord The opt record is used to store property values for a shape.
class | EscherPictBlip
class | EscherSpgrRecord The spgr record defines information about a shape group.
class | EscherSplitMenuColorsRecord A list of the most recently used colours for the drawings contained in this document.
class | EscherSpRecord Together the the EscherOptRecord this record defines some of the basic properties of a shape.
class | EscherTertiaryOptRecord "The OfficeArtTertiaryFOPT record specifies a table of OfficeArtRGFOPTE properties, as defined in section 2.3.1." -- [MS-ODRAW] -- v20110608; Office Drawing Binary File Format
class | EscherTextboxRecord Holds data from the parent application.
class | UnknownEscherRecord This record is used whenever a escher record is encountered that we do not explicitly support.

Methods in org.apache.poi.ddf with type parameters of type EscherRecord
<T extends EscherRecord>
T
EscherContainerRecord.getChildById(short recordId)

Methods in org.apache.poi.ddf that return EscherRecord
EscherRecord | EscherRecordFactory.createRecord(byte[] data, int offset) Create a new escher record from the data provided.
EscherRecord | DefaultEscherRecordFactory.createRecord(byte[] data, int offset) Generates an escher record including the any children contained under that record.
EscherRecord | EscherRecord.getChild(int index) Returns the indexed child record.
EscherRecord | EscherContainerRecord.getChild(int index)

Methods in org.apache.poi.ddf that return types with arguments of type EscherRecord
java.util.Iterator<EscherRecord> | EscherContainerRecord.getChildIterator()
java.util.List<EscherRecord> | UnknownEscherRecord.getChildRecords()
java.util.List<EscherRecord> | EscherRecord.getChildRecords()
java.util.List<EscherRecord> | EscherContainerRecord.getChildRecords()

Methods in org.apache.poi.ddf with parameters of type EscherRecord
void | EscherContainerRecord.addChildBefore(EscherRecord record, int insertBeforeRecordId)
void | UnknownEscherRecord.addChildRecord(EscherRecord childRecord)
void | EscherContainerRecord.addChildRecord(EscherRecord record)
void | NullEscherSerializationListener.afterRecordSerialize(int offset, short recordId, int size, EscherRecord record)
void | EscherSerializationListener.afterRecordSerialize(int offset, short recordId, int size, EscherRecord record) Fired after a record has been serialized.
void | NullEscherSerializationListener.beforeRecordSerialize(int offset, short recordId, EscherRecord record)
void | EscherSerializationListener.beforeRecordSerialize(int offset, short recordId, EscherRecord record) Fired before a given escher record is serialized.
boolean | EscherContainerRecord.removeChildRecord(EscherRecord toBeRemoved)

Method parameters in org.apache.poi.ddf with type arguments of type EscherRecord
void | EscherContainerRecord.getRecordsById(short recordId, java.util.List<EscherRecord> out) Recursively find records with the specified record ID
void | UnknownEscherRecord.setChildRecords(java.util.List<EscherRecord> childRecords)
void | EscherRecord.setChildRecords(java.util.List<EscherRecord> childRecords) Sets the child records for this record.
void | EscherContainerRecord.setChildRecords(java.util.List<EscherRecord> childRecords) replaces the internal child list with the contents of the supplied childRecords

Uses of EscherRecord in org.apache.poi.hpbf.model

Methods in org.apache.poi.hpbf.model that return EscherRecord
 EscherRecord[] EscherPart.getEscherRecords()

Uses of EscherRecord in org.apache.poi.hslf.dev

Methods in org.apache.poi.hslf.dev with parameters of type EscherRecord
 java.lang.String SlideShowRecordDumper.printEscherRecord(EscherRecord er)

Uses of EscherRecord in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return EscherRecord
static EscherRecord Shape.getEscherChild(EscherContainerRecord owner, int recordId)
Helper method to return escher child by record ID

Uses of EscherRecord in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return EscherRecord
 EscherRecord[] PPDrawing.getEscherRecords()
Get access to the underlying Escher Records

Uses of EscherRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return EscherRecord
static EscherRecord | ConvertAnchor.createAnchor(HSSFAnchor userAnchor)
protected EscherRecord | AbstractShape.createAnchor(HSSFAnchor userAnchor) Creates an escher anchor record from a HSSFAnchor.
EscherRecord | TextboxShape.getEscherTextbox()

Uses of EscherRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return EscherRecord
EscherRecord | AbstractEscherHolderRecord.findFirstWithId(short id) Descends into all our children, returning the first EscherRecord with the given id, or null if none found
EscherRecord | AbstractEscherHolderRecord.getEscherRecord(int index)

Methods in org.apache.poi.hssf.record that return types with arguments of type EscherRecord
 java.util.List<EscherRecord> AbstractEscherHolderRecord.getEscherRecords()

Methods in org.apache.poi.hssf.record with parameters of type EscherRecord
boolean | AbstractEscherHolderRecord.addEscherRecord(EscherRecord element)
void | AbstractEscherHolderRecord.addEscherRecord(int index, EscherRecord element)

Uses of EscherRecord in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return EscherRecord
 EscherRecord EscherRecordHolder.findFirstWithId(short id)
Descends into all our children, returning the first EscherRecord with the given id, or null if none found

Methods in org.apache.poi.hwpf.model that return types with arguments of type EscherRecord
java.util.List<EscherRecord> | PICFAndOfficeArtData.getBlipRecords()
java.util.List<EscherRecord> | EscherRecordHolder.getEscherRecords()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ddf.EscherRecordFactory

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ddf.EscherRecordFactory

Packages that use EscherRecordFactory
org.apache.poi.ddf This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

Uses of EscherRecordFactory in org.apache.poi.ddf

Classes in org.apache.poi.ddf that implement EscherRecordFactory
 class DefaultEscherRecordFactory
Generates escher records when provided the byte array containing those records.

Methods in org.apache.poi.ddf with parameters of type EscherRecordFactory
protected  int EscherRecord.fillFields(byte[] data, EscherRecordFactory f)
Delegates to fillFields(byte[], int, EscherRecordFactory)
 int UnknownEscherRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherTextboxRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherSpRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherSplitMenuColorsRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherSpgrRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
abstract  int EscherRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
The contract of this method is to deserialize an escher record including it's children.
 int EscherPictBlip.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherMetafileBlip.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherDgRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherDggRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherContainerRecord.fillFields(byte[] data, int pOffset, EscherRecordFactory recordFactory)
 int EscherClientDataRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherClientAnchorRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherChildAnchorRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherBSERecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherBlipWMFRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherBlipRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int EscherBitmapBlip.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)
 int AbstractEscherOptRecord.fillFields(byte[] data, int offset, EscherRecordFactory recordFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherRGBProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherRGBProperty

No usage of org.apache.poi.ddf.EscherRGBProperty

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ddf.EscherSerializationListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ddf.EscherSerializationListener

Packages that use EscherSerializationListener
org.apache.poi.ddf This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

Uses of EscherSerializationListener in org.apache.poi.ddf

Classes in org.apache.poi.ddf that implement EscherSerializationListener
 class NullEscherSerializationListener
Ignores all serialization events.

Methods in org.apache.poi.ddf with parameters of type EscherSerializationListener
int | UnknownEscherRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherTextboxRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherSpRecord.serialize(int offset, byte[] data, EscherSerializationListener listener) This method serializes this escher record into a byte array.
int | EscherSplitMenuColorsRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherSpgrRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
abstract int | EscherRecord.serialize(int offset, byte[] data, EscherSerializationListener listener) Serializes the record to an existing byte array.
int | EscherPictBlip.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherMetafileBlip.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherDgRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherDggRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherContainerRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherClientDataRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherClientAnchorRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherChildAnchorRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherBSERecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherBlipWMFRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherBlipRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | EscherBitmapBlip.serialize(int offset, byte[] data, EscherSerializationListener listener)
int | AbstractEscherOptRecord.serialize(int offset, byte[] data, EscherSerializationListener listener)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherShapePathProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherShapePathProperty

No usage of org.apache.poi.ddf.EscherShapePathProperty

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherSimpleProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherSimpleProperty

Packages that use EscherSimpleProperty
org.apache.poi.ddf This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.

Uses of EscherSimpleProperty in org.apache.poi.ddf

Subclasses of EscherSimpleProperty in org.apache.poi.ddf
class | EscherBoolProperty Represents a boolean property.
class | EscherRGBProperty A color property.
class | EscherShapePathProperty Defines the constants for the various possible shape paths.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherSpgrRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherSpgrRecord

No usage of org.apache.poi.ddf.EscherSpgrRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherSplitMenuColorsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherSplitMenuColorsRecord

No usage of org.apache.poi.ddf.EscherSplitMenuColorsRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherSpRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherSpRecord

No usage of org.apache.poi.ddf.EscherSpRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherTertiaryOptRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherTertiaryOptRecord

No usage of org.apache.poi.ddf.EscherTertiaryOptRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.EscherTextboxRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.EscherTextboxRecord

Packages that use EscherTextboxRecord
org.apache.poi.hslf.record

Uses of EscherTextboxRecord in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return EscherTextboxRecord
 EscherTextboxRecord EscherTextboxWrapper.getEscherRecord()
Returns the underlying DDF Escher Record

Constructors in org.apache.poi.hslf.record with parameters of type EscherTextboxRecord
EscherTextboxWrapper(EscherTextboxRecord textbox)
Creates the wrapper for the given DDF Escher Record and children

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.NullEscherSerializationListener

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.NullEscherSerializationListener

No usage of org.apache.poi.ddf.NullEscherSerializationListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ddf.UnknownEscherRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ddf.UnknownEscherRecord

No usage of org.apache.poi.ddf.UnknownEscherRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


OOXMLLister

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.dev
Class OOXMLLister

java.lang.Object
    extended by  org.apache.poi.dev.OOXMLLister

public class OOXMLLister
extends java.lang.Object

Prints out the contents of a OOXML container. Useful for seeing what parts are defined, and how they're all related to each other.

Constructor Summary
OOXMLLister(OPCPackage container)
OOXMLLister(OPCPackage container, java.io.PrintStream disp)
Method Summary
void | displayParts() Displays information on all the different parts of the OOXML file container.
void | displayRelations() Displays information on all the different relationships between different parts of the OOXML file container.
static long | getSize(PackagePart part) Figures out how big a given PackagePart is.
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OOXMLLister

public OOXMLLister(OPCPackage container)

OOXMLLister

public OOXMLLister(OPCPackage container,
                   java.io.PrintStream disp)
Method Detail

getSize

public static long getSize(PackagePart part)
                    throws java.io.IOException
Figures out how big a given PackagePart is.

Throws:
java.io.IOException

displayParts

public void displayParts()
                  throws java.lang.Exception
Displays information on all the different parts of the OOXML file container.

Throws:
java.lang.Exception

displayRelations

public void displayRelations()
                      throws java.lang.Exception
Displays information on all the different relationships between different parts of the OOXML file container.

Throws:
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.dev
Classes
OOXMLLister
RecordGenerator


org.apache.poi.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.dev

Class Summary
OOXMLLister | Prints out the contents of a OOXML container.
RecordGenerator | Description of the Class


org.apache.poi.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.dev.OOXMLLister
    • org.apache.poi.dev.RecordGenerator


Uses of Package org.apache.poi.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.dev

No usage of org.apache.poi.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RecordGenerator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.dev
Class RecordGenerator

java.lang.Object
    extended by  org.apache.poi.dev.RecordGenerator

public class RecordGenerator
extends java.lang.Object

Description of the Class

Since:
May 10, 2002
Author:
andy

Constructor Summary
RecordGenerator()
Method Summary
static void main(java.lang.String[] args)
The main program for the RecordGenerator class
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordGenerator

public RecordGenerator()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
The main program for the RecordGenerator class

Parameters:
args - The command line arguments
Throws:
java.lang.Exception - Description of the Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.dev.OOXMLLister

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.dev.OOXMLLister

No usage of org.apache.poi.dev.OOXMLLister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.dev.RecordGenerator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.dev.RecordGenerator

No usage of org.apache.poi.dev.RecordGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CommandLineTextExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.extractor
Class CommandLineTextExtractor

java.lang.Object
    extended by  org.apache.poi.extractor.CommandLineTextExtractor

public class CommandLineTextExtractor
extends java.lang.Object

A command line wrapper around ExtractorFactory, useful for when debugging.

Field Summary
static java.lang.String DIVIDER
Constructor Summary
CommandLineTextExtractor()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DIVIDER

public static java.lang.String DIVIDER
Constructor Detail

CommandLineTextExtractor

public CommandLineTextExtractor()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ExtractorFactory

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.extractor
Class ExtractorFactory

java.lang.Object
    extended by  org.apache.poi.extractor.ExtractorFactory

public class ExtractorFactory
extends java.lang.Object

Figures out the correct POITextExtractor for your supplied document, and returns it.

Field Summary
static java.lang.String CORE_DOCUMENT_REL
Constructor Summary
ExtractorFactory()
Method Summary
static POITextExtractor | createExtractor(DirectoryNode poifsDir)
static POITextExtractor | createExtractor(DirectoryNode poifsDir, POIFSFileSystem fs) Deprecated. Use createExtractor(DirectoryNode) instead
static POITextExtractor | createExtractor(java.io.File f)
static POITextExtractor | createExtractor(java.io.InputStream inp)
static POIXMLTextExtractor | createExtractor(OPCPackage pkg)
static POIOLE2TextExtractor | createExtractor(POIFSFileSystem fs)
static java.lang.Boolean | getAllThreadsPreferEventExtractors() Should all threads prefer event based over usermodel based extractors? (usermodel extractors tend to be more accurate, but use more memory) Default is to use the thread level setting, which defaults to false.
static POITextExtractor[] | getEmbededDocsTextExtractors(POIOLE2TextExtractor ext) Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).
static POITextExtractor[] | getEmbededDocsTextExtractors(POIXMLTextExtractor ext) Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).
protected static boolean | getPreferEventExtractor() Should this thread use event based extractors is available? Checks the all-threads one first, then thread specific.
static boolean | getThreadPrefersEventExtractors() Should this thread prefer event based over usermodel based extractors? (usermodel extractors tend to be more accurate, but use more memory) Default is false.
static void | setAllThreadsPreferEventExtractors(java.lang.Boolean preferEventExtractors) Should all threads prefer event based over usermodel based extractors? If set, will take preference over the Thread level setting.
static void | setThreadPrefersEventExtractors(boolean preferEventExtractors) Should this thread prefer event based over usermodel based extractors? Will only be used if the All Threads setting is null.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CORE_DOCUMENT_REL

public static final java.lang.String CORE_DOCUMENT_REL
See Also:
Constant Field Values
Constructor Detail

ExtractorFactory

public ExtractorFactory()
Method Detail

getThreadPrefersEventExtractors

public static boolean getThreadPrefersEventExtractors()
Should this thread prefer event based over usermodel based extractors? (usermodel extractors tend to be more accurate, but use more memory) Default is false.

getAllThreadsPreferEventExtractors

public static java.lang.Boolean getAllThreadsPreferEventExtractors()
Should all threads prefer event based over usermodel based extractors? (usermodel extractors tend to be more accurate, but use more memory) Default is to use the thread level setting, which defaults to false.

setThreadPrefersEventExtractors

public static void setThreadPrefersEventExtractors(boolean preferEventExtractors)
Should this thread prefer event based over usermodel based extractors? Will only be used if the All Threads setting is null.

setAllThreadsPreferEventExtractors

public static void setAllThreadsPreferEventExtractors(java.lang.Boolean preferEventExtractors)
Should all threads prefer event based over usermodel based extractors? If set, will take preference over the Thread level setting.

getPreferEventExtractor

protected static boolean getPreferEventExtractor()
Should this thread use event based extractors is available? Checks the all-threads one first, then thread specific.

createExtractor

public static POITextExtractor createExtractor(java.io.File f)
                                        throws java.io.IOException,
                                               InvalidFormatException,
                                               OpenXML4JException,
                                               org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
InvalidFormatException
OpenXML4JException
org.apache.xmlbeans.XmlException

createExtractor

public static POITextExtractor createExtractor(java.io.InputStream inp)
                                        throws java.io.IOException,
                                               InvalidFormatException,
                                               OpenXML4JException,
                                               org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
InvalidFormatException
OpenXML4JException
org.apache.xmlbeans.XmlException

createExtractor

public static POIXMLTextExtractor createExtractor(OPCPackage pkg)
                                           throws java.io.IOException,
                                                  OpenXML4JException,
                                                  org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
OpenXML4JException
org.apache.xmlbeans.XmlException

createExtractor

public static POIOLE2TextExtractor createExtractor(POIFSFileSystem fs)
                                            throws java.io.IOException,
                                                   InvalidFormatException,
                                                   OpenXML4JException,
                                                   org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
InvalidFormatException
OpenXML4JException
org.apache.xmlbeans.XmlException

createExtractor

@Deprecated
public static POITextExtractor createExtractor(DirectoryNode poifsDir,
                                                          POIFSFileSystem fs)
                                        throws java.io.IOException,
                                               InvalidFormatException,
                                               OpenXML4JException,
                                               org.apache.xmlbeans.XmlException
Deprecated. Use createExtractor(DirectoryNode) instead

Throws:
java.io.IOException
InvalidFormatException
OpenXML4JException
org.apache.xmlbeans.XmlException

createExtractor

public static POITextExtractor createExtractor(DirectoryNode poifsDir)
                                        throws java.io.IOException,
                                               InvalidFormatException,
                                               OpenXML4JException,
                                               org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
InvalidFormatException
OpenXML4JException
org.apache.xmlbeans.XmlException

getEmbededDocsTextExtractors

public static POITextExtractor[] getEmbededDocsTextExtractors(POIOLE2TextExtractor ext)
                                                       throws java.io.IOException,
                                                              InvalidFormatException,
                                                              OpenXML4JException,
                                                              org.apache.xmlbeans.XmlException
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any). If there are no embeded documents, you'll get back an empty array. Otherwise, you'll get one open POITextExtractor for each embeded file.

Throws:
java.io.IOException
InvalidFormatException
OpenXML4JException
org.apache.xmlbeans.XmlException

getEmbededDocsTextExtractors

public static POITextExtractor[] getEmbededDocsTextExtractors(POIXMLTextExtractor ext)
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any). If there are no embeded documents, you'll get back an empty array. Otherwise, you'll get one open POITextExtractor for each embeded file.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.extractor
Classes
CommandLineTextExtractor
ExtractorFactory


org.apache.poi.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.extractor

Class Summary
CommandLineTextExtractor | A command line wrapper around ExtractorFactory, useful for when debugging.
ExtractorFactory | Figures out the correct POITextExtractor for your supplied document, and returns it.


org.apache.poi.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.extractor.CommandLineTextExtractor
    • org.apache.poi.extractor.ExtractorFactory


Uses of Package org.apache.poi.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.extractor

No usage of org.apache.poi.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.extractor.CommandLineTextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.extractor.CommandLineTextExtractor

No usage of org.apache.poi.extractor.CommandLineTextExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.extractor.ExtractorFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.extractor.ExtractorFactory

No usage of org.apache.poi.extractor.ExtractorFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HDGFDiagram

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf
Class HDGFDiagram

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hdgf.HDGFDiagram

public final class HDGFDiagram
extends POIDocument

See http://www.redferni.uklinux.net/visio/ http://www.gnome.ru/projects/docs/vsdocs.html http://www.gnome.ru/projects/docs/slide1.png http://www.gnome.ru/projects/docs/slide2.png

Field Summary
Fields inherited from class org.apache.poi.POIDocument
directory
Constructor Summary
HDGFDiagram(DirectoryNode dir)
HDGFDiagram(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use HDGFDiagram(DirectoryNode) instead
HDGFDiagram(NPOIFSFileSystem fs)
HDGFDiagram(POIFSFileSystem fs)
Method Summary
void | debug() Prints out some simple debug on the base contents of the file.
long | getDocumentSize()
Stream[] | getTopLevelStreams() Returns all the top level streams, which are the streams pointed to by the TrailerStream.
TrailerStream | getTrailerStream() Returns the TrailerStream, which is at the root of the tree of Streams.
static void | main(java.lang.String[] args) For testing only
void | write(java.io.OutputStream out) Writes the document out to the specified output stream
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HDGFDiagram

public HDGFDiagram(POIFSFileSystem fs)
            throws java.io.IOException
Throws:
java.io.IOException

HDGFDiagram

public HDGFDiagram(NPOIFSFileSystem fs)
            throws java.io.IOException
Throws:
java.io.IOException

HDGFDiagram

@Deprecated
public HDGFDiagram(DirectoryNode dir,
                              POIFSFileSystem fs)
            throws java.io.IOException
Deprecated. Use HDGFDiagram(DirectoryNode) instead

Throws:
java.io.IOException

HDGFDiagram

public HDGFDiagram(DirectoryNode dir)
            throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getTrailerStream

public TrailerStream getTrailerStream()
Returns the TrailerStream, which is at the root of the tree of Streams.

getTopLevelStreams

public Stream[] getTopLevelStreams()
Returns all the top level streams, which are the streams pointed to by the TrailerStream.

getDocumentSize

public long getDocumentSize()

debug

public void debug()
Prints out some simple debug on the base contents of the file.

See Also:
VSDDumper

write

public void write(java.io.OutputStream out)
Description copied from class: POIDocument
Writes the document out to the specified output stream

Specified by:
write in class POIDocument

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
For testing only

Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HDGFLZW

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf
Class HDGFLZW

java.lang.Object
    extended by  org.apache.poi.util.LZWDecompresser
        extended by  org.apache.poi.hdgf.HDGFLZW

public class HDGFLZW
extends LZWDecompresser

A decoder for the crazy LZW implementation used in Visio. According to VSDump, "it's a slightly perverted version of LZW compression, with inverted meaning of flag byte and 0xFEE as an 'initial shift'". It uses 12 bit codes (http://www.gnome.ru/projects/vsdump_en.html) Two good resources on LZW are: http://en.wikipedia.org/wiki/LZW http://marknelson.us/1989/10/01/lzw-data-compression/

Constructor Summary
HDGFLZW()
Method Summary
protected int | adjustDictionaryOffset(int pntr) We have a slight shift by 18 bytes
byte[] | compress(java.io.InputStream src) Compress the given input stream, returning the array of bytes of the compressed input
void | compress(java.io.InputStream src, java.io.OutputStream res) Performs the Visio compatible streaming LZW compression.
protected int | populateDictionary(byte[] dict) We want an empty dictionary, so do nothing
Methods inherited from class org.apache.poi.util.LZWDecompresser
decompress, decompress, fromByte, fromInt
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HDGFLZW

public HDGFLZW()
Method Detail

compress

public byte[] compress(java.io.InputStream src)
                throws java.io.IOException
Compress the given input stream, returning the array of bytes of the compressed input

Throws:
java.io.IOException

adjustDictionaryOffset

protected int adjustDictionaryOffset(int pntr)
We have a slight shift by 18 bytes

Specified by:
adjustDictionaryOffset in class LZWDecompresser

populateDictionary

protected int populateDictionary(byte[] dict)
We want an empty dictionary, so do nothing

Specified by:
populateDictionary in class LZWDecompresser

compress

public void compress(java.io.InputStream src,
                     java.io.OutputStream res)
              throws java.io.IOException
Performs the Visio compatible streaming LZW compression.

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hdgf
Classes
HDGFDiagram
HDGFLZW


org.apache.poi.hdgf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hdgf

Class Summary
HDGFDiagram | See http://www.redferni.uklinux.net/visio/ http://www.gnome.ru/projects/docs/vsdocs.html http://www.gnome.ru/projects/docs/slide1.png http://www.gnome.ru/projects/docs/slide2.png
HDGFLZW | A decoder for the crazy LZW implementation used in Visio.


org.apache.poi.hdgf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hdgf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.util.LZWDecompresser
      • org.apache.poi.hdgf.HDGFLZW
    • org.apache.poi.POIDocument
      • org.apache.poi.hdgf.HDGFDiagram


Uses of Package org.apache.poi.hdgf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hdgf

Packages that use org.apache.poi.hdgf
org.apache.poi.hdgf.extractor

Classes in org.apache.poi.hdgf used by org.apache.poi.hdgf.extractor
HDGFDiagram
See http://www.redferni.uklinux.net/visio/ http://www.gnome.ru/projects/docs/vsdocs.html http://www.gnome.ru/projects/docs/slide1.png http://www.gnome.ru/projects/docs/slide2.png

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Chunk.BlockOffsetCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class Chunk.BlockOffsetCommand

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.Chunk.Command
        extended by  org.apache.poi.hdgf.chunks.Chunk.BlockOffsetCommand
Enclosing class:
Chunk
public static class Chunk.BlockOffsetCommand
extends Chunk.Command

A special kind of command that holds the offset to a block

Field Summary
Fields inherited from class org.apache.poi.hdgf.chunks.Chunk.Command
value
Method Summary
Methods inherited from class org.apache.poi.hdgf.chunks.Chunk.Command
getDefinition, getValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Chunk.Command

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class Chunk.Command

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.Chunk.Command
Direct Known Subclasses:
Chunk.BlockOffsetCommand
Enclosing class:
Chunk
public static class Chunk.Command
extends java.lang.Object

A command in the visio file. In order to make things fun, all the chunk actually stores is the value of the command. You have to have your own lookup table to figure out what the commands are based on the chunk type.

Field Summary
protected  java.lang.Object value
Method Summary
ChunkFactory.CommandDefinition | getDefinition()
java.lang.Object | getValue()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

protected java.lang.Object value
Method Detail

getDefinition

public ChunkFactory.CommandDefinition getDefinition()

getValue

public java.lang.Object getValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Chunk

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class Chunk

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.Chunk

public final class Chunk
extends java.lang.Object

Base of all chunks, which hold data, flags etc

Nested Class Summary
static class | Chunk.BlockOffsetCommand A special kind of command that holds the offset to a block
static class | Chunk.Command A command in the visio file.
Field Summary
protected  ChunkFactory.CommandDefinition[] commandDefinitions
The possible different commands we can hold
Constructor Summary
Chunk(ChunkHeader header, ChunkTrailer trailer, ChunkSeparator separator, byte[] contents)
Method Summary
byte[] | _getContents()
ChunkFactory.CommandDefinition[] | getCommandDefinitions() Gets the command definitions, which define and describe much of the data held by the chunk.
Chunk.Command[] | getCommands()
ChunkHeader | getHeader()
java.lang.String | getName() Get the name of the chunk, as found from the CommandDefinitions
int | getOnDiskSize() Returns the size of the chunk, including any headers, trailers and separators.
ChunkSeparator | getSeparator() Gets the separator between this chunk and the next, if it exists
ChunkTrailer | getTrailer() Gets the trailer for this chunk, if it exists
protected void | processCommands() Uses our CommandDefinitions to process the commands our chunk type has, and figure out the values for them.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

commandDefinitions

protected ChunkFactory.CommandDefinition[] commandDefinitions
The possible different commands we can hold

Constructor Detail

Chunk

public Chunk(ChunkHeader header,
             ChunkTrailer trailer,
             ChunkSeparator separator,
             byte[] contents)
Method Detail

_getContents

public byte[] _getContents()

getHeader

public ChunkHeader getHeader()

getSeparator

public ChunkSeparator getSeparator()
Gets the separator between this chunk and the next, if it exists

getTrailer

public ChunkTrailer getTrailer()
Gets the trailer for this chunk, if it exists

getCommandDefinitions

public ChunkFactory.CommandDefinition[] getCommandDefinitions()
Gets the command definitions, which define and describe much of the data held by the chunk.

getCommands

public Chunk.Command[] getCommands()

getName

public java.lang.String getName()
Get the name of the chunk, as found from the CommandDefinitions

getOnDiskSize

public int getOnDiskSize()
Returns the size of the chunk, including any headers, trailers and separators.

processCommands

protected void processCommands()
Uses our CommandDefinitions to process the commands our chunk type has, and figure out the values for them.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ChunkFactory.CommandDefinition

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkFactory.CommandDefinition

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition
Enclosing class:
ChunkFactory
public class ChunkFactory.CommandDefinition
extends java.lang.Object

The definition of a Command, which a chunk may hold. The Command holds the value, this describes it.

Constructor Summary
ChunkFactory.CommandDefinition(int type, int offset, java.lang.String name)
Method Summary
java.lang.String | getName()
int | getOffset()
int | getType()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ChunkFactory.CommandDefinition

public ChunkFactory.CommandDefinition(int type,
                                      int offset,
                                      java.lang.String name)
Method Detail

getName

public java.lang.String getName()

getOffset

public int getOffset()

getType

public int getType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkFactory

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkFactory

public final class ChunkFactory
extends java.lang.Object

Factor class to create the appropriate chunks, which needs the version of the file to process the chunk header and trailer areas. Makes use of chunks_parse_cmds.tbl from vsdump to be able to process the chunk value area

Nested Class Summary
 class ChunkFactory.CommandDefinition
The definition of a Command, which a chunk may hold.
Constructor Summary
ChunkFactory(int version)
Method Summary
Chunk | createChunk(byte[] data, int offset) Creates the appropriate chunk at the given location.
int | getVersion()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ChunkFactory

public ChunkFactory(int version)
             throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getVersion

public int getVersion()

createChunk

public Chunk createChunk(byte[] data,
                         int offset)
Creates the appropriate chunk at the given location.

Parameters:
data -
offset -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkHeader

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkHeader
Direct Known Subclasses:
ChunkHeaderV4V5, ChunkHeaderV6
public abstract class ChunkHeader
extends java.lang.Object

A chunk header

Field Summary
protected int | id
protected int | length
protected int | type
protected int | unknown1
Constructor Summary
ChunkHeader()
Method Summary
static ChunkHeader | createChunkHeader(int documentVersion, byte[] data, int offset) Creates the appropriate ChunkHeader for the Chunk Header at the given location, for the given document version.
static int | getHeaderSize(int documentVersion) Returns the size of a chunk header for the given document version.
int | getId() Returns the ID/IX of the chunk
int | getLength() Returns the length of the trunk, excluding the length of the header, trailer or separator.
abstract int | getSizeInBytes()
int | getType() Returns the type of the chunk, which affects the mandatory information
int | getUnknown1()
abstract boolean | hasSeparator()
abstract boolean | hasTrailer()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

type

protected int type

id

protected int id

length

protected int length

unknown1

protected int unknown1
Constructor Detail

ChunkHeader

public ChunkHeader()
Method Detail

createChunkHeader

public static ChunkHeader createChunkHeader(int documentVersion,
                                            byte[] data,
                                            int offset)
Creates the appropriate ChunkHeader for the Chunk Header at the given location, for the given document version.

getHeaderSize

public static int getHeaderSize(int documentVersion)
Returns the size of a chunk header for the given document version.

getSizeInBytes

public abstract int getSizeInBytes()

hasTrailer

public abstract boolean hasTrailer()

hasSeparator

public abstract boolean hasSeparator()

getId

public int getId()
Returns the ID/IX of the chunk

getLength

public int getLength()
Returns the length of the trunk, excluding the length of the header, trailer or separator.

getType

public int getType()
Returns the type of the chunk, which affects the mandatory information

getUnknown1

public int getUnknown1()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkHeaderV11

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkHeaderV11

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkHeader
        extended by  org.apache.poi.hdgf.chunks.ChunkHeaderV6
            extended by  org.apache.poi.hdgf.chunks.ChunkHeaderV11

public final class ChunkHeaderV11
extends ChunkHeaderV6

A chunk header from v11+

Field Summary
Fields inherited from class org.apache.poi.hdgf.chunks.ChunkHeaderV6
unknown2, unknown3
Fields inherited from class org.apache.poi.hdgf.chunks.ChunkHeader
id, length, type, unknown1
Constructor Summary
ChunkHeaderV11()
Method Summary
 boolean hasSeparator()
Does the chunk have a separator?
Methods inherited from class org.apache.poi.hdgf.chunks.ChunkHeaderV6
getHeaderSize, getSizeInBytes, getUnknown2, getUnknown3, hasTrailer
Methods inherited from class org.apache.poi.hdgf.chunks.ChunkHeader
createChunkHeader, getHeaderSize, getId, getLength, getType, getUnknown1
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ChunkHeaderV11

public ChunkHeaderV11()
Method Detail

hasSeparator

public boolean hasSeparator()
Does the chunk have a separator?

Overrides:
hasSeparator in class ChunkHeaderV6
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkHeaderV4V5

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkHeaderV4V5

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkHeader
        extended by  org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

public final class ChunkHeaderV4V5
extends ChunkHeader

A chunk header from v4 or v5

Field Summary
protected short | unknown2
protected short | unknown3
Fields inherited from class org.apache.poi.hdgf.chunks.ChunkHeader
id, length, type, unknown1
Constructor Summary
ChunkHeaderV4V5()
Method Summary
protected static int | getHeaderSize()
int | getSizeInBytes()
short | getUnknown2()
short | getUnknown3()
boolean | hasSeparator() Does the chunk have a separator?
boolean | hasTrailer() Does the chunk have a trailer?
Methods inherited from class org.apache.poi.hdgf.chunks.ChunkHeader
createChunkHeader, getHeaderSize, getId, getLength, getType, getUnknown1
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

unknown2

protected short unknown2

unknown3

protected short unknown3
Constructor Detail

ChunkHeaderV4V5

public ChunkHeaderV4V5()
Method Detail

getUnknown2

public short getUnknown2()

getUnknown3

public short getUnknown3()

getHeaderSize

protected static int getHeaderSize()

getSizeInBytes

public int getSizeInBytes()
Specified by:
getSizeInBytes in class ChunkHeader

hasTrailer

public boolean hasTrailer()
Does the chunk have a trailer?

Specified by:
hasTrailer in class ChunkHeader

hasSeparator

public boolean hasSeparator()
Does the chunk have a separator?

Specified by:
hasSeparator in class ChunkHeader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkHeaderV6

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkHeaderV6

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkHeader
        extended by  org.apache.poi.hdgf.chunks.ChunkHeaderV6
Direct Known Subclasses:
ChunkHeaderV11
public class ChunkHeaderV6
extends ChunkHeader

A chunk header from v6

Field Summary
protected short | unknown2
protected short | unknown3
Fields inherited from class org.apache.poi.hdgf.chunks.ChunkHeader
id, length, type, unknown1
Constructor Summary
ChunkHeaderV6()
Method Summary
protected static int | getHeaderSize()
int | getSizeInBytes()
short | getUnknown2()
short | getUnknown3()
boolean | hasSeparator() Does the chunk have a separator?
boolean | hasTrailer() Does the chunk have a trailer?
Methods inherited from class org.apache.poi.hdgf.chunks.ChunkHeader
createChunkHeader, getHeaderSize, getId, getLength, getType, getUnknown1
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

unknown2

protected short unknown2

unknown3

protected short unknown3
Constructor Detail

ChunkHeaderV6

public ChunkHeaderV6()
Method Detail

getUnknown2

public short getUnknown2()

getUnknown3

public short getUnknown3()

getHeaderSize

protected static int getHeaderSize()

getSizeInBytes

public int getSizeInBytes()
Specified by:
getSizeInBytes in class ChunkHeader

hasTrailer

public boolean hasTrailer()
Does the chunk have a trailer?

Specified by:
hasTrailer in class ChunkHeader

hasSeparator

public boolean hasSeparator()
Does the chunk have a separator?

Specified by:
hasSeparator in class ChunkHeader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkSeparator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkSeparator

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkSeparator

public final class ChunkSeparator
extends java.lang.Object

A separator between the trailer of one chunk, and the header of the next one

Field Summary
protected  byte[] separatorData
Constructor Summary
ChunkSeparator(byte[] data, int offset)
Method Summary
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

separatorData

protected byte[] separatorData
Constructor Detail

ChunkSeparator

public ChunkSeparator(byte[] data,
                      int offset)
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkTrailer

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.chunks
Class ChunkTrailer

java.lang.Object
    extended by  org.apache.poi.hdgf.chunks.ChunkTrailer

public final class ChunkTrailer
extends java.lang.Object

A trailer that follows a chunk

Field Summary
protected  byte[] trailerData
Constructor Summary
ChunkTrailer(byte[] data, int offset)
Method Summary
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

trailerData

protected byte[] trailerData
Constructor Detail

ChunkTrailer

public ChunkTrailer(byte[] data,
                    int offset)
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hdgf.chunks
Classes
Chunk
Chunk.BlockOffsetCommand
Chunk.Command
ChunkFactory
ChunkHeader
ChunkHeaderV11
ChunkHeaderV4V5
ChunkHeaderV6
ChunkSeparator
ChunkTrailer


org.apache.poi.hdgf.chunks

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hdgf.chunks

Class Summary
Chunk | Base of all chunks, which hold data, flags etc
Chunk.BlockOffsetCommand | A special kind of command that holds the offset to a block
Chunk.Command | A command in the visio file.
ChunkFactory | Factor class to create the appropriate chunks, which needs the version of the file to process the chunk header and trailer areas.
ChunkHeader | A chunk header
ChunkHeaderV11 | A chunk header from v11+
ChunkHeaderV4V5 | A chunk header from v4 or v5
ChunkHeaderV6 | A chunk header from v6
ChunkSeparator | A separator between the trailer of one chunk, and the header of the next one
ChunkTrailer | A trailer that follows a chunk


org.apache.poi.hdgf.chunks Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hdgf.chunks

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hdgf.chunks.Chunk
    • org.apache.poi.hdgf.chunks.Chunk.Command
      • org.apache.poi.hdgf.chunks.Chunk.BlockOffsetCommand
    • org.apache.poi.hdgf.chunks.ChunkFactory
    • org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition
    • org.apache.poi.hdgf.chunks.ChunkHeader
      • org.apache.poi.hdgf.chunks.ChunkHeaderV4V5
      • org.apache.poi.hdgf.chunks.ChunkHeaderV6
        • org.apache.poi.hdgf.chunks.ChunkHeaderV11
    • org.apache.poi.hdgf.chunks.ChunkSeparator
    • org.apache.poi.hdgf.chunks.ChunkTrailer


Uses of Package org.apache.poi.hdgf.chunks

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hdgf.chunks

Packages that use org.apache.poi.hdgf.chunks
org.apache.poi.hdgf.chunks
org.apache.poi.hdgf.streams

Classes in org.apache.poi.hdgf.chunks used by org.apache.poi.hdgf.chunks
Chunk
Base of all chunks, which hold data, flags etc
Chunk.Command
A command in the visio file.
ChunkFactory.CommandDefinition
The definition of a Command, which a chunk may hold.
ChunkHeader
A chunk header
ChunkHeaderV6
A chunk header from v6
ChunkSeparator
A separator between the trailer of one chunk, and the header of the next one
ChunkTrailer
A trailer that follows a chunk

Classes in org.apache.poi.hdgf.chunks used by org.apache.poi.hdgf.streams
Chunk
Base of all chunks, which hold data, flags etc
ChunkFactory
Factor class to create the appropriate chunks, which needs the version of the file to process the chunk header and trailer areas.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.Chunk.BlockOffsetCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.Chunk.BlockOffsetCommand

No usage of org.apache.poi.hdgf.chunks.Chunk.BlockOffsetCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.Chunk.Command

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.Chunk.Command

Packages that use Chunk.Command
org.apache.poi.hdgf.chunks

Uses of Chunk.Command in org.apache.poi.hdgf.chunks

Subclasses of Chunk.Command in org.apache.poi.hdgf.chunks
static class Chunk.BlockOffsetCommand
A special kind of command that holds the offset to a block

Methods in org.apache.poi.hdgf.chunks that return Chunk.Command
 Chunk.Command[] Chunk.getCommands()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.Chunk

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.Chunk

Packages that use Chunk
org.apache.poi.hdgf.chunks
org.apache.poi.hdgf.streams

Uses of Chunk in org.apache.poi.hdgf.chunks

Methods in org.apache.poi.hdgf.chunks that return Chunk
 Chunk ChunkFactory.createChunk(byte[] data, int offset)
Creates the appropriate chunk at the given location.

Uses of Chunk in org.apache.poi.hdgf.streams

Methods in org.apache.poi.hdgf.streams that return Chunk
 Chunk[] ChunkStream.getChunks()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkFactory.CommandDefinition

Packages that use ChunkFactory.CommandDefinition
org.apache.poi.hdgf.chunks

Uses of ChunkFactory.CommandDefinition in org.apache.poi.hdgf.chunks

Fields in org.apache.poi.hdgf.chunks declared as ChunkFactory.CommandDefinition
protected  ChunkFactory.CommandDefinition[] Chunk.commandDefinitions
The possible different commands we can hold

Methods in org.apache.poi.hdgf.chunks that return ChunkFactory.CommandDefinition
ChunkFactory.CommandDefinition[] | Chunk.getCommandDefinitions() Gets the command definitions, which define and describe much of the data held by the chunk.
ChunkFactory.CommandDefinition | Chunk.Command.getDefinition()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkFactory

Packages that use ChunkFactory
org.apache.poi.hdgf.streams

Uses of ChunkFactory in org.apache.poi.hdgf.streams

Methods in org.apache.poi.hdgf.streams with parameters of type ChunkFactory
static Stream Stream.createStream(Pointer pointer, byte[] documentData, ChunkFactory chunkFactory, PointerFactory pointerFactory)
Uses the pointer to locate a Stream within the document data, and creates it.

Constructors in org.apache.poi.hdgf.streams with parameters of type ChunkFactory
ChunkStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
PointerContainingStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
StringsStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
TrailerStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkHeader

Packages that use ChunkHeader
org.apache.poi.hdgf.chunks

Uses of ChunkHeader in org.apache.poi.hdgf.chunks

Subclasses of ChunkHeader in org.apache.poi.hdgf.chunks
class | ChunkHeaderV11 A chunk header from v11+
class | ChunkHeaderV4V5 A chunk header from v4 or v5
class | ChunkHeaderV6 A chunk header from v6

Methods in org.apache.poi.hdgf.chunks that return ChunkHeader
static ChunkHeader | ChunkHeader.createChunkHeader(int documentVersion, byte[] data, int offset) Creates the appropriate ChunkHeader for the Chunk Header at the given location, for the given document version.
ChunkHeader | Chunk.getHeader()

Constructors in org.apache.poi.hdgf.chunks with parameters of type ChunkHeader
Chunk(ChunkHeader header, ChunkTrailer trailer, ChunkSeparator separator, byte[] contents)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkHeaderV11

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkHeaderV11

No usage of org.apache.poi.hdgf.chunks.ChunkHeaderV11

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

No usage of org.apache.poi.hdgf.chunks.ChunkHeaderV4V5

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkHeaderV6

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkHeaderV6

Packages that use ChunkHeaderV6
org.apache.poi.hdgf.chunks

Uses of ChunkHeaderV6 in org.apache.poi.hdgf.chunks

Subclasses of ChunkHeaderV6 in org.apache.poi.hdgf.chunks
 class ChunkHeaderV11
A chunk header from v11+

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkSeparator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkSeparator

Packages that use ChunkSeparator
org.apache.poi.hdgf.chunks

Uses of ChunkSeparator in org.apache.poi.hdgf.chunks

Methods in org.apache.poi.hdgf.chunks that return ChunkSeparator
 ChunkSeparator Chunk.getSeparator()
Gets the separator between this chunk and the next, if it exists

Constructors in org.apache.poi.hdgf.chunks with parameters of type ChunkSeparator
Chunk(ChunkHeader header, ChunkTrailer trailer, ChunkSeparator separator, byte[] contents)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.chunks.ChunkTrailer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.chunks.ChunkTrailer

Packages that use ChunkTrailer
org.apache.poi.hdgf.chunks

Uses of ChunkTrailer in org.apache.poi.hdgf.chunks

Methods in org.apache.poi.hdgf.chunks that return ChunkTrailer
 ChunkTrailer Chunk.getTrailer()
Gets the trailer for this chunk, if it exists

Constructors in org.apache.poi.hdgf.chunks with parameters of type ChunkTrailer
Chunk(ChunkHeader header, ChunkTrailer trailer, ChunkSeparator separator, byte[] contents)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.HDGFDiagram

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.HDGFDiagram

Packages that use HDGFDiagram
org.apache.poi.hdgf.extractor

Uses of HDGFDiagram in org.apache.poi.hdgf.extractor

Constructors in org.apache.poi.hdgf.extractor with parameters of type HDGFDiagram
VisioTextExtractor(HDGFDiagram hdgf)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.HDGFLZW

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.HDGFLZW

No usage of org.apache.poi.hdgf.HDGFLZW

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hdgf.dev
Classes
VSDDumper


org.apache.poi.hdgf.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hdgf.dev

Class Summary
VSDDumper Developer helper class to dump out the pointer+stream structure of a Visio file


org.apache.poi.hdgf.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hdgf.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hdgf.dev.VSDDumper


Uses of Package org.apache.poi.hdgf.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hdgf.dev

No usage of org.apache.poi.hdgf.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


VSDDumper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.dev
Class VSDDumper

java.lang.Object
    extended by  org.apache.poi.hdgf.dev.VSDDumper

public final class VSDDumper
extends java.lang.Object

Developer helper class to dump out the pointer+stream structure of a Visio file

Constructor Summary
VSDDumper()
Method Summary
static void | dumpStream(Stream stream, int indent)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VSDDumper

public VSDDumper()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

dumpStream

public static void dumpStream(Stream stream,
                              int indent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hdgf.dev.VSDDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.dev.VSDDumper

No usage of org.apache.poi.hdgf.dev.VSDDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HDGFException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.exceptions
Class HDGFException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hdgf.exceptions.HDGFException
All Implemented Interfaces:
java.io.Serializable
public final class HDGFException
extends java.lang.RuntimeException

The superclass of all HDGF exceptions

Author:
Yegor Kozlov
See Also:
Serialized Form

Constructor Summary
HDGFException()
HDGFException(java.lang.String message)
HDGFException(java.lang.String message, java.lang.Throwable cause)
HDGFException(java.lang.Throwable cause)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HDGFException

public HDGFException()

HDGFException

public HDGFException(java.lang.String message)

HDGFException

public HDGFException(java.lang.String message,
                     java.lang.Throwable cause)

HDGFException

public HDGFException(java.lang.Throwable cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hdgf.exceptions
Exceptions
HDGFException


org.apache.poi.hdgf.exceptions

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hdgf.exceptions

Exception Summary
HDGFException The superclass of all HDGF exceptions


org.apache.poi.hdgf.exceptions Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hdgf.exceptions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.apache.poi.hdgf.exceptions.HDGFException


Uses of Package org.apache.poi.hdgf.exceptions

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hdgf.exceptions

No usage of org.apache.poi.hdgf.exceptions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.exceptions.HDGFException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.exceptions.HDGFException

No usage of org.apache.poi.hdgf.exceptions.HDGFException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hdgf.extractor
Classes
VisioTextExtractor


org.apache.poi.hdgf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hdgf.extractor

Class Summary
VisioTextExtractor Class to find all the text in a Visio file, and return it.


org.apache.poi.hdgf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hdgf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIOLE2TextExtractor
        • org.apache.poi.hdgf.extractor.VisioTextExtractor


Uses of Package org.apache.poi.hdgf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hdgf.extractor

No usage of org.apache.poi.hdgf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


VisioTextExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.extractor
Class VisioTextExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hdgf.extractor.VisioTextExtractor

public final class VisioTextExtractor
extends POIOLE2TextExtractor

Class to find all the text in a Visio file, and return it. Can opperate on the command line (outputs to stdout), or can return the text for you (eg for use with Lucene).

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
VisioTextExtractor(DirectoryNode dir)
VisioTextExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use VisioTextExtractor(DirectoryNode) instead
VisioTextExtractor(HDGFDiagram hdgf)
VisioTextExtractor(java.io.InputStream inp)
VisioTextExtractor(NPOIFSFileSystem fs)
VisioTextExtractor(POIFSFileSystem fs)
Method Summary
java.lang.String[] | getAllText() Locates all the text entries in the file, and returns their contents.
java.lang.String | getText() Returns the textual contents of the file.
static void | main(java.lang.String[] args)
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getDocSummaryInformation, getFileSystem, getMetadataTextExtractor, getRoot, getSummaryInformation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VisioTextExtractor

public VisioTextExtractor(HDGFDiagram hdgf)

VisioTextExtractor

public VisioTextExtractor(POIFSFileSystem fs)
                   throws java.io.IOException
Throws:
java.io.IOException

VisioTextExtractor

public VisioTextExtractor(NPOIFSFileSystem fs)
                   throws java.io.IOException
Throws:
java.io.IOException

VisioTextExtractor

public VisioTextExtractor(DirectoryNode dir)
                   throws java.io.IOException
Throws:
java.io.IOException

VisioTextExtractor

@Deprecated
public VisioTextExtractor(DirectoryNode dir,
                                     POIFSFileSystem fs)
                   throws java.io.IOException
Deprecated. Use VisioTextExtractor(DirectoryNode) instead

Throws:
java.io.IOException

VisioTextExtractor

public VisioTextExtractor(java.io.InputStream inp)
                   throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getAllText

public java.lang.String[] getAllText()
Locates all the text entries in the file, and returns their contents.

getText

public java.lang.String getText()
Returns the textual contents of the file. Each textual object's text will be separated by a newline

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hdgf.extractor.VisioTextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.extractor.VisioTextExtractor

No usage of org.apache.poi.hdgf.extractor.VisioTextExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hdgf.pointers
Classes
Pointer
PointerFactory
PointerV6


org.apache.poi.hdgf.pointers

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hdgf.pointers

Class Summary
Pointer | Base class of pointers, which hold metadata and offsets about blocks elsewhere in the file
PointerFactory | Factor class to create the appropriate pointers, based on the version of the file
PointerV6 | A Pointer from v6+


org.apache.poi.hdgf.pointers Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hdgf.pointers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hdgf.pointers.Pointer
      • org.apache.poi.hdgf.pointers.PointerV6
    • org.apache.poi.hdgf.pointers.PointerFactory


Uses of Package org.apache.poi.hdgf.pointers

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hdgf.pointers

Packages that use org.apache.poi.hdgf.pointers
org.apache.poi.hdgf.pointers
org.apache.poi.hdgf.streams

Classes in org.apache.poi.hdgf.pointers used by org.apache.poi.hdgf.pointers
Pointer
Base class of pointers, which hold metadata and offsets about blocks elsewhere in the file

Classes in org.apache.poi.hdgf.pointers used by org.apache.poi.hdgf.streams
Pointer
Base class of pointers, which hold metadata and offsets about blocks elsewhere in the file
PointerFactory
Factor class to create the appropriate pointers, based on the version of the file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Pointer

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.pointers
Class Pointer

java.lang.Object
    extended by  org.apache.poi.hdgf.pointers.Pointer
Direct Known Subclasses:
PointerV6
public abstract class Pointer
extends java.lang.Object

Base class of pointers, which hold metadata and offsets about blocks elsewhere in the file

Field Summary
protected int | address
protected short | format
protected int | length
protected int | offset
protected int | type
Constructor Summary
Pointer()
Method Summary
abstract boolean | destinationCompressed()
abstract boolean | destinationHasChunks()
abstract boolean | destinationHasPointers()
abstract boolean | destinationHasStrings()
int | getAddress()
short | getFormat()
int | getLength()
int | getOffset()
abstract int | getSizeInBytes()
int | getType()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

type

protected int type

address

protected int address

offset

protected int offset

length

protected int length

format

protected short format
Constructor Detail

Pointer

public Pointer()
Method Detail

getAddress

public int getAddress()

getFormat

public short getFormat()

getLength

public int getLength()

getOffset

public int getOffset()

getType

public int getType()

getSizeInBytes

public abstract int getSizeInBytes()

destinationHasStrings

public abstract boolean destinationHasStrings()

destinationHasPointers

public abstract boolean destinationHasPointers()

destinationHasChunks

public abstract boolean destinationHasChunks()

destinationCompressed

public abstract boolean destinationCompressed()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PointerFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.pointers
Class PointerFactory

java.lang.Object
    extended by  org.apache.poi.hdgf.pointers.PointerFactory

public final class PointerFactory
extends java.lang.Object

Factor class to create the appropriate pointers, based on the version of the file

Constructor Summary
PointerFactory(int version)
Method Summary
Pointer | createPointer(byte[] data, int offset)
int | getVersion()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PointerFactory

public PointerFactory(int version)
Method Detail

getVersion

public int getVersion()

createPointer

public Pointer createPointer(byte[] data,
                             int offset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PointerV6

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.pointers
Class PointerV6

java.lang.Object
    extended by  org.apache.poi.hdgf.pointers.Pointer
        extended by  org.apache.poi.hdgf.pointers.PointerV6

public final class PointerV6
extends Pointer

A Pointer from v6+

Field Summary
Fields inherited from class org.apache.poi.hdgf.pointers.Pointer
address, format, length, offset, type
Constructor Summary
PointerV6()
Method Summary
boolean | destinationCompressed()
boolean | destinationHasChunks()
boolean | destinationHasPointers()
boolean | destinationHasStrings()
int | getSizeInBytes() With v6 pointers, the on-disk size is 18 bytes
Methods inherited from class org.apache.poi.hdgf.pointers.Pointer
getAddress, getFormat, getLength, getOffset, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PointerV6

public PointerV6()
Method Detail

destinationHasStrings

public boolean destinationHasStrings()
Specified by:
destinationHasStrings in class Pointer

destinationHasPointers

public boolean destinationHasPointers()
Specified by:
destinationHasPointers in class Pointer

destinationHasChunks

public boolean destinationHasChunks()
Specified by:
destinationHasChunks in class Pointer

destinationCompressed

public boolean destinationCompressed()
Specified by:
destinationCompressed in class Pointer

getSizeInBytes

public int getSizeInBytes()
With v6 pointers, the on-disk size is 18 bytes

Specified by:
getSizeInBytes in class Pointer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hdgf.pointers.Pointer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.pointers.Pointer

Packages that use Pointer
org.apache.poi.hdgf.pointers
org.apache.poi.hdgf.streams

Uses of Pointer in org.apache.poi.hdgf.pointers

Subclasses of Pointer in org.apache.poi.hdgf.pointers
 class PointerV6
A Pointer from v6+

Methods in org.apache.poi.hdgf.pointers that return Pointer
 Pointer PointerFactory.createPointer(byte[] data, int offset)

Uses of Pointer in org.apache.poi.hdgf.streams

Methods in org.apache.poi.hdgf.streams that return Pointer
protected Pointer[] | PointerContainingStream.getChildPointers() Returns all the pointers that we contain
Pointer | Stream.getPointer()

Methods in org.apache.poi.hdgf.streams with parameters of type Pointer
static Stream Stream.createStream(Pointer pointer, byte[] documentData, ChunkFactory chunkFactory, PointerFactory pointerFactory)
Uses the pointer to locate a Stream within the document data, and creates it.

Constructors in org.apache.poi.hdgf.streams with parameters of type Pointer
ChunkStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
PointerContainingStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
Stream(Pointer pointer, StreamStore store)
Creates a new Stream, having already used the pointer to build a store
StringsStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
TrailerStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
UnknownStream(Pointer pointer, StreamStore store)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.pointers.PointerFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.pointers.PointerFactory

Packages that use PointerFactory
org.apache.poi.hdgf.streams

Uses of PointerFactory in org.apache.poi.hdgf.streams

Methods in org.apache.poi.hdgf.streams with parameters of type PointerFactory
static Stream Stream.createStream(Pointer pointer, byte[] documentData, ChunkFactory chunkFactory, PointerFactory pointerFactory)
Uses the pointer to locate a Stream within the document data, and creates it.

Constructors in org.apache.poi.hdgf.streams with parameters of type PointerFactory
PointerContainingStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
TrailerStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.pointers.PointerV6

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.pointers.PointerV6

No usage of org.apache.poi.hdgf.pointers.PointerV6

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ChunkStream

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class ChunkStream

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.Stream
        extended by  org.apache.poi.hdgf.streams.ChunkStream

public final class ChunkStream
extends Stream

Constructor Summary
protected ChunkStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
Method Summary
void | findChunks() Process the contents of the stream out into chunks
Chunk[] | getChunks()
Methods inherited from class org.apache.poi.hdgf.streams.Stream
_getContentsLength, _getStore, createStream, getPointer, getStore
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ChunkStream

protected ChunkStream(Pointer pointer,
                      StreamStore store,
                      ChunkFactory chunkFactory)
Method Detail

getChunks

public Chunk[] getChunks()

findChunks

public void findChunks()
Process the contents of the stream out into chunks

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CompressedStreamStore

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class CompressedStreamStore

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.StreamStore
        extended by  org.apache.poi.hdgf.streams.CompressedStreamStore

public final class CompressedStreamStore
extends StreamStore

A StreamStore where the data on-disk is compressed, using the crazy Visio LZW

Constructor Summary
protected CompressedStreamStore(byte[] data, int offset, int length)
Creates a new compressed StreamStore, which will handle the decompression.
Method Summary
protected byte[] | _getBlockHeader()
protected byte[] | _getCompressedContents()
protected void | copyBlockHeaderToContents() Some kinds of streams expect their 4 byte header to be on the front of the contents.
static byte[][] | decompress(byte[] data, int offset, int length) Decompresses the given data, returning it as header + contents
Methods inherited from class org.apache.poi.hdgf.streams.StreamStore
_getContents, getContents, prependContentsWith
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CompressedStreamStore

protected CompressedStreamStore(byte[] data,
                                int offset,
                                int length)
                         throws java.io.IOException
Creates a new compressed StreamStore, which will handle the decompression.

Throws:
java.io.IOException
Method Detail

_getCompressedContents

protected byte[] _getCompressedContents()

_getBlockHeader

protected byte[] _getBlockHeader()

copyBlockHeaderToContents

protected void copyBlockHeaderToContents()
Some kinds of streams expect their 4 byte header to be on the front of the contents. They can call this to have it sorted.

Overrides:
copyBlockHeaderToContents in class StreamStore

decompress

public static byte[][] decompress(byte[] data,
                                  int offset,
                                  int length)
                           throws java.io.IOException
Decompresses the given data, returning it as header + contents

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hdgf.streams
Classes
ChunkStream
CompressedStreamStore
PointerContainingStream
Stream
StreamStore
StringsStream
TrailerStream
UnknownStream


org.apache.poi.hdgf.streams

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hdgf.streams

Class Summary
ChunkStream |
CompressedStreamStore | A StreamStore where the data on-disk is compressed, using the crazy Visio LZW
PointerContainingStream | A stream that holds pointers, possibly in addition to some other data too.
Stream | Base of all Streams within a HDGF document.
StreamStore | Holds the representation of the stream on-disk, and handles de-compressing it as required.
StringsStream | A Stream which holds Strings.
TrailerStream | The TrailerStream is a special kind of Stream containing pointers, and some core document settings.
UnknownStream | A placeholder for a stream where we don't known anything about how to process / handle it


org.apache.poi.hdgf.streams Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hdgf.streams

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hdgf.streams.Stream
      • org.apache.poi.hdgf.streams.ChunkStream
      • org.apache.poi.hdgf.streams.PointerContainingStream
        • org.apache.poi.hdgf.streams.TrailerStream
      • org.apache.poi.hdgf.streams.StringsStream
      • org.apache.poi.hdgf.streams.UnknownStream
    • org.apache.poi.hdgf.streams.StreamStore
      • org.apache.poi.hdgf.streams.CompressedStreamStore


Uses of Package org.apache.poi.hdgf.streams

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hdgf.streams

Packages that use org.apache.poi.hdgf.streams
org.apache.poi.hdgf
org.apache.poi.hdgf.dev
org.apache.poi.hdgf.streams

Classes in org.apache.poi.hdgf.streams used by org.apache.poi.hdgf
Stream
Base of all Streams within a HDGF document.
TrailerStream
The TrailerStream is a special kind of Stream containing pointers, and some core document settings.

Classes in org.apache.poi.hdgf.streams used by org.apache.poi.hdgf.dev
Stream
Base of all Streams within a HDGF document.

Classes in org.apache.poi.hdgf.streams used by org.apache.poi.hdgf.streams
PointerContainingStream
A stream that holds pointers, possibly in addition to some other data too.
Stream
Base of all Streams within a HDGF document.
StreamStore
Holds the representation of the stream on-disk, and handles de-compressing it as required.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PointerContainingStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class PointerContainingStream

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.Stream
        extended by  org.apache.poi.hdgf.streams.PointerContainingStream
Direct Known Subclasses:
TrailerStream
public class PointerContainingStream
extends Stream

A stream that holds pointers, possibly in addition to some other data too.

Constructor Summary
protected PointerContainingStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
Method Summary
void | findChildren(byte[] documentData) Performs a recursive search, identifying the pointers we contain, creating the Streams for where they point to, then searching those if appropriate.
protected Pointer[] | getChildPointers() Returns all the pointers that we contain
Stream[] | getPointedToStreams() Returns all the "child" streams.
Methods inherited from class org.apache.poi.hdgf.streams.Stream
_getContentsLength, _getStore, createStream, getPointer, getStore
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PointerContainingStream

protected PointerContainingStream(Pointer pointer,
                                  StreamStore store,
                                  ChunkFactory chunkFactory,
                                  PointerFactory pointerFactory)
Method Detail

getChildPointers

protected Pointer[] getChildPointers()
Returns all the pointers that we contain

getPointedToStreams

public Stream[] getPointedToStreams()
Returns all the "child" streams. These are all the streams pointed to by the pointers that we contain.

findChildren

public void findChildren(byte[] documentData)
Performs a recursive search, identifying the pointers we contain, creating the Streams for where they point to, then searching those if appropriate.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Stream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class Stream

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.Stream
Direct Known Subclasses:
ChunkStream, PointerContainingStream, StringsStream, UnknownStream
public abstract class Stream
extends java.lang.Object

Base of all Streams within a HDGF document. Streams are what hold the data (the metadata of a stream is held in the pointer that points to the stream). A stream may be stored compressed or un-compressed on the disk, but that doesn't appear to change their use.

Constructor Summary
protected Stream(Pointer pointer, StreamStore store)
Creates a new Stream, having already used the pointer to build a store
Method Summary
int | _getContentsLength()
StreamStore | _getStore()
static Stream | createStream(Pointer pointer, byte[] documentData, ChunkFactory chunkFactory, PointerFactory pointerFactory) Uses the pointer to locate a Stream within the document data, and creates it.
Pointer | getPointer()
protected StreamStore | getStore()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Stream

protected Stream(Pointer pointer,
                 StreamStore store)
Creates a new Stream, having already used the pointer to build a store

Method Detail

getPointer

public Pointer getPointer()

getStore

protected StreamStore getStore()

_getStore

public StreamStore _getStore()

_getContentsLength

public int _getContentsLength()

createStream

public static Stream createStream(Pointer pointer,
                                  byte[] documentData,
                                  ChunkFactory chunkFactory,
                                  PointerFactory pointerFactory)
Uses the pointer to locate a Stream within the document data, and creates it.

Parameters:
pointer - The Pointer to create a stream for
documentData - The raw document data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StreamStore

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class StreamStore

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.StreamStore
Direct Known Subclasses:
CompressedStreamStore
public class StreamStore
extends java.lang.Object

Holds the representation of the stream on-disk, and handles de-compressing it as required. In future, may also handle writing it back out again

Constructor Summary
protected StreamStore(byte[] data, int offset, int length)
Creates a new, non compressed Stream Store
Method Summary
byte[] | _getContents()
protected void | copyBlockHeaderToContents()
protected byte[] | getContents()
protected void | prependContentsWith(byte[] b)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StreamStore

protected StreamStore(byte[] data,
                      int offset,
                      int length)
Creates a new, non compressed Stream Store

Method Detail

prependContentsWith

protected void prependContentsWith(byte[] b)

copyBlockHeaderToContents

protected void copyBlockHeaderToContents()

getContents

protected byte[] getContents()

_getContents

public byte[] _getContents()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringsStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class StringsStream

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.Stream
        extended by  org.apache.poi.hdgf.streams.StringsStream

public final class StringsStream
extends Stream

A Stream which holds Strings. This is just another kind of ChunkStream, it seems

Constructor Summary
protected StringsStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
Method Summary
Methods inherited from class org.apache.poi.hdgf.streams.Stream
_getContentsLength, _getStore, createStream, getPointer, getStore
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StringsStream

protected StringsStream(Pointer pointer,
                        StreamStore store,
                        ChunkFactory chunkFactory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TrailerStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class TrailerStream

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.Stream
        extended by  org.apache.poi.hdgf.streams.PointerContainingStream
            extended by  org.apache.poi.hdgf.streams.TrailerStream

public class TrailerStream
extends PointerContainingStream

The TrailerStream is a special kind of Stream containing pointers, and some core document settings. These is one of these in each document, and it's pointed to by a special series of byte near the start of the file.

Constructor Summary
protected TrailerStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
Method Summary
Methods inherited from class org.apache.poi.hdgf.streams.PointerContainingStream
findChildren, getChildPointers, getPointedToStreams
Methods inherited from class org.apache.poi.hdgf.streams.Stream
_getContentsLength, _getStore, createStream, getPointer, getStore
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TrailerStream

protected TrailerStream(Pointer pointer,
                        StreamStore store,
                        ChunkFactory chunkFactory,
                        PointerFactory pointerFactory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownStream

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hdgf.streams
Class UnknownStream

java.lang.Object
    extended by  org.apache.poi.hdgf.streams.Stream
        extended by  org.apache.poi.hdgf.streams.UnknownStream

public final class UnknownStream
extends Stream

A placeholder for a stream where we don't known anything about how to process / handle it

Constructor Summary
protected UnknownStream(Pointer pointer, StreamStore store)
Method Summary
Methods inherited from class org.apache.poi.hdgf.streams.Stream
_getContentsLength, _getStore, createStream, getPointer, getStore
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnknownStream

protected UnknownStream(Pointer pointer,
                        StreamStore store)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hdgf.streams.ChunkStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.ChunkStream

No usage of org.apache.poi.hdgf.streams.ChunkStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.streams.CompressedStreamStore

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.CompressedStreamStore

No usage of org.apache.poi.hdgf.streams.CompressedStreamStore

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.streams.PointerContainingStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.PointerContainingStream

Packages that use PointerContainingStream
org.apache.poi.hdgf.streams

Uses of PointerContainingStream in org.apache.poi.hdgf.streams

Subclasses of PointerContainingStream in org.apache.poi.hdgf.streams
 class TrailerStream
The TrailerStream is a special kind of Stream containing pointers, and some core document settings.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.streams.Stream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.Stream

Packages that use Stream
org.apache.poi.hdgf
org.apache.poi.hdgf.dev
org.apache.poi.hdgf.streams

Uses of Stream in org.apache.poi.hdgf

Methods in org.apache.poi.hdgf that return Stream
 Stream[] HDGFDiagram.getTopLevelStreams()
Returns all the top level streams, which are the streams pointed to by the TrailerStream.

Uses of Stream in org.apache.poi.hdgf.dev

Methods in org.apache.poi.hdgf.dev with parameters of type Stream
static void VSDDumper.dumpStream(Stream stream, int indent)

Uses of Stream in org.apache.poi.hdgf.streams

Subclasses of Stream in org.apache.poi.hdgf.streams
class | ChunkStream
class | PointerContainingStream A stream that holds pointers, possibly in addition to some other data too.
class | StringsStream A Stream which holds Strings.
class | TrailerStream The TrailerStream is a special kind of Stream containing pointers, and some core document settings.
class | UnknownStream A placeholder for a stream where we don't known anything about how to process / handle it

Methods in org.apache.poi.hdgf.streams that return Stream
static Stream | Stream.createStream(Pointer pointer, byte[] documentData, ChunkFactory chunkFactory, PointerFactory pointerFactory) Uses the pointer to locate a Stream within the document data, and creates it.
Stream[] | PointerContainingStream.getPointedToStreams() Returns all the "child" streams.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.streams.StreamStore

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.StreamStore

Packages that use StreamStore
org.apache.poi.hdgf.streams

Uses of StreamStore in org.apache.poi.hdgf.streams

Subclasses of StreamStore in org.apache.poi.hdgf.streams
 class CompressedStreamStore
A StreamStore where the data on-disk is compressed, using the crazy Visio LZW

Methods in org.apache.poi.hdgf.streams that return StreamStore
StreamStore | Stream._getStore()
protected StreamStore | Stream.getStore()

Constructors in org.apache.poi.hdgf.streams with parameters of type StreamStore
ChunkStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
PointerContainingStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
Stream(Pointer pointer, StreamStore store)
Creates a new Stream, having already used the pointer to build a store
StringsStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory)
TrailerStream(Pointer pointer, StreamStore store, ChunkFactory chunkFactory, PointerFactory pointerFactory)
UnknownStream(Pointer pointer, StreamStore store)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.streams.StringsStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.StringsStream

No usage of org.apache.poi.hdgf.streams.StringsStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.streams.TrailerStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.TrailerStream

Packages that use TrailerStream
org.apache.poi.hdgf

Uses of TrailerStream in org.apache.poi.hdgf

Methods in org.apache.poi.hdgf that return TrailerStream
 TrailerStream HDGFDiagram.getTrailerStream()
Returns the TrailerStream, which is at the root of the tree of Streams.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hdgf.streams.UnknownStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hdgf.streams.UnknownStream

No usage of org.apache.poi.hdgf.streams.UnknownStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Attachment

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef
Class Attachment

java.lang.Object
    extended by  org.apache.poi.hmef.Attachment

public final class Attachment
extends java.lang.Object

An attachment within a HMEFMessage. Provides both helper methods to get at common parts and attributes of the attachment, and list methods to get all of them.

Constructor Summary
Attachment()
Method Summary
protected void | addAttribute(TNEFAttribute attr)
TNEFAttribute | getAttribute(TNEFProperty id) Return the attachment attribute with the given ID, or null if there isn't one.
java.util.List<TNEFAttribute> | getAttributes() Returns all HMEF/TNEF attributes of the attachment, such as filename, icon and contents
byte[] | getContents() Returns the contents of the attachment.
java.lang.String | getExtension() Returns the file extension
java.lang.String | getFilename() Returns the short filename
java.lang.String | getLongFilename() Returns the long filename
MAPIAttribute | getMAPIAttribute(MAPIProperty id) Return the attachment MAPI Attribute with the given ID, or null if there isn't one.
java.util.List<MAPIAttribute> | getMAPIAttributes() Returns all MAPI attributes of the attachment, such as extension, encoding, size and position
java.util.Date | getModifiedDate() Return when the file was last modified, if known.
byte[] | getRenderedMetaFile() Returns the Meta File rendered representation of the attachment, or null if not set.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Attachment

public Attachment()
Method Detail

addAttribute

protected void addAttribute(TNEFAttribute attr)

getAttribute

public TNEFAttribute getAttribute(TNEFProperty id)
Return the attachment attribute with the given ID, or null if there isn't one.

getMAPIAttribute

public MAPIAttribute getMAPIAttribute(MAPIProperty id)
Return the attachment MAPI Attribute with the given ID, or null if there isn't one.

getAttributes

public java.util.List<TNEFAttribute> getAttributes()
Returns all HMEF/TNEF attributes of the attachment, such as filename, icon and contents

getMAPIAttributes

public java.util.List<MAPIAttribute> getMAPIAttributes()
Returns all MAPI attributes of the attachment, such as extension, encoding, size and position

getFilename

public java.lang.String getFilename()
Returns the short filename

getLongFilename

public java.lang.String getLongFilename()
Returns the long filename

getExtension

public java.lang.String getExtension()
Returns the file extension

getModifiedDate

public java.util.Date getModifiedDate()
Return when the file was last modified, if known.

getContents

public byte[] getContents()
Returns the contents of the attachment.

getRenderedMetaFile

public byte[] getRenderedMetaFile()
Returns the Meta File rendered representation of the attachment, or null if not set.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CompressedRTF

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef
Class CompressedRTF

java.lang.Object
    extended by  org.apache.poi.util.LZWDecompresser
        extended by  org.apache.poi.hmef.CompressedRTF

public final class CompressedRTF
extends LZWDecompresser

Within a HMEFMessage, the content is often stored in as RTF, but LZW compressed. This class handles decompressing it for you.

Field Summary
static byte[] | COMPRESSED_SIGNATURE
static int | COMPRESSED_SIGNATURE_INT
static java.lang.String | LZW_RTF_PRELOAD
static byte[] | UNCOMPRESSED_SIGNATURE
static int | UNCOMPRESSED_SIGNATURE_INT
Constructor Summary
CompressedRTF()
Method Summary
protected int | adjustDictionaryOffset(int offset) We use regular dictionary offsets, so no need to change anything
void | decompress(java.io.InputStream src, java.io.OutputStream res) Decompresses the whole of the compressed RTF stream, outputting the resulting RTF bytes.
int | getCompressedSize() Returns how big the compressed version was.
int | getDeCompressedSize() Returns how big the decompressed version was.
protected int | populateDictionary(byte[] dict) Populates the dictionary, and returns where in it to begin writing new codes.
Methods inherited from class org.apache.poi.util.LZWDecompresser
decompress, fromByte, fromInt
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPRESSED_SIGNATURE

public static final byte[] COMPRESSED_SIGNATURE

UNCOMPRESSED_SIGNATURE

public static final byte[] UNCOMPRESSED_SIGNATURE

COMPRESSED_SIGNATURE_INT

public static final int COMPRESSED_SIGNATURE_INT

UNCOMPRESSED_SIGNATURE_INT

public static final int UNCOMPRESSED_SIGNATURE_INT

LZW_RTF_PRELOAD

public static final java.lang.String LZW_RTF_PRELOAD
See Also:
Constant Field Values
Constructor Detail

CompressedRTF

public CompressedRTF()
Method Detail

decompress

public void decompress(java.io.InputStream src,
                       java.io.OutputStream res)
                throws java.io.IOException
Decompresses the whole of the compressed RTF stream, outputting the resulting RTF bytes. Note - will decompress any padding at the end of the input, if present, use getDeCompressedSize() if you need to know how much of the result is real. (Padding may be up to 7 bytes).

Overrides:
decompress in class LZWDecompresser
Throws:
java.io.IOException

getCompressedSize

public int getCompressedSize()
Returns how big the compressed version was.

getDeCompressedSize

public int getDeCompressedSize()
Returns how big the decompressed version was.

adjustDictionaryOffset

protected int adjustDictionaryOffset(int offset)
We use regular dictionary offsets, so no need to change anything

Specified by:
adjustDictionaryOffset in class LZWDecompresser

populateDictionary

protected int populateDictionary(byte[] dict)
Description copied from class: LZWDecompresser
Populates the dictionary, and returns where in it to begin writing new codes. Generally, if the dictionary is pre-populated, then new codes should be placed at the end of that block. Equally, if the dictionary is left with all zeros, then usually the new codes can go in at the start.

Specified by:
populateDictionary in class LZWDecompresser
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HMEFMessage

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef
Class HMEFMessage

java.lang.Object
    extended by  org.apache.poi.hmef.HMEFMessage

public final class HMEFMessage
extends java.lang.Object

HMEF - Implementation of the Microsoft TNEF message encoding format (aka winmail.dat) See: http://support.microsoft.com/kb/241538 http://en.wikipedia.org/wiki/Transport_Neutral_Encapsulation_Format http://search.cpan.org/dist/Convert-TNEF/

Field Summary
static long HEADER_SIGNATURE
Constructor Summary
HMEFMessage(java.io.InputStream inp)
Method Summary
java.util.List<Attachment> | getAttachments() Returns all the Attachments of the message.
java.lang.String | getBody() Returns the Message Body, as RTF, or null if the mapi property for this isn't set
TNEFAttribute | getMessageAttribute(TNEFProperty id) Return the message attribute with the given ID, or null if there isn't one.
java.util.List<TNEFAttribute> | getMessageAttributes() Returns all HMEF/TNEF attributes of the message.
MAPIAttribute | getMessageMAPIAttribute(MAPIProperty id) Return the message MAPI Attribute with the given ID, or null if there isn't one.
java.util.List<MAPIAttribute> | getMessageMAPIAttributes() Returns all MAPI attributes of the message.
java.lang.String | getSubject() Returns the Message Subject, or null if the mapi property for this isn't set
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HEADER_SIGNATURE

public static final long HEADER_SIGNATURE
See Also:
Constant Field Values
Constructor Detail

HMEFMessage

public HMEFMessage(java.io.InputStream inp)
            throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getMessageAttributes

public java.util.List<TNEFAttribute> getMessageAttributes()
Returns all HMEF/TNEF attributes of the message. Note - In a typical message, most of the interesting properties are stored as MAPIAttributes - see getMessageMAPIAttributes()

getMessageMAPIAttributes

public java.util.List<MAPIAttribute> getMessageMAPIAttributes()
Returns all MAPI attributes of the message. Note - A small number of HMEF/TNEF specific attributes normally apply to most messages, see getMessageAttributes()

getAttachments

public java.util.List<Attachment> getAttachments()
Returns all the Attachments of the message.

getMessageAttribute

public TNEFAttribute getMessageAttribute(TNEFProperty id)
Return the message attribute with the given ID, or null if there isn't one.

getMessageMAPIAttribute

public MAPIAttribute getMessageMAPIAttribute(MAPIProperty id)
Return the message MAPI Attribute with the given ID, or null if there isn't one.

getSubject

public java.lang.String getSubject()
Returns the Message Subject, or null if the mapi property for this isn't set

getBody

public java.lang.String getBody()
Returns the Message Body, as RTF, or null if the mapi property for this isn't set

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hmef
Classes
Attachment
CompressedRTF
HMEFMessage


org.apache.poi.hmef

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hmef

Class Summary
Attachment | An attachment within a HMEFMessage.
CompressedRTF | Within a HMEFMessage, the content is often stored in as RTF, but LZW compressed.
HMEFMessage | HMEF - Implementation of the Microsoft TNEF message encoding format (aka winmail.dat) See: http://support.microsoft.com/kb/241538 http://en.wikipedia.org/wiki/Transport_Neutral_Encapsulation_Format http://search.cpan.org/dist/Convert-TNEF/


org.apache.poi.hmef Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hmef

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hmef.Attachment
    • org.apache.poi.hmef.HMEFMessage
    • org.apache.poi.util.LZWDecompresser
      • org.apache.poi.hmef.CompressedRTF


Uses of Package org.apache.poi.hmef

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hmef

Packages that use org.apache.poi.hmef
org.apache.poi.hmef
org.apache.poi.hmef.extractor

Classes in org.apache.poi.hmef used by org.apache.poi.hmef
Attachment
An attachment within a HMEFMessage.

Classes in org.apache.poi.hmef used by org.apache.poi.hmef.extractor
HMEFMessage
HMEF - Implementation of the Microsoft TNEF message encoding format (aka winmail.dat) See: http://support.microsoft.com/kb/241538 http://en.wikipedia.org/wiki/Transport_Neutral_Encapsulation_Format http://search.cpan.org/dist/Convert-TNEF/

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


MAPIAttribute

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class MAPIAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.MAPIAttribute
Direct Known Subclasses:
MAPIDateAttribute, MAPIRtfAttribute, MAPIStringAttribute
public class MAPIAttribute
extends java.lang.Object

A pure-MAPI attribute which applies to a HMEFMessage or one of its Attachments.

Constructor Summary
MAPIAttribute(MAPIProperty property, int type, byte[] data)
Constructs a single new attribute from the contents of the stream
Method Summary
static java.util.List<MAPIAttribute> | create(TNEFAttribute parent) Parses a MAPI Properties TNEF Attribute, and returns the list of MAPI Attributes contained within it
byte[] | getData()
MAPIProperty | getProperty()
int | getType()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MAPIAttribute

public MAPIAttribute(MAPIProperty property,
                     int type,
                     byte[] data)
Constructs a single new attribute from the contents of the stream

Method Detail

getProperty

public MAPIProperty getProperty()

getType

public int getType()

getData

public byte[] getData()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

create

public static java.util.List<MAPIAttribute> create(TNEFAttribute parent)
                                            throws java.io.IOException
Parses a MAPI Properties TNEF Attribute, and returns the list of MAPI Attributes contained within it

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MAPIDateAttribute

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class MAPIDateAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.MAPIAttribute
        extended by  org.apache.poi.hmef.attribute.MAPIDateAttribute

public final class MAPIDateAttribute
extends MAPIAttribute

A pure-MAPI attribute holding a Date, which applies to a HMEFMessage or one of its Attachments.

Constructor Summary
protected MAPIDateAttribute(MAPIProperty property, int type, byte[] data)
Constructs a single new date attribute from the id, type, and the contents of the stream
Method Summary
static java.util.Date | getAsDate(MAPIAttribute attr) Returns the Date of a Attribute, converting as appropriate
java.util.Date | getDate()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hmef.attribute.MAPIAttribute
create, getData, getProperty, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MAPIDateAttribute

protected MAPIDateAttribute(MAPIProperty property,
                            int type,
                            byte[] data)
Constructs a single new date attribute from the id, type, and the contents of the stream

Method Detail

getDate

public java.util.Date getDate()

toString

public java.lang.String toString()
Overrides:
toString in class MAPIAttribute

getAsDate

public static java.util.Date getAsDate(MAPIAttribute attr)
Returns the Date of a Attribute, converting as appropriate

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MAPIRtfAttribute

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class MAPIRtfAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.MAPIAttribute
        extended by  org.apache.poi.hmef.attribute.MAPIRtfAttribute

public final class MAPIRtfAttribute
extends MAPIAttribute

A pure-MAPI attribute holding RTF (compressed or not), which applies to a HMEFMessage or one of its Attachments.

Constructor Summary
MAPIRtfAttribute(MAPIProperty property, int type, byte[] data)
Method Summary
byte[] | getData() Returns the raw uncompressed RTF data
java.lang.String | getDataString() Returns the uncompressed RTF as a string
byte[] | getRawData() Returns the original, compressed RTF
java.lang.String | toString()
Methods inherited from class org.apache.poi.hmef.attribute.MAPIAttribute
create, getProperty, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MAPIRtfAttribute

public MAPIRtfAttribute(MAPIProperty property,
                        int type,
                        byte[] data)
                 throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getRawData

public byte[] getRawData()
Returns the original, compressed RTF

getData

public byte[] getData()
Returns the raw uncompressed RTF data

Overrides:
getData in class MAPIAttribute

getDataString

public java.lang.String getDataString()
Returns the uncompressed RTF as a string

toString

public java.lang.String toString()
Overrides:
toString in class MAPIAttribute
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MAPIStringAttribute

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class MAPIStringAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.MAPIAttribute
        extended by  org.apache.poi.hmef.attribute.MAPIStringAttribute

public final class MAPIStringAttribute
extends MAPIAttribute

A pure-MAPI attribute holding a String, which applies to a HMEFMessage or one of its Attachments.

Constructor Summary
MAPIStringAttribute(MAPIProperty property, int type, byte[] data)
Method Summary
static java.lang.String | getAsString(MAPIAttribute attr) Returns the string of a Attribute, converting as appropriate
java.lang.String | getDataString()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hmef.attribute.MAPIAttribute
create, getData, getProperty, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MAPIStringAttribute

public MAPIStringAttribute(MAPIProperty property,
                           int type,
                           byte[] data)
Method Detail

getDataString

public java.lang.String getDataString()

toString

public java.lang.String toString()
Overrides:
toString in class MAPIAttribute

getAsString

public static java.lang.String getAsString(MAPIAttribute attr)
Returns the string of a Attribute, converting as appropriate

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hmef.attribute
Classes
MAPIAttribute
MAPIDateAttribute
MAPIRtfAttribute
MAPIStringAttribute
TNEFAttribute
TNEFDateAttribute
TNEFMAPIAttribute
TNEFProperty
TNEFStringAttribute


org.apache.poi.hmef.attribute

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hmef.attribute

Class Summary
MAPIAttribute | A pure-MAPI attribute which applies to a HMEFMessage or one of its Attachments.
MAPIDateAttribute | A pure-MAPI attribute holding a Date, which applies to a HMEFMessage or one of its Attachments.
MAPIRtfAttribute | A pure-MAPI attribute holding RTF (compressed or not), which applies to a HMEFMessage or one of its Attachments.
MAPIStringAttribute | A pure-MAPI attribute holding a String, which applies to a HMEFMessage or one of its Attachments.
TNEFAttribute | An attribute which applies to a HMEFMessage or one of its Attachments.
TNEFDateAttribute | A Date attribute which applies to a HMEFMessage or one of its Attachments.
TNEFMAPIAttribute | A TNEF Attribute holding MAPI Attributes, which applies to a HMEFMessage or one of its Attachments.
TNEFProperty | Holds the list of TNEF Attributes, and allows lookup by friendly name, ID and MAPI Property Name.
TNEFStringAttribute | A String attribute which applies to a HMEFMessage or one of its Attachments.


org.apache.poi.hmef.attribute Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hmef.attribute

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hmef.attribute.MAPIAttribute
      • org.apache.poi.hmef.attribute.MAPIDateAttribute
      • org.apache.poi.hmef.attribute.MAPIRtfAttribute
      • org.apache.poi.hmef.attribute.MAPIStringAttribute
    • org.apache.poi.hmef.attribute.TNEFAttribute
      • org.apache.poi.hmef.attribute.TNEFDateAttribute
      • org.apache.poi.hmef.attribute.TNEFMAPIAttribute
      • org.apache.poi.hmef.attribute.TNEFStringAttribute
    • org.apache.poi.hmef.attribute.TNEFProperty


Uses of Package org.apache.poi.hmef.attribute

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hmef.attribute

Packages that use org.apache.poi.hmef.attribute
org.apache.poi.hmef
org.apache.poi.hmef.attribute

Classes in org.apache.poi.hmef.attribute used by org.apache.poi.hmef
MAPIAttribute
A pure-MAPI attribute which applies to a HMEFMessage or one of its Attachments.
TNEFAttribute
An attribute which applies to a HMEFMessage or one of its Attachments.
TNEFProperty
Holds the list of TNEF Attributes, and allows lookup by friendly name, ID and MAPI Property Name.

Classes in org.apache.poi.hmef.attribute used by org.apache.poi.hmef.attribute
MAPIAttribute
A pure-MAPI attribute which applies to a HMEFMessage or one of its Attachments.
TNEFAttribute
An attribute which applies to a HMEFMessage or one of its Attachments.
TNEFProperty
Holds the list of TNEF Attributes, and allows lookup by friendly name, ID and MAPI Property Name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


TNEFAttribute

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class TNEFAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.TNEFAttribute
Direct Known Subclasses:
TNEFDateAttribute, TNEFMAPIAttribute, TNEFStringAttribute
public class TNEFAttribute
extends java.lang.Object

An attribute which applies to a HMEFMessage or one of its Attachments. Note - the types and IDs differ from standard Outlook/MAPI ones, so we can't just re-use the HSMF ones.

Constructor Summary
protected TNEFAttribute(int id, int type, java.io.InputStream inp)
Constructs a single new attribute from the id, type, and the contents of the stream
Method Summary
static TNEFAttribute | create(java.io.InputStream inp) Creates a new TNEF Attribute by reading data from the stream within a HMEFMessage
byte[] | getData()
TNEFProperty | getProperty()
int | getType()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TNEFAttribute

protected TNEFAttribute(int id,
                        int type,
                        java.io.InputStream inp)
                 throws java.io.IOException
Constructs a single new attribute from the id, type, and the contents of the stream

Throws:
java.io.IOException
Method Detail

create

public static TNEFAttribute create(java.io.InputStream inp)
                            throws java.io.IOException
Creates a new TNEF Attribute by reading data from the stream within a HMEFMessage

Throws:
java.io.IOException

getProperty

public TNEFProperty getProperty()

getType

public int getType()

getData

public byte[] getData()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TNEFDateAttribute

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class TNEFDateAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.TNEFAttribute
        extended by  org.apache.poi.hmef.attribute.TNEFDateAttribute

public final class TNEFDateAttribute
extends TNEFAttribute

A Date attribute which applies to a HMEFMessage or one of its Attachments.

Constructor Summary
protected TNEFDateAttribute(int id, int type, java.io.InputStream inp)
Constructs a single new date attribute from the id, type, and the contents of the stream
Method Summary
static java.util.Date | getAsDate(TNEFAttribute attr) Returns the Date of a Attribute, converting as appropriate
java.util.Date | getDate()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hmef.attribute.TNEFAttribute
create, getData, getProperty, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TNEFDateAttribute

protected TNEFDateAttribute(int id,
                            int type,
                            java.io.InputStream inp)
                     throws java.io.IOException
Constructs a single new date attribute from the id, type, and the contents of the stream

Throws:
java.io.IOException
Method Detail

getDate

public java.util.Date getDate()

toString

public java.lang.String toString()
Overrides:
toString in class TNEFAttribute

getAsDate

public static java.util.Date getAsDate(TNEFAttribute attr)
Returns the Date of a Attribute, converting as appropriate

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TNEFMAPIAttribute

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class TNEFMAPIAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.TNEFAttribute
        extended by  org.apache.poi.hmef.attribute.TNEFMAPIAttribute

public final class TNEFMAPIAttribute
extends TNEFAttribute

A TNEF Attribute holding MAPI Attributes, which applies to a HMEFMessage or one of its Attachments.

Constructor Summary
protected TNEFMAPIAttribute(int id, int type, java.io.InputStream inp)
Constructs a single new mapi containing attribute from the id, type, and the contents of the stream
Method Summary
java.util.List<MAPIAttribute> | getMAPIAttributes()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hmef.attribute.TNEFAttribute
create, getData, getProperty, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TNEFMAPIAttribute

protected TNEFMAPIAttribute(int id,
                            int type,
                            java.io.InputStream inp)
                     throws java.io.IOException
Constructs a single new mapi containing attribute from the id, type, and the contents of the stream

Throws:
java.io.IOException
Method Detail

getMAPIAttributes

public java.util.List<MAPIAttribute> getMAPIAttributes()

toString

public java.lang.String toString()
Overrides:
toString in class TNEFAttribute
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TNEFProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class TNEFProperty

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.TNEFProperty

public final class TNEFProperty
extends java.lang.Object

Holds the list of TNEF Attributes, and allows lookup by friendly name, ID and MAPI Property Name. Note - the types and IDs differ from standard Outlook/MAPI ones, so we can't just re-use the HSMF ones.

Field Summary
int | id The TNEF Property ID
static TNEFProperty | ID_AIDOWNER
static TNEFProperty | ID_ATTACHCREATEDATE
static TNEFProperty | ID_ATTACHDATA
static TNEFProperty | ID_ATTACHMENT
static TNEFProperty | ID_ATTACHMETAFILE
static TNEFProperty | ID_ATTACHMODIFYDATE
static TNEFProperty | ID_ATTACHRENDERDATA
static TNEFProperty | ID_ATTACHTITLE
static TNEFProperty | ID_ATTACHTRANSPORTFILENAME
static TNEFProperty | ID_BODY
static TNEFProperty | ID_CONVERSATIONID
static TNEFProperty | ID_DATEEND
static TNEFProperty | ID_DATEMODIFIED
static TNEFProperty | ID_DATERECEIVED
static TNEFProperty | ID_DATESENT
static TNEFProperty | ID_DATESTART
static TNEFProperty | ID_DELEGATE
static TNEFProperty | ID_FROM
static TNEFProperty | ID_MAPIPROPERTIES
static TNEFProperty | ID_MESSAGECLASS
static TNEFProperty | ID_MESSAGEID
static TNEFProperty | ID_MESSAGESTATUS
static TNEFProperty | ID_NULL
static TNEFProperty | ID_OEMCODEPAGE
static TNEFProperty | ID_ORIGINALMESSAGECLASS
static TNEFProperty | ID_OWNER
static TNEFProperty | ID_PARENTID
static TNEFProperty | ID_PRIORITY
static TNEFProperty | ID_RECIPIENTTABLE
static TNEFProperty | ID_REQUESTRESPONSE
static TNEFProperty | ID_SENTFOR
static TNEFProperty | ID_SUBJECT
static TNEFProperty | ID_TNEFVERSION
static TNEFProperty | ID_UNKNOWN
static int | LEVEL_ATTACHMENT
static int | LEVEL_END_OF_FILE
static int | LEVEL_MESSAGE
java.lang.String | mapiProperty Equivalent MAPI Property
java.lang.String | name Property Name
static int | PTYPE_APPTIME AppTime - application time value
static int | PTYPE_BINARY Binary - counted byte array
static int | PTYPE_BOOLEAN Boolean - 16-bit Boolean value.
static int | PTYPE_CLASSID ClassId - OLE GUID
static int | PTYPE_CURRENCY Currency - signed 64-bit integer that represents a base ten decimal with four digits to the right of the decimal point
static int | PTYPE_DOUBLE Double - floating point double
static int | PTYPE_ERROR Error - 32-bit error value
static int | PTYPE_I2 I2 - signed 16-bit value
static int | PTYPE_I8 I8 - 8-byte signed integer
static int | PTYPE_LONG Long - signed 32-bit value
static int | PTYPE_MULTIVALUED MultiValued - Value part contains multiple values
static int | PTYPE_NULL Null - NULL property value
static int | PTYPE_OBJECT Object - embedded object in a property
static int | PTYPE_R4 R4 - 4-byte floating point value
static int | PTYPE_STRING8 String8 - null-terminated 8-bit character string
static int | PTYPE_SYSTIME SysTime - FILETIME 64-bit integer specifying the number of 100ns periods since Jan 1, 1601
static int | PTYPE_UNICODE Unicode - null-terminated Unicode string
static int | PTYPE_UNSPECIFIED Unspecified
static int | TYPE_BYTE
static int | TYPE_DATE
static int | TYPE_DWORD
static int | TYPE_LONG
static int | TYPE_MAX
static int | TYPE_SHORT
static int | TYPE_STRING
static int | TYPE_TEXT
static int | TYPE_TRIPLES
static int | TYPE_WORD
int | usualType Usual Type
Method Summary
static TNEFProperty | getBest(int id, int type)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

TYPE_TRIPLES

public static final int TYPE_TRIPLES
See Also:
Constant Field Values

TYPE_STRING

public static final int TYPE_STRING
See Also:
Constant Field Values

TYPE_TEXT

public static final int TYPE_TEXT
See Also:
Constant Field Values

TYPE_DATE

public static final int TYPE_DATE
See Also:
Constant Field Values

TYPE_SHORT

public static final int TYPE_SHORT
See Also:
Constant Field Values

TYPE_LONG

public static final int TYPE_LONG
See Also:
Constant Field Values

TYPE_BYTE

public static final int TYPE_BYTE
See Also:
Constant Field Values

TYPE_WORD

public static final int TYPE_WORD
See Also:
Constant Field Values

TYPE_DWORD

public static final int TYPE_DWORD
See Also:
Constant Field Values

TYPE_MAX

public static final int TYPE_MAX
See Also:
Constant Field Values

PTYPE_APPTIME

public static final int PTYPE_APPTIME
AppTime - application time value

See Also:
Constant Field Values

PTYPE_BINARY

public static final int PTYPE_BINARY
Binary - counted byte array

See Also:
Constant Field Values

PTYPE_BOOLEAN

public static final int PTYPE_BOOLEAN
Boolean - 16-bit Boolean value. '0' is false. Non-zero is true

See Also:
Constant Field Values

PTYPE_CLASSID

public static final int PTYPE_CLASSID
ClassId - OLE GUID

See Also:
Constant Field Values

PTYPE_CURRENCY

public static final int PTYPE_CURRENCY
Currency - signed 64-bit integer that represents a base ten decimal with four digits to the right of the decimal point

See Also:
Constant Field Values

PTYPE_DOUBLE

public static final int PTYPE_DOUBLE
Double - floating point double

See Also:
Constant Field Values

PTYPE_ERROR

public static final int PTYPE_ERROR
Error - 32-bit error value

See Also:
Constant Field Values

PTYPE_I2

public static final int PTYPE_I2
I2 - signed 16-bit value

See Also:
Constant Field Values

PTYPE_I8

public static final int PTYPE_I8
I8 - 8-byte signed integer

See Also:
Constant Field Values

PTYPE_LONG

public static final int PTYPE_LONG
Long - signed 32-bit value

See Also:
Constant Field Values

PTYPE_MULTIVALUED

public static final int PTYPE_MULTIVALUED
MultiValued - Value part contains multiple values

See Also:
Constant Field Values

PTYPE_NULL

public static final int PTYPE_NULL
Null - NULL property value

See Also:
Constant Field Values

PTYPE_OBJECT

public static final int PTYPE_OBJECT
Object - embedded object in a property

See Also:
Constant Field Values

PTYPE_R4

public static final int PTYPE_R4
R4 - 4-byte floating point value

See Also:
Constant Field Values

PTYPE_STRING8

public static final int PTYPE_STRING8
String8 - null-terminated 8-bit character string

See Also:
Constant Field Values

PTYPE_SYSTIME

public static final int PTYPE_SYSTIME
SysTime - FILETIME 64-bit integer specifying the number of 100ns periods since Jan 1, 1601

See Also:
Constant Field Values

PTYPE_UNICODE

public static final int PTYPE_UNICODE
Unicode - null-terminated Unicode string

See Also:
Constant Field Values

PTYPE_UNSPECIFIED

public static final int PTYPE_UNSPECIFIED
Unspecified

See Also:
Constant Field Values

LEVEL_MESSAGE

public static final int LEVEL_MESSAGE
See Also:
Constant Field Values

LEVEL_ATTACHMENT

public static final int LEVEL_ATTACHMENT
See Also:
Constant Field Values

LEVEL_END_OF_FILE

public static final int LEVEL_END_OF_FILE
See Also:
Constant Field Values

ID_AIDOWNER

public static final TNEFProperty ID_AIDOWNER

ID_ATTACHCREATEDATE

public static final TNEFProperty ID_ATTACHCREATEDATE

ID_ATTACHDATA

public static final TNEFProperty ID_ATTACHDATA

ID_ATTACHMENT

public static final TNEFProperty ID_ATTACHMENT

ID_ATTACHMETAFILE

public static final TNEFProperty ID_ATTACHMETAFILE

ID_ATTACHMODIFYDATE

public static final TNEFProperty ID_ATTACHMODIFYDATE

ID_ATTACHRENDERDATA

public static final TNEFProperty ID_ATTACHRENDERDATA

ID_ATTACHTITLE

public static final TNEFProperty ID_ATTACHTITLE

ID_ATTACHTRANSPORTFILENAME

public static final TNEFProperty ID_ATTACHTRANSPORTFILENAME

ID_BODY

public static final TNEFProperty ID_BODY

ID_CONVERSATIONID

public static final TNEFProperty ID_CONVERSATIONID

ID_DATEEND

public static final TNEFProperty ID_DATEEND

ID_DATEMODIFIED

public static final TNEFProperty ID_DATEMODIFIED

ID_DATERECEIVED

public static final TNEFProperty ID_DATERECEIVED

ID_DATESENT

public static final TNEFProperty ID_DATESENT

ID_DATESTART

public static final TNEFProperty ID_DATESTART

ID_DELEGATE

public static final TNEFProperty ID_DELEGATE

ID_FROM

public static final TNEFProperty ID_FROM

ID_MAPIPROPERTIES

public static final TNEFProperty ID_MAPIPROPERTIES

ID_MESSAGECLASS

public static final TNEFProperty ID_MESSAGECLASS

ID_MESSAGEID

public static final TNEFProperty ID_MESSAGEID

ID_MESSAGESTATUS

public static final TNEFProperty ID_MESSAGESTATUS

ID_NULL

public static final TNEFProperty ID_NULL

ID_OEMCODEPAGE

public static final TNEFProperty ID_OEMCODEPAGE

ID_ORIGINALMESSAGECLASS

public static final TNEFProperty ID_ORIGINALMESSAGECLASS

ID_OWNER

public static final TNEFProperty ID_OWNER

ID_PARENTID

public static final TNEFProperty ID_PARENTID

ID_PRIORITY

public static final TNEFProperty ID_PRIORITY

ID_RECIPIENTTABLE

public static final TNEFProperty ID_RECIPIENTTABLE

ID_REQUESTRESPONSE

public static final TNEFProperty ID_REQUESTRESPONSE

ID_SENTFOR

public static final TNEFProperty ID_SENTFOR

ID_SUBJECT

public static final TNEFProperty ID_SUBJECT

ID_TNEFVERSION

public static final TNEFProperty ID_TNEFVERSION

ID_UNKNOWN

public static final TNEFProperty ID_UNKNOWN

id

public final int id
The TNEF Property ID

usualType

public final int usualType
Usual Type

name

public final java.lang.String name
Property Name

mapiProperty

public final java.lang.String mapiProperty
Equivalent MAPI Property

Method Detail

getBest

public static TNEFProperty getBest(int id,
                                   int type)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TNEFStringAttribute

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.attribute
Class TNEFStringAttribute

java.lang.Object
    extended by  org.apache.poi.hmef.attribute.TNEFAttribute
        extended by  org.apache.poi.hmef.attribute.TNEFStringAttribute

public final class TNEFStringAttribute
extends TNEFAttribute

A String attribute which applies to a HMEFMessage or one of its Attachments.

Constructor Summary
protected TNEFStringAttribute(int id, int type, java.io.InputStream inp)
Constructs a single new string attribute from the id, type, and the contents of the stream
Method Summary
static java.lang.String | getAsString(TNEFAttribute attr) Returns the string of a Attribute, converting as appropriate
java.lang.String | getString()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hmef.attribute.TNEFAttribute
create, getData, getProperty, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TNEFStringAttribute

protected TNEFStringAttribute(int id,
                              int type,
                              java.io.InputStream inp)
                       throws java.io.IOException
Constructs a single new string attribute from the id, type, and the contents of the stream

Throws:
java.io.IOException
Method Detail

getString

public java.lang.String getString()

toString

public java.lang.String toString()
Overrides:
toString in class TNEFAttribute

getAsString

public static java.lang.String getAsString(TNEFAttribute attr)
Returns the string of a Attribute, converting as appropriate

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hmef.attribute.MAPIAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.MAPIAttribute

Packages that use MAPIAttribute
org.apache.poi.hmef
org.apache.poi.hmef.attribute

Uses of MAPIAttribute in org.apache.poi.hmef

Methods in org.apache.poi.hmef that return MAPIAttribute
MAPIAttribute | Attachment.getMAPIAttribute(MAPIProperty id) Return the attachment MAPI Attribute with the given ID, or null if there isn't one.
MAPIAttribute | HMEFMessage.getMessageMAPIAttribute(MAPIProperty id) Return the message MAPI Attribute with the given ID, or null if there isn't one.

Methods in org.apache.poi.hmef that return types with arguments of type MAPIAttribute
java.util.List<MAPIAttribute> | Attachment.getMAPIAttributes() Returns all MAPI attributes of the attachment, such as extension, encoding, size and position
java.util.List<MAPIAttribute> | HMEFMessage.getMessageMAPIAttributes() Returns all MAPI attributes of the message.

Uses of MAPIAttribute in org.apache.poi.hmef.attribute

Subclasses of MAPIAttribute in org.apache.poi.hmef.attribute
class | MAPIDateAttribute A pure-MAPI attribute holding a Date, which applies to a HMEFMessage or one of its Attachments.
class | MAPIRtfAttribute A pure-MAPI attribute holding RTF (compressed or not), which applies to a HMEFMessage or one of its Attachments.
class | MAPIStringAttribute A pure-MAPI attribute holding a String, which applies to a HMEFMessage or one of its Attachments.

Methods in org.apache.poi.hmef.attribute that return types with arguments of type MAPIAttribute
static java.util.List<MAPIAttribute> | MAPIAttribute.create(TNEFAttribute parent) Parses a MAPI Properties TNEF Attribute, and returns the list of MAPI Attributes contained within it
java.util.List<MAPIAttribute> | TNEFMAPIAttribute.getMAPIAttributes()

Methods in org.apache.poi.hmef.attribute with parameters of type MAPIAttribute
static java.util.Date | MAPIDateAttribute.getAsDate(MAPIAttribute attr) Returns the Date of a Attribute, converting as appropriate
static java.lang.String | MAPIStringAttribute.getAsString(MAPIAttribute attr) Returns the string of a Attribute, converting as appropriate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.MAPIDateAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.MAPIDateAttribute

No usage of org.apache.poi.hmef.attribute.MAPIDateAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.MAPIRtfAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.MAPIRtfAttribute

No usage of org.apache.poi.hmef.attribute.MAPIRtfAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.MAPIStringAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.MAPIStringAttribute

No usage of org.apache.poi.hmef.attribute.MAPIStringAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.TNEFAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.TNEFAttribute

Packages that use TNEFAttribute
org.apache.poi.hmef
org.apache.poi.hmef.attribute

Uses of TNEFAttribute in org.apache.poi.hmef

Methods in org.apache.poi.hmef that return TNEFAttribute
TNEFAttribute | Attachment.getAttribute(TNEFProperty id) Return the attachment attribute with the given ID, or null if there isn't one.
TNEFAttribute | HMEFMessage.getMessageAttribute(TNEFProperty id) Return the message attribute with the given ID, or null if there isn't one.

Methods in org.apache.poi.hmef that return types with arguments of type TNEFAttribute
java.util.List<TNEFAttribute> | Attachment.getAttributes() Returns all HMEF/TNEF attributes of the attachment, such as filename, icon and contents
java.util.List<TNEFAttribute> | HMEFMessage.getMessageAttributes() Returns all HMEF/TNEF attributes of the message.

Methods in org.apache.poi.hmef with parameters of type TNEFAttribute
protected  void Attachment.addAttribute(TNEFAttribute attr)

Uses of TNEFAttribute in org.apache.poi.hmef.attribute

Subclasses of TNEFAttribute in org.apache.poi.hmef.attribute
class | TNEFDateAttribute A Date attribute which applies to a HMEFMessage or one of its Attachments.
class | TNEFMAPIAttribute A TNEF Attribute holding MAPI Attributes, which applies to a HMEFMessage or one of its Attachments.
class | TNEFStringAttribute A String attribute which applies to a HMEFMessage or one of its Attachments.

Methods in org.apache.poi.hmef.attribute that return TNEFAttribute
static TNEFAttribute TNEFAttribute.create(java.io.InputStream inp)
Creates a new TNEF Attribute by reading data from the stream within a HMEFMessage

Methods in org.apache.poi.hmef.attribute with parameters of type TNEFAttribute
static java.util.List<MAPIAttribute> | MAPIAttribute.create(TNEFAttribute parent) Parses a MAPI Properties TNEF Attribute, and returns the list of MAPI Attributes contained within it
static java.util.Date | TNEFDateAttribute.getAsDate(TNEFAttribute attr) Returns the Date of a Attribute, converting as appropriate
static java.lang.String | TNEFStringAttribute.getAsString(TNEFAttribute attr) Returns the string of a Attribute, converting as appropriate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.TNEFDateAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.TNEFDateAttribute

No usage of org.apache.poi.hmef.attribute.TNEFDateAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.TNEFMAPIAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.TNEFMAPIAttribute

No usage of org.apache.poi.hmef.attribute.TNEFMAPIAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.TNEFProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.TNEFProperty

Packages that use TNEFProperty
org.apache.poi.hmef
org.apache.poi.hmef.attribute

Uses of TNEFProperty in org.apache.poi.hmef

Methods in org.apache.poi.hmef with parameters of type TNEFProperty
TNEFAttribute | Attachment.getAttribute(TNEFProperty id) Return the attachment attribute with the given ID, or null if there isn't one.
TNEFAttribute | HMEFMessage.getMessageAttribute(TNEFProperty id) Return the message attribute with the given ID, or null if there isn't one.

Uses of TNEFProperty in org.apache.poi.hmef.attribute

Fields in org.apache.poi.hmef.attribute declared as TNEFProperty
static TNEFProperty | TNEFProperty.ID_AIDOWNER
static TNEFProperty | TNEFProperty.ID_ATTACHCREATEDATE
static TNEFProperty | TNEFProperty.ID_ATTACHDATA
static TNEFProperty | TNEFProperty.ID_ATTACHMENT
static TNEFProperty | TNEFProperty.ID_ATTACHMETAFILE
static TNEFProperty | TNEFProperty.ID_ATTACHMODIFYDATE
static TNEFProperty | TNEFProperty.ID_ATTACHRENDERDATA
static TNEFProperty | TNEFProperty.ID_ATTACHTITLE
static TNEFProperty | TNEFProperty.ID_ATTACHTRANSPORTFILENAME
static TNEFProperty | TNEFProperty.ID_BODY
static TNEFProperty | TNEFProperty.ID_CONVERSATIONID
static TNEFProperty | TNEFProperty.ID_DATEEND
static TNEFProperty | TNEFProperty.ID_DATEMODIFIED
static TNEFProperty | TNEFProperty.ID_DATERECEIVED
static TNEFProperty | TNEFProperty.ID_DATESENT
static TNEFProperty | TNEFProperty.ID_DATESTART
static TNEFProperty | TNEFProperty.ID_DELEGATE
static TNEFProperty | TNEFProperty.ID_FROM
static TNEFProperty | TNEFProperty.ID_MAPIPROPERTIES
static TNEFProperty | TNEFProperty.ID_MESSAGECLASS
static TNEFProperty | TNEFProperty.ID_MESSAGEID
static TNEFProperty | TNEFProperty.ID_MESSAGESTATUS
static TNEFProperty | TNEFProperty.ID_NULL
static TNEFProperty | TNEFProperty.ID_OEMCODEPAGE
static TNEFProperty | TNEFProperty.ID_ORIGINALMESSAGECLASS
static TNEFProperty | TNEFProperty.ID_OWNER
static TNEFProperty | TNEFProperty.ID_PARENTID
static TNEFProperty | TNEFProperty.ID_PRIORITY
static TNEFProperty | TNEFProperty.ID_RECIPIENTTABLE
static TNEFProperty | TNEFProperty.ID_REQUESTRESPONSE
static TNEFProperty | TNEFProperty.ID_SENTFOR
static TNEFProperty | TNEFProperty.ID_SUBJECT
static TNEFProperty | TNEFProperty.ID_TNEFVERSION
static TNEFProperty | TNEFProperty.ID_UNKNOWN

Methods in org.apache.poi.hmef.attribute that return TNEFProperty
static TNEFProperty | TNEFProperty.getBest(int id, int type)
TNEFProperty | TNEFAttribute.getProperty()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.attribute.TNEFStringAttribute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.attribute.TNEFStringAttribute

No usage of org.apache.poi.hmef.attribute.TNEFStringAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.Attachment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.Attachment

Packages that use Attachment
org.apache.poi.hmef

Uses of Attachment in org.apache.poi.hmef

Methods in org.apache.poi.hmef that return types with arguments of type Attachment
 java.util.List<Attachment> HMEFMessage.getAttachments()
Returns all the Attachments of the message.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.CompressedRTF

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.CompressedRTF

No usage of org.apache.poi.hmef.CompressedRTF

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.HMEFMessage

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.HMEFMessage

Packages that use HMEFMessage
org.apache.poi.hmef.extractor

Uses of HMEFMessage in org.apache.poi.hmef.extractor

Constructors in org.apache.poi.hmef.extractor with parameters of type HMEFMessage
HMEFContentsExtractor(HMEFMessage message)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HMEFDumper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.dev
Class HMEFDumper

java.lang.Object
    extended by  org.apache.poi.hmef.dev.HMEFDumper

public final class HMEFDumper
extends java.lang.Object

Developer focused raw dumper

Constructor Summary
HMEFDumper(java.io.InputStream inp)
Method Summary
static void | main(java.lang.String[] args)
void | setTruncatePropertyData(boolean truncate)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HMEFDumper

public HMEFDumper(java.io.InputStream inp)
           throws java.io.IOException
Throws:
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

setTruncatePropertyData

public void setTruncatePropertyData(boolean truncate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hmef.dev
Classes
HMEFDumper


org.apache.poi.hmef.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hmef.dev

Class Summary
HMEFDumper Developer focused raw dumper


org.apache.poi.hmef.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hmef.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hmef.dev.HMEFDumper


Uses of Package org.apache.poi.hmef.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hmef.dev

No usage of org.apache.poi.hmef.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.dev.HMEFDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.dev.HMEFDumper

No usage of org.apache.poi.hmef.dev.HMEFDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HMEFContentsExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hmef.extractor
Class HMEFContentsExtractor

java.lang.Object
    extended by  org.apache.poi.hmef.extractor.HMEFContentsExtractor

public final class HMEFContentsExtractor
extends java.lang.Object

A utility for extracting out the message body, and all attachments from a HMEF/TNEF/winmail.dat file

Constructor Summary
HMEFContentsExtractor(java.io.File filename)
HMEFContentsExtractor(HMEFMessage message)
Method Summary
void | extractAttachments(java.io.File dir) Extracts all the message attachments to the supplied directory
void | extractMessageBody(java.io.File dest) Extracts the RTF message body to the supplied file
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HMEFContentsExtractor

public HMEFContentsExtractor(java.io.File filename)
                      throws java.io.IOException
Throws:
java.io.IOException

HMEFContentsExtractor

public HMEFContentsExtractor(HMEFMessage message)
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

extractMessageBody

public void extractMessageBody(java.io.File dest)
                        throws java.io.IOException
Extracts the RTF message body to the supplied file

Throws:
java.io.IOException

extractAttachments

public void extractAttachments(java.io.File dir)
                        throws java.io.IOException
Extracts all the message attachments to the supplied directory

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hmef.extractor
Classes
HMEFContentsExtractor


org.apache.poi.hmef.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hmef.extractor

Class Summary
HMEFContentsExtractor A utility for extracting out the message body, and all attachments from a HMEF/TNEF/winmail.dat file


org.apache.poi.hmef.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hmef.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hmef.extractor.HMEFContentsExtractor


Uses of Package org.apache.poi.hmef.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hmef.extractor

No usage of org.apache.poi.hmef.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hmef.extractor.HMEFContentsExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hmef.extractor.HMEFContentsExtractor

No usage of org.apache.poi.hmef.extractor.HMEFContentsExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HPBFDocument

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf
Class HPBFDocument

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hpbf.HPBFDocument

public final class HPBFDocument
extends POIDocument

This class provides the basic functionality for HPBF, our implementation of the publisher file format.

Field Summary
Fields inherited from class org.apache.poi.POIDocument
directory
Constructor Summary
HPBFDocument(DirectoryNode dir)
Opens an embedded publisher document, at the given directory.
HPBFDocument(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use HPBFDocument(DirectoryNode) instead
HPBFDocument(java.io.InputStream inp)
HPBFDocument(NPOIFSFileSystem fs)
HPBFDocument(POIFSFileSystem fs)
Opens a new publisher document
Method Summary
EscherDelayStm | getEscherDelayStm()
EscherStm | getEscherStm()
MainContents | getMainContents()
QuillContents | getQuillContents()
void | write(java.io.OutputStream out) Writes the document out to the specified output stream
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HPBFDocument

public HPBFDocument(POIFSFileSystem fs)
             throws java.io.IOException
Opens a new publisher document

Throws:
java.io.IOException

HPBFDocument

public HPBFDocument(NPOIFSFileSystem fs)
             throws java.io.IOException
Throws:
java.io.IOException

HPBFDocument

public HPBFDocument(java.io.InputStream inp)
             throws java.io.IOException
Throws:
java.io.IOException

HPBFDocument

@Deprecated
public HPBFDocument(DirectoryNode dir,
                               POIFSFileSystem fs)
             throws java.io.IOException
Deprecated. Use HPBFDocument(DirectoryNode) instead

Opens an embedded publisher document, at the given directory.

Throws:
java.io.IOException

HPBFDocument

public HPBFDocument(DirectoryNode dir)
             throws java.io.IOException
Opens an embedded publisher document, at the given directory.

Throws:
java.io.IOException
Method Detail

getMainContents

public MainContents getMainContents()

getQuillContents

public QuillContents getQuillContents()

getEscherStm

public EscherStm getEscherStm()

getEscherDelayStm

public EscherDelayStm getEscherDelayStm()

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Description copied from class: POIDocument
Writes the document out to the specified output stream

Specified by:
write in class POIDocument
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hpbf
Classes
HPBFDocument


org.apache.poi.hpbf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpbf

Class Summary
HPBFDocument This class provides the basic functionality for HPBF, our implementation of the publisher file format.


org.apache.poi.hpbf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpbf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POIDocument
      • org.apache.poi.hpbf.HPBFDocument


Uses of Package org.apache.poi.hpbf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpbf

Packages that use org.apache.poi.hpbf
org.apache.poi.hpbf.dev
org.apache.poi.hpbf.extractor

Classes in org.apache.poi.hpbf used by org.apache.poi.hpbf.dev
HPBFDocument
This class provides the basic functionality for HPBF, our implementation of the publisher file format.

Classes in org.apache.poi.hpbf used by org.apache.poi.hpbf.extractor
HPBFDocument
This class provides the basic functionality for HPBF, our implementation of the publisher file format.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.HPBFDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.HPBFDocument

Packages that use HPBFDocument
org.apache.poi.hpbf.dev
org.apache.poi.hpbf.extractor

Uses of HPBFDocument in org.apache.poi.hpbf.dev

Constructors in org.apache.poi.hpbf.dev with parameters of type HPBFDocument
PLCDumper(HPBFDocument hpbfDoc)

Uses of HPBFDocument in org.apache.poi.hpbf.extractor

Constructors in org.apache.poi.hpbf.extractor with parameters of type HPBFDocument
PublisherTextExtractor(HPBFDocument doc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HPBFDumper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.dev
Class HPBFDumper

java.lang.Object
    extended by  org.apache.poi.hpbf.dev.HPBFDumper

public final class HPBFDumper
extends java.lang.Object

For dumping out the contents of HPBF (Publisher) files, while we try to figure out how they're constructed.

Constructor Summary
HPBFDumper(java.io.InputStream inp)
HPBFDumper(POIFSFileSystem fs)
Method Summary
protected void | dump001CompObj(DirectoryNode dir)
void | dumpContents()
void | dumpCONTENTSguessed(DirectoryNode dir)
void | dumpCONTENTSraw(DirectoryNode dir)
void | dumpEnvelope()
void | dumpEscher() Dump out the escher parts of the file.
protected void | dumpEscherDelayStm(DirectoryNode escherDir)
protected void | dumpEscherStm(DirectoryNode escherDir)
void | dumpQuill()
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HPBFDumper

public HPBFDumper(POIFSFileSystem fs)

HPBFDumper

public HPBFDumper(java.io.InputStream inp)
           throws java.io.IOException
Throws:
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

dumpEscher

public void dumpEscher()
                throws java.io.IOException
Dump out the escher parts of the file. Escher -> EscherStm and EscherDelayStm

Throws:
java.io.IOException

dumpEscherStm

protected void dumpEscherStm(DirectoryNode escherDir)
                      throws java.io.IOException
Throws:
java.io.IOException

dumpEscherDelayStm

protected void dumpEscherDelayStm(DirectoryNode escherDir)
                           throws java.io.IOException
Throws:
java.io.IOException

dumpEnvelope

public void dumpEnvelope()
                  throws java.io.IOException
Throws:
java.io.IOException

dumpContents

public void dumpContents()
                  throws java.io.IOException
Throws:
java.io.IOException

dumpCONTENTSraw

public void dumpCONTENTSraw(DirectoryNode dir)
                     throws java.io.IOException
Throws:
java.io.IOException

dumpCONTENTSguessed

public void dumpCONTENTSguessed(DirectoryNode dir)
                         throws java.io.IOException
Throws:
java.io.IOException

dump001CompObj

protected void dump001CompObj(DirectoryNode dir)

dumpQuill

public void dumpQuill()
               throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hpbf.dev
Classes
HPBFDumper
PLCDumper


org.apache.poi.hpbf.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpbf.dev

Class Summary
HPBFDumper | For dumping out the contents of HPBF (Publisher) files, while we try to figure out how they're constructed.
PLCDumper | For dumping out the PLC contents of QC Bits of a HPBF (Publisher) file, while we try to figure out what the format of them is.


org.apache.poi.hpbf.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpbf.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hpbf.dev.HPBFDumper
    • org.apache.poi.hpbf.dev.PLCDumper


Uses of Package org.apache.poi.hpbf.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpbf.dev

No usage of org.apache.poi.hpbf.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PLCDumper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.dev
Class PLCDumper

java.lang.Object
    extended by  org.apache.poi.hpbf.dev.PLCDumper

public final class PLCDumper
extends java.lang.Object

For dumping out the PLC contents of QC Bits of a HPBF (Publisher) file, while we try to figure out what the format of them is.

Constructor Summary
PLCDumper(HPBFDocument hpbfDoc)
PLCDumper(java.io.InputStream inp)
PLCDumper(POIFSFileSystem fs)
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PLCDumper

public PLCDumper(HPBFDocument hpbfDoc)

PLCDumper

public PLCDumper(POIFSFileSystem fs)
          throws java.io.IOException
Throws:
java.io.IOException

PLCDumper

public PLCDumper(java.io.InputStream inp)
          throws java.io.IOException
Throws:
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hpbf.dev.HPBFDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.dev.HPBFDumper

No usage of org.apache.poi.hpbf.dev.HPBFDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.dev.PLCDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.dev.PLCDumper

No usage of org.apache.poi.hpbf.dev.PLCDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hpbf.extractor
Classes
PublisherTextExtractor


org.apache.poi.hpbf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpbf.extractor

Class Summary
PublisherTextExtractor Extract text from HPBF Publisher files


org.apache.poi.hpbf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpbf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIOLE2TextExtractor
        • org.apache.poi.hpbf.extractor.PublisherTextExtractor


Uses of Package org.apache.poi.hpbf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpbf.extractor

No usage of org.apache.poi.hpbf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PublisherTextExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.extractor
Class PublisherTextExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hpbf.extractor.PublisherTextExtractor

public final class PublisherTextExtractor
extends POIOLE2TextExtractor

Extract text from HPBF Publisher files

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
PublisherTextExtractor(DirectoryNode dir)
PublisherTextExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated.
PublisherTextExtractor(HPBFDocument doc)
PublisherTextExtractor(java.io.InputStream is)
PublisherTextExtractor(NPOIFSFileSystem fs)
PublisherTextExtractor(POIFSFileSystem fs)
Method Summary
java.lang.String | getText() Retrieves all the text from the document.
static void | main(java.lang.String[] args)
void | setHyperlinksByDefault(boolean hyperlinksByDefault) Should a call to getText() return hyperlinks inline with the text? Default is no
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getDocSummaryInformation, getFileSystem, getMetadataTextExtractor, getRoot, getSummaryInformation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PublisherTextExtractor

public PublisherTextExtractor(HPBFDocument doc)

PublisherTextExtractor

public PublisherTextExtractor(DirectoryNode dir)
                       throws java.io.IOException
Throws:
java.io.IOException

PublisherTextExtractor

public PublisherTextExtractor(POIFSFileSystem fs)
                       throws java.io.IOException
Throws:
java.io.IOException

PublisherTextExtractor

public PublisherTextExtractor(NPOIFSFileSystem fs)
                       throws java.io.IOException
Throws:
java.io.IOException

PublisherTextExtractor

public PublisherTextExtractor(java.io.InputStream is)
                       throws java.io.IOException
Throws:
java.io.IOException

PublisherTextExtractor

@Deprecated
public PublisherTextExtractor(DirectoryNode dir,
                                         POIFSFileSystem fs)
                       throws java.io.IOException
Deprecated.

Throws:
java.io.IOException
Method Detail

setHyperlinksByDefault

public void setHyperlinksByDefault(boolean hyperlinksByDefault)
Should a call to getText() return hyperlinks inline with the text? Default is no

getText

public java.lang.String getText()
Description copied from class: POITextExtractor
Retrieves all the text from the document. How cells, paragraphs etc are separated in the text is implementation specific - see the javadocs for a specific project for details.

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hpbf.extractor.PublisherTextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.extractor.PublisherTextExtractor

No usage of org.apache.poi.hpbf.extractor.PublisherTextExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


EscherDelayStm

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model
Class EscherDelayStm

java.lang.Object
    extended by  org.apache.poi.hpbf.model.HPBFPart
        extended by  org.apache.poi.hpbf.model.EscherPart
            extended by  org.apache.poi.hpbf.model.EscherDelayStm

public final class EscherDelayStm
extends EscherPart

Field Summary
Fields inherited from class org.apache.poi.hpbf.model.HPBFPart
data
Constructor Summary
EscherDelayStm(DirectoryNode baseDir)
Method Summary
Methods inherited from class org.apache.poi.hpbf.model.EscherPart
generateData, getEscherRecords
Methods inherited from class org.apache.poi.hpbf.model.HPBFPart
getData, getPath, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherDelayStm

public EscherDelayStm(DirectoryNode baseDir)
               throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EscherPart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model
Class EscherPart

java.lang.Object
    extended by  org.apache.poi.hpbf.model.HPBFPart
        extended by  org.apache.poi.hpbf.model.EscherPart
Direct Known Subclasses:
EscherDelayStm, EscherStm
public abstract class EscherPart
extends HPBFPart

Parent class of all Escher parts

Field Summary
Fields inherited from class org.apache.poi.hpbf.model.HPBFPart
data
Constructor Summary
EscherPart(DirectoryNode baseDir, java.lang.String[] parts)
Creates the Escher Part, and finds our child escher records
Method Summary
protected void | generateData() Serialises our Escher children back into bytes.
EscherRecord[] | getEscherRecords()
Methods inherited from class org.apache.poi.hpbf.model.HPBFPart
getData, getPath, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherPart

public EscherPart(DirectoryNode baseDir,
                  java.lang.String[] parts)
           throws java.io.IOException
Creates the Escher Part, and finds our child escher records

Throws:
java.io.IOException
Method Detail

getEscherRecords

public EscherRecord[] getEscherRecords()

generateData

protected void generateData()
Serialises our Escher children back into bytes.

Specified by:
generateData in class HPBFPart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherStm

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model
Class EscherStm

java.lang.Object
    extended by  org.apache.poi.hpbf.model.HPBFPart
        extended by  org.apache.poi.hpbf.model.EscherPart
            extended by  org.apache.poi.hpbf.model.EscherStm

public final class EscherStm
extends EscherPart

Field Summary
Fields inherited from class org.apache.poi.hpbf.model.HPBFPart
data
Constructor Summary
EscherStm(DirectoryNode baseDir)
Method Summary
Methods inherited from class org.apache.poi.hpbf.model.EscherPart
generateData, getEscherRecords
Methods inherited from class org.apache.poi.hpbf.model.HPBFPart
getData, getPath, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherStm

public EscherStm(DirectoryNode baseDir)
          throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HPBFPart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model
Class HPBFPart

java.lang.Object
    extended by  org.apache.poi.hpbf.model.HPBFPart
Direct Known Subclasses:
EscherPart, MainContents, QuillContents
public abstract class HPBFPart
extends java.lang.Object

Parent class of all HPBF sub-parts, handling the fiddly reading in / writing out bits for all of them.

Field Summary
protected  byte[] data
Constructor Summary
HPBFPart(DirectoryNode baseDir, java.lang.String[] path)
Method Summary
protected abstract void | generateData() Called just before writing out, to trigger the data byte array to be updated with the latest contents.
byte[] | getData() Returns the raw data that makes up this document part.
java.lang.String[] | getPath() Returns
void | writeOut(DirectoryNode baseDir)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

data

protected byte[] data
Constructor Detail

HPBFPart

public HPBFPart(DirectoryNode baseDir,
                java.lang.String[] path)
         throws java.io.IOException
Parameters:
path - the path to the part, eg Contents or Quill, QuillSub, CONTENTS
Throws:
java.io.IOException
Method Detail

writeOut

public void writeOut(DirectoryNode baseDir)
              throws java.io.IOException
Throws:
java.io.IOException

generateData

protected abstract void generateData()
Called just before writing out, to trigger the data byte array to be updated with the latest contents.

getData

public byte[] getData()
Returns the raw data that makes up this document part.

getPath

public final java.lang.String[] getPath()
Returns

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MainContents

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model
Class MainContents

java.lang.Object
    extended by  org.apache.poi.hpbf.model.HPBFPart
        extended by  org.apache.poi.hpbf.model.MainContents

public final class MainContents
extends HPBFPart

The main Contents. Not yet understood

Field Summary
Fields inherited from class org.apache.poi.hpbf.model.HPBFPart
data
Constructor Summary
MainContents(DirectoryNode baseDir)
Method Summary
protected  void generateData()
Called just before writing out, to trigger the data byte array to be updated with the latest contents.
Methods inherited from class org.apache.poi.hpbf.model.HPBFPart
getData, getPath, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MainContents

public MainContents(DirectoryNode baseDir)
             throws java.io.IOException
Throws:
java.io.IOException
Method Detail

generateData

protected void generateData()
Description copied from class: HPBFPart
Called just before writing out, to trigger the data byte array to be updated with the latest contents.

Specified by:
generateData in class HPBFPart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hpbf.model
Classes
EscherDelayStm
EscherPart
EscherStm
HPBFPart
MainContents
QuillContents


org.apache.poi.hpbf.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpbf.model

Class Summary
EscherDelayStm |
EscherPart | Parent class of all Escher parts
EscherStm |
HPBFPart | Parent class of all HPBF sub-parts, handling the fiddly reading in / writing out bits for all of them.
MainContents | The main Contents.
QuillContents | Quill -> QuillSub -> CONTENTS


org.apache.poi.hpbf.model Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpbf.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hpbf.model.HPBFPart
      • org.apache.poi.hpbf.model.EscherPart
        • org.apache.poi.hpbf.model.EscherDelayStm
        • org.apache.poi.hpbf.model.EscherStm
      • org.apache.poi.hpbf.model.MainContents
      • org.apache.poi.hpbf.model.QuillContents


Uses of Package org.apache.poi.hpbf.model

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpbf.model

Packages that use org.apache.poi.hpbf.model
org.apache.poi.hpbf
org.apache.poi.hpbf.model

Classes in org.apache.poi.hpbf.model used by org.apache.poi.hpbf
EscherDelayStm
EscherStm
MainContents
The main Contents.
QuillContents
Quill -> QuillSub -> CONTENTS

Classes in org.apache.poi.hpbf.model used by org.apache.poi.hpbf.model
EscherPart
Parent class of all Escher parts
HPBFPart
Parent class of all HPBF sub-parts, handling the fiddly reading in / writing out bits for all of them.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


QuillContents

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model
Class QuillContents

java.lang.Object
    extended by  org.apache.poi.hpbf.model.HPBFPart
        extended by  org.apache.poi.hpbf.model.QuillContents

public final class QuillContents
extends HPBFPart

Quill -> QuillSub -> CONTENTS

Field Summary
Fields inherited from class org.apache.poi.hpbf.model.HPBFPart
data
Constructor Summary
QuillContents(DirectoryNode baseDir)
Method Summary
protected void | generateData() Called just before writing out, to trigger the data byte array to be updated with the latest contents.
QCBit[] | getBits()
Methods inherited from class org.apache.poi.hpbf.model.HPBFPart
getData, getPath, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QuillContents

public QuillContents(DirectoryNode baseDir)
              throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getBits

public QCBit[] getBits()

generateData

protected void generateData()
Description copied from class: HPBFPart
Called just before writing out, to trigger the data byte array to be updated with the latest contents.

Specified by:
generateData in class HPBFPart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hpbf.model.EscherDelayStm

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.EscherDelayStm

Packages that use EscherDelayStm
org.apache.poi.hpbf

Uses of EscherDelayStm in org.apache.poi.hpbf

Methods in org.apache.poi.hpbf that return EscherDelayStm
 EscherDelayStm HPBFDocument.getEscherDelayStm()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.EscherPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.EscherPart

Packages that use EscherPart
org.apache.poi.hpbf.model

Uses of EscherPart in org.apache.poi.hpbf.model

Subclasses of EscherPart in org.apache.poi.hpbf.model
class | EscherDelayStm
class | EscherStm

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.EscherStm

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.EscherStm

Packages that use EscherStm
org.apache.poi.hpbf

Uses of EscherStm in org.apache.poi.hpbf

Methods in org.apache.poi.hpbf that return EscherStm
 EscherStm HPBFDocument.getEscherStm()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.HPBFPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.HPBFPart

Packages that use HPBFPart
org.apache.poi.hpbf.model

Uses of HPBFPart in org.apache.poi.hpbf.model

Subclasses of HPBFPart in org.apache.poi.hpbf.model
class | EscherDelayStm
class | EscherPart Parent class of all Escher parts
class | EscherStm
class | MainContents The main Contents.
class | QuillContents Quill -> QuillSub -> CONTENTS

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.MainContents

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.MainContents

Packages that use MainContents
org.apache.poi.hpbf

Uses of MainContents in org.apache.poi.hpbf

Methods in org.apache.poi.hpbf that return MainContents
 MainContents HPBFDocument.getMainContents()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.QuillContents

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.QuillContents

Packages that use QuillContents
org.apache.poi.hpbf

Uses of QuillContents in org.apache.poi.hpbf

Methods in org.apache.poi.hpbf that return QuillContents
 QuillContents HPBFDocument.getQuillContents()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hpbf.model.qcbits
Classes
QCBit
QCPLCBit
QCPLCBit.Type0
QCPLCBit.Type12
QCPLCBit.Type4
QCPLCBit.Type8
QCTextBit
UnknownQCBit


org.apache.poi.hpbf.model.qcbits

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpbf.model.qcbits

Class Summary
QCBit | Parent of all Quill CONTENTS bits
QCPLCBit | A "PLC " (PLC) based bit of Quill Contents.
QCPLCBit.Type0 | Type 0 seem to be somewhat rare.
QCPLCBit.Type12 | Type 12 holds hyperlinks, and is very complex.
QCPLCBit.Type4 | Type 4 is quite common.
QCPLCBit.Type8 | Type 8 is quite common.
QCTextBit | A Text based bit of Quill Contents
UnknownQCBit | Any Quill Contents bits we don't know how to handle explicitly


org.apache.poi.hpbf.model.qcbits Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpbf.model.qcbits

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hpbf.model.qcbits.QCBit
      • org.apache.poi.hpbf.model.qcbits.QCPLCBit
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type0
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type4
        • org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type8
      • org.apache.poi.hpbf.model.qcbits.QCTextBit
      • org.apache.poi.hpbf.model.qcbits.UnknownQCBit


Uses of Package org.apache.poi.hpbf.model.qcbits

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpbf.model.qcbits

Packages that use org.apache.poi.hpbf.model.qcbits
org.apache.poi.hpbf.model
org.apache.poi.hpbf.model.qcbits

Classes in org.apache.poi.hpbf.model.qcbits used by org.apache.poi.hpbf.model
QCBit
Parent of all Quill CONTENTS bits

Classes in org.apache.poi.hpbf.model.qcbits used by org.apache.poi.hpbf.model.qcbits
QCBit
Parent of all Quill CONTENTS bits
QCPLCBit
A "PLC " (PLC) based bit of Quill Contents.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


QCBit

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class QCBit

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
Direct Known Subclasses:
QCPLCBit, QCTextBit, UnknownQCBit
public abstract class QCBit
extends java.lang.Object

Parent of all Quill CONTENTS bits

Field Summary
protected java.lang.String | bitType
protected byte[] | data
protected int | dataOffset
protected int | optA
protected int | optB
protected int | optC
protected java.lang.String | thingType
Constructor Summary
QCBit(java.lang.String thingType, java.lang.String bitType, byte[] data)
Method Summary
java.lang.String | getBitType() Returns the type of the bit data, eg TEXT or PLC
byte[] | getData()
int | getDataOffset()
int | getLength()
int | getOptA()
int | getOptB()
int | getOptC()
java.lang.String | getThingType() Returns the type of the thing, eg TEXT, FONT or TOKN
void | setDataOffset(int offset)
void | setOptA(int optA)
void | setOptB(int optB)
void | setOptC(int optC)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

thingType

protected java.lang.String thingType

bitType

protected java.lang.String bitType

data

protected byte[] data

optA

protected int optA

optB

protected int optB

optC

protected int optC

dataOffset

protected int dataOffset
Constructor Detail

QCBit

public QCBit(java.lang.String thingType,
             java.lang.String bitType,
             byte[] data)
Method Detail

getThingType

public java.lang.String getThingType()
Returns the type of the thing, eg TEXT, FONT or TOKN

getBitType

public java.lang.String getBitType()
Returns the type of the bit data, eg TEXT or PLC

getData

public byte[] getData()

getOptA

public int getOptA()

setOptA

public void setOptA(int optA)

getOptB

public int getOptB()

setOptB

public void setOptB(int optB)

getOptC

public int getOptC()

setOptC

public void setOptC(int optC)

getDataOffset

public int getDataOffset()

setDataOffset

public void setDataOffset(int offset)

getLength

public int getLength()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


QCPLCBit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class QCPLCBit

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
        extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit
Direct Known Subclasses:
QCPLCBit.Type0, QCPLCBit.Type12, QCPLCBit.Type4, QCPLCBit.Type8
public abstract class QCPLCBit
extends QCBit

A "PLC " (PLC) based bit of Quill Contents. The exact format is determined by the type of the PLCs.

Nested Class Summary
static class | QCPLCBit.Type0 Type 0 seem to be somewhat rare.
static class | QCPLCBit.Type12 Type 12 holds hyperlinks, and is very complex.
static class | QCPLCBit.Type4 Type 4 is quite common.
static class | QCPLCBit.Type8 Type 8 is quite common.
Field Summary
protected int | numberOfPLCs
protected long[] | plcValA The first value of each PLC, normally 4 bytes
protected long[] | plcValB The second value of each PLC, normally 4 bytes
protected int[] | preData The data which goes before the main PLC entries.
protected int | typeOfPLCS
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
bitType, data, dataOffset, optA, optB, optC, thingType
Method Summary
static QCPLCBit | createQCPLCBit(java.lang.String thingType, java.lang.String bitType, byte[] data)
int | getNumberOfPLCs()
long[] | getPlcValA()
long[] | getPlcValB()
int[] | getPreData()
int | getTypeOfPLCS()
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
getBitType, getData, getDataOffset, getLength, getOptA, getOptB, getOptC, getThingType, setDataOffset, setOptA, setOptB, setOptC
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

numberOfPLCs

protected int numberOfPLCs

typeOfPLCS

protected int typeOfPLCS

preData

protected int[] preData
The data which goes before the main PLC entries. This is apparently always made up of 2 byte un-signed ints..

plcValA

protected long[] plcValA
The first value of each PLC, normally 4 bytes

plcValB

protected long[] plcValB
The second value of each PLC, normally 4 bytes

Method Detail

getNumberOfPLCs

public int getNumberOfPLCs()

getTypeOfPLCS

public int getTypeOfPLCS()

getPreData

public int[] getPreData()

getPlcValA

public long[] getPlcValA()

getPlcValB

public long[] getPlcValB()

createQCPLCBit

public static QCPLCBit createQCPLCBit(java.lang.String thingType,
                                      java.lang.String bitType,
                                      byte[] data)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QCPLCBit.Type0

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class QCPLCBit.Type0

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
        extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit
            extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type0
Enclosing class:
QCPLCBit
public static class QCPLCBit.Type0
extends QCPLCBit

Type 0 seem to be somewhat rare. They have 8 bytes of pre-data, then 2x 2 byte values.

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
QCPLCBit.Type0, QCPLCBit.Type12, QCPLCBit.Type4, QCPLCBit.Type8
Field Summary
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
numberOfPLCs, plcValA, plcValB, preData, typeOfPLCS
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
bitType, data, dataOffset, optA, optB, optC, thingType
Method Summary
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
createQCPLCBit, getNumberOfPLCs, getPlcValA, getPlcValB, getPreData, getTypeOfPLCS
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
getBitType, getData, getDataOffset, getLength, getOptA, getOptB, getOptC, getThingType, setDataOffset, setOptA, setOptB, setOptC
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QCPLCBit.Type12

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class QCPLCBit.Type12

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
        extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit
            extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12
Enclosing class:
QCPLCBit
public static class QCPLCBit.Type12
extends QCPLCBit

Type 12 holds hyperlinks, and is very complex. There is normally one of these for each text area that contains at least one hyperlinks. The character offsets are relative to the start of the text area that this applies to.

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
QCPLCBit.Type0, QCPLCBit.Type12, QCPLCBit.Type4, QCPLCBit.Type8
Field Summary
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
numberOfPLCs, plcValA, plcValB, preData, typeOfPLCS
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
bitType, data, dataOffset, optA, optB, optC, thingType
Method Summary
int | getAllTextEndAt() Returns where in the text that this block of hyperlinks stops applying to.
java.lang.String | getHyperlink(int number) Returns the URL of the hyperlink at the given index.
int | getNumberOfHyperlinks() Returns the number of hyperlinks, which should either be zero, or the number of PLC bits
int | getTextStartAt(int number) Returns where in the text (in characters) the hyperlink at the given index starts applying to.
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
createQCPLCBit, getNumberOfPLCs, getPlcValA, getPlcValB, getPreData, getTypeOfPLCS
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
getBitType, getData, getDataOffset, getLength, getOptA, getOptB, getOptC, getThingType, setDataOffset, setOptA, setOptB, setOptC
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getNumberOfHyperlinks

public int getNumberOfHyperlinks()
Returns the number of hyperlinks, which should either be zero, or the number of PLC bits

getHyperlink

public java.lang.String getHyperlink(int number)
Returns the URL of the hyperlink at the given index.

Parameters:
number - The hyperlink number, zero based

getTextStartAt

public int getTextStartAt(int number)
Returns where in the text (in characters) the hyperlink at the given index starts applying to. This position is relative to the text area that this PLCBit applies to.

Parameters:
number - The hyperlink number, zero based

getAllTextEndAt

public int getAllTextEndAt()
Returns where in the text that this block of hyperlinks stops applying to. Normally, but not always the end of the text. This position is relative to the text area that this PLCBit applies to.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QCPLCBit.Type4

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class QCPLCBit.Type4

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
        extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit
            extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type4
Enclosing class:
QCPLCBit
public static class QCPLCBit.Type4
extends QCPLCBit

Type 4 is quite common. They have 8 bytes of pre-data, then 2x 4 byte values.

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
QCPLCBit.Type0, QCPLCBit.Type12, QCPLCBit.Type4, QCPLCBit.Type8
Field Summary
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
numberOfPLCs, plcValA, plcValB, preData, typeOfPLCS
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
bitType, data, dataOffset, optA, optB, optC, thingType
Method Summary
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
createQCPLCBit, getNumberOfPLCs, getPlcValA, getPlcValB, getPreData, getTypeOfPLCS
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
getBitType, getData, getDataOffset, getLength, getOptA, getOptB, getOptC, getThingType, setDataOffset, setOptA, setOptB, setOptC
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QCPLCBit.Type8

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class QCPLCBit.Type8

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
        extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit
            extended by  org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type8
Enclosing class:
QCPLCBit
public static class QCPLCBit.Type8
extends QCPLCBit

Type 8 is quite common. They have 14 bytes of pre-data, then 2x 4 byte values.

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
QCPLCBit.Type0, QCPLCBit.Type12, QCPLCBit.Type4, QCPLCBit.Type8
Field Summary
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
numberOfPLCs, plcValA, plcValB, preData, typeOfPLCS
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
bitType, data, dataOffset, optA, optB, optC, thingType
Method Summary
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCPLCBit
createQCPLCBit, getNumberOfPLCs, getPlcValA, getPlcValB, getPreData, getTypeOfPLCS
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
getBitType, getData, getDataOffset, getLength, getOptA, getOptB, getOptC, getThingType, setDataOffset, setOptA, setOptB, setOptC
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QCTextBit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class QCTextBit

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
        extended by  org.apache.poi.hpbf.model.qcbits.QCTextBit

public final class QCTextBit
extends QCBit

A Text based bit of Quill Contents

Field Summary
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
bitType, data, dataOffset, optA, optB, optC, thingType
Constructor Summary
QCTextBit(java.lang.String thingType, java.lang.String bitType, byte[] data)
Method Summary
java.lang.String | getText() Returns the text.
void | setText(java.lang.String text)
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
getBitType, getData, getDataOffset, getLength, getOptA, getOptB, getOptC, getThingType, setDataOffset, setOptA, setOptB, setOptC
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QCTextBit

public QCTextBit(java.lang.String thingType,
                 java.lang.String bitType,
                 byte[] data)
Method Detail

getText

public java.lang.String getText()
Returns the text. Note that line endings are \r and not \n

setText

public void setText(java.lang.String text)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownQCBit

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpbf.model.qcbits
Class UnknownQCBit

java.lang.Object
    extended by  org.apache.poi.hpbf.model.qcbits.QCBit
        extended by  org.apache.poi.hpbf.model.qcbits.UnknownQCBit

public final class UnknownQCBit
extends QCBit

Any Quill Contents bits we don't know how to handle explicitly

Field Summary
Fields inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
bitType, data, dataOffset, optA, optB, optC, thingType
Constructor Summary
UnknownQCBit(java.lang.String thingType, java.lang.String bitType, byte[] data)
Method Summary
Methods inherited from class org.apache.poi.hpbf.model.qcbits.QCBit
getBitType, getData, getDataOffset, getLength, getOptA, getOptB, getOptC, getThingType, setDataOffset, setOptA, setOptB, setOptC
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnknownQCBit

public UnknownQCBit(java.lang.String thingType,
                    java.lang.String bitType,
                    byte[] data)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hpbf.model.qcbits.QCBit

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.QCBit

Packages that use QCBit
org.apache.poi.hpbf.model
org.apache.poi.hpbf.model.qcbits

Uses of QCBit in org.apache.poi.hpbf.model

Methods in org.apache.poi.hpbf.model that return QCBit
 QCBit[] QuillContents.getBits()

Uses of QCBit in org.apache.poi.hpbf.model.qcbits

Subclasses of QCBit in org.apache.poi.hpbf.model.qcbits
class | QCPLCBit A "PLC " (PLC) based bit of Quill Contents.
static class | QCPLCBit.Type0 Type 0 seem to be somewhat rare.
static class | QCPLCBit.Type12 Type 12 holds hyperlinks, and is very complex.
static class | QCPLCBit.Type4 Type 4 is quite common.
static class | QCPLCBit.Type8 Type 8 is quite common.
class | QCTextBit A Text based bit of Quill Contents
class | UnknownQCBit Any Quill Contents bits we don't know how to handle explicitly

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.qcbits.QCPLCBit

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.QCPLCBit

Packages that use QCPLCBit
org.apache.poi.hpbf.model.qcbits

Uses of QCPLCBit in org.apache.poi.hpbf.model.qcbits

Subclasses of QCPLCBit in org.apache.poi.hpbf.model.qcbits
static class | QCPLCBit.Type0 Type 0 seem to be somewhat rare.
static class | QCPLCBit.Type12 Type 12 holds hyperlinks, and is very complex.
static class | QCPLCBit.Type4 Type 4 is quite common.
static class | QCPLCBit.Type8 Type 8 is quite common.

Methods in org.apache.poi.hpbf.model.qcbits that return QCPLCBit
static QCPLCBit QCPLCBit.createQCPLCBit(java.lang.String thingType, java.lang.String bitType, byte[] data)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type0

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type0

No usage of org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type0

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12

No usage of org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type12

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type4

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type4

No usage of org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type4

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type8

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type8

No usage of org.apache.poi.hpbf.model.qcbits.QCPLCBit.Type8

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.qcbits.QCTextBit

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.QCTextBit

No usage of org.apache.poi.hpbf.model.qcbits.QCTextBit

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpbf.model.qcbits.UnknownQCBit

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpbf.model.qcbits.UnknownQCBit

No usage of org.apache.poi.hpbf.model.qcbits.UnknownQCBit

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ClassID

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class ClassID

java.lang.Object
    extended by  org.apache.poi.hpsf.ClassID

public class ClassID
extends java.lang.Object

Represents a class ID (16 bytes). Unlike other little-endian type the ClassID is not just 16 bytes stored in the wrong order. Instead, it is a double word (4 bytes) followed by two words (2 bytes each) followed by 8 bytes.

Author:
Rainer Klute <klute@rainer-klute.de>

Field Summary
protected byte[] | bytes The bytes making out the class ID in correct order, i.e.
static int | LENGTH The number of bytes occupied by this object in the byte stream.
Constructor Summary
ClassID()
Creates a ClassID and initializes its value with 0x00 bytes.
ClassID(byte[] src, int offset)
Creates a ClassID and reads its value from a byte array.
Method Summary
boolean | equals(java.lang.Object o) Checks whether this ClassID is equal to another object.
byte[] | getBytes() Gets the bytes making out the class ID.
int | hashCode()
int | length()
byte[] | read(byte[] src, int offset) Reads the class ID's value from a byte array by turning little-endian into big-endian.
void | setBytes(byte[] bytes) Sets the bytes making out the class ID.
java.lang.String | toString() Returns a human-readable representation of the Class ID in standard format "{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}".
void | write(byte[] dst, int offset) Writes the class ID to a byte array in the little-endian format.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

bytes

protected byte[] bytes

The bytes making out the class ID in correct order, i.e. big-endian.

LENGTH

public static final int LENGTH

The number of bytes occupied by this object in the byte stream.

See Also:
Constant Field Values
Constructor Detail

ClassID

public ClassID(byte[] src,
               int offset)

Creates a ClassID and reads its value from a byte array.

Parameters:
src - The byte array to read from.
offset - The offset of the first byte to read.

ClassID

public ClassID()

Creates a ClassID and initializes its value with 0x00 bytes.

Method Detail

length

public int length()
Returns:
The number of bytes occupied by this object in the byte stream.

getBytes

public byte[] getBytes()

Gets the bytes making out the class ID. They are returned in correct order, i.e. big-endian.

Returns:
the bytes making out the class ID.

setBytes

public void setBytes(byte[] bytes)

Sets the bytes making out the class ID.

Parameters:
bytes - The bytes making out the class ID in big-endian format. They are copied without their order being changed.

read

public byte[] read(byte[] src,
                   int offset)

Reads the class ID's value from a byte array by turning little-endian into big-endian.

Parameters:
src - The byte array to read from
offset - The offset within the src byte array
Returns:
A byte array containing the class ID.

write

public void write(byte[] dst,
                  int offset)
           throws java.lang.ArrayStoreException

Writes the class ID to a byte array in the little-endian format.

Parameters:
dst - The byte array to write to.
offset - The offset within the dst byte array.
Throws:
java.lang.ArrayStoreException - if there is not enough room for the class ID 16 bytes in the byte array after the offset position.

equals

public boolean equals(java.lang.Object o)

Checks whether this ClassID is equal to another object.

Overrides:
equals in class java.lang.Object
Parameters:
o - the object to compare this PropertySet with
Returns:
true if the objects are equal, else false.

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
See Also:
Object.hashCode()

toString

public java.lang.String toString()

Returns a human-readable representation of the Class ID in standard format "{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}".

Overrides:
toString in class java.lang.Object
Returns:
String representation of the Class ID represented by this object.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Constants

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class Constants

java.lang.Object
    extended by  org.apache.poi.hpsf.Constants

public class Constants
extends java.lang.Object

Defines constants of general use.

Author:
Rainer Klute <klute@rainer-klute.de>

Field Summary
static int | CP_037 Codepage 037, a special case
static int | CP_EUC_JP Codepage for EUC-JP
static int | CP_EUC_KR Codepage for EUC-KR
static int | CP_GB18030 Codepage for GB18030
static int | CP_GB2312 Codepage for GB2312
static int | CP_GBK Codepage for GBK, aka MS936
static int | CP_ISO_2022_JP1 Codepage for ISO-2022-JP
static int | CP_ISO_2022_JP2 Another codepage for ISO-2022-JP
static int | CP_ISO_2022_JP3 Yet another codepage for ISO-2022-JP
static int | CP_ISO_2022_KR Codepage for ISO-2022-KR
static int | CP_ISO_8859_1 Codepage for ISO-8859-1
static int | CP_ISO_8859_2 Codepage for ISO-8859-2
static int | CP_ISO_8859_3 Codepage for ISO-8859-3
static int | CP_ISO_8859_4 Codepage for ISO-8859-4
static int | CP_ISO_8859_5 Codepage for ISO-8859-5
static int | CP_ISO_8859_6 Codepage for ISO-8859-6
static int | CP_ISO_8859_7 Codepage for ISO-8859-7
static int | CP_ISO_8859_8 Codepage for ISO-8859-8
static int | CP_ISO_8859_9 Codepage for ISO-8859-9
static int | CP_JOHAB Codepage for Johab
static int | CP_KOI8_R Codepage for KOI8-R
static int | CP_MAC_ARABIC Codepage for Macintosh Arabic (Java: MacArabic)
static int | CP_MAC_CENTRAL_EUROPE Codepage for Macintosh Central Europe (Latin-2) (Java: MacCentralEurope)
static int | CP_MAC_CHINESE_SIMPLE Codepage for Macintosh Chinese Simplified (Java: unknown - use EUC_CN, ISO2022_CN_GB, MS936 or cp935)
static int | CP_MAC_CHINESE_TRADITIONAL Codepage for Macintosh Chinese Traditional (Java: unknown - use Big5, MS950, or cp937)
static int | CP_MAC_CROATIAN Codepage for Macintosh Croatian (Java: MacCroatian)
static int | CP_MAC_CYRILLIC Codepage for Macintosh Cyrillic (Java: MacCyrillic)
static int | CP_MAC_GREEK Codepage for Macintosh Greek (Java: MacGreek)
static int | CP_MAC_HEBREW Codepage for Macintosh Hebrew (Java: MacHebrew)
static int | CP_MAC_ICELAND Codepage for Macintosh Iceland (Java: MacIceland)
static int | CP_MAC_JAPAN Codepage for Macintosh Japan (Java: unknown - use SJIS, cp942 or cp943)
static int | CP_MAC_KOREAN Codepage for Macintosh Korean (Java: unknown - use EUC_KR or cp949)
static int | CP_MAC_ROMAN Codepage for Macintosh Roman (Java: MacRoman)
static int | CP_MAC_ROMANIA Codepage for Macintosh Romanian (Java: MacRomania)
static int | CP_MAC_THAI Codepage for Macintosh Thai (Java: MacThai)
static int | CP_MAC_TURKISH Codepage for Macintosh Turkish (Java: MacTurkish)
static int | CP_MAC_UKRAINE Codepage for Macintosh Ukrainian (Java: MacUkraine)
static int | CP_MS949 Codepage for MS949
static int | CP_SJIS Codepage for SJIS
static int | CP_UNICODE Codepage for Unicode
static int | CP_US_ACSII Codepage for US-ASCII
static int | CP_US_ASCII2 Another codepage for US-ASCII
static int | CP_UTF16 Codepage for UTF-16
static int | CP_UTF16_BE Codepage for UTF-16 big-endian
static int | CP_UTF8 Codepage for UTF-8
static int | CP_WINDOWS_1250 Codepage for Windows 1250
static int | CP_WINDOWS_1251 Codepage for Windows 1251
static int | CP_WINDOWS_1252 Codepage for Windows 1252
static int | CP_WINDOWS_1253 Codepage for Windows 1253
static int | CP_WINDOWS_1254 Codepage for Windows 1254
static int | CP_WINDOWS_1255 Codepage for Windows 1255
static int | CP_WINDOWS_1256 Codepage for Windows 1256
static int | CP_WINDOWS_1257 Codepage for Windows 1257
static int | CP_WINDOWS_1258 Codepage for Windows 1258
Constructor Summary
Constants()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CP_037

public static final int CP_037

Codepage 037, a special case

See Also:
Constant Field Values

CP_SJIS

public static final int CP_SJIS

Codepage for SJIS

See Also:
Constant Field Values

CP_GBK

public static final int CP_GBK

Codepage for GBK, aka MS936

See Also:
Constant Field Values

CP_MS949

public static final int CP_MS949

Codepage for MS949

See Also:
Constant Field Values

CP_UTF16

public static final int CP_UTF16

Codepage for UTF-16

See Also:
Constant Field Values

CP_UTF16_BE

public static final int CP_UTF16_BE

Codepage for UTF-16 big-endian

See Also:
Constant Field Values

CP_WINDOWS_1250

public static final int CP_WINDOWS_1250

Codepage for Windows 1250

See Also:
Constant Field Values

CP_WINDOWS_1251

public static final int CP_WINDOWS_1251

Codepage for Windows 1251

See Also:
Constant Field Values

CP_WINDOWS_1252

public static final int CP_WINDOWS_1252

Codepage for Windows 1252

See Also:
Constant Field Values

CP_WINDOWS_1253

public static final int CP_WINDOWS_1253

Codepage for Windows 1253

See Also:
Constant Field Values

CP_WINDOWS_1254

public static final int CP_WINDOWS_1254

Codepage for Windows 1254

See Also:
Constant Field Values

CP_WINDOWS_1255

public static final int CP_WINDOWS_1255

Codepage for Windows 1255

See Also:
Constant Field Values

CP_WINDOWS_1256

public static final int CP_WINDOWS_1256

Codepage for Windows 1256

See Also:
Constant Field Values

CP_WINDOWS_1257

public static final int CP_WINDOWS_1257

Codepage for Windows 1257

See Also:
Constant Field Values

CP_WINDOWS_1258

public static final int CP_WINDOWS_1258

Codepage for Windows 1258

See Also:
Constant Field Values

CP_JOHAB

public static final int CP_JOHAB

Codepage for Johab

See Also:
Constant Field Values

CP_MAC_ROMAN

public static final int CP_MAC_ROMAN

Codepage for Macintosh Roman (Java: MacRoman)

See Also:
Constant Field Values

CP_MAC_JAPAN

public static final int CP_MAC_JAPAN

Codepage for Macintosh Japan (Java: unknown - use SJIS, cp942 or cp943)

See Also:
Constant Field Values

CP_MAC_CHINESE_TRADITIONAL

public static final int CP_MAC_CHINESE_TRADITIONAL

Codepage for Macintosh Chinese Traditional (Java: unknown - use Big5, MS950, or cp937)

See Also:
Constant Field Values

CP_MAC_KOREAN

public static final int CP_MAC_KOREAN

Codepage for Macintosh Korean (Java: unknown - use EUC_KR or cp949)

See Also:
Constant Field Values

CP_MAC_ARABIC

public static final int CP_MAC_ARABIC

Codepage for Macintosh Arabic (Java: MacArabic)

See Also:
Constant Field Values

CP_MAC_HEBREW

public static final int CP_MAC_HEBREW

Codepage for Macintosh Hebrew (Java: MacHebrew)

See Also:
Constant Field Values

CP_MAC_GREEK

public static final int CP_MAC_GREEK

Codepage for Macintosh Greek (Java: MacGreek)

See Also:
Constant Field Values

CP_MAC_CYRILLIC

public static final int CP_MAC_CYRILLIC

Codepage for Macintosh Cyrillic (Java: MacCyrillic)

See Also:
Constant Field Values

CP_MAC_CHINESE_SIMPLE

public static final int CP_MAC_CHINESE_SIMPLE

Codepage for Macintosh Chinese Simplified (Java: unknown - use EUC_CN, ISO2022_CN_GB, MS936 or cp935)

See Also:
Constant Field Values

CP_MAC_ROMANIA

public static final int CP_MAC_ROMANIA

Codepage for Macintosh Romanian (Java: MacRomania)

See Also:
Constant Field Values

CP_MAC_UKRAINE

public static final int CP_MAC_UKRAINE

Codepage for Macintosh Ukrainian (Java: MacUkraine)

See Also:
Constant Field Values

CP_MAC_THAI

public static final int CP_MAC_THAI

Codepage for Macintosh Thai (Java: MacThai)

See Also:
Constant Field Values

CP_MAC_CENTRAL_EUROPE

public static final int CP_MAC_CENTRAL_EUROPE

Codepage for Macintosh Central Europe (Latin-2) (Java: MacCentralEurope)

See Also:
Constant Field Values

CP_MAC_ICELAND

public static final int CP_MAC_ICELAND

Codepage for Macintosh Iceland (Java: MacIceland)

See Also:
Constant Field Values

CP_MAC_TURKISH

public static final int CP_MAC_TURKISH

Codepage for Macintosh Turkish (Java: MacTurkish)

See Also:
Constant Field Values

CP_MAC_CROATIAN

public static final int CP_MAC_CROATIAN

Codepage for Macintosh Croatian (Java: MacCroatian)

See Also:
Constant Field Values

CP_US_ACSII

public static final int CP_US_ACSII

Codepage for US-ASCII

See Also:
Constant Field Values

CP_KOI8_R

public static final int CP_KOI8_R

Codepage for KOI8-R

See Also:
Constant Field Values

CP_ISO_8859_1

public static final int CP_ISO_8859_1

Codepage for ISO-8859-1

See Also:
Constant Field Values

CP_ISO_8859_2

public static final int CP_ISO_8859_2

Codepage for ISO-8859-2

See Also:
Constant Field Values

CP_ISO_8859_3

public static final int CP_ISO_8859_3

Codepage for ISO-8859-3

See Also:
Constant Field Values

CP_ISO_8859_4

public static final int CP_ISO_8859_4

Codepage for ISO-8859-4

See Also:
Constant Field Values

CP_ISO_8859_5

public static final int CP_ISO_8859_5

Codepage for ISO-8859-5

See Also:
Constant Field Values

CP_ISO_8859_6

public static final int CP_ISO_8859_6

Codepage for ISO-8859-6

See Also:
Constant Field Values

CP_ISO_8859_7

public static final int CP_ISO_8859_7

Codepage for ISO-8859-7

See Also:
Constant Field Values

CP_ISO_8859_8

public static final int CP_ISO_8859_8

Codepage for ISO-8859-8

See Also:
Constant Field Values

CP_ISO_8859_9

public static final int CP_ISO_8859_9

Codepage for ISO-8859-9

See Also:
Constant Field Values

CP_ISO_2022_JP1

public static final int CP_ISO_2022_JP1

Codepage for ISO-2022-JP

See Also:
Constant Field Values

CP_ISO_2022_JP2

public static final int CP_ISO_2022_JP2

Another codepage for ISO-2022-JP

See Also:
Constant Field Values

CP_ISO_2022_JP3

public static final int CP_ISO_2022_JP3

Yet another codepage for ISO-2022-JP

See Also:
Constant Field Values

CP_ISO_2022_KR

public static final int CP_ISO_2022_KR

Codepage for ISO-2022-KR

See Also:
Constant Field Values

CP_EUC_JP

public static final int CP_EUC_JP

Codepage for EUC-JP

See Also:
Constant Field Values

CP_EUC_KR

public static final int CP_EUC_KR

Codepage for EUC-KR

See Also:
Constant Field Values

CP_GB2312

public static final int CP_GB2312

Codepage for GB2312

See Also:
Constant Field Values

CP_GB18030

public static final int CP_GB18030

Codepage for GB18030

See Also:
Constant Field Values

CP_US_ASCII2

public static final int CP_US_ASCII2

Another codepage for US-ASCII

See Also:
Constant Field Values

CP_UTF8

public static final int CP_UTF8

Codepage for UTF-8

See Also:
Constant Field Values

CP_UNICODE

public static final int CP_UNICODE

Codepage for Unicode

See Also:
Constant Field Values
Constructor Detail

Constants

public Constants()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class CustomProperties

java.lang.Object
    extended by  java.util.AbstractMap<K,V>
        extended by  java.util.HashMap<java.lang.Object,CustomProperty>
            extended by  org.apache.poi.hpsf.CustomProperties
All Implemented Interfaces:
java.io.Serializable, java.lang.Cloneable, java.util.Map<java.lang.Object,CustomProperty>
public class CustomProperties
extends java.util.HashMap<java.lang.Object,CustomProperty>

Maintains the instances of CustomProperty that belong to a DocumentSummaryInformation. The class maintains the names of the custom properties in a dictionary. It implements the Map interface and by this provides a simplified view on custom properties: A property's name is the key that maps to a typed value. This implementation hides property IDs from the developer and regards the property names as keys to typed values.

While this class provides a simple API to custom properties, it ignores the fact that not names, but IDs are the real keys to properties. Under the hood this class maintains a 1:1 relationship between IDs and names. Therefore you should not use this class to process property sets with several IDs mapping to the same name or with properties without a name: the result will contain only a subset of the original properties. If you really need to deal such property sets, use HPSF's low-level access methods.

An application can call the isPure method to check whether a property set parsed by CustomProperties is still pure (i.e. unmodified) or whether one or more properties have been dropped.

This class is not thread-safe; concurrent access to instances of this class must be synchronized.

While this class is roughly HashMap, that's the internal representation. To external calls, it should appear as HashMap mapping between Names and Custom Property Values.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.util.AbstractMap
java.util.AbstractMap.SimpleEntry<K,V>, java.util.AbstractMap.SimpleImmutableEntry<K,V>
Constructor Summary
CustomProperties()
Method Summary
boolean | containsKey(java.lang.Object key) Checks against both String Name and Long ID
boolean | containsValue(java.lang.Object value) Checks against both the property, and its values.
java.lang.Object | get(java.lang.String name) Gets a named value from the custom properties.
int | getCodepage() Gets the codepage.
java.util.Set<java.lang.String> | idSet() Returns a set of all the IDs of our custom properties
boolean | isPure() Tells whether this CustomProperties instance is pure or one or more properties of the underlying low-level property set has been dropped.
java.util.Set | keySet() Returns a set of all the names of our custom properties.
java.util.Set<java.lang.String> | nameSet() Returns a set of all the names of our custom properties
java.lang.Object | put(java.lang.String name, java.lang.Boolean value) Adds a named boolean property.
CustomProperty | put(java.lang.String name, CustomProperty cp) Puts a CustomProperty into this map.
java.lang.Object | put(java.lang.String name, java.util.Date value) Adds a named date property.
java.lang.Object | put(java.lang.String name, java.lang.Double value) Adds a named double property.
java.lang.Object | put(java.lang.String name, java.lang.Integer value) Adds a named integer property.
java.lang.Object | put(java.lang.String name, java.lang.Long value) Adds a named long property.
java.lang.Object | put(java.lang.String name, java.lang.String value) Adds a named string property.
java.lang.Object | remove(java.lang.String name) Removes a custom property.
void | setCodepage(int codepage) Sets the codepage.
void | setPure(boolean isPure) Sets the purity of the custom property set.
Methods inherited from class java.util.HashMap
clear, clone, entrySet, get, isEmpty, put, putAll, remove, size, values
Methods inherited from class java.util.AbstractMap
equals, hashCode, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Constructor Detail

CustomProperties

public CustomProperties()
Method Detail

put

public CustomProperty put(java.lang.String name,
                          CustomProperty cp)

Puts a CustomProperty into this map. It is assumed that the CustomProperty already has a valid ID. Otherwise use put(CustomProperty).

remove

public java.lang.Object remove(java.lang.String name)

Removes a custom property.

Parameters:
name - The name of the custom property to remove
Returns:
The removed property or null if the specified property was not found.
See Also:
HashSet.remove(java.lang.Object)

put

public java.lang.Object put(java.lang.String name,
                            java.lang.String value)

Adds a named string property.

Parameters:
name - The property's name.
value - The property's value.
Returns:
the property that was stored under the specified name before, or null if there was no such property before.

put

public java.lang.Object put(java.lang.String name,
                            java.lang.Long value)

Adds a named long property.

Parameters:
name - The property's name.
value - The property's value.
Returns:
the property that was stored under the specified name before, or null if there was no such property before.

put

public java.lang.Object put(java.lang.String name,
                            java.lang.Double value)

Adds a named double property.

Parameters:
name - The property's name.
value - The property's value.
Returns:
the property that was stored under the specified name before, or null if there was no such property before.

put

public java.lang.Object put(java.lang.String name,
                            java.lang.Integer value)

Adds a named integer property.

Parameters:
name - The property's name.
value - The property's value.
Returns:
the property that was stored under the specified name before, or null if there was no such property before.

put

public java.lang.Object put(java.lang.String name,
                            java.lang.Boolean value)

Adds a named boolean property.

Parameters:
name - The property's name.
value - The property's value.
Returns:
the property that was stored under the specified name before, or null if there was no such property before.

get

public java.lang.Object get(java.lang.String name)

Gets a named value from the custom properties.

Parameters:
name - the name of the value to get
Returns:
the value or null if a value with the specified name is not found in the custom properties.

put

public java.lang.Object put(java.lang.String name,
                            java.util.Date value)

Adds a named date property.

Parameters:
name - The property's name.
value - The property's value.
Returns:
the property that was stored under the specified name before, or null if there was no such property before.

keySet

public java.util.Set keySet()
Returns a set of all the names of our custom properties. Equivalent to nameSet()

Specified by:
keySet in interface java.util.Map<java.lang.Object,CustomProperty>
Overrides:
keySet in class java.util.HashMap<java.lang.Object,CustomProperty>

nameSet

public java.util.Set<java.lang.String> nameSet()
Returns a set of all the names of our custom properties

idSet

public java.util.Set<java.lang.String> idSet()
Returns a set of all the IDs of our custom properties

setCodepage

public void setCodepage(int codepage)

Sets the codepage.

Parameters:
codepage - the codepage

containsKey

public boolean containsKey(java.lang.Object key)
Checks against both String Name and Long ID

Specified by:
containsKey in interface java.util.Map<java.lang.Object,CustomProperty>
Overrides:
containsKey in class java.util.HashMap<java.lang.Object,CustomProperty>

containsValue

public boolean containsValue(java.lang.Object value)
Checks against both the property, and its values.

Specified by:
containsValue in interface java.util.Map<java.lang.Object,CustomProperty>
Overrides:
containsValue in class java.util.HashMap<java.lang.Object,CustomProperty>

getCodepage

public int getCodepage()

Gets the codepage.

Returns:
the codepage or -1 if the codepage is undefined.

isPure

public boolean isPure()

Tells whether this CustomProperties instance is pure or one or more properties of the underlying low-level property set has been dropped.

Returns:
true if the CustomProperties is pure, else false.

setPure

public void setPure(boolean isPure)

Sets the purity of the custom property set.

Parameters:
isPure - the purity
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class CustomProperty

java.lang.Object
    extended by  org.apache.poi.hpsf.Property
        extended by  org.apache.poi.hpsf.MutableProperty
            extended by  org.apache.poi.hpsf.CustomProperty

public class CustomProperty
extends MutableProperty

This class represents custom properties in the document summary information stream. The difference to normal properties is that custom properties have an optional name. If the name is not null it will be maintained in the section's dictionary.

Author:
Rainer Klute <klute@rainer-klute.de>

Field Summary
Fields inherited from class org.apache.poi.hpsf.Property
id, type, value
Constructor Summary
CustomProperty()
Creates an empty CustomProperty.
CustomProperty(Property property)
Creates a CustomProperty without a name by copying the underlying Property' attributes.
CustomProperty(Property property, java.lang.String name)
Creates a CustomProperty with a name.
Method Summary
boolean | equalsContents(java.lang.Object o) Compares two custom properties for equality.
java.lang.String | getName() Gets the property's name.
int | hashCode()
void | setName(java.lang.String name) Sets the property's name.
Methods inherited from class org.apache.poi.hpsf.MutableProperty
setID, setType, setValue, write
Methods inherited from class org.apache.poi.hpsf.Property
equals, getID, getSize, getType, getValue, readDictionary, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomProperty

public CustomProperty()

Creates an empty CustomProperty. The set methods must be called to make it usable.

CustomProperty

public CustomProperty(Property property)

Creates a CustomProperty without a name by copying the underlying Property' attributes.

Parameters:
property - the property to copy

CustomProperty

public CustomProperty(Property property,
                      java.lang.String name)

Creates a CustomProperty with a name.

Parameters:
property - This property's attributes are copied to the new custom property.
name - The new custom property's name.
Method Detail

getName

public java.lang.String getName()

Gets the property's name.

Returns:
the property's name.

setName

public void setName(java.lang.String name)

Sets the property's name.

Parameters:
name - The name to set.

equalsContents

public boolean equalsContents(java.lang.Object o)

Compares two custom properties for equality. The method returns true if all attributes of the two custom properties are equal.

Parameters:
o - The custom property to compare with.
Returns:
true if both custom properties are equal, else false.
See Also:
AbstractSet.equals(java.lang.Object)

hashCode

public int hashCode()
Overrides:
hashCode in class Property
See Also:
AbstractSet.hashCode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentSummaryInformation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class DocumentSummaryInformation

java.lang.Object
    extended by  org.apache.poi.hpsf.PropertySet
        extended by  org.apache.poi.hpsf.MutablePropertySet
            extended by  org.apache.poi.hpsf.SpecialPropertySet
                extended by  org.apache.poi.hpsf.DocumentSummaryInformation

public class DocumentSummaryInformation
extends SpecialPropertySet

Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.

Author:
Rainer Klute <klute@rainer-klute.de>, Drew Varner (Drew.Varner closeTo sc.edu), robert_flaherty@hyperion.com
See Also:
SummaryInformation

Field Summary
static java.lang.String DEFAULT_STREAM_NAME
The document name a document summary information stream usually has in a POIFS filesystem.
Fields inherited from class org.apache.poi.hpsf.PropertySet
byteOrder, classID, format, OS_MACINTOSH, OS_WIN16, OS_WIN32, osVersion, sections
Constructor Summary
DocumentSummaryInformation(PropertySet ps)
Creates a DocumentSummaryInformation from a given PropertySet.
Method Summary
int | getByteCount() Returns the byte count or 0 if the DocumentSummaryInformation does not contain a byte count.
java.lang.String | getCategory() Returns the category (or null).
java.lang.String | getCompany() Returns the company (or null).
CustomProperties | getCustomProperties() Gets the custom properties.
byte[] | getDocparts() Returns the doc parts (or null) when this method is implemented.
byte[] | getHeadingPair() Returns the heading pair (or null) when this method is implemented.
int | getHiddenCount() Returns the hidden count or 0 if the DocumentSummaryInformation does not contain a hidden count.
int | getLineCount() Returns the line count or 0 if the DocumentSummaryInformation does not contain a line count.
boolean | getLinksDirty() Returns true if the custom links are dirty.
java.lang.String | getManager() Returns the manager (or null).
int | getMMClipCount() Returns the mmclip count or 0 if the DocumentSummaryInformation does not contain a mmclip count.
int | getNoteCount() Returns the note count or 0 if the DocumentSummaryInformation does not contain a note count.
int | getParCount() Returns the par count or 0 if the DocumentSummaryInformation does not contain a par count.
java.lang.String | getPresentationFormat() Returns the presentation format (or null).
PropertyIDMap | getPropertySetIDMap() The id to name mapping of the properties in this set.
boolean | getScale() Returns true when scaling of the thumbnail is desired, false if cropping is desired.
int | getSlideCount() Returns the slide count or 0 if the DocumentSummaryInformation does not contain a slide count.
void | removeByteCount() Removes the byte count.
void | removeCategory() Removes the category.
void | removeCompany() Removes the company.
void | removeCustomProperties() Removes the custom properties.
void | removeDocparts() Removes the doc parts.
void | removeHeadingPair() Removes the heading pair.
void | removeHiddenCount() Removes the hidden count.
void | removeLineCount() Removes the line count.
void | removeLinksDirty() Removes the links dirty.
void | removeManager() Removes the manager.
void | removeMMClipCount() Removes the mmclip count.
void | removeNoteCount() Removes the noteCount.
void | removeParCount() Removes the par count.
void | removePresentationFormat() Removes the presentation format.
void | removeScale() Removes the scale.
void | removeSlideCount() Removes the slide count.
void | setByteCount(int byteCount) Sets the byte count.
void | setCategory(java.lang.String category) Sets the category.
void | setCompany(java.lang.String company) Sets the company.
void | setCustomProperties(CustomProperties customProperties) Sets the custom properties.
void | setDocparts(byte[] docparts) Sets the doc parts.
void | setHeadingPair(byte[] headingPair) Sets the heading pair.
void | setHiddenCount(int hiddenCount) Sets the hidden count.
void | setLineCount(int lineCount) Sets the line count.
void | setLinksDirty(boolean linksDirty) Sets the linksDirty.
void | setManager(java.lang.String manager) Sets the manager.
void | setMMClipCount(int mmClipCount) Sets the mmclip count.
void | setNoteCount(int noteCount) Sets the note count.
void | setParCount(int parCount) Sets the par count.
void | setPresentationFormat(java.lang.String presentationFormat) Sets the presentation format.
void | setScale(boolean scale) Sets the scale.
void | setSlideCount(int slideCount) Sets the slideCount.
Methods inherited from class org.apache.poi.hpsf.SpecialPropertySet
addSection, clearSections, equals, getByteOrder, getClassID, getFirstSection, getFormat, getOSVersion, getProperties, getProperty, getPropertyBooleanValue, getPropertyIntValue, getSectionCount, getSections, hashCode, isDocumentSummaryInformation, isSummaryInformation, setByteOrder, setClassID, setFormat, setOSVersion, toInputStream, toString, wasNull, write, write
Methods inherited from class org.apache.poi.hpsf.PropertySet
getSingleSection, isPropertySetStream, isPropertySetStream
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT_STREAM_NAME

public static final java.lang.String DEFAULT_STREAM_NAME

The document name a document summary information stream usually has in a POIFS filesystem.

See Also:
Constant Field Values
Constructor Detail

DocumentSummaryInformation

public DocumentSummaryInformation(PropertySet ps)
                           throws UnexpectedPropertySetTypeException

Creates a DocumentSummaryInformation from a given PropertySet.

Parameters:
ps - A property set which should be created from a document summary information stream.
Throws:
UnexpectedPropertySetTypeException - if ps does not contain a document summary information stream.
Method Detail

getPropertySetIDMap

public PropertyIDMap getPropertySetIDMap()
Description copied from class: SpecialPropertySet
The id to name mapping of the properties in this set.

Specified by:
getPropertySetIDMap in class SpecialPropertySet

getCategory

public java.lang.String getCategory()

Returns the category (or null).

Returns:
The category value

setCategory

public void setCategory(java.lang.String category)

Sets the category.

Parameters:
category - The category to set.

removeCategory

public void removeCategory()

Removes the category.

getPresentationFormat

public java.lang.String getPresentationFormat()

Returns the presentation format (or null).

Returns:
The presentation format value

setPresentationFormat

public void setPresentationFormat(java.lang.String presentationFormat)

Sets the presentation format.

Parameters:
presentationFormat - The presentation format to set.

removePresentationFormat

public void removePresentationFormat()

Removes the presentation format.

getByteCount

public int getByteCount()

Returns the byte count or 0 if the DocumentSummaryInformation does not contain a byte count.

Returns:
The byteCount value

setByteCount

public void setByteCount(int byteCount)

Sets the byte count.

Parameters:
byteCount - The byte count to set.

removeByteCount

public void removeByteCount()

Removes the byte count.

getLineCount

public int getLineCount()

Returns the line count or 0 if the DocumentSummaryInformation does not contain a line count.

Returns:
The line count value

setLineCount

public void setLineCount(int lineCount)

Sets the line count.

Parameters:
lineCount - The line count to set.

removeLineCount

public void removeLineCount()

Removes the line count.

getParCount

public int getParCount()

Returns the par count or 0 if the DocumentSummaryInformation does not contain a par count.

Returns:
The par count value

setParCount

public void setParCount(int parCount)

Sets the par count.

Parameters:
parCount - The par count to set.

removeParCount

public void removeParCount()

Removes the par count.

getSlideCount

public int getSlideCount()

Returns the slide count or 0 if the DocumentSummaryInformation does not contain a slide count.

Returns:
The slide count value

setSlideCount

public void setSlideCount(int slideCount)

Sets the slideCount.

Parameters:
slideCount - The slide count to set.

removeSlideCount

public void removeSlideCount()

Removes the slide count.

getNoteCount

public int getNoteCount()

Returns the note count or 0 if the DocumentSummaryInformation does not contain a note count.

Returns:
The note count value

setNoteCount

public void setNoteCount(int noteCount)

Sets the note count.

Parameters:
noteCount - The note count to set.

removeNoteCount

public void removeNoteCount()

Removes the noteCount.

getHiddenCount

public int getHiddenCount()

Returns the hidden count or 0 if the DocumentSummaryInformation does not contain a hidden count.

Returns:
The hidden count value

setHiddenCount

public void setHiddenCount(int hiddenCount)

Sets the hidden count.

Parameters:
hiddenCount - The hidden count to set.

removeHiddenCount

public void removeHiddenCount()

Removes the hidden count.

getMMClipCount

public int getMMClipCount()

Returns the mmclip count or 0 if the DocumentSummaryInformation does not contain a mmclip count.

Returns:
The mmclip count value

setMMClipCount

public void setMMClipCount(int mmClipCount)

Sets the mmclip count.

Parameters:
mmClipCount - The mmclip count to set.

removeMMClipCount

public void removeMMClipCount()

Removes the mmclip count.

getScale

public boolean getScale()

Returns true when scaling of the thumbnail is desired, false if cropping is desired.

Returns:
The scale value

setScale

public void setScale(boolean scale)

Sets the scale.

Parameters:
scale - The scale to set.

removeScale

public void removeScale()

Removes the scale.

getHeadingPair

public byte[] getHeadingPair()

Returns the heading pair (or null) when this method is implemented. Please note that the return type is likely to change!

Returns:
The heading pair value

setHeadingPair

public void setHeadingPair(byte[] headingPair)

Sets the heading pair.

Parameters:
headingPair - The heading pair to set.

removeHeadingPair

public void removeHeadingPair()

Removes the heading pair.

getDocparts

public byte[] getDocparts()

Returns the doc parts (or null) when this method is implemented. Please note that the return type is likely to change!

Returns:
The doc parts value

setDocparts

public void setDocparts(byte[] docparts)

Sets the doc parts.

Parameters:
docparts - The doc parts to set.

removeDocparts

public void removeDocparts()

Removes the doc parts.

getManager

public java.lang.String getManager()

Returns the manager (or null).

Returns:
The manager value

setManager

public void setManager(java.lang.String manager)

Sets the manager.

Parameters:
manager - The manager to set.

removeManager

public void removeManager()

Removes the manager.

getCompany

public java.lang.String getCompany()

Returns the company (or null).

Returns:
The company value

setCompany

public void setCompany(java.lang.String company)

Sets the company.

Parameters:
company - The company to set.

removeCompany

public void removeCompany()

Removes the company.

getLinksDirty

public boolean getLinksDirty()

Returns true if the custom links are dirty.

Returns:
The links dirty value

setLinksDirty

public void setLinksDirty(boolean linksDirty)

Sets the linksDirty.

Parameters:
linksDirty - The links dirty value to set.

removeLinksDirty

public void removeLinksDirty()

Removes the links dirty.

getCustomProperties

public CustomProperties getCustomProperties()

Gets the custom properties.

Returns:
The custom properties.

setCustomProperties

public void setCustomProperties(CustomProperties customProperties)

Sets the custom properties.

Parameters:
customProperties - The custom properties

removeCustomProperties

public void removeCustomProperties()

Removes the custom properties.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HPSFException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class HPSFException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
MarkUnsupportedException, NoPropertySetStreamException, UnexpectedPropertySetTypeException, VariantTypeException
public class HPSFException
extends java.lang.Exception

This exception is the superclass of all other checked exceptions thrown in this package. It supports a nested "reason" throwable, i.e. an exception that caused this one to be thrown.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
HPSFException()
Creates an HPSFException.
HPSFException(java.lang.String msg)
Creates an HPSFException with a message string.
HPSFException(java.lang.String msg, java.lang.Throwable reason)
Creates an HPSFException with a message string and a reason.
HPSFException(java.lang.Throwable reason)
Creates a new HPSFException with a reason.
Method Summary
 java.lang.Throwable getReason()
Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HPSFException

public HPSFException()

Creates an HPSFException.

HPSFException

public HPSFException(java.lang.String msg)

Creates an HPSFException with a message string.

Parameters:
msg - The message string.

HPSFException

public HPSFException(java.lang.Throwable reason)

Creates a new HPSFException with a reason.

Parameters:
reason - The reason, i.e. a throwable that indirectly caused this exception.

HPSFException

public HPSFException(java.lang.String msg,
                     java.lang.Throwable reason)

Creates an HPSFException with a message string and a reason.

Parameters:
msg - The message string.
reason - The reason, i.e. a throwable that indirectly caused this exception.
Method Detail

getReason

public java.lang.Throwable getReason()

Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.

Returns:
The reason
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HPSFRuntimeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class HPSFRuntimeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hpsf.HPSFRuntimeException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
IllegalPropertySetDataException, MissingSectionException, NoFormatIDException, NoSingleSectionException
public class HPSFRuntimeException
extends java.lang.RuntimeException

This exception is the superclass of all other unchecked exceptions thrown in this package. It supports a nested "reason" throwable, i.e. an exception that caused this one to be thrown.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
HPSFRuntimeException()
Creates a new HPSFRuntimeException.
HPSFRuntimeException(java.lang.String msg)
Creates a new HPSFRuntimeException with a message string.
HPSFRuntimeException(java.lang.String msg, java.lang.Throwable reason)
Creates a new HPSFRuntimeException with a message string and a reason.
HPSFRuntimeException(java.lang.Throwable reason)
Creates a new HPSFRuntimeException with a reason.
Method Summary
java.lang.Throwable | getReason() Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.
void | printStackTrace()
void | printStackTrace(java.io.PrintStream p)
void | printStackTrace(java.io.PrintWriter p)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HPSFRuntimeException

public HPSFRuntimeException()

Creates a new HPSFRuntimeException.

HPSFRuntimeException

public HPSFRuntimeException(java.lang.String msg)

Creates a new HPSFRuntimeException with a message string.

Parameters:
msg - The message string.

HPSFRuntimeException

public HPSFRuntimeException(java.lang.Throwable reason)

Creates a new HPSFRuntimeException with a reason.

Parameters:
reason - The reason, i.e. a throwable that indirectly caused this exception.

HPSFRuntimeException

public HPSFRuntimeException(java.lang.String msg,
                            java.lang.Throwable reason)

Creates a new HPSFRuntimeException with a message string and a reason.

Parameters:
msg - The message string.
reason - The reason, i.e. a throwable that indirectly caused this exception.
Method Detail

getReason

public java.lang.Throwable getReason()

Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.

Returns:
The reason

printStackTrace

public void printStackTrace()
Overrides:
printStackTrace in class java.lang.Throwable
See Also:
Throwable.printStackTrace()

printStackTrace

public void printStackTrace(java.io.PrintStream p)
Overrides:
printStackTrace in class java.lang.Throwable
See Also:
Throwable.printStackTrace(java.io.PrintStream)

printStackTrace

public void printStackTrace(java.io.PrintWriter p)
Overrides:
printStackTrace in class java.lang.Throwable
See Also:
Throwable.printStackTrace(java.io.PrintWriter)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IllegalPropertySetDataException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class IllegalPropertySetDataException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hpsf.HPSFRuntimeException
                    extended by  org.apache.poi.hpsf.IllegalPropertySetDataException
All Implemented Interfaces:
java.io.Serializable
public class IllegalPropertySetDataException
extends HPSFRuntimeException

This exception is thrown when there is an illegal value set in a PropertySet. For example, a Variant.VT_BOOL must have a value of -1 (true) or 0 (false). Any other value would trigger this exception. It supports a nested "reason" throwable, i.e. an exception that caused this one to be thrown.

Author:
Drew Varner(Drew.Varner atDomain sc.edu)
See Also:
Serialized Form

Constructor Summary
IllegalPropertySetDataException()
Constructor
IllegalPropertySetDataException(java.lang.String msg)
Constructor
IllegalPropertySetDataException(java.lang.String msg, java.lang.Throwable reason)
Constructor
IllegalPropertySetDataException(java.lang.Throwable reason)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.HPSFRuntimeException
getReason, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalPropertySetDataException

public IllegalPropertySetDataException()

Constructor

IllegalPropertySetDataException

public IllegalPropertySetDataException(java.lang.String msg)

Constructor

Parameters:
msg - The exception's message string

IllegalPropertySetDataException

public IllegalPropertySetDataException(java.lang.Throwable reason)

Constructor

Parameters:
reason - This exception's underlying reason

IllegalPropertySetDataException

public IllegalPropertySetDataException(java.lang.String msg,
                                       java.lang.Throwable reason)

Constructor

Parameters:
msg - The exception's message string
reason - This exception's underlying reason
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IllegalVariantTypeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class IllegalVariantTypeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.VariantTypeException
                    extended by  org.apache.poi.hpsf.IllegalVariantTypeException
All Implemented Interfaces:
java.io.Serializable
public class IllegalVariantTypeException
extends VariantTypeException

This exception is thrown if HPSF encounters a variant type that is illegal in the current context.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
IllegalVariantTypeException(long variantType, java.lang.Object value)
Constructor
IllegalVariantTypeException(long variantType, java.lang.Object value, java.lang.String msg)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.VariantTypeException
getValue, getVariantType
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalVariantTypeException

public IllegalVariantTypeException(long variantType,
                                   java.lang.Object value,
                                   java.lang.String msg)

Constructor

Parameters:
variantType - The unsupported variant type
value - The value
msg - A message string

IllegalVariantTypeException

public IllegalVariantTypeException(long variantType,
                                   java.lang.Object value)

Constructor

Parameters:
variantType - The unsupported variant type
value - The value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MarkUnsupportedException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class MarkUnsupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.MarkUnsupportedException
All Implemented Interfaces:
java.io.Serializable
public class MarkUnsupportedException
extends HPSFException

This exception is thrown if an InputStream does not support the InputStream.mark(int) operation.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
MarkUnsupportedException()
Constructor
MarkUnsupportedException(java.lang.String msg)
Constructor
MarkUnsupportedException(java.lang.String msg, java.lang.Throwable reason)
Constructor
MarkUnsupportedException(java.lang.Throwable reason)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MarkUnsupportedException

public MarkUnsupportedException()

Constructor

MarkUnsupportedException

public MarkUnsupportedException(java.lang.String msg)

Constructor

Parameters:
msg - The exception's message string

MarkUnsupportedException

public MarkUnsupportedException(java.lang.Throwable reason)

Constructor

Parameters:
reason - This exception's underlying reason

MarkUnsupportedException

public MarkUnsupportedException(java.lang.String msg,
                                java.lang.Throwable reason)

Constructor

Parameters:
msg - The exception's message string
reason - This exception's underlying reason
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MissingSectionException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class MissingSectionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hpsf.HPSFRuntimeException
                    extended by  org.apache.poi.hpsf.MissingSectionException
All Implemented Interfaces:
java.io.Serializable
public class MissingSectionException
extends HPSFRuntimeException

This exception is thrown if one of the PropertySet's convenience methods does not find a required Section.

The constructors of this class are analogous to those of its superclass and documented there.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
MissingSectionException()
Constructor
MissingSectionException(java.lang.String msg)
Constructor
MissingSectionException(java.lang.String msg, java.lang.Throwable reason)
Constructor
MissingSectionException(java.lang.Throwable reason)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.HPSFRuntimeException
getReason, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MissingSectionException

public MissingSectionException()

Constructor

MissingSectionException

public MissingSectionException(java.lang.String msg)

Constructor

Parameters:
msg - The exception's message string

MissingSectionException

public MissingSectionException(java.lang.Throwable reason)

Constructor

Parameters:
reason - This exception's underlying reason

MissingSectionException

public MissingSectionException(java.lang.String msg,
                               java.lang.Throwable reason)

Constructor

Parameters:
msg - The exception's message string
reason - This exception's underlying reason
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MutableProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class MutableProperty

java.lang.Object
    extended by  org.apache.poi.hpsf.Property
        extended by  org.apache.poi.hpsf.MutableProperty
Direct Known Subclasses:
CustomProperty
public class MutableProperty
extends Property

Adds writing capability to the Property class.

Please be aware that this class' functionality will be merged into the Property class at a later time, so the API will change.

Author:
Rainer Klute <klute@rainer-klute.de>

Field Summary
Fields inherited from class org.apache.poi.hpsf.Property
id, type, value
Constructor Summary
MutableProperty()
Creates an empty property.
MutableProperty(Property p)
Creates a MutableProperty as a copy of an existing Property.
Method Summary
void | setID(long id) Sets the property's ID.
void | setType(long type) Sets the property's type.
void | setValue(java.lang.Object value) Sets the property's value.
int | write(java.io.OutputStream out, int codepage) Writes the property to an output stream.
Methods inherited from class org.apache.poi.hpsf.Property
equals, getID, getSize, getType, getValue, hashCode, readDictionary, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MutableProperty

public MutableProperty()

Creates an empty property. It must be filled using the set method to be usable.

MutableProperty

public MutableProperty(Property p)

Creates a MutableProperty as a copy of an existing Property.

Parameters:
p - The property to copy.
Method Detail

setID

public void setID(long id)

Sets the property's ID.

Parameters:
id - the ID

setType

public void setType(long type)

Sets the property's type.

Parameters:
type - the property's type

setValue

public void setValue(java.lang.Object value)

Sets the property's value.

Parameters:
value - the property's value

write

public int write(java.io.OutputStream out,
                 int codepage)
          throws java.io.IOException,
                 WritingNotSupportedException

Writes the property to an output stream.

Parameters:
out - The output stream to write to.
codepage - The codepage to use for writing non-wide strings
Returns:
the number of bytes written to the stream
Throws:
java.io.IOException - if an I/O error occurs
WritingNotSupportedException - if a variant type is to be written that is not yet supported
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MutablePropertySet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class MutablePropertySet

java.lang.Object
    extended by  org.apache.poi.hpsf.PropertySet
        extended by  org.apache.poi.hpsf.MutablePropertySet
Direct Known Subclasses:
SpecialPropertySet
public class MutablePropertySet
extends PropertySet

Adds writing support to the PropertySet class.

Please be aware that this class' functionality will be merged into the PropertySet class at a later time, so the API will change.

Author:
Rainer Klute <klute@rainer-klute.de>

Field Summary
Fields inherited from class org.apache.poi.hpsf.PropertySet
byteOrder, classID, format, OS_MACINTOSH, OS_WIN16, OS_WIN32, osVersion, sections
Constructor Summary
MutablePropertySet()
Constructs a MutablePropertySet instance.
MutablePropertySet(PropertySet ps)
Constructs a MutablePropertySet by doing a deep copy of an existing PropertySet.
Method Summary
void | addSection(Section section) Adds a section to this property set.
void | clearSections() Removes all sections from this property set.
void | setByteOrder(int byteOrder) Sets the "byteOrder" property.
void | setClassID(ClassID classID) Sets the property set stream's low-level "class ID" field.
void | setFormat(int format) Sets the "format" property.
void | setOSVersion(int osVersion) Sets the "osVersion" property.
java.io.InputStream | toInputStream() Returns the contents of this property set stream as an input stream.
void | write(DirectoryEntry dir, java.lang.String name) Writes a property set to a document in a POI filesystem directory.
void | write(java.io.OutputStream out) Writes the property set to an output stream.
Methods inherited from class org.apache.poi.hpsf.PropertySet
equals, getByteOrder, getClassID, getFirstSection, getFormat, getOSVersion, getProperties, getProperty, getPropertyBooleanValue, getPropertyIntValue, getSectionCount, getSections, getSingleSection, hashCode, isDocumentSummaryInformation, isPropertySetStream, isPropertySetStream, isSummaryInformation, toString, wasNull
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MutablePropertySet

public MutablePropertySet()

Constructs a MutablePropertySet instance. Its primary task is to initialize the immutable field with their proper values. It also sets fields that might change to reasonable defaults.

MutablePropertySet

public MutablePropertySet(PropertySet ps)

Constructs a MutablePropertySet by doing a deep copy of an existing PropertySet. All nested elements, i.e. Sections and Property instances, will be their mutable counterparts in the new MutablePropertySet.

Parameters:
ps - The property set to copy
Method Detail

setByteOrder

public void setByteOrder(int byteOrder)

Sets the "byteOrder" property.

Parameters:
byteOrder - the byteOrder value to set

setFormat

public void setFormat(int format)

Sets the "format" property.

Parameters:
format - the format value to set

setOSVersion

public void setOSVersion(int osVersion)

Sets the "osVersion" property.

Parameters:
osVersion - the osVersion value to set

setClassID

public void setClassID(ClassID classID)

Sets the property set stream's low-level "class ID" field.

Parameters:
classID - The property set stream's low-level "class ID" field.
See Also:
PropertySet.getClassID()

clearSections

public void clearSections()

Removes all sections from this property set.

addSection

public void addSection(Section section)

Adds a section to this property set.

Parameters:
section - The Section to add. It will be appended after any sections that are already present in the property set and thus become the last section.

write

public void write(java.io.OutputStream out)
           throws WritingNotSupportedException,
                  java.io.IOException

Writes the property set to an output stream.

Parameters:
out - the output stream to write the section to
Throws:
java.io.IOException - if an error when writing to the output stream occurs
WritingNotSupportedException - if HPSF does not yet support writing a property's variant type.

toInputStream

public java.io.InputStream toInputStream()
                                  throws java.io.IOException,
                                         WritingNotSupportedException

Returns the contents of this property set stream as an input stream. The latter can be used for example to write the property set into a POIFS document. The input stream represents a snapshot of the property set. If the latter is modified while the input stream is still being read, the modifications will not be reflected in the input stream but in the MutablePropertySet only.

Returns:
the contents of this property set stream
Throws:
WritingNotSupportedException - if HPSF does not yet support writing of a property's variant type.
java.io.IOException - if an I/O exception occurs.

write

public void write(DirectoryEntry dir,
                  java.lang.String name)
           throws WritingNotSupportedException,
                  java.io.IOException

Writes a property set to a document in a POI filesystem directory.

Parameters:
dir - The directory in the POI filesystem to write the document to.
name - The document's name. If there is already a document with the same name in the directory the latter will be overwritten.
Throws:
WritingNotSupportedException
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MutableSection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class MutableSection

java.lang.Object
    extended by  org.apache.poi.hpsf.Section
        extended by  org.apache.poi.hpsf.MutableSection

public class MutableSection
extends Section

Adds writing capability to the Section class.

Please be aware that this class' functionality will be merged into the Section class at a later time, so the API will change.

Field Summary
Fields inherited from class org.apache.poi.hpsf.Section
dictionary, formatID, offset, properties, size
Constructor Summary
MutableSection()
Creates an empty mutable section.
MutableSection(Section s)
Constructs a MutableSection by doing a deep copy of an existing Section.
Method Summary
void | clear() Removes all properties from the section including 0 (dictionary) and 1 (codepage).
Property[] | getProperties() Gets this section's properties.
java.lang.Object | getProperty(long id) Gets a property.
int | getPropertyCount() Overwrites the super class' method to cope with a redundancy: the property count is maintained in a separate member variable, but shouldn't.
int | getSize() Returns the section's size.
void | removeProperty(long id) Removes a property.
void | setCodepage(int codepage) Sets the codepage.
void | setDictionary(java.util.Map<java.lang.Long,java.lang.String> dictionary) Sets the section's dictionary.
void | setFormatID(byte[] formatID) Sets the section's format ID.
void | setFormatID(ClassID formatID) Sets the section's format ID.
void | setProperties(Property[] properties) Sets this section's properties.
void | setProperty(int id, boolean value) Sets the boolean value of the property with the specified ID.
void | setProperty(int id, int value) Sets the int value of the property with the specified ID.
void | setProperty(int id, long value) Sets the long value of the property with the specified ID.
void | setProperty(int id, long variantType, java.lang.Object value) Sets the value and the variant type of the property with the specified ID.
void | setProperty(int id, java.lang.Object value) Sets a property.
void | setProperty(int id, java.lang.String value) Sets the string value of the property with the specified ID.
void | setProperty(Property p) Sets a property.
protected void | setPropertyBooleanValue(int id, boolean value) Sets the value of the boolean property with the specified ID.
int | write(java.io.OutputStream out) Writes this section into an output stream.
Methods inherited from class org.apache.poi.hpsf.Section
equals, getCodepage, getDictionary, getFormatID, getOffset, getPIDString, getPropertyBooleanValue, getPropertyIntValue, hashCode, toString, wasNull
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MutableSection

public MutableSection()

Creates an empty mutable section.

MutableSection

public MutableSection(Section s)

Constructs a MutableSection by doing a deep copy of an existing Section. All nested Property instances, will be their mutable counterparts in the new MutableSection.

Parameters:
s - The section set to copy
Method Detail

setFormatID

public void setFormatID(ClassID formatID)

Sets the section's format ID.

Parameters:
formatID - The section's format ID
See Also:
setFormatID(byte[]), Section.getFormatID()

setFormatID

public void setFormatID(byte[] formatID)

Sets the section's format ID.

Parameters:
formatID - The section's format ID as a byte array. It components are in big-endian format.
See Also:
setFormatID(ClassID), Section.getFormatID()

setProperties

public void setProperties(Property[] properties)

Sets this section's properties. Any former values are overwritten.

Parameters:
properties - This section's new properties.

setProperty

public void setProperty(int id,
                        java.lang.String value)

Sets the string value of the property with the specified ID.

Parameters:
id - The property's ID
value - The property's value. It will be written as a Unicode string.
See Also:
setProperty(int, long, Object), getProperty(long)

setProperty

public void setProperty(int id,
                        int value)

Sets the int value of the property with the specified ID.

Parameters:
id - The property's ID
value - The property's value.
See Also:
setProperty(int, long, Object), getProperty(long)

setProperty

public void setProperty(int id,
                        long value)

Sets the long value of the property with the specified ID.

Parameters:
id - The property's ID
value - The property's value.
See Also:
setProperty(int, long, Object), getProperty(long)

setProperty

public void setProperty(int id,
                        boolean value)

Sets the boolean value of the property with the specified ID.

Parameters:
id - The property's ID
value - The property's value.
See Also:
setProperty(int, long, Object), getProperty(long)

setProperty

public void setProperty(int id,
                        long variantType,
                        java.lang.Object value)

Sets the value and the variant type of the property with the specified ID. If a property with this ID is not yet present in the section, it will be added. An already present property with the specified ID will be overwritten. A default mapping will be used to choose the property's type.

Parameters:
id - The property's ID.
variantType - The property's variant type.
value - The property's value.
See Also:
setProperty(int, String), getProperty(long), Variant

setProperty

public void setProperty(Property p)

Sets a property.

Parameters:
p - The property to be set.
See Also:
setProperty(int, long, Object), getProperty(long), Variant

removeProperty

public void removeProperty(long id)

Removes a property.

Parameters:
id - The ID of the property to be removed

setPropertyBooleanValue

protected void setPropertyBooleanValue(int id,
                                       boolean value)

Sets the value of the boolean property with the specified ID.

Parameters:
id - The property's ID
value - The property's value
See Also:
setProperty(int, long, Object), getProperty(long), Variant

getSize

public int getSize()

Returns the section's size.

Overrides:
getSize in class Section
Returns:
the section's size.

write

public int write(java.io.OutputStream out)
          throws WritingNotSupportedException,
                 java.io.IOException

Writes this section into an output stream.

Internally this is done by writing into three byte array output streams: one for the properties, one for the property list and one for the section as such. The two former are appended to the latter when they have received all their data.

Parameters:
out - The stream to write into.
Returns:
The number of bytes written, i.e. the section's size.
Throws:
java.io.IOException - if an I/O error occurs
WritingNotSupportedException - if HPSF does not yet support writing a property's variant type.

getPropertyCount

public int getPropertyCount()

Overwrites the super class' method to cope with a redundancy: the property count is maintained in a separate member variable, but shouldn't.

Overrides:
getPropertyCount in class Section
Returns:
The number of properties in this section

getProperties

public Property[] getProperties()

Gets this section's properties.

Overrides:
getProperties in class Section
Returns:
this section's properties.

getProperty

public java.lang.Object getProperty(long id)

Gets a property.

Overrides:
getProperty in class Section
Parameters:
id - The ID of the property to get
Returns:
The property or null if there is no such property

setDictionary

public void setDictionary(java.util.Map<java.lang.Long,java.lang.String> dictionary)
                   throws IllegalPropertySetDataException

Sets the section's dictionary. All keys in the dictionary must be Long instances, all values must be Strings. This method overwrites the properties with IDs 0 and 1 since they are reserved for the dictionary and the dictionary's codepage. Setting these properties explicitly might have surprising effects. An application should never do this but always use this method.

Parameters:
dictionary - The dictionary
Throws:
IllegalPropertySetDataException - if the dictionary's key and value types are not correct.
See Also:
Section.getDictionary()

setProperty

public void setProperty(int id,
                        java.lang.Object value)

Sets a property.

Parameters:
id - The property ID.
value - The property's value. The value's class must be one of those supported by HPSF.

clear

public void clear()

Removes all properties from the section including 0 (dictionary) and 1 (codepage).

setCodepage

public void setCodepage(int codepage)

Sets the codepage.

Parameters:
codepage - the codepage
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoFormatIDException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class NoFormatIDException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hpsf.HPSFRuntimeException
                    extended by  org.apache.poi.hpsf.NoFormatIDException
All Implemented Interfaces:
java.io.Serializable
public class NoFormatIDException
extends HPSFRuntimeException

This exception is thrown if a MutablePropertySet is to be written but does not have a formatID set (see MutableSection.setFormatID(ClassID) or MutableSection.setFormatID(byte[]).

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
NoFormatIDException()
Constructor
NoFormatIDException(java.lang.String msg)
Constructor
NoFormatIDException(java.lang.String msg, java.lang.Throwable reason)
Constructor
NoFormatIDException(java.lang.Throwable reason)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.HPSFRuntimeException
getReason, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoFormatIDException

public NoFormatIDException()

Constructor

NoFormatIDException

public NoFormatIDException(java.lang.String msg)

Constructor

Parameters:
msg - The exception's message string

NoFormatIDException

public NoFormatIDException(java.lang.Throwable reason)

Constructor

Parameters:
reason - This exception's underlying reason

NoFormatIDException

public NoFormatIDException(java.lang.String msg,
                           java.lang.Throwable reason)

Constructor

Parameters:
msg - The exception's message string
reason - This exception's underlying reason
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoPropertySetStreamException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class NoPropertySetStreamException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.NoPropertySetStreamException
All Implemented Interfaces:
java.io.Serializable
public class NoPropertySetStreamException
extends HPSFException

This exception is thrown if a format error in a property set stream is detected or when the input data do not constitute a property set stream.

The constructors of this class are analogous to those of its superclass and are documented there.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
NoPropertySetStreamException()
Constructor
NoPropertySetStreamException(java.lang.String msg)
Constructor
NoPropertySetStreamException(java.lang.String msg, java.lang.Throwable reason)
Constructor
NoPropertySetStreamException(java.lang.Throwable reason)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoPropertySetStreamException

public NoPropertySetStreamException()

Constructor

NoPropertySetStreamException

public NoPropertySetStreamException(java.lang.String msg)

Constructor

Parameters:
msg - The exception's message string

NoPropertySetStreamException

public NoPropertySetStreamException(java.lang.Throwable reason)

Constructor

Parameters:
reason - This exception's underlying reason

NoPropertySetStreamException

public NoPropertySetStreamException(java.lang.String msg,
                                    java.lang.Throwable reason)

Constructor

Parameters:
msg - The exception's message string
reason - This exception's underlying reason
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoSingleSectionException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class NoSingleSectionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hpsf.HPSFRuntimeException
                    extended by  org.apache.poi.hpsf.NoSingleSectionException
All Implemented Interfaces:
java.io.Serializable
public class NoSingleSectionException
extends HPSFRuntimeException

This exception is thrown if one of the PropertySet's convenience methods that require a single Section is called and the PropertySet does not contain exactly one Section.

The constructors of this class are analogous to those of its superclass and documented there.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
NoSingleSectionException()
Constructor
NoSingleSectionException(java.lang.String msg)
Constructor
NoSingleSectionException(java.lang.String msg, java.lang.Throwable reason)
Constructor
NoSingleSectionException(java.lang.Throwable reason)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.HPSFRuntimeException
getReason, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSingleSectionException

public NoSingleSectionException()

Constructor

NoSingleSectionException

public NoSingleSectionException(java.lang.String msg)

Constructor

Parameters:
msg - The exception's message string

NoSingleSectionException

public NoSingleSectionException(java.lang.Throwable reason)

Constructor

Parameters:
reason - This exception's underlying reason

NoSingleSectionException

public NoSingleSectionException(java.lang.String msg,
                                java.lang.Throwable reason)

Constructor

Parameters:
msg - The exception's message string
reason - This exception's underlying reason
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hpsf
Classes
ClassID
Constants
CustomProperties
CustomProperty
DocumentSummaryInformation
MutableProperty
MutablePropertySet
MutableSection
Property
PropertySet
PropertySetFactory
Section
SpecialPropertySet
SummaryInformation
Thumbnail
TypeWriter
Util
Variant
VariantSupport
Exceptions
HPSFException
HPSFRuntimeException
IllegalPropertySetDataException
IllegalVariantTypeException
MarkUnsupportedException
MissingSectionException
NoFormatIDException
NoPropertySetStreamException
NoSingleSectionException
ReadingNotSupportedException
UnexpectedPropertySetTypeException
UnsupportedVariantTypeException
VariantTypeException
WritingNotSupportedException


org.apache.poi.hpsf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpsf

See:
Description

Class Summary
ClassID | Represents a class ID (16 bytes).
Constants | Defines constants of general use.
CustomProperties | Maintains the instances of CustomProperty that belong to a DocumentSummaryInformation.
CustomProperty | This class represents custom properties in the document summary information stream.
DocumentSummaryInformation | Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
MutableProperty | Adds writing capability to the Property class.
MutablePropertySet | Adds writing support to the PropertySet class.
MutableSection | Adds writing capability to the Section class.
Property | A property in a Section of a PropertySet.
PropertySet | Represents a property set in the Horrible Property Set Format (HPSF).
PropertySetFactory | Factory class to create instances of SummaryInformation, DocumentSummaryInformation and PropertySet.
Section | Represents a section in a PropertySet.
SpecialPropertySet | Abstract superclass for the convenience classes SummaryInformation and DocumentSummaryInformation.
SummaryInformation | Convenience class representing a Summary Information stream in a Microsoft Office document.
Thumbnail | Class to manipulate data in the Clipboard Variant (VT_CF) format.
TypeWriter | Class for writing little-endian data and more.
Util | Provides various static utility methods.
Variant | The Variant types as defined by Microsoft's COM.
VariantSupport | Supports reading and writing of variant data.

Exception Summary
HPSFException | This exception is the superclass of all other checked exceptions thrown in this package.
HPSFRuntimeException | This exception is the superclass of all other unchecked exceptions thrown in this package.
IllegalPropertySetDataException | This exception is thrown when there is an illegal value set in a PropertySet.
IllegalVariantTypeException | This exception is thrown if HPSF encounters a variant type that is illegal in the current context.
MarkUnsupportedException | This exception is thrown if an InputStream does not support the InputStream.mark(int) operation.
MissingSectionException | This exception is thrown if one of the PropertySet's convenience methods does not find a required Section.
NoFormatIDException | This exception is thrown if a MutablePropertySet is to be written but does not have a formatID set (see MutableSection.setFormatID(ClassID) or MutableSection.setFormatID(byte[]).
NoPropertySetStreamException | This exception is thrown if a format error in a property set stream is detected or when the input data do not constitute a property set stream.
NoSingleSectionException | This exception is thrown if one of the PropertySet's convenience methods that require a single Section is called and the PropertySet does not contain exactly one Section.
ReadingNotSupportedException | This exception is thrown when HPSF tries to read a (yet) unsupported variant type.
UnexpectedPropertySetTypeException | This exception is thrown if a certain type of property set is expected (e.g.
UnsupportedVariantTypeException | This exception is thrown if HPSF encounters a variant type that isn't supported yet.
VariantTypeException | This exception is thrown if HPSF encounters a problem with a variant type.
WritingNotSupportedException | This exception is thrown when trying to write a (yet) unsupported variant type.

Package org.apache.poi.hpsf Description

Processes streams in the Horrible Property Set Format (HPSF) in POI filesystems. Microsoft Office documents, i.e. POI filesystems, usually contain meta data like author, title, last saving time etc. These items are called properties and stored in property set streams along with the document itself. These streams are commonly named \005SummaryInformation and \005DocumentSummaryInformation. However, a POI filesystem may contain further property sets of other names or types.

In order to extract the properties from a POI filesystem, a property set stream's contents must be parsed into a PropertySet instance. Its subclasses SummaryInformation and DocumentSummaryInformation deal with the well-known property set streams \005SummaryInformation and \005DocumentSummaryInformation. (However, the streams' names are irrelevant. What counts is the property set's first section's format ID - see below.)

The factory method PropertySetFactory.create(java.io.InputStream) creates a PropertySet instance. This method always returns the most specific property set: If it identifies the stream data as a Summary Information or as a Document Summary Information it returns an instance of the corresponding class, else the general PropertySet.

A PropertySet contains a list of Sections which can be retrieved with PropertySet.getSections(). Each Section contains a Property array which can be retrieved with Section.getProperties(). Since the vast majority of PropertySets contains only a single Section, the convenience method PropertySet.getProperties() returns the properties of a PropertySet's Section (throwing a NoSingleSectionException if the PropertySet contains more (or less) than exactly one Section).

Each Property has an ID, a type, and a value which can be retrieved with Property.getID(), Property.getType(), and Property.getValue(), respectively. The value's class depends on the property's type. The current implementation does not yet support all property types and restricts the values' classes to String, Integer and Date. A value of a yet unknown type is returned as a byte array containing the value's origin bytes from the property set stream.

To retrieve the value of a specific Property, use Section.getProperty(long) or Section.getPropertyIntValue(long).

The SummaryInformation and DocumentSummaryInformation classes provide convenience methods for retrieving well-known properties. For example, an application that wants to retrieve a document's title string just calls SummaryInformation.getTitle() instead of going through the hassle of first finding out what the title's property ID is and then using this ID to get the property's value.

Writing properties can be done with the classes MutablePropertySet, MutableSection, and MutableProperty.

Public documentation from Microsoft can be found in the appropriate section of the MSDN Library.

History

2003-09-11:

PropertySetFactory.create(InputStream) no longer throws an UnexpectedPropertySetTypeException.

To Do

The following is still left to be implemented. Sponsering could foster these issues considerably.

  • Convenience methods for setting summary information and document summary information properties

  • Better codepage support

  • Support for more property (variant) types

Author:
Rainer Klute (klute@rainer-klute.de)


org.apache.poi.hpsf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpsf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • org.apache.poi.hpsf.CustomProperties
    • org.apache.poi.hpsf.ClassID
    • org.apache.poi.hpsf.Constants
    • org.apache.poi.hpsf.Property
      • org.apache.poi.hpsf.MutableProperty
        • org.apache.poi.hpsf.CustomProperty
    • org.apache.poi.hpsf.PropertySet
      • org.apache.poi.hpsf.MutablePropertySet
        • org.apache.poi.hpsf.SpecialPropertySet
          • org.apache.poi.hpsf.DocumentSummaryInformation
          • org.apache.poi.hpsf.SummaryInformation
    • org.apache.poi.hpsf.PropertySetFactory
    • org.apache.poi.hpsf.Section
      • org.apache.poi.hpsf.MutableSection
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.hpsf.HPSFException
          • org.apache.poi.hpsf.MarkUnsupportedException
          • org.apache.poi.hpsf.NoPropertySetStreamException
          • org.apache.poi.hpsf.UnexpectedPropertySetTypeException
          • org.apache.poi.hpsf.VariantTypeException
            • org.apache.poi.hpsf.IllegalVariantTypeException
            • org.apache.poi.hpsf.UnsupportedVariantTypeException
              • org.apache.poi.hpsf.ReadingNotSupportedException
              • org.apache.poi.hpsf.WritingNotSupportedException
        • java.lang.RuntimeException
          • org.apache.poi.hpsf.HPSFRuntimeException
            • org.apache.poi.hpsf.IllegalPropertySetDataException
            • org.apache.poi.hpsf.MissingSectionException
            • org.apache.poi.hpsf.NoFormatIDException
            • org.apache.poi.hpsf.NoSingleSectionException
    • org.apache.poi.hpsf.Thumbnail
    • org.apache.poi.hpsf.TypeWriter
    • org.apache.poi.hpsf.Util
    • org.apache.poi.hpsf.Variant
      • org.apache.poi.hpsf.VariantSupport


Uses of Package org.apache.poi.hpsf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpsf

Packages that use org.apache.poi.hpsf
org.apache.poi |
org.apache.poi.hpsf |
org.apache.poi.hssf.converter |
org.apache.poi.hssf.extractor |
org.apache.poi.hwpf.converter |
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.

Classes in org.apache.poi.hpsf used by org.apache.poi
DocumentSummaryInformation
Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
PropertySet
Represents a property set in the Horrible Property Set Format (HPSF).
SummaryInformation
Convenience class representing a Summary Information stream in a Microsoft Office document.

Classes in org.apache.poi.hpsf used by org.apache.poi.hpsf
ClassID
Represents a class ID (16 bytes).
CustomProperties
Maintains the instances of CustomProperty that belong to a DocumentSummaryInformation.
CustomProperty
This class represents custom properties in the document summary information stream.
DocumentSummaryInformation
Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
HPSFException
This exception is the superclass of all other checked exceptions thrown in this package.
HPSFRuntimeException
This exception is the superclass of all other unchecked exceptions thrown in this package.
IllegalPropertySetDataException
This exception is thrown when there is an illegal value set in a PropertySet.
MarkUnsupportedException
This exception is thrown if an InputStream does not support the InputStream.mark(int) operation.
MutableProperty
Adds writing capability to the Property class.
MutablePropertySet
Adds writing support to the PropertySet class.
NoPropertySetStreamException
This exception is thrown if a format error in a property set stream is detected or when the input data do not constitute a property set stream.
NoSingleSectionException
This exception is thrown if one of the PropertySet's convenience methods that require a single Section is called and the PropertySet does not contain exactly one Section.
Property
A property in a Section of a PropertySet.
PropertySet
Represents a property set in the Horrible Property Set Format (HPSF).
ReadingNotSupportedException
This exception is thrown when HPSF tries to read a (yet) unsupported variant type.
Section
Represents a section in a PropertySet.
SpecialPropertySet
Abstract superclass for the convenience classes SummaryInformation and DocumentSummaryInformation.
SummaryInformation
Convenience class representing a Summary Information stream in a Microsoft Office document.
UnexpectedPropertySetTypeException
This exception is thrown if a certain type of property set is expected (e.g.
UnsupportedVariantTypeException
This exception is thrown if HPSF encounters a variant type that isn't supported yet.
Variant
The Variant types as defined by Microsoft's COM.
VariantTypeException
This exception is thrown if HPSF encounters a problem with a variant type.
WritingNotSupportedException
This exception is thrown when trying to write a (yet) unsupported variant type.

Classes in org.apache.poi.hpsf used by org.apache.poi.hssf.converter
SummaryInformation
Convenience class representing a Summary Information stream in a Microsoft Office document.

Classes in org.apache.poi.hpsf used by org.apache.poi.hssf.extractor
DocumentSummaryInformation
Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
SummaryInformation
Convenience class representing a Summary Information stream in a Microsoft Office document.

Classes in org.apache.poi.hpsf used by org.apache.poi.hwpf.converter
SummaryInformation
Convenience class representing a Summary Information stream in a Microsoft Office document.

Classes in org.apache.poi.hpsf used by org.apache.poi.poifs.filesystem
ClassID
Represents a class ID (16 bytes).

Classes in org.apache.poi.hpsf used by org.apache.poi.poifs.property
ClassID
Represents a class ID (16 bytes).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Property

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class Property

java.lang.Object
    extended by  org.apache.poi.hpsf.Property
Direct Known Subclasses:
MutableProperty
public class Property
extends java.lang.Object

A property in a Section of a PropertySet.

The property's ID gives the property a meaning in the context of its Section. Each Section spans its own name space of property IDs.

The property's type determines how its value is interpreted. For example, if the type is Variant.VT_LPSTR (byte string), the value consists of a DWord telling how many bytes the string contains. The bytes follow immediately, including any null bytes that terminate the string. The type Variant.VT_I4 denotes a four-byte integer value, Variant.VT_FILETIME some date and time (of a file).

Please note that not all Variant types yet. This might change over time but largely depends on your feedback so that the POI team knows which variant types are really needed. So please feel free to submit error reports or patches for the types you need.

Microsoft documentation: Property Set Display Name Dictionary.

Author:
Rainer Klute <klute@rainer-klute.de>, Drew Varner (Drew.Varner InAndAround sc.edu)
See Also:
Section, Variant

Field Summary
protected long | id The property's ID.
protected long | type The property's type.
protected java.lang.Object | value The property's value.
Constructor Summary
protected | Property() Creates an empty property.
 | Property(long id, byte[] src, long offset, int length, int codepage) Creates a Property instance by reading its bytes from the property set stream.
 | Property(long id, long type, java.lang.Object value) Creates a property.
Method Summary
boolean | equals(java.lang.Object o) Compares two properties.
long | getID() Returns the property's ID.
protected int | getSize() Returns the property's size in bytes.
long | getType() Returns the property's type.
java.lang.Object | getValue() Returns the property's value.
int | hashCode()
protected java.util.Map<?,?> | readDictionary(byte[] src, long offset, int length, int codepage) Reads a dictionary.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

id

protected long id

The property's ID.

type

protected long type

The property's type.

value

protected java.lang.Object value

The property's value.

Constructor Detail

Property

public Property(long id,
                long type,
                java.lang.Object value)

Creates a property.

Parameters:
id - the property's ID.
type - the property's type, see Variant.
value - the property's value. Only certain types are allowed, see Variant.

Property

public Property(long id,
                byte[] src,
                long offset,
                int length,
                int codepage)
         throws java.io.UnsupportedEncodingException

Creates a Property instance by reading its bytes from the property set stream.

Parameters:
id - The property's ID.
src - The bytes the property set stream consists of.
offset - The property's type/value pair's offset in the section.
length - The property's type/value pair's length in bytes.
codepage - The section's and thus the property's codepage. It is needed only when reading string values.
Throws:
java.io.UnsupportedEncodingException - if the specified codepage is not supported.

Property

protected Property()

Creates an empty property. It must be filled using the set method to be usable.

Method Detail

getID

public long getID()

Returns the property's ID.

Returns:
The ID value

getType

public long getType()

Returns the property's type.

Returns:
The type value

getValue

public java.lang.Object getValue()

Returns the property's value.

Returns:
The property's value

readDictionary

protected java.util.Map<?,?> readDictionary(byte[] src,
                                            long offset,
                                            int length,
                                            int codepage)
                                     throws java.io.UnsupportedEncodingException

Reads a dictionary.

Parameters:
src - The byte array containing the bytes making out the dictionary.
offset - At this offset within src the dictionary starts.
length - The dictionary contains at most this many bytes.
codepage - The codepage of the string values.
Returns:
The dictonary
Throws:
java.io.UnsupportedEncodingException - if the dictionary's codepage is not (yet) supported.

getSize

protected int getSize()
               throws WritingNotSupportedException

Returns the property's size in bytes. This is always a multiple of 4.

Returns:
the property's size in bytes
Throws:
WritingNotSupportedException - if HPSF does not yet support the property's variant type.

equals

public boolean equals(java.lang.Object o)

Compares two properties.

Please beware that a property with ID == 0 is a special case: It does not have a type, and its value is the section's dictionary. Another special case are strings: Two properties may have the different types Variant.VT_LPSTR and Variant.VT_LPWSTR;

Overrides:
equals in class java.lang.Object
See Also:
Object.equals(java.lang.Object)

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
See Also:
Object.hashCode()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
See Also:
Object.toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertySet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class PropertySet

java.lang.Object
    extended by  org.apache.poi.hpsf.PropertySet
Direct Known Subclasses:
MutablePropertySet
public class PropertySet
extends java.lang.Object

Represents a property set in the Horrible Property Set Format (HPSF). These are usually metadata of a Microsoft Office document.

An application that wants to access these metadata should create an instance of this class or one of its subclasses by calling the factory method PropertySetFactory.create(java.io.InputStream) and then retrieve the information its needs by calling appropriate methods.

PropertySetFactory.create(java.io.InputStream) does its work by calling one of the constructors PropertySet(InputStream) or PropertySet(byte[]). If the constructor's argument is not in the Horrible Property Set Format, i.e. not a property set stream, or if any other error occurs, an appropriate exception is thrown.

A PropertySet has a list of Sections, and each Section has a Property array. Use getSections() to retrieve the Sections, then call Section.getProperties() for each Section to get hold of the Property arrays.

Since the vast majority of PropertySets contains only a single Section, the convenience method getProperties() returns the properties of a PropertySet's Section (throwing a NoSingleSectionException if the PropertySet contains more (or less) than exactly one Section).

Author:
Rainer Klute <klute@rainer-klute.de>, Drew Varner (Drew.Varner hanginIn sc.edu)

Field Summary
protected int | byteOrder Specifies this PropertySet's byte order.
protected ClassID | classID Specifies this PropertySet's "classID" field.
protected int | format Specifies this PropertySet's format.
static int | OS_MACINTOSH If the OS version field holds this value the property set stream was created on a Macintosh system.
static int | OS_WIN16 If the OS version field holds this value the property set stream was created on a 16-bit Windows system.
static int | OS_WIN32 If the OS version field holds this value the property set stream was created on a 32-bit Windows system.
protected int | osVersion Specifies the version of the operating system that created this PropertySet.
protected java.util.List<Section> | sections The sections in this PropertySet.
Constructor Summary
protected | PropertySet() Creates an empty (uninitialized) PropertySet.
 | PropertySet(byte[] stream) Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.
 | PropertySet(byte[] stream, int offset, int length) Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.
 | PropertySet(java.io.InputStream stream) Creates a PropertySet instance from an InputStream in the Horrible Property Set Format.
Method Summary
boolean | equals(java.lang.Object o) Returns true if the PropertySet is equal to the specified parameter, else false.
int | getByteOrder() Returns the property set stream's low-level "byte order" field.
ClassID | getClassID() Returns the property set stream's low-level "class ID" field.
Section | getFirstSection() Gets the PropertySet's first section.
int | getFormat() Returns the property set stream's low-level "format" field.
int | getOSVersion() Returns the property set stream's low-level "OS version" field.
Property[] | getProperties() Convenience method returning the Property array contained in this property set.
protected java.lang.Object | getProperty(int id) Convenience method returning the value of the property with the specified ID.
protected boolean | getPropertyBooleanValue(int id) Convenience method returning the value of a boolean property with the specified ID.
protected int | getPropertyIntValue(int id) Convenience method returning the value of the numeric property with the specified ID.
int | getSectionCount() Returns the number of Sections in the property set.
java.util.List<Section> | getSections() Returns the Sections in the property set.
Section | getSingleSection() If the PropertySet has only a single section this method returns it.
int | hashCode()
boolean | isDocumentSummaryInformation() Checks whether this PropertySet is a Document Summary Information.
static boolean | isPropertySetStream(byte[] src, int offset, int length) Checks whether a byte array is in the Horrible Property Set Format.
static boolean | isPropertySetStream(java.io.InputStream stream) Checks whether an InputStream is in the Horrible Property Set Format.
boolean | isSummaryInformation() Checks whether this PropertySet represents a Summary Information.
java.lang.String | toString()
boolean | wasNull() Checks whether the property which the last call to getPropertyIntValue(int) or getProperty(int) tried to access was available or not.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

byteOrder

protected int byteOrder

Specifies this PropertySet's byte order. See the HPFS documentation for details!

format

protected int format

Specifies this PropertySet's format. See the HPFS documentation for details!

osVersion

protected int osVersion

Specifies the version of the operating system that created this PropertySet. See the HPFS documentation for details!

OS_WIN16

public static final int OS_WIN16

If the OS version field holds this value the property set stream was created on a 16-bit Windows system.

See Also:
Constant Field Values

OS_MACINTOSH

public static final int OS_MACINTOSH

If the OS version field holds this value the property set stream was created on a Macintosh system.

See Also:
Constant Field Values

OS_WIN32

public static final int OS_WIN32

If the OS version field holds this value the property set stream was created on a 32-bit Windows system.

See Also:
Constant Field Values

classID

protected ClassID classID

Specifies this PropertySet's "classID" field. See the HPFS documentation for details!

sections

protected java.util.List<Section> sections

The sections in this PropertySet.

Constructor Detail

PropertySet

protected PropertySet()

Creates an empty (uninitialized) PropertySet.

Please note: For the time being this constructor is protected since it is used for internal purposes only, but expect it to become public once the property set's writing functionality is implemented.

PropertySet

public PropertySet(java.io.InputStream stream)
            throws NoPropertySetStreamException,
                   MarkUnsupportedException,
                   java.io.IOException,
                   java.io.UnsupportedEncodingException

Creates a PropertySet instance from an InputStream in the Horrible Property Set Format.

The constructor reads the first few bytes from the stream and determines whether it is really a property set stream. If it is, it parses the rest of the stream. If it is not, it resets the stream to its beginning in order to let other components mess around with the data and throws an exception.

Parameters:
stream - Holds the data making out the property set stream.
Throws:
MarkUnsupportedException - if the stream does not support the InputStream.markSupported() method.
java.io.IOException - if the InputStream cannot not be accessed as needed.
NoPropertySetStreamException - if the input stream does not contain a property set.
java.io.UnsupportedEncodingException - if a character encoding is not supported.

PropertySet

public PropertySet(byte[] stream,
                   int offset,
                   int length)
            throws NoPropertySetStreamException,
                   java.io.UnsupportedEncodingException

Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.

Parameters:
stream - The byte array holding the stream data.
offset - The offset in stream where the stream data begin. If the stream data begin with the first byte in the array, the offset is 0.
length - The length of the stream data.
Throws:
NoPropertySetStreamException - if the byte array is not a property set stream.
java.io.UnsupportedEncodingException - if the codepage is not supported.

PropertySet

public PropertySet(byte[] stream)
            throws NoPropertySetStreamException,
                   java.io.UnsupportedEncodingException

Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.

Parameters:
stream - The byte array holding the stream data. The complete byte array contents is the stream data.
Throws:
NoPropertySetStreamException - if the byte array is not a property set stream.
java.io.UnsupportedEncodingException - if the codepage is not supported.
Method Detail

getByteOrder

public int getByteOrder()

Returns the property set stream's low-level "byte order" field. It is always 0xFFFE .

Returns:
The property set stream's low-level "byte order" field.

getFormat

public int getFormat()

Returns the property set stream's low-level "format" field. It is always 0x0000 .

Returns:
The property set stream's low-level "format" field.

getOSVersion

public int getOSVersion()

Returns the property set stream's low-level "OS version" field.

Returns:
The property set stream's low-level "OS version" field.

getClassID

public ClassID getClassID()

Returns the property set stream's low-level "class ID" field.

Returns:
The property set stream's low-level "class ID" field.

getSectionCount

public int getSectionCount()

Returns the number of Sections in the property set.

Returns:
The number of Sections in the property set.

getSections

public java.util.List<Section> getSections()

Returns the Sections in the property set.

Returns:
The Sections in the property set.

isPropertySetStream

public static boolean isPropertySetStream(java.io.InputStream stream)
                                   throws MarkUnsupportedException,
                                          java.io.IOException

Checks whether an InputStream is in the Horrible Property Set Format.

Parameters:
stream - The InputStream to check. In order to perform the check, the method reads the first bytes from the stream. After reading, the stream is reset to the position it had before reading. The InputStream must support the InputStream.mark(int) method.
Returns:
true if the stream is a property set stream, else false.
Throws:
MarkUnsupportedException - if the InputStream does not support the InputStream.mark(int) method.
java.io.IOException - if an I/O error occurs

isPropertySetStream

public static boolean isPropertySetStream(byte[] src,
                                          int offset,
                                          int length)

Checks whether a byte array is in the Horrible Property Set Format.

Parameters:
src - The byte array to check.
offset - The offset in the byte array.
length - The significant number of bytes in the byte array. Only this number of bytes will be checked.
Returns:
true if the byte array is a property set stream, false if not.

isSummaryInformation

public boolean isSummaryInformation()

Checks whether this PropertySet represents a Summary Information.

Returns:
true if this PropertySet represents a Summary Information, else false.

isDocumentSummaryInformation

public boolean isDocumentSummaryInformation()

Checks whether this PropertySet is a Document Summary Information.

Returns:
true if this PropertySet represents a Document Summary Information, else false.

getProperties

public Property[] getProperties()
                         throws NoSingleSectionException

Convenience method returning the Property array contained in this property set. It is a shortcut for getting the PropertySet's Sections list and then getting the Property array from the first Section.

Returns:
The properties of the only Section of this PropertySet.
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.

getProperty

protected java.lang.Object getProperty(int id)
                                throws NoSingleSectionException

Convenience method returning the value of the property with the specified ID. If the property is not available, null is returned and a subsequent call to wasNull() will return true .

Parameters:
id - The property ID
Returns:
The property value
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.

getPropertyBooleanValue

protected boolean getPropertyBooleanValue(int id)
                                   throws NoSingleSectionException

Convenience method returning the value of a boolean property with the specified ID. If the property is not available, false is returned. A subsequent call to wasNull() will return true to let the caller distinguish that case from a real property value of false.

Parameters:
id - The property ID
Returns:
The property value
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.

getPropertyIntValue

protected int getPropertyIntValue(int id)
                           throws NoSingleSectionException

Convenience method returning the value of the numeric property with the specified ID. If the property is not available, 0 is returned. A subsequent call to wasNull() will return true to let the caller distinguish that case from a real property value of 0.

Parameters:
id - The property ID
Returns:
The propertyIntValue value
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.

wasNull

public boolean wasNull()
                throws NoSingleSectionException

Checks whether the property which the last call to getPropertyIntValue(int) or getProperty(int) tried to access was available or not. This information might be important for callers of getPropertyIntValue(int) since the latter returns 0 if the property does not exist. Using wasNull(), the caller can distiguish this case from a property's real value of 0.

Returns:
true if the last call to getPropertyIntValue(int) or getProperty(int) tried to access a property that was not available, else false.
Throws:
NoSingleSectionException - if the PropertySet has more than one Section.

getFirstSection

public Section getFirstSection()

Gets the PropertySet's first section.

Returns:
The PropertySet's first section.

getSingleSection

public Section getSingleSection()

If the PropertySet has only a single section this method returns it.

Returns:
The singleSection value

equals

public boolean equals(java.lang.Object o)

Returns true if the PropertySet is equal to the specified parameter, else false.

Overrides:
equals in class java.lang.Object
Parameters:
o - the object to compare this PropertySet with
Returns:
true if the objects are equal, false if not

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
See Also:
Object.hashCode()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
See Also:
Object.toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertySetFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class PropertySetFactory

java.lang.Object
    extended by  org.apache.poi.hpsf.PropertySetFactory

public class PropertySetFactory
extends java.lang.Object

Factory class to create instances of SummaryInformation, DocumentSummaryInformation and PropertySet.

Author:
Rainer Klute <klute@rainer-klute.de>

Constructor Summary
PropertySetFactory()
Method Summary
static PropertySet | create(java.io.InputStream stream) Creates the most specific PropertySet from an InputStream.
static DocumentSummaryInformation | newDocumentSummaryInformation() Creates a new document summary information.
static SummaryInformation | newSummaryInformation() Creates a new summary information.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertySetFactory

public PropertySetFactory()
Method Detail

create

public static PropertySet create(java.io.InputStream stream)
                          throws NoPropertySetStreamException,
                                 MarkUnsupportedException,
                                 java.io.UnsupportedEncodingException,
                                 java.io.IOException

Creates the most specific PropertySet from an InputStream. This is preferrably a DocumentSummaryInformation or a SummaryInformation. If the specified InputStream does not contain a property set stream, an exception is thrown and the InputStream is repositioned at its beginning.

Parameters:
stream - Contains the property set stream's data.
Returns:
The created PropertySet.
Throws:
NoPropertySetStreamException - if the stream does not contain a property set.
MarkUnsupportedException - if the stream does not support the mark operation.
java.io.IOException - if some I/O problem occurs.
java.io.UnsupportedEncodingException - if the specified codepage is not supported.

newSummaryInformation

public static SummaryInformation newSummaryInformation()

Creates a new summary information.

Returns:
the new summary information.

newDocumentSummaryInformation

public static DocumentSummaryInformation newDocumentSummaryInformation()

Creates a new document summary information.

Returns:
the new document summary information.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReadingNotSupportedException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class ReadingNotSupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.VariantTypeException
                    extended by  org.apache.poi.hpsf.UnsupportedVariantTypeException
                        extended by  org.apache.poi.hpsf.ReadingNotSupportedException
All Implemented Interfaces:
java.io.Serializable
public class ReadingNotSupportedException
extends UnsupportedVariantTypeException

This exception is thrown when HPSF tries to read a (yet) unsupported variant type.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
WritingNotSupportedException, UnsupportedVariantTypeException, Serialized Form

Constructor Summary
ReadingNotSupportedException(long variantType, java.lang.Object value)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.VariantTypeException
getValue, getVariantType
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReadingNotSupportedException

public ReadingNotSupportedException(long variantType,
                                    java.lang.Object value)

Constructor

Parameters:
variantType - The unsupported variant type.
value - The value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Section

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class Section

java.lang.Object
    extended by  org.apache.poi.hpsf.Section
Direct Known Subclasses:
MutableSection
public class Section
extends java.lang.Object

Represents a section in a PropertySet.

Author:
Rainer Klute <klute@rainer-klute.de>, Drew Varner (Drew.Varner allUpIn sc.edu)

Field Summary
protected java.util.Map<java.lang.Long,java.lang.String> | dictionary Maps property IDs to section-private PID strings.
protected ClassID | formatID The section's format ID, getFormatID().
protected long | offset
protected Property[] | properties
protected int | size
Constructor Summary
protected | Section() Creates an empty and uninitialized Section.
 | Section(byte[] src, int offset) Creates a Section instance from a byte array.
Method Summary
boolean | equals(java.lang.Object o) Checks whether this section is equal to another object.
int | getCodepage() Gets the section's codepage, if any.
java.util.Map<java.lang.Long,java.lang.String> | getDictionary() Gets the section's dictionary.
ClassID | getFormatID() Returns the format ID.
long | getOffset() Returns the offset of the section in the stream.
java.lang.String | getPIDString(long pid) Returns the PID string associated with a property ID.
Property[] | getProperties() Returns this section's properties.
java.lang.Object | getProperty(long id) Returns the value of the property with the specified ID.
protected boolean | getPropertyBooleanValue(int id) Returns the value of the boolean property with the specified ID.
int | getPropertyCount() Returns the number of properties in this section.
protected int | getPropertyIntValue(long id) Returns the value of the numeric property with the specified ID.
int | getSize() Returns the section's size in bytes.
int | hashCode()
java.lang.String | toString()
boolean | wasNull() Checks whether the property which the last call to getPropertyIntValue(long) or getProperty(long) tried to access was available or not.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

dictionary

protected java.util.Map<java.lang.Long,java.lang.String> dictionary

Maps property IDs to section-private PID strings. These strings can be found in the property with ID 0.

formatID

protected ClassID formatID

The section's format ID, getFormatID().

offset

protected long offset
See Also:
getOffset()

size

protected int size
See Also:
getSize()

properties

protected Property[] properties
See Also:
getProperties()
Constructor Detail

Section

protected Section()

Creates an empty and uninitialized Section.

Section

public Section(byte[] src,
               int offset)
        throws java.io.UnsupportedEncodingException

Creates a Section instance from a byte array.

Parameters:
src - Contains the complete property set stream.
offset - The position in the stream that points to the section's format ID.
Throws:
java.io.UnsupportedEncodingException - if the section's codepage is not supported.
Method Detail

getFormatID

public ClassID getFormatID()

Returns the format ID. The format ID is the "type" of the section. For example, if the format ID of the first Section contains the bytes specified by org.apache.poi.hpsf.wellknown.SectionIDMap.SUMMARY_INFORMATION_ID the section (and thus the property set) is a SummaryInformation.

Returns:
The format ID

getOffset

public long getOffset()

Returns the offset of the section in the stream.

Returns:
The offset of the section in the stream.

getSize

public int getSize()

Returns the section's size in bytes.

Returns:
The section's size in bytes.

getPropertyCount

public int getPropertyCount()

Returns the number of properties in this section.

Returns:
The number of properties in this section.

getProperties

public Property[] getProperties()

Returns this section's properties.

Returns:
This section's properties.

getProperty

public java.lang.Object getProperty(long id)

Returns the value of the property with the specified ID. If the property is not available, null is returned and a subsequent call to wasNull will return true.

Parameters:
id - The property's ID
Returns:
The property's value

getPropertyIntValue

protected int getPropertyIntValue(long id)

Returns the value of the numeric property with the specified ID. If the property is not available, 0 is returned. A subsequent call to wasNull will return true to let the caller distinguish that case from a real property value of 0.

Parameters:
id - The property's ID
Returns:
The property's value

getPropertyBooleanValue

protected boolean getPropertyBooleanValue(int id)

Returns the value of the boolean property with the specified ID. If the property is not available, false is returned. A subsequent call to wasNull will return true to let the caller distinguish that case from a real property value of false.

Parameters:
id - The property's ID
Returns:
The property's value

wasNull

public boolean wasNull()

Checks whether the property which the last call to getPropertyIntValue(long) or getProperty(long) tried to access was available or not. This information might be important for callers of getPropertyIntValue(long) since the latter returns 0 if the property does not exist. Using wasNull the caller can distiguish this case from a property's real value of 0.

Returns:
true if the last call to getPropertyIntValue(long) or getProperty(long) tried to access a property that was not available, else false.

getPIDString

public java.lang.String getPIDString(long pid)

Returns the PID string associated with a property ID. The ID is first looked up in the Section's private dictionary. If it is not found there, the method calls SectionIDMap.getPIDString(byte[], long).

Parameters:
pid - The property ID
Returns:
The property ID's string value

equals

public boolean equals(java.lang.Object o)

Checks whether this section is equal to another object. The result is false if one of the the following conditions holds:

  • The other object is not a Section.

  • The format IDs of the two sections are not equal.

  • The sections have a different number of properties. However, properties with ID 1 (codepage) are not counted.

  • The other object is not a Section.

  • The properties have different values. The order of the properties is irrelevant.

Overrides:
equals in class java.lang.Object
Parameters:
o - The object to compare this section with
Returns:
true if the objects are equal, false if not

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
See Also:
Object.hashCode()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
See Also:
Object.toString()

getDictionary

public java.util.Map<java.lang.Long,java.lang.String> getDictionary()

Gets the section's dictionary. A dictionary allows an application to use human-readable property names instead of numeric property IDs. It contains mappings from property IDs to their associated string values. The dictionary is stored as the property with ID 0. The codepage for the strings in the dictionary is defined by property with ID 1.

Returns:
the dictionary or null if the section does not have a dictionary.

getCodepage

public int getCodepage()

Gets the section's codepage, if any.

Returns:
The section's codepage if one is defined, else -1.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SpecialPropertySet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class SpecialPropertySet

java.lang.Object
    extended by  org.apache.poi.hpsf.PropertySet
        extended by  org.apache.poi.hpsf.MutablePropertySet
            extended by  org.apache.poi.hpsf.SpecialPropertySet
Direct Known Subclasses:
DocumentSummaryInformation, SummaryInformation
public abstract class SpecialPropertySet
extends MutablePropertySet

Abstract superclass for the convenience classes SummaryInformation and DocumentSummaryInformation.

The motivation behind this class is quite nasty if you look behind the scenes, but it serves the application programmer well by providing him with the easy-to-use SummaryInformation and DocumentSummaryInformation classes. When parsing the data a property set stream consists of (possibly coming from an InputStream) we want to read and process each byte only once. Since we don't know in advance which kind of property set we have, we can expect only the most general PropertySet. Creating a special subclass should be as easy as calling the special subclass' constructor and pass the general PropertySet in. To make things easy internally, the special class just holds a reference to the general PropertySet and delegates all method calls to it.

A cleaner implementation would have been like this: The PropertySetFactory parses the stream data into some internal object first. Then it finds out whether the stream is a SummaryInformation, a DocumentSummaryInformation or a general PropertySet. However, the current implementation went the other way round historically: the convenience classes came only late to my mind.

Author:
Rainer Klute <klute@rainer-klute.de>

Field Summary
Fields inherited from class org.apache.poi.hpsf.PropertySet
byteOrder, classID, format, OS_MACINTOSH, OS_WIN16, OS_WIN32, osVersion, sections
Constructor Summary
SpecialPropertySet(MutablePropertySet ps)
Creates a SpecialPropertySet.
SpecialPropertySet(PropertySet ps)
Creates a SpecialPropertySet.
Method Summary
 void addSection(Section section)
Adds a section to this property set.
 void clearSections()
Removes all sections from this property set.
 boolean equals(java.lang.Object o)
Returns true if the PropertySet is equal to the specified parameter, else false.
 int getByteOrder()
Returns the property set stream's low-level "byte order" field.
 ClassID getClassID()
Returns the property set stream's low-level "class ID" field.
 Section getFirstSection()
Gets the PropertySet's first section.
 int getFormat()
Returns the property set stream's low-level "format" field.
 int getOSVersion()
Returns the property set stream's low-level "OS version" field.
 Property[] getProperties()
Convenience method returning the Property array contained in this property set.
protected  java.lang.Object getProperty(int id)
Convenience method returning the value of the property with the specified ID.
protected  boolean getPropertyBooleanValue(int id)
Convenience method returning the value of a boolean property with the specified ID.
protected  int getPropertyIntValue(int id)
Convenience method returning the value of the numeric property with the specified ID.
abstract  PropertyIDMap getPropertySetIDMap()
The id to name mapping of the properties in this set.
 int getSectionCount()
Returns the number of Sections in the property set.
 java.util.List getSections()
Returns the Sections in the property set.
 int hashCode()
 boolean isDocumentSummaryInformation()
Checks whether this PropertySet is a Document Summary Information.
 boolean isSummaryInformation()
Checks whether this PropertySet represents a Summary Information.
 void setByteOrder(int byteOrder)
Sets the "byteOrder" property.
 void setClassID(ClassID classID)
Sets the property set stream's low-level "class ID" field.
 void setFormat(int format)
Sets the "format" property.
 void setOSVersion(int osVersion)
Sets the "osVersion" property.
 java.io.InputStream toInputStream()
Returns the contents of this property set stream as an input stream.
 java.lang.String toString()
 boolean wasNull()
Checks whether the property which the last call to PropertySet.getPropertyIntValue(int) or PropertySet.getProperty(int) tried to access was available or not.
 void write(DirectoryEntry dir, java.lang.String name)
Writes a property set to a document in a POI filesystem directory.
 void write(java.io.OutputStream out)
Writes the property set to an output stream.
Methods inherited from class org.apache.poi.hpsf.PropertySet
getSingleSection, isPropertySetStream, isPropertySetStream
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SpecialPropertySet

public SpecialPropertySet(PropertySet ps)

Creates a SpecialPropertySet.

Parameters:
ps - The property set to be encapsulated by the SpecialPropertySet

SpecialPropertySet

public SpecialPropertySet(MutablePropertySet ps)

Creates a SpecialPropertySet.

Parameters:
ps - The mutable property set to be encapsulated by the SpecialPropertySet
Method Detail

getPropertySetIDMap

public abstract PropertyIDMap getPropertySetIDMap()
The id to name mapping of the properties in this set.

getByteOrder

public int getByteOrder()
Description copied from class: PropertySet

Returns the property set stream's low-level "byte order" field. It is always 0xFFFE .

Overrides:
getByteOrder in class PropertySet
Returns:
The property set stream's low-level "byte order" field.
See Also:
PropertySet.getByteOrder()

getFormat

public int getFormat()
Description copied from class: PropertySet

Returns the property set stream's low-level "format" field. It is always 0x0000 .

Overrides:
getFormat in class PropertySet
Returns:
The property set stream's low-level "format" field.
See Also:
PropertySet.getFormat()

getOSVersion

public int getOSVersion()
Description copied from class: PropertySet

Returns the property set stream's low-level "OS version" field.

Overrides:
getOSVersion in class PropertySet
Returns:
The property set stream's low-level "OS version" field.
See Also:
PropertySet.getOSVersion()

getClassID

public ClassID getClassID()
Description copied from class: PropertySet

Returns the property set stream's low-level "class ID" field.

Overrides:
getClassID in class PropertySet
Returns:
The property set stream's low-level "class ID" field.
See Also:
PropertySet.getClassID()

getSectionCount

public int getSectionCount()
Description copied from class: PropertySet

Returns the number of Sections in the property set.

Overrides:
getSectionCount in class PropertySet
Returns:
The number of Sections in the property set.
See Also:
PropertySet.getSectionCount()

getSections

public java.util.List getSections()
Description copied from class: PropertySet

Returns the Sections in the property set.

Overrides:
getSections in class PropertySet
Returns:
The Sections in the property set.
See Also:
PropertySet.getSections()

isSummaryInformation

public boolean isSummaryInformation()
Description copied from class: PropertySet

Checks whether this PropertySet represents a Summary Information.

Overrides:
isSummaryInformation in class PropertySet
Returns:
true if this PropertySet represents a Summary Information, else false.
See Also:
PropertySet.isSummaryInformation()

isDocumentSummaryInformation

public boolean isDocumentSummaryInformation()
Description copied from class: PropertySet

Checks whether this PropertySet is a Document Summary Information.

Overrides:
isDocumentSummaryInformation in class PropertySet
Returns:
true if this PropertySet represents a Document Summary Information, else false.
See Also:
PropertySet.isDocumentSummaryInformation()

getFirstSection

public Section getFirstSection()
Description copied from class: PropertySet

Gets the PropertySet's first section.

Overrides:
getFirstSection in class PropertySet
Returns:
The PropertySet's first section.
See Also:
PropertySet.getSingleSection()

addSection

public void addSection(Section section)
Description copied from class: MutablePropertySet

Adds a section to this property set.

Overrides:
addSection in class MutablePropertySet
Parameters:
section - The Section to add. It will be appended after any sections that are already present in the property set and thus become the last section.
See Also:
MutablePropertySet.addSection(org.apache.poi.hpsf.Section)

clearSections

public void clearSections()
Description copied from class: MutablePropertySet

Removes all sections from this property set.

Overrides:
clearSections in class MutablePropertySet
See Also:
MutablePropertySet.clearSections()

setByteOrder

public void setByteOrder(int byteOrder)
Description copied from class: MutablePropertySet

Sets the "byteOrder" property.

Overrides:
setByteOrder in class MutablePropertySet
Parameters:
byteOrder - the byteOrder value to set
See Also:
MutablePropertySet.setByteOrder(int)

setClassID

public void setClassID(ClassID classID)
Description copied from class: MutablePropertySet

Sets the property set stream's low-level "class ID" field.

Overrides:
setClassID in class MutablePropertySet
Parameters:
classID - The property set stream's low-level "class ID" field.
See Also:
MutablePropertySet.setClassID(org.apache.poi.hpsf.ClassID)

setFormat

public void setFormat(int format)
Description copied from class: MutablePropertySet

Sets the "format" property.

Overrides:
setFormat in class MutablePropertySet
Parameters:
format - the format value to set
See Also:
MutablePropertySet.setFormat(int)

setOSVersion

public void setOSVersion(int osVersion)
Description copied from class: MutablePropertySet

Sets the "osVersion" property.

Overrides:
setOSVersion in class MutablePropertySet
Parameters:
osVersion - the osVersion value to set
See Also:
MutablePropertySet.setOSVersion(int)

toInputStream

public java.io.InputStream toInputStream()
                                  throws java.io.IOException,
                                         WritingNotSupportedException
Description copied from class: MutablePropertySet

Returns the contents of this property set stream as an input stream. The latter can be used for example to write the property set into a POIFS document. The input stream represents a snapshot of the property set. If the latter is modified while the input stream is still being read, the modifications will not be reflected in the input stream but in the MutablePropertySet only.

Overrides:
toInputStream in class MutablePropertySet
Returns:
the contents of this property set stream
Throws:
java.io.IOException - if an I/O exception occurs.
WritingNotSupportedException - if HPSF does not yet support writing of a property's variant type.
See Also:
MutablePropertySet.toInputStream()

write

public void write(DirectoryEntry dir,
                  java.lang.String name)
           throws WritingNotSupportedException,
                  java.io.IOException
Description copied from class: MutablePropertySet

Writes a property set to a document in a POI filesystem directory.

Overrides:
write in class MutablePropertySet
Parameters:
dir - The directory in the POI filesystem to write the document to.
name - The document's name. If there is already a document with the same name in the directory the latter will be overwritten.
Throws:
WritingNotSupportedException
java.io.IOException
See Also:
MutablePropertySet.write(org.apache.poi.poifs.filesystem.DirectoryEntry, java.lang.String)

write

public void write(java.io.OutputStream out)
           throws WritingNotSupportedException,
                  java.io.IOException
Description copied from class: MutablePropertySet

Writes the property set to an output stream.

Overrides:
write in class MutablePropertySet
Parameters:
out - the output stream to write the section to
Throws:
WritingNotSupportedException - if HPSF does not yet support writing a property's variant type.
java.io.IOException - if an error when writing to the output stream occurs
See Also:
MutablePropertySet.write(java.io.OutputStream)

equals

public boolean equals(java.lang.Object o)
Description copied from class: PropertySet

Returns true if the PropertySet is equal to the specified parameter, else false.

Overrides:
equals in class PropertySet
Parameters:
o - the object to compare this PropertySet with
Returns:
true if the objects are equal, false if not
See Also:
PropertySet.equals(java.lang.Object)

getProperties

public Property[] getProperties()
                         throws NoSingleSectionException
Description copied from class: PropertySet

Convenience method returning the Property array contained in this property set. It is a shortcut for getting the PropertySet's Sections list and then getting the Property array from the first Section.

Overrides:
getProperties in class PropertySet
Returns:
The properties of the only Section of this PropertySet.
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.
See Also:
PropertySet.getProperties()

getProperty

protected java.lang.Object getProperty(int id)
                                throws NoSingleSectionException
Description copied from class: PropertySet

Convenience method returning the value of the property with the specified ID. If the property is not available, null is returned and a subsequent call to PropertySet.wasNull() will return true .

Overrides:
getProperty in class PropertySet
Parameters:
id - The property ID
Returns:
The property value
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.
See Also:
PropertySet.getProperty(int)

getPropertyBooleanValue

protected boolean getPropertyBooleanValue(int id)
                                   throws NoSingleSectionException
Description copied from class: PropertySet

Convenience method returning the value of a boolean property with the specified ID. If the property is not available, false is returned. A subsequent call to PropertySet.wasNull() will return true to let the caller distinguish that case from a real property value of false.

Overrides:
getPropertyBooleanValue in class PropertySet
Parameters:
id - The property ID
Returns:
The property value
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.
See Also:
PropertySet.getPropertyBooleanValue(int)

getPropertyIntValue

protected int getPropertyIntValue(int id)
                           throws NoSingleSectionException
Description copied from class: PropertySet

Convenience method returning the value of the numeric property with the specified ID. If the property is not available, 0 is returned. A subsequent call to PropertySet.wasNull() will return true to let the caller distinguish that case from a real property value of 0.

Overrides:
getPropertyIntValue in class PropertySet
Parameters:
id - The property ID
Returns:
The propertyIntValue value
Throws:
NoSingleSectionException - if the PropertySet has more or less than one Section.
See Also:
PropertySet.getPropertyIntValue(int)

hashCode

public int hashCode()
Overrides:
hashCode in class PropertySet
See Also:
PropertySet.hashCode()

toString

public java.lang.String toString()
Overrides:
toString in class PropertySet
See Also:
PropertySet.toString()

wasNull

public boolean wasNull()
                throws NoSingleSectionException
Description copied from class: PropertySet

Checks whether the property which the last call to PropertySet.getPropertyIntValue(int) or PropertySet.getProperty(int) tried to access was available or not. This information might be important for callers of PropertySet.getPropertyIntValue(int) since the latter returns 0 if the property does not exist. Using PropertySet.wasNull(), the caller can distiguish this case from a property's real value of 0.

Overrides:
wasNull in class PropertySet
Returns:
true if the last call to PropertySet.getPropertyIntValue(int) or PropertySet.getProperty(int) tried to access a property that was not available, else false.
Throws:
NoSingleSectionException - if the PropertySet has more than one Section.
See Also:
PropertySet.wasNull()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SummaryInformation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class SummaryInformation

java.lang.Object
    extended by  org.apache.poi.hpsf.PropertySet
        extended by  org.apache.poi.hpsf.MutablePropertySet
            extended by  org.apache.poi.hpsf.SpecialPropertySet
                extended by  org.apache.poi.hpsf.SummaryInformation

public final class SummaryInformation
extends SpecialPropertySet

Convenience class representing a Summary Information stream in a Microsoft Office document.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
DocumentSummaryInformation

Field Summary
static java.lang.String DEFAULT_STREAM_NAME
The document name a summary information stream usually has in a POIFS filesystem.
Fields inherited from class org.apache.poi.hpsf.PropertySet
byteOrder, classID, format, OS_MACINTOSH, OS_WIN16, OS_WIN32, osVersion, sections
Constructor Summary
SummaryInformation(PropertySet ps)
Creates a SummaryInformation from a given PropertySet.
Method Summary
java.lang.String | getApplicationName() Returns the application name (or null).
java.lang.String | getAuthor() Returns the author (or null).
int | getCharCount() Returns the character count or 0 if the SummaryInformation does not contain a char count.
java.lang.String | getComments() Returns the comments (or null).
java.util.Date | getCreateDateTime() Returns the creation time (or null).
long | getEditTime() Returns the total time spent in editing the document (or 0).
java.lang.String | getKeywords() Returns the keywords (or null).
java.lang.String | getLastAuthor() Returns the last author (or null).
java.util.Date | getLastPrinted() Returns the last printed time (or null).
java.util.Date | getLastSaveDateTime() Returns the last save time (or null).
int | getPageCount() Returns the page count or 0 if the SummaryInformation does not contain a page count.
PropertyIDMap | getPropertySetIDMap() The id to name mapping of the properties in this set.
java.lang.String | getRevNumber() Returns the revision number (or null).
int | getSecurity() Returns a security code which is one of the following values:
java.lang.String | getSubject() Returns the subject (or null).
java.lang.String | getTemplate() Returns the template (or null).
byte[] | getThumbnail() Returns the thumbnail (or null) when this method is implemented.
java.lang.String | getTitle() Returns the title (or null).
int | getWordCount() Returns the word count or 0 if the SummaryInformation does not contain a word count.
void | removeApplicationName() Removes the application name.
void | removeAuthor() Removes the author.
void | removeCharCount() Removes the character count.
void | removeComments() Removes the comments.
void | removeCreateDateTime() Removes the creation time.
void | removeEditTime() Remove the total time spent in editing the document.
void | removeKeywords() Removes the keywords.
void | removeLastAuthor() Removes the last author.
void | removeLastPrinted() Removes the lastPrinted.
void | removeLastSaveDateTime() Remove the total time spent in editing the document.
void | removePageCount() Removes the page count.
void | removeRevNumber() Removes the revision number.
void | removeSecurity() Removes the security code.
void | removeSubject() Removes the subject.
void | removeTemplate() Removes the template.
void | removeThumbnail() Removes the thumbnail.
void | removeTitle() Removes the title.
void | removeWordCount() Removes the word count.
void | setApplicationName(java.lang.String applicationName) Sets the application name.
void | setAuthor(java.lang.String author) Sets the author.
void | setCharCount(int charCount) Sets the character count.
void | setComments(java.lang.String comments) Sets the comments.
void | setCreateDateTime(java.util.Date createDateTime) Sets the creation time.
void | setEditTime(long time) Sets the total time spent in editing the document.
void | setKeywords(java.lang.String keywords) Sets the keywords.
void | setLastAuthor(java.lang.String lastAuthor) Sets the last author.
void | setLastPrinted(java.util.Date lastPrinted) Sets the lastPrinted.
void | setLastSaveDateTime(java.util.Date time) Sets the total time spent in editing the document.
void | setPageCount(int pageCount) Sets the page count.
void | setRevNumber(java.lang.String revNumber) Sets the revision number.
void | setSecurity(int security) Sets the security code.
void | setSubject(java.lang.String subject) Sets the subject.
void | setTemplate(java.lang.String template) Sets the template.
void | setThumbnail(byte[] thumbnail) Sets the thumbnail.
void | setTitle(java.lang.String title) Sets the title.
void | setWordCount(int wordCount) Sets the word count.
Methods inherited from class org.apache.poi.hpsf.SpecialPropertySet
addSection, clearSections, equals, getByteOrder, getClassID, getFirstSection, getFormat, getOSVersion, getProperties, getProperty, getPropertyBooleanValue, getPropertyIntValue, getSectionCount, getSections, hashCode, isDocumentSummaryInformation, isSummaryInformation, setByteOrder, setClassID, setFormat, setOSVersion, toInputStream, toString, wasNull, write, write
Methods inherited from class org.apache.poi.hpsf.PropertySet
getSingleSection, isPropertySetStream, isPropertySetStream
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT_STREAM_NAME

public static final java.lang.String DEFAULT_STREAM_NAME

The document name a summary information stream usually has in a POIFS filesystem.

See Also:
Constant Field Values
Constructor Detail

SummaryInformation

public SummaryInformation(PropertySet ps)
                   throws UnexpectedPropertySetTypeException

Creates a SummaryInformation from a given PropertySet.

Parameters:
ps - A property set which should be created from a summary information stream.
Throws:
UnexpectedPropertySetTypeException - if ps does not contain a summary information stream.
Method Detail

getPropertySetIDMap

public PropertyIDMap getPropertySetIDMap()
Description copied from class: SpecialPropertySet
The id to name mapping of the properties in this set.

Specified by:
getPropertySetIDMap in class SpecialPropertySet

getTitle

public java.lang.String getTitle()

Returns the title (or null).

Returns:
The title or null

setTitle

public void setTitle(java.lang.String title)

Sets the title.

Parameters:
title - The title to set.

removeTitle

public void removeTitle()

Removes the title.

getSubject

public java.lang.String getSubject()

Returns the subject (or null).

Returns:
The subject or null

setSubject

public void setSubject(java.lang.String subject)

Sets the subject.

Parameters:
subject - The subject to set.

removeSubject

public void removeSubject()

Removes the subject.

getAuthor

public java.lang.String getAuthor()

Returns the author (or null).

Returns:
The author or null

setAuthor

public void setAuthor(java.lang.String author)

Sets the author.

Parameters:
author - The author to set.

removeAuthor

public void removeAuthor()

Removes the author.

getKeywords

public java.lang.String getKeywords()

Returns the keywords (or null).

Returns:
The keywords or null

setKeywords

public void setKeywords(java.lang.String keywords)

Sets the keywords.

Parameters:
keywords - The keywords to set.

removeKeywords

public void removeKeywords()

Removes the keywords.

getComments

public java.lang.String getComments()

Returns the comments (or null).

Returns:
The comments or null

setComments

public void setComments(java.lang.String comments)

Sets the comments.

Parameters:
comments - The comments to set.

removeComments

public void removeComments()

Removes the comments.

getTemplate

public java.lang.String getTemplate()

Returns the template (or null).

Returns:
The template or null

setTemplate

public void setTemplate(java.lang.String template)

Sets the template.

Parameters:
template - The template to set.

removeTemplate

public void removeTemplate()

Removes the template.

getLastAuthor

public java.lang.String getLastAuthor()

Returns the last author (or null).

Returns:
The last author or null

setLastAuthor

public void setLastAuthor(java.lang.String lastAuthor)

Sets the last author.

Parameters:
lastAuthor - The last author to set.

removeLastAuthor

public void removeLastAuthor()

Removes the last author.

getRevNumber

public java.lang.String getRevNumber()

Returns the revision number (or null).

Returns:
The revision number or null

setRevNumber

public void setRevNumber(java.lang.String revNumber)

Sets the revision number.

Parameters:
revNumber - The revision number to set.

removeRevNumber

public void removeRevNumber()

Removes the revision number.

getEditTime

public long getEditTime()

Returns the total time spent in editing the document (or 0).

Returns:
The total time spent in editing the document or 0 if the SummaryInformation does not contain this information.

setEditTime

public void setEditTime(long time)

Sets the total time spent in editing the document.

Parameters:
time - The time to set.

removeEditTime

public void removeEditTime()

Remove the total time spent in editing the document.

getLastPrinted

public java.util.Date getLastPrinted()

Returns the last printed time (or null).

Returns:
The last printed time or null

setLastPrinted

public void setLastPrinted(java.util.Date lastPrinted)

Sets the lastPrinted.

Parameters:
lastPrinted - The lastPrinted to set.

removeLastPrinted

public void removeLastPrinted()

Removes the lastPrinted.

getCreateDateTime

public java.util.Date getCreateDateTime()

Returns the creation time (or null).

Returns:
The creation time or null

setCreateDateTime

public void setCreateDateTime(java.util.Date createDateTime)

Sets the creation time.

Parameters:
createDateTime - The creation time to set.

removeCreateDateTime

public void removeCreateDateTime()

Removes the creation time.

getLastSaveDateTime

public java.util.Date getLastSaveDateTime()

Returns the last save time (or null).

Returns:
The last save time or null

setLastSaveDateTime

public void setLastSaveDateTime(java.util.Date time)

Sets the total time spent in editing the document.

Parameters:
time - The time to set.

removeLastSaveDateTime

public void removeLastSaveDateTime()

Remove the total time spent in editing the document.

getPageCount

public int getPageCount()

Returns the page count or 0 if the SummaryInformation does not contain a page count.

Returns:
The page count or 0 if the SummaryInformation does not contain a page count.

setPageCount

public void setPageCount(int pageCount)

Sets the page count.

Parameters:
pageCount - The page count to set.

removePageCount

public void removePageCount()

Removes the page count.

getWordCount

public int getWordCount()

Returns the word count or 0 if the SummaryInformation does not contain a word count.

Returns:
The word count or null

setWordCount

public void setWordCount(int wordCount)

Sets the word count.

Parameters:
wordCount - The word count to set.

removeWordCount

public void removeWordCount()

Removes the word count.

getCharCount

public int getCharCount()

Returns the character count or 0 if the SummaryInformation does not contain a char count.

Returns:
The character count or null

setCharCount

public void setCharCount(int charCount)

Sets the character count.

Parameters:
charCount - The character count to set.

removeCharCount

public void removeCharCount()

Removes the character count.

getThumbnail

public byte[] getThumbnail()

Returns the thumbnail (or null) when this method is implemented. Please note that the return type is likely to change!

Hint to developers: Drew Varner <Drew.Varner -at- sc.edu> said that this is an image in WMF or Clipboard (BMP?) format. However, we won't do any conversion into any image type but instead just return a byte array.

Returns:
The thumbnail or null

setThumbnail

public void setThumbnail(byte[] thumbnail)

Sets the thumbnail.

Parameters:
thumbnail - The thumbnail to set.

removeThumbnail

public void removeThumbnail()

Removes the thumbnail.

getApplicationName

public java.lang.String getApplicationName()

Returns the application name (or null).

Returns:
The application name or null

setApplicationName

public void setApplicationName(java.lang.String applicationName)

Sets the application name.

Parameters:
applicationName - The application name to set.

removeApplicationName

public void removeApplicationName()

Removes the application name.

getSecurity

public int getSecurity()

Returns a security code which is one of the following values:

  • 0 if the SummaryInformation does not contain a security field or if there is no security on the document. Use PropertySet.wasNull() to distinguish between the two cases!

  • 1 if the document is password protected

  • 2 if the document is read-only recommended

  • 4 if the document is read-only enforced

  • 8 if the document is locked for annotations

Returns:
The security code or null

setSecurity

public void setSecurity(int security)

Sets the security code.

Parameters:
security - The security code to set.

removeSecurity

public void removeSecurity()

Removes the security code.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Thumbnail

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class Thumbnail

java.lang.Object
    extended by  org.apache.poi.hpsf.Thumbnail

public final class Thumbnail
extends java.lang.Object

Class to manipulate data in the Clipboard Variant (VT_CF) format.

Author:
Drew Varner (Drew.Varner inOrAround sc.edu)
See Also:
SummaryInformation.getThumbnail()

Field Summary
static int | CF_BITMAP Clipboard Format - Bitmap
static int | CF_DIB Clipboard Format - Device Independent Bitmap
static int | CF_ENHMETAFILE Clipboard Format - Enhanced Windows metafile format
static int | CF_METAFILEPICT Clipboard Format - Windows metafile format.
static int | CFTAG_FMTID Clipboard Format Tag - Format ID
static int | CFTAG_MACINTOSH Clipboard Format Tag - Macintosh clipboard format
static int | CFTAG_NODATA Clipboard Format Tag - No Data
static int | CFTAG_WINDOWS Clipboard Format Tag - Windows clipboard format
static int | OFFSET_CF Offset in bytes where the Clipboard Format starts in the byte[] returned by SummaryInformation.getThumbnail()
static int | OFFSET_CFTAG Offset in bytes where the Clipboard Format Tag starts in the byte[] returned by SummaryInformation.getThumbnail()
static int | OFFSET_WMFDATA Offset in bytes where the Windows Metafile (WMF) image data starts in the byte[] returned by SummaryInformation.getThumbnail()
Constructor Summary
Thumbnail()
Default Constructor.
Thumbnail(byte[] thumbnailData)
Creates a Thumbnail instance and initializes with the specified image bytes.
Method Summary
long | getClipboardFormat() Returns an int representing the Clipboard Format
long | getClipboardFormatTag() Returns an int representing the Clipboard Format Tag
byte[] | getThumbnail() Returns the thumbnail as a byte[] in VT_CF format.
byte[] | getThumbnailAsWMF() Returns the Thumbnail as a byte[] of WMF data if the Thumbnail's Clipboard Format Tag is CFTAG_WINDOWS and its Clipboard Format is CF_METAFILEPICT
void | setThumbnail(byte[] thumbnail) Sets the Thumbnail's underlying byte[] in VT_CF format.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OFFSET_CFTAG

public static int OFFSET_CFTAG

Offset in bytes where the Clipboard Format Tag starts in the byte[] returned by SummaryInformation.getThumbnail()

OFFSET_CF

public static int OFFSET_CF

Offset in bytes where the Clipboard Format starts in the byte[] returned by SummaryInformation.getThumbnail()

This is only valid if the Clipboard Format Tag is CFTAG_WINDOWS

OFFSET_WMFDATA

public static int OFFSET_WMFDATA

Offset in bytes where the Windows Metafile (WMF) image data starts in the byte[] returned by SummaryInformation.getThumbnail()

There is only WMF data at this point in the byte[] if the Clipboard Format Tag is CFTAG_WINDOWS and the Clipboard Format is CF_METAFILEPICT.

Note: The byte[] that starts at OFFSET_WMFDATA and ends at getThumbnail().length - 1 forms a complete WMF image. It can be saved to disk with a .wmf file type and read using a WMF-capable image viewer.

CFTAG_WINDOWS

public static int CFTAG_WINDOWS

Clipboard Format Tag - Windows clipboard format

A DWORD indicating a built-in Windows clipboard format value

CFTAG_MACINTOSH

public static int CFTAG_MACINTOSH

Clipboard Format Tag - Macintosh clipboard format

A DWORD indicating a Macintosh clipboard format value

CFTAG_FMTID

public static int CFTAG_FMTID

Clipboard Format Tag - Format ID

A GUID containing a format identifier (FMTID). This is rarely used.

CFTAG_NODATA

public static int CFTAG_NODATA

Clipboard Format Tag - No Data

A DWORD indicating No data. This is rarely used.

CF_METAFILEPICT

public static int CF_METAFILEPICT

Clipboard Format - Windows metafile format. This is the recommended way to store thumbnails in Property Streams.

Note: This is not the same format used in regular WMF images. The clipboard version of this format has an extra clipboard-specific header.

CF_DIB

public static int CF_DIB

Clipboard Format - Device Independent Bitmap

CF_ENHMETAFILE

public static int CF_ENHMETAFILE

Clipboard Format - Enhanced Windows metafile format

CF_BITMAP

public static int CF_BITMAP

Clipboard Format - Bitmap

Obsolete, see msdn.microsoft.com/library/en-us/dnw98bk/html/clipboardoperations.asp.

Constructor Detail

Thumbnail

public Thumbnail()

Default Constructor. If you use it then one you'll have to add the thumbnail byte[] from SummaryInformation.getThumbnail() to do any useful manipulations, otherwise you'll get a NullPointerException.

Thumbnail

public Thumbnail(byte[] thumbnailData)

Creates a Thumbnail instance and initializes with the specified image bytes.

Parameters:
thumbnailData - The thumbnail data
Method Detail

getThumbnail

public byte[] getThumbnail()

Returns the thumbnail as a byte[] in VT_CF format.

Returns:
The thumbnail value
See Also:
SummaryInformation.getThumbnail()

setThumbnail

public void setThumbnail(byte[] thumbnail)

Sets the Thumbnail's underlying byte[] in VT_CF format.

Parameters:
thumbnail - The new thumbnail value
See Also:
SummaryInformation.getThumbnail()

getClipboardFormatTag

public long getClipboardFormatTag()

Returns an int representing the Clipboard Format Tag

Possible return values are:

  • CFTAG_WINDOWS
  • CFTAG_MACINTOSH
  • CFTAG_FMTID
  • CFTAG_NODATA

Returns:
A flag indicating the Clipboard Format Tag

getClipboardFormat

public long getClipboardFormat()
                        throws HPSFException

Returns an int representing the Clipboard Format

Will throw an exception if the Thumbnail's Clipboard Format Tag is not CFTAG_WINDOWS.

Possible return values are:

  • CF_METAFILEPICT
  • CF_DIB
  • CF_ENHMETAFILE
  • CF_BITMAP

Returns:
a flag indicating the Clipboard Format
Throws:
HPSFException - if the Thumbnail isn't CFTAG_WINDOWS

getThumbnailAsWMF

public byte[] getThumbnailAsWMF()
                         throws HPSFException

Returns the Thumbnail as a byte[] of WMF data if the Thumbnail's Clipboard Format Tag is CFTAG_WINDOWS and its Clipboard Format is CF_METAFILEPICT

This byte[] is in the traditional WMF file, not the clipboard-specific version with special headers.

See http://www.wvware.com/caolan/ora-wmf.html for more information on the WMF image format.

Returns:
A WMF image of the Thumbnail
Throws:
HPSFException - if the Thumbnail isn't CFTAG_WINDOWS and CF_METAFILEPICT
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TypeWriter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class TypeWriter

java.lang.Object
    extended by  org.apache.poi.hpsf.TypeWriter

public class TypeWriter
extends java.lang.Object

Class for writing little-endian data and more.

Author:
Rainer Klute <klute@rainer-klute.de>

Constructor Summary
TypeWriter()
Method Summary
static int | writeToStream(java.io.OutputStream out, ClassID n) Writes a 16-byte ClassID to an output stream.
static int | writeToStream(java.io.OutputStream out, double n) Writes a double value value to an output stream.
static int | writeToStream(java.io.OutputStream out, int n) Writes a four-byte value to an output stream.
static int | writeToStream(java.io.OutputStream out, long n) Writes a eight-byte value to an output stream.
static void | writeToStream(java.io.OutputStream out, Property[] properties, int codepage) Writes an array of Property instances to an output stream according to the Horrible Property Stream Format.
static int | writeToStream(java.io.OutputStream out, short n) Writes a two-byte value (short) to an output stream.
static int | writeUIntToStream(java.io.OutputStream out, long n) Writes an unsigned four-byte value to an output stream.
static void | writeUShortToStream(java.io.OutputStream out, int n) Writes an unsigned two-byte value to an output stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TypeWriter

public TypeWriter()
Method Detail

writeToStream

public static int writeToStream(java.io.OutputStream out,
                                short n)
                         throws java.io.IOException

Writes a two-byte value (short) to an output stream.

Parameters:
out - The stream to write to.
n - The value to write.
Returns:
The number of bytes that have been written.
Throws:
java.io.IOException - if an I/O error occurs

writeToStream

public static int writeToStream(java.io.OutputStream out,
                                int n)
                         throws java.io.IOException

Writes a four-byte value to an output stream.

Parameters:
out - The stream to write to.
n - The value to write.
Returns:
The number of bytes written to the output stream.
Throws:
java.io.IOException - if an I/O error occurs

writeToStream

public static int writeToStream(java.io.OutputStream out,
                                long n)
                         throws java.io.IOException

Writes a eight-byte value to an output stream.

Parameters:
out - The stream to write to.
n - The value to write.
Returns:
The number of bytes written to the output stream.
Throws:
java.io.IOException - if an I/O error occurs

writeUShortToStream

public static void writeUShortToStream(java.io.OutputStream out,
                                       int n)
                                throws java.io.IOException

Writes an unsigned two-byte value to an output stream.

Parameters:
out - The stream to write to
n - The value to write
Throws:
java.io.IOException - if an I/O error occurs

writeUIntToStream

public static int writeUIntToStream(java.io.OutputStream out,
                                    long n)
                             throws java.io.IOException

Writes an unsigned four-byte value to an output stream.

Parameters:
out - The stream to write to.
n - The value to write.
Returns:
The number of bytes that have been written to the output stream.
Throws:
java.io.IOException - if an I/O error occurs

writeToStream

public static int writeToStream(java.io.OutputStream out,
                                ClassID n)
                         throws java.io.IOException

Writes a 16-byte ClassID to an output stream.

Parameters:
out - The stream to write to
n - The value to write
Returns:
The number of bytes written
Throws:
java.io.IOException - if an I/O error occurs

writeToStream

public static void writeToStream(java.io.OutputStream out,
                                 Property[] properties,
                                 int codepage)
                          throws java.io.IOException,
                                 UnsupportedVariantTypeException

Writes an array of Property instances to an output stream according to the Horrible Property Stream Format.

Parameters:
out - The stream to write to
properties - The array to write to the stream
codepage - The codepage number to use for writing strings
Throws:
java.io.IOException - if an I/O error occurs
UnsupportedVariantTypeException - if HPSF does not support some variant type.

writeToStream

public static int writeToStream(java.io.OutputStream out,
                                double n)
                         throws java.io.IOException

Writes a double value value to an output stream.

Parameters:
out - The stream to write to.
n - The value to write.
Returns:
The number of bytes written to the output stream.
Throws:
java.io.IOException - if an I/O error occurs
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnexpectedPropertySetTypeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class UnexpectedPropertySetTypeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.UnexpectedPropertySetTypeException
All Implemented Interfaces:
java.io.Serializable
public class UnexpectedPropertySetTypeException
extends HPSFException

This exception is thrown if a certain type of property set is expected (e.g. a Document Summary Information) but the provided property set is not of that type.

The constructors of this class are analogous to those of its superclass and documented there.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
UnexpectedPropertySetTypeException()
Creates an UnexpectedPropertySetTypeException.
UnexpectedPropertySetTypeException(java.lang.String msg)
Creates an UnexpectedPropertySetTypeException with a message string.
UnexpectedPropertySetTypeException(java.lang.String msg, java.lang.Throwable reason)
Creates an UnexpectedPropertySetTypeException with a message string and a reason.
UnexpectedPropertySetTypeException(java.lang.Throwable reason)
Creates a new UnexpectedPropertySetTypeException with a reason.
Method Summary
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnexpectedPropertySetTypeException

public UnexpectedPropertySetTypeException()

Creates an UnexpectedPropertySetTypeException.

UnexpectedPropertySetTypeException

public UnexpectedPropertySetTypeException(java.lang.String msg)

Creates an UnexpectedPropertySetTypeException with a message string.

Parameters:
msg - The message string.

UnexpectedPropertySetTypeException

public UnexpectedPropertySetTypeException(java.lang.Throwable reason)

Creates a new UnexpectedPropertySetTypeException with a reason.

Parameters:
reason - The reason, i.e. a throwable that indirectly caused this exception.

UnexpectedPropertySetTypeException

public UnexpectedPropertySetTypeException(java.lang.String msg,
                                          java.lang.Throwable reason)

Creates an UnexpectedPropertySetTypeException with a message string and a reason.

Parameters:
msg - The message string.
reason - The reason, i.e. a throwable that indirectly caused this exception.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnsupportedVariantTypeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class UnsupportedVariantTypeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.VariantTypeException
                    extended by  org.apache.poi.hpsf.UnsupportedVariantTypeException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ReadingNotSupportedException, WritingNotSupportedException
public abstract class UnsupportedVariantTypeException
extends VariantTypeException

This exception is thrown if HPSF encounters a variant type that isn't supported yet. Although a variant type is unsupported the value can still be retrieved using the VariantTypeException.getValue() method.

Obviously this class should disappear some day.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
UnsupportedVariantTypeException(long variantType, java.lang.Object value)
Constructor.
Method Summary
Methods inherited from class org.apache.poi.hpsf.VariantTypeException
getValue, getVariantType
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnsupportedVariantTypeException

public UnsupportedVariantTypeException(long variantType,
                                       java.lang.Object value)

Constructor.

Parameters:
variantType - The unsupported variant type
value - The value who's variant type is not yet supported
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Util

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class Util

java.lang.Object
    extended by  org.apache.poi.hpsf.Util

public class Util
extends java.lang.Object

Provides various static utility methods.

Author:
Rainer Klute (klute@rainer-klute.de)

Field Summary
static long EPOCH_DIFF
The difference between the Windows epoch (1601-01-01 00:00:00) and the Unix epoch (1970-01-01 00:00:00) in milliseconds: 11644473600000L.
Constructor Summary
Util()
Method Summary
static byte[] | cat(byte[][] byteArrays) Concatenates the contents of several byte arrays into a single one.
static byte[] | copy(byte[] src, int offset, int length) Copies bytes from a source byte array into a new byte array.
static void | copy(byte[] src, int srcOffset, int length, byte[] dst, int dstOffset) Copies a part of a byte array into another byte array.
static long | dateToFileTime(java.util.Date date) Converts a Date into a filetime.
static boolean | equal(byte[] a, byte[] b) Checks whether two byte arrays a and b are equal.
static boolean | equals(java.util.Collection<?> c1, java.util.Collection<?> c2) Checks whether two collections are equal.
static boolean | equals(java.lang.Object[] c1, java.lang.Object[] c2) Compares to object arrays with regarding the objects' order.
static java.util.Date | filetimeToDate(int high, int low) Converts a Windows FILETIME into a Date.
static java.util.Date | filetimeToDate(long filetime) Converts a Windows FILETIME into a Date.
static byte[] | pad4(byte[] ba) Pads a byte array with 0x00 bytes so that its length is a multiple of 4.
static char[] | pad4(char[] ca) Pads a character array with 0x0000 characters so that its length is a multiple of 4.
static char[] | pad4(java.lang.String s) Pads a string with 0x0000 characters so that its length is a multiple of 4.
static java.lang.String | toString(java.lang.Throwable t) Returns a textual representation of a Throwable, including a stacktrace.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EPOCH_DIFF

public static final long EPOCH_DIFF

The difference between the Windows epoch (1601-01-01 00:00:00) and the Unix epoch (1970-01-01 00:00:00) in milliseconds: 11644473600000L. (Use your favorite spreadsheet program to verify the correctness of this value. By the way, did you notice that you can tell from the epochs which operating system is the modern one? :-))

See Also:
Constant Field Values
Constructor Detail

Util

public Util()
Method Detail

equal

public static boolean equal(byte[] a,
                            byte[] b)

Checks whether two byte arrays a and b are equal. They are equal

  • if they have the same length and

  • if for each i with i >= 0 and i < a.length holds a[i] == b[i].

Parameters:
a - The first byte array
b - The first byte array
Returns:
true if the byte arrays are equal, else false

copy

public static void copy(byte[] src,
                        int srcOffset,
                        int length,
                        byte[] dst,
                        int dstOffset)

Copies a part of a byte array into another byte array.

Parameters:
src - The source byte array.
srcOffset - Offset in the source byte array.
length - The number of bytes to copy.
dst - The destination byte array.
dstOffset - Offset in the destination byte array.

cat

public static byte[] cat(byte[][] byteArrays)

Concatenates the contents of several byte arrays into a single one.

Parameters:
byteArrays - The byte arrays to be concatened.
Returns:
A new byte array containing the concatenated byte arrays.

copy

public static byte[] copy(byte[] src,
                          int offset,
                          int length)

Copies bytes from a source byte array into a new byte array.

Parameters:
src - Copy from this byte array.
offset - Start copying here.
length - Copy this many bytes.
Returns:
The new byte array. Its length is number of copied bytes.

filetimeToDate

public static java.util.Date filetimeToDate(int high,
                                            int low)

Converts a Windows FILETIME into a Date. The Windows FILETIME structure holds a date and time associated with a file. The structure identifies a 64-bit integer specifying the number of 100-nanosecond intervals which have passed since January 1, 1601. This 64-bit value is split into the two double words stored in the structure.

Parameters:
high - The higher double word of the FILETIME structure.
low - The lower double word of the FILETIME structure.
Returns:
The Windows FILETIME as a Date.

filetimeToDate

public static java.util.Date filetimeToDate(long filetime)

Converts a Windows FILETIME into a Date. The Windows FILETIME structure holds a date and time associated with a file. The structure identifies a 64-bit integer specifying the number of 100-nanosecond intervals which have passed since January 1, 1601.

Parameters:
filetime - The filetime to convert.
Returns:
The Windows FILETIME as a Date.

dateToFileTime

public static long dateToFileTime(java.util.Date date)

Converts a Date into a filetime.

Parameters:
date - The date to be converted
Returns:
The filetime
See Also:
filetimeToDate(long), filetimeToDate(int, int)

equals

public static boolean equals(java.util.Collection<?> c1,
                             java.util.Collection<?> c2)

Checks whether two collections are equal. Two collections C1 and C2 are equal, if the following conditions are true:

  • For each c1i (element of C1) there is a c2j (element of C2), and c1i equals c2j.

  • For each c2i (element of C2) there is a c1j (element of C1) and c2i equals c1j.

Parameters:
c1 - the first collection
c2 - the second collection
Returns:
true if the collections are equal, else false.

equals

public static boolean equals(java.lang.Object[] c1,
                             java.lang.Object[] c2)

Compares to object arrays with regarding the objects' order. For example, [1, 2, 3] and [2, 1, 3] are equal.

Parameters:
c1 - The first object array.
c2 - The second object array.
Returns:
true if the object arrays are equal, false if they are not.

pad4

public static byte[] pad4(byte[] ba)

Pads a byte array with 0x00 bytes so that its length is a multiple of 4.

Parameters:
ba - The byte array to pad.
Returns:
The padded byte array.

pad4

public static char[] pad4(char[] ca)

Pads a character array with 0x0000 characters so that its length is a multiple of 4.

Parameters:
ca - The character array to pad.
Returns:
The padded character array.

pad4

public static char[] pad4(java.lang.String s)

Pads a string with 0x0000 characters so that its length is a multiple of 4.

Parameters:
s - The string to pad.
Returns:
The padded string as a character array.

toString

public static java.lang.String toString(java.lang.Throwable t)

Returns a textual representation of a Throwable, including a stacktrace.

Parameters:
t - The Throwable
Returns:
a string containing the output of a call to t.printStacktrace().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Variant

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class Variant

java.lang.Object
    extended by  org.apache.poi.hpsf.Variant
Direct Known Subclasses:
VariantSupport
public class Variant
extends java.lang.Object

The Variant types as defined by Microsoft's COM. I found this information in http://www.marin.clara.net/COM/variant_type_definitions.htm.

In the variant types descriptions the following shortcuts are used: [V] - may appear in a VARIANT, [T] - may appear in a TYPEDESC, [P] - may appear in an OLE property set, [S] - may appear in a Safe Array.

Author:
Rainer Klute (klute@rainer-klute.de)

Field Summary
static java.lang.Integer | LENGTH_0 Denotes a variant type with a length of 0 bytes.
static java.lang.Integer | LENGTH_2 Denotes a variant type with a length of 2 bytes.
static java.lang.Integer | LENGTH_4 Denotes a variant type with a length of 4 bytes.
static java.lang.Integer | LENGTH_8 Denotes a variant type with a length of 8 bytes.
static java.lang.Integer | LENGTH_UNKNOWN Denotes a variant type with a length that is unknown to HPSF yet.
static java.lang.Integer | LENGTH_VARIABLE Denotes a variant type with a variable length.
static int | VT_ARRAY [V] SAFEARRAY*.
static int | VT_BLOB [P] Length prefixed bytes.
static int | VT_BLOB_OBJECT [P] Blob contains an object.
static int | VT_BOOL [V][T][P][S] True=-1, False=0.
static int | VT_BSTR [V][T][P][S] OLE Automation string.
static int | VT_BYREF [V] void* for local use.
static int | VT_CARRAY [T] C style array.
static int | VT_CF [P] Clipboard format.
static int | VT_CLSID [P] A Class ID.
static int | VT_CY [V][T][P][S] currency.
static int | VT_DATE [V][T][P][S] date.
static int | VT_DECIMAL [V][T][S] 16 byte fixed point.
static int | VT_DISPATCH [V][T][P][S] IDispatch *.
static int | VT_EMPTY [V][P] Nothing, i.e.
static int | VT_ERROR [V][T][S] SCODE.
static int | VT_FILETIME [P] FILETIME.
static int | VT_HRESULT [T] Standard return type.
static int | VT_I1 [T] signed char.
static int | VT_I2 [V][T][P][S] 2 byte signed int.
static int | VT_I4 [V][T][P][S] 4 byte signed int.
static int | VT_I8 [T][P] signed 64-bit int.
static int | VT_ILLEGAL FIXME (3): Document this!
static int | VT_ILLEGALMASKED FIXME (3): Document this!
static int | VT_INT [T] signed machine int.
static int | VT_LPSTR [T][P] null terminated string.
static int | VT_LPWSTR [T][P] wide (Unicode) null terminated string.
static int | VT_NULL [V][P] SQL style Null.
static int | VT_PTR [T] pointer type.
static int | VT_R4 [V][T][P][S] 4 byte real.
static int | VT_R8 [V][T][P][S] 8 byte real.
static int | VT_RESERVED FIXME (3): Document this!
static int | VT_SAFEARRAY [T] (use VT_ARRAY in VARIANT).
static int | VT_STORAGE [P] Name of the storage follows.
static int | VT_STORED_OBJECT [P] Storage contains an object.
static int | VT_STREAM [P] Name of the stream follows.
static int | VT_STREAMED_OBJECT [P] Stream contains an object.
static int | VT_TYPEMASK FIXME (3): Document this!
static int | VT_UI1 [V][T][P][S] unsigned char.
static int | VT_UI2 [T][P] unsigned short.
static int | VT_UI4 [T][P] unsigned int.
static int | VT_UI8 [T][P] unsigned 64-bit int.
static int | VT_UINT [T] unsigned machine int.
static int | VT_UNKNOWN [V][T][S] IUnknown *.
static int | VT_USERDEFINED [T] user defined type.
static int | VT_VARIANT [V][T][P][S] VARIANT *.
static int | VT_VECTOR [P] simple counted array.
static int | VT_VERSIONED_STREAM "MUST be a VersionedStream.
static int | VT_VOID [T] C style void.
Constructor Summary
Variant()
Method Summary
static int | getVariantLength(long variantType) Returns a variant type's length.
static java.lang.String | getVariantName(long variantType) Returns the variant type name associated with a variant type number.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VT_EMPTY

public static final int VT_EMPTY

[V][P] Nothing, i.e. not a single byte of data.

See Also:
Constant Field Values

VT_NULL

public static final int VT_NULL

[V][P] SQL style Null.

See Also:
Constant Field Values

VT_I2

public static final int VT_I2

[V][T][P][S] 2 byte signed int.

See Also:
Constant Field Values

VT_I4

public static final int VT_I4

[V][T][P][S] 4 byte signed int.

See Also:
Constant Field Values

VT_R4

public static final int VT_R4

[V][T][P][S] 4 byte real.

See Also:
Constant Field Values

VT_R8

public static final int VT_R8

[V][T][P][S] 8 byte real.

See Also:
Constant Field Values

VT_CY

public static final int VT_CY

[V][T][P][S] currency. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_DATE

public static final int VT_DATE

[V][T][P][S] date. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_BSTR

public static final int VT_BSTR

[V][T][P][S] OLE Automation string. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_DISPATCH

public static final int VT_DISPATCH

[V][T][P][S] IDispatch *. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_ERROR

public static final int VT_ERROR

[V][T][S] SCODE. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_BOOL

public static final int VT_BOOL

[V][T][P][S] True=-1, False=0.

See Also:
Constant Field Values

VT_VARIANT

public static final int VT_VARIANT

[V][T][P][S] VARIANT *. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_UNKNOWN

public static final int VT_UNKNOWN

[V][T][S] IUnknown *. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_DECIMAL

public static final int VT_DECIMAL

[V][T][S] 16 byte fixed point.

See Also:
Constant Field Values

VT_I1

public static final int VT_I1

[T] signed char.

See Also:
Constant Field Values

VT_UI1

public static final int VT_UI1

[V][T][P][S] unsigned char.

See Also:
Constant Field Values

VT_UI2

public static final int VT_UI2

[T][P] unsigned short.

See Also:
Constant Field Values

VT_UI4

public static final int VT_UI4

[T][P] unsigned int.

See Also:
Constant Field Values

VT_I8

public static final int VT_I8

[T][P] signed 64-bit int.

See Also:
Constant Field Values

VT_UI8

public static final int VT_UI8

[T][P] unsigned 64-bit int.

See Also:
Constant Field Values

VT_INT

public static final int VT_INT

[T] signed machine int.

See Also:
Constant Field Values

VT_UINT

public static final int VT_UINT

[T] unsigned machine int.

See Also:
Constant Field Values

VT_VOID

public static final int VT_VOID

[T] C style void.

See Also:
Constant Field Values

VT_HRESULT

public static final int VT_HRESULT

[T] Standard return type. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_PTR

public static final int VT_PTR

[T] pointer type. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_SAFEARRAY

public static final int VT_SAFEARRAY

[T] (use VT_ARRAY in VARIANT).

See Also:
Constant Field Values

VT_CARRAY

public static final int VT_CARRAY

[T] C style array. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_USERDEFINED

public static final int VT_USERDEFINED

[T] user defined type. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_LPSTR

public static final int VT_LPSTR

[T][P] null terminated string.

See Also:
Constant Field Values

VT_LPWSTR

public static final int VT_LPWSTR

[T][P] wide (Unicode) null terminated string.

See Also:
Constant Field Values

VT_FILETIME

public static final int VT_FILETIME

[P] FILETIME. The FILETIME structure holds a date and time associated with a file. The structure identifies a 64-bit integer specifying the number of 100-nanosecond intervals which have passed since January 1, 1601. This 64-bit value is split into the two dwords stored in the structure.

See Also:
Constant Field Values

VT_BLOB

public static final int VT_BLOB

[P] Length prefixed bytes.

See Also:
Constant Field Values

VT_STREAM

public static final int VT_STREAM

[P] Name of the stream follows.

See Also:
Constant Field Values

VT_STORAGE

public static final int VT_STORAGE

[P] Name of the storage follows.

See Also:
Constant Field Values

VT_STREAMED_OBJECT

public static final int VT_STREAMED_OBJECT

[P] Stream contains an object. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_STORED_OBJECT

public static final int VT_STORED_OBJECT

[P] Storage contains an object. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_BLOB_OBJECT

public static final int VT_BLOB_OBJECT

[P] Blob contains an object. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_CF

public static final int VT_CF

[P] Clipboard format. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_CLSID

public static final int VT_CLSID

[P] A Class ID.

It consists of a 32 bit unsigned integer indicating the size of the structure, a 32 bit signed integer indicating (Clipboard Format Tag) indicating the type of data that it contains, and then a byte array containing the data.

The valid Clipboard Format Tags are:

  • Thumbnail.CFTAG_WINDOWS
  • Thumbnail.CFTAG_MACINTOSH
  • Thumbnail.CFTAG_NODATA
  • Thumbnail.CFTAG_FMTID
typedef struct tagCLIPDATA {
 // cbSize is the size of the buffer pointed to
 // by pClipData, plus sizeof(ulClipFmt)
 ULONG              cbSize;
 long               ulClipFmt;
 BYTE*              pClipData;
 } CLIPDATA;

See msdn.microsoft.com/library/en-us/com/stgrstrc_0uwk.asp.

See Also:
Constant Field Values

VT_VERSIONED_STREAM

public static final int VT_VERSIONED_STREAM
"MUST be a VersionedStream. The storage representing the (non-simple) property set MUST have a stream element with the name in the StreamName field." -- [MS-OLEPS] -- v20110920; Object Linking and Embedding (OLE) Property Set Data Structures; page 24 / 63

See Also:
Constant Field Values

VT_VECTOR

public static final int VT_VECTOR

[P] simple counted array. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_ARRAY

public static final int VT_ARRAY

[V] SAFEARRAY*. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_BYREF

public static final int VT_BYREF

[V] void* for local use. How long is this? How is it to be interpreted?

See Also:
Constant Field Values

VT_RESERVED

public static final int VT_RESERVED

FIXME (3): Document this!

See Also:
Constant Field Values

VT_ILLEGAL

public static final int VT_ILLEGAL

FIXME (3): Document this!

See Also:
Constant Field Values

VT_ILLEGALMASKED

public static final int VT_ILLEGALMASKED

FIXME (3): Document this!

See Also:
Constant Field Values

VT_TYPEMASK

public static final int VT_TYPEMASK

FIXME (3): Document this!

See Also:
Constant Field Values

LENGTH_UNKNOWN

public static final java.lang.Integer LENGTH_UNKNOWN

Denotes a variant type with a length that is unknown to HPSF yet.

LENGTH_VARIABLE

public static final java.lang.Integer LENGTH_VARIABLE

Denotes a variant type with a variable length.

LENGTH_0

public static final java.lang.Integer LENGTH_0

Denotes a variant type with a length of 0 bytes.

LENGTH_2

public static final java.lang.Integer LENGTH_2

Denotes a variant type with a length of 2 bytes.

LENGTH_4

public static final java.lang.Integer LENGTH_4

Denotes a variant type with a length of 4 bytes.

LENGTH_8

public static final java.lang.Integer LENGTH_8

Denotes a variant type with a length of 8 bytes.

Constructor Detail

Variant

public Variant()
Method Detail

getVariantName

public static java.lang.String getVariantName(long variantType)

Returns the variant type name associated with a variant type number.

Parameters:
variantType - The variant type number
Returns:
The variant type name or the string "unknown variant type"

getVariantLength

public static int getVariantLength(long variantType)

Returns a variant type's length.

Parameters:
variantType - The variant type number
Returns:
The length of the variant type's data in bytes. If the length is variable, i.e. the length of a string, -1 is returned. If HPSF does not know the length, -2 is returned. The latter usually indicates an unsupported variant type.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VariantSupport

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class VariantSupport

java.lang.Object
    extended by  org.apache.poi.hpsf.Variant
        extended by  org.apache.poi.hpsf.VariantSupport

public class VariantSupport
extends Variant

Supports reading and writing of variant data.

FIXME (3): Reading and writing should be made more uniform than it is now. The following items should be resolved:

  • Reading requires a length parameter that is 4 byte greater than the actual data, because the variant type field is included.

  • Reading reads from a byte array while writing writes to an byte array output stream.

Author:
Rainer Klute <klute@rainer-klute.de>

Field Summary
static int[] | SUPPORTED_TYPES HPSF is able to read these Variant types.
protected static java.util.List | unsupportedMessage Keeps a list of the variant types an "unsupported" message has already been issued for.
Fields inherited from class org.apache.poi.hpsf.Variant
LENGTH_0, LENGTH_2, LENGTH_4, LENGTH_8, LENGTH_UNKNOWN, LENGTH_VARIABLE, VT_ARRAY, VT_BLOB, VT_BLOB_OBJECT, VT_BOOL, VT_BSTR, VT_BYREF, VT_CARRAY, VT_CF, VT_CLSID, VT_CY, VT_DATE, VT_DECIMAL, VT_DISPATCH, VT_EMPTY, VT_ERROR, VT_FILETIME, VT_HRESULT, VT_I1, VT_I2, VT_I4, VT_I8, VT_ILLEGAL, VT_ILLEGALMASKED, VT_INT, VT_LPSTR, VT_LPWSTR, VT_NULL, VT_PTR, VT_R4, VT_R8, VT_RESERVED, VT_SAFEARRAY, VT_STORAGE, VT_STORED_OBJECT, VT_STREAM, VT_STREAMED_OBJECT, VT_TYPEMASK, VT_UI1, VT_UI2, VT_UI4, VT_UI8, VT_UINT, VT_UNKNOWN, VT_USERDEFINED, VT_VARIANT, VT_VECTOR, VT_VERSIONED_STREAM, VT_VOID
Constructor Summary
VariantSupport()
Method Summary
static java.lang.String | codepageToEncoding(int codepage) Turns a codepage number into the equivalent character encoding's name.
static boolean | isLogUnsupportedTypes() Checks whether logging of unsupported variant types warning is turned on or off.
boolean | isSupportedType(int variantType) Checks whether HPSF supports the specified variant type.
static java.lang.Object | read(byte[] src, int offset, int length, long type, int codepage) Reads a variant type from a byte array.
static void | setLogUnsupportedTypes(boolean logUnsupportedTypes) Specifies whether warnings about unsupported variant types are to be written to System.err or not.
static int | write(java.io.OutputStream out, long type, java.lang.Object value, int codepage) Writes a variant value to an output stream.
protected static void | writeUnsupportedTypeMessage(UnsupportedVariantTypeException ex) Writes a warning to System.err that a variant type is unsupported by HPSF.
Methods inherited from class org.apache.poi.hpsf.Variant
getVariantLength, getVariantName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

unsupportedMessage

protected static java.util.List unsupportedMessage

Keeps a list of the variant types an "unsupported" message has already been issued for.

SUPPORTED_TYPES

public static final int[] SUPPORTED_TYPES

HPSF is able to read these Variant types.

Constructor Detail

VariantSupport

public VariantSupport()
Method Detail

setLogUnsupportedTypes

public static void setLogUnsupportedTypes(boolean logUnsupportedTypes)

Specifies whether warnings about unsupported variant types are to be written to System.err or not.

Parameters:
logUnsupportedTypes - If true warnings will be written, if false they won't.

isLogUnsupportedTypes

public static boolean isLogUnsupportedTypes()

Checks whether logging of unsupported variant types warning is turned on or off.

Returns:
true if logging is turned on, else false.

writeUnsupportedTypeMessage

protected static void writeUnsupportedTypeMessage(UnsupportedVariantTypeException ex)

Writes a warning to System.err that a variant type is unsupported by HPSF. Such a warning is written only once for each variant type. Log messages can be turned on or off by

Parameters:
ex - The exception to log

isSupportedType

public boolean isSupportedType(int variantType)

Checks whether HPSF supports the specified variant type. Unsupported types should be implemented included in the SUPPORTED_TYPES array.

Parameters:
variantType - the variant type to check
Returns:
true if HPFS supports this type, else false
See Also:
Variant

read

public static java.lang.Object read(byte[] src,
                                    int offset,
                                    int length,
                                    long type,
                                    int codepage)
                             throws ReadingNotSupportedException,
                                    java.io.UnsupportedEncodingException

Reads a variant type from a byte array.

Parameters:
src - The byte array
offset - The offset in the byte array where the variant starts
length - The length of the variant including the variant type field
type - The variant type to read
codepage - The codepage to use for non-wide strings
Returns:
A Java object that corresponds best to the variant field. For example, a VT_I4 is returned as a Long, a VT_LPSTR as a String.
Throws:
ReadingNotSupportedException - if a property is to be written who's variant type HPSF does not yet support
java.io.UnsupportedEncodingException - if the specified codepage is not supported.
See Also:
Variant

codepageToEncoding

public static java.lang.String codepageToEncoding(int codepage)
                                           throws java.io.UnsupportedEncodingException

Turns a codepage number into the equivalent character encoding's name.

Parameters:
codepage - The codepage number
Returns:
The character encoding's name. If the codepage number is 65001, the encoding name is "UTF-8". All other positive numbers are mapped to "cp" followed by the number, e.g. if the codepage number is 1252 the returned character encoding name will be "cp1252".
Throws:
java.io.UnsupportedEncodingException - if the specified codepage is less than zero.

write

public static int write(java.io.OutputStream out,
                        long type,
                        java.lang.Object value,
                        int codepage)
                 throws java.io.IOException,
                        WritingNotSupportedException

Writes a variant value to an output stream. This method ensures that always a multiple of 4 bytes is written.

If the codepage is UTF-16, which is encouraged, strings must always be written as Variant.VT_LPWSTR strings, not as Variant.VT_LPSTR strings. This method ensure this by converting strings appropriately, if needed.

Parameters:
out - The stream to write the value to.
type - The variant's type.
value - The variant's value.
codepage - The codepage to use to write non-wide strings
Returns:
The number of entities that have been written. In many cases an "entity" is a byte but this is not always the case.
Throws:
java.io.IOException - if an I/O exceptions occurs
WritingNotSupportedException - if a property is to be written who's variant type HPSF does not yet support
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VariantTypeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class VariantTypeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.VariantTypeException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
IllegalVariantTypeException, UnsupportedVariantTypeException
public abstract class VariantTypeException
extends HPSFException

This exception is thrown if HPSF encounters a problem with a variant type. Concrete subclasses specifiy the problem further.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Constructor Summary
VariantTypeException(long variantType, java.lang.Object value, java.lang.String msg)
Constructor.
Method Summary
java.lang.Object | getValue() Returns the value who's variant type caused the problem.
long | getVariantType() Returns the offending variant type.
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

VariantTypeException

public VariantTypeException(long variantType,
                            java.lang.Object value,
                            java.lang.String msg)

Constructor.

Parameters:
variantType - The variant type causing the problem
value - The value who's variant type causes the problem
msg - A message text describing the problem
Method Detail

getVariantType

public long getVariantType()

Returns the offending variant type.

Returns:
the offending variant type.

getValue

public java.lang.Object getValue()

Returns the value who's variant type caused the problem.

Returns:
the value who's variant type caused the problem
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WritingNotSupportedException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf
Class WritingNotSupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hpsf.HPSFException
                extended by  org.apache.poi.hpsf.VariantTypeException
                    extended by  org.apache.poi.hpsf.UnsupportedVariantTypeException
                        extended by  org.apache.poi.hpsf.WritingNotSupportedException
All Implemented Interfaces:
java.io.Serializable
public class WritingNotSupportedException
extends UnsupportedVariantTypeException

This exception is thrown when trying to write a (yet) unsupported variant type.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
ReadingNotSupportedException, UnsupportedVariantTypeException, Serialized Form

Constructor Summary
WritingNotSupportedException(long variantType, java.lang.Object value)
Constructor
Method Summary
Methods inherited from class org.apache.poi.hpsf.VariantTypeException
getValue, getVariantType
Methods inherited from class org.apache.poi.hpsf.HPSFException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WritingNotSupportedException

public WritingNotSupportedException(long variantType,
                                    java.lang.Object value)

Constructor

Parameters:
variantType - The unsupported variant type.
value - The value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hpsf.ClassID

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.ClassID

Packages that use ClassID
org.apache.poi.hpsf |
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.

Uses of ClassID in org.apache.poi.hpsf

Fields in org.apache.poi.hpsf declared as ClassID
protected ClassID | PropertySet.classID Specifies this PropertySet's "classID" field.
protected ClassID | Section.formatID The section's format ID, Section.getFormatID().

Methods in org.apache.poi.hpsf that return ClassID
ClassID | SpecialPropertySet.getClassID()
ClassID | PropertySet.getClassID() Returns the property set stream's low-level "class ID" field.
ClassID | Section.getFormatID() Returns the format ID.

Methods in org.apache.poi.hpsf with parameters of type ClassID
void | SpecialPropertySet.setClassID(ClassID classID)
void | MutablePropertySet.setClassID(ClassID classID) Sets the property set stream's low-level "class ID" field.
void | MutableSection.setFormatID(ClassID formatID) Sets the section's format ID.
static int | TypeWriter.writeToStream(java.io.OutputStream out, ClassID n) Writes a 16-byte ClassID to an output stream.

Uses of ClassID in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return ClassID
ClassID | FilteringDirectoryNode.getStorageClsid()
ClassID | DirectoryNode.getStorageClsid() Gets the storage clsid of the directory entry
ClassID | DirectoryEntry.getStorageClsid() Gets the storage clsid of the directory entry

Methods in org.apache.poi.poifs.filesystem with parameters of type ClassID
void | FilteringDirectoryNode.setStorageClsid(ClassID clsidStorage)
void | DirectoryNode.setStorageClsid(ClassID clsidStorage) Sets the storage clsid for the directory entry
void | DirectoryEntry.setStorageClsid(ClassID clsidStorage) Sets the storage clsid for the directory entry

Uses of ClassID in org.apache.poi.poifs.property

Methods in org.apache.poi.poifs.property that return ClassID
 ClassID Property.getStorageClsid()
Sets the storage clsid, which is the Class ID of a COM object which reads and writes this stream

Methods in org.apache.poi.poifs.property with parameters of type ClassID
 void Property.setStorageClsid(ClassID clsidStorage)
Sets the storage class ID for this property stream.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.Constants

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.Constants

No usage of org.apache.poi.hpsf.Constants

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.CustomProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.CustomProperties

Packages that use CustomProperties
org.apache.poi.hpsf

Uses of CustomProperties in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that return CustomProperties
 CustomProperties DocumentSummaryInformation.getCustomProperties()
Gets the custom properties.

Methods in org.apache.poi.hpsf with parameters of type CustomProperties
 void DocumentSummaryInformation.setCustomProperties(CustomProperties customProperties)
Sets the custom properties.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.CustomProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.CustomProperty

Packages that use CustomProperty
org.apache.poi.hpsf

Uses of CustomProperty in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that return CustomProperty
 CustomProperty CustomProperties.put(java.lang.String name, CustomProperty cp)
Puts a CustomProperty into this map.

Methods in org.apache.poi.hpsf with parameters of type CustomProperty
 CustomProperty CustomProperties.put(java.lang.String name, CustomProperty cp)
Puts a CustomProperty into this map.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.DocumentSummaryInformation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.DocumentSummaryInformation

Packages that use DocumentSummaryInformation
org.apache.poi
org.apache.poi.hpsf
org.apache.poi.hssf.extractor

Uses of DocumentSummaryInformation in org.apache.poi

Methods in org.apache.poi that return DocumentSummaryInformation
DocumentSummaryInformation | POIOLE2TextExtractor.getDocSummaryInformation() Returns the document information metadata for the document
DocumentSummaryInformation | POIDocument.getDocumentSummaryInformation() Fetch the Document Summary Information of the document

Uses of DocumentSummaryInformation in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that return DocumentSummaryInformation
static DocumentSummaryInformation PropertySetFactory.newDocumentSummaryInformation()
Creates a new document summary information.

Uses of DocumentSummaryInformation in org.apache.poi.hssf.extractor

Methods in org.apache.poi.hssf.extractor that return DocumentSummaryInformation
 DocumentSummaryInformation EventBasedExcelExtractor.getDocSummaryInformation()
Would return the document information metadata for the document, if we supported it

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.HPSFException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.HPSFException

Packages that use HPSFException
org.apache.poi.hpsf

Uses of HPSFException in org.apache.poi.hpsf

Subclasses of HPSFException in org.apache.poi.hpsf
class | IllegalVariantTypeException This exception is thrown if HPSF encounters a variant type that is illegal in the current context.
class | MarkUnsupportedException This exception is thrown if an InputStream does not support the InputStream.mark(int) operation.
class | NoPropertySetStreamException This exception is thrown if a format error in a property set stream is detected or when the input data do not constitute a property set stream.
class | ReadingNotSupportedException This exception is thrown when HPSF tries to read a (yet) unsupported variant type.
class | UnexpectedPropertySetTypeException This exception is thrown if a certain type of property set is expected (e.g.
class | UnsupportedVariantTypeException This exception is thrown if HPSF encounters a variant type that isn't supported yet.
class | VariantTypeException This exception is thrown if HPSF encounters a problem with a variant type.
class | WritingNotSupportedException This exception is thrown when trying to write a (yet) unsupported variant type.

Methods in org.apache.poi.hpsf that throw HPSFException
long | Thumbnail.getClipboardFormat() Returns an int representing the Clipboard Format
byte[] | Thumbnail.getThumbnailAsWMF() Returns the Thumbnail as a byte[] of WMF data if the Thumbnail's Clipboard Format Tag is CFTAG_WINDOWS and its Clipboard Format is CF_METAFILEPICT

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.HPSFRuntimeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.HPSFRuntimeException

Packages that use HPSFRuntimeException
org.apache.poi.hpsf

Uses of HPSFRuntimeException in org.apache.poi.hpsf

Subclasses of HPSFRuntimeException in org.apache.poi.hpsf
class | IllegalPropertySetDataException This exception is thrown when there is an illegal value set in a PropertySet.
class | MissingSectionException This exception is thrown if one of the PropertySet's convenience methods does not find a required Section.
class | NoFormatIDException This exception is thrown if a MutablePropertySet is to be written but does not have a formatID set (see MutableSection.setFormatID(ClassID) or MutableSection.setFormatID(byte[]).
class | NoSingleSectionException This exception is thrown if one of the PropertySet's convenience methods that require a single Section is called and the PropertySet does not contain exactly one Section.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.IllegalPropertySetDataException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.IllegalPropertySetDataException

Packages that use IllegalPropertySetDataException
org.apache.poi.hpsf

Uses of IllegalPropertySetDataException in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that throw IllegalPropertySetDataException
 void MutableSection.setDictionary(java.util.Map<java.lang.Long,java.lang.String> dictionary)
Sets the section's dictionary.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.IllegalVariantTypeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.IllegalVariantTypeException

No usage of org.apache.poi.hpsf.IllegalVariantTypeException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.MarkUnsupportedException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.MarkUnsupportedException

Packages that use MarkUnsupportedException
org.apache.poi.hpsf

Uses of MarkUnsupportedException in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that throw MarkUnsupportedException
static PropertySet | PropertySetFactory.create(java.io.InputStream stream) Creates the most specific PropertySet from an InputStream.
static boolean | PropertySet.isPropertySetStream(java.io.InputStream stream) Checks whether an InputStream is in the Horrible Property Set Format.

Constructors in org.apache.poi.hpsf that throw MarkUnsupportedException
PropertySet(java.io.InputStream stream)
Creates a PropertySet instance from an InputStream in the Horrible Property Set Format.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.MissingSectionException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.MissingSectionException

No usage of org.apache.poi.hpsf.MissingSectionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.MutableProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.MutableProperty

Packages that use MutableProperty
org.apache.poi.hpsf

Uses of MutableProperty in org.apache.poi.hpsf

Subclasses of MutableProperty in org.apache.poi.hpsf
 class CustomProperty
This class represents custom properties in the document summary information stream.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.MutablePropertySet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.MutablePropertySet

Packages that use MutablePropertySet
org.apache.poi.hpsf

Uses of MutablePropertySet in org.apache.poi.hpsf

Subclasses of MutablePropertySet in org.apache.poi.hpsf
class | DocumentSummaryInformation Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
class | SpecialPropertySet Abstract superclass for the convenience classes SummaryInformation and DocumentSummaryInformation.
class | SummaryInformation Convenience class representing a Summary Information stream in a Microsoft Office document.

Constructors in org.apache.poi.hpsf with parameters of type MutablePropertySet
SpecialPropertySet(MutablePropertySet ps)
Creates a SpecialPropertySet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.MutableSection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.MutableSection

No usage of org.apache.poi.hpsf.MutableSection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.NoFormatIDException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.NoFormatIDException

No usage of org.apache.poi.hpsf.NoFormatIDException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.NoPropertySetStreamException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.NoPropertySetStreamException

Packages that use NoPropertySetStreamException
org.apache.poi.hpsf

Uses of NoPropertySetStreamException in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that throw NoPropertySetStreamException
static PropertySet PropertySetFactory.create(java.io.InputStream stream)
Creates the most specific PropertySet from an InputStream.

Constructors in org.apache.poi.hpsf that throw NoPropertySetStreamException
PropertySet(byte[] stream)
Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.
PropertySet(byte[] stream, int offset, int length)
Creates a PropertySet instance from a byte array that represents a stream in the Horrible Property Set Format.
PropertySet(java.io.InputStream stream)
Creates a PropertySet instance from an InputStream in the Horrible Property Set Format.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.NoSingleSectionException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.NoSingleSectionException

Packages that use NoSingleSectionException
org.apache.poi.hpsf

Uses of NoSingleSectionException in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that throw NoSingleSectionException
 Property[] SpecialPropertySet.getProperties()
 Property[] PropertySet.getProperties()
Convenience method returning the Property array contained in this property set.
protected  java.lang.Object SpecialPropertySet.getProperty(int id)
protected  java.lang.Object PropertySet.getProperty(int id)
Convenience method returning the value of the property with the specified ID.
protected  boolean SpecialPropertySet.getPropertyBooleanValue(int id)
protected  boolean PropertySet.getPropertyBooleanValue(int id)
Convenience method returning the value of a boolean property with the specified ID.
protected  int SpecialPropertySet.getPropertyIntValue(int id)
protected  int PropertySet.getPropertyIntValue(int id)
Convenience method returning the value of the numeric property with the specified ID.
 boolean SpecialPropertySet.wasNull()
 boolean PropertySet.wasNull()
Checks whether the property which the last call to PropertySet.getPropertyIntValue(int) or PropertySet.getProperty(int) tried to access was available or not.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.Property

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.Property

Packages that use Property
org.apache.poi.hpsf

Uses of Property in org.apache.poi.hpsf

Subclasses of Property in org.apache.poi.hpsf
class | CustomProperty This class represents custom properties in the document summary information stream.
class | MutableProperty Adds writing capability to the Property class.

Fields in org.apache.poi.hpsf declared as Property
protected  Property[] Section.properties

Methods in org.apache.poi.hpsf that return Property
Property[] | SpecialPropertySet.getProperties()
Property[] | Section.getProperties() Returns this section's properties.
Property[] | PropertySet.getProperties() Convenience method returning the Property array contained in this property set.
Property[] | MutableSection.getProperties() Gets this section's properties.

Methods in org.apache.poi.hpsf with parameters of type Property
void | MutableSection.setProperties(Property[] properties) Sets this section's properties.
void | MutableSection.setProperty(Property p) Sets a property.
static void | TypeWriter.writeToStream(java.io.OutputStream out, Property[] properties, int codepage) Writes an array of Property instances to an output stream according to the Horrible Property Stream Format.

Constructors in org.apache.poi.hpsf with parameters of type Property
CustomProperty(Property property)
Creates a CustomProperty without a name by copying the underlying Property' attributes.
CustomProperty(Property property, java.lang.String name)
Creates a CustomProperty with a name.
MutableProperty(Property p)
Creates a MutableProperty as a copy of an existing Property.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.PropertySet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.PropertySet

Packages that use PropertySet
org.apache.poi
org.apache.poi.hpsf

Uses of PropertySet in org.apache.poi

Methods in org.apache.poi that return PropertySet
protected  PropertySet POIDocument.getPropertySet(java.lang.String setName)
For a given named property entry, either return it or null if if it wasn't found

Methods in org.apache.poi with parameters of type PropertySet
protected  void POIDocument.writePropertySet(java.lang.String name, PropertySet set, POIFSFileSystem outFS)
Writes out a given ProperySet

Uses of PropertySet in org.apache.poi.hpsf

Subclasses of PropertySet in org.apache.poi.hpsf
class | DocumentSummaryInformation Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
class | MutablePropertySet Adds writing support to the PropertySet class.
class | SpecialPropertySet Abstract superclass for the convenience classes SummaryInformation and DocumentSummaryInformation.
class | SummaryInformation Convenience class representing a Summary Information stream in a Microsoft Office document.

Methods in org.apache.poi.hpsf that return PropertySet
static PropertySet PropertySetFactory.create(java.io.InputStream stream)
Creates the most specific PropertySet from an InputStream.

Constructors in org.apache.poi.hpsf with parameters of type PropertySet
DocumentSummaryInformation(PropertySet ps)
Creates a DocumentSummaryInformation from a given PropertySet.
MutablePropertySet(PropertySet ps)
Constructs a MutablePropertySet by doing a deep copy of an existing PropertySet.
SpecialPropertySet(PropertySet ps)
Creates a SpecialPropertySet.
SummaryInformation(PropertySet ps)
Creates a SummaryInformation from a given PropertySet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.PropertySetFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.PropertySetFactory

No usage of org.apache.poi.hpsf.PropertySetFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.ReadingNotSupportedException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.ReadingNotSupportedException

Packages that use ReadingNotSupportedException
org.apache.poi.hpsf

Uses of ReadingNotSupportedException in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that throw ReadingNotSupportedException
static java.lang.Object VariantSupport.read(byte[] src, int offset, int length, long type, int codepage)
Reads a variant type from a byte array.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.Section

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.Section

Packages that use Section
org.apache.poi.hpsf

Uses of Section in org.apache.poi.hpsf

Subclasses of Section in org.apache.poi.hpsf
 class MutableSection
Adds writing capability to the Section class.

Fields in org.apache.poi.hpsf with type parameters of type Section
protected  java.util.List<Section> PropertySet.sections
The sections in this PropertySet.

Methods in org.apache.poi.hpsf that return Section
Section | SpecialPropertySet.getFirstSection()
Section | PropertySet.getFirstSection() Gets the PropertySet's first section.
Section | PropertySet.getSingleSection() If the PropertySet has only a single section this method returns it.

Methods in org.apache.poi.hpsf that return types with arguments of type Section
 java.util.List<Section> PropertySet.getSections()
Returns the Sections in the property set.

Methods in org.apache.poi.hpsf with parameters of type Section
void | SpecialPropertySet.addSection(Section section)
void | MutablePropertySet.addSection(Section section) Adds a section to this property set.

Constructors in org.apache.poi.hpsf with parameters of type Section
MutableSection(Section s)
Constructs a MutableSection by doing a deep copy of an existing Section.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.SpecialPropertySet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.SpecialPropertySet

Packages that use SpecialPropertySet
org.apache.poi.hpsf

Uses of SpecialPropertySet in org.apache.poi.hpsf

Subclasses of SpecialPropertySet in org.apache.poi.hpsf
class | DocumentSummaryInformation Convenience class representing a DocumentSummary Information stream in a Microsoft Office document.
class | SummaryInformation Convenience class representing a Summary Information stream in a Microsoft Office document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.SummaryInformation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.SummaryInformation

Packages that use SummaryInformation
org.apache.poi
org.apache.poi.hpsf
org.apache.poi.hssf.converter
org.apache.poi.hssf.extractor
org.apache.poi.hwpf.converter

Uses of SummaryInformation in org.apache.poi

Methods in org.apache.poi that return SummaryInformation
SummaryInformation | POIOLE2TextExtractor.getSummaryInformation() Returns the summary information metadata for the document
SummaryInformation | POIDocument.getSummaryInformation() Fetch the Summary Information of the document

Uses of SummaryInformation in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that return SummaryInformation
static SummaryInformation PropertySetFactory.newSummaryInformation()
Creates a new summary information.

Uses of SummaryInformation in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type SummaryInformation
protected void | ExcelToHtmlConverter.processDocumentInformation(SummaryInformation summaryInformation)
protected void | ExcelToFoConverter.processDocumentInformation(SummaryInformation summaryInformation)

Uses of SummaryInformation in org.apache.poi.hssf.extractor

Methods in org.apache.poi.hssf.extractor that return SummaryInformation
 SummaryInformation EventBasedExcelExtractor.getSummaryInformation()
Would return the summary information metadata for the document, if we supported it

Uses of SummaryInformation in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type SummaryInformation
protected void | WordToTextConverter.processDocumentInformation(SummaryInformation summaryInformation)
protected void | WordToHtmlConverter.processDocumentInformation(SummaryInformation summaryInformation)
protected void | WordToFoConverter.processDocumentInformation(SummaryInformation summaryInformation)
protected abstract void | AbstractWordConverter.processDocumentInformation(SummaryInformation summaryInformation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.Thumbnail

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.Thumbnail

No usage of org.apache.poi.hpsf.Thumbnail

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.TypeWriter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.TypeWriter

No usage of org.apache.poi.hpsf.TypeWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.UnexpectedPropertySetTypeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.UnexpectedPropertySetTypeException

Packages that use UnexpectedPropertySetTypeException
org.apache.poi.hpsf

Uses of UnexpectedPropertySetTypeException in org.apache.poi.hpsf

Constructors in org.apache.poi.hpsf that throw UnexpectedPropertySetTypeException
DocumentSummaryInformation(PropertySet ps)
Creates a DocumentSummaryInformation from a given PropertySet.
SummaryInformation(PropertySet ps)
Creates a SummaryInformation from a given PropertySet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.UnsupportedVariantTypeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.UnsupportedVariantTypeException

Packages that use UnsupportedVariantTypeException
org.apache.poi.hpsf

Uses of UnsupportedVariantTypeException in org.apache.poi.hpsf

Subclasses of UnsupportedVariantTypeException in org.apache.poi.hpsf
class | ReadingNotSupportedException This exception is thrown when HPSF tries to read a (yet) unsupported variant type.
class | WritingNotSupportedException This exception is thrown when trying to write a (yet) unsupported variant type.

Methods in org.apache.poi.hpsf with parameters of type UnsupportedVariantTypeException
protected static void VariantSupport.writeUnsupportedTypeMessage(UnsupportedVariantTypeException ex)
Writes a warning to System.err that a variant type is unsupported by HPSF.

Methods in org.apache.poi.hpsf that throw UnsupportedVariantTypeException
static void TypeWriter.writeToStream(java.io.OutputStream out, Property[] properties, int codepage)
Writes an array of Property instances to an output stream according to the Horrible Property Stream Format.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.Util

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.Util

No usage of org.apache.poi.hpsf.Util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.Variant

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.Variant

Packages that use Variant
org.apache.poi.hpsf

Uses of Variant in org.apache.poi.hpsf

Subclasses of Variant in org.apache.poi.hpsf
 class VariantSupport
Supports reading and writing of variant data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.VariantSupport

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.VariantSupport

No usage of org.apache.poi.hpsf.VariantSupport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.VariantTypeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.VariantTypeException

Packages that use VariantTypeException
org.apache.poi.hpsf

Uses of VariantTypeException in org.apache.poi.hpsf

Subclasses of VariantTypeException in org.apache.poi.hpsf
class | IllegalVariantTypeException This exception is thrown if HPSF encounters a variant type that is illegal in the current context.
class | ReadingNotSupportedException This exception is thrown when HPSF tries to read a (yet) unsupported variant type.
class | UnsupportedVariantTypeException This exception is thrown if HPSF encounters a variant type that isn't supported yet.
class | WritingNotSupportedException This exception is thrown when trying to write a (yet) unsupported variant type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.WritingNotSupportedException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.WritingNotSupportedException

Packages that use WritingNotSupportedException
org.apache.poi.hpsf

Uses of WritingNotSupportedException in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that throw WritingNotSupportedException
protected int | Property.getSize() Returns the property's size in bytes.
java.io.InputStream | SpecialPropertySet.toInputStream()
java.io.InputStream | MutablePropertySet.toInputStream() Returns the contents of this property set stream as an input stream.
void | SpecialPropertySet.write(DirectoryEntry dir, java.lang.String name)
void | MutablePropertySet.write(DirectoryEntry dir, java.lang.String name) Writes a property set to a document in a POI filesystem directory.
void | SpecialPropertySet.write(java.io.OutputStream out)
int | MutableSection.write(java.io.OutputStream out) Writes this section into an output stream.
void | MutablePropertySet.write(java.io.OutputStream out) Writes the property set to an output stream.
int | MutableProperty.write(java.io.OutputStream out, int codepage) Writes the property to an output stream.
static int | VariantSupport.write(java.io.OutputStream out, long type, java.lang.Object value, int codepage) Writes a variant value to an output stream.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HPSFPropertiesExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf.extractor
Class HPSFPropertiesExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

public class HPSFPropertiesExtractor
extends POITextExtractor

Extracts all of the HPSF properties, both build in and custom, returning them in textual form.

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
HPSFPropertiesExtractor(NPOIFSFileSystem fs)
HPSFPropertiesExtractor(POIDocument doc)
HPSFPropertiesExtractor(POIFSFileSystem fs)
HPSFPropertiesExtractor(POITextExtractor mainExtractor)
Method Summary
java.lang.String | getDocumentSummaryInformationText()
POITextExtractor | getMetadataTextExtractor() Prevent recursion!
java.lang.String | getSummaryInformationText()
java.lang.String | getText() Retrieves all the text from the document.
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HPSFPropertiesExtractor

public HPSFPropertiesExtractor(POITextExtractor mainExtractor)

HPSFPropertiesExtractor

public HPSFPropertiesExtractor(POIDocument doc)

HPSFPropertiesExtractor

public HPSFPropertiesExtractor(POIFSFileSystem fs)

HPSFPropertiesExtractor

public HPSFPropertiesExtractor(NPOIFSFileSystem fs)
Method Detail

getDocumentSummaryInformationText

public java.lang.String getDocumentSummaryInformationText()

getSummaryInformationText

public java.lang.String getSummaryInformationText()

getText

public java.lang.String getText()
Description copied from class: POITextExtractor
Retrieves all the text from the document. How cells, paragraphs etc are separated in the text is implementation specific - see the javadocs for a specific project for details.

Specified by:
getText in class POITextExtractor
Returns:
the text of all the properties defined in the document.

getMetadataTextExtractor

public POITextExtractor getMetadataTextExtractor()
Prevent recursion!

Specified by:
getMetadataTextExtractor in class POITextExtractor

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hpsf.extractor
Classes
HPSFPropertiesExtractor


org.apache.poi.hpsf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpsf.extractor

Class Summary
HPSFPropertiesExtractor Extracts all of the HPSF properties, both build in and custom, returning them in textual form.


org.apache.poi.hpsf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpsf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor


Uses of Package org.apache.poi.hpsf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpsf.extractor

No usage of org.apache.poi.hpsf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

No usage of org.apache.poi.hpsf.extractor.HPSFPropertiesExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hpsf.wellknown
Classes
PropertyIDMap
SectionIDMap


org.apache.poi.hpsf.wellknown

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hpsf.wellknown

Specific support for DocumentSummaryInformation, SummaryInformation types.

See:
Description

Class Summary
PropertyIDMap | This is a dictionary which maps property ID values to property ID strings.
SectionIDMap | Maps section format IDs to PropertyIDMaps.

Package org.apache.poi.hpsf.wellknown Description

Specific support for DocumentSummaryInformation, SummaryInformation types.

Support classes for "well-known" section format IDs and property IDs. The streams \005DocumentSummaryInformation and \005SummaryInformation (or any streams with the same section format IDs as the aforementioned) are considered well-known. So are most property IDs in these streams.

Author:
Rainer Klute (klute@rainer-klute.de)


org.apache.poi.hpsf.wellknown Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hpsf.wellknown

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • org.apache.poi.hpsf.wellknown.PropertyIDMap
        • org.apache.poi.hpsf.wellknown.SectionIDMap


Uses of Package org.apache.poi.hpsf.wellknown

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hpsf.wellknown

Packages that use org.apache.poi.hpsf.wellknown
org.apache.poi.hpsf |
org.apache.poi.hpsf.wellknown | Specific support for DocumentSummaryInformation, SummaryInformation types.

Classes in org.apache.poi.hpsf.wellknown used by org.apache.poi.hpsf
PropertyIDMap
This is a dictionary which maps property ID values to property ID strings.

Classes in org.apache.poi.hpsf.wellknown used by org.apache.poi.hpsf.wellknown
PropertyIDMap
This is a dictionary which maps property ID values to property ID strings.
SectionIDMap
Maps section format IDs to PropertyIDMaps.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PropertyIDMap

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf.wellknown
Class PropertyIDMap

java.lang.Object
    extended by  java.util.AbstractMap<K,V>
        extended by  java.util.HashMap
            extended by  org.apache.poi.hpsf.wellknown.PropertyIDMap
All Implemented Interfaces:
java.io.Serializable, java.lang.Cloneable, java.util.Map
public class PropertyIDMap
extends java.util.HashMap

This is a dictionary which maps property ID values to property ID strings.

The methods getSummaryInformationProperties() and getDocumentSummaryInformationProperties() return singleton PropertyIDMaps. An application that wants to extend these maps should treat them as unmodifiable, copy them and modifiy the copies.

Author:
Rainer Klute <klute@rainer-klute.de>
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.util.AbstractMap
java.util.AbstractMap.SimpleEntry<K,V>, java.util.AbstractMap.SimpleImmutableEntry<K,V>
Field Summary
static int | PID_APPNAME ID of the property that denotes the application that created the document
static int | PID_AUTHOR ID of the property that denotes the document's author
static int | PID_BYTECOUNT Number of bytes.
static int | PID_CATEGORY The entry is a string denoting the category the file belongs to, e.g.
static int | PID_CHARCOUNT ID of the property that denotes the number of characters in the document
static int | PID_CODEPAGE The entry denotes a code page.
static int | PID_COMMENTS ID of the property that denotes the document's comments
static int | PID_COMPANY This entry contains the company name.
static int | PID_CREATE_DTM ID of the property that denotes the date and time the document was created.
static int | PID_DICTIONARY The entry is a dictionary.
static int | PID_DOCPARTS This entry contains the names of document parts (word: names of the documents in the master document, excel: sheet names, power point: slide titles, binder: document names).
static int | PID_EDITTIME ID of the property that denotes the document's edit time
static int | PID_HEADINGPAIR This entry denotes an internally used property.
static int | PID_HIDDENCOUNT Number of hidden slides.
static int | PID_KEYWORDS ID of the property that denotes the document's keywords
static int | PID_LASTAUTHOR ID of the property that denotes the document's last author
static int | PID_LASTPRINTED ID of the property that denotes the date and time the document was last printed
static int | PID_LASTSAVE_DTM ID of the property that denotes the date and time the document was saved
static int | PID_LINECOUNT Number of lines.
static int | PID_LINKSDIRTY If this entry is -1 the links are dirty and should be re-evaluated.
static int | PID_MANAGER This entry contains the name of the project manager.
static int | PID_MAX The highest well-known property ID.
static int | PID_MMCLIPCOUNT Number of multimedia clips, e.g.
static int | PID_NOTECOUNT Number of slides with notes.
static int | PID_PAGECOUNT ID of the property that denotes the number of pages in the document
static int | PID_PARCOUNT Number of paragraphs.
static int | PID_PRESFORMAT Target format for power point presentation, e.g.
static int | PID_REVNUMBER ID of the property that denotes the document's revision number
static int | PID_SCALE This entry is set to -1 when scaling of the thumbnail is desired.
static int | PID_SECURITY ID of the property that denotes whether read/write access to the document is allowed or whether is should be opened as read-only.
static int | PID_SLIDECOUNT Number of slides in a power point presentation.
static int | PID_SUBJECT ID of the property that denotes the document's subject
static int | PID_TEMPLATE ID of the property that denotes the document's template
static int | PID_THUMBNAIL ID of the property that denotes the document's thumbnail
static int | PID_TITLE ID of the property that denotes the document's title
static int | PID_WORDCOUNT ID of the property that denotes the number of words in the document
Constructor Summary
PropertyIDMap(int initialCapacity, float loadFactor)
Creates a PropertyIDMap.
PropertyIDMap(java.util.Map map)
Creates a PropertyIDMap backed by another map.
Method Summary
java.lang.Object | get(long id) Gets the ID string for an ID from the PropertyIDMap.
static PropertyIDMap | getDocumentSummaryInformationProperties() Returns the Document Summary Information properties singleton.
static PropertyIDMap | getSummaryInformationProperties()
static void | main(java.lang.String[] args) For the most basic testing.
java.lang.Object | put(long id, java.lang.String idString) Puts a ID string for an ID into the PropertyIDMap.
Methods inherited from class java.util.HashMap
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
Methods inherited from class java.util.AbstractMap
equals, hashCode, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Field Detail

PID_TITLE

public static final int PID_TITLE

ID of the property that denotes the document's title

See Also:
Constant Field Values

PID_SUBJECT

public static final int PID_SUBJECT

ID of the property that denotes the document's subject

See Also:
Constant Field Values

PID_AUTHOR

public static final int PID_AUTHOR

ID of the property that denotes the document's author

See Also:
Constant Field Values

PID_KEYWORDS

public static final int PID_KEYWORDS

ID of the property that denotes the document's keywords

See Also:
Constant Field Values

PID_COMMENTS

public static final int PID_COMMENTS

ID of the property that denotes the document's comments

See Also:
Constant Field Values

PID_TEMPLATE

public static final int PID_TEMPLATE

ID of the property that denotes the document's template

See Also:
Constant Field Values

PID_LASTAUTHOR

public static final int PID_LASTAUTHOR

ID of the property that denotes the document's last author

See Also:
Constant Field Values

PID_REVNUMBER

public static final int PID_REVNUMBER

ID of the property that denotes the document's revision number

See Also:
Constant Field Values

PID_EDITTIME

public static final int PID_EDITTIME

ID of the property that denotes the document's edit time

See Also:
Constant Field Values

PID_LASTPRINTED

public static final int PID_LASTPRINTED

ID of the property that denotes the date and time the document was last printed

See Also:
Constant Field Values

PID_CREATE_DTM

public static final int PID_CREATE_DTM

ID of the property that denotes the date and time the document was created.

See Also:
Constant Field Values

PID_LASTSAVE_DTM

public static final int PID_LASTSAVE_DTM

ID of the property that denotes the date and time the document was saved

See Also:
Constant Field Values

PID_PAGECOUNT

public static final int PID_PAGECOUNT

ID of the property that denotes the number of pages in the document

See Also:
Constant Field Values

PID_WORDCOUNT

public static final int PID_WORDCOUNT

ID of the property that denotes the number of words in the document

See Also:
Constant Field Values

PID_CHARCOUNT

public static final int PID_CHARCOUNT

ID of the property that denotes the number of characters in the document

See Also:
Constant Field Values

PID_THUMBNAIL

public static final int PID_THUMBNAIL

ID of the property that denotes the document's thumbnail

See Also:
Constant Field Values

PID_APPNAME

public static final int PID_APPNAME

ID of the property that denotes the application that created the document

See Also:
Constant Field Values

PID_SECURITY

public static final int PID_SECURITY

ID of the property that denotes whether read/write access to the document is allowed or whether is should be opened as read-only. It can have the following values:

Value

Description

0

No restriction

2

Read-only recommended

4

Read-only enforced

See Also:
Constant Field Values

PID_DICTIONARY

public static final int PID_DICTIONARY

The entry is a dictionary.

See Also:
Constant Field Values

PID_CODEPAGE

public static final int PID_CODEPAGE

The entry denotes a code page.

See Also:
Constant Field Values

PID_CATEGORY

public static final int PID_CATEGORY

The entry is a string denoting the category the file belongs to, e.g. review, memo, etc. This is useful to find documents of same type.

See Also:
Constant Field Values

PID_PRESFORMAT

public static final int PID_PRESFORMAT

Target format for power point presentation, e.g. 35mm, printer, video etc.

See Also:
Constant Field Values

PID_BYTECOUNT

public static final int PID_BYTECOUNT

Number of bytes.

See Also:
Constant Field Values

PID_LINECOUNT

public static final int PID_LINECOUNT

Number of lines.

See Also:
Constant Field Values

PID_PARCOUNT

public static final int PID_PARCOUNT

Number of paragraphs.

See Also:
Constant Field Values

PID_SLIDECOUNT

public static final int PID_SLIDECOUNT

Number of slides in a power point presentation.

See Also:
Constant Field Values

PID_NOTECOUNT

public static final int PID_NOTECOUNT

Number of slides with notes.

See Also:
Constant Field Values

PID_HIDDENCOUNT

public static final int PID_HIDDENCOUNT

Number of hidden slides.

See Also:
Constant Field Values

PID_MMCLIPCOUNT

public static final int PID_MMCLIPCOUNT

Number of multimedia clips, e.g. sound or video.

See Also:
Constant Field Values

PID_SCALE

public static final int PID_SCALE

This entry is set to -1 when scaling of the thumbnail is desired. Otherwise the thumbnail should be cropped.

See Also:
Constant Field Values

PID_HEADINGPAIR

public static final int PID_HEADINGPAIR

This entry denotes an internally used property. It is a vector of variants consisting of pairs of a string (VT_LPSTR) and a number (VT_I4). The string is a heading name, and the number tells how many document parts are under that heading.

See Also:
Constant Field Values

PID_DOCPARTS

public static final int PID_DOCPARTS

This entry contains the names of document parts (word: names of the documents in the master document, excel: sheet names, power point: slide titles, binder: document names).

See Also:
Constant Field Values

PID_MANAGER

public static final int PID_MANAGER

This entry contains the name of the project manager.

See Also:
Constant Field Values

PID_COMPANY

public static final int PID_COMPANY

This entry contains the company name.

See Also:
Constant Field Values

PID_LINKSDIRTY

public static final int PID_LINKSDIRTY

If this entry is -1 the links are dirty and should be re-evaluated.

See Also:
Constant Field Values

PID_MAX

public static final int PID_MAX

The highest well-known property ID. Applications are free to use higher values for custom purposes.

See Also:
Constant Field Values
Constructor Detail

PropertyIDMap

public PropertyIDMap(int initialCapacity,
                     float loadFactor)

Creates a PropertyIDMap.

Parameters:
initialCapacity - The initial capacity as defined for HashMap
loadFactor - The load factor as defined for HashMap

PropertyIDMap

public PropertyIDMap(java.util.Map map)

Creates a PropertyIDMap backed by another map.

Parameters:
map - The instance to be created is backed by this map.
Method Detail

put

public java.lang.Object put(long id,
                            java.lang.String idString)

Puts a ID string for an ID into the PropertyIDMap.

Parameters:
id - The ID.
idString - The ID string.
Returns:
As specified by the Map interface, this method returns the previous value associated with the specified id, or null if there was no mapping for key.

get

public java.lang.Object get(long id)

Gets the ID string for an ID from the PropertyIDMap.

Parameters:
id - The ID.
Returns:
The ID string associated with id.

getSummaryInformationProperties

public static PropertyIDMap getSummaryInformationProperties()
Returns:
the Summary Information properties singleton

getDocumentSummaryInformationProperties

public static PropertyIDMap getDocumentSummaryInformationProperties()

Returns the Document Summary Information properties singleton.

Returns:
The Document Summary Information properties singleton.

main

public static void main(java.lang.String[] args)

For the most basic testing.

Parameters:
args - The command-line arguments
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SectionIDMap

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hpsf.wellknown
Class SectionIDMap

java.lang.Object
    extended by  java.util.AbstractMap<K,V>
        extended by  java.util.HashMap
            extended by  org.apache.poi.hpsf.wellknown.SectionIDMap
All Implemented Interfaces:
java.io.Serializable, java.lang.Cloneable, java.util.Map
public class SectionIDMap
extends java.util.HashMap

Maps section format IDs to PropertyIDMaps. It is initialized with two well-known section format IDs: those of the \005SummaryInformation stream and the \005DocumentSummaryInformation stream.

If you have a section format ID you can use it as a key to query this map. If you get a PropertyIDMap returned your section is well-known and you can query the PropertyIDMap for PID strings. If you get back null you are on your own.

This Map expects the byte arrays of section format IDs as keys. A key maps to a PropertyIDMap describing the property IDs in sections with the specified section format ID.

Author:
Rainer Klute (klute@rainer-klute.de)
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.util.AbstractMap
java.util.AbstractMap.SimpleEntry<K,V>, java.util.AbstractMap.SimpleImmutableEntry<K,V>
Field Summary
static byte[][] | DOCUMENT_SUMMARY_INFORMATION_ID The DocumentSummaryInformation's first and second sections' format ID.
static byte[] | SUMMARY_INFORMATION_ID The SummaryInformation's section's format ID.
static java.lang.String | UNDEFINED A property without a known name is described by this string.
Constructor Summary
SectionIDMap()
Method Summary
 PropertyIDMap get(byte[] sectionFormatID)
Returns the PropertyIDMap for a given section format ID.
 java.lang.Object get(java.lang.Object sectionFormatID)
Deprecated. Use get(byte[]) instead!
static SectionIDMap getInstance()
Returns the singleton instance of the default SectionIDMap.
static java.lang.String getPIDString(byte[] sectionFormatID, long pid)
Returns the property ID string that is associated with a given property ID in a section format ID's namespace.
 java.lang.Object put(byte[] sectionFormatID, PropertyIDMap propertyIDMap)
Associates a section format ID with a PropertyIDMap.
 java.lang.Object put(java.lang.Object key, java.lang.Object value)
Deprecated. Use put(byte[], PropertyIDMap) instead!
Methods inherited from class java.util.HashMap
clear, clone, containsKey, containsValue, entrySet, isEmpty, keySet, putAll, remove, size, values
Methods inherited from class java.util.AbstractMap
equals, hashCode, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Field Detail

SUMMARY_INFORMATION_ID

public static final byte[] SUMMARY_INFORMATION_ID

The SummaryInformation's section's format ID.

DOCUMENT_SUMMARY_INFORMATION_ID

public static final byte[][] DOCUMENT_SUMMARY_INFORMATION_ID

The DocumentSummaryInformation's first and second sections' format ID.

UNDEFINED

public static final java.lang.String UNDEFINED

A property without a known name is described by this string.

See Also:
Constant Field Values
Constructor Detail

SectionIDMap

public SectionIDMap()
Method Detail

getInstance

public static SectionIDMap getInstance()

Returns the singleton instance of the default SectionIDMap.

Returns:
The instance value

getPIDString

public static java.lang.String getPIDString(byte[] sectionFormatID,
                                            long pid)

Returns the property ID string that is associated with a given property ID in a section format ID's namespace.

Parameters:
sectionFormatID - Each section format ID has its own name space of property ID strings and thus must be specified.
pid - The property ID
Returns:
The well-known property ID string associated with the property ID pid in the name space spanned by sectionFormatID . If the pid /sectionFormatID combination is not well-known, the string "[undefined]" is returned.

get

public PropertyIDMap get(byte[] sectionFormatID)

Returns the PropertyIDMap for a given section format ID.

Parameters:
sectionFormatID - the section format ID
Returns:
the property ID map

get

public java.lang.Object get(java.lang.Object sectionFormatID)
Deprecated. Use get(byte[]) instead!

Returns the PropertyIDMap for a given section format ID.

Specified by:
get in interface java.util.Map
Overrides:
get in class java.util.HashMap
Parameters:
sectionFormatID - A section format ID as a byte[] .
Returns:
the property ID map

put

public java.lang.Object put(byte[] sectionFormatID,
                            PropertyIDMap propertyIDMap)

Associates a section format ID with a PropertyIDMap.

Parameters:
sectionFormatID - the section format ID
propertyIDMap - the property ID map
Returns:
as defined by Map.put(K, V)

put

public java.lang.Object put(java.lang.Object key,
                            java.lang.Object value)
Deprecated. Use put(byte[], PropertyIDMap) instead!

Specified by:
put in interface java.util.Map
Overrides:
put in class java.util.HashMap
Parameters:
key - This parameter remains undocumented since the method is deprecated.
value - This parameter remains undocumented since the method is deprecated.
Returns:
The return value remains undocumented since the method is deprecated.
See Also:
put(byte[], PropertyIDMap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hpsf.wellknown.PropertyIDMap

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.wellknown.PropertyIDMap

Packages that use PropertyIDMap
org.apache.poi.hpsf |
org.apache.poi.hpsf.wellknown | Specific support for DocumentSummaryInformation, SummaryInformation types.

Uses of PropertyIDMap in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf that return PropertyIDMap
PropertyIDMap | SummaryInformation.getPropertySetIDMap()
abstract PropertyIDMap | SpecialPropertySet.getPropertySetIDMap() The id to name mapping of the properties in this set.
PropertyIDMap | DocumentSummaryInformation.getPropertySetIDMap()

Uses of PropertyIDMap in org.apache.poi.hpsf.wellknown

Methods in org.apache.poi.hpsf.wellknown that return PropertyIDMap
PropertyIDMap | SectionIDMap.get(byte[] sectionFormatID) Returns the PropertyIDMap for a given section format ID.
static PropertyIDMap | PropertyIDMap.getDocumentSummaryInformationProperties() Returns the Document Summary Information properties singleton.
static PropertyIDMap | PropertyIDMap.getSummaryInformationProperties()

Methods in org.apache.poi.hpsf.wellknown with parameters of type PropertyIDMap
 java.lang.Object SectionIDMap.put(byte[] sectionFormatID, PropertyIDMap propertyIDMap)
Associates a section format ID with a PropertyIDMap.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hpsf.wellknown.SectionIDMap

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hpsf.wellknown.SectionIDMap

Packages that use SectionIDMap
org.apache.poi.hpsf.wellknown
Specific support for DocumentSummaryInformation, SummaryInformation types.

Uses of SectionIDMap in org.apache.poi.hpsf.wellknown

Methods in org.apache.poi.hpsf.wellknown that return SectionIDMap
static SectionIDMap SectionIDMap.getInstance()
Returns the singleton instance of the default SectionIDMap.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


EncryptedSlideShow

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf
Class EncryptedSlideShow

java.lang.Object
    extended by  org.apache.poi.hslf.EncryptedSlideShow

public final class EncryptedSlideShow
extends java.lang.Object

This class provides helper functions for determining if a PowerPoint document is Encrypted. In future, it may also provide Encryption and Decryption functions, but first we'd need to figure out how PowerPoint encryption is really done!

Author:
Nick Burch

Constructor Summary
EncryptedSlideShow()
Method Summary
static boolean | checkIfEncrypted(HSLFSlideShow hss) Check to see if a HSLFSlideShow represents an encrypted PowerPoint document, or not
static DocumentEncryptionAtom | fetchDocumentEncryptionAtom(HSLFSlideShow hss) Return the DocumentEncryptionAtom for a HSLFSlideShow, or null if there isn't one.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EncryptedSlideShow

public EncryptedSlideShow()
Method Detail

checkIfEncrypted

public static boolean checkIfEncrypted(HSLFSlideShow hss)
Check to see if a HSLFSlideShow represents an encrypted PowerPoint document, or not

Parameters:
hss - The HSLFSlideShow to check
Returns:
true if encrypted, otherwise false

fetchDocumentEncryptionAtom

public static DocumentEncryptionAtom fetchDocumentEncryptionAtom(HSLFSlideShow hss)
Return the DocumentEncryptionAtom for a HSLFSlideShow, or null if there isn't one.

Returns:
a DocumentEncryptionAtom, or null if there isn't one
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HSLFSlideShow

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf
Class HSLFSlideShow

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hslf.HSLFSlideShow

public final class HSLFSlideShow
extends POIDocument

This class contains the main functionality for the Powerpoint file "reader". It is only a very basic class for now

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.POIDocument
directory
Constructor Summary
HSLFSlideShow(DirectoryNode dir)
Constructs a Powerpoint document from a specific point in a POIFS Filesystem.
HSLFSlideShow(DirectoryNode dir, POIFSFileSystem filesystem)
Deprecated. Use HSLFSlideShow(DirectoryNode) instead
HSLFSlideShow(java.io.InputStream inputStream)
Constructs a Powerpoint document from an input stream.
HSLFSlideShow(NPOIFSFileSystem filesystem)
Constructs a Powerpoint document from a POIFS Filesystem.
HSLFSlideShow(POIFSFileSystem filesystem)
Constructs a Powerpoint document from a POIFS Filesystem.
HSLFSlideShow(java.lang.String fileName)
Constructs a Powerpoint document from fileName.
Method Summary
int | addPicture(PictureData img) Add a new picture to this presentation.
int | appendRootLevelRecord(Record newRecord) Adds a new root level record, at the end, but before the last PersistPtrIncrementalBlock.
static HSLFSlideShow | create() Constructs a new, empty, Powerpoint document.
CurrentUserAtom | getCurrentUserAtom() Fetch the Current User Atom of the document
ObjectData[] | getEmbeddedObjects() Gets embedded object data from the slide show.
PictureData[] | getPictures() Return array of pictures contained in this presentation
protected DirectoryNode | getPOIFSDirectory() Returns the directory in the underlying POIFSFileSystem for the document that is open.
protected POIFSFileSystem | getPOIFSFileSystem() Returns the underlying POIFSFileSystem for the document that is open.
Record[] | getRecords() Returns an array of all the records found in the slideshow
byte[] | getUnderlyingBytes() Returns an array of the bytes of the file.
void | write(java.io.OutputStream out) Writes out the slideshow file the is represented by an instance of this class.
void | write(java.io.OutputStream out, boolean preserveNodes) Writes out the slideshow file the is represented by an instance of this class.
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSLFSlideShow

public HSLFSlideShow(java.lang.String fileName)
              throws java.io.IOException
Constructs a Powerpoint document from fileName. Parses the document and places all the important stuff into data structures.

Parameters:
fileName - The name of the file to read.
Throws:
java.io.IOException - if there is a problem while parsing the document.

HSLFSlideShow

public HSLFSlideShow(java.io.InputStream inputStream)
              throws java.io.IOException
Constructs a Powerpoint document from an input stream. Parses the document and places all the important stuff into data structures.

Parameters:
inputStream - the source of the data
Throws:
java.io.IOException - if there is a problem while parsing the document.

HSLFSlideShow

public HSLFSlideShow(POIFSFileSystem filesystem)
              throws java.io.IOException
Constructs a Powerpoint document from a POIFS Filesystem. Parses the document and places all the important stuff into data structures.

Parameters:
filesystem - the POIFS FileSystem to read from
Throws:
java.io.IOException - if there is a problem while parsing the document.

HSLFSlideShow

public HSLFSlideShow(NPOIFSFileSystem filesystem)
              throws java.io.IOException
Constructs a Powerpoint document from a POIFS Filesystem. Parses the document and places all the important stuff into data structures.

Parameters:
filesystem - the POIFS FileSystem to read from
Throws:
java.io.IOException - if there is a problem while parsing the document.

HSLFSlideShow

@Deprecated
public HSLFSlideShow(DirectoryNode dir,
                                POIFSFileSystem filesystem)
              throws java.io.IOException
Deprecated. Use HSLFSlideShow(DirectoryNode) instead

Constructs a Powerpoint document from a specific point in a POIFS Filesystem. Parses the document and places all the important stuff into data structures.

Parameters:
dir - the POIFS directory to read from
filesystem - the POIFS FileSystem to read from
Throws:
java.io.IOException - if there is a problem while parsing the document.

HSLFSlideShow

public HSLFSlideShow(DirectoryNode dir)
              throws java.io.IOException
Constructs a Powerpoint document from a specific point in a POIFS Filesystem. Parses the document and places all the important stuff into data structures.

Parameters:
dir - the POIFS directory to read from
Throws:
java.io.IOException - if there is a problem while parsing the document.
Method Detail

getPOIFSFileSystem

protected POIFSFileSystem getPOIFSFileSystem()
Returns the underlying POIFSFileSystem for the document that is open.

getPOIFSDirectory

protected DirectoryNode getPOIFSDirectory()
Returns the directory in the underlying POIFSFileSystem for the document that is open.

create

public static final HSLFSlideShow create()
Constructs a new, empty, Powerpoint document.

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Writes out the slideshow file the is represented by an instance of this class. It will write out the common OLE2 streams. If you require all streams to be written out, pass in preserveNodes

Specified by:
write in class POIDocument
Parameters:
out - The OutputStream to write to.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in OutputStream

write

public void write(java.io.OutputStream out,
                  boolean preserveNodes)
           throws java.io.IOException
Writes out the slideshow file the is represented by an instance of this class. If you require all streams to be written out (eg Marcos, embeded documents), then set preserveNodes to true

Parameters:
out - The OutputStream to write to.
preserveNodes - Should all OLE2 streams be written back out, or only the common ones?
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in OutputStream

appendRootLevelRecord

public int appendRootLevelRecord(Record newRecord)
Adds a new root level record, at the end, but before the last PersistPtrIncrementalBlock.

addPicture

public int addPicture(PictureData img)
Add a new picture to this presentation.

Returns:
offset of this picture in the Pictures stream

getRecords

public Record[] getRecords()
Returns an array of all the records found in the slideshow

getUnderlyingBytes

public byte[] getUnderlyingBytes()
Returns an array of the bytes of the file. Only correct after a call to open or write - at all other times might be wrong!

getCurrentUserAtom

public CurrentUserAtom getCurrentUserAtom()
Fetch the Current User Atom of the document

getPictures

public PictureData[] getPictures()
Return array of pictures contained in this presentation

Returns:
array with the read pictures or null if the presentation doesn't contain pictures.

getEmbeddedObjects

public ObjectData[] getEmbeddedObjects()
Gets embedded object data from the slide show.

Returns:
the embedded objects.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf
Classes
EncryptedSlideShow
HSLFSlideShow


org.apache.poi.hslf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf

Class Summary
EncryptedSlideShow | This class provides helper functions for determining if a PowerPoint document is Encrypted.
HSLFSlideShow | This class contains the main functionality for the Powerpoint file "reader".


org.apache.poi.hslf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.EncryptedSlideShow
    • org.apache.poi.POIDocument
      • org.apache.poi.hslf.HSLFSlideShow


Uses of Package org.apache.poi.hslf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf

Packages that use org.apache.poi.hslf
org.apache.poi.hslf
org.apache.poi.hslf.extractor
org.apache.poi.hslf.usermodel

Classes in org.apache.poi.hslf used by org.apache.poi.hslf
HSLFSlideShow
This class contains the main functionality for the Powerpoint file "reader".

Classes in org.apache.poi.hslf used by org.apache.poi.hslf.extractor
HSLFSlideShow
This class contains the main functionality for the Powerpoint file "reader".

Classes in org.apache.poi.hslf used by org.apache.poi.hslf.usermodel
HSLFSlideShow
This class contains the main functionality for the Powerpoint file "reader".

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Bitmap

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class Bitmap

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Bitmap
Direct Known Subclasses:
DIB, JPEG, PNG
public abstract class Bitmap
extends PictureData

Represents a bitmap picture data: JPEG or PNG. The data is not compressed and the exact file content is written in the stream.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
Bitmap()
Method Summary
byte[] | getData() Returns the binary data of this Picture
void | setData(byte[] data) Set picture data
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getHeader, getImagePainter, getOffset, getRawData, getSignature, getSize, getType, getUID, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Bitmap

public Bitmap()
Method Detail

getData

public byte[] getData()
Description copied from class: PictureData
Returns the binary data of this Picture

Specified by:
getData in class PictureData
Returns:
picture data

setData

public void setData(byte[] data)
             throws java.io.IOException
Description copied from class: PictureData
Set picture data

Specified by:
setData in class PictureData
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BitmapPainter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class BitmapPainter

java.lang.Object
    extended by  org.apache.poi.hslf.blip.BitmapPainter
All Implemented Interfaces:
ImagePainter
public final class BitmapPainter
extends java.lang.Object
implements ImagePainter

Creates BufferedImage using javax.imageio.ImageIO and draws it in the specified graphics.

Author:
Yegor Kozlov.

Field Summary
protected  POILogger logger
Constructor Summary
BitmapPainter()
Method Summary
 void paint(java.awt.Graphics2D graphics, PictureData pict, Picture parent)
Paints the specified picture data
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected POILogger logger
Constructor Detail

BitmapPainter

public BitmapPainter()
Method Detail

paint

public void paint(java.awt.Graphics2D graphics,
                  PictureData pict,
                  Picture parent)
Description copied from interface: ImagePainter
Paints the specified picture data

Specified by:
paint in interface ImagePainter
Parameters:
graphics - the graphics to paintb into
pict - the data to paint
parent - the shapes that owns the picture data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DIB

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class DIB

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Bitmap
            extended by  org.apache.poi.hslf.blip.DIB

public final class DIB
extends Bitmap

Represents a DIB picture data in a PPT file

Author:
Yegor Kozlov

Field Summary
static int HEADER_SIZE
Size of the BITMAPFILEHEADER structure preceding the actual DIB bytes
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
DIB()
Method Summary
static byte[] | addBMPHeader(byte[] data)
byte[] | getData() Returns the binary data of this Picture
int | getSignature() DIB signature is 0x7A80
int | getType() Returns type of this picture.
void | setData(byte[] data) Set picture data
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getHeader, getImagePainter, getOffset, getRawData, getSize, getUID, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HEADER_SIZE

public static final int HEADER_SIZE
Size of the BITMAPFILEHEADER structure preceding the actual DIB bytes

See Also:
Constant Field Values
Constructor Detail

DIB

public DIB()
Method Detail

getType

public int getType()
Description copied from class: PictureData
Returns type of this picture. Must be one of the static constants defined in the Picture class.

Specified by:
getType in class PictureData
Returns:
type of this picture
See Also:
Picture.DIB

getSignature

public int getSignature()
DIB signature is 0x7A80

Specified by:
getSignature in class PictureData
Returns:
DIB signature (0x7A80)

getData

public byte[] getData()
Description copied from class: PictureData
Returns the binary data of this Picture

Overrides:
getData in class Bitmap
Returns:
picture data

addBMPHeader

public static byte[] addBMPHeader(byte[] data)

setData

public void setData(byte[] data)
             throws java.io.IOException
Description copied from class: PictureData
Set picture data

Overrides:
setData in class Bitmap
Throws:
java.io.IOException
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EMF

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class EMF

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Metafile
            extended by  org.apache.poi.hslf.blip.EMF

public final class EMF
extends Metafile

Represents EMF (Windows Enhanced Metafile) picture data.

Author:
Yegor Kozlov

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hslf.blip.Metafile
Metafile.Header
Field Summary
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
EMF()
Method Summary
byte[] | getData() Extract compressed EMF data from a ppt
int | getSignature() EMF signature is 0x3D40
int | getType() Returns type of this picture.
void | setData(byte[] data) Set picture data
Methods inherited from class org.apache.poi.hslf.blip.Metafile
compress
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getHeader, getImagePainter, getOffset, getRawData, getSize, getUID, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EMF

public EMF()
Method Detail

getData

public byte[] getData()
Extract compressed EMF data from a ppt

Specified by:
getData in class PictureData
Returns:
picture data

setData

public void setData(byte[] data)
             throws java.io.IOException
Description copied from class: PictureData
Set picture data

Specified by:
setData in class PictureData
Throws:
java.io.IOException

getType

public int getType()
Description copied from class: PictureData
Returns type of this picture. Must be one of the static constants defined in the Picture class.

Specified by:
getType in class PictureData
Returns:
type of this picture.

getSignature

public int getSignature()
EMF signature is 0x3D40

Specified by:
getSignature in class PictureData
Returns:
EMF signature (0x3D40)
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ImagePainter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Interface ImagePainter

All Known Implementing Classes:
BitmapPainter
public interface ImagePainter

A common interface for objects that can render ppt picture data.

Subclasses can redefine it and use third-party libraries for actual rendering, for example, Bitmaps can be rendered using javax.imageio.* , WMF can be rendered using Apache Batik, PICT can be rendered using Apple QuickTime API for Java, etc.

A typical usage is as follows:
public WMFPaiter implements ImagePainter{
  public void paint(Graphics2D graphics, PictureData pict, Picture parent){
      DataInputStream is = new DataInputStream(new ByteArrayInputStream(pict.getData()));
      org.apache.batik.transcoder.wmf.tosvg.WMFRecordStore wmfStore =
              new org.apache.batik.transcoder.wmf.tosvg.WMFRecordStore();
      try {
          wmfStore.read(is);
      } catch (IOException e){
          return;
      }

      Rectangle anchor = parent.getAnchor();
      float scale = (float)anchor.width/wmfStore.getWidthPixels();

      org.apache.batik.transcoder.wmf.tosvg.WMFPainter painter =
              new org.apache.batik.transcoder.wmf.tosvg.WMFPainter(wmfStore, 0, 0, scale);
      graphics.translate(anchor.x, anchor.y);
      painter.paint(graphics);
  }
}
PictureData.setImagePainter(Picture.WMF, new WMFPaiter());
...
 Subsequent calls of Slide.draw(Graphics gr) will use WMFPaiter for WMF images.

Author:
Yegor Kozlov.

Method Summary
 void paint(java.awt.Graphics2D graphics, PictureData pict, Picture parent)
Paints the specified picture data

Method Detail

paint

void paint(java.awt.Graphics2D graphics,
           PictureData pict,
           Picture parent)
Paints the specified picture data

Parameters:
graphics - the graphics to paintb into
pict - the data to paint
parent - the shapes that owns the picture data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JPEG

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class JPEG

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Bitmap
            extended by  org.apache.poi.hslf.blip.JPEG

public final class JPEG
extends Bitmap

Represents a JPEG picture data in a PPT file

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
JPEG()
Method Summary
int | getSignature() JPEG signature is 0x46A0
int | getType() Returns type of this picture.
Methods inherited from class org.apache.poi.hslf.blip.Bitmap
getData, setData
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getHeader, getImagePainter, getOffset, getRawData, getSize, getUID, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JPEG

public JPEG()
Method Detail

getType

public int getType()
Description copied from class: PictureData
Returns type of this picture. Must be one of the static constants defined in the Picture class.

Specified by:
getType in class PictureData
Returns:
type of this picture
See Also:
Picture.JPEG

getSignature

public int getSignature()
JPEG signature is 0x46A0

Specified by:
getSignature in class PictureData
Returns:
JPEG signature (0x46A0)
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Metafile.Header

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class Metafile.Header

java.lang.Object
    extended by  org.apache.poi.hslf.blip.Metafile.Header
Enclosing class:
Metafile
public static class Metafile.Header
extends java.lang.Object

A structure which represents a 34-byte header preceeding the compressed metafile data

Author:
Yegor Kozlov

Field Summary
java.awt.Rectangle | bounds Boundary of the metafile drawing commands
int | compression Reserved.
int | filter Reserved.
java.awt.Dimension | size Size of the metafile in EMUs
int | wmfsize size of the original file
int | zipsize size of the compressed metafile data
Constructor Summary
Metafile.Header()
Method Summary
int | getSize()
void | read(byte[] data, int offset)
void | write(java.io.OutputStream out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

wmfsize

public int wmfsize
size of the original file

bounds

public java.awt.Rectangle bounds
Boundary of the metafile drawing commands

size

public java.awt.Dimension size
Size of the metafile in EMUs

zipsize

public int zipsize
size of the compressed metafile data

compression

public int compression
Reserved. Always 0.

filter

public int filter
Reserved. Always 254.

Constructor Detail

Metafile.Header

public Metafile.Header()
Method Detail

read

public void read(byte[] data,
                 int offset)

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Throws:
java.io.IOException

getSize

public int getSize()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Metafile

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class Metafile

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Metafile
Direct Known Subclasses:
EMF, PICT, WMF
public abstract class Metafile
extends PictureData

Represents a metafile picture which can be one of the following types: EMF, WMF, or PICT. A metafile is stored compressed using the ZIP deflate/inflate algorithm.

Author:
Yegor Kozlov

Nested Class Summary
static class Metafile.Header
A structure which represents a 34-byte header preceeding the compressed metafile data
Field Summary
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
Metafile()
Method Summary
protected  byte[] compress(byte[] bytes, int offset, int length)
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getData, getHeader, getImagePainter, getOffset, getRawData, getSignature, getSize, getType, getUID, setData, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Metafile

public Metafile()
Method Detail

compress

protected byte[] compress(byte[] bytes,
                          int offset,
                          int length)
                   throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.blip
Interfaces
ImagePainter
Classes
Bitmap
BitmapPainter
DIB
EMF
JPEG
Metafile
Metafile.Header
PICT
PNG
WMF


org.apache.poi.hslf.blip

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.blip

Interface Summary
ImagePainter A common interface for objects that can render ppt picture data.

Class Summary
Bitmap | Represents a bitmap picture data: JPEG or PNG.
BitmapPainter | Creates BufferedImage using javax.imageio.ImageIO and draws it in the specified graphics.
DIB | Represents a DIB picture data in a PPT file
EMF | Represents EMF (Windows Enhanced Metafile) picture data.
JPEG | Represents a JPEG picture data in a PPT file
Metafile | Represents a metafile picture which can be one of the following types: EMF, WMF, or PICT.
Metafile.Header | A structure which represents a 34-byte header preceeding the compressed metafile data
PICT | Represents Macintosh PICT picture data.
PNG | Represents a PNG picture data in a PPT file
WMF | Represents a WMF (Windows Metafile) picture data.


org.apache.poi.hslf.blip Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.blip

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.blip.BitmapPainter (implements org.apache.poi.hslf.blip.ImagePainter)
    • org.apache.poi.hslf.blip.Metafile.Header
    • org.apache.poi.hslf.usermodel.PictureData
      • org.apache.poi.hslf.blip.Bitmap
        • org.apache.poi.hslf.blip.DIB
        • org.apache.poi.hslf.blip.JPEG
        • org.apache.poi.hslf.blip.PNG
      • org.apache.poi.hslf.blip.Metafile
        • org.apache.poi.hslf.blip.EMF
        • org.apache.poi.hslf.blip.PICT
        • org.apache.poi.hslf.blip.WMF
    • org.apache.poi.hslf.blip.WMF.AldusHeader

Interface Hierarchy

  • org.apache.poi.hslf.blip.ImagePainter


Uses of Package org.apache.poi.hslf.blip

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.blip

Packages that use org.apache.poi.hslf.blip
org.apache.poi.hslf.blip
org.apache.poi.hslf.usermodel

Classes in org.apache.poi.hslf.blip used by org.apache.poi.hslf.blip
Bitmap
Represents a bitmap picture data: JPEG or PNG.
ImagePainter
A common interface for objects that can render ppt picture data.
Metafile
Represents a metafile picture which can be one of the following types: EMF, WMF, or PICT.

Classes in org.apache.poi.hslf.blip used by org.apache.poi.hslf.usermodel
ImagePainter
A common interface for objects that can render ppt picture data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PICT

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class PICT

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Metafile
            extended by  org.apache.poi.hslf.blip.PICT

public final class PICT
extends Metafile

Represents Macintosh PICT picture data.

Author:
Yegor Kozlov

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hslf.blip.Metafile
Metafile.Header
Field Summary
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
PICT()
Method Summary
byte[] | getData() Extract compressed PICT data from a ppt
int | getSignature() PICT signature is 0x5430
int | getType() Returns type of this picture.
void | setData(byte[] data) Set picture data
Methods inherited from class org.apache.poi.hslf.blip.Metafile
compress
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getHeader, getImagePainter, getOffset, getRawData, getSize, getUID, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PICT

public PICT()
Method Detail

getData

public byte[] getData()
Extract compressed PICT data from a ppt

Specified by:
getData in class PictureData
Returns:
picture data

setData

public void setData(byte[] data)
             throws java.io.IOException
Description copied from class: PictureData
Set picture data

Specified by:
setData in class PictureData
Throws:
java.io.IOException

getType

public int getType()
Description copied from class: PictureData
Returns type of this picture. Must be one of the static constants defined in the Picture class.

Specified by:
getType in class PictureData
Returns:
type of this picture.
See Also:
Picture.PICT

getSignature

public int getSignature()
PICT signature is 0x5430

Specified by:
getSignature in class PictureData
Returns:
PICT signature (0x5430)
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PNG

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class PNG

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Bitmap
            extended by  org.apache.poi.hslf.blip.PNG

public final class PNG
extends Bitmap

Represents a PNG picture data in a PPT file

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
PNG()
Method Summary
byte[] | getData() Returns the binary data of this Picture
int | getSignature() PNG signature is 0x6E00
int | getType() Returns type of this picture.
Methods inherited from class org.apache.poi.hslf.blip.Bitmap
setData
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getHeader, getImagePainter, getOffset, getRawData, getSize, getUID, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PNG

public PNG()
Method Detail

getData

public byte[] getData()
Description copied from class: PictureData
Returns the binary data of this Picture

Overrides:
getData in class Bitmap
Returns:
PNG data

getType

public int getType()
Description copied from class: PictureData
Returns type of this picture. Must be one of the static constants defined in the Picture class.

Specified by:
getType in class PictureData
Returns:
type of this picture
See Also:
Picture.PNG

getSignature

public int getSignature()
PNG signature is 0x6E00

Specified by:
getSignature in class PictureData
Returns:
PNG signature (0x6E00)
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WMF.AldusHeader

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class WMF.AldusHeader

java.lang.Object
    extended by  org.apache.poi.hslf.blip.WMF.AldusHeader
Enclosing class:
WMF
public class WMF.AldusHeader
extends java.lang.Object

Aldus Placeable Metafile header - 22 byte structure before WMF data.

  • int Key; Magic number (always 9AC6CDD7h)
  • short Handle; Metafile HANDLE number (always 0)
  • short Left; Left coordinate in metafile units
  • short Top; Top coordinate in metafile units
  • short Right; Right coordinate in metafile units
  • short Bottom; Bottom coordinate in metafile units
  • short Inch; Number of metafile units per inch
  • int Reserved; Reserved (always 0)
  • short Checksum; Checksum value for previous 10 shorts

Field Summary
static int | APMHEADER_KEY
int | bottom
int | checksum
int | handle
int | inch
int | left
int | reserved
int | right
int | top
Constructor Summary
WMF.AldusHeader()
Method Summary
int | getChecksum() Returns a checksum value for the previous 10 shorts in the header.
int | getSize()
void | read(byte[] data, int offset)
void | write(java.io.OutputStream out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

APMHEADER_KEY

public static final int APMHEADER_KEY
See Also:
Constant Field Values

handle

public int handle

left

public int left

top

public int top

right

public int right

bottom

public int bottom

inch

public int inch

reserved

public int reserved

checksum

public int checksum
Constructor Detail

WMF.AldusHeader

public WMF.AldusHeader()
Method Detail

read

public void read(byte[] data,
                 int offset)

getChecksum

public int getChecksum()
Returns a checksum value for the previous 10 shorts in the header. The checksum is calculated by XORing each short value to an initial value of 0:

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Throws:
java.io.IOException

getSize

public int getSize()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


WMF

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.blip
Class WMF

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
        extended by  org.apache.poi.hslf.blip.Metafile
            extended by  org.apache.poi.hslf.blip.WMF

public final class WMF
extends Metafile

Represents a WMF (Windows Metafile) picture data.

Author:
Yegor Kozlov

Nested Class Summary
 class WMF.AldusHeader
Aldus Placeable Metafile header - 22 byte structure before WMF data.
Nested classes/interfaces inherited from class org.apache.poi.hslf.blip.Metafile
Metafile.Header
Field Summary
Fields inherited from class org.apache.poi.hslf.usermodel.PictureData
CHECKSUM_SIZE, logger, offset, painters
Constructor Summary
WMF()
Method Summary
byte[] | getData() Extract compressed WMF data from a ppt
int | getSignature() WMF signature is 0x2160
int | getType() We are of type Picture.WMF
void | setData(byte[] data) Set picture data
Methods inherited from class org.apache.poi.hslf.blip.Metafile
compress
Methods inherited from class org.apache.poi.hslf.usermodel.PictureData
create, draw, getChecksum, getHeader, getImagePainter, getOffset, getRawData, getSize, getUID, setImagePainter, setOffset, setRawData, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WMF

public WMF()
Method Detail

getData

public byte[] getData()
Extract compressed WMF data from a ppt

Specified by:
getData in class PictureData
Returns:
picture data

setData

public void setData(byte[] data)
             throws java.io.IOException
Description copied from class: PictureData
Set picture data

Specified by:
setData in class PictureData
Throws:
java.io.IOException

getType

public int getType()
We are of type Picture.WMF

Specified by:
getType in class PictureData
Returns:
type of this picture.

getSignature

public int getSignature()
WMF signature is 0x2160

Specified by:
getSignature in class PictureData
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.blip.Bitmap

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.Bitmap

Packages that use Bitmap
org.apache.poi.hslf.blip

Uses of Bitmap in org.apache.poi.hslf.blip

Subclasses of Bitmap in org.apache.poi.hslf.blip
class | DIB Represents a DIB picture data in a PPT file
class | JPEG Represents a JPEG picture data in a PPT file
class | PNG Represents a PNG picture data in a PPT file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.BitmapPainter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.BitmapPainter

No usage of org.apache.poi.hslf.blip.BitmapPainter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.DIB

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.DIB

No usage of org.apache.poi.hslf.blip.DIB

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.EMF

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.EMF

No usage of org.apache.poi.hslf.blip.EMF

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hslf.blip.ImagePainter

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hslf.blip.ImagePainter

Packages that use ImagePainter
org.apache.poi.hslf.blip
org.apache.poi.hslf.usermodel

Uses of ImagePainter in org.apache.poi.hslf.blip

Classes in org.apache.poi.hslf.blip that implement ImagePainter
 class BitmapPainter
Creates BufferedImage using javax.imageio.ImageIO and draws it in the specified graphics.

Uses of ImagePainter in org.apache.poi.hslf.usermodel

Fields in org.apache.poi.hslf.usermodel declared as ImagePainter
protected static ImagePainter[] PictureData.painters

Methods in org.apache.poi.hslf.usermodel that return ImagePainter
static ImagePainter PictureData.getImagePainter(int type)
Return ImagePainter for the specified image type

Methods in org.apache.poi.hslf.usermodel with parameters of type ImagePainter
static void PictureData.setImagePainter(int type, ImagePainter painter)
Register ImagePainter for the specified image type

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.JPEG

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.JPEG

No usage of org.apache.poi.hslf.blip.JPEG

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.Metafile.Header

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.Metafile.Header

No usage of org.apache.poi.hslf.blip.Metafile.Header

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.Metafile

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.Metafile

Packages that use Metafile
org.apache.poi.hslf.blip

Uses of Metafile in org.apache.poi.hslf.blip

Subclasses of Metafile in org.apache.poi.hslf.blip
class | EMF Represents EMF (Windows Enhanced Metafile) picture data.
class | PICT Represents Macintosh PICT picture data.
class | WMF Represents a WMF (Windows Metafile) picture data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.PICT

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.PICT

No usage of org.apache.poi.hslf.blip.PICT

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.PNG

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.PNG

No usage of org.apache.poi.hslf.blip.PNG

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.WMF.AldusHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.WMF.AldusHeader

No usage of org.apache.poi.hslf.blip.WMF.AldusHeader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.blip.WMF

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.blip.WMF

No usage of org.apache.poi.hslf.blip.WMF

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.EncryptedSlideShow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.EncryptedSlideShow

No usage of org.apache.poi.hslf.EncryptedSlideShow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.HSLFSlideShow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.HSLFSlideShow

Packages that use HSLFSlideShow
org.apache.poi.hslf
org.apache.poi.hslf.extractor
org.apache.poi.hslf.usermodel

Uses of HSLFSlideShow in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return HSLFSlideShow
static HSLFSlideShow HSLFSlideShow.create()
Constructs a new, empty, Powerpoint document.

Methods in org.apache.poi.hslf with parameters of type HSLFSlideShow
static boolean | EncryptedSlideShow.checkIfEncrypted(HSLFSlideShow hss) Check to see if a HSLFSlideShow represents an encrypted PowerPoint document, or not
static DocumentEncryptionAtom | EncryptedSlideShow.fetchDocumentEncryptionAtom(HSLFSlideShow hss) Return the DocumentEncryptionAtom for a HSLFSlideShow, or null if there isn't one.

Uses of HSLFSlideShow in org.apache.poi.hslf.extractor

Constructors in org.apache.poi.hslf.extractor with parameters of type HSLFSlideShow
PowerPointExtractor(HSLFSlideShow ss)
Creates a PowerPointExtractor, from a HSLFSlideShow

Uses of HSLFSlideShow in org.apache.poi.hslf.usermodel

Constructors in org.apache.poi.hslf.usermodel with parameters of type HSLFSlideShow
SlideShow(HSLFSlideShow hslfSlideShow)
Constructs a Powerpoint document from the underlying HSLFSlideShow object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hslf.dev
Classes
PPDrawingTextListing
PPTXMLDump
SlideAndNotesAtomListing
SlideIdListing
SlideShowDumper
SlideShowRecordDumper
SLWTListing
SLWTTextListing
TextStyleListing
UserEditAndPersistListing


org.apache.poi.hslf.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.dev

Class Summary
PPDrawingTextListing | Uses record level code to locate PPDrawing entries.
PPTXMLDump | Utility class which dumps raw contents of a ppt file into XML format
SlideAndNotesAtomListing | Uses record level code to locate Notes and Slide records.
SlideIdListing | Gets all the different things that have Slide IDs (of sorts) in them, and displays them, so you can try to guess what they all mean
SlideShowDumper | This class provides a way to "peek" inside a powerpoint file.
SlideShowRecordDumper | This class provides a way to view the contents of a powerpoint file.
SLWTListing | Uses record level code to Documents.
SLWTTextListing | Uses record level code to locate SlideListWithText entries.
TextStyleListing | Uses record level code to locate StyleTextPropAtom entries.
UserEditAndPersistListing | Uses record level code to locate UserEditAtom records, and other persistence related atoms.


org.apache.poi.hslf.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.dev.PPDrawingTextListing
    • org.apache.poi.hslf.dev.PPTXMLDump
    • org.apache.poi.hslf.dev.SlideAndNotesAtomListing
    • org.apache.poi.hslf.dev.SlideIdListing
    • org.apache.poi.hslf.dev.SlideShowDumper
    • org.apache.poi.hslf.dev.SlideShowRecordDumper
    • org.apache.poi.hslf.dev.SLWTListing
    • org.apache.poi.hslf.dev.SLWTTextListing
    • org.apache.poi.hslf.dev.TextStyleListing
    • org.apache.poi.hslf.dev.UserEditAndPersistListing


Uses of Package org.apache.poi.hslf.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.dev

No usage of org.apache.poi.hslf.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PPDrawingTextListing

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class PPDrawingTextListing

java.lang.Object
    extended by  org.apache.poi.hslf.dev.PPDrawingTextListing

public final class PPDrawingTextListing
extends java.lang.Object

Uses record level code to locate PPDrawing entries. Having found them, it sees if they have DDF Textbox records, and if so, searches those for text. Prints out any text it finds

Constructor Summary
PPDrawingTextListing()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PPDrawingTextListing

public PPDrawingTextListing()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PPTXMLDump

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class PPTXMLDump

java.lang.Object
    extended by  org.apache.poi.hslf.dev.PPTXMLDump

public final class PPTXMLDump
extends java.lang.Object

Utility class which dumps raw contents of a ppt file into XML format

Author:
Yegor Kozlov

Field Summary
static java.lang.String | CR
protected byte[] | docstream
static int | HEADER_SIZE
protected boolean | hexHeader
protected java.io.Writer | out
static int | PICT_HEADER_SIZE
protected byte[] | pictstream
static java.lang.String | PICTURES_ENTRY
static java.lang.String | PPDOC_ENTRY
Constructor Summary
PPTXMLDump(java.io.File ppt)
Method Summary
void | dump(byte[] data, int offset, int length, int padding) Dump a part of the document stream into XML
void | dump(java.io.Writer out) Dump the structure of the supplied PPT file into XML
void | dumpPictures(byte[] data, int padding) Dumps the Pictures OLE stream into XML.
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HEADER_SIZE

public static final int HEADER_SIZE
See Also:
Constant Field Values

PICT_HEADER_SIZE

public static final int PICT_HEADER_SIZE
See Also:
Constant Field Values

PPDOC_ENTRY

public static final java.lang.String PPDOC_ENTRY
See Also:
Constant Field Values

PICTURES_ENTRY

public static final java.lang.String PICTURES_ENTRY
See Also:
Constant Field Values

CR

public static java.lang.String CR

out

protected java.io.Writer out

docstream

protected byte[] docstream

pictstream

protected byte[] pictstream

hexHeader

protected boolean hexHeader
Constructor Detail

PPTXMLDump

public PPTXMLDump(java.io.File ppt)
           throws java.io.IOException
Throws:
java.io.IOException
Method Detail

dump

public void dump(java.io.Writer out)
          throws java.io.IOException
Dump the structure of the supplied PPT file into XML

Parameters:
out - Writer to write out
Throws:
java.io.IOException

dump

public void dump(byte[] data,
                 int offset,
                 int length,
                 int padding)
          throws java.io.IOException
Dump a part of the document stream into XML

Parameters:
data - PPT binary data
offset - offset from the beginning of the document
length - of the document
padding - used for formatting results
Throws:
java.io.IOException

dumpPictures

public void dumpPictures(byte[] data,
                         int padding)
                  throws java.io.IOException
Dumps the Pictures OLE stream into XML.

Parameters:
data - from the Pictures OLE data stream
padding -
Throws:
java.io.IOException

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideAndNotesAtomListing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class SlideAndNotesAtomListing

java.lang.Object
    extended by  org.apache.poi.hslf.dev.SlideAndNotesAtomListing

public final class SlideAndNotesAtomListing
extends java.lang.Object

Uses record level code to locate Notes and Slide records. Having found them, it asks their SlideAtom or NotesAtom entries what they are all about. Useful for checking the matching between Slides, Master Slides and Notes

Constructor Summary
SlideAndNotesAtomListing()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlideAndNotesAtomListing

public SlideAndNotesAtomListing()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideIdListing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class SlideIdListing

java.lang.Object
    extended by  org.apache.poi.hslf.dev.SlideIdListing

public final class SlideIdListing
extends java.lang.Object

Gets all the different things that have Slide IDs (of sorts) in them, and displays them, so you can try to guess what they all mean

Constructor Summary
SlideIdListing()
Method Summary
static Record | findRecordAtPos(int pos)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlideIdListing

public SlideIdListing()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

findRecordAtPos

public static Record findRecordAtPos(int pos)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideShowDumper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class SlideShowDumper

java.lang.Object
    extended by  org.apache.poi.hslf.dev.SlideShowDumper

public final class SlideShowDumper
extends java.lang.Object

This class provides a way to "peek" inside a powerpoint file. It will print out all the types it find, and for those it know aren't atoms, what they contain To figure out what things are, and if they are atoms or not, used the list in hslf.record.RecordTypes To peek inside PPDrawings, which hold Escher drawings, we use the DDF package from POI (but we can fake it by using the Escher listings from hslf.record.RecordTypes also)

Author:
Nick Burch

Constructor Summary
SlideShowDumper(java.io.InputStream inputStream)
Constructs a Powerpoint dump from an input stream.
SlideShowDumper(POIFSFileSystem filesystem)
Constructs a Powerpoint dump from a POIFS Filesystem.
SlideShowDumper(java.lang.String fileName)
Constructs a Powerpoint dump from fileName.
Method Summary
void | close() Shuts things down.
static void | main(java.lang.String[] args) right now this function takes one parameter: a ppt file, and outputs a dump of what it contains
java.lang.String | makeHex(int i)
java.lang.String | makeHex(short s)
void | printDump()
void | setBasicEscher(boolean grok) Control dumping of any Escher records found - should our built in basic groker be used?
void | setDDFEscher(boolean grok) Control dumping of any Escher records found - should DDF be used?
void | walkEscherBasic(int indent, int pos, int len) Use the basic record format groking code to walk the Escher records
void | walkEscherDDF(int indent, int pos, int len) Use the DDF code to walk the Escher records
void | walkTree(int depth, int startPos, int maxLen)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlideShowDumper

public SlideShowDumper(java.lang.String fileName)
                throws java.io.IOException
Constructs a Powerpoint dump from fileName. Parses the document and dumps out the contents

Parameters:
fileName - The name of the file to read.
Throws:
java.io.IOException - if there is a problem while parsing the document.

SlideShowDumper

public SlideShowDumper(java.io.InputStream inputStream)
                throws java.io.IOException
Constructs a Powerpoint dump from an input stream. Parses the document and dumps out the contents

Parameters:
inputStream - the source of the data
Throws:
java.io.IOException - if there is a problem while parsing the document.

SlideShowDumper

public SlideShowDumper(POIFSFileSystem filesystem)
                throws java.io.IOException
Constructs a Powerpoint dump from a POIFS Filesystem. Parses the document and dumps out the contents

Parameters:
filesystem - the POIFS FileSystem to read from
Throws:
java.io.IOException - if there is a problem while parsing the document.
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
right now this function takes one parameter: a ppt file, and outputs a dump of what it contains

Throws:
java.io.IOException

setDDFEscher

public void setDDFEscher(boolean grok)
Control dumping of any Escher records found - should DDF be used?

setBasicEscher

public void setBasicEscher(boolean grok)
Control dumping of any Escher records found - should our built in basic groker be used?

close

public void close()
           throws java.io.IOException
Shuts things down. Closes underlying streams etc

Throws:
java.io.IOException

printDump

public void printDump()

makeHex

public java.lang.String makeHex(short s)

makeHex

public java.lang.String makeHex(int i)

walkTree

public void walkTree(int depth,
                     int startPos,
                     int maxLen)

walkEscherDDF

public void walkEscherDDF(int indent,
                          int pos,
                          int len)
Use the DDF code to walk the Escher records

walkEscherBasic

public void walkEscherBasic(int indent,
                            int pos,
                            int len)
Use the basic record format groking code to walk the Escher records

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideShowRecordDumper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class SlideShowRecordDumper

java.lang.Object
    extended by  org.apache.poi.hslf.dev.SlideShowRecordDumper

public final class SlideShowRecordDumper
extends java.lang.Object

This class provides a way to view the contents of a powerpoint file. It will use the recored layer to grok the contents of the file, and will print out what it finds.

Author:
Nick Burch

Constructor Summary
SlideShowRecordDumper(java.lang.String fileName, boolean verbose, boolean escher)
Constructs a Powerpoint dump from fileName.
Method Summary
int | getDiskLen(Record r)
java.lang.String | getPrintableRecordContents(Record r)
static void | main(java.lang.String[] args) right now this function takes one parameter: a ppt file, and outputs a dump of what it contains
java.lang.String | makeHex(int number, int padding)
void | printDump()
java.lang.String | printEscherContainerRecord(EscherContainerRecord ecr)
java.lang.String | printEscherRecord(EscherRecord er)
static void | printUsage()
java.lang.String | reverseHex(java.lang.String s)
void | walkTree(int depth, int pos, Record[] records)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlideShowRecordDumper

public SlideShowRecordDumper(java.lang.String fileName,
                             boolean verbose,
                             boolean escher)
                      throws java.io.IOException
Constructs a Powerpoint dump from fileName. Parses the document and dumps out the contents

Parameters:
fileName - The name of the file to read.
Throws:
java.io.IOException - if there is a problem while parsing the document.
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
right now this function takes one parameter: a ppt file, and outputs a dump of what it contains

Throws:
java.io.IOException

printUsage

public static void printUsage()

printDump

public void printDump()
               throws java.io.IOException
Throws:
java.io.IOException

makeHex

public java.lang.String makeHex(int number,
                                int padding)

reverseHex

public java.lang.String reverseHex(java.lang.String s)

getDiskLen

public int getDiskLen(Record r)
               throws java.io.IOException
Throws:
java.io.IOException

getPrintableRecordContents

public java.lang.String getPrintableRecordContents(Record r)
                                            throws java.io.IOException
Throws:
java.io.IOException

printEscherRecord

public java.lang.String printEscherRecord(EscherRecord er)

printEscherContainerRecord

public java.lang.String printEscherContainerRecord(EscherContainerRecord ecr)

walkTree

public void walkTree(int depth,
                     int pos,
                     Record[] records)
              throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SLWTListing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class SLWTListing

java.lang.Object
    extended by  org.apache.poi.hslf.dev.SLWTListing

public final class SLWTListing
extends java.lang.Object

Uses record level code to Documents. Having found them, it sees if they have any SlideListWithTexts, and reports how many, and what sorts of things they contain

Constructor Summary
SLWTListing()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SLWTListing

public SLWTListing()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SLWTTextListing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class SLWTTextListing

java.lang.Object
    extended by  org.apache.poi.hslf.dev.SLWTTextListing

public final class SLWTTextListing
extends java.lang.Object

Uses record level code to locate SlideListWithText entries. Having found them, it sees if they have any text, and prints out what it finds.

Constructor Summary
SLWTTextListing()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SLWTTextListing

public SLWTTextListing()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextStyleListing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class TextStyleListing

java.lang.Object
    extended by  org.apache.poi.hslf.dev.TextStyleListing

public final class TextStyleListing
extends java.lang.Object

Uses record level code to locate StyleTextPropAtom entries. Having found them, it shows the contents

Constructor Summary
TextStyleListing()
Method Summary
static void | main(java.lang.String[] args)
static void | showStyleTextPropAtom(StyleTextPropAtom stpa)
static void | showTextProps(TextPropCollection tpc)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextStyleListing

public TextStyleListing()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

showStyleTextPropAtom

public static void showStyleTextPropAtom(StyleTextPropAtom stpa)

showTextProps

public static void showTextProps(TextPropCollection tpc)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserEditAndPersistListing

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.dev
Class UserEditAndPersistListing

java.lang.Object
    extended by  org.apache.poi.hslf.dev.UserEditAndPersistListing

public final class UserEditAndPersistListing
extends java.lang.Object

Uses record level code to locate UserEditAtom records, and other persistence related atoms. Tries to match them together, to help illuminate quite what all the offsets mean

Constructor Summary
UserEditAndPersistListing()
Method Summary
static Record | findRecordAtPos(int pos)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UserEditAndPersistListing

public UserEditAndPersistListing()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

findRecordAtPos

public static Record findRecordAtPos(int pos)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.dev.PPDrawingTextListing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.PPDrawingTextListing

No usage of org.apache.poi.hslf.dev.PPDrawingTextListing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.PPTXMLDump

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.PPTXMLDump

No usage of org.apache.poi.hslf.dev.PPTXMLDump

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.SlideAndNotesAtomListing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.SlideAndNotesAtomListing

No usage of org.apache.poi.hslf.dev.SlideAndNotesAtomListing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.SlideIdListing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.SlideIdListing

No usage of org.apache.poi.hslf.dev.SlideIdListing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.SlideShowDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.SlideShowDumper

No usage of org.apache.poi.hslf.dev.SlideShowDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.SlideShowRecordDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.SlideShowRecordDumper

No usage of org.apache.poi.hslf.dev.SlideShowRecordDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.SLWTListing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.SLWTListing

No usage of org.apache.poi.hslf.dev.SLWTListing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.SLWTTextListing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.SLWTTextListing

No usage of org.apache.poi.hslf.dev.SLWTTextListing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.TextStyleListing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.TextStyleListing

No usage of org.apache.poi.hslf.dev.TextStyleListing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.dev.UserEditAndPersistListing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.dev.UserEditAndPersistListing

No usage of org.apache.poi.hslf.dev.UserEditAndPersistListing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CorruptPowerPointFileException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.exceptions
Class CorruptPowerPointFileException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalStateException
                    extended by  org.apache.poi.hslf.exceptions.CorruptPowerPointFileException
All Implemented Interfaces:
java.io.Serializable
public final class CorruptPowerPointFileException
extends java.lang.IllegalStateException

This exception is thrown when we try to open a PowerPoint file, and something is fundamentally broken about it.

Author:
Nick Burch
See Also:
Serialized Form

Constructor Summary
CorruptPowerPointFileException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CorruptPowerPointFileException

public CorruptPowerPointFileException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EncryptedPowerPointFileException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.exceptions
Class EncryptedPowerPointFileException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalStateException
                    extended by  org.apache.poi.EncryptedDocumentException
                        extended by  org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException
All Implemented Interfaces:
java.io.Serializable
public final class EncryptedPowerPointFileException
extends EncryptedDocumentException

This exception is thrown when we try to open a PowerPoint file, and discover that it is encrypted

See Also:
Serialized Form

Constructor Summary
EncryptedPowerPointFileException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EncryptedPowerPointFileException

public EncryptedPowerPointFileException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSLFException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.exceptions
Class HSLFException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hslf.exceptions.HSLFException
All Implemented Interfaces:
java.io.Serializable
public final class HSLFException
extends java.lang.RuntimeException

A generic exception that can be thrown by HSLF classes

Author:
Yegor Kozlov
See Also:
Serialized Form

Constructor Summary
HSLFException()
HSLFException(java.lang.String message)
HSLFException(java.lang.String message, java.lang.Throwable cause)
HSLFException(java.lang.Throwable cause)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HSLFException

public HSLFException()

HSLFException

public HSLFException(java.lang.String message)

HSLFException

public HSLFException(java.lang.String message,
                     java.lang.Throwable cause)

HSLFException

public HSLFException(java.lang.Throwable cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvalidRecordFormatException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.exceptions
Class InvalidRecordFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hslf.exceptions.InvalidRecordFormatException
All Implemented Interfaces:
java.io.Serializable
public final class InvalidRecordFormatException
extends java.lang.Exception

This exception is thrown when we try to create a record, and the underlying data just doesn't match up

Author:
Nick Burch
See Also:
Serialized Form

Constructor Summary
InvalidRecordFormatException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRecordFormatException

public InvalidRecordFormatException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OldPowerPointFormatException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.exceptions
Class OldPowerPointFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalArgumentException
                    extended by  org.apache.poi.OldFileFormatException
                        extended by  org.apache.poi.hslf.exceptions.OldPowerPointFormatException
All Implemented Interfaces:
java.io.Serializable
public class OldPowerPointFormatException
extends OldFileFormatException

This exception is thrown when we try to open a PowerPoint file, and it's too old for us.

See Also:
Serialized Form

Constructor Summary
OldPowerPointFormatException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OldPowerPointFormatException

public OldPowerPointFormatException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.exceptions
Exceptions
CorruptPowerPointFileException
EncryptedPowerPointFileException
HSLFException
InvalidRecordFormatException
OldPowerPointFormatException


org.apache.poi.hslf.exceptions

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.exceptions

Exception Summary
CorruptPowerPointFileException | This exception is thrown when we try to open a PowerPoint file, and something is fundamentally broken about it.
EncryptedPowerPointFileException | This exception is thrown when we try to open a PowerPoint file, and discover that it is encrypted
HSLFException | A generic exception that can be thrown by HSLF classes
InvalidRecordFormatException | This exception is thrown when we try to create a record, and the underlying data just doesn't match up
OldPowerPointFormatException | This exception is thrown when we try to open a PowerPoint file, and it's too old for us.


org.apache.poi.hslf.exceptions Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.exceptions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.hslf.exceptions.InvalidRecordFormatException
        • java.lang.RuntimeException
          • org.apache.poi.hslf.exceptions.HSLFException
          • java.lang.IllegalArgumentException
            • org.apache.poi.OldFileFormatException
              • org.apache.poi.hslf.exceptions.OldPowerPointFormatException
          • java.lang.IllegalStateException
            • org.apache.poi.hslf.exceptions.CorruptPowerPointFileException
            • org.apache.poi.EncryptedDocumentException
              • org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException


Uses of Package org.apache.poi.hslf.exceptions

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.exceptions

No usage of org.apache.poi.hslf.exceptions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.exceptions.CorruptPowerPointFileException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.exceptions.CorruptPowerPointFileException

No usage of org.apache.poi.hslf.exceptions.CorruptPowerPointFileException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException

No usage of org.apache.poi.hslf.exceptions.EncryptedPowerPointFileException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.exceptions.HSLFException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.exceptions.HSLFException

No usage of org.apache.poi.hslf.exceptions.HSLFException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.exceptions.InvalidRecordFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.exceptions.InvalidRecordFormatException

No usage of org.apache.poi.hslf.exceptions.InvalidRecordFormatException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.exceptions.OldPowerPointFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.exceptions.OldPowerPointFormatException

No usage of org.apache.poi.hslf.exceptions.OldPowerPointFormatException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ImageExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.extractor
Class ImageExtractor

java.lang.Object
    extended by  org.apache.poi.hslf.extractor.ImageExtractor

public final class ImageExtractor
extends java.lang.Object

Utility to extract pictures from a PowerPoint file.

Author:
Yegor Kozlov

Constructor Summary
ImageExtractor()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ImageExtractor

public ImageExtractor()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.extractor
Classes
ImageExtractor
PowerPointExtractor
QuickButCruddyTextExtractor


org.apache.poi.hslf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.extractor

Class Summary
ImageExtractor | Utility to extract pictures from a PowerPoint file.
PowerPointExtractor | This class can be used to extract text from a PowerPoint file.
QuickButCruddyTextExtractor | This class will get all the text from a Powerpoint Document, including all the bits you didn't want, and in a somewhat random order, but will do it very fast.


org.apache.poi.hslf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.extractor.ImageExtractor
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIOLE2TextExtractor
        • org.apache.poi.hslf.extractor.PowerPointExtractor
    • org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor


Uses of Package org.apache.poi.hslf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.extractor

No usage of org.apache.poi.hslf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PowerPointExtractor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.extractor
Class PowerPointExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hslf.extractor.PowerPointExtractor

public final class PowerPointExtractor
extends POIOLE2TextExtractor

This class can be used to extract text from a PowerPoint file. Can optionally also get the notes from one.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
PowerPointExtractor(DirectoryNode dir)
Creates a PowerPointExtractor, from a specific place inside an open NPOIFSFileSystem
PowerPointExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use PowerPointExtractor(DirectoryNode) instead
PowerPointExtractor(HSLFSlideShow ss)
Creates a PowerPointExtractor, from a HSLFSlideShow
PowerPointExtractor(java.io.InputStream iStream)
Creates a PowerPointExtractor, from an Input Stream
PowerPointExtractor(NPOIFSFileSystem fs)
Creates a PowerPointExtractor, from an open NPOIFSFileSystem
PowerPointExtractor(POIFSFileSystem fs)
Creates a PowerPointExtractor, from an open POIFSFileSystem
PowerPointExtractor(java.lang.String fileName)
Creates a PowerPointExtractor, from a file
Method Summary
 java.lang.String getNotes()
Fetches all the notes text from the slideshow, but not the slide text
 java.util.List<OLEShape> getOLEShapes()
 java.lang.String getText()
Fetches all the slide text from the slideshow, but not the notes, unless you've called setSlidesByDefault() and setNotesByDefault() to change this
 java.lang.String getText(boolean getSlideText, boolean getNoteText)
Fetches text from the slideshow, be it slide text or note text.
 java.lang.String getText(boolean getSlideText, boolean getNoteText, boolean getCommentText, boolean getMasterText)
static void main(java.lang.String[] args)
Basic extractor.
 void setCommentsByDefault(boolean commentsByDefault)
Should a call to getText() return comments text? Default is no
 void setMasterByDefault(boolean masterByDefault)
Should a call to getText() return text from master? Default is no
 void setNotesByDefault(boolean notesByDefault)
Should a call to getText() return notes text? Default is no
 void setSlidesByDefault(boolean slidesByDefault)
Should a call to getText() return slide text? Default is yes
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getDocSummaryInformation, getFileSystem, getMetadataTextExtractor, getRoot, getSummaryInformation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PowerPointExtractor

public PowerPointExtractor(java.lang.String fileName)
                    throws java.io.IOException
Creates a PowerPointExtractor, from a file

Parameters:
fileName - The name of the file to extract from
Throws:
java.io.IOException

PowerPointExtractor

public PowerPointExtractor(java.io.InputStream iStream)
                    throws java.io.IOException
Creates a PowerPointExtractor, from an Input Stream

Parameters:
iStream - The input stream containing the PowerPoint document
Throws:
java.io.IOException

PowerPointExtractor

public PowerPointExtractor(POIFSFileSystem fs)
                    throws java.io.IOException
Creates a PowerPointExtractor, from an open POIFSFileSystem

Parameters:
fs - the POIFSFileSystem containing the PowerPoint document
Throws:
java.io.IOException

PowerPointExtractor

public PowerPointExtractor(NPOIFSFileSystem fs)
                    throws java.io.IOException
Creates a PowerPointExtractor, from an open NPOIFSFileSystem

Parameters:
fs - the NPOIFSFileSystem containing the PowerPoint document
Throws:
java.io.IOException

PowerPointExtractor

public PowerPointExtractor(DirectoryNode dir)
                    throws java.io.IOException
Creates a PowerPointExtractor, from a specific place inside an open NPOIFSFileSystem

Parameters:
dir - the POIFS Directory containing the PowerPoint document
Throws:
java.io.IOException

PowerPointExtractor

@Deprecated
public PowerPointExtractor(DirectoryNode dir,
                                      POIFSFileSystem fs)
                    throws java.io.IOException
Deprecated. Use PowerPointExtractor(DirectoryNode) instead

Throws:
java.io.IOException

PowerPointExtractor

public PowerPointExtractor(HSLFSlideShow ss)
Creates a PowerPointExtractor, from a HSLFSlideShow

Parameters:
ss - the HSLFSlideShow to extract text from
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Basic extractor. Returns all the text, and optionally all the notes

Throws:
java.io.IOException

setSlidesByDefault

public void setSlidesByDefault(boolean slidesByDefault)
Should a call to getText() return slide text? Default is yes

setNotesByDefault

public void setNotesByDefault(boolean notesByDefault)
Should a call to getText() return notes text? Default is no

setCommentsByDefault

public void setCommentsByDefault(boolean commentsByDefault)
Should a call to getText() return comments text? Default is no

setMasterByDefault

public void setMasterByDefault(boolean masterByDefault)
Should a call to getText() return text from master? Default is no

getText

public java.lang.String getText()
Fetches all the slide text from the slideshow, but not the notes, unless you've called setSlidesByDefault() and setNotesByDefault() to change this

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

getNotes

public java.lang.String getNotes()
Fetches all the notes text from the slideshow, but not the slide text

getOLEShapes

public java.util.List<OLEShape> getOLEShapes()

getText

public java.lang.String getText(boolean getSlideText,
                                boolean getNoteText)
Fetches text from the slideshow, be it slide text or note text. Because the final block of text in a TextRun normally have their last \n stripped, we add it back

Parameters:
getSlideText - fetch slide text
getNoteText - fetch note text

getText

public java.lang.String getText(boolean getSlideText,
                                boolean getNoteText,
                                boolean getCommentText,
                                boolean getMasterText)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuickButCruddyTextExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.extractor
Class QuickButCruddyTextExtractor

java.lang.Object
    extended by  org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor

public final class QuickButCruddyTextExtractor
extends java.lang.Object

This class will get all the text from a Powerpoint Document, including all the bits you didn't want, and in a somewhat random order, but will do it very fast. The class ignores most of the hslf classes, and doesn't use HSLFSlideShow. Instead, it just does a very basic scan through the file, grabbing all the text records as it goes. It then returns the text, either as a single string, or as a vector of all the individual strings. Because of how it works, it will return a lot of "crud" text that you probably didn't want! It will return text from master slides. It will return duplicate text, and some mangled text (powerpoint files often have duplicate copies of slide text in them). You don't get any idea what the text was associated with. Almost everyone will want to use @see PowerPointExtractor instead. There are only a very small number of cases (eg some performance sensitive lucene indexers) that would ever want to use this!

Author:
Nick Burch

Constructor Summary
QuickButCruddyTextExtractor(java.io.InputStream iStream)
Creates an extractor from a given input stream
QuickButCruddyTextExtractor(POIFSFileSystem poifs)
Creates an extractor from a POIFS Filesystem
QuickButCruddyTextExtractor(java.lang.String fileName)
Creates an extractor from a given file name
Method Summary
void | close() Shuts down the underlying streams
int | findTextRecords(int startPos, java.util.Vector<java.lang.String> textV) For the given position, look if the record is a text record, and wind on after.
java.lang.String | getTextAsString() Fetches the ALL the text of the powerpoint file, as a single string
java.util.Vector<java.lang.String> | getTextAsVector() Fetches the ALL the text of the powerpoint file, in a vector of strings, one per text record
static void | main(java.lang.String[] args) Really basic text extractor, that will also return lots of crud text.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QuickButCruddyTextExtractor

public QuickButCruddyTextExtractor(java.lang.String fileName)
                            throws java.io.IOException
Creates an extractor from a given file name

Parameters:
fileName -
Throws:
java.io.IOException

QuickButCruddyTextExtractor

public QuickButCruddyTextExtractor(java.io.InputStream iStream)
                            throws java.io.IOException
Creates an extractor from a given input stream

Parameters:
iStream -
Throws:
java.io.IOException

QuickButCruddyTextExtractor

public QuickButCruddyTextExtractor(POIFSFileSystem poifs)
                            throws java.io.IOException
Creates an extractor from a POIFS Filesystem

Parameters:
poifs -
Throws:
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Really basic text extractor, that will also return lots of crud text. Takes a single argument, the file to extract from

Throws:
java.io.IOException

close

public void close()
           throws java.io.IOException
Shuts down the underlying streams

Throws:
java.io.IOException

getTextAsString

public java.lang.String getTextAsString()
Fetches the ALL the text of the powerpoint file, as a single string

getTextAsVector

public java.util.Vector<java.lang.String> getTextAsVector()
Fetches the ALL the text of the powerpoint file, in a vector of strings, one per text record

findTextRecords

public int findTextRecords(int startPos,
                           java.util.Vector<java.lang.String> textV)
For the given position, look if the record is a text record, and wind on after. If it is a text record, grabs out the text. Whatever happens, returns the position of the next record, or -1 if no more.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.extractor.ImageExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.extractor.ImageExtractor

No usage of org.apache.poi.hslf.extractor.ImageExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.extractor.PowerPointExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.extractor.PowerPointExtractor

No usage of org.apache.poi.hslf.extractor.PowerPointExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor

No usage of org.apache.poi.hslf.extractor.QuickButCruddyTextExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActiveXShape

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class ActiveXShape

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.Picture
                extended by  org.apache.poi.hslf.model.ActiveXShape

public final class ActiveXShape
extends Picture

Represents an ActiveX control in a PowerPoint document. TODO: finish

Author:
Yegor Kozlov

Field Summary
static int DEFAULT_ACTIVEX_THUMBNAIL
Fields inherited from class org.apache.poi.hslf.model.Picture
DIB, EMF, JPEG, PICT, PNG, WMF
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected | ActiveXShape(EscherContainerRecord escherRecord, Shape parent) Create a Picture object
 | ActiveXShape(int movieIdx, int pictureIdx) Create a new Picture
Method Summary
protected void | afterInsert(Sheet sheet) By default set the orininal image size
protected EscherContainerRecord | createSpContainer(int idx, boolean isChild) Create a new Placeholder and initialize internal structures
int | getControlIndex()
ExControl | getExControl() Document-level container that specifies information about an ActiveX control
void | setActiveXIndex(int idx) Assign a control to this shape
void | setProperty(java.lang.String key, java.lang.String value) Set a property of this ActiveX control
Methods inherited from class org.apache.poi.hslf.model.Picture
draw, getEscherBSERecord, getPictureData, getPictureIndex, getPictureName, setDefaultSize, setPictureName
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_ACTIVEX_THUMBNAIL

public static final int DEFAULT_ACTIVEX_THUMBNAIL
See Also:
Constant Field Values
Constructor Detail

ActiveXShape

public ActiveXShape(int movieIdx,
                    int pictureIdx)
Create a new Picture

Parameters:
pictureIdx - the index of the picture

ActiveXShape

protected ActiveXShape(EscherContainerRecord escherRecord,
                       Shape parent)
Create a Picture object

Parameters:
escherRecord - the EscherSpContainer record which holds information about this picture in the Slide
parent - the parent shape of this picture
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(int idx,
                                                  boolean isChild)
Create a new Placeholder and initialize internal structures

Overrides:
createSpContainer in class Picture
Parameters:
idx - the index of the picture which referes to EscherBSE container.
Returns:
the created EscherContainerRecord which holds shape data

setActiveXIndex

public void setActiveXIndex(int idx)
Assign a control to this shape

Parameters:
idx - the index of the movie
See Also:
SlideShow.addMovie(String, int)

getControlIndex

public int getControlIndex()

setProperty

public void setProperty(java.lang.String key,
                        java.lang.String value)
Set a property of this ActiveX control

Parameters:
key -
value -

getExControl

public ExControl getExControl()
Document-level container that specifies information about an ActiveX control

Returns:
container that specifies information about an ActiveX control

afterInsert

protected void afterInsert(Sheet sheet)
Description copied from class: Picture
By default set the orininal image size

Overrides:
afterInsert in class Picture
Parameters:
sheet - - owning shape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AutoShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class AutoShape

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.TextShape
                extended by  org.apache.poi.hslf.model.AutoShape
Direct Known Subclasses:
Freeform, Polygon
public class AutoShape
extends TextShape

Represents an AutoShape.

AutoShapes are drawing objects with a particular shape that may be customized through smart resizing and adjustments. See ShapeTypes

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.model.TextShape
_frc, _txtbox, _txtrun, AlignCenter, AlignJustify, AlignLeft, AlignRight, AnchorBottom, AnchorBottomBaseline, AnchorBottomCentered, AnchorBottomCenteredBaseline, AnchorMiddle, AnchorMiddleCentered, AnchorTop, AnchorTopBaseline, AnchorTopCentered, AnchorTopCenteredBaseline, WrapByPoints, WrapNone, WrapSquare, WrapThrough, WrapTopBottom
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected | AutoShape(EscherContainerRecord escherRecord, Shape parent)
 | AutoShape(int type)
 | AutoShape(int type, Shape parent)
Method Summary
protected EscherContainerRecord | createSpContainer(int shapeType, boolean isChild)
int | getAdjustmentValue(int idx) Gets adjust value which controls smart resizing of the auto-shape.
java.awt.Shape | getOutline() Return shape outline as a java.awt.Shape object
void | setAdjustmentValue(int idx, int val) Sets adjust value which controls smart resizing of the auto-shape.
protected void | setDefaultTextProperties(TextRun _txtrun) Set default properties for the TextRun.
Methods inherited from class org.apache.poi.hslf.model.TextShape
afterInsert, createTextRun, draw, getEscherTextboxWrapper, getHorizontalAlignment, getMarginBottom, getMarginLeft, getMarginRight, getMarginTop, getPlaceholderAtom, getText, getTextId, getTextRun, getVerticalAlignment, getWordWrap, initTextRun, resizeToFitText, setHorizontalAlignment, setHyperlink, setMarginBottom, setMarginLeft, setMarginRight, setMarginTop, setSheet, setText, setTextId, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoShape

protected AutoShape(EscherContainerRecord escherRecord,
                    Shape parent)

AutoShape

public AutoShape(int type,
                 Shape parent)

AutoShape

public AutoShape(int type)
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(int shapeType,
                                                  boolean isChild)

setDefaultTextProperties

protected void setDefaultTextProperties(TextRun _txtrun)
Description copied from class: TextShape
Set default properties for the TextRun. Depending on the text and shape type the defaults are different: TextBox: align=left, valign=top AutoShape: align=center, valign=middle

Overrides:
setDefaultTextProperties in class TextShape

getAdjustmentValue

public int getAdjustmentValue(int idx)
Gets adjust value which controls smart resizing of the auto-shape.

The adjustment values are given in shape coordinates: the origin is at the top-left, positive-x is to the right, positive-y is down. The region from (0,0) to (S,S) maps to the geometry box of the shape (S=21600 is a constant).

Parameters:
idx - the adjust index in the [0, 9] range
Returns:
the adjustment value

setAdjustmentValue

public void setAdjustmentValue(int idx,
                               int val)
Sets adjust value which controls smart resizing of the auto-shape.

The adjustment values are given in shape coordinates: the origin is at the top-left, positive-x is to the right, positive-y is down. The region from (0,0) to (S,S) maps to the geometry box of the shape (S=21600 is a constant).

Parameters:
idx - the adjust index in the [0, 9] range
val - the adjustment value

getOutline

public java.awt.Shape getOutline()
Description copied from class: Shape
Return shape outline as a java.awt.Shape object

Overrides:
getOutline in class Shape
Returns:
the shape outline
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutoShapes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class AutoShapes

java.lang.Object
    extended by  org.apache.poi.hslf.model.AutoShapes

public final class AutoShapes
extends java.lang.Object

Stores definition of auto-shapes. See the Office Drawing 97-2007 Binary Format Specification for details. TODO: follow the spec and define all the auto-shapes

Author:
Yegor Kozlov

Field Summary
protected static ShapeOutline[] shapes
Constructor Summary
AutoShapes()
Method Summary
static ShapeOutline | getShapeOutline(int type) Return shape outline by shape type
static java.awt.Shape | transform(java.awt.Shape outline, java.awt.geom.Rectangle2D anchor) Auto-shapes are defined in the [0,21600] coordinate system.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

shapes

protected static ShapeOutline[] shapes
Constructor Detail

AutoShapes

public AutoShapes()
Method Detail

getShapeOutline

public static ShapeOutline getShapeOutline(int type)
Return shape outline by shape type

Parameters:
type - shape type see ShapeTypes
Returns:
the shape outline

transform

public static java.awt.Shape transform(java.awt.Shape outline,
                                       java.awt.geom.Rectangle2D anchor)
Auto-shapes are defined in the [0,21600] coordinate system. We need to transform it into normal slide coordinates

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Background

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Background

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.Background

public final class Background
extends Shape

Background shape

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected Background(EscherContainerRecord escherRecord, Shape parent)
Method Summary
protected EscherContainerRecord | createSpContainer(boolean isChild) Creates the lowerlevel escher records for this shape.
void | draw(java.awt.Graphics2D graphics)
Methods inherited from class org.apache.poi.hslf.model.Shape
afterInsert, getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getLogicalAnchor2D, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Background

protected Background(EscherContainerRecord escherRecord,
                     Shape parent)
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(boolean isChild)
Description copied from class: Shape
Creates the lowerlevel escher records for this shape.

Specified by:
createSpContainer in class Shape

draw

public void draw(java.awt.Graphics2D graphics)
Overrides:
draw in class Shape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Comment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Comment

java.lang.Object
    extended by  org.apache.poi.hslf.model.Comment

public final class Comment
extends java.lang.Object

Author:
Nick Burch

Constructor Summary
Comment(Comment2000 comment2000)
Method Summary
java.lang.String | getAuthor() Get the Author of this comment
java.lang.String | getAuthorInitials() Get the Author's Initials of this comment
protected Comment2000 | getComment2000()
java.lang.String | getText() Get the text of this comment
void | setAuthor(java.lang.String author) Set the Author of this comment
void | setAuthorInitials(java.lang.String initials) Set the Author's Initials of this comment
void | setText(java.lang.String text) Set the text of this comment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Comment

public Comment(Comment2000 comment2000)
Method Detail

getComment2000

protected Comment2000 getComment2000()

getAuthor

public java.lang.String getAuthor()
Get the Author of this comment

setAuthor

public void setAuthor(java.lang.String author)
Set the Author of this comment

getAuthorInitials

public java.lang.String getAuthorInitials()
Get the Author's Initials of this comment

setAuthorInitials

public void setAuthorInitials(java.lang.String initials)
Set the Author's Initials of this comment

getText

public java.lang.String getText()
Get the text of this comment

setText

public void setText(java.lang.String text)
Set the text of this comment

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fill

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Fill

java.lang.Object
    extended by  org.apache.poi.hslf.model.Fill

public final class Fill
extends java.lang.Object

Represents functionality provided by the 'Fill Effects' dialog in PowerPoint.

Author:
Yegor Kozlov

Field Summary
static int | FILL_BACKGROUND Use the background fill color/pattern
static int | FILL_PATTERN Fill with a pattern (bitmap)
static int | FILL_PICTURE Center a picture in the shape
static int | FILL_SHADE Shade from start to end points
static int | FILL_SHADE_CENTER Shade from bounding rectangle to end point
static int | FILL_SHADE_SCALE Similar to FILL_SHADE, but the fill angle is additionally scaled by the aspect ratio of the shape.
static int | FILL_SHADE_SHAPE Shade from shape outline to end point
static int | FILL_SHADE_TITLE shade to title
static int | FILL_SOLID Fill with a solid color
static int | FILL_TEXTURE A texture (pattern with its own color map)
protected POILogger | logger
protected Shape | shape The shape this background applies to
Constructor Summary
Fill(Shape shape)
Construct a Fill object for a shape.
Method Summary
protected void | afterInsert(Sheet sh)
java.awt.Color | getBackgroundColor() Background color
protected EscherBSERecord | getEscherBSERecord(int idx)
int | getFillType() Returns fill type.
java.awt.Color | getForegroundColor() Foreground color
PictureData | getPictureData() PictureData object used in a texture, pattern of picture fill.
void | setBackgroundColor(java.awt.Color color) Background color
void | setFillType(int type) Sets fill type.
void | setForegroundColor(java.awt.Color color) Foreground color
void | setPictureData(int idx) Assign picture used to fill the underlying shape.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected POILogger logger

FILL_SOLID

public static final int FILL_SOLID
Fill with a solid color

See Also:
Constant Field Values

FILL_PATTERN

public static final int FILL_PATTERN
Fill with a pattern (bitmap)

See Also:
Constant Field Values

FILL_TEXTURE

public static final int FILL_TEXTURE
A texture (pattern with its own color map)

See Also:
Constant Field Values

FILL_PICTURE

public static final int FILL_PICTURE
Center a picture in the shape

See Also:
Constant Field Values

FILL_SHADE

public static final int FILL_SHADE
Shade from start to end points

See Also:
Constant Field Values

FILL_SHADE_CENTER

public static final int FILL_SHADE_CENTER
Shade from bounding rectangle to end point

See Also:
Constant Field Values

FILL_SHADE_SHAPE

public static final int FILL_SHADE_SHAPE
Shade from shape outline to end point

See Also:
Constant Field Values

FILL_SHADE_SCALE

public static final int FILL_SHADE_SCALE
Similar to FILL_SHADE, but the fill angle is additionally scaled by the aspect ratio of the shape. If shape is square, it is the same as FILL_SHADE

See Also:
Constant Field Values

FILL_SHADE_TITLE

public static final int FILL_SHADE_TITLE
shade to title

See Also:
Constant Field Values

FILL_BACKGROUND

public static final int FILL_BACKGROUND
Use the background fill color/pattern

See Also:
Constant Field Values

shape

protected Shape shape
The shape this background applies to

Constructor Detail

Fill

public Fill(Shape shape)
Construct a Fill object for a shape. Fill information will be read from shape's escher properties.

Parameters:
shape - the shape this background applies to
Method Detail

getFillType

public int getFillType()
Returns fill type. Must be one of the FILL_* constants defined in this class.

Returns:
type of fill

afterInsert

protected void afterInsert(Sheet sh)

getEscherBSERecord

protected EscherBSERecord getEscherBSERecord(int idx)

setFillType

public void setFillType(int type)
Sets fill type. Must be one of the FILL_* constants defined in this class.

Parameters:
type - type of the fill

getForegroundColor

public java.awt.Color getForegroundColor()
Foreground color

setForegroundColor

public void setForegroundColor(java.awt.Color color)
Foreground color

getBackgroundColor

public java.awt.Color getBackgroundColor()
Background color

setBackgroundColor

public void setBackgroundColor(java.awt.Color color)
Background color

getPictureData

public PictureData getPictureData()
PictureData object used in a texture, pattern of picture fill.

setPictureData

public void setPictureData(int idx)
Assign picture used to fill the underlying shape.

Parameters:
idx - 0-based index of the picture added to this ppt by SlideShow.addPicture method.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Freeform

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Freeform

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.TextShape
                extended by  org.apache.poi.hslf.model.AutoShape
                    extended by  org.apache.poi.hslf.model.Freeform

public final class Freeform
extends AutoShape

A "Freeform" shape.

Shapes drawn with the "Freeform" tool have cubic bezier curve segments in the smooth sections and straight-line segments in the straight sections. This object closely corresponds to java.awt.geom.GeneralPath.

Author:
Yegor Kozlov

Field Summary
static byte[] | SEGMENTINFO_CLOSE
static byte[] | SEGMENTINFO_CUBICTO
static byte[] | SEGMENTINFO_CUBICTO2
static byte[] | SEGMENTINFO_END
static byte[] | SEGMENTINFO_ESCAPE
static byte[] | SEGMENTINFO_ESCAPE2
static byte[] | SEGMENTINFO_LINETO
static byte[] | SEGMENTINFO_MOVETO
Fields inherited from class org.apache.poi.hslf.model.TextShape
_frc, _txtbox, _txtrun, AlignCenter, AlignJustify, AlignLeft, AlignRight, AnchorBottom, AnchorBottomBaseline, AnchorBottomCentered, AnchorBottomCenteredBaseline, AnchorMiddle, AnchorMiddleCentered, AnchorTop, AnchorTopBaseline, AnchorTopCentered, AnchorTopCenteredBaseline, WrapByPoints, WrapNone, WrapSquare, WrapThrough, WrapTopBottom
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
 | Freeform() Create a new Freeform.
protected | Freeform(EscherContainerRecord escherRecord, Shape parent) Create a Freeform object and initialize it from the supplied Record container.
 | Freeform(Shape parent) Create a new Freeform.
Method Summary
java.awt.Shape | getOutline() Return shape outline as a java.awt.Shape object
java.awt.geom.GeneralPath | getPath() Gets the freeform path
void | setPath(java.awt.geom.GeneralPath path) Set the shape path
Methods inherited from class org.apache.poi.hslf.model.AutoShape
createSpContainer, getAdjustmentValue, setAdjustmentValue, setDefaultTextProperties
Methods inherited from class org.apache.poi.hslf.model.TextShape
afterInsert, createTextRun, draw, getEscherTextboxWrapper, getHorizontalAlignment, getMarginBottom, getMarginLeft, getMarginRight, getMarginTop, getPlaceholderAtom, getText, getTextId, getTextRun, getVerticalAlignment, getWordWrap, initTextRun, resizeToFitText, setHorizontalAlignment, setHyperlink, setMarginBottom, setMarginLeft, setMarginRight, setMarginTop, setSheet, setText, setTextId, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SEGMENTINFO_MOVETO

public static final byte[] SEGMENTINFO_MOVETO

SEGMENTINFO_LINETO

public static final byte[] SEGMENTINFO_LINETO

SEGMENTINFO_ESCAPE

public static final byte[] SEGMENTINFO_ESCAPE

SEGMENTINFO_ESCAPE2

public static final byte[] SEGMENTINFO_ESCAPE2

SEGMENTINFO_CUBICTO

public static final byte[] SEGMENTINFO_CUBICTO

SEGMENTINFO_CUBICTO2

public static final byte[] SEGMENTINFO_CUBICTO2

SEGMENTINFO_CLOSE

public static final byte[] SEGMENTINFO_CLOSE

SEGMENTINFO_END

public static final byte[] SEGMENTINFO_END
Constructor Detail

Freeform

protected Freeform(EscherContainerRecord escherRecord,
                   Shape parent)
Create a Freeform object and initialize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape

Freeform

public Freeform(Shape parent)
Create a new Freeform. This constructor is used when a new shape is created.

Parameters:
parent - the parent of this Shape. For example, if this text box is a cell in a table then the parent is Table.

Freeform

public Freeform()
Create a new Freeform. This constructor is used when a new shape is created.

Method Detail

setPath

public void setPath(java.awt.geom.GeneralPath path)
Set the shape path

Parameters:
path -

getPath

public java.awt.geom.GeneralPath getPath()
Gets the freeform path

Returns:
the freeform path

getOutline

public java.awt.Shape getOutline()
Description copied from class: Shape
Return shape outline as a java.awt.Shape object

Overrides:
getOutline in class AutoShape
Returns:
the shape outline
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeadersFooters

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class HeadersFooters

java.lang.Object
    extended by  org.apache.poi.hslf.model.HeadersFooters

public final class HeadersFooters
extends java.lang.Object

Header / Footer settings. You can get these on slides, or across all notes

Author:
Yegor Kozlov

Constructor Summary
HeadersFooters(HeadersFootersContainer rec, Sheet sheet, boolean newRecord, boolean isPpt2007)
HeadersFooters(HeadersFootersContainer rec, SlideShow ppt, boolean newRecord, boolean isPpt2007)
Method Summary
int | getDateTimeFormat() An integer that specifies the format ID to be used to style the datetime.
java.lang.String | getDateTimeText() This is the date that the user wants in the footers, instead of today's date.
java.lang.String | getFooterText() Footer's text
java.lang.String | getHeaderText() Headers's text
boolean | isDateTimeVisible() whether the date is displayed in the footer.
boolean | isFooterVisible() whether the footer text is displayed.
boolean | isHeaderVisible() whether the header text is displayed.
boolean | isSlideNumberVisible() whether the slide number is displayed in the footer.
boolean | isUserDateVisible() whether the custom user date is used instead of today's date.
void | setDateTimeFormat(int formatId) An integer that specifies the format ID to be used to style the datetime.
void | setDateTimeText(java.lang.String text) Sets custom user date to be displayed instead of today's date.
void | setDateTimeVisible(boolean flag) whether the date is displayed in the footer.
void | setFootersText(java.lang.String text) Sets footers's text
void | setFooterVisible(boolean flag) whether the footer text is displayed.
void | setHeaderText(java.lang.String text) Sets headers's text
void | setHeaderVisible(boolean flag) whether the header text is displayed.
void | setSlideNumberVisible(boolean flag) whether the slide number is displayed in the footer.
void | setUserDateVisible(boolean flag) whether the date is displayed in the footer.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HeadersFooters

public HeadersFooters(HeadersFootersContainer rec,
                      SlideShow ppt,
                      boolean newRecord,
                      boolean isPpt2007)

HeadersFooters

public HeadersFooters(HeadersFootersContainer rec,
                      Sheet sheet,
                      boolean newRecord,
                      boolean isPpt2007)
Method Detail

getHeaderText

public java.lang.String getHeaderText()
Headers's text

Returns:
Headers's text

setHeaderText

public void setHeaderText(java.lang.String text)
Sets headers's text

Parameters:
text - headers's text

getFooterText

public java.lang.String getFooterText()
Footer's text

Returns:
Footer's text

setFootersText

public void setFootersText(java.lang.String text)
Sets footers's text

Parameters:
text - footers's text

getDateTimeText

public java.lang.String getDateTimeText()
This is the date that the user wants in the footers, instead of today's date.

Returns:
custom user date

setDateTimeText

public void setDateTimeText(java.lang.String text)
Sets custom user date to be displayed instead of today's date.

Parameters:
text - custom user date

isFooterVisible

public boolean isFooterVisible()
whether the footer text is displayed.

setFooterVisible

public void setFooterVisible(boolean flag)
whether the footer text is displayed.

isHeaderVisible

public boolean isHeaderVisible()
whether the header text is displayed.

setHeaderVisible

public void setHeaderVisible(boolean flag)
whether the header text is displayed.

isDateTimeVisible

public boolean isDateTimeVisible()
whether the date is displayed in the footer.

setDateTimeVisible

public void setDateTimeVisible(boolean flag)
whether the date is displayed in the footer.

isUserDateVisible

public boolean isUserDateVisible()
whether the custom user date is used instead of today's date.

setUserDateVisible

public void setUserDateVisible(boolean flag)
whether the date is displayed in the footer.

isSlideNumberVisible

public boolean isSlideNumberVisible()
whether the slide number is displayed in the footer.

setSlideNumberVisible

public void setSlideNumberVisible(boolean flag)
whether the slide number is displayed in the footer.

getDateTimeFormat

public int getDateTimeFormat()
An integer that specifies the format ID to be used to style the datetime.

Returns:
an integer that specifies the format ID to be used to style the datetime.

setDateTimeFormat

public void setDateTimeFormat(int formatId)
An integer that specifies the format ID to be used to style the datetime.

Parameters:
formatId - an integer that specifies the format ID to be used to style the datetime.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Hyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Hyperlink

java.lang.Object
    extended by  org.apache.poi.hslf.model.Hyperlink

public final class Hyperlink
extends java.lang.Object

Represents a hyperlink in a PowerPoint document

Author:
Yegor Kozlov

Field Summary
static byte | LINK_FIRSTSLIDE
static byte | LINK_LASTSLIDE
static byte | LINK_NEXTSLIDE
static byte | LINK_NULL
static byte | LINK_PREVIOUSSLIDE
static byte | LINK_URL
Constructor Summary
Hyperlink()
Method Summary
protected static Hyperlink | find(Shape shape) Find hyperlink assigned to the supplied shape
protected static Hyperlink[] | find(TextRun run) Find hyperlinks in a text run
java.lang.String | getAddress() Gets the hyperlink URL
int | getEndIndex() Gets the ending character position
int | getId()
int | getStartIndex() Gets the beginning character position
java.lang.String | getTitle() Gets the hyperlink user-friendly title (if different from URL)
int | getType() Gets the type of the hyperlink action.
void | setAddress(java.lang.String str)
void | setId(int id)
void | setTitle(java.lang.String str)
void | setType(int val)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LINK_NEXTSLIDE

public static final byte LINK_NEXTSLIDE
See Also:
Constant Field Values

LINK_PREVIOUSSLIDE

public static final byte LINK_PREVIOUSSLIDE
See Also:
Constant Field Values

LINK_FIRSTSLIDE

public static final byte LINK_FIRSTSLIDE
See Also:
Constant Field Values

LINK_LASTSLIDE

public static final byte LINK_LASTSLIDE
See Also:
Constant Field Values

LINK_URL

public static final byte LINK_URL
See Also:
Constant Field Values

LINK_NULL

public static final byte LINK_NULL
See Also:
Constant Field Values
Constructor Detail

Hyperlink

public Hyperlink()
Method Detail

getType

public int getType()
Gets the type of the hyperlink action. Must be a LINK_* constant

Returns:
the hyperlink URL
See Also:
InteractiveInfoAtom

setType

public void setType(int val)

getAddress

public java.lang.String getAddress()
Gets the hyperlink URL

Returns:
the hyperlink URL

setAddress

public void setAddress(java.lang.String str)

getId

public int getId()

setId

public void setId(int id)

getTitle

public java.lang.String getTitle()
Gets the hyperlink user-friendly title (if different from URL)

Returns:
the hyperlink user-friendly title

setTitle

public void setTitle(java.lang.String str)

getStartIndex

public int getStartIndex()
Gets the beginning character position

Returns:
the beginning character position

getEndIndex

public int getEndIndex()
Gets the ending character position

Returns:
the ending character position

find

protected static Hyperlink[] find(TextRun run)
Find hyperlinks in a text run

Parameters:
run - TextRun to lookup hyperlinks in
Returns:
found hyperlinks or null if not found

find

protected static Hyperlink find(Shape shape)
Find hyperlink assigned to the supplied shape

Parameters:
shape - Shape to lookup hyperlink in
Returns:
found hyperlink or null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Line

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Line

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.Line

public final class Line
extends SimpleShape

Represents a line in a PowerPoint drawing

Author:
Yegor Kozlov

Field Summary
static int | LINE_DOUBLE Double lines of equal width
static int | LINE_SIMPLE Single line (of width lineWidth)
static int | LINE_THICKTHIN Double lines, one thick, one thin
static int | LINE_THINTHICK Double lines, reverse order
static int | LINE_TRIPLE Three lines, thin, thick, thin
static int | PEN_DASH dash style
static int | PEN_DASHDOT PS_DASHDOT system dash style
static int | PEN_DASHDOTDOT PS_DASHDOTDOT system dash style
static int | PEN_DASHDOTGEL dash short dash
static int | PEN_DOT PS_DOT system dash style
static int | PEN_DOTGEL square dot style
static int | PEN_LONGDASHDOTDOTGEL long dash short dash short dash
static int | PEN_LONGDASHDOTGEL long dash short dash
static int | PEN_LONGDASHGEL long dash style
static int | PEN_PS_DASH PS_DASH system dash style
static int | PEN_SOLID Solid (continuous) pen
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
 | Line()
protected | Line(EscherContainerRecord escherRecord, Shape parent)
 | Line(Shape parent)
Method Summary
protected EscherContainerRecord | createSpContainer(boolean isChild) Create a new Shape
java.awt.Shape | getOutline() Return shape outline as a java.awt.Shape object
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
draw, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
afterInsert, getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PEN_SOLID

public static final int PEN_SOLID
Solid (continuous) pen

See Also:
Constant Field Values

PEN_PS_DASH

public static final int PEN_PS_DASH
PS_DASH system dash style

See Also:
Constant Field Values

PEN_DOT

public static final int PEN_DOT
PS_DOT system dash style

See Also:
Constant Field Values

PEN_DASHDOT

public static final int PEN_DASHDOT
PS_DASHDOT system dash style

See Also:
Constant Field Values

PEN_DASHDOTDOT

public static final int PEN_DASHDOTDOT
PS_DASHDOTDOT system dash style

See Also:
Constant Field Values

PEN_DOTGEL

public static final int PEN_DOTGEL
square dot style

See Also:
Constant Field Values

PEN_DASH

public static final int PEN_DASH
dash style

See Also:
Constant Field Values

PEN_LONGDASHGEL

public static final int PEN_LONGDASHGEL
long dash style

See Also:
Constant Field Values

PEN_DASHDOTGEL

public static final int PEN_DASHDOTGEL
dash short dash

See Also:
Constant Field Values

PEN_LONGDASHDOTGEL

public static final int PEN_LONGDASHDOTGEL
long dash short dash

See Also:
Constant Field Values

PEN_LONGDASHDOTDOTGEL

public static final int PEN_LONGDASHDOTDOTGEL
long dash short dash short dash

See Also:
Constant Field Values

LINE_SIMPLE

public static final int LINE_SIMPLE
Single line (of width lineWidth)

See Also:
Constant Field Values

LINE_DOUBLE

public static final int LINE_DOUBLE
Double lines of equal width

See Also:
Constant Field Values

LINE_THICKTHIN

public static final int LINE_THICKTHIN
Double lines, one thick, one thin

See Also:
Constant Field Values

LINE_THINTHICK

public static final int LINE_THINTHICK
Double lines, reverse order

See Also:
Constant Field Values

LINE_TRIPLE

public static final int LINE_TRIPLE
Three lines, thin, thick, thin

See Also:
Constant Field Values
Constructor Detail

Line

protected Line(EscherContainerRecord escherRecord,
               Shape parent)

Line

public Line(Shape parent)

Line

public Line()
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(boolean isChild)
Description copied from class: SimpleShape
Create a new Shape

Overrides:
createSpContainer in class SimpleShape
Parameters:
isChild - true if the Line is inside a group, false otherwise
Returns:
the record container which holds this shape

getOutline

public java.awt.Shape getOutline()
Description copied from class: Shape
Return shape outline as a java.awt.Shape object

Overrides:
getOutline in class Shape
Returns:
the shape outline
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MasterSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class MasterSheet

java.lang.Object
    extended by  org.apache.poi.hslf.model.Sheet
        extended by  org.apache.poi.hslf.model.MasterSheet
Direct Known Subclasses:
SlideMaster, TitleMaster
public abstract class MasterSheet
extends Sheet

The superclass of all master sheets - Slide masters, Notes masters, etc. For now it's empty. When we understand more about masters in ppt we will add the common functionality here.

Author:
Yegor Kozlov

Constructor Summary
MasterSheet(SheetContainer container, int sheetNo)
Method Summary
abstract TextProp | getStyleAttribute(int txtype, int level, java.lang.String name, boolean isCharacter) Pickup a style attribute from the master.
static boolean | isPlaceholder(Shape shape) Checks if the shape is a placeholder.
Methods inherited from class org.apache.poi.hslf.model.Sheet
_getSheetNumber, _getSheetRefId, addShape, allocateShapeId, draw, findTextRuns, findTextRuns, getBackground, getColorScheme, getMasterSheet, getPlaceholder, getPlaceholderByTextType, getPPDrawing, getProgrammableTag, getShapes, getSheetContainer, getSlideShow, getTextRuns, onAddTextShape, onCreate, removeShape, setSlideShow
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MasterSheet

public MasterSheet(SheetContainer container,
                   int sheetNo)
Method Detail

getStyleAttribute

public abstract TextProp getStyleAttribute(int txtype,
                                           int level,
                                           java.lang.String name,
                                           boolean isCharacter)
Pickup a style attribute from the master. This is the "workhorse" which returns the default style attrubutes.

isPlaceholder

public static boolean isPlaceholder(Shape shape)
Checks if the shape is a placeholder. (placeholders aren't normal shapes, they are visible only in the Edit Master mode)

Returns:
true if the shape is a placeholder
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MovieShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class MovieShape

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.Picture
                extended by  org.apache.poi.hslf.model.MovieShape

public final class MovieShape
extends Picture

Represents a movie in a PowerPoint document.

Author:
Yegor Kozlov

Field Summary
static int | DEFAULT_MOVIE_THUMBNAIL
static int | MOVIE_AVI
static int | MOVIE_MPEG
Fields inherited from class org.apache.poi.hslf.model.Picture
DIB, EMF, JPEG, PICT, PNG, WMF
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected | MovieShape(EscherContainerRecord escherRecord, Shape parent) Create a Picture object
 | MovieShape(int movieIdx, int pictureIdx) Create a new Picture
 | MovieShape(int movieIdx, int idx, Shape parent) Create a new Picture
Method Summary
protected EscherContainerRecord | createSpContainer(int idx, boolean isChild) Create a new Placeholder and initialize internal structures
java.lang.String | getPath()
boolean | isAutoPlay()
void | setAutoPlay(boolean flag)
void | setMovieIndex(int idx) Assign a movie to this shape
Methods inherited from class org.apache.poi.hslf.model.Picture
afterInsert, draw, getEscherBSERecord, getPictureData, getPictureIndex, getPictureName, setDefaultSize, setPictureName
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_MOVIE_THUMBNAIL

public static final int DEFAULT_MOVIE_THUMBNAIL
See Also:
Constant Field Values

MOVIE_MPEG

public static final int MOVIE_MPEG
See Also:
Constant Field Values

MOVIE_AVI

public static final int MOVIE_AVI
See Also:
Constant Field Values
Constructor Detail

MovieShape

public MovieShape(int movieIdx,
                  int pictureIdx)
Create a new Picture

Parameters:
pictureIdx - the index of the picture

MovieShape

public MovieShape(int movieIdx,
                  int idx,
                  Shape parent)
Create a new Picture

Parameters:
idx - the index of the picture
parent - the parent shape

MovieShape

protected MovieShape(EscherContainerRecord escherRecord,
                     Shape parent)
Create a Picture object

Parameters:
escherRecord - the EscherSpContainer record which holds information about this picture in the Slide
parent - the parent shape of this picture
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(int idx,
                                                  boolean isChild)
Create a new Placeholder and initialize internal structures

Overrides:
createSpContainer in class Picture
Parameters:
idx - the index of the picture which referes to EscherBSE container.
Returns:
the created EscherContainerRecord which holds shape data

setMovieIndex

public void setMovieIndex(int idx)
Assign a movie to this shape

Parameters:
idx - the index of the movie
See Also:
SlideShow.addMovie(String, int)

setAutoPlay

public void setAutoPlay(boolean flag)

isAutoPlay

public boolean isAutoPlay()

getPath

public java.lang.String getPath()
Returns:
UNC or local path to a video file
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Notes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Notes

java.lang.Object
    extended by  org.apache.poi.hslf.model.Sheet
        extended by  org.apache.poi.hslf.model.Notes

public final class Notes
extends Sheet

This class represents a slide's notes in a PowerPoint Document. It allows access to the text within, and the layout. For now, it only does the text side of things though

Author:
Nick Burch

Constructor Summary
Notes(Notes notes)
Constructs a Notes Sheet from the given Notes record.
Method Summary
MasterSheet | getMasterSheet() Return null - Notes Masters are not yet supported
TextRun[] | getTextRuns() Returns an array of all the TextRuns found
Methods inherited from class org.apache.poi.hslf.model.Sheet
_getSheetNumber, _getSheetRefId, addShape, allocateShapeId, draw, findTextRuns, findTextRuns, getBackground, getColorScheme, getPlaceholder, getPlaceholderByTextType, getPPDrawing, getProgrammableTag, getShapes, getSheetContainer, getSlideShow, onAddTextShape, onCreate, removeShape, setSlideShow
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Notes

public Notes(Notes notes)
Constructs a Notes Sheet from the given Notes record. Initialises TextRuns, to provide easier access to the text

Parameters:
notes - the Notes record to read from
Method Detail

getTextRuns

public TextRun[] getTextRuns()
Returns an array of all the TextRuns found

Specified by:
getTextRuns in class Sheet

getMasterSheet

public MasterSheet getMasterSheet()
Return null - Notes Masters are not yet supported

Specified by:
getMasterSheet in class Sheet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OLEShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class OLEShape

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.Picture
                extended by  org.apache.poi.hslf.model.OLEShape

public final class OLEShape
extends Picture

A shape representing embedded OLE obejct.

Author:
Yegor Kozlov

Field Summary
protected  ExEmbed _exEmbed
Fields inherited from class org.apache.poi.hslf.model.Picture
DIB, EMF, JPEG, PICT, PNG, WMF
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected | OLEShape(EscherContainerRecord escherRecord, Shape parent) Create a OLEShape object
 | OLEShape(int idx) Create a new OLEShape
 | OLEShape(int idx, Shape parent) Create a new OLEShape
Method Summary
ExEmbed | getExEmbed() Return the record container for this embedded object.
java.lang.String | getFullName() Returns the full name of the embedded object, e.g.
java.lang.String | getInstanceName() Returns the instance name of the embedded object, e.g.
ObjectData | getObjectData() Returns unique identifier for the OLE object.
int | getObjectID() Returns unique identifier for the OLE object.
java.lang.String | getProgID() Returns the ProgID that stores the OLE Programmatic Identifier.
Methods inherited from class org.apache.poi.hslf.model.Picture
afterInsert, createSpContainer, draw, getEscherBSERecord, getPictureData, getPictureIndex, getPictureName, setDefaultSize, setPictureName
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_exEmbed

protected ExEmbed _exEmbed
Constructor Detail

OLEShape

public OLEShape(int idx)
Create a new OLEShape

Parameters:
idx - the index of the picture

OLEShape

public OLEShape(int idx,
                Shape parent)
Create a new OLEShape

Parameters:
idx - the index of the picture
parent - the parent shape

OLEShape

protected OLEShape(EscherContainerRecord escherRecord,
                   Shape parent)
Create a OLEShape object

Parameters:
escherRecord - the EscherSpContainer record which holds information about this picture in the Slide
parent - the parent shape of this picture
Method Detail

getObjectID

public int getObjectID()
Returns unique identifier for the OLE object.

Returns:
the unique identifier for the OLE object

getObjectData

public ObjectData getObjectData()
Returns unique identifier for the OLE object.

Returns:
the unique identifier for the OLE object

getExEmbed

public ExEmbed getExEmbed()
Return the record container for this embedded object.

It contains: 1. ExEmbedAtom.(4045) 2. ExOleObjAtom (4035) 3. CString (4026), Instance MenuName (1) used for menus and the Links dialog box. 4. CString (4026), Instance ProgID (2) that stores the OLE Programmatic Identifier. A ProgID is a string that uniquely identifies a given object. 5. CString (4026), Instance ClipboardName (3) that appears in the paste special dialog. 6. MetaFile( 4033), optional

getInstanceName

public java.lang.String getInstanceName()
Returns the instance name of the embedded object, e.g. "Document" or "Workbook".

Returns:
the instance name of the embedded object

getFullName

public java.lang.String getFullName()
Returns the full name of the embedded object, e.g. "Microsoft Word Document" or "Microsoft Office Excel Worksheet".

Returns:
the full name of the embedded object

getProgID

public java.lang.String getProgID()
Returns the ProgID that stores the OLE Programmatic Identifier. A ProgID is a string that uniquely identifies a given object, for example, "Word.Document.8" or "Excel.Sheet.8".

Returns:
the ProgID
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.model
Interfaces
ShapeOutline
Classes
ActiveXShape
AutoShape
AutoShapes
Background
Comment
Fill
Freeform
HeadersFooters
Hyperlink
Line
MasterSheet
MovieShape
Notes
OLEShape
Picture
Placeholder
Polygon
PPFont
PPGraphics2D
Shape
ShapeFactory
ShapeGroup
ShapePainter
ShapeTypes
Sheet
SimpleShape
Slide
SlideMaster
Table
TableCell
TextBox
TextPainter
TextPainter.TextElement
TextRun
TextShape
TitleMaster


org.apache.poi.hslf.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.model

Interface Summary
ShapeOutline Date: Apr 17, 2008

Class Summary
ActiveXShape | Represents an ActiveX control in a PowerPoint document.
AutoShape | Represents an AutoShape.
AutoShapes | Stores definition of auto-shapes.
Background | Background shape
Comment |
Fill | Represents functionality provided by the 'Fill Effects' dialog in PowerPoint.
Freeform | A "Freeform" shape.
HeadersFooters | Header / Footer settings.
Hyperlink | Represents a hyperlink in a PowerPoint document
Line | Represents a line in a PowerPoint drawing
MasterSheet | The superclass of all master sheets - Slide masters, Notes masters, etc.
MovieShape | Represents a movie in a PowerPoint document.
Notes | This class represents a slide's notes in a PowerPoint Document.
OLEShape | A shape representing embedded OLE obejct.
Picture | Represents a picture in a PowerPoint document.
Placeholder | Represents a Placeholder in PowerPoint.
Polygon | A simple closed polygon shape
PPFont | Represents a Font used in a presenation.
PPGraphics2D | Translates Graphics2D calls into PowerPoint.
Shape | Represents a Shape which is the elemental object that composes a drawing.
ShapeFactory | Create a Shape object depending on its type
ShapeGroup | Represents a group of shapes.
ShapePainter | Paint a shape into java.awt.Graphics2D
ShapeTypes | Contains all known shape types in PowerPoint
Sheet | This class defines the common format of "Sheets" in a powerpoint document.
SimpleShape | An abstract simple (non-group) shape.
Slide | This class represents a slide in a PowerPoint Document.
SlideMaster | SlideMaster determines the graphics, layout, and formatting for all the slides in a given presentation.
Table | Represents a table in a PowerPoint presentation
TableCell | Represents a cell in a ppt table
TextBox | Represents a TextFrame shape in PowerPoint.
TextPainter | Paint text into java.awt.Graphics2D
TextPainter.TextElement |
TextRun | This class represents a run of text in a powerpoint document.
TextShape | A common superclass of all shapes that can hold text.
TitleMaster | Title masters define the design template for slides with a Title Slide layout.


org.apache.poi.hslf.model Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.model.AutoShapes
    • org.apache.poi.hslf.model.Comment
    • org.apache.poi.hslf.model.Fill
    • java.awt.Graphics
      • java.awt.Graphics2D
        • org.apache.poi.hslf.model.PPGraphics2D (implements java.lang.Cloneable)
    • org.apache.poi.hslf.model.HeadersFooters
    • org.apache.poi.hslf.model.Hyperlink
    • org.apache.poi.hslf.model.PPFont
    • org.apache.poi.hslf.model.Shape
      • org.apache.poi.hslf.model.Background
      • org.apache.poi.hslf.model.ShapeGroup
        • org.apache.poi.hslf.model.Table
      • org.apache.poi.hslf.model.SimpleShape
        • org.apache.poi.hslf.model.Line
        • org.apache.poi.hslf.model.Picture
          • org.apache.poi.hslf.model.ActiveXShape
          • org.apache.poi.hslf.model.MovieShape
          • org.apache.poi.hslf.model.OLEShape
        • org.apache.poi.hslf.model.TextShape
          • org.apache.poi.hslf.model.AutoShape
            • org.apache.poi.hslf.model.Freeform
            • org.apache.poi.hslf.model.Polygon
          • org.apache.poi.hslf.model.TextBox
            • org.apache.poi.hslf.model.Placeholder
            • org.apache.poi.hslf.model.TableCell
    • org.apache.poi.hslf.model.ShapeFactory
    • org.apache.poi.hslf.model.ShapePainter
    • org.apache.poi.hslf.model.ShapeTypes (implements org.apache.poi.sl.usermodel.ShapeTypes)
    • org.apache.poi.hslf.model.Sheet
      • org.apache.poi.hslf.model.MasterSheet
        • org.apache.poi.hslf.model.SlideMaster
        • org.apache.poi.hslf.model.TitleMaster
      • org.apache.poi.hslf.model.Notes
      • org.apache.poi.hslf.model.Slide
    • org.apache.poi.hslf.model.TextPainter
    • org.apache.poi.hslf.model.TextPainter.TextElement
    • org.apache.poi.hslf.model.TextRun

Interface Hierarchy

  • org.apache.poi.hslf.model.ShapeOutline


Uses of Package org.apache.poi.hslf.model

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.model

Packages that use org.apache.poi.hslf.model
org.apache.poi.hslf.blip
org.apache.poi.hslf.extractor
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Classes in org.apache.poi.hslf.model used by org.apache.poi.hslf.blip
Picture
Represents a picture in a PowerPoint document.

Classes in org.apache.poi.hslf.model used by org.apache.poi.hslf.extractor
OLEShape
A shape representing embedded OLE obejct.

Classes in org.apache.poi.hslf.model used by org.apache.poi.hslf.model
AutoShape
Represents an AutoShape.
Background
Background shape
Comment
Fill
Represents functionality provided by the 'Fill Effects' dialog in PowerPoint.
HeadersFooters
Header / Footer settings.
Hyperlink
Represents a hyperlink in a PowerPoint document
Line
Represents a line in a PowerPoint drawing
MasterSheet
The superclass of all master sheets - Slide masters, Notes masters, etc.
Notes
This class represents a slide's notes in a PowerPoint Document.
Picture
Represents a picture in a PowerPoint document.
PPFont
Represents a Font used in a presenation.
Shape
Represents a Shape which is the elemental object that composes a drawing.
ShapeGroup
Represents a group of shapes.
ShapeOutline
Date: Apr 17, 2008
Sheet
This class defines the common format of "Sheets" in a powerpoint document.
SimpleShape
An abstract simple (non-group) shape.
TableCell
Represents a cell in a ppt table
TextBox
Represents a TextFrame shape in PowerPoint.
TextPainter.TextElement
TextRun
This class represents a run of text in a powerpoint document.
TextShape
A common superclass of all shapes that can hold text.

Classes in org.apache.poi.hslf.model used by org.apache.poi.hslf.usermodel
HeadersFooters
Header / Footer settings.
Hyperlink
Represents a hyperlink in a PowerPoint document
Notes
This class represents a slide's notes in a PowerPoint Document.
Picture
Represents a picture in a PowerPoint document.
PPFont
Represents a Font used in a presenation.
Slide
This class represents a slide in a PowerPoint Document.
SlideMaster
SlideMaster determines the graphics, layout, and formatting for all the slides in a given presentation.
TextRun
This class represents a run of text in a powerpoint document.
TitleMaster
Title masters define the design template for slides with a Title Slide layout.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Picture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Picture

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.Picture
Direct Known Subclasses:
ActiveXShape, MovieShape, OLEShape
public class Picture
extends SimpleShape

Represents a picture in a PowerPoint document.

Author:
Yegor Kozlov

Field Summary
static byte | DIB Windows DIB (BMP)
static int | EMF Windows Enhanced Metafile (EMF)
static int | JPEG JPEG
static int | PICT Macintosh PICT
static int | PNG PNG
static int | WMF Windows Metafile (WMF)
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected | Picture(EscherContainerRecord escherRecord, Shape parent) Create a Picture object
 | Picture(int idx) Create a new Picture
 | Picture(int idx, Shape parent) Create a new Picture
Method Summary
protected void | afterInsert(Sheet sh) By default set the orininal image size
protected EscherContainerRecord | createSpContainer(int idx, boolean isChild) Create a new Picture and populate the inital structure of the EscherSp record which holds information about this picture.
void | draw(java.awt.Graphics2D graphics)
protected EscherBSERecord | getEscherBSERecord()
PictureData | getPictureData() Returns the picture data for this picture.
int | getPictureIndex() Returns index associated with this picture.
java.lang.String | getPictureName() Name of this picture.
void | setDefaultSize() Resize this picture to the default size.
void | setPictureName(java.lang.String name) Name of this picture.
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EMF

public static final int EMF
Windows Enhanced Metafile (EMF)

See Also:
Constant Field Values

WMF

public static final int WMF
Windows Metafile (WMF)

See Also:
Constant Field Values

PICT

public static final int PICT
Macintosh PICT

See Also:
Constant Field Values

JPEG

public static final int JPEG
JPEG

See Also:
Constant Field Values

PNG

public static final int PNG
PNG

See Also:
Constant Field Values

DIB

public static final byte DIB
Windows DIB (BMP)

See Also:
Constant Field Values
Constructor Detail

Picture

public Picture(int idx)
Create a new Picture

Parameters:
idx - the index of the picture

Picture

public Picture(int idx,
               Shape parent)
Create a new Picture

Parameters:
idx - the index of the picture
parent - the parent shape

Picture

protected Picture(EscherContainerRecord escherRecord,
                  Shape parent)
Create a Picture object

Parameters:
escherRecord - the EscherSpContainer record which holds information about this picture in the Slide
parent - the parent shape of this picture
Method Detail

getPictureIndex

public int getPictureIndex()
Returns index associated with this picture. Index starts with 1 and points to a EscherBSE record which holds information about this picture.

Returns:
the index to this picture (1 based).

createSpContainer

protected EscherContainerRecord createSpContainer(int idx,
                                                  boolean isChild)
Create a new Picture and populate the inital structure of the EscherSp record which holds information about this picture.

Parameters:
idx - the index of the picture which referes to EscherBSE container.
Returns:
the create Picture object

setDefaultSize

public void setDefaultSize()
Resize this picture to the default size. For PNG and JPEG resizes the image to 100%, for other types sets the default size of 200x200 pixels.

getPictureData

public PictureData getPictureData()
Returns the picture data for this picture.

Returns:
the picture data for this picture.

getEscherBSERecord

protected EscherBSERecord getEscherBSERecord()

getPictureName

public java.lang.String getPictureName()
Name of this picture.

Returns:
name of this picture

setPictureName

public void setPictureName(java.lang.String name)
Name of this picture.

Parameters:
name - of this picture

afterInsert

protected void afterInsert(Sheet sh)
By default set the orininal image size

Overrides:
afterInsert in class Shape
Parameters:
sh - - owning shape

draw

public void draw(java.awt.Graphics2D graphics)
Overrides:
draw in class SimpleShape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Placeholder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Placeholder

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.TextShape
                extended by  org.apache.poi.hslf.model.TextBox
                    extended by  org.apache.poi.hslf.model.Placeholder

public final class Placeholder
extends TextBox

Represents a Placeholder in PowerPoint.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.model.TextShape
_frc, _txtbox, _txtrun, AlignCenter, AlignJustify, AlignLeft, AlignRight, AnchorBottom, AnchorBottomBaseline, AnchorBottomCentered, AnchorBottomCenteredBaseline, AnchorMiddle, AnchorMiddleCentered, AnchorTop, AnchorTopBaseline, AnchorTopCentered, AnchorTopCenteredBaseline, WrapByPoints, WrapNone, WrapSquare, WrapThrough, WrapTopBottom
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
 | Placeholder()
protected | Placeholder(EscherContainerRecord escherRecord, Shape parent)
 | Placeholder(Shape parent)
Method Summary
protected  EscherContainerRecord createSpContainer(boolean isChild)
Create a new Placeholder and initialize internal structures
Methods inherited from class org.apache.poi.hslf.model.TextBox
setDefaultTextProperties
Methods inherited from class org.apache.poi.hslf.model.TextShape
afterInsert, createTextRun, draw, getEscherTextboxWrapper, getHorizontalAlignment, getMarginBottom, getMarginLeft, getMarginRight, getMarginTop, getPlaceholderAtom, getText, getTextId, getTextRun, getVerticalAlignment, getWordWrap, initTextRun, resizeToFitText, setHorizontalAlignment, setHyperlink, setMarginBottom, setMarginLeft, setMarginRight, setMarginTop, setSheet, setText, setTextId, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Placeholder

protected Placeholder(EscherContainerRecord escherRecord,
                      Shape parent)

Placeholder

public Placeholder(Shape parent)

Placeholder

public Placeholder()
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(boolean isChild)
Create a new Placeholder and initialize internal structures

Overrides:
createSpContainer in class TextBox
Parameters:
isChild - true if the Line is inside a group, false otherwise
Returns:
the created EscherContainerRecord which holds shape data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Polygon

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Polygon

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.TextShape
                extended by  org.apache.poi.hslf.model.AutoShape
                    extended by  org.apache.poi.hslf.model.Polygon

public final class Polygon
extends AutoShape

A simple closed polygon shape

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.model.TextShape
_frc, _txtbox, _txtrun, AlignCenter, AlignJustify, AlignLeft, AlignRight, AnchorBottom, AnchorBottomBaseline, AnchorBottomCentered, AnchorBottomCenteredBaseline, AnchorMiddle, AnchorMiddleCentered, AnchorTop, AnchorTopBaseline, AnchorTopCentered, AnchorTopCenteredBaseline, WrapByPoints, WrapNone, WrapSquare, WrapThrough, WrapTopBottom
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
 | Polygon() Create a new Polygon.
protected | Polygon(EscherContainerRecord escherRecord, Shape parent) Create a Polygon object and initialize it from the supplied Record container.
 | Polygon(Shape parent) Create a new Polygon.
Method Summary
void | setPoints(float[] xPoints, float[] yPoints) Set the polygon vertices
void | setPoints(java.awt.geom.Point2D[] points) Set the polygon vertices
Methods inherited from class org.apache.poi.hslf.model.AutoShape
createSpContainer, getAdjustmentValue, getOutline, setAdjustmentValue, setDefaultTextProperties
Methods inherited from class org.apache.poi.hslf.model.TextShape
afterInsert, createTextRun, draw, getEscherTextboxWrapper, getHorizontalAlignment, getMarginBottom, getMarginLeft, getMarginRight, getMarginTop, getPlaceholderAtom, getText, getTextId, getTextRun, getVerticalAlignment, getWordWrap, initTextRun, resizeToFitText, setHorizontalAlignment, setHyperlink, setMarginBottom, setMarginLeft, setMarginRight, setMarginTop, setSheet, setText, setTextId, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Polygon

protected Polygon(EscherContainerRecord escherRecord,
                  Shape parent)
Create a Polygon object and initialize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape

Polygon

public Polygon(Shape parent)
Create a new Polygon. This constructor is used when a new shape is created.

Parameters:
parent - the parent of this Shape. For example, if this text box is a cell in a table then the parent is Table.

Polygon

public Polygon()
Create a new Polygon. This constructor is used when a new shape is created.

Method Detail

setPoints

public void setPoints(float[] xPoints,
                      float[] yPoints)
Set the polygon vertices

Parameters:
xPoints -
yPoints -

setPoints

public void setPoints(java.awt.geom.Point2D[] points)
Set the polygon vertices

Parameters:
points - the polygon vertices
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PPFont

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class PPFont

java.lang.Object
    extended by  org.apache.poi.hslf.model.PPFont

public final class PPFont
extends java.lang.Object

Represents a Font used in a presenation.

In PowerPoint Font is a shared resource and can be shared among text object in the presentation.

Some commonly used fonts are predefined in static constants.

Author:
Yegor Kozlov

Field Summary
static byte | ANSI_CHARSET ANSI character set
static PPFont | ARIAL
protected int | charset
static PPFont | COURIER_NEW
static byte | DEFAULT_CHARSET Default character set.
static byte | DEFAULT_PITCH Constants for the pitch and family of the font.
static byte | FF_DECORATIVE Novelty fonts.
static byte | FF_DONTCARE Don't care or don't know.
static byte | FF_MODERN Fonts with constant stroke width (monospace), with or without serifs.
static byte | FF_ROMAN Fonts with variable stroke width (proportional) and with serifs.
static byte | FF_SCRIPT Fonts designed to look like handwriting.
static byte | FF_SWISS Fonts with variable stroke width (proportional) and without serifs.
static byte | FIXED_PITCH
protected int | flags
protected java.lang.String | name
protected int | pitch
static byte | SYMBOL_CHARSET Symbol character set
static PPFont | TIMES_NEW_ROMAN
protected int | type
static byte | VARIABLE_PITCH
static PPFont | WINGDINGS
Constructor Summary
PPFont()
Creates a new instance of PPFont
PPFont(FontEntityAtom fontAtom)
Creates a new instance of PPFont and initialize it from the supplied font atom
Method Summary
int | getCharSet() get the character set
int | getFontFlags() get the character set Bit 1: If set, font is subsetted
java.lang.String | getFontName() get the name for the font (i.e.
int | getFontType() get the font type
int | getPitchAndFamily() get lfPitchAndFamily
void | setCharSet(int val) set the character set
void | setFontFlags(int val) set the font flags Bit 1: If set, font is subsetted
void | setFontName(java.lang.String val) set the name for the font (i.e.
void | setFontType(int val) set the font type
void | setPitchAndFamily(int val) set lfPitchAndFamily
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ANSI_CHARSET

public static final byte ANSI_CHARSET
ANSI character set

See Also:
Constant Field Values

DEFAULT_CHARSET

public static final byte DEFAULT_CHARSET
Default character set.

See Also:
Constant Field Values

SYMBOL_CHARSET

public static final byte SYMBOL_CHARSET
Symbol character set

See Also:
Constant Field Values

DEFAULT_PITCH

public static final byte DEFAULT_PITCH
Constants for the pitch and family of the font. The two low-order bits specify the pitch of the font and can be one of the following values

See Also:
Constant Field Values

FIXED_PITCH

public static final byte FIXED_PITCH
See Also:
Constant Field Values

VARIABLE_PITCH

public static final byte VARIABLE_PITCH
See Also:
Constant Field Values

FF_DONTCARE

public static final byte FF_DONTCARE
Don't care or don't know.

See Also:
Constant Field Values

FF_ROMAN

public static final byte FF_ROMAN
Fonts with variable stroke width (proportional) and with serifs. Times New Roman is an example.

See Also:
Constant Field Values

FF_SWISS

public static final byte FF_SWISS
Fonts with variable stroke width (proportional) and without serifs. Arial is an example.

See Also:
Constant Field Values

FF_SCRIPT

public static final byte FF_SCRIPT
Fonts designed to look like handwriting. Script and Cursive are examples.

See Also:
Constant Field Values

FF_MODERN

public static final byte FF_MODERN
Fonts with constant stroke width (monospace), with or without serifs. Monospace fonts are usually modern. CourierNew is an example

See Also:
Constant Field Values

FF_DECORATIVE

public static final byte FF_DECORATIVE
Novelty fonts. Old English is an example

See Also:
Constant Field Values

charset

protected int charset

type

protected int type

flags

protected int flags

pitch

protected int pitch

name

protected java.lang.String name

ARIAL

public static final PPFont ARIAL

TIMES_NEW_ROMAN

public static final PPFont TIMES_NEW_ROMAN

COURIER_NEW

public static final PPFont COURIER_NEW

WINGDINGS

public static final PPFont WINGDINGS
Constructor Detail

PPFont

public PPFont()
Creates a new instance of PPFont

PPFont

public PPFont(FontEntityAtom fontAtom)
Creates a new instance of PPFont and initialize it from the supplied font atom

Method Detail

setFontName

public void setFontName(java.lang.String val)
set the name for the font (i.e. Arial)

Parameters:
val - String representing the name of the font to use

getFontName

public java.lang.String getFontName()
get the name for the font (i.e. Arial)

Returns:
String representing the name of the font to use

setCharSet

public void setCharSet(int val)
set the character set

Parameters:
val - - characterset

getCharSet

public int getCharSet()
get the character set

Returns:
charset - characterset

setFontFlags

public void setFontFlags(int val)
set the font flags Bit 1: If set, font is subsetted

Parameters:
val - - the font flags

getFontFlags

public int getFontFlags()
get the character set Bit 1: If set, font is subsetted

Returns:
the font flags

setFontType

public void setFontType(int val)
set the font type

Bit 1: Raster Font Bit 2: Device Font Bit 3: TrueType Font

Parameters:
val - - the font type

getFontType

public int getFontType()
get the font type

Bit 1: Raster Font Bit 2: Device Font Bit 3: TrueType Font

Returns:
the font type

setPitchAndFamily

public void setPitchAndFamily(int val)
set lfPitchAndFamily

Parameters:
val - - Corresponds to the lfPitchAndFamily field of the Win32 API LOGFONT structure

getPitchAndFamily

public int getPitchAndFamily()
get lfPitchAndFamily

Returns:
corresponds to the lfPitchAndFamily field of the Win32 API LOGFONT structure
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PPGraphics2D

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class PPGraphics2D

java.lang.Object
    extended by  java.awt.Graphics
        extended by  java.awt.Graphics2D
            extended by  org.apache.poi.hslf.model.PPGraphics2D
All Implemented Interfaces:
java.lang.Cloneable
public final class PPGraphics2D
extends java.awt.Graphics2D
implements java.lang.Cloneable

Translates Graphics2D calls into PowerPoint.

Author:
Yegor Kozlov

Field Summary
protected  POILogger log
Constructor Summary
PPGraphics2D(ShapeGroup group)
Construct Java Graphics object which translates graphic calls in ppt drawing layer.
Method Summary
void | addRenderingHints(java.util.Map hints) Sets the values of an arbitrary number of preferences for the rendering algorithms.
protected void | applyPaint(SimpleShape shape)
protected void | applyStroke(SimpleShape shape)
void | clearRect(int x, int y, int width, int height) Clears the specified rectangle by filling it with the background color of the current drawing surface.
void | clip(java.awt.Shape s) Intersects the current Clip with the interior of the specified Shape and sets the Clip to the resulting intersection.
void | clipRect(int x, int y, int width, int height) Intersects the current clip with the specified rectangle.
void | copyArea(int x, int y, int width, int height, int dx, int dy)
java.awt.Graphics | create() Creates a new Graphics object that is a copy of this Graphics object.
void | dispose() Disposes of this graphics context and releases any system resources that it is using.
void | draw(java.awt.Shape shape) Strokes the outline of a Shape using the settings of the current Graphics2D context.
void | drawArc(int x, int y, int width, int height, int startAngle, int arcAngle) Draws the outline of a circular or elliptical arc covering the specified rectangle.
void | drawGlyphVector(java.awt.font.GlyphVector g, float x, float y) Renders the text of the specified GlyphVector using the Graphics2D context's rendering attributes.
void | drawImage(java.awt.image.BufferedImage img, java.awt.image.BufferedImageOp op, int x, int y) Renders a BufferedImage that is filtered with a BufferedImageOp.
boolean | drawImage(java.awt.Image img, java.awt.geom.AffineTransform xform, java.awt.image.ImageObserver obs) Renders an image, applying a transform from image space into user space before drawing.
boolean | drawImage(java.awt.Image img, int x, int y, java.awt.Color bgcolor, java.awt.image.ImageObserver observer) Draws as much of the specified image as is currently available.
boolean | drawImage(java.awt.Image img, int x, int y, java.awt.image.ImageObserver observer) Draws as much of the specified image as is currently available.
boolean | drawImage(java.awt.Image img, int x, int y, int width, int height, java.awt.Color bgcolor, java.awt.image.ImageObserver observer) Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
boolean | drawImage(java.awt.Image img, int x, int y, int width, int height, java.awt.image.ImageObserver observer) Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
boolean | drawImage(java.awt.Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.Color bgcolor, java.awt.image.ImageObserver observer) Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
boolean | drawImage(java.awt.Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.image.ImageObserver observer) Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
void | drawLine(int x1, int y1, int x2, int y2) Draws a line, using the current color, between the points (x1, y1) and (x2, y2) in this graphics context's coordinate system.
void | drawOval(int x, int y, int width, int height) Draws the outline of an oval.
void | drawPolygon(int[] xPoints, int[] yPoints, int nPoints) Draws a closed polygon defined by arrays of x and y coordinates.
void | drawPolyline(int[] xPoints, int[] yPoints, int nPoints) Draws a sequence of connected lines defined by arrays of x and y coordinates.
void | drawRect(int x, int y, int width, int height) Draws the outline of the specified rectangle.
void | drawRenderableImage(java.awt.image.renderable.RenderableImage img, java.awt.geom.AffineTransform xform) Renders a RenderedImage, applying a transform from image space into user space before drawing.
void | drawRenderedImage(java.awt.image.RenderedImage img, java.awt.geom.AffineTransform xform) Renders a RenderableImage, applying a transform from image space into user space before drawing.
void | drawRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight) Draws an outlined round-cornered rectangle using this graphics context's current color.
void | drawString(java.text.AttributedCharacterIterator iterator, float x, float y) Renders the text of the specified iterator, using the Graphics2D context's current Paint.
void | drawString(java.text.AttributedCharacterIterator iterator, int x, int y) Draws the text given by the specified iterator, using this graphics context's current color.
void | drawString(java.lang.String s, float x, float y) Renders the text specified by the specified String, using the current text attribute state in the Graphics2D context.
void | drawString(java.lang.String str, int x, int y) Draws the text given by the specified string, using this graphics context's current font and color.
void | fill(java.awt.Shape shape) Fills the interior of a Shape using the settings of the Graphics2D context.
void | fillArc(int x, int y, int width, int height, int startAngle, int arcAngle) Fills a circular or elliptical arc covering the specified rectangle.
void | fillOval(int x, int y, int width, int height) Fills an oval bounded by the specified rectangle with the current color.
void | fillPolygon(int[] xPoints, int[] yPoints, int nPoints) Fills a closed polygon defined by arrays of x and y coordinates.
void | fillRect(int x, int y, int width, int height) Fills the specified rectangle.
void | fillRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight) Fills the specified rounded corner rectangle with the current color.
java.awt.Color | getBackground() Returns the background color used for clearing a region.
java.awt.Shape | getClip() Gets the current clipping area.
java.awt.Rectangle | getClipBounds() Returns the bounding rectangle of the current clipping area.
java.awt.Color | getColor() Gets this graphics context's current color.
java.awt.Composite | getComposite() Returns the current Composite in the Graphics2D context.
java.awt.GraphicsConfiguration | getDeviceConfiguration() Returns the device configuration associated with this Graphics2D.
java.awt.Font | getFont() Gets the current font.
java.awt.FontMetrics | getFontMetrics(java.awt.Font f) Gets the font metrics for the specified font.
java.awt.font.FontRenderContext | getFontRenderContext() Get the rendering context of the Font within this Graphics2D context.
java.awt.Paint | getPaint() Returns the current Paint of the Graphics2D context.
java.lang.Object | getRenderingHint(java.awt.RenderingHints.Key hintKey) Returns the value of a single preference for the rendering algorithms.
java.awt.RenderingHints | getRenderingHints() Gets the preferences for the rendering algorithms.
ShapeGroup | getShapeGroup()
java.awt.Stroke | getStroke() Returns the current Stroke in the Graphics2D context.
java.awt.geom.AffineTransform | getTransform() Returns a copy of the current Transform in the Graphics2D context.
boolean | hit(java.awt.Rectangle rect, java.awt.Shape s, boolean onStroke) Checks whether or not the specified Shape intersects the specified Rectangle, which is in device space.
void | rotate(double theta) Concatenates the current Graphics2D Transform with a rotation transform.
void | rotate(double theta, double x, double y) Concatenates the current Graphics2D Transform with a translated rotation transform.
void | scale(double sx, double sy) Concatenates the current Graphics2D Transform with a scaling transformation Subsequent rendering is resized according to the specified scaling factors relative to the previous scaling.
void | setBackground(java.awt.Color color) Sets the background color for the Graphics2D context.
void | setClip(int x, int y, int width, int height) Sets the current clip to the rectangle specified by the given coordinates.
void | setClip(java.awt.Shape clip) Sets the current clipping area to an arbitrary clip shape.
void | setColor(java.awt.Color c) Sets this graphics context's current color to the specified color.
void | setComposite(java.awt.Composite comp) Sets the Composite for the Graphics2D context.
void | setFont(java.awt.Font font) Sets this graphics context's font to the specified font.
void | setPaint(java.awt.Paint paint) Sets the Paint attribute for the Graphics2D context.
void | setPaintMode() Sets the paint mode of this graphics context to overwrite the destination with this graphics context's current color.
void | setRenderingHint(java.awt.RenderingHints.Key hintKey, java.lang.Object hintValue) Sets the value of a single preference for the rendering algorithms.
void | setRenderingHints(java.util.Map hints) Replaces the values of all preferences for the rendering algorithms with the specified hints.
void | setStroke(java.awt.Stroke s) Sets the Stroke for the Graphics2D context.
void | setTransform(java.awt.geom.AffineTransform Tx) Sets the Transform in the Graphics2D context.
void | setXORMode(java.awt.Color c1) Sets the paint mode of this graphics context to alternate between this graphics context's current color and the new specified color.
void | shear(double shx, double shy) Concatenates the current Graphics2D Transform with a shearing transform.
void | transform(java.awt.geom.AffineTransform Tx) Composes an AffineTransform object with the Transform in this Graphics2D according to the rule last-specified-first-applied.
void | translate(double tx, double ty) Concatenates the current Graphics2D Transform with a translation transform.
void | translate(int x, int y) Translates the origin of the graphics context to the point (x, y) in the current coordinate system.
Methods inherited from class java.awt.Graphics2D
draw3DRect, fill3DRect
Methods inherited from class java.awt.Graphics
create, drawBytes, drawChars, drawPolygon, fillPolygon, finalize, getClipBounds, getClipRect, getFontMetrics, hitClip, toString
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

log

protected POILogger log
Constructor Detail

PPGraphics2D

public PPGraphics2D(ShapeGroup group)
Construct Java Graphics object which translates graphic calls in ppt drawing layer.

Parameters:
group - The shape group to write the graphics calls into.
Method Detail

getShapeGroup

public ShapeGroup getShapeGroup()
Returns:
the shape group being used for drawing

getFont

public java.awt.Font getFont()
Gets the current font.

Specified by:
getFont in class java.awt.Graphics
Returns:
this graphics context's current font.
See Also:
Font, Graphics.setFont(Font)

setFont

public void setFont(java.awt.Font font)
Sets this graphics context's font to the specified font. All subsequent text operations using this graphics context use this font.

Specified by:
setFont in class java.awt.Graphics
Parameters:
font - the font.
See Also:
Graphics.getFont(),
Graphics.drawString(java.lang.String, int, int),
Graphics.drawBytes(byte[], int, int, int, int),
Graphics.drawChars(char[], int, int, int, int)

getColor

public java.awt.Color getColor()
Gets this graphics context's current color.

Specified by:
getColor in class java.awt.Graphics
Returns:
this graphics context's current color.
See Also:
Color, Graphics.setColor(java.awt.Color)

setColor

public void setColor(java.awt.Color c)
Sets this graphics context's current color to the specified color. All subsequent graphics operations using this graphics context use this specified color.

Specified by:
setColor in class java.awt.Graphics
Parameters:
c - the new rendering color.
See Also:
Color, Graphics.getColor()

getStroke

public java.awt.Stroke getStroke()
Returns the current Stroke in the Graphics2D context.

Specified by:
getStroke in class java.awt.Graphics2D
Returns:
the current Graphics2D Stroke, which defines the line style.
See Also:
setStroke(java.awt.Stroke)

setStroke

public void setStroke(java.awt.Stroke s)
Sets the Stroke for the Graphics2D context.

Specified by:
setStroke in class java.awt.Graphics2D
Parameters:
s - the Stroke object to be used to stroke a Shape during the rendering process

getPaint

public java.awt.Paint getPaint()
Returns the current Paint of the Graphics2D context.

Specified by:
getPaint in class java.awt.Graphics2D
Returns:
the current Graphics2D Paint, which defines a color or pattern.
See Also:
setPaint(java.awt.Paint), Graphics.setColor(java.awt.Color)

setPaint

public void setPaint(java.awt.Paint paint)
Sets the Paint attribute for the Graphics2D context. Calling this method with a null Paint object does not have any effect on the current Paint attribute of this Graphics2D.

Specified by:
setPaint in class java.awt.Graphics2D
Parameters:
paint - the Paint object to be used to generate color during the rendering process, or null
See Also:
Graphics.setColor(java.awt.Color)

getTransform

public java.awt.geom.AffineTransform getTransform()
Returns a copy of the current Transform in the Graphics2D context.

Specified by:
getTransform in class java.awt.Graphics2D
Returns:
the current AffineTransform in the Graphics2D context.
See Also:
_transform, setTransform(java.awt.geom.AffineTransform)

setTransform

public void setTransform(java.awt.geom.AffineTransform Tx)
Sets the Transform in the Graphics2D context.

Specified by:
setTransform in class java.awt.Graphics2D
Parameters:
Tx - the AffineTransform object to be used in the rendering process
See Also:
_transform, AffineTransform

draw

public void draw(java.awt.Shape shape)
Strokes the outline of a Shape using the settings of the current Graphics2D context. The rendering attributes applied include the Clip, Transform, Paint, Composite and Stroke attributes.

Specified by:
draw in class java.awt.Graphics2D
Parameters:
shape - the Shape to be rendered
See Also:
setStroke(java.awt.Stroke),
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
_transform,
setTransform(java.awt.geom.AffineTransform),
clip(java.awt.Shape),
setClip(java.awt.Shape),
setComposite(java.awt.Composite)

drawString

public void drawString(java.lang.String s,
                       float x,
                       float y)
Renders the text specified by the specified String, using the current text attribute state in the Graphics2D context. The baseline of the first character is at position (x, y) in the User Space. The rendering attributes applied include the Clip, Transform, Paint, Font and Composite attributes. For characters in script systems such as Hebrew and Arabic, the glyphs can be rendered from right to left, in which case the coordinate supplied is the location of the leftmost character on the baseline.

Specified by:
drawString in class java.awt.Graphics2D
Parameters:
s - the String to be rendered
x - the x coordinate of the location where the String should be rendered
y - the y coordinate of the location where the String should be rendered
Throws:
java.lang.NullPointerException - if str is null
See Also:
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
Graphics.setFont(java.awt.Font),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
setClip(java.awt.Shape)

fill

public void fill(java.awt.Shape shape)
Fills the interior of a Shape using the settings of the Graphics2D context. The rendering attributes applied include the Clip, Transform, Paint, and Composite.

Specified by:
fill in class java.awt.Graphics2D
Parameters:
shape - the Shape to be filled
See Also:
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
_transform,
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
setClip(java.awt.Shape)

translate

public void translate(int x,
                      int y)
Translates the origin of the graphics context to the point (x, y) in the current coordinate system. Modifies this graphics context so that its new origin corresponds to the point (x, y) in this graphics context's original coordinate system. All coordinates used in subsequent rendering operations on this graphics context will be relative to this new origin.

Specified by:
translate in class java.awt.Graphics2D
Parameters:
x - the x coordinate.
y - the y coordinate.

clip

public void clip(java.awt.Shape s)
Intersects the current Clip with the interior of the specified Shape and sets the Clip to the resulting intersection. The specified Shape is transformed with the current Graphics2D Transform before being intersected with the current Clip. This method is used to make the current Clip smaller. To make the Clip larger, use setClip. The user clip modified by this method is independent of the clipping associated with device bounds and visibility. If no clip has previously been set, or if the clip has been cleared using setClip with a null argument, the specified Shape becomes the new user clip.

Specified by:
clip in class java.awt.Graphics2D
Parameters:
s - the Shape to be intersected with the current Clip. If s is null, this method clears the current Clip.

getClip

public java.awt.Shape getClip()
Gets the current clipping area. This method returns the user clip, which is independent of the clipping associated with device bounds and window visibility. If no clip has previously been set, or if the clip has been cleared using setClip(null), this method returns null.

Specified by:
getClip in class java.awt.Graphics
Returns:
a Shape object representing the current clipping area, or null if no clip is set.
Since:
JDK1.1
See Also:
Graphics.getClipBounds(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int),
Graphics.setClip(Shape)

scale

public void scale(double sx,
                  double sy)
Concatenates the current Graphics2D Transform with a scaling transformation Subsequent rendering is resized according to the specified scaling factors relative to the previous scaling. This is equivalent to calling transform(S), where S is an AffineTransform represented by the following matrix:
          [   sx   0    0   ]
          [   0    sy   0   ]
          [   0    0    1   ]

Specified by:
scale in class java.awt.Graphics2D
Parameters:
sx - the amount by which X coordinates in subsequent rendering operations are multiplied relative to previous rendering operations.
sy - the amount by which Y coordinates in subsequent rendering operations are multiplied relative to previous rendering operations.

drawRoundRect

public void drawRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
Draws an outlined round-cornered rectangle using this graphics context's current color. The left and right edges of the rectangle are at x and x + width, respectively. The top and bottom edges of the rectangle are at y and y + height.

Specified by:
drawRoundRect in class java.awt.Graphics
Parameters:
x - the x coordinate of the rectangle to be drawn.
y - the y coordinate of the rectangle to be drawn.
width - the width of the rectangle to be drawn.
height - the height of the rectangle to be drawn.
arcWidth - the horizontal diameter of the arc at the four corners.
arcHeight - the vertical diameter of the arc at the four corners.
See Also:
Graphics.fillRoundRect(int, int, int, int, int, int)

drawString

public void drawString(java.lang.String str,
                       int x,
                       int y)
Draws the text given by the specified string, using this graphics context's current font and color. The baseline of the first character is at position (x, y) in this graphics context's coordinate system.

Specified by:
drawString in class java.awt.Graphics2D
Parameters:
str - the string to be drawn.
x - the x coordinate.
y - the y coordinate.
See Also:
Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawChars(char[], int, int, int, int)

fillOval

public void fillOval(int x,
                     int y,
                     int width,
                     int height)
Fills an oval bounded by the specified rectangle with the current color.

Specified by:
fillOval in class java.awt.Graphics
Parameters:
x - the x coordinate of the upper left corner of the oval to be filled.
y - the y coordinate of the upper left corner of the oval to be filled.
width - the width of the oval to be filled.
height - the height of the oval to be filled.
See Also:
Graphics.drawOval(int, int, int, int)

fillRoundRect

public void fillRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
Fills the specified rounded corner rectangle with the current color. The left and right edges of the rectangle are at x and x + width - 1, respectively. The top and bottom edges of the rectangle are at y and y + height - 1.

Specified by:
fillRoundRect in class java.awt.Graphics
Parameters:
x - the x coordinate of the rectangle to be filled.
y - the y coordinate of the rectangle to be filled.
width - the width of the rectangle to be filled.
height - the height of the rectangle to be filled.
arcWidth - the horizontal diameter of the arc at the four corners.
arcHeight - the vertical diameter of the arc at the four corners.
See Also:
Graphics.drawRoundRect(int, int, int, int, int, int)

fillArc

public void fillArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
Fills a circular or elliptical arc covering the specified rectangle.

The resulting arc begins at startAngle and extends for arcAngle degrees. Angles are interpreted such that 0 degrees is at the 3 o'clock position. A positive value indicates a counter-clockwise rotation while a negative value indicates a clockwise rotation.

The center of the arc is the center of the rectangle whose origin is (x, y) and whose size is specified by the width and height arguments.

The resulting arc covers an area width + 1 pixels wide by height + 1 pixels tall.

The angles are specified relative to the non-square extents of the bounding rectangle such that 45 degrees always falls on the line from the center of the ellipse to the upper right corner of the bounding rectangle. As a result, if the bounding rectangle is noticeably longer in one axis than the other, the angles to the start and end of the arc segment will be skewed farther along the longer axis of the bounds.

Specified by:
fillArc in class java.awt.Graphics
Parameters:
x - the x coordinate of the upper-left corner of the arc to be filled.
y - the y coordinate of the upper-left corner of the arc to be filled.
width - the width of the arc to be filled.
height - the height of the arc to be filled.
startAngle - the beginning angle.
arcAngle - the angular extent of the arc, relative to the start angle.
See Also:
Graphics.drawArc(int, int, int, int, int, int)

drawArc

public void drawArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
Draws the outline of a circular or elliptical arc covering the specified rectangle.

The resulting arc begins at startAngle and extends for arcAngle degrees, using the current color. Angles are interpreted such that 0 degrees is at the 3 o'clock position. A positive value indicates a counter-clockwise rotation while a negative value indicates a clockwise rotation.

The center of the arc is the center of the rectangle whose origin is (x, y) and whose size is specified by the width and height arguments.

The resulting arc covers an area width + 1 pixels wide by height + 1 pixels tall.

The angles are specified relative to the non-square extents of the bounding rectangle such that 45 degrees always falls on the line from the center of the ellipse to the upper right corner of the bounding rectangle. As a result, if the bounding rectangle is noticeably longer in one axis than the other, the angles to the start and end of the arc segment will be skewed farther along the longer axis of the bounds.

Specified by:
drawArc in class java.awt.Graphics
Parameters:
x - the x coordinate of the upper-left corner of the arc to be drawn.
y - the y coordinate of the upper-left corner of the arc to be drawn.
width - the width of the arc to be drawn.
height - the height of the arc to be drawn.
startAngle - the beginning angle.
arcAngle - the angular extent of the arc, relative to the start angle.
See Also:
Graphics.fillArc(int, int, int, int, int, int)

drawPolyline

public void drawPolyline(int[] xPoints,
                         int[] yPoints,
                         int nPoints)
Draws a sequence of connected lines defined by arrays of x and y coordinates. Each pair of (x, y) coordinates defines a point. The figure is not closed if the first point differs from the last point.

Specified by:
drawPolyline in class java.awt.Graphics
Parameters:
xPoints - an array of x points
yPoints - an array of y points
nPoints - the total number of points
Since:
JDK1.1
See Also:
Graphics.drawPolygon(int[], int[], int)

drawOval

public void drawOval(int x,
                     int y,
                     int width,
                     int height)
Draws the outline of an oval. The result is a circle or ellipse that fits within the rectangle specified by the x, y, width, and height arguments.

The oval covers an area that is width + 1 pixels wide and height + 1 pixels tall.

Specified by:
drawOval in class java.awt.Graphics
Parameters:
x - the x coordinate of the upper left corner of the oval to be drawn.
y - the y coordinate of the upper left corner of the oval to be drawn.
width - the width of the oval to be drawn.
height - the height of the oval to be drawn.
See Also:
Graphics.fillOval(int, int, int, int)

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         java.awt.Color bgcolor,
                         java.awt.image.ImageObserver observer)
Draws as much of the specified image as is currently available. The image is drawn with its top-left corner at (x, y) in this graphics context's coordinate space. Transparent pixels are drawn in the specified background color.

This operation is equivalent to filling a rectangle of the width and height of the specified image with the given color and then drawing the image on top of it, but possibly more efficient.

This method returns immediately in all cases, even if the complete image has not yet been loaded, and it has not been dithered and converted for the current output device.

If the image has not yet been completely loaded, then drawImage returns false. As more of the image becomes available, the process that draws the image notifies the specified image observer.

Specified by:
drawImage in class java.awt.Graphics
Parameters:
img - the specified image to be drawn.
x - the x coordinate.
y - the y coordinate.
bgcolor - the background color to paint under the non-opaque portions of the image.
observer - object to be notified as more of the image is converted.
See Also:
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         int width,
                         int height,
                         java.awt.Color bgcolor,
                         java.awt.image.ImageObserver observer)
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.

The image is drawn inside the specified rectangle of this graphics context's coordinate space, and is scaled if necessary. Transparent pixels are drawn in the specified background color. This operation is equivalent to filling a rectangle of the width and height of the specified image with the given color and then drawing the image on top of it, but possibly more efficient.

This method returns immediately in all cases, even if the entire image has not yet been scaled, dithered, and converted for the current output device. If the current output representation is not yet complete then drawImage returns false. As more of the image becomes available, the process that draws the image notifies the specified image observer.

A scaled version of an image will not necessarily be available immediately just because an unscaled version of the image has been constructed for this output device. Each size of the image may be cached separately and generated from the original data in a separate image production sequence.

Specified by:
drawImage in class java.awt.Graphics
Parameters:
img - the specified image to be drawn.
x - the x coordinate.
y - the y coordinate.
width - the width of the rectangle.
height - the height of the rectangle.
bgcolor - the background color to paint under the non-opaque portions of the image.
observer - object to be notified as more of the image is converted.
See Also:
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(java.awt.Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.image.ImageObserver observer)
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface. Transparent pixels do not affect whatever pixels are already there.

This method returns immediately in all cases, even if the image area to be drawn has not yet been scaled, dithered, and converted for the current output device. If the current output representation is not yet complete then drawImage returns false. As more of the image becomes available, the process that draws the image notifies the specified image observer.

This method always uses the unscaled version of the image to render the scaled rectangle and performs the required scaling on the fly. It does not use a cached, scaled version of the image for this operation. Scaling of the image from source to destination is performed such that the first coordinate of the source rectangle is mapped to the first coordinate of the destination rectangle, and the second source coordinate is mapped to the second destination coordinate. The subimage is scaled and flipped as needed to preserve those mappings.

Specified by:
drawImage in class java.awt.Graphics
Parameters:
img - the specified image to be drawn
dx1 - the x coordinate of the first corner of the destination rectangle.
dy1 - the y coordinate of the first corner of the destination rectangle.
dx2 - the x coordinate of the second corner of the destination rectangle.
dy2 - the y coordinate of the second corner of the destination rectangle.
sx1 - the x coordinate of the first corner of the source rectangle.
sy1 - the y coordinate of the first corner of the source rectangle.
sx2 - the x coordinate of the second corner of the source rectangle.
sy2 - the y coordinate of the second corner of the source rectangle.
observer - object to be notified as more of the image is scaled and converted.
Since:
JDK1.1
See Also:
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(java.awt.Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.Color bgcolor,
                         java.awt.image.ImageObserver observer)
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.

Transparent pixels are drawn in the specified background color. This operation is equivalent to filling a rectangle of the width and height of the specified image with the given color and then drawing the image on top of it, but possibly more efficient.

This method returns immediately in all cases, even if the image area to be drawn has not yet been scaled, dithered, and converted for the current output device. If the current output representation is not yet complete then drawImage returns false. As more of the image becomes available, the process that draws the image notifies the specified image observer.

This method always uses the unscaled version of the image to render the scaled rectangle and performs the required scaling on the fly. It does not use a cached, scaled version of the image for this operation. Scaling of the image from source to destination is performed such that the first coordinate of the source rectangle is mapped to the first coordinate of the destination rectangle, and the second source coordinate is mapped to the second destination coordinate. The subimage is scaled and flipped as needed to preserve those mappings.

Specified by:
drawImage in class java.awt.Graphics
Parameters:
img - the specified image to be drawn
dx1 - the x coordinate of the first corner of the destination rectangle.
dy1 - the y coordinate of the first corner of the destination rectangle.
dx2 - the x coordinate of the second corner of the destination rectangle.
dy2 - the y coordinate of the second corner of the destination rectangle.
sx1 - the x coordinate of the first corner of the source rectangle.
sy1 - the y coordinate of the first corner of the source rectangle.
sx2 - the x coordinate of the second corner of the source rectangle.
sy2 - the y coordinate of the second corner of the source rectangle.
bgcolor - the background color to paint under the non-opaque portions of the image.
observer - object to be notified as more of the image is scaled and converted.
Since:
JDK1.1
See Also:
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         java.awt.image.ImageObserver observer)
Draws as much of the specified image as is currently available. The image is drawn with its top-left corner at (x, y) in this graphics context's coordinate space. Transparent pixels in the image do not affect whatever pixels are already there.

This method returns immediately in all cases, even if the complete image has not yet been loaded, and it has not been dithered and converted for the current output device.

If the image has completely loaded and its pixels are no longer being changed, then drawImage returns true. Otherwise, drawImage returns false and as more of the image becomes available or it is time to draw another frame of animation, the process that loads the image notifies the specified image observer.

Specified by:
drawImage in class java.awt.Graphics
Parameters:
img - the specified image to be drawn. This method does nothing if img is null.
x - the x coordinate.
y - the y coordinate.
observer - object to be notified as more of the image is converted.
Returns:
false if the image pixels are still changing; true otherwise.
See Also:
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

dispose

public void dispose()
Disposes of this graphics context and releases any system resources that it is using. A Graphics object cannot be used after disposehas been called.

When a Java program runs, a large number of Graphics objects can be created within a short time frame. Although the finalization process of the garbage collector also disposes of the same system resources, it is preferable to manually free the associated resources by calling this method rather than to rely on a finalization process which may not run to completion for a long period of time.

Graphics objects which are provided as arguments to the paint and update methods of components are automatically released by the system when those methods return. For efficiency, programmers should call dispose when finished using a Graphics object only if it was created directly from a component or another Graphics object.

Specified by:
dispose in class java.awt.Graphics
See Also:
Graphics.finalize(),
Component.paint(java.awt.Graphics),
Component.update(java.awt.Graphics),
Component.getGraphics(),
Graphics.create()

drawLine

public void drawLine(int x1,
                     int y1,
                     int x2,
                     int y2)
Draws a line, using the current color, between the points (x1, y1) and (x2, y2) in this graphics context's coordinate system.

Specified by:
drawLine in class java.awt.Graphics
Parameters:
x1 - the first point's x coordinate.
y1 - the first point's y coordinate.
x2 - the second point's x coordinate.
y2 - the second point's y coordinate.

fillPolygon

public void fillPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Fills a closed polygon defined by arrays of x and y coordinates.

This method draws the polygon defined by nPoint line segments, where the first nPoint - 1 line segments are line segments from (xPoints[i - 1], yPoints[i - 1]) to (xPoints[i], yPoints[i]), for 1 ≤ i ≤ nPoints. The figure is automatically closed by drawing a line connecting the final point to the first point, if those points are different.

The area inside the polygon is defined using an even-odd fill rule, also known as the alternating rule.

Specified by:
fillPolygon in class java.awt.Graphics
Parameters:
xPoints - a an array of x coordinates.
yPoints - a an array of y coordinates.
nPoints - a the total number of points.
See Also:
Graphics.drawPolygon(int[], int[], int)

fillRect

public void fillRect(int x,
                     int y,
                     int width,
                     int height)
Fills the specified rectangle. The left and right edges of the rectangle are at x and x + width - 1. The top and bottom edges are at y and y + height - 1. The resulting rectangle covers an area width pixels wide by height pixels tall. The rectangle is filled using the graphics context's current color.

Specified by:
fillRect in class java.awt.Graphics
Parameters:
x - the x coordinate of the rectangle to be filled.
y - the y coordinate of the rectangle to be filled.
width - the width of the rectangle to be filled.
height - the height of the rectangle to be filled.
See Also:
Graphics.clearRect(int, int, int, int), Graphics.drawRect(int, int, int, int)

drawRect

public void drawRect(int x,
                     int y,
                     int width,
                     int height)
Draws the outline of the specified rectangle. The left and right edges of the rectangle are at x and x + width. The top and bottom edges are at y and y + height. The rectangle is drawn using the graphics context's current color.

Overrides:
drawRect in class java.awt.Graphics
Parameters:
x - the x coordinate of the rectangle to be drawn.
y - the y coordinate of the rectangle to be drawn.
width - the width of the rectangle to be drawn.
height - the height of the rectangle to be drawn.
See Also:
Graphics.fillRect(int, int, int, int), Graphics.clearRect(int, int, int, int)

drawPolygon

public void drawPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Draws a closed polygon defined by arrays of x and y coordinates. Each pair of (x, y) coordinates defines a point.

This method draws the polygon defined by nPoint line segments, where the first nPoint - 1 line segments are line segments from (xPoints[i - 1], yPoints[i - 1]) to (xPoints[i], yPoints[i]), for 1 ≤ i ≤ nPoints. The figure is automatically closed by drawing a line connecting the final point to the first point, if those points are different.

Specified by:
drawPolygon in class java.awt.Graphics
Parameters:
xPoints - a an array of x coordinates.
yPoints - a an array of y coordinates.
nPoints - a the total number of points.
See Also:
Graphics.fillPolygon(int[],int[],int), Graphics.drawPolyline(int[], int[], int)

clipRect

public void clipRect(int x,
                     int y,
                     int width,
                     int height)
Intersects the current clip with the specified rectangle. The resulting clipping area is the intersection of the current clipping area and the specified rectangle. If there is no current clipping area, either because the clip has never been set, or the clip has been cleared using setClip(null), the specified rectangle becomes the new clip. This method sets the user clip, which is independent of the clipping associated with device bounds and window visibility. This method can only be used to make the current clip smaller. To set the current clip larger, use any of the setClip methods. Rendering operations have no effect outside of the clipping area.

Specified by:
clipRect in class java.awt.Graphics
Parameters:
x - the x coordinate of the rectangle to intersect the clip with
y - the y coordinate of the rectangle to intersect the clip with
width - the width of the rectangle to intersect the clip with
height - the height of the rectangle to intersect the clip with
See Also:
setClip(int, int, int, int), setClip(Shape)

setClip

public void setClip(java.awt.Shape clip)
Sets the current clipping area to an arbitrary clip shape. Not all objects that implement the Shape interface can be used to set the clip. The only Shape objects that are guaranteed to be supported are Shape objects that are obtained via the getClip method and via Rectangle objects. This method sets the user clip, which is independent of the clipping associated with device bounds and window visibility.

Specified by:
setClip in class java.awt.Graphics
Parameters:
clip - the Shape to use to set the clip
Since:
JDK1.1
See Also:
Graphics.getClip(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int)

getClipBounds

public java.awt.Rectangle getClipBounds()
Returns the bounding rectangle of the current clipping area. This method refers to the user clip, which is independent of the clipping associated with device bounds and window visibility. If no clip has previously been set, or if the clip has been cleared using setClip(null), this method returns null. The coordinates in the rectangle are relative to the coordinate system origin of this graphics context.

Specified by:
getClipBounds in class java.awt.Graphics
Returns:
the bounding rectangle of the current clipping area, or null if no clip is set.
Since:
JDK1.1
See Also:
Graphics.getClip(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int),
Graphics.setClip(Shape)

drawString

public void drawString(java.text.AttributedCharacterIterator iterator,
                       int x,
                       int y)
Draws the text given by the specified iterator, using this graphics context's current color. The iterator has to specify a font for each character. The baseline of the first character is at position (x, y) in this graphics context's coordinate system.

Specified by:
drawString in class java.awt.Graphics2D
Parameters:
iterator - the iterator whose text is to be drawn
x - the x coordinate.
y - the y coordinate.
See Also:
Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawChars(char[], int, int, int, int)

clearRect

public void clearRect(int x,
                      int y,
                      int width,
                      int height)
Clears the specified rectangle by filling it with the background color of the current drawing surface. This operation does not use the current paint mode.

Beginning with Java 1.1, the background color of offscreen images may be system dependent. Applications should use setColor followed by fillRect to ensure that an offscreen image is cleared to a specific color.

Specified by:
clearRect in class java.awt.Graphics
Parameters:
x - the x coordinate of the rectangle to clear.
y - the y coordinate of the rectangle to clear.
width - the width of the rectangle to clear.
height - the height of the rectangle to clear.
See Also:
Graphics.fillRect(int, int, int, int),
Graphics.drawRect(int, int, int, int),
Graphics.setColor(java.awt.Color),
Graphics.setPaintMode(),
Graphics.setXORMode(java.awt.Color)

copyArea

public void copyArea(int x,
                     int y,
                     int width,
                     int height,
                     int dx,
                     int dy)
Specified by:
copyArea in class java.awt.Graphics

setClip

public void setClip(int x,
                    int y,
                    int width,
                    int height)
Sets the current clip to the rectangle specified by the given coordinates. This method sets the user clip, which is independent of the clipping associated with device bounds and window visibility. Rendering operations have no effect outside of the clipping area.

Specified by:
setClip in class java.awt.Graphics
Parameters:
x - the x coordinate of the new clip rectangle.
y - the y coordinate of the new clip rectangle.
width - the width of the new clip rectangle.
height - the height of the new clip rectangle.
Since:
JDK1.1
See Also:
Graphics.clipRect(int, int, int, int), Graphics.setClip(Shape)

rotate

public void rotate(double theta)
Concatenates the current Graphics2D Transform with a rotation transform. Subsequent rendering is rotated by the specified radians relative to the previous origin. This is equivalent to calling transform(R), where R is an AffineTransform represented by the following matrix:
          [   cos(theta)    -sin(theta)    0   ]
          [   sin(theta)     cos(theta)    0   ]
          [       0              0         1   ]
Rotating with a positive angle theta rotates points on the positive x axis toward the positive y axis.

Specified by:
rotate in class java.awt.Graphics2D
Parameters:
theta - the angle of rotation in radians

rotate

public void rotate(double theta,
                   double x,
                   double y)
Concatenates the current Graphics2D Transform with a translated rotation transform. Subsequent rendering is transformed by a transform which is constructed by translating to the specified location, rotating by the specified radians, and translating back by the same amount as the original translation. This is equivalent to the following sequence of calls:
          translate(x, y);
          rotate(theta);
          translate(-x, -y);
Rotating with a positive angle theta rotates points on the positive x axis toward the positive y axis.

Specified by:
rotate in class java.awt.Graphics2D
Parameters:
theta - the angle of rotation in radians
x - x coordinate of the origin of the rotation
y - y coordinate of the origin of the rotation

shear

public void shear(double shx,
                  double shy)
Concatenates the current Graphics2D Transform with a shearing transform. Subsequent renderings are sheared by the specified multiplier relative to the previous position. This is equivalent to calling transform(SH), where SH is an AffineTransform represented by the following matrix:
          [   1   shx   0   ]
          [  shy   1    0   ]
          [   0    0    1   ]

Specified by:
shear in class java.awt.Graphics2D
Parameters:
shx - the multiplier by which coordinates are shifted in the positive X axis direction as a function of their Y coordinate
shy - the multiplier by which coordinates are shifted in the positive Y axis direction as a function of their X coordinate

getFontRenderContext

public java.awt.font.FontRenderContext getFontRenderContext()
Get the rendering context of the Font within this Graphics2D context. The FontRenderContext encapsulates application hints such as anti-aliasing and fractional metrics, as well as target device specific information such as dots-per-inch. This information should be provided by the application when using objects that perform typographical formatting, such as Font and TextLayout. This information should also be provided by applications that perform their own layout and need accurate measurements of various characteristics of glyphs such as advance and line height when various rendering hints have been applied to the text rendering.

Specified by:
getFontRenderContext in class java.awt.Graphics2D
Returns:
a reference to an instance of FontRenderContext.
Since:
JDK1.2
See Also:
FontRenderContext, Font.createGlyphVector(FontRenderContext,char[]), TextLayout

transform

public void transform(java.awt.geom.AffineTransform Tx)
Composes an AffineTransform object with the Transform in this Graphics2D according to the rule last-specified-first-applied. If the current Transform is Cx, the result of composition with Tx is a new Transform Cx'. Cx' becomes the current Transform for this Graphics2D. Transforming a point p by the updated Transform Cx' is equivalent to first transforming p by Tx and then transforming the result by the original Transform Cx. In other words, Cx'(p) = Cx(Tx(p)). A copy of the Tx is made, if necessary, so further modifications to Tx do not affect rendering.

Specified by:
transform in class java.awt.Graphics2D
Parameters:
Tx - the AffineTransform object to be composed with the current Transform
See Also:
setTransform(java.awt.geom.AffineTransform), AffineTransform

drawImage

public void drawImage(java.awt.image.BufferedImage img,
                      java.awt.image.BufferedImageOp op,
                      int x,
                      int y)
Renders a BufferedImage that is filtered with a BufferedImageOp. The rendering attributes applied include the Clip, Transform and Composite attributes. This is equivalent to:
 img1 = op.filter(img, null);
 drawImage(img1, new AffineTransform(1f,0f,0f,1f,x,y), null);

Specified by:
drawImage in class java.awt.Graphics2D
Parameters:
img - the BufferedImage to be rendered
op - the filter to be applied to the image before rendering
x - the x coordinate in user space where the image is rendered
y - the y coordinate in user space where the image is rendered
See Also:
_transform,
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
setClip(Shape)

setBackground

public void setBackground(java.awt.Color color)
Sets the background color for the Graphics2D context. The background color is used for clearing a region. When a Graphics2D is constructed for a Component, the background color is inherited from the Component. Setting the background color in the Graphics2D context only affects the subsequent clearRect calls and not the background color of the Component. To change the background of the Component, use appropriate methods of the Component.

Specified by:
setBackground in class java.awt.Graphics2D
Parameters:
color - the background color that isused in subsequent calls to clearRect
See Also:
getBackground(), Graphics.clearRect(int, int, int, int)

getBackground

public java.awt.Color getBackground()
Returns the background color used for clearing a region.

Specified by:
getBackground in class java.awt.Graphics2D
Returns:
the current Graphics2D Color, which defines the background color.
See Also:
setBackground(java.awt.Color)

setComposite

public void setComposite(java.awt.Composite comp)
Sets the Composite for the Graphics2D context. The Composite is used in all drawing methods such as drawImage, drawString, draw, and fill. It specifies how new pixels are to be combined with the existing pixels on the graphics device during the rendering process.

If this Graphics2D context is drawing to a Component on the display screen and the Composite is a custom object rather than an instance of the AlphaComposite class, and if there is a security manager, its checkPermission method is called with an AWTPermission("readDisplayPixels") permission.

Specified by:
setComposite in class java.awt.Graphics2D
Parameters:
comp - the Composite object to be used for rendering
Throws:
java.lang.SecurityException - if a custom Composite object is being used to render to the screen and a security manager is set and its checkPermission method does not allow the operation.
See Also:
Graphics.setXORMode(java.awt.Color), Graphics.setPaintMode(), AlphaComposite

getComposite

public java.awt.Composite getComposite()
Returns the current Composite in the Graphics2D context.

Specified by:
getComposite in class java.awt.Graphics2D
Returns:
the current Graphics2D Composite, which defines a compositing style.
See Also:
setComposite(java.awt.Composite)

getRenderingHint

public java.lang.Object getRenderingHint(java.awt.RenderingHints.Key hintKey)
Returns the value of a single preference for the rendering algorithms. Hint categories include controls for rendering quality and overall time/quality trade-off in the rendering process. Refer to the RenderingHints class for definitions of some common keys and values.

Specified by:
getRenderingHint in class java.awt.Graphics2D
Parameters:
hintKey - the key corresponding to the hint to get.
Returns:
an object representing the value for the specified hint key. Some of the keys and their associated values are defined in the RenderingHints class.
See Also:
RenderingHints

setRenderingHint

public void setRenderingHint(java.awt.RenderingHints.Key hintKey,
                             java.lang.Object hintValue)
Sets the value of a single preference for the rendering algorithms. Hint categories include controls for rendering quality and overall time/quality trade-off in the rendering process. Refer to the RenderingHints class for definitions of some common keys and values.

Specified by:
setRenderingHint in class java.awt.Graphics2D
Parameters:
hintKey - the key of the hint to be set.
hintValue - the value indicating preferences for the specified hint category.
See Also:
RenderingHints

drawGlyphVector

public void drawGlyphVector(java.awt.font.GlyphVector g,
                            float x,
                            float y)
Renders the text of the specified GlyphVector using the Graphics2D context's rendering attributes. The rendering attributes applied include the Clip, Transform, Paint, and Composite attributes. The GlyphVector specifies individual glyphs from a Font. The GlyphVector can also contain the glyph positions. This is the fastest way to render a set of characters to the screen.

Specified by:
drawGlyphVector in class java.awt.Graphics2D
Parameters:
g - the GlyphVector to be rendered
x - the x position in user space where the glyphs should be rendered
y - the y position in user space where the glyphs should be rendered
See Also:
Font.createGlyphVector(FontRenderContext, char[]),
GlyphVector,
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
setClip(Shape)

getDeviceConfiguration

public java.awt.GraphicsConfiguration getDeviceConfiguration()
Returns the device configuration associated with this Graphics2D.

Specified by:
getDeviceConfiguration in class java.awt.Graphics2D
Returns:
the device configuration

addRenderingHints

public void addRenderingHints(java.util.Map hints)
Sets the values of an arbitrary number of preferences for the rendering algorithms. Only values for the rendering hints that are present in the specified Map object are modified. All other preferences not present in the specified object are left unmodified. Hint categories include controls for rendering quality and overall time/quality trade-off in the rendering process. Refer to the RenderingHints class for definitions of some common keys and values.

Specified by:
addRenderingHints in class java.awt.Graphics2D
Parameters:
hints - the rendering hints to be set
See Also:
RenderingHints

translate

public void translate(double tx,
                      double ty)
Concatenates the current Graphics2D Transform with a translation transform. Subsequent rendering is translated by the specified distance relative to the previous position. This is equivalent to calling transform(T), where T is an AffineTransform represented by the following matrix:
          [   1    0    tx  ]
          [   0    1    ty  ]
          [   0    0    1   ]

Specified by:
translate in class java.awt.Graphics2D
Parameters:
tx - the distance to translate along the x-axis
ty - the distance to translate along the y-axis

drawString

public void drawString(java.text.AttributedCharacterIterator iterator,
                       float x,
                       float y)
Renders the text of the specified iterator, using the Graphics2D context's current Paint. The iterator must specify a font for each character. The baseline of the first character is at position (x, y) in the User Space. The rendering attributes applied include the Clip, Transform, Paint, and Composite attributes. For characters in script systems such as Hebrew and Arabic, the glyphs can be rendered from right to left, in which case the coordinate supplied is the location of the leftmost character on the baseline.

Specified by:
drawString in class java.awt.Graphics2D
Parameters:
iterator - the iterator whose text is to be rendered
x - the x coordinate where the iterator's text is to be rendered
y - the y coordinate where the iterator's text is to be rendered
See Also:
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
setClip(java.awt.Shape)

hit

public boolean hit(java.awt.Rectangle rect,
                   java.awt.Shape s,
                   boolean onStroke)
Checks whether or not the specified Shape intersects the specified Rectangle, which is in device space. If onStroke is false, this method checks whether or not the interior of the specified Shape intersects the specified Rectangle. If onStroke is true, this method checks whether or not the Stroke of the specified Shape outline intersects the specified Rectangle. The rendering attributes taken into account include the Clip, Transform, and Stroke attributes.

Specified by:
hit in class java.awt.Graphics2D
Parameters:
rect - the area in device space to check for a hit
s - the Shape to check for a hit
onStroke - flag used to choose between testing the stroked or the filled shape. If the flag is true, the Stroke oultine is tested. If the flag is false, the filled Shape is tested.
Returns:
true if there is a hit; false otherwise.
See Also:
setStroke(java.awt.Stroke), fill(Shape), draw(Shape), _transform, setTransform(java.awt.geom.AffineTransform), clip(java.awt.Shape), setClip(Shape)

getRenderingHints

public java.awt.RenderingHints getRenderingHints()
Gets the preferences for the rendering algorithms. Hint categories include controls for rendering quality and overall time/quality trade-off in the rendering process. Returns all of the hint key/value pairs that were ever specified in one operation. Refer to the RenderingHints class for definitions of some common keys and values.

Specified by:
getRenderingHints in class java.awt.Graphics2D
Returns:
a reference to an instance of RenderingHints that contains the current preferences.
See Also:
RenderingHints

setRenderingHints

public void setRenderingHints(java.util.Map hints)
Replaces the values of all preferences for the rendering algorithms with the specified hints. The existing values for all rendering hints are discarded and the new set of known hints and values are initialized from the specified Map object. Hint categories include controls for rendering quality and overall time/quality trade-off in the rendering process. Refer to the RenderingHints class for definitions of some common keys and values.

Specified by:
setRenderingHints in class java.awt.Graphics2D
Parameters:
hints - the rendering hints to be set
See Also:
RenderingHints

drawImage

public boolean drawImage(java.awt.Image img,
                         java.awt.geom.AffineTransform xform,
                         java.awt.image.ImageObserver obs)
Renders an image, applying a transform from image space into user space before drawing. The transformation from user space into device space is done with the current Transform in the Graphics2D. The specified transformation is applied to the image before the transform attribute in the Graphics2D context is applied. The rendering attributes applied include the Clip, Transform, and Composite attributes. Note that no rendering is done if the specified transform is noninvertible.

Specified by:
drawImage in class java.awt.Graphics2D
Parameters:
img - the Image to be rendered
xform - the transformation from image space into user space
obs - the ImageObserver to be notified as more of the Image is converted
Returns:
true if the Image is fully loaded and completely rendered; false if the Image is still being loaded.
See Also:
_transform,
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
setClip(Shape)

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         int width,
                         int height,
                         java.awt.image.ImageObserver observer)
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.

The image is drawn inside the specified rectangle of this graphics context's coordinate space, and is scaled if necessary. Transparent pixels do not affect whatever pixels are already there.

This method returns immediately in all cases, even if the entire image has not yet been scaled, dithered, and converted for the current output device. If the current output representation is not yet complete, then drawImage returns false. As more of the image becomes available, the process that loads the image notifies the image observer by calling its imageUpdate method.

A scaled version of an image will not necessarily be available immediately just because an unscaled version of the image has been constructed for this output device. Each size of the image may be cached separately and generated from the original data in a separate image production sequence.

Specified by:
drawImage in class java.awt.Graphics
Parameters:
img - the specified image to be drawn. This method does nothing if img is null.
x - the x coordinate.
y - the y coordinate.
width - the width of the rectangle.
height - the height of the rectangle.
observer - object to be notified as more of the image is converted.
Returns:
false if the image pixels are still changing; true otherwise.
See Also:
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

create

public java.awt.Graphics create()
Creates a new Graphics object that is a copy of this Graphics object.

Specified by:
create in class java.awt.Graphics
Returns:
a new graphics context that is a copy of this graphics context.

getFontMetrics

public java.awt.FontMetrics getFontMetrics(java.awt.Font f)
Gets the font metrics for the specified font.

Specified by:
getFontMetrics in class java.awt.Graphics
Parameters:
f - the specified font
Returns:
the font metrics for the specified font.
See Also:
Graphics.getFont(), FontMetrics, Graphics.getFontMetrics()

setXORMode

public void setXORMode(java.awt.Color c1)
Sets the paint mode of this graphics context to alternate between this graphics context's current color and the new specified color. This specifies that logical pixel operations are performed in the XOR mode, which alternates pixels between the current color and a specified XOR color.

When drawing operations are performed, pixels which are the current color are changed to the specified color, and vice versa.

Pixels that are of colors other than those two colors are changed in an unpredictable but reversible manner; if the same figure is drawn twice, then all pixels are restored to their original values.

Specified by:
setXORMode in class java.awt.Graphics
Parameters:
c1 - the XOR alternation color

setPaintMode

public void setPaintMode()
Sets the paint mode of this graphics context to overwrite the destination with this graphics context's current color. This sets the logical pixel operation function to the paint or overwrite mode. All subsequent rendering operations will overwrite the destination with the current color.

Specified by:
setPaintMode in class java.awt.Graphics

drawRenderedImage

public void drawRenderedImage(java.awt.image.RenderedImage img,
                              java.awt.geom.AffineTransform xform)
Renders a RenderableImage, applying a transform from image space into user space before drawing. The transformation from user space into device space is done with the current Transform in the Graphics2D. The specified transformation is applied to the image before the transform attribute in the Graphics2D context is applied. The rendering attributes applied include the Clip, Transform, and Composite attributes. Note that no rendering is done if the specified transform is noninvertible.

Rendering hints set on the Graphics2D object might be used in rendering the RenderableImage. If explicit control is required over specific hints recognized by a specific RenderableImage, or if knowledge of which hints are used is required, then a RenderedImage should be obtained directly from the RenderableImage and rendered using drawRenderedImage.

Specified by:
drawRenderedImage in class java.awt.Graphics2D
Parameters:
img - the image to be rendered. This method does nothing if img is null.
xform - the transformation from image space into user space
See Also:
_transform,
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
setClip(java.awt.Shape),
drawRenderedImage(java.awt.image.RenderedImage, java.awt.geom.AffineTransform)

drawRenderableImage

public void drawRenderableImage(java.awt.image.renderable.RenderableImage img,
                                java.awt.geom.AffineTransform xform)
Renders a RenderedImage, applying a transform from image space into user space before drawing. The transformation from user space into device space is done with the current Transform in the Graphics2D. The specified transformation is applied to the image before the transform attribute in the Graphics2D context is applied. The rendering attributes applied include the Clip, Transform, and Composite attributes. Note that no rendering is done if the specified transform is noninvertible.

Specified by:
drawRenderableImage in class java.awt.Graphics2D
Parameters:
img - the image to be rendered. This method does nothing if img is null.
xform - the transformation from image space into user space
See Also:
_transform,
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
setClip(java.awt.Shape)

applyStroke

protected void applyStroke(SimpleShape shape)

applyPaint

protected void applyPaint(SimpleShape shape)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Shape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Shape

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
Direct Known Subclasses:
Background, ShapeGroup, SimpleShape
public abstract class Shape
extends java.lang.Object

Represents a Shape which is the elemental object that composes a drawing. This class is a wrapper around EscherSpContainer which holds all information about a shape in PowerPoint document.

When you add a shape, you usually specify the dimensions of the shape and the position of the upper'left corner of the bounding box for the shape relative to the upper'left corner of the page, worksheet, or slide. Distances in the drawing layer are measured in points (72 points = 1 inch).

Author:
Yegor Kozlov

Field Summary
protected EscherContainerRecord | _escherContainer Either EscherSpContainer or EscheSpgrContainer record which holds information about this shape.
protected Fill | _fill Fill
protected Shape | _parent Parent of this shape.
protected Sheet | _sheet The Sheet this shape belongs to
static int | EMU_PER_CENTIMETER
static int | EMU_PER_INCH In Escher absolute distances are specified in English Metric Units (EMUs), occasionally referred to as A units; there are 360000 EMUs per centimeter, 914400 EMUs per inch, 12700 EMUs per point.
static int | EMU_PER_POINT
protected POILogger | logger
static int | MASTER_DPI Master DPI (576 pixels per inch).
static int | PIXEL_DPI Pixels DPI (96 pixels per inch)
static int | POINT_DPI Points DPI (72 pixels per inch)
Constructor Summary
protected Shape(EscherContainerRecord escherRecord, Shape parent)
Create a Shape object.
Method Summary
protected void | afterInsert(Sheet sh) Event which fires when a shape is inserted in the sheet.
protected abstract EscherContainerRecord | createSpContainer(boolean isChild) Creates the lowerlevel escher records for this shape.
void | draw(java.awt.Graphics2D graphics)
java.awt.Rectangle | getAnchor() Returns the anchor (the bounding box rectangle) of this shape.
java.awt.geom.Rectangle2D | getAnchor2D() Returns the anchor (the bounding box rectangle) of this shape.
static EscherRecord | getEscherChild(EscherContainerRecord owner, int recordId) Helper method to return escher child by record ID
static EscherProperty | getEscherProperty(EscherOptRecord opt, int propId) Returns escher property by id.
int | getEscherProperty(short propId) Get the value of a simple escher property for this shape.
int | getEscherProperty(short propId, int defaultValue) Get the value of a simple escher property for this shape.
Fill | getFill() Fill properties of this shape
Hyperlink | getHyperlink() Returns the hyperlink assigned to this shape
java.awt.geom.Rectangle2D | getLogicalAnchor2D()
java.awt.Shape | getOutline() Return shape outline as a java.awt.Shape object
Shape | getParent()
int | getShapeId()
java.lang.String | getShapeName()
int | getShapeType()
Sheet | getSheet()
EscherContainerRecord | getSpContainer()
void | moveTo(float x, float y) Moves the top left corner of the shape to the specified point.
void | setAnchor(java.awt.geom.Rectangle2D anchor) Sets the anchor (the bounding box rectangle) of this shape.
static void | setEscherProperty(EscherOptRecord opt, short propId, int value) Set an escher property for this shape.
void | setEscherProperty(short propId, int value) Set an simple escher property for this shape.
void | setShapeId(int id) Sets shape ID
void | setShapeType(int type)
void | setSheet(Sheet sheet) Assign the SlideShow this shape belongs to
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected POILogger logger

EMU_PER_INCH

public static final int EMU_PER_INCH
In Escher absolute distances are specified in English Metric Units (EMUs), occasionally referred to as A units; there are 360000 EMUs per centimeter, 914400 EMUs per inch, 12700 EMUs per point.

See Also:
Constant Field Values

EMU_PER_POINT

public static final int EMU_PER_POINT
See Also:
Constant Field Values

EMU_PER_CENTIMETER

public static final int EMU_PER_CENTIMETER
See Also:
Constant Field Values

MASTER_DPI

public static final int MASTER_DPI
Master DPI (576 pixels per inch). Used by the reference coordinate system in PowerPoint.

See Also:
Constant Field Values

PIXEL_DPI

public static final int PIXEL_DPI
Pixels DPI (96 pixels per inch)

See Also:
Constant Field Values

POINT_DPI

public static final int POINT_DPI
Points DPI (72 pixels per inch)

See Also:
Constant Field Values

_escherContainer

protected EscherContainerRecord _escherContainer
Either EscherSpContainer or EscheSpgrContainer record which holds information about this shape.

_parent

protected Shape _parent
Parent of this shape. null for the topmost shapes.

_sheet

protected Sheet _sheet
The Sheet this shape belongs to

_fill

protected Fill _fill
Fill

Constructor Detail

Shape

protected Shape(EscherContainerRecord escherRecord,
                Shape parent)
Create a Shape object. This constructor is used when an existing Shape is read from from a PowerPoint document.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of this Shape
Method Detail

createSpContainer

protected abstract EscherContainerRecord createSpContainer(boolean isChild)
Creates the lowerlevel escher records for this shape.

getParent

public Shape getParent()
Returns:
the parent of this shape

getShapeName

public java.lang.String getShapeName()
Returns:
name of the shape.

getShapeType

public int getShapeType()
Returns:
type of the shape.
See Also:
RecordTypes

setShapeType

public void setShapeType(int type)
Parameters:
type - type of the shape.
See Also:
RecordTypes

getAnchor

public java.awt.Rectangle getAnchor()
Returns the anchor (the bounding box rectangle) of this shape. All coordinates are expressed in points (72 dpi).

Returns:
the anchor of this shape

getAnchor2D

public java.awt.geom.Rectangle2D getAnchor2D()
Returns the anchor (the bounding box rectangle) of this shape. All coordinates are expressed in points (72 dpi).

Returns:
the anchor of this shape

getLogicalAnchor2D

public java.awt.geom.Rectangle2D getLogicalAnchor2D()

setAnchor

public void setAnchor(java.awt.geom.Rectangle2D anchor)
Sets the anchor (the bounding box rectangle) of this shape. All coordinates should be expressed in points (72 dpi).

Parameters:
anchor - new anchor

moveTo

public void moveTo(float x,
                   float y)
Moves the top left corner of the shape to the specified point.

Parameters:
x - the x coordinate of the top left corner of the shape
y - the y coordinate of the top left corner of the shape

getEscherChild

public static EscherRecord getEscherChild(EscherContainerRecord owner,
                                          int recordId)
Helper method to return escher child by record ID

Returns:
escher record or null if not found.

getEscherProperty

public static EscherProperty getEscherProperty(EscherOptRecord opt,
                                               int propId)
Returns escher property by id.

Returns:
escher property or null if not found.

setEscherProperty

public static void setEscherProperty(EscherOptRecord opt,
                                     short propId,
                                     int value)
Set an escher property for this shape.

Parameters:
opt - The opt record to set the properties to.
propId - The id of the property. One of the constants defined in EscherOptRecord.
value - value of the property. If value = -1 then the property is removed.

setEscherProperty

public void setEscherProperty(short propId,
                              int value)
Set an simple escher property for this shape.

Parameters:
propId - The id of the property. One of the constants defined in EscherOptRecord.
value - value of the property. If value = -1 then the property is removed.

getEscherProperty

public int getEscherProperty(short propId)
Get the value of a simple escher property for this shape.

Parameters:
propId - The id of the property. One of the constants defined in EscherOptRecord.

getEscherProperty

public int getEscherProperty(short propId,
                             int defaultValue)
Get the value of a simple escher property for this shape.

Parameters:
propId - The id of the property. One of the constants defined in EscherOptRecord.

getSpContainer

public EscherContainerRecord getSpContainer()
Returns:
The shape container and it's children that can represent this shape.

afterInsert

protected void afterInsert(Sheet sh)
Event which fires when a shape is inserted in the sheet. In some cases we need to propagate changes to upper level containers.
Default implementation does nothing.

Parameters:
sh - - owning shape

getSheet

public Sheet getSheet()
Returns:
the SlideShow this shape belongs to

setSheet

public void setSheet(Sheet sheet)
Assign the SlideShow this shape belongs to

Parameters:
sheet - owner of this shape

getShapeId

public int getShapeId()
Returns:
id for the shape.

setShapeId

public void setShapeId(int id)
Sets shape ID

Parameters:
id - of the shape

getFill

public Fill getFill()
Fill properties of this shape

Returns:
fill properties of this shape

getHyperlink

public Hyperlink getHyperlink()
Returns the hyperlink assigned to this shape

Returns:
the hyperlink assigned to this shape or null if not found.

draw

public void draw(java.awt.Graphics2D graphics)

getOutline

public java.awt.Shape getOutline()
Return shape outline as a java.awt.Shape object

Returns:
the shape outline
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class ShapeFactory

java.lang.Object
    extended by  org.apache.poi.hslf.model.ShapeFactory

public final class ShapeFactory
extends java.lang.Object

Create a Shape object depending on its type

Author:
Yegor Kozlov

Field Summary
protected static POILogger logger
Constructor Summary
ShapeFactory()
Method Summary
static Shape | createShape(EscherContainerRecord spContainer, Shape parent) Create a new shape from the data provided.
static ShapeGroup | createShapeGroup(EscherContainerRecord spContainer, Shape parent)
static Shape | createSimpeShape(EscherContainerRecord spContainer, Shape parent)
protected static Record | getClientDataRecord(EscherContainerRecord spContainer, int recordType)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected static POILogger logger
Constructor Detail

ShapeFactory

public ShapeFactory()
Method Detail

createShape

public static Shape createShape(EscherContainerRecord spContainer,
                                Shape parent)
Create a new shape from the data provided.

createShapeGroup

public static ShapeGroup createShapeGroup(EscherContainerRecord spContainer,
                                          Shape parent)

createSimpeShape

public static Shape createSimpeShape(EscherContainerRecord spContainer,
                                     Shape parent)

getClientDataRecord

protected static Record getClientDataRecord(EscherContainerRecord spContainer,
                                            int recordType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class ShapeGroup

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.ShapeGroup
Direct Known Subclasses:
Table
public class ShapeGroup
extends Shape

Represents a group of shapes.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
 | ShapeGroup() Create a new ShapeGroup.
protected | ShapeGroup(EscherContainerRecord escherRecord, Shape parent) Create a ShapeGroup object and initilize it from the supplied Record container.
Method Summary
void | addShape(Shape shape) Add a shape to this group.
protected EscherContainerRecord | createSpContainer(boolean isChild) Create a new ShapeGroup and create an instance of EscherSpgrContainer which represents a group of shapes
void | draw(java.awt.Graphics2D graphics)
java.awt.geom.Rectangle2D | getAnchor2D() Returns the anchor (the bounding box rectangle) of this shape group.
java.awt.geom.Rectangle2D | getCoordinates() Gets the coordinate space of this group.
Hyperlink | getHyperlink() Returns null - shape groups can't have hyperlinks
Shape[] | getShapes()
int | getShapeType() Return type of the shape.
void | moveTo(int x, int y) Moves this ShapeGroup to the specified location.
void | setAnchor(java.awt.Rectangle anchor) Sets the anchor (the bounding box rectangle) of this shape.
void | setCoordinates(java.awt.geom.Rectangle2D anchor) Sets the coordinate space of this group.
Methods inherited from class org.apache.poi.hslf.model.Shape
afterInsert, getAnchor, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getLogicalAnchor2D, getOutline, getParent, getShapeId, getShapeName, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShapeGroup

public ShapeGroup()
Create a new ShapeGroup. This constructor is used when a new shape is created.

ShapeGroup

protected ShapeGroup(EscherContainerRecord escherRecord,
                     Shape parent)
Create a ShapeGroup object and initilize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape
Method Detail

getShapes

public Shape[] getShapes()
Returns:
the shapes contained in this group container

setAnchor

public void setAnchor(java.awt.Rectangle anchor)
Sets the anchor (the bounding box rectangle) of this shape. All coordinates should be expressed in Master units (576 dpi).

Parameters:
anchor - new anchor

setCoordinates

public void setCoordinates(java.awt.geom.Rectangle2D anchor)
Sets the coordinate space of this group. All children are constrained to these coordinates.

Parameters:
anchor - the coordinate space of this group

getCoordinates

public java.awt.geom.Rectangle2D getCoordinates()
Gets the coordinate space of this group. All children are constrained to these coordinates.

Returns:
the coordinate space of this group

createSpContainer

protected EscherContainerRecord createSpContainer(boolean isChild)
Create a new ShapeGroup and create an instance of EscherSpgrContainer which represents a group of shapes

Specified by:
createSpContainer in class Shape

addShape

public void addShape(Shape shape)
Add a shape to this group.

Parameters:
shape - - the Shape to add

moveTo

public void moveTo(int x,
                   int y)
Moves this ShapeGroup to the specified location.

Parameters:
x - the x coordinate of the top left corner of the shape in new location
y - the y coordinate of the top left corner of the shape in new location

getAnchor2D

public java.awt.geom.Rectangle2D getAnchor2D()
Returns the anchor (the bounding box rectangle) of this shape group. All coordinates are expressed in points (72 dpi).

Overrides:
getAnchor2D in class Shape
Returns:
the anchor of this shape group

getShapeType

public int getShapeType()
Return type of the shape. In most cases shape group type is ShapeTypes.NotPrimitive

Overrides:
getShapeType in class Shape
Returns:
type of the shape.
See Also:
RecordTypes

getHyperlink

public Hyperlink getHyperlink()
Returns null - shape groups can't have hyperlinks

Overrides:
getHyperlink in class Shape
Returns:
null.

draw

public void draw(java.awt.Graphics2D graphics)
Overrides:
draw in class Shape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeOutline

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Interface ShapeOutline

public interface ShapeOutline

Date: Apr 17, 2008

Author:
Yegor Kozlov

Method Summary
 java.awt.Shape getOutline(Shape shape)

Method Detail

getOutline

java.awt.Shape getOutline(Shape shape)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapePainter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class ShapePainter

java.lang.Object
    extended by  org.apache.poi.hslf.model.ShapePainter

public final class ShapePainter
extends java.lang.Object

Paint a shape into java.awt.Graphics2D

Author:
Yegor Kozlov

Field Summary
protected static POILogger logger
Constructor Summary
ShapePainter()
Method Summary
static void paint(SimpleShape shape, java.awt.Graphics2D graphics)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected static POILogger logger
Constructor Detail

ShapePainter

public ShapePainter()
Method Detail

paint

public static void paint(SimpleShape shape,
                         java.awt.Graphics2D graphics)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeTypes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class ShapeTypes

java.lang.Object
    extended by  org.apache.poi.hslf.model.ShapeTypes
All Implemented Interfaces:
ShapeTypes
public final class ShapeTypes
extends java.lang.Object
implements ShapeTypes

Contains all known shape types in PowerPoint

Author:
Yegor Kozlov

Field Summary
static java.util.HashMap types
Fields inherited from interface org.apache.poi.sl.usermodel.ShapeTypes
AccentBorderCallout1, AccentBorderCallout2, AccentBorderCallout3, AccentBorderCallout90, AccentCallout1, AccentCallout2, AccentCallout3, AccentCallout90, ActionButtonBackPrevious, ActionButtonBeginning, ActionButtonBlank, ActionButtonDocument, ActionButtonEnd, ActionButtonForwardNext, ActionButtonHelp, ActionButtonHome, ActionButtonInformation, ActionButtonMovie, ActionButtonReturn, ActionButtonSound, Arc, Arrow, Balloon, BentArrow, BentConnector2, BentConnector3, BentConnector4, BentConnector5, BentUpArrow, Bevel, BlockArc, BorderCallout1, BorderCallout2, BorderCallout3, BorderCallout90, BracePair, BracketPair, Callout1, Callout2, Callout3, Callout90, Can, Chevron, CircularArrow, CloudCallout, Cube, CurvedConnector2, CurvedConnector3, CurvedConnector4, CurvedConnector5, CurvedDownArrow, CurvedLeftArrow, CurvedRightArrow, CurvedUpArrow, Diamond, Donut, DoubleWave, DownArrow, DownArrowCallout, Ellipse, EllipseRibbon, EllipseRibbon2, FlowChartAlternateProcess, FlowChartCollate, FlowChartConnector, FlowChartDecision, FlowChartDelay, FlowChartDisplay, FlowChartDocument, FlowChartExtract, FlowChartInputOutput, FlowChartInternalStorage, FlowChartMagneticDisk, FlowChartMagneticDrum, FlowChartMagneticTape, FlowChartManualInput, FlowChartManualOperation, FlowChartMerge, FlowChartMultidocument, FlowChartOfflineStorage, FlowChartOffpageConnector, FlowChartOnlineStorage, FlowChartOr, FlowChartPredefinedProcess, FlowChartPreparation, FlowChartProcess, FlowChartPunchedCard, FlowChartPunchedTape, FlowChartSort, FlowChartSummingJunction, FlowChartTerminator, FoldedCorner, Heart, Hexagon, HomePlate, HorizontalScroll, HostControl, IrregularSeal1, IrregularSeal2, IsocelesTriangle, LeftArrow, LeftArrowCallout, LeftBrace, LeftBracket, LeftRightArrow, LeftRightArrowCallout, LeftRightUpArrow, LeftUpArrow, LightningBolt, Line, Moon, NoSmoking, NotchedCircularArrow, NotchedRightArrow, NotPrimitive, Octagon, Parallelogram, Pentagon, PictureFrame, Plaque, Plus, QuadArrow, QuadArrowCallout, Rectangle, Ribbon, Ribbon2, RightArrowCallout, RightBrace, RightBracket, RightTriangle, RoundRectangle, Seal, SmileyFace, Star, Star16, Star24, Star32, Star4, Star8, StraightConnector1, StripedRightArrow, Sun, TextArchDownCurve, TextArchDownPour, TextArchUpCurve, TextArchUpPour, TextBox, TextButtonCurve, TextButtonPour, TextCanDown, TextCanUp, TextCascadeDown, TextCascadeUp, TextChevron, TextChevronInverted, TextCircleCurve, TextCirclePour, TextCurve, TextCurveDown, TextCurveUp, TextDeflate, TextDeflateBottom, TextDeflateInflate, TextDeflateInflateDeflate, TextDeflateTop, TextFadeDown, TextFadeLeft, TextFadeRight, TextFadeUp, TextHexagon, TextInflate, TextInflateBottom, TextInflateTop, TextOctagon, TextOnCurve, TextOnRing, TextPlainText, TextRing, TextRingInside, TextRingOutside, TextSimple, TextSlantDown, TextSlantUp, TextStop, TextTriangle, TextTriangleInverted, TextWave, TextWave1, TextWave2, TextWave3, TextWave4, ThickArrow, Trapezoid, UpArrow, UpArrowCallout, UpDownArrow, UpDownArrowCallout, UturnArrow, VerticalScroll, Wave, WedgeEllipseCallout, WedgeRectCallout, WedgeRRectCallout
Constructor Summary
ShapeTypes()
Method Summary
static java.lang.String typeName(int type)
Return name of the shape by id
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

types

public static java.util.HashMap types
Constructor Detail

ShapeTypes

public ShapeTypes()
Method Detail

typeName

public static java.lang.String typeName(int type)
Return name of the shape by id

Parameters:
type - - the id of the shape, one of the static constants defined in this class
Returns:
the name of the shape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Sheet

java.lang.Object
    extended by  org.apache.poi.hslf.model.Sheet
Direct Known Subclasses:
MasterSheet, Notes, Slide
public abstract class Sheet
extends java.lang.Object

This class defines the common format of "Sheets" in a powerpoint document. Such sheets could be Slides, Notes, Master etc

Author:
Nick Burch, Yegor Kozlov

Constructor Summary
Sheet(SheetContainer container, int sheetNo)
Method Summary
int | _getSheetNumber() Returns the (internal, SlideIdentifier based) sheet number, as used to reference this sheet from other records.
int | _getSheetRefId() Returns the (internal, RefID based) sheet number, as used to in PersistPtr stuff.
void | addShape(Shape shape) Add a new Shape to this Slide
int | allocateShapeId() Allocates new shape id for the new drawing group id.
void | draw(java.awt.Graphics2D graphics)
static TextRun[] | findTextRuns(PPDrawing ppdrawing) For a given PPDrawing, grab all the TextRuns
protected static void | findTextRuns(Record[] records, java.util.List<TextRun> found) Scans through the supplied record array, looking for a TextHeaderAtom followed by one of a TextBytesAtom or a TextCharsAtom.
Background | getBackground() Returns the background shape for this sheet.
ColorSchemeAtom | getColorScheme() Color scheme for this sheet.
abstract MasterSheet | getMasterSheet() Return the master sheet .
TextShape | getPlaceholder(int type) Search text placeholer by its type
TextShape | getPlaceholderByTextType(int type) Return placeholder by text type
protected PPDrawing | getPPDrawing() Fetch the PPDrawing from the underlying record
java.lang.String | getProgrammableTag() Return programmable tag associated with this sheet, e.g.
Shape[] | getShapes() Returns all shapes contained in this Sheet
SheetContainer | getSheetContainer() Return record container for this sheet
SlideShow | getSlideShow() Fetch the SlideShow we're attached to
abstract TextRun[] | getTextRuns() Returns an array of all the TextRuns in the sheet.
protected void | onAddTextShape(TextShape shape) Subclasses should call this method and update the array of text runs when a text shape is added
void | onCreate() Called by SlideShow ater a new sheet is created
boolean | removeShape(Shape shape) Removes the specified shape from this sheet.
void | setSlideShow(SlideShow ss) Set the SlideShow we're attached to.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sheet

public Sheet(SheetContainer container,
             int sheetNo)
Method Detail

getTextRuns

public abstract TextRun[] getTextRuns()
Returns an array of all the TextRuns in the sheet.

_getSheetRefId

public int _getSheetRefId()
Returns the (internal, RefID based) sheet number, as used to in PersistPtr stuff.

_getSheetNumber

public int _getSheetNumber()
Returns the (internal, SlideIdentifier based) sheet number, as used to reference this sheet from other records.

getPPDrawing

protected PPDrawing getPPDrawing()
Fetch the PPDrawing from the underlying record

getSlideShow

public SlideShow getSlideShow()
Fetch the SlideShow we're attached to

getSheetContainer

public SheetContainer getSheetContainer()
Return record container for this sheet

setSlideShow

public void setSlideShow(SlideShow ss)
Set the SlideShow we're attached to. Also passes it on to our child RichTextRuns

findTextRuns

public static TextRun[] findTextRuns(PPDrawing ppdrawing)
For a given PPDrawing, grab all the TextRuns

findTextRuns

protected static void findTextRuns(Record[] records,
                                   java.util.List<TextRun> found)
Scans through the supplied record array, looking for a TextHeaderAtom followed by one of a TextBytesAtom or a TextCharsAtom. Builds up TextRuns from these

Parameters:
records - the records to build from
found - vector to add any found to

getShapes

public Shape[] getShapes()
Returns all shapes contained in this Sheet

Returns:
all shapes contained in this Sheet (Slide or Notes)

addShape

public void addShape(Shape shape)
Add a new Shape to this Slide

Parameters:
shape - - the Shape to add

allocateShapeId

public int allocateShapeId()
Allocates new shape id for the new drawing group id.

Returns:
a new shape id.

removeShape

public boolean removeShape(Shape shape)
Removes the specified shape from this sheet.

Parameters:
shape - shape to be removed from this sheet, if present.
Returns:
true if the shape was deleted.

onCreate

public void onCreate()
Called by SlideShow ater a new sheet is created

getMasterSheet

public abstract MasterSheet getMasterSheet()
Return the master sheet .

getColorScheme

public ColorSchemeAtom getColorScheme()
Color scheme for this sheet.

getBackground

public Background getBackground()
Returns the background shape for this sheet.

Returns:
the background shape for this sheet.

draw

public void draw(java.awt.Graphics2D graphics)

onAddTextShape

protected void onAddTextShape(TextShape shape)
Subclasses should call this method and update the array of text runs when a text shape is added

Parameters:
shape -

getPlaceholderByTextType

public TextShape getPlaceholderByTextType(int type)
Return placeholder by text type

Parameters:
type - type of text, See TextHeaderAtom
Returns:
TextShape or null

getPlaceholder

public TextShape getPlaceholder(int type)
Search text placeholer by its type

Parameters:
type - type of placeholder to search. See OEPlaceholderAtom
Returns:
TextShape or null

getProgrammableTag

public java.lang.String getProgrammableTag()
Return programmable tag associated with this sheet, e.g. ___PPT12.

Returns:
programmable tag associated with this sheet.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class SimpleShape

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
Direct Known Subclasses:
Line, Picture, TextShape
public abstract class SimpleShape
extends Shape

An abstract simple (non-group) shape. This is the parent class for all primitive shapes like Line, Rectangle, etc.

Author:
Yegor Kozlov

Field Summary
protected EscherClientDataRecord | _clientData
protected Record[] | _clientRecords Records stored in EscherClientDataRecord
static double | DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected SimpleShape(EscherContainerRecord escherRecord, Shape parent)
Create a SimpleShape object and initialize it from the supplied Record container.
Method Summary
protected EscherContainerRecord | createSpContainer(boolean isChild) Create a new Shape
void | draw(java.awt.Graphics2D graphics)
protected Record | getClientDataRecord(int recordType) Find a record in the underlying EscherClientDataRecord
protected Record[] | getClientRecords() Search for EscherClientDataRecord, if found, convert its contents into an array of HSLF records
java.awt.Color | getFillColor() The color used to fill this shape.
boolean | getFlipHorizontal() Whether the shape is horizontally flipped
boolean | getFlipVertical() Whether the shape is vertically flipped
java.awt.Color | getLineColor()
int | getLineDashing() Gets line dashing.
int | getLineStyle() Returns line style.
double | getLineWidth() Returns width of the line in in points
java.awt.geom.Rectangle2D | getLogicalAnchor2D()
int | getRotation() Rotation angle in degrees
void | setFillColor(java.awt.Color color) The color used to fill this shape.
void | setHyperlink(Hyperlink link)
void | setLineColor(java.awt.Color color) Sets the color of line
void | setLineDashing(int pen) Sets line dashing.
void | setLineStyle(int style) Sets line style.
void | setLineWidth(double width) Sets the width of line in in points
void | setRotation(int theta) Rotate this shape
protected void | updateClientData()
Methods inherited from class org.apache.poi.hslf.model.Shape
afterInsert, getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType, setSheet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_LINE_WIDTH

public static final double DEFAULT_LINE_WIDTH
See Also:
Constant Field Values

_clientRecords

protected Record[] _clientRecords
Records stored in EscherClientDataRecord

_clientData

protected EscherClientDataRecord _clientData
Constructor Detail

SimpleShape

protected SimpleShape(EscherContainerRecord escherRecord,
                      Shape parent)
Create a SimpleShape object and initialize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(boolean isChild)
Create a new Shape

Specified by:
createSpContainer in class Shape
Parameters:
isChild - true if the Line is inside a group, false otherwise
Returns:
the record container which holds this shape

getLineWidth

public double getLineWidth()
Returns width of the line in in points

setLineWidth

public void setLineWidth(double width)
Sets the width of line in in points

Parameters:
width - the width of line in in points

setLineColor

public void setLineColor(java.awt.Color color)
Sets the color of line

Parameters:
color - new color of the line

getLineColor

public java.awt.Color getLineColor()
Returns:
color of the line. If color is not set returns java.awt.Color.black

getLineDashing

public int getLineDashing()
Gets line dashing. One of the PEN_* constants defined in this class.

Returns:
dashing of the line.

setLineDashing

public void setLineDashing(int pen)
Sets line dashing. One of the PEN_* constants defined in this class.

Parameters:
pen - new style of the line.

setLineStyle

public void setLineStyle(int style)
Sets line style. One of the constants defined in this class.

Parameters:
style - new style of the line.

getLineStyle

public int getLineStyle()
Returns line style. One of the constants defined in this class.

Returns:
style of the line.

getFillColor

public java.awt.Color getFillColor()
The color used to fill this shape.

setFillColor

public void setFillColor(java.awt.Color color)
The color used to fill this shape.

Parameters:
color - the background color

getFlipHorizontal

public boolean getFlipHorizontal()
Whether the shape is horizontally flipped

Returns:
whether the shape is horizontally flipped

getFlipVertical

public boolean getFlipVertical()
Whether the shape is vertically flipped

Returns:
whether the shape is vertically flipped

getRotation

public int getRotation()
Rotation angle in degrees

Returns:
rotation angle in degrees

setRotation

public void setRotation(int theta)
Rotate this shape

Parameters:
theta - the rotation angle in degrees

getLogicalAnchor2D

public java.awt.geom.Rectangle2D getLogicalAnchor2D()
Overrides:
getLogicalAnchor2D in class Shape
Returns:
'absolute' anchor of this shape relative to the parent sheet

draw

public void draw(java.awt.Graphics2D graphics)
Overrides:
draw in class Shape

getClientDataRecord

protected Record getClientDataRecord(int recordType)
Find a record in the underlying EscherClientDataRecord

Parameters:
recordType - type of the record to search

getClientRecords

protected Record[] getClientRecords()
Search for EscherClientDataRecord, if found, convert its contents into an array of HSLF records

Returns:
an array of HSLF records contained in the shape's EscherClientDataRecord or null

updateClientData

protected void updateClientData()

setHyperlink

public void setHyperlink(Hyperlink link)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Slide

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Slide

java.lang.Object
    extended by  org.apache.poi.hslf.model.Sheet
        extended by  org.apache.poi.hslf.model.Slide

public final class Slide
extends Sheet

This class represents a slide in a PowerPoint Document. It allows access to the text within, and the layout. For now, it only does the text side of things though

Author:
Nick Burch, Yegor Kozlov

Constructor Summary
Slide(int sheetNumber, int sheetRefId, int slideNumber)
Create a new Slide instance
Slide(Slide slide, Notes notes, SlideListWithText.SlideAtomsSet atomSet, int slideIdentifier, int slideNumber)
Constructs a Slide from the Slide record, and the SlideAtomsSet containing the text.
Method Summary
TextBox | addTitle() Create a TextBox object that represents the slide's title.
void | draw(java.awt.Graphics2D graphics)
Background | getBackground() Background for this slide.
ColorSchemeAtom | getColorScheme() Color scheme for this slide.
Comment[] | getComments() Get the comment(s) for this slide.
boolean | getFollowMasterBackground() Whether this slide follows master sheet background
boolean | getFollowMasterObjects() Whether this slide draws master sheet objects
boolean | getFollowMasterScheme() Whether this slide follows master color scheme
HeadersFooters | getHeadersFooters() Header / Footer settings for this slide.
MasterSheet | getMasterSheet() Returns master sheet associated with this slide.
Notes | getNotesSheet() Returns the Notes Sheet for this slide, or null if there isn't one
protected SlideListWithText.SlideAtomsSet | getSlideAtomsSet()
int | getSlideNumber() Returns the (public facing) page number of this slide
Slide | getSlideRecord() Returns the underlying slide record
TextRun[] | getTextRuns() Returns an array of all the TextRuns found
java.lang.String | getTitle() Return title of this slide or null if the slide does not have title.
protected void | onAddTextShape(TextShape shape) Subclasses should call this method and update the array of text runs when a text shape is added
void | onCreate() Called by SlideShow ater a new slide is created.
void | setFollowMasterBackground(boolean flag) Sets whether this slide follows master background
void | setFollowMasterObjects(boolean flag) Sets whether this slide draws master sheet objects
void | setFollowMasterScheme(boolean flag) Sets whether this slide draws master color scheme
void | setMasterSheet(MasterSheet master) Change Master of this slide.
void | setNotes(Notes notes) Sets the Notes that are associated with this.
void | setSlideNumber(int newSlideNumber) Changes the Slide's (external facing) page number.
Methods inherited from class org.apache.poi.hslf.model.Sheet
_getSheetNumber, _getSheetRefId, addShape, allocateShapeId, findTextRuns, findTextRuns, getPlaceholder, getPlaceholderByTextType, getPPDrawing, getProgrammableTag, getShapes, getSheetContainer, getSlideShow, removeShape, setSlideShow
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Slide

public Slide(Slide slide,
             Notes notes,
             SlideListWithText.SlideAtomsSet atomSet,
             int slideIdentifier,
             int slideNumber)
Constructs a Slide from the Slide record, and the SlideAtomsSet containing the text. Initialises TextRuns, to provide easier access to the text

Parameters:
slide - the Slide record we're based on
notes - the Notes sheet attached to us
atomSet - the SlideAtomsSet to get the text from

Slide

public Slide(int sheetNumber,
             int sheetRefId,
             int slideNumber)
Create a new Slide instance

Parameters:
sheetNumber - The internal number of the sheet, as used by PersistPtrHolder
slideNumber - The user facing number of the sheet
Method Detail

setNotes

public void setNotes(Notes notes)
Sets the Notes that are associated with this. Updates the references in the records to point to the new ID

setSlideNumber

public void setSlideNumber(int newSlideNumber)
Changes the Slide's (external facing) page number.

See Also:
SlideShow.reorderSlide(int, int)

onCreate

public void onCreate()
Called by SlideShow ater a new slide is created.

For Slide we need to do the following:

  • set id of the drawing group.
  • set shapeId for the container descriptor and background

    Overrides:
    onCreate in class Sheet

    • addTitle

    public TextBox addTitle()
    Create a TextBox object that represents the slide's title.

    Returns:
    TextBox object that represents the slide's title.

    getTitle

    public java.lang.String getTitle()
    Return title of this slide or null if the slide does not have title.

    The title is a run of text of type TextHeaderAtom.CENTER_TITLE_TYPE or TextHeaderAtom.TITLE_TYPE

    Returns:
    title of this slide
    See Also:
    TextHeaderAtom

    getTextRuns

    public TextRun[] getTextRuns()
    Returns an array of all the TextRuns found

    Specified by:
    getTextRuns in class Sheet

    getSlideNumber

    public int getSlideNumber()
    Returns the (public facing) page number of this slide

    getSlideRecord

    public Slide getSlideRecord()
    Returns the underlying slide record

    getNotesSheet

    public Notes getNotesSheet()
    Returns the Notes Sheet for this slide, or null if there isn't one

    getSlideAtomsSet

    protected SlideListWithText.SlideAtomsSet getSlideAtomsSet()
    Returns:
    set of records inside SlideListWithtext container which hold text data for this slide (typically for placeholders).

    getMasterSheet

    public MasterSheet getMasterSheet()
    Returns master sheet associated with this slide. It can be either SlideMaster or TitleMaster objects.

    Specified by:
    getMasterSheet in class Sheet
    Returns:
    the master sheet associated with this slide.

    setMasterSheet

    public void setMasterSheet(MasterSheet master)
    Change Master of this slide.

    setFollowMasterBackground

    public void setFollowMasterBackground(boolean flag)
    Sets whether this slide follows master background

    Parameters:
    flag - true if the slide follows master, false otherwise

    getFollowMasterBackground

    public boolean getFollowMasterBackground()
    Whether this slide follows master sheet background

    Returns:
    true if the slide follows master background, false otherwise

    setFollowMasterObjects

    public void setFollowMasterObjects(boolean flag)
    Sets whether this slide draws master sheet objects

    Parameters:
    flag - true if the slide draws master sheet objects, false otherwise

    getFollowMasterScheme

    public boolean getFollowMasterScheme()
    Whether this slide follows master color scheme

    Returns:
    true if the slide follows master color scheme, false otherwise

    setFollowMasterScheme

    public void setFollowMasterScheme(boolean flag)
    Sets whether this slide draws master color scheme

    Parameters:
    flag - true if the slide draws master color scheme, false otherwise

    getFollowMasterObjects

    public boolean getFollowMasterObjects()
    Whether this slide draws master sheet objects

    Returns:
    true if the slide draws master sheet objects, false otherwise

    getBackground

    public Background getBackground()
    Background for this slide.

    Overrides:
    getBackground in class Sheet
    Returns:
    the background shape for this sheet.

    getColorScheme

    public ColorSchemeAtom getColorScheme()
    Color scheme for this slide.

    Overrides:
    getColorScheme in class Sheet

    getComments

    public Comment[] getComments()
    Get the comment(s) for this slide. Note - for now, only works on PPT 2000 and PPT 2003 files. Doesn't work for PPT 97 ones, as they do their comments oddly.

    draw

    public void draw(java.awt.Graphics2D graphics)
    Overrides:
    draw in class Sheet

    getHeadersFooters

    public HeadersFooters getHeadersFooters()
    Header / Footer settings for this slide.

    Returns:
    Header / Footer settings for this slide

    onAddTextShape

    protected void onAddTextShape(TextShape shape)
    Description copied from class: Sheet
    Subclasses should call this method and update the array of text runs when a text shape is added

    Overrides:
    onAddTextShape in class Sheet
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideMaster

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class SlideMaster

java.lang.Object
    extended by  org.apache.poi.hslf.model.Sheet
        extended by  org.apache.poi.hslf.model.MasterSheet
            extended by  org.apache.poi.hslf.model.SlideMaster

public final class SlideMaster
extends MasterSheet

SlideMaster determines the graphics, layout, and formatting for all the slides in a given presentation. It stores information about default font styles, placeholder sizes and positions, background design, and color schemes.

Author:
Yegor Kozlov

Constructor Summary
SlideMaster(MainMaster record, int sheetNo)
Constructs a SlideMaster from the MainMaster record,
Method Summary
MasterSheet | getMasterSheet() Returns null since SlideMasters doen't have master sheet.
TextProp | getStyleAttribute(int txtype, int level, java.lang.String name, boolean isCharacter) Pickup a style attribute from the master.
TextRun[] | getTextRuns() Returns an array of all the TextRuns found
TxMasterStyleAtom[] | getTxMasterStyleAtoms()
protected void | onAddTextShape(TextShape shape) Subclasses should call this method and update the array of text runs when a text shape is added
void | setSlideShow(SlideShow ss) Assign SlideShow for this slide master.
Methods inherited from class org.apache.poi.hslf.model.MasterSheet
isPlaceholder
Methods inherited from class org.apache.poi.hslf.model.Sheet
_getSheetNumber, _getSheetRefId, addShape, allocateShapeId, draw, findTextRuns, findTextRuns, getBackground, getColorScheme, getPlaceholder, getPlaceholderByTextType, getPPDrawing, getProgrammableTag, getShapes, getSheetContainer, getSlideShow, onCreate, removeShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlideMaster

public SlideMaster(MainMaster record,
                   int sheetNo)
Constructs a SlideMaster from the MainMaster record,

Method Detail

getTextRuns

public TextRun[] getTextRuns()
Returns an array of all the TextRuns found

Specified by:
getTextRuns in class Sheet

getMasterSheet

public MasterSheet getMasterSheet()
Returns null since SlideMasters doen't have master sheet.

Specified by:
getMasterSheet in class Sheet

getStyleAttribute

public TextProp getStyleAttribute(int txtype,
                                  int level,
                                  java.lang.String name,
                                  boolean isCharacter)
Pickup a style attribute from the master. This is the "workhorse" which returns the default style attrubutes.

Specified by:
getStyleAttribute in class MasterSheet

setSlideShow

public void setSlideShow(SlideShow ss)
Assign SlideShow for this slide master. (Used interanlly)

Overrides:
setSlideShow in class Sheet

onAddTextShape

protected void onAddTextShape(TextShape shape)
Description copied from class: Sheet
Subclasses should call this method and update the array of text runs when a text shape is added

Overrides:
onAddTextShape in class Sheet

getTxMasterStyleAtoms

public TxMasterStyleAtom[] getTxMasterStyleAtoms()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Table

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class Table

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.ShapeGroup
            extended by  org.apache.poi.hslf.model.Table

public final class Table
extends ShapeGroup

Represents a table in a PowerPoint presentation

Author:
Yegor Kozlov

Field Summary
protected static int | BORDER_BOTTOM
protected static int | BORDER_LEFT
protected static int | BORDER_RIGHT
protected static int | BORDER_TOP
protected static int | BORDERS_ALL
protected static int | BORDERS_INSIDE
protected static int | BORDERS_NONE
protected static int | BORDERS_OUTSIDE
protected TableCell[][] | cells
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
Table(EscherContainerRecord escherRecord, Shape parent)
Create a Table object and initilize it from the supplied Record container.
Table(int numrows, int numcols)
Create a new Table of the given number of rows and columns
Method Summary
protected void | afterInsert(Sheet sh) Event which fires when a shape is inserted in the sheet.
Line | createBorder() Create a border to format this table
TableCell | getCell(int row, int col) Gets a cell
int | getNumberOfColumns()
int | getNumberOfRows()
protected void | initTable()
void | setAllBorders(Line line) Format the table and apply the specified Line to all cell boundaries, both outside and inside
void | setColumnWidth(int col, int width) Sets the column width.
void | setInsideBorders(Line line) Format the inside border using the specified Line object
void | setOutsideBorders(Line line) Format the outside border using the specified Line object
void | setRowHeight(int row, int height) Sets the row height.
void | setSheet(Sheet sheet) Assign the SlideShow this shape belongs to
Methods inherited from class org.apache.poi.hslf.model.ShapeGroup
addShape, createSpContainer, draw, getAnchor2D, getCoordinates, getHyperlink, getShapes, getShapeType, moveTo, setAnchor, setCoordinates
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getLogicalAnchor2D, getOutline, getParent, getShapeId, getShapeName, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BORDER_TOP

protected static final int BORDER_TOP
See Also:
Constant Field Values

BORDER_RIGHT

protected static final int BORDER_RIGHT
See Also:
Constant Field Values

BORDER_BOTTOM

protected static final int BORDER_BOTTOM
See Also:
Constant Field Values

BORDER_LEFT

protected static final int BORDER_LEFT
See Also:
Constant Field Values

BORDERS_ALL

protected static final int BORDERS_ALL
See Also:
Constant Field Values

BORDERS_OUTSIDE

protected static final int BORDERS_OUTSIDE
See Also:
Constant Field Values

BORDERS_INSIDE

protected static final int BORDERS_INSIDE
See Also:
Constant Field Values

BORDERS_NONE

protected static final int BORDERS_NONE
See Also:
Constant Field Values

cells

protected TableCell[][] cells
Constructor Detail

Table

public Table(int numrows,
             int numcols)
Create a new Table of the given number of rows and columns

Parameters:
numrows - the number of rows
numcols - the number of columns

Table

public Table(EscherContainerRecord escherRecord,
             Shape parent)
Create a Table object and initilize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape
Method Detail

getCell

public TableCell getCell(int row,
                         int col)
Gets a cell

Parameters:
row - the row index (0-based)
col - the column index (0-based)
Returns:
the cell

getNumberOfColumns

public int getNumberOfColumns()

getNumberOfRows

public int getNumberOfRows()

afterInsert

protected void afterInsert(Sheet sh)
Description copied from class: Shape
Event which fires when a shape is inserted in the sheet. In some cases we need to propagate changes to upper level containers.
Default implementation does nothing.

Overrides:
afterInsert in class Shape
Parameters:
sh - - owning shape

initTable

protected void initTable()

setSheet

public void setSheet(Sheet sheet)
Assign the SlideShow this shape belongs to

Overrides:
setSheet in class Shape
Parameters:
sheet - owner of this shape

setRowHeight

public void setRowHeight(int row,
                         int height)
Sets the row height.

Parameters:
row - the row index (0-based)
height - the height to set (in pixels)

setColumnWidth

public void setColumnWidth(int col,
                           int width)
Sets the column width.

Parameters:
col - the column index (0-based)
width - the width to set (in pixels)

setAllBorders

public void setAllBorders(Line line)
Format the table and apply the specified Line to all cell boundaries, both outside and inside

Parameters:
line - the border line

setOutsideBorders

public void setOutsideBorders(Line line)
Format the outside border using the specified Line object

Parameters:
line - the border line

setInsideBorders

public void setInsideBorders(Line line)
Format the inside border using the specified Line object

Parameters:
line - the border line

createBorder

public Line createBorder()
Create a border to format this table

Returns:
the created border
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class TableCell

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.TextShape
                extended by  org.apache.poi.hslf.model.TextBox
                    extended by  org.apache.poi.hslf.model.TableCell

public final class TableCell
extends TextBox

Represents a cell in a ppt table

Author:
Yegor Kozlov

Field Summary
protected static int | DEFAULT_HEIGHT
protected static int | DEFAULT_WIDTH
Fields inherited from class org.apache.poi.hslf.model.TextShape
_frc, _txtbox, _txtrun, AlignCenter, AlignJustify, AlignLeft, AlignRight, AnchorBottom, AnchorBottomBaseline, AnchorBottomCentered, AnchorBottomCenteredBaseline, AnchorMiddle, AnchorMiddleCentered, AnchorTop, AnchorTopBaseline, AnchorTopCentered, AnchorTopCenteredBaseline, WrapByPoints, WrapNone, WrapSquare, WrapThrough, WrapTopBottom
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
protected | TableCell(EscherContainerRecord escherRecord, Shape parent) Create a TableCell object and initialize it from the supplied Record container.
 | TableCell(Shape parent) Create a new TableCell.
Method Summary
protected void | anchorBorder(int type, Line line)
protected EscherContainerRecord | createSpContainer(boolean isChild) Create a new TextBox and initialize its internal structures
Line | getBorderBottom()
Line | getBorderLeft()
Line | getBorderRight()
Line | getBorderTop()
void | setAnchor(java.awt.Rectangle anchor)
void | setBorderBottom(Line line)
void | setBorderLeft(Line line)
void | setBorderRight(Line line)
void | setBorderTop(Line line)
Methods inherited from class org.apache.poi.hslf.model.TextBox
setDefaultTextProperties
Methods inherited from class org.apache.poi.hslf.model.TextShape
afterInsert, createTextRun, draw, getEscherTextboxWrapper, getHorizontalAlignment, getMarginBottom, getMarginLeft, getMarginRight, getMarginTop, getPlaceholderAtom, getText, getTextId, getTextRun, getVerticalAlignment, getWordWrap, initTextRun, resizeToFitText, setHorizontalAlignment, setHyperlink, setMarginBottom, setMarginLeft, setMarginRight, setMarginTop, setSheet, setText, setTextId, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_WIDTH

protected static final int DEFAULT_WIDTH
See Also:
Constant Field Values

DEFAULT_HEIGHT

protected static final int DEFAULT_HEIGHT
See Also:
Constant Field Values
Constructor Detail

TableCell

protected TableCell(EscherContainerRecord escherRecord,
                    Shape parent)
Create a TableCell object and initialize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape

TableCell

public TableCell(Shape parent)
Create a new TableCell. This constructor is used when a new shape is created.

Parameters:
parent - the parent of this Shape. For example, if this text box is a cell in a table then the parent is Table.
Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(boolean isChild)
Description copied from class: TextBox
Create a new TextBox and initialize its internal structures

Overrides:
createSpContainer in class TextBox
Parameters:
isChild - true if the Line is inside a group, false otherwise
Returns:
the created EscherContainerRecord which holds shape data

anchorBorder

protected void anchorBorder(int type,
                            Line line)

getBorderLeft

public Line getBorderLeft()

setBorderLeft

public void setBorderLeft(Line line)

getBorderRight

public Line getBorderRight()

setBorderRight

public void setBorderRight(Line line)

getBorderTop

public Line getBorderTop()

setBorderTop

public void setBorderTop(Line line)

getBorderBottom

public Line getBorderBottom()

setBorderBottom

public void setBorderBottom(Line line)

setAnchor

public void setAnchor(java.awt.Rectangle anchor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class TextBox

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.TextShape
                extended by  org.apache.poi.hslf.model.TextBox
Direct Known Subclasses:
Placeholder, TableCell
public class TextBox
extends TextShape

Represents a TextFrame shape in PowerPoint.

Contains the text in a text frame as well as the properties and methods that control alignment and anchoring of the text.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.model.TextShape
_frc, _txtbox, _txtrun, AlignCenter, AlignJustify, AlignLeft, AlignRight, AnchorBottom, AnchorBottomBaseline, AnchorBottomCentered, AnchorBottomCenteredBaseline, AnchorMiddle, AnchorMiddleCentered, AnchorTop, AnchorTopBaseline, AnchorTopCentered, AnchorTopCenteredBaseline, WrapByPoints, WrapNone, WrapSquare, WrapThrough, WrapTopBottom
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
 | TextBox() Create a new TextBox.
protected | TextBox(EscherContainerRecord escherRecord, Shape parent) Create a TextBox object and initialize it from the supplied Record container.
 | TextBox(Shape parent) Create a new TextBox.
Method Summary
protected EscherContainerRecord | createSpContainer(boolean isChild) Create a new TextBox and initialize its internal structures
protected void | setDefaultTextProperties(TextRun _txtrun) Set default properties for the TextRun.
Methods inherited from class org.apache.poi.hslf.model.TextShape
afterInsert, createTextRun, draw, getEscherTextboxWrapper, getHorizontalAlignment, getMarginBottom, getMarginLeft, getMarginRight, getMarginTop, getPlaceholderAtom, getText, getTextId, getTextRun, getVerticalAlignment, getWordWrap, initTextRun, resizeToFitText, setHorizontalAlignment, setHyperlink, setMarginBottom, setMarginLeft, setMarginRight, setMarginTop, setSheet, setText, setTextId, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextBox

protected TextBox(EscherContainerRecord escherRecord,
                  Shape parent)
Create a TextBox object and initialize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape

TextBox

public TextBox(Shape parent)
Create a new TextBox. This constructor is used when a new shape is created.

Parameters:
parent - the parent of this Shape. For example, if this text box is a cell in a table then the parent is Table.

TextBox

public TextBox()
Create a new TextBox. This constructor is used when a new shape is created.

Method Detail

createSpContainer

protected EscherContainerRecord createSpContainer(boolean isChild)
Create a new TextBox and initialize its internal structures

Overrides:
createSpContainer in class SimpleShape
Parameters:
isChild - true if the Line is inside a group, false otherwise
Returns:
the created EscherContainerRecord which holds shape data

setDefaultTextProperties

protected void setDefaultTextProperties(TextRun _txtrun)
Description copied from class: TextShape
Set default properties for the TextRun. Depending on the text and shape type the defaults are different: TextBox: align=left, valign=top AutoShape: align=center, valign=middle

Overrides:
setDefaultTextProperties in class TextShape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextPainter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class TextPainter

java.lang.Object
    extended by  org.apache.poi.hslf.model.TextPainter

public final class TextPainter
extends java.lang.Object

Paint text into java.awt.Graphics2D

Author:
Yegor Kozlov

Nested Class Summary
static class TextPainter.TextElement
Field Summary
protected TextShape | _shape
protected static char | DEFAULT_BULLET_CHAR Display unicode square if a bullet char can't be displayed, for example, if Wingdings font is used.
protected POILogger | logger
Constructor Summary
TextPainter(TextShape shape)
Method Summary
java.text.AttributedString | getAttributedString(TextRun txrun) Convert the underlying set of rich text runs into java.text.AttributedString
TextPainter.TextElement[] | getTextElements(float textWidth, java.awt.font.FontRenderContext frc)
void | paint(java.awt.Graphics2D graphics)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected POILogger logger

DEFAULT_BULLET_CHAR

protected static final char DEFAULT_BULLET_CHAR
Display unicode square if a bullet char can't be displayed, for example, if Wingdings font is used. TODO: map Wingdngs and Symbol to unicode Arial

See Also:
Constant Field Values

_shape

protected TextShape _shape
Constructor Detail

TextPainter

public TextPainter(TextShape shape)
Method Detail

getAttributedString

public java.text.AttributedString getAttributedString(TextRun txrun)
Convert the underlying set of rich text runs into java.text.AttributedString

paint

public void paint(java.awt.Graphics2D graphics)

getTextElements

public TextPainter.TextElement[] getTextElements(float textWidth,
                                                 java.awt.font.FontRenderContext frc)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextPainter.TextElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class TextPainter.TextElement

java.lang.Object
    extended by  org.apache.poi.hslf.model.TextPainter.TextElement
Enclosing class:
TextPainter
public static class TextPainter.TextElement
extends java.lang.Object

Field Summary
int | _align
java.text.AttributedString | _bullet
int | _bulletOffset
java.text.AttributedString | _text
int | _textOffset
float | advance
float | ascent
float | descent
int | textEndIndex
int | textStartIndex
Constructor Summary
TextPainter.TextElement()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_text

public java.text.AttributedString _text

_textOffset

public int _textOffset

_bullet

public java.text.AttributedString _bullet

_bulletOffset

public int _bulletOffset

_align

public int _align

ascent

public float ascent

descent

public float descent

advance

public float advance

textStartIndex

public int textStartIndex

textEndIndex

public int textEndIndex
Constructor Detail

TextPainter.TextElement

public TextPainter.TextElement()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class TextRun

java.lang.Object
    extended by  org.apache.poi.hslf.model.TextRun

public final class TextRun
extends java.lang.Object

This class represents a run of text in a powerpoint document. That run could be text on a sheet, or text in a note. It is only a very basic class for now

Author:
Nick Burch

Field Summary
protected TextBytesAtom | _byteAtom
protected TextCharsAtom | _charAtom
protected TextHeaderAtom | _headerAtom
protected boolean | _isUnicode
protected Record[] | _records all text run records that follow TextHeaderAtom.
protected RichTextRun[] | _rtRuns
protected TextRulerAtom | _ruler
protected StyleTextPropAtom | _styleAtom
Constructor Summary
TextRun(TextHeaderAtom tha, TextBytesAtom tba, StyleTextPropAtom sta)
Constructs a Text Run from a Ascii text block
TextRun(TextHeaderAtom tha, TextCharsAtom tca, StyleTextPropAtom sta)
Constructs a Text Run from a Unicode text block
Method Summary
RichTextRun | appendText(java.lang.String s) Adds the supplied text onto the end of the TextRun, creating a new RichTextRun (returned) for it to sit in.
void | buildRichTextRuns(java.util.LinkedList pStyles, java.util.LinkedList cStyles, java.lang.String runRawText)
void | changeTextInRichTextRun(RichTextRun run, java.lang.String s) Handles an update to the text stored in one of the Rich Text Runs
TextRulerAtom | createTextRuler()
void | ensureStyleAtomPresent() Ensure a StyleTextPropAtom is present for this run, by adding if required.
Hyperlink[] | getHyperlinks() Returns the array of all hyperlinks in this text run
protected int | getIndex()
java.lang.String | getRawText() Returns the raw text content of the run.
Record[] | getRecords() Returns records that make up this text run
RichTextRun | getRichTextRunAt(int pos) Fetch RichTextRun at a given position
RichTextRun[] | getRichTextRuns() Fetch the rich text runs (runs of text with the same styling) that are contained within this block of text
int | getRunType() Returns the type of the text, from the TextHeaderAtom.
protected int | getShapeId()
Sheet | getSheet()
java.lang.String | getText() Returns the text content of the run, which has been made safe for printing and other use.
TextRulerAtom | getTextRuler()
java.lang.String | normalize(java.lang.String s) Returns a new string with line breaks converted into internal ppt representation
protected void | setIndex(int id)
void | setRawText(java.lang.String s) Changes the text, and sets it all to have the same styling as the the first character has.
void | setRunType(int type) Changes the type of the text.
protected void | setShapeId(int id)
void | setSheet(Sheet sheet)
void | setText(java.lang.String s) Changes the text.
void | supplySlideShow(SlideShow ss) Supply the SlideShow we belong to.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_headerAtom

protected TextHeaderAtom _headerAtom

_byteAtom

protected TextBytesAtom _byteAtom

_charAtom

protected TextCharsAtom _charAtom

_styleAtom

protected StyleTextPropAtom _styleAtom

_ruler

protected TextRulerAtom _ruler

_isUnicode

protected boolean _isUnicode

_rtRuns

protected RichTextRun[] _rtRuns

_records

protected Record[] _records
all text run records that follow TextHeaderAtom. (there can be misc InteractiveInfo, TxInteractiveInfo and other records)

Constructor Detail

TextRun

public TextRun(TextHeaderAtom tha,
               TextCharsAtom tca,
               StyleTextPropAtom sta)
Constructs a Text Run from a Unicode text block

Parameters:
tha - the TextHeaderAtom that defines what's what
tca - the TextCharsAtom containing the text
sta - the StyleTextPropAtom which defines the character stylings

TextRun

public TextRun(TextHeaderAtom tha,
               TextBytesAtom tba,
               StyleTextPropAtom sta)
Constructs a Text Run from a Ascii text block

Parameters:
tha - the TextHeaderAtom that defines what's what
tba - the TextBytesAtom containing the text
sta - the StyleTextPropAtom which defines the character stylings
Method Detail

buildRichTextRuns

public void buildRichTextRuns(java.util.LinkedList pStyles,
                              java.util.LinkedList cStyles,
                              java.lang.String runRawText)

appendText

public RichTextRun appendText(java.lang.String s)
Adds the supplied text onto the end of the TextRun, creating a new RichTextRun (returned) for it to sit in. In many cases, before calling this, you'll want to add a newline onto the end of your last RichTextRun

changeTextInRichTextRun

public void changeTextInRichTextRun(RichTextRun run,
                                    java.lang.String s)
Handles an update to the text stored in one of the Rich Text Runs

Parameters:
run -
s -

setRawText

public void setRawText(java.lang.String s)
Changes the text, and sets it all to have the same styling as the the first character has. If you care about styling, do setText on a RichTextRun instead

setText

public void setText(java.lang.String s)
Changes the text. Converts '\r' into '\n'

ensureStyleAtomPresent

public void ensureStyleAtomPresent()
Ensure a StyleTextPropAtom is present for this run, by adding if required. Normally for internal TextRun use.

getText

public java.lang.String getText()
Returns the text content of the run, which has been made safe for printing and other use.

getRawText

public java.lang.String getRawText()
Returns the raw text content of the run. This hasn't had any changes applied to it, and so is probably unlikely to print out nicely.

getRichTextRuns

public RichTextRun[] getRichTextRuns()
Fetch the rich text runs (runs of text with the same styling) that are contained within this block of text

getRunType

public int getRunType()
Returns the type of the text, from the TextHeaderAtom. Possible values can be seen from TextHeaderAtom

See Also:
TextHeaderAtom

setRunType

public void setRunType(int type)
Changes the type of the text. Values should be taken from TextHeaderAtom. No checking is done to ensure you set this to a valid value!

See Also:
TextHeaderAtom

supplySlideShow

public void supplySlideShow(SlideShow ss)
Supply the SlideShow we belong to. Also passes it on to our child RichTextRuns

setSheet

public void setSheet(Sheet sheet)

getSheet

public Sheet getSheet()

getShapeId

protected int getShapeId()
Returns:
Shape ID

setShapeId

protected void setShapeId(int id)
Parameters:
id - Shape ID

getIndex

protected int getIndex()
Returns:
0-based index of the text run in the SLWT container

setIndex

protected void setIndex(int id)
Parameters:
id - 0-based index of the text run in the SLWT container

getHyperlinks

public Hyperlink[] getHyperlinks()
Returns the array of all hyperlinks in this text run

Returns:
the array of all hyperlinks in this text run or null if not found.

getRichTextRunAt

public RichTextRun getRichTextRunAt(int pos)
Fetch RichTextRun at a given position

Parameters:
pos - 0-based index in the text
Returns:
RichTextRun or null if not found

getTextRuler

public TextRulerAtom getTextRuler()

createTextRuler

public TextRulerAtom createTextRuler()

normalize

public java.lang.String normalize(java.lang.String s)
Returns a new string with line breaks converted into internal ppt representation

getRecords

public Record[] getRecords()
Returns records that make up this text run

Returns:
text run records
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class TextShape

java.lang.Object
    extended by  org.apache.poi.hslf.model.Shape
        extended by  org.apache.poi.hslf.model.SimpleShape
            extended by  org.apache.poi.hslf.model.TextShape
Direct Known Subclasses:
AutoShape, TextBox
public abstract class TextShape
extends SimpleShape

A common superclass of all shapes that can hold text.

Author:
Yegor Kozlov

Field Summary
protected static java.awt.font.FontRenderContext | _frc Used to calculate text bounds
protected EscherTextboxWrapper | _txtbox Escher container which holds text attributes such as TextHeaderAtom, TextBytesAtom ot TextCharsAtom, StyleTextPropAtom etc.
protected TextRun | _txtrun TextRun object which holds actual text and format data
static int | AlignCenter
static int | AlignJustify
static int | AlignLeft How to align the text
static int | AlignRight
static int | AnchorBottom
static int | AnchorBottomBaseline
static int | AnchorBottomCentered
static int | AnchorBottomCenteredBaseline
static int | AnchorMiddle
static int | AnchorMiddleCentered
static int | AnchorTop How to anchor the text
static int | AnchorTopBaseline
static int | AnchorTopCentered
static int | AnchorTopCenteredBaseline
static int | WrapByPoints
static int | WrapNone
static int | WrapSquare How to wrap the text
static int | WrapThrough
static int | WrapTopBottom
Fields inherited from class org.apache.poi.hslf.model.SimpleShape
_clientData, _clientRecords, DEFAULT_LINE_WIDTH
Fields inherited from class org.apache.poi.hslf.model.Shape
_escherContainer, _fill, _parent, _sheet, EMU_PER_CENTIMETER, EMU_PER_INCH, EMU_PER_POINT, logger, MASTER_DPI, PIXEL_DPI, POINT_DPI
Constructor Summary
 | TextShape() Create a new TextBox.
protected | TextShape(EscherContainerRecord escherRecord, Shape parent) Create a TextBox object and initialize it from the supplied Record container.
 | TextShape(Shape parent) Create a new TextBox.
Method Summary
protected void | afterInsert(Sheet sh) When a textbox is added to a sheet we need to tell upper-level PPDrawing about it.
TextRun | createTextRun()
void | draw(java.awt.Graphics2D graphics)
protected EscherTextboxWrapper | getEscherTextboxWrapper()
int | getHorizontalAlignment() Gets the type of horizontal alignment for the text.
float | getMarginBottom() Returns the distance (in points) between the bottom of the text frame and the bottom of the inscribed rectangle of the shape that contains the text.
float | getMarginLeft() Returns the distance (in points) between the left edge of the text frame and the left edge of the inscribed rectangle of the shape that contains the text.
float | getMarginRight() Returns the distance (in points) between the right edge of the text frame and the right edge of the inscribed rectangle of the shape that contains the text.
float | getMarginTop() Returns the distance (in points) between the top of the text frame and the top of the inscribed rectangle of the shape that contains the text.
OEPlaceholderAtom | getPlaceholderAtom() Return OEPlaceholderAtom, the atom that describes a placeholder.
java.lang.String | getText() Returns the text contained in this text frame.
int | getTextId()
TextRun | getTextRun()
int | getVerticalAlignment() Returns the type of vertical alignment for the text.
int | getWordWrap() Returns the value indicating word wrap.
protected void | initTextRun()
java.awt.geom.Rectangle2D | resizeToFitText() Adjust the size of the TextShape so it encompasses the text inside it.
protected void | setDefaultTextProperties(TextRun _txtrun) Set default properties for the TextRun.
void | setHorizontalAlignment(int align) Sets the type of horizontal alignment for the text.
void | setHyperlink(int linkId, int beginIndex, int endIndex) Assigns a hyperlink to this text shape
void | setMarginBottom(float margin) Sets the botom margin.
void | setMarginLeft(float margin) Sets the left margin.
void | setMarginRight(float margin) Sets the right margin.
void | setMarginTop(float margin) Sets the top margin.
void | setSheet(Sheet sheet) Assign the SlideShow this shape belongs to
void | setText(java.lang.String text) Sets the text contained in this text frame.
void | setTextId(int id) Sets text ID
void | setVerticalAlignment(int align) Sets the type of vertical alignment for the text.
void | setWordWrap(int wrap) Specifies how the text should be wrapped
Methods inherited from class org.apache.poi.hslf.model.SimpleShape
createSpContainer, getClientDataRecord, getClientRecords, getFillColor, getFlipHorizontal, getFlipVertical, getLineColor, getLineDashing, getLineStyle, getLineWidth, getLogicalAnchor2D, getRotation, setFillColor, setHyperlink, setLineColor, setLineDashing, setLineStyle, setLineWidth, setRotation, updateClientData
Methods inherited from class org.apache.poi.hslf.model.Shape
getAnchor, getAnchor2D, getEscherChild, getEscherProperty, getEscherProperty, getEscherProperty, getFill, getHyperlink, getOutline, getParent, getShapeId, getShapeName, getShapeType, getSheet, getSpContainer, moveTo, setAnchor, setEscherProperty, setEscherProperty, setShapeId, setShapeType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

AnchorTop

public static final int AnchorTop
How to anchor the text

See Also:
Constant Field Values

AnchorMiddle

public static final int AnchorMiddle
See Also:
Constant Field Values

AnchorBottom

public static final int AnchorBottom
See Also:
Constant Field Values

AnchorTopCentered

public static final int AnchorTopCentered
See Also:
Constant Field Values

AnchorMiddleCentered

public static final int AnchorMiddleCentered
See Also:
Constant Field Values

AnchorBottomCentered

public static final int AnchorBottomCentered
See Also:
Constant Field Values

AnchorTopBaseline

public static final int AnchorTopBaseline
See Also:
Constant Field Values

AnchorBottomBaseline

public static final int AnchorBottomBaseline
See Also:
Constant Field Values

AnchorTopCenteredBaseline

public static final int AnchorTopCenteredBaseline
See Also:
Constant Field Values

AnchorBottomCenteredBaseline

public static final int AnchorBottomCenteredBaseline
See Also:
Constant Field Values

WrapSquare

public static final int WrapSquare
How to wrap the text

See Also:
Constant Field Values

WrapByPoints

public static final int WrapByPoints
See Also:
Constant Field Values

WrapNone

public static final int WrapNone
See Also:
Constant Field Values

WrapTopBottom

public static final int WrapTopBottom
See Also:
Constant Field Values

WrapThrough

public static final int WrapThrough
See Also:
Constant Field Values

AlignLeft

public static final int AlignLeft
How to align the text

See Also:
Constant Field Values

AlignCenter

public static final int AlignCenter
See Also:
Constant Field Values

AlignRight

public static final int AlignRight
See Also:
Constant Field Values

AlignJustify

public static final int AlignJustify
See Also:
Constant Field Values

_txtrun

protected TextRun _txtrun
TextRun object which holds actual text and format data

_txtbox

protected EscherTextboxWrapper _txtbox
Escher container which holds text attributes such as TextHeaderAtom, TextBytesAtom ot TextCharsAtom, StyleTextPropAtom etc.

_frc

protected static final java.awt.font.FontRenderContext _frc
Used to calculate text bounds

Constructor Detail

TextShape

protected TextShape(EscherContainerRecord escherRecord,
                    Shape parent)
Create a TextBox object and initialize it from the supplied Record container.

Parameters:
escherRecord - EscherSpContainer container which holds information about this shape
parent - the parent of the shape

TextShape

public TextShape(Shape parent)
Create a new TextBox. This constructor is used when a new shape is created.

Parameters:
parent - the parent of this Shape. For example, if this text box is a cell in a table then the parent is Table.

TextShape

public TextShape()
Create a new TextBox. This constructor is used when a new shape is created.

Method Detail

createTextRun

public TextRun createTextRun()

setDefaultTextProperties

protected void setDefaultTextProperties(TextRun _txtrun)
Set default properties for the TextRun. Depending on the text and shape type the defaults are different: TextBox: align=left, valign=top AutoShape: align=center, valign=middle

getText

public java.lang.String getText()
Returns the text contained in this text frame.

Returns:
the text string for this textbox.

setText

public void setText(java.lang.String text)
Sets the text contained in this text frame.

Parameters:
text - the text string used by this object.

afterInsert

protected void afterInsert(Sheet sh)
When a textbox is added to a sheet we need to tell upper-level PPDrawing about it.

Overrides:
afterInsert in class Shape
Parameters:
sh - the sheet we are adding to

getEscherTextboxWrapper

protected EscherTextboxWrapper getEscherTextboxWrapper()

resizeToFitText

public java.awt.geom.Rectangle2D resizeToFitText()
Adjust the size of the TextShape so it encompasses the text inside it.

Returns:
a Rectangle2D that is the bounds of this TextShape.

getVerticalAlignment

public int getVerticalAlignment()
Returns the type of vertical alignment for the text. One of the Anchor* constants defined in this class.

Returns:
the type of alignment

setVerticalAlignment

public void setVerticalAlignment(int align)
Sets the type of vertical alignment for the text. One of the Anchor* constants defined in this class.

Parameters:
align - - the type of alignment

setHorizontalAlignment

public void setHorizontalAlignment(int align)
Sets the type of horizontal alignment for the text. One of the Align* constants defined in this class.

Parameters:
align - - the type of horizontal alignment

getHorizontalAlignment

public int getHorizontalAlignment()
Gets the type of horizontal alignment for the text. One of the Align* constants defined in this class.

Returns:
align - the type of horizontal alignment

getMarginBottom

public float getMarginBottom()
Returns the distance (in points) between the bottom of the text frame and the bottom of the inscribed rectangle of the shape that contains the text. Default value is 1/20 inch.

Returns:
the botom margin

setMarginBottom

public void setMarginBottom(float margin)
Sets the botom margin.

Parameters:
margin - the bottom margin
See Also:
getMarginBottom()

getMarginLeft

public float getMarginLeft()
Returns the distance (in points) between the left edge of the text frame and the left edge of the inscribed rectangle of the shape that contains the text. Default value is 1/10 inch.

Returns:
the left margin

setMarginLeft

public void setMarginLeft(float margin)
Sets the left margin.

Parameters:
margin - the left margin
See Also:
getMarginLeft()

getMarginRight

public float getMarginRight()
Returns the distance (in points) between the right edge of the text frame and the right edge of the inscribed rectangle of the shape that contains the text. Default value is 1/10 inch.

Returns:
the right margin

setMarginRight

public void setMarginRight(float margin)
Sets the right margin.

Parameters:
margin - the right margin
See Also:
getMarginRight()

getMarginTop

public float getMarginTop()
Returns the distance (in points) between the top of the text frame and the top of the inscribed rectangle of the shape that contains the text. Default value is 1/20 inch.

Returns:
the top margin

setMarginTop

public void setMarginTop(float margin)
Sets the top margin.

Parameters:
margin - the top margin
See Also:
getMarginTop()

getWordWrap

public int getWordWrap()
Returns the value indicating word wrap.

Returns:
the value indicating word wrap. Must be one of the Wrap* constants defined in this class.

setWordWrap

public void setWordWrap(int wrap)
Specifies how the text should be wrapped

Parameters:
wrap - the value indicating how the text should be wrapped. Must be one of the Wrap* constants defined in this class.

getTextId

public int getTextId()
Returns:
id for the text.

setTextId

public void setTextId(int id)
Sets text ID

Parameters:
id - of the text

getTextRun

public TextRun getTextRun()
Returns:
the TextRun object for this text box

setSheet

public void setSheet(Sheet sheet)
Description copied from class: Shape
Assign the SlideShow this shape belongs to

Overrides:
setSheet in class Shape
Parameters:
sheet - owner of this shape

initTextRun

protected void initTextRun()

draw

public void draw(java.awt.Graphics2D graphics)
Overrides:
draw in class SimpleShape

getPlaceholderAtom

public OEPlaceholderAtom getPlaceholderAtom()
Return OEPlaceholderAtom, the atom that describes a placeholder.

Returns:
OEPlaceholderAtom or null if not found

setHyperlink

public void setHyperlink(int linkId,
                         int beginIndex,
                         int endIndex)
Assigns a hyperlink to this text shape

Parameters:
linkId - id of the hyperlink, @see org.apache.poi.hslf.usermodel.SlideShow#addHyperlink(Hyperlink)
beginIndex - the beginning index, inclusive.
endIndex - the ending index, exclusive.
See Also:
SlideShow.addHyperlink(Hyperlink)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TitleMaster

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model
Class TitleMaster

java.lang.Object
    extended by  org.apache.poi.hslf.model.Sheet
        extended by  org.apache.poi.hslf.model.MasterSheet
            extended by  org.apache.poi.hslf.model.TitleMaster

public final class TitleMaster
extends MasterSheet

Title masters define the design template for slides with a Title Slide layout.

Author:
Yegor Kozlov

Constructor Summary
TitleMaster(Slide record, int sheetNo)
Constructs a TitleMaster
Method Summary
MasterSheet | getMasterSheet() Returns the slide master for this title master.
TextProp | getStyleAttribute(int txtype, int level, java.lang.String name, boolean isCharacter) Delegate the call to the underlying slide master.
TextRun[] | getTextRuns() Returns an array of all the TextRuns found
Methods inherited from class org.apache.poi.hslf.model.MasterSheet
isPlaceholder
Methods inherited from class org.apache.poi.hslf.model.Sheet
_getSheetNumber, _getSheetRefId, addShape, allocateShapeId, draw, findTextRuns, findTextRuns, getBackground, getColorScheme, getPlaceholder, getPlaceholderByTextType, getPPDrawing, getProgrammableTag, getShapes, getSheetContainer, getSlideShow, onAddTextShape, onCreate, removeShape, setSlideShow
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TitleMaster

public TitleMaster(Slide record,
                   int sheetNo)
Constructs a TitleMaster

Method Detail

getTextRuns

public TextRun[] getTextRuns()
Returns an array of all the TextRuns found

Specified by:
getTextRuns in class Sheet

getStyleAttribute

public TextProp getStyleAttribute(int txtype,
                                  int level,
                                  java.lang.String name,
                                  boolean isCharacter)
Delegate the call to the underlying slide master.

Specified by:
getStyleAttribute in class MasterSheet

getMasterSheet

public MasterSheet getMasterSheet()
Returns the slide master for this title master.

Specified by:
getMasterSheet in class Sheet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.model.ActiveXShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.ActiveXShape

No usage of org.apache.poi.hslf.model.ActiveXShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.AutoShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.AutoShape

Packages that use AutoShape
org.apache.poi.hslf.model

Uses of AutoShape in org.apache.poi.hslf.model

Subclasses of AutoShape in org.apache.poi.hslf.model
class | Freeform A "Freeform" shape.
class | Polygon A simple closed polygon shape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.AutoShapes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.AutoShapes

No usage of org.apache.poi.hslf.model.AutoShapes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Background

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Background

Packages that use Background
org.apache.poi.hslf.model

Uses of Background in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return Background
Background | Slide.getBackground() Background for this slide.
Background | Sheet.getBackground() Returns the background shape for this sheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Comment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Comment

Packages that use Comment
org.apache.poi.hslf.model

Uses of Comment in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return Comment
 Comment[] Slide.getComments()
Get the comment(s) for this slide.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Fill

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Fill

Packages that use Fill
org.apache.poi.hslf.model

Uses of Fill in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as Fill
protected  Fill Shape._fill
Fill

Methods in org.apache.poi.hslf.model that return Fill
 Fill Shape.getFill()
Fill properties of this shape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Freeform

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Freeform

No usage of org.apache.poi.hslf.model.Freeform

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.HeadersFooters

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.HeadersFooters

Packages that use HeadersFooters
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of HeadersFooters in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return HeadersFooters
 HeadersFooters Slide.getHeadersFooters()
Header / Footer settings for this slide.

Uses of HeadersFooters in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return HeadersFooters
HeadersFooters | SlideShow.getNotesHeadersFooters() Return Header / Footer settings for notes
HeadersFooters | SlideShow.getSlideHeadersFooters() Return Header / Footer settings for slides

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Hyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Hyperlink

Packages that use Hyperlink
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of Hyperlink in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return Hyperlink
protected static Hyperlink | Hyperlink.find(Shape shape) Find hyperlink assigned to the supplied shape
protected static Hyperlink[] | Hyperlink.find(TextRun run) Find hyperlinks in a text run
Hyperlink | ShapeGroup.getHyperlink() Returns null - shape groups can't have hyperlinks
Hyperlink | Shape.getHyperlink() Returns the hyperlink assigned to this shape
Hyperlink[] | TextRun.getHyperlinks() Returns the array of all hyperlinks in this text run

Methods in org.apache.poi.hslf.model with parameters of type Hyperlink
 void SimpleShape.setHyperlink(Hyperlink link)

Uses of Hyperlink in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel with parameters of type Hyperlink
 int SlideShow.addHyperlink(Hyperlink link)
Add a hyperlink to this presentation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Line

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Line

Packages that use Line
org.apache.poi.hslf.model

Uses of Line in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return Line
Line | Table.createBorder() Create a border to format this table
Line | TableCell.getBorderBottom()
Line | TableCell.getBorderLeft()
Line | TableCell.getBorderRight()
Line | TableCell.getBorderTop()

Methods in org.apache.poi.hslf.model with parameters of type Line
protected void | TableCell.anchorBorder(int type, Line line)
void | Table.setAllBorders(Line line) Format the table and apply the specified Line to all cell boundaries, both outside and inside
void | TableCell.setBorderBottom(Line line)
void | TableCell.setBorderLeft(Line line)
void | TableCell.setBorderRight(Line line)
void | TableCell.setBorderTop(Line line)
void | Table.setInsideBorders(Line line) Format the inside border using the specified Line object
void | Table.setOutsideBorders(Line line) Format the outside border using the specified Line object

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.MasterSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.MasterSheet

Packages that use MasterSheet
org.apache.poi.hslf.model

Uses of MasterSheet in org.apache.poi.hslf.model

Subclasses of MasterSheet in org.apache.poi.hslf.model
class | SlideMaster SlideMaster determines the graphics, layout, and formatting for all the slides in a given presentation.
class | TitleMaster Title masters define the design template for slides with a Title Slide layout.

Methods in org.apache.poi.hslf.model that return MasterSheet
MasterSheet | TitleMaster.getMasterSheet() Returns the slide master for this title master.
MasterSheet | SlideMaster.getMasterSheet() Returns null since SlideMasters doen't have master sheet.
MasterSheet | Slide.getMasterSheet() Returns master sheet associated with this slide.
abstract MasterSheet | Sheet.getMasterSheet() Return the master sheet .
MasterSheet | Notes.getMasterSheet() Return null - Notes Masters are not yet supported

Methods in org.apache.poi.hslf.model with parameters of type MasterSheet
 void Slide.setMasterSheet(MasterSheet master)
Change Master of this slide.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.MovieShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.MovieShape

No usage of org.apache.poi.hslf.model.MovieShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Notes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Notes

Packages that use Notes
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of Notes in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return Notes
 Notes Slide.getNotesSheet()
Returns the Notes Sheet for this slide, or null if there isn't one

Methods in org.apache.poi.hslf.model with parameters of type Notes
 void Slide.setNotes(Notes notes)
Sets the Notes that are associated with this.

Constructors in org.apache.poi.hslf.model with parameters of type Notes
Slide(Slide slide, Notes notes, SlideListWithText.SlideAtomsSet atomSet, int slideIdentifier, int slideNumber)
Constructs a Slide from the Slide record, and the SlideAtomsSet containing the text.

Uses of Notes in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return Notes
 Notes[] SlideShow.getNotes()
Returns an array of all the normal Notes found in the slideshow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.OLEShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.OLEShape

Packages that use OLEShape
org.apache.poi.hslf.extractor

Uses of OLEShape in org.apache.poi.hslf.extractor

Methods in org.apache.poi.hslf.extractor that return types with arguments of type OLEShape
 java.util.List<OLEShape> PowerPointExtractor.getOLEShapes()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Picture

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Picture

Packages that use Picture
org.apache.poi.hslf.blip
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of Picture in org.apache.poi.hslf.blip

Methods in org.apache.poi.hslf.blip with parameters of type Picture
void | ImagePainter.paint(java.awt.Graphics2D graphics, PictureData pict, Picture parent) Paints the specified picture data
void | BitmapPainter.paint(java.awt.Graphics2D graphics, PictureData pict, Picture parent)

Uses of Picture in org.apache.poi.hslf.model

Subclasses of Picture in org.apache.poi.hslf.model
class | ActiveXShape Represents an ActiveX control in a PowerPoint document.
class | MovieShape Represents a movie in a PowerPoint document.
class | OLEShape A shape representing embedded OLE obejct.

Uses of Picture in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel with parameters of type Picture
 void PictureData.draw(java.awt.Graphics2D graphics, Picture parent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Placeholder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Placeholder

No usage of org.apache.poi.hslf.model.Placeholder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Polygon

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Polygon

No usage of org.apache.poi.hslf.model.Polygon

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.PPFont

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.PPFont

Packages that use PPFont
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of PPFont in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as PPFont
static PPFont | PPFont.ARIAL
static PPFont | PPFont.COURIER_NEW
static PPFont | PPFont.TIMES_NEW_ROMAN
static PPFont | PPFont.WINGDINGS

Uses of PPFont in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return PPFont
 PPFont SlideShow.getFont(int idx)
Get a font by index

Methods in org.apache.poi.hslf.usermodel with parameters of type PPFont
 int SlideShow.addFont(PPFont font)
Add a font in this presentation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.PPGraphics2D

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.PPGraphics2D

No usage of org.apache.poi.hslf.model.PPGraphics2D

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Shape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Shape

Packages that use Shape
org.apache.poi.hslf.model

Uses of Shape in org.apache.poi.hslf.model

Subclasses of Shape in org.apache.poi.hslf.model
class | ActiveXShape Represents an ActiveX control in a PowerPoint document.
class | AutoShape Represents an AutoShape.
class | Background Background shape
class | Freeform A "Freeform" shape.
class | Line Represents a line in a PowerPoint drawing
class | MovieShape Represents a movie in a PowerPoint document.
class | OLEShape A shape representing embedded OLE obejct.
class | Picture Represents a picture in a PowerPoint document.
class | Placeholder Represents a Placeholder in PowerPoint.
class | Polygon A simple closed polygon shape
class | ShapeGroup Represents a group of shapes.
class | SimpleShape An abstract simple (non-group) shape.
class | Table Represents a table in a PowerPoint presentation
class | TableCell Represents a cell in a ppt table
class | TextBox Represents a TextFrame shape in PowerPoint.
class | TextShape A common superclass of all shapes that can hold text.

Fields in org.apache.poi.hslf.model declared as Shape
protected Shape | Shape._parent Parent of this shape.
protected Shape | Fill.shape The shape this background applies to

Methods in org.apache.poi.hslf.model that return Shape
static Shape | ShapeFactory.createShape(EscherContainerRecord spContainer, Shape parent) Create a new shape from the data provided.
static Shape | ShapeFactory.createSimpeShape(EscherContainerRecord spContainer, Shape parent)
Shape | Shape.getParent()
Shape[] | Sheet.getShapes() Returns all shapes contained in this Sheet
Shape[] | ShapeGroup.getShapes()

Methods in org.apache.poi.hslf.model with parameters of type Shape
void | Sheet.addShape(Shape shape) Add a new Shape to this Slide
void | ShapeGroup.addShape(Shape shape) Add a shape to this group.
static Shape | ShapeFactory.createShape(EscherContainerRecord spContainer, Shape parent) Create a new shape from the data provided.
static ShapeGroup | ShapeFactory.createShapeGroup(EscherContainerRecord spContainer, Shape parent)
static Shape | ShapeFactory.createSimpeShape(EscherContainerRecord spContainer, Shape parent)
protected static Hyperlink | Hyperlink.find(Shape shape) Find hyperlink assigned to the supplied shape
java.awt.Shape | ShapeOutline.getOutline(Shape shape)
static boolean | MasterSheet.isPlaceholder(Shape shape) Checks if the shape is a placeholder.
boolean | Sheet.removeShape(Shape shape) Removes the specified shape from this sheet.

Constructors in org.apache.poi.hslf.model with parameters of type Shape
ActiveXShape(EscherContainerRecord escherRecord, Shape parent)
Create a Picture object
AutoShape(EscherContainerRecord escherRecord, Shape parent)
AutoShape(int type, Shape parent)
Background(EscherContainerRecord escherRecord, Shape parent)
Fill(Shape shape)
Construct a Fill object for a shape.
Freeform(EscherContainerRecord escherRecord, Shape parent)
Create a Freeform object and initialize it from the supplied Record container.
Freeform(Shape parent)
Create a new Freeform.
Line(EscherContainerRecord escherRecord, Shape parent)
Line(Shape parent)
MovieShape(EscherContainerRecord escherRecord, Shape parent)
Create a Picture object
MovieShape(int movieIdx, int idx, Shape parent)
Create a new Picture
OLEShape(EscherContainerRecord escherRecord, Shape parent)
Create a OLEShape object
OLEShape(int idx, Shape parent)
Create a new OLEShape
Picture(EscherContainerRecord escherRecord, Shape parent)
Create a Picture object
Picture(int idx, Shape parent)
Create a new Picture
Placeholder(EscherContainerRecord escherRecord, Shape parent)
Placeholder(Shape parent)
Polygon(EscherContainerRecord escherRecord, Shape parent)
Create a Polygon object and initialize it from the supplied Record container.
Polygon(Shape parent)
Create a new Polygon.
Shape(EscherContainerRecord escherRecord, Shape parent)
Create a Shape object.
ShapeGroup(EscherContainerRecord escherRecord, Shape parent)
Create a ShapeGroup object and initilize it from the supplied Record container.
SimpleShape(EscherContainerRecord escherRecord, Shape parent)
Create a SimpleShape object and initialize it from the supplied Record container.
Table(EscherContainerRecord escherRecord, Shape parent)
Create a Table object and initilize it from the supplied Record container.
TableCell(EscherContainerRecord escherRecord, Shape parent)
Create a TableCell object and initialize it from the supplied Record container.
TableCell(Shape parent)
Create a new TableCell.
TextBox(EscherContainerRecord escherRecord, Shape parent)
Create a TextBox object and initialize it from the supplied Record container.
TextBox(Shape parent)
Create a new TextBox.
TextShape(EscherContainerRecord escherRecord, Shape parent)
Create a TextBox object and initialize it from the supplied Record container.
TextShape(Shape parent)
Create a new TextBox.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.ShapeFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.ShapeFactory

No usage of org.apache.poi.hslf.model.ShapeFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.ShapeGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.ShapeGroup

Packages that use ShapeGroup
org.apache.poi.hslf.model

Uses of ShapeGroup in org.apache.poi.hslf.model

Subclasses of ShapeGroup in org.apache.poi.hslf.model
 class Table
Represents a table in a PowerPoint presentation

Methods in org.apache.poi.hslf.model that return ShapeGroup
static ShapeGroup | ShapeFactory.createShapeGroup(EscherContainerRecord spContainer, Shape parent)
ShapeGroup | PPGraphics2D.getShapeGroup()

Constructors in org.apache.poi.hslf.model with parameters of type ShapeGroup
PPGraphics2D(ShapeGroup group)
Construct Java Graphics object which translates graphic calls in ppt drawing layer.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hslf.model.ShapeOutline

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hslf.model.ShapeOutline

Packages that use ShapeOutline
org.apache.poi.hslf.model

Uses of ShapeOutline in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as ShapeOutline
protected static ShapeOutline[] AutoShapes.shapes

Methods in org.apache.poi.hslf.model that return ShapeOutline
static ShapeOutline AutoShapes.getShapeOutline(int type)
Return shape outline by shape type

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.ShapePainter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.ShapePainter

No usage of org.apache.poi.hslf.model.ShapePainter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.ShapeTypes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.ShapeTypes

No usage of org.apache.poi.hslf.model.ShapeTypes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Sheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Sheet

Packages that use Sheet
org.apache.poi.hslf.model

Uses of Sheet in org.apache.poi.hslf.model

Subclasses of Sheet in org.apache.poi.hslf.model
class | MasterSheet The superclass of all master sheets - Slide masters, Notes masters, etc.
class | Notes This class represents a slide's notes in a PowerPoint Document.
class | Slide This class represents a slide in a PowerPoint Document.
class | SlideMaster SlideMaster determines the graphics, layout, and formatting for all the slides in a given presentation.
class | TitleMaster Title masters define the design template for slides with a Title Slide layout.

Fields in org.apache.poi.hslf.model declared as Sheet
protected  Sheet Shape._sheet
The Sheet this shape belongs to

Methods in org.apache.poi.hslf.model that return Sheet
Sheet | TextRun.getSheet()
Sheet | Shape.getSheet()

Methods in org.apache.poi.hslf.model with parameters of type Sheet
protected void | TextShape.afterInsert(Sheet sh) When a textbox is added to a sheet we need to tell upper-level PPDrawing about it.
protected void | Table.afterInsert(Sheet sh)
protected void | Shape.afterInsert(Sheet sh) Event which fires when a shape is inserted in the sheet.
protected void | Picture.afterInsert(Sheet sh) By default set the orininal image size
protected void | Fill.afterInsert(Sheet sh)
protected void | ActiveXShape.afterInsert(Sheet sheet)
void | TextShape.setSheet(Sheet sheet)
void | TextRun.setSheet(Sheet sheet)
void | Table.setSheet(Sheet sheet) Assign the SlideShow this shape belongs to
void | Shape.setSheet(Sheet sheet) Assign the SlideShow this shape belongs to

Constructors in org.apache.poi.hslf.model with parameters of type Sheet
HeadersFooters(HeadersFootersContainer rec, Sheet sheet, boolean newRecord, boolean isPpt2007)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.SimpleShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.SimpleShape

Packages that use SimpleShape
org.apache.poi.hslf.model

Uses of SimpleShape in org.apache.poi.hslf.model

Subclasses of SimpleShape in org.apache.poi.hslf.model
class | ActiveXShape Represents an ActiveX control in a PowerPoint document.
class | AutoShape Represents an AutoShape.
class | Freeform A "Freeform" shape.
class | Line Represents a line in a PowerPoint drawing
class | MovieShape Represents a movie in a PowerPoint document.
class | OLEShape A shape representing embedded OLE obejct.
class | Picture Represents a picture in a PowerPoint document.
class | Placeholder Represents a Placeholder in PowerPoint.
class | Polygon A simple closed polygon shape
class | TableCell Represents a cell in a ppt table
class | TextBox Represents a TextFrame shape in PowerPoint.
class | TextShape A common superclass of all shapes that can hold text.

Methods in org.apache.poi.hslf.model with parameters of type SimpleShape
protected void | PPGraphics2D.applyPaint(SimpleShape shape)
protected void | PPGraphics2D.applyStroke(SimpleShape shape)
static void | ShapePainter.paint(SimpleShape shape, java.awt.Graphics2D graphics)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Slide

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Slide

Packages that use Slide
org.apache.poi.hslf.usermodel

Uses of Slide in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return Slide
Slide | SlideShow.createSlide() Create a blank Slide.
Slide[] | SlideShow.getSlides() Returns an array of all the normal Slides found in the slideshow
Slide | SlideShow.removeSlide(int index) Removes the slide at the given index (0-based).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.SlideMaster

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.SlideMaster

Packages that use SlideMaster
org.apache.poi.hslf.usermodel

Uses of SlideMaster in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return SlideMaster
 SlideMaster[] SlideShow.getSlidesMasters()
Returns an array of all the normal Slide Masters found in the slideshow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.Table

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.Table

No usage of org.apache.poi.hslf.model.Table

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.TableCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.TableCell

Packages that use TableCell
org.apache.poi.hslf.model

Uses of TableCell in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as TableCell
protected  TableCell[][] Table.cells

Methods in org.apache.poi.hslf.model that return TableCell
 TableCell Table.getCell(int row, int col)
Gets a cell

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.TextBox

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.TextBox

Packages that use TextBox
org.apache.poi.hslf.model

Uses of TextBox in org.apache.poi.hslf.model

Subclasses of TextBox in org.apache.poi.hslf.model
class | Placeholder Represents a Placeholder in PowerPoint.
class | TableCell Represents a cell in a ppt table

Methods in org.apache.poi.hslf.model that return TextBox
 TextBox Slide.addTitle()
Create a TextBox object that represents the slide's title.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.TextPainter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.TextPainter

No usage of org.apache.poi.hslf.model.TextPainter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.TextPainter.TextElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.TextPainter.TextElement

Packages that use TextPainter.TextElement
org.apache.poi.hslf.model

Uses of TextPainter.TextElement in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return TextPainter.TextElement
 TextPainter.TextElement[] TextPainter.getTextElements(float textWidth, java.awt.font.FontRenderContext frc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.TextRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.TextRun

Packages that use TextRun
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of TextRun in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as TextRun
protected  TextRun TextShape._txtrun
TextRun object which holds actual text and format data

Methods in org.apache.poi.hslf.model that return TextRun
TextRun | TextShape.createTextRun()
static TextRun[] | Sheet.findTextRuns(PPDrawing ppdrawing) For a given PPDrawing, grab all the TextRuns
TextRun | TextShape.getTextRun()
TextRun[] | TitleMaster.getTextRuns() Returns an array of all the TextRuns found
TextRun[] | SlideMaster.getTextRuns() Returns an array of all the TextRuns found
TextRun[] | Slide.getTextRuns() Returns an array of all the TextRuns found
abstract TextRun[] | Sheet.getTextRuns() Returns an array of all the TextRuns in the sheet.
TextRun[] | Notes.getTextRuns() Returns an array of all the TextRuns found

Methods in org.apache.poi.hslf.model with parameters of type TextRun
protected static Hyperlink[] | Hyperlink.find(TextRun run) Find hyperlinks in a text run
java.text.AttributedString | TextPainter.getAttributedString(TextRun txrun) Convert the underlying set of rich text runs into java.text.AttributedString
protected void | TextShape.setDefaultTextProperties(TextRun _txtrun) Set default properties for the TextRun.
protected void | TextBox.setDefaultTextProperties(TextRun _txtrun)
protected void | AutoShape.setDefaultTextProperties(TextRun _txtrun)

Method parameters in org.apache.poi.hslf.model with type arguments of type TextRun
protected static void Sheet.findTextRuns(Record[] records, java.util.List<TextRun> found)
Scans through the supplied record array, looking for a TextHeaderAtom followed by one of a TextBytesAtom or a TextCharsAtom.

Uses of TextRun in org.apache.poi.hslf.usermodel

Constructors in org.apache.poi.hslf.usermodel with parameters of type TextRun
RichTextRun(TextRun parent, int startAt, int len)
Create a new wrapper around a (currently not) rich text string
RichTextRun(TextRun parent, int startAt, int len, TextPropCollection pStyle, TextPropCollection cStyle, boolean pShared, boolean cShared)
Create a new wrapper around a rich text string

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.TextShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.TextShape

Packages that use TextShape
org.apache.poi.hslf.model

Uses of TextShape in org.apache.poi.hslf.model

Subclasses of TextShape in org.apache.poi.hslf.model
class | AutoShape Represents an AutoShape.
class | Freeform A "Freeform" shape.
class | Placeholder Represents a Placeholder in PowerPoint.
class | Polygon A simple closed polygon shape
class | TableCell Represents a cell in a ppt table
class | TextBox Represents a TextFrame shape in PowerPoint.

Fields in org.apache.poi.hslf.model declared as TextShape
protected  TextShape TextPainter._shape

Methods in org.apache.poi.hslf.model that return TextShape
TextShape | Sheet.getPlaceholder(int type) Search text placeholer by its type
TextShape | Sheet.getPlaceholderByTextType(int type) Return placeholder by text type

Methods in org.apache.poi.hslf.model with parameters of type TextShape
protected void | SlideMaster.onAddTextShape(TextShape shape)
protected void | Slide.onAddTextShape(TextShape shape)
protected void | Sheet.onAddTextShape(TextShape shape) Subclasses should call this method and update the array of text runs when a text shape is added

Constructors in org.apache.poi.hslf.model with parameters of type TextShape
TextPainter(TextShape shape)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.TitleMaster

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.TitleMaster

Packages that use TitleMaster
org.apache.poi.hslf.usermodel

Uses of TitleMaster in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return TitleMaster
 TitleMaster[] SlideShow.getTitleMasters()
Returns an array of all the normal Title Masters found in the slideshow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AlignmentTextProp

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model.textproperties
Class AlignmentTextProp

java.lang.Object
    extended by  org.apache.poi.hslf.model.textproperties.TextProp
        extended by  org.apache.poi.hslf.model.textproperties.AlignmentTextProp
All Implemented Interfaces:
java.lang.Cloneable
public class AlignmentTextProp
extends TextProp

Definition for the alignment text property.

Field Summary
static int | CENTER
static int | JUSTIFY
static int | JUSTIFYLOW
static int | LEFT
static int | RIGHT
static int | THAIDISTRIBUTED
Fields inherited from class org.apache.poi.hslf.model.textproperties.TextProp
dataValue, maskInHeader, propName, sizeOfDataBlock
Constructor Summary
AlignmentTextProp()
Method Summary
Methods inherited from class org.apache.poi.hslf.model.textproperties.TextProp
clone, getMask, getName, getSize, getValue, getWriteMask, setValue
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LEFT

public static final int LEFT
See Also:
Constant Field Values

CENTER

public static final int CENTER
See Also:
Constant Field Values

RIGHT

public static final int RIGHT
See Also:
Constant Field Values

JUSTIFY

public static final int JUSTIFY
See Also:
Constant Field Values

THAIDISTRIBUTED

public static final int THAIDISTRIBUTED
See Also:
Constant Field Values

JUSTIFYLOW

public static final int JUSTIFYLOW
See Also:
Constant Field Values
Constructor Detail

AlignmentTextProp

public AlignmentTextProp()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BitMaskTextProp

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model.textproperties
Class BitMaskTextProp

java.lang.Object
    extended by  org.apache.poi.hslf.model.textproperties.TextProp
        extended by  org.apache.poi.hslf.model.textproperties.BitMaskTextProp
All Implemented Interfaces:
java.lang.Cloneable
Direct Known Subclasses:
CharFlagsTextProp, ParagraphFlagsTextProp
public class BitMaskTextProp
extends TextProp
implements java.lang.Cloneable

Definition of a special kind of property of some text, or its paragraph. For these properties, a flag in the "contains" header field tells you the data property family will exist. The value of the property is itself a mask, encoding several different (but related) properties

Field Summary
Fields inherited from class org.apache.poi.hslf.model.textproperties.TextProp
dataValue, maskInHeader, propName, sizeOfDataBlock
Constructor Summary
BitMaskTextProp(int sizeOfDataBlock, int maskInHeader, java.lang.String overallName, java.lang.String[] subPropNames)
Method Summary
java.lang.Object | clone() Clone, eg when you want to actually make use of one of these.
boolean[] | getSubPropMatches() Fetch the list of if the sub properties match or not
java.lang.String[] | getSubPropNames() Fetch the list of the names of the sub properties
boolean | getSubValue(int idx) Fetch the true/false status of the subproperty with the given index
int | getWriteMask() As we're purely mask based, just set flags for stuff that is set
void | setSubValue(boolean value, int idx) Set the true/false status of the subproperty with the given index
void | setValue(int val) Set the value of the text property, and recompute the sub properties based on it
Methods inherited from class org.apache.poi.hslf.model.textproperties.TextProp
getMask, getName, getSize, getValue
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BitMaskTextProp

public BitMaskTextProp(int sizeOfDataBlock,
                       int maskInHeader,
                       java.lang.String overallName,
                       java.lang.String[] subPropNames)
Method Detail

getSubPropNames

public java.lang.String[] getSubPropNames()
Fetch the list of the names of the sub properties

getSubPropMatches

public boolean[] getSubPropMatches()
Fetch the list of if the sub properties match or not

getWriteMask

public int getWriteMask()
As we're purely mask based, just set flags for stuff that is set

Overrides:
getWriteMask in class TextProp

setValue

public void setValue(int val)
Set the value of the text property, and recompute the sub properties based on it

Overrides:
setValue in class TextProp

getSubValue

public boolean getSubValue(int idx)
Fetch the true/false status of the subproperty with the given index

setSubValue

public void setSubValue(boolean value,
                        int idx)
Set the true/false status of the subproperty with the given index

clone

public java.lang.Object clone()
Description copied from class: TextProp
Clone, eg when you want to actually make use of one of these.

Overrides:
clone in class TextProp
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharFlagsTextProp

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model.textproperties
Class CharFlagsTextProp

java.lang.Object
    extended by  org.apache.poi.hslf.model.textproperties.TextProp
        extended by  org.apache.poi.hslf.model.textproperties.BitMaskTextProp
            extended by  org.apache.poi.hslf.model.textproperties.CharFlagsTextProp
All Implemented Interfaces:
java.lang.Cloneable
public class CharFlagsTextProp
extends BitMaskTextProp

Definition for the common character text property bitset, which handles bold/italic/underline etc.

Field Summary
static int | BOLD_IDX
static int | ENABLE_NUMBERING_1_IDX
static int | ENABLE_NUMBERING_2_IDX
static int | ITALIC_IDX
static java.lang.String | NAME
static int | RELIEF_IDX
static int | RESET_NUMBERING_IDX
static int | SHADOW_IDX
static int | STRIKETHROUGH_IDX
static int | UNDERLINE_IDX
Fields inherited from class org.apache.poi.hslf.model.textproperties.TextProp
dataValue, maskInHeader, propName, sizeOfDataBlock
Constructor Summary
CharFlagsTextProp()
Method Summary
Methods inherited from class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
clone, getSubPropMatches, getSubPropNames, getSubValue, getWriteMask, setSubValue, setValue
Methods inherited from class org.apache.poi.hslf.model.textproperties.TextProp
getMask, getName, getSize, getValue
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BOLD_IDX

public static final int BOLD_IDX
See Also:
Constant Field Values

ITALIC_IDX

public static final int ITALIC_IDX
See Also:
Constant Field Values

UNDERLINE_IDX

public static final int UNDERLINE_IDX
See Also:
Constant Field Values

SHADOW_IDX

public static final int SHADOW_IDX
See Also:
Constant Field Values

STRIKETHROUGH_IDX

public static final int STRIKETHROUGH_IDX
See Also:
Constant Field Values

RELIEF_IDX

public static final int RELIEF_IDX
See Also:
Constant Field Values

RESET_NUMBERING_IDX

public static final int RESET_NUMBERING_IDX
See Also:
Constant Field Values

ENABLE_NUMBERING_1_IDX

public static final int ENABLE_NUMBERING_1_IDX
See Also:
Constant Field Values

ENABLE_NUMBERING_2_IDX

public static final int ENABLE_NUMBERING_2_IDX
See Also:
Constant Field Values

NAME

public static java.lang.String NAME
Constructor Detail

CharFlagsTextProp

public CharFlagsTextProp()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.model.textproperties
Classes
AlignmentTextProp
BitMaskTextProp
CharFlagsTextProp
ParagraphFlagsTextProp
TextProp
TextPropCollection


org.apache.poi.hslf.model.textproperties

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.model.textproperties

Class Summary
AlignmentTextProp | Definition for the alignment text property.
BitMaskTextProp | Definition of a special kind of property of some text, or its paragraph.
CharFlagsTextProp | Definition for the common character text property bitset, which handles bold/italic/underline etc.
ParagraphFlagsTextProp | Definition for the common paragraph text property bitset.
TextProp | Definition of a property of some text, or its paragraph.
TextPropCollection | For a given run of characters, holds the properties (which could be paragraph properties or character properties).


org.apache.poi.hslf.model.textproperties Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.model.textproperties

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.model.textproperties.TextProp (implements java.lang.Cloneable)
      • org.apache.poi.hslf.model.textproperties.AlignmentTextProp
      • org.apache.poi.hslf.model.textproperties.BitMaskTextProp (implements java.lang.Cloneable)
        • org.apache.poi.hslf.model.textproperties.CharFlagsTextProp
        • org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp
    • org.apache.poi.hslf.model.textproperties.TextPropCollection


Uses of Package org.apache.poi.hslf.model.textproperties

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.model.textproperties

Packages that use org.apache.poi.hslf.model.textproperties
org.apache.poi.hslf.dev
org.apache.poi.hslf.model
org.apache.poi.hslf.model.textproperties
org.apache.poi.hslf.record
org.apache.poi.hslf.usermodel

Classes in org.apache.poi.hslf.model.textproperties used by org.apache.poi.hslf.dev
TextPropCollection
For a given run of characters, holds the properties (which could be paragraph properties or character properties).

Classes in org.apache.poi.hslf.model.textproperties used by org.apache.poi.hslf.model
TextProp
Definition of a property of some text, or its paragraph.

Classes in org.apache.poi.hslf.model.textproperties used by org.apache.poi.hslf.model.textproperties
BitMaskTextProp
Definition of a special kind of property of some text, or its paragraph.
TextProp
Definition of a property of some text, or its paragraph.

Classes in org.apache.poi.hslf.model.textproperties used by org.apache.poi.hslf.record
TextProp
Definition of a property of some text, or its paragraph.
TextPropCollection
For a given run of characters, holds the properties (which could be paragraph properties or character properties).

Classes in org.apache.poi.hslf.model.textproperties used by org.apache.poi.hslf.usermodel
TextPropCollection
For a given run of characters, holds the properties (which could be paragraph properties or character properties).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ParagraphFlagsTextProp

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model.textproperties
Class ParagraphFlagsTextProp

java.lang.Object
    extended by  org.apache.poi.hslf.model.textproperties.TextProp
        extended by  org.apache.poi.hslf.model.textproperties.BitMaskTextProp
            extended by  org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp
All Implemented Interfaces:
java.lang.Cloneable
public final class ParagraphFlagsTextProp
extends BitMaskTextProp

Definition for the common paragraph text property bitset.

Author:
Yegor Kozlov

Field Summary
static int | BULLET_HARDCOLOR_IDX
static int | BULLET_HARDFONT_IDX
static int | BULLET_HARDSIZE_IDX
static int | BULLET_IDX
static java.lang.String | NAME
Fields inherited from class org.apache.poi.hslf.model.textproperties.TextProp
dataValue, maskInHeader, propName, sizeOfDataBlock
Constructor Summary
ParagraphFlagsTextProp()
Method Summary
Methods inherited from class org.apache.poi.hslf.model.textproperties.BitMaskTextProp
clone, getSubPropMatches, getSubPropNames, getSubValue, getWriteMask, setSubValue, setValue
Methods inherited from class org.apache.poi.hslf.model.textproperties.TextProp
getMask, getName, getSize, getValue
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BULLET_IDX

public static final int BULLET_IDX
See Also:
Constant Field Values

BULLET_HARDFONT_IDX

public static final int BULLET_HARDFONT_IDX
See Also:
Constant Field Values

BULLET_HARDCOLOR_IDX

public static final int BULLET_HARDCOLOR_IDX
See Also:
Constant Field Values

BULLET_HARDSIZE_IDX

public static final int BULLET_HARDSIZE_IDX
See Also:
Constant Field Values

NAME

public static java.lang.String NAME
Constructor Detail

ParagraphFlagsTextProp

public ParagraphFlagsTextProp()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextProp

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model.textproperties
Class TextProp

java.lang.Object
    extended by  org.apache.poi.hslf.model.textproperties.TextProp
All Implemented Interfaces:
java.lang.Cloneable
Direct Known Subclasses:
AlignmentTextProp, BitMaskTextProp
public class TextProp
extends java.lang.Object
implements java.lang.Cloneable

Definition of a property of some text, or its paragraph. Defines how to find out if it's present (via the mask on the paragraph or character "contains" header field), how long the value of it is, and how to get and set the value. As the exact form of these (such as mask value, size of data block etc) is different for StyleTextProps and TxMasterTextProps, the definitions of the standard TextProps is stored in the different record classes

Field Summary
protected int | dataValue
protected int | maskInHeader
protected java.lang.String | propName
protected int | sizeOfDataBlock
Constructor Summary
TextProp(int sizeOfDataBlock, int maskInHeader, java.lang.String propName)
Generate the definition of a given type of text property.
Method Summary
java.lang.Object | clone() Clone, eg when you want to actually make use of one of these.
int | getMask() Mask in the paragraph or character "contains" header field that indicates that this text property is present.
java.lang.String | getName() Name of the text property
int | getSize() Size of the data section of the text property (2 or 4 bytes)
int | getValue() Fetch the value of the text property (meaning is specific to each different kind of text property)
int | getWriteMask() Get the mask that's used at write time.
void | setValue(int val) Set the value of the text property.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

sizeOfDataBlock

protected int sizeOfDataBlock

propName

protected java.lang.String propName

dataValue

protected int dataValue

maskInHeader

protected int maskInHeader
Constructor Detail

TextProp

public TextProp(int sizeOfDataBlock,
                int maskInHeader,
                java.lang.String propName)
Generate the definition of a given type of text property.

Method Detail

getName

public java.lang.String getName()
Name of the text property

getSize

public int getSize()
Size of the data section of the text property (2 or 4 bytes)

getMask

public int getMask()
Mask in the paragraph or character "contains" header field that indicates that this text property is present.

getWriteMask

public int getWriteMask()
Get the mask that's used at write time. Only differs from the result of getMask() for the mask based properties

getValue

public int getValue()
Fetch the value of the text property (meaning is specific to each different kind of text property)

setValue

public void setValue(int val)
Set the value of the text property.

clone

public java.lang.Object clone()
Clone, eg when you want to actually make use of one of these.

Overrides:
clone in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextPropCollection

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.model.textproperties
Class TextPropCollection

java.lang.Object
    extended by  org.apache.poi.hslf.model.textproperties.TextPropCollection

public class TextPropCollection
extends java.lang.Object

For a given run of characters, holds the properties (which could be paragraph properties or character properties). Used to hold the number of characters affected, the list of active properties, and the random reserved field if required.

Constructor Summary
TextPropCollection(int textSize)
Create a new collection of text properties (be they paragraph or character) for a run of text without any
TextPropCollection(int charactersCovered, short reservedField)
Create a new collection of text properties (be they paragraph or character) which will be groked via a subsequent call to buildTextPropList().
Method Summary
TextProp | addWithName(java.lang.String name) Add the TextProp with this name to the list
int | buildTextPropList(int containsField, TextProp[] potentialProperties, byte[] data, int dataOffset) For an existing set of text properties, build the list of properties coded for in a given run of properties.
TextProp | findByName(java.lang.String textPropName) Fetch the TextProp with this name, or null if it isn't present
int | getCharactersCovered() Fetch the number of characters this styling applies to
short | getReservedField()
int | getSpecialMask()
java.util.LinkedList<TextProp> | getTextPropList() Fetch the TextProps that define this styling
void | setReservedField(short val)
void | updateTextSize(int textSize) Update the size of the text that this set of properties applies to
void | writeOut(java.io.OutputStream o) Writes out to disk the header, and then all the properties
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextPropCollection

public TextPropCollection(int charactersCovered,
                          short reservedField)
Create a new collection of text properties (be they paragraph or character) which will be groked via a subsequent call to buildTextPropList().

TextPropCollection

public TextPropCollection(int textSize)
Create a new collection of text properties (be they paragraph or character) for a run of text without any

Method Detail

getSpecialMask

public int getSpecialMask()

getCharactersCovered

public int getCharactersCovered()
Fetch the number of characters this styling applies to

getTextPropList

public java.util.LinkedList<TextProp> getTextPropList()
Fetch the TextProps that define this styling

findByName

public TextProp findByName(java.lang.String textPropName)
Fetch the TextProp with this name, or null if it isn't present

addWithName

public TextProp addWithName(java.lang.String name)
Add the TextProp with this name to the list

buildTextPropList

public int buildTextPropList(int containsField,
                             TextProp[] potentialProperties,
                             byte[] data,
                             int dataOffset)
For an existing set of text properties, build the list of properties coded for in a given run of properties.

Returns:
the number of bytes that were used encoding the properties list

updateTextSize

public void updateTextSize(int textSize)
Update the size of the text that this set of properties applies to

writeOut

public void writeOut(java.io.OutputStream o)
              throws java.io.IOException
Writes out to disk the header, and then all the properties

Throws:
java.io.IOException

getReservedField

public short getReservedField()

setReservedField

public void setReservedField(short val)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.model.textproperties.AlignmentTextProp

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.textproperties.AlignmentTextProp

No usage of org.apache.poi.hslf.model.textproperties.AlignmentTextProp

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.textproperties.BitMaskTextProp

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.textproperties.BitMaskTextProp

Packages that use BitMaskTextProp
org.apache.poi.hslf.model.textproperties

Uses of BitMaskTextProp in org.apache.poi.hslf.model.textproperties

Subclasses of BitMaskTextProp in org.apache.poi.hslf.model.textproperties
class | CharFlagsTextProp Definition for the common character text property bitset, which handles bold/italic/underline etc.
class | ParagraphFlagsTextProp Definition for the common paragraph text property bitset.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

No usage of org.apache.poi.hslf.model.textproperties.CharFlagsTextProp

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

No usage of org.apache.poi.hslf.model.textproperties.ParagraphFlagsTextProp

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.textproperties.TextProp

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.textproperties.TextProp

Packages that use TextProp
org.apache.poi.hslf.model
org.apache.poi.hslf.model.textproperties
org.apache.poi.hslf.record

Uses of TextProp in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return TextProp
TextProp | TitleMaster.getStyleAttribute(int txtype, int level, java.lang.String name, boolean isCharacter) Delegate the call to the underlying slide master.
TextProp | SlideMaster.getStyleAttribute(int txtype, int level, java.lang.String name, boolean isCharacter) Pickup a style attribute from the master.
abstract TextProp | MasterSheet.getStyleAttribute(int txtype, int level, java.lang.String name, boolean isCharacter) Pickup a style attribute from the master.

Uses of TextProp in org.apache.poi.hslf.model.textproperties

Subclasses of TextProp in org.apache.poi.hslf.model.textproperties
class | AlignmentTextProp Definition for the alignment text property.
class | BitMaskTextProp Definition of a special kind of property of some text, or its paragraph.
class | CharFlagsTextProp Definition for the common character text property bitset, which handles bold/italic/underline etc.
class | ParagraphFlagsTextProp Definition for the common paragraph text property bitset.

Methods in org.apache.poi.hslf.model.textproperties that return TextProp
TextProp | TextPropCollection.addWithName(java.lang.String name) Add the TextProp with this name to the list
TextProp | TextPropCollection.findByName(java.lang.String textPropName) Fetch the TextProp with this name, or null if it isn't present

Methods in org.apache.poi.hslf.model.textproperties that return types with arguments of type TextProp
 java.util.LinkedList<TextProp> TextPropCollection.getTextPropList()
Fetch the TextProps that define this styling

Methods in org.apache.poi.hslf.model.textproperties with parameters of type TextProp
 int TextPropCollection.buildTextPropList(int containsField, TextProp[] potentialProperties, byte[] data, int dataOffset)
For an existing set of text properties, build the list of properties coded for in a given run of properties.

Uses of TextProp in org.apache.poi.hslf.record

Fields in org.apache.poi.hslf.record declared as TextProp
static TextProp[] | StyleTextPropAtom.characterTextPropTypes All the different kinds of character properties we might handle
static TextProp[] | StyleTextPropAtom.paragraphTextPropTypes All the different kinds of paragraph properties we might handle

Methods in org.apache.poi.hslf.record that return TextProp
protected TextProp[] | TxMasterStyleAtom.getCharacterProps(int type, int level) Character properties for the specified text type and indent level.
protected TextProp[] | TxMasterStyleAtom.getParagraphProps(int type, int level) Paragraph properties for the specified text type and indent level Depending on the level and type, it may be our special ones, or the standard StyleTextPropAtom ones

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.model.textproperties.TextPropCollection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.model.textproperties.TextPropCollection

Packages that use TextPropCollection
org.apache.poi.hslf.dev
org.apache.poi.hslf.record
org.apache.poi.hslf.usermodel

Uses of TextPropCollection in org.apache.poi.hslf.dev

Methods in org.apache.poi.hslf.dev with parameters of type TextPropCollection
static void TextStyleListing.showTextProps(TextPropCollection tpc)

Uses of TextPropCollection in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return TextPropCollection
TextPropCollection | StyleTextPropAtom.addCharacterTextPropCollection(int charactersCovered) Create a new Character TextPropCollection, and add it to the list
TextPropCollection | StyleTextPropAtom.addParagraphTextPropCollection(int charactersCovered) Create a new Paragraph TextPropCollection, and add it to the list
TextPropCollection[] | TxMasterStyleAtom.getCharacterStyles() Returns array of character styles defined in this record.
TextPropCollection[] | TxMasterStyleAtom.getParagraphStyles() Returns array of paragraph styles defined in this record.

Methods in org.apache.poi.hslf.record that return types with arguments of type TextPropCollection
java.util.LinkedList<TextPropCollection> | StyleTextPropAtom.getCharacterStyles()
java.util.LinkedList<TextPropCollection> | StyleTextPropAtom.getParagraphStyles()

Method parameters in org.apache.poi.hslf.record with type arguments of type TextPropCollection
void | StyleTextPropAtom.setCharacterStyles(java.util.LinkedList<TextPropCollection> cs) Updates the link list of TextPropCollections which make up the character stylings
void | StyleTextPropAtom.setParagraphStyles(java.util.LinkedList<TextPropCollection> ps) Updates the link list of TextPropCollections which make up the paragraph stylings

Uses of TextPropCollection in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return TextPropCollection
TextPropCollection | RichTextRun._getRawCharacterStyle() Internal Use Only - get the underlying character style collection.
TextPropCollection | RichTextRun._getRawParagraphStyle() Internal Use Only - get the underlying paragraph style collection.

Methods in org.apache.poi.hslf.usermodel with parameters of type TextPropCollection
 void RichTextRun.supplyTextProps(TextPropCollection pStyle, TextPropCollection cStyle, boolean pShared, boolean cShared)
Supply (normally default) textprops, and if they're shared, when a run gets them

Constructors in org.apache.poi.hslf.usermodel with parameters of type TextPropCollection
RichTextRun(TextRun parent, int startAt, int len, TextPropCollection pStyle, TextPropCollection cStyle, boolean pShared, boolean cShared)
Create a new wrapper around a rich text string

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AnimationInfo

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class AnimationInfo

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.AnimationInfo

public final class AnimationInfo
extends RecordContainer

A container record that specifies information about animation information for a shape.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | AnimationInfo() Create a new AnimationInfo, with blank fields
protected | AnimationInfo(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
AnimationInfoAtom | getAnimationInfoAtom() Returns the AnimationInfo
long | getRecordType() We are of type 4103
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnimationInfo

protected AnimationInfo(byte[] source,
                        int start,
                        int len)
Set things up, and find our more interesting children

AnimationInfo

public AnimationInfo()
Create a new AnimationInfo, with blank fields

Method Detail

getRecordType

public long getRecordType()
We are of type 4103

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getAnimationInfoAtom

public AnimationInfoAtom getAnimationInfoAtom()
Returns the AnimationInfo

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AnimationInfoAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class AnimationInfoAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.AnimationInfoAtom

public final class AnimationInfoAtom
extends RecordAtom

An atom record that specifies the animation information for a shape.

Author:
Yegor Kozlov

Field Summary
static int | AnimateBg whether the background of the shape is animated
static int | Automatic whether the animation starts automatically
static int | Hide whether the shape is hidden while the animation is not playing
static int | Play whether an associated sound, media or action verb is activated when the shape is clicked.
static int | Reverse whether the animation plays in the reverse direction
static int | Sound whether the animation has an associated sound
static int | StopSound whether all playing sounds are stopped when this animation begins
static int | Synchronous specifies that the animation, while playing, stops other slide show actions.
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | AnimationInfoAtom() Constructs a brand new link related atom record.
protected | AnimationInfoAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
int | getDelayTime() A signed integer that specifies the delay time, in milliseconds, before the animation starts to play.
int | getDimColor() A rgb structure that specifies a color for the dim effect after the animation is complete.
boolean | getFlag(int bit)
int | getMask() A bit mask specifying options for displaying headers and footers
int | getOrderID() A signed integer that specifies the order of the animation in the slide.
long | getRecordType() Gets the record type.
int | getSlideCount() An unsigned integer that specifies the number of slides that this animation continues playing.
int | getSoundIdRef() A 4-byte unsigned integer that specifies a reference to a sound in the SoundCollectionContainer record to locate the embedded audio
void | setDelayTime(int id) A signed integer that specifies the delay time, in milliseconds, before the animation starts to play.
void | setDimColor(int rgb) A rgb structure that specifies a color for the dim effect after the animation is complete.
void | setFlag(int bit, boolean value)
void | setMask(int mask) A bit mask specifying options for displaying video
void | setOrderID(int id) A signed integer that specifies the order of the animation in the slide.
void | setSlideCount(int id) An unsigned integer that specifies the number of slides that this animation continues playing.
void | setSoundIdRef(int id) A 4-byte unsigned integer that specifies a reference to a sound in the SoundCollectionContainer record to locate the embedded audio
java.lang.String | toString()
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

Reverse

public static final int Reverse
whether the animation plays in the reverse direction

See Also:
Constant Field Values

Automatic

public static final int Automatic
whether the animation starts automatically

See Also:
Constant Field Values

Sound

public static final int Sound
whether the animation has an associated sound

See Also:
Constant Field Values

StopSound

public static final int StopSound
whether all playing sounds are stopped when this animation begins

See Also:
Constant Field Values

Play

public static final int Play
whether an associated sound, media or action verb is activated when the shape is clicked.

See Also:
Constant Field Values

Synchronous

public static final int Synchronous
specifies that the animation, while playing, stops other slide show actions.

See Also:
Constant Field Values

Hide

public static final int Hide
whether the shape is hidden while the animation is not playing

See Also:
Constant Field Values

AnimateBg

public static final int AnimateBg
whether the background of the shape is animated

See Also:
Constant Field Values
Constructor Detail

AnimationInfoAtom

protected AnimationInfoAtom()
Constructs a brand new link related atom record.

AnimationInfoAtom

protected AnimationInfoAtom(byte[] source,
                            int start,
                            int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.

getDimColor

public int getDimColor()
A rgb structure that specifies a color for the dim effect after the animation is complete.

Returns:
color for the dim effect after the animation is complete

setDimColor

public void setDimColor(int rgb)
A rgb structure that specifies a color for the dim effect after the animation is complete.

Parameters:
rgb - color for the dim effect after the animation is complete

getMask

public int getMask()
A bit mask specifying options for displaying headers and footers

Returns:
A bit mask specifying options for displaying headers and footers

setMask

public void setMask(int mask)
A bit mask specifying options for displaying video

Parameters:
mask - A bit mask specifying options for displaying video

getFlag

public boolean getFlag(int bit)
Parameters:
bit - the bit to check
Returns:
whether the specified flag is set

setFlag

public void setFlag(int bit,
                    boolean value)
Parameters:
bit - the bit to set
value - whether the specified bit is set

getSoundIdRef

public int getSoundIdRef()
A 4-byte unsigned integer that specifies a reference to a sound in the SoundCollectionContainer record to locate the embedded audio

Returns:
reference to a sound

setSoundIdRef

public void setSoundIdRef(int id)
A 4-byte unsigned integer that specifies a reference to a sound in the SoundCollectionContainer record to locate the embedded audio

Parameters:
id - reference to a sound

getDelayTime

public int getDelayTime()
A signed integer that specifies the delay time, in milliseconds, before the animation starts to play. If Automatic is 0x1, this value MUST be greater than or equal to 0; otherwise, this field MUST be ignored.

setDelayTime

public void setDelayTime(int id)
A signed integer that specifies the delay time, in milliseconds, before the animation starts to play. If Automatic is 0x1, this value MUST be greater than or equal to 0; otherwise, this field MUST be ignored.

getOrderID

public int getOrderID()
A signed integer that specifies the order of the animation in the slide. It MUST be greater than or equal to -2. The value -2 specifies that this animation follows the order of the corresponding placeholder shape on the main master slide or title master slide. The value -1 SHOULD NOT <105> be used.

setOrderID

public void setOrderID(int id)
A signed integer that specifies the order of the animation in the slide. It MUST be greater than or equal to -2. The value -2 specifies that this animation follows the order of the corresponding placeholder shape on the main master slide or title master slide. The value -1 SHOULD NOT <105> be used.

getSlideCount

public int getSlideCount()
An unsigned integer that specifies the number of slides that this animation continues playing. This field is utilized only in conjunction with media. The value 0xFFFFFFFF specifies that the animation plays for one slide.

setSlideCount

public void setSlideCount(int id)
An unsigned integer that specifies the number of slides that this animation continues playing. This field is utilized only in conjunction with media. The value 0xFFFFFFFF specifies that the animation plays for one slide.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ColorSchemeAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ColorSchemeAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ColorSchemeAtom

public final class ColorSchemeAtom
extends RecordAtom

A ColorSchemeAtom (type 2032). Holds the 8 RGB values for the different colours of bits of text, that makes up a given colour scheme. Slides (presumably) link to a given colour scheme atom, and that defines the colours to be used

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ColorSchemeAtom() Create a new ColorSchemeAtom, to go with a new Slide
protected | ColorSchemeAtom(byte[] source, int start, int len) For the Colour Scheme (ColorSchem) Atom
Method Summary
int | getAccentAndFollowingHyperlinkColourRGB() Fetch the RGB value for Accent And Following Hyperlink Colour
int | getAccentAndHyperlinkColourRGB() Fetch the RGB value for Accent And Hyperlink Colour
int | getAccentColourRGB() Fetch the RGB value for Accent Colour
int | getBackgroundColourRGB() Fetch the RGB value for Background Colour
int | getColor(int idx) Returns color by its index
int | getFillsColourRGB() Fetch the RGB value for Fills Colour
long | getRecordType() We are of type 3999
int | getShadowsColourRGB() Fetch the RGB value for Shadows Colour
int | getTextAndLinesColourRGB() Fetch the RGB value for Text And Lines Colour
int | getTitleTextColourRGB() Fetch the RGB value for Title Text Colour
static int | joinRGB(byte[] rgb) Convert from split R, G, B values to an integer RGB value
static int | joinRGB(byte r, byte g, byte b) Convert from split R, G, B values to an integer RGB value
void | setAccentAndFollowingHyperlinkColourRGB(int rgb) Set the RGB value for Accent And Following Hyperlink Colour
void | setAccentAndHyperlinkColourRGB(int rgb) Set the RGB value for Accent And Hyperlink Colour
void | setAccentColourRGB(int rgb) Set the RGB value for Accent Colour
void | setBackgroundColourRGB(int rgb) Set the RGB value for Background Colour
void | setFillsColourRGB(int rgb) Set the RGB value for Fills Colour
void | setShadowsColourRGB(int rgb) Set the RGB value for Shadows Colour
void | setTextAndLinesColourRGB(int rgb) Set the RGB value for Text And Lines Colour
void | setTitleTextColourRGB(int rgb) Set the RGB value for Title Text Colour
static byte[] | splitRGB(int rgb) Convert from an integer RGB value to individual R, G, B 0-255 values
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ColorSchemeAtom

protected ColorSchemeAtom(byte[] source,
                          int start,
                          int len)
For the Colour Scheme (ColorSchem) Atom

ColorSchemeAtom

public ColorSchemeAtom()
Create a new ColorSchemeAtom, to go with a new Slide

Method Detail

getBackgroundColourRGB

public int getBackgroundColourRGB()
Fetch the RGB value for Background Colour

setBackgroundColourRGB

public void setBackgroundColourRGB(int rgb)
Set the RGB value for Background Colour

getTextAndLinesColourRGB

public int getTextAndLinesColourRGB()
Fetch the RGB value for Text And Lines Colour

setTextAndLinesColourRGB

public void setTextAndLinesColourRGB(int rgb)
Set the RGB value for Text And Lines Colour

getShadowsColourRGB

public int getShadowsColourRGB()
Fetch the RGB value for Shadows Colour

setShadowsColourRGB

public void setShadowsColourRGB(int rgb)
Set the RGB value for Shadows Colour

getTitleTextColourRGB

public int getTitleTextColourRGB()
Fetch the RGB value for Title Text Colour

setTitleTextColourRGB

public void setTitleTextColourRGB(int rgb)
Set the RGB value for Title Text Colour

getFillsColourRGB

public int getFillsColourRGB()
Fetch the RGB value for Fills Colour

setFillsColourRGB

public void setFillsColourRGB(int rgb)
Set the RGB value for Fills Colour

getAccentColourRGB

public int getAccentColourRGB()
Fetch the RGB value for Accent Colour

setAccentColourRGB

public void setAccentColourRGB(int rgb)
Set the RGB value for Accent Colour

getAccentAndHyperlinkColourRGB

public int getAccentAndHyperlinkColourRGB()
Fetch the RGB value for Accent And Hyperlink Colour

setAccentAndHyperlinkColourRGB

public void setAccentAndHyperlinkColourRGB(int rgb)
Set the RGB value for Accent And Hyperlink Colour

getAccentAndFollowingHyperlinkColourRGB

public int getAccentAndFollowingHyperlinkColourRGB()
Fetch the RGB value for Accent And Following Hyperlink Colour

setAccentAndFollowingHyperlinkColourRGB

public void setAccentAndFollowingHyperlinkColourRGB(int rgb)
Set the RGB value for Accent And Following Hyperlink Colour

getRecordType

public long getRecordType()
We are of type 3999

Specified by:
getRecordType in class Record

splitRGB

public static byte[] splitRGB(int rgb)
Convert from an integer RGB value to individual R, G, B 0-255 values

joinRGB

public static int joinRGB(byte r,
                          byte g,
                          byte b)
Convert from split R, G, B values to an integer RGB value

joinRGB

public static int joinRGB(byte[] rgb)
Convert from split R, G, B values to an integer RGB value

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getColor

public int getColor(int idx)
Returns color by its index

Parameters:
idx - 0-based color index
Returns:
color by its index
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Comment2000

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Comment2000

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.Comment2000

public final class Comment2000
extends RecordContainer

This class represents a comment on a slide, in the format used by PPT 2000/XP/etc. (PPT 97 uses plain Escher Text Boxes for comments)

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | Comment2000() Create a new Comment2000, with blank fields
protected | Comment2000(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
java.lang.String | getAuthor() Get the Author of this comment
java.lang.String | getAuthorInitials() Get the Author's Initials of this comment
Comment2000Atom | getComment2000Atom() Returns the Comment2000Atom of this Comment
long | getRecordType() We are of type 1200
java.lang.String | getText() Get the text of this comment
void | setAuthor(java.lang.String author) Set the Author of this comment
void | setAuthorInitials(java.lang.String initials) Set the Author's Initials of this comment
void | setText(java.lang.String text) Set the text of this comment
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Comment2000

protected Comment2000(byte[] source,
                      int start,
                      int len)
Set things up, and find our more interesting children

Comment2000

public Comment2000()
Create a new Comment2000, with blank fields

Method Detail

getComment2000Atom

public Comment2000Atom getComment2000Atom()
Returns the Comment2000Atom of this Comment

getAuthor

public java.lang.String getAuthor()
Get the Author of this comment

setAuthor

public void setAuthor(java.lang.String author)
Set the Author of this comment

getAuthorInitials

public java.lang.String getAuthorInitials()
Get the Author's Initials of this comment

setAuthorInitials

public void setAuthorInitials(java.lang.String initials)
Set the Author's Initials of this comment

getText

public java.lang.String getText()
Get the text of this comment

setText

public void setText(java.lang.String text)
Set the text of this comment

getRecordType

public long getRecordType()
We are of type 1200

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Comment2000Atom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Comment2000Atom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.Comment2000Atom

public final class Comment2000Atom
extends RecordAtom

An atomic record containing information about a comment.

Author:
Daniel Noll

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | Comment2000Atom() Constructs a brand new comment atom record.
protected | Comment2000Atom(byte[] source, int start, int len) Constructs the comment atom record from its source data.
Method Summary
java.util.Date | getDate() Gets the date the comment was made.
int | getNumber() Gets the comment number (note - each user normally has their own count).
long | getRecordType() Gets the record type.
int | getXOffset() Gets the X offset of the comment on the page.
int | getYOffset() Gets the Y offset of the comment on the page.
void | setDate(java.util.Date date) Sets the date the comment was made.
void | setNumber(int number) Sets the comment number (note - each user normally has their own count).
void | setXOffset(int xOffset) Sets the X offset of the comment on the page.
void | setYOffset(int yOffset) Sets the Y offset of the comment on the page.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Comment2000Atom

protected Comment2000Atom()
Constructs a brand new comment atom record.

Comment2000Atom

protected Comment2000Atom(byte[] source,
                          int start,
                          int len)
Constructs the comment atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getNumber

public int getNumber()
Gets the comment number (note - each user normally has their own count).

Returns:
the comment number.

setNumber

public void setNumber(int number)
Sets the comment number (note - each user normally has their own count).

Parameters:
number - the comment number.

getDate

public java.util.Date getDate()
Gets the date the comment was made.

Returns:
the comment date.

setDate

public void setDate(java.util.Date date)
Sets the date the comment was made.

Parameters:
date - the comment date.

getXOffset

public int getXOffset()
Gets the X offset of the comment on the page.

Returns:
the X offset.

setXOffset

public void setXOffset(int xOffset)
Sets the X offset of the comment on the page.

Parameters:
xOffset - the X offset.

getYOffset

public int getYOffset()
Gets the Y offset of the comment on the page.

Returns:
the Y offset.

setYOffset

public void setYOffset(int yOffset)
Sets the Y offset of the comment on the page.

Parameters:
yOffset - the Y offset.

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class CString

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.CString

public final class CString
extends RecordAtom

A CString (type 4026). Holds a unicode string, and the first two bytes of the record header normally encode the count. Typically attached to some complex sequence of records, eg Commetns.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | CString() Create an empty CString
protected | CString(byte[] source, int start, int len) For the CStrubg Atom
Method Summary
int | getOptions() Grabs the count, from the first two bytes of the header.
long | getRecordType() We are of type 4026
java.lang.String | getText() Grabs the text.
void | setOptions(int count) Sets the count The meaning of the count is specific to the type of the parent record
void | setText(java.lang.String text) Updates the text in the Atom.
java.lang.String | toString() Gets a string representation of this object, primarily for debugging.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CString

protected CString(byte[] source,
                  int start,
                  int len)
For the CStrubg Atom

CString

public CString()
Create an empty CString

Method Detail

getText

public java.lang.String getText()
Grabs the text. Never null

setText

public void setText(java.lang.String text)
Updates the text in the Atom.

getOptions

public int getOptions()
Grabs the count, from the first two bytes of the header. The meaning of the count is specific to the type of the parent record

setOptions

public void setOptions(int count)
Sets the count The meaning of the count is specific to the type of the parent record

getRecordType

public long getRecordType()
We are of type 4026

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

toString

public java.lang.String toString()
Gets a string representation of this object, primarily for debugging.

Overrides:
toString in class java.lang.Object
Returns:
a string representation of this object.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrentUserAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class CurrentUserAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.CurrentUserAtom

public class CurrentUserAtom
extends java.lang.Object

This is a special kind of Atom, becauase it doesn't live inside the PowerPoint document. Instead, it lives in a seperate stream in the document. As such, it has to be treaded specially

Author:
Nick Burch

Field Summary
static byte[] | atomHeader Standard Atom header
static byte[] | encHeaderToken The PowerPoint magic number for an encrytpted file
static byte[] | headerToken The PowerPoint magic number for a non-encrypted file
static byte[] | ppt97FileVer The Powerpoint 97 version, major and minor numbers
Constructor Summary
CurrentUserAtom()
Create a new Current User Atom
CurrentUserAtom(byte[] b)
Create things from the bytes
CurrentUserAtom(DirectoryNode dir)
Find the Current User in the filesystem, and create from that
CurrentUserAtom(POIFSFileSystem fs)
Find the Current User in the filesystem, and create from that
Method Summary
long | getCurrentEditOffset() Points to the UserEditAtom
int | getDocFinalVersion()
byte | getDocMajorNo()
byte | getDocMinorNo()
java.lang.String | getLastEditUsername()
long | getReleaseVersion()
void | setCurrentEditOffset(long id)
void | setLastEditUsername(java.lang.String u)
void | setReleaseVersion(long rv)
void | writeOut(java.io.OutputStream out) Writes ourselves back out
void | writeToFS(POIFSFileSystem fs) Writes ourselves back out to a filesystem
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

atomHeader

public static final byte[] atomHeader
Standard Atom header

headerToken

public static final byte[] headerToken
The PowerPoint magic number for a non-encrypted file

encHeaderToken

public static final byte[] encHeaderToken
The PowerPoint magic number for an encrytpted file

ppt97FileVer

public static final byte[] ppt97FileVer
The Powerpoint 97 version, major and minor numbers

Constructor Detail

CurrentUserAtom

public CurrentUserAtom()
Create a new Current User Atom

CurrentUserAtom

public CurrentUserAtom(POIFSFileSystem fs)
                throws java.io.IOException
Find the Current User in the filesystem, and create from that

Throws:
java.io.IOException

CurrentUserAtom

public CurrentUserAtom(DirectoryNode dir)
                throws java.io.IOException
Find the Current User in the filesystem, and create from that

Throws:
java.io.IOException

CurrentUserAtom

public CurrentUserAtom(byte[] b)
Create things from the bytes

Method Detail

getDocFinalVersion

public int getDocFinalVersion()

getDocMajorNo

public byte getDocMajorNo()

getDocMinorNo

public byte getDocMinorNo()

getReleaseVersion

public long getReleaseVersion()

setReleaseVersion

public void setReleaseVersion(long rv)

getCurrentEditOffset

public long getCurrentEditOffset()
Points to the UserEditAtom

setCurrentEditOffset

public void setCurrentEditOffset(long id)

getLastEditUsername

public java.lang.String getLastEditUsername()

setLastEditUsername

public void setLastEditUsername(java.lang.String u)

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Writes ourselves back out

Throws:
java.io.IOException

writeToFS

public void writeToFS(POIFSFileSystem fs)
               throws java.io.IOException
Writes ourselves back out to a filesystem

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Document

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Document

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
                extended by  org.apache.poi.hslf.record.Document
All Implemented Interfaces:
PositionDependentRecord
public final class Document
extends PositionDependentRecordContainer

Master container for Document. There is one of these for every slideshow, and it holds lots of definitions, and some summaries.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected Document(byte[] source, int start, int len)
Set things up, and find our more interesting children
Method Summary
void | addSlideListWithText(SlideListWithText slwt) Adds a new SlideListWithText record, at the appropriate point in the child records.
DocumentAtom | getDocumentAtom() Returns the DocumentAtom of this Document
Environment | getEnvironment() Returns the Environment of this Notes, which lots of settings for the document in it
ExObjList | getExObjList() Returns the ExObjList, which holds the references to external objects used in the slides.
SlideListWithText | getMasterSlideListWithText() Returns the SlideListWithText that deals with the Master Slides
SlideListWithText | getNotesSlideListWithText() Returns the SlideListWithText that deals with the notes, or null if there isn't one
PPDrawingGroup | getPPDrawingGroup() Returns the PPDrawingGroup, which holds an Escher Structure that contains information on pictures in the slides.
long | getRecordType() We are of type 1000
SlideListWithText[] | getSlideListWithTexts() Returns all the SlideListWithTexts that are defined for this Document.
SlideListWithText | getSlideSlideListWithText() Returns the SlideListWithText that deals with the Slides, or null if there isn't one
void | removeSlideListWithText(SlideListWithText slwt)
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
getLastOnDiskOffset, getSheetId, setLastOnDiskOffset, setSheetId, updateOtherRecordReferences
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Document

protected Document(byte[] source,
                   int start,
                   int len)
Set things up, and find our more interesting children

Method Detail

getDocumentAtom

public DocumentAtom getDocumentAtom()
Returns the DocumentAtom of this Document

getEnvironment

public Environment getEnvironment()
Returns the Environment of this Notes, which lots of settings for the document in it

getPPDrawingGroup

public PPDrawingGroup getPPDrawingGroup()
Returns the PPDrawingGroup, which holds an Escher Structure that contains information on pictures in the slides.

getExObjList

public ExObjList getExObjList()
Returns the ExObjList, which holds the references to external objects used in the slides. This may be null, if there are no external references.

getSlideListWithTexts

public SlideListWithText[] getSlideListWithTexts()
Returns all the SlideListWithTexts that are defined for this Document. They hold the text, and some of the text properties, which are referred to by the slides. This will normally return an array of size 2 or 3

getMasterSlideListWithText

public SlideListWithText getMasterSlideListWithText()
Returns the SlideListWithText that deals with the Master Slides

getSlideSlideListWithText

public SlideListWithText getSlideSlideListWithText()
Returns the SlideListWithText that deals with the Slides, or null if there isn't one

getNotesSlideListWithText

public SlideListWithText getNotesSlideListWithText()
Returns the SlideListWithText that deals with the notes, or null if there isn't one

addSlideListWithText

public void addSlideListWithText(SlideListWithText slwt)
Adds a new SlideListWithText record, at the appropriate point in the child records.

removeSlideListWithText

public void removeSlideListWithText(SlideListWithText slwt)

getRecordType

public long getRecordType()
We are of type 1000

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class DocumentAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.DocumentAtom

public final class DocumentAtom
extends RecordAtom

A Document Atom (type 1001). Holds misc information on the PowerPoint document, lots of them size and scale related.

Author:
Nick Burch

Nested Class Summary
static class DocumentAtom.SlideSize
Holds the different Slide Size values
Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected DocumentAtom(byte[] source, int start, int len)
For the Document Atom
Method Summary
int | getFirstSlideNum()
long | getHandoutMasterPersist() Returns a reference to the HandoutMaster, or 0 if none
long | getNotesMasterPersist() Returns a reference to the NotesMaster, or 0 if none
long | getNotesSizeX()
long | getNotesSizeY()
boolean | getOmitTitlePlace() Have the placeholders on the title slide been omitted?
long | getRecordType() We are of type 1001
boolean | getRightToLeft() Is this a Bi-Directional PPT Doc?
boolean | getSaveWithFonts() Was the document saved with True Type fonts embeded?
long | getServerZoomFrom()
long | getServerZoomTo()
boolean | getShowComments() Are comment shapes visible?
int | getSlideSizeType() The Size of the Document's slides, @see DocumentAtom.SlideSize for values
long | getSlideSizeX()
long | getSlideSizeY()
void | setNotesSizeX(long x)
void | setNotesSizeY(long y)
void | setServerZoomFrom(long zoom)
void | setServerZoomTo(long zoom)
void | setSlideSizeX(long x)
void | setSlideSizeY(long y)
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DocumentAtom

protected DocumentAtom(byte[] source,
                       int start,
                       int len)
For the Document Atom

Method Detail

getSlideSizeX

public long getSlideSizeX()

getSlideSizeY

public long getSlideSizeY()

getNotesSizeX

public long getNotesSizeX()

getNotesSizeY

public long getNotesSizeY()

setSlideSizeX

public void setSlideSizeX(long x)

setSlideSizeY

public void setSlideSizeY(long y)

setNotesSizeX

public void setNotesSizeX(long x)

setNotesSizeY

public void setNotesSizeY(long y)

getServerZoomFrom

public long getServerZoomFrom()

getServerZoomTo

public long getServerZoomTo()

setServerZoomFrom

public void setServerZoomFrom(long zoom)

setServerZoomTo

public void setServerZoomTo(long zoom)

getNotesMasterPersist

public long getNotesMasterPersist()
Returns a reference to the NotesMaster, or 0 if none

getHandoutMasterPersist

public long getHandoutMasterPersist()
Returns a reference to the HandoutMaster, or 0 if none

getFirstSlideNum

public int getFirstSlideNum()

getSlideSizeType

public int getSlideSizeType()
The Size of the Document's slides, @see DocumentAtom.SlideSize for values

getSaveWithFonts

public boolean getSaveWithFonts()
Was the document saved with True Type fonts embeded?

getOmitTitlePlace

public boolean getOmitTitlePlace()
Have the placeholders on the title slide been omitted?

getRightToLeft

public boolean getRightToLeft()
Is this a Bi-Directional PPT Doc?

getShowComments

public boolean getShowComments()
Are comment shapes visible?

getRecordType

public long getRecordType()
We are of type 1001

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentAtom.SlideSize

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class DocumentAtom.SlideSize

java.lang.Object
    extended by  org.apache.poi.hslf.record.DocumentAtom.SlideSize
Enclosing class:
DocumentAtom
public static final class DocumentAtom.SlideSize
extends java.lang.Object

Holds the different Slide Size values

Field Summary
static int | A4_SIZED_PAPER
static int | BANNER
static int | CUSTOM
static int | LETTER_SIZED_PAPER
static int | ON_35MM
static int | ON_SCREEN
static int | OVERHEAD
Constructor Summary
DocumentAtom.SlideSize()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ON_SCREEN

public static final int ON_SCREEN
See Also:
Constant Field Values

LETTER_SIZED_PAPER

public static final int LETTER_SIZED_PAPER
See Also:
Constant Field Values

A4_SIZED_PAPER

public static final int A4_SIZED_PAPER
See Also:
Constant Field Values

ON_35MM

public static final int ON_35MM
See Also:
Constant Field Values

OVERHEAD

public static final int OVERHEAD
See Also:
Constant Field Values

BANNER

public static final int BANNER
See Also:
Constant Field Values

CUSTOM

public static final int CUSTOM
See Also:
Constant Field Values
Constructor Detail

DocumentAtom.SlideSize

public DocumentAtom.SlideSize()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentEncryptionAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class DocumentEncryptionAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.DocumentEncryptionAtom

public final class DocumentEncryptionAtom
extends RecordAtom

A Document Encryption Atom (type 12052). Holds information on the Encryption of a Document

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected DocumentEncryptionAtom(byte[] source, int start, int len)
For the Document Encryption Atom
Method Summary
java.lang.String | getEncryptionProviderName() Return the name of the encryption provider used
int | getKeyLength() Return the length of the encryption key, in bits
long | getRecordType() We are of type 12052
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DocumentEncryptionAtom

protected DocumentEncryptionAtom(byte[] source,
                                 int start,
                                 int len)
For the Document Encryption Atom

Method Detail

getKeyLength

public int getKeyLength()
Return the length of the encryption key, in bits

getEncryptionProviderName

public java.lang.String getEncryptionProviderName()
Return the name of the encryption provider used

getRecordType

public long getRecordType()
We are of type 12052

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DummyPositionSensitiveRecordWithChildren

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class DummyPositionSensitiveRecordWithChildren

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
                extended by  org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren
All Implemented Interfaces:
PositionDependentRecord
public final class DummyPositionSensitiveRecordWithChildren
extends PositionDependentRecordContainer

If we come across a record we know has children of (potential) interest, but where the record itself is boring, but where other records may care about where this one lives, we create one of these. It allows us to get at the children, and track where on disk this is, but not much else. Anything done using this should quite quickly be transitioned to its own proper record class!

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected DummyPositionSensitiveRecordWithChildren(byte[] source, int start, int len)
Create a new holder for a boring record with children, but with position dependent characteristics
Method Summary
long | getRecordType() Return the value we were given at creation
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
getLastOnDiskOffset, getSheetId, setLastOnDiskOffset, setSheetId, updateOtherRecordReferences
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DummyPositionSensitiveRecordWithChildren

protected DummyPositionSensitiveRecordWithChildren(byte[] source,
                                                   int start,
                                                   int len)
Create a new holder for a boring record with children, but with position dependent characteristics

Method Detail

getRecordType

public long getRecordType()
Return the value we were given at creation

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DummyRecordWithChildren

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class DummyRecordWithChildren

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.DummyRecordWithChildren

public final class DummyRecordWithChildren
extends RecordContainer

If we come across a record we know has children of (potential) interest, but where the record itself is boring, we create one of these. It allows us to get at the children, but not much else

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected DummyRecordWithChildren(byte[] source, int start, int len)
Create a new holder for a boring record with children
Method Summary
long | getRecordType() Return the value we were given at creation
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DummyRecordWithChildren

protected DummyRecordWithChildren(byte[] source,
                                  int start,
                                  int len)
Create a new holder for a boring record with children

Method Detail

getRecordType

public long getRecordType()
Return the value we were given at creation

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Environment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Environment

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
                extended by  org.apache.poi.hslf.record.Environment
All Implemented Interfaces:
PositionDependentRecord
public final class Environment
extends PositionDependentRecordContainer

Environment, which contains lots of settings for the document.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected Environment(byte[] source, int start, int len)
Set things up, and find our more interesting children
Method Summary
FontCollection | getFontCollection() Returns the FontCollection of this Environment
long | getRecordType() We are of type 1010
TxMasterStyleAtom | getTxMasterStyleAtom()
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
getLastOnDiskOffset, getSheetId, setLastOnDiskOffset, setSheetId, updateOtherRecordReferences
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Environment

protected Environment(byte[] source,
                      int start,
                      int len)
Set things up, and find our more interesting children

Method Detail

getFontCollection

public FontCollection getFontCollection()
Returns the FontCollection of this Environment

getTxMasterStyleAtom

public TxMasterStyleAtom getTxMasterStyleAtom()

getRecordType

public long getRecordType()
We are of type 1010

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherTextboxWrapper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class EscherTextboxWrapper

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.EscherTextboxWrapper

public final class EscherTextboxWrapper
extends RecordContainer

A wrapper around a DDF (Escher) EscherTextbox Record. Causes the DDF Record to be accessible as if it were a HSLF record. Note: when asked to write out, will simply put any child records correctly into the Escher layer. A call to the escher layer to write out (by the parent PPDrawing) will do the actual write out

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
EscherTextboxWrapper()
Creates a new, empty wrapper for DDF Escher Records and their children
EscherTextboxWrapper(EscherTextboxRecord textbox)
Creates the wrapper for the given DDF Escher Record and children
Method Summary
EscherTextboxRecord | getEscherRecord() Returns the underlying DDF Escher Record
long | getRecordType() Return the type of the escher record (normally in the 0xFnnn range)
int | getShapeId()
void | setShapeId(int id)
void | writeOut(java.io.OutputStream out) Stores the data for the child records back into the Escher layer.
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EscherTextboxWrapper

public EscherTextboxWrapper(EscherTextboxRecord textbox)
Creates the wrapper for the given DDF Escher Record and children

EscherTextboxWrapper

public EscherTextboxWrapper()
Creates a new, empty wrapper for DDF Escher Records and their children

Method Detail

getEscherRecord

public EscherTextboxRecord getEscherRecord()
Returns the underlying DDF Escher Record

getRecordType

public long getRecordType()
Return the type of the escher record (normally in the 0xFnnn range)

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Stores the data for the child records back into the Escher layer. Doesn't actually do the writing out, that's left to the Escher layer to do. Must be called before writeOut/serialize is called on the underlying Escher object!

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getShapeId

public int getShapeId()
Returns:
Shape ID

setShapeId

public void setShapeId(int id)
Parameters:
id - Shape ID
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExAviMovie

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExAviMovie

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.ExMCIMovie
                extended by  org.apache.poi.hslf.record.ExAviMovie

public final class ExAviMovie
extends ExMCIMovie

A container record that specifies information about a movie stored externally.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExAviMovie() Create a new ExAviMovie, with blank fields
protected | ExAviMovie(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
 long getRecordType()
We are of type 4102
Methods inherited from class org.apache.poi.hslf.record.ExMCIMovie
getExVideo, writeOut
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExAviMovie

protected ExAviMovie(byte[] source,
                     int start,
                     int len)
Set things up, and find our more interesting children

ExAviMovie

public ExAviMovie()
Create a new ExAviMovie, with blank fields

Method Detail

getRecordType

public long getRecordType()
We are of type 4102

Overrides:
getRecordType in class ExMCIMovie
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExControl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExControl

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.ExEmbed
                extended by  org.apache.poi.hslf.record.ExControl

public final class ExControl
extends ExEmbed

A container record that specifies information about an ActiveX control. It contains:

1. ExControlAtom (4091) 2. ExOleObjAtom (4035) 3. CString (4026), Instance MenuName (1) used for menus and the Links dialog box. 4. CString (4026), Instance ProgID (2) that stores the OLE Programmatic Identifier. A ProgID is a string that uniquely identifies a given object. 5. CString (4026), Instance ClipboardName (3) that appears in the paste special dialog. 6. MetaFile( 4033), optional

Author:
Yegor kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.ExEmbed
embedAtom
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExControl() Create a new ExEmbed, with blank fields
protected | ExControl(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
ExControlAtom | getExControlAtom() Gets the ExControlAtom.
long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
Methods inherited from class org.apache.poi.hslf.record.ExEmbed
getClipboardName, getExEmbedAtom, getExOleObjAtom, getMenuName, getProgId, setClipboardName, setMenuName, setProgId, writeOut
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExControl

protected ExControl(byte[] source,
                    int start,
                    int len)
Set things up, and find our more interesting children

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.

ExControl

public ExControl()
Create a new ExEmbed, with blank fields

Method Detail

getExControlAtom

public ExControlAtom getExControlAtom()
Gets the ExControlAtom.

Returns:
the ExControlAtom.

getRecordType

public long getRecordType()
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.

Overrides:
getRecordType in class ExEmbed
Returns:
the record type.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExControlAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExControlAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ExControlAtom

public final class ExControlAtom
extends RecordAtom

An atom record that specifies an ActiveX control.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | ExControlAtom() Constructs a brand new embedded object atom record.
protected | ExControlAtom(byte[] source, int start, int len) Constructs the ExControlAtom record from its source data.
Method Summary
long | getRecordType() Gets the record type.
int | getSlideId() An integer that specifies which presentation slide is associated with the ActiveX control.
void | setSlideId(int id) Sets which presentation slide is associated with the ActiveX control.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExControlAtom

protected ExControlAtom()
Constructs a brand new embedded object atom record.

ExControlAtom

protected ExControlAtom(byte[] source,
                        int start,
                        int len)
Constructs the ExControlAtom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getSlideId

public int getSlideId()
An integer that specifies which presentation slide is associated with the ActiveX control.

It MUST be 0x00000000 or equal to the value of the slideId field of a SlidePersistAtom record. The value 0x00000000 specifies a null reference.

Returns:
an integer that specifies which presentation slide is associated with the ActiveX control

setSlideId

public void setSlideId(int id)
Sets which presentation slide is associated with the ActiveX control.

Parameters:
id - an integer that specifies which presentation slide is associated with the ActiveX control

It MUST be 0x00000000 or equal to the value of the slideId field of a SlidePersistAtom record. The value 0x00000000 specifies a null reference.

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExEmbed

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExEmbed

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.ExEmbed
Direct Known Subclasses:
ExControl
public class ExEmbed
extends RecordContainer

This data represents an embedded object in the document.

Author:
Daniel Noll

Field Summary
protected  RecordAtom embedAtom
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExEmbed() Create a new ExEmbed, with blank fields
protected | ExEmbed(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
java.lang.String | getClipboardName() Gets the name that appears in the paste special dialog.
ExEmbedAtom | getExEmbedAtom() Gets the ExEmbedAtom.
ExOleObjAtom | getExOleObjAtom() Gets the ExOleObjAtom.
java.lang.String | getMenuName() Gets the name used for menus and the Links dialog box.
java.lang.String | getProgId() Gets the OLE Programmatic Identifier.
long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
void | setClipboardName(java.lang.String s)
void | setMenuName(java.lang.String s)
void | setProgId(java.lang.String s)
void | writeOut(java.io.OutputStream out) Have the contents printer out into an OutputStream, used when writing a file back out to disk.
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

embedAtom

protected RecordAtom embedAtom
Constructor Detail

ExEmbed

protected ExEmbed(byte[] source,
                  int start,
                  int len)
Set things up, and find our more interesting children

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.

ExEmbed

public ExEmbed()
Create a new ExEmbed, with blank fields

Method Detail

getExEmbedAtom

public ExEmbedAtom getExEmbedAtom()
Gets the ExEmbedAtom.

Returns:
the ExEmbedAtom.

getExOleObjAtom

public ExOleObjAtom getExOleObjAtom()
Gets the ExOleObjAtom.

Returns:
the ExOleObjAtom.

getMenuName

public java.lang.String getMenuName()
Gets the name used for menus and the Links dialog box.

Returns:
the name used for menus and the Links dialog box.

setMenuName

public void setMenuName(java.lang.String s)

getProgId

public java.lang.String getProgId()
Gets the OLE Programmatic Identifier.

Returns:
the OLE Programmatic Identifier.

setProgId

public void setProgId(java.lang.String s)

getClipboardName

public java.lang.String getClipboardName()
Gets the name that appears in the paste special dialog.

Returns:
the name that appears in the paste special dialog.

setClipboardName

public void setClipboardName(java.lang.String s)

getRecordType

public long getRecordType()
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Have the contents printer out into an OutputStream, used when writing a file back out to disk.

Specified by:
writeOut in class Record
Parameters:
out - the output stream.
Throws:
java.io.IOException - if there was an error writing to the stream.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExEmbedAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExEmbedAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ExEmbedAtom

public class ExEmbedAtom
extends RecordAtom

The atom that holds metadata on a specific embedded object in the document.

Author:
Daniel Noll

Field Summary
static int | DOES_NOT_FOLLOW_COLOR_SCHEME Embedded document does not follow the color scheme.
static int | FOLLOWS_ENTIRE_COLOR_SCHEME Embedded document follows the entire color scheme.
static int | FOLLOWS_TEXT_AND_BACKGROUND_SCHEME Embedded document follows the text and background scheme.
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | ExEmbedAtom() Constructs a brand new embedded object atom record.
protected | ExEmbedAtom(byte[] source, int start, int len) Constructs the embedded object atom record from its source data.
Method Summary
boolean | getCantLockServerB() Gets whether the embedded server cannot be locked.
int | getFollowColorScheme() Gets whether the object follows the color scheme.
boolean | getIsTable() Getswhether the object is a Word table.
boolean | getNoSizeToServerB() Gets whether it is not required to send the dimensions to the embedded object.
long | getRecordType() Gets the record type.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DOES_NOT_FOLLOW_COLOR_SCHEME

public static final int DOES_NOT_FOLLOW_COLOR_SCHEME
Embedded document does not follow the color scheme.

See Also:
Constant Field Values

FOLLOWS_ENTIRE_COLOR_SCHEME

public static final int FOLLOWS_ENTIRE_COLOR_SCHEME
Embedded document follows the entire color scheme.

See Also:
Constant Field Values

FOLLOWS_TEXT_AND_BACKGROUND_SCHEME

public static final int FOLLOWS_TEXT_AND_BACKGROUND_SCHEME
Embedded document follows the text and background scheme.

See Also:
Constant Field Values
Constructor Detail

ExEmbedAtom

protected ExEmbedAtom()
Constructs a brand new embedded object atom record.

ExEmbedAtom

protected ExEmbedAtom(byte[] source,
                      int start,
                      int len)
Constructs the embedded object atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getFollowColorScheme

public int getFollowColorScheme()
Gets whether the object follows the color scheme.

Returns:
one of DOES_NOT_FOLLOW_COLOR_SCHEME, FOLLOWS_ENTIRE_COLOR_SCHEME, or FOLLOWS_TEXT_AND_BACKGROUND_SCHEME.

getCantLockServerB

public boolean getCantLockServerB()
Gets whether the embedded server cannot be locked.

Returns:
true if the embedded server cannot be locked.

getNoSizeToServerB

public boolean getNoSizeToServerB()
Gets whether it is not required to send the dimensions to the embedded object.

Returns:
true if the embedded server does not require the object dimensions.

getIsTable

public boolean getIsTable()
Getswhether the object is a Word table.

Returns:
true if the object is a Word table.

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExHyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExHyperlink

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.ExHyperlink

public class ExHyperlink
extends RecordContainer

This class represents the data of a link in the document.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExHyperlink() Create a new ExHyperlink, with blank fields
protected | ExHyperlink(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
java.lang.String | _getDetailsA() Get the link details (field A)
java.lang.String | _getDetailsB() Get the link details (field B)
ExHyperlinkAtom | getExHyperlinkAtom() Returns the ExHyperlinkAtom of this link
java.lang.String | getLinkTitle() Returns the hyperlink's user-readable name
java.lang.String | getLinkURL() Returns the URL of the link.
long | getRecordType() We are of type 4055
void | setLinkTitle(java.lang.String title)
void | setLinkURL(java.lang.String url) Sets the URL of the link TODO: Figure out if we should always set both
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExHyperlink

protected ExHyperlink(byte[] source,
                      int start,
                      int len)
Set things up, and find our more interesting children

ExHyperlink

public ExHyperlink()
Create a new ExHyperlink, with blank fields

Method Detail

getExHyperlinkAtom

public ExHyperlinkAtom getExHyperlinkAtom()
Returns the ExHyperlinkAtom of this link

getLinkURL

public java.lang.String getLinkURL()
Returns the URL of the link.

Returns:
the URL of the link

getLinkTitle

public java.lang.String getLinkTitle()
Returns the hyperlink's user-readable name

Returns:
the hyperlink's user-readable name

setLinkURL

public void setLinkURL(java.lang.String url)
Sets the URL of the link TODO: Figure out if we should always set both

setLinkTitle

public void setLinkTitle(java.lang.String title)

_getDetailsA

public java.lang.String _getDetailsA()
Get the link details (field A)

_getDetailsB

public java.lang.String _getDetailsB()
Get the link details (field B)

getRecordType

public long getRecordType()
We are of type 4055

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExHyperlinkAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExHyperlinkAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ExHyperlinkAtom

public final class ExHyperlinkAtom
extends RecordAtom

Tne atom that holds metadata on a specific Link in the document. (The actual link is held in a sibling CString record)

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | ExHyperlinkAtom() Constructs a brand new link related atom record.
protected | ExHyperlinkAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
int | getNumber() Gets the link number.
long | getRecordType() Gets the record type.
void | setNumber(int number) Sets the link number
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExHyperlinkAtom

protected ExHyperlinkAtom()
Constructs a brand new link related atom record.

ExHyperlinkAtom

protected ExHyperlinkAtom(byte[] source,
                          int start,
                          int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getNumber

public int getNumber()
Gets the link number. This will match the one in the InteractiveInfoAtom which uses the link.

Returns:
the link number

setNumber

public void setNumber(int number)
Sets the link number

Parameters:
number - the link number.

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExMCIMovie

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExMCIMovie

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.ExMCIMovie
Direct Known Subclasses:
ExAviMovie
public class ExMCIMovie
extends RecordContainer

A container record that specifies information about a movie stored externally.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExMCIMovie() Create a new ExMCIMovie, with blank fields
protected | ExMCIMovie(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
ExVideoContainer | getExVideo() Returns the ExVideoContainer that specifies information about the MCI movie
long | getRecordType() We are of type 4103
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExMCIMovie

protected ExMCIMovie(byte[] source,
                     int start,
                     int len)
Set things up, and find our more interesting children

ExMCIMovie

public ExMCIMovie()
Create a new ExMCIMovie, with blank fields

Method Detail

getRecordType

public long getRecordType()
We are of type 4103

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getExVideo

public ExVideoContainer getExVideo()
Returns the ExVideoContainer that specifies information about the MCI movie

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExMediaAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExMediaAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ExMediaAtom

public final class ExMediaAtom
extends RecordAtom

An atom record that specifies information about external audio or video data.

Author:
Yegor Kozlov

Field Summary
static int | fLoop A bit that specifies whether the audio or video data is repeated continuously during playback.
static int | fNarration A bit that specifies whether the audio data is recorded narration for the slide show.
static int | fRewind A bit that specifies whether the audio or video data is rewound after playing.
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | ExMediaAtom() Constructs a brand new link related atom record.
protected | ExMediaAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
boolean | getFlag(int bit)
int | getMask() A bit mask specifying options for displaying headers and footers
int | getObjectId() A 4-byte unsigned integer that specifies an ID for an external object.
long | getRecordType() Gets the record type.
void | setFlag(int bit, boolean value)
void | setMask(int mask) A bit mask specifying options for displaying video
void | setObjectId(int id) A 4-byte unsigned integer that specifies an ID for an external object.
java.lang.String | toString()
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

fLoop

public static final int fLoop
A bit that specifies whether the audio or video data is repeated continuously during playback.

See Also:
Constant Field Values

fRewind

public static final int fRewind
A bit that specifies whether the audio or video data is rewound after playing.

See Also:
Constant Field Values

fNarration

public static final int fNarration
A bit that specifies whether the audio data is recorded narration for the slide show. It MUST be FALSE if this ExMediaAtom record is contained by an ExVideoContainer record.

See Also:
Constant Field Values
Constructor Detail

ExMediaAtom

protected ExMediaAtom()
Constructs a brand new link related atom record.

ExMediaAtom

protected ExMediaAtom(byte[] source,
                      int start,
                      int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.

getObjectId

public int getObjectId()
A 4-byte unsigned integer that specifies an ID for an external object.

Returns:
A 4-byte unsigned integer that specifies an ID for an external object.

setObjectId

public void setObjectId(int id)
A 4-byte unsigned integer that specifies an ID for an external object.

Parameters:
id - A 4-byte unsigned integer that specifies an ID for an external object.

getMask

public int getMask()
A bit mask specifying options for displaying headers and footers

Returns:
A bit mask specifying options for displaying headers and footers

setMask

public void setMask(int mask)
A bit mask specifying options for displaying video

Parameters:
mask - A bit mask specifying options for displaying video

getFlag

public boolean getFlag(int bit)
Parameters:
bit - the bit to check
Returns:
whether the specified flag is set

setFlag

public void setFlag(int bit,
                    boolean value)
Parameters:
bit - the bit to set
value - whether the specified bit is set

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExObjList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExObjList

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.ExObjList

public class ExObjList
extends RecordContainer

This class holds the links to exernal objects referenced from the document.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExObjList() Create a new ExObjList, with blank fields
protected | ExObjList(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
ExHyperlink | get(int id) Lookup a hyperlink by its unique id
ExHyperlink[] | getExHyperlinks() Returns all the ExHyperlinks
ExObjListAtom | getExObjListAtom() Returns the ExObjListAtom of this list
long | getRecordType() We are of type 1033
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExObjList

protected ExObjList(byte[] source,
                    int start,
                    int len)
Set things up, and find our more interesting children

ExObjList

public ExObjList()
Create a new ExObjList, with blank fields

Method Detail

getExObjListAtom

public ExObjListAtom getExObjListAtom()
Returns the ExObjListAtom of this list

getExHyperlinks

public ExHyperlink[] getExHyperlinks()
Returns all the ExHyperlinks

getRecordType

public long getRecordType()
We are of type 1033

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

get

public ExHyperlink get(int id)
Lookup a hyperlink by its unique id

Parameters:
id - hyperlink id
Returns:
found ExHyperlink or null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExObjListAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExObjListAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ExObjListAtom

public class ExObjListAtom
extends RecordAtom

Tne atom that holds the seed info used by a ExObjList

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | ExObjListAtom() Constructs a brand new link related atom record.
protected | ExObjListAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
long | getObjectIDSeed() Gets the object ID seed, which will be used as the unique OLE identifier for the next OLE object added
long | getRecordType() Gets the record type.
void | setObjectIDSeed(int seed) Sets the object ID seed
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExObjListAtom

protected ExObjListAtom()
Constructs a brand new link related atom record.

ExObjListAtom

protected ExObjListAtom(byte[] source,
                        int start,
                        int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getObjectIDSeed

public long getObjectIDSeed()
Gets the object ID seed, which will be used as the unique OLE identifier for the next OLE object added

Returns:
the object ID seed

setObjectIDSeed

public void setObjectIDSeed(int seed)
Sets the object ID seed

Parameters:
seed - the new ID seed

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExOleObjAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExOleObjAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ExOleObjAtom

public class ExOleObjAtom
extends RecordAtom

Atom storing information for an OLE object.

Author:
Daniel Noll

Field Summary
static int | DRAW_ASPECT_DOCPRINT The object is displayed on the screen as though it were printed to a printer.
static int | DRAW_ASPECT_ICON The object is displayed as an icon.
static int | DRAW_ASPECT_THUMBNAIL The object is displayed as a thumbnail image.
static int | DRAW_ASPECT_VISIBLE The object) is displayed as an embedded object inside of a container,
static int | SUBTYPE_CLIPART_GALLERY
static int | SUBTYPE_DEFAULT
static int | SUBTYPE_EQUATION
static int | SUBTYPE_EXCEL
static int | SUBTYPE_EXCEL_CHART
static int | SUBTYPE_GRAPH
static int | SUBTYPE_IMAGE
static int | SUBTYPE_MEDIA_PLAYER
static int | SUBTYPE_NOTEIT
static int | SUBTYPE_ORGANIZATION_CHART
static int | SUBTYPE_POWERPOINT_PRESENTATION
static int | SUBTYPE_POWERPOINT_SLIDE
static int | SUBTYPE_PROJECT
static int | SUBTYPE_SOUND
static int | SUBTYPE_WORD_TABLE
static int | SUBTYPE_WORDART
static int | TYPE_CONTROL The OLE object is an ActiveX control.
static int | TYPE_EMBEDDED An embedded OLE object; the object is serialized and saved within the file.
static int | TYPE_LINKED A linked OLE object; the object is saved outside of the file.
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExOleObjAtom() Constructs a brand new link related atom record.
protected | ExOleObjAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
int | getDrawAspect() Gets whether the object can be completely seen, or if only the icon is visible.
boolean | getIsBlank() Gets whether the object's image is blank.
int | getObjID() Gets the unique identifier for the OLE object.
int | getObjStgDataRef() Gets the reference to the persistent object
int | getOptions() Gets misc options (the last four bytes in the atom).
long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
int | getSubType() Gets the type of OLE object.
int | getType() Gets whether the object is embedded or linked.
void | setDrawAspect(int aspect) Sets whether the object can be completely seen, or if only the icon is visible.
void | setObjID(int id) Sets the unique identifier for the OLE object.
void | setObjStgDataRef(int ref) Sets the reference to the persistent object
void | setOptions(int opts) Sets misc options (the last four bytes in the atom).
void | setSubType(int type) Sets the type of OLE object.
void | setType(int type) Sets whether the object is embedded or linked.
java.lang.String | toString()
void | writeOut(java.io.OutputStream out) Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DRAW_ASPECT_VISIBLE

public static final int DRAW_ASPECT_VISIBLE
The object) is displayed as an embedded object inside of a container,

See Also:
Constant Field Values

DRAW_ASPECT_THUMBNAIL

public static final int DRAW_ASPECT_THUMBNAIL
The object is displayed as a thumbnail image.

See Also:
Constant Field Values

DRAW_ASPECT_ICON

public static final int DRAW_ASPECT_ICON
The object is displayed as an icon.

See Also:
Constant Field Values

DRAW_ASPECT_DOCPRINT

public static final int DRAW_ASPECT_DOCPRINT
The object is displayed on the screen as though it were printed to a printer.

See Also:
Constant Field Values

TYPE_EMBEDDED

public static final int TYPE_EMBEDDED
An embedded OLE object; the object is serialized and saved within the file.

See Also:
Constant Field Values

TYPE_LINKED

public static final int TYPE_LINKED
A linked OLE object; the object is saved outside of the file.

See Also:
Constant Field Values

TYPE_CONTROL

public static final int TYPE_CONTROL
The OLE object is an ActiveX control.

See Also:
Constant Field Values

SUBTYPE_DEFAULT

public static final int SUBTYPE_DEFAULT
See Also:
Constant Field Values

SUBTYPE_CLIPART_GALLERY

public static final int SUBTYPE_CLIPART_GALLERY
See Also:
Constant Field Values

SUBTYPE_WORD_TABLE

public static final int SUBTYPE_WORD_TABLE
See Also:
Constant Field Values

SUBTYPE_EXCEL

public static final int SUBTYPE_EXCEL
See Also:
Constant Field Values

SUBTYPE_GRAPH

public static final int SUBTYPE_GRAPH
See Also:
Constant Field Values

SUBTYPE_ORGANIZATION_CHART

public static final int SUBTYPE_ORGANIZATION_CHART
See Also:
Constant Field Values

SUBTYPE_EQUATION

public static final int SUBTYPE_EQUATION
See Also:
Constant Field Values

SUBTYPE_WORDART

public static final int SUBTYPE_WORDART
See Also:
Constant Field Values

SUBTYPE_SOUND

public static final int SUBTYPE_SOUND
See Also:
Constant Field Values

SUBTYPE_IMAGE

public static final int SUBTYPE_IMAGE
See Also:
Constant Field Values

SUBTYPE_POWERPOINT_PRESENTATION

public static final int SUBTYPE_POWERPOINT_PRESENTATION
See Also:
Constant Field Values

SUBTYPE_POWERPOINT_SLIDE

public static final int SUBTYPE_POWERPOINT_SLIDE
See Also:
Constant Field Values

SUBTYPE_PROJECT

public static final int SUBTYPE_PROJECT
See Also:
Constant Field Values

SUBTYPE_NOTEIT

public static final int SUBTYPE_NOTEIT
See Also:
Constant Field Values

SUBTYPE_EXCEL_CHART

public static final int SUBTYPE_EXCEL_CHART
See Also:
Constant Field Values

SUBTYPE_MEDIA_PLAYER

public static final int SUBTYPE_MEDIA_PLAYER
See Also:
Constant Field Values
Constructor Detail

ExOleObjAtom

public ExOleObjAtom()
Constructs a brand new link related atom record.

ExOleObjAtom

protected ExOleObjAtom(byte[] source,
                       int start,
                       int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getDrawAspect

public int getDrawAspect()
Gets whether the object can be completely seen, or if only the icon is visible.

Returns:
the draw aspect, one of the DRAW_ASPECT_* constants.

setDrawAspect

public void setDrawAspect(int aspect)
Sets whether the object can be completely seen, or if only the icon is visible.

Parameters:
aspect - the draw aspect, one of the DRAW_ASPECT_* constants.

getType

public int getType()
Gets whether the object is embedded or linked.

Returns:
the type, one of the TYPE_EMBEDDED_* constants.

setType

public void setType(int type)
Sets whether the object is embedded or linked.

Parameters:
type - the type, one of the TYPE_EMBEDDED_* constants.

getObjID

public int getObjID()
Gets the unique identifier for the OLE object.

Returns:
the object ID.

setObjID

public void setObjID(int id)
Sets the unique identifier for the OLE object.

Parameters:
id - the object ID.

getSubType

public int getSubType()
Gets the type of OLE object.

Returns:
the sub-type, one of the SUBTYPE_* constants.

setSubType

public void setSubType(int type)
Sets the type of OLE object.

Parameters:
type - the sub-type, one of the SUBTYPE_* constants.

getObjStgDataRef

public int getObjStgDataRef()
Gets the reference to the persistent object

Returns:
the reference to the persistent object, corresponds with an ExOleObjStg storage container.

setObjStgDataRef

public void setObjStgDataRef(int ref)
Sets the reference to the persistent object

Parameters:
ref - the reference to the persistent object, corresponds with an ExOleObjStg storage container.

getIsBlank

public boolean getIsBlank()
Gets whether the object's image is blank.

Returns:
true if the object's image is blank.

getOptions

public int getOptions()
Gets misc options (the last four bytes in the atom).

Returns:
true if the object's image is blank.

setOptions

public void setOptions(int opts)
Sets misc options (the last four bytes in the atom).

getRecordType

public long getRecordType()
Returns the type (held as a little endian in bytes 3 and 4) that this class handles.

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)

Specified by:
writeOut in class Record
Throws:
java.io.IOException

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExOleObjStg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExOleObjStg

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.ExOleObjStg
All Implemented Interfaces:
PersistRecord, PositionDependentRecord
public class ExOleObjStg
extends RecordAtom
implements PositionDependentRecord, PersistRecord

Storage for embedded OLE objects.

Author:
Daniel Noll

Field Summary
protected  int myLastOnDiskOffset
Our location on the disk, as of the last write out
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExOleObjStg() Constructs a new empty storage container.
protected | ExOleObjStg(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
java.io.InputStream | getData() Opens an input stream which will decompress the data on the fly.
int | getDataLength() Gets the uncompressed length of the data.
int | getLastOnDiskOffset() Fetch our location on the disk, as of the last write out
int | getPersistId() Fetch our sheet ID, as found from a PersistPtrHolder.
byte[] | getRawData()
long | getRecordType() Gets the record type.
boolean | isCompressed()
void | setData(byte[] data) Sets the embedded data.
void | setLastOnDiskOffset(int offset) Update the Record's idea of where on disk it lives, after a write out.
void | setPersistId(int id) Set our sheet ID, as found from a PersistPtrHolder
void | updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup) Offer the record the list of records that have changed their location as part of the writeout.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk.
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

myLastOnDiskOffset

protected int myLastOnDiskOffset
Our location on the disk, as of the last write out

Constructor Detail

ExOleObjStg

public ExOleObjStg()
Constructs a new empty storage container.

ExOleObjStg

protected ExOleObjStg(byte[] source,
                      int start,
                      int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

isCompressed

public boolean isCompressed()

getDataLength

public int getDataLength()
Gets the uncompressed length of the data.

Returns:
the uncompressed length of the data.

getData

public java.io.InputStream getData()
Opens an input stream which will decompress the data on the fly.

Returns:
the data input stream.

getRawData

public byte[] getRawData()

setData

public void setData(byte[] data)
             throws java.io.IOException
Sets the embedded data.

Parameters:
data - the embedded data.
Throws:
java.io.IOException

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk.

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.

getPersistId

public int getPersistId()
Fetch our sheet ID, as found from a PersistPtrHolder. Should match the RefId of our matching SlidePersistAtom

Specified by:
getPersistId in interface PersistRecord

setPersistId

public void setPersistId(int id)
Set our sheet ID, as found from a PersistPtrHolder

Specified by:
setPersistId in interface PersistRecord

getLastOnDiskOffset

public int getLastOnDiskOffset()
Fetch our location on the disk, as of the last write out

Specified by:
getLastOnDiskOffset in interface PositionDependentRecord

setLastOnDiskOffset

public void setLastOnDiskOffset(int offset)
Update the Record's idea of where on disk it lives, after a write out. Use with care...

Specified by:
setLastOnDiskOffset in interface PositionDependentRecord

updateOtherRecordReferences

public void updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup)
Description copied from interface: PositionDependentRecord
Offer the record the list of records that have changed their location as part of the writeout.

Specified by:
updateOtherRecordReferences in interface PositionDependentRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExVideoContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class ExVideoContainer

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.ExVideoContainer

public final class ExVideoContainer
extends RecordContainer

A container record that specifies information about external video data.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | ExVideoContainer() Create a new ExVideoContainer, with blank fields
protected | ExVideoContainer(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
ExMediaAtom | getExMediaAtom() Returns the ExMediaAtom of this link
CString | getPathAtom() Returns the Path Atom (CString) of this link
long | getRecordType() We are of type 4103
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExVideoContainer

protected ExVideoContainer(byte[] source,
                           int start,
                           int len)
Set things up, and find our more interesting children

ExVideoContainer

public ExVideoContainer()
Create a new ExVideoContainer, with blank fields

Method Detail

getRecordType

public long getRecordType()
We are of type 4103

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getExMediaAtom

public ExMediaAtom getExMediaAtom()
Returns the ExMediaAtom of this link

getPathAtom

public CString getPathAtom()
Returns the Path Atom (CString) of this link

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontCollection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class FontCollection

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.FontCollection

public final class FontCollection
extends RecordContainer

FontCollection ia a container that holds information about all the fonts in the presentation.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected FontCollection(byte[] source, int start, int len)
Method Summary
int | addFont(java.lang.String name) Add font with the specified name to the font collection.
int | addFont(java.lang.String name, int charset, int flags, int type, int pitch)
int | getFontIndex(java.lang.String name)
java.lang.String | getFontWithId(int id) Get the name of the font at the given ID, or null if there is no font at that ID.
int | getNumberOfFonts()
long | getRecordType() Return the type, which is 2005
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FontCollection

protected FontCollection(byte[] source,
                         int start,
                         int len)
Method Detail

getRecordType

public long getRecordType()
Return the type, which is 2005

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

addFont

public int addFont(java.lang.String name)
Add font with the specified name to the font collection. If the font is already present return its index.

Parameters:
name - of the font
Returns:
zero based index of the font in the collection

addFont

public int addFont(java.lang.String name,
                   int charset,
                   int flags,
                   int type,
                   int pitch)

getFontIndex

public int getFontIndex(java.lang.String name)
Returns:
zero based index of the font in the collection or -1 if not found

getNumberOfFonts

public int getNumberOfFonts()

getFontWithId

public java.lang.String getFontWithId(int id)
Get the name of the font at the given ID, or null if there is no font at that ID.

Parameters:
id -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontEntityAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class FontEntityAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.FontEntityAtom

public final class FontEntityAtom
extends RecordAtom

This atom corresponds exactly to a Windows Logical Font (LOGFONT) structure. It keeps all the information needed to define the attributes of a font, such as height, width, etc. For more information, consult the Windows API Programmer's reference.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | FontEntityAtom() Create a new instance of FontEntityAtom
protected | FontEntityAtom(byte[] source, int start, int len) Build an instance of FontEntityAtom from on-disk data
Method Summary
int | getCharSet() get the character set
int | getFontFlags() get the character set Bit 1: If set, font is subsetted
int | getFontIndex()
java.lang.String | getFontName() A null-terminated string that specifies the typeface name of the font.
int | getFontType() get the font type
int | getPitchAndFamily() get lfPitchAndFamily
long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles
void | setCharSet(int charset) set the character set
void | setFontFlags(int flags) set the font flags Bit 1: If set, font is subsetted
void | setFontIndex(int idx)
void | setFontName(java.lang.String name) Set the name of the font.
void | setFontType(int type) set the font type
void | setPitchAndFamily(int val) set lfPitchAndFamily
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FontEntityAtom

protected FontEntityAtom(byte[] source,
                         int start,
                         int len)
Build an instance of FontEntityAtom from on-disk data

FontEntityAtom

public FontEntityAtom()
Create a new instance of FontEntityAtom

Method Detail

getRecordType

public long getRecordType()
Description copied from class: Record
Returns the type (held as a little endian in bytes 3 and 4) that this class handles

Specified by:
getRecordType in class Record

getFontName

public java.lang.String getFontName()
A null-terminated string that specifies the typeface name of the font. The length of this string must not exceed 32 characters including the null terminator.

Returns:
font name

setFontName

public void setFontName(java.lang.String name)
Set the name of the font. The length of this string must not exceed 32 characters including the null terminator. Will be converted to null-terminated if not already

Parameters:
name - of the font

setFontIndex

public void setFontIndex(int idx)

getFontIndex

public int getFontIndex()

setCharSet

public void setCharSet(int charset)
set the character set

Parameters:
charset - - characterset

getCharSet

public int getCharSet()
get the character set

Returns:
charset - characterset

setFontFlags

public void setFontFlags(int flags)
set the font flags Bit 1: If set, font is subsetted

Parameters:
flags - - the font flags

getFontFlags

public int getFontFlags()
get the character set Bit 1: If set, font is subsetted

Returns:
the font flags

setFontType

public void setFontType(int type)
set the font type

Bit 1: Raster Font Bit 2: Device Font Bit 3: TrueType Font

Parameters:
type - - the font type

getFontType

public int getFontType()
get the font type

Bit 1: Raster Font Bit 2: Device Font Bit 3: TrueType Font

Returns:
the font type

setPitchAndFamily

public void setPitchAndFamily(int val)
set lfPitchAndFamily

Parameters:
val - - Corresponds to the lfPitchAndFamily field of the Win32 API LOGFONT structure

getPitchAndFamily

public int getPitchAndFamily()
get lfPitchAndFamily

Returns:
corresponds to the lfPitchAndFamily field of the Win32 API LOGFONT structure

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeadersFootersAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class HeadersFootersAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.HeadersFootersAtom

public final class HeadersFootersAtom
extends RecordAtom

An atom record that specifies options for displaying headers and footers on a presentation slide or notes slide.

Author:
Yegor Kozlov

Field Summary
static int | fHasDate A bit that specifies whether the date is displayed in the footer.
static int | fHasFooter bit that specifies whether the footer text is displayed.
static int | fHasHeader bit that specifies whether the header text is displayed.
static int | fHasSlideNumber A bit that specifies whether the slide number is displayed in the footer.
static int | fHasTodayDate A bit that specifies whether the current datetime is used for displaying the datetime.
static int | fHasUserDate A bit that specifies whether the date specified in UserDateAtom record is used for displaying the datetime.
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | HeadersFootersAtom() Create a new instance of HeadersFootersAtom
protected | HeadersFootersAtom(byte[] source, int start, int len) Build an instance of HeadersFootersAtom from on-disk data
Method Summary
boolean | getFlag(int bit)
int | getFormatId() A signed integer that specifies the format ID to be used to style the datetime.
int | getMask() A bit mask specifying options for displaying headers and footers A - fHasDate (1 bit): A bit that specifies whether the date is displayed in the footer.
long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles
void | setFlag(int bit, boolean value)
void | setFormatId(int formatId) A signed integer that specifies the format ID to be used to style the datetime.
void | setMask(int mask) A bit mask specifying options for displaying headers and footers
java.lang.String | toString()
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

fHasDate

public static final int fHasDate
A bit that specifies whether the date is displayed in the footer.

See Also:
getMask(), setMask(int), Constant Field Values

fHasTodayDate

public static final int fHasTodayDate
A bit that specifies whether the current datetime is used for displaying the datetime.

See Also:
getMask(), setMask(int), Constant Field Values

fHasUserDate

public static final int fHasUserDate
A bit that specifies whether the date specified in UserDateAtom record is used for displaying the datetime.

See Also:
getMask(), setMask(int), Constant Field Values

fHasSlideNumber

public static final int fHasSlideNumber
A bit that specifies whether the slide number is displayed in the footer.

See Also:
getMask(), setMask(int), Constant Field Values

fHasHeader

public static final int fHasHeader
bit that specifies whether the header text is displayed.

See Also:
getMask(), setMask(int), Constant Field Values

fHasFooter

public static final int fHasFooter
bit that specifies whether the footer text is displayed.

See Also:
getMask(), setMask(int), Constant Field Values
Constructor Detail

HeadersFootersAtom

protected HeadersFootersAtom(byte[] source,
                             int start,
                             int len)
Build an instance of HeadersFootersAtom from on-disk data

HeadersFootersAtom

public HeadersFootersAtom()
Create a new instance of HeadersFootersAtom

Method Detail

getRecordType

public long getRecordType()
Description copied from class: Record
Returns the type (held as a little endian in bytes 3 and 4) that this class handles

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getFormatId

public int getFormatId()
A signed integer that specifies the format ID to be used to style the datetime.

It MUST be in the range [0, 12].
This value is converted into a string as specified by the index field of the DateTimeMCAtom record. It MUST be ignored unless fHasTodayDate is TRUE.

Returns:
A signed integer that specifies the format ID to be used to style the datetime.

setFormatId

public void setFormatId(int formatId)
A signed integer that specifies the format ID to be used to style the datetime.

Parameters:
formatId - A signed integer that specifies the format ID to be used to style the datetime.

getMask

public int getMask()
A bit mask specifying options for displaying headers and footers
  • A - fHasDate (1 bit): A bit that specifies whether the date is displayed in the footer.
  • B - fHasTodayDate (1 bit): A bit that specifies whether the current datetime is used for displaying the datetime.
  • C - fHasUserDate (1 bit): A bit that specifies whether the date specified in UserDateAtom record is used for displaying the datetime.
  • D - fHasSlideNumber (1 bit): A bit that specifies whether the slide number is displayed in the footer.
  • E - fHasHeader (1 bit): A bit that specifies whether the header text specified by HeaderAtom record is displayed.
  • F - fHasFooter (1 bit): A bit that specifies whether the footer text specified by FooterAtom record is displayed.
  • reserved (10 bits): MUST be zero and MUST be ignored.

    Returns:
    A bit mask specifying options for displaying headers and footers

    • setMask

    public void setMask(int mask)
    A bit mask specifying options for displaying headers and footers

    Parameters:
    mask - A bit mask specifying options for displaying headers and footers

    getFlag

    public boolean getFlag(int bit)
    Parameters:
    bit - the bit to check
    Returns:
    whether the specified flag is set

    setFlag

    public void setFlag(int bit,
                    boolean value)
    Parameters:
    bit - the bit to set
    value - whether the specified bit is set

    toString

    public java.lang.String toString()
    Overrides:
    toString in class java.lang.Object
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeadersFootersContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class HeadersFootersContainer

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.HeadersFootersContainer

public final class HeadersFootersContainer
extends RecordContainer

A container record that specifies information about the footers on a presentation slide.

It contains:

  • 1. HeadersFootersAtom
  • 2. CString, Instance UserDate (0), optional: Stores the user's date. This is the date that the user wants in the footers, instead of today's date.
  • 3. CString, Instance Header (1), optional: Stores the Header's contents.
  • 4. CString, Instance Footer (2), optional: Stores the Footer's contents.

    Author:
    Yegor Kozlov

    Field Summary
    static int FOOTERATOM
    static int HEADERATOM
    static short NotesHeadersFootersContainer
    "instance" field in the record header indicating that this HeadersFootersContaine is applied for notes and handouts
    static short SlideHeadersFootersContainer
    "instance" field in the record header indicating that this HeadersFootersContaine is applied for slides
    static int USERDATEATOM
    Fields inherited from class org.apache.poi.hslf.record.RecordContainer
    _children
    Fields inherited from class org.apache.poi.hslf.record.Record
    logger
    Constructor Summary
    protected HeadersFootersContainer(byte[] source, int start, int len)
      HeadersFootersContainer(short options)
    Method Summary
     CString addFooterAtom()
    Insert a CString record that stores the user's date.
     CString addHeaderAtom()
    Insert a CString record that stores the user's date.
     CString addUserDateAtom()
    Insert a CString record that stores the user's date.
     CString getFooterAtom()
    A CString record that stores the Footers's contents.
     CString getHeaderAtom()
    A CString record that stores the Header's contents.
     HeadersFootersAtom getHeadersFootersAtom()
    HeadersFootersAtom stores the basic information of the header and footer structure.
     int getOptions()
    Must be either SlideHeadersFootersContainer or NotesHeadersFootersContainer
     long getRecordType()
    Return the type, which is RecordTypes.HeadersFooters
     CString getUserDateAtom()
    A CString record that stores the user's date.
     void writeOut(java.io.OutputStream out)
    Write the contents of the record back, so it can be written to disk
    Methods inherited from class org.apache.poi.hslf.record.RecordContainer
    addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
    Methods inherited from class org.apache.poi.hslf.record.Record
    buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
    Methods inherited from class java.lang.Object
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Field Detail

    SlideHeadersFootersContainer

    public static final short SlideHeadersFootersContainer
    "instance" field in the record header indicating that this HeadersFootersContaine is applied for slides

    See Also:
    Constant Field Values

    NotesHeadersFootersContainer

    public static final short NotesHeadersFootersContainer
    "instance" field in the record header indicating that this HeadersFootersContaine is applied for notes and handouts

    See Also:
    Constant Field Values

    USERDATEATOM

    public static final int USERDATEATOM
    See Also:
    Constant Field Values

    HEADERATOM

    public static final int HEADERATOM
    See Also:
    Constant Field Values

    FOOTERATOM

    public static final int FOOTERATOM
    See Also:
    Constant Field Values
    Constructor Detail

    HeadersFootersContainer

    protected HeadersFootersContainer(byte[] source,
                                  int start,
                                  int len)

    HeadersFootersContainer

    public HeadersFootersContainer(short options)
    Method Detail

    getRecordType

    public long getRecordType()
    Return the type, which is RecordTypes.HeadersFooters

    Specified by:
    getRecordType in class Record

    getOptions

    public int getOptions()
    Must be either SlideHeadersFootersContainer or NotesHeadersFootersContainer

    Returns:
    "instance" field in the record header

    writeOut

    public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
    Write the contents of the record back, so it can be written to disk

    Specified by:
    writeOut in class Record
    Throws:
    java.io.IOException

    getHeadersFootersAtom

    public HeadersFootersAtom getHeadersFootersAtom()
    HeadersFootersAtom stores the basic information of the header and footer structure.

    Returns:
    HeadersFootersAtom

    getUserDateAtom

    public CString getUserDateAtom()
    A CString record that stores the user's date.

    This is the date that the user wants in the footers, instead of today's date.

    Returns:
    A CString record that stores the user's date or null

    getHeaderAtom

    public CString getHeaderAtom()
    A CString record that stores the Header's contents.

    Returns:
    A CString record that stores the Header's contents or null

    getFooterAtom

    public CString getFooterAtom()
    A CString record that stores the Footers's contents.

    Returns:
    A CString record that stores the Footers's contents or null

    addUserDateAtom

    public CString addUserDateAtom()
    Insert a CString record that stores the user's date.

    Returns:
    the created CString record that stores the user's date.

    addHeaderAtom

    public CString addHeaderAtom()
    Insert a CString record that stores the user's date.

    Returns:
    the created CString record that stores the user's date.

    addFooterAtom

    public CString addFooterAtom()
    Insert a CString record that stores the user's date.

    Returns:
    the created CString record that stores the user's date.
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InteractiveInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class InteractiveInfo

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.InteractiveInfo

public class InteractiveInfo
extends RecordContainer

This class represents the metadata of a link in a slide/notes/etc. It normally just holds a InteractiveInfoAtom, with the metadata in it.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | InteractiveInfo() Create a new InteractiveInfo, with blank fields
protected | InteractiveInfo(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
InteractiveInfoAtom | getInteractiveInfoAtom() Returns the InteractiveInfoAtom of this InteractiveInfo
long | getRecordType() We are of type 4802
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InteractiveInfo

protected InteractiveInfo(byte[] source,
                          int start,
                          int len)
Set things up, and find our more interesting children

InteractiveInfo

public InteractiveInfo()
Create a new InteractiveInfo, with blank fields

Method Detail

getInteractiveInfoAtom

public InteractiveInfoAtom getInteractiveInfoAtom()
Returns the InteractiveInfoAtom of this InteractiveInfo

getRecordType

public long getRecordType()
We are of type 4802

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InteractiveInfoAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class InteractiveInfoAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.InteractiveInfoAtom

public class InteractiveInfoAtom
extends RecordAtom

Tne atom that holds metadata on Links in the document. (The actual link is held Document.ExObjList.ExHyperlink)

Author:
Nick Burch, Yegor Kozlov

Field Summary
static byte | ACTION_CUSTOMSHOW
static byte | ACTION_HYPERLINK
static byte | ACTION_JUMP
static byte | ACTION_MACRO
static byte | ACTION_MEDIA
static byte | ACTION_NONE Action Table
static byte | ACTION_OLE
static byte | ACTION_RUNPROGRAM
static byte | JUMP_ENDSHOW
static byte | JUMP_FIRSTSLIDE
static byte | JUMP_LASTSLIDE
static byte | JUMP_LASTSLIDEVIEWED
static byte | JUMP_NEXTSLIDE
static byte | JUMP_NONE Jump Table
static byte | JUMP_PREVIOUSSLIDE
static byte | LINK_CustomShow
static byte | LINK_FirstSlide
static byte | LINK_LastSlide
static byte | LINK_NextSlide Types of hyperlinks
static byte | LINK_NULL
static byte | LINK_OtherFile
static byte | LINK_OtherPresentation
static byte | LINK_PreviousSlide
static byte | LINK_SlideNumber
static byte | LINK_Url
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | InteractiveInfoAtom() Constructs a brand new link related atom record.
protected | InteractiveInfoAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
byte | getAction() Hyperlink Action.
byte | getFlags() Flags
int | getHyperlinkID() Gets the link number.
byte | getHyperlinkType() hyperlink type
byte | getJump() Jump
byte | getOleVerb() Only valid when action == OLEAction.
long | getRecordType() Gets the record type.
int | getSoundRef() a reference to a sound in the sound collection.
void | setAction(byte val) Hyperlink Action
void | setFlags(byte val) Flags
void | setHyperlinkID(int number) Sets the persistent unique identifier of the link
void | setHyperlinkType(byte val) hyperlink type
void | setJump(byte val) Jump
void | setOleVerb(byte val) Only valid when action == OLEAction.
void | setSoundRef(int val) a reference to a sound in the sound collection.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ACTION_NONE

public static final byte ACTION_NONE
Action Table

See Also:
Constant Field Values

ACTION_MACRO

public static final byte ACTION_MACRO
See Also:
Constant Field Values

ACTION_RUNPROGRAM

public static final byte ACTION_RUNPROGRAM
See Also:
Constant Field Values

ACTION_JUMP

public static final byte ACTION_JUMP
See Also:
Constant Field Values

ACTION_HYPERLINK

public static final byte ACTION_HYPERLINK
See Also:
Constant Field Values

ACTION_OLE

public static final byte ACTION_OLE
See Also:
Constant Field Values

ACTION_MEDIA

public static final byte ACTION_MEDIA
See Also:
Constant Field Values

ACTION_CUSTOMSHOW

public static final byte ACTION_CUSTOMSHOW
See Also:
Constant Field Values

JUMP_NONE

public static final byte JUMP_NONE
Jump Table

See Also:
Constant Field Values

JUMP_NEXTSLIDE

public static final byte JUMP_NEXTSLIDE
See Also:
Constant Field Values

JUMP_PREVIOUSSLIDE

public static final byte JUMP_PREVIOUSSLIDE
See Also:
Constant Field Values

JUMP_FIRSTSLIDE

public static final byte JUMP_FIRSTSLIDE
See Also:
Constant Field Values

JUMP_LASTSLIDE

public static final byte JUMP_LASTSLIDE
See Also:
Constant Field Values

JUMP_LASTSLIDEVIEWED

public static final byte JUMP_LASTSLIDEVIEWED
See Also:
Constant Field Values

JUMP_ENDSHOW

public static final byte JUMP_ENDSHOW
See Also:
Constant Field Values

LINK_NextSlide

public static final byte LINK_NextSlide
Types of hyperlinks

See Also:
Constant Field Values

LINK_PreviousSlide

public static final byte LINK_PreviousSlide
See Also:
Constant Field Values

LINK_FirstSlide

public static final byte LINK_FirstSlide
See Also:
Constant Field Values

LINK_LastSlide

public static final byte LINK_LastSlide
See Also:
Constant Field Values

LINK_CustomShow

public static final byte LINK_CustomShow
See Also:
Constant Field Values

LINK_SlideNumber

public static final byte LINK_SlideNumber
See Also:
Constant Field Values

LINK_Url

public static final byte LINK_Url
See Also:
Constant Field Values

LINK_OtherPresentation

public static final byte LINK_OtherPresentation
See Also:
Constant Field Values

LINK_OtherFile

public static final byte LINK_OtherFile
See Also:
Constant Field Values

LINK_NULL

public static final byte LINK_NULL
See Also:
Constant Field Values
Constructor Detail

InteractiveInfoAtom

protected InteractiveInfoAtom()
Constructs a brand new link related atom record.

InteractiveInfoAtom

protected InteractiveInfoAtom(byte[] source,
                              int start,
                              int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getHyperlinkID

public int getHyperlinkID()
Gets the link number. You will normally look the ExHyperlink with this number to get the details.

Returns:
the link number

setHyperlinkID

public void setHyperlinkID(int number)
Sets the persistent unique identifier of the link

Parameters:
number - the persistent unique identifier of the link

getSoundRef

public int getSoundRef()
a reference to a sound in the sound collection.

setSoundRef

public void setSoundRef(int val)
a reference to a sound in the sound collection.

Parameters:
val - a reference to a sound in the sound collection

getAction

public byte getAction()
Hyperlink Action.

see ACTION_* constants for the list of actions

Returns:
hyperlink action.

setAction

public void setAction(byte val)
Hyperlink Action

see ACTION_* constants for the list of actions

Parameters:
val - hyperlink action.

getOleVerb

public byte getOleVerb()
Only valid when action == OLEAction. OLE verb to use, 0 = first verb, 1 = second verb, etc.

setOleVerb

public void setOleVerb(byte val)
Only valid when action == OLEAction. OLE verb to use, 0 = first verb, 1 = second verb, etc.

getJump

public byte getJump()
Jump

see JUMP_* constants for the list of actions

Returns:
jump

setJump

public void setJump(byte val)
Jump

see JUMP_* constants for the list of actions

Parameters:
val - jump

getFlags

public byte getFlags()
Flags

  • Bit 1: Animated. If 1, then button is animated
  • Bit 2: Stop sound. If 1, then stop current sound when button is pressed.
  • Bit 3: CustomShowReturn. If 1, and this is a jump to custom show, then return to this slide after custom show.

    • setFlags

    public void setFlags(byte val)
    Flags

  • Bit 1: Animated. If 1, then button is animated
  • Bit 2: Stop sound. If 1, then stop current sound when button is pressed.
  • Bit 3: CustomShowReturn. If 1, and this is a jump to custom show, then return to this slide after custom show.

    • getHyperlinkType

    public byte getHyperlinkType()
    hyperlink type

    Returns:
    hyperlink type

    setHyperlinkType

    public void setHyperlinkType(byte val)
    hyperlink type

    Parameters:
    val - hyperlink type

    getRecordType

    public long getRecordType()
    Gets the record type.

    Specified by:
    getRecordType in class Record
    Returns:
    the record type.

    writeOut

    public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
    Write the contents of the record back, so it can be written to disk

    Specified by:
    writeOut in class Record
    Parameters:
    out - the output stream to write to.
    Throws:
    java.io.IOException - if an error occurs.
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MainMaster

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class MainMaster

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
                extended by  org.apache.poi.hslf.record.SheetContainer
                    extended by  org.apache.poi.hslf.record.MainMaster
All Implemented Interfaces:
PositionDependentRecord
public final class MainMaster
extends SheetContainer

Master slide

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected MainMaster(byte[] source, int start, int len)
Set things up, and find our more interesting children
Method Summary
ColorSchemeAtom | getColorScheme()
ColorSchemeAtom[] | getColorSchemeAtoms()
PPDrawing | getPPDrawing() Returns the PPDrawing of this Slide, which has all the interesting data in it
long | getRecordType() We are of type 1016
SlideAtom | getSlideAtom() Returns the SlideAtom of this Slide
TxMasterStyleAtom[] | getTxMasterStyleAtoms()
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
getLastOnDiskOffset, getSheetId, setLastOnDiskOffset, setSheetId, updateOtherRecordReferences
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MainMaster

protected MainMaster(byte[] source,
                     int start,
                     int len)
Set things up, and find our more interesting children

Method Detail

getSlideAtom

public SlideAtom getSlideAtom()
Returns the SlideAtom of this Slide

getPPDrawing

public PPDrawing getPPDrawing()
Returns the PPDrawing of this Slide, which has all the interesting data in it

Specified by:
getPPDrawing in class SheetContainer

getTxMasterStyleAtoms

public TxMasterStyleAtom[] getTxMasterStyleAtoms()

getColorSchemeAtoms

public ColorSchemeAtom[] getColorSchemeAtoms()

getRecordType

public long getRecordType()
We are of type 1016

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getColorScheme

public ColorSchemeAtom getColorScheme()
Specified by:
getColorScheme in class SheetContainer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Notes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Notes

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
                extended by  org.apache.poi.hslf.record.SheetContainer
                    extended by  org.apache.poi.hslf.record.Notes
All Implemented Interfaces:
PositionDependentRecord
public final class Notes
extends SheetContainer

Master container for Notes. There is one of these for every page of notes, and they have certain specific children

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected Notes(byte[] source, int start, int len)
Set things up, and find our more interesting children
Method Summary
ColorSchemeAtom | getColorScheme()
NotesAtom | getNotesAtom() Returns the NotesAtom of this Notes
PPDrawing | getPPDrawing() Returns the PPDrawing of this Notes, which has all the interesting data in it
long | getRecordType() We are of type 1008
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
getLastOnDiskOffset, getSheetId, setLastOnDiskOffset, setSheetId, updateOtherRecordReferences
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Notes

protected Notes(byte[] source,
                int start,
                int len)
Set things up, and find our more interesting children

Method Detail

getNotesAtom

public NotesAtom getNotesAtom()
Returns the NotesAtom of this Notes

getPPDrawing

public PPDrawing getPPDrawing()
Returns the PPDrawing of this Notes, which has all the interesting data in it

Specified by:
getPPDrawing in class SheetContainer

getRecordType

public long getRecordType()
We are of type 1008

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getColorScheme

public ColorSchemeAtom getColorScheme()
Specified by:
getColorScheme in class SheetContainer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotesAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class NotesAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.NotesAtom

public final class NotesAtom
extends RecordAtom

A Notes Atom (type 1009). Holds information on the parent Notes, such as what slide it is tied to

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected NotesAtom(byte[] source, int start, int len)
For the Notes Atom
Method Summary
boolean | getFollowMasterBackground()
boolean | getFollowMasterObjects()
boolean | getFollowMasterScheme()
long | getRecordType() We are of type 1009
int | getSlideID()
void | setFollowMasterBackground(boolean flag)
void | setFollowMasterObjects(boolean flag)
void | setFollowMasterScheme(boolean flag)
void | setSlideID(int id)
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotesAtom

protected NotesAtom(byte[] source,
                    int start,
                    int len)
For the Notes Atom

Method Detail

getSlideID

public int getSlideID()

setSlideID

public void setSlideID(int id)

getFollowMasterObjects

public boolean getFollowMasterObjects()

getFollowMasterScheme

public boolean getFollowMasterScheme()

getFollowMasterBackground

public boolean getFollowMasterBackground()

setFollowMasterObjects

public void setFollowMasterObjects(boolean flag)

setFollowMasterScheme

public void setFollowMasterScheme(boolean flag)

setFollowMasterBackground

public void setFollowMasterBackground(boolean flag)

getRecordType

public long getRecordType()
We are of type 1009

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OEPlaceholderAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class OEPlaceholderAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.OEPlaceholderAtom

public final class OEPlaceholderAtom
extends RecordAtom

OEPlaceholderAtom (3011).

An atom record that specifies whether a shape is a placeholder shape.

Author:
Yegor Kozlov

Field Summary
static byte | Body The corresponding shape contains the body text.
static byte | CenteredTitle The corresponding shape contains the title text.
static byte | ClipArt The corresponding shape contains a clipart object.
static byte | Graph The corresponding shape contains a chart object.
static byte | MasterBody The corresponding shape contains the master body text.
static byte | MasterCenteredTitle The corresponding shape contains the master center title text.
static byte | MasterDate The corresponding shape contains the date text field.
static byte | MasterFooter The corresponding shape contains a footer text field.
static byte | MasterHeader The corresponding shape contains a header text field.
static byte | MasterNotesBody The corresponding shape contains the master body text.
static byte | MasterNotesSlideImage The corresponding shape contains the shared properties for slide image shapes.
static byte | MasterSlideNumber The corresponding shape contains a slide number text field.
static byte | MasterSubTitle The corresponding shape contains the master sub-title text.
static byte | MasterTitle The corresponding shape contains the master title text.
static byte | MediaClip The corresponding shape contains a media object.
static byte | None MUST NOT be used for this field.
static byte | NotesBody The corresponding shape contains the notes text.
static byte | NotesSlideImage The corresponding shape contains a presentation slide image.
static byte | Object The corresponding shape contains a generic object.
static byte | OrganizationChart The corresponding shape contains an organization chart object.
static int | PLACEHOLDER_FULLSIZE The full size of the master body text placeholder shape.
static int | PLACEHOLDER_HALFSIZE Half of the size of the master body text placeholder shape.
static int | PLACEHOLDER_QUARTSIZE A quarter of the size of the master body text placeholder shape.
static byte | Subtitle The corresponding shape contains the sub-title text.
static byte | Table The corresponding shape contains a table object.
static byte | Title The corresponding shape contains the title text.
static byte | VerticalTextBody The corresponding shape contains the body text with vertical text flow.
static byte | VerticalTextTitle The corresponding shape contains the title text with vertical text flow.
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | OEPlaceholderAtom() Create a new instance of OEPlaceholderAtom
protected | OEPlaceholderAtom(byte[] source, int start, int len) Build an instance of OEPlaceholderAtom from on-disk data
Method Summary
int | getPlaceholderId() Returns the placeholder Id.
int | getPlaceholderSize() Returns the placeholder size.
int | getPlacementId() Returns the placement Id.
long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles
void | setPlaceholderId(byte id) Sets the placeholder Id.
void | setPlaceholderSize(byte size) Sets the placeholder size.
void | setPlacementId(int id) Sets the placement Id.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PLACEHOLDER_FULLSIZE

public static final int PLACEHOLDER_FULLSIZE
The full size of the master body text placeholder shape.

See Also:
Constant Field Values

PLACEHOLDER_HALFSIZE

public static final int PLACEHOLDER_HALFSIZE
Half of the size of the master body text placeholder shape.

See Also:
Constant Field Values

PLACEHOLDER_QUARTSIZE

public static final int PLACEHOLDER_QUARTSIZE
A quarter of the size of the master body text placeholder shape.

See Also:
Constant Field Values

None

public static final byte None
MUST NOT be used for this field.

See Also:
Constant Field Values

MasterTitle

public static final byte MasterTitle
The corresponding shape contains the master title text. The corresponding slide MUST be a main master slide.

See Also:
Constant Field Values

MasterBody

public static final byte MasterBody
The corresponding shape contains the master body text. The corresponding slide MUST be a main master slide.

See Also:
Constant Field Values

MasterCenteredTitle

public static final byte MasterCenteredTitle
The corresponding shape contains the master center title text. The corresponding slide MUST be a title master slide.

See Also:
Constant Field Values

MasterSubTitle

public static final byte MasterSubTitle
The corresponding shape contains the master sub-title text. The corresponding slide MUST be a title master slide.

See Also:
Constant Field Values

MasterNotesSlideImage

public static final byte MasterNotesSlideImage
The corresponding shape contains the shared properties for slide image shapes. The corresponding slide MUST be a notes master slide.

See Also:
Constant Field Values

MasterNotesBody

public static final byte MasterNotesBody
The corresponding shape contains the master body text. The corresponding slide MUST be a notes master slide.

See Also:
Constant Field Values

MasterDate

public static final byte MasterDate
The corresponding shape contains the date text field. The corresponding slide MUST be a main master slide, title master slide, notes master slide, or handout master slide.

See Also:
Constant Field Values

MasterSlideNumber

public static final byte MasterSlideNumber
The corresponding shape contains a slide number text field. The corresponding slide MUST be a main master slide, title master slide, notes master slide, or handout master slide.

See Also:
Constant Field Values

MasterFooter

public static final byte MasterFooter
The corresponding shape contains a footer text field. The corresponding slide MUST be a main master slide, title master slide, notes master slide, or handout master slide.

See Also:
Constant Field Values

MasterHeader

public static final byte MasterHeader
The corresponding shape contains a header text field. The corresponding slide must be a notes master slide or handout master slide.

See Also:
Constant Field Values

NotesSlideImage

public static final byte NotesSlideImage
The corresponding shape contains a presentation slide image. The corresponding slide MUST be a notes slide.

See Also:
Constant Field Values

NotesBody

public static final byte NotesBody
The corresponding shape contains the notes text. The corresponding slide MUST be a notes slide.

See Also:
Constant Field Values

Title

public static final byte Title
The corresponding shape contains the title text. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

Body

public static final byte Body
The corresponding shape contains the body text. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

CenteredTitle

public static final byte CenteredTitle
The corresponding shape contains the title text. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

Subtitle

public static final byte Subtitle
The corresponding shape contains the sub-title text. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

VerticalTextTitle

public static final byte VerticalTextTitle
The corresponding shape contains the title text with vertical text flow. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

VerticalTextBody

public static final byte VerticalTextBody
The corresponding shape contains the body text with vertical text flow. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

Object

public static final byte Object
The corresponding shape contains a generic object. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

Graph

public static final byte Graph
The corresponding shape contains a chart object. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

Table

public static final byte Table
The corresponding shape contains a table object. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

ClipArt

public static final byte ClipArt
The corresponding shape contains a clipart object. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

OrganizationChart

public static final byte OrganizationChart
The corresponding shape contains an organization chart object. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values

MediaClip

public static final byte MediaClip
The corresponding shape contains a media object. The corresponding slide MUST be a presentation slide.

See Also:
Constant Field Values
Constructor Detail

OEPlaceholderAtom

public OEPlaceholderAtom()
Create a new instance of OEPlaceholderAtom

OEPlaceholderAtom

protected OEPlaceholderAtom(byte[] source,
                            int start,
                            int len)
Build an instance of OEPlaceholderAtom from on-disk data

Method Detail

getRecordType

public long getRecordType()
Description copied from class: Record
Returns the type (held as a little endian in bytes 3 and 4) that this class handles

Specified by:
getRecordType in class Record
Returns:
type of this record RecordTypes.OEPlaceholderAtom.

getPlacementId

public int getPlacementId()
Returns the placement Id.

The placement Id is a number assigned to the placeholder. It goes from -1 to the number of placeholders. It SHOULD be unique among all PlacholderAtom records contained in the corresponding slide. The value 0xFFFFFFFF specifies that the corresponding shape is not a placeholder shape.

Returns:
the placement Id.

setPlacementId

public void setPlacementId(int id)
Sets the placement Id.

The placement Id is a number assigned to the placeholder. It goes from -1 to the number of placeholders. It SHOULD be unique among all PlacholderAtom records contained in the corresponding slide. The value 0xFFFFFFFF specifies that the corresponding shape is not a placeholder shape.

Parameters:
id - the placement Id.

getPlaceholderId

public int getPlaceholderId()
Returns the placeholder Id.

placeholder Id specifies the type of the placeholder shape. The value MUST be one of the static constants defined in this class

Returns:
the placeholder Id.

setPlaceholderId

public void setPlaceholderId(byte id)
Sets the placeholder Id.

placeholder Id specifies the type of the placeholder shape. The value MUST be one of the static constants defined in this class

Parameters:
id - the placeholder Id.

getPlaceholderSize

public int getPlaceholderSize()
Returns the placeholder size. Must be one of the PLACEHOLDER_* static constants defined in this class.

Returns:
the placeholder size.

setPlaceholderSize

public void setPlaceholderSize(byte size)
Sets the placeholder size. Must be one of the PLACEHOLDER_* static constants defined in this class.

Parameters:
size - the placeholder size.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OEShapeAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class OEShapeAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.OEShapeAtom

public final class OEShapeAtom
extends RecordAtom

Atom that contains information that describes shape client data.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | OEShapeAtom() Constructs a brand new link related atom record.
protected | OEShapeAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
int | getOptions() shape flags.
long | getRecordType() Gets the record type.
void | setOptions(int id) shape flags.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OEShapeAtom

public OEShapeAtom()
Constructs a brand new link related atom record.

OEShapeAtom

protected OEShapeAtom(byte[] source,
                      int start,
                      int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.

getOptions

public int getOptions()
shape flags.

Returns:
shape flags.

setOptions

public void setOptions(int id)
shape flags.

Parameters:
id - shape flags.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OutlineTextRefAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class OutlineTextRefAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.OutlineTextRefAtom

public final class OutlineTextRefAtom
extends RecordAtom

OEPlaceholderAtom (3998).
What MSDN says about OutlineTextRefAtom:

Appears in a slide to indicate a text that is already contained in the document, in a SlideListWithText containter. Sometimes slide texts are not contained within the slide container to be able to delay loading a slide and still display the title and body text in outline view.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | OutlineTextRefAtom() Create a new instance of FontEntityAtom
protected | OutlineTextRefAtom(byte[] source, int start, int len) Build an instance of OutlineTextRefAtom from on-disk data
Method Summary
long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles
int | getTextIndex() Return text's index within the SlideListWithText container (0 for title, 1..n for the nth body).
void | setTextIndex(int idx) Sets text's index within the SlideListWithText container (0 for title, 1..n for the nth body).
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OutlineTextRefAtom

protected OutlineTextRefAtom(byte[] source,
                             int start,
                             int len)
Build an instance of OutlineTextRefAtom from on-disk data

OutlineTextRefAtom

protected OutlineTextRefAtom()
Create a new instance of FontEntityAtom

Method Detail

getRecordType

public long getRecordType()
Description copied from class: Record
Returns the type (held as a little endian in bytes 3 and 4) that this class handles

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

setTextIndex

public void setTextIndex(int idx)
Sets text's index within the SlideListWithText container (0 for title, 1..n for the nth body).

Parameters:
idx - 0-based text's index

getTextIndex

public int getTextIndex()
Return text's index within the SlideListWithText container (0 for title, 1..n for the nth body).

Returns:
idx text's index
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.record
Interfaces
ParentAwareRecord
PersistRecord
PositionDependentRecord
Classes
AnimationInfo
AnimationInfoAtom
ColorSchemeAtom
Comment2000
Comment2000Atom
CString
CurrentUserAtom
Document
DocumentAtom
DocumentAtom.SlideSize
DocumentEncryptionAtom
DummyPositionSensitiveRecordWithChildren
DummyRecordWithChildren
Environment
EscherTextboxWrapper
ExAviMovie
ExControl
ExControlAtom
ExEmbed
ExEmbedAtom
ExHyperlink
ExHyperlinkAtom
ExMCIMovie
ExMediaAtom
ExObjList
ExObjListAtom
ExOleObjAtom
ExOleObjStg
ExVideoContainer
FontCollection
FontEntityAtom
HeadersFootersAtom
HeadersFootersContainer
InteractiveInfo
InteractiveInfoAtom
MainMaster
Notes
NotesAtom
OEPlaceholderAtom
OEShapeAtom
OutlineTextRefAtom
PersistPtrHolder
PositionDependentRecordAtom
PositionDependentRecordContainer
PPDrawing
PPDrawingGroup
Record
RecordAtom
RecordContainer
RecordTypes
RecordTypes.Type
RoundTripHFPlaceholder12
SheetContainer
Slide
SlideAtom
SlideListWithText
SlidePersistAtom
Sound
SoundCollection
SoundData
StyleTextPropAtom
TextBytesAtom
TextCharsAtom
TextHeaderAtom
TextRulerAtom
TextSpecInfoAtom
TextSpecInfoAtom.TextSpecInfoRun
TxInteractiveInfoAtom
TxMasterStyleAtom
UnknownRecordPlaceholder
UserEditAtom


org.apache.poi.hslf.record

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.record

Interface Summary
ParentAwareRecord | Interface to define how a record can indicate it cares about what its parent is, and how it wants to be told which record is its parent.
PersistRecord | A record that can be referenced in PersistPtr storage.
PositionDependentRecord | Records which either care about where they are on disk, or have other records who care about where they are, will implement this interface.

Class Summary
AnimationInfo | A container record that specifies information about animation information for a shape.
AnimationInfoAtom | An atom record that specifies the animation information for a shape.
ColorSchemeAtom | A ColorSchemeAtom (type 2032).
Comment2000 | This class represents a comment on a slide, in the format used by PPT 2000/XP/etc.
Comment2000Atom | An atomic record containing information about a comment.
CString | A CString (type 4026).
CurrentUserAtom | This is a special kind of Atom, becauase it doesn't live inside the PowerPoint document.
Document | Master container for Document.
DocumentAtom | A Document Atom (type 1001).
DocumentAtom.SlideSize | Holds the different Slide Size values
DocumentEncryptionAtom | A Document Encryption Atom (type 12052).
DummyPositionSensitiveRecordWithChildren | If we come across a record we know has children of (potential) interest, but where the record itself is boring, but where other records may care about where this one lives, we create one of these.
DummyRecordWithChildren | If we come across a record we know has children of (potential) interest, but where the record itself is boring, we create one of these.
Environment | Environment, which contains lots of settings for the document.
EscherTextboxWrapper | A wrapper around a DDF (Escher) EscherTextbox Record.
ExAviMovie | A container record that specifies information about a movie stored externally.
ExControl | A container record that specifies information about an ActiveX control.
ExControlAtom | An atom record that specifies an ActiveX control.
ExEmbed | This data represents an embedded object in the document.
ExEmbedAtom | The atom that holds metadata on a specific embedded object in the document.
ExHyperlink | This class represents the data of a link in the document.
ExHyperlinkAtom | Tne atom that holds metadata on a specific Link in the document.
ExMCIMovie | A container record that specifies information about a movie stored externally.
ExMediaAtom | An atom record that specifies information about external audio or video data.
ExObjList | This class holds the links to exernal objects referenced from the document.
ExObjListAtom | Tne atom that holds the seed info used by a ExObjList
ExOleObjAtom | Atom storing information for an OLE object.
ExOleObjStg | Storage for embedded OLE objects.
ExVideoContainer | A container record that specifies information about external video data.
FontCollection | FontCollection ia a container that holds information about all the fonts in the presentation.
FontEntityAtom | This atom corresponds exactly to a Windows Logical Font (LOGFONT) structure.
HeadersFootersAtom | An atom record that specifies options for displaying headers and footers on a presentation slide or notes slide.
HeadersFootersContainer | A container record that specifies information about the footers on a presentation slide.
InteractiveInfo | This class represents the metadata of a link in a slide/notes/etc.
InteractiveInfoAtom | Tne atom that holds metadata on Links in the document.
MainMaster | Master slide
Notes | Master container for Notes.
NotesAtom | A Notes Atom (type 1009).
OEPlaceholderAtom | OEPlaceholderAtom (3011).
OEShapeAtom | Atom that contains information that describes shape client data.
OutlineTextRefAtom | OEPlaceholderAtom (3998).
PersistPtrHolder | General holder for PersistPtrFullBlock and PersistPtrIncrementalBlock records.
PositionDependentRecordAtom | A special (and dangerous) kind of Record Atom that cares about where it lives on the disk, or who has other Atoms that care about where this is on the disk.
PositionDependentRecordContainer | A special (and dangerous) kind of Record Container, for which other Atoms care about where this one lives on disk.
PPDrawing | These are actually wrappers onto Escher drawings.
PPDrawingGroup | Container records which always exists inside Document.
Record | This abstract class represents a record in the PowerPoint document.
RecordAtom | Abstract class which all atom records will extend.
RecordContainer | Abstract class which all container records will extend.
RecordTypes | List of all known record types in a PowerPoint document, and the classes that handle them.
RecordTypes.Type | Wrapper for the details of a PowerPoint or Escher record type.
RoundTripHFPlaceholder12 | An atom record that specifies that a shape is a header or footer placeholder shape
SheetContainer | The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
Slide | Master container for Slides.
SlideAtom | A Slide Atom (type 1007).
SlideListWithText | These are tricky beasts.
SlidePersistAtom | A SlidePersist Atom (type 1011).
Sound | A container holding information about a sound.
SoundCollection | Is a container for all sound related atoms and containers.
SoundData | Storage for embedded sounds.
StyleTextPropAtom | A StyleTextPropAtom (type 4001).
TextBytesAtom | A TextBytesAtom (type 4008).
TextCharsAtom | A TextCharsAtom (type 4000).
TextHeaderAtom | A TextHeaderAtom (type 3999).
TextRulerAtom | Ruler of a text as it differs from the style's ruler settings.
TextSpecInfoAtom | The special info runs contained in this text.
TextSpecInfoAtom.TextSpecInfoRun |
TxInteractiveInfoAtom | Tne atom that holds starting and ending character positions of a hyperlink
TxMasterStyleAtom | TxMasterStyleAtom atom (4003).
UnknownRecordPlaceholder | If we come across a record we don't know about, we create one of these.
UserEditAtom | A UserEdit Atom (type 4085).


org.apache.poi.hslf.record Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.record

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.record.CurrentUserAtom
    • org.apache.poi.hslf.record.DocumentAtom.SlideSize
    • org.apache.poi.hslf.record.Record
      • org.apache.poi.hslf.record.RecordAtom
        • org.apache.poi.hslf.record.AnimationInfoAtom
        • org.apache.poi.hslf.record.ColorSchemeAtom
        • org.apache.poi.hslf.record.Comment2000Atom
        • org.apache.poi.hslf.record.CString
        • org.apache.poi.hslf.record.DocumentAtom
        • org.apache.poi.hslf.record.DocumentEncryptionAtom
        • org.apache.poi.hslf.record.ExControlAtom
        • org.apache.poi.hslf.record.ExEmbedAtom
        • org.apache.poi.hslf.record.ExHyperlinkAtom
        • org.apache.poi.hslf.record.ExMediaAtom
        • org.apache.poi.hslf.record.ExObjListAtom
        • org.apache.poi.hslf.record.ExOleObjAtom
        • org.apache.poi.hslf.record.ExOleObjStg (implements org.apache.poi.hslf.record.PersistRecord, org.apache.poi.hslf.record.PositionDependentRecord)
        • org.apache.poi.hslf.record.FontEntityAtom
        • org.apache.poi.hslf.record.HeadersFootersAtom
        • org.apache.poi.hslf.record.InteractiveInfoAtom
        • org.apache.poi.hslf.record.NotesAtom
        • org.apache.poi.hslf.record.OEPlaceholderAtom
        • org.apache.poi.hslf.record.OEShapeAtom
        • org.apache.poi.hslf.record.OutlineTextRefAtom
        • org.apache.poi.hslf.record.PositionDependentRecordAtom (implements org.apache.poi.hslf.record.PositionDependentRecord)
          • org.apache.poi.hslf.record.PersistPtrHolder
          • org.apache.poi.hslf.record.UserEditAtom
        • org.apache.poi.hslf.record.PPDrawing
        • org.apache.poi.hslf.record.PPDrawingGroup
        • org.apache.poi.hslf.record.RoundTripHFPlaceholder12
        • org.apache.poi.hslf.record.SlideAtom
        • org.apache.poi.hslf.record.SlidePersistAtom
        • org.apache.poi.hslf.record.SoundData
        • org.apache.poi.hslf.record.StyleTextPropAtom
        • org.apache.poi.hslf.record.TextBytesAtom
        • org.apache.poi.hslf.record.TextCharsAtom
        • org.apache.poi.hslf.record.TextHeaderAtom (implements org.apache.poi.hslf.record.ParentAwareRecord)
        • org.apache.poi.hslf.record.TextRulerAtom
        • org.apache.poi.hslf.record.TextSpecInfoAtom
        • org.apache.poi.hslf.record.TxInteractiveInfoAtom
        • org.apache.poi.hslf.record.TxMasterStyleAtom
        • org.apache.poi.hslf.record.UnknownRecordPlaceholder
      • org.apache.poi.hslf.record.RecordContainer
        • org.apache.poi.hslf.record.AnimationInfo
        • org.apache.poi.hslf.record.Comment2000
        • org.apache.poi.hslf.record.DummyRecordWithChildren
        • org.apache.poi.hslf.record.EscherTextboxWrapper
        • org.apache.poi.hslf.record.ExEmbed
          • org.apache.poi.hslf.record.ExControl
        • org.apache.poi.hslf.record.ExHyperlink
        • org.apache.poi.hslf.record.ExMCIMovie
          • org.apache.poi.hslf.record.ExAviMovie
        • org.apache.poi.hslf.record.ExObjList
        • org.apache.poi.hslf.record.ExVideoContainer
        • org.apache.poi.hslf.record.FontCollection
        • org.apache.poi.hslf.record.HeadersFootersContainer
        • org.apache.poi.hslf.record.InteractiveInfo
        • org.apache.poi.hslf.record.PositionDependentRecordContainer (implements org.apache.poi.hslf.record.PositionDependentRecord)
          • org.apache.poi.hslf.record.Document
          • org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren
          • org.apache.poi.hslf.record.Environment
          • org.apache.poi.hslf.record.SheetContainer
            • org.apache.poi.hslf.record.MainMaster
            • org.apache.poi.hslf.record.Notes
            • org.apache.poi.hslf.record.Slide
        • org.apache.poi.hslf.record.SlideListWithText
        • org.apache.poi.hslf.record.Sound
        • org.apache.poi.hslf.record.SoundCollection
    • org.apache.poi.hslf.record.RecordTypes
    • org.apache.poi.hslf.record.RecordTypes.Type
    • org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
    • org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet
    • org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

Interface Hierarchy

  • org.apache.poi.hslf.record.ParentAwareRecord
  • org.apache.poi.hslf.record.PersistRecord
  • org.apache.poi.hslf.record.PositionDependentRecord


Uses of Package org.apache.poi.hslf.record

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.record

Packages that use org.apache.poi.hslf.record
org.apache.poi.hslf
org.apache.poi.hslf.dev
org.apache.poi.hslf.model
org.apache.poi.hslf.record
org.apache.poi.hslf.usermodel

Classes in org.apache.poi.hslf.record used by org.apache.poi.hslf
CurrentUserAtom
This is a special kind of Atom, becauase it doesn't live inside the PowerPoint document.
DocumentEncryptionAtom
A Document Encryption Atom (type 12052).
Record
This abstract class represents a record in the PowerPoint document.

Classes in org.apache.poi.hslf.record used by org.apache.poi.hslf.dev
Record
This abstract class represents a record in the PowerPoint document.
StyleTextPropAtom
A StyleTextPropAtom (type 4001).

Classes in org.apache.poi.hslf.record used by org.apache.poi.hslf.model
ColorSchemeAtom
A ColorSchemeAtom (type 2032).
Comment2000
This class represents a comment on a slide, in the format used by PPT 2000/XP/etc.
EscherTextboxWrapper
A wrapper around a DDF (Escher) EscherTextbox Record.
ExControl
A container record that specifies information about an ActiveX control.
ExEmbed
This data represents an embedded object in the document.
FontEntityAtom
This atom corresponds exactly to a Windows Logical Font (LOGFONT) structure.
HeadersFootersContainer
A container record that specifies information about the footers on a presentation slide.
MainMaster
Master slide
Notes
Master container for Notes.
OEPlaceholderAtom
OEPlaceholderAtom (3011).
PPDrawing
These are actually wrappers onto Escher drawings.
Record
This abstract class represents a record in the PowerPoint document.
SheetContainer
The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
Slide
Master container for Slides.
SlideListWithText.SlideAtomsSet
Inner class to wrap up a matching set of records that hold the text for a given sheet.
StyleTextPropAtom
A StyleTextPropAtom (type 4001).
TextBytesAtom
A TextBytesAtom (type 4008).
TextCharsAtom
A TextCharsAtom (type 4000).
TextHeaderAtom
A TextHeaderAtom (type 3999).
TextRulerAtom
Ruler of a text as it differs from the style's ruler settings.
TxMasterStyleAtom
TxMasterStyleAtom atom (4003).

Classes in org.apache.poi.hslf.record used by org.apache.poi.hslf.record
AnimationInfoAtom
An atom record that specifies the animation information for a shape.
ColorSchemeAtom
A ColorSchemeAtom (type 2032).
Comment2000Atom
An atomic record containing information about a comment.
CString
A CString (type 4026).
DocumentAtom
A Document Atom (type 1001).
Environment
Environment, which contains lots of settings for the document.
EscherTextboxWrapper
A wrapper around a DDF (Escher) EscherTextbox Record.
ExControlAtom
An atom record that specifies an ActiveX control.
ExEmbed
This data represents an embedded object in the document.
ExEmbedAtom
The atom that holds metadata on a specific embedded object in the document.
ExHyperlink
This class represents the data of a link in the document.
ExHyperlinkAtom
Tne atom that holds metadata on a specific Link in the document.
ExMCIMovie
A container record that specifies information about a movie stored externally.
ExMediaAtom
An atom record that specifies information about external audio or video data.
ExObjList
This class holds the links to exernal objects referenced from the document.
ExObjListAtom
Tne atom that holds the seed info used by a ExObjList
ExOleObjAtom
Atom storing information for an OLE object.
ExVideoContainer
A container record that specifies information about external video data.
FontCollection
FontCollection ia a container that holds information about all the fonts in the presentation.
HeadersFootersAtom
An atom record that specifies options for displaying headers and footers on a presentation slide or notes slide.
InteractiveInfoAtom
Tne atom that holds metadata on Links in the document.
NotesAtom
A Notes Atom (type 1009).
ParentAwareRecord
Interface to define how a record can indicate it cares about what its parent is, and how it wants to be told which record is its parent.
PersistRecord
A record that can be referenced in PersistPtr storage.
PositionDependentRecord
Records which either care about where they are on disk, or have other records who care about where they are, will implement this interface.
PositionDependentRecordAtom
A special (and dangerous) kind of Record Atom that cares about where it lives on the disk, or who has other Atoms that care about where this is on the disk.
PositionDependentRecordContainer
A special (and dangerous) kind of Record Container, for which other Atoms care about where this one lives on disk.
PPDrawing
These are actually wrappers onto Escher drawings.
PPDrawingGroup
Container records which always exists inside Document.
Record
This abstract class represents a record in the PowerPoint document.
RecordAtom
Abstract class which all atom records will extend.
RecordContainer
Abstract class which all container records will extend.
RecordTypes.Type
Wrapper for the details of a PowerPoint or Escher record type.
SheetContainer
The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
SlideAtom
A Slide Atom (type 1007).
SlideAtom.SSlideLayoutAtom
Holds the geometry of the Slide, and the ID of the placeholders on the slide.
SlideListWithText
These are tricky beasts.
SlideListWithText.SlideAtomsSet
Inner class to wrap up a matching set of records that hold the text for a given sheet.
SlidePersistAtom
A SlidePersist Atom (type 1011).
TextRulerAtom
Ruler of a text as it differs from the style's ruler settings.
TextSpecInfoAtom.TextSpecInfoRun
TxMasterStyleAtom
TxMasterStyleAtom atom (4003).

Classes in org.apache.poi.hslf.record used by org.apache.poi.hslf.usermodel
Document
Master container for Document.
ExOleObjStg
Storage for embedded OLE objects.
FontCollection
FontCollection ia a container that holds information about all the fonts in the presentation.
Record
This abstract class represents a record in the PowerPoint document.
Sound
A container holding information about a sound.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ParentAwareRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Interface ParentAwareRecord

All Known Implementing Classes:
TextHeaderAtom
public interface ParentAwareRecord

Interface to define how a record can indicate it cares about what its parent is, and how it wants to be told which record is its parent.

Author:
Nick Burch (nick at torchbox dot com)

Method Summary
RecordContainer | getParentRecord()
void | setParentRecord(RecordContainer parentRecord)

Method Detail

getParentRecord

RecordContainer getParentRecord()

setParentRecord

void setParentRecord(RecordContainer parentRecord)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistPtrHolder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class PersistPtrHolder

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.PositionDependentRecordAtom
                extended by  org.apache.poi.hslf.record.PersistPtrHolder
All Implemented Interfaces:
PositionDependentRecord
public final class PersistPtrHolder
extends PositionDependentRecordAtom

General holder for PersistPtrFullBlock and PersistPtrIncrementalBlock records. We need to handle them specially, since we have to go around updating UserEditAtoms if they shuffle about on disk These hold references to where slides "live". If the position of a slide moves, then we have update all of these. If we come up with a new version of a slide, then we have to add one of these to the end of the chain (via CurrentUserAtom and UserEditAtom) pointing to the new slide location

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordAtom
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected PersistPtrHolder(byte[] source, int start, int len)
Create a new holder for a PersistPtr record
Method Summary
void | addSlideLookup(int slideID, int posOnDisk) Adds a new slide, notes or similar, to be looked up by this.
int[] | getKnownSlideIDs() Get the list of slides that this PersistPtrHolder knows about.
long | getRecordType() Return the value we were given at creation, be it 6001 or 6002
java.util.Hashtable<java.lang.Integer,java.lang.Integer> | getSlideLocationsLookup() Get the lookup from slide numbers to byte offsets, for the slides known about by this PersistPtrHolder.
java.util.Hashtable<java.lang.Integer,java.lang.Integer> | getSlideOffsetDataLocationsLookup() Get the lookup from slide numbers to their offsets inside _ptrData, used when adding or moving slides.
void | updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup) At write-out time, update the references to the sheets to their new positions
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordAtom
getLastOnDiskOffset, setLastOnDiskOffset
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PersistPtrHolder

protected PersistPtrHolder(byte[] source,
                           int start,
                           int len)
Create a new holder for a PersistPtr record

Method Detail

getKnownSlideIDs

public int[] getKnownSlideIDs()
Get the list of slides that this PersistPtrHolder knows about. (They will be the keys in the hashtable for looking up the positions of these slides)

getSlideLocationsLookup

public java.util.Hashtable<java.lang.Integer,java.lang.Integer> getSlideLocationsLookup()
Get the lookup from slide numbers to byte offsets, for the slides known about by this PersistPtrHolder.

getSlideOffsetDataLocationsLookup

public java.util.Hashtable<java.lang.Integer,java.lang.Integer> getSlideOffsetDataLocationsLookup()
Get the lookup from slide numbers to their offsets inside _ptrData, used when adding or moving slides.

addSlideLookup

public void addSlideLookup(int slideID,
                           int posOnDisk)
Adds a new slide, notes or similar, to be looked up by this. For now, won't look for the most optimal on disk representation.

getRecordType

public long getRecordType()
Return the value we were given at creation, be it 6001 or 6002

Specified by:
getRecordType in class Record

updateOtherRecordReferences

public void updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup)
At write-out time, update the references to the sheets to their new positions

Specified by:
updateOtherRecordReferences in interface PositionDependentRecord
Specified by:
updateOtherRecordReferences in class PositionDependentRecordAtom

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Interface PersistRecord

All Known Implementing Classes:
ExOleObjStg
public interface PersistRecord

A record that can be referenced in PersistPtr storage.

Author:
Yegor Kozlov

Method Summary
int | getPersistId() Fetch the persist ID
void | setPersistId(int id) Set the persist ID

Method Detail

getPersistId

int getPersistId()
Fetch the persist ID

setPersistId

void setPersistId(int id)
Set the persist ID

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PositionDependentRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Interface PositionDependentRecord

All Known Implementing Classes:
Document, DummyPositionSensitiveRecordWithChildren, Environment, ExOleObjStg, MainMaster, Notes, PersistPtrHolder, PositionDependentRecordAtom, PositionDependentRecordContainer, SheetContainer, Slide, UserEditAtom
public interface PositionDependentRecord

Records which either care about where they are on disk, or have other records who care about where they are, will implement this interface. Normally, they'll subclass PositionDependentRecordAtom or PositionDependentRecordContainer, which will do the work of providing the setting and updating interfaces for them. This is a special (and dangerous) kind of Record. When created, they need to be pinged with their current location. When written out, they need to be given their new location, and offered the list of records which have changed their location.

Author:
Nick Burch

Method Summary
int | getLastOnDiskOffset() Fetch our location on the disk, as of the last write out
void | setLastOnDiskOffset(int offset) Update the Record's idea of where on disk it lives, after a write out.
void | updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup) Offer the record the list of records that have changed their location as part of the writeout.

Method Detail

getLastOnDiskOffset

int getLastOnDiskOffset()
Fetch our location on the disk, as of the last write out

setLastOnDiskOffset

void setLastOnDiskOffset(int offset)
Update the Record's idea of where on disk it lives, after a write out. Use with care...

updateOtherRecordReferences

void updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup)
Offer the record the list of records that have changed their location as part of the writeout.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PositionDependentRecordAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class PositionDependentRecordAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.PositionDependentRecordAtom
All Implemented Interfaces:
PositionDependentRecord
Direct Known Subclasses:
PersistPtrHolder, UserEditAtom
public abstract class PositionDependentRecordAtom
extends RecordAtom
implements PositionDependentRecord

A special (and dangerous) kind of Record Atom that cares about where it lives on the disk, or who has other Atoms that care about where this is on the disk.

Author:
Nick Burch

Field Summary
protected  int myLastOnDiskOffset
Our location on the disk, as of the last write out
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
PositionDependentRecordAtom()
Method Summary
int | getLastOnDiskOffset() Fetch our location on the disk, as of the last write out
void | setLastOnDiskOffset(int offset) Update the Record's idea of where on disk it lives, after a write out.
abstract void | updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup) Offer the record the list of records that have changed their location as part of the writeout.
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, getRecordType, writeLittleEndian, writeLittleEndian, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

myLastOnDiskOffset

protected int myLastOnDiskOffset
Our location on the disk, as of the last write out

Constructor Detail

PositionDependentRecordAtom

public PositionDependentRecordAtom()
Method Detail

getLastOnDiskOffset

public int getLastOnDiskOffset()
Fetch our location on the disk, as of the last write out

Specified by:
getLastOnDiskOffset in interface PositionDependentRecord

setLastOnDiskOffset

public void setLastOnDiskOffset(int offset)
Update the Record's idea of where on disk it lives, after a write out. Use with care...

Specified by:
setLastOnDiskOffset in interface PositionDependentRecord

updateOtherRecordReferences

public abstract void updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup)
Offer the record the list of records that have changed their location as part of the writeout. Allows records to update their internal pointers to other records locations

Specified by:
updateOtherRecordReferences in interface PositionDependentRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PositionDependentRecordContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class PositionDependentRecordContainer

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
All Implemented Interfaces:
PositionDependentRecord
Direct Known Subclasses:
Document, DummyPositionSensitiveRecordWithChildren, Environment, SheetContainer
public abstract class PositionDependentRecordContainer
extends RecordContainer
implements PositionDependentRecord

A special (and dangerous) kind of Record Container, for which other Atoms care about where this one lives on disk. Will track its position on disk.

Author:
Nick Burch

Field Summary
protected  int myLastOnDiskOffset
Our location on the disk, as of the last write out
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
PositionDependentRecordContainer()
Method Summary
int | getLastOnDiskOffset() Fetch our location on the disk, as of the last write out
int | getSheetId() Fetch our sheet ID, as found from a PersistPtrHolder.
void | setLastOnDiskOffset(int offset) Update the Record's idea of where on disk it lives, after a write out.
void | setSheetId(int id) Set our sheet ID, as found from a PersistPtrHolder
void | updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup) Since we're a container, we don't mind if other records move about.
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, getRecordType, writeLittleEndian, writeLittleEndian, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

myLastOnDiskOffset

protected int myLastOnDiskOffset
Our location on the disk, as of the last write out

Constructor Detail

PositionDependentRecordContainer

public PositionDependentRecordContainer()
Method Detail

getSheetId

public int getSheetId()
Fetch our sheet ID, as found from a PersistPtrHolder. Should match the RefId of our matching SlidePersistAtom

setSheetId

public void setSheetId(int id)
Set our sheet ID, as found from a PersistPtrHolder

getLastOnDiskOffset

public int getLastOnDiskOffset()
Fetch our location on the disk, as of the last write out

Specified by:
getLastOnDiskOffset in interface PositionDependentRecord

setLastOnDiskOffset

public void setLastOnDiskOffset(int offset)
Update the Record's idea of where on disk it lives, after a write out. Use with care...

Specified by:
setLastOnDiskOffset in interface PositionDependentRecord

updateOtherRecordReferences

public void updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup)
Since we're a container, we don't mind if other records move about. If we're told they have, just return straight off.

Specified by:
updateOtherRecordReferences in interface PositionDependentRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PPDrawing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class PPDrawing

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.PPDrawing

public final class PPDrawing
extends RecordAtom

These are actually wrappers onto Escher drawings. Make use of the DDF classes to do useful things with them. For now, creates a tree of the Escher records, and then creates any PowerPoint (hslf) records found within the EscherTextboxRecord (msofbtClientTextbox) records. Also provides easy access to the EscherTextboxRecords, so that their text may be extracted and used in Sheets

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | PPDrawing() Creates a new, empty, PPDrawing (typically for use with a new Slide or Notes)
protected | PPDrawing(byte[] source, int start, int len) Sets everything up, groks the escher etc
Method Summary
void | addTextboxWrapper(EscherTextboxWrapper txtbox) Add a new EscherTextboxWrapper to this PPDrawing.
Record[] | getChildRecords() We're pretending to be an atom, so return null
EscherDgRecord | getEscherDgRecord() Return EscherDgRecord which keeps track of the number of shapes and shapeId in this drawing group
EscherRecord[] | getEscherRecords() Get access to the underlying Escher Records
long | getRecordType() We are type 1036
EscherTextboxWrapper[] | getTextboxWrappers() Get access to the atoms inside Textboxes
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk Walks the escher layer to get the contents
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PPDrawing

protected PPDrawing(byte[] source,
                    int start,
                    int len)
Sets everything up, groks the escher etc

PPDrawing

public PPDrawing()
Creates a new, empty, PPDrawing (typically for use with a new Slide or Notes)

Method Detail

getEscherRecords

public EscherRecord[] getEscherRecords()
Get access to the underlying Escher Records

getTextboxWrappers

public EscherTextboxWrapper[] getTextboxWrappers()
Get access to the atoms inside Textboxes

getRecordType

public long getRecordType()
We are type 1036

Specified by:
getRecordType in class Record

getChildRecords

public Record[] getChildRecords()
We're pretending to be an atom, so return null

Overrides:
getChildRecords in class RecordAtom

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk Walks the escher layer to get the contents

Specified by:
writeOut in class Record
Throws:
java.io.IOException

addTextboxWrapper

public void addTextboxWrapper(EscherTextboxWrapper txtbox)
Add a new EscherTextboxWrapper to this PPDrawing.

getEscherDgRecord

public EscherDgRecord getEscherDgRecord()
Return EscherDgRecord which keeps track of the number of shapes and shapeId in this drawing group

Returns:
EscherDgRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PPDrawingGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class PPDrawingGroup

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.PPDrawingGroup

public final class PPDrawingGroup
extends RecordAtom

Container records which always exists inside Document. It always acts as a holder for escher DGG container which may contain which Escher BStore container information about pictures containes in the presentation (if any).

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected PPDrawingGroup(byte[] source, int start, int len)
Method Summary
Record[] | getChildRecords() We're pretending to be an atom, so return null
EscherContainerRecord | getDggContainer()
EscherDggRecord | getEscherDggRecord()
long | getRecordType() We are type 1035
void | writeOut(java.io.OutputStream out) Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PPDrawingGroup

protected PPDrawingGroup(byte[] source,
                         int start,
                         int len)
Method Detail

getRecordType

public long getRecordType()
We are type 1035

Specified by:
getRecordType in class Record

getChildRecords

public Record[] getChildRecords()
We're pretending to be an atom, so return null

Overrides:
getChildRecords in class RecordAtom

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Description copied from class: Record
Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getDggContainer

public EscherContainerRecord getDggContainer()

getEscherDggRecord

public EscherDggRecord getEscherDggRecord()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Record

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Record

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
Direct Known Subclasses:
RecordAtom, RecordContainer
public abstract class Record
extends java.lang.Object

This abstract class represents a record in the PowerPoint document. Record classes should extend with RecordContainer or RecordAtom, which extend this in turn.

Author:
Nick Burch

Field Summary
protected  POILogger logger
Constructor Summary
Record()
Method Summary
static Record | buildRecordAtOffset(byte[] b, int offset) Build and return the Record at the given offset.
static Record | createRecordForType(long type, byte[] b, int start, int len) For a given type (little endian bytes 3 and 4 in record header), byte array, start position and length: will return a Record object that will handle that record Remember that while PPT stores the record lengths as 8 bytes short (not including the size of the header), this code assumes you're passing in corrected lengths
static Record[] | findChildRecords(byte[] b, int start, int len) Default method for finding child records of a container record
abstract Record[] | getChildRecords() Fetch all the child records of this record If this record is an atom, will return null If this record is a non-atom, but has no children, will return an empty array
abstract long | getRecordType() Returns the type (held as a little endian in bytes 3 and 4) that this class handles
abstract boolean | isAnAtom() Is this record type an Atom record (only has data), or is it a non-Atom record (has other records)?
static void | writeLittleEndian(int i, java.io.OutputStream o) When writing out, write out a signed int (32bit) in Little Endian format
static void | writeLittleEndian(short s, java.io.OutputStream o) When writing out, write out a signed short (16bit) in Little Endian format
abstract void | writeOut(java.io.OutputStream o) Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected POILogger logger
Constructor Detail

Record

public Record()
Method Detail

isAnAtom

public abstract boolean isAnAtom()
Is this record type an Atom record (only has data), or is it a non-Atom record (has other records)?

getRecordType

public abstract long getRecordType()
Returns the type (held as a little endian in bytes 3 and 4) that this class handles

getChildRecords

public abstract Record[] getChildRecords()
Fetch all the child records of this record If this record is an atom, will return null If this record is a non-atom, but has no children, will return an empty array

writeOut

public abstract void writeOut(java.io.OutputStream o)
                       throws java.io.IOException
Have the contents printer out into an OutputStream, used when writing a file back out to disk (Normally, atom classes will keep their bytes around, but non atom classes will just request the bytes from their children, then chuck on their header and return)

Throws:
java.io.IOException

writeLittleEndian

public static void writeLittleEndian(int i,
                                     java.io.OutputStream o)
                              throws java.io.IOException
When writing out, write out a signed int (32bit) in Little Endian format

Throws:
java.io.IOException

writeLittleEndian

public static void writeLittleEndian(short s,
                                     java.io.OutputStream o)
                              throws java.io.IOException
When writing out, write out a signed short (16bit) in Little Endian format

Throws:
java.io.IOException

buildRecordAtOffset

public static Record buildRecordAtOffset(byte[] b,
                                         int offset)
Build and return the Record at the given offset. Note - does less error checking and handling than findChildRecords

Parameters:
b - The byte array to build from
offset - The offset to build at

findChildRecords

public static Record[] findChildRecords(byte[] b,
                                        int start,
                                        int len)
Default method for finding child records of a container record

createRecordForType

public static Record createRecordForType(long type,
                                         byte[] b,
                                         int start,
                                         int len)
For a given type (little endian bytes 3 and 4 in record header), byte array, start position and length: will return a Record object that will handle that record Remember that while PPT stores the record lengths as 8 bytes short (not including the size of the header), this code assumes you're passing in corrected lengths

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class RecordAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
Direct Known Subclasses:
AnimationInfoAtom, ColorSchemeAtom, Comment2000Atom, CString, DocumentAtom, DocumentEncryptionAtom, ExControlAtom, ExEmbedAtom, ExHyperlinkAtom, ExMediaAtom, ExObjListAtom, ExOleObjAtom, ExOleObjStg, FontEntityAtom, HeadersFootersAtom, InteractiveInfoAtom, NotesAtom, OEPlaceholderAtom, OEShapeAtom, OutlineTextRefAtom, PositionDependentRecordAtom, PPDrawing, PPDrawingGroup, RoundTripHFPlaceholder12, SlideAtom, SlidePersistAtom, SoundData, StyleTextPropAtom, TextBytesAtom, TextCharsAtom, TextHeaderAtom, TextRulerAtom, TextSpecInfoAtom, TxInteractiveInfoAtom, TxMasterStyleAtom, UnknownRecordPlaceholder
public abstract class RecordAtom
extends Record

Abstract class which all atom records will extend.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
RecordAtom()
Method Summary
Record[] | getChildRecords() We're an atom, returns null
boolean | isAnAtom() We are an atom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, getRecordType, writeLittleEndian, writeLittleEndian, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordAtom

public RecordAtom()
Method Detail

isAnAtom

public boolean isAnAtom()
We are an atom

Specified by:
isAnAtom in class Record

getChildRecords

public Record[] getChildRecords()
We're an atom, returns null

Specified by:
getChildRecords in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class RecordContainer

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
Direct Known Subclasses:
AnimationInfo, Comment2000, DummyRecordWithChildren, EscherTextboxWrapper, ExEmbed, ExHyperlink, ExMCIMovie, ExObjList, ExVideoContainer, FontCollection, HeadersFootersContainer, InteractiveInfo, PositionDependentRecordContainer, SlideListWithText, Sound, SoundCollection
public abstract class RecordContainer
extends Record

Abstract class which all container records will extend. Providers helpful methods for writing child records out to disk

Author:
Nick Burch

Field Summary
protected  Record[] _children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
RecordContainer()
Method Summary
void | addChildAfter(Record newChild, Record after) Adds the given Child Record after the supplied record
void | addChildBefore(Record newChild, Record before) Adds the given Child Record before the supplied record
void | appendChildRecord(Record newChild) Add a new child record onto a record's list of children.
Record | findFirstOfType(long type) Finds the first child record of the given type, or null if none of the child records are of the given type.
Record[] | getChildRecords() Return any children
static void | handleParentAwareRecords(RecordContainer br) Find the records that are parent-aware, and tell them who their parent is
boolean | isAnAtom() We're not an atom
void | moveChildBefore(Record child, Record before) Moves the given Child Record to before the supplied record
void | moveChildrenAfter(Record firstChild, int number, Record after) Moves the given Child Records to after the supplied record
void | moveChildrenBefore(Record firstChild, int number, Record before) Moves the given Child Records to before the supplied record
Record | removeChild(Record ch) Remove a child record from this record container
void | setChildRecord(Record[] records) Set child records.
void | writeOut(byte headerA, byte headerB, long type, Record[] children, java.io.OutputStream out) Write out our header, and our children.
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, getRecordType, writeLittleEndian, writeLittleEndian, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_children

protected Record[] _children
Constructor Detail

RecordContainer

public RecordContainer()
Method Detail

getChildRecords

public Record[] getChildRecords()
Return any children

Specified by:
getChildRecords in class Record

isAnAtom

public boolean isAnAtom()
We're not an atom

Specified by:
isAnAtom in class Record

findFirstOfType

public Record findFirstOfType(long type)
Finds the first child record of the given type, or null if none of the child records are of the given type. Does not descend.

removeChild

public Record removeChild(Record ch)
Remove a child record from this record container

Parameters:
ch - the child to remove
Returns:
the removed record

appendChildRecord

public void appendChildRecord(Record newChild)
Add a new child record onto a record's list of children.

addChildAfter

public void addChildAfter(Record newChild,
                          Record after)
Adds the given Child Record after the supplied record

Parameters:
newChild -
after -

addChildBefore

public void addChildBefore(Record newChild,
                           Record before)
Adds the given Child Record before the supplied record

Parameters:
newChild -
before -

moveChildBefore

public void moveChildBefore(Record child,
                            Record before)
Moves the given Child Record to before the supplied record

moveChildrenBefore

public void moveChildrenBefore(Record firstChild,
                               int number,
                               Record before)
Moves the given Child Records to before the supplied record

moveChildrenAfter

public void moveChildrenAfter(Record firstChild,
                              int number,
                              Record after)
Moves the given Child Records to after the supplied record

setChildRecord

public void setChildRecord(Record[] records)
Set child records.

Parameters:
records - the new child records

writeOut

public void writeOut(byte headerA,
                     byte headerB,
                     long type,
                     Record[] children,
                     java.io.OutputStream out)
              throws java.io.IOException
Write out our header, and our children.

Parameters:
headerA - the first byte of the header
headerB - the second byte of the header
type - the record type
children - our child records
out - the stream to write to
Throws:
java.io.IOException

handleParentAwareRecords

public static void handleParentAwareRecords(RecordContainer br)
Find the records that are parent-aware, and tell them who their parent is

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordTypes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class RecordTypes

java.lang.Object
    extended by  org.apache.poi.hslf.record.RecordTypes

public final class RecordTypes
extends java.lang.Object

List of all known record types in a PowerPoint document, and the classes that handle them. There are two categories of records:

  • PowerPoint records: 0 <= info <= 10002 (will carry class info)
  • Escher records: info >= 0xF000 (handled by DDF, so no class info)

    Author:
    Yegor Kozlov, Nick Burch

    Nested Class Summary
    static class RecordTypes.Type
    Wrapper for the details of a PowerPoint or Escher record type.
    Field Summary
    static RecordTypes.Type AnimationInfo
    static RecordTypes.Type AnimationInfoAtom
    static RecordTypes.Type BaseTextPropAtom
    static RecordTypes.Type BinaryTagData
    static RecordTypes.Type BookmarkCollection
    static RecordTypes.Type BookmarkEntityAtom
    static RecordTypes.Type BookmarkSeedAtom
    static RecordTypes.Type CharFormatAtom
    static RecordTypes.Type ColorSchemeAtom
    static RecordTypes.Type Comment2000
    static RecordTypes.Type Comment2000Atom
    static RecordTypes.Type Comment2000Summary
    static RecordTypes.Type Comment2000SummaryAtom
    static RecordTypes.Type CompositeMasterId
    static RecordTypes.Type CString
    static RecordTypes.Type CurrentUserAtom
    static RecordTypes.Type DateTimeMCAtom
    static RecordTypes.Type DefaultRulerAtom
    static RecordTypes.Type DocRoutingSlip
    static RecordTypes.Type Document
    static RecordTypes.Type DocumentAtom
    static RecordTypes.Type DocumentEncryptionAtom
    static RecordTypes.Type EndDocument
    static RecordTypes.Type Environment
    static int EscherAlignRule
    static int EscherAnchor
    static int EscherArcRule
    static int EscherBlip_END
    static int EscherBlip_START
    static int EscherBSE
    static int EscherBStoreContainer
    static int EscherCalloutRule
    static int EscherChildAnchor
    static int EscherClientAnchor
    static int EscherClientData
    static int EscherClientRule
    static int EscherClientTextbox
    static int EscherCLSID
    static int EscherColorMRU
    static int EscherColorScheme
    static int EscherConnectorRule
    static int EscherDeletedPspl
    static int EscherDg
    static int EscherDgContainer
    static int EscherDgg
    static int EscherDggContainer
    static int EscherOleObject
    static int EscherOPT
    static int EscherRegroupItems
    static int EscherSelection
    static int EscherSolverContainer
    static int EscherSp
    static int EscherSpContainer
    static int EscherSpgr
    static int EscherSpgrContainer
    static int EscherSplitMenuColors
    static int EscherTextbox
    static int EscherUserDefined
    static RecordTypes.Type ExAviMovie
    static RecordTypes.Type ExCDAudio
    static RecordTypes.Type ExCDAudioAtom
    static RecordTypes.Type ExControl
    static RecordTypes.Type ExControlAtom
    static RecordTypes.Type ExEmbed
    static RecordTypes.Type ExEmbedAtom
    static RecordTypes.Type ExHyperlink
    static RecordTypes.Type ExHyperlinkAtom
    static RecordTypes.Type ExLink
    static RecordTypes.Type ExLinkAtom
    static RecordTypes.Type ExMCIMovie
    static RecordTypes.Type ExMediaAtom
    static RecordTypes.Type ExMIDIAudio
    static RecordTypes.Type ExObjList
    static RecordTypes.Type ExObjListAtom
    static RecordTypes.Type ExObjRefAtom
    static RecordTypes.Type ExOleObjAtom
    static RecordTypes.Type ExOleObjStg
    static RecordTypes.Type ExQuickTimeMovie
    static RecordTypes.Type ExQuickTimeMovieData
    static RecordTypes.Type ExVideoContainer
    static RecordTypes.Type ExWAVAudioEmbedded
    static RecordTypes.Type ExWAVAudioEmbeddedAtom
    static RecordTypes.Type ExWAVAudioLink
    static RecordTypes.Type FontCollection
    static RecordTypes.Type FontEmbeddedData
    static RecordTypes.Type FontEntityAtom
    static RecordTypes.Type FooterMCAtom
    static RecordTypes.Type GenericDateMCAtom
    static RecordTypes.Type GPopublicintAtom
    static RecordTypes.Type GRatioAtom
    static RecordTypes.Type GRColorAtom
    static RecordTypes.Type GScalingAtom
    static RecordTypes.Type GuideAtom
    static RecordTypes.Type HandOut
    static RecordTypes.Type HeadersFooters
    static RecordTypes.Type HeadersFootersAtom
    static RecordTypes.Type InteractiveInfo
    static RecordTypes.Type InteractiveInfoAtom
    static RecordTypes.Type List
    static RecordTypes.Type MainMaster
    static RecordTypes.Type MetaFile
    static RecordTypes.Type NamedShow
    static RecordTypes.Type NamedShows
    static RecordTypes.Type NamedShowSlides
    static RecordTypes.Type Notes
    static RecordTypes.Type NotesAtom
    static RecordTypes.Type OEPlaceholderAtom
    static RecordTypes.Type OEShapeAtom
    static RecordTypes.Type OriginalMainMasterId
    static RecordTypes.Type OutlineTextRefAtom
    static RecordTypes.Type OutlineViewInfo
    static RecordTypes.Type ParaFormatAtom
    static RecordTypes.Type PersistPtrFullBlock
    static RecordTypes.Type PersistPtrIncrementalBlock
    static RecordTypes.Type PPDrawing
    static RecordTypes.Type PPDrawingGroup
    static RecordTypes.Type ProgBinaryTag
    static RecordTypes.Type ProgStringTag
    static RecordTypes.Type ProgTags
    static RecordTypes.Type PrpublicintOptions
    static RecordTypes.Type RecolorInfoAtom
    static RecordTypes.Type RoundTripContentMasterId
    static RecordTypes.Type RoundTripContentMasterInfo12
    static RecordTypes.Type RoundTripCustomTableStyles12
    static RecordTypes.Type RoundTripHFPlaceholder12
    static RecordTypes.Type RoundTripNotesMasterTextStyles12
    static RecordTypes.Type RoundTripOArtTextStyles12
    static RecordTypes.Type RoundTripShapeCheckSumForCustomLayouts12
    static RecordTypes.Type RoundTripShapeId12
    static RecordTypes.Type RTFDateTimeMCAtom
    static RecordTypes.Type SheetProperties
    static RecordTypes.Type Slide
    static RecordTypes.Type SlideAtom
    static RecordTypes.Type SlideListWithText
    static RecordTypes.Type SlideNumberMCAtom
    static RecordTypes.Type SlidePersistAtom
    static RecordTypes.Type SlideViewInfo
    static RecordTypes.Type SlideViewInfoAtom
    static RecordTypes.Type SorterViewInfo
    static RecordTypes.Type Sound
    static RecordTypes.Type SoundCollAtom
    static RecordTypes.Type SoundCollection
    static RecordTypes.Type SoundData
    static RecordTypes.Type SrKinsoku
    static RecordTypes.Type SrKinsokuAtom
    static RecordTypes.Type SSDocInfoAtom
    static RecordTypes.Type SSlideLayoutAtom
    static RecordTypes.Type SSSlideInfoAtom
    static RecordTypes.Type StyleTextPropAtom
    static RecordTypes.Type Summary
    static RecordTypes.Type TextBookmarkAtom
    static RecordTypes.Type TextBytesAtom
    static RecordTypes.Type TextCharsAtom
    static RecordTypes.Type TextHeaderAtom
    static RecordTypes.Type TextRulerAtom
    static RecordTypes.Type TextSpecInfoAtom
    static RecordTypes.Type TxCFStyleAtom
    static RecordTypes.Type TxInteractiveInfoAtom
    static RecordTypes.Type TxMasterStyleAtom
    static RecordTypes.Type TxPFStyleAtom
    static RecordTypes.Type TxSIStyleAtom
    static java.util.HashMap<java.lang.Integer,java.lang.Class<? extends Record>> typeToClass
    static java.util.HashMap<java.lang.Integer,java.lang.String> typeToName
    static RecordTypes.Type Unknown
    static RecordTypes.Type UserEditAtom
    static RecordTypes.Type VBAInfo
    static RecordTypes.Type VBAInfoAtom
    static RecordTypes.Type ViewInfo
    static RecordTypes.Type ViewInfoAtom
    Constructor Summary
    RecordTypes()
    Method Summary
    static java.lang.Class<? extends Record> recordHandlingClass(int type)
    Returns the class handling a record by its type.
    static java.lang.String recordName(int type)
    Returns name of the record by its type
    Methods inherited from class java.lang.Object
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Field Detail

    typeToName

    public static java.util.HashMap<java.lang.Integer,java.lang.String> typeToName

    typeToClass

    public static java.util.HashMap<java.lang.Integer,java.lang.Class<? extends Record>> typeToClass

    Unknown

    public static final RecordTypes.Type Unknown

    Document

    public static final RecordTypes.Type Document

    DocumentAtom

    public static final RecordTypes.Type DocumentAtom

    EndDocument

    public static final RecordTypes.Type EndDocument

    Slide

    public static final RecordTypes.Type Slide

    SlideAtom

    public static final RecordTypes.Type SlideAtom

    Notes

    public static final RecordTypes.Type Notes

    NotesAtom

    public static final RecordTypes.Type NotesAtom

    Environment

    public static final RecordTypes.Type Environment

    SlidePersistAtom

    public static final RecordTypes.Type SlidePersistAtom

    SSlideLayoutAtom

    public static final RecordTypes.Type SSlideLayoutAtom

    MainMaster

    public static final RecordTypes.Type MainMaster

    SSSlideInfoAtom

    public static final RecordTypes.Type SSSlideInfoAtom

    SlideViewInfo

    public static final RecordTypes.Type SlideViewInfo

    GuideAtom

    public static final RecordTypes.Type GuideAtom

    ViewInfo

    public static final RecordTypes.Type ViewInfo

    ViewInfoAtom

    public static final RecordTypes.Type ViewInfoAtom

    SlideViewInfoAtom

    public static final RecordTypes.Type SlideViewInfoAtom

    VBAInfo

    public static final RecordTypes.Type VBAInfo

    VBAInfoAtom

    public static final RecordTypes.Type VBAInfoAtom

    SSDocInfoAtom

    public static final RecordTypes.Type SSDocInfoAtom

    Summary

    public static final RecordTypes.Type Summary

    DocRoutingSlip

    public static final RecordTypes.Type DocRoutingSlip

    OutlineViewInfo

    public static final RecordTypes.Type OutlineViewInfo

    SorterViewInfo

    public static final RecordTypes.Type SorterViewInfo

    ExObjList

    public static final RecordTypes.Type ExObjList

    ExObjListAtom

    public static final RecordTypes.Type ExObjListAtom

    PPDrawingGroup

    public static final RecordTypes.Type PPDrawingGroup

    PPDrawing

    public static final RecordTypes.Type PPDrawing

    NamedShows

    public static final RecordTypes.Type NamedShows

    NamedShow

    public static final RecordTypes.Type NamedShow

    NamedShowSlides

    public static final RecordTypes.Type NamedShowSlides

    SheetProperties

    public static final RecordTypes.Type SheetProperties

    List

    public static final RecordTypes.Type List

    FontCollection

    public static final RecordTypes.Type FontCollection

    BookmarkCollection

    public static final RecordTypes.Type BookmarkCollection

    SoundCollection

    public static final RecordTypes.Type SoundCollection

    SoundCollAtom

    public static final RecordTypes.Type SoundCollAtom

    Sound

    public static final RecordTypes.Type Sound

    SoundData

    public static final RecordTypes.Type SoundData

    BookmarkSeedAtom

    public static final RecordTypes.Type BookmarkSeedAtom

    ColorSchemeAtom

    public static final RecordTypes.Type ColorSchemeAtom

    ExObjRefAtom

    public static final RecordTypes.Type ExObjRefAtom

    OEShapeAtom

    public static final RecordTypes.Type OEShapeAtom

    OEPlaceholderAtom

    public static final RecordTypes.Type OEPlaceholderAtom

    GPopublicintAtom

    public static final RecordTypes.Type GPopublicintAtom

    GRatioAtom

    public static final RecordTypes.Type GRatioAtom

    OutlineTextRefAtom

    public static final RecordTypes.Type OutlineTextRefAtom

    TextHeaderAtom

    public static final RecordTypes.Type TextHeaderAtom

    TextCharsAtom

    public static final RecordTypes.Type TextCharsAtom

    StyleTextPropAtom

    public static final RecordTypes.Type StyleTextPropAtom

    BaseTextPropAtom

    public static final RecordTypes.Type BaseTextPropAtom

    TxMasterStyleAtom

    public static final RecordTypes.Type TxMasterStyleAtom

    TxCFStyleAtom

    public static final RecordTypes.Type TxCFStyleAtom

    TxPFStyleAtom

    public static final RecordTypes.Type TxPFStyleAtom

    TextRulerAtom

    public static final RecordTypes.Type TextRulerAtom

    TextBookmarkAtom

    public static final RecordTypes.Type TextBookmarkAtom

    TextBytesAtom

    public static final RecordTypes.Type TextBytesAtom

    TxSIStyleAtom

    public static final RecordTypes.Type TxSIStyleAtom

    TextSpecInfoAtom

    public static final RecordTypes.Type TextSpecInfoAtom

    DefaultRulerAtom

    public static final RecordTypes.Type DefaultRulerAtom

    FontEntityAtom

    public static final RecordTypes.Type FontEntityAtom

    FontEmbeddedData

    public static final RecordTypes.Type FontEmbeddedData

    CString

    public static final RecordTypes.Type CString

    MetaFile

    public static final RecordTypes.Type MetaFile

    ExOleObjAtom

    public static final RecordTypes.Type ExOleObjAtom

    SrKinsoku

    public static final RecordTypes.Type SrKinsoku

    HandOut

    public static final RecordTypes.Type HandOut

    ExEmbed

    public static final RecordTypes.Type ExEmbed

    ExEmbedAtom

    public static final RecordTypes.Type ExEmbedAtom

    ExLink

    public static final RecordTypes.Type ExLink

    BookmarkEntityAtom

    public static final RecordTypes.Type BookmarkEntityAtom

    ExLinkAtom

    public static final RecordTypes.Type ExLinkAtom

    SrKinsokuAtom

    public static final RecordTypes.Type SrKinsokuAtom

    ExHyperlinkAtom

    public static final RecordTypes.Type ExHyperlinkAtom

    ExHyperlink

    public static final RecordTypes.Type ExHyperlink

    SlideNumberMCAtom

    public static final RecordTypes.Type SlideNumberMCAtom

    HeadersFooters

    public static final RecordTypes.Type HeadersFooters

    HeadersFootersAtom

    public static final RecordTypes.Type HeadersFootersAtom

    TxInteractiveInfoAtom

    public static final RecordTypes.Type TxInteractiveInfoAtom

    CharFormatAtom

    public static final RecordTypes.Type CharFormatAtom

    ParaFormatAtom

    public static final RecordTypes.Type ParaFormatAtom

    RecolorInfoAtom

    public static final RecordTypes.Type RecolorInfoAtom

    ExQuickTimeMovie

    public static final RecordTypes.Type ExQuickTimeMovie

    ExQuickTimeMovieData

    public static final RecordTypes.Type ExQuickTimeMovieData

    ExControl

    public static final RecordTypes.Type ExControl

    SlideListWithText

    public static final RecordTypes.Type SlideListWithText

    InteractiveInfo

    public static final RecordTypes.Type InteractiveInfo

    InteractiveInfoAtom

    public static final RecordTypes.Type InteractiveInfoAtom

    UserEditAtom

    public static final RecordTypes.Type UserEditAtom

    CurrentUserAtom

    public static final RecordTypes.Type CurrentUserAtom

    DateTimeMCAtom

    public static final RecordTypes.Type DateTimeMCAtom

    GenericDateMCAtom

    public static final RecordTypes.Type GenericDateMCAtom

    FooterMCAtom

    public static final RecordTypes.Type FooterMCAtom

    ExControlAtom

    public static final RecordTypes.Type ExControlAtom

    ExMediaAtom

    public static final RecordTypes.Type ExMediaAtom

    ExVideoContainer

    public static final RecordTypes.Type ExVideoContainer

    ExAviMovie

    public static final RecordTypes.Type ExAviMovie

    ExMCIMovie

    public static final RecordTypes.Type ExMCIMovie

    ExMIDIAudio

    public static final RecordTypes.Type ExMIDIAudio

    ExCDAudio

    public static final RecordTypes.Type ExCDAudio

    ExWAVAudioEmbedded

    public static final RecordTypes.Type ExWAVAudioEmbedded

    ExWAVAudioLink

    public static final RecordTypes.Type ExWAVAudioLink

    ExOleObjStg

    public static final RecordTypes.Type ExOleObjStg

    ExCDAudioAtom

    public static final RecordTypes.Type ExCDAudioAtom

    ExWAVAudioEmbeddedAtom

    public static final RecordTypes.Type ExWAVAudioEmbeddedAtom

    AnimationInfo

    public static final RecordTypes.Type AnimationInfo

    AnimationInfoAtom

    public static final RecordTypes.Type AnimationInfoAtom

    RTFDateTimeMCAtom

    public static final RecordTypes.Type RTFDateTimeMCAtom

    ProgTags

    public static final RecordTypes.Type ProgTags

    ProgStringTag

    public static final RecordTypes.Type ProgStringTag

    ProgBinaryTag

    public static final RecordTypes.Type ProgBinaryTag

    BinaryTagData

    public static final RecordTypes.Type BinaryTagData

    PrpublicintOptions

    public static final RecordTypes.Type PrpublicintOptions

    PersistPtrFullBlock

    public static final RecordTypes.Type PersistPtrFullBlock

    PersistPtrIncrementalBlock

    public static final RecordTypes.Type PersistPtrIncrementalBlock

    GScalingAtom

    public static final RecordTypes.Type GScalingAtom

    GRColorAtom

    public static final RecordTypes.Type GRColorAtom

    Comment2000

    public static final RecordTypes.Type Comment2000

    Comment2000Atom

    public static final RecordTypes.Type Comment2000Atom

    Comment2000Summary

    public static final RecordTypes.Type Comment2000Summary

    Comment2000SummaryAtom

    public static final RecordTypes.Type Comment2000SummaryAtom

    DocumentEncryptionAtom

    public static final RecordTypes.Type DocumentEncryptionAtom

    OriginalMainMasterId

    public static final RecordTypes.Type OriginalMainMasterId

    CompositeMasterId

    public static final RecordTypes.Type CompositeMasterId

    RoundTripContentMasterInfo12

    public static final RecordTypes.Type RoundTripContentMasterInfo12

    RoundTripShapeId12

    public static final RecordTypes.Type RoundTripShapeId12

    RoundTripHFPlaceholder12

    public static final RecordTypes.Type RoundTripHFPlaceholder12

    RoundTripContentMasterId

    public static final RecordTypes.Type RoundTripContentMasterId

    RoundTripOArtTextStyles12

    public static final RecordTypes.Type RoundTripOArtTextStyles12

    RoundTripShapeCheckSumForCustomLayouts12

    public static final RecordTypes.Type RoundTripShapeCheckSumForCustomLayouts12

    RoundTripNotesMasterTextStyles12

    public static final RecordTypes.Type RoundTripNotesMasterTextStyles12

    RoundTripCustomTableStyles12

    public static final RecordTypes.Type RoundTripCustomTableStyles12

    EscherDggContainer

    public static final int EscherDggContainer
    See Also:
    Constant Field Values

    EscherDgg

    public static final int EscherDgg
    See Also:
    Constant Field Values

    EscherCLSID

    public static final int EscherCLSID
    See Also:
    Constant Field Values

    EscherOPT

    public static final int EscherOPT
    See Also:
    Constant Field Values

    EscherBStoreContainer

    public static final int EscherBStoreContainer
    See Also:
    Constant Field Values

    EscherBSE

    public static final int EscherBSE
    See Also:
    Constant Field Values

    EscherBlip_START

    public static final int EscherBlip_START
    See Also:
    Constant Field Values

    EscherBlip_END

    public static final int EscherBlip_END
    See Also:
    Constant Field Values

    EscherDgContainer

    public static final int EscherDgContainer
    See Also:
    Constant Field Values

    EscherDg

    public static final int EscherDg
    See Also:
    Constant Field Values

    EscherRegroupItems

    public static final int EscherRegroupItems
    See Also:
    Constant Field Values

    EscherColorScheme

    public static final int EscherColorScheme
    See Also:
    Constant Field Values

    EscherSpgrContainer

    public static final int EscherSpgrContainer
    See Also:
    Constant Field Values

    EscherSpContainer

    public static final int EscherSpContainer
    See Also:
    Constant Field Values

    EscherSpgr

    public static final int EscherSpgr
    See Also:
    Constant Field Values

    EscherSp

    public static final int EscherSp
    See Also:
    Constant Field Values

    EscherTextbox

    public static final int EscherTextbox
    See Also:
    Constant Field Values

    EscherClientTextbox

    public static final int EscherClientTextbox
    See Also:
    Constant Field Values

    EscherAnchor

    public static final int EscherAnchor
    See Also:
    Constant Field Values

    EscherChildAnchor

    public static final int EscherChildAnchor
    See Also:
    Constant Field Values

    EscherClientAnchor

    public static final int EscherClientAnchor
    See Also:
    Constant Field Values

    EscherClientData

    public static final int EscherClientData
    See Also:
    Constant Field Values

    EscherSolverContainer

    public static final int EscherSolverContainer
    See Also:
    Constant Field Values

    EscherConnectorRule

    public static final int EscherConnectorRule
    See Also:
    Constant Field Values

    EscherAlignRule

    public static final int EscherAlignRule
    See Also:
    Constant Field Values

    EscherArcRule

    public static final int EscherArcRule
    See Also:
    Constant Field Values

    EscherClientRule

    public static final int EscherClientRule
    See Also:
    Constant Field Values

    EscherCalloutRule

    public static final int EscherCalloutRule
    See Also:
    Constant Field Values

    EscherSelection

    public static final int EscherSelection
    See Also:
    Constant Field Values

    EscherColorMRU

    public static final int EscherColorMRU
    See Also:
    Constant Field Values

    EscherDeletedPspl

    public static final int EscherDeletedPspl
    See Also:
    Constant Field Values

    EscherSplitMenuColors

    public static final int EscherSplitMenuColors
    See Also:
    Constant Field Values

    EscherOleObject

    public static final int EscherOleObject
    See Also:
    Constant Field Values

    EscherUserDefined

    public static final int EscherUserDefined
    See Also:
    Constant Field Values
    Constructor Detail

    RecordTypes

    public RecordTypes()
    Method Detail

    recordName

    public static java.lang.String recordName(int type)
    Returns name of the record by its type

    Parameters:
    type - section of the record header
    Returns:
    name of the record

    recordHandlingClass

    public static java.lang.Class<? extends Record> recordHandlingClass(int type)
    Returns the class handling a record by its type. If given an un-handled PowerPoint record, will return a dummy placeholder class. If given an unknown PowerPoint record, or and Escher record, will return null.

    Parameters:
    type - section of the record header
    Returns:
    class to handle the record, or null if an unknown (eg Escher) record
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordTypes.Type

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class RecordTypes.Type

java.lang.Object
    extended by  org.apache.poi.hslf.record.RecordTypes.Type
Enclosing class:
RecordTypes
public static class RecordTypes.Type
extends java.lang.Object

Wrapper for the details of a PowerPoint or Escher record type. Contains both the type, and the handling class (if any), and offers methods to get either back out.

Field Summary
java.lang.Class<? extends Record> | handlingClass
int | typeID
Constructor Summary
RecordTypes.Type(int typeID, java.lang.Class<? extends Record> handlingClass)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

typeID

public int typeID

handlingClass

public java.lang.Class<? extends Record> handlingClass
Constructor Detail

RecordTypes.Type

public RecordTypes.Type(int typeID,
                        java.lang.Class<? extends Record> handlingClass)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoundTripHFPlaceholder12

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class RoundTripHFPlaceholder12

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.RoundTripHFPlaceholder12

public final class RoundTripHFPlaceholder12
extends RecordAtom

An atom record that specifies that a shape is a header or footer placeholder shape

Since:
PowerPoint 2007
Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected RoundTripHFPlaceholder12(byte[] source, int start, int len)
Constructs the comment atom record from its source data.
Method Summary
int | getPlaceholderId() Gets the comment number (note - each user normally has their own count).
long | getRecordType() Gets the record type.
void | setPlaceholderId(int number) Sets the comment number (note - each user normally has their own count).
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RoundTripHFPlaceholder12

protected RoundTripHFPlaceholder12(byte[] source,
                                   int start,
                                   int len)
Constructs the comment atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getPlaceholderId

public int getPlaceholderId()
Gets the comment number (note - each user normally has their own count).

Returns:
the comment number.

setPlaceholderId

public void setPlaceholderId(int number)
Sets the comment number (note - each user normally has their own count).

Parameters:
number - the comment number.

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SheetContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SheetContainer

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
                extended by  org.apache.poi.hslf.record.SheetContainer
All Implemented Interfaces:
PositionDependentRecord
Direct Known Subclasses:
MainMaster, Notes, Slide
public abstract class SheetContainer
extends PositionDependentRecordContainer

The superclass of all sheet container records - Slide, Notes, MainMaster, etc.

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
SheetContainer()
Method Summary
abstract ColorSchemeAtom | getColorScheme()
abstract PPDrawing | getPPDrawing() Returns the PPDrawing of this sheet, which has all the interesting data in it
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
getLastOnDiskOffset, getSheetId, setLastOnDiskOffset, setSheetId, updateOtherRecordReferences
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, getRecordType, writeLittleEndian, writeLittleEndian, writeOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SheetContainer

public SheetContainer()
Method Detail

getPPDrawing

public abstract PPDrawing getPPDrawing()
Returns the PPDrawing of this sheet, which has all the interesting data in it

getColorScheme

public abstract ColorSchemeAtom getColorScheme()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Slide

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Slide

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.PositionDependentRecordContainer
                extended by  org.apache.poi.hslf.record.SheetContainer
                    extended by  org.apache.poi.hslf.record.Slide
All Implemented Interfaces:
PositionDependentRecord
public final class Slide
extends SheetContainer

Master container for Slides. There is one of these for every slide, and they have certain specific children

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | Slide() Create a new, empty, Slide, along with its required child records.
protected | Slide(byte[] source, int start, int len) Set things up, and find our more interesting children
Method Summary
ColorSchemeAtom | getColorScheme()
PPDrawing | getPPDrawing() Returns the PPDrawing of this Slide, which has all the interesting data in it
long | getRecordType() We are of type 1006
SlideAtom | getSlideAtom() Returns the SlideAtom of this Slide
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordContainer
getLastOnDiskOffset, getSheetId, setLastOnDiskOffset, setSheetId, updateOtherRecordReferences
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Slide

protected Slide(byte[] source,
                int start,
                int len)
Set things up, and find our more interesting children

Slide

public Slide()
Create a new, empty, Slide, along with its required child records.

Method Detail

getSlideAtom

public SlideAtom getSlideAtom()
Returns the SlideAtom of this Slide

getPPDrawing

public PPDrawing getPPDrawing()
Returns the PPDrawing of this Slide, which has all the interesting data in it

Specified by:
getPPDrawing in class SheetContainer

getRecordType

public long getRecordType()
We are of type 1006

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getColorScheme

public ColorSchemeAtom getColorScheme()
Specified by:
getColorScheme in class SheetContainer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SlideAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.SlideAtom

public final class SlideAtom
extends RecordAtom

A Slide Atom (type 1007). Holds information on the parent Slide, what Master Slide it uses, what Notes is attached to it, that sort of thing. It also has a SSlideLayoutAtom embeded in it, but without the Atom header

Author:
Nick Burch

Nested Class Summary
 class SlideAtom.SSlideLayoutAtom
Holds the geometry of the Slide, and the ID of the placeholders on the slide.
Field Summary
static int | MASTER_SLIDE_ID
static int | USES_MASTER_SLIDE_ID
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | SlideAtom() Create a new SlideAtom, to go with a new Slide
protected | SlideAtom(byte[] source, int start, int len) For the Slide Atom
Method Summary
boolean | getFollowMasterBackground()
boolean | getFollowMasterObjects()
boolean | getFollowMasterScheme()
int | getMasterID() Get the ID of the master slide used.
int | getNotesID() Get the ID of the notes for this slide.
long | getRecordType() We are of type 1007
SlideAtom.SSlideLayoutAtom | getSSlideLayoutAtom() Get the embeded SSlideLayoutAtom
void | setFollowMasterBackground(boolean flag)
void | setFollowMasterObjects(boolean flag)
void | setFollowMasterScheme(boolean flag)
void | setMasterID(int id) Change slide master.
void | setNotesID(int id) Change the ID of the notes for this slide.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MASTER_SLIDE_ID

public static final int MASTER_SLIDE_ID
See Also:
Constant Field Values

USES_MASTER_SLIDE_ID

public static final int USES_MASTER_SLIDE_ID
See Also:
Constant Field Values
Constructor Detail

SlideAtom

protected SlideAtom(byte[] source,
                    int start,
                    int len)
For the Slide Atom

SlideAtom

public SlideAtom()
Create a new SlideAtom, to go with a new Slide

Method Detail

getMasterID

public int getMasterID()
Get the ID of the master slide used. 0 if this is a master slide, otherwise -2147483648

setMasterID

public void setMasterID(int id)
Change slide master.

getNotesID

public int getNotesID()
Get the ID of the notes for this slide. 0 if doesn't have one

getSSlideLayoutAtom

public SlideAtom.SSlideLayoutAtom getSSlideLayoutAtom()
Get the embeded SSlideLayoutAtom

setNotesID

public void setNotesID(int id)
Change the ID of the notes for this slide. 0 if it no longer has one

getFollowMasterObjects

public boolean getFollowMasterObjects()

getFollowMasterScheme

public boolean getFollowMasterScheme()

getFollowMasterBackground

public boolean getFollowMasterBackground()

setFollowMasterObjects

public void setFollowMasterObjects(boolean flag)

setFollowMasterScheme

public void setFollowMasterScheme(boolean flag)

setFollowMasterBackground

public void setFollowMasterBackground(boolean flag)

getRecordType

public long getRecordType()
We are of type 1007

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideAtom.SSlideLayoutAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SlideAtom.SSlideLayoutAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom
Enclosing class:
SlideAtom
public class SlideAtom.SSlideLayoutAtom
extends java.lang.Object

Holds the geometry of the Slide, and the ID of the placeholders on the slide. (Embeded inside SlideAtom is a SSlideLayoutAtom, without the usual record header. Since it's a fixed size and tied to the SlideAtom, we'll hold it here.)

Field Summary
static int | BIG_OBJECT
static int | BLANK_SLIDE
static int | FOUR_OBJECTS
static int | HANDOUT
static int | MASTER_NOTES
static int | MASTER_SLIDE
static int | NOTES_TITLE_BODY
static int | TITLE_2_COLUMN_BODY
static int | TITLE_2_COLUNM_LEFT_2_ROW_BODY
static int | TITLE_2_COLUNM_RIGHT_2_ROW_BODY
static int | TITLE_2_ROW_BODY
static int | TITLE_2_ROW_BOTTOM_2_COLUMN_BODY
static int | TITLE_2_ROW_TOP_2_COLUMN_BODY
static int | TITLE_BODY_SLIDE
static int | TITLE_MASTER_SLIDE
static int | TITLE_ONLY
static int | TITLE_SLIDE
static int | VERTICAL_TITLE_2_ROW_BODY_LEFT
static int | VERTICAL_TITLE_BODY_LEFT
Constructor Summary
SlideAtom.SSlideLayoutAtom(byte[] data)
Create a new Embeded SSlideLayoutAtom, from 12 bytes of data
Method Summary
int | getGeometryType() Retrieve the geometry type
void | setGeometryType(int geom) Set the geometry type
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TITLE_SLIDE

public static final int TITLE_SLIDE
See Also:
Constant Field Values

TITLE_BODY_SLIDE

public static final int TITLE_BODY_SLIDE
See Also:
Constant Field Values

TITLE_MASTER_SLIDE

public static final int TITLE_MASTER_SLIDE
See Also:
Constant Field Values

MASTER_SLIDE

public static final int MASTER_SLIDE
See Also:
Constant Field Values

MASTER_NOTES

public static final int MASTER_NOTES
See Also:
Constant Field Values

NOTES_TITLE_BODY

public static final int NOTES_TITLE_BODY
See Also:
Constant Field Values

HANDOUT

public static final int HANDOUT
See Also:
Constant Field Values

TITLE_ONLY

public static final int TITLE_ONLY
See Also:
Constant Field Values

TITLE_2_COLUMN_BODY

public static final int TITLE_2_COLUMN_BODY
See Also:
Constant Field Values

TITLE_2_ROW_BODY

public static final int TITLE_2_ROW_BODY
See Also:
Constant Field Values

TITLE_2_COLUNM_RIGHT_2_ROW_BODY

public static final int TITLE_2_COLUNM_RIGHT_2_ROW_BODY
See Also:
Constant Field Values

TITLE_2_COLUNM_LEFT_2_ROW_BODY

public static final int TITLE_2_COLUNM_LEFT_2_ROW_BODY
See Also:
Constant Field Values

TITLE_2_ROW_BOTTOM_2_COLUMN_BODY

public static final int TITLE_2_ROW_BOTTOM_2_COLUMN_BODY
See Also:
Constant Field Values

TITLE_2_ROW_TOP_2_COLUMN_BODY

public static final int TITLE_2_ROW_TOP_2_COLUMN_BODY
See Also:
Constant Field Values

FOUR_OBJECTS

public static final int FOUR_OBJECTS
See Also:
Constant Field Values

BIG_OBJECT

public static final int BIG_OBJECT
See Also:
Constant Field Values

BLANK_SLIDE

public static final int BLANK_SLIDE
See Also:
Constant Field Values

VERTICAL_TITLE_BODY_LEFT

public static final int VERTICAL_TITLE_BODY_LEFT
See Also:
Constant Field Values

VERTICAL_TITLE_2_ROW_BODY_LEFT

public static final int VERTICAL_TITLE_2_ROW_BODY_LEFT
See Also:
Constant Field Values
Constructor Detail

SlideAtom.SSlideLayoutAtom

public SlideAtom.SSlideLayoutAtom(byte[] data)
Create a new Embeded SSlideLayoutAtom, from 12 bytes of data

Method Detail

getGeometryType

public int getGeometryType()
Retrieve the geometry type

setGeometryType

public void setGeometryType(int geom)
Set the geometry type

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk. Skips the record header

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideListWithText

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SlideListWithText

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.SlideListWithText

public final class SlideListWithText
extends RecordContainer

These are tricky beasts. They contain the text of potentially many (normal) slides. They are made up of several sets of - SlidePersistAtom - TextHeaderAtom - TextBytesAtom / TextCharsAtom - StyleTextPropAtom (optional) - TextSpecInfoAtom (optional) - InteractiveInfo (optional) - TxInteractiveInfoAtom (optional) and then the next SlidePersistAtom. Eventually, Slides will find the blocks that interest them from all the SlideListWithText entries, and refere to them For now, we scan through looking for interesting bits, then creating the helpful Sheet from model for them

Author:
Nick Burch

Nested Class Summary
 class SlideListWithText.SlideAtomsSet
Inner class to wrap up a matching set of records that hold the text for a given sheet.
Field Summary
static int | MASTER Instance filed of the record header indicates that this SlideListWithText stores references to master slides
static int | NOTES Instance filed of the record header indicates that this SlideListWithText stores references to notes
static int | SLIDES Instance filed of the record header indicates that this SlideListWithText stores references to slides
Fields inherited from class org.apache.poi.hslf.record.RecordContainer
_children
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | SlideListWithText() Create a new, empty, SlideListWithText
protected | SlideListWithText(byte[] source, int start, int len) Create a new holder for slide records
Method Summary
void | addSlidePersistAtom(SlidePersistAtom spa) Add a new SlidePersistAtom, to the end of the current list, and update the internal list of SlidePersistAtoms
int | getInstance()
long | getRecordType() Return the value we were given at creation
SlideListWithText.SlideAtomsSet[] | getSlideAtomsSets() Get access to the SlideAtomsSets of the children of this record
void | setInstance(int inst)
void | setSlideAtomsSets(SlideListWithText.SlideAtomsSet[] sas) Get access to the SlideAtomsSets of the children of this record
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordContainer
addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SLIDES

public static final int SLIDES
Instance filed of the record header indicates that this SlideListWithText stores references to slides

See Also:
Constant Field Values

MASTER

public static final int MASTER
Instance filed of the record header indicates that this SlideListWithText stores references to master slides

See Also:
Constant Field Values

NOTES

public static final int NOTES
Instance filed of the record header indicates that this SlideListWithText stores references to notes

See Also:
Constant Field Values
Constructor Detail

SlideListWithText

protected SlideListWithText(byte[] source,
                            int start,
                            int len)
Create a new holder for slide records

SlideListWithText

public SlideListWithText()
Create a new, empty, SlideListWithText

Method Detail

addSlidePersistAtom

public void addSlidePersistAtom(SlidePersistAtom spa)
Add a new SlidePersistAtom, to the end of the current list, and update the internal list of SlidePersistAtoms

Parameters:
spa -

getInstance

public int getInstance()

setInstance

public void setInstance(int inst)

getSlideAtomsSets

public SlideListWithText.SlideAtomsSet[] getSlideAtomsSets()
Get access to the SlideAtomsSets of the children of this record

setSlideAtomsSets

public void setSlideAtomsSets(SlideListWithText.SlideAtomsSet[] sas)
Get access to the SlideAtomsSets of the children of this record

getRecordType

public long getRecordType()
Return the value we were given at creation

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideListWithText.SlideAtomsSet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SlideListWithText.SlideAtomsSet

java.lang.Object
    extended by  org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet
Enclosing class:
SlideListWithText
public class SlideListWithText.SlideAtomsSet
extends java.lang.Object

Inner class to wrap up a matching set of records that hold the text for a given sheet. Contains the leading SlidePersistAtom, and all of the records until the next SlidePersistAtom. This includes sets of TextHeaderAtom and TextBytesAtom/TextCharsAtom, along with some others.

Constructor Summary
SlideListWithText.SlideAtomsSet(SlidePersistAtom s, Record[] r)
Create one to hold the Records for one Slide's text
Method Summary
SlidePersistAtom | getSlidePersistAtom() Get the SlidePersistAtom, which gives details on the Slide this text is associated with
Record[] | getSlideRecords() Get the Text related records for this slide
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlideListWithText.SlideAtomsSet

public SlideListWithText.SlideAtomsSet(SlidePersistAtom s,
                                       Record[] r)
Create one to hold the Records for one Slide's text

Method Detail

getSlidePersistAtom

public SlidePersistAtom getSlidePersistAtom()
Get the SlidePersistAtom, which gives details on the Slide this text is associated with

getSlideRecords

public Record[] getSlideRecords()
Get the Text related records for this slide

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlidePersistAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SlidePersistAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.SlidePersistAtom

public final class SlidePersistAtom
extends RecordAtom

A SlidePersist Atom (type 1011). Holds information on the text of a given slide, which are stored in the same SlideListWithText

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | SlidePersistAtom() Create a new SlidePersistAtom, for use with a new Slide
protected | SlidePersistAtom(byte[] source, int start, int len) For the SlidePersist Atom
Method Summary
boolean | getHasShapesOtherThanPlaceholders()
int | getNumPlaceholderTexts()
long | getRecordType() We are of type 1011
int | getRefID()
int | getSlideIdentifier()
void | setRefID(int id)
void | setSlideIdentifier(int id)
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlidePersistAtom

protected SlidePersistAtom(byte[] source,
                           int start,
                           int len)
For the SlidePersist Atom

SlidePersistAtom

public SlidePersistAtom()
Create a new SlidePersistAtom, for use with a new Slide

Method Detail

getRefID

public int getRefID()

getSlideIdentifier

public int getSlideIdentifier()

getNumPlaceholderTexts

public int getNumPlaceholderTexts()

getHasShapesOtherThanPlaceholders

public boolean getHasShapesOtherThanPlaceholders()

setRefID

public void setRefID(int id)

setSlideIdentifier

public void setSlideIdentifier(int id)

getRecordType

public long getRecordType()
We are of type 1011

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sound

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class Sound

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.Sound

public final class Sound
extends RecordContainer

A container holding information about a sound. It contains:

  • 1. CString (4026), Instance 0: Name of sound (e.g. "crash")
  • 2. CString (4026), Instance 1: Type of sound (e.g. ".wav")
  • 3. CString (4026), Instance 2: Reference id of sound in sound collection
  • 4. CString (4026), Instance 3, optional: Built-in id of sound, for sounds we ship. This is the id that?s in the reg file.
  • 5. SoundData (2023), optional

    Author:
    Yegor Kozlov

    Field Summary
    Fields inherited from class org.apache.poi.hslf.record.RecordContainer
    _children
    Fields inherited from class org.apache.poi.hslf.record.Record
    logger
    Constructor Summary
    protected Sound(byte[] source, int start, int len)
    Set things up, and find our more interesting children
    Method Summary
     long getRecordType()
    Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
     byte[] getSoundData()
    The sound data
     java.lang.String getSoundName()
    Name of the sound (e.g.
     java.lang.String getSoundType()
    Type of the sound (e.g.
     void writeOut(java.io.OutputStream out)
    Have the contents printer out into an OutputStream, used when writing a file back out to disk.
    Methods inherited from class org.apache.poi.hslf.record.RecordContainer
    addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
    Methods inherited from class org.apache.poi.hslf.record.Record
    buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
    Methods inherited from class java.lang.Object
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Constructor Detail

    Sound

    protected Sound(byte[] source,
                int start,
                int len)
    Set things up, and find our more interesting children

    Parameters:
    source - the source data as a byte array.
    start - the start offset into the byte array.
    len - the length of the slice in the byte array.
    Method Detail

    getRecordType

    public long getRecordType()
    Returns the type (held as a little endian in bytes 3 and 4) that this class handles.

    Specified by:
    getRecordType in class Record
    Returns:
    the record type.

    writeOut

    public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
    Have the contents printer out into an OutputStream, used when writing a file back out to disk.

    Specified by:
    writeOut in class Record
    Parameters:
    out - the output stream.
    Throws:
    java.io.IOException - if there was an error writing to the stream.

    getSoundName

    public java.lang.String getSoundName()
    Name of the sound (e.g. "crash")

    Returns:
    name of the sound

    getSoundType

    public java.lang.String getSoundType()
    Type of the sound (e.g. ".wav")

    Returns:
    type of the sound

    getSoundData

    public byte[] getSoundData()
    The sound data

    Returns:
    the sound data.
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SoundCollection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SoundCollection

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordContainer
            extended by  org.apache.poi.hslf.record.SoundCollection

public final class SoundCollection
extends RecordContainer

Is a container for all sound related atoms and containers. It contains:

  • 1. SoundCollAtom (2021)
  • 2. Sound (2022), for each sound, if any

    Author:
    Yegor Kozlov

    Field Summary
    Fields inherited from class org.apache.poi.hslf.record.RecordContainer
    _children
    Fields inherited from class org.apache.poi.hslf.record.Record
    logger
    Constructor Summary
    protected SoundCollection(byte[] source, int start, int len)
    Set things up, and find our more interesting children
    Method Summary
     long getRecordType()
    Returns the type (held as a little endian in bytes 3 and 4) that this class handles.
     void writeOut(java.io.OutputStream out)
    Have the contents printer out into an OutputStream, used when writing a file back out to disk.
    Methods inherited from class org.apache.poi.hslf.record.RecordContainer
    addChildAfter, addChildBefore, appendChildRecord, findFirstOfType, getChildRecords, handleParentAwareRecords, isAnAtom, moveChildBefore, moveChildrenAfter, moveChildrenBefore, removeChild, setChildRecord, writeOut
    Methods inherited from class org.apache.poi.hslf.record.Record
    buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
    Methods inherited from class java.lang.Object
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Constructor Detail

    SoundCollection

    protected SoundCollection(byte[] source,
                          int start,
                          int len)
    Set things up, and find our more interesting children

    Parameters:
    source - the source data as a byte array.
    start - the start offset into the byte array.
    len - the length of the slice in the byte array.
    Method Detail

    getRecordType

    public long getRecordType()
    Returns the type (held as a little endian in bytes 3 and 4) that this class handles.

    Specified by:
    getRecordType in class Record
    Returns:
    the record type.

    writeOut

    public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
    Have the contents printer out into an OutputStream, used when writing a file back out to disk.

    Specified by:
    writeOut in class Record
    Parameters:
    out - the output stream.
    Throws:
    java.io.IOException - if there was an error writing to the stream.
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SoundData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class SoundData

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.SoundData

public final class SoundData
extends RecordAtom

Storage for embedded sounds.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected | SoundData() Constructs a new empty sound container.
protected | SoundData(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
byte[] | getData() Returns the sound data.
long | getRecordType() Gets the record type.
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk.
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SoundData

protected SoundData()
Constructs a new empty sound container.

SoundData

protected SoundData(byte[] source,
                    int start,
                    int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getData

public byte[] getData()
Returns the sound data.

Returns:
the sound data

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk.

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StyleTextPropAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class StyleTextPropAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.StyleTextPropAtom

public final class StyleTextPropAtom
extends RecordAtom

A StyleTextPropAtom (type 4001). Holds basic character properties (bold, italic, underline, font size etc) and paragraph properties (alignment, line spacing etc) for the block of text (TextBytesAtom or TextCharsAtom) that this record follows. You will find two lists within this class. 1 - Paragraph style list (paragraphStyles) 2 - Character style list (charStyles) Both are lists of TextPropCollections. These define how many characters the style applies to, and what style elements make up the style (another list, this time of TextProps). Each TextProp has a value, which somehow encapsulates a property of the style

Author:
Nick Burch, Yegor Kozlov

Field Summary
static TextProp[] | characterTextPropTypes All the different kinds of character properties we might handle
static TextProp[] | paragraphTextPropTypes All the different kinds of paragraph properties we might handle
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
StyleTextPropAtom(byte[] source, int start, int len)
For the Text Style Properties (StyleTextProp) Atom
StyleTextPropAtom(int parentTextSize)
A new set of text style properties for some text without any.
Method Summary
TextPropCollection | addCharacterTextPropCollection(int charactersCovered) Create a new Character TextPropCollection, and add it to the list
TextPropCollection | addParagraphTextPropCollection(int charactersCovered) Create a new Paragraph TextPropCollection, and add it to the list
java.util.LinkedList<TextPropCollection> | getCharacterStyles()
int | getCharacterTextLengthCovered() Returns how many characters the character's TextPropCollections cover.
java.util.LinkedList<TextPropCollection> | getParagraphStyles()
int | getParagraphTextLengthCovered() Returns how many characters the paragraph's TextPropCollections cover.
long | getRecordType() We are of type 4001
void | setCharacterStyles(java.util.LinkedList<TextPropCollection> cs) Updates the link list of TextPropCollections which make up the character stylings
void | setParagraphStyles(java.util.LinkedList<TextPropCollection> ps) Updates the link list of TextPropCollections which make up the paragraph stylings
void | setParentTextSize(int size) Tell us how much text the parent TextCharsAtom or TextBytesAtom contains, so we can go ahead and initialise ourselves.
void | setRawContents(byte[] bytes)
java.lang.String | toString() Dump the record content into StringBuffer
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

paragraphTextPropTypes

public static TextProp[] paragraphTextPropTypes
All the different kinds of paragraph properties we might handle

characterTextPropTypes

public static TextProp[] characterTextPropTypes
All the different kinds of character properties we might handle

Constructor Detail

StyleTextPropAtom

public StyleTextPropAtom(byte[] source,
                         int start,
                         int len)
For the Text Style Properties (StyleTextProp) Atom

StyleTextPropAtom

public StyleTextPropAtom(int parentTextSize)
A new set of text style properties for some text without any.

Method Detail

getParagraphStyles

public java.util.LinkedList<TextPropCollection> getParagraphStyles()

setParagraphStyles

public void setParagraphStyles(java.util.LinkedList<TextPropCollection> ps)
Updates the link list of TextPropCollections which make up the paragraph stylings

getCharacterStyles

public java.util.LinkedList<TextPropCollection> getCharacterStyles()

setCharacterStyles

public void setCharacterStyles(java.util.LinkedList<TextPropCollection> cs)
Updates the link list of TextPropCollections which make up the character stylings

getParagraphTextLengthCovered

public int getParagraphTextLengthCovered()
Returns how many characters the paragraph's TextPropCollections cover. (May be one or two more than the underlying text does, due to having extra characters meaning something special to powerpoint)

getCharacterTextLengthCovered

public int getCharacterTextLengthCovered()
Returns how many characters the character's TextPropCollections cover. (May be one or two more than the underlying text does, due to having extra characters meaning something special to powerpoint)

getRecordType

public long getRecordType()
We are of type 4001

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

setParentTextSize

public void setParentTextSize(int size)
Tell us how much text the parent TextCharsAtom or TextBytesAtom contains, so we can go ahead and initialise ourselves.

setRawContents

public void setRawContents(byte[] bytes)

addParagraphTextPropCollection

public TextPropCollection addParagraphTextPropCollection(int charactersCovered)
Create a new Paragraph TextPropCollection, and add it to the list

Parameters:
charactersCovered - The number of characters this TextPropCollection will cover
Returns:
the new TextPropCollection, which will then be in the list

addCharacterTextPropCollection

public TextPropCollection addCharacterTextPropCollection(int charactersCovered)
Create a new Character TextPropCollection, and add it to the list

Parameters:
charactersCovered - The number of characters this TextPropCollection will cover
Returns:
the new TextPropCollection, which will then be in the list

toString

public java.lang.String toString()
Dump the record content into StringBuffer

Overrides:
toString in class java.lang.Object
Returns:
the string representation of the record data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextBytesAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TextBytesAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.TextBytesAtom

public final class TextBytesAtom
extends RecordAtom

A TextBytesAtom (type 4008). Holds text in ascii form (unknown code page, for now assumed to be the default of org.apache.poi.util.StringUtil, which is the Excel default). The trailing return character is always stripped from this

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | TextBytesAtom() Create an empty TextBytes Atom
protected | TextBytesAtom(byte[] source, int start, int len) For the TextBytes Atom
Method Summary
 long getRecordType()
We are of type 4008
 java.lang.String getText()
Grabs the text.
 void setText(byte[] b)
Updates the text in the Atom.
 java.lang.String toString()
dump debug info; use getText() to return a string representation of the atom
 void writeOut(java.io.OutputStream out)
Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TextBytesAtom

protected TextBytesAtom(byte[] source,
                        int start,
                        int len)
For the TextBytes Atom

TextBytesAtom

public TextBytesAtom()
Create an empty TextBytes Atom

Method Detail

getText

public java.lang.String getText()
Grabs the text. Uses the default codepage

setText

public void setText(byte[] b)
Updates the text in the Atom. Must be 8 bit ascii

getRecordType

public long getRecordType()
We are of type 4008

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

toString

public java.lang.String toString()
dump debug info; use getText() to return a string representation of the atom

Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextCharsAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TextCharsAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.TextCharsAtom

public final class TextCharsAtom
extends RecordAtom

A TextCharsAtom (type 4000). Holds text in byte swapped unicode form. The trailing return character is always stripped from this

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | TextCharsAtom() Create an empty TextCharsAtom
protected | TextCharsAtom(byte[] source, int start, int len) For the TextChars Atom
Method Summary
 long getRecordType()
We are of type 4000
 java.lang.String getText()
Grabs the text.
 void setText(java.lang.String text)
Updates the text in the Atom.
 java.lang.String toString()
dump debug info; use getText() to return a string representation of the atom
 void writeOut(java.io.OutputStream out)
Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TextCharsAtom

protected TextCharsAtom(byte[] source,
                        int start,
                        int len)
For the TextChars Atom

TextCharsAtom

public TextCharsAtom()
Create an empty TextCharsAtom

Method Detail

getText

public java.lang.String getText()
Grabs the text.

setText

public void setText(java.lang.String text)
Updates the text in the Atom.

getRecordType

public long getRecordType()
We are of type 4000

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

toString

public java.lang.String toString()
dump debug info; use getText() to return a string representation of the atom

Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextHeaderAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TextHeaderAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.TextHeaderAtom
All Implemented Interfaces:
ParentAwareRecord
public final class TextHeaderAtom
extends RecordAtom
implements ParentAwareRecord

A TextHeaderAtom (type 3999). Holds information on what kind of text is contained in the TextBytesAtom / TextCharsAtom that follows straight after

Author:
Nick Burch

Field Summary
static int | BODY_TYPE
static int | CENTER_TITLE_TYPE
static int | CENTRE_BODY_TYPE
static int | HALF_BODY_TYPE
static int | NOTES_TYPE
static int | OTHER_TYPE
static int | QUARTER_BODY_TYPE
static int | TITLE_TYPE
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | TextHeaderAtom() Create a new TextHeader Atom, for an unknown type of text
protected | TextHeaderAtom(byte[] source, int start, int len) For the TextHeader Atom
Method Summary
RecordContainer | getParentRecord()
long | getRecordType() We are of type 3999
int | getTextType()
void | setParentRecord(RecordContainer record)
void | setTextType(int type)
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TITLE_TYPE

public static final int TITLE_TYPE
See Also:
Constant Field Values

BODY_TYPE

public static final int BODY_TYPE
See Also:
Constant Field Values

NOTES_TYPE

public static final int NOTES_TYPE
See Also:
Constant Field Values

OTHER_TYPE

public static final int OTHER_TYPE
See Also:
Constant Field Values

CENTRE_BODY_TYPE

public static final int CENTRE_BODY_TYPE
See Also:
Constant Field Values

CENTER_TITLE_TYPE

public static final int CENTER_TITLE_TYPE
See Also:
Constant Field Values

HALF_BODY_TYPE

public static final int HALF_BODY_TYPE
See Also:
Constant Field Values

QUARTER_BODY_TYPE

public static final int QUARTER_BODY_TYPE
See Also:
Constant Field Values
Constructor Detail

TextHeaderAtom

protected TextHeaderAtom(byte[] source,
                         int start,
                         int len)
For the TextHeader Atom

TextHeaderAtom

public TextHeaderAtom()
Create a new TextHeader Atom, for an unknown type of text

Method Detail

getTextType

public int getTextType()

setTextType

public void setTextType(int type)

getParentRecord

public RecordContainer getParentRecord()
Specified by:
getParentRecord in interface ParentAwareRecord

setParentRecord

public void setParentRecord(RecordContainer record)
Specified by:
setParentRecord in interface ParentAwareRecord

getRecordType

public long getRecordType()
We are of type 3999

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextRulerAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TextRulerAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.TextRulerAtom

public final class TextRulerAtom
extends RecordAtom

Ruler of a text as it differs from the style's ruler settings.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | TextRulerAtom() Constructs a new empty ruler atom.
protected | TextRulerAtom(byte[] source, int start, int len) Constructs the ruler atom record from its source data.
Method Summary
int[] | getBulletOffsets() First line of paragraph's distance from shape's left margin, in master coordinates (576 dpi).
int | getDefaultTabSize() Default distance between tab stops, in master coordinates (576 dpi).
int | getNumberOfLevels() Number of indent levels (maximum 5).
static TextRulerAtom | getParagraphInstance()
long | getRecordType() Gets the record type.
int[] | getTabStops() Default distance between tab stops, in master coordinates (576 dpi).
int[] | getTextOffsets() Paragraph's distance from shape's left margin, in master coordinates (576 dpi).
void | setParagraphIndent(short tetxOffset, short bulletOffset)
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk.
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextRulerAtom

public TextRulerAtom()
Constructs a new empty ruler atom.

TextRulerAtom

protected TextRulerAtom(byte[] source,
                        int start,
                        int len)
Constructs the ruler atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk.

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.

getDefaultTabSize

public int getDefaultTabSize()
Default distance between tab stops, in master coordinates (576 dpi).

getNumberOfLevels

public int getNumberOfLevels()
Number of indent levels (maximum 5).

getTabStops

public int[] getTabStops()
Default distance between tab stops, in master coordinates (576 dpi).

getTextOffsets

public int[] getTextOffsets()
Paragraph's distance from shape's left margin, in master coordinates (576 dpi).

getBulletOffsets

public int[] getBulletOffsets()
First line of paragraph's distance from shape's left margin, in master coordinates (576 dpi).

getParagraphInstance

public static TextRulerAtom getParagraphInstance()

setParagraphIndent

public void setParagraphIndent(short tetxOffset,
                               short bulletOffset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextSpecInfoAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TextSpecInfoAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.TextSpecInfoAtom

public final class TextSpecInfoAtom
extends RecordAtom

The special info runs contained in this text. Special info runs consist of character properties which don?t follow styles.

Author:
Yegor Kozlov

Nested Class Summary
static class TextSpecInfoAtom.TextSpecInfoRun
Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected TextSpecInfoAtom(byte[] source, int start, int len)
Constructs the link related atom record from its source data.
Method Summary
int | getCharactersCovered() Get the number of characters covered by this records
long | getRecordType() Gets the record type.
TextSpecInfoAtom.TextSpecInfoRun[] | getTextSpecInfoRuns()
void | reset(int size) Reset the content to one info run with the default values
void | setTextSize(int size) Update the text length
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextSpecInfoAtom

protected TextSpecInfoAtom(byte[] source,
                           int start,
                           int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.

setTextSize

public void setTextSize(int size)
Update the text length

Parameters:
size - the text length

reset

public void reset(int size)
Reset the content to one info run with the default values

Parameters:
size - the site of parent text

getCharactersCovered

public int getCharactersCovered()
Get the number of characters covered by this records

Returns:
the number of characters covered by this records

getTextSpecInfoRuns

public TextSpecInfoAtom.TextSpecInfoRun[] getTextSpecInfoRuns()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextSpecInfoAtom.TextSpecInfoRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TextSpecInfoAtom.TextSpecInfoRun

java.lang.Object
    extended by  org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun
Enclosing class:
TextSpecInfoAtom
public static class TextSpecInfoAtom.TextSpecInfoRun
extends java.lang.Object

Field Summary
protected short | altLangId
protected short | langId
protected int | len
protected int | mask
protected short | spellInfo
Constructor Summary
TextSpecInfoAtom.TextSpecInfoRun()
Method Summary
short | getAltLangId() Alternate Windows LANGID of this text; must be a valid non-East Asian LANGID if the text has an East Asian language, otherwise may be an East Asian LANGID or language neutral (zero).
short | getLangId() Windows LANGID for this text.
short | getSpellInfo() Spelling status of this text.
int | length()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

len

protected int len

mask

protected int mask

spellInfo

protected short spellInfo

langId

protected short langId

altLangId

protected short altLangId
Constructor Detail

TextSpecInfoAtom.TextSpecInfoRun

public TextSpecInfoAtom.TextSpecInfoRun()
Method Detail

getSpellInfo

public short getSpellInfo()
Spelling status of this text. See Spell Info table below.

Spell Info Types:

  • 0 Unchecked
  • 1 Previously incorrect, needs rechecking
  • 2 Correct
  • 3 Incorrect

    Returns:
    Spelling status of this text

    • getLangId

    public short getLangId()
    Windows LANGID for this text.

    Returns:
    Windows LANGID for this text.

    getAltLangId

    public short getAltLangId()
    Alternate Windows LANGID of this text; must be a valid non-East Asian LANGID if the text has an East Asian language, otherwise may be an East Asian LANGID or language neutral (zero).

    Returns:
    Alternate Windows LANGID of this text

    length

    public int length()
    Returns:
    Length of special info run.
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TxInteractiveInfoAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TxInteractiveInfoAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.TxInteractiveInfoAtom

public final class TxInteractiveInfoAtom
extends RecordAtom

Tne atom that holds starting and ending character positions of a hyperlink

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
 | TxInteractiveInfoAtom() Constructs a brand new link related atom record.
protected | TxInteractiveInfoAtom(byte[] source, int start, int len) Constructs the link related atom record from its source data.
Method Summary
int | getEndIndex() Gets the ending character position
long | getRecordType() Gets the record type.
int | getStartIndex() Gets the beginning character position
void | setEndIndex(int idx) Sets the ending character position
void | setStartIndex(int idx) Sets the beginning character position
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TxInteractiveInfoAtom

public TxInteractiveInfoAtom()
Constructs a brand new link related atom record.

TxInteractiveInfoAtom

protected TxInteractiveInfoAtom(byte[] source,
                                int start,
                                int len)
Constructs the link related atom record from its source data.

Parameters:
source - the source data as a byte array.
start - the start offset into the byte array.
len - the length of the slice in the byte array.
Method Detail

getStartIndex

public int getStartIndex()
Gets the beginning character position

Returns:
the beginning character position

setStartIndex

public void setStartIndex(int idx)
Sets the beginning character position

Parameters:
idx - the beginning character position

getEndIndex

public int getEndIndex()
Gets the ending character position

Returns:
the ending character position

setEndIndex

public void setEndIndex(int idx)
Sets the ending character position

Parameters:
idx - the ending character position

getRecordType

public long getRecordType()
Gets the record type.

Specified by:
getRecordType in class Record
Returns:
the record type.

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Parameters:
out - the output stream to write to.
Throws:
java.io.IOException - if an error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TxMasterStyleAtom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class TxMasterStyleAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.TxMasterStyleAtom

public final class TxMasterStyleAtom
extends RecordAtom

TxMasterStyleAtom atom (4003).

Stores default character and paragraph styles. The atom instance value is the text type and is encoded like the txstyle field in TextHeaderAtom. The text styles are located in the MainMaster container, except for the "other" style, which is in the Document.Environment container.

This atom can store up to 5 pairs of paragraph+character styles, each pair describes an indent level. The first pair describes first-level paragraph with no indentation.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected TxMasterStyleAtom(byte[] source, int start, int len)
Method Summary
protected TextProp[] | getCharacterProps(int type, int level) Character properties for the specified text type and indent level.
TextPropCollection[] | getCharacterStyles() Returns array of character styles defined in this record.
protected TextProp[] | getParagraphProps(int type, int level) Paragraph properties for the specified text type and indent level Depending on the level and type, it may be our special ones, or the standard StyleTextPropAtom ones
TextPropCollection[] | getParagraphStyles() Returns array of paragraph styles defined in this record.
long | getRecordType() We are of type 4003
int | getTextType() Return type of the text.
protected void | init() parse the record data and initialize styles
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TxMasterStyleAtom

protected TxMasterStyleAtom(byte[] source,
                            int start,
                            int len)
Method Detail

getRecordType

public long getRecordType()
We are of type 4003

Specified by:
getRecordType in class Record
Returns:
type of this record
See Also:
RecordTypes.TxMasterStyleAtom

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException

getCharacterStyles

public TextPropCollection[] getCharacterStyles()
Returns array of character styles defined in this record.

Returns:
character styles defined in this record

getParagraphStyles

public TextPropCollection[] getParagraphStyles()
Returns array of paragraph styles defined in this record.

Returns:
paragraph styles defined in this record

getTextType

public int getTextType()
Return type of the text. Must be a constant defined in TextHeaderAtom

Returns:
type of the text
See Also:
TextHeaderAtom

init

protected void init()
parse the record data and initialize styles

getParagraphProps

protected TextProp[] getParagraphProps(int type,
                                       int level)
Paragraph properties for the specified text type and indent level Depending on the level and type, it may be our special ones, or the standard StyleTextPropAtom ones

getCharacterProps

protected TextProp[] getCharacterProps(int type,
                                       int level)
Character properties for the specified text type and indent level. Depending on the level and type, it may be our special ones, or the standard StyleTextPropAtom ones

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownRecordPlaceholder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class UnknownRecordPlaceholder

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.UnknownRecordPlaceholder

public final class UnknownRecordPlaceholder
extends RecordAtom

If we come across a record we don't know about, we create one of these. It allows us to keep track of what it contains, so we can write it back out to disk unchanged

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected UnknownRecordPlaceholder(byte[] source, int start, int len)
Create a new holder for a record we don't grok
Method Summary
long | getRecordType() Return the value we were given at creation
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnknownRecordPlaceholder

protected UnknownRecordPlaceholder(byte[] source,
                                   int start,
                                   int len)
Create a new holder for a record we don't grok

Method Detail

getRecordType

public long getRecordType()
Return the value we were given at creation

Specified by:
getRecordType in class Record

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserEditAtom

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.record
Class UserEditAtom

java.lang.Object
    extended by  org.apache.poi.hslf.record.Record
        extended by  org.apache.poi.hslf.record.RecordAtom
            extended by  org.apache.poi.hslf.record.PositionDependentRecordAtom
                extended by  org.apache.poi.hslf.record.UserEditAtom
All Implemented Interfaces:
PositionDependentRecord
public final class UserEditAtom
extends PositionDependentRecordAtom

A UserEdit Atom (type 4085). Holds information which bits of the file were last used by powerpoint, the version of powerpoint last used etc. ** WARNING ** stores byte offsets from the start of the PPT stream to other records! If you change the size of any elements before one of these, you'll need to update the offsets!

Author:
Nick Burch

Field Summary
static int | LAST_VIEW_NONE
static int | LAST_VIEW_NOTES
static int | LAST_VIEW_OUTLINE_VIEW
static int | LAST_VIEW_SLIDE_VIEW
Fields inherited from class org.apache.poi.hslf.record.PositionDependentRecordAtom
myLastOnDiskOffset
Fields inherited from class org.apache.poi.hslf.record.Record
logger
Constructor Summary
protected UserEditAtom(byte[] source, int start, int len)
For the UserEdit Atom
Method Summary
int | getDocPersistRef()
int | getLastUserEditAtomOffset()
int | getLastViewedSlideID()
short | getLastViewType()
int | getMaxPersistWritten()
int | getPersistPointersOffset()
long | getRecordType() We are of type 4085
void | setLastUserEditAtomOffset(int offset)
void | setLastViewType(short type)
void | setMaxPersistWritten(int max)
void | setPersistPointersOffset(int offset)
void | updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup) At write-out time, update the references to PersistPtrs and other UserEditAtoms to point to their new positions
void | writeOut(java.io.OutputStream out) Write the contents of the record back, so it can be written to disk
Methods inherited from class org.apache.poi.hslf.record.PositionDependentRecordAtom
getLastOnDiskOffset, setLastOnDiskOffset
Methods inherited from class org.apache.poi.hslf.record.RecordAtom
getChildRecords, isAnAtom
Methods inherited from class org.apache.poi.hslf.record.Record
buildRecordAtOffset, createRecordForType, findChildRecords, writeLittleEndian, writeLittleEndian
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LAST_VIEW_NONE

public static final int LAST_VIEW_NONE
See Also:
Constant Field Values

LAST_VIEW_SLIDE_VIEW

public static final int LAST_VIEW_SLIDE_VIEW
See Also:
Constant Field Values

LAST_VIEW_OUTLINE_VIEW

public static final int LAST_VIEW_OUTLINE_VIEW
See Also:
Constant Field Values

LAST_VIEW_NOTES

public static final int LAST_VIEW_NOTES
See Also:
Constant Field Values
Constructor Detail

UserEditAtom

protected UserEditAtom(byte[] source,
                       int start,
                       int len)
For the UserEdit Atom

Method Detail

getLastViewedSlideID

public int getLastViewedSlideID()

getLastViewType

public short getLastViewType()

getLastUserEditAtomOffset

public int getLastUserEditAtomOffset()

getPersistPointersOffset

public int getPersistPointersOffset()

getDocPersistRef

public int getDocPersistRef()

getMaxPersistWritten

public int getMaxPersistWritten()

setLastUserEditAtomOffset

public void setLastUserEditAtomOffset(int offset)

setPersistPointersOffset

public void setPersistPointersOffset(int offset)

setLastViewType

public void setLastViewType(short type)

setMaxPersistWritten

public void setMaxPersistWritten(int max)

getRecordType

public long getRecordType()
We are of type 4085

Specified by:
getRecordType in class Record

updateOtherRecordReferences

public void updateOtherRecordReferences(java.util.Hashtable<java.lang.Integer,java.lang.Integer> oldToNewReferencesLookup)
At write-out time, update the references to PersistPtrs and other UserEditAtoms to point to their new positions

Specified by:
updateOtherRecordReferences in interface PositionDependentRecord
Specified by:
updateOtherRecordReferences in class PositionDependentRecordAtom

writeOut

public void writeOut(java.io.OutputStream out)
              throws java.io.IOException
Write the contents of the record back, so it can be written to disk

Specified by:
writeOut in class Record
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.record.AnimationInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.AnimationInfo

No usage of org.apache.poi.hslf.record.AnimationInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.AnimationInfoAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.AnimationInfoAtom

Packages that use AnimationInfoAtom
org.apache.poi.hslf.record

Uses of AnimationInfoAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return AnimationInfoAtom
 AnimationInfoAtom AnimationInfo.getAnimationInfoAtom()
Returns the AnimationInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ColorSchemeAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ColorSchemeAtom

Packages that use ColorSchemeAtom
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of ColorSchemeAtom in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return ColorSchemeAtom
ColorSchemeAtom | Slide.getColorScheme() Color scheme for this slide.
ColorSchemeAtom | Sheet.getColorScheme() Color scheme for this sheet.

Uses of ColorSchemeAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ColorSchemeAtom
ColorSchemeAtom | Slide.getColorScheme()
abstract ColorSchemeAtom | SheetContainer.getColorScheme()
ColorSchemeAtom | Notes.getColorScheme()
ColorSchemeAtom | MainMaster.getColorScheme()
ColorSchemeAtom[] | MainMaster.getColorSchemeAtoms()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Comment2000

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Comment2000

Packages that use Comment2000
org.apache.poi.hslf.model

Uses of Comment2000 in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return Comment2000
protected  Comment2000 Comment.getComment2000()

Constructors in org.apache.poi.hslf.model with parameters of type Comment2000
Comment(Comment2000 comment2000)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Comment2000Atom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Comment2000Atom

Packages that use Comment2000Atom
org.apache.poi.hslf.record

Uses of Comment2000Atom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return Comment2000Atom
 Comment2000Atom Comment2000.getComment2000Atom()
Returns the Comment2000Atom of this Comment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.CString

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.CString

Packages that use CString
org.apache.poi.hslf.record

Uses of CString in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return CString
CString | HeadersFootersContainer.addFooterAtom() Insert a CString record that stores the user's date.
CString | HeadersFootersContainer.addHeaderAtom() Insert a CString record that stores the user's date.
CString | HeadersFootersContainer.addUserDateAtom() Insert a CString record that stores the user's date.
CString | HeadersFootersContainer.getFooterAtom() A CString record that stores the Footers's contents.
CString | HeadersFootersContainer.getHeaderAtom() A CString record that stores the Header's contents.
CString | ExVideoContainer.getPathAtom() Returns the Path Atom (CString) of this link
CString | HeadersFootersContainer.getUserDateAtom() A CString record that stores the user's date.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.CurrentUserAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.CurrentUserAtom

Packages that use CurrentUserAtom
org.apache.poi.hslf

Uses of CurrentUserAtom in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return CurrentUserAtom
 CurrentUserAtom HSLFSlideShow.getCurrentUserAtom()
Fetch the Current User Atom of the document

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Document

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Document

Packages that use Document
org.apache.poi.hslf.usermodel

Uses of Document in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return Document
 Document SlideShow.getDocumentRecord()
Helper method for usermodel and model: Get the document record

Methods in org.apache.poi.hslf.usermodel with parameters of type Document
static SoundData[] SoundData.find(Document document)
Find all sound records in the supplied Document records

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.DocumentAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.DocumentAtom

Packages that use DocumentAtom
org.apache.poi.hslf.record

Uses of DocumentAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return DocumentAtom
 DocumentAtom Document.getDocumentAtom()
Returns the DocumentAtom of this Document

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.DocumentAtom.SlideSize

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.DocumentAtom.SlideSize

No usage of org.apache.poi.hslf.record.DocumentAtom.SlideSize

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.DocumentEncryptionAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.DocumentEncryptionAtom

Packages that use DocumentEncryptionAtom
org.apache.poi.hslf

Uses of DocumentEncryptionAtom in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return DocumentEncryptionAtom
static DocumentEncryptionAtom EncryptedSlideShow.fetchDocumentEncryptionAtom(HSLFSlideShow hss)
Return the DocumentEncryptionAtom for a HSLFSlideShow, or null if there isn't one.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren

No usage of org.apache.poi.hslf.record.DummyPositionSensitiveRecordWithChildren

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.DummyRecordWithChildren

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.DummyRecordWithChildren

No usage of org.apache.poi.hslf.record.DummyRecordWithChildren

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Environment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Environment

Packages that use Environment
org.apache.poi.hslf.record

Uses of Environment in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return Environment
 Environment Document.getEnvironment()
Returns the Environment of this Notes, which lots of settings for the document in it

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.EscherTextboxWrapper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.EscherTextboxWrapper

Packages that use EscherTextboxWrapper
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of EscherTextboxWrapper in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as EscherTextboxWrapper
protected  EscherTextboxWrapper TextShape._txtbox
Escher container which holds text attributes such as TextHeaderAtom, TextBytesAtom ot TextCharsAtom, StyleTextPropAtom etc.

Methods in org.apache.poi.hslf.model that return EscherTextboxWrapper
protected  EscherTextboxWrapper TextShape.getEscherTextboxWrapper()

Uses of EscherTextboxWrapper in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return EscherTextboxWrapper
 EscherTextboxWrapper[] PPDrawing.getTextboxWrappers()
Get access to the atoms inside Textboxes

Methods in org.apache.poi.hslf.record with parameters of type EscherTextboxWrapper
 void PPDrawing.addTextboxWrapper(EscherTextboxWrapper txtbox)
Add a new EscherTextboxWrapper to this PPDrawing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExAviMovie

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExAviMovie

No usage of org.apache.poi.hslf.record.ExAviMovie

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExControl

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExControl

Packages that use ExControl
org.apache.poi.hslf.model

Uses of ExControl in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return ExControl
 ExControl ActiveXShape.getExControl()
Document-level container that specifies information about an ActiveX control

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExControlAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExControlAtom

Packages that use ExControlAtom
org.apache.poi.hslf.record

Uses of ExControlAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExControlAtom
 ExControlAtom ExControl.getExControlAtom()
Gets the ExControlAtom.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExEmbed

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExEmbed

Packages that use ExEmbed
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of ExEmbed in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as ExEmbed
protected  ExEmbed OLEShape._exEmbed

Methods in org.apache.poi.hslf.model that return ExEmbed
 ExEmbed OLEShape.getExEmbed()
Return the record container for this embedded object.

Uses of ExEmbed in org.apache.poi.hslf.record

Subclasses of ExEmbed in org.apache.poi.hslf.record
 class ExControl
A container record that specifies information about an ActiveX control.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExEmbedAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExEmbedAtom

Packages that use ExEmbedAtom
org.apache.poi.hslf.record

Uses of ExEmbedAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExEmbedAtom
 ExEmbedAtom ExEmbed.getExEmbedAtom()
Gets the ExEmbedAtom.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExHyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExHyperlink

Packages that use ExHyperlink
org.apache.poi.hslf.record

Uses of ExHyperlink in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExHyperlink
ExHyperlink | ExObjList.get(int id) Lookup a hyperlink by its unique id
ExHyperlink[] | ExObjList.getExHyperlinks() Returns all the ExHyperlinks

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExHyperlinkAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExHyperlinkAtom

Packages that use ExHyperlinkAtom
org.apache.poi.hslf.record

Uses of ExHyperlinkAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExHyperlinkAtom
 ExHyperlinkAtom ExHyperlink.getExHyperlinkAtom()
Returns the ExHyperlinkAtom of this link

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExMCIMovie

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExMCIMovie

Packages that use ExMCIMovie
org.apache.poi.hslf.record

Uses of ExMCIMovie in org.apache.poi.hslf.record

Subclasses of ExMCIMovie in org.apache.poi.hslf.record
 class ExAviMovie
A container record that specifies information about a movie stored externally.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExMediaAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExMediaAtom

Packages that use ExMediaAtom
org.apache.poi.hslf.record

Uses of ExMediaAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExMediaAtom
 ExMediaAtom ExVideoContainer.getExMediaAtom()
Returns the ExMediaAtom of this link

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExObjList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExObjList

Packages that use ExObjList
org.apache.poi.hslf.record

Uses of ExObjList in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExObjList
 ExObjList Document.getExObjList()
Returns the ExObjList, which holds the references to external objects used in the slides.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExObjListAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExObjListAtom

Packages that use ExObjListAtom
org.apache.poi.hslf.record

Uses of ExObjListAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExObjListAtom
 ExObjListAtom ExObjList.getExObjListAtom()
Returns the ExObjListAtom of this list

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExOleObjAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExOleObjAtom

Packages that use ExOleObjAtom
org.apache.poi.hslf.record

Uses of ExOleObjAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExOleObjAtom
 ExOleObjAtom ExEmbed.getExOleObjAtom()
Gets the ExOleObjAtom.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExOleObjStg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExOleObjStg

Packages that use ExOleObjStg
org.apache.poi.hslf.usermodel

Uses of ExOleObjStg in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return ExOleObjStg
 ExOleObjStg ObjectData.getExOleObjStg()
Return the record that contains the object data.

Constructors in org.apache.poi.hslf.usermodel with parameters of type ExOleObjStg
ObjectData(ExOleObjStg storage)
Creates the object data wrapping the record that contains the object data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.ExVideoContainer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.ExVideoContainer

Packages that use ExVideoContainer
org.apache.poi.hslf.record

Uses of ExVideoContainer in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return ExVideoContainer
 ExVideoContainer ExMCIMovie.getExVideo()
Returns the ExVideoContainer that specifies information about the MCI movie

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.FontCollection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.FontCollection

Packages that use FontCollection
org.apache.poi.hslf.record
org.apache.poi.hslf.usermodel

Uses of FontCollection in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return FontCollection
 FontCollection Environment.getFontCollection()
Returns the FontCollection of this Environment

Uses of FontCollection in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return FontCollection
protected  FontCollection SlideShow.getFontCollection()
Helper method for usermodel: Get the font collection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.FontEntityAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.FontEntityAtom

Packages that use FontEntityAtom
org.apache.poi.hslf.model

Uses of FontEntityAtom in org.apache.poi.hslf.model

Constructors in org.apache.poi.hslf.model with parameters of type FontEntityAtom
PPFont(FontEntityAtom fontAtom)
Creates a new instance of PPFont and initialize it from the supplied font atom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.HeadersFootersAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.HeadersFootersAtom

Packages that use HeadersFootersAtom
org.apache.poi.hslf.record

Uses of HeadersFootersAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return HeadersFootersAtom
 HeadersFootersAtom HeadersFootersContainer.getHeadersFootersAtom()
HeadersFootersAtom stores the basic information of the header and footer structure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.HeadersFootersContainer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.HeadersFootersContainer

Packages that use HeadersFootersContainer
org.apache.poi.hslf.model

Uses of HeadersFootersContainer in org.apache.poi.hslf.model

Constructors in org.apache.poi.hslf.model with parameters of type HeadersFootersContainer
HeadersFooters(HeadersFootersContainer rec, Sheet sheet, boolean newRecord, boolean isPpt2007)
HeadersFooters(HeadersFootersContainer rec, SlideShow ppt, boolean newRecord, boolean isPpt2007)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.InteractiveInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.InteractiveInfo

No usage of org.apache.poi.hslf.record.InteractiveInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.InteractiveInfoAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.InteractiveInfoAtom

Packages that use InteractiveInfoAtom
org.apache.poi.hslf.record

Uses of InteractiveInfoAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return InteractiveInfoAtom
 InteractiveInfoAtom InteractiveInfo.getInteractiveInfoAtom()
Returns the InteractiveInfoAtom of this InteractiveInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.MainMaster

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.MainMaster

Packages that use MainMaster
org.apache.poi.hslf.model

Uses of MainMaster in org.apache.poi.hslf.model

Constructors in org.apache.poi.hslf.model with parameters of type MainMaster
SlideMaster(MainMaster record, int sheetNo)
Constructs a SlideMaster from the MainMaster record,

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Notes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Notes

Packages that use Notes
org.apache.poi.hslf.model

Uses of Notes in org.apache.poi.hslf.model

Constructors in org.apache.poi.hslf.model with parameters of type Notes
Notes(Notes notes)
Constructs a Notes Sheet from the given Notes record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.NotesAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.NotesAtom

Packages that use NotesAtom
org.apache.poi.hslf.record

Uses of NotesAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return NotesAtom
 NotesAtom Notes.getNotesAtom()
Returns the NotesAtom of this Notes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.OEPlaceholderAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.OEPlaceholderAtom

Packages that use OEPlaceholderAtom
org.apache.poi.hslf.model

Uses of OEPlaceholderAtom in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return OEPlaceholderAtom
 OEPlaceholderAtom TextShape.getPlaceholderAtom()
Return OEPlaceholderAtom, the atom that describes a placeholder.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.OEShapeAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.OEShapeAtom

No usage of org.apache.poi.hslf.record.OEShapeAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.OutlineTextRefAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.OutlineTextRefAtom

No usage of org.apache.poi.hslf.record.OutlineTextRefAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hslf.record.ParentAwareRecord

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hslf.record.ParentAwareRecord

Packages that use ParentAwareRecord
org.apache.poi.hslf.record

Uses of ParentAwareRecord in org.apache.poi.hslf.record

Classes in org.apache.poi.hslf.record that implement ParentAwareRecord
 class TextHeaderAtom
A TextHeaderAtom (type 3999).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.PersistPtrHolder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.PersistPtrHolder

No usage of org.apache.poi.hslf.record.PersistPtrHolder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hslf.record.PersistRecord

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hslf.record.PersistRecord

Packages that use PersistRecord
org.apache.poi.hslf.record

Uses of PersistRecord in org.apache.poi.hslf.record

Classes in org.apache.poi.hslf.record that implement PersistRecord
 class ExOleObjStg
Storage for embedded OLE objects.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hslf.record.PositionDependentRecord

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hslf.record.PositionDependentRecord

Packages that use PositionDependentRecord
org.apache.poi.hslf.record

Uses of PositionDependentRecord in org.apache.poi.hslf.record

Classes in org.apache.poi.hslf.record that implement PositionDependentRecord
class | Document Master container for Document.
class | DummyPositionSensitiveRecordWithChildren If we come across a record we know has children of (potential) interest, but where the record itself is boring, but where other records may care about where this one lives, we create one of these.
class | Environment Environment, which contains lots of settings for the document.
class | ExOleObjStg Storage for embedded OLE objects.
class | MainMaster Master slide
class | Notes Master container for Notes.
class | PersistPtrHolder General holder for PersistPtrFullBlock and PersistPtrIncrementalBlock records.
class | PositionDependentRecordAtom A special (and dangerous) kind of Record Atom that cares about where it lives on the disk, or who has other Atoms that care about where this is on the disk.
class | PositionDependentRecordContainer A special (and dangerous) kind of Record Container, for which other Atoms care about where this one lives on disk.
class | SheetContainer The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
class | Slide Master container for Slides.
class | UserEditAtom A UserEdit Atom (type 4085).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.PositionDependentRecordAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.PositionDependentRecordAtom

Packages that use PositionDependentRecordAtom
org.apache.poi.hslf.record

Uses of PositionDependentRecordAtom in org.apache.poi.hslf.record

Subclasses of PositionDependentRecordAtom in org.apache.poi.hslf.record
class | PersistPtrHolder General holder for PersistPtrFullBlock and PersistPtrIncrementalBlock records.
class | UserEditAtom A UserEdit Atom (type 4085).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.PositionDependentRecordContainer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.PositionDependentRecordContainer

Packages that use PositionDependentRecordContainer
org.apache.poi.hslf.record

Uses of PositionDependentRecordContainer in org.apache.poi.hslf.record

Subclasses of PositionDependentRecordContainer in org.apache.poi.hslf.record
class | Document Master container for Document.
class | DummyPositionSensitiveRecordWithChildren If we come across a record we know has children of (potential) interest, but where the record itself is boring, but where other records may care about where this one lives, we create one of these.
class | Environment Environment, which contains lots of settings for the document.
class | MainMaster Master slide
class | Notes Master container for Notes.
class | SheetContainer The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
class | Slide Master container for Slides.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.PPDrawing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.PPDrawing

Packages that use PPDrawing
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of PPDrawing in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return PPDrawing
protected  PPDrawing Sheet.getPPDrawing()
Fetch the PPDrawing from the underlying record

Methods in org.apache.poi.hslf.model with parameters of type PPDrawing
static TextRun[] Sheet.findTextRuns(PPDrawing ppdrawing)
For a given PPDrawing, grab all the TextRuns

Uses of PPDrawing in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return PPDrawing
PPDrawing | Slide.getPPDrawing() Returns the PPDrawing of this Slide, which has all the interesting data in it
abstract PPDrawing | SheetContainer.getPPDrawing() Returns the PPDrawing of this sheet, which has all the interesting data in it
PPDrawing | Notes.getPPDrawing() Returns the PPDrawing of this Notes, which has all the interesting data in it
PPDrawing | MainMaster.getPPDrawing() Returns the PPDrawing of this Slide, which has all the interesting data in it

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.PPDrawingGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.PPDrawingGroup

Packages that use PPDrawingGroup
org.apache.poi.hslf.record

Uses of PPDrawingGroup in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return PPDrawingGroup
 PPDrawingGroup Document.getPPDrawingGroup()
Returns the PPDrawingGroup, which holds an Escher Structure that contains information on pictures in the slides.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Record

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Record

Packages that use Record
org.apache.poi.hslf
org.apache.poi.hslf.dev
org.apache.poi.hslf.model
org.apache.poi.hslf.record
org.apache.poi.hslf.usermodel

Uses of Record in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return Record
 Record[] HSLFSlideShow.getRecords()
Returns an array of all the records found in the slideshow

Methods in org.apache.poi.hslf with parameters of type Record
 int HSLFSlideShow.appendRootLevelRecord(Record newRecord)
Adds a new root level record, at the end, but before the last PersistPtrIncrementalBlock.

Uses of Record in org.apache.poi.hslf.dev

Methods in org.apache.poi.hslf.dev that return Record
static Record | UserEditAndPersistListing.findRecordAtPos(int pos)
static Record | SlideIdListing.findRecordAtPos(int pos)

Methods in org.apache.poi.hslf.dev with parameters of type Record
int | SlideShowRecordDumper.getDiskLen(Record r)
java.lang.String | SlideShowRecordDumper.getPrintableRecordContents(Record r)
void | SlideShowRecordDumper.walkTree(int depth, int pos, Record[] records)

Uses of Record in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as Record
protected Record[] | SimpleShape._clientRecords Records stored in EscherClientDataRecord
protected Record[] | TextRun._records all text run records that follow TextHeaderAtom.

Methods in org.apache.poi.hslf.model that return Record
protected static Record | ShapeFactory.getClientDataRecord(EscherContainerRecord spContainer, int recordType)
protected Record | SimpleShape.getClientDataRecord(int recordType) Find a record in the underlying EscherClientDataRecord
protected Record[] | SimpleShape.getClientRecords() Search for EscherClientDataRecord, if found, convert its contents into an array of HSLF records
Record[] | TextRun.getRecords() Returns records that make up this text run

Methods in org.apache.poi.hslf.model with parameters of type Record
protected static void Sheet.findTextRuns(Record[] records, java.util.List<TextRun> found)
Scans through the supplied record array, looking for a TextHeaderAtom followed by one of a TextBytesAtom or a TextCharsAtom.

Uses of Record in org.apache.poi.hslf.record

Subclasses of Record in org.apache.poi.hslf.record
class | AnimationInfo A container record that specifies information about animation information for a shape.
class | AnimationInfoAtom An atom record that specifies the animation information for a shape.
class | ColorSchemeAtom A ColorSchemeAtom (type 2032).
class | Comment2000 This class represents a comment on a slide, in the format used by PPT 2000/XP/etc.
class | Comment2000Atom An atomic record containing information about a comment.
class | CString A CString (type 4026).
class | Document Master container for Document.
class | DocumentAtom A Document Atom (type 1001).
class | DocumentEncryptionAtom A Document Encryption Atom (type 12052).
class | DummyPositionSensitiveRecordWithChildren If we come across a record we know has children of (potential) interest, but where the record itself is boring, but where other records may care about where this one lives, we create one of these.
class | DummyRecordWithChildren If we come across a record we know has children of (potential) interest, but where the record itself is boring, we create one of these.
class | Environment Environment, which contains lots of settings for the document.
class | EscherTextboxWrapper A wrapper around a DDF (Escher) EscherTextbox Record.
class | ExAviMovie A container record that specifies information about a movie stored externally.
class | ExControl A container record that specifies information about an ActiveX control.
class | ExControlAtom An atom record that specifies an ActiveX control.
class | ExEmbed This data represents an embedded object in the document.
class | ExEmbedAtom The atom that holds metadata on a specific embedded object in the document.
class | ExHyperlink This class represents the data of a link in the document.
class | ExHyperlinkAtom Tne atom that holds metadata on a specific Link in the document.
class | ExMCIMovie A container record that specifies information about a movie stored externally.
class | ExMediaAtom An atom record that specifies information about external audio or video data.
class | ExObjList This class holds the links to exernal objects referenced from the document.
class | ExObjListAtom Tne atom that holds the seed info used by a ExObjList
class | ExOleObjAtom Atom storing information for an OLE object.
class | ExOleObjStg Storage for embedded OLE objects.
class | ExVideoContainer A container record that specifies information about external video data.
class | FontCollection FontCollection ia a container that holds information about all the fonts in the presentation.
class | FontEntityAtom This atom corresponds exactly to a Windows Logical Font (LOGFONT) structure.
class | HeadersFootersAtom An atom record that specifies options for displaying headers and footers on a presentation slide or notes slide.
class | HeadersFootersContainer A container record that specifies information about the footers on a presentation slide.
class | InteractiveInfo This class represents the metadata of a link in a slide/notes/etc.
class | InteractiveInfoAtom Tne atom that holds metadata on Links in the document.
class | MainMaster Master slide
class | Notes Master container for Notes.
class | NotesAtom A Notes Atom (type 1009).
class | OEPlaceholderAtom OEPlaceholderAtom (3011).
class | OEShapeAtom Atom that contains information that describes shape client data.
class | OutlineTextRefAtom OEPlaceholderAtom (3998).
class | PersistPtrHolder General holder for PersistPtrFullBlock and PersistPtrIncrementalBlock records.
class | PositionDependentRecordAtom A special (and dangerous) kind of Record Atom that cares about where it lives on the disk, or who has other Atoms that care about where this is on the disk.
class | PositionDependentRecordContainer A special (and dangerous) kind of Record Container, for which other Atoms care about where this one lives on disk.
class | PPDrawing These are actually wrappers onto Escher drawings.
class | PPDrawingGroup Container records which always exists inside Document.
class | RecordAtom Abstract class which all atom records will extend.
class | RecordContainer Abstract class which all container records will extend.
class | RoundTripHFPlaceholder12 An atom record that specifies that a shape is a header or footer placeholder shape
class | SheetContainer The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
class | Slide Master container for Slides.
class | SlideAtom A Slide Atom (type 1007).
class | SlideListWithText These are tricky beasts.
class | SlidePersistAtom A SlidePersist Atom (type 1011).
class | Sound A container holding information about a sound.
class | SoundCollection Is a container for all sound related atoms and containers.
class | SoundData Storage for embedded sounds.
class | StyleTextPropAtom A StyleTextPropAtom (type 4001).
class | TextBytesAtom A TextBytesAtom (type 4008).
class | TextCharsAtom A TextCharsAtom (type 4000).
class | TextHeaderAtom A TextHeaderAtom (type 3999).
class | TextRulerAtom Ruler of a text as it differs from the style's ruler settings.
class | TextSpecInfoAtom The special info runs contained in this text.
class | TxInteractiveInfoAtom Tne atom that holds starting and ending character positions of a hyperlink
class | TxMasterStyleAtom TxMasterStyleAtom atom (4003).
class | UnknownRecordPlaceholder If we come across a record we don't know about, we create one of these.
class | UserEditAtom A UserEdit Atom (type 4085).

Fields in org.apache.poi.hslf.record declared as Record
protected  Record[] RecordContainer._children

Fields in org.apache.poi.hslf.record with type parameters of type Record
java.lang.Class<? extends Record> | RecordTypes.Type.handlingClass
static java.util.HashMap<java.lang.Integer,java.lang.Class<? extends Record>> | RecordTypes.typeToClass

Methods in org.apache.poi.hslf.record that return Record
static Record | Record.buildRecordAtOffset(byte[] b, int offset) Build and return the Record at the given offset.
static Record | Record.createRecordForType(long type, byte[] b, int start, int len) For a given type (little endian bytes 3 and 4 in record header), byte array, start position and length: will return a Record object that will handle that record Remember that while PPT stores the record lengths as 8 bytes short (not including the size of the header), this code assumes you're passing in corrected lengths
static Record[] | Record.findChildRecords(byte[] b, int start, int len) Default method for finding child records of a container record
Record | RecordContainer.findFirstOfType(long type) Finds the first child record of the given type, or null if none of the child records are of the given type.
Record[] | RecordContainer.getChildRecords() Return any children
Record[] | RecordAtom.getChildRecords() We're an atom, returns null
abstract Record[] | Record.getChildRecords() Fetch all the child records of this record If this record is an atom, will return null If this record is a non-atom, but has no children, will return an empty array
Record[] | PPDrawingGroup.getChildRecords() We're pretending to be an atom, so return null
Record[] | PPDrawing.getChildRecords() We're pretending to be an atom, so return null
Record[] | SlideListWithText.SlideAtomsSet.getSlideRecords() Get the Text related records for this slide
Record | RecordContainer.removeChild(Record ch) Remove a child record from this record container

Methods in org.apache.poi.hslf.record that return types with arguments of type Record
static java.lang.Class<? extends Record> RecordTypes.recordHandlingClass(int type)
Returns the class handling a record by its type.

Methods in org.apache.poi.hslf.record with parameters of type Record
void | RecordContainer.addChildAfter(Record newChild, Record after) Adds the given Child Record after the supplied record
void | RecordContainer.addChildBefore(Record newChild, Record before) Adds the given Child Record before the supplied record
void | RecordContainer.appendChildRecord(Record newChild) Add a new child record onto a record's list of children.
void | RecordContainer.moveChildBefore(Record child, Record before) Moves the given Child Record to before the supplied record
void | RecordContainer.moveChildrenAfter(Record firstChild, int number, Record after) Moves the given Child Records to after the supplied record
void | RecordContainer.moveChildrenBefore(Record firstChild, int number, Record before) Moves the given Child Records to before the supplied record
Record | RecordContainer.removeChild(Record ch) Remove a child record from this record container
void | RecordContainer.setChildRecord(Record[] records) Set child records.
void | RecordContainer.writeOut(byte headerA, byte headerB, long type, Record[] children, java.io.OutputStream out) Write out our header, and our children.

Constructors in org.apache.poi.hslf.record with parameters of type Record
SlideListWithText.SlideAtomsSet(SlidePersistAtom s, Record[] r)
Create one to hold the Records for one Slide's text

Constructor parameters in org.apache.poi.hslf.record with type arguments of type Record
RecordTypes.Type(int typeID, java.lang.Class<? extends Record> handlingClass)

Uses of Record in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return Record
 Record[] SlideShow.getMostRecentCoreRecords()
Returns an array of the most recent version of all the interesting records

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.RecordAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.RecordAtom

Packages that use RecordAtom
org.apache.poi.hslf.record

Uses of RecordAtom in org.apache.poi.hslf.record

Subclasses of RecordAtom in org.apache.poi.hslf.record
class | AnimationInfoAtom An atom record that specifies the animation information for a shape.
class | ColorSchemeAtom A ColorSchemeAtom (type 2032).
class | Comment2000Atom An atomic record containing information about a comment.
class | CString A CString (type 4026).
class | DocumentAtom A Document Atom (type 1001).
class | DocumentEncryptionAtom A Document Encryption Atom (type 12052).
class | ExControlAtom An atom record that specifies an ActiveX control.
class | ExEmbedAtom The atom that holds metadata on a specific embedded object in the document.
class | ExHyperlinkAtom Tne atom that holds metadata on a specific Link in the document.
class | ExMediaAtom An atom record that specifies information about external audio or video data.
class | ExObjListAtom Tne atom that holds the seed info used by a ExObjList
class | ExOleObjAtom Atom storing information for an OLE object.
class | ExOleObjStg Storage for embedded OLE objects.
class | FontEntityAtom This atom corresponds exactly to a Windows Logical Font (LOGFONT) structure.
class | HeadersFootersAtom An atom record that specifies options for displaying headers and footers on a presentation slide or notes slide.
class | InteractiveInfoAtom Tne atom that holds metadata on Links in the document.
class | NotesAtom A Notes Atom (type 1009).
class | OEPlaceholderAtom OEPlaceholderAtom (3011).
class | OEShapeAtom Atom that contains information that describes shape client data.
class | OutlineTextRefAtom OEPlaceholderAtom (3998).
class | PersistPtrHolder General holder for PersistPtrFullBlock and PersistPtrIncrementalBlock records.
class | PositionDependentRecordAtom A special (and dangerous) kind of Record Atom that cares about where it lives on the disk, or who has other Atoms that care about where this is on the disk.
class | PPDrawing These are actually wrappers onto Escher drawings.
class | PPDrawingGroup Container records which always exists inside Document.
class | RoundTripHFPlaceholder12 An atom record that specifies that a shape is a header or footer placeholder shape
class | SlideAtom A Slide Atom (type 1007).
class | SlidePersistAtom A SlidePersist Atom (type 1011).
class | SoundData Storage for embedded sounds.
class | StyleTextPropAtom A StyleTextPropAtom (type 4001).
class | TextBytesAtom A TextBytesAtom (type 4008).
class | TextCharsAtom A TextCharsAtom (type 4000).
class | TextHeaderAtom A TextHeaderAtom (type 3999).
class | TextRulerAtom Ruler of a text as it differs from the style's ruler settings.
class | TextSpecInfoAtom The special info runs contained in this text.
class | TxInteractiveInfoAtom Tne atom that holds starting and ending character positions of a hyperlink
class | TxMasterStyleAtom TxMasterStyleAtom atom (4003).
class | UnknownRecordPlaceholder If we come across a record we don't know about, we create one of these.
class | UserEditAtom A UserEdit Atom (type 4085).

Fields in org.apache.poi.hslf.record declared as RecordAtom
protected  RecordAtom ExEmbed.embedAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.RecordContainer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.RecordContainer

Packages that use RecordContainer
org.apache.poi.hslf.record

Uses of RecordContainer in org.apache.poi.hslf.record

Subclasses of RecordContainer in org.apache.poi.hslf.record
class | AnimationInfo A container record that specifies information about animation information for a shape.
class | Comment2000 This class represents a comment on a slide, in the format used by PPT 2000/XP/etc.
class | Document Master container for Document.
class | DummyPositionSensitiveRecordWithChildren If we come across a record we know has children of (potential) interest, but where the record itself is boring, but where other records may care about where this one lives, we create one of these.
class | DummyRecordWithChildren If we come across a record we know has children of (potential) interest, but where the record itself is boring, we create one of these.
class | Environment Environment, which contains lots of settings for the document.
class | EscherTextboxWrapper A wrapper around a DDF (Escher) EscherTextbox Record.
class | ExAviMovie A container record that specifies information about a movie stored externally.
class | ExControl A container record that specifies information about an ActiveX control.
class | ExEmbed This data represents an embedded object in the document.
class | ExHyperlink This class represents the data of a link in the document.
class | ExMCIMovie A container record that specifies information about a movie stored externally.
class | ExObjList This class holds the links to exernal objects referenced from the document.
class | ExVideoContainer A container record that specifies information about external video data.
class | FontCollection FontCollection ia a container that holds information about all the fonts in the presentation.
class | HeadersFootersContainer A container record that specifies information about the footers on a presentation slide.
class | InteractiveInfo This class represents the metadata of a link in a slide/notes/etc.
class | MainMaster Master slide
class | Notes Master container for Notes.
class | PositionDependentRecordContainer A special (and dangerous) kind of Record Container, for which other Atoms care about where this one lives on disk.
class | SheetContainer The superclass of all sheet container records - Slide, Notes, MainMaster, etc.
class | Slide Master container for Slides.
class | SlideListWithText These are tricky beasts.
class | Sound A container holding information about a sound.
class | SoundCollection Is a container for all sound related atoms and containers.

Methods in org.apache.poi.hslf.record that return RecordContainer
RecordContainer | TextHeaderAtom.getParentRecord()
RecordContainer | ParentAwareRecord.getParentRecord()

Methods in org.apache.poi.hslf.record with parameters of type RecordContainer
static void | RecordContainer.handleParentAwareRecords(RecordContainer br) Find the records that are parent-aware, and tell them who their parent is
void | TextHeaderAtom.setParentRecord(RecordContainer record)
void | ParentAwareRecord.setParentRecord(RecordContainer parentRecord)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.RecordTypes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.RecordTypes

No usage of org.apache.poi.hslf.record.RecordTypes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.RecordTypes.Type

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.RecordTypes.Type

Packages that use RecordTypes.Type
org.apache.poi.hslf.record

Uses of RecordTypes.Type in org.apache.poi.hslf.record

Fields in org.apache.poi.hslf.record declared as RecordTypes.Type
static RecordTypes.Type | RecordTypes.AnimationInfo
static RecordTypes.Type | RecordTypes.AnimationInfoAtom
static RecordTypes.Type | RecordTypes.BaseTextPropAtom
static RecordTypes.Type | RecordTypes.BinaryTagData
static RecordTypes.Type | RecordTypes.BookmarkCollection
static RecordTypes.Type | RecordTypes.BookmarkEntityAtom
static RecordTypes.Type | RecordTypes.BookmarkSeedAtom
static RecordTypes.Type | RecordTypes.CharFormatAtom
static RecordTypes.Type | RecordTypes.ColorSchemeAtom
static RecordTypes.Type | RecordTypes.Comment2000
static RecordTypes.Type | RecordTypes.Comment2000Atom
static RecordTypes.Type | RecordTypes.Comment2000Summary
static RecordTypes.Type | RecordTypes.Comment2000SummaryAtom
static RecordTypes.Type | RecordTypes.CompositeMasterId
static RecordTypes.Type | RecordTypes.CString
static RecordTypes.Type | RecordTypes.CurrentUserAtom
static RecordTypes.Type | RecordTypes.DateTimeMCAtom
static RecordTypes.Type | RecordTypes.DefaultRulerAtom
static RecordTypes.Type | RecordTypes.DocRoutingSlip
static RecordTypes.Type | RecordTypes.Document
static RecordTypes.Type | RecordTypes.DocumentAtom
static RecordTypes.Type | RecordTypes.DocumentEncryptionAtom
static RecordTypes.Type | RecordTypes.EndDocument
static RecordTypes.Type | RecordTypes.Environment
static RecordTypes.Type | RecordTypes.ExAviMovie
static RecordTypes.Type | RecordTypes.ExCDAudio
static RecordTypes.Type | RecordTypes.ExCDAudioAtom
static RecordTypes.Type | RecordTypes.ExControl
static RecordTypes.Type | RecordTypes.ExControlAtom
static RecordTypes.Type | RecordTypes.ExEmbed
static RecordTypes.Type | RecordTypes.ExEmbedAtom
static RecordTypes.Type | RecordTypes.ExHyperlink
static RecordTypes.Type | RecordTypes.ExHyperlinkAtom
static RecordTypes.Type | RecordTypes.ExLink
static RecordTypes.Type | RecordTypes.ExLinkAtom
static RecordTypes.Type | RecordTypes.ExMCIMovie
static RecordTypes.Type | RecordTypes.ExMediaAtom
static RecordTypes.Type | RecordTypes.ExMIDIAudio
static RecordTypes.Type | RecordTypes.ExObjList
static RecordTypes.Type | RecordTypes.ExObjListAtom
static RecordTypes.Type | RecordTypes.ExObjRefAtom
static RecordTypes.Type | RecordTypes.ExOleObjAtom
static RecordTypes.Type | RecordTypes.ExOleObjStg
static RecordTypes.Type | RecordTypes.ExQuickTimeMovie
static RecordTypes.Type | RecordTypes.ExQuickTimeMovieData
static RecordTypes.Type | RecordTypes.ExVideoContainer
static RecordTypes.Type | RecordTypes.ExWAVAudioEmbedded
static RecordTypes.Type | RecordTypes.ExWAVAudioEmbeddedAtom
static RecordTypes.Type | RecordTypes.ExWAVAudioLink
static RecordTypes.Type | RecordTypes.FontCollection
static RecordTypes.Type | RecordTypes.FontEmbeddedData
static RecordTypes.Type | RecordTypes.FontEntityAtom
static RecordTypes.Type | RecordTypes.FooterMCAtom
static RecordTypes.Type | RecordTypes.GenericDateMCAtom
static RecordTypes.Type | RecordTypes.GPopublicintAtom
static RecordTypes.Type | RecordTypes.GRatioAtom
static RecordTypes.Type | RecordTypes.GRColorAtom
static RecordTypes.Type | RecordTypes.GScalingAtom
static RecordTypes.Type | RecordTypes.GuideAtom
static RecordTypes.Type | RecordTypes.HandOut
static RecordTypes.Type | RecordTypes.HeadersFooters
static RecordTypes.Type | RecordTypes.HeadersFootersAtom
static RecordTypes.Type | RecordTypes.InteractiveInfo
static RecordTypes.Type | RecordTypes.InteractiveInfoAtom
static RecordTypes.Type | RecordTypes.List
static RecordTypes.Type | RecordTypes.MainMaster
static RecordTypes.Type | RecordTypes.MetaFile
static RecordTypes.Type | RecordTypes.NamedShow
static RecordTypes.Type | RecordTypes.NamedShows
static RecordTypes.Type | RecordTypes.NamedShowSlides
static RecordTypes.Type | RecordTypes.Notes
static RecordTypes.Type | RecordTypes.NotesAtom
static RecordTypes.Type | RecordTypes.OEPlaceholderAtom
static RecordTypes.Type | RecordTypes.OEShapeAtom
static RecordTypes.Type | RecordTypes.OriginalMainMasterId
static RecordTypes.Type | RecordTypes.OutlineTextRefAtom
static RecordTypes.Type | RecordTypes.OutlineViewInfo
static RecordTypes.Type | RecordTypes.ParaFormatAtom
static RecordTypes.Type | RecordTypes.PersistPtrFullBlock
static RecordTypes.Type | RecordTypes.PersistPtrIncrementalBlock
static RecordTypes.Type | RecordTypes.PPDrawing
static RecordTypes.Type | RecordTypes.PPDrawingGroup
static RecordTypes.Type | RecordTypes.ProgBinaryTag
static RecordTypes.Type | RecordTypes.ProgStringTag
static RecordTypes.Type | RecordTypes.ProgTags
static RecordTypes.Type | RecordTypes.PrpublicintOptions
static RecordTypes.Type | RecordTypes.RecolorInfoAtom
static RecordTypes.Type | RecordTypes.RoundTripContentMasterId
static RecordTypes.Type | RecordTypes.RoundTripContentMasterInfo12
static RecordTypes.Type | RecordTypes.RoundTripCustomTableStyles12
static RecordTypes.Type | RecordTypes.RoundTripHFPlaceholder12
static RecordTypes.Type | RecordTypes.RoundTripNotesMasterTextStyles12
static RecordTypes.Type | RecordTypes.RoundTripOArtTextStyles12
static RecordTypes.Type | RecordTypes.RoundTripShapeCheckSumForCustomLayouts12
static RecordTypes.Type | RecordTypes.RoundTripShapeId12
static RecordTypes.Type | RecordTypes.RTFDateTimeMCAtom
static RecordTypes.Type | RecordTypes.SheetProperties
static RecordTypes.Type | RecordTypes.Slide
static RecordTypes.Type | RecordTypes.SlideAtom
static RecordTypes.Type | RecordTypes.SlideListWithText
static RecordTypes.Type | RecordTypes.SlideNumberMCAtom
static RecordTypes.Type | RecordTypes.SlidePersistAtom
static RecordTypes.Type | RecordTypes.SlideViewInfo
static RecordTypes.Type | RecordTypes.SlideViewInfoAtom
static RecordTypes.Type | RecordTypes.SorterViewInfo
static RecordTypes.Type | RecordTypes.Sound
static RecordTypes.Type | RecordTypes.SoundCollAtom
static RecordTypes.Type | RecordTypes.SoundCollection
static RecordTypes.Type | RecordTypes.SoundData
static RecordTypes.Type | RecordTypes.SrKinsoku
static RecordTypes.Type | RecordTypes.SrKinsokuAtom
static RecordTypes.Type | RecordTypes.SSDocInfoAtom
static RecordTypes.Type | RecordTypes.SSlideLayoutAtom
static RecordTypes.Type | RecordTypes.SSSlideInfoAtom
static RecordTypes.Type | RecordTypes.StyleTextPropAtom
static RecordTypes.Type | RecordTypes.Summary
static RecordTypes.Type | RecordTypes.TextBookmarkAtom
static RecordTypes.Type | RecordTypes.TextBytesAtom
static RecordTypes.Type | RecordTypes.TextCharsAtom
static RecordTypes.Type | RecordTypes.TextHeaderAtom
static RecordTypes.Type | RecordTypes.TextRulerAtom
static RecordTypes.Type | RecordTypes.TextSpecInfoAtom
static RecordTypes.Type | RecordTypes.TxCFStyleAtom
static RecordTypes.Type | RecordTypes.TxInteractiveInfoAtom
static RecordTypes.Type | RecordTypes.TxMasterStyleAtom
static RecordTypes.Type | RecordTypes.TxPFStyleAtom
static RecordTypes.Type | RecordTypes.TxSIStyleAtom
static RecordTypes.Type | RecordTypes.Unknown
static RecordTypes.Type | RecordTypes.UserEditAtom
static RecordTypes.Type | RecordTypes.VBAInfo
static RecordTypes.Type | RecordTypes.VBAInfoAtom
static RecordTypes.Type | RecordTypes.ViewInfo
static RecordTypes.Type | RecordTypes.ViewInfoAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.RoundTripHFPlaceholder12

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.RoundTripHFPlaceholder12

No usage of org.apache.poi.hslf.record.RoundTripHFPlaceholder12

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SheetContainer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SheetContainer

Packages that use SheetContainer
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of SheetContainer in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return SheetContainer
 SheetContainer Sheet.getSheetContainer()
Return record container for this sheet

Constructors in org.apache.poi.hslf.model with parameters of type SheetContainer
MasterSheet(SheetContainer container, int sheetNo)
Sheet(SheetContainer container, int sheetNo)

Uses of SheetContainer in org.apache.poi.hslf.record

Subclasses of SheetContainer in org.apache.poi.hslf.record
class | MainMaster Master slide
class | Notes Master container for Notes.
class | Slide Master container for Slides.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Slide

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Slide

Packages that use Slide
org.apache.poi.hslf.model

Uses of Slide in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return Slide
 Slide Slide.getSlideRecord()
Returns the underlying slide record

Constructors in org.apache.poi.hslf.model with parameters of type Slide
Slide(Slide slide, Notes notes, SlideListWithText.SlideAtomsSet atomSet, int slideIdentifier, int slideNumber)
Constructs a Slide from the Slide record, and the SlideAtomsSet containing the text.
TitleMaster(Slide record, int sheetNo)
Constructs a TitleMaster

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SlideAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SlideAtom

Packages that use SlideAtom
org.apache.poi.hslf.record

Uses of SlideAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return SlideAtom
SlideAtom | Slide.getSlideAtom() Returns the SlideAtom of this Slide
SlideAtom | MainMaster.getSlideAtom() Returns the SlideAtom of this Slide

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SlideAtom.SSlideLayoutAtom

Packages that use SlideAtom.SSlideLayoutAtom
org.apache.poi.hslf.record

Uses of SlideAtom.SSlideLayoutAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return SlideAtom.SSlideLayoutAtom
 SlideAtom.SSlideLayoutAtom SlideAtom.getSSlideLayoutAtom()
Get the embeded SSlideLayoutAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SlideListWithText

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SlideListWithText

Packages that use SlideListWithText
org.apache.poi.hslf.record

Uses of SlideListWithText in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return SlideListWithText
SlideListWithText | Document.getMasterSlideListWithText() Returns the SlideListWithText that deals with the Master Slides
SlideListWithText | Document.getNotesSlideListWithText() Returns the SlideListWithText that deals with the notes, or null if there isn't one
SlideListWithText[] | Document.getSlideListWithTexts() Returns all the SlideListWithTexts that are defined for this Document.
SlideListWithText | Document.getSlideSlideListWithText() Returns the SlideListWithText that deals with the Slides, or null if there isn't one

Methods in org.apache.poi.hslf.record with parameters of type SlideListWithText
void | Document.addSlideListWithText(SlideListWithText slwt) Adds a new SlideListWithText record, at the appropriate point in the child records.
void | Document.removeSlideListWithText(SlideListWithText slwt)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SlideListWithText.SlideAtomsSet

Packages that use SlideListWithText.SlideAtomsSet
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of SlideListWithText.SlideAtomsSet in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return SlideListWithText.SlideAtomsSet
protected  SlideListWithText.SlideAtomsSet Slide.getSlideAtomsSet()

Constructors in org.apache.poi.hslf.model with parameters of type SlideListWithText.SlideAtomsSet
Slide(Slide slide, Notes notes, SlideListWithText.SlideAtomsSet atomSet, int slideIdentifier, int slideNumber)
Constructs a Slide from the Slide record, and the SlideAtomsSet containing the text.

Uses of SlideListWithText.SlideAtomsSet in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return SlideListWithText.SlideAtomsSet
 SlideListWithText.SlideAtomsSet[] SlideListWithText.getSlideAtomsSets()
Get access to the SlideAtomsSets of the children of this record

Methods in org.apache.poi.hslf.record with parameters of type SlideListWithText.SlideAtomsSet
 void SlideListWithText.setSlideAtomsSets(SlideListWithText.SlideAtomsSet[] sas)
Get access to the SlideAtomsSets of the children of this record

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SlidePersistAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SlidePersistAtom

Packages that use SlidePersistAtom
org.apache.poi.hslf.record

Uses of SlidePersistAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return SlidePersistAtom
 SlidePersistAtom SlideListWithText.SlideAtomsSet.getSlidePersistAtom()
Get the SlidePersistAtom, which gives details on the Slide this text is associated with

Methods in org.apache.poi.hslf.record with parameters of type SlidePersistAtom
 void SlideListWithText.addSlidePersistAtom(SlidePersistAtom spa)
Add a new SlidePersistAtom, to the end of the current list, and update the internal list of SlidePersistAtoms

Constructors in org.apache.poi.hslf.record with parameters of type SlidePersistAtom
SlideListWithText.SlideAtomsSet(SlidePersistAtom s, Record[] r)
Create one to hold the Records for one Slide's text

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.Sound

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.Sound

Packages that use Sound
org.apache.poi.hslf.usermodel

Uses of Sound in org.apache.poi.hslf.usermodel

Constructors in org.apache.poi.hslf.usermodel with parameters of type Sound
SoundData(Sound container)
Creates the object data wrapping the record that contains the sound data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SoundCollection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SoundCollection

No usage of org.apache.poi.hslf.record.SoundCollection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.SoundData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.SoundData

No usage of org.apache.poi.hslf.record.SoundData

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.StyleTextPropAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.StyleTextPropAtom

Packages that use StyleTextPropAtom
org.apache.poi.hslf.dev
org.apache.poi.hslf.model

Uses of StyleTextPropAtom in org.apache.poi.hslf.dev

Methods in org.apache.poi.hslf.dev with parameters of type StyleTextPropAtom
static void TextStyleListing.showStyleTextPropAtom(StyleTextPropAtom stpa)

Uses of StyleTextPropAtom in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as StyleTextPropAtom
protected  StyleTextPropAtom TextRun._styleAtom

Constructors in org.apache.poi.hslf.model with parameters of type StyleTextPropAtom
TextRun(TextHeaderAtom tha, TextBytesAtom tba, StyleTextPropAtom sta)
Constructs a Text Run from a Ascii text block
TextRun(TextHeaderAtom tha, TextCharsAtom tca, StyleTextPropAtom sta)
Constructs a Text Run from a Unicode text block

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TextBytesAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TextBytesAtom

Packages that use TextBytesAtom
org.apache.poi.hslf.model

Uses of TextBytesAtom in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as TextBytesAtom
protected  TextBytesAtom TextRun._byteAtom

Constructors in org.apache.poi.hslf.model with parameters of type TextBytesAtom
TextRun(TextHeaderAtom tha, TextBytesAtom tba, StyleTextPropAtom sta)
Constructs a Text Run from a Ascii text block

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TextCharsAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TextCharsAtom

Packages that use TextCharsAtom
org.apache.poi.hslf.model

Uses of TextCharsAtom in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as TextCharsAtom
protected  TextCharsAtom TextRun._charAtom

Constructors in org.apache.poi.hslf.model with parameters of type TextCharsAtom
TextRun(TextHeaderAtom tha, TextCharsAtom tca, StyleTextPropAtom sta)
Constructs a Text Run from a Unicode text block

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TextHeaderAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TextHeaderAtom

Packages that use TextHeaderAtom
org.apache.poi.hslf.model

Uses of TextHeaderAtom in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as TextHeaderAtom
protected  TextHeaderAtom TextRun._headerAtom

Constructors in org.apache.poi.hslf.model with parameters of type TextHeaderAtom
TextRun(TextHeaderAtom tha, TextBytesAtom tba, StyleTextPropAtom sta)
Constructs a Text Run from a Ascii text block
TextRun(TextHeaderAtom tha, TextCharsAtom tca, StyleTextPropAtom sta)
Constructs a Text Run from a Unicode text block

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TextRulerAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TextRulerAtom

Packages that use TextRulerAtom
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of TextRulerAtom in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as TextRulerAtom
protected  TextRulerAtom TextRun._ruler

Methods in org.apache.poi.hslf.model that return TextRulerAtom
TextRulerAtom | TextRun.createTextRuler()
TextRulerAtom | TextRun.getTextRuler()

Uses of TextRulerAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return TextRulerAtom
static TextRulerAtom TextRulerAtom.getParagraphInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TextSpecInfoAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TextSpecInfoAtom

No usage of org.apache.poi.hslf.record.TextSpecInfoAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TextSpecInfoAtom.TextSpecInfoRun

Packages that use TextSpecInfoAtom.TextSpecInfoRun
org.apache.poi.hslf.record

Uses of TextSpecInfoAtom.TextSpecInfoRun in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return TextSpecInfoAtom.TextSpecInfoRun
 TextSpecInfoAtom.TextSpecInfoRun[] TextSpecInfoAtom.getTextSpecInfoRuns()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TxInteractiveInfoAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TxInteractiveInfoAtom

No usage of org.apache.poi.hslf.record.TxInteractiveInfoAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.TxMasterStyleAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.TxMasterStyleAtom

Packages that use TxMasterStyleAtom
org.apache.poi.hslf.model
org.apache.poi.hslf.record

Uses of TxMasterStyleAtom in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return TxMasterStyleAtom
 TxMasterStyleAtom[] SlideMaster.getTxMasterStyleAtoms()

Uses of TxMasterStyleAtom in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record that return TxMasterStyleAtom
TxMasterStyleAtom | Environment.getTxMasterStyleAtom()
TxMasterStyleAtom[] | MainMaster.getTxMasterStyleAtoms()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.UnknownRecordPlaceholder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.UnknownRecordPlaceholder

No usage of org.apache.poi.hslf.record.UnknownRecordPlaceholder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.record.UserEditAtom

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.record.UserEditAtom

No usage of org.apache.poi.hslf.record.UserEditAtom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ObjectData

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.usermodel
Class ObjectData

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.ObjectData

public class ObjectData
extends java.lang.Object

A class that represents object data embedded in a slide show.

Author:
Daniel Noll

Constructor Summary
ObjectData(ExOleObjStg storage)
Creates the object data wrapping the record that contains the object data.
Method Summary
java.io.InputStream | getData() Gets an input stream which returns the binary of the embedded data.
ExOleObjStg | getExOleObjStg() Return the record that contains the object data.
void | setData(byte[] data) Sets the embedded data.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectData

public ObjectData(ExOleObjStg storage)
Creates the object data wrapping the record that contains the object data.

Parameters:
storage - the record that contains the object data.
Method Detail

getData

public java.io.InputStream getData()
Gets an input stream which returns the binary of the embedded data.

Returns:
the input stream which will contain the binary of the embedded data.

setData

public void setData(byte[] data)
             throws java.io.IOException
Sets the embedded data.

Parameters:
data - the embedded data.
Throws:
java.io.IOException

getExOleObjStg

public ExOleObjStg getExOleObjStg()
Return the record that contains the object data.

Returns:
the record that contains the object data.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.usermodel
Classes
ObjectData
PictureData
RichTextRun
SlideShow
SoundData


org.apache.poi.hslf.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.usermodel

Class Summary
ObjectData | A class that represents object data embedded in a slide show.
PictureData | A class that represents image data contained in a slide show.
RichTextRun | Represents a run of text, all with the same style
SlideShow | This class is a friendly wrapper on top of the more scary HSLFSlideShow.
SoundData | A class that represents sound data embedded in a slide show.


org.apache.poi.hslf.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.usermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hslf.usermodel.ObjectData
    • org.apache.poi.hslf.usermodel.PictureData
    • org.apache.poi.hslf.usermodel.RichTextRun
    • org.apache.poi.hslf.usermodel.SlideShow
    • org.apache.poi.hslf.usermodel.SoundData


Uses of Package org.apache.poi.hslf.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.usermodel

Packages that use org.apache.poi.hslf.usermodel
org.apache.poi.hslf
org.apache.poi.hslf.blip
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Classes in org.apache.poi.hslf.usermodel used by org.apache.poi.hslf
ObjectData
A class that represents object data embedded in a slide show.
PictureData
A class that represents image data contained in a slide show.

Classes in org.apache.poi.hslf.usermodel used by org.apache.poi.hslf.blip
PictureData
A class that represents image data contained in a slide show.

Classes in org.apache.poi.hslf.usermodel used by org.apache.poi.hslf.model
ObjectData
A class that represents object data embedded in a slide show.
PictureData
A class that represents image data contained in a slide show.
RichTextRun
Represents a run of text, all with the same style
SlideShow
This class is a friendly wrapper on top of the more scary HSLFSlideShow.

Classes in org.apache.poi.hslf.usermodel used by org.apache.poi.hslf.usermodel
ObjectData
A class that represents object data embedded in a slide show.
PictureData
A class that represents image data contained in a slide show.
SlideShow
This class is a friendly wrapper on top of the more scary HSLFSlideShow.
SoundData
A class that represents sound data embedded in a slide show.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PictureData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.usermodel
Class PictureData

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.PictureData
Direct Known Subclasses:
Bitmap, Metafile
public abstract class PictureData
extends java.lang.Object

A class that represents image data contained in a slide show.

Author:
Yegor Kozlov

Field Summary
protected static int | CHECKSUM_SIZE Size of the image checksum calculated using MD5 algorithm.
protected POILogger | logger
protected int | offset The offset to the picture in the stream
protected static ImagePainter[] | painters
Constructor Summary
PictureData()
Method Summary
static PictureData create(int type)
Create an instance of PictureData by type.
 void draw(java.awt.Graphics2D graphics, Picture parent)
static byte[] getChecksum(byte[] data)
Compute 16-byte checksum of this picture using MD5 algorithm.
abstract  byte[] getData()
Returns the binary data of this Picture
 byte[] getHeader()
Return 24 byte header which preceeds the actual picture data.
static ImagePainter getImagePainter(int type)
Return ImagePainter for the specified image type
 int getOffset()
File offset in the 'Pictures' stream
 byte[] getRawData()
Returns the raw binary data of this Picture excluding the first 8 bytes which hold image signature and size of the image data.
protected abstract  int getSignature()
Blip signature.
 int getSize()
Deprecated. Use getData().length instead.
abstract  int getType()
Returns type of this picture.
 byte[] getUID()
Returns 16-byte checksum of this picture
abstract  void setData(byte[] data)
Set picture data
static void setImagePainter(int type, ImagePainter painter)
Register ImagePainter for the specified image type
 void setOffset(int offset)
Set offset of this picture in the 'Pictures' stream.
 void setRawData(byte[] data)
 void write(java.io.OutputStream out)
Write this picture into OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected POILogger logger

CHECKSUM_SIZE

protected static final int CHECKSUM_SIZE
Size of the image checksum calculated using MD5 algorithm.

See Also:
Constant Field Values

offset

protected int offset
The offset to the picture in the stream

painters

protected static ImagePainter[] painters
Constructor Detail

PictureData

public PictureData()
Method Detail

getType

public abstract int getType()
Returns type of this picture. Must be one of the static constants defined in the Picture class.

Returns:
type of this picture.

getData

public abstract byte[] getData()
Returns the binary data of this Picture

Returns:
picture data

setData

public abstract void setData(byte[] data)
                      throws java.io.IOException
Set picture data

Throws:
java.io.IOException

getSignature

protected abstract int getSignature()
Blip signature.

getRawData

public byte[] getRawData()
Returns the raw binary data of this Picture excluding the first 8 bytes which hold image signature and size of the image data.

Returns:
picture data

setRawData

public void setRawData(byte[] data)

getOffset

public int getOffset()
File offset in the 'Pictures' stream

Returns:
offset in the 'Pictures' stream

setOffset

public void setOffset(int offset)
Set offset of this picture in the 'Pictures' stream. We need to set it when a new picture is created.

Parameters:
offset - in the 'Pictures' stream

getUID

public byte[] getUID()
Returns 16-byte checksum of this picture

getChecksum

public static byte[] getChecksum(byte[] data)
Compute 16-byte checksum of this picture using MD5 algorithm.

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Write this picture into OutputStream

Throws:
java.io.IOException

create

public static PictureData create(int type)
Create an instance of PictureData by type.

Parameters:
type - type of the picture data. Must be one of the static constants defined in the Picture class.
Returns:
concrete instance of PictureData

getHeader

public byte[] getHeader()
Return 24 byte header which preceeds the actual picture data.

The header consists of 2-byte signature, 2-byte type, 4-byte image size and 16-byte checksum of the image data.

Returns:
the 24 byte header which preceeds the actual picture data.

getSize

public int getSize()
Deprecated. Use getData().length instead.

Return image size in bytes

Returns:
the size of the picture in bytes

draw

public void draw(java.awt.Graphics2D graphics,
                 Picture parent)

setImagePainter

public static void setImagePainter(int type,
                                   ImagePainter painter)
Register ImagePainter for the specified image type

Parameters:
type - image type, must be one of the static constants defined in the Picture class.
painter -

getImagePainter

public static ImagePainter getImagePainter(int type)
Return ImagePainter for the specified image type

Parameters:
type - blip type, must be one of the static constants defined in the Picture class.
Returns:
ImagePainter for the specified image type
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RichTextRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.usermodel
Class RichTextRun

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.RichTextRun

public final class RichTextRun
extends java.lang.Object

Represents a run of text, all with the same style

Field Summary
protected  POILogger logger
Constructor Summary
RichTextRun(TextRun parent, int startAt, int len)
Create a new wrapper around a (currently not) rich text string
RichTextRun(TextRun parent, int startAt, int len, TextPropCollection pStyle, TextPropCollection cStyle, boolean pShared, boolean cShared)
Create a new wrapper around a rich text string
Method Summary
TextPropCollection | _getRawCharacterStyle() Internal Use Only - get the underlying character style collection.
TextPropCollection | _getRawParagraphStyle() Internal Use Only - get the underlying paragraph style collection.
boolean | _isCharacterStyleShared() Internal Use Only - are the Character styles shared?
boolean | _isParagraphStyleShared() Internal Use Only - are the Paragraph styles shared?
int | getAlignment() Returns the type of horizontal alignment for the text.
char | getBulletChar() Returns the bullet character
java.awt.Color | getBulletColor() Returns the bullet color
int | getBulletFont() Returns the bullet font
int | getBulletOffset() Returns the bullet offset
int | getBulletSize() Returns the bullet size
int | getEndIndex() The ending index, exclusive.
java.awt.Color | getFontColor()
int | getFontIndex() Gets the font index
java.lang.String | getFontName() Gets the font name
int | getFontSize() Gets the font size
int | getIndentLevel()
int | getLength() Get the length of the text
int | getLineSpacing() Returns the line spacing
java.lang.String | getRawText() Fetch the text, in raw storage form
int | getSpaceAfter() Returns spacing after a paragraph
int | getSpaceBefore() Returns spacing before a paragraph
int | getStartIndex() The beginning index, inclusive.
int | getSuperscript() Gets the subscript/superscript option
java.lang.String | getText() Fetch the text, in output suitable form
int | getTextOffset() Returns the text offset
boolean | isBold() Is the text bold?
boolean | isBullet() Returns whether this rich text run has bullets
boolean | isBulletHard() Returns whether this rich text run has bullets
boolean | isEmbossed() Is this text embossed?
boolean | isItalic() Is the text italic?
boolean | isShadowed() Does the text have a shadow?
boolean | isStrikethrough() Gets the strikethrough flag
boolean | isUnderlined() Is the text underlined?
void | setAlignment(int align) Sets the type of horizontal alignment for the text.
void | setBold(boolean bold) Is the text bold?
void | setBullet(boolean flag) Sets whether this rich text run has bullets
void | setBulletChar(char c) Sets the bullet character
void | setBulletColor(java.awt.Color color) Sets the bullet color
void | setBulletFont(int idx) Sets the bullet font
void | setBulletOffset(int offset) Sets the bullet offset
void | setBulletSize(int size) Sets the bullet size
void | setCharTextPropVal(java.lang.String propName, int val) Sets the value of the given Paragraph TextProp, add if required
void | setEmbossed(boolean flag) Is this text embossed?
void | setFlag(boolean isCharacter, int index, boolean value)
void | setFontColor(java.awt.Color color) Sets color of the text, as a java.awt.Color
void | setFontColor(int bgr) Sets color of the text, as a int bgr.
void | setFontIndex(int idx) Sets the font index
void | setFontName(java.lang.String fontName) Sets the font name to use
void | setFontSize(int fontSize) Sets the font size
void | setIndentLevel(int level) Sets indentation level
void | setItalic(boolean italic) Is the text italic?
void | setLineSpacing(int val) Sets the line spacing.
void | setParaTextPropVal(java.lang.String propName, int val) Sets the value of the given Character TextProp, add if required
void | setRawText(java.lang.String text) Change the text
void | setShadowed(boolean flag) Does the text have a shadow?
void | setSpaceAfter(int val) Sets spacing after a paragraph.
void | setSpaceBefore(int val) Sets spacing before a paragraph.
void | setStrikethrough(boolean flag) Sets the strikethrough flag
void | setSuperscript(int val) Sets the subscript/superscript option
void | setText(java.lang.String text) Change the text
void | setTextOffset(int offset) Sets the text offset
void | setUnderlined(boolean underlined) Is the text underlined?
void | supplySlideShow(SlideShow ss) Supply the SlideShow we belong to
void | supplyTextProps(TextPropCollection pStyle, TextPropCollection cStyle, boolean pShared, boolean cShared) Supply (normally default) textprops, and if they're shared, when a run gets them
void | updateStartPosition(int startAt) Tells the RichTextRun its new position in the parent TextRun
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected POILogger logger
Constructor Detail

RichTextRun

public RichTextRun(TextRun parent,
                   int startAt,
                   int len)
Create a new wrapper around a (currently not) rich text string

Parameters:
parent -
startAt -
len -

RichTextRun

public RichTextRun(TextRun parent,
                   int startAt,
                   int len,
                   TextPropCollection pStyle,
                   TextPropCollection cStyle,
                   boolean pShared,
                   boolean cShared)
Create a new wrapper around a rich text string

Parameters:
parent - The parent TextRun
startAt - The start position of this run
len - The length of this run
pStyle - The paragraph style property collection
cStyle - The character style property collection
pShared - The paragraph styles are shared with other runs
cShared - The character styles are shared with other runs
Method Detail

supplyTextProps

public void supplyTextProps(TextPropCollection pStyle,
                            TextPropCollection cStyle,
                            boolean pShared,
                            boolean cShared)
Supply (normally default) textprops, and if they're shared, when a run gets them

supplySlideShow

public void supplySlideShow(SlideShow ss)
Supply the SlideShow we belong to

getLength

public int getLength()
Get the length of the text

getStartIndex

public int getStartIndex()
The beginning index, inclusive.

Returns:
the beginning index, inclusive.

getEndIndex

public int getEndIndex()
The ending index, exclusive.

Returns:
the ending index, exclusive.

getText

public java.lang.String getText()
Fetch the text, in output suitable form

getRawText

public java.lang.String getRawText()
Fetch the text, in raw storage form

setText

public void setText(java.lang.String text)
Change the text

setRawText

public void setRawText(java.lang.String text)
Change the text

updateStartPosition

public void updateStartPosition(int startAt)
Tells the RichTextRun its new position in the parent TextRun

Parameters:
startAt -

setFlag

public void setFlag(boolean isCharacter,
                    int index,
                    boolean value)

setParaTextPropVal

public void setParaTextPropVal(java.lang.String propName,
                               int val)
Sets the value of the given Character TextProp, add if required

Parameters:
propName - The name of the Character TextProp
val - The value to set for the TextProp

setCharTextPropVal

public void setCharTextPropVal(java.lang.String propName,
                               int val)
Sets the value of the given Paragraph TextProp, add if required

Parameters:
propName - The name of the Paragraph TextProp
val - The value to set for the TextProp

isBold

public boolean isBold()
Is the text bold?

setBold

public void setBold(boolean bold)
Is the text bold?

isItalic

public boolean isItalic()
Is the text italic?

setItalic

public void setItalic(boolean italic)
Is the text italic?

isUnderlined

public boolean isUnderlined()
Is the text underlined?

setUnderlined

public void setUnderlined(boolean underlined)
Is the text underlined?

isShadowed

public boolean isShadowed()
Does the text have a shadow?

setShadowed

public void setShadowed(boolean flag)
Does the text have a shadow?

isEmbossed

public boolean isEmbossed()
Is this text embossed?

setEmbossed

public void setEmbossed(boolean flag)
Is this text embossed?

isStrikethrough

public boolean isStrikethrough()
Gets the strikethrough flag

setStrikethrough

public void setStrikethrough(boolean flag)
Sets the strikethrough flag

getSuperscript

public int getSuperscript()
Gets the subscript/superscript option

Returns:
the percentage of the font size. If the value is positive, it is superscript, otherwise it is subscript

setSuperscript

public void setSuperscript(int val)
Sets the subscript/superscript option

Parameters:
val - the percentage of the font size. If the value is positive, it is superscript, otherwise it is subscript

getFontSize

public int getFontSize()
Gets the font size

setFontSize

public void setFontSize(int fontSize)
Sets the font size

getFontIndex

public int getFontIndex()
Gets the font index

setFontIndex

public void setFontIndex(int idx)
Sets the font index

setFontName

public void setFontName(java.lang.String fontName)
Sets the font name to use

getFontName

public java.lang.String getFontName()
Gets the font name

getFontColor

public java.awt.Color getFontColor()
Returns:
font color as RGB value
See Also:
Color

setFontColor

public void setFontColor(int bgr)
Sets color of the text, as a int bgr. (PowerPoint stores as BlueGreenRed, not the more usual RedGreenBlue)

See Also:
Color

setFontColor

public void setFontColor(java.awt.Color color)
Sets color of the text, as a java.awt.Color

setAlignment

public void setAlignment(int align)
Sets the type of horizontal alignment for the text. One of the Align* constants defined in the TextBox class.

Parameters:
align - - the type of alignment

getAlignment

public int getAlignment()
Returns the type of horizontal alignment for the text. One of the Align* constants defined in the TextBox class.

Returns:
the type of alignment

getIndentLevel

public int getIndentLevel()
Returns:
indentation level

setIndentLevel

public void setIndentLevel(int level)
Sets indentation level

Parameters:
level - indentation level. Must be in the range [0, 4]

setBullet

public void setBullet(boolean flag)
Sets whether this rich text run has bullets

isBullet

public boolean isBullet()
Returns whether this rich text run has bullets

isBulletHard

public boolean isBulletHard()
Returns whether this rich text run has bullets

setBulletChar

public void setBulletChar(char c)
Sets the bullet character

getBulletChar

public char getBulletChar()
Returns the bullet character

setBulletOffset

public void setBulletOffset(int offset)
Sets the bullet offset

getBulletOffset

public int getBulletOffset()
Returns the bullet offset

setTextOffset

public void setTextOffset(int offset)
Sets the text offset

getTextOffset

public int getTextOffset()
Returns the text offset

setBulletSize

public void setBulletSize(int size)
Sets the bullet size

getBulletSize

public int getBulletSize()
Returns the bullet size

setBulletColor

public void setBulletColor(java.awt.Color color)
Sets the bullet color

getBulletColor

public java.awt.Color getBulletColor()
Returns the bullet color

setBulletFont

public void setBulletFont(int idx)
Sets the bullet font

getBulletFont

public int getBulletFont()
Returns the bullet font

setLineSpacing

public void setLineSpacing(int val)
Sets the line spacing.

If linespacing >= 0, then linespacing is a percentage of normal line height. If linespacing < 0, the absolute value of linespacing is the spacing in master coordinates.

getLineSpacing

public int getLineSpacing()
Returns the line spacing

If linespacing >= 0, then linespacing is a percentage of normal line height. If linespacing < 0, the absolute value of linespacing is the spacing in master coordinates.

Returns:
the spacing between lines

setSpaceBefore

public void setSpaceBefore(int val)
Sets spacing before a paragraph.

If spacebefore >= 0, then spacebefore is a percentage of normal line height. If spacebefore < 0, the absolute value of spacebefore is the spacing in master coordinates.

getSpaceBefore

public int getSpaceBefore()
Returns spacing before a paragraph

If spacebefore >= 0, then spacebefore is a percentage of normal line height. If spacebefore < 0, the absolute value of spacebefore is the spacing in master coordinates.

Returns:
the spacing before a paragraph

setSpaceAfter

public void setSpaceAfter(int val)
Sets spacing after a paragraph.

If spaceafter >= 0, then spaceafter is a percentage of normal line height. If spaceafter < 0, the absolute value of spaceafter is the spacing in master coordinates.

getSpaceAfter

public int getSpaceAfter()
Returns spacing after a paragraph

If spaceafter >= 0, then spaceafter is a percentage of normal line height. If spaceafter < 0, the absolute value of spaceafter is the spacing in master coordinates.

Returns:
the spacing before a paragraph

_getRawParagraphStyle

public TextPropCollection _getRawParagraphStyle()
Internal Use Only - get the underlying paragraph style collection. For normal use, use the friendly setters and getters

_getRawCharacterStyle

public TextPropCollection _getRawCharacterStyle()
Internal Use Only - get the underlying character style collection. For normal use, use the friendly setters and getters

_isParagraphStyleShared

public boolean _isParagraphStyleShared()
Internal Use Only - are the Paragraph styles shared?

_isCharacterStyleShared

public boolean _isCharacterStyleShared()
Internal Use Only - are the Character styles shared?

Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideShow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.usermodel
Class SlideShow

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.SlideShow

public final class SlideShow
extends java.lang.Object

This class is a friendly wrapper on top of the more scary HSLFSlideShow. TODO: - figure out how to match notes to their correct sheet (will involve understanding DocSlideList and DocNotesList) - handle Slide creation cleaner

Author:
Nick Burch, Yegor kozlov

Constructor Summary
SlideShow()
Constructs a new, empty, Powerpoint document.
SlideShow(HSLFSlideShow hslfSlideShow)
Constructs a Powerpoint document from the underlying HSLFSlideShow object.
SlideShow(java.io.InputStream inputStream)
Constructs a Powerpoint document from an input stream.
Method Summary
int | addControl(java.lang.String name, java.lang.String progId) Add a control in this presentation
int | addFont(PPFont font) Add a font in this presentation
int | addHyperlink(Hyperlink link) Add a hyperlink to this presentation
int | addMovie(java.lang.String path, int type) Add a movie in this presentation
int | addPicture(byte[] data, int format) Adds a picture to this presentation and returns the associated index.
int | addPicture(java.io.File pict, int format) Adds a picture to this presentation and returns the associated index.
Slide | createSlide() Create a blank Slide.
Document | getDocumentRecord() Helper method for usermodel and model: Get the document record
ObjectData[] | getEmbeddedObjects() Returns the data of all the embedded OLE object in the SlideShow
PPFont | getFont(int idx) Get a font by index
protected FontCollection | getFontCollection() Helper method for usermodel: Get the font collection
Record[] | getMostRecentCoreRecords() Returns an array of the most recent version of all the interesting records
Notes[] | getNotes() Returns an array of all the normal Notes found in the slideshow
HeadersFooters | getNotesHeadersFooters() Return Header / Footer settings for notes
int | getNumberOfFonts() get the number of fonts in the presentation
java.awt.Dimension | getPageSize() Return the current page size
PictureData[] | getPictureData() Returns the data of all the pictures attached to the SlideShow
HeadersFooters | getSlideHeadersFooters() Return Header / Footer settings for slides
Slide[] | getSlides() Returns an array of all the normal Slides found in the slideshow
SlideMaster[] | getSlidesMasters() Returns an array of all the normal Slide Masters found in the slideshow
SoundData[] | getSoundData() Returns the data of all the embedded sounds in the SlideShow
TitleMaster[] | getTitleMasters() Returns an array of all the normal Title Masters found in the slideshow
Slide | removeSlide(int index) Removes the slide at the given index (0-based).
void | reorderSlide(int oldSlideNumber, int newSlideNumber) Re-orders a slide, to a new position.
void | setPageSize(java.awt.Dimension pgsize) Change the current page size
void | write(java.io.OutputStream out) Writes out the slideshow file the is represented by an instance of this class
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SlideShow

public SlideShow(HSLFSlideShow hslfSlideShow)
Constructs a Powerpoint document from the underlying HSLFSlideShow object. Finds the model stuff from this

Parameters:
hslfSlideShow - the HSLFSlideShow to base on

SlideShow

public SlideShow()
Constructs a new, empty, Powerpoint document.

SlideShow

public SlideShow(java.io.InputStream inputStream)
          throws java.io.IOException
Constructs a Powerpoint document from an input stream.

Throws:
java.io.IOException
Method Detail

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Writes out the slideshow file the is represented by an instance of this class

Parameters:
out - The OutputStream to write to.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in OutputStream

getMostRecentCoreRecords

public Record[] getMostRecentCoreRecords()
Returns an array of the most recent version of all the interesting records

getSlides

public Slide[] getSlides()
Returns an array of all the normal Slides found in the slideshow

getNotes

public Notes[] getNotes()
Returns an array of all the normal Notes found in the slideshow

getSlidesMasters

public SlideMaster[] getSlidesMasters()
Returns an array of all the normal Slide Masters found in the slideshow

getTitleMasters

public TitleMaster[] getTitleMasters()
Returns an array of all the normal Title Masters found in the slideshow

getPictureData

public PictureData[] getPictureData()
Returns the data of all the pictures attached to the SlideShow

getEmbeddedObjects

public ObjectData[] getEmbeddedObjects()
Returns the data of all the embedded OLE object in the SlideShow

getSoundData

public SoundData[] getSoundData()
Returns the data of all the embedded sounds in the SlideShow

getPageSize

public java.awt.Dimension getPageSize()
Return the current page size

setPageSize

public void setPageSize(java.awt.Dimension pgsize)
Change the current page size

Parameters:
pgsize - page size (in points)

getFontCollection

protected FontCollection getFontCollection()
Helper method for usermodel: Get the font collection

getDocumentRecord

public Document getDocumentRecord()
Helper method for usermodel and model: Get the document record

reorderSlide

public void reorderSlide(int oldSlideNumber,
                         int newSlideNumber)
Re-orders a slide, to a new position.

Parameters:
oldSlideNumber - The old slide number (1 based)
newSlideNumber - The new slide number (1 based)

removeSlide

public Slide removeSlide(int index)
Removes the slide at the given index (0-based).

Shifts any subsequent slides to the left (subtracts one from their slide numbers).

Parameters:
index - the index of the slide to remove (0-based)
Returns:
the slide that was removed from the slide show.

createSlide

public Slide createSlide()
Create a blank Slide.

Returns:
the created Slide

addPicture

public int addPicture(byte[] data,
                      int format)
               throws java.io.IOException
Adds a picture to this presentation and returns the associated index.

Parameters:
data - picture data
format - the format of the picture. One of constans defined in the Picture class.
Returns:
the index to this picture (1 based).
Throws:
java.io.IOException

addPicture

public int addPicture(java.io.File pict,
                      int format)
               throws java.io.IOException
Adds a picture to this presentation and returns the associated index.

Parameters:
pict - the file containing the image to add
format - the format of the picture. One of constans defined in the Picture class.
Returns:
the index to this picture (1 based).
Throws:
java.io.IOException

addFont

public int addFont(PPFont font)
Add a font in this presentation

Parameters:
font - the font to add
Returns:
0-based index of the font

getFont

public PPFont getFont(int idx)
Get a font by index

Parameters:
idx - 0-based index of the font
Returns:
of an instance of PPFont or null if not found

getNumberOfFonts

public int getNumberOfFonts()
get the number of fonts in the presentation

Returns:
number of fonts

getSlideHeadersFooters

public HeadersFooters getSlideHeadersFooters()
Return Header / Footer settings for slides

Returns:
Header / Footer settings for slides

getNotesHeadersFooters

public HeadersFooters getNotesHeadersFooters()
Return Header / Footer settings for notes

Returns:
Header / Footer settings for notes

addMovie

public int addMovie(java.lang.String path,
                    int type)
Add a movie in this presentation

Parameters:
path - the path or url to the movie
Returns:
0-based index of the movie

addControl

public int addControl(java.lang.String name,
                      java.lang.String progId)
Add a control in this presentation

Parameters:
name - name of the control, e.g. "Shockwave Flash Object"
progId - OLE Programmatic Identifier, e.g. "ShockwaveFlash.ShockwaveFlash.9"
Returns:
0-based index of the control

addHyperlink

public int addHyperlink(Hyperlink link)
Add a hyperlink to this presentation

Returns:
0-based index of the hyperlink
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SoundData

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.usermodel
Class SoundData

java.lang.Object
    extended by  org.apache.poi.hslf.usermodel.SoundData

public final class SoundData
extends java.lang.Object

A class that represents sound data embedded in a slide show.

Author:
Yegor Kozlov

Constructor Summary
SoundData(Sound container)
Creates the object data wrapping the record that contains the sound data.
Method Summary
static SoundData[] | find(Document document) Find all sound records in the supplied Document records
byte[] | getData() Gets an input stream which returns the binary of the sound data.
java.lang.String | getSoundName() Name of the sound (e.g.
java.lang.String | getSoundType() Type of the sound (e.g.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SoundData

public SoundData(Sound container)
Creates the object data wrapping the record that contains the sound data.

Parameters:
container - the record that contains the sound data.
Method Detail

getSoundName

public java.lang.String getSoundName()
Name of the sound (e.g. "crash")

Returns:
name of the sound

getSoundType

public java.lang.String getSoundType()
Type of the sound (e.g. ".wav")

Returns:
type of the sound

getData

public byte[] getData()
Gets an input stream which returns the binary of the sound data.

Returns:
the input stream which will contain the binary of the sound data.

find

public static SoundData[] find(Document document)
Find all sound records in the supplied Document records

Parameters:
document - the document to find in
Returns:
the array with the sound data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.usermodel.ObjectData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.usermodel.ObjectData

Packages that use ObjectData
org.apache.poi.hslf
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of ObjectData in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return ObjectData
 ObjectData[] HSLFSlideShow.getEmbeddedObjects()
Gets embedded object data from the slide show.

Uses of ObjectData in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return ObjectData
 ObjectData OLEShape.getObjectData()
Returns unique identifier for the OLE object.

Uses of ObjectData in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return ObjectData
 ObjectData[] SlideShow.getEmbeddedObjects()
Returns the data of all the embedded OLE object in the SlideShow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.usermodel.PictureData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.usermodel.PictureData

Packages that use PictureData
org.apache.poi.hslf
org.apache.poi.hslf.blip
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of PictureData in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return PictureData
 PictureData[] HSLFSlideShow.getPictures()
Return array of pictures contained in this presentation

Methods in org.apache.poi.hslf with parameters of type PictureData
 int HSLFSlideShow.addPicture(PictureData img)
Add a new picture to this presentation.

Uses of PictureData in org.apache.poi.hslf.blip

Subclasses of PictureData in org.apache.poi.hslf.blip
class | Bitmap Represents a bitmap picture data: JPEG or PNG.
class | DIB Represents a DIB picture data in a PPT file
class | EMF Represents EMF (Windows Enhanced Metafile) picture data.
class | JPEG Represents a JPEG picture data in a PPT file
class | Metafile Represents a metafile picture which can be one of the following types: EMF, WMF, or PICT.
class | PICT Represents Macintosh PICT picture data.
class | PNG Represents a PNG picture data in a PPT file
class | WMF Represents a WMF (Windows Metafile) picture data.

Methods in org.apache.poi.hslf.blip with parameters of type PictureData
void | ImagePainter.paint(java.awt.Graphics2D graphics, PictureData pict, Picture parent) Paints the specified picture data
void | BitmapPainter.paint(java.awt.Graphics2D graphics, PictureData pict, Picture parent)

Uses of PictureData in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return PictureData
PictureData | Picture.getPictureData() Returns the picture data for this picture.
PictureData | Fill.getPictureData() PictureData object used in a texture, pattern of picture fill.

Uses of PictureData in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return PictureData
static PictureData | PictureData.create(int type) Create an instance of PictureData by type.
PictureData[] | SlideShow.getPictureData() Returns the data of all the pictures attached to the SlideShow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.usermodel.RichTextRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.usermodel.RichTextRun

Packages that use RichTextRun
org.apache.poi.hslf.model

Uses of RichTextRun in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as RichTextRun
protected  RichTextRun[] TextRun._rtRuns

Methods in org.apache.poi.hslf.model that return RichTextRun
RichTextRun | TextRun.appendText(java.lang.String s) Adds the supplied text onto the end of the TextRun, creating a new RichTextRun (returned) for it to sit in.
RichTextRun | TextRun.getRichTextRunAt(int pos) Fetch RichTextRun at a given position
RichTextRun[] | TextRun.getRichTextRuns() Fetch the rich text runs (runs of text with the same styling) that are contained within this block of text

Methods in org.apache.poi.hslf.model with parameters of type RichTextRun
 void TextRun.changeTextInRichTextRun(RichTextRun run, java.lang.String s)
Handles an update to the text stored in one of the Rich Text Runs

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.usermodel.SlideShow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.usermodel.SlideShow

Packages that use SlideShow
org.apache.poi.hslf.model
org.apache.poi.hslf.usermodel

Uses of SlideShow in org.apache.poi.hslf.model

Methods in org.apache.poi.hslf.model that return SlideShow
 SlideShow Sheet.getSlideShow()
Fetch the SlideShow we're attached to

Methods in org.apache.poi.hslf.model with parameters of type SlideShow
void | SlideMaster.setSlideShow(SlideShow ss) Assign SlideShow for this slide master.
void | Sheet.setSlideShow(SlideShow ss) Set the SlideShow we're attached to.
void | TextRun.supplySlideShow(SlideShow ss) Supply the SlideShow we belong to.

Constructors in org.apache.poi.hslf.model with parameters of type SlideShow
HeadersFooters(HeadersFootersContainer rec, SlideShow ppt, boolean newRecord, boolean isPpt2007)

Uses of SlideShow in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel with parameters of type SlideShow
 void RichTextRun.supplySlideShow(SlideShow ss)
Supply the SlideShow we belong to

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.usermodel.SoundData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.usermodel.SoundData

Packages that use SoundData
org.apache.poi.hslf.usermodel

Uses of SoundData in org.apache.poi.hslf.usermodel

Methods in org.apache.poi.hslf.usermodel that return SoundData
static SoundData[] | SoundData.find(Document document) Find all sound records in the supplied Document records
SoundData[] | SlideShow.getSoundData() Returns the data of all the embedded sounds in the SlideShow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


MutableByteArrayOutputStream

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.util
Class MutableByteArrayOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  java.io.ByteArrayOutputStream
            extended by  org.apache.poi.hslf.util.MutableByteArrayOutputStream
All Implemented Interfaces:
java.io.Closeable, java.io.Flushable
public final class MutableByteArrayOutputStream
extends java.io.ByteArrayOutputStream

This class doesn't work yet, but is here to show the idea of a ByteArrayOutputStream where you can track how many bytes you've already written, and go back and write over a previous part of the stream

Author:
Nick Burch

Field Summary
Fields inherited from class java.io.ByteArrayOutputStream
buf, count
Constructor Summary
MutableByteArrayOutputStream()
Method Summary
int | getBytesWritten() Return how many bytes we've stuffed in so far
void | overwrite(byte[] b, int startPos) Write some bytes to an earlier bit of the array
void | write(byte[] b) Write some bytes to the array
void | write(int b)
Methods inherited from class java.io.ByteArrayOutputStream
close, reset, size, toByteArray, toString, toString, toString, write, writeTo
Methods inherited from class java.io.OutputStream
flush
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MutableByteArrayOutputStream

public MutableByteArrayOutputStream()
Method Detail

getBytesWritten

public int getBytesWritten()
Return how many bytes we've stuffed in so far

write

public void write(byte[] b)
Write some bytes to the array

Overrides:
write in class java.io.OutputStream

write

public void write(int b)
Overrides:
write in class java.io.ByteArrayOutputStream

overwrite

public void overwrite(byte[] b,
                      int startPos)
Write some bytes to an earlier bit of the array

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hslf.util
Classes
MutableByteArrayOutputStream
SystemTimeUtils


org.apache.poi.hslf.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hslf.util

Class Summary
MutableByteArrayOutputStream | This class doesn't work yet, but is here to show the idea of a ByteArrayOutputStream where you can track how many bytes you've already written, and go back and write over a previous part of the stream
SystemTimeUtils | A helper class for dealing with SystemTime Structs, as defined at http://msdn.microsoft.com/library/en-us/sysinfo/base/systemtime_str.asp .


org.apache.poi.hslf.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hslf.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
        • org.apache.poi.hslf.util.MutableByteArrayOutputStream
    • org.apache.poi.hslf.util.SystemTimeUtils


Uses of Package org.apache.poi.hslf.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hslf.util

No usage of org.apache.poi.hslf.util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SystemTimeUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hslf.util
Class SystemTimeUtils

java.lang.Object
    extended by  org.apache.poi.hslf.util.SystemTimeUtils

public final class SystemTimeUtils
extends java.lang.Object

A helper class for dealing with SystemTime Structs, as defined at http://msdn.microsoft.com/library/en-us/sysinfo/base/systemtime_str.asp . Discrepancies between Calendar and SYSTEMTIME: - that January = 1 in SYSTEMTIME, 0 in Calendar. - that the day of the week (0) starts on Sunday in SYSTEMTIME, and Monday in Calendar It is also the case that this does not store the timezone, and no... it is not stored as UTC either, but rather the local system time (yuck.)

Author:
Daniel Noll, Nick Burch

Constructor Summary
SystemTimeUtils()
Method Summary
static java.util.Date | getDate(byte[] data) Get the date found in the byte array, as a java Data object
static java.util.Date | getDate(byte[] data, int offset) Get the date found in the byte array, as a java Data object
static void | storeDate(java.util.Date date, byte[] dest) Convert the supplied java Date into a SystemTime struct, and write it into the supplied byte array.
static void | storeDate(java.util.Date date, byte[] dest, int offset) Convert the supplied java Date into a SystemTime struct, and write it into the supplied byte array.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SystemTimeUtils

public SystemTimeUtils()
Method Detail

getDate

public static java.util.Date getDate(byte[] data)
Get the date found in the byte array, as a java Data object

getDate

public static java.util.Date getDate(byte[] data,
                                     int offset)
Get the date found in the byte array, as a java Data object

storeDate

public static void storeDate(java.util.Date date,
                             byte[] dest)
Convert the supplied java Date into a SystemTime struct, and write it into the supplied byte array.

storeDate

public static void storeDate(java.util.Date date,
                             byte[] dest,
                             int offset)
Convert the supplied java Date into a SystemTime struct, and write it into the supplied byte array.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hslf.util.MutableByteArrayOutputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.util.MutableByteArrayOutputStream

No usage of org.apache.poi.hslf.util.MutableByteArrayOutputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hslf.util.SystemTimeUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hslf.util.SystemTimeUtils

No usage of org.apache.poi.hslf.util.SystemTimeUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


MAPIMessage

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf
Class MAPIMessage

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hsmf.MAPIMessage

public class MAPIMessage
extends POIDocument

Reads an Outlook MSG File in and provides hooks into its data structure. If you want to develop with HSMF, you might find it worth getting some of the microsoft public documentation, such as: [MS-OXCMSG]: Message and Attachment Object Protocol Specification

Field Summary
Fields inherited from class org.apache.poi.POIDocument
directory
Constructor Summary
MAPIMessage()
Constructor for creating new files.
MAPIMessage(DirectoryNode poifsDir)
Constructor for reading MSG Files from a certain point within a POIFS filesystem
MAPIMessage(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use MAPIMessage(DirectoryNode) instead
MAPIMessage(java.io.InputStream in)
Constructor for reading MSG Files from an input stream.
MAPIMessage(NPOIFSFileSystem fs)
Constructor for reading MSG Files from a POIFS filesystem
MAPIMessage(POIFSFileSystem fs)
Constructor for reading MSG Files from a POIFS filesystem
MAPIMessage(java.lang.String filename)
Constructor for reading MSG Files from the file system.
Method Summary
AttachmentChunks[] | getAttachmentFiles() Gets the message attachments.
java.lang.String | getConversationTopic() Gets the conversation topic of the parsed Outlook Message.
java.lang.String | getDisplayBCC() Gets the display value of the "BCC" line of the outlook message.
java.lang.String | getDisplayCC() Gets the display value of the "CC" line of the outlook message.
java.lang.String | getDisplayFrom() Gets the display value of the "FROM" line of the outlook message This is not the actual address that was sent from but the formated display of the user name.
java.lang.String | getDisplayTo() Gets the display value of the "TO" line of the outlook message.
java.lang.String[] | getHeaders() Returns all the headers, one entry per line
java.lang.String | getHmtlBody() Deprecated.
java.lang.String | getHtmlBody() Gets the html body of this Outlook Message, if this email contains a html version.
Chunks | getMainChunks() Gets the main, core details chunks
java.lang.String | getMessageClass() Gets the message class of the parsed Outlook Message.
java.util.Calendar | getMessageDate() Gets the date that the message was accepted by the server on.
NameIdChunks | getNameIdChunks() Gets the Name ID chunks, or null if there aren't any
RecipientChunks[] | getRecipientDetailsChunks() Gets all the recipient details chunks.
java.lang.String | getRecipientEmailAddress() Returns all the recipients' email address, separated by semicolons.
java.lang.String[] | getRecipientEmailAddressList() Returns an array of all the recipient's email address, normally in TO then CC then BCC order.
java.lang.String | getRecipientNames() Returns all the recipients' names, separated by semicolons.
java.lang.String[] | getRecipientNamesList() Returns an array of all the recipient's names, normally in TO then CC then BCC order.
java.lang.String | getRtfBody() Gets the RTF Rich Message body of this Outlook Message, if this email contains a RTF (rich) version.
java.lang.String | getStringFromChunk(StringChunk chunk) Gets a string value based on the passed chunk.
java.lang.String | getSubject() Gets the subject line of the Outlook Message
java.lang.String | getTextBody() Gets the plain text body of this Outlook Message
void | guess7BitEncoding() Many messages store their strings as unicode, which is nice and easy.
boolean | has7BitEncodingStrings() Does this file contain any strings that are stored as 7 bit rather than unicode?
boolean | isReturnNullOnMissingChunk() Will you get a null on a missing chunk, or a ChunkNotFoundException (default is the exception).
void | set7BitEncoding(java.lang.String charset) Many messages store their strings as unicode, which is nice and easy.
void | setReturnNullOnMissingChunk(boolean returnNullOnMissingChunk) Sets whether on asking for a missing chunk, you get back null or a ChunkNotFoundException (default is the exception).
void | write(java.io.OutputStream out) Note - not yet supported, sorry.
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MAPIMessage

public MAPIMessage()
Constructor for creating new files.

MAPIMessage

public MAPIMessage(java.lang.String filename)
            throws java.io.IOException
Constructor for reading MSG Files from the file system.

Parameters:
filename -
Throws:
java.io.IOException

MAPIMessage

public MAPIMessage(java.io.InputStream in)
            throws java.io.IOException
Constructor for reading MSG Files from an input stream.

Parameters:
in -
Throws:
java.io.IOException

MAPIMessage

public MAPIMessage(POIFSFileSystem fs)
            throws java.io.IOException
Constructor for reading MSG Files from a POIFS filesystem

Parameters:
fs -
Throws:
java.io.IOException

MAPIMessage

public MAPIMessage(NPOIFSFileSystem fs)
            throws java.io.IOException
Constructor for reading MSG Files from a POIFS filesystem

Parameters:
fs -
Throws:
java.io.IOException

MAPIMessage

@Deprecated
public MAPIMessage(DirectoryNode poifsDir,
                              POIFSFileSystem fs)
            throws java.io.IOException
Deprecated. Use MAPIMessage(DirectoryNode) instead

Throws:
java.io.IOException

MAPIMessage

public MAPIMessage(DirectoryNode poifsDir)
            throws java.io.IOException
Constructor for reading MSG Files from a certain point within a POIFS filesystem

Parameters:
poifsDir -
Throws:
java.io.IOException
Method Detail

getStringFromChunk

public java.lang.String getStringFromChunk(StringChunk chunk)
                                    throws ChunkNotFoundException
Gets a string value based on the passed chunk.

Throws:
ChunkNotFoundException - if the chunk isn't there

getTextBody

public java.lang.String getTextBody()
                             throws ChunkNotFoundException
Gets the plain text body of this Outlook Message

Returns:
The string representation of the 'text' version of the body, if available.
Throws:
ChunkNotFoundException

getHtmlBody

public java.lang.String getHtmlBody()
                             throws ChunkNotFoundException
Gets the html body of this Outlook Message, if this email contains a html version.

Returns:
The string representation of the 'html' version of the body, if available.
Throws:
ChunkNotFoundException

getHmtlBody

@Deprecated
public java.lang.String getHmtlBody()
                             throws ChunkNotFoundException
Deprecated.

Throws:
ChunkNotFoundException

getRtfBody

public java.lang.String getRtfBody()
                            throws ChunkNotFoundException
Gets the RTF Rich Message body of this Outlook Message, if this email contains a RTF (rich) version.

Returns:
The string representation of the 'RTF' version of the body, if available.
Throws:
ChunkNotFoundException

getSubject

public java.lang.String getSubject()
                            throws ChunkNotFoundException
Gets the subject line of the Outlook Message

Throws:
ChunkNotFoundException

getDisplayFrom

public java.lang.String getDisplayFrom()
                                throws ChunkNotFoundException
Gets the display value of the "FROM" line of the outlook message This is not the actual address that was sent from but the formated display of the user name.

Throws:
ChunkNotFoundException

getDisplayTo

public java.lang.String getDisplayTo()
                              throws ChunkNotFoundException
Gets the display value of the "TO" line of the outlook message. If there are multiple recipients, they will be separated by semicolons. This is not the actual list of addresses/values that will be sent to if you click Reply in the email - those are stored in RecipientChunks.

Throws:
ChunkNotFoundException

getDisplayCC

public java.lang.String getDisplayCC()
                              throws ChunkNotFoundException
Gets the display value of the "CC" line of the outlook message. If there are multiple recipients, they will be separated by semicolons. This is not the actual list of addresses/values that will be sent to if you click Reply in the email - those are stored in RecipientChunks.

Throws:
ChunkNotFoundException

getDisplayBCC

public java.lang.String getDisplayBCC()
                               throws ChunkNotFoundException
Gets the display value of the "BCC" line of the outlook message. If there are multiple recipients, they will be separated by semicolons. This is not the actual list of addresses/values that will be sent to if you click Reply in the email - those are stored in RecipientChunks. This will only be present in sent emails, not received ones!

Throws:
ChunkNotFoundException

getRecipientEmailAddress

public java.lang.String getRecipientEmailAddress()
                                          throws ChunkNotFoundException
Returns all the recipients' email address, separated by semicolons. Checks all the likely chunks in search of the addresses.

Throws:
ChunkNotFoundException

getRecipientEmailAddressList

public java.lang.String[] getRecipientEmailAddressList()
                                                throws ChunkNotFoundException
Returns an array of all the recipient's email address, normally in TO then CC then BCC order. Checks all the likely chunks in search of the addresses.

Throws:
ChunkNotFoundException

getRecipientNames

public java.lang.String getRecipientNames()
                                   throws ChunkNotFoundException
Returns all the recipients' names, separated by semicolons. Checks all the likely chunks in search of the names. See also getDisplayTo(), getDisplayCC() and getDisplayBCC().

Throws:
ChunkNotFoundException

getRecipientNamesList

public java.lang.String[] getRecipientNamesList()
                                         throws ChunkNotFoundException
Returns an array of all the recipient's names, normally in TO then CC then BCC order. Checks all the likely chunks in search of the names. See also getDisplayTo(), getDisplayCC() and getDisplayBCC().

Throws:
ChunkNotFoundException

guess7BitEncoding

public void guess7BitEncoding()
Many messages store their strings as unicode, which is nice and easy. Some use one-byte encodings for their strings, but don't easily store the encoding anywhere in the file! This method looks at the headers for the message, and tries to use these to guess the correct encoding for your file. Bug #49441 has more on why this is needed

set7BitEncoding

public void set7BitEncoding(java.lang.String charset)
Many messages store their strings as unicode, which is nice and easy. Some use one-byte encodings for their strings, but don't easily store the encoding anywhere in the file! If you know what the encoding is of your file, you can use this method to set the 7 bit encoding for all the non unicode strings in the file.

See Also:
guess7BitEncoding()

has7BitEncodingStrings

public boolean has7BitEncodingStrings()
Does this file contain any strings that are stored as 7 bit rather than unicode?

getHeaders

public java.lang.String[] getHeaders()
                              throws ChunkNotFoundException
Returns all the headers, one entry per line

Throws:
ChunkNotFoundException

getConversationTopic

public java.lang.String getConversationTopic()
                                      throws ChunkNotFoundException
Gets the conversation topic of the parsed Outlook Message. This is the part of the subject line that is after the RE: and FWD:

Throws:
ChunkNotFoundException

getMessageClass

public java.lang.String getMessageClass()
                                 throws ChunkNotFoundException
Gets the message class of the parsed Outlook Message. (Yes, you can use this to determine if a message is a calendar item, note, or actual outlook Message) For emails the class will be IPM.Note

Throws:
ChunkNotFoundException

getMessageDate

public java.util.Calendar getMessageDate()
                                  throws ChunkNotFoundException
Gets the date that the message was accepted by the server on.

Throws:
ChunkNotFoundException

getMainChunks

public Chunks getMainChunks()
Gets the main, core details chunks

getRecipientDetailsChunks

public RecipientChunks[] getRecipientDetailsChunks()
Gets all the recipient details chunks. These will normally be in the order of: * TO recipients, in the order returned by getDisplayTo() * CC recipients, in the order returned by getDisplayCC() * BCC recipients, in the order returned by getDisplayBCC()

getNameIdChunks

public NameIdChunks getNameIdChunks()
Gets the Name ID chunks, or null if there aren't any

getAttachmentFiles

public AttachmentChunks[] getAttachmentFiles()
Gets the message attachments.

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Note - not yet supported, sorry.

Specified by:
write in class POIDocument
Throws:
java.io.IOException

isReturnNullOnMissingChunk

public boolean isReturnNullOnMissingChunk()
Will you get a null on a missing chunk, or a ChunkNotFoundException (default is the exception).

setReturnNullOnMissingChunk

public void setReturnNullOnMissingChunk(boolean returnNullOnMissingChunk)
Sets whether on asking for a missing chunk, you get back null or a ChunkNotFoundException (default is the exception).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hsmf
Classes
MAPIMessage


org.apache.poi.hsmf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hsmf

Class Summary
MAPIMessage Reads an Outlook MSG File in and provides hooks into its data structure.


org.apache.poi.hsmf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hsmf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POIDocument
      • org.apache.poi.hsmf.MAPIMessage


Uses of Package org.apache.poi.hsmf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hsmf

Packages that use org.apache.poi.hsmf
org.apache.poi.hsmf.datatypes
org.apache.poi.hsmf.extractor

Classes in org.apache.poi.hsmf used by org.apache.poi.hsmf.datatypes
MAPIMessage
Reads an Outlook MSG File in and provides hooks into its data structure.

Classes in org.apache.poi.hsmf used by org.apache.poi.hsmf.extractor
MAPIMessage
Reads an Outlook MSG File in and provides hooks into its data structure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.MAPIMessage

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.MAPIMessage

Packages that use MAPIMessage
org.apache.poi.hsmf.datatypes
org.apache.poi.hsmf.extractor

Uses of MAPIMessage in org.apache.poi.hsmf.datatypes

Methods in org.apache.poi.hsmf.datatypes that return MAPIMessage
 MAPIMessage DirectoryChunk.getAsEmbededMessage()
Treats the directory as an embeded MAPIMessage (it normally is one), and returns a MAPIMessage object to process it with.

Uses of MAPIMessage in org.apache.poi.hsmf.extractor

Methods in org.apache.poi.hsmf.extractor that return MAPIMessage
 MAPIMessage OutlookTextExtactor.getMAPIMessage()
Returns the underlying MAPI message

Constructors in org.apache.poi.hsmf.extractor with parameters of type MAPIMessage
OutlookTextExtactor(MAPIMessage msg)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AttachmentChunks.AttachmentChunksSorter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class AttachmentChunks.AttachmentChunksSorter

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter
All Implemented Interfaces:
java.util.Comparator<AttachmentChunks>
Enclosing class:
AttachmentChunks
public static class AttachmentChunks.AttachmentChunksSorter
extends java.lang.Object
implements java.util.Comparator<AttachmentChunks>

Orders by the attachment number.

Constructor Summary
AttachmentChunks.AttachmentChunksSorter()
Method Summary
 int compare(AttachmentChunks a, AttachmentChunks b)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

AttachmentChunks.AttachmentChunksSorter

public AttachmentChunks.AttachmentChunksSorter()
Method Detail

compare

public int compare(AttachmentChunks a,
                   AttachmentChunks b)
Specified by:
compare in interface java.util.Comparator<AttachmentChunks>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AttachmentChunks

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class AttachmentChunks

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.AttachmentChunks
All Implemented Interfaces:
ChunkGroup
public class AttachmentChunks
extends java.lang.Object
implements ChunkGroup

Collection of convenence chunks for standard parts of the MSG file attachment.

Nested Class Summary
static class AttachmentChunks.AttachmentChunksSorter
Orders by the attachment number.
Field Summary
ByteChunk | attachData
StringChunk | attachExtension
StringChunk | attachFileName
StringChunk | attachLongFileName
DirectoryChunk | attachmentDirectory
StringChunk | attachMimeTag
ByteChunk | attachRenderingWMF This is in WMF Format.
static java.lang.String | PREFIX
Constructor Summary
AttachmentChunks(java.lang.String poifsName)
Method Summary
Chunk[] | getAll()
Chunk[] | getChunks() Returns the chunks that make up the group.
java.lang.String | getPOIFSName()
void | record(Chunk chunk) Called by the parser whenever a chunk is found.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PREFIX

public static final java.lang.String PREFIX
See Also:
Constant Field Values

attachData

public ByteChunk attachData

attachExtension

public StringChunk attachExtension

attachFileName

public StringChunk attachFileName

attachLongFileName

public StringChunk attachLongFileName

attachMimeTag

public StringChunk attachMimeTag

attachmentDirectory

public DirectoryChunk attachmentDirectory

attachRenderingWMF

public ByteChunk attachRenderingWMF
This is in WMF Format. You'll probably want to pass it to Apache Batik to turn it into a SVG that you can then display.

Constructor Detail

AttachmentChunks

public AttachmentChunks(java.lang.String poifsName)
Method Detail

getAll

public Chunk[] getAll()

getChunks

public Chunk[] getChunks()
Description copied from interface: ChunkGroup
Returns the chunks that make up the group. Should certainly contain all the interesting Chunks, but needn't always contain all of the Chunks.

Specified by:
getChunks in interface ChunkGroup

getPOIFSName

public java.lang.String getPOIFSName()

record

public void record(Chunk chunk)
Called by the parser whenever a chunk is found.

Specified by:
record in interface ChunkGroup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ByteChunk

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class ByteChunk

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.Chunk
        extended by  org.apache.poi.hsmf.datatypes.ByteChunk

public class ByteChunk
extends Chunk

A Chunk that holds binary data, normally unparsed. Generally as we know how to make sense of the contents, we create a new Chunk class and add a special case in the parser for them.

Field Summary
Fields inherited from class org.apache.poi.hsmf.datatypes.Chunk
chunkId, DEFAULT_NAME_PREFIX, namePrefix, type
Constructor Summary
ByteChunk(int chunkId, int type)
Create a Byte Chunk, with the specified type.
ByteChunk(java.lang.String namePrefix, int chunkId, int type)
Creates a Byte Chunk.
Method Summary
java.lang.String | getAs7bitString() Returns the data, formatted as a string assuming it was a non-unicode string.
byte[] | getValue()
void | readValue(java.io.InputStream value) Reads the value of this chunk using an InputStream
void | setValue(byte[] value)
void | writeValue(java.io.OutputStream out) Writes the value of this chunk back out again.
Methods inherited from class org.apache.poi.hsmf.datatypes.Chunk
getChunkId, getEntryName, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ByteChunk

public ByteChunk(java.lang.String namePrefix,
                 int chunkId,
                 int type)
Creates a Byte Chunk.

ByteChunk

public ByteChunk(int chunkId,
                 int type)
Create a Byte Chunk, with the specified type.

Method Detail

readValue

public void readValue(java.io.InputStream value)
               throws java.io.IOException
Description copied from class: Chunk
Reads the value of this chunk using an InputStream

Specified by:
readValue in class Chunk
Throws:
java.io.IOException

writeValue

public void writeValue(java.io.OutputStream out)
                throws java.io.IOException
Description copied from class: Chunk
Writes the value of this chunk back out again.

Specified by:
writeValue in class Chunk
Throws:
java.io.IOException

getValue

public byte[] getValue()

setValue

public void setValue(byte[] value)

getAs7bitString

public java.lang.String getAs7bitString()
Returns the data, formatted as a string assuming it was a non-unicode string. If your data isn't in fact stored as basically ASCII, don't expect this to return much of any sense....

Returns:
the data formatted as a string
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Chunk

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class Chunk

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.Chunk
Direct Known Subclasses:
ByteChunk, DirectoryChunk, MessageSubmissionChunk, StringChunk
public abstract class Chunk
extends java.lang.Object

Field Summary
protected int | chunkId
static java.lang.String | DEFAULT_NAME_PREFIX
protected java.lang.String | namePrefix
protected int | type
Constructor Summary
protected | Chunk(int chunkId, int type)
protected | Chunk(java.lang.String namePrefix, int chunkId, int type)
Method Summary
int | getChunkId() Gets the id of this chunk
java.lang.String | getEntryName() Creates a string to use to identify this chunk in the POI file system object.
int | getType() Gets the numeric type of this chunk.
abstract void | readValue(java.io.InputStream value) Reads the value of this chunk using an InputStream
abstract void | writeValue(java.io.OutputStream out) Writes the value of this chunk back out again.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_NAME_PREFIX

public static final java.lang.String DEFAULT_NAME_PREFIX
See Also:
Constant Field Values

chunkId

protected int chunkId

type

protected int type

namePrefix

protected java.lang.String namePrefix
Constructor Detail

Chunk

protected Chunk(java.lang.String namePrefix,
                int chunkId,
                int type)

Chunk

protected Chunk(int chunkId,
                int type)
Method Detail

getChunkId

public int getChunkId()
Gets the id of this chunk

getType

public int getType()
Gets the numeric type of this chunk.

getEntryName

public java.lang.String getEntryName()
Creates a string to use to identify this chunk in the POI file system object.

writeValue

public abstract void writeValue(java.io.OutputStream out)
                         throws java.io.IOException
Writes the value of this chunk back out again.

Throws:
java.io.IOException

readValue

public abstract void readValue(java.io.InputStream value)
                        throws java.io.IOException
Reads the value of this chunk using an InputStream

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChunkGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Interface ChunkGroup

All Known Implementing Classes:
AttachmentChunks, Chunks, NameIdChunks, RecipientChunks
public interface ChunkGroup

A group of chunks, that are at the same point in the file structure.

Method Summary
Chunk[] | getChunks() Returns the chunks that make up the group.
void | record(Chunk chunk) Called by the parser whenever a chunk is found.

Method Detail

getChunks

Chunk[] getChunks()
Returns the chunks that make up the group. Should certainly contain all the interesting Chunks, but needn't always contain all of the Chunks.

record

void record(Chunk chunk)
Called by the parser whenever a chunk is found.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Chunks

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class Chunks

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.Chunks
All Implemented Interfaces:
ChunkGroup
public final class Chunks
extends java.lang.Object
implements ChunkGroup

Collection of convenience chunks for standard parts of the MSG file. Not all of these will be present in any given file. A partial list is available at: http://msdn.microsoft.com/en-us/library/ms526356%28v=exchg.10%29.aspx

Field Summary
StringChunk | conversationTopic Sort of like the subject line, but without the RE: and FWD: parts.
StringChunk | displayBCCChunk Value that shows in the BCC field
StringChunk | displayCCChunk value that shows in the CC field
StringChunk | displayFromChunk Value that is in the FROM field
StringChunk | displayToChunk Value that is in the TO field (not actually the addresses as they are stored in recip directory nodes
StringChunk | emailFromChunk TODO
ByteChunk | htmlBodyChunkBinary
StringChunk | htmlBodyChunkString BODY Html Chunk, for html messages
StringChunk | messageClass Type of message that the MSG represents (ie.
StringChunk | messageHeaders The email headers
StringChunk | messageId The message ID
ByteChunk | rtfBodyChunk BODY Rtf Chunk, for Rtf (Rich) messages
StringChunk | sentByServerType Type of server that the message originated from (SMTP, etc).
StringChunk | subjectChunk Subject link chunk, in plain/text
MessageSubmissionChunk | submissionChunk TODO
StringChunk | textBodyChunk BODY Chunk, for plain/text messages
Constructor Summary
Chunks()
Method Summary
Chunk[] | getAll()
Chunk[] | getChunks() Returns the chunks that make up the group.
void | record(Chunk chunk) Called by the parser whenever a chunk is found.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

messageClass

public StringChunk messageClass
Type of message that the MSG represents (ie. IPM.Note)

textBodyChunk

public StringChunk textBodyChunk
BODY Chunk, for plain/text messages

htmlBodyChunkString

public StringChunk htmlBodyChunkString
BODY Html Chunk, for html messages

htmlBodyChunkBinary

public ByteChunk htmlBodyChunkBinary

rtfBodyChunk

public ByteChunk rtfBodyChunk
BODY Rtf Chunk, for Rtf (Rich) messages

subjectChunk

public StringChunk subjectChunk
Subject link chunk, in plain/text

displayToChunk

public StringChunk displayToChunk
Value that is in the TO field (not actually the addresses as they are stored in recip directory nodes

displayFromChunk

public StringChunk displayFromChunk
Value that is in the FROM field

displayCCChunk

public StringChunk displayCCChunk
value that shows in the CC field

displayBCCChunk

public StringChunk displayBCCChunk
Value that shows in the BCC field

conversationTopic

public StringChunk conversationTopic
Sort of like the subject line, but without the RE: and FWD: parts.

sentByServerType

public StringChunk sentByServerType
Type of server that the message originated from (SMTP, etc).

messageHeaders

public StringChunk messageHeaders
The email headers

submissionChunk

public MessageSubmissionChunk submissionChunk
TODO

emailFromChunk

public StringChunk emailFromChunk
TODO

messageId

public StringChunk messageId
The message ID

Constructor Detail

Chunks

public Chunks()
Method Detail

getAll

public Chunk[] getAll()

getChunks

public Chunk[] getChunks()
Description copied from interface: ChunkGroup
Returns the chunks that make up the group. Should certainly contain all the interesting Chunks, but needn't always contain all of the Chunks.

Specified by:
getChunks in interface ChunkGroup

record

public void record(Chunk chunk)
Called by the parser whenever a chunk is found.

Specified by:
record in interface ChunkGroup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirectoryChunk

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class DirectoryChunk

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.Chunk
        extended by  org.apache.poi.hsmf.datatypes.DirectoryChunk

public class DirectoryChunk
extends Chunk

A Chunk that is just a placeholder in the MAPIMessage directory structure, which contains children. This is most commonly used with nested MAPIMessages

Field Summary
Fields inherited from class org.apache.poi.hsmf.datatypes.Chunk
chunkId, DEFAULT_NAME_PREFIX, namePrefix, type
Constructor Summary
DirectoryChunk(DirectoryNode dir, java.lang.String namePrefix, int chunkId, int type)
Method Summary
MAPIMessage | getAsEmbededMessage() Treats the directory as an embeded MAPIMessage (it normally is one), and returns a MAPIMessage object to process it with.
DirectoryNode | getDirectory() Returns the directory entry for this chunk.
void | readValue(java.io.InputStream value) Reads the value of this chunk using an InputStream
void | writeValue(java.io.OutputStream out) Writes the value of this chunk back out again.
Methods inherited from class org.apache.poi.hsmf.datatypes.Chunk
getChunkId, getEntryName, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DirectoryChunk

public DirectoryChunk(DirectoryNode dir,
                      java.lang.String namePrefix,
                      int chunkId,
                      int type)
Method Detail

getDirectory

public DirectoryNode getDirectory()
Returns the directory entry for this chunk. You can then use standard POIFS methods to enumerate the entries in it.

getAsEmbededMessage

public MAPIMessage getAsEmbededMessage()
                                throws java.io.IOException
Treats the directory as an embeded MAPIMessage (it normally is one), and returns a MAPIMessage object to process it with.

Throws:
java.io.IOException

readValue

public void readValue(java.io.InputStream value)
Description copied from class: Chunk
Reads the value of this chunk using an InputStream

Specified by:
readValue in class Chunk

writeValue

public void writeValue(java.io.OutputStream out)
Description copied from class: Chunk
Writes the value of this chunk back out again.

Specified by:
writeValue in class Chunk
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MAPIProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class MAPIProperty

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.MAPIProperty

public class MAPIProperty
extends java.lang.Object

Holds the list of MAPI Attributes, and allows lookup by friendly name, ID and MAPI Property Name. These are taken from the following MSDN resources: http://msdn.microsoft.com/en-us/library/microsoft.exchange.data.contenttypes.tnef.tnefpropertyid%28v=EXCHG.140%29.aspx http://msdn.microsoft.com/en-us/library/ms526356%28v=exchg.10%29.aspx

Field Summary
static MAPIProperty | AB_DEFAULT_DIR
static MAPIProperty | AB_DEFAULT_PAB
static MAPIProperty | AB_PROVIDER_ID
static MAPIProperty | AB_PROVIDERS
static MAPIProperty | AB_SEARCH_PATH
static MAPIProperty | AB_SEARCH_PATH_UPDATE
static MAPIProperty | ACCESS
static MAPIProperty | ACCESS_LEVEL
static MAPIProperty | ACCOUNT
static MAPIProperty | ADDRTYPE
static MAPIProperty | ALTERNATE_RECIPIENT
static MAPIProperty | ALTERNATE_RECIPIENT_ALLOWED
static MAPIProperty | ANR
static MAPIProperty | ASSISTANT
static MAPIProperty | ASSISTANT_TELEPHONE_NUMBER
static MAPIProperty | ASSOC_CONTENT_COUNT
static MAPIProperty | ATTACH_ADDITIONAL_INFO
static MAPIProperty | ATTACH_CONTENT_BASE
static MAPIProperty | ATTACH_CONTENT_ID
static MAPIProperty | ATTACH_CONTENT_LOCATION
static MAPIProperty | ATTACH_DATA
static MAPIProperty | ATTACH_DISPOSITION
static MAPIProperty | ATTACH_ENCODING
static MAPIProperty | ATTACH_EXTENSION
static MAPIProperty | ATTACH_FILENAME
static MAPIProperty | ATTACH_FLAGS
static MAPIProperty | ATTACH_LONG_FILENAME
static MAPIProperty | ATTACH_LONG_PATHNAME
static MAPIProperty | ATTACH_METHOD
static MAPIProperty | ATTACH_MIME_SEQUENCE
static MAPIProperty | ATTACH_MIME_TAG
static MAPIProperty | ATTACH_NETSCAPE_MAC_INFO
static MAPIProperty | ATTACH_NUM
static MAPIProperty | ATTACH_PATHNAME
static MAPIProperty | ATTACH_RENDERING
static MAPIProperty | ATTACH_SIZE
static MAPIProperty | ATTACH_TAG
static MAPIProperty | ATTACH_TRANSPORT_NAME
static MAPIProperty | ATTACHMENT_X400_PARAMETERS
static MAPIProperty | AUTHORIZING_USERS
static MAPIProperty | AUTO_FORWARD_COMMENT
static MAPIProperty | AUTO_FORWARDED
static MAPIProperty | AUTO_RESPONSE_SUPPRESS
static MAPIProperty | BIRTHDAY
static MAPIProperty | BODY
static MAPIProperty | BODY_CONTENT_ID
static MAPIProperty | BODY_CONTENT_LOCATION
static MAPIProperty | BODY_CRC
static MAPIProperty | BODY_HTML
static MAPIProperty | BUSINESS_FAX_NUMBER
static MAPIProperty | BUSINESS_HOME_PAGE
static MAPIProperty | CALLBACK_TELEPHONE_NUMBER
static MAPIProperty | CAR_TELEPHONE_NUMBER
static MAPIProperty | CHILDRENS_NAMES
static MAPIProperty | CLIENT_SUBMIT_TIME
static MAPIProperty | COMMENT
static MAPIProperty | COMMON_VIEWS_ENTRY_ID
static MAPIProperty | COMPANY_MAIN_PHONE_NUMBER
static MAPIProperty | COMPANY_NAME
static MAPIProperty | COMPUTER_NETWORK_NAME
static MAPIProperty | CONTACT_ADDRTYPES
static MAPIProperty | CONTACT_DEFAULT_ADDRESS_INDEX
static MAPIProperty | CONTACT_EMAIL_ADDRESSES
static MAPIProperty | CONTACT_ENTRY_IDS
static MAPIProperty | CONTACT_VERSION
static MAPIProperty | CONTAINER_CLASS
static MAPIProperty | CONTAINER_CONTENTS
static MAPIProperty | CONTAINER_FLAGS
static MAPIProperty | CONTAINER_HIERARCHY
static MAPIProperty | CONTAINER_MODIFY_VERSION
static MAPIProperty | CONTENT_CONFIDENTIALITY_ALGORITHM_ID
static MAPIProperty | CONTENT_CORRELATOR
static MAPIProperty | CONTENT_COUNT
static MAPIProperty | CONTENT_IDENTIFIER
static MAPIProperty | CONTENT_INTEGRITY_CHECK
static MAPIProperty | CONTENT_LENGTH
static MAPIProperty | CONTENT_RETURN_REQUESTED
static MAPIProperty | CONTENT_UNREAD
static MAPIProperty | CONTENTS_SORT_ORDER
static MAPIProperty | CONTROL_FLAGS
static MAPIProperty | CONTROL_ID
static MAPIProperty | CONTROL_STRUCTURE
static MAPIProperty | CONTROL_TYPE
static MAPIProperty | CONVERSATION_INDEX
static MAPIProperty | CONVERSATION_KEY
static MAPIProperty | CONVERSATION_TOPIC
static MAPIProperty | CONVERSION_EITS
static MAPIProperty | CONVERSION_PROHIBITED
static MAPIProperty | CONVERSION_WITH_LOSS_PROHIBITED
static MAPIProperty | CONVERTED_EITS
static MAPIProperty | CORRELATE
static MAPIProperty | CORRELATE_MTSID
static MAPIProperty | COUNTRY
static MAPIProperty | CREATE_TEMPLATES
static MAPIProperty | CREATION_TIME
static MAPIProperty | CREATION_VERSION
static MAPIProperty | CURRENT_VERSION
static MAPIProperty | CUSTOMER_ID
static MAPIProperty | DEF_CREATE_DL
static MAPIProperty | DEF_CREATE_MAILUSER
static MAPIProperty | DEFAULT_PROFILE
static MAPIProperty | DEFAULT_STORE
static MAPIProperty | DEFAULT_VIEW_ENTRY_ID
static MAPIProperty | DEFERRED_DELIVERY_TIME
static MAPIProperty | DELEGATION
static MAPIProperty | DELETE_AFTER_SUBMIT
static MAPIProperty | DELIVER_TIME
static MAPIProperty | DELIVERY_POINT
static MAPIProperty | DELTAX
static MAPIProperty | DELTAY
static MAPIProperty | DEPARTMENT_NAME
static MAPIProperty | DEPTH
static MAPIProperty | DETAILS_TABLE
static MAPIProperty | DISC_VAL
static MAPIProperty | DISCARD_REASON
static MAPIProperty | DISCLOSE_RECIPIENTS
static MAPIProperty | DISCLOSURE_OF_RECIPIENTS
static MAPIProperty | DISCRETE_VALUES
static MAPIProperty | DISPLAY_BCC
static MAPIProperty | DISPLAY_CC
static MAPIProperty | DISPLAY_NAME
static MAPIProperty | DISPLAY_NAME_PREFIX
static MAPIProperty | DISPLAY_TO
static MAPIProperty | DISPLAY_TYPE
static MAPIProperty | DL_EXPANSION_HISTORY
static MAPIProperty | DL_EXPANSION_PROHIBITED
static MAPIProperty | EMAIL_ADDRESS
static MAPIProperty | END_DATE
static MAPIProperty | ENTRY_ID
static MAPIProperty | EXPAND_BEGIN_TIME
static MAPIProperty | EXPAND_END_TIME
static MAPIProperty | EXPANDED_BEGIN_TIME
static MAPIProperty | EXPANDED_END_TIME
static MAPIProperty | EXPIRY_TIME
static MAPIProperty | EXPLICIT_CONVERSION
static MAPIProperty | FILTERING_HOOKS
static MAPIProperty | FINDER_ENTRY_ID
static MAPIProperty | FOLDER_ASSOCIATED_CONTENTS
static MAPIProperty | FOLDER_TYPE
static MAPIProperty | FORM_CATEGORY
static MAPIProperty | FORM_CATEGORY_SUB
static MAPIProperty | FORM_CLSID
static MAPIProperty | FORM_CONTACT_NAME
static MAPIProperty | FORM_DESIGNER_GUID
static MAPIProperty | FORM_DESIGNER_NAME
static MAPIProperty | FORM_HIDDEN
static MAPIProperty | FORM_HOST_MAP
static MAPIProperty | FORM_MESSAGE_BEHAVIOR
static MAPIProperty | FORM_VERSION
static MAPIProperty | FTP_SITE
static MAPIProperty | GENDER
static MAPIProperty | GENERATION
static MAPIProperty | GIVEN_NAME
static MAPIProperty | GOVERNMENT_ID_NUMBER
static MAPIProperty | HASATTACH
static MAPIProperty | HEADER_FOLDER_ENTRY_ID
static MAPIProperty | HOBBIES
static MAPIProperty | HOME_ADDRESS_CITY
static MAPIProperty | HOME_ADDRESS_COUNTRY
static MAPIProperty | HOME_ADDRESS_POST_OFFICE_BOX
static MAPIProperty | HOME_ADDRESS_POSTAL_CODE
static MAPIProperty | HOME_ADDRESS_STATE_OR_PROVINCE
static MAPIProperty | HOME_ADDRESS_STREET
static MAPIProperty | HOME_FAX_NUMBER
static MAPIProperty | HOME_TELEPHONE_NUMBER
static MAPIProperty | HOME2_TELEPHONE_NUMBER
static MAPIProperty | ICON
int | id
static MAPIProperty | IDENTITY_DISPLAY
static MAPIProperty | IDENTITY_ENTRY_ID
static MAPIProperty | IDENTITY_SEARCH_KEY
static MAPIProperty | IMPLICIT_CONVERSION_PROHIBITED
static MAPIProperty | IMPORTANCE
static MAPIProperty | IN_REPLY_TO_ID
static MAPIProperty | INCOMPLETE_COPY
static MAPIProperty | INET_MAIL_OVERRIDE_CHARSET
static MAPIProperty | INET_MAIL_OVERRIDE_FORMAT
static MAPIProperty | INITIAL_DETAILS_PANE
static MAPIProperty | INITIALS
static MAPIProperty | INSTANCE_KEY
static MAPIProperty | INTERNET_APPROVED
static MAPIProperty | INTERNET_ARTICLE_NUMBER
static MAPIProperty | INTERNET_CONTROL
static MAPIProperty | INTERNET_CPID
static MAPIProperty | INTERNET_DISTRIBUTION
static MAPIProperty | INTERNET_FOLLOWUP_TO
static MAPIProperty | INTERNET_LINES
static MAPIProperty | INTERNET_MESSAGE_ID
static MAPIProperty | INTERNET_NEWSGROUPS
static MAPIProperty | INTERNET_NNTP_PATH
static MAPIProperty | INTERNET_ORGANIZATION
static MAPIProperty | INTERNET_PRECEDENCE
static MAPIProperty | INTERNET_REFERENCES
static MAPIProperty | IPM_ID
static MAPIProperty | IPM_OUTBOX_ENTRY_ID
static MAPIProperty | IPM_OUTBOX_SEARCH_KEY
static MAPIProperty | IPM_RETURN_REQUESTED
static MAPIProperty | IPM_SENTMAIL_ENTRY_ID
static MAPIProperty | IPM_SENTMAIL_SEARCH_KEY
static MAPIProperty | IPM_SUBTREE_ENTRY_ID
static MAPIProperty | IPM_SUBTREE_SEARCH_KEY
static MAPIProperty | IPM_WASTEBASKET_ENTRY_ID
static MAPIProperty | IPM_WASTEBASKET_SEARCH_KEY
static MAPIProperty | ISDN_NUMBER
static MAPIProperty | KEYWORD
static MAPIProperty | LANGUAGE
static MAPIProperty | LANGUAGES
static MAPIProperty | LAST_MODIFICATION_TIME
static MAPIProperty | LATEST_DELIVERY_TIME
static MAPIProperty | LIST_HELP
static MAPIProperty | LIST_SUBSCRIBE
static MAPIProperty | LIST_UNSUBSCRIBE
static MAPIProperty | LOCALITY
static MAPIProperty | LOCALLY_DELIVERED
static MAPIProperty | LOCATION
static MAPIProperty | LOCK_BRANCH_ID
static MAPIProperty | LOCK_DEPTH
static MAPIProperty | LOCK_ENLISTMENT_CONTEXT
static MAPIProperty | LOCK_EXPIRY_TIME
static MAPIProperty | LOCK_PERSISTENT
static MAPIProperty | LOCK_RESOURCE_DID
static MAPIProperty | LOCK_RESOURCE_FID
static MAPIProperty | LOCK_RESOURCE_MID
static MAPIProperty | LOCK_SCOPE
static MAPIProperty | LOCK_TIMEOUT
static MAPIProperty | LOCK_TYPE
static MAPIProperty | MAIL_PERMISSION
static MAPIProperty | MANAGER_NAME
java.lang.String | mapiProperty
static MAPIProperty | MAPPING_SIGNATURE
static MAPIProperty | MDB_PROVIDER
static MAPIProperty | MESSAGE_ATTACHMENTS
static MAPIProperty | MESSAGE_CC_ME
static MAPIProperty | MESSAGE_CLASS
static MAPIProperty | MESSAGE_CODEPAGE
static MAPIProperty | MESSAGE_DELIVERY_ID
static MAPIProperty | MESSAGE_DELIVERY_TIME
static MAPIProperty | MESSAGE_DOWNLOAD_TIME
static MAPIProperty | MESSAGE_FLAGS
static MAPIProperty | MESSAGE_RECIP_ME
static MAPIProperty | MESSAGE_RECIPIENTS
static MAPIProperty | MESSAGE_SECURITY_LABEL
static MAPIProperty | MESSAGE_SIZE
static MAPIProperty | MESSAGE_SUBMISSION_ID
static MAPIProperty | MESSAGE_TO_ME
static MAPIProperty | MESSAGE_TOKEN
static MAPIProperty | MHS_COMMON_NAME
static MAPIProperty | MIDDLE_NAME
static MAPIProperty | MINI_ICON
static MAPIProperty | MOBILE_TELEPHONE_NUMBER
static MAPIProperty | MODIFY_VERSION
static MAPIProperty | MSG_STATUS
java.lang.String | name
static MAPIProperty | NDR_DIAG_CODE
static MAPIProperty | NDR_REASON_CODE
static MAPIProperty | NDR_STATUS_CODE
static MAPIProperty | NEWSGROUP_NAME
static MAPIProperty | NICKNAME
static MAPIProperty | NNTP_XREF
static MAPIProperty | NON_RECEIPT_NOTIFICATION_REQUESTED
static MAPIProperty | NON_RECEIPT_REASON
static MAPIProperty | NORMALIZED_SUBJECT
static MAPIProperty | NT_SECURITY_DESCRIPTOR
static MAPIProperty | NULL
static MAPIProperty | OBJECT_TYPE
static MAPIProperty | OBSOLETED_IPMS
static MAPIProperty | OFFICE_LOCATION
static MAPIProperty | OFFICE_TELEPHONE_NUMBER
static MAPIProperty | OFFICE2_TELEPHONE_NUMBER
static MAPIProperty | OOF_REPLY_TYPE
static MAPIProperty | ORGANIZATIONAL_ID_NUMBER
static MAPIProperty | ORIG_ENTRY_ID
static MAPIProperty | ORIG_MESSAGE_CLASS
static MAPIProperty | ORIGIN_CHECK
static MAPIProperty | ORIGINAL_AUTHOR_ADDRTYPE
static MAPIProperty | ORIGINAL_AUTHOR_EMAIL_ADDRESS
static MAPIProperty | ORIGINAL_AUTHOR_ENTRY_ID
static MAPIProperty | ORIGINAL_AUTHOR_NAME
static MAPIProperty | ORIGINAL_AUTHOR_SEARCH_KEY
static MAPIProperty | ORIGINAL_DELIVERY_TIME
static MAPIProperty | ORIGINAL_DISPLAY_BCC
static MAPIProperty | ORIGINAL_DISPLAY_CC
static MAPIProperty | ORIGINAL_DISPLAY_NAME
static MAPIProperty | ORIGINAL_DISPLAY_TO
static MAPIProperty | ORIGINAL_EITS
static MAPIProperty | ORIGINAL_ENTRY_ID
static MAPIProperty | ORIGINAL_SEARCH_KEY
static MAPIProperty | ORIGINAL_SENDER_ADDRTYPE
static MAPIProperty | ORIGINAL_SENDER_EMAIL_ADDRESS
static MAPIProperty | ORIGINAL_SENDER_ENTRY_ID
static MAPIProperty | ORIGINAL_SENDER_NAME
static MAPIProperty | ORIGINAL_SENDER_SEARCH_KEY
static MAPIProperty | ORIGINAL_SENSITIVITY
static MAPIProperty | ORIGINAL_SENT_REPRESENTING_ADDRTYPE
static MAPIProperty | ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS
static MAPIProperty | ORIGINAL_SENT_REPRESENTING_ENTRY_ID
static MAPIProperty | ORIGINAL_SENT_REPRESENTING_NAME
static MAPIProperty | ORIGINAL_SENT_REPRESENTING_SEARCH_KEY
static MAPIProperty | ORIGINAL_SUBJECT
static MAPIProperty | ORIGINAL_SUBMIT_TIME
static MAPIProperty | ORIGINALLY_INTENDED_RECIP_ADDRTYPE
static MAPIProperty | ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS
static MAPIProperty | ORIGINALLY_INTENDED_RECIP_ENTRY_ID
static MAPIProperty | ORIGINALLY_INTENDED_RECIPIENT_NAME
static MAPIProperty | ORIGINATING_MTA_CERTIFICATE
static MAPIProperty | ORIGINATOR_AND_DL_EXPANSION_HISTORY
static MAPIProperty | ORIGINATOR_CERTIFICATE
static MAPIProperty | ORIGINATOR_DELIVERY_REPORT_REQUESTED
static MAPIProperty | ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED
static MAPIProperty | ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT
static MAPIProperty | ORIGINATOR_RETURN_ADDRESS
static MAPIProperty | OTHER_ADDRESS_CITY
static MAPIProperty | OTHER_ADDRESS_COUNTRY
static MAPIProperty | OTHER_ADDRESS_POST_OFFICE_BOX
static MAPIProperty | OTHER_ADDRESS_POSTAL_CODE
static MAPIProperty | OTHER_ADDRESS_STATE_OR_PROVINCE
static MAPIProperty | OTHER_ADDRESS_STREET
static MAPIProperty | OTHER_TELEPHONE_NUMBER
static MAPIProperty | OWN_STORE_ENTRY_ID
static MAPIProperty | OWNER_APPT_ID
static MAPIProperty | PAGER_TELEPHONE_NUMBER
static MAPIProperty | PARENT_DISPLAY
static MAPIProperty | PARENT_ENTRY_ID
static MAPIProperty | PARENT_KEY
static MAPIProperty | PERSONAL_HOME_PAGE
static MAPIProperty | PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY
static MAPIProperty | PHYSICAL_DELIVERY_MODE
static MAPIProperty | PHYSICAL_DELIVERY_REPORT_REQUEST
static MAPIProperty | PHYSICAL_FORWARDING_ADDRESS
static MAPIProperty | PHYSICAL_FORWARDING_ADDRESS_REQUESTED
static MAPIProperty | PHYSICAL_FORWARDING_PROHIBITED
static MAPIProperty | PHYSICAL_RENDITION_ATTRIBUTES
static MAPIProperty | POST_FOLDER_ENTRIES
static MAPIProperty | POST_FOLDER_NAMES
static MAPIProperty | POST_OFFICE_BOX
static MAPIProperty | POST_REPLY_DENIED
static MAPIProperty | POST_REPLY_FOLDER_ENTRIES
static MAPIProperty | POST_REPLY_FOLDER_NAMES
static MAPIProperty | POSTAL_ADDRESS
static MAPIProperty | POSTAL_CODE
static MAPIProperty | PREPROCESS
static MAPIProperty | PRIMARY_CAPABILITY
static MAPIProperty | PRIMARY_FAX_NUMBER
static MAPIProperty | PRIMARY_TELEPHONE_NUMBER
static MAPIProperty | PRIORITY
static MAPIProperty | PROFESSION
static MAPIProperty | PROFILE_NAME
static MAPIProperty | PROOF_OF_DELIVERY
static MAPIProperty | PROOF_OF_DELIVERY_REQUESTED
static MAPIProperty | PROOF_OF_SUBMISSION
static MAPIProperty | PROOF_OF_SUBMISSION_REQUESTED
static MAPIProperty | PROP_ID_SECURE_MAX
static MAPIProperty | PROP_ID_SECURE_MIN
static MAPIProperty | PROVIDER_DISPLAY
static MAPIProperty | PROVIDER_DLL_NAME
static MAPIProperty | PROVIDER_ORDINAL
static MAPIProperty | PROVIDER_SUBMIT_TIME
static MAPIProperty | PROVIDER_UID
static MAPIProperty | PUID
static MAPIProperty | RADIO_TELEPHONE_NUMBER
static MAPIProperty | RCVD_REPRESENTING_ADDRTYPE
static MAPIProperty | RCVD_REPRESENTING_EMAIL_ADDRESS
static MAPIProperty | RCVD_REPRESENTING_ENTRY_ID
static MAPIProperty | RCVD_REPRESENTING_NAME
static MAPIProperty | RCVD_REPRESENTING_SEARCH_KEY
static MAPIProperty | READ_RECEIPT_ENTRY_ID
static MAPIProperty | READ_RECEIPT_REQUESTED
static MAPIProperty | READ_RECEIPT_SEARCH_KEY
static MAPIProperty | RECEIPT_TIME
static MAPIProperty | RECEIVE_FOLDER_SETTINGS
static MAPIProperty | RECEIVED_BY_ADDRTYPE
static MAPIProperty | RECEIVED_BY_EMAIL_ADDRESS
static MAPIProperty | RECEIVED_BY_ENTRY_ID
static MAPIProperty | RECEIVED_BY_NAME
static MAPIProperty | RECEIVED_BY_SEARCH_KEY
static MAPIProperty | RECIPIENT_CERTIFICATE
static MAPIProperty | RECIPIENT_DISPLAY_NAME
static MAPIProperty | RECIPIENT_ENTRY_ID
static MAPIProperty | RECIPIENT_FLAGS
static MAPIProperty | RECIPIENT_NUMBER_FOR_ADVICE
static MAPIProperty | RECIPIENT_REASSIGNMENT_PROHIBITED
static MAPIProperty | RECIPIENT_STATUS
static MAPIProperty | RECIPIENT_TYPE
static MAPIProperty | RECORD_KEY
static MAPIProperty | REDIRECTION_HISTORY
static MAPIProperty | REFERRED_BY_NAME
static MAPIProperty | REGISTERED_MAIL_TYPE
static MAPIProperty | RELATED_IPMS
static MAPIProperty | REMOTE_PROGRESS
static MAPIProperty | REMOTE_PROGRESS_TEXT
static MAPIProperty | REMOTE_VALIDATE_OK
static MAPIProperty | RENDERING_POSITION
static MAPIProperty | REPLY_RECIPIENT_ENTRIES
static MAPIProperty | REPLY_RECIPIENT_NAMES
static MAPIProperty | REPLY_REQUESTED
static MAPIProperty | REPLY_TIME
static MAPIProperty | REPORT_ENTRY_ID
static MAPIProperty | REPORT_NAME
static MAPIProperty | REPORT_SEARCH_KEY
static MAPIProperty | REPORT_TAG
static MAPIProperty | REPORT_TEXT
static MAPIProperty | REPORT_TIME
static MAPIProperty | REPORTING_DL_NAME
static MAPIProperty | REPORTING_MTA_CERTIFICATE
static MAPIProperty | REQUESTED_DELIVERY_METHOD
static MAPIProperty | RESOURCE_FLAGS
static MAPIProperty | RESOURCE_METHODS
static MAPIProperty | RESOURCE_PATH
static MAPIProperty | RESOURCE_TYPE
static MAPIProperty | RESPONSE_REQUESTED
static MAPIProperty | RESPONSIBILITY
static MAPIProperty | RETURNED_IPM
static MAPIProperty | ROW_TYPE
static MAPIProperty | ROWID
static MAPIProperty | RTF_COMPRESSED
static MAPIProperty | RTF_IN_SYNC
static MAPIProperty | RTF_SYNC_BODY_COUNT
static MAPIProperty | RTF_SYNC_BODY_CRC
static MAPIProperty | RTF_SYNC_BODY_TAG
static MAPIProperty | RTF_SYNC_PREFIX_COUNT
static MAPIProperty | RTF_SYNC_TRAILING_COUNT
static MAPIProperty | SEARCH
static MAPIProperty | SEARCH_KEY
static MAPIProperty | SECURITY
static MAPIProperty | SELECTABLE
static MAPIProperty | SEND_INTERNET_ENCODING
static MAPIProperty | SEND_RECALL_REPORT
static MAPIProperty | SEND_RICH_INFO
static MAPIProperty | SENDER_ADDRTYPE
static MAPIProperty | SENDER_EMAIL_ADDRESS
static MAPIProperty | SENDER_ENTRY_ID
static MAPIProperty | SENDER_NAME
static MAPIProperty | SENDER_SEARCH_KEY
static MAPIProperty | SENSITIVITY
static MAPIProperty | SENT_REPRESENTING_ADDRTYPE
static MAPIProperty | SENT_REPRESENTING_EMAIL_ADDRESS
static MAPIProperty | SENT_REPRESENTING_ENTRY_ID
static MAPIProperty | SENT_REPRESENTING_NAME
static MAPIProperty | SENT_REPRESENTING_SEARCH_KEY
static MAPIProperty | SENTMAIL_ENTRY_ID
static MAPIProperty | SERVICE_DELETE_FILES
static MAPIProperty | SERVICE_DLL_NAME
static MAPIProperty | SERVICE_ENTRY_NAME
static MAPIProperty | SERVICE_EXTRA_UIDS
static MAPIProperty | SERVICE_NAME
static MAPIProperty | SERVICE_SUPPORT_FILES
static MAPIProperty | SERVICE_UID
static MAPIProperty | SERVICES
static MAPIProperty | SEVEN_BIT_DISPLAY_NAME
static MAPIProperty | SMTP_ADDRESS
static MAPIProperty | SPOOLER_STATUS
static MAPIProperty | SPOUSE_NAME
static MAPIProperty | START_DATE
static MAPIProperty | STATE_OR_PROVINCE
static MAPIProperty | STATUS
static MAPIProperty | STATUS_CODE
static MAPIProperty | STATUS_STRING
static MAPIProperty | STORE_ENTRY_ID
static MAPIProperty | STORE_PROVIDERS
static MAPIProperty | STORE_RECORD_KEY
static MAPIProperty | STORE_STATE
static MAPIProperty | STORE_SUPPORT_MASK
static MAPIProperty | STREET_ADDRESS
static MAPIProperty | SUBFOLDERS
static MAPIProperty | SUBJECT
static MAPIProperty | SUBJECT_IPM
static MAPIProperty | SUBJECT_PREFIX
static MAPIProperty | SUBMIT_FLAGS
static MAPIProperty | SUPERSEDES
static MAPIProperty | SUPPLEMENTARY_INFO
static MAPIProperty | SURNAME
static MAPIProperty | TELEX_NUMBER
static MAPIProperty | TEMPLATEID
static MAPIProperty | TITLE
static MAPIProperty | TNEF_CORRELATION_KEY
static MAPIProperty | TRANSMITABLE_DISPLAY_NAME
static MAPIProperty | TRANSPORT_KEY
static MAPIProperty | TRANSPORT_MESSAGE_HEADERS
static MAPIProperty | TRANSPORT_PROVIDERS
static MAPIProperty | TRANSPORT_STATUS
static MAPIProperty | TTYTDD_PHONE_NUMBER
static MAPIProperty | TYPE_OF_MTS_USER
static MAPIProperty | UNKNOWN
static MAPIProperty | USER_CERTIFICATE
static MAPIProperty | USER_X509_CERTIFICATE
int | usualType
static MAPIProperty | VALID_FOLDER_MASK
static MAPIProperty | VIEWS_ENTRY_ID
static MAPIProperty | WEDDING_ANNIVERSARY
static MAPIProperty | X400_CONTENT_TYPE
static MAPIProperty | X400_DEFERRED_DELIVERY_CANCEL
static MAPIProperty | XPOS
static MAPIProperty | YPOS
Method Summary
static MAPIProperty | createCustom(int id, int type, java.lang.String name)
static MAPIProperty | get(int id)
static java.util.Collection<MAPIProperty> | getAll()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

AB_DEFAULT_DIR

public static final MAPIProperty AB_DEFAULT_DIR

AB_DEFAULT_PAB

public static final MAPIProperty AB_DEFAULT_PAB

AB_PROVIDER_ID

public static final MAPIProperty AB_PROVIDER_ID

AB_PROVIDERS

public static final MAPIProperty AB_PROVIDERS

AB_SEARCH_PATH

public static final MAPIProperty AB_SEARCH_PATH

AB_SEARCH_PATH_UPDATE

public static final MAPIProperty AB_SEARCH_PATH_UPDATE

ACCESS

public static final MAPIProperty ACCESS

ACCESS_LEVEL

public static final MAPIProperty ACCESS_LEVEL

ACCOUNT

public static final MAPIProperty ACCOUNT

ADDRTYPE

public static final MAPIProperty ADDRTYPE

ALTERNATE_RECIPIENT

public static final MAPIProperty ALTERNATE_RECIPIENT

ALTERNATE_RECIPIENT_ALLOWED

public static final MAPIProperty ALTERNATE_RECIPIENT_ALLOWED

ANR

public static final MAPIProperty ANR

ASSISTANT

public static final MAPIProperty ASSISTANT

ASSISTANT_TELEPHONE_NUMBER

public static final MAPIProperty ASSISTANT_TELEPHONE_NUMBER

ASSOC_CONTENT_COUNT

public static final MAPIProperty ASSOC_CONTENT_COUNT

ATTACH_ADDITIONAL_INFO

public static final MAPIProperty ATTACH_ADDITIONAL_INFO

ATTACH_CONTENT_BASE

public static final MAPIProperty ATTACH_CONTENT_BASE

ATTACH_CONTENT_ID

public static final MAPIProperty ATTACH_CONTENT_ID

ATTACH_CONTENT_LOCATION

public static final MAPIProperty ATTACH_CONTENT_LOCATION

ATTACH_DATA

public static final MAPIProperty ATTACH_DATA

ATTACH_DISPOSITION

public static final MAPIProperty ATTACH_DISPOSITION

ATTACH_ENCODING

public static final MAPIProperty ATTACH_ENCODING

ATTACH_EXTENSION

public static final MAPIProperty ATTACH_EXTENSION

ATTACH_FILENAME

public static final MAPIProperty ATTACH_FILENAME

ATTACH_FLAGS

public static final MAPIProperty ATTACH_FLAGS

ATTACH_LONG_FILENAME

public static final MAPIProperty ATTACH_LONG_FILENAME

ATTACH_LONG_PATHNAME

public static final MAPIProperty ATTACH_LONG_PATHNAME

ATTACH_METHOD

public static final MAPIProperty ATTACH_METHOD

ATTACH_MIME_SEQUENCE

public static final MAPIProperty ATTACH_MIME_SEQUENCE

ATTACH_MIME_TAG

public static final MAPIProperty ATTACH_MIME_TAG

ATTACH_NETSCAPE_MAC_INFO

public static final MAPIProperty ATTACH_NETSCAPE_MAC_INFO

ATTACH_NUM

public static final MAPIProperty ATTACH_NUM

ATTACH_PATHNAME

public static final MAPIProperty ATTACH_PATHNAME

ATTACH_RENDERING

public static final MAPIProperty ATTACH_RENDERING

ATTACH_SIZE

public static final MAPIProperty ATTACH_SIZE

ATTACH_TAG

public static final MAPIProperty ATTACH_TAG

ATTACH_TRANSPORT_NAME

public static final MAPIProperty ATTACH_TRANSPORT_NAME

ATTACHMENT_X400_PARAMETERS

public static final MAPIProperty ATTACHMENT_X400_PARAMETERS

AUTHORIZING_USERS

public static final MAPIProperty AUTHORIZING_USERS

AUTO_FORWARD_COMMENT

public static final MAPIProperty AUTO_FORWARD_COMMENT

AUTO_FORWARDED

public static final MAPIProperty AUTO_FORWARDED

AUTO_RESPONSE_SUPPRESS

public static final MAPIProperty AUTO_RESPONSE_SUPPRESS

BIRTHDAY

public static final MAPIProperty BIRTHDAY

BODY

public static final MAPIProperty BODY

BODY_CONTENT_ID

public static final MAPIProperty BODY_CONTENT_ID

BODY_CONTENT_LOCATION

public static final MAPIProperty BODY_CONTENT_LOCATION

BODY_CRC

public static final MAPIProperty BODY_CRC

BODY_HTML

public static final MAPIProperty BODY_HTML

BUSINESS_FAX_NUMBER

public static final MAPIProperty BUSINESS_FAX_NUMBER

BUSINESS_HOME_PAGE

public static final MAPIProperty BUSINESS_HOME_PAGE

CALLBACK_TELEPHONE_NUMBER

public static final MAPIProperty CALLBACK_TELEPHONE_NUMBER

CAR_TELEPHONE_NUMBER

public static final MAPIProperty CAR_TELEPHONE_NUMBER

CHILDRENS_NAMES

public static final MAPIProperty CHILDRENS_NAMES

CLIENT_SUBMIT_TIME

public static final MAPIProperty CLIENT_SUBMIT_TIME

COMMENT

public static final MAPIProperty COMMENT

COMMON_VIEWS_ENTRY_ID

public static final MAPIProperty COMMON_VIEWS_ENTRY_ID

COMPANY_MAIN_PHONE_NUMBER

public static final MAPIProperty COMPANY_MAIN_PHONE_NUMBER

COMPANY_NAME

public static final MAPIProperty COMPANY_NAME

COMPUTER_NETWORK_NAME

public static final MAPIProperty COMPUTER_NETWORK_NAME

CONTACT_ADDRTYPES

public static final MAPIProperty CONTACT_ADDRTYPES

CONTACT_DEFAULT_ADDRESS_INDEX

public static final MAPIProperty CONTACT_DEFAULT_ADDRESS_INDEX

CONTACT_EMAIL_ADDRESSES

public static final MAPIProperty CONTACT_EMAIL_ADDRESSES

CONTACT_ENTRY_IDS

public static final MAPIProperty CONTACT_ENTRY_IDS

CONTACT_VERSION

public static final MAPIProperty CONTACT_VERSION

CONTAINER_CLASS

public static final MAPIProperty CONTAINER_CLASS

CONTAINER_CONTENTS

public static final MAPIProperty CONTAINER_CONTENTS

CONTAINER_FLAGS

public static final MAPIProperty CONTAINER_FLAGS

CONTAINER_HIERARCHY

public static final MAPIProperty CONTAINER_HIERARCHY

CONTAINER_MODIFY_VERSION

public static final MAPIProperty CONTAINER_MODIFY_VERSION

CONTENT_CONFIDENTIALITY_ALGORITHM_ID

public static final MAPIProperty CONTENT_CONFIDENTIALITY_ALGORITHM_ID

CONTENT_CORRELATOR

public static final MAPIProperty CONTENT_CORRELATOR

CONTENT_COUNT

public static final MAPIProperty CONTENT_COUNT

CONTENT_IDENTIFIER

public static final MAPIProperty CONTENT_IDENTIFIER

CONTENT_INTEGRITY_CHECK

public static final MAPIProperty CONTENT_INTEGRITY_CHECK

CONTENT_LENGTH

public static final MAPIProperty CONTENT_LENGTH

CONTENT_RETURN_REQUESTED

public static final MAPIProperty CONTENT_RETURN_REQUESTED

CONTENT_UNREAD

public static final MAPIProperty CONTENT_UNREAD

CONTENTS_SORT_ORDER

public static final MAPIProperty CONTENTS_SORT_ORDER

CONTROL_FLAGS

public static final MAPIProperty CONTROL_FLAGS

CONTROL_ID

public static final MAPIProperty CONTROL_ID

CONTROL_STRUCTURE

public static final MAPIProperty CONTROL_STRUCTURE

CONTROL_TYPE

public static final MAPIProperty CONTROL_TYPE

CONVERSATION_INDEX

public static final MAPIProperty CONVERSATION_INDEX

CONVERSATION_KEY

public static final MAPIProperty CONVERSATION_KEY

CONVERSATION_TOPIC

public static final MAPIProperty CONVERSATION_TOPIC

CONVERSION_EITS

public static final MAPIProperty CONVERSION_EITS

CONVERSION_PROHIBITED

public static final MAPIProperty CONVERSION_PROHIBITED

CONVERSION_WITH_LOSS_PROHIBITED

public static final MAPIProperty CONVERSION_WITH_LOSS_PROHIBITED

CONVERTED_EITS

public static final MAPIProperty CONVERTED_EITS

CORRELATE

public static final MAPIProperty CORRELATE

CORRELATE_MTSID

public static final MAPIProperty CORRELATE_MTSID

COUNTRY

public static final MAPIProperty COUNTRY

CREATE_TEMPLATES

public static final MAPIProperty CREATE_TEMPLATES

CREATION_TIME

public static final MAPIProperty CREATION_TIME

CREATION_VERSION

public static final MAPIProperty CREATION_VERSION

CURRENT_VERSION

public static final MAPIProperty CURRENT_VERSION

CUSTOMER_ID

public static final MAPIProperty CUSTOMER_ID

DEF_CREATE_DL

public static final MAPIProperty DEF_CREATE_DL

DEF_CREATE_MAILUSER

public static final MAPIProperty DEF_CREATE_MAILUSER

DEFAULT_PROFILE

public static final MAPIProperty DEFAULT_PROFILE

DEFAULT_STORE

public static final MAPIProperty DEFAULT_STORE

DEFAULT_VIEW_ENTRY_ID

public static final MAPIProperty DEFAULT_VIEW_ENTRY_ID

DEFERRED_DELIVERY_TIME

public static final MAPIProperty DEFERRED_DELIVERY_TIME

DELEGATION

public static final MAPIProperty DELEGATION

DELETE_AFTER_SUBMIT

public static final MAPIProperty DELETE_AFTER_SUBMIT

DELIVER_TIME

public static final MAPIProperty DELIVER_TIME

DELIVERY_POINT

public static final MAPIProperty DELIVERY_POINT

DELTAX

public static final MAPIProperty DELTAX

DELTAY

public static final MAPIProperty DELTAY

DEPARTMENT_NAME

public static final MAPIProperty DEPARTMENT_NAME

DEPTH

public static final MAPIProperty DEPTH

DETAILS_TABLE

public static final MAPIProperty DETAILS_TABLE

DISC_VAL

public static final MAPIProperty DISC_VAL

DISCARD_REASON

public static final MAPIProperty DISCARD_REASON

DISCLOSE_RECIPIENTS

public static final MAPIProperty DISCLOSE_RECIPIENTS

DISCLOSURE_OF_RECIPIENTS

public static final MAPIProperty DISCLOSURE_OF_RECIPIENTS

DISCRETE_VALUES

public static final MAPIProperty DISCRETE_VALUES

DISPLAY_BCC

public static final MAPIProperty DISPLAY_BCC

DISPLAY_CC

public static final MAPIProperty DISPLAY_CC

DISPLAY_NAME

public static final MAPIProperty DISPLAY_NAME

DISPLAY_NAME_PREFIX

public static final MAPIProperty DISPLAY_NAME_PREFIX

DISPLAY_TO

public static final MAPIProperty DISPLAY_TO

DISPLAY_TYPE

public static final MAPIProperty DISPLAY_TYPE

DL_EXPANSION_HISTORY

public static final MAPIProperty DL_EXPANSION_HISTORY

DL_EXPANSION_PROHIBITED

public static final MAPIProperty DL_EXPANSION_PROHIBITED

EMAIL_ADDRESS

public static final MAPIProperty EMAIL_ADDRESS

END_DATE

public static final MAPIProperty END_DATE

ENTRY_ID

public static final MAPIProperty ENTRY_ID

EXPAND_BEGIN_TIME

public static final MAPIProperty EXPAND_BEGIN_TIME

EXPAND_END_TIME

public static final MAPIProperty EXPAND_END_TIME

EXPANDED_BEGIN_TIME

public static final MAPIProperty EXPANDED_BEGIN_TIME

EXPANDED_END_TIME

public static final MAPIProperty EXPANDED_END_TIME

EXPIRY_TIME

public static final MAPIProperty EXPIRY_TIME

EXPLICIT_CONVERSION

public static final MAPIProperty EXPLICIT_CONVERSION

FILTERING_HOOKS

public static final MAPIProperty FILTERING_HOOKS

FINDER_ENTRY_ID

public static final MAPIProperty FINDER_ENTRY_ID

FOLDER_ASSOCIATED_CONTENTS

public static final MAPIProperty FOLDER_ASSOCIATED_CONTENTS

FOLDER_TYPE

public static final MAPIProperty FOLDER_TYPE

FORM_CATEGORY

public static final MAPIProperty FORM_CATEGORY

FORM_CATEGORY_SUB

public static final MAPIProperty FORM_CATEGORY_SUB

FORM_CLSID

public static final MAPIProperty FORM_CLSID

FORM_CONTACT_NAME

public static final MAPIProperty FORM_CONTACT_NAME

FORM_DESIGNER_GUID

public static final MAPIProperty FORM_DESIGNER_GUID

FORM_DESIGNER_NAME

public static final MAPIProperty FORM_DESIGNER_NAME

FORM_HIDDEN

public static final MAPIProperty FORM_HIDDEN

FORM_HOST_MAP

public static final MAPIProperty FORM_HOST_MAP

FORM_MESSAGE_BEHAVIOR

public static final MAPIProperty FORM_MESSAGE_BEHAVIOR

FORM_VERSION

public static final MAPIProperty FORM_VERSION

FTP_SITE

public static final MAPIProperty FTP_SITE

GENDER

public static final MAPIProperty GENDER

GENERATION

public static final MAPIProperty GENERATION

GIVEN_NAME

public static final MAPIProperty GIVEN_NAME

GOVERNMENT_ID_NUMBER

public static final MAPIProperty GOVERNMENT_ID_NUMBER

HASATTACH

public static final MAPIProperty HASATTACH

HEADER_FOLDER_ENTRY_ID

public static final MAPIProperty HEADER_FOLDER_ENTRY_ID

HOBBIES

public static final MAPIProperty HOBBIES

HOME2_TELEPHONE_NUMBER

public static final MAPIProperty HOME2_TELEPHONE_NUMBER

HOME_ADDRESS_CITY

public static final MAPIProperty HOME_ADDRESS_CITY

HOME_ADDRESS_COUNTRY

public static final MAPIProperty HOME_ADDRESS_COUNTRY

HOME_ADDRESS_POST_OFFICE_BOX

public static final MAPIProperty HOME_ADDRESS_POST_OFFICE_BOX

HOME_ADDRESS_POSTAL_CODE

public static final MAPIProperty HOME_ADDRESS_POSTAL_CODE

HOME_ADDRESS_STATE_OR_PROVINCE

public static final MAPIProperty HOME_ADDRESS_STATE_OR_PROVINCE

HOME_ADDRESS_STREET

public static final MAPIProperty HOME_ADDRESS_STREET

HOME_FAX_NUMBER

public static final MAPIProperty HOME_FAX_NUMBER

HOME_TELEPHONE_NUMBER

public static final MAPIProperty HOME_TELEPHONE_NUMBER

INET_MAIL_OVERRIDE_CHARSET

public static final MAPIProperty INET_MAIL_OVERRIDE_CHARSET

INET_MAIL_OVERRIDE_FORMAT

public static final MAPIProperty INET_MAIL_OVERRIDE_FORMAT

ICON

public static final MAPIProperty ICON

IDENTITY_DISPLAY

public static final MAPIProperty IDENTITY_DISPLAY

IDENTITY_ENTRY_ID

public static final MAPIProperty IDENTITY_ENTRY_ID

IDENTITY_SEARCH_KEY

public static final MAPIProperty IDENTITY_SEARCH_KEY

IMPLICIT_CONVERSION_PROHIBITED

public static final MAPIProperty IMPLICIT_CONVERSION_PROHIBITED

IMPORTANCE

public static final MAPIProperty IMPORTANCE

IN_REPLY_TO_ID

public static final MAPIProperty IN_REPLY_TO_ID

INCOMPLETE_COPY

public static final MAPIProperty INCOMPLETE_COPY

INITIAL_DETAILS_PANE

public static final MAPIProperty INITIAL_DETAILS_PANE

INITIALS

public static final MAPIProperty INITIALS

INSTANCE_KEY

public static final MAPIProperty INSTANCE_KEY

INTERNET_APPROVED

public static final MAPIProperty INTERNET_APPROVED

INTERNET_ARTICLE_NUMBER

public static final MAPIProperty INTERNET_ARTICLE_NUMBER

INTERNET_CPID

public static final MAPIProperty INTERNET_CPID

INTERNET_CONTROL

public static final MAPIProperty INTERNET_CONTROL

INTERNET_DISTRIBUTION

public static final MAPIProperty INTERNET_DISTRIBUTION

INTERNET_FOLLOWUP_TO

public static final MAPIProperty INTERNET_FOLLOWUP_TO

INTERNET_LINES

public static final MAPIProperty INTERNET_LINES

INTERNET_MESSAGE_ID

public static final MAPIProperty INTERNET_MESSAGE_ID

INTERNET_NEWSGROUPS

public static final MAPIProperty INTERNET_NEWSGROUPS

INTERNET_NNTP_PATH

public static final MAPIProperty INTERNET_NNTP_PATH

INTERNET_ORGANIZATION

public static final MAPIProperty INTERNET_ORGANIZATION

INTERNET_PRECEDENCE

public static final MAPIProperty INTERNET_PRECEDENCE

INTERNET_REFERENCES

public static final MAPIProperty INTERNET_REFERENCES

IPM_ID

public static final MAPIProperty IPM_ID

IPM_OUTBOX_ENTRY_ID

public static final MAPIProperty IPM_OUTBOX_ENTRY_ID

IPM_OUTBOX_SEARCH_KEY

public static final MAPIProperty IPM_OUTBOX_SEARCH_KEY

IPM_RETURN_REQUESTED

public static final MAPIProperty IPM_RETURN_REQUESTED

IPM_SENTMAIL_ENTRY_ID

public static final MAPIProperty IPM_SENTMAIL_ENTRY_ID

IPM_SENTMAIL_SEARCH_KEY

public static final MAPIProperty IPM_SENTMAIL_SEARCH_KEY

IPM_SUBTREE_ENTRY_ID

public static final MAPIProperty IPM_SUBTREE_ENTRY_ID

IPM_SUBTREE_SEARCH_KEY

public static final MAPIProperty IPM_SUBTREE_SEARCH_KEY

IPM_WASTEBASKET_ENTRY_ID

public static final MAPIProperty IPM_WASTEBASKET_ENTRY_ID

IPM_WASTEBASKET_SEARCH_KEY

public static final MAPIProperty IPM_WASTEBASKET_SEARCH_KEY

ISDN_NUMBER

public static final MAPIProperty ISDN_NUMBER

KEYWORD

public static final MAPIProperty KEYWORD

LANGUAGE

public static final MAPIProperty LANGUAGE

LANGUAGES

public static final MAPIProperty LANGUAGES

LAST_MODIFICATION_TIME

public static final MAPIProperty LAST_MODIFICATION_TIME

LATEST_DELIVERY_TIME

public static final MAPIProperty LATEST_DELIVERY_TIME

LIST_HELP

public static final MAPIProperty LIST_HELP

LIST_SUBSCRIBE

public static final MAPIProperty LIST_SUBSCRIBE

LIST_UNSUBSCRIBE

public static final MAPIProperty LIST_UNSUBSCRIBE

LOCALITY

public static final MAPIProperty LOCALITY

LOCALLY_DELIVERED

public static final MAPIProperty LOCALLY_DELIVERED

LOCATION

public static final MAPIProperty LOCATION

LOCK_BRANCH_ID

public static final MAPIProperty LOCK_BRANCH_ID

LOCK_DEPTH

public static final MAPIProperty LOCK_DEPTH

LOCK_ENLISTMENT_CONTEXT

public static final MAPIProperty LOCK_ENLISTMENT_CONTEXT

LOCK_EXPIRY_TIME

public static final MAPIProperty LOCK_EXPIRY_TIME

LOCK_PERSISTENT

public static final MAPIProperty LOCK_PERSISTENT

LOCK_RESOURCE_DID

public static final MAPIProperty LOCK_RESOURCE_DID

LOCK_RESOURCE_FID

public static final MAPIProperty LOCK_RESOURCE_FID

LOCK_RESOURCE_MID

public static final MAPIProperty LOCK_RESOURCE_MID

LOCK_SCOPE

public static final MAPIProperty LOCK_SCOPE

LOCK_TIMEOUT

public static final MAPIProperty LOCK_TIMEOUT

LOCK_TYPE

public static final MAPIProperty LOCK_TYPE

MAIL_PERMISSION

public static final MAPIProperty MAIL_PERMISSION

MANAGER_NAME

public static final MAPIProperty MANAGER_NAME

MAPPING_SIGNATURE

public static final MAPIProperty MAPPING_SIGNATURE

MDB_PROVIDER

public static final MAPIProperty MDB_PROVIDER

MESSAGE_ATTACHMENTS

public static final MAPIProperty MESSAGE_ATTACHMENTS

MESSAGE_CC_ME

public static final MAPIProperty MESSAGE_CC_ME

MESSAGE_CLASS

public static final MAPIProperty MESSAGE_CLASS

MESSAGE_CODEPAGE

public static final MAPIProperty MESSAGE_CODEPAGE

MESSAGE_DELIVERY_ID

public static final MAPIProperty MESSAGE_DELIVERY_ID

MESSAGE_DELIVERY_TIME

public static final MAPIProperty MESSAGE_DELIVERY_TIME

MESSAGE_DOWNLOAD_TIME

public static final MAPIProperty MESSAGE_DOWNLOAD_TIME

MESSAGE_FLAGS

public static final MAPIProperty MESSAGE_FLAGS

MESSAGE_RECIP_ME

public static final MAPIProperty MESSAGE_RECIP_ME

MESSAGE_RECIPIENTS

public static final MAPIProperty MESSAGE_RECIPIENTS

MESSAGE_SECURITY_LABEL

public static final MAPIProperty MESSAGE_SECURITY_LABEL

MESSAGE_SIZE

public static final MAPIProperty MESSAGE_SIZE

MESSAGE_SUBMISSION_ID

public static final MAPIProperty MESSAGE_SUBMISSION_ID

MESSAGE_TO_ME

public static final MAPIProperty MESSAGE_TO_ME

MESSAGE_TOKEN

public static final MAPIProperty MESSAGE_TOKEN

MHS_COMMON_NAME

public static final MAPIProperty MHS_COMMON_NAME

MIDDLE_NAME

public static final MAPIProperty MIDDLE_NAME

MINI_ICON

public static final MAPIProperty MINI_ICON

MOBILE_TELEPHONE_NUMBER

public static final MAPIProperty MOBILE_TELEPHONE_NUMBER

MODIFY_VERSION

public static final MAPIProperty MODIFY_VERSION

MSG_STATUS

public static final MAPIProperty MSG_STATUS

NDR_DIAG_CODE

public static final MAPIProperty NDR_DIAG_CODE

NDR_REASON_CODE

public static final MAPIProperty NDR_REASON_CODE

NDR_STATUS_CODE

public static final MAPIProperty NDR_STATUS_CODE

NEWSGROUP_NAME

public static final MAPIProperty NEWSGROUP_NAME

NICKNAME

public static final MAPIProperty NICKNAME

NNTP_XREF

public static final MAPIProperty NNTP_XREF

NON_RECEIPT_NOTIFICATION_REQUESTED

public static final MAPIProperty NON_RECEIPT_NOTIFICATION_REQUESTED

NON_RECEIPT_REASON

public static final MAPIProperty NON_RECEIPT_REASON

NORMALIZED_SUBJECT

public static final MAPIProperty NORMALIZED_SUBJECT

NT_SECURITY_DESCRIPTOR

public static final MAPIProperty NT_SECURITY_DESCRIPTOR

NULL

public static final MAPIProperty NULL

OBJECT_TYPE

public static final MAPIProperty OBJECT_TYPE

OBSOLETED_IPMS

public static final MAPIProperty OBSOLETED_IPMS

OFFICE2_TELEPHONE_NUMBER

public static final MAPIProperty OFFICE2_TELEPHONE_NUMBER

OFFICE_LOCATION

public static final MAPIProperty OFFICE_LOCATION

OFFICE_TELEPHONE_NUMBER

public static final MAPIProperty OFFICE_TELEPHONE_NUMBER

OOF_REPLY_TYPE

public static final MAPIProperty OOF_REPLY_TYPE

ORGANIZATIONAL_ID_NUMBER

public static final MAPIProperty ORGANIZATIONAL_ID_NUMBER

ORIG_ENTRY_ID

public static final MAPIProperty ORIG_ENTRY_ID

ORIG_MESSAGE_CLASS

public static final MAPIProperty ORIG_MESSAGE_CLASS

ORIGIN_CHECK

public static final MAPIProperty ORIGIN_CHECK

ORIGINAL_AUTHOR_ADDRTYPE

public static final MAPIProperty ORIGINAL_AUTHOR_ADDRTYPE

ORIGINAL_AUTHOR_EMAIL_ADDRESS

public static final MAPIProperty ORIGINAL_AUTHOR_EMAIL_ADDRESS

ORIGINAL_AUTHOR_ENTRY_ID

public static final MAPIProperty ORIGINAL_AUTHOR_ENTRY_ID

ORIGINAL_AUTHOR_NAME

public static final MAPIProperty ORIGINAL_AUTHOR_NAME

ORIGINAL_AUTHOR_SEARCH_KEY

public static final MAPIProperty ORIGINAL_AUTHOR_SEARCH_KEY

ORIGINAL_DELIVERY_TIME

public static final MAPIProperty ORIGINAL_DELIVERY_TIME

ORIGINAL_DISPLAY_BCC

public static final MAPIProperty ORIGINAL_DISPLAY_BCC

ORIGINAL_DISPLAY_CC

public static final MAPIProperty ORIGINAL_DISPLAY_CC

ORIGINAL_DISPLAY_NAME

public static final MAPIProperty ORIGINAL_DISPLAY_NAME

ORIGINAL_DISPLAY_TO

public static final MAPIProperty ORIGINAL_DISPLAY_TO

ORIGINAL_EITS

public static final MAPIProperty ORIGINAL_EITS

ORIGINAL_ENTRY_ID

public static final MAPIProperty ORIGINAL_ENTRY_ID

ORIGINAL_SEARCH_KEY

public static final MAPIProperty ORIGINAL_SEARCH_KEY

ORIGINAL_SENDER_ADDRTYPE

public static final MAPIProperty ORIGINAL_SENDER_ADDRTYPE

ORIGINAL_SENDER_EMAIL_ADDRESS

public static final MAPIProperty ORIGINAL_SENDER_EMAIL_ADDRESS

ORIGINAL_SENDER_ENTRY_ID

public static final MAPIProperty ORIGINAL_SENDER_ENTRY_ID

ORIGINAL_SENDER_NAME

public static final MAPIProperty ORIGINAL_SENDER_NAME

ORIGINAL_SENDER_SEARCH_KEY

public static final MAPIProperty ORIGINAL_SENDER_SEARCH_KEY

ORIGINAL_SENSITIVITY

public static final MAPIProperty ORIGINAL_SENSITIVITY

ORIGINAL_SENT_REPRESENTING_ADDRTYPE

public static final MAPIProperty ORIGINAL_SENT_REPRESENTING_ADDRTYPE

ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS

public static final MAPIProperty ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS

ORIGINAL_SENT_REPRESENTING_ENTRY_ID

public static final MAPIProperty ORIGINAL_SENT_REPRESENTING_ENTRY_ID

ORIGINAL_SENT_REPRESENTING_NAME

public static final MAPIProperty ORIGINAL_SENT_REPRESENTING_NAME

ORIGINAL_SENT_REPRESENTING_SEARCH_KEY

public static final MAPIProperty ORIGINAL_SENT_REPRESENTING_SEARCH_KEY

ORIGINAL_SUBJECT

public static final MAPIProperty ORIGINAL_SUBJECT

ORIGINAL_SUBMIT_TIME

public static final MAPIProperty ORIGINAL_SUBMIT_TIME

ORIGINALLY_INTENDED_RECIP_ADDRTYPE

public static final MAPIProperty ORIGINALLY_INTENDED_RECIP_ADDRTYPE

ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS

public static final MAPIProperty ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS

ORIGINALLY_INTENDED_RECIP_ENTRY_ID

public static final MAPIProperty ORIGINALLY_INTENDED_RECIP_ENTRY_ID

ORIGINALLY_INTENDED_RECIPIENT_NAME

public static final MAPIProperty ORIGINALLY_INTENDED_RECIPIENT_NAME

ORIGINATING_MTA_CERTIFICATE

public static final MAPIProperty ORIGINATING_MTA_CERTIFICATE

ORIGINATOR_AND_DL_EXPANSION_HISTORY

public static final MAPIProperty ORIGINATOR_AND_DL_EXPANSION_HISTORY

ORIGINATOR_CERTIFICATE

public static final MAPIProperty ORIGINATOR_CERTIFICATE

ORIGINATOR_DELIVERY_REPORT_REQUESTED

public static final MAPIProperty ORIGINATOR_DELIVERY_REPORT_REQUESTED

ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED

public static final MAPIProperty ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED

ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT

public static final MAPIProperty ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT

ORIGINATOR_RETURN_ADDRESS

public static final MAPIProperty ORIGINATOR_RETURN_ADDRESS

OTHER_ADDRESS_CITY

public static final MAPIProperty OTHER_ADDRESS_CITY

OTHER_ADDRESS_COUNTRY

public static final MAPIProperty OTHER_ADDRESS_COUNTRY

OTHER_ADDRESS_POST_OFFICE_BOX

public static final MAPIProperty OTHER_ADDRESS_POST_OFFICE_BOX

OTHER_ADDRESS_POSTAL_CODE

public static final MAPIProperty OTHER_ADDRESS_POSTAL_CODE

OTHER_ADDRESS_STATE_OR_PROVINCE

public static final MAPIProperty OTHER_ADDRESS_STATE_OR_PROVINCE

OTHER_ADDRESS_STREET

public static final MAPIProperty OTHER_ADDRESS_STREET

OTHER_TELEPHONE_NUMBER

public static final MAPIProperty OTHER_TELEPHONE_NUMBER

OWN_STORE_ENTRY_ID

public static final MAPIProperty OWN_STORE_ENTRY_ID

OWNER_APPT_ID

public static final MAPIProperty OWNER_APPT_ID

PAGER_TELEPHONE_NUMBER

public static final MAPIProperty PAGER_TELEPHONE_NUMBER

PARENT_DISPLAY

public static final MAPIProperty PARENT_DISPLAY

PARENT_ENTRY_ID

public static final MAPIProperty PARENT_ENTRY_ID

PARENT_KEY

public static final MAPIProperty PARENT_KEY

PERSONAL_HOME_PAGE

public static final MAPIProperty PERSONAL_HOME_PAGE

PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY

public static final MAPIProperty PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY

PHYSICAL_DELIVERY_MODE

public static final MAPIProperty PHYSICAL_DELIVERY_MODE

PHYSICAL_DELIVERY_REPORT_REQUEST

public static final MAPIProperty PHYSICAL_DELIVERY_REPORT_REQUEST

PHYSICAL_FORWARDING_ADDRESS

public static final MAPIProperty PHYSICAL_FORWARDING_ADDRESS

PHYSICAL_FORWARDING_ADDRESS_REQUESTED

public static final MAPIProperty PHYSICAL_FORWARDING_ADDRESS_REQUESTED

PHYSICAL_FORWARDING_PROHIBITED

public static final MAPIProperty PHYSICAL_FORWARDING_PROHIBITED

PHYSICAL_RENDITION_ATTRIBUTES

public static final MAPIProperty PHYSICAL_RENDITION_ATTRIBUTES

POST_FOLDER_ENTRIES

public static final MAPIProperty POST_FOLDER_ENTRIES

POST_FOLDER_NAMES

public static final MAPIProperty POST_FOLDER_NAMES

POST_OFFICE_BOX

public static final MAPIProperty POST_OFFICE_BOX

POST_REPLY_DENIED

public static final MAPIProperty POST_REPLY_DENIED

POST_REPLY_FOLDER_ENTRIES

public static final MAPIProperty POST_REPLY_FOLDER_ENTRIES

POST_REPLY_FOLDER_NAMES

public static final MAPIProperty POST_REPLY_FOLDER_NAMES

POSTAL_ADDRESS

public static final MAPIProperty POSTAL_ADDRESS

POSTAL_CODE

public static final MAPIProperty POSTAL_CODE

PREPROCESS

public static final MAPIProperty PREPROCESS

PRIMARY_CAPABILITY

public static final MAPIProperty PRIMARY_CAPABILITY

PRIMARY_FAX_NUMBER

public static final MAPIProperty PRIMARY_FAX_NUMBER

PRIMARY_TELEPHONE_NUMBER

public static final MAPIProperty PRIMARY_TELEPHONE_NUMBER

PRIORITY

public static final MAPIProperty PRIORITY

PROFESSION

public static final MAPIProperty PROFESSION

PROFILE_NAME

public static final MAPIProperty PROFILE_NAME

PROOF_OF_DELIVERY

public static final MAPIProperty PROOF_OF_DELIVERY

PROOF_OF_DELIVERY_REQUESTED

public static final MAPIProperty PROOF_OF_DELIVERY_REQUESTED

PROOF_OF_SUBMISSION

public static final MAPIProperty PROOF_OF_SUBMISSION

PROOF_OF_SUBMISSION_REQUESTED

public static final MAPIProperty PROOF_OF_SUBMISSION_REQUESTED

PROP_ID_SECURE_MAX

public static final MAPIProperty PROP_ID_SECURE_MAX

PROP_ID_SECURE_MIN

public static final MAPIProperty PROP_ID_SECURE_MIN

PROVIDER_DISPLAY

public static final MAPIProperty PROVIDER_DISPLAY

PROVIDER_DLL_NAME

public static final MAPIProperty PROVIDER_DLL_NAME

PROVIDER_ORDINAL

public static final MAPIProperty PROVIDER_ORDINAL

PROVIDER_SUBMIT_TIME

public static final MAPIProperty PROVIDER_SUBMIT_TIME

PROVIDER_UID

public static final MAPIProperty PROVIDER_UID

PUID

public static final MAPIProperty PUID

RADIO_TELEPHONE_NUMBER

public static final MAPIProperty RADIO_TELEPHONE_NUMBER

RCVD_REPRESENTING_ADDRTYPE

public static final MAPIProperty RCVD_REPRESENTING_ADDRTYPE

RCVD_REPRESENTING_EMAIL_ADDRESS

public static final MAPIProperty RCVD_REPRESENTING_EMAIL_ADDRESS

RCVD_REPRESENTING_ENTRY_ID

public static final MAPIProperty RCVD_REPRESENTING_ENTRY_ID

RCVD_REPRESENTING_NAME

public static final MAPIProperty RCVD_REPRESENTING_NAME

RCVD_REPRESENTING_SEARCH_KEY

public static final MAPIProperty RCVD_REPRESENTING_SEARCH_KEY

READ_RECEIPT_ENTRY_ID

public static final MAPIProperty READ_RECEIPT_ENTRY_ID

READ_RECEIPT_REQUESTED

public static final MAPIProperty READ_RECEIPT_REQUESTED

READ_RECEIPT_SEARCH_KEY

public static final MAPIProperty READ_RECEIPT_SEARCH_KEY

RECEIPT_TIME

public static final MAPIProperty RECEIPT_TIME

RECEIVE_FOLDER_SETTINGS

public static final MAPIProperty RECEIVE_FOLDER_SETTINGS

RECEIVED_BY_ADDRTYPE

public static final MAPIProperty RECEIVED_BY_ADDRTYPE

RECEIVED_BY_EMAIL_ADDRESS

public static final MAPIProperty RECEIVED_BY_EMAIL_ADDRESS

RECEIVED_BY_ENTRY_ID

public static final MAPIProperty RECEIVED_BY_ENTRY_ID

RECEIVED_BY_NAME

public static final MAPIProperty RECEIVED_BY_NAME

RECIPIENT_DISPLAY_NAME

public static final MAPIProperty RECIPIENT_DISPLAY_NAME

RECIPIENT_ENTRY_ID

public static final MAPIProperty RECIPIENT_ENTRY_ID

RECIPIENT_FLAGS

public static final MAPIProperty RECIPIENT_FLAGS

RECEIVED_BY_SEARCH_KEY

public static final MAPIProperty RECEIVED_BY_SEARCH_KEY

RECIPIENT_CERTIFICATE

public static final MAPIProperty RECIPIENT_CERTIFICATE

RECIPIENT_NUMBER_FOR_ADVICE

public static final MAPIProperty RECIPIENT_NUMBER_FOR_ADVICE

RECIPIENT_REASSIGNMENT_PROHIBITED

public static final MAPIProperty RECIPIENT_REASSIGNMENT_PROHIBITED

RECIPIENT_STATUS

public static final MAPIProperty RECIPIENT_STATUS

RECIPIENT_TYPE

public static final MAPIProperty RECIPIENT_TYPE

RECORD_KEY

public static final MAPIProperty RECORD_KEY

REDIRECTION_HISTORY

public static final MAPIProperty REDIRECTION_HISTORY

REFERRED_BY_NAME

public static final MAPIProperty REFERRED_BY_NAME

REGISTERED_MAIL_TYPE

public static final MAPIProperty REGISTERED_MAIL_TYPE

RELATED_IPMS

public static final MAPIProperty RELATED_IPMS

REMOTE_PROGRESS

public static final MAPIProperty REMOTE_PROGRESS

REMOTE_PROGRESS_TEXT

public static final MAPIProperty REMOTE_PROGRESS_TEXT

REMOTE_VALIDATE_OK

public static final MAPIProperty REMOTE_VALIDATE_OK

RENDERING_POSITION

public static final MAPIProperty RENDERING_POSITION

REPLY_RECIPIENT_ENTRIES

public static final MAPIProperty REPLY_RECIPIENT_ENTRIES

REPLY_RECIPIENT_NAMES

public static final MAPIProperty REPLY_RECIPIENT_NAMES

REPLY_REQUESTED

public static final MAPIProperty REPLY_REQUESTED

REPLY_TIME

public static final MAPIProperty REPLY_TIME

REPORT_ENTRY_ID

public static final MAPIProperty REPORT_ENTRY_ID

REPORT_NAME

public static final MAPIProperty REPORT_NAME

REPORT_SEARCH_KEY

public static final MAPIProperty REPORT_SEARCH_KEY

REPORT_TAG

public static final MAPIProperty REPORT_TAG

REPORT_TEXT

public static final MAPIProperty REPORT_TEXT

REPORT_TIME

public static final MAPIProperty REPORT_TIME

REPORTING_DL_NAME

public static final MAPIProperty REPORTING_DL_NAME

REPORTING_MTA_CERTIFICATE

public static final MAPIProperty REPORTING_MTA_CERTIFICATE

REQUESTED_DELIVERY_METHOD

public static final MAPIProperty REQUESTED_DELIVERY_METHOD

RESOURCE_FLAGS

public static final MAPIProperty RESOURCE_FLAGS

RESOURCE_METHODS

public static final MAPIProperty RESOURCE_METHODS

RESOURCE_PATH

public static final MAPIProperty RESOURCE_PATH

RESOURCE_TYPE

public static final MAPIProperty RESOURCE_TYPE

RESPONSE_REQUESTED

public static final MAPIProperty RESPONSE_REQUESTED

RESPONSIBILITY

public static final MAPIProperty RESPONSIBILITY

RETURNED_IPM

public static final MAPIProperty RETURNED_IPM

ROW_TYPE

public static final MAPIProperty ROW_TYPE

ROWID

public static final MAPIProperty ROWID

RTF_COMPRESSED

public static final MAPIProperty RTF_COMPRESSED

RTF_IN_SYNC

public static final MAPIProperty RTF_IN_SYNC

RTF_SYNC_BODY_COUNT

public static final MAPIProperty RTF_SYNC_BODY_COUNT

RTF_SYNC_BODY_CRC

public static final MAPIProperty RTF_SYNC_BODY_CRC

RTF_SYNC_BODY_TAG

public static final MAPIProperty RTF_SYNC_BODY_TAG

RTF_SYNC_PREFIX_COUNT

public static final MAPIProperty RTF_SYNC_PREFIX_COUNT

RTF_SYNC_TRAILING_COUNT

public static final MAPIProperty RTF_SYNC_TRAILING_COUNT

SEARCH

public static final MAPIProperty SEARCH

SEARCH_KEY

public static final MAPIProperty SEARCH_KEY

SECURITY

public static final MAPIProperty SECURITY

SELECTABLE

public static final MAPIProperty SELECTABLE

SEND_INTERNET_ENCODING

public static final MAPIProperty SEND_INTERNET_ENCODING

SEND_RECALL_REPORT

public static final MAPIProperty SEND_RECALL_REPORT

SEND_RICH_INFO

public static final MAPIProperty SEND_RICH_INFO

SENDER_ADDRTYPE

public static final MAPIProperty SENDER_ADDRTYPE

SENDER_EMAIL_ADDRESS

public static final MAPIProperty SENDER_EMAIL_ADDRESS

SENDER_ENTRY_ID

public static final MAPIProperty SENDER_ENTRY_ID

SENDER_NAME

public static final MAPIProperty SENDER_NAME

SENDER_SEARCH_KEY

public static final MAPIProperty SENDER_SEARCH_KEY

SENSITIVITY

public static final MAPIProperty SENSITIVITY

SENT_REPRESENTING_ADDRTYPE

public static final MAPIProperty SENT_REPRESENTING_ADDRTYPE

SENT_REPRESENTING_EMAIL_ADDRESS

public static final MAPIProperty SENT_REPRESENTING_EMAIL_ADDRESS

SENT_REPRESENTING_ENTRY_ID

public static final MAPIProperty SENT_REPRESENTING_ENTRY_ID

SENT_REPRESENTING_NAME

public static final MAPIProperty SENT_REPRESENTING_NAME

SENT_REPRESENTING_SEARCH_KEY

public static final MAPIProperty SENT_REPRESENTING_SEARCH_KEY

SENTMAIL_ENTRY_ID

public static final MAPIProperty SENTMAIL_ENTRY_ID

SERVICE_DELETE_FILES

public static final MAPIProperty SERVICE_DELETE_FILES

SERVICE_DLL_NAME

public static final MAPIProperty SERVICE_DLL_NAME

SERVICE_ENTRY_NAME

public static final MAPIProperty SERVICE_ENTRY_NAME

SERVICE_EXTRA_UIDS

public static final MAPIProperty SERVICE_EXTRA_UIDS

SERVICE_NAME

public static final MAPIProperty SERVICE_NAME

SERVICE_SUPPORT_FILES

public static final MAPIProperty SERVICE_SUPPORT_FILES

SERVICE_UID

public static final MAPIProperty SERVICE_UID

SERVICES

public static final MAPIProperty SERVICES

SEVEN_BIT_DISPLAY_NAME

public static final MAPIProperty SEVEN_BIT_DISPLAY_NAME

SMTP_ADDRESS

public static final MAPIProperty SMTP_ADDRESS

SPOOLER_STATUS

public static final MAPIProperty SPOOLER_STATUS

SPOUSE_NAME

public static final MAPIProperty SPOUSE_NAME

START_DATE

public static final MAPIProperty START_DATE

STATE_OR_PROVINCE

public static final MAPIProperty STATE_OR_PROVINCE

STATUS

public static final MAPIProperty STATUS

STATUS_CODE

public static final MAPIProperty STATUS_CODE

STATUS_STRING

public static final MAPIProperty STATUS_STRING

STORE_ENTRY_ID

public static final MAPIProperty STORE_ENTRY_ID

STORE_PROVIDERS

public static final MAPIProperty STORE_PROVIDERS

STORE_RECORD_KEY

public static final MAPIProperty STORE_RECORD_KEY

STORE_STATE

public static final MAPIProperty STORE_STATE

STORE_SUPPORT_MASK

public static final MAPIProperty STORE_SUPPORT_MASK

STREET_ADDRESS

public static final MAPIProperty STREET_ADDRESS

SUBFOLDERS

public static final MAPIProperty SUBFOLDERS

SUBJECT

public static final MAPIProperty SUBJECT

SUBJECT_IPM

public static final MAPIProperty SUBJECT_IPM

SUBJECT_PREFIX

public static final MAPIProperty SUBJECT_PREFIX

SUBMIT_FLAGS

public static final MAPIProperty SUBMIT_FLAGS

SUPERSEDES

public static final MAPIProperty SUPERSEDES

SUPPLEMENTARY_INFO

public static final MAPIProperty SUPPLEMENTARY_INFO

SURNAME

public static final MAPIProperty SURNAME

TELEX_NUMBER

public static final MAPIProperty TELEX_NUMBER

TEMPLATEID

public static final MAPIProperty TEMPLATEID

TITLE

public static final MAPIProperty TITLE

TNEF_CORRELATION_KEY

public static final MAPIProperty TNEF_CORRELATION_KEY

TRANSMITABLE_DISPLAY_NAME

public static final MAPIProperty TRANSMITABLE_DISPLAY_NAME

TRANSPORT_KEY

public static final MAPIProperty TRANSPORT_KEY

TRANSPORT_MESSAGE_HEADERS

public static final MAPIProperty TRANSPORT_MESSAGE_HEADERS

TRANSPORT_PROVIDERS

public static final MAPIProperty TRANSPORT_PROVIDERS

TRANSPORT_STATUS

public static final MAPIProperty TRANSPORT_STATUS

TTYTDD_PHONE_NUMBER

public static final MAPIProperty TTYTDD_PHONE_NUMBER

TYPE_OF_MTS_USER

public static final MAPIProperty TYPE_OF_MTS_USER

USER_CERTIFICATE

public static final MAPIProperty USER_CERTIFICATE

USER_X509_CERTIFICATE

public static final MAPIProperty USER_X509_CERTIFICATE

VALID_FOLDER_MASK

public static final MAPIProperty VALID_FOLDER_MASK

VIEWS_ENTRY_ID

public static final MAPIProperty VIEWS_ENTRY_ID

WEDDING_ANNIVERSARY

public static final MAPIProperty WEDDING_ANNIVERSARY

X400_CONTENT_TYPE

public static final MAPIProperty X400_CONTENT_TYPE

X400_DEFERRED_DELIVERY_CANCEL

public static final MAPIProperty X400_DEFERRED_DELIVERY_CANCEL

XPOS

public static final MAPIProperty XPOS

YPOS

public static final MAPIProperty YPOS

UNKNOWN

public static final MAPIProperty UNKNOWN

id

public final int id

usualType

public final int usualType

name

public final java.lang.String name

mapiProperty

public final java.lang.String mapiProperty
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

get

public static MAPIProperty get(int id)

getAll

public static java.util.Collection<MAPIProperty> getAll()

createCustom

public static MAPIProperty createCustom(int id,
                                        int type,
                                        java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MessageSubmissionChunk

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class MessageSubmissionChunk

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.Chunk
        extended by  org.apache.poi.hsmf.datatypes.MessageSubmissionChunk

public class MessageSubmissionChunk
extends Chunk

A Chunk that holds the details given back by the server at submission time. This includes the date the message was given to the server, and an ID that's used if you want to cancel a message or similar

Field Summary
Fields inherited from class org.apache.poi.hsmf.datatypes.Chunk
chunkId, DEFAULT_NAME_PREFIX, namePrefix, type
Constructor Summary
MessageSubmissionChunk(int chunkId, int type)
Create a Byte Chunk, with the specified type.
MessageSubmissionChunk(java.lang.String namePrefix, int chunkId, int type)
Creates a Byte Chunk.
Method Summary
java.util.Calendar | getAcceptedAtTime()
java.lang.String | getSubmissionId()
void | readValue(java.io.InputStream value) Reads the value of this chunk using an InputStream
void | writeValue(java.io.OutputStream out) Writes the value of this chunk back out again.
Methods inherited from class org.apache.poi.hsmf.datatypes.Chunk
getChunkId, getEntryName, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageSubmissionChunk

public MessageSubmissionChunk(java.lang.String namePrefix,
                              int chunkId,
                              int type)
Creates a Byte Chunk.

MessageSubmissionChunk

public MessageSubmissionChunk(int chunkId,
                              int type)
Create a Byte Chunk, with the specified type.

Method Detail

readValue

public void readValue(java.io.InputStream value)
               throws java.io.IOException
Description copied from class: Chunk
Reads the value of this chunk using an InputStream

Specified by:
readValue in class Chunk
Throws:
java.io.IOException

writeValue

public void writeValue(java.io.OutputStream out)
                throws java.io.IOException
Description copied from class: Chunk
Writes the value of this chunk back out again.

Specified by:
writeValue in class Chunk
Throws:
java.io.IOException

getAcceptedAtTime

public java.util.Calendar getAcceptedAtTime()
Returns:
the date that the server accepted the message, as found from the message ID it generated.

getSubmissionId

public java.lang.String getSubmissionId()
Returns:
the full ID that the server generated when it accepted the message.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NameIdChunks

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class NameIdChunks

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.NameIdChunks
All Implemented Interfaces:
ChunkGroup
public final class NameIdChunks
extends java.lang.Object
implements ChunkGroup

Collection of convenience chunks for the NameID part of an outlook file

Field Summary
static java.lang.String PREFIX
Constructor Summary
NameIdChunks()
Method Summary
Chunk[] | getAll()
Chunk[] | getChunks() Returns the chunks that make up the group.
void | record(Chunk chunk) Called by the parser whenever a chunk is found.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PREFIX

public static final java.lang.String PREFIX
See Also:
Constant Field Values
Constructor Detail

NameIdChunks

public NameIdChunks()
Method Detail

getAll

public Chunk[] getAll()

getChunks

public Chunk[] getChunks()
Description copied from interface: ChunkGroup
Returns the chunks that make up the group. Should certainly contain all the interesting Chunks, but needn't always contain all of the Chunks.

Specified by:
getChunks in interface ChunkGroup

record

public void record(Chunk chunk)
Called by the parser whenever a chunk is found.

Specified by:
record in interface ChunkGroup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hsmf.datatypes
Interfaces
ChunkGroup
Classes
AttachmentChunks
AttachmentChunks.AttachmentChunksSorter
ByteChunk
Chunk
Chunks
DirectoryChunk
MAPIProperty
MessageSubmissionChunk
NameIdChunks
RecipientChunks
RecipientChunks.RecipientChunksSorter
StringChunk
Types


org.apache.poi.hsmf.datatypes

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hsmf.datatypes

Interface Summary
ChunkGroup A group of chunks, that are at the same point in the file structure.

Class Summary
AttachmentChunks | Collection of convenence chunks for standard parts of the MSG file attachment.
AttachmentChunks.AttachmentChunksSorter | Orders by the attachment number.
ByteChunk | A Chunk that holds binary data, normally unparsed.
Chunk |
Chunks | Collection of convenience chunks for standard parts of the MSG file.
DirectoryChunk | A Chunk that is just a placeholder in the MAPIMessage directory structure, which contains children.
MAPIProperty | Holds the list of MAPI Attributes, and allows lookup by friendly name, ID and MAPI Property Name.
MessageSubmissionChunk | A Chunk that holds the details given back by the server at submission time.
NameIdChunks | Collection of convenience chunks for the NameID part of an outlook file
RecipientChunks | Collection of convenience chunks for the Recip(ient) part of an outlook file.
RecipientChunks.RecipientChunksSorter | Orders by the recipient number.
StringChunk | A Chunk made up of a single string.
Types | The types list and details are available from http://msdn.microsoft.com/en-us/library/microsoft.exchange.data.contenttypes.tnef.tnefpropertytype%28v=EXCHG.140%29.aspx


org.apache.poi.hsmf.datatypes Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hsmf.datatypes

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hsmf.datatypes.AttachmentChunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter (implements java.util.Comparator<T>)
    • org.apache.poi.hsmf.datatypes.Chunk
      • org.apache.poi.hsmf.datatypes.ByteChunk
      • org.apache.poi.hsmf.datatypes.DirectoryChunk
      • org.apache.poi.hsmf.datatypes.MessageSubmissionChunk
      • org.apache.poi.hsmf.datatypes.StringChunk
    • org.apache.poi.hsmf.datatypes.Chunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.hsmf.datatypes.MAPIProperty
    • org.apache.poi.hsmf.datatypes.NameIdChunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.hsmf.datatypes.RecipientChunks (implements org.apache.poi.hsmf.datatypes.ChunkGroup)
    • org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter (implements java.util.Comparator<T>)
    • org.apache.poi.hsmf.datatypes.Types

Interface Hierarchy

  • org.apache.poi.hsmf.datatypes.ChunkGroup


Uses of Package org.apache.poi.hsmf.datatypes

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hsmf.datatypes

Packages that use org.apache.poi.hsmf.datatypes
org.apache.poi.hmef
org.apache.poi.hmef.attribute
org.apache.poi.hsmf
org.apache.poi.hsmf.datatypes
org.apache.poi.hsmf.parsers

Classes in org.apache.poi.hsmf.datatypes used by org.apache.poi.hmef
MAPIProperty
Holds the list of MAPI Attributes, and allows lookup by friendly name, ID and MAPI Property Name.

Classes in org.apache.poi.hsmf.datatypes used by org.apache.poi.hmef.attribute
MAPIProperty
Holds the list of MAPI Attributes, and allows lookup by friendly name, ID and MAPI Property Name.

Classes in org.apache.poi.hsmf.datatypes used by org.apache.poi.hsmf
AttachmentChunks
Collection of convenence chunks for standard parts of the MSG file attachment.
Chunks
Collection of convenience chunks for standard parts of the MSG file.
NameIdChunks
Collection of convenience chunks for the NameID part of an outlook file
RecipientChunks
Collection of convenience chunks for the Recip(ient) part of an outlook file.
StringChunk
A Chunk made up of a single string.

Classes in org.apache.poi.hsmf.datatypes used by org.apache.poi.hsmf.datatypes
AttachmentChunks
Collection of convenence chunks for standard parts of the MSG file attachment.
ByteChunk
A Chunk that holds binary data, normally unparsed.
Chunk
ChunkGroup
A group of chunks, that are at the same point in the file structure.
DirectoryChunk
A Chunk that is just a placeholder in the MAPIMessage directory structure, which contains children.
MAPIProperty
Holds the list of MAPI Attributes, and allows lookup by friendly name, ID and MAPI Property Name.
MessageSubmissionChunk
A Chunk that holds the details given back by the server at submission time.
RecipientChunks
Collection of convenience chunks for the Recip(ient) part of an outlook file.
StringChunk
A Chunk made up of a single string.

Classes in org.apache.poi.hsmf.datatypes used by org.apache.poi.hsmf.parsers
ChunkGroup
A group of chunks, that are at the same point in the file structure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RecipientChunks

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class RecipientChunks

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.RecipientChunks
All Implemented Interfaces:
ChunkGroup
public final class RecipientChunks
extends java.lang.Object
implements ChunkGroup

Collection of convenience chunks for the Recip(ient) part of an outlook file. If a message has multiple recipients, there will be several of these.

Nested Class Summary
static class RecipientChunks.RecipientChunksSorter
Orders by the recipient number.
Field Summary
static MAPIProperty | DELIVERY_TYPE
StringChunk | deliveryTypeChunk Normally EX or SMTP.
static java.lang.String | PREFIX
static MAPIProperty | RECIPIENT_DISPLAY_NAME
static MAPIProperty | RECIPIENT_EMAIL_ADDRESS
static MAPIProperty | RECIPIENT_NAME
static MAPIProperty | RECIPIENT_SEARCH
static MAPIProperty | RECIPIENT_SMTP_ADDRESS
StringChunk | recipientDisplayNameChunk The display name of the recipient.
StringChunk | recipientEmailChunk The email address of the recipient, which could be in SMTP or SEARCH format, but isn't always present...
StringChunk | recipientNameChunk The "name", which could be their name if an internal person, or their email address if an external person
int | recipientNumber Our 0 based position in the list of recipients
ByteChunk | recipientSearchChunk TODO
StringChunk | recipientSMTPChunk The smtp destination email address of the recipient, but isn't always present...
Constructor Summary
RecipientChunks(java.lang.String name)
Method Summary
Chunk[] | getAll()
Chunk[] | getChunks() Returns the chunks that make up the group.
java.lang.String | getRecipientEmailAddress() Tries to find their email address, in whichever chunk holds it given the delivery type.
java.lang.String | getRecipientName() Tries to find their name, in whichever chunk holds it.
void | record(Chunk chunk) Called by the parser whenever a chunk is found.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PREFIX

public static final java.lang.String PREFIX
See Also:
Constant Field Values

RECIPIENT_NAME

public static final MAPIProperty RECIPIENT_NAME

DELIVERY_TYPE

public static final MAPIProperty DELIVERY_TYPE

RECIPIENT_EMAIL_ADDRESS

public static final MAPIProperty RECIPIENT_EMAIL_ADDRESS

RECIPIENT_SEARCH

public static final MAPIProperty RECIPIENT_SEARCH

RECIPIENT_SMTP_ADDRESS

public static final MAPIProperty RECIPIENT_SMTP_ADDRESS

RECIPIENT_DISPLAY_NAME

public static final MAPIProperty RECIPIENT_DISPLAY_NAME

recipientNumber

public int recipientNumber
Our 0 based position in the list of recipients

recipientSearchChunk

public ByteChunk recipientSearchChunk
TODO

recipientNameChunk

public StringChunk recipientNameChunk
The "name", which could be their name if an internal person, or their email address if an external person

recipientEmailChunk

public StringChunk recipientEmailChunk
The email address of the recipient, which could be in SMTP or SEARCH format, but isn't always present...

recipientSMTPChunk

public StringChunk recipientSMTPChunk
The smtp destination email address of the recipient, but isn't always present...

deliveryTypeChunk

public StringChunk deliveryTypeChunk
Normally EX or SMTP. Will generally affect where the email address ends up.

recipientDisplayNameChunk

public StringChunk recipientDisplayNameChunk
The display name of the recipient. Normally seems to hold the same value as in recipientNameChunk

Constructor Detail

RecipientChunks

public RecipientChunks(java.lang.String name)
Method Detail

getRecipientName

public java.lang.String getRecipientName()
Tries to find their name, in whichever chunk holds it.

getRecipientEmailAddress

public java.lang.String getRecipientEmailAddress()
Tries to find their email address, in whichever chunk holds it given the delivery type.

getAll

public Chunk[] getAll()

getChunks

public Chunk[] getChunks()
Description copied from interface: ChunkGroup
Returns the chunks that make up the group. Should certainly contain all the interesting Chunks, but needn't always contain all of the Chunks.

Specified by:
getChunks in interface ChunkGroup

record

public void record(Chunk chunk)
Called by the parser whenever a chunk is found.

Specified by:
record in interface ChunkGroup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecipientChunks.RecipientChunksSorter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class RecipientChunks.RecipientChunksSorter

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter
All Implemented Interfaces:
java.util.Comparator<RecipientChunks>
Enclosing class:
RecipientChunks
public static class RecipientChunks.RecipientChunksSorter
extends java.lang.Object
implements java.util.Comparator<RecipientChunks>

Orders by the recipient number.

Constructor Summary
RecipientChunks.RecipientChunksSorter()
Method Summary
 int compare(RecipientChunks a, RecipientChunks b)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

RecipientChunks.RecipientChunksSorter

public RecipientChunks.RecipientChunksSorter()
Method Detail

compare

public int compare(RecipientChunks a,
                   RecipientChunks b)
Specified by:
compare in interface java.util.Comparator<RecipientChunks>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringChunk

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class StringChunk

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.Chunk
        extended by  org.apache.poi.hsmf.datatypes.StringChunk

public class StringChunk
extends Chunk

A Chunk made up of a single string.

Field Summary
Fields inherited from class org.apache.poi.hsmf.datatypes.Chunk
chunkId, DEFAULT_NAME_PREFIX, namePrefix, type
Constructor Summary
StringChunk(int chunkId, int type)
Create a String Chunk, with the specified type.
StringChunk(java.lang.String namePrefix, int chunkId, int type)
Creates a String Chunk.
Method Summary
java.lang.String | get7BitEncoding() Returns the Encoding that will be used to decode any "7 bit" (non unicode) data.
byte[] | getRawValue()
java.lang.String | getValue() Returns the Text value of the chunk
protected static java.lang.String | parseAs7BitData(byte[] data) Parses as non-unicode, supposedly 7 bit CP1252 data and returns the string that that yields.
protected static java.lang.String | parseAs7BitData(byte[] data, java.lang.String encoding) Parses as non-unicode, supposedly 7 bit data and returns the string that that yields.
void | readValue(java.io.InputStream value) Reads the value of this chunk using an InputStream
void | set7BitEncoding(java.lang.String encoding) Sets the Encoding that will be used to decode any "7 bit" (non unicode) data.
void | setValue(java.lang.String str)
java.lang.String | toString()
void | writeValue(java.io.OutputStream out) Writes the value of this chunk back out again.
Methods inherited from class org.apache.poi.hsmf.datatypes.Chunk
getChunkId, getEntryName, getType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StringChunk

public StringChunk(java.lang.String namePrefix,
                   int chunkId,
                   int type)
Creates a String Chunk.

StringChunk

public StringChunk(int chunkId,
                   int type)
Create a String Chunk, with the specified type.

Method Detail

get7BitEncoding

public java.lang.String get7BitEncoding()
Returns the Encoding that will be used to decode any "7 bit" (non unicode) data. Most files default to CP1252

set7BitEncoding

public void set7BitEncoding(java.lang.String encoding)
Sets the Encoding that will be used to decode any "7 bit" (non unicode) data. This doesn't appear to be stored anywhere specific in the file, so you may need to guess by looking at headers etc

readValue

public void readValue(java.io.InputStream value)
               throws java.io.IOException
Description copied from class: Chunk
Reads the value of this chunk using an InputStream

Specified by:
readValue in class Chunk
Throws:
java.io.IOException

writeValue

public void writeValue(java.io.OutputStream out)
                throws java.io.IOException
Description copied from class: Chunk
Writes the value of this chunk back out again.

Specified by:
writeValue in class Chunk
Throws:
java.io.IOException

getValue

public java.lang.String getValue()
Returns the Text value of the chunk

getRawValue

public byte[] getRawValue()

setValue

public void setValue(java.lang.String str)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

parseAs7BitData

protected static java.lang.String parseAs7BitData(byte[] data)
Parses as non-unicode, supposedly 7 bit CP1252 data and returns the string that that yields.

parseAs7BitData

protected static java.lang.String parseAs7BitData(byte[] data,
                                                  java.lang.String encoding)
Parses as non-unicode, supposedly 7 bit data and returns the string that that yields.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Types

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.datatypes
Class Types

java.lang.Object
    extended by  org.apache.poi.hsmf.datatypes.Types

public final class Types
extends java.lang.Object

The types list and details are available from http://msdn.microsoft.com/en-us/library/microsoft.exchange.data.contenttypes.tnef.tnefpropertytype%28v=EXCHG.140%29.aspx

Field Summary
static int | APP_TIME AppTime - application time value
static int | ASCII_STRING An 8-bit string, probably in CP1252, but don't quote us...
static int | BINARY Binary - counted byte array
static int | BOOLEAN Boolean - 16-bit Boolean value.
static int | CLS_ID ClassId - OLE GUID
static int | CURRENCY Currency - signed 64-bit integer that represents a base ten decimal with four digits to the right of the decimal point
static int | DIRECTORY Object/Directory - embedded object in a property
static int | DOUBLE Double - floating point double
static int | ERROR Error - 32-bit error value
static int | FLOAT R4 - 4-byte floating point value
static int | LONG Long - signed 32-bit value
static int | LONG_LONG I8 - 8-byte signed integer
static int | MULTIVALUED_FLAG MultiValued - Value part contains multiple values
static int | NULL Null - NULL property value
static int | SHORT I2 - signed 16-bit value
static int | TIME SysTime - FILETIME 64-bit integer specifying the number of 100ns periods since Jan 1, 1601
static int | UNICODE_STRING A string, from Outlook 3.0 onwards.
static int | UNSPECIFIED Unspecified
Constructor Summary
Types()
Method Summary
static java.lang.String | asFileEnding(int type)
static java.lang.String | asName(int type)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNSPECIFIED

public static final int UNSPECIFIED
Unspecified

See Also:
Constant Field Values

NULL

public static final int NULL
Null - NULL property value

See Also:
Constant Field Values

SHORT

public static final int SHORT
I2 - signed 16-bit value

See Also:
Constant Field Values

LONG

public static final int LONG
Long - signed 32-bit value

See Also:
Constant Field Values

FLOAT

public static final int FLOAT
R4 - 4-byte floating point value

See Also:
Constant Field Values

DOUBLE

public static final int DOUBLE
Double - floating point double

See Also:
Constant Field Values

CURRENCY

public static final int CURRENCY
Currency - signed 64-bit integer that represents a base ten decimal with four digits to the right of the decimal point

See Also:
Constant Field Values

APP_TIME

public static final int APP_TIME
AppTime - application time value

See Also:
Constant Field Values

ERROR

public static final int ERROR
Error - 32-bit error value

See Also:
Constant Field Values

BOOLEAN

public static final int BOOLEAN
Boolean - 16-bit Boolean value. '0' is false. Non-zero is true

See Also:
Constant Field Values

DIRECTORY

public static final int DIRECTORY
Object/Directory - embedded object in a property

See Also:
Constant Field Values

LONG_LONG

public static final int LONG_LONG
I8 - 8-byte signed integer

See Also:
Constant Field Values

TIME

public static final int TIME
SysTime - FILETIME 64-bit integer specifying the number of 100ns periods since Jan 1, 1601

See Also:
Constant Field Values

CLS_ID

public static final int CLS_ID
ClassId - OLE GUID

See Also:
Constant Field Values

BINARY

public static final int BINARY
Binary - counted byte array

See Also:
Constant Field Values

ASCII_STRING

public static final int ASCII_STRING
An 8-bit string, probably in CP1252, but don't quote us... Normally used for everything before Outlook 3.0, and some fields in Outlook 3.0.

See Also:
Constant Field Values

UNICODE_STRING

public static final int UNICODE_STRING
A string, from Outlook 3.0 onwards. Normally unicode

See Also:
Constant Field Values

MULTIVALUED_FLAG

public static final int MULTIVALUED_FLAG
MultiValued - Value part contains multiple values

See Also:
Constant Field Values
Constructor Detail

Types

public Types()
Method Detail

asFileEnding

public static java.lang.String asFileEnding(int type)

asName

public static java.lang.String asName(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter

No usage of org.apache.poi.hsmf.datatypes.AttachmentChunks.AttachmentChunksSorter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.AttachmentChunks

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.AttachmentChunks

Packages that use AttachmentChunks
org.apache.poi.hsmf
org.apache.poi.hsmf.datatypes

Uses of AttachmentChunks in org.apache.poi.hsmf

Methods in org.apache.poi.hsmf that return AttachmentChunks
 AttachmentChunks[] MAPIMessage.getAttachmentFiles()
Gets the message attachments.

Uses of AttachmentChunks in org.apache.poi.hsmf.datatypes

Methods in org.apache.poi.hsmf.datatypes with parameters of type AttachmentChunks
 int AttachmentChunks.AttachmentChunksSorter.compare(AttachmentChunks a, AttachmentChunks b)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.ByteChunk

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.ByteChunk

Packages that use ByteChunk
org.apache.poi.hsmf.datatypes

Uses of ByteChunk in org.apache.poi.hsmf.datatypes

Fields in org.apache.poi.hsmf.datatypes declared as ByteChunk
ByteChunk | AttachmentChunks.attachData
ByteChunk | AttachmentChunks.attachRenderingWMF This is in WMF Format.
ByteChunk | Chunks.htmlBodyChunkBinary
ByteChunk | RecipientChunks.recipientSearchChunk TODO
ByteChunk | Chunks.rtfBodyChunk BODY Rtf Chunk, for Rtf (Rich) messages

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.Chunk

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.Chunk

Packages that use Chunk
org.apache.poi.hsmf.datatypes

Uses of Chunk in org.apache.poi.hsmf.datatypes

Subclasses of Chunk in org.apache.poi.hsmf.datatypes
class | ByteChunk A Chunk that holds binary data, normally unparsed.
class | DirectoryChunk A Chunk that is just a placeholder in the MAPIMessage directory structure, which contains children.
class | MessageSubmissionChunk A Chunk that holds the details given back by the server at submission time.
class | StringChunk A Chunk made up of a single string.

Methods in org.apache.poi.hsmf.datatypes that return Chunk
Chunk[] | RecipientChunks.getAll()
Chunk[] | NameIdChunks.getAll()
Chunk[] | Chunks.getAll()
Chunk[] | AttachmentChunks.getAll()
Chunk[] | RecipientChunks.getChunks()
Chunk[] | NameIdChunks.getChunks()
Chunk[] | Chunks.getChunks()
Chunk[] | ChunkGroup.getChunks() Returns the chunks that make up the group.
Chunk[] | AttachmentChunks.getChunks()

Methods in org.apache.poi.hsmf.datatypes with parameters of type Chunk
void | RecipientChunks.record(Chunk chunk) Called by the parser whenever a chunk is found.
void | NameIdChunks.record(Chunk chunk) Called by the parser whenever a chunk is found.
void | Chunks.record(Chunk chunk) Called by the parser whenever a chunk is found.
void | ChunkGroup.record(Chunk chunk) Called by the parser whenever a chunk is found.
void | AttachmentChunks.record(Chunk chunk) Called by the parser whenever a chunk is found.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hsmf.datatypes.ChunkGroup

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hsmf.datatypes.ChunkGroup

Packages that use ChunkGroup
org.apache.poi.hsmf.datatypes
org.apache.poi.hsmf.parsers

Uses of ChunkGroup in org.apache.poi.hsmf.datatypes

Classes in org.apache.poi.hsmf.datatypes that implement ChunkGroup
class | AttachmentChunks Collection of convenence chunks for standard parts of the MSG file attachment.
class | Chunks Collection of convenience chunks for standard parts of the MSG file.
class | NameIdChunks Collection of convenience chunks for the NameID part of an outlook file
class | RecipientChunks Collection of convenience chunks for the Recip(ient) part of an outlook file.

Uses of ChunkGroup in org.apache.poi.hsmf.parsers

Methods in org.apache.poi.hsmf.parsers that return ChunkGroup
static ChunkGroup[] | POIFSChunkParser.parse(DirectoryNode node)
static ChunkGroup[] | POIFSChunkParser.parse(POIFSFileSystem fs)

Methods in org.apache.poi.hsmf.parsers with parameters of type ChunkGroup
protected static void | POIFSChunkParser.process(Entry entry, ChunkGroup grouping) Creates a chunk, and gives it to its parent group
protected static void | POIFSChunkParser.processChunks(DirectoryNode node, ChunkGroup grouping) Creates all the chunks for a given Directory, but doesn't recurse or descend

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.Chunks

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.Chunks

Packages that use Chunks
org.apache.poi.hsmf

Uses of Chunks in org.apache.poi.hsmf

Methods in org.apache.poi.hsmf that return Chunks
 Chunks MAPIMessage.getMainChunks()
Gets the main, core details chunks

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.DirectoryChunk

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.DirectoryChunk

Packages that use DirectoryChunk
org.apache.poi.hsmf.datatypes

Uses of DirectoryChunk in org.apache.poi.hsmf.datatypes

Fields in org.apache.poi.hsmf.datatypes declared as DirectoryChunk
 DirectoryChunk AttachmentChunks.attachmentDirectory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.MAPIProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.MAPIProperty

Packages that use MAPIProperty
org.apache.poi.hmef
org.apache.poi.hmef.attribute
org.apache.poi.hsmf.datatypes

Uses of MAPIProperty in org.apache.poi.hmef

Methods in org.apache.poi.hmef with parameters of type MAPIProperty
MAPIAttribute | Attachment.getMAPIAttribute(MAPIProperty id) Return the attachment MAPI Attribute with the given ID, or null if there isn't one.
MAPIAttribute | HMEFMessage.getMessageMAPIAttribute(MAPIProperty id) Return the message MAPI Attribute with the given ID, or null if there isn't one.

Uses of MAPIProperty in org.apache.poi.hmef.attribute

Methods in org.apache.poi.hmef.attribute that return MAPIProperty
 MAPIProperty MAPIAttribute.getProperty()

Constructors in org.apache.poi.hmef.attribute with parameters of type MAPIProperty
MAPIAttribute(MAPIProperty property, int type, byte[] data)
Constructs a single new attribute from the contents of the stream
MAPIDateAttribute(MAPIProperty property, int type, byte[] data)
Constructs a single new date attribute from the id, type, and the contents of the stream
MAPIRtfAttribute(MAPIProperty property, int type, byte[] data)
MAPIStringAttribute(MAPIProperty property, int type, byte[] data)

Uses of MAPIProperty in org.apache.poi.hsmf.datatypes

Fields in org.apache.poi.hsmf.datatypes declared as MAPIProperty
static MAPIProperty | MAPIProperty.AB_DEFAULT_DIR
static MAPIProperty | MAPIProperty.AB_DEFAULT_PAB
static MAPIProperty | MAPIProperty.AB_PROVIDER_ID
static MAPIProperty | MAPIProperty.AB_PROVIDERS
static MAPIProperty | MAPIProperty.AB_SEARCH_PATH
static MAPIProperty | MAPIProperty.AB_SEARCH_PATH_UPDATE
static MAPIProperty | MAPIProperty.ACCESS
static MAPIProperty | MAPIProperty.ACCESS_LEVEL
static MAPIProperty | MAPIProperty.ACCOUNT
static MAPIProperty | MAPIProperty.ADDRTYPE
static MAPIProperty | MAPIProperty.ALTERNATE_RECIPIENT
static MAPIProperty | MAPIProperty.ALTERNATE_RECIPIENT_ALLOWED
static MAPIProperty | MAPIProperty.ANR
static MAPIProperty | MAPIProperty.ASSISTANT
static MAPIProperty | MAPIProperty.ASSISTANT_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.ASSOC_CONTENT_COUNT
static MAPIProperty | MAPIProperty.ATTACH_ADDITIONAL_INFO
static MAPIProperty | MAPIProperty.ATTACH_CONTENT_BASE
static MAPIProperty | MAPIProperty.ATTACH_CONTENT_ID
static MAPIProperty | MAPIProperty.ATTACH_CONTENT_LOCATION
static MAPIProperty | MAPIProperty.ATTACH_DATA
static MAPIProperty | MAPIProperty.ATTACH_DISPOSITION
static MAPIProperty | MAPIProperty.ATTACH_ENCODING
static MAPIProperty | MAPIProperty.ATTACH_EXTENSION
static MAPIProperty | MAPIProperty.ATTACH_FILENAME
static MAPIProperty | MAPIProperty.ATTACH_FLAGS
static MAPIProperty | MAPIProperty.ATTACH_LONG_FILENAME
static MAPIProperty | MAPIProperty.ATTACH_LONG_PATHNAME
static MAPIProperty | MAPIProperty.ATTACH_METHOD
static MAPIProperty | MAPIProperty.ATTACH_MIME_SEQUENCE
static MAPIProperty | MAPIProperty.ATTACH_MIME_TAG
static MAPIProperty | MAPIProperty.ATTACH_NETSCAPE_MAC_INFO
static MAPIProperty | MAPIProperty.ATTACH_NUM
static MAPIProperty | MAPIProperty.ATTACH_PATHNAME
static MAPIProperty | MAPIProperty.ATTACH_RENDERING
static MAPIProperty | MAPIProperty.ATTACH_SIZE
static MAPIProperty | MAPIProperty.ATTACH_TAG
static MAPIProperty | MAPIProperty.ATTACH_TRANSPORT_NAME
static MAPIProperty | MAPIProperty.ATTACHMENT_X400_PARAMETERS
static MAPIProperty | MAPIProperty.AUTHORIZING_USERS
static MAPIProperty | MAPIProperty.AUTO_FORWARD_COMMENT
static MAPIProperty | MAPIProperty.AUTO_FORWARDED
static MAPIProperty | MAPIProperty.AUTO_RESPONSE_SUPPRESS
static MAPIProperty | MAPIProperty.BIRTHDAY
static MAPIProperty | MAPIProperty.BODY
static MAPIProperty | MAPIProperty.BODY_CONTENT_ID
static MAPIProperty | MAPIProperty.BODY_CONTENT_LOCATION
static MAPIProperty | MAPIProperty.BODY_CRC
static MAPIProperty | MAPIProperty.BODY_HTML
static MAPIProperty | MAPIProperty.BUSINESS_FAX_NUMBER
static MAPIProperty | MAPIProperty.BUSINESS_HOME_PAGE
static MAPIProperty | MAPIProperty.CALLBACK_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.CAR_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.CHILDRENS_NAMES
static MAPIProperty | MAPIProperty.CLIENT_SUBMIT_TIME
static MAPIProperty | MAPIProperty.COMMENT
static MAPIProperty | MAPIProperty.COMMON_VIEWS_ENTRY_ID
static MAPIProperty | MAPIProperty.COMPANY_MAIN_PHONE_NUMBER
static MAPIProperty | MAPIProperty.COMPANY_NAME
static MAPIProperty | MAPIProperty.COMPUTER_NETWORK_NAME
static MAPIProperty | MAPIProperty.CONTACT_ADDRTYPES
static MAPIProperty | MAPIProperty.CONTACT_DEFAULT_ADDRESS_INDEX
static MAPIProperty | MAPIProperty.CONTACT_EMAIL_ADDRESSES
static MAPIProperty | MAPIProperty.CONTACT_ENTRY_IDS
static MAPIProperty | MAPIProperty.CONTACT_VERSION
static MAPIProperty | MAPIProperty.CONTAINER_CLASS
static MAPIProperty | MAPIProperty.CONTAINER_CONTENTS
static MAPIProperty | MAPIProperty.CONTAINER_FLAGS
static MAPIProperty | MAPIProperty.CONTAINER_HIERARCHY
static MAPIProperty | MAPIProperty.CONTAINER_MODIFY_VERSION
static MAPIProperty | MAPIProperty.CONTENT_CONFIDENTIALITY_ALGORITHM_ID
static MAPIProperty | MAPIProperty.CONTENT_CORRELATOR
static MAPIProperty | MAPIProperty.CONTENT_COUNT
static MAPIProperty | MAPIProperty.CONTENT_IDENTIFIER
static MAPIProperty | MAPIProperty.CONTENT_INTEGRITY_CHECK
static MAPIProperty | MAPIProperty.CONTENT_LENGTH
static MAPIProperty | MAPIProperty.CONTENT_RETURN_REQUESTED
static MAPIProperty | MAPIProperty.CONTENT_UNREAD
static MAPIProperty | MAPIProperty.CONTENTS_SORT_ORDER
static MAPIProperty | MAPIProperty.CONTROL_FLAGS
static MAPIProperty | MAPIProperty.CONTROL_ID
static MAPIProperty | MAPIProperty.CONTROL_STRUCTURE
static MAPIProperty | MAPIProperty.CONTROL_TYPE
static MAPIProperty | MAPIProperty.CONVERSATION_INDEX
static MAPIProperty | MAPIProperty.CONVERSATION_KEY
static MAPIProperty | MAPIProperty.CONVERSATION_TOPIC
static MAPIProperty | MAPIProperty.CONVERSION_EITS
static MAPIProperty | MAPIProperty.CONVERSION_PROHIBITED
static MAPIProperty | MAPIProperty.CONVERSION_WITH_LOSS_PROHIBITED
static MAPIProperty | MAPIProperty.CONVERTED_EITS
static MAPIProperty | MAPIProperty.CORRELATE
static MAPIProperty | MAPIProperty.CORRELATE_MTSID
static MAPIProperty | MAPIProperty.COUNTRY
static MAPIProperty | MAPIProperty.CREATE_TEMPLATES
static MAPIProperty | MAPIProperty.CREATION_TIME
static MAPIProperty | MAPIProperty.CREATION_VERSION
static MAPIProperty | MAPIProperty.CURRENT_VERSION
static MAPIProperty | MAPIProperty.CUSTOMER_ID
static MAPIProperty | MAPIProperty.DEF_CREATE_DL
static MAPIProperty | MAPIProperty.DEF_CREATE_MAILUSER
static MAPIProperty | MAPIProperty.DEFAULT_PROFILE
static MAPIProperty | MAPIProperty.DEFAULT_STORE
static MAPIProperty | MAPIProperty.DEFAULT_VIEW_ENTRY_ID
static MAPIProperty | MAPIProperty.DEFERRED_DELIVERY_TIME
static MAPIProperty | MAPIProperty.DELEGATION
static MAPIProperty | MAPIProperty.DELETE_AFTER_SUBMIT
static MAPIProperty | MAPIProperty.DELIVER_TIME
static MAPIProperty | MAPIProperty.DELIVERY_POINT
static MAPIProperty | RecipientChunks.DELIVERY_TYPE
static MAPIProperty | MAPIProperty.DELTAX
static MAPIProperty | MAPIProperty.DELTAY
static MAPIProperty | MAPIProperty.DEPARTMENT_NAME
static MAPIProperty | MAPIProperty.DEPTH
static MAPIProperty | MAPIProperty.DETAILS_TABLE
static MAPIProperty | MAPIProperty.DISC_VAL
static MAPIProperty | MAPIProperty.DISCARD_REASON
static MAPIProperty | MAPIProperty.DISCLOSE_RECIPIENTS
static MAPIProperty | MAPIProperty.DISCLOSURE_OF_RECIPIENTS
static MAPIProperty | MAPIProperty.DISCRETE_VALUES
static MAPIProperty | MAPIProperty.DISPLAY_BCC
static MAPIProperty | MAPIProperty.DISPLAY_CC
static MAPIProperty | MAPIProperty.DISPLAY_NAME
static MAPIProperty | MAPIProperty.DISPLAY_NAME_PREFIX
static MAPIProperty | MAPIProperty.DISPLAY_TO
static MAPIProperty | MAPIProperty.DISPLAY_TYPE
static MAPIProperty | MAPIProperty.DL_EXPANSION_HISTORY
static MAPIProperty | MAPIProperty.DL_EXPANSION_PROHIBITED
static MAPIProperty | MAPIProperty.EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.END_DATE
static MAPIProperty | MAPIProperty.ENTRY_ID
static MAPIProperty | MAPIProperty.EXPAND_BEGIN_TIME
static MAPIProperty | MAPIProperty.EXPAND_END_TIME
static MAPIProperty | MAPIProperty.EXPANDED_BEGIN_TIME
static MAPIProperty | MAPIProperty.EXPANDED_END_TIME
static MAPIProperty | MAPIProperty.EXPIRY_TIME
static MAPIProperty | MAPIProperty.EXPLICIT_CONVERSION
static MAPIProperty | MAPIProperty.FILTERING_HOOKS
static MAPIProperty | MAPIProperty.FINDER_ENTRY_ID
static MAPIProperty | MAPIProperty.FOLDER_ASSOCIATED_CONTENTS
static MAPIProperty | MAPIProperty.FOLDER_TYPE
static MAPIProperty | MAPIProperty.FORM_CATEGORY
static MAPIProperty | MAPIProperty.FORM_CATEGORY_SUB
static MAPIProperty | MAPIProperty.FORM_CLSID
static MAPIProperty | MAPIProperty.FORM_CONTACT_NAME
static MAPIProperty | MAPIProperty.FORM_DESIGNER_GUID
static MAPIProperty | MAPIProperty.FORM_DESIGNER_NAME
static MAPIProperty | MAPIProperty.FORM_HIDDEN
static MAPIProperty | MAPIProperty.FORM_HOST_MAP
static MAPIProperty | MAPIProperty.FORM_MESSAGE_BEHAVIOR
static MAPIProperty | MAPIProperty.FORM_VERSION
static MAPIProperty | MAPIProperty.FTP_SITE
static MAPIProperty | MAPIProperty.GENDER
static MAPIProperty | MAPIProperty.GENERATION
static MAPIProperty | MAPIProperty.GIVEN_NAME
static MAPIProperty | MAPIProperty.GOVERNMENT_ID_NUMBER
static MAPIProperty | MAPIProperty.HASATTACH
static MAPIProperty | MAPIProperty.HEADER_FOLDER_ENTRY_ID
static MAPIProperty | MAPIProperty.HOBBIES
static MAPIProperty | MAPIProperty.HOME_ADDRESS_CITY
static MAPIProperty | MAPIProperty.HOME_ADDRESS_COUNTRY
static MAPIProperty | MAPIProperty.HOME_ADDRESS_POST_OFFICE_BOX
static MAPIProperty | MAPIProperty.HOME_ADDRESS_POSTAL_CODE
static MAPIProperty | MAPIProperty.HOME_ADDRESS_STATE_OR_PROVINCE
static MAPIProperty | MAPIProperty.HOME_ADDRESS_STREET
static MAPIProperty | MAPIProperty.HOME_FAX_NUMBER
static MAPIProperty | MAPIProperty.HOME_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.HOME2_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.ICON
static MAPIProperty | MAPIProperty.IDENTITY_DISPLAY
static MAPIProperty | MAPIProperty.IDENTITY_ENTRY_ID
static MAPIProperty | MAPIProperty.IDENTITY_SEARCH_KEY
static MAPIProperty | MAPIProperty.IMPLICIT_CONVERSION_PROHIBITED
static MAPIProperty | MAPIProperty.IMPORTANCE
static MAPIProperty | MAPIProperty.IN_REPLY_TO_ID
static MAPIProperty | MAPIProperty.INCOMPLETE_COPY
static MAPIProperty | MAPIProperty.INET_MAIL_OVERRIDE_CHARSET
static MAPIProperty | MAPIProperty.INET_MAIL_OVERRIDE_FORMAT
static MAPIProperty | MAPIProperty.INITIAL_DETAILS_PANE
static MAPIProperty | MAPIProperty.INITIALS
static MAPIProperty | MAPIProperty.INSTANCE_KEY
static MAPIProperty | MAPIProperty.INTERNET_APPROVED
static MAPIProperty | MAPIProperty.INTERNET_ARTICLE_NUMBER
static MAPIProperty | MAPIProperty.INTERNET_CONTROL
static MAPIProperty | MAPIProperty.INTERNET_CPID
static MAPIProperty | MAPIProperty.INTERNET_DISTRIBUTION
static MAPIProperty | MAPIProperty.INTERNET_FOLLOWUP_TO
static MAPIProperty | MAPIProperty.INTERNET_LINES
static MAPIProperty | MAPIProperty.INTERNET_MESSAGE_ID
static MAPIProperty | MAPIProperty.INTERNET_NEWSGROUPS
static MAPIProperty | MAPIProperty.INTERNET_NNTP_PATH
static MAPIProperty | MAPIProperty.INTERNET_ORGANIZATION
static MAPIProperty | MAPIProperty.INTERNET_PRECEDENCE
static MAPIProperty | MAPIProperty.INTERNET_REFERENCES
static MAPIProperty | MAPIProperty.IPM_ID
static MAPIProperty | MAPIProperty.IPM_OUTBOX_ENTRY_ID
static MAPIProperty | MAPIProperty.IPM_OUTBOX_SEARCH_KEY
static MAPIProperty | MAPIProperty.IPM_RETURN_REQUESTED
static MAPIProperty | MAPIProperty.IPM_SENTMAIL_ENTRY_ID
static MAPIProperty | MAPIProperty.IPM_SENTMAIL_SEARCH_KEY
static MAPIProperty | MAPIProperty.IPM_SUBTREE_ENTRY_ID
static MAPIProperty | MAPIProperty.IPM_SUBTREE_SEARCH_KEY
static MAPIProperty | MAPIProperty.IPM_WASTEBASKET_ENTRY_ID
static MAPIProperty | MAPIProperty.IPM_WASTEBASKET_SEARCH_KEY
static MAPIProperty | MAPIProperty.ISDN_NUMBER
static MAPIProperty | MAPIProperty.KEYWORD
static MAPIProperty | MAPIProperty.LANGUAGE
static MAPIProperty | MAPIProperty.LANGUAGES
static MAPIProperty | MAPIProperty.LAST_MODIFICATION_TIME
static MAPIProperty | MAPIProperty.LATEST_DELIVERY_TIME
static MAPIProperty | MAPIProperty.LIST_HELP
static MAPIProperty | MAPIProperty.LIST_SUBSCRIBE
static MAPIProperty | MAPIProperty.LIST_UNSUBSCRIBE
static MAPIProperty | MAPIProperty.LOCALITY
static MAPIProperty | MAPIProperty.LOCALLY_DELIVERED
static MAPIProperty | MAPIProperty.LOCATION
static MAPIProperty | MAPIProperty.LOCK_BRANCH_ID
static MAPIProperty | MAPIProperty.LOCK_DEPTH
static MAPIProperty | MAPIProperty.LOCK_ENLISTMENT_CONTEXT
static MAPIProperty | MAPIProperty.LOCK_EXPIRY_TIME
static MAPIProperty | MAPIProperty.LOCK_PERSISTENT
static MAPIProperty | MAPIProperty.LOCK_RESOURCE_DID
static MAPIProperty | MAPIProperty.LOCK_RESOURCE_FID
static MAPIProperty | MAPIProperty.LOCK_RESOURCE_MID
static MAPIProperty | MAPIProperty.LOCK_SCOPE
static MAPIProperty | MAPIProperty.LOCK_TIMEOUT
static MAPIProperty | MAPIProperty.LOCK_TYPE
static MAPIProperty | MAPIProperty.MAIL_PERMISSION
static MAPIProperty | MAPIProperty.MANAGER_NAME
static MAPIProperty | MAPIProperty.MAPPING_SIGNATURE
static MAPIProperty | MAPIProperty.MDB_PROVIDER
static MAPIProperty | MAPIProperty.MESSAGE_ATTACHMENTS
static MAPIProperty | MAPIProperty.MESSAGE_CC_ME
static MAPIProperty | MAPIProperty.MESSAGE_CLASS
static MAPIProperty | MAPIProperty.MESSAGE_CODEPAGE
static MAPIProperty | MAPIProperty.MESSAGE_DELIVERY_ID
static MAPIProperty | MAPIProperty.MESSAGE_DELIVERY_TIME
static MAPIProperty | MAPIProperty.MESSAGE_DOWNLOAD_TIME
static MAPIProperty | MAPIProperty.MESSAGE_FLAGS
static MAPIProperty | MAPIProperty.MESSAGE_RECIP_ME
static MAPIProperty | MAPIProperty.MESSAGE_RECIPIENTS
static MAPIProperty | MAPIProperty.MESSAGE_SECURITY_LABEL
static MAPIProperty | MAPIProperty.MESSAGE_SIZE
static MAPIProperty | MAPIProperty.MESSAGE_SUBMISSION_ID
static MAPIProperty | MAPIProperty.MESSAGE_TO_ME
static MAPIProperty | MAPIProperty.MESSAGE_TOKEN
static MAPIProperty | MAPIProperty.MHS_COMMON_NAME
static MAPIProperty | MAPIProperty.MIDDLE_NAME
static MAPIProperty | MAPIProperty.MINI_ICON
static MAPIProperty | MAPIProperty.MOBILE_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.MODIFY_VERSION
static MAPIProperty | MAPIProperty.MSG_STATUS
static MAPIProperty | MAPIProperty.NDR_DIAG_CODE
static MAPIProperty | MAPIProperty.NDR_REASON_CODE
static MAPIProperty | MAPIProperty.NDR_STATUS_CODE
static MAPIProperty | MAPIProperty.NEWSGROUP_NAME
static MAPIProperty | MAPIProperty.NICKNAME
static MAPIProperty | MAPIProperty.NNTP_XREF
static MAPIProperty | MAPIProperty.NON_RECEIPT_NOTIFICATION_REQUESTED
static MAPIProperty | MAPIProperty.NON_RECEIPT_REASON
static MAPIProperty | MAPIProperty.NORMALIZED_SUBJECT
static MAPIProperty | MAPIProperty.NT_SECURITY_DESCRIPTOR
static MAPIProperty | MAPIProperty.NULL
static MAPIProperty | MAPIProperty.OBJECT_TYPE
static MAPIProperty | MAPIProperty.OBSOLETED_IPMS
static MAPIProperty | MAPIProperty.OFFICE_LOCATION
static MAPIProperty | MAPIProperty.OFFICE_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.OFFICE2_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.OOF_REPLY_TYPE
static MAPIProperty | MAPIProperty.ORGANIZATIONAL_ID_NUMBER
static MAPIProperty | MAPIProperty.ORIG_ENTRY_ID
static MAPIProperty | MAPIProperty.ORIG_MESSAGE_CLASS
static MAPIProperty | MAPIProperty.ORIGIN_CHECK
static MAPIProperty | MAPIProperty.ORIGINAL_AUTHOR_ADDRTYPE
static MAPIProperty | MAPIProperty.ORIGINAL_AUTHOR_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.ORIGINAL_AUTHOR_ENTRY_ID
static MAPIProperty | MAPIProperty.ORIGINAL_AUTHOR_NAME
static MAPIProperty | MAPIProperty.ORIGINAL_AUTHOR_SEARCH_KEY
static MAPIProperty | MAPIProperty.ORIGINAL_DELIVERY_TIME
static MAPIProperty | MAPIProperty.ORIGINAL_DISPLAY_BCC
static MAPIProperty | MAPIProperty.ORIGINAL_DISPLAY_CC
static MAPIProperty | MAPIProperty.ORIGINAL_DISPLAY_NAME
static MAPIProperty | MAPIProperty.ORIGINAL_DISPLAY_TO
static MAPIProperty | MAPIProperty.ORIGINAL_EITS
static MAPIProperty | MAPIProperty.ORIGINAL_ENTRY_ID
static MAPIProperty | MAPIProperty.ORIGINAL_SEARCH_KEY
static MAPIProperty | MAPIProperty.ORIGINAL_SENDER_ADDRTYPE
static MAPIProperty | MAPIProperty.ORIGINAL_SENDER_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.ORIGINAL_SENDER_ENTRY_ID
static MAPIProperty | MAPIProperty.ORIGINAL_SENDER_NAME
static MAPIProperty | MAPIProperty.ORIGINAL_SENDER_SEARCH_KEY
static MAPIProperty | MAPIProperty.ORIGINAL_SENSITIVITY
static MAPIProperty | MAPIProperty.ORIGINAL_SENT_REPRESENTING_ADDRTYPE
static MAPIProperty | MAPIProperty.ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.ORIGINAL_SENT_REPRESENTING_ENTRY_ID
static MAPIProperty | MAPIProperty.ORIGINAL_SENT_REPRESENTING_NAME
static MAPIProperty | MAPIProperty.ORIGINAL_SENT_REPRESENTING_SEARCH_KEY
static MAPIProperty | MAPIProperty.ORIGINAL_SUBJECT
static MAPIProperty | MAPIProperty.ORIGINAL_SUBMIT_TIME
static MAPIProperty | MAPIProperty.ORIGINALLY_INTENDED_RECIP_ADDRTYPE
static MAPIProperty | MAPIProperty.ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.ORIGINALLY_INTENDED_RECIP_ENTRY_ID
static MAPIProperty | MAPIProperty.ORIGINALLY_INTENDED_RECIPIENT_NAME
static MAPIProperty | MAPIProperty.ORIGINATING_MTA_CERTIFICATE
static MAPIProperty | MAPIProperty.ORIGINATOR_AND_DL_EXPANSION_HISTORY
static MAPIProperty | MAPIProperty.ORIGINATOR_CERTIFICATE
static MAPIProperty | MAPIProperty.ORIGINATOR_DELIVERY_REPORT_REQUESTED
static MAPIProperty | MAPIProperty.ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED
static MAPIProperty | MAPIProperty.ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT
static MAPIProperty | MAPIProperty.ORIGINATOR_RETURN_ADDRESS
static MAPIProperty | MAPIProperty.OTHER_ADDRESS_CITY
static MAPIProperty | MAPIProperty.OTHER_ADDRESS_COUNTRY
static MAPIProperty | MAPIProperty.OTHER_ADDRESS_POST_OFFICE_BOX
static MAPIProperty | MAPIProperty.OTHER_ADDRESS_POSTAL_CODE
static MAPIProperty | MAPIProperty.OTHER_ADDRESS_STATE_OR_PROVINCE
static MAPIProperty | MAPIProperty.OTHER_ADDRESS_STREET
static MAPIProperty | MAPIProperty.OTHER_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.OWN_STORE_ENTRY_ID
static MAPIProperty | MAPIProperty.OWNER_APPT_ID
static MAPIProperty | MAPIProperty.PAGER_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.PARENT_DISPLAY
static MAPIProperty | MAPIProperty.PARENT_ENTRY_ID
static MAPIProperty | MAPIProperty.PARENT_KEY
static MAPIProperty | MAPIProperty.PERSONAL_HOME_PAGE
static MAPIProperty | MAPIProperty.PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY
static MAPIProperty | MAPIProperty.PHYSICAL_DELIVERY_MODE
static MAPIProperty | MAPIProperty.PHYSICAL_DELIVERY_REPORT_REQUEST
static MAPIProperty | MAPIProperty.PHYSICAL_FORWARDING_ADDRESS
static MAPIProperty | MAPIProperty.PHYSICAL_FORWARDING_ADDRESS_REQUESTED
static MAPIProperty | MAPIProperty.PHYSICAL_FORWARDING_PROHIBITED
static MAPIProperty | MAPIProperty.PHYSICAL_RENDITION_ATTRIBUTES
static MAPIProperty | MAPIProperty.POST_FOLDER_ENTRIES
static MAPIProperty | MAPIProperty.POST_FOLDER_NAMES
static MAPIProperty | MAPIProperty.POST_OFFICE_BOX
static MAPIProperty | MAPIProperty.POST_REPLY_DENIED
static MAPIProperty | MAPIProperty.POST_REPLY_FOLDER_ENTRIES
static MAPIProperty | MAPIProperty.POST_REPLY_FOLDER_NAMES
static MAPIProperty | MAPIProperty.POSTAL_ADDRESS
static MAPIProperty | MAPIProperty.POSTAL_CODE
static MAPIProperty | MAPIProperty.PREPROCESS
static MAPIProperty | MAPIProperty.PRIMARY_CAPABILITY
static MAPIProperty | MAPIProperty.PRIMARY_FAX_NUMBER
static MAPIProperty | MAPIProperty.PRIMARY_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.PRIORITY
static MAPIProperty | MAPIProperty.PROFESSION
static MAPIProperty | MAPIProperty.PROFILE_NAME
static MAPIProperty | MAPIProperty.PROOF_OF_DELIVERY
static MAPIProperty | MAPIProperty.PROOF_OF_DELIVERY_REQUESTED
static MAPIProperty | MAPIProperty.PROOF_OF_SUBMISSION
static MAPIProperty | MAPIProperty.PROOF_OF_SUBMISSION_REQUESTED
static MAPIProperty | MAPIProperty.PROP_ID_SECURE_MAX
static MAPIProperty | MAPIProperty.PROP_ID_SECURE_MIN
static MAPIProperty | MAPIProperty.PROVIDER_DISPLAY
static MAPIProperty | MAPIProperty.PROVIDER_DLL_NAME
static MAPIProperty | MAPIProperty.PROVIDER_ORDINAL
static MAPIProperty | MAPIProperty.PROVIDER_SUBMIT_TIME
static MAPIProperty | MAPIProperty.PROVIDER_UID
static MAPIProperty | MAPIProperty.PUID
static MAPIProperty | MAPIProperty.RADIO_TELEPHONE_NUMBER
static MAPIProperty | MAPIProperty.RCVD_REPRESENTING_ADDRTYPE
static MAPIProperty | MAPIProperty.RCVD_REPRESENTING_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.RCVD_REPRESENTING_ENTRY_ID
static MAPIProperty | MAPIProperty.RCVD_REPRESENTING_NAME
static MAPIProperty | MAPIProperty.RCVD_REPRESENTING_SEARCH_KEY
static MAPIProperty | MAPIProperty.READ_RECEIPT_ENTRY_ID
static MAPIProperty | MAPIProperty.READ_RECEIPT_REQUESTED
static MAPIProperty | MAPIProperty.READ_RECEIPT_SEARCH_KEY
static MAPIProperty | MAPIProperty.RECEIPT_TIME
static MAPIProperty | MAPIProperty.RECEIVE_FOLDER_SETTINGS
static MAPIProperty | MAPIProperty.RECEIVED_BY_ADDRTYPE
static MAPIProperty | MAPIProperty.RECEIVED_BY_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.RECEIVED_BY_ENTRY_ID
static MAPIProperty | MAPIProperty.RECEIVED_BY_NAME
static MAPIProperty | MAPIProperty.RECEIVED_BY_SEARCH_KEY
static MAPIProperty | MAPIProperty.RECIPIENT_CERTIFICATE
static MAPIProperty | RecipientChunks.RECIPIENT_DISPLAY_NAME
static MAPIProperty | MAPIProperty.RECIPIENT_DISPLAY_NAME
static MAPIProperty | RecipientChunks.RECIPIENT_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.RECIPIENT_ENTRY_ID
static MAPIProperty | MAPIProperty.RECIPIENT_FLAGS
static MAPIProperty | RecipientChunks.RECIPIENT_NAME
static MAPIProperty | MAPIProperty.RECIPIENT_NUMBER_FOR_ADVICE
static MAPIProperty | MAPIProperty.RECIPIENT_REASSIGNMENT_PROHIBITED
static MAPIProperty | RecipientChunks.RECIPIENT_SEARCH
static MAPIProperty | RecipientChunks.RECIPIENT_SMTP_ADDRESS
static MAPIProperty | MAPIProperty.RECIPIENT_STATUS
static MAPIProperty | MAPIProperty.RECIPIENT_TYPE
static MAPIProperty | MAPIProperty.RECORD_KEY
static MAPIProperty | MAPIProperty.REDIRECTION_HISTORY
static MAPIProperty | MAPIProperty.REFERRED_BY_NAME
static MAPIProperty | MAPIProperty.REGISTERED_MAIL_TYPE
static MAPIProperty | MAPIProperty.RELATED_IPMS
static MAPIProperty | MAPIProperty.REMOTE_PROGRESS
static MAPIProperty | MAPIProperty.REMOTE_PROGRESS_TEXT
static MAPIProperty | MAPIProperty.REMOTE_VALIDATE_OK
static MAPIProperty | MAPIProperty.RENDERING_POSITION
static MAPIProperty | MAPIProperty.REPLY_RECIPIENT_ENTRIES
static MAPIProperty | MAPIProperty.REPLY_RECIPIENT_NAMES
static MAPIProperty | MAPIProperty.REPLY_REQUESTED
static MAPIProperty | MAPIProperty.REPLY_TIME
static MAPIProperty | MAPIProperty.REPORT_ENTRY_ID
static MAPIProperty | MAPIProperty.REPORT_NAME
static MAPIProperty | MAPIProperty.REPORT_SEARCH_KEY
static MAPIProperty | MAPIProperty.REPORT_TAG
static MAPIProperty | MAPIProperty.REPORT_TEXT
static MAPIProperty | MAPIProperty.REPORT_TIME
static MAPIProperty | MAPIProperty.REPORTING_DL_NAME
static MAPIProperty | MAPIProperty.REPORTING_MTA_CERTIFICATE
static MAPIProperty | MAPIProperty.REQUESTED_DELIVERY_METHOD
static MAPIProperty | MAPIProperty.RESOURCE_FLAGS
static MAPIProperty | MAPIProperty.RESOURCE_METHODS
static MAPIProperty | MAPIProperty.RESOURCE_PATH
static MAPIProperty | MAPIProperty.RESOURCE_TYPE
static MAPIProperty | MAPIProperty.RESPONSE_REQUESTED
static MAPIProperty | MAPIProperty.RESPONSIBILITY
static MAPIProperty | MAPIProperty.RETURNED_IPM
static MAPIProperty | MAPIProperty.ROW_TYPE
static MAPIProperty | MAPIProperty.ROWID
static MAPIProperty | MAPIProperty.RTF_COMPRESSED
static MAPIProperty | MAPIProperty.RTF_IN_SYNC
static MAPIProperty | MAPIProperty.RTF_SYNC_BODY_COUNT
static MAPIProperty | MAPIProperty.RTF_SYNC_BODY_CRC
static MAPIProperty | MAPIProperty.RTF_SYNC_BODY_TAG
static MAPIProperty | MAPIProperty.RTF_SYNC_PREFIX_COUNT
static MAPIProperty | MAPIProperty.RTF_SYNC_TRAILING_COUNT
static MAPIProperty | MAPIProperty.SEARCH
static MAPIProperty | MAPIProperty.SEARCH_KEY
static MAPIProperty | MAPIProperty.SECURITY
static MAPIProperty | MAPIProperty.SELECTABLE
static MAPIProperty | MAPIProperty.SEND_INTERNET_ENCODING
static MAPIProperty | MAPIProperty.SEND_RECALL_REPORT
static MAPIProperty | MAPIProperty.SEND_RICH_INFO
static MAPIProperty | MAPIProperty.SENDER_ADDRTYPE
static MAPIProperty | MAPIProperty.SENDER_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.SENDER_ENTRY_ID
static MAPIProperty | MAPIProperty.SENDER_NAME
static MAPIProperty | MAPIProperty.SENDER_SEARCH_KEY
static MAPIProperty | MAPIProperty.SENSITIVITY
static MAPIProperty | MAPIProperty.SENT_REPRESENTING_ADDRTYPE
static MAPIProperty | MAPIProperty.SENT_REPRESENTING_EMAIL_ADDRESS
static MAPIProperty | MAPIProperty.SENT_REPRESENTING_ENTRY_ID
static MAPIProperty | MAPIProperty.SENT_REPRESENTING_NAME
static MAPIProperty | MAPIProperty.SENT_REPRESENTING_SEARCH_KEY
static MAPIProperty | MAPIProperty.SENTMAIL_ENTRY_ID
static MAPIProperty | MAPIProperty.SERVICE_DELETE_FILES
static MAPIProperty | MAPIProperty.SERVICE_DLL_NAME
static MAPIProperty | MAPIProperty.SERVICE_ENTRY_NAME
static MAPIProperty | MAPIProperty.SERVICE_EXTRA_UIDS
static MAPIProperty | MAPIProperty.SERVICE_NAME
static MAPIProperty | MAPIProperty.SERVICE_SUPPORT_FILES
static MAPIProperty | MAPIProperty.SERVICE_UID
static MAPIProperty | MAPIProperty.SERVICES
static MAPIProperty | MAPIProperty.SEVEN_BIT_DISPLAY_NAME
static MAPIProperty | MAPIProperty.SMTP_ADDRESS
static MAPIProperty | MAPIProperty.SPOOLER_STATUS
static MAPIProperty | MAPIProperty.SPOUSE_NAME
static MAPIProperty | MAPIProperty.START_DATE
static MAPIProperty | MAPIProperty.STATE_OR_PROVINCE
static MAPIProperty | MAPIProperty.STATUS
static MAPIProperty | MAPIProperty.STATUS_CODE
static MAPIProperty | MAPIProperty.STATUS_STRING
static MAPIProperty | MAPIProperty.STORE_ENTRY_ID
static MAPIProperty | MAPIProperty.STORE_PROVIDERS
static MAPIProperty | MAPIProperty.STORE_RECORD_KEY
static MAPIProperty | MAPIProperty.STORE_STATE
static MAPIProperty | MAPIProperty.STORE_SUPPORT_MASK
static MAPIProperty | MAPIProperty.STREET_ADDRESS
static MAPIProperty | MAPIProperty.SUBFOLDERS
static MAPIProperty | MAPIProperty.SUBJECT
static MAPIProperty | MAPIProperty.SUBJECT_IPM
static MAPIProperty | MAPIProperty.SUBJECT_PREFIX
static MAPIProperty | MAPIProperty.SUBMIT_FLAGS
static MAPIProperty | MAPIProperty.SUPERSEDES
static MAPIProperty | MAPIProperty.SUPPLEMENTARY_INFO
static MAPIProperty | MAPIProperty.SURNAME
static MAPIProperty | MAPIProperty.TELEX_NUMBER
static MAPIProperty | MAPIProperty.TEMPLATEID
static MAPIProperty | MAPIProperty.TITLE
static MAPIProperty | MAPIProperty.TNEF_CORRELATION_KEY
static MAPIProperty | MAPIProperty.TRANSMITABLE_DISPLAY_NAME
static MAPIProperty | MAPIProperty.TRANSPORT_KEY
static MAPIProperty | MAPIProperty.TRANSPORT_MESSAGE_HEADERS
static MAPIProperty | MAPIProperty.TRANSPORT_PROVIDERS
static MAPIProperty | MAPIProperty.TRANSPORT_STATUS
static MAPIProperty | MAPIProperty.TTYTDD_PHONE_NUMBER
static MAPIProperty | MAPIProperty.TYPE_OF_MTS_USER
static MAPIProperty | MAPIProperty.UNKNOWN
static MAPIProperty | MAPIProperty.USER_CERTIFICATE
static MAPIProperty | MAPIProperty.USER_X509_CERTIFICATE
static MAPIProperty | MAPIProperty.VALID_FOLDER_MASK
static MAPIProperty | MAPIProperty.VIEWS_ENTRY_ID
static MAPIProperty | MAPIProperty.WEDDING_ANNIVERSARY
static MAPIProperty | MAPIProperty.X400_CONTENT_TYPE
static MAPIProperty | MAPIProperty.X400_DEFERRED_DELIVERY_CANCEL
static MAPIProperty | MAPIProperty.XPOS
static MAPIProperty | MAPIProperty.YPOS

Methods in org.apache.poi.hsmf.datatypes that return MAPIProperty
static MAPIProperty | MAPIProperty.createCustom(int id, int type, java.lang.String name)
static MAPIProperty | MAPIProperty.get(int id)

Methods in org.apache.poi.hsmf.datatypes that return types with arguments of type MAPIProperty
static java.util.Collection<MAPIProperty> MAPIProperty.getAll()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.MessageSubmissionChunk

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.MessageSubmissionChunk

Packages that use MessageSubmissionChunk
org.apache.poi.hsmf.datatypes

Uses of MessageSubmissionChunk in org.apache.poi.hsmf.datatypes

Fields in org.apache.poi.hsmf.datatypes declared as MessageSubmissionChunk
 MessageSubmissionChunk Chunks.submissionChunk
TODO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.NameIdChunks

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.NameIdChunks

Packages that use NameIdChunks
org.apache.poi.hsmf

Uses of NameIdChunks in org.apache.poi.hsmf

Methods in org.apache.poi.hsmf that return NameIdChunks
 NameIdChunks MAPIMessage.getNameIdChunks()
Gets the Name ID chunks, or null if there aren't any

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.RecipientChunks

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.RecipientChunks

Packages that use RecipientChunks
org.apache.poi.hsmf
org.apache.poi.hsmf.datatypes

Uses of RecipientChunks in org.apache.poi.hsmf

Methods in org.apache.poi.hsmf that return RecipientChunks
 RecipientChunks[] MAPIMessage.getRecipientDetailsChunks()
Gets all the recipient details chunks.

Uses of RecipientChunks in org.apache.poi.hsmf.datatypes

Methods in org.apache.poi.hsmf.datatypes with parameters of type RecipientChunks
 int RecipientChunks.RecipientChunksSorter.compare(RecipientChunks a, RecipientChunks b)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter

No usage of org.apache.poi.hsmf.datatypes.RecipientChunks.RecipientChunksSorter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.StringChunk

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.StringChunk

Packages that use StringChunk
org.apache.poi.hsmf
org.apache.poi.hsmf.datatypes

Uses of StringChunk in org.apache.poi.hsmf

Methods in org.apache.poi.hsmf with parameters of type StringChunk
 java.lang.String MAPIMessage.getStringFromChunk(StringChunk chunk)
Gets a string value based on the passed chunk.

Uses of StringChunk in org.apache.poi.hsmf.datatypes

Fields in org.apache.poi.hsmf.datatypes declared as StringChunk
StringChunk | AttachmentChunks.attachExtension
StringChunk | AttachmentChunks.attachFileName
StringChunk | AttachmentChunks.attachLongFileName
StringChunk | AttachmentChunks.attachMimeTag
StringChunk | Chunks.conversationTopic Sort of like the subject line, but without the RE: and FWD: parts.
StringChunk | RecipientChunks.deliveryTypeChunk Normally EX or SMTP.
StringChunk | Chunks.displayBCCChunk Value that shows in the BCC field
StringChunk | Chunks.displayCCChunk value that shows in the CC field
StringChunk | Chunks.displayFromChunk Value that is in the FROM field
StringChunk | Chunks.displayToChunk Value that is in the TO field (not actually the addresses as they are stored in recip directory nodes
StringChunk | Chunks.emailFromChunk TODO
StringChunk | Chunks.htmlBodyChunkString BODY Html Chunk, for html messages
StringChunk | Chunks.messageClass Type of message that the MSG represents (ie.
StringChunk | Chunks.messageHeaders The email headers
StringChunk | Chunks.messageId The message ID
StringChunk | RecipientChunks.recipientDisplayNameChunk The display name of the recipient.
StringChunk | RecipientChunks.recipientEmailChunk The email address of the recipient, which could be in SMTP or SEARCH format, but isn't always present...
StringChunk | RecipientChunks.recipientNameChunk The "name", which could be their name if an internal person, or their email address if an external person
StringChunk | RecipientChunks.recipientSMTPChunk The smtp destination email address of the recipient, but isn't always present...
StringChunk | Chunks.sentByServerType Type of server that the message originated from (SMTP, etc).
StringChunk | Chunks.subjectChunk Subject link chunk, in plain/text
StringChunk | Chunks.textBodyChunk BODY Chunk, for plain/text messages

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.datatypes.Types

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.datatypes.Types

No usage of org.apache.poi.hsmf.datatypes.Types

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HSMFDump

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.dev
Class HSMFDump

java.lang.Object
    extended by  org.apache.poi.hsmf.dev.HSMFDump

public class HSMFDump
extends java.lang.Object

Dumps out the chunk details, and where possible contents

Constructor Summary
HSMFDump(POIFSFileSystem fs)
Method Summary
void | dump()
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSMFDump

public HSMFDump(POIFSFileSystem fs)
Method Detail

dump

public void dump()
          throws java.io.IOException
Throws:
java.io.IOException

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hsmf.dev
Classes
HSMFDump
TypesLister


org.apache.poi.hsmf.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hsmf.dev

Class Summary
HSMFDump | Dumps out the chunk details, and where possible contents
TypesLister | Lists the different MAPI types


org.apache.poi.hsmf.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hsmf.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hsmf.dev.HSMFDump
    • org.apache.poi.hsmf.dev.TypesLister


Uses of Package org.apache.poi.hsmf.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hsmf.dev

No usage of org.apache.poi.hsmf.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


TypesLister

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.dev
Class TypesLister

java.lang.Object
    extended by  org.apache.poi.hsmf.dev.TypesLister

public class TypesLister
extends java.lang.Object

Lists the different MAPI types

Constructor Summary
TypesLister()
Method Summary
void | listById(java.io.PrintStream out)
void | listByName(java.io.PrintStream out)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TypesLister

public TypesLister()
Method Detail

listByName

public void listByName(java.io.PrintStream out)

listById

public void listById(java.io.PrintStream out)

main

public static void main(java.lang.String[] args)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hsmf.dev.HSMFDump

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.dev.HSMFDump

No usage of org.apache.poi.hsmf.dev.HSMFDump

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.dev.TypesLister

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.dev.TypesLister

No usage of org.apache.poi.hsmf.dev.TypesLister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ChunkNotFoundException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.exceptions
Class ChunkNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hsmf.exceptions.ChunkNotFoundException
All Implemented Interfaces:
java.io.Serializable
public final class ChunkNotFoundException
extends java.lang.Exception

See Also:
Serialized Form

Constructor Summary
ChunkNotFoundException()
ChunkNotFoundException(java.lang.String chunkName)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ChunkNotFoundException

public ChunkNotFoundException()

ChunkNotFoundException

public ChunkNotFoundException(java.lang.String chunkName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DirectoryChunkNotFoundException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.exceptions
Class DirectoryChunkNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException
All Implemented Interfaces:
java.io.Serializable
public final class DirectoryChunkNotFoundException
extends java.lang.Exception

Exception for when a directory chunk is not found but is expected.

Author:
Travis Ferguson
See Also:
Serialized Form

Constructor Summary
DirectoryChunkNotFoundException(java.lang.String directory)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DirectoryChunkNotFoundException

public DirectoryChunkNotFoundException(java.lang.String directory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hsmf.exceptions
Exceptions
ChunkNotFoundException
DirectoryChunkNotFoundException


org.apache.poi.hsmf.exceptions

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hsmf.exceptions

Exception Summary
ChunkNotFoundException |
DirectoryChunkNotFoundException | Exception for when a directory chunk is not found but is expected.


org.apache.poi.hsmf.exceptions Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hsmf.exceptions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.hsmf.exceptions.ChunkNotFoundException
        • org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException


Uses of Package org.apache.poi.hsmf.exceptions

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hsmf.exceptions

Packages that use org.apache.poi.hsmf.exceptions
org.apache.poi.hsmf

Classes in org.apache.poi.hsmf.exceptions used by org.apache.poi.hsmf
ChunkNotFoundException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.exceptions.ChunkNotFoundException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.exceptions.ChunkNotFoundException

Packages that use ChunkNotFoundException
org.apache.poi.hsmf

Uses of ChunkNotFoundException in org.apache.poi.hsmf

Methods in org.apache.poi.hsmf that throw ChunkNotFoundException
java.lang.String | MAPIMessage.getConversationTopic() Gets the conversation topic of the parsed Outlook Message.
java.lang.String | MAPIMessage.getDisplayBCC() Gets the display value of the "BCC" line of the outlook message.
java.lang.String | MAPIMessage.getDisplayCC() Gets the display value of the "CC" line of the outlook message.
java.lang.String | MAPIMessage.getDisplayFrom() Gets the display value of the "FROM" line of the outlook message This is not the actual address that was sent from but the formated display of the user name.
java.lang.String | MAPIMessage.getDisplayTo() Gets the display value of the "TO" line of the outlook message.
java.lang.String[] | MAPIMessage.getHeaders() Returns all the headers, one entry per line
java.lang.String | MAPIMessage.getHmtlBody() Deprecated.
java.lang.String | MAPIMessage.getHtmlBody() Gets the html body of this Outlook Message, if this email contains a html version.
java.lang.String | MAPIMessage.getMessageClass() Gets the message class of the parsed Outlook Message.
java.util.Calendar | MAPIMessage.getMessageDate() Gets the date that the message was accepted by the server on.
java.lang.String | MAPIMessage.getRecipientEmailAddress() Returns all the recipients' email address, separated by semicolons.
java.lang.String[] | MAPIMessage.getRecipientEmailAddressList() Returns an array of all the recipient's email address, normally in TO then CC then BCC order.
java.lang.String | MAPIMessage.getRecipientNames() Returns all the recipients' names, separated by semicolons.
java.lang.String[] | MAPIMessage.getRecipientNamesList() Returns an array of all the recipient's names, normally in TO then CC then BCC order.
java.lang.String | MAPIMessage.getRtfBody() Gets the RTF Rich Message body of this Outlook Message, if this email contains a RTF (rich) version.
java.lang.String | MAPIMessage.getStringFromChunk(StringChunk chunk) Gets a string value based on the passed chunk.
java.lang.String | MAPIMessage.getSubject() Gets the subject line of the Outlook Message
java.lang.String | MAPIMessage.getTextBody() Gets the plain text body of this Outlook Message

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException

No usage of org.apache.poi.hsmf.exceptions.DirectoryChunkNotFoundException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


OutlookTextExtactor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.extractor
Class OutlookTextExtactor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hsmf.extractor.OutlookTextExtactor

public class OutlookTextExtactor
extends POIOLE2TextExtractor

A text extractor for HSMF (Outlook) .msg files. Outputs in a format somewhat like a plain text email.

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
OutlookTextExtactor(DirectoryNode poifsDir)
OutlookTextExtactor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated.
OutlookTextExtactor(java.io.InputStream inp)
OutlookTextExtactor(MAPIMessage msg)
OutlookTextExtactor(NPOIFSFileSystem fs)
OutlookTextExtactor(POIFSFileSystem fs)
Method Summary
MAPIMessage | getMAPIMessage() Returns the underlying MAPI message
java.lang.String | getText() Outputs something a little like a RFC822 email
protected void | handleEmails(java.lang.StringBuffer s, java.lang.String type, java.lang.String displayText, StringUtil.StringsIterator emails) Takes a Display focused string, eg "Nick; Jim" and an iterator of emails, and does its best to return something like "Nick ; Jim "
static void | main(java.lang.String[] args)
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getDocSummaryInformation, getFileSystem, getMetadataTextExtractor, getRoot, getSummaryInformation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OutlookTextExtactor

public OutlookTextExtactor(MAPIMessage msg)

OutlookTextExtactor

@Deprecated
public OutlookTextExtactor(DirectoryNode poifsDir,
                                      POIFSFileSystem fs)
                    throws java.io.IOException
Deprecated.

Use OutlookTextExtactor(DirectoryNode) instead

Throws:
java.io.IOException

OutlookTextExtactor

public OutlookTextExtactor(DirectoryNode poifsDir)
                    throws java.io.IOException
Throws:
java.io.IOException

OutlookTextExtactor

public OutlookTextExtactor(POIFSFileSystem fs)
                    throws java.io.IOException
Throws:
java.io.IOException

OutlookTextExtactor

public OutlookTextExtactor(NPOIFSFileSystem fs)
                    throws java.io.IOException
Throws:
java.io.IOException

OutlookTextExtactor

public OutlookTextExtactor(java.io.InputStream inp)
                    throws java.io.IOException
Throws:
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

getMAPIMessage

public MAPIMessage getMAPIMessage()
Returns the underlying MAPI message

getText

public java.lang.String getText()
Outputs something a little like a RFC822 email

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

handleEmails

protected void handleEmails(java.lang.StringBuffer s,
                            java.lang.String type,
                            java.lang.String displayText,
                            StringUtil.StringsIterator emails)
Takes a Display focused string, eg "Nick; Jim" and an iterator of emails, and does its best to return something like "Nick ; Jim "

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hsmf.extractor
Classes
OutlookTextExtactor


org.apache.poi.hsmf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hsmf.extractor

Class Summary
OutlookTextExtactor A text extractor for HSMF (Outlook) .msg files.


org.apache.poi.hsmf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hsmf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIOLE2TextExtractor
        • org.apache.poi.hsmf.extractor.OutlookTextExtactor


Uses of Package org.apache.poi.hsmf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hsmf.extractor

No usage of org.apache.poi.hsmf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hsmf.extractor.OutlookTextExtactor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.extractor.OutlookTextExtactor

No usage of org.apache.poi.hsmf.extractor.OutlookTextExtactor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hsmf.parsers
Classes
POIFSChunkParser


org.apache.poi.hsmf.parsers

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hsmf.parsers

Class Summary
POIFSChunkParser Processes a POIFS of a .msg file into groups of Chunks, such as core data, attachment #1 data, attachment #2 data, recipient data and so on.


org.apache.poi.hsmf.parsers Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hsmf.parsers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hsmf.parsers.POIFSChunkParser


Uses of Package org.apache.poi.hsmf.parsers

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hsmf.parsers

No usage of org.apache.poi.hsmf.parsers

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POIFSChunkParser

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hsmf.parsers
Class POIFSChunkParser

java.lang.Object
    extended by  org.apache.poi.hsmf.parsers.POIFSChunkParser

public final class POIFSChunkParser
extends java.lang.Object

Processes a POIFS of a .msg file into groups of Chunks, such as core data, attachment #1 data, attachment #2 data, recipient data and so on.

Constructor Summary
POIFSChunkParser()
Method Summary
static ChunkGroup[] | parse(DirectoryNode node)
static ChunkGroup[] | parse(POIFSFileSystem fs)
protected static void | process(Entry entry, ChunkGroup grouping) Creates a chunk, and gives it to its parent group
protected static void | processChunks(DirectoryNode node, ChunkGroup grouping) Creates all the chunks for a given Directory, but doesn't recurse or descend
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSChunkParser

public POIFSChunkParser()
Method Detail

parse

public static ChunkGroup[] parse(POIFSFileSystem fs)
                          throws java.io.IOException
Throws:
java.io.IOException

parse

public static ChunkGroup[] parse(DirectoryNode node)
                          throws java.io.IOException
Throws:
java.io.IOException

processChunks

protected static void processChunks(DirectoryNode node,
                                    ChunkGroup grouping)
Creates all the chunks for a given Directory, but doesn't recurse or descend

process

protected static void process(Entry entry,
                              ChunkGroup grouping)
Creates a chunk, and gives it to its parent group

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hsmf.parsers.POIFSChunkParser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hsmf.parsers.POIFSChunkParser

No usage of org.apache.poi.hsmf.parsers.POIFSChunkParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


OldExcelFormatException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf
Class OldExcelFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalArgumentException
                    extended by  org.apache.poi.OldFileFormatException
                        extended by  org.apache.poi.hssf.OldExcelFormatException
All Implemented Interfaces:
java.io.Serializable
public class OldExcelFormatException
extends OldFileFormatException

See Also:
Serialized Form

Constructor Summary
OldExcelFormatException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OldExcelFormatException

public OldExcelFormatException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf
Exceptions
OldExcelFormatException


org.apache.poi.hssf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf

Horrible SpreadSheet Format API's for reading/writting Excel files using pure Java.

See:
Description

Exception Summary
OldExcelFormatException

Package org.apache.poi.hssf Description

Horrible SpreadSheet Format API's for reading/writting Excel files using pure Java.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.hssf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • org.apache.poi.OldFileFormatException
              • org.apache.poi.hssf.OldExcelFormatException


Uses of Package org.apache.poi.hssf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf

No usage of org.apache.poi.hssf

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.OldExcelFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.OldExcelFormatException

No usage of org.apache.poi.hssf.OldExcelFormatException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractExcelConverter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.converter
Class AbstractExcelConverter

java.lang.Object
    extended by  org.apache.poi.hssf.converter.AbstractExcelConverter
Direct Known Subclasses:
ExcelToFoConverter, ExcelToHtmlConverter
@Beta
public abstract class AbstractExcelConverter
extends java.lang.Object

Common class for ExcelToFoConverter and ExcelToHtmlConverter

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)
See Also:
AbstractWordConverter

Field Summary
protected  HSSFDataFormatter _formatter
Constructor Summary
AbstractExcelConverter()
Method Summary
protected java.lang.String | getColumnName(int columnIndex) Generates name for output as column header in case isOutputColumnHeaders() == true
protected static int | getColumnWidth(HSSFSheet sheet, int columnIndex)
protected static int | getDefaultColumnWidth(HSSFSheet sheet)
protected abstract org.w3c.dom.Document | getDocument()
FontReplacer | getFontReplacer()
protected java.lang.String | getRowName(HSSFRow row) Generates name for output as row number in case isOutputRowNumbers() == true
boolean | isOutputColumnHeaders()
boolean | isOutputHiddenColumns()
boolean | isOutputHiddenRows()
boolean | isOutputLeadingSpacesAsNonBreaking()
boolean | isOutputRowNumbers()
protected boolean | isTextEmpty(HSSFCell cell)
void | setFontReplacer(FontReplacer fontReplacer)
void | setOutputColumnHeaders(boolean outputColumnHeaders)
void | setOutputHiddenColumns(boolean outputZeroWidthColumns)
void | setOutputHiddenRows(boolean outputZeroHeightRows)
void | setOutputLeadingSpacesAsNonBreaking(boolean outputPrePostSpacesAsNonBreaking)
void | setOutputRowNumbers(boolean outputRowNumbers)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_formatter

protected final HSSFDataFormatter _formatter
Constructor Detail

AbstractExcelConverter

public AbstractExcelConverter()
Method Detail

getColumnWidth

protected static int getColumnWidth(HSSFSheet sheet,
                                    int columnIndex)

getDefaultColumnWidth

protected static int getDefaultColumnWidth(HSSFSheet sheet)

getColumnName

protected java.lang.String getColumnName(int columnIndex)
Generates name for output as column header in case isOutputColumnHeaders() == true

Parameters:
columnIndex - 0-based column index

getDocument

protected abstract org.w3c.dom.Document getDocument()

getFontReplacer

public FontReplacer getFontReplacer()

getRowName

protected java.lang.String getRowName(HSSFRow row)
Generates name for output as row number in case isOutputRowNumbers() == true

isOutputColumnHeaders

public boolean isOutputColumnHeaders()

isOutputHiddenColumns

public boolean isOutputHiddenColumns()

isOutputHiddenRows

public boolean isOutputHiddenRows()

isOutputLeadingSpacesAsNonBreaking

public boolean isOutputLeadingSpacesAsNonBreaking()

isOutputRowNumbers

public boolean isOutputRowNumbers()

isTextEmpty

protected boolean isTextEmpty(HSSFCell cell)

setFontReplacer

public void setFontReplacer(FontReplacer fontReplacer)

setOutputColumnHeaders

public void setOutputColumnHeaders(boolean outputColumnHeaders)

setOutputHiddenColumns

public void setOutputHiddenColumns(boolean outputZeroWidthColumns)

setOutputHiddenRows

public void setOutputHiddenRows(boolean outputZeroHeightRows)

setOutputLeadingSpacesAsNonBreaking

public void setOutputLeadingSpacesAsNonBreaking(boolean outputPrePostSpacesAsNonBreaking)

setOutputRowNumbers

public void setOutputRowNumbers(boolean outputRowNumbers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractExcelUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.converter
Class AbstractExcelUtils

java.lang.Object
    extended by  org.apache.poi.hssf.converter.AbstractExcelUtils
Direct Known Subclasses:
ExcelToFoUtils, ExcelToHtmlUtils
@Beta
public class AbstractExcelUtils
extends java.lang.Object

Common class for ExcelToFoUtils and ExcelToHtmlUtils

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)
See Also:
AbstractWordUtils

Constructor Summary
AbstractExcelUtils()
Method Summary
static java.lang.String | getAlign(short alignment)
static java.lang.String | getBorderStyle(short xlsBorder)
static java.lang.String | getBorderWidth(short xlsBorder)
static java.lang.String | getColor(HSSFColor color)
static int | getColumnWidthInPx(int widthUnits) See here for Xio explanation and details
static CellRangeAddress | getMergedRange(CellRangeAddress[][] mergedRanges, int rowNumber, int columnNumber)
static HSSFWorkbook | loadXls(java.io.File xlsFile)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractExcelUtils

public AbstractExcelUtils()
Method Detail

getAlign

public static java.lang.String getAlign(short alignment)

getBorderStyle

public static java.lang.String getBorderStyle(short xlsBorder)

getBorderWidth

public static java.lang.String getBorderWidth(short xlsBorder)

getColor

public static java.lang.String getColor(HSSFColor color)

getColumnWidthInPx

public static int getColumnWidthInPx(int widthUnits)
See here for Xio explanation and details

getMergedRange

public static CellRangeAddress getMergedRange(CellRangeAddress[][] mergedRanges,
                                              int rowNumber,
                                              int columnNumber)
Parameters:
mergedRanges - map of sheet merged ranges built with ExcelToHtmlUtils.buildMergedRangesMap(HSSFSheet)
Returns:
CellRangeAddress from map if cell with specified row and column numbers contained in found range, null otherwise

loadXls

public static HSSFWorkbook loadXls(java.io.File xlsFile)
                            throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExcelToFoConverter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.converter
Class ExcelToFoConverter

java.lang.Object
    extended by  org.apache.poi.hssf.converter.AbstractExcelConverter
        extended by  org.apache.poi.hssf.converter.ExcelToFoConverter

@Beta
public class ExcelToFoConverter
extends AbstractExcelConverter

Converts xls files (97-2007) to XSL FO.

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Field Summary
Fields inherited from class org.apache.poi.hssf.converter.AbstractExcelConverter
_formatter
Constructor Summary
ExcelToFoConverter(org.w3c.dom.Document document)
ExcelToFoConverter(FoDocumentFacade foDocumentFacade)
Method Summary
protected  java.lang.String createPageMaster(float tableWidthIn, java.lang.String pageMasterName)
protected  org.w3c.dom.Document getDocument()
 float getPageMarginInches()
protected  boolean isEmptyStyle(CellStyle cellStyle)
Returns false if cell style by itself (without text, i.e.
static void main(java.lang.String[] args)
Java main() interface to interact with ExcelToFoConverter
static org.w3c.dom.Document process(java.io.File xlsFile)
Converts Excel file (97-2007) into XSL FO file.
protected  boolean processCell(HSSFWorkbook workbook, HSSFCell cell, org.w3c.dom.Element tableCellElement, int normalWidthPx, int maxSpannedWidthPx, float normalHeightPt)
protected  void processCellStyle(HSSFWorkbook workbook, HSSFCellStyle cellStyle, org.w3c.dom.Element cellTarget, org.w3c.dom.Element blockTarget)
protected  void processCellStyleBorder(HSSFWorkbook workbook, org.w3c.dom.Element cellTarget, java.lang.String type, short xlsBorder, short borderColor)
protected  void processCellStyleFont(HSSFWorkbook workbook, org.w3c.dom.Element blockTarget, HSSFFont font)
protected  void processColumnHeaders(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table)
protected  float processColumnWidths(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table)
Creates COLGROUP element with width specified for all columns.
protected  void processDocumentInformation(SummaryInformation summaryInformation)
protected  int processRow(HSSFWorkbook workbook, CellRangeAddress[][] mergedRanges, HSSFRow row, org.w3c.dom.Element tableRowElement)
protected  org.w3c.dom.Element processRowNumber(HSSFRow row)
protected  float processSheet(HSSFWorkbook workbook, HSSFSheet sheet, org.w3c.dom.Element flow)
protected  boolean processSheet(HSSFWorkbook workbook, int sheetIndex)
Process single sheet (as specified by 0-based sheet index)
protected  void processSheetName(HSSFSheet sheet, org.w3c.dom.Element flow)
 void processWorkbook(HSSFWorkbook workbook)
 void setPageMarginInches(float pageMarginInches)
Methods inherited from class org.apache.poi.hssf.converter.AbstractExcelConverter
getColumnName, getColumnWidth, getDefaultColumnWidth, getFontReplacer, getRowName, isOutputColumnHeaders, isOutputHiddenColumns, isOutputHiddenRows, isOutputLeadingSpacesAsNonBreaking, isOutputRowNumbers, isTextEmpty, setFontReplacer, setOutputColumnHeaders, setOutputHiddenColumns, setOutputHiddenRows, setOutputLeadingSpacesAsNonBreaking, setOutputRowNumbers
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExcelToFoConverter

public ExcelToFoConverter(org.w3c.dom.Document document)

ExcelToFoConverter

public ExcelToFoConverter(FoDocumentFacade foDocumentFacade)
Method Detail

main

public static void main(java.lang.String[] args)
Java main() interface to interact with ExcelToFoConverter

Usage: ExcelToHtmlConverter infile outfile

Where infile is an input .xls file ( Word 97-2007) which will be rendered as XSL FO into outfile

process

public static org.w3c.dom.Document process(java.io.File xlsFile)
                                    throws java.lang.Exception
Converts Excel file (97-2007) into XSL FO file.

Parameters:
xlsFile - file to process
Returns:
DOM representation of result XSL FO
Throws:
java.lang.Exception

createPageMaster

protected java.lang.String createPageMaster(float tableWidthIn,
                                            java.lang.String pageMasterName)

getDocument

protected org.w3c.dom.Document getDocument()
Specified by:
getDocument in class AbstractExcelConverter

getPageMarginInches

public float getPageMarginInches()

isEmptyStyle

protected boolean isEmptyStyle(CellStyle cellStyle)
Returns false if cell style by itself (without text, i.e. borders, fill, etc.) worth a mention, true otherwise

Returns:
false if cell style by itself (without text, i.e. borders, fill, etc.) worth a mention, true otherwise

processCell

protected boolean processCell(HSSFWorkbook workbook,
                              HSSFCell cell,
                              org.w3c.dom.Element tableCellElement,
                              int normalWidthPx,
                              int maxSpannedWidthPx,
                              float normalHeightPt)

processCellStyle

protected void processCellStyle(HSSFWorkbook workbook,
                                HSSFCellStyle cellStyle,
                                org.w3c.dom.Element cellTarget,
                                org.w3c.dom.Element blockTarget)

processCellStyleBorder

protected void processCellStyleBorder(HSSFWorkbook workbook,
                                      org.w3c.dom.Element cellTarget,
                                      java.lang.String type,
                                      short xlsBorder,
                                      short borderColor)

processCellStyleFont

protected void processCellStyleFont(HSSFWorkbook workbook,
                                    org.w3c.dom.Element blockTarget,
                                    HSSFFont font)

processColumnHeaders

protected void processColumnHeaders(HSSFSheet sheet,
                                    int maxSheetColumns,
                                    org.w3c.dom.Element table)

processColumnWidths

protected float processColumnWidths(HSSFSheet sheet,
                                    int maxSheetColumns,
                                    org.w3c.dom.Element table)
Creates COLGROUP element with width specified for all columns. (Except first if AbstractExcelConverter.isOutputRowNumbers()==true)

Returns:
table width in inches

processDocumentInformation

protected void processDocumentInformation(SummaryInformation summaryInformation)

processRow

protected int processRow(HSSFWorkbook workbook,
                         CellRangeAddress[][] mergedRanges,
                         HSSFRow row,
                         org.w3c.dom.Element tableRowElement)
Returns:
maximum 1-base index of column that were rendered, zero if none

processRowNumber

protected org.w3c.dom.Element processRowNumber(HSSFRow row)

processSheet

protected float processSheet(HSSFWorkbook workbook,
                             HSSFSheet sheet,
                             org.w3c.dom.Element flow)

processSheet

protected boolean processSheet(HSSFWorkbook workbook,
                               int sheetIndex)
Process single sheet (as specified by 0-based sheet index)

Returns:
true if result were added to FO document, false otherwise

processSheetName

protected void processSheetName(HSSFSheet sheet,
                                org.w3c.dom.Element flow)

processWorkbook

public void processWorkbook(HSSFWorkbook workbook)

setPageMarginInches

public void setPageMarginInches(float pageMarginInches)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExcelToFoUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.converter
Class ExcelToFoUtils

java.lang.Object
    extended by  org.apache.poi.hssf.converter.AbstractExcelUtils
        extended by  org.apache.poi.hssf.converter.ExcelToFoUtils

@Beta
public class ExcelToFoUtils
extends AbstractExcelUtils

Constructor Summary
ExcelToFoUtils()
Method Summary
Methods inherited from class org.apache.poi.hssf.converter.AbstractExcelUtils
getAlign, getBorderStyle, getBorderWidth, getColor, getColumnWidthInPx, getMergedRange, loadXls
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExcelToFoUtils

public ExcelToFoUtils()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExcelToHtmlConverter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.converter
Class ExcelToHtmlConverter

java.lang.Object
    extended by  org.apache.poi.hssf.converter.AbstractExcelConverter
        extended by  org.apache.poi.hssf.converter.ExcelToHtmlConverter

@Beta
public class ExcelToHtmlConverter
extends AbstractExcelConverter

Converts xls files (97-2007) to HTML file.

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Field Summary
Fields inherited from class org.apache.poi.hssf.converter.AbstractExcelConverter
_formatter
Constructor Summary
ExcelToHtmlConverter(org.w3c.dom.Document doc)
ExcelToHtmlConverter(HtmlDocumentFacade htmlDocumentFacade)
Method Summary
protected  java.lang.String buildStyle(HSSFWorkbook workbook, HSSFCellStyle cellStyle)
 java.lang.String getCssClassPrefixCell()
 java.lang.String getCssClassPrefixDiv()
 java.lang.String getCssClassPrefixRow()
 java.lang.String getCssClassPrefixTable()
 org.w3c.dom.Document getDocument()
protected  java.lang.String getStyleClassName(HSSFWorkbook workbook, HSSFCellStyle cellStyle)
 boolean isUseDivsToSpan()
static void main(java.lang.String[] args)
Java main() interface to interact with ExcelToHtmlConverter
static org.w3c.dom.Document process(java.io.File xlsFile)
Converts Excel file (97-2007) into HTML file.
protected  boolean processCell(HSSFCell cell, org.w3c.dom.Element tableCellElement, int normalWidthPx, int maxSpannedWidthPx, float normalHeightPt)
protected  void processColumnHeaders(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table)
protected  void processColumnWidths(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table)
Creates COLGROUP element with width specified for all columns.
protected  void processDocumentInformation(SummaryInformation summaryInformation)
protected  int processRow(CellRangeAddress[][] mergedRanges, HSSFRow row, org.w3c.dom.Element tableRowElement)
protected  void processRowNumber(HSSFRow row, org.w3c.dom.Element tableRowNumberCellElement)
protected  void processSheet(HSSFSheet sheet)
protected  void processSheetHeader(org.w3c.dom.Element htmlBody, HSSFSheet sheet)
 void processWorkbook(HSSFWorkbook workbook)
 void setCssClassPrefixCell(java.lang.String cssClassPrefixCell)
 void setCssClassPrefixDiv(java.lang.String cssClassPrefixDiv)
 void setCssClassPrefixRow(java.lang.String cssClassPrefixRow)
 void setCssClassPrefixTable(java.lang.String cssClassPrefixTable)
 void setUseDivsToSpan(boolean useDivsToSpan)
Allows converter to wrap content into two additional DIVs with tricky styles, so it will wrap across empty cells (like in Excel).
Methods inherited from class org.apache.poi.hssf.converter.AbstractExcelConverter
getColumnName, getColumnWidth, getDefaultColumnWidth, getFontReplacer, getRowName, isOutputColumnHeaders, isOutputHiddenColumns, isOutputHiddenRows, isOutputLeadingSpacesAsNonBreaking, isOutputRowNumbers, isTextEmpty, setFontReplacer, setOutputColumnHeaders, setOutputHiddenColumns, setOutputHiddenRows, setOutputLeadingSpacesAsNonBreaking, setOutputRowNumbers
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExcelToHtmlConverter

public ExcelToHtmlConverter(org.w3c.dom.Document doc)

ExcelToHtmlConverter

public ExcelToHtmlConverter(HtmlDocumentFacade htmlDocumentFacade)
Method Detail

main

public static void main(java.lang.String[] args)
Java main() interface to interact with ExcelToHtmlConverter

Usage: ExcelToHtmlConverter infile outfile

Where infile is an input .xls file ( Word 97-2007) which will be rendered as HTML into outfile

process

public static org.w3c.dom.Document process(java.io.File xlsFile)
                                    throws java.lang.Exception
Converts Excel file (97-2007) into HTML file.

Parameters:
xlsFile - file to process
Returns:
DOM representation of result HTML
Throws:
java.lang.Exception

buildStyle

protected java.lang.String buildStyle(HSSFWorkbook workbook,
                                      HSSFCellStyle cellStyle)

getCssClassPrefixCell

public java.lang.String getCssClassPrefixCell()

getCssClassPrefixDiv

public java.lang.String getCssClassPrefixDiv()

getCssClassPrefixRow

public java.lang.String getCssClassPrefixRow()

getCssClassPrefixTable

public java.lang.String getCssClassPrefixTable()

getDocument

public org.w3c.dom.Document getDocument()
Specified by:
getDocument in class AbstractExcelConverter

getStyleClassName

protected java.lang.String getStyleClassName(HSSFWorkbook workbook,
                                             HSSFCellStyle cellStyle)

isUseDivsToSpan

public boolean isUseDivsToSpan()

processCell

protected boolean processCell(HSSFCell cell,
                              org.w3c.dom.Element tableCellElement,
                              int normalWidthPx,
                              int maxSpannedWidthPx,
                              float normalHeightPt)

processColumnHeaders

protected void processColumnHeaders(HSSFSheet sheet,
                                    int maxSheetColumns,
                                    org.w3c.dom.Element table)

processColumnWidths

protected void processColumnWidths(HSSFSheet sheet,
                                   int maxSheetColumns,
                                   org.w3c.dom.Element table)
Creates COLGROUP element with width specified for all columns. (Except first if AbstractExcelConverter.isOutputRowNumbers()==true)

processDocumentInformation

protected void processDocumentInformation(SummaryInformation summaryInformation)

processRow

protected int processRow(CellRangeAddress[][] mergedRanges,
                         HSSFRow row,
                         org.w3c.dom.Element tableRowElement)
Returns:
maximum 1-base index of column that were rendered, zero if none

processRowNumber

protected void processRowNumber(HSSFRow row,
                                org.w3c.dom.Element tableRowNumberCellElement)

processSheet

protected void processSheet(HSSFSheet sheet)

processSheetHeader

protected void processSheetHeader(org.w3c.dom.Element htmlBody,
                                  HSSFSheet sheet)

processWorkbook

public void processWorkbook(HSSFWorkbook workbook)

setCssClassPrefixCell

public void setCssClassPrefixCell(java.lang.String cssClassPrefixCell)

setCssClassPrefixDiv

public void setCssClassPrefixDiv(java.lang.String cssClassPrefixDiv)

setCssClassPrefixRow

public void setCssClassPrefixRow(java.lang.String cssClassPrefixRow)

setCssClassPrefixTable

public void setCssClassPrefixTable(java.lang.String cssClassPrefixTable)

setUseDivsToSpan

public void setUseDivsToSpan(boolean useDivsToSpan)
Allows converter to wrap content into two additional DIVs with tricky styles, so it will wrap across empty cells (like in Excel).

Warning: after enabling this mode do not serialize result HTML with INDENT=YES option, because line breaks will make additional (unwanted) changes

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExcelToHtmlUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.converter
Class ExcelToHtmlUtils

java.lang.Object
    extended by  org.apache.poi.hssf.converter.AbstractExcelUtils
        extended by  org.apache.poi.hssf.converter.ExcelToHtmlUtils

@Beta
public class ExcelToHtmlUtils
extends AbstractExcelUtils

Constructor Summary
ExcelToHtmlUtils()
Method Summary
static void | appendAlign(java.lang.StringBuilder style, short alignment)
static CellRangeAddress[][] | buildMergedRangesMap(HSSFSheet sheet) Creates a map (i.e.
Methods inherited from class org.apache.poi.hssf.converter.AbstractExcelUtils
getAlign, getBorderStyle, getBorderWidth, getColor, getColumnWidthInPx, getMergedRange, loadXls
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExcelToHtmlUtils

public ExcelToHtmlUtils()
Method Detail

appendAlign

public static void appendAlign(java.lang.StringBuilder style,
                               short alignment)

buildMergedRangesMap

public static CellRangeAddress[][] buildMergedRangesMap(HSSFSheet sheet)
Creates a map (i.e. two-dimensional array) filled with ranges. Allow fast retrieving CellRangeAddress of any cell, if cell is contained in range.

See Also:
AbstractExcelUtils.getMergedRange(CellRangeAddress[][], int, int)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.converter
Classes
AbstractExcelConverter
AbstractExcelUtils
ExcelToFoConverter
ExcelToFoUtils
ExcelToHtmlConverter
ExcelToHtmlUtils


org.apache.poi.hssf.converter

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.converter

Class Summary
AbstractExcelConverter | Common class for ExcelToFoConverter and ExcelToHtmlConverter
AbstractExcelUtils | Common class for ExcelToFoUtils and ExcelToHtmlUtils
ExcelToFoConverter | Converts xls files (97-2007) to XSL FO.
ExcelToFoUtils |
ExcelToHtmlConverter | Converts xls files (97-2007) to HTML file.
ExcelToHtmlUtils |


org.apache.poi.hssf.converter Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.converter

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.converter.AbstractExcelConverter
      • org.apache.poi.hssf.converter.ExcelToFoConverter
      • org.apache.poi.hssf.converter.ExcelToHtmlConverter
    • org.apache.poi.hssf.converter.AbstractExcelUtils
      • org.apache.poi.hssf.converter.ExcelToFoUtils
      • org.apache.poi.hssf.converter.ExcelToHtmlUtils


Uses of Package org.apache.poi.hssf.converter

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.converter

Packages that use org.apache.poi.hssf.converter
org.apache.poi.hssf.converter

Classes in org.apache.poi.hssf.converter used by org.apache.poi.hssf.converter
AbstractExcelConverter
Common class for ExcelToFoConverter and ExcelToHtmlConverter
AbstractExcelUtils
Common class for ExcelToFoUtils and ExcelToHtmlUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.converter.AbstractExcelConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.converter.AbstractExcelConverter

Packages that use AbstractExcelConverter
org.apache.poi.hssf.converter

Uses of AbstractExcelConverter in org.apache.poi.hssf.converter

Subclasses of AbstractExcelConverter in org.apache.poi.hssf.converter
class | ExcelToFoConverter Converts xls files (97-2007) to XSL FO.
class | ExcelToHtmlConverter Converts xls files (97-2007) to HTML file.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.converter.AbstractExcelUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.converter.AbstractExcelUtils

Packages that use AbstractExcelUtils
org.apache.poi.hssf.converter

Uses of AbstractExcelUtils in org.apache.poi.hssf.converter

Subclasses of AbstractExcelUtils in org.apache.poi.hssf.converter
class | ExcelToFoUtils
class | ExcelToHtmlUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.converter.ExcelToFoConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.converter.ExcelToFoConverter

No usage of org.apache.poi.hssf.converter.ExcelToFoConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.converter.ExcelToFoUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.converter.ExcelToFoUtils

No usage of org.apache.poi.hssf.converter.ExcelToFoUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.converter.ExcelToHtmlConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.converter.ExcelToHtmlConverter

No usage of org.apache.poi.hssf.converter.ExcelToHtmlConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.converter.ExcelToHtmlUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.converter.ExcelToHtmlUtils

No usage of org.apache.poi.hssf.converter.ExcelToHtmlUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BiffViewer

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.dev
Class BiffViewer

java.lang.Object
    extended by  org.apache.poi.hssf.dev.BiffViewer

public final class BiffViewer
extends java.lang.Object

Utillity for reading in BIFF8 records and displaying data from them.

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org)
See Also:
main(java.lang.String[])

Method Summary
static Record[] | createRecords(java.io.InputStream is, java.io.PrintStream ps, org.apache.poi.hssf.dev.BiffViewer.BiffRecordListener recListener, boolean dumpInterpretedRecords) Create an array of records from an input stream
static void | main(java.lang.String[] args) Method main with 1 argument just run straight biffview against given file
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createRecords

public static Record[] createRecords(java.io.InputStream is,
                                     java.io.PrintStream ps,
                                     org.apache.poi.hssf.dev.BiffViewer.BiffRecordListener recListener,
                                     boolean dumpInterpretedRecords)
                              throws RecordFormatException
Create an array of records from an input stream

Parameters:
is - the InputStream from which the records will be obtained
Returns:
an array of Records created from the InputStream
Throws:
RecordFormatException - on error processing the InputStream

main

public static void main(java.lang.String[] args)
Method main with 1 argument just run straight biffview against given file

Usage:
BiffViewer [--biffhex] [--noint] [--noescher] [--out] <fileName>
BiffViewer --rawhex [--out] <fileName>

--biffhex | show hex dump of each BIFF record
--noint | do not output interpretation of BIFF records
--out | send output to <fileName>.out
--rawhex | output raw hex dump of whole workbook stream
--escher | turn on deserialization of escher records (default is off)
--noheader | do not print record header (default is on)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EFBiffViewer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.dev
Class EFBiffViewer

java.lang.Object
    extended by  org.apache.poi.hssf.dev.EFBiffViewer

public class EFBiffViewer
extends java.lang.Object

Author:
andy

Constructor Summary
EFBiffViewer()
Creates a new instance of EFBiffViewer
Method Summary
static void | main(java.lang.String[] args)
void | run()
void | setFile(java.lang.String file)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EFBiffViewer

public EFBiffViewer()
Creates a new instance of EFBiffViewer

Method Detail

run

public void run()
         throws java.io.IOException
Throws:
java.io.IOException

setFile

public void setFile(java.lang.String file)

main

public static void main(java.lang.String[] args)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaViewer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.dev
Class FormulaViewer

java.lang.Object
    extended by  org.apache.poi.hssf.dev.FormulaViewer

public class FormulaViewer
extends java.lang.Object

FormulaViewer - finds formulas in a BIFF8 file and attempts to read them/display data from them. Only works if Formulas are enabled in "RecordFactory"

Author:
andy, Avik

Constructor Summary
FormulaViewer()
Creates new FormulaViewer
Method Summary
static void | main(java.lang.String[] args) Method main pass me a filename and I'll try and parse the formulas from it
void | parseFormulaRecord(FormulaRecord record) Method parseFormulaRecord
void | run() Method run
void | setFile(java.lang.String file) Method setFile
void | setList(boolean list)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormulaViewer

public FormulaViewer()
Creates new FormulaViewer

Method Detail

run

public void run()
         throws java.lang.Exception
Method run

Throws:
java.lang.Exception

parseFormulaRecord

public void parseFormulaRecord(FormulaRecord record)
Method parseFormulaRecord

Parameters:
record -

setFile

public void setFile(java.lang.String file)
Method setFile

Parameters:
file -

setList

public void setList(boolean list)

main

public static void main(java.lang.String[] args)
Method main pass me a filename and I'll try and parse the formulas from it

Parameters:
args - pass one argument with the filename or --help
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.dev
Classes
BiffViewer
EFBiffViewer
FormulaViewer
RecordLister


org.apache.poi.hssf.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.dev

DEV package serves two purposes.

See:
Description

Class Summary
BiffViewer | Utillity for reading in BIFF8 records and displaying data from them.
EFBiffViewer |
FormulaViewer | FormulaViewer - finds formulas in a BIFF8 file and attempts to read them/display data from them.
RecordLister | This is a low-level debugging class, which simply prints out what records come in what order.

Package org.apache.poi.hssf.dev Description

DEV package serves two purposes. 1. Examples for how to use HSSF and 2. tools for developing and validating HSSF.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.hssf.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.dev.BiffViewer
    • org.apache.poi.hssf.dev.EFBiffViewer
    • org.apache.poi.hssf.dev.FormulaViewer
    • org.apache.poi.hssf.dev.RecordLister


Uses of Package org.apache.poi.hssf.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.dev

No usage of org.apache.poi.hssf.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RecordLister

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.dev
Class RecordLister

java.lang.Object
    extended by  org.apache.poi.hssf.dev.RecordLister

public class RecordLister
extends java.lang.Object

This is a low-level debugging class, which simply prints out what records come in what order. Most people will want to use BiffViewer or EFBiffViewer, but this can be handy when trying to make sense of ContinueRecord special cases. Output is of the form: SID - Length - Type (if known) byte0 byte1 byte2 byte3 .... byte(n-4) byte(n-3) byte(n-2) byte(n-1)

Constructor Summary
RecordLister()
Method Summary
static void | main(java.lang.String[] args)
void | run()
void | setFile(java.lang.String file)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordLister

public RecordLister()
Method Detail

run

public void run()
         throws java.io.IOException
Throws:
java.io.IOException

setFile

public void setFile(java.lang.String file)

main

public static void main(java.lang.String[] args)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.dev.BiffViewer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.dev.BiffViewer

No usage of org.apache.poi.hssf.dev.BiffViewer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.dev.EFBiffViewer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.dev.EFBiffViewer

No usage of org.apache.poi.hssf.dev.EFBiffViewer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.dev.FormulaViewer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.dev.FormulaViewer

No usage of org.apache.poi.hssf.dev.FormulaViewer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.dev.RecordLister

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.dev.RecordLister

No usage of org.apache.poi.hssf.dev.RecordLister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ERFListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventmodel
Interface ERFListener

public interface ERFListener

An ERFListener is registered with the EventRecordFactory. An ERFListener listens for Records coming from the stream via the EventRecordFactory

Author:
Andrew C. Oliver acoliver@apache.org
See Also:
EventRecordFactory

Method Summary
 boolean processRecord(Record rec)
Process a Record.

Method Detail

processRecord

boolean processRecord(Record rec)
Process a Record. This method is called by the EventRecordFactory when a record is returned.

Returns:
boolean specifying whether the effort was a success.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EventRecordFactory

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventmodel
Class EventRecordFactory

java.lang.Object
    extended by  org.apache.poi.hssf.eventmodel.EventRecordFactory

public final class EventRecordFactory
extends java.lang.Object

Event-based record factory. As opposed to RecordFactory this version sends ERFListener.processRecord(Record) messages to the supplied listener. Record notifications are sent one record behind to ensure that ContinueRecords are processed first.

Author:
Andrew C. Oliver (acoliver@apache.org) - probably to blame for the bugs (so yank his chain on the list), Marc Johnson (mjohnson at apache dot org) - methods taken from RecordFactory, Glen Stampoultzis (glens at apache.org) - methods taken from RecordFactory, Csaba Nagy (ncsaba at yahoo dot com)

Constructor Summary
EventRecordFactory(ERFListener listener, short[] sids)
Method Summary
 void processRecords(java.io.InputStream in)
Create an array of records from an input stream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EventRecordFactory

public EventRecordFactory(ERFListener listener,
                          short[] sids)
Parameters:
sids - an array of Record.sid values identifying the records the listener will work with. Alternatively if this is "null" then all records are passed. For all 'known' record types use RecordFactory.getAllKnownRecordSIDs()
Method Detail

processRecords

public void processRecords(java.io.InputStream in)
                    throws RecordFormatException
Create an array of records from an input stream

Parameters:
in - the InputStream from which the records will be obtained
Throws:
RecordFormatException - on error processing the InputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.eventmodel
Interfaces
ERFListener
Classes
EventRecordFactory


org.apache.poi.hssf.eventmodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.eventmodel

Interface Summary
ERFListener An ERFListener is registered with the EventRecordFactory.

Class Summary
EventRecordFactory Event-based record factory.


org.apache.poi.hssf.eventmodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.eventmodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.eventmodel.EventRecordFactory

Interface Hierarchy

  • org.apache.poi.hssf.eventmodel.ERFListener


Uses of Package org.apache.poi.hssf.eventmodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.eventmodel

Packages that use org.apache.poi.hssf.eventmodel
org.apache.poi.hssf.eventmodel

Classes in org.apache.poi.hssf.eventmodel used by org.apache.poi.hssf.eventmodel
ERFListener
An ERFListener is registered with the EventRecordFactory.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.eventmodel.ERFListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.eventmodel.ERFListener

Packages that use ERFListener
org.apache.poi.hssf.eventmodel

Uses of ERFListener in org.apache.poi.hssf.eventmodel

Constructors in org.apache.poi.hssf.eventmodel with parameters of type ERFListener
EventRecordFactory(ERFListener listener, short[] sids)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventmodel.EventRecordFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventmodel.EventRecordFactory

No usage of org.apache.poi.hssf.eventmodel.EventRecordFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbortableHSSFListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class AbortableHSSFListener

java.lang.Object
    extended by  org.apache.poi.hssf.eventusermodel.AbortableHSSFListener
All Implemented Interfaces:
HSSFListener
public abstract class AbortableHSSFListener
extends java.lang.Object
implements HSSFListener

Abstract class for use with the HSSFRequest and HSSFEventFactory, which allows for the halting of processing. Users should create subclass of this (which implements the usual HSSFListener), and then override the #abortableProcessRecord(Record) method to do their processing. This should then be registered with the HSSFRequest (associating it with Record SID's) as usual.

Author:
Carey Sublette (careysub@earthling.net)
See Also:
HSSFEventFactory, HSSFRequest, HSSFUserException

Constructor Summary
AbortableHSSFListener()
Method Summary
abstract short | abortableProcessRecord(Record record) Process an HSSF Record.
void | processRecord(Record record) This method, inherited from HSSFListener is implemented as a stub.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbortableHSSFListener

public AbortableHSSFListener()
Method Detail

processRecord

public void processRecord(Record record)
This method, inherited from HSSFListener is implemented as a stub. It is never called by HSSFEventFactory or HSSFRequest. You should implement #abortableProcessRecord instead

Specified by:
processRecord in interface HSSFListener

abortableProcessRecord

public abstract short abortableProcessRecord(Record record)
                                      throws HSSFUserException
Process an HSSF Record. Called when a record occurs in an HSSF file. Provides two options for halting the processing of the HSSF file. The return value provides a means of non-error termination with a user-defined result code. A value of zero must be returned to continue processing, any other value will halt processing by HSSFEventFactory with the code being passed back by its abortable process events methods. Error termination can be done by throwing the HSSFUserException. Note that HSSFEventFactory will not call the inherited process

Returns:
result code of zero for continued processing.
Throws:
HSSFUserException - User code can throw this to abort file processing by HSSFEventFactory and return diagnostic information.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EventWorkbookBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class EventWorkbookBuilder

java.lang.Object
    extended by  org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder

public class EventWorkbookBuilder
extends java.lang.Object

When working with the EventUserModel, if you want to process formulas, you need an instance of InternalWorkbook to pass to a HSSFWorkbook, to finally give to HSSFFormulaParser, and this will build you stub ones. Since you're working with the EventUserModel, you wouldn't want to get a full InternalWorkbook and HSSFWorkbook, as they would eat too much memory. Instead, you should collect a few key records as they go past, then call this once you have them to build a stub InternalWorkbook, and from that a stub HSSFWorkbook, to use with the HSSFFormulaParser. The records you should collect are: * ExternSheetRecord * BoundSheetRecord You should probably also collect SSTRecord, but it's not required to pass this in. To help, this class includes a HSSFListener wrapper that will do the collecting for you.

Nested Class Summary
static class EventWorkbookBuilder.SheetRecordCollectingListener
A wrapping HSSFListener which will collect BoundSheetRecords and ExternSheetRecords as they go past, so you can create a Stub InternalWorkbook from them once required.
Constructor Summary
EventWorkbookBuilder()
Method Summary
static InternalWorkbook | createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds) Creates a stub workbook from the supplied records, suitable for use with the HSSFFormulaParser
static InternalWorkbook | createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds, SSTRecord sst) Creates a stub Workbook from the supplied records, suitable for use with the HSSFFormulaParser
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EventWorkbookBuilder

public EventWorkbookBuilder()
Method Detail

createStubWorkbook

public static InternalWorkbook createStubWorkbook(ExternSheetRecord[] externs,
                                                  BoundSheetRecord[] bounds,
                                                  SSTRecord sst)
Creates a stub Workbook from the supplied records, suitable for use with the HSSFFormulaParser

Parameters:
externs - The ExternSheetRecords in your file
bounds - The BoundSheetRecords in your file
sst - The SSTRecord in your file.
Returns:
A stub Workbook suitable for use with HSSFFormulaParser

createStubWorkbook

public static InternalWorkbook createStubWorkbook(ExternSheetRecord[] externs,
                                                  BoundSheetRecord[] bounds)
Creates a stub workbook from the supplied records, suitable for use with the HSSFFormulaParser

Parameters:
externs - The ExternSheetRecords in your file
bounds - The BoundSheetRecords in your file
Returns:
A stub Workbook suitable for use with HSSFFormulaParser
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EventWorkbookBuilder.SheetRecordCollectingListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class EventWorkbookBuilder.SheetRecordCollectingListener

java.lang.Object
    extended by  org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener
All Implemented Interfaces:
HSSFListener
Enclosing class:
EventWorkbookBuilder
public static class EventWorkbookBuilder.SheetRecordCollectingListener
extends java.lang.Object
implements HSSFListener

A wrapping HSSFListener which will collect BoundSheetRecords and ExternSheetRecords as they go past, so you can create a Stub InternalWorkbook from them once required.

Constructor Summary
EventWorkbookBuilder.SheetRecordCollectingListener(HSSFListener childListener)
Method Summary
BoundSheetRecord[] | getBoundSheetRecords()
ExternSheetRecord[] | getExternSheetRecords()
SSTRecord | getSSTRecord()
HSSFWorkbook | getStubHSSFWorkbook()
InternalWorkbook | getStubWorkbook()
void | processRecord(Record record) Process this record ourselves, and then pass it on to our child listener
void | processRecordInternally(Record record) Process the record ourselves, but do not pass it on to the child Listener.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EventWorkbookBuilder.SheetRecordCollectingListener

public EventWorkbookBuilder.SheetRecordCollectingListener(HSSFListener childListener)
Method Detail

getBoundSheetRecords

public BoundSheetRecord[] getBoundSheetRecords()

getExternSheetRecords

public ExternSheetRecord[] getExternSheetRecords()

getSSTRecord

public SSTRecord getSSTRecord()

getStubHSSFWorkbook

public HSSFWorkbook getStubHSSFWorkbook()

getStubWorkbook

public InternalWorkbook getStubWorkbook()

processRecord

public void processRecord(Record record)
Process this record ourselves, and then pass it on to our child listener

Specified by:
processRecord in interface HSSFListener

processRecordInternally

public void processRecordInternally(Record record)
Process the record ourselves, but do not pass it on to the child Listener.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormatTrackingHSSFListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class FormatTrackingHSSFListener

java.lang.Object
    extended by  org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener
All Implemented Interfaces:
HSSFListener
public class FormatTrackingHSSFListener
extends java.lang.Object
implements HSSFListener

A proxy HSSFListener that keeps track of the document formatting records, and provides an easy way to look up the format strings used by cells from their ids.

Constructor Summary
FormatTrackingHSSFListener(HSSFListener childListener)
Creates a format tracking wrapper around the given listener, using the default locale for the formats.
FormatTrackingHSSFListener(HSSFListener childListener, java.util.Locale locale)
Creates a format tracking wrapper around the given listener, using the given locale for the formats.
Method Summary
java.lang.String | formatNumberDateCell(CellValueRecordInterface cell) Formats the given numeric of date Cell's contents as a String, in as close as we can to the way that Excel would do so.
int | getFormatIndex(CellValueRecordInterface cell) Returns the index of the format string, used by your cell, or -1 if none found
java.lang.String | getFormatString(CellValueRecordInterface cell) Returns the format string, eg $##.##, used by your cell
java.lang.String | getFormatString(int formatIndex) Returns the format string, eg $##.##, for the given number format index.
protected int | getNumberOfCustomFormats()
protected int | getNumberOfExtendedFormats()
void | processRecord(Record record) Process this record ourselves, and then pass it on to our child listener
void | processRecordInternally(Record record) Process the record ourselves, but do not pass it on to the child Listener.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormatTrackingHSSFListener

public FormatTrackingHSSFListener(HSSFListener childListener)
Creates a format tracking wrapper around the given listener, using the default locale for the formats.

FormatTrackingHSSFListener

public FormatTrackingHSSFListener(HSSFListener childListener,
                                  java.util.Locale locale)
Creates a format tracking wrapper around the given listener, using the given locale for the formats.

Method Detail

getNumberOfCustomFormats

protected int getNumberOfCustomFormats()

getNumberOfExtendedFormats

protected int getNumberOfExtendedFormats()

processRecord

public void processRecord(Record record)
Process this record ourselves, and then pass it on to our child listener

Specified by:
processRecord in interface HSSFListener

processRecordInternally

public void processRecordInternally(Record record)
Process the record ourselves, but do not pass it on to the child Listener.

Parameters:
record -

formatNumberDateCell

public java.lang.String formatNumberDateCell(CellValueRecordInterface cell)
Formats the given numeric of date Cell's contents as a String, in as close as we can to the way that Excel would do so. Uses the various format records to manage this. TODO - move this to a central class in such a way that hssf.usermodel can make use of it too

getFormatString

public java.lang.String getFormatString(int formatIndex)
Returns the format string, eg $##.##, for the given number format index.

getFormatString

public java.lang.String getFormatString(CellValueRecordInterface cell)
Returns the format string, eg $##.##, used by your cell

getFormatIndex

public int getFormatIndex(CellValueRecordInterface cell)
Returns the index of the format string, used by your cell, or -1 if none found

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFEventFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class HSSFEventFactory

java.lang.Object
    extended by  org.apache.poi.hssf.eventusermodel.HSSFEventFactory

public class HSSFEventFactory
extends java.lang.Object

Low level event based HSSF reader. Pass either a DocumentInputStream to process events along with a request object or pass a POIFS POIFSFileSystem to processWorkbookEvents along with a request. This will cause your file to be processed a record at a time. Each record with a static id matching one that you have registered in your HSSFRequest will be passed to your associated HSSFListener.

Author:
Andrew C. Oliver (acoliver at apache dot org), Carey Sublette (careysub@earthling.net)

Constructor Summary
HSSFEventFactory()
Creates a new instance of HSSFEventFactory
Method Summary
short | abortableProcessEvents(HSSFRequest req, java.io.InputStream in) Processes a DocumentInputStream into essentially Record events.
short | abortableProcessWorkbookEvents(HSSFRequest req, DirectoryNode dir) Processes a file into essentially record events.
short | abortableProcessWorkbookEvents(HSSFRequest req, POIFSFileSystem fs) Processes a file into essentially record events.
void | processEvents(HSSFRequest req, java.io.InputStream in) Processes a DocumentInputStream into essentially Record events.
void | processWorkbookEvents(HSSFRequest req, DirectoryNode dir) Processes a file into essentially record events.
void | processWorkbookEvents(HSSFRequest req, POIFSFileSystem fs) Processes a file into essentially record events.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFEventFactory

public HSSFEventFactory()
Creates a new instance of HSSFEventFactory

Method Detail

processWorkbookEvents

public void processWorkbookEvents(HSSFRequest req,
                                  POIFSFileSystem fs)
                           throws java.io.IOException
Processes a file into essentially record events.

Parameters:
req - an Instance of HSSFRequest which has your registered listeners
fs - a POIFS filesystem containing your workbook
Throws:
java.io.IOException

processWorkbookEvents

public void processWorkbookEvents(HSSFRequest req,
                                  DirectoryNode dir)
                           throws java.io.IOException
Processes a file into essentially record events.

Parameters:
req - an Instance of HSSFRequest which has your registered listeners
dir - a DirectoryNode containing your workbook
Throws:
java.io.IOException

abortableProcessWorkbookEvents

public short abortableProcessWorkbookEvents(HSSFRequest req,
                                            POIFSFileSystem fs)
                                     throws java.io.IOException,
                                            HSSFUserException
Processes a file into essentially record events.

Parameters:
req - an Instance of HSSFRequest which has your registered listeners
fs - a POIFS filesystem containing your workbook
Returns:
numeric user-specified result code.
Throws:
java.io.IOException
HSSFUserException

abortableProcessWorkbookEvents

public short abortableProcessWorkbookEvents(HSSFRequest req,
                                            DirectoryNode dir)
                                     throws java.io.IOException,
                                            HSSFUserException
Processes a file into essentially record events.

Parameters:
req - an Instance of HSSFRequest which has your registered listeners
dir - a DirectoryNode containing your workbook
Returns:
numeric user-specified result code.
Throws:
java.io.IOException
HSSFUserException

processEvents

public void processEvents(HSSFRequest req,
                          java.io.InputStream in)
Processes a DocumentInputStream into essentially Record events. If an AbortableHSSFListener causes a halt to processing during this call the method will return just as with abortableProcessEvents, but no user code or HSSFUserException will be passed back.

Parameters:
req - an Instance of HSSFRequest which has your registered listeners
in - a DocumentInputStream obtained from POIFS's POIFSFileSystem object
See Also:
POIFSFileSystem.createDocumentInputStream(String)

abortableProcessEvents

public short abortableProcessEvents(HSSFRequest req,
                                    java.io.InputStream in)
                             throws HSSFUserException
Processes a DocumentInputStream into essentially Record events.

Parameters:
req - an Instance of HSSFRequest which has your registered listeners
in - a DocumentInputStream obtained from POIFS's POIFSFileSystem object
Returns:
numeric user-specified result code.
Throws:
HSSFUserException
See Also:
POIFSFileSystem.createDocumentInputStream(String)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Interface HSSFListener

All Known Implementing Classes:
AbortableHSSFListener, EventWorkbookBuilder.SheetRecordCollectingListener, FormatTrackingHSSFListener, MissingRecordAwareHSSFListener
public interface HSSFListener

Interface for use with the HSSFRequest and HSSFEventFactory. Users should create a listener supporting this interface and register it with the HSSFRequest (associating it with Record SID's).

Author:
acoliver@apache.org
See Also:
HSSFEventFactory, HSSFRequest

Method Summary
 void processRecord(Record record)
process an HSSF Record.

Method Detail

processRecord

void processRecord(Record record)
process an HSSF Record. Called when a record occurs in an HSSF file.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFRequest

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class HSSFRequest

java.lang.Object
    extended by  org.apache.poi.hssf.eventusermodel.HSSFRequest

public class HSSFRequest
extends java.lang.Object

An HSSFRequest object should be constructed registering an instance or multiple instances of HSSFListener with each Record.sid you wish to listen for.

Author:
Andrew C. Oliver (acoliver at apache dot org), Carey Sublette (careysub@earthling.net)
See Also:
HSSFEventFactory, HSSFListener, HSSFUserException

Constructor Summary
HSSFRequest()
Creates a new instance of HSSFRequest
Method Summary
void | addListener(HSSFListener lsnr, short sid) add an event listener for a particular record type.
void | addListenerForAllRecords(HSSFListener lsnr) This is the equivalent of calling addListener(myListener, sid) for EVERY record in the org.apache.poi.hssf.record package.
protected short | processRecord(Record rec) Called by HSSFEventFactory, passes the Record to each listener associated with a record.sid.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFRequest

public HSSFRequest()
Creates a new instance of HSSFRequest

Method Detail

addListener

public void addListener(HSSFListener lsnr,
                        short sid)
add an event listener for a particular record type. The trick is you have to know what the records are for or just start with our examples and build on them. Alternatively, you CAN call addListenerForAllRecords and you'll receive ALL record events in one listener, but if you like to squeeze every last byte of efficiency out of life you my not like this. (its sure as heck what I plan to do)

Parameters:
lsnr - for the event
sid - identifier for the record type this is the .sid static member on the individual records for example req.addListener(myListener, BOFRecord.sid)
See Also:
addListenerForAllRecords(HSSFListener)

addListenerForAllRecords

public void addListenerForAllRecords(HSSFListener lsnr)
This is the equivalent of calling addListener(myListener, sid) for EVERY record in the org.apache.poi.hssf.record package. This is for lazy people like me. You can call this more than once with more than one listener, but that seems like a bad thing to do from a practice-perspective unless you have a compelling reason to do so (like maybe you send the event two places or log it or something?).

Parameters:
lsnr - a single listener to associate with ALL records

processRecord

protected short processRecord(Record rec)
                       throws HSSFUserException
Called by HSSFEventFactory, passes the Record to each listener associated with a record.sid. Exception and return value added 2002-04-19 by Carey Sublette

Returns:
numeric user-specified result code. If zero continue processing.
Throws:
HSSFUserException - User exception condition
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFUserException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class HSSFUserException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.hssf.eventusermodel.HSSFUserException
All Implemented Interfaces:
java.io.Serializable
public class HSSFUserException
extends java.lang.Exception

This exception is provided as a way for API users to throw exceptions from their event handling code. By doing so they abort file processing by the HSSFEventFactory and by catching it from outside the HSSFEventFactory.processEvents method they can diagnose the cause for the abort.

The HSSFUserException supports a nested "reason" throwable, i.e. an exception that caused this one to be thrown.

The HSSF package does not itself throw any of these exceptions.

Since:
2002-04-19
Version:
HSSFUserException.java,v 1.0
Author:
Rainer Klute (klute@rainer-klute.de), Carey Sublette (careysub@earthling.net)
See Also:
Serialized Form

Constructor Summary
HSSFUserException()
Creates a new HSSFUserException.
HSSFUserException(java.lang.String msg)
Creates a new HSSFUserException with a message string.
HSSFUserException(java.lang.String msg, java.lang.Throwable reason)
Creates a new HSSFUserException with a message string and a reason.
HSSFUserException(java.lang.Throwable reason)
Creates a new HSSFUserException with a reason.
Method Summary
 java.lang.Throwable getReason()
Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HSSFUserException

public HSSFUserException()

Creates a new HSSFUserException.

HSSFUserException

public HSSFUserException(java.lang.String msg)

Creates a new HSSFUserException with a message string.

HSSFUserException

public HSSFUserException(java.lang.Throwable reason)

Creates a new HSSFUserException with a reason.

HSSFUserException

public HSSFUserException(java.lang.String msg,
                         java.lang.Throwable reason)

Creates a new HSSFUserException with a message string and a reason.

Method Detail

getReason

public java.lang.Throwable getReason()

Returns the Throwable that caused this exception to be thrown or null if there was no such Throwable.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MissingRecordAwareHSSFListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel
Class MissingRecordAwareHSSFListener

java.lang.Object
    extended by  org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener
All Implemented Interfaces:
HSSFListener
public final class MissingRecordAwareHSSFListener
extends java.lang.Object
implements HSSFListener

A HSSFListener which tracks rows and columns, and will trigger your HSSFListener for all rows and cells, even the ones that aren't actually stored in the file.

This allows your code to have a more "Excel" like view of the data in the file, and not have to worry (as much) about if a particular row/cell is in the file, or was skipped from being written as it was blank.

Constructor Summary
MissingRecordAwareHSSFListener(HSSFListener listener)
Constructs a new MissingRecordAwareHSSFListener, which will fire processRecord on the supplied child HSSFListener for all Records, and missing records.
Method Summary
 void processRecord(Record record)
process an HSSF Record.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MissingRecordAwareHSSFListener

public MissingRecordAwareHSSFListener(HSSFListener listener)
Constructs a new MissingRecordAwareHSSFListener, which will fire processRecord on the supplied child HSSFListener for all Records, and missing records.

Parameters:
listener - The HSSFListener to pass records on to
Method Detail

processRecord

public void processRecord(Record record)
Description copied from interface: HSSFListener
process an HSSF Record. Called when a record occurs in an HSSF file.

Specified by:
processRecord in interface HSSFListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.eventusermodel
Interfaces
HSSFListener
Classes
AbortableHSSFListener
EventWorkbookBuilder
EventWorkbookBuilder.SheetRecordCollectingListener
FormatTrackingHSSFListener
HSSFEventFactory
HSSFRequest
MissingRecordAwareHSSFListener
Exceptions
HSSFUserException


org.apache.poi.hssf.eventusermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.eventusermodel

HSSF eventmodel Package provides an event-based API for reading HSSF files.

See:
Description

Interface Summary
HSSFListener Interface for use with the HSSFRequest and HSSFEventFactory.

Class Summary
AbortableHSSFListener | Abstract class for use with the HSSFRequest and HSSFEventFactory, which allows for the halting of processing.
EventWorkbookBuilder | When working with the EventUserModel, if you want to process formulas, you need an instance of InternalWorkbook to pass to a HSSFWorkbook, to finally give to HSSFFormulaParser, and this will build you stub ones.
EventWorkbookBuilder.SheetRecordCollectingListener | A wrapping HSSFListener which will collect BoundSheetRecords and ExternSheetRecords as they go past, so you can create a Stub InternalWorkbook from them once required.
FormatTrackingHSSFListener | A proxy HSSFListener that keeps track of the document formatting records, and provides an easy way to look up the format strings used by cells from their ids.
HSSFEventFactory | Low level event based HSSF reader.
HSSFRequest | An HSSFRequest object should be constructed registering an instance or multiple instances of HSSFListener with each Record.sid you wish to listen for.
MissingRecordAwareHSSFListener | A HSSFListener which tracks rows and columns, and will trigger your HSSFListener for all rows and cells, even the ones that aren't actually stored in the file.

Exception Summary
HSSFUserException This exception is provided as a way for API users to throw exceptions from their event handling code.

Package org.apache.poi.hssf.eventusermodel Description

HSSF eventmodel Package provides an event-based API for reading HSSF files.

Related Documentation

The event model can reald XLS files with a very small memory footprint. For writing you still have to use the usermodel. The eventmodel is to the usermodel what SAX is to DOM. For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.hssf.usermodel, org.apache.poi.hssf.record


org.apache.poi.hssf.eventusermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.eventusermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.eventusermodel.AbortableHSSFListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder
    • org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • org.apache.poi.hssf.eventusermodel.HSSFEventFactory
    • org.apache.poi.hssf.eventusermodel.HSSFRequest
    • org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener (implements org.apache.poi.hssf.eventusermodel.HSSFListener)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.hssf.eventusermodel.HSSFUserException

Interface Hierarchy

  • org.apache.poi.hssf.eventusermodel.HSSFListener


Uses of Package org.apache.poi.hssf.eventusermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.eventusermodel

Packages that use org.apache.poi.hssf.eventusermodel
org.apache.poi.hssf.eventusermodel HSSF eventmodel Package provides an event-based API for reading HSSF files.

Classes in org.apache.poi.hssf.eventusermodel used by org.apache.poi.hssf.eventusermodel
HSSFListener
Interface for use with the HSSFRequest and HSSFEventFactory.
HSSFRequest
An HSSFRequest object should be constructed registering an instance or multiple instances of HSSFListener with each Record.sid you wish to listen for.
HSSFUserException
This exception is provided as a way for API users to throw exceptions from their event handling code.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.AbortableHSSFListener

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.AbortableHSSFListener

No usage of org.apache.poi.hssf.eventusermodel.AbortableHSSFListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder

No usage of org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

No usage of org.apache.poi.hssf.eventusermodel.EventWorkbookBuilder.SheetRecordCollectingListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener

No usage of org.apache.poi.hssf.eventusermodel.FormatTrackingHSSFListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.HSSFEventFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.HSSFEventFactory

No usage of org.apache.poi.hssf.eventusermodel.HSSFEventFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.eventusermodel.HSSFListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.eventusermodel.HSSFListener

Packages that use HSSFListener
org.apache.poi.hssf.eventusermodel HSSF eventmodel Package provides an event-based API for reading HSSF files.

Uses of HSSFListener in org.apache.poi.hssf.eventusermodel

Classes in org.apache.poi.hssf.eventusermodel that implement HSSFListener
class | AbortableHSSFListener Abstract class for use with the HSSFRequest and HSSFEventFactory, which allows for the halting of processing.
static class | EventWorkbookBuilder.SheetRecordCollectingListener A wrapping HSSFListener which will collect BoundSheetRecords and ExternSheetRecords as they go past, so you can create a Stub InternalWorkbook from them once required.
class | FormatTrackingHSSFListener A proxy HSSFListener that keeps track of the document formatting records, and provides an easy way to look up the format strings used by cells from their ids.
class | MissingRecordAwareHSSFListener A HSSFListener which tracks rows and columns, and will trigger your HSSFListener for all rows and cells, even the ones that aren't actually stored in the file.

Methods in org.apache.poi.hssf.eventusermodel with parameters of type HSSFListener
 void HSSFRequest.addListener(HSSFListener lsnr, short sid)
add an event listener for a particular record type.
 void HSSFRequest.addListenerForAllRecords(HSSFListener lsnr)
This is the equivalent of calling addListener(myListener, sid) for EVERY record in the org.apache.poi.hssf.record package.

Constructors in org.apache.poi.hssf.eventusermodel with parameters of type HSSFListener
EventWorkbookBuilder.SheetRecordCollectingListener(HSSFListener childListener)
FormatTrackingHSSFListener(HSSFListener childListener)
Creates a format tracking wrapper around the given listener, using the default locale for the formats.
FormatTrackingHSSFListener(HSSFListener childListener, java.util.Locale locale)
Creates a format tracking wrapper around the given listener, using the given locale for the formats.
MissingRecordAwareHSSFListener(HSSFListener listener)
Constructs a new MissingRecordAwareHSSFListener, which will fire processRecord on the supplied child HSSFListener for all Records, and missing records.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.HSSFRequest

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.HSSFRequest

Packages that use HSSFRequest
org.apache.poi.hssf.eventusermodel HSSF eventmodel Package provides an event-based API for reading HSSF files.

Uses of HSSFRequest in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel with parameters of type HSSFRequest
short | HSSFEventFactory.abortableProcessEvents(HSSFRequest req, java.io.InputStream in) Processes a DocumentInputStream into essentially Record events.
short | HSSFEventFactory.abortableProcessWorkbookEvents(HSSFRequest req, DirectoryNode dir) Processes a file into essentially record events.
short | HSSFEventFactory.abortableProcessWorkbookEvents(HSSFRequest req, POIFSFileSystem fs) Processes a file into essentially record events.
void | HSSFEventFactory.processEvents(HSSFRequest req, java.io.InputStream in) Processes a DocumentInputStream into essentially Record events.
void | HSSFEventFactory.processWorkbookEvents(HSSFRequest req, DirectoryNode dir) Processes a file into essentially record events.
void | HSSFEventFactory.processWorkbookEvents(HSSFRequest req, POIFSFileSystem fs) Processes a file into essentially record events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.HSSFUserException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.HSSFUserException

Packages that use HSSFUserException
org.apache.poi.hssf.eventusermodel HSSF eventmodel Package provides an event-based API for reading HSSF files.

Uses of HSSFUserException in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel that throw HSSFUserException
short | HSSFEventFactory.abortableProcessEvents(HSSFRequest req, java.io.InputStream in) Processes a DocumentInputStream into essentially Record events.
abstract short | AbortableHSSFListener.abortableProcessRecord(Record record) Process an HSSF Record.
short | HSSFEventFactory.abortableProcessWorkbookEvents(HSSFRequest req, DirectoryNode dir) Processes a file into essentially record events.
short | HSSFEventFactory.abortableProcessWorkbookEvents(HSSFRequest req, POIFSFileSystem fs) Processes a file into essentially record events.
protected short | HSSFRequest.processRecord(Record rec) Called by HSSFEventFactory, passes the Record to each listener associated with a record.sid.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener

No usage of org.apache.poi.hssf.eventusermodel.MissingRecordAwareHSSFListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


LastCellOfRowDummyRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel.dummyrecord
Class LastCellOfRowDummyRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord

public final class LastCellOfRowDummyRecord
extends Record

A dummy record to indicate that we've now had the last cell record for this row.

Constructor Summary
LastCellOfRowDummyRecord(int row, int lastColumnNumber)
Method Summary
int | getLastColumnNumber() Returns the (0 based) number of the last column seen for this row.
int | getRecordSize() gives the current serialized size of the record.
int | getRow() Returns the (0 based) number of the row we are currently working on.
short | getSid() return the non static version of the id for this record.
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LastCellOfRowDummyRecord

public LastCellOfRowDummyRecord(int row,
                                int lastColumnNumber)
Method Detail

getRow

public int getRow()
Returns the (0 based) number of the row we are currently working on.

getLastColumnNumber

public int getLastColumnNumber()
Returns the (0 based) number of the last column seen for this row. You should have already been called with that record. This is -1 in the case of there being no columns for the row.

getSid

public final short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public int serialize(int offset,
                     byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getRecordSize

public final int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MissingCellDummyRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel.dummyrecord
Class MissingCellDummyRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord

public final class MissingCellDummyRecord
extends Record

A dummy record for when we're missing a cell in a row, but still want to trigger something

Constructor Summary
MissingCellDummyRecord(int row, int column)
Method Summary
int | getColumn()
int | getRecordSize() gives the current serialized size of the record.
int | getRow()
short | getSid() return the non static version of the id for this record.
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MissingCellDummyRecord

public MissingCellDummyRecord(int row,
                              int column)
Method Detail

getRow

public int getRow()

getColumn

public int getColumn()

getSid

public final short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public int serialize(int offset,
                     byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getRecordSize

public final int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MissingRowDummyRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.eventusermodel.dummyrecord
Class MissingRowDummyRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord

public final class MissingRowDummyRecord
extends Record

A dummy record for when we're missing a row, but still want to trigger something

Constructor Summary
MissingRowDummyRecord(int rowNumber)
Method Summary
int | getRecordSize() gives the current serialized size of the record.
int | getRowNumber()
short | getSid() return the non static version of the id for this record.
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MissingRowDummyRecord

public MissingRowDummyRecord(int rowNumber)
Method Detail

getRowNumber

public int getRowNumber()

getSid

public final short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public int serialize(int offset,
                     byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getRecordSize

public final int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.eventusermodel.dummyrecord
Classes
LastCellOfRowDummyRecord
MissingCellDummyRecord
MissingRowDummyRecord


org.apache.poi.hssf.eventusermodel.dummyrecord

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.eventusermodel.dummyrecord

Class Summary
LastCellOfRowDummyRecord | A dummy record to indicate that we've now had the last cell record for this row.
MissingCellDummyRecord | A dummy record for when we're missing a cell in a row, but still want to trigger something
MissingRowDummyRecord | A dummy record for when we're missing a row, but still want to trigger something


org.apache.poi.hssf.eventusermodel.dummyrecord Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.eventusermodel.dummyrecord

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.RecordBase
      • org.apache.poi.hssf.record.Record
        • org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord
        • org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord
        • org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord


Uses of Package org.apache.poi.hssf.eventusermodel.dummyrecord

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.eventusermodel.dummyrecord

No usage of org.apache.poi.hssf.eventusermodel.dummyrecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord

No usage of org.apache.poi.hssf.eventusermodel.dummyrecord.LastCellOfRowDummyRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord

No usage of org.apache.poi.hssf.eventusermodel.dummyrecord.MissingCellDummyRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord

No usage of org.apache.poi.hssf.eventusermodel.dummyrecord.MissingRowDummyRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


EventBasedExcelExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.extractor
Class EventBasedExcelExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hssf.extractor.EventBasedExcelExtractor

public class EventBasedExcelExtractor
extends POIOLE2TextExtractor

A text extractor for Excel files, that is based on the hssf eventusermodel api. It will typically use less memory than ExcelExtractor, but may not provide the same richness of formatting. Returns the textual content of the file, suitable for indexing by something like Lucene, but not really intended for display to the user.

To turn an excel file into a CSV or similar, then see the XLS2CSVmra example

http://svn.apache.org/repos/asf/poi/trunk/src/examples/src/org/apache/poi/hssf/eventusermodel/examples/XLS2CSVmra.java

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
EventBasedExcelExtractor(DirectoryNode dir)
EventBasedExcelExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use EventBasedExcelExtractor(DirectoryNode) instead
EventBasedExcelExtractor(POIFSFileSystem fs)
Method Summary
 DocumentSummaryInformation getDocSummaryInformation()
Would return the document information metadata for the document, if we supported it
 POIFSFileSystem getFileSystem()
Deprecated. Use POIOLE2TextExtractor.getRoot() instead
 SummaryInformation getSummaryInformation()
Would return the summary information metadata for the document, if we supported it
 java.lang.String getText()
Retreives the text contents of the file
 void setFormulasNotResults(boolean formulasNotResults)
Should we return the formula itself, and not the result it produces? Default is false
 void setIncludeSheetNames(boolean includeSheetNames)
Should sheet names be included? Default is true
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getMetadataTextExtractor, getRoot
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EventBasedExcelExtractor

@Deprecated
public EventBasedExcelExtractor(DirectoryNode dir,
                                           POIFSFileSystem fs)
Deprecated. Use EventBasedExcelExtractor(DirectoryNode) instead

EventBasedExcelExtractor

public EventBasedExcelExtractor(DirectoryNode dir)

EventBasedExcelExtractor

public EventBasedExcelExtractor(POIFSFileSystem fs)
Method Detail

getFileSystem

public POIFSFileSystem getFileSystem()
Deprecated. Use POIOLE2TextExtractor.getRoot() instead

Return the underlying POIFS FileSystem of this document.

Overrides:
getFileSystem in class POIOLE2TextExtractor

getDocSummaryInformation

public DocumentSummaryInformation getDocSummaryInformation()
Would return the document information metadata for the document, if we supported it

Overrides:
getDocSummaryInformation in class POIOLE2TextExtractor

getSummaryInformation

public SummaryInformation getSummaryInformation()
Would return the summary information metadata for the document, if we supported it

Overrides:
getSummaryInformation in class POIOLE2TextExtractor

setIncludeSheetNames

public void setIncludeSheetNames(boolean includeSheetNames)
Should sheet names be included? Default is true

setFormulasNotResults

public void setFormulasNotResults(boolean formulasNotResults)
Should we return the formula itself, and not the result it produces? Default is false

getText

public java.lang.String getText()
Retreives the text contents of the file

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ExcelExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.extractor
Class ExcelExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hssf.extractor.ExcelExtractor
All Implemented Interfaces:
ExcelExtractor
public class ExcelExtractor
extends POIOLE2TextExtractor
implements ExcelExtractor

A text extractor for Excel files.

Returns the textual content of the file, suitable for indexing by something like Lucene, but not really intended for display to the user.

To turn an excel file into a CSV or similar, then see the XLS2CSVmra example

http://svn.apache.org/repos/asf/poi/trunk/src/examples/src/org/apache/poi/hssf/eventusermodel/examples/XLS2CSVmra.java

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
ExcelExtractor(DirectoryNode dir)
ExcelExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use ExcelExtractor(DirectoryNode) instead
ExcelExtractor(HSSFWorkbook wb)
ExcelExtractor(POIFSFileSystem fs)
Method Summary
static java.lang.String | _extractHeaderFooter(HeaderFooter hf)
java.lang.String | getText() Retrieves the text contents of the file
static void | main(java.lang.String[] args) Command line extractor.
void | setFormulasNotResults(boolean formulasNotResults) Should we return the formula itself, and not the result it produces? Default is false
void | setIncludeBlankCells(boolean includeBlankCells) Should blank cells be output? Default is to only output cells that are present in the file and are non-blank.
void | setIncludeCellComments(boolean includeCellComments) Should cell comments be included? Default is false
void | setIncludeHeadersFooters(boolean includeHeadersFooters) Should headers and footers be included in the output? Default is to include them.
void | setIncludeSheetNames(boolean includeSheetNames) Should sheet names be included? Default is true
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getDocSummaryInformation, getFileSystem, getMetadataTextExtractor, getRoot, getSummaryInformation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExcelExtractor

public ExcelExtractor(HSSFWorkbook wb)

ExcelExtractor

public ExcelExtractor(POIFSFileSystem fs)
               throws java.io.IOException
Throws:
java.io.IOException

ExcelExtractor

@Deprecated
public ExcelExtractor(DirectoryNode dir,
                                 POIFSFileSystem fs)
               throws java.io.IOException
Deprecated. Use ExcelExtractor(DirectoryNode) instead

Throws:
java.io.IOException

ExcelExtractor

public ExcelExtractor(DirectoryNode dir)
               throws java.io.IOException
Throws:
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
Command line extractor.

setIncludeSheetNames

public void setIncludeSheetNames(boolean includeSheetNames)
Should sheet names be included? Default is true

Specified by:
setIncludeSheetNames in interface ExcelExtractor

setFormulasNotResults

public void setFormulasNotResults(boolean formulasNotResults)
Should we return the formula itself, and not the result it produces? Default is false

Specified by:
setFormulasNotResults in interface ExcelExtractor

setIncludeCellComments

public void setIncludeCellComments(boolean includeCellComments)
Should cell comments be included? Default is false

Specified by:
setIncludeCellComments in interface ExcelExtractor

setIncludeBlankCells

public void setIncludeBlankCells(boolean includeBlankCells)
Should blank cells be output? Default is to only output cells that are present in the file and are non-blank.

setIncludeHeadersFooters

public void setIncludeHeadersFooters(boolean includeHeadersFooters)
Should headers and footers be included in the output? Default is to include them.

getText

public java.lang.String getText()
Retrieves the text contents of the file

Specified by:
getText in interface ExcelExtractor
Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

_extractHeaderFooter

public static java.lang.String _extractHeaderFooter(HeaderFooter hf)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.extractor
Classes
EventBasedExcelExtractor
ExcelExtractor


org.apache.poi.hssf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.extractor

Class Summary
EventBasedExcelExtractor | A text extractor for Excel files, that is based on the hssf eventusermodel api.
ExcelExtractor | A text extractor for Excel files.


org.apache.poi.hssf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIOLE2TextExtractor
        • org.apache.poi.hssf.extractor.EventBasedExcelExtractor
        • org.apache.poi.hssf.extractor.ExcelExtractor (implements org.apache.poi.ss.extractor.ExcelExtractor)


Uses of Package org.apache.poi.hssf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.extractor

No usage of org.apache.poi.hssf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.extractor.EventBasedExcelExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.extractor.EventBasedExcelExtractor

No usage of org.apache.poi.hssf.extractor.EventBasedExcelExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.extractor.ExcelExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.extractor.ExcelExtractor

No usage of org.apache.poi.hssf.extractor.ExcelExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractShape

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class AbstractShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
Direct Known Subclasses:
ComboboxShape, LineShape, PictureShape, PolygonShape, SimpleFilledShape, TextboxShape
public abstract class AbstractShape
extends java.lang.Object

An abstract shape is the lowlevel model for a shape.

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
protected AbstractShape()
Method Summary
protected int | addStandardOptions(HSSFShape shape, EscherOptRecord opt) Add standard properties to the opt record.
protected EscherRecord | createAnchor(HSSFAnchor userAnchor) Creates an escher anchor record from a HSSFAnchor.
static AbstractShape | createShape(HSSFShape hssfShape, int shapeId) Create a new shape object used to create the escher records.
abstract ObjRecord | getObjRecord()
abstract EscherContainerRecord | getSpContainer()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractShape

protected AbstractShape()
Method Detail

createShape

public static AbstractShape createShape(HSSFShape hssfShape,
                                        int shapeId)
Create a new shape object used to create the escher records.

Parameters:
hssfShape - The simple shape this is based on.

getSpContainer

public abstract EscherContainerRecord getSpContainer()
Returns:
The shape container and it's children that can represent this shape.

getObjRecord

public abstract ObjRecord getObjRecord()
Returns:
The object record that is associated with this shape.

createAnchor

protected EscherRecord createAnchor(HSSFAnchor userAnchor)
Creates an escher anchor record from a HSSFAnchor.

Parameters:
userAnchor - The high level anchor to convert.
Returns:
An escher anchor record.

addStandardOptions

protected int addStandardOptions(HSSFShape shape,
                                 EscherOptRecord opt)
Add standard properties to the opt record. These properties effect all records.

Parameters:
shape - The user model shape.
opt - The opt record to add the properties to.
Returns:
The number of options added.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ComboboxShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class ComboboxShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
        extended by  org.apache.poi.hssf.model.ComboboxShape

public class ComboboxShape
extends AbstractShape

Represents a combobox shape.

Author:
Yegor Kozlov

Method Summary
ObjRecord | getObjRecord()
EscherContainerRecord | getSpContainer()
Methods inherited from class org.apache.poi.hssf.model.AbstractShape
addStandardOptions, createAnchor, createShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getSpContainer

public EscherContainerRecord getSpContainer()
Specified by:
getSpContainer in class AbstractShape
Returns:
The shape container and it's children that can represent this shape.

getObjRecord

public ObjRecord getObjRecord()
Specified by:
getObjRecord in class AbstractShape
Returns:
The object record that is associated with this shape.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CommentShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class CommentShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
        extended by  org.apache.poi.hssf.model.TextboxShape
            extended by  org.apache.poi.hssf.model.CommentShape

public final class CommentShape
extends TextboxShape

Represents a cell comment. This class converts highlevel model data from HSSFComment to low-level records.

Author:
Yegor Kozlov

Constructor Summary
CommentShape(HSSFComment hssfShape, int shapeId)
Creates the low-level records for a comment.
Method Summary
protected int | addStandardOptions(HSSFShape shape, EscherOptRecord opt) Sets standard escher options for a comment.
NoteRecord | getNoteRecord() Return the NoteRecord holding the comment attributes
Methods inherited from class org.apache.poi.hssf.model.TextboxShape
getEscherTextbox, getObjRecord, getSpContainer, getTextObjectRecord
Methods inherited from class org.apache.poi.hssf.model.AbstractShape
createAnchor, createShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommentShape

public CommentShape(HSSFComment hssfShape,
                    int shapeId)
Creates the low-level records for a comment.

Parameters:
hssfShape - The highlevel shape.
shapeId - The shape id to use for this shape.
Method Detail

addStandardOptions

protected int addStandardOptions(HSSFShape shape,
                                 EscherOptRecord opt)
Sets standard escher options for a comment. This method is responsible for setting default background, shading and other comment properties.

Overrides:
addStandardOptions in class AbstractShape
Parameters:
shape - The highlevel shape.
opt - The escher records holding the proerties
Returns:
number of escher options added

getNoteRecord

public NoteRecord getNoteRecord()
Return the NoteRecord holding the comment attributes

Returns:
NoteRecord holding the comment attributes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConvertAnchor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class ConvertAnchor

java.lang.Object
    extended by  org.apache.poi.hssf.model.ConvertAnchor

public class ConvertAnchor
extends java.lang.Object

Constructor Summary
ConvertAnchor()
Method Summary
static EscherRecord createAnchor(HSSFAnchor userAnchor)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConvertAnchor

public ConvertAnchor()
Method Detail

createAnchor

public static EscherRecord createAnchor(HSSFAnchor userAnchor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class DrawingManager

java.lang.Object
    extended by  org.apache.poi.hssf.model.DrawingManager

public class DrawingManager
extends java.lang.Object

Provides utilities to manage drawing groups.

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
DrawingManager(EscherDggRecord dgg)
Method Summary
int | allocateShapeId(short drawingGroupId) Allocates new shape id for the new drawing group id.
EscherDgRecord | createDgRecord()
EscherDggRecord | getDgg()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingManager

public DrawingManager(EscherDggRecord dgg)
Method Detail

createDgRecord

public EscherDgRecord createDgRecord()

allocateShapeId

public int allocateShapeId(short drawingGroupId)
Allocates new shape id for the new drawing group id.

Returns:
a new shape id.

getDgg

public EscherDggRecord getDgg()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingManager2

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class DrawingManager2

java.lang.Object
    extended by  org.apache.poi.hssf.model.DrawingManager2

public class DrawingManager2
extends java.lang.Object

Provides utilities to manage drawing groups.

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
DrawingManager2(EscherDggRecord dgg)
Method Summary
int | allocateShapeId(short drawingGroupId) Allocates new shape id for the new drawing group id.
int | allocateShapeId(short drawingGroupId, EscherDgRecord dg) Allocates new shape id for the new drawing group id.
void | clearDrawingGroups() Clears the cached list of drawing groups
EscherDgRecord | createDgRecord()
EscherDggRecord | getDgg()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingManager2

public DrawingManager2(EscherDggRecord dgg)
Method Detail

clearDrawingGroups

public void clearDrawingGroups()
Clears the cached list of drawing groups

createDgRecord

public EscherDgRecord createDgRecord()

allocateShapeId

public int allocateShapeId(short drawingGroupId)
Allocates new shape id for the new drawing group id.

Returns:
a new shape id.

allocateShapeId

public int allocateShapeId(short drawingGroupId,
                           EscherDgRecord dg)
Allocates new shape id for the new drawing group id.

Returns:
a new shape id.

getDgg

public EscherDggRecord getDgg()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFFormulaParser

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class HSSFFormulaParser

java.lang.Object
    extended by  org.apache.poi.hssf.model.HSSFFormulaParser

public final class HSSFFormulaParser
extends java.lang.Object

HSSF wrapper for the FormulaParser and FormulaRenderer

Author:
Josh Micich

Method Summary
static Ptg[] | parse(java.lang.String formula, HSSFWorkbook workbook) Convenience method for parsing cell formulas.
static Ptg[] | parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType)
static Ptg[] | parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType, int sheetIndex)
static java.lang.String | toFormulaString(HSSFWorkbook book, Ptg[] ptgs) Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

parse

public static Ptg[] parse(java.lang.String formula,
                          HSSFWorkbook workbook)
                   throws FormulaParseException
Convenience method for parsing cell formulas. see parse(String, HSSFWorkbook, int, int)

Throws:
FormulaParseException

parse

public static Ptg[] parse(java.lang.String formula,
                          HSSFWorkbook workbook,
                          int formulaType)
                   throws FormulaParseException
Parameters:
formulaType - a constant from FormulaType
Returns:
the parsed formula tokens
Throws:
FormulaParseException - if the formula has incorrect syntax or is otherwise invalid

parse

public static Ptg[] parse(java.lang.String formula,
                          HSSFWorkbook workbook,
                          int formulaType,
                          int sheetIndex)
                   throws FormulaParseException
Parameters:
formula - the formula to parse
workbook - the parent workbook
formulaType - a constant from FormulaType
sheetIndex - the 0-based index of the sheet this formula belongs to. The sheet index is required to resolve sheet-level names. -1 means that the scope of the name will be ignored and the parser will match named ranges only by name
Returns:
the parsed formula tokens
Throws:
FormulaParseException - if the formula has incorrect syntax or is otherwise invalid

toFormulaString

public static java.lang.String toFormulaString(HSSFWorkbook book,
                                               Ptg[] ptgs)
Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.

Parameters:
book - used for defined names and 3D references
ptgs - must not be null
Returns:
a human readable String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InternalSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class InternalSheet

java.lang.Object
    extended by  org.apache.poi.hssf.model.InternalSheet

@Internal
public final class InternalSheet
extends java.lang.Object

Low level model implementation of a Sheet (one workbook contains many sheets) This file contains the low level binary records starting at the sheets BOF and ending with the sheets EOF. Use HSSFSheet for a high level representation.

The structures of the highlevel API use references to this to perform most of their operations. Its probably unwise to use these low level structures directly unless you really know what you're doing. I recommend you read the Microsoft Excel 97 Developer's Kit (Microsoft Press) and the documentation at http://sc.openoffice.org/excelfileformat.pdf before even attempting to use this.

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org), Shawn Laubach (slaubach at apache dot org) Gridlines, Headers, Footers, PrintSetup, and Setting Default Column Styles, Jason Height (jheight at chariot dot net dot au) Clone support. DBCell & Index Record writing support, Brian Sanders (kestrel at burdell dot org) Active Cell support, Jean-Pierre Paris (jean-pierre.paris at m4x dot org) (Just a little)
See Also:
InternalWorkbook, HSSFSheet

Field Summary
protected boolean | _isUncalced Add an UncalcedRecord if not true indicating formulas have not been calculated
protected RowRecordsAggregate | _rowsAggregate always present
protected SelectionRecord | _selection
static short | BottomMargin
protected DefaultColWidthRecord | defaultcolwidth
protected DefaultRowHeightRecord | defaultrowheight
protected GridsetRecord | gridset
static short | LeftMargin
static byte | PANE_LOWER_LEFT
static byte | PANE_LOWER_RIGHT
static byte | PANE_UPPER_LEFT
static byte | PANE_UPPER_RIGHT
protected PrintGridlinesRecord | printGridlines
static short | RightMargin
static short | TopMargin
protected WindowTwoRecord | windowTwo
Method Summary
 int addMergedRegion(int rowFrom, int colFrom, int rowTo, int colTo)
 void addRow(RowRecord row)
Adds a row record to the sheet
 void addValueRecord(int row, CellValueRecordInterface col)
Adds a value record to the sheet's contained binary records (i.e.
 int aggregateDrawingRecords(DrawingManager2 drawingManager, boolean createIfMissing)
Finds the DrawingRecord for our sheet, and attaches it to the DrawingManager (which knows about the overall DrawingGroup for our workbook).
 InternalSheet cloneSheet()
Clones the low level records of this sheet and returns the new sheet instance.
 void createFreezePane(int colSplit, int rowSplit, int topRow, int leftmostColumn)
Creates a split (freezepane).
static InternalSheet createSheet()
Creates a sheet with all the usual records minus values and the "index" record (not required).
static InternalSheet createSheet(RecordStream rs)
read support (offset used as starting point for search) for low level API.
 void createSplitPane(int xSplitPos, int ySplitPos, int topRow, int leftmostColumn, int activePane)
Creates a split pane.
 Record findFirstRecordBySid(short sid)
Returns the first occurrence of a record matching a particular sid.
 int findFirstRecordLocBySid(short sid)
Finds the first occurrence of a record matching a particular sid and returns it's position.
 short getActiveCellCol()
 int getActiveCellRow()
Returns the active row
 java.util.Iterator<CellValueRecordInterface> getCellValueIterator()
Get all the value records (from LOC).
 int getColumnWidth(int columnIndex)
get the width of a given column in units of 1/256th of a character width
 ConditionalFormattingTable getConditionalFormattingTable()
 int getDefaultColumnWidth()
get the default column width for the sheet (if the columns do not define their own width)
 short getDefaultRowHeight()
get the default row height for the sheet (if the rows do not define their own height)
 GridsetRecord getGridsetRecord()
Gets the gridset record for this sheet.
 short getLeftCol()
 CellRangeAddress getMergedRegionAt(int index)
 RowRecord getNextRow()
get the NEXT RowRecord (from LOC).
 NoteRecord[] getNoteRecords()
Get the NoteRecords (related to cell comments) for this sheet
 int getNumMergedRegions()
 DataValidityTable getOrCreateDataValidityTable()
 PageSettingsBlock getPageSettings()
 PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).
 PrintGridlinesRecord getPrintGridlines()
Returns the PrintGridlinesRecord.
 WorksheetProtectionBlock getProtectionBlock()
 java.util.List<RecordBase> getRecords()
 RowRecord getRow(int rownum)
get the NEXT (from LOC) RowRecord where rownumber matches the given rownum.
 RowRecordsAggregate getRowsAggregate()
 SelectionRecord getSelection()
 short getTopRow()
 boolean getUncalced()
 CellValueRecordInterface[] getValueRecords()
Deprecated. use getCellValueIterator() instead
 WindowTwoRecord getWindowTwo()
 short getXFIndexForColAt(short columnIndex)
get the index to the ExtendedFormatRecord "associated" with the column at specified 0-based index.
 void groupColumnRange(int fromColumn, int toColumn, boolean indent)
Creates an outline group for the specified columns.
 void groupRowRange(int fromRow, int toRow, boolean indent)
 boolean isColumnHidden(int columnIndex)
Get the hidden property for a given column.
 boolean isDisplayFormulas()
Returns if formulas are displayed.
 boolean isDisplayGridlines()
 boolean isDisplayRowColHeadings()
Returns if RowColHeadings are displayed.
 boolean isGridsPrinted()
 void preSerialize()
Perform any work necessary before the sheet is about to be serialized.
 void removeMergedRegion(int index)
 void removeRow(RowRecord row)
Removes a row record This method is not loc sensitive, it resets loc to = dimsloc so no worries.
 void removeValueRecord(int row, CellValueRecordInterface col)
remove a value record from the records array.
 void replaceValueRecord(CellValueRecordInterface newval)
replace a value record from the records array.
 void setActiveCellCol(short col)
Sets the active column
 void setActiveCellRow(int row)
Sets the active row
 void setColumnGroupCollapsed(int columnNumber, boolean collapsed)
 void setColumnHidden(int column, boolean hidden)
Get the hidden property for a given column.
 void setColumnWidth(int column, int width)
set the width for a given column in 1/256th of a character width units
 void setDefaultColumnStyle(int column, int styleIndex)
 void setDefaultColumnWidth(int dcw)
set the default column width for the sheet (if the columns do not define their own width)
 void setDefaultRowHeight(short dch)
set the default row height for the sheet (if the rows do not define their own height)
 void setDimensions(int firstrow, short firstcol, int lastrow, short lastcol)
Per an earlier reported bug in working with Andy Khan's excel read library.
 void setDisplayFormulas(boolean show)
Sets whether the formulas are shown in a viewer.
 void setDisplayGridlines(boolean show)
Sets whether the gridlines are shown in a viewer.
 void setDisplayRowColHeadings(boolean show)
Sets whether the RowColHeadings are shown in a viewer.
 void setGridsPrinted(boolean value)
set whether gridlines printed or not.
 void setLeftCol(short leftCol)
Sets the left column to show in desktop window pane.
 void setPrintGridlines(PrintGridlinesRecord newPrintGridlines)
Sets the PrintGridlinesRecord.
 void setSCLRecord(SCLRecord sclRecord)
Sets the SCL record or creates it in the correct place if it does not already exist.
 void setSelected(boolean sel)
Sets whether the sheet is selected
 void setSelection(SelectionRecord selection)
 void setTopRow(short topRow)
 void setUncalced(boolean uncalced)
 void updateFormulasAfterCellShift(FormulaShifter shifter, int externSheetIndex)
Updates formulas in cells and conditional formats due to moving of cells
 void visitContainedRecords(RecordAggregate.RecordVisitor rv, int offset)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LeftMargin

public static final short LeftMargin
See Also:
Constant Field Values

RightMargin

public static final short RightMargin
See Also:
Constant Field Values

TopMargin

public static final short TopMargin
See Also:
Constant Field Values

BottomMargin

public static final short BottomMargin
See Also:
Constant Field Values

printGridlines

protected PrintGridlinesRecord printGridlines

gridset

protected GridsetRecord gridset

defaultcolwidth

protected DefaultColWidthRecord defaultcolwidth

defaultrowheight

protected DefaultRowHeightRecord defaultrowheight

windowTwo

protected WindowTwoRecord windowTwo

_selection

protected SelectionRecord _selection

_rowsAggregate

protected final RowRecordsAggregate _rowsAggregate
always present

_isUncalced

protected boolean _isUncalced
Add an UncalcedRecord if not true indicating formulas have not been calculated

PANE_LOWER_RIGHT

public static final byte PANE_LOWER_RIGHT
See Also:
Constant Field Values

PANE_UPPER_RIGHT

public static final byte PANE_UPPER_RIGHT
See Also:
Constant Field Values

PANE_LOWER_LEFT

public static final byte PANE_LOWER_LEFT
See Also:
Constant Field Values

PANE_UPPER_LEFT

public static final byte PANE_UPPER_LEFT
See Also:
Constant Field Values
Method Detail

createSheet

public static InternalSheet createSheet(RecordStream rs)
read support (offset used as starting point for search) for low level API. Pass in an array of Record objects, the sheet number (0 based) and a record offset (should be the location of the sheets BOF record). A Sheet object is constructed and passed back with all of its initialization set to the passed in records and references to those records held. This function is normally called via Workbook.

Parameters:
rs - the stream to read records from
Returns:
Sheet object with all values set to those read from the file
See Also:
InternalWorkbook, Record

cloneSheet

public InternalSheet cloneSheet()
Clones the low level records of this sheet and returns the new sheet instance. This method is implemented by adding methods for deep cloning to all records that can be added to a sheet. The Record object does not implement cloneable. When adding a new record, implement a public clone method if and only if the record belongs to a sheet.

createSheet

public static InternalSheet createSheet()
Creates a sheet with all the usual records minus values and the "index" record (not required). Sets the location pointer to where the first value records should go. Use this to create a sheet from "scratch".

Returns:
Sheet object with all values set to defaults

getRowsAggregate

public RowRecordsAggregate getRowsAggregate()

updateFormulasAfterCellShift

public void updateFormulasAfterCellShift(FormulaShifter shifter,
                                         int externSheetIndex)
Updates formulas in cells and conditional formats due to moving of cells

Parameters:
externSheetIndex - the externSheet index of this sheet

addMergedRegion

public int addMergedRegion(int rowFrom,
                           int colFrom,
                           int rowTo,
                           int colTo)

removeMergedRegion

public void removeMergedRegion(int index)

getMergedRegionAt

public CellRangeAddress getMergedRegionAt(int index)

getNumMergedRegions

public int getNumMergedRegions()

getConditionalFormattingTable

public ConditionalFormattingTable getConditionalFormattingTable()

setDimensions

public void setDimensions(int firstrow,
                          short firstcol,
                          int lastrow,
                          short lastcol)
Per an earlier reported bug in working with Andy Khan's excel read library. This sets the values in the sheet's DimensionsRecord object to be correct. Excel doesn't really care, but we want to play nice with other libraries.

See Also:
DimensionsRecord

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv,
                                  int offset)

addValueRecord

public void addValueRecord(int row,
                           CellValueRecordInterface col)
Adds a value record to the sheet's contained binary records (i.e. LabelSSTRecord or NumberRecord).

This method is "loc" sensitive. Meaning you need to set LOC to where you want it to start searching. If you don't know do this: setLoc(getDimsLoc). When adding several rows you can just start at the last one by leaving loc at what this sets it to.

Parameters:
row - the row to add the cell value to
col - the cell value record itself.

removeValueRecord

public void removeValueRecord(int row,
                              CellValueRecordInterface col)
remove a value record from the records array. This method is not loc sensitive, it resets loc to = dimsloc so no worries.

Parameters:
row - - the row of the value record you wish to remove
col - - a record supporting the CellValueRecordInterface.
See Also:
CellValueRecordInterface

replaceValueRecord

public void replaceValueRecord(CellValueRecordInterface newval)
replace a value record from the records array. This method is not loc sensitive, it resets loc to = dimsloc so no worries.

Parameters:
newval - - a record supporting the CellValueRecordInterface. this will replace the cell value with the same row and column. If there isn't one, one will be added.

addRow

public void addRow(RowRecord row)
Adds a row record to the sheet

This method is "loc" sensitive. Meaning you need to set LOC to where you want it to start searching. If you don't know do this: setLoc(getDimsLoc). When adding several rows you can just start at the last one by leaving loc at what this sets it to.

Parameters:
row - the row record to be added

removeRow

public void removeRow(RowRecord row)
Removes a row record This method is not loc sensitive, it resets loc to = dimsloc so no worries.

Parameters:
row - the row record to remove

getCellValueIterator

public java.util.Iterator<CellValueRecordInterface> getCellValueIterator()
Get all the value records (from LOC). Records will be returned from the first record (starting at LOC) which is a value record.

This method is "loc" sensitive. Meaning you need to set LOC to where you want it to start searching. If you don't know do this: setLoc(getDimsLoc). When adding several rows you can just start at the last one by leaving loc at what this sets it to. For this method, set loc to dimsloc to start with, subsequent calls will return values in (physical) sequence or NULL when you get to the end.

Returns:
Iterator of CellValueRecordInterface representing the value records

getValueRecords

@Deprecated
public CellValueRecordInterface[] getValueRecords()
Deprecated. use getCellValueIterator() instead

Get all the value records (from LOC). Records will be returned from the first record (starting at LOC) which is a value record.

This method is "loc" sensitive. Meaning you need to set LOC to where you want it to start searching. If you don't know do this: setLoc(getDimsLoc). When adding several rows you can just start at the last one by leaving loc at what this sets it to. For this method, set loc to dimsloc to start with, subsequent calls will return values in (physical) sequence or NULL when you get to the end.

Returns:
Array of CellValueRecordInterface representing the remaining value records

getNextRow

public RowRecord getNextRow()
get the NEXT RowRecord (from LOC). The first record that is a Row record (starting at LOC) will be returned.

This method is "loc" sensitive. Meaning you need to set LOC to where you want it to start searching. If you don't know do this: setLoc(getDimsLoc). When adding several rows you can just start at the last one by leaving loc at what this sets it to. For this method, set loc to dimsloc to start with. subsequent calls will return rows in (physical) sequence or NULL when you get to the end.

Returns:
RowRecord representing the next row record or NULL if there are no more

getRow

public RowRecord getRow(int rownum)
get the NEXT (from LOC) RowRecord where rownumber matches the given rownum. The first record that is a Row record (starting at LOC) that has the same rownum as the given rownum will be returned.

This method is "loc" sensitive. Meaning you need to set LOC to where you want it to start searching. If you don't know do this: setLoc(getDimsLoc). When adding several rows you can just start at the last one by leaving loc at what this sets it to. For this method, set loc to dimsloc to start with. subsequent calls will return rows in (physical) sequence or NULL when you get to the end.

Parameters:
rownum - which row to return (careful with LOC)
Returns:
RowRecord representing the next row record or NULL if there are no more

getDefaultColumnWidth

public int getDefaultColumnWidth()
get the default column width for the sheet (if the columns do not define their own width)

Returns:
default column width

isGridsPrinted

public boolean isGridsPrinted()
Returns:
true if gridlines are printed

setGridsPrinted

public void setGridsPrinted(boolean value)
set whether gridlines printed or not.

Parameters:
value - True if gridlines printed.

setDefaultColumnWidth

public void setDefaultColumnWidth(int dcw)
set the default column width for the sheet (if the columns do not define their own width)

Parameters:
dcw - default column width

setDefaultRowHeight

public void setDefaultRowHeight(short dch)
set the default row height for the sheet (if the rows do not define their own height)

getDefaultRowHeight

public short getDefaultRowHeight()
get the default row height for the sheet (if the rows do not define their own height)

Returns:
default row height

getColumnWidth

public int getColumnWidth(int columnIndex)
get the width of a given column in units of 1/256th of a character width

Parameters:
columnIndex - index
Returns:
column width in units of 1/256th of a character width
See Also:
DefaultColWidthRecord, ColumnInfoRecord, setColumnWidth(int, int)

getXFIndexForColAt

public short getXFIndexForColAt(short columnIndex)
get the index to the ExtendedFormatRecord "associated" with the column at specified 0-based index. (In this case, an ExtendedFormatRecord index is actually associated with a ColumnInfoRecord which spans 1 or more columns)
Returns the index to the default ExtendedFormatRecord (0xF) if no ColumnInfoRecord exists that includes the column index specified.

Parameters:
columnIndex -
Returns:
index of ExtendedFormatRecord associated with ColumnInfoRecord that includes the column index or the index of the default ExtendedFormatRecord (0xF)

setColumnWidth

public void setColumnWidth(int column,
                           int width)
set the width for a given column in 1/256th of a character width units

Parameters:
column - - the column number
width - (in units of 1/256th of a character width)

isColumnHidden

public boolean isColumnHidden(int columnIndex)
Get the hidden property for a given column.

Parameters:
columnIndex - column index
Returns:
whether the column is hidden or not.
See Also:
DefaultColWidthRecord, ColumnInfoRecord, setColumnHidden(int, boolean)

setColumnHidden

public void setColumnHidden(int column,
                            boolean hidden)
Get the hidden property for a given column.

Parameters:
column - - the column number
hidden - - whether the column is hidden or not

setDefaultColumnStyle

public void setDefaultColumnStyle(int column,
                                  int styleIndex)

groupColumnRange

public void groupColumnRange(int fromColumn,
                             int toColumn,
                             boolean indent)
Creates an outline group for the specified columns.

Parameters:
fromColumn - group from this column (inclusive)
toColumn - group to this column (inclusive)
indent - if true the group will be indented by one level, if false indenting will be removed by one level.

getTopRow

public short getTopRow()

setTopRow

public void setTopRow(short topRow)

setLeftCol

public void setLeftCol(short leftCol)
Sets the left column to show in desktop window pane.

Parameters:
leftCol - the left column to show in desktop window pane

getLeftCol

public short getLeftCol()

getActiveCellRow

public int getActiveCellRow()
Returns the active row

Returns:
row the active row index
See Also:
SelectionRecord

setActiveCellRow

public void setActiveCellRow(int row)
Sets the active row

Parameters:
row - the row index
See Also:
SelectionRecord

getActiveCellCol

public short getActiveCellCol()
Returns:
column of the active cell
See Also:
SelectionRecord

setActiveCellCol

public void setActiveCellCol(short col)
Sets the active column

Parameters:
col - the column index
See Also:
SelectionRecord

getRecords

public java.util.List<RecordBase> getRecords()

getGridsetRecord

public GridsetRecord getGridsetRecord()
Gets the gridset record for this sheet.

findFirstRecordBySid

public Record findFirstRecordBySid(short sid)
Returns the first occurrence of a record matching a particular sid.

setSCLRecord

public void setSCLRecord(SCLRecord sclRecord)
Sets the SCL record or creates it in the correct place if it does not already exist.

Parameters:
sclRecord - The record to set.

findFirstRecordLocBySid

public int findFirstRecordLocBySid(short sid)
Finds the first occurrence of a record matching a particular sid and returns it's position.

Parameters:
sid - the sid to search for
Returns:
the record position of the matching record or -1 if no match is made.

getWindowTwo

public WindowTwoRecord getWindowTwo()

getPrintGridlines

public PrintGridlinesRecord getPrintGridlines()
Returns the PrintGridlinesRecord.

Returns:
PrintGridlinesRecord for the sheet.

setPrintGridlines

public void setPrintGridlines(PrintGridlinesRecord newPrintGridlines)
Sets the PrintGridlinesRecord.

Parameters:
newPrintGridlines - The new PrintGridlinesRecord for the sheet.

setSelected

public void setSelected(boolean sel)
Sets whether the sheet is selected

Parameters:
sel - True to select the sheet, false otherwise.

createFreezePane

public void createFreezePane(int colSplit,
                             int rowSplit,
                             int topRow,
                             int leftmostColumn)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

If both colSplit and rowSplit are zero then the existing freeze pane is removed

Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.
topRow - Top row visible in bottom pane
leftmostColumn - Left column visible in right pane.

createSplitPane

public void createSplitPane(int xSplitPos,
                            int ySplitPos,
                            int topRow,
                            int leftmostColumn,
                            int activePane)
Creates a split pane. Any existing freezepane or split pane is overwritten.

Parameters:
xSplitPos - Horizonatal position of split (in 1/20th of a point).
ySplitPos - Vertical position of split (in 1/20th of a point).
topRow - Top row visible in bottom pane
leftmostColumn - Left column visible in right pane.
activePane - Active pane. One of: PANE_LOWER_RIGHT, PANE_UPPER_RIGHT, PANE_LOWER_LEFT, PANE_UPPER_LEFT
See Also:
PANE_LOWER_LEFT, PANE_LOWER_RIGHT, PANE_UPPER_LEFT, PANE_UPPER_RIGHT

getPaneInformation

public PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).

Returns:
null if no pane configured, or the pane information.

getSelection

public SelectionRecord getSelection()

setSelection

public void setSelection(SelectionRecord selection)

getProtectionBlock

public WorksheetProtectionBlock getProtectionBlock()
Returns:
the WorksheetProtectionBlock for this sheet

setDisplayGridlines

public void setDisplayGridlines(boolean show)
Sets whether the gridlines are shown in a viewer.

Parameters:
show - whether to show gridlines or not

isDisplayGridlines

public boolean isDisplayGridlines()
Returns:
true if gridlines are displayed

setDisplayFormulas

public void setDisplayFormulas(boolean show)
Sets whether the formulas are shown in a viewer.

Parameters:
show - whether to show formulas or not

isDisplayFormulas

public boolean isDisplayFormulas()
Returns if formulas are displayed.

Returns:
whether formulas are displayed

setDisplayRowColHeadings

public void setDisplayRowColHeadings(boolean show)
Sets whether the RowColHeadings are shown in a viewer.

Parameters:
show - whether to show RowColHeadings or not

isDisplayRowColHeadings

public boolean isDisplayRowColHeadings()
Returns if RowColHeadings are displayed.

Returns:
whether RowColHeadings are displayed

getUncalced

public boolean getUncalced()
Returns:
whether an uncalced record must be inserted or not at generation

setUncalced

public void setUncalced(boolean uncalced)
Parameters:
uncalced - whether an uncalced record must be inserted or not at generation

aggregateDrawingRecords

public int aggregateDrawingRecords(DrawingManager2 drawingManager,
                                   boolean createIfMissing)
Finds the DrawingRecord for our sheet, and attaches it to the DrawingManager (which knows about the overall DrawingGroup for our workbook). If requested, will create a new DrawRecord if none currently exist

Parameters:
drawingManager - The DrawingManager2 for our workbook
createIfMissing - Should one be created if missing?

preSerialize

public void preSerialize()
Perform any work necessary before the sheet is about to be serialized. For instance the escher aggregates size needs to be calculated before serialization so that the dgg record (which occurs first) can be written.

getPageSettings

public PageSettingsBlock getPageSettings()

setColumnGroupCollapsed

public void setColumnGroupCollapsed(int columnNumber,
                                    boolean collapsed)

groupRowRange

public void groupRowRange(int fromRow,
                          int toRow,
                          boolean indent)

getOrCreateDataValidityTable

public DataValidityTable getOrCreateDataValidityTable()

getNoteRecords

public NoteRecord[] getNoteRecords()
Get the NoteRecords (related to cell comments) for this sheet

Returns:
never null, typically empty array
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InternalWorkbook

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class InternalWorkbook

java.lang.Object
    extended by  org.apache.poi.hssf.model.InternalWorkbook

@Internal
public final class InternalWorkbook
extends java.lang.Object

Low level model implementation of a Workbook. Provides creational methods for settings and objects contained in the workbook object.

This file contains the low level binary records starting at the workbook's BOF and ending with the workbook's EOF. Use HSSFWorkbook for a high level representation.

The structures of the highlevel API use references to this to perform most of their operations. Its probably unwise to use these low level structures directly unless you really know what you're doing. I recommend you read the Microsoft Excel 97 Developer's Kit (Microsoft Press) and the documentation at http://sc.openoffice.org/excelfileformat.pdf before even attempting to use this.

Author:
Luc Girardin (luc dot girardin at macrofocus dot com), Sergei Kozello (sergeikozello at mail.ru), Shawn Laubach (slaubach at apache dot org) (Data Formats), Andrew C. Oliver (acoliver at apache dot org), Brian Sanders (bsanders at risklabs dot com) - custom palette, Dan Sherman (dsherman at isisph.com), Glen Stampoultzis (glens at apache.org)
See Also:
HSSFWorkbook

Field Summary
protected  SSTRecord sst
this contains a reference to the SSTRecord so that new stings can be added to it.
Method Summary
int | addBSERecord(EscherBSERecord e)
NameRecord | addName(NameRecord name) creates new name
int | addSSTString(UnicodeString string) Adds a string to the SST table and returns its index (if its a duplicate just returns its index and update the counts) ASSUMES compressed unicode (meaning 8bit)
boolean | changeExternalReference(java.lang.String oldUrl, java.lang.String newUrl) Changes an external referenced file to another file.
short | checkExternSheet(int sheetNumber) returns the extern sheet number for specific sheet number , if this sheet doesn't exist in extern sheet , add it
void | cloneDrawings(InternalSheet sheet) Check if the cloned sheet has drawings.
NameRecord | cloneFilter(int filterDbNameIndex, int newSheetIndex)
NameRecord | createBuiltInName(byte builtInName, int sheetNumber) Generates a NameRecord to represent a built-in region
ExtendedFormatRecord | createCellXF() creates a new Cell-type Extneded Format Record and adds it to the end of ExtendedFormatRecords collection
void | createDrawingGroup() Creates a primary drawing group record.
int | createFormat(java.lang.String formatString) Creates a FormatRecord, inserts it, and returns the index code.
NameRecord | createName() creates new name
FontRecord | createNewFont() creates a new font record and adds it to the "font table".
StyleRecord | createStyleRecord(int xfIndex) Creates a new StyleRecord, for the given Extended Format index, and adds it onto the end of the records collection
static InternalWorkbook | createWorkbook() Creates an empty workbook object with three blank sheets and all the empty fields.
static InternalWorkbook | createWorkbook(java.util.List<Record> recs) read support for low level API.
boolean | doesContainsSheetName(java.lang.String name, int excludeSheetIdx) Determines whether a workbook contains the provided sheet name.
DrawingManager2 | findDrawingGroup() Finds the primary drawing group, if one already exists
Record | findFirstRecordBySid(short sid) Returns the first occurance of a record matching a particular sid.
int | findFirstRecordLocBySid(short sid) Returns the index of a record matching a particular sid.
Record | findNextRecordBySid(short sid, int pos) Returns the next occurance of a record matching a particular sid.
java.lang.String | findSheetNameFromExternSheet(int externSheetIndex) finds the sheet name by his extern sheet index
BackupRecord | getBackupRecord() Returns the position of the backup record.
EscherBSERecord | getBSERecord(int pictureIndex)
PaletteRecord | getCustomPalette() Returns the custom palette in use for this workbook; if a custom palette record does not exist, then it is created.
DrawingManager2 | getDrawingManager()
ExtendedFormatRecord | getExFormatAt(int index) gets the ExtendedFormatRecord at the given 0-based index
EvaluationWorkbook.ExternalName | getExternalName(int externSheetIndex, int externNameIndex)
EvaluationWorkbook.ExternalSheet | getExternalSheet(int externSheetIndex)
int | getExternalSheetIndex(java.lang.String workbookName, java.lang.String sheetName)
FileSharingRecord | getFileSharing()
int | getFontIndex(FontRecord font) Retrieves the index of the given font
FontRecord | getFontRecordAt(int idx) gets the font record at the given index in the font table.
short | getFormat(java.lang.String format, boolean createIfNotFound) Returns a format index that matches the passed in format.
java.util.List<FormatRecord> | getFormats() Returns the list of FormatRecords in the workbook.
java.util.List<HyperlinkRecord> | getHyperlinks()
NameCommentRecord | getNameCommentRecord(NameRecord nameRecord) gets the name comment record
NameRecord | getNameRecord(int index) gets the name record
NameXPtg | getNameXPtg(java.lang.String name, UDFFinder udf)
int | getNumberOfFontRecords() gets the number of font records
int | getNumExFormats() get the number of ExtendedFormat records contained in this workbook.
int | getNumNames() gets the total number of names
int | getNumRecords()
int | getNumSheets() returns the number of boundsheet objects contained in this workbook.
RecalcIdRecord | getRecalcId() Get or create RecalcIdRecord
java.util.List<Record> | getRecords()
int | getSheetIndex(java.lang.String name) get the sheet's index
int | getSheetIndexFromExternSheetIndex(int externSheetNumber) Finds the sheet index for a particular external sheet number.
java.lang.String | getSheetName(int sheetIndex) gets the name for a given sheet.
int | getSize()
NameRecord | getSpecificBuiltinRecord(byte name, int sheetNumber) Retrieves the Builtin NameRecord that matches the name and index There shouldn't be too many names to make the sequential search too slow
UnicodeString | getSSTString(int str) given an index into the SST table, this function returns the corresponding String value
StyleRecord | getStyleRecord(int xfIndex) Returns the StyleRecord for the given xfIndex, or null if that ExtendedFormat doesn't have a Style set.
WindowOneRecord | getWindowOne()
WriteAccessRecord | getWriteAccess()
WriteProtectRecord | getWriteProtect()
void | insertSST() use this function to add a Shared String Table to an existing sheet (say generated by a different java api) without an sst....
boolean | isSheetHidden(int sheetnum) Gets the hidden flag for a given sheet.
boolean | isSheetVeryHidden(int sheetnum) Gets the very hidden flag for a given sheet.
boolean | isUsing1904DateWindowing() Whether date windowing is based on 1/2/1904 or 1/1/1900.
boolean | isWriteProtected() is the workbook protected with a password (not encrypted)?
void | removeBuiltinRecord(byte name, int sheetIndex) Removes the specified Builtin NameRecord that matches the name and index
void | removeExFormatRecord(ExtendedFormatRecord rec) Removes the given ExtendedFormatRecord record from the file's list.
void | removeFontRecord(FontRecord rec) Removes the given font record from the file's list.
void | removeName(int nameIndex) removes the name
void | removeSheet(int sheetIndex)
java.lang.String | resolveNameXText(int refIndex, int definedNameIndex)
int | serialize(int offset, byte[] data) Serializes all records int the worksheet section into a big byte array.
void | setSheetBof(int sheetIndex, int pos) Sets the BOF for a given sheet
void | setSheetHidden(int sheetnum, boolean hidden) Hide or unhide a sheet
void | setSheetHidden(int sheetnum, int hidden) Hide or unhide a sheet.
void | setSheetName(int sheetnum, java.lang.String sheetname) sets the name for a given sheet.
void | setSheetOrder(java.lang.String sheetname, int pos) sets the order of appearance for a given sheet.
void | unwriteProtectWorkbook() removes the write protect flag
void | updateNameCommentRecordCache(NameCommentRecord commentRecord) If a NameCommentRecord is added or the name it references is renamed, then this will update the lookup cache for it.
void | updateNamesAfterCellShift(FormulaShifter shifter) Updates named ranges due to moving of cells
void | writeProtectWorkbook(java.lang.String password, java.lang.String username) protect a workbook with a password (not encypted, just sets writeprotect flags and the password.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

sst

protected SSTRecord sst
this contains a reference to the SSTRecord so that new stings can be added to it.

Method Detail

createWorkbook

public static InternalWorkbook createWorkbook(java.util.List<Record> recs)
read support for low level API. Pass in an array of Record objects, A Workbook object is constructed and passed back with all of its initialization set to the passed in records and references to those records held. Unlike Sheet workbook does not use an offset (its assumed to be 0) since its first in a file. If you need an offset then construct a new array with a 0 offset or write your own ;-p.

Parameters:
recs - an array of Record objects
Returns:
Workbook object

createWorkbook

public static InternalWorkbook createWorkbook()
Creates an empty workbook object with three blank sheets and all the empty fields. Use this to create a workbook from scratch.

getSpecificBuiltinRecord

public NameRecord getSpecificBuiltinRecord(byte name,
                                           int sheetNumber)
Retrieves the Builtin NameRecord that matches the name and index There shouldn't be too many names to make the sequential search too slow

Parameters:
name - byte representation of the builtin name to match
sheetNumber - 1-based sheet number
Returns:
null if no builtin NameRecord matches

removeBuiltinRecord

public void removeBuiltinRecord(byte name,
                                int sheetIndex)
Removes the specified Builtin NameRecord that matches the name and index

Parameters:
name - byte representation of the builtin to match
sheetIndex - zero-based sheet reference

getNumRecords

public int getNumRecords()

getFontRecordAt

public FontRecord getFontRecordAt(int idx)
gets the font record at the given index in the font table. Remember "There is No Four" (someone at M$ must have gone to Rocky Horror one too many times)

Parameters:
idx - the index to look at (0 or greater but NOT 4)
Returns:
FontRecord located at the given index

getFontIndex

public int getFontIndex(FontRecord font)
Retrieves the index of the given font

createNewFont

public FontRecord createNewFont()
creates a new font record and adds it to the "font table". This causes the boundsheets to move down one, extended formats to move down (so this function moves those pointers as well)

Returns:
FontRecord that was just created

removeFontRecord

public void removeFontRecord(FontRecord rec)
Removes the given font record from the file's list. This will make all subsequent font indicies drop by one, so you'll need to update those yourself!

getNumberOfFontRecords

public int getNumberOfFontRecords()
gets the number of font records

Returns:
number of font records in the "font table"

setSheetBof

public void setSheetBof(int sheetIndex,
                        int pos)
Sets the BOF for a given sheet

Parameters:
sheetIndex - the number of the sheet to set the positing of the bof for
pos - the actual bof position

getBackupRecord

public BackupRecord getBackupRecord()
Returns the position of the backup record.

setSheetName

public void setSheetName(int sheetnum,
                         java.lang.String sheetname)
sets the name for a given sheet. If the boundsheet record doesn't exist and its only one more than we have, go ahead and create it. If it's > 1 more than we have, except

Parameters:
sheetnum - the sheet number (0 based)
sheetname - the name for the sheet

doesContainsSheetName

public boolean doesContainsSheetName(java.lang.String name,
                                     int excludeSheetIdx)
Determines whether a workbook contains the provided sheet name. For the purpose of comparison, long names are truncated to 31 chars.

Parameters:
name - the name to test (case insensitive match)
excludeSheetIdx - the sheet to exclude from the check or -1 to include all sheets in the check.
Returns:
true if the sheet contains the name, false otherwise.

setSheetOrder

public void setSheetOrder(java.lang.String sheetname,
                          int pos)
sets the order of appearance for a given sheet.

Parameters:
sheetname - the name of the sheet to reorder
pos - the position that we want to insert the sheet into (0 based)

getSheetName

public java.lang.String getSheetName(int sheetIndex)
gets the name for a given sheet.

Parameters:
sheetIndex - the sheet number (0 based)
Returns:
sheetname the name for the sheet

isSheetHidden

public boolean isSheetHidden(int sheetnum)
Gets the hidden flag for a given sheet. Note that a sheet could instead be set to be very hidden, which is different (isSheetVeryHidden(int))

Parameters:
sheetnum - the sheet number (0 based)
Returns:
True if sheet is hidden

isSheetVeryHidden

public boolean isSheetVeryHidden(int sheetnum)
Gets the very hidden flag for a given sheet. This is different from the normal hidden flag (isSheetHidden(int))

Parameters:
sheetnum - the sheet number (0 based)
Returns:
True if sheet is very hidden

setSheetHidden

public void setSheetHidden(int sheetnum,
                           boolean hidden)
Hide or unhide a sheet

Parameters:
sheetnum - The sheet number
hidden - True to mark the sheet as hidden, false otherwise

setSheetHidden

public void setSheetHidden(int sheetnum,
                           int hidden)
Hide or unhide a sheet. 0 = not hidden 1 = hidden 2 = very hidden.

Parameters:
sheetnum - The sheet number
hidden - 0 for not hidden, 1 for hidden, 2 for very hidden

getSheetIndex

public int getSheetIndex(java.lang.String name)
get the sheet's index

Parameters:
name - sheet name
Returns:
sheet index or -1 if it was not found.

removeSheet

public void removeSheet(int sheetIndex)
Parameters:
sheetIndex - zero based sheet index

getNumSheets

public int getNumSheets()
returns the number of boundsheet objects contained in this workbook.

Returns:
number of BoundSheet records

getNumExFormats

public int getNumExFormats()
get the number of ExtendedFormat records contained in this workbook.

Returns:
int count of ExtendedFormat records

getExFormatAt

public ExtendedFormatRecord getExFormatAt(int index)
gets the ExtendedFormatRecord at the given 0-based index

Parameters:
index - of the Extended format record (0-based)
Returns:
ExtendedFormatRecord at the given index

removeExFormatRecord

public void removeExFormatRecord(ExtendedFormatRecord rec)
Removes the given ExtendedFormatRecord record from the file's list. This will make all subsequent font indicies drop by one, so you'll need to update those yourself!

createCellXF

public ExtendedFormatRecord createCellXF()
creates a new Cell-type Extneded Format Record and adds it to the end of ExtendedFormatRecords collection

Returns:
ExtendedFormatRecord that was created

getStyleRecord

public StyleRecord getStyleRecord(int xfIndex)
Returns the StyleRecord for the given xfIndex, or null if that ExtendedFormat doesn't have a Style set.

createStyleRecord

public StyleRecord createStyleRecord(int xfIndex)
Creates a new StyleRecord, for the given Extended Format index, and adds it onto the end of the records collection

addSSTString

public int addSSTString(UnicodeString string)
Adds a string to the SST table and returns its index (if its a duplicate just returns its index and update the counts) ASSUMES compressed unicode (meaning 8bit)

Parameters:
string - the string to be added to the SSTRecord
Returns:
index of the string within the SSTRecord

getSSTString

public UnicodeString getSSTString(int str)
given an index into the SST table, this function returns the corresponding String value

Returns:
String containing the SST String

insertSST

public void insertSST()
use this function to add a Shared String Table to an existing sheet (say generated by a different java api) without an sst....

See Also:
createExtendedSST(), SSTRecord

serialize

public int serialize(int offset,
                     byte[] data)
Serializes all records int the worksheet section into a big byte array. Use this to write the Workbook out.

Parameters:
offset - of the data to be written
data - array of bytes to write this to

getSize

public int getSize()

findSheetNameFromExternSheet

public java.lang.String findSheetNameFromExternSheet(int externSheetIndex)
finds the sheet name by his extern sheet index

Parameters:
externSheetIndex - extern sheet index
Returns:
sheet name.

getExternalSheet

public EvaluationWorkbook.ExternalSheet getExternalSheet(int externSheetIndex)

getExternalName

public EvaluationWorkbook.ExternalName getExternalName(int externSheetIndex,
                                                       int externNameIndex)

getSheetIndexFromExternSheetIndex

public int getSheetIndexFromExternSheetIndex(int externSheetNumber)
Finds the sheet index for a particular external sheet number.

Parameters:
externSheetNumber - The external sheet number to convert
Returns:
The index to the sheet found.

checkExternSheet

public short checkExternSheet(int sheetNumber)
returns the extern sheet number for specific sheet number , if this sheet doesn't exist in extern sheet , add it

Parameters:
sheetNumber - sheet number
Returns:
index to extern sheet

getExternalSheetIndex

public int getExternalSheetIndex(java.lang.String workbookName,
                                 java.lang.String sheetName)

getNumNames

public int getNumNames()
gets the total number of names

Returns:
number of names

getNameRecord

public NameRecord getNameRecord(int index)
gets the name record

Parameters:
index - name index
Returns:
name record

getNameCommentRecord

public NameCommentRecord getNameCommentRecord(NameRecord nameRecord)
gets the name comment record

Parameters:
nameRecord - name record who's comment is required.
Returns:
name comment record or null if there isn't one for the given name.

createName

public NameRecord createName()
creates new name

Returns:
new name record

addName

public NameRecord addName(NameRecord name)
creates new name

Returns:
new name record

createBuiltInName

public NameRecord createBuiltInName(byte builtInName,
                                    int sheetNumber)
Generates a NameRecord to represent a built-in region

Returns:
a new NameRecord

removeName

public void removeName(int nameIndex)
removes the name

Parameters:
nameIndex - name index

updateNameCommentRecordCache

public void updateNameCommentRecordCache(NameCommentRecord commentRecord)
If a NameCommentRecord is added or the name it references is renamed, then this will update the lookup cache for it.

getFormat

public short getFormat(java.lang.String format,
                       boolean createIfNotFound)
Returns a format index that matches the passed in format. It does not tie into HSSFDataFormat.

Parameters:
format - the format string
createIfNotFound - creates a new format if format not found
Returns:
the format id of a format that matches or -1 if none found and createIfNotFound

getFormats

public java.util.List<FormatRecord> getFormats()
Returns the list of FormatRecords in the workbook.

Returns:
ArrayList of FormatRecords in the notebook

createFormat

public int createFormat(java.lang.String formatString)
Creates a FormatRecord, inserts it, and returns the index code.

Parameters:
formatString - the format string
Returns:
the index code of the format record.
See Also:
FormatRecord, Record

findFirstRecordBySid

public Record findFirstRecordBySid(short sid)
Returns the first occurance of a record matching a particular sid.

findFirstRecordLocBySid

public int findFirstRecordLocBySid(short sid)
Returns the index of a record matching a particular sid.

Parameters:
sid - The sid of the record to match
Returns:
The index of -1 if no match made.

findNextRecordBySid

public Record findNextRecordBySid(short sid,
                                  int pos)
Returns the next occurance of a record matching a particular sid.

getHyperlinks

public java.util.List<HyperlinkRecord> getHyperlinks()

getRecords

public java.util.List<Record> getRecords()

isUsing1904DateWindowing

public boolean isUsing1904DateWindowing()
Whether date windowing is based on 1/2/1904 or 1/1/1900. Some versions of Excel (Mac) can save workbooks using 1904 date windowing.

Returns:
true if using 1904 date windowing

getCustomPalette

public PaletteRecord getCustomPalette()
Returns the custom palette in use for this workbook; if a custom palette record does not exist, then it is created.

findDrawingGroup

public DrawingManager2 findDrawingGroup()
Finds the primary drawing group, if one already exists

createDrawingGroup

public void createDrawingGroup()
Creates a primary drawing group record. If it already exists then it's modified.

getWindowOne

public WindowOneRecord getWindowOne()

getBSERecord

public EscherBSERecord getBSERecord(int pictureIndex)

addBSERecord

public int addBSERecord(EscherBSERecord e)

getDrawingManager

public DrawingManager2 getDrawingManager()

getWriteProtect

public WriteProtectRecord getWriteProtect()

getWriteAccess

public WriteAccessRecord getWriteAccess()

getFileSharing

public FileSharingRecord getFileSharing()

isWriteProtected

public boolean isWriteProtected()
is the workbook protected with a password (not encrypted)?

writeProtectWorkbook

public void writeProtectWorkbook(java.lang.String password,
                                 java.lang.String username)
protect a workbook with a password (not encypted, just sets writeprotect flags and the password.

Parameters:
password - to set

unwriteProtectWorkbook

public void unwriteProtectWorkbook()
removes the write protect flag

resolveNameXText

public java.lang.String resolveNameXText(int refIndex,
                                         int definedNameIndex)
Parameters:
refIndex - Index to REF entry in EXTERNSHEET record in the Link Table
definedNameIndex - zero-based to DEFINEDNAME or EXTERNALNAME record
Returns:
the string representation of the defined or external name

getNameXPtg

public NameXPtg getNameXPtg(java.lang.String name,
                            UDFFinder udf)
Parameters:
name - the name of an external function, typically a name of a UDF
udf - locator of user-defiend functions to resolve names of VBA and Add-In functions
Returns:
the external name or null

cloneDrawings

public void cloneDrawings(InternalSheet sheet)
Check if the cloned sheet has drawings. If yes, then allocate a new drawing group ID and re-generate shape IDs

Parameters:
sheet - the cloned sheet

cloneFilter

public NameRecord cloneFilter(int filterDbNameIndex,
                              int newSheetIndex)

updateNamesAfterCellShift

public void updateNamesAfterCellShift(FormulaShifter shifter)
Updates named ranges due to moving of cells

getRecalcId

public RecalcIdRecord getRecalcId()
Get or create RecalcIdRecord

See Also:
HSSFWorkbook.setForceFormulaRecalculation(boolean)

changeExternalReference

public boolean changeExternalReference(java.lang.String oldUrl,
                                       java.lang.String newUrl)
Changes an external referenced file to another file. A formular in Excel which refers a cell in another file is saved in two parts: The referenced file is stored in an reference table. the row/cell information is saved separate. This method invokation will only change the reference in the lookup-table itself.

Parameters:
oldUrl - The old URL to search for and which is to be replaced
newUrl - The URL replacement
Returns:
true if the oldUrl was found and replaced with newUrl. Otherwise false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class LineShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
        extended by  org.apache.poi.hssf.model.LineShape

public class LineShape
extends AbstractShape

Represents a line shape and creates all the line specific low level records.

Author:
Glen Stampoultzis (glens at apache.org)

Method Summary
ObjRecord | getObjRecord()
EscherContainerRecord | getSpContainer()
Methods inherited from class org.apache.poi.hssf.model.AbstractShape
addStandardOptions, createAnchor, createShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getSpContainer

public EscherContainerRecord getSpContainer()
Specified by:
getSpContainer in class AbstractShape
Returns:
The shape container and it's children that can represent this shape.

getObjRecord

public ObjRecord getObjRecord()
Specified by:
getObjRecord in class AbstractShape
Returns:
The object record that is associated with this shape.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.model
Classes
AbstractShape
ComboboxShape
CommentShape
ConvertAnchor
DrawingManager
DrawingManager2
HSSFFormulaParser
InternalSheet
InternalWorkbook
LineShape
PictureShape
PolygonShape
RecordStream
RowBlocksReader
SimpleFilledShape
TextboxShape
WorkbookRecordList


org.apache.poi.hssf.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.model

Provides low level API structures for reading, writing, modifying XLS files.

See:
Description

Class Summary
AbstractShape | An abstract shape is the lowlevel model for a shape.
ComboboxShape | Represents a combobox shape.
CommentShape | Represents a cell comment.
ConvertAnchor |
DrawingManager | Provides utilities to manage drawing groups.
DrawingManager2 | Provides utilities to manage drawing groups.
HSSFFormulaParser | HSSF wrapper for the FormulaParser and FormulaRenderer
InternalSheet | Low level model implementation of a Sheet (one workbook contains many sheets) This file contains the low level binary records starting at the sheets BOF and ending with the sheets EOF.
InternalWorkbook | Low level model implementation of a Workbook.
LineShape | Represents a line shape and creates all the line specific low level records.
PictureShape | Represents a picture shape and creates all specific low level records.
PolygonShape |
RecordStream | Simplifies iteration over a sequence of Record objects.
RowBlocksReader | Segregates the 'Row Blocks' section of a single sheet into plain row/cell records and shared formula records.
SimpleFilledShape |
TextboxShape | Represents an textbox shape and converts between the highlevel records and lowlevel records for an oval.
WorkbookRecordList |

Package org.apache.poi.hssf.model Description

Provides low level API structures for reading, writing, modifying XLS files.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.hssf.usermodel


org.apache.poi.hssf.model Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.model.AbstractShape
      • org.apache.poi.hssf.model.ComboboxShape
      • org.apache.poi.hssf.model.LineShape
      • org.apache.poi.hssf.model.PictureShape
      • org.apache.poi.hssf.model.PolygonShape
      • org.apache.poi.hssf.model.SimpleFilledShape
      • org.apache.poi.hssf.model.TextboxShape
        • org.apache.poi.hssf.model.CommentShape
    • org.apache.poi.hssf.model.ConvertAnchor
    • org.apache.poi.hssf.model.DrawingManager
    • org.apache.poi.hssf.model.DrawingManager2
    • org.apache.poi.hssf.model.HSSFFormulaParser
    • org.apache.poi.hssf.model.InternalSheet
    • org.apache.poi.hssf.model.InternalWorkbook
    • org.apache.poi.hssf.model.RecordStream
    • org.apache.poi.hssf.model.RowBlocksReader
    • org.apache.poi.hssf.model.WorkbookRecordList (implements java.lang.Iterable<T>)


Uses of Package org.apache.poi.hssf.model

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.model

Packages that use org.apache.poi.hssf.model
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Classes in org.apache.poi.hssf.model used by org.apache.poi.hssf.eventusermodel
InternalWorkbook
Low level model implementation of a Workbook.

Classes in org.apache.poi.hssf.model used by org.apache.poi.hssf.model
AbstractShape
An abstract shape is the lowlevel model for a shape.
DrawingManager2
Provides utilities to manage drawing groups.
InternalSheet
Low level model implementation of a Sheet (one workbook contains many sheets) This file contains the low level binary records starting at the sheets BOF and ending with the sheets EOF.
InternalWorkbook
Low level model implementation of a Workbook.
RecordStream
Simplifies iteration over a sequence of Record objects.
TextboxShape
Represents an textbox shape and converts between the highlevel records and lowlevel records for an oval.

Classes in org.apache.poi.hssf.model used by org.apache.poi.hssf.record
DrawingManager2
Provides utilities to manage drawing groups.

Classes in org.apache.poi.hssf.model used by org.apache.poi.hssf.record.aggregates
RecordStream
Simplifies iteration over a sequence of Record objects.

Classes in org.apache.poi.hssf.model used by org.apache.poi.hssf.usermodel
InternalSheet
Low level model implementation of a Sheet (one workbook contains many sheets) This file contains the low level binary records starting at the sheets BOF and ending with the sheets EOF.
InternalWorkbook
Low level model implementation of a Workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PictureShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class PictureShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
        extended by  org.apache.poi.hssf.model.PictureShape

public class PictureShape
extends AbstractShape

Represents a picture shape and creates all specific low level records.

Author:
Glen Stampoultzis (glens at apache.org)

Method Summary
ObjRecord | getObjRecord()
EscherContainerRecord | getSpContainer()
Methods inherited from class org.apache.poi.hssf.model.AbstractShape
addStandardOptions, createAnchor, createShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getSpContainer

public EscherContainerRecord getSpContainer()
Specified by:
getSpContainer in class AbstractShape
Returns:
The shape container and it's children that can represent this shape.

getObjRecord

public ObjRecord getObjRecord()
Specified by:
getObjRecord in class AbstractShape
Returns:
The object record that is associated with this shape.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PolygonShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class PolygonShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
        extended by  org.apache.poi.hssf.model.PolygonShape

public class PolygonShape
extends AbstractShape

Field Summary
static short OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING
Method Summary
ObjRecord | getObjRecord()
EscherContainerRecord | getSpContainer()
Methods inherited from class org.apache.poi.hssf.model.AbstractShape
addStandardOptions, createAnchor, createShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING

public static final short OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING
See Also:
Constant Field Values
Method Detail

getSpContainer

public EscherContainerRecord getSpContainer()
Specified by:
getSpContainer in class AbstractShape
Returns:
The shape container and it's children that can represent this shape.

getObjRecord

public ObjRecord getObjRecord()
Specified by:
getObjRecord in class AbstractShape
Returns:
The object record that is associated with this shape.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class RecordStream

java.lang.Object
    extended by  org.apache.poi.hssf.model.RecordStream

public final class RecordStream
extends java.lang.Object

Simplifies iteration over a sequence of Record objects.

Author:
Josh Micich

Constructor Summary
RecordStream(java.util.List<Record> records, int startIx)
RecordStream(java.util.List<Record> inputList, int startIndex, int endIx)
Creates a RecordStream bounded by startIndex and endIndex
Method Summary
int | getCountRead()
Record | getNext()
boolean | hasNext()
java.lang.Class<? extends Record> | peekNextClass()
int | peekNextSid()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordStream

public RecordStream(java.util.List<Record> inputList,
                    int startIndex,
                    int endIx)
Creates a RecordStream bounded by startIndex and endIndex

RecordStream

public RecordStream(java.util.List<Record> records,
                    int startIx)
Method Detail

hasNext

public boolean hasNext()

getNext

public Record getNext()

peekNextClass

public java.lang.Class<? extends Record> peekNextClass()
Returns:
the Class of the next Record. null if this stream is exhausted.

peekNextSid

public int peekNextSid()
Returns:
-1 if at end of records

getCountRead

public int getCountRead()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RowBlocksReader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class RowBlocksReader

java.lang.Object
    extended by  org.apache.poi.hssf.model.RowBlocksReader

public final class RowBlocksReader
extends java.lang.Object

Segregates the 'Row Blocks' section of a single sheet into plain row/cell records and shared formula records.

Author:
Josh Micich

Constructor Summary
RowBlocksReader(RecordStream rs)
Also collects any loose MergeCellRecords and puts them in the supplied mergedCellsTable
Method Summary
MergeCellsRecord[] | getLooseMergedCells() Some unconventional apps place MergeCellsRecords within the row block.
RecordStream | getPlainRecordStream()
SharedValueManager | getSharedFormulaManager()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RowBlocksReader

public RowBlocksReader(RecordStream rs)
Also collects any loose MergeCellRecords and puts them in the supplied mergedCellsTable

Method Detail

getLooseMergedCells

public MergeCellsRecord[] getLooseMergedCells()
Some unconventional apps place MergeCellsRecords within the row block. They actually should be in the MergedCellsTable which is much later (see bug 45699).

Returns:
any loose MergeCellsRecords found

getSharedFormulaManager

public SharedValueManager getSharedFormulaManager()

getPlainRecordStream

public RecordStream getPlainRecordStream()
Returns:
a RecordStream containing all the non-SharedFormulaRecord non-ArrayRecord and non-TableRecord Records.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleFilledShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class SimpleFilledShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
        extended by  org.apache.poi.hssf.model.SimpleFilledShape

public class SimpleFilledShape
extends AbstractShape

Method Summary
ObjRecord | getObjRecord()
EscherContainerRecord | getSpContainer()
Methods inherited from class org.apache.poi.hssf.model.AbstractShape
addStandardOptions, createAnchor, createShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getSpContainer

public EscherContainerRecord getSpContainer()
Specified by:
getSpContainer in class AbstractShape
Returns:
The shape container and it's children that can represent this shape.

getObjRecord

public ObjRecord getObjRecord()
Specified by:
getObjRecord in class AbstractShape
Returns:
The object record that is associated with this shape.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextboxShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class TextboxShape

java.lang.Object
    extended by  org.apache.poi.hssf.model.AbstractShape
        extended by  org.apache.poi.hssf.model.TextboxShape
Direct Known Subclasses:
CommentShape
public class TextboxShape
extends AbstractShape

Represents an textbox shape and converts between the highlevel records and lowlevel records for an oval.

Author:
Glen Stampoultzis (glens at apache.org)

Method Summary
EscherRecord | getEscherTextbox()
ObjRecord | getObjRecord()
EscherContainerRecord | getSpContainer()
TextObjectRecord | getTextObjectRecord()
Methods inherited from class org.apache.poi.hssf.model.AbstractShape
addStandardOptions, createAnchor, createShape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getSpContainer

public EscherContainerRecord getSpContainer()
Specified by:
getSpContainer in class AbstractShape
Returns:
The shape container and it's children that can represent this shape.

getObjRecord

public ObjRecord getObjRecord()
Specified by:
getObjRecord in class AbstractShape
Returns:
The object record that is associated with this shape.

getTextObjectRecord

public TextObjectRecord getTextObjectRecord()

getEscherTextbox

public EscherRecord getEscherTextbox()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkbookRecordList

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.model
Class WorkbookRecordList

java.lang.Object
    extended by  org.apache.poi.hssf.model.WorkbookRecordList
All Implemented Interfaces:
java.lang.Iterable<Record>
public final class WorkbookRecordList
extends java.lang.Object
implements java.lang.Iterable<Record>

Constructor Summary
WorkbookRecordList()
Method Summary
void | add(int pos, Record r)
Record | get(int i)
int | getBackuppos()
int | getBspos()
int | getExternsheetPos() Returns the externsheetPos.
int | getFontpos()
int | getNamepos() Returns the namepos.
int | getPalettepos()
int | getProtpos()
java.util.List<Record> | getRecords()
int | getSupbookpos() Returns the supbookpos.
int | getTabpos()
int | getXfpos()
java.util.Iterator<Record> | iterator()
void | remove(int pos)
void | remove(java.lang.Object record)
void | setBackuppos(int backuppos)
void | setBspos(int bspos)
void | setExternsheetPos(int externsheetPos) Sets the externsheetPos.
void | setFontpos(int fontpos)
void | setNamepos(int namepos) Sets the namepos.
void | setPalettepos(int palettepos)
void | setProtpos(int protpos)
void | setRecords(java.util.List<Record> records)
void | setSupbookpos(int supbookpos) Sets the supbookpos.
void | setTabpos(int tabpos)
void | setXfpos(int xfpos)
int | size()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkbookRecordList

public WorkbookRecordList()
Method Detail

setRecords

public void setRecords(java.util.List<Record> records)

size

public int size()

get

public Record get(int i)

add

public void add(int pos,
                Record r)

getRecords

public java.util.List<Record> getRecords()

iterator

public java.util.Iterator<Record> iterator()
Specified by:
iterator in interface java.lang.Iterable<Record>

remove

public void remove(java.lang.Object record)

remove

public void remove(int pos)

getProtpos

public int getProtpos()

setProtpos

public void setProtpos(int protpos)

getBspos

public int getBspos()

setBspos

public void setBspos(int bspos)

getTabpos

public int getTabpos()

setTabpos

public void setTabpos(int tabpos)

getFontpos

public int getFontpos()

setFontpos

public void setFontpos(int fontpos)

getXfpos

public int getXfpos()

setXfpos

public void setXfpos(int xfpos)

getBackuppos

public int getBackuppos()

setBackuppos

public void setBackuppos(int backuppos)

getPalettepos

public int getPalettepos()

setPalettepos

public void setPalettepos(int palettepos)

getNamepos

public int getNamepos()
Returns the namepos.

Returns:
int

getSupbookpos

public int getSupbookpos()
Returns the supbookpos.

Returns:
int

setNamepos

public void setNamepos(int namepos)
Sets the namepos.

Parameters:
namepos - The namepos to set

setSupbookpos

public void setSupbookpos(int supbookpos)
Sets the supbookpos.

Parameters:
supbookpos - The supbookpos to set

getExternsheetPos

public int getExternsheetPos()
Returns the externsheetPos.

Returns:
int

setExternsheetPos

public void setExternsheetPos(int externsheetPos)
Sets the externsheetPos.

Parameters:
externsheetPos - The externsheetPos to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.model.AbstractShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.AbstractShape

Packages that use AbstractShape
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of AbstractShape in org.apache.poi.hssf.model

Subclasses of AbstractShape in org.apache.poi.hssf.model
class | ComboboxShape Represents a combobox shape.
class | CommentShape Represents a cell comment.
class | LineShape Represents a line shape and creates all the line specific low level records.
class | PictureShape Represents a picture shape and creates all specific low level records.
class | PolygonShape
class | SimpleFilledShape
class | TextboxShape Represents an textbox shape and converts between the highlevel records and lowlevel records for an oval.

Methods in org.apache.poi.hssf.model that return AbstractShape
static AbstractShape AbstractShape.createShape(HSSFShape hssfShape, int shapeId)
Create a new shape object used to create the escher records.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.ComboboxShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.ComboboxShape

No usage of org.apache.poi.hssf.model.ComboboxShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.CommentShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.CommentShape

No usage of org.apache.poi.hssf.model.CommentShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.ConvertAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.ConvertAnchor

No usage of org.apache.poi.hssf.model.ConvertAnchor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.DrawingManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.DrawingManager

No usage of org.apache.poi.hssf.model.DrawingManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.DrawingManager2

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.DrawingManager2

Packages that use DrawingManager2
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.

Uses of DrawingManager2 in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return DrawingManager2
DrawingManager2 | InternalWorkbook.findDrawingGroup() Finds the primary drawing group, if one already exists
DrawingManager2 | InternalWorkbook.getDrawingManager()

Methods in org.apache.poi.hssf.model with parameters of type DrawingManager2
 int InternalSheet.aggregateDrawingRecords(DrawingManager2 drawingManager, boolean createIfMissing)
Finds the DrawingRecord for our sheet, and attaches it to the DrawingManager (which knows about the overall DrawingGroup for our workbook).

Uses of DrawingManager2 in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type DrawingManager2
static EscherAggregate EscherAggregate.createAggregate(java.util.List records, int locFirstDrawingRecord, DrawingManager2 drawingManager)
Collapses the drawing records into an aggregate.

Constructors in org.apache.poi.hssf.record with parameters of type DrawingManager2
EscherAggregate(DrawingManager2 drawingManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.HSSFFormulaParser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.HSSFFormulaParser

No usage of org.apache.poi.hssf.model.HSSFFormulaParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.InternalSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.InternalSheet

Packages that use InternalSheet
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of InternalSheet in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return InternalSheet
InternalSheet | InternalSheet.cloneSheet() Clones the low level records of this sheet and returns the new sheet instance.
static InternalSheet | InternalSheet.createSheet() Creates a sheet with all the usual records minus values and the "index" record (not required).
static InternalSheet | InternalSheet.createSheet(RecordStream rs) read support (offset used as starting point for search) for low level API.

Methods in org.apache.poi.hssf.model with parameters of type InternalSheet
 void InternalWorkbook.cloneDrawings(InternalSheet sheet)
Check if the cloned sheet has drawings.

Uses of InternalSheet in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel with parameters of type InternalSheet
protected static HSSFComment HSSFCell.findCellComment(InternalSheet sheet, int row, int column)
Cell comment finder.

Constructors in org.apache.poi.hssf.usermodel with parameters of type InternalSheet
HSSFSheet(HSSFWorkbook workbook, InternalSheet sheet)
Creates an HSSFSheet representing the given Sheet object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.InternalWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.InternalWorkbook

Packages that use InternalWorkbook
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of InternalWorkbook in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel that return InternalWorkbook
static InternalWorkbook | EventWorkbookBuilder.createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds) Creates a stub workbook from the supplied records, suitable for use with the HSSFFormulaParser
static InternalWorkbook | EventWorkbookBuilder.createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds, SSTRecord sst) Creates a stub Workbook from the supplied records, suitable for use with the HSSFFormulaParser
InternalWorkbook | EventWorkbookBuilder.SheetRecordCollectingListener.getStubWorkbook()

Uses of InternalWorkbook in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return InternalWorkbook
static InternalWorkbook | InternalWorkbook.createWorkbook() Creates an empty workbook object with three blank sheets and all the empty fields.
static InternalWorkbook | InternalWorkbook.createWorkbook(java.util.List<Record> recs) read support for low level API.

Uses of InternalWorkbook in org.apache.poi.hssf.usermodel

Fields in org.apache.poi.hssf.usermodel declared as InternalWorkbook
protected  InternalWorkbook HSSFSheet._book

Methods in org.apache.poi.hssf.usermodel that return InternalWorkbook
protected  InternalWorkbook HSSFCell.getBoundWorkbook()
Returns the Workbook that this Cell is bound to

Methods in org.apache.poi.hssf.usermodel with parameters of type InternalWorkbook
static HSSFWorkbook | HSSFWorkbook.create(InternalWorkbook book)
java.lang.String | HSSFCellStyle.getDataFormatString(InternalWorkbook workbook) Get the contents of the format string, by looking up the DataFormat against the supplied low level workbook

Constructors in org.apache.poi.hssf.usermodel with parameters of type InternalWorkbook
HSSFCellStyle(short index, ExtendedFormatRecord rec, InternalWorkbook workbook)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.LineShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.LineShape

No usage of org.apache.poi.hssf.model.LineShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.PictureShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.PictureShape

No usage of org.apache.poi.hssf.model.PictureShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.PolygonShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.PolygonShape

No usage of org.apache.poi.hssf.model.PolygonShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.RecordStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.RecordStream

Packages that use RecordStream
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of RecordStream in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return RecordStream
 RecordStream RowBlocksReader.getPlainRecordStream()

Methods in org.apache.poi.hssf.model with parameters of type RecordStream
static InternalSheet InternalSheet.createSheet(RecordStream rs)
read support (offset used as starting point for search) for low level API.

Constructors in org.apache.poi.hssf.model with parameters of type RecordStream
RowBlocksReader(RecordStream rs)
Also collects any loose MergeCellRecords and puts them in the supplied mergedCellsTable

Uses of RecordStream in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type RecordStream
void | PageSettingsBlock.addLateRecords(RecordStream rs) This method reads PageSettingsBlock records from the supplied RecordStream until the first non-PageSettingsBlock record is encountered.
void | WorksheetProtectionBlock.addRecords(RecordStream rs) This method reads WorksheetProtectionBlock records from the supplied RecordStream until the first non-WorksheetProtectionBlock record is encountered.
void | ValueRecordsAggregate.construct(CellValueRecordInterface rec, RecordStream rs, SharedValueManager sfh) Processes a single cell value record
static CFRecordsAggregate | CFRecordsAggregate.createCFAggregate(RecordStream rs) Create CFRecordsAggregate from a list of CF Records
void | MergedCellsTable.read(RecordStream rs) reads zero or more consecutive MergeCellsRecords

Constructors in org.apache.poi.hssf.record.aggregates with parameters of type RecordStream
ChartSubstreamRecordAggregate(RecordStream rs)
ColumnInfoRecordsAggregate(RecordStream rs)
ConditionalFormattingTable(RecordStream rs)
CustomViewSettingsRecordAggregate(RecordStream rs)
DataValidityTable(RecordStream rs)
PageSettingsBlock(RecordStream rs)
RowRecordsAggregate(RecordStream rs, SharedValueManager svm)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.RowBlocksReader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.RowBlocksReader

No usage of org.apache.poi.hssf.model.RowBlocksReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.SimpleFilledShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.SimpleFilledShape

No usage of org.apache.poi.hssf.model.SimpleFilledShape

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.TextboxShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.TextboxShape

Packages that use TextboxShape
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of TextboxShape in org.apache.poi.hssf.model

Subclasses of TextboxShape in org.apache.poi.hssf.model
 class CommentShape
Represents a cell comment.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.model.WorkbookRecordList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.model.WorkbookRecordList

No usage of org.apache.poi.hssf.model.WorkbookRecordList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractEscherHolderRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class AbstractEscherHolderRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.AbstractEscherHolderRecord
Direct Known Subclasses:
DrawingGroupRecord, DrawingRecordForBiffViewer, EscherAggregate
public abstract class AbstractEscherHolderRecord
extends Record

The escher container record is used to hold escher records. It is abstract and must be subclassed for maximum benefit.

Author:
Glen Stampoultzis (glens at apache.org), Michael Zalewski (zalewski at optonline.net)

Constructor Summary
AbstractEscherHolderRecord()
AbstractEscherHolderRecord(RecordInputStream in)
Method Summary
boolean | addEscherRecord(EscherRecord element)
void | addEscherRecord(int index, EscherRecord element)
void | clearEscherRecords()
java.lang.Object | clone()
protected void | convertRawBytesToEscherRecords()
void | decode() Convert raw data to escher records.
EscherRecord | findFirstWithId(short id) Descends into all our children, returning the first EscherRecord with the given id, or null if none found
EscherContainerRecord | getEscherContainer() If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.
EscherRecord | getEscherRecord(int index)
java.util.List<EscherRecord> | getEscherRecords()
byte[] | getRawData()
protected abstract java.lang.String | getRecordName()
int | getRecordSize() gives the current serialized size of the record.
abstract short | getSid() return the non static version of the id for this record.
void | join(AbstractEscherHolderRecord record) Big drawing group records are split but it's easier to deal with them as a whole group so we need to join them together.
void | processContinueRecord(byte[] record)
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
void | setRawData(byte[] rawData)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AbstractEscherHolderRecord

public AbstractEscherHolderRecord()

AbstractEscherHolderRecord

public AbstractEscherHolderRecord(RecordInputStream in)
Method Detail

convertRawBytesToEscherRecords

protected void convertRawBytesToEscherRecords()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getRecordName

protected abstract java.lang.String getRecordName()

serialize

public int serialize(int offset,
                     byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getRecordSize

public int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase

getSid

public abstract short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

addEscherRecord

public void addEscherRecord(int index,
                            EscherRecord element)

addEscherRecord

public boolean addEscherRecord(EscherRecord element)

getEscherRecords

public java.util.List<EscherRecord> getEscherRecords()

clearEscherRecords

public void clearEscherRecords()

getEscherContainer

public EscherContainerRecord getEscherContainer()
If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.

findFirstWithId

public EscherRecord findFirstWithId(short id)
Descends into all our children, returning the first EscherRecord with the given id, or null if none found

getEscherRecord

public EscherRecord getEscherRecord(int index)

join

public void join(AbstractEscherHolderRecord record)
Big drawing group records are split but it's easier to deal with them as a whole group so we need to join them together.

processContinueRecord

public void processContinueRecord(byte[] record)

getRawData

public byte[] getRawData()

setRawData

public void setRawData(byte[] rawData)

decode

public void decode()
Convert raw data to escher records.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ArrayRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ArrayRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SharedValueRecordBase
                    extended by  org.apache.poi.hssf.record.ArrayRecord

public final class ArrayRecord
extends SharedValueRecordBase

ARRAY (0x0221)

Treated in a similar way to SharedFormulaRecord

Author:
Josh Micich

Field Summary
static short sid
Constructor Summary
ArrayRecord(Formula formula, CellRangeAddress8Bit range)
ArrayRecord(RecordInputStream in)
Method Summary
protected int | getExtraDataSize()
Ptg[] | getFormulaTokens()
short | getSid() return the non static version of the id for this record.
boolean | isAlwaysRecalculate()
boolean | isCalculateOnOpen()
protected void | serializeExtraData(LittleEndianOutput out)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.SharedValueRecordBase
getDataSize, getFirstColumn, getFirstRow, getLastColumn, getLastRow, getRange, isFirstCell, isInRange, serialize
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ArrayRecord

public ArrayRecord(RecordInputStream in)

ArrayRecord

public ArrayRecord(Formula formula,
                   CellRangeAddress8Bit range)
Method Detail

isAlwaysRecalculate

public boolean isAlwaysRecalculate()

isCalculateOnOpen

public boolean isCalculateOnOpen()

getFormulaTokens

public Ptg[] getFormulaTokens()

getExtraDataSize

protected int getExtraDataSize()
Specified by:
getExtraDataSize in class SharedValueRecordBase

serializeExtraData

protected void serializeExtraData(LittleEndianOutput out)
Specified by:
serializeExtraData in class SharedValueRecordBase

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutoFilterInfoRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class AutoFilterInfoRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.AutoFilterInfoRecord

public final class AutoFilterInfoRecord
extends StandardRecord

The AutoFilterInfo record specifies the number of columns that have AutoFilter enabled and indicates the beginning of the collection of AutoFilter records.

Author:
Yegor Kozlov

Field Summary
static short sid
Constructor Summary
AutoFilterInfoRecord()
AutoFilterInfoRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getNumEntries() get the number of AutoFilter drop-down arrows on the sheet
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setNumEntries(short num) set the number of AutoFilter drop-down arrows on the sheet
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

AutoFilterInfoRecord

public AutoFilterInfoRecord()

AutoFilterInfoRecord

public AutoFilterInfoRecord(RecordInputStream in)
Method Detail

setNumEntries

public void setNumEntries(short num)
set the number of AutoFilter drop-down arrows on the sheet

Parameters:
num - the number of AutoFilter drop-down arrows on the sheet

getNumEntries

public short getNumEntries()
get the number of AutoFilter drop-down arrows on the sheet

Returns:
the number of AutoFilter drop-down arrows on the sheet

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BackupRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class BackupRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.BackupRecord

public final class BackupRecord
extends StandardRecord

Title: Backup Record

Description: Boolean specifying whether the GUI should store a backup of the file.

REFERENCE: PG 287 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
BackupRecord()
BackupRecord(RecordInputStream in)
Method Summary
short | getBackup() get the backup flag
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBackup(short backup) set the backup flag (0,1)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BackupRecord

public BackupRecord()

BackupRecord

public BackupRecord(RecordInputStream in)
Method Detail

setBackup

public void setBackup(short backup)
set the backup flag (0,1)

Parameters:
backup - backup flag

getBackup

public short getBackup()
get the backup flag

Returns:
short 0/1 (off/on)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BiffHeaderInput

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Interface BiffHeaderInput

All Known Implementing Classes:
Biff8DecryptingStream
public interface BiffHeaderInput

Method Summary
int | available()
int | readDataSize() Read an unsigned short from the stream without decrypting
int | readRecordSID() Read an unsigned short from the stream without decrypting

Method Detail

readRecordSID

int readRecordSID()
Read an unsigned short from the stream without decrypting

readDataSize

int readDataSize()
Read an unsigned short from the stream without decrypting

available

int available()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlankRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class BlankRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.BlankRecord
All Implemented Interfaces:
CellValueRecordInterface
public final class BlankRecord
extends StandardRecord
implements CellValueRecordInterface

Title: Blank cell record (0x0201)

Description: Represents a column in a row with no value but with styling.

REFERENCE: PG 287 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
BlankRecord()
Creates a new instance of BlankRecord
BlankRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getColumn() get the column this cell defines within the row
protected int | getDataSize()
int | getRow() get the row this cell occurs on
short | getSid() return the non static version of the id for this record.
short | getXFIndex() get the index of the extended format record to style this cell with
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setColumn(short col) set the column this cell defines within the row
void | setRow(int row) set the row this cell occurs on
void | setXFIndex(short xf) set the index of the extended format record to style this cell with
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BlankRecord

public BlankRecord()
Creates a new instance of BlankRecord

BlankRecord

public BlankRecord(RecordInputStream in)
Method Detail

setRow

public void setRow(int row)
set the row this cell occurs on

Specified by:
setRow in interface CellValueRecordInterface
Parameters:
row - the row this cell occurs within

getRow

public int getRow()
get the row this cell occurs on

Specified by:
getRow in interface CellValueRecordInterface
Returns:
the row

getColumn

public short getColumn()
get the column this cell defines within the row

Specified by:
getColumn in interface CellValueRecordInterface
Returns:
the column

setXFIndex

public void setXFIndex(short xf)
set the index of the extended format record to style this cell with

Specified by:
setXFIndex in interface CellValueRecordInterface
Parameters:
xf - - the 0-based index of the extended format
See Also:
ExtendedFormatRecord

getXFIndex

public short getXFIndex()
get the index of the extended format record to style this cell with

Specified by:
getXFIndex in interface CellValueRecordInterface
Returns:
extended format index

setColumn

public void setColumn(short col)
set the column this cell defines within the row

Specified by:
setColumn in interface CellValueRecordInterface
Parameters:
col - the column this cell defines

getSid

public short getSid()
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BOFRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class BOFRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.BOFRecord

public final class BOFRecord
extends StandardRecord

Title: Beginning Of File (0x0809)

Description: Somewhat of a misnomer, its used for the beginning of a set of records that have a particular purpose or subject. Used in sheets and workbooks.

REFERENCE: PG 289 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver, Jason Height (jheight at chariot dot net dot au)

Field Summary
static int | BUILD suggested default 0x10d3
static int | BUILD_YEAR suggested default 0x07CC (1996)
static int | HISTORY_MASK suggested default for a normal sheet (0x41)
static short | sid for BIFF8 files the BOF is 0x809.
static int | TYPE_CHART
static int | TYPE_EXCEL_4_MACRO
static int | TYPE_VB_MODULE
static int | TYPE_WORKBOOK
static int | TYPE_WORKSHEET
static int | TYPE_WORKSPACE_FILE
static int | VERSION suggested default (0x0600 - BIFF8)
Constructor Summary
BOFRecord()
Constructs an empty BOFRecord with no fields set.
BOFRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
static BOFRecord | createSheetBOF()
int | getBuild() get the build that wrote this file
int | getBuildYear() Year of the build that wrote this file
protected int | getDataSize()
int | getHistoryBitMask() get the history bit mask (not very useful)
int | getRequiredVersion() get the minimum version required to read this file
short | getSid() return the non static version of the id for this record.
int | getType() type of object this marks
int | getVersion() Version number - for BIFF8 should be 0x06
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBuild(int build) build that wrote this file
void | setBuildYear(int year) Year of the build that wrote this file
void | setHistoryBitMask(int bitmask) set the history bit mask (not very useful)
void | setRequiredVersion(int version) set the minimum version required to read this file
void | setType(int type) type of object this marks
void | setVersion(int version) Version number - for BIFF8 should be 0x06
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
for BIFF8 files the BOF is 0x809. For earlier versions it was 0x09 or 0x(biffversion)09

See Also:
Constant Field Values

VERSION

public static final int VERSION
suggested default (0x0600 - BIFF8)

See Also:
Constant Field Values

BUILD

public static final int BUILD
suggested default 0x10d3

See Also:
Constant Field Values

BUILD_YEAR

public static final int BUILD_YEAR
suggested default 0x07CC (1996)

See Also:
Constant Field Values

HISTORY_MASK

public static final int HISTORY_MASK
suggested default for a normal sheet (0x41)

See Also:
Constant Field Values

TYPE_WORKBOOK

public static final int TYPE_WORKBOOK
See Also:
Constant Field Values

TYPE_VB_MODULE

public static final int TYPE_VB_MODULE
See Also:
Constant Field Values

TYPE_WORKSHEET

public static final int TYPE_WORKSHEET
See Also:
Constant Field Values

TYPE_CHART

public static final int TYPE_CHART
See Also:
Constant Field Values

TYPE_EXCEL_4_MACRO

public static final int TYPE_EXCEL_4_MACRO
See Also:
Constant Field Values

TYPE_WORKSPACE_FILE

public static final int TYPE_WORKSPACE_FILE
See Also:
Constant Field Values
Constructor Detail

BOFRecord

public BOFRecord()
Constructs an empty BOFRecord with no fields set.

BOFRecord

public BOFRecord(RecordInputStream in)
Method Detail

createSheetBOF

public static BOFRecord createSheetBOF()

setVersion

public void setVersion(int version)
Version number - for BIFF8 should be 0x06

Parameters:
version - version to be set
See Also:
VERSION

setType

public void setType(int type)
type of object this marks

Parameters:
type - type to be set
See Also:
TYPE_WORKBOOK, TYPE_VB_MODULE, TYPE_WORKSHEET, TYPE_CHART, TYPE_EXCEL_4_MACRO, TYPE_WORKSPACE_FILE

setBuild

public void setBuild(int build)
build that wrote this file

Parameters:
build - build number to set
See Also:
BUILD

setBuildYear

public void setBuildYear(int year)
Year of the build that wrote this file

Parameters:
year - build year to set
See Also:
BUILD_YEAR

setHistoryBitMask

public void setHistoryBitMask(int bitmask)
set the history bit mask (not very useful)

Parameters:
bitmask - bitmask to set for the history
See Also:
HISTORY_MASK

setRequiredVersion

public void setRequiredVersion(int version)
set the minimum version required to read this file

Parameters:
version - version to set
See Also:
VERSION

getVersion

public int getVersion()
Version number - for BIFF8 should be 0x06

Returns:
version number of the generator of this file
See Also:
VERSION

getType

public int getType()
type of object this marks

Returns:
type of object
See Also:
TYPE_WORKBOOK, TYPE_VB_MODULE, TYPE_WORKSHEET, TYPE_CHART, TYPE_EXCEL_4_MACRO, TYPE_WORKSPACE_FILE

getBuild

public int getBuild()
get the build that wrote this file

Returns:
short build number of the generator of this file
See Also:
BUILD

getBuildYear

public int getBuildYear()
Year of the build that wrote this file

Returns:
short build year of the generator of this file
See Also:
BUILD_YEAR

getHistoryBitMask

public int getHistoryBitMask()
get the history bit mask (not very useful)

Returns:
int bitmask showing the history of the file (who cares!)
See Also:
HISTORY_MASK

getRequiredVersion

public int getRequiredVersion()
get the minimum version required to read this file

Returns:
int least version that can read the file
See Also:
VERSION

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BookBoolRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class BookBoolRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.BookBoolRecord

public final class BookBoolRecord
extends StandardRecord

Title: Save External Links record (BookBool)

Description: Contains a flag specifying whether the Gui should save externally linked values from other workbooks.

REFERENCE: PG 289 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
BookBoolRecord()
BookBoolRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSaveLinkValues() get the save ext links flag
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setSaveLinkValues(short flag) set the save ext links flag
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BookBoolRecord

public BookBoolRecord()

BookBoolRecord

public BookBoolRecord(RecordInputStream in)
Method Detail

setSaveLinkValues

public void setSaveLinkValues(short flag)
set the save ext links flag

Parameters:
flag - flag (0/1 -off/on)

getSaveLinkValues

public short getSaveLinkValues()
get the save ext links flag

Returns:
short 0/1 (off/on)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BoolErrRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class BoolErrRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CellRecord
                    extended by  org.apache.poi.hssf.record.BoolErrRecord
All Implemented Interfaces:
CellValueRecordInterface
public final class BoolErrRecord
extends CellRecord

Creates new BoolErrRecord. (0x0205)

REFERENCE: PG ??? Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Michael P. Harhen, Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
BoolErrRecord()
Creates new BoolErrRecord
BoolErrRecord(RecordInputStream in)
Method Summary
protected  void appendValueText(java.lang.StringBuilder sb)
Append specific debug info (used by CellRecord.toString() for the value contained in this record.
 java.lang.Object clone()
 boolean getBooleanValue()
get the value for the cell
 byte getErrorValue()
get the error value for the cell
protected  java.lang.String getRecordName()
Gets the debug info BIFF record type name (used by CellRecord.toString().
 short getSid()
return the non static version of the id for this record.
protected  int getValueDataSize()
 boolean isBoolean()
Indicates whether the call holds a boolean value
 boolean isError()
Indicates whether the call holds an error value
protected  void serializeValue(LittleEndianOutput out)
writes out the value data for this cell record
 void setValue(boolean value)
set the boolean value for the cell
 void setValue(byte value)
set the error value for the cell
Methods inherited from class org.apache.poi.hssf.record.CellRecord
copyBaseFields, getColumn, getDataSize, getRow, getXFIndex, serialize, setColumn, setRow, setXFIndex, toString
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BoolErrRecord

public BoolErrRecord()
Creates new BoolErrRecord

BoolErrRecord

public BoolErrRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

setValue

public void setValue(boolean value)
set the boolean value for the cell

Parameters:
value - representing the boolean value

setValue

public void setValue(byte value)
set the error value for the cell

Parameters:
value - error representing the error value this value can only be 0,7,15,23,29,36 or 42 see bugzilla bug 16560 for an explanation

getBooleanValue

public boolean getBooleanValue()
get the value for the cell

Returns:
boolean representing the boolean value

getErrorValue

public byte getErrorValue()
get the error value for the cell

Returns:
byte representing the error value

isBoolean

public boolean isBoolean()
Indicates whether the call holds a boolean value

Returns:
boolean true if the cell holds a boolean value

isError

public boolean isError()
Indicates whether the call holds an error value

Returns:
boolean true if the cell holds an error value

getRecordName

protected java.lang.String getRecordName()
Description copied from class: CellRecord
Gets the debug info BIFF record type name (used by CellRecord.toString().

Specified by:
getRecordName in class CellRecord

appendValueText

protected void appendValueText(java.lang.StringBuilder sb)
Description copied from class: CellRecord
Append specific debug info (used by CellRecord.toString() for the value contained in this record. Trailing new-line should not be appended (superclass does that).

Specified by:
appendValueText in class CellRecord

serializeValue

protected void serializeValue(LittleEndianOutput out)
Description copied from class: CellRecord
writes out the value data for this cell record

Specified by:
serializeValue in class CellRecord

getValueDataSize

protected int getValueDataSize()
Specified by:
getValueDataSize in class CellRecord
Returns:
the size (in bytes) of the value data for this cell record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BottomMarginRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class BottomMarginRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.BottomMarginRecord
All Implemented Interfaces:
Margin
public final class BottomMarginRecord
extends StandardRecord
implements Margin

Record for the bottom margin.

Author:
Shawn Laubach (slaubach at apache dot org)

Field Summary
static short sid
Constructor Summary
BottomMarginRecord()
BottomMarginRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
double | getMargin() Get the margin field for the BottomMargin record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setMargin(double field_1_margin) Set the margin field for the BottomMargin record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BottomMarginRecord

public BottomMarginRecord()

BottomMarginRecord

public BottomMarginRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getMargin

public double getMargin()
Get the margin field for the BottomMargin record.

Specified by:
getMargin in interface Margin

setMargin

public void setMargin(double field_1_margin)
Set the margin field for the BottomMargin record.

Specified by:
setMargin in interface Margin

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BoundSheetRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class BoundSheetRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.BoundSheetRecord

public final class BoundSheetRecord
extends StandardRecord

Title: Bound Sheet Record (aka BundleSheet) (0x0085)

Description: Defines a sheet within a workbook. Basically stores the sheet name and tells where the Beginning of file record is within the HSSF file.

REFERENCE: PG 291 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Sergei Kozello (sergeikozello at mail.ru)

Field Summary
static short sid
Constructor Summary
BoundSheetRecord(RecordInputStream in)
UTF8: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + len(str) UNICODE: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + 2 * len(str)
BoundSheetRecord(java.lang.String sheetname)
Method Summary
protected int | getDataSize()
int | getPositionOfBof() get the offset in bytes of the Beginning of File Marker within the HSSF Stream part of the POIFS file
java.lang.String | getSheetname() get the sheetname for this sheet.
short | getSid() return the non static version of the id for this record.
boolean | isHidden() Is the sheet hidden? Different from very hidden
boolean | isVeryHidden() Is the sheet very hidden? Different from (normal) hidden
static BoundSheetRecord[] | orderByBofPosition(java.util.List<BoundSheetRecord> boundSheetRecords) Converts a List of BoundSheetRecords to an array and sorts by the position of their BOFs.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setHidden(boolean hidden) Is the sheet hidden? Different from very hidden
void | setPositionOfBof(int pos) set the offset in bytes of the Beginning of File Marker within the HSSF Stream part of the POIFS file
void | setSheetname(java.lang.String sheetName) Set the sheetname for this sheet.
void | setVeryHidden(boolean veryHidden) Is the sheet very hidden? Different from (normal) hidden
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BoundSheetRecord

public BoundSheetRecord(java.lang.String sheetname)

BoundSheetRecord

public BoundSheetRecord(RecordInputStream in)
UTF8: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + len(str) UNICODE: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + 2 * len(str)

Method Detail

setPositionOfBof

public void setPositionOfBof(int pos)
set the offset in bytes of the Beginning of File Marker within the HSSF Stream part of the POIFS file

Parameters:
pos - offset in bytes

setSheetname

public void setSheetname(java.lang.String sheetName)
Set the sheetname for this sheet. (this appears in the tabs at the bottom)

Parameters:
sheetName - the name of the sheet
Throws:
java.lang.IllegalArgumentException - if sheet name will cause excel to crash.
See Also:
for a safe way to create valid names

getPositionOfBof

public int getPositionOfBof()
get the offset in bytes of the Beginning of File Marker within the HSSF Stream part of the POIFS file

Returns:
offset in bytes

getSheetname

public java.lang.String getSheetname()
get the sheetname for this sheet. (this appears in the tabs at the bottom)

Returns:
sheetname the name of the sheet

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

isHidden

public boolean isHidden()
Is the sheet hidden? Different from very hidden

setHidden

public void setHidden(boolean hidden)
Is the sheet hidden? Different from very hidden

isVeryHidden

public boolean isVeryHidden()
Is the sheet very hidden? Different from (normal) hidden

setVeryHidden

public void setVeryHidden(boolean veryHidden)
Is the sheet very hidden? Different from (normal) hidden

orderByBofPosition

public static BoundSheetRecord[] orderByBofPosition(java.util.List<BoundSheetRecord> boundSheetRecords)
Converts a List of BoundSheetRecords to an array and sorts by the position of their BOFs.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CalcCountRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CalcCountRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CalcCountRecord

public final class CalcCountRecord
extends StandardRecord

Title: Calc Count Record Description: Specifies the maximum times the gui should perform a formula recalculation. For instance: in the case a formula includes cells that are themselves a result of a formula and a value changes. This is essentially a failsafe against an infinate loop in the event the formulas are not independant.

REFERENCE: PG 292 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)
See Also:
CalcModeRecord

Field Summary
static short sid
Constructor Summary
CalcCountRecord()
CalcCountRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getIterations() get the number of iterations to perform
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setIterations(short iterations) set the number of iterations to perform
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

CalcCountRecord

public CalcCountRecord()

CalcCountRecord

public CalcCountRecord(RecordInputStream in)
Method Detail

setIterations

public void setIterations(short iterations)
set the number of iterations to perform

Parameters:
iterations - to perform

getIterations

public short getIterations()
get the number of iterations to perform

Returns:
iterations

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CalcModeRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CalcModeRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CalcModeRecord

public final class CalcModeRecord
extends StandardRecord

Title: Calc Mode Record

Description: Tells the gui whether to calculate formulas automatically, manually or automatically except for tables.

REFERENCE: PG 292 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)
See Also:
CalcCountRecord

Field Summary
static short | AUTOMATIC automatically calculate formulas (1)
static short | AUTOMATIC_EXCEPT_TABLES automatically calculate formulas except for tables (-1)
static short | MANUAL manually calculate formulas (0)
static short | sid
Constructor Summary
CalcModeRecord()
CalcModeRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getCalcMode() get the calc mode flag for formulas
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCalcMode(short calcmode) set the calc mode flag for formulas
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

MANUAL

public static final short MANUAL
manually calculate formulas (0)

See Also:
Constant Field Values

AUTOMATIC

public static final short AUTOMATIC
automatically calculate formulas (1)

See Also:
Constant Field Values

AUTOMATIC_EXCEPT_TABLES

public static final short AUTOMATIC_EXCEPT_TABLES
automatically calculate formulas except for tables (-1)

See Also:
Constant Field Values
Constructor Detail

CalcModeRecord

public CalcModeRecord()

CalcModeRecord

public CalcModeRecord(RecordInputStream in)
Method Detail

setCalcMode

public void setCalcMode(short calcmode)
set the calc mode flag for formulas

Parameters:
calcmode - one of the three flags above
See Also:
MANUAL, AUTOMATIC, AUTOMATIC_EXCEPT_TABLES

getCalcMode

public short getCalcMode()
get the calc mode flag for formulas

Returns:
calcmode one of the three flags above
See Also:
MANUAL, AUTOMATIC, AUTOMATIC_EXCEPT_TABLES

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CellRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CellRecord
All Implemented Interfaces:
CellValueRecordInterface
Direct Known Subclasses:
BoolErrRecord, FormulaRecord, LabelSSTRecord, NumberRecord, RKRecord
public abstract class CellRecord
extends StandardRecord
implements CellValueRecordInterface

Base class for all cell value records (implementors of CellValueRecordInterface). Subclasses are expected to manage the cell data values (of various types).

Author:
Josh Micich

Constructor Summary
protected | CellRecord()
protected | CellRecord(RecordInputStream in)
Method Summary
protected abstract  void appendValueText(java.lang.StringBuilder sb)
Append specific debug info (used by toString() for the value contained in this record.
protected  void copyBaseFields(CellRecord rec)
 short getColumn()
protected  int getDataSize()
protected abstract  java.lang.String getRecordName()
Gets the debug info BIFF record type name (used by toString().
 int getRow()
protected abstract  int getValueDataSize()
 short getXFIndex()
get the index to the ExtendedFormat
 void serialize(LittleEndianOutput out)
Write the data content of this BIFF record.
protected abstract  void serializeValue(LittleEndianOutput out)
writes out the value data for this cell record
 void setColumn(short col)
 void setRow(int row)
 void setXFIndex(short xf)
set the index to the ExtendedFormat
 java.lang.String toString()
get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, getSid, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CellRecord

protected CellRecord()

CellRecord

protected CellRecord(RecordInputStream in)
Method Detail

setRow

public final void setRow(int row)
Specified by:
setRow in interface CellValueRecordInterface
Parameters:
row - the row this cell occurs within

setColumn

public final void setColumn(short col)
Specified by:
setColumn in interface CellValueRecordInterface
Parameters:
col - the column this cell defines

setXFIndex

public final void setXFIndex(short xf)
set the index to the ExtendedFormat

Specified by:
setXFIndex in interface CellValueRecordInterface
Parameters:
xf - index to the XF record
See Also:
ExtendedFormatRecord

getRow

public final int getRow()
Specified by:
getRow in interface CellValueRecordInterface
Returns:
the row this cell occurs on

getColumn

public final short getColumn()
Specified by:
getColumn in interface CellValueRecordInterface
Returns:
the column this cell defines within the row

getXFIndex

public final short getXFIndex()
get the index to the ExtendedFormat

Specified by:
getXFIndex in interface CellValueRecordInterface
Returns:
index to the XF record
See Also:
ExtendedFormatRecord

toString

public final java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

appendValueText

protected abstract void appendValueText(java.lang.StringBuilder sb)
Append specific debug info (used by toString() for the value contained in this record. Trailing new-line should not be appended (superclass does that).

getRecordName

protected abstract java.lang.String getRecordName()
Gets the debug info BIFF record type name (used by toString().

serializeValue

protected abstract void serializeValue(LittleEndianOutput out)
writes out the value data for this cell record

getValueDataSize

protected abstract int getValueDataSize()
Returns:
the size (in bytes) of the value data for this cell record

serialize

public final void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected final int getDataSize()
Specified by:
getDataSize in class StandardRecord

copyBaseFields

protected final void copyBaseFields(CellRecord rec)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellValueRecordInterface

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Interface CellValueRecordInterface

All Known Implementing Classes:
BlankRecord, BoolErrRecord, CellRecord, FormulaRecord, FormulaRecordAggregate, LabelRecord, LabelSSTRecord, NumberRecord, RKRecord
public interface CellValueRecordInterface

The cell value record interface is implemented by all classes of type Record that contain cell values. It allows the containing sheet to move through them and compare them.

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)
See Also:
Record, RecordFactory

Method Summary
short | getColumn()
int | getRow()
short | getXFIndex()
void | setColumn(short col)
void | setRow(int row)
void | setXFIndex(short xf)

Method Detail

getRow

int getRow()
Returns:
the row this cell occurs on

getColumn

short getColumn()
Returns:
the column this cell defines within the row

setRow

void setRow(int row)
Parameters:
row - the row this cell occurs within

setColumn

void setColumn(short col)
Parameters:
col - the column this cell defines

setXFIndex

void setXFIndex(short xf)

getXFIndex

short getXFIndex()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CFHeaderRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CFHeaderRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CFHeaderRecord

public final class CFHeaderRecord
extends StandardRecord

Conditional Formatting Header record CFHEADER (0x01B0)

Author:
Dmitriy Kumshayev

Field Summary
static short sid
Constructor Summary
CFHeaderRecord()
Creates new CFHeaderRecord
CFHeaderRecord(CellRangeAddress[] regions, int nRules)
CFHeaderRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
CellRangeAddress[] | getCellRanges()
protected int | getDataSize()
CellRangeAddress | getEnclosingCellRange()
boolean | getNeedRecalculation()
int | getNumberOfConditionalFormats()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCellRanges(CellRangeAddress[] cellRanges) Set cell ranges list to a single cell range and modify the enclosing cell range accordingly.
void | setEnclosingCellRange(CellRangeAddress cr)
void | setNeedRecalculation(boolean b)
void | setNumberOfConditionalFormats(int n)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

CFHeaderRecord

public CFHeaderRecord()
Creates new CFHeaderRecord

CFHeaderRecord

public CFHeaderRecord(CellRangeAddress[] regions,
                      int nRules)

CFHeaderRecord

public CFHeaderRecord(RecordInputStream in)
Method Detail

getNumberOfConditionalFormats

public int getNumberOfConditionalFormats()

setNumberOfConditionalFormats

public void setNumberOfConditionalFormats(int n)

getNeedRecalculation

public boolean getNeedRecalculation()

setNeedRecalculation

public void setNeedRecalculation(boolean b)

getEnclosingCellRange

public CellRangeAddress getEnclosingCellRange()

setEnclosingCellRange

public void setEnclosingCellRange(CellRangeAddress cr)

setCellRanges

public void setCellRanges(CellRangeAddress[] cellRanges)
Set cell ranges list to a single cell range and modify the enclosing cell range accordingly.

Parameters:
cellRanges - - list of CellRange objects

getCellRanges

public CellRangeAddress[] getCellRanges()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CFRuleRecord.ComparisonOperator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CFRuleRecord.ComparisonOperator

java.lang.Object
    extended by  org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator
Enclosing class:
CFRuleRecord
public static final class CFRuleRecord.ComparisonOperator
extends java.lang.Object

Field Summary
static byte | BETWEEN
static byte | EQUAL
static byte | GE
static byte | GT
static byte | LE
static byte | LT
static byte | NO_COMPARISON
static byte | NOT_BETWEEN
static byte | NOT_EQUAL
Constructor Summary
CFRuleRecord.ComparisonOperator()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_COMPARISON

public static final byte NO_COMPARISON
See Also:
Constant Field Values

BETWEEN

public static final byte BETWEEN
See Also:
Constant Field Values

NOT_BETWEEN

public static final byte NOT_BETWEEN
See Also:
Constant Field Values

EQUAL

public static final byte EQUAL
See Also:
Constant Field Values

NOT_EQUAL

public static final byte NOT_EQUAL
See Also:
Constant Field Values

GT

public static final byte GT
See Also:
Constant Field Values

LT

public static final byte LT
See Also:
Constant Field Values

GE

public static final byte GE
See Also:
Constant Field Values

LE

public static final byte LE
See Also:
Constant Field Values
Constructor Detail

CFRuleRecord.ComparisonOperator

public CFRuleRecord.ComparisonOperator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CFRuleRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CFRuleRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CFRuleRecord

public final class CFRuleRecord
extends StandardRecord

Conditional Formatting Rule Record (0x01B1).

Author:
Dmitriy Kumshayev

Nested Class Summary
static class CFRuleRecord.ComparisonOperator
Field Summary
static byte | CONDITION_TYPE_CELL_VALUE_IS
static byte | CONDITION_TYPE_FORMULA
static short | sid
Constructor Summary
CFRuleRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
boolean | containsAlignFormattingBlock()
boolean | containsBorderFormattingBlock()
boolean | containsFontFormattingBlock()
boolean | containsPatternFormattingBlock()
boolean | containsProtectionFormattingBlock()
static CFRuleRecord | create(HSSFSheet sheet, byte comparisonOperation, java.lang.String formulaText1, java.lang.String formulaText2) Creates a new comparison operation rule
static CFRuleRecord | create(HSSFSheet sheet, java.lang.String formulaText) Creates a new comparison operation rule
BorderFormatting | getBorderFormatting()
byte | getComparisonOperation()
byte | getConditionType()
protected int | getDataSize()
FontFormatting | getFontFormatting()
int | getOptions() get the option flags
Ptg[] | getParsedExpression1() get the stack of the 1st expression as a list
Ptg[] | getParsedExpression2() get the stack of the 2nd expression as a list
PatternFormatting | getPatternFormatting()
short | getSid() return the non static version of the id for this record.
boolean | isBottomBorderModified()
boolean | isBottomLeftTopRightBorderModified()
boolean | isLeftBorderModified()
boolean | isPatternBackgroundColorModified()
boolean | isPatternColorModified()
boolean | isPatternStyleModified()
boolean | isRightBorderModified()
boolean | isTopBorderModified()
boolean | isTopLeftBottomRightBorderModified()
void | serialize(LittleEndianOutput out) called by the class that is responsible for writing this sucker.
void | setAlignFormattingUnchanged()
void | setBorderFormatting(BorderFormatting borderFormatting)
void | setBottomBorderModified(boolean modified)
void | setBottomLeftTopRightBorderModified(boolean modified)
void | setComparisonOperation(byte operation)
void | setFontFormatting(FontFormatting fontFormatting)
void | setLeftBorderModified(boolean modified)
void | setParsedExpression1(Ptg[] ptgs)
void | setParsedExpression2(Ptg[] ptgs)
void | setPatternBackgroundColorModified(boolean modified)
void | setPatternColorModified(boolean modified)
void | setPatternFormatting(PatternFormatting patternFormatting)
void | setPatternStyleModified(boolean modified)
void | setProtectionFormattingUnchanged()
void | setRightBorderModified(boolean modified)
void | setTopBorderModified(boolean modified)
void | setTopLeftBottomRightBorderModified(boolean modified)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

CONDITION_TYPE_CELL_VALUE_IS

public static final byte CONDITION_TYPE_CELL_VALUE_IS
See Also:
Constant Field Values

CONDITION_TYPE_FORMULA

public static final byte CONDITION_TYPE_FORMULA
See Also:
Constant Field Values
Constructor Detail

CFRuleRecord

public CFRuleRecord(RecordInputStream in)
Method Detail

create

public static CFRuleRecord create(HSSFSheet sheet,
                                  java.lang.String formulaText)
Creates a new comparison operation rule

create

public static CFRuleRecord create(HSSFSheet sheet,
                                  byte comparisonOperation,
                                  java.lang.String formulaText1,
                                  java.lang.String formulaText2)
Creates a new comparison operation rule

getConditionType

public byte getConditionType()

containsFontFormattingBlock

public boolean containsFontFormattingBlock()

setFontFormatting

public void setFontFormatting(FontFormatting fontFormatting)

getFontFormatting

public FontFormatting getFontFormatting()

containsAlignFormattingBlock

public boolean containsAlignFormattingBlock()

setAlignFormattingUnchanged

public void setAlignFormattingUnchanged()

containsBorderFormattingBlock

public boolean containsBorderFormattingBlock()

setBorderFormatting

public void setBorderFormatting(BorderFormatting borderFormatting)

getBorderFormatting

public BorderFormatting getBorderFormatting()

containsPatternFormattingBlock

public boolean containsPatternFormattingBlock()

setPatternFormatting

public void setPatternFormatting(PatternFormatting patternFormatting)

getPatternFormatting

public PatternFormatting getPatternFormatting()

containsProtectionFormattingBlock

public boolean containsProtectionFormattingBlock()

setProtectionFormattingUnchanged

public void setProtectionFormattingUnchanged()

setComparisonOperation

public void setComparisonOperation(byte operation)

getComparisonOperation

public byte getComparisonOperation()

getOptions

public int getOptions()
get the option flags

Returns:
bit mask

isLeftBorderModified

public boolean isLeftBorderModified()

setLeftBorderModified

public void setLeftBorderModified(boolean modified)

isRightBorderModified

public boolean isRightBorderModified()

setRightBorderModified

public void setRightBorderModified(boolean modified)

isTopBorderModified

public boolean isTopBorderModified()

setTopBorderModified

public void setTopBorderModified(boolean modified)

isBottomBorderModified

public boolean isBottomBorderModified()

setBottomBorderModified

public void setBottomBorderModified(boolean modified)

isTopLeftBottomRightBorderModified

public boolean isTopLeftBottomRightBorderModified()

setTopLeftBottomRightBorderModified

public void setTopLeftBottomRightBorderModified(boolean modified)

isBottomLeftTopRightBorderModified

public boolean isBottomLeftTopRightBorderModified()

setBottomLeftTopRightBorderModified

public void setBottomLeftTopRightBorderModified(boolean modified)

isPatternStyleModified

public boolean isPatternStyleModified()

setPatternStyleModified

public void setPatternStyleModified(boolean modified)

isPatternColorModified

public boolean isPatternColorModified()

setPatternColorModified

public void setPatternColorModified(boolean modified)

isPatternBackgroundColorModified

public boolean isPatternBackgroundColorModified()

setPatternBackgroundColorModified

public void setPatternBackgroundColorModified(boolean modified)

getParsedExpression1

public Ptg[] getParsedExpression1()
get the stack of the 1st expression as a list

Returns:
list of tokens (casts stack to a list and returns it!) this method can return null is we are unable to create Ptgs from existing excel file callers should check for null!

setParsedExpression1

public void setParsedExpression1(Ptg[] ptgs)

getParsedExpression2

public Ptg[] getParsedExpression2()
get the stack of the 2nd expression as a list

Returns:
array of Ptgs, possibly null

setParsedExpression2

public void setParsedExpression2(Ptg[] ptgs)

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class StandardRecord
Parameters:
out - the stream to write to

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CodepageRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CodepageRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CodepageRecord

public final class CodepageRecord
extends StandardRecord

Title: Codepage Record

Description: the default characterset. for the workbook

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short | CODEPAGE the likely correct value for CODEPAGE (at least for US versions).
static short | sid
Constructor Summary
CodepageRecord()
CodepageRecord(RecordInputStream in)
Method Summary
short | getCodepage() get the codepage for this workbook
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCodepage(short cp) set the codepage for this workbook
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

CODEPAGE

public static final short CODEPAGE
the likely correct value for CODEPAGE (at least for US versions). We could use some help with international versions (which we do not have access to documentation for)

See Also:
Constant Field Values
Constructor Detail

CodepageRecord

public CodepageRecord()

CodepageRecord

public CodepageRecord(RecordInputStream in)
Method Detail

setCodepage

public void setCodepage(short cp)
set the codepage for this workbook

Parameters:
cp - the codepage to set
See Also:
CODEPAGE

getCodepage

public short getCodepage()
get the codepage for this workbook

Returns:
codepage - the codepage to set
See Also:
CODEPAGE

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ColumnInfoRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ColumnInfoRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ColumnInfoRecord

public final class ColumnInfoRecord
extends StandardRecord

Title: COLINFO Record (0x007D)

Description: Defines with width and formatting for a range of columns

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
ColumnInfoRecord()
Creates a column info record with default width and format
ColumnInfoRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
boolean | containsColumn(int columnIndex)
boolean | formatMatches(ColumnInfoRecord other)
boolean | getCollapsed()
int | getColumnWidth()
protected int | getDataSize()
int | getFirstColumn() get the first column this record defines formatting info for
boolean | getHidden()
int | getLastColumn() get the last column this record defines formatting info for
int | getOutlineLevel()
short | getSid() return the non static version of the id for this record.
int | getXFIndex() get the columns' default format info
boolean | isAdjacentBefore(ColumnInfoRecord other)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCollapsed(boolean isCollapsed) set whether the cells are collapsed
void | setColumnWidth(int cw) set the columns' width in 1/256 of a character width
void | setFirstColumn(int fc) set the first column this record defines formatting info for
void | setHidden(boolean ishidden) set whether or not these cells are hidden
void | setLastColumn(int lc) set the last column this record defines formatting info for
void | setOutlineLevel(int olevel) set the outline level for the cells
void | setXFIndex(int xfi) set the columns' default format info
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ColumnInfoRecord

public ColumnInfoRecord()
Creates a column info record with default width and format

ColumnInfoRecord

public ColumnInfoRecord(RecordInputStream in)
Method Detail

setFirstColumn

public void setFirstColumn(int fc)
set the first column this record defines formatting info for

Parameters:
fc - - the first column index (0-based)

setLastColumn

public void setLastColumn(int lc)
set the last column this record defines formatting info for

Parameters:
lc - - the last column index (0-based)

setColumnWidth

public void setColumnWidth(int cw)
set the columns' width in 1/256 of a character width

Parameters:
cw - - column width

setXFIndex

public void setXFIndex(int xfi)
set the columns' default format info

Parameters:
xfi - - the extended format index
See Also:
ExtendedFormatRecord

setHidden

public void setHidden(boolean ishidden)
set whether or not these cells are hidden

Parameters:
ishidden - - whether the cells are hidden.

setOutlineLevel

public void setOutlineLevel(int olevel)
set the outline level for the cells

Parameters:
olevel - -outline level for the cells

setCollapsed

public void setCollapsed(boolean isCollapsed)
set whether the cells are collapsed

Parameters:
isCollapsed - - whether the cells are collapsed

getFirstColumn

public int getFirstColumn()
get the first column this record defines formatting info for

Returns:
the first column index (0-based)

getLastColumn

public int getLastColumn()
get the last column this record defines formatting info for

Returns:
the last column index (0-based)

getColumnWidth

public int getColumnWidth()
Returns:
column width in units of 1/256 of a character width

getXFIndex

public int getXFIndex()
get the columns' default format info

Returns:
the extended format index
See Also:
ExtendedFormatRecord

getHidden

public boolean getHidden()
Returns:
whether the cells are hidden.

getOutlineLevel

public int getOutlineLevel()
Returns:
outline level for the cells

getCollapsed

public boolean getCollapsed()
Returns:
whether the cells are collapsed

containsColumn

public boolean containsColumn(int columnIndex)

isAdjacentBefore

public boolean isAdjacentBefore(ColumnInfoRecord other)

formatMatches

public boolean formatMatches(ColumnInfoRecord other)
Returns:
true if the format, options and column width match

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CommonObjectDataSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CommonObjectDataSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
        extended by  org.apache.poi.hssf.record.CommonObjectDataSubRecord

public final class CommonObjectDataSubRecord
extends SubRecord

The common object data record is used to store all common preferences for an excel object.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | OBJECT_TYPE_ARC
static short | OBJECT_TYPE_BUTTON
static short | OBJECT_TYPE_CHART
static short | OBJECT_TYPE_CHECKBOX
static short | OBJECT_TYPE_COMBO_BOX
static short | OBJECT_TYPE_COMMENT
static short | OBJECT_TYPE_DIALOG_BOX
static short | OBJECT_TYPE_EDIT_BOX
static short | OBJECT_TYPE_GROUP
static short | OBJECT_TYPE_GROUP_BOX
static short | OBJECT_TYPE_LABEL
static short | OBJECT_TYPE_LINE
static short | OBJECT_TYPE_LIST_BOX
static short | OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING
static short | OBJECT_TYPE_OPTION_BUTTON
static short | OBJECT_TYPE_OVAL
static short | OBJECT_TYPE_PICTURE
static short | OBJECT_TYPE_POLYGON
static short | OBJECT_TYPE_RECTANGLE
static short | OBJECT_TYPE_RESERVED1
static short | OBJECT_TYPE_RESERVED2
static short | OBJECT_TYPE_RESERVED3
static short | OBJECT_TYPE_RESERVED4
static short | OBJECT_TYPE_RESERVED5
static short | OBJECT_TYPE_RESERVED6
static short | OBJECT_TYPE_RESERVED7
static short | OBJECT_TYPE_RESERVED8
static short | OBJECT_TYPE_RESERVED9
static short | OBJECT_TYPE_SCROLL_BAR
static short | OBJECT_TYPE_SPINNER
static short | OBJECT_TYPE_TEXT
static short | sid
Constructor Summary
CommonObjectDataSubRecord()
CommonObjectDataSubRecord(LittleEndianInput in, int size)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
int | getObjectId() Get the object id field for the CommonObjectData record.
short | getObjectType() Get the object type field for the CommonObjectData record.
short | getOption() Get the option field for the CommonObjectData record.
int | getReserved1() Get the reserved1 field for the CommonObjectData record.
int | getReserved2() Get the reserved2 field for the CommonObjectData record.
int | getReserved3() Get the reserved3 field for the CommonObjectData record.
short | getSid()
boolean | isAutofill() whether object uses an automatic fill style
boolean | isAutoline() whether object uses an automatic line style
boolean | isLocked() true if object is locked when sheet has been protected
boolean | isPrintable() object appears when printed
void | serialize(LittleEndianOutput out)
void | setAutofill(boolean value) Sets the autofill field value.
void | setAutoline(boolean value) Sets the autoline field value.
void | setLocked(boolean value) Sets the locked field value.
void | setObjectId(int field_2_objectId) Set the object id field for the CommonObjectData record.
void | setObjectType(short field_1_objectType) Set the object type field for the CommonObjectData record.
void | setOption(short field_3_option) Set the option field for the CommonObjectData record.
void | setPrintable(boolean value) Sets the printable field value.
void | setReserved1(int field_4_reserved1) Set the reserved1 field for the CommonObjectData record.
void | setReserved2(int field_5_reserved2) Set the reserved2 field for the CommonObjectData record.
void | setReserved3(int field_6_reserved3) Set the reserved3 field for the CommonObjectData record.
java.lang.String | toString()
Methods inherited from class org.apache.poi.hssf.record.SubRecord
createSubRecord, isTerminating, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

OBJECT_TYPE_GROUP

public static final short OBJECT_TYPE_GROUP
See Also:
Constant Field Values

OBJECT_TYPE_LINE

public static final short OBJECT_TYPE_LINE
See Also:
Constant Field Values

OBJECT_TYPE_RECTANGLE

public static final short OBJECT_TYPE_RECTANGLE
See Also:
Constant Field Values

OBJECT_TYPE_OVAL

public static final short OBJECT_TYPE_OVAL
See Also:
Constant Field Values

OBJECT_TYPE_ARC

public static final short OBJECT_TYPE_ARC
See Also:
Constant Field Values

OBJECT_TYPE_CHART

public static final short OBJECT_TYPE_CHART
See Also:
Constant Field Values

OBJECT_TYPE_TEXT

public static final short OBJECT_TYPE_TEXT
See Also:
Constant Field Values

OBJECT_TYPE_BUTTON

public static final short OBJECT_TYPE_BUTTON
See Also:
Constant Field Values

OBJECT_TYPE_PICTURE

public static final short OBJECT_TYPE_PICTURE
See Also:
Constant Field Values

OBJECT_TYPE_POLYGON

public static final short OBJECT_TYPE_POLYGON
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED1

public static final short OBJECT_TYPE_RESERVED1
See Also:
Constant Field Values

OBJECT_TYPE_CHECKBOX

public static final short OBJECT_TYPE_CHECKBOX
See Also:
Constant Field Values

OBJECT_TYPE_OPTION_BUTTON

public static final short OBJECT_TYPE_OPTION_BUTTON
See Also:
Constant Field Values

OBJECT_TYPE_EDIT_BOX

public static final short OBJECT_TYPE_EDIT_BOX
See Also:
Constant Field Values

OBJECT_TYPE_LABEL

public static final short OBJECT_TYPE_LABEL
See Also:
Constant Field Values

OBJECT_TYPE_DIALOG_BOX

public static final short OBJECT_TYPE_DIALOG_BOX
See Also:
Constant Field Values

OBJECT_TYPE_SPINNER

public static final short OBJECT_TYPE_SPINNER
See Also:
Constant Field Values

OBJECT_TYPE_SCROLL_BAR

public static final short OBJECT_TYPE_SCROLL_BAR
See Also:
Constant Field Values

OBJECT_TYPE_LIST_BOX

public static final short OBJECT_TYPE_LIST_BOX
See Also:
Constant Field Values

OBJECT_TYPE_GROUP_BOX

public static final short OBJECT_TYPE_GROUP_BOX
See Also:
Constant Field Values

OBJECT_TYPE_COMBO_BOX

public static final short OBJECT_TYPE_COMBO_BOX
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED2

public static final short OBJECT_TYPE_RESERVED2
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED3

public static final short OBJECT_TYPE_RESERVED3
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED4

public static final short OBJECT_TYPE_RESERVED4
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED5

public static final short OBJECT_TYPE_RESERVED5
See Also:
Constant Field Values

OBJECT_TYPE_COMMENT

public static final short OBJECT_TYPE_COMMENT
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED6

public static final short OBJECT_TYPE_RESERVED6
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED7

public static final short OBJECT_TYPE_RESERVED7
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED8

public static final short OBJECT_TYPE_RESERVED8
See Also:
Constant Field Values

OBJECT_TYPE_RESERVED9

public static final short OBJECT_TYPE_RESERVED9
See Also:
Constant Field Values

OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING

public static final short OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING
See Also:
Constant Field Values
Constructor Detail

CommonObjectDataSubRecord

public CommonObjectDataSubRecord()

CommonObjectDataSubRecord

public CommonObjectDataSubRecord(LittleEndianInput in,
                                 int size)
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in class SubRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class SubRecord
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

getSid

public short getSid()

clone

public java.lang.Object clone()
Specified by:
clone in class SubRecord

getObjectType

public short getObjectType()
Get the object type field for the CommonObjectData record.

Returns:
One of OBJECT_TYPE_GROUP OBJECT_TYPE_LINE OBJECT_TYPE_RECTANGLE OBJECT_TYPE_OVAL OBJECT_TYPE_ARC OBJECT_TYPE_CHART OBJECT_TYPE_TEXT OBJECT_TYPE_BUTTON OBJECT_TYPE_PICTURE OBJECT_TYPE_POLYGON OBJECT_TYPE_RESERVED1 OBJECT_TYPE_CHECKBOX OBJECT_TYPE_OPTION_BUTTON OBJECT_TYPE_EDIT_BOX OBJECT_TYPE_LABEL OBJECT_TYPE_DIALOG_BOX OBJECT_TYPE_SPINNER OBJECT_TYPE_SCROLL_BAR OBJECT_TYPE_LIST_BOX OBJECT_TYPE_GROUP_BOX OBJECT_TYPE_COMBO_BOX OBJECT_TYPE_RESERVED2 OBJECT_TYPE_RESERVED3 OBJECT_TYPE_RESERVED4 OBJECT_TYPE_RESERVED5 OBJECT_TYPE_COMMENT OBJECT_TYPE_RESERVED6 OBJECT_TYPE_RESERVED7 OBJECT_TYPE_RESERVED8 OBJECT_TYPE_RESERVED9 OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING

setObjectType

public void setObjectType(short field_1_objectType)
Set the object type field for the CommonObjectData record.

Parameters:
field_1_objectType - One of OBJECT_TYPE_GROUP OBJECT_TYPE_LINE OBJECT_TYPE_RECTANGLE OBJECT_TYPE_OVAL OBJECT_TYPE_ARC OBJECT_TYPE_CHART OBJECT_TYPE_TEXT OBJECT_TYPE_BUTTON OBJECT_TYPE_PICTURE OBJECT_TYPE_POLYGON OBJECT_TYPE_RESERVED1 OBJECT_TYPE_CHECKBOX OBJECT_TYPE_OPTION_BUTTON OBJECT_TYPE_EDIT_BOX OBJECT_TYPE_LABEL OBJECT_TYPE_DIALOG_BOX OBJECT_TYPE_SPINNER OBJECT_TYPE_SCROLL_BAR OBJECT_TYPE_LIST_BOX OBJECT_TYPE_GROUP_BOX OBJECT_TYPE_COMBO_BOX OBJECT_TYPE_RESERVED2 OBJECT_TYPE_RESERVED3 OBJECT_TYPE_RESERVED4 OBJECT_TYPE_RESERVED5 OBJECT_TYPE_COMMENT OBJECT_TYPE_RESERVED6 OBJECT_TYPE_RESERVED7 OBJECT_TYPE_RESERVED8 OBJECT_TYPE_RESERVED9 OBJECT_TYPE_MICROSOFT_OFFICE_DRAWING

getObjectId

public int getObjectId()
Get the object id field for the CommonObjectData record.

setObjectId

public void setObjectId(int field_2_objectId)
Set the object id field for the CommonObjectData record.

getOption

public short getOption()
Get the option field for the CommonObjectData record.

setOption

public void setOption(short field_3_option)
Set the option field for the CommonObjectData record.

getReserved1

public int getReserved1()
Get the reserved1 field for the CommonObjectData record.

setReserved1

public void setReserved1(int field_4_reserved1)
Set the reserved1 field for the CommonObjectData record.

getReserved2

public int getReserved2()
Get the reserved2 field for the CommonObjectData record.

setReserved2

public void setReserved2(int field_5_reserved2)
Set the reserved2 field for the CommonObjectData record.

getReserved3

public int getReserved3()
Get the reserved3 field for the CommonObjectData record.

setReserved3

public void setReserved3(int field_6_reserved3)
Set the reserved3 field for the CommonObjectData record.

setLocked

public void setLocked(boolean value)
Sets the locked field value. true if object is locked when sheet has been protected

isLocked

public boolean isLocked()
true if object is locked when sheet has been protected

Returns:
the locked field value.

setPrintable

public void setPrintable(boolean value)
Sets the printable field value. object appears when printed

isPrintable

public boolean isPrintable()
object appears when printed

Returns:
the printable field value.

setAutofill

public void setAutofill(boolean value)
Sets the autofill field value. whether object uses an automatic fill style

isAutofill

public boolean isAutofill()
whether object uses an automatic fill style

Returns:
the autofill field value.

setAutoline

public void setAutoline(boolean value)
Sets the autoline field value. whether object uses an automatic line style

isAutoline

public boolean isAutoline()
whether object uses an automatic line style

Returns:
the autoline field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContinueRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ContinueRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ContinueRecord

public final class ContinueRecord
extends StandardRecord

Title: Continue Record(0x003C) - Helper class used primarily for SST Records

Description: handles overflow for prior record in the input stream; content is tailored to that prior record

Author:
Marc Johnson (mjohnson at apache dot org), Andrew C. Oliver (acoliver at apache dot org), Csaba Nagy (ncsaba at yahoo dot com)

Field Summary
static short sid
Constructor Summary
ContinueRecord(byte[] data)
ContinueRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
byte[] | getData() get the data for continuation
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ContinueRecord

public ContinueRecord(byte[] data)

ContinueRecord

public ContinueRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getData

public byte[] getData()
get the data for continuation

Returns:
byte array containing all of the continued data

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CountryRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CountryRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CountryRecord

public final class CountryRecord
extends StandardRecord

Title: Country Record (aka WIN.INI country)

Description: used for localization. Currently HSSF always sets this to 1 and it seems to work fine even in Germany. (es geht's auch fuer Deutschland)

REFERENCE: PG 298 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
CountryRecord()
CountryRecord(RecordInputStream in)
Method Summary
short | getCurrentCountry() gets the current country
protected int | getDataSize()
short | getDefaultCountry() gets the default country
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCurrentCountry(short country) sets the current country
void | setDefaultCountry(short country) sets the default country
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

CountryRecord

public CountryRecord()

CountryRecord

public CountryRecord(RecordInputStream in)
Method Detail

setDefaultCountry

public void setDefaultCountry(short country)
sets the default country

Parameters:
country - ID to set (1 = US)

setCurrentCountry

public void setCurrentCountry(short country)
sets the current country

Parameters:
country - ID to set (1 = US)

getDefaultCountry

public short getDefaultCountry()
gets the default country

Returns:
country ID (1 = US)

getCurrentCountry

public short getCurrentCountry()
gets the current country

Returns:
country ID (1 = US)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CRNCountRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CRNCountRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CRNCountRecord

public final class CRNCountRecord
extends StandardRecord

XCT - CRN Count

REFERENCE: 5.114

Author:
Josh Micich

Field Summary
static short sid
Constructor Summary
CRNCountRecord()
CRNCountRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
int | getNumberOfCRNs()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

CRNCountRecord

public CRNCountRecord()

CRNCountRecord

public CRNCountRecord(RecordInputStream in)
Method Detail

getNumberOfCRNs

public int getNumberOfCRNs()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CRNRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class CRNRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CRNRecord

public final class CRNRecord
extends StandardRecord

Title: CRN(0x005A)

Description: This record stores the contents of an external cell or cell range

REFERENCE: OOO 5.23

Author:
josh micich

Field Summary
static short sid
Constructor Summary
CRNRecord()
CRNRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
int | getNumberOfCRNs()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

CRNRecord

public CRNRecord()

CRNRecord

public CRNRecord(RecordInputStream in)
Method Detail

getNumberOfCRNs

public int getNumberOfCRNs()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateWindow1904Record

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DateWindow1904Record

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DateWindow1904Record

public final class DateWindow1904Record
extends StandardRecord

Title: Date Window 1904 Flag record

Description: Flag specifying whether 1904 date windowing is used. (tick toc tick toc...BOOM!)

REFERENCE: PG 280 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
DateWindow1904Record()
DateWindow1904Record(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
short | getWindowing() gets whether or not to use 1904 date windowing (which means you'll be screwed in 2004)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setWindowing(short window) sets whether or not to use 1904 date windowing (which means you'll be screwed in 2004)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DateWindow1904Record

public DateWindow1904Record()

DateWindow1904Record

public DateWindow1904Record(RecordInputStream in)
Method Detail

setWindowing

public void setWindowing(short window)
sets whether or not to use 1904 date windowing (which means you'll be screwed in 2004)

Parameters:
window - flag - 0/1 (false,true)

getWindowing

public short getWindowing()
gets whether or not to use 1904 date windowing (which means you'll be screwed in 2004)

Returns:
window flag - 0/1 (false,true)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DBCellRecord.Builder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DBCellRecord.Builder

java.lang.Object
    extended by  org.apache.poi.hssf.record.DBCellRecord.Builder
Enclosing class:
DBCellRecord
public static final class DBCellRecord.Builder
extends java.lang.Object

Constructor Summary
DBCellRecord.Builder()
Method Summary
void | addCellOffset(int cellRefOffset)
DBCellRecord | build(int rowOffset)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DBCellRecord.Builder

public DBCellRecord.Builder()
Method Detail

addCellOffset

public void addCellOffset(int cellRefOffset)

build

public DBCellRecord build(int rowOffset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DBCellRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DBCellRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DBCellRecord

public final class DBCellRecord
extends StandardRecord

Title: DBCell Record (0x00D7)

Description: Used by Excel and other MS apps to quickly find rows in the sheets.

REFERENCE: PG 299/440 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height

Nested Class Summary
static class DBCellRecord.Builder
Field Summary
static int | BLOCK_SIZE
static short | sid
Constructor Summary
DBCellRecord(RecordInputStream in)
Method Summary
static int | calculateSizeOfRecords(int nBlocks, int nRows)
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

BLOCK_SIZE

public static final int BLOCK_SIZE
See Also:
Constant Field Values
Constructor Detail

DBCellRecord

public DBCellRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

calculateSizeOfRecords

public static int calculateSizeOfRecords(int nBlocks,
                                         int nRows)
Returns:
the size of the group of DBCellRecords needed to encode the specified number of blocks and rows

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DConRefRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DConRefRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DConRefRecord

public class DConRefRecord
extends StandardRecord

DConRef records specify a range in a workbook (internal or external) that serves as a data source for pivot tables or data consolidation. Represents a DConRef Structure [MS-XLS s. 2.4.86], and the contained DConFile structure [MS-XLS s. 2.5.69]. This in turn contains a XLUnicodeStringNoCch [MS-XLS s. 2.5.296].

         _______________________________
        |          DConRef              |
(bytes) +-+-+-+-+-+-+-+-+-+-+...+-+-+-+-+
        |    ref    |cch|  stFile   | un|
        +-+-+-+-+-+-+-+-+-+-+...+-+-+-+-+
                              |
                     _________|_____________________
                    |DConFile / XLUnicodeStringNoCch|
                    +-+-+-+-+-+-+-+-+-+-+-+...+-+-+-+
             (bits) |h|   reserved  |      rgb      |
                    +-+-+-+-+-+-+-+-+-+-+-+...+-+-+-+
Where
  • DConFile.h = 0x00 if the characters inrgb are single byte, and DConFile.h = 0x01 if they are double byte.
    If they are double byte, then
    • If it exists, the length of DConRef.un = 2. Otherwise it is 1.
    • The length of DConFile.rgb = (2 * DConRef.cch). Otherwise it is equal to DConRef.cch.
  • DConRef.rgb starts with 0x01 if it is an external reference, and with 0x02 if it is a self-reference.
At the moment this class is read-only.

Author:
Niklas Rehfeld

Field Summary
static short sid
The id of the record type, sid = 81
Constructor Summary
DConRefRecord(byte[] data)
Read constructor.
DConRefRecord(RecordInputStream inStream)
Read Constructor.
Method Summary
protected int | getDataSize()
int | getFirstColumn()
int | getFirstRow()
int | getLastColumn()
int | getLastRow()
byte[] | getPath()
java.lang.String | getReadablePath()
short | getSid() return the non static version of the id for this record.
boolean | isExternalRef() Checks if the data source in this reference record is external to this sheet or internal.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
The id of the record type, sid = 81

See Also:
Constant Field Values
Constructor Detail

DConRefRecord

public DConRefRecord(byte[] data)
Read constructor.

Parameters:
data - byte array containing a DConRef Record, including the header.

DConRefRecord

public DConRefRecord(RecordInputStream inStream)
Read Constructor.

Parameters:
inStream - RecordInputStream containing a DConRefRecord structure.
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getFirstColumn

public int getFirstColumn()
Returns:
The first column of the range.

getFirstRow

public int getFirstRow()
Returns:
The first row of the range.

getLastColumn

public int getLastColumn()
Returns:
The last column of the range.

getLastRow

public int getLastRow()
Returns:
The last row of the range.

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getPath

public byte[] getPath()
Returns:
raw path byte array.

getReadablePath

public java.lang.String getReadablePath()
Returns:
the link's path, with the special characters stripped/replaced. May be null.
See Also:
2.5.277 (VirtualPath)

isExternalRef

public boolean isExternalRef()
Checks if the data source in this reference record is external to this sheet or internal.

Returns:
true iff this is an external reference.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultColWidthRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DefaultColWidthRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DefaultColWidthRecord

public final class DefaultColWidthRecord
extends StandardRecord

Title: Default Column Width Record (0x0055)

Description: Specifies the default width for columns that have no specific width set.

REFERENCE: PG 302 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static int | DEFAULT_COLUMN_WIDTH The default column width is 8 characters
static short | sid
Constructor Summary
DefaultColWidthRecord()
DefaultColWidthRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
int | getColWidth() get the default column width
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setColWidth(int width) set the default column width
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

DEFAULT_COLUMN_WIDTH

public static final int DEFAULT_COLUMN_WIDTH
The default column width is 8 characters

See Also:
Constant Field Values
Constructor Detail

DefaultColWidthRecord

public DefaultColWidthRecord()

DefaultColWidthRecord

public DefaultColWidthRecord(RecordInputStream in)
Method Detail

setColWidth

public void setColWidth(int width)
set the default column width

Parameters:
width - defaultwidth for columns

getColWidth

public int getColWidth()
get the default column width

Returns:
defaultwidth for columns

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultRowHeightRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DefaultRowHeightRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DefaultRowHeightRecord

public final class DefaultRowHeightRecord
extends StandardRecord

Title: Default Row Height Record Description: Row height for rows with undefined or not explicitly defined heights. REFERENCE: PG 301 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short | DEFAULT_ROW_HEIGHT The default row height for empty rows is 255 twips (255 / 20 == 12.75 points)
static short | sid
Constructor Summary
DefaultRowHeightRecord()
DefaultRowHeightRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getOptionFlags() get the (currently unimportant to HSSF) option flags
short | getRowHeight() get the default row height
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setOptionFlags(short flags) set the (currently unimportant to HSSF) option flags
void | setRowHeight(short height) set the default row height
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

DEFAULT_ROW_HEIGHT

public static final short DEFAULT_ROW_HEIGHT
The default row height for empty rows is 255 twips (255 / 20 == 12.75 points)

See Also:
Constant Field Values
Constructor Detail

DefaultRowHeightRecord

public DefaultRowHeightRecord()

DefaultRowHeightRecord

public DefaultRowHeightRecord(RecordInputStream in)
Method Detail

setOptionFlags

public void setOptionFlags(short flags)
set the (currently unimportant to HSSF) option flags

Parameters:
flags - the bitmask to set

setRowHeight

public void setRowHeight(short height)
set the default row height

Parameters:
height - for undefined rows/rows w/undefined height

getOptionFlags

public short getOptionFlags()
get the (currently unimportant to HSSF) option flags

Returns:
flags - the current bitmask

getRowHeight

public short getRowHeight()
get the default row height

Returns:
rowheight for undefined rows/rows w/undefined height

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DeltaRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DeltaRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DeltaRecord

public final class DeltaRecord
extends StandardRecord

Title: Delta Record (0x0010)

Description: controls the accuracy of the calculations

REFERENCE: PG 303 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static double | DEFAULT_VALUE
static short | sid
Constructor Summary
DeltaRecord(double maxChange)
DeltaRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
double | getMaxChange() get the maximum change
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

DEFAULT_VALUE

public static final double DEFAULT_VALUE
See Also:
Constant Field Values
Constructor Detail

DeltaRecord

public DeltaRecord(double maxChange)

DeltaRecord

public DeltaRecord(RecordInputStream in)
Method Detail

getMaxChange

public double getMaxChange()
get the maximum change

Returns:
maxChange - maximum rounding error

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DimensionsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DimensionsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DimensionsRecord

public final class DimensionsRecord
extends StandardRecord

Title: Dimensions Record

Description: provides the minumum and maximum bounds of a sheet.

REFERENCE: PG 303 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
DimensionsRecord()
DimensionsRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getFirstCol() get the first column number for the sheet
int | getFirstRow() get the first row number for the sheet
short | getLastCol() get the last col number for the sheet
int | getLastRow() get the last row number for the sheet
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setFirstCol(short col) set the first column number for the sheet
void | setFirstRow(int row) set the first row number for the sheet
void | setLastCol(short col) set the last col number for the sheet
void | setLastRow(int row) set the last row number for the sheet
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DimensionsRecord

public DimensionsRecord()

DimensionsRecord

public DimensionsRecord(RecordInputStream in)
Method Detail

setFirstRow

public void setFirstRow(int row)
set the first row number for the sheet

Parameters:
row - - first row on the sheet

setLastRow

public void setLastRow(int row)
set the last row number for the sheet

Parameters:
row - - last row on the sheet

setFirstCol

public void setFirstCol(short col)
set the first column number for the sheet

Parameters:
col - first column on the sheet

setLastCol

public void setLastCol(short col)
set the last col number for the sheet

Parameters:
col - last column on the sheet

getFirstRow

public int getFirstRow()
get the first row number for the sheet

Returns:
row - first row on the sheet

getLastRow

public int getLastRow()
get the last row number for the sheet

Returns:
row - last row on the sheet

getFirstCol

public short getFirstCol()
get the first column number for the sheet

Returns:
column - first column on the sheet

getLastCol

public short getLastCol()
get the last col number for the sheet

Returns:
column - last column on the sheet

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingGroupRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DrawingGroupRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.AbstractEscherHolderRecord
                extended by  org.apache.poi.hssf.record.DrawingGroupRecord

public final class DrawingGroupRecord
extends AbstractEscherHolderRecord

Field Summary
static short sid
Constructor Summary
DrawingGroupRecord()
DrawingGroupRecord(RecordInputStream in)
Method Summary
protected java.lang.String | getRecordName()
int | getRecordSize() gives the current serialized size of the record.
short | getSid() return the non static version of the id for this record.
void | processChildRecords() Process the bytes into escher records.
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
Methods inherited from class org.apache.poi.hssf.record.AbstractEscherHolderRecord
addEscherRecord, addEscherRecord, clearEscherRecords, clone, convertRawBytesToEscherRecords, decode, findFirstWithId, getEscherContainer, getEscherRecord, getEscherRecords, getRawData, join, processContinueRecord, setRawData, toString
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DrawingGroupRecord

public DrawingGroupRecord()

DrawingGroupRecord

public DrawingGroupRecord(RecordInputStream in)
Method Detail

getRecordName

protected java.lang.String getRecordName()
Specified by:
getRecordName in class AbstractEscherHolderRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class AbstractEscherHolderRecord

serialize

public int serialize(int offset,
                     byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Overrides:
serialize in class AbstractEscherHolderRecord
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

processChildRecords

public void processChildRecords()
Process the bytes into escher records. (Not done by default in case we break things, unless you set the "poi.deserialize.escher" system property)

getRecordSize

public int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Overrides:
getRecordSize in class AbstractEscherHolderRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DrawingRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DrawingRecord

public final class DrawingRecord
extends StandardRecord

DrawingRecord (0x00EC)

Field Summary
static short sid
Constructor Summary
DrawingRecord()
DrawingRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
byte[] | getData()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | processContinueRecord(byte[] record)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setData(byte[] thedata)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DrawingRecord

public DrawingRecord()

DrawingRecord

public DrawingRecord(RecordInputStream in)
Method Detail

processContinueRecord

public void processContinueRecord(byte[] record)

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getData

public byte[] getData()

setData

public void setData(byte[] thedata)

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingRecordForBiffViewer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DrawingRecordForBiffViewer

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.AbstractEscherHolderRecord
                extended by  org.apache.poi.hssf.record.DrawingRecordForBiffViewer

public final class DrawingRecordForBiffViewer
extends AbstractEscherHolderRecord

This is purely for the biff viewer. During normal operations we don't want to be seeing this.

Field Summary
static short sid
Constructor Summary
DrawingRecordForBiffViewer()
DrawingRecordForBiffViewer(DrawingRecord r)
DrawingRecordForBiffViewer(RecordInputStream in)
Method Summary
protected java.lang.String | getRecordName()
short | getSid() return the non static version of the id for this record.
Methods inherited from class org.apache.poi.hssf.record.AbstractEscherHolderRecord
addEscherRecord, addEscherRecord, clearEscherRecords, clone, convertRawBytesToEscherRecords, decode, findFirstWithId, getEscherContainer, getEscherRecord, getEscherRecords, getRawData, getRecordSize, join, processContinueRecord, serialize, setRawData, toString
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DrawingRecordForBiffViewer

public DrawingRecordForBiffViewer()

DrawingRecordForBiffViewer

public DrawingRecordForBiffViewer(RecordInputStream in)

DrawingRecordForBiffViewer

public DrawingRecordForBiffViewer(DrawingRecord r)
Method Detail

getRecordName

protected java.lang.String getRecordName()
Specified by:
getRecordName in class AbstractEscherHolderRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class AbstractEscherHolderRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingSelectionRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DrawingSelectionRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DrawingSelectionRecord

public final class DrawingSelectionRecord
extends StandardRecord

MsoDrawingSelection (0x00ED)

Reference: [MS-OGRAPH].pdf sec 2.4.69

Author:
Josh Micich

Field Summary
static short sid
Constructor Summary
DrawingSelectionRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DrawingSelectionRecord

public DrawingSelectionRecord(RecordInputStream in)
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

clone

public java.lang.Object clone()
Overrides:
clone in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DSFRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DSFRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DSFRecord

public final class DSFRecord
extends StandardRecord

Title: Double Stream Flag Record (0x0161)

Description: tells if this is a double stream file. (always no for HSSF generated files)

Double Stream files contain both BIFF8 and BIFF7 workbooks.

REFERENCE: PG 305 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
DSFRecord(boolean isBiff5BookStreamPresent)
DSFRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
boolean | isBiff5BookStreamPresent()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DSFRecord

public DSFRecord(boolean isBiff5BookStreamPresent)

DSFRecord

public DSFRecord(RecordInputStream in)
Method Detail

isBiff5BookStreamPresent

public boolean isBiff5BookStreamPresent()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DVALRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DVALRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DVALRecord

public final class DVALRecord
extends StandardRecord

Title: DATAVALIDATIONS Record (0x01B2)

Description: used in data validation ; This record is the list header of all data validation records (0x01BE) in the current sheet.

Author:
Dragos Buleandra (dragos.buleandra@trade2b.ro)

Field Summary
static short sid
Constructor Summary
DVALRecord()
DVALRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
int | getDVRecNo() Get number of following DV records
int | getHorizontalPos()
int | getObjectID() get Object ID of the drop down arrow object for list boxes
short | getOptions()
short | getSid() return the non static version of the id for this record.
int | getVerticalPos()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setDVRecNo(int dvNo) Set the number of following DV records
void | setHorizontalPos(int horiz_pos)
void | setObjectID(int cboID) set the object ID of the drop down arrow object for list boxes
void | setOptions(short options)
void | setVerticalPos(int vert_pos)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DVALRecord

public DVALRecord()

DVALRecord

public DVALRecord(RecordInputStream in)
Method Detail

setOptions

public void setOptions(short options)
Parameters:
options - the options of the dialog

setHorizontalPos

public void setHorizontalPos(int horiz_pos)
Parameters:
horiz_pos - the Horizontal position of the dialog

setVerticalPos

public void setVerticalPos(int vert_pos)
Parameters:
vert_pos - the Vertical position of the dialog

setObjectID

public void setObjectID(int cboID)
set the object ID of the drop down arrow object for list boxes

Parameters:
cboID - - Object ID

setDVRecNo

public void setDVRecNo(int dvNo)
Set the number of following DV records

Parameters:
dvNo - - the DV records number

getOptions

public short getOptions()
Returns:
the field_1_options

getHorizontalPos

public int getHorizontalPos()
Returns:
the Horizontal position of the dialog

getVerticalPos

public int getVerticalPos()
Returns:
the the Vertical position of the dialog

getObjectID

public int getObjectID()
get Object ID of the drop down arrow object for list boxes

getDVRecNo

public int getDVRecNo()
Get number of following DV records

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DVRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class DVRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.DVRecord

public final class DVRecord
extends StandardRecord

Title: DATAVALIDATION Record (0x01BE)

Description: This record stores data validation settings and a list of cell ranges which contain these settings. The data validation settings of a sheet are stored in a sequential list of DV records. This list is followed by DVAL record(s)

Author:
Dragos Buleandra (dragos.buleandra@trade2b.ro), Josh Micich

Field Summary
static short sid
Constructor Summary
DVRecord(int validationType, int operator, int errorStyle, boolean emptyCellAllowed, boolean suppressDropDownArrow, boolean isExplicitList, boolean showPromptBox, java.lang.String promptTitle, java.lang.String promptText, boolean showErrorBox, java.lang.String errorTitle, java.lang.String errorText, Ptg[] formula1, Ptg[] formula2, CellRangeAddressList regions)
DVRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone() Clones the object.
CellRangeAddressList | getCellRangeAddress()
int | getConditionOperator() get the condition operator
protected int | getDataSize()
int | getDataType()
boolean | getEmptyCellAllowed()
int | getErrorStyle()
boolean | getListExplicitFormula()
boolean | getShowErrorOnInvalidValue()
boolean | getShowPromptOnCellSelected()
short | getSid() return the non static version of the id for this record.
boolean | getSuppressDropdownArrow()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DVRecord

public DVRecord(int validationType,
                int operator,
                int errorStyle,
                boolean emptyCellAllowed,
                boolean suppressDropDownArrow,
                boolean isExplicitList,
                boolean showPromptBox,
                java.lang.String promptTitle,
                java.lang.String promptText,
                boolean showErrorBox,
                java.lang.String errorTitle,
                java.lang.String errorText,
                Ptg[] formula1,
                Ptg[] formula2,
                CellRangeAddressList regions)

DVRecord

public DVRecord(RecordInputStream in)
Method Detail

getDataType

public int getDataType()
Returns:
the condition data type
See Also:
DataValidationConstraint.ValidationType

getErrorStyle

public int getErrorStyle()
Returns:
the condition error style
See Also:
DataValidation.ErrorStyle

getListExplicitFormula

public boolean getListExplicitFormula()
Returns:
true if in list validations the string list is explicitly given in the formula, false otherwise

getEmptyCellAllowed

public boolean getEmptyCellAllowed()
Returns:
true if empty values are allowed in cells, false otherwise

getSuppressDropdownArrow

public boolean getSuppressDropdownArrow()
Returns:
true if drop down arrow should be suppressed when list validation is used, false otherwise

getShowPromptOnCellSelected

public boolean getShowPromptOnCellSelected()
Returns:
true if a prompt window should appear when cell is selected, false otherwise

getShowErrorOnInvalidValue

public boolean getShowErrorOnInvalidValue()
Returns:
true if an error window should appear when an invalid value is entered in the cell, false otherwise

getConditionOperator

public int getConditionOperator()
get the condition operator

Returns:
the condition operator
See Also:
utility class

getCellRangeAddress

public CellRangeAddressList getCellRangeAddress()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Clones the object. Uses serialisation, as the contents are somewhat complex

Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmbeddedObjectRefSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class EmbeddedObjectRefSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
        extended by  org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

public final class EmbeddedObjectRefSubRecord
extends SubRecord

ftPictFmla (0x0009)
A sub-record within the OBJ record which stores a reference to an object stored in a separate entry within the OLE2 compound file.

Author:
Daniel Noll

Field Summary
static short sid
Constructor Summary
EmbeddedObjectRefSubRecord(LittleEndianInput in, int size)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
byte[] | getObjectData()
java.lang.String | getOLEClassName()
short | getSid()
java.lang.Integer | getStreamId() Gets the stream ID containing the actual data.
void | serialize(LittleEndianOutput out)
java.lang.String | toString()
Methods inherited from class org.apache.poi.hssf.record.SubRecord
createSubRecord, isTerminating, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

EmbeddedObjectRefSubRecord

public EmbeddedObjectRefSubRecord(LittleEndianInput in,
                                  int size)
Method Detail

getSid

public short getSid()

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class SubRecord
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in class SubRecord

getStreamId

public java.lang.Integer getStreamId()
Gets the stream ID containing the actual data. The data itself can be found under a top-level directory entry in the OLE2 filesystem under the name "MBDxxxxxxxx" where xxxxxxxx is this ID converted into hex (in big endian order, funnily enough.)

Returns:
the data stream ID. Possibly null

getOLEClassName

public java.lang.String getOLEClassName()

getObjectData

public byte[] getObjectData()

clone

public java.lang.Object clone()
Specified by:
clone in class SubRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EndSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class EndSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
        extended by  org.apache.poi.hssf.record.EndSubRecord

public final class EndSubRecord
extends SubRecord

ftEnd (0x0000)

The end data record is used to denote the end of the subrecords.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
EndSubRecord()
EndSubRecord(LittleEndianInput in, int size)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid()
boolean | isTerminating() Wether this record terminates the sub-record stream.
void | serialize(LittleEndianOutput out)
java.lang.String | toString()
Methods inherited from class org.apache.poi.hssf.record.SubRecord
createSubRecord, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

EndSubRecord

public EndSubRecord()

EndSubRecord

public EndSubRecord(LittleEndianInput in,
                    int size)
Parameters:
in - unused (since this record has no data)
size -
Method Detail

isTerminating

public boolean isTerminating()
Description copied from class: SubRecord
Wether this record terminates the sub-record stream. There are two cases when this method must be overridden and return true - EndSubRecord (sid = 0x00) - LbsDataSubRecord (sid = 0x12)

Overrides:
isTerminating in class SubRecord
Returns:
whether this record is the last in the sub-record stream

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in class SubRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class SubRecord
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

getSid

public short getSid()

clone

public java.lang.Object clone()
Specified by:
clone in class SubRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EOFRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class EOFRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.EOFRecord

public final class EOFRecord
extends StandardRecord

End Of File record.

Description: Marks the end of records belonging to a particular object in the HSSF File

REFERENCE: PG 307 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static int | ENCODED_SIZE
static EOFRecord | instance
static short | sid
Constructor Summary
EOFRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

ENCODED_SIZE

public static final int ENCODED_SIZE
See Also:
Constant Field Values

instance

public static final EOFRecord instance
Constructor Detail

EOFRecord

public EOFRecord(RecordInputStream in)
Parameters:
in - unused (since this record has no data)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class EscherAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.AbstractEscherHolderRecord
                extended by  org.apache.poi.hssf.record.EscherAggregate

public final class EscherAggregate
extends AbstractEscherHolderRecord

This class is used to aggregate the MSODRAWING and OBJ record combinations. This is necessary due to the bizare way in which these records are serialized. What happens is that you get a combination of MSODRAWING -> OBJ -> MSODRAWING -> OBJ records but the escher records are serialized _across_ the MSODRAWING records.

It gets even worse when you start looking at TXO records.

So what we do with this class is aggregate lazily. That is we don't aggregate the MSODRAWING -> OBJ records unless we need to modify them.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
protected HSSFPatriarch | patriarch
static short | sid
static short | ST_ACCENTBORDERCALLOUT1
static short | ST_ACCENTBORDERCALLOUT2
static short | ST_ACCENTBORDERCALLOUT3
static short | ST_ACCENTBORDERCALLOUT90
static short | ST_ACCENTCALLOUT1
static short | ST_ACCENTCALLOUT2
static short | ST_ACCENTCALLOUT3
static short | ST_ACCENTCALLOUT90
static short | ST_ACTIONBUTTONBACKPREVIOUS
static short | ST_ACTIONBUTTONBEGINNING
static short | ST_ACTIONBUTTONBLANK
static short | ST_ACTIONBUTTONDOCUMENT
static short | ST_ACTIONBUTTONEND
static short | ST_ACTIONBUTTONFORWARDNEXT
static short | ST_ACTIONBUTTONHELP
static short | ST_ACTIONBUTTONHOME
static short | ST_ACTIONBUTTONINFORMATION
static short | ST_ACTIONBUTTONMOVIE
static short | ST_ACTIONBUTTONRETURN
static short | ST_ACTIONBUTTONSOUND
static short | ST_ARC
static short | ST_ARROW
static short | ST_BALLOON
static short | ST_BENTARROW
static short | ST_BENTCONNECTOR2
static short | ST_BENTCONNECTOR3
static short | ST_BENTCONNECTOR4
static short | ST_BENTCONNECTOR5
static short | ST_BENTUPARROW
static short | ST_BEVEL
static short | ST_BLOCKARC
static short | ST_BORDERCALLOUT1
static short | ST_BORDERCALLOUT2
static short | ST_BORDERCALLOUT3
static short | ST_BORDERCALLOUT90
static short | ST_BRACEPAIR
static short | ST_BRACKETPAIR
static short | ST_CALLOUT1
static short | ST_CALLOUT2
static short | ST_CALLOUT3
static short | ST_CALLOUT90
static short | ST_CAN
static short | ST_CHEVRON
static short | ST_CIRCULARARROW
static short | ST_CLOUDCALLOUT
static short | ST_CUBE
static short | ST_CURVEDCONNECTOR2
static short | ST_CURVEDCONNECTOR3
static short | ST_CURVEDCONNECTOR4
static short | ST_CURVEDCONNECTOR5
static short | ST_CURVEDDOWNARROW
static short | ST_CURVEDLEFTARROW
static short | ST_CURVEDRIGHTARROW
static short | ST_CURVEDUPARROW
static short | ST_DIAMOND
static short | ST_DONUT
static short | ST_DOUBLEWAVE
static short | ST_DOWNARROW
static short | ST_DOWNARROWCALLOUT
static short | ST_ELLIPSE
static short | ST_ELLIPSERIBBON
static short | ST_ELLIPSERIBBON2
static short | ST_FLOWCHARTALTERNATEPROCESS
static short | ST_FLOWCHARTCOLLATE
static short | ST_FLOWCHARTCONNECTOR
static short | ST_FLOWCHARTDECISION
static short | ST_FLOWCHARTDELAY
static short | ST_FLOWCHARTDISPLAY
static short | ST_FLOWCHARTDOCUMENT
static short | ST_FLOWCHARTEXTRACT
static short | ST_FLOWCHARTINPUTOUTPUT
static short | ST_FLOWCHARTINTERNALSTORAGE
static short | ST_FLOWCHARTMAGNETICDISK
static short | ST_FLOWCHARTMAGNETICDRUM
static short | ST_FLOWCHARTMAGNETICTAPE
static short | ST_FLOWCHARTMANUALINPUT
static short | ST_FLOWCHARTMANUALOPERATION
static short | ST_FLOWCHARTMERGE
static short | ST_FLOWCHARTMULTIDOCUMENT
static short | ST_FLOWCHARTOFFLINESTORAGE
static short | ST_FLOWCHARTOFFPAGECONNECTOR
static short | ST_FLOWCHARTONLINESTORAGE
static short | ST_FLOWCHARTOR
static short | ST_FLOWCHARTPREDEFINEDPROCESS
static short | ST_FLOWCHARTPREPARATION
static short | ST_FLOWCHARTPROCESS
static short | ST_FLOWCHARTPUNCHEDCARD
static short | ST_FLOWCHARTPUNCHEDTAPE
static short | ST_FLOWCHARTSORT
static short | ST_FLOWCHARTSUMMINGJUNCTION
static short | ST_FLOWCHARTTERMINATOR
static short | ST_FOLDEDCORNER
static short | ST_HEART
static short | ST_HEXAGON
static short | ST_HOMEPLATE
static short | ST_HORIZONTALSCROLL
static short | ST_HOSTCONTROL
static short | ST_IRREGULARSEAL1
static short | ST_IRREGULARSEAL2
static short | ST_ISOCELESTRIANGLE
static short | ST_LEFTARROW
static short | ST_LEFTARROWCALLOUT
static short | ST_LEFTBRACE
static short | ST_LEFTBRACKET
static short | ST_LEFTRIGHTARROW
static short | ST_LEFTRIGHTARROWCALLOUT
static short | ST_LEFTRIGHTUPARROW
static short | ST_LEFTUPARROW
static short | ST_LIGHTNINGBOLT
static short | ST_LINE
static short | ST_MIN
static short | ST_MOON
static short | ST_NIL
static short | ST_NOSMOKING
static short | ST_NOT_PRIMATIVE
static short | ST_NOTCHEDCIRCULARARROW
static short | ST_NOTCHEDRIGHTARROW
static short | ST_OCTAGON
static short | ST_PARALLELOGRAM
static short | ST_PENTAGON
static short | ST_PICTUREFRAME
static short | ST_PLAQUE
static short | ST_PLUS
static short | ST_QUADARROW
static short | ST_QUADARROWCALLOUT
static short | ST_RECTANGLE
static short | ST_RIBBON
static short | ST_RIBBON2
static short | ST_RIGHTARROWCALLOUT
static short | ST_RIGHTBRACE
static short | ST_RIGHTBRACKET
static short | ST_RIGHTTRIANGLE
static short | ST_ROUNDRECTANGLE
static short | ST_SEAL
static short | ST_SEAL16
static short | ST_SEAL24
static short | ST_SEAL32
static short | ST_SEAL4
static short | ST_SEAL8
static short | ST_SMILEYFACE
static short | ST_STAR
static short | ST_STRAIGHTCONNECTOR1
static short | ST_STRIPEDRIGHTARROW
static short | ST_SUN
static short | ST_TEXTARCHDOWNCURVE
static short | ST_TEXTARCHDOWNPOUR
static short | ST_TEXTARCHUPCURVE
static short | ST_TEXTARCHUPPOUR
static short | ST_TEXTBOX
static short | ST_TEXTBUTTONCURVE
static short | ST_TEXTBUTTONPOUR
static short | ST_TEXTCANDOWN
static short | ST_TEXTCANUP
static short | ST_TEXTCASCADEDOWN
static short | ST_TEXTCASCADEUP
static short | ST_TEXTCHEVRON
static short | ST_TEXTCHEVRONINVERTED
static short | ST_TEXTCIRCLECURVE
static short | ST_TEXTCIRCLEPOUR
static short | ST_TEXTCURVE
static short | ST_TEXTCURVEDOWN
static short | ST_TEXTCURVEUP
static short | ST_TEXTDEFLATE
static short | ST_TEXTDEFLATEBOTTOM
static short | ST_TEXTDEFLATEINFLATE
static short | ST_TEXTDEFLATEINFLATEDEFLATE
static short | ST_TEXTDEFLATETOP
static short | ST_TEXTFADEDOWN
static short | ST_TEXTFADELEFT
static short | ST_TEXTFADERIGHT
static short | ST_TEXTFADEUP
static short | ST_TEXTHEXAGON
static short | ST_TEXTINFLATE
static short | ST_TEXTINFLATEBOTTOM
static short | ST_TEXTINFLATETOP
static short | ST_TEXTOCTAGON
static short | ST_TEXTONCURVE
static short | ST_TEXTONRING
static short | ST_TEXTPLAINTEXT
static short | ST_TEXTRING
static short | ST_TEXTRINGINSIDE
static short | ST_TEXTRINGOUTSIDE
static short | ST_TEXTSIMPLE
static short | ST_TEXTSLANTDOWN
static short | ST_TEXTSLANTUP
static short | ST_TEXTSTOP
static short | ST_TEXTTRIANGLE
static short | ST_TEXTTRIANGLEINVERTED
static short | ST_TEXTWAVE
static short | ST_TEXTWAVE1
static short | ST_TEXTWAVE2
static short | ST_TEXTWAVE3
static short | ST_TEXTWAVE4
static short | ST_THICKARROW
static short | ST_TRAPEZOID
static short | ST_UPARROW
static short | ST_UPARROWCALLOUT
static short | ST_UPDOWNARROW
static short | ST_UPDOWNARROWCALLOUT
static short | ST_UTURNARROW
static short | ST_VERTICALSCROLL
static short | ST_WAVE
static short | ST_WEDGEELLIPSECALLOUT
static short | ST_WEDGERECTCALLOUT
static short | ST_WEDGERRECTCALLOUT
Constructor Summary
EscherAggregate(DrawingManager2 drawingManager)
Method Summary
void | clear()
void | convertRecordsToUserModel() Converts the Records into UserModel objects on the bound HSSFPatriarch
static EscherAggregate | createAggregate(java.util.List records, int locFirstDrawingRecord, DrawingManager2 drawingManager) Collapses the drawing records into an aggregate.
HSSFPatriarch | getPatriarch()
protected java.lang.String | getRecordName()
int | getRecordSize() gives the current serialized size of the record.
short | getSid() return the non static version of the id for this record.
int | serialize(int offset, byte[] data) Serializes this aggregate to a byte array.
void | setPatriarch(HSSFPatriarch patriarch)
java.lang.String | toString() Calculates the string representation of this record.
Methods inherited from class org.apache.poi.hssf.record.AbstractEscherHolderRecord
addEscherRecord, addEscherRecord, clearEscherRecords, clone, convertRawBytesToEscherRecords, decode, findFirstWithId, getEscherContainer, getEscherRecord, getEscherRecords, getRawData, join, processContinueRecord, setRawData
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

ST_MIN

public static final short ST_MIN
See Also:
Constant Field Values

ST_NOT_PRIMATIVE

public static final short ST_NOT_PRIMATIVE
See Also:
Constant Field Values

ST_RECTANGLE

public static final short ST_RECTANGLE
See Also:
Constant Field Values

ST_ROUNDRECTANGLE

public static final short ST_ROUNDRECTANGLE
See Also:
Constant Field Values

ST_ELLIPSE

public static final short ST_ELLIPSE
See Also:
Constant Field Values

ST_DIAMOND

public static final short ST_DIAMOND
See Also:
Constant Field Values

ST_ISOCELESTRIANGLE

public static final short ST_ISOCELESTRIANGLE
See Also:
Constant Field Values

ST_RIGHTTRIANGLE

public static final short ST_RIGHTTRIANGLE
See Also:
Constant Field Values

ST_PARALLELOGRAM

public static final short ST_PARALLELOGRAM
See Also:
Constant Field Values

ST_TRAPEZOID

public static final short ST_TRAPEZOID
See Also:
Constant Field Values

ST_HEXAGON

public static final short ST_HEXAGON
See Also:
Constant Field Values

ST_OCTAGON

public static final short ST_OCTAGON
See Also:
Constant Field Values

ST_PLUS

public static final short ST_PLUS
See Also:
Constant Field Values

ST_STAR

public static final short ST_STAR
See Also:
Constant Field Values

ST_ARROW

public static final short ST_ARROW
See Also:
Constant Field Values

ST_THICKARROW

public static final short ST_THICKARROW
See Also:
Constant Field Values

ST_HOMEPLATE

public static final short ST_HOMEPLATE
See Also:
Constant Field Values

ST_CUBE

public static final short ST_CUBE
See Also:
Constant Field Values

ST_BALLOON

public static final short ST_BALLOON
See Also:
Constant Field Values

ST_SEAL

public static final short ST_SEAL
See Also:
Constant Field Values

ST_ARC

public static final short ST_ARC
See Also:
Constant Field Values

ST_LINE

public static final short ST_LINE
See Also:
Constant Field Values

ST_PLAQUE

public static final short ST_PLAQUE
See Also:
Constant Field Values

ST_CAN

public static final short ST_CAN
See Also:
Constant Field Values

ST_DONUT

public static final short ST_DONUT
See Also:
Constant Field Values

ST_TEXTSIMPLE

public static final short ST_TEXTSIMPLE
See Also:
Constant Field Values

ST_TEXTOCTAGON

public static final short ST_TEXTOCTAGON
See Also:
Constant Field Values

ST_TEXTHEXAGON

public static final short ST_TEXTHEXAGON
See Also:
Constant Field Values

ST_TEXTCURVE

public static final short ST_TEXTCURVE
See Also:
Constant Field Values

ST_TEXTWAVE

public static final short ST_TEXTWAVE
See Also:
Constant Field Values

ST_TEXTRING

public static final short ST_TEXTRING
See Also:
Constant Field Values

ST_TEXTONCURVE

public static final short ST_TEXTONCURVE
See Also:
Constant Field Values

ST_TEXTONRING

public static final short ST_TEXTONRING
See Also:
Constant Field Values

ST_STRAIGHTCONNECTOR1

public static final short ST_STRAIGHTCONNECTOR1
See Also:
Constant Field Values

ST_BENTCONNECTOR2

public static final short ST_BENTCONNECTOR2
See Also:
Constant Field Values

ST_BENTCONNECTOR3

public static final short ST_BENTCONNECTOR3
See Also:
Constant Field Values

ST_BENTCONNECTOR4

public static final short ST_BENTCONNECTOR4
See Also:
Constant Field Values

ST_BENTCONNECTOR5

public static final short ST_BENTCONNECTOR5
See Also:
Constant Field Values

ST_CURVEDCONNECTOR2

public static final short ST_CURVEDCONNECTOR2
See Also:
Constant Field Values

ST_CURVEDCONNECTOR3

public static final short ST_CURVEDCONNECTOR3
See Also:
Constant Field Values

ST_CURVEDCONNECTOR4

public static final short ST_CURVEDCONNECTOR4
See Also:
Constant Field Values

ST_CURVEDCONNECTOR5

public static final short ST_CURVEDCONNECTOR5
See Also:
Constant Field Values

ST_CALLOUT1

public static final short ST_CALLOUT1
See Also:
Constant Field Values

ST_CALLOUT2

public static final short ST_CALLOUT2
See Also:
Constant Field Values

ST_CALLOUT3

public static final short ST_CALLOUT3
See Also:
Constant Field Values

ST_ACCENTCALLOUT1

public static final short ST_ACCENTCALLOUT1
See Also:
Constant Field Values

ST_ACCENTCALLOUT2

public static final short ST_ACCENTCALLOUT2
See Also:
Constant Field Values

ST_ACCENTCALLOUT3

public static final short ST_ACCENTCALLOUT3
See Also:
Constant Field Values

ST_BORDERCALLOUT1

public static final short ST_BORDERCALLOUT1
See Also:
Constant Field Values

ST_BORDERCALLOUT2

public static final short ST_BORDERCALLOUT2
See Also:
Constant Field Values

ST_BORDERCALLOUT3

public static final short ST_BORDERCALLOUT3
See Also:
Constant Field Values

ST_ACCENTBORDERCALLOUT1

public static final short ST_ACCENTBORDERCALLOUT1
See Also:
Constant Field Values

ST_ACCENTBORDERCALLOUT2

public static final short ST_ACCENTBORDERCALLOUT2
See Also:
Constant Field Values

ST_ACCENTBORDERCALLOUT3

public static final short ST_ACCENTBORDERCALLOUT3
See Also:
Constant Field Values

ST_RIBBON

public static final short ST_RIBBON
See Also:
Constant Field Values

ST_RIBBON2

public static final short ST_RIBBON2
See Also:
Constant Field Values

ST_CHEVRON

public static final short ST_CHEVRON
See Also:
Constant Field Values

ST_PENTAGON

public static final short ST_PENTAGON
See Also:
Constant Field Values

ST_NOSMOKING

public static final short ST_NOSMOKING
See Also:
Constant Field Values

ST_SEAL8

public static final short ST_SEAL8
See Also:
Constant Field Values

ST_SEAL16

public static final short ST_SEAL16
See Also:
Constant Field Values

ST_SEAL32

public static final short ST_SEAL32
See Also:
Constant Field Values

ST_WEDGERECTCALLOUT

public static final short ST_WEDGERECTCALLOUT
See Also:
Constant Field Values

ST_WEDGERRECTCALLOUT

public static final short ST_WEDGERRECTCALLOUT
See Also:
Constant Field Values

ST_WEDGEELLIPSECALLOUT

public static final short ST_WEDGEELLIPSECALLOUT
See Also:
Constant Field Values

ST_WAVE

public static final short ST_WAVE
See Also:
Constant Field Values

ST_FOLDEDCORNER

public static final short ST_FOLDEDCORNER
See Also:
Constant Field Values

ST_LEFTARROW

public static final short ST_LEFTARROW
See Also:
Constant Field Values

ST_DOWNARROW

public static final short ST_DOWNARROW
See Also:
Constant Field Values

ST_UPARROW

public static final short ST_UPARROW
See Also:
Constant Field Values

ST_LEFTRIGHTARROW

public static final short ST_LEFTRIGHTARROW
See Also:
Constant Field Values

ST_UPDOWNARROW

public static final short ST_UPDOWNARROW
See Also:
Constant Field Values

ST_IRREGULARSEAL1

public static final short ST_IRREGULARSEAL1
See Also:
Constant Field Values

ST_IRREGULARSEAL2

public static final short ST_IRREGULARSEAL2
See Also:
Constant Field Values

ST_LIGHTNINGBOLT

public static final short ST_LIGHTNINGBOLT
See Also:
Constant Field Values

ST_HEART

public static final short ST_HEART
See Also:
Constant Field Values

ST_PICTUREFRAME

public static final short ST_PICTUREFRAME
See Also:
Constant Field Values

ST_QUADARROW

public static final short ST_QUADARROW
See Also:
Constant Field Values

ST_LEFTARROWCALLOUT

public static final short ST_LEFTARROWCALLOUT
See Also:
Constant Field Values

ST_RIGHTARROWCALLOUT

public static final short ST_RIGHTARROWCALLOUT
See Also:
Constant Field Values

ST_UPARROWCALLOUT

public static final short ST_UPARROWCALLOUT
See Also:
Constant Field Values

ST_DOWNARROWCALLOUT

public static final short ST_DOWNARROWCALLOUT
See Also:
Constant Field Values

ST_LEFTRIGHTARROWCALLOUT

public static final short ST_LEFTRIGHTARROWCALLOUT
See Also:
Constant Field Values

ST_UPDOWNARROWCALLOUT

public static final short ST_UPDOWNARROWCALLOUT
See Also:
Constant Field Values

ST_QUADARROWCALLOUT

public static final short ST_QUADARROWCALLOUT
See Also:
Constant Field Values

ST_BEVEL

public static final short ST_BEVEL
See Also:
Constant Field Values

ST_LEFTBRACKET

public static final short ST_LEFTBRACKET
See Also:
Constant Field Values

ST_RIGHTBRACKET

public static final short ST_RIGHTBRACKET
See Also:
Constant Field Values

ST_LEFTBRACE

public static final short ST_LEFTBRACE
See Also:
Constant Field Values

ST_RIGHTBRACE

public static final short ST_RIGHTBRACE
See Also:
Constant Field Values

ST_LEFTUPARROW

public static final short ST_LEFTUPARROW
See Also:
Constant Field Values

ST_BENTUPARROW

public static final short ST_BENTUPARROW
See Also:
Constant Field Values

ST_BENTARROW

public static final short ST_BENTARROW
See Also:
Constant Field Values

ST_SEAL24

public static final short ST_SEAL24
See Also:
Constant Field Values

ST_STRIPEDRIGHTARROW

public static final short ST_STRIPEDRIGHTARROW
See Also:
Constant Field Values

ST_NOTCHEDRIGHTARROW

public static final short ST_NOTCHEDRIGHTARROW
See Also:
Constant Field Values

ST_BLOCKARC

public static final short ST_BLOCKARC
See Also:
Constant Field Values

ST_SMILEYFACE

public static final short ST_SMILEYFACE
See Also:
Constant Field Values

ST_VERTICALSCROLL

public static final short ST_VERTICALSCROLL
See Also:
Constant Field Values

ST_HORIZONTALSCROLL

public static final short ST_HORIZONTALSCROLL
See Also:
Constant Field Values

ST_CIRCULARARROW

public static final short ST_CIRCULARARROW
See Also:
Constant Field Values

ST_NOTCHEDCIRCULARARROW

public static final short ST_NOTCHEDCIRCULARARROW
See Also:
Constant Field Values

ST_UTURNARROW

public static final short ST_UTURNARROW
See Also:
Constant Field Values

ST_CURVEDRIGHTARROW

public static final short ST_CURVEDRIGHTARROW
See Also:
Constant Field Values

ST_CURVEDLEFTARROW

public static final short ST_CURVEDLEFTARROW
See Also:
Constant Field Values

ST_CURVEDUPARROW

public static final short ST_CURVEDUPARROW
See Also:
Constant Field Values

ST_CURVEDDOWNARROW

public static final short ST_CURVEDDOWNARROW
See Also:
Constant Field Values

ST_CLOUDCALLOUT

public static final short ST_CLOUDCALLOUT
See Also:
Constant Field Values

ST_ELLIPSERIBBON

public static final short ST_ELLIPSERIBBON
See Also:
Constant Field Values

ST_ELLIPSERIBBON2

public static final short ST_ELLIPSERIBBON2
See Also:
Constant Field Values

ST_FLOWCHARTPROCESS

public static final short ST_FLOWCHARTPROCESS
See Also:
Constant Field Values

ST_FLOWCHARTDECISION

public static final short ST_FLOWCHARTDECISION
See Also:
Constant Field Values

ST_FLOWCHARTINPUTOUTPUT

public static final short ST_FLOWCHARTINPUTOUTPUT
See Also:
Constant Field Values

ST_FLOWCHARTPREDEFINEDPROCESS

public static final short ST_FLOWCHARTPREDEFINEDPROCESS
See Also:
Constant Field Values

ST_FLOWCHARTINTERNALSTORAGE

public static final short ST_FLOWCHARTINTERNALSTORAGE
See Also:
Constant Field Values

ST_FLOWCHARTDOCUMENT

public static final short ST_FLOWCHARTDOCUMENT
See Also:
Constant Field Values

ST_FLOWCHARTMULTIDOCUMENT

public static final short ST_FLOWCHARTMULTIDOCUMENT
See Also:
Constant Field Values

ST_FLOWCHARTTERMINATOR

public static final short ST_FLOWCHARTTERMINATOR
See Also:
Constant Field Values

ST_FLOWCHARTPREPARATION

public static final short ST_FLOWCHARTPREPARATION
See Also:
Constant Field Values

ST_FLOWCHARTMANUALINPUT

public static final short ST_FLOWCHARTMANUALINPUT
See Also:
Constant Field Values

ST_FLOWCHARTMANUALOPERATION

public static final short ST_FLOWCHARTMANUALOPERATION
See Also:
Constant Field Values

ST_FLOWCHARTCONNECTOR

public static final short ST_FLOWCHARTCONNECTOR
See Also:
Constant Field Values

ST_FLOWCHARTPUNCHEDCARD

public static final short ST_FLOWCHARTPUNCHEDCARD
See Also:
Constant Field Values

ST_FLOWCHARTPUNCHEDTAPE

public static final short ST_FLOWCHARTPUNCHEDTAPE
See Also:
Constant Field Values

ST_FLOWCHARTSUMMINGJUNCTION

public static final short ST_FLOWCHARTSUMMINGJUNCTION
See Also:
Constant Field Values

ST_FLOWCHARTOR

public static final short ST_FLOWCHARTOR
See Also:
Constant Field Values

ST_FLOWCHARTCOLLATE

public static final short ST_FLOWCHARTCOLLATE
See Also:
Constant Field Values

ST_FLOWCHARTSORT

public static final short ST_FLOWCHARTSORT
See Also:
Constant Field Values

ST_FLOWCHARTEXTRACT

public static final short ST_FLOWCHARTEXTRACT
See Also:
Constant Field Values

ST_FLOWCHARTMERGE

public static final short ST_FLOWCHARTMERGE
See Also:
Constant Field Values

ST_FLOWCHARTOFFLINESTORAGE

public static final short ST_FLOWCHARTOFFLINESTORAGE
See Also:
Constant Field Values

ST_FLOWCHARTONLINESTORAGE

public static final short ST_FLOWCHARTONLINESTORAGE
See Also:
Constant Field Values

ST_FLOWCHARTMAGNETICTAPE

public static final short ST_FLOWCHARTMAGNETICTAPE
See Also:
Constant Field Values

ST_FLOWCHARTMAGNETICDISK

public static final short ST_FLOWCHARTMAGNETICDISK
See Also:
Constant Field Values

ST_FLOWCHARTMAGNETICDRUM

public static final short ST_FLOWCHARTMAGNETICDRUM
See Also:
Constant Field Values

ST_FLOWCHARTDISPLAY

public static final short ST_FLOWCHARTDISPLAY
See Also:
Constant Field Values

ST_FLOWCHARTDELAY

public static final short ST_FLOWCHARTDELAY
See Also:
Constant Field Values

ST_TEXTPLAINTEXT

public static final short ST_TEXTPLAINTEXT
See Also:
Constant Field Values

ST_TEXTSTOP

public static final short ST_TEXTSTOP
See Also:
Constant Field Values

ST_TEXTTRIANGLE

public static final short ST_TEXTTRIANGLE
See Also:
Constant Field Values

ST_TEXTTRIANGLEINVERTED

public static final short ST_TEXTTRIANGLEINVERTED
See Also:
Constant Field Values

ST_TEXTCHEVRON

public static final short ST_TEXTCHEVRON
See Also:
Constant Field Values

ST_TEXTCHEVRONINVERTED

public static final short ST_TEXTCHEVRONINVERTED
See Also:
Constant Field Values

ST_TEXTRINGINSIDE

public static final short ST_TEXTRINGINSIDE
See Also:
Constant Field Values

ST_TEXTRINGOUTSIDE

public static final short ST_TEXTRINGOUTSIDE
See Also:
Constant Field Values

ST_TEXTARCHUPCURVE

public static final short ST_TEXTARCHUPCURVE
See Also:
Constant Field Values

ST_TEXTARCHDOWNCURVE

public static final short ST_TEXTARCHDOWNCURVE
See Also:
Constant Field Values

ST_TEXTCIRCLECURVE

public static final short ST_TEXTCIRCLECURVE
See Also:
Constant Field Values

ST_TEXTBUTTONCURVE

public static final short ST_TEXTBUTTONCURVE
See Also:
Constant Field Values

ST_TEXTARCHUPPOUR

public static final short ST_TEXTARCHUPPOUR
See Also:
Constant Field Values

ST_TEXTARCHDOWNPOUR

public static final short ST_TEXTARCHDOWNPOUR
See Also:
Constant Field Values

ST_TEXTCIRCLEPOUR

public static final short ST_TEXTCIRCLEPOUR
See Also:
Constant Field Values

ST_TEXTBUTTONPOUR

public static final short ST_TEXTBUTTONPOUR
See Also:
Constant Field Values

ST_TEXTCURVEUP

public static final short ST_TEXTCURVEUP
See Also:
Constant Field Values

ST_TEXTCURVEDOWN

public static final short ST_TEXTCURVEDOWN
See Also:
Constant Field Values

ST_TEXTCASCADEUP

public static final short ST_TEXTCASCADEUP
See Also:
Constant Field Values

ST_TEXTCASCADEDOWN

public static final short ST_TEXTCASCADEDOWN
See Also:
Constant Field Values

ST_TEXTWAVE1

public static final short ST_TEXTWAVE1
See Also:
Constant Field Values

ST_TEXTWAVE2

public static final short ST_TEXTWAVE2
See Also:
Constant Field Values

ST_TEXTWAVE3

public static final short ST_TEXTWAVE3
See Also:
Constant Field Values

ST_TEXTWAVE4

public static final short ST_TEXTWAVE4
See Also:
Constant Field Values

ST_TEXTINFLATE

public static final short ST_TEXTINFLATE
See Also:
Constant Field Values

ST_TEXTDEFLATE

public static final short ST_TEXTDEFLATE
See Also:
Constant Field Values

ST_TEXTINFLATEBOTTOM

public static final short ST_TEXTINFLATEBOTTOM
See Also:
Constant Field Values

ST_TEXTDEFLATEBOTTOM

public static final short ST_TEXTDEFLATEBOTTOM
See Also:
Constant Field Values

ST_TEXTINFLATETOP

public static final short ST_TEXTINFLATETOP
See Also:
Constant Field Values

ST_TEXTDEFLATETOP

public static final short ST_TEXTDEFLATETOP
See Also:
Constant Field Values

ST_TEXTDEFLATEINFLATE

public static final short ST_TEXTDEFLATEINFLATE
See Also:
Constant Field Values

ST_TEXTDEFLATEINFLATEDEFLATE

public static final short ST_TEXTDEFLATEINFLATEDEFLATE
See Also:
Constant Field Values

ST_TEXTFADERIGHT

public static final short ST_TEXTFADERIGHT
See Also:
Constant Field Values

ST_TEXTFADELEFT

public static final short ST_TEXTFADELEFT
See Also:
Constant Field Values

ST_TEXTFADEUP

public static final short ST_TEXTFADEUP
See Also:
Constant Field Values

ST_TEXTFADEDOWN

public static final short ST_TEXTFADEDOWN
See Also:
Constant Field Values

ST_TEXTSLANTUP

public static final short ST_TEXTSLANTUP
See Also:
Constant Field Values

ST_TEXTSLANTDOWN

public static final short ST_TEXTSLANTDOWN
See Also:
Constant Field Values

ST_TEXTCANUP

public static final short ST_TEXTCANUP
See Also:
Constant Field Values

ST_TEXTCANDOWN

public static final short ST_TEXTCANDOWN
See Also:
Constant Field Values

ST_FLOWCHARTALTERNATEPROCESS

public static final short ST_FLOWCHARTALTERNATEPROCESS
See Also:
Constant Field Values

ST_FLOWCHARTOFFPAGECONNECTOR

public static final short ST_FLOWCHARTOFFPAGECONNECTOR
See Also:
Constant Field Values

ST_CALLOUT90

public static final short ST_CALLOUT90
See Also:
Constant Field Values

ST_ACCENTCALLOUT90

public static final short ST_ACCENTCALLOUT90
See Also:
Constant Field Values

ST_BORDERCALLOUT90

public static final short ST_BORDERCALLOUT90
See Also:
Constant Field Values

ST_ACCENTBORDERCALLOUT90

public static final short ST_ACCENTBORDERCALLOUT90
See Also:
Constant Field Values

ST_LEFTRIGHTUPARROW

public static final short ST_LEFTRIGHTUPARROW
See Also:
Constant Field Values

ST_SUN

public static final short ST_SUN
See Also:
Constant Field Values

ST_MOON

public static final short ST_MOON
See Also:
Constant Field Values

ST_BRACKETPAIR

public static final short ST_BRACKETPAIR
See Also:
Constant Field Values

ST_BRACEPAIR

public static final short ST_BRACEPAIR
See Also:
Constant Field Values

ST_SEAL4

public static final short ST_SEAL4
See Also:
Constant Field Values

ST_DOUBLEWAVE

public static final short ST_DOUBLEWAVE
See Also:
Constant Field Values

ST_ACTIONBUTTONBLANK

public static final short ST_ACTIONBUTTONBLANK
See Also:
Constant Field Values

ST_ACTIONBUTTONHOME

public static final short ST_ACTIONBUTTONHOME
See Also:
Constant Field Values

ST_ACTIONBUTTONHELP

public static final short ST_ACTIONBUTTONHELP
See Also:
Constant Field Values

ST_ACTIONBUTTONINFORMATION

public static final short ST_ACTIONBUTTONINFORMATION
See Also:
Constant Field Values

ST_ACTIONBUTTONFORWARDNEXT

public static final short ST_ACTIONBUTTONFORWARDNEXT
See Also:
Constant Field Values

ST_ACTIONBUTTONBACKPREVIOUS

public static final short ST_ACTIONBUTTONBACKPREVIOUS
See Also:
Constant Field Values

ST_ACTIONBUTTONEND

public static final short ST_ACTIONBUTTONEND
See Also:
Constant Field Values

ST_ACTIONBUTTONBEGINNING

public static final short ST_ACTIONBUTTONBEGINNING
See Also:
Constant Field Values

ST_ACTIONBUTTONRETURN

public static final short ST_ACTIONBUTTONRETURN
See Also:
Constant Field Values

ST_ACTIONBUTTONDOCUMENT

public static final short ST_ACTIONBUTTONDOCUMENT
See Also:
Constant Field Values

ST_ACTIONBUTTONSOUND

public static final short ST_ACTIONBUTTONSOUND
See Also:
Constant Field Values

ST_ACTIONBUTTONMOVIE

public static final short ST_ACTIONBUTTONMOVIE
See Also:
Constant Field Values

ST_HOSTCONTROL

public static final short ST_HOSTCONTROL
See Also:
Constant Field Values

ST_TEXTBOX

public static final short ST_TEXTBOX
See Also:
Constant Field Values

ST_NIL

public static final short ST_NIL
See Also:
Constant Field Values

patriarch

protected HSSFPatriarch patriarch
Constructor Detail

EscherAggregate

public EscherAggregate(DrawingManager2 drawingManager)
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class AbstractEscherHolderRecord
Returns:
Returns the current sid.

toString

public java.lang.String toString()
Calculates the string representation of this record. This is simply a dump of all the records.

Overrides:
toString in class AbstractEscherHolderRecord

createAggregate

public static EscherAggregate createAggregate(java.util.List records,
                                              int locFirstDrawingRecord,
                                              DrawingManager2 drawingManager)
Collapses the drawing records into an aggregate.

serialize

public int serialize(int offset,
                     byte[] data)
Serializes this aggregate to a byte array. Since this is an aggregate record it will effectively serialize the aggregated records.

Overrides:
serialize in class AbstractEscherHolderRecord
Parameters:
offset - The offset into the start of the array.
data - The byte array to serialize to.
Returns:
The number of bytes serialized.

getRecordSize

public int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Overrides:
getRecordSize in class AbstractEscherHolderRecord

getPatriarch

public HSSFPatriarch getPatriarch()

setPatriarch

public void setPatriarch(HSSFPatriarch patriarch)

convertRecordsToUserModel

public void convertRecordsToUserModel()
Converts the Records into UserModel objects on the bound HSSFPatriarch

clear

public void clear()

getRecordName

protected java.lang.String getRecordName()
Specified by:
getRecordName in class AbstractEscherHolderRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExtendedFormatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ExtendedFormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ExtendedFormatRecord

public final class ExtendedFormatRecord
extends StandardRecord

Title: Extended Format Record Description: Probably one of the more complex records. There are two breeds: Style and Cell.

It should be noted that fields in the extended format record are somewhat arbitrary. Almost all of the fields are bit-level, but we name them as best as possible by functional group. In some places this is better than others.

REFERENCE: PG 426 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short | ALT_BARS
static short | BIG_SPOTS
static short | BRICKS
static short | CENTER
static short | CENTER_SELECTION
static short | DASH_DOT
static short | DASH_DOT_DOT
static short | DASHED
static short | DIAMONDS
static short | DOTTED
static short | DOUBLE
static short | FILL
static short | FINE_DOTS
static short | GENERAL
static short | HAIR
static short | JUSTIFY
static short | LEFT
static short | MEDIUM
static short | MEDIUM_DASH_DOT
static short | MEDIUM_DASH_DOT_DOT
static short | MEDIUM_DASHED
static short | NO_FILL
static short | NONE
static short | NULL
static short | RIGHT
static short | sid
static short | SLANTED_DASH_DOT
static short | SOLID_FILL
static short | SPARSE_DOTS
static short | SQUARES
static short | THICK
static short | THICK_BACKWARD_DIAG
static short | THICK_FORWARD_DIAG
static short | THICK_HORZ_BANDS
static short | THICK_VERT_BANDS
static short | THIN
static short | THIN_BACKWARD_DIAG
static short | THIN_FORWARD_DIAG
static short | THIN_HORZ_BANDS
static short | THIN_VERT_BANDS
static short | VERTICAL_BOTTOM
static short | VERTICAL_CENTER
static short | VERTICAL_JUSTIFY
static short | VERTICAL_TOP
static short | XF_CELL
static short | XF_STYLE
Constructor Summary
ExtendedFormatRecord()
Constructor ExtendedFormatRecord
ExtendedFormatRecord(RecordInputStream in)
Method Summary
void | cloneStyleFrom(ExtendedFormatRecord source) Clones all the style information from another ExtendedFormatRecord, onto this one.
boolean | equals(java.lang.Object obj) Will consider two different records with the same contents as equals, as the various indexes that matter are embedded in the records
boolean | get123Prefix() get some old holdover from lotus 123.
short | getAdtlDiag() get for diagonal borders? No idea (its a palette color for the other function we didn't know what was?)
short | getAdtlDiagLineStyle() get the diagonal border line style? Who the heck ever heard of a diagonal border?
short | getAdtlFillPattern() get the additional fill pattern
int | getAdtlPaletteOptions() get the additional palette options bitmask (see individual bit getter methods that reference this method)
short | getAlignment() get the horizontal alignment of the cell.
short | getAlignmentOptions() get the alignment options bitmask.
short | getBorderBottom() get the borderline style for the bottom border
short | getBorderLeft() get the borderline style for the left border
short | getBorderOptions() get the border options bitmask (see the corresponding bit getter methods that reference back to this one)
short | getBorderRight() get the borderline style for the right border
short | getBorderTop() get the borderline style for the top border
short | getBottomBorderPaletteIdx() get the palette index for the bottom border
short | getCellOptions() gets the options bitmask - you can also use corresponding option bit getters (see other methods that reference this one)
protected int | getDataSize()
short | getDiag() Not sure what this is for (maybe fill lines?) 1 = down, 2 = up, 3 = both, 0 for none..
short | getFillBackground() get the background palette color index
short | getFillForeground() get the foreground palette color index
short | getFillPaletteOptions() get the fill palette options bitmask (see indivdual bit getters that reference this method)
short | getFontIndex() get the index to the FONT record (which font to use 0 based)
short | getFormatIndex() get the index to the Format record (which FORMAT to use 0-based)
short | getIndent() get indention (not sure of the units, think its spaces)
short | getIndentionOptions() get the indent options bitmask (see corresponding bit getters that reference this field)
short | getJustifyLast() Dunno.
short | getLeftBorderPaletteIdx() get the palette index for the left border color
boolean | getMergeCells() get whether to merge cells
short | getPaletteOptions() get the palette options bitmask (see the individual bit getter methods that reference this one)
short | getParentIndex() for cell XF types this is the parent style (usually 0/normal).
short | getReadingOrder() get the reading order for far east versions (0 - Context, 1 - Left to right, 2 - right to left) - We could use some help with support for the far east.
short | getRightBorderPaletteIdx() get the palette index for the right border color
short | getRotation() get the degree of rotation.
boolean | getShrinkToFit() get whether to shrink the text to fit
short | getSid() return the non static version of the id for this record.
short | getTopBorderPaletteIdx() get the palette index for the top border
short | getVerticalAlignment() get the vertical alignment of text in the cell
boolean | getWrapText() get whether to wrap the text in the cell
short | getXFType() get whether the cell is a cell or style XFRecord
int | hashCode()
boolean | isHidden() get whether the cell is hidden or not
boolean | isIndentNotParentAlignment() get whether or not to use the alignment in this XF instead of the parent XF.
boolean | isIndentNotParentBorder() get whether or not to use the border in this XF instead of the parent XF.
boolean | isIndentNotParentCellOptions() get whether or not to use the locking/hidden in this XF instead of the parent XF.
boolean | isIndentNotParentFont() get whether or not to use the font in this XF instead of the parent XF.
boolean | isIndentNotParentFormat() get whether or not to use the format in this XF instead of the parent XF.
boolean | isIndentNotParentPattern() get whether or not to use the pattern in this XF instead of the parent XF.
boolean | isLocked() get whether the cell is locked or not
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | set123Prefix(boolean prefix) set some old holdover from lotus 123.
void | setAdtlDiag(short diag) set for diagonal borders? No idea (its a palette color for the other function we didn't know what was?)
void | setAdtlDiagLineStyle(short diag) set the diagonal border line style? Who the heck ever heard of a diagonal border?
void | setAdtlFillPattern(short fill) set the fill pattern
void | setAdtlPaletteOptions(short options) set the additional palette options bitmask (see individual bitsetter methods that reference this method)
void | setAlignment(short align) set the horizontal alignment of the cell.
void | setAlignmentOptions(short options) set the alignment options bitmask.
void | setBorderBottom(short border) set the border line style for the bottom border
void | setBorderLeft(short border) set the borderline style for the left border
void | setBorderOptions(short options) set the border options bitmask (see the corresponding bitsetter methods that reference back to this one)
void | setBorderRight(short border) set the border line style for the right border
void | setBorderTop(short border) set the border line style for the top border
void | setBottomBorderPaletteIdx(short border) set the palette index for the bottom border
void | setCellOptions(short options) sets the options bitmask - you can also use corresponding option bit setters (see other methods that reference this one)
void | setDiag(short diag) Not sure what this is for (maybe fill lines?) 1 = down, 2 = up, 3 = both, 0 for none..
void | setFillBackground(short color) set the background palette color index
void | setFillForeground(short color) set the foreground palette color index
void | setFillPaletteOptions(short options) set the fill palette options bitmask (see
void | setFontIndex(short index) set the index to the FONT record (which font to use 0 based)
void | setFormatIndex(short index) set the index to the Format record (which FORMAT to use 0-based)
void | setHidden(boolean hidden) set whether the cell is hidden or not
void | setIndent(short indent) set indention (not sure of the units, think its spaces)
void | setIndentionOptions(short options) set the indent options bitmask (see corresponding bitmask setters that reference this field)
void | setIndentNotParentAlignment(boolean alignment) set whether or not to use the alignment in this XF instead of the parent XF.
void | setIndentNotParentBorder(boolean border) set whether or not to use the border in this XF instead of the parent XF.
void | setIndentNotParentCellOptions(boolean options) set whether or not to use the locking/hidden in this XF instead of the parent XF.
void | setIndentNotParentFont(boolean font) set whether or not to use the font in this XF instead of the parent XF.
void | setIndentNotParentFormat(boolean parent) set whether or not to use the format in this XF instead of the parent XF.
void | setIndentNotParentPattern(boolean pattern) Sets whether or not to use the pattern in this XF instead of the parent XF (foreground/background).
void | setJustifyLast(short justify) Dunno.
void | setLeftBorderPaletteIdx(short border) set the palette index for the left border color
void | setLocked(boolean locked) set whether the cell is locked or not
void | setMergeCells(boolean merge) set whether to merge cells
void | setPaletteOptions(short options) set the palette options bitmask (see the individual bitsetter methods that reference this one)
void | setParentIndex(short parent) for cell XF types this is the parent style (usually 0/normal).
void | setReadingOrder(short order) set the reading order for far east versions (0 - Context, 1 - Left to right, 2 - right to left) - We could use some help with support for the far east.
void | setRightBorderPaletteIdx(short border) set the palette index for the right border color
void | setRotation(short rotation) set the degree of rotation.
void | setShrinkToFit(boolean shrink) set whether to shrink the text to fit
void | setTopBorderPaletteIdx(short border) set the palette index for the top border
void | setVerticalAlignment(short align) set the vertical alignment of text in the cell
void | setWrapText(boolean wrapped) set whether to wrap the text in the cell
void | setXFType(short type) set whether the cell is a cell or style XFRecord
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

NULL

public static final short NULL
See Also:
Constant Field Values

XF_STYLE

public static final short XF_STYLE
See Also:
Constant Field Values

XF_CELL

public static final short XF_CELL
See Also:
Constant Field Values

NONE

public static final short NONE
See Also:
Constant Field Values

THIN

public static final short THIN
See Also:
Constant Field Values

MEDIUM

public static final short MEDIUM
See Also:
Constant Field Values

DASHED

public static final short DASHED
See Also:
Constant Field Values

DOTTED

public static final short DOTTED
See Also:
Constant Field Values

THICK

public static final short THICK
See Also:
Constant Field Values

DOUBLE

public static final short DOUBLE
See Also:
Constant Field Values

HAIR

public static final short HAIR
See Also:
Constant Field Values

MEDIUM_DASHED

public static final short MEDIUM_DASHED
See Also:
Constant Field Values

DASH_DOT

public static final short DASH_DOT
See Also:
Constant Field Values

MEDIUM_DASH_DOT

public static final short MEDIUM_DASH_DOT
See Also:
Constant Field Values

DASH_DOT_DOT

public static final short DASH_DOT_DOT
See Also:
Constant Field Values

MEDIUM_DASH_DOT_DOT

public static final short MEDIUM_DASH_DOT_DOT
See Also:
Constant Field Values

SLANTED_DASH_DOT

public static final short SLANTED_DASH_DOT
See Also:
Constant Field Values

GENERAL

public static final short GENERAL
See Also:
Constant Field Values

LEFT

public static final short LEFT
See Also:
Constant Field Values

CENTER

public static final short CENTER
See Also:
Constant Field Values

RIGHT

public static final short RIGHT
See Also:
Constant Field Values

FILL

public static final short FILL
See Also:
Constant Field Values

JUSTIFY

public static final short JUSTIFY
See Also:
Constant Field Values

CENTER_SELECTION

public static final short CENTER_SELECTION
See Also:
Constant Field Values

VERTICAL_TOP

public static final short VERTICAL_TOP
See Also:
Constant Field Values

VERTICAL_CENTER

public static final short VERTICAL_CENTER
See Also:
Constant Field Values

VERTICAL_BOTTOM

public static final short VERTICAL_BOTTOM
See Also:
Constant Field Values

VERTICAL_JUSTIFY

public static final short VERTICAL_JUSTIFY
See Also:
Constant Field Values

NO_FILL

public static final short NO_FILL
See Also:
Constant Field Values

SOLID_FILL

public static final short SOLID_FILL
See Also:
Constant Field Values

FINE_DOTS

public static final short FINE_DOTS
See Also:
Constant Field Values

ALT_BARS

public static final short ALT_BARS
See Also:
Constant Field Values

SPARSE_DOTS

public static final short SPARSE_DOTS
See Also:
Constant Field Values

THICK_HORZ_BANDS

public static final short THICK_HORZ_BANDS
See Also:
Constant Field Values

THICK_VERT_BANDS

public static final short THICK_VERT_BANDS
See Also:
Constant Field Values

THICK_BACKWARD_DIAG

public static final short THICK_BACKWARD_DIAG
See Also:
Constant Field Values

THICK_FORWARD_DIAG

public static final short THICK_FORWARD_DIAG
See Also:
Constant Field Values

BIG_SPOTS

public static final short BIG_SPOTS
See Also:
Constant Field Values

BRICKS

public static final short BRICKS
See Also:
Constant Field Values

THIN_HORZ_BANDS

public static final short THIN_HORZ_BANDS
See Also:
Constant Field Values

THIN_VERT_BANDS

public static final short THIN_VERT_BANDS
See Also:
Constant Field Values

THIN_BACKWARD_DIAG

public static final short THIN_BACKWARD_DIAG
See Also:
Constant Field Values

THIN_FORWARD_DIAG

public static final short THIN_FORWARD_DIAG
See Also:
Constant Field Values

SQUARES

public static final short SQUARES
See Also:
Constant Field Values

DIAMONDS

public static final short DIAMONDS
See Also:
Constant Field Values
Constructor Detail

ExtendedFormatRecord

public ExtendedFormatRecord()
Constructor ExtendedFormatRecord

ExtendedFormatRecord

public ExtendedFormatRecord(RecordInputStream in)
Method Detail

setFontIndex

public void setFontIndex(short index)
set the index to the FONT record (which font to use 0 based)

Parameters:
index - to the font
See Also:
FontRecord

setFormatIndex

public void setFormatIndex(short index)
set the index to the Format record (which FORMAT to use 0-based)

Parameters:
index - to the format record
See Also:
FormatRecord

setCellOptions

public void setCellOptions(short options)
sets the options bitmask - you can also use corresponding option bit setters (see other methods that reference this one)

Parameters:
options - bitmask to set

setLocked

public void setLocked(boolean locked)
set whether the cell is locked or not

Parameters:
locked - - if the cell is locked
See Also:
setCellOptions(short)

setHidden

public void setHidden(boolean hidden)
set whether the cell is hidden or not

Parameters:
hidden - - if the cell is hidden
See Also:
setCellOptions(short)

setXFType

public void setXFType(short type)
set whether the cell is a cell or style XFRecord

Parameters:
type - - cell or style (0/1)
See Also:
XF_STYLE, XF_CELL, setCellOptions(short)

set123Prefix

public void set123Prefix(boolean prefix)
set some old holdover from lotus 123. Who cares, its all over for Lotus. RIP Lotus.

Parameters:
prefix - - the lotus thing to set.
See Also:
setCellOptions(short)

setParentIndex

public void setParentIndex(short parent)
for cell XF types this is the parent style (usually 0/normal). For style this should be NULL.

Parameters:
parent - index of parent XF
See Also:
NULL, setCellOptions(short)

setAlignmentOptions

public void setAlignmentOptions(short options)
set the alignment options bitmask. See corresponding bitsetter methods that reference this one.

Parameters:
options - - the bitmask to set

setAlignment

public void setAlignment(short align)
set the horizontal alignment of the cell.

Parameters:
align - - how to align the cell (see constants)
See Also:
GENERAL, LEFT, CENTER, RIGHT, FILL, JUSTIFY, CENTER_SELECTION, setAlignmentOptions(short)

setWrapText

public void setWrapText(boolean wrapped)
set whether to wrap the text in the cell

Parameters:
wrapped - - whether or not to wrap the cell text
See Also:
setAlignmentOptions(short)

setVerticalAlignment

public void setVerticalAlignment(short align)
set the vertical alignment of text in the cell

Parameters:
align - where to align the text
See Also:
VERTICAL_TOP, VERTICAL_CENTER, VERTICAL_BOTTOM, VERTICAL_JUSTIFY, setAlignmentOptions(short)

setJustifyLast

public void setJustifyLast(short justify)
Dunno. Docs just say this is for far east versions.. (I'm guessing it justifies for right-to-left read languages)

Parameters:
justify -
See Also:
setAlignmentOptions(short)

setRotation

public void setRotation(short rotation)
set the degree of rotation. (I've not actually seen this used anywhere)

Parameters:
rotation - the degree of rotation
See Also:
setAlignmentOptions(short)

setIndentionOptions

public void setIndentionOptions(short options)
set the indent options bitmask (see corresponding bitmask setters that reference this field)

Parameters:
options - bitmask to set.

setIndent

public void setIndent(short indent)
set indention (not sure of the units, think its spaces)

Parameters:
indent - - how far to indent the cell
See Also:
setIndentionOptions(short)

setShrinkToFit

public void setShrinkToFit(boolean shrink)
set whether to shrink the text to fit

Parameters:
shrink - - shrink to fit or not
See Also:
setIndentionOptions(short)

setMergeCells

public void setMergeCells(boolean merge)
set whether to merge cells

Parameters:
merge - - merge cells or not
See Also:
setIndentionOptions(short)

setReadingOrder

public void setReadingOrder(short order)
set the reading order for far east versions (0 - Context, 1 - Left to right, 2 - right to left) - We could use some help with support for the far east.

Parameters:
order - - the reading order (0,1,2)
See Also:
setIndentionOptions(short)

setIndentNotParentFormat

public void setIndentNotParentFormat(boolean parent)
set whether or not to use the format in this XF instead of the parent XF.

Parameters:
parent - - true if this XF has a different format value than its parent, false otherwise.
See Also:
setIndentionOptions(short)

setIndentNotParentFont

public void setIndentNotParentFont(boolean font)
set whether or not to use the font in this XF instead of the parent XF.

Parameters:
font - - true if this XF has a different font value than its parent, false otherwise.
See Also:
setIndentionOptions(short)

setIndentNotParentAlignment

public void setIndentNotParentAlignment(boolean alignment)
set whether or not to use the alignment in this XF instead of the parent XF.

Parameters:
alignment - true if this XF has a different alignment value than its parent, false otherwise.
See Also:
setIndentionOptions(short)

setIndentNotParentBorder

public void setIndentNotParentBorder(boolean border)
set whether or not to use the border in this XF instead of the parent XF.

Parameters:
border - - true if this XF has a different border value than its parent, false otherwise.
See Also:
setIndentionOptions(short)

setIndentNotParentPattern

public void setIndentNotParentPattern(boolean pattern)

Sets whether or not to use the pattern in this XF instead of the parent XF (foreground/background).

Parameters:
pattern - true if this XF has a different pattern value than its parent, false otherwise.
See Also:
setIndentionOptions(short)

setIndentNotParentCellOptions

public void setIndentNotParentCellOptions(boolean options)
set whether or not to use the locking/hidden in this XF instead of the parent XF.

Parameters:
options - true if this XF has a different locking or hidden value than its parent, false otherwise.
See Also:
setIndentionOptions(short)

setBorderOptions

public void setBorderOptions(short options)
set the border options bitmask (see the corresponding bitsetter methods that reference back to this one)

Parameters:
options - - the bit mask to set

setBorderLeft

public void setBorderLeft(short border)
set the borderline style for the left border

Parameters:
border - - type of border for the left side of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, setBorderOptions(short)

setBorderRight

public void setBorderRight(short border)
set the border line style for the right border

Parameters:
border - - type of border for the right side of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, setBorderOptions(short)

setBorderTop

public void setBorderTop(short border)
set the border line style for the top border

Parameters:
border - - type of border for the top of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, setBorderOptions(short)

setBorderBottom

public void setBorderBottom(short border)
set the border line style for the bottom border

Parameters:
border - - type of border for the bottom of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, setBorderOptions(short)

setPaletteOptions

public void setPaletteOptions(short options)
set the palette options bitmask (see the individual bitsetter methods that reference this one)

Parameters:
options - - the bitmask to set

setLeftBorderPaletteIdx

public void setLeftBorderPaletteIdx(short border)
set the palette index for the left border color

Parameters:
border - - palette index
See Also:
setPaletteOptions(short)

setRightBorderPaletteIdx

public void setRightBorderPaletteIdx(short border)
set the palette index for the right border color

Parameters:
border - - palette index
See Also:
setPaletteOptions(short)

setDiag

public void setDiag(short diag)
Not sure what this is for (maybe fill lines?) 1 = down, 2 = up, 3 = both, 0 for none..

Parameters:
diag - - set whatever it is that this is.
See Also:
setPaletteOptions(short)

setAdtlPaletteOptions

public void setAdtlPaletteOptions(short options)
set the additional palette options bitmask (see individual bitsetter methods that reference this method)

Parameters:
options - - bitmask to set

setTopBorderPaletteIdx

public void setTopBorderPaletteIdx(short border)
set the palette index for the top border

Parameters:
border - - palette index
See Also:
setAdtlPaletteOptions(short)

setBottomBorderPaletteIdx

public void setBottomBorderPaletteIdx(short border)
set the palette index for the bottom border

Parameters:
border - - palette index
See Also:
setAdtlPaletteOptions(short)

setAdtlDiag

public void setAdtlDiag(short diag)
set for diagonal borders? No idea (its a palette color for the other function we didn't know what was?)

Parameters:
diag - - the palette index?
See Also:
setAdtlPaletteOptions(short)

setAdtlDiagLineStyle

public void setAdtlDiagLineStyle(short diag)
set the diagonal border line style? Who the heck ever heard of a diagonal border?

Parameters:
diag - - the line style
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, setAdtlPaletteOptions(short)

setAdtlFillPattern

public void setAdtlFillPattern(short fill)
set the fill pattern

Parameters:
fill - - fill pattern??
See Also:
NO_FILL, SOLID_FILL, FINE_DOTS, ALT_BARS, SPARSE_DOTS, THICK_HORZ_BANDS, THICK_VERT_BANDS, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, BIG_SPOTS, BRICKS, THIN_HORZ_BANDS, THIN_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, SQUARES, DIAMONDS, setAdtlPaletteOptions(short)

setFillPaletteOptions

public void setFillPaletteOptions(short options)
set the fill palette options bitmask (see

Parameters:
options -

setFillForeground

public void setFillForeground(short color)
set the foreground palette color index

Parameters:
color - - palette index
See Also:
setFillPaletteOptions(short)

setFillBackground

public void setFillBackground(short color)
set the background palette color index

Parameters:
color - - palette index
See Also:
setFillPaletteOptions(short)

getFontIndex

public short getFontIndex()
get the index to the FONT record (which font to use 0 based)

Returns:
index to the font
See Also:
FontRecord

getFormatIndex

public short getFormatIndex()
get the index to the Format record (which FORMAT to use 0-based)

Returns:
index to the format record
See Also:
FormatRecord

getCellOptions

public short getCellOptions()
gets the options bitmask - you can also use corresponding option bit getters (see other methods that reference this one)

Returns:
options bitmask

isLocked

public boolean isLocked()
get whether the cell is locked or not

Returns:
locked - if the cell is locked
See Also:
getCellOptions()

isHidden

public boolean isHidden()
get whether the cell is hidden or not

Returns:
hidden - if the cell is hidden
See Also:
getCellOptions()

getXFType

public short getXFType()
get whether the cell is a cell or style XFRecord

Returns:
type - cell or style (0/1)
See Also:
XF_STYLE, XF_CELL, getCellOptions()

get123Prefix

public boolean get123Prefix()
get some old holdover from lotus 123. Who cares, its all over for Lotus. RIP Lotus.

Returns:
prefix - the lotus thing
See Also:
getCellOptions()

getParentIndex

public short getParentIndex()
for cell XF types this is the parent style (usually 0/normal). For style this should be NULL.

Returns:
index of parent XF
See Also:
NULL, getCellOptions()

getAlignmentOptions

public short getAlignmentOptions()
get the alignment options bitmask. See corresponding bitgetter methods that reference this one.

Returns:
options - the bitmask

getAlignment

public short getAlignment()
get the horizontal alignment of the cell.

Returns:
align - how to align the cell (see constants)
See Also:
GENERAL, LEFT, CENTER, RIGHT, FILL, JUSTIFY, CENTER_SELECTION, getAlignmentOptions()

getWrapText

public boolean getWrapText()
get whether to wrap the text in the cell

Returns:
wrapped - whether or not to wrap the cell text
See Also:
getAlignmentOptions()

getVerticalAlignment

public short getVerticalAlignment()
get the vertical alignment of text in the cell

Returns:
where to align the text
See Also:
VERTICAL_TOP, VERTICAL_CENTER, VERTICAL_BOTTOM, VERTICAL_JUSTIFY, getAlignmentOptions()

getJustifyLast

public short getJustifyLast()
Dunno. Docs just say this is for far east versions.. (I'm guessing it justifies for right-to-left read languages)

Returns:
justify
See Also:
getAlignmentOptions()

getRotation

public short getRotation()
get the degree of rotation. (I've not actually seen this used anywhere)

Returns:
rotation - the degree of rotation
See Also:
getAlignmentOptions()

getIndentionOptions

public short getIndentionOptions()
get the indent options bitmask (see corresponding bit getters that reference this field)

Returns:
options bitmask

getIndent

public short getIndent()
get indention (not sure of the units, think its spaces)

Returns:
indent - how far to indent the cell
See Also:
getIndentionOptions()

getShrinkToFit

public boolean getShrinkToFit()
get whether to shrink the text to fit

Returns:
shrink - shrink to fit or not
See Also:
getIndentionOptions()

getMergeCells

public boolean getMergeCells()
get whether to merge cells

Returns:
merge - merge cells or not
See Also:
getIndentionOptions()

getReadingOrder

public short getReadingOrder()
get the reading order for far east versions (0 - Context, 1 - Left to right, 2 - right to left) - We could use some help with support for the far east.

Returns:
order - the reading order (0,1,2)
See Also:
getIndentionOptions()

isIndentNotParentFormat

public boolean isIndentNotParentFormat()
get whether or not to use the format in this XF instead of the parent XF.

Returns:
parent - true if this XF has a different format value than its parent, false otherwise.
See Also:
getIndentionOptions()

isIndentNotParentFont

public boolean isIndentNotParentFont()
get whether or not to use the font in this XF instead of the parent XF.

Returns:
font - true if this XF has a different font value than its parent, false otherwise.
See Also:
getIndentionOptions()

isIndentNotParentAlignment

public boolean isIndentNotParentAlignment()
get whether or not to use the alignment in this XF instead of the parent XF.

Returns:
alignment true if this XF has a different alignment value than its parent, false otherwise.
See Also:
getIndentionOptions()

isIndentNotParentBorder

public boolean isIndentNotParentBorder()
get whether or not to use the border in this XF instead of the parent XF.

Returns:
border - true if this XF has a different border value than its parent, false otherwise.
See Also:
getIndentionOptions()

isIndentNotParentPattern

public boolean isIndentNotParentPattern()
get whether or not to use the pattern in this XF instead of the parent XF. (foregrount/background)

Returns:
pattern- true if this XF has a different pattern value than its parent, false otherwise.
See Also:
getIndentionOptions()

isIndentNotParentCellOptions

public boolean isIndentNotParentCellOptions()
get whether or not to use the locking/hidden in this XF instead of the parent XF.

Returns:
options- true if this XF has a different locking or hidden value than its parent, false otherwise.
See Also:
getIndentionOptions()

getBorderOptions

public short getBorderOptions()
get the border options bitmask (see the corresponding bit getter methods that reference back to this one)

Returns:
options - the bit mask to set

getBorderLeft

public short getBorderLeft()
get the borderline style for the left border

Returns:
border - type of border for the left side of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, getBorderOptions()

getBorderRight

public short getBorderRight()
get the borderline style for the right border

Returns:
border - type of border for the right side of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, getBorderOptions()

getBorderTop

public short getBorderTop()
get the borderline style for the top border

Returns:
border - type of border for the top of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, getBorderOptions()

getBorderBottom

public short getBorderBottom()
get the borderline style for the bottom border

Returns:
border - type of border for the bottom of the cell
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, getBorderOptions()

getPaletteOptions

public short getPaletteOptions()
get the palette options bitmask (see the individual bit getter methods that reference this one)

Returns:
options - the bitmask

getLeftBorderPaletteIdx

public short getLeftBorderPaletteIdx()
get the palette index for the left border color

Returns:
border - palette index
See Also:
getPaletteOptions()

getRightBorderPaletteIdx

public short getRightBorderPaletteIdx()
get the palette index for the right border color

Returns:
border - palette index
See Also:
getPaletteOptions()

getDiag

public short getDiag()
Not sure what this is for (maybe fill lines?) 1 = down, 2 = up, 3 = both, 0 for none..

Returns:
diag - whatever it is that this is.
See Also:
getPaletteOptions()

getAdtlPaletteOptions

public int getAdtlPaletteOptions()
get the additional palette options bitmask (see individual bit getter methods that reference this method)

Returns:
options - bitmask to set

getTopBorderPaletteIdx

public short getTopBorderPaletteIdx()
get the palette index for the top border

Returns:
border - palette index
See Also:
getAdtlPaletteOptions()

getBottomBorderPaletteIdx

public short getBottomBorderPaletteIdx()
get the palette index for the bottom border

Returns:
border - palette index
See Also:
getAdtlPaletteOptions()

getAdtlDiag

public short getAdtlDiag()
get for diagonal borders? No idea (its a palette color for the other function we didn't know what was?)

Returns:
diag - the palette index?
See Also:
getAdtlPaletteOptions()

getAdtlDiagLineStyle

public short getAdtlDiagLineStyle()
get the diagonal border line style? Who the heck ever heard of a diagonal border?

Returns:
diag - the line style
See Also:
NONE, THIN, MEDIUM, DASHED, DOTTED, THICK, DOUBLE, HAIR, MEDIUM_DASHED, DASH_DOT, MEDIUM_DASH_DOT, DASH_DOT_DOT, MEDIUM_DASH_DOT_DOT, SLANTED_DASH_DOT, getAdtlPaletteOptions()

getAdtlFillPattern

public short getAdtlFillPattern()
get the additional fill pattern

Returns:
fill - fill pattern??
See Also:
NO_FILL, SOLID_FILL, FINE_DOTS, ALT_BARS, SPARSE_DOTS, THICK_HORZ_BANDS, THICK_VERT_BANDS, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, BIG_SPOTS, BRICKS, THIN_HORZ_BANDS, THIN_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, SQUARES, DIAMONDS, getAdtlPaletteOptions()

getFillPaletteOptions

public short getFillPaletteOptions()
get the fill palette options bitmask (see indivdual bit getters that reference this method)

Returns:
options

getFillForeground

public short getFillForeground()
get the foreground palette color index

Returns:
color - palette index
See Also:
getFillPaletteOptions()

getFillBackground

public short getFillBackground()
get the background palette color index

Returns:
color palette index
See Also:
getFillPaletteOptions()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

cloneStyleFrom

public void cloneStyleFrom(ExtendedFormatRecord source)
Clones all the style information from another ExtendedFormatRecord, onto this one. This will then hold all the same style options. If The source ExtendedFormatRecord comes from a different Workbook, you will need to sort out the font and format indicies yourself!

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Will consider two different records with the same contents as equals, as the various indexes that matter are embedded in the records

Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExternalNameRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ExternalNameRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ExternalNameRecord

public final class ExternalNameRecord
extends StandardRecord

EXTERNALNAME (0x0023)

Author:
Josh Micich

Field Summary
static short sid
Constructor Summary
ExternalNameRecord()
ExternalNameRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getIx() If this is a local name, then this is the (1 based) index of the name of the Sheet this refers to, as defined in the preceeding SupBookRecord.
Ptg[] | getParsedExpression()
short | getSid() return the non static version of the id for this record.
java.lang.String | getText()
boolean | isAutomaticLink() For OLE and DDE, links can be either 'automatic' or 'manual'
boolean | isBuiltInName() Convenience Function to determine if the name is a built-in name
boolean | isIconifiedPictureLink()
boolean | isOLELink()
boolean | isPicureLink() only for OLE and DDE
boolean | isStdDocumentNameIdentifier() DDE links only.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setIx(short ix)
void | setParsedExpression(Ptg[] ptgs)
void | setText(java.lang.String str)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ExternalNameRecord

public ExternalNameRecord()

ExternalNameRecord

public ExternalNameRecord(RecordInputStream in)
Method Detail

isBuiltInName

public boolean isBuiltInName()
Convenience Function to determine if the name is a built-in name

isAutomaticLink

public boolean isAutomaticLink()
For OLE and DDE, links can be either 'automatic' or 'manual'

isPicureLink

public boolean isPicureLink()
only for OLE and DDE

isStdDocumentNameIdentifier

public boolean isStdDocumentNameIdentifier()
DDE links only. If true, this denotes the 'StdDocumentName'

isOLELink

public boolean isOLELink()

isIconifiedPictureLink

public boolean isIconifiedPictureLink()

getText

public java.lang.String getText()
Returns:
the standard String representation of this name

setText

public void setText(java.lang.String str)

getIx

public short getIx()
If this is a local name, then this is the (1 based) index of the name of the Sheet this refers to, as defined in the preceeding SupBookRecord. If it isn't a local name, then it must be zero.

setIx

public void setIx(short ix)

getParsedExpression

public Ptg[] getParsedExpression()

setParsedExpression

public void setParsedExpression(Ptg[] ptgs)

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExternSheetRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ExternSheetRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ExternSheetRecord

public class ExternSheetRecord
extends StandardRecord

EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

Author:
Libin Roman (Vista Portal LDT. Developer)

Field Summary
static short sid
Constructor Summary
ExternSheetRecord()
ExternSheetRecord(RecordInputStream in)
Method Summary
int | addRef(int extBookIndex, int firstSheetIndex, int lastSheetIndex) Add a zero-based reference to a SupBookRecord.
void | addREFRecord(org.apache.poi.hssf.record.ExternSheetRecord.RefSubRecord rec) adds REF struct (ExternSheetSubRecord)
static ExternSheetRecord | combine(ExternSheetRecord[] esrs)
int | findRefIndexFromExtBookIndex(int extBookIndex)
protected int | getDataSize()
int | getExtbookIndexFromRefIndex(int refIndex)
int | getFirstSheetIndexFromRefIndex(int extRefIndex)
int | getNumOfREFRecords() returns the number of REF Records, which is in model
int | getNumOfRefs()
int | getRefIxForSheet(int externalBookIndex, int sheetIndex)
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ExternSheetRecord

public ExternSheetRecord()

ExternSheetRecord

public ExternSheetRecord(RecordInputStream in)
Method Detail

getNumOfRefs

public int getNumOfRefs()
Returns:
number of REF structures

addREFRecord

public void addREFRecord(org.apache.poi.hssf.record.ExternSheetRecord.RefSubRecord rec)
adds REF struct (ExternSheetSubRecord)

Parameters:
rec - REF struct

getNumOfREFRecords

public int getNumOfREFRecords()
returns the number of REF Records, which is in model

Returns:
number of REF records

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
return the non static version of the id for this record.

Specified by:
getSid in class Record

getExtbookIndexFromRefIndex

public int getExtbookIndexFromRefIndex(int refIndex)

findRefIndexFromExtBookIndex

public int findRefIndexFromExtBookIndex(int extBookIndex)
Returns:
-1 if not found

getFirstSheetIndexFromRefIndex

public int getFirstSheetIndexFromRefIndex(int extRefIndex)

addRef

public int addRef(int extBookIndex,
                  int firstSheetIndex,
                  int lastSheetIndex)
Add a zero-based reference to a SupBookRecord.

If the type of the SupBook record is same-sheet referencing, Add-In referencing, DDE data source referencing, or OLE data source referencing, then no scope is specified and this value MUST be -2. Otherwise, the scope must be set as follows:

  1. -2 Workbook-level reference that applies to the entire workbook.
  2. -1 Sheet-level reference.
  3. >=0 Sheet-level reference. This specifies the first sheet in the reference.

    If the SupBook type is unused or external workbook referencing, then this value specifies the zero-based index of an external sheet name, see SupBookRecord.getSheetNames(). This referenced string specifies the name of the first sheet within the external workbook that is in scope. This sheet MUST be a worksheet or macro sheet.

    If the supporting link type is self-referencing, then this value specifies the zero-based index of a BoundSheetRecord record in the workbook stream that specifies the first sheet within the scope of this reference. This sheet MUST be a worksheet or a macro sheet.

Parameters:
firstSheetIndex - the scope, must be -2 for add-in references
lastSheetIndex - the scope, must be -2 for add-in references
Returns:
index of newly added ref

getRefIxForSheet

public int getRefIxForSheet(int externalBookIndex,
                            int sheetIndex)

combine

public static ExternSheetRecord combine(ExternSheetRecord[] esrs)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExtSSTRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ExtSSTRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.cont.ContinuableRecord
                extended by  org.apache.poi.hssf.record.ExtSSTRecord

public final class ExtSSTRecord
extends ContinuableRecord

Title: Extended Static String Table (0x00FF)

Description: This record is used for a quick lookup into the SST record. This record breaks the SST table into a set of buckets. The offsets to these buckets within the SST record are kept as well as the position relative to the start of the SST record. REFERENCE: PG 313 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at apache dot org)

Nested Class Summary
static class ExtSSTRecord.InfoSubRecord
Field Summary
static int | DEFAULT_BUCKET_SIZE
static int | MAX_BUCKETS
static short | sid
Constructor Summary
ExtSSTRecord()
ExtSSTRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
protected ExtSSTRecord.InfoSubRecord[] | getInfoSubRecords()
static int | getNumberOfInfoRecsForStrings(int numStrings)
static int | getRecordSizeForStrings(int numStrings) Given a number of strings (in the sst), returns the size of the extsst record
short | getSid() return the non static version of the id for this record.
void | serialize(ContinuableRecordOutput out) Serializes this record's content to the supplied data output. The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method.
void | setBucketOffsets(int[] bucketAbsoluteOffsets, int[] bucketRelativeOffsets)
void | setNumStringsPerBucket(short numStrings)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.cont.ContinuableRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

DEFAULT_BUCKET_SIZE

public static final int DEFAULT_BUCKET_SIZE
See Also:
Constant Field Values

MAX_BUCKETS

public static final int MAX_BUCKETS
See Also:
Constant Field Values
Constructor Detail

ExtSSTRecord

public ExtSSTRecord()

ExtSSTRecord

public ExtSSTRecord(RecordInputStream in)
Method Detail

setNumStringsPerBucket

public void setNumStringsPerBucket(short numStrings)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(ContinuableRecordOutput out)
Description copied from class: ContinuableRecord
Serializes this record's content to the supplied data output.
The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method. Simple data types can be written with the standard LittleEndianOutput methods. Methods from ContinuableRecordOutput can be used to serialize strings (with ContinueRecords being written as required). If necessary, implementors can explicitly start ContinueRecords (regardless of the amount of remaining space).

Specified by:
serialize in class ContinuableRecord
Parameters:
out - a data output stream

getDataSize

protected int getDataSize()

getInfoSubRecords

protected ExtSSTRecord.InfoSubRecord[] getInfoSubRecords()

getNumberOfInfoRecsForStrings

public static final int getNumberOfInfoRecsForStrings(int numStrings)

getRecordSizeForStrings

public static final int getRecordSizeForStrings(int numStrings)
Given a number of strings (in the sst), returns the size of the extsst record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

setBucketOffsets

public void setBucketOffsets(int[] bucketAbsoluteOffsets,
                             int[] bucketRelativeOffsets)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExtSSTRecord.InfoSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ExtSSTRecord.InfoSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord
Enclosing class:
ExtSSTRecord
public static final class ExtSSTRecord.InfoSubRecord
extends java.lang.Object

Field Summary
static int ENCODED_SIZE
Constructor Summary
ExtSSTRecord.InfoSubRecord(int streamPos, int bucketSstOffset)
Creates new ExtSSTInfoSubRecord
ExtSSTRecord.InfoSubRecord(RecordInputStream in)
Method Summary
int | getBucketSSTOffset()
int | getStreamPos()
void | serialize(LittleEndianOutput out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ENCODED_SIZE

public static final int ENCODED_SIZE
See Also:
Constant Field Values
Constructor Detail

ExtSSTRecord.InfoSubRecord

public ExtSSTRecord.InfoSubRecord(int streamPos,
                                  int bucketSstOffset)
Creates new ExtSSTInfoSubRecord

ExtSSTRecord.InfoSubRecord

public ExtSSTRecord.InfoSubRecord(RecordInputStream in)
Method Detail

getStreamPos

public int getStreamPos()

getBucketSSTOffset

public int getBucketSSTOffset()

serialize

public void serialize(LittleEndianOutput out)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeatHdrRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FeatHdrRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.FeatHdrRecord

public final class FeatHdrRecord
extends StandardRecord

Title: FeatHdr (Feature Header) Record

This record specifies common information for Shared Features, and specifies the beginning of a collection of records to define them. The collection of data (Globals Substream ABNF, macro sheet substream ABNF or worksheet substream ABNF) specifies Shared Feature data.

Field Summary
static int | SHAREDFEATURES_ISFFACTOID Specifies the smart tag type.
static int | SHAREDFEATURES_ISFFEC2 Specifies that formula errors should be ignored
static int | SHAREDFEATURES_ISFLIST Specifies the shared list type.
static int | SHAREDFEATURES_ISFPROTECTION Specifies the enhanced protection type.
static short | sid
Constructor Summary
FeatHdrRecord()
FeatHdrRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SHAREDFEATURES_ISFPROTECTION

public static final int SHAREDFEATURES_ISFPROTECTION
Specifies the enhanced protection type. Used to protect a shared workbook by restricting access to some areas of it

See Also:
Constant Field Values

SHAREDFEATURES_ISFFEC2

public static final int SHAREDFEATURES_ISFFEC2
Specifies that formula errors should be ignored

See Also:
Constant Field Values

SHAREDFEATURES_ISFFACTOID

public static final int SHAREDFEATURES_ISFFACTOID
Specifies the smart tag type. Recognises certain types of entries (proper names, dates/times etc) and flags them for action

See Also:
Constant Field Values

SHAREDFEATURES_ISFLIST

public static final int SHAREDFEATURES_ISFLIST
Specifies the shared list type. Used for a table within a sheet

See Also:
Constant Field Values

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FeatHdrRecord

public FeatHdrRecord()

FeatHdrRecord

public FeatHdrRecord(RecordInputStream in)
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FeatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.FeatRecord

public final class FeatRecord
extends StandardRecord

Title: Feat (Feature) Record

This record specifies Shared Features data. It is normally paired up with a FeatHdrRecord.

Field Summary
static short sid
Constructor Summary
FeatRecord()
FeatRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
long | getCbFeatData()
CellRangeAddress[] | getCellRefs()
protected int | getDataSize()
int | getIsf_sharedFeatureType()
SharedFeature | getSharedFeature()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCbFeatData(long cbFeatData)
void | setCellRefs(CellRangeAddress[] cellRefs)
void | setSharedFeature(SharedFeature feature)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FeatRecord

public FeatRecord()

FeatRecord

public FeatRecord(RecordInputStream in)
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getIsf_sharedFeatureType

public int getIsf_sharedFeatureType()

getCbFeatData

public long getCbFeatData()

setCbFeatData

public void setCbFeatData(long cbFeatData)

getCellRefs

public CellRangeAddress[] getCellRefs()

setCellRefs

public void setCellRefs(CellRangeAddress[] cellRefs)

getSharedFeature

public SharedFeature getSharedFeature()

setSharedFeature

public void setSharedFeature(SharedFeature feature)

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilePassRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FilePassRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.FilePassRecord

public final class FilePassRecord
extends StandardRecord

Title: File Pass Record (0x002F)

Description: Indicates that the record after this record are encrypted.

Author:
Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
FilePassRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
byte[] | getDocId()
byte[] | getSaltData()
byte[] | getSaltHash()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setDocId(byte[] docId)
void | setSaltData(byte[] saltData)
void | setSaltHash(byte[] saltHash)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FilePassRecord

public FilePassRecord(RecordInputStream in)
Method Detail

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getDocId

public byte[] getDocId()

setDocId

public void setDocId(byte[] docId)

getSaltData

public byte[] getSaltData()

setSaltData

public void setSaltData(byte[] saltData)

getSaltHash

public byte[] getSaltHash()

setSaltHash

public void setSaltHash(byte[] saltHash)

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileSharingRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FileSharingRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.FileSharingRecord

public final class FileSharingRecord
extends StandardRecord

Title: FILESHARING (0x005B)

Description: stores the encrypted readonly for a workbook (write protect) This functionality is accessed from the options dialog box available when performing 'Save As'.

REFERENCE: PG 314 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
FileSharingRecord()
FileSharingRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone() Clone this record.
protected int | getDataSize()
short | getPassword()
short | getReadOnly() get the readonly
short | getSid() return the non static version of the id for this record.
java.lang.String | getUsername()
static short | hashPassword(java.lang.String password)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setPassword(short password)
void | setReadOnly(short readonly) set the readonly flag
void | setUsername(java.lang.String username)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FileSharingRecord

public FileSharingRecord()

FileSharingRecord

public FileSharingRecord(RecordInputStream in)
Method Detail

hashPassword

public static short hashPassword(java.lang.String password)

setReadOnly

public void setReadOnly(short readonly)
set the readonly flag

Parameters:
readonly - 1 for true, not 1 for false

getReadOnly

public short getReadOnly()
get the readonly

Returns:
short representing if this is read only (1 = true)

setPassword

public void setPassword(short password)
Parameters:
password - hashed password

getPassword

public short getPassword()
Returns:
password hashed with hashPassword() (very lame)

getUsername

public java.lang.String getUsername()
Returns:
username of the user that created the file

setUsername

public void setUsername(java.lang.String username)
Parameters:
username - of the user that created the file

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Clone this record.

Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FnGroupCountRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FnGroupCountRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.FnGroupCountRecord

public final class FnGroupCountRecord
extends StandardRecord

Title: Function Group Count Record

Description: Number of built in function groups in the current version of the Spreadsheet (probably only used on Windoze)

REFERENCE: PG 315 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short | COUNT suggested default (14 dec)
static short | sid
Constructor Summary
FnGroupCountRecord()
FnGroupCountRecord(RecordInputStream in)
Method Summary
short | getCount() get the number of built-in functions
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCount(short count) set the number of built-in functions
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

COUNT

public static final short COUNT
suggested default (14 dec)

See Also:
Constant Field Values
Constructor Detail

FnGroupCountRecord

public FnGroupCountRecord()

FnGroupCountRecord

public FnGroupCountRecord(RecordInputStream in)
Method Detail

setCount

public void setCount(short count)
set the number of built-in functions

Parameters:
count - - number of functions

getCount

public short getCount()
get the number of built-in functions

Returns:
number of built-in functions

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FontRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.FontRecord

public final class FontRecord
extends StandardRecord

Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

Description: An element in the Font Table

REFERENCE: PG 315 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short | sid
static short | SS_NONE
static short | SS_SUB
static short | SS_SUPER
static byte | U_DOUBLE
static byte | U_DOUBLE_ACCOUNTING
static byte | U_NONE
static byte | U_SINGLE
static byte | U_SINGLE_ACCOUNTING
Constructor Summary
FontRecord()
FontRecord(RecordInputStream in)
Method Summary
void | cloneStyleFrom(FontRecord source) Clones all the font style information from another FontRecord, onto this one.
short | getAttributes() get the font attributes (see individual bit getters that reference this method)
short | getBoldWeight() get the bold weight for this font (100-1000dec or 0x64-0x3e8).
byte | getCharset() get the character set
short | getColorPaletteIndex() get the font's color palette index
protected int | getDataSize()
byte | getFamily() get the font family (TODO)
short | getFontHeight() gets the height of the font in 1/20th point units
java.lang.String | getFontName() get the name of the font
short | getSid() return the non static version of the id for this record.
short | getSuperSubScript() get the type of super or subscript for the font
byte | getUnderline() get the type of underlining for the font
int | hashCode()
boolean | isItalic() get whether the font is to be italics or not
boolean | isMacoutlined() whether to use the mac outline font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
boolean | isMacshadowed() whether to use the mac shado font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
boolean | isStruckout() get whether the font is to be stricken out or not
boolean | sameProperties(FontRecord other) Does this FontRecord have all the same font properties as the supplied FontRecord? Note that Object.equals(Object) will check for exact objects, while this will check for exact contents, because normally the font record's position makes a big difference too.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAttributes(short attributes) set the font attributes (see individual bit setters that reference this method)
void | setBoldWeight(short bw) set the bold weight for this font (100-1000dec or 0x64-0x3e8).
void | setCharset(byte charset) set the character set
void | setColorPaletteIndex(short cpi) set the font's color palette index
void | setFamily(byte f) set the font family (TODO)
void | setFontHeight(short height) sets the height of the font in 1/20th point units
void | setFontName(java.lang.String fn) set the name of the font
void | setItalic(boolean italics) set the font to be italics or not
void | setMacoutline(boolean mac) whether to use the mac outline font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
void | setMacshadow(boolean mac) whether to use the mac shado font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)
void | setStrikeout(boolean strike) set the font to be stricken out or not
void | setSuperSubScript(short sss) set the type of super or subscript for the font
void | setUnderline(byte u) set the type of underlining for the font
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

SS_NONE

public static final short SS_NONE
See Also:
Constant Field Values

SS_SUPER

public static final short SS_SUPER
See Also:
Constant Field Values

SS_SUB

public static final short SS_SUB
See Also:
Constant Field Values

U_NONE

public static final byte U_NONE
See Also:
Constant Field Values

U_SINGLE

public static final byte U_SINGLE
See Also:
Constant Field Values

U_DOUBLE

public static final byte U_DOUBLE
See Also:
Constant Field Values

U_SINGLE_ACCOUNTING

public static final byte U_SINGLE_ACCOUNTING
See Also:
Constant Field Values

U_DOUBLE_ACCOUNTING

public static final byte U_DOUBLE_ACCOUNTING
See Also:
Constant Field Values
Constructor Detail

FontRecord

public FontRecord()

FontRecord

public FontRecord(RecordInputStream in)
Method Detail

setFontHeight

public void setFontHeight(short height)
sets the height of the font in 1/20th point units

Parameters:
height - fontheight (in points/20)

setAttributes

public void setAttributes(short attributes)
set the font attributes (see individual bit setters that reference this method)

Parameters:
attributes - the bitmask to set

setItalic

public void setItalic(boolean italics)
set the font to be italics or not

Parameters:
italics - - whether the font is italics or not
See Also:
setAttributes(short)

setStrikeout

public void setStrikeout(boolean strike)
set the font to be stricken out or not

Parameters:
strike - - whether the font is stricken out or not
See Also:
setAttributes(short)

setMacoutline

public void setMacoutline(boolean mac)
whether to use the mac outline font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)

Parameters:
mac - - whether to do that mac font outline thing or not
See Also:
setAttributes(short)

setMacshadow

public void setMacshadow(boolean mac)
whether to use the mac shado font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)

Parameters:
mac - - whether to do that mac font shadow thing or not
See Also:
setAttributes(short)

setColorPaletteIndex

public void setColorPaletteIndex(short cpi)
set the font's color palette index

Parameters:
cpi - - font color index

setBoldWeight

public void setBoldWeight(short bw)
set the bold weight for this font (100-1000dec or 0x64-0x3e8). Default is 0x190 for normal and 0x2bc for bold

Parameters:
bw - - a number between 100-1000 for the fonts "boldness"

setSuperSubScript

public void setSuperSubScript(short sss)
set the type of super or subscript for the font

Parameters:
sss - super or subscript option
See Also:
SS_NONE, SS_SUPER, SS_SUB

setUnderline

public void setUnderline(byte u)
set the type of underlining for the font

Parameters:
u - super or subscript option
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

setFamily

public void setFamily(byte f)
set the font family (TODO)

Parameters:
f - family

setCharset

public void setCharset(byte charset)
set the character set

Parameters:
charset - - character set

setFontName

public void setFontName(java.lang.String fn)
set the name of the font

Parameters:
fn - - name of the font (i.e. "Arial")

getFontHeight

public short getFontHeight()
gets the height of the font in 1/20th point units

Returns:
fontheight (in points/20)

getAttributes

public short getAttributes()
get the font attributes (see individual bit getters that reference this method)

Returns:
attribute - the bitmask

isItalic

public boolean isItalic()
get whether the font is to be italics or not

Returns:
italics - whether the font is italics or not
See Also:
getAttributes()

isStruckout

public boolean isStruckout()
get whether the font is to be stricken out or not

Returns:
strike - whether the font is stricken out or not
See Also:
getAttributes()

isMacoutlined

public boolean isMacoutlined()
whether to use the mac outline font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)

Returns:
mac - whether to do that mac font outline thing or not
See Also:
getAttributes()

isMacshadowed

public boolean isMacshadowed()
whether to use the mac shado font style thing (mac only) - Some mac person should comment this instead of me doing it (since I have no idea)

Returns:
mac - whether to do that mac font shadow thing or not
See Also:
getAttributes()

getColorPaletteIndex

public short getColorPaletteIndex()
get the font's color palette index

Returns:
cpi - font color index

getBoldWeight

public short getBoldWeight()
get the bold weight for this font (100-1000dec or 0x64-0x3e8). Default is 0x190 for normal and 0x2bc for bold

Returns:
bw - a number between 100-1000 for the fonts "boldness"

getSuperSubScript

public short getSuperSubScript()
get the type of super or subscript for the font

Returns:
super or subscript option
See Also:
SS_NONE, SS_SUPER, SS_SUB

getUnderline

public byte getUnderline()
get the type of underlining for the font

Returns:
super or subscript option
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

getFamily

public byte getFamily()
get the font family (TODO)

Returns:
family

getCharset

public byte getCharset()
get the character set

Returns:
charset - character set

getFontName

public java.lang.String getFontName()
get the name of the font

Returns:
fn - name of the font (i.e. "Arial")

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

cloneStyleFrom

public void cloneStyleFrom(FontRecord source)
Clones all the font style information from another FontRecord, onto this one. This will then hold all the same font style options.

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

sameProperties

public boolean sameProperties(FontRecord other)
Does this FontRecord have all the same font properties as the supplied FontRecord? Note that Object.equals(Object) will check for exact objects, while this will check for exact contents, because normally the font record's position makes a big difference too.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FooterRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FooterRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.HeaderFooterBase
                    extended by  org.apache.poi.hssf.record.FooterRecord

public final class FooterRecord
extends HeaderFooterBase

Title: Footer Record (0x0015)

Description: Specifies the footer for a sheet

REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Shawn Laubach (slaubach at apache dot org) Modified 3/14/02, Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
FooterRecord(RecordInputStream in)
FooterRecord(java.lang.String text)
Method Summary
java.lang.Object | clone()
short | getSid() return the non static version of the id for this record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.HeaderFooterBase
getDataSize, getText, serialize, setText
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FooterRecord

public FooterRecord(java.lang.String text)

FooterRecord

public FooterRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.FormatRecord

public final class FormatRecord
extends StandardRecord

Title: Format Record (0x041E)

Description: describes a number format -- those goofy strings like $(#,###)

REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Shawn M. Laubach (slaubach at apache dot org)

Field Summary
static short sid
Constructor Summary
FormatRecord(int indexCode, java.lang.String fs)
FormatRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
java.lang.String | getFormatString() get the format string
int | getIndexCode() get the format index code (for built in formats)
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FormatRecord

public FormatRecord(int indexCode,
                    java.lang.String fs)

FormatRecord

public FormatRecord(RecordInputStream in)
Method Detail

getIndexCode

public int getIndexCode()
get the format index code (for built in formats)

Returns:
the format index code
See Also:
InternalWorkbook

getFormatString

public java.lang.String getFormatString()
get the format string

Returns:
the format string

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FormulaRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CellRecord
                    extended by  org.apache.poi.hssf.record.FormulaRecord
All Implemented Interfaces:
CellValueRecordInterface
public final class FormulaRecord
extends CellRecord

Formula Record (0x0006). REFERENCE: PG 317/444 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
FormulaRecord()
Creates new FormulaRecord
FormulaRecord(RecordInputStream ris)
Method Summary
protected  void appendValueText(java.lang.StringBuilder sb)
Append specific debug info (used by CellRecord.toString() for the value contained in this record.
 java.lang.Object clone()
 boolean getCachedBooleanValue()
 int getCachedErrorValue()
 int getCachedResultType()
 Formula getFormula()
 short getOptions()
get the option flags
 Ptg[] getParsedExpression()
protected  java.lang.String getRecordName()
Gets the debug info BIFF record type name (used by CellRecord.toString().
 short getSid()
return the non static version of the id for this record.
 double getValue()
get the calculated value of the formula
protected  int getValueDataSize()
 boolean hasCachedResultString()
 boolean isAlwaysCalc()
 boolean isCalcOnLoad()
 boolean isSharedFormula()
protected  void serializeValue(LittleEndianOutput out)
writes out the value data for this cell record
 void setAlwaysCalc(boolean flag)
 void setCachedResultBoolean(boolean value)
 void setCachedResultErrorCode(int errorCode)
 void setCachedResultTypeEmptyString()
 void setCachedResultTypeString()
 void setCalcOnLoad(boolean flag)
 void setOptions(short options)
set the option flags
 void setParsedExpression(Ptg[] ptgs)
 void setSharedFormula(boolean flag)
 void setValue(double value)
set the calculated value of the formula
Methods inherited from class org.apache.poi.hssf.record.CellRecord
copyBaseFields, getColumn, getDataSize, getRow, getXFIndex, serialize, setColumn, setRow, setXFIndex, toString
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FormulaRecord

public FormulaRecord()
Creates new FormulaRecord

FormulaRecord

public FormulaRecord(RecordInputStream ris)
Method Detail

setValue

public void setValue(double value)
set the calculated value of the formula

Parameters:
value - calculated value

setCachedResultTypeEmptyString

public void setCachedResultTypeEmptyString()

setCachedResultTypeString

public void setCachedResultTypeString()

setCachedResultErrorCode

public void setCachedResultErrorCode(int errorCode)

setCachedResultBoolean

public void setCachedResultBoolean(boolean value)

hasCachedResultString

public boolean hasCachedResultString()
Returns:
true if this FormulaRecord is followed by a StringRecord representing the cached text result of the formula evaluation.

getCachedResultType

public int getCachedResultType()

getCachedBooleanValue

public boolean getCachedBooleanValue()

getCachedErrorValue

public int getCachedErrorValue()

setOptions

public void setOptions(short options)
set the option flags

Parameters:
options - bitmask

getValue

public double getValue()
get the calculated value of the formula

Returns:
calculated value

getOptions

public short getOptions()
get the option flags

Returns:
bitmask

isSharedFormula

public boolean isSharedFormula()

setSharedFormula

public void setSharedFormula(boolean flag)

isAlwaysCalc

public boolean isAlwaysCalc()

setAlwaysCalc

public void setAlwaysCalc(boolean flag)

isCalcOnLoad

public boolean isCalcOnLoad()

setCalcOnLoad

public void setCalcOnLoad(boolean flag)

getParsedExpression

public Ptg[] getParsedExpression()
Returns:
the formula tokens. never null

getFormula

public Formula getFormula()

setParsedExpression

public void setParsedExpression(Ptg[] ptgs)

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getValueDataSize

protected int getValueDataSize()
Specified by:
getValueDataSize in class CellRecord
Returns:
the size (in bytes) of the value data for this cell record

serializeValue

protected void serializeValue(LittleEndianOutput out)
Description copied from class: CellRecord
writes out the value data for this cell record

Specified by:
serializeValue in class CellRecord

getRecordName

protected java.lang.String getRecordName()
Description copied from class: CellRecord
Gets the debug info BIFF record type name (used by CellRecord.toString().

Specified by:
getRecordName in class CellRecord

appendValueText

protected void appendValueText(java.lang.StringBuilder sb)
Description copied from class: CellRecord
Append specific debug info (used by CellRecord.toString() for the value contained in this record. Trailing new-line should not be appended (superclass does that).

Specified by:
appendValueText in class CellRecord

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FtCblsSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class FtCblsSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
        extended by  org.apache.poi.hssf.record.FtCblsSubRecord

public final class FtCblsSubRecord
extends SubRecord

This structure appears as part of an Obj record that represents a checkbox or radio button.

Author:
Yegor Kozlov

Field Summary
static short sid
Constructor Summary
FtCblsSubRecord()
Construct a new FtCblsSubRecord and fill its data with the default values
FtCblsSubRecord(LittleEndianInput in, int size)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid()
void | serialize(LittleEndianOutput out) Serialize the record data into the supplied array of bytes
java.lang.String | toString() Convert this record to string.
Methods inherited from class org.apache.poi.hssf.record.SubRecord
createSubRecord, isTerminating, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FtCblsSubRecord

public FtCblsSubRecord()
Construct a new FtCblsSubRecord and fill its data with the default values

FtCblsSubRecord

public FtCblsSubRecord(LittleEndianInput in,
                       int size)
Method Detail

toString

public java.lang.String toString()
Convert this record to string. Used by BiffViewer and other utilities.

Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Serialize the record data into the supplied array of bytes

Specified by:
serialize in class SubRecord
Parameters:
out - the stream to serialize into

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class SubRecord
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

getSid

public short getSid()
Returns:
id of this record.

clone

public java.lang.Object clone()
Specified by:
clone in class SubRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GridsetRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class GridsetRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.GridsetRecord

public final class GridsetRecord
extends StandardRecord

Title: Gridset Record.

Description: flag denoting whether the user specified that gridlines are used when printing.

REFERENCE: PG 320 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org), Jason Height (jheight at chariot dot net dot au)

Field Summary
short | field_1_gridset_flag
static short | sid
Constructor Summary
GridsetRecord()
GridsetRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getGridset() get whether the gridlines are shown during printing.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setGridset(boolean gridset) set whether gridlines are visible when printing
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

field_1_gridset_flag

public short field_1_gridset_flag
Constructor Detail

GridsetRecord

public GridsetRecord()

GridsetRecord

public GridsetRecord(RecordInputStream in)
Method Detail

setGridset

public void setGridset(boolean gridset)
set whether gridlines are visible when printing

Parameters:
gridset - - true if no gridlines are print, false if gridlines are not print.

getGridset

public boolean getGridset()
get whether the gridlines are shown during printing.

Returns:
gridset - true if gridlines are NOT printed, false if they are.

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GroupMarkerSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class GroupMarkerSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
        extended by  org.apache.poi.hssf.record.GroupMarkerSubRecord

public final class GroupMarkerSubRecord
extends SubRecord

ftGmo (0x0006)

The group marker record is used as a position holder for groups.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
GroupMarkerSubRecord()
GroupMarkerSubRecord(LittleEndianInput in, int size)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid()
void | serialize(LittleEndianOutput out)
java.lang.String | toString()
Methods inherited from class org.apache.poi.hssf.record.SubRecord
createSubRecord, isTerminating, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

GroupMarkerSubRecord

public GroupMarkerSubRecord()

GroupMarkerSubRecord

public GroupMarkerSubRecord(LittleEndianInput in,
                            int size)
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in class SubRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class SubRecord
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

getSid

public short getSid()

clone

public java.lang.Object clone()
Specified by:
clone in class SubRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GutsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class GutsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.GutsRecord

public final class GutsRecord
extends StandardRecord

Title: Guts Record

Description: Row/column gutter sizes

REFERENCE: PG 320 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
GutsRecord()
GutsRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getColLevelMax() get the maximum outline level for the col gutter.
protected int | getDataSize()
short | getLeftRowGutter() get the size of the gutter that appears at the left of the rows
short | getRowLevelMax() get the maximum outline level for the row gutter.
short | getSid() return the non static version of the id for this record.
short | getTopColGutter() get the size of the gutter that appears at the above the columns
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setColLevelMax(short max) set the maximum outline level for the col gutter.
void | setLeftRowGutter(short gut) set the size of the gutter that appears at the left of the rows
void | setRowLevelMax(short max) set the maximum outline level for the row gutter.
void | setTopColGutter(short gut) set the size of the gutter that appears at the above the columns
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

GutsRecord

public GutsRecord()

GutsRecord

public GutsRecord(RecordInputStream in)
Method Detail

setLeftRowGutter

public void setLeftRowGutter(short gut)
set the size of the gutter that appears at the left of the rows

Parameters:
gut - gutter size in screen units

setTopColGutter

public void setTopColGutter(short gut)
set the size of the gutter that appears at the above the columns

Parameters:
gut - gutter size in screen units

setRowLevelMax

public void setRowLevelMax(short max)
set the maximum outline level for the row gutter.

Parameters:
max - maximum outline level

setColLevelMax

public void setColLevelMax(short max)
set the maximum outline level for the col gutter.

Parameters:
max - maximum outline level

getLeftRowGutter

public short getLeftRowGutter()
get the size of the gutter that appears at the left of the rows

Returns:
gutter size in screen units

getTopColGutter

public short getTopColGutter()
get the size of the gutter that appears at the above the columns

Returns:
gutter size in screen units

getRowLevelMax

public short getRowLevelMax()
get the maximum outline level for the row gutter.

Returns:
maximum outline level

getColLevelMax

public short getColLevelMax()
get the maximum outline level for the col gutter.

Returns:
maximum outline level

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HCenterRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class HCenterRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.HCenterRecord

public final class HCenterRecord
extends StandardRecord

Title: HCenter record (0x0083)

Description: whether to center between horizontal margins

REFERENCE: PG 320 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
HCenterRecord()
HCenterRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getHCenter() get whether or not to horizonatally center this sheet.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setHCenter(boolean hc) set whether or not to horizonatally center this sheet.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

HCenterRecord

public HCenterRecord()

HCenterRecord

public HCenterRecord(RecordInputStream in)
Method Detail

setHCenter

public void setHCenter(boolean hc)
set whether or not to horizonatally center this sheet.

Parameters:
hc - center - t/f

getHCenter

public boolean getHCenter()
get whether or not to horizonatally center this sheet.

Returns:
center - t/f

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderFooterBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class HeaderFooterBase

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.HeaderFooterBase
Direct Known Subclasses:
FooterRecord, HeaderRecord
public abstract class HeaderFooterBase
extends StandardRecord

Common header/footer base class

Author:
Josh Micich

Constructor Summary
protected | HeaderFooterBase(RecordInputStream in)
protected | HeaderFooterBase(java.lang.String text)
Method Summary
protected int | getDataSize()
java.lang.String | getText()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setText(java.lang.String text) set the footer string
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, getSid, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HeaderFooterBase

protected HeaderFooterBase(java.lang.String text)

HeaderFooterBase

protected HeaderFooterBase(RecordInputStream in)
Method Detail

setText

public final void setText(java.lang.String text)
set the footer string

Parameters:
text - string to display

getText

public final java.lang.String getText()

serialize

public final void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected final int getDataSize()
Specified by:
getDataSize in class StandardRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderFooterRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class HeaderFooterRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.HeaderFooterRecord

public final class HeaderFooterRecord
extends StandardRecord

The HEADERFOOTER record stores information added in Office Excel 2007 for headers/footers.

Author:
Yegor Kozlov

Field Summary
static short sid
Constructor Summary
HeaderFooterRecord(byte[] data)
HeaderFooterRecord(RecordInputStream in)
construct a HeaderFooterRecord record.
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
byte[] | getGuid() If this header belongs to a specific sheet view , the sheet view?s GUID will be saved here.
short | getSid() return the non static version of the id for this record.
boolean | isCurrentSheet()
void | serialize(LittleEndianOutput out) spit the record out AS IS.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

HeaderFooterRecord

public HeaderFooterRecord(byte[] data)

HeaderFooterRecord

public HeaderFooterRecord(RecordInputStream in)
construct a HeaderFooterRecord record. No fields are interpreted and the record will be serialized in its original form more or less

Parameters:
in - the RecordInputstream to read the record from
Method Detail

serialize

public void serialize(LittleEndianOutput out)
spit the record out AS IS. no interpretation or identification

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getGuid

public byte[] getGuid()
If this header belongs to a specific sheet view , the sheet view?s GUID will be saved here.

If it is zero, it means the current sheet. Otherwise, this field MUST match the guid field of the preceding UserSViewBegin record.

Returns:
the sheet view?s GUID

isCurrentSheet

public boolean isCurrentSheet()
Returns:
whether this record belongs to the current sheet

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class HeaderRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.HeaderFooterBase
                    extended by  org.apache.poi.hssf.record.HeaderRecord

public final class HeaderRecord
extends HeaderFooterBase

Title: Header Record

Description: Specifies a header for a sheet

REFERENCE: PG 321 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Shawn Laubach (slaubach at apache dot org) Modified 3/14/02, Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
HeaderRecord(RecordInputStream in)
HeaderRecord(java.lang.String text)
Method Summary
java.lang.Object | clone()
short | getSid() return the non static version of the id for this record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.HeaderFooterBase
getDataSize, getText, serialize, setText
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

HeaderRecord

public HeaderRecord(java.lang.String text)

HeaderRecord

public HeaderRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HideObjRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class HideObjRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.HideObjRecord

public final class HideObjRecord
extends StandardRecord

Title: Hide Object Record

Description: flag defines whether to hide placeholders and object

REFERENCE: PG 321 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short | HIDE_ALL
static short | SHOW_ALL
static short | SHOW_PLACEHOLDERS
static short | sid
Constructor Summary
HideObjRecord()
HideObjRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getHideObj() get hide object options
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setHideObj(short hide) set hide object options
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

HIDE_ALL

public static final short HIDE_ALL
See Also:
Constant Field Values

SHOW_PLACEHOLDERS

public static final short SHOW_PLACEHOLDERS
See Also:
Constant Field Values

SHOW_ALL

public static final short SHOW_ALL
See Also:
Constant Field Values
Constructor Detail

HideObjRecord

public HideObjRecord()

HideObjRecord

public HideObjRecord(RecordInputStream in)
Method Detail

setHideObj

public void setHideObj(short hide)
set hide object options

Parameters:
hide - options
See Also:
HIDE_ALL, SHOW_PLACEHOLDERS, SHOW_ALL

getHideObj

public short getHideObj()
get hide object options

Returns:
hide options
See Also:
HIDE_ALL, SHOW_PLACEHOLDERS, SHOW_ALL

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HorizontalPageBreakRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class HorizontalPageBreakRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PageBreakRecord
                    extended by  org.apache.poi.hssf.record.HorizontalPageBreakRecord

public final class HorizontalPageBreakRecord
extends PageBreakRecord

HorizontalPageBreak (0x001B) record that stores page breaks at rows

Author:
Danny Mui (dmui at apache dot org)
See Also:
PageBreakRecord

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.PageBreakRecord
PageBreakRecord.Break
Field Summary
static short sid
Constructor Summary
HorizontalPageBreakRecord()
Creates an empty horizontal page break record
HorizontalPageBreakRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getSid() return the non static version of the id for this record.
Methods inherited from class org.apache.poi.hssf.record.PageBreakRecord
addBreak, getBreak, getBreaks, getBreaksIterator, getDataSize, getNumBreaks, isEmpty, removeBreak, serialize, toString
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

HorizontalPageBreakRecord

public HorizontalPageBreakRecord()
Creates an empty horizontal page break record

HorizontalPageBreakRecord

public HorizontalPageBreakRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HyperlinkRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class HyperlinkRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.HyperlinkRecord

public final class HyperlinkRecord
extends StandardRecord

The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format. Supports only external links for now (eg http://)

Author:
Mark Hissink Muller
Field Summary
static short sid
Constructor Summary
HyperlinkRecord()
Create a new hyperlink
HyperlinkRecord(RecordInputStream in)
Method Summary
 java.lang.Object clone()
 java.lang.String getAddress()
Hyperlink address.
protected  int getDataSize()
 int getFileOptions()
Options for a file link
 int getFirstColumn()
 int getFirstRow()
 java.lang.String getLabel()
Return text label for this hyperlink
 int getLabelOptions()
Label options
 int getLastColumn()
 int getLastRow()
 java.lang.String getShortFilename()
 short getSid()
return the non static version of the id for this record.
 java.lang.String getTargetFrame()
 java.lang.String getTextMark()
 boolean isDocumentLink()
Based on the link options, is this a document?
 boolean isFileLink()
Based on the link options, is this a file?
 boolean isUrlLink()
Based on the link options, is this a url?
 void newDocumentLink()
Initialize a new document link
 void newFileLink()
Initialize a new file link
 void newUrlLink()
Initialize a new url link
 void serialize(LittleEndianOutput out)
Write the data content of this BIFF record.
 void setAddress(java.lang.String address)
Hyperlink address.
 void setFirstColumn(int col)
Set the first column (zero-based)of the range that contains this hyperlink
 void setFirstRow(int col)
Set the first row (zero-based)of the range that contains this hyperlink
 void setLabel(java.lang.String label)
Sets text label for this hyperlink
 void setLastColumn(int col)
Set the last column (zero-based)of the range that contains this hyperlink
 void setLastRow(int col)
Set the last row (zero-based)of the range that contains this hyperlink
 void setShortFilename(java.lang.String shortFilename)
 void setTextMark(java.lang.String textMark)
 java.lang.String toString()
get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

HyperlinkRecord

public HyperlinkRecord()
Create a new hyperlink

HyperlinkRecord

public HyperlinkRecord(RecordInputStream in)
Method Detail

getFirstColumn

public int getFirstColumn()
Returns:
the 0-based column of the first cell that contains this hyperlink

setFirstColumn

public void setFirstColumn(int col)
Set the first column (zero-based)of the range that contains this hyperlink

getLastColumn

public int getLastColumn()
Returns:
the 0-based column of the last cell that contains this hyperlink

setLastColumn

public void setLastColumn(int col)
Set the last column (zero-based)of the range that contains this hyperlink

getFirstRow

public int getFirstRow()
Returns:
the 0-based row of the first cell that contains this hyperlink

setFirstRow

public void setFirstRow(int col)
Set the first row (zero-based)of the range that contains this hyperlink

getLastRow

public int getLastRow()
Returns:
the 0-based row of the last cell that contains this hyperlink

setLastRow

public void setLastRow(int col)
Set the last row (zero-based)of the range that contains this hyperlink

getLabel

public java.lang.String getLabel()
Return text label for this hyperlink

Returns:
text to display

setLabel

public void setLabel(java.lang.String label)
Sets text label for this hyperlink

Parameters:
label - text label for this hyperlink

getTargetFrame

public java.lang.String getTargetFrame()

getAddress

public java.lang.String getAddress()
Hyperlink address. Depending on the hyperlink type it can be URL, e-mail, path to a file, etc.

Returns:
the address of this hyperlink

setAddress

public void setAddress(java.lang.String address)
Hyperlink address. Depending on the hyperlink type it can be URL, e-mail, path to a file, etc.

Parameters:
address - the address of this hyperlink

getShortFilename

public java.lang.String getShortFilename()

setShortFilename

public void setShortFilename(java.lang.String shortFilename)

getTextMark

public java.lang.String getTextMark()

setTextMark

public void setTextMark(java.lang.String textMark)

getLabelOptions

public int getLabelOptions()
Label options

getFileOptions

public int getFileOptions()
Options for a file link

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

isUrlLink

public boolean isUrlLink()
Based on the link options, is this a url?

isFileLink

public boolean isFileLink()
Based on the link options, is this a file?

isDocumentLink

public boolean isDocumentLink()
Based on the link options, is this a document?

newUrlLink

public void newUrlLink()
Initialize a new url link

newFileLink

public void newFileLink()
Initialize a new file link

newDocumentLink

public void newDocumentLink()
Initialize a new document link

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class IndexRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.IndexRecord

public class IndexRecord
extends StandardRecord

Title: Index Record (0x020B)

Description: Occurs right after BOF, tells you where the DBCELL records are for a sheet Important for locating cells

NOT USED IN THIS RELEASE REFERENCE: PG 323 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
IndexRecord()
IndexRecord(RecordInputStream in)
Method Summary
void | addDbcell(int cell)
java.lang.Object | clone()
protected int | getDataSize()
int | getDbcellAt(int cellnum)
int | getFirstRow()
int | getLastRowAdd1()
int | getNumDbcells()
static int | getRecordSizeForBlockCount(int blockCount)
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setDbcell(int cell, int value)
void | setFirstRow(int row)
void | setLastRowAdd1(int row)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

IndexRecord

public IndexRecord()

IndexRecord

public IndexRecord(RecordInputStream in)
Method Detail

setFirstRow

public void setFirstRow(int row)

setLastRowAdd1

public void setLastRowAdd1(int row)

addDbcell

public void addDbcell(int cell)

setDbcell

public void setDbcell(int cell,
                      int value)

getFirstRow

public int getFirstRow()

getLastRowAdd1

public int getLastRowAdd1()

getNumDbcells

public int getNumDbcells()

getDbcellAt

public int getDbcellAt(int cellnum)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getRecordSizeForBlockCount

public static int getRecordSizeForBlockCount(int blockCount)
Returns:
the size of an INdexRecord when it needs to index the specified number of blocks

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterfaceEndRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class InterfaceEndRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.InterfaceEndRecord

public final class InterfaceEndRecord
extends StandardRecord

Title: Interface End Record (0x00E2)

Description: Shows where the Interface Records end (MMS) (has no fields)

REFERENCE: PG 324 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static InterfaceEndRecord | instance
static short | sid
Method Summary
static Record | create(RecordInputStream in)
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

instance

public static final InterfaceEndRecord instance
Method Detail

create

public static Record create(RecordInputStream in)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterfaceHdrRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class InterfaceHdrRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.InterfaceHdrRecord

public final class InterfaceHdrRecord
extends StandardRecord

Title: Interface Header Record (0x00E1)

Description: Defines the beginning of Interface records (MMS)

REFERENCE: PG 324 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static int | CODEPAGE suggested (and probably correct) default
static short | sid
Constructor Summary
InterfaceHdrRecord(int codePage)
InterfaceHdrRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

CODEPAGE

public static final int CODEPAGE
suggested (and probably correct) default

See Also:
Constant Field Values
Constructor Detail

InterfaceHdrRecord

public InterfaceHdrRecord(int codePage)

InterfaceHdrRecord

public InterfaceHdrRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IterationRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class IterationRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.IterationRecord

public final class IterationRecord
extends StandardRecord

Title: Iteration Record (0x0011)

Description: Tells whether to iterate over forumla calculations or not (if a formula is dependant upon another formula's result) (odd feature for something that can only have 32 elements in a formula!)

REFERENCE: PG 325 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
IterationRecord(boolean iterateOn)
IterationRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getIteration() get whether or not to iterate for calculations
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setIteration(boolean iterate) set whether or not to iterate for calculations
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

IterationRecord

public IterationRecord(boolean iterateOn)

IterationRecord

public IterationRecord(RecordInputStream in)
Method Detail

setIteration

public void setIteration(boolean iterate)
set whether or not to iterate for calculations

Parameters:
iterate - or not

getIteration

public boolean getIteration()
get whether or not to iterate for calculations

Returns:
whether iterative calculations are turned off or on

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class LabelRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.LabelRecord
All Implemented Interfaces:
CellValueRecordInterface
public final class LabelRecord
extends Record
implements CellValueRecordInterface

Label Record (0x0204) - read only support for strings stored directly in the cell.. Don't use this (except to read), use LabelSST instead

REFERENCE: PG 325 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)
See Also:
LabelSSTRecord

Field Summary
static short sid
Constructor Summary
LabelRecord()
Creates new LabelRecord
LabelRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getColumn()
int | getRecordSize() gives the current serialized size of the record.
int | getRow()
short | getSid() return the non static version of the id for this record.
short | getStringLength() get the number of characters this string contains
java.lang.String | getValue() get the value
short | getXFIndex()
boolean | isUnCompressedUnicode() is this uncompressed unicode (16bit)? Or just 8-bit compressed?
int | serialize(int offset, byte[] data) THROWS A RUNTIME EXCEPTION..
void | setColumn(short col) NO-OP!
void | setRow(int row) NO-OP!
void | setXFIndex(short xf) no op!
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

LabelRecord

public LabelRecord()
Creates new LabelRecord

LabelRecord

public LabelRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

getRow

public int getRow()
Specified by:
getRow in interface CellValueRecordInterface
Returns:
the row this cell occurs on

getColumn

public short getColumn()
Specified by:
getColumn in interface CellValueRecordInterface
Returns:
the column this cell defines within the row

getXFIndex

public short getXFIndex()
Specified by:
getXFIndex in interface CellValueRecordInterface

getStringLength

public short getStringLength()
get the number of characters this string contains

Returns:
number of characters

isUnCompressedUnicode

public boolean isUnCompressedUnicode()
is this uncompressed unicode (16bit)? Or just 8-bit compressed?

Returns:
isUnicode - True for 16bit- false for 8bit

getValue

public java.lang.String getValue()
get the value

Returns:
the text string
See Also:
getStringLength()

serialize

public int serialize(int offset,
                     byte[] data)
THROWS A RUNTIME EXCEPTION.. USE LABELSSTRecords. YOU HAVE NO REASON to use LABELRecord!!

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getRecordSize

public int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

setColumn

public void setColumn(short col)
NO-OP!

Specified by:
setColumn in interface CellValueRecordInterface
Parameters:
col - the column this cell defines

setRow

public void setRow(int row)
NO-OP!

Specified by:
setRow in interface CellValueRecordInterface
Parameters:
row - the row this cell occurs within

setXFIndex

public void setXFIndex(short xf)
no op!

Specified by:
setXFIndex in interface CellValueRecordInterface

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelSSTRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class LabelSSTRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CellRecord
                    extended by  org.apache.poi.hssf.record.LabelSSTRecord
All Implemented Interfaces:
CellValueRecordInterface
public final class LabelSSTRecord
extends CellRecord

Title: Label SST Record

Description: Refers to a string in the shared string table and is a column value.

REFERENCE: PG 325 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
LabelSSTRecord()
LabelSSTRecord(RecordInputStream in)
Method Summary
protected  void appendValueText(java.lang.StringBuilder sb)
Append specific debug info (used by CellRecord.toString() for the value contained in this record.
 java.lang.Object clone()
protected  java.lang.String getRecordName()
Gets the debug info BIFF record type name (used by CellRecord.toString().
 short getSid()
return the non static version of the id for this record.
 int getSSTIndex()
get the index to the string in the SSTRecord
protected  int getValueDataSize()
protected  void serializeValue(LittleEndianOutput out)
writes out the value data for this cell record
 void setSSTIndex(int index)
set the index to the string in the SSTRecord
Methods inherited from class org.apache.poi.hssf.record.CellRecord
copyBaseFields, getColumn, getDataSize, getRow, getXFIndex, serialize, setColumn, setRow, setXFIndex, toString
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

LabelSSTRecord

public LabelSSTRecord()

LabelSSTRecord

public LabelSSTRecord(RecordInputStream in)
Method Detail

setSSTIndex

public void setSSTIndex(int index)
set the index to the string in the SSTRecord

Parameters:
index - - of string in the SST Table
See Also:
SSTRecord

getSSTIndex

public int getSSTIndex()
get the index to the string in the SSTRecord

Returns:
index of string in the SST Table
See Also:
SSTRecord

getRecordName

protected java.lang.String getRecordName()
Description copied from class: CellRecord
Gets the debug info BIFF record type name (used by CellRecord.toString().

Specified by:
getRecordName in class CellRecord

appendValueText

protected void appendValueText(java.lang.StringBuilder sb)
Description copied from class: CellRecord
Append specific debug info (used by CellRecord.toString() for the value contained in this record. Trailing new-line should not be appended (superclass does that).

Specified by:
appendValueText in class CellRecord

serializeValue

protected void serializeValue(LittleEndianOutput out)
Description copied from class: CellRecord
writes out the value data for this cell record

Specified by:
serializeValue in class CellRecord

getValueDataSize

protected int getValueDataSize()
Specified by:
getValueDataSize in class CellRecord
Returns:
the size (in bytes) of the value data for this cell record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LbsDataSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class LbsDataSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
        extended by  org.apache.poi.hssf.record.LbsDataSubRecord

public class LbsDataSubRecord
extends SubRecord

This structure specifies the properties of a list or drop-down list embedded object in a sheet.

Nested Class Summary
static class LbsDataSubRecord.LbsDropData
This structure specifies properties of the dropdown list control
Field Summary
static int sid
Constructor Summary
LbsDataSubRecord(LittleEndianInput in, int cbFContinued, int cmoOt)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
Ptg | getFormula()
int | getNumberOfItems()
boolean | isTerminating() Wether this record terminates the sub-record stream.
static LbsDataSubRecord | newAutoFilterInstance()
void | serialize(LittleEndianOutput out)
java.lang.String | toString()
Methods inherited from class org.apache.poi.hssf.record.SubRecord
createSubRecord, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final int sid
See Also:
Constant Field Values
Constructor Detail

LbsDataSubRecord

public LbsDataSubRecord(LittleEndianInput in,
                        int cbFContinued,
                        int cmoOt)
Parameters:
in - the stream to read data from
cbFContinued - the seconf short in the record header
cmoOt - the containing Obj's CommonObjectDataSubRecord.field_1_objectType
Method Detail

newAutoFilterInstance

public static LbsDataSubRecord newAutoFilterInstance()
Returns:
a new instance of LbsDataSubRecord to construct auto-filters
See Also:
ComboboxShape.createObjRecord(org.apache.poi.hssf.usermodel.HSSFSimpleShape, int)

isTerminating

public boolean isTerminating()
Description copied from class: SubRecord
Wether this record terminates the sub-record stream. There are two cases when this method must be overridden and return true - EndSubRecord (sid = 0x00) - LbsDataSubRecord (sid = 0x12)

Overrides:
isTerminating in class SubRecord
Returns:
true as LbsDataSubRecord is always the last sub-record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class SubRecord
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in class SubRecord

clone

public java.lang.Object clone()
Specified by:
clone in class SubRecord

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getFormula

public Ptg getFormula()
Returns:
the formula that specifies the range of cell values that are the items in this list.

getNumberOfItems

public int getNumberOfItems()
Returns:
the number of items in the list
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LbsDataSubRecord.LbsDropData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class LbsDataSubRecord.LbsDropData

java.lang.Object
    extended by  org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
Enclosing class:
LbsDataSubRecord
public static class LbsDataSubRecord.LbsDropData
extends java.lang.Object

This structure specifies properties of the dropdown list control

Field Summary
static int | STYLE_COMBO_DROPDOWN Combo dropdown control
static int | STYLE_COMBO_EDIT_DROPDOWN Combo Edit dropdown control
static int | STYLE_COMBO_SIMPLE_DROPDOWN Simple dropdown control (just the dropdown button)
Constructor Summary
LbsDataSubRecord.LbsDropData()
LbsDataSubRecord.LbsDropData(LittleEndianInput in)
Method Summary
int | getDataSize()
void | serialize(LittleEndianOutput out)
void | setNumLines(int num) Set the number of lines to be displayed in the dropdown.
void | setStyle(int style) Set the style of this dropdown.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

STYLE_COMBO_DROPDOWN

public static int STYLE_COMBO_DROPDOWN
Combo dropdown control

STYLE_COMBO_EDIT_DROPDOWN

public static int STYLE_COMBO_EDIT_DROPDOWN
Combo Edit dropdown control

STYLE_COMBO_SIMPLE_DROPDOWN

public static int STYLE_COMBO_SIMPLE_DROPDOWN
Simple dropdown control (just the dropdown button)

Constructor Detail

LbsDataSubRecord.LbsDropData

public LbsDataSubRecord.LbsDropData()

LbsDataSubRecord.LbsDropData

public LbsDataSubRecord.LbsDropData(LittleEndianInput in)
Method Detail

setStyle

public void setStyle(int style)
Set the style of this dropdown. Possible values:

0 Combo dropdown control 1 Combo Edit dropdown control 2 Simple dropdown control (just the dropdown button)

setNumLines

public void setNumLines(int num)
Set the number of lines to be displayed in the dropdown.

serialize

public void serialize(LittleEndianOutput out)

getDataSize

public int getDataSize()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LeftMarginRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class LeftMarginRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.LeftMarginRecord
All Implemented Interfaces:
Margin
public final class LeftMarginRecord
extends StandardRecord
implements Margin

Record for the left margin.

Author:
Shawn Laubach (slaubach at apache dot org)

Field Summary
static short sid
Constructor Summary
LeftMarginRecord()
LeftMarginRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
double | getMargin() Get the margin field for the LeftMargin record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setMargin(double field_1_margin) Set the margin field for the LeftMargin record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

LeftMarginRecord

public LeftMarginRecord()

LeftMarginRecord

public LeftMarginRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getMargin

public double getMargin()
Get the margin field for the LeftMargin record.

Specified by:
getMargin in interface Margin

setMargin

public void setMargin(double field_1_margin)
Set the margin field for the LeftMargin record.

Specified by:
setMargin in interface Margin

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Margin

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Interface Margin

All Known Implementing Classes:
BottomMarginRecord, LeftMarginRecord, RightMarginRecord, TopMarginRecord
public interface Margin

The margin interface is a parent used to define left, right, top and bottom margins. This allows much of the code to be generic when it comes to handling margins.

Author:
Shawn Laubach (slaubach at apache dot org)

Method Summary
double | getMargin() Get the margin field for the Margin.
void | setMargin(double field_1_margin) Set the margin field for the Margin.

Method Detail

getMargin

double getMargin()
Get the margin field for the Margin.

setMargin

void setMargin(double field_1_margin)
Set the margin field for the Margin.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MergeCellsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class MergeCellsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.MergeCellsRecord

public final class MergeCellsRecord
extends StandardRecord

Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
MergeCellsRecord(CellRangeAddress[] regions, int startIndex, int numberOfRegions)
MergeCellsRecord(RecordInputStream in)
Constructs a MergedCellsRecord and sets its fields appropriately
Method Summary
java.lang.Object | clone()
CellRangeAddress | getAreaAt(int index)
protected int | getDataSize()
short | getNumAreas() get the number of merged areas.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

MergeCellsRecord

public MergeCellsRecord(CellRangeAddress[] regions,
                        int startIndex,
                        int numberOfRegions)

MergeCellsRecord

public MergeCellsRecord(RecordInputStream in)
Constructs a MergedCellsRecord and sets its fields appropriately

Parameters:
in - the RecordInputstream to read the record from
Method Detail

getNumAreas

public short getNumAreas()
get the number of merged areas. If this drops down to 0 you should just go ahead and delete the record.

Returns:
number of areas

getAreaAt

public CellRangeAddress getAreaAt(int index)
Returns:
MergedRegion at the given index representing the area that is Merged (r1,c1 - r2,c2)

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MMSRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class MMSRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.MMSRecord

public final class MMSRecord
extends StandardRecord

Title: MMS Record

Description: defines how many add menu and del menu options are stored in the file. Should always be set to 0 for HSSF workbooks

REFERENCE: PG 328 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
MMSRecord()
MMSRecord(RecordInputStream in)
Method Summary
byte | getAddMenuCount() get number of add menu options (should be 0)
protected int | getDataSize()
byte | getDelMenuCount() get number of add del options (should be 0)
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAddMenuCount(byte am) set number of add menu options (set to 0)
void | setDelMenuCount(byte dm) set number of del menu options (set to 0)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

MMSRecord

public MMSRecord()

MMSRecord

public MMSRecord(RecordInputStream in)
Method Detail

setAddMenuCount

public void setAddMenuCount(byte am)
set number of add menu options (set to 0)

Parameters:
am - number of add menu options

setDelMenuCount

public void setDelMenuCount(byte dm)
set number of del menu options (set to 0)

Parameters:
dm - number of del menu options

getAddMenuCount

public byte getAddMenuCount()
get number of add menu options (should be 0)

Returns:
number of add menu options

getDelMenuCount

public byte getDelMenuCount()
get number of add del options (should be 0)

Returns:
number of add menu options

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MulBlankRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class MulBlankRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.MulBlankRecord

public final class MulBlankRecord
extends StandardRecord

Title: Multiple Blank cell record(0x00BE)

Description: Represents a set of columns in a row with no value but with styling.

REFERENCE: PG 329 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org)
See Also:
BlankRecord

Field Summary
static short sid
Constructor Summary
MulBlankRecord(int row, int firstCol, short[] xfs)
MulBlankRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
int | getFirstColumn()
int | getLastColumn()
int | getNumColumns() get the number of columns this contains (last-first +1)
int | getRow()
short | getSid() return the non static version of the id for this record.
short | getXFAt(int coffset) returns the xf index for column (coffset = column - field_2_first_col)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

MulBlankRecord

public MulBlankRecord(int row,
                      int firstCol,
                      short[] xfs)

MulBlankRecord

public MulBlankRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

getRow

public int getRow()
Returns:
the row number of the cells this represents

getFirstColumn

public int getFirstColumn()
Returns:
starting column (first cell this holds in the row). Zero based

getLastColumn

public int getLastColumn()
Returns:
ending column (last cell this holds in the row). Zero based

getNumColumns

public int getNumColumns()
get the number of columns this contains (last-first +1)

Returns:
number of columns (last - first +1)

getXFAt

public short getXFAt(int coffset)
returns the xf index for column (coffset = column - field_2_first_col)

Parameters:
coffset - the column (coffset = column - field_2_first_col)
Returns:
the XF index for the column

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MulRKRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class MulRKRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.MulRKRecord

public final class MulRKRecord
extends StandardRecord

MULRK (0x00BD)

Used to store multiple RK numbers on a row. 1 MulRk = Multiple Cell values. HSSF just converts this into multiple NUMBER records. READ-ONLY SUPPORT!

REFERENCE: PG 330 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
MulRKRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getFirstColumn() starting column (first cell this holds in the row)
short | getLastColumn() ending column (last cell this holds in the row)
int | getNumColumns() get the number of columns this contains (last-first +1)
double | getRKNumberAt(int coffset) returns the rk number for column (coffset = column - field_2_first_col)
int | getRow()
short | getSid() return the non static version of the id for this record.
short | getXFAt(int coffset) returns the xf index for column (coffset = column - field_2_first_col)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

MulRKRecord

public MulRKRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

getRow

public int getRow()

getFirstColumn

public short getFirstColumn()
starting column (first cell this holds in the row)

Returns:
first column number

getLastColumn

public short getLastColumn()
ending column (last cell this holds in the row)

Returns:
first column number

getNumColumns

public int getNumColumns()
get the number of columns this contains (last-first +1)

Returns:
number of columns (last - first +1)

getXFAt

public short getXFAt(int coffset)
returns the xf index for column (coffset = column - field_2_first_col)

Returns:
the XF index for the column

getRKNumberAt

public double getRKNumberAt(int coffset)
returns the rk number for column (coffset = column - field_2_first_col)

Returns:
the value (decoded into a double)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NameCommentRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class NameCommentRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.NameCommentRecord

public final class NameCommentRecord
extends StandardRecord

Title: NAMECMT Record (0x0894)

Description: Defines a comment associated with a specified name.

REFERENCE:

Author:
Andrew Shirley (aks at corefiling.co.uk)

Field Summary
static short sid
Constructor Summary
NameCommentRecord(RecordInputStream ris)
NameCommentRecord(java.lang.String name, java.lang.String comment)
Method Summary
java.lang.String | getCommentText()
protected int | getDataSize()
java.lang.String | getNameText()
short | getRecordType()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCommentText(java.lang.String comment)
void | setNameText(java.lang.String newName) Updates the name we're associated with, normally used when renaming that Name
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

NameCommentRecord

public NameCommentRecord(java.lang.String name,
                         java.lang.String comment)

NameCommentRecord

public NameCommentRecord(RecordInputStream ris)
Parameters:
ris - the RecordInputstream to read the record from
Method Detail

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getNameText

public java.lang.String getNameText()
Returns:
the name of the NameRecord to which this comment applies.

setNameText

public void setNameText(java.lang.String newName)
Updates the name we're associated with, normally used when renaming that Name

getCommentText

public java.lang.String getCommentText()
Returns:
the text of the comment.

setCommentText

public void setCommentText(java.lang.String comment)

getRecordType

public short getRecordType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NameRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class NameRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.cont.ContinuableRecord
                extended by  org.apache.poi.hssf.record.NameRecord

public final class NameRecord
extends ContinuableRecord

Title: DEFINEDNAME Record (0x0018)

Description: Defines a named range within a workbook.

REFERENCE:

Author:
Libin Roman (Vista Portal LDT. Developer), Sergei Kozello (sergeikozello at mail.ru), Glen Stampoultzis (glens at apache.org), Petr Udalau - added method setFunction(boolean)

Field Summary
static byte | BUILTIN_AUTO_ACTIVATE Included for completeness sake, not implemented
static byte | BUILTIN_AUTO_CLOSE Included for completeness sake, not implemented
static byte | BUILTIN_AUTO_DEACTIVATE Included for completeness sake, not implemented
static byte | BUILTIN_AUTO_OPEN Included for completeness sake, not implemented
static byte | BUILTIN_CONSOLIDATE_AREA Included for completeness sake, not implemented
static byte | BUILTIN_CRITERIA Included for completeness sake, not implemented
static byte | BUILTIN_DATA_FORM Included for completeness sake, not implemented
static byte | BUILTIN_DATABASE Included for completeness sake, not implemented
static byte | BUILTIN_FILTER_DB
static byte | BUILTIN_PRINT_AREA
static byte | BUILTIN_PRINT_TITLE
static byte | BUILTIN_RECORDER Included for completeness sake, not implemented
static byte | BUILTIN_SHEET_TITLE Included for completeness sake, not implemented
static short | sid
Constructor Summary
NameRecord()
Creates new NameRecord
NameRecord(byte builtin, int sheetNumber)
Constructor to create a built-in named region
NameRecord(RecordInputStream ris)
called by the constructor, should set class level fields.
Method Summary
byte | getBuiltInName() Gets the Built In Name
java.lang.String | getCustomMenuText() get the custom menu text
protected int | getDataSize()
java.lang.String | getDescriptionText() gets the description text
int | getExternSheetNumber() gets the extern sheet number
byte | getFnGroup()
java.lang.String | getHelpTopicText() get the help topic text
byte | getKeyboardShortcut() returns the keyboard shortcut
Ptg[] | getNameDefinition() gets the definition, reference (Formula)
java.lang.String | getNameText() gets the name
short | getOptionFlag() gets the option flag
int | getSheetNumber() For named ranges, and built-in names
short | getSid() return the non static version of the id for this record.
java.lang.String | getStatusBarText() gets the status bar text
boolean | hasFormula()
boolean | isBuiltInName() Convenience Function to determine if the name is a built-in name
boolean | isCommandName()
boolean | isComplexFunction()
boolean | isFunctionName()
boolean | isHiddenName()
boolean | isMacro()
void | serialize(ContinuableRecordOutput out) NameRecord can span into
void | setCustomMenuText(java.lang.String text) sets the custom menu text
void | setDescriptionText(java.lang.String text) sets the description text
void | setFunction(boolean function) Indicates that the defined name refers to a user-defined function.
void | setHelpTopicText(java.lang.String text) sets the help topic text
void | setHidden(boolean b)
void | setKeyboardShortcut(byte shortcut) sets the keyboard shortcut
void | setNameDefinition(Ptg[] ptgs)
void | setNameText(java.lang.String name) sets the name of the named range
void | setOptionFlag(short flag) sets the option flag for the named range
void | setSheetNumber(int value)
void | setStatusBarText(java.lang.String text) sets the status bar text
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.cont.ContinuableRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

BUILTIN_CONSOLIDATE_AREA

public static final byte BUILTIN_CONSOLIDATE_AREA
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_AUTO_OPEN

public static final byte BUILTIN_AUTO_OPEN
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_AUTO_CLOSE

public static final byte BUILTIN_AUTO_CLOSE
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_DATABASE

public static final byte BUILTIN_DATABASE
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_CRITERIA

public static final byte BUILTIN_CRITERIA
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_PRINT_AREA

public static final byte BUILTIN_PRINT_AREA
See Also:
Constant Field Values

BUILTIN_PRINT_TITLE

public static final byte BUILTIN_PRINT_TITLE
See Also:
Constant Field Values

BUILTIN_RECORDER

public static final byte BUILTIN_RECORDER
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_DATA_FORM

public static final byte BUILTIN_DATA_FORM
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_AUTO_ACTIVATE

public static final byte BUILTIN_AUTO_ACTIVATE
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_AUTO_DEACTIVATE

public static final byte BUILTIN_AUTO_DEACTIVATE
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_SHEET_TITLE

public static final byte BUILTIN_SHEET_TITLE
Included for completeness sake, not implemented

See Also:
Constant Field Values

BUILTIN_FILTER_DB

public static final byte BUILTIN_FILTER_DB
See Also:
Constant Field Values
Constructor Detail

NameRecord

public NameRecord()
Creates new NameRecord

NameRecord

public NameRecord(byte builtin,
                  int sheetNumber)
Constructor to create a built-in named region

Parameters:
builtin - Built-in byte representation for the name record, use the public constants

NameRecord

public NameRecord(RecordInputStream ris)
called by the constructor, should set class level fields. Should throw runtime exception for bad/icomplete data.

Parameters:
ris - the RecordInputstream to read the record from
Method Detail

setOptionFlag

public void setOptionFlag(short flag)
sets the option flag for the named range

Parameters:
flag - option flag

setKeyboardShortcut

public void setKeyboardShortcut(byte shortcut)
sets the keyboard shortcut

Parameters:
shortcut - keyboard shortcut

getSheetNumber

public int getSheetNumber()
For named ranges, and built-in names

Returns:
the 1-based sheet number.

getFnGroup

public byte getFnGroup()
Returns:
function group
See Also:
FnGroupCountRecord

setSheetNumber

public void setSheetNumber(int value)

setNameText

public void setNameText(java.lang.String name)
sets the name of the named range

Parameters:
name - named range name

setCustomMenuText

public void setCustomMenuText(java.lang.String text)
sets the custom menu text

Parameters:
text - custom menu text

setDescriptionText

public void setDescriptionText(java.lang.String text)
sets the description text

Parameters:
text - the description text

setHelpTopicText

public void setHelpTopicText(java.lang.String text)
sets the help topic text

Parameters:
text - help topix text

setStatusBarText

public void setStatusBarText(java.lang.String text)
sets the status bar text

Parameters:
text - status bar text

getOptionFlag

public short getOptionFlag()
gets the option flag

Returns:
option flag

getKeyboardShortcut

public byte getKeyboardShortcut()
returns the keyboard shortcut

Returns:
keyboard shortcut

isHiddenName

public boolean isHiddenName()
Returns:
true if name is hidden

setHidden

public void setHidden(boolean b)

isFunctionName

public boolean isFunctionName()
Returns:
true if name is a function

setFunction

public void setFunction(boolean function)
Indicates that the defined name refers to a user-defined function. This attribute is used when there is an add-in or other code project associated with the file.

Parameters:
function - true indicates the name refers to a function.

hasFormula

public boolean hasFormula()
Returns:
true if name has a formula (named range or defined value)

isCommandName

public boolean isCommandName()
Returns:
true if name is a command

isMacro

public boolean isMacro()
Returns:
true if function macro or command macro

isComplexFunction

public boolean isComplexFunction()
Returns:
true if array formula or user defined

isBuiltInName

public boolean isBuiltInName()
Convenience Function to determine if the name is a built-in name

getNameText

public java.lang.String getNameText()
gets the name

Returns:
name

getBuiltInName

public byte getBuiltInName()
Gets the Built In Name

Returns:
the built in Name

getNameDefinition

public Ptg[] getNameDefinition()
gets the definition, reference (Formula)

Returns:
the name formula. never null

setNameDefinition

public void setNameDefinition(Ptg[] ptgs)

getCustomMenuText

public java.lang.String getCustomMenuText()
get the custom menu text

Returns:
custom menu text

getDescriptionText

public java.lang.String getDescriptionText()
gets the description text

Returns:
description text

getHelpTopicText

public java.lang.String getHelpTopicText()
get the help topic text

Returns:
gelp topic text

getStatusBarText

public java.lang.String getStatusBarText()
gets the status bar text

Returns:
status bar text

serialize

public void serialize(ContinuableRecordOutput out)
NameRecord can span into

Specified by:
serialize in class ContinuableRecord
Parameters:
out - a data output stream

getDataSize

protected int getDataSize()

getExternSheetNumber

public int getExternSheetNumber()
gets the extern sheet number

Returns:
extern sheet index

getSid

public short getSid()
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoteRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class NoteRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.NoteRecord

public final class NoteRecord
extends StandardRecord

NOTE: Comment Associated with a Cell (0x001C)

Author:
Yegor Kozlov

Field Summary
static NoteRecord[] | EMPTY_ARRAY
static short | NOTE_HIDDEN Flag indicating that the comment is hidden (default)
static short | NOTE_VISIBLE Flag indicating that the comment is visible
static short | sid
Constructor Summary
NoteRecord()
Construct a new NoteRecord and fill its data with the default values
NoteRecord(RecordInputStream in)
Read the record data from the supplied RecordInputStream
Method Summary
protected boolean | authorIsMultibyte() For unit testing only!
java.lang.Object | clone()
java.lang.String | getAuthor() Name of the original comment author
int | getColumn() Return the column that contains the comment
protected int | getDataSize()
short | getFlags() Options flags.
int | getRow() Return the row that contains the comment
int | getShapeId() Object id for OBJ record that contains the comment
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAuthor(java.lang.String author) Name of the original comment author
void | setColumn(int col) Specify the column that contains the comment
void | setFlags(short flags) Options flag
void | setRow(int row) Specify the row that contains the comment
void | setShapeId(int id) Object id for OBJ record that contains the comment
java.lang.String | toString() Convert this record to string.
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

EMPTY_ARRAY

public static final NoteRecord[] EMPTY_ARRAY

NOTE_HIDDEN

public static final short NOTE_HIDDEN
Flag indicating that the comment is hidden (default)

See Also:
Constant Field Values

NOTE_VISIBLE

public static final short NOTE_VISIBLE
Flag indicating that the comment is visible

See Also:
Constant Field Values
Constructor Detail

NoteRecord

public NoteRecord()
Construct a new NoteRecord and fill its data with the default values

NoteRecord

public NoteRecord(RecordInputStream in)
Read the record data from the supplied RecordInputStream

Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Returns:
id of this record.

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

toString

public java.lang.String toString()
Convert this record to string. Used by BiffViewer and other utilities.

Overrides:
toString in class Record

getRow

public int getRow()
Return the row that contains the comment

Returns:
the row that contains the comment

setRow

public void setRow(int row)
Specify the row that contains the comment

Parameters:
row - the row that contains the comment

getColumn

public int getColumn()
Return the column that contains the comment

Returns:
the column that contains the comment

setColumn

public void setColumn(int col)
Specify the column that contains the comment

Parameters:
col - the column that contains the comment

getFlags

public short getFlags()
Options flags.

Returns:
the options flag
See Also:
NOTE_VISIBLE, NOTE_HIDDEN

setFlags

public void setFlags(short flags)
Options flag

Parameters:
flags - the options flag
See Also:
NOTE_VISIBLE, NOTE_HIDDEN

authorIsMultibyte

protected boolean authorIsMultibyte()
For unit testing only!

getShapeId

public int getShapeId()
Object id for OBJ record that contains the comment

setShapeId

public void setShapeId(int id)
Object id for OBJ record that contains the comment

getAuthor

public java.lang.String getAuthor()
Name of the original comment author

Returns:
the name of the original author of the comment

setAuthor

public void setAuthor(java.lang.String author)
Name of the original comment author

Parameters:
author - the name of the original author of the comment

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoteStructureSubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class NoteStructureSubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
        extended by  org.apache.poi.hssf.record.NoteStructureSubRecord

public final class NoteStructureSubRecord
extends SubRecord

ftNts (0x000D)

Represents a NoteStructure sub record.

The docs say nothing about it. The length of this record is always 26 bytes.

Author:
Yegor Kozlov

Field Summary
static short sid
Constructor Summary
NoteStructureSubRecord()
Construct a new NoteStructureSubRecord and fill its data with the default values
NoteStructureSubRecord(LittleEndianInput in, int size)
Read the record data from the supplied RecordInputStream
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid()
void | serialize(LittleEndianOutput out) Serialize the record data into the supplied array of bytes
java.lang.String | toString() Convert this record to string.
Methods inherited from class org.apache.poi.hssf.record.SubRecord
createSubRecord, isTerminating, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

NoteStructureSubRecord

public NoteStructureSubRecord()
Construct a new NoteStructureSubRecord and fill its data with the default values

NoteStructureSubRecord

public NoteStructureSubRecord(LittleEndianInput in,
                              int size)
Read the record data from the supplied RecordInputStream

Method Detail

toString

public java.lang.String toString()
Convert this record to string. Used by BiffViewer and other utilities.

Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Serialize the record data into the supplied array of bytes

Specified by:
serialize in class SubRecord
Parameters:
out - the stream to serialize into

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class SubRecord
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

getSid

public short getSid()
Returns:
id of this record.

clone

public java.lang.Object clone()
Specified by:
clone in class SubRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumberRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class NumberRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CellRecord
                    extended by  org.apache.poi.hssf.record.NumberRecord
All Implemented Interfaces:
CellValueRecordInterface
public final class NumberRecord
extends CellRecord

NUMBER (0x0203) Contains a numeric cell value.

REFERENCE: PG 334 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
NumberRecord()
Creates new NumberRecord
NumberRecord(RecordInputStream in)
Method Summary
protected  void appendValueText(java.lang.StringBuilder sb)
Append specific debug info (used by CellRecord.toString() for the value contained in this record.
 java.lang.Object clone()
protected  java.lang.String getRecordName()
Gets the debug info BIFF record type name (used by CellRecord.toString().
 short getSid()
return the non static version of the id for this record.
 double getValue()
get the value for the cell
protected  int getValueDataSize()
protected  void serializeValue(LittleEndianOutput out)
writes out the value data for this cell record
 void setValue(double value)
set the value for the cell
Methods inherited from class org.apache.poi.hssf.record.CellRecord
copyBaseFields, getColumn, getDataSize, getRow, getXFIndex, serialize, setColumn, setRow, setXFIndex, toString
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

NumberRecord

public NumberRecord()
Creates new NumberRecord

NumberRecord

public NumberRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

setValue

public void setValue(double value)
set the value for the cell

Parameters:
value - double representing the value

getValue

public double getValue()
get the value for the cell

Returns:
double representing the value

getRecordName

protected java.lang.String getRecordName()
Description copied from class: CellRecord
Gets the debug info BIFF record type name (used by CellRecord.toString().

Specified by:
getRecordName in class CellRecord

appendValueText

protected void appendValueText(java.lang.StringBuilder sb)
Description copied from class: CellRecord
Append specific debug info (used by CellRecord.toString() for the value contained in this record. Trailing new-line should not be appended (superclass does that).

Specified by:
appendValueText in class CellRecord

serializeValue

protected void serializeValue(LittleEndianOutput out)
Description copied from class: CellRecord
writes out the value data for this cell record

Specified by:
serializeValue in class CellRecord

getValueDataSize

protected int getValueDataSize()
Specified by:
getValueDataSize in class CellRecord
Returns:
the size (in bytes) of the value data for this cell record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectProtectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ObjectProtectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ObjectProtectRecord

public final class ObjectProtectRecord
extends StandardRecord

Title: Object Protect Record

Description: Protect embedded object with the lamest "security" ever invented. This record tells "I want to protect my objects" with lame security. It appears in conjunction with the PASSWORD and PROTECT records as well as its scenario protect cousin.

REFERENCE: PG 368 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
ObjectProtectRecord()
ObjectProtectRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getProtect() get whether the sheet is protected or not
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setProtect(boolean protect) set whether the sheet is protected or not
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ObjectProtectRecord

public ObjectProtectRecord()

ObjectProtectRecord

public ObjectProtectRecord(RecordInputStream in)
Method Detail

setProtect

public void setProtect(boolean protect)
set whether the sheet is protected or not

Parameters:
protect - whether to protect the sheet or not

getProtect

public boolean getProtect()
get whether the sheet is protected or not

Returns:
whether to protect the sheet or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ObjRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.ObjRecord

public final class ObjRecord
extends Record

OBJRECORD (0x005D)

The obj record is used to hold various graphic objects and controls.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
ObjRecord()
ObjRecord(RecordInputStream in)
Method Summary
void | addSubRecord(int index, SubRecord element)
boolean | addSubRecord(SubRecord o)
void | clearSubRecords()
java.lang.Object | clone()
int | getRecordSize() gives the current serialized size of the record.
short | getSid() return the non static version of the id for this record.
java.util.List<SubRecord> | getSubRecords()
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ObjRecord

public ObjRecord()

ObjRecord

public ObjRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getRecordSize

public int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase

serialize

public int serialize(int offset,
                     byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getSubRecords

public java.util.List<SubRecord> getSubRecords()

clearSubRecords

public void clearSubRecords()

addSubRecord

public void addSubRecord(int index,
                         SubRecord element)

addSubRecord

public boolean addSubRecord(SubRecord o)

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record
Interfaces
BiffHeaderInput
CellValueRecordInterface
Margin
Classes
AbstractEscherHolderRecord
ArrayRecord
AutoFilterInfoRecord
BackupRecord
BlankRecord
BOFRecord
BookBoolRecord
BoolErrRecord
BottomMarginRecord
BoundSheetRecord
CalcCountRecord
CalcModeRecord
CellRecord
CFHeaderRecord
CFRuleRecord
CFRuleRecord.ComparisonOperator
CodepageRecord
ColumnInfoRecord
CommonObjectDataSubRecord
ContinueRecord
CountryRecord
CRNCountRecord
CRNRecord
DateWindow1904Record
DBCellRecord
DBCellRecord.Builder
DConRefRecord
DefaultColWidthRecord
DefaultRowHeightRecord
DeltaRecord
DimensionsRecord
DrawingGroupRecord
DrawingRecord
DrawingRecordForBiffViewer
DrawingSelectionRecord
DSFRecord
DVALRecord
DVRecord
EmbeddedObjectRefSubRecord
EndSubRecord
EOFRecord
EscherAggregate
ExtendedFormatRecord
ExternalNameRecord
ExternSheetRecord
ExtSSTRecord
ExtSSTRecord.InfoSubRecord
FeatHdrRecord
FeatRecord
FilePassRecord
FileSharingRecord
FnGroupCountRecord
FontRecord
FooterRecord
FormatRecord
FormulaRecord
FtCblsSubRecord
GridsetRecord
GroupMarkerSubRecord
GutsRecord
HCenterRecord
HeaderFooterBase
HeaderFooterRecord
HeaderRecord
HideObjRecord
HorizontalPageBreakRecord
HyperlinkRecord
IndexRecord
InterfaceEndRecord
InterfaceHdrRecord
IterationRecord
LabelRecord
LabelSSTRecord
LbsDataSubRecord
LbsDataSubRecord.LbsDropData
LeftMarginRecord
MergeCellsRecord
MMSRecord
MulBlankRecord
MulRKRecord
NameCommentRecord
NameRecord
NoteRecord
NoteStructureSubRecord
NumberRecord
ObjectProtectRecord
ObjRecord
PageBreakRecord
PageBreakRecord.Break
PaletteRecord
PaneRecord
PasswordRecord
PasswordRev4Record
PrecisionRecord
PrintGridlinesRecord
PrintHeadersRecord
PrintSetupRecord
ProtectionRev4Record
ProtectRecord
RecalcIdRecord
Record
RecordBase
RecordFactory
RecordFactoryInputStream
RecordInputStream
RefModeRecord
RefreshAllRecord
RightMarginRecord
RKRecord
RowRecord
SaveRecalcRecord
ScenarioProtectRecord
SCLRecord
SelectionRecord
SharedFormulaRecord
SharedValueRecordBase
SSTRecord
StandardRecord
StringRecord
StyleRecord
SubRecord
SupBookRecord
TabIdRecord
TableRecord
TableStylesRecord
TextObjectRecord
TopMarginRecord
UncalcedRecord
UnicodeString
UnknownRecord
UserSViewBegin
UserSViewEnd
UseSelFSRecord
VCenterRecord
VerticalPageBreakRecord
WindowOneRecord
WindowProtectRecord
WindowTwoRecord
WriteAccessRecord
WriteProtectRecord
WSBoolRecord
Exceptions
RecordFormatException
RecordInputStream.LeftoverDataException


org.apache.poi.hssf.record

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record

Record package contains class representations for XLS binary strutures.

See:
Description

Interface Summary
BiffHeaderInput |
CellValueRecordInterface | The cell value record interface is implemented by all classes of type Record that contain cell values.
Margin | The margin interface is a parent used to define left, right, top and bottom margins.

Class Summary
AbstractEscherHolderRecord | The escher container record is used to hold escher records.
ArrayRecord ARRAY (0x0221)

Treated in a similar way to SharedFormulaRecord

AutoFilterInfoRecord | The AutoFilterInfo record specifies the number of columns that have AutoFilter enabled and indicates the beginning of the collection of AutoFilter records.
BackupRecord | Title: Backup Record
BlankRecord | Title: Blank cell record (0x0201)
BOFRecord | Title: Beginning Of File (0x0809)
BookBoolRecord | Title: Save External Links record (BookBool)
BoolErrRecord | Creates new BoolErrRecord.
BottomMarginRecord Record for the bottom margin.
BoundSheetRecord | Title: Bound Sheet Record (aka BundleSheet) (0x0085)
CalcCountRecord | Title: Calc Count Record Description: Specifies the maximum times the gui should perform a formula recalculation.
CalcModeRecord | Title: Calc Mode Record
CellRecord | Base class for all cell value records (implementors of CellValueRecordInterface).
CFHeaderRecord | Conditional Formatting Header record CFHEADER (0x01B0)
CFRuleRecord Conditional Formatting Rule Record (0x01B1).
CFRuleRecord.ComparisonOperator
CodepageRecord | Title: Codepage Record
ColumnInfoRecord Title: COLINFO Record (0x007D)

Description: Defines with width and formatting for a range of columns

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
CommonObjectDataSubRecord The common object data record is used to store all common preferences for an excel object.
ContinueRecord | Title: Continue Record(0x003C) - Helper class used primarily for SST Records
CountryRecord | Title: Country Record (aka WIN.INI country)
CRNCountRecord | XCT - CRN Count
CRNRecord Title: CRN(0x005A)

Description: This record stores the contents of an external cell or cell range

REFERENCE: OOO 5.23
DateWindow1904Record | Title: Date Window 1904 Flag record
DBCellRecord Title: DBCell Record (0x00D7)

Description: Used by Excel and other MS apps to quickly find rows in the sheets.

DBCellRecord.Builder
DConRefRecord | DConRef records specify a range in a workbook (internal or external) that serves as a data source for pivot tables or data consolidation.
DefaultColWidthRecord | Title: Default Column Width Record (0x0055)
DefaultRowHeightRecord | Title: Default Row Height Record Description: Row height for rows with undefined or not explicitly defined heights.
DeltaRecord Title: Delta Record (0x0010)

Description: controls the accuracy of the calculations

REFERENCE: PG 303 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
DimensionsRecord | Title: Dimensions Record
DrawingGroupRecord
DrawingRecord DrawingRecord (0x00EC)
DrawingRecordForBiffViewer | This is purely for the biff viewer.
DrawingSelectionRecord MsoDrawingSelection (0x00ED)

Reference: [MS-OGRAPH].pdf sec 2.4.69

DSFRecord Title: Double Stream Flag Record (0x0161)

Description: tells if this is a double stream file.

DVALRecord Title: DATAVALIDATIONS Record (0x01B2)

Description: used in data validation ; This record is the list header of all data validation records (0x01BE) in the current sheet.

DVRecord Title: DATAVALIDATION Record (0x01BE)

Description: This record stores data validation settings and a list of cell ranges which contain these settings.

EmbeddedObjectRefSubRecord ftPictFmla (0x0009)
A sub-record within the OBJ record which stores a reference to an object stored in a separate entry within the OLE2 compound file.
EndSubRecord ftEnd (0x0000)

The end data record is used to denote the end of the subrecords.
EOFRecord | End Of File record.
EscherAggregate | This class is used to aggregate the MSODRAWING and OBJ record combinations.
ExtendedFormatRecord | Title: Extended Format Record Description: Probably one of the more complex records.
ExternalNameRecord EXTERNALNAME (0x0023)
ExternSheetRecord EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

ExtSSTRecord Title: Extended Static String Table (0x00FF)

Description: This record is used for a quick lookup into the SST record.

ExtSSTRecord.InfoSubRecord
FeatHdrRecord | Title: FeatHdr (Feature Header) Record
FeatRecord | Title: Feat (Feature) Record
FilePassRecord Title: File Pass Record (0x002F)

Description: Indicates that the record after this record are encrypted.

FileSharingRecord Title: FILESHARING (0x005B)

Description: stores the encrypted readonly for a workbook (write protect) This functionality is accessed from the options dialog box available when performing 'Save As'.

REFERENCE: PG 314 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
FnGroupCountRecord | Title: Function Group Count Record
FontRecord Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

FooterRecord Title: Footer Record (0x0015)

Description: Specifies the footer for a sheet

FormatRecord Title: Format Record (0x041E)

Description: describes a number format -- those goofy strings like $(#,###)

REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
FormulaRecord | Formula Record (0x0006).
FtCblsSubRecord | This structure appears as part of an Obj record that represents a checkbox or radio button.
GridsetRecord | Title: Gridset Record.
GroupMarkerSubRecord ftGmo (0x0006)

The group marker record is used as a position holder for groups.

GutsRecord | Title: Guts Record
HCenterRecord | Title: HCenter record (0x0083)
HeaderFooterBase | Common header/footer base class
HeaderFooterRecord | The HEADERFOOTER record stores information added in Office Excel 2007 for headers/footers.
HeaderRecord | Title: Header Record
HideObjRecord | Title: Hide Object Record
HorizontalPageBreakRecord HorizontalPageBreak (0x001B) record that stores page breaks at rows

HyperlinkRecord | The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format.
IndexRecord Title: Index Record (0x020B)

Description: Occurs right after BOF, tells you where the DBCELL records are for a sheet Important for locating cells

NOT USED IN THIS RELEASE REFERENCE: PG 323 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
InterfaceEndRecord | Title: Interface End Record (0x00E2)
InterfaceHdrRecord | Title: Interface Header Record (0x00E1)
IterationRecord Title: Iteration Record (0x0011)

Description: Tells whether to iterate over forumla calculations or not (if a formula is dependant upon another formula's result) (odd feature for something that can only have 32 elements in a formula!)

LabelRecord | Label Record (0x0204) - read only support for strings stored directly in the cell..
LabelSSTRecord | Title: Label SST Record
LbsDataSubRecord | This structure specifies the properties of a list or drop-down list embedded object in a sheet.
LbsDataSubRecord.LbsDropData | This structure specifies properties of the dropdown list control
LeftMarginRecord Record for the left margin.
MergeCellsRecord Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.
MMSRecord | Title: MMS Record
MulBlankRecord Title: Multiple Blank cell record(0x00BE)

Description: Represents a set of columns in a row with no value but with styling.

MulRKRecord MULRK (0x00BD)

Used to store multiple RK numbers on a row.

NameCommentRecord Title: NAMECMT Record (0x0894)

Description: Defines a comment associated with a specified name.

NameRecord Title: DEFINEDNAME Record (0x0018)

Description: Defines a named range within a workbook.

NoteRecord NOTE: Comment Associated with a Cell (0x001C)
NoteStructureSubRecord ftNts (0x000D)

Represents a NoteStructure sub record.

NumberRecord | NUMBER (0x0203) Contains a numeric cell value.
ObjectProtectRecord | Title: Object Protect Record
ObjRecord OBJRECORD (0x005D)

The obj record is used to hold various graphic objects and controls.

PageBreakRecord | Record that contains the functionality page breaks (horizontal and vertical)
PageBreakRecord.Break | Since both records store 2byte integers (short), no point in differentiating it in the records.
PaletteRecord | PaletteRecord (0x0092) - Supports custom palettes.
PaneRecord Describes the frozen and unfozen panes.
PasswordRecord Title: Password Record (0x0013)

Description: stores the encrypted password for a sheet or workbook (HSSF doesn't support encryption) REFERENCE: PG 371 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
PasswordRev4Record Title: Protection Revision 4 password Record (0x01BC)

Description: Stores the (2 byte??!!) encrypted password for a shared workbook

REFERENCE: PG 374 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
PrecisionRecord | Title: Precision Record
PrintGridlinesRecord | Title: Print Gridlines Record
PrintHeadersRecord | Title: Print Headers Record
PrintSetupRecord Title: PAGESETUP (0x00A1)

Description: Stores print setup options -- bogus for HSSF (and marked as such)

REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214
ProtectionRev4Record Title: Protection Revision 4 Record (0x01AF)

Description: describes whether this is a protected shared/tracked workbook

REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
ProtectRecord Title: Protect Record (0x0012)

Description: defines whether a sheet or workbook is protected (HSSF DOES NOT SUPPORT ENCRYPTION)

HSSF now supports the simple "protected" sheets (where they are not encrypted and open office et al ignore the password record entirely).

RecalcIdRecord Title: Recalc Id Record (0x01C1)

Description: This record contains an ID that marks when a worksheet was last recalculated.

Record | Title: Record Description: All HSSF Records inherit from this class.
RecordBase | Common base class of Record and RecordAggregate
RecordFactory | Title: Record Factory
RecordFactoryInputStream | A stream based way to get at complete records, with as low a memory footprint as possible.
RecordInputStream | Title: Record Input Stream
RefModeRecord | Title: RefMode Record
RefreshAllRecord Title: Refresh All Record (0x01B7)

Description: Flag whether to refresh all external data when loading a sheet.

RightMarginRecord Record for the right margin.
RKRecord Title: RK Record (0x027E)

Description: An internal 32 bit number with the two most significant bits storing the type.

RowRecord Title: Row Record (0x0208)

Description: stores the row information for the sheet.

SaveRecalcRecord | Title: Save Recalc Record
ScenarioProtectRecord | Title: Scenario Protect Record
SCLRecord | Specifies the window's zoom magnification.
SelectionRecord | Title: Selection Record (0x001D)
SharedFormulaRecord | Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
SharedValueRecordBase | Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.
SSTRecord Title: Static String Table Record (0x00FC)

Description: This holds all the strings for LabelSSTRecords.

StandardRecord | Subclasses of this class (the majority of BIFF records) are non-continuable.
StringRecord STRING (0x0207)

Stores the cached result of a text formula

StyleRecord Title: Style Record (0x0293)

Description: Describes a builtin to the gui or user defined style

SubRecord | Subrecords are part of the OBJ class.
SupBookRecord Title: Sup Book - EXTERNALBOOK (0x01AE)

Description: A External Workbook Description (Supplemental Book) Its only a dummy record for making new ExternSheet Record

TabIdRecord Title: Sheet Tab Index Array Record (0x013D)

Description: Contains an array of sheet id's.

TableRecord DATATABLE (0x0236)

TableRecord - The record specifies a data table.

TableStylesRecord TABLESTYLES (0x088E)
TextObjectRecord | The TXO record (0x01B6) is used to define the properties of a text box.
TopMarginRecord Record for the top margin.
UncalcedRecord | Title: Uncalced Record
UnicodeString | Deprecated. Use UnicodeString instead
UnknownRecord Title: Unknown Record (for debugging)

Description: Unknown record just tells you the sid so you can figure out what records you are missing.

UserSViewBegin | The UserSViewBegin record specifies settings for a custom view associated with the sheet.
UserSViewEnd | The UserSViewEnd record marks the end of the settings for a custom view associated with the sheet
UseSelFSRecord Title: USESELFS (0x0160) - Use Natural Language Formulas Flag

Description: Tells the GUI if this was written by something that can use "natural language" formulas.

VCenterRecord | Title: VCenter record
VerticalPageBreakRecord VerticalPageBreak (0x001A) record that stores page breaks at columns
WindowOneRecord | Title: Window1 Record
WindowProtectRecord Title: Window Protect Record (0x0019)

Description: flags whether workbook windows are protected

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
WindowTwoRecord | Title: Window Two Record
WriteAccessRecord Title: Write Access Record (0x005C)

Description: Stores the username of that who owns the spreadsheet generator (on unix the user's login, on Windoze its the name you typed when you installed the thing)

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

WriteProtectRecord | Title: Write Protect Record
WSBoolRecord Title: WSBOOL (0x0081) (called SHEETPR in OOO doc)

Description: stores workbook settings (aka its a big "everything we didn't put somewhere else")

Exception Summary
RecordFormatException | Title: Record Format Exception Description: Used by records to indicate invalid format/data.
RecordInputStream.LeftoverDataException | For use in BiffViewer which may construct Records that don't completely read all available data.

Package org.apache.poi.hssf.record Description

Record package contains class representations for XLS binary strutures. Its very low level.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.hssf.eventmodel, RecordFactory


org.apache.poi.hssf.record Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator
    • org.apache.poi.hssf.record.DBCellRecord.Builder
    • org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord
    • org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData
    • org.apache.poi.hssf.record.PageBreakRecord.Break
    • org.apache.poi.hssf.record.RecordBase
      • org.apache.poi.hssf.record.Record
        • org.apache.poi.hssf.record.AbstractEscherHolderRecord
          • org.apache.poi.hssf.record.DrawingGroupRecord
          • org.apache.poi.hssf.record.DrawingRecordForBiffViewer
          • org.apache.poi.hssf.record.EscherAggregate
        • org.apache.poi.hssf.record.cont.ContinuableRecord
          • org.apache.poi.hssf.record.ExtSSTRecord
          • org.apache.poi.hssf.record.NameRecord
          • org.apache.poi.hssf.record.SSTRecord
          • org.apache.poi.hssf.record.StringRecord
          • org.apache.poi.hssf.record.TextObjectRecord
        • org.apache.poi.hssf.record.LabelRecord (implements org.apache.poi.hssf.record.CellValueRecordInterface)
        • org.apache.poi.hssf.record.ObjRecord
        • org.apache.poi.hssf.record.StandardRecord
          • org.apache.poi.hssf.record.AutoFilterInfoRecord
          • org.apache.poi.hssf.record.BackupRecord
          • org.apache.poi.hssf.record.BlankRecord (implements org.apache.poi.hssf.record.CellValueRecordInterface)
          • org.apache.poi.hssf.record.BOFRecord
          • org.apache.poi.hssf.record.BookBoolRecord
          • org.apache.poi.hssf.record.BottomMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.BoundSheetRecord
          • org.apache.poi.hssf.record.CalcCountRecord
          • org.apache.poi.hssf.record.CalcModeRecord
          • org.apache.poi.hssf.record.CellRecord (implements org.apache.poi.hssf.record.CellValueRecordInterface)
            • org.apache.poi.hssf.record.BoolErrRecord
            • org.apache.poi.hssf.record.FormulaRecord
            • org.apache.poi.hssf.record.LabelSSTRecord
            • org.apache.poi.hssf.record.NumberRecord
            • org.apache.poi.hssf.record.RKRecord
          • org.apache.poi.hssf.record.CFHeaderRecord
          • org.apache.poi.hssf.record.CFRuleRecord
          • org.apache.poi.hssf.record.CodepageRecord
          • org.apache.poi.hssf.record.ColumnInfoRecord
          • org.apache.poi.hssf.record.ContinueRecord
          • org.apache.poi.hssf.record.CountryRecord
          • org.apache.poi.hssf.record.CRNCountRecord
          • org.apache.poi.hssf.record.CRNRecord
          • org.apache.poi.hssf.record.DateWindow1904Record
          • org.apache.poi.hssf.record.DBCellRecord
          • org.apache.poi.hssf.record.DConRefRecord
          • org.apache.poi.hssf.record.DefaultColWidthRecord
          • org.apache.poi.hssf.record.DefaultRowHeightRecord
          • org.apache.poi.hssf.record.DeltaRecord
          • org.apache.poi.hssf.record.DimensionsRecord
          • org.apache.poi.hssf.record.DrawingRecord
          • org.apache.poi.hssf.record.DrawingSelectionRecord
          • org.apache.poi.hssf.record.DSFRecord
          • org.apache.poi.hssf.record.DVALRecord
          • org.apache.poi.hssf.record.DVRecord
          • org.apache.poi.hssf.record.EOFRecord
          • org.apache.poi.hssf.record.ExtendedFormatRecord
          • org.apache.poi.hssf.record.ExternalNameRecord
          • org.apache.poi.hssf.record.ExternSheetRecord
          • org.apache.poi.hssf.record.FeatHdrRecord
          • org.apache.poi.hssf.record.FeatRecord
          • org.apache.poi.hssf.record.FilePassRecord
          • org.apache.poi.hssf.record.FileSharingRecord
          • org.apache.poi.hssf.record.FnGroupCountRecord
          • org.apache.poi.hssf.record.FontRecord
          • org.apache.poi.hssf.record.FormatRecord
          • org.apache.poi.hssf.record.GridsetRecord
          • org.apache.poi.hssf.record.GutsRecord
          • org.apache.poi.hssf.record.HCenterRecord
          • org.apache.poi.hssf.record.HeaderFooterBase
            • org.apache.poi.hssf.record.FooterRecord
            • org.apache.poi.hssf.record.HeaderRecord
          • org.apache.poi.hssf.record.HeaderFooterRecord
          • org.apache.poi.hssf.record.HideObjRecord
          • org.apache.poi.hssf.record.HyperlinkRecord
          • org.apache.poi.hssf.record.IndexRecord
          • org.apache.poi.hssf.record.InterfaceEndRecord
          • org.apache.poi.hssf.record.InterfaceHdrRecord
          • org.apache.poi.hssf.record.IterationRecord
          • org.apache.poi.hssf.record.LeftMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.MergeCellsRecord
          • org.apache.poi.hssf.record.MMSRecord
          • org.apache.poi.hssf.record.MulBlankRecord
          • org.apache.poi.hssf.record.MulRKRecord
          • org.apache.poi.hssf.record.NameCommentRecord
          • org.apache.poi.hssf.record.NoteRecord
          • org.apache.poi.hssf.record.ObjectProtectRecord
          • org.apache.poi.hssf.record.PageBreakRecord
            • org.apache.poi.hssf.record.HorizontalPageBreakRecord
            • org.apache.poi.hssf.record.VerticalPageBreakRecord
          • org.apache.poi.hssf.record.PaletteRecord
          • org.apache.poi.hssf.record.PaneRecord
          • org.apache.poi.hssf.record.PasswordRecord
          • org.apache.poi.hssf.record.PasswordRev4Record
          • org.apache.poi.hssf.record.PrecisionRecord
          • org.apache.poi.hssf.record.PrintGridlinesRecord
          • org.apache.poi.hssf.record.PrintHeadersRecord
          • org.apache.poi.hssf.record.PrintSetupRecord
          • org.apache.poi.hssf.record.ProtectionRev4Record
          • org.apache.poi.hssf.record.ProtectRecord
          • org.apache.poi.hssf.record.RecalcIdRecord
          • org.apache.poi.hssf.record.RefModeRecord
          • org.apache.poi.hssf.record.RefreshAllRecord
          • org.apache.poi.hssf.record.RightMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.RowRecord
          • org.apache.poi.hssf.record.SaveRecalcRecord
          • org.apache.poi.hssf.record.ScenarioProtectRecord
          • org.apache.poi.hssf.record.SCLRecord
          • org.apache.poi.hssf.record.SelectionRecord
          • org.apache.poi.hssf.record.SharedValueRecordBase
            • org.apache.poi.hssf.record.ArrayRecord
            • org.apache.poi.hssf.record.SharedFormulaRecord
            • org.apache.poi.hssf.record.TableRecord
          • org.apache.poi.hssf.record.StyleRecord
          • org.apache.poi.hssf.record.SupBookRecord
          • org.apache.poi.hssf.record.TabIdRecord
          • org.apache.poi.hssf.record.TableStylesRecord
          • org.apache.poi.hssf.record.TopMarginRecord (implements org.apache.poi.hssf.record.Margin)
          • org.apache.poi.hssf.record.UncalcedRecord
          • org.apache.poi.hssf.record.UnknownRecord
          • org.apache.poi.hssf.record.UserSViewBegin
          • org.apache.poi.hssf.record.UserSViewEnd
          • org.apache.poi.hssf.record.UseSelFSRecord
          • org.apache.poi.hssf.record.VCenterRecord
          • org.apache.poi.hssf.record.WindowOneRecord
          • org.apache.poi.hssf.record.WindowProtectRecord
          • org.apache.poi.hssf.record.WindowTwoRecord
          • org.apache.poi.hssf.record.WriteAccessRecord
          • org.apache.poi.hssf.record.WriteProtectRecord
          • org.apache.poi.hssf.record.WSBoolRecord
    • org.apache.poi.hssf.record.RecordFactory
    • org.apache.poi.hssf.record.RecordFactoryInputStream
    • org.apache.poi.hssf.record.RecordInputStream (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.hssf.record.SubRecord
      • org.apache.poi.hssf.record.CommonObjectDataSubRecord
      • org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord
      • org.apache.poi.hssf.record.EndSubRecord
      • org.apache.poi.hssf.record.FtCblsSubRecord
      • org.apache.poi.hssf.record.GroupMarkerSubRecord
      • org.apache.poi.hssf.record.LbsDataSubRecord
      • org.apache.poi.hssf.record.NoteStructureSubRecord
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.apache.poi.util.RecordFormatException
            • org.apache.poi.hssf.record.RecordFormatException
          • org.apache.poi.hssf.record.RecordInputStream.LeftoverDataException
    • org.apache.poi.hssf.record.common.UnicodeString (implements java.lang.Comparable<T>)
      • org.apache.poi.hssf.record.UnicodeString

Interface Hierarchy

  • org.apache.poi.hssf.record.BiffHeaderInput
  • org.apache.poi.hssf.record.CellValueRecordInterface
  • org.apache.poi.hssf.record.Margin


Uses of Package org.apache.poi.hssf.record

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record

Packages that use org.apache.poi.hssf.record
org.apache.poi.hssf.dev | DEV package serves two purposes.
org.apache.poi.hssf.eventmodel |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.eventusermodel.dummyrecord |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.crypto |
org.apache.poi.hssf.record.pivottable |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.dev
FormulaRecord
Formula Record (0x0006).
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordFormatException
Title: Record Format Exception Description: Used by records to indicate invalid format/data.

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.eventmodel
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordFormatException
Title: Record Format Exception Description: Used by records to indicate invalid format/data.

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.eventusermodel
BoundSheetRecord
Title: Bound Sheet Record (aka BundleSheet) (0x0085)
CellValueRecordInterface
The cell value record interface is implemented by all classes of type Record that contain cell values.
ExternSheetRecord
EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

Record
Title: Record Description: All HSSF Records inherit from this class.
SSTRecord
Title: Static String Table Record (0x00FC)

Description: This holds all the strings for LabelSSTRecords.

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.eventusermodel.dummyrecord
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordBase
Common base class of Record and RecordAggregate

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.model
BackupRecord
Title: Backup Record
CellValueRecordInterface
The cell value record interface is implemented by all classes of type Record that contain cell values.
DefaultColWidthRecord
Title: Default Column Width Record (0x0055)
DefaultRowHeightRecord
Title: Default Row Height Record Description: Row height for rows with undefined or not explicitly defined heights.
ExtendedFormatRecord
Title: Extended Format Record Description: Probably one of the more complex records.
FileSharingRecord
Title: FILESHARING (0x005B)

Description: stores the encrypted readonly for a workbook (write protect) This functionality is accessed from the options dialog box available when performing 'Save As'.

REFERENCE: PG 314 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
FontRecord
Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

FormatRecord
Title: Format Record (0x041E)

Description: describes a number format -- those goofy strings like $(#,###)

REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
GridsetRecord
Title: Gridset Record.
HyperlinkRecord
The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format.
MergeCellsRecord
Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.
NameCommentRecord
Title: NAMECMT Record (0x0894)

Description: Defines a comment associated with a specified name.

NameRecord
Title: DEFINEDNAME Record (0x0018)

Description: Defines a named range within a workbook.

NoteRecord
NOTE: Comment Associated with a Cell (0x001C)
ObjRecord
OBJRECORD (0x005D)

The obj record is used to hold various graphic objects and controls.

PaletteRecord
PaletteRecord (0x0092) - Supports custom palettes.
PrintGridlinesRecord
Title: Print Gridlines Record
RecalcIdRecord
Title: Recalc Id Record (0x01C1)

Description: This record contains an ID that marks when a worksheet was last recalculated.

Record
Title: Record Description: All HSSF Records inherit from this class.
RecordBase
Common base class of Record and RecordAggregate
RowRecord
Title: Row Record (0x0208)

Description: stores the row information for the sheet.

SCLRecord
Specifies the window's zoom magnification.
SelectionRecord
Title: Selection Record (0x001D)
SSTRecord
Title: Static String Table Record (0x00FC)

Description: This holds all the strings for LabelSSTRecords.

StyleRecord
Title: Style Record (0x0293)

Description: Describes a builtin to the gui or user defined style

TextObjectRecord
The TXO record (0x01B6) is used to define the properties of a text box.
WindowOneRecord
Title: Window1 Record
WindowTwoRecord
Title: Window Two Record
WriteAccessRecord
Title: Write Access Record (0x005C)

Description: Stores the username of that who owns the spreadsheet generator (on unix the user's login, on Windoze its the name you typed when you installed the thing)

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

WriteProtectRecord
Title: Write Protect Record

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record
AbstractEscherHolderRecord
The escher container record is used to hold escher records.
BlankRecord
Title: Blank cell record (0x0201)
BOFRecord
Title: Beginning Of File (0x0809)
BoundSheetRecord
Title: Bound Sheet Record (aka BundleSheet) (0x0085)
CellRecord
Base class for all cell value records (implementors of CellValueRecordInterface).
CellValueRecordInterface
The cell value record interface is implemented by all classes of type Record that contain cell values.
CFRuleRecord
Conditional Formatting Rule Record (0x01B1).
ColumnInfoRecord
Title: COLINFO Record (0x007D)

Description: Defines with width and formatting for a range of columns

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
DBCellRecord
Title: DBCell Record (0x00D7)

Description: Used by Excel and other MS apps to quickly find rows in the sheets.

DrawingRecord
DrawingRecord (0x00EC)
EOFRecord
End Of File record.
EscherAggregate
This class is used to aggregate the MSODRAWING and OBJ record combinations.
ExtendedFormatRecord
Title: Extended Format Record Description: Probably one of the more complex records.
ExternSheetRecord
EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

ExtSSTRecord
Title: Extended Static String Table (0x00FF)

Description: This record is used for a quick lookup into the SST record.

ExtSSTRecord.InfoSubRecord
FontRecord
Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

FormulaRecord
Formula Record (0x0006).
HeaderFooterBase
Common header/footer base class
InterfaceEndRecord
Title: Interface End Record (0x00E2)
LbsDataSubRecord
This structure specifies the properties of a list or drop-down list embedded object in a sheet.
Margin
The margin interface is a parent used to define left, right, top and bottom margins.
MulBlankRecord
Title: Multiple Blank cell record(0x00BE)

Description: Represents a set of columns in a row with no value but with styling.

MulRKRecord
MULRK (0x00BD)

Used to store multiple RK numbers on a row.

NoteRecord
NOTE: Comment Associated with a Cell (0x001C)
NumberRecord
NUMBER (0x0203) Contains a numeric cell value.
PageBreakRecord
Record that contains the functionality page breaks (horizontal and vertical)
PageBreakRecord.Break
Since both records store 2byte integers (short), no point in differentiating it in the records.
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordBase
Common base class of Record and RecordAggregate
RecordFormatException
Title: Record Format Exception Description: Used by records to indicate invalid format/data.
RecordInputStream
Title: Record Input Stream
RecordInputStream.LeftoverDataException
For use in BiffViewer which may construct Records that don't completely read all available data.
RKRecord
Title: RK Record (0x027E)

Description: An internal 32 bit number with the two most significant bits storing the type.

SharedFormulaRecord
Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
SharedValueRecordBase
Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.
StandardRecord
Subclasses of this class (the majority of BIFF records) are non-continuable.
SubRecord
Subrecords are part of the OBJ class.
SupBookRecord
Title: Sup Book - EXTERNALBOOK (0x01AE)

Description: A External Workbook Description (Supplemental Book) Its only a dummy record for making new ExternSheet Record

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record.aggregates
ArrayRecord
ARRAY (0x0221)

Treated in a similar way to SharedFormulaRecord

CellValueRecordInterface
The cell value record interface is implemented by all classes of type Record that contain cell values.
CFHeaderRecord
Conditional Formatting Header record CFHEADER (0x01B0)
CFRuleRecord
Conditional Formatting Rule Record (0x01B1).
ColumnInfoRecord
Title: COLINFO Record (0x007D)

Description: Defines with width and formatting for a range of columns

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
DimensionsRecord
Title: Dimensions Record
DVRecord
Title: DATAVALIDATION Record (0x01BE)

Description: This record stores data validation settings and a list of cell ranges which contain these settings.

FooterRecord
Title: Footer Record (0x0015)

Description: Specifies the footer for a sheet

FormulaRecord
Formula Record (0x0006).
HCenterRecord
Title: HCenter record (0x0083)
HeaderFooterRecord
The HEADERFOOTER record stores information added in Office Excel 2007 for headers/footers.
HeaderRecord
Title: Header Record
IndexRecord
Title: Index Record (0x020B)

Description: Occurs right after BOF, tells you where the DBCELL records are for a sheet Important for locating cells

NOT USED IN THIS RELEASE REFERENCE: PG 323 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
MergeCellsRecord
Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.
MulBlankRecord
Title: Multiple Blank cell record(0x00BE)

Description: Represents a set of columns in a row with no value but with styling.

PasswordRecord
Title: Password Record (0x0013)

Description: stores the encrypted password for a sheet or workbook (HSSF doesn't support encryption) REFERENCE: PG 371 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
PrintSetupRecord
Title: PAGESETUP (0x00A1)

Description: Stores print setup options -- bogus for HSSF (and marked as such)

REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordBase
Common base class of Record and RecordAggregate
RowRecord
Title: Row Record (0x0208)

Description: stores the row information for the sheet.

ScenarioProtectRecord
Title: Scenario Protect Record
SharedFormulaRecord
Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
SharedValueRecordBase
Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.
StringRecord
STRING (0x0207)

Stores the cached result of a text formula

TableRecord
DATATABLE (0x0236)

TableRecord - The record specifies a data table.

VCenterRecord
Title: VCenter record

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record.cf
RecordInputStream
Title: Record Input Stream

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record.chart
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordBase
Common base class of Record and RecordAggregate
RecordInputStream
Title: Record Input Stream
StandardRecord
Subclasses of this class (the majority of BIFF records) are non-continuable.

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record.common
RecordInputStream
Title: Record Input Stream

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record.cont
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordBase
Common base class of Record and RecordAggregate
RecordInputStream
Title: Record Input Stream

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record.crypto
BiffHeaderInput

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.record.pivottable
Record
Title: Record Description: All HSSF Records inherit from this class.
RecordBase
Common base class of Record and RecordAggregate
RecordInputStream
Title: Record Input Stream
StandardRecord
Subclasses of this class (the majority of BIFF records) are non-continuable.

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.usermodel
CellValueRecordInterface
The cell value record interface is implemented by all classes of type Record that contain cell values.
CFRuleRecord
Conditional Formatting Rule Record (0x01B1).
DVRecord
Title: DATAVALIDATION Record (0x01BE)

Description: This record stores data validation settings and a list of cell ranges which contain these settings.

EmbeddedObjectRefSubRecord
ftPictFmla (0x0009)
A sub-record within the OBJ record which stores a reference to an object stored in a separate entry within the OLE2 compound file.
EscherAggregate
This class is used to aggregate the MSODRAWING and OBJ record combinations.
ExtendedFormatRecord
Title: Extended Format Record Description: Probably one of the more complex records.
FontRecord
Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

HyperlinkRecord
The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format.
NameRecord
Title: DEFINEDNAME Record (0x0018)

Description: Defines a named range within a workbook.

NoteRecord
NOTE: Comment Associated with a Cell (0x001C)
ObjRecord
OBJRECORD (0x005D)

The obj record is used to hold various graphic objects and controls.

PaletteRecord
PaletteRecord (0x0092) - Supports custom palettes.
PrintSetupRecord
Title: PAGESETUP (0x00A1)

Description: Stores print setup options -- bogus for HSSF (and marked as such)

REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214
Record
Title: Record Description: All HSSF Records inherit from this class.
RowRecord
Title: Row Record (0x0208)

Description: stores the row information for the sheet.

TextObjectRecord
The TXO record (0x01B6) is used to define the properties of a text box.

Classes in org.apache.poi.hssf.record used by org.apache.poi.hssf.util
RecordInputStream
Title: Record Input Stream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PageBreakRecord.Break

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PageBreakRecord.Break

java.lang.Object
    extended by  org.apache.poi.hssf.record.PageBreakRecord.Break
Enclosing class:
PageBreakRecord
public static final class PageBreakRecord.Break
extends java.lang.Object

Since both records store 2byte integers (short), no point in differentiating it in the records.

The subs (rows or columns, don't seem to be able to set but excel sets them automatically)

Field Summary
static int | ENCODED_SIZE
int | main
int | subFrom
int | subTo
Constructor Summary
PageBreakRecord.Break(int main, int subFrom, int subTo)
PageBreakRecord.Break(RecordInputStream in)
Method Summary
 void serialize(LittleEndianOutput out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ENCODED_SIZE

public static final int ENCODED_SIZE
See Also:
Constant Field Values

main

public int main

subFrom

public int subFrom

subTo

public int subTo
Constructor Detail

PageBreakRecord.Break

public PageBreakRecord.Break(int main,
                             int subFrom,
                             int subTo)

PageBreakRecord.Break

public PageBreakRecord.Break(RecordInputStream in)
Method Detail

serialize

public void serialize(LittleEndianOutput out)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PageBreakRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PageBreakRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PageBreakRecord
Direct Known Subclasses:
HorizontalPageBreakRecord, VerticalPageBreakRecord
public abstract class PageBreakRecord
extends StandardRecord

Record that contains the functionality page breaks (horizontal and vertical)

The other two classes just specifically set the SIDS for record creation.

REFERENCE: Microsoft Excel SDK page 322 and 420

Author:
Danny Mui (dmui at apache dot org)
See Also:
HorizontalPageBreakRecord, VerticalPageBreakRecord

Nested Class Summary
static class PageBreakRecord.Break
Since both records store 2byte integers (short), no point in differentiating it in the records.
Constructor Summary
protected | PageBreakRecord()
 | PageBreakRecord(RecordInputStream in)
Method Summary
void | addBreak(int main, int subFrom, int subTo) Adds the page break at the specified parameters
PageBreakRecord.Break | getBreak(int main) Retrieves the region at the row/column indicated
int[] | getBreaks()
java.util.Iterator<PageBreakRecord.Break> | getBreaksIterator()
protected int | getDataSize()
int | getNumBreaks()
boolean | isEmpty()
void | removeBreak(int main) Removes the break indicated by the parameter
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, getSid, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PageBreakRecord

protected PageBreakRecord()

PageBreakRecord

public PageBreakRecord(RecordInputStream in)
Method Detail

isEmpty

public boolean isEmpty()

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public final void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getNumBreaks

public int getNumBreaks()

getBreaksIterator

public final java.util.Iterator<PageBreakRecord.Break> getBreaksIterator()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

addBreak

public void addBreak(int main,
                     int subFrom,
                     int subTo)
Adds the page break at the specified parameters

Parameters:
main - Depending on sid, will determine row or column to put page break (zero-based)
subFrom - No user-interface to set (defaults to minimum, 0)
subTo - No user-interface to set

removeBreak

public final void removeBreak(int main)
Removes the break indicated by the parameter

Parameters:
main - (zero-based)

getBreak

public final PageBreakRecord.Break getBreak(int main)
Retrieves the region at the row/column indicated

Parameters:
main - FIXME: Document this!
Returns:
The Break or null if no break exists at the row/col specified.

getBreaks

public final int[] getBreaks()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PaletteRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PaletteRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PaletteRecord

public final class PaletteRecord
extends StandardRecord

PaletteRecord (0x0092) - Supports custom palettes.

Author:
Andrew C. Oliver (acoliver at apache dot org), Brian Sanders (bsanders at risklabs dot com) - custom palette editing

Field Summary
static short | FIRST_COLOR_INDEX The byte index of the first color
static short | sid
static byte | STANDARD_PALETTE_SIZE The standard size of an XLS palette
Constructor Summary
PaletteRecord()
PaletteRecord(RecordInputStream in)
Method Summary
byte[] | getColor(int byteIndex) Returns the color value at a given index
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setColor(short byteIndex, byte red, byte green, byte blue) Sets the color value at a given index If the given index is greater than the current last color index, then black is inserted at every index required to make the palette continuous.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

STANDARD_PALETTE_SIZE

public static final byte STANDARD_PALETTE_SIZE
The standard size of an XLS palette

See Also:
Constant Field Values

FIRST_COLOR_INDEX

public static final short FIRST_COLOR_INDEX
The byte index of the first color

See Also:
Constant Field Values
Constructor Detail

PaletteRecord

public PaletteRecord()

PaletteRecord

public PaletteRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getColor

public byte[] getColor(int byteIndex)
Returns the color value at a given index

Returns:
the RGB triplet for the color, or null if the specified index does not exist

setColor

public void setColor(short byteIndex,
                     byte red,
                     byte green,
                     byte blue)
Sets the color value at a given index If the given index is greater than the current last color index, then black is inserted at every index required to make the palette continuous.

Parameters:
byteIndex - the index to set; if this index is less than 0x8 or greater than 0x40, then no modification is made
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PaneRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PaneRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PaneRecord

public final class PaneRecord
extends StandardRecord

Describes the frozen and unfozen panes.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | ACTIVE_PANE_LOWER_LEFT
static short | ACTIVE_PANE_LOWER_RIGHT
static short | ACTIVE_PANE_UPER_LEFT Deprecated. use ACTIVE_PANE_UPPER_LEFT
static short | ACTIVE_PANE_UPPER_LEFT
static short | ACTIVE_PANE_UPPER_RIGHT
static short | sid
Constructor Summary
PaneRecord()
PaneRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getActivePane() Get the active pane field for the Pane record.
protected int | getDataSize()
short | getLeftColumn() Get the left column field for the Pane record.
short | getSid() return the non static version of the id for this record.
short | getTopRow() Get the top row field for the Pane record.
short | getX() Get the x field for the Pane record.
short | getY() Get the y field for the Pane record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setActivePane(short field_5_activePane) Set the active pane field for the Pane record.
void | setLeftColumn(short field_4_leftColumn) Set the left column field for the Pane record.
void | setTopRow(short field_3_topRow) Set the top row field for the Pane record.
void | setX(short field_1_x) Set the x field for the Pane record.
void | setY(short field_2_y) Set the y field for the Pane record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

ACTIVE_PANE_LOWER_RIGHT

public static final short ACTIVE_PANE_LOWER_RIGHT
See Also:
Constant Field Values

ACTIVE_PANE_UPPER_RIGHT

public static final short ACTIVE_PANE_UPPER_RIGHT
See Also:
Constant Field Values

ACTIVE_PANE_LOWER_LEFT

public static final short ACTIVE_PANE_LOWER_LEFT
See Also:
Constant Field Values

ACTIVE_PANE_UPER_LEFT

public static final short ACTIVE_PANE_UPER_LEFT
Deprecated. use ACTIVE_PANE_UPPER_LEFT
See Also:
Constant Field Values

ACTIVE_PANE_UPPER_LEFT

public static final short ACTIVE_PANE_UPPER_LEFT
See Also:
Constant Field Values
Constructor Detail

PaneRecord

public PaneRecord()

PaneRecord

public PaneRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getX

public short getX()
Get the x field for the Pane record.

setX

public void setX(short field_1_x)
Set the x field for the Pane record.

getY

public short getY()
Get the y field for the Pane record.

setY

public void setY(short field_2_y)
Set the y field for the Pane record.

getTopRow

public short getTopRow()
Get the top row field for the Pane record.

setTopRow

public void setTopRow(short field_3_topRow)
Set the top row field for the Pane record.

getLeftColumn

public short getLeftColumn()
Get the left column field for the Pane record.

setLeftColumn

public void setLeftColumn(short field_4_leftColumn)
Set the left column field for the Pane record.

getActivePane

public short getActivePane()
Get the active pane field for the Pane record.

Returns:
One of ACTIVE_PANE_LOWER_RIGHT ACTIVE_PANE_UPPER_RIGHT ACTIVE_PANE_LOWER_LEFT ACTIVE_PANE_UPPER_LEFT

setActivePane

public void setActivePane(short field_5_activePane)
Set the active pane field for the Pane record.

Parameters:
field_5_activePane - One of ACTIVE_PANE_LOWER_RIGHT ACTIVE_PANE_UPPER_RIGHT ACTIVE_PANE_LOWER_LEFT ACTIVE_PANE_UPPER_LEFT
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PasswordRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PasswordRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PasswordRecord

public final class PasswordRecord
extends StandardRecord

Title: Password Record (0x0013)

Description: stores the encrypted password for a sheet or workbook (HSSF doesn't support encryption) REFERENCE: PG 371 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
PasswordRecord(int password)
PasswordRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone() Clone this record.
protected int | getDataSize()
int | getPassword() get the password
short | getSid() return the non static version of the id for this record.
static short | hashPassword(java.lang.String password)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setPassword(int password) set the password
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PasswordRecord

public PasswordRecord(int password)

PasswordRecord

public PasswordRecord(RecordInputStream in)
Method Detail

hashPassword

public static short hashPassword(java.lang.String password)

setPassword

public void setPassword(int password)
set the password

Parameters:
password - representing the password

getPassword

public int getPassword()
get the password

Returns:
short representing the password

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Clone this record.

Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PasswordRev4Record

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PasswordRev4Record

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PasswordRev4Record

public final class PasswordRev4Record
extends StandardRecord

Title: Protection Revision 4 password Record (0x01BC)

Description: Stores the (2 byte??!!) encrypted password for a shared workbook

REFERENCE: PG 374 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
PasswordRev4Record(int pw)
PasswordRev4Record(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setPassword(short pw) set the password
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PasswordRev4Record

public PasswordRev4Record(int pw)

PasswordRev4Record

public PasswordRev4Record(RecordInputStream in)
Method Detail

setPassword

public void setPassword(short pw)
set the password

Parameters:
pw - representing the password

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrecisionRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PrecisionRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PrecisionRecord

public final class PrecisionRecord
extends StandardRecord

Title: Precision Record

Description: defines whether to store with full precision or what's displayed by the gui (meaning have really screwed up and skewed figures or only think you do!)

REFERENCE: PG 372 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
short | field_1_precision
static short | sid
Constructor Summary
PrecisionRecord()
PrecisionRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
boolean | getFullPrecision() get whether to use full precision or just skew all you figures all to hell.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setFullPrecision(boolean fullprecision) set whether to use full precision or just skew all you figures all to hell.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

field_1_precision

public short field_1_precision
Constructor Detail

PrecisionRecord

public PrecisionRecord()

PrecisionRecord

public PrecisionRecord(RecordInputStream in)
Method Detail

setFullPrecision

public void setFullPrecision(boolean fullprecision)
set whether to use full precision or just skew all you figures all to hell.

Parameters:
fullprecision - - or not

getFullPrecision

public boolean getFullPrecision()
get whether to use full precision or just skew all you figures all to hell.

Returns:
fullprecision - or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrintGridlinesRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PrintGridlinesRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PrintGridlinesRecord

public final class PrintGridlinesRecord
extends StandardRecord

Title: Print Gridlines Record

Description: whether to print the gridlines when you enjoy you spreadsheet on paper.

REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
PrintGridlinesRecord()
PrintGridlinesRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getPrintGridlines() get whether or not to print the gridlines (and make your spreadsheet ugly)
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setPrintGridlines(boolean pg) set whether or not to print the gridlines (and make your spreadsheet ugly)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PrintGridlinesRecord

public PrintGridlinesRecord()

PrintGridlinesRecord

public PrintGridlinesRecord(RecordInputStream in)
Method Detail

setPrintGridlines

public void setPrintGridlines(boolean pg)
set whether or not to print the gridlines (and make your spreadsheet ugly)

Parameters:
pg - make spreadsheet ugly - Y/N

getPrintGridlines

public boolean getPrintGridlines()
get whether or not to print the gridlines (and make your spreadsheet ugly)

Returns:
make spreadsheet ugly - Y/N

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrintHeadersRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PrintHeadersRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PrintHeadersRecord

public final class PrintHeadersRecord
extends StandardRecord

Title: Print Headers Record

Description: Whether or not to print the row/column headers when you enjoy your spreadsheet in the physical form.

REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
PrintHeadersRecord()
PrintHeadersRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getPrintHeaders() get whether to print the headers - y/n
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setPrintHeaders(boolean p) set to print the headers - y/n
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PrintHeadersRecord

public PrintHeadersRecord()

PrintHeadersRecord

public PrintHeadersRecord(RecordInputStream in)
Method Detail

setPrintHeaders

public void setPrintHeaders(boolean p)
set to print the headers - y/n

Parameters:
p - printheaders or not

getPrintHeaders

public boolean getPrintHeaders()
get whether to print the headers - y/n

Returns:
printheaders or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrintSetupRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class PrintSetupRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PrintSetupRecord

public final class PrintSetupRecord
extends StandardRecord

Title: PAGESETUP (0x00A1)

Description: Stores print setup options -- bogus for HSSF (and marked as such)

REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
PrintSetupRecord()
PrintSetupRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getCopies()
protected int | getDataSize()
boolean | getDraft()
short | getFitHeight()
short | getFitWidth()
double | getFooterMargin()
double | getHeaderMargin()
short | getHResolution()
boolean | getLandscape()
boolean | getLeftToRight()
boolean | getNoColor()
boolean | getNoOrientation()
boolean | getNotes()
short | getOptions()
short | getPageStart()
short | getPaperSize()
short | getScale()
short | getSid() return the non static version of the id for this record.
boolean | getUsePage()
boolean | getValidSettings()
short | getVResolution()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCopies(short copies)
void | setDraft(boolean d)
void | setFitHeight(short height)
void | setFitWidth(short width)
void | setFooterMargin(double footermargin)
void | setHeaderMargin(double headermargin)
void | setHResolution(short resolution)
void | setLandscape(boolean ls)
void | setLeftToRight(boolean ltor)
void | setNoColor(boolean mono)
void | setNoOrientation(boolean orientation)
void | setNotes(boolean printnotes)
void | setOptions(short options)
void | setPageStart(short start)
void | setPaperSize(short size)
void | setScale(short scale)
void | setUsePage(boolean page)
void | setValidSettings(boolean valid)
void | setVResolution(short resolution)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PrintSetupRecord

public PrintSetupRecord()

PrintSetupRecord

public PrintSetupRecord(RecordInputStream in)
Method Detail

setPaperSize

public void setPaperSize(short size)

setScale

public void setScale(short scale)

setPageStart

public void setPageStart(short start)

setFitWidth

public void setFitWidth(short width)

setFitHeight

public void setFitHeight(short height)

setOptions

public void setOptions(short options)

setLeftToRight

public void setLeftToRight(boolean ltor)

setLandscape

public void setLandscape(boolean ls)

setValidSettings

public void setValidSettings(boolean valid)

setNoColor

public void setNoColor(boolean mono)

setDraft

public void setDraft(boolean d)

setNotes

public void setNotes(boolean printnotes)

setNoOrientation

public void setNoOrientation(boolean orientation)

setUsePage

public void setUsePage(boolean page)

setHResolution

public void setHResolution(short resolution)

setVResolution

public void setVResolution(short resolution)

setHeaderMargin

public void setHeaderMargin(double headermargin)

setFooterMargin

public void setFooterMargin(double footermargin)

setCopies

public void setCopies(short copies)

getPaperSize

public short getPaperSize()

getScale

public short getScale()

getPageStart

public short getPageStart()

getFitWidth

public short getFitWidth()

getFitHeight

public short getFitHeight()

getOptions

public short getOptions()

getLeftToRight

public boolean getLeftToRight()

getLandscape

public boolean getLandscape()

getValidSettings

public boolean getValidSettings()

getNoColor

public boolean getNoColor()

getDraft

public boolean getDraft()

getNotes

public boolean getNotes()

getNoOrientation

public boolean getNoOrientation()

getUsePage

public boolean getUsePage()

getHResolution

public short getHResolution()

getVResolution

public short getVResolution()

getHeaderMargin

public double getHeaderMargin()

getFooterMargin

public double getFooterMargin()

getCopies

public short getCopies()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProtectionRev4Record

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ProtectionRev4Record

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ProtectionRev4Record

public final class ProtectionRev4Record
extends StandardRecord

Title: Protection Revision 4 Record (0x01AF)

Description: describes whether this is a protected shared/tracked workbook

REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
ProtectionRev4Record(boolean protect)
ProtectionRev4Record(RecordInputStream in)
Method Summary
protected int | getDataSize()
boolean | getProtect() get whether the this is protected shared/tracked workbook or not
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setProtect(boolean protect) set whether the this is protected shared/tracked workbook or not
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ProtectionRev4Record

public ProtectionRev4Record(boolean protect)

ProtectionRev4Record

public ProtectionRev4Record(RecordInputStream in)
Method Detail

setProtect

public void setProtect(boolean protect)
set whether the this is protected shared/tracked workbook or not

Parameters:
protect - whether to protect the workbook or not

getProtect

public boolean getProtect()
get whether the this is protected shared/tracked workbook or not

Returns:
whether to protect the workbook or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProtectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ProtectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ProtectRecord

public final class ProtectRecord
extends StandardRecord

Title: Protect Record (0x0012)

Description: defines whether a sheet or workbook is protected (HSSF DOES NOT SUPPORT ENCRYPTION)

HSSF now supports the simple "protected" sheets (where they are not encrypted and open office et al ignore the password record entirely). REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
ProtectRecord(boolean isProtected)
ProtectRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getProtect() get whether the sheet is protected or not
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setProtect(boolean protect) set whether the sheet is protected or not
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ProtectRecord

public ProtectRecord(boolean isProtected)

ProtectRecord

public ProtectRecord(RecordInputStream in)
Method Detail

setProtect

public void setProtect(boolean protect)
set whether the sheet is protected or not

Parameters:
protect - whether to protect the sheet or not

getProtect

public boolean getProtect()
get whether the sheet is protected or not

Returns:
whether to protect the sheet or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecalcIdRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RecalcIdRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.RecalcIdRecord

public final class RecalcIdRecord
extends StandardRecord

Title: Recalc Id Record (0x01C1)

Description: This record contains an ID that marks when a worksheet was last recalculated. It's an optimization Excel uses to determine if it needs to recalculate the spreadsheet when it's opened. So far, only the two engine ids 0x80 0x38 0x01 0x00 and 0x60 0x69 0x01 0x00 have been seen. A value of 0x00 will cause Excel to recalculate all formulas on the next load.

REFERENCE: http://chicago.sourceforge.net/devel/docs/excel/biff8.html

Author:
Luc Girardin (luc dot girardin at macrofocus dot com)

Field Summary
static short sid
Constructor Summary
RecalcIdRecord()
RecalcIdRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
int | getEngineId()
short | getSid() return the non static version of the id for this record.
boolean | isNeeded()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setEngineId(int val)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

RecalcIdRecord

public RecalcIdRecord()

RecalcIdRecord

public RecalcIdRecord(RecordInputStream in)
Method Detail

isNeeded

public boolean isNeeded()

setEngineId

public void setEngineId(int val)

getEngineId

public int getEngineId()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Record

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class Record

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
Direct Known Subclasses:
AbstractEscherHolderRecord, ContinuableRecord, LabelRecord, LastCellOfRowDummyRecord, MissingCellDummyRecord, MissingRowDummyRecord, ObjRecord, StandardRecord
public abstract class Record
extends RecordBase

Title: Record Description: All HSSF Records inherit from this class.

Author:
Andrew C. Oliver, Marc Johnson (mjohnson at apache dot org), Jason Height (jheight at chariot dot net dot au)

Constructor Summary
protected Record()
Method Summary
java.lang.Object | clone()
Record | cloneViaReserialise() Clone the current record, via a call to serialize it, and another to create a new record from the bytes.
abstract short | getSid() return the non static version of the id for this record.
byte[] | serialize() called by the class that is responsible for writing this sucker.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.RecordBase
getRecordSize, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Record

protected Record()
Method Detail

serialize

public final byte[] serialize()
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Returns:
byte array containing instance data

toString

public java.lang.String toString()
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class java.lang.Object

getSid

public abstract short getSid()
return the non static version of the id for this record.

clone

public java.lang.Object clone()
Overrides:
clone in class java.lang.Object

cloneViaReserialise

public Record cloneViaReserialise()
Clone the current record, via a call to serialize it, and another to create a new record from the bytes. May only be used for classes which don't have internal counts / ids in them. For those which do, a full model-aware cloning is needed, which allocates new ids / counts as needed.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RecordBase

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
Direct Known Subclasses:
Record, RecordAggregate
public abstract class RecordBase
extends java.lang.Object

Common base class of Record and RecordAggregate

Author:
Josh Micich

Constructor Summary
RecordBase()
Method Summary
abstract int | getRecordSize() gives the current serialized size of the record.
abstract int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordBase

public RecordBase()
Method Detail

serialize

public abstract int serialize(int offset,
                              byte[] data)
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getRecordSize

public abstract int getRecordSize()
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RecordFactory

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordFactory

public final class RecordFactory
extends java.lang.Object

Title: Record Factory

Description: Takes a stream and outputs an array of Record objects.

Author:
Andrew C. Oliver (acoliver at apache dot org), Marc Johnson (mjohnson at apache dot org), Glen Stampoultzis (glens at apache.org), Csaba Nagy (ncsaba at yahoo dot com)
See Also:
EventRecordFactory

Constructor Summary
RecordFactory()
Method Summary
static BlankRecord[] | convertBlankRecords(MulBlankRecord mbk) Converts a MulBlankRecord into an equivalent array of BlankRecords
static NumberRecord[] | convertRKRecords(MulRKRecord mrk) Converts a MulRKRecord into an equivalent array of NumberRecords
static NumberRecord | convertToNumberRecord(RKRecord rk) RK record is a slightly smaller alternative to NumberRecord POI likes NumberRecord better
static Record[] | createRecord(RecordInputStream in) create a record, if there are MUL records than multiple records are returned digested into the non-mul form.
static java.util.List<Record> | createRecords(java.io.InputStream in) Create an array of records from an input stream
static Record | createSingleRecord(RecordInputStream in)
static short[] | getAllKnownRecordSIDs()
static java.lang.Class<? extends Record> | getRecordClass(int sid) Debug / diagnosis method Gets the POI implementation class for a given sid.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordFactory

public RecordFactory()
Method Detail

getRecordClass

public static java.lang.Class<? extends Record> getRecordClass(int sid)
Debug / diagnosis method
Gets the POI implementation class for a given sid. Only a subset of the any BIFF records are actually interpreted by POI. A few others are known but not interpreted (see UnknownRecord.getBiffName(int)).

Returns:
the POI implementation class for the specified record sid. null if the specified record is not interpreted by POI.

createRecord

public static Record[] createRecord(RecordInputStream in)
create a record, if there are MUL records than multiple records are returned digested into the non-mul form.

createSingleRecord

public static Record createSingleRecord(RecordInputStream in)

convertToNumberRecord

public static NumberRecord convertToNumberRecord(RKRecord rk)
RK record is a slightly smaller alternative to NumberRecord POI likes NumberRecord better

convertRKRecords

public static NumberRecord[] convertRKRecords(MulRKRecord mrk)
Converts a MulRKRecord into an equivalent array of NumberRecords

convertBlankRecords

public static BlankRecord[] convertBlankRecords(MulBlankRecord mbk)
Converts a MulBlankRecord into an equivalent array of BlankRecords

getAllKnownRecordSIDs

public static short[] getAllKnownRecordSIDs()
Returns:
an array of all the SIDS for all known records

createRecords

public static java.util.List<Record> createRecords(java.io.InputStream in)
                                            throws RecordFormatException
Create an array of records from an input stream

Parameters:
in - the InputStream from which the records will be obtained
Returns:
an array of Records created from the InputStream
Throws:
RecordFormatException - on error processing the InputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordFactoryInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RecordFactoryInputStream

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordFactoryInputStream

public final class RecordFactoryInputStream
extends java.lang.Object

A stream based way to get at complete records, with as low a memory footprint as possible. This handles reading from a RecordInputStream, turning the data into full records, processing continue records etc. Most users should use HSSFEventFactory / HSSFListener and have new records pushed to them, but this does allow for a "pull" style of coding.

Constructor Summary
RecordFactoryInputStream(java.io.InputStream in, boolean shouldIncludeContinueRecords)
Method Summary
 Record nextRecord()
Returns the next (complete) record from the stream, or null if there are no more.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordFactoryInputStream

public RecordFactoryInputStream(java.io.InputStream in,
                                boolean shouldIncludeContinueRecords)
Parameters:
shouldIncludeContinueRecords - caller can pass false if loose ContinueRecords should be skipped (this is sometimes useful in event based processing).
Method Detail

nextRecord

public Record nextRecord()
Returns the next (complete) record from the stream, or null if there are no more.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordFormatException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RecordFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.util.RecordFormatException
                    extended by  org.apache.poi.hssf.record.RecordFormatException
All Implemented Interfaces:
java.io.Serializable
public class RecordFormatException
extends RecordFormatException

Title: Record Format Exception Description: Used by records to indicate invalid format/data.

See Also:
Serialized Form

Constructor Summary
RecordFormatException(java.lang.String exception)
RecordFormatException(java.lang.String exception, java.lang.Throwable thr)
RecordFormatException(java.lang.Throwable thr)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RecordFormatException

public RecordFormatException(java.lang.String exception)

RecordFormatException

public RecordFormatException(java.lang.String exception,
                             java.lang.Throwable thr)

RecordFormatException

public RecordFormatException(java.lang.Throwable thr)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RecordInputStream

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordInputStream
All Implemented Interfaces:
LittleEndianInput
public final class RecordInputStream
extends java.lang.Object
implements LittleEndianInput

Title: Record Input Stream

Description: Wraps a stream and provides helper methods for the construction of records.

Author:
Jason Height (jheight @ apache dot org)

Nested Class Summary
static class RecordInputStream.LeftoverDataException
For use in BiffViewer which may construct Records that don't completely read all available data.
Field Summary
static short MAX_RECORD_DATA_SIZE
Maximum size of a single record (minus the 4 byte header) without a continue
Constructor Summary
RecordInputStream(java.io.InputStream in)
RecordInputStream(java.io.InputStream in, Biff8EncryptionKey key, int initialOffset)
Method Summary
int | available()
int | getNextSid()
short | getSid()
boolean | hasNextRecord() Note - this method is expected to be called only when completed reading the current BIFF record.
void | nextRecord() Moves to the next record in the stream.
int | read(byte[] b, int off, int len)
byte[] | readAllContinuedRemainder() Deprecated. Best to write a input stream that wraps this one where there is special sub record that may overlap continue records.
byte | readByte() Reads an 8 bit, signed value
java.lang.String | readCompressedUnicode(int requestedLength)
double | readDouble()
void | readFully(byte[] buf)
void | readFully(byte[] buf, int off, int len)
int | readInt() Reads a 32 bit, signed value
long | readLong() Reads a 64 bit, signed value
byte[] | readRemainder() Returns the remaining bytes for the current record.
short | readShort() Reads a 16 bit, signed value
java.lang.String | readString()
int | readUByte() Reads an 8 bit, unsigned value
java.lang.String | readUnicodeLEString(int requestedLength) given a byte array of 16-bit unicode characters, compress to 8-bit and return a string { 0x16, 0x00 } -0x16
int | readUShort() Reads a 16 bit, unsigned value.
int | remaining() The remaining number of bytes in the current record.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MAX_RECORD_DATA_SIZE

public static final short MAX_RECORD_DATA_SIZE
Maximum size of a single record (minus the 4 byte header) without a continue

See Also:
Constant Field Values
Constructor Detail

RecordInputStream

public RecordInputStream(java.io.InputStream in)
                  throws RecordFormatException
Throws:
RecordFormatException

RecordInputStream

public RecordInputStream(java.io.InputStream in,
                         Biff8EncryptionKey key,
                         int initialOffset)
                  throws RecordFormatException
Throws:
RecordFormatException
Method Detail

available

public int available()
Specified by:
available in interface LittleEndianInput
Returns:
the number of bytes available in the current BIFF record
See Also:
remaining()

read

public int read(byte[] b,
                int off,
                int len)

getSid

public short getSid()

hasNextRecord

public boolean hasNextRecord()
                      throws RecordInputStream.LeftoverDataException
Note - this method is expected to be called only when completed reading the current BIFF record.

Throws:
RecordInputStream.LeftoverDataException - if this method is called before reaching the end of the current record.

nextRecord

public void nextRecord()
                throws RecordFormatException
Moves to the next record in the stream. Note: The auto continue flag is reset to true

Throws:
RecordFormatException

readByte

public byte readByte()
Reads an 8 bit, signed value

Specified by:
readByte in interface LittleEndianInput

readShort

public short readShort()
Reads a 16 bit, signed value

Specified by:
readShort in interface LittleEndianInput

readInt

public int readInt()
Reads a 32 bit, signed value

Specified by:
readInt in interface LittleEndianInput

readLong

public long readLong()
Reads a 64 bit, signed value

Specified by:
readLong in interface LittleEndianInput

readUByte

public int readUByte()
Reads an 8 bit, unsigned value

Specified by:
readUByte in interface LittleEndianInput

readUShort

public int readUShort()
Reads a 16 bit, unsigned value.

Specified by:
readUShort in interface LittleEndianInput

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput

readFully

public void readFully(byte[] buf)
Specified by:
readFully in interface LittleEndianInput

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput

readString

public java.lang.String readString()

readUnicodeLEString

public java.lang.String readUnicodeLEString(int requestedLength)
given a byte array of 16-bit unicode characters, compress to 8-bit and return a string { 0x16, 0x00 } -0x16

Parameters:
requestedLength - the length of the final string
Returns:
the converted string
Throws:
java.lang.IllegalArgumentException - if len is too large (i.e., there is not enough data in string to create a String of that length)

readCompressedUnicode

public java.lang.String readCompressedUnicode(int requestedLength)

readRemainder

public byte[] readRemainder()
Returns the remaining bytes for the current record.

Returns:
The remaining bytes of the current record.

readAllContinuedRemainder

public byte[] readAllContinuedRemainder()
Deprecated. Best to write a input stream that wraps this one where there is special sub record that may overlap continue records.

Reads all byte data for the current record, including any that overlaps into any following continue records.

remaining

public int remaining()
The remaining number of bytes in the current record.

Returns:
The number of bytes remaining in the current record

getNextSid

public int getNextSid()
Returns:
sid of next record. Can be called after hasNextRecord()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordInputStream.LeftoverDataException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RecordInputStream.LeftoverDataException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.hssf.record.RecordInputStream.LeftoverDataException
All Implemented Interfaces:
java.io.Serializable
Enclosing class:
RecordInputStream
public static final class RecordInputStream.LeftoverDataException
extends java.lang.RuntimeException

For use in BiffViewer which may construct Records that don't completely read all available data. This exception should never be thrown otherwise.

See Also:
Serialized Form

Constructor Summary
RecordInputStream.LeftoverDataException(int sid, int remainingByteCount)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RecordInputStream.LeftoverDataException

public RecordInputStream.LeftoverDataException(int sid,
                                               int remainingByteCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefModeRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RefModeRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.RefModeRecord

public final class RefModeRecord
extends StandardRecord

Title: RefMode Record

Description: Describes which reference mode to use

REFERENCE: PG 376 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short | sid
static short | USE_A1_MODE
static short | USE_R1C1_MODE
Constructor Summary
RefModeRecord()
RefModeRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getMode() get the reference mode to use (HSSF uses/assumes A1)
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setMode(short mode) set the reference mode to use (HSSF uses/assumes A1)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

USE_A1_MODE

public static final short USE_A1_MODE
See Also:
Constant Field Values

USE_R1C1_MODE

public static final short USE_R1C1_MODE
See Also:
Constant Field Values
Constructor Detail

RefModeRecord

public RefModeRecord()

RefModeRecord

public RefModeRecord(RecordInputStream in)
Method Detail

setMode

public void setMode(short mode)
set the reference mode to use (HSSF uses/assumes A1)

Parameters:
mode - the mode to use
See Also:
USE_A1_MODE, USE_R1C1_MODE

getMode

public short getMode()
get the reference mode to use (HSSF uses/assumes A1)

Returns:
mode to use
See Also:
USE_A1_MODE, USE_R1C1_MODE

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefreshAllRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RefreshAllRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.RefreshAllRecord

public final class RefreshAllRecord
extends StandardRecord

Title: Refresh All Record (0x01B7)

Description: Flag whether to refresh all external data when loading a sheet. (which hssf doesn't support anyhow so who really cares?)

REFERENCE: PG 376 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
RefreshAllRecord(boolean refreshAll)
RefreshAllRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getRefreshAll() get whether to refresh all external data when loading a sheet
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setRefreshAll(boolean refreshAll) set whether to refresh all external data when loading a sheet
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

RefreshAllRecord

public RefreshAllRecord(RecordInputStream in)

RefreshAllRecord

public RefreshAllRecord(boolean refreshAll)
Method Detail

setRefreshAll

public void setRefreshAll(boolean refreshAll)
set whether to refresh all external data when loading a sheet

Parameters:
refreshAll - or not

getRefreshAll

public boolean getRefreshAll()
get whether to refresh all external data when loading a sheet

Returns:
refreshall or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RightMarginRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RightMarginRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.RightMarginRecord
All Implemented Interfaces:
Margin
public final class RightMarginRecord
extends StandardRecord
implements Margin

Record for the right margin.

Author:
Shawn Laubach (slaubach at apache dot org)

Field Summary
static short sid
Constructor Summary
RightMarginRecord()
RightMarginRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
double | getMargin() Get the margin field for the RightMargin record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setMargin(double field_1_margin) Set the margin field for the RightMargin record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

RightMarginRecord

public RightMarginRecord()

RightMarginRecord

public RightMarginRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getMargin

public double getMargin()
Get the margin field for the RightMargin record.

Specified by:
getMargin in interface Margin

setMargin

public void setMargin(double field_1_margin)
Set the margin field for the RightMargin record.

Specified by:
setMargin in interface Margin

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RKRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RKRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.CellRecord
                    extended by  org.apache.poi.hssf.record.RKRecord
All Implemented Interfaces:
CellValueRecordInterface
public final class RKRecord
extends CellRecord

Title: RK Record (0x027E)

Description: An internal 32 bit number with the two most significant bits storing the type. This is part of a bizarre scheme to save disk space and memory (gee look at all the other whole records that are in the file just "cause"..,far better to waste processor cycles on this then leave on of those "valuable" records out).

We support this in READ-ONLY mode. HSSF converts these to NUMBER records

REFERENCE: PG 376 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)
See Also:
NumberRecord

Field Summary
static short | RK_IEEE_NUMBER
static short | RK_IEEE_NUMBER_TIMES_100
static short | RK_INTEGER
static short | RK_INTEGER_TIMES_100
static short | sid
Constructor Summary
RKRecord(RecordInputStream in)
Method Summary
protected  void appendValueText(java.lang.StringBuilder sb)
Append specific debug info (used by CellRecord.toString() for the value contained in this record.
 java.lang.Object clone()
protected  java.lang.String getRecordName()
Gets the debug info BIFF record type name (used by CellRecord.toString().
 double getRKNumber()
Extract the value of the number
 short getSid()
return the non static version of the id for this record.
protected  int getValueDataSize()
protected  void serializeValue(LittleEndianOutput out)
writes out the value data for this cell record
Methods inherited from class org.apache.poi.hssf.record.CellRecord
copyBaseFields, getColumn, getDataSize, getRow, getXFIndex, serialize, setColumn, setRow, setXFIndex, toString
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

RK_IEEE_NUMBER

public static final short RK_IEEE_NUMBER
See Also:
Constant Field Values

RK_IEEE_NUMBER_TIMES_100

public static final short RK_IEEE_NUMBER_TIMES_100
See Also:
Constant Field Values

RK_INTEGER

public static final short RK_INTEGER
See Also:
Constant Field Values

RK_INTEGER_TIMES_100

public static final short RK_INTEGER_TIMES_100
See Also:
Constant Field Values
Constructor Detail

RKRecord

public RKRecord(RecordInputStream in)
Method Detail

getRKNumber

public double getRKNumber()
Extract the value of the number

The mechanism for determining the value is dependent on the two low order bits of the raw number. If bit 1 is set, the number is an integer and can be cast directly as a double, otherwise, it's apparently the exponent and mantissa of a double (and the remaining low-order bits of the double's mantissa are 0's).

If bit 0 is set, the result of the conversion to a double is divided by 100; otherwise, the value is left alone.

[insert picture of Screwy Squirrel in full Napoleonic regalia]

Returns:
the value as a proper double (hey, it could happen)

getRecordName

protected java.lang.String getRecordName()
Description copied from class: CellRecord
Gets the debug info BIFF record type name (used by CellRecord.toString().

Specified by:
getRecordName in class CellRecord

appendValueText

protected void appendValueText(java.lang.StringBuilder sb)
Description copied from class: CellRecord
Append specific debug info (used by CellRecord.toString() for the value contained in this record. Trailing new-line should not be appended (superclass does that).

Specified by:
appendValueText in class CellRecord

serializeValue

protected void serializeValue(LittleEndianOutput out)
Description copied from class: CellRecord
writes out the value data for this cell record

Specified by:
serializeValue in class CellRecord

getValueDataSize

protected int getValueDataSize()
Specified by:
getValueDataSize in class CellRecord
Returns:
the size (in bytes) of the value data for this cell record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RowRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class RowRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.RowRecord

public final class RowRecord
extends StandardRecord

Title: Row Record (0x0208)

Description: stores the row information for the sheet.

REFERENCE: PG 379 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static int | ENCODED_SIZE
static short | sid
Constructor Summary
RowRecord(int rowNumber)
RowRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
boolean | getBadFontHeight() get whether the font and row height are not compatible
boolean | getColapsed() get whether or not to colapse this row
protected int | getDataSize()
int | getFirstCol() get the logical col number for the first cell this row (0 based index)
boolean | getFormatted() get whether the row has been formatted (even if its got all blank cells)
short | getHeight() get the height of the row
int | getLastCol() get the logical col number for the last cell this row (0 based index), plus one
short | getOptimize() get whether to optimize or not (set to 0)
short | getOptionFlags() gets the option bitmask.
short | getOutlineLevel() get the outline level of this row
int | getRowNumber() get the logical row number for this row (0 based index)
short | getSid() return the non static version of the id for this record.
short | getXFIndex() if the row is formatted then this is the index to the extended format record
boolean | getZeroHeight() get whether or not to display this row with 0 height
boolean | isEmpty()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBadFontHeight(boolean f) set whether the font and row height are not compatible
void | setColapsed(boolean c) set whether or not to collapse this row
void | setEmpty() Updates the firstCol and lastCol fields to the reserved value (-1) to signify that this row is empty
void | setFirstCol(int col) set the logical col number for the first cell this row (0 based index)
void | setFormatted(boolean f) set whether the row has been formatted (even if its got all blank cells)
void | setHeight(short height) set the height of the row
void | setLastCol(int col)
void | setOptimize(short optimize) set whether to optimize or not (set to 0)
void | setOutlineLevel(short ol) set the outline level of this row
void | setRowNumber(int row) set the logical row number for this row (0 based index)
void | setXFIndex(short index) if the row is formatted then this is the index to the extended format record
void | setZeroHeight(boolean z) set whether or not to display this row with 0 height
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

ENCODED_SIZE

public static final int ENCODED_SIZE
See Also:
Constant Field Values
Constructor Detail

RowRecord

public RowRecord(int rowNumber)

RowRecord

public RowRecord(RecordInputStream in)
Method Detail

setEmpty

public void setEmpty()
Updates the firstCol and lastCol fields to the reserved value (-1) to signify that this row is empty

isEmpty

public boolean isEmpty()

setRowNumber

public void setRowNumber(int row)
set the logical row number for this row (0 based index)

Parameters:
row - - the row number

setFirstCol

public void setFirstCol(int col)
set the logical col number for the first cell this row (0 based index)

Parameters:
col - - the col number

setLastCol

public void setLastCol(int col)
Parameters:
col - - one past the zero-based index to the last cell in this row

setHeight

public void setHeight(short height)
set the height of the row

Parameters:
height - of the row

setOptimize

public void setOptimize(short optimize)
set whether to optimize or not (set to 0)

Parameters:
optimize - (set to 0)

setOutlineLevel

public void setOutlineLevel(short ol)
set the outline level of this row

Parameters:
ol - - the outline level

setColapsed

public void setColapsed(boolean c)
set whether or not to collapse this row

Parameters:
c - - collapse or not

setZeroHeight

public void setZeroHeight(boolean z)
set whether or not to display this row with 0 height

Parameters:
z - height is zero or not.

setBadFontHeight

public void setBadFontHeight(boolean f)
set whether the font and row height are not compatible

Parameters:
f - true if they aren't compatible (damn not logic)

setFormatted

public void setFormatted(boolean f)
set whether the row has been formatted (even if its got all blank cells)

Parameters:
f - formatted or not

setXFIndex

public void setXFIndex(short index)
if the row is formatted then this is the index to the extended format record

Parameters:
index - to the XF record
See Also:
ExtendedFormatRecord

getRowNumber

public int getRowNumber()
get the logical row number for this row (0 based index)

Returns:
row - the row number

getFirstCol

public int getFirstCol()
get the logical col number for the first cell this row (0 based index)

Returns:
col - the col number

getLastCol

public int getLastCol()
get the logical col number for the last cell this row (0 based index), plus one

Returns:
col - the last col index + 1

getHeight

public short getHeight()
get the height of the row

Returns:
height of the row

getOptimize

public short getOptimize()
get whether to optimize or not (set to 0)

Returns:
optimize (set to 0)

getOptionFlags

public short getOptionFlags()
gets the option bitmask. (use the individual bit setters that refer to this method)

Returns:
options - the bitmask

getOutlineLevel

public short getOutlineLevel()
get the outline level of this row

Returns:
ol - the outline level
See Also:
getOptionFlags()

getColapsed

public boolean getColapsed()
get whether or not to colapse this row

Returns:
c - colapse or not
See Also:
getOptionFlags()

getZeroHeight

public boolean getZeroHeight()
get whether or not to display this row with 0 height

Returns:
- z height is zero or not.
See Also:
getOptionFlags()

getBadFontHeight

public boolean getBadFontHeight()
get whether the font and row height are not compatible

Returns:
- f -true if they aren't compatible (damn not logic)
See Also:
getOptionFlags()

getFormatted

public boolean getFormatted()
get whether the row has been formatted (even if its got all blank cells)

Returns:
formatted or not
See Also:
getOptionFlags()

getXFIndex

public short getXFIndex()
if the row is formatted then this is the index to the extended format record

Returns:
index to the XF record or bogus value (undefined) if isn't formatted
See Also:
ExtendedFormatRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SaveRecalcRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SaveRecalcRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SaveRecalcRecord

public final class SaveRecalcRecord
extends StandardRecord

Title: Save Recalc Record

Description: defines whether to recalculate before saving (set to true)

REFERENCE: PG 381 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
SaveRecalcRecord()
SaveRecalcRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getRecalc() get whether to recalculate formulas/etc before saving or not
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setRecalc(boolean recalc) set whether to recalculate formulas/etc before saving or not
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SaveRecalcRecord

public SaveRecalcRecord()

SaveRecalcRecord

public SaveRecalcRecord(RecordInputStream in)
Method Detail

setRecalc

public void setRecalc(boolean recalc)
set whether to recalculate formulas/etc before saving or not

Parameters:
recalc - - whether to recalculate or not

getRecalc

public boolean getRecalc()
get whether to recalculate formulas/etc before saving or not

Returns:
recalc - whether to recalculate or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScenarioProtectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class ScenarioProtectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.ScenarioProtectRecord

public final class ScenarioProtectRecord
extends StandardRecord

Title: Scenario Protect Record

Description: I have no idea what a Scenario is or why on would want to protect it with the lamest "security" ever invented. However this record tells excel "I want to protect my scenarios" (0xAF) with lame security. It appears in conjunction with the PASSWORD and PROTECT records as well as its object protect cousin.

REFERENCE: PG 383 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
ScenarioProtectRecord()
ScenarioProtectRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getProtect() get whether the sheet is protected or not
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setProtect(boolean protect) set whether the sheet is protected or not
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ScenarioProtectRecord

public ScenarioProtectRecord()

ScenarioProtectRecord

public ScenarioProtectRecord(RecordInputStream in)
Method Detail

setProtect

public void setProtect(boolean protect)
set whether the sheet is protected or not

Parameters:
protect - whether to protect the sheet or not

getProtect

public boolean getProtect()
get whether the sheet is protected or not

Returns:
whether to protect the sheet or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SCLRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SCLRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SCLRecord

public final class SCLRecord
extends StandardRecord

Specifies the window's zoom magnification.

If this record isn't present then the windows zoom is 100%. see p384 Excel Dev Kit

Author:
Andrew C. Oliver (acoliver at apache.org)

Field Summary
static short sid
Constructor Summary
SCLRecord()
SCLRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getDenominator() Get the denominator field for the SCL record.
short | getNumerator() Get the numerator field for the SCL record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setDenominator(short field_2_denominator) Set the denominator field for the SCL record.
void | setNumerator(short field_1_numerator) Set the numerator field for the SCL record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SCLRecord

public SCLRecord()

SCLRecord

public SCLRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getNumerator

public short getNumerator()
Get the numerator field for the SCL record.

setNumerator

public void setNumerator(short field_1_numerator)
Set the numerator field for the SCL record.

getDenominator

public short getDenominator()
Get the denominator field for the SCL record.

setDenominator

public void setDenominator(short field_2_denominator)
Set the denominator field for the SCL record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectionRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SelectionRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SelectionRecord

public final class SelectionRecord
extends StandardRecord

Title: Selection Record (0x001D)

Description: shows the user's selection on the sheet for write set num refs to 0

REFERENCE: PG 291 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au), Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
SelectionRecord(int activeCellRow, int activeCellCol)
Creates a default selection record (cell A1, in pane ID 3)
SelectionRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
int | getActiveCellCol() get the active cell's col
int | getActiveCellRef() get the active cell's reference number
int | getActiveCellRow() get the active cell's row
protected int | getDataSize()
byte | getPane()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setActiveCellCol(short col) set the active cell's col
void | setActiveCellRef(short ref) set the active cell's reference number
void | setActiveCellRow(int row) set the active cell's row
void | setPane(byte pane) set which window pane this is for
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SelectionRecord

public SelectionRecord(int activeCellRow,
                       int activeCellCol)
Creates a default selection record (cell A1, in pane ID 3)

SelectionRecord

public SelectionRecord(RecordInputStream in)
Method Detail

setPane

public void setPane(byte pane)
set which window pane this is for

setActiveCellRow

public void setActiveCellRow(int row)
set the active cell's row

Parameters:
row - number of active cell

setActiveCellCol

public void setActiveCellCol(short col)
set the active cell's col

Parameters:
col - number of active cell

setActiveCellRef

public void setActiveCellRef(short ref)
set the active cell's reference number

Parameters:
ref - number of active cell

getPane

public byte getPane()
Returns:
the pane ID which window pane this is for

getActiveCellRow

public int getActiveCellRow()
get the active cell's row

Returns:
row number of active cell

getActiveCellCol

public int getActiveCellCol()
get the active cell's col

Returns:
col number of active cell

getActiveCellRef

public int getActiveCellRef()
get the active cell's reference number

Returns:
ref number of active cell

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SharedFormulaRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SharedFormulaRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SharedValueRecordBase
                    extended by  org.apache.poi.hssf.record.SharedFormulaRecord

public final class SharedFormulaRecord
extends SharedValueRecordBase

Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times. We should recognize this record and serialize as is since this is used when reading templates.

Note: the documentation says that the SID is BC where biffviewer reports 4BC. The hex dump shows that the two byte sid representation to be 'BC 04' that is consistent with the other high byte record types.

Author:
Danny Mui at apache dot org

Field Summary
static short sid
Constructor Summary
SharedFormulaRecord()
SharedFormulaRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getExtraDataSize()
Ptg[] | getFormulaTokens(FormulaRecord formula)
short | getSid() return the non static version of the id for this record.
boolean | isFormulaSame(SharedFormulaRecord other)
protected void | serializeExtraData(LittleEndianOutput out)
java.lang.String | toString() print a sort of string representation ([SHARED FORMULA RECORD] id = x [/SHARED FORMULA RECORD])
Methods inherited from class org.apache.poi.hssf.record.SharedValueRecordBase
getDataSize, getFirstColumn, getFirstRow, getLastColumn, getLastRow, getRange, isFirstCell, isInRange, serialize
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SharedFormulaRecord

public SharedFormulaRecord()

SharedFormulaRecord

public SharedFormulaRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

serializeExtraData

protected void serializeExtraData(LittleEndianOutput out)
Specified by:
serializeExtraData in class SharedValueRecordBase

getExtraDataSize

protected int getExtraDataSize()
Specified by:
getExtraDataSize in class SharedValueRecordBase

toString

public java.lang.String toString()
print a sort of string representation ([SHARED FORMULA RECORD] id = x [/SHARED FORMULA RECORD])

Overrides:
toString in class Record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getFormulaTokens

public Ptg[] getFormulaTokens(FormulaRecord formula)
Returns:
the equivalent Ptg array that the formula would have, were it not shared.

clone

public java.lang.Object clone()
Overrides:
clone in class Record

isFormulaSame

public boolean isFormulaSame(SharedFormulaRecord other)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SharedValueRecordBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SharedValueRecordBase

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SharedValueRecordBase
Direct Known Subclasses:
ArrayRecord, SharedFormulaRecord, TableRecord
public abstract class SharedValueRecordBase
extends StandardRecord

Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.

Author:
Josh Micich

Constructor Summary
protected | SharedValueRecordBase()
protected | SharedValueRecordBase(CellRangeAddress8Bit range)
 | SharedValueRecordBase(LittleEndianInput in) reads only the range (1 CellRangeAddress8Bit) from the stream
Method Summary
protected int | getDataSize()
protected abstract int | getExtraDataSize()
int | getFirstColumn()
int | getFirstRow()
int | getLastColumn()
int | getLastRow()
CellRangeAddress8Bit | getRange()
boolean | isFirstCell(int rowIx, int colIx)
boolean | isInRange(int rowIx, int colIx)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
protected abstract void | serializeExtraData(LittleEndianOutput out)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, getSid, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SharedValueRecordBase

protected SharedValueRecordBase(CellRangeAddress8Bit range)

SharedValueRecordBase

protected SharedValueRecordBase()

SharedValueRecordBase

public SharedValueRecordBase(LittleEndianInput in)
reads only the range (1 CellRangeAddress8Bit) from the stream

Method Detail

getRange

public final CellRangeAddress8Bit getRange()
Returns:
the range of cells that this record is shared across. Never null.

getFirstRow

public final int getFirstRow()

getLastRow

public final int getLastRow()

getFirstColumn

public final int getFirstColumn()

getLastColumn

public final int getLastColumn()

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getExtraDataSize

protected abstract int getExtraDataSize()

serializeExtraData

protected abstract void serializeExtraData(LittleEndianOutput out)

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

isInRange

public final boolean isInRange(int rowIx,
                               int colIx)
Returns:
true if (rowIx, colIx) is within the range (getRange()) of this shared value object.

isFirstCell

public final boolean isFirstCell(int rowIx,
                                 int colIx)
Returns:
true if (rowIx, colIx) describes the first cell in this shared value object's range (getRange())
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SSTRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SSTRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.cont.ContinuableRecord
                extended by  org.apache.poi.hssf.record.SSTRecord

public final class SSTRecord
extends ContinuableRecord

Title: Static String Table Record (0x00FC)

Description: This holds all the strings for LabelSSTRecords.

REFERENCE: PG 389 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Marc Johnson (mjohnson at apache dot org), Glen Stampoultzis (glens at apache.org)
See Also:
LabelSSTRecord, ContinueRecord

Field Summary
static short sid
Constructor Summary
SSTRecord()
SSTRecord(RecordInputStream in)
Fill the fields from the data
Method Summary
int | addString(UnicodeString string) Add a string.
int | calcExtSSTRecordSize() Calculates the size in bytes of the EXTSST record as it would be if the record was serialized.
ExtSSTRecord | createExtSSTRecord(int sstOffset) Creates an extended string record based on the current contents of the current SST record.
int | getNumStrings()
int | getNumUniqueStrings()
short | getSid() return the non static version of the id for this record.
UnicodeString | getString(int id) Get a particular string by its index
protected void | serialize(ContinuableRecordOutput out) Serializes this record's content to the supplied data output. The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method.
java.lang.String | toString() Return a debugging string representation
Methods inherited from class org.apache.poi.hssf.record.cont.ContinuableRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SSTRecord

public SSTRecord()

SSTRecord

public SSTRecord(RecordInputStream in)
Fill the fields from the data

The data consists of sets of string data. This string data is arranged as follows:

 short  string_length;   // length of string data
 byte   string_flag;     // flag specifying special string
                         // handling
 short  run_count;       // optional count of formatting runs
 int    extend_length;   // optional extension length
 char[] string_data;     // string data, can be byte[] or
                         // short[] (length of array is
                         // string_length)
 int[]  formatting_runs; // optional formatting runs (length of
                         // array is run_count)
 byte[] extension;       // optional extension (length of array
                         // is extend_length)

The string_flag is bit mapped as follows:

Bit number | Meaning if 0 | Meaning if 1
0 | string_data is byte[] | string_data is short[]
1 | Should always be 0 | string_flag is defective
2 | extension is not included | extension is included
3 | formatting run data is not included | formatting run data is included
4 | Should always be 0 | string_flag is defective
5 | Should always be 0 | string_flag is defective
6 | Should always be 0 | string_flag is defective
7 | Should always be 0 | string_flag is defective

We can handle eating the overhead associated with bits 2 or 3 (or both) being set, but we have no idea what to do with the associated data. The UnicodeString class can handle the byte[] vs short[] nature of the actual string data

Parameters:
in - the RecordInputstream to read the record from
Method Detail

addString

public int addString(UnicodeString string)
Add a string.

Parameters:
string - string to be added
Returns:
the index of that string in the table

getNumStrings

public int getNumStrings()
Returns:
number of strings

getNumUniqueStrings

public int getNumUniqueStrings()
Returns:
number of unique strings

getString

public UnicodeString getString(int id)
Get a particular string by its index

Parameters:
id - index into the array of strings
Returns:
the desired string

toString

public java.lang.String toString()
Return a debugging string representation

Overrides:
toString in class Record
Returns:
string representation

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

protected void serialize(ContinuableRecordOutput out)
Description copied from class: ContinuableRecord
Serializes this record's content to the supplied data output.
The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method. Simple data types can be written with the standard LittleEndianOutput methods. Methods from ContinuableRecordOutput can be used to serialize strings (with ContinueRecords being written as required). If necessary, implementors can explicitly start ContinueRecords (regardless of the amount of remaining space).

Specified by:
serialize in class ContinuableRecord
Parameters:
out - a data output stream

createExtSSTRecord

public ExtSSTRecord createExtSSTRecord(int sstOffset)
Creates an extended string record based on the current contents of the current SST record. The offset within the stream to the SST record is required because the extended string record points directly to the strings in the SST record.

NOTE: THIS FUNCTION MUST ONLY BE CALLED AFTER THE SST RECORD HAS BEEN SERIALIZED.

Parameters:
sstOffset - The offset in the stream to the start of the SST record.
Returns:
The new SST record.

calcExtSSTRecordSize

public int calcExtSSTRecordSize()
Calculates the size in bytes of the EXTSST record as it would be if the record was serialized.

Returns:
The size of the ExtSST record in bytes.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StandardRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class StandardRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
Direct Known Subclasses:
AreaFormatRecord, AreaRecord, AutoFilterInfoRecord, AxisLineFormatRecord, AxisOptionsRecord, AxisParentRecord, AxisRecord, AxisUsedRecord, BackupRecord, BarRecord, BeginRecord, BlankRecord, BOFRecord, BookBoolRecord, BottomMarginRecord, BoundSheetRecord, CalcCountRecord, CalcModeRecord, CategorySeriesAxisRecord, CatLabRecord, CellRecord, CFHeaderRecord, CFRuleRecord, ChartEndBlockRecord, ChartEndObjectRecord, ChartFormatRecord, ChartFRTInfoRecord, ChartRecord, ChartStartBlockRecord, ChartStartObjectRecord, ChartTitleFormatRecord, CodepageRecord, ColumnInfoRecord, ContinueRecord, CountryRecord, CRNCountRecord, CRNRecord, DataFormatRecord, DataItemRecord, DataLabelExtensionRecord, DateWindow1904Record, DatRecord, DBCellRecord, DConRefRecord, DefaultColWidthRecord, DefaultDataLabelTextPropertiesRecord, DefaultRowHeightRecord, DeltaRecord, DimensionsRecord, DrawingRecord, DrawingSelectionRecord, DSFRecord, DVALRecord, DVRecord, EndRecord, EOFRecord, ExtendedFormatRecord, ExtendedPivotTableViewFieldsRecord, ExternalNameRecord, ExternSheetRecord, FeatHdrRecord, FeatRecord, FilePassRecord, FileSharingRecord, FnGroupCountRecord, FontBasisRecord, FontIndexRecord, FontRecord, FormatRecord, FrameRecord, GridsetRecord, GutsRecord, HCenterRecord, HeaderFooterBase, HeaderFooterRecord, HideObjRecord, HyperlinkRecord, IndexRecord, InterfaceEndRecord, InterfaceHdrRecord, IterationRecord, LeftMarginRecord, LegendRecord, LineFormatRecord, LinkedDataRecord, MergeCellsRecord, MMSRecord, MulBlankRecord, MulRKRecord, NameCommentRecord, NoteRecord, NumberFormatIndexRecord, ObjectLinkRecord, ObjectProtectRecord, PageBreakRecord, PageItemRecord, PaletteRecord, PaneRecord, PasswordRecord, PasswordRev4Record, PlotAreaRecord, PlotGrowthRecord, PrecisionRecord, PrintGridlinesRecord, PrintHeadersRecord, PrintSetupRecord, ProtectionRev4Record, ProtectRecord, RecalcIdRecord, RefModeRecord, RefreshAllRecord, RightMarginRecord, RowRecord, SaveRecalcRecord, ScenarioProtectRecord, SCLRecord, SelectionRecord, SeriesChartGroupIndexRecord, SeriesIndexRecord, SeriesLabelsRecord, SeriesListRecord, SeriesRecord, SeriesTextRecord, SeriesToChartGroupRecord, SharedValueRecordBase, SheetPropertiesRecord, StreamIDRecord, StyleRecord, SupBookRecord, TabIdRecord, TableStylesRecord, TextRecord, TickRecord, TopMarginRecord, UncalcedRecord, UnitsRecord, UnknownRecord, UserSViewBegin, UserSViewEnd, UseSelFSRecord, ValueRangeRecord, VCenterRecord, ViewDefinitionRecord, ViewFieldsRecord, ViewSourceRecord, WindowOneRecord, WindowProtectRecord, WindowTwoRecord, WriteAccessRecord, WriteProtectRecord, WSBoolRecord
public abstract class StandardRecord
extends Record

Subclasses of this class (the majority of BIFF records) are non-continuable. This allows for some simplification of serialization logic

Author:
Josh Micich

Constructor Summary
StandardRecord()
Method Summary
protected abstract  int getDataSize()
 int getRecordSize()
gives the current serialized size of the record.
 int serialize(int offset, byte[] data)
Write the data content of this BIFF record including the sid and record length.
The subclass must write the exact number of bytes as reported by RecordBase.getRecordSize()}
protected abstract  void serialize(LittleEndianOutput out)
Write the data content of this BIFF record.
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, getSid, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StandardRecord

public StandardRecord()
Method Detail

getDataSize

protected abstract int getDataSize()

getRecordSize

public final int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase

serialize

public final int serialize(int offset,
                           byte[] data)
Write the data content of this BIFF record including the sid and record length.
The subclass must write the exact number of bytes as reported by RecordBase.getRecordSize()}

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

serialize

protected abstract void serialize(LittleEndianOutput out)
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class StringRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.cont.ContinuableRecord
                extended by  org.apache.poi.hssf.record.StringRecord

public final class StringRecord
extends ContinuableRecord

STRING (0x0207)

Stores the cached result of a text formula

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
StringRecord()
StringRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getSid() return the non static version of the id for this record.
java.lang.String | getString()
protected void | serialize(ContinuableRecordOutput out) Serializes this record's content to the supplied data output. The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method.
void | setString(java.lang.String string) Sets the string represented by this record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.cont.ContinuableRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

StringRecord

public StringRecord()

StringRecord

public StringRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

serialize

protected void serialize(ContinuableRecordOutput out)
Description copied from class: ContinuableRecord
Serializes this record's content to the supplied data output.
The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method. Simple data types can be written with the standard LittleEndianOutput methods. Methods from ContinuableRecordOutput can be used to serialize strings (with ContinueRecords being written as required). If necessary, implementors can explicitly start ContinueRecords (regardless of the amount of remaining space).

Specified by:
serialize in class ContinuableRecord
Parameters:
out - a data output stream

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getString

public java.lang.String getString()
Returns:
The string represented by this record.

setString

public void setString(java.lang.String string)
Sets the string represented by this record.

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StyleRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class StyleRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.StyleRecord

public final class StyleRecord
extends StandardRecord

Title: Style Record (0x0293)

Description: Describes a builtin to the gui or user defined style

REFERENCE: PG 390 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), aviks : string fixes for UserDefined Style

Field Summary
static short sid
Constructor Summary
StyleRecord()
creates a new style record, initially set to 'built-in'
StyleRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
java.lang.String | getName() get the style's name
short | getSid() return the non static version of the id for this record.
int | getXFIndex() get the actual index of the style extended format record
boolean | isBuiltin()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBuiltinStyle(int builtinStyleId) if this is a builtin style set the number of the built in style
void | setName(java.lang.String name) set the style's name
void | setOutlineStyleLevel(int level) set the row or column level of the style (if builtin 1||2)
void | setXFIndex(int xfIndex) set the actual index of the style extended format record
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

StyleRecord

public StyleRecord()
creates a new style record, initially set to 'built-in'

StyleRecord

public StyleRecord(RecordInputStream in)
Method Detail

setXFIndex

public void setXFIndex(int xfIndex)
set the actual index of the style extended format record

Parameters:
xfIndex - of the xf record

getXFIndex

public int getXFIndex()
get the actual index of the style extended format record

Returns:
index of the xf record
See Also:
getXFIndex()

setName

public void setName(java.lang.String name)
set the style's name

Parameters:
name - of the style

setBuiltinStyle

public void setBuiltinStyle(int builtinStyleId)
if this is a builtin style set the number of the built in style

Parameters:
builtinStyleId - style number (0-7)

setOutlineStyleLevel

public void setOutlineStyleLevel(int level)
set the row or column level of the style (if builtin 1||2)

isBuiltin

public boolean isBuiltin()

getName

public java.lang.String getName()
get the style's name

Returns:
name of the style

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SubRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.SubRecord
Direct Known Subclasses:
CommonObjectDataSubRecord, EmbeddedObjectRefSubRecord, EndSubRecord, FtCblsSubRecord, GroupMarkerSubRecord, LbsDataSubRecord, NoteStructureSubRecord
public abstract class SubRecord
extends java.lang.Object

Subrecords are part of the OBJ class.

Constructor Summary
protected SubRecord()
Method Summary
abstract java.lang.Object | clone()
static SubRecord | createSubRecord(LittleEndianInput in, int cmoOt) read a sub-record from the supplied stream
protected abstract int | getDataSize()
boolean | isTerminating() Wether this record terminates the sub-record stream.
byte[] | serialize()
abstract void | serialize(LittleEndianOutput out)
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubRecord

protected SubRecord()
Method Detail

createSubRecord

public static SubRecord createSubRecord(LittleEndianInput in,
                                        int cmoOt)
read a sub-record from the supplied stream

Parameters:
in - the stream to read from
cmoOt - the objectType field of the containing CommonObjectDataSubRecord, we need it to propagate to next sub-records as it defines what data follows
Returns:
the created sub-record

getDataSize

protected abstract int getDataSize()
Returns:
the size of the data for this record (which is always 4 bytes less than the total record size). Note however, that ushort encoded after the record sid is usually but not always the data size.

serialize

public byte[] serialize()

serialize

public abstract void serialize(LittleEndianOutput out)

clone

public abstract java.lang.Object clone()
Overrides:
clone in class java.lang.Object

isTerminating

public boolean isTerminating()
Wether this record terminates the sub-record stream. There are two cases when this method must be overridden and return true - EndSubRecord (sid = 0x00) - LbsDataSubRecord (sid = 0x12)

Returns:
whether this record is the last in the sub-record stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SupBookRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class SupBookRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SupBookRecord

public final class SupBookRecord
extends StandardRecord

Title: Sup Book - EXTERNALBOOK (0x01AE)

Description: A External Workbook Description (Supplemental Book) Its only a dummy record for making new ExternSheet Record

REFERENCE: 5.38

Author:
Libin Roman (Vista Portal LDT. Developer), Andrew C. Oliver (acoliver@apache.org)

Field Summary
protected static char | CH_ALT_STARTUP_DIR
protected static char | CH_DOWN_DIR
protected static char | CH_LIB_DIR
protected static char | CH_LONG_VOLUME
protected static char | CH_SAME_VOLUME
protected static char | CH_STARTUP_DIR
protected static char | CH_UP_DIR
protected static char | CH_VOLUME
protected static java.lang.String | PATH_SEPERATOR
static short | sid
Constructor Summary
SupBookRecord(RecordInputStream in)
called by the constructor, should set class level fields.
SupBookRecord(java.lang.String url, java.lang.String[] sheetNames)
Method Summary
static SupBookRecord | createAddInFunctions()
static SupBookRecord | createExternalReferences(java.lang.String url, java.lang.String[] sheetNames)
static SupBookRecord | createInternalReferences(short numberOfSheets)
protected int | getDataSize()
short | getNumberOfSheets()
java.lang.String[] | getSheetNames()
short | getSid() return the non static version of the id for this record.
java.lang.String | getURL()
boolean | isAddInFunctions()
boolean | isExternalReferences()
boolean | isInternalReferences()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setNumberOfSheets(short number)
void | setURL(java.lang.String pUrl)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

CH_VOLUME

protected static final char CH_VOLUME
See Also:
Constant Field Values

CH_SAME_VOLUME

protected static final char CH_SAME_VOLUME
See Also:
Constant Field Values

CH_DOWN_DIR

protected static final char CH_DOWN_DIR
See Also:
Constant Field Values

CH_UP_DIR

protected static final char CH_UP_DIR
See Also:
Constant Field Values

CH_LONG_VOLUME

protected static final char CH_LONG_VOLUME
See Also:
Constant Field Values

CH_STARTUP_DIR

protected static final char CH_STARTUP_DIR
See Also:
Constant Field Values

CH_ALT_STARTUP_DIR

protected static final char CH_ALT_STARTUP_DIR
See Also:
Constant Field Values

CH_LIB_DIR

protected static final char CH_LIB_DIR
See Also:
Constant Field Values

PATH_SEPERATOR

protected static final java.lang.String PATH_SEPERATOR
Constructor Detail

SupBookRecord

public SupBookRecord(java.lang.String url,
                     java.lang.String[] sheetNames)

SupBookRecord

public SupBookRecord(RecordInputStream in)
called by the constructor, should set class level fields. Should throw runtime exception for bad/incomplete data.

Parameters:
in - the stream to read from
Method Detail

createInternalReferences

public static SupBookRecord createInternalReferences(short numberOfSheets)

createAddInFunctions

public static SupBookRecord createAddInFunctions()

createExternalReferences

public static SupBookRecord createExternalReferences(java.lang.String url,
                                                     java.lang.String[] sheetNames)

isExternalReferences

public boolean isExternalReferences()

isInternalReferences

public boolean isInternalReferences()

isAddInFunctions

public boolean isAddInFunctions()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

setNumberOfSheets

public void setNumberOfSheets(short number)

getNumberOfSheets

public short getNumberOfSheets()

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getURL

public java.lang.String getURL()

getSheetNames

public java.lang.String[] getSheetNames()

setURL

public void setURL(java.lang.String pUrl)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabIdRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class TabIdRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.TabIdRecord

public final class TabIdRecord
extends StandardRecord

Title: Sheet Tab Index Array Record (0x013D)

Description: Contains an array of sheet id's. Sheets always keep their ID regardless of what their name is.

REFERENCE: PG 412 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
short[] | _tabids
static short | sid
Constructor Summary
TabIdRecord()
TabIdRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setTabIdArray(short[] array) set the tab array.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

_tabids

public short[] _tabids
Constructor Detail

TabIdRecord

public TabIdRecord()

TabIdRecord

public TabIdRecord(RecordInputStream in)
Method Detail

setTabIdArray

public void setTabIdArray(short[] array)
set the tab array. (0,1,2).

Parameters:
array - of tab id's {0,1,2}

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class TableRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.SharedValueRecordBase
                    extended by  org.apache.poi.hssf.record.TableRecord

public final class TableRecord
extends SharedValueRecordBase

DATATABLE (0x0236)

TableRecord - The record specifies a data table. This record is preceded by a single Formula record that defines the first cell in the data table, which should only contain a single Ptg, TblPtg. See p536 of the June 08 binary docs

Field Summary
static short sid
Constructor Summary
TableRecord(CellRangeAddress8Bit range)
TableRecord(RecordInputStream in)
Method Summary
int | getColInputCol()
int | getColInputRow()
protected int | getExtraDataSize()
int | getFlags()
int | getRowInputCol()
int | getRowInputRow()
short | getSid() return the non static version of the id for this record.
boolean | isAlwaysCalc()
boolean | isColDeleted()
boolean | isOneNotTwoVar()
boolean | isRowDeleted()
boolean | isRowOrColInpCell()
protected void | serializeExtraData(LittleEndianOutput out)
void | setAlwaysCalc(boolean flag)
void | setColDeleted(boolean flag)
void | setColInputCol(int colInputCol)
void | setColInputRow(int colInputRow)
void | setFlags(int flags)
void | setOneNotTwoVar(boolean flag)
void | setRowDeleted(boolean flag)
void | setRowInputCol(int rowInputCol)
void | setRowInputRow(int rowInputRow)
void | setRowOrColInpCell(boolean flag)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.SharedValueRecordBase
getDataSize, getFirstColumn, getFirstRow, getLastColumn, getLastRow, getRange, isFirstCell, isInRange, serialize
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

TableRecord

public TableRecord(RecordInputStream in)

TableRecord

public TableRecord(CellRangeAddress8Bit range)
Method Detail

getFlags

public int getFlags()

setFlags

public void setFlags(int flags)

getRowInputRow

public int getRowInputRow()

setRowInputRow

public void setRowInputRow(int rowInputRow)

getColInputRow

public int getColInputRow()

setColInputRow

public void setColInputRow(int colInputRow)

getRowInputCol

public int getRowInputCol()

setRowInputCol

public void setRowInputCol(int rowInputCol)

getColInputCol

public int getColInputCol()

setColInputCol

public void setColInputCol(int colInputCol)

isAlwaysCalc

public boolean isAlwaysCalc()

setAlwaysCalc

public void setAlwaysCalc(boolean flag)

isRowOrColInpCell

public boolean isRowOrColInpCell()

setRowOrColInpCell

public void setRowOrColInpCell(boolean flag)

isOneNotTwoVar

public boolean isOneNotTwoVar()

setOneNotTwoVar

public void setOneNotTwoVar(boolean flag)

isColDeleted

public boolean isColDeleted()

setColDeleted

public void setColDeleted(boolean flag)

isRowDeleted

public boolean isRowDeleted()

setRowDeleted

public void setRowDeleted(boolean flag)

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getExtraDataSize

protected int getExtraDataSize()
Specified by:
getExtraDataSize in class SharedValueRecordBase

serializeExtraData

protected void serializeExtraData(LittleEndianOutput out)
Specified by:
serializeExtraData in class SharedValueRecordBase

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableStylesRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class TableStylesRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.TableStylesRecord

public final class TableStylesRecord
extends StandardRecord

TABLESTYLES (0x088E)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
TableStylesRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

TableStylesRecord

public TableStylesRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextObjectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class TextObjectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.cont.ContinuableRecord
                extended by  org.apache.poi.hssf.record.TextObjectRecord

public final class TextObjectRecord
extends ContinuableRecord

The TXO record (0x01B6) is used to define the properties of a text box. It is followed by two or more continue records unless there is no actual text. The first continue records contain the text data and the last continue record contains the formatting runs.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | HORIZONTAL_TEXT_ALIGNMENT_CENTERED
static short | HORIZONTAL_TEXT_ALIGNMENT_JUSTIFIED
static short | HORIZONTAL_TEXT_ALIGNMENT_LEFT_ALIGNED
static short | HORIZONTAL_TEXT_ALIGNMENT_RIGHT_ALIGNED
static short | sid
static short | TEXT_ORIENTATION_NONE
static short | TEXT_ORIENTATION_ROT_LEFT
static short | TEXT_ORIENTATION_ROT_RIGHT
static short | TEXT_ORIENTATION_TOP_TO_BOTTOM
static short | VERTICAL_TEXT_ALIGNMENT_BOTTOM
static short | VERTICAL_TEXT_ALIGNMENT_CENTER
static short | VERTICAL_TEXT_ALIGNMENT_JUSTIFY
static short | VERTICAL_TEXT_ALIGNMENT_TOP
Constructor Summary
TextObjectRecord()
TextObjectRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
int | getHorizontalTextAlignment()
Ptg | getLinkRefPtg()
short | getSid() return the non static version of the id for this record.
HSSFRichTextString | getStr()
int | getTextOrientation() Get the text orientation field for the TextObjectBase record.
int | getVerticalTextAlignment()
boolean | isTextLocked()
protected void | serialize(ContinuableRecordOutput out) Serializes this record's content to the supplied data output. The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method.
void | setHorizontalTextAlignment(int value) Sets the Horizontal text alignment field value.
void | setStr(HSSFRichTextString str)
void | setTextLocked(boolean value) Sets the text locked field value.
void | setTextOrientation(int textOrientation) Set the text orientation field for the TextObjectBase record.
void | setVerticalTextAlignment(int value) Sets the Vertical text alignment field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.cont.ContinuableRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

HORIZONTAL_TEXT_ALIGNMENT_LEFT_ALIGNED

public static final short HORIZONTAL_TEXT_ALIGNMENT_LEFT_ALIGNED
See Also:
Constant Field Values

HORIZONTAL_TEXT_ALIGNMENT_CENTERED

public static final short HORIZONTAL_TEXT_ALIGNMENT_CENTERED
See Also:
Constant Field Values

HORIZONTAL_TEXT_ALIGNMENT_RIGHT_ALIGNED

public static final short HORIZONTAL_TEXT_ALIGNMENT_RIGHT_ALIGNED
See Also:
Constant Field Values

HORIZONTAL_TEXT_ALIGNMENT_JUSTIFIED

public static final short HORIZONTAL_TEXT_ALIGNMENT_JUSTIFIED
See Also:
Constant Field Values

VERTICAL_TEXT_ALIGNMENT_TOP

public static final short VERTICAL_TEXT_ALIGNMENT_TOP
See Also:
Constant Field Values

VERTICAL_TEXT_ALIGNMENT_CENTER

public static final short VERTICAL_TEXT_ALIGNMENT_CENTER
See Also:
Constant Field Values

VERTICAL_TEXT_ALIGNMENT_BOTTOM

public static final short VERTICAL_TEXT_ALIGNMENT_BOTTOM
See Also:
Constant Field Values

VERTICAL_TEXT_ALIGNMENT_JUSTIFY

public static final short VERTICAL_TEXT_ALIGNMENT_JUSTIFY
See Also:
Constant Field Values

TEXT_ORIENTATION_NONE

public static final short TEXT_ORIENTATION_NONE
See Also:
Constant Field Values

TEXT_ORIENTATION_TOP_TO_BOTTOM

public static final short TEXT_ORIENTATION_TOP_TO_BOTTOM
See Also:
Constant Field Values

TEXT_ORIENTATION_ROT_RIGHT

public static final short TEXT_ORIENTATION_ROT_RIGHT
See Also:
Constant Field Values

TEXT_ORIENTATION_ROT_LEFT

public static final short TEXT_ORIENTATION_ROT_LEFT
See Also:
Constant Field Values
Constructor Detail

TextObjectRecord

public TextObjectRecord()

TextObjectRecord

public TextObjectRecord(RecordInputStream in)
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

protected void serialize(ContinuableRecordOutput out)
Description copied from class: ContinuableRecord
Serializes this record's content to the supplied data output.
The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method. Simple data types can be written with the standard LittleEndianOutput methods. Methods from ContinuableRecordOutput can be used to serialize strings (with ContinueRecords being written as required). If necessary, implementors can explicitly start ContinueRecords (regardless of the amount of remaining space).

Specified by:
serialize in class ContinuableRecord
Parameters:
out - a data output stream

setHorizontalTextAlignment

public void setHorizontalTextAlignment(int value)
Sets the Horizontal text alignment field value.

getHorizontalTextAlignment

public int getHorizontalTextAlignment()
Returns:
the Horizontal text alignment field value.

setVerticalTextAlignment

public void setVerticalTextAlignment(int value)
Sets the Vertical text alignment field value.

getVerticalTextAlignment

public int getVerticalTextAlignment()
Returns:
the Vertical text alignment field value.

setTextLocked

public void setTextLocked(boolean value)
Sets the text locked field value.

isTextLocked

public boolean isTextLocked()
Returns:
the text locked field value.

getTextOrientation

public int getTextOrientation()
Get the text orientation field for the TextObjectBase record.

Returns:
One of TEXT_ORIENTATION_NONE TEXT_ORIENTATION_TOP_TO_BOTTOM TEXT_ORIENTATION_ROT_RIGHT TEXT_ORIENTATION_ROT_LEFT

setTextOrientation

public void setTextOrientation(int textOrientation)
Set the text orientation field for the TextObjectBase record.

Parameters:
textOrientation - One of TEXT_ORIENTATION_NONE TEXT_ORIENTATION_TOP_TO_BOTTOM TEXT_ORIENTATION_ROT_RIGHT TEXT_ORIENTATION_ROT_LEFT

getStr

public HSSFRichTextString getStr()

setStr

public void setStr(HSSFRichTextString str)

getLinkRefPtg

public Ptg getLinkRefPtg()

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TopMarginRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class TopMarginRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.TopMarginRecord
All Implemented Interfaces:
Margin
public final class TopMarginRecord
extends StandardRecord
implements Margin

Record for the top margin.

Author:
Shawn Laubach (slaubach at apache dot org)

Field Summary
static short sid
Constructor Summary
TopMarginRecord()
TopMarginRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
double | getMargin() Get the margin field for the TopMargin record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setMargin(double field_1_margin) Set the margin field for the TopMargin record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

TopMarginRecord

public TopMarginRecord()

TopMarginRecord

public TopMarginRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getMargin

public double getMargin()
Get the margin field for the TopMargin record.

Specified by:
getMargin in interface Margin

setMargin

public void setMargin(double field_1_margin)
Set the margin field for the TopMargin record.

Specified by:
setMargin in interface Margin

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UncalcedRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class UncalcedRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.UncalcedRecord

public final class UncalcedRecord
extends StandardRecord

Title: Uncalced Record

If this record occurs in the Worksheet Substream, it indicates that the formulas have not been recalculated before the document was saved.

Author:
Olivier Leprince

Field Summary
static short sid
Constructor Summary
UncalcedRecord()
UncalcedRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
static int | getStaticRecordSize()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

UncalcedRecord

public UncalcedRecord()

UncalcedRecord

public UncalcedRecord(RecordInputStream in)
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getStaticRecordSize

public static int getStaticRecordSize()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnicodeString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class UnicodeString

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.UnicodeString
        extended by  org.apache.poi.hssf.record.UnicodeString
All Implemented Interfaces:
java.lang.Comparable<UnicodeString>
Deprecated. Use UnicodeString instead

public final class UnicodeString
extends UnicodeString

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.common.UnicodeString
UnicodeString.ExtRst, UnicodeString.FormatRun, UnicodeString.PhRun
Constructor Summary
UnicodeString(RecordInputStream in)
Deprecated. Use UnicodeString instead
UnicodeString(java.lang.String str)
Deprecated. Use UnicodeString instead
Method Summary
Methods inherited from class org.apache.poi.hssf.record.common.UnicodeString
addFormatRun, clearFormatting, clone, compareTo, equals, formatIterator, getCharCount, getCharCountShort, getDebugInfo, getExtendedRst, getFormatRun, getFormatRunCount, getOptionFlags, getString, hashCode, removeFormatRun, serialize, setCharCount, setOptionFlags, setString, swapFontUse, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

UnicodeString

public UnicodeString(RecordInputStream in)
Deprecated. Use UnicodeString instead

UnicodeString

public UnicodeString(java.lang.String str)
Deprecated. Use UnicodeString instead

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class UnknownRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.UnknownRecord

public final class UnknownRecord
extends StandardRecord

Title: Unknown Record (for debugging)

Description: Unknown record just tells you the sid so you can figure out what records you are missing. Also helps us read/modify sheets we don't know all the records to. (HSSF leaves these alone!)

Company: SuperLink Software, Inc.

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au), Glen Stampoultzis (glens at apache.org)

Field Summary
static int | BITMAP_00E9
static int | CODENAME_1BA
static int | HEADER_FOOTER_089C
static int | LABELRANGES_015F
static int | PHONETICPR_00EF
static int | PLS_004D Environment-Specific Print Record
static int | PRINTSIZE_0033 seems to be part of the PageSettingsBlock.
static int | QUICKTIP_0800
static int | SCL_00A0
static int | SHEETEXT_0862
static int | SHEETPR_0081
static int | SHEETPROTECTION_0867
static int | SORT_0090
static int | STANDARDWIDTH_0099
Constructor Summary
UnknownRecord(int id, byte[] data)
UnknownRecord(RecordInputStream in)
construct an unknown record.
Method Summary
java.lang.Object | clone()
static java.lang.String | getBiffName(int sid) These BIFF record types are known but still uninterpreted by POI
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) spit the record out AS IS.
java.lang.String | toString() print a sort of string representation ([UNKNOWN RECORD] id = x [/UNKNOWN RECORD])
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

PRINTSIZE_0033

public static final int PRINTSIZE_0033
seems to be part of the PageSettingsBlock. Not interpreted by POI. The name 'PRINTSIZE' was taken from OOO source.
The few POI test samples with this record have data { 0x03, 0x00 }.

See Also:
Constant Field Values

PLS_004D

public static final int PLS_004D
Environment-Specific Print Record

See Also:
Constant Field Values

SHEETPR_0081

public static final int SHEETPR_0081
See Also:
Constant Field Values

SORT_0090

public static final int SORT_0090
See Also:
Constant Field Values

STANDARDWIDTH_0099

public static final int STANDARDWIDTH_0099
See Also:
Constant Field Values

SCL_00A0

public static final int SCL_00A0
See Also:
Constant Field Values

BITMAP_00E9

public static final int BITMAP_00E9
See Also:
Constant Field Values

PHONETICPR_00EF

public static final int PHONETICPR_00EF
See Also:
Constant Field Values

LABELRANGES_015F

public static final int LABELRANGES_015F
See Also:
Constant Field Values

QUICKTIP_0800

public static final int QUICKTIP_0800
See Also:
Constant Field Values

SHEETEXT_0862

public static final int SHEETEXT_0862
See Also:
Constant Field Values

SHEETPROTECTION_0867

public static final int SHEETPROTECTION_0867
See Also:
Constant Field Values

HEADER_FOOTER_089C

public static final int HEADER_FOOTER_089C
See Also:
Constant Field Values

CODENAME_1BA

public static final int CODENAME_1BA
See Also:
Constant Field Values
Constructor Detail

UnknownRecord

public UnknownRecord(int id,
                     byte[] data)
Parameters:
id - id of the record -not validated, just stored for serialization
data - the data

UnknownRecord

public UnknownRecord(RecordInputStream in)
construct an unknown record. No fields are interpreted and the record will be serialized in its original form more or less

Parameters:
in - the RecordInputstream to read the record from
Method Detail

serialize

public void serialize(LittleEndianOutput out)
spit the record out AS IS. no interpretation or identification

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

toString

public java.lang.String toString()
print a sort of string representation ([UNKNOWN RECORD] id = x [/UNKNOWN RECORD])

Overrides:
toString in class Record

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getBiffName

public static java.lang.String getBiffName(int sid)
These BIFF record types are known but still uninterpreted by POI

Returns:
the documented name of this BIFF record type, null if unknown to POI

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserSViewBegin

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class UserSViewBegin

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.UserSViewBegin

public final class UserSViewBegin
extends StandardRecord

The UserSViewBegin record specifies settings for a custom view associated with the sheet. This record also marks the start of custom view records, which save custom view settings. Records between UserSViewBegin and UserSViewEnd contain settings for the custom view, not settings for the sheet itself.

Author:
Yegor Kozlov

Field Summary
static short sid
Constructor Summary
UserSViewBegin(byte[] data)
UserSViewBegin(RecordInputStream in)
construct an UserSViewBegin record.
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
byte[] | getGuid()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) spit the record out AS IS.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

UserSViewBegin

public UserSViewBegin(byte[] data)

UserSViewBegin

public UserSViewBegin(RecordInputStream in)
construct an UserSViewBegin record. No fields are interpreted and the record will be serialized in its original form more or less

Parameters:
in - the RecordInputstream to read the record from
Method Detail

serialize

public void serialize(LittleEndianOutput out)
spit the record out AS IS. no interpretation or identification

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getGuid

public byte[] getGuid()
Returns:
Globally unique identifier for the custom view

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserSViewEnd

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class UserSViewEnd

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.UserSViewEnd

public final class UserSViewEnd
extends StandardRecord

The UserSViewEnd record marks the end of the settings for a custom view associated with the sheet

Author:
Yegor Kozlov

Field Summary
static short sid
Constructor Summary
UserSViewEnd(byte[] data)
UserSViewEnd(RecordInputStream in)
construct an UserSViewEnd record.
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) spit the record out AS IS.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

UserSViewEnd

public UserSViewEnd(byte[] data)

UserSViewEnd

public UserSViewEnd(RecordInputStream in)
construct an UserSViewEnd record. No fields are interpreted and the record will be serialized in its original form more or less

Parameters:
in - the RecordInputstream to read the record from
Method Detail

serialize

public void serialize(LittleEndianOutput out)
spit the record out AS IS. no interpretation or identification

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UseSelFSRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class UseSelFSRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.UseSelFSRecord

public final class UseSelFSRecord
extends StandardRecord

Title: USESELFS (0x0160) - Use Natural Language Formulas Flag

Description: Tells the GUI if this was written by something that can use "natural language" formulas. HSSF can't.

REFERENCE: PG 420 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
UseSelFSRecord(boolean b)
UseSelFSRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

UseSelFSRecord

public UseSelFSRecord(RecordInputStream in)

UseSelFSRecord

public UseSelFSRecord(boolean b)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VCenterRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class VCenterRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.VCenterRecord

public final class VCenterRecord
extends StandardRecord

Title: VCenter record

Description: tells whether to center the sheet between vertical margins

REFERENCE: PG 420 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
VCenterRecord()
VCenterRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
boolean | getVCenter() get whether to center vertically or not
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setVCenter(boolean hc) set whether to center vertically or not
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

VCenterRecord

public VCenterRecord()

VCenterRecord

public VCenterRecord(RecordInputStream in)
Method Detail

setVCenter

public void setVCenter(boolean hc)
set whether to center vertically or not

Parameters:
hc - vcenter or not

getVCenter

public boolean getVCenter()
get whether to center vertically or not

Returns:
vcenter or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VerticalPageBreakRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class VerticalPageBreakRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.PageBreakRecord
                    extended by  org.apache.poi.hssf.record.VerticalPageBreakRecord

public final class VerticalPageBreakRecord
extends PageBreakRecord

VerticalPageBreak (0x001A) record that stores page breaks at columns

Author:
Danny Mui (dmui at apache dot org)
See Also:
PageBreakRecord

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.PageBreakRecord
PageBreakRecord.Break
Field Summary
static short sid
Constructor Summary
VerticalPageBreakRecord()
Creates an empty vertical page break record
VerticalPageBreakRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getSid() return the non static version of the id for this record.
Methods inherited from class org.apache.poi.hssf.record.PageBreakRecord
addBreak, getBreak, getBreaks, getBreaksIterator, getDataSize, getNumBreaks, isEmpty, removeBreak, serialize, toString
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

VerticalPageBreakRecord

public VerticalPageBreakRecord()
Creates an empty vertical page break record

VerticalPageBreakRecord

public VerticalPageBreakRecord(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WindowOneRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class WindowOneRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.WindowOneRecord

public final class WindowOneRecord
extends StandardRecord

Title: Window1 Record

Description: Stores the attributes of the workbook window. This is basically so the gui knows how big to make the window holding the spreadsheet document.

REFERENCE: PG 421 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
WindowOneRecord()
WindowOneRecord(RecordInputStream in)
Method Summary
 int getActiveSheetIndex()
protected  int getDataSize()
 short getDisplayedTab()
Deprecated. - Misleading name - use getFirstVisibleTab()
 boolean getDisplayHorizontalScrollbar()
get whether to display the horizontal scrollbar or not
 boolean getDisplayTabs()
get whether to display the tabs or not
 boolean getDisplayVerticalScrollbar()
get whether to display the vertical scrollbar or not
 int getFirstVisibleTab()
 short getHeight()
get the height of the window
 boolean getHidden()
get whether the window is hidden or not
 short getHorizontalHold()
get the horizontal position of the window (in 1/20ths of a point)
 boolean getIconic()
get whether the window has been iconized or not
 short getNumSelectedTabs()
get the number of selected tabs
 short getOptions()
get the options bitmask (see bit setters)
 short getSelectedTab()
Deprecated. - Misleading name - use getActiveSheetIndex()
 short getSid()
return the non static version of the id for this record.
 short getTabWidthRatio()
ratio of the width of the tabs to the horizontal scrollbar
 short getVerticalHold()
get the vertical position of the window (in 1/20ths of a point)
 short getWidth()
get the width of the window
 void serialize(LittleEndianOutput out)
Write the data content of this BIFF record.
 void setActiveSheetIndex(int index)
 void setDisplayedTab(short t)
Deprecated. - Misleading name - use setFirstVisibleTab()
 void setDisplayHorizonalScrollbar(boolean scroll)
set whether to display the horizontal scrollbar or not
 void setDisplayTabs(boolean disptabs)
set whether to display the tabs or not
 void setDisplayVerticalScrollbar(boolean scroll)
set whether to display the vertical scrollbar or not
 void setFirstVisibleTab(int t)
Sets the first visible sheet in the worksheet tab-bar.
 void setHeight(short h)
set teh height of the window
 void setHidden(boolean ishidden)
set whether the window is hidden or not
 void setHorizontalHold(short h)
set the horizontal position of the window (in 1/20ths of a point)
 void setIconic(boolean isiconic)
set whether the window has been iconized or not
 void setNumSelectedTabs(short n)
set the number of selected tabs
 void setOptions(short o)
set the options bitmask (see bit setters)
 void setSelectedTab(short s)
Deprecated. - Misleading name - use setActiveSheetIndex()
 void setTabWidthRatio(short r)
ratio of the width of the tabs to the horizontal scrollbar
 void setVerticalHold(short v)
set the vertical position of the window (in 1/20ths of a point)
 void setWidth(short w)
set the width of the window
 java.lang.String toString()
get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

WindowOneRecord

public WindowOneRecord()

WindowOneRecord

public WindowOneRecord(RecordInputStream in)
Method Detail

setHorizontalHold

public void setHorizontalHold(short h)
set the horizontal position of the window (in 1/20ths of a point)

Parameters:
h - - horizontal location

setVerticalHold

public void setVerticalHold(short v)
set the vertical position of the window (in 1/20ths of a point)

Parameters:
v - - vertical location

setWidth

public void setWidth(short w)
set the width of the window

Parameters:
w - width

setHeight

public void setHeight(short h)
set teh height of the window

Parameters:
h - height

setOptions

public void setOptions(short o)
set the options bitmask (see bit setters)

Parameters:
o - - the bitmask

setHidden

public void setHidden(boolean ishidden)
set whether the window is hidden or not

Parameters:
ishidden - or not

setIconic

public void setIconic(boolean isiconic)
set whether the window has been iconized or not

Parameters:
isiconic - iconize or not

setDisplayHorizonalScrollbar

public void setDisplayHorizonalScrollbar(boolean scroll)
set whether to display the horizontal scrollbar or not

Parameters:
scroll - display or not

setDisplayVerticalScrollbar

public void setDisplayVerticalScrollbar(boolean scroll)
set whether to display the vertical scrollbar or not

Parameters:
scroll - display or not

setDisplayTabs

public void setDisplayTabs(boolean disptabs)
set whether to display the tabs or not

Parameters:
disptabs - display or not

setActiveSheetIndex

public void setActiveSheetIndex(int index)

setSelectedTab

public void setSelectedTab(short s)
Deprecated. - Misleading name - use setActiveSheetIndex()

deprecated May 2008

setFirstVisibleTab

public void setFirstVisibleTab(int t)
Sets the first visible sheet in the worksheet tab-bar. This method does not hide, select or focus sheets. It just sets the scroll position in the tab-bar.

Parameters:
t - the sheet index of the tab that will become the first in the tab-bar

setDisplayedTab

public void setDisplayedTab(short t)
Deprecated. - Misleading name - use setFirstVisibleTab()

deprecated May 2008

setNumSelectedTabs

public void setNumSelectedTabs(short n)
set the number of selected tabs

Parameters:
n - number of tabs

setTabWidthRatio

public void setTabWidthRatio(short r)
ratio of the width of the tabs to the horizontal scrollbar

Parameters:
r - ratio

getHorizontalHold

public short getHorizontalHold()
get the horizontal position of the window (in 1/20ths of a point)

Returns:
h - horizontal location

getVerticalHold

public short getVerticalHold()
get the vertical position of the window (in 1/20ths of a point)

Returns:
v - vertical location

getWidth

public short getWidth()
get the width of the window

Returns:
width

getHeight

public short getHeight()
get the height of the window

Returns:
height

getOptions

public short getOptions()
get the options bitmask (see bit setters)

Returns:
o - the bitmask

getHidden

public boolean getHidden()
get whether the window is hidden or not

Returns:
ishidden or not

getIconic

public boolean getIconic()
get whether the window has been iconized or not

Returns:
iconize or not

getDisplayHorizontalScrollbar

public boolean getDisplayHorizontalScrollbar()
get whether to display the horizontal scrollbar or not

Returns:
display or not

getDisplayVerticalScrollbar

public boolean getDisplayVerticalScrollbar()
get whether to display the vertical scrollbar or not

Returns:
display or not

getDisplayTabs

public boolean getDisplayTabs()
get whether to display the tabs or not

Returns:
display or not

getActiveSheetIndex

public int getActiveSheetIndex()
Returns:
the index of the currently displayed sheet

getSelectedTab

public short getSelectedTab()
Deprecated. - Misleading name - use getActiveSheetIndex()

deprecated May 2008

getFirstVisibleTab

public int getFirstVisibleTab()
Returns:
the first visible sheet in the worksheet tab-bar. I.E. the scroll position of the tab-bar.

getDisplayedTab

public short getDisplayedTab()
Deprecated. - Misleading name - use getFirstVisibleTab()

deprecated May 2008

getNumSelectedTabs

public short getNumSelectedTabs()
get the number of selected tabs

Returns:
number of tabs

getTabWidthRatio

public short getTabWidthRatio()
ratio of the width of the tabs to the horizontal scrollbar

Returns:
ratio

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WindowProtectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class WindowProtectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.WindowProtectRecord

public final class WindowProtectRecord
extends StandardRecord

Title: Window Protect Record (0x0019)

Description: flags whether workbook windows are protected

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
WindowProtectRecord(boolean protect)
WindowProtectRecord(int options)
WindowProtectRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
boolean | getProtect() is this window protected or not
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setProtect(boolean protect) set whether this window should be protected or not
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

WindowProtectRecord

public WindowProtectRecord(int options)

WindowProtectRecord

public WindowProtectRecord(RecordInputStream in)

WindowProtectRecord

public WindowProtectRecord(boolean protect)
Method Detail

setProtect

public void setProtect(boolean protect)
set whether this window should be protected or not

Parameters:
protect - or not

getProtect

public boolean getProtect()
is this window protected or not

Returns:
protected or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WindowTwoRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class WindowTwoRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.WindowTwoRecord

public final class WindowTwoRecord
extends StandardRecord

Title: Window Two Record

Description: sheet window settings

REFERENCE: PG 422 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
2.0-pre
Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
WindowTwoRecord()
WindowTwoRecord(RecordInputStream in)
Method Summary
 java.lang.Object clone()
 boolean getArabic()
is this arabic?
protected  int getDataSize()
 boolean getDefaultHeader()
get whether the window should display a default header
 boolean getDisplayFormulas()
get whether the window should display formulas
 boolean getDisplayGridlines()
get whether the window should display gridlines
 boolean getDisplayGuts()
get whether the outline symbols are displaed
 boolean getDisplayRowColHeadings()
get whether the window should display row and column headings
 boolean getDisplayZeros()
get whether the window should display zero values
 boolean getFreezePanes()
get whether the window should freeze panes
 boolean getFreezePanesNoSplit()
freeze unsplit panes or not
 int getHeaderColor()
get the palette index for the header color
 short getLeftCol()
get the leftmost column displayed in the window
 short getNormalZoom()
get the zoom magnification in normal view
 short getOptions()
get the options bitmask or just use the bit setters.
 short getPageBreakZoom()
zoom magification in page break view
 boolean getPaged()
Deprecated. use isActive()
 int getReserved()
get the reserved bits - why would you do this?
 boolean getSavedInPageBreakPreview()
was the sheet saved in page break view
 boolean getSelected()
sheet tab is selected
 short getSid()
return the non static version of the id for this record.
 short getTopRow()
get the top row visible in the window
 boolean isActive()
is the sheet currently displayed in the window
 void serialize(LittleEndianOutput out)
Write the data content of this BIFF record.
 void setActive(boolean p)
is the sheet currently displayed in the window
 void setArabic(boolean isarabic)
is this arabic?
 void setDefaultHeader(boolean header)
set whether the window should display a default header
 void setDisplayFormulas(boolean formulas)
set whether the window should display formulas
 void setDisplayGridlines(boolean gridlines)
set whether the window should display gridlines
 void setDisplayGuts(boolean guts)
set whether the outline symbols are displaed
 void setDisplayRowColHeadings(boolean headings)
set whether the window should display row and column headings
 void setDisplayZeros(boolean zeros)
set whether the window should display zero values
 void setFreezePanes(boolean freezepanes)
set whether the window should freeze panes
 void setFreezePanesNoSplit(boolean freeze)
freeze unsplit panes or not
 void setHeaderColor(int color)
set the palette index for the header color
 void setLeftCol(short leftCol)
set the leftmost column displayed in the window
 void setNormalZoom(short zoom)
set the zoom magnification in normal view
 void setOptions(short options)
set the options bitmask or just use the bit setters.
 void setPageBreakZoom(short zoom)
zoom magification in page break view
 void setPaged(boolean p)
Deprecated. use setActive()
 void setReserved(int reserved)
set the reserved (don't do this) value
 void setSavedInPageBreakPreview(boolean p)
was the sheet saved in page break view
 void setSelected(boolean sel)
sheet tab is selected
 void setTopRow(short topRow)
set the top row visible in the window
 java.lang.String toString()
get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

WindowTwoRecord

public WindowTwoRecord()

WindowTwoRecord

public WindowTwoRecord(RecordInputStream in)
Method Detail

setOptions

public void setOptions(short options)
set the options bitmask or just use the bit setters.

Parameters:
options -

setDisplayFormulas

public void setDisplayFormulas(boolean formulas)
set whether the window should display formulas

Parameters:
formulas - or not

setDisplayGridlines

public void setDisplayGridlines(boolean gridlines)
set whether the window should display gridlines

Parameters:
gridlines - or not

setDisplayRowColHeadings

public void setDisplayRowColHeadings(boolean headings)
set whether the window should display row and column headings

Parameters:
headings - or not

setFreezePanes

public void setFreezePanes(boolean freezepanes)
set whether the window should freeze panes

Parameters:
freezepanes - freeze panes or not

setDisplayZeros

public void setDisplayZeros(boolean zeros)
set whether the window should display zero values

Parameters:
zeros - or not

setDefaultHeader

public void setDefaultHeader(boolean header)
set whether the window should display a default header

Parameters:
header - or not

setArabic

public void setArabic(boolean isarabic)
is this arabic?

Parameters:
isarabic - arabic or not

setDisplayGuts

public void setDisplayGuts(boolean guts)
set whether the outline symbols are displaed

Parameters:
guts - symbols or not

setFreezePanesNoSplit

public void setFreezePanesNoSplit(boolean freeze)
freeze unsplit panes or not

Parameters:
freeze - or not

setSelected

public void setSelected(boolean sel)
sheet tab is selected

Parameters:
sel - selected or not

setActive

public void setActive(boolean p)
is the sheet currently displayed in the window

Parameters:
p - displayed or not

setPaged

public void setPaged(boolean p)
Deprecated. use setActive()

deprecated May 2008

setSavedInPageBreakPreview

public void setSavedInPageBreakPreview(boolean p)
was the sheet saved in page break view

Parameters:
p - pagebreaksaved or not

setTopRow

public void setTopRow(short topRow)
set the top row visible in the window

Parameters:
topRow - top row visible

setLeftCol

public void setLeftCol(short leftCol)
set the leftmost column displayed in the window

Parameters:
leftCol - leftmost column

setHeaderColor

public void setHeaderColor(int color)
set the palette index for the header color

Parameters:
color -

setPageBreakZoom

public void setPageBreakZoom(short zoom)
zoom magification in page break view

Parameters:
zoom -

setNormalZoom

public void setNormalZoom(short zoom)
set the zoom magnification in normal view

Parameters:
zoom -

setReserved

public void setReserved(int reserved)
set the reserved (don't do this) value

getOptions

public short getOptions()
get the options bitmask or just use the bit setters.

Returns:
options

getDisplayFormulas

public boolean getDisplayFormulas()
get whether the window should display formulas

Returns:
formulas or not

getDisplayGridlines

public boolean getDisplayGridlines()
get whether the window should display gridlines

Returns:
gridlines or not

getDisplayRowColHeadings

public boolean getDisplayRowColHeadings()
get whether the window should display row and column headings

Returns:
headings or not

getFreezePanes

public boolean getFreezePanes()
get whether the window should freeze panes

Returns:
freeze panes or not

getDisplayZeros

public boolean getDisplayZeros()
get whether the window should display zero values

Returns:
zeros or not

getDefaultHeader

public boolean getDefaultHeader()
get whether the window should display a default header

Returns:
header or not

getArabic

public boolean getArabic()
is this arabic?

Returns:
arabic or not

getDisplayGuts

public boolean getDisplayGuts()
get whether the outline symbols are displaed

Returns:
symbols or not

getFreezePanesNoSplit

public boolean getFreezePanesNoSplit()
freeze unsplit panes or not

Returns:
freeze or not

getSelected

public boolean getSelected()
sheet tab is selected

Returns:
selected or not

isActive

public boolean isActive()
is the sheet currently displayed in the window

Returns:
displayed or not

getPaged

public boolean getPaged()
Deprecated. use isActive()

deprecated May 2008

getSavedInPageBreakPreview

public boolean getSavedInPageBreakPreview()
was the sheet saved in page break view

Returns:
pagebreaksaved or not

getTopRow

public short getTopRow()
get the top row visible in the window

Returns:
toprow

getLeftCol

public short getLeftCol()
get the leftmost column displayed in the window

Returns:
leftmost

getHeaderColor

public int getHeaderColor()
get the palette index for the header color

Returns:
color

getPageBreakZoom

public short getPageBreakZoom()
zoom magification in page break view

Returns:
zoom

getNormalZoom

public short getNormalZoom()
get the zoom magnification in normal view

Returns:
zoom

getReserved

public int getReserved()
get the reserved bits - why would you do this?

Returns:
reserved stuff -probably garbage

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WriteAccessRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class WriteAccessRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.WriteAccessRecord

public final class WriteAccessRecord
extends StandardRecord

Title: Write Access Record (0x005C)

Description: Stores the username of that who owns the spreadsheet generator (on unix the user's login, on Windoze its the name you typed when you installed the thing)

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static short sid
Constructor Summary
WriteAccessRecord()
WriteAccessRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
java.lang.String | getUsername() get the username for the user that created the report.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setUsername(java.lang.String username) set the username for the user that created the report.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

WriteAccessRecord

public WriteAccessRecord()

WriteAccessRecord

public WriteAccessRecord(RecordInputStream in)
Method Detail

setUsername

public void setUsername(java.lang.String username)
set the username for the user that created the report. HSSF uses the logged in user.

Parameters:
username - of the user who is logged in (probably "tomcat" or "apache")

getUsername

public java.lang.String getUsername()
get the username for the user that created the report. HSSF uses the logged in user. On natively created M$ Excel sheet this would be the name you typed in when you installed it in most cases.

Returns:
username of the user who is logged in (probably "tomcat" or "apache")

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WriteProtectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class WriteProtectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.WriteProtectRecord

public final class WriteProtectRecord
extends StandardRecord

Title: Write Protect Record

Description: Indicated that the sheet/workbook is write protected. REFERENCE: PG 425 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Version:
3.0-pre

Field Summary
static short sid
Constructor Summary
WriteProtectRecord()
WriteProtectRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

WriteProtectRecord

public WriteProtectRecord()

WriteProtectRecord

public WriteProtectRecord(RecordInputStream in)
Parameters:
in - unused (since this record has no data)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WSBoolRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record
Class WSBoolRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.WSBoolRecord

public final class WSBoolRecord
extends StandardRecord

Title: WSBOOL (0x0081) (called SHEETPR in OOO doc)

Description: stores workbook settings (aka its a big "everything we didn't put somewhere else")

REFERENCE: PG 425 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (gstamp@iprimus.com.au), Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Constructor Summary
WSBoolRecord()
WSBoolRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
boolean | getAlternateExpression() whether alternate expression evaluation is on
boolean | getAlternateFormula() whether alternative formula entry is on
boolean | getAutobreaks() show automatic page breaks or not
protected int | getDataSize()
boolean | getDialog() get whether sheet is a dialog sheet or not
boolean | getDisplayGuts() get whether to display the guts or not
boolean | getFitToPage() fit to page option is on
boolean | getRowSumsBelow() get if row summaries appear below detail in the outline
boolean | getRowSumsRight() get if col summaries appear right of the detail in the outline
short | getSid() return the non static version of the id for this record.
byte | getWSBool1() get first byte (see bit getters)
byte | getWSBool2() get the second byte (see bit getters)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAlternateExpression(boolean altexp) whether alternate expression evaluation is on
void | setAlternateFormula(boolean formula) whether alternative formula entry is on
void | setAutobreaks(boolean ab) show automatic page breaks or not
void | setDialog(boolean isDialog) set whether sheet is a dialog sheet or not
void | setDisplayGuts(boolean guts) set whether to display the guts or not
void | setFitToPage(boolean fit2page) fit to page option is on
void | setRowSumsBelow(boolean below) set if row summaries appear below detail in the outline
void | setRowSumsRight(boolean right) set if col summaries appear right of the detail in the outline
void | setWSBool1(byte bool1) set first byte (see bit setters)
void | setWSBool2(byte bool2) set the second byte (see bit setters)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

WSBoolRecord

public WSBoolRecord()

WSBoolRecord

public WSBoolRecord(RecordInputStream in)
Method Detail

setWSBool1

public void setWSBool1(byte bool1)
set first byte (see bit setters)

setAutobreaks

public void setAutobreaks(boolean ab)
show automatic page breaks or not

Parameters:
ab - whether to show auto page breaks

setDialog

public void setDialog(boolean isDialog)
set whether sheet is a dialog sheet or not

Parameters:
isDialog - or not

setRowSumsBelow

public void setRowSumsBelow(boolean below)
set if row summaries appear below detail in the outline

Parameters:
below - or not

setRowSumsRight

public void setRowSumsRight(boolean right)
set if col summaries appear right of the detail in the outline

Parameters:
right - or not

setWSBool2

public void setWSBool2(byte bool2)
set the second byte (see bit setters)

setFitToPage

public void setFitToPage(boolean fit2page)
fit to page option is on

Parameters:
fit2page - fit or not

setDisplayGuts

public void setDisplayGuts(boolean guts)
set whether to display the guts or not

Parameters:
guts - or no guts (or glory)

setAlternateExpression

public void setAlternateExpression(boolean altexp)
whether alternate expression evaluation is on

Parameters:
altexp - alternative expression evaluation or not

setAlternateFormula

public void setAlternateFormula(boolean formula)
whether alternative formula entry is on

Parameters:
formula - alternative formulas or not

getWSBool1

public byte getWSBool1()
get first byte (see bit getters)

getAutobreaks

public boolean getAutobreaks()
show automatic page breaks or not

Returns:
whether to show auto page breaks

getDialog

public boolean getDialog()
get whether sheet is a dialog sheet or not

Returns:
isDialog or not

getRowSumsBelow

public boolean getRowSumsBelow()
get if row summaries appear below detail in the outline

Returns:
below or not

getRowSumsRight

public boolean getRowSumsRight()
get if col summaries appear right of the detail in the outline

Returns:
right or not

getWSBool2

public byte getWSBool2()
get the second byte (see bit getters)

getFitToPage

public boolean getFitToPage()
fit to page option is on

Returns:
fit or not

getDisplayGuts

public boolean getDisplayGuts()
get whether to display the guts or not

Returns:
guts or no guts (or glory)

getAlternateExpression

public boolean getAlternateExpression()
whether alternate expression evaluation is on

Returns:
alternative expression evaluation or not

getAlternateFormula

public boolean getAlternateFormula()
whether alternative formula entry is on

Returns:
alternative formulas or not

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CFRecordsAggregate

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class CFRecordsAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

public final class CFRecordsAggregate
extends RecordAggregate

CFRecordsAggregate - aggregates Conditional Formatting records CFHeaderRecord and number of up to three CFRuleRecord records together to simplify access to them.

Author:
Dmitriy Kumshayev

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
CFRecordsAggregate(CellRangeAddress[] regions, CFRuleRecord[] rules)
Method Summary
void | addRule(CFRuleRecord r)
CFRecordsAggregate | cloneCFAggregate() Create a deep clone of the record
static CFRecordsAggregate | createCFAggregate(RecordStream rs) Create CFRecordsAggregate from a list of CF Records
CFHeaderRecord | getHeader()
int | getNumberOfRules()
CFRuleRecord | getRule(int idx)
void | setRule(int idx, CFRuleRecord r)
java.lang.String | toString() String representation of CFRecordsAggregate
boolean | updateFormulasAfterCellShift(FormulaShifter shifter, int currentExternSheetIx)
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CFRecordsAggregate

public CFRecordsAggregate(CellRangeAddress[] regions,
                          CFRuleRecord[] rules)
Method Detail

createCFAggregate

public static CFRecordsAggregate createCFAggregate(RecordStream rs)
Create CFRecordsAggregate from a list of CF Records

Parameters:
rs - - the stream to read from
Returns:
CFRecordsAggregate object

cloneCFAggregate

public CFRecordsAggregate cloneCFAggregate()
Create a deep clone of the record

getHeader

public CFHeaderRecord getHeader()
Returns:
the header. Never null.

getRule

public CFRuleRecord getRule(int idx)

setRule

public void setRule(int idx,
                    CFRuleRecord r)

addRule

public void addRule(CFRuleRecord r)

getNumberOfRules

public int getNumberOfRules()

toString

public java.lang.String toString()
String representation of CFRecordsAggregate

Overrides:
toString in class java.lang.Object

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

updateFormulasAfterCellShift

public boolean updateFormulasAfterCellShift(FormulaShifter shifter,
                                            int currentExternSheetIx)
Returns:
false if this whole CFHeaderRecord / CFRuleRecords should be deleted
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ChartSubstreamRecordAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class ChartSubstreamRecordAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate

public final class ChartSubstreamRecordAggregate
extends RecordAggregate

Manages the all the records associated with a chart sub-stream.
Includes the initial BOFRecord and final EOFRecord.

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
ChartSubstreamRecordAggregate(RecordStream rs)
Method Summary
 void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ChartSubstreamRecordAggregate

public ChartSubstreamRecordAggregate(RecordStream rs)
Method Detail

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ColumnInfoRecordsAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class ColumnInfoRecordsAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

public final class ColumnInfoRecordsAggregate
extends RecordAggregate

Author:
Glen Stampoultzis

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
ColumnInfoRecordsAggregate()
Creates an empty aggregate
ColumnInfoRecordsAggregate(RecordStream rs)
Method Summary
java.lang.Object | clone() Performs a deep clone of the record
void | collapseColumn(int columnIndex)
void | expandColumn(int columnIndex)
ColumnInfoRecord | findColumnInfo(int columnIndex) Finds the ColumnInfoRecord which contains the specified columnIndex
int | getMaxOutlineLevel()
void | groupColumnRange(int fromColumnIx, int toColumnIx, boolean indent) Creates an outline group for the specified columns, by setting the level field for each col info record in the range.
void | insertColumn(ColumnInfoRecord col) Inserts a column into the aggregate (at the end of the list).
void | setColumn(int targetColumnIx, java.lang.Short xfIndex, java.lang.Integer width, java.lang.Integer level, java.lang.Boolean hidden, java.lang.Boolean collapsed)
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ColumnInfoRecordsAggregate

public ColumnInfoRecordsAggregate()
Creates an empty aggregate

ColumnInfoRecordsAggregate

public ColumnInfoRecordsAggregate(RecordStream rs)
Method Detail

clone

public java.lang.Object clone()
Performs a deep clone of the record

Overrides:
clone in class java.lang.Object

insertColumn

public void insertColumn(ColumnInfoRecord col)
Inserts a column into the aggregate (at the end of the list).

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

collapseColumn

public void collapseColumn(int columnIndex)

expandColumn

public void expandColumn(int columnIndex)

setColumn

public void setColumn(int targetColumnIx,
                      java.lang.Short xfIndex,
                      java.lang.Integer width,
                      java.lang.Integer level,
                      java.lang.Boolean hidden,
                      java.lang.Boolean collapsed)

groupColumnRange

public void groupColumnRange(int fromColumnIx,
                             int toColumnIx,
                             boolean indent)
Creates an outline group for the specified columns, by setting the level field for each col info record in the range. ColumnInfoRecords may be created, split or merged as a result of this operation.

Parameters:
fromColumnIx - group from this column (inclusive)
toColumnIx - group to this column (inclusive)
indent - if true the group will be indented by one level, if false indenting will be decreased by one level.

findColumnInfo

public ColumnInfoRecord findColumnInfo(int columnIndex)
Finds the ColumnInfoRecord which contains the specified columnIndex

Parameters:
columnIndex - index of the column (not the index of the ColumnInfoRecord)
Returns:
null if no column info found for the specified column

getMaxOutlineLevel

public int getMaxOutlineLevel()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConditionalFormattingTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class ConditionalFormattingTable

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

public final class ConditionalFormattingTable
extends RecordAggregate

Holds all the conditional formatting for a workbook sheet.

See OOO exelfileformat.pdf sec 4.12 'Conditional Formatting Table'

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
ConditionalFormattingTable()
Creates an empty ConditionalFormattingTable
ConditionalFormattingTable(RecordStream rs)
Method Summary
int | add(CFRecordsAggregate cfAggregate)
CFRecordsAggregate | get(int index)
void | remove(int index)
int | size()
void | updateFormulasAfterCellShift(FormulaShifter shifter, int externSheetIndex)
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConditionalFormattingTable

public ConditionalFormattingTable()
Creates an empty ConditionalFormattingTable

ConditionalFormattingTable

public ConditionalFormattingTable(RecordStream rs)
Method Detail

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

add

public int add(CFRecordsAggregate cfAggregate)
Returns:
index of the newly added CF header aggregate

size

public int size()

get

public CFRecordsAggregate get(int index)

remove

public void remove(int index)

updateFormulasAfterCellShift

public void updateFormulasAfterCellShift(FormulaShifter shifter,
                                         int externSheetIndex)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomViewSettingsRecordAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class CustomViewSettingsRecordAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

public final class CustomViewSettingsRecordAggregate
extends RecordAggregate

Manages the all the records associated with a 'Custom View Settings' sub-stream.
Includes the initial USERSVIEWBEGIN(0x01AA) and final USERSVIEWEND(0x01AB).

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
CustomViewSettingsRecordAggregate(RecordStream rs)
Method Summary
void | append(RecordBase r)
static boolean | isBeginRecord(int sid)
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomViewSettingsRecordAggregate

public CustomViewSettingsRecordAggregate(RecordStream rs)
Method Detail

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

isBeginRecord

public static boolean isBeginRecord(int sid)

append

public void append(RecordBase r)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataValidityTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class DataValidityTable

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.DataValidityTable

public final class DataValidityTable
extends RecordAggregate

Manages the DVALRecord and DVRecords for a single sheet
See OOO excelfileformat.pdf section 4.14

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
DataValidityTable()
DataValidityTable(RecordStream rs)
Method Summary
void | addDataValidation(DVRecord dvRecord)
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataValidityTable

public DataValidityTable(RecordStream rs)

DataValidityTable

public DataValidityTable()
Method Detail

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

addDataValidation

public void addDataValidation(DVRecord dvRecord)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaRecordAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class FormulaRecordAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate
All Implemented Interfaces:
CellValueRecordInterface
public final class FormulaRecordAggregate
extends RecordAggregate
implements CellValueRecordInterface

The formula record aggregate is used to join together the formula record and it's (optional) string record and (optional) Shared Formula Record (template reads, excel optimization).

Author:
Glen Stampoultzis (glens at apache.org), Vladimirs Abramovs(Vladimirs.Abramovs at exigenservices.com) - Array Formula support

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
FormulaRecordAggregate(FormulaRecord formulaRec, StringRecord stringRec, SharedValueManager svm)
Method Summary
CellRangeAddress | getArrayFormulaRange()
short | getColumn()
FormulaRecord | getFormulaRecord()
Ptg[] | getFormulaTokens()
int | getRow()
StringRecord | getStringRecord() debug only TODO - encapsulate
java.lang.String | getStringValue()
short | getXFIndex()
boolean | isPartOfArrayFormula()
void | notifyFormulaChanging() Should be called by any code which is either deleting this formula cell, or changing its type.
CellRangeAddress | removeArrayFormula(int rowIndex, int columnIndex) Removes an array formula
void | setArrayFormula(CellRangeAddress r, Ptg[] ptgs)
void | setCachedBooleanResult(boolean value)
void | setCachedDoubleResult(double value)
void | setCachedErrorResult(int errorCode)
void | setCachedStringResult(java.lang.String value)
void | setColumn(short col)
void | setParsedExpression(Ptg[] ptgs) Also checks for a related shared formula and unlinks it if found
void | setRow(int row)
void | setXFIndex(short xf)
java.lang.String | toString()
void | unlinkSharedFormula()
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FormulaRecordAggregate

public FormulaRecordAggregate(FormulaRecord formulaRec,
                              StringRecord stringRec,
                              SharedValueManager svm)
Parameters:
stringRec - may be null if this formula does not have a cached text value.
svm - the SharedValueManager for the current sheet
Method Detail

getFormulaRecord

public FormulaRecord getFormulaRecord()

getStringRecord

public StringRecord getStringRecord()
debug only TODO - encapsulate

getXFIndex

public short getXFIndex()
Specified by:
getXFIndex in interface CellValueRecordInterface

setXFIndex

public void setXFIndex(short xf)
Specified by:
setXFIndex in interface CellValueRecordInterface

setColumn

public void setColumn(short col)
Specified by:
setColumn in interface CellValueRecordInterface
Parameters:
col - the column this cell defines

setRow

public void setRow(int row)
Specified by:
setRow in interface CellValueRecordInterface
Parameters:
row - the row this cell occurs within

getColumn

public short getColumn()
Specified by:
getColumn in interface CellValueRecordInterface
Returns:
the column this cell defines within the row

getRow

public int getRow()
Specified by:
getRow in interface CellValueRecordInterface
Returns:
the row this cell occurs on

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

getStringValue

public java.lang.String getStringValue()

setCachedStringResult

public void setCachedStringResult(java.lang.String value)

setCachedBooleanResult

public void setCachedBooleanResult(boolean value)

setCachedErrorResult

public void setCachedErrorResult(int errorCode)

setCachedDoubleResult

public void setCachedDoubleResult(double value)

getFormulaTokens

public Ptg[] getFormulaTokens()

setParsedExpression

public void setParsedExpression(Ptg[] ptgs)
Also checks for a related shared formula and unlinks it if found

unlinkSharedFormula

public void unlinkSharedFormula()

notifyFormulaChanging

public void notifyFormulaChanging()
Should be called by any code which is either deleting this formula cell, or changing its type. This method gives the aggregate a chance to unlink any shared formula that may be involved with this cell formula.

isPartOfArrayFormula

public boolean isPartOfArrayFormula()

getArrayFormulaRange

public CellRangeAddress getArrayFormulaRange()

setArrayFormula

public void setArrayFormula(CellRangeAddress r,
                            Ptg[] ptgs)

removeArrayFormula

public CellRangeAddress removeArrayFormula(int rowIndex,
                                           int columnIndex)
Removes an array formula

Returns:
the range of the array formula containing the specified cell. Never null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MergedCellsTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class MergedCellsTable

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.MergedCellsTable

public final class MergedCellsTable
extends RecordAggregate

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
MergedCellsTable()
Creates an empty aggregate
Method Summary
void | addArea(int rowFrom, int colFrom, int rowTo, int colTo)
void | addRecords(MergeCellsRecord[] mcrs)
CellRangeAddress | get(int index)
int | getNumberOfMergedRegions()
int | getRecordSize() gives the current serialized size of the record.
void | read(RecordStream rs) reads zero or more consecutive MergeCellsRecords
void | remove(int index)
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MergedCellsTable

public MergedCellsTable()
Creates an empty aggregate

Method Detail

read

public void read(RecordStream rs)
reads zero or more consecutive MergeCellsRecords

Parameters:
rs -

getRecordSize

public int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Overrides:
getRecordSize in class RecordAggregate

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

addRecords

public void addRecords(MergeCellsRecord[] mcrs)

get

public CellRangeAddress get(int index)

remove

public void remove(int index)

addArea

public void addArea(int rowFrom,
                    int colFrom,
                    int rowTo,
                    int colTo)

getNumberOfMergedRegions

public int getNumberOfMergedRegions()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record.aggregates
Interfaces
RecordAggregate.RecordVisitor
Classes
CFRecordsAggregate
ChartSubstreamRecordAggregate
ColumnInfoRecordsAggregate
ConditionalFormattingTable
CustomViewSettingsRecordAggregate
DataValidityTable
FormulaRecordAggregate
MergedCellsTable
PageSettingsBlock
RecordAggregate
RecordAggregate.PositionTrackingVisitor
RowRecordsAggregate
SharedValueManager
ValueRecordsAggregate
WorksheetProtectionBlock


org.apache.poi.hssf.record.aggregates

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record.aggregates

record aggregates are not real "records" but collections of records that act as a single record.

See:
Description

Interface Summary
RecordAggregate.RecordVisitor

Class Summary
CFRecordsAggregate | CFRecordsAggregate - aggregates Conditional Formatting records CFHeaderRecord and number of up to three CFRuleRecord records together to simplify access to them.
ChartSubstreamRecordAggregate | Manages the all the records associated with a chart sub-stream. Includes the initial BOFRecord and final EOFRecord.
ColumnInfoRecordsAggregate |
ConditionalFormattingTable | Holds all the conditional formatting for a workbook sheet. See OOO exelfileformat.pdf sec 4.12 'Conditional Formatting Table'
CustomViewSettingsRecordAggregate | Manages the all the records associated with a 'Custom View Settings' sub-stream. Includes the initial USERSVIEWBEGIN(0x01AA) and final USERSVIEWEND(0x01AB).
DataValidityTable | Manages the DVALRecord and DVRecords for a single sheet See OOO excelfileformat.pdf section 4.14
FormulaRecordAggregate | The formula record aggregate is used to join together the formula record and it's (optional) string record and (optional) Shared Formula Record (template reads, excel optimization).
MergedCellsTable |
PageSettingsBlock | Groups the page settings records for a worksheet. See OOO excelfileformat.pdf sec 4.4 'Page Settings Block'
RecordAggregate | RecordAggregates are groups of of BIFF Records that are typically stored together and/or updated together.
RecordAggregate.PositionTrackingVisitor | A wrapper for RecordAggregate.RecordVisitor which accumulates the sizes of all records visited.
RowRecordsAggregate |
SharedValueManager | Manages various auxiliary records while constructing a RowRecordsAggregate: SharedFormulaRecords ArrayRecords TableRecords
ValueRecordsAggregate | Aggregate value records together.
WorksheetProtectionBlock | Groups the sheet protection records for a worksheet.

Package org.apache.poi.hssf.record.aggregates Description

record aggregates are not real "records" but collections of records that act as a single record. This is an optimization basically.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.hssf.record, org.apache.poi.hssf.eventmodel, RecordFactory


org.apache.poi.hssf.record.aggregates Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record.aggregates

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor (implements org.apache.poi.hssf.record.aggregates.RecordAggregate.RecordVisitor)
    • org.apache.poi.hssf.record.RecordBase
      • org.apache.poi.hssf.record.aggregates.RecordAggregate
        • org.apache.poi.hssf.record.aggregates.CFRecordsAggregate
        • org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate
        • org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate
        • org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable
        • org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate
        • org.apache.poi.hssf.record.aggregates.DataValidityTable
        • org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate (implements org.apache.poi.hssf.record.CellValueRecordInterface)
        • org.apache.poi.hssf.record.aggregates.MergedCellsTable
        • org.apache.poi.hssf.record.aggregates.PageSettingsBlock
        • org.apache.poi.hssf.record.aggregates.RowRecordsAggregate
        • org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock
    • org.apache.poi.hssf.record.aggregates.SharedValueManager
    • org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate (implements java.lang.Iterable<T>)

Interface Hierarchy

  • org.apache.poi.hssf.record.aggregates.RecordAggregate.RecordVisitor


Uses of Package org.apache.poi.hssf.record.aggregates

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record.aggregates

Packages that use org.apache.poi.hssf.record.aggregates
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Classes in org.apache.poi.hssf.record.aggregates used by org.apache.poi.hssf.model
ConditionalFormattingTable
Holds all the conditional formatting for a workbook sheet.

See OOO exelfileformat.pdf sec 4.12 'Conditional Formatting Table'

DataValidityTable
Manages the DVALRecord and DVRecords for a single sheet
See OOO excelfileformat.pdf section 4.14
PageSettingsBlock
Groups the page settings records for a worksheet.

See OOO excelfileformat.pdf sec 4.4 'Page Settings Block'

RecordAggregate.RecordVisitor
RowRecordsAggregate
SharedValueManager
Manages various auxiliary records while constructing a RowRecordsAggregate: SharedFormulaRecords ArrayRecords TableRecords
WorksheetProtectionBlock
Groups the sheet protection records for a worksheet.

Classes in org.apache.poi.hssf.record.aggregates used by org.apache.poi.hssf.record.aggregates
CFRecordsAggregate
CFRecordsAggregate - aggregates Conditional Formatting records CFHeaderRecord and number of up to three CFRuleRecord records together to simplify access to them.
FormulaRecordAggregate
The formula record aggregate is used to join together the formula record and it's (optional) string record and (optional) Shared Formula Record (template reads, excel optimization).
RecordAggregate
RecordAggregates are groups of of BIFF Records that are typically stored together and/or updated together.
RecordAggregate.RecordVisitor
SharedValueManager
Manages various auxiliary records while constructing a RowRecordsAggregate: SharedFormulaRecords ArrayRecords TableRecords

Classes in org.apache.poi.hssf.record.aggregates used by org.apache.poi.hssf.usermodel
PageSettingsBlock
Groups the page settings records for a worksheet.

See OOO excelfileformat.pdf sec 4.4 'Page Settings Block'

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PageSettingsBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class PageSettingsBlock

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.PageSettingsBlock

public final class PageSettingsBlock
extends RecordAggregate

Groups the page settings records for a worksheet.

See OOO excelfileformat.pdf sec 4.4 'Page Settings Block'

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
PageSettingsBlock()
Creates a PageSettingsBlock with default settings
PageSettingsBlock(RecordStream rs)
Method Summary
void | addLateHeaderFooter(HeaderFooterRecord rec) HEADERFOOTER is new in 2007.
void | addLateRecords(RecordStream rs) This method reads PageSettingsBlock records from the supplied RecordStream until the first non-PageSettingsBlock record is encountered.
int[] | getColumnBreaks()
FooterRecord | getFooter() Returns the FooterRecord.
HCenterRecord | getHCenter()
HeaderRecord | getHeader() Returns the HeaderRecord.
double | getMargin(short margin) Gets the size of the margin in inches.
int | getNumColumnBreaks()
int | getNumRowBreaks()
PrintSetupRecord | getPrintSetup() Returns the PrintSetupRecord.
int[] | getRowBreaks()
VCenterRecord | getVCenter()
boolean | isColumnBroken(int column) Queries if the specified column has a page break
static boolean | isComponentRecord(int sid)
boolean | isRowBroken(int row) Queries if the specified row has a page break
void | positionRecords(java.util.List<RecordBase> sheetRecords) Some apps can define multiple HeaderFooterRecord records for a sheet.
void | removeColumnBreak(int column) Removes a page break at the indicated column
void | removeRowBreak(int row) Removes a page break at the indicated row
void | setColumnBreak(short column, short fromRow, short toRow) Sets a page break at the indicated column
void | setFooter(FooterRecord newFooter) Sets the FooterRecord.
void | setHeader(HeaderRecord newHeader) Sets the HeaderRecord.
void | setMargin(short margin, double size) Sets the size of the margin in inches.
void | setPrintSetup(PrintSetupRecord newPrintSetup) Sets the PrintSetupRecord.
void | setRowBreak(int row, short fromCol, short toCol) Sets a page break at the indicated row
void | shiftColumnBreaks(short startingCol, short endingCol, short count) Shifts the vertical page breaks for the indicated count
void | shiftRowBreaks(int startingRow, int endingRow, int count) Shifts the horizontal page breaks for the indicated count
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PageSettingsBlock

public PageSettingsBlock(RecordStream rs)

PageSettingsBlock

public PageSettingsBlock()
Creates a PageSettingsBlock with default settings

Method Detail

isComponentRecord

public static boolean isComponentRecord(int sid)
Returns:
true if the specified Record sid is one belonging to the 'Page Settings Block'.

setColumnBreak

public void setColumnBreak(short column,
                           short fromRow,
                           short toRow)
Sets a page break at the indicated column

removeColumnBreak

public void removeColumnBreak(int column)
Removes a page break at the indicated column

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

getHeader

public HeaderRecord getHeader()
Returns the HeaderRecord.

Returns:
HeaderRecord for the sheet.

setHeader

public void setHeader(HeaderRecord newHeader)
Sets the HeaderRecord.

Parameters:
newHeader - The new HeaderRecord for the sheet.

getFooter

public FooterRecord getFooter()
Returns the FooterRecord.

Returns:
FooterRecord for the sheet.

setFooter

public void setFooter(FooterRecord newFooter)
Sets the FooterRecord.

Parameters:
newFooter - The new FooterRecord for the sheet.

getPrintSetup

public PrintSetupRecord getPrintSetup()
Returns the PrintSetupRecord.

Returns:
PrintSetupRecord for the sheet.

setPrintSetup

public void setPrintSetup(PrintSetupRecord newPrintSetup)
Sets the PrintSetupRecord.

Parameters:
newPrintSetup - The new PrintSetupRecord for the sheet.

getMargin

public double getMargin(short margin)
Gets the size of the margin in inches.

Parameters:
margin - which margin to get
Returns:
the size of the margin

setMargin

public void setMargin(short margin,
                      double size)
Sets the size of the margin in inches.

Parameters:
margin - which margin to get
size - the size of the margin

setRowBreak

public void setRowBreak(int row,
                        short fromCol,
                        short toCol)
Sets a page break at the indicated row

Parameters:
row -

removeRowBreak

public void removeRowBreak(int row)
Removes a page break at the indicated row

Parameters:
row -

isRowBroken

public boolean isRowBroken(int row)
Queries if the specified row has a page break

Parameters:
row -
Returns:
true if the specified row has a page break

isColumnBroken

public boolean isColumnBroken(int column)
Queries if the specified column has a page break

Returns:
true if the specified column has a page break

shiftRowBreaks

public void shiftRowBreaks(int startingRow,
                           int endingRow,
                           int count)
Shifts the horizontal page breaks for the indicated count

Parameters:
startingRow -
endingRow -
count -

shiftColumnBreaks

public void shiftColumnBreaks(short startingCol,
                              short endingCol,
                              short count)
Shifts the vertical page breaks for the indicated count

Parameters:
startingCol -
endingCol -
count -

getRowBreaks

public int[] getRowBreaks()
Returns:
all the horizontal page breaks, never null

getNumRowBreaks

public int getNumRowBreaks()
Returns:
the number of row page breaks

getColumnBreaks

public int[] getColumnBreaks()
Returns:
all the column page breaks, never null

getNumColumnBreaks

public int getNumColumnBreaks()
Returns:
the number of column page breaks

getVCenter

public VCenterRecord getVCenter()

getHCenter

public HCenterRecord getHCenter()

addLateHeaderFooter

public void addLateHeaderFooter(HeaderFooterRecord rec)
HEADERFOOTER is new in 2007. Some apps seem to have scattered this record long after the PageSettingsBlock where it belongs.

addLateRecords

public void addLateRecords(RecordStream rs)
This method reads PageSettingsBlock records from the supplied RecordStream until the first non-PageSettingsBlock record is encountered. As each record is read, it is incorporated into this PageSettingsBlock.

The latest Excel version seems to write the PageSettingsBlock uninterrupted. However there are several examples (that Excel reads OK) where these records are not written together:

  • HEADER_FOOTER(0x089C) after WINDOW2 - This record is new in 2007. Some apps seem to have scattered this record long after the PageSettingsBlock where it belongs test samples: SharedFormulaTest.xls, ex44921-21902.xls, ex42570-20305.xls
  • PLS, WSBOOL, PageSettingsBlock - WSBOOL is not a PSB record. This happens in the test sample file "NoGutsRecords.xls" and "WORKBOOK_in_capitals.xls"
  • Margins after DIMENSION - All of PSB should be before DIMENSION. (Bug-47199)
These were probably written by other applications (or earlier versions of Excel). It was decided to not write specific code for detecting each of these cases. POI now tolerates PageSettingsBlock records scattered all over the sheet record stream, and in any order, but does not allow duplicates of any of those records.

Note - when POI writes out this PageSettingsBlock, the records will always be written in one consolidated block (in the standard ordering) regardless of how scattered the records were when they were originally read.

Throws:
RecordFormatException - if any PSB record encountered has the same type (sid) as a record that is already part of this PageSettingsBlock

positionRecords

public void positionRecords(java.util.List<RecordBase> sheetRecords)
Some apps can define multiple HeaderFooterRecord records for a sheet. When saving such a file Excel 2007 re-positions them according to the following rules: - take a HeaderFooterRecord and read 16-byte GUID at offset 12. If it is zero, it means the current sheet and the given HeaderFooterRecord belongs to this PageSettingsBlock - If GUID is not zero then search in preceding CustomViewSettingsRecordAggregates. Compare first 16 bytes of UserSViewBegin with the HeaderFooterRecord's GUID. If match, then append the HeaderFooterRecord to this CustomViewSettingsRecordAggregates

Parameters:
sheetRecords - the list of sheet records read so far
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class RecordAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
Direct Known Subclasses:
CFRecordsAggregate, ChartSubstreamRecordAggregate, ColumnInfoRecordsAggregate, ConditionalFormattingTable, CustomViewSettingsRecordAggregate, DataValidityTable, FormulaRecordAggregate, MergedCellsTable, PageSettingsBlock, RowRecordsAggregate, WorksheetProtectionBlock
public abstract class RecordAggregate
extends RecordBase

RecordAggregates are groups of of BIFF Records that are typically stored together and/or updated together. Workbook / Sheet records are typically stored in a sequential list, which does not provide much structure to coordinate updates.

Author:
Josh Micich

Nested Class Summary
static class | RecordAggregate.PositionTrackingVisitor A wrapper for RecordAggregate.RecordVisitor which accumulates the sizes of all records visited.
static interface | RecordAggregate.RecordVisitor
Constructor Summary
RecordAggregate()
Method Summary
int | getRecordSize() gives the current serialized size of the record.
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
abstract void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordAggregate

public RecordAggregate()
Method Detail

visitContainedRecords

public abstract void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

serialize

public final int serialize(int offset,
                           byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written

getRecordSize

public int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordAggregate.PositionTrackingVisitor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class RecordAggregate.PositionTrackingVisitor

java.lang.Object
    extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor
All Implemented Interfaces:
RecordAggregate.RecordVisitor
Enclosing class:
RecordAggregate
public static final class RecordAggregate.PositionTrackingVisitor
extends java.lang.Object
implements RecordAggregate.RecordVisitor

A wrapper for RecordAggregate.RecordVisitor which accumulates the sizes of all records visited.

Constructor Summary
RecordAggregate.PositionTrackingVisitor(RecordAggregate.RecordVisitor rv, int initialPosition)
Method Summary
int | getPosition()
void | setPosition(int position)
void | visitRecord(Record r) Implementors may call non-mutating methods on Record r.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordAggregate.PositionTrackingVisitor

public RecordAggregate.PositionTrackingVisitor(RecordAggregate.RecordVisitor rv,
                                               int initialPosition)
Method Detail

visitRecord

public void visitRecord(Record r)
Description copied from interface: RecordAggregate.RecordVisitor
Implementors may call non-mutating methods on Record r.

Specified by:
visitRecord in interface RecordAggregate.RecordVisitor
Parameters:
r - must not be null

setPosition

public void setPosition(int position)

getPosition

public int getPosition()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordAggregate.RecordVisitor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Interface RecordAggregate.RecordVisitor

All Known Implementing Classes:
RecordAggregate.PositionTrackingVisitor
Enclosing class:
RecordAggregate
public static interface RecordAggregate.RecordVisitor

Method Summary
 void visitRecord(Record r)
Implementors may call non-mutating methods on Record r.

Method Detail

visitRecord

void visitRecord(Record r)
Implementors may call non-mutating methods on Record r.

Parameters:
r - must not be null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RowRecordsAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class RowRecordsAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

public final class RowRecordsAggregate
extends RecordAggregate

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
RowRecordsAggregate()
Creates a new instance of ValueRecordsAggregate
RowRecordsAggregate(RecordStream rs, SharedValueManager svm)
Method Summary
 void collapseRow(int rowNumber)
 DimensionsRecord createDimensions()
 FormulaRecordAggregate createFormula(int row, int col)
 IndexRecord createIndexRecord(int indexRecordOffset, int sizeOfInitialSheetRecords)
static RowRecord createRow(int rowNumber)
Create a row record.
 void expandRow(int rowNumber)
 int findEndOfRowOutlineGroup(int row)
 int findStartOfRowOutlineGroup(int row)
 java.util.Iterator<CellValueRecordInterface> getCellValueIterator()
Returns an iterator for the cell values
 int getFirstRowNum()
 java.util.Iterator<RowRecord> getIterator()
 int getLastRowNum()
 int getPhysicalNumberOfRows()
 RowRecord getRow(int rowIndex)
 int getRowBlockCount()
Returns the number of row blocks.
 int getRowCountForBlock(int block)
Returns the number of physical rows within a block
 CellValueRecordInterface[] getValueRecords()
Deprecated. use getCellValueIterator() instead
 void insertCell(CellValueRecordInterface cvRec)
 void insertRow(RowRecord row)
 boolean isRowGroupCollapsed(int row)
 boolean isRowGroupHiddenByParent(int row)
 void removeCell(CellValueRecordInterface cvRec)
 void removeRow(RowRecord row)
 void updateFormulasAfterRowShift(FormulaShifter formulaShifter, int currentExternSheetIndex)
 void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RowRecordsAggregate

public RowRecordsAggregate()
Creates a new instance of ValueRecordsAggregate

RowRecordsAggregate

public RowRecordsAggregate(RecordStream rs,
                           SharedValueManager svm)
Parameters:
rs - record stream with all SharedFormulaRecord ArrayRecord, TableRecord MergeCellsRecord Records removed
svm - an initialised SharedValueManager (from the shared formula, array and table records of the current sheet). Never null.
Method Detail

insertRow

public void insertRow(RowRecord row)

removeRow

public void removeRow(RowRecord row)

getRow

public RowRecord getRow(int rowIndex)

getPhysicalNumberOfRows

public int getPhysicalNumberOfRows()

getFirstRowNum

public int getFirstRowNum()

getLastRowNum

public int getLastRowNum()

getRowBlockCount

public int getRowBlockCount()
Returns the number of row blocks.

The row blocks are goupings of rows that contain the DBCell record after them

getRowCountForBlock

public int getRowCountForBlock(int block)
Returns the number of physical rows within a block

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

getIterator

public java.util.Iterator<RowRecord> getIterator()

findStartOfRowOutlineGroup

public int findStartOfRowOutlineGroup(int row)

findEndOfRowOutlineGroup

public int findEndOfRowOutlineGroup(int row)

collapseRow

public void collapseRow(int rowNumber)

createRow

public static RowRecord createRow(int rowNumber)
Create a row record.

Parameters:
rowNumber - row number
Returns:
RowRecord created for the passed in row number
See Also:
RowRecord

isRowGroupCollapsed

public boolean isRowGroupCollapsed(int row)

expandRow

public void expandRow(int rowNumber)

isRowGroupHiddenByParent

public boolean isRowGroupHiddenByParent(int row)

getCellValueIterator

public java.util.Iterator<CellValueRecordInterface> getCellValueIterator()
Returns an iterator for the cell values

getValueRecords

public CellValueRecordInterface[] getValueRecords()
Deprecated. use getCellValueIterator() instead

createIndexRecord

public IndexRecord createIndexRecord(int indexRecordOffset,
                                     int sizeOfInitialSheetRecords)

insertCell

public void insertCell(CellValueRecordInterface cvRec)

removeCell

public void removeCell(CellValueRecordInterface cvRec)

createFormula

public FormulaRecordAggregate createFormula(int row,
                                            int col)

updateFormulasAfterRowShift

public void updateFormulasAfterRowShift(FormulaShifter formulaShifter,
                                        int currentExternSheetIndex)

createDimensions

public DimensionsRecord createDimensions()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SharedValueManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class SharedValueManager

java.lang.Object
    extended by  org.apache.poi.hssf.record.aggregates.SharedValueManager

public final class SharedValueManager
extends java.lang.Object

Manages various auxiliary records while constructing a RowRecordsAggregate:

  • SharedFormulaRecords
  • ArrayRecords
  • TableRecords

Author:
Josh Micich, Vladimirs Abramovs(Vladimirs.Abramovs at exigenservices.com) - handling of ArrayRecords

Method Summary
void | addArrayRecord(ArrayRecord ar) Add specified Array Record.
static SharedValueManager | create(SharedFormulaRecord[] sharedFormulaRecords, CellReference[] firstCells, ArrayRecord[] arrayRecords, TableRecord[] tableRecords)
static SharedValueManager | createEmpty()
ArrayRecord | getArrayRecord(int firstRow, int firstColumn)
SharedValueRecordBase | getRecordForFirstCell(FormulaRecordAggregate agg) Gets the SharedValueRecordBase record if it should be encoded immediately after the formula record contained in the specified FormulaRecordAggregate agg.
SharedFormulaRecord | linkSharedFormulaRecord(CellReference firstCell, FormulaRecordAggregate agg)
CellRangeAddress8Bit | removeArrayFormula(int rowIndex, int columnIndex) Removes the ArrayRecord for the cell group containing the specified cell.
void | unlink(SharedFormulaRecord sharedFormulaRecord) Converts all FormulaRecords handled by sharedFormulaRecord to plain unshared formulas
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createEmpty

public static SharedValueManager createEmpty()
Returns:
a new empty SharedValueManager.

create

public static SharedValueManager create(SharedFormulaRecord[] sharedFormulaRecords,
                                        CellReference[] firstCells,
                                        ArrayRecord[] arrayRecords,
                                        TableRecord[] tableRecords)

linkSharedFormulaRecord

public SharedFormulaRecord linkSharedFormulaRecord(CellReference firstCell,
                                                   FormulaRecordAggregate agg)
Parameters:
firstCell - as extracted from the ExpPtg from the cell's formula.
Returns:
never null

getRecordForFirstCell

public SharedValueRecordBase getRecordForFirstCell(FormulaRecordAggregate agg)
Gets the SharedValueRecordBase record if it should be encoded immediately after the formula record contained in the specified FormulaRecordAggregate agg. Note - the shared value record always appears after the first formula record in the group. For arrays and tables the first formula is always the in the top left cell. However, since shared formula groups can be sparse and/or overlap, the first formula may not actually be in the top left cell.

Returns:
the SHRFMLA, TABLE or ARRAY record for the formula cell, if it is the first cell of a table or array region. null if the formula cell is not shared/array/table, or if the specified formula is not the the first in the group.

unlink

public void unlink(SharedFormulaRecord sharedFormulaRecord)
Converts all FormulaRecords handled by sharedFormulaRecord to plain unshared formulas

addArrayRecord

public void addArrayRecord(ArrayRecord ar)
Add specified Array Record.

removeArrayFormula

public CellRangeAddress8Bit removeArrayFormula(int rowIndex,
                                               int columnIndex)
Removes the ArrayRecord for the cell group containing the specified cell. The caller should clear (set blank) all cells in the returned range.

Returns:
the range of the array formula which was just removed. Never null.

getArrayRecord

public ArrayRecord getArrayRecord(int firstRow,
                                  int firstColumn)
Returns:
the shared ArrayRecord identified by (firstRow, firstColumn). never null.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueRecordsAggregate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class ValueRecordsAggregate

java.lang.Object
    extended by  org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate
All Implemented Interfaces:
java.lang.Iterable<CellValueRecordInterface>
public final class ValueRecordsAggregate
extends java.lang.Object
implements java.lang.Iterable<CellValueRecordInterface>

Aggregate value records together. Things are easier to handle that way.

Author:
andy, Glen Stampoultzis (glens at apache.org), Jason Height (jheight at chariot dot net dot au)

Constructor Summary
ValueRecordsAggregate()
Creates a new instance of ValueRecordsAggregate
Method Summary
 void addMultipleBlanks(MulBlankRecord mbr)
 java.lang.Object clone()
 void construct(CellValueRecordInterface rec, RecordStream rs, SharedValueManager sfh)
Processes a single cell value record
 int getFirstCellNum()
 int getLastCellNum()
 int getPhysicalNumberOfCells()
 int getRowCellBlockSize(int startRow, int endRow)
Tallies a count of the size of the cell records that are attached to the rows in the range specified.
 CellValueRecordInterface[] getValueRecords()
Deprecated. use iterator() instead
 void insertCell(CellValueRecordInterface cell)
 java.util.Iterator<CellValueRecordInterface> iterator()
value iterator
 void removeAllCellsValuesForRow(int rowIndex)
 void removeCell(CellValueRecordInterface cell)
 boolean rowHasCells(int row)
Returns true if the row has cells attached to it
 void updateFormulasAfterRowShift(FormulaShifter shifter, int currentExternSheetIndex)
 void visitCellsForRow(int rowIndex, RecordAggregate.RecordVisitor rv)
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValueRecordsAggregate

public ValueRecordsAggregate()
Creates a new instance of ValueRecordsAggregate

Method Detail

insertCell

public void insertCell(CellValueRecordInterface cell)

removeCell

public void removeCell(CellValueRecordInterface cell)

removeAllCellsValuesForRow

public void removeAllCellsValuesForRow(int rowIndex)

getPhysicalNumberOfCells

public int getPhysicalNumberOfCells()

getFirstCellNum

public int getFirstCellNum()

getLastCellNum

public int getLastCellNum()

addMultipleBlanks

public void addMultipleBlanks(MulBlankRecord mbr)

construct

public void construct(CellValueRecordInterface rec,
                      RecordStream rs,
                      SharedValueManager sfh)
Processes a single cell value record

Parameters:
sfh - used to resolve any shared-formulas/arrays/tables for the current sheet

getRowCellBlockSize

public int getRowCellBlockSize(int startRow,
                               int endRow)
Tallies a count of the size of the cell records that are attached to the rows in the range specified.

rowHasCells

public boolean rowHasCells(int row)
Returns true if the row has cells attached to it

visitCellsForRow

public void visitCellsForRow(int rowIndex,
                             RecordAggregate.RecordVisitor rv)

updateFormulasAfterRowShift

public void updateFormulasAfterRowShift(FormulaShifter shifter,
                                        int currentExternSheetIndex)

iterator

public java.util.Iterator<CellValueRecordInterface> iterator()
value iterator

Specified by:
iterator in interface java.lang.Iterable<CellValueRecordInterface>

getValueRecords

@Deprecated
public CellValueRecordInterface[] getValueRecords()
Deprecated. use iterator() instead

Gets all the cell records contained in this aggregate. Note BlankRecords appear separate (not in MulBlankRecords).

clone

public java.lang.Object clone()
Overrides:
clone in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorksheetProtectionBlock

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.aggregates
Class WorksheetProtectionBlock

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.aggregates.RecordAggregate
            extended by  org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

public final class WorksheetProtectionBlock
extends RecordAggregate

Groups the sheet protection records for a worksheet.

See OOO excelfileformat.pdf sec 4.18.2 'Sheet Protection in a Workbook (BIFF5-BIFF8)'

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
RecordAggregate.PositionTrackingVisitor, RecordAggregate.RecordVisitor
Constructor Summary
WorksheetProtectionBlock()
Creates an empty WorksheetProtectionBlock
Method Summary
void | addRecords(RecordStream rs) This method reads WorksheetProtectionBlock records from the supplied RecordStream until the first non-WorksheetProtectionBlock record is encountered.
ScenarioProtectRecord | getHCenter()
int | getPasswordHash()
PasswordRecord | getPasswordRecord()
static boolean | isComponentRecord(int sid)
boolean | isObjectProtected()
boolean | isScenarioProtected()
boolean | isSheetProtected()
void | protectSheet(java.lang.String password, boolean shouldProtectObjects, boolean shouldProtectScenarios) protect a spreadsheet with a password (not encrypted, just sets protect flags and the password.
void | visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
Methods inherited from class org.apache.poi.hssf.record.aggregates.RecordAggregate
getRecordSize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorksheetProtectionBlock

public WorksheetProtectionBlock()
Creates an empty WorksheetProtectionBlock

Method Detail

isComponentRecord

public static boolean isComponentRecord(int sid)
Returns:
true if the specified Record sid is one belonging to the 'Page Settings Block'.

visitContainedRecords

public void visitContainedRecords(RecordAggregate.RecordVisitor rv)
Description copied from class: RecordAggregate
Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file. Implementors may or may not return the actual Records being used to manage POI's internal implementation. Callers should not assume either way, and therefore only attempt to modify those Records after cloning

Specified by:
visitContainedRecords in class RecordAggregate

getPasswordRecord

public PasswordRecord getPasswordRecord()

getHCenter

public ScenarioProtectRecord getHCenter()

addRecords

public void addRecords(RecordStream rs)
This method reads WorksheetProtectionBlock records from the supplied RecordStream until the first non-WorksheetProtectionBlock record is encountered. As each record is read, it is incorporated into this WorksheetProtectionBlock.

As per the OOO documentation, the protection block records can be expected to be written together (with no intervening records), but earlier versions of POI (prior to Jun 2009) didn't do this. Workbooks with sheet protection created by those earlier POI versions seemed to be valid (Excel opens them OK). So PO allows continues to support reading of files with non continuous worksheet protection blocks.

Note - when POI writes out this WorksheetProtectionBlock, the records will always be written in one consolidated block (in the standard ordering) regardless of how scattered the records were when they were originally read.

protectSheet

public void protectSheet(java.lang.String password,
                         boolean shouldProtectObjects,
                         boolean shouldProtectScenarios)
protect a spreadsheet with a password (not encrypted, just sets protect flags and the password.

Parameters:
password - to set. Pass null to remove all protection
shouldProtectObjects - are protected
shouldProtectScenarios - are protected

isSheetProtected

public boolean isSheetProtected()

isObjectProtected

public boolean isObjectProtected()

isScenarioProtected

public boolean isScenarioProtected()

getPasswordHash

public int getPasswordHash()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.CFRecordsAggregate

Packages that use CFRecordsAggregate
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of CFRecordsAggregate in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return CFRecordsAggregate
CFRecordsAggregate | CFRecordsAggregate.cloneCFAggregate() Create a deep clone of the record
static CFRecordsAggregate | CFRecordsAggregate.createCFAggregate(RecordStream rs) Create CFRecordsAggregate from a list of CF Records
CFRecordsAggregate | ConditionalFormattingTable.get(int index)

Methods in org.apache.poi.hssf.record.aggregates with parameters of type CFRecordsAggregate
 int ConditionalFormattingTable.add(CFRecordsAggregate cfAggregate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate

No usage of org.apache.poi.hssf.record.aggregates.ChartSubstreamRecordAggregate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

No usage of org.apache.poi.hssf.record.aggregates.ColumnInfoRecordsAggregate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.ConditionalFormattingTable

Packages that use ConditionalFormattingTable
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of ConditionalFormattingTable in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return ConditionalFormattingTable
 ConditionalFormattingTable InternalSheet.getConditionalFormattingTable()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

No usage of org.apache.poi.hssf.record.aggregates.CustomViewSettingsRecordAggregate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.DataValidityTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.DataValidityTable

Packages that use DataValidityTable
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of DataValidityTable in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return DataValidityTable
 DataValidityTable InternalSheet.getOrCreateDataValidityTable()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.FormulaRecordAggregate

Packages that use FormulaRecordAggregate
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of FormulaRecordAggregate in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return FormulaRecordAggregate
 FormulaRecordAggregate RowRecordsAggregate.createFormula(int row, int col)

Methods in org.apache.poi.hssf.record.aggregates with parameters of type FormulaRecordAggregate
SharedValueRecordBase | SharedValueManager.getRecordForFirstCell(FormulaRecordAggregate agg) Gets the SharedValueRecordBase record if it should be encoded immediately after the formula record contained in the specified FormulaRecordAggregate agg.
SharedFormulaRecord | SharedValueManager.linkSharedFormulaRecord(CellReference firstCell, FormulaRecordAggregate agg)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.MergedCellsTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.MergedCellsTable

No usage of org.apache.poi.hssf.record.aggregates.MergedCellsTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.PageSettingsBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.PageSettingsBlock

Packages that use PageSettingsBlock
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of PageSettingsBlock in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return PageSettingsBlock
 PageSettingsBlock InternalSheet.getPageSettings()

Uses of PageSettingsBlock in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type PageSettingsBlock
HSSFFooter(PageSettingsBlock psb)
HSSFHeader(PageSettingsBlock psb)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.RecordAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.RecordAggregate

Packages that use RecordAggregate
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of RecordAggregate in org.apache.poi.hssf.record.aggregates

Subclasses of RecordAggregate in org.apache.poi.hssf.record.aggregates
class | CFRecordsAggregate CFRecordsAggregate - aggregates Conditional Formatting records CFHeaderRecord and number of up to three CFRuleRecord records together to simplify access to them.
class | ChartSubstreamRecordAggregate Manages the all the records associated with a chart sub-stream. Includes the initial BOFRecord and final EOFRecord.
class | ColumnInfoRecordsAggregate
class | ConditionalFormattingTable Holds all the conditional formatting for a workbook sheet. See OOO exelfileformat.pdf sec 4.12 'Conditional Formatting Table'
class | CustomViewSettingsRecordAggregate Manages the all the records associated with a 'Custom View Settings' sub-stream. Includes the initial USERSVIEWBEGIN(0x01AA) and final USERSVIEWEND(0x01AB).
class | DataValidityTable Manages the DVALRecord and DVRecords for a single sheet See OOO excelfileformat.pdf section 4.14
class | FormulaRecordAggregate The formula record aggregate is used to join together the formula record and it's (optional) string record and (optional) Shared Formula Record (template reads, excel optimization).
class | MergedCellsTable
class | PageSettingsBlock Groups the page settings records for a worksheet. See OOO excelfileformat.pdf sec 4.4 'Page Settings Block'
class | RowRecordsAggregate
class | WorksheetProtectionBlock Groups the sheet protection records for a worksheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor

No usage of org.apache.poi.hssf.record.aggregates.RecordAggregate.PositionTrackingVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.record.aggregates.RecordAggregate.RecordVisitor

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.record.aggregates.RecordAggregate.RecordVisitor

Packages that use RecordAggregate.RecordVisitor
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of RecordAggregate.RecordVisitor in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type RecordAggregate.RecordVisitor
 void InternalSheet.visitContainedRecords(RecordAggregate.RecordVisitor rv, int offset)

Uses of RecordAggregate.RecordVisitor in org.apache.poi.hssf.record.aggregates

Classes in org.apache.poi.hssf.record.aggregates that implement RecordAggregate.RecordVisitor
static class RecordAggregate.PositionTrackingVisitor
A wrapper for RecordAggregate.RecordVisitor which accumulates the sizes of all records visited.

Methods in org.apache.poi.hssf.record.aggregates with parameters of type RecordAggregate.RecordVisitor
void | ValueRecordsAggregate.visitCellsForRow(int rowIndex, RecordAggregate.RecordVisitor rv)
void | WorksheetProtectionBlock.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | RowRecordsAggregate.visitContainedRecords(RecordAggregate.RecordVisitor rv)
abstract void | RecordAggregate.visitContainedRecords(RecordAggregate.RecordVisitor rv) Visit each of the atomic BIFF records contained in this RecordAggregate in the order that they should be written to file.
void | PageSettingsBlock.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | MergedCellsTable.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | FormulaRecordAggregate.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | DataValidityTable.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | CustomViewSettingsRecordAggregate.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | ConditionalFormattingTable.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | ColumnInfoRecordsAggregate.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | ChartSubstreamRecordAggregate.visitContainedRecords(RecordAggregate.RecordVisitor rv)
void | CFRecordsAggregate.visitContainedRecords(RecordAggregate.RecordVisitor rv)

Constructors in org.apache.poi.hssf.record.aggregates with parameters of type RecordAggregate.RecordVisitor
RecordAggregate.PositionTrackingVisitor(RecordAggregate.RecordVisitor rv, int initialPosition)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.RowRecordsAggregate

Packages that use RowRecordsAggregate
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of RowRecordsAggregate in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as RowRecordsAggregate
protected  RowRecordsAggregate InternalSheet._rowsAggregate
always present

Methods in org.apache.poi.hssf.model that return RowRecordsAggregate
 RowRecordsAggregate InternalSheet.getRowsAggregate()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.SharedValueManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.SharedValueManager

Packages that use SharedValueManager
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of SharedValueManager in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return SharedValueManager
 SharedValueManager RowBlocksReader.getSharedFormulaManager()

Uses of SharedValueManager in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return SharedValueManager
static SharedValueManager | SharedValueManager.create(SharedFormulaRecord[] sharedFormulaRecords, CellReference[] firstCells, ArrayRecord[] arrayRecords, TableRecord[] tableRecords)
static SharedValueManager | SharedValueManager.createEmpty()

Methods in org.apache.poi.hssf.record.aggregates with parameters of type SharedValueManager
 void ValueRecordsAggregate.construct(CellValueRecordInterface rec, RecordStream rs, SharedValueManager sfh)
Processes a single cell value record

Constructors in org.apache.poi.hssf.record.aggregates with parameters of type SharedValueManager
FormulaRecordAggregate(FormulaRecord formulaRec, StringRecord stringRec, SharedValueManager svm)
RowRecordsAggregate(RecordStream rs, SharedValueManager svm)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

No usage of org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.aggregates.WorksheetProtectionBlock

Packages that use WorksheetProtectionBlock
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of WorksheetProtectionBlock in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return WorksheetProtectionBlock
 WorksheetProtectionBlock InternalSheet.getProtectionBlock()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BorderFormatting

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.cf
Class BorderFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.record.cf.BorderFormatting

public final class BorderFormatting
extends java.lang.Object

Border Formatting Block of the Conditional Formatting Rule Record.

Author:
Dmitriy Kumshayev

Field Summary
static short | BORDER_DASH_DOT dash-dot border
static short | BORDER_DASH_DOT_DOT dash-dot-dot border
static short | BORDER_DASHED dash border
static short | BORDER_DOTTED hair-line border
static short | BORDER_DOUBLE double-line border
static short | BORDER_HAIR dot border
static short | BORDER_MEDIUM Medium border
static short | BORDER_MEDIUM_DASH_DOT medium dash-dot border
static short | BORDER_MEDIUM_DASH_DOT_DOT medium dash-dot-dot border
static short | BORDER_MEDIUM_DASHED Medium dashed border
static short | BORDER_NONE No border
static short | BORDER_SLANTED_DASH_DOT slanted dash-dot border
static short | BORDER_THICK Thick border
static short | BORDER_THIN Thin border
Constructor Summary
BorderFormatting()
BorderFormatting(LittleEndianInput in)
Creates new FontFormatting
Method Summary
java.lang.Object | clone()
int | getBorderBottom() get the type of border to use for the bottom border of the cell
int | getBorderDiagonal() get the type of border to use for the diagonal border of the cell
int | getBorderLeft() get the type of border to use for the left border of the cell
int | getBorderRight() get the type of border to use for the right border of the cell
int | getBorderTop() get the type of border to use for the top border of the cell
int | getBottomBorderColor() get the color to use for the bottom border
int | getDiagonalBorderColor() get the color to use for the diagonal border
int | getLeftBorderColor() get the color to use for the left border
int | getRightBorderColor() get the color to use for the right border
int | getTopBorderColor() get the color to use for the top border
boolean | isBackwardDiagonalOn()
boolean | isForwardDiagonalOn()
int | serialize(int offset, byte[] data)
void | serialize(LittleEndianOutput out)
void | setBackwardDiagonalOn(boolean on) Of/off top left to bottom right line
void | setBorderBottom(int border) set the type of border to use for the bottom border of the cell
void | setBorderDiagonal(int border) set the type of border to use for the diagonal border of the cell
void | setBorderLeft(int border) set the type of border to use for the left border of the cell
void | setBorderRight(int border) set the type of border to use for the right border of the cell
void | setBorderTop(int border) set the type of border to use for the top border of the cell
void | setBottomBorderColor(int color) set the color to use for the bottom border
void | setDiagonalBorderColor(int color) set the color to use for the diagonal borders
void | setForwardDiagonalOn(boolean on) Of/off bottom left to top right line
void | setLeftBorderColor(int color) set the color to use for the left border
void | setRightBorderColor(int color) set the color to use for the right border
void | setTopBorderColor(int color) set the color to use for the top border
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

BORDER_NONE

public static final short BORDER_NONE
No border

See Also:
Constant Field Values

BORDER_THIN

public static final short BORDER_THIN
Thin border

See Also:
Constant Field Values

BORDER_MEDIUM

public static final short BORDER_MEDIUM
Medium border

See Also:
Constant Field Values

BORDER_DASHED

public static final short BORDER_DASHED
dash border

See Also:
Constant Field Values

BORDER_HAIR

public static final short BORDER_HAIR
dot border

See Also:
Constant Field Values

BORDER_THICK

public static final short BORDER_THICK
Thick border

See Also:
Constant Field Values

BORDER_DOUBLE

public static final short BORDER_DOUBLE
double-line border

See Also:
Constant Field Values

BORDER_DOTTED

public static final short BORDER_DOTTED
hair-line border

See Also:
Constant Field Values

BORDER_MEDIUM_DASHED

public static final short BORDER_MEDIUM_DASHED
Medium dashed border

See Also:
Constant Field Values

BORDER_DASH_DOT

public static final short BORDER_DASH_DOT
dash-dot border

See Also:
Constant Field Values

BORDER_MEDIUM_DASH_DOT

public static final short BORDER_MEDIUM_DASH_DOT
medium dash-dot border

See Also:
Constant Field Values

BORDER_DASH_DOT_DOT

public static final short BORDER_DASH_DOT_DOT
dash-dot-dot border

See Also:
Constant Field Values

BORDER_MEDIUM_DASH_DOT_DOT

public static final short BORDER_MEDIUM_DASH_DOT_DOT
medium dash-dot-dot border

See Also:
Constant Field Values

BORDER_SLANTED_DASH_DOT

public static final short BORDER_SLANTED_DASH_DOT
slanted dash-dot border

See Also:
Constant Field Values
Constructor Detail

BorderFormatting

public BorderFormatting()

BorderFormatting

public BorderFormatting(LittleEndianInput in)
Creates new FontFormatting

Method Detail

setBorderLeft

public void setBorderLeft(int border)
set the type of border to use for the left border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderLeft

public int getBorderLeft()
get the type of border to use for the left border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setBorderRight

public void setBorderRight(int border)
set the type of border to use for the right border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderRight

public int getBorderRight()
get the type of border to use for the right border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setBorderTop

public void setBorderTop(int border)
set the type of border to use for the top border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderTop

public int getBorderTop()
get the type of border to use for the top border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setBorderBottom

public void setBorderBottom(int border)
set the type of border to use for the bottom border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderBottom

public int getBorderBottom()
get the type of border to use for the bottom border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setBorderDiagonal

public void setBorderDiagonal(int border)
set the type of border to use for the diagonal border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderDiagonal

public int getBorderDiagonal()
get the type of border to use for the diagonal border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setLeftBorderColor

public void setLeftBorderColor(int color)
set the color to use for the left border

Parameters:
color - The index of the color definition

getLeftBorderColor

public int getLeftBorderColor()
get the color to use for the left border

Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setRightBorderColor

public void setRightBorderColor(int color)
set the color to use for the right border

Parameters:
color - The index of the color definition

getRightBorderColor

public int getRightBorderColor()
get the color to use for the right border

Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setTopBorderColor

public void setTopBorderColor(int color)
set the color to use for the top border

Parameters:
color - The index of the color definition

getTopBorderColor

public int getTopBorderColor()
get the color to use for the top border

Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setBottomBorderColor

public void setBottomBorderColor(int color)
set the color to use for the bottom border

Parameters:
color - The index of the color definition

getBottomBorderColor

public int getBottomBorderColor()
get the color to use for the bottom border

Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setDiagonalBorderColor

public void setDiagonalBorderColor(int color)
set the color to use for the diagonal borders

Parameters:
color - The index of the color definition

getDiagonalBorderColor

public int getDiagonalBorderColor()
get the color to use for the diagonal border

Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setForwardDiagonalOn

public void setForwardDiagonalOn(boolean on)
Of/off bottom left to top right line

Parameters:
on - - if true - on, otherwise off

setBackwardDiagonalOn

public void setBackwardDiagonalOn(boolean on)
Of/off top left to bottom right line

Parameters:
on - - if true - on, otherwise off

isForwardDiagonalOn

public boolean isForwardDiagonalOn()
Returns:
true if forward diagonal is on

isBackwardDiagonalOn

public boolean isBackwardDiagonalOn()
Returns:
true if backward diagonal is on

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

clone

public java.lang.Object clone()
Overrides:
clone in class java.lang.Object

serialize

public int serialize(int offset,
                     byte[] data)

serialize

public void serialize(LittleEndianOutput out)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CellRangeUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.cf
Class CellRangeUtil

java.lang.Object
    extended by  org.apache.poi.hssf.record.cf.CellRangeUtil

public final class CellRangeUtil
extends java.lang.Object

Author:
Dmitriy Kumshayev

Field Summary
static int | ENCLOSES first range encloses or is equal to the second
static int | INSIDE first range is within the second range
static int | NO_INTERSECTION
static int | OVERLAP
Method Summary
static boolean | contains(CellRangeAddress crA, CellRangeAddress crB) Check if the specified range is located inside of this cell range.
static CellRangeAddress | createEnclosingCellRange(CellRangeAddress crA, CellRangeAddress crB) Create an enclosing CellRange for the two cell ranges.
static boolean | hasExactSharedBorder(CellRangeAddress crA, CellRangeAddress crB) Check if the specified cell range has a shared border with the current range.
static int | intersect(CellRangeAddress crA, CellRangeAddress crB) Intersect this range with the specified range.
static CellRangeAddress[] | mergeCellRanges(CellRangeAddress[] cellRanges) Do all possible cell merges between cells of the list so that: if a cell range is completely inside of another cell range, it gets removed from the list if two cells have a shared border, merge them into one bigger cell range
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_INTERSECTION

public static final int NO_INTERSECTION
See Also:
Constant Field Values

OVERLAP

public static final int OVERLAP
See Also:
Constant Field Values

INSIDE

public static final int INSIDE
first range is within the second range

See Also:
Constant Field Values

ENCLOSES

public static final int ENCLOSES
first range encloses or is equal to the second

See Also:
Constant Field Values
Method Detail

intersect

public static int intersect(CellRangeAddress crA,
                            CellRangeAddress crB)
Intersect this range with the specified range.

Parameters:
crB - - the specified range
Returns:
code which reflects how the specified range is related to this range.
Possible return codes are: NO_INTERSECTION - the specified range is outside of this range;
OVERLAP - both ranges partially overlap;
INSIDE - the specified range is inside of this one
ENCLOSES - the specified range encloses (possibly exactly the same as) this range

mergeCellRanges

public static CellRangeAddress[] mergeCellRanges(CellRangeAddress[] cellRanges)
Do all possible cell merges between cells of the list so that:
  • if a cell range is completely inside of another cell range, it gets removed from the list
  • if two cells have a shared border, merge them into one bigger cell range

    Parameters:
    cellRanges -
    Returns:
    updated List of cell ranges

    • contains

    public static boolean contains(CellRangeAddress crA,
                               CellRangeAddress crB)
    Check if the specified range is located inside of this cell range.

    Parameters:
    crB -
    Returns:
    true if this cell range contains the argument range inside if it's area

    hasExactSharedBorder

    public static boolean hasExactSharedBorder(CellRangeAddress crA,
                                           CellRangeAddress crB)
    Check if the specified cell range has a shared border with the current range.

    Returns:
    true if the ranges have a complete shared border (i.e. the two ranges together make a simple rectangular region.

    createEnclosingCellRange

    public static CellRangeAddress createEnclosingCellRange(CellRangeAddress crA,
                                                        CellRangeAddress crB)
    Create an enclosing CellRange for the two cell ranges.

    Returns:
    enclosing CellRange
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.cf
Class FontFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.record.cf.FontFormatting

public final class FontFormatting
extends java.lang.Object

Font Formatting Block of the Conditional Formatting Rule Record.

Author:
Dmitriy Kumshayev

Field Summary
static int | FONT_CELL_HEIGHT_PRESERVED
static short | SS_NONE Escapement type - None
static short | SS_SUB Escapement type - Subscript
static short | SS_SUPER Escapement type - Superscript
static byte | U_DOUBLE Underline type - Double
static byte | U_DOUBLE_ACCOUNTING Underline type - Double Accounting
static byte | U_NONE Underline type - None
static byte | U_SINGLE Underline type - Single
static byte | U_SINGLE_ACCOUNTING Underline type - Single Accounting
Constructor Summary
FontFormatting()
FontFormatting(RecordInputStream in)
Creates new FontFormatting
Method Summary
java.lang.Object | clone()
short | getEscapementType() get the type of super or subscript for the font
short | getFontColorIndex()
int | getFontHeight() gets the height of the font in 1/20th point units
short | getFontWeight() get the font weight for this font (100-1000dec or 0x64-0x3e8).
byte[] | getRawRecord()
short | getUnderlineType() get the type of underlining for the font
boolean | isBold() get whether the font weight is set to bold or not
boolean | isEscapementTypeModified()
boolean | isFontCancellationModified()
boolean | isFontOutlineModified()
boolean | isFontShadowModified()
boolean | isFontStyleModified()
boolean | isFontWeightModified()
boolean | isItalic() get whether the font is to be italics or not
boolean | isOutlineOn()
boolean | isShadowOn()
boolean | isStruckout() get whether the font is to be stricken out or not
boolean | isUnderlineTypeModified()
void | setBold(boolean bold) set the font weight to bold (weight=700) or to normal(weight=400) boldness.
void | setEscapementType(short escapementType) set the escapement type for the font
void | setEscapementTypeModified(boolean modified)
void | setFontCancellationModified(boolean modified)
void | setFontColorIndex(short fci)
void | setFontHeight(int height) sets the height of the font in 1/20th point units
void | setFontOutlineModified(boolean modified)
void | setFontShadowModified(boolean modified)
void | setFontStyleModified(boolean modified)
void | setFontWieghtModified(boolean modified)
void | setItalic(boolean italic) set the font to be italics or not
void | setOutline(boolean on)
void | setShadow(boolean on)
void | setStrikeout(boolean strike) set the font to be stricken out or not
void | setUnderlineType(short underlineType) set the type of underlining type for the font
void | setUnderlineTypeModified(boolean modified)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FONT_CELL_HEIGHT_PRESERVED

public static final int FONT_CELL_HEIGHT_PRESERVED
See Also:
Constant Field Values

SS_NONE

public static final short SS_NONE
Escapement type - None

See Also:
Constant Field Values

SS_SUPER

public static final short SS_SUPER
Escapement type - Superscript

See Also:
Constant Field Values

SS_SUB

public static final short SS_SUB
Escapement type - Subscript

See Also:
Constant Field Values

U_NONE

public static final byte U_NONE
Underline type - None

See Also:
Constant Field Values

U_SINGLE

public static final byte U_SINGLE
Underline type - Single

See Also:
Constant Field Values

U_DOUBLE

public static final byte U_DOUBLE
Underline type - Double

See Also:
Constant Field Values

U_SINGLE_ACCOUNTING

public static final byte U_SINGLE_ACCOUNTING
Underline type - Single Accounting

See Also:
Constant Field Values

U_DOUBLE_ACCOUNTING

public static final byte U_DOUBLE_ACCOUNTING
Underline type - Double Accounting

See Also:
Constant Field Values
Constructor Detail

FontFormatting

public FontFormatting()

FontFormatting

public FontFormatting(RecordInputStream in)
Creates new FontFormatting

Method Detail

getRawRecord

public byte[] getRawRecord()

setFontHeight

public void setFontHeight(int height)
sets the height of the font in 1/20th point units

Parameters:
height - fontheight (in points/20); or -1 to preserve the cell font height

getFontHeight

public int getFontHeight()
gets the height of the font in 1/20th point units

Returns:
fontheight (in points/20); or -1 if not modified

setItalic

public void setItalic(boolean italic)
set the font to be italics or not

Parameters:
italic - - whether the font is italics or not
See Also:
setFontOption(boolean, org.apache.poi.util.BitField)

isItalic

public boolean isItalic()
get whether the font is to be italics or not

Returns:
italics - whether the font is italics or not
See Also:
getFontOption(org.apache.poi.util.BitField)

setOutline

public void setOutline(boolean on)

isOutlineOn

public boolean isOutlineOn()

setShadow

public void setShadow(boolean on)

isShadowOn

public boolean isShadowOn()

setStrikeout

public void setStrikeout(boolean strike)
set the font to be stricken out or not

Parameters:
strike - - whether the font is stricken out or not

isStruckout

public boolean isStruckout()
get whether the font is to be stricken out or not

Returns:
strike - whether the font is stricken out or not
See Also:
getFontOption(org.apache.poi.util.BitField)

setBold

public void setBold(boolean bold)
set the font weight to bold (weight=700) or to normal(weight=400) boldness.

Parameters:
bold - - set font weight to bold if true; to normal otherwise

getFontWeight

public short getFontWeight()
get the font weight for this font (100-1000dec or 0x64-0x3e8). Default is 0x190 for normal and 0x2bc for bold

Returns:
bw - a number between 100-1000 for the fonts "boldness"

isBold

public boolean isBold()
get whether the font weight is set to bold or not

Returns:
bold - whether the font is bold or not

getEscapementType

public short getEscapementType()
get the type of super or subscript for the font

Returns:
super or subscript option
See Also:
FontFormatting.SS_NONE, FontFormatting.SS_SUPER, FontFormatting.SS_SUB

setEscapementType

public void setEscapementType(short escapementType)
set the escapement type for the font

Parameters:
escapementType - super or subscript option
See Also:
FontFormatting.SS_NONE, FontFormatting.SS_SUPER, FontFormatting.SS_SUB

getUnderlineType

public short getUnderlineType()
get the type of underlining for the font

Returns:
font underlining type
See Also:
HSSFFontFormatting.U_NONE, HSSFFontFormatting.U_SINGLE, HSSFFontFormatting.U_DOUBLE, HSSFFontFormatting.U_SINGLE_ACCOUNTING, HSSFFontFormatting.U_DOUBLE_ACCOUNTING

setUnderlineType

public void setUnderlineType(short underlineType)
set the type of underlining type for the font

Parameters:
underlineType - underline option
See Also:
HSSFFontFormatting.U_NONE, HSSFFontFormatting.U_SINGLE, HSSFFontFormatting.U_DOUBLE, HSSFFontFormatting.U_SINGLE_ACCOUNTING, HSSFFontFormatting.U_DOUBLE_ACCOUNTING

getFontColorIndex

public short getFontColorIndex()

setFontColorIndex

public void setFontColorIndex(short fci)

isFontStyleModified

public boolean isFontStyleModified()

setFontStyleModified

public void setFontStyleModified(boolean modified)

isFontOutlineModified

public boolean isFontOutlineModified()

setFontOutlineModified

public void setFontOutlineModified(boolean modified)

isFontShadowModified

public boolean isFontShadowModified()

setFontShadowModified

public void setFontShadowModified(boolean modified)

setFontCancellationModified

public void setFontCancellationModified(boolean modified)

isFontCancellationModified

public boolean isFontCancellationModified()

setEscapementTypeModified

public void setEscapementTypeModified(boolean modified)

isEscapementTypeModified

public boolean isEscapementTypeModified()

setUnderlineTypeModified

public void setUnderlineTypeModified(boolean modified)

isUnderlineTypeModified

public boolean isUnderlineTypeModified()

setFontWieghtModified

public void setFontWieghtModified(boolean modified)

isFontWeightModified

public boolean isFontWeightModified()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

clone

public java.lang.Object clone()
Overrides:
clone in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record.cf
Classes
BorderFormatting
CellRangeUtil
FontFormatting
PatternFormatting


org.apache.poi.hssf.record.cf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record.cf

Class Summary
BorderFormatting | Border Formatting Block of the Conditional Formatting Rule Record.
CellRangeUtil |
FontFormatting | Font Formatting Block of the Conditional Formatting Rule Record.
PatternFormatting | Pattern Formatting Block of the Conditional Formatting Rule Record.


org.apache.poi.hssf.record.cf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record.cf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.cf.BorderFormatting
    • org.apache.poi.hssf.record.cf.CellRangeUtil
    • org.apache.poi.hssf.record.cf.FontFormatting
    • org.apache.poi.hssf.record.cf.PatternFormatting (implements java.lang.Cloneable)


Uses of Package org.apache.poi.hssf.record.cf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record.cf

Packages that use org.apache.poi.hssf.record.cf
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Classes in org.apache.poi.hssf.record.cf used by org.apache.poi.hssf.record
BorderFormatting
Border Formatting Block of the Conditional Formatting Rule Record.
FontFormatting
Font Formatting Block of the Conditional Formatting Rule Record.
PatternFormatting
Pattern Formatting Block of the Conditional Formatting Rule Record.

Classes in org.apache.poi.hssf.record.cf used by org.apache.poi.hssf.usermodel
BorderFormatting
Border Formatting Block of the Conditional Formatting Rule Record.
FontFormatting
Font Formatting Block of the Conditional Formatting Rule Record.
PatternFormatting
Pattern Formatting Block of the Conditional Formatting Rule Record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PatternFormatting

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.cf
Class PatternFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.record.cf.PatternFormatting
All Implemented Interfaces:
java.lang.Cloneable
public final class PatternFormatting
extends java.lang.Object
implements java.lang.Cloneable

Pattern Formatting Block of the Conditional Formatting Rule Record.

Author:
Dmitriy Kumshayev

Field Summary
static short | ALT_BARS Wide dots
static short | BIG_SPOTS Large spots
static short | BRICKS Brick-like layout
static short | DIAMONDS Diamonds
static short | FINE_DOTS Small fine dots
static short | LEAST_DOTS Least Dots
static short | LESS_DOTS Less Dots
static short | NO_FILL No background
static short | SOLID_FOREGROUND Solidly filled
static short | SPARSE_DOTS Sparse dots
static short | SQUARES Squares
static short | THICK_BACKWARD_DIAG Thick backward facing diagonals
static short | THICK_FORWARD_DIAG Thick forward facing diagonals
static short | THICK_HORZ_BANDS Thick horizontal bands
static short | THICK_VERT_BANDS Thick vertical bands
static short | THIN_BACKWARD_DIAG Thin backward diagonal
static short | THIN_FORWARD_DIAG Thin forward diagonal
static short | THIN_HORZ_BANDS Thin horizontal bands
static short | THIN_VERT_BANDS Thin vertical bands
Constructor Summary
PatternFormatting()
PatternFormatting(LittleEndianInput in)
Creates new FontFormatting
Method Summary
java.lang.Object | clone()
int | getFillBackgroundColor()
int | getFillForegroundColor()
int | getFillPattern()
void | serialize(LittleEndianOutput out)
void | setFillBackgroundColor(int bg) set the background fill color.
void | setFillForegroundColor(int fg) set the foreground fill color
void | setFillPattern(int fp) setting fill pattern
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NO_FILL

public static final short NO_FILL
No background

See Also:
Constant Field Values

SOLID_FOREGROUND

public static final short SOLID_FOREGROUND
Solidly filled

See Also:
Constant Field Values

FINE_DOTS

public static final short FINE_DOTS
Small fine dots

See Also:
Constant Field Values

ALT_BARS

public static final short ALT_BARS
Wide dots

See Also:
Constant Field Values

SPARSE_DOTS

public static final short SPARSE_DOTS
Sparse dots

See Also:
Constant Field Values

THICK_HORZ_BANDS

public static final short THICK_HORZ_BANDS
Thick horizontal bands

See Also:
Constant Field Values

THICK_VERT_BANDS

public static final short THICK_VERT_BANDS
Thick vertical bands

See Also:
Constant Field Values

THICK_BACKWARD_DIAG

public static final short THICK_BACKWARD_DIAG
Thick backward facing diagonals

See Also:
Constant Field Values

THICK_FORWARD_DIAG

public static final short THICK_FORWARD_DIAG
Thick forward facing diagonals

See Also:
Constant Field Values

BIG_SPOTS

public static final short BIG_SPOTS
Large spots

See Also:
Constant Field Values

BRICKS

public static final short BRICKS
Brick-like layout

See Also:
Constant Field Values

THIN_HORZ_BANDS

public static final short THIN_HORZ_BANDS
Thin horizontal bands

See Also:
Constant Field Values

THIN_VERT_BANDS

public static final short THIN_VERT_BANDS
Thin vertical bands

See Also:
Constant Field Values

THIN_BACKWARD_DIAG

public static final short THIN_BACKWARD_DIAG
Thin backward diagonal

See Also:
Constant Field Values

THIN_FORWARD_DIAG

public static final short THIN_FORWARD_DIAG
Thin forward diagonal

See Also:
Constant Field Values

SQUARES

public static final short SQUARES
Squares

See Also:
Constant Field Values

DIAMONDS

public static final short DIAMONDS
Diamonds

See Also:
Constant Field Values

LESS_DOTS

public static final short LESS_DOTS
Less Dots

See Also:
Constant Field Values

LEAST_DOTS

public static final short LEAST_DOTS
Least Dots

See Also:
Constant Field Values
Constructor Detail

PatternFormatting

public PatternFormatting()

PatternFormatting

public PatternFormatting(LittleEndianInput in)
Creates new FontFormatting

Method Detail

setFillPattern

public void setFillPattern(int fp)
setting fill pattern

Parameters:
fp - fill pattern
See Also:
NO_FILL, SOLID_FOREGROUND, FINE_DOTS, ALT_BARS, SPARSE_DOTS, THICK_HORZ_BANDS, THICK_VERT_BANDS, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, BIG_SPOTS, BRICKS, THIN_HORZ_BANDS, THIN_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, SQUARES, DIAMONDS

getFillPattern

public int getFillPattern()
Returns:
fill pattern

setFillBackgroundColor

public void setFillBackgroundColor(int bg)
set the background fill color.

getFillBackgroundColor

public int getFillBackgroundColor()
Returns:
get the background fill color
See Also:
HSSFPalette.getColor(short)

setFillForegroundColor

public void setFillForegroundColor(int fg)
set the foreground fill color

getFillForegroundColor

public int getFillForegroundColor()
Returns:
get the foreground fill color
See Also:
HSSFPalette.getColor(short)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

clone

public java.lang.Object clone()
Overrides:
clone in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.record.cf.BorderFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.cf.BorderFormatting

Packages that use BorderFormatting
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of BorderFormatting in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return BorderFormatting
 BorderFormatting CFRuleRecord.getBorderFormatting()

Methods in org.apache.poi.hssf.record with parameters of type BorderFormatting
 void CFRuleRecord.setBorderFormatting(BorderFormatting borderFormatting)

Uses of BorderFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return BorderFormatting
protected  BorderFormatting HSSFBorderFormatting.getBorderFormattingBlock()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.cf.CellRangeUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.cf.CellRangeUtil

No usage of org.apache.poi.hssf.record.cf.CellRangeUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.cf.FontFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.cf.FontFormatting

Packages that use FontFormatting
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of FontFormatting in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return FontFormatting
 FontFormatting CFRuleRecord.getFontFormatting()

Methods in org.apache.poi.hssf.record with parameters of type FontFormatting
 void CFRuleRecord.setFontFormatting(FontFormatting fontFormatting)

Uses of FontFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return FontFormatting
protected  FontFormatting HSSFFontFormatting.getFontFormattingBlock()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.cf.PatternFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.cf.PatternFormatting

Packages that use PatternFormatting
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of PatternFormatting in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return PatternFormatting
 PatternFormatting CFRuleRecord.getPatternFormatting()

Methods in org.apache.poi.hssf.record with parameters of type PatternFormatting
 void CFRuleRecord.setPatternFormatting(PatternFormatting patternFormatting)

Uses of PatternFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return PatternFormatting
protected  PatternFormatting HSSFPatternFormatting.getPatternFormattingBlock()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AreaFormatRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class AreaFormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.AreaFormatRecord

public final class AreaFormatRecord
extends StandardRecord

The area format record is used to define the colours and patterns for an area.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
AreaFormatRecord()
AreaFormatRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getBackcolorIndex() Get the backcolor index field for the AreaFormat record.
int | getBackgroundColor() Get the background color field for the AreaFormat record.
protected int | getDataSize()
short | getForecolorIndex() Get the forecolor index field for the AreaFormat record.
int | getForegroundColor() Get the foreground color field for the AreaFormat record.
short | getFormatFlags() Get the format flags field for the AreaFormat record.
short | getPattern() Get the pattern field for the AreaFormat record.
short | getSid() return the non static version of the id for this record.
boolean | isAutomatic() automatic formatting
boolean | isInvert() swap foreground and background colours when data is negative
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAutomatic(boolean value) Sets the automatic field value.
void | setBackcolorIndex(short field_6_backcolorIndex) Set the backcolor index field for the AreaFormat record.
void | setBackgroundColor(int field_2_backgroundColor) Set the background color field for the AreaFormat record.
void | setForecolorIndex(short field_5_forecolorIndex) Set the forecolor index field for the AreaFormat record.
void | setForegroundColor(int field_1_foregroundColor) Set the foreground color field for the AreaFormat record.
void | setFormatFlags(short field_4_formatFlags) Set the format flags field for the AreaFormat record.
void | setInvert(boolean value) Sets the invert field value.
void | setPattern(short field_3_pattern) Set the pattern field for the AreaFormat record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

AreaFormatRecord

public AreaFormatRecord()

AreaFormatRecord

public AreaFormatRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getForegroundColor

public int getForegroundColor()
Get the foreground color field for the AreaFormat record.

setForegroundColor

public void setForegroundColor(int field_1_foregroundColor)
Set the foreground color field for the AreaFormat record.

getBackgroundColor

public int getBackgroundColor()
Get the background color field for the AreaFormat record.

setBackgroundColor

public void setBackgroundColor(int field_2_backgroundColor)
Set the background color field for the AreaFormat record.

getPattern

public short getPattern()
Get the pattern field for the AreaFormat record.

setPattern

public void setPattern(short field_3_pattern)
Set the pattern field for the AreaFormat record.

getFormatFlags

public short getFormatFlags()
Get the format flags field for the AreaFormat record.

setFormatFlags

public void setFormatFlags(short field_4_formatFlags)
Set the format flags field for the AreaFormat record.

getForecolorIndex

public short getForecolorIndex()
Get the forecolor index field for the AreaFormat record.

setForecolorIndex

public void setForecolorIndex(short field_5_forecolorIndex)
Set the forecolor index field for the AreaFormat record.

getBackcolorIndex

public short getBackcolorIndex()
Get the backcolor index field for the AreaFormat record.

setBackcolorIndex

public void setBackcolorIndex(short field_6_backcolorIndex)
Set the backcolor index field for the AreaFormat record.

setAutomatic

public void setAutomatic(boolean value)
Sets the automatic field value. automatic formatting

isAutomatic

public boolean isAutomatic()
automatic formatting

Returns:
the automatic field value.

setInvert

public void setInvert(boolean value)
Sets the invert field value. swap foreground and background colours when data is negative

isInvert

public boolean isInvert()
swap foreground and background colours when data is negative

Returns:
the invert field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AreaRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class AreaRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.AreaRecord

public final class AreaRecord
extends StandardRecord

The area record is used to define a area chart.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
AreaRecord()
AreaRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getFormatFlags() Get the format flags field for the Area record.
short | getSid() return the non static version of the id for this record.
boolean | isDisplayAsPercentage() results displayed as percentages
boolean | isShadow() display a shadow for the chart
boolean | isStacked() series is stacked
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setDisplayAsPercentage(boolean value) Sets the display as percentage field value.
void | setFormatFlags(short field_1_formatFlags) Set the format flags field for the Area record.
void | setShadow(boolean value) Sets the shadow field value.
void | setStacked(boolean value) Sets the stacked field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

AreaRecord

public AreaRecord()

AreaRecord

public AreaRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getFormatFlags

public short getFormatFlags()
Get the format flags field for the Area record.

setFormatFlags

public void setFormatFlags(short field_1_formatFlags)
Set the format flags field for the Area record.

setStacked

public void setStacked(boolean value)
Sets the stacked field value. series is stacked

isStacked

public boolean isStacked()
series is stacked

Returns:
the stacked field value.

setDisplayAsPercentage

public void setDisplayAsPercentage(boolean value)
Sets the display as percentage field value. results displayed as percentages

isDisplayAsPercentage

public boolean isDisplayAsPercentage()
results displayed as percentages

Returns:
the display as percentage field value.

setShadow

public void setShadow(boolean value)
Sets the shadow field value. display a shadow for the chart

isShadow

public boolean isShadow()
display a shadow for the chart

Returns:
the shadow field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AxisLineFormatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class AxisLineFormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.AxisLineFormatRecord

public final class AxisLineFormatRecord
extends StandardRecord

The axis line format record defines the axis type details.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | AXIS_TYPE_AXIS_LINE
static short | AXIS_TYPE_MAJOR_GRID_LINE
static short | AXIS_TYPE_MINOR_GRID_LINE
static short | AXIS_TYPE_WALLS_OR_FLOOR
static short | sid
Constructor Summary
AxisLineFormatRecord()
AxisLineFormatRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getAxisType() Get the axis type field for the AxisLineFormat record.
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAxisType(short field_1_axisType) Set the axis type field for the AxisLineFormat record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

AXIS_TYPE_AXIS_LINE

public static final short AXIS_TYPE_AXIS_LINE
See Also:
Constant Field Values

AXIS_TYPE_MAJOR_GRID_LINE

public static final short AXIS_TYPE_MAJOR_GRID_LINE
See Also:
Constant Field Values

AXIS_TYPE_MINOR_GRID_LINE

public static final short AXIS_TYPE_MINOR_GRID_LINE
See Also:
Constant Field Values

AXIS_TYPE_WALLS_OR_FLOOR

public static final short AXIS_TYPE_WALLS_OR_FLOOR
See Also:
Constant Field Values
Constructor Detail

AxisLineFormatRecord

public AxisLineFormatRecord()

AxisLineFormatRecord

public AxisLineFormatRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getAxisType

public short getAxisType()
Get the axis type field for the AxisLineFormat record.

Returns:
One of AXIS_TYPE_AXIS_LINE AXIS_TYPE_MAJOR_GRID_LINE AXIS_TYPE_MINOR_GRID_LINE AXIS_TYPE_WALLS_OR_FLOOR

setAxisType

public void setAxisType(short field_1_axisType)
Set the axis type field for the AxisLineFormat record.

Parameters:
field_1_axisType - One of AXIS_TYPE_AXIS_LINE AXIS_TYPE_MAJOR_GRID_LINE AXIS_TYPE_MINOR_GRID_LINE AXIS_TYPE_WALLS_OR_FLOOR
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AxisOptionsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class AxisOptionsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.AxisOptionsRecord

public final class AxisOptionsRecord
extends StandardRecord

The axis options record provides unit information and other various tidbits about the axis.

Author:
Andrew C. Oliver(acoliver at apache.org)

Field Summary
static short sid
Constructor Summary
AxisOptionsRecord()
AxisOptionsRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getBaseUnit() Get the base unit field for the AxisOptions record.
short | getCrossingPoint() Get the crossing point field for the AxisOptions record.
protected int | getDataSize()
short | getMajorUnit() Get the major unit field for the AxisOptions record.
short | getMajorUnitValue() Get the major unit value field for the AxisOptions record.
short | getMaximumCategory() Get the maximum category field for the AxisOptions record.
short | getMinimumCategory() Get the minimum category field for the AxisOptions record.
short | getMinorUnit() Get the minor unit field for the AxisOptions record.
short | getMinorUnitValue() Get the minor unit value field for the AxisOptions record.
short | getOptions() Get the options field for the AxisOptions record.
short | getSid() return the non static version of the id for this record.
boolean | isDefaultBase() use the default base unit
boolean | isDefaultCross() use the default crossing point
boolean | isDefaultDateSettings() use default date setttings for this axis
boolean | isDefaultMajor() use the default major unit
boolean | isDefaultMaximum() use the default maximum category
boolean | isDefaultMinimum() use the default minimum category
boolean | isDefaultMinorUnit() use the default minor unit
boolean | isIsDate() this is a date axis
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBaseUnit(short field_7_baseUnit) Set the base unit field for the AxisOptions record.
void | setCrossingPoint(short field_8_crossingPoint) Set the crossing point field for the AxisOptions record.
void | setDefaultBase(boolean value) Sets the default base field value.
void | setDefaultCross(boolean value) Sets the default cross field value.
void | setDefaultDateSettings(boolean value) Sets the default date settings field value.
void | setDefaultMajor(boolean value) Sets the default major field value.
void | setDefaultMaximum(boolean value) Sets the default maximum field value.
void | setDefaultMinimum(boolean value) Sets the default minimum field value.
void | setDefaultMinorUnit(boolean value) Sets the default minor unit field value.
void | setIsDate(boolean value) Sets the isDate field value.
void | setMajorUnit(short field_4_majorUnit) Set the major unit field for the AxisOptions record.
void | setMajorUnitValue(short field_3_majorUnitValue) Set the major unit value field for the AxisOptions record.
void | setMaximumCategory(short field_2_maximumCategory) Set the maximum category field for the AxisOptions record.
void | setMinimumCategory(short field_1_minimumCategory) Set the minimum category field for the AxisOptions record.
void | setMinorUnit(short field_6_minorUnit) Set the minor unit field for the AxisOptions record.
void | setMinorUnitValue(short field_5_minorUnitValue) Set the minor unit value field for the AxisOptions record.
void | setOptions(short field_9_options) Set the options field for the AxisOptions record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

AxisOptionsRecord

public AxisOptionsRecord()

AxisOptionsRecord

public AxisOptionsRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getMinimumCategory

public short getMinimumCategory()
Get the minimum category field for the AxisOptions record.

setMinimumCategory

public void setMinimumCategory(short field_1_minimumCategory)
Set the minimum category field for the AxisOptions record.

getMaximumCategory

public short getMaximumCategory()
Get the maximum category field for the AxisOptions record.

setMaximumCategory

public void setMaximumCategory(short field_2_maximumCategory)
Set the maximum category field for the AxisOptions record.

getMajorUnitValue

public short getMajorUnitValue()
Get the major unit value field for the AxisOptions record.

setMajorUnitValue

public void setMajorUnitValue(short field_3_majorUnitValue)
Set the major unit value field for the AxisOptions record.

getMajorUnit

public short getMajorUnit()
Get the major unit field for the AxisOptions record.

setMajorUnit

public void setMajorUnit(short field_4_majorUnit)
Set the major unit field for the AxisOptions record.

getMinorUnitValue

public short getMinorUnitValue()
Get the minor unit value field for the AxisOptions record.

setMinorUnitValue

public void setMinorUnitValue(short field_5_minorUnitValue)
Set the minor unit value field for the AxisOptions record.

getMinorUnit

public short getMinorUnit()
Get the minor unit field for the AxisOptions record.

setMinorUnit

public void setMinorUnit(short field_6_minorUnit)
Set the minor unit field for the AxisOptions record.

getBaseUnit

public short getBaseUnit()
Get the base unit field for the AxisOptions record.

setBaseUnit

public void setBaseUnit(short field_7_baseUnit)
Set the base unit field for the AxisOptions record.

getCrossingPoint

public short getCrossingPoint()
Get the crossing point field for the AxisOptions record.

setCrossingPoint

public void setCrossingPoint(short field_8_crossingPoint)
Set the crossing point field for the AxisOptions record.

getOptions

public short getOptions()
Get the options field for the AxisOptions record.

setOptions

public void setOptions(short field_9_options)
Set the options field for the AxisOptions record.

setDefaultMinimum

public void setDefaultMinimum(boolean value)
Sets the default minimum field value. use the default minimum category

isDefaultMinimum

public boolean isDefaultMinimum()
use the default minimum category

Returns:
the default minimum field value.

setDefaultMaximum

public void setDefaultMaximum(boolean value)
Sets the default maximum field value. use the default maximum category

isDefaultMaximum

public boolean isDefaultMaximum()
use the default maximum category

Returns:
the default maximum field value.

setDefaultMajor

public void setDefaultMajor(boolean value)
Sets the default major field value. use the default major unit

isDefaultMajor

public boolean isDefaultMajor()
use the default major unit

Returns:
the default major field value.

setDefaultMinorUnit

public void setDefaultMinorUnit(boolean value)
Sets the default minor unit field value. use the default minor unit

isDefaultMinorUnit

public boolean isDefaultMinorUnit()
use the default minor unit

Returns:
the default minor unit field value.

setIsDate

public void setIsDate(boolean value)
Sets the isDate field value. this is a date axis

isIsDate

public boolean isIsDate()
this is a date axis

Returns:
the isDate field value.

setDefaultBase

public void setDefaultBase(boolean value)
Sets the default base field value. use the default base unit

isDefaultBase

public boolean isDefaultBase()
use the default base unit

Returns:
the default base field value.

setDefaultCross

public void setDefaultCross(boolean value)
Sets the default cross field value. use the default crossing point

isDefaultCross

public boolean isDefaultCross()
use the default crossing point

Returns:
the default cross field value.

setDefaultDateSettings

public void setDefaultDateSettings(boolean value)
Sets the default date settings field value. use default date setttings for this axis

isDefaultDateSettings

public boolean isDefaultDateSettings()
use default date setttings for this axis

Returns:
the default date settings field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AxisParentRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class AxisParentRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.AxisParentRecord

public final class AxisParentRecord
extends StandardRecord

The axis size and location

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | AXIS_TYPE_MAIN
static short | AXIS_TYPE_SECONDARY
static short | sid
Constructor Summary
AxisParentRecord()
AxisParentRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getAxisType() Get the axis type field for the AxisParent record.
protected int | getDataSize()
int | getHeight() Get the height field for the AxisParent record.
short | getSid() return the non static version of the id for this record.
int | getWidth() Get the width field for the AxisParent record.
int | getX() Get the x field for the AxisParent record.
int | getY() Get the y field for the AxisParent record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAxisType(short field_1_axisType) Set the axis type field for the AxisParent record.
void | setHeight(int field_5_height) Set the height field for the AxisParent record.
void | setWidth(int field_4_width) Set the width field for the AxisParent record.
void | setX(int field_2_x) Set the x field for the AxisParent record.
void | setY(int field_3_y) Set the y field for the AxisParent record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

AXIS_TYPE_MAIN

public static final short AXIS_TYPE_MAIN
See Also:
Constant Field Values

AXIS_TYPE_SECONDARY

public static final short AXIS_TYPE_SECONDARY
See Also:
Constant Field Values
Constructor Detail

AxisParentRecord

public AxisParentRecord()

AxisParentRecord

public AxisParentRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getAxisType

public short getAxisType()
Get the axis type field for the AxisParent record.

Returns:
One of AXIS_TYPE_MAIN AXIS_TYPE_SECONDARY

setAxisType

public void setAxisType(short field_1_axisType)
Set the axis type field for the AxisParent record.

Parameters:
field_1_axisType - One of AXIS_TYPE_MAIN AXIS_TYPE_SECONDARY

getX

public int getX()
Get the x field for the AxisParent record.

setX

public void setX(int field_2_x)
Set the x field for the AxisParent record.

getY

public int getY()
Get the y field for the AxisParent record.

setY

public void setY(int field_3_y)
Set the y field for the AxisParent record.

getWidth

public int getWidth()
Get the width field for the AxisParent record.

setWidth

public void setWidth(int field_4_width)
Set the width field for the AxisParent record.

getHeight

public int getHeight()
Get the height field for the AxisParent record.

setHeight

public void setHeight(int field_5_height)
Set the height field for the AxisParent record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AxisRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class AxisRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.AxisRecord

public final class AxisRecord
extends StandardRecord

The axis record defines the type of an axis.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | AXIS_TYPE_CATEGORY_OR_X_AXIS
static short | AXIS_TYPE_SERIES_AXIS
static short | AXIS_TYPE_VALUE_AXIS
static short | sid
Constructor Summary
AxisRecord()
AxisRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getAxisType() Get the axis type field for the Axis record.
protected int | getDataSize()
int | getReserved1() Get the reserved1 field for the Axis record.
int | getReserved2() Get the reserved2 field for the Axis record.
int | getReserved3() Get the reserved3 field for the Axis record.
int | getReserved4() Get the reserved4 field for the Axis record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAxisType(short field_1_axisType) Set the axis type field for the Axis record.
void | setReserved1(int field_2_reserved1) Set the reserved1 field for the Axis record.
void | setReserved2(int field_3_reserved2) Set the reserved2 field for the Axis record.
void | setReserved3(int field_4_reserved3) Set the reserved3 field for the Axis record.
void | setReserved4(int field_5_reserved4) Set the reserved4 field for the Axis record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

AXIS_TYPE_CATEGORY_OR_X_AXIS

public static final short AXIS_TYPE_CATEGORY_OR_X_AXIS
See Also:
Constant Field Values

AXIS_TYPE_VALUE_AXIS

public static final short AXIS_TYPE_VALUE_AXIS
See Also:
Constant Field Values

AXIS_TYPE_SERIES_AXIS

public static final short AXIS_TYPE_SERIES_AXIS
See Also:
Constant Field Values
Constructor Detail

AxisRecord

public AxisRecord()

AxisRecord

public AxisRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getAxisType

public short getAxisType()
Get the axis type field for the Axis record.

Returns:
One of AXIS_TYPE_CATEGORY_OR_X_AXIS AXIS_TYPE_VALUE_AXIS AXIS_TYPE_SERIES_AXIS

setAxisType

public void setAxisType(short field_1_axisType)
Set the axis type field for the Axis record.

Parameters:
field_1_axisType - One of AXIS_TYPE_CATEGORY_OR_X_AXIS AXIS_TYPE_VALUE_AXIS AXIS_TYPE_SERIES_AXIS

getReserved1

public int getReserved1()
Get the reserved1 field for the Axis record.

setReserved1

public void setReserved1(int field_2_reserved1)
Set the reserved1 field for the Axis record.

getReserved2

public int getReserved2()
Get the reserved2 field for the Axis record.

setReserved2

public void setReserved2(int field_3_reserved2)
Set the reserved2 field for the Axis record.

getReserved3

public int getReserved3()
Get the reserved3 field for the Axis record.

setReserved3

public void setReserved3(int field_4_reserved3)
Set the reserved3 field for the Axis record.

getReserved4

public int getReserved4()
Get the reserved4 field for the Axis record.

setReserved4

public void setReserved4(int field_5_reserved4)
Set the reserved4 field for the Axis record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AxisUsedRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class AxisUsedRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.AxisUsedRecord

public final class AxisUsedRecord
extends StandardRecord

The number of axes used on a chart.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
AxisUsedRecord()
AxisUsedRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getNumAxis() Get the num axis field for the AxisUsed record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setNumAxis(short field_1_numAxis) Set the num axis field for the AxisUsed record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

AxisUsedRecord

public AxisUsedRecord()

AxisUsedRecord

public AxisUsedRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getNumAxis

public short getNumAxis()
Get the num axis field for the AxisUsed record.

setNumAxis

public void setNumAxis(short field_1_numAxis)
Set the num axis field for the AxisUsed record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BarRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class BarRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.BarRecord

public final class BarRecord
extends StandardRecord

The bar record is used to define a bar chart.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
BarRecord()
BarRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getBarSpace() Get the bar space field for the Bar record.
short | getCategorySpace() Get the category space field for the Bar record.
protected int | getDataSize()
short | getFormatFlags() Get the format flags field for the Bar record.
short | getSid() return the non static version of the id for this record.
boolean | isDisplayAsPercentage() display chart values as a percentage
boolean | isHorizontal() true to display horizontal bar charts, false for vertical
boolean | isShadow() display a shadow for the chart
boolean | isStacked() stack displayed values
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBarSpace(short field_1_barSpace) Set the bar space field for the Bar record.
void | setCategorySpace(short field_2_categorySpace) Set the category space field for the Bar record.
void | setDisplayAsPercentage(boolean value) Sets the display as percentage field value.
void | setFormatFlags(short field_3_formatFlags) Set the format flags field for the Bar record.
void | setHorizontal(boolean value) Sets the horizontal field value.
void | setShadow(boolean value) Sets the shadow field value.
void | setStacked(boolean value) Sets the stacked field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BarRecord

public BarRecord()

BarRecord

public BarRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getBarSpace

public short getBarSpace()
Get the bar space field for the Bar record.

setBarSpace

public void setBarSpace(short field_1_barSpace)
Set the bar space field for the Bar record.

getCategorySpace

public short getCategorySpace()
Get the category space field for the Bar record.

setCategorySpace

public void setCategorySpace(short field_2_categorySpace)
Set the category space field for the Bar record.

getFormatFlags

public short getFormatFlags()
Get the format flags field for the Bar record.

setFormatFlags

public void setFormatFlags(short field_3_formatFlags)
Set the format flags field for the Bar record.

setHorizontal

public void setHorizontal(boolean value)
Sets the horizontal field value. true to display horizontal bar charts, false for vertical

isHorizontal

public boolean isHorizontal()
true to display horizontal bar charts, false for vertical

Returns:
the horizontal field value.

setStacked

public void setStacked(boolean value)
Sets the stacked field value. stack displayed values

isStacked

public boolean isStacked()
stack displayed values

Returns:
the stacked field value.

setDisplayAsPercentage

public void setDisplayAsPercentage(boolean value)
Sets the display as percentage field value. display chart values as a percentage

isDisplayAsPercentage

public boolean isDisplayAsPercentage()
display chart values as a percentage

Returns:
the display as percentage field value.

setShadow

public void setShadow(boolean value)
Sets the shadow field value. display a shadow for the chart

isShadow

public boolean isShadow()
display a shadow for the chart

Returns:
the shadow field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BeginRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class BeginRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.BeginRecord

public final class BeginRecord
extends StandardRecord

The begin record defines the start of a block of records for a (grpahing data object. This record is matched with a corresponding EndRecord.

Author:
Glen Stampoultzis (glens at apache.org)
See Also:
EndRecord

Field Summary
static short sid
Constructor Summary
BeginRecord()
BeginRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

BeginRecord

public BeginRecord()

BeginRecord

public BeginRecord(RecordInputStream in)
Parameters:
in - unused (since this record has no data)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CategorySeriesAxisRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class CategorySeriesAxisRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

public final class CategorySeriesAxisRecord
extends StandardRecord

This record refers to a category or series axis and is used to specify label/tickmark frequency.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
CategorySeriesAxisRecord()
CategorySeriesAxisRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getCrossingPoint() Get the crossing point field for the CategorySeriesAxis record.
protected int | getDataSize()
short | getLabelFrequency() Get the label frequency field for the CategorySeriesAxis record.
short | getOptions() Get the options field for the CategorySeriesAxis record.
short | getSid() return the non static version of the id for this record.
short | getTickMarkFrequency() Get the tick mark frequency field for the CategorySeriesAxis record.
boolean | isCrossesFarRight() axis crosses at the far right
boolean | isReversed() categories are displayed in reverse order
boolean | isValueAxisCrossing() set true to indicate axis crosses between categories and false to cross axis midway
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCrossesFarRight(boolean value) Sets the crosses far right field value.
void | setCrossingPoint(short field_1_crossingPoint) Set the crossing point field for the CategorySeriesAxis record.
void | setLabelFrequency(short field_2_labelFrequency) Set the label frequency field for the CategorySeriesAxis record.
void | setOptions(short field_4_options) Set the options field for the CategorySeriesAxis record.
void | setReversed(boolean value) Sets the reversed field value.
void | setTickMarkFrequency(short field_3_tickMarkFrequency) Set the tick mark frequency field for the CategorySeriesAxis record.
void | setValueAxisCrossing(boolean value) Sets the value axis crossing field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

CategorySeriesAxisRecord

public CategorySeriesAxisRecord()

CategorySeriesAxisRecord

public CategorySeriesAxisRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getCrossingPoint

public short getCrossingPoint()
Get the crossing point field for the CategorySeriesAxis record.

setCrossingPoint

public void setCrossingPoint(short field_1_crossingPoint)
Set the crossing point field for the CategorySeriesAxis record.

getLabelFrequency

public short getLabelFrequency()
Get the label frequency field for the CategorySeriesAxis record.

setLabelFrequency

public void setLabelFrequency(short field_2_labelFrequency)
Set the label frequency field for the CategorySeriesAxis record.

getTickMarkFrequency

public short getTickMarkFrequency()
Get the tick mark frequency field for the CategorySeriesAxis record.

setTickMarkFrequency

public void setTickMarkFrequency(short field_3_tickMarkFrequency)
Set the tick mark frequency field for the CategorySeriesAxis record.

getOptions

public short getOptions()
Get the options field for the CategorySeriesAxis record.

setOptions

public void setOptions(short field_4_options)
Set the options field for the CategorySeriesAxis record.

setValueAxisCrossing

public void setValueAxisCrossing(boolean value)
Sets the value axis crossing field value. set true to indicate axis crosses between categories and false to cross axis midway

isValueAxisCrossing

public boolean isValueAxisCrossing()
set true to indicate axis crosses between categories and false to cross axis midway

Returns:
the value axis crossing field value.

setCrossesFarRight

public void setCrossesFarRight(boolean value)
Sets the crosses far right field value. axis crosses at the far right

isCrossesFarRight

public boolean isCrossesFarRight()
axis crosses at the far right

Returns:
the crosses far right field value.

setReversed

public void setReversed(boolean value)
Sets the reversed field value. categories are displayed in reverse order

isReversed

public boolean isReversed()
categories are displayed in reverse order

Returns:
the reversed field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CatLabRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class CatLabRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.CatLabRecord

public final class CatLabRecord
extends StandardRecord

CATLAB - Category Labels (0x0856)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
CatLabRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

CatLabRecord

public CatLabRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartEndBlockRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartEndBlockRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartEndBlockRecord

public final class ChartEndBlockRecord
extends StandardRecord

ENDBLOCK - Chart Future Record Type End Block (0x0853)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ChartEndBlockRecord()
ChartEndBlockRecord(RecordInputStream in)
Method Summary
ChartEndBlockRecord | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartEndBlockRecord

public ChartEndBlockRecord()

ChartEndBlockRecord

public ChartEndBlockRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public ChartEndBlockRecord clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartEndObjectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartEndObjectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartEndObjectRecord

public final class ChartEndObjectRecord
extends StandardRecord

ENDOBJECT - Chart Future Record Type End Object (0x0855)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ChartEndObjectRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartEndObjectRecord

public ChartEndObjectRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartFormatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartFormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartFormatRecord

public final class ChartFormatRecord
extends StandardRecord

Class ChartFormatRecord (0x1014)

(As with all chart related records, documentation is lacking. See ChartRecord for more details)

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
ChartFormatRecord()
ChartFormatRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
int | getHeight()
short | getSid() return the non static version of the id for this record.
boolean | getVaryDisplayPattern()
int | getWidth()
int | getXPosition()
int | getYPosition()
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setHeight(int height)
void | setVaryDisplayPattern(boolean value)
void | setWidth(int width)
void | setXPosition(int xPosition)
void | setYPosition(int yPosition)
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartFormatRecord

public ChartFormatRecord()

ChartFormatRecord

public ChartFormatRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getXPosition

public int getXPosition()

setXPosition

public void setXPosition(int xPosition)

getYPosition

public int getYPosition()

setYPosition

public void setYPosition(int yPosition)

getWidth

public int getWidth()

setWidth

public void setWidth(int width)

getHeight

public int getHeight()

setHeight

public void setHeight(int height)

getVaryDisplayPattern

public boolean getVaryDisplayPattern()

setVaryDisplayPattern

public void setVaryDisplayPattern(boolean value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartFRTInfoRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartFRTInfoRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

public final class ChartFRTInfoRecord
extends StandardRecord

CHARTFRTINFO - Chart Future Record Type Info (0x0850)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ChartFRTInfoRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartFRTInfoRecord

public ChartFRTInfoRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartRecord

public final class ChartRecord
extends StandardRecord

CHART (0x1002)

The chart record is used to define the location and size of a chart.

Chart related records don't seem to be covered in either the OOO or the MS documentation. The book "Microsoft Excel 97 Developer's Kit" ISBN: (1-57231-498-2) seems to have an entire chapter (10) devoted to Chart records. One blog suggests that some documentation for these records is available in "MSDN Library, Feb 1998", but no later.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
ChartRecord()
ChartRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
int | getHeight() Get the height field for the Chart record.
short | getSid() return the non static version of the id for this record.
int | getWidth() Get the width field for the Chart record.
int | getX() Get the x field for the Chart record.
int | getY() Get the y field for the Chart record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setHeight(int height) Set the height field for the Chart record.
void | setWidth(int width) Set the width field for the Chart record.
void | setX(int x) Set the x field for the Chart record.
void | setY(int y) Set the y field for the Chart record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartRecord

public ChartRecord()

ChartRecord

public ChartRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getX

public int getX()
Get the x field for the Chart record.

setX

public void setX(int x)
Set the x field for the Chart record.

getY

public int getY()
Get the y field for the Chart record.

setY

public void setY(int y)
Set the y field for the Chart record.

getWidth

public int getWidth()
Get the width field for the Chart record.

setWidth

public void setWidth(int width)
Set the width field for the Chart record.

getHeight

public int getHeight()
Get the height field for the Chart record.

setHeight

public void setHeight(int height)
Set the height field for the Chart record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartStartBlockRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartStartBlockRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartStartBlockRecord

public final class ChartStartBlockRecord
extends StandardRecord

STARTBLOCK - Chart Future Record Type Start Block (0x0852)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ChartStartBlockRecord()
ChartStartBlockRecord(RecordInputStream in)
Method Summary
ChartStartBlockRecord | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartStartBlockRecord

public ChartStartBlockRecord()

ChartStartBlockRecord

public ChartStartBlockRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

clone

public ChartStartBlockRecord clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartStartObjectRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartStartObjectRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartStartObjectRecord

public final class ChartStartObjectRecord
extends StandardRecord

STARTOBJECT - Chart Future Record Type Start Object (0x0854)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ChartStartObjectRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartStartObjectRecord

public ChartStartObjectRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartTitleFormatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ChartTitleFormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

public class ChartTitleFormatRecord
extends StandardRecord

CHARTTITLEFORMAT (0x1050)

Describes the formatting runs associated with a chart title.

Field Summary
static short sid
Constructor Summary
ChartTitleFormatRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
int | getFormatCount()
short | getSid() return the non static version of the id for this record.
void | modifyFormatRun(short oldPos, short newLen)
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ChartTitleFormatRecord

public ChartTitleFormatRecord(RecordInputStream in)
Method Detail

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

getFormatCount

public int getFormatCount()

modifyFormatRun

public void modifyFormatRun(short oldPos,
                            short newLen)

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataFormatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class DataFormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.DataFormatRecord

public final class DataFormatRecord
extends StandardRecord

The data format record is used to index into a series.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
DataFormatRecord()
DataFormatRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getFormatFlags() Get the format flags field for the DataFormat record.
short | getPointNumber() Get the point number field for the DataFormat record.
short | getSeriesIndex() Get the series index field for the DataFormat record.
short | getSeriesNumber() Get the series number field for the DataFormat record.
short | getSid() return the non static version of the id for this record.
boolean | isUseExcel4Colors() set true to use excel 4 colors.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setFormatFlags(short field_4_formatFlags) Set the format flags field for the DataFormat record.
void | setPointNumber(short field_1_pointNumber) Set the point number field for the DataFormat record.
void | setSeriesIndex(short field_2_seriesIndex) Set the series index field for the DataFormat record.
void | setSeriesNumber(short field_3_seriesNumber) Set the series number field for the DataFormat record.
void | setUseExcel4Colors(boolean value) Sets the use excel 4 colors field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DataFormatRecord

public DataFormatRecord()

DataFormatRecord

public DataFormatRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getPointNumber

public short getPointNumber()
Get the point number field for the DataFormat record.

setPointNumber

public void setPointNumber(short field_1_pointNumber)
Set the point number field for the DataFormat record.

getSeriesIndex

public short getSeriesIndex()
Get the series index field for the DataFormat record.

setSeriesIndex

public void setSeriesIndex(short field_2_seriesIndex)
Set the series index field for the DataFormat record.

getSeriesNumber

public short getSeriesNumber()
Get the series number field for the DataFormat record.

setSeriesNumber

public void setSeriesNumber(short field_3_seriesNumber)
Set the series number field for the DataFormat record.

getFormatFlags

public short getFormatFlags()
Get the format flags field for the DataFormat record.

setFormatFlags

public void setFormatFlags(short field_4_formatFlags)
Set the format flags field for the DataFormat record.

setUseExcel4Colors

public void setUseExcel4Colors(boolean value)
Sets the use excel 4 colors field value. set true to use excel 4 colors.

isUseExcel4Colors

public boolean isUseExcel4Colors()
set true to use excel 4 colors.

Returns:
the use excel 4 colors field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataLabelExtensionRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class DataLabelExtensionRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

public final class DataLabelExtensionRecord
extends StandardRecord

DATALABEXT - Chart Data Label Extension (0x086A)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
DataLabelExtensionRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DataLabelExtensionRecord

public DataLabelExtensionRecord(RecordInputStream in)
Method Detail

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class DatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.DatRecord

public final class DatRecord
extends StandardRecord

The dat record is used to store options for the chart.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
DatRecord()
DatRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getOptions() Get the options field for the Dat record.
short | getSid() return the non static version of the id for this record.
boolean | isBorder() data table has a border
boolean | isHorizontalBorder() has a horizontal border
boolean | isShowSeriesKey() shows the series key
boolean | isVerticalBorder() has vertical border
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBorder(boolean value) Sets the border field value.
void | setHorizontalBorder(boolean value) Sets the horizontal border field value.
void | setOptions(short field_1_options) Set the options field for the Dat record.
void | setShowSeriesKey(boolean value) Sets the show series key field value.
void | setVerticalBorder(boolean value) Sets the vertical border field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DatRecord

public DatRecord()

DatRecord

public DatRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getOptions

public short getOptions()
Get the options field for the Dat record.

setOptions

public void setOptions(short field_1_options)
Set the options field for the Dat record.

setHorizontalBorder

public void setHorizontalBorder(boolean value)
Sets the horizontal border field value. has a horizontal border

isHorizontalBorder

public boolean isHorizontalBorder()
has a horizontal border

Returns:
the horizontal border field value.

setVerticalBorder

public void setVerticalBorder(boolean value)
Sets the vertical border field value. has vertical border

isVerticalBorder

public boolean isVerticalBorder()
has vertical border

Returns:
the vertical border field value.

setBorder

public void setBorder(boolean value)
Sets the border field value. data table has a border

isBorder

public boolean isBorder()
data table has a border

Returns:
the border field value.

setShowSeriesKey

public void setShowSeriesKey(boolean value)
Sets the show series key field value. shows the series key

isShowSeriesKey

public boolean isShowSeriesKey()
shows the series key

Returns:
the show series key field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultDataLabelTextPropertiesRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class DefaultDataLabelTextPropertiesRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

public final class DefaultDataLabelTextPropertiesRecord
extends StandardRecord

The default data label text properties record identifies the text characteristics of the preceding text record.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | CATEGORY_DATA_TYPE_ALL_TEXT_CHARACTERISTIC
static short | CATEGORY_DATA_TYPE_SHOW_LABELS_CHARACTERISTIC
static short | CATEGORY_DATA_TYPE_VALUE_AND_PERCENTAGE_CHARACTERISTIC
static short | sid
Constructor Summary
DefaultDataLabelTextPropertiesRecord()
DefaultDataLabelTextPropertiesRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getCategoryDataType() Get the category data type field for the DefaultDataLabelTextProperties record.
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCategoryDataType(short field_1_categoryDataType) Set the category data type field for the DefaultDataLabelTextProperties record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

CATEGORY_DATA_TYPE_SHOW_LABELS_CHARACTERISTIC

public static final short CATEGORY_DATA_TYPE_SHOW_LABELS_CHARACTERISTIC
See Also:
Constant Field Values

CATEGORY_DATA_TYPE_VALUE_AND_PERCENTAGE_CHARACTERISTIC

public static final short CATEGORY_DATA_TYPE_VALUE_AND_PERCENTAGE_CHARACTERISTIC
See Also:
Constant Field Values

CATEGORY_DATA_TYPE_ALL_TEXT_CHARACTERISTIC

public static final short CATEGORY_DATA_TYPE_ALL_TEXT_CHARACTERISTIC
See Also:
Constant Field Values
Constructor Detail

DefaultDataLabelTextPropertiesRecord

public DefaultDataLabelTextPropertiesRecord()

DefaultDataLabelTextPropertiesRecord

public DefaultDataLabelTextPropertiesRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getCategoryDataType

public short getCategoryDataType()
Get the category data type field for the DefaultDataLabelTextProperties record.

Returns:
One of CATEGORY_DATA_TYPE_SHOW_LABELS_CHARACTERISTIC CATEGORY_DATA_TYPE_VALUE_AND_PERCENTAGE_CHARACTERISTIC CATEGORY_DATA_TYPE_ALL_TEXT_CHARACTERISTIC

setCategoryDataType

public void setCategoryDataType(short field_1_categoryDataType)
Set the category data type field for the DefaultDataLabelTextProperties record.

Parameters:
field_1_categoryDataType - One of CATEGORY_DATA_TYPE_SHOW_LABELS_CHARACTERISTIC CATEGORY_DATA_TYPE_VALUE_AND_PERCENTAGE_CHARACTERISTIC CATEGORY_DATA_TYPE_ALL_TEXT_CHARACTERISTIC
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EndRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class EndRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.EndRecord

public final class EndRecord
extends StandardRecord

The end record defines the end of a block of records for a (Graphing) data object. This record is matched with a corresponding BeginRecord.

Author:
Glen Stampoultzis (glens at apache.org)
See Also:
BeginRecord

Field Summary
static short sid
Constructor Summary
EndRecord()
EndRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

EndRecord

public EndRecord()

EndRecord

public EndRecord(RecordInputStream in)
Parameters:
in - unused (since this record has no data)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontBasisRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class FontBasisRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.FontBasisRecord

public final class FontBasisRecord
extends StandardRecord

The font basis record stores various font metrics.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
FontBasisRecord()
FontBasisRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getHeightBasis() Get the height basis field for the FontBasis record.
short | getIndexToFontTable() Get the index to font table field for the FontBasis record.
short | getScale() Get the scale field for the FontBasis record.
short | getSid() return the non static version of the id for this record.
short | getXBasis() Get the x Basis field for the FontBasis record.
short | getYBasis() Get the y Basis field for the FontBasis record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setHeightBasis(short field_3_heightBasis) Set the height basis field for the FontBasis record.
void | setIndexToFontTable(short field_5_indexToFontTable) Set the index to font table field for the FontBasis record.
void | setScale(short field_4_scale) Set the scale field for the FontBasis record.
void | setXBasis(short field_1_xBasis) Set the x Basis field for the FontBasis record.
void | setYBasis(short field_2_yBasis) Set the y Basis field for the FontBasis record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FontBasisRecord

public FontBasisRecord()

FontBasisRecord

public FontBasisRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getXBasis

public short getXBasis()
Get the x Basis field for the FontBasis record.

setXBasis

public void setXBasis(short field_1_xBasis)
Set the x Basis field for the FontBasis record.

getYBasis

public short getYBasis()
Get the y Basis field for the FontBasis record.

setYBasis

public void setYBasis(short field_2_yBasis)
Set the y Basis field for the FontBasis record.

getHeightBasis

public short getHeightBasis()
Get the height basis field for the FontBasis record.

setHeightBasis

public void setHeightBasis(short field_3_heightBasis)
Set the height basis field for the FontBasis record.

getScale

public short getScale()
Get the scale field for the FontBasis record.

setScale

public void setScale(short field_4_scale)
Set the scale field for the FontBasis record.

getIndexToFontTable

public short getIndexToFontTable()
Get the index to font table field for the FontBasis record.

setIndexToFontTable

public void setIndexToFontTable(short field_5_indexToFontTable)
Set the index to font table field for the FontBasis record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontIndexRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class FontIndexRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.FontIndexRecord

public final class FontIndexRecord
extends StandardRecord

The font index record indexes into the font table for the text record.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
FontIndexRecord()
FontIndexRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getFontIndex() Get the font index field for the FontIndex record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setFontIndex(short field_1_fontIndex) Set the font index field for the FontIndex record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

FontIndexRecord

public FontIndexRecord()

FontIndexRecord

public FontIndexRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getFontIndex

public short getFontIndex()
Get the font index field for the FontIndex record.

setFontIndex

public void setFontIndex(short field_1_fontIndex)
Set the font index field for the FontIndex record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FrameRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class FrameRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.FrameRecord

public final class FrameRecord
extends StandardRecord

The frame record indicates whether there is a border around the displayed text of a chart.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | BORDER_TYPE_REGULAR
static short | BORDER_TYPE_SHADOW
static short | sid
Constructor Summary
FrameRecord()
FrameRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getBorderType() Get the border type field for the Frame record.
protected int | getDataSize()
short | getOptions() Get the options field for the Frame record.
short | getSid() return the non static version of the id for this record.
boolean | isAutoPosition() excel calculates the position automatically
boolean | isAutoSize() excel calculates the size automatically if true
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAutoPosition(boolean value) Sets the auto position field value.
void | setAutoSize(boolean value) Sets the auto size field value.
void | setBorderType(short field_1_borderType) Set the border type field for the Frame record.
void | setOptions(short field_2_options) Set the options field for the Frame record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

BORDER_TYPE_REGULAR

public static final short BORDER_TYPE_REGULAR
See Also:
Constant Field Values

BORDER_TYPE_SHADOW

public static final short BORDER_TYPE_SHADOW
See Also:
Constant Field Values
Constructor Detail

FrameRecord

public FrameRecord()

FrameRecord

public FrameRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getBorderType

public short getBorderType()
Get the border type field for the Frame record.

Returns:
One of BORDER_TYPE_REGULAR BORDER_TYPE_SHADOW

setBorderType

public void setBorderType(short field_1_borderType)
Set the border type field for the Frame record.

Parameters:
field_1_borderType - One of BORDER_TYPE_REGULAR BORDER_TYPE_SHADOW

getOptions

public short getOptions()
Get the options field for the Frame record.

setOptions

public void setOptions(short field_2_options)
Set the options field for the Frame record.

setAutoSize

public void setAutoSize(boolean value)
Sets the auto size field value. excel calculates the size automatically if true

isAutoSize

public boolean isAutoSize()
excel calculates the size automatically if true

Returns:
the auto size field value.

setAutoPosition

public void setAutoPosition(boolean value)
Sets the auto position field value. excel calculates the position automatically

isAutoPosition

public boolean isAutoPosition()
excel calculates the position automatically

Returns:
the auto position field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LegendRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class LegendRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.LegendRecord

public final class LegendRecord
extends StandardRecord

Defines a legend for a chart.

Author:
Andrew C. Oliver (acoliver at apache.org)

Field Summary
static short | sid
static byte | SPACING_CLOSE
static byte | SPACING_MEDIUM
static byte | SPACING_OPEN
static byte | TYPE_BOTTOM
static byte | TYPE_CORNER
static byte | TYPE_LEFT
static byte | TYPE_RIGHT
static byte | TYPE_TOP
static byte | TYPE_UNDOCKED
Constructor Summary
LegendRecord()
LegendRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getOptions() Get the options field for the Legend record.
short | getSid() return the non static version of the id for this record.
byte | getSpacing() Get the spacing field for the Legend record.
byte | getType() Get the type field for the Legend record.
int | getXAxisUpperLeft() Get the x axis upper left field for the Legend record.
int | getXSize() Get the x size field for the Legend record.
int | getYAxisUpperLeft() Get the y axis upper left field for the Legend record.
int | getYSize() Get the y size field for the Legend record.
boolean | isAutoPosition() automatic positioning (1=docked)
boolean | isAutoSeries() excel 5 only (true)
boolean | isAutoXPositioning() position of legend on the x axis is automatic
boolean | isAutoYPositioning() position of legend on the y axis is automatic
boolean | isDataTable() 1 if chart contains data table
boolean | isVertical() vertical or horizontal legend (1 or 0 respectively).
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAutoPosition(boolean value) Sets the auto position field value.
void | setAutoSeries(boolean value) Sets the auto series field value.
void | setAutoXPositioning(boolean value) Sets the auto x positioning field value.
void | setAutoYPositioning(boolean value) Sets the auto y positioning field value.
void | setDataTable(boolean value) Sets the data table field value.
void | setOptions(short field_7_options) Set the options field for the Legend record.
void | setSpacing(byte field_6_spacing) Set the spacing field for the Legend record.
void | setType(byte field_5_type) Set the type field for the Legend record.
void | setVertical(boolean value) Sets the vertical field value.
void | setXAxisUpperLeft(int field_1_xAxisUpperLeft) Set the x axis upper left field for the Legend record.
void | setXSize(int field_3_xSize) Set the x size field for the Legend record.
void | setYAxisUpperLeft(int field_2_yAxisUpperLeft) Set the y axis upper left field for the Legend record.
void | setYSize(int field_4_ySize) Set the y size field for the Legend record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

TYPE_BOTTOM

public static final byte TYPE_BOTTOM
See Also:
Constant Field Values

TYPE_CORNER

public static final byte TYPE_CORNER
See Also:
Constant Field Values

TYPE_TOP

public static final byte TYPE_TOP
See Also:
Constant Field Values

TYPE_RIGHT

public static final byte TYPE_RIGHT
See Also:
Constant Field Values

TYPE_LEFT

public static final byte TYPE_LEFT
See Also:
Constant Field Values

TYPE_UNDOCKED

public static final byte TYPE_UNDOCKED
See Also:
Constant Field Values

SPACING_CLOSE

public static final byte SPACING_CLOSE
See Also:
Constant Field Values

SPACING_MEDIUM

public static final byte SPACING_MEDIUM
See Also:
Constant Field Values

SPACING_OPEN

public static final byte SPACING_OPEN
See Also:
Constant Field Values
Constructor Detail

LegendRecord

public LegendRecord()

LegendRecord

public LegendRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getXAxisUpperLeft

public int getXAxisUpperLeft()
Get the x axis upper left field for the Legend record.

setXAxisUpperLeft

public void setXAxisUpperLeft(int field_1_xAxisUpperLeft)
Set the x axis upper left field for the Legend record.

getYAxisUpperLeft

public int getYAxisUpperLeft()
Get the y axis upper left field for the Legend record.

setYAxisUpperLeft

public void setYAxisUpperLeft(int field_2_yAxisUpperLeft)
Set the y axis upper left field for the Legend record.

getXSize

public int getXSize()
Get the x size field for the Legend record.

setXSize

public void setXSize(int field_3_xSize)
Set the x size field for the Legend record.

getYSize

public int getYSize()
Get the y size field for the Legend record.

setYSize

public void setYSize(int field_4_ySize)
Set the y size field for the Legend record.

getType

public byte getType()
Get the type field for the Legend record.

Returns:
One of TYPE_BOTTOM TYPE_CORNER TYPE_TOP TYPE_RIGHT TYPE_LEFT TYPE_UNDOCKED

setType

public void setType(byte field_5_type)
Set the type field for the Legend record.

Parameters:
field_5_type - One of TYPE_BOTTOM TYPE_CORNER TYPE_TOP TYPE_RIGHT TYPE_LEFT TYPE_UNDOCKED

getSpacing

public byte getSpacing()
Get the spacing field for the Legend record.

Returns:
One of SPACING_CLOSE SPACING_MEDIUM SPACING_OPEN

setSpacing

public void setSpacing(byte field_6_spacing)
Set the spacing field for the Legend record.

Parameters:
field_6_spacing - One of SPACING_CLOSE SPACING_MEDIUM SPACING_OPEN

getOptions

public short getOptions()
Get the options field for the Legend record.

setOptions

public void setOptions(short field_7_options)
Set the options field for the Legend record.

setAutoPosition

public void setAutoPosition(boolean value)
Sets the auto position field value. automatic positioning (1=docked)

isAutoPosition

public boolean isAutoPosition()
automatic positioning (1=docked)

Returns:
the auto position field value.

setAutoSeries

public void setAutoSeries(boolean value)
Sets the auto series field value. excel 5 only (true)

isAutoSeries

public boolean isAutoSeries()
excel 5 only (true)

Returns:
the auto series field value.

setAutoXPositioning

public void setAutoXPositioning(boolean value)
Sets the auto x positioning field value. position of legend on the x axis is automatic

isAutoXPositioning

public boolean isAutoXPositioning()
position of legend on the x axis is automatic

Returns:
the auto x positioning field value.

setAutoYPositioning

public void setAutoYPositioning(boolean value)
Sets the auto y positioning field value. position of legend on the y axis is automatic

isAutoYPositioning

public boolean isAutoYPositioning()
position of legend on the y axis is automatic

Returns:
the auto y positioning field value.

setVertical

public void setVertical(boolean value)
Sets the vertical field value. vertical or horizontal legend (1 or 0 respectively). Always 0 if not automatic.

isVertical

public boolean isVertical()
vertical or horizontal legend (1 or 0 respectively). Always 0 if not automatic.

Returns:
the vertical field value.

setDataTable

public void setDataTable(boolean value)
Sets the data table field value. 1 if chart contains data table

isDataTable

public boolean isDataTable()
1 if chart contains data table

Returns:
the data table field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineFormatRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class LineFormatRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.LineFormatRecord

public final class LineFormatRecord
extends StandardRecord

Describes a line format record. The line format record controls how a line on a chart appears.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | LINE_PATTERN_DARK_GRAY_PATTERN
static short | LINE_PATTERN_DASH
static short | LINE_PATTERN_DASH_DOT
static short | LINE_PATTERN_DASH_DOT_DOT
static short | LINE_PATTERN_DOT
static short | LINE_PATTERN_LIGHT_GRAY_PATTERN
static short | LINE_PATTERN_MEDIUM_GRAY_PATTERN
static short | LINE_PATTERN_NONE
static short | LINE_PATTERN_SOLID
static short | sid
static short | WEIGHT_HAIRLINE
static short | WEIGHT_MEDIUM
static short | WEIGHT_NARROW
static short | WEIGHT_WIDE
Constructor Summary
LineFormatRecord()
LineFormatRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getColourPaletteIndex() Get the colour palette index field for the LineFormat record.
protected int | getDataSize()
short | getFormat() Get the format field for the LineFormat record.
int | getLineColor() Get the line color field for the LineFormat record.
short | getLinePattern() Get the line pattern field for the LineFormat record.
short | getSid() return the non static version of the id for this record.
short | getWeight() Get the weight field for the LineFormat record.
boolean | isAuto() automatic format
boolean | isDrawTicks() draw tick marks
boolean | isUnknown() book marks this as reserved = 0 but it seems to do something
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAuto(boolean value) Sets the auto field value.
void | setColourPaletteIndex(short field_5_colourPaletteIndex) Set the colour palette index field for the LineFormat record.
void | setDrawTicks(boolean value) Sets the draw ticks field value.
void | setFormat(short field_4_format) Set the format field for the LineFormat record.
void | setLineColor(int field_1_lineColor) Set the line color field for the LineFormat record.
void | setLinePattern(short field_2_linePattern) Set the line pattern field for the LineFormat record.
void | setUnknown(boolean value) Sets the unknown field value.
void | setWeight(short field_3_weight) Set the weight field for the LineFormat record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

LINE_PATTERN_SOLID

public static final short LINE_PATTERN_SOLID
See Also:
Constant Field Values

LINE_PATTERN_DASH

public static final short LINE_PATTERN_DASH
See Also:
Constant Field Values

LINE_PATTERN_DOT

public static final short LINE_PATTERN_DOT
See Also:
Constant Field Values

LINE_PATTERN_DASH_DOT

public static final short LINE_PATTERN_DASH_DOT
See Also:
Constant Field Values

LINE_PATTERN_DASH_DOT_DOT

public static final short LINE_PATTERN_DASH_DOT_DOT
See Also:
Constant Field Values

LINE_PATTERN_NONE

public static final short LINE_PATTERN_NONE
See Also:
Constant Field Values

LINE_PATTERN_DARK_GRAY_PATTERN

public static final short LINE_PATTERN_DARK_GRAY_PATTERN
See Also:
Constant Field Values

LINE_PATTERN_MEDIUM_GRAY_PATTERN

public static final short LINE_PATTERN_MEDIUM_GRAY_PATTERN
See Also:
Constant Field Values

LINE_PATTERN_LIGHT_GRAY_PATTERN

public static final short LINE_PATTERN_LIGHT_GRAY_PATTERN
See Also:
Constant Field Values

WEIGHT_HAIRLINE

public static final short WEIGHT_HAIRLINE
See Also:
Constant Field Values

WEIGHT_NARROW

public static final short WEIGHT_NARROW
See Also:
Constant Field Values

WEIGHT_MEDIUM

public static final short WEIGHT_MEDIUM
See Also:
Constant Field Values

WEIGHT_WIDE

public static final short WEIGHT_WIDE
See Also:
Constant Field Values
Constructor Detail

LineFormatRecord

public LineFormatRecord()

LineFormatRecord

public LineFormatRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getLineColor

public int getLineColor()
Get the line color field for the LineFormat record.

setLineColor

public void setLineColor(int field_1_lineColor)
Set the line color field for the LineFormat record.

getLinePattern

public short getLinePattern()
Get the line pattern field for the LineFormat record.

Returns:
One of LINE_PATTERN_SOLID LINE_PATTERN_DASH LINE_PATTERN_DOT LINE_PATTERN_DASH_DOT LINE_PATTERN_DASH_DOT_DOT LINE_PATTERN_NONE LINE_PATTERN_DARK_GRAY_PATTERN LINE_PATTERN_MEDIUM_GRAY_PATTERN LINE_PATTERN_LIGHT_GRAY_PATTERN

setLinePattern

public void setLinePattern(short field_2_linePattern)
Set the line pattern field for the LineFormat record.

Parameters:
field_2_linePattern - One of LINE_PATTERN_SOLID LINE_PATTERN_DASH LINE_PATTERN_DOT LINE_PATTERN_DASH_DOT LINE_PATTERN_DASH_DOT_DOT LINE_PATTERN_NONE LINE_PATTERN_DARK_GRAY_PATTERN LINE_PATTERN_MEDIUM_GRAY_PATTERN LINE_PATTERN_LIGHT_GRAY_PATTERN

getWeight

public short getWeight()
Get the weight field for the LineFormat record.

Returns:
One of WEIGHT_HAIRLINE WEIGHT_NARROW WEIGHT_MEDIUM WEIGHT_WIDE

setWeight

public void setWeight(short field_3_weight)
Set the weight field for the LineFormat record.

Parameters:
field_3_weight - One of WEIGHT_HAIRLINE WEIGHT_NARROW WEIGHT_MEDIUM WEIGHT_WIDE

getFormat

public short getFormat()
Get the format field for the LineFormat record.

setFormat

public void setFormat(short field_4_format)
Set the format field for the LineFormat record.

getColourPaletteIndex

public short getColourPaletteIndex()
Get the colour palette index field for the LineFormat record.

setColourPaletteIndex

public void setColourPaletteIndex(short field_5_colourPaletteIndex)
Set the colour palette index field for the LineFormat record.

setAuto

public void setAuto(boolean value)
Sets the auto field value. automatic format

isAuto

public boolean isAuto()
automatic format

Returns:
the auto field value.

setDrawTicks

public void setDrawTicks(boolean value)
Sets the draw ticks field value. draw tick marks

isDrawTicks

public boolean isDrawTicks()
draw tick marks

Returns:
the draw ticks field value.

setUnknown

public void setUnknown(boolean value)
Sets the unknown field value. book marks this as reserved = 0 but it seems to do something

isUnknown

public boolean isUnknown()
book marks this as reserved = 0 but it seems to do something

Returns:
the unknown field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LinkedDataRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class LinkedDataRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.LinkedDataRecord

public final class LinkedDataRecord
extends StandardRecord

Describes a linked data record. This record refers to the series data or text.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static byte | LINK_TYPE_CATEGORIES
static byte | LINK_TYPE_TITLE_OR_TEXT
static byte | LINK_TYPE_VALUES
static byte | REFERENCE_TYPE_DEFAULT_CATEGORIES
static byte | REFERENCE_TYPE_DIRECT
static byte | REFERENCE_TYPE_ERROR_REPORTED
static byte | REFERENCE_TYPE_NOT_USED
static byte | REFERENCE_TYPE_WORKSHEET
static short | sid
Constructor Summary
LinkedDataRecord()
LinkedDataRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
Ptg[] | getFormulaOfLink() Get the formula of link field for the LinkedData record.
short | getIndexNumberFmtRecord() Get the index number fmt record field for the LinkedData record.
byte | getLinkType() Get the link type field for the LinkedData record.
short | getOptions() Get the options field for the LinkedData record.
byte | getReferenceType() Get the reference type field for the LinkedData record.
short | getSid() return the non static version of the id for this record.
boolean | isCustomNumberFormat() true if this object has a custom number format
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setCustomNumberFormat(boolean value) Sets the custom number format field value.
void | setFormulaOfLink(Ptg[] ptgs) Set the formula of link field for the LinkedData record.
void | setIndexNumberFmtRecord(short field_4_indexNumberFmtRecord) Set the index number fmt record field for the LinkedData record.
void | setLinkType(byte field_1_linkType) Set the link type field for the LinkedData record.
void | setOptions(short field_3_options) Set the options field for the LinkedData record.
void | setReferenceType(byte field_2_referenceType) Set the reference type field for the LinkedData record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

LINK_TYPE_TITLE_OR_TEXT

public static final byte LINK_TYPE_TITLE_OR_TEXT
See Also:
Constant Field Values

LINK_TYPE_VALUES

public static final byte LINK_TYPE_VALUES
See Also:
Constant Field Values

LINK_TYPE_CATEGORIES

public static final byte LINK_TYPE_CATEGORIES
See Also:
Constant Field Values

REFERENCE_TYPE_DEFAULT_CATEGORIES

public static final byte REFERENCE_TYPE_DEFAULT_CATEGORIES
See Also:
Constant Field Values

REFERENCE_TYPE_DIRECT

public static final byte REFERENCE_TYPE_DIRECT
See Also:
Constant Field Values

REFERENCE_TYPE_WORKSHEET

public static final byte REFERENCE_TYPE_WORKSHEET
See Also:
Constant Field Values

REFERENCE_TYPE_NOT_USED

public static final byte REFERENCE_TYPE_NOT_USED
See Also:
Constant Field Values

REFERENCE_TYPE_ERROR_REPORTED

public static final byte REFERENCE_TYPE_ERROR_REPORTED
See Also:
Constant Field Values
Constructor Detail

LinkedDataRecord

public LinkedDataRecord()

LinkedDataRecord

public LinkedDataRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getLinkType

public byte getLinkType()
Get the link type field for the LinkedData record.

Returns:
One of LINK_TYPE_TITLE_OR_TEXT LINK_TYPE_VALUES LINK_TYPE_CATEGORIES

setLinkType

public void setLinkType(byte field_1_linkType)
Set the link type field for the LinkedData record.

Parameters:
field_1_linkType - One of LINK_TYPE_TITLE_OR_TEXT LINK_TYPE_VALUES LINK_TYPE_CATEGORIES

getReferenceType

public byte getReferenceType()
Get the reference type field for the LinkedData record.

Returns:
One of REFERENCE_TYPE_DEFAULT_CATEGORIES REFERENCE_TYPE_DIRECT REFERENCE_TYPE_WORKSHEET REFERENCE_TYPE_NOT_USED REFERENCE_TYPE_ERROR_REPORTED

setReferenceType

public void setReferenceType(byte field_2_referenceType)
Set the reference type field for the LinkedData record.

Parameters:
field_2_referenceType - One of REFERENCE_TYPE_DEFAULT_CATEGORIES REFERENCE_TYPE_DIRECT REFERENCE_TYPE_WORKSHEET REFERENCE_TYPE_NOT_USED REFERENCE_TYPE_ERROR_REPORTED

getOptions

public short getOptions()
Get the options field for the LinkedData record.

setOptions

public void setOptions(short field_3_options)
Set the options field for the LinkedData record.

getIndexNumberFmtRecord

public short getIndexNumberFmtRecord()
Get the index number fmt record field for the LinkedData record.

setIndexNumberFmtRecord

public void setIndexNumberFmtRecord(short field_4_indexNumberFmtRecord)
Set the index number fmt record field for the LinkedData record.

getFormulaOfLink

public Ptg[] getFormulaOfLink()
Get the formula of link field for the LinkedData record.

setFormulaOfLink

public void setFormulaOfLink(Ptg[] ptgs)
Set the formula of link field for the LinkedData record.

setCustomNumberFormat

public void setCustomNumberFormat(boolean value)
Sets the custom number format field value. true if this object has a custom number format

isCustomNumberFormat

public boolean isCustomNumberFormat()
true if this object has a custom number format

Returns:
the custom number format field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumberFormatIndexRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class NumberFormatIndexRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

public final class NumberFormatIndexRecord
extends StandardRecord

The number format index record indexes format table. This applies to an axis.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
NumberFormatIndexRecord()
NumberFormatIndexRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getFormatIndex() Get the format index field for the NumberFormatIndex record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setFormatIndex(short field_1_formatIndex) Set the format index field for the NumberFormatIndex record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

NumberFormatIndexRecord

public NumberFormatIndexRecord()

NumberFormatIndexRecord

public NumberFormatIndexRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getFormatIndex

public short getFormatIndex()
Get the format index field for the NumberFormatIndex record.

setFormatIndex

public void setFormatIndex(short field_1_formatIndex)
Set the format index field for the NumberFormatIndex record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectLinkRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ObjectLinkRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ObjectLinkRecord

public final class ObjectLinkRecord
extends StandardRecord

Links text to an object on the chart or identifies it as the title.

Author:
Andrew C. Oliver (acoliver at apache.org)

Field Summary
static short | ANCHOR_ID_CHART_TITLE
static short | ANCHOR_ID_SERIES_OR_POINT
static short | ANCHOR_ID_X_AXIS
static short | ANCHOR_ID_Y_AXIS
static short | ANCHOR_ID_Z_AXIS
static short | sid
Constructor Summary
ObjectLinkRecord()
ObjectLinkRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getAnchorId() Get the anchor id field for the ObjectLink record.
protected int | getDataSize()
short | getLink1() Get the link 1 field for the ObjectLink record.
short | getLink2() Get the link 2 field for the ObjectLink record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAnchorId(short field_1_anchorId) Set the anchor id field for the ObjectLink record.
void | setLink1(short field_2_link1) Set the link 1 field for the ObjectLink record.
void | setLink2(short field_3_link2) Set the link 2 field for the ObjectLink record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

ANCHOR_ID_CHART_TITLE

public static final short ANCHOR_ID_CHART_TITLE
See Also:
Constant Field Values

ANCHOR_ID_Y_AXIS

public static final short ANCHOR_ID_Y_AXIS
See Also:
Constant Field Values

ANCHOR_ID_X_AXIS

public static final short ANCHOR_ID_X_AXIS
See Also:
Constant Field Values

ANCHOR_ID_SERIES_OR_POINT

public static final short ANCHOR_ID_SERIES_OR_POINT
See Also:
Constant Field Values

ANCHOR_ID_Z_AXIS

public static final short ANCHOR_ID_Z_AXIS
See Also:
Constant Field Values
Constructor Detail

ObjectLinkRecord

public ObjectLinkRecord()

ObjectLinkRecord

public ObjectLinkRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getAnchorId

public short getAnchorId()
Get the anchor id field for the ObjectLink record.

Returns:
One of ANCHOR_ID_CHART_TITLE ANCHOR_ID_Y_AXIS ANCHOR_ID_X_AXIS ANCHOR_ID_SERIES_OR_POINT ANCHOR_ID_Z_AXIS

setAnchorId

public void setAnchorId(short field_1_anchorId)
Set the anchor id field for the ObjectLink record.

Parameters:
field_1_anchorId - One of ANCHOR_ID_CHART_TITLE ANCHOR_ID_Y_AXIS ANCHOR_ID_X_AXIS ANCHOR_ID_SERIES_OR_POINT ANCHOR_ID_Z_AXIS

getLink1

public short getLink1()
Get the link 1 field for the ObjectLink record.

setLink1

public void setLink1(short field_2_link1)
Set the link 1 field for the ObjectLink record.

getLink2

public short getLink2()
Get the link 2 field for the ObjectLink record.

setLink2

public void setLink2(short field_3_link2)
Set the link 2 field for the ObjectLink record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record.chart
Classes
AreaFormatRecord
AreaRecord
AxisLineFormatRecord
AxisOptionsRecord
AxisParentRecord
AxisRecord
AxisUsedRecord
BarRecord
BeginRecord
CategorySeriesAxisRecord
CatLabRecord
ChartEndBlockRecord
ChartEndObjectRecord
ChartFormatRecord
ChartFRTInfoRecord
ChartRecord
ChartStartBlockRecord
ChartStartObjectRecord
ChartTitleFormatRecord
DataFormatRecord
DataLabelExtensionRecord
DatRecord
DefaultDataLabelTextPropertiesRecord
EndRecord
FontBasisRecord
FontIndexRecord
FrameRecord
LegendRecord
LineFormatRecord
LinkedDataRecord
NumberFormatIndexRecord
ObjectLinkRecord
PlotAreaRecord
PlotGrowthRecord
SeriesChartGroupIndexRecord
SeriesIndexRecord
SeriesLabelsRecord
SeriesListRecord
SeriesRecord
SeriesTextRecord
SeriesToChartGroupRecord
SheetPropertiesRecord
TextRecord
TickRecord
UnitsRecord
ValueRangeRecord


org.apache.poi.hssf.record.chart

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record.chart

Class Summary
AreaFormatRecord | The area format record is used to define the colours and patterns for an area.
AreaRecord | The area record is used to define a area chart.
AxisLineFormatRecord | The axis line format record defines the axis type details.
AxisOptionsRecord | The axis options record provides unit information and other various tidbits about the axis.
AxisParentRecord | The axis size and location
AxisRecord | The axis record defines the type of an axis.
AxisUsedRecord | The number of axes used on a chart.
BarRecord | The bar record is used to define a bar chart.
BeginRecord | The begin record defines the start of a block of records for a (grpahing data object.
CategorySeriesAxisRecord | This record refers to a category or series axis and is used to specify label/tickmark frequency.
CatLabRecord | CATLAB - Category Labels (0x0856)
ChartEndBlockRecord | ENDBLOCK - Chart Future Record Type End Block (0x0853)
ChartEndObjectRecord | ENDOBJECT - Chart Future Record Type End Object (0x0855)
ChartFormatRecord | Class ChartFormatRecord (0x1014) (As with all chart related records, documentation is lacking.
ChartFRTInfoRecord | CHARTFRTINFO - Chart Future Record Type Info (0x0850)
ChartRecord | CHART (0x1002) The chart record is used to define the location and size of a chart. Chart related records don't seem to be covered in either the OOO or the MS documentation.
ChartStartBlockRecord | STARTBLOCK - Chart Future Record Type Start Block (0x0852)
ChartStartObjectRecord | STARTOBJECT - Chart Future Record Type Start Object (0x0854)
ChartTitleFormatRecord | CHARTTITLEFORMAT (0x1050) Describes the formatting runs associated with a chart title.
DataFormatRecord | The data format record is used to index into a series.
DataLabelExtensionRecord | DATALABEXT - Chart Data Label Extension (0x086A)
DatRecord | The dat record is used to store options for the chart.
DefaultDataLabelTextPropertiesRecord | The default data label text properties record identifies the text characteristics of the preceding text record.
EndRecord | The end record defines the end of a block of records for a (Graphing) data object.
FontBasisRecord | The font basis record stores various font metrics.
FontIndexRecord | The font index record indexes into the font table for the text record.
FrameRecord | The frame record indicates whether there is a border around the displayed text of a chart.
LegendRecord | Defines a legend for a chart.
LineFormatRecord | Describes a line format record.
LinkedDataRecord | Describes a linked data record.
NumberFormatIndexRecord | The number format index record indexes format table.
ObjectLinkRecord | Links text to an object on the chart or identifies it as the title.
PlotAreaRecord | preceeds and identifies a frame as belonging to the plot area.
PlotGrowthRecord | The plot growth record specifies the scaling factors used when a font is scaled.
SeriesChartGroupIndexRecord | The series chart group index record stores the index to the CHARTFORMAT record (0 based).
SeriesIndexRecord | links a series to its position in the series list.
SeriesLabelsRecord | The series label record defines the type of label associated with the data format record.
SeriesListRecord | SERIESLIST (0x1016) The series list record defines the series displayed as an overlay to the main chart record. (As with all chart related records, documentation is lacking.
SeriesRecord | The series record describes the overall data for a series.
SeriesTextRecord | SERIESTEXT (0x100D)
SeriesToChartGroupRecord | Indicates the chart-group index for a series.
SheetPropertiesRecord | Describes a chart sheet properties record.
TextRecord | The text record is used to define text stored on a chart.
TickRecord | The Tick record defines how tick marks and label positioning/formatting
UnitsRecord | The units record describes units.
ValueRangeRecord | The value range record defines the range of the value axis.


org.apache.poi.hssf.record.chart Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record.chart

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.RecordBase
      • org.apache.poi.hssf.record.Record
        • org.apache.poi.hssf.record.StandardRecord
          • org.apache.poi.hssf.record.chart.AreaFormatRecord
          • org.apache.poi.hssf.record.chart.AreaRecord
          • org.apache.poi.hssf.record.chart.AxisLineFormatRecord
          • org.apache.poi.hssf.record.chart.AxisOptionsRecord
          • org.apache.poi.hssf.record.chart.AxisParentRecord
          • org.apache.poi.hssf.record.chart.AxisRecord
          • org.apache.poi.hssf.record.chart.AxisUsedRecord
          • org.apache.poi.hssf.record.chart.BarRecord
          • org.apache.poi.hssf.record.chart.BeginRecord
          • org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord
          • org.apache.poi.hssf.record.chart.CatLabRecord
          • org.apache.poi.hssf.record.chart.ChartEndBlockRecord
          • org.apache.poi.hssf.record.chart.ChartEndObjectRecord
          • org.apache.poi.hssf.record.chart.ChartFormatRecord
          • org.apache.poi.hssf.record.chart.ChartFRTInfoRecord
          • org.apache.poi.hssf.record.chart.ChartRecord
          • org.apache.poi.hssf.record.chart.ChartStartBlockRecord
          • org.apache.poi.hssf.record.chart.ChartStartObjectRecord
          • org.apache.poi.hssf.record.chart.ChartTitleFormatRecord
          • org.apache.poi.hssf.record.chart.DataFormatRecord
          • org.apache.poi.hssf.record.chart.DataLabelExtensionRecord
          • org.apache.poi.hssf.record.chart.DatRecord
          • org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord
          • org.apache.poi.hssf.record.chart.EndRecord
          • org.apache.poi.hssf.record.chart.FontBasisRecord
          • org.apache.poi.hssf.record.chart.FontIndexRecord
          • org.apache.poi.hssf.record.chart.FrameRecord
          • org.apache.poi.hssf.record.chart.LegendRecord
          • org.apache.poi.hssf.record.chart.LineFormatRecord
          • org.apache.poi.hssf.record.chart.LinkedDataRecord
          • org.apache.poi.hssf.record.chart.NumberFormatIndexRecord
          • org.apache.poi.hssf.record.chart.ObjectLinkRecord
          • org.apache.poi.hssf.record.chart.PlotAreaRecord
          • org.apache.poi.hssf.record.chart.PlotGrowthRecord
          • org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord
          • org.apache.poi.hssf.record.chart.SeriesIndexRecord
          • org.apache.poi.hssf.record.chart.SeriesLabelsRecord
          • org.apache.poi.hssf.record.chart.SeriesListRecord
          • org.apache.poi.hssf.record.chart.SeriesRecord
          • org.apache.poi.hssf.record.chart.SeriesTextRecord
          • org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord
          • org.apache.poi.hssf.record.chart.SheetPropertiesRecord
          • org.apache.poi.hssf.record.chart.TextRecord
          • org.apache.poi.hssf.record.chart.TickRecord
          • org.apache.poi.hssf.record.chart.UnitsRecord
          • org.apache.poi.hssf.record.chart.ValueRangeRecord


Uses of Package org.apache.poi.hssf.record.chart

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record.chart

Packages that use org.apache.poi.hssf.record.chart
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Classes in org.apache.poi.hssf.record.chart used by org.apache.poi.hssf.record.chart
ChartEndBlockRecord
ENDBLOCK - Chart Future Record Type End Block (0x0853)
ChartStartBlockRecord
STARTBLOCK - Chart Future Record Type Start Block (0x0852)

Classes in org.apache.poi.hssf.record.chart used by org.apache.poi.hssf.usermodel
LinkedDataRecord
Describes a linked data record.
SeriesRecord
The series record describes the overall data for a series.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PlotAreaRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class PlotAreaRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.PlotAreaRecord

public final class PlotAreaRecord
extends StandardRecord

preceeds and identifies a frame as belonging to the plot area.

Author:
Andrew C. Oliver (acoliver at apache.org)

Field Summary
static short sid
Constructor Summary
PlotAreaRecord()
PlotAreaRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PlotAreaRecord

public PlotAreaRecord()

PlotAreaRecord

public PlotAreaRecord(RecordInputStream in)
Parameters:
in - unused (since this record has no data)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PlotGrowthRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class PlotGrowthRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.PlotGrowthRecord

public final class PlotGrowthRecord
extends StandardRecord

The plot growth record specifies the scaling factors used when a font is scaled.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
PlotGrowthRecord()
PlotGrowthRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
int | getHorizontalScale() Get the horizontalScale field for the PlotGrowth record.
short | getSid() return the non static version of the id for this record.
int | getVerticalScale() Get the verticalScale field for the PlotGrowth record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setHorizontalScale(int field_1_horizontalScale) Set the horizontalScale field for the PlotGrowth record.
void | setVerticalScale(int field_2_verticalScale) Set the verticalScale field for the PlotGrowth record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PlotGrowthRecord

public PlotGrowthRecord()

PlotGrowthRecord

public PlotGrowthRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getHorizontalScale

public int getHorizontalScale()
Get the horizontalScale field for the PlotGrowth record.

setHorizontalScale

public void setHorizontalScale(int field_1_horizontalScale)
Set the horizontalScale field for the PlotGrowth record.

getVerticalScale

public int getVerticalScale()
Get the verticalScale field for the PlotGrowth record.

setVerticalScale

public void setVerticalScale(int field_2_verticalScale)
Set the verticalScale field for the PlotGrowth record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SeriesChartGroupIndexRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SeriesChartGroupIndexRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

public final class SeriesChartGroupIndexRecord
extends StandardRecord

The series chart group index record stores the index to the CHARTFORMAT record (0 based).

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
SeriesChartGroupIndexRecord()
SeriesChartGroupIndexRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getChartGroupIndex() Get the chart group index field for the SeriesChartGroupIndex record.
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setChartGroupIndex(short field_1_chartGroupIndex) Set the chart group index field for the SeriesChartGroupIndex record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SeriesChartGroupIndexRecord

public SeriesChartGroupIndexRecord()

SeriesChartGroupIndexRecord

public SeriesChartGroupIndexRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getChartGroupIndex

public short getChartGroupIndex()
Get the chart group index field for the SeriesChartGroupIndex record.

setChartGroupIndex

public void setChartGroupIndex(short field_1_chartGroupIndex)
Set the chart group index field for the SeriesChartGroupIndex record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SeriesIndexRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SeriesIndexRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SeriesIndexRecord

public final class SeriesIndexRecord
extends StandardRecord

links a series to its position in the series list.

Author:
Andrew C. Oliver (acoliver at apache.org)

Field Summary
static short sid
Constructor Summary
SeriesIndexRecord()
SeriesIndexRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getIndex() Get the index field for the SeriesIndex record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setIndex(short field_1_index) Set the index field for the SeriesIndex record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SeriesIndexRecord

public SeriesIndexRecord()

SeriesIndexRecord

public SeriesIndexRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getIndex

public short getIndex()
Get the index field for the SeriesIndex record.

setIndex

public void setIndex(short field_1_index)
Set the index field for the SeriesIndex record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SeriesLabelsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SeriesLabelsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SeriesLabelsRecord

public final class SeriesLabelsRecord
extends StandardRecord

The series label record defines the type of label associated with the data format record.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
SeriesLabelsRecord()
SeriesLabelsRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getFormatFlags() Get the format flags field for the SeriesLabels record.
short | getSid() return the non static version of the id for this record.
boolean | isLabelAsPercentage() show category label/value as percentage (pie charts only)
boolean | isShowActual() show actual value of the data point
boolean | isShowBubbleSizes() ??
boolean | isShowLabel() display category label
boolean | isShowPercent() show value as percentage of total (pie charts only)
boolean | isSmoothedLine() show smooth line
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setFormatFlags(short field_1_formatFlags) Set the format flags field for the SeriesLabels record.
void | setLabelAsPercentage(boolean value) Sets the label as percentage field value.
void | setShowActual(boolean value) Sets the show actual field value.
void | setShowBubbleSizes(boolean value) Sets the show bubble sizes field value.
void | setShowLabel(boolean value) Sets the show label field value.
void | setShowPercent(boolean value) Sets the show percent field value.
void | setSmoothedLine(boolean value) Sets the smoothed line field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SeriesLabelsRecord

public SeriesLabelsRecord()

SeriesLabelsRecord

public SeriesLabelsRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getFormatFlags

public short getFormatFlags()
Get the format flags field for the SeriesLabels record.

setFormatFlags

public void setFormatFlags(short field_1_formatFlags)
Set the format flags field for the SeriesLabels record.

setShowActual

public void setShowActual(boolean value)
Sets the show actual field value. show actual value of the data point

isShowActual

public boolean isShowActual()
show actual value of the data point

Returns:
the show actual field value.

setShowPercent

public void setShowPercent(boolean value)
Sets the show percent field value. show value as percentage of total (pie charts only)

isShowPercent

public boolean isShowPercent()
show value as percentage of total (pie charts only)

Returns:
the show percent field value.

setLabelAsPercentage

public void setLabelAsPercentage(boolean value)
Sets the label as percentage field value. show category label/value as percentage (pie charts only)

isLabelAsPercentage

public boolean isLabelAsPercentage()
show category label/value as percentage (pie charts only)

Returns:
the label as percentage field value.

setSmoothedLine

public void setSmoothedLine(boolean value)
Sets the smoothed line field value. show smooth line

isSmoothedLine

public boolean isSmoothedLine()
show smooth line

Returns:
the smoothed line field value.

setShowLabel

public void setShowLabel(boolean value)
Sets the show label field value. display category label

isShowLabel

public boolean isShowLabel()
display category label

Returns:
the show label field value.

setShowBubbleSizes

public void setShowBubbleSizes(boolean value)
Sets the show bubble sizes field value. ??

isShowBubbleSizes

public boolean isShowBubbleSizes()
??

Returns:
the show bubble sizes field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SeriesListRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SeriesListRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SeriesListRecord

public final class SeriesListRecord
extends StandardRecord

SERIESLIST (0x1016)

The series list record defines the series displayed as an overlay to the main chart record.
(As with all chart related records, documentation is lacking. See ChartRecord for more details)

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
SeriesListRecord(RecordInputStream in)
SeriesListRecord(short[] seriesNumbers)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short[] | getSeriesNumbers() Get the series numbers field for the SeriesList record.
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SeriesListRecord

public SeriesListRecord(short[] seriesNumbers)

SeriesListRecord

public SeriesListRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getSeriesNumbers

public short[] getSeriesNumbers()
Get the series numbers field for the SeriesList record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SeriesRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SeriesRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SeriesRecord

public final class SeriesRecord
extends StandardRecord

The series record describes the overall data for a series.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | BUBBLE_SERIES_TYPE_DATES
static short | BUBBLE_SERIES_TYPE_NUMERIC
static short | BUBBLE_SERIES_TYPE_SEQUENCE
static short | BUBBLE_SERIES_TYPE_TEXT
static short | CATEGORY_DATA_TYPE_DATES
static short | CATEGORY_DATA_TYPE_NUMERIC
static short | CATEGORY_DATA_TYPE_SEQUENCE
static short | CATEGORY_DATA_TYPE_TEXT
static short | sid
static short | VALUES_DATA_TYPE_DATES
static short | VALUES_DATA_TYPE_NUMERIC
static short | VALUES_DATA_TYPE_SEQUENCE
static short | VALUES_DATA_TYPE_TEXT
Constructor Summary
SeriesRecord()
SeriesRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getBubbleSeriesType() Get the bubble series type field for the Series record.
short | getCategoryDataType() Get the category data type field for the Series record.
protected int | getDataSize()
short | getNumBubbleValues() Get the num bubble values field for the Series record.
short | getNumCategories() Get the num categories field for the Series record.
short | getNumValues() Get the num values field for the Series record.
short | getSid() return the non static version of the id for this record.
short | getValuesDataType() Get the values data type field for the Series record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setBubbleSeriesType(short field_5_bubbleSeriesType) Set the bubble series type field for the Series record.
void | setCategoryDataType(short field_1_categoryDataType) Set the category data type field for the Series record.
void | setNumBubbleValues(short field_6_numBubbleValues) Set the num bubble values field for the Series record.
void | setNumCategories(short field_3_numCategories) Set the num categories field for the Series record.
void | setNumValues(short field_4_numValues) Set the num values field for the Series record.
void | setValuesDataType(short field_2_valuesDataType) Set the values data type field for the Series record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

CATEGORY_DATA_TYPE_DATES

public static final short CATEGORY_DATA_TYPE_DATES
See Also:
Constant Field Values

CATEGORY_DATA_TYPE_NUMERIC

public static final short CATEGORY_DATA_TYPE_NUMERIC
See Also:
Constant Field Values

CATEGORY_DATA_TYPE_SEQUENCE

public static final short CATEGORY_DATA_TYPE_SEQUENCE
See Also:
Constant Field Values

CATEGORY_DATA_TYPE_TEXT

public static final short CATEGORY_DATA_TYPE_TEXT
See Also:
Constant Field Values

VALUES_DATA_TYPE_DATES

public static final short VALUES_DATA_TYPE_DATES
See Also:
Constant Field Values

VALUES_DATA_TYPE_NUMERIC

public static final short VALUES_DATA_TYPE_NUMERIC
See Also:
Constant Field Values

VALUES_DATA_TYPE_SEQUENCE

public static final short VALUES_DATA_TYPE_SEQUENCE
See Also:
Constant Field Values

VALUES_DATA_TYPE_TEXT

public static final short VALUES_DATA_TYPE_TEXT
See Also:
Constant Field Values

BUBBLE_SERIES_TYPE_DATES

public static final short BUBBLE_SERIES_TYPE_DATES
See Also:
Constant Field Values

BUBBLE_SERIES_TYPE_NUMERIC

public static final short BUBBLE_SERIES_TYPE_NUMERIC
See Also:
Constant Field Values

BUBBLE_SERIES_TYPE_SEQUENCE

public static final short BUBBLE_SERIES_TYPE_SEQUENCE
See Also:
Constant Field Values

BUBBLE_SERIES_TYPE_TEXT

public static final short BUBBLE_SERIES_TYPE_TEXT
See Also:
Constant Field Values
Constructor Detail

SeriesRecord

public SeriesRecord()

SeriesRecord

public SeriesRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getCategoryDataType

public short getCategoryDataType()
Get the category data type field for the Series record.

Returns:
One of CATEGORY_DATA_TYPE_DATES CATEGORY_DATA_TYPE_NUMERIC CATEGORY_DATA_TYPE_SEQUENCE CATEGORY_DATA_TYPE_TEXT

setCategoryDataType

public void setCategoryDataType(short field_1_categoryDataType)
Set the category data type field for the Series record.

Parameters:
field_1_categoryDataType - One of CATEGORY_DATA_TYPE_DATES CATEGORY_DATA_TYPE_NUMERIC CATEGORY_DATA_TYPE_SEQUENCE CATEGORY_DATA_TYPE_TEXT

getValuesDataType

public short getValuesDataType()
Get the values data type field for the Series record.

Returns:
One of VALUES_DATA_TYPE_DATES VALUES_DATA_TYPE_NUMERIC VALUES_DATA_TYPE_SEQUENCE VALUES_DATA_TYPE_TEXT

setValuesDataType

public void setValuesDataType(short field_2_valuesDataType)
Set the values data type field for the Series record.

Parameters:
field_2_valuesDataType - One of VALUES_DATA_TYPE_DATES VALUES_DATA_TYPE_NUMERIC VALUES_DATA_TYPE_SEQUENCE VALUES_DATA_TYPE_TEXT

getNumCategories

public short getNumCategories()
Get the num categories field for the Series record.

setNumCategories

public void setNumCategories(short field_3_numCategories)
Set the num categories field for the Series record.

getNumValues

public short getNumValues()
Get the num values field for the Series record.

setNumValues

public void setNumValues(short field_4_numValues)
Set the num values field for the Series record.

getBubbleSeriesType

public short getBubbleSeriesType()
Get the bubble series type field for the Series record.

Returns:
One of BUBBLE_SERIES_TYPE_DATES BUBBLE_SERIES_TYPE_NUMERIC BUBBLE_SERIES_TYPE_SEQUENCE BUBBLE_SERIES_TYPE_TEXT

setBubbleSeriesType

public void setBubbleSeriesType(short field_5_bubbleSeriesType)
Set the bubble series type field for the Series record.

Parameters:
field_5_bubbleSeriesType - One of BUBBLE_SERIES_TYPE_DATES BUBBLE_SERIES_TYPE_NUMERIC BUBBLE_SERIES_TYPE_SEQUENCE BUBBLE_SERIES_TYPE_TEXT

getNumBubbleValues

public short getNumBubbleValues()
Get the num bubble values field for the Series record.

setNumBubbleValues

public void setNumBubbleValues(short field_6_numBubbleValues)
Set the num bubble values field for the Series record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SeriesTextRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SeriesTextRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SeriesTextRecord

public final class SeriesTextRecord
extends StandardRecord

SERIESTEXT (0x100D)

Defines a series name

Author:
Andrew C. Oliver (acoliver at apache.org)

Field Summary
static short sid
Constructor Summary
SeriesTextRecord()
SeriesTextRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
int | getId() Get the id field for the SeriesText record.
short | getSid() return the non static version of the id for this record.
java.lang.String | getText() Get the text field for the SeriesText record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setId(int id) Set the id field for the SeriesText record.
void | setText(java.lang.String text) Set the text field for the SeriesText record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SeriesTextRecord

public SeriesTextRecord()

SeriesTextRecord

public SeriesTextRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getId

public int getId()
Get the id field for the SeriesText record.

setId

public void setId(int id)
Set the id field for the SeriesText record.

getText

public java.lang.String getText()
Get the text field for the SeriesText record.

setText

public void setText(java.lang.String text)
Set the text field for the SeriesText record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SeriesToChartGroupRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SeriesToChartGroupRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

public final class SeriesToChartGroupRecord
extends StandardRecord

Indicates the chart-group index for a series. The order probably defines the mapping. So the 0th record probably means the 0th series. The only field in this of course defines which chart group the 0th series (for instance) would map to. Confusing? Well thats because it is. (p 522 BCG)

Author:
Andrew C. Oliver (acoliver at apache.org)

Field Summary
static short sid
Constructor Summary
SeriesToChartGroupRecord()
SeriesToChartGroupRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getChartGroupIndex() Get the chart group index field for the SeriesToChartGroup record.
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setChartGroupIndex(short field_1_chartGroupIndex) Set the chart group index field for the SeriesToChartGroup record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

SeriesToChartGroupRecord

public SeriesToChartGroupRecord()

SeriesToChartGroupRecord

public SeriesToChartGroupRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getChartGroupIndex

public short getChartGroupIndex()
Get the chart group index field for the SeriesToChartGroup record.

setChartGroupIndex

public void setChartGroupIndex(short field_1_chartGroupIndex)
Set the chart group index field for the SeriesToChartGroup record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SheetPropertiesRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class SheetPropertiesRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.SheetPropertiesRecord

public final class SheetPropertiesRecord
extends StandardRecord

Describes a chart sheet properties record. SHTPROPS (0x1044)

(As with all chart related records, documentation is lacking. See ChartRecord for more details)

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static byte | EMPTY_INTERPOLATED
static byte | EMPTY_NOT_PLOTTED
static byte | EMPTY_ZERO
static short | sid
Constructor Summary
SheetPropertiesRecord()
SheetPropertiesRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
int | getEmpty() Get the empty field for the SheetProperties record.
int | getFlags() Get the flags field for the SheetProperties record.
short | getSid() return the non static version of the id for this record.
boolean | isAutoPlotArea() ??
boolean | isChartTypeManuallyFormatted() Has the chart type been manually formatted?
boolean | isDefaultPlotDimensions() Indicates that the default area dimensions should be used.
boolean | isDoNotSizeWithWindow() Do not size the chart when the window changes size
boolean | isPlotVisibleOnly() Only show visible cells on the chart.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAutoPlotArea(boolean value) Sets the auto plot area field value.
void | setChartTypeManuallyFormatted(boolean value) Sets the chart type manually formatted field value.
void | setDefaultPlotDimensions(boolean value) Sets the default plot dimensions field value.
void | setDoNotSizeWithWindow(boolean value) Sets the do not size with window field value.
void | setEmpty(byte empty) Set the empty field for the SheetProperties record.
void | setPlotVisibleOnly(boolean value) Sets the plot visible only field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

EMPTY_NOT_PLOTTED

public static final byte EMPTY_NOT_PLOTTED
See Also:
Constant Field Values

EMPTY_ZERO

public static final byte EMPTY_ZERO
See Also:
Constant Field Values

EMPTY_INTERPOLATED

public static final byte EMPTY_INTERPOLATED
See Also:
Constant Field Values
Constructor Detail

SheetPropertiesRecord

public SheetPropertiesRecord()

SheetPropertiesRecord

public SheetPropertiesRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getFlags

public int getFlags()
Get the flags field for the SheetProperties record.

getEmpty

public int getEmpty()
Get the empty field for the SheetProperties record.

Returns:
One of EMPTY_NOT_PLOTTED EMPTY_ZERO EMPTY_INTERPOLATED

setEmpty

public void setEmpty(byte empty)
Set the empty field for the SheetProperties record.

Parameters:
empty - One of EMPTY_NOT_PLOTTED EMPTY_ZERO EMPTY_INTERPOLATED

setChartTypeManuallyFormatted

public void setChartTypeManuallyFormatted(boolean value)
Sets the chart type manually formatted field value. Has the chart type been manually formatted?

isChartTypeManuallyFormatted

public boolean isChartTypeManuallyFormatted()
Has the chart type been manually formatted?

Returns:
the chart type manually formatted field value.

setPlotVisibleOnly

public void setPlotVisibleOnly(boolean value)
Sets the plot visible only field value. Only show visible cells on the chart.

isPlotVisibleOnly

public boolean isPlotVisibleOnly()
Only show visible cells on the chart.

Returns:
the plot visible only field value.

setDoNotSizeWithWindow

public void setDoNotSizeWithWindow(boolean value)
Sets the do not size with window field value. Do not size the chart when the window changes size

isDoNotSizeWithWindow

public boolean isDoNotSizeWithWindow()
Do not size the chart when the window changes size

Returns:
the do not size with window field value.

setDefaultPlotDimensions

public void setDefaultPlotDimensions(boolean value)
Sets the default plot dimensions field value. Indicates that the default area dimensions should be used.

isDefaultPlotDimensions

public boolean isDefaultPlotDimensions()
Indicates that the default area dimensions should be used.

Returns:
the default plot dimensions field value.

setAutoPlotArea

public void setAutoPlotArea(boolean value)
Sets the auto plot area field value. ??

isAutoPlotArea

public boolean isAutoPlotArea()
??

Returns:
the auto plot area field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class TextRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.TextRecord

public final class TextRecord
extends StandardRecord

The text record is used to define text stored on a chart.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | DATA_LABEL_PLACEMENT_ABOVE
static short | DATA_LABEL_PLACEMENT_AUTO
static short | DATA_LABEL_PLACEMENT_AXIS
static short | DATA_LABEL_PLACEMENT_BELOW
static short | DATA_LABEL_PLACEMENT_CENTER
static short | DATA_LABEL_PLACEMENT_CHART_DEPENDENT
static short | DATA_LABEL_PLACEMENT_INSIDE
static short | DATA_LABEL_PLACEMENT_LEFT
static short | DATA_LABEL_PLACEMENT_OUTSIDE
static short | DATA_LABEL_PLACEMENT_RIGHT
static short | DATA_LABEL_PLACEMENT_USER_MOVED
static short | DISPLAY_MODE_OPAQUE
static short | DISPLAY_MODE_TRANSPARENT
static byte | HORIZONTAL_ALIGNMENT_BOTTOM
static byte | HORIZONTAL_ALIGNMENT_CENTER
static byte | HORIZONTAL_ALIGNMENT_JUSTIFY
static byte | HORIZONTAL_ALIGNMENT_LEFT
static short | ROTATION_NONE
static short | ROTATION_ROTATED_90_DEGREES
static short | ROTATION_ROTATED_90_DEGREES_CLOCKWISE
static short | ROTATION_TOP_TO_BOTTOM
static short | sid
static byte | VERTICAL_ALIGNMENT_BOTTOM
static byte | VERTICAL_ALIGNMENT_CENTER
static byte | VERTICAL_ALIGNMENT_JUSTIFY
static byte | VERTICAL_ALIGNMENT_TOP
Constructor Summary
TextRecord()
TextRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
short | getDataLabelPlacement()
protected int | getDataSize()
short | getDisplayMode() Get the display mode field for the Text record.
int | getHeight() Get the height field for the Text record.
byte | getHorizontalAlignment() Get the horizontal alignment field for the Text record.
short | getIndexOfColorValue() Get the index of color value field for the Text record.
short | getOptions1() Get the options1 field for the Text record.
short | getOptions2() Get the options2 field for the Text record.
int | getRgbColor() Get the rgbColor field for the Text record.
short | getRotation()
short | getSid() return the non static version of the id for this record.
short | getTextRotation() Get the text rotation field for the Text record.
byte | getVerticalAlignment() Get the vertical alignment field for the Text record.
int | getWidth() Get the width field for the Text record.
int | getX() Get the x field for the Text record.
int | getY() Get the y field for the Text record.
boolean | isAutoBackground()
boolean | isAutoColor() true = automaticly selected colour, false = user-selected
boolean | isAutoGeneratedText()
boolean | isAutoLabelDeleted()
boolean | isGenerated()
boolean | isShowBubbleSizes()
boolean | isShowCategoryLabelAsPercentage()
boolean | isShowKey() true = draw legend
boolean | isShowLabel()
boolean | isShowValue() false = text is category label
boolean | isShowValueAsPercentage()
boolean | isVertical() true = text is vertical
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAutoBackground(boolean value) Sets the auto background field value.
void | setAutoColor(boolean value) Sets the auto color field value.
void | setAutoGeneratedText(boolean value) Sets the auto generated text field value.
void | setAutoLabelDeleted(boolean value) Sets the auto label deleted field value.
void | setDataLabelPlacement(short value) Sets the data label placement field value.
void | setDisplayMode(short field_3_displayMode) Set the display mode field for the Text record.
void | setGenerated(boolean value) Sets the generated field value.
void | setHeight(int field_8_height) Set the height field for the Text record.
void | setHorizontalAlignment(byte field_1_horizontalAlignment) Set the horizontal alignment field for the Text record.
void | setIndexOfColorValue(short field_10_indexOfColorValue) Set the index of color value field for the Text record.
void | setOptions1(short field_9_options1) Set the options1 field for the Text record.
void | setOptions2(short field_11_options2) Set the options2 field for the Text record.
void | setRgbColor(int field_4_rgbColor) Set the rgbColor field for the Text record.
void | setRotation(short value) Sets the rotation field value.
void | setShowBubbleSizes(boolean value) Sets the show bubble sizes field value.
void | setShowCategoryLabelAsPercentage(boolean value) Sets the show category label as percentage field value.
void | setShowKey(boolean value) Sets the show key field value.
void | setShowLabel(boolean value) Sets the show label field value.
void | setShowValue(boolean value) Sets the show value field value.
void | setShowValueAsPercentage(boolean value) Sets the show value as percentage field value.
void | setTextRotation(short field_12_textRotation) Set the text rotation field for the Text record.
void | setVertical(boolean value) Sets the vertical field value.
void | setVerticalAlignment(byte field_2_verticalAlignment) Set the vertical alignment field for the Text record.
void | setWidth(int field_7_width) Set the width field for the Text record.
void | setX(int field_5_x) Set the x field for the Text record.
void | setY(int field_6_y) Set the y field for the Text record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_LEFT

public static final byte HORIZONTAL_ALIGNMENT_LEFT
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_CENTER

public static final byte HORIZONTAL_ALIGNMENT_CENTER
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_BOTTOM

public static final byte HORIZONTAL_ALIGNMENT_BOTTOM
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_JUSTIFY

public static final byte HORIZONTAL_ALIGNMENT_JUSTIFY
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_TOP

public static final byte VERTICAL_ALIGNMENT_TOP
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_CENTER

public static final byte VERTICAL_ALIGNMENT_CENTER
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_BOTTOM

public static final byte VERTICAL_ALIGNMENT_BOTTOM
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_JUSTIFY

public static final byte VERTICAL_ALIGNMENT_JUSTIFY
See Also:
Constant Field Values

DISPLAY_MODE_TRANSPARENT

public static final short DISPLAY_MODE_TRANSPARENT
See Also:
Constant Field Values

DISPLAY_MODE_OPAQUE

public static final short DISPLAY_MODE_OPAQUE
See Also:
Constant Field Values

ROTATION_NONE

public static final short ROTATION_NONE
See Also:
Constant Field Values

ROTATION_TOP_TO_BOTTOM

public static final short ROTATION_TOP_TO_BOTTOM
See Also:
Constant Field Values

ROTATION_ROTATED_90_DEGREES

public static final short ROTATION_ROTATED_90_DEGREES
See Also:
Constant Field Values

ROTATION_ROTATED_90_DEGREES_CLOCKWISE

public static final short ROTATION_ROTATED_90_DEGREES_CLOCKWISE
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_CHART_DEPENDENT

public static final short DATA_LABEL_PLACEMENT_CHART_DEPENDENT
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_OUTSIDE

public static final short DATA_LABEL_PLACEMENT_OUTSIDE
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_INSIDE

public static final short DATA_LABEL_PLACEMENT_INSIDE
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_CENTER

public static final short DATA_LABEL_PLACEMENT_CENTER
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_AXIS

public static final short DATA_LABEL_PLACEMENT_AXIS
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_ABOVE

public static final short DATA_LABEL_PLACEMENT_ABOVE
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_BELOW

public static final short DATA_LABEL_PLACEMENT_BELOW
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_LEFT

public static final short DATA_LABEL_PLACEMENT_LEFT
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_RIGHT

public static final short DATA_LABEL_PLACEMENT_RIGHT
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_AUTO

public static final short DATA_LABEL_PLACEMENT_AUTO
See Also:
Constant Field Values

DATA_LABEL_PLACEMENT_USER_MOVED

public static final short DATA_LABEL_PLACEMENT_USER_MOVED
See Also:
Constant Field Values
Constructor Detail

TextRecord

public TextRecord()

TextRecord

public TextRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getHorizontalAlignment

public byte getHorizontalAlignment()
Get the horizontal alignment field for the Text record.

Returns:
One of HORIZONTAL_ALIGNMENT_LEFT HORIZONTAL_ALIGNMENT_CENTER HORIZONTAL_ALIGNMENT_BOTTOM HORIZONTAL_ALIGNMENT_JUSTIFY

setHorizontalAlignment

public void setHorizontalAlignment(byte field_1_horizontalAlignment)
Set the horizontal alignment field for the Text record.

Parameters:
field_1_horizontalAlignment - One of HORIZONTAL_ALIGNMENT_LEFT HORIZONTAL_ALIGNMENT_CENTER HORIZONTAL_ALIGNMENT_BOTTOM HORIZONTAL_ALIGNMENT_JUSTIFY

getVerticalAlignment

public byte getVerticalAlignment()
Get the vertical alignment field for the Text record.

Returns:
One of VERTICAL_ALIGNMENT_TOP VERTICAL_ALIGNMENT_CENTER VERTICAL_ALIGNMENT_BOTTOM VERTICAL_ALIGNMENT_JUSTIFY

setVerticalAlignment

public void setVerticalAlignment(byte field_2_verticalAlignment)
Set the vertical alignment field for the Text record.

Parameters:
field_2_verticalAlignment - One of VERTICAL_ALIGNMENT_TOP VERTICAL_ALIGNMENT_CENTER VERTICAL_ALIGNMENT_BOTTOM VERTICAL_ALIGNMENT_JUSTIFY

getDisplayMode

public short getDisplayMode()
Get the display mode field for the Text record.

Returns:
One of DISPLAY_MODE_TRANSPARENT DISPLAY_MODE_OPAQUE

setDisplayMode

public void setDisplayMode(short field_3_displayMode)
Set the display mode field for the Text record.

Parameters:
field_3_displayMode - One of DISPLAY_MODE_TRANSPARENT DISPLAY_MODE_OPAQUE

getRgbColor

public int getRgbColor()
Get the rgbColor field for the Text record.

setRgbColor

public void setRgbColor(int field_4_rgbColor)
Set the rgbColor field for the Text record.

getX

public int getX()
Get the x field for the Text record.

setX

public void setX(int field_5_x)
Set the x field for the Text record.

getY

public int getY()
Get the y field for the Text record.

setY

public void setY(int field_6_y)
Set the y field for the Text record.

getWidth

public int getWidth()
Get the width field for the Text record.

setWidth

public void setWidth(int field_7_width)
Set the width field for the Text record.

getHeight

public int getHeight()
Get the height field for the Text record.

setHeight

public void setHeight(int field_8_height)
Set the height field for the Text record.

getOptions1

public short getOptions1()
Get the options1 field for the Text record.

setOptions1

public void setOptions1(short field_9_options1)
Set the options1 field for the Text record.

getIndexOfColorValue

public short getIndexOfColorValue()
Get the index of color value field for the Text record.

setIndexOfColorValue

public void setIndexOfColorValue(short field_10_indexOfColorValue)
Set the index of color value field for the Text record.

getOptions2

public short getOptions2()
Get the options2 field for the Text record.

setOptions2

public void setOptions2(short field_11_options2)
Set the options2 field for the Text record.

getTextRotation

public short getTextRotation()
Get the text rotation field for the Text record.

setTextRotation

public void setTextRotation(short field_12_textRotation)
Set the text rotation field for the Text record.

setAutoColor

public void setAutoColor(boolean value)
Sets the auto color field value. true = automaticly selected colour, false = user-selected

isAutoColor

public boolean isAutoColor()
true = automaticly selected colour, false = user-selected

Returns:
the auto color field value.

setShowKey

public void setShowKey(boolean value)
Sets the show key field value. true = draw legend

isShowKey

public boolean isShowKey()
true = draw legend

Returns:
the show key field value.

setShowValue

public void setShowValue(boolean value)
Sets the show value field value. false = text is category label

isShowValue

public boolean isShowValue()
false = text is category label

Returns:
the show value field value.

setVertical

public void setVertical(boolean value)
Sets the vertical field value. true = text is vertical

isVertical

public boolean isVertical()
true = text is vertical

Returns:
the vertical field value.

setAutoGeneratedText

public void setAutoGeneratedText(boolean value)
Sets the auto generated text field value.

isAutoGeneratedText

public boolean isAutoGeneratedText()
Returns:
the auto generated text field value.

setGenerated

public void setGenerated(boolean value)
Sets the generated field value.

isGenerated

public boolean isGenerated()
Returns:
the generated field value.

setAutoLabelDeleted

public void setAutoLabelDeleted(boolean value)
Sets the auto label deleted field value.

isAutoLabelDeleted

public boolean isAutoLabelDeleted()
Returns:
the auto label deleted field value.

setAutoBackground

public void setAutoBackground(boolean value)
Sets the auto background field value.

isAutoBackground

public boolean isAutoBackground()
Returns:
the auto background field value.

setRotation

public void setRotation(short value)
Sets the rotation field value.

getRotation

public short getRotation()
Returns:
the rotation field value.

setShowCategoryLabelAsPercentage

public void setShowCategoryLabelAsPercentage(boolean value)
Sets the show category label as percentage field value.

isShowCategoryLabelAsPercentage

public boolean isShowCategoryLabelAsPercentage()
Returns:
the show category label as percentage field value.

setShowValueAsPercentage

public void setShowValueAsPercentage(boolean value)
Sets the show value as percentage field value.

isShowValueAsPercentage

public boolean isShowValueAsPercentage()
Returns:
the show value as percentage field value.

setShowBubbleSizes

public void setShowBubbleSizes(boolean value)
Sets the show bubble sizes field value.

isShowBubbleSizes

public boolean isShowBubbleSizes()
Returns:
the show bubble sizes field value.

setShowLabel

public void setShowLabel(boolean value)
Sets the show label field value.

isShowLabel

public boolean isShowLabel()
Returns:
the show label field value.

setDataLabelPlacement

public void setDataLabelPlacement(short value)
Sets the data label placement field value.

getDataLabelPlacement

public short getDataLabelPlacement()
Returns:
the data label placement field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TickRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class TickRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.TickRecord

public final class TickRecord
extends StandardRecord

The Tick record defines how tick marks and label positioning/formatting

Author:
Andrew C. Oliver(acoliver at apache.org)

Field Summary
static short sid
Constructor Summary
TickRecord()
TickRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
byte | getBackground() Get the background field for the Tick record.
protected int | getDataSize()
int | getLabelColorRgb() Get the label color rgb field for the Tick record.
byte | getLabelPosition() Get the label position field for the Tick record.
byte | getMajorTickType() Get the major tick type field for the Tick record.
byte | getMinorTickType() Get the minor tick type field for the Tick record.
short | getOptions() Get the options field for the Tick record.
short | getRotation() rotate text (0=none, 1=normal, 2=90 degrees counterclockwise, 3=90 degrees clockwise)
short | getSid() return the non static version of the id for this record.
short | getTickColor() Get the tick color field for the Tick record.
int | getZero1() Get the zero 1 field for the Tick record.
int | getZero2() Get the zero 2 field for the Tick record.
short | getZero3() Get the zero 3 field for the Tick record.
boolean | isAutorotate() automatically rotate the text
boolean | isAutoTextBackground() use the quote unquote automatic color for text background
boolean | isAutoTextColor() use the quote unquote automatic color for text
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAutorotate(boolean value) Sets the autorotate field value.
void | setAutoTextBackground(boolean value) Sets the auto text background field value.
void | setAutoTextColor(boolean value) Sets the auto text color field value.
void | setBackground(byte field_4_background) Set the background field for the Tick record.
void | setLabelColorRgb(int field_5_labelColorRgb) Set the label color rgb field for the Tick record.
void | setLabelPosition(byte field_3_labelPosition) Set the label position field for the Tick record.
void | setMajorTickType(byte field_1_majorTickType) Set the major tick type field for the Tick record.
void | setMinorTickType(byte field_2_minorTickType) Set the minor tick type field for the Tick record.
void | setOptions(short field_10_options) Set the options field for the Tick record.
void | setRotation(short value) Sets the rotation field value.
void | setTickColor(short field_11_tickColor) Set the tick color field for the Tick record.
void | setZero1(int field_6_zero1) Set the zero 1 field for the Tick record.
void | setZero2(int field_7_zero2) Set the zero 2 field for the Tick record.
void | setZero3(short field_12_zero3) Set the zero 3 field for the Tick record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

TickRecord

public TickRecord()

TickRecord

public TickRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getMajorTickType

public byte getMajorTickType()
Get the major tick type field for the Tick record.

setMajorTickType

public void setMajorTickType(byte field_1_majorTickType)
Set the major tick type field for the Tick record.

getMinorTickType

public byte getMinorTickType()
Get the minor tick type field for the Tick record.

setMinorTickType

public void setMinorTickType(byte field_2_minorTickType)
Set the minor tick type field for the Tick record.

getLabelPosition

public byte getLabelPosition()
Get the label position field for the Tick record.

setLabelPosition

public void setLabelPosition(byte field_3_labelPosition)
Set the label position field for the Tick record.

getBackground

public byte getBackground()
Get the background field for the Tick record.

setBackground

public void setBackground(byte field_4_background)
Set the background field for the Tick record.

getLabelColorRgb

public int getLabelColorRgb()
Get the label color rgb field for the Tick record.

setLabelColorRgb

public void setLabelColorRgb(int field_5_labelColorRgb)
Set the label color rgb field for the Tick record.

getZero1

public int getZero1()
Get the zero 1 field for the Tick record.

setZero1

public void setZero1(int field_6_zero1)
Set the zero 1 field for the Tick record.

getZero2

public int getZero2()
Get the zero 2 field for the Tick record.

setZero2

public void setZero2(int field_7_zero2)
Set the zero 2 field for the Tick record.

getOptions

public short getOptions()
Get the options field for the Tick record.

setOptions

public void setOptions(short field_10_options)
Set the options field for the Tick record.

getTickColor

public short getTickColor()
Get the tick color field for the Tick record.

setTickColor

public void setTickColor(short field_11_tickColor)
Set the tick color field for the Tick record.

getZero3

public short getZero3()
Get the zero 3 field for the Tick record.

setZero3

public void setZero3(short field_12_zero3)
Set the zero 3 field for the Tick record.

setAutoTextColor

public void setAutoTextColor(boolean value)
Sets the auto text color field value. use the quote unquote automatic color for text

isAutoTextColor

public boolean isAutoTextColor()
use the quote unquote automatic color for text

Returns:
the auto text color field value.

setAutoTextBackground

public void setAutoTextBackground(boolean value)
Sets the auto text background field value. use the quote unquote automatic color for text background

isAutoTextBackground

public boolean isAutoTextBackground()
use the quote unquote automatic color for text background

Returns:
the auto text background field value.

setRotation

public void setRotation(short value)
Sets the rotation field value. rotate text (0=none, 1=normal, 2=90 degrees counterclockwise, 3=90 degrees clockwise)

getRotation

public short getRotation()
rotate text (0=none, 1=normal, 2=90 degrees counterclockwise, 3=90 degrees clockwise)

Returns:
the rotation field value.

setAutorotate

public void setAutorotate(boolean value)
Sets the autorotate field value. automatically rotate the text

isAutorotate

public boolean isAutorotate()
automatically rotate the text

Returns:
the autorotate field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnitsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class UnitsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.UnitsRecord

public final class UnitsRecord
extends StandardRecord

The units record describes units.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
UnitsRecord()
UnitsRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
short | getUnits() Get the units field for the Units record.
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setUnits(short field_1_units) Set the units field for the Units record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

UnitsRecord

public UnitsRecord()

UnitsRecord

public UnitsRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getUnits

public short getUnits()
Get the units field for the Units record.

setUnits

public void setUnits(short field_1_units)
Set the units field for the Units record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueRangeRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.chart
Class ValueRangeRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.chart.ValueRangeRecord

public final class ValueRangeRecord
extends StandardRecord

The value range record defines the range of the value axis.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short sid
Constructor Summary
ValueRangeRecord()
ValueRangeRecord(RecordInputStream in)
Method Summary
java.lang.Object | clone()
double | getCategoryAxisCross() Get the category axis cross field for the ValueRange record.
protected int | getDataSize()
double | getMajorIncrement() Get the major increment field for the ValueRange record.
double | getMaximumAxisValue() Get the maximum axis value field for the ValueRange record.
double | getMinimumAxisValue() Get the minimum axis value field for the ValueRange record.
double | getMinorIncrement() Get the minor increment field for the ValueRange record.
short | getOptions() Get the options field for the ValueRange record.
short | getSid() return the non static version of the id for this record.
boolean | isAutomaticCategoryCrossing() category crossing point is automatically selected
boolean | isAutomaticMajor() automatic major unit selected
boolean | isAutomaticMaximum() automatic maximum value selected
boolean | isAutomaticMinimum() automatic minimum value selected
boolean | isAutomaticMinor() automatic minor unit selected
boolean | isCrossCategoryAxisAtMaximum() category axis to cross at maximum value
boolean | isLogarithmicScale() use logarithmic scale
boolean | isReserved() reserved, must equal 1 (excel dev.
boolean | isValuesInReverse() values are reverses in graph
void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | setAutomaticCategoryCrossing(boolean value) Sets the automatic category crossing field value.
void | setAutomaticMajor(boolean value) Sets the automatic major field value.
void | setAutomaticMaximum(boolean value) Sets the automatic maximum field value.
void | setAutomaticMinimum(boolean value) Sets the automatic minimum field value.
void | setAutomaticMinor(boolean value) Sets the automatic minor field value.
void | setCategoryAxisCross(double field_5_categoryAxisCross) Set the category axis cross field for the ValueRange record.
void | setCrossCategoryAxisAtMaximum(boolean value) Sets the cross category axis at maximum field value.
void | setLogarithmicScale(boolean value) Sets the logarithmic scale field value.
void | setMajorIncrement(double field_3_majorIncrement) Set the major increment field for the ValueRange record.
void | setMaximumAxisValue(double field_2_maximumAxisValue) Set the maximum axis value field for the ValueRange record.
void | setMinimumAxisValue(double field_1_minimumAxisValue) Set the minimum axis value field for the ValueRange record.
void | setMinorIncrement(double field_4_minorIncrement) Set the minor increment field for the ValueRange record.
void | setOptions(short field_6_options) Set the options field for the ValueRange record.
void | setReserved(boolean value) Sets the reserved field value.
void | setValuesInReverse(boolean value) Sets the values in reverse field value.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ValueRangeRecord

public ValueRangeRecord()

ValueRangeRecord

public ValueRangeRecord(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record

serialize

public void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

clone

public java.lang.Object clone()
Overrides:
clone in class Record

getMinimumAxisValue

public double getMinimumAxisValue()
Get the minimum axis value field for the ValueRange record.

setMinimumAxisValue

public void setMinimumAxisValue(double field_1_minimumAxisValue)
Set the minimum axis value field for the ValueRange record.

getMaximumAxisValue

public double getMaximumAxisValue()
Get the maximum axis value field for the ValueRange record.

setMaximumAxisValue

public void setMaximumAxisValue(double field_2_maximumAxisValue)
Set the maximum axis value field for the ValueRange record.

getMajorIncrement

public double getMajorIncrement()
Get the major increment field for the ValueRange record.

setMajorIncrement

public void setMajorIncrement(double field_3_majorIncrement)
Set the major increment field for the ValueRange record.

getMinorIncrement

public double getMinorIncrement()
Get the minor increment field for the ValueRange record.

setMinorIncrement

public void setMinorIncrement(double field_4_minorIncrement)
Set the minor increment field for the ValueRange record.

getCategoryAxisCross

public double getCategoryAxisCross()
Get the category axis cross field for the ValueRange record.

setCategoryAxisCross

public void setCategoryAxisCross(double field_5_categoryAxisCross)
Set the category axis cross field for the ValueRange record.

getOptions

public short getOptions()
Get the options field for the ValueRange record.

setOptions

public void setOptions(short field_6_options)
Set the options field for the ValueRange record.

setAutomaticMinimum

public void setAutomaticMinimum(boolean value)
Sets the automatic minimum field value. automatic minimum value selected

isAutomaticMinimum

public boolean isAutomaticMinimum()
automatic minimum value selected

Returns:
the automatic minimum field value.

setAutomaticMaximum

public void setAutomaticMaximum(boolean value)
Sets the automatic maximum field value. automatic maximum value selected

isAutomaticMaximum

public boolean isAutomaticMaximum()
automatic maximum value selected

Returns:
the automatic maximum field value.

setAutomaticMajor

public void setAutomaticMajor(boolean value)
Sets the automatic major field value. automatic major unit selected

isAutomaticMajor

public boolean isAutomaticMajor()
automatic major unit selected

Returns:
the automatic major field value.

setAutomaticMinor

public void setAutomaticMinor(boolean value)
Sets the automatic minor field value. automatic minor unit selected

isAutomaticMinor

public boolean isAutomaticMinor()
automatic minor unit selected

Returns:
the automatic minor field value.

setAutomaticCategoryCrossing

public void setAutomaticCategoryCrossing(boolean value)
Sets the automatic category crossing field value. category crossing point is automatically selected

isAutomaticCategoryCrossing

public boolean isAutomaticCategoryCrossing()
category crossing point is automatically selected

Returns:
the automatic category crossing field value.

setLogarithmicScale

public void setLogarithmicScale(boolean value)
Sets the logarithmic scale field value. use logarithmic scale

isLogarithmicScale

public boolean isLogarithmicScale()
use logarithmic scale

Returns:
the logarithmic scale field value.

setValuesInReverse

public void setValuesInReverse(boolean value)
Sets the values in reverse field value. values are reverses in graph

isValuesInReverse

public boolean isValuesInReverse()
values are reverses in graph

Returns:
the values in reverse field value.

setCrossCategoryAxisAtMaximum

public void setCrossCategoryAxisAtMaximum(boolean value)
Sets the cross category axis at maximum field value. category axis to cross at maximum value

isCrossCategoryAxisAtMaximum

public boolean isCrossCategoryAxisAtMaximum()
category axis to cross at maximum value

Returns:
the cross category axis at maximum field value.

setReserved

public void setReserved(boolean value)
Sets the reserved field value. reserved, must equal 1 (excel dev. guide says otherwise)

isReserved

public boolean isReserved()
reserved, must equal 1 (excel dev. guide says otherwise)

Returns:
the reserved field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.record.chart.AreaFormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.AreaFormatRecord

No usage of org.apache.poi.hssf.record.chart.AreaFormatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.AreaRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.AreaRecord

No usage of org.apache.poi.hssf.record.chart.AreaRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.AxisLineFormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.AxisLineFormatRecord

No usage of org.apache.poi.hssf.record.chart.AxisLineFormatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.AxisOptionsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.AxisOptionsRecord

No usage of org.apache.poi.hssf.record.chart.AxisOptionsRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.AxisParentRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.AxisParentRecord

No usage of org.apache.poi.hssf.record.chart.AxisParentRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.AxisRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.AxisRecord

No usage of org.apache.poi.hssf.record.chart.AxisRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.AxisUsedRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.AxisUsedRecord

No usage of org.apache.poi.hssf.record.chart.AxisUsedRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.BarRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.BarRecord

No usage of org.apache.poi.hssf.record.chart.BarRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.BeginRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.BeginRecord

No usage of org.apache.poi.hssf.record.chart.BeginRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

No usage of org.apache.poi.hssf.record.chart.CategorySeriesAxisRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.CatLabRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.CatLabRecord

No usage of org.apache.poi.hssf.record.chart.CatLabRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartEndBlockRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartEndBlockRecord

Packages that use ChartEndBlockRecord
org.apache.poi.hssf.record.chart

Uses of ChartEndBlockRecord in org.apache.poi.hssf.record.chart

Methods in org.apache.poi.hssf.record.chart that return ChartEndBlockRecord
 ChartEndBlockRecord ChartEndBlockRecord.clone()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartEndObjectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartEndObjectRecord

No usage of org.apache.poi.hssf.record.chart.ChartEndObjectRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartFormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartFormatRecord

No usage of org.apache.poi.hssf.record.chart.ChartFormatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

No usage of org.apache.poi.hssf.record.chart.ChartFRTInfoRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartRecord

No usage of org.apache.poi.hssf.record.chart.ChartRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartStartBlockRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartStartBlockRecord

Packages that use ChartStartBlockRecord
org.apache.poi.hssf.record.chart

Uses of ChartStartBlockRecord in org.apache.poi.hssf.record.chart

Methods in org.apache.poi.hssf.record.chart that return ChartStartBlockRecord
 ChartStartBlockRecord ChartStartBlockRecord.clone()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartStartObjectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartStartObjectRecord

No usage of org.apache.poi.hssf.record.chart.ChartStartObjectRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

No usage of org.apache.poi.hssf.record.chart.ChartTitleFormatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.DataFormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.DataFormatRecord

No usage of org.apache.poi.hssf.record.chart.DataFormatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

No usage of org.apache.poi.hssf.record.chart.DataLabelExtensionRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.DatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.DatRecord

No usage of org.apache.poi.hssf.record.chart.DatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

No usage of org.apache.poi.hssf.record.chart.DefaultDataLabelTextPropertiesRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.EndRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.EndRecord

No usage of org.apache.poi.hssf.record.chart.EndRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.FontBasisRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.FontBasisRecord

No usage of org.apache.poi.hssf.record.chart.FontBasisRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.FontIndexRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.FontIndexRecord

No usage of org.apache.poi.hssf.record.chart.FontIndexRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.FrameRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.FrameRecord

No usage of org.apache.poi.hssf.record.chart.FrameRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.LegendRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.LegendRecord

No usage of org.apache.poi.hssf.record.chart.LegendRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.LineFormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.LineFormatRecord

No usage of org.apache.poi.hssf.record.chart.LineFormatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.LinkedDataRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.LinkedDataRecord

Packages that use LinkedDataRecord
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of LinkedDataRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return LinkedDataRecord
LinkedDataRecord | HSSFChart.HSSFSeries.getDataCategoryLabels()
LinkedDataRecord | HSSFChart.HSSFSeries.getDataName()
LinkedDataRecord | HSSFChart.HSSFSeries.getDataSecondaryCategoryLabels()
LinkedDataRecord | HSSFChart.HSSFSeries.getDataValues()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

No usage of org.apache.poi.hssf.record.chart.NumberFormatIndexRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ObjectLinkRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ObjectLinkRecord

No usage of org.apache.poi.hssf.record.chart.ObjectLinkRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.PlotAreaRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.PlotAreaRecord

No usage of org.apache.poi.hssf.record.chart.PlotAreaRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.PlotGrowthRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.PlotGrowthRecord

No usage of org.apache.poi.hssf.record.chart.PlotGrowthRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

No usage of org.apache.poi.hssf.record.chart.SeriesChartGroupIndexRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SeriesIndexRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SeriesIndexRecord

No usage of org.apache.poi.hssf.record.chart.SeriesIndexRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SeriesLabelsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SeriesLabelsRecord

No usage of org.apache.poi.hssf.record.chart.SeriesLabelsRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SeriesListRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SeriesListRecord

No usage of org.apache.poi.hssf.record.chart.SeriesListRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SeriesRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SeriesRecord

Packages that use SeriesRecord
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of SeriesRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return SeriesRecord
 SeriesRecord HSSFChart.HSSFSeries.getSeries()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SeriesTextRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SeriesTextRecord

No usage of org.apache.poi.hssf.record.chart.SeriesTextRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

No usage of org.apache.poi.hssf.record.chart.SeriesToChartGroupRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.SheetPropertiesRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.SheetPropertiesRecord

No usage of org.apache.poi.hssf.record.chart.SheetPropertiesRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.TextRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.TextRecord

No usage of org.apache.poi.hssf.record.chart.TextRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.TickRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.TickRecord

No usage of org.apache.poi.hssf.record.chart.TickRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.UnitsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.UnitsRecord

No usage of org.apache.poi.hssf.record.chart.UnitsRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.chart.ValueRangeRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.chart.ValueRangeRecord

No usage of org.apache.poi.hssf.record.chart.ValueRangeRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.AbstractEscherHolderRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.AbstractEscherHolderRecord

Packages that use AbstractEscherHolderRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of AbstractEscherHolderRecord in org.apache.poi.hssf.record

Subclasses of AbstractEscherHolderRecord in org.apache.poi.hssf.record
class | DrawingGroupRecord
class | DrawingRecordForBiffViewer This is purely for the biff viewer.
class | EscherAggregate This class is used to aggregate the MSODRAWING and OBJ record combinations.

Methods in org.apache.poi.hssf.record with parameters of type AbstractEscherHolderRecord
 void AbstractEscherHolderRecord.join(AbstractEscherHolderRecord record)
Big drawing group records are split but it's easier to deal with them as a whole group so we need to join them together.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ArrayRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ArrayRecord

Packages that use ArrayRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of ArrayRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return ArrayRecord
 ArrayRecord SharedValueManager.getArrayRecord(int firstRow, int firstColumn)

Methods in org.apache.poi.hssf.record.aggregates with parameters of type ArrayRecord
void | SharedValueManager.addArrayRecord(ArrayRecord ar) Add specified Array Record.
static SharedValueManager | SharedValueManager.create(SharedFormulaRecord[] sharedFormulaRecords, CellReference[] firstCells, ArrayRecord[] arrayRecords, TableRecord[] tableRecords)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.AutoFilterInfoRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.AutoFilterInfoRecord

No usage of org.apache.poi.hssf.record.AutoFilterInfoRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.BackupRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.BackupRecord

Packages that use BackupRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of BackupRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return BackupRecord
 BackupRecord InternalWorkbook.getBackupRecord()
Returns the position of the backup record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.record.BiffHeaderInput

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.record.BiffHeaderInput

Packages that use BiffHeaderInput
org.apache.poi.hssf.record.crypto

Uses of BiffHeaderInput in org.apache.poi.hssf.record.crypto

Classes in org.apache.poi.hssf.record.crypto that implement BiffHeaderInput
 class Biff8DecryptingStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.BlankRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.BlankRecord

Packages that use BlankRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of BlankRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return BlankRecord
static BlankRecord[] RecordFactory.convertBlankRecords(MulBlankRecord mbk)
Converts a MulBlankRecord into an equivalent array of BlankRecords

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.BOFRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.BOFRecord

Packages that use BOFRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of BOFRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return BOFRecord
static BOFRecord BOFRecord.createSheetBOF()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.BookBoolRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.BookBoolRecord

No usage of org.apache.poi.hssf.record.BookBoolRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.BoolErrRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.BoolErrRecord

No usage of org.apache.poi.hssf.record.BoolErrRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.BottomMarginRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.BottomMarginRecord

No usage of org.apache.poi.hssf.record.BottomMarginRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.BoundSheetRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.BoundSheetRecord

Packages that use BoundSheetRecord
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.

Uses of BoundSheetRecord in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel that return BoundSheetRecord
 BoundSheetRecord[] EventWorkbookBuilder.SheetRecordCollectingListener.getBoundSheetRecords()

Methods in org.apache.poi.hssf.eventusermodel with parameters of type BoundSheetRecord
static InternalWorkbook | EventWorkbookBuilder.createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds) Creates a stub workbook from the supplied records, suitable for use with the HSSFFormulaParser
static InternalWorkbook | EventWorkbookBuilder.createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds, SSTRecord sst) Creates a stub Workbook from the supplied records, suitable for use with the HSSFFormulaParser

Uses of BoundSheetRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return BoundSheetRecord
static BoundSheetRecord[] BoundSheetRecord.orderByBofPosition(java.util.List<BoundSheetRecord> boundSheetRecords)
Converts a List of BoundSheetRecords to an array and sorts by the position of their BOFs.

Method parameters in org.apache.poi.hssf.record with type arguments of type BoundSheetRecord
static BoundSheetRecord[] BoundSheetRecord.orderByBofPosition(java.util.List<BoundSheetRecord> boundSheetRecords)
Converts a List of BoundSheetRecords to an array and sorts by the position of their BOFs.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CalcCountRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CalcCountRecord

No usage of org.apache.poi.hssf.record.CalcCountRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CalcModeRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CalcModeRecord

No usage of org.apache.poi.hssf.record.CalcModeRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CellRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CellRecord

Packages that use CellRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of CellRecord in org.apache.poi.hssf.record

Subclasses of CellRecord in org.apache.poi.hssf.record
class | BoolErrRecord Creates new BoolErrRecord.
class | FormulaRecord Formula Record (0x0006).
class | LabelSSTRecord Title: Label SST Record
class | NumberRecord NUMBER (0x0203) Contains a numeric cell value.
class | RKRecord Title: RK Record (0x027E) Description: An internal 32 bit number with the two most significant bits storing the type.

Methods in org.apache.poi.hssf.record with parameters of type CellRecord
protected  void CellRecord.copyBaseFields(CellRecord rec)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.record.CellValueRecordInterface

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.record.CellValueRecordInterface

Packages that use CellValueRecordInterface
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of CellValueRecordInterface in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel with parameters of type CellValueRecordInterface
java.lang.String | FormatTrackingHSSFListener.formatNumberDateCell(CellValueRecordInterface cell) Formats the given numeric of date Cell's contents as a String, in as close as we can to the way that Excel would do so.
int | FormatTrackingHSSFListener.getFormatIndex(CellValueRecordInterface cell) Returns the index of the format string, used by your cell, or -1 if none found
java.lang.String | FormatTrackingHSSFListener.getFormatString(CellValueRecordInterface cell) Returns the format string, eg $##.##, used by your cell

Uses of CellValueRecordInterface in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return CellValueRecordInterface
 CellValueRecordInterface[] InternalSheet.getValueRecords()
Deprecated. use InternalSheet.getCellValueIterator() instead

Methods in org.apache.poi.hssf.model that return types with arguments of type CellValueRecordInterface
 java.util.Iterator<CellValueRecordInterface> InternalSheet.getCellValueIterator()
Get all the value records (from LOC).

Methods in org.apache.poi.hssf.model with parameters of type CellValueRecordInterface
void | InternalSheet.addValueRecord(int row, CellValueRecordInterface col) Adds a value record to the sheet's contained binary records (i.e.
void | InternalSheet.removeValueRecord(int row, CellValueRecordInterface col) remove a value record from the records array.
void | InternalSheet.replaceValueRecord(CellValueRecordInterface newval) replace a value record from the records array.

Uses of CellValueRecordInterface in org.apache.poi.hssf.record

Classes in org.apache.poi.hssf.record that implement CellValueRecordInterface
class | BlankRecord Title: Blank cell record (0x0201)
class | BoolErrRecord Creates new BoolErrRecord.
class | CellRecord Base class for all cell value records (implementors of CellValueRecordInterface).
class | FormulaRecord Formula Record (0x0006).
class | LabelRecord Label Record (0x0204) - read only support for strings stored directly in the cell..
class | LabelSSTRecord Title: Label SST Record
class | NumberRecord NUMBER (0x0203) Contains a numeric cell value.
class | RKRecord Title: RK Record (0x027E) Description: An internal 32 bit number with the two most significant bits storing the type.

Uses of CellValueRecordInterface in org.apache.poi.hssf.record.aggregates

Classes in org.apache.poi.hssf.record.aggregates that implement CellValueRecordInterface
 class FormulaRecordAggregate
The formula record aggregate is used to join together the formula record and it's (optional) string record and (optional) Shared Formula Record (template reads, excel optimization).

Methods in org.apache.poi.hssf.record.aggregates that return CellValueRecordInterface
 CellValueRecordInterface[] ValueRecordsAggregate.getValueRecords()
Deprecated. use ValueRecordsAggregate.iterator() instead
 CellValueRecordInterface[] RowRecordsAggregate.getValueRecords()
Deprecated. use RowRecordsAggregate.getCellValueIterator() instead

Methods in org.apache.poi.hssf.record.aggregates that return types with arguments of type CellValueRecordInterface
java.util.Iterator<CellValueRecordInterface> | RowRecordsAggregate.getCellValueIterator() Returns an iterator for the cell values
java.util.Iterator<CellValueRecordInterface> | ValueRecordsAggregate.iterator() value iterator

Methods in org.apache.poi.hssf.record.aggregates with parameters of type CellValueRecordInterface
void | ValueRecordsAggregate.construct(CellValueRecordInterface rec, RecordStream rs, SharedValueManager sfh) Processes a single cell value record
void | ValueRecordsAggregate.insertCell(CellValueRecordInterface cell)
void | RowRecordsAggregate.insertCell(CellValueRecordInterface cvRec)
void | ValueRecordsAggregate.removeCell(CellValueRecordInterface cell)
void | RowRecordsAggregate.removeCell(CellValueRecordInterface cvRec)

Uses of CellValueRecordInterface in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return CellValueRecordInterface
protected  CellValueRecordInterface HSSFCell.getCellValueRecord()
Should only be used by HSSFSheet and friends.

Constructors in org.apache.poi.hssf.usermodel with parameters of type CellValueRecordInterface
HSSFCell(HSSFWorkbook book, HSSFSheet sheet, CellValueRecordInterface cval)
Creates an HSSFCell from a CellValueRecordInterface.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CFHeaderRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CFHeaderRecord

Packages that use CFHeaderRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of CFHeaderRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return CFHeaderRecord
 CFHeaderRecord CFRecordsAggregate.getHeader()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

No usage of org.apache.poi.hssf.record.CFRuleRecord.ComparisonOperator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CFRuleRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CFRuleRecord

Packages that use CFRuleRecord
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of CFRuleRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return CFRuleRecord
static CFRuleRecord | CFRuleRecord.create(HSSFSheet sheet, byte comparisonOperation, java.lang.String formulaText1, java.lang.String formulaText2) Creates a new comparison operation rule
static CFRuleRecord | CFRuleRecord.create(HSSFSheet sheet, java.lang.String formulaText) Creates a new comparison operation rule

Uses of CFRuleRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return CFRuleRecord
 CFRuleRecord CFRecordsAggregate.getRule(int idx)

Methods in org.apache.poi.hssf.record.aggregates with parameters of type CFRuleRecord
void | CFRecordsAggregate.addRule(CFRuleRecord r)
void | CFRecordsAggregate.setRule(int idx, CFRuleRecord r)

Constructors in org.apache.poi.hssf.record.aggregates with parameters of type CFRuleRecord
CFRecordsAggregate(CellRangeAddress[] regions, CFRuleRecord[] rules)

Uses of CFRuleRecord in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type CFRuleRecord
HSSFBorderFormatting(CFRuleRecord cfRuleRecord)
HSSFFontFormatting(CFRuleRecord cfRuleRecord)
HSSFPatternFormatting(CFRuleRecord cfRuleRecord)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CodepageRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CodepageRecord

No usage of org.apache.poi.hssf.record.CodepageRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ColumnInfoRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ColumnInfoRecord

Packages that use ColumnInfoRecord
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of ColumnInfoRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type ColumnInfoRecord
boolean | ColumnInfoRecord.formatMatches(ColumnInfoRecord other)
boolean | ColumnInfoRecord.isAdjacentBefore(ColumnInfoRecord other)

Uses of ColumnInfoRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return ColumnInfoRecord
 ColumnInfoRecord ColumnInfoRecordsAggregate.findColumnInfo(int columnIndex)
Finds the ColumnInfoRecord which contains the specified columnIndex

Methods in org.apache.poi.hssf.record.aggregates with parameters of type ColumnInfoRecord
 void ColumnInfoRecordsAggregate.insertColumn(ColumnInfoRecord col)
Inserts a column into the aggregate (at the end of the list).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CommonObjectDataSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CommonObjectDataSubRecord

No usage of org.apache.poi.hssf.record.CommonObjectDataSubRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ContinueRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ContinueRecord

No usage of org.apache.poi.hssf.record.ContinueRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CountryRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CountryRecord

No usage of org.apache.poi.hssf.record.CountryRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CRNCountRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CRNCountRecord

No usage of org.apache.poi.hssf.record.CRNCountRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.CRNRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.CRNRecord

No usage of org.apache.poi.hssf.record.CRNRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DateWindow1904Record

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DateWindow1904Record

No usage of org.apache.poi.hssf.record.DateWindow1904Record

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DBCellRecord.Builder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DBCellRecord.Builder

No usage of org.apache.poi.hssf.record.DBCellRecord.Builder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DBCellRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DBCellRecord

Packages that use DBCellRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of DBCellRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return DBCellRecord
 DBCellRecord DBCellRecord.Builder.build(int rowOffset)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DConRefRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DConRefRecord

No usage of org.apache.poi.hssf.record.DConRefRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DefaultColWidthRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DefaultColWidthRecord

Packages that use DefaultColWidthRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of DefaultColWidthRecord in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as DefaultColWidthRecord
protected  DefaultColWidthRecord InternalSheet.defaultcolwidth

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DefaultRowHeightRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DefaultRowHeightRecord

Packages that use DefaultRowHeightRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of DefaultRowHeightRecord in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as DefaultRowHeightRecord
protected  DefaultRowHeightRecord InternalSheet.defaultrowheight

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DeltaRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DeltaRecord

No usage of org.apache.poi.hssf.record.DeltaRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DimensionsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DimensionsRecord

Packages that use DimensionsRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of DimensionsRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return DimensionsRecord
 DimensionsRecord RowRecordsAggregate.createDimensions()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DrawingGroupRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DrawingGroupRecord

No usage of org.apache.poi.hssf.record.DrawingGroupRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DrawingRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DrawingRecord

Packages that use DrawingRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of DrawingRecord in org.apache.poi.hssf.record

Constructors in org.apache.poi.hssf.record with parameters of type DrawingRecord
DrawingRecordForBiffViewer(DrawingRecord r)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DrawingRecordForBiffViewer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DrawingRecordForBiffViewer

No usage of org.apache.poi.hssf.record.DrawingRecordForBiffViewer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DrawingSelectionRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DrawingSelectionRecord

No usage of org.apache.poi.hssf.record.DrawingSelectionRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DSFRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DSFRecord

No usage of org.apache.poi.hssf.record.DSFRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DVALRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DVALRecord

No usage of org.apache.poi.hssf.record.DVALRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.DVRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.DVRecord

Packages that use DVRecord
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of DVRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type DVRecord
 void DataValidityTable.addDataValidation(DVRecord dvRecord)

Uses of DVRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return DVRecord
 DVRecord HSSFDataValidation.createDVRecord(HSSFSheet sheet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.EmbeddedObjectRefSubRecord

Packages that use EmbeddedObjectRefSubRecord
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of EmbeddedObjectRefSubRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return EmbeddedObjectRefSubRecord
protected  EmbeddedObjectRefSubRecord HSSFObjectData.findObjectRecord()
Finds the EmbeddedObjectRefSubRecord, or throws an Exception if there wasn't one

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.EndSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.EndSubRecord

No usage of org.apache.poi.hssf.record.EndSubRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.EOFRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.EOFRecord

Packages that use EOFRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of EOFRecord in org.apache.poi.hssf.record

Fields in org.apache.poi.hssf.record declared as EOFRecord
static EOFRecord EOFRecord.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.EscherAggregate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.EscherAggregate

Packages that use EscherAggregate
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of EscherAggregate in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return EscherAggregate
static EscherAggregate EscherAggregate.createAggregate(java.util.List records, int locFirstDrawingRecord, DrawingManager2 drawingManager)
Collapses the drawing records into an aggregate.

Uses of EscherAggregate in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return EscherAggregate
protected EscherAggregate | HSSFPatriarch._getBoundAggregate() Returns the aggregate escher record we're bound to
EscherAggregate | HSSFSheet.getDrawingEscherAggregate() Returns the agregate escher records for this sheet, it there is one.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ExtendedFormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ExtendedFormatRecord

Packages that use ExtendedFormatRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of ExtendedFormatRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return ExtendedFormatRecord
ExtendedFormatRecord | InternalWorkbook.createCellXF() creates a new Cell-type Extneded Format Record and adds it to the end of ExtendedFormatRecords collection
ExtendedFormatRecord | InternalWorkbook.getExFormatAt(int index) gets the ExtendedFormatRecord at the given 0-based index

Methods in org.apache.poi.hssf.model with parameters of type ExtendedFormatRecord
 void InternalWorkbook.removeExFormatRecord(ExtendedFormatRecord rec)
Removes the given ExtendedFormatRecord record from the file's list.

Uses of ExtendedFormatRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type ExtendedFormatRecord
 void ExtendedFormatRecord.cloneStyleFrom(ExtendedFormatRecord source)
Clones all the style information from another ExtendedFormatRecord, onto this one.

Uses of ExtendedFormatRecord in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type ExtendedFormatRecord
HSSFCellStyle(short index, ExtendedFormatRecord rec, HSSFWorkbook workbook)
Creates new HSSFCellStyle why would you want to do this??
HSSFCellStyle(short index, ExtendedFormatRecord rec, InternalWorkbook workbook)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ExternalNameRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ExternalNameRecord

No usage of org.apache.poi.hssf.record.ExternalNameRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ExternSheetRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ExternSheetRecord

Packages that use ExternSheetRecord
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.

Uses of ExternSheetRecord in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel that return ExternSheetRecord
 ExternSheetRecord[] EventWorkbookBuilder.SheetRecordCollectingListener.getExternSheetRecords()

Methods in org.apache.poi.hssf.eventusermodel with parameters of type ExternSheetRecord
static InternalWorkbook | EventWorkbookBuilder.createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds) Creates a stub workbook from the supplied records, suitable for use with the HSSFFormulaParser
static InternalWorkbook | EventWorkbookBuilder.createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds, SSTRecord sst) Creates a stub Workbook from the supplied records, suitable for use with the HSSFFormulaParser

Uses of ExternSheetRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return ExternSheetRecord
static ExternSheetRecord ExternSheetRecord.combine(ExternSheetRecord[] esrs)

Methods in org.apache.poi.hssf.record with parameters of type ExternSheetRecord
static ExternSheetRecord ExternSheetRecord.combine(ExternSheetRecord[] esrs)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ExtSSTRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ExtSSTRecord

Packages that use ExtSSTRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of ExtSSTRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return ExtSSTRecord
 ExtSSTRecord SSTRecord.createExtSSTRecord(int sstOffset)
Creates an extended string record based on the current contents of the current SST record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ExtSSTRecord.InfoSubRecord

Packages that use ExtSSTRecord.InfoSubRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of ExtSSTRecord.InfoSubRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return ExtSSTRecord.InfoSubRecord
protected  ExtSSTRecord.InfoSubRecord[] ExtSSTRecord.getInfoSubRecords()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FeatHdrRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FeatHdrRecord

No usage of org.apache.poi.hssf.record.FeatHdrRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FeatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FeatRecord

No usage of org.apache.poi.hssf.record.FeatRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FilePassRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FilePassRecord

No usage of org.apache.poi.hssf.record.FilePassRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FileSharingRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FileSharingRecord

Packages that use FileSharingRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of FileSharingRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return FileSharingRecord
 FileSharingRecord InternalWorkbook.getFileSharing()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FnGroupCountRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FnGroupCountRecord

No usage of org.apache.poi.hssf.record.FnGroupCountRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FontRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FontRecord

Packages that use FontRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of FontRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return FontRecord
FontRecord | InternalWorkbook.createNewFont() creates a new font record and adds it to the "font table".
FontRecord | InternalWorkbook.getFontRecordAt(int idx) gets the font record at the given index in the font table.

Methods in org.apache.poi.hssf.model with parameters of type FontRecord
int | InternalWorkbook.getFontIndex(FontRecord font) Retrieves the index of the given font
void | InternalWorkbook.removeFontRecord(FontRecord rec) Removes the given font record from the file's list.

Uses of FontRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type FontRecord
 void FontRecord.cloneStyleFrom(FontRecord source)
Clones all the font style information from another FontRecord, onto this one.
 boolean FontRecord.sameProperties(FontRecord other)
Does this FontRecord have all the same font properties as the supplied FontRecord? Note that Object.equals(Object) will check for exact objects, while this will check for exact contents, because normally the font record's position makes a big difference too.

Uses of FontRecord in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type FontRecord
HSSFFont(short index, FontRecord rec)
Creates a new instance of HSSFFont

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FooterRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FooterRecord

Packages that use FooterRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of FooterRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return FooterRecord
 FooterRecord PageSettingsBlock.getFooter()
Returns the FooterRecord.

Methods in org.apache.poi.hssf.record.aggregates with parameters of type FooterRecord
 void PageSettingsBlock.setFooter(FooterRecord newFooter)
Sets the FooterRecord.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FormatRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FormatRecord

Packages that use FormatRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of FormatRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return types with arguments of type FormatRecord
 java.util.List<FormatRecord> InternalWorkbook.getFormats()
Returns the list of FormatRecords in the workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FormulaRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FormulaRecord

Packages that use FormulaRecord
org.apache.poi.hssf.dev | DEV package serves two purposes.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of FormulaRecord in org.apache.poi.hssf.dev

Methods in org.apache.poi.hssf.dev with parameters of type FormulaRecord
 void FormulaViewer.parseFormulaRecord(FormulaRecord record)
Method parseFormulaRecord

Uses of FormulaRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type FormulaRecord
 Ptg[] SharedFormulaRecord.getFormulaTokens(FormulaRecord formula)

Uses of FormulaRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return FormulaRecord
 FormulaRecord FormulaRecordAggregate.getFormulaRecord()

Constructors in org.apache.poi.hssf.record.aggregates with parameters of type FormulaRecord
FormulaRecordAggregate(FormulaRecord formulaRec, StringRecord stringRec, SharedValueManager svm)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.FtCblsSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.FtCblsSubRecord

No usage of org.apache.poi.hssf.record.FtCblsSubRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.GridsetRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.GridsetRecord

Packages that use GridsetRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of GridsetRecord in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as GridsetRecord
protected  GridsetRecord InternalSheet.gridset

Methods in org.apache.poi.hssf.model that return GridsetRecord
 GridsetRecord InternalSheet.getGridsetRecord()
Gets the gridset record for this sheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.GroupMarkerSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.GroupMarkerSubRecord

No usage of org.apache.poi.hssf.record.GroupMarkerSubRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.GutsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.GutsRecord

No usage of org.apache.poi.hssf.record.GutsRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.HCenterRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.HCenterRecord

Packages that use HCenterRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of HCenterRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return HCenterRecord
 HCenterRecord PageSettingsBlock.getHCenter()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.HeaderFooterBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.HeaderFooterBase

Packages that use HeaderFooterBase
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of HeaderFooterBase in org.apache.poi.hssf.record

Subclasses of HeaderFooterBase in org.apache.poi.hssf.record
class | FooterRecord Title: Footer Record (0x0015) Description: Specifies the footer for a sheet
class | HeaderRecord Title: Header Record

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.HeaderFooterRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.HeaderFooterRecord

Packages that use HeaderFooterRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of HeaderFooterRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type HeaderFooterRecord
 void PageSettingsBlock.addLateHeaderFooter(HeaderFooterRecord rec)
HEADERFOOTER is new in 2007.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.HeaderRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.HeaderRecord

Packages that use HeaderRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of HeaderRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return HeaderRecord
 HeaderRecord PageSettingsBlock.getHeader()
Returns the HeaderRecord.

Methods in org.apache.poi.hssf.record.aggregates with parameters of type HeaderRecord
 void PageSettingsBlock.setHeader(HeaderRecord newHeader)
Sets the HeaderRecord.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.HideObjRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.HideObjRecord

No usage of org.apache.poi.hssf.record.HideObjRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.HorizontalPageBreakRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.HorizontalPageBreakRecord

No usage of org.apache.poi.hssf.record.HorizontalPageBreakRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.HyperlinkRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.HyperlinkRecord

Packages that use HyperlinkRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HyperlinkRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return types with arguments of type HyperlinkRecord
 java.util.List<HyperlinkRecord> InternalWorkbook.getHyperlinks()

Uses of HyperlinkRecord in org.apache.poi.hssf.usermodel

Fields in org.apache.poi.hssf.usermodel declared as HyperlinkRecord
protected  HyperlinkRecord HSSFHyperlink.record
Low-level record object that stores the actual hyperlink data

Constructors in org.apache.poi.hssf.usermodel with parameters of type HyperlinkRecord
HSSFHyperlink(HyperlinkRecord record)
Initialize the hyperlink by a HyperlinkRecord record

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.IndexRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.IndexRecord

Packages that use IndexRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of IndexRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return IndexRecord
 IndexRecord RowRecordsAggregate.createIndexRecord(int indexRecordOffset, int sizeOfInitialSheetRecords)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.InterfaceEndRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.InterfaceEndRecord

Packages that use InterfaceEndRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of InterfaceEndRecord in org.apache.poi.hssf.record

Fields in org.apache.poi.hssf.record declared as InterfaceEndRecord
static InterfaceEndRecord InterfaceEndRecord.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.InterfaceHdrRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.InterfaceHdrRecord

No usage of org.apache.poi.hssf.record.InterfaceHdrRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.IterationRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.IterationRecord

No usage of org.apache.poi.hssf.record.IterationRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.LabelRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.LabelRecord

No usage of org.apache.poi.hssf.record.LabelRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.LabelSSTRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.LabelSSTRecord

No usage of org.apache.poi.hssf.record.LabelSSTRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.LbsDataSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.LbsDataSubRecord

Packages that use LbsDataSubRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of LbsDataSubRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return LbsDataSubRecord
static LbsDataSubRecord LbsDataSubRecord.newAutoFilterInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

No usage of org.apache.poi.hssf.record.LbsDataSubRecord.LbsDropData

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.LeftMarginRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.LeftMarginRecord

No usage of org.apache.poi.hssf.record.LeftMarginRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.record.Margin

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.record.Margin

Packages that use Margin
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of Margin in org.apache.poi.hssf.record

Classes in org.apache.poi.hssf.record that implement Margin
class | BottomMarginRecord Record for the bottom margin.
class | LeftMarginRecord Record for the left margin.
class | RightMarginRecord Record for the right margin.
class | TopMarginRecord Record for the top margin.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.MergeCellsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.MergeCellsRecord

Packages that use MergeCellsRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of MergeCellsRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return MergeCellsRecord
 MergeCellsRecord[] RowBlocksReader.getLooseMergedCells()
Some unconventional apps place MergeCellsRecords within the row block.

Uses of MergeCellsRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type MergeCellsRecord
 void MergedCellsTable.addRecords(MergeCellsRecord[] mcrs)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.MMSRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.MMSRecord

No usage of org.apache.poi.hssf.record.MMSRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.MulBlankRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.MulBlankRecord

Packages that use MulBlankRecord
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of MulBlankRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type MulBlankRecord
static BlankRecord[] RecordFactory.convertBlankRecords(MulBlankRecord mbk)
Converts a MulBlankRecord into an equivalent array of BlankRecords

Uses of MulBlankRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type MulBlankRecord
 void ValueRecordsAggregate.addMultipleBlanks(MulBlankRecord mbr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.MulRKRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.MulRKRecord

Packages that use MulRKRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of MulRKRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type MulRKRecord
static NumberRecord[] RecordFactory.convertRKRecords(MulRKRecord mrk)
Converts a MulRKRecord into an equivalent array of NumberRecords

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.NameCommentRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.NameCommentRecord

Packages that use NameCommentRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of NameCommentRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return NameCommentRecord
 NameCommentRecord InternalWorkbook.getNameCommentRecord(NameRecord nameRecord)
gets the name comment record

Methods in org.apache.poi.hssf.model with parameters of type NameCommentRecord
 void InternalWorkbook.updateNameCommentRecordCache(NameCommentRecord commentRecord)
If a NameCommentRecord is added or the name it references is renamed, then this will update the lookup cache for it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.NameRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.NameRecord

Packages that use NameRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of NameRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return NameRecord
NameRecord | InternalWorkbook.addName(NameRecord name) creates new name
NameRecord | InternalWorkbook.cloneFilter(int filterDbNameIndex, int newSheetIndex)
NameRecord | InternalWorkbook.createBuiltInName(byte builtInName, int sheetNumber) Generates a NameRecord to represent a built-in region
NameRecord | InternalWorkbook.createName() creates new name
NameRecord | InternalWorkbook.getNameRecord(int index) gets the name record
NameRecord | InternalWorkbook.getSpecificBuiltinRecord(byte name, int sheetNumber) Retrieves the Builtin NameRecord that matches the name and index There shouldn't be too many names to make the sequential search too slow

Methods in org.apache.poi.hssf.model with parameters of type NameRecord
NameRecord | InternalWorkbook.addName(NameRecord name) creates new name
NameCommentRecord | InternalWorkbook.getNameCommentRecord(NameRecord nameRecord) gets the name comment record

Uses of NameRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return NameRecord
 NameRecord HSSFWorkbook.getNameRecord(int nameIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.NoteRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.NoteRecord

Packages that use NoteRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of NoteRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return NoteRecord
NoteRecord | CommentShape.getNoteRecord() Return the NoteRecord holding the comment attributes
NoteRecord[] | InternalSheet.getNoteRecords() Get the NoteRecords (related to cell comments) for this sheet

Uses of NoteRecord in org.apache.poi.hssf.record

Fields in org.apache.poi.hssf.record declared as NoteRecord
static NoteRecord[] NoteRecord.EMPTY_ARRAY

Uses of NoteRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return NoteRecord
protected  NoteRecord HSSFComment.getNoteRecord()
Returns the underlying Note record

Constructors in org.apache.poi.hssf.usermodel with parameters of type NoteRecord
HSSFComment(NoteRecord note, TextObjectRecord txo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.NoteStructureSubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.NoteStructureSubRecord

No usage of org.apache.poi.hssf.record.NoteStructureSubRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.NumberRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.NumberRecord

Packages that use NumberRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of NumberRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return NumberRecord
static NumberRecord[] | RecordFactory.convertRKRecords(MulRKRecord mrk) Converts a MulRKRecord into an equivalent array of NumberRecords
static NumberRecord | RecordFactory.convertToNumberRecord(RKRecord rk) RK record is a slightly smaller alternative to NumberRecord POI likes NumberRecord better

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ObjectProtectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ObjectProtectRecord

No usage of org.apache.poi.hssf.record.ObjectProtectRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ObjRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ObjRecord

Packages that use ObjRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of ObjRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return ObjRecord
ObjRecord | TextboxShape.getObjRecord()
ObjRecord | SimpleFilledShape.getObjRecord()
ObjRecord | PolygonShape.getObjRecord()
ObjRecord | PictureShape.getObjRecord()
ObjRecord | LineShape.getObjRecord()
ObjRecord | ComboboxShape.getObjRecord()
abstract ObjRecord | AbstractShape.getObjRecord()

Uses of ObjRecord in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type ObjRecord
HSSFObjectData(ObjRecord record, DirectoryEntry root)
Constructs object data by wrapping a lower level object record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PageBreakRecord.Break

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PageBreakRecord.Break

Packages that use PageBreakRecord.Break
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of PageBreakRecord.Break in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return PageBreakRecord.Break
 PageBreakRecord.Break PageBreakRecord.getBreak(int main)
Retrieves the region at the row/column indicated

Methods in org.apache.poi.hssf.record that return types with arguments of type PageBreakRecord.Break
 java.util.Iterator<PageBreakRecord.Break> PageBreakRecord.getBreaksIterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PageBreakRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PageBreakRecord

Packages that use PageBreakRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of PageBreakRecord in org.apache.poi.hssf.record

Subclasses of PageBreakRecord in org.apache.poi.hssf.record
class | HorizontalPageBreakRecord HorizontalPageBreak (0x001B) record that stores page breaks at rows
class | VerticalPageBreakRecord VerticalPageBreak (0x001A) record that stores page breaks at columns

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PaletteRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PaletteRecord

Packages that use PaletteRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of PaletteRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return PaletteRecord
 PaletteRecord InternalWorkbook.getCustomPalette()
Returns the custom palette in use for this workbook; if a custom palette record does not exist, then it is created.

Uses of PaletteRecord in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type PaletteRecord
HSSFPalette(PaletteRecord palette)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PaneRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PaneRecord

No usage of org.apache.poi.hssf.record.PaneRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PasswordRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PasswordRecord

Packages that use PasswordRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of PasswordRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return PasswordRecord
 PasswordRecord WorksheetProtectionBlock.getPasswordRecord()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PasswordRev4Record

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PasswordRev4Record

No usage of org.apache.poi.hssf.record.PasswordRev4Record

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PrecisionRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PrecisionRecord

No usage of org.apache.poi.hssf.record.PrecisionRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PrintGridlinesRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PrintGridlinesRecord

Packages that use PrintGridlinesRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of PrintGridlinesRecord in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as PrintGridlinesRecord
protected  PrintGridlinesRecord InternalSheet.printGridlines

Methods in org.apache.poi.hssf.model that return PrintGridlinesRecord
 PrintGridlinesRecord InternalSheet.getPrintGridlines()
Returns the PrintGridlinesRecord.

Methods in org.apache.poi.hssf.model with parameters of type PrintGridlinesRecord
 void InternalSheet.setPrintGridlines(PrintGridlinesRecord newPrintGridlines)
Sets the PrintGridlinesRecord.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PrintHeadersRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PrintHeadersRecord

No usage of org.apache.poi.hssf.record.PrintHeadersRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.PrintSetupRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.PrintSetupRecord

Packages that use PrintSetupRecord
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of PrintSetupRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return PrintSetupRecord
 PrintSetupRecord PageSettingsBlock.getPrintSetup()
Returns the PrintSetupRecord.

Methods in org.apache.poi.hssf.record.aggregates with parameters of type PrintSetupRecord
 void PageSettingsBlock.setPrintSetup(PrintSetupRecord newPrintSetup)
Sets the PrintSetupRecord.

Uses of PrintSetupRecord in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type PrintSetupRecord
HSSFPrintSetup(PrintSetupRecord printSetupRecord)
Constructor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ProtectionRev4Record

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ProtectionRev4Record

No usage of org.apache.poi.hssf.record.ProtectionRev4Record

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ProtectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ProtectRecord

No usage of org.apache.poi.hssf.record.ProtectRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RecalcIdRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RecalcIdRecord

Packages that use RecalcIdRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of RecalcIdRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return RecalcIdRecord
 RecalcIdRecord InternalWorkbook.getRecalcId()
Get or create RecalcIdRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.Record

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.Record

Packages that use Record
org.apache.poi.hssf.dev | DEV package serves two purposes.
org.apache.poi.hssf.eventmodel |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.eventusermodel.dummyrecord |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.pivottable |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of Record in org.apache.poi.hssf.dev

Methods in org.apache.poi.hssf.dev that return Record
static Record[] BiffViewer.createRecords(java.io.InputStream is, java.io.PrintStream ps, org.apache.poi.hssf.dev.BiffViewer.BiffRecordListener recListener, boolean dumpInterpretedRecords)
Create an array of records from an input stream

Uses of Record in org.apache.poi.hssf.eventmodel

Methods in org.apache.poi.hssf.eventmodel with parameters of type Record
 boolean ERFListener.processRecord(Record rec)
Process a Record.

Uses of Record in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel with parameters of type Record
abstract short | AbortableHSSFListener.abortableProcessRecord(Record record) Process an HSSF Record.
void | MissingRecordAwareHSSFListener.processRecord(Record record)
protected short | HSSFRequest.processRecord(Record rec) Called by HSSFEventFactory, passes the Record to each listener associated with a record.sid.
void | HSSFListener.processRecord(Record record) process an HSSF Record.
void | FormatTrackingHSSFListener.processRecord(Record record) Process this record ourselves, and then pass it on to our child listener
void | EventWorkbookBuilder.SheetRecordCollectingListener.processRecord(Record record) Process this record ourselves, and then pass it on to our child listener
void | AbortableHSSFListener.processRecord(Record record) This method, inherited from HSSFListener is implemented as a stub.
void | FormatTrackingHSSFListener.processRecordInternally(Record record) Process the record ourselves, but do not pass it on to the child Listener.
void | EventWorkbookBuilder.SheetRecordCollectingListener.processRecordInternally(Record record) Process the record ourselves, but do not pass it on to the child Listener.

Uses of Record in org.apache.poi.hssf.eventusermodel.dummyrecord

Subclasses of Record in org.apache.poi.hssf.eventusermodel.dummyrecord
class | LastCellOfRowDummyRecord A dummy record to indicate that we've now had the last cell record for this row.
class | MissingCellDummyRecord A dummy record for when we're missing a cell in a row, but still want to trigger something
class | MissingRowDummyRecord A dummy record for when we're missing a row, but still want to trigger something

Uses of Record in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return Record
Record | InternalWorkbook.findFirstRecordBySid(short sid) Returns the first occurance of a record matching a particular sid.
Record | InternalSheet.findFirstRecordBySid(short sid) Returns the first occurrence of a record matching a particular sid.
Record | InternalWorkbook.findNextRecordBySid(short sid, int pos) Returns the next occurance of a record matching a particular sid.
Record | WorkbookRecordList.get(int i)
Record | RecordStream.getNext()

Methods in org.apache.poi.hssf.model that return types with arguments of type Record
java.util.List<Record> | WorkbookRecordList.getRecords()
java.util.List<Record> | InternalWorkbook.getRecords()
java.util.Iterator<Record> | WorkbookRecordList.iterator()
java.lang.Class<? extends Record> | RecordStream.peekNextClass()

Methods in org.apache.poi.hssf.model with parameters of type Record
 void WorkbookRecordList.add(int pos, Record r)

Method parameters in org.apache.poi.hssf.model with type arguments of type Record
static InternalWorkbook | InternalWorkbook.createWorkbook(java.util.List<Record> recs) read support for low level API.
void | WorkbookRecordList.setRecords(java.util.List<Record> records)

Constructor parameters in org.apache.poi.hssf.model with type arguments of type Record
RecordStream(java.util.List<Record> records, int startIx)
RecordStream(java.util.List<Record> inputList, int startIndex, int endIx)
Creates a RecordStream bounded by startIndex and endIndex

Uses of Record in org.apache.poi.hssf.record

Subclasses of Record in org.apache.poi.hssf.record
 class AbstractEscherHolderRecord
The escher container record is used to hold escher records.
 class ArrayRecord
ARRAY (0x0221)

Treated in a similar way to SharedFormulaRecord

 class AutoFilterInfoRecord
The AutoFilterInfo record specifies the number of columns that have AutoFilter enabled and indicates the beginning of the collection of AutoFilter records.
 class BackupRecord
Title: Backup Record
 class BlankRecord
Title: Blank cell record (0x0201)
 class BOFRecord
Title: Beginning Of File (0x0809)
 class BookBoolRecord
Title: Save External Links record (BookBool)
 class BoolErrRecord
Creates new BoolErrRecord.
 class BottomMarginRecord
Record for the bottom margin.
 class BoundSheetRecord
Title: Bound Sheet Record (aka BundleSheet) (0x0085)
 class CalcCountRecord
Title: Calc Count Record Description: Specifies the maximum times the gui should perform a formula recalculation.
 class CalcModeRecord
Title: Calc Mode Record
 class CellRecord
Base class for all cell value records (implementors of CellValueRecordInterface).
 class CFHeaderRecord
Conditional Formatting Header record CFHEADER (0x01B0)
 class CFRuleRecord
Conditional Formatting Rule Record (0x01B1).
 class CodepageRecord
Title: Codepage Record
 class ColumnInfoRecord
Title: COLINFO Record (0x007D)

Description: Defines with width and formatting for a range of columns

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class ContinueRecord
Title: Continue Record(0x003C) - Helper class used primarily for SST Records
 class CountryRecord
Title: Country Record (aka WIN.INI country)
 class CRNCountRecord
XCT - CRN Count
 class CRNRecord
Title: CRN(0x005A)

Description: This record stores the contents of an external cell or cell range

REFERENCE: OOO 5.23
 class DateWindow1904Record
Title: Date Window 1904 Flag record
 class DBCellRecord
Title: DBCell Record (0x00D7)

Description: Used by Excel and other MS apps to quickly find rows in the sheets.

 class DConRefRecord
DConRef records specify a range in a workbook (internal or external) that serves as a data source for pivot tables or data consolidation.
 class DefaultColWidthRecord
Title: Default Column Width Record (0x0055)
 class DefaultRowHeightRecord
Title: Default Row Height Record Description: Row height for rows with undefined or not explicitly defined heights.
 class DeltaRecord
Title: Delta Record (0x0010)

Description: controls the accuracy of the calculations

REFERENCE: PG 303 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class DimensionsRecord
Title: Dimensions Record
 class DrawingGroupRecord
 class DrawingRecord
DrawingRecord (0x00EC)
 class DrawingRecordForBiffViewer
This is purely for the biff viewer.
 class DrawingSelectionRecord
MsoDrawingSelection (0x00ED)

Reference: [MS-OGRAPH].pdf sec 2.4.69

 class DSFRecord
Title: Double Stream Flag Record (0x0161)

Description: tells if this is a double stream file.

 class DVALRecord
Title: DATAVALIDATIONS Record (0x01B2)

Description: used in data validation ; This record is the list header of all data validation records (0x01BE) in the current sheet.

 class DVRecord
Title: DATAVALIDATION Record (0x01BE)

Description: This record stores data validation settings and a list of cell ranges which contain these settings.

 class EOFRecord
End Of File record.
 class EscherAggregate
This class is used to aggregate the MSODRAWING and OBJ record combinations.
 class ExtendedFormatRecord
Title: Extended Format Record Description: Probably one of the more complex records.
 class ExternalNameRecord
EXTERNALNAME (0x0023)
 class ExternSheetRecord
EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

 class ExtSSTRecord
Title: Extended Static String Table (0x00FF)

Description: This record is used for a quick lookup into the SST record.

 class FeatHdrRecord
Title: FeatHdr (Feature Header) Record
 class FeatRecord
Title: Feat (Feature) Record
 class FilePassRecord
Title: File Pass Record (0x002F)

Description: Indicates that the record after this record are encrypted.

 class FileSharingRecord
Title: FILESHARING (0x005B)

Description: stores the encrypted readonly for a workbook (write protect) This functionality is accessed from the options dialog box available when performing 'Save As'.

REFERENCE: PG 314 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class FnGroupCountRecord
Title: Function Group Count Record
 class FontRecord
Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

 class FooterRecord
Title: Footer Record (0x0015)

Description: Specifies the footer for a sheet

 class FormatRecord
Title: Format Record (0x041E)

Description: describes a number format -- those goofy strings like $(#,###)

REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class FormulaRecord
Formula Record (0x0006).
 class GridsetRecord
Title: Gridset Record.
 class GutsRecord
Title: Guts Record
 class HCenterRecord
Title: HCenter record (0x0083)
 class HeaderFooterBase
Common header/footer base class
 class HeaderFooterRecord
The HEADERFOOTER record stores information added in Office Excel 2007 for headers/footers.
 class HeaderRecord
Title: Header Record
 class HideObjRecord
Title: Hide Object Record
 class HorizontalPageBreakRecord
HorizontalPageBreak (0x001B) record that stores page breaks at rows

 class HyperlinkRecord
The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format.
 class IndexRecord
Title: Index Record (0x020B)

Description: Occurs right after BOF, tells you where the DBCELL records are for a sheet Important for locating cells

NOT USED IN THIS RELEASE REFERENCE: PG 323 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class InterfaceEndRecord
Title: Interface End Record (0x00E2)
 class InterfaceHdrRecord
Title: Interface Header Record (0x00E1)
 class IterationRecord
Title: Iteration Record (0x0011)

Description: Tells whether to iterate over forumla calculations or not (if a formula is dependant upon another formula's result) (odd feature for something that can only have 32 elements in a formula!)

 class LabelRecord
Label Record (0x0204) - read only support for strings stored directly in the cell..
 class LabelSSTRecord
Title: Label SST Record
 class LeftMarginRecord
Record for the left margin.
 class MergeCellsRecord
Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.
 class MMSRecord
Title: MMS Record
 class MulBlankRecord
Title: Multiple Blank cell record(0x00BE)

Description: Represents a set of columns in a row with no value but with styling.

 class MulRKRecord
MULRK (0x00BD)

Used to store multiple RK numbers on a row.

 class NameCommentRecord
Title: NAMECMT Record (0x0894)

Description: Defines a comment associated with a specified name.

 class NameRecord
Title: DEFINEDNAME Record (0x0018)

Description: Defines a named range within a workbook.

 class NoteRecord
NOTE: Comment Associated with a Cell (0x001C)
 class NumberRecord
NUMBER (0x0203) Contains a numeric cell value.
 class ObjectProtectRecord
Title: Object Protect Record
 class ObjRecord
OBJRECORD (0x005D)

The obj record is used to hold various graphic objects and controls.

 class PageBreakRecord
Record that contains the functionality page breaks (horizontal and vertical)
 class PaletteRecord
PaletteRecord (0x0092) - Supports custom palettes.
 class PaneRecord
Describes the frozen and unfozen panes.
 class PasswordRecord
Title: Password Record (0x0013)

Description: stores the encrypted password for a sheet or workbook (HSSF doesn't support encryption) REFERENCE: PG 371 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class PasswordRev4Record
Title: Protection Revision 4 password Record (0x01BC)

Description: Stores the (2 byte??!!) encrypted password for a shared workbook

REFERENCE: PG 374 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class PrecisionRecord
Title: Precision Record
 class PrintGridlinesRecord
Title: Print Gridlines Record
 class PrintHeadersRecord
Title: Print Headers Record
 class PrintSetupRecord
Title: PAGESETUP (0x00A1)

Description: Stores print setup options -- bogus for HSSF (and marked as such)

REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214
 class ProtectionRev4Record
Title: Protection Revision 4 Record (0x01AF)

Description: describes whether this is a protected shared/tracked workbook

REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class ProtectRecord
Title: Protect Record (0x0012)

Description: defines whether a sheet or workbook is protected (HSSF DOES NOT SUPPORT ENCRYPTION)

HSSF now supports the simple "protected" sheets (where they are not encrypted and open office et al ignore the password record entirely).

 class RecalcIdRecord
Title: Recalc Id Record (0x01C1)

Description: This record contains an ID that marks when a worksheet was last recalculated.

 class RefModeRecord
Title: RefMode Record
 class RefreshAllRecord
Title: Refresh All Record (0x01B7)

Description: Flag whether to refresh all external data when loading a sheet.

 class RightMarginRecord
Record for the right margin.
 class RKRecord
Title: RK Record (0x027E)

Description: An internal 32 bit number with the two most significant bits storing the type.

 class RowRecord
Title: Row Record (0x0208)

Description: stores the row information for the sheet.

 class SaveRecalcRecord
Title: Save Recalc Record
 class ScenarioProtectRecord
Title: Scenario Protect Record
 class SCLRecord
Specifies the window's zoom magnification.
 class SelectionRecord
Title: Selection Record (0x001D)
 class SharedFormulaRecord
Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
 class SharedValueRecordBase
Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.
 class SSTRecord
Title: Static String Table Record (0x00FC)

Description: This holds all the strings for LabelSSTRecords.

 class StandardRecord
Subclasses of this class (the majority of BIFF records) are non-continuable.
 class StringRecord
STRING (0x0207)

Stores the cached result of a text formula

 class StyleRecord
Title: Style Record (0x0293)

Description: Describes a builtin to the gui or user defined style

 class SupBookRecord
Title: Sup Book - EXTERNALBOOK (0x01AE)

Description: A External Workbook Description (Supplemental Book) Its only a dummy record for making new ExternSheet Record

 class TabIdRecord
Title: Sheet Tab Index Array Record (0x013D)

Description: Contains an array of sheet id's.

 class TableRecord
DATATABLE (0x0236)

TableRecord - The record specifies a data table.

 class TableStylesRecord
TABLESTYLES (0x088E)
 class TextObjectRecord
The TXO record (0x01B6) is used to define the properties of a text box.
 class TopMarginRecord
Record for the top margin.
 class UncalcedRecord
Title: Uncalced Record
 class UnknownRecord
Title: Unknown Record (for debugging)

Description: Unknown record just tells you the sid so you can figure out what records you are missing.

 class UserSViewBegin
The UserSViewBegin record specifies settings for a custom view associated with the sheet.
 class UserSViewEnd
The UserSViewEnd record marks the end of the settings for a custom view associated with the sheet
 class UseSelFSRecord
Title: USESELFS (0x0160) - Use Natural Language Formulas Flag

Description: Tells the GUI if this was written by something that can use "natural language" formulas.

 class VCenterRecord
Title: VCenter record
 class VerticalPageBreakRecord
VerticalPageBreak (0x001A) record that stores page breaks at columns
 class WindowOneRecord
Title: Window1 Record
 class WindowProtectRecord
Title: Window Protect Record (0x0019)

Description: flags whether workbook windows are protected

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class WindowTwoRecord
Title: Window Two Record
 class WriteAccessRecord
Title: Write Access Record (0x005C)

Description: Stores the username of that who owns the spreadsheet generator (on unix the user's login, on Windoze its the name you typed when you installed the thing)

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

 class WriteProtectRecord
Title: Write Protect Record
 class WSBoolRecord
Title: WSBOOL (0x0081) (called SHEETPR in OOO doc)

Description: stores workbook settings (aka its a big "everything we didn't put somewhere else")

Methods in org.apache.poi.hssf.record that return Record
Record | Record.cloneViaReserialise() Clone the current record, via a call to serialize it, and another to create a new record from the bytes.
static Record | InterfaceEndRecord.create(RecordInputStream in)
static Record[] | RecordFactory.createRecord(RecordInputStream in) create a record, if there are MUL records than multiple records are returned digested into the non-mul form.
static Record | RecordFactory.createSingleRecord(RecordInputStream in)
Record | RecordFactoryInputStream.nextRecord() Returns the next (complete) record from the stream, or null if there are no more.

Methods in org.apache.poi.hssf.record that return types with arguments of type Record
static java.util.List<Record> | RecordFactory.createRecords(java.io.InputStream in) Create an array of records from an input stream
static java.lang.Class<? extends Record> | RecordFactory.getRecordClass(int sid) Debug / diagnosis method Gets the POI implementation class for a given sid.

Uses of Record in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type Record
void | RecordAggregate.RecordVisitor.visitRecord(Record r) Implementors may call non-mutating methods on Record r.
void | RecordAggregate.PositionTrackingVisitor.visitRecord(Record r)

Uses of Record in org.apache.poi.hssf.record.chart

Subclasses of Record in org.apache.poi.hssf.record.chart
class | AreaFormatRecord The area format record is used to define the colours and patterns for an area.
class | AreaRecord The area record is used to define a area chart.
class | AxisLineFormatRecord The axis line format record defines the axis type details.
class | AxisOptionsRecord The axis options record provides unit information and other various tidbits about the axis.
class | AxisParentRecord The axis size and location
class | AxisRecord The axis record defines the type of an axis.
class | AxisUsedRecord The number of axes used on a chart.
class | BarRecord The bar record is used to define a bar chart.
class | BeginRecord The begin record defines the start of a block of records for a (grpahing data object.
class | CategorySeriesAxisRecord This record refers to a category or series axis and is used to specify label/tickmark frequency.
class | CatLabRecord CATLAB - Category Labels (0x0856)
class | ChartEndBlockRecord ENDBLOCK - Chart Future Record Type End Block (0x0853)
class | ChartEndObjectRecord ENDOBJECT - Chart Future Record Type End Object (0x0855)
class | ChartFormatRecord Class ChartFormatRecord (0x1014) (As with all chart related records, documentation is lacking.
class | ChartFRTInfoRecord CHARTFRTINFO - Chart Future Record Type Info (0x0850)
class | ChartRecord CHART (0x1002) The chart record is used to define the location and size of a chart. Chart related records don't seem to be covered in either the OOO or the MS documentation.
class | ChartStartBlockRecord STARTBLOCK - Chart Future Record Type Start Block (0x0852)
class | ChartStartObjectRecord STARTOBJECT - Chart Future Record Type Start Object (0x0854)
class | ChartTitleFormatRecord CHARTTITLEFORMAT (0x1050) Describes the formatting runs associated with a chart title.
class | DataFormatRecord The data format record is used to index into a series.
class | DataLabelExtensionRecord DATALABEXT - Chart Data Label Extension (0x086A)
class | DatRecord The dat record is used to store options for the chart.
class | DefaultDataLabelTextPropertiesRecord The default data label text properties record identifies the text characteristics of the preceding text record.
class | EndRecord The end record defines the end of a block of records for a (Graphing) data object.
class | FontBasisRecord The font basis record stores various font metrics.
class | FontIndexRecord The font index record indexes into the font table for the text record.
class | FrameRecord The frame record indicates whether there is a border around the displayed text of a chart.
class | LegendRecord Defines a legend for a chart.
class | LineFormatRecord Describes a line format record.
class | LinkedDataRecord Describes a linked data record.
class | NumberFormatIndexRecord The number format index record indexes format table.
class | ObjectLinkRecord Links text to an object on the chart or identifies it as the title.
class | PlotAreaRecord preceeds and identifies a frame as belonging to the plot area.
class | PlotGrowthRecord The plot growth record specifies the scaling factors used when a font is scaled.
class | SeriesChartGroupIndexRecord The series chart group index record stores the index to the CHARTFORMAT record (0 based).
class | SeriesIndexRecord links a series to its position in the series list.
class | SeriesLabelsRecord The series label record defines the type of label associated with the data format record.
class | SeriesListRecord SERIESLIST (0x1016) The series list record defines the series displayed as an overlay to the main chart record. (As with all chart related records, documentation is lacking.
class | SeriesRecord The series record describes the overall data for a series.
class | SeriesTextRecord SERIESTEXT (0x100D)
class | SeriesToChartGroupRecord Indicates the chart-group index for a series.
class | SheetPropertiesRecord Describes a chart sheet properties record.
class | TextRecord The text record is used to define text stored on a chart.
class | TickRecord The Tick record defines how tick marks and label positioning/formatting
class | UnitsRecord The units record describes units.
class | ValueRangeRecord The value range record defines the range of the value axis.

Uses of Record in org.apache.poi.hssf.record.cont

Subclasses of Record in org.apache.poi.hssf.record.cont
 class ContinuableRecord
Common superclass of all records that can produce ContinueRecords while being serialized.

Uses of Record in org.apache.poi.hssf.record.pivottable

Subclasses of Record in org.apache.poi.hssf.record.pivottable
class | DataItemRecord SXDI - Data Item (0x00C5)
class | ExtendedPivotTableViewFieldsRecord SXVDEX - Extended PivotTable View Fields (0x0100)
class | PageItemRecord SXPI - Page Item (0x00B6)
class | StreamIDRecord SXIDSTM - Stream ID (0x00D5)
class | ViewDefinitionRecord SXVIEW - View Definition (0x00B0)
class | ViewFieldsRecord SXVD - View Fields (0x00B1)
class | ViewSourceRecord SXVS - View Source (0x00E3)

Uses of Record in org.apache.poi.hssf.usermodel

Method parameters in org.apache.poi.hssf.usermodel with type arguments of type Record
protected  void HSSFSheet.insertChartRecords(java.util.List<Record> records)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RecordBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RecordBase

Packages that use RecordBase
org.apache.poi.hssf.eventusermodel.dummyrecord |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.pivottable |

Uses of RecordBase in org.apache.poi.hssf.eventusermodel.dummyrecord

Subclasses of RecordBase in org.apache.poi.hssf.eventusermodel.dummyrecord
class | LastCellOfRowDummyRecord A dummy record to indicate that we've now had the last cell record for this row.
class | MissingCellDummyRecord A dummy record for when we're missing a cell in a row, but still want to trigger something
class | MissingRowDummyRecord A dummy record for when we're missing a row, but still want to trigger something

Uses of RecordBase in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return types with arguments of type RecordBase
 java.util.List<RecordBase> InternalSheet.getRecords()

Uses of RecordBase in org.apache.poi.hssf.record

Subclasses of RecordBase in org.apache.poi.hssf.record
 class AbstractEscherHolderRecord
The escher container record is used to hold escher records.
 class ArrayRecord
ARRAY (0x0221)

Treated in a similar way to SharedFormulaRecord

 class AutoFilterInfoRecord
The AutoFilterInfo record specifies the number of columns that have AutoFilter enabled and indicates the beginning of the collection of AutoFilter records.
 class BackupRecord
Title: Backup Record
 class BlankRecord
Title: Blank cell record (0x0201)
 class BOFRecord
Title: Beginning Of File (0x0809)
 class BookBoolRecord
Title: Save External Links record (BookBool)
 class BoolErrRecord
Creates new BoolErrRecord.
 class BottomMarginRecord
Record for the bottom margin.
 class BoundSheetRecord
Title: Bound Sheet Record (aka BundleSheet) (0x0085)
 class CalcCountRecord
Title: Calc Count Record Description: Specifies the maximum times the gui should perform a formula recalculation.
 class CalcModeRecord
Title: Calc Mode Record
 class CellRecord
Base class for all cell value records (implementors of CellValueRecordInterface).
 class CFHeaderRecord
Conditional Formatting Header record CFHEADER (0x01B0)
 class CFRuleRecord
Conditional Formatting Rule Record (0x01B1).
 class CodepageRecord
Title: Codepage Record
 class ColumnInfoRecord
Title: COLINFO Record (0x007D)

Description: Defines with width and formatting for a range of columns

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class ContinueRecord
Title: Continue Record(0x003C) - Helper class used primarily for SST Records
 class CountryRecord
Title: Country Record (aka WIN.INI country)
 class CRNCountRecord
XCT - CRN Count
 class CRNRecord
Title: CRN(0x005A)

Description: This record stores the contents of an external cell or cell range

REFERENCE: OOO 5.23
 class DateWindow1904Record
Title: Date Window 1904 Flag record
 class DBCellRecord
Title: DBCell Record (0x00D7)

Description: Used by Excel and other MS apps to quickly find rows in the sheets.

 class DConRefRecord
DConRef records specify a range in a workbook (internal or external) that serves as a data source for pivot tables or data consolidation.
 class DefaultColWidthRecord
Title: Default Column Width Record (0x0055)
 class DefaultRowHeightRecord
Title: Default Row Height Record Description: Row height for rows with undefined or not explicitly defined heights.
 class DeltaRecord
Title: Delta Record (0x0010)

Description: controls the accuracy of the calculations

REFERENCE: PG 303 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class DimensionsRecord
Title: Dimensions Record
 class DrawingGroupRecord
 class DrawingRecord
DrawingRecord (0x00EC)
 class DrawingRecordForBiffViewer
This is purely for the biff viewer.
 class DrawingSelectionRecord
MsoDrawingSelection (0x00ED)

Reference: [MS-OGRAPH].pdf sec 2.4.69

 class DSFRecord
Title: Double Stream Flag Record (0x0161)

Description: tells if this is a double stream file.

 class DVALRecord
Title: DATAVALIDATIONS Record (0x01B2)

Description: used in data validation ; This record is the list header of all data validation records (0x01BE) in the current sheet.

 class DVRecord
Title: DATAVALIDATION Record (0x01BE)

Description: This record stores data validation settings and a list of cell ranges which contain these settings.

 class EOFRecord
End Of File record.
 class EscherAggregate
This class is used to aggregate the MSODRAWING and OBJ record combinations.
 class ExtendedFormatRecord
Title: Extended Format Record Description: Probably one of the more complex records.
 class ExternalNameRecord
EXTERNALNAME (0x0023)
 class ExternSheetRecord
EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

 class ExtSSTRecord
Title: Extended Static String Table (0x00FF)

Description: This record is used for a quick lookup into the SST record.

 class FeatHdrRecord
Title: FeatHdr (Feature Header) Record
 class FeatRecord
Title: Feat (Feature) Record
 class FilePassRecord
Title: File Pass Record (0x002F)

Description: Indicates that the record after this record are encrypted.

 class FileSharingRecord
Title: FILESHARING (0x005B)

Description: stores the encrypted readonly for a workbook (write protect) This functionality is accessed from the options dialog box available when performing 'Save As'.

REFERENCE: PG 314 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class FnGroupCountRecord
Title: Function Group Count Record
 class FontRecord
Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

 class FooterRecord
Title: Footer Record (0x0015)

Description: Specifies the footer for a sheet

 class FormatRecord
Title: Format Record (0x041E)

Description: describes a number format -- those goofy strings like $(#,###)

REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class FormulaRecord
Formula Record (0x0006).
 class GridsetRecord
Title: Gridset Record.
 class GutsRecord
Title: Guts Record
 class HCenterRecord
Title: HCenter record (0x0083)
 class HeaderFooterBase
Common header/footer base class
 class HeaderFooterRecord
The HEADERFOOTER record stores information added in Office Excel 2007 for headers/footers.
 class HeaderRecord
Title: Header Record
 class HideObjRecord
Title: Hide Object Record
 class HorizontalPageBreakRecord
HorizontalPageBreak (0x001B) record that stores page breaks at rows

 class HyperlinkRecord
The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format.
 class IndexRecord
Title: Index Record (0x020B)

Description: Occurs right after BOF, tells you where the DBCELL records are for a sheet Important for locating cells

NOT USED IN THIS RELEASE REFERENCE: PG 323 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class InterfaceEndRecord
Title: Interface End Record (0x00E2)
 class InterfaceHdrRecord
Title: Interface Header Record (0x00E1)
 class IterationRecord
Title: Iteration Record (0x0011)

Description: Tells whether to iterate over forumla calculations or not (if a formula is dependant upon another formula's result) (odd feature for something that can only have 32 elements in a formula!)

 class LabelRecord
Label Record (0x0204) - read only support for strings stored directly in the cell..
 class LabelSSTRecord
Title: Label SST Record
 class LeftMarginRecord
Record for the left margin.
 class MergeCellsRecord
Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.
 class MMSRecord
Title: MMS Record
 class MulBlankRecord
Title: Multiple Blank cell record(0x00BE)

Description: Represents a set of columns in a row with no value but with styling.

 class MulRKRecord
MULRK (0x00BD)

Used to store multiple RK numbers on a row.

 class NameCommentRecord
Title: NAMECMT Record (0x0894)

Description: Defines a comment associated with a specified name.

 class NameRecord
Title: DEFINEDNAME Record (0x0018)

Description: Defines a named range within a workbook.

 class NoteRecord
NOTE: Comment Associated with a Cell (0x001C)
 class NumberRecord
NUMBER (0x0203) Contains a numeric cell value.
 class ObjectProtectRecord
Title: Object Protect Record
 class ObjRecord
OBJRECORD (0x005D)

The obj record is used to hold various graphic objects and controls.

 class PageBreakRecord
Record that contains the functionality page breaks (horizontal and vertical)
 class PaletteRecord
PaletteRecord (0x0092) - Supports custom palettes.
 class PaneRecord
Describes the frozen and unfozen panes.
 class PasswordRecord
Title: Password Record (0x0013)

Description: stores the encrypted password for a sheet or workbook (HSSF doesn't support encryption) REFERENCE: PG 371 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class PasswordRev4Record
Title: Protection Revision 4 password Record (0x01BC)

Description: Stores the (2 byte??!!) encrypted password for a shared workbook

REFERENCE: PG 374 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class PrecisionRecord
Title: Precision Record
 class PrintGridlinesRecord
Title: Print Gridlines Record
 class PrintHeadersRecord
Title: Print Headers Record
 class PrintSetupRecord
Title: PAGESETUP (0x00A1)

Description: Stores print setup options -- bogus for HSSF (and marked as such)

REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214
 class ProtectionRev4Record
Title: Protection Revision 4 Record (0x01AF)

Description: describes whether this is a protected shared/tracked workbook

REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class ProtectRecord
Title: Protect Record (0x0012)

Description: defines whether a sheet or workbook is protected (HSSF DOES NOT SUPPORT ENCRYPTION)

HSSF now supports the simple "protected" sheets (where they are not encrypted and open office et al ignore the password record entirely).

 class RecalcIdRecord
Title: Recalc Id Record (0x01C1)

Description: This record contains an ID that marks when a worksheet was last recalculated.

 class Record
Title: Record Description: All HSSF Records inherit from this class.
 class RefModeRecord
Title: RefMode Record
 class RefreshAllRecord
Title: Refresh All Record (0x01B7)

Description: Flag whether to refresh all external data when loading a sheet.

 class RightMarginRecord
Record for the right margin.
 class RKRecord
Title: RK Record (0x027E)

Description: An internal 32 bit number with the two most significant bits storing the type.

 class RowRecord
Title: Row Record (0x0208)

Description: stores the row information for the sheet.

 class SaveRecalcRecord
Title: Save Recalc Record
 class ScenarioProtectRecord
Title: Scenario Protect Record
 class SCLRecord
Specifies the window's zoom magnification.
 class SelectionRecord
Title: Selection Record (0x001D)
 class SharedFormulaRecord
Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
 class SharedValueRecordBase
Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.
 class SSTRecord
Title: Static String Table Record (0x00FC)

Description: This holds all the strings for LabelSSTRecords.

 class StandardRecord
Subclasses of this class (the majority of BIFF records) are non-continuable.
 class StringRecord
STRING (0x0207)

Stores the cached result of a text formula

 class StyleRecord
Title: Style Record (0x0293)

Description: Describes a builtin to the gui or user defined style

 class SupBookRecord
Title: Sup Book - EXTERNALBOOK (0x01AE)

Description: A External Workbook Description (Supplemental Book) Its only a dummy record for making new ExternSheet Record

 class TabIdRecord
Title: Sheet Tab Index Array Record (0x013D)

Description: Contains an array of sheet id's.

 class TableRecord
DATATABLE (0x0236)

TableRecord - The record specifies a data table.

 class TableStylesRecord
TABLESTYLES (0x088E)
 class TextObjectRecord
The TXO record (0x01B6) is used to define the properties of a text box.
 class TopMarginRecord
Record for the top margin.
 class UncalcedRecord
Title: Uncalced Record
 class UnknownRecord
Title: Unknown Record (for debugging)

Description: Unknown record just tells you the sid so you can figure out what records you are missing.

 class UserSViewBegin
The UserSViewBegin record specifies settings for a custom view associated with the sheet.
 class UserSViewEnd
The UserSViewEnd record marks the end of the settings for a custom view associated with the sheet
 class UseSelFSRecord
Title: USESELFS (0x0160) - Use Natural Language Formulas Flag

Description: Tells the GUI if this was written by something that can use "natural language" formulas.

 class VCenterRecord
Title: VCenter record
 class VerticalPageBreakRecord
VerticalPageBreak (0x001A) record that stores page breaks at columns
 class WindowOneRecord
Title: Window1 Record
 class WindowProtectRecord
Title: Window Protect Record (0x0019)

Description: flags whether workbook windows are protected

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class WindowTwoRecord
Title: Window Two Record
 class WriteAccessRecord
Title: Write Access Record (0x005C)

Description: Stores the username of that who owns the spreadsheet generator (on unix the user's login, on Windoze its the name you typed when you installed the thing)

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

 class WriteProtectRecord
Title: Write Protect Record
 class WSBoolRecord
Title: WSBOOL (0x0081) (called SHEETPR in OOO doc)

Description: stores workbook settings (aka its a big "everything we didn't put somewhere else")

Uses of RecordBase in org.apache.poi.hssf.record.aggregates

Subclasses of RecordBase in org.apache.poi.hssf.record.aggregates
class | CFRecordsAggregate CFRecordsAggregate - aggregates Conditional Formatting records CFHeaderRecord and number of up to three CFRuleRecord records together to simplify access to them.
class | ChartSubstreamRecordAggregate Manages the all the records associated with a chart sub-stream. Includes the initial BOFRecord and final EOFRecord.
class | ColumnInfoRecordsAggregate
class | ConditionalFormattingTable Holds all the conditional formatting for a workbook sheet. See OOO exelfileformat.pdf sec 4.12 'Conditional Formatting Table'
class | CustomViewSettingsRecordAggregate Manages the all the records associated with a 'Custom View Settings' sub-stream. Includes the initial USERSVIEWBEGIN(0x01AA) and final USERSVIEWEND(0x01AB).
class | DataValidityTable Manages the DVALRecord and DVRecords for a single sheet See OOO excelfileformat.pdf section 4.14
class | FormulaRecordAggregate The formula record aggregate is used to join together the formula record and it's (optional) string record and (optional) Shared Formula Record (template reads, excel optimization).
class | MergedCellsTable
class | PageSettingsBlock Groups the page settings records for a worksheet. See OOO excelfileformat.pdf sec 4.4 'Page Settings Block'
class | RecordAggregate RecordAggregates are groups of of BIFF Records that are typically stored together and/or updated together.
class | RowRecordsAggregate
class | WorksheetProtectionBlock Groups the sheet protection records for a worksheet.

Methods in org.apache.poi.hssf.record.aggregates with parameters of type RecordBase
 void CustomViewSettingsRecordAggregate.append(RecordBase r)

Method parameters in org.apache.poi.hssf.record.aggregates with type arguments of type RecordBase
 void PageSettingsBlock.positionRecords(java.util.List<RecordBase> sheetRecords)
Some apps can define multiple HeaderFooterRecord records for a sheet.

Uses of RecordBase in org.apache.poi.hssf.record.chart

Subclasses of RecordBase in org.apache.poi.hssf.record.chart
class | AreaFormatRecord The area format record is used to define the colours and patterns for an area.
class | AreaRecord The area record is used to define a area chart.
class | AxisLineFormatRecord The axis line format record defines the axis type details.
class | AxisOptionsRecord The axis options record provides unit information and other various tidbits about the axis.
class | AxisParentRecord The axis size and location
class | AxisRecord The axis record defines the type of an axis.
class | AxisUsedRecord The number of axes used on a chart.
class | BarRecord The bar record is used to define a bar chart.
class | BeginRecord The begin record defines the start of a block of records for a (grpahing data object.
class | CategorySeriesAxisRecord This record refers to a category or series axis and is used to specify label/tickmark frequency.
class | CatLabRecord CATLAB - Category Labels (0x0856)
class | ChartEndBlockRecord ENDBLOCK - Chart Future Record Type End Block (0x0853)
class | ChartEndObjectRecord ENDOBJECT - Chart Future Record Type End Object (0x0855)
class | ChartFormatRecord Class ChartFormatRecord (0x1014) (As with all chart related records, documentation is lacking.
class | ChartFRTInfoRecord CHARTFRTINFO - Chart Future Record Type Info (0x0850)
class | ChartRecord CHART (0x1002) The chart record is used to define the location and size of a chart. Chart related records don't seem to be covered in either the OOO or the MS documentation.
class | ChartStartBlockRecord STARTBLOCK - Chart Future Record Type Start Block (0x0852)
class | ChartStartObjectRecord STARTOBJECT - Chart Future Record Type Start Object (0x0854)
class | ChartTitleFormatRecord CHARTTITLEFORMAT (0x1050) Describes the formatting runs associated with a chart title.
class | DataFormatRecord The data format record is used to index into a series.
class | DataLabelExtensionRecord DATALABEXT - Chart Data Label Extension (0x086A)
class | DatRecord The dat record is used to store options for the chart.
class | DefaultDataLabelTextPropertiesRecord The default data label text properties record identifies the text characteristics of the preceding text record.
class | EndRecord The end record defines the end of a block of records for a (Graphing) data object.
class | FontBasisRecord The font basis record stores various font metrics.
class | FontIndexRecord The font index record indexes into the font table for the text record.
class | FrameRecord The frame record indicates whether there is a border around the displayed text of a chart.
class | LegendRecord Defines a legend for a chart.
class | LineFormatRecord Describes a line format record.
class | LinkedDataRecord Describes a linked data record.
class | NumberFormatIndexRecord The number format index record indexes format table.
class | ObjectLinkRecord Links text to an object on the chart or identifies it as the title.
class | PlotAreaRecord preceeds and identifies a frame as belonging to the plot area.
class | PlotGrowthRecord The plot growth record specifies the scaling factors used when a font is scaled.
class | SeriesChartGroupIndexRecord The series chart group index record stores the index to the CHARTFORMAT record (0 based).
class | SeriesIndexRecord links a series to its position in the series list.
class | SeriesLabelsRecord The series label record defines the type of label associated with the data format record.
class | SeriesListRecord SERIESLIST (0x1016) The series list record defines the series displayed as an overlay to the main chart record. (As with all chart related records, documentation is lacking.
class | SeriesRecord The series record describes the overall data for a series.
class | SeriesTextRecord SERIESTEXT (0x100D)
class | SeriesToChartGroupRecord Indicates the chart-group index for a series.
class | SheetPropertiesRecord Describes a chart sheet properties record.
class | TextRecord The text record is used to define text stored on a chart.
class | TickRecord The Tick record defines how tick marks and label positioning/formatting
class | UnitsRecord The units record describes units.
class | ValueRangeRecord The value range record defines the range of the value axis.

Uses of RecordBase in org.apache.poi.hssf.record.cont

Subclasses of RecordBase in org.apache.poi.hssf.record.cont
 class ContinuableRecord
Common superclass of all records that can produce ContinueRecords while being serialized.

Uses of RecordBase in org.apache.poi.hssf.record.pivottable

Subclasses of RecordBase in org.apache.poi.hssf.record.pivottable
class | DataItemRecord SXDI - Data Item (0x00C5)
class | ExtendedPivotTableViewFieldsRecord SXVDEX - Extended PivotTable View Fields (0x0100)
class | PageItemRecord SXPI - Page Item (0x00B6)
class | StreamIDRecord SXIDSTM - Stream ID (0x00D5)
class | ViewDefinitionRecord SXVIEW - View Definition (0x00B0)
class | ViewFieldsRecord SXVD - View Fields (0x00B1)
class | ViewSourceRecord SXVS - View Source (0x00E3)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RecordFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RecordFactory

No usage of org.apache.poi.hssf.record.RecordFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RecordFactoryInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RecordFactoryInputStream

No usage of org.apache.poi.hssf.record.RecordFactoryInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RecordFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RecordFormatException

Packages that use RecordFormatException
org.apache.poi.hssf.dev | DEV package serves two purposes.
org.apache.poi.hssf.eventmodel |
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.

Uses of RecordFormatException in org.apache.poi.hssf.dev

Methods in org.apache.poi.hssf.dev that throw RecordFormatException
static Record[] BiffViewer.createRecords(java.io.InputStream is, java.io.PrintStream ps, org.apache.poi.hssf.dev.BiffViewer.BiffRecordListener recListener, boolean dumpInterpretedRecords)
Create an array of records from an input stream

Uses of RecordFormatException in org.apache.poi.hssf.eventmodel

Methods in org.apache.poi.hssf.eventmodel that throw RecordFormatException
 void EventRecordFactory.processRecords(java.io.InputStream in)
Create an array of records from an input stream

Uses of RecordFormatException in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that throw RecordFormatException
static java.util.List<Record> | RecordFactory.createRecords(java.io.InputStream in) Create an array of records from an input stream
void | RecordInputStream.nextRecord() Moves to the next record in the stream.

Constructors in org.apache.poi.hssf.record that throw RecordFormatException
RecordInputStream(java.io.InputStream in)
RecordInputStream(java.io.InputStream in, Biff8EncryptionKey key, int initialOffset)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RecordInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RecordInputStream

Packages that use RecordInputStream
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.pivottable |
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.util |

Uses of RecordInputStream in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type RecordInputStream
static Record | InterfaceEndRecord.create(RecordInputStream in)
static Record[] | RecordFactory.createRecord(RecordInputStream in) create a record, if there are MUL records than multiple records are returned digested into the non-mul form.
static Record | RecordFactory.createSingleRecord(RecordInputStream in)

Constructors in org.apache.poi.hssf.record with parameters of type RecordInputStream
AbstractEscherHolderRecord(RecordInputStream in)
ArrayRecord(RecordInputStream in)
AutoFilterInfoRecord(RecordInputStream in)
BackupRecord(RecordInputStream in)
BlankRecord(RecordInputStream in)
BOFRecord(RecordInputStream in)
BookBoolRecord(RecordInputStream in)
BoolErrRecord(RecordInputStream in)
BottomMarginRecord(RecordInputStream in)
BoundSheetRecord(RecordInputStream in)
UTF8: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + len(str) UNICODE: sid + len + bof + flags + len(str) + unicode + str 2 + 2 + 4 + 2 + 1 + 1 + 2 * len(str)
CalcCountRecord(RecordInputStream in)
CalcModeRecord(RecordInputStream in)
CellRecord(RecordInputStream in)
CFHeaderRecord(RecordInputStream in)
CFRuleRecord(RecordInputStream in)
CodepageRecord(RecordInputStream in)
ColumnInfoRecord(RecordInputStream in)
ContinueRecord(RecordInputStream in)
CountryRecord(RecordInputStream in)
CRNCountRecord(RecordInputStream in)
CRNRecord(RecordInputStream in)
DateWindow1904Record(RecordInputStream in)
DBCellRecord(RecordInputStream in)
DConRefRecord(RecordInputStream inStream)
Read Constructor.
DefaultColWidthRecord(RecordInputStream in)
DefaultRowHeightRecord(RecordInputStream in)
DeltaRecord(RecordInputStream in)
DimensionsRecord(RecordInputStream in)
DrawingGroupRecord(RecordInputStream in)
DrawingRecord(RecordInputStream in)
DrawingRecordForBiffViewer(RecordInputStream in)
DrawingSelectionRecord(RecordInputStream in)
DSFRecord(RecordInputStream in)
DVALRecord(RecordInputStream in)
DVRecord(RecordInputStream in)
EOFRecord(RecordInputStream in)
ExtendedFormatRecord(RecordInputStream in)
ExternalNameRecord(RecordInputStream in)
ExternSheetRecord(RecordInputStream in)
ExtSSTRecord.InfoSubRecord(RecordInputStream in)
ExtSSTRecord(RecordInputStream in)
FeatHdrRecord(RecordInputStream in)
FeatRecord(RecordInputStream in)
FilePassRecord(RecordInputStream in)
FileSharingRecord(RecordInputStream in)
FnGroupCountRecord(RecordInputStream in)
FontRecord(RecordInputStream in)
FooterRecord(RecordInputStream in)
FormatRecord(RecordInputStream in)
FormulaRecord(RecordInputStream ris)
GridsetRecord(RecordInputStream in)
GutsRecord(RecordInputStream in)
HCenterRecord(RecordInputStream in)
HeaderFooterBase(RecordInputStream in)
HeaderFooterRecord(RecordInputStream in)
construct a HeaderFooterRecord record.
HeaderRecord(RecordInputStream in)
HideObjRecord(RecordInputStream in)
HorizontalPageBreakRecord(RecordInputStream in)
HyperlinkRecord(RecordInputStream in)
IndexRecord(RecordInputStream in)
InterfaceHdrRecord(RecordInputStream in)
IterationRecord(RecordInputStream in)
LabelRecord(RecordInputStream in)
LabelSSTRecord(RecordInputStream in)
LeftMarginRecord(RecordInputStream in)
MergeCellsRecord(RecordInputStream in)
Constructs a MergedCellsRecord and sets its fields appropriately
MMSRecord(RecordInputStream in)
MulBlankRecord(RecordInputStream in)
MulRKRecord(RecordInputStream in)
NameCommentRecord(RecordInputStream ris)
NameRecord(RecordInputStream ris)
called by the constructor, should set class level fields.
NoteRecord(RecordInputStream in)
Read the record data from the supplied RecordInputStream
NumberRecord(RecordInputStream in)
ObjectProtectRecord(RecordInputStream in)
ObjRecord(RecordInputStream in)
PageBreakRecord.Break(RecordInputStream in)
PageBreakRecord(RecordInputStream in)
PaletteRecord(RecordInputStream in)
PaneRecord(RecordInputStream in)
PasswordRecord(RecordInputStream in)
PasswordRev4Record(RecordInputStream in)
PrecisionRecord(RecordInputStream in)
PrintGridlinesRecord(RecordInputStream in)
PrintHeadersRecord(RecordInputStream in)
PrintSetupRecord(RecordInputStream in)
ProtectionRev4Record(RecordInputStream in)
ProtectRecord(RecordInputStream in)
RecalcIdRecord(RecordInputStream in)
RefModeRecord(RecordInputStream in)
RefreshAllRecord(RecordInputStream in)
RightMarginRecord(RecordInputStream in)
RKRecord(RecordInputStream in)
RowRecord(RecordInputStream in)
SaveRecalcRecord(RecordInputStream in)
ScenarioProtectRecord(RecordInputStream in)
SCLRecord(RecordInputStream in)
SelectionRecord(RecordInputStream in)
SharedFormulaRecord(RecordInputStream in)
SSTRecord(RecordInputStream in)
Fill the fields from the data
StringRecord(RecordInputStream in)
StyleRecord(RecordInputStream in)
SupBookRecord(RecordInputStream in)
called by the constructor, should set class level fields.
TabIdRecord(RecordInputStream in)
TableRecord(RecordInputStream in)
TableStylesRecord(RecordInputStream in)
TextObjectRecord(RecordInputStream in)
TopMarginRecord(RecordInputStream in)
UncalcedRecord(RecordInputStream in)
UnicodeString(RecordInputStream in)
Deprecated. Use UnicodeString instead
UnknownRecord(RecordInputStream in)
construct an unknown record.
UserSViewBegin(RecordInputStream in)
construct an UserSViewBegin record.
UserSViewEnd(RecordInputStream in)
construct an UserSViewEnd record.
UseSelFSRecord(RecordInputStream in)
VCenterRecord(RecordInputStream in)
VerticalPageBreakRecord(RecordInputStream in)
WindowOneRecord(RecordInputStream in)
WindowProtectRecord(RecordInputStream in)
WindowTwoRecord(RecordInputStream in)
WriteAccessRecord(RecordInputStream in)
WriteProtectRecord(RecordInputStream in)
WSBoolRecord(RecordInputStream in)

Uses of RecordInputStream in org.apache.poi.hssf.record.cf

Constructors in org.apache.poi.hssf.record.cf with parameters of type RecordInputStream
FontFormatting(RecordInputStream in)
Creates new FontFormatting

Uses of RecordInputStream in org.apache.poi.hssf.record.chart

Constructors in org.apache.poi.hssf.record.chart with parameters of type RecordInputStream
AreaFormatRecord(RecordInputStream in)
AreaRecord(RecordInputStream in)
AxisLineFormatRecord(RecordInputStream in)
AxisOptionsRecord(RecordInputStream in)
AxisParentRecord(RecordInputStream in)
AxisRecord(RecordInputStream in)
AxisUsedRecord(RecordInputStream in)
BarRecord(RecordInputStream in)
BeginRecord(RecordInputStream in)
CategorySeriesAxisRecord(RecordInputStream in)
CatLabRecord(RecordInputStream in)
ChartEndBlockRecord(RecordInputStream in)
ChartEndObjectRecord(RecordInputStream in)
ChartFormatRecord(RecordInputStream in)
ChartFRTInfoRecord(RecordInputStream in)
ChartRecord(RecordInputStream in)
ChartStartBlockRecord(RecordInputStream in)
ChartStartObjectRecord(RecordInputStream in)
ChartTitleFormatRecord(RecordInputStream in)
DataFormatRecord(RecordInputStream in)
DataLabelExtensionRecord(RecordInputStream in)
DatRecord(RecordInputStream in)
DefaultDataLabelTextPropertiesRecord(RecordInputStream in)
EndRecord(RecordInputStream in)
FontBasisRecord(RecordInputStream in)
FontIndexRecord(RecordInputStream in)
FrameRecord(RecordInputStream in)
LegendRecord(RecordInputStream in)
LineFormatRecord(RecordInputStream in)
LinkedDataRecord(RecordInputStream in)
NumberFormatIndexRecord(RecordInputStream in)
ObjectLinkRecord(RecordInputStream in)
PlotAreaRecord(RecordInputStream in)
PlotGrowthRecord(RecordInputStream in)
SeriesChartGroupIndexRecord(RecordInputStream in)
SeriesIndexRecord(RecordInputStream in)
SeriesLabelsRecord(RecordInputStream in)
SeriesListRecord(RecordInputStream in)
SeriesRecord(RecordInputStream in)
SeriesTextRecord(RecordInputStream in)
SeriesToChartGroupRecord(RecordInputStream in)
SheetPropertiesRecord(RecordInputStream in)
TextRecord(RecordInputStream in)
TickRecord(RecordInputStream in)
UnitsRecord(RecordInputStream in)
ValueRangeRecord(RecordInputStream in)

Uses of RecordInputStream in org.apache.poi.hssf.record.common

Constructors in org.apache.poi.hssf.record.common with parameters of type RecordInputStream
FeatFormulaErr2(RecordInputStream in)
FeatProtection(RecordInputStream in)
FeatSmartTag(RecordInputStream in)
FtrHeader(RecordInputStream in)
UnicodeString(RecordInputStream in)
construct a unicode string record and fill its fields, ID is ignored

Uses of RecordInputStream in org.apache.poi.hssf.record.cont

Constructors in org.apache.poi.hssf.record.cont with parameters of type RecordInputStream
ContinuableRecordInput(RecordInputStream in)

Uses of RecordInputStream in org.apache.poi.hssf.record.pivottable

Constructors in org.apache.poi.hssf.record.pivottable with parameters of type RecordInputStream
DataItemRecord(RecordInputStream in)
ExtendedPivotTableViewFieldsRecord(RecordInputStream in)
PageItemRecord(RecordInputStream in)
StreamIDRecord(RecordInputStream in)
ViewDefinitionRecord(RecordInputStream in)
ViewFieldsRecord(RecordInputStream in)
ViewSourceRecord(RecordInputStream in)

Uses of RecordInputStream in org.apache.poi.hssf.util

Constructors in org.apache.poi.hssf.util with parameters of type RecordInputStream
CellRangeAddress(RecordInputStream in)
Deprecated.
CellRangeAddressList(RecordInputStream in)
Deprecated.

Uses of RecordInputStream in org.apache.poi.ss.util

Constructors in org.apache.poi.ss.util with parameters of type RecordInputStream
CellRangeAddress(RecordInputStream in)
CellRangeAddressList(RecordInputStream in)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RecordInputStream.LeftoverDataException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RecordInputStream.LeftoverDataException

Packages that use RecordInputStream.LeftoverDataException
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of RecordInputStream.LeftoverDataException in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that throw RecordInputStream.LeftoverDataException
 boolean RecordInputStream.hasNextRecord()
Note - this method is expected to be called only when completed reading the current BIFF record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RefModeRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RefModeRecord

No usage of org.apache.poi.hssf.record.RefModeRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RefreshAllRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RefreshAllRecord

No usage of org.apache.poi.hssf.record.RefreshAllRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RightMarginRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RightMarginRecord

No usage of org.apache.poi.hssf.record.RightMarginRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RKRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RKRecord

Packages that use RKRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of RKRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type RKRecord
static NumberRecord RecordFactory.convertToNumberRecord(RKRecord rk)
RK record is a slightly smaller alternative to NumberRecord POI likes NumberRecord better

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.RowRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.RowRecord

Packages that use RowRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of RowRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return RowRecord
RowRecord | InternalSheet.getNextRow() get the NEXT RowRecord (from LOC).
RowRecord | InternalSheet.getRow(int rownum) get the NEXT (from LOC) RowRecord where rownumber matches the given rownum.

Methods in org.apache.poi.hssf.model with parameters of type RowRecord
void | InternalSheet.addRow(RowRecord row) Adds a row record to the sheet
void | InternalSheet.removeRow(RowRecord row) Removes a row record This method is not loc sensitive, it resets loc to = dimsloc so no worries.

Uses of RowRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return RowRecord
static RowRecord | RowRecordsAggregate.createRow(int rowNumber) Create a row record.
RowRecord | RowRecordsAggregate.getRow(int rowIndex)

Methods in org.apache.poi.hssf.record.aggregates that return types with arguments of type RowRecord
 java.util.Iterator<RowRecord> RowRecordsAggregate.getIterator()

Methods in org.apache.poi.hssf.record.aggregates with parameters of type RowRecord
void | RowRecordsAggregate.insertRow(RowRecord row)
void | RowRecordsAggregate.removeRow(RowRecord row)

Uses of RowRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return RowRecord
protected  RowRecord HSSFRow.getRowRecord()
get the lowlevel RowRecord represented by this object - should only be called by other parts of the high level API

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SaveRecalcRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SaveRecalcRecord

No usage of org.apache.poi.hssf.record.SaveRecalcRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.ScenarioProtectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.ScenarioProtectRecord

Packages that use ScenarioProtectRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of ScenarioProtectRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return ScenarioProtectRecord
 ScenarioProtectRecord WorksheetProtectionBlock.getHCenter()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SCLRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SCLRecord

Packages that use SCLRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of SCLRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type SCLRecord
 void InternalSheet.setSCLRecord(SCLRecord sclRecord)
Sets the SCL record or creates it in the correct place if it does not already exist.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SelectionRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SelectionRecord

Packages that use SelectionRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of SelectionRecord in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as SelectionRecord
protected  SelectionRecord InternalSheet._selection

Methods in org.apache.poi.hssf.model that return SelectionRecord
 SelectionRecord InternalSheet.getSelection()

Methods in org.apache.poi.hssf.model with parameters of type SelectionRecord
 void InternalSheet.setSelection(SelectionRecord selection)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SharedFormulaRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SharedFormulaRecord

Packages that use SharedFormulaRecord
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of SharedFormulaRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type SharedFormulaRecord
 boolean SharedFormulaRecord.isFormulaSame(SharedFormulaRecord other)

Uses of SharedFormulaRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return SharedFormulaRecord
 SharedFormulaRecord SharedValueManager.linkSharedFormulaRecord(CellReference firstCell, FormulaRecordAggregate agg)

Methods in org.apache.poi.hssf.record.aggregates with parameters of type SharedFormulaRecord
static SharedValueManager | SharedValueManager.create(SharedFormulaRecord[] sharedFormulaRecords, CellReference[] firstCells, ArrayRecord[] arrayRecords, TableRecord[] tableRecords)
void | SharedValueManager.unlink(SharedFormulaRecord sharedFormulaRecord) Converts all FormulaRecords handled by sharedFormulaRecord to plain unshared formulas

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SharedValueRecordBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SharedValueRecordBase

Packages that use SharedValueRecordBase
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.

Uses of SharedValueRecordBase in org.apache.poi.hssf.record

Subclasses of SharedValueRecordBase in org.apache.poi.hssf.record
class | ArrayRecord ARRAY (0x0221) Treated in a similar way to SharedFormulaRecord
class | SharedFormulaRecord Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
class | TableRecord DATATABLE (0x0236) TableRecord - The record specifies a data table.

Uses of SharedValueRecordBase in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return SharedValueRecordBase
 SharedValueRecordBase SharedValueManager.getRecordForFirstCell(FormulaRecordAggregate agg)
Gets the SharedValueRecordBase record if it should be encoded immediately after the formula record contained in the specified FormulaRecordAggregate agg.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SSTRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SSTRecord

Packages that use SSTRecord
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.

Uses of SSTRecord in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel that return SSTRecord
 SSTRecord EventWorkbookBuilder.SheetRecordCollectingListener.getSSTRecord()

Methods in org.apache.poi.hssf.eventusermodel with parameters of type SSTRecord
static InternalWorkbook EventWorkbookBuilder.createStubWorkbook(ExternSheetRecord[] externs, BoundSheetRecord[] bounds, SSTRecord sst)
Creates a stub Workbook from the supplied records, suitable for use with the HSSFFormulaParser

Uses of SSTRecord in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as SSTRecord
protected  SSTRecord InternalWorkbook.sst
this contains a reference to the SSTRecord so that new stings can be added to it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.StandardRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.StandardRecord

Packages that use StandardRecord
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.pivottable |

Uses of StandardRecord in org.apache.poi.hssf.record

Subclasses of StandardRecord in org.apache.poi.hssf.record
 class ArrayRecord
ARRAY (0x0221)

Treated in a similar way to SharedFormulaRecord

 class AutoFilterInfoRecord
The AutoFilterInfo record specifies the number of columns that have AutoFilter enabled and indicates the beginning of the collection of AutoFilter records.
 class BackupRecord
Title: Backup Record
 class BlankRecord
Title: Blank cell record (0x0201)
 class BOFRecord
Title: Beginning Of File (0x0809)
 class BookBoolRecord
Title: Save External Links record (BookBool)
 class BoolErrRecord
Creates new BoolErrRecord.
 class BottomMarginRecord
Record for the bottom margin.
 class BoundSheetRecord
Title: Bound Sheet Record (aka BundleSheet) (0x0085)
 class CalcCountRecord
Title: Calc Count Record Description: Specifies the maximum times the gui should perform a formula recalculation.
 class CalcModeRecord
Title: Calc Mode Record
 class CellRecord
Base class for all cell value records (implementors of CellValueRecordInterface).
 class CFHeaderRecord
Conditional Formatting Header record CFHEADER (0x01B0)
 class CFRuleRecord
Conditional Formatting Rule Record (0x01B1).
 class CodepageRecord
Title: Codepage Record
 class ColumnInfoRecord
Title: COLINFO Record (0x007D)

Description: Defines with width and formatting for a range of columns

REFERENCE: PG 293 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class ContinueRecord
Title: Continue Record(0x003C) - Helper class used primarily for SST Records
 class CountryRecord
Title: Country Record (aka WIN.INI country)
 class CRNCountRecord
XCT - CRN Count
 class CRNRecord
Title: CRN(0x005A)

Description: This record stores the contents of an external cell or cell range

REFERENCE: OOO 5.23
 class DateWindow1904Record
Title: Date Window 1904 Flag record
 class DBCellRecord
Title: DBCell Record (0x00D7)

Description: Used by Excel and other MS apps to quickly find rows in the sheets.

 class DConRefRecord
DConRef records specify a range in a workbook (internal or external) that serves as a data source for pivot tables or data consolidation.
 class DefaultColWidthRecord
Title: Default Column Width Record (0x0055)
 class DefaultRowHeightRecord
Title: Default Row Height Record Description: Row height for rows with undefined or not explicitly defined heights.
 class DeltaRecord
Title: Delta Record (0x0010)

Description: controls the accuracy of the calculations

REFERENCE: PG 303 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class DimensionsRecord
Title: Dimensions Record
 class DrawingRecord
DrawingRecord (0x00EC)
 class DrawingSelectionRecord
MsoDrawingSelection (0x00ED)

Reference: [MS-OGRAPH].pdf sec 2.4.69

 class DSFRecord
Title: Double Stream Flag Record (0x0161)

Description: tells if this is a double stream file.

 class DVALRecord
Title: DATAVALIDATIONS Record (0x01B2)

Description: used in data validation ; This record is the list header of all data validation records (0x01BE) in the current sheet.

 class DVRecord
Title: DATAVALIDATION Record (0x01BE)

Description: This record stores data validation settings and a list of cell ranges which contain these settings.

 class EOFRecord
End Of File record.
 class ExtendedFormatRecord
Title: Extended Format Record Description: Probably one of the more complex records.
 class ExternalNameRecord
EXTERNALNAME (0x0023)
 class ExternSheetRecord
EXTERNSHEET (0x0017)
A List of Indexes to EXTERNALBOOK (supplemental book) Records

 class FeatHdrRecord
Title: FeatHdr (Feature Header) Record
 class FeatRecord
Title: Feat (Feature) Record
 class FilePassRecord
Title: File Pass Record (0x002F)

Description: Indicates that the record after this record are encrypted.

 class FileSharingRecord
Title: FILESHARING (0x005B)

Description: stores the encrypted readonly for a workbook (write protect) This functionality is accessed from the options dialog box available when performing 'Save As'.

REFERENCE: PG 314 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class FnGroupCountRecord
Title: Function Group Count Record
 class FontRecord
Title: Font Record (0x0031)

- describes a font in the workbook (index = 0-3,5-infinity - skip 4)

 class FooterRecord
Title: Footer Record (0x0015)

Description: Specifies the footer for a sheet

 class FormatRecord
Title: Format Record (0x041E)

Description: describes a number format -- those goofy strings like $(#,###)

REFERENCE: PG 317 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class FormulaRecord
Formula Record (0x0006).
 class GridsetRecord
Title: Gridset Record.
 class GutsRecord
Title: Guts Record
 class HCenterRecord
Title: HCenter record (0x0083)
 class HeaderFooterBase
Common header/footer base class
 class HeaderFooterRecord
The HEADERFOOTER record stores information added in Office Excel 2007 for headers/footers.
 class HeaderRecord
Title: Header Record
 class HideObjRecord
Title: Hide Object Record
 class HorizontalPageBreakRecord
HorizontalPageBreak (0x001B) record that stores page breaks at rows

 class HyperlinkRecord
The HyperlinkRecord (0x01B8) wraps an HLINK-record from the Excel-97 format.
 class IndexRecord
Title: Index Record (0x020B)

Description: Occurs right after BOF, tells you where the DBCELL records are for a sheet Important for locating cells

NOT USED IN THIS RELEASE REFERENCE: PG 323 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class InterfaceEndRecord
Title: Interface End Record (0x00E2)
 class InterfaceHdrRecord
Title: Interface Header Record (0x00E1)
 class IterationRecord
Title: Iteration Record (0x0011)

Description: Tells whether to iterate over forumla calculations or not (if a formula is dependant upon another formula's result) (odd feature for something that can only have 32 elements in a formula!)

 class LabelSSTRecord
Title: Label SST Record
 class LeftMarginRecord
Record for the left margin.
 class MergeCellsRecord
Title: Merged Cells Record (0x00E5)
Description: Optional record defining a square area of cells to "merged" into one cell.
 class MMSRecord
Title: MMS Record
 class MulBlankRecord
Title: Multiple Blank cell record(0x00BE)

Description: Represents a set of columns in a row with no value but with styling.

 class MulRKRecord
MULRK (0x00BD)

Used to store multiple RK numbers on a row.

 class NameCommentRecord
Title: NAMECMT Record (0x0894)

Description: Defines a comment associated with a specified name.

 class NoteRecord
NOTE: Comment Associated with a Cell (0x001C)
 class NumberRecord
NUMBER (0x0203) Contains a numeric cell value.
 class ObjectProtectRecord
Title: Object Protect Record
 class PageBreakRecord
Record that contains the functionality page breaks (horizontal and vertical)
 class PaletteRecord
PaletteRecord (0x0092) - Supports custom palettes.
 class PaneRecord
Describes the frozen and unfozen panes.
 class PasswordRecord
Title: Password Record (0x0013)

Description: stores the encrypted password for a sheet or workbook (HSSF doesn't support encryption) REFERENCE: PG 371 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class PasswordRev4Record
Title: Protection Revision 4 password Record (0x01BC)

Description: Stores the (2 byte??!!) encrypted password for a shared workbook

REFERENCE: PG 374 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class PrecisionRecord
Title: Precision Record
 class PrintGridlinesRecord
Title: Print Gridlines Record
 class PrintHeadersRecord
Title: Print Headers Record
 class PrintSetupRecord
Title: PAGESETUP (0x00A1)

Description: Stores print setup options -- bogus for HSSF (and marked as such)

REFERENCE: PG 385 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 412 Microsoft Excel Binary File Format Structure v20091214
 class ProtectionRev4Record
Title: Protection Revision 4 Record (0x01AF)

Description: describes whether this is a protected shared/tracked workbook

REFERENCE: PG 373 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class ProtectRecord
Title: Protect Record (0x0012)

Description: defines whether a sheet or workbook is protected (HSSF DOES NOT SUPPORT ENCRYPTION)

HSSF now supports the simple "protected" sheets (where they are not encrypted and open office et al ignore the password record entirely).

 class RecalcIdRecord
Title: Recalc Id Record (0x01C1)

Description: This record contains an ID that marks when a worksheet was last recalculated.

 class RefModeRecord
Title: RefMode Record
 class RefreshAllRecord
Title: Refresh All Record (0x01B7)

Description: Flag whether to refresh all external data when loading a sheet.

 class RightMarginRecord
Record for the right margin.
 class RKRecord
Title: RK Record (0x027E)

Description: An internal 32 bit number with the two most significant bits storing the type.

 class RowRecord
Title: Row Record (0x0208)

Description: stores the row information for the sheet.

 class SaveRecalcRecord
Title: Save Recalc Record
 class ScenarioProtectRecord
Title: Scenario Protect Record
 class SCLRecord
Specifies the window's zoom magnification.
 class SelectionRecord
Title: Selection Record (0x001D)
 class SharedFormulaRecord
Title: SHAREDFMLA (0x04BC) SharedFormulaRecord Description: Primarily used as an excel optimization so that multiple similar formulas are not written out too many times.
 class SharedValueRecordBase
Common base class for SharedFormulaRecord, ArrayRecord and TableRecord which are have similarities.
 class StyleRecord
Title: Style Record (0x0293)

Description: Describes a builtin to the gui or user defined style

 class SupBookRecord
Title: Sup Book - EXTERNALBOOK (0x01AE)

Description: A External Workbook Description (Supplemental Book) Its only a dummy record for making new ExternSheet Record

 class TabIdRecord
Title: Sheet Tab Index Array Record (0x013D)

Description: Contains an array of sheet id's.

 class TableRecord
DATATABLE (0x0236)

TableRecord - The record specifies a data table.

 class TableStylesRecord
TABLESTYLES (0x088E)
 class TopMarginRecord
Record for the top margin.
 class UncalcedRecord
Title: Uncalced Record
 class UnknownRecord
Title: Unknown Record (for debugging)

Description: Unknown record just tells you the sid so you can figure out what records you are missing.

 class UserSViewBegin
The UserSViewBegin record specifies settings for a custom view associated with the sheet.
 class UserSViewEnd
The UserSViewEnd record marks the end of the settings for a custom view associated with the sheet
 class UseSelFSRecord
Title: USESELFS (0x0160) - Use Natural Language Formulas Flag

Description: Tells the GUI if this was written by something that can use "natural language" formulas.

 class VCenterRecord
Title: VCenter record
 class VerticalPageBreakRecord
VerticalPageBreak (0x001A) record that stores page breaks at columns
 class WindowOneRecord
Title: Window1 Record
 class WindowProtectRecord
Title: Window Protect Record (0x0019)

Description: flags whether workbook windows are protected

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)
 class WindowTwoRecord
Title: Window Two Record
 class WriteAccessRecord
Title: Write Access Record (0x005C)

Description: Stores the username of that who owns the spreadsheet generator (on unix the user's login, on Windoze its the name you typed when you installed the thing)

REFERENCE: PG 424 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

 class WriteProtectRecord
Title: Write Protect Record
 class WSBoolRecord
Title: WSBOOL (0x0081) (called SHEETPR in OOO doc)

Description: stores workbook settings (aka its a big "everything we didn't put somewhere else")

Uses of StandardRecord in org.apache.poi.hssf.record.chart

Subclasses of StandardRecord in org.apache.poi.hssf.record.chart
class | AreaFormatRecord The area format record is used to define the colours and patterns for an area.
class | AreaRecord The area record is used to define a area chart.
class | AxisLineFormatRecord The axis line format record defines the axis type details.
class | AxisOptionsRecord The axis options record provides unit information and other various tidbits about the axis.
class | AxisParentRecord The axis size and location
class | AxisRecord The axis record defines the type of an axis.
class | AxisUsedRecord The number of axes used on a chart.
class | BarRecord The bar record is used to define a bar chart.
class | BeginRecord The begin record defines the start of a block of records for a (grpahing data object.
class | CategorySeriesAxisRecord This record refers to a category or series axis and is used to specify label/tickmark frequency.
class | CatLabRecord CATLAB - Category Labels (0x0856)
class | ChartEndBlockRecord ENDBLOCK - Chart Future Record Type End Block (0x0853)
class | ChartEndObjectRecord ENDOBJECT - Chart Future Record Type End Object (0x0855)
class | ChartFormatRecord Class ChartFormatRecord (0x1014) (As with all chart related records, documentation is lacking.
class | ChartFRTInfoRecord CHARTFRTINFO - Chart Future Record Type Info (0x0850)
class | ChartRecord CHART (0x1002) The chart record is used to define the location and size of a chart. Chart related records don't seem to be covered in either the OOO or the MS documentation.
class | ChartStartBlockRecord STARTBLOCK - Chart Future Record Type Start Block (0x0852)
class | ChartStartObjectRecord STARTOBJECT - Chart Future Record Type Start Object (0x0854)
class | ChartTitleFormatRecord CHARTTITLEFORMAT (0x1050) Describes the formatting runs associated with a chart title.
class | DataFormatRecord The data format record is used to index into a series.
class | DataLabelExtensionRecord DATALABEXT - Chart Data Label Extension (0x086A)
class | DatRecord The dat record is used to store options for the chart.
class | DefaultDataLabelTextPropertiesRecord The default data label text properties record identifies the text characteristics of the preceding text record.
class | EndRecord The end record defines the end of a block of records for a (Graphing) data object.
class | FontBasisRecord The font basis record stores various font metrics.
class | FontIndexRecord The font index record indexes into the font table for the text record.
class | FrameRecord The frame record indicates whether there is a border around the displayed text of a chart.
class | LegendRecord Defines a legend for a chart.
class | LineFormatRecord Describes a line format record.
class | LinkedDataRecord Describes a linked data record.
class | NumberFormatIndexRecord The number format index record indexes format table.
class | ObjectLinkRecord Links text to an object on the chart or identifies it as the title.
class | PlotAreaRecord preceeds and identifies a frame as belonging to the plot area.
class | PlotGrowthRecord The plot growth record specifies the scaling factors used when a font is scaled.
class | SeriesChartGroupIndexRecord The series chart group index record stores the index to the CHARTFORMAT record (0 based).
class | SeriesIndexRecord links a series to its position in the series list.
class | SeriesLabelsRecord The series label record defines the type of label associated with the data format record.
class | SeriesListRecord SERIESLIST (0x1016) The series list record defines the series displayed as an overlay to the main chart record. (As with all chart related records, documentation is lacking.
class | SeriesRecord The series record describes the overall data for a series.
class | SeriesTextRecord SERIESTEXT (0x100D)
class | SeriesToChartGroupRecord Indicates the chart-group index for a series.
class | SheetPropertiesRecord Describes a chart sheet properties record.
class | TextRecord The text record is used to define text stored on a chart.
class | TickRecord The Tick record defines how tick marks and label positioning/formatting
class | UnitsRecord The units record describes units.
class | ValueRangeRecord The value range record defines the range of the value axis.

Uses of StandardRecord in org.apache.poi.hssf.record.pivottable

Subclasses of StandardRecord in org.apache.poi.hssf.record.pivottable
class | DataItemRecord SXDI - Data Item (0x00C5)
class | ExtendedPivotTableViewFieldsRecord SXVDEX - Extended PivotTable View Fields (0x0100)
class | PageItemRecord SXPI - Page Item (0x00B6)
class | StreamIDRecord SXIDSTM - Stream ID (0x00D5)
class | ViewDefinitionRecord SXVIEW - View Definition (0x00B0)
class | ViewFieldsRecord SXVD - View Fields (0x00B1)
class | ViewSourceRecord SXVS - View Source (0x00E3)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.StringRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.StringRecord

Packages that use StringRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of StringRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return StringRecord
 StringRecord FormulaRecordAggregate.getStringRecord()
debug only TODO - encapsulate

Constructors in org.apache.poi.hssf.record.aggregates with parameters of type StringRecord
FormulaRecordAggregate(FormulaRecord formulaRec, StringRecord stringRec, SharedValueManager svm)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.StyleRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.StyleRecord

Packages that use StyleRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of StyleRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return StyleRecord
StyleRecord | InternalWorkbook.createStyleRecord(int xfIndex) Creates a new StyleRecord, for the given Extended Format index, and adds it onto the end of the records collection
StyleRecord | InternalWorkbook.getStyleRecord(int xfIndex) Returns the StyleRecord for the given xfIndex, or null if that ExtendedFormat doesn't have a Style set.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SubRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SubRecord

Packages that use SubRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of SubRecord in org.apache.poi.hssf.record

Subclasses of SubRecord in org.apache.poi.hssf.record
class | CommonObjectDataSubRecord The common object data record is used to store all common preferences for an excel object.
class | EmbeddedObjectRefSubRecord ftPictFmla (0x0009) A sub-record within the OBJ record which stores a reference to an object stored in a separate entry within the OLE2 compound file.
class | EndSubRecord ftEnd (0x0000) The end data record is used to denote the end of the subrecords.
class | FtCblsSubRecord This structure appears as part of an Obj record that represents a checkbox or radio button.
class | GroupMarkerSubRecord ftGmo (0x0006) The group marker record is used as a position holder for groups.
class | LbsDataSubRecord This structure specifies the properties of a list or drop-down list embedded object in a sheet.
class | NoteStructureSubRecord ftNts (0x000D) Represents a NoteStructure sub record.

Methods in org.apache.poi.hssf.record that return SubRecord
static SubRecord SubRecord.createSubRecord(LittleEndianInput in, int cmoOt)
read a sub-record from the supplied stream

Methods in org.apache.poi.hssf.record that return types with arguments of type SubRecord
 java.util.List<SubRecord> ObjRecord.getSubRecords()

Methods in org.apache.poi.hssf.record with parameters of type SubRecord
void | ObjRecord.addSubRecord(int index, SubRecord element)
boolean | ObjRecord.addSubRecord(SubRecord o)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.SupBookRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.SupBookRecord

Packages that use SupBookRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of SupBookRecord in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return SupBookRecord
static SupBookRecord | SupBookRecord.createAddInFunctions()
static SupBookRecord | SupBookRecord.createExternalReferences(java.lang.String url, java.lang.String[] sheetNames)
static SupBookRecord | SupBookRecord.createInternalReferences(short numberOfSheets)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.TabIdRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.TabIdRecord

No usage of org.apache.poi.hssf.record.TabIdRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.TableRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.TableRecord

Packages that use TableRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of TableRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type TableRecord
static SharedValueManager SharedValueManager.create(SharedFormulaRecord[] sharedFormulaRecords, CellReference[] firstCells, ArrayRecord[] arrayRecords, TableRecord[] tableRecords)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.TableStylesRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.TableStylesRecord

No usage of org.apache.poi.hssf.record.TableStylesRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.TextObjectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.TextObjectRecord

Packages that use TextObjectRecord
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of TextObjectRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return TextObjectRecord
 TextObjectRecord TextboxShape.getTextObjectRecord()

Uses of TextObjectRecord in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return TextObjectRecord
protected  TextObjectRecord HSSFComment.getTextObjectRecord()
Returns the underlying Text record

Constructors in org.apache.poi.hssf.usermodel with parameters of type TextObjectRecord
HSSFComment(NoteRecord note, TextObjectRecord txo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.TopMarginRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.TopMarginRecord

No usage of org.apache.poi.hssf.record.TopMarginRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.UncalcedRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.UncalcedRecord

No usage of org.apache.poi.hssf.record.UncalcedRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.UnicodeString

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.UnicodeString

No usage of org.apache.poi.hssf.record.UnicodeString

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.UnknownRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.UnknownRecord

No usage of org.apache.poi.hssf.record.UnknownRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.UserSViewBegin

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.UserSViewBegin

No usage of org.apache.poi.hssf.record.UserSViewBegin

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.UserSViewEnd

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.UserSViewEnd

No usage of org.apache.poi.hssf.record.UserSViewEnd

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.UseSelFSRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.UseSelFSRecord

No usage of org.apache.poi.hssf.record.UseSelFSRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.VCenterRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.VCenterRecord

Packages that use VCenterRecord
org.apache.poi.hssf.record.aggregates record aggregates are not real "records" but collections of records that act as a single record.

Uses of VCenterRecord in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return VCenterRecord
 VCenterRecord PageSettingsBlock.getVCenter()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.VerticalPageBreakRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.VerticalPageBreakRecord

No usage of org.apache.poi.hssf.record.VerticalPageBreakRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.WindowOneRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.WindowOneRecord

Packages that use WindowOneRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of WindowOneRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return WindowOneRecord
 WindowOneRecord InternalWorkbook.getWindowOne()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.WindowProtectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.WindowProtectRecord

No usage of org.apache.poi.hssf.record.WindowProtectRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.WindowTwoRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.WindowTwoRecord

Packages that use WindowTwoRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of WindowTwoRecord in org.apache.poi.hssf.model

Fields in org.apache.poi.hssf.model declared as WindowTwoRecord
protected  WindowTwoRecord InternalSheet.windowTwo

Methods in org.apache.poi.hssf.model that return WindowTwoRecord
 WindowTwoRecord InternalSheet.getWindowTwo()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.WriteAccessRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.WriteAccessRecord

Packages that use WriteAccessRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of WriteAccessRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return WriteAccessRecord
 WriteAccessRecord InternalWorkbook.getWriteAccess()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.WriteProtectRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.WriteProtectRecord

Packages that use WriteProtectRecord
org.apache.poi.hssf.model Provides low level API structures for reading, writing, modifying XLS files.

Uses of WriteProtectRecord in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return WriteProtectRecord
 WriteProtectRecord InternalWorkbook.getWriteProtect()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.WSBoolRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.WSBoolRecord

No usage of org.apache.poi.hssf.record.WSBoolRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FeatFormulaErr2

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class FeatFormulaErr2

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.FeatFormulaErr2
All Implemented Interfaces:
SharedFeature
public final class FeatFormulaErr2
extends java.lang.Object
implements SharedFeature

Title: FeatFormulaErr2 (Formula Evaluation Shared Feature) common record part

This record part specifies Formula Evaluation & Error Ignoring data for a sheet, stored as part of a Shared Feature. It can be found in records such as FeatRecord. For the full meanings of the flags, see pages 669 and 670 of the Excel binary file format documentation.

Constructor Summary
FeatFormulaErr2()
FeatFormulaErr2(RecordInputStream in)
Method Summary
int | _getRawErrorCheckValue()
boolean | getCheckCalculationErrors()
boolean | getCheckDateTimeFormats()
boolean | getCheckEmptyCellRef()
boolean | getCheckInconsistentFormulas()
boolean | getCheckInconsistentRanges()
boolean | getCheckNumbersAsText()
boolean | getCheckUnprotectedFormulas()
int | getDataSize()
boolean | getPerformDataValidation()
void | serialize(LittleEndianOutput out)
void | setCheckCalculationErrors(boolean checkCalculationErrors)
void | setCheckDateTimeFormats(boolean checkDateTimeFormats)
void | setCheckEmptyCellRef(boolean checkEmptyCellRef)
void | setCheckInconsistentFormulas(boolean checkInconsistentFormulas)
void | setCheckInconsistentRanges(boolean checkInconsistentRanges)
void | setCheckNumbersAsText(boolean checkNumbersAsText)
void | setCheckUnprotectedFormulas(boolean checkUnprotectedFormulas)
void | setPerformDataValidation(boolean performDataValidation)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FeatFormulaErr2

public FeatFormulaErr2()

FeatFormulaErr2

public FeatFormulaErr2(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Specified by:
toString in interface SharedFeature
Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in interface SharedFeature

getDataSize

public int getDataSize()
Specified by:
getDataSize in interface SharedFeature

_getRawErrorCheckValue

public int _getRawErrorCheckValue()

getCheckCalculationErrors

public boolean getCheckCalculationErrors()

setCheckCalculationErrors

public void setCheckCalculationErrors(boolean checkCalculationErrors)

getCheckEmptyCellRef

public boolean getCheckEmptyCellRef()

setCheckEmptyCellRef

public void setCheckEmptyCellRef(boolean checkEmptyCellRef)

getCheckNumbersAsText

public boolean getCheckNumbersAsText()

setCheckNumbersAsText

public void setCheckNumbersAsText(boolean checkNumbersAsText)

getCheckInconsistentRanges

public boolean getCheckInconsistentRanges()

setCheckInconsistentRanges

public void setCheckInconsistentRanges(boolean checkInconsistentRanges)

getCheckInconsistentFormulas

public boolean getCheckInconsistentFormulas()

setCheckInconsistentFormulas

public void setCheckInconsistentFormulas(boolean checkInconsistentFormulas)

getCheckDateTimeFormats

public boolean getCheckDateTimeFormats()

setCheckDateTimeFormats

public void setCheckDateTimeFormats(boolean checkDateTimeFormats)

getCheckUnprotectedFormulas

public boolean getCheckUnprotectedFormulas()

setCheckUnprotectedFormulas

public void setCheckUnprotectedFormulas(boolean checkUnprotectedFormulas)

getPerformDataValidation

public boolean getPerformDataValidation()

setPerformDataValidation

public void setPerformDataValidation(boolean performDataValidation)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FeatProtection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class FeatProtection

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.FeatProtection
All Implemented Interfaces:
SharedFeature
public final class FeatProtection
extends java.lang.Object
implements SharedFeature

Title: FeatProtection (Protection Shared Feature) common record part

This record part specifies Protection data for a sheet, stored as part of a Shared Feature. It can be found in records such as FeatRecord

Field Summary
static long | HAS_SELF_RELATIVE_SECURITY_FEATURE
static long | NO_SELF_RELATIVE_SECURITY_FEATURE
Constructor Summary
FeatProtection()
FeatProtection(RecordInputStream in)
Method Summary
int | getDataSize()
int | getFSD()
int | getPasswordVerifier()
java.lang.String | getTitle()
void | serialize(LittleEndianOutput out)
void | setPasswordVerifier(int passwordVerifier)
void | setTitle(java.lang.String title)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NO_SELF_RELATIVE_SECURITY_FEATURE

public static long NO_SELF_RELATIVE_SECURITY_FEATURE

HAS_SELF_RELATIVE_SECURITY_FEATURE

public static long HAS_SELF_RELATIVE_SECURITY_FEATURE
Constructor Detail

FeatProtection

public FeatProtection()

FeatProtection

public FeatProtection(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Specified by:
toString in interface SharedFeature
Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in interface SharedFeature

getDataSize

public int getDataSize()
Specified by:
getDataSize in interface SharedFeature

getPasswordVerifier

public int getPasswordVerifier()

setPasswordVerifier

public void setPasswordVerifier(int passwordVerifier)

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String title)

getFSD

public int getFSD()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeatSmartTag

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class FeatSmartTag

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.FeatSmartTag
All Implemented Interfaces:
SharedFeature
public final class FeatSmartTag
extends java.lang.Object
implements SharedFeature

Title: FeatSmartTag (Smart Tag Shared Feature) common record part

This record part specifies Smart Tag data for a sheet, stored as part of a Shared Feature. It can be found in records such as FeatRecord. It is made up of a hash, and a set of Factoid Data that makes up the smart tags. For more details, see page 669 of the Excel binary file format documentation.

Constructor Summary
FeatSmartTag()
FeatSmartTag(RecordInputStream in)
Method Summary
int | getDataSize()
void | serialize(LittleEndianOutput out)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FeatSmartTag

public FeatSmartTag()

FeatSmartTag

public FeatSmartTag(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Specified by:
toString in interface SharedFeature
Overrides:
toString in class java.lang.Object

getDataSize

public int getDataSize()
Specified by:
getDataSize in interface SharedFeature

serialize

public void serialize(LittleEndianOutput out)
Specified by:
serialize in interface SharedFeature
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FtrHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class FtrHeader

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.FtrHeader

public final class FtrHeader
extends java.lang.Object

Title: FtrHeader (Future Record Header) common record part

This record part specifies a header for a Ftr (Future) style record, which includes extra attributes above and beyond those of a traditional record.

Constructor Summary
FtrHeader()
FtrHeader(RecordInputStream in)
Method Summary
static int | getDataSize()
short | getGrbitFrt()
short | getRecordType()
byte[] | getReserved()
void | serialize(LittleEndianOutput out)
void | setGrbitFrt(short grbitFrt)
void | setRecordType(short recordType)
void | setReserved(byte[] reserved)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FtrHeader

public FtrHeader()

FtrHeader

public FtrHeader(RecordInputStream in)
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)

getDataSize

public static int getDataSize()

getRecordType

public short getRecordType()

setRecordType

public void setRecordType(short recordType)

getGrbitFrt

public short getGrbitFrt()

setGrbitFrt

public void setGrbitFrt(short grbitFrt)

getReserved

public byte[] getReserved()

setReserved

public void setReserved(byte[] reserved)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record.common
Interfaces
SharedFeature
Classes
FeatFormulaErr2
FeatProtection
FeatSmartTag
FtrHeader
UnicodeString
UnicodeString.ExtRst
UnicodeString.FormatRun
UnicodeString.PhRun


org.apache.poi.hssf.record.common

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record.common

Interface Summary
SharedFeature Common Interface for all Shared Features

Class Summary
FeatFormulaErr2 | Title: FeatFormulaErr2 (Formula Evaluation Shared Feature) common record part
FeatProtection | Title: FeatProtection (Protection Shared Feature) common record part
FeatSmartTag | Title: FeatSmartTag (Smart Tag Shared Feature) common record part
FtrHeader | Title: FtrHeader (Future Record Header) common record part
UnicodeString | Title: Unicode String Description: Unicode String - just standard fields that are in several records.
UnicodeString.ExtRst |
UnicodeString.FormatRun |
UnicodeString.PhRun |


org.apache.poi.hssf.record.common Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record.common

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.common.FeatFormulaErr2 (implements org.apache.poi.hssf.record.common.SharedFeature)
    • org.apache.poi.hssf.record.common.FeatProtection (implements org.apache.poi.hssf.record.common.SharedFeature)
    • org.apache.poi.hssf.record.common.FeatSmartTag (implements org.apache.poi.hssf.record.common.SharedFeature)
    • org.apache.poi.hssf.record.common.FtrHeader
    • org.apache.poi.hssf.record.common.UnicodeString (implements java.lang.Comparable<T>)
    • org.apache.poi.hssf.record.common.UnicodeString.ExtRst (implements java.lang.Comparable<T>)
    • org.apache.poi.hssf.record.common.UnicodeString.FormatRun (implements java.lang.Comparable<T>)
    • org.apache.poi.hssf.record.common.UnicodeString.PhRun

Interface Hierarchy

  • org.apache.poi.hssf.record.common.SharedFeature


Uses of Package org.apache.poi.hssf.record.common

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record.common

Packages that use org.apache.poi.hssf.record.common
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.common |

Classes in org.apache.poi.hssf.record.common used by org.apache.poi.hssf.model
UnicodeString
Title: Unicode String

Description: Unicode String - just standard fields that are in several records.

Classes in org.apache.poi.hssf.record.common used by org.apache.poi.hssf.record
SharedFeature
Common Interface for all Shared Features
UnicodeString
Title: Unicode String

Description: Unicode String - just standard fields that are in several records.

Classes in org.apache.poi.hssf.record.common used by org.apache.poi.hssf.record.common
SharedFeature
Common Interface for all Shared Features
UnicodeString.ExtRst
UnicodeString.FormatRun
UnicodeString.PhRun

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SharedFeature

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Interface SharedFeature

All Known Implementing Classes:
FeatFormulaErr2, FeatProtection, FeatSmartTag
public interface SharedFeature

Common Interface for all Shared Features

Method Summary
int | getDataSize()
void | serialize(LittleEndianOutput out)
java.lang.String | toString()

Method Detail

toString

java.lang.String toString()
Overrides:
toString in class java.lang.Object

serialize

void serialize(LittleEndianOutput out)

getDataSize

int getDataSize()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnicodeString.ExtRst

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class UnicodeString.ExtRst

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.UnicodeString.ExtRst
All Implemented Interfaces:
java.lang.Comparable<UnicodeString.ExtRst>
Enclosing class:
UnicodeString
public static class UnicodeString.ExtRst
extends java.lang.Object
implements java.lang.Comparable<UnicodeString.ExtRst>

Constructor Summary
protected | UnicodeString.ExtRst()
protected | UnicodeString.ExtRst(LittleEndianInput in, int expectedLength)
Method Summary
protected UnicodeString.ExtRst | clone()
int | compareTo(UnicodeString.ExtRst o)
boolean | equals(java.lang.Object obj)
protected int | getDataSize() Returns our size, excluding our 4 byte header
short | getFormattingFontIndex()
short | getFormattingOptions()
int | getNumberOfRuns()
java.lang.String | getPhoneticText()
UnicodeString.PhRun[] | getPhRuns()
protected void | serialize(ContinuableRecordOutput out)
Methods inherited from class java.lang.Object
finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnicodeString.ExtRst

protected UnicodeString.ExtRst()

UnicodeString.ExtRst

protected UnicodeString.ExtRst(LittleEndianInput in,
                               int expectedLength)
Method Detail

getDataSize

protected int getDataSize()
Returns our size, excluding our 4 byte header

serialize

protected void serialize(ContinuableRecordOutput out)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

compareTo

public int compareTo(UnicodeString.ExtRst o)
Specified by:
compareTo in interface java.lang.Comparable<UnicodeString.ExtRst>

clone

protected UnicodeString.ExtRst clone()
Overrides:
clone in class java.lang.Object

getFormattingFontIndex

public short getFormattingFontIndex()

getFormattingOptions

public short getFormattingOptions()

getNumberOfRuns

public int getNumberOfRuns()

getPhoneticText

public java.lang.String getPhoneticText()

getPhRuns

public UnicodeString.PhRun[] getPhRuns()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnicodeString.FormatRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class UnicodeString.FormatRun

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.UnicodeString.FormatRun
All Implemented Interfaces:
java.lang.Comparable<UnicodeString.FormatRun>
Enclosing class:
UnicodeString
public static class UnicodeString.FormatRun
extends java.lang.Object
implements java.lang.Comparable<UnicodeString.FormatRun>

Constructor Summary
UnicodeString.FormatRun(LittleEndianInput in)
UnicodeString.FormatRun(short character, short fontIndex)
Method Summary
int | compareTo(UnicodeString.FormatRun r)
boolean | equals(java.lang.Object o)
short | getCharacterPos()
short | getFontIndex()
void | serialize(LittleEndianOutput out)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnicodeString.FormatRun

public UnicodeString.FormatRun(short character,
                               short fontIndex)

UnicodeString.FormatRun

public UnicodeString.FormatRun(LittleEndianInput in)
Method Detail

getCharacterPos

public short getCharacterPos()

getFontIndex

public short getFontIndex()

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

compareTo

public int compareTo(UnicodeString.FormatRun r)
Specified by:
compareTo in interface java.lang.Comparable<UnicodeString.FormatRun>

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

serialize

public void serialize(LittleEndianOutput out)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnicodeString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class UnicodeString

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.UnicodeString
All Implemented Interfaces:
java.lang.Comparable<UnicodeString>
Direct Known Subclasses:
UnicodeString
public class UnicodeString
extends java.lang.Object
implements java.lang.Comparable<UnicodeString>

Title: Unicode String

Description: Unicode String - just standard fields that are in several records. It is considered more desirable then repeating it in all of them.

This is often called a XLUnicodeRichExtendedString in MS documentation.

REFERENCE: PG 264 Microsoft Excel 97 Developer's Kit (ISBN: 1-57231-498-2)

REFERENCE: PG 951 Excel Binary File Format (.xls) Structure Specification v20091214

Nested Class Summary
static class | UnicodeString.ExtRst
static class | UnicodeString.FormatRun
static class | UnicodeString.PhRun
Constructor Summary
UnicodeString(RecordInputStream in)
construct a unicode string record and fill its fields, ID is ignored
UnicodeString(java.lang.String str)
Method Summary
 void addFormatRun(UnicodeString.FormatRun r)
Adds a font run to the formatted string.
 void clearFormatting()
 java.lang.Object clone()
 int compareTo(UnicodeString str)
 boolean equals(java.lang.Object o)
Our handling of equals is inconsistent with compareTo.
 java.util.Iterator<UnicodeString.FormatRun> formatIterator()
 int getCharCount()
get the number of characters in the string, as an un-wrapped int
 short getCharCountShort()
get the number of characters in the string, wrapped as needed to fit within a short
 java.lang.String getDebugInfo()
return a character representation of the fields of this record
 UnicodeString.ExtRst getExtendedRst()
 UnicodeString.FormatRun getFormatRun(int index)
 int getFormatRunCount()
 byte getOptionFlags()
get the option flags which among other things return if this is a 16-bit or 8 bit string
 java.lang.String getString()
 int hashCode()
 void removeFormatRun(UnicodeString.FormatRun r)
 void serialize(ContinuableRecordOutput out)
Serialises out the String.
 void setCharCount(short cc)
set the number of characters in the string
 void setOptionFlags(byte of)
set the option flags which among other things return if this is a 16-bit or 8 bit string
 void setString(java.lang.String string)
set the actual string this contains
 void swapFontUse(short oldFontIndex, short newFontIndex)
Swaps all use in the string of one font index for use of a different font index.
 java.lang.String toString()
unlike the real records we return the same as "getString()" rather than debug info
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

UnicodeString

public UnicodeString(java.lang.String str)

UnicodeString

public UnicodeString(RecordInputStream in)
construct a unicode string record and fill its fields, ID is ignored

Parameters:
in - the RecordInputstream to read the record from
Method Detail

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object o)
Our handling of equals is inconsistent with compareTo. The trouble is because we don't truely understand rich text fields yet it's difficult to make a sound comparison.

Overrides:
equals in class java.lang.Object
Parameters:
o - The object to compare.
Returns:
true if the object is actually equal.

getCharCount

public int getCharCount()
get the number of characters in the string, as an un-wrapped int

Returns:
number of characters

getCharCountShort

public short getCharCountShort()
get the number of characters in the string, wrapped as needed to fit within a short

Returns:
number of characters

setCharCount

public void setCharCount(short cc)
set the number of characters in the string

Parameters:
cc - - number of characters

getOptionFlags

public byte getOptionFlags()
get the option flags which among other things return if this is a 16-bit or 8 bit string

Returns:
optionflags bitmask

setOptionFlags

public void setOptionFlags(byte of)
set the option flags which among other things return if this is a 16-bit or 8 bit string

Parameters:
of - optionflags bitmask

getString

public java.lang.String getString()
Returns:
the actual string this contains as a java String object

setString

public void setString(java.lang.String string)
set the actual string this contains

Parameters:
string - the text

getFormatRunCount

public int getFormatRunCount()

getFormatRun

public UnicodeString.FormatRun getFormatRun(int index)

addFormatRun

public void addFormatRun(UnicodeString.FormatRun r)
Adds a font run to the formatted string. If a font run exists at the current charcter location, then it is replaced with the font run to be added.

formatIterator

public java.util.Iterator<UnicodeString.FormatRun> formatIterator()

removeFormatRun

public void removeFormatRun(UnicodeString.FormatRun r)

clearFormatting

public void clearFormatting()

getExtendedRst

public UnicodeString.ExtRst getExtendedRst()

swapFontUse

public void swapFontUse(short oldFontIndex,
                        short newFontIndex)
Swaps all use in the string of one font index for use of a different font index. Normally only called when fonts have been removed / re-ordered

toString

public java.lang.String toString()
unlike the real records we return the same as "getString()" rather than debug info

Overrides:
toString in class java.lang.Object
Returns:
String value of the record
See Also:
getDebugInfo()

getDebugInfo

public java.lang.String getDebugInfo()
return a character representation of the fields of this record

Returns:
String of output for biffviewer etc.

serialize

public void serialize(ContinuableRecordOutput out)
Serialises out the String. There are special rules about where we can and can't split onto Continue records.

compareTo

public int compareTo(UnicodeString str)
Specified by:
compareTo in interface java.lang.Comparable<UnicodeString>

clone

public java.lang.Object clone()
Overrides:
clone in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnicodeString.PhRun

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.common
Class UnicodeString.PhRun

java.lang.Object
    extended by  org.apache.poi.hssf.record.common.UnicodeString.PhRun
Enclosing class:
UnicodeString
public static class UnicodeString.PhRun
extends java.lang.Object

Constructor Summary
UnicodeString.PhRun(int phoneticTextFirstCharacterOffset, int realTextFirstCharacterOffset, int realTextLength)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnicodeString.PhRun

public UnicodeString.PhRun(int phoneticTextFirstCharacterOffset,
                           int realTextFirstCharacterOffset,
                           int realTextLength)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.record.common.FeatFormulaErr2

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.FeatFormulaErr2

No usage of org.apache.poi.hssf.record.common.FeatFormulaErr2

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.common.FeatProtection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.FeatProtection

No usage of org.apache.poi.hssf.record.common.FeatProtection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.common.FeatSmartTag

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.FeatSmartTag

No usage of org.apache.poi.hssf.record.common.FeatSmartTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.common.FtrHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.FtrHeader

No usage of org.apache.poi.hssf.record.common.FtrHeader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.record.common.SharedFeature

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.record.common.SharedFeature

Packages that use SharedFeature
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.common |

Uses of SharedFeature in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return SharedFeature
 SharedFeature FeatRecord.getSharedFeature()

Methods in org.apache.poi.hssf.record with parameters of type SharedFeature
 void FeatRecord.setSharedFeature(SharedFeature feature)

Uses of SharedFeature in org.apache.poi.hssf.record.common

Classes in org.apache.poi.hssf.record.common that implement SharedFeature
class | FeatFormulaErr2 Title: FeatFormulaErr2 (Formula Evaluation Shared Feature) common record part
class | FeatProtection Title: FeatProtection (Protection Shared Feature) common record part
class | FeatSmartTag Title: FeatSmartTag (Smart Tag Shared Feature) common record part

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.common.UnicodeString.ExtRst

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.UnicodeString.ExtRst

Packages that use UnicodeString.ExtRst
org.apache.poi.hssf.record.common

Uses of UnicodeString.ExtRst in org.apache.poi.hssf.record.common

Methods in org.apache.poi.hssf.record.common that return UnicodeString.ExtRst
protected UnicodeString.ExtRst | UnicodeString.ExtRst.clone()
UnicodeString.ExtRst | UnicodeString.getExtendedRst()

Methods in org.apache.poi.hssf.record.common with parameters of type UnicodeString.ExtRst
 int UnicodeString.ExtRst.compareTo(UnicodeString.ExtRst o)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.common.UnicodeString.FormatRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.UnicodeString.FormatRun

Packages that use UnicodeString.FormatRun
org.apache.poi.hssf.record.common

Uses of UnicodeString.FormatRun in org.apache.poi.hssf.record.common

Methods in org.apache.poi.hssf.record.common that return UnicodeString.FormatRun
 UnicodeString.FormatRun UnicodeString.getFormatRun(int index)

Methods in org.apache.poi.hssf.record.common that return types with arguments of type UnicodeString.FormatRun
 java.util.Iterator<UnicodeString.FormatRun> UnicodeString.formatIterator()

Methods in org.apache.poi.hssf.record.common with parameters of type UnicodeString.FormatRun
void | UnicodeString.addFormatRun(UnicodeString.FormatRun r) Adds a font run to the formatted string.
int | UnicodeString.FormatRun.compareTo(UnicodeString.FormatRun r)
void | UnicodeString.removeFormatRun(UnicodeString.FormatRun r)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.common.UnicodeString

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.UnicodeString

Packages that use UnicodeString
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.common |

Uses of UnicodeString in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return UnicodeString
 UnicodeString InternalWorkbook.getSSTString(int str)
given an index into the SST table, this function returns the corresponding String value

Methods in org.apache.poi.hssf.model with parameters of type UnicodeString
 int InternalWorkbook.addSSTString(UnicodeString string)
Adds a string to the SST table and returns its index (if its a duplicate just returns its index and update the counts) ASSUMES compressed unicode (meaning 8bit)

Uses of UnicodeString in org.apache.poi.hssf.record

Subclasses of UnicodeString in org.apache.poi.hssf.record
 class UnicodeString
Deprecated. Use UnicodeString instead

Methods in org.apache.poi.hssf.record that return UnicodeString
 UnicodeString SSTRecord.getString(int id)
Get a particular string by its index

Methods in org.apache.poi.hssf.record with parameters of type UnicodeString
 int SSTRecord.addString(UnicodeString string)
Add a string.

Uses of UnicodeString in org.apache.poi.hssf.record.common

Methods in org.apache.poi.hssf.record.common with parameters of type UnicodeString
 int UnicodeString.compareTo(UnicodeString str)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.common.UnicodeString.PhRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.common.UnicodeString.PhRun

Packages that use UnicodeString.PhRun
org.apache.poi.hssf.record.common

Uses of UnicodeString.PhRun in org.apache.poi.hssf.record.common

Methods in org.apache.poi.hssf.record.common that return UnicodeString.PhRun
 UnicodeString.PhRun[] UnicodeString.ExtRst.getPhRuns()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ContinuableRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.cont
Class ContinuableRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.cont.ContinuableRecord
Direct Known Subclasses:
ExtSSTRecord, NameRecord, SSTRecord, StringRecord, TextObjectRecord
public abstract class ContinuableRecord
extends Record

Common superclass of all records that can produce ContinueRecords while being serialized.

Author:
Josh Micich

Constructor Summary
protected ContinuableRecord()
Method Summary
int | getRecordSize() gives the current serialized size of the record.
protected abstract void | serialize(ContinuableRecordOutput out) Serializes this record's content to the supplied data output. The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method.
int | serialize(int offset, byte[] data) called by the class that is responsible for writing this sucker.
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, getSid, serialize, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ContinuableRecord

protected ContinuableRecord()
Method Detail

serialize

protected abstract void serialize(ContinuableRecordOutput out)
Serializes this record's content to the supplied data output.
The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method. Simple data types can be written with the standard LittleEndianOutput methods. Methods from ContinuableRecordOutput can be used to serialize strings (with ContinueRecords being written as required). If necessary, implementors can explicitly start ContinueRecords (regardless of the amount of remaining space).

Parameters:
out - a data output stream

getRecordSize

public final int getRecordSize()
Description copied from class: RecordBase
gives the current serialized size of the record. Should include the sid and reclength (4 bytes).

Specified by:
getRecordSize in class RecordBase
Returns:
the total length of the encoded record(s) (Note - if any ContinueRecord is required, this result includes the size of those too)

serialize

public final int serialize(int offset,
                           byte[] data)
Description copied from class: RecordBase
called by the class that is responsible for writing this sucker. Subclasses should implement this so that their data is passed back in a byte array.

Specified by:
serialize in class RecordBase
Parameters:
offset - to begin writing at
data - byte array containing instance data
Returns:
number of bytes written
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ContinuableRecordInput

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.cont
Class ContinuableRecordInput

java.lang.Object
    extended by  org.apache.poi.hssf.record.cont.ContinuableRecordInput
All Implemented Interfaces:
LittleEndianInput
public class ContinuableRecordInput
extends java.lang.Object
implements LittleEndianInput

A decorated RecordInputStream that can read primitive data types (short, int, long, etc.) spanned across a ContinueRecord boundary.

Most records construct themselves from RecordInputStream. This class assumes that a ContinueRecord record break always occurs at the type boundary, however, it is not always so.

Two attachments to Bugzilla 50779 demonstrate that a CONTINUE break can appear right in between two bytes of a unicode character or between two bytes of a short. The problematic portion of the data is in a Asian Phonetic Settings Block (ExtRst) of a UnicodeString.

RecordInputStream greedily requests the bytes to be read and stumbles on such files with a "Not enough data (1) to read requested (2) bytes" exception. The ContinuableRecordInput class circumvents this "type boundary" rule and reads data byte-by-byte rolling over CONTINUE if necessary.

YK: For now (March 2011) this class is only used to read

Author:
Yegor Kozlov

Constructor Summary
ContinuableRecordInput(RecordInputStream in)
Method Summary
int | available()
byte | readByte()
double | readDouble()
void | readFully(byte[] buf)
void | readFully(byte[] buf, int off, int len)
int | readInt()
long | readLong()
short | readShort()
int | readUByte()
int | readUShort()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ContinuableRecordInput

public ContinuableRecordInput(RecordInputStream in)
Method Detail

available

public int available()
Specified by:
available in interface LittleEndianInput

readByte

public byte readByte()
Specified by:
readByte in interface LittleEndianInput

readUByte

public int readUByte()
Specified by:
readUByte in interface LittleEndianInput

readShort

public short readShort()
Specified by:
readShort in interface LittleEndianInput

readUShort

public int readUShort()
Specified by:
readUShort in interface LittleEndianInput

readInt

public int readInt()
Specified by:
readInt in interface LittleEndianInput

readLong

public long readLong()
Specified by:
readLong in interface LittleEndianInput

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput

readFully

public void readFully(byte[] buf)
Specified by:
readFully in interface LittleEndianInput

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContinuableRecordOutput

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.cont
Class ContinuableRecordOutput

java.lang.Object
    extended by  org.apache.poi.hssf.record.cont.ContinuableRecordOutput
All Implemented Interfaces:
LittleEndianOutput
public final class ContinuableRecordOutput
extends java.lang.Object
implements LittleEndianOutput

An augmented LittleEndianOutput used for serialization of ContinuableRecords. This class keeps track of how much remaining space is available in the current BIFF record and can start new ContinueRecords as required.

Author:
Josh Micich

Constructor Summary
ContinuableRecordOutput(LittleEndianOutput out, int sid)
Method Summary
static ContinuableRecordOutput | createForCountingOnly()
int | getAvailableSpace()
int | getTotalSize()
void | write(byte[] b)
void | write(byte[] b, int offset, int len)
void | writeByte(int v)
void | writeContinue() Terminates the current record and starts a new ContinueRecord (regardless of how much space is still available in the current record).
void | writeContinueIfRequired(int requiredContinuousSize) Will terminate the current record and start a new ContinueRecord if there isn't space for the requested number of bytes
void | writeDouble(double v)
void | writeInt(int v)
void | writeLong(long v)
void | writeShort(int v)
void | writeString(java.lang.String text, int numberOfRichTextRuns, int extendedDataSize) Writes a unicode string complete with header and character data.
void | writeStringData(java.lang.String text) Writes the 'optionFlags' byte and encoded character data of a unicode string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ContinuableRecordOutput

public ContinuableRecordOutput(LittleEndianOutput out,
                               int sid)
Method Detail

createForCountingOnly

public static ContinuableRecordOutput createForCountingOnly()

getTotalSize

public int getTotalSize()
Returns:
total number of bytes written so far (including all BIFF headers)

getAvailableSpace

public int getAvailableSpace()
Returns:
number of remaining bytes of space in current record

writeContinue

public void writeContinue()
Terminates the current record and starts a new ContinueRecord (regardless of how much space is still available in the current record).

writeContinueIfRequired

public void writeContinueIfRequired(int requiredContinuousSize)
Will terminate the current record and start a new ContinueRecord if there isn't space for the requested number of bytes

Parameters:
requiredContinuousSize - The number of bytes that need to be written

writeStringData

public void writeStringData(java.lang.String text)
Writes the 'optionFlags' byte and encoded character data of a unicode string. This includes:
  • byte optionFlags
  • encoded character data (in "ISO-8859-1" or "UTF-16LE" encoding)
Notes:
  • The value of the 'is16bitEncoded' flag is determined by the actual character data of text
  • The string options flag is never separated (by a ContinueRecord) from the first chunk of character data it refers to.
  • The 'ushort length' field is assumed to have been explicitly written earlier. Hence, there may be an intervening ContinueRecord

writeString

public void writeString(java.lang.String text,
                        int numberOfRichTextRuns,
                        int extendedDataSize)
Writes a unicode string complete with header and character data. This includes:
  • ushort length
  • byte optionFlags
  • ushort numberOfRichTextRuns (optional)
  • ushort extendedDataSize (optional)
  • encoded character data (in "ISO-8859-1" or "UTF-16LE" encoding)
The following bits of the 'optionFlags' byte will be set as appropriate:
Mask | Description
0x01 | is16bitEncoded
0x04 | hasExtendedData
0x08 | isRichText
Notes:
  • The value of the 'is16bitEncoded' flag is determined by the actual character data of text
  • The string header fields are never separated (by a ContinueRecord) from the first chunk of character data (i.e. the first character is always encoded in the same record as the string header).

write

public void write(byte[] b)
Specified by:
write in interface LittleEndianOutput

write

public void write(byte[] b,
                  int offset,
                  int len)
Specified by:
write in interface LittleEndianOutput

writeByte

public void writeByte(int v)
Specified by:
writeByte in interface LittleEndianOutput

writeDouble

public void writeDouble(double v)
Specified by:
writeDouble in interface LittleEndianOutput

writeInt

public void writeInt(int v)
Specified by:
writeInt in interface LittleEndianOutput

writeLong

public void writeLong(long v)
Specified by:
writeLong in interface LittleEndianOutput

writeShort

public void writeShort(int v)
Specified by:
writeShort in interface LittleEndianOutput
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record.cont
Classes
ContinuableRecord
ContinuableRecordInput
ContinuableRecordOutput


org.apache.poi.hssf.record.cont

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record.cont

Class Summary
ContinuableRecord | Common superclass of all records that can produce ContinueRecords while being serialized.
ContinuableRecordInput | A decorated RecordInputStream that can read primitive data types (short, int, long, etc.) spanned across a ContinueRecord boundary.
ContinuableRecordOutput | An augmented LittleEndianOutput used for serialization of ContinuableRecords.


org.apache.poi.hssf.record.cont Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record.cont

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.cont.ContinuableRecordInput (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.hssf.record.cont.ContinuableRecordOutput (implements org.apache.poi.util.LittleEndianOutput)
    • org.apache.poi.hssf.record.RecordBase
      • org.apache.poi.hssf.record.Record
        • org.apache.poi.hssf.record.cont.ContinuableRecord


Uses of Package org.apache.poi.hssf.record.cont

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record.cont

Packages that use org.apache.poi.hssf.record.cont
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |

Classes in org.apache.poi.hssf.record.cont used by org.apache.poi.hssf.record
ContinuableRecord
Common superclass of all records that can produce ContinueRecords while being serialized.
ContinuableRecordOutput
An augmented LittleEndianOutput used for serialization of ContinuableRecords.

Classes in org.apache.poi.hssf.record.cont used by org.apache.poi.hssf.record.common
ContinuableRecordOutput
An augmented LittleEndianOutput used for serialization of ContinuableRecords.

Classes in org.apache.poi.hssf.record.cont used by org.apache.poi.hssf.record.cont
ContinuableRecordOutput
An augmented LittleEndianOutput used for serialization of ContinuableRecords.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.cont.ContinuableRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.cont.ContinuableRecord

Packages that use ContinuableRecord
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of ContinuableRecord in org.apache.poi.hssf.record

Subclasses of ContinuableRecord in org.apache.poi.hssf.record
class | ExtSSTRecord Title: Extended Static String Table (0x00FF) Description: This record is used for a quick lookup into the SST record.
class | NameRecord Title: DEFINEDNAME Record (0x0018) Description: Defines a named range within a workbook.
class | SSTRecord Title: Static String Table Record (0x00FC) Description: This holds all the strings for LabelSSTRecords.
class | StringRecord STRING (0x0207) Stores the cached result of a text formula
class | TextObjectRecord The TXO record (0x01B6) is used to define the properties of a text box.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.cont.ContinuableRecordInput

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.cont.ContinuableRecordInput

No usage of org.apache.poi.hssf.record.cont.ContinuableRecordInput

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.cont.ContinuableRecordOutput

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.cont.ContinuableRecordOutput

Packages that use ContinuableRecordOutput
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |

Uses of ContinuableRecordOutput in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type ContinuableRecordOutput
protected void | TextObjectRecord.serialize(ContinuableRecordOutput out)
protected void | StringRecord.serialize(ContinuableRecordOutput out)
protected void | SSTRecord.serialize(ContinuableRecordOutput out)
void | NameRecord.serialize(ContinuableRecordOutput out) NameRecord can span into
void | ExtSSTRecord.serialize(ContinuableRecordOutput out)

Uses of ContinuableRecordOutput in org.apache.poi.hssf.record.common

Methods in org.apache.poi.hssf.record.common with parameters of type ContinuableRecordOutput
void | UnicodeString.serialize(ContinuableRecordOutput out) Serialises out the String.
protected void | UnicodeString.ExtRst.serialize(ContinuableRecordOutput out)

Uses of ContinuableRecordOutput in org.apache.poi.hssf.record.cont

Methods in org.apache.poi.hssf.record.cont that return ContinuableRecordOutput
static ContinuableRecordOutput ContinuableRecordOutput.createForCountingOnly()

Methods in org.apache.poi.hssf.record.cont with parameters of type ContinuableRecordOutput
protected abstract  void ContinuableRecord.serialize(ContinuableRecordOutput out)
Serializes this record's content to the supplied data output.
The standard BIFF header (ushort sid, ushort size) has been handled by the superclass, so only BIFF data should be written by this method.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Biff8DecryptingStream

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.crypto
Class Biff8DecryptingStream

java.lang.Object
    extended by  org.apache.poi.hssf.record.crypto.Biff8DecryptingStream
All Implemented Interfaces:
BiffHeaderInput, LittleEndianInput
public final class Biff8DecryptingStream
extends java.lang.Object
implements BiffHeaderInput, LittleEndianInput

Author:
Josh Micich

Constructor Summary
Biff8DecryptingStream(java.io.InputStream in, int initialOffset, Biff8EncryptionKey key)
Method Summary
int | available()
byte | readByte()
int | readDataSize() Reads an unsigned short value without decrypting
double | readDouble()
void | readFully(byte[] buf)
void | readFully(byte[] buf, int off, int len)
int | readInt()
long | readLong()
int | readRecordSID() Reads an unsigned short value without decrypting
short | readShort()
int | readUByte()
int | readUShort()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Biff8DecryptingStream

public Biff8DecryptingStream(java.io.InputStream in,
                             int initialOffset,
                             Biff8EncryptionKey key)
Method Detail

available

public int available()
Specified by:
available in interface BiffHeaderInput
Specified by:
available in interface LittleEndianInput

readRecordSID

public int readRecordSID()
Reads an unsigned short value without decrypting

Specified by:
readRecordSID in interface BiffHeaderInput

readDataSize

public int readDataSize()
Reads an unsigned short value without decrypting

Specified by:
readDataSize in interface BiffHeaderInput

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput

readFully

public void readFully(byte[] buf)
Specified by:
readFully in interface LittleEndianInput

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput

readUByte

public int readUByte()
Specified by:
readUByte in interface LittleEndianInput

readByte

public byte readByte()
Specified by:
readByte in interface LittleEndianInput

readUShort

public int readUShort()
Specified by:
readUShort in interface LittleEndianInput

readShort

public short readShort()
Specified by:
readShort in interface LittleEndianInput

readInt

public int readInt()
Specified by:
readInt in interface LittleEndianInput

readLong

public long readLong()
Specified by:
readLong in interface LittleEndianInput
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Biff8EncryptionKey

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.crypto
Class Biff8EncryptionKey

java.lang.Object
    extended by  org.apache.poi.hssf.record.crypto.Biff8EncryptionKey

public final class Biff8EncryptionKey
extends java.lang.Object

Method Summary
static Biff8EncryptionKey | create(byte[] docId) Create using the default password and a specified docId
static Biff8EncryptionKey | create(java.lang.String password, byte[] docIdData)
static java.lang.String | getCurrentUserPassword()
static void | setCurrentUserPassword(java.lang.String password) Sets the BIFF8 encryption/decryption password for the current thread.
boolean | validate(byte[] saltData, byte[] saltHash)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public static Biff8EncryptionKey create(byte[] docId)
Create using the default password and a specified docId

Parameters:
docId - 16 bytes

create

public static Biff8EncryptionKey create(java.lang.String password,
                                        byte[] docIdData)

validate

public boolean validate(byte[] saltData,
                        byte[] saltHash)
Returns:
true if the keyDigest is compatible with the specified saltData and saltHash

setCurrentUserPassword

public static void setCurrentUserPassword(java.lang.String password)
Sets the BIFF8 encryption/decryption password for the current thread.

Parameters:
password - pass null to clear user password (and use default)

getCurrentUserPassword

public static java.lang.String getCurrentUserPassword()
Returns:
the BIFF8 encryption/decryption password for the current thread. null if it is currently unset.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record.crypto
Classes
Biff8DecryptingStream
Biff8EncryptionKey


org.apache.poi.hssf.record.crypto

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record.crypto

Class Summary
Biff8DecryptingStream
Biff8EncryptionKey


org.apache.poi.hssf.record.crypto Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record.crypto

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.crypto.Biff8DecryptingStream (implements org.apache.poi.hssf.record.BiffHeaderInput, org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.hssf.record.crypto.Biff8EncryptionKey


Uses of Package org.apache.poi.hssf.record.crypto

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record.crypto

Packages that use org.apache.poi.hssf.record.crypto
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.crypto |

Classes in org.apache.poi.hssf.record.crypto used by org.apache.poi.hssf.record
Biff8EncryptionKey

Classes in org.apache.poi.hssf.record.crypto used by org.apache.poi.hssf.record.crypto
Biff8EncryptionKey

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

No usage of org.apache.poi.hssf.record.crypto.Biff8DecryptingStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.crypto.Biff8EncryptionKey

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.crypto.Biff8EncryptionKey

Packages that use Biff8EncryptionKey
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.crypto |

Uses of Biff8EncryptionKey in org.apache.poi.hssf.record

Constructors in org.apache.poi.hssf.record with parameters of type Biff8EncryptionKey
RecordInputStream(java.io.InputStream in, Biff8EncryptionKey key, int initialOffset)

Uses of Biff8EncryptionKey in org.apache.poi.hssf.record.crypto

Methods in org.apache.poi.hssf.record.crypto that return Biff8EncryptionKey
static Biff8EncryptionKey | Biff8EncryptionKey.create(byte[] docId) Create using the default password and a specified docId
static Biff8EncryptionKey | Biff8EncryptionKey.create(java.lang.String password, byte[] docIdData)

Constructors in org.apache.poi.hssf.record.crypto with parameters of type Biff8EncryptionKey
Biff8DecryptingStream(java.io.InputStream in, int initialOffset, Biff8EncryptionKey key)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DataItemRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.pivottable
Class DataItemRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.pivottable.DataItemRecord

public final class DataItemRecord
extends StandardRecord

SXDI - Data Item (0x00C5)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
DataItemRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

DataItemRecord

public DataItemRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ExtendedPivotTableViewFieldsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.pivottable
Class ExtendedPivotTableViewFieldsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

public final class ExtendedPivotTableViewFieldsRecord
extends StandardRecord

SXVDEX - Extended PivotTable View Fields (0x0100)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ExtendedPivotTableViewFieldsRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ExtendedPivotTableViewFieldsRecord

public ExtendedPivotTableViewFieldsRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.record.pivottable
Classes
DataItemRecord
ExtendedPivotTableViewFieldsRecord
PageItemRecord
StreamIDRecord
ViewDefinitionRecord
ViewFieldsRecord
ViewSourceRecord


org.apache.poi.hssf.record.pivottable

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.record.pivottable

Class Summary
DataItemRecord | SXDI - Data Item (0x00C5)
ExtendedPivotTableViewFieldsRecord | SXVDEX - Extended PivotTable View Fields (0x0100)
PageItemRecord | SXPI - Page Item (0x00B6)
StreamIDRecord | SXIDSTM - Stream ID (0x00D5)
ViewDefinitionRecord | SXVIEW - View Definition (0x00B0)
ViewFieldsRecord | SXVD - View Fields (0x00B1)
ViewSourceRecord | SXVS - View Source (0x00E3)


org.apache.poi.hssf.record.pivottable Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.record.pivottable

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hssf.record.RecordBase
      • org.apache.poi.hssf.record.Record
        • org.apache.poi.hssf.record.StandardRecord
          • org.apache.poi.hssf.record.pivottable.DataItemRecord
          • org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord
          • org.apache.poi.hssf.record.pivottable.PageItemRecord
          • org.apache.poi.hssf.record.pivottable.StreamIDRecord
          • org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord
          • org.apache.poi.hssf.record.pivottable.ViewFieldsRecord
          • org.apache.poi.hssf.record.pivottable.ViewSourceRecord


Uses of Package org.apache.poi.hssf.record.pivottable

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.record.pivottable

No usage of org.apache.poi.hssf.record.pivottable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PageItemRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.pivottable
Class PageItemRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.pivottable.PageItemRecord

public final class PageItemRecord
extends StandardRecord

SXPI - Page Item (0x00B6)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
PageItemRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

PageItemRecord

public PageItemRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StreamIDRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.pivottable
Class StreamIDRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.pivottable.StreamIDRecord

public final class StreamIDRecord
extends StandardRecord

SXIDSTM - Stream ID (0x00D5)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
StreamIDRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

StreamIDRecord

public StreamIDRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewDefinitionRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.pivottable
Class ViewDefinitionRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

public final class ViewDefinitionRecord
extends StandardRecord

SXVIEW - View Definition (0x00B0)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ViewDefinitionRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ViewDefinitionRecord

public ViewDefinitionRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewFieldsRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.pivottable
Class ViewFieldsRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

public final class ViewFieldsRecord
extends StandardRecord

SXVD - View Fields (0x00B1)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ViewFieldsRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ViewFieldsRecord

public ViewFieldsRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewSourceRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.record.pivottable
Class ViewSourceRecord

java.lang.Object
    extended by  org.apache.poi.hssf.record.RecordBase
        extended by  org.apache.poi.hssf.record.Record
            extended by  org.apache.poi.hssf.record.StandardRecord
                extended by  org.apache.poi.hssf.record.pivottable.ViewSourceRecord

public final class ViewSourceRecord
extends StandardRecord

SXVS - View Source (0x00E3)

Author:
Patrick Cheng

Field Summary
static short sid
Constructor Summary
ViewSourceRecord(RecordInputStream in)
Method Summary
protected int | getDataSize()
short | getSid() return the non static version of the id for this record.
protected void | serialize(LittleEndianOutput out) Write the data content of this BIFF record.
java.lang.String | toString() get a string representation of the record (for biffview/debugging)
Methods inherited from class org.apache.poi.hssf.record.StandardRecord
getRecordSize, serialize
Methods inherited from class org.apache.poi.hssf.record.Record
clone, cloneViaReserialise, serialize
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ViewSourceRecord

public ViewSourceRecord(RecordInputStream in)
Method Detail

serialize

protected void serialize(LittleEndianOutput out)
Description copied from class: StandardRecord
Write the data content of this BIFF record. The 'ushort sid' and 'ushort size' header fields have already been written by the superclass.
The number of bytes written must equal the record size reported by RecordBase.getRecordSize()} minus four ( record header consiting of a 'ushort sid' and 'ushort reclength' has already been written by thye superclass).

Specified by:
serialize in class StandardRecord

getDataSize

protected int getDataSize()
Specified by:
getDataSize in class StandardRecord

getSid

public short getSid()
Description copied from class: Record
return the non static version of the id for this record.

Specified by:
getSid in class Record

toString

public java.lang.String toString()
Description copied from class: Record
get a string representation of the record (for biffview/debugging)

Overrides:
toString in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.record.pivottable.DataItemRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.pivottable.DataItemRecord

No usage of org.apache.poi.hssf.record.pivottable.DataItemRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

No usage of org.apache.poi.hssf.record.pivottable.ExtendedPivotTableViewFieldsRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.pivottable.PageItemRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.pivottable.PageItemRecord

No usage of org.apache.poi.hssf.record.pivottable.PageItemRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.pivottable.StreamIDRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.pivottable.StreamIDRecord

No usage of org.apache.poi.hssf.record.pivottable.StreamIDRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

No usage of org.apache.poi.hssf.record.pivottable.ViewDefinitionRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

No usage of org.apache.poi.hssf.record.pivottable.ViewFieldsRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.record.pivottable.ViewSourceRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.record.pivottable.ViewSourceRecord

No usage of org.apache.poi.hssf.record.pivottable.ViewSourceRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DummyGraphics2d

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class DummyGraphics2d

java.lang.Object
    extended by  java.awt.Graphics
        extended by  java.awt.Graphics2D
            extended by  org.apache.poi.hssf.usermodel.DummyGraphics2d

public class DummyGraphics2d
extends java.awt.Graphics2D

Constructor Summary
DummyGraphics2d()
Method Summary
void | addRenderingHints(java.util.Map hints)
void | clearRect(int x, int y, int width, int height)
void | clip(java.awt.Shape s)
void | clipRect(int x, int y, int width, int height)
void | copyArea(int x, int y, int width, int height, int dx, int dy)
java.awt.Graphics | create()
java.awt.Graphics | create(int x, int y, int width, int height)
void | dispose()
void | draw(java.awt.Shape s)
void | draw3DRect(int x, int y, int width, int height, boolean raised)
void | drawArc(int x, int y, int width, int height, int startAngle, int arcAngle)
void | drawBytes(byte[] data, int offset, int length, int x, int y)
void | drawChars(char[] data, int offset, int length, int x, int y)
void | drawGlyphVector(java.awt.font.GlyphVector g, float x, float y)
void | drawImage(java.awt.image.BufferedImage img, java.awt.image.BufferedImageOp op, int x, int y)
boolean | drawImage(java.awt.Image img, java.awt.geom.AffineTransform xform, java.awt.image.ImageObserver obs)
boolean | drawImage(java.awt.Image img, int x, int y, java.awt.Color bgcolor, java.awt.image.ImageObserver observer)
boolean | drawImage(java.awt.Image img, int x, int y, java.awt.image.ImageObserver observer)
boolean | drawImage(java.awt.Image img, int x, int y, int width, int height, java.awt.Color bgcolor, java.awt.image.ImageObserver observer)
boolean | drawImage(java.awt.Image img, int x, int y, int width, int height, java.awt.image.ImageObserver observer)
boolean | drawImage(java.awt.Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.Color bgcolor, java.awt.image.ImageObserver observer)
boolean | drawImage(java.awt.Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.image.ImageObserver observer)
void | drawLine(int x1, int y1, int x2, int y2)
void | drawOval(int x, int y, int width, int height)
void | drawPolygon(int[] xPoints, int[] yPoints, int nPoints)
void | drawPolygon(java.awt.Polygon p)
void | drawPolyline(int[] xPoints, int[] yPoints, int nPoints)
void | drawRect(int x, int y, int width, int height)
void | drawRenderableImage(java.awt.image.renderable.RenderableImage img, java.awt.geom.AffineTransform xform)
void | drawRenderedImage(java.awt.image.RenderedImage img, java.awt.geom.AffineTransform xform)
void | drawRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
void | drawString(java.text.AttributedCharacterIterator iterator, float x, float y)
void | drawString(java.text.AttributedCharacterIterator iterator, int x, int y)
void | drawString(java.lang.String s, float x, float y)
void | drawString(java.lang.String str, int x, int y)
void | fill(java.awt.Shape s)
void | fill3DRect(int x, int y, int width, int height, boolean raised)
void | fillArc(int x, int y, int width, int height, int startAngle, int arcAngle)
void | fillOval(int x, int y, int width, int height)
void | fillPolygon(int[] xPoints, int[] yPoints, int nPoints)
void | fillPolygon(java.awt.Polygon p)
void | fillRect(int x, int y, int width, int height)
void | fillRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
void | finalize()
java.awt.Color | getBackground()
java.awt.Shape | getClip()
java.awt.Rectangle | getClipBounds()
java.awt.Rectangle | getClipBounds(java.awt.Rectangle r)
java.awt.Rectangle | getClipRect()
java.awt.Color | getColor()
java.awt.Composite | getComposite()
java.awt.GraphicsConfiguration | getDeviceConfiguration()
java.awt.Font | getFont()
java.awt.FontMetrics | getFontMetrics()
java.awt.FontMetrics | getFontMetrics(java.awt.Font f)
java.awt.font.FontRenderContext | getFontRenderContext()
java.awt.Paint | getPaint()
java.lang.Object | getRenderingHint(java.awt.RenderingHints.Key hintKey)
java.awt.RenderingHints | getRenderingHints()
java.awt.Stroke | getStroke()
java.awt.geom.AffineTransform | getTransform()
boolean | hit(java.awt.Rectangle rect, java.awt.Shape s, boolean onStroke)
boolean | hitClip(int x, int y, int width, int height)
void | rotate(double theta)
void | rotate(double theta, double x, double y)
void | scale(double sx, double sy)
void | setBackground(java.awt.Color color)
void | setClip(int x, int y, int width, int height)
void | setClip(java.awt.Shape clip)
void | setColor(java.awt.Color c)
void | setComposite(java.awt.Composite comp)
void | setFont(java.awt.Font font)
void | setPaint(java.awt.Paint paint)
void | setPaintMode()
void | setRenderingHint(java.awt.RenderingHints.Key hintKey, java.lang.Object hintValue)
void | setRenderingHints(java.util.Map hints)
void | setStroke(java.awt.Stroke s)
void | setTransform(java.awt.geom.AffineTransform Tx)
void | setXORMode(java.awt.Color c1)
void | shear(double shx, double shy)
java.lang.String | toString()
void | transform(java.awt.geom.AffineTransform Tx)
void | translate(double tx, double ty)
void | translate(int x, int y)
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DummyGraphics2d

public DummyGraphics2d()
Method Detail

addRenderingHints

public void addRenderingHints(java.util.Map hints)
Specified by:
addRenderingHints in class java.awt.Graphics2D

clip

public void clip(java.awt.Shape s)
Specified by:
clip in class java.awt.Graphics2D

draw

public void draw(java.awt.Shape s)
Specified by:
draw in class java.awt.Graphics2D

drawGlyphVector

public void drawGlyphVector(java.awt.font.GlyphVector g,
                            float x,
                            float y)
Specified by:
drawGlyphVector in class java.awt.Graphics2D

drawImage

public void drawImage(java.awt.image.BufferedImage img,
                      java.awt.image.BufferedImageOp op,
                      int x,
                      int y)
Specified by:
drawImage in class java.awt.Graphics2D

drawImage

public boolean drawImage(java.awt.Image img,
                         java.awt.geom.AffineTransform xform,
                         java.awt.image.ImageObserver obs)
Specified by:
drawImage in class java.awt.Graphics2D

drawRenderableImage

public void drawRenderableImage(java.awt.image.renderable.RenderableImage img,
                                java.awt.geom.AffineTransform xform)
Specified by:
drawRenderableImage in class java.awt.Graphics2D

drawRenderedImage

public void drawRenderedImage(java.awt.image.RenderedImage img,
                              java.awt.geom.AffineTransform xform)
Specified by:
drawRenderedImage in class java.awt.Graphics2D

drawString

public void drawString(java.text.AttributedCharacterIterator iterator,
                       float x,
                       float y)
Specified by:
drawString in class java.awt.Graphics2D

drawString

public void drawString(java.lang.String s,
                       float x,
                       float y)
Specified by:
drawString in class java.awt.Graphics2D

fill

public void fill(java.awt.Shape s)
Specified by:
fill in class java.awt.Graphics2D

getBackground

public java.awt.Color getBackground()
Specified by:
getBackground in class java.awt.Graphics2D

getComposite

public java.awt.Composite getComposite()
Specified by:
getComposite in class java.awt.Graphics2D

getDeviceConfiguration

public java.awt.GraphicsConfiguration getDeviceConfiguration()
Specified by:
getDeviceConfiguration in class java.awt.Graphics2D

getFontRenderContext

public java.awt.font.FontRenderContext getFontRenderContext()
Specified by:
getFontRenderContext in class java.awt.Graphics2D

getPaint

public java.awt.Paint getPaint()
Specified by:
getPaint in class java.awt.Graphics2D

getRenderingHint

public java.lang.Object getRenderingHint(java.awt.RenderingHints.Key hintKey)
Specified by:
getRenderingHint in class java.awt.Graphics2D

getRenderingHints

public java.awt.RenderingHints getRenderingHints()
Specified by:
getRenderingHints in class java.awt.Graphics2D

getStroke

public java.awt.Stroke getStroke()
Specified by:
getStroke in class java.awt.Graphics2D

getTransform

public java.awt.geom.AffineTransform getTransform()
Specified by:
getTransform in class java.awt.Graphics2D

hit

public boolean hit(java.awt.Rectangle rect,
                   java.awt.Shape s,
                   boolean onStroke)
Specified by:
hit in class java.awt.Graphics2D

rotate

public void rotate(double theta)
Specified by:
rotate in class java.awt.Graphics2D

rotate

public void rotate(double theta,
                   double x,
                   double y)
Specified by:
rotate in class java.awt.Graphics2D

scale

public void scale(double sx,
                  double sy)
Specified by:
scale in class java.awt.Graphics2D

setBackground

public void setBackground(java.awt.Color color)
Specified by:
setBackground in class java.awt.Graphics2D

setComposite

public void setComposite(java.awt.Composite comp)
Specified by:
setComposite in class java.awt.Graphics2D

setPaint

public void setPaint(java.awt.Paint paint)
Specified by:
setPaint in class java.awt.Graphics2D

setRenderingHint

public void setRenderingHint(java.awt.RenderingHints.Key hintKey,
                             java.lang.Object hintValue)
Specified by:
setRenderingHint in class java.awt.Graphics2D

setRenderingHints

public void setRenderingHints(java.util.Map hints)
Specified by:
setRenderingHints in class java.awt.Graphics2D

setStroke

public void setStroke(java.awt.Stroke s)
Specified by:
setStroke in class java.awt.Graphics2D

setTransform

public void setTransform(java.awt.geom.AffineTransform Tx)
Specified by:
setTransform in class java.awt.Graphics2D

shear

public void shear(double shx,
                  double shy)
Specified by:
shear in class java.awt.Graphics2D

transform

public void transform(java.awt.geom.AffineTransform Tx)
Specified by:
transform in class java.awt.Graphics2D

translate

public void translate(double tx,
                      double ty)
Specified by:
translate in class java.awt.Graphics2D

clearRect

public void clearRect(int x,
                      int y,
                      int width,
                      int height)
Specified by:
clearRect in class java.awt.Graphics

clipRect

public void clipRect(int x,
                     int y,
                     int width,
                     int height)
Specified by:
clipRect in class java.awt.Graphics

copyArea

public void copyArea(int x,
                     int y,
                     int width,
                     int height,
                     int dx,
                     int dy)
Specified by:
copyArea in class java.awt.Graphics

create

public java.awt.Graphics create()
Specified by:
create in class java.awt.Graphics

create

public java.awt.Graphics create(int x,
                                int y,
                                int width,
                                int height)
Overrides:
create in class java.awt.Graphics

dispose

public void dispose()
Specified by:
dispose in class java.awt.Graphics

draw3DRect

public void draw3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
Overrides:
draw3DRect in class java.awt.Graphics2D

drawArc

public void drawArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
Specified by:
drawArc in class java.awt.Graphics

drawBytes

public void drawBytes(byte[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
Overrides:
drawBytes in class java.awt.Graphics

drawChars

public void drawChars(char[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
Overrides:
drawChars in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.Color bgcolor,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         java.awt.Color bgcolor,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         int width,
                         int height,
                         java.awt.Color bgcolor,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         int width,
                         int height,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawLine

public void drawLine(int x1,
                     int y1,
                     int x2,
                     int y2)
Specified by:
drawLine in class java.awt.Graphics

drawOval

public void drawOval(int x,
                     int y,
                     int width,
                     int height)
Specified by:
drawOval in class java.awt.Graphics

drawPolygon

public void drawPolygon(java.awt.Polygon p)
Overrides:
drawPolygon in class java.awt.Graphics

drawPolygon

public void drawPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Specified by:
drawPolygon in class java.awt.Graphics

drawPolyline

public void drawPolyline(int[] xPoints,
                         int[] yPoints,
                         int nPoints)
Specified by:
drawPolyline in class java.awt.Graphics

drawRect

public void drawRect(int x,
                     int y,
                     int width,
                     int height)
Overrides:
drawRect in class java.awt.Graphics

drawRoundRect

public void drawRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
Specified by:
drawRoundRect in class java.awt.Graphics

drawString

public void drawString(java.text.AttributedCharacterIterator iterator,
                       int x,
                       int y)
Specified by:
drawString in class java.awt.Graphics2D

drawString

public void drawString(java.lang.String str,
                       int x,
                       int y)
Specified by:
drawString in class java.awt.Graphics2D

fill3DRect

public void fill3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
Overrides:
fill3DRect in class java.awt.Graphics2D

fillArc

public void fillArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
Specified by:
fillArc in class java.awt.Graphics

fillOval

public void fillOval(int x,
                     int y,
                     int width,
                     int height)
Specified by:
fillOval in class java.awt.Graphics

fillPolygon

public void fillPolygon(java.awt.Polygon p)
Overrides:
fillPolygon in class java.awt.Graphics

fillPolygon

public void fillPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Specified by:
fillPolygon in class java.awt.Graphics

fillRect

public void fillRect(int x,
                     int y,
                     int width,
                     int height)
Specified by:
fillRect in class java.awt.Graphics

fillRoundRect

public void fillRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
Specified by:
fillRoundRect in class java.awt.Graphics

finalize

public void finalize()
Overrides:
finalize in class java.awt.Graphics

getClip

public java.awt.Shape getClip()
Specified by:
getClip in class java.awt.Graphics

getClipBounds

public java.awt.Rectangle getClipBounds()
Specified by:
getClipBounds in class java.awt.Graphics

getClipBounds

public java.awt.Rectangle getClipBounds(java.awt.Rectangle r)
Overrides:
getClipBounds in class java.awt.Graphics

getClipRect

public java.awt.Rectangle getClipRect()
Overrides:
getClipRect in class java.awt.Graphics

getColor

public java.awt.Color getColor()
Specified by:
getColor in class java.awt.Graphics

getFont

public java.awt.Font getFont()
Specified by:
getFont in class java.awt.Graphics

getFontMetrics

public java.awt.FontMetrics getFontMetrics()
Overrides:
getFontMetrics in class java.awt.Graphics

getFontMetrics

public java.awt.FontMetrics getFontMetrics(java.awt.Font f)
Specified by:
getFontMetrics in class java.awt.Graphics

hitClip

public boolean hitClip(int x,
                       int y,
                       int width,
                       int height)
Overrides:
hitClip in class java.awt.Graphics

setClip

public void setClip(java.awt.Shape clip)
Specified by:
setClip in class java.awt.Graphics

setClip

public void setClip(int x,
                    int y,
                    int width,
                    int height)
Specified by:
setClip in class java.awt.Graphics

setColor

public void setColor(java.awt.Color c)
Specified by:
setColor in class java.awt.Graphics

setFont

public void setFont(java.awt.Font font)
Specified by:
setFont in class java.awt.Graphics

setPaintMode

public void setPaintMode()
Specified by:
setPaintMode in class java.awt.Graphics

setXORMode

public void setXORMode(java.awt.Color c1)
Specified by:
setXORMode in class java.awt.Graphics

toString

public java.lang.String toString()
Overrides:
toString in class java.awt.Graphics

translate

public void translate(int x,
                      int y)
Specified by:
translate in class java.awt.Graphics2D
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DVConstraint.FormulaPair

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class DVConstraint.FormulaPair

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair
Enclosing class:
DVConstraint
public static final class DVConstraint.FormulaPair
extends java.lang.Object

Constructor Summary
DVConstraint.FormulaPair(Ptg[] formula1, Ptg[] formula2)
Method Summary
Ptg[] | getFormula1()
Ptg[] | getFormula2()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DVConstraint.FormulaPair

public DVConstraint.FormulaPair(Ptg[] formula1,
                                Ptg[] formula2)
Method Detail

getFormula1

public Ptg[] getFormula1()

getFormula2

public Ptg[] getFormula2()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DVConstraint

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class DVConstraint

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.DVConstraint
All Implemented Interfaces:
DataValidationConstraint
public class DVConstraint
extends java.lang.Object
implements DataValidationConstraint

Author:
Josh Micich

Nested Class Summary
static class DVConstraint.FormulaPair
Nested classes/interfaces inherited from interface org.apache.poi.ss.usermodel.DataValidationConstraint
DataValidationConstraint.OperatorType, DataValidationConstraint.ValidationType
Method Summary
static DVConstraint | createCustomFormulaConstraint(java.lang.String formula)
static DVConstraint | createDateConstraint(int comparisonOperator, java.lang.String expr1, java.lang.String expr2, java.lang.String dateFormat) Creates a date based data validation constraint.
static DVConstraint | createExplicitListConstraint(java.lang.String[] explicitListValues)
static DVConstraint | createFormulaListConstraint(java.lang.String listFormula)
static DVConstraint | createNumericConstraint(int validationType, int comparisonOperator, java.lang.String expr1, java.lang.String expr2) Creates a number based data validation constraint.
static DVConstraint | createTimeConstraint(int comparisonOperator, java.lang.String expr1, java.lang.String expr2) Creates a time based data validation constraint.
java.lang.String[] | getExplicitListValues()
java.lang.String | getFormula1()
java.lang.String | getFormula2()
int | getOperator()
int | getValidationType()
java.lang.Double | getValue1()
java.lang.Double | getValue2()
boolean | isExplicitList() Convenience method
boolean | isListValidationType() Convenience method
void | setExplicitListValues(java.lang.String[] explicitListValues)
void | setFormula1(java.lang.String formula1) Sets a formula for expression 1.
void | setFormula2(java.lang.String formula2) Sets a formula for expression 2.
void | setOperator(int operator) Sets the comparison operator for this constraint
void | setValue1(double value1) Sets a numeric value for expression 1.
void | setValue2(double value2) Sets a numeric value for expression 2.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createNumericConstraint

public static DVConstraint createNumericConstraint(int validationType,
                                                   int comparisonOperator,
                                                   java.lang.String expr1,
                                                   java.lang.String expr2)
Creates a number based data validation constraint. The text values entered for expr1 and expr2 can be either standard Excel formulas or formatted number values. If the expression starts with '=' it is parsed as a formula, otherwise it is parsed as a formatted number.

Parameters:
validationType - one of DataValidationConstraint.ValidationType.ANY, DataValidationConstraint.ValidationType.DECIMAL, DataValidationConstraint.ValidationType.INTEGER, DataValidationConstraint.ValidationType.TEXT_LENGTH
comparisonOperator - any constant from DataValidationConstraint.OperatorType enum
expr1 - date formula (when first char is '=') or formatted number value
expr2 - date formula (when first char is '=') or formatted number value

createFormulaListConstraint

public static DVConstraint createFormulaListConstraint(java.lang.String listFormula)

createExplicitListConstraint

public static DVConstraint createExplicitListConstraint(java.lang.String[] explicitListValues)

createTimeConstraint

public static DVConstraint createTimeConstraint(int comparisonOperator,
                                                java.lang.String expr1,
                                                java.lang.String expr2)
Creates a time based data validation constraint. The text values entered for expr1 and expr2 can be either standard Excel formulas or formatted time values. If the expression starts with '=' it is parsed as a formula, otherwise it is parsed as a formatted time. To parse formatted times, two formats are supported: "HH:MM" or "HH:MM:SS". This is contrary to Excel which uses the default time format from the OS.

Parameters:
comparisonOperator - constant from DataValidationConstraint.OperatorType enum
expr1 - date formula (when first char is '=') or formatted time value
expr2 - date formula (when first char is '=') or formatted time value

createDateConstraint

public static DVConstraint createDateConstraint(int comparisonOperator,
                                                java.lang.String expr1,
                                                java.lang.String expr2,
                                                java.lang.String dateFormat)
Creates a date based data validation constraint. The text values entered for expr1 and expr2 can be either standard Excel formulas or formatted date values. If the expression starts with '=' it is parsed as a formula, otherwise it is parsed as a formatted date (Excel uses the same convention). To parse formatted dates, a date format needs to be specified. This is contrary to Excel which uses the default short date format from the OS.

Parameters:
comparisonOperator - constant from DataValidationConstraint.OperatorType enum
expr1 - date formula (when first char is '=') or formatted date value
expr2 - date formula (when first char is '=') or formatted date value
dateFormat - ignored if both expr1 and expr2 are formulas. Default value is "YYYY/MM/DD" otherwise any other valid argument for SimpleDateFormat can be used
See Also:
SimpleDateFormat

createCustomFormulaConstraint

public static DVConstraint createCustomFormulaConstraint(java.lang.String formula)

getValidationType

public int getValidationType()
Specified by:
getValidationType in interface DataValidationConstraint
Returns:
data validation type of this constraint
See Also:
DataValidationConstraint.ValidationType

isListValidationType

public boolean isListValidationType()
Convenience method

Returns:
true if this constraint is a 'list' validation

isExplicitList

public boolean isExplicitList()
Convenience method

Returns:
true if this constraint is a 'list' validation with explicit values

getOperator

public int getOperator()
Specified by:
getOperator in interface DataValidationConstraint
Returns:
the operator used for this constraint
See Also:
DataValidationConstraint.OperatorType

setOperator

public void setOperator(int operator)
Description copied from interface: DataValidationConstraint
Sets the comparison operator for this constraint

Specified by:
setOperator in interface DataValidationConstraint
See Also:
DataValidationConstraint.OperatorType

getExplicitListValues

public java.lang.String[] getExplicitListValues()
Specified by:
getExplicitListValues in interface DataValidationConstraint

setExplicitListValues

public void setExplicitListValues(java.lang.String[] explicitListValues)
Specified by:
setExplicitListValues in interface DataValidationConstraint

getFormula1

public java.lang.String getFormula1()
Specified by:
getFormula1 in interface DataValidationConstraint
Returns:
the formula for expression 1. May be null

setFormula1

public void setFormula1(java.lang.String formula1)
Description copied from interface: DataValidationConstraint
Sets a formula for expression 1.

Specified by:
setFormula1 in interface DataValidationConstraint

getFormula2

public java.lang.String getFormula2()
Specified by:
getFormula2 in interface DataValidationConstraint
Returns:
the formula for expression 2. May be null

setFormula2

public void setFormula2(java.lang.String formula2)
Description copied from interface: DataValidationConstraint
Sets a formula for expression 2.

Specified by:
setFormula2 in interface DataValidationConstraint

getValue1

public java.lang.Double getValue1()
Returns:
the numeric value for expression 1. May be null

setValue1

public void setValue1(double value1)
Sets a numeric value for expression 1.

getValue2

public java.lang.Double getValue2()
Returns:
the numeric value for expression 2. May be null

setValue2

public void setValue2(double value2)
Sets a numeric value for expression 2.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherGraphics

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class EscherGraphics

java.lang.Object
    extended by  java.awt.Graphics
        extended by  org.apache.poi.hssf.usermodel.EscherGraphics

public class EscherGraphics
extends java.awt.Graphics

Translates Graphics calls into escher calls. The translation is lossy so many features are not supported and some just aren't implemented yet. If in doubt test the specific calls you wish to make. Graphics calls are always performed into an EscherGroup so one will need to be created.

Important:

One important concept worth considering is that of font size. One of the difficulties in converting Graphics calls into escher drawing calls is that Excel does not have the concept of absolute pixel positions. It measures it's cell widths in 'characters' and the cell heights in points. Unfortunately it's not defined exactly what a type of character it's measuring. Presumably this is due to the fact that the Excel will be using different fonts on different platforms or even within the same platform.

Because of this constraint we've had to calculate the verticalPointsPerPixel. This the amount the font should be scaled by when you issue commands such as drawString(). A good way to calculate this is to use the follow formula:

      multipler = groupHeightInPoints / heightOfGroup

The height of the group is calculated fairly simply by calculating the difference between the y coordinates of the bounding box of the shape. The height of the group can be calculated by using a convenience called HSSFClientAnchor.getAnchorHeightInPoints().

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
EscherGraphics(HSSFShapeGroup escherGroup, HSSFWorkbook workbook, java.awt.Color forecolor, float verticalPointsPerPixel)
Construct an escher graphics object.
Method Summary
void | clearRect(int x, int y, int width, int height)
void | clipRect(int x, int y, int width, int height)
void | copyArea(int x, int y, int width, int height, int dx, int dy)
java.awt.Graphics | create()
void | dispose()
void | drawArc(int x, int y, int width, int height, int startAngle, int arcAngle)
boolean | drawImage(java.awt.Image image, int i, int j, java.awt.Color color, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image image, int i, int j, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image image, int i, int j, int k, int l, java.awt.Color color, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image image, int i, int j, int k, int l, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.Color bgcolor, java.awt.image.ImageObserver observer)
boolean | drawImage(java.awt.Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.image.ImageObserver observer)
void | drawLine(int x1, int y1, int x2, int y2)
void | drawLine(int x1, int y1, int x2, int y2, int width)
void | drawOval(int x, int y, int width, int height)
void | drawPolygon(int[] xPoints, int[] yPoints, int nPoints)
void | drawPolyline(int[] xPoints, int[] yPoints, int nPoints)
void | drawRect(int x, int y, int width, int height)
void | drawRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
void | drawString(java.text.AttributedCharacterIterator iterator, int x, int y)
void | drawString(java.lang.String str, int x, int y)
void | fillArc(int x, int y, int width, int height, int startAngle, int arcAngle)
void | fillOval(int x, int y, int width, int height)
void | fillPolygon(int[] xPoints, int[] yPoints, int nPoints) Fills a (closed) polygon, as defined by a pair of arrays, which hold the x and y coordinates.
void | fillRect(int x, int y, int width, int height)
void | fillRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
java.awt.Color | getBackground()
java.awt.Shape | getClip()
java.awt.Rectangle | getClipBounds()
java.awt.Rectangle | getClipRect()
java.awt.Color | getColor()
java.awt.Font | getFont()
java.awt.FontMetrics | getFontMetrics(java.awt.Font f)
void | setBackground(java.awt.Color background)
void | setClip(int x, int y, int width, int height)
void | setClip(java.awt.Shape shape)
void | setColor(java.awt.Color color)
void | setFont(java.awt.Font f)
void | setPaintMode()
void | setXORMode(java.awt.Color color)
void | translate(int x, int y)
Methods inherited from class java.awt.Graphics
create, draw3DRect, drawBytes, drawChars, drawPolygon, fill3DRect, fillPolygon, finalize, getClipBounds, getFontMetrics, hitClip, toString
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EscherGraphics

public EscherGraphics(HSSFShapeGroup escherGroup,
                      HSSFWorkbook workbook,
                      java.awt.Color forecolor,
                      float verticalPointsPerPixel)
Construct an escher graphics object.

Parameters:
escherGroup - The escher group to write the graphics calls into.
workbook - The workbook we are using.
forecolor - The foreground color to use as default.
verticalPointsPerPixel - The font multiplier. (See class description for information on how this works.).
Method Detail

clearRect

public void clearRect(int x,
                      int y,
                      int width,
                      int height)
Specified by:
clearRect in class java.awt.Graphics

clipRect

public void clipRect(int x,
                     int y,
                     int width,
                     int height)
Specified by:
clipRect in class java.awt.Graphics

copyArea

public void copyArea(int x,
                     int y,
                     int width,
                     int height,
                     int dx,
                     int dy)
Specified by:
copyArea in class java.awt.Graphics

create

public java.awt.Graphics create()
Specified by:
create in class java.awt.Graphics

dispose

public void dispose()
Specified by:
dispose in class java.awt.Graphics

drawArc

public void drawArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
Specified by:
drawArc in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.Color bgcolor,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int i,
                         int j,
                         int k,
                         int l,
                         java.awt.Color color,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int i,
                         int j,
                         int k,
                         int l,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int i,
                         int j,
                         java.awt.Color color,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int i,
                         int j,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawLine

public void drawLine(int x1,
                     int y1,
                     int x2,
                     int y2)
Specified by:
drawLine in class java.awt.Graphics

drawLine

public void drawLine(int x1,
                     int y1,
                     int x2,
                     int y2,
                     int width)

drawOval

public void drawOval(int x,
                     int y,
                     int width,
                     int height)
Specified by:
drawOval in class java.awt.Graphics

drawPolygon

public void drawPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Specified by:
drawPolygon in class java.awt.Graphics

drawPolyline

public void drawPolyline(int[] xPoints,
                         int[] yPoints,
                         int nPoints)
Specified by:
drawPolyline in class java.awt.Graphics

drawRect

public void drawRect(int x,
                     int y,
                     int width,
                     int height)
Overrides:
drawRect in class java.awt.Graphics

drawRoundRect

public void drawRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
Specified by:
drawRoundRect in class java.awt.Graphics

drawString

public void drawString(java.lang.String str,
                       int x,
                       int y)
Specified by:
drawString in class java.awt.Graphics

drawString

public void drawString(java.text.AttributedCharacterIterator iterator,
                       int x,
                       int y)
Specified by:
drawString in class java.awt.Graphics

fillArc

public void fillArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
Specified by:
fillArc in class java.awt.Graphics

fillOval

public void fillOval(int x,
                     int y,
                     int width,
                     int height)
Specified by:
fillOval in class java.awt.Graphics

fillPolygon

public void fillPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Fills a (closed) polygon, as defined by a pair of arrays, which hold the x and y coordinates.

This draws the polygon, with nPoint line segments. The first nPoint - 1 line segments are drawn between sequential points (xPoints[i],yPoints[i],xPoints[i+1],yPoints[i+1]). The final line segment is a closing one, from the last point to the first (assuming they are different).

The area inside of the polygon is defined by using an even-odd fill rule (also known as the alternating rule), and the area inside of it is filled.

Specified by:
fillPolygon in class java.awt.Graphics
Parameters:
xPoints - array of the x coordinates.
yPoints - array of the y coordinates.
nPoints - the total number of points in the polygon.
See Also:
Graphics.drawPolygon(int[], int[], int)

fillRect

public void fillRect(int x,
                     int y,
                     int width,
                     int height)
Specified by:
fillRect in class java.awt.Graphics

fillRoundRect

public void fillRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
Specified by:
fillRoundRect in class java.awt.Graphics

getClip

public java.awt.Shape getClip()
Specified by:
getClip in class java.awt.Graphics

getClipBounds

public java.awt.Rectangle getClipBounds()
Specified by:
getClipBounds in class java.awt.Graphics

getClipRect

public java.awt.Rectangle getClipRect()
Overrides:
getClipRect in class java.awt.Graphics

getColor

public java.awt.Color getColor()
Specified by:
getColor in class java.awt.Graphics

getFont

public java.awt.Font getFont()
Specified by:
getFont in class java.awt.Graphics

getFontMetrics

public java.awt.FontMetrics getFontMetrics(java.awt.Font f)
Specified by:
getFontMetrics in class java.awt.Graphics

setClip

public void setClip(int x,
                    int y,
                    int width,
                    int height)
Specified by:
setClip in class java.awt.Graphics

setClip

public void setClip(java.awt.Shape shape)
Specified by:
setClip in class java.awt.Graphics

setColor

public void setColor(java.awt.Color color)
Specified by:
setColor in class java.awt.Graphics

setFont

public void setFont(java.awt.Font f)
Specified by:
setFont in class java.awt.Graphics

setPaintMode

public void setPaintMode()
Specified by:
setPaintMode in class java.awt.Graphics

setXORMode

public void setXORMode(java.awt.Color color)
Specified by:
setXORMode in class java.awt.Graphics

translate

public void translate(int x,
                      int y)
Specified by:
translate in class java.awt.Graphics

getBackground

public java.awt.Color getBackground()

setBackground

public void setBackground(java.awt.Color background)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherGraphics2d

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class EscherGraphics2d

java.lang.Object
    extended by  java.awt.Graphics
        extended by  java.awt.Graphics2D
            extended by  org.apache.poi.hssf.usermodel.EscherGraphics2d

public final class EscherGraphics2d
extends java.awt.Graphics2D

Translates Graphics2d calls into escher calls. The translation is lossy so many features are not supported and some just aren't implemented yet. If in doubt test the specific calls you wish to make. Graphics calls are always drawn into an EscherGroup so one will need to be created.

Important:

One important concept worth considering is that of font size. One of the difficulties in converting Graphics calls into escher drawing calls is that Excel does not have the concept of absolute pixel positions. It measures it's cell widths in 'characters' and the cell heights in points. Unfortunately it's not defined exactly what a type of character it's measuring. Presumably this is due to the fact that the Excel will be using different fonts on different platforms or even within the same platform.

Because of this constraint you have to calculate the verticalPointsPerPixel. This the amount the font should be scaled by when you issue commands such as drawString(). A good way to calculate this is to use the follow formula:

      multipler = groupHeightInPoints / heightOfGroup

The height of the group is calculated fairly simply by calculating the difference between the y coordinates of the bounding box of the shape. The height of the group can be calculated by using a convenience called HSSFClientAnchor.getAnchorHeightInPoints().

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
EscherGraphics2d(EscherGraphics escherGraphics)
Constructs one escher graphics object from an escher graphics object.
Method Summary
void | addRenderingHints(java.util.Map map)
void | clearRect(int i, int j, int k, int l)
void | clip(java.awt.Shape shape)
void | clipRect(int x, int y, int width, int height)
void | copyArea(int x, int y, int width, int height, int dx, int dy)
java.awt.Graphics | create()
void | dispose()
void | draw(java.awt.Shape shape)
void | drawArc(int x, int y, int width, int height, int startAngle, int arcAngle)
void | drawGlyphVector(java.awt.font.GlyphVector g, float x, float y)
void | drawImage(java.awt.image.BufferedImage bufferedimage, java.awt.image.BufferedImageOp op, int x, int y)
boolean | drawImage(java.awt.Image image, java.awt.geom.AffineTransform affinetransform, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image image, int x, int y, java.awt.Color bgColor, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image image, int x, int y, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image image, int dx1, int dy1, int dx2, int dy2, java.awt.Color bgColor, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image img, int x, int y, int width, int height, java.awt.image.ImageObserver observer)
boolean | drawImage(java.awt.Image image, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.Color bgColor, java.awt.image.ImageObserver imageobserver)
boolean | drawImage(java.awt.Image image, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, java.awt.image.ImageObserver imageobserver)
void | drawLine(int x1, int y1, int x2, int y2)
void | drawLine(int x1, int y1, int x2, int y2, int width)
void | drawOval(int x, int y, int width, int height)
void | drawPolygon(int[] xPoints, int[] yPoints, int nPoints)
void | drawPolyline(int[] xPoints, int[] yPoints, int nPoints)
void | drawRect(int x, int y, int width, int height)
void | drawRenderableImage(java.awt.image.renderable.RenderableImage renderableimage, java.awt.geom.AffineTransform affinetransform)
void | drawRenderedImage(java.awt.image.RenderedImage renderedimage, java.awt.geom.AffineTransform affinetransform)
void | drawRoundRect(int i, int j, int k, int l, int i1, int j1)
void | drawString(java.text.AttributedCharacterIterator attributedcharacteriterator, float x, float y)
void | drawString(java.text.AttributedCharacterIterator attributedcharacteriterator, int x, int y)
void | drawString(java.lang.String string, float x, float y)
void | drawString(java.lang.String string, int x, int y)
void | fill(java.awt.Shape shape)
void | fillArc(int i, int j, int k, int l, int i1, int j1)
void | fillOval(int x, int y, int width, int height)
void | fillPolygon(int[] xPoints, int[] yPoints, int nPoints) Fills a (closed) polygon, as defined by a pair of arrays, which hold the x and y coordinates.
void | fillRect(int x, int y, int width, int height)
void | fillRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
java.awt.Color | getBackground()
java.awt.Shape | getClip()
java.awt.Rectangle | getClipBounds()
java.awt.Color | getColor()
java.awt.Composite | getComposite()
java.awt.GraphicsConfiguration | getDeviceConfiguration()
java.awt.Font | getFont()
java.awt.FontMetrics | getFontMetrics(java.awt.Font font)
java.awt.font.FontRenderContext | getFontRenderContext()
java.awt.Paint | getPaint()
java.lang.Object | getRenderingHint(java.awt.RenderingHints.Key key)
java.awt.RenderingHints | getRenderingHints()
java.awt.Stroke | getStroke()
java.awt.geom.AffineTransform | getTransform()
boolean | hit(java.awt.Rectangle rectangle, java.awt.Shape shape, boolean flag)
void | rotate(double d)
void | rotate(double d, double d1, double d2)
void | scale(double d, double d1)
void | setBackground(java.awt.Color c)
void | setClip(int i, int j, int k, int l)
void | setClip(java.awt.Shape shape)
void | setColor(java.awt.Color c)
void | setComposite(java.awt.Composite composite)
void | setFont(java.awt.Font font)
void | setPaint(java.awt.Paint paint1)
void | setPaintMode()
void | setRenderingHint(java.awt.RenderingHints.Key key, java.lang.Object obj)
void | setRenderingHints(java.util.Map map)
void | setStroke(java.awt.Stroke s)
void | setTransform(java.awt.geom.AffineTransform affinetransform)
void | setXORMode(java.awt.Color color1)
void | shear(double d, double d1)
void | transform(java.awt.geom.AffineTransform affinetransform)
void | translate(double d, double d1)
void | translate(int i, int j)
Methods inherited from class java.awt.Graphics2D
draw3DRect, fill3DRect
Methods inherited from class java.awt.Graphics
create, drawBytes, drawChars, drawPolygon, fillPolygon, finalize, getClipBounds, getClipRect, getFontMetrics, hitClip, toString
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EscherGraphics2d

public EscherGraphics2d(EscherGraphics escherGraphics)
Constructs one escher graphics object from an escher graphics object.

Parameters:
escherGraphics - the original EscherGraphics2d object to copy
Method Detail

addRenderingHints

public void addRenderingHints(java.util.Map map)
Specified by:
addRenderingHints in class java.awt.Graphics2D

clearRect

public void clearRect(int i,
                      int j,
                      int k,
                      int l)
Specified by:
clearRect in class java.awt.Graphics

clip

public void clip(java.awt.Shape shape)
Specified by:
clip in class java.awt.Graphics2D

clipRect

public void clipRect(int x,
                     int y,
                     int width,
                     int height)
Specified by:
clipRect in class java.awt.Graphics

copyArea

public void copyArea(int x,
                     int y,
                     int width,
                     int height,
                     int dx,
                     int dy)
Specified by:
copyArea in class java.awt.Graphics

create

public java.awt.Graphics create()
Specified by:
create in class java.awt.Graphics

dispose

public void dispose()
Specified by:
dispose in class java.awt.Graphics

draw

public void draw(java.awt.Shape shape)
Specified by:
draw in class java.awt.Graphics2D

drawArc

public void drawArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
Specified by:
drawArc in class java.awt.Graphics

drawGlyphVector

public void drawGlyphVector(java.awt.font.GlyphVector g,
                            float x,
                            float y)
Specified by:
drawGlyphVector in class java.awt.Graphics2D

drawImage

public boolean drawImage(java.awt.Image image,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.Color bgColor,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         java.awt.Color bgColor,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image img,
                         int x,
                         int y,
                         int width,
                         int height,
                         java.awt.image.ImageObserver observer)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int x,
                         int y,
                         java.awt.Color bgColor,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         int x,
                         int y,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics

drawImage

public boolean drawImage(java.awt.Image image,
                         java.awt.geom.AffineTransform affinetransform,
                         java.awt.image.ImageObserver imageobserver)
Specified by:
drawImage in class java.awt.Graphics2D

drawImage

public void drawImage(java.awt.image.BufferedImage bufferedimage,
                      java.awt.image.BufferedImageOp op,
                      int x,
                      int y)
Specified by:
drawImage in class java.awt.Graphics2D

drawLine

public void drawLine(int x1,
                     int y1,
                     int x2,
                     int y2,
                     int width)

drawLine

public void drawLine(int x1,
                     int y1,
                     int x2,
                     int y2)
Specified by:
drawLine in class java.awt.Graphics

drawOval

public void drawOval(int x,
                     int y,
                     int width,
                     int height)
Specified by:
drawOval in class java.awt.Graphics

drawPolygon

public void drawPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Specified by:
drawPolygon in class java.awt.Graphics

drawPolyline

public void drawPolyline(int[] xPoints,
                         int[] yPoints,
                         int nPoints)
Specified by:
drawPolyline in class java.awt.Graphics

drawRect

public void drawRect(int x,
                     int y,
                     int width,
                     int height)
Overrides:
drawRect in class java.awt.Graphics

drawRenderableImage

public void drawRenderableImage(java.awt.image.renderable.RenderableImage renderableimage,
                                java.awt.geom.AffineTransform affinetransform)
Specified by:
drawRenderableImage in class java.awt.Graphics2D

drawRenderedImage

public void drawRenderedImage(java.awt.image.RenderedImage renderedimage,
                              java.awt.geom.AffineTransform affinetransform)
Specified by:
drawRenderedImage in class java.awt.Graphics2D

drawRoundRect

public void drawRoundRect(int i,
                          int j,
                          int k,
                          int l,
                          int i1,
                          int j1)
Specified by:
drawRoundRect in class java.awt.Graphics

drawString

public void drawString(java.lang.String string,
                       float x,
                       float y)
Specified by:
drawString in class java.awt.Graphics2D

drawString

public void drawString(java.lang.String string,
                       int x,
                       int y)
Specified by:
drawString in class java.awt.Graphics2D

drawString

public void drawString(java.text.AttributedCharacterIterator attributedcharacteriterator,
                       float x,
                       float y)
Specified by:
drawString in class java.awt.Graphics2D

drawString

public void drawString(java.text.AttributedCharacterIterator attributedcharacteriterator,
                       int x,
                       int y)
Specified by:
drawString in class java.awt.Graphics2D

fill

public void fill(java.awt.Shape shape)
Specified by:
fill in class java.awt.Graphics2D

fillArc

public void fillArc(int i,
                    int j,
                    int k,
                    int l,
                    int i1,
                    int j1)
Specified by:
fillArc in class java.awt.Graphics

fillOval

public void fillOval(int x,
                     int y,
                     int width,
                     int height)
Specified by:
fillOval in class java.awt.Graphics

fillPolygon

public void fillPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
Fills a (closed) polygon, as defined by a pair of arrays, which hold the x and y coordinates.

This draws the polygon, with nPoint line segments. The first nPoint - 1 line segments are drawn between sequential points (xPoints[i],yPoints[i],xPoints[i+1],yPoints[i+1]). The final line segment is a closing one, from the last point to the first (assuming they are different).

The area inside of the polygon is defined by using an even-odd fill rule (also known as the alternating rule), and the area inside of it is filled.

Specified by:
fillPolygon in class java.awt.Graphics
Parameters:
xPoints - array of the x coordinates.
yPoints - array of the y coordinates.
nPoints - the total number of points in the polygon.
See Also:
Graphics.drawPolygon(int[], int[], int)

fillRect

public void fillRect(int x,
                     int y,
                     int width,
                     int height)
Specified by:
fillRect in class java.awt.Graphics

fillRoundRect

public void fillRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
Specified by:
fillRoundRect in class java.awt.Graphics

getBackground

public java.awt.Color getBackground()
Specified by:
getBackground in class java.awt.Graphics2D

getClip

public java.awt.Shape getClip()
Specified by:
getClip in class java.awt.Graphics

getClipBounds

public java.awt.Rectangle getClipBounds()
Specified by:
getClipBounds in class java.awt.Graphics

getColor

public java.awt.Color getColor()
Specified by:
getColor in class java.awt.Graphics

getComposite

public java.awt.Composite getComposite()
Specified by:
getComposite in class java.awt.Graphics2D

getDeviceConfiguration

public java.awt.GraphicsConfiguration getDeviceConfiguration()
Specified by:
getDeviceConfiguration in class java.awt.Graphics2D

getFont

public java.awt.Font getFont()
Specified by:
getFont in class java.awt.Graphics

getFontMetrics

public java.awt.FontMetrics getFontMetrics(java.awt.Font font)
Specified by:
getFontMetrics in class java.awt.Graphics

getFontRenderContext

public java.awt.font.FontRenderContext getFontRenderContext()
Specified by:
getFontRenderContext in class java.awt.Graphics2D

getPaint

public java.awt.Paint getPaint()
Specified by:
getPaint in class java.awt.Graphics2D

getRenderingHint

public java.lang.Object getRenderingHint(java.awt.RenderingHints.Key key)
Specified by:
getRenderingHint in class java.awt.Graphics2D

getRenderingHints

public java.awt.RenderingHints getRenderingHints()
Specified by:
getRenderingHints in class java.awt.Graphics2D

getStroke

public java.awt.Stroke getStroke()
Specified by:
getStroke in class java.awt.Graphics2D

getTransform

public java.awt.geom.AffineTransform getTransform()
Specified by:
getTransform in class java.awt.Graphics2D

hit

public boolean hit(java.awt.Rectangle rectangle,
                   java.awt.Shape shape,
                   boolean flag)
Specified by:
hit in class java.awt.Graphics2D

rotate

public void rotate(double d)
Specified by:
rotate in class java.awt.Graphics2D

rotate

public void rotate(double d,
                   double d1,
                   double d2)
Specified by:
rotate in class java.awt.Graphics2D

scale

public void scale(double d,
                  double d1)
Specified by:
scale in class java.awt.Graphics2D

setBackground

public void setBackground(java.awt.Color c)
Specified by:
setBackground in class java.awt.Graphics2D

setClip

public void setClip(int i,
                    int j,
                    int k,
                    int l)
Specified by:
setClip in class java.awt.Graphics

setClip

public void setClip(java.awt.Shape shape)
Specified by:
setClip in class java.awt.Graphics

setColor

public void setColor(java.awt.Color c)
Specified by:
setColor in class java.awt.Graphics

setComposite

public void setComposite(java.awt.Composite composite)
Specified by:
setComposite in class java.awt.Graphics2D

setFont

public void setFont(java.awt.Font font)
Specified by:
setFont in class java.awt.Graphics

setPaint

public void setPaint(java.awt.Paint paint1)
Specified by:
setPaint in class java.awt.Graphics2D

setPaintMode

public void setPaintMode()
Specified by:
setPaintMode in class java.awt.Graphics

setRenderingHint

public void setRenderingHint(java.awt.RenderingHints.Key key,
                             java.lang.Object obj)
Specified by:
setRenderingHint in class java.awt.Graphics2D

setRenderingHints

public void setRenderingHints(java.util.Map map)
Specified by:
setRenderingHints in class java.awt.Graphics2D

setStroke

public void setStroke(java.awt.Stroke s)
Specified by:
setStroke in class java.awt.Graphics2D

setTransform

public void setTransform(java.awt.geom.AffineTransform affinetransform)
Specified by:
setTransform in class java.awt.Graphics2D

setXORMode

public void setXORMode(java.awt.Color color1)
Specified by:
setXORMode in class java.awt.Graphics

shear

public void shear(double d,
                  double d1)
Specified by:
shear in class java.awt.Graphics2D

transform

public void transform(java.awt.geom.AffineTransform affinetransform)
Specified by:
transform in class java.awt.Graphics2D

translate

public void translate(double d,
                      double d1)
Specified by:
translate in class java.awt.Graphics2D

translate

public void translate(int i,
                      int j)
Specified by:
translate in class java.awt.Graphics2D
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontDetails

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class FontDetails

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.FontDetails

public class FontDetails
extends java.lang.Object

Stores width and height details about a font.

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
FontDetails(java.lang.String fontName, int height)
Construct the font details with the given name and height.
Method Summary
void | addChar(char c, int width)
void | addChars(char[] characters, int[] widths)
protected static java.lang.String | buildFontCharactersProperty(java.lang.String fontName)
protected static java.lang.String | buildFontHeightProperty(java.lang.String fontName)
protected static java.lang.String | buildFontWidthsProperty(java.lang.String fontName)
static FontDetails | create(java.lang.String fontName, java.util.Properties fontMetricsProps) Create an instance of FontDetails by loading them from the provided property object.
int | getCharWidth(char c) Retrieves the width of the specified character.
java.lang.String | getFontName()
int | getHeight()
int | getStringWidth(java.lang.String str) Gets the width of all characters in a string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FontDetails

public FontDetails(java.lang.String fontName,
                   int height)
Construct the font details with the given name and height.

Parameters:
fontName - The font name.
height - The height of the font.
Method Detail

getFontName

public java.lang.String getFontName()

getHeight

public int getHeight()

addChar

public void addChar(char c,
                    int width)

getCharWidth

public int getCharWidth(char c)
Retrieves the width of the specified character. If the metrics for a particular character are not available it defaults to returning the width for the 'W' character.

addChars

public void addChars(char[] characters,
                     int[] widths)

buildFontHeightProperty

protected static java.lang.String buildFontHeightProperty(java.lang.String fontName)

buildFontWidthsProperty

protected static java.lang.String buildFontWidthsProperty(java.lang.String fontName)

buildFontCharactersProperty

protected static java.lang.String buildFontCharactersProperty(java.lang.String fontName)

create

public static FontDetails create(java.lang.String fontName,
                                 java.util.Properties fontMetricsProps)
Create an instance of FontDetails by loading them from the provided property object.

Parameters:
fontName - the font name
fontMetricsProps - the property object holding the details of this particular font.
Returns:
a new FontDetails instance.

getStringWidth

public int getStringWidth(java.lang.String str)
Gets the width of all characters in a string.

Parameters:
str - The string to measure.
Returns:
The width of the string for a 10 point font.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HeaderFooter

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HeaderFooter
All Implemented Interfaces:
HeaderFooter
Direct Known Subclasses:
HSSFFooter, HSSFHeader
public abstract class HeaderFooter
extends java.lang.Object
implements HeaderFooter

Common class for HSSFHeader and HSSFFooter.

Constructor Summary
protected HeaderFooter()
Method Summary
static java.lang.String | date()
static java.lang.String | endBold()
static java.lang.String | endDoubleUnderline()
static java.lang.String | endUnderline()
static java.lang.String | file()
static java.lang.String | font(java.lang.String font, java.lang.String style)
static java.lang.String | fontSize(short size)
java.lang.String | getCenter() Get the center of the header or footer.
java.lang.String | getLeft() Get the left side of the header or footer.
protected abstract java.lang.String | getRawText()
java.lang.String | getRight() Get the right side of the header or footer.
static java.lang.String | numPages()
static java.lang.String | page()
void | setCenter(java.lang.String newCenter) Sets the center string.
protected abstract void | setHeaderFooterText(java.lang.String text)
void | setLeft(java.lang.String newLeft) Sets the left string.
void | setRight(java.lang.String newRight) Sets the right string or footer.
static java.lang.String | startBold()
static java.lang.String | startDoubleUnderline()
static java.lang.String | startUnderline()
static java.lang.String | stripFields(java.lang.String pText) Removes any fields (eg macros, page markers etc) from the string.
static java.lang.String | tab()
static java.lang.String | time()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HeaderFooter

protected HeaderFooter()
Method Detail

getRawText

protected abstract java.lang.String getRawText()
Returns:
the internal text representation (combining center, left and right parts). Possibly empty string if no header or footer is set. Never null.

getLeft

public final java.lang.String getLeft()
Description copied from interface: HeaderFooter
Get the left side of the header or footer.

Specified by:
getLeft in interface HeaderFooter
Returns:
the left side of the header or footer.

setLeft

public final void setLeft(java.lang.String newLeft)
Description copied from interface: HeaderFooter
Sets the left string.

Specified by:
setLeft in interface HeaderFooter
Parameters:
newLeft - The string to set as the left side.

getCenter

public final java.lang.String getCenter()
Description copied from interface: HeaderFooter
Get the center of the header or footer.

Specified by:
getCenter in interface HeaderFooter
Returns:
the center of the header or footer.

setCenter

public final void setCenter(java.lang.String newCenter)
Description copied from interface: HeaderFooter
Sets the center string.

Specified by:
setCenter in interface HeaderFooter
Parameters:
newCenter - The string to set as the center.

getRight

public final java.lang.String getRight()
Description copied from interface: HeaderFooter
Get the right side of the header or footer.

Specified by:
getRight in interface HeaderFooter
Returns:
The right side of the header or footer.

setRight

public final void setRight(java.lang.String newRight)
Description copied from interface: HeaderFooter
Sets the right string or footer.

Specified by:
setRight in interface HeaderFooter
Parameters:
newRight - The string to set as the right side.

setHeaderFooterText

protected abstract void setHeaderFooterText(java.lang.String text)
Parameters:
text - the new header footer text (contains mark-up tags). Possibly empty string never null

fontSize

public static java.lang.String fontSize(short size)
Parameters:
size - the new font size
Returns:
The mark-up tag representing a new font size

font

public static java.lang.String font(java.lang.String font,
                                    java.lang.String style)
Parameters:
font - the new font
style - the fonts style, one of regular, italic, bold, italic bold or bold italic
Returns:
The mark-up tag representing a new font size

page

public static java.lang.String page()
Returns:
The mark-up tag representing the current page number

numPages

public static java.lang.String numPages()
Returns:
The mark-up tag representing the number of pages

date

public static java.lang.String date()
Returns:
The mark-up tag representing the current date date

time

public static java.lang.String time()
Returns:
The mark-up tag representing current time

file

public static java.lang.String file()
Returns:
The mark-up tag representing the current file name

tab

public static java.lang.String tab()
Returns:
The mark-up tag representing the current tab (sheet) name

startBold

public static java.lang.String startBold()
Returns:
The mark-up tag for start bold

endBold

public static java.lang.String endBold()
Returns:
The mark-up tag for end bold

startUnderline

public static java.lang.String startUnderline()
Returns:
The mark-up tag for start underline

endUnderline

public static java.lang.String endUnderline()
Returns:
The mark-up tag for end underline

startDoubleUnderline

public static java.lang.String startDoubleUnderline()
Returns:
The mark-up tag for start double underline

endDoubleUnderline

public static java.lang.String endDoubleUnderline()
Returns:
The mark-up tag for end double underline

stripFields

public static java.lang.String stripFields(java.lang.String pText)
Removes any fields (eg macros, page markers etc) from the string. Normally used to make some text suitable for showing to humans, and the resultant text should not normally be saved back into the document!

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFAnchor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFAnchor

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFAnchor
Direct Known Subclasses:
HSSFChildAnchor, HSSFClientAnchor
public abstract class HSSFAnchor
extends java.lang.Object

An anchor is what specifics the position of a shape within a client object or within another containing shape.

Author:
Glen Stampoultzis (glens at apache.org)

Constructor Summary
HSSFAnchor()
HSSFAnchor(int dx1, int dy1, int dx2, int dy2)
Method Summary
int | getDx1()
int | getDx2()
int | getDy1()
int | getDy2()
abstract boolean | isHorizontallyFlipped()
abstract boolean | isVerticallyFlipped()
void | setDx1(int dx1)
void | setDx2(int dx2)
void | setDy1(int dy1)
void | setDy2(int dy2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFAnchor

public HSSFAnchor()

HSSFAnchor

public HSSFAnchor(int dx1,
                  int dy1,
                  int dx2,
                  int dy2)
Method Detail

getDx1

public int getDx1()

setDx1

public void setDx1(int dx1)

getDy1

public int getDy1()

setDy1

public void setDy1(int dy1)

getDy2

public int getDy2()

setDy2

public void setDy2(int dy2)

getDx2

public int getDx2()

setDx2

public void setDx2(int dx2)

isHorizontallyFlipped

public abstract boolean isHorizontallyFlipped()

isVerticallyFlipped

public abstract boolean isVerticallyFlipped()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFAutoFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFAutoFilter

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFAutoFilter
All Implemented Interfaces:
AutoFilter
public final class HSSFAutoFilter
extends java.lang.Object
implements AutoFilter

Represents autofiltering for the specified worksheet.

Author:
Yegor Kozlov

Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFBorderFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFBorderFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFBorderFormatting
All Implemented Interfaces:
BorderFormatting
public final class HSSFBorderFormatting
extends java.lang.Object
implements BorderFormatting

High level representation for Border Formatting component of Conditional Formatting settings

Author:
Dmitriy Kumshayev

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.BorderFormatting
BORDER_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_DASHED, BORDER_DOTTED, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM, BORDER_MEDIUM_DASH_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_MEDIUM_DASHED, BORDER_NONE, BORDER_SLANTED_DASH_DOT, BORDER_THICK, BORDER_THIN
Constructor Summary
protected HSSFBorderFormatting(CFRuleRecord cfRuleRecord)
Method Summary
short | getBorderBottom()
short | getBorderDiagonal()
protected BorderFormatting | getBorderFormattingBlock()
short | getBorderLeft()
short | getBorderRight()
short | getBorderTop()
short | getBottomBorderColor()
short | getDiagonalBorderColor()
short | getLeftBorderColor()
short | getRightBorderColor()
short | getTopBorderColor()
boolean | isBackwardDiagonalOn()
boolean | isForwardDiagonalOn()
void | setBackwardDiagonalOn(boolean on)
void | setBorderBottom(short border)
void | setBorderDiagonal(short border) Set diagonal border.
void | setBorderLeft(short border) Set left border.
void | setBorderRight(short border) Set right border.
void | setBorderTop(short border) Set top border.
void | setBottomBorderColor(short color)
void | setDiagonalBorderColor(short color)
void | setForwardDiagonalOn(boolean on)
void | setLeftBorderColor(short color)
void | setRightBorderColor(short color)
void | setTopBorderColor(short color)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFBorderFormatting

protected HSSFBorderFormatting(CFRuleRecord cfRuleRecord)
Method Detail

getBorderFormattingBlock

protected BorderFormatting getBorderFormattingBlock()

getBorderBottom

public short getBorderBottom()
Specified by:
getBorderBottom in interface BorderFormatting

getBorderDiagonal

public short getBorderDiagonal()
Specified by:
getBorderDiagonal in interface BorderFormatting

getBorderLeft

public short getBorderLeft()
Specified by:
getBorderLeft in interface BorderFormatting

getBorderRight

public short getBorderRight()
Specified by:
getBorderRight in interface BorderFormatting

getBorderTop

public short getBorderTop()
Specified by:
getBorderTop in interface BorderFormatting

getBottomBorderColor

public short getBottomBorderColor()
Specified by:
getBottomBorderColor in interface BorderFormatting

getDiagonalBorderColor

public short getDiagonalBorderColor()
Specified by:
getDiagonalBorderColor in interface BorderFormatting

getLeftBorderColor

public short getLeftBorderColor()
Specified by:
getLeftBorderColor in interface BorderFormatting

getRightBorderColor

public short getRightBorderColor()
Specified by:
getRightBorderColor in interface BorderFormatting

getTopBorderColor

public short getTopBorderColor()
Specified by:
getTopBorderColor in interface BorderFormatting

isBackwardDiagonalOn

public boolean isBackwardDiagonalOn()

isForwardDiagonalOn

public boolean isForwardDiagonalOn()

setBackwardDiagonalOn

public void setBackwardDiagonalOn(boolean on)

setBorderBottom

public void setBorderBottom(short border)
Specified by:
setBorderBottom in interface BorderFormatting

setBorderDiagonal

public void setBorderDiagonal(short border)
Description copied from interface: BorderFormatting
Set diagonal border.

Specified by:
setBorderDiagonal in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBorderLeft

public void setBorderLeft(short border)
Description copied from interface: BorderFormatting
Set left border.

Specified by:
setBorderLeft in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBorderRight

public void setBorderRight(short border)
Description copied from interface: BorderFormatting
Set right border.

Specified by:
setBorderRight in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBorderTop

public void setBorderTop(short border)
Description copied from interface: BorderFormatting
Set top border.

Specified by:
setBorderTop in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBottomBorderColor

public void setBottomBorderColor(short color)
Specified by:
setBottomBorderColor in interface BorderFormatting

setDiagonalBorderColor

public void setDiagonalBorderColor(short color)
Specified by:
setDiagonalBorderColor in interface BorderFormatting

setForwardDiagonalOn

public void setForwardDiagonalOn(boolean on)

setLeftBorderColor

public void setLeftBorderColor(short color)
Specified by:
setLeftBorderColor in interface BorderFormatting

setRightBorderColor

public void setRightBorderColor(short color)
Specified by:
setRightBorderColor in interface BorderFormatting

setTopBorderColor

public void setTopBorderColor(short color)
Specified by:
setTopBorderColor in interface BorderFormatting
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFCell

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFCell
All Implemented Interfaces:
Cell
public class HSSFCell
extends java.lang.Object
implements Cell

High level representation of a cell in a row of a spreadsheet. Cells can be numeric, formula-based or string-based (text). The cell type specifies this. String cells cannot conatin numbers and numeric cells cannot contain strings (at least according to our model). Client apps should do the conversions themselves. Formula cells have the formula string, as well as the formula result, which can be numeric or string.

Cells should have their number (0 based) before being added to a row. Only cells that have values should be added.

Author:
Andrew C. Oliver (acoliver at apache dot org), Dan Sherman (dsherman at isisph.com), Brian Sanders (kestrel at burdell dot org) Active Cell support, Yegor Kozlov cell comments support

Field Summary
static short | ENCODING_COMPRESSED_UNICODE
static short | ENCODING_UNCHANGED
static short | ENCODING_UTF_16
static int | LAST_COLUMN_NUMBER The maximum number of columns in BIFF8
Fields inherited from interface org.apache.poi.ss.usermodel.Cell
CELL_TYPE_BLANK, CELL_TYPE_BOOLEAN, CELL_TYPE_ERROR, CELL_TYPE_FORMULA, CELL_TYPE_NUMERIC, CELL_TYPE_STRING
Constructor Summary
protected | HSSFCell(HSSFWorkbook book, HSSFSheet sheet, CellValueRecordInterface cval) Creates an HSSFCell from a CellValueRecordInterface.
protected | HSSFCell(HSSFWorkbook book, HSSFSheet sheet, int row, short col) Creates new Cell - Should only be called by HSSFRow.
protected | HSSFCell(HSSFWorkbook book, HSSFSheet sheet, int row, short col, int type) Creates new Cell - Should only be called by HSSFRow.
Method Summary
protected static HSSFComment findCellComment(InternalSheet sheet, int row, int column)
Cell comment finder.
 CellRangeAddress getArrayFormulaRange()
Only valid for array formula cells
 boolean getBooleanCellValue()
get the value of the cell as a boolean.
protected  InternalWorkbook getBoundWorkbook()
Returns the Workbook that this Cell is bound to
 int getCachedFormulaResultType()
Only valid for formula cells
 HSSFComment getCellComment()
Returns comment associated with this cell
 java.lang.String getCellFormula()
Return a formula for the cell, for example, SUM(C4:E4)
 short getCellNum()
Deprecated. (Oct 2008) use getColumnIndex()
 HSSFCellStyle getCellStyle()
get the style for the cell.
 int getCellType()
get the cells type (numeric, formula or string)
protected  CellValueRecordInterface getCellValueRecord()
Should only be used by HSSFSheet and friends.
 int getColumnIndex()
Returns column index of this cell
 java.util.Date getDateCellValue()
Get the value of the cell as a date.
 byte getErrorCellValue()
get the value of the cell as an error code.
 HSSFHyperlink getHyperlink()
 double getNumericCellValue()
Get the value of the cell as a number.
 HSSFRichTextString getRichStringCellValue()
get the value of the cell as a string - for numeric cells we throw an exception.
 HSSFRow getRow()
Returns the HSSFRow this cell belongs to
 int getRowIndex()
Returns row index of a row in the sheet that contains this cell
 HSSFSheet getSheet()
Returns the HSSFSheet this cell belongs to
 java.lang.String getStringCellValue()
get the value of the cell as a string - for numeric cells we throw an exception.
 boolean isPartOfArrayFormulaGroup()
 void removeCellComment()
Removes the comment for this cell, if there is one.
 void setAsActiveCell()
Sets this cell as the active cell for the worksheet
 void setCellComment(Comment comment)
Assign a comment to this cell.
 void setCellErrorValue(byte errorCode)
set a error value for the cell
 void setCellFormula(java.lang.String formula)
Sets formula for this cell.
 void setCellNum(short num)
Deprecated. (Jan 2008) Doesn't update the row's idea of what cell this is, use HSSFRow.moveCell(HSSFCell, short) instead
 void setCellStyle(CellStyle style)
set the style for the cell.
 void setCellStyle(HSSFCellStyle style)
 void setCellType(int cellType)
set the cells type (numeric, formula or string)
 void setCellValue(boolean value)
set a boolean value for the cell
 void setCellValue(java.util.Calendar value)
set a date value for the cell.
 void setCellValue(java.util.Date value)
set a date value for the cell.
 void setCellValue(double value)
set a numeric value for the cell
 void setCellValue(RichTextString value)
Set a string value for the cell.
 void setCellValue(java.lang.String value)
set a string value for the cell.
 void setHyperlink(Hyperlink hyperlink)
Assign a hyperlink to this cell
 java.lang.String toString()
Returns a string representation of the cell This method returns a simple representation, anthing more complex should be in user code, with knowledge of the semantics of the sheet being processed.
protected  void updateCellNum(short num)
Updates the cell record's idea of what column it belongs in (0 based)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

LAST_COLUMN_NUMBER

public static final int LAST_COLUMN_NUMBER
The maximum number of columns in BIFF8

ENCODING_UNCHANGED

public static final short ENCODING_UNCHANGED
See Also:
Constant Field Values

ENCODING_COMPRESSED_UNICODE

public static final short ENCODING_COMPRESSED_UNICODE
See Also:
Constant Field Values

ENCODING_UTF_16

public static final short ENCODING_UTF_16
See Also:
Constant Field Values
Constructor Detail

HSSFCell

protected HSSFCell(HSSFWorkbook book,
                   HSSFSheet sheet,
                   int row,
                   short col)
Creates new Cell - Should only be called by HSSFRow. This creates a cell from scratch.

When the cell is initially created it is set to CELL_TYPE_BLANK. Cell types can be changed/overwritten by calling setCellValue with the appropriate type as a parameter although conversions from one type to another may be prohibited.

Parameters:
book - - Workbook record of the workbook containing this cell
sheet - - Sheet record of the sheet containing this cell
row - - the row of this cell
col - - the column for this cell
See Also:
HSSFRow.createCell(short)

HSSFCell

protected HSSFCell(HSSFWorkbook book,
                   HSSFSheet sheet,
                   int row,
                   short col,
                   int type)
Creates new Cell - Should only be called by HSSFRow. This creates a cell from scratch.

Parameters:
book - - Workbook record of the workbook containing this cell
sheet - - Sheet record of the sheet containing this cell
row - - the row of this cell
col - - the column for this cell
type - - CELL_TYPE_NUMERIC, CELL_TYPE_STRING, CELL_TYPE_FORMULA, CELL_TYPE_BLANK, CELL_TYPE_BOOLEAN, CELL_TYPE_ERROR Type of cell
See Also:
HSSFRow.createCell(short,int)

HSSFCell

protected HSSFCell(HSSFWorkbook book,
                   HSSFSheet sheet,
                   CellValueRecordInterface cval)
Creates an HSSFCell from a CellValueRecordInterface. HSSFSheet uses this when reading in cells from an existing sheet.

Parameters:
book - - Workbook record of the workbook containing this cell
sheet - - Sheet record of the sheet containing this cell
cval - - the Cell Value Record we wish to represent
Method Detail

getSheet

public HSSFSheet getSheet()
Returns the HSSFSheet this cell belongs to

Specified by:
getSheet in interface Cell
Returns:
the HSSFSheet that owns this cell

getRow

public HSSFRow getRow()
Returns the HSSFRow this cell belongs to

Specified by:
getRow in interface Cell
Returns:
the HSSFRow that owns this cell

getBoundWorkbook

protected InternalWorkbook getBoundWorkbook()
Returns the Workbook that this Cell is bound to

getRowIndex

public int getRowIndex()
Description copied from interface: Cell
Returns row index of a row in the sheet that contains this cell

Specified by:
getRowIndex in interface Cell
Returns:
the (zero based) index of the row containing this cell

setCellNum

public void setCellNum(short num)
Deprecated. (Jan 2008) Doesn't update the row's idea of what cell this is, use HSSFRow.moveCell(HSSFCell, short) instead

Set the cell's number within the row (0 based).

Parameters:
num - short the cell number

updateCellNum

protected void updateCellNum(short num)
Updates the cell record's idea of what column it belongs in (0 based)

Parameters:
num - the new cell number

getCellNum

public short getCellNum()
Deprecated. (Oct 2008) use getColumnIndex()

getColumnIndex

public int getColumnIndex()
Description copied from interface: Cell
Returns column index of this cell

Specified by:
getColumnIndex in interface Cell
Returns:
zero-based column index of a column in a sheet.

setCellType

public void setCellType(int cellType)
set the cells type (numeric, formula or string)

Specified by:
setCellType in interface Cell
See Also:
Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_FORMULA, Cell.CELL_TYPE_BLANK, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR

getCellType

public int getCellType()
get the cells type (numeric, formula or string)

Specified by:
getCellType in interface Cell
Returns:
the cell type
See Also:
Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_FORMULA, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR

setCellValue

public void setCellValue(double value)
set a numeric value for the cell

Specified by:
setCellValue in interface Cell
Parameters:
value - the numeric value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numeric cell and set its value.

setCellValue

public void setCellValue(java.util.Date value)
set a date value for the cell. Excel treats dates as numeric so you will need to format the cell as a date.

Specified by:
setCellValue in interface Cell
Parameters:
value - the date value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numeric cell and set its value.

setCellValue

public void setCellValue(java.util.Calendar value)
set a date value for the cell. Excel treats dates as numeric so you will need to format the cell as a date. This will set the cell value based on the Calendar's timezone. As Excel does not support timezones this means that both 20:00+03:00 and 20:00-03:00 will be reported as the same value (20:00) even that there are 6 hours difference between the two times. This difference can be preserved by using setCellValue(value.getTime()) which will automatically shift the times to the default timezone.

Specified by:
setCellValue in interface Cell
Parameters:
value - the date value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For othertypes we will change the cell to a numeric cell and set its value.

setCellValue

public void setCellValue(java.lang.String value)
set a string value for the cell.

Specified by:
setCellValue in interface Cell
Parameters:
value - value to set the cell to. For formulas we'll set the formula cached string result, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

setCellValue

public void setCellValue(RichTextString value)
Set a string value for the cell.

Specified by:
setCellValue in interface Cell
Parameters:
value - value to set the cell to. For formulas we'll set the formula string, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

setCellFormula

public void setCellFormula(java.lang.String formula)
Description copied from interface: Cell
Sets formula for this cell.

Note, this method only sets the formula string and does not calculate the formula value. To set the precalculated value use Cell.setCellValue(double) or Cell.setCellValue(String)

Specified by:
setCellFormula in interface Cell
Parameters:
formula - the formula to set, e.g. "SUM(C4:E4)". If the argument is null then the current formula is removed.

getCellFormula

public java.lang.String getCellFormula()
Description copied from interface: Cell
Return a formula for the cell, for example, SUM(C4:E4)

Specified by:
getCellFormula in interface Cell
Returns:
a formula for the cell

getNumericCellValue

public double getNumericCellValue()
Get the value of the cell as a number. For strings we throw an exception. For blank cells we return a 0. See HSSFDataFormatter for turning this number into a string similar to that which Excel would render this number as.

Specified by:
getNumericCellValue in interface Cell
Returns:
the value of the cell as a number
See Also:
for turning this number into a string similar to that which Excel would render this number as.

getDateCellValue

public java.util.Date getDateCellValue()
Get the value of the cell as a date. For strings we throw an exception. For blank cells we return a null. See HSSFDataFormatter for formatting this date into a string similar to how excel does.

Specified by:
getDateCellValue in interface Cell
Returns:
the value of the cell as a date
See Also:
for formatting this date into a string similar to how excel does.

getStringCellValue

public java.lang.String getStringCellValue()
get the value of the cell as a string - for numeric cells we throw an exception. For blank cells we return an empty string. For formulaCells that are not string Formulas, we throw an exception

Specified by:
getStringCellValue in interface Cell
Returns:
the value of the cell as a string

getRichStringCellValue

public HSSFRichTextString getRichStringCellValue()
get the value of the cell as a string - for numeric cells we throw an exception. For blank cells we return an empty string. For formulaCells that are not string Formulas, we throw an exception

Specified by:
getRichStringCellValue in interface Cell
Returns:
the value of the cell as a XSSFRichTextString

setCellValue

public void setCellValue(boolean value)
set a boolean value for the cell

Specified by:
setCellValue in interface Cell
Parameters:
value - the boolean value to set this cell to. For formulas we'll set the precalculated value, for booleans we'll set its value. For other types we will change the cell to a boolean cell and set its value.

setCellErrorValue

public void setCellErrorValue(byte errorCode)
set a error value for the cell

Specified by:
setCellErrorValue in interface Cell
Parameters:
errorCode - the error value to set this cell to. For formulas we'll set the precalculated value , for errors we'll set its value. For other types we will change the cell to an error cell and set its value.
See Also:
FormulaError

getBooleanCellValue

public boolean getBooleanCellValue()
get the value of the cell as a boolean. For strings, numbers, and errors, we throw an exception. For blank cells we return a false.

Specified by:
getBooleanCellValue in interface Cell
Returns:
the value of the cell as a boolean

getErrorCellValue

public byte getErrorCellValue()
get the value of the cell as an error code. For strings, numbers, and booleans, we throw an exception. For blank cells we return a 0.

Specified by:
getErrorCellValue in interface Cell
Returns:
the value of the cell as an error code
See Also:
for error codes

setCellStyle

public void setCellStyle(CellStyle style)
set the style for the cell. The style should be an HSSFCellStyle created/retreived from the HSSFWorkbook.

Specified by:
setCellStyle in interface Cell
Parameters:
style - reference contained in the workbook
See Also:
HSSFWorkbook.createCellStyle(), HSSFWorkbook.getCellStyleAt(short)

setCellStyle

public void setCellStyle(HSSFCellStyle style)

getCellStyle

public HSSFCellStyle getCellStyle()
get the style for the cell. This is a reference to a cell style contained in the workbook object.

Specified by:
getCellStyle in interface Cell
Returns:
the cell's style. Always not-null. Default cell style has zero index and can be obtained as workbook.getCellStyleAt(0)
See Also:
HSSFWorkbook.getCellStyleAt(short)

getCellValueRecord

protected CellValueRecordInterface getCellValueRecord()
Should only be used by HSSFSheet and friends. Returns the low level CellValueRecordInterface record

Returns:
CellValueRecordInterface representing the cell via the low level api.

setAsActiveCell

public void setAsActiveCell()
Sets this cell as the active cell for the worksheet

Specified by:
setAsActiveCell in interface Cell

toString

public java.lang.String toString()
Returns a string representation of the cell This method returns a simple representation, anthing more complex should be in user code, with knowledge of the semantics of the sheet being processed. Formula cells return the formula string, rather than the formula result. Dates are displayed in dd-MMM-yyyy format Errors are displayed as #ERR<errIdx>

Overrides:
toString in class java.lang.Object

setCellComment

public void setCellComment(Comment comment)
Assign a comment to this cell. If the supplied comment is null, the comment for this cell will be removed.

Specified by:
setCellComment in interface Cell
Parameters:
comment - comment associated with this cell

getCellComment

public HSSFComment getCellComment()
Returns comment associated with this cell

Specified by:
getCellComment in interface Cell
Returns:
comment associated with this cell

removeCellComment

public void removeCellComment()
Removes the comment for this cell, if there is one. WARNING - some versions of excel will loose all comments after performing this action!

Specified by:
removeCellComment in interface Cell

findCellComment

protected static HSSFComment findCellComment(InternalSheet sheet,
                                             int row,
                                             int column)
Cell comment finder. Returns cell comment for the specified sheet, row and column.

Returns:
cell comment or null if not found

getHyperlink

public HSSFHyperlink getHyperlink()
Specified by:
getHyperlink in interface Cell
Returns:
hyperlink associated with this cell or null if not found

setHyperlink

public void setHyperlink(Hyperlink hyperlink)
Assign a hyperlink to this cell

Specified by:
setHyperlink in interface Cell
Parameters:
hyperlink - hyperlink associated with this cell

getCachedFormulaResultType

public int getCachedFormulaResultType()
Only valid for formula cells

Specified by:
getCachedFormulaResultType in interface Cell
Returns:
one of (Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR) depending on the cached value of the formula

getArrayFormulaRange

public CellRangeAddress getArrayFormulaRange()
Description copied from interface: Cell
Only valid for array formula cells

Specified by:
getArrayFormulaRange in interface Cell
Returns:
range of the array formula group that the cell belongs to.

isPartOfArrayFormulaGroup

public boolean isPartOfArrayFormulaGroup()
Specified by:
isPartOfArrayFormulaGroup in interface Cell
Returns:
true if this cell is part of group of cells having a common array formula.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFCellStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFCellStyle

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFCellStyle
All Implemented Interfaces:
CellStyle
public final class HSSFCellStyle
extends java.lang.Object
implements CellStyle

High level representation of the style of a cell in a sheet of a workbook.

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)
See Also:
HSSFWorkbook.createCellStyle(),
HSSFWorkbook.getCellStyleAt(short),
HSSFCell.setCellStyle(HSSFCellStyle)

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.CellStyle
ALIGN_CENTER, ALIGN_CENTER_SELECTION, ALIGN_FILL, ALIGN_GENERAL, ALIGN_JUSTIFY, ALIGN_LEFT, ALIGN_RIGHT, ALT_BARS, BIG_SPOTS, BORDER_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_DASHED, BORDER_DOTTED, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM, BORDER_MEDIUM_DASH_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_MEDIUM_DASHED, BORDER_NONE, BORDER_SLANTED_DASH_DOT, BORDER_THICK, BORDER_THIN, BRICKS, DIAMONDS, FINE_DOTS, LEAST_DOTS, LESS_DOTS, NO_FILL, SOLID_FOREGROUND, SPARSE_DOTS, SQUARES, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, THICK_HORZ_BANDS, THICK_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, THIN_HORZ_BANDS, THIN_VERT_BANDS, VERTICAL_BOTTOM, VERTICAL_CENTER, VERTICAL_JUSTIFY, VERTICAL_TOP
Constructor Summary
protected | HSSFCellStyle(short index, ExtendedFormatRecord rec, HSSFWorkbook workbook) Creates new HSSFCellStyle why would you want to do this??
protected | HSSFCellStyle(short index, ExtendedFormatRecord rec, InternalWorkbook workbook)
Method Summary
void | cloneStyleFrom(CellStyle source) Clones all the style information from another HSSFCellStyle, onto this one.
void | cloneStyleFrom(HSSFCellStyle source)
boolean | equals(java.lang.Object obj)
short | getAlignment() get the type of horizontal alignment for the cell
short | getBorderBottom() get the type of border to use for the bottom border of the cell
short | getBorderLeft() get the type of border to use for the left border of the cell
short | getBorderRight() get the type of border to use for the right border of the cell
short | getBorderTop() get the type of border to use for the top border of the cell
short | getBottomBorderColor() get the color to use for the left border
short | getDataFormat() get the index of the format
java.lang.String | getDataFormatString() Get the contents of the format string, by looking up the DataFormat against the bound workbook
java.lang.String | getDataFormatString(InternalWorkbook workbook) Get the contents of the format string, by looking up the DataFormat against the supplied low level workbook
java.lang.String | getDataFormatString(Workbook workbook) Get the contents of the format string, by looking up the DataFormat against the supplied workbook
short | getFillBackgroundColor() Get the background fill color.
HSSFColor | getFillBackgroundColorColor() Gets the color object representing the current background fill, resolving indexes using the supplied workbook.
short | getFillForegroundColor() Get the foreground fill color.
HSSFColor | getFillForegroundColorColor() Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook.
short | getFillPattern() get the fill pattern (??) - set to 1 to fill with foreground color
HSSFFont | getFont(Workbook parentWorkbook) gets the font for this style
short | getFontIndex() gets the index of the font for this style
boolean | getHidden() get whether the cell's using this style are to be hidden
short | getIndention() get the number of spaces to indent the text in the cell
short | getIndex() get the index within the HSSFWorkbook (sequence within the collection of ExtnededFormat objects)
short | getLeftBorderColor() get the color to use for the left border
boolean | getLocked() get whether the cell's using this style are to be locked
HSSFCellStyle | getParentStyle() Return the parent style for this cell style.
short | getRightBorderColor() get the color to use for the left border
short | getRotation() get the degree of rotation for the text in the cell
short | getTopBorderColor() get the color to use for the top border
java.lang.String | getUserStyleName() Gets the name of the user defined style.
short | getVerticalAlignment() get the type of vertical alignment for the cell
boolean | getWrapText() get whether the text should be wrapped
int | hashCode()
void | setAlignment(short align) set the type of horizontal alignment for the cell
void | setBorderBottom(short border) set the type of border to use for the bottom border of the cell
void | setBorderLeft(short border) set the type of border to use for the left border of the cell
void | setBorderRight(short border) set the type of border to use for the right border of the cell
void | setBorderTop(short border) set the type of border to use for the top border of the cell
void | setBottomBorderColor(short color) set the color to use for the bottom border
void | setDataFormat(short fmt) set the data format (must be a valid format)
void | setFillBackgroundColor(short bg) set the background fill color.
void | setFillForegroundColor(short bg) set the foreground fill color Note: Ensure Foreground color is set prior to background color.
void | setFillPattern(short fp) setting to one fills the cell with the foreground color...
void | setFont(Font font) set the font for this style
void | setFont(HSSFFont font)
void | setHidden(boolean hidden) set the cell's using this style to be hidden
void | setIndention(short indent) set the number of spaces to indent the text in the cell
void | setLeftBorderColor(short color) set the color to use for the left border
void | setLocked(boolean locked) set the cell's using this style to be locked
void | setRightBorderColor(short color) set the color to use for the right border
void | setRotation(short rotation) set the degree of rotation for the text in the cell
void | setTopBorderColor(short color) set the color to use for the top border
void | setUserStyleName(java.lang.String styleName) Sets the name of the user defined style.
void | setVerticalAlignment(short align) set the type of vertical alignment for the cell
void | setWrapText(boolean wrapped) set whether the text should be wrapped
void | verifyBelongsToWorkbook(HSSFWorkbook wb) Verifies that this style belongs to the supplied Workbook.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFCellStyle

protected HSSFCellStyle(short index,
                        ExtendedFormatRecord rec,
                        HSSFWorkbook workbook)
Creates new HSSFCellStyle why would you want to do this??

HSSFCellStyle

protected HSSFCellStyle(short index,
                        ExtendedFormatRecord rec,
                        InternalWorkbook workbook)
Method Detail

getIndex

public short getIndex()
get the index within the HSSFWorkbook (sequence within the collection of ExtnededFormat objects)

Specified by:
getIndex in interface CellStyle
Returns:
unique index number of the underlying record this style represents (probably you don't care unless you're comparing which one is which)

getParentStyle

public HSSFCellStyle getParentStyle()
Return the parent style for this cell style. In most cases this will be null, but in a few cases there'll be a fully defined parent.

setDataFormat

public void setDataFormat(short fmt)
set the data format (must be a valid format)

Specified by:
setDataFormat in interface CellStyle
See Also:
HSSFDataFormat

getDataFormat

public short getDataFormat()
get the index of the format

Specified by:
getDataFormat in interface CellStyle
See Also:
HSSFDataFormat

getDataFormatString

public java.lang.String getDataFormatString()
Get the contents of the format string, by looking up the DataFormat against the bound workbook

Specified by:
getDataFormatString in interface CellStyle
Returns:
the format string or "General" if not found
See Also:
HSSFDataFormat

getDataFormatString

public java.lang.String getDataFormatString(Workbook workbook)
Get the contents of the format string, by looking up the DataFormat against the supplied workbook

Returns:
the format string or "General" if not found
See Also:
HSSFDataFormat

getDataFormatString

public java.lang.String getDataFormatString(InternalWorkbook workbook)
Get the contents of the format string, by looking up the DataFormat against the supplied low level workbook

See Also:
HSSFDataFormat

setFont

public void setFont(Font font)
set the font for this style

Specified by:
setFont in interface CellStyle
Parameters:
font - a font object created or retreived from the HSSFWorkbook object
See Also:
HSSFWorkbook.createFont(), HSSFWorkbook.getFontAt(short)

setFont

public void setFont(HSSFFont font)

getFontIndex

public short getFontIndex()
gets the index of the font for this style

Specified by:
getFontIndex in interface CellStyle
See Also:
HSSFWorkbook.getFontAt(short)

getFont

public HSSFFont getFont(Workbook parentWorkbook)
gets the font for this style

Parameters:
parentWorkbook - The HSSFWorkbook that this style belongs to
See Also:
getFontIndex(), HSSFWorkbook.getFontAt(short)

setHidden

public void setHidden(boolean hidden)
set the cell's using this style to be hidden

Specified by:
setHidden in interface CellStyle
Parameters:
hidden - - whether the cell using this style should be hidden

getHidden

public boolean getHidden()
get whether the cell's using this style are to be hidden

Specified by:
getHidden in interface CellStyle
Returns:
hidden - whether the cell using this style should be hidden

setLocked

public void setLocked(boolean locked)
set the cell's using this style to be locked

Specified by:
setLocked in interface CellStyle
Parameters:
locked - - whether the cell using this style should be locked

getLocked

public boolean getLocked()
get whether the cell's using this style are to be locked

Specified by:
getLocked in interface CellStyle
Returns:
hidden - whether the cell using this style should be locked

setAlignment

public void setAlignment(short align)
set the type of horizontal alignment for the cell

Specified by:
setAlignment in interface CellStyle
Parameters:
align - - the type of alignment
See Also:
CellStyle.ALIGN_GENERAL, CellStyle.ALIGN_LEFT, CellStyle.ALIGN_CENTER, CellStyle.ALIGN_RIGHT, CellStyle.ALIGN_FILL, CellStyle.ALIGN_JUSTIFY, CellStyle.ALIGN_CENTER_SELECTION

getAlignment

public short getAlignment()
get the type of horizontal alignment for the cell

Specified by:
getAlignment in interface CellStyle
Returns:
align - the type of alignment
See Also:
CellStyle.ALIGN_GENERAL, CellStyle.ALIGN_LEFT, CellStyle.ALIGN_CENTER, CellStyle.ALIGN_RIGHT, CellStyle.ALIGN_FILL, CellStyle.ALIGN_JUSTIFY, CellStyle.ALIGN_CENTER_SELECTION

setWrapText

public void setWrapText(boolean wrapped)
set whether the text should be wrapped

Specified by:
setWrapText in interface CellStyle
Parameters:
wrapped - wrap text or not

getWrapText

public boolean getWrapText()
get whether the text should be wrapped

Specified by:
getWrapText in interface CellStyle
Returns:
wrap text or not

setVerticalAlignment

public void setVerticalAlignment(short align)
set the type of vertical alignment for the cell

Specified by:
setVerticalAlignment in interface CellStyle
Parameters:
align - the type of alignment
See Also:
CellStyle.VERTICAL_TOP, CellStyle.VERTICAL_CENTER, CellStyle.VERTICAL_BOTTOM, CellStyle.VERTICAL_JUSTIFY

getVerticalAlignment

public short getVerticalAlignment()
get the type of vertical alignment for the cell

Specified by:
getVerticalAlignment in interface CellStyle
Returns:
align the type of alignment
See Also:
CellStyle.VERTICAL_TOP, CellStyle.VERTICAL_CENTER, CellStyle.VERTICAL_BOTTOM, CellStyle.VERTICAL_JUSTIFY

setRotation

public void setRotation(short rotation)
set the degree of rotation for the text in the cell

Specified by:
setRotation in interface CellStyle
Parameters:
rotation - degrees (between -90 and 90 degrees, of 0xff for vertical)

getRotation

public short getRotation()
get the degree of rotation for the text in the cell

Specified by:
getRotation in interface CellStyle
Returns:
rotation degrees (between -90 and 90 degrees, or 0xff for vertical)

setIndention

public void setIndention(short indent)
set the number of spaces to indent the text in the cell

Specified by:
setIndention in interface CellStyle
Parameters:
indent - - number of spaces

getIndention

public short getIndention()
get the number of spaces to indent the text in the cell

Specified by:
getIndention in interface CellStyle
Returns:
indent - number of spaces

setBorderLeft

public void setBorderLeft(short border)
set the type of border to use for the left border of the cell

Specified by:
setBorderLeft in interface CellStyle
Parameters:
border - type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderLeft

public short getBorderLeft()
get the type of border to use for the left border of the cell

Specified by:
getBorderLeft in interface CellStyle
Returns:
border type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setBorderRight

public void setBorderRight(short border)
set the type of border to use for the right border of the cell

Specified by:
setBorderRight in interface CellStyle
Parameters:
border - type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderRight

public short getBorderRight()
get the type of border to use for the right border of the cell

Specified by:
getBorderRight in interface CellStyle
Returns:
border type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setBorderTop

public void setBorderTop(short border)
set the type of border to use for the top border of the cell

Specified by:
setBorderTop in interface CellStyle
Parameters:
border - type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderTop

public short getBorderTop()
get the type of border to use for the top border of the cell

Specified by:
getBorderTop in interface CellStyle
Returns:
border type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setBorderBottom

public void setBorderBottom(short border)
set the type of border to use for the bottom border of the cell

Specified by:
setBorderBottom in interface CellStyle
Parameters:
border - type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderBottom

public short getBorderBottom()
get the type of border to use for the bottom border of the cell

Specified by:
getBorderBottom in interface CellStyle
Returns:
border type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setLeftBorderColor

public void setLeftBorderColor(short color)
set the color to use for the left border

Specified by:
setLeftBorderColor in interface CellStyle
Parameters:
color - The index of the color definition

getLeftBorderColor

public short getLeftBorderColor()
get the color to use for the left border

Specified by:
getLeftBorderColor in interface CellStyle
Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setRightBorderColor

public void setRightBorderColor(short color)
set the color to use for the right border

Specified by:
setRightBorderColor in interface CellStyle
Parameters:
color - The index of the color definition

getRightBorderColor

public short getRightBorderColor()
get the color to use for the left border

Specified by:
getRightBorderColor in interface CellStyle
Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setTopBorderColor

public void setTopBorderColor(short color)
set the color to use for the top border

Specified by:
setTopBorderColor in interface CellStyle
Parameters:
color - The index of the color definition

getTopBorderColor

public short getTopBorderColor()
get the color to use for the top border

Specified by:
getTopBorderColor in interface CellStyle
Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setBottomBorderColor

public void setBottomBorderColor(short color)
set the color to use for the bottom border

Specified by:
setBottomBorderColor in interface CellStyle
Parameters:
color - The index of the color definition

getBottomBorderColor

public short getBottomBorderColor()
get the color to use for the left border

Specified by:
getBottomBorderColor in interface CellStyle
Returns:
The index of the color definition
See Also:
HSSFPalette.getColor(short)

setFillPattern

public void setFillPattern(short fp)
setting to one fills the cell with the foreground color... No idea about other values

Specified by:
setFillPattern in interface CellStyle
Parameters:
fp - fill pattern (set to 1 to fill w/foreground color)
See Also:
CellStyle.NO_FILL, CellStyle.SOLID_FOREGROUND, CellStyle.FINE_DOTS, CellStyle.ALT_BARS, CellStyle.SPARSE_DOTS, CellStyle.THICK_HORZ_BANDS, CellStyle.THICK_VERT_BANDS, CellStyle.THICK_BACKWARD_DIAG, CellStyle.THICK_FORWARD_DIAG, CellStyle.BIG_SPOTS, CellStyle.BRICKS, CellStyle.THIN_HORZ_BANDS, CellStyle.THIN_VERT_BANDS, CellStyle.THIN_BACKWARD_DIAG, CellStyle.THIN_FORWARD_DIAG, CellStyle.SQUARES, CellStyle.DIAMONDS

getFillPattern

public short getFillPattern()
get the fill pattern (??) - set to 1 to fill with foreground color

Specified by:
getFillPattern in interface CellStyle
Returns:
fill pattern

setFillBackgroundColor

public void setFillBackgroundColor(short bg)
set the background fill color.

For example:

 cs.setFillPattern(HSSFCellStyle.FINE_DOTS );
 cs.setFillBackgroundColor(new HSSFColor.RED().getIndex());
optionally a Foreground and background fill can be applied: Note: Ensure Foreground color is set prior to background
 cs.setFillPattern(HSSFCellStyle.FINE_DOTS );
 cs.setFillForegroundColor(new HSSFColor.BLUE().getIndex());
 cs.setFillBackgroundColor(new HSSFColor.RED().getIndex());
or, for the special case of SOLID_FILL:
 cs.setFillPattern(HSSFCellStyle.SOLID_FOREGROUND );
 cs.setFillForegroundColor(new HSSFColor.RED().getIndex());
It is necessary to set the fill style in order for the color to be shown in the cell.

Specified by:
setFillBackgroundColor in interface CellStyle
Parameters:
bg - color

getFillBackgroundColor

public short getFillBackgroundColor()
Get the background fill color. Note - many cells are actually filled with a foreground fill, not a background fill - see getFillForegroundColor()

Specified by:
getFillBackgroundColor in interface CellStyle
Returns:
fill color
See Also:
HSSFPalette.getColor(short)

getFillBackgroundColorColor

public HSSFColor getFillBackgroundColorColor()
Description copied from interface: CellStyle
Gets the color object representing the current background fill, resolving indexes using the supplied workbook. This will work for both indexed and rgb defined colors.

Specified by:
getFillBackgroundColorColor in interface CellStyle

setFillForegroundColor

public void setFillForegroundColor(short bg)
set the foreground fill color Note: Ensure Foreground color is set prior to background color.

Specified by:
setFillForegroundColor in interface CellStyle
Parameters:
bg - color

getFillForegroundColor

public short getFillForegroundColor()
Get the foreground fill color. Many cells are filled with this, instead of a background color (getFillBackgroundColor())

Specified by:
getFillForegroundColor in interface CellStyle
Returns:
fill color
See Also:
HSSFPalette.getColor(short)

getFillForegroundColorColor

public HSSFColor getFillForegroundColorColor()
Description copied from interface: CellStyle
Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook. This will work for both indexed and rgb defined colors.

Specified by:
getFillForegroundColorColor in interface CellStyle

getUserStyleName

public java.lang.String getUserStyleName()
Gets the name of the user defined style. Returns null for built in styles, and styles where no name has been defined

setUserStyleName

public void setUserStyleName(java.lang.String styleName)
Sets the name of the user defined style. Will complain if you try this on a built in style.

verifyBelongsToWorkbook

public void verifyBelongsToWorkbook(HSSFWorkbook wb)
Verifies that this style belongs to the supplied Workbook. Will throw an exception if it belongs to a different one. This is normally called when trying to assign a style to a cell, to ensure the cell and the style are from the same workbook (if they're not, it won't work)

Throws:
java.lang.IllegalArgumentException - if there's a workbook mis-match

cloneStyleFrom

public void cloneStyleFrom(CellStyle source)
Clones all the style information from another HSSFCellStyle, onto this one. This HSSFCellStyle will then have all the same properties as the source, but the two may be edited independently. Any stylings on this HSSFCellStyle will be lost! The source HSSFCellStyle could be from another HSSFWorkbook if you like. This allows you to copy styles from one HSSFWorkbook to another.

Specified by:
cloneStyleFrom in interface CellStyle

cloneStyleFrom

public void cloneStyleFrom(HSSFCellStyle source)

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFChart.HSSFChartType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hssf.usermodel
Enum HSSFChart.HSSFChartType

java.lang.Object
    extended by  java.lang.Enum<HSSFChart.HSSFChartType>
        extended by  org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<HSSFChart.HSSFChartType>
Enclosing class:
HSSFChart
public static enum HSSFChart.HSSFChartType
extends java.lang.Enum<HSSFChart.HSSFChartType>

Enum Constant Summary
Area
Bar
Line
Pie
Scatter
Unknown
Method Summary
abstract short | getSid()
static HSSFChart.HSSFChartType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static HSSFChart.HSSFChartType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Area

public static final HSSFChart.HSSFChartType Area

Bar

public static final HSSFChart.HSSFChartType Bar

Line

public static final HSSFChart.HSSFChartType Line

Pie

public static final HSSFChart.HSSFChartType Pie

Scatter

public static final HSSFChart.HSSFChartType Scatter

Unknown

public static final HSSFChart.HSSFChartType Unknown
Method Detail

values

public static HSSFChart.HSSFChartType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (HSSFChart.HSSFChartType c : HSSFChart.HSSFChartType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static HSSFChart.HSSFChartType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getSid

public abstract short getSid()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


HSSFChart.HSSFSeries

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFChart.HSSFSeries

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries
Enclosing class:
HSSFChart
public class HSSFChart.HSSFSeries
extends java.lang.Object

A series in a chart

Method Summary
CellRangeAddressBase | getCategoryLabelsCellRange()
LinkedDataRecord | getDataCategoryLabels()
LinkedDataRecord | getDataName()
LinkedDataRecord | getDataSecondaryCategoryLabels()
LinkedDataRecord | getDataValues()
short | getNumValues()
SeriesRecord | getSeries()
java.lang.String | getSeriesTitle() Returns the series' title, if there is one, or null if not
CellRangeAddressBase | getValuesCellRange()
short | getValueType() See SeriesRecord
void | setCategoryLabelsCellRange(CellRangeAddressBase range)
void | setSeriesTitle(java.lang.String title) Changes the series' title, but only if there was one already.
void | setValuesCellRange(CellRangeAddressBase range)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getNumValues

public short getNumValues()

getValueType

public short getValueType()
See SeriesRecord

getSeriesTitle

public java.lang.String getSeriesTitle()
Returns the series' title, if there is one, or null if not

setSeriesTitle

public void setSeriesTitle(java.lang.String title)
Changes the series' title, but only if there was one already. TODO - add in the records if not

getDataName

public LinkedDataRecord getDataName()
Returns:
record with data names

getDataValues

public LinkedDataRecord getDataValues()
Returns:
record with data values

getDataCategoryLabels

public LinkedDataRecord getDataCategoryLabels()
Returns:
record with data category labels

getDataSecondaryCategoryLabels

public LinkedDataRecord getDataSecondaryCategoryLabels()
Returns:
record with data secondary category labels

getSeries

public SeriesRecord getSeries()
Returns:
record with series

getValuesCellRange

public CellRangeAddressBase getValuesCellRange()

getCategoryLabelsCellRange

public CellRangeAddressBase getCategoryLabelsCellRange()

setValuesCellRange

public void setValuesCellRange(CellRangeAddressBase range)

setCategoryLabelsCellRange

public void setCategoryLabelsCellRange(CellRangeAddressBase range)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFChart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFChart

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFChart

public final class HSSFChart
extends java.lang.Object

Has methods for construction of a chart object.

Author:
Glen Stampoultzis (glens at apache.org)

Nested Class Summary
static class | HSSFChart.HSSFChartType
class | HSSFChart.HSSFSeries A series in a chart
Method Summary
void | createBarChart(HSSFWorkbook workbook, HSSFSheet sheet) Creates a bar chart.
HSSFChart.HSSFSeries | createSeries()
int | getChartHeight() Get the height of the chart.
java.lang.String | getChartTitle() Returns the chart's title, if there is one, or null if not
int | getChartWidth() Get the width of the chart.
int | getChartX() Get the X offset of the chart
int | getChartY() Get the Y offset of the chart
HSSFChart.HSSFSeries[] | getSeries() Returns the series of the chart
static HSSFChart[] | getSheetCharts(HSSFSheet sheet) Returns all the charts for the given sheet.
HSSFChart.HSSFChartType | getType()
boolean | removeSeries(HSSFChart.HSSFSeries series)
void | setChartHeight(int height) Sets the height of the chart.
void | setChartTitle(java.lang.String title) Changes the chart's title, but only if there was one already.
void | setChartWidth(int width) Sets the width of the chart.
void | setChartX(int x) Sets the X offset of the chart
void | setChartY(int y) Sets the Y offset of the chart
void | setValueRange(int axisIndex, java.lang.Double minimum, java.lang.Double maximum, java.lang.Double majorUnit, java.lang.Double minorUnit) Set value range (basic Axis Options)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createBarChart

public void createBarChart(HSSFWorkbook workbook,
                           HSSFSheet sheet)
Creates a bar chart. API needs some work. :)

NOTE: Does not yet work... checking it in just so others can take a look.

getSheetCharts

public static HSSFChart[] getSheetCharts(HSSFSheet sheet)
Returns all the charts for the given sheet. NOTE: You won't be able to do very much with these charts yet, as this is very limited support

getChartX

public int getChartX()
Get the X offset of the chart

getChartY

public int getChartY()
Get the Y offset of the chart

getChartWidth

public int getChartWidth()
Get the width of the chart. ChartRecord

getChartHeight

public int getChartHeight()
Get the height of the chart. ChartRecord

setChartX

public void setChartX(int x)
Sets the X offset of the chart

setChartY

public void setChartY(int y)
Sets the Y offset of the chart

setChartWidth

public void setChartWidth(int width)
Sets the width of the chart. ChartRecord

setChartHeight

public void setChartHeight(int height)
Sets the height of the chart. ChartRecord

getSeries

public HSSFChart.HSSFSeries[] getSeries()
Returns the series of the chart

getChartTitle

public java.lang.String getChartTitle()
Returns the chart's title, if there is one, or null if not

setChartTitle

public void setChartTitle(java.lang.String title)
Changes the chart's title, but only if there was one already. TODO - add in the records if not

setValueRange

public void setValueRange(int axisIndex,
                          java.lang.Double minimum,
                          java.lang.Double maximum,
                          java.lang.Double majorUnit,
                          java.lang.Double minorUnit)
Set value range (basic Axis Options)

Parameters:
axisIndex - 0 - primary axis, 1 - secondary axis
minimum - minimum value; Double.NaN - automatic; null - no change
maximum - maximum value; Double.NaN - automatic; null - no change
majorUnit - major unit value; Double.NaN - automatic; null - no change
minorUnit - minor unit value; Double.NaN - automatic; null - no change

createSeries

public HSSFChart.HSSFSeries createSeries()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

removeSeries

public boolean removeSeries(HSSFChart.HSSFSeries series)

getType

public HSSFChart.HSSFChartType getType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFChildAnchor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFChildAnchor

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFAnchor
        extended by  org.apache.poi.hssf.usermodel.HSSFChildAnchor

public final class HSSFChildAnchor
extends HSSFAnchor

Constructor Summary
HSSFChildAnchor()
HSSFChildAnchor(int dx1, int dy1, int dx2, int dy2)
Method Summary
boolean | isHorizontallyFlipped()
boolean | isVerticallyFlipped()
void | setAnchor(int dx1, int dy1, int dx2, int dy2)
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFAnchor
getDx1, getDx2, getDy1, getDy2, setDx1, setDx2, setDy1, setDy2
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFChildAnchor

public HSSFChildAnchor()

HSSFChildAnchor

public HSSFChildAnchor(int dx1,
                       int dy1,
                       int dx2,
                       int dy2)
Method Detail

setAnchor

public void setAnchor(int dx1,
                      int dy1,
                      int dx2,
                      int dy2)

isHorizontallyFlipped

public boolean isHorizontallyFlipped()
Specified by:
isHorizontallyFlipped in class HSSFAnchor

isVerticallyFlipped

public boolean isVerticallyFlipped()
Specified by:
isVerticallyFlipped in class HSSFAnchor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFClientAnchor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFClientAnchor

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFAnchor
        extended by  org.apache.poi.hssf.usermodel.HSSFClientAnchor
All Implemented Interfaces:
ClientAnchor
public final class HSSFClientAnchor
extends HSSFAnchor
implements ClientAnchor

A client anchor is attached to an excel worksheet. It anchors against a top-left and buttom-right cell.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.ClientAnchor
DONT_MOVE_AND_RESIZE, MOVE_AND_RESIZE, MOVE_DONT_RESIZE
Constructor Summary
HSSFClientAnchor()
Creates a new client anchor and defaults all the anchor positions to 0.
HSSFClientAnchor(int dx1, int dy1, int dx2, int dy2, short col1, int row1, short col2, int row2)
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
Method Summary
float | getAnchorHeightInPoints(HSSFSheet sheet) Calculates the height of a client anchor in points.
int | getAnchorType() Gets the anchor type
short | getCol1() Returns the column (0 based) of the first cell.
short | getCol2() Returns the column (0 based) of the second cell.
int | getRow1() Returns the row (0 based) of the first cell.
int | getRow2() Returns the row (0 based) of the second cell.
boolean | isHorizontallyFlipped()
boolean | isVerticallyFlipped()
void | setAnchor(short col1, int row1, int x1, int y1, short col2, int row2, int x2, int y2) Dets the top-left and bottom-right coordinates of the anchor.
void | setAnchorType(int anchorType) Sets the anchor type
void | setCol1(int col1) Sets the column (0 based) of the first cell.
void | setCol1(short col1)
void | setCol2(int col2) Returns the column (0 based) of the second cell.
void | setCol2(short col2)
void | setRow1(int row1) Returns the row (0 based) of the first cell.
void | setRow2(int row2) Returns the row (0 based) of the first cell.
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFAnchor
getDx1, getDx2, getDy1, getDy2, setDx1, setDx2, setDy1, setDy2
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.ClientAnchor
getDx1, getDx2, getDy1, getDy2, setDx1, setDx2, setDy1, setDy2

Constructor Detail

HSSFClientAnchor

public HSSFClientAnchor()
Creates a new client anchor and defaults all the anchor positions to 0.

HSSFClientAnchor

public HSSFClientAnchor(int dx1,
                        int dy1,
                        int dx2,
                        int dy2,
                        short col1,
                        int row1,
                        short col2,
                        int row2)
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.

Parameters:
dx1 - the x coordinate within the first cell.
dy1 - the y coordinate within the first cell.
dx2 - the x coordinate within the second cell.
dy2 - the y coordinate within the second cell.
col1 - the column (0 based) of the first cell.
row1 - the row (0 based) of the first cell.
col2 - the column (0 based) of the second cell.
row2 - the row (0 based) of the second cell.
Method Detail

getAnchorHeightInPoints

public float getAnchorHeightInPoints(HSSFSheet sheet)
Calculates the height of a client anchor in points.

Parameters:
sheet - the sheet the anchor will be attached to
Returns:
the shape height.

getCol1

public short getCol1()
Description copied from interface: ClientAnchor
Returns the column (0 based) of the first cell.

Specified by:
getCol1 in interface ClientAnchor
Returns:
0-based column of the first cell.

setCol1

public void setCol1(short col1)

setCol1

public void setCol1(int col1)
Description copied from interface: ClientAnchor
Sets the column (0 based) of the first cell.

Specified by:
setCol1 in interface ClientAnchor
Parameters:
col1 - 0-based column of the first cell.

getCol2

public short getCol2()
Description copied from interface: ClientAnchor
Returns the column (0 based) of the second cell.

Specified by:
getCol2 in interface ClientAnchor
Returns:
0-based column of the second cell.

setCol2

public void setCol2(short col2)

setCol2

public void setCol2(int col2)
Description copied from interface: ClientAnchor
Returns the column (0 based) of the second cell.

Specified by:
setCol2 in interface ClientAnchor
Parameters:
col2 - 0-based column of the second cell.

getRow1

public int getRow1()
Description copied from interface: ClientAnchor
Returns the row (0 based) of the first cell.

Specified by:
getRow1 in interface ClientAnchor
Returns:
0-based row of the first cell.

setRow1

public void setRow1(int row1)
Description copied from interface: ClientAnchor
Returns the row (0 based) of the first cell.

Specified by:
setRow1 in interface ClientAnchor
Parameters:
row1 - 0-based row of the first cell.

getRow2

public int getRow2()
Description copied from interface: ClientAnchor
Returns the row (0 based) of the second cell.

Specified by:
getRow2 in interface ClientAnchor
Returns:
0-based row of the second cell.

setRow2

public void setRow2(int row2)
Description copied from interface: ClientAnchor
Returns the row (0 based) of the first cell.

Specified by:
setRow2 in interface ClientAnchor
Parameters:
row2 - 0-based row of the first cell.

setAnchor

public void setAnchor(short col1,
                      int row1,
                      int x1,
                      int y1,
                      short col2,
                      int row2,
                      int x2,
                      int y2)
Dets the top-left and bottom-right coordinates of the anchor.

Parameters:
x1 - the x coordinate within the first cell.
y1 - the y coordinate within the first cell.
x2 - the x coordinate within the second cell.
y2 - the y coordinate within the second cell.
col1 - the column (0 based) of the first cell.
row1 - the row (0 based) of the first cell.
col2 - the column (0 based) of the second cell.
row2 - the row (0 based) of the second cell.

isHorizontallyFlipped

public boolean isHorizontallyFlipped()
Specified by:
isHorizontallyFlipped in class HSSFAnchor
Returns:
true if the anchor goes from right to left.

isVerticallyFlipped

public boolean isVerticallyFlipped()
Specified by:
isVerticallyFlipped in class HSSFAnchor
Returns:
true if the anchor goes from bottom to top.

getAnchorType

public int getAnchorType()
Gets the anchor type

0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

Specified by:
getAnchorType in interface ClientAnchor
Returns:
the anchor type
See Also:
ClientAnchor.MOVE_AND_RESIZE, ClientAnchor.MOVE_DONT_RESIZE, ClientAnchor.DONT_MOVE_AND_RESIZE

setAnchorType

public void setAnchorType(int anchorType)
Sets the anchor type

0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

Specified by:
setAnchorType in interface ClientAnchor
Parameters:
anchorType - the anchor type
See Also:
ClientAnchor.MOVE_AND_RESIZE, ClientAnchor.MOVE_DONT_RESIZE, ClientAnchor.DONT_MOVE_AND_RESIZE
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFComment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFComment

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFShape
        extended by  org.apache.poi.hssf.usermodel.HSSFSimpleShape
            extended by  org.apache.poi.hssf.usermodel.HSSFTextbox
                extended by  org.apache.poi.hssf.usermodel.HSSFComment
All Implemented Interfaces:
Comment
public class HSSFComment
extends HSSFTextbox
implements Comment

Represents a cell comment - a sticky note associated with a cell.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFTextbox
HORIZONTAL_ALIGNMENT_CENTERED, HORIZONTAL_ALIGNMENT_DISTRIBUTED, HORIZONTAL_ALIGNMENT_JUSTIFIED, HORIZONTAL_ALIGNMENT_LEFT, HORIZONTAL_ALIGNMENT_RIGHT, OBJECT_TYPE_TEXT, VERTICAL_ALIGNMENT_BOTTOM, VERTICAL_ALIGNMENT_CENTER, VERTICAL_ALIGNMENT_DISTRIBUTED, VERTICAL_ALIGNMENT_JUSTIFY, VERTICAL_ALIGNMENT_TOP
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFSimpleShape
OBJECT_TYPE_COMBO_BOX, OBJECT_TYPE_COMMENT, OBJECT_TYPE_LINE, OBJECT_TYPE_OVAL, OBJECT_TYPE_PICTURE, OBJECT_TYPE_RECTANGLE
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFShape
LINESTYLE_DASHDOTDOTSYS, LINESTYLE_DASHDOTGEL, LINESTYLE_DASHDOTSYS, LINESTYLE_DASHGEL, LINESTYLE_DASHSYS, LINESTYLE_DOTGEL, LINESTYLE_DOTSYS, LINESTYLE_LONGDASHDOTDOTGEL, LINESTYLE_LONGDASHDOTGEL, LINESTYLE_LONGDASHGEL, LINESTYLE_NONE, LINESTYLE_SOLID, LINEWIDTH_DEFAULT, LINEWIDTH_ONE_PT
Constructor Summary
 | HSSFComment(HSSFShape parent, HSSFAnchor anchor) Construct a new comment with the given parent and anchor.
protected | HSSFComment(NoteRecord note, TextObjectRecord txo)
Method Summary
java.lang.String | getAuthor() Name of the original comment author
int | getColumn() Return the column of the cell that contains the comment
protected NoteRecord | getNoteRecord() Returns the underlying Note record
int | getRow() Return the row of the cell that contains the comment
protected TextObjectRecord | getTextObjectRecord() Returns the underlying Text record
boolean | isVisible() Sets whether this comment is visible.
void | setAuthor(java.lang.String author) Name of the original comment author
void | setColumn(int col) Set the column of the cell that contains the comment
void | setColumn(short col) Deprecated. (Nov 2009) use setColumn(int) }
void | setRow(int row) Set the row of the cell that contains the comment
void | setString(RichTextString string) Sets the rich text string used by this comment.
void | setVisible(boolean visible) Returns whether this comment is visible.
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFTextbox
getHorizontalAlignment, getMarginBottom, getMarginLeft, getMarginRight, getMarginTop, getString, getVerticalAlignment, setHorizontalAlignment, setMarginBottom, setMarginLeft, setMarginRight, setMarginTop, setVerticalAlignment
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFSimpleShape
getShapeType, setShapeType
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFShape
countOfAllChildren, getAnchor, getFillColor, getLineStyle, getLineStyleColor, getLineWidth, getParent, isNoFill, setAnchor, setFillColor, setFillColor, setLineStyle, setLineStyleColor, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Comment
getString

Constructor Detail

HSSFComment

public HSSFComment(HSSFShape parent,
                   HSSFAnchor anchor)
Construct a new comment with the given parent and anchor.

Parameters:
parent -
anchor - defines position of this anchor in the sheet

HSSFComment

protected HSSFComment(NoteRecord note,
                      TextObjectRecord txo)
Method Detail

setVisible

public void setVisible(boolean visible)
Returns whether this comment is visible.

Specified by:
setVisible in interface Comment
Parameters:
visible - true if the comment is visible, false otherwise

isVisible

public boolean isVisible()
Sets whether this comment is visible.

Specified by:
isVisible in interface Comment
Returns:
true if the comment is visible, false otherwise

getRow

public int getRow()
Return the row of the cell that contains the comment

Specified by:
getRow in interface Comment
Returns:
the 0-based row of the cell that contains the comment

setRow

public void setRow(int row)
Set the row of the cell that contains the comment

Specified by:
setRow in interface Comment
Parameters:
row - the 0-based row of the cell that contains the comment

getColumn

public int getColumn()
Return the column of the cell that contains the comment

Specified by:
getColumn in interface Comment
Returns:
the 0-based column of the cell that contains the comment

setColumn

public void setColumn(int col)
Set the column of the cell that contains the comment

Specified by:
setColumn in interface Comment
Parameters:
col - the 0-based column of the cell that contains the comment

setColumn

@Deprecated
public void setColumn(short col)
Deprecated. (Nov 2009) use setColumn(int) }

getAuthor

public java.lang.String getAuthor()
Name of the original comment author

Specified by:
getAuthor in interface Comment
Returns:
the name of the original author of the comment

setAuthor

public void setAuthor(java.lang.String author)
Name of the original comment author

Specified by:
setAuthor in interface Comment
Parameters:
author - the name of the original author of the comment

setString

public void setString(RichTextString string)
Sets the rich text string used by this comment.

Specified by:
setString in interface Comment
Overrides:
setString in class HSSFTextbox
Parameters:
string - Sets the rich text string used by this object.

getNoteRecord

protected NoteRecord getNoteRecord()
Returns the underlying Note record

getTextObjectRecord

protected TextObjectRecord getTextObjectRecord()
Returns the underlying Text record

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFConditionalFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFConditionalFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFConditionalFormatting
All Implemented Interfaces:
ConditionalFormatting
public final class HSSFConditionalFormatting
extends java.lang.Object
implements ConditionalFormatting

HSSFConditionalFormatting class encapsulates all settings of Conditional Formatting. The class can be used

  • to make a copy HSSFConditionalFormatting settings.
    • For example:
     HSSFConditionalFormatting cf = sheet.getConditionalFormattingAt(index);
 newSheet.addConditionalFormatting(cf);
  • or to modify existing Conditional Formatting settings (formatting regions and/or rules).
Use HSSFSheet.getSheetConditionalFormatting() to get access to an instance of this class.

To create a new Conditional Formatting set use the following approach:

 // Define a Conditional Formatting rule, which triggers formatting
 // when cell's value is greater or equal than 100.0 and
 // applies patternFormatting defined below.
 HSSFConditionalFormattingRule rule = sheet.createConditionalFormattingRule(
     ComparisonOperator.GE,
     "100.0", // 1st formula
     null     // 2nd formula is not used for comparison operator GE
 );

 // Create pattern with red background
 HSSFPatternFormatting patternFmt = rule.cretePatternFormatting();
 patternFormatting.setFillBackgroundColor(HSSFColor.RED.index);

 // Define a region containing first column
 Region [] regions =
 {
     new Region(1,(short)1,-1,(short)1)
 };

 // Apply Conditional Formatting rule defined above to the regions
 sheet.addConditionalFormatting(regions, rule);

Author:
Dmitriy Kumshayev

Method Summary
 void addRule(ConditionalFormattingRule cfRule)
Add a Conditional Formatting rule.
 void addRule(HSSFConditionalFormattingRule cfRule)
add a Conditional Formatting rule.
 CellRangeAddress[] getFormattingRanges()
 Region[] getFormattingRegions()
Deprecated. (Aug-2008) use getFormattingRanges()
 int getNumberOfRules()
 HSSFConditionalFormattingRule getRule(int idx)
 void setRule(int idx, ConditionalFormattingRule cfRule)
Replaces an existing Conditional Formatting rule at position idx.
 void setRule(int idx, HSSFConditionalFormattingRule cfRule)
Replaces an existing Conditional Formatting rule at position idx.
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getFormattingRegions

public Region[] getFormattingRegions()
Deprecated. (Aug-2008) use getFormattingRanges()

getFormattingRanges

public CellRangeAddress[] getFormattingRanges()
Specified by:
getFormattingRanges in interface ConditionalFormatting
Returns:
array of CellRangeAddresss. never null

setRule

public void setRule(int idx,
                    HSSFConditionalFormattingRule cfRule)
Replaces an existing Conditional Formatting rule at position idx. Excel allows to create up to 3 Conditional Formatting rules. This method can be useful to modify existing Conditional Formatting rules.

Parameters:
idx - position of the rule. Should be between 0 and 2.
cfRule - - Conditional Formatting rule

setRule

public void setRule(int idx,
                    ConditionalFormattingRule cfRule)
Description copied from interface: ConditionalFormatting
Replaces an existing Conditional Formatting rule at position idx. Excel allows to create up to 3 Conditional Formatting rules. This method can be useful to modify existing Conditional Formatting rules.

Specified by:
setRule in interface ConditionalFormatting
Parameters:
idx - position of the rule. Should be between 0 and 2.
cfRule - - Conditional Formatting rule

addRule

public void addRule(HSSFConditionalFormattingRule cfRule)
add a Conditional Formatting rule. Excel allows to create up to 3 Conditional Formatting rules.

Parameters:
cfRule - - Conditional Formatting rule

addRule

public void addRule(ConditionalFormattingRule cfRule)
Description copied from interface: ConditionalFormatting
Add a Conditional Formatting rule. Excel allows to create up to 3 Conditional Formatting rules.

Specified by:
addRule in interface ConditionalFormatting
Parameters:
cfRule - - Conditional Formatting rule

getRule

public HSSFConditionalFormattingRule getRule(int idx)
Specified by:
getRule in interface ConditionalFormatting
Returns:
the Conditional Formatting rule at position idx.

getNumberOfRules

public int getNumberOfRules()
Specified by:
getNumberOfRules in interface ConditionalFormatting
Returns:
number of Conditional Formatting rules.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFConditionalFormattingRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFConditionalFormattingRule

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule
All Implemented Interfaces:
ConditionalFormattingRule
public final class HSSFConditionalFormattingRule
extends java.lang.Object
implements ConditionalFormattingRule

High level representation of Conditional Formatting Rule. It allows to specify formula based conditions for the Conditional Formatting and the formatting settings such as font, border and pattern.

Author:
Dmitriy Kumshayev

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
CONDITION_TYPE_CELL_VALUE_IS, CONDITION_TYPE_FORMULA
Method Summary
HSSFBorderFormatting | createBorderFormatting() create a new border formatting structure if it does not exist, otherwise just return existing object.
HSSFFontFormatting | createFontFormatting() create a new font formatting structure if it does not exist, otherwise just return existing object.
HSSFPatternFormatting | createPatternFormatting() create a new pattern formatting structure if it does not exist, otherwise just return existing object.
HSSFBorderFormatting | getBorderFormatting()
byte | getComparisonOperation() The comparison function used when the type of conditional formatting is set to ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS
byte | getConditionType() Type of conditional formatting rule.
HSSFFontFormatting | getFontFormatting()
java.lang.String | getFormula1() The formula used to evaluate the first operand for the conditional formatting rule.
java.lang.String | getFormula2() The formula used to evaluate the second operand of the comparison when comparison type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN
HSSFPatternFormatting | getPatternFormatting()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getFontFormatting

public HSSFFontFormatting getFontFormatting()
Specified by:
getFontFormatting in interface ConditionalFormattingRule
Returns:
- font formatting object if defined, null otherwise

createFontFormatting

public HSSFFontFormatting createFontFormatting()
create a new font formatting structure if it does not exist, otherwise just return existing object.

Specified by:
createFontFormatting in interface ConditionalFormattingRule
Returns:
- font formatting object, never returns null.

getBorderFormatting

public HSSFBorderFormatting getBorderFormatting()
Specified by:
getBorderFormatting in interface ConditionalFormattingRule
Returns:
- border formatting object if defined, null otherwise

createBorderFormatting

public HSSFBorderFormatting createBorderFormatting()
create a new border formatting structure if it does not exist, otherwise just return existing object.

Specified by:
createBorderFormatting in interface ConditionalFormattingRule
Returns:
- border formatting object, never returns null.

getPatternFormatting

public HSSFPatternFormatting getPatternFormatting()
Specified by:
getPatternFormatting in interface ConditionalFormattingRule
Returns:
- pattern formatting object if defined, null otherwise

createPatternFormatting

public HSSFPatternFormatting createPatternFormatting()
create a new pattern formatting structure if it does not exist, otherwise just return existing object.

Specified by:
createPatternFormatting in interface ConditionalFormattingRule
Returns:
- pattern formatting object, never returns null.

getConditionType

public byte getConditionType()
Description copied from interface: ConditionalFormattingRule
Type of conditional formatting rule.

MUST be either ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS or ConditionalFormattingRule.CONDITION_TYPE_FORMULA

Specified by:
getConditionType in interface ConditionalFormattingRule
Returns:
- the conditiontype for the cfrule

getComparisonOperation

public byte getComparisonOperation()
Description copied from interface: ConditionalFormattingRule
The comparison function used when the type of conditional formatting is set to ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS

MUST be a constant from ComparisonOperator

Specified by:
getComparisonOperation in interface ConditionalFormattingRule
Returns:
- the comparisionoperatation for the cfrule

getFormula1

public java.lang.String getFormula1()
Description copied from interface: ConditionalFormattingRule
The formula used to evaluate the first operand for the conditional formatting rule.

If the condition type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS, this field is the first operand of the comparison. If type is ConditionalFormattingRule.CONDITION_TYPE_FORMULA, this formula is used to determine if the conditional formatting is applied.

If comparison type is ConditionalFormattingRule.CONDITION_TYPE_FORMULA the formula MUST be a Boolean function

Specified by:
getFormula1 in interface ConditionalFormattingRule
Returns:
the first formula

getFormula2

public java.lang.String getFormula2()
Description copied from interface: ConditionalFormattingRule
The formula used to evaluate the second operand of the comparison when comparison type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN

Specified by:
getFormula2 in interface ConditionalFormattingRule
Returns:
the second formula
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFCreationHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFCreationHelper

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFCreationHelper
All Implemented Interfaces:
CreationHelper
public class HSSFCreationHelper
extends java.lang.Object
implements CreationHelper

Method Summary
HSSFClientAnchor | createClientAnchor() Creates a HSSFClientAnchor.
HSSFDataFormat | createDataFormat() Creates a new DataFormat instance
HSSFFormulaEvaluator | createFormulaEvaluator() Creates a HSSFFormulaEvaluator, the object that evaluates formula cells.
HSSFHyperlink | createHyperlink(int type) Creates a new Hyperlink, of the given type
HSSFRichTextString | createRichTextString(java.lang.String text) Creates a new RichTextString instance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createRichTextString

public HSSFRichTextString createRichTextString(java.lang.String text)
Description copied from interface: CreationHelper
Creates a new RichTextString instance

Specified by:
createRichTextString in interface CreationHelper
Parameters:
text - The text to initialise the RichTextString with

createDataFormat

public HSSFDataFormat createDataFormat()
Description copied from interface: CreationHelper
Creates a new DataFormat instance

Specified by:
createDataFormat in interface CreationHelper

createHyperlink

public HSSFHyperlink createHyperlink(int type)
Description copied from interface: CreationHelper
Creates a new Hyperlink, of the given type

Specified by:
createHyperlink in interface CreationHelper

createFormulaEvaluator

public HSSFFormulaEvaluator createFormulaEvaluator()
Creates a HSSFFormulaEvaluator, the object that evaluates formula cells.

Specified by:
createFormulaEvaluator in interface CreationHelper
Returns:
a HSSFFormulaEvaluator instance

createClientAnchor

public HSSFClientAnchor createClientAnchor()
Creates a HSSFClientAnchor. Use this object to position drawing object in a sheet

Specified by:
createClientAnchor in interface CreationHelper
Returns:
a HSSFClientAnchor instance
See Also:
Drawing
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFDataFormat

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFDataFormat

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFDataFormat
All Implemented Interfaces:
DataFormat
public final class HSSFDataFormat
extends java.lang.Object
implements DataFormat

Identifies both built-in and user defined formats within a workbook.

See BuiltinFormats for a list of supported built-in formats.

International Formats
Since version 2003 Excel has supported international formats. These are denoted with a prefix "[$-xxx]" (where xxx is a 1-7 digit hexadecimal number). See the Microsoft article Creating international number formats for more details on these codes.

Author:
Andrew C. Oliver (acoliver at apache dot org), Shawn M. Laubach (slaubach at apache dot org)

Method Summary
static java.lang.String | getBuiltinFormat(short index) get the format string that matches the given format index
static short | getBuiltinFormat(java.lang.String format) get the format index that matches the given format string
static java.util.List<java.lang.String> | getBuiltinFormats()
java.lang.String | getFormat(short index) get the format string that matches the given format index
short | getFormat(java.lang.String pFormat) Get the format index that matches the given format string, creating a new format entry if required.
static int | getNumberOfBuiltinBuiltinFormats() get the number of built-in and reserved builtinFormats
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getBuiltinFormats

public static java.util.List<java.lang.String> getBuiltinFormats()

getBuiltinFormat

public static short getBuiltinFormat(java.lang.String format)
get the format index that matches the given format string

Automatically converts "text" to excel's format string to represent text.

Parameters:
format - string matching a built in format
Returns:
index of format or -1 if undefined.

getFormat

public short getFormat(java.lang.String pFormat)
Get the format index that matches the given format string, creating a new format entry if required. Aliases text to the proper format as required.

Specified by:
getFormat in interface DataFormat
Parameters:
pFormat - string matching a built in format
Returns:
index of format.

getFormat

public java.lang.String getFormat(short index)
get the format string that matches the given format index

Specified by:
getFormat in interface DataFormat
Parameters:
index - of a format
Returns:
string represented at index of format or null if there is not a format at that index

getBuiltinFormat

public static java.lang.String getBuiltinFormat(short index)
get the format string that matches the given format index

Parameters:
index - of a built in format
Returns:
string represented at index of format or null if there is not a builtin format at that index

getNumberOfBuiltinBuiltinFormats

public static int getNumberOfBuiltinBuiltinFormats()
get the number of built-in and reserved builtinFormats

Returns:
number of built-in and reserved builtinFormats
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFDataFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFDataFormatter

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.DataFormatter
        extended by  org.apache.poi.hssf.usermodel.HSSFDataFormatter

public final class HSSFDataFormatter
extends DataFormatter

HSSFDataFormatter contains methods for formatting the value stored in an HSSFCell. This can be useful for reports and GUI presentations when you need to display data exactly as it appears in Excel. Supported formats include currency, SSN, percentages, decimals, dates, phone numbers, zip codes, etc.

Internally, formats will be implemented using subclasses of Format such as DecimalFormat and SimpleDateFormat. Therefore the formats used by this class must obey the same pattern rules as these Format subclasses. This means that only legal number pattern characters ("0", "#", ".", "," etc.) may appear in number formats. Other characters can be inserted before or after the number pattern to form a prefix or suffix.

For example the Excel pattern "$#,##0.00 "USD"_);($#,##0.00 "USD")" will be correctly formatted as "$1,000.00 USD" or "($1,000.00 USD)". However the pattern "00-00-00" is incorrectly formatted by DecimalFormat as "000000--". For Excel formats that are not compatible with DecimalFormat, you can provide your own custom Format implementation via HSSFDataFormatter.addFormat(String,Format). The following custom formats are already provided by this class:

  • SSN "000-00-0000"
    •

  • Phone Number "(###) ###-####"
    •

  • Zip plus 4 "00000-0000"
    •

If the Excel format pattern cannot be parsed successfully, then a default format will be used. The default number format will mimic the Excel General format: "#" for whole numbers and "#.##########" for decimal numbers. You can override the default format pattern with HSSFDataFormatter.setDefaultNumberFormat(Format). Note: the default format will only be used when a Format cannot be created from the cell's data format string.

Author:
James May (james dot may at fmr dot com)

Constructor Summary
HSSFDataFormatter()
Creates a formatter using the default locale.
HSSFDataFormatter(java.util.Locale locale)
Creates a formatter using the given locale.
Method Summary
Methods inherited from class org.apache.poi.ss.usermodel.DataFormatter
addFormat, createFormat, formatCellValue, formatCellValue, formatRawCellContents, formatRawCellContents, getDefaultFormat, setDefaultNumberFormat, setExcelStyleRoundingMode, setExcelStyleRoundingMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFDataFormatter

public HSSFDataFormatter(java.util.Locale locale)
Creates a formatter using the given locale.

HSSFDataFormatter

public HSSFDataFormatter()
Creates a formatter using the default locale.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFDataValidation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFDataValidation

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFDataValidation
All Implemented Interfaces:
DataValidation
public final class HSSFDataValidation
extends java.lang.Object
implements DataValidation

Utility class for creating data validation cells

Author:
Dragos Buleandra (dragos.buleandra@trade2b.ro)

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.usermodel.DataValidation
DataValidation.ErrorStyle
Constructor Summary
HSSFDataValidation(CellRangeAddressList regions, DataValidationConstraint constraint)
Constructor which initializes the cell range on which this object will be applied
Method Summary
DVRecord | createDVRecord(HSSFSheet sheet)
void | createErrorBox(java.lang.String title, java.lang.String text) Sets the title and text for the error box .
void | createPromptBox(java.lang.String title, java.lang.String text) Sets the title and text for the prompt box .
DVConstraint | getConstraint()
boolean | getEmptyCellAllowed() Retrieve the settings for empty cells allowed
java.lang.String | getErrorBoxText()
java.lang.String | getErrorBoxTitle()
int | getErrorStyle() o
java.lang.String | getPromptBoxText()
java.lang.String | getPromptBoxTitle()
CellRangeAddressList | getRegions()
boolean | getShowErrorBox()
boolean | getShowPromptBox()
boolean | getSuppressDropDownArrow() Useful only list validation objects .
DataValidationConstraint | getValidationConstraint()
void | setEmptyCellAllowed(boolean allowed) Sets if this object allows empty as a valid value
void | setErrorStyle(int error_style) Sets the error style for error box
void | setShowErrorBox(boolean show) Sets the behaviour when an invalid value is entered
void | setShowPromptBox(boolean show) Sets the behaviour when a cell which belongs to this object is selected
void | setSuppressDropDownArrow(boolean suppress) Useful for list validation objects .
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFDataValidation

public HSSFDataValidation(CellRangeAddressList regions,
                          DataValidationConstraint constraint)
Constructor which initializes the cell range on which this object will be applied

Parameters:
constraint -
Method Detail

getValidationConstraint

public DataValidationConstraint getValidationConstraint()
Specified by:
getValidationConstraint in interface DataValidation

getConstraint

public DVConstraint getConstraint()

getRegions

public CellRangeAddressList getRegions()
Specified by:
getRegions in interface DataValidation

setErrorStyle

public void setErrorStyle(int error_style)
Description copied from interface: DataValidation
Sets the error style for error box

Specified by:
setErrorStyle in interface DataValidation
See Also:
DataValidation.ErrorStyle

getErrorStyle

public int getErrorStyle()
Description copied from interface: DataValidation
o

Specified by:
getErrorStyle in interface DataValidation
Returns:
the error style of error box
See Also:
DataValidation.ErrorStyle

setEmptyCellAllowed

public void setEmptyCellAllowed(boolean allowed)
Description copied from interface: DataValidation
Sets if this object allows empty as a valid value

Specified by:
setEmptyCellAllowed in interface DataValidation
Parameters:
allowed - true if this object should treats empty as valid value , false otherwise

getEmptyCellAllowed

public boolean getEmptyCellAllowed()
Description copied from interface: DataValidation
Retrieve the settings for empty cells allowed

Specified by:
getEmptyCellAllowed in interface DataValidation
Returns:
True if this object should treats empty as valid value , false otherwise

setSuppressDropDownArrow

public void setSuppressDropDownArrow(boolean suppress)
Description copied from interface: DataValidation
Useful for list validation objects .

Specified by:
setSuppressDropDownArrow in interface DataValidation
Parameters:
suppress - True if a list should display the values into a drop down list , false otherwise . In other words , if a list should display the arrow sign on its right side

getSuppressDropDownArrow

public boolean getSuppressDropDownArrow()
Description copied from interface: DataValidation
Useful only list validation objects . This method always returns false if the object isn't a list validation object

Specified by:
getSuppressDropDownArrow in interface DataValidation
Returns:
true if a list should display the values into a drop down list , false otherwise .

setShowPromptBox

public void setShowPromptBox(boolean show)
Description copied from interface: DataValidation
Sets the behaviour when a cell which belongs to this object is selected

Specified by:
setShowPromptBox in interface DataValidation
Parameters:
show - true if an prompt box should be displayed , false otherwise

getShowPromptBox

public boolean getShowPromptBox()
Specified by:
getShowPromptBox in interface DataValidation
Returns:
true if an prompt box should be displayed , false otherwise

setShowErrorBox

public void setShowErrorBox(boolean show)
Description copied from interface: DataValidation
Sets the behaviour when an invalid value is entered

Specified by:
setShowErrorBox in interface DataValidation
Parameters:
show - true if an error box should be displayed , false otherwise

getShowErrorBox

public boolean getShowErrorBox()
Specified by:
getShowErrorBox in interface DataValidation
Returns:
true if an error box should be displayed , false otherwise

createPromptBox

public void createPromptBox(java.lang.String title,
                            java.lang.String text)
Description copied from interface: DataValidation
Sets the title and text for the prompt box . Prompt box is displayed when the user selects a cell which belongs to this validation object . In order for a prompt box to be displayed you should also use method setShowPromptBox( boolean show )

Specified by:
createPromptBox in interface DataValidation
Parameters:
title - The prompt box's title
text - The prompt box's text

getPromptBoxTitle

public java.lang.String getPromptBoxTitle()
Specified by:
getPromptBoxTitle in interface DataValidation
Returns:
Prompt box's title or null

getPromptBoxText

public java.lang.String getPromptBoxText()
Specified by:
getPromptBoxText in interface DataValidation
Returns:
Prompt box's text or null

createErrorBox

public void createErrorBox(java.lang.String title,
                           java.lang.String text)
Description copied from interface: DataValidation
Sets the title and text for the error box . Error box is displayed when the user enters an invalid value int o a cell which belongs to this validation object . In order for an error box to be displayed you should also use method setShowErrorBox( boolean show )

Specified by:
createErrorBox in interface DataValidation
Parameters:
title - The error box's title
text - The error box's text

getErrorBoxTitle

public java.lang.String getErrorBoxTitle()
Specified by:
getErrorBoxTitle in interface DataValidation
Returns:
Error box's title or null

getErrorBoxText

public java.lang.String getErrorBoxText()
Specified by:
getErrorBoxText in interface DataValidation
Returns:
Error box's text or null

createDVRecord

public DVRecord createDVRecord(HSSFSheet sheet)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFDataValidationHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFDataValidationHelper

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFDataValidationHelper
All Implemented Interfaces:
DataValidationHelper
public class HSSFDataValidationHelper
extends java.lang.Object
implements DataValidationHelper

Author:
Radhakrishnan J

Constructor Summary
HSSFDataValidationHelper(HSSFSheet sheet)
Method Summary
DataValidationConstraint | createCustomConstraint(java.lang.String formula)
DataValidationConstraint | createDateConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2, java.lang.String dateFormat)
DataValidationConstraint | createDecimalConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createExplicitListConstraint(java.lang.String[] listOfValues)
DataValidationConstraint | createFormulaListConstraint(java.lang.String listFormula)
DataValidationConstraint | createIntegerConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createNumericConstraint(int validationType, int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createTextLengthConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createTimeConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidation | createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFDataValidationHelper

public HSSFDataValidationHelper(HSSFSheet sheet)
Method Detail

createDateConstraint

public DataValidationConstraint createDateConstraint(int operatorType,
                                                     java.lang.String formula1,
                                                     java.lang.String formula2,
                                                     java.lang.String dateFormat)
Specified by:
createDateConstraint in interface DataValidationHelper

createExplicitListConstraint

public DataValidationConstraint createExplicitListConstraint(java.lang.String[] listOfValues)
Specified by:
createExplicitListConstraint in interface DataValidationHelper

createFormulaListConstraint

public DataValidationConstraint createFormulaListConstraint(java.lang.String listFormula)
Specified by:
createFormulaListConstraint in interface DataValidationHelper

createNumericConstraint

public DataValidationConstraint createNumericConstraint(int validationType,
                                                        int operatorType,
                                                        java.lang.String formula1,
                                                        java.lang.String formula2)
Specified by:
createNumericConstraint in interface DataValidationHelper

createIntegerConstraint

public DataValidationConstraint createIntegerConstraint(int operatorType,
                                                        java.lang.String formula1,
                                                        java.lang.String formula2)
Specified by:
createIntegerConstraint in interface DataValidationHelper

createDecimalConstraint

public DataValidationConstraint createDecimalConstraint(int operatorType,
                                                        java.lang.String formula1,
                                                        java.lang.String formula2)
Specified by:
createDecimalConstraint in interface DataValidationHelper

createTextLengthConstraint

public DataValidationConstraint createTextLengthConstraint(int operatorType,
                                                           java.lang.String formula1,
                                                           java.lang.String formula2)
Specified by:
createTextLengthConstraint in interface DataValidationHelper

createTimeConstraint

public DataValidationConstraint createTimeConstraint(int operatorType,
                                                     java.lang.String formula1,
                                                     java.lang.String formula2)
Specified by:
createTimeConstraint in interface DataValidationHelper

createCustomConstraint

public DataValidationConstraint createCustomConstraint(java.lang.String formula)
Specified by:
createCustomConstraint in interface DataValidationHelper

createValidation

public DataValidation createValidation(DataValidationConstraint constraint,
                                       CellRangeAddressList cellRangeAddressList)
Specified by:
createValidation in interface DataValidationHelper
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFDateUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFDateUtil

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.DateUtil
        extended by  org.apache.poi.hssf.usermodel.HSSFDateUtil

public class HSSFDateUtil
extends DateUtil

Contains methods for dealing with Excel dates.

Author:
Michael Harhen, Glen Stampoultzis (glens at apache.org), Dan Sherman (dsherman at isisph.com), Hack Kampbjorn (hak at 2mba.dk), Alex Jacoby (ajacoby at gmail.com), Pavel Krupets (pkrupets at palmtreebusiness dot com)

Constructor Summary
HSSFDateUtil()
Method Summary
protected static int absoluteDay(java.util.Calendar cal, boolean use1904windowing)
Methods inherited from class org.apache.poi.ss.usermodel.DateUtil
convertTime, getExcelDate, getExcelDate, getExcelDate, getJavaDate, getJavaDate, isADateFormat, isCellDateFormatted, isCellInternalDateFormatted, isInternalDateFormat, isValidExcelDate, parseYYYYMMDDDate, setCalendar
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFDateUtil

public HSSFDateUtil()
Method Detail

absoluteDay

protected static int absoluteDay(java.util.Calendar cal,
                                 boolean use1904windowing)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFErrorConstants

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFErrorConstants

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.ErrorConstants
        extended by  org.apache.poi.hssf.usermodel.HSSFErrorConstants

public final class HSSFErrorConstants
extends ErrorConstants

Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)

Author:
Michael Harhen

Field Summary
Fields inherited from class org.apache.poi.ss.usermodel.ErrorConstants
ERROR_DIV_0, ERROR_NA, ERROR_NAME, ERROR_NULL, ERROR_NUM, ERROR_REF, ERROR_VALUE
Constructor Summary
HSSFErrorConstants()
Method Summary
Methods inherited from class org.apache.poi.ss.usermodel.ErrorConstants
getText, isValidCode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFErrorConstants

public HSSFErrorConstants()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFEvaluationWorkbook

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFEvaluationWorkbook

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook
All Implemented Interfaces:
EvaluationWorkbook, FormulaParsingWorkbook, FormulaRenderingWorkbook
public final class HSSFEvaluationWorkbook
extends java.lang.Object
implements FormulaRenderingWorkbook, EvaluationWorkbook, FormulaParsingWorkbook

Internal POI use only

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.EvaluationWorkbook
EvaluationWorkbook.ExternalName, EvaluationWorkbook.ExternalSheet
Method Summary
int | convertFromExternSheetIndex(int externSheetIndex)
static HSSFEvaluationWorkbook | create(HSSFWorkbook book)
EvaluationWorkbook.ExternalName | getExternalName(int externSheetIndex, int externNameIndex)
EvaluationWorkbook.ExternalSheet | getExternalSheet(int externSheetIndex)
int | getExternalSheetIndex(java.lang.String sheetName) gets the externSheet index for a sheet from this workbook
int | getExternalSheetIndex(java.lang.String workbookName, java.lang.String sheetName) gets the externSheet index for a sheet from an external workbook
Ptg[] | getFormulaTokens(EvaluationCell evalCell)
EvaluationName | getName(NamePtg namePtg)
EvaluationName | getName(java.lang.String name, int sheetIndex) Lookup a named range by its name.
java.lang.String | getNameText(NamePtg namePtg)
NameXPtg | getNameXPtg(java.lang.String name)
EvaluationSheet | getSheet(int sheetIndex)
int | getSheetIndex(EvaluationSheet evalSheet)
int | getSheetIndex(java.lang.String sheetName) Finds a sheet index by case insensitive name.
java.lang.String | getSheetName(int sheetIndex)
java.lang.String | getSheetNameByExternSheet(int externSheetIndex)
SpreadsheetVersion | getSpreadsheetVersion() Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)
UDFFinder | getUDFFinder()
java.lang.String | resolveNameXText(NameXPtg n)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public static HSSFEvaluationWorkbook create(HSSFWorkbook book)

getExternalSheetIndex

public int getExternalSheetIndex(java.lang.String sheetName)
Description copied from interface: FormulaParsingWorkbook
gets the externSheet index for a sheet from this workbook

Specified by:
getExternalSheetIndex in interface FormulaParsingWorkbook

getExternalSheetIndex

public int getExternalSheetIndex(java.lang.String workbookName,
                                 java.lang.String sheetName)
Description copied from interface: FormulaParsingWorkbook
gets the externSheet index for a sheet from an external workbook

Specified by:
getExternalSheetIndex in interface FormulaParsingWorkbook
Parameters:
workbookName - e.g. "Budget.xls"
sheetName - a name of a sheet in that workbook

getNameXPtg

public NameXPtg getNameXPtg(java.lang.String name)
Specified by:
getNameXPtg in interface FormulaParsingWorkbook

getName

public EvaluationName getName(java.lang.String name,
                              int sheetIndex)
Lookup a named range by its name.

Specified by:
getName in interface EvaluationWorkbook
Specified by:
getName in interface FormulaParsingWorkbook
Parameters:
name - the name to search
sheetIndex - the 0-based index of the sheet this formula belongs to. The sheet index is required to resolve sheet-level names. -1 means workbook-global names

getSheetIndex

public int getSheetIndex(EvaluationSheet evalSheet)
Specified by:
getSheetIndex in interface EvaluationWorkbook
Returns:
-1 if the specified sheet is from a different book

getSheetIndex

public int getSheetIndex(java.lang.String sheetName)
Description copied from interface: EvaluationWorkbook
Finds a sheet index by case insensitive name.

Specified by:
getSheetIndex in interface EvaluationWorkbook
Returns:
the index of the sheet matching the specified name. -1 if not found

getSheetName

public java.lang.String getSheetName(int sheetIndex)
Specified by:
getSheetName in interface EvaluationWorkbook

getSheet

public EvaluationSheet getSheet(int sheetIndex)
Specified by:
getSheet in interface EvaluationWorkbook

convertFromExternSheetIndex

public int convertFromExternSheetIndex(int externSheetIndex)
Specified by:
convertFromExternSheetIndex in interface EvaluationWorkbook

getExternalSheet

public EvaluationWorkbook.ExternalSheet getExternalSheet(int externSheetIndex)
Specified by:
getExternalSheet in interface EvaluationWorkbook
Specified by:
getExternalSheet in interface FormulaRenderingWorkbook
Returns:
null if externSheetIndex refers to a sheet inside the current workbook

getExternalName

public EvaluationWorkbook.ExternalName getExternalName(int externSheetIndex,
                                                       int externNameIndex)
Specified by:
getExternalName in interface EvaluationWorkbook

resolveNameXText

public java.lang.String resolveNameXText(NameXPtg n)
Specified by:
resolveNameXText in interface EvaluationWorkbook
Specified by:
resolveNameXText in interface FormulaRenderingWorkbook

getSheetNameByExternSheet

public java.lang.String getSheetNameByExternSheet(int externSheetIndex)
Specified by:
getSheetNameByExternSheet in interface FormulaRenderingWorkbook

getNameText

public java.lang.String getNameText(NamePtg namePtg)
Specified by:
getNameText in interface FormulaRenderingWorkbook

getName

public EvaluationName getName(NamePtg namePtg)
Specified by:
getName in interface EvaluationWorkbook

getFormulaTokens

public Ptg[] getFormulaTokens(EvaluationCell evalCell)
Specified by:
getFormulaTokens in interface EvaluationWorkbook

getUDFFinder

public UDFFinder getUDFFinder()
Specified by:
getUDFFinder in interface EvaluationWorkbook

getSpreadsheetVersion

public SpreadsheetVersion getSpreadsheetVersion()
Description copied from interface: FormulaParsingWorkbook
Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)

Specified by:
getSpreadsheetVersion in interface FormulaParsingWorkbook
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFFont

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFFont

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFFont
All Implemented Interfaces:
Font
public final class HSSFFont
extends java.lang.Object
implements Font

Represents a Font used in a workbook.

Author:
Andrew C. Oliver
See Also:
HSSFWorkbook.createFont(),
HSSFWorkbook.getFontAt(short),
HSSFCellStyle.setFont(HSSFFont)

Field Summary
static java.lang.String FONT_ARIAL
Arial font
Fields inherited from interface org.apache.poi.ss.usermodel.Font
ANSI_CHARSET, BOLDWEIGHT_BOLD, BOLDWEIGHT_NORMAL, COLOR_NORMAL, COLOR_RED, DEFAULT_CHARSET, SS_NONE, SS_SUB, SS_SUPER, SYMBOL_CHARSET, U_DOUBLE, U_DOUBLE_ACCOUNTING, U_NONE, U_SINGLE, U_SINGLE_ACCOUNTING
Constructor Summary
protected HSSFFont(short index, FontRecord rec)
Creates a new instance of HSSFFont
Method Summary
boolean | equals(java.lang.Object obj)
short | getBoldweight() get the boldness to use
int | getCharSet() get character-set to use.
short | getColor() get the color for the font
short | getFontHeight() get the font height in unit's of 1/20th of a point.
short | getFontHeightInPoints() get the font height
java.lang.String | getFontName() get the name for the font (i.e.
HSSFColor | getHSSFColor(HSSFWorkbook wb) get the color value for the font
short | getIndex() get the index within the HSSFWorkbook (sequence within the collection of Font objects)
boolean | getItalic() get whether to use italics or not
boolean | getStrikeout() get whether to use a strikeout horizontal line through the text or not
short | getTypeOffset() get normal,super or subscript.
byte | getUnderline() get type of text underlining to use
int | hashCode()
void | setBoldweight(short boldweight) set the boldness to use
void | setCharSet(byte charset) set character-set to use.
void | setCharSet(int charset) set character-set to use.
void | setColor(short color) set the color for the font
void | setFontHeight(short height) set the font height in unit's of 1/20th of a point.
void | setFontHeightInPoints(short height) set the font height
void | setFontName(java.lang.String name) set the name for the font (i.e.
void | setItalic(boolean italic) set whether to use italics or not
void | setStrikeout(boolean strikeout) set whether to use a strikeout horizontal line through the text or not
void | setTypeOffset(short offset) set normal,super or subscript.
void | setUnderline(byte underline) set type of text underlining to use
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

FONT_ARIAL

public static final java.lang.String FONT_ARIAL
Arial font

See Also:
Constant Field Values
Constructor Detail

HSSFFont

protected HSSFFont(short index,
                   FontRecord rec)
Creates a new instance of HSSFFont

Method Detail

setFontName

public void setFontName(java.lang.String name)
set the name for the font (i.e. Arial)

Specified by:
setFontName in interface Font
Parameters:
name - String representing the name of the font to use
See Also:
FONT_ARIAL

getFontName

public java.lang.String getFontName()
get the name for the font (i.e. Arial)

Specified by:
getFontName in interface Font
Returns:
String representing the name of the font to use
See Also:
FONT_ARIAL

getIndex

public short getIndex()
get the index within the HSSFWorkbook (sequence within the collection of Font objects)

Specified by:
getIndex in interface Font
Returns:
unique index number of the underlying record this Font represents (probably you don't care unless you're comparing which one is which)

setFontHeight

public void setFontHeight(short height)
set the font height in unit's of 1/20th of a point. Maybe you might want to use the setFontHeightInPoints which matches to the familiar 10, 12, 14 etc..

Specified by:
setFontHeight in interface Font
Parameters:
height - height in 1/20ths of a point
See Also:
setFontHeightInPoints(short)

setFontHeightInPoints

public void setFontHeightInPoints(short height)
set the font height

Specified by:
setFontHeightInPoints in interface Font
Parameters:
height - height in the familiar unit of measure - points
See Also:
setFontHeight(short)

getFontHeight

public short getFontHeight()
get the font height in unit's of 1/20th of a point. Maybe you might want to use the getFontHeightInPoints which matches to the familiar 10, 12, 14 etc..

Specified by:
getFontHeight in interface Font
Returns:
short - height in 1/20ths of a point
See Also:
getFontHeightInPoints()

getFontHeightInPoints

public short getFontHeightInPoints()
get the font height

Specified by:
getFontHeightInPoints in interface Font
Returns:
short - height in the familiar unit of measure - points
See Also:
getFontHeight()

setItalic

public void setItalic(boolean italic)
set whether to use italics or not

Specified by:
setItalic in interface Font
Parameters:
italic - italics or not

getItalic

public boolean getItalic()
get whether to use italics or not

Specified by:
getItalic in interface Font
Returns:
italics or not

setStrikeout

public void setStrikeout(boolean strikeout)
set whether to use a strikeout horizontal line through the text or not

Specified by:
setStrikeout in interface Font
Parameters:
strikeout - or not

getStrikeout

public boolean getStrikeout()
get whether to use a strikeout horizontal line through the text or not

Specified by:
getStrikeout in interface Font
Returns:
strikeout or not

setColor

public void setColor(short color)
set the color for the font

Specified by:
setColor in interface Font
Parameters:
color - to use
See Also:
Note: Use this rather than HSSFColor.AUTOMATIC for default font color, Font.COLOR_RED

getColor

public short getColor()
get the color for the font

Specified by:
getColor in interface Font
Returns:
color to use
See Also:
Font.COLOR_NORMAL, Font.COLOR_RED, HSSFPalette.getColor(short)

getHSSFColor

public HSSFColor getHSSFColor(HSSFWorkbook wb)
get the color value for the font

setBoldweight

public void setBoldweight(short boldweight)
set the boldness to use

Specified by:
setBoldweight in interface Font
Parameters:
boldweight -
See Also:
Font.BOLDWEIGHT_NORMAL, Font.BOLDWEIGHT_BOLD

getBoldweight

public short getBoldweight()
get the boldness to use

Specified by:
getBoldweight in interface Font
Returns:
boldweight
See Also:
Font.BOLDWEIGHT_NORMAL, Font.BOLDWEIGHT_BOLD

setTypeOffset

public void setTypeOffset(short offset)
set normal,super or subscript.

Specified by:
setTypeOffset in interface Font
Parameters:
offset - type to use (none,super,sub)
See Also:
Font.SS_NONE, Font.SS_SUPER, Font.SS_SUB

getTypeOffset

public short getTypeOffset()
get normal,super or subscript.

Specified by:
getTypeOffset in interface Font
Returns:
offset type to use (none,super,sub)
See Also:
Font.SS_NONE, Font.SS_SUPER, Font.SS_SUB

setUnderline

public void setUnderline(byte underline)
set type of text underlining to use

Specified by:
setUnderline in interface Font
Parameters:
underline - type
See Also:
Font.U_NONE, Font.U_SINGLE, Font.U_DOUBLE, Font.U_SINGLE_ACCOUNTING, Font.U_DOUBLE_ACCOUNTING

getUnderline

public byte getUnderline()
get type of text underlining to use

Specified by:
getUnderline in interface Font
Returns:
underlining type
See Also:
Font.U_NONE, Font.U_SINGLE, Font.U_DOUBLE, Font.U_SINGLE_ACCOUNTING, Font.U_DOUBLE_ACCOUNTING

getCharSet

public int getCharSet()
get character-set to use.

Specified by:
getCharSet in interface Font
Returns:
character-set
See Also:
Font.ANSI_CHARSET, Font.DEFAULT_CHARSET, Font.SYMBOL_CHARSET

setCharSet

public void setCharSet(int charset)
set character-set to use.

Specified by:
setCharSet in interface Font
See Also:
Font.ANSI_CHARSET, Font.DEFAULT_CHARSET, Font.SYMBOL_CHARSET

setCharSet

public void setCharSet(byte charset)
set character-set to use.

Specified by:
setCharSet in interface Font
See Also:
Font.ANSI_CHARSET, Font.DEFAULT_CHARSET, Font.SYMBOL_CHARSET

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFFontFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFFontFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFFontFormatting
All Implemented Interfaces:
FontFormatting
public final class HSSFFontFormatting
extends java.lang.Object
implements FontFormatting

High level representation for Font Formatting component of Conditional Formatting settings

Author:
Dmitriy Kumshayev

Field Summary
static byte | U_DOUBLE Underline type - Double
static byte | U_DOUBLE_ACCOUNTING Underline type - Double Accounting
static byte | U_NONE Underline type - None
static byte | U_SINGLE Underline type - Single
static byte | U_SINGLE_ACCOUNTING Underline type - Single Accounting
Fields inherited from interface org.apache.poi.ss.usermodel.FontFormatting
SS_NONE, SS_SUB, SS_SUPER
Constructor Summary
protected HSSFFontFormatting(CFRuleRecord cfRuleRecord)
Method Summary
short | getEscapementType() get the type of super or subscript for the font
short | getFontColorIndex()
protected FontFormatting | getFontFormattingBlock()
int | getFontHeight() gets the height of the font in 1/20th point units
short | getFontWeight() get the font weight for this font (100-1000dec or 0x64-0x3e8).
protected byte[] | getRawRecord()
short | getUnderlineType() get the type of underlining for the font
boolean | isBold() get whether the font weight is set to bold or not
boolean | isEscapementTypeModified()
boolean | isFontCancellationModified()
boolean | isFontOutlineModified()
boolean | isFontShadowModified()
boolean | isFontStyleModified()
boolean | isFontWeightModified()
boolean | isItalic()
boolean | isOutlineOn()
boolean | isShadowOn()
boolean | isStruckout()
boolean | isUnderlineTypeModified()
void | resetFontStyle() set font style options to default values (non-italic, non-bold)
void | setEscapementType(short escapementType) set the escapement type for the font
void | setEscapementTypeModified(boolean modified)
void | setFontCancellationModified(boolean modified)
void | setFontColorIndex(short fci)
void | setFontHeight(int height) Sets the height of the font in 1/20th point units
void | setFontOutlineModified(boolean modified)
void | setFontShadowModified(boolean modified)
void | setFontStyle(boolean italic, boolean bold) set font style options.
void | setFontStyleModified(boolean modified)
void | setOutline(boolean on)
void | setShadow(boolean on)
void | setStrikeout(boolean strike)
void | setUnderlineType(short underlineType) set the type of underlining type for the font
void | setUnderlineTypeModified(boolean modified)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

U_NONE

public static final byte U_NONE
Underline type - None

See Also:
Constant Field Values

U_SINGLE

public static final byte U_SINGLE
Underline type - Single

See Also:
Constant Field Values

U_DOUBLE

public static final byte U_DOUBLE
Underline type - Double

See Also:
Constant Field Values

U_SINGLE_ACCOUNTING

public static final byte U_SINGLE_ACCOUNTING
Underline type - Single Accounting

See Also:
Constant Field Values

U_DOUBLE_ACCOUNTING

public static final byte U_DOUBLE_ACCOUNTING
Underline type - Double Accounting

See Also:
Constant Field Values
Constructor Detail

HSSFFontFormatting

protected HSSFFontFormatting(CFRuleRecord cfRuleRecord)
Method Detail

getFontFormattingBlock

protected FontFormatting getFontFormattingBlock()

getEscapementType

public short getEscapementType()
get the type of super or subscript for the font

Specified by:
getEscapementType in interface FontFormatting
Returns:
super or subscript option
See Also:
FontFormatting.SS_NONE, FontFormatting.SS_SUPER, FontFormatting.SS_SUB

getFontColorIndex

public short getFontColorIndex()
Specified by:
getFontColorIndex in interface FontFormatting
Returns:
font color index

getFontHeight

public int getFontHeight()
gets the height of the font in 1/20th point units

Specified by:
getFontHeight in interface FontFormatting
Returns:
fontheight (in points/20); or -1 if not modified

getFontWeight

public short getFontWeight()
get the font weight for this font (100-1000dec or 0x64-0x3e8). Default is 0x190 for normal and 0x2bc for bold

Returns:
bw - a number between 100-1000 for the fonts "boldness"

getRawRecord

protected byte[] getRawRecord()
See Also:
FontFormatting.getRawRecord()

getUnderlineType

public short getUnderlineType()
get the type of underlining for the font

Specified by:
getUnderlineType in interface FontFormatting
Returns:
font underlining type
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

isBold

public boolean isBold()
get whether the font weight is set to bold or not

Specified by:
isBold in interface FontFormatting
Returns:
bold - whether the font is bold or not

isEscapementTypeModified

public boolean isEscapementTypeModified()
Returns:
true if escapement type was modified from default

isFontCancellationModified

public boolean isFontCancellationModified()
Returns:
true if font cancellation was modified from default

isFontOutlineModified

public boolean isFontOutlineModified()
Returns:
true if font outline type was modified from default

isFontShadowModified

public boolean isFontShadowModified()
Returns:
true if font shadow type was modified from default

isFontStyleModified

public boolean isFontStyleModified()
Returns:
true if font style was modified from default

isItalic

public boolean isItalic()
Specified by:
isItalic in interface FontFormatting
Returns:
true if font style was set to italic

isOutlineOn

public boolean isOutlineOn()
Returns:
true if font outline is on

isShadowOn

public boolean isShadowOn()
Returns:
true if font shadow is on

isStruckout

public boolean isStruckout()
Returns:
true if font strikeout is on

isUnderlineTypeModified

public boolean isUnderlineTypeModified()
Returns:
true if font underline type was modified from default

isFontWeightModified

public boolean isFontWeightModified()
Returns:
true if font weight was modified from default

setFontStyle

public void setFontStyle(boolean italic,
                         boolean bold)
set font style options.

Specified by:
setFontStyle in interface FontFormatting
Parameters:
italic - - if true, set posture style to italic, otherwise to normal
bold - if true, set font weight to bold, otherwise to normal

resetFontStyle

public void resetFontStyle()
set font style options to default values (non-italic, non-bold)

Specified by:
resetFontStyle in interface FontFormatting

setEscapementType

public void setEscapementType(short escapementType)
set the escapement type for the font

Specified by:
setEscapementType in interface FontFormatting
Parameters:
escapementType - super or subscript option
See Also:
FontFormatting.SS_NONE, FontFormatting.SS_SUPER, FontFormatting.SS_SUB

setEscapementTypeModified

public void setEscapementTypeModified(boolean modified)
Parameters:
modified -
See Also:
FontFormatting.setEscapementTypeModified(boolean)

setFontCancellationModified

public void setFontCancellationModified(boolean modified)
Parameters:
modified -
See Also:
FontFormatting.setFontCancellationModified(boolean)

setFontColorIndex

public void setFontColorIndex(short fci)
Specified by:
setFontColorIndex in interface FontFormatting
Parameters:
fci -
See Also:
FontFormatting.setFontColorIndex(short)

setFontHeight

public void setFontHeight(int height)
Description copied from interface: FontFormatting
Sets the height of the font in 1/20th point units

Specified by:
setFontHeight in interface FontFormatting
Parameters:
height -
See Also:
FontFormatting.setFontHeight(int)

setFontOutlineModified

public void setFontOutlineModified(boolean modified)
Parameters:
modified -
See Also:
FontFormatting.setFontOutlineModified(boolean)

setFontShadowModified

public void setFontShadowModified(boolean modified)
Parameters:
modified -
See Also:
FontFormatting.setFontShadowModified(boolean)

setFontStyleModified

public void setFontStyleModified(boolean modified)
Parameters:
modified -
See Also:
FontFormatting.setFontStyleModified(boolean)

setOutline

public void setOutline(boolean on)
Parameters:
on -
See Also:
FontFormatting.setOutline(boolean)

setShadow

public void setShadow(boolean on)
Parameters:
on -
See Also:
FontFormatting.setShadow(boolean)

setStrikeout

public void setStrikeout(boolean strike)
Parameters:
strike -
See Also:
FontFormatting.setStrikeout(boolean)

setUnderlineType

public void setUnderlineType(short underlineType)
set the type of underlining type for the font

Specified by:
setUnderlineType in interface FontFormatting
Parameters:
underlineType - super or subscript option
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

setUnderlineTypeModified

public void setUnderlineTypeModified(boolean modified)
Parameters:
modified -
See Also:
FontFormatting.setUnderlineTypeModified(boolean)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFFooter

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HeaderFooter
        extended by  org.apache.poi.hssf.usermodel.HSSFFooter
All Implemented Interfaces:
Footer, HeaderFooter
public final class HSSFFooter
extends HeaderFooter
implements Footer

Class to read and manipulate the footer.

The footer works by having a left, center, and right side. The total cannot be more that 255 bytes long. One uses this class by getting the HSSFFooter from HSSFSheet and then getting or setting the left, center, and right side. For special things (such as page numbers and date), one can use a the methods that return the characters used to represent these. One can also change the fonts by using similar methods.

Author:
Shawn Laubach (slaubach at apache dot org)

Constructor Summary
protected HSSFFooter(PageSettingsBlock psb)
Method Summary
protected java.lang.String | getRawText()
protected void | setHeaderFooterText(java.lang.String text)
Methods inherited from class org.apache.poi.hssf.usermodel.HeaderFooter
date, endBold, endDoubleUnderline, endUnderline, file, font, fontSize, getCenter, getLeft, getRight, numPages, page, setCenter, setLeft, setRight, startBold, startDoubleUnderline, startUnderline, stripFields, tab, time
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Footer
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

HSSFFooter

protected HSSFFooter(PageSettingsBlock psb)
Method Detail

getRawText

protected java.lang.String getRawText()
Specified by:
getRawText in class HeaderFooter
Returns:
the internal text representation (combining center, left and right parts). Possibly empty string if no header or footer is set. Never null.

setHeaderFooterText

protected void setHeaderFooterText(java.lang.String text)
Specified by:
setHeaderFooterText in class HeaderFooter
Parameters:
text - the new header footer text (contains mark-up tags). Possibly empty string never null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFFormulaEvaluator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFFormulaEvaluator

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator
All Implemented Interfaces:
FormulaEvaluator
public class HSSFFormulaEvaluator
extends java.lang.Object
implements FormulaEvaluator

Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values. Be sure to call clearAllCachedResultValues() if any workbook cells are changed between calls to evaluate~ methods on this class.

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >, Josh Micich

Constructor Summary
HSSFFormulaEvaluator(HSSFSheet sheet, HSSFWorkbook workbook)
Deprecated. (Sep 2008) HSSFSheet parameter is ignored
HSSFFormulaEvaluator(HSSFWorkbook workbook)
HSSFFormulaEvaluator(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier)
Method Summary
void | clearAllCachedResultValues() Should be called whenever there are major changes (e.g.
static HSSFFormulaEvaluator | create(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
CellValue | evaluate(Cell cell) If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
void | evaluateAll() Loops over all cells in all sheets of the supplied workbook.
static void | evaluateAllFormulaCells(HSSFWorkbook wb) Loops over all cells in all sheets of the supplied workbook.
static void | evaluateAllFormulaCells(Workbook wb) Loops over all cells in all sheets of the supplied workbook.
int | evaluateFormulaCell(Cell cell) If cell contains formula, it evaluates the formula, and saves the result of the formula.
HSSFCell | evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
void | notifyDeleteCell(Cell cell) Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed
void | notifyDeleteCell(HSSFCell cell) Should be called to tell the cell value cache that the specified cell has just been deleted.
void | notifySetFormula(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
void | notifyUpdateCell(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
void | notifyUpdateCell(HSSFCell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
void | setCurrentRow(HSSFRow row) Deprecated. (Aug 2008) - not needed, since the current row can be derived from the cell
void | setIgnoreMissingWorkbooks(boolean ignore) Whether to ignore missing references to external workbooks and use cached formula results in the main workbook instead.
static void | setupEnvironment(java.lang.String[] workbookNames, HSSFFormulaEvaluator[] evaluators) Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFFormulaEvaluator

public HSSFFormulaEvaluator(HSSFSheet sheet,
                            HSSFWorkbook workbook)
Deprecated. (Sep 2008) HSSFSheet parameter is ignored

HSSFFormulaEvaluator

public HSSFFormulaEvaluator(HSSFWorkbook workbook)

HSSFFormulaEvaluator

public HSSFFormulaEvaluator(HSSFWorkbook workbook,
                            IStabilityClassifier stabilityClassifier)
Parameters:
stabilityClassifier - used to optimise caching performance. Pass null for the (conservative) assumption that any cell may have its definition changed after evaluation begins.
Method Detail

create

public static HSSFFormulaEvaluator create(HSSFWorkbook workbook,
                                          IStabilityClassifier stabilityClassifier,
                                          UDFFinder udfFinder)
Parameters:
stabilityClassifier - used to optimise caching performance. Pass null for the (conservative) assumption that any cell may have its definition changed after evaluation begins.
udfFinder - pass null for default (AnalysisToolPak only)

setupEnvironment

public static void setupEnvironment(java.lang.String[] workbookNames,
                                    HSSFFormulaEvaluator[] evaluators)
Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.

Parameters:
workbookNames - the simple file names used to identify the workbooks in formulas with external links (for example "MyData.xls" as used in a formula "[MyData.xls]Sheet1!A1")
evaluators - all evaluators for the full set of workbooks required by the formulas.

setCurrentRow

public void setCurrentRow(HSSFRow row)
Deprecated. (Aug 2008) - not needed, since the current row can be derived from the cell

Does nothing

clearAllCachedResultValues

public void clearAllCachedResultValues()
Should be called whenever there are major changes (e.g. moving sheets) to input cells in the evaluated workbook. If performance is not critical, a single call to this method may be used instead of many specific calls to the notify~ methods. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

Specified by:
clearAllCachedResultValues in interface FormulaEvaluator

notifyUpdateCell

public void notifyUpdateCell(HSSFCell cell)
Should be called to tell the cell value cache that the specified (value or formula) cell has changed. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

notifyUpdateCell

public void notifyUpdateCell(Cell cell)
Description copied from interface: FormulaEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

Specified by:
notifyUpdateCell in interface FormulaEvaluator

notifyDeleteCell

public void notifyDeleteCell(HSSFCell cell)
Should be called to tell the cell value cache that the specified cell has just been deleted. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

notifyDeleteCell

public void notifyDeleteCell(Cell cell)
Description copied from interface: FormulaEvaluator
Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed

Specified by:
notifyDeleteCell in interface FormulaEvaluator

notifySetFormula

public void notifySetFormula(Cell cell)
Should be called to tell the cell value cache that the specified (value or formula) cell has changed. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

Specified by:
notifySetFormula in interface FormulaEvaluator

evaluate

public CellValue evaluate(Cell cell)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type. This method should be preferred over evaluateInCell() when the call should not modify the contents of the original cell.

Specified by:
evaluate in interface FormulaEvaluator
Parameters:
cell - may be null signifying that the cell is not present (or blank)
Returns:
null if the supplied cell is null or blank

evaluateFormulaCell

public int evaluateFormulaCell(Cell cell)
If cell contains formula, it evaluates the formula, and saves the result of the formula. The cell remains as a formula cell. If the cell does not contain formula, this method returns -1 and leaves the cell unchanged. Note that the type of the formula result is returned, so you know what kind of cached formula result is also stored with the formula.
 int evaluatedCellType = evaluator.evaluateFormulaCell(cell);
Be aware that your cell will hold both the formula, and the result. If you want the cell replaced with the result of the formula, use evaluateInCell(org.apache.poi.ss.usermodel.Cell)

Specified by:
evaluateFormulaCell in interface FormulaEvaluator
Parameters:
cell - The cell to evaluate
Returns:
-1 for non-formula cells, or the type of the formula result

evaluateInCell

public HSSFCell evaluateInCell(Cell cell)
If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula. Else if cell does not contain formula, this method leaves the cell unchanged. Note that the same instance of HSSFCell is returned to allow chained calls like:
 int evaluatedCellType = evaluator.evaluateInCell(cell).getCellType();
Be aware that your cell value will be changed to hold the result of the formula. If you simply want the formula value computed for you, use evaluateFormulaCell(Cell)}

Specified by:
evaluateInCell in interface FormulaEvaluator

evaluateAllFormulaCells

public static void evaluateAllFormulaCells(HSSFWorkbook wb)
Loops over all cells in all sheets of the supplied workbook. For cells that contain formulas, their formulas are evaluated, and the results are saved. These cells remain as formula cells. For cells that do not contain formulas, no changes are made. This is a helpful wrapper around looping over all cells, and calling evaluateFormulaCell on each one.

evaluateAllFormulaCells

public static void evaluateAllFormulaCells(Workbook wb)
Loops over all cells in all sheets of the supplied workbook. For cells that contain formulas, their formulas are evaluated, and the results are saved. These cells remain as formula cells. For cells that do not contain formulas, no changes are made. This is a helpful wrapper around looping over all cells, and calling evaluateFormulaCell on each one.

evaluateAll

public void evaluateAll()
Loops over all cells in all sheets of the supplied workbook. For cells that contain formulas, their formulas are evaluated, and the results are saved. These cells remain as formula cells. For cells that do not contain formulas, no changes are made. This is a helpful wrapper around looping over all cells, and calling evaluateFormulaCell on each one.

Specified by:
evaluateAll in interface FormulaEvaluator

setIgnoreMissingWorkbooks

public void setIgnoreMissingWorkbooks(boolean ignore)
Whether to ignore missing references to external workbooks and use cached formula results in the main workbook instead.

In some cases exetrnal workbooks referenced by formulas in the main workbook are not avaiable. With this method you can control how POI handles such missing references:

  • by default ignoreMissingWorkbooks=false and POI throws CollaboratingWorkbooksEnvironment.WorkbookNotFoundException if an external reference cannot be resolved
  • if ignoreMissingWorkbooks=true then POI uses cached formula result that already exists in the main workbook

Parameters:
ignore - whether to ignore missing references to external workbooks
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFHeader

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HeaderFooter
        extended by  org.apache.poi.hssf.usermodel.HSSFHeader
All Implemented Interfaces:
Header, HeaderFooter
public final class HSSFHeader
extends HeaderFooter
implements Header

Class to read and manipulate the header.

The header works by having a left, center, and right side. The total cannot be more that 255 bytes long. One uses this class by getting the HSSFHeader from HSSFSheet and then getting or setting the left, center, and right side. For special things (such as page numbers and date), one can use a the methods that return the characters used to represent these. One can also change the fonts by using similar methods.

Author:
Shawn Laubach (slaubach at apache dot org)

Constructor Summary
protected HSSFHeader(PageSettingsBlock psb)
Method Summary
protected java.lang.String | getRawText()
protected void | setHeaderFooterText(java.lang.String text)
Methods inherited from class org.apache.poi.hssf.usermodel.HeaderFooter
date, endBold, endDoubleUnderline, endUnderline, file, font, fontSize, getCenter, getLeft, getRight, numPages, page, setCenter, setLeft, setRight, startBold, startDoubleUnderline, startUnderline, stripFields, tab, time
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Header
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

HSSFHeader

protected HSSFHeader(PageSettingsBlock psb)
Method Detail

getRawText

protected java.lang.String getRawText()
Specified by:
getRawText in class HeaderFooter
Returns:
the internal text representation (combining center, left and right parts). Possibly empty string if no header or footer is set. Never null.

setHeaderFooterText

protected void setHeaderFooterText(java.lang.String text)
Specified by:
setHeaderFooterText in class HeaderFooter
Parameters:
text - the new header footer text (contains mark-up tags). Possibly empty string never null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFHyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFHyperlink

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFHyperlink
All Implemented Interfaces:
Hyperlink
public class HSSFHyperlink
extends java.lang.Object
implements Hyperlink

Represents an Excel hyperlink.

Author:
Yegor Kozlov (yegor at apache dot org)

Field Summary
static int | LINK_DOCUMENT Link to a place in this document
static int | LINK_EMAIL Link to an E-mail address
static int | LINK_FILE Link to a file
protected int | link_type If we create a new hypelrink remember its type
static int | LINK_URL Link to a existing file or web page
protected HyperlinkRecord | record Low-level record object that stores the actual hyperlink data
Constructor Summary
protected | HSSFHyperlink(HyperlinkRecord record) Initialize the hyperlink by a HyperlinkRecord record
 | HSSFHyperlink(int type) Construct a new hyperlink
Method Summary
java.lang.String | getAddress() Hypelink address.
int | getFirstColumn() Return the column of the first cell that contains the hyperlink
int | getFirstRow() Return the row of the first cell that contains the hyperlink
java.lang.String | getLabel() Return text label for this hyperlink
int | getLastColumn() Return the column of the last cell that contains the hyperlink
int | getLastRow() Return the row of the last cell that contains the hyperlink
java.lang.String | getShortFilename()
java.lang.String | getTextMark()
int | getType() Return the type of this hyperlink
void | setAddress(java.lang.String address) Hypelink address.
void | setFirstColumn(int col) Set the column of the first cell that contains the hyperlink
void | setFirstRow(int row) Set the row of the first cell that contains the hyperlink
void | setLabel(java.lang.String label) Sets text label for this hyperlink
void | setLastColumn(int col) Set the column of the last cell that contains the hyperlink
void | setLastRow(int row) Set the row of the last cell that contains the hyperlink
void | setShortFilename(java.lang.String shortFilename) Convenience method equivalent to setAddress(String)
void | setTextMark(java.lang.String textMark) Convenience method equivalent to setAddress(String)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LINK_URL

public static final int LINK_URL
Link to a existing file or web page

See Also:
Constant Field Values

LINK_DOCUMENT

public static final int LINK_DOCUMENT
Link to a place in this document

See Also:
Constant Field Values

LINK_EMAIL

public static final int LINK_EMAIL
Link to an E-mail address

See Also:
Constant Field Values

LINK_FILE

public static final int LINK_FILE
Link to a file

See Also:
Constant Field Values

record

protected HyperlinkRecord record
Low-level record object that stores the actual hyperlink data

link_type

protected int link_type
If we create a new hypelrink remember its type

Constructor Detail

HSSFHyperlink

public HSSFHyperlink(int type)
Construct a new hyperlink

Parameters:
type - the type of hyperlink to create

HSSFHyperlink

protected HSSFHyperlink(HyperlinkRecord record)
Initialize the hyperlink by a HyperlinkRecord record

Parameters:
record -
Method Detail

getFirstRow

public int getFirstRow()
Return the row of the first cell that contains the hyperlink

Returns:
the 0-based row of the cell that contains the hyperlink

setFirstRow

public void setFirstRow(int row)
Set the row of the first cell that contains the hyperlink

Parameters:
row - the 0-based row of the first cell that contains the hyperlink

getLastRow

public int getLastRow()
Return the row of the last cell that contains the hyperlink

Returns:
the 0-based row of the last cell that contains the hyperlink

setLastRow

public void setLastRow(int row)
Set the row of the last cell that contains the hyperlink

Parameters:
row - the 0-based row of the last cell that contains the hyperlink

getFirstColumn

public int getFirstColumn()
Return the column of the first cell that contains the hyperlink

Returns:
the 0-based column of the first cell that contains the hyperlink

setFirstColumn

public void setFirstColumn(int col)
Set the column of the first cell that contains the hyperlink

Parameters:
col - the 0-based column of the first cell that contains the hyperlink

getLastColumn

public int getLastColumn()
Return the column of the last cell that contains the hyperlink

Returns:
the 0-based column of the last cell that contains the hyperlink

setLastColumn

public void setLastColumn(int col)
Set the column of the last cell that contains the hyperlink

Parameters:
col - the 0-based column of the last cell that contains the hyperlink

getAddress

public java.lang.String getAddress()
Hypelink address. Depending on the hyperlink type it can be URL, e-mail, path to a file, etc.

Specified by:
getAddress in interface Hyperlink
Returns:
the address of this hyperlink

getTextMark

public java.lang.String getTextMark()

setTextMark

public void setTextMark(java.lang.String textMark)
Convenience method equivalent to setAddress(String)

Parameters:
textMark - the place in worksheet this hypelrink referes to, e.g. 'Target Sheet'!A1'

getShortFilename

public java.lang.String getShortFilename()

setShortFilename

public void setShortFilename(java.lang.String shortFilename)
Convenience method equivalent to setAddress(String)

Parameters:
shortFilename - the path to a file this hypelrink points to, e.g. 'readme.txt'

setAddress

public void setAddress(java.lang.String address)
Hypelink address. Depending on the hyperlink type it can be URL, e-mail, patrh to a file, etc.

Specified by:
setAddress in interface Hyperlink
Parameters:
address - the address of this hyperlink

getLabel

public java.lang.String getLabel()
Return text label for this hyperlink

Specified by:
getLabel in interface Hyperlink
Returns:
text to display

setLabel

public void setLabel(java.lang.String label)
Sets text label for this hyperlink

Specified by:
setLabel in interface Hyperlink
Parameters:
label - text label for this hyperlink

getType

public int getType()
Return the type of this hyperlink

Specified by:
getType in interface Hyperlink
Returns:
the type of this hyperlink
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFName

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFName

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFName
All Implemented Interfaces:
Name
public final class HSSFName
extends java.lang.Object
implements Name

High Level Representation of a 'defined name' which could be a 'built-in' name, 'named range' or name of a user defined function.

Author:
Libin Roman (Vista Portal LDT. Developer)

Method Summary
 java.lang.String getComment()
Returns the comment the user provided when the name was created.
 java.lang.String getNameName()
Gets the name of the named range
 java.lang.String getReference()
Deprecated. (Nov 2008) Misleading name. Use getRefersToFormula() instead.
 java.lang.String getRefersToFormula()
Returns the formula that the name is defined to refer to.
 int getSheetIndex()
Returns the sheet index this name applies to.
 java.lang.String getSheetName()
Get the sheets name which this named range is referenced to
 boolean isDeleted()
Checks if this name points to a cell that no longer exists
 boolean isFunctionName()
Checks if this name is a function name
 void setComment(java.lang.String comment)
Sets the comment the user provided when the name was created.
 void setFunction(boolean value)
Indicates that the defined name refers to a user-defined function.
 void setNameName(java.lang.String nameName)
Sets the name of the named range
 void setReference(java.lang.String ref)
Deprecated. (Nov 2008) Misleading name. Use setRefersToFormula(String) instead.
 void setRefersToFormula(java.lang.String formulaText)
Sets the formula that the name is defined to refer to.
 void setSheetIndex(int index)
Specifies if the defined name is a local name, and if so, which sheet it is on.
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getSheetName

public java.lang.String getSheetName()
Get the sheets name which this named range is referenced to

Specified by:
getSheetName in interface Name
Returns:
sheet name, which this named range referred to

getNameName

public java.lang.String getNameName()
Description copied from interface: Name
Gets the name of the named range

Specified by:
getNameName in interface Name
Returns:
text name of this defined name

setNameName

public void setNameName(java.lang.String nameName)
Sets the name of the named range

The following is a list of syntax rules that you need to be aware of when you create and edit names.

  • Valid characters The first character of a name must be a letter, an underscore character (_), or a backslash (\). Remaining characters in the name can be letters, numbers, periods, and underscore characters.
  • Cell references disallowed Names cannot be the same as a cell reference, such as Z$100 or R1C1.
  • Spaces are not valid Spaces are not allowed as part of a name. Use the underscore character (_) and period (.) as word separators, such as, Sales_Tax or First.Quarter.
  • Name length A name can contain up to 255 characters.
  • Case sensitivity Names can contain uppercase and lowercase letters.

A name must always be unique within its scope. POI prevents you from defining a name that is not unique within its scope. However you can use the same name in different scopes. Example:

 //by default names are workbook-global
 HSSFName name;
 name = workbook.createName();
 name.setNameName("sales_08");

 name = workbook.createName();
 name.setNameName("sales_08"); //will throw an exception: "The workbook already contains this name (case-insensitive)"

 //create sheet-level name
 name = workbook.createName();
 name.setSheetIndex(0); //the scope of the name is the first sheet
 name.setNameName("sales_08");  //ok

 name = workbook.createName();
 name.setSheetIndex(0);
 name.setNameName("sales_08");  //will throw an exception: "The sheet already contains this name (case-insensitive)"

Specified by:
setNameName in interface Name
Parameters:
nameName - named range name to set
Throws:
java.lang.IllegalArgumentException - if the name is invalid or the name already exists (case-insensitive)

getReference

public java.lang.String getReference()
Deprecated. (Nov 2008) Misleading name. Use getRefersToFormula() instead.

Returns the formula that the name is defined to refer to.

setReference

public void setReference(java.lang.String ref)
Deprecated. (Nov 2008) Misleading name. Use setRefersToFormula(String) instead.

Sets the formula that the name is defined to refer to.

setRefersToFormula

public void setRefersToFormula(java.lang.String formulaText)
Description copied from interface: Name
Sets the formula that the name is defined to refer to. The following are representative examples:
  • 'My Sheet'!$A$3
  • 8.3
  • HR!$A$1:$Z$345
  • SUM(Sheet1!A1,Sheet2!B2)
  • -PMT(Interest_Rate/12,Number_of_Payments,Loan_Amount)

Specified by:
setRefersToFormula in interface Name
Parameters:
formulaText - the reference for this name

getRefersToFormula

public java.lang.String getRefersToFormula()
Description copied from interface: Name
Returns the formula that the name is defined to refer to.

Specified by:
getRefersToFormula in interface Name
Returns:
the reference for this name, null if it has not been set yet. Never empty string
See Also:
Name.setRefersToFormula(String)

isDeleted

public boolean isDeleted()
Description copied from interface: Name
Checks if this name points to a cell that no longer exists

Specified by:
isDeleted in interface Name
Returns:
true if the name refers to a deleted cell, false otherwise

isFunctionName

public boolean isFunctionName()
Checks if this name is a function name

Specified by:
isFunctionName in interface Name
Returns:
true if this name is a function name

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

setSheetIndex

public void setSheetIndex(int index)
Specifies if the defined name is a local name, and if so, which sheet it is on.

Specified by:
setSheetIndex in interface Name
Parameters:
index - if greater than 0, the defined name is a local name and the value MUST be a 0-based index to the collection of sheets as they appear in the workbook.
Throws:
java.lang.IllegalArgumentException - if the sheet index is invalid.

getSheetIndex

public int getSheetIndex()
Returns the sheet index this name applies to.

Specified by:
getSheetIndex in interface Name
Returns:
the sheet index this name applies to, -1 if this name applies to the entire workbook

getComment

public java.lang.String getComment()
Returns the comment the user provided when the name was created.

Specified by:
getComment in interface Name
Returns:
the user comment for this named range

setComment

public void setComment(java.lang.String comment)
Sets the comment the user provided when the name was created.

Specified by:
setComment in interface Name
Parameters:
comment - the user comment for this named range

setFunction

public void setFunction(boolean value)
Indicates that the defined name refers to a user-defined function. This attribute is used when there is an add-in or other code project associated with the file.

Specified by:
setFunction in interface Name
Parameters:
value - true indicates the name refers to a function.
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFObjectData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFObjectData

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFObjectData

public final class HSSFObjectData
extends java.lang.Object

Represents binary object (i.e. OLE) data stored in the file. Eg. A GIF, JPEG etc...

Author:
Daniel Noll

Constructor Summary
HSSFObjectData(ObjRecord record, DirectoryEntry root)
Constructs object data by wrapping a lower level object record.
Method Summary
protected EmbeddedObjectRefSubRecord | findObjectRecord() Finds the EmbeddedObjectRefSubRecord, or throws an Exception if there wasn't one
DirectoryEntry | getDirectory() Gets the object data.
byte[] | getObjectData() Returns the data portion, for an ObjectData that doesn't have an associated POIFS Directory Entry
java.lang.String | getOLE2ClassName() Returns the OLE2 Class Name of the object
boolean | hasDirectoryEntry() Does this ObjectData have an associated POIFS Directory Entry? (Not all do, those that don't have a data portion)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFObjectData

public HSSFObjectData(ObjRecord record,
                      DirectoryEntry root)
Constructs object data by wrapping a lower level object record.

Parameters:
record - the low-level object record.
root - the root of the filesystem, required for retrieving the object data.
Method Detail

getOLE2ClassName

public java.lang.String getOLE2ClassName()
Returns the OLE2 Class Name of the object

getDirectory

public DirectoryEntry getDirectory()
                            throws java.io.IOException
Gets the object data. Only call for ones that have data though. See hasDirectoryEntry()

Returns:
the object data as an OLE2 directory.
Throws:
java.io.IOException - if there was an error reading the data.

getObjectData

public byte[] getObjectData()
Returns the data portion, for an ObjectData that doesn't have an associated POIFS Directory Entry

hasDirectoryEntry

public boolean hasDirectoryEntry()
Does this ObjectData have an associated POIFS Directory Entry? (Not all do, those that don't have a data portion)

findObjectRecord

protected EmbeddedObjectRefSubRecord findObjectRecord()
Finds the EmbeddedObjectRefSubRecord, or throws an Exception if there wasn't one

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFOptimiser

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFOptimiser

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFOptimiser

public class HSSFOptimiser
extends java.lang.Object

Excel can get cranky if you give it files containing too many (especially duplicate) objects, and this class can help to avoid those. In general, it's much better to make sure you don't duplicate the objects in your code, as this is likely to be much faster than creating lots and lots of excel objects+records, only to optimise them down to many fewer at a later stage. However, sometimes this is too hard / tricky to do, which is where the use of this class comes in.

Constructor Summary
HSSFOptimiser()
Method Summary
static void | optimiseCellStyles(HSSFWorkbook workbook) Goes through the Wokrbook, optimising the cell styles by removing duplicate ones.
static void | optimiseFonts(HSSFWorkbook workbook) Goes through the Workbook, optimising the fonts by removing duplicate ones.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFOptimiser

public HSSFOptimiser()
Method Detail

optimiseFonts

public static void optimiseFonts(HSSFWorkbook workbook)
Goes through the Workbook, optimising the fonts by removing duplicate ones. For now, only works on fonts used in HSSFCellStyle and HSSFRichTextString. Any other font uses (eg charts, pictures) may well end up broken! This can be a slow operation, especially if you have lots of cells, cell styles or rich text strings

Parameters:
workbook - The workbook in which to optimise the fonts

optimiseCellStyles

public static void optimiseCellStyles(HSSFWorkbook workbook)
Goes through the Wokrbook, optimising the cell styles by removing duplicate ones. For best results, optimise the fonts via a call to optimiseFonts(HSSFWorkbook) first.

Parameters:
workbook - The workbook in which to optimise the cell styles
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFPalette

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFPalette

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFPalette

public final class HSSFPalette
extends java.lang.Object

Represents a workbook color palette. Internally, the XLS format refers to colors using an offset into the palette record. Thus, the first color in the palette has the index 0x8, the second has the index 0x9, etc. through 0x40

Author:
Brian Sanders (bsanders at risklabs dot com)

Constructor Summary
protected HSSFPalette(PaletteRecord palette)
Method Summary
HSSFColor | addColor(byte red, byte green, byte blue) Adds a new color into an empty color slot.
HSSFColor | findColor(byte red, byte green, byte blue) Finds the first occurance of a given color
HSSFColor | findSimilarColor(byte red, byte green, byte blue) Finds the closest matching color in the custom palette.
HSSFColor | findSimilarColor(int red, int green, int blue) Finds the closest matching color in the custom palette.
HSSFColor | getColor(int index) Retrieves the color at a given index
HSSFColor | getColor(short index) Retrieves the color at a given index
void | setColorAtIndex(short index, byte red, byte green, byte blue) Sets the color at the given offset
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFPalette

protected HSSFPalette(PaletteRecord palette)
Method Detail

getColor

public HSSFColor getColor(short index)
Retrieves the color at a given index

Parameters:
index - the palette index, between 0x8 to 0x40 inclusive
Returns:
the color, or null if the index is not populated

getColor

public HSSFColor getColor(int index)
Retrieves the color at a given index

Parameters:
index - the palette index, between 0x8 to 0x40 inclusive
Returns:
the color, or null if the index is not populated

findColor

public HSSFColor findColor(byte red,
                           byte green,
                           byte blue)
Finds the first occurance of a given color

Parameters:
red - the RGB red component, between 0 and 255 inclusive
green - the RGB green component, between 0 and 255 inclusive
blue - the RGB blue component, between 0 and 255 inclusive
Returns:
the color, or null if the color does not exist in this palette

findSimilarColor

public HSSFColor findSimilarColor(byte red,
                                  byte green,
                                  byte blue)
Finds the closest matching color in the custom palette. The method for finding the distance between the colors is fairly primative.

Parameters:
red - The red component of the color to match.
green - The green component of the color to match.
blue - The blue component of the color to match.
Returns:
The closest color or null if there are no custom colors currently defined.

findSimilarColor

public HSSFColor findSimilarColor(int red,
                                  int green,
                                  int blue)
Finds the closest matching color in the custom palette. The method for finding the distance between the colors is fairly primative.

Parameters:
red - The red component of the color to match.
green - The green component of the color to match.
blue - The blue component of the color to match.
Returns:
The closest color or null if there are no custom colors currently defined.

setColorAtIndex

public void setColorAtIndex(short index,
                            byte red,
                            byte green,
                            byte blue)
Sets the color at the given offset

Parameters:
index - the palette index, between 0x8 to 0x40 inclusive
red - the RGB red component, between 0 and 255 inclusive
green - the RGB green component, between 0 and 255 inclusive
blue - the RGB blue component, between 0 and 255 inclusive

addColor

public HSSFColor addColor(byte red,
                          byte green,
                          byte blue)
Adds a new color into an empty color slot.

Parameters:
red - The red component
green - The green component
blue - The blue component
Returns:
The new custom color.
Throws:
java.lang.RuntimeException - if there are more more free color indexes.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFPatriarch

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFPatriarch

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFPatriarch
All Implemented Interfaces:
HSSFShapeContainer, Drawing
public final class HSSFPatriarch
extends java.lang.Object
implements HSSFShapeContainer, Drawing

The patriarch is the toplevel container for shapes in a sheet. It does little other than act as a container for other shapes and groups.

Author:
Glen Stampoultzis (glens at apache.org)

Method Summary
protected EscherAggregate | _getBoundAggregate() Returns the aggregate escher record we're bound to
void | addShape(HSSFShape shape) add a shape to this drawing
boolean | containsChart() Does this HSSFPatriarch contain a chart? (Technically a reference to a chart, since they get stored in a different block of records) FIXME - detect chart in all cases (only seems to work on some charts so far)
int | countOfAllChildren() Total count of all children and their children's children.
HSSFClientAnchor | createAnchor(int dx1, int dy1, int dx2, int dy2, int col1, int row1, int col2, int row2) Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
HSSFComment | createCellComment(ClientAnchor anchor) Creates a comment.
Chart | createChart(ClientAnchor anchor) Creates a chart.
HSSFComment | createComment(HSSFAnchor anchor) Constructs a cell comment.
HSSFShapeGroup | createGroup(HSSFClientAnchor anchor) Creates a new group record stored under this patriarch.
HSSFPicture | createPicture(ClientAnchor anchor, int pictureIndex) Creates a picture.
HSSFPicture | createPicture(HSSFClientAnchor anchor, int pictureIndex) Creates a picture.
HSSFPolygon | createPolygon(HSSFClientAnchor anchor) Creates a polygon
HSSFSimpleShape | createSimpleShape(HSSFClientAnchor anchor) Creates a simple shape.
HSSFTextbox | createTextbox(HSSFClientAnchor anchor) Constructs a textbox under the patriarch.
java.util.List<HSSFShape> | getChildren() Returns a list of all shapes contained by the patriarch.
int | getX1() The top left x coordinate of this group.
int | getX2() The bottom right x coordinate of this group.
int | getY1() The top left y coordinate of this group.
int | getY2() The bottom right y coordinate of this group.
void | setCoordinates(int x1, int y1, int x2, int y2) Sets the coordinate space of this group.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createGroup

public HSSFShapeGroup createGroup(HSSFClientAnchor anchor)
Creates a new group record stored under this patriarch.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created group.

createSimpleShape

public HSSFSimpleShape createSimpleShape(HSSFClientAnchor anchor)
Creates a simple shape. This includes such shapes as lines, rectangles, and ovals.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

createPicture

public HSSFPicture createPicture(HSSFClientAnchor anchor,
                                 int pictureIndex)
Creates a picture.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

createPicture

public HSSFPicture createPicture(ClientAnchor anchor,
                                 int pictureIndex)
Description copied from interface: Drawing
Creates a picture.

Specified by:
createPicture in interface Drawing
Parameters:
anchor - the client anchor describes how this picture is attached to the sheet.
pictureIndex - the index of the picture in the workbook collection of pictures.
Returns:
the newly created picture.

createPolygon

public HSSFPolygon createPolygon(HSSFClientAnchor anchor)
Creates a polygon

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

createTextbox

public HSSFTextbox createTextbox(HSSFClientAnchor anchor)
Constructs a textbox under the patriarch.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created textbox.

createComment

public HSSFComment createComment(HSSFAnchor anchor)
Constructs a cell comment.

Parameters:
anchor - the client anchor describes how this comment is attached to the sheet.
Returns:
the newly created comment.

createCellComment

public HSSFComment createCellComment(ClientAnchor anchor)
Description copied from interface: Drawing
Creates a comment.

Specified by:
createCellComment in interface Drawing
Parameters:
anchor - the client anchor describes how this comment is attached to the sheet.
Returns:
the newly created comment.

getChildren

public java.util.List<HSSFShape> getChildren()
Returns a list of all shapes contained by the patriarch.

Specified by:
getChildren in interface HSSFShapeContainer
Returns:
Any children contained by this shape.

addShape

@Internal
public void addShape(HSSFShape shape)
add a shape to this drawing

countOfAllChildren

public int countOfAllChildren()
Total count of all children and their children's children.

setCoordinates

public void setCoordinates(int x1,
                           int y1,
                           int x2,
                           int y2)
Sets the coordinate space of this group. All children are constrained to these coordinates.

containsChart

public boolean containsChart()
Does this HSSFPatriarch contain a chart? (Technically a reference to a chart, since they get stored in a different block of records) FIXME - detect chart in all cases (only seems to work on some charts so far)

getX1

public int getX1()
The top left x coordinate of this group.

getY1

public int getY1()
The top left y coordinate of this group.

getX2

public int getX2()
The bottom right x coordinate of this group.

getY2

public int getY2()
The bottom right y coordinate of this group.

_getBoundAggregate

protected EscherAggregate _getBoundAggregate()
Returns the aggregate escher record we're bound to

createAnchor

public HSSFClientAnchor createAnchor(int dx1,
                                     int dy1,
                                     int dx2,
                                     int dy2,
                                     int col1,
                                     int row1,
                                     int col2,
                                     int row2)
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.

Specified by:
createAnchor in interface Drawing
Parameters:
dx1 - the x coordinate in EMU within the first cell.
dy1 - the y coordinate in EMU within the first cell.
dx2 - the x coordinate in EMU within the second cell.
dy2 - the y coordinate in EMU within the second cell.
col1 - the column (0 based) of the first cell.
row1 - the row (0 based) of the first cell.
col2 - the column (0 based) of the second cell.
row2 - the row (0 based) of the second cell.
Returns:
the newly created client anchor

createChart

public Chart createChart(ClientAnchor anchor)
Description copied from interface: Drawing
Creates a chart.

Specified by:
createChart in interface Drawing
Parameters:
anchor - the client anchor describes how this chart is attached to the sheet.
Returns:
the newly created chart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFPatternFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFPatternFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFPatternFormatting
All Implemented Interfaces:
PatternFormatting
public class HSSFPatternFormatting
extends java.lang.Object
implements PatternFormatting

High level representation for Conditional Formatting settings

Author:
Dmitriy Kumshayev

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.PatternFormatting
ALT_BARS, BIG_SPOTS, BRICKS, DIAMONDS, FINE_DOTS, LEAST_DOTS, LESS_DOTS, NO_FILL, SOLID_FOREGROUND, SPARSE_DOTS, SQUARES, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, THICK_HORZ_BANDS, THICK_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, THIN_HORZ_BANDS, THIN_VERT_BANDS
Constructor Summary
protected HSSFPatternFormatting(CFRuleRecord cfRuleRecord)
Method Summary
short | getFillBackgroundColor()
short | getFillForegroundColor()
short | getFillPattern()
protected PatternFormatting | getPatternFormattingBlock()
void | setFillBackgroundColor(short bg)
void | setFillForegroundColor(short fg)
void | setFillPattern(short fp)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFPatternFormatting

protected HSSFPatternFormatting(CFRuleRecord cfRuleRecord)
Method Detail

getPatternFormattingBlock

protected PatternFormatting getPatternFormattingBlock()

getFillBackgroundColor

public short getFillBackgroundColor()
Specified by:
getFillBackgroundColor in interface PatternFormatting
See Also:
PatternFormatting.getFillBackgroundColor()

getFillForegroundColor

public short getFillForegroundColor()
Specified by:
getFillForegroundColor in interface PatternFormatting
See Also:
PatternFormatting.getFillForegroundColor()

getFillPattern

public short getFillPattern()
Specified by:
getFillPattern in interface PatternFormatting
See Also:
PatternFormatting.getFillPattern()

setFillBackgroundColor

public void setFillBackgroundColor(short bg)
Specified by:
setFillBackgroundColor in interface PatternFormatting
Parameters:
bg -
See Also:
PatternFormatting.setFillBackgroundColor(int)

setFillForegroundColor

public void setFillForegroundColor(short fg)
Specified by:
setFillForegroundColor in interface PatternFormatting
Parameters:
fg -
See Also:
PatternFormatting.setFillForegroundColor(int)

setFillPattern

public void setFillPattern(short fp)
Specified by:
setFillPattern in interface PatternFormatting
Parameters:
fp -
See Also:
PatternFormatting.setFillPattern(int)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFPicture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFPicture

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFShape
        extended by  org.apache.poi.hssf.usermodel.HSSFSimpleShape
            extended by  org.apache.poi.hssf.usermodel.HSSFPicture
All Implemented Interfaces:
Picture
public final class HSSFPicture
extends HSSFSimpleShape
implements Picture

Represents a escher picture. Eg. A GIF, JPEG etc...

Author:
Glen Stampoultzis, Yegor Kozlov (yegor at apache.org)

Field Summary
static int | PICTURE_TYPE_DIB
static int | PICTURE_TYPE_EMF
static int | PICTURE_TYPE_JPEG
static int | PICTURE_TYPE_PICT
static int | PICTURE_TYPE_PNG
static int | PICTURE_TYPE_WMF
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFSimpleShape
OBJECT_TYPE_COMBO_BOX, OBJECT_TYPE_COMMENT, OBJECT_TYPE_LINE, OBJECT_TYPE_OVAL, OBJECT_TYPE_PICTURE, OBJECT_TYPE_RECTANGLE
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFShape
LINESTYLE_DASHDOTDOTSYS, LINESTYLE_DASHDOTGEL, LINESTYLE_DASHDOTSYS, LINESTYLE_DASHGEL, LINESTYLE_DASHSYS, LINESTYLE_DOTGEL, LINESTYLE_DOTSYS, LINESTYLE_LONGDASHDOTDOTGEL, LINESTYLE_LONGDASHDOTGEL, LINESTYLE_LONGDASHGEL, LINESTYLE_NONE, LINESTYLE_SOLID, LINEWIDTH_DEFAULT, LINEWIDTH_ONE_PT
Constructor Summary
HSSFPicture(HSSFShape parent, HSSFAnchor anchor)
Constructs a picture object.
Method Summary
java.awt.Dimension | getImageDimension() Return the dimension of this image
HSSFPictureData | getPictureData() Return picture data for this shape
int | getPictureIndex()
HSSFClientAnchor | getPreferredSize() Calculate the preferred size for this picture.
HSSFClientAnchor | getPreferredSize(double scale) Calculate the preferred size for this picture.
void | resize() Reset the image to the original size.
void | resize(double scale) Resize the image
void | setPictureIndex(int pictureIndex)
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFSimpleShape
getShapeType, setShapeType
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFShape
countOfAllChildren, getAnchor, getFillColor, getLineStyle, getLineStyleColor, getLineWidth, getParent, isNoFill, setAnchor, setFillColor, setFillColor, setLineStyle, setLineStyleColor, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PICTURE_TYPE_EMF

public static final int PICTURE_TYPE_EMF
See Also:
Constant Field Values

PICTURE_TYPE_WMF

public static final int PICTURE_TYPE_WMF
See Also:
Constant Field Values

PICTURE_TYPE_PICT

public static final int PICTURE_TYPE_PICT
See Also:
Constant Field Values

PICTURE_TYPE_JPEG

public static final int PICTURE_TYPE_JPEG
See Also:
Constant Field Values

PICTURE_TYPE_PNG

public static final int PICTURE_TYPE_PNG
See Also:
Constant Field Values

PICTURE_TYPE_DIB

public static final int PICTURE_TYPE_DIB
See Also:
Constant Field Values
Constructor Detail

HSSFPicture

public HSSFPicture(HSSFShape parent,
                   HSSFAnchor anchor)
Constructs a picture object.

Method Detail

getPictureIndex

public int getPictureIndex()

setPictureIndex

public void setPictureIndex(int pictureIndex)

resize

public void resize(double scale)
Resize the image

Please note, that this method works correctly only for workbooks with default font size (Arial 10pt for .xls). If the default font is changed the resized image can be streched vertically or horizontally.

Specified by:
resize in interface Picture
Parameters:
scale - the amount by which image dimensions are multiplied relative to the original size. resize(1.0) sets the original size, resize(0.5) resize to 50% of the original, resize(2.0) resizes to 200% of the original.

resize

public void resize()
Reset the image to the original size.

Please note, that this method works correctly only for workbooks with default font size (Arial 10pt for .xls). If the default font is changed the resized image can be streched vertically or horizontally.

Specified by:
resize in interface Picture

getPreferredSize

public HSSFClientAnchor getPreferredSize()
Calculate the preferred size for this picture.

Specified by:
getPreferredSize in interface Picture
Returns:
HSSFClientAnchor with the preferred size for this image
Since:
POI 3.0.2

getPreferredSize

public HSSFClientAnchor getPreferredSize(double scale)
Calculate the preferred size for this picture.

Parameters:
scale - the amount by which image dimensions are multiplied relative to the original size.
Returns:
HSSFClientAnchor with the preferred size for this image
Since:
POI 3.0.2

getImageDimension

public java.awt.Dimension getImageDimension()
Return the dimension of this image

Returns:
image dimension

getPictureData

public HSSFPictureData getPictureData()
Return picture data for this shape

Specified by:
getPictureData in interface Picture
Returns:
picture data for this shape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFPictureData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFPictureData

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFPictureData
All Implemented Interfaces:
PictureData
public class HSSFPictureData
extends java.lang.Object
implements PictureData

Represents binary data stored in the file. Eg. A GIF, JPEG etc...

Author:
Daniel Noll

Field Summary
static short | FORMAT_MASK
static short | MSOBI_DIB
static short | MSOBI_EMF
static short | MSOBI_JPEG
static short | MSOBI_PICT
static short | MSOBI_PNG
static short | MSOBI_WMF
Constructor Summary
HSSFPictureData(EscherBlipRecord blip)
Constructs a picture object.
Method Summary
byte[] | getData() Gets the picture data.
int | getFormat()
java.lang.String | getMimeType() Returns the mime type for the image
java.lang.String | suggestFileExtension() Suggests a file extension for this image.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MSOBI_WMF

public static final short MSOBI_WMF
See Also:
Constant Field Values

MSOBI_EMF

public static final short MSOBI_EMF
See Also:
Constant Field Values

MSOBI_PICT

public static final short MSOBI_PICT
See Also:
Constant Field Values

MSOBI_PNG

public static final short MSOBI_PNG
See Also:
Constant Field Values

MSOBI_JPEG

public static final short MSOBI_JPEG
See Also:
Constant Field Values

MSOBI_DIB

public static final short MSOBI_DIB
See Also:
Constant Field Values

FORMAT_MASK

public static final short FORMAT_MASK
See Also:
Constant Field Values
Constructor Detail

HSSFPictureData

public HSSFPictureData(EscherBlipRecord blip)
Constructs a picture object.

Parameters:
blip - the underlying blip record containing the bitmap data.
Method Detail

getData

public byte[] getData()
Description copied from interface: PictureData
Gets the picture data.

Specified by:
getData in interface PictureData
Returns:
the picture data.

getFormat

public int getFormat()
Returns:
format of the picture.
See Also:
Workbook.PICTURE_TYPE_DIB, Workbook.PICTURE_TYPE_WMF, Workbook.PICTURE_TYPE_EMF, Workbook.PICTURE_TYPE_PNG, Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PICT

suggestFileExtension

public java.lang.String suggestFileExtension()
Description copied from interface: PictureData
Suggests a file extension for this image.

Specified by:
suggestFileExtension in interface PictureData
Returns:
'wmf', 'jpeg' etc depending on the format. never null
See Also:
getFormat()

getMimeType

public java.lang.String getMimeType()
Returns the mime type for the image

Specified by:
getMimeType in interface PictureData
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFPolygon

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFPolygon

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFShape
        extended by  org.apache.poi.hssf.usermodel.HSSFPolygon

public class HSSFPolygon
extends HSSFShape

Author:
Glen Stampoultzis (glens at superlinksoftware.com)

Field Summary
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFShape
LINESTYLE_DASHDOTDOTSYS, LINESTYLE_DASHDOTGEL, LINESTYLE_DASHDOTSYS, LINESTYLE_DASHGEL, LINESTYLE_DASHSYS, LINESTYLE_DOTGEL, LINESTYLE_DOTSYS, LINESTYLE_LONGDASHDOTDOTGEL, LINESTYLE_LONGDASHDOTGEL, LINESTYLE_LONGDASHGEL, LINESTYLE_NONE, LINESTYLE_SOLID, LINEWIDTH_DEFAULT, LINEWIDTH_ONE_PT
Method Summary
int | getDrawAreaHeight()
int | getDrawAreaWidth()
int[] | getXPoints()
int[] | getYPoints()
void | setPoints(int[] xPoints, int[] yPoints)
void | setPolygonDrawArea(int width, int height) Defines the width and height of the points in the polygon
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFShape
countOfAllChildren, getAnchor, getFillColor, getLineStyle, getLineStyleColor, getLineWidth, getParent, isNoFill, setAnchor, setFillColor, setFillColor, setLineStyle, setLineStyleColor, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXPoints

public int[] getXPoints()

getYPoints

public int[] getYPoints()

setPoints

public void setPoints(int[] xPoints,
                      int[] yPoints)

setPolygonDrawArea

public void setPolygonDrawArea(int width,
                               int height)
Defines the width and height of the points in the polygon

Parameters:
width -
height -

getDrawAreaWidth

public int getDrawAreaWidth()

getDrawAreaHeight

public int getDrawAreaHeight()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFPrintSetup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFPrintSetup

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFPrintSetup
All Implemented Interfaces:
PrintSetup
public class HSSFPrintSetup
extends java.lang.Object
implements PrintSetup

Used to modify the print setup.

 Paper size constants have been added for the ones I have access
 to.  They follow as:
public static final short LETTER_PAPERSIZE              = 1;
public static final short LEGAL_PAPERSIZE               = 5;
public static final short EXECUTIVE_PAPERSIZE           = 7;
public static final short A4_PAPERSIZE                  = 9;
public static final short A5_PAPERSIZE                  = 11;
public static final short ENVELOPE_10_PAPERSIZE         = 20;
public static final short ENVELOPE_DL_PAPERSIZE         = 27;
public static final short ENVELOPE_CS_PAPERSIZE         = 28;
public static final short ENVELOPE_MONARCH_PAPERSIZE  = 37;

Author:
Shawn Laubach (slaubach at apache dot org)

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.PrintSetup
A3_PAPERSIZE, A4_EXTRA_PAPERSIZE, A4_PAPERSIZE, A4_PLUS_PAPERSIZE, A4_ROTATED_PAPERSIZE, A4_SMALL_PAPERSIZE, A4_TRANSVERSE_PAPERSIZE, A5_PAPERSIZE, B4_PAPERSIZE, B5_PAPERSIZE, ELEVEN_BY_SEVENTEEN_PAPERSIZE, ENVELOPE_10_PAPERSIZE, ENVELOPE_9_PAPERSIZE, ENVELOPE_C3_PAPERSIZE, ENVELOPE_C4_PAPERSIZE, ENVELOPE_C5_PAPERSIZE, ENVELOPE_C6_PAPERSIZE, ENVELOPE_CS_PAPERSIZE, ENVELOPE_DL_PAPERSIZE, ENVELOPE_MONARCH_PAPERSIZE, EXECUTIVE_PAPERSIZE, FOLIO8_PAPERSIZE, LEDGER_PAPERSIZE, LEGAL_PAPERSIZE, LETTER_PAPERSIZE, LETTER_ROTATED_PAPERSIZE, LETTER_SMALL_PAGESIZE, NOTE8_PAPERSIZE, QUARTO_PAPERSIZE, STATEMENT_PAPERSIZE, TABLOID_PAPERSIZE, TEN_BY_FOURTEEN_PAPERSIZE
Constructor Summary
protected HSSFPrintSetup(PrintSetupRecord printSetupRecord)
Constructor.
Method Summary
short | getCopies() Returns the number of copies.
boolean | getDraft() Returns the draft mode.
short | getFitHeight() Returns the number of pages high to fit the sheet in.
short | getFitWidth() Returns the number of pages wide to fit sheet in.
double | getFooterMargin() Returns the footer margin.
double | getHeaderMargin() Returns the header margin.
short | getHResolution() Returns the horizontal resolution.
boolean | getLandscape() Returns the landscape mode.
boolean | getLeftToRight() Returns the left to right print order.
boolean | getNoColor() Returns the black and white setting.
boolean | getNoOrientation() Returns the no orientation.
boolean | getNotes() Returns the print notes.
short | getOptions() Returns the bit flags for the options.
short | getPageStart() Returns the page start.
short | getPaperSize() Returns the paper size.
short | getScale() Returns the scale.
boolean | getUsePage() Returns the use page numbers.
boolean | getValidSettings() Returns the valid settings.
short | getVResolution() Returns the vertical resolution.
void | setCopies(short copies) Sets the number of copies.
void | setDraft(boolean d) Set whether it is in draft mode
void | setFitHeight(short height) Set the number of pages high to fit the sheet in
void | setFitWidth(short width) Set the number of pages wide to fit the sheet in
void | setFooterMargin(double footermargin) Sets the footer margin.
void | setHeaderMargin(double headermargin) Sets the header margin.
void | setHResolution(short resolution) Sets the horizontal resolution.
void | setLandscape(boolean ls) Set whether to print in landscape
void | setLeftToRight(boolean ltor) Set whether to go left to right or top down in ordering
void | setNoColor(boolean mono) Set whether it is black and white
void | setNoOrientation(boolean orientation) Set no orientation.
void | setNotes(boolean printnotes) Print the include notes
void | setOptions(short options) Sets the options flags.
void | setPageStart(short start) Set the page numbering start.
void | setPaperSize(short size) Set the paper size.
void | setScale(short scale) Set the scale.
void | setUsePage(boolean page) Set whether to use page start
void | setValidSettings(boolean valid) Valid settings.
void | setVResolution(short resolution) Sets the vertical resolution.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFPrintSetup

protected HSSFPrintSetup(PrintSetupRecord printSetupRecord)
Constructor. Takes the low level print setup record.

Parameters:
printSetupRecord - the low level print setup record
Method Detail

setPaperSize

public void setPaperSize(short size)
Set the paper size.

Specified by:
setPaperSize in interface PrintSetup
Parameters:
size - the paper size.

setScale

public void setScale(short scale)
Set the scale.

Specified by:
setScale in interface PrintSetup
Parameters:
scale - the scale to use

setPageStart

public void setPageStart(short start)
Set the page numbering start.

Specified by:
setPageStart in interface PrintSetup
Parameters:
start - the page numbering start

setFitWidth

public void setFitWidth(short width)
Set the number of pages wide to fit the sheet in

Specified by:
setFitWidth in interface PrintSetup
Parameters:
width - the number of pages

setFitHeight

public void setFitHeight(short height)
Set the number of pages high to fit the sheet in

Specified by:
setFitHeight in interface PrintSetup
Parameters:
height - the number of pages

setOptions

public void setOptions(short options)
Sets the options flags. Not advisable to do it directly.

Parameters:
options - The bit flags for the options

setLeftToRight

public void setLeftToRight(boolean ltor)
Set whether to go left to right or top down in ordering

Specified by:
setLeftToRight in interface PrintSetup
Parameters:
ltor - left to right

setLandscape

public void setLandscape(boolean ls)
Set whether to print in landscape

Specified by:
setLandscape in interface PrintSetup
Parameters:
ls - landscape

setValidSettings

public void setValidSettings(boolean valid)
Valid settings. I'm not for sure.

Specified by:
setValidSettings in interface PrintSetup
Parameters:
valid - Valid

setNoColor

public void setNoColor(boolean mono)
Set whether it is black and white

Specified by:
setNoColor in interface PrintSetup
Parameters:
mono - Black and white

setDraft

public void setDraft(boolean d)
Set whether it is in draft mode

Specified by:
setDraft in interface PrintSetup
Parameters:
d - draft

setNotes

public void setNotes(boolean printnotes)
Print the include notes

Specified by:
setNotes in interface PrintSetup
Parameters:
printnotes - print the notes

setNoOrientation

public void setNoOrientation(boolean orientation)
Set no orientation. ?

Specified by:
setNoOrientation in interface PrintSetup
Parameters:
orientation - Orientation.

setUsePage

public void setUsePage(boolean page)
Set whether to use page start

Specified by:
setUsePage in interface PrintSetup
Parameters:
page - Use page start

setHResolution

public void setHResolution(short resolution)
Sets the horizontal resolution.

Specified by:
setHResolution in interface PrintSetup
Parameters:
resolution - horizontal resolution

setVResolution

public void setVResolution(short resolution)
Sets the vertical resolution.

Specified by:
setVResolution in interface PrintSetup
Parameters:
resolution - vertical resolution

setHeaderMargin

public void setHeaderMargin(double headermargin)
Sets the header margin.

Specified by:
setHeaderMargin in interface PrintSetup
Parameters:
headermargin - header margin

setFooterMargin

public void setFooterMargin(double footermargin)
Sets the footer margin.

Specified by:
setFooterMargin in interface PrintSetup
Parameters:
footermargin - footer margin

setCopies

public void setCopies(short copies)
Sets the number of copies.

Specified by:
setCopies in interface PrintSetup
Parameters:
copies - number of copies

getPaperSize

public short getPaperSize()
Returns the paper size.

Specified by:
getPaperSize in interface PrintSetup
Returns:
paper size

getScale

public short getScale()
Returns the scale.

Specified by:
getScale in interface PrintSetup
Returns:
scale

getPageStart

public short getPageStart()
Returns the page start.

Specified by:
getPageStart in interface PrintSetup
Returns:
page start

getFitWidth

public short getFitWidth()
Returns the number of pages wide to fit sheet in.

Specified by:
getFitWidth in interface PrintSetup
Returns:
number of pages wide to fit sheet in

getFitHeight

public short getFitHeight()
Returns the number of pages high to fit the sheet in.

Specified by:
getFitHeight in interface PrintSetup
Returns:
number of pages high to fit the sheet in

getOptions

public short getOptions()
Returns the bit flags for the options.

Returns:
bit flags for the options

getLeftToRight

public boolean getLeftToRight()
Returns the left to right print order.

Specified by:
getLeftToRight in interface PrintSetup
Returns:
left to right print order

getLandscape

public boolean getLandscape()
Returns the landscape mode.

Specified by:
getLandscape in interface PrintSetup
Returns:
landscape mode

getValidSettings

public boolean getValidSettings()
Returns the valid settings.

Specified by:
getValidSettings in interface PrintSetup
Returns:
valid settings

getNoColor

public boolean getNoColor()
Returns the black and white setting.

Specified by:
getNoColor in interface PrintSetup
Returns:
black and white setting

getDraft

public boolean getDraft()
Returns the draft mode.

Specified by:
getDraft in interface PrintSetup
Returns:
draft mode

getNotes

public boolean getNotes()
Returns the print notes.

Specified by:
getNotes in interface PrintSetup
Returns:
print notes

getNoOrientation

public boolean getNoOrientation()
Returns the no orientation.

Specified by:
getNoOrientation in interface PrintSetup
Returns:
no orientation

getUsePage

public boolean getUsePage()
Returns the use page numbers.

Specified by:
getUsePage in interface PrintSetup
Returns:
use page numbers

getHResolution

public short getHResolution()
Returns the horizontal resolution.

Specified by:
getHResolution in interface PrintSetup
Returns:
horizontal resolution

getVResolution

public short getVResolution()
Returns the vertical resolution.

Specified by:
getVResolution in interface PrintSetup
Returns:
vertical resolution

getHeaderMargin

public double getHeaderMargin()
Returns the header margin.

Specified by:
getHeaderMargin in interface PrintSetup
Returns:
header margin

getFooterMargin

public double getFooterMargin()
Returns the footer margin.

Specified by:
getFooterMargin in interface PrintSetup
Returns:
footer margin

getCopies

public short getCopies()
Returns the number of copies.

Specified by:
getCopies in interface PrintSetup
Returns:
number of copies
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFRichTextString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFRichTextString

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFRichTextString
All Implemented Interfaces:
java.lang.Comparable<HSSFRichTextString>, RichTextString
public final class HSSFRichTextString
extends java.lang.Object
implements java.lang.Comparable<HSSFRichTextString>, RichTextString

Rich text unicode string. These strings can have fonts applied to arbitary parts of the string.

Note, that in certain cases creating too many HSSFRichTextString cells may cause Excel 2003 and lower to crash when changing the color of the cells and then saving the Excel file. Compare two snippets that produce equivalent output:

  HSSFCell hssfCell = row.createCell(idx);
  //rich text consists of two runs
  HSSFRichTextString richString = new HSSFRichTextString( "Hello, World!" );
  richString.applyFont( 0, 6, font1 );
  richString.applyFont( 6, 13, font2 );
  hssfCell.setCellValue( richString );
and

  //create a cell style and assign the first font to it
  HSSFCellStyle style = workbook.createCellStyle();
  style.setFont(font1);

  HSSFCell hssfCell = row.createCell(idx);
  hssfCell.setCellStyle(style);

  //rich text consists of one run overriding the cell style
  HSSFRichTextString richString = new HSSFRichTextString( "Hello, World!" );
  richString.applyFont( 6, 13, font2 );
  hssfCell.setCellValue( richString );

Excel always uses the latter approach: for a reach text containing N runs Excel saves the font of the first run in the cell's style and subsequent N-1 runs override this font.

For more information regarding this behavior please consult Bugzilla 47543: https://issues.apache.org/bugzilla/show_bug.cgi?id=47543

Author:
Glen Stampoultzis (glens at apache.org), Jason Height (jheight at apache.org)

Field Summary
static short NO_FONT
Place holder for indicating that NO_FONT has been applied here
Constructor Summary
HSSFRichTextString()
HSSFRichTextString(java.lang.String string)
Method Summary
void | applyFont(Font font) Sets the font of the entire string.
void | applyFont(int startIndex, int endIndex, Font font) Applies a font to the specified characters of a string.
void | applyFont(int startIndex, int endIndex, short fontIndex) Applies a font to the specified characters of a string.
void | applyFont(short fontIndex) Applies the specified font to the entire string.
void | clearFormatting() Removes any formatting that may have been applied to the string.
int | compareTo(HSSFRichTextString r) Compares one rich text string to another.
boolean | equals(java.lang.Object o)
short | getFontAtIndex(int index) Returns the font in use at a particular index.
short | getFontOfFormattingRun(int index) Gets the font used in a particular formatting run.
int | getIndexOfFormattingRun(int index) The index within the string to which the specified formatting run applies.
java.lang.String | getString() Returns the plain string representation.
int | length()
int | numFormattingRuns()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NO_FONT

public static final short NO_FONT
Place holder for indicating that NO_FONT has been applied here

See Also:
Constant Field Values
Constructor Detail

HSSFRichTextString

public HSSFRichTextString()

HSSFRichTextString

public HSSFRichTextString(java.lang.String string)
Method Detail

applyFont

public void applyFont(int startIndex,
                      int endIndex,
                      short fontIndex)
Applies a font to the specified characters of a string.

Specified by:
applyFont in interface RichTextString
Parameters:
startIndex - The start index to apply the font to (inclusive)
endIndex - The end index to apply the font to (exclusive)
fontIndex - The font to use.

applyFont

public void applyFont(int startIndex,
                      int endIndex,
                      Font font)
Applies a font to the specified characters of a string.

Specified by:
applyFont in interface RichTextString
Parameters:
startIndex - The start index to apply the font to (inclusive)
endIndex - The end index to apply to font to (exclusive)
font - The index of the font to use.

applyFont

public void applyFont(Font font)
Sets the font of the entire string.

Specified by:
applyFont in interface RichTextString
Parameters:
font - The font to use.

clearFormatting

public void clearFormatting()
Removes any formatting that may have been applied to the string.

Specified by:
clearFormatting in interface RichTextString

getString

public java.lang.String getString()
Returns the plain string representation.

Specified by:
getString in interface RichTextString

length

public int length()
Specified by:
length in interface RichTextString
Returns:
the number of characters in the text.

getFontAtIndex

public short getFontAtIndex(int index)
Returns the font in use at a particular index.

Parameters:
index - The index.
Returns:
The font that's currently being applied at that index or null if no font is being applied or the index is out of range.

numFormattingRuns

public int numFormattingRuns()
Specified by:
numFormattingRuns in interface RichTextString
Returns:
The number of formatting runs used. There will always be at least one of font NO_FONT.
See Also:
NO_FONT

getIndexOfFormattingRun

public int getIndexOfFormattingRun(int index)
The index within the string to which the specified formatting run applies.

Specified by:
getIndexOfFormattingRun in interface RichTextString
Parameters:
index - the index of the formatting run
Returns:
the index within the string.

getFontOfFormattingRun

public short getFontOfFormattingRun(int index)
Gets the font used in a particular formatting run.

Parameters:
index - the index of the formatting run
Returns:
the font number used.

compareTo

public int compareTo(HSSFRichTextString r)
Compares one rich text string to another.

Specified by:
compareTo in interface java.lang.Comparable<HSSFRichTextString>

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Returns:
the plain text representation of this string.

applyFont

public void applyFont(short fontIndex)
Applies the specified font to the entire string.

Specified by:
applyFont in interface RichTextString
Parameters:
fontIndex - the font to apply.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFRow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFRow

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFRow
All Implemented Interfaces:
java.lang.Iterable<Cell>, Row
public final class HSSFRow
extends java.lang.Object
implements Row

High level representation of a row of a spreadsheet. Only rows that have cells should be added to a Sheet.

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org)

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.usermodel.Row
Row.MissingCellPolicy
Field Summary
static int INITIAL_CAPACITY
Fields inherited from interface org.apache.poi.ss.usermodel.Row
CREATE_NULL_AS_BLANK, RETURN_BLANK_AS_NULL, RETURN_NULL_AND_BLANK
Method Summary
 java.util.Iterator<Cell> cellIterator()
 int compareTo(java.lang.Object obj)
 HSSFCell createCell(int column)
Use this to create new cells within the row and return it.
 HSSFCell createCell(int columnIndex, int type)
Use this to create new cells within the row and return it.
 HSSFCell createCell(short columnIndex)
Deprecated. (Aug 2008) use createCell(int)
 HSSFCell createCell(short columnIndex, int type)
Deprecated. (Aug 2008) use createCell(int, int)
 boolean equals(java.lang.Object obj)
 HSSFCell getCell(int cellnum)
Get the hssfcell representing a given column (logical cell) 0-based.
 HSSFCell getCell(int cellnum, Row.MissingCellPolicy policy)
Get the hssfcell representing a given column (logical cell) 0-based.
 HSSFCell getCell(short cellnum)
Deprecated. (Aug 2008) use getCell(int)
 short getFirstCellNum()
get the number of the first cell contained in this row.
 short getHeight()
get the row's height or ff (-1) for undefined/default-height in twips (1/20th of a point)
 float getHeightInPoints()
get the row's height or ff (-1) for undefined/default-height in points (20*getHeight())
 short getLastCellNum()
Gets the index of the last cell contained in this row PLUS ONE.
protected  int getOutlineLevel()
Returns the rows outline level.
 int getPhysicalNumberOfCells()
gets the number of defined cells (NOT number of cells in the actual row!).
 int getRowNum()
get row number this row represents
protected  RowRecord getRowRecord()
get the lowlevel RowRecord represented by this object - should only be called by other parts of the high level API
 HSSFCellStyle getRowStyle()
Returns the whole-row cell styles.
 HSSFSheet getSheet()
Returns the HSSFSheet this row belongs to
 boolean getZeroHeight()
get whether or not to display this row with 0 height
 boolean isFormatted()
Is this row formatted? Most aren't, but some rows do have whole-row styles.
 java.util.Iterator iterator()
Alias for cellIterator() to allow foreach loops
 void moveCell(HSSFCell cell, short newColumn)
Moves the supplied cell to a new column, which must not already have a cell there!
protected  void removeAllCells()
Removes all the cells from the row, and their records too.
 void removeCell(Cell cell)
remove the HSSFCell from this row.
 void setHeight(short height)
set the row's height or set to ff (-1) for undefined/default-height.
 void setHeightInPoints(float height)
set the row's height in points.
 void setRowNum(int rowIndex)
set the row number of this row.
 void setRowStyle(CellStyle style)
Applies a whole-row cell styling to the row.
 void setRowStyle(HSSFCellStyle style)
Applies a whole-row cell styling to the row.
 void setZeroHeight(boolean zHeight)
set whether or not to display this row with 0 height
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INITIAL_CAPACITY

public static final int INITIAL_CAPACITY
See Also:
Constant Field Values
Method Detail

createCell

public HSSFCell createCell(short columnIndex)
Deprecated. (Aug 2008) use createCell(int)

createCell

public HSSFCell createCell(short columnIndex,
                           int type)
Deprecated. (Aug 2008) use createCell(int, int)

createCell

public HSSFCell createCell(int column)
Use this to create new cells within the row and return it.

The cell that is returned is a CELL_TYPE_BLANK. The type can be changed either through calling setCellValue or setCellType.

Specified by:
createCell in interface Row
Parameters:
column - - the column number this cell represents
Returns:
HSSFCell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if columnIndex < 0 or greater than 255, the maximum number of columns supported by the Excel binary format (.xls)

createCell

public HSSFCell createCell(int columnIndex,
                           int type)
Use this to create new cells within the row and return it.

The cell that is returned is a CELL_TYPE_BLANK. The type can be changed either through calling setCellValue or setCellType.

Specified by:
createCell in interface Row
Parameters:
columnIndex - - the column number this cell represents
Returns:
HSSFCell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if columnIndex < 0 or greater than 255, the maximum number of columns supported by the Excel binary format (.xls)

removeCell

public void removeCell(Cell cell)
remove the HSSFCell from this row.

Specified by:
removeCell in interface Row
Parameters:
cell - to remove

removeAllCells

protected void removeAllCells()
Removes all the cells from the row, and their records too.

setRowNum

public void setRowNum(int rowIndex)
set the row number of this row.

Specified by:
setRowNum in interface Row
Parameters:
rowIndex - the row number (0-based)
Throws:
java.lang.IndexOutOfBoundsException - if the row number is not within the range 0-65535.

getRowNum

public int getRowNum()
get row number this row represents

Specified by:
getRowNum in interface Row
Returns:
the row number (0 based)

getSheet

public HSSFSheet getSheet()
Returns the HSSFSheet this row belongs to

Specified by:
getSheet in interface Row
Returns:
the HSSFSheet that owns this row

getOutlineLevel

protected int getOutlineLevel()
Returns the rows outline level. Increased as you put it into more groups (outlines), reduced as you take it out of them. TODO - Should this really be public?

moveCell

public void moveCell(HSSFCell cell,
                     short newColumn)
Moves the supplied cell to a new column, which must not already have a cell there!

Parameters:
cell - The cell to move
newColumn - The new column number (0 based)

getCell

public HSSFCell getCell(short cellnum)
Deprecated. (Aug 2008) use getCell(int)

getCell

public HSSFCell getCell(int cellnum)
Get the hssfcell representing a given column (logical cell) 0-based. If you ask for a cell that is not defined then you get a null, unless you have set a different Row.MissingCellPolicy on the base workbook.

Specified by:
getCell in interface Row
Parameters:
cellnum - 0 based column number
Returns:
HSSFCell representing that column or null if undefined.
See Also:
Row.getCell(int, org.apache.poi.ss.usermodel.Row.MissingCellPolicy)

getCell

public HSSFCell getCell(int cellnum,
                        Row.MissingCellPolicy policy)
Get the hssfcell representing a given column (logical cell) 0-based. If you ask for a cell that is not defined, then your supplied policy says what to do

Specified by:
getCell in interface Row
Parameters:
cellnum - 0 based column number
policy - Policy on blank / missing cells
Returns:
representing that column or null if undefined + policy allows.
See Also:
Row.RETURN_NULL_AND_BLANK, Row.RETURN_BLANK_AS_NULL, Row.CREATE_NULL_AS_BLANK

getFirstCellNum

public short getFirstCellNum()
get the number of the first cell contained in this row.

Specified by:
getFirstCellNum in interface Row
Returns:
short representing the first logical cell in the row, or -1 if the row does not contain any cells.

getLastCellNum

public short getLastCellNum()
Gets the index of the last cell contained in this row PLUS ONE. The result also happens to be the 1-based column number of the last cell. This value can be used as a standard upper bound when iterating over cells:
 short minColIx = row.getFirstCellNum();
 short maxColIx = row.getLastCellNum();
 for(short colIx=minColIx; colIx<maxColIx; colIx++) {
   HSSFCell cell = row.getCell(colIx);
   if(cell == null) {
     continue;
   }
   //... do something with cell
 }

Specified by:
getLastCellNum in interface Row
Returns:
short representing the last logical cell in the row PLUS ONE, or -1 if the row does not contain any cells.

getPhysicalNumberOfCells

public int getPhysicalNumberOfCells()
gets the number of defined cells (NOT number of cells in the actual row!). That is to say if only columns 0,4,5 have values then there would be 3.

Specified by:
getPhysicalNumberOfCells in interface Row
Returns:
int representing the number of defined cells in the row.

setHeight

public void setHeight(short height)
set the row's height or set to ff (-1) for undefined/default-height. Set the height in "twips" or 1/20th of a point.

Specified by:
setHeight in interface Row
Parameters:
height - rowheight or -1 for undefined (use sheet default)

setZeroHeight

public void setZeroHeight(boolean zHeight)
set whether or not to display this row with 0 height

Specified by:
setZeroHeight in interface Row
Parameters:
zHeight - height is zero or not.

getZeroHeight

public boolean getZeroHeight()
get whether or not to display this row with 0 height

Specified by:
getZeroHeight in interface Row
Returns:
- zHeight height is zero or not.

setHeightInPoints

public void setHeightInPoints(float height)
set the row's height in points.

Specified by:
setHeightInPoints in interface Row
Parameters:
height - row height in points, -1 means to use the default height

getHeight

public short getHeight()
get the row's height or ff (-1) for undefined/default-height in twips (1/20th of a point)

Specified by:
getHeight in interface Row
Returns:
rowheight or 0xff for undefined (use sheet default)

getHeightInPoints

public float getHeightInPoints()
get the row's height or ff (-1) for undefined/default-height in points (20*getHeight())

Specified by:
getHeightInPoints in interface Row
Returns:
rowheight or 0xff for undefined (use sheet default)
See Also:
Sheet.getDefaultRowHeightInPoints()

getRowRecord

protected RowRecord getRowRecord()
get the lowlevel RowRecord represented by this object - should only be called by other parts of the high level API

Returns:
RowRecord this row represents

isFormatted

public boolean isFormatted()
Is this row formatted? Most aren't, but some rows do have whole-row styles. For those that do, you can get the formatting from getRowStyle()

Specified by:
isFormatted in interface Row

getRowStyle

public HSSFCellStyle getRowStyle()
Returns the whole-row cell styles. Most rows won't have one of these, so will return null. Call isFormatted() to check first.

Specified by:
getRowStyle in interface Row

setRowStyle

public void setRowStyle(HSSFCellStyle style)
Applies a whole-row cell styling to the row.

setRowStyle

public void setRowStyle(CellStyle style)
Applies a whole-row cell styling to the row.

Specified by:
setRowStyle in interface Row

cellIterator

public java.util.Iterator<Cell> cellIterator()
Specified by:
cellIterator in interface Row
Returns:
cell iterator of the physically defined cells. Note that the 4th element might well not be cell 4, as the iterator will not return un-defined (null) cells. Call getCellNum() on the returned cells to know which cell they are. As this only ever works on physically defined cells, the Row.MissingCellPolicy has no effect.

iterator

public java.util.Iterator iterator()
Alias for cellIterator() to allow foreach loops

Specified by:
iterator in interface java.lang.Iterable<Cell>

compareTo

public int compareTo(java.lang.Object obj)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFShape

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFShape
Direct Known Subclasses:
HSSFPolygon, HSSFShapeGroup, HSSFSimpleShape
public abstract class HSSFShape
extends java.lang.Object

An abstract shape.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static int | LINESTYLE_DASHDOTDOTSYS
static int | LINESTYLE_DASHDOTGEL
static int | LINESTYLE_DASHDOTSYS
static int | LINESTYLE_DASHGEL
static int | LINESTYLE_DASHSYS
static int | LINESTYLE_DOTGEL
static int | LINESTYLE_DOTSYS
static int | LINESTYLE_LONGDASHDOTDOTGEL
static int | LINESTYLE_LONGDASHDOTGEL
static int | LINESTYLE_LONGDASHGEL
static int | LINESTYLE_NONE
static int | LINESTYLE_SOLID
static int | LINEWIDTH_DEFAULT
static int | LINEWIDTH_ONE_PT
Method Summary
int | countOfAllChildren() Count of all children and their children's children.
HSSFAnchor | getAnchor()
int | getFillColor() The color used to fill this shape.
int | getLineStyle()
int | getLineStyleColor() The color applied to the lines of this shape.
int | getLineWidth()
HSSFShape | getParent() Gets the parent shape.
boolean | isNoFill()
void | setAnchor(HSSFAnchor anchor) Sets a particular anchor.
void | setFillColor(int fillColor) The color used to fill this shape.
void | setFillColor(int red, int green, int blue) The color used to fill this shape.
void | setLineStyle(int lineStyle) Sets the line style.
void | setLineStyleColor(int lineStyleColor) The color applied to the lines of this shape.
void | setLineStyleColor(int red, int green, int blue) The color applied to the lines of this shape.
void | setLineWidth(int lineWidth) Sets the width of the line.
void | setNoFill(boolean noFill) Sets whether this shape is filled or transparent.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LINEWIDTH_ONE_PT

public static final int LINEWIDTH_ONE_PT
See Also:
Constant Field Values

LINEWIDTH_DEFAULT

public static final int LINEWIDTH_DEFAULT
See Also:
Constant Field Values

LINESTYLE_SOLID

public static final int LINESTYLE_SOLID
See Also:
Constant Field Values

LINESTYLE_DASHSYS

public static final int LINESTYLE_DASHSYS
See Also:
Constant Field Values

LINESTYLE_DOTSYS

public static final int LINESTYLE_DOTSYS
See Also:
Constant Field Values

LINESTYLE_DASHDOTSYS

public static final int LINESTYLE_DASHDOTSYS
See Also:
Constant Field Values

LINESTYLE_DASHDOTDOTSYS

public static final int LINESTYLE_DASHDOTDOTSYS
See Also:
Constant Field Values

LINESTYLE_DOTGEL

public static final int LINESTYLE_DOTGEL
See Also:
Constant Field Values

LINESTYLE_DASHGEL

public static final int LINESTYLE_DASHGEL
See Also:
Constant Field Values

LINESTYLE_LONGDASHGEL

public static final int LINESTYLE_LONGDASHGEL
See Also:
Constant Field Values

LINESTYLE_DASHDOTGEL

public static final int LINESTYLE_DASHDOTGEL
See Also:
Constant Field Values

LINESTYLE_LONGDASHDOTGEL

public static final int LINESTYLE_LONGDASHDOTGEL
See Also:
Constant Field Values

LINESTYLE_LONGDASHDOTDOTGEL

public static final int LINESTYLE_LONGDASHDOTDOTGEL
See Also:
Constant Field Values

LINESTYLE_NONE

public static final int LINESTYLE_NONE
See Also:
Constant Field Values
Method Detail

getParent

public HSSFShape getParent()
Gets the parent shape.

getAnchor

public HSSFAnchor getAnchor()
Returns:
the anchor that is used by this shape.

setAnchor

public void setAnchor(HSSFAnchor anchor)
Sets a particular anchor. A top-level shape must have an anchor of HSSFClientAnchor. A child anchor must have an anchor of HSSFChildAnchor

Parameters:
anchor - the anchor to use.
Throws:
java.lang.IllegalArgumentException - when the wrong anchor is used for this particular shape.
See Also:
HSSFChildAnchor, HSSFClientAnchor

getLineStyleColor

public int getLineStyleColor()
The color applied to the lines of this shape.

setLineStyleColor

public void setLineStyleColor(int lineStyleColor)
The color applied to the lines of this shape.

setLineStyleColor

public void setLineStyleColor(int red,
                              int green,
                              int blue)
The color applied to the lines of this shape.

getFillColor

public int getFillColor()
The color used to fill this shape.

setFillColor

public void setFillColor(int fillColor)
The color used to fill this shape.

setFillColor

public void setFillColor(int red,
                         int green,
                         int blue)
The color used to fill this shape.

getLineWidth

public int getLineWidth()
Returns:
returns with width of the line in EMUs. 12700 = 1 pt.

setLineWidth

public void setLineWidth(int lineWidth)
Sets the width of the line. 12700 = 1 pt.

Parameters:
lineWidth - width in EMU's. 12700EMU's = 1 pt
See Also:
LINEWIDTH_ONE_PT

getLineStyle

public int getLineStyle()
Returns:
One of the constants in LINESTYLE_*

setLineStyle

public void setLineStyle(int lineStyle)
Sets the line style.

Parameters:
lineStyle - One of the constants in LINESTYLE_*

isNoFill

public boolean isNoFill()
Returns:
true if this shape is not filled with a color.

setNoFill

public void setNoFill(boolean noFill)
Sets whether this shape is filled or transparent.

countOfAllChildren

public int countOfAllChildren()
Count of all children and their children's children.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFShapeContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Interface HSSFShapeContainer

All Known Implementing Classes:
HSSFPatriarch, HSSFShapeGroup
public interface HSSFShapeContainer

An interface that indicates whether a class can contain children.

Author:
Glen Stampoultzis (glens at apache.org)

Method Summary
 java.util.List getChildren()

Method Detail

getChildren

java.util.List getChildren()
Returns:
Any children contained by this shape.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFShapeGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFShapeGroup

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFShape
        extended by  org.apache.poi.hssf.usermodel.HSSFShapeGroup
All Implemented Interfaces:
HSSFShapeContainer
public class HSSFShapeGroup
extends HSSFShape
implements HSSFShapeContainer

A shape group may contain other shapes. It was no actual form on the sheet.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFShape
LINESTYLE_DASHDOTDOTSYS, LINESTYLE_DASHDOTGEL, LINESTYLE_DASHDOTSYS, LINESTYLE_DASHGEL, LINESTYLE_DASHSYS, LINESTYLE_DOTGEL, LINESTYLE_DOTSYS, LINESTYLE_LONGDASHDOTDOTGEL, LINESTYLE_LONGDASHDOTGEL, LINESTYLE_LONGDASHGEL, LINESTYLE_NONE, LINESTYLE_SOLID, LINEWIDTH_DEFAULT, LINEWIDTH_ONE_PT
Constructor Summary
HSSFShapeGroup(HSSFShape parent, HSSFAnchor anchor)
Method Summary
void | addShape(HSSFShape shape)
int | countOfAllChildren() Count of all children and their childrens children.
HSSFShapeGroup | createGroup(HSSFChildAnchor anchor) Create another group under this group.
HSSFPicture | createPicture(HSSFChildAnchor anchor, int pictureIndex) Creates a picture.
HSSFPolygon | createPolygon(HSSFChildAnchor anchor) Creates a polygon
HSSFSimpleShape | createShape(HSSFChildAnchor anchor) Create a new simple shape under this group.
HSSFTextbox | createTextbox(HSSFChildAnchor anchor) Create a new textbox under this group.
java.util.List<HSSFShape> | getChildren() Return all children contained by this shape.
int | getX1() The top left x coordinate of this group.
int | getX2() The bottom right x coordinate of this group.
int | getY1() The top left y coordinate of this group.
int | getY2() The bottom right y coordinate of this group.
void | setCoordinates(int x1, int y1, int x2, int y2) Sets the coordinate space of this group.
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFShape
getAnchor, getFillColor, getLineStyle, getLineStyleColor, getLineWidth, getParent, isNoFill, setAnchor, setFillColor, setFillColor, setLineStyle, setLineStyleColor, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFShapeGroup

public HSSFShapeGroup(HSSFShape parent,
                      HSSFAnchor anchor)
Method Detail

createGroup

public HSSFShapeGroup createGroup(HSSFChildAnchor anchor)
Create another group under this group.

Parameters:
anchor - the position of the new group.
Returns:
the group

addShape

public void addShape(HSSFShape shape)

createShape

public HSSFSimpleShape createShape(HSSFChildAnchor anchor)
Create a new simple shape under this group.

Parameters:
anchor - the position of the shape.
Returns:
the shape

createTextbox

public HSSFTextbox createTextbox(HSSFChildAnchor anchor)
Create a new textbox under this group.

Parameters:
anchor - the position of the shape.
Returns:
the textbox

createPolygon

public HSSFPolygon createPolygon(HSSFChildAnchor anchor)
Creates a polygon

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

createPicture

public HSSFPicture createPicture(HSSFChildAnchor anchor,
                                 int pictureIndex)
Creates a picture.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

getChildren

public java.util.List<HSSFShape> getChildren()
Return all children contained by this shape.

Specified by:
getChildren in interface HSSFShapeContainer
Returns:
Any children contained by this shape.

setCoordinates

public void setCoordinates(int x1,
                           int y1,
                           int x2,
                           int y2)
Sets the coordinate space of this group. All children are constrained to these coordinates.

getX1

public int getX1()
The top left x coordinate of this group.

getY1

public int getY1()
The top left y coordinate of this group.

getX2

public int getX2()
The bottom right x coordinate of this group.

getY2

public int getY2()
The bottom right y coordinate of this group.

countOfAllChildren

public int countOfAllChildren()
Count of all children and their childrens children.

Overrides:
countOfAllChildren in class HSSFShape
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFSheet

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFSheet
All Implemented Interfaces:
java.lang.Iterable<Row>, Sheet
public final class HSSFSheet
extends java.lang.Object
implements Sheet

High level representation of a worksheet.

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org), Libin Roman (romal at vistaportal.com), Shawn Laubach (slaubach at apache dot org) (Just a little), Jean-Pierre Paris (jean-pierre.paris at m4x dot org) (Just a little, too), Yegor Kozlov (yegor at apache.org) (Autosizing columns), Josh Micich, Petr Udalau(Petr.Udalau at exigenservices.com) - set/remove array formulas

Field Summary
protected InternalWorkbook | _book
protected HSSFWorkbook | _workbook
static int | INITIAL_CAPACITY Used for compile-time optimization.
Fields inherited from interface org.apache.poi.ss.usermodel.Sheet
BottomMargin, FooterMargin, HeaderMargin, LeftMargin, PANE_LOWER_LEFT, PANE_LOWER_RIGHT, PANE_UPPER_LEFT, PANE_UPPER_RIGHT, RightMargin, TopMargin
Constructor Summary
protected | HSSFSheet(HSSFWorkbook workbook) Creates new HSSFSheet - called by HSSFWorkbook to create a sheet from scratch.
protected | HSSFSheet(HSSFWorkbook workbook, InternalSheet sheet) Creates an HSSFSheet representing the given Sheet object.
Method Summary
 int addMergedRegion(CellRangeAddress region)
adds a merged region of cells (hence those cells form one)
 int addMergedRegion(Region region)
Deprecated. (Aug-2008) use CellRangeAddress instead of Region
 void addValidationData(DataValidation dataValidation)
Creates a data validation object
 void autoSizeColumn(int column)
Adjusts the column width to fit the contents.
 void autoSizeColumn(int column, boolean useMergedCells)
Adjusts the column width to fit the contents.
 HSSFPatriarch createDrawingPatriarch()
Creates the top-level drawing patriarch.
 void createFreezePane(int colSplit, int rowSplit)
Creates a split (freezepane).
 void createFreezePane(int colSplit, int rowSplit, int leftmostColumn, int topRow)
Creates a split (freezepane).
 HSSFRow createRow(int rownum)
Create a new row within the sheet and return the high level representation
 void createSplitPane(int xSplitPos, int ySplitPos, int leftmostColumn, int topRow, int activePane)
Creates a split pane.
 void dumpDrawingRecords(boolean fat)
Aggregates the drawing records and dumps the escher record hierarchy to the standard output.
 boolean getAlternateExpression()
whether alternate expression evaluation is on
 boolean getAlternateFormula()
whether alternative formula entry is on
 boolean getAutobreaks()
show automatic page breaks or not
 HSSFComment getCellComment(int row, int column)
Returns cell comment for the specified row and column
 int[] getColumnBreaks()
Retrieves all the vertical page breaks
 HSSFCellStyle getColumnStyle(int column)
Returns the HSSFCellStyle that applies to the given (0 based) column, or null if no style has been set for that column
 int getColumnWidth(int columnIndex)
get the width (in units of 1/256th of a character width )
 short getColumnWidth(short columnIndex)
Deprecated. (Sep 2008) use getColumnWidth(int)
 DataValidationHelper getDataValidationHelper()
 int getDefaultColumnWidth()
get the default column width for the sheet (if the columns do not define their own width) in characters
 short getDefaultRowHeight()
get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
 float getDefaultRowHeightInPoints()
get the default row height for the sheet (if the rows do not define their own height) in points.
 boolean getDialog()
get whether sheet is a dialog sheet or not
 boolean getDisplayGuts()
get whether to display the guts or not
 EscherAggregate getDrawingEscherAggregate()
Returns the agregate escher records for this sheet, it there is one.
 HSSFPatriarch getDrawingPatriarch()
Returns the top-level drawing patriach, if there is one.
 int getFirstRowNum()
Gets the first row on the sheet
 boolean getFitToPage()
fit to page option is on
 HSSFFooter getFooter()
Gets the user model for the default document footer.
 boolean getForceFormulaRecalculation()
Whether a record must be inserted or not at generation to indicate that formula must be recalculated when workbook is opened.
 HSSFHeader getHeader()
Gets the user model for the default document header.
 boolean getHorizontallyCenter()
Determine whether printed output for this sheet will be horizontally centered.
 int getLastRowNum()
Gets the number last row on the sheet.
 short getLeftCol()
The left col in the visible view when the sheet is first viewed after opening it in a viewer
 double getMargin(short margin)
Gets the size of the margin in inches.
 CellRangeAddress getMergedRegion(int index)
Returns the merged region at the specified index
 Region getMergedRegionAt(int index)
Deprecated. (Aug-2008) use getMergedRegion(int)
 int getNumMergedRegions()
returns the number of merged regions
 boolean getObjectProtect()
Answer whether object protection is enabled or disabled
 PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).
 short getPassword()
 int getPhysicalNumberOfRows()
Returns the number of physically defined rows (NOT the number of rows in the sheet)
 HSSFPrintSetup getPrintSetup()
Gets the print setup object.
 boolean getProtect()
Answer whether protection is enabled or disabled
 HSSFRow getRow(int rowIndex)
Returns the logical row (not physical) 0-based.
 int[] getRowBreaks()
Retrieves all the horizontal page breaks
 boolean getRowSumsBelow()
get if row summaries appear below detail in the outline
 boolean getRowSumsRight()
get if col summaries appear right of the detail in the outline
 boolean getScenarioProtect()
Answer whether scenario protection is enabled or disabled
 HSSFSheetConditionalFormatting getSheetConditionalFormatting()
The 'Conditional Formatting' facet for this Sheet
 java.lang.String getSheetName()
Returns the name of this sheet
 short getTopRow()
The top row in the visible view when the sheet is first viewed after opening it in a viewer
 boolean getVerticallyCenter()
Determine whether printed output for this sheet will be vertically centered.
 boolean getVerticallyCenter(boolean value)
Deprecated. (Mar-2008) use getVerticallyCenter() instead
 HSSFWorkbook getWorkbook()
Return the parent workbook
 void groupColumn(int fromColumn, int toColumn)
Create an outline for the provided column range.
 void groupColumn(short fromColumn, short toColumn)
Deprecated. (Sep 2008) use groupColumn(int, int)
 void groupRow(int fromRow, int toRow)
Tie a range of cell together so that they can be collapsed or expanded
protected  void insertChartRecords(java.util.List<Record> records)
 boolean isActive()
 boolean isColumnBroken(int column)
Determines if there is a page break at the indicated column
 boolean isColumnHidden(int columnIndex)
Get the hidden state for a given column.
 boolean isColumnHidden(short columnIndex)
Deprecated. (Sep 2008) use isColumnHidden(int)
 boolean isDisplayFormulas()
Returns if formulas are displayed.
 boolean isDisplayGridlines()
Returns if gridlines are displayed.
 boolean isDisplayRowColHeadings()
Returns if RowColHeadings are displayed.
 boolean isDisplayZeros()
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
 boolean isGridsPrinted()
get whether gridlines are printed.
 boolean isPrintGridlines()
Returns whether gridlines are printed.
 boolean isRightToLeft()
Whether the text is displayed in right-to-left mode in the window
 boolean isRowBroken(int row)
Determines if there is a page break at the indicated row
 boolean isSelected()
Note - this is not the same as whether the sheet is focused (isActive)
 java.util.Iterator<Row> iterator()
Alias for rowIterator() to allow foreach loops
 void protectSheet(java.lang.String password)
Sets the protection enabled as well as the password
 CellRange<HSSFCell> removeArrayFormula(Cell cell)
Remove a Array Formula from this sheet.
 void removeColumnBreak(int column)
Removes a page break at the indicated column
 void removeMergedRegion(int index)
removes a merged region of cells (hence letting them free)
 void removeRow(Row row)
Remove a row from this sheet.
 void removeRowBreak(int row)
Removes the page break at the indicated row
 java.util.Iterator<Row> rowIterator()
Returns an iterator of the physical rows
 void setActive(boolean sel)
Sets whether sheet is selected.
 void setAlternativeExpression(boolean b)
whether alternate expression evaluation is on
 void setAlternativeFormula(boolean b)
whether alternative formula entry is on
 CellRange<HSSFCell> setArrayFormula(java.lang.String formula, CellRangeAddress range)
Sets array formula to specified region for result.
 void setAutobreaks(boolean b)
show automatic page breaks or not
 HSSFAutoFilter setAutoFilter(CellRangeAddress range)
Enable filtering for a range of cells
 void setColumnBreak(int column)
Sets a page break at the indicated column.
 void setColumnGroupCollapsed(int columnNumber, boolean collapsed)
Expands or collapses a column group.
 void setColumnGroupCollapsed(short columnNumber, boolean collapsed)
Deprecated. (Sep 2008) use setColumnGroupCollapsed(int, boolean)
 void setColumnHidden(int columnIndex, boolean hidden)
Get the visibility state for a given column.
 void setColumnHidden(short columnIndex, boolean hidden)
Deprecated. (Sep 2008) use setColumnHidden(int, boolean)
 void setColumnWidth(int columnIndex, int width)
Set the width (in units of 1/256th of a character width)
 void setColumnWidth(short columnIndex, short width)
Deprecated. (Sep 2008) use setColumnWidth(int, int)
 void setDefaultColumnStyle(int column, CellStyle style)
Sets the default column style for a given column.
 void setDefaultColumnWidth(int width)
set the default column width for the sheet (if the columns do not define their own width) in characters
 void setDefaultColumnWidth(short width)
Deprecated. (Sep 2008) use setDefaultColumnWidth(int)
 void setDefaultRowHeight(short height)
set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
 void setDefaultRowHeightInPoints(float height)
set the default row height for the sheet (if the rows do not define their own height) in points
 void setDialog(boolean b)
set whether sheet is a dialog sheet or not
 void setDisplayFormulas(boolean show)
Sets whether the formulas are shown in a viewer.
 void setDisplayGridlines(boolean show)
Sets whether the gridlines are shown in a viewer.
 void setDisplayGuts(boolean b)
set whether to display the guts or not
 void setDisplayRowColHeadings(boolean show)
Sets whether the RowColHeadings are shown in a viewer.
 void setDisplayZeros(boolean value)
Set whether the window should show 0 (zero) in cells containing zero value.
 void setFitToPage(boolean b)
fit to page option is on
 void setForceFormulaRecalculation(boolean value)
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.
 void setGridsPrinted(boolean value)
set whether gridlines printed.
 void setHorizontallyCenter(boolean value)
determines whether the output is horizontally centered on the page.
 void setMargin(short margin, double size)
Sets the size of the margin in inches.
 void setPrintGridlines(boolean newPrintGridlines)
Turns on or off the printing of gridlines.
 void setRightToLeft(boolean value)
Sets whether the worksheet is displayed from right to left instead of from left to right.
 void setRowBreak(int row)
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive.
 void setRowGroupCollapsed(int rowIndex, boolean collapse)
Set view state of a groupped range of rows
 void setRowSumsBelow(boolean b)
set if row summaries appear below detail in the outline
 void setRowSumsRight(boolean b)
set if col summaries appear right of the detail in the outline
 void setSelected(boolean sel)
Sets whether sheet is selected.
 void setVerticallyCenter(boolean value)
determines whether the output is vertically centered on the page.
 void setZoom(int numerator, int denominator)
Sets the zoom magnification for the sheet.
protected  void shiftMerged(int startRow, int endRow, int n, boolean isRow)
Shifts the merged regions left or right depending on mode
 void shiftRows(int startRow, int endRow, int n)
Shifts rows between startRow and endRow n number of rows.
 void shiftRows(int startRow, int endRow, int n, boolean copyRowHeight, boolean resetOriginalRowHeight)
Shifts rows between startRow and endRow n number of rows.
 void shiftRows(int startRow, int endRow, int n, boolean copyRowHeight, boolean resetOriginalRowHeight, boolean moveComments)
Shifts rows between startRow and endRow n number of rows.
 void showInPane(short toprow, short leftcol)
Sets desktop window pane display area, when the file is first opened in a viewer.
 void ungroupColumn(int fromColumn, int toColumn)
Ungroup a range of columns that were previously groupped
 void ungroupColumn(short fromColumn, short toColumn)
Deprecated. (Sep 2008) use ungroupColumn(int, int)
 void ungroupRow(int fromRow, int toRow)
Ungroup a range of rows that were previously groupped
protected  void validateColumn(int column)
Runs a bounds check for column numbers
protected  void validateRow(int row)
Runs a bounds check for row numbers
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INITIAL_CAPACITY

public static final int INITIAL_CAPACITY
Used for compile-time optimization. This is the initial size for the collection of rows. It is currently set to 20. If you generate larger sheets you may benefit by setting this to a higher number and recompiling a custom edition of HSSFSheet.

See Also:
Constant Field Values

_book

protected final InternalWorkbook _book

_workbook

protected final HSSFWorkbook _workbook
Constructor Detail

HSSFSheet

protected HSSFSheet(HSSFWorkbook workbook)
Creates new HSSFSheet - called by HSSFWorkbook to create a sheet from scratch. You should not be calling this from application code (its protected anyhow).

Parameters:
workbook - - The HSSF Workbook object associated with the sheet.
See Also:
HSSFWorkbook.createSheet()

HSSFSheet

protected HSSFSheet(HSSFWorkbook workbook,
                    InternalSheet sheet)
Creates an HSSFSheet representing the given Sheet object. Should only be called by HSSFWorkbook when reading in an exisiting file.

Parameters:
workbook - - The HSSF Workbook object associated with the sheet.
sheet - - lowlevel Sheet object this sheet will represent
See Also:
HSSFWorkbook.createSheet()
Method Detail

getWorkbook

public HSSFWorkbook getWorkbook()
Return the parent workbook

Specified by:
getWorkbook in interface Sheet
Returns:
the parent workbook

createRow

public HSSFRow createRow(int rownum)
Create a new row within the sheet and return the high level representation

Specified by:
createRow in interface Sheet
Parameters:
rownum - row number
Returns:
High level HSSFRow object representing a row in the sheet
See Also:
HSSFRow, removeRow(org.apache.poi.ss.usermodel.Row)

removeRow

public void removeRow(Row row)
Remove a row from this sheet. All cells contained in the row are removed as well

Specified by:
removeRow in interface Sheet
Parameters:
row - representing a row to remove.

getRow

public HSSFRow getRow(int rowIndex)
Returns the logical row (not physical) 0-based. If you ask for a row that is not defined you get a null. This is to say row 4 represents the fifth row on a sheet.

Specified by:
getRow in interface Sheet
Parameters:
rowIndex - row to get
Returns:
HSSFRow representing the row number or null if its not defined on the sheet

getPhysicalNumberOfRows

public int getPhysicalNumberOfRows()
Returns the number of physically defined rows (NOT the number of rows in the sheet)

Specified by:
getPhysicalNumberOfRows in interface Sheet
Returns:
the number of physically defined rows in this sheet

getFirstRowNum

public int getFirstRowNum()
Gets the first row on the sheet

Specified by:
getFirstRowNum in interface Sheet
Returns:
the number of the first logical row on the sheet, zero based

getLastRowNum

public int getLastRowNum()
Gets the number last row on the sheet. Owing to idiosyncrasies in the excel file format, if the result of calling this method is zero, you can't tell if that means there are zero rows on the sheet, or one at position zero. For that case, additionally call getPhysicalNumberOfRows() to tell if there is a row at position zero or not.

Specified by:
getLastRowNum in interface Sheet
Returns:
the number of the last row contained in this sheet, zero based.

addValidationData

public void addValidationData(DataValidation dataValidation)
Creates a data validation object

Specified by:
addValidationData in interface Sheet
Parameters:
dataValidation - The Data validation object settings

setColumnHidden

public void setColumnHidden(short columnIndex,
                            boolean hidden)
Deprecated. (Sep 2008) use setColumnHidden(int, boolean)

isColumnHidden

public boolean isColumnHidden(short columnIndex)
Deprecated. (Sep 2008) use isColumnHidden(int)

setColumnWidth

public void setColumnWidth(short columnIndex,
                           short width)
Deprecated. (Sep 2008) use setColumnWidth(int, int)

getColumnWidth

public short getColumnWidth(short columnIndex)
Deprecated. (Sep 2008) use getColumnWidth(int)

setDefaultColumnWidth

public void setDefaultColumnWidth(short width)
Deprecated. (Sep 2008) use setDefaultColumnWidth(int)

setColumnHidden

public void setColumnHidden(int columnIndex,
                            boolean hidden)
Get the visibility state for a given column.

Specified by:
setColumnHidden in interface Sheet
Parameters:
columnIndex - - the column to get (0-based)
hidden - - the visiblity state of the column

isColumnHidden

public boolean isColumnHidden(int columnIndex)
Get the hidden state for a given column.

Specified by:
isColumnHidden in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
Returns:
hidden - false if the column is visible

setColumnWidth

public void setColumnWidth(int columnIndex,
                           int width)
Set the width (in units of 1/256th of a character width)

The maximum column width for an individual cell is 255 characters. This value represents the number of characters that can be displayed in a cell that is formatted with the standard font (first font in the workbook).

Character width is defined as the maximum digit width of the numbers 0, 1, 2, ... 9 as rendered using the default font (first font in the workbook).
Unless you are using a very special font, the default character is '0' (zero), this is true for Arial (default font font in HSSF) and Calibri (default font in XSSF)

Please note, that the width set by this method includes 4 pixels of margin padding (two on each side), plus 1 pixel padding for the gridlines (Section 3.3.1.12 of the OOXML spec). This results is a slightly less value of visible characters than passed to this method (approx. 1/2 of a character).

To compute the actual number of visible characters, Excel uses the following formula (Section 3.3.1.12 of the OOXML spec):

width = Truncate([{Number of Visible Characters} * {Maximum Digit Width} + {5 pixel padding}]/{Maximum Digit Width}*256)/256

Using the Calibri font as an example, the maximum digit width of 11 point font size is 7 pixels (at 96 dpi). If you set a column width to be eight characters wide, e.g. setColumnWidth(columnIndex, 8*256), then the actual value of visible characters (the value shown in Excel) is derived from the following equation: Truncate([numChars*7+5]/7*256)/256 = 8; which gives 7.29.

Specified by:
setColumnWidth in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
width - - the width in units of 1/256th of a character width
Throws:
java.lang.IllegalArgumentException - if width > 255*256 (the maximum column width in Excel is 255 characters)

getColumnWidth

public int getColumnWidth(int columnIndex)
get the width (in units of 1/256th of a character width )

Specified by:
getColumnWidth in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
Returns:
width - the width in units of 1/256th of a character width

getDefaultColumnWidth

public int getDefaultColumnWidth()
get the default column width for the sheet (if the columns do not define their own width) in characters

Specified by:
getDefaultColumnWidth in interface Sheet
Returns:
default column width

setDefaultColumnWidth

public void setDefaultColumnWidth(int width)
set the default column width for the sheet (if the columns do not define their own width) in characters

Specified by:
setDefaultColumnWidth in interface Sheet
Parameters:
width - default column width

getDefaultRowHeight

public short getDefaultRowHeight()
get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Specified by:
getDefaultRowHeight in interface Sheet
Returns:
default row height

getDefaultRowHeightInPoints

public float getDefaultRowHeightInPoints()
get the default row height for the sheet (if the rows do not define their own height) in points.

Specified by:
getDefaultRowHeightInPoints in interface Sheet
Returns:
default row height in points

setDefaultRowHeight

public void setDefaultRowHeight(short height)
set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Specified by:
setDefaultRowHeight in interface Sheet
Parameters:
height - default row height

setDefaultRowHeightInPoints

public void setDefaultRowHeightInPoints(float height)
set the default row height for the sheet (if the rows do not define their own height) in points

Specified by:
setDefaultRowHeightInPoints in interface Sheet
Parameters:
height - default row height

getColumnStyle

public HSSFCellStyle getColumnStyle(int column)
Returns the HSSFCellStyle that applies to the given (0 based) column, or null if no style has been set for that column

Specified by:
getColumnStyle in interface Sheet

isGridsPrinted

public boolean isGridsPrinted()
get whether gridlines are printed.

Returns:
true if printed

setGridsPrinted

public void setGridsPrinted(boolean value)
set whether gridlines printed.

Parameters:
value - false if not printed.

addMergedRegion

public int addMergedRegion(Region region)
Deprecated. (Aug-2008) use CellRangeAddress instead of Region

addMergedRegion

public int addMergedRegion(CellRangeAddress region)
adds a merged region of cells (hence those cells form one)

Specified by:
addMergedRegion in interface Sheet
Parameters:
region - (rowfrom/colfrom-rowto/colto) to merge
Returns:
index of this region

setForceFormulaRecalculation

public void setForceFormulaRecalculation(boolean value)
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.

Calculating the formula values with FormulaEvaluator is the recommended solution, but this may be used for certain cases where evaluation in POI is not possible.

It is recommended to force recalcuation of formulas on workbook level using Workbook.setForceFormulaRecalculation(boolean) to ensure that all cross-worksheet formuals and external dependencies are updated.

Specified by:
setForceFormulaRecalculation in interface Sheet
Parameters:
value - true if the application will perform a full recalculation of this worksheet values when the workbook is opened
See Also:
Workbook.setForceFormulaRecalculation(boolean)

getForceFormulaRecalculation

public boolean getForceFormulaRecalculation()
Whether a record must be inserted or not at generation to indicate that formula must be recalculated when workbook is opened.

Specified by:
getForceFormulaRecalculation in interface Sheet
Returns:
true if an uncalced record must be inserted or not at generation

setVerticallyCenter

public void setVerticallyCenter(boolean value)
determines whether the output is vertically centered on the page.

Specified by:
setVerticallyCenter in interface Sheet
Parameters:
value - true to vertically center, false otherwise.

getVerticallyCenter

public boolean getVerticallyCenter(boolean value)
Deprecated. (Mar-2008) use getVerticallyCenter() instead

TODO: Boolean not needed, remove after next release

getVerticallyCenter

public boolean getVerticallyCenter()
Determine whether printed output for this sheet will be vertically centered.

Specified by:
getVerticallyCenter in interface Sheet

setHorizontallyCenter

public void setHorizontallyCenter(boolean value)
determines whether the output is horizontally centered on the page.

Specified by:
setHorizontallyCenter in interface Sheet
Parameters:
value - true to horizontally center, false otherwise.

getHorizontallyCenter

public boolean getHorizontallyCenter()
Determine whether printed output for this sheet will be horizontally centered.

Specified by:
getHorizontallyCenter in interface Sheet

setRightToLeft

public void setRightToLeft(boolean value)
Sets whether the worksheet is displayed from right to left instead of from left to right.

Specified by:
setRightToLeft in interface Sheet
Parameters:
value - true for right to left, false otherwise.

isRightToLeft

public boolean isRightToLeft()
Whether the text is displayed in right-to-left mode in the window

Specified by:
isRightToLeft in interface Sheet
Returns:
whether the text is displayed in right-to-left mode in the window

removeMergedRegion

public void removeMergedRegion(int index)
removes a merged region of cells (hence letting them free)

Specified by:
removeMergedRegion in interface Sheet
Parameters:
index - of the region to unmerge

getNumMergedRegions

public int getNumMergedRegions()
returns the number of merged regions

Specified by:
getNumMergedRegions in interface Sheet
Returns:
number of merged regions

getMergedRegionAt

public Region getMergedRegionAt(int index)
Deprecated. (Aug-2008) use getMergedRegion(int)

getMergedRegion

public CellRangeAddress getMergedRegion(int index)
Description copied from interface: Sheet
Returns the merged region at the specified index

Specified by:
getMergedRegion in interface Sheet
Returns:
the merged region at the specified index

rowIterator

public java.util.Iterator<Row> rowIterator()
Description copied from interface: Sheet
Returns an iterator of the physical rows

Specified by:
rowIterator in interface Sheet
Returns:
an iterator of the PHYSICAL rows. Meaning the 3rd element may not be the third row if say for instance the second row is undefined. Call getRowNum() on each row if you care which one it is.

iterator

public java.util.Iterator<Row> iterator()
Alias for rowIterator() to allow foreach loops

Specified by:
iterator in interface java.lang.Iterable<Row>

setAlternativeExpression

public void setAlternativeExpression(boolean b)
whether alternate expression evaluation is on

Parameters:
b - alternative expression evaluation or not

setAlternativeFormula

public void setAlternativeFormula(boolean b)
whether alternative formula entry is on

Parameters:
b - alternative formulas or not

setAutobreaks

public void setAutobreaks(boolean b)
show automatic page breaks or not

Specified by:
setAutobreaks in interface Sheet
Parameters:
b - whether to show auto page breaks

setDialog

public void setDialog(boolean b)
set whether sheet is a dialog sheet or not

Parameters:
b - isDialog or not

setDisplayGuts

public void setDisplayGuts(boolean b)
set whether to display the guts or not

Specified by:
setDisplayGuts in interface Sheet
Parameters:
b - guts or no guts (or glory)

setFitToPage

public void setFitToPage(boolean b)
fit to page option is on

Specified by:
setFitToPage in interface Sheet
Parameters:
b - fit or not

setRowSumsBelow

public void setRowSumsBelow(boolean b)
set if row summaries appear below detail in the outline

Specified by:
setRowSumsBelow in interface Sheet
Parameters:
b - below or not

setRowSumsRight

public void setRowSumsRight(boolean b)
set if col summaries appear right of the detail in the outline

Specified by:
setRowSumsRight in interface Sheet
Parameters:
b - right or not

getAlternateExpression

public boolean getAlternateExpression()
whether alternate expression evaluation is on

Returns:
alternative expression evaluation or not

getAlternateFormula

public boolean getAlternateFormula()
whether alternative formula entry is on

Returns:
alternative formulas or not

getAutobreaks

public boolean getAutobreaks()
show automatic page breaks or not

Specified by:
getAutobreaks in interface Sheet
Returns:
whether to show auto page breaks

getDialog

public boolean getDialog()
get whether sheet is a dialog sheet or not

Returns:
isDialog or not

getDisplayGuts

public boolean getDisplayGuts()
get whether to display the guts or not

Specified by:
getDisplayGuts in interface Sheet
Returns:
guts or no guts (or glory)

isDisplayZeros

public boolean isDisplayZeros()
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

In Excel 2003 this option can be changed in the Options dialog on the View tab.

Specified by:
isDisplayZeros in interface Sheet
Returns:
whether all zero values on the worksheet are displayed

setDisplayZeros

public void setDisplayZeros(boolean value)
Set whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

In Excel 2003 this option can be set in the Options dialog on the View tab.

Specified by:
setDisplayZeros in interface Sheet
Parameters:
value - whether to display or hide all zero values on the worksheet

getFitToPage

public boolean getFitToPage()
fit to page option is on

Specified by:
getFitToPage in interface Sheet
Returns:
fit or not

getRowSumsBelow

public boolean getRowSumsBelow()
get if row summaries appear below detail in the outline

Specified by:
getRowSumsBelow in interface Sheet
Returns:
below or not

getRowSumsRight

public boolean getRowSumsRight()
get if col summaries appear right of the detail in the outline

Specified by:
getRowSumsRight in interface Sheet
Returns:
right or not

isPrintGridlines

public boolean isPrintGridlines()
Returns whether gridlines are printed.

Specified by:
isPrintGridlines in interface Sheet
Returns:
Gridlines are printed
See Also:
to check if printing of gridlines is turned on or off

setPrintGridlines

public void setPrintGridlines(boolean newPrintGridlines)
Turns on or off the printing of gridlines.

Specified by:
setPrintGridlines in interface Sheet
Parameters:
newPrintGridlines - boolean to turn on or off the printing of gridlines
See Also:
Sheet.setPrintGridlines(boolean)

getPrintSetup

public HSSFPrintSetup getPrintSetup()
Gets the print setup object.

Specified by:
getPrintSetup in interface Sheet
Returns:
The user model for the print setup object.

getHeader

public HSSFHeader getHeader()
Description copied from interface: Sheet
Gets the user model for the default document header.

Note that XSSF offers more kinds of document headers than HSSF does

Specified by:
getHeader in interface Sheet
Returns:
the document header. Never null

getFooter

public HSSFFooter getFooter()
Description copied from interface: Sheet
Gets the user model for the default document footer.

Note that XSSF offers more kinds of document footers than HSSF does.

Specified by:
getFooter in interface Sheet
Returns:
the document footer. Never null

isSelected

public boolean isSelected()
Note - this is not the same as whether the sheet is focused (isActive)

Specified by:
isSelected in interface Sheet
Returns:
true if this sheet is currently selected

setSelected

public void setSelected(boolean sel)
Sets whether sheet is selected.

Specified by:
setSelected in interface Sheet
Parameters:
sel - Whether to select the sheet or deselect the sheet.
See Also:
Workbook.setActiveSheet(int)

isActive

public boolean isActive()
Returns:
true if this sheet is currently focused

setActive

public void setActive(boolean sel)
Sets whether sheet is selected.

Parameters:
sel - Whether to select the sheet or deselect the sheet.

getMargin

public double getMargin(short margin)
Gets the size of the margin in inches.

Specified by:
getMargin in interface Sheet
Parameters:
margin - which margin to get
Returns:
the size of the margin

setMargin

public void setMargin(short margin,
                      double size)
Sets the size of the margin in inches.

Specified by:
setMargin in interface Sheet
Parameters:
margin - which margin to get
size - the size of the margin

getProtect

public boolean getProtect()
Answer whether protection is enabled or disabled

Specified by:
getProtect in interface Sheet
Returns:
true => protection enabled; false => protection disabled

getPassword

public short getPassword()
Returns:
hashed password

getObjectProtect

public boolean getObjectProtect()
Answer whether object protection is enabled or disabled

Returns:
true => protection enabled; false => protection disabled

getScenarioProtect

public boolean getScenarioProtect()
Answer whether scenario protection is enabled or disabled

Specified by:
getScenarioProtect in interface Sheet
Returns:
true => protection enabled; false => protection disabled

protectSheet

public void protectSheet(java.lang.String password)
Sets the protection enabled as well as the password

Specified by:
protectSheet in interface Sheet
Parameters:
password - to set for protection. Pass null to remove protection

setZoom

public void setZoom(int numerator,
                    int denominator)
Sets the zoom magnification for the sheet. The zoom is expressed as a fraction. For example to express a zoom of 75% use 3 for the numerator and 4 for the denominator.

Specified by:
setZoom in interface Sheet
Parameters:
numerator - The numerator for the zoom magnification.
denominator - The denominator for the zoom magnification.

getTopRow

public short getTopRow()
The top row in the visible view when the sheet is first viewed after opening it in a viewer

Specified by:
getTopRow in interface Sheet
Returns:
short indicating the rownum (0 based) of the top row

getLeftCol

public short getLeftCol()
The left col in the visible view when the sheet is first viewed after opening it in a viewer

Specified by:
getLeftCol in interface Sheet
Returns:
short indicating the rownum (0 based) of the top row

showInPane

public void showInPane(short toprow,
                       short leftcol)
Sets desktop window pane display area, when the file is first opened in a viewer.

Specified by:
showInPane in interface Sheet
Parameters:
toprow - the top row to show in desktop window pane
leftcol - the left column to show in desktop window pane

shiftMerged

protected void shiftMerged(int startRow,
                           int endRow,
                           int n,
                           boolean isRow)
Shifts the merged regions left or right depending on mode

TODO: MODE , this is only row specific

Parameters:
startRow -
endRow -
n -
isRow -

shiftRows

public void shiftRows(int startRow,
                      int endRow,
                      int n)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around. Calls shiftRows(startRow, endRow, n, false, false);

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

Specified by:
shiftRows in interface Sheet
Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift

shiftRows

public void shiftRows(int startRow,
                      int endRow,
                      int n,
                      boolean copyRowHeight,
                      boolean resetOriginalRowHeight)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

TODO Might want to add bounds checking here

Specified by:
shiftRows in interface Sheet
Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift
copyRowHeight - whether to copy the row height during the shift
resetOriginalRowHeight - whether to set the original row's height to the default

shiftRows

public void shiftRows(int startRow,
                      int endRow,
                      int n,
                      boolean copyRowHeight,
                      boolean resetOriginalRowHeight,
                      boolean moveComments)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

TODO Might want to add bounds checking here

Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift
copyRowHeight - whether to copy the row height during the shift
resetOriginalRowHeight - whether to set the original row's height to the default
moveComments - whether to move comments at the same time as the cells they are attached to

insertChartRecords

protected void insertChartRecords(java.util.List<Record> records)

createFreezePane

public void createFreezePane(int colSplit,
                             int rowSplit,
                             int leftmostColumn,
                             int topRow)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

If both colSplit and rowSplit are zero then the existing freeze pane is removed

Specified by:
createFreezePane in interface Sheet
Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.
leftmostColumn - Left column visible in right pane.
topRow - Top row visible in bottom pane

createFreezePane

public void createFreezePane(int colSplit,
                             int rowSplit)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

If both colSplit and rowSplit are zero then the existing freeze pane is removed

Specified by:
createFreezePane in interface Sheet
Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.

createSplitPane

public void createSplitPane(int xSplitPos,
                            int ySplitPos,
                            int leftmostColumn,
                            int topRow,
                            int activePane)
Creates a split pane. Any existing freezepane or split pane is overwritten.

Specified by:
createSplitPane in interface Sheet
Parameters:
xSplitPos - Horizonatal position of split (in 1/20th of a point).
ySplitPos - Vertical position of split (in 1/20th of a point).
topRow - Top row visible in bottom pane
leftmostColumn - Left column visible in right pane.
activePane - Active pane. One of: PANE_LOWER_RIGHT, PANE_UPPER_RIGHT, PANE_LOWER_LEFT, PANE_UPPER_LEFT
See Also:
Sheet.PANE_LOWER_LEFT, Sheet.PANE_LOWER_RIGHT, Sheet.PANE_UPPER_LEFT, Sheet.PANE_UPPER_RIGHT

getPaneInformation

public PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).

Specified by:
getPaneInformation in interface Sheet
Returns:
null if no pane configured, or the pane information.

setDisplayGridlines

public void setDisplayGridlines(boolean show)
Sets whether the gridlines are shown in a viewer.

Specified by:
setDisplayGridlines in interface Sheet
Parameters:
show - whether to show gridlines or not

isDisplayGridlines

public boolean isDisplayGridlines()
Returns if gridlines are displayed.

Specified by:
isDisplayGridlines in interface Sheet
Returns:
whether gridlines are displayed

setDisplayFormulas

public void setDisplayFormulas(boolean show)
Sets whether the formulas are shown in a viewer.

Specified by:
setDisplayFormulas in interface Sheet
Parameters:
show - whether to show formulas or not

isDisplayFormulas

public boolean isDisplayFormulas()
Returns if formulas are displayed.

Specified by:
isDisplayFormulas in interface Sheet
Returns:
whether formulas are displayed

setDisplayRowColHeadings

public void setDisplayRowColHeadings(boolean show)
Sets whether the RowColHeadings are shown in a viewer.

Specified by:
setDisplayRowColHeadings in interface Sheet
Parameters:
show - whether to show RowColHeadings or not

isDisplayRowColHeadings

public boolean isDisplayRowColHeadings()
Returns if RowColHeadings are displayed.

Specified by:
isDisplayRowColHeadings in interface Sheet
Returns:
whether RowColHeadings are displayed

setRowBreak

public void setRowBreak(int row)
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive. For example, sheet.setColumnBreak(2); breaks the sheet into two parts with columns A,B,C in the first and D,E,... in the second. Simuilar, sheet.setRowBreak(2); breaks the sheet into two parts with first three rows (rownum=1...3) in the first part and rows starting with rownum=4 in the second.

Specified by:
setRowBreak in interface Sheet
Parameters:
row - the row to break, inclusive

isRowBroken

public boolean isRowBroken(int row)
Description copied from interface: Sheet
Determines if there is a page break at the indicated row

Specified by:
isRowBroken in interface Sheet
Parameters:
row - FIXME: Document this!
Returns:
true if there is a page break at the indicated row

removeRowBreak

public void removeRowBreak(int row)
Removes the page break at the indicated row

Specified by:
removeRowBreak in interface Sheet

getRowBreaks

public int[] getRowBreaks()
Description copied from interface: Sheet
Retrieves all the horizontal page breaks

Specified by:
getRowBreaks in interface Sheet
Returns:
row indexes of all the horizontal page breaks, never null

getColumnBreaks

public int[] getColumnBreaks()
Description copied from interface: Sheet
Retrieves all the vertical page breaks

Specified by:
getColumnBreaks in interface Sheet
Returns:
column indexes of all the vertical page breaks, never null

setColumnBreak

public void setColumnBreak(int column)
Sets a page break at the indicated column. Breaks occur above the specified row and left of the specified column inclusive. For example, sheet.setColumnBreak(2); breaks the sheet into two parts with columns A,B,C in the first and D,E,... in the second. Simuilar, sheet.setRowBreak(2); breaks the sheet into two parts with first three rows (rownum=1...3) in the first part and rows starting with rownum=4 in the second.

Specified by:
setColumnBreak in interface Sheet
Parameters:
column - the column to break, inclusive

isColumnBroken

public boolean isColumnBroken(int column)
Determines if there is a page break at the indicated column

Specified by:
isColumnBroken in interface Sheet
Parameters:
column - FIXME: Document this!
Returns:
FIXME: Document this!

removeColumnBreak

public void removeColumnBreak(int column)
Removes a page break at the indicated column

Specified by:
removeColumnBreak in interface Sheet
Parameters:
column -

validateRow

protected void validateRow(int row)
Runs a bounds check for row numbers

Parameters:
row -

validateColumn

protected void validateColumn(int column)
Runs a bounds check for column numbers

Parameters:
column -

dumpDrawingRecords

public void dumpDrawingRecords(boolean fat)
Aggregates the drawing records and dumps the escher record hierarchy to the standard output.

createDrawingPatriarch

public HSSFPatriarch createDrawingPatriarch()
Creates the top-level drawing patriarch. This will have the effect of removing any existing drawings on this sheet. This may then be used to add graphics or charts

Specified by:
createDrawingPatriarch in interface Sheet
Returns:
The new patriarch.

getDrawingEscherAggregate

public EscherAggregate getDrawingEscherAggregate()
Returns the agregate escher records for this sheet, it there is one. WARNING - calling this will trigger a parsing of the associated escher records. Any that aren't supported (such as charts and complex drawing types) will almost certainly be lost or corrupted when written out.

getDrawingPatriarch

public HSSFPatriarch getDrawingPatriarch()
Returns the top-level drawing patriach, if there is one. This will hold any graphics or charts for the sheet. WARNING - calling this will trigger a parsing of the associated escher records. Any that aren't supported (such as charts and complex drawing types) will almost certainly be lost or corrupted when written out. Only use this with simple drawings, otherwise call createDrawingPatriarch() and start from scratch!

setColumnGroupCollapsed

public void setColumnGroupCollapsed(short columnNumber,
                                    boolean collapsed)
Deprecated. (Sep 2008) use setColumnGroupCollapsed(int, boolean)

groupColumn

public void groupColumn(short fromColumn,
                        short toColumn)
Deprecated. (Sep 2008) use groupColumn(int, int)

ungroupColumn

public void ungroupColumn(short fromColumn,
                          short toColumn)
Deprecated. (Sep 2008) use ungroupColumn(int, int)

setColumnGroupCollapsed

public void setColumnGroupCollapsed(int columnNumber,
                                    boolean collapsed)
Expands or collapses a column group.

Specified by:
setColumnGroupCollapsed in interface Sheet
Parameters:
columnNumber - One of the columns in the group.
collapsed - true = collapse group, false = expand group.

groupColumn

public void groupColumn(int fromColumn,
                        int toColumn)
Create an outline for the provided column range.

Specified by:
groupColumn in interface Sheet
Parameters:
fromColumn - beginning of the column range.
toColumn - end of the column range.

ungroupColumn

public void ungroupColumn(int fromColumn,
                          int toColumn)
Description copied from interface: Sheet
Ungroup a range of columns that were previously groupped

Specified by:
ungroupColumn in interface Sheet
Parameters:
fromColumn - start column (0-based)
toColumn - end column (0-based)

groupRow

public void groupRow(int fromRow,
                     int toRow)
Tie a range of cell together so that they can be collapsed or expanded

Specified by:
groupRow in interface Sheet
Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

ungroupRow

public void ungroupRow(int fromRow,
                       int toRow)
Description copied from interface: Sheet
Ungroup a range of rows that were previously groupped

Specified by:
ungroupRow in interface Sheet
Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

setRowGroupCollapsed

public void setRowGroupCollapsed(int rowIndex,
                                 boolean collapse)
Description copied from interface: Sheet
Set view state of a groupped range of rows

Specified by:
setRowGroupCollapsed in interface Sheet
Parameters:
rowIndex - start row of a groupped range of rows (0-based)
collapse - whether to expand/collapse the detail rows

setDefaultColumnStyle

public void setDefaultColumnStyle(int column,
                                  CellStyle style)
Sets the default column style for a given column. POI will only apply this style to new cells added to the sheet.

Specified by:
setDefaultColumnStyle in interface Sheet
Parameters:
column - the column index
style - the style to set

autoSizeColumn

public void autoSizeColumn(int column)
Adjusts the column width to fit the contents. This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing.

Specified by:
autoSizeColumn in interface Sheet
Parameters:
column - the column index

autoSizeColumn

public void autoSizeColumn(int column,
                           boolean useMergedCells)
Adjusts the column width to fit the contents. This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing. You can specify whether the content of merged cells should be considered or ignored. Default is to ignore merged cells.

Specified by:
autoSizeColumn in interface Sheet
Parameters:
column - the column index
useMergedCells - whether to use the contents of merged cells when calculating the width of the column

getCellComment

public HSSFComment getCellComment(int row,
                                  int column)
Returns cell comment for the specified row and column

Specified by:
getCellComment in interface Sheet
Returns:
cell comment or null if not found

getSheetConditionalFormatting

public HSSFSheetConditionalFormatting getSheetConditionalFormatting()
Description copied from interface: Sheet
The 'Conditional Formatting' facet for this Sheet

Specified by:
getSheetConditionalFormatting in interface Sheet
Returns:
conditional formatting rule for this sheet

getSheetName

public java.lang.String getSheetName()
Returns the name of this sheet

Specified by:
getSheetName in interface Sheet
Returns:
the name of this sheet

setArrayFormula

public CellRange<HSSFCell> setArrayFormula(java.lang.String formula,
                                           CellRangeAddress range)
Description copied from interface: Sheet
Sets array formula to specified region for result.

Specified by:
setArrayFormula in interface Sheet
Parameters:
formula - text representation of the formula
range - Region of array formula for result.
Returns:
the CellRange of cells affected by this change

removeArrayFormula

public CellRange<HSSFCell> removeArrayFormula(Cell cell)
Description copied from interface: Sheet
Remove a Array Formula from this sheet. All cells contained in the Array Formula range are removed as well

Specified by:
removeArrayFormula in interface Sheet
Parameters:
cell - any cell within Array Formula range
Returns:
the CellRange of cells affected by this change

getDataValidationHelper

public DataValidationHelper getDataValidationHelper()
Specified by:
getDataValidationHelper in interface Sheet

setAutoFilter

public HSSFAutoFilter setAutoFilter(CellRangeAddress range)
Description copied from interface: Sheet
Enable filtering for a range of cells

Specified by:
setAutoFilter in interface Sheet
Parameters:
range - the range of cells to filter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFSheetConditionalFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFSheetConditionalFormatting

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting
All Implemented Interfaces:
SheetConditionalFormatting
public final class HSSFSheetConditionalFormatting
extends java.lang.Object
implements SheetConditionalFormatting

The 'Conditional Formatting' facet of HSSFSheet

Author:
Dmitriy Kumshayev

Method Summary
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1) Add a new Conditional Formatting to the sheet.
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules) Add a new Conditional Formatting set to the sheet.
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2) Add a new Conditional Formatting consisting of two rules.
int | addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule rule1)
int | addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule[] cfRules) Allows to add a new Conditional Formatting set to the sheet.
int | addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule rule1, HSSFConditionalFormattingRule rule2)
int | addConditionalFormatting(ConditionalFormatting cf) Adds a copy of a ConditionalFormatting object to the sheet
int | addConditionalFormatting(HSSFConditionalFormatting cf) Adds a copy of HSSFConditionalFormatting object to the sheet
int | addConditionalFormatting(Region[] regions, HSSFConditionalFormattingRule[] cfRules) Deprecated. use CellRangeAddress instead of Region
HSSFConditionalFormattingRule | createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1) Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *
HSSFConditionalFormattingRule | createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1, java.lang.String formula2) A factory method allowing to create a conditional formatting rule with a cell comparison operator TODO - formulas containing cell references are currently not parsed properly
HSSFConditionalFormattingRule | createConditionalFormattingRule(java.lang.String formula) A factory method allowing to create a conditional formatting rule with a formula. The formatting rules are applied by Excel when the value of the formula not equal to 0. TODO - formulas containing cell references are currently not parsed properly
HSSFConditionalFormatting | getConditionalFormattingAt(int index) gets Conditional Formatting object at a particular index
int | getNumConditionalFormattings()
void | removeConditionalFormatting(int index) removes a Conditional Formatting object by index
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createConditionalFormattingRule

public HSSFConditionalFormattingRule createConditionalFormattingRule(byte comparisonOperation,
                                                                     java.lang.String formula1,
                                                                     java.lang.String formula2)
A factory method allowing to create a conditional formatting rule with a cell comparison operator

TODO - formulas containing cell references are currently not parsed properly

Specified by:
createConditionalFormattingRule in interface SheetConditionalFormatting
Parameters:
comparisonOperation - - a constant value from CFRuleRecord.ComparisonOperator:

  • BETWEEN
  • NOT_BETWEEN
  • EQUAL
  • NOT_EQUAL
  • GT
  • LT
  • GE
  • LE

formula1 - - formula for the valued, compared with the cell
formula2 - - second formula (only used with CFRuleRecord.ComparisonOperator.BETWEEN) and CFRuleRecord.ComparisonOperator.NOT_BETWEEN operations)

createConditionalFormattingRule

public HSSFConditionalFormattingRule createConditionalFormattingRule(byte comparisonOperation,
                                                                     java.lang.String formula1)
Description copied from interface: SheetConditionalFormatting
Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *

The type of the created condition is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS

Specified by:
createConditionalFormattingRule in interface SheetConditionalFormatting
Parameters:
comparisonOperation - MUST be a constant value from ComparisonOperator except BETWEEN and NOT_BETWEEN
formula1 - the formula to determine if the conditional formatting is applied

createConditionalFormattingRule

public HSSFConditionalFormattingRule createConditionalFormattingRule(java.lang.String formula)
A factory method allowing to create a conditional formatting rule with a formula.
The formatting rules are applied by Excel when the value of the formula not equal to 0.

TODO - formulas containing cell references are currently not parsed properly

Specified by:
createConditionalFormattingRule in interface SheetConditionalFormatting
Parameters:
formula - - formula for the valued, compared with the cell

addConditionalFormatting

public int addConditionalFormatting(HSSFConditionalFormatting cf)
Adds a copy of HSSFConditionalFormatting object to the sheet

This method could be used to copy HSSFConditionalFormatting object from one sheet to another. For example:

 HSSFConditionalFormatting cf = sheet.getConditionalFormattingAt(index);
 newSheet.addConditionalFormatting(cf);

Parameters:
cf - HSSFConditionalFormatting object
Returns:
index of the new Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(ConditionalFormatting cf)
Description copied from interface: SheetConditionalFormatting
Adds a copy of a ConditionalFormatting object to the sheet

This method could be used to copy ConditionalFormatting object from one sheet to another. For example:

 ConditionalFormatting cf = sheet.getConditionalFormattingAt(index);
 newSheet.addConditionalFormatting(cf);

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
cf - the Conditional Formatting to clone
Returns:
index of the new Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(Region[] regions,
                                    HSSFConditionalFormattingRule[] cfRules)
Deprecated. use CellRangeAddress instead of Region

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    HSSFConditionalFormattingRule[] cfRules)
Allows to add a new Conditional Formatting set to the sheet.

Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
cfRules - - set of up to three conditional formatting rules
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    ConditionalFormattingRule[] cfRules)
Description copied from interface: SheetConditionalFormatting
Add a new Conditional Formatting set to the sheet.

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
cfRules - - set of up to three conditional formatting rules
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    HSSFConditionalFormattingRule rule1)

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    ConditionalFormattingRule rule1)
Description copied from interface: SheetConditionalFormatting
Add a new Conditional Formatting to the sheet.

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
rule1 - - the rule to apply
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    HSSFConditionalFormattingRule rule1,
                                    HSSFConditionalFormattingRule rule2)

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    ConditionalFormattingRule rule1,
                                    ConditionalFormattingRule rule2)
Description copied from interface: SheetConditionalFormatting
Add a new Conditional Formatting consisting of two rules.

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
rule1 - - the first rule
rule2 - - the second rule
Returns:
index of the newly created Conditional Formatting object

getConditionalFormattingAt

public HSSFConditionalFormatting getConditionalFormattingAt(int index)
gets Conditional Formatting object at a particular index

Specified by:
getConditionalFormattingAt in interface SheetConditionalFormatting
Parameters:
index - of the Conditional Formatting object to fetch
Returns:
Conditional Formatting object

getNumConditionalFormattings

public int getNumConditionalFormattings()
Specified by:
getNumConditionalFormattings in interface SheetConditionalFormatting
Returns:
number of Conditional Formatting objects of the sheet

removeConditionalFormatting

public void removeConditionalFormatting(int index)
removes a Conditional Formatting object by index

Specified by:
removeConditionalFormatting in interface SheetConditionalFormatting
Parameters:
index - of a Conditional Formatting object to remove
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFSimpleShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFSimpleShape

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFShape
        extended by  org.apache.poi.hssf.usermodel.HSSFSimpleShape
Direct Known Subclasses:
HSSFPicture, HSSFTextbox
public class HSSFSimpleShape
extends HSSFShape

Represents a simple shape such as a line, rectangle or oval.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | OBJECT_TYPE_COMBO_BOX
static short | OBJECT_TYPE_COMMENT
static short | OBJECT_TYPE_LINE
static short | OBJECT_TYPE_OVAL
static short | OBJECT_TYPE_PICTURE
static short | OBJECT_TYPE_RECTANGLE
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFShape
LINESTYLE_DASHDOTDOTSYS, LINESTYLE_DASHDOTGEL, LINESTYLE_DASHDOTSYS, LINESTYLE_DASHGEL, LINESTYLE_DASHSYS, LINESTYLE_DOTGEL, LINESTYLE_DOTSYS, LINESTYLE_LONGDASHDOTDOTGEL, LINESTYLE_LONGDASHDOTGEL, LINESTYLE_LONGDASHGEL, LINESTYLE_NONE, LINESTYLE_SOLID, LINEWIDTH_DEFAULT, LINEWIDTH_ONE_PT
Constructor Summary
HSSFSimpleShape(HSSFShape parent, HSSFAnchor anchor)
Method Summary
int | getShapeType() Gets the shape type.
void | setShapeType(int shapeType) Sets the shape types.
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFShape
countOfAllChildren, getAnchor, getFillColor, getLineStyle, getLineStyleColor, getLineWidth, getParent, isNoFill, setAnchor, setFillColor, setFillColor, setLineStyle, setLineStyleColor, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OBJECT_TYPE_LINE

public static final short OBJECT_TYPE_LINE
See Also:
Constant Field Values

OBJECT_TYPE_RECTANGLE

public static final short OBJECT_TYPE_RECTANGLE
See Also:
Constant Field Values

OBJECT_TYPE_OVAL

public static final short OBJECT_TYPE_OVAL
See Also:
Constant Field Values

OBJECT_TYPE_PICTURE

public static final short OBJECT_TYPE_PICTURE
See Also:
Constant Field Values

OBJECT_TYPE_COMBO_BOX

public static final short OBJECT_TYPE_COMBO_BOX
See Also:
Constant Field Values

OBJECT_TYPE_COMMENT

public static final short OBJECT_TYPE_COMMENT
See Also:
Constant Field Values
Constructor Detail

HSSFSimpleShape

public HSSFSimpleShape(HSSFShape parent,
                       HSSFAnchor anchor)
Method Detail

getShapeType

public int getShapeType()
Gets the shape type.

Returns:
One of the OBJECT_TYPE_* constants.
See Also:
OBJECT_TYPE_LINE, OBJECT_TYPE_OVAL, OBJECT_TYPE_RECTANGLE, OBJECT_TYPE_PICTURE, OBJECT_TYPE_COMMENT

setShapeType

public void setShapeType(int shapeType)
Sets the shape types.

Parameters:
shapeType - One of the OBJECT_TYPE_* constants.
See Also:
OBJECT_TYPE_LINE, OBJECT_TYPE_OVAL, OBJECT_TYPE_RECTANGLE, OBJECT_TYPE_PICTURE, OBJECT_TYPE_COMMENT
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFTextbox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFTextbox

java.lang.Object
    extended by  org.apache.poi.hssf.usermodel.HSSFShape
        extended by  org.apache.poi.hssf.usermodel.HSSFSimpleShape
            extended by  org.apache.poi.hssf.usermodel.HSSFTextbox
Direct Known Subclasses:
HSSFComment
public class HSSFTextbox
extends HSSFSimpleShape

A textbox is a shape that may hold a rich text string.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static short | HORIZONTAL_ALIGNMENT_CENTERED
static short | HORIZONTAL_ALIGNMENT_DISTRIBUTED
static short | HORIZONTAL_ALIGNMENT_JUSTIFIED
static short | HORIZONTAL_ALIGNMENT_LEFT How to align text horizontally
static short | HORIZONTAL_ALIGNMENT_RIGHT
static short | OBJECT_TYPE_TEXT
static short | VERTICAL_ALIGNMENT_BOTTOM
static short | VERTICAL_ALIGNMENT_CENTER
static short | VERTICAL_ALIGNMENT_DISTRIBUTED
static short | VERTICAL_ALIGNMENT_JUSTIFY
static short | VERTICAL_ALIGNMENT_TOP How to align text vertically
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFSimpleShape
OBJECT_TYPE_COMBO_BOX, OBJECT_TYPE_COMMENT, OBJECT_TYPE_LINE, OBJECT_TYPE_OVAL, OBJECT_TYPE_PICTURE, OBJECT_TYPE_RECTANGLE
Fields inherited from class org.apache.poi.hssf.usermodel.HSSFShape
LINESTYLE_DASHDOTDOTSYS, LINESTYLE_DASHDOTGEL, LINESTYLE_DASHDOTSYS, LINESTYLE_DASHGEL, LINESTYLE_DASHSYS, LINESTYLE_DOTGEL, LINESTYLE_DOTSYS, LINESTYLE_LONGDASHDOTDOTGEL, LINESTYLE_LONGDASHDOTGEL, LINESTYLE_LONGDASHGEL, LINESTYLE_NONE, LINESTYLE_SOLID, LINEWIDTH_DEFAULT, LINEWIDTH_ONE_PT
Constructor Summary
HSSFTextbox(HSSFShape parent, HSSFAnchor anchor)
Construct a new textbox with the given parent and anchor.
Method Summary
short | getHorizontalAlignment() Gets the horizontal alignment.
int | getMarginBottom() Gets the bottom margin within the textbox.
int | getMarginLeft()
int | getMarginRight()
int | getMarginTop()
HSSFRichTextString | getString()
short | getVerticalAlignment() Gets the vertical alignment.
void | setHorizontalAlignment(short align) Sets the horizontal alignment.
void | setMarginBottom(int marginBottom) Sets the bottom margin within the textbox.
void | setMarginLeft(int marginLeft) Sets the left margin within the textbox.
void | setMarginRight(int marginRight) Sets the right margin within the textbox.
void | setMarginTop(int marginTop) Sets the top margin within the textbox.
void | setString(RichTextString string)
void | setVerticalAlignment(short align) Sets the vertical alignment.
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFSimpleShape
getShapeType, setShapeType
Methods inherited from class org.apache.poi.hssf.usermodel.HSSFShape
countOfAllChildren, getAnchor, getFillColor, getLineStyle, getLineStyleColor, getLineWidth, getParent, isNoFill, setAnchor, setFillColor, setFillColor, setLineStyle, setLineStyleColor, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OBJECT_TYPE_TEXT

public static final short OBJECT_TYPE_TEXT
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_LEFT

public static final short HORIZONTAL_ALIGNMENT_LEFT
How to align text horizontally

See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_CENTERED

public static final short HORIZONTAL_ALIGNMENT_CENTERED
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_RIGHT

public static final short HORIZONTAL_ALIGNMENT_RIGHT
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_JUSTIFIED

public static final short HORIZONTAL_ALIGNMENT_JUSTIFIED
See Also:
Constant Field Values

HORIZONTAL_ALIGNMENT_DISTRIBUTED

public static final short HORIZONTAL_ALIGNMENT_DISTRIBUTED
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_TOP

public static final short VERTICAL_ALIGNMENT_TOP
How to align text vertically

See Also:
Constant Field Values

VERTICAL_ALIGNMENT_CENTER

public static final short VERTICAL_ALIGNMENT_CENTER
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_BOTTOM

public static final short VERTICAL_ALIGNMENT_BOTTOM
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_JUSTIFY

public static final short VERTICAL_ALIGNMENT_JUSTIFY
See Also:
Constant Field Values

VERTICAL_ALIGNMENT_DISTRIBUTED

public static final short VERTICAL_ALIGNMENT_DISTRIBUTED
See Also:
Constant Field Values
Constructor Detail

HSSFTextbox

public HSSFTextbox(HSSFShape parent,
                   HSSFAnchor anchor)
Construct a new textbox with the given parent and anchor.

Parameters:
parent -
anchor - One of HSSFClientAnchor or HSSFChildAnchor
Method Detail

getString

public HSSFRichTextString getString()
Returns:
the rich text string for this textbox.

setString

public void setString(RichTextString string)
Parameters:
string - Sets the rich text string used by this object.

getMarginLeft

public int getMarginLeft()
Returns:
Returns the left margin within the textbox.

setMarginLeft

public void setMarginLeft(int marginLeft)
Sets the left margin within the textbox.

getMarginRight

public int getMarginRight()
Returns:
returns the right margin within the textbox.

setMarginRight

public void setMarginRight(int marginRight)
Sets the right margin within the textbox.

getMarginTop

public int getMarginTop()
Returns:
returns the top margin within the textbox.

setMarginTop

public void setMarginTop(int marginTop)
Sets the top margin within the textbox.

getMarginBottom

public int getMarginBottom()
Gets the bottom margin within the textbox.

setMarginBottom

public void setMarginBottom(int marginBottom)
Sets the bottom margin within the textbox.

getHorizontalAlignment

public short getHorizontalAlignment()
Gets the horizontal alignment.

setHorizontalAlignment

public void setHorizontalAlignment(short align)
Sets the horizontal alignment.

getVerticalAlignment

public short getVerticalAlignment()
Gets the vertical alignment.

setVerticalAlignment

public void setVerticalAlignment(short align)
Sets the vertical alignment.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFWorkbook

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.usermodel
Class HSSFWorkbook

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hssf.usermodel.HSSFWorkbook
All Implemented Interfaces:
Workbook
public final class HSSFWorkbook
extends POIDocument
implements Workbook

High level representation of a workbook. This is the first object most users will construct whether they are reading or writing a workbook. It is also the top level object for creating new sheets/etc.

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org), Shawn Laubach (slaubach at apache dot org)
See Also:
InternalWorkbook, HSSFSheet

Field Summary
protected java.util.List<HSSFSheet> | _sheets this holds the HSSFSheet objects attached to this workbook
static int | INITIAL_CAPACITY used for compile-time performance/memory optimization.
Fields inherited from class org.apache.poi.POIDocument
directory
Fields inherited from interface org.apache.poi.ss.usermodel.Workbook
PICTURE_TYPE_DIB, PICTURE_TYPE_EMF, PICTURE_TYPE_JPEG, PICTURE_TYPE_PICT, PICTURE_TYPE_PNG, PICTURE_TYPE_WMF, SHEET_STATE_HIDDEN, SHEET_STATE_VERY_HIDDEN, SHEET_STATE_VISIBLE
Constructor Summary
HSSFWorkbook()
Creates new HSSFWorkbook from scratch (start here!)
HSSFWorkbook(DirectoryNode directory, boolean preserveNodes)
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models.
HSSFWorkbook(DirectoryNode directory, POIFSFileSystem fs, boolean preserveNodes)
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models.
HSSFWorkbook(java.io.InputStream s)
HSSFWorkbook(java.io.InputStream s, boolean preserveNodes)
Companion to HSSFWorkbook(POIFSFileSystem), this constructs the POI filesystem around your inputstream.
HSSFWorkbook(POIFSFileSystem fs)
HSSFWorkbook(POIFSFileSystem fs, boolean preserveNodes)
given a POI POIFSFileSystem object, read in its Workbook and populate the high and low level models.
Method Summary
 int addPicture(byte[] pictureData, int format)
Adds a picture to the workbook.
 int addSSTString(java.lang.String string)
Deprecated. Do not call this method from your applications. Use the methods available in the HSSFRow to add string HSSFCells
 void addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.
 boolean changeExternalReference(java.lang.String oldUrl, java.lang.String newUrl)
Changes an external referenced file to another file.
 HSSFSheet cloneSheet(int sheetIndex)
create an HSSFSheet from an existing sheet in the HSSFWorkbook.
static HSSFWorkbook create(InternalWorkbook book)
 HSSFCellStyle createCellStyle()
Create a new Cell style and add it to the workbook's style table.
 HSSFDataFormat createDataFormat()
Returns the instance of HSSFDataFormat for this workbook.
 HSSFFont createFont()
create a new Font and add it to the workbook's font table
 HSSFName createName()
creates a new named range and add it to the model
 HSSFSheet createSheet()
create an HSSFSheet for this HSSFWorkbook, adds it to the sheets and returns the high level representation.
 HSSFSheet createSheet(java.lang.String sheetname)
Create a new sheet for this Workbook and return the high level representation.
 void dumpDrawingGroupRecords(boolean fat)
Spits out a list of all the drawing records in the workbook.
 HSSFFont findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline)
Finds a font that matches the one with the supplied attributes
 java.lang.String findSheetNameFromExternSheet(int externSheetIndex)
Deprecated. for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.
 int getActiveSheetIndex()
gets the tab whose data is actually seen when the sheet is opened.
 java.util.List<HSSFObjectData> getAllEmbeddedObjects()
Gets all embedded OLE2 objects from the Workbook.
 java.util.List<HSSFPictureData> getAllPictures()
Gets all pictures from the Workbook.
 boolean getBackupFlag()
determine whether the Excel GUI will backup the workbook when saving.
 byte[] getBytes()
Method getBytes - get the bytes of just the HSSF portions of the XLS file.
 HSSFCellStyle getCellStyleAt(short idx)
get the cell style object at the given index
 HSSFCreationHelper getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
 HSSFPalette getCustomPalette()
 short getDisplayedTab()
Deprecated. - Misleading name - use getFirstVisibleTab()
 int getExternalSheetIndex(int internalSheetIndex)
Deprecated. for POI internal use only (formula parsing). This method is likely to be removed in future versions of POI.
 int getFirstVisibleTab()
sets the first tab that is displayed in the list of tabs in excel.
 HSSFFont getFontAt(short idx)
Get the font at the given index number
 boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
 Row.MissingCellPolicy getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.
 HSSFName getName(java.lang.String name)
 HSSFName getNameAt(int nameIndex)
 int getNameIndex(java.lang.String name)
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.
 java.lang.String getNameName(int index)
gets the named range name
 NameRecord getNameRecord(int nameIndex)
 short getNumberOfFonts()
get the number of fonts in the font table
 int getNumberOfNames()
 int getNumberOfSheets()
get the number of spreadsheets in the workbook (this will be three after serialization)
 short getNumCellStyles()
get the number of styles the workbook contains
 java.lang.String getPrintArea(int sheetIndex)
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
 short getSelectedTab()
Deprecated. - Misleading name - use getActiveSheetIndex()
 HSSFSheet getSheet(java.lang.String name)
Get sheet with the given name (case insensitive match)
 HSSFSheet getSheetAt(int index)
Get the HSSFSheet object at the given index.
 int getSheetIndex(Sheet sheet)
Returns the index of the given sheet
 int getSheetIndex(java.lang.String name)
Returns the index of the sheet by his name
 int getSheetIndexFromExternSheetIndex(int externSheetNumber)
 java.lang.String getSheetName(int sheetIndex)
Get the sheet name
 java.lang.String getSSTString(int index)
Deprecated. Do not call this method from your applications. Use the methods available in the HSSFRow to get string HSSFCells
 void insertChartRecord()
Test only.
 boolean isHidden()
 boolean isSheetHidden(int sheetIx)
Check whether a sheet is hidden.
 boolean isSheetVeryHidden(int sheetIx)
Check whether a sheet is very hidden.
 boolean isWriteProtected()
Is the workbook protected with a password (not encrypted)?
 void removeName(int index)
Remove the defined name at the specified index
 void removeName(java.lang.String name)
Remove a defined name by name
 void removePrintArea(int sheetIndex)
Delete the printarea for the sheet specified
 void removeSheetAt(int index)
Removes sheet at the given index.

Care must be taken if the removed sheet is the currently active or only selected sheet in the workbook.

protected  void resetFontCache()
Reset the fonts cache, causing all new calls to getFontAt() to create new objects.
 java.lang.String resolveNameXText(int refIndex, int definedNameIndex)
Deprecated. for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.
 void setActiveSheet(int index)
Convenience method to set the active sheet.
 void setBackupFlag(boolean backupValue)
determine whether the Excel GUI will backup the workbook when saving.
 void setDisplayedTab(short index)
Deprecated. - Misleading name - use setFirstVisibleTab()
 void setFirstVisibleTab(int index)
sets the first tab that is displayed in the list of tabs in excel.
 void setForceFormulaRecalculation(boolean value)
Whether the application shall perform a full recalculation when the workbook is opened.
 void setHidden(boolean hiddenFlag)
 void setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy)
Sets the policy on what to do when getting missing or blank cells from a row.
 void setPrintArea(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow)
For the Convenience of Java Programmers maintaining pointers.
 void setPrintArea(int sheetIndex, java.lang.String reference)
Sets the printarea for the sheet provided
 void setRepeatingRowsAndColumns(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow)
Sets the repeating rows and columns for a sheet (as found in 2003:File->PageSetup->Sheet, 2007:Page Layout->Print Titles).
 void setSelectedTab(int index)
Selects a single sheet.
 void setSelectedTab(short index)
Deprecated. use setSelectedTab(int)
 void setSelectedTabs(int[] indexes)
 void setSheetHidden(int sheetIx, boolean hidden)
Hide or unhide a sheet
 void setSheetHidden(int sheetIx, int hidden)
Hide or unhide a sheet.
 void setSheetName(int sheetIx, java.lang.String name)
Set the sheet name.
 void setSheetOrder(java.lang.String sheetname, int pos)
sets the order of appearance for a given sheet.
 void unwriteProtectWorkbook()
removes the write protect flag
 void write(java.io.OutputStream stream)
Method write - write out this workbook to an Outputstream.
 void writeProtectWorkbook(java.lang.String password, java.lang.String username)
protect a workbook with a password (not encypted, just sets writeprotect flags and the password.
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INITIAL_CAPACITY

public static final int INITIAL_CAPACITY
used for compile-time performance/memory optimization. This determines the initial capacity for the sheet collection. Its currently set to 3. Changing it in this release will decrease performance since you're never allowed to have more or less than three sheets!

See Also:
Constant Field Values

_sheets

protected java.util.List<HSSFSheet> _sheets
this holds the HSSFSheet objects attached to this workbook

Constructor Detail

HSSFWorkbook

public HSSFWorkbook()
Creates new HSSFWorkbook from scratch (start here!)

HSSFWorkbook

public HSSFWorkbook(POIFSFileSystem fs)
             throws java.io.IOException
Throws:
java.io.IOException

HSSFWorkbook

public HSSFWorkbook(POIFSFileSystem fs,
                    boolean preserveNodes)
             throws java.io.IOException
given a POI POIFSFileSystem object, read in its Workbook and populate the high and low level models. If you're reading in a workbook...start here.

Parameters:
fs - the POI filesystem that contains the Workbook stream.
preserveNodes - whether to preseve other nodes, such as macros. This takes more memory, so only say yes if you need to. If set, will store all of the POIFSFileSystem in memory
Throws:
java.io.IOException - if the stream cannot be read
See Also:
POIFSFileSystem

HSSFWorkbook

public HSSFWorkbook(DirectoryNode directory,
                    POIFSFileSystem fs,
                    boolean preserveNodes)
             throws java.io.IOException
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models. If you're reading in a workbook...start here.

Parameters:
directory - the POI filesystem directory to process from
fs - the POI filesystem that contains the Workbook stream.
preserveNodes - whether to preseve other nodes, such as macros. This takes more memory, so only say yes if you need to. If set, will store all of the POIFSFileSystem in memory
Throws:
java.io.IOException - if the stream cannot be read
See Also:
POIFSFileSystem

HSSFWorkbook

public HSSFWorkbook(DirectoryNode directory,
                    boolean preserveNodes)
             throws java.io.IOException
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models. If you're reading in a workbook...start here.

Parameters:
directory - the POI filesystem directory to process from
preserveNodes - whether to preseve other nodes, such as macros. This takes more memory, so only say yes if you need to. If set, will store all of the POIFSFileSystem in memory
Throws:
java.io.IOException - if the stream cannot be read
See Also:
POIFSFileSystem

HSSFWorkbook

public HSSFWorkbook(java.io.InputStream s)
             throws java.io.IOException
Throws:
java.io.IOException

HSSFWorkbook

public HSSFWorkbook(java.io.InputStream s,
                    boolean preserveNodes)
             throws java.io.IOException
Companion to HSSFWorkbook(POIFSFileSystem), this constructs the POI filesystem around your inputstream.

Parameters:
s - the POI filesystem that contains the Workbook stream.
preserveNodes - whether to preseve other nodes, such as macros. This takes more memory, so only say yes if you need to.
Throws:
java.io.IOException - if the stream cannot be read
See Also:
POIFSFileSystem, HSSFWorkbook(POIFSFileSystem)
Method Detail

create

public static HSSFWorkbook create(InternalWorkbook book)

getMissingCellPolicy

public Row.MissingCellPolicy getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row. The default is to return blank and null cells. Row.MissingCellPolicy

Specified by:
getMissingCellPolicy in interface Workbook

setMissingCellPolicy

public void setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy)
Sets the policy on what to do when getting missing or blank cells from a row. This will then apply to all calls to HSSFRow.getCell(int)}. See Row.MissingCellPolicy. Note that this has no effect on any iterators, only on when fetching Cells by their column index.

Specified by:
setMissingCellPolicy in interface Workbook

setSheetOrder

public void setSheetOrder(java.lang.String sheetname,
                          int pos)
sets the order of appearance for a given sheet.

Specified by:
setSheetOrder in interface Workbook
Parameters:
sheetname - the name of the sheet to reorder
pos - the position that we want to insert the sheet into (0 based)

setSelectedTab

public void setSelectedTab(int index)
Selects a single sheet. This may be different to the 'active' sheet (which is the sheet with focus).

Specified by:
setSelectedTab in interface Workbook
Parameters:
index - the index of the sheet to select (0 based)
See Also:
Sheet.setSelected(boolean)

setSelectedTab

public void setSelectedTab(short index)
Deprecated. use setSelectedTab(int)

deprecated May 2008

setSelectedTabs

public void setSelectedTabs(int[] indexes)

setActiveSheet

public void setActiveSheet(int index)
Convenience method to set the active sheet. The active sheet is is the sheet which is currently displayed when the workbook is viewed in Excel. 'Selected' sheet(s) is a distinct concept.

Specified by:
setActiveSheet in interface Workbook
Parameters:
index - index of the active sheet (0-based)

getActiveSheetIndex

public int getActiveSheetIndex()
gets the tab whose data is actually seen when the sheet is opened. This may be different from the "selected sheet" since excel seems to allow you to show the data of one sheet when another is seen "selected" in the tabs (at the bottom).

Specified by:
getActiveSheetIndex in interface Workbook
Returns:
the index of the active sheet (0-based)
See Also:
HSSFSheet.setSelected(boolean)

getSelectedTab

public short getSelectedTab()
Deprecated. - Misleading name - use getActiveSheetIndex()

deprecated May 2008

setFirstVisibleTab

public void setFirstVisibleTab(int index)
sets the first tab that is displayed in the list of tabs in excel.

Specified by:
setFirstVisibleTab in interface Workbook
Parameters:
index -

setDisplayedTab

public void setDisplayedTab(short index)
Deprecated. - Misleading name - use setFirstVisibleTab()

deprecated May 2008

getFirstVisibleTab

public int getFirstVisibleTab()
sets the first tab that is displayed in the list of tabs in excel.

Specified by:
getFirstVisibleTab in interface Workbook
Returns:
the first tab that to display in the list of tabs (0-based).

getDisplayedTab

public short getDisplayedTab()
Deprecated. - Misleading name - use getFirstVisibleTab()

deprecated May 2008

setSheetName

public void setSheetName(int sheetIx,
                         java.lang.String name)
Set the sheet name.

Specified by:
setSheetName in interface Workbook
Parameters:
sheetIx - number (0 based)
Throws:
java.lang.IllegalArgumentException - if the name is null or invalid or workbook already contains a sheet with this name
See Also:
createSheet(String), WorkbookUtil.createSafeSheetName(String nameProposal)

getSheetName

public java.lang.String getSheetName(int sheetIndex)
Description copied from interface: Workbook
Get the sheet name

Specified by:
getSheetName in interface Workbook
Parameters:
sheetIndex - sheet number (0 based)
Returns:
Sheet name for the specified index

isHidden

public boolean isHidden()
Specified by:
isHidden in interface Workbook
Returns:
false if this workbook is not visible in the GUI

setHidden

public void setHidden(boolean hiddenFlag)
Specified by:
setHidden in interface Workbook
Parameters:
hiddenFlag - pass false to make the workbook visible in the GUI

isSheetHidden

public boolean isSheetHidden(int sheetIx)
Description copied from interface: Workbook
Check whether a sheet is hidden.

Note that a sheet could instead be set to be very hidden, which is different (Workbook.isSheetVeryHidden(int))

Specified by:
isSheetHidden in interface Workbook
Parameters:
sheetIx - Number
Returns:
true if sheet is hidden

isSheetVeryHidden

public boolean isSheetVeryHidden(int sheetIx)
Description copied from interface: Workbook
Check whether a sheet is very hidden.

This is different from the normal hidden status (Workbook.isSheetHidden(int))

Specified by:
isSheetVeryHidden in interface Workbook
Parameters:
sheetIx - sheet index to check
Returns:
true if sheet is very hidden

setSheetHidden

public void setSheetHidden(int sheetIx,
                           boolean hidden)
Description copied from interface: Workbook
Hide or unhide a sheet

Specified by:
setSheetHidden in interface Workbook
Parameters:
sheetIx - the sheet index (0-based)
hidden - True to mark the sheet as hidden, false otherwise

setSheetHidden

public void setSheetHidden(int sheetIx,
                           int hidden)
Description copied from interface: Workbook
Hide or unhide a sheet.
  • 0 - visible.
  • 1 - hidden.
  • 2 - very hidden.

Specified by:
setSheetHidden in interface Workbook
Parameters:
sheetIx - the sheet index (0-based)
hidden - one of the following Workbook constants: Workbook.SHEET_STATE_VISIBLE, Workbook.SHEET_STATE_HIDDEN, or Workbook.SHEET_STATE_VERY_HIDDEN.

getSheetIndex

public int getSheetIndex(java.lang.String name)
Returns the index of the sheet by his name

Specified by:
getSheetIndex in interface Workbook
Parameters:
name - the sheet name
Returns:
index of the sheet (0 based)

getSheetIndex

public int getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Specified by:
getSheetIndex in interface Workbook
Parameters:
sheet - the sheet to look up
Returns:
index of the sheet (0 based). -1 if not found

getExternalSheetIndex

public int getExternalSheetIndex(int internalSheetIndex)
Deprecated. for POI internal use only (formula parsing). This method is likely to be removed in future versions of POI.

Returns the external sheet index of the sheet with the given internal index, creating one if needed. Used by some of the more obscure formula and named range things.

findSheetNameFromExternSheet

public java.lang.String findSheetNameFromExternSheet(int externSheetIndex)
Deprecated. for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.

resolveNameXText

public java.lang.String resolveNameXText(int refIndex,
                                         int definedNameIndex)
Deprecated. for POI internal use only (formula rendering). This method is likely to be removed in future versions of POI.

Parameters:
refIndex - Index to REF entry in EXTERNSHEET record in the Link Table
definedNameIndex - zero-based to DEFINEDNAME or EXTERNALNAME record
Returns:
the string representation of the defined or external name

createSheet

public HSSFSheet createSheet()
create an HSSFSheet for this HSSFWorkbook, adds it to the sheets and returns the high level representation. Use this to create new sheets.

Specified by:
createSheet in interface Workbook
Returns:
HSSFSheet representing the new sheet.

cloneSheet

public HSSFSheet cloneSheet(int sheetIndex)
create an HSSFSheet from an existing sheet in the HSSFWorkbook.

Specified by:
cloneSheet in interface Workbook
Returns:
HSSFSheet representing the cloned sheet.

createSheet

public HSSFSheet createSheet(java.lang.String sheetname)
Create a new sheet for this Workbook and return the high level representation. Use this to create new sheets.

Note that Excel allows sheet names up to 31 chars in length but other applications (such as OpenOffice) allow more. Some versions of Excel crash with names longer than 31 chars, others - truncate such names to 31 character.

POI's SpreadsheetAPI silently truncates the input argument to 31 characters. Example:

     Sheet sheet = workbook.createSheet("My very long sheet name which is longer than 31 chars"); // will be truncated
     assert 31 == sheet.getSheetName().length();
     assert "My very long sheet name which i" == sheet.getSheetName();

Except the 31-character constraint, Excel applies some other rules:

Sheet name MUST be unique in the workbook and MUST NOT contain the any of the following characters:

  • 0x0000
  • 0x0003
  • colon (:)
  • backslash (\)
  • asterisk (*)
  • question mark (?)
  • forward slash (/)
  • opening square bracket ([)
  • closing square bracket (])
The string MUST NOT begin or end with the single quote (') character.

Specified by:
createSheet in interface Workbook
Parameters:
sheetname - sheetname to set for the sheet.
Returns:
Sheet representing the new sheet.
Throws:
java.lang.IllegalArgumentException - if the name is null or invalid or workbook already contains a sheet with this name
See Also:
WorkbookUtil.createSafeSheetName(String nameProposal)

getNumberOfSheets

public int getNumberOfSheets()
get the number of spreadsheets in the workbook (this will be three after serialization)

Specified by:
getNumberOfSheets in interface Workbook
Returns:
number of sheets

getSheetIndexFromExternSheetIndex

public int getSheetIndexFromExternSheetIndex(int externSheetNumber)

getSheetAt

public HSSFSheet getSheetAt(int index)
Get the HSSFSheet object at the given index.

Specified by:
getSheetAt in interface Workbook
Parameters:
index - of the sheet number (0-based physical & logical)
Returns:
HSSFSheet at the provided index

getSheet

public HSSFSheet getSheet(java.lang.String name)
Get sheet with the given name (case insensitive match)

Specified by:
getSheet in interface Workbook
Parameters:
name - of the sheet
Returns:
HSSFSheet with the name provided or null if it does not exist

removeSheetAt

public void removeSheetAt(int index)
Removes sheet at the given index.

Care must be taken if the removed sheet is the currently active or only selected sheet in the workbook. There are a few situations when Excel must have a selection and/or active sheet. (For example when printing - see Bug 40414).
This method makes sure that if the removed sheet was active, another sheet will become active in its place. Furthermore, if the removed sheet was the only selected sheet, another sheet will become selected. The newly active/selected sheet will have the same index, or one less if the removed sheet was the last in the workbook.

Specified by:
removeSheetAt in interface Workbook
Parameters:
index - of the sheet (0-based)

setBackupFlag

public void setBackupFlag(boolean backupValue)
determine whether the Excel GUI will backup the workbook when saving.

Parameters:
backupValue - true to indicate a backup will be performed.

getBackupFlag

public boolean getBackupFlag()
determine whether the Excel GUI will backup the workbook when saving.

Returns:
the current setting for backups.

setRepeatingRowsAndColumns

public void setRepeatingRowsAndColumns(int sheetIndex,
                                       int startColumn,
                                       int endColumn,
                                       int startRow,
                                       int endRow)
Sets the repeating rows and columns for a sheet (as found in 2003:File->PageSetup->Sheet, 2007:Page Layout->Print Titles). This is function is included in the workbook because it creates/modifies name records which are stored at the workbook level.

To set just repeating columns:

  workbook.setRepeatingRowsAndColumns(0,0,1,-1-1);
To set just repeating rows:
  workbook.setRepeatingRowsAndColumns(0,-1,-1,0,4);
To remove all repeating rows and columns for a sheet.
  workbook.setRepeatingRowsAndColumns(0,-1,-1,-1,-1);

Specified by:
setRepeatingRowsAndColumns in interface Workbook
Parameters:
sheetIndex - 0 based index to sheet.
startColumn - 0 based start of repeating columns.
endColumn - 0 based end of repeating columns.
startRow - 0 based start of repeating rows.
endRow - 0 based end of repeating rows.

createFont

public HSSFFont createFont()
create a new Font and add it to the workbook's font table

Specified by:
createFont in interface Workbook
Returns:
new font object

findFont

public HSSFFont findFont(short boldWeight,
                         short color,
                         short fontHeight,
                         java.lang.String name,
                         boolean italic,
                         boolean strikeout,
                         short typeOffset,
                         byte underline)
Finds a font that matches the one with the supplied attributes

Specified by:
findFont in interface Workbook
Returns:
the font with the matched attributes or null

getNumberOfFonts

public short getNumberOfFonts()
get the number of fonts in the font table

Specified by:
getNumberOfFonts in interface Workbook
Returns:
number of fonts

getFontAt

public HSSFFont getFontAt(short idx)
Get the font at the given index number

Specified by:
getFontAt in interface Workbook
Parameters:
idx - index number
Returns:
HSSFFont at the index

resetFontCache

protected void resetFontCache()
Reset the fonts cache, causing all new calls to getFontAt() to create new objects. Should only be called after deleting fonts, and that's not something you should normally do

createCellStyle

public HSSFCellStyle createCellStyle()
Create a new Cell style and add it to the workbook's style table. You can define up to 4000 unique styles in a .xls workbook.

Specified by:
createCellStyle in interface Workbook
Returns:
the new Cell Style object
Throws:
java.lang.IllegalStateException - if the maximum number of cell styles exceeded the limit

getNumCellStyles

public short getNumCellStyles()
get the number of styles the workbook contains

Specified by:
getNumCellStyles in interface Workbook
Returns:
count of cell styles

getCellStyleAt

public HSSFCellStyle getCellStyleAt(short idx)
get the cell style object at the given index

Specified by:
getCellStyleAt in interface Workbook
Parameters:
idx - index within the set of styles
Returns:
HSSFCellStyle object at the index

write

public void write(java.io.OutputStream stream)
           throws java.io.IOException
Method write - write out this workbook to an Outputstream. Constructs a new POI POIFSFileSystem, passes in the workbook binary representation and writes it out.

Specified by:
write in interface Workbook
Specified by:
write in class POIDocument
Parameters:
stream - - the java OutputStream you wish to write the XLS to
Throws:
java.io.IOException - if anything can't be written.
See Also:
POIFSFileSystem

getBytes

public byte[] getBytes()
Method getBytes - get the bytes of just the HSSF portions of the XLS file. Use this to construct a POI POIFSFileSystem yourself.

Returns:
byte[] array containing the binary representation of this workbook and all contained sheets, rows, cells, etc.

addSSTString

public int addSSTString(java.lang.String string)
Deprecated. Do not call this method from your applications. Use the methods available in the HSSFRow to add string HSSFCells

getSSTString

public java.lang.String getSSTString(int index)
Deprecated. Do not call this method from your applications. Use the methods available in the HSSFRow to get string HSSFCells

getNumberOfNames

public int getNumberOfNames()
Specified by:
getNumberOfNames in interface Workbook
Returns:
the total number of defined names in this workbook

getName

public HSSFName getName(java.lang.String name)
Specified by:
getName in interface Workbook
Parameters:
name - the name of the defined name
Returns:
the defined name with the specified name. null if not found.

getNameAt

public HSSFName getNameAt(int nameIndex)
Specified by:
getNameAt in interface Workbook
Parameters:
nameIndex - position of the named range (0-based)
Returns:
the defined name at the specified index

getNameRecord

public NameRecord getNameRecord(int nameIndex)

getNameName

public java.lang.String getNameName(int index)
gets the named range name

Parameters:
index - the named range index (0 based)
Returns:
named range name

setPrintArea

public void setPrintArea(int sheetIndex,
                         java.lang.String reference)
Sets the printarea for the sheet provided

i.e. Reference = $A$1:$B$2

Specified by:
setPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
reference - Valid name Reference for the Print Area

setPrintArea

public void setPrintArea(int sheetIndex,
                         int startColumn,
                         int endColumn,
                         int startRow,
                         int endRow)
For the Convenience of Java Programmers maintaining pointers.

Specified by:
setPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 = First Sheet)
startColumn - Column to begin printarea
endColumn - Column to end the printarea
startRow - Row to begin the printarea
endRow - Row to end the printarea
See Also:
setPrintArea(int, String)

getPrintArea

public java.lang.String getPrintArea(int sheetIndex)
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.

Specified by:
getPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
Returns:
String Null if no print area has been defined

removePrintArea

public void removePrintArea(int sheetIndex)
Delete the printarea for the sheet specified

Specified by:
removePrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 = First Sheet)

createName

public HSSFName createName()
creates a new named range and add it to the model

Specified by:
createName in interface Workbook
Returns:
named range high level

getNameIndex

public int getNameIndex(java.lang.String name)
Description copied from interface: Workbook
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.

Specified by:
getNameIndex in interface Workbook
Parameters:
name - the name of the defined name
Returns:
zero based index of the defined name. -1 if not found.

removeName

public void removeName(int index)
Description copied from interface: Workbook
Remove the defined name at the specified index

Specified by:
removeName in interface Workbook
Parameters:
index - named range index (0 based)

createDataFormat

public HSSFDataFormat createDataFormat()
Returns the instance of HSSFDataFormat for this workbook.

Specified by:
createDataFormat in interface Workbook
Returns:
the HSSFDataFormat object
See Also:
FormatRecord, Record

removeName

public void removeName(java.lang.String name)
Description copied from interface: Workbook
Remove a defined name by name

Specified by:
removeName in interface Workbook
Parameters:
name - the name of the defined name

getCustomPalette

public HSSFPalette getCustomPalette()

insertChartRecord

public void insertChartRecord()
Test only. Do not use

dumpDrawingGroupRecords

public void dumpDrawingGroupRecords(boolean fat)
Spits out a list of all the drawing records in the workbook.

addPicture

public int addPicture(byte[] pictureData,
                      int format)
Adds a picture to the workbook.

Specified by:
addPicture in interface Workbook
Parameters:
pictureData - The bytes of the picture
format - The format of the picture. One of PICTURE_TYPE_*
Returns:
the index to this picture (1 based).
See Also:
Workbook.PICTURE_TYPE_EMF, Workbook.PICTURE_TYPE_WMF, Workbook.PICTURE_TYPE_PICT, Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PNG, Workbook.PICTURE_TYPE_DIB

getAllPictures

public java.util.List<HSSFPictureData> getAllPictures()
Gets all pictures from the Workbook.

Specified by:
getAllPictures in interface Workbook
Returns:
the list of pictures (a list of HSSFPictureData objects.)

isWriteProtected

public boolean isWriteProtected()
Is the workbook protected with a password (not encrypted)?

writeProtectWorkbook

public void writeProtectWorkbook(java.lang.String password,
                                 java.lang.String username)
protect a workbook with a password (not encypted, just sets writeprotect flags and the password.

Parameters:
password - to set

unwriteProtectWorkbook

public void unwriteProtectWorkbook()
removes the write protect flag

getAllEmbeddedObjects

public java.util.List<HSSFObjectData> getAllEmbeddedObjects()
Gets all embedded OLE2 objects from the Workbook.

Returns:
the list of embedded objects (a list of HSSFObjectData objects.)

getCreationHelper

public HSSFCreationHelper getCreationHelper()
Description copied from interface: Workbook
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.

Specified by:
getCreationHelper in interface Workbook

addToolPack

public void addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.

Specified by:
addToolPack in interface Workbook
Parameters:
toopack - the toolpack to register

setForceFormulaRecalculation

public void setForceFormulaRecalculation(boolean value)
Whether the application shall perform a full recalculation when the workbook is opened.

Typically you want to force formula recalculation when you modify cell formulas or values of a workbook previously created by Excel. When set to true, this flag will tell Excel that it needs to recalculate all formulas in the workbook the next time the file is opened.

Note, that recalculation updates cached formula results and, thus, modifies the workbook. Depending on the version, Excel may prompt you with "Do you want to save the changes in filename?" on close.

Specified by:
setForceFormulaRecalculation in interface Workbook
Parameters:
value - true if the application will perform a full recalculation of workbook values when the workbook is opened
Since:
3.8

getForceFormulaRecalculation

public boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.

Specified by:
getForceFormulaRecalculation in interface Workbook
Since:
3.8

changeExternalReference

public boolean changeExternalReference(java.lang.String oldUrl,
                                       java.lang.String newUrl)
Changes an external referenced file to another file. A formular in Excel which refers a cell in another file is saved in two parts: The referenced file is stored in an reference table. the row/cell information is saved separate. This method invokation will only change the reference in the lookup-table itself.

Parameters:
oldUrl - The old URL to search for and which is to be replaced
newUrl - The URL replacement
Returns:
true if the oldUrl was found and replaced with newUrl. Otherwise false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.usermodel
Interfaces
HSSFShapeContainer
Classes
DummyGraphics2d
DVConstraint
DVConstraint.FormulaPair
EscherGraphics
EscherGraphics2d
FontDetails
HeaderFooter
HSSFAnchor
HSSFAutoFilter
HSSFBorderFormatting
HSSFCell
HSSFCellStyle
HSSFChart
HSSFChildAnchor
HSSFClientAnchor
HSSFComment
HSSFConditionalFormatting
HSSFConditionalFormattingRule
HSSFCreationHelper
HSSFDataFormat
HSSFDataFormatter
HSSFDataValidation
HSSFDataValidationHelper
HSSFDateUtil
HSSFErrorConstants
HSSFEvaluationWorkbook
HSSFFont
HSSFFontFormatting
HSSFFooter
HSSFFormulaEvaluator
HSSFHeader
HSSFHyperlink
HSSFName
HSSFObjectData
HSSFOptimiser
HSSFPalette
HSSFPatriarch
HSSFPatternFormatting
HSSFPicture
HSSFPictureData
HSSFPolygon
HSSFPrintSetup
HSSFRichTextString
HSSFRow
HSSFShape
HSSFShapeGroup
HSSFSheet
HSSFSheetConditionalFormatting
HSSFSimpleShape
HSSFTextbox
HSSFWorkbook
Enums
HSSFChart.HSSFChartType


org.apache.poi.hssf.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.usermodel

usermodel package maps HSSF low level strutures to familiar workbook/sheet model

See:
Description

Interface Summary
HSSFShapeContainer An interface that indicates whether a class can contain children.

Class Summary
DummyGraphics2d |
DVConstraint |
DVConstraint.FormulaPair |
EscherGraphics | Translates Graphics calls into escher calls.
EscherGraphics2d | Translates Graphics2d calls into escher calls.
FontDetails | Stores width and height details about a font.
HeaderFooter | Common class for HSSFHeader and HSSFFooter.
HSSFAnchor | An anchor is what specifics the position of a shape within a client object or within another containing shape.
HSSFAutoFilter | Represents autofiltering for the specified worksheet.
HSSFBorderFormatting | High level representation for Border Formatting component of Conditional Formatting settings
HSSFCell | High level representation of a cell in a row of a spreadsheet.
HSSFCellStyle | High level representation of the style of a cell in a sheet of a workbook.
HSSFChart | Has methods for construction of a chart object.
HSSFChildAnchor |
HSSFClientAnchor | A client anchor is attached to an excel worksheet.
HSSFComment | Represents a cell comment - a sticky note associated with a cell.
HSSFConditionalFormatting | HSSFConditionalFormatting class encapsulates all settings of Conditional Formatting.
HSSFConditionalFormattingRule | High level representation of Conditional Formatting Rule.
HSSFCreationHelper |
HSSFDataFormat | Identifies both built-in and user defined formats within a workbook. See BuiltinFormats for a list of supported built-in formats. International Formats Since version 2003 Excel has supported international formats.
HSSFDataFormatter | HSSFDataFormatter contains methods for formatting the value stored in an HSSFCell.
HSSFDataValidation | Utility class for creating data validation cells
HSSFDataValidationHelper |
HSSFDateUtil | Contains methods for dealing with Excel dates.
HSSFErrorConstants | Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)
HSSFEvaluationWorkbook | Internal POI use only
HSSFFont | Represents a Font used in a workbook.
HSSFFontFormatting | High level representation for Font Formatting component of Conditional Formatting settings
HSSFFooter | Class to read and manipulate the footer.
HSSFFormulaEvaluator | Evaluates formula cells. For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.
HSSFHeader | Class to read and manipulate the header.
HSSFHyperlink | Represents an Excel hyperlink.
HSSFName | High Level Representation of a 'defined name' which could be a 'built-in' name, 'named range' or name of a user defined function.
HSSFObjectData | Represents binary object (i.e.
HSSFOptimiser | Excel can get cranky if you give it files containing too many (especially duplicate) objects, and this class can help to avoid those.
HSSFPalette | Represents a workbook color palette.
HSSFPatriarch | The patriarch is the toplevel container for shapes in a sheet.
HSSFPatternFormatting | High level representation for Conditional Formatting settings
HSSFPicture | Represents a escher picture.
HSSFPictureData | Represents binary data stored in the file.
HSSFPolygon |
HSSFPrintSetup | Used to modify the print setup.
HSSFRichTextString | Rich text unicode string.
HSSFRow | High level representation of a row of a spreadsheet.
HSSFShape | An abstract shape.
HSSFShapeGroup | A shape group may contain other shapes.
HSSFSheet | High level representation of a worksheet.
HSSFSheetConditionalFormatting | The 'Conditional Formatting' facet of HSSFSheet
HSSFSimpleShape | Represents a simple shape such as a line, rectangle or oval.
HSSFTextbox | A textbox is a shape that may hold a rich text string.
HSSFWorkbook | High level representation of a workbook.

Enum Summary
HSSFChart.HSSFChartType

Package org.apache.poi.hssf.usermodel Description

usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.hssf.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.usermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.usermodel.DataFormatter
      • org.apache.poi.hssf.usermodel.HSSFDataFormatter
    • org.apache.poi.ss.usermodel.DateUtil
      • org.apache.poi.hssf.usermodel.HSSFDateUtil
    • org.apache.poi.hssf.usermodel.DVConstraint (implements org.apache.poi.ss.usermodel.DataValidationConstraint)
    • org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair
    • org.apache.poi.ss.usermodel.ErrorConstants
      • org.apache.poi.hssf.usermodel.HSSFErrorConstants
    • org.apache.poi.hssf.usermodel.FontDetails
    • java.awt.Graphics
      • org.apache.poi.hssf.usermodel.EscherGraphics
      • java.awt.Graphics2D
        • org.apache.poi.hssf.usermodel.DummyGraphics2d
        • org.apache.poi.hssf.usermodel.EscherGraphics2d
    • org.apache.poi.hssf.usermodel.HeaderFooter (implements org.apache.poi.ss.usermodel.HeaderFooter)
      • org.apache.poi.hssf.usermodel.HSSFFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.hssf.usermodel.HSSFHeader (implements org.apache.poi.ss.usermodel.Header)
    • org.apache.poi.hssf.usermodel.HSSFAnchor
      • org.apache.poi.hssf.usermodel.HSSFChildAnchor
      • org.apache.poi.hssf.usermodel.HSSFClientAnchor (implements org.apache.poi.ss.usermodel.ClientAnchor)
    • org.apache.poi.hssf.usermodel.HSSFAutoFilter (implements org.apache.poi.ss.usermodel.AutoFilter)
    • org.apache.poi.hssf.usermodel.HSSFBorderFormatting (implements org.apache.poi.ss.usermodel.BorderFormatting)
    • org.apache.poi.hssf.usermodel.HSSFCell (implements org.apache.poi.ss.usermodel.Cell)
    • org.apache.poi.hssf.usermodel.HSSFCellStyle (implements org.apache.poi.ss.usermodel.CellStyle)
    • org.apache.poi.hssf.usermodel.HSSFChart
    • org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries
    • org.apache.poi.hssf.usermodel.HSSFConditionalFormatting (implements org.apache.poi.ss.usermodel.ConditionalFormatting)
    • org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule (implements org.apache.poi.ss.usermodel.ConditionalFormattingRule)
    • org.apache.poi.hssf.usermodel.HSSFCreationHelper (implements org.apache.poi.ss.usermodel.CreationHelper)
    • org.apache.poi.hssf.usermodel.HSSFDataFormat (implements org.apache.poi.ss.usermodel.DataFormat)
    • org.apache.poi.hssf.usermodel.HSSFDataValidation (implements org.apache.poi.ss.usermodel.DataValidation)
    • org.apache.poi.hssf.usermodel.HSSFDataValidationHelper (implements org.apache.poi.ss.usermodel.DataValidationHelper)
    • org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook (implements org.apache.poi.ss.formula.EvaluationWorkbook, org.apache.poi.ss.formula.FormulaParsingWorkbook, org.apache.poi.ss.formula.FormulaRenderingWorkbook)
    • org.apache.poi.hssf.usermodel.HSSFFont (implements org.apache.poi.ss.usermodel.Font)
    • org.apache.poi.hssf.usermodel.HSSFFontFormatting (implements org.apache.poi.ss.usermodel.FontFormatting)
    • org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator (implements org.apache.poi.ss.usermodel.FormulaEvaluator)
    • org.apache.poi.hssf.usermodel.HSSFHyperlink (implements org.apache.poi.ss.usermodel.Hyperlink)
    • org.apache.poi.hssf.usermodel.HSSFName (implements org.apache.poi.ss.usermodel.Name)
    • org.apache.poi.hssf.usermodel.HSSFObjectData
    • org.apache.poi.hssf.usermodel.HSSFOptimiser
    • org.apache.poi.hssf.usermodel.HSSFPalette
    • org.apache.poi.hssf.usermodel.HSSFPatriarch (implements org.apache.poi.ss.usermodel.Drawing, org.apache.poi.hssf.usermodel.HSSFShapeContainer)
    • org.apache.poi.hssf.usermodel.HSSFPatternFormatting (implements org.apache.poi.ss.usermodel.PatternFormatting)
    • org.apache.poi.hssf.usermodel.HSSFPictureData (implements org.apache.poi.ss.usermodel.PictureData)
    • org.apache.poi.hssf.usermodel.HSSFPrintSetup (implements org.apache.poi.ss.usermodel.PrintSetup)
    • org.apache.poi.hssf.usermodel.HSSFRichTextString (implements java.lang.Comparable<T>, org.apache.poi.ss.usermodel.RichTextString)
    • org.apache.poi.hssf.usermodel.HSSFRow (implements org.apache.poi.ss.usermodel.Row)
    • org.apache.poi.hssf.usermodel.HSSFShape
      • org.apache.poi.hssf.usermodel.HSSFPolygon
      • org.apache.poi.hssf.usermodel.HSSFShapeGroup (implements org.apache.poi.hssf.usermodel.HSSFShapeContainer)
      • org.apache.poi.hssf.usermodel.HSSFSimpleShape
        • org.apache.poi.hssf.usermodel.HSSFPicture (implements org.apache.poi.ss.usermodel.Picture)
        • org.apache.poi.hssf.usermodel.HSSFTextbox
          • org.apache.poi.hssf.usermodel.HSSFComment (implements org.apache.poi.ss.usermodel.Comment)
    • org.apache.poi.hssf.usermodel.HSSFSheet (implements org.apache.poi.ss.usermodel.Sheet)
    • org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting (implements org.apache.poi.ss.usermodel.SheetConditionalFormatting)
    • org.apache.poi.POIDocument
      • org.apache.poi.hssf.usermodel.HSSFWorkbook (implements org.apache.poi.ss.usermodel.Workbook)

Interface Hierarchy

  • org.apache.poi.hssf.usermodel.HSSFShapeContainer

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType


Uses of Package org.apache.poi.hssf.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.usermodel

Packages that use org.apache.poi.hssf.usermodel
org.apache.poi.hssf.converter |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Classes in org.apache.poi.hssf.usermodel used by org.apache.poi.hssf.converter
HSSFCell
High level representation of a cell in a row of a spreadsheet.
HSSFCellStyle
High level representation of the style of a cell in a sheet of a workbook.
HSSFDataFormatter
HSSFDataFormatter contains methods for formatting the value stored in an HSSFCell.
HSSFFont
Represents a Font used in a workbook.
HSSFRow
High level representation of a row of a spreadsheet.
HSSFSheet
High level representation of a worksheet.
HSSFWorkbook
High level representation of a workbook.

Classes in org.apache.poi.hssf.usermodel used by org.apache.poi.hssf.eventusermodel
HSSFWorkbook
High level representation of a workbook.

Classes in org.apache.poi.hssf.usermodel used by org.apache.poi.hssf.extractor
HSSFWorkbook
High level representation of a workbook.

Classes in org.apache.poi.hssf.usermodel used by org.apache.poi.hssf.model
HSSFAnchor
An anchor is what specifics the position of a shape within a client object or within another containing shape.
HSSFComment
Represents a cell comment - a sticky note associated with a cell.
HSSFShape
An abstract shape.
HSSFWorkbook
High level representation of a workbook.

Classes in org.apache.poi.hssf.usermodel used by org.apache.poi.hssf.record
HSSFPatriarch
The patriarch is the toplevel container for shapes in a sheet.
HSSFRichTextString
Rich text unicode string.
HSSFSheet
High level representation of a worksheet.

Classes in org.apache.poi.hssf.usermodel used by org.apache.poi.hssf.usermodel
DVConstraint
EscherGraphics
Translates Graphics calls into escher calls.
FontDetails
Stores width and height details about a font.
HeaderFooter
Common class for HSSFHeader and HSSFFooter.
HSSFAnchor
An anchor is what specifics the position of a shape within a client object or within another containing shape.
HSSFAutoFilter
Represents autofiltering for the specified worksheet.
HSSFBorderFormatting
High level representation for Border Formatting component of Conditional Formatting settings
HSSFCell
High level representation of a cell in a row of a spreadsheet.
HSSFCellStyle
High level representation of the style of a cell in a sheet of a workbook.
HSSFChart
Has methods for construction of a chart object.
HSSFChart.HSSFChartType
HSSFChart.HSSFSeries
A series in a chart
HSSFChildAnchor
HSSFClientAnchor
A client anchor is attached to an excel worksheet.
HSSFComment
Represents a cell comment - a sticky note associated with a cell.
HSSFConditionalFormatting
HSSFConditionalFormatting class encapsulates all settings of Conditional Formatting.
HSSFConditionalFormattingRule
High level representation of Conditional Formatting Rule.
HSSFCreationHelper
HSSFDataFormat
Identifies both built-in and user defined formats within a workbook.

See BuiltinFormats for a list of supported built-in formats.

International Formats
Since version 2003 Excel has supported international formats.

HSSFEvaluationWorkbook
Internal POI use only
HSSFFont
Represents a Font used in a workbook.
HSSFFontFormatting
High level representation for Font Formatting component of Conditional Formatting settings
HSSFFooter
Class to read and manipulate the footer.
HSSFFormulaEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

HSSFHeader
Class to read and manipulate the header.
HSSFHyperlink
Represents an Excel hyperlink.
HSSFName
High Level Representation of a 'defined name' which could be a 'built-in' name, 'named range' or name of a user defined function.
HSSFObjectData
Represents binary object (i.e.
HSSFPalette
Represents a workbook color palette.
HSSFPatriarch
The patriarch is the toplevel container for shapes in a sheet.
HSSFPatternFormatting
High level representation for Conditional Formatting settings
HSSFPicture
Represents a escher picture.
HSSFPictureData
Represents binary data stored in the file.
HSSFPolygon
HSSFPrintSetup
Used to modify the print setup.
HSSFRichTextString
Rich text unicode string.
HSSFRow
High level representation of a row of a spreadsheet.
HSSFShape
An abstract shape.
HSSFShapeContainer
An interface that indicates whether a class can contain children.
HSSFShapeGroup
A shape group may contain other shapes.
HSSFSheet
High level representation of a worksheet.
HSSFSheetConditionalFormatting
The 'Conditional Formatting' facet of HSSFSheet
HSSFSimpleShape
Represents a simple shape such as a line, rectangle or oval.
HSSFTextbox
A textbox is a shape that may hold a rich text string.
HSSFWorkbook
High level representation of a workbook.

Classes in org.apache.poi.hssf.usermodel used by org.apache.poi.hssf.util
HSSFCell
High level representation of a cell in a row of a spreadsheet.
HSSFCellStyle
High level representation of the style of a cell in a sheet of a workbook.
HSSFFont
Represents a Font used in a workbook.
HSSFRow
High level representation of a row of a spreadsheet.
HSSFSheet
High level representation of a worksheet.
HSSFWorkbook
High level representation of a workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.DummyGraphics2d

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.DummyGraphics2d

No usage of org.apache.poi.hssf.usermodel.DummyGraphics2d

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair

No usage of org.apache.poi.hssf.usermodel.DVConstraint.FormulaPair

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.DVConstraint

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.DVConstraint

Packages that use DVConstraint
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of DVConstraint in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return DVConstraint
static DVConstraint | DVConstraint.createCustomFormulaConstraint(java.lang.String formula)
static DVConstraint | DVConstraint.createDateConstraint(int comparisonOperator, java.lang.String expr1, java.lang.String expr2, java.lang.String dateFormat) Creates a date based data validation constraint.
static DVConstraint | DVConstraint.createExplicitListConstraint(java.lang.String[] explicitListValues)
static DVConstraint | DVConstraint.createFormulaListConstraint(java.lang.String listFormula)
static DVConstraint | DVConstraint.createNumericConstraint(int validationType, int comparisonOperator, java.lang.String expr1, java.lang.String expr2) Creates a number based data validation constraint.
static DVConstraint | DVConstraint.createTimeConstraint(int comparisonOperator, java.lang.String expr1, java.lang.String expr2) Creates a time based data validation constraint.
DVConstraint | HSSFDataValidation.getConstraint()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.EscherGraphics

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.EscherGraphics

Packages that use EscherGraphics
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of EscherGraphics in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type EscherGraphics
EscherGraphics2d(EscherGraphics escherGraphics)
Constructs one escher graphics object from an escher graphics object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.EscherGraphics2d

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.EscherGraphics2d

No usage of org.apache.poi.hssf.usermodel.EscherGraphics2d

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.FontDetails

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.FontDetails

Packages that use FontDetails
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of FontDetails in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return FontDetails
static FontDetails FontDetails.create(java.lang.String fontName, java.util.Properties fontMetricsProps)
Create an instance of FontDetails by loading them from the provided property object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HeaderFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HeaderFooter

Packages that use HeaderFooter
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HeaderFooter in org.apache.poi.hssf.usermodel

Subclasses of HeaderFooter in org.apache.poi.hssf.usermodel
class | HSSFFooter Class to read and manipulate the footer.
class | HSSFHeader Class to read and manipulate the header.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFAnchor

Packages that use HSSFAnchor
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFAnchor in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type HSSFAnchor
static EscherRecord | ConvertAnchor.createAnchor(HSSFAnchor userAnchor)
protected EscherRecord | AbstractShape.createAnchor(HSSFAnchor userAnchor) Creates an escher anchor record from a HSSFAnchor.

Uses of HSSFAnchor in org.apache.poi.hssf.usermodel

Subclasses of HSSFAnchor in org.apache.poi.hssf.usermodel
class | HSSFChildAnchor
class | HSSFClientAnchor A client anchor is attached to an excel worksheet.

Methods in org.apache.poi.hssf.usermodel that return HSSFAnchor
 HSSFAnchor HSSFShape.getAnchor()

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFAnchor
HSSFComment | HSSFPatriarch.createComment(HSSFAnchor anchor) Constructs a cell comment.
void | HSSFShape.setAnchor(HSSFAnchor anchor) Sets a particular anchor.

Constructors in org.apache.poi.hssf.usermodel with parameters of type HSSFAnchor
HSSFComment(HSSFShape parent, HSSFAnchor anchor)
Construct a new comment with the given parent and anchor.
HSSFPicture(HSSFShape parent, HSSFAnchor anchor)
Constructs a picture object.
HSSFShapeGroup(HSSFShape parent, HSSFAnchor anchor)
HSSFSimpleShape(HSSFShape parent, HSSFAnchor anchor)
HSSFTextbox(HSSFShape parent, HSSFAnchor anchor)
Construct a new textbox with the given parent and anchor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFAutoFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFAutoFilter

Packages that use HSSFAutoFilter
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFAutoFilter in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFAutoFilter
 HSSFAutoFilter HSSFSheet.setAutoFilter(CellRangeAddress range)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFBorderFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFBorderFormatting

Packages that use HSSFBorderFormatting
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFBorderFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFBorderFormatting
HSSFBorderFormatting | HSSFConditionalFormattingRule.createBorderFormatting() create a new border formatting structure if it does not exist, otherwise just return existing object.
HSSFBorderFormatting | HSSFConditionalFormattingRule.getBorderFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFCell

Packages that use HSSFCell
org.apache.poi.hssf.converter |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of HSSFCell in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type HSSFCell
protected boolean | AbstractExcelConverter.isTextEmpty(HSSFCell cell)
protected boolean | ExcelToHtmlConverter.processCell(HSSFCell cell, org.w3c.dom.Element tableCellElement, int normalWidthPx, int maxSpannedWidthPx, float normalHeightPt)
protected boolean | ExcelToFoConverter.processCell(HSSFWorkbook workbook, HSSFCell cell, org.w3c.dom.Element tableCellElement, int normalWidthPx, int maxSpannedWidthPx, float normalHeightPt)

Uses of HSSFCell in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFCell
 HSSFCell HSSFRow.createCell(int column)
Use this to create new cells within the row and return it.
 HSSFCell HSSFRow.createCell(int columnIndex, int type)
Use this to create new cells within the row and return it.
 HSSFCell HSSFRow.createCell(short columnIndex)
Deprecated. (Aug 2008) use HSSFRow.createCell(int)
 HSSFCell HSSFRow.createCell(short columnIndex, int type)
Deprecated. (Aug 2008) use HSSFRow.createCell(int, int)
 HSSFCell HSSFFormulaEvaluator.evaluateInCell(Cell cell)
If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
 HSSFCell HSSFRow.getCell(int cellnum)
Get the hssfcell representing a given column (logical cell) 0-based.
 HSSFCell HSSFRow.getCell(int cellnum, Row.MissingCellPolicy policy)
Get the hssfcell representing a given column (logical cell) 0-based.
 HSSFCell HSSFRow.getCell(short cellnum)
Deprecated. (Aug 2008) use HSSFRow.getCell(int)

Methods in org.apache.poi.hssf.usermodel that return types with arguments of type HSSFCell
CellRange<HSSFCell> | HSSFSheet.removeArrayFormula(Cell cell)
CellRange<HSSFCell> | HSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range)

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFCell
void | HSSFRow.moveCell(HSSFCell cell, short newColumn) Moves the supplied cell to a new column, which must not already have a cell there!
void | HSSFFormulaEvaluator.notifyDeleteCell(HSSFCell cell) Should be called to tell the cell value cache that the specified cell has just been deleted.
void | HSSFFormulaEvaluator.notifyUpdateCell(HSSFCell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.

Uses of HSSFCell in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util that return HSSFCell
static HSSFCell | HSSFCellUtil.createCell(HSSFRow row, int column, java.lang.String value) Create a cell, and give it a value.
static HSSFCell | HSSFCellUtil.createCell(HSSFRow row, int column, java.lang.String value, HSSFCellStyle style) Creates a cell, gives it a value, and applies a style if provided
static HSSFCell | HSSFCellUtil.getCell(HSSFRow row, int columnIndex) Get a specific cell from a row.
static HSSFCell | HSSFCellUtil.translateUnicodeValues(HSSFCell cell) Looks for text in the cell that should be unicode, like α and provides the unicode version of it.

Methods in org.apache.poi.hssf.util with parameters of type HSSFCell
static void | HSSFCellUtil.setAlignment(HSSFCell cell, HSSFWorkbook workbook, short align) Take a cell, and align it.
static void | HSSFCellUtil.setCellStyleProperty(HSSFCell cell, HSSFWorkbook workbook, java.lang.String propertyName, java.lang.Object propertyValue) This method attempt to find an already existing HSSFCellStyle that matches what you want the style to be.
static void | HSSFCellUtil.setFont(HSSFCell cell, HSSFWorkbook workbook, HSSFFont font) Take a cell, and apply a font to it
static HSSFCell | HSSFCellUtil.translateUnicodeValues(HSSFCell cell) Looks for text in the cell that should be unicode, like α and provides the unicode version of it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFCellStyle

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFCellStyle

Packages that use HSSFCellStyle
org.apache.poi.hssf.converter |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of HSSFCellStyle in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type HSSFCellStyle
protected java.lang.String | ExcelToHtmlConverter.buildStyle(HSSFWorkbook workbook, HSSFCellStyle cellStyle)
protected java.lang.String | ExcelToHtmlConverter.getStyleClassName(HSSFWorkbook workbook, HSSFCellStyle cellStyle)
protected void | ExcelToFoConverter.processCellStyle(HSSFWorkbook workbook, HSSFCellStyle cellStyle, org.w3c.dom.Element cellTarget, org.w3c.dom.Element blockTarget)

Uses of HSSFCellStyle in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFCellStyle
HSSFCellStyle | HSSFWorkbook.createCellStyle() Create a new Cell style and add it to the workbook's style table.
HSSFCellStyle | HSSFCell.getCellStyle() get the style for the cell.
HSSFCellStyle | HSSFWorkbook.getCellStyleAt(short idx) get the cell style object at the given index
HSSFCellStyle | HSSFSheet.getColumnStyle(int column) Returns the HSSFCellStyle that applies to the given (0 based) column, or null if no style has been set for that column
HSSFCellStyle | HSSFCellStyle.getParentStyle() Return the parent style for this cell style.
HSSFCellStyle | HSSFRow.getRowStyle() Returns the whole-row cell styles.

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFCellStyle
void | HSSFCellStyle.cloneStyleFrom(HSSFCellStyle source)
void | HSSFCell.setCellStyle(HSSFCellStyle style)
void | HSSFRow.setRowStyle(HSSFCellStyle style) Applies a whole-row cell styling to the row.

Uses of HSSFCellStyle in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util with parameters of type HSSFCellStyle
static HSSFCell HSSFCellUtil.createCell(HSSFRow row, int column, java.lang.String value, HSSFCellStyle style)
Creates a cell, gives it a value, and applies a style if provided

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFChart.HSSFChartType

Packages that use HSSFChart.HSSFChartType
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFChart.HSSFChartType in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFChart.HSSFChartType
HSSFChart.HSSFChartType | HSSFChart.getType()
static HSSFChart.HSSFChartType | HSSFChart.HSSFChartType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static HSSFChart.HSSFChartType[] | HSSFChart.HSSFChartType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFChart.HSSFSeries

Packages that use HSSFChart.HSSFSeries
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFChart.HSSFSeries in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFChart.HSSFSeries
HSSFChart.HSSFSeries | HSSFChart.createSeries()
HSSFChart.HSSFSeries[] | HSSFChart.getSeries() Returns the series of the chart

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFChart.HSSFSeries
 boolean HSSFChart.removeSeries(HSSFChart.HSSFSeries series)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFChart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFChart

Packages that use HSSFChart
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFChart in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFChart
static HSSFChart[] HSSFChart.getSheetCharts(HSSFSheet sheet)
Returns all the charts for the given sheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFChildAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFChildAnchor

Packages that use HSSFChildAnchor
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFChildAnchor in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFChildAnchor
HSSFShapeGroup | HSSFShapeGroup.createGroup(HSSFChildAnchor anchor) Create another group under this group.
HSSFPicture | HSSFShapeGroup.createPicture(HSSFChildAnchor anchor, int pictureIndex) Creates a picture.
HSSFPolygon | HSSFShapeGroup.createPolygon(HSSFChildAnchor anchor) Creates a polygon
HSSFSimpleShape | HSSFShapeGroup.createShape(HSSFChildAnchor anchor) Create a new simple shape under this group.
HSSFTextbox | HSSFShapeGroup.createTextbox(HSSFChildAnchor anchor) Create a new textbox under this group.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFClientAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFClientAnchor

Packages that use HSSFClientAnchor
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFClientAnchor in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFClientAnchor
HSSFClientAnchor | HSSFPatriarch.createAnchor(int dx1, int dy1, int dx2, int dy2, int col1, int row1, int col2, int row2) Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
HSSFClientAnchor | HSSFCreationHelper.createClientAnchor() Creates a HSSFClientAnchor.
HSSFClientAnchor | HSSFPicture.getPreferredSize() Calculate the preferred size for this picture.
HSSFClientAnchor | HSSFPicture.getPreferredSize(double scale) Calculate the preferred size for this picture.

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFClientAnchor
HSSFShapeGroup | HSSFPatriarch.createGroup(HSSFClientAnchor anchor) Creates a new group record stored under this patriarch.
HSSFPicture | HSSFPatriarch.createPicture(HSSFClientAnchor anchor, int pictureIndex) Creates a picture.
HSSFPolygon | HSSFPatriarch.createPolygon(HSSFClientAnchor anchor) Creates a polygon
HSSFSimpleShape | HSSFPatriarch.createSimpleShape(HSSFClientAnchor anchor) Creates a simple shape.
HSSFTextbox | HSSFPatriarch.createTextbox(HSSFClientAnchor anchor) Constructs a textbox under the patriarch.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFComment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFComment

Packages that use HSSFComment
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFComment in org.apache.poi.hssf.model

Constructors in org.apache.poi.hssf.model with parameters of type HSSFComment
CommentShape(HSSFComment hssfShape, int shapeId)
Creates the low-level records for a comment.

Uses of HSSFComment in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFComment
HSSFComment | HSSFPatriarch.createCellComment(ClientAnchor anchor)
HSSFComment | HSSFPatriarch.createComment(HSSFAnchor anchor) Constructs a cell comment.
protected static HSSFComment | HSSFCell.findCellComment(InternalSheet sheet, int row, int column) Cell comment finder.
HSSFComment | HSSFCell.getCellComment() Returns comment associated with this cell
HSSFComment | HSSFSheet.getCellComment(int row, int column) Returns cell comment for the specified row and column

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFConditionalFormatting

Packages that use HSSFConditionalFormatting
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFConditionalFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFConditionalFormatting
 HSSFConditionalFormatting HSSFSheetConditionalFormatting.getConditionalFormattingAt(int index)
gets Conditional Formatting object at a particular index

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFConditionalFormatting
 int HSSFSheetConditionalFormatting.addConditionalFormatting(HSSFConditionalFormatting cf)
Adds a copy of HSSFConditionalFormatting object to the sheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFConditionalFormattingRule

Packages that use HSSFConditionalFormattingRule
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFConditionalFormattingRule in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFConditionalFormattingRule
HSSFConditionalFormattingRule | HSSFSheetConditionalFormatting.createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1)
HSSFConditionalFormattingRule | HSSFSheetConditionalFormatting.createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1, java.lang.String formula2) A factory method allowing to create a conditional formatting rule with a cell comparison operator TODO - formulas containing cell references are currently not parsed properly
HSSFConditionalFormattingRule | HSSFSheetConditionalFormatting.createConditionalFormattingRule(java.lang.String formula) A factory method allowing to create a conditional formatting rule with a formula. The formatting rules are applied by Excel when the value of the formula not equal to 0. TODO - formulas containing cell references are currently not parsed properly
HSSFConditionalFormattingRule | HSSFConditionalFormatting.getRule(int idx)

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFConditionalFormattingRule
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule rule1)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule[] cfRules) Allows to add a new Conditional Formatting set to the sheet.
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule rule1, HSSFConditionalFormattingRule rule2)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(Region[] regions, HSSFConditionalFormattingRule[] cfRules) Deprecated. use CellRangeAddress instead of Region
void | HSSFConditionalFormatting.addRule(HSSFConditionalFormattingRule cfRule) add a Conditional Formatting rule.
void | HSSFConditionalFormatting.setRule(int idx, HSSFConditionalFormattingRule cfRule) Replaces an existing Conditional Formatting rule at position idx.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFCreationHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFCreationHelper

Packages that use HSSFCreationHelper
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFCreationHelper in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFCreationHelper
 HSSFCreationHelper HSSFWorkbook.getCreationHelper()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFDataFormat

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFDataFormat

Packages that use HSSFDataFormat
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFDataFormat in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFDataFormat
HSSFDataFormat | HSSFWorkbook.createDataFormat() Returns the instance of HSSFDataFormat for this workbook.
HSSFDataFormat | HSSFCreationHelper.createDataFormat()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFDataFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFDataFormatter

Packages that use HSSFDataFormatter
org.apache.poi.hssf.converter

Uses of HSSFDataFormatter in org.apache.poi.hssf.converter

Fields in org.apache.poi.hssf.converter declared as HSSFDataFormatter
protected  HSSFDataFormatter AbstractExcelConverter._formatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFDataValidation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFDataValidation

No usage of org.apache.poi.hssf.usermodel.HSSFDataValidation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

No usage of org.apache.poi.hssf.usermodel.HSSFDataValidationHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFDateUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFDateUtil

No usage of org.apache.poi.hssf.usermodel.HSSFDateUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFErrorConstants

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFErrorConstants

No usage of org.apache.poi.hssf.usermodel.HSSFErrorConstants

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFEvaluationWorkbook

Packages that use HSSFEvaluationWorkbook
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFEvaluationWorkbook in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFEvaluationWorkbook
static HSSFEvaluationWorkbook HSSFEvaluationWorkbook.create(HSSFWorkbook book)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFFont

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFFont

Packages that use HSSFFont
org.apache.poi.hssf.converter |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of HSSFFont in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type HSSFFont
protected  void ExcelToFoConverter.processCellStyleFont(HSSFWorkbook workbook, org.w3c.dom.Element blockTarget, HSSFFont font)

Uses of HSSFFont in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFFont
HSSFFont | HSSFWorkbook.createFont() create a new Font and add it to the workbook's font table
HSSFFont | HSSFWorkbook.findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline) Finds a font that matches the one with the supplied attributes
HSSFFont | HSSFCellStyle.getFont(Workbook parentWorkbook) gets the font for this style
HSSFFont | HSSFWorkbook.getFontAt(short idx) Get the font at the given index number

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFFont
 void HSSFCellStyle.setFont(HSSFFont font)

Uses of HSSFFont in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util with parameters of type HSSFFont
static void HSSFCellUtil.setFont(HSSFCell cell, HSSFWorkbook workbook, HSSFFont font)
Take a cell, and apply a font to it

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFFontFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFFontFormatting

Packages that use HSSFFontFormatting
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFFontFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFFontFormatting
HSSFFontFormatting | HSSFConditionalFormattingRule.createFontFormatting() create a new font formatting structure if it does not exist, otherwise just return existing object.
HSSFFontFormatting | HSSFConditionalFormattingRule.getFontFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFFooter

Packages that use HSSFFooter
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFFooter in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFFooter
 HSSFFooter HSSFSheet.getFooter()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFFormulaEvaluator

Packages that use HSSFFormulaEvaluator
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFFormulaEvaluator in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFFormulaEvaluator
static HSSFFormulaEvaluator | HSSFFormulaEvaluator.create(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
HSSFFormulaEvaluator | HSSFCreationHelper.createFormulaEvaluator() Creates a HSSFFormulaEvaluator, the object that evaluates formula cells.

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFFormulaEvaluator
static void HSSFFormulaEvaluator.setupEnvironment(java.lang.String[] workbookNames, HSSFFormulaEvaluator[] evaluators)
Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFHeader

Packages that use HSSFHeader
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFHeader in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFHeader
 HSSFHeader HSSFSheet.getHeader()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFHyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFHyperlink

Packages that use HSSFHyperlink
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFHyperlink in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFHyperlink
HSSFHyperlink | HSSFCreationHelper.createHyperlink(int type)
HSSFHyperlink | HSSFCell.getHyperlink()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFName

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFName

Packages that use HSSFName
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFName in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFName
HSSFName | HSSFWorkbook.createName() creates a new named range and add it to the model
HSSFName | HSSFWorkbook.getName(java.lang.String name)
HSSFName | HSSFWorkbook.getNameAt(int nameIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFObjectData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFObjectData

Packages that use HSSFObjectData
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFObjectData in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return types with arguments of type HSSFObjectData
 java.util.List<HSSFObjectData> HSSFWorkbook.getAllEmbeddedObjects()
Gets all embedded OLE2 objects from the Workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFOptimiser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFOptimiser

No usage of org.apache.poi.hssf.usermodel.HSSFOptimiser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFPalette

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFPalette

Packages that use HSSFPalette
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFPalette in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFPalette
 HSSFPalette HSSFWorkbook.getCustomPalette()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFPatriarch

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFPatriarch

Packages that use HSSFPatriarch
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFPatriarch in org.apache.poi.hssf.record

Fields in org.apache.poi.hssf.record declared as HSSFPatriarch
protected  HSSFPatriarch EscherAggregate.patriarch

Methods in org.apache.poi.hssf.record that return HSSFPatriarch
 HSSFPatriarch EscherAggregate.getPatriarch()

Methods in org.apache.poi.hssf.record with parameters of type HSSFPatriarch
 void EscherAggregate.setPatriarch(HSSFPatriarch patriarch)

Uses of HSSFPatriarch in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFPatriarch
HSSFPatriarch | HSSFSheet.createDrawingPatriarch() Creates the top-level drawing patriarch.
HSSFPatriarch | HSSFSheet.getDrawingPatriarch() Returns the top-level drawing patriach, if there is one.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFPatternFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFPatternFormatting

Packages that use HSSFPatternFormatting
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFPatternFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFPatternFormatting
HSSFPatternFormatting | HSSFConditionalFormattingRule.createPatternFormatting() create a new pattern formatting structure if it does not exist, otherwise just return existing object.
HSSFPatternFormatting | HSSFConditionalFormattingRule.getPatternFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFPicture

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFPicture

Packages that use HSSFPicture
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFPicture in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFPicture
HSSFPicture | HSSFPatriarch.createPicture(ClientAnchor anchor, int pictureIndex)
HSSFPicture | HSSFShapeGroup.createPicture(HSSFChildAnchor anchor, int pictureIndex) Creates a picture.
HSSFPicture | HSSFPatriarch.createPicture(HSSFClientAnchor anchor, int pictureIndex) Creates a picture.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFPictureData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFPictureData

Packages that use HSSFPictureData
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFPictureData in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFPictureData
 HSSFPictureData HSSFPicture.getPictureData()
Return picture data for this shape

Methods in org.apache.poi.hssf.usermodel that return types with arguments of type HSSFPictureData
 java.util.List<HSSFPictureData> HSSFWorkbook.getAllPictures()
Gets all pictures from the Workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFPolygon

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFPolygon

Packages that use HSSFPolygon
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFPolygon in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFPolygon
HSSFPolygon | HSSFShapeGroup.createPolygon(HSSFChildAnchor anchor) Creates a polygon
HSSFPolygon | HSSFPatriarch.createPolygon(HSSFClientAnchor anchor) Creates a polygon

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFPrintSetup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFPrintSetup

Packages that use HSSFPrintSetup
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFPrintSetup in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFPrintSetup
 HSSFPrintSetup HSSFSheet.getPrintSetup()
Gets the print setup object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFRichTextString

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFRichTextString

Packages that use HSSFRichTextString
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFRichTextString in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return HSSFRichTextString
 HSSFRichTextString TextObjectRecord.getStr()

Methods in org.apache.poi.hssf.record with parameters of type HSSFRichTextString
 void TextObjectRecord.setStr(HSSFRichTextString str)

Uses of HSSFRichTextString in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFRichTextString
HSSFRichTextString | HSSFCreationHelper.createRichTextString(java.lang.String text)
HSSFRichTextString | HSSFCell.getRichStringCellValue() get the value of the cell as a string - for numeric cells we throw an exception.
HSSFRichTextString | HSSFTextbox.getString()

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFRichTextString
 int HSSFRichTextString.compareTo(HSSFRichTextString r)
Compares one rich text string to another.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFRow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFRow

Packages that use HSSFRow
org.apache.poi.hssf.converter |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of HSSFRow in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type HSSFRow
protected  java.lang.String AbstractExcelConverter.getRowName(HSSFRow row)
Generates name for output as row number in case AbstractExcelConverter.isOutputRowNumbers() == true
protected  int ExcelToHtmlConverter.processRow(CellRangeAddress[][] mergedRanges, HSSFRow row, org.w3c.dom.Element tableRowElement)
protected  int ExcelToFoConverter.processRow(HSSFWorkbook workbook, CellRangeAddress[][] mergedRanges, HSSFRow row, org.w3c.dom.Element tableRowElement)
protected  org.w3c.dom.Element ExcelToFoConverter.processRowNumber(HSSFRow row)
protected  void ExcelToHtmlConverter.processRowNumber(HSSFRow row, org.w3c.dom.Element tableRowNumberCellElement)

Uses of HSSFRow in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFRow
HSSFRow | HSSFSheet.createRow(int rownum) Create a new row within the sheet and return the high level representation
HSSFRow | HSSFCell.getRow() Returns the HSSFRow this cell belongs to
HSSFRow | HSSFSheet.getRow(int rowIndex) Returns the logical row (not physical) 0-based.

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFRow
 void HSSFFormulaEvaluator.setCurrentRow(HSSFRow row)
Deprecated. (Aug 2008) - not needed, since the current row can be derived from the cell

Uses of HSSFRow in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util that return HSSFRow
static HSSFRow HSSFCellUtil.getRow(int rowIndex, HSSFSheet sheet)
Get a row from the spreadsheet, and create it if it doesn't exist.

Methods in org.apache.poi.hssf.util with parameters of type HSSFRow
static HSSFCell | HSSFCellUtil.createCell(HSSFRow row, int column, java.lang.String value) Create a cell, and give it a value.
static HSSFCell | HSSFCellUtil.createCell(HSSFRow row, int column, java.lang.String value, HSSFCellStyle style) Creates a cell, gives it a value, and applies a style if provided
static HSSFCell | HSSFCellUtil.getCell(HSSFRow row, int columnIndex) Get a specific cell from a row.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFShape

Packages that use HSSFShape
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFShape in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type HSSFShape
protected int | CommentShape.addStandardOptions(HSSFShape shape, EscherOptRecord opt) Sets standard escher options for a comment.
protected int | AbstractShape.addStandardOptions(HSSFShape shape, EscherOptRecord opt) Add standard properties to the opt record.
static AbstractShape | AbstractShape.createShape(HSSFShape hssfShape, int shapeId) Create a new shape object used to create the escher records.

Uses of HSSFShape in org.apache.poi.hssf.usermodel

Subclasses of HSSFShape in org.apache.poi.hssf.usermodel
class | HSSFComment Represents a cell comment - a sticky note associated with a cell.
class | HSSFPicture Represents a escher picture.
class | HSSFPolygon
class | HSSFShapeGroup A shape group may contain other shapes.
class | HSSFSimpleShape Represents a simple shape such as a line, rectangle or oval.
class | HSSFTextbox A textbox is a shape that may hold a rich text string.

Methods in org.apache.poi.hssf.usermodel that return HSSFShape
 HSSFShape HSSFShape.getParent()
Gets the parent shape.

Methods in org.apache.poi.hssf.usermodel that return types with arguments of type HSSFShape
java.util.List<HSSFShape> | HSSFShapeGroup.getChildren() Return all children contained by this shape.
java.util.List<HSSFShape> | HSSFPatriarch.getChildren() Returns a list of all shapes contained by the patriarch.

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFShape
void | HSSFShapeGroup.addShape(HSSFShape shape)
void | HSSFPatriarch.addShape(HSSFShape shape) add a shape to this drawing

Constructors in org.apache.poi.hssf.usermodel with parameters of type HSSFShape
HSSFComment(HSSFShape parent, HSSFAnchor anchor)
Construct a new comment with the given parent and anchor.
HSSFPicture(HSSFShape parent, HSSFAnchor anchor)
Constructs a picture object.
HSSFShapeGroup(HSSFShape parent, HSSFAnchor anchor)
HSSFSimpleShape(HSSFShape parent, HSSFAnchor anchor)
HSSFTextbox(HSSFShape parent, HSSFAnchor anchor)
Construct a new textbox with the given parent and anchor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hssf.usermodel.HSSFShapeContainer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hssf.usermodel.HSSFShapeContainer

Packages that use HSSFShapeContainer
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFShapeContainer in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement HSSFShapeContainer
class | HSSFPatriarch The patriarch is the toplevel container for shapes in a sheet.
class | HSSFShapeGroup A shape group may contain other shapes.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFShapeGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFShapeGroup

Packages that use HSSFShapeGroup
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFShapeGroup in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFShapeGroup
HSSFShapeGroup | HSSFShapeGroup.createGroup(HSSFChildAnchor anchor) Create another group under this group.
HSSFShapeGroup | HSSFPatriarch.createGroup(HSSFClientAnchor anchor) Creates a new group record stored under this patriarch.

Constructors in org.apache.poi.hssf.usermodel with parameters of type HSSFShapeGroup
EscherGraphics(HSSFShapeGroup escherGroup, HSSFWorkbook workbook, java.awt.Color forecolor, float verticalPointsPerPixel)
Construct an escher graphics object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFSheet

Packages that use HSSFSheet
org.apache.poi.hssf.converter |
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of HSSFSheet in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type HSSFSheet
static CellRangeAddress[][] | ExcelToHtmlUtils.buildMergedRangesMap(HSSFSheet sheet) Creates a map (i.e.
protected static int | AbstractExcelConverter.getColumnWidth(HSSFSheet sheet, int columnIndex)
protected static int | AbstractExcelConverter.getDefaultColumnWidth(HSSFSheet sheet)
protected void | ExcelToHtmlConverter.processColumnHeaders(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table)
protected void | ExcelToFoConverter.processColumnHeaders(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table)
protected void | ExcelToHtmlConverter.processColumnWidths(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table) Creates COLGROUP element with width specified for all columns.
protected float | ExcelToFoConverter.processColumnWidths(HSSFSheet sheet, int maxSheetColumns, org.w3c.dom.Element table) Creates COLGROUP element with width specified for all columns.
protected void | ExcelToHtmlConverter.processSheet(HSSFSheet sheet)
protected float | ExcelToFoConverter.processSheet(HSSFWorkbook workbook, HSSFSheet sheet, org.w3c.dom.Element flow)
protected void | ExcelToHtmlConverter.processSheetHeader(org.w3c.dom.Element htmlBody, HSSFSheet sheet)
protected void | ExcelToFoConverter.processSheetName(HSSFSheet sheet, org.w3c.dom.Element flow)

Uses of HSSFSheet in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type HSSFSheet
static CFRuleRecord | CFRuleRecord.create(HSSFSheet sheet, byte comparisonOperation, java.lang.String formulaText1, java.lang.String formulaText2) Creates a new comparison operation rule
static CFRuleRecord | CFRuleRecord.create(HSSFSheet sheet, java.lang.String formulaText) Creates a new comparison operation rule

Uses of HSSFSheet in org.apache.poi.hssf.usermodel

Fields in org.apache.poi.hssf.usermodel with type parameters of type HSSFSheet
protected  java.util.List<HSSFSheet> HSSFWorkbook._sheets
this holds the HSSFSheet objects attached to this workbook

Methods in org.apache.poi.hssf.usermodel that return HSSFSheet
HSSFSheet | HSSFWorkbook.cloneSheet(int sheetIndex) create an HSSFSheet from an existing sheet in the HSSFWorkbook.
HSSFSheet | HSSFWorkbook.createSheet() create an HSSFSheet for this HSSFWorkbook, adds it to the sheets and returns the high level representation.
HSSFSheet | HSSFWorkbook.createSheet(java.lang.String sheetname) Create a new sheet for this Workbook and return the high level representation.
HSSFSheet | HSSFRow.getSheet() Returns the HSSFSheet this row belongs to
HSSFSheet | HSSFCell.getSheet() Returns the HSSFSheet this cell belongs to
HSSFSheet | HSSFWorkbook.getSheet(java.lang.String name) Get sheet with the given name (case insensitive match)
HSSFSheet | HSSFWorkbook.getSheetAt(int index) Get the HSSFSheet object at the given index.

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFSheet
void | HSSFChart.createBarChart(HSSFWorkbook workbook, HSSFSheet sheet) Creates a bar chart.
DVRecord | HSSFDataValidation.createDVRecord(HSSFSheet sheet)
float | HSSFClientAnchor.getAnchorHeightInPoints(HSSFSheet sheet) Calculates the height of a client anchor in points.
static HSSFChart[] | HSSFChart.getSheetCharts(HSSFSheet sheet) Returns all the charts for the given sheet.

Constructors in org.apache.poi.hssf.usermodel with parameters of type HSSFSheet
HSSFCell(HSSFWorkbook book, HSSFSheet sheet, CellValueRecordInterface cval)
Creates an HSSFCell from a CellValueRecordInterface.
HSSFCell(HSSFWorkbook book, HSSFSheet sheet, int row, short col)
Creates new Cell - Should only be called by HSSFRow.
HSSFCell(HSSFWorkbook book, HSSFSheet sheet, int row, short col, int type)
Creates new Cell - Should only be called by HSSFRow.
HSSFDataValidationHelper(HSSFSheet sheet)
HSSFFormulaEvaluator(HSSFSheet sheet, HSSFWorkbook workbook)
Deprecated. (Sep 2008) HSSFSheet parameter is ignored

Uses of HSSFSheet in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util with parameters of type HSSFSheet
static HSSFRow | HSSFCellUtil.getRow(int rowIndex, HSSFSheet sheet) Get a row from the spreadsheet, and create it if it doesn't exist.
static void | HSSFRegionUtil.setBorderBottom(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderBottom(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderLeft(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | HSSFRegionUtil.setBorderLeft(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderRight(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderRight attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderRight(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderTop(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderTop(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBottomBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the bottomBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBottomBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setLeftBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the leftBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setLeftBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setRightBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the rightBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setRightBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setTopBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the topBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setTopBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFSheetConditionalFormatting

Packages that use HSSFSheetConditionalFormatting
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFSheetConditionalFormatting in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFSheetConditionalFormatting
 HSSFSheetConditionalFormatting HSSFSheet.getSheetConditionalFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFSimpleShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFSimpleShape

Packages that use HSSFSimpleShape
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFSimpleShape in org.apache.poi.hssf.usermodel

Subclasses of HSSFSimpleShape in org.apache.poi.hssf.usermodel
class | HSSFComment Represents a cell comment - a sticky note associated with a cell.
class | HSSFPicture Represents a escher picture.
class | HSSFTextbox A textbox is a shape that may hold a rich text string.

Methods in org.apache.poi.hssf.usermodel that return HSSFSimpleShape
HSSFSimpleShape | HSSFShapeGroup.createShape(HSSFChildAnchor anchor) Create a new simple shape under this group.
HSSFSimpleShape | HSSFPatriarch.createSimpleShape(HSSFClientAnchor anchor) Creates a simple shape.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFTextbox

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFTextbox

Packages that use HSSFTextbox
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of HSSFTextbox in org.apache.poi.hssf.usermodel

Subclasses of HSSFTextbox in org.apache.poi.hssf.usermodel
 class HSSFComment
Represents a cell comment - a sticky note associated with a cell.

Methods in org.apache.poi.hssf.usermodel that return HSSFTextbox
HSSFTextbox | HSSFShapeGroup.createTextbox(HSSFChildAnchor anchor) Create a new textbox under this group.
HSSFTextbox | HSSFPatriarch.createTextbox(HSSFClientAnchor anchor) Constructs a textbox under the patriarch.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.usermodel.HSSFWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.usermodel.HSSFWorkbook

Packages that use HSSFWorkbook
org.apache.poi.hssf.converter |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of HSSFWorkbook in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter that return HSSFWorkbook
static HSSFWorkbook AbstractExcelUtils.loadXls(java.io.File xlsFile)

Methods in org.apache.poi.hssf.converter with parameters of type HSSFWorkbook
protected java.lang.String | ExcelToHtmlConverter.buildStyle(HSSFWorkbook workbook, HSSFCellStyle cellStyle)
protected java.lang.String | ExcelToHtmlConverter.getStyleClassName(HSSFWorkbook workbook, HSSFCellStyle cellStyle)
protected boolean | ExcelToFoConverter.processCell(HSSFWorkbook workbook, HSSFCell cell, org.w3c.dom.Element tableCellElement, int normalWidthPx, int maxSpannedWidthPx, float normalHeightPt)
protected void | ExcelToFoConverter.processCellStyle(HSSFWorkbook workbook, HSSFCellStyle cellStyle, org.w3c.dom.Element cellTarget, org.w3c.dom.Element blockTarget)
protected void | ExcelToFoConverter.processCellStyleBorder(HSSFWorkbook workbook, org.w3c.dom.Element cellTarget, java.lang.String type, short xlsBorder, short borderColor)
protected void | ExcelToFoConverter.processCellStyleFont(HSSFWorkbook workbook, org.w3c.dom.Element blockTarget, HSSFFont font)
protected int | ExcelToFoConverter.processRow(HSSFWorkbook workbook, CellRangeAddress[][] mergedRanges, HSSFRow row, org.w3c.dom.Element tableRowElement)
protected float | ExcelToFoConverter.processSheet(HSSFWorkbook workbook, HSSFSheet sheet, org.w3c.dom.Element flow)
protected boolean | ExcelToFoConverter.processSheet(HSSFWorkbook workbook, int sheetIndex) Process single sheet (as specified by 0-based sheet index)
void | ExcelToHtmlConverter.processWorkbook(HSSFWorkbook workbook)
void | ExcelToFoConverter.processWorkbook(HSSFWorkbook workbook)

Uses of HSSFWorkbook in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel that return HSSFWorkbook
 HSSFWorkbook EventWorkbookBuilder.SheetRecordCollectingListener.getStubHSSFWorkbook()

Uses of HSSFWorkbook in org.apache.poi.hssf.extractor

Constructors in org.apache.poi.hssf.extractor with parameters of type HSSFWorkbook
ExcelExtractor(HSSFWorkbook wb)

Uses of HSSFWorkbook in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type HSSFWorkbook
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook) Convenience method for parsing cell formulas.
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType)
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType, int sheetIndex)
static java.lang.String | HSSFFormulaParser.toFormulaString(HSSFWorkbook book, Ptg[] ptgs) Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.

Uses of HSSFWorkbook in org.apache.poi.hssf.usermodel

Fields in org.apache.poi.hssf.usermodel declared as HSSFWorkbook
protected  HSSFWorkbook HSSFSheet._workbook

Methods in org.apache.poi.hssf.usermodel that return HSSFWorkbook
static HSSFWorkbook | HSSFWorkbook.create(InternalWorkbook book)
HSSFWorkbook | HSSFSheet.getWorkbook() Return the parent workbook

Methods in org.apache.poi.hssf.usermodel with parameters of type HSSFWorkbook
static HSSFEvaluationWorkbook | HSSFEvaluationWorkbook.create(HSSFWorkbook book)
static HSSFFormulaEvaluator | HSSFFormulaEvaluator.create(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
void | HSSFChart.createBarChart(HSSFWorkbook workbook, HSSFSheet sheet) Creates a bar chart.
static void | HSSFFormulaEvaluator.evaluateAllFormulaCells(HSSFWorkbook wb) Loops over all cells in all sheets of the supplied workbook.
HSSFColor | HSSFFont.getHSSFColor(HSSFWorkbook wb) get the color value for the font
static void | HSSFOptimiser.optimiseCellStyles(HSSFWorkbook workbook) Goes through the Wokrbook, optimising the cell styles by removing duplicate ones.
static void | HSSFOptimiser.optimiseFonts(HSSFWorkbook workbook) Goes through the Workbook, optimising the fonts by removing duplicate ones.
void | HSSFCellStyle.verifyBelongsToWorkbook(HSSFWorkbook wb) Verifies that this style belongs to the supplied Workbook.

Constructors in org.apache.poi.hssf.usermodel with parameters of type HSSFWorkbook
EscherGraphics(HSSFShapeGroup escherGroup, HSSFWorkbook workbook, java.awt.Color forecolor, float verticalPointsPerPixel)
Construct an escher graphics object.
HSSFCell(HSSFWorkbook book, HSSFSheet sheet, CellValueRecordInterface cval)
Creates an HSSFCell from a CellValueRecordInterface.
HSSFCell(HSSFWorkbook book, HSSFSheet sheet, int row, short col)
Creates new Cell - Should only be called by HSSFRow.
HSSFCell(HSSFWorkbook book, HSSFSheet sheet, int row, short col, int type)
Creates new Cell - Should only be called by HSSFRow.
HSSFCellStyle(short index, ExtendedFormatRecord rec, HSSFWorkbook workbook)
Creates new HSSFCellStyle why would you want to do this??
HSSFFormulaEvaluator(HSSFSheet sheet, HSSFWorkbook workbook)
Deprecated. (Sep 2008) HSSFSheet parameter is ignored
HSSFFormulaEvaluator(HSSFWorkbook workbook)
HSSFFormulaEvaluator(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier)
HSSFSheet(HSSFWorkbook workbook)
Creates new HSSFSheet - called by HSSFWorkbook to create a sheet from scratch.
HSSFSheet(HSSFWorkbook workbook, InternalSheet sheet)
Creates an HSSFSheet representing the given Sheet object.

Uses of HSSFWorkbook in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util with parameters of type HSSFWorkbook
static void | HSSFCellUtil.setAlignment(HSSFCell cell, HSSFWorkbook workbook, short align) Take a cell, and align it.
static void | HSSFRegionUtil.setBorderBottom(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderBottom(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderLeft(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | HSSFRegionUtil.setBorderLeft(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderRight(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderRight attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderRight(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderTop(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderTop(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBottomBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the bottomBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBottomBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFCellUtil.setCellStyleProperty(HSSFCell cell, HSSFWorkbook workbook, java.lang.String propertyName, java.lang.Object propertyValue) This method attempt to find an already existing HSSFCellStyle that matches what you want the style to be.
static void | HSSFCellUtil.setFont(HSSFCell cell, HSSFWorkbook workbook, HSSFFont font) Take a cell, and apply a font to it
static void | HSSFRegionUtil.setLeftBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the leftBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setLeftBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setRightBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the rightBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setRightBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setTopBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the topBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setTopBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AreaReference

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class AreaReference

java.lang.Object
    extended by  org.apache.poi.ss.util.AreaReference
        extended by  org.apache.poi.hssf.util.AreaReference

public final class AreaReference
extends AreaReference

Constructor Summary
AreaReference(CellReference topLeft, CellReference botRight)
Creates an area ref from a pair of Cell References.
AreaReference(java.lang.String reference)
Create an area ref from a string representation.
Method Summary
Methods inherited from class org.apache.poi.ss.util.AreaReference
formatAsString, generateContiguous, getAllReferencedCells, getFirstCell, getLastCell, getWholeColumn, getWholeRow, isContiguous, isSingleCell, isWholeColumnReference, isWholeColumnReference, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AreaReference

public AreaReference(java.lang.String reference)
Create an area ref from a string representation. Sheet names containing special characters should be delimited and escaped as per normal syntax rules for formulas.
The area reference must be contiguous (i.e. represent a single rectangle, not a union of rectangles)

AreaReference

public AreaReference(CellReference topLeft,
                     CellReference botRight)
Creates an area ref from a pair of Cell References. Also normalises such that the top-left

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CellRangeAddress

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class CellRangeAddress

java.lang.Object
    extended by  org.apache.poi.ss.util.CellRangeAddressBase
        extended by  org.apache.poi.ss.util.CellRangeAddress
            extended by  org.apache.poi.hssf.util.CellRangeAddress
Deprecated. use CellRangeAddress

public class CellRangeAddress
extends CellRangeAddress

See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Note - SelectionRecord uses the BIFF5 version of this structure

Author:
Dragos Buleandra (dragos.buleandra@trade2b.ro)

Field Summary
Fields inherited from class org.apache.poi.ss.util.CellRangeAddress
ENCODED_SIZE
Constructor Summary
CellRangeAddress(int firstRow, int lastRow, int firstCol, int lastCol)
Deprecated.
CellRangeAddress(RecordInputStream in)
Deprecated.
Method Summary
Methods inherited from class org.apache.poi.ss.util.CellRangeAddress
copy, formatAsString, formatAsString, getEncodedSize, serialize, serialize, valueOf
Methods inherited from class org.apache.poi.ss.util.CellRangeAddressBase
getFirstColumn, getFirstRow, getLastColumn, getLastRow, getNumberOfCells, isFullColumnRange, isFullRowRange, isInRange, setFirstColumn, setFirstRow, setLastColumn, setLastRow, toString, validate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CellRangeAddress

public CellRangeAddress(int firstRow,
                        int lastRow,
                        int firstCol,
                        int lastCol)
Deprecated.

CellRangeAddress

public CellRangeAddress(RecordInputStream in)
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellRangeAddress8Bit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class CellRangeAddress8Bit

java.lang.Object
    extended by  org.apache.poi.ss.util.CellRangeAddressBase
        extended by  org.apache.poi.hssf.util.CellRangeAddress8Bit

public final class CellRangeAddress8Bit
extends CellRangeAddressBase

See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Like CellRangeAddress except column fields are 8-bit.

Author:
Josh Micich

Field Summary
static int ENCODED_SIZE
Constructor Summary
CellRangeAddress8Bit(int firstRow, int lastRow, int firstCol, int lastCol)
CellRangeAddress8Bit(LittleEndianInput in)
Method Summary
CellRangeAddress8Bit | copy()
static int | getEncodedSize(int numberOfItems)
int | serialize(int offset, byte[] data) Deprecated. use serialize(LittleEndianOutput)
void | serialize(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.util.CellRangeAddressBase
getFirstColumn, getFirstRow, getLastColumn, getLastRow, getNumberOfCells, isFullColumnRange, isFullRowRange, isInRange, setFirstColumn, setFirstRow, setLastColumn, setLastRow, toString, validate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ENCODED_SIZE

public static final int ENCODED_SIZE
See Also:
Constant Field Values
Constructor Detail

CellRangeAddress8Bit

public CellRangeAddress8Bit(int firstRow,
                            int lastRow,
                            int firstCol,
                            int lastCol)

CellRangeAddress8Bit

public CellRangeAddress8Bit(LittleEndianInput in)
Method Detail

serialize

public int serialize(int offset,
                     byte[] data)
Deprecated. use serialize(LittleEndianOutput)

serialize

public void serialize(LittleEndianOutput out)

copy

public CellRangeAddress8Bit copy()

getEncodedSize

public static int getEncodedSize(int numberOfItems)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellRangeAddressList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class CellRangeAddressList

java.lang.Object
    extended by  org.apache.poi.ss.util.CellRangeAddressList
        extended by  org.apache.poi.hssf.util.CellRangeAddressList
Deprecated. use CellRangeAddressList

public class CellRangeAddressList
extends CellRangeAddressList

Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas). A cell range address list consists of a field with the number of ranges and the list of the range addresses. Each cell range address (called an ADDR structure) contains 4 16-bit-values.

Author:
Dragos Buleandra (dragos.buleandra@trade2b.ro)

Field Summary
Fields inherited from class org.apache.poi.ss.util.CellRangeAddressList
_list
Constructor Summary
CellRangeAddressList()
Deprecated.
CellRangeAddressList(int firstRow, int lastRow, int firstCol, int lastCol)
Deprecated.
CellRangeAddressList(RecordInputStream in)
Deprecated.
Method Summary
Methods inherited from class org.apache.poi.ss.util.CellRangeAddressList
addCellRangeAddress, addCellRangeAddress, copy, countRanges, getCellRangeAddress, getCellRangeAddresses, getEncodedSize, getSize, remove, serialize, serialize
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellRangeAddressList

public CellRangeAddressList(int firstRow,
                            int lastRow,
                            int firstCol,
                            int lastCol)
Deprecated.

CellRangeAddressList

public CellRangeAddressList()
Deprecated.

CellRangeAddressList

public CellRangeAddressList(RecordInputStream in)
Deprecated.
Parameters:
in - the RecordInputstream to read the record from
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellReference

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class CellReference

java.lang.Object
    extended by  org.apache.poi.ss.util.CellReference
        extended by  org.apache.poi.hssf.util.CellReference

public final class CellReference
extends CellReference

Common conversion functions between Excel style A1, C27 style cell references, and POI usermodel style row=0, column=0 style references.

Author:
Avik Sengupta, Dennis Doubleday (patch to seperateRowColumns())

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.ss.util.CellReference
CellReference.NameType
Constructor Summary
CellReference(int pRow, int pCol)
CellReference(int pRow, int pCol, boolean pAbsRow, boolean pAbsCol)
CellReference(java.lang.String cellRef)
Create an cell ref from a string representation.
CellReference(java.lang.String pSheetName, int pRow, int pCol, boolean pAbsRow, boolean pAbsCol)
Method Summary
Methods inherited from class org.apache.poi.ss.util.CellReference
cellReferenceIsWithinRange, classifyCellReference, convertColStringToIndex, convertNumToColString, equals, formatAsString, getCellRefParts, getCol, getRow, getSheetName, isColAbsolute, isColumnWithnRange, isPartAbsolute, isRowAbsolute, isRowWithnRange, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CellReference

public CellReference(java.lang.String cellRef)
Create an cell ref from a string representation. Sheet names containing special characters should be delimited and escaped as per normal syntax rules for formulas.

CellReference

public CellReference(int pRow,
                     int pCol)

CellReference

public CellReference(int pRow,
                     int pCol,
                     boolean pAbsRow,
                     boolean pAbsCol)

CellReference

public CellReference(java.lang.String pSheetName,
                     int pRow,
                     int pCol,
                     boolean pAbsRow,
                     boolean pAbsCol)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFCellUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFCellUtil

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFCellUtil

public final class HSSFCellUtil
extends java.lang.Object

Various utility functions that make working with a cells and rows easier. The various methods that deal with style's allow you to create your HSSFCellStyles as you need them. When you apply a style change to a cell, the code will attempt to see if a style already exists that meets your needs. If not, then it will create a new style. This is to prevent creating too many styles. there is an upper limit in Excel on the number of styles that can be supported.

Author:
Eric Pugh epugh@upstate.com

Method Summary
static HSSFCell | createCell(HSSFRow row, int column, java.lang.String value) Create a cell, and give it a value.
static HSSFCell | createCell(HSSFRow row, int column, java.lang.String value, HSSFCellStyle style) Creates a cell, gives it a value, and applies a style if provided
static HSSFCell | getCell(HSSFRow row, int columnIndex) Get a specific cell from a row.
static HSSFRow | getRow(int rowIndex, HSSFSheet sheet) Get a row from the spreadsheet, and create it if it doesn't exist.
static void | setAlignment(HSSFCell cell, HSSFWorkbook workbook, short align) Take a cell, and align it.
static void | setCellStyleProperty(HSSFCell cell, HSSFWorkbook workbook, java.lang.String propertyName, java.lang.Object propertyValue) This method attempt to find an already existing HSSFCellStyle that matches what you want the style to be.
static void | setFont(HSSFCell cell, HSSFWorkbook workbook, HSSFFont font) Take a cell, and apply a font to it
static HSSFCell | translateUnicodeValues(HSSFCell cell) Looks for text in the cell that should be unicode, like α and provides the unicode version of it.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getRow

public static HSSFRow getRow(int rowIndex,
                             HSSFSheet sheet)
Get a row from the spreadsheet, and create it if it doesn't exist.

Parameters:
rowIndex - The 0 based row number
sheet - The sheet that the row is part of.
Returns:
The row indicated by the rowCounter

getCell

public static HSSFCell getCell(HSSFRow row,
                               int columnIndex)
Get a specific cell from a row. If the cell doesn't exist, then create it.

Parameters:
row - The row that the cell is part of
columnIndex - The column index that the cell is in.
Returns:
The cell indicated by the column.

createCell

public static HSSFCell createCell(HSSFRow row,
                                  int column,
                                  java.lang.String value,
                                  HSSFCellStyle style)
Creates a cell, gives it a value, and applies a style if provided

Parameters:
row - the row to create the cell in
column - the column index to create the cell in
value - The value of the cell
style - If the style is not null, then set
Returns:
A new HSSFCell

createCell

public static HSSFCell createCell(HSSFRow row,
                                  int column,
                                  java.lang.String value)
Create a cell, and give it a value.

Parameters:
row - the row to create the cell in
column - the column index to create the cell in
value - The value of the cell
Returns:
A new HSSFCell.

setAlignment

public static void setAlignment(HSSFCell cell,
                                HSSFWorkbook workbook,
                                short align)
Take a cell, and align it.

Parameters:
cell - the cell to set the alignment for
workbook - The workbook that is being worked with.
align - the column alignment to use.
See Also:
for alignment options

setFont

public static void setFont(HSSFCell cell,
                           HSSFWorkbook workbook,
                           HSSFFont font)
Take a cell, and apply a font to it

Parameters:
cell - the cell to set the alignment for
workbook - The workbook that is being worked with.
font - The HSSFFont that you want to set...

setCellStyleProperty

public static void setCellStyleProperty(HSSFCell cell,
                                        HSSFWorkbook workbook,
                                        java.lang.String propertyName,
                                        java.lang.Object propertyValue)
This method attempt to find an already existing HSSFCellStyle that matches what you want the style to be. If it does not find the style, then it creates a new one. If it does create a new one, then it applies the propertyName and propertyValue to the style. This is necessary because Excel has an upper limit on the number of Styles that it supports.

Parameters:
workbook - The workbook that is being worked with.
propertyName - The name of the property that is to be changed.
propertyValue - The value of the property that is to be changed.
cell - The cell that needs it's style changes

translateUnicodeValues

public static HSSFCell translateUnicodeValues(HSSFCell cell)
Looks for text in the cell that should be unicode, like α and provides the unicode version of it.

Parameters:
cell - The cell to check for unicode values
Returns:
translated to unicode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.AQUA

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.AQUA

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.AQUA
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.AQUA
extends HSSFColor

Class AQUA

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.AQUA()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.AQUA

public HSSFColor.AQUA()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.AUTOMATIC

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.AUTOMATIC

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.AUTOMATIC
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.AUTOMATIC
extends HSSFColor

Special Default/Normal/Automatic color.

Note: This class is NOT in the default HashTables returned by HSSFColor. The index is a special case which is interpreted in the various setXXXColor calls.

Author:
Jason

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static short index
Constructor Summary
HSSFColor.AUTOMATIC()
Method Summary
java.lang.String | getHexString()
short | getIndex()
static HSSFColor | getInstance()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values
Constructor Detail

HSSFColor.AUTOMATIC

public HSSFColor.AUTOMATIC()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet

getInstance

public static HSSFColor getInstance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.BLACK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.BLACK

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.BLACK
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.BLACK
extends HSSFColor

Class BLACK

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.BLACK()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.BLACK

public HSSFColor.BLACK()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.BLUE
extends HSSFColor

Class BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.BLUE

public HSSFColor.BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.BLUE_GREY

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.BLUE_GREY

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.BLUE_GREY
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.BLUE_GREY
extends HSSFColor

Class BLUE_GREY

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.BLUE_GREY()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.BLUE_GREY

public HSSFColor.BLUE_GREY()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.BRIGHT_GREEN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.BRIGHT_GREEN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.BRIGHT_GREEN
extends HSSFColor

Class BRIGHT_GREEN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.BRIGHT_GREEN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.BRIGHT_GREEN

public HSSFColor.BRIGHT_GREEN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.BROWN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.BROWN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.BROWN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.BROWN
extends HSSFColor

Class BROWN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.BROWN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.BROWN

public HSSFColor.BROWN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.CORAL

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.CORAL

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.CORAL
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.CORAL
extends HSSFColor

Class CORAL

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.CORAL()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.CORAL

public HSSFColor.CORAL()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.CORNFLOWER_BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.CORNFLOWER_BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.CORNFLOWER_BLUE
extends HSSFColor

Class CORNFLOWER_BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.CORNFLOWER_BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.CORNFLOWER_BLUE

public HSSFColor.CORNFLOWER_BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.DARK_BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.DARK_BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.DARK_BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.DARK_BLUE
extends HSSFColor

Class DARK_BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.DARK_BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.DARK_BLUE

public HSSFColor.DARK_BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.DARK_GREEN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.DARK_GREEN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.DARK_GREEN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.DARK_GREEN
extends HSSFColor

Class DARK_GREEN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.DARK_GREEN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.DARK_GREEN

public HSSFColor.DARK_GREEN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.DARK_RED

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.DARK_RED

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.DARK_RED
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.DARK_RED
extends HSSFColor

Class DARK_RED

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.DARK_RED()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.DARK_RED

public HSSFColor.DARK_RED()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.DARK_TEAL

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.DARK_TEAL

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.DARK_TEAL
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.DARK_TEAL
extends HSSFColor

Class DARK_TEAL

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.DARK_TEAL()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.DARK_TEAL

public HSSFColor.DARK_TEAL()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.DARK_YELLOW

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.DARK_YELLOW

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.DARK_YELLOW
extends HSSFColor

Class DARK_YELLOW

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.DARK_YELLOW()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.DARK_YELLOW

public HSSFColor.DARK_YELLOW()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.GOLD

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.GOLD

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.GOLD
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.GOLD
extends HSSFColor

Class GOLD

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.GOLD()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.GOLD

public HSSFColor.GOLD()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.GREEN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.GREEN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.GREEN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.GREEN
extends HSSFColor

Class GREEN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.GREEN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.GREEN

public HSSFColor.GREEN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.GREY_25_PERCENT

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.GREY_25_PERCENT

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.GREY_25_PERCENT
extends HSSFColor

Class GREY_25_PERCENT

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.GREY_25_PERCENT()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.GREY_25_PERCENT

public HSSFColor.GREY_25_PERCENT()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.GREY_40_PERCENT

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.GREY_40_PERCENT

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.GREY_40_PERCENT
extends HSSFColor

Class GREY_40_PERCENT

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.GREY_40_PERCENT()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.GREY_40_PERCENT

public HSSFColor.GREY_40_PERCENT()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.GREY_50_PERCENT

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.GREY_50_PERCENT

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.GREY_50_PERCENT
extends HSSFColor

Class GREY_50_PERCENT

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.GREY_50_PERCENT()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.GREY_50_PERCENT

public HSSFColor.GREY_50_PERCENT()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.GREY_80_PERCENT

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.GREY_80_PERCENT

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.GREY_80_PERCENT
extends HSSFColor

Class GREY_80_PERCENT

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.GREY_80_PERCENT()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.GREY_80_PERCENT

public HSSFColor.GREY_80_PERCENT()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
All Implemented Interfaces:
Color
Direct Known Subclasses:
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
public class HSSFColor
extends java.lang.Object
implements Color

Intends to provide support for the very evil index to triplet issue and will likely replace the color constants interface for HSSF 2.0. This class contains static inner class members for representing colors. Each color has an index (for the standard palette in Excel (tm) ), native (RGB) triplet and string triplet. The string triplet is as the color would be represented by Gnumeric. Having (string) this here is a bit of a collusion of function between HSSF and the HSSFSerializer but I think its a reasonable one in this case.

Author:
Andrew C. Oliver (acoliver at apache dot org), Brian Sanders (bsanders at risklabs dot com) - full default color palette

Nested Class Summary
static class | HSSFColor.AQUA Class AQUA
static class | HSSFColor.AUTOMATIC Special Default/Normal/Automatic color.
static class | HSSFColor.BLACK Class BLACK
static class | HSSFColor.BLUE Class BLUE
static class | HSSFColor.BLUE_GREY Class BLUE_GREY
static class | HSSFColor.BRIGHT_GREEN Class BRIGHT_GREEN
static class | HSSFColor.BROWN Class BROWN
static class | HSSFColor.CORAL Class CORAL
static class | HSSFColor.CORNFLOWER_BLUE Class CORNFLOWER_BLUE
static class | HSSFColor.DARK_BLUE Class DARK_BLUE
static class | HSSFColor.DARK_GREEN Class DARK_GREEN
static class | HSSFColor.DARK_RED Class DARK_RED
static class | HSSFColor.DARK_TEAL Class DARK_TEAL
static class | HSSFColor.DARK_YELLOW Class DARK_YELLOW
static class | HSSFColor.GOLD Class GOLD
static class | HSSFColor.GREEN Class GREEN
static class | HSSFColor.GREY_25_PERCENT Class GREY_25_PERCENT
static class | HSSFColor.GREY_40_PERCENT Class GREY_40_PERCENT
static class | HSSFColor.GREY_50_PERCENT Class GREY_50_PERCENT
static class | HSSFColor.GREY_80_PERCENT Class GREY_80_PERCENT
static class | HSSFColor.INDIGO Class INDIGO
static class | HSSFColor.LAVENDER Class LAVENDER
static class | HSSFColor.LEMON_CHIFFON Class LEMON_CHIFFON
static class | HSSFColor.LIGHT_BLUE Class LIGHT_BLUE
static class | HSSFColor.LIGHT_CORNFLOWER_BLUE Class LIGHT_CORNFLOWER_BLUE
static class | HSSFColor.LIGHT_GREEN Class LIGHT_GREEN
static class | HSSFColor.LIGHT_ORANGE Class LIGHT_ORANGE
static class | HSSFColor.LIGHT_TURQUOISE Class LIGHT_TURQUOISE
static class | HSSFColor.LIGHT_YELLOW Class LIGHT_YELLOW
static class | HSSFColor.LIME Class LIME
static class | HSSFColor.MAROON Class MAROON
static class | HSSFColor.OLIVE_GREEN Class OLIVE_GREEN
static class | HSSFColor.ORANGE Class ORANGE
static class | HSSFColor.ORCHID Class ORCHID
static class | HSSFColor.PALE_BLUE Class PALE_BLUE
static class | HSSFColor.PINK Class PINK
static class | HSSFColor.PLUM Class PLUM
static class | HSSFColor.RED Class RED
static class | HSSFColor.ROSE Class ROSE
static class | HSSFColor.ROYAL_BLUE Class ROYAL_BLUE
static class | HSSFColor.SEA_GREEN Class SEA_GREEN
static class | HSSFColor.SKY_BLUE Class SKY_BLUE
static class | HSSFColor.TAN Class TAN
static class | HSSFColor.TEAL Class TEAL
static class | HSSFColor.TURQUOISE Class TURQUOISE
static class | HSSFColor.VIOLET Class VIOLET
static class | HSSFColor.WHITE Class WHITE
static class | HSSFColor.YELLOW Class YELLOW
Constructor Summary
HSSFColor()
Creates a new instance of HSSFColor
Method Summary
java.lang.String | getHexString()
short | getIndex()
static java.util.Map<java.lang.Integer,HSSFColor> | getIndexHash() This function returns all the colours in an unmodifiable Map.
static java.util.Hashtable<java.lang.Integer,HSSFColor> | getMutableIndexHash() This function returns all the Colours, stored in a Hashtable that can be edited.
short[] | getTriplet()
static java.util.Hashtable<java.lang.String,HSSFColor> | getTripletHash() this function returns all colors in a hastable.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSSFColor

public HSSFColor()
Creates a new instance of HSSFColor

Method Detail

getIndexHash

public static final java.util.Map<java.lang.Integer,HSSFColor> getIndexHash()
This function returns all the colours in an unmodifiable Map. The map is cached on first use.

Returns:
a Map containing all colours keyed by Integer excel-style palette indexes

getMutableIndexHash

public static final java.util.Hashtable<java.lang.Integer,HSSFColor> getMutableIndexHash()
This function returns all the Colours, stored in a Hashtable that can be edited. No caching is performed. If you don't need to edit the table, then call getIndexHash() which returns a statically cached imuatable map of colours.

getTripletHash

public static final java.util.Hashtable<java.lang.String,HSSFColor> getTripletHash()
this function returns all colors in a hastable. Its not implemented as a static member/staticly initialized because that would be dirty in a server environment as it is intended. This means you'll eat the time it takes to create it once per request but you will not hold onto it if you have none of those requests.

Returns:
a hashtable containing all colors keyed by String gnumeric-like triplets

getIndex

public short getIndex()
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.INDIGO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.INDIGO

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.INDIGO
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.INDIGO
extends HSSFColor

Class INDIGO

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.INDIGO()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.INDIGO

public HSSFColor.INDIGO()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LAVENDER

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LAVENDER

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LAVENDER
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LAVENDER
extends HSSFColor

Class LAVENDER

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LAVENDER()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LAVENDER

public HSSFColor.LAVENDER()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LEMON_CHIFFON

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LEMON_CHIFFON

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LEMON_CHIFFON
extends HSSFColor

Class LEMON_CHIFFON

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LEMON_CHIFFON()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LEMON_CHIFFON

public HSSFColor.LEMON_CHIFFON()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LIGHT_BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LIGHT_BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LIGHT_BLUE
extends HSSFColor

Class LIGHT_BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LIGHT_BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LIGHT_BLUE

public HSSFColor.LIGHT_BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LIGHT_CORNFLOWER_BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LIGHT_CORNFLOWER_BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LIGHT_CORNFLOWER_BLUE
extends HSSFColor

Class LIGHT_CORNFLOWER_BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LIGHT_CORNFLOWER_BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LIGHT_CORNFLOWER_BLUE

public HSSFColor.LIGHT_CORNFLOWER_BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LIGHT_GREEN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LIGHT_GREEN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LIGHT_GREEN
extends HSSFColor

Class LIGHT_GREEN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LIGHT_GREEN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LIGHT_GREEN

public HSSFColor.LIGHT_GREEN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LIGHT_ORANGE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LIGHT_ORANGE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LIGHT_ORANGE
extends HSSFColor

Class LIGHT_ORANGE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LIGHT_ORANGE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LIGHT_ORANGE

public HSSFColor.LIGHT_ORANGE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LIGHT_TURQUOISE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LIGHT_TURQUOISE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LIGHT_TURQUOISE
extends HSSFColor

Class LIGHT_TURQUOISE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.LIGHT_TURQUOISE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LIGHT_TURQUOISE

public HSSFColor.LIGHT_TURQUOISE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LIGHT_YELLOW

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LIGHT_YELLOW

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LIGHT_YELLOW
extends HSSFColor

Class LIGHT_YELLOW

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LIGHT_YELLOW()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LIGHT_YELLOW

public HSSFColor.LIGHT_YELLOW()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.LIME

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.LIME

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.LIME
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.LIME
extends HSSFColor

Class LIME

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.LIME()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.LIME

public HSSFColor.LIME()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.MAROON

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.MAROON

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.MAROON
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.MAROON
extends HSSFColor

Class MAROON

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.MAROON()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.MAROON

public HSSFColor.MAROON()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.OLIVE_GREEN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.OLIVE_GREEN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static class HSSFColor.OLIVE_GREEN
extends HSSFColor

Class OLIVE_GREEN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.OLIVE_GREEN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.OLIVE_GREEN

public HSSFColor.OLIVE_GREEN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.ORANGE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.ORANGE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.ORANGE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.ORANGE
extends HSSFColor

Class ORANGE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.ORANGE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.ORANGE

public HSSFColor.ORANGE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.ORCHID

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.ORCHID

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.ORCHID
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.ORCHID
extends HSSFColor

Class ORCHID

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.ORCHID()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.ORCHID

public HSSFColor.ORCHID()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.PALE_BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.PALE_BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.PALE_BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.PALE_BLUE
extends HSSFColor

Class PALE_BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.PALE_BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.PALE_BLUE

public HSSFColor.PALE_BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.PINK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.PINK

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.PINK
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.PINK
extends HSSFColor

Class PINK

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.PINK()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.PINK

public HSSFColor.PINK()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.PLUM

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.PLUM

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.PLUM
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.PLUM
extends HSSFColor

Class PLUM

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.PLUM()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.PLUM

public HSSFColor.PLUM()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.RED

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.RED

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.RED
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.RED
extends HSSFColor

Class RED

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.RED()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.RED

public HSSFColor.RED()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.ROSE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.ROSE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.ROSE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.ROSE
extends HSSFColor

Class ROSE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.ROSE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.ROSE

public HSSFColor.ROSE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.ROYAL_BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.ROYAL_BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.ROYAL_BLUE
extends HSSFColor

Class ROYAL_BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.ROYAL_BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.ROYAL_BLUE

public HSSFColor.ROYAL_BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.SEA_GREEN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.SEA_GREEN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.SEA_GREEN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.SEA_GREEN
extends HSSFColor

Class SEA_GREEN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.SEA_GREEN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.SEA_GREEN

public HSSFColor.SEA_GREEN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.SKY_BLUE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.SKY_BLUE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.SKY_BLUE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.SKY_BLUE
extends HSSFColor

Class SKY_BLUE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.SKY_BLUE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.SKY_BLUE

public HSSFColor.SKY_BLUE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.TAN

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.TAN

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.TAN
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.TAN
extends HSSFColor

Class TAN

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.TAN()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.TAN

public HSSFColor.TAN()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.TEAL

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.TEAL

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.TEAL
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.TEAL
extends HSSFColor

Class TEAL

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.TEAL()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.TEAL

public HSSFColor.TEAL()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.TURQUOISE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.TURQUOISE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.TURQUOISE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.TURQUOISE
extends HSSFColor

Class TURQUOISE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.TURQUOISE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.TURQUOISE

public HSSFColor.TURQUOISE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.VIOLET

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.VIOLET

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.VIOLET
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.VIOLET
extends HSSFColor

Class VIOLET

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.VIOLET()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.VIOLET

public HSSFColor.VIOLET()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.WHITE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.WHITE

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.WHITE
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.WHITE
extends HSSFColor

Class WHITE

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short[] | triplet
Constructor Summary
HSSFColor.WHITE()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.WHITE

public HSSFColor.WHITE()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFColor.YELLOW

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFColor.YELLOW

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFColor
        extended by  org.apache.poi.hssf.util.HSSFColor.YELLOW
All Implemented Interfaces:
Color
Enclosing class:
HSSFColor
public static final class HSSFColor.YELLOW
extends HSSFColor

Class YELLOW

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hssf.util.HSSFColor
HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW
Field Summary
static java.lang.String | hexString
static short | index
static short | index2
static short[] | triplet
Constructor Summary
HSSFColor.YELLOW()
Method Summary
java.lang.String | getHexString()
short | getIndex()
short[] | getTriplet()
Methods inherited from class org.apache.poi.hssf.util.HSSFColor
getIndexHash, getMutableIndexHash, getTripletHash
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public static final short index
See Also:
Constant Field Values

index2

public static final short index2
See Also:
Constant Field Values

triplet

public static final short[] triplet

hexString

public static final java.lang.String hexString
See Also:
Constant Field Values
Constructor Detail

HSSFColor.YELLOW

public HSSFColor.YELLOW()
Method Detail

getIndex

public short getIndex()
Overrides:
getIndex in class HSSFColor
Returns:
index to the standard palette

getTriplet

public short[] getTriplet()
Overrides:
getTriplet in class HSSFColor
Returns:
triplet representation like that in Excel

getHexString

public java.lang.String getHexString()
Overrides:
getHexString in class HSSFColor
Returns:
a hex string exactly like a gnumeric triplet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSSFRegionUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class HSSFRegionUtil

java.lang.Object
    extended by  org.apache.poi.hssf.util.HSSFRegionUtil

public final class HSSFRegionUtil
extends java.lang.Object

Various utility functions that make working with a region of cells easier.

Author:
Eric Pugh epugh@upstate.com

Method Summary
static void | setBorderBottom(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | setBorderBottom(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | setBorderLeft(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | setBorderLeft(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | setBorderRight(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderRight attribute of the HSSFRegionUtil object
static void | setBorderRight(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | setBorderTop(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | setBorderTop(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | setBottomBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the bottomBorderColor attribute of the HSSFRegionUtil object
static void | setBottomBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | setLeftBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the leftBorderColor attribute of the HSSFRegionUtil object
static void | setLeftBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | setRightBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the rightBorderColor attribute of the HSSFRegionUtil object
static void | setRightBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | setTopBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the topBorderColor attribute of the HSSFRegionUtil object
static void | setTopBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

setBorderLeft

public static void setBorderLeft(short border,
                                 Region region,
                                 HSSFSheet sheet,
                                 HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setBorderLeft

public static void setBorderLeft(int border,
                                 CellRangeAddress region,
                                 HSSFSheet sheet,
                                 HSSFWorkbook workbook)
Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setLeftBorderColor

public static void setLeftBorderColor(short color,
                                      Region region,
                                      HSSFSheet sheet,
                                      HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setLeftBorderColor

public static void setLeftBorderColor(int color,
                                      CellRangeAddress region,
                                      HSSFSheet sheet,
                                      HSSFWorkbook workbook)
Sets the leftBorderColor attribute of the HSSFRegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBorderRight

public static void setBorderRight(short border,
                                  Region region,
                                  HSSFSheet sheet,
                                  HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setBorderRight

public static void setBorderRight(int border,
                                  CellRangeAddress region,
                                  HSSFSheet sheet,
                                  HSSFWorkbook workbook)
Sets the borderRight attribute of the HSSFRegionUtil object

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setRightBorderColor

public static void setRightBorderColor(short color,
                                       Region region,
                                       HSSFSheet sheet,
                                       HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setRightBorderColor

public static void setRightBorderColor(int color,
                                       CellRangeAddress region,
                                       HSSFSheet sheet,
                                       HSSFWorkbook workbook)
Sets the rightBorderColor attribute of the HSSFRegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBorderBottom

public static void setBorderBottom(short border,
                                   Region region,
                                   HSSFSheet sheet,
                                   HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setBorderBottom

public static void setBorderBottom(int border,
                                   CellRangeAddress region,
                                   HSSFSheet sheet,
                                   HSSFWorkbook workbook)
Sets the borderBottom attribute of the HSSFRegionUtil object

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBottomBorderColor

public static void setBottomBorderColor(short color,
                                        Region region,
                                        HSSFSheet sheet,
                                        HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setBottomBorderColor

public static void setBottomBorderColor(int color,
                                        CellRangeAddress region,
                                        HSSFSheet sheet,
                                        HSSFWorkbook workbook)
Sets the bottomBorderColor attribute of the HSSFRegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBorderTop

public static void setBorderTop(short border,
                                Region region,
                                HSSFSheet sheet,
                                HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setBorderTop

public static void setBorderTop(int border,
                                CellRangeAddress region,
                                HSSFSheet sheet,
                                HSSFWorkbook workbook)
Sets the borderBottom attribute of the HSSFRegionUtil object

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setTopBorderColor

public static void setTopBorderColor(short color,
                                     Region region,
                                     HSSFSheet sheet,
                                     HSSFWorkbook workbook)
Deprecated. (Aug 2008) use CellRangeAddress instead of Region

setTopBorderColor

public static void setTopBorderColor(int color,
                                     CellRangeAddress region,
                                     HSSFSheet sheet,
                                     HSSFWorkbook workbook)
Sets the topBorderColor attribute of the HSSFRegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LazilyConcatenatedByteArray

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class LazilyConcatenatedByteArray

java.lang.Object
    extended by  org.apache.poi.hssf.util.LazilyConcatenatedByteArray

public class LazilyConcatenatedByteArray
extends java.lang.Object

Utility for delaying the concatenation of multiple byte arrays. Doing this up-front causes significantly more copying, which for a large number of byte arrays can cost a large amount of time.

Constructor Summary
LazilyConcatenatedByteArray()
Method Summary
void | clear() Clears the array (sets the concatenated length back to zero.
void | concatenate(byte[] array) Concatenates an array onto the end of our array.
byte[] | toArray() Gets the concatenated contents as a single byte array.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LazilyConcatenatedByteArray

public LazilyConcatenatedByteArray()
Method Detail

clear

public void clear()
Clears the array (sets the concatenated length back to zero.

concatenate

public void concatenate(byte[] array)
Concatenates an array onto the end of our array. This is a relatively fast operation.

Parameters:
array - the array to concatenate.
Throws:
java.lang.IllegalArgumentException - if array is null.

toArray

public byte[] toArray()
Gets the concatenated contents as a single byte array. This is a slower operation, but the concatenated array is stored off as a single array again so that subsequent calls will not perform additional copying.

Returns:
the byte array. Returns null if no data has been placed into it.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hssf.util
Classes
AreaReference
CellRangeAddress
CellRangeAddress8Bit
CellRangeAddressList
CellReference
HSSFCellUtil
HSSFColor
HSSFColor.AQUA
HSSFColor.AUTOMATIC
HSSFColor.BLACK
HSSFColor.BLUE
HSSFColor.BLUE_GREY
HSSFColor.BRIGHT_GREEN
HSSFColor.BROWN
HSSFColor.CORAL
HSSFColor.CORNFLOWER_BLUE
HSSFColor.DARK_BLUE
HSSFColor.DARK_GREEN
HSSFColor.DARK_RED
HSSFColor.DARK_TEAL
HSSFColor.DARK_YELLOW
HSSFColor.GOLD
HSSFColor.GREEN
HSSFColor.GREY_25_PERCENT
HSSFColor.GREY_40_PERCENT
HSSFColor.GREY_50_PERCENT
HSSFColor.GREY_80_PERCENT
HSSFColor.INDIGO
HSSFColor.LAVENDER
HSSFColor.LEMON_CHIFFON
HSSFColor.LIGHT_BLUE
HSSFColor.LIGHT_CORNFLOWER_BLUE
HSSFColor.LIGHT_GREEN
HSSFColor.LIGHT_ORANGE
HSSFColor.LIGHT_TURQUOISE
HSSFColor.LIGHT_YELLOW
HSSFColor.LIME
HSSFColor.MAROON
HSSFColor.OLIVE_GREEN
HSSFColor.ORANGE
HSSFColor.ORCHID
HSSFColor.PALE_BLUE
HSSFColor.PINK
HSSFColor.PLUM
HSSFColor.RED
HSSFColor.ROSE
HSSFColor.ROYAL_BLUE
HSSFColor.SEA_GREEN
HSSFColor.SKY_BLUE
HSSFColor.TAN
HSSFColor.TEAL
HSSFColor.TURQUOISE
HSSFColor.VIOLET
HSSFColor.WHITE
HSSFColor.YELLOW
HSSFRegionUtil
LazilyConcatenatedByteArray
PaneInformation
Region
RKUtil


org.apache.poi.hssf.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hssf.util

util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

See:
Description

Class Summary
AreaReference |
CellRangeAddress | Deprecated. use CellRangeAddress
CellRangeAddress8Bit | See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address' Like CellRangeAddress except column fields are 8-bit.
CellRangeAddressList | Deprecated. use CellRangeAddressList
CellReference | Common conversion functions between Excel style A1, C27 style cell references, and POI usermodel style row=0, column=0 style references.
HSSFCellUtil | Various utility functions that make working with a cells and rows easier.
HSSFColor | Intends to provide support for the very evil index to triplet issue and will likely replace the color constants interface for HSSF 2.0.
HSSFColor.AQUA | Class AQUA
HSSFColor.AUTOMATIC | Special Default/Normal/Automatic color.
HSSFColor.BLACK | Class BLACK
HSSFColor.BLUE | Class BLUE
HSSFColor.BLUE_GREY | Class BLUE_GREY
HSSFColor.BRIGHT_GREEN | Class BRIGHT_GREEN
HSSFColor.BROWN | Class BROWN
HSSFColor.CORAL | Class CORAL
HSSFColor.CORNFLOWER_BLUE | Class CORNFLOWER_BLUE
HSSFColor.DARK_BLUE | Class DARK_BLUE
HSSFColor.DARK_GREEN | Class DARK_GREEN
HSSFColor.DARK_RED | Class DARK_RED
HSSFColor.DARK_TEAL | Class DARK_TEAL
HSSFColor.DARK_YELLOW | Class DARK_YELLOW
HSSFColor.GOLD | Class GOLD
HSSFColor.GREEN | Class GREEN
HSSFColor.GREY_25_PERCENT | Class GREY_25_PERCENT
HSSFColor.GREY_40_PERCENT | Class GREY_40_PERCENT
HSSFColor.GREY_50_PERCENT | Class GREY_50_PERCENT
HSSFColor.GREY_80_PERCENT | Class GREY_80_PERCENT
HSSFColor.INDIGO | Class INDIGO
HSSFColor.LAVENDER | Class LAVENDER
HSSFColor.LEMON_CHIFFON | Class LEMON_CHIFFON
HSSFColor.LIGHT_BLUE | Class LIGHT_BLUE
HSSFColor.LIGHT_CORNFLOWER_BLUE | Class LIGHT_CORNFLOWER_BLUE
HSSFColor.LIGHT_GREEN | Class LIGHT_GREEN
HSSFColor.LIGHT_ORANGE | Class LIGHT_ORANGE
HSSFColor.LIGHT_TURQUOISE | Class LIGHT_TURQUOISE
HSSFColor.LIGHT_YELLOW | Class LIGHT_YELLOW
HSSFColor.LIME | Class LIME
HSSFColor.MAROON | Class MAROON
HSSFColor.OLIVE_GREEN | Class OLIVE_GREEN
HSSFColor.ORANGE | Class ORANGE
HSSFColor.ORCHID | Class ORCHID
HSSFColor.PALE_BLUE | Class PALE_BLUE
HSSFColor.PINK | Class PINK
HSSFColor.PLUM | Class PLUM
HSSFColor.RED | Class RED
HSSFColor.ROSE | Class ROSE
HSSFColor.ROYAL_BLUE | Class ROYAL_BLUE
HSSFColor.SEA_GREEN | Class SEA_GREEN
HSSFColor.SKY_BLUE | Class SKY_BLUE
HSSFColor.TAN | Class TAN
HSSFColor.TEAL | Class TEAL
HSSFColor.TURQUOISE | Class TURQUOISE
HSSFColor.VIOLET | Class VIOLET
HSSFColor.WHITE | Class WHITE
HSSFColor.YELLOW | Class YELLOW
HSSFRegionUtil | Various utility functions that make working with a region of cells easier.
LazilyConcatenatedByteArray | Utility for delaying the concatenation of multiple byte arrays.
PaneInformation | Holds information regarding a split plane or freeze plane for a sheet.
Region | Deprecated. (Aug-2008) use CellRangeAddress
RKUtil | Utility class for helping convert RK numbers.

Package org.apache.poi.hssf.util Description

util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.hssf.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hssf.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.util.AreaReference
      • org.apache.poi.hssf.util.AreaReference
    • org.apache.poi.ss.util.CellRangeAddressBase
      • org.apache.poi.ss.util.CellRangeAddress
        • org.apache.poi.hssf.util.CellRangeAddress
      • org.apache.poi.hssf.util.CellRangeAddress8Bit
    • org.apache.poi.ss.util.CellRangeAddressList
      • org.apache.poi.hssf.util.CellRangeAddressList
    • org.apache.poi.ss.util.CellReference
      • org.apache.poi.hssf.util.CellReference
    • org.apache.poi.hssf.util.HSSFCellUtil
    • org.apache.poi.hssf.util.HSSFColor (implements org.apache.poi.ss.usermodel.Color)
      • org.apache.poi.hssf.util.HSSFColor.AQUA
      • org.apache.poi.hssf.util.HSSFColor.AUTOMATIC
      • org.apache.poi.hssf.util.HSSFColor.BLACK
      • org.apache.poi.hssf.util.HSSFColor.BLUE
      • org.apache.poi.hssf.util.HSSFColor.BLUE_GREY
      • org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN
      • org.apache.poi.hssf.util.HSSFColor.BROWN
      • org.apache.poi.hssf.util.HSSFColor.CORAL
      • org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE
      • org.apache.poi.hssf.util.HSSFColor.DARK_BLUE
      • org.apache.poi.hssf.util.HSSFColor.DARK_GREEN
      • org.apache.poi.hssf.util.HSSFColor.DARK_RED
      • org.apache.poi.hssf.util.HSSFColor.DARK_TEAL
      • org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW
      • org.apache.poi.hssf.util.HSSFColor.GOLD
      • org.apache.poi.hssf.util.HSSFColor.GREEN
      • org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT
      • org.apache.poi.hssf.util.HSSFColor.INDIGO
      • org.apache.poi.hssf.util.HSSFColor.LAVENDER
      • org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE
      • org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW
      • org.apache.poi.hssf.util.HSSFColor.LIME
      • org.apache.poi.hssf.util.HSSFColor.MAROON
      • org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN
      • org.apache.poi.hssf.util.HSSFColor.ORANGE
      • org.apache.poi.hssf.util.HSSFColor.ORCHID
      • org.apache.poi.hssf.util.HSSFColor.PALE_BLUE
      • org.apache.poi.hssf.util.HSSFColor.PINK
      • org.apache.poi.hssf.util.HSSFColor.PLUM
      • org.apache.poi.hssf.util.HSSFColor.RED
      • org.apache.poi.hssf.util.HSSFColor.ROSE
      • org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE
      • org.apache.poi.hssf.util.HSSFColor.SEA_GREEN
      • org.apache.poi.hssf.util.HSSFColor.SKY_BLUE
      • org.apache.poi.hssf.util.HSSFColor.TAN
      • org.apache.poi.hssf.util.HSSFColor.TEAL
      • org.apache.poi.hssf.util.HSSFColor.TURQUOISE
      • org.apache.poi.hssf.util.HSSFColor.VIOLET
      • org.apache.poi.hssf.util.HSSFColor.WHITE
      • org.apache.poi.hssf.util.HSSFColor.YELLOW
    • org.apache.poi.hssf.util.HSSFRegionUtil
    • org.apache.poi.hssf.util.LazilyConcatenatedByteArray
    • org.apache.poi.hssf.util.PaneInformation
    • org.apache.poi.ss.util.Region (implements java.lang.Comparable<T>)
      • org.apache.poi.hssf.util.Region
    • org.apache.poi.hssf.util.RKUtil


Uses of Package org.apache.poi.hssf.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hssf.util

Packages that use org.apache.poi.hssf.util
org.apache.poi.hssf.converter |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Classes in org.apache.poi.hssf.util used by org.apache.poi.hssf.converter
HSSFColor
Intends to provide support for the very evil index to triplet issue and will likely replace the color constants interface for HSSF 2.0.

Classes in org.apache.poi.hssf.util used by org.apache.poi.hssf.model
PaneInformation
Holds information regarding a split plane or freeze plane for a sheet.

Classes in org.apache.poi.hssf.util used by org.apache.poi.hssf.record
CellRangeAddress8Bit
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Like CellRangeAddress except column fields are 8-bit.

Classes in org.apache.poi.hssf.util used by org.apache.poi.hssf.record.aggregates
CellRangeAddress8Bit
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Like CellRangeAddress except column fields are 8-bit.

Classes in org.apache.poi.hssf.util used by org.apache.poi.hssf.usermodel
HSSFColor
Intends to provide support for the very evil index to triplet issue and will likely replace the color constants interface for HSSF 2.0.
PaneInformation
Holds information regarding a split plane or freeze plane for a sheet.
Region
Deprecated. (Aug-2008) use CellRangeAddress

Classes in org.apache.poi.hssf.util used by org.apache.poi.hssf.util
CellRangeAddress8Bit
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Like CellRangeAddress except column fields are 8-bit.

CellReference
Common conversion functions between Excel style A1, C27 style cell references, and POI usermodel style row=0, column=0 style references.
HSSFColor
Intends to provide support for the very evil index to triplet issue and will likely replace the color constants interface for HSSF 2.0.
Region
Deprecated. (Aug-2008) use CellRangeAddress

Classes in org.apache.poi.hssf.util used by org.apache.poi.ss.usermodel
PaneInformation
Holds information regarding a split plane or freeze plane for a sheet.

Classes in org.apache.poi.hssf.util used by org.apache.poi.xssf.streaming
PaneInformation
Holds information regarding a split plane or freeze plane for a sheet.

Classes in org.apache.poi.hssf.util used by org.apache.poi.xssf.usermodel
PaneInformation
Holds information regarding a split plane or freeze plane for a sheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PaneInformation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class PaneInformation

java.lang.Object
    extended by  org.apache.poi.hssf.util.PaneInformation

public class PaneInformation
extends java.lang.Object

Holds information regarding a split plane or freeze plane for a sheet.

Field Summary
static byte | PANE_LOWER_LEFT Constant for active pane being the lower left
static byte | PANE_LOWER_RIGHT Constant for active pane being the lower right
static byte | PANE_UPPER_LEFT Constant for active pane being the upper left
static byte | PANE_UPPER_RIGHT Constant for active pane being the upper right
Constructor Summary
PaneInformation(short x, short y, short top, short left, byte active, boolean frozen)
Method Summary
byte | getActivePane() Returns the active pane
short | getHorizontalSplitPosition() Returns the horizontal position of the split.
short | getHorizontalSplitTopRow() For a horizontal split returns the top row in the BOTTOM pane.
short | getVerticalSplitLeftColumn() For a vertical split returns the left column in the RIGHT pane.
short | getVerticalSplitPosition() Returns the vertical position of the split.
boolean | isFreezePane() Returns true if this is a Freeze pane, false if it is a split pane.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PANE_LOWER_RIGHT

public static final byte PANE_LOWER_RIGHT
Constant for active pane being the lower right

See Also:
Constant Field Values

PANE_UPPER_RIGHT

public static final byte PANE_UPPER_RIGHT
Constant for active pane being the upper right

See Also:
Constant Field Values

PANE_LOWER_LEFT

public static final byte PANE_LOWER_LEFT
Constant for active pane being the lower left

See Also:
Constant Field Values

PANE_UPPER_LEFT

public static final byte PANE_UPPER_LEFT
Constant for active pane being the upper left

See Also:
Constant Field Values
Constructor Detail

PaneInformation

public PaneInformation(short x,
                       short y,
                       short top,
                       short left,
                       byte active,
                       boolean frozen)
Method Detail

getVerticalSplitPosition

public short getVerticalSplitPosition()
Returns the vertical position of the split.

Returns:
0 if there is no vertical spilt, or for a freeze pane the number of columns in the TOP pane, or for a split plane the position of the split in 1/20th of a point.

getHorizontalSplitPosition

public short getHorizontalSplitPosition()
Returns the horizontal position of the split.

Returns:
0 if there is no horizontal spilt, or for a freeze pane the number of rows in the LEFT pane, or for a split plane the position of the split in 1/20th of a point.

getHorizontalSplitTopRow

public short getHorizontalSplitTopRow()
For a horizontal split returns the top row in the BOTTOM pane.

Returns:
0 if there is no horizontal split, or the top row of the bottom pane.

getVerticalSplitLeftColumn

public short getVerticalSplitLeftColumn()
For a vertical split returns the left column in the RIGHT pane.

Returns:
0 if there is no vertical split, or the left column in the RIGHT pane.

getActivePane

public byte getActivePane()
Returns the active pane

Returns:
the active pane.
See Also:
PANE_LOWER_RIGHT, PANE_UPPER_RIGHT, PANE_LOWER_LEFT, PANE_UPPER_LEFT

isFreezePane

public boolean isFreezePane()
Returns true if this is a Freeze pane, false if it is a split pane.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Region

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class Region

java.lang.Object
    extended by  org.apache.poi.ss.util.Region
        extended by  org.apache.poi.hssf.util.Region
All Implemented Interfaces:
java.lang.Comparable<Region>
Deprecated. (Aug-2008) use CellRangeAddress

public class Region
extends Region

Represents a from/to row/col square. This is a object primitive that can be used to represent row,col - row,col just as one would use String to represent a string of characters. Its really only useful for HSSF though.

Author:
Andrew C. Oliver acoliver at apache dot org

Constructor Summary
Region()
Deprecated. Creates a new instance of Region (0,0 - 0,0)
Region(int rowFrom, short colFrom, int rowTo, short colTo)
Deprecated.
Region(java.lang.String ref)
Deprecated.
Method Summary
Methods inherited from class org.apache.poi.ss.util.Region
compareTo, contains, convertCellRangesToRegions, convertRegionsToCellRanges, convertToCellRangeAddress, equals, getArea, getColumnFrom, getColumnTo, getRegionRef, getRowFrom, getRowTo, setColumnFrom, setColumnTo, setRowFrom, setRowTo
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Region

public Region()
Deprecated.
Creates a new instance of Region (0,0 - 0,0)

Region

public Region(int rowFrom,
              short colFrom,
              int rowTo,
              short colTo)
Deprecated.

Region

public Region(java.lang.String ref)
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RKUtil

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hssf.util
Class RKUtil

java.lang.Object
    extended by  org.apache.poi.hssf.util.RKUtil

public final class RKUtil
extends java.lang.Object

Utility class for helping convert RK numbers.

Author:
Andrew C. Oliver (acoliver at apache dot org), Glen Stampoultzis (glens at apache.org), Rolf-J鰎gen Moll
See Also:
MulRKRecord, RKRecord

Method Summary
static double decodeNumber(int number)
Do the dirty work of decoding; made a private static method to facilitate testing the algorithm
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

decodeNumber

public static double decodeNumber(int number)
Do the dirty work of decoding; made a private static method to facilitate testing the algorithm

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hssf.util.AreaReference

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.AreaReference

No usage of org.apache.poi.hssf.util.AreaReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.CellRangeAddress

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.CellRangeAddress

No usage of org.apache.poi.hssf.util.CellRangeAddress

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.CellRangeAddress8Bit

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.CellRangeAddress8Bit

Packages that use CellRangeAddress8Bit
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of CellRangeAddress8Bit in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return CellRangeAddress8Bit
 CellRangeAddress8Bit SharedValueRecordBase.getRange()

Constructors in org.apache.poi.hssf.record with parameters of type CellRangeAddress8Bit
ArrayRecord(Formula formula, CellRangeAddress8Bit range)
SharedValueRecordBase(CellRangeAddress8Bit range)
TableRecord(CellRangeAddress8Bit range)

Uses of CellRangeAddress8Bit in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return CellRangeAddress8Bit
 CellRangeAddress8Bit SharedValueManager.removeArrayFormula(int rowIndex, int columnIndex)
Removes the ArrayRecord for the cell group containing the specified cell.

Uses of CellRangeAddress8Bit in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util that return CellRangeAddress8Bit
 CellRangeAddress8Bit CellRangeAddress8Bit.copy()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.CellRangeAddressList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.CellRangeAddressList

No usage of org.apache.poi.hssf.util.CellRangeAddressList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.CellReference

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.CellReference

Packages that use CellReference
org.apache.poi.hssf.util util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of CellReference in org.apache.poi.hssf.util

Constructors in org.apache.poi.hssf.util with parameters of type CellReference
AreaReference(CellReference topLeft, CellReference botRight)
Creates an area ref from a pair of Cell References.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFCellUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFCellUtil

No usage of org.apache.poi.hssf.util.HSSFCellUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.AQUA

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.AQUA

No usage of org.apache.poi.hssf.util.HSSFColor.AQUA

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

No usage of org.apache.poi.hssf.util.HSSFColor.AUTOMATIC

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.BLACK

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.BLACK

No usage of org.apache.poi.hssf.util.HSSFColor.BLACK

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

No usage of org.apache.poi.hssf.util.HSSFColor.BLUE_GREY

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

No usage of org.apache.poi.hssf.util.HSSFColor.BRIGHT_GREEN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.BROWN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.BROWN

No usage of org.apache.poi.hssf.util.HSSFColor.BROWN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.CORAL

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.CORAL

No usage of org.apache.poi.hssf.util.HSSFColor.CORAL

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.CORNFLOWER_BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.DARK_BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

No usage of org.apache.poi.hssf.util.HSSFColor.DARK_GREEN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.DARK_RED

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.DARK_RED

No usage of org.apache.poi.hssf.util.HSSFColor.DARK_RED

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

No usage of org.apache.poi.hssf.util.HSSFColor.DARK_TEAL

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

No usage of org.apache.poi.hssf.util.HSSFColor.DARK_YELLOW

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.GOLD

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.GOLD

No usage of org.apache.poi.hssf.util.HSSFColor.GOLD

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.GREEN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.GREEN

No usage of org.apache.poi.hssf.util.HSSFColor.GREEN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

No usage of org.apache.poi.hssf.util.HSSFColor.GREY_25_PERCENT

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

No usage of org.apache.poi.hssf.util.HSSFColor.GREY_40_PERCENT

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

No usage of org.apache.poi.hssf.util.HSSFColor.GREY_50_PERCENT

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

No usage of org.apache.poi.hssf.util.HSSFColor.GREY_80_PERCENT

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor

Packages that use HSSFColor
org.apache.poi.hssf.converter |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of HSSFColor in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type HSSFColor
static java.lang.String AbstractExcelUtils.getColor(HSSFColor color)

Uses of HSSFColor in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return HSSFColor
HSSFColor | HSSFPalette.addColor(byte red, byte green, byte blue) Adds a new color into an empty color slot.
HSSFColor | HSSFPalette.findColor(byte red, byte green, byte blue) Finds the first occurance of a given color
HSSFColor | HSSFPalette.findSimilarColor(byte red, byte green, byte blue) Finds the closest matching color in the custom palette.
HSSFColor | HSSFPalette.findSimilarColor(int red, int green, int blue) Finds the closest matching color in the custom palette.
HSSFColor | HSSFPalette.getColor(int index) Retrieves the color at a given index
HSSFColor | HSSFPalette.getColor(short index) Retrieves the color at a given index
HSSFColor | HSSFCellStyle.getFillBackgroundColorColor()
HSSFColor | HSSFCellStyle.getFillForegroundColorColor()
HSSFColor | HSSFFont.getHSSFColor(HSSFWorkbook wb) get the color value for the font

Uses of HSSFColor in org.apache.poi.hssf.util

Subclasses of HSSFColor in org.apache.poi.hssf.util
static class | HSSFColor.AQUA Class AQUA
static class | HSSFColor.AUTOMATIC Special Default/Normal/Automatic color.
static class | HSSFColor.BLACK Class BLACK
static class | HSSFColor.BLUE Class BLUE
static class | HSSFColor.BLUE_GREY Class BLUE_GREY
static class | HSSFColor.BRIGHT_GREEN Class BRIGHT_GREEN
static class | HSSFColor.BROWN Class BROWN
static class | HSSFColor.CORAL Class CORAL
static class | HSSFColor.CORNFLOWER_BLUE Class CORNFLOWER_BLUE
static class | HSSFColor.DARK_BLUE Class DARK_BLUE
static class | HSSFColor.DARK_GREEN Class DARK_GREEN
static class | HSSFColor.DARK_RED Class DARK_RED
static class | HSSFColor.DARK_TEAL Class DARK_TEAL
static class | HSSFColor.DARK_YELLOW Class DARK_YELLOW
static class | HSSFColor.GOLD Class GOLD
static class | HSSFColor.GREEN Class GREEN
static class | HSSFColor.GREY_25_PERCENT Class GREY_25_PERCENT
static class | HSSFColor.GREY_40_PERCENT Class GREY_40_PERCENT
static class | HSSFColor.GREY_50_PERCENT Class GREY_50_PERCENT
static class | HSSFColor.GREY_80_PERCENT Class GREY_80_PERCENT
static class | HSSFColor.INDIGO Class INDIGO
static class | HSSFColor.LAVENDER Class LAVENDER
static class | HSSFColor.LEMON_CHIFFON Class LEMON_CHIFFON
static class | HSSFColor.LIGHT_BLUE Class LIGHT_BLUE
static class | HSSFColor.LIGHT_CORNFLOWER_BLUE Class LIGHT_CORNFLOWER_BLUE
static class | HSSFColor.LIGHT_GREEN Class LIGHT_GREEN
static class | HSSFColor.LIGHT_ORANGE Class LIGHT_ORANGE
static class | HSSFColor.LIGHT_TURQUOISE Class LIGHT_TURQUOISE
static class | HSSFColor.LIGHT_YELLOW Class LIGHT_YELLOW
static class | HSSFColor.LIME Class LIME
static class | HSSFColor.MAROON Class MAROON
static class | HSSFColor.OLIVE_GREEN Class OLIVE_GREEN
static class | HSSFColor.ORANGE Class ORANGE
static class | HSSFColor.ORCHID Class ORCHID
static class | HSSFColor.PALE_BLUE Class PALE_BLUE
static class | HSSFColor.PINK Class PINK
static class | HSSFColor.PLUM Class PLUM
static class | HSSFColor.RED Class RED
static class | HSSFColor.ROSE Class ROSE
static class | HSSFColor.ROYAL_BLUE Class ROYAL_BLUE
static class | HSSFColor.SEA_GREEN Class SEA_GREEN
static class | HSSFColor.SKY_BLUE Class SKY_BLUE
static class | HSSFColor.TAN Class TAN
static class | HSSFColor.TEAL Class TEAL
static class | HSSFColor.TURQUOISE Class TURQUOISE
static class | HSSFColor.VIOLET Class VIOLET
static class | HSSFColor.WHITE Class WHITE
static class | HSSFColor.YELLOW Class YELLOW

Methods in org.apache.poi.hssf.util that return HSSFColor
static HSSFColor HSSFColor.AUTOMATIC.getInstance()

Methods in org.apache.poi.hssf.util that return types with arguments of type HSSFColor
static java.util.Map<java.lang.Integer,HSSFColor> | HSSFColor.getIndexHash() This function returns all the colours in an unmodifiable Map.
static java.util.Hashtable<java.lang.Integer,HSSFColor> | HSSFColor.getMutableIndexHash() This function returns all the Colours, stored in a Hashtable that can be edited.
static java.util.Hashtable<java.lang.String,HSSFColor> | HSSFColor.getTripletHash() this function returns all colors in a hastable.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.INDIGO

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.INDIGO

No usage of org.apache.poi.hssf.util.HSSFColor.INDIGO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LAVENDER

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LAVENDER

No usage of org.apache.poi.hssf.util.HSSFColor.LAVENDER

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

No usage of org.apache.poi.hssf.util.HSSFColor.LEMON_CHIFFON

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.LIGHT_BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.LIGHT_CORNFLOWER_BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

No usage of org.apache.poi.hssf.util.HSSFColor.LIGHT_GREEN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

No usage of org.apache.poi.hssf.util.HSSFColor.LIGHT_ORANGE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

No usage of org.apache.poi.hssf.util.HSSFColor.LIGHT_TURQUOISE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

No usage of org.apache.poi.hssf.util.HSSFColor.LIGHT_YELLOW

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.LIME

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.LIME

No usage of org.apache.poi.hssf.util.HSSFColor.LIME

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.MAROON

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.MAROON

No usage of org.apache.poi.hssf.util.HSSFColor.MAROON

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

No usage of org.apache.poi.hssf.util.HSSFColor.OLIVE_GREEN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.ORANGE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.ORANGE

No usage of org.apache.poi.hssf.util.HSSFColor.ORANGE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.ORCHID

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.ORCHID

No usage of org.apache.poi.hssf.util.HSSFColor.ORCHID

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.PALE_BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.PINK

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.PINK

No usage of org.apache.poi.hssf.util.HSSFColor.PINK

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.PLUM

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.PLUM

No usage of org.apache.poi.hssf.util.HSSFColor.PLUM

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.RED

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.RED

No usage of org.apache.poi.hssf.util.HSSFColor.RED

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.ROSE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.ROSE

No usage of org.apache.poi.hssf.util.HSSFColor.ROSE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.ROYAL_BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

No usage of org.apache.poi.hssf.util.HSSFColor.SEA_GREEN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

No usage of org.apache.poi.hssf.util.HSSFColor.SKY_BLUE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.TAN

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.TAN

No usage of org.apache.poi.hssf.util.HSSFColor.TAN

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.TEAL

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.TEAL

No usage of org.apache.poi.hssf.util.HSSFColor.TEAL

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.TURQUOISE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.TURQUOISE

No usage of org.apache.poi.hssf.util.HSSFColor.TURQUOISE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.VIOLET

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.VIOLET

No usage of org.apache.poi.hssf.util.HSSFColor.VIOLET

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.WHITE

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.WHITE

No usage of org.apache.poi.hssf.util.HSSFColor.WHITE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFColor.YELLOW

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFColor.YELLOW

No usage of org.apache.poi.hssf.util.HSSFColor.YELLOW

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.HSSFRegionUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.HSSFRegionUtil

No usage of org.apache.poi.hssf.util.HSSFRegionUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.LazilyConcatenatedByteArray

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.LazilyConcatenatedByteArray

No usage of org.apache.poi.hssf.util.LazilyConcatenatedByteArray

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.PaneInformation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.PaneInformation

Packages that use PaneInformation
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of PaneInformation in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return PaneInformation
 PaneInformation InternalSheet.getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).

Uses of PaneInformation in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return PaneInformation
 PaneInformation HSSFSheet.getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).

Uses of PaneInformation in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PaneInformation
 PaneInformation Sheet.getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze)

Uses of PaneInformation in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return PaneInformation
 PaneInformation SXSSFSheet.getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze)

Uses of PaneInformation in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return PaneInformation
 PaneInformation XSSFSheet.getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.Region

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.Region

Packages that use Region
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.

Uses of Region in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return Region
 Region HSSFSheet.getMergedRegionAt(int index)
Deprecated. (Aug-2008) use HSSFSheet.getMergedRegion(int)

Uses of Region in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util with parameters of type Region
static void | HSSFRegionUtil.setBorderBottom(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderLeft(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderRight(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBorderTop(short border, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setBottomBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setLeftBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setRightBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region
static void | HSSFRegionUtil.setTopBorderColor(short color, Region region, HSSFSheet sheet, HSSFWorkbook workbook) Deprecated. (Aug 2008) use CellRangeAddress instead of Region

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hssf.util.RKUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hssf.util.RKUtil

No usage of org.apache.poi.hssf.util.RKUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HWPFDocument

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf
Class HWPFDocument

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hwpf.HWPFDocumentCore
            extended by  org.apache.poi.hwpf.HWPFDocument

public final class HWPFDocument
extends HWPFDocumentCore

This class acts as the bucket that we throw all of the Word data structures into.

Author:
Ryan Ackley

Field Summary
protected Bookmarks | _bookmarks Holds the bookmarks
protected BookmarksTables | _bookmarksTables Holds the bookmarks tables
protected ComplexFileTable | _cft Contains text of the document wrapped in a obfuscated Word data structure
protected byte[] | _dataStream data stream buffer
protected DocumentProperties | _dop Document wide Properties
protected Notes | _endnotes Holds the footnotes
protected NotesTables | _endnotesTables Holds the ending notes tables
protected EscherRecordHolder | _escherRecordHolder Escher Drawing Group information
protected Fields | _fields Holds the fields
protected FieldsTables | _fieldsTables Holds the fields PLCFs
protected Notes | _footnotes Holds the footnotes
protected NotesTables | _footnotesTables Holds the footnotes tables
protected ShapesTable | _officeArts Deprecated.
protected OfficeDrawingsImpl | _officeDrawingsHeaders Holds Office Art objects
protected OfficeDrawingsImpl | _officeDrawingsMain Holds Office Art objects
protected PicturesTable | _pictures Holds pictures table
protected RevisionMarkAuthorTable | _rmat Holds the revision mark authors for this document.
protected SavedByTable | _sbt Holds the save history for this document.
protected byte[] | _tableStream table stream buffer
protected java.lang.StringBuilder | _text Contains text buffer linked directly to single-piece document text piece
Fields inherited from class org.apache.poi.hwpf.HWPFDocumentCore
_cbt, _fib, _ft, _lt, _mainStream, _objectPool, _pbt, _ss, _st, STREAM_OBJECT_POOL, STREAM_WORD_DOCUMENT
Fields inherited from class org.apache.poi.POIDocument
directory
Constructor Summary
protected | HWPFDocument()
 | HWPFDocument(DirectoryNode directory) This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default.
 | HWPFDocument(DirectoryNode directory, POIFSFileSystem pfilesystem) Deprecated. Use HWPFDocument(DirectoryNode) instead
 | HWPFDocument(java.io.InputStream istream) This constructor loads a Word document from an InputStream.
 | HWPFDocument(POIFSFileSystem pfilesystem) This constructor loads a Word document from a POIFSFileSystem
Method Summary
 int characterLength()
Returns the character length of a document.
 void delete(int start, int length)
 Bookmarks getBookmarks()
 Range getCommentsRange()
Returns the Range which covers all annotations.
 byte[] getDataStream()
 DocumentProperties getDocProperties()
 Range getEndnoteRange()
Returns the Range which covers all endnotes.
 Notes getEndnotes()
 EscherRecordHolder getEscherRecordHolder()
 Fields getFields()
Returns user-friendly interface to access document Fields
 FieldsTables getFieldsTables()
Deprecated.
 Range getFootnoteRange()
Returns the Range which covers all the Footnotes.
 Notes getFootnotes()
 Range getHeaderStoryRange()
Returns the range which covers all "Header Stories".
 Range getMainTextboxRange()
Returns the Range which covers all textboxes.
 OfficeDrawings getOfficeDrawingsHeaders()
 OfficeDrawings getOfficeDrawingsMain()
 Range getOverallRange()
Returns the range that covers all text in the file, including main text, footnotes, headers and comments
 PicturesTable getPicturesTable()
 Range getRange()
Returns the range which covers the whole of the document, but excludes any headers and footers.
 RevisionMarkAuthorTable getRevisionMarkAuthorTable()
Gets a reference to the revision mark author table, which holds the revision mark authors for the document.
 SavedByTable getSavedByTable()
Gets a reference to the saved -by table, which holds the save history for the document.
 ShapesTable getShapesTable()
Deprecated. use getOfficeDrawingsMain() instead
 byte[] getTableStream()
 java.lang.StringBuilder getText()
Internal method to access document text
 TextPieceTable getTextTable()
 int registerList(HWPFList list)
 void write(java.io.OutputStream out)
Writes out the word file that is represented by an instance of this class.
Methods inherited from class org.apache.poi.hwpf.HWPFDocumentCore
getCharacterTable, getDocumentText, getFileInformationBlock, getFontTable, getListTables, getObjectsPool, getParagraphTable, getSectionTable, getStyleSheet, verifyAndBuildPOIFS
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_tableStream

protected byte[] _tableStream
table stream buffer

_dataStream

protected byte[] _dataStream
data stream buffer

_dop

protected DocumentProperties _dop
Document wide Properties

_cft

protected ComplexFileTable _cft
Contains text of the document wrapped in a obfuscated Word data structure

_text

protected java.lang.StringBuilder _text
Contains text buffer linked directly to single-piece document text piece

_sbt

protected SavedByTable _sbt
Holds the save history for this document.

_rmat

protected RevisionMarkAuthorTable _rmat
Holds the revision mark authors for this document.

_escherRecordHolder

protected EscherRecordHolder _escherRecordHolder
Escher Drawing Group information

_pictures

protected PicturesTable _pictures
Holds pictures table

_officeArts

@Deprecated
protected ShapesTable _officeArts
Deprecated.
Holds Office Art objects

_officeDrawingsHeaders

protected OfficeDrawingsImpl _officeDrawingsHeaders
Holds Office Art objects

_officeDrawingsMain

protected OfficeDrawingsImpl _officeDrawingsMain
Holds Office Art objects

_bookmarksTables

protected BookmarksTables _bookmarksTables
Holds the bookmarks tables

_bookmarks

protected Bookmarks _bookmarks
Holds the bookmarks

_endnotesTables

protected NotesTables _endnotesTables
Holds the ending notes tables

_endnotes

protected Notes _endnotes
Holds the footnotes

_footnotesTables

protected NotesTables _footnotesTables
Holds the footnotes tables

_footnotes

protected Notes _footnotes
Holds the footnotes

_fieldsTables

protected FieldsTables _fieldsTables
Holds the fields PLCFs

_fields

protected Fields _fields
Holds the fields

Constructor Detail

HWPFDocument

protected HWPFDocument()

HWPFDocument

public HWPFDocument(java.io.InputStream istream)
             throws java.io.IOException
This constructor loads a Word document from an InputStream.

Parameters:
istream - The InputStream that contains the Word document.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in InputStream.

HWPFDocument

public HWPFDocument(POIFSFileSystem pfilesystem)
             throws java.io.IOException
This constructor loads a Word document from a POIFSFileSystem

Parameters:
pfilesystem - The POIFSFileSystem that contains the Word document.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in POIFSFileSystem.

HWPFDocument

@Deprecated
public HWPFDocument(DirectoryNode directory,
                               POIFSFileSystem pfilesystem)
             throws java.io.IOException
Deprecated. Use HWPFDocument(DirectoryNode) instead

This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default. Used typically to open embedded documents.

Parameters:
pfilesystem - The POIFSFileSystem that contains the Word document.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in POIFSFileSystem.

HWPFDocument

public HWPFDocument(DirectoryNode directory)
             throws java.io.IOException
This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default. Used typically to open embeded documents.

Parameters:
directory - The DirectoryNode that contains the Word document.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in POIFSFileSystem.
Method Detail

getTextTable

@Internal
public TextPieceTable getTextTable()
Specified by:
getTextTable in class HWPFDocumentCore

getText

@Internal
public java.lang.StringBuilder getText()
Description copied from class: HWPFDocumentCore
Internal method to access document text

Specified by:
getText in class HWPFDocumentCore

getDocProperties

public DocumentProperties getDocProperties()

getOverallRange

public Range getOverallRange()
Description copied from class: HWPFDocumentCore
Returns the range that covers all text in the file, including main text, footnotes, headers and comments

Specified by:
getOverallRange in class HWPFDocumentCore

getRange

public Range getRange()
Returns the range which covers the whole of the document, but excludes any headers and footers.

Specified by:
getRange in class HWPFDocumentCore

getFootnoteRange

public Range getFootnoteRange()
Returns the Range which covers all the Footnotes.

Returns:
the Range which covers all the Footnotes.

getEndnoteRange

public Range getEndnoteRange()
Returns the Range which covers all endnotes.

Returns:
the Range which covers all endnotes.

getCommentsRange

public Range getCommentsRange()
Returns the Range which covers all annotations.

Returns:
the Range which covers all annotations.

getMainTextboxRange

public Range getMainTextboxRange()
Returns the Range which covers all textboxes.

Returns:
the Range which covers all textboxes.

getHeaderStoryRange

public Range getHeaderStoryRange()
Returns the range which covers all "Header Stories". A header story contains a header, footer, end note separators and footnote separators.

characterLength

public int characterLength()
Returns the character length of a document.

Returns:
the character length of a document

getSavedByTable

@Internal
public SavedByTable getSavedByTable()
Gets a reference to the saved -by table, which holds the save history for the document.

Returns:
the saved-by table.

getRevisionMarkAuthorTable

@Internal
public RevisionMarkAuthorTable getRevisionMarkAuthorTable()
Gets a reference to the revision mark author table, which holds the revision mark authors for the document.

Returns:
the saved-by table.

getPicturesTable

public PicturesTable getPicturesTable()
Returns:
PicturesTable object, that is able to extract images from this document

getEscherRecordHolder

@Internal
public EscherRecordHolder getEscherRecordHolder()

getShapesTable

@Deprecated
@Internal
public ShapesTable getShapesTable()
Deprecated. use getOfficeDrawingsMain() instead

Returns:
ShapesTable object, that is able to extract office are shapes from this document

getOfficeDrawingsHeaders

public OfficeDrawings getOfficeDrawingsHeaders()

getOfficeDrawingsMain

public OfficeDrawings getOfficeDrawingsMain()

getBookmarks

public Bookmarks getBookmarks()
Returns:
user-friendly interface to access document bookmarks

getEndnotes

public Notes getEndnotes()
Returns:
user-friendly interface to access document endnotes

getFootnotes

public Notes getFootnotes()
Returns:
user-friendly interface to access document footnotes

getFieldsTables

@Deprecated
@Internal
public FieldsTables getFieldsTables()
Deprecated.

Returns:
FieldsTables object, that is able to extract fields descriptors from this document

getFields

public Fields getFields()
Returns user-friendly interface to access document Fields

Returns:
user-friendly interface to access document Fields

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Writes out the word file that is represented by an instance of this class.

Specified by:
write in class POIDocument
Parameters:
out - The OutputStream to write to.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in OutputStream.

getDataStream

@Internal
public byte[] getDataStream()

getTableStream

@Internal
public byte[] getTableStream()

registerList

public int registerList(HWPFList list)

delete

public void delete(int start,
                   int length)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HWPFDocumentCore

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf
Class HWPFDocumentCore

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hwpf.HWPFDocumentCore
Direct Known Subclasses:
HWPFDocument, HWPFOldDocument
public abstract class HWPFDocumentCore
extends POIDocument

This class holds much of the core of a Word document, but without some of the table structure information. You generally want to work with one of HWPFDocument or HWPFOldDocument

Field Summary
protected CHPBinTable | _cbt Contains formatting properties for text
protected FileInformationBlock | _fib The FIB
protected FontTable | _ft Holds fonts for this document.
protected ListTables | _lt Hold list tables
protected byte[] | _mainStream main document stream buffer
protected ObjectPoolImpl | _objectPool Holds OLE2 objects
protected PAPBinTable | _pbt Contains formatting properties for paragraphs
protected StyleSheet | _ss Holds styles for this document.
protected SectionTable | _st Contains formatting properties for sections.
protected static java.lang.String | STREAM_OBJECT_POOL
protected static java.lang.String | STREAM_WORD_DOCUMENT
Fields inherited from class org.apache.poi.POIDocument
directory
Constructor Summary
protected | HWPFDocumentCore()
 | HWPFDocumentCore(DirectoryNode directory) This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default.
 | HWPFDocumentCore(java.io.InputStream istream) This constructor loads a Word document from an InputStream.
 | HWPFDocumentCore(POIFSFileSystem pfilesystem) This constructor loads a Word document from a POIFSFileSystem
Method Summary
CHPBinTable | getCharacterTable()
java.lang.String | getDocumentText() Returns document text, i.e.
FileInformationBlock | getFileInformationBlock()
FontTable | getFontTable()
ListTables | getListTables()
ObjectsPool | getObjectsPool()
abstract Range | getOverallRange() Returns the range that covers all text in the file, including main text, footnotes, headers and comments
PAPBinTable | getParagraphTable()
abstract Range | getRange() Returns the range which covers the whole of the document, but excludes any headers and footers.
SectionTable | getSectionTable()
StyleSheet | getStyleSheet()
abstract java.lang.StringBuilder | getText() Internal method to access document text
abstract TextPieceTable | getTextTable()
static POIFSFileSystem | verifyAndBuildPOIFS(java.io.InputStream istream) Takens an InputStream, verifies that it's not RTF, builds a POIFSFileSystem from it, and returns that.
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, write, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STREAM_OBJECT_POOL

protected static final java.lang.String STREAM_OBJECT_POOL
See Also:
Constant Field Values

STREAM_WORD_DOCUMENT

protected static final java.lang.String STREAM_WORD_DOCUMENT
See Also:
Constant Field Values

_objectPool

protected ObjectPoolImpl _objectPool
Holds OLE2 objects

_fib

protected FileInformationBlock _fib
The FIB

_ss

protected StyleSheet _ss
Holds styles for this document.

_cbt

protected CHPBinTable _cbt
Contains formatting properties for text

_pbt

protected PAPBinTable _pbt
Contains formatting properties for paragraphs

_st

protected SectionTable _st
Contains formatting properties for sections.

_ft

protected FontTable _ft
Holds fonts for this document.

_lt

protected ListTables _lt
Hold list tables

_mainStream

protected byte[] _mainStream
main document stream buffer

Constructor Detail

HWPFDocumentCore

protected HWPFDocumentCore()

HWPFDocumentCore

public HWPFDocumentCore(java.io.InputStream istream)
                 throws java.io.IOException
This constructor loads a Word document from an InputStream.

Parameters:
istream - The InputStream that contains the Word document.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in InputStream.

HWPFDocumentCore

public HWPFDocumentCore(POIFSFileSystem pfilesystem)
                 throws java.io.IOException
This constructor loads a Word document from a POIFSFileSystem

Parameters:
pfilesystem - The POIFSFileSystem that contains the Word document.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in POIFSFileSystem.

HWPFDocumentCore

public HWPFDocumentCore(DirectoryNode directory)
                 throws java.io.IOException
This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default. Used typically to open embeded documents.

Parameters:
directory - The DirectoryNode that contains the Word document.
Throws:
java.io.IOException - If there is an unexpected IOException from the passed in POIFSFileSystem.
Method Detail

verifyAndBuildPOIFS

public static POIFSFileSystem verifyAndBuildPOIFS(java.io.InputStream istream)
                                           throws java.io.IOException
Takens an InputStream, verifies that it's not RTF, builds a POIFSFileSystem from it, and returns that.

Throws:
java.io.IOException

getRange

public abstract Range getRange()
Returns the range which covers the whole of the document, but excludes any headers and footers.

getOverallRange

public abstract Range getOverallRange()
Returns the range that covers all text in the file, including main text, footnotes, headers and comments

getDocumentText

public java.lang.String getDocumentText()
Returns document text, i.e. text information from all text pieces, including OLE descriptions and field codes

getText

@Internal
public abstract java.lang.StringBuilder getText()
Internal method to access document text

getCharacterTable

public CHPBinTable getCharacterTable()

getParagraphTable

public PAPBinTable getParagraphTable()

getSectionTable

public SectionTable getSectionTable()

getStyleSheet

public StyleSheet getStyleSheet()

getListTables

public ListTables getListTables()

getFontTable

public FontTable getFontTable()

getFileInformationBlock

public FileInformationBlock getFileInformationBlock()

getObjectsPool

public ObjectsPool getObjectsPool()

getTextTable

public abstract TextPieceTable getTextTable()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HWPFOldDocument

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf
Class HWPFOldDocument

java.lang.Object
    extended by  org.apache.poi.POIDocument
        extended by  org.apache.poi.hwpf.HWPFDocumentCore
            extended by  org.apache.poi.hwpf.HWPFOldDocument

public class HWPFOldDocument
extends HWPFDocumentCore

Provides very simple support for old (Word 6 / Word 95) files.

Field Summary
Fields inherited from class org.apache.poi.hwpf.HWPFDocumentCore
_cbt, _fib, _ft, _lt, _mainStream, _objectPool, _pbt, _ss, _st, STREAM_OBJECT_POOL, STREAM_WORD_DOCUMENT
Fields inherited from class org.apache.poi.POIDocument
directory
Constructor Summary
HWPFOldDocument(DirectoryNode directory)
HWPFOldDocument(DirectoryNode directory, POIFSFileSystem fs)
Deprecated.
HWPFOldDocument(POIFSFileSystem fs)
Method Summary
Range | getOverallRange() Returns the range that covers all text in the file, including main text, footnotes, headers and comments
Range | getRange() Returns the range which covers the whole of the document, but excludes any headers and footers.
java.lang.StringBuilder | getText() Internal method to access document text
TextPieceTable | getTextTable()
void | write(java.io.OutputStream out) Writes the document out to the specified output stream
Methods inherited from class org.apache.poi.hwpf.HWPFDocumentCore
getCharacterTable, getDocumentText, getFileInformationBlock, getFontTable, getListTables, getObjectsPool, getParagraphTable, getSectionTable, getStyleSheet, verifyAndBuildPOIFS
Methods inherited from class org.apache.poi.POIDocument
copyNodeRecursively, copyNodes, copyNodes, createInformationProperties, getDocumentSummaryInformation, getPropertySet, getSummaryInformation, readProperties, writeProperties, writeProperties, writePropertySet
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HWPFOldDocument

public HWPFOldDocument(POIFSFileSystem fs)
                throws java.io.IOException
Throws:
java.io.IOException

HWPFOldDocument

@Deprecated
public HWPFOldDocument(DirectoryNode directory,
                                  POIFSFileSystem fs)
                throws java.io.IOException
Deprecated.

Throws:
java.io.IOException

HWPFOldDocument

public HWPFOldDocument(DirectoryNode directory)
                throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getOverallRange

public Range getOverallRange()
Description copied from class: HWPFDocumentCore
Returns the range that covers all text in the file, including main text, footnotes, headers and comments

Specified by:
getOverallRange in class HWPFDocumentCore

getRange

public Range getRange()
Description copied from class: HWPFDocumentCore
Returns the range which covers the whole of the document, but excludes any headers and footers.

Specified by:
getRange in class HWPFDocumentCore

getTextTable

public TextPieceTable getTextTable()
Specified by:
getTextTable in class HWPFDocumentCore

getText

public java.lang.StringBuilder getText()
Description copied from class: HWPFDocumentCore
Internal method to access document text

Specified by:
getText in class HWPFDocumentCore

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Description copied from class: POIDocument
Writes the document out to the specified output stream

Specified by:
write in class POIDocument
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OldWordFileFormatException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf
Class OldWordFileFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalArgumentException
                    extended by  org.apache.poi.OldFileFormatException
                        extended by  org.apache.poi.hwpf.OldWordFileFormatException
All Implemented Interfaces:
java.io.Serializable
public class OldWordFileFormatException
extends OldFileFormatException

See Also:
Serialized Form

Constructor Summary
OldWordFileFormatException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OldWordFileFormatException

public OldWordFileFormatException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf
Classes
HWPFDocument
HWPFDocumentCore
HWPFOldDocument
QuickTest
Exceptions
OldWordFileFormatException


org.apache.poi.hwpf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf

Class Summary
HWPFDocument | This class acts as the bucket that we throw all of the Word data structures into.
HWPFDocumentCore | This class holds much of the core of a Word document, but without some of the table structure information.
HWPFOldDocument | Provides very simple support for old (Word 6 / Word 95) files.
QuickTest |

Exception Summary
OldWordFileFormatException


org.apache.poi.hwpf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POIDocument
      • org.apache.poi.hwpf.HWPFDocumentCore
        • org.apache.poi.hwpf.HWPFDocument
        • org.apache.poi.hwpf.HWPFOldDocument
    • org.apache.poi.hwpf.QuickTest
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • org.apache.poi.OldFileFormatException
              • org.apache.poi.hwpf.OldWordFileFormatException


Uses of Package org.apache.poi.hwpf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf

Packages that use org.apache.poi.hwpf
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.extractor
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf used by org.apache.poi.hwpf
HWPFDocumentCore
This class holds much of the core of a Word document, but without some of the table structure information.

Classes in org.apache.poi.hwpf used by org.apache.poi.hwpf.converter
HWPFDocument
This class acts as the bucket that we throw all of the Word data structures into.
HWPFDocumentCore
This class holds much of the core of a Word document, but without some of the table structure information.

Classes in org.apache.poi.hwpf used by org.apache.poi.hwpf.dev
HWPFDocumentCore
This class holds much of the core of a Word document, but without some of the table structure information.

Classes in org.apache.poi.hwpf used by org.apache.poi.hwpf.extractor
HWPFDocument
This class acts as the bucket that we throw all of the Word data structures into.
HWPFOldDocument
Provides very simple support for old (Word 6 / Word 95) files.

Classes in org.apache.poi.hwpf used by org.apache.poi.hwpf.model
HWPFDocument
This class acts as the bucket that we throw all of the Word data structures into.

Classes in org.apache.poi.hwpf used by org.apache.poi.hwpf.usermodel
HWPFDocument
This class acts as the bucket that we throw all of the Word data structures into.
HWPFDocumentCore
This class holds much of the core of a Word document, but without some of the table structure information.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


QuickTest

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf
Class QuickTest

java.lang.Object
    extended by  org.apache.poi.hwpf.QuickTest

public final class QuickTest
extends java.lang.Object

Constructor Summary
QuickTest()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QuickTest

public QuickTest()
Method Detail

main

public static void main(java.lang.String[] args)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hwpf.HWPFDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.HWPFDocument

Packages that use HWPFDocument
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.extractor
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of HWPFDocument in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type HWPFDocument
protected void | AbstractWordConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, org.w3c.dom.Element block)
protected void | WordToTextConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToHtmlConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToFoConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected abstract void | AbstractWordConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToTextConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected void | WordToHtmlConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected void | WordToFoConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected abstract void | AbstractWordConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected void | AbstractWordConverter.processField(HWPFDocument wordDocument, Range parentRange, int currentTableLevel, Field field, org.w3c.dom.Element currentBlock)
protected void | WordToTextConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected void | WordToHtmlConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected void | WordToFoConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected abstract void | AbstractWordConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected void | WordToTextConverter.processNote(HWPFDocument wordDocument, org.w3c.dom.Element block, Range noteTextRange)
protected void | AbstractWordConverter.processNoteAnchor(HWPFDocument doc, CharacterRun characterRun, org.w3c.dom.Element block)
protected void | WordToHtmlConverter.processNoteAutonumbered(HWPFDocument doc, java.lang.String type, int noteIndex, org.w3c.dom.Element block, Range noteTextRange)
protected boolean | WordToTextConverter.processOle2(HWPFDocument wordDocument, org.w3c.dom.Element block, Entry entry)
protected boolean | AbstractWordConverter.processOle2(HWPFDocument wordDocument, org.w3c.dom.Element block, Entry entry)

Uses of HWPFDocument in org.apache.poi.hwpf.extractor

Constructors in org.apache.poi.hwpf.extractor with parameters of type HWPFDocument
WordExtractor(HWPFDocument doc)
Create a new Word Extractor

Uses of HWPFDocument in org.apache.poi.hwpf.model

Constructors in org.apache.poi.hwpf.model with parameters of type HWPFDocument
PicturesTable(HWPFDocument _document, byte[] _dataStream, byte[] _mainStream)
PicturesTable(HWPFDocument _document, byte[] _dataStream, byte[] _mainStream, FSPATable fspa, EscherRecordHolder dgg)
Deprecated.

Uses of HWPFDocument in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type HWPFDocument
DocumentPosition(HWPFDocument doc, int pos)
HeaderStories(HWPFDocument doc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.HWPFDocumentCore

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.HWPFDocumentCore

Packages that use HWPFDocumentCore
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.usermodel

Uses of HWPFDocumentCore in org.apache.poi.hwpf

Subclasses of HWPFDocumentCore in org.apache.poi.hwpf
class | HWPFDocument This class acts as the bucket that we throw all of the Word data structures into.
class | HWPFOldDocument Provides very simple support for old (Word 6 / Word 95) files.

Uses of HWPFDocumentCore in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter that return HWPFDocumentCore
static HWPFDocumentCore | AbstractWordUtils.loadDoc(DirectoryNode root)
static HWPFDocumentCore | AbstractWordUtils.loadDoc(java.io.File docFile)
static HWPFDocumentCore | AbstractWordUtils.loadDoc(java.io.InputStream inputStream)
static HWPFDocumentCore | AbstractWordUtils.loadDoc(POIFSFileSystem poifsFileSystem)

Methods in org.apache.poi.hwpf.converter with parameters of type HWPFDocumentCore
static java.lang.String | WordToTextConverter.getText(HWPFDocumentCore wordDocument)
protected void | WordToTextConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected void | WordToHtmlConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected void | WordToFoConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected abstract void | AbstractWordConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks) Wrap range into bookmark(s) and process it.
protected boolean | AbstractWordConverter.processCharacters(HWPFDocumentCore wordDocument, int currentTableLevel, Range range, org.w3c.dom.Element block)
protected void | AbstractWordConverter.processDeadField(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, int beginMark, int separatorMark, int endMark)
void | AbstractWordConverter.processDocument(HWPFDocumentCore wordDocument)
void | WordToTextConverter.processDocumentPart(HWPFDocumentCore wordDocument, Range range)
void | WordToHtmlConverter.processDocumentPart(HWPFDocumentCore wordDocument, Range range)
protected void | AbstractWordConverter.processDocumentPart(HWPFDocumentCore wordDocument, Range range)
protected void | WordToTextConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected void | WordToHtmlConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected void | WordToFoConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected abstract void | AbstractWordConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected void | WordToTextConverter.processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected void | WordToHtmlConverter.processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected void | WordToFoConverter.processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected abstract void | AbstractWordConverter.processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected void | WordToTextConverter.processPageref(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected void | WordToHtmlConverter.processPageref(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected void | WordToFoConverter.processPageref(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected abstract void | AbstractWordConverter.processPageref(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected void | WordToTextConverter.processParagraph(HWPFDocumentCore wordDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected void | WordToHtmlConverter.processParagraph(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected void | WordToFoConverter.processParagraph(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element parentFopElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected abstract void | AbstractWordConverter.processParagraph(HWPFDocumentCore wordDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected void | AbstractWordConverter.processParagraphes(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Range range, int currentTableLevel)
protected void | WordToTextConverter.processSection(HWPFDocumentCore wordDocument, Section section, int s)
protected void | WordToHtmlConverter.processSection(HWPFDocumentCore wordDocument, Section section, int sectionCounter)
protected void | WordToFoConverter.processSection(HWPFDocumentCore wordDocument, Section section, int sectionCounter)
protected abstract void | AbstractWordConverter.processSection(HWPFDocumentCore wordDocument, Section section, int s)
protected void | WordToHtmlConverter.processSingleSection(HWPFDocumentCore wordDocument, Section section)
protected void | AbstractWordConverter.processSingleSection(HWPFDocumentCore wordDocument, Section section)
protected void | WordToTextConverter.processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
protected void | WordToHtmlConverter.processTable(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element flow, Table table)
protected void | WordToFoConverter.processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
protected abstract void | AbstractWordConverter.processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
protected int | AbstractWordConverter.tryDeadField(HWPFDocumentCore wordDocument, Range range, int currentTableLevel, int beginMark, org.w3c.dom.Element currentBlock)

Uses of HWPFDocumentCore in org.apache.poi.hwpf.dev

Constructors in org.apache.poi.hwpf.dev with parameters of type HWPFDocumentCore
HWPFLister(HWPFDocumentCore doc)

Uses of HWPFDocumentCore in org.apache.poi.hwpf.usermodel

Fields in org.apache.poi.hwpf.usermodel declared as HWPFDocumentCore
protected  HWPFDocumentCore Range._doc
The document this range blongs to.

Methods in org.apache.poi.hwpf.usermodel that return HWPFDocumentCore
protected  HWPFDocumentCore Range.getDocument()

Constructors in org.apache.poi.hwpf.usermodel with parameters of type HWPFDocumentCore
Range(int start, int end, HWPFDocumentCore doc)
Used to construct a Range from a document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.HWPFOldDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.HWPFOldDocument

Packages that use HWPFOldDocument
org.apache.poi.hwpf.extractor

Uses of HWPFOldDocument in org.apache.poi.hwpf.extractor

Constructors in org.apache.poi.hwpf.extractor with parameters of type HWPFOldDocument
Word6Extractor(HWPFOldDocument doc)
Create a new Word Extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.OldWordFileFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.OldWordFileFormatException

No usage of org.apache.poi.hwpf.OldWordFileFormatException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.QuickTest

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.QuickTest

No usage of org.apache.poi.hwpf.QuickTest

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractWordConverter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class AbstractWordConverter

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.AbstractWordConverter
Direct Known Subclasses:
WordToFoConverter, WordToHtmlConverter, WordToTextConverter
@Beta
public abstract class AbstractWordConverter
extends java.lang.Object

Field Summary
protected static char | UNICODECHAR_NO_BREAK_SPACE
protected static char | UNICODECHAR_NONBREAKING_HYPHEN
protected static char | UNICODECHAR_ZERO_WIDTH_SPACE
Constructor Summary
AbstractWordConverter()
Method Summary
protected void | afterProcess() Special actions that need to be called after processing complete, like updating stylesheets or building document notes list.
protected FontReplacer.Triplet | getCharacterRunTriplet(CharacterRun characterRun)
abstract org.w3c.dom.Document | getDocument()
FontReplacer | getFontReplacer()
protected int | getNumberColumnsSpanned(int[] tableCellEdges, int currentEdgeIndex, TableCell tableCell)
protected int | getNumberRowsSpanned(Table table, int[] tableCellEdges, int currentRowIndex, int currentColumnIndex, TableCell tableCell)
PicturesManager | getPicturesManager()
protected abstract void | outputCharacters(org.w3c.dom.Element block, CharacterRun characterRun, java.lang.String text)
protected abstract void | processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks) Wrap range into bookmark(s) and process it.
protected boolean | processCharacters(HWPFDocumentCore wordDocument, int currentTableLevel, Range range, org.w3c.dom.Element block)
protected void | processDeadField(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, int beginMark, int separatorMark, int endMark)
void | processDocument(HWPFDocumentCore wordDocument)
protected abstract void | processDocumentInformation(SummaryInformation summaryInformation)
protected void | processDocumentPart(HWPFDocumentCore wordDocument, Range range)
protected void | processDrawnObject(HWPFDocument doc, CharacterRun characterRun, org.w3c.dom.Element block)
protected abstract void | processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected abstract void | processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected void | processField(HWPFDocument wordDocument, Range parentRange, int currentTableLevel, Field field, org.w3c.dom.Element currentBlock)
protected abstract void | processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected abstract void | processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected void | processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected abstract void | processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String url)
protected abstract void | processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected abstract void | processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected void | processNoteAnchor(HWPFDocument doc, CharacterRun characterRun, org.w3c.dom.Element block)
protected boolean | processOle2(HWPFDocument wordDocument, org.w3c.dom.Element block, Entry entry)
protected abstract void | processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected abstract void | processPageref(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected abstract void | processParagraph(HWPFDocumentCore wordDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected void | processParagraphes(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Range range, int currentTableLevel)
protected abstract void | processSection(HWPFDocumentCore wordDocument, Section section, int s)
protected void | processSingleSection(HWPFDocumentCore wordDocument, Section section)
protected abstract void | processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
void | setFontReplacer(FontReplacer fontReplacer)
void | setPicturesManager(PicturesManager fileManager)
protected int | tryDeadField(HWPFDocumentCore wordDocument, Range range, int currentTableLevel, int beginMark, org.w3c.dom.Element currentBlock)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNICODECHAR_NO_BREAK_SPACE

protected static final char UNICODECHAR_NO_BREAK_SPACE
See Also:
Constant Field Values

UNICODECHAR_NONBREAKING_HYPHEN

protected static final char UNICODECHAR_NONBREAKING_HYPHEN
See Also:
Constant Field Values

UNICODECHAR_ZERO_WIDTH_SPACE

protected static final char UNICODECHAR_ZERO_WIDTH_SPACE
See Also:
Constant Field Values
Constructor Detail

AbstractWordConverter

public AbstractWordConverter()
Method Detail

afterProcess

protected void afterProcess()
Special actions that need to be called after processing complete, like updating stylesheets or building document notes list. Usually they are called once, but it's okay to call them several times.

getCharacterRunTriplet

protected FontReplacer.Triplet getCharacterRunTriplet(CharacterRun characterRun)

getDocument

public abstract org.w3c.dom.Document getDocument()

getFontReplacer

public FontReplacer getFontReplacer()

getNumberColumnsSpanned

protected int getNumberColumnsSpanned(int[] tableCellEdges,
                                      int currentEdgeIndex,
                                      TableCell tableCell)

getNumberRowsSpanned

protected int getNumberRowsSpanned(Table table,
                                   int[] tableCellEdges,
                                   int currentRowIndex,
                                   int currentColumnIndex,
                                   TableCell tableCell)

getPicturesManager

public PicturesManager getPicturesManager()

outputCharacters

protected abstract void outputCharacters(org.w3c.dom.Element block,
                                         CharacterRun characterRun,
                                         java.lang.String text)

processBookmarks

protected abstract void processBookmarks(HWPFDocumentCore wordDocument,
                                         org.w3c.dom.Element currentBlock,
                                         Range range,
                                         int currentTableLevel,
                                         java.util.List<Bookmark> rangeBookmarks)
Wrap range into bookmark(s) and process it. All bookmarks have starts equal to range start and ends equal to range end. Usually it's only one bookmark.

processCharacters

protected boolean processCharacters(HWPFDocumentCore wordDocument,
                                    int currentTableLevel,
                                    Range range,
                                    org.w3c.dom.Element block)

processDeadField

protected void processDeadField(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element currentBlock,
                                Range range,
                                int currentTableLevel,
                                int beginMark,
                                int separatorMark,
                                int endMark)

processDocument

public void processDocument(HWPFDocumentCore wordDocument)

processDocumentInformation

protected abstract void processDocumentInformation(SummaryInformation summaryInformation)

processDocumentPart

protected void processDocumentPart(HWPFDocumentCore wordDocument,
                                   Range range)

processDrawnObject

protected void processDrawnObject(HWPFDocument doc,
                                  CharacterRun characterRun,
                                  org.w3c.dom.Element block)

processDrawnObject

protected abstract void processDrawnObject(HWPFDocument doc,
                                           CharacterRun characterRun,
                                           OfficeDrawing officeDrawing,
                                           java.lang.String path,
                                           org.w3c.dom.Element block)

processEndnoteAutonumbered

protected abstract void processEndnoteAutonumbered(HWPFDocument wordDocument,
                                                   int noteIndex,
                                                   org.w3c.dom.Element block,
                                                   Range endnoteTextRange)

processField

protected void processField(HWPFDocument wordDocument,
                            Range parentRange,
                            int currentTableLevel,
                            Field field,
                            org.w3c.dom.Element currentBlock)

processFootnoteAutonumbered

protected abstract void processFootnoteAutonumbered(HWPFDocument wordDocument,
                                                    int noteIndex,
                                                    org.w3c.dom.Element block,
                                                    Range footnoteTextRange)

processHyperlink

protected abstract void processHyperlink(HWPFDocumentCore wordDocument,
                                         org.w3c.dom.Element currentBlock,
                                         Range textRange,
                                         int currentTableLevel,
                                         java.lang.String hyperlink)

processImage

protected void processImage(org.w3c.dom.Element currentBlock,
                            boolean inlined,
                            Picture picture)

processImage

protected abstract void processImage(org.w3c.dom.Element currentBlock,
                                     boolean inlined,
                                     Picture picture,
                                     java.lang.String url)

processImageWithoutPicturesManager

@Internal
protected abstract void processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock,
                                                                    boolean inlined,
                                                                    Picture picture)

processLineBreak

protected abstract void processLineBreak(org.w3c.dom.Element block,
                                         CharacterRun characterRun)

processNoteAnchor

protected void processNoteAnchor(HWPFDocument doc,
                                 CharacterRun characterRun,
                                 org.w3c.dom.Element block)

processOle2

protected boolean processOle2(HWPFDocument wordDocument,
                              org.w3c.dom.Element block,
                              Entry entry)
                       throws java.lang.Exception
Throws:
java.lang.Exception

processPageBreak

protected abstract void processPageBreak(HWPFDocumentCore wordDocument,
                                         org.w3c.dom.Element flow)

processPageref

protected abstract void processPageref(HWPFDocumentCore wordDocument,
                                       org.w3c.dom.Element currentBlock,
                                       Range textRange,
                                       int currentTableLevel,
                                       java.lang.String pageref)

processParagraph

protected abstract void processParagraph(HWPFDocumentCore wordDocument,
                                         org.w3c.dom.Element parentElement,
                                         int currentTableLevel,
                                         Paragraph paragraph,
                                         java.lang.String bulletText)

processParagraphes

protected void processParagraphes(HWPFDocumentCore wordDocument,
                                  org.w3c.dom.Element flow,
                                  Range range,
                                  int currentTableLevel)

processSection

protected abstract void processSection(HWPFDocumentCore wordDocument,
                                       Section section,
                                       int s)

processSingleSection

protected void processSingleSection(HWPFDocumentCore wordDocument,
                                    Section section)

processTable

protected abstract void processTable(HWPFDocumentCore wordDocument,
                                     org.w3c.dom.Element flow,
                                     Table table)

setFontReplacer

public void setFontReplacer(FontReplacer fontReplacer)

setPicturesManager

public void setPicturesManager(PicturesManager fileManager)

tryDeadField

protected int tryDeadField(HWPFDocumentCore wordDocument,
                           Range range,
                           int currentTableLevel,
                           int beginMark,
                           org.w3c.dom.Element currentBlock)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractWordUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class AbstractWordUtils

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.AbstractWordUtils
Direct Known Subclasses:
WordToFoUtils, WordToHtmlUtils
@Beta
public class AbstractWordUtils
extends java.lang.Object

Field Summary
static float | TWIPS_PER_INCH
static int | TWIPS_PER_PT
Constructor Summary
AbstractWordUtils()
Method Summary
static java.lang.String | getBorderType(BorderCode borderCode)
static java.lang.String | getBorderWidth(BorderCode borderCode)
static java.lang.String | getBulletText(ListTables listTables, Paragraph paragraph, int listId)
static java.lang.String | getColor(int ico)
static java.lang.String | getColor24(int argbValue)
static java.lang.String | getJustification(int js)
static java.lang.String | getLanguage(int languageCode)
static java.lang.String | getListItemNumberLabel(int number, int format)
static java.lang.String | getOpacity(int argbValue)
static HWPFDocumentCore | loadDoc(DirectoryNode root)
static HWPFDocumentCore | loadDoc(java.io.File docFile)
static HWPFDocumentCore | loadDoc(java.io.InputStream inputStream)
static HWPFDocumentCore | loadDoc(POIFSFileSystem poifsFileSystem)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TWIPS_PER_INCH

public static final float TWIPS_PER_INCH
See Also:
Constant Field Values

TWIPS_PER_PT

public static final int TWIPS_PER_PT
See Also:
Constant Field Values
Constructor Detail

AbstractWordUtils

public AbstractWordUtils()
Method Detail

getBorderType

public static java.lang.String getBorderType(BorderCode borderCode)

getBorderWidth

public static java.lang.String getBorderWidth(BorderCode borderCode)

getBulletText

public static java.lang.String getBulletText(ListTables listTables,
                                             Paragraph paragraph,
                                             int listId)

getColor

public static java.lang.String getColor(int ico)

getOpacity

public static java.lang.String getOpacity(int argbValue)

getColor24

public static java.lang.String getColor24(int argbValue)

getJustification

public static java.lang.String getJustification(int js)

getLanguage

public static java.lang.String getLanguage(int languageCode)

getListItemNumberLabel

public static java.lang.String getListItemNumberLabel(int number,
                                                      int format)

loadDoc

public static HWPFDocumentCore loadDoc(DirectoryNode root)
                                throws java.io.IOException
Throws:
java.io.IOException

loadDoc

public static HWPFDocumentCore loadDoc(java.io.File docFile)
                                throws java.io.IOException
Throws:
java.io.IOException

loadDoc

public static HWPFDocumentCore loadDoc(java.io.InputStream inputStream)
                                throws java.io.IOException
Throws:
java.io.IOException

loadDoc

public static HWPFDocumentCore loadDoc(POIFSFileSystem poifsFileSystem)
                                throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultFontReplacer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class DefaultFontReplacer

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.DefaultFontReplacer
All Implemented Interfaces:
FontReplacer
@Beta
public class DefaultFontReplacer
extends java.lang.Object
implements FontReplacer

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.hwpf.converter.FontReplacer
FontReplacer.Triplet
Constructor Summary
DefaultFontReplacer()
Method Summary
 FontReplacer.Triplet update(FontReplacer.Triplet original)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultFontReplacer

public DefaultFontReplacer()
Method Detail

update

public FontReplacer.Triplet update(FontReplacer.Triplet original)
Specified by:
update in interface FontReplacer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FoDocumentFacade

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class FoDocumentFacade

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.FoDocumentFacade

@Beta
public class FoDocumentFacade
extends java.lang.Object

Field Summary
protected org.w3c.dom.Element | declarations
protected org.w3c.dom.Document | document
protected org.w3c.dom.Element | layoutMasterSet
protected org.w3c.dom.Element | propertiesRoot
protected org.w3c.dom.Element | root
Constructor Summary
FoDocumentFacade(org.w3c.dom.Document document)
Method Summary
org.w3c.dom.Element | addFlowToPageSequence(org.w3c.dom.Element pageSequence, java.lang.String flowName)
org.w3c.dom.Element | addListItem(org.w3c.dom.Element listBlock)
org.w3c.dom.Element | addListItemBody(org.w3c.dom.Element listItem)
org.w3c.dom.Element | addListItemLabel(org.w3c.dom.Element listItem, java.lang.String text)
void | addPageSequence(org.w3c.dom.Element pageSequence)
org.w3c.dom.Element | addPageSequence(java.lang.String pageMaster)
org.w3c.dom.Element | addRegionBody(org.w3c.dom.Element pageMaster)
org.w3c.dom.Element | addSimplePageMaster(java.lang.String masterName)
org.w3c.dom.Element | createBasicLinkExternal(java.lang.String externalDestination)
org.w3c.dom.Element | createBasicLinkInternal(java.lang.String internalDestination)
org.w3c.dom.Element | createBlock()
org.w3c.dom.Element | createExternalGraphic(java.lang.String source)
org.w3c.dom.Element | createFootnote()
org.w3c.dom.Element | createFootnoteBody()
org.w3c.dom.Element | createInline()
org.w3c.dom.Element | createLeader()
org.w3c.dom.Element | createListBlock()
org.w3c.dom.Element | createListItem()
org.w3c.dom.Element | createListItemBody()
org.w3c.dom.Element | createListItemLabel(java.lang.String text)
org.w3c.dom.Element | createPageSequence(java.lang.String pageMaster)
org.w3c.dom.Element | createTable()
org.w3c.dom.Element | createTableBody()
org.w3c.dom.Element | createTableCell()
org.w3c.dom.Element | createTableColumn()
org.w3c.dom.Element | createTableHeader()
org.w3c.dom.Element | createTableRow()
org.w3c.dom.Text | createText(java.lang.String data)
org.w3c.dom.Document | getDocument()
protected org.w3c.dom.Element | getOrCreatePropertiesRoot()
void | setCreator(java.lang.String value)
void | setCreatorTool(java.lang.String value)
void | setDescription(java.lang.String value)
org.w3c.dom.Element | setDublinCoreProperty(java.lang.String name, java.lang.String value)
void | setKeywords(java.lang.String value)
org.w3c.dom.Element | setPdfProperty(java.lang.String name, java.lang.String value)
void | setProducer(java.lang.String value)
protected org.w3c.dom.Element | setProperty(java.lang.String namespace, java.lang.String prefix, java.lang.String name, java.lang.String value)
void | setSubject(java.lang.String value)
void | setTitle(java.lang.String value)
org.w3c.dom.Element | setXmpProperty(java.lang.String name, java.lang.String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

declarations

protected final org.w3c.dom.Element declarations

document

protected final org.w3c.dom.Document document

layoutMasterSet

protected final org.w3c.dom.Element layoutMasterSet

propertiesRoot

protected org.w3c.dom.Element propertiesRoot

root

protected final org.w3c.dom.Element root
Constructor Detail

FoDocumentFacade

public FoDocumentFacade(org.w3c.dom.Document document)
Method Detail

addFlowToPageSequence

public org.w3c.dom.Element addFlowToPageSequence(org.w3c.dom.Element pageSequence,
                                                 java.lang.String flowName)

addListItem

public org.w3c.dom.Element addListItem(org.w3c.dom.Element listBlock)

addListItemBody

public org.w3c.dom.Element addListItemBody(org.w3c.dom.Element listItem)

addListItemLabel

public org.w3c.dom.Element addListItemLabel(org.w3c.dom.Element listItem,
                                            java.lang.String text)

addPageSequence

public void addPageSequence(org.w3c.dom.Element pageSequence)

addPageSequence

public org.w3c.dom.Element addPageSequence(java.lang.String pageMaster)

addRegionBody

public org.w3c.dom.Element addRegionBody(org.w3c.dom.Element pageMaster)

addSimplePageMaster

public org.w3c.dom.Element addSimplePageMaster(java.lang.String masterName)

createBasicLinkExternal

public org.w3c.dom.Element createBasicLinkExternal(java.lang.String externalDestination)

createBasicLinkInternal

public org.w3c.dom.Element createBasicLinkInternal(java.lang.String internalDestination)

createBlock

public org.w3c.dom.Element createBlock()

createExternalGraphic

public org.w3c.dom.Element createExternalGraphic(java.lang.String source)

createFootnote

public org.w3c.dom.Element createFootnote()

createFootnoteBody

public org.w3c.dom.Element createFootnoteBody()

createInline

public org.w3c.dom.Element createInline()

createLeader

public org.w3c.dom.Element createLeader()

createListBlock

public org.w3c.dom.Element createListBlock()

createListItem

public org.w3c.dom.Element createListItem()

createListItemBody

public org.w3c.dom.Element createListItemBody()

createListItemLabel

public org.w3c.dom.Element createListItemLabel(java.lang.String text)

createPageSequence

public org.w3c.dom.Element createPageSequence(java.lang.String pageMaster)

createTable

public org.w3c.dom.Element createTable()

createTableBody

public org.w3c.dom.Element createTableBody()

createTableCell

public org.w3c.dom.Element createTableCell()

createTableColumn

public org.w3c.dom.Element createTableColumn()

createTableHeader

public org.w3c.dom.Element createTableHeader()

createTableRow

public org.w3c.dom.Element createTableRow()

createText

public org.w3c.dom.Text createText(java.lang.String data)

getDocument

public org.w3c.dom.Document getDocument()

getOrCreatePropertiesRoot

protected org.w3c.dom.Element getOrCreatePropertiesRoot()

setCreator

public void setCreator(java.lang.String value)

setCreatorTool

public void setCreatorTool(java.lang.String value)

setDescription

public void setDescription(java.lang.String value)

setDublinCoreProperty

public org.w3c.dom.Element setDublinCoreProperty(java.lang.String name,
                                                 java.lang.String value)

setKeywords

public void setKeywords(java.lang.String value)

setPdfProperty

public org.w3c.dom.Element setPdfProperty(java.lang.String name,
                                          java.lang.String value)

setProducer

public void setProducer(java.lang.String value)

setProperty

protected org.w3c.dom.Element setProperty(java.lang.String namespace,
                                          java.lang.String prefix,
                                          java.lang.String name,
                                          java.lang.String value)

setSubject

public void setSubject(java.lang.String value)

setTitle

public void setTitle(java.lang.String value)

setXmpProperty

public org.w3c.dom.Element setXmpProperty(java.lang.String name,
                                          java.lang.String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontReplacer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Interface FontReplacer

All Known Implementing Classes:
DefaultFontReplacer
@Beta
public interface FontReplacer

Nested Class Summary
static class FontReplacer.Triplet
Method Summary
 FontReplacer.Triplet update(FontReplacer.Triplet original)

Method Detail

update

FontReplacer.Triplet update(FontReplacer.Triplet original)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontReplacer.Triplet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class FontReplacer.Triplet

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.FontReplacer.Triplet
Enclosing interface:
FontReplacer
public static class FontReplacer.Triplet
extends java.lang.Object

Field Summary
boolean | bold
java.lang.String | fontName
boolean | italic
Constructor Summary
FontReplacer.Triplet()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

fontName

public java.lang.String fontName

bold

public boolean bold

italic

public boolean italic
Constructor Detail

FontReplacer.Triplet

public FontReplacer.Triplet()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HtmlDocumentFacade

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class HtmlDocumentFacade

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.HtmlDocumentFacade

@Beta
public class HtmlDocumentFacade
extends java.lang.Object

Field Summary
protected org.w3c.dom.Element | body
protected org.w3c.dom.Document | document
protected org.w3c.dom.Element | head
protected org.w3c.dom.Element | html
protected org.w3c.dom.Element | title
protected org.w3c.dom.Text | titleText
Constructor Summary
HtmlDocumentFacade(org.w3c.dom.Document document)
Method Summary
void | addAuthor(java.lang.String value)
void | addDescription(java.lang.String value)
void | addKeywords(java.lang.String value)
void | addMeta(java.lang.String name, java.lang.String value)
void | addStyleClass(org.w3c.dom.Element element, java.lang.String classNamePrefix, java.lang.String style)
protected java.lang.String | buildStylesheet(java.util.Map<java.lang.String,java.util.Map<java.lang.String,java.lang.String>> prefixToMapOfStyles)
org.w3c.dom.Element | createBlock()
org.w3c.dom.Element | createBookmark(java.lang.String name)
org.w3c.dom.Element | createHeader1()
org.w3c.dom.Element | createHeader2()
org.w3c.dom.Element | createHyperlink(java.lang.String internalDestination)
org.w3c.dom.Element | createImage(java.lang.String src)
org.w3c.dom.Element | createLineBreak()
org.w3c.dom.Element | createListItem()
org.w3c.dom.Element | createParagraph()
org.w3c.dom.Element | createTable()
org.w3c.dom.Element | createTableBody()
org.w3c.dom.Element | createTableCell()
org.w3c.dom.Element | createTableColumn()
org.w3c.dom.Element | createTableColumnGroup()
org.w3c.dom.Element | createTableHeader()
org.w3c.dom.Element | createTableHeaderCell()
org.w3c.dom.Element | createTableRow()
org.w3c.dom.Text | createText(java.lang.String data)
org.w3c.dom.Element | createUnorderedList()
org.w3c.dom.Element | getBody()
org.w3c.dom.Document | getDocument()
org.w3c.dom.Element | getHead()
java.lang.String | getOrCreateCssClass(java.lang.String classNamePrefix, java.lang.String style)
java.lang.String | getTitle()
void | setTitle(java.lang.String titleText)
void | updateStylesheet()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

body

protected final org.w3c.dom.Element body

document

protected final org.w3c.dom.Document document

head

protected final org.w3c.dom.Element head

html

protected final org.w3c.dom.Element html

title

protected org.w3c.dom.Element title

titleText

protected org.w3c.dom.Text titleText
Constructor Detail

HtmlDocumentFacade

public HtmlDocumentFacade(org.w3c.dom.Document document)
Method Detail

addAuthor

public void addAuthor(java.lang.String value)

addDescription

public void addDescription(java.lang.String value)

addKeywords

public void addKeywords(java.lang.String value)

addMeta

public void addMeta(java.lang.String name,
                    java.lang.String value)

addStyleClass

public void addStyleClass(org.w3c.dom.Element element,
                          java.lang.String classNamePrefix,
                          java.lang.String style)

buildStylesheet

protected java.lang.String buildStylesheet(java.util.Map<java.lang.String,java.util.Map<java.lang.String,java.lang.String>> prefixToMapOfStyles)

createBlock

public org.w3c.dom.Element createBlock()

createBookmark

public org.w3c.dom.Element createBookmark(java.lang.String name)

createHeader1

public org.w3c.dom.Element createHeader1()

createHeader2

public org.w3c.dom.Element createHeader2()

createHyperlink

public org.w3c.dom.Element createHyperlink(java.lang.String internalDestination)

createImage

public org.w3c.dom.Element createImage(java.lang.String src)

createLineBreak

public org.w3c.dom.Element createLineBreak()

createListItem

public org.w3c.dom.Element createListItem()

createParagraph

public org.w3c.dom.Element createParagraph()

createTable

public org.w3c.dom.Element createTable()

createTableBody

public org.w3c.dom.Element createTableBody()

createTableCell

public org.w3c.dom.Element createTableCell()

createTableColumn

public org.w3c.dom.Element createTableColumn()

createTableColumnGroup

public org.w3c.dom.Element createTableColumnGroup()

createTableHeader

public org.w3c.dom.Element createTableHeader()

createTableHeaderCell

public org.w3c.dom.Element createTableHeaderCell()

createTableRow

public org.w3c.dom.Element createTableRow()

createText

public org.w3c.dom.Text createText(java.lang.String data)

createUnorderedList

public org.w3c.dom.Element createUnorderedList()

getBody

public org.w3c.dom.Element getBody()

getDocument

public org.w3c.dom.Document getDocument()

getHead

public org.w3c.dom.Element getHead()

getOrCreateCssClass

public java.lang.String getOrCreateCssClass(java.lang.String classNamePrefix,
                                            java.lang.String style)

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String titleText)

updateStylesheet

public void updateStylesheet()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumberFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class NumberFormatter

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.NumberFormatter

@Beta
public final class NumberFormatter
extends java.lang.Object

Utility class to translate numbers in letters, usually for lists.

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Constructor Summary
NumberFormatter()
Method Summary
static java.lang.String getNumber(int num, int style)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NumberFormatter

public NumberFormatter()
Method Detail

getNumber

public static java.lang.String getNumber(int num,
                                         int style)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf.converter
Interfaces
FontReplacer
PicturesManager
Classes
AbstractWordConverter
AbstractWordUtils
DefaultFontReplacer
FoDocumentFacade
FontReplacer.Triplet
HtmlDocumentFacade
NumberFormatter
TextDocumentFacade
WordToFoConverter
WordToFoUtils
WordToHtmlConverter
WordToHtmlUtils
WordToTextConverter


org.apache.poi.hwpf.converter

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.converter

Interface Summary
FontReplacer |
PicturesManager | User-implemented pictures manager to store images on-disk

Class Summary
AbstractWordConverter |
AbstractWordUtils |
DefaultFontReplacer |
FoDocumentFacade |
FontReplacer.Triplet |
HtmlDocumentFacade |
NumberFormatter | Utility class to translate numbers in letters, usually for lists.
TextDocumentFacade |
WordToFoConverter |
WordToFoUtils |
WordToHtmlConverter | Converts Word files (95-2007) into HTML files.
WordToHtmlUtils |
WordToTextConverter |


org.apache.poi.hwpf.converter Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.converter

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hwpf.converter.AbstractWordConverter
      • org.apache.poi.hwpf.converter.WordToFoConverter
      • org.apache.poi.hwpf.converter.WordToHtmlConverter
      • org.apache.poi.hwpf.converter.WordToTextConverter
    • org.apache.poi.hwpf.converter.AbstractWordUtils
      • org.apache.poi.hwpf.converter.WordToFoUtils
      • org.apache.poi.hwpf.converter.WordToHtmlUtils
    • org.apache.poi.hwpf.converter.DefaultFontReplacer (implements org.apache.poi.hwpf.converter.FontReplacer)
    • org.apache.poi.hwpf.converter.FoDocumentFacade
    • org.apache.poi.hwpf.converter.FontReplacer.Triplet
    • org.apache.poi.hwpf.converter.HtmlDocumentFacade
    • org.apache.poi.hwpf.converter.NumberFormatter
    • org.apache.poi.hwpf.converter.TextDocumentFacade

Interface Hierarchy

  • org.apache.poi.hwpf.converter.FontReplacer
  • org.apache.poi.hwpf.converter.PicturesManager


Uses of Package org.apache.poi.hwpf.converter

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.converter

Packages that use org.apache.poi.hwpf.converter
org.apache.poi.hssf.converter
org.apache.poi.hwpf.converter

Classes in org.apache.poi.hwpf.converter used by org.apache.poi.hssf.converter
FoDocumentFacade
FontReplacer
HtmlDocumentFacade

Classes in org.apache.poi.hwpf.converter used by org.apache.poi.hwpf.converter
AbstractWordConverter
AbstractWordUtils
FoDocumentFacade
FontReplacer
FontReplacer.Triplet
HtmlDocumentFacade
PicturesManager
User-implemented pictures manager to store images on-disk
TextDocumentFacade

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PicturesManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Interface PicturesManager

@Beta
public interface PicturesManager

User-implemented pictures manager to store images on-disk

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Method Summary
 java.lang.String savePicture(byte[] content, PictureType pictureType, java.lang.String suggestedName, float widthInches, float heightInches)
Stores image (probably on disk).

Method Detail

savePicture

java.lang.String savePicture(byte[] content,
                             PictureType pictureType,
                             java.lang.String suggestedName,
                             float widthInches,
                             float heightInches)
Stores image (probably on disk). Please, note that different output format support different file types, so image conversion may be required. For example, HTML browsers usually supports PictureType.GIF, PictureType.JPEG, PictureType.PNG, PictureType.TIFF, but rarely PictureType.EMF or PictureType.WMF. FO (Apache FOP) supports at least PNG and SVG types.

Parameters:
content - picture content
pictureType - detected picture type (may be PictureType.UNKNOWN
suggestedName - suggested picture name (based on picture offset in file), supposed to be unique
widthInches - display width in inches (scaled). May be useful for rendering vector images (such as EMF or WMF)
heightInches - display height in inches (scaled). May be useful for rendering vector images (such as EMF or WMF)
Returns:
path to file that can be used as reference in HTML (img's src) of XLS FO (fo:external-graphic's src) or null if image were not saved and should not be referenced from result HTML / FO.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextDocumentFacade

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class TextDocumentFacade

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.TextDocumentFacade

@Beta
public class TextDocumentFacade
extends java.lang.Object

Field Summary
protected org.w3c.dom.Element | body
protected org.w3c.dom.Document | document
protected org.w3c.dom.Element | head
protected org.w3c.dom.Element | root
protected org.w3c.dom.Element | title
protected org.w3c.dom.Text | titleText
Constructor Summary
TextDocumentFacade(org.w3c.dom.Document document)
Method Summary
void | addAuthor(java.lang.String value)
void | addDescription(java.lang.String value)
void | addKeywords(java.lang.String value)
void | addMeta(java.lang.String name, java.lang.String value)
org.w3c.dom.Element | createBlock()
org.w3c.dom.Element | createHeader1()
org.w3c.dom.Element | createHeader2()
org.w3c.dom.Element | createParagraph()
org.w3c.dom.Element | createTable()
org.w3c.dom.Element | createTableBody()
org.w3c.dom.Element | createTableCell()
org.w3c.dom.Element | createTableRow()
org.w3c.dom.Text | createText(java.lang.String data)
org.w3c.dom.Element | createUnorderedList()
org.w3c.dom.Element | getBody()
org.w3c.dom.Document | getDocument()
org.w3c.dom.Element | getHead()
java.lang.String | getTitle()
void | setTitle(java.lang.String titleText)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

body

protected final org.w3c.dom.Element body

document

protected final org.w3c.dom.Document document

head

protected final org.w3c.dom.Element head

root

protected final org.w3c.dom.Element root

title

protected org.w3c.dom.Element title

titleText

protected org.w3c.dom.Text titleText
Constructor Detail

TextDocumentFacade

public TextDocumentFacade(org.w3c.dom.Document document)
Method Detail

addAuthor

public void addAuthor(java.lang.String value)

addDescription

public void addDescription(java.lang.String value)

addKeywords

public void addKeywords(java.lang.String value)

addMeta

public void addMeta(java.lang.String name,
                    java.lang.String value)

createBlock

public org.w3c.dom.Element createBlock()

createHeader1

public org.w3c.dom.Element createHeader1()

createHeader2

public org.w3c.dom.Element createHeader2()

createParagraph

public org.w3c.dom.Element createParagraph()

createTable

public org.w3c.dom.Element createTable()

createTableBody

public org.w3c.dom.Element createTableBody()

createTableCell

public org.w3c.dom.Element createTableCell()

createTableRow

public org.w3c.dom.Element createTableRow()

createText

public org.w3c.dom.Text createText(java.lang.String data)

createUnorderedList

public org.w3c.dom.Element createUnorderedList()

getBody

public org.w3c.dom.Element getBody()

getDocument

public org.w3c.dom.Document getDocument()

getHead

public org.w3c.dom.Element getHead()

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String titleText)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WordToFoConverter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class WordToFoConverter

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.AbstractWordConverter
        extended by  org.apache.poi.hwpf.converter.WordToFoConverter

@Beta
public class WordToFoConverter
extends AbstractWordConverter

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Field Summary
protected  FoDocumentFacade foDocumentFacade
Fields inherited from class org.apache.poi.hwpf.converter.AbstractWordConverter
UNICODECHAR_NO_BREAK_SPACE, UNICODECHAR_NONBREAKING_HYPHEN, UNICODECHAR_ZERO_WIDTH_SPACE
Constructor Summary
WordToFoConverter(org.w3c.dom.Document document)
Creates new instance of WordToFoConverter.
WordToFoConverter(FoDocumentFacade foDocumentFacade)
Method Summary
protected  org.w3c.dom.Element createNoteInline(java.lang.String noteIndexText)
protected  java.lang.String createPageMaster(Section section, java.lang.String type, int sectionIndex)
 org.w3c.dom.Document getDocument()
 boolean isOutputCharactersLanguage()
static void main(java.lang.String[] args)
Java main() interface to interact with WordToFoConverter
protected  void outputCharacters(org.w3c.dom.Element block, CharacterRun characterRun, java.lang.String text)
protected  void processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
Wrap range into bookmark(s) and process it.
protected  void processDocumentInformation(SummaryInformation summaryInformation)
protected  void processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected  void processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected  void processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected  void processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected  void processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String url)
protected  void processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected  void processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected  void processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected  void processPageref(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected  void processParagraph(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element parentFopElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected  void processSection(HWPFDocumentCore wordDocument, Section section, int sectionCounter)
protected  void processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
protected  boolean setId(org.w3c.dom.Element element, java.lang.String id)
 void setOutputCharactersLanguage(boolean outputCharactersLanguage)
Methods inherited from class org.apache.poi.hwpf.converter.AbstractWordConverter
afterProcess, getCharacterRunTriplet, getFontReplacer, getNumberColumnsSpanned, getNumberRowsSpanned, getPicturesManager, processCharacters, processDeadField, processDocument, processDocumentPart, processDrawnObject, processField, processImage, processNoteAnchor, processOle2, processParagraphes, processSingleSection, setFontReplacer, setPicturesManager, tryDeadField
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

foDocumentFacade

protected final FoDocumentFacade foDocumentFacade
Constructor Detail

WordToFoConverter

public WordToFoConverter(org.w3c.dom.Document document)
Creates new instance of WordToFoConverter. Can be used for output several HWPFDocuments into single FO document.

Parameters:
document - XML DOM Document used as XSL FO document. Shall support namespaces

WordToFoConverter

public WordToFoConverter(FoDocumentFacade foDocumentFacade)
Method Detail

main

public static void main(java.lang.String[] args)
Java main() interface to interact with WordToFoConverter

Usage: WordToFoConverter infile outfile

Where infile is an input .doc file ( Word 97-2007) which will be rendered as XSL-FO into outfile

createNoteInline

protected org.w3c.dom.Element createNoteInline(java.lang.String noteIndexText)

createPageMaster

protected java.lang.String createPageMaster(Section section,
                                            java.lang.String type,
                                            int sectionIndex)

getDocument

public org.w3c.dom.Document getDocument()
Specified by:
getDocument in class AbstractWordConverter

isOutputCharactersLanguage

public boolean isOutputCharactersLanguage()

outputCharacters

protected void outputCharacters(org.w3c.dom.Element block,
                                CharacterRun characterRun,
                                java.lang.String text)
Specified by:
outputCharacters in class AbstractWordConverter

processBookmarks

protected void processBookmarks(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element currentBlock,
                                Range range,
                                int currentTableLevel,
                                java.util.List<Bookmark> rangeBookmarks)
Description copied from class: AbstractWordConverter
Wrap range into bookmark(s) and process it. All bookmarks have starts equal to range start and ends equal to range end. Usually it's only one bookmark.

Specified by:
processBookmarks in class AbstractWordConverter

processDocumentInformation

protected void processDocumentInformation(SummaryInformation summaryInformation)
Specified by:
processDocumentInformation in class AbstractWordConverter

processDrawnObject

protected void processDrawnObject(HWPFDocument doc,
                                  CharacterRun characterRun,
                                  OfficeDrawing officeDrawing,
                                  java.lang.String path,
                                  org.w3c.dom.Element block)
Specified by:
processDrawnObject in class AbstractWordConverter

processEndnoteAutonumbered

protected void processEndnoteAutonumbered(HWPFDocument wordDocument,
                                          int noteIndex,
                                          org.w3c.dom.Element block,
                                          Range endnoteTextRange)
Specified by:
processEndnoteAutonumbered in class AbstractWordConverter

processFootnoteAutonumbered

protected void processFootnoteAutonumbered(HWPFDocument wordDocument,
                                           int noteIndex,
                                           org.w3c.dom.Element block,
                                           Range footnoteTextRange)
Specified by:
processFootnoteAutonumbered in class AbstractWordConverter

processHyperlink

protected void processHyperlink(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element currentBlock,
                                Range textRange,
                                int currentTableLevel,
                                java.lang.String hyperlink)
Specified by:
processHyperlink in class AbstractWordConverter

processImage

protected void processImage(org.w3c.dom.Element currentBlock,
                            boolean inlined,
                            Picture picture,
                            java.lang.String url)
Specified by:
processImage in class AbstractWordConverter

processImageWithoutPicturesManager

protected void processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock,
                                                  boolean inlined,
                                                  Picture picture)
Specified by:
processImageWithoutPicturesManager in class AbstractWordConverter

processLineBreak

protected void processLineBreak(org.w3c.dom.Element block,
                                CharacterRun characterRun)
Specified by:
processLineBreak in class AbstractWordConverter

processPageBreak

protected void processPageBreak(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element flow)
Specified by:
processPageBreak in class AbstractWordConverter

processPageref

protected void processPageref(HWPFDocumentCore hwpfDocument,
                              org.w3c.dom.Element currentBlock,
                              Range textRange,
                              int currentTableLevel,
                              java.lang.String pageref)
Specified by:
processPageref in class AbstractWordConverter

processParagraph

protected void processParagraph(HWPFDocumentCore hwpfDocument,
                                org.w3c.dom.Element parentFopElement,
                                int currentTableLevel,
                                Paragraph paragraph,
                                java.lang.String bulletText)
Specified by:
processParagraph in class AbstractWordConverter

processSection

protected void processSection(HWPFDocumentCore wordDocument,
                              Section section,
                              int sectionCounter)
Specified by:
processSection in class AbstractWordConverter

processTable

protected void processTable(HWPFDocumentCore wordDocument,
                            org.w3c.dom.Element flow,
                            Table table)
Specified by:
processTable in class AbstractWordConverter

setId

protected boolean setId(org.w3c.dom.Element element,
                        java.lang.String id)

setOutputCharactersLanguage

public void setOutputCharactersLanguage(boolean outputCharactersLanguage)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WordToFoUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class WordToFoUtils

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.AbstractWordUtils
        extended by  org.apache.poi.hwpf.converter.WordToFoUtils

@Beta
public class WordToFoUtils
extends AbstractWordUtils

Field Summary
Fields inherited from class org.apache.poi.hwpf.converter.AbstractWordUtils
TWIPS_PER_INCH, TWIPS_PER_PT
Constructor Summary
WordToFoUtils()
Method Summary
static void | setBold(org.w3c.dom.Element element, boolean bold)
static void | setBorder(org.w3c.dom.Element element, BorderCode borderCode, java.lang.String where)
static void | setCharactersProperties(CharacterRun characterRun, org.w3c.dom.Element inline)
static void | setFontFamily(org.w3c.dom.Element element, java.lang.String fontFamily)
static void | setFontSize(org.w3c.dom.Element element, int fontSize)
static void | setIndent(Paragraph paragraph, org.w3c.dom.Element block)
static void | setItalic(org.w3c.dom.Element element, boolean italic)
static void | setJustification(Paragraph paragraph, org.w3c.dom.Element element)
static void | setLanguage(CharacterRun characterRun, org.w3c.dom.Element inline)
static void | setParagraphProperties(Paragraph paragraph, org.w3c.dom.Element block)
static void | setPictureProperties(Picture picture, org.w3c.dom.Element graphicElement)
static void | setTableCellProperties(TableRow tableRow, TableCell tableCell, org.w3c.dom.Element element, boolean toppest, boolean bottomest, boolean leftest, boolean rightest)
static void | setTableRowProperties(TableRow tableRow, org.w3c.dom.Element tableRowElement)
Methods inherited from class org.apache.poi.hwpf.converter.AbstractWordUtils
getBorderType, getBorderWidth, getBulletText, getColor, getColor24, getJustification, getLanguage, getListItemNumberLabel, getOpacity, loadDoc, loadDoc, loadDoc, loadDoc
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WordToFoUtils

public WordToFoUtils()
Method Detail

setBold

public static void setBold(org.w3c.dom.Element element,
                           boolean bold)

setBorder

public static void setBorder(org.w3c.dom.Element element,
                             BorderCode borderCode,
                             java.lang.String where)

setCharactersProperties

public static void setCharactersProperties(CharacterRun characterRun,
                                           org.w3c.dom.Element inline)

setFontFamily

public static void setFontFamily(org.w3c.dom.Element element,
                                 java.lang.String fontFamily)

setFontSize

public static void setFontSize(org.w3c.dom.Element element,
                               int fontSize)

setIndent

public static void setIndent(Paragraph paragraph,
                             org.w3c.dom.Element block)

setItalic

public static void setItalic(org.w3c.dom.Element element,
                             boolean italic)

setJustification

public static void setJustification(Paragraph paragraph,
                                    org.w3c.dom.Element element)

setLanguage

public static void setLanguage(CharacterRun characterRun,
                               org.w3c.dom.Element inline)

setParagraphProperties

public static void setParagraphProperties(Paragraph paragraph,
                                          org.w3c.dom.Element block)

setPictureProperties

public static void setPictureProperties(Picture picture,
                                        org.w3c.dom.Element graphicElement)

setTableCellProperties

public static void setTableCellProperties(TableRow tableRow,
                                          TableCell tableCell,
                                          org.w3c.dom.Element element,
                                          boolean toppest,
                                          boolean bottomest,
                                          boolean leftest,
                                          boolean rightest)

setTableRowProperties

public static void setTableRowProperties(TableRow tableRow,
                                         org.w3c.dom.Element tableRowElement)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WordToHtmlConverter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class WordToHtmlConverter

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.AbstractWordConverter
        extended by  org.apache.poi.hwpf.converter.WordToHtmlConverter

@Beta
public class WordToHtmlConverter
extends AbstractWordConverter

Converts Word files (95-2007) into HTML files.

This implementation doesn't create images or links to them. This can be changed by overriding AbstractWordConverter.processImage(Element, boolean, Picture) method.

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Field Summary
Fields inherited from class org.apache.poi.hwpf.converter.AbstractWordConverter
UNICODECHAR_NO_BREAK_SPACE, UNICODECHAR_NONBREAKING_HYPHEN, UNICODECHAR_ZERO_WIDTH_SPACE
Constructor Summary
WordToHtmlConverter(org.w3c.dom.Document document)
Creates new instance of WordToHtmlConverter.
WordToHtmlConverter(HtmlDocumentFacade htmlDocumentFacade)
Method Summary
protected  void afterProcess()
Special actions that need to be called after processing complete, like updating stylesheets or building document notes list.
 org.w3c.dom.Document getDocument()
static void main(java.lang.String[] args)
Java main() interface to interact with WordToHtmlConverter
protected  void outputCharacters(org.w3c.dom.Element pElement, CharacterRun characterRun, java.lang.String text)
protected  void processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
Wrap range into bookmark(s) and process it.
protected  void processDocumentInformation(SummaryInformation summaryInformation)
 void processDocumentPart(HWPFDocumentCore wordDocument, Range range)
protected  void processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected  void processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected  void processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected  void processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected  void processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String imageSourcePath)
protected  void processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected  void processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected  void processNoteAutonumbered(HWPFDocument doc, java.lang.String type, int noteIndex, org.w3c.dom.Element block, Range noteTextRange)
protected  void processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected  void processPageref(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected  void processParagraph(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected  void processSection(HWPFDocumentCore wordDocument, Section section, int sectionCounter)
protected  void processSingleSection(HWPFDocumentCore wordDocument, Section section)
protected  void processTable(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element flow, Table table)
Methods inherited from class org.apache.poi.hwpf.converter.AbstractWordConverter
getCharacterRunTriplet, getFontReplacer, getNumberColumnsSpanned, getNumberRowsSpanned, getPicturesManager, processCharacters, processDeadField, processDocument, processDrawnObject, processField, processImage, processNoteAnchor, processOle2, processParagraphes, setFontReplacer, setPicturesManager, tryDeadField
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WordToHtmlConverter

public WordToHtmlConverter(org.w3c.dom.Document document)
Creates new instance of WordToHtmlConverter. Can be used for output several HWPFDocuments into single HTML document.

Parameters:
document - XML DOM Document used as HTML document

WordToHtmlConverter

public WordToHtmlConverter(HtmlDocumentFacade htmlDocumentFacade)
Method Detail

main

public static void main(java.lang.String[] args)
Java main() interface to interact with WordToHtmlConverter

Usage: WordToHtmlConverter infile outfile

Where infile is an input .doc file ( Word 95-2007) which will be rendered as HTML into outfile

afterProcess

protected void afterProcess()
Description copied from class: AbstractWordConverter
Special actions that need to be called after processing complete, like updating stylesheets or building document notes list. Usually they are called once, but it's okay to call them several times.

Overrides:
afterProcess in class AbstractWordConverter

getDocument

public org.w3c.dom.Document getDocument()
Specified by:
getDocument in class AbstractWordConverter

outputCharacters

protected void outputCharacters(org.w3c.dom.Element pElement,
                                CharacterRun characterRun,
                                java.lang.String text)
Specified by:
outputCharacters in class AbstractWordConverter

processBookmarks

protected void processBookmarks(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element currentBlock,
                                Range range,
                                int currentTableLevel,
                                java.util.List<Bookmark> rangeBookmarks)
Description copied from class: AbstractWordConverter
Wrap range into bookmark(s) and process it. All bookmarks have starts equal to range start and ends equal to range end. Usually it's only one bookmark.

Specified by:
processBookmarks in class AbstractWordConverter

processDocumentInformation

protected void processDocumentInformation(SummaryInformation summaryInformation)
Specified by:
processDocumentInformation in class AbstractWordConverter

processDocumentPart

public void processDocumentPart(HWPFDocumentCore wordDocument,
                                Range range)
Overrides:
processDocumentPart in class AbstractWordConverter

processDrawnObject

protected void processDrawnObject(HWPFDocument doc,
                                  CharacterRun characterRun,
                                  OfficeDrawing officeDrawing,
                                  java.lang.String path,
                                  org.w3c.dom.Element block)
Specified by:
processDrawnObject in class AbstractWordConverter

processEndnoteAutonumbered

protected void processEndnoteAutonumbered(HWPFDocument wordDocument,
                                          int noteIndex,
                                          org.w3c.dom.Element block,
                                          Range endnoteTextRange)
Specified by:
processEndnoteAutonumbered in class AbstractWordConverter

processFootnoteAutonumbered

protected void processFootnoteAutonumbered(HWPFDocument wordDocument,
                                           int noteIndex,
                                           org.w3c.dom.Element block,
                                           Range footnoteTextRange)
Specified by:
processFootnoteAutonumbered in class AbstractWordConverter

processHyperlink

protected void processHyperlink(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element currentBlock,
                                Range textRange,
                                int currentTableLevel,
                                java.lang.String hyperlink)
Specified by:
processHyperlink in class AbstractWordConverter

processImage

protected void processImage(org.w3c.dom.Element currentBlock,
                            boolean inlined,
                            Picture picture,
                            java.lang.String imageSourcePath)
Specified by:
processImage in class AbstractWordConverter

processImageWithoutPicturesManager

protected void processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock,
                                                  boolean inlined,
                                                  Picture picture)
Specified by:
processImageWithoutPicturesManager in class AbstractWordConverter

processLineBreak

protected void processLineBreak(org.w3c.dom.Element block,
                                CharacterRun characterRun)
Specified by:
processLineBreak in class AbstractWordConverter

processNoteAutonumbered

protected void processNoteAutonumbered(HWPFDocument doc,
                                       java.lang.String type,
                                       int noteIndex,
                                       org.w3c.dom.Element block,
                                       Range noteTextRange)

processPageBreak

protected void processPageBreak(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element flow)
Specified by:
processPageBreak in class AbstractWordConverter

processPageref

protected void processPageref(HWPFDocumentCore hwpfDocument,
                              org.w3c.dom.Element currentBlock,
                              Range textRange,
                              int currentTableLevel,
                              java.lang.String pageref)
Specified by:
processPageref in class AbstractWordConverter

processParagraph

protected void processParagraph(HWPFDocumentCore hwpfDocument,
                                org.w3c.dom.Element parentElement,
                                int currentTableLevel,
                                Paragraph paragraph,
                                java.lang.String bulletText)
Specified by:
processParagraph in class AbstractWordConverter

processSection

protected void processSection(HWPFDocumentCore wordDocument,
                              Section section,
                              int sectionCounter)
Specified by:
processSection in class AbstractWordConverter

processSingleSection

protected void processSingleSection(HWPFDocumentCore wordDocument,
                                    Section section)
Overrides:
processSingleSection in class AbstractWordConverter

processTable

protected void processTable(HWPFDocumentCore hwpfDocument,
                            org.w3c.dom.Element flow,
                            Table table)
Specified by:
processTable in class AbstractWordConverter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WordToHtmlUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class WordToHtmlUtils

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.AbstractWordUtils
        extended by  org.apache.poi.hwpf.converter.WordToHtmlUtils

@Beta
public class WordToHtmlUtils
extends AbstractWordUtils

Field Summary
Fields inherited from class org.apache.poi.hwpf.converter.AbstractWordUtils
TWIPS_PER_INCH, TWIPS_PER_PT
Constructor Summary
WordToHtmlUtils()
Method Summary
static void | addBold(boolean bold, java.lang.StringBuilder style)
static void | addBorder(BorderCode borderCode, java.lang.String where, java.lang.StringBuilder style)
static void | addCharactersProperties(CharacterRun characterRun, java.lang.StringBuilder style)
static void | addFontFamily(java.lang.String fontFamily, java.lang.StringBuilder style)
static void | addFontSize(int fontSize, java.lang.StringBuilder style)
static void | addIndent(Paragraph paragraph, java.lang.StringBuilder style)
static void | addJustification(Paragraph paragraph, java.lang.StringBuilder style)
static void | addParagraphProperties(Paragraph paragraph, java.lang.StringBuilder style)
static void | addTableCellProperties(TableRow tableRow, TableCell tableCell, boolean toppest, boolean bottomest, boolean leftest, boolean rightest, java.lang.StringBuilder style)
static void | addTableRowProperties(TableRow tableRow, java.lang.StringBuilder style)
Methods inherited from class org.apache.poi.hwpf.converter.AbstractWordUtils
getBorderType, getBorderWidth, getBulletText, getColor, getColor24, getJustification, getLanguage, getListItemNumberLabel, getOpacity, loadDoc, loadDoc, loadDoc, loadDoc
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WordToHtmlUtils

public WordToHtmlUtils()
Method Detail

addBold

public static void addBold(boolean bold,
                           java.lang.StringBuilder style)

addBorder

public static void addBorder(BorderCode borderCode,
                             java.lang.String where,
                             java.lang.StringBuilder style)

addCharactersProperties

public static void addCharactersProperties(CharacterRun characterRun,
                                           java.lang.StringBuilder style)

addFontFamily

public static void addFontFamily(java.lang.String fontFamily,
                                 java.lang.StringBuilder style)

addFontSize

public static void addFontSize(int fontSize,
                               java.lang.StringBuilder style)

addIndent

public static void addIndent(Paragraph paragraph,
                             java.lang.StringBuilder style)

addJustification

public static void addJustification(Paragraph paragraph,
                                    java.lang.StringBuilder style)

addParagraphProperties

public static void addParagraphProperties(Paragraph paragraph,
                                          java.lang.StringBuilder style)

addTableCellProperties

public static void addTableCellProperties(TableRow tableRow,
                                          TableCell tableCell,
                                          boolean toppest,
                                          boolean bottomest,
                                          boolean leftest,
                                          boolean rightest,
                                          java.lang.StringBuilder style)

addTableRowProperties

public static void addTableRowProperties(TableRow tableRow,
                                         java.lang.StringBuilder style)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WordToTextConverter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.converter
Class WordToTextConverter

java.lang.Object
    extended by  org.apache.poi.hwpf.converter.AbstractWordConverter
        extended by  org.apache.poi.hwpf.converter.WordToTextConverter

@Beta
public class WordToTextConverter
extends AbstractWordConverter

Field Summary
Fields inherited from class org.apache.poi.hwpf.converter.AbstractWordConverter
UNICODECHAR_NO_BREAK_SPACE, UNICODECHAR_NONBREAKING_HYPHEN, UNICODECHAR_ZERO_WIDTH_SPACE
Constructor Summary
WordToTextConverter()
Creates new instance of WordToTextConverter.
WordToTextConverter(org.w3c.dom.Document document)
Creates new instance of WordToTextConverter.
WordToTextConverter(TextDocumentFacade textDocumentFacade)
Method Summary
protected  void afterProcess()
Special actions that need to be called after processing complete, like updating stylesheets or building document notes list.
 org.w3c.dom.Document getDocument()
 java.lang.String getText()
static java.lang.String getText(DirectoryNode root)
static java.lang.String getText(java.io.File docFile)
static java.lang.String getText(HWPFDocumentCore wordDocument)
 boolean isOutputSummaryInformation()
static void main(java.lang.String[] args)
Java main() interface to interact with WordToTextConverter
protected  void outputCharacters(org.w3c.dom.Element block, CharacterRun characterRun, java.lang.String text)
protected  void processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
Wrap range into bookmark(s) and process it.
protected  void processDocumentInformation(SummaryInformation summaryInformation)
 void processDocumentPart(HWPFDocumentCore wordDocument, Range range)
protected  void processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected  void processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected  void processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected  void processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected  void processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected  void processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String url)
protected  void processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected  void processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected  void processNote(HWPFDocument wordDocument, org.w3c.dom.Element block, Range noteTextRange)
protected  boolean processOle2(HWPFDocument wordDocument, org.w3c.dom.Element block, Entry entry)
protected  void processPageBreak(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow)
protected  void processPageref(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected  void processParagraph(HWPFDocumentCore wordDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected  void processSection(HWPFDocumentCore wordDocument, Section section, int s)
protected  void processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
 void setOutputSummaryInformation(boolean outputDocumentInformation)
Methods inherited from class org.apache.poi.hwpf.converter.AbstractWordConverter
getCharacterRunTriplet, getFontReplacer, getNumberColumnsSpanned, getNumberRowsSpanned, getPicturesManager, processCharacters, processDeadField, processDocument, processDrawnObject, processField, processNoteAnchor, processParagraphes, processSingleSection, setFontReplacer, setPicturesManager, tryDeadField
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WordToTextConverter

public WordToTextConverter()
                    throws javax.xml.parsers.ParserConfigurationException
Creates new instance of WordToTextConverter. Can be used for output several HWPFDocuments into single text document.

Throws:
javax.xml.parsers.ParserConfigurationException - if an internal DocumentBuilder cannot be created

WordToTextConverter

public WordToTextConverter(org.w3c.dom.Document document)
Creates new instance of WordToTextConverter. Can be used for output several HWPFDocuments into single text document.

Parameters:
document - XML DOM Document used as storage for text pieces

WordToTextConverter

public WordToTextConverter(TextDocumentFacade textDocumentFacade)
Method Detail

getText

public static java.lang.String getText(DirectoryNode root)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getText

public static java.lang.String getText(java.io.File docFile)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getText

public static java.lang.String getText(HWPFDocumentCore wordDocument)
                                throws java.lang.Exception
Throws:
java.lang.Exception

main

public static void main(java.lang.String[] args)
Java main() interface to interact with WordToTextConverter

Usage: WordToTextConverter infile outfile

Where infile is an input .doc file ( Word 95-2007) which will be rendered as plain text into outfile

afterProcess

protected void afterProcess()
Description copied from class: AbstractWordConverter
Special actions that need to be called after processing complete, like updating stylesheets or building document notes list. Usually they are called once, but it's okay to call them several times.

Overrides:
afterProcess in class AbstractWordConverter

getDocument

public org.w3c.dom.Document getDocument()
Specified by:
getDocument in class AbstractWordConverter

getText

public java.lang.String getText()
                         throws java.lang.Exception
Throws:
java.lang.Exception

isOutputSummaryInformation

public boolean isOutputSummaryInformation()

outputCharacters

protected void outputCharacters(org.w3c.dom.Element block,
                                CharacterRun characterRun,
                                java.lang.String text)
Specified by:
outputCharacters in class AbstractWordConverter

processBookmarks

protected void processBookmarks(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element currentBlock,
                                Range range,
                                int currentTableLevel,
                                java.util.List<Bookmark> rangeBookmarks)
Description copied from class: AbstractWordConverter
Wrap range into bookmark(s) and process it. All bookmarks have starts equal to range start and ends equal to range end. Usually it's only one bookmark.

Specified by:
processBookmarks in class AbstractWordConverter

processDocumentInformation

protected void processDocumentInformation(SummaryInformation summaryInformation)
Specified by:
processDocumentInformation in class AbstractWordConverter

processDocumentPart

public void processDocumentPart(HWPFDocumentCore wordDocument,
                                Range range)
Overrides:
processDocumentPart in class AbstractWordConverter

processDrawnObject

protected void processDrawnObject(HWPFDocument doc,
                                  CharacterRun characterRun,
                                  OfficeDrawing officeDrawing,
                                  java.lang.String path,
                                  org.w3c.dom.Element block)
Specified by:
processDrawnObject in class AbstractWordConverter

processEndnoteAutonumbered

protected void processEndnoteAutonumbered(HWPFDocument wordDocument,
                                          int noteIndex,
                                          org.w3c.dom.Element block,
                                          Range endnoteTextRange)
Specified by:
processEndnoteAutonumbered in class AbstractWordConverter

processFootnoteAutonumbered

protected void processFootnoteAutonumbered(HWPFDocument wordDocument,
                                           int noteIndex,
                                           org.w3c.dom.Element block,
                                           Range footnoteTextRange)
Specified by:
processFootnoteAutonumbered in class AbstractWordConverter

processHyperlink

protected void processHyperlink(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element currentBlock,
                                Range textRange,
                                int currentTableLevel,
                                java.lang.String hyperlink)
Specified by:
processHyperlink in class AbstractWordConverter

processImage

protected void processImage(org.w3c.dom.Element currentBlock,
                            boolean inlined,
                            Picture picture)
Overrides:
processImage in class AbstractWordConverter

processImage

protected void processImage(org.w3c.dom.Element currentBlock,
                            boolean inlined,
                            Picture picture,
                            java.lang.String url)
Specified by:
processImage in class AbstractWordConverter

processImageWithoutPicturesManager

protected void processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock,
                                                  boolean inlined,
                                                  Picture picture)
Specified by:
processImageWithoutPicturesManager in class AbstractWordConverter

processLineBreak

protected void processLineBreak(org.w3c.dom.Element block,
                                CharacterRun characterRun)
Specified by:
processLineBreak in class AbstractWordConverter

processNote

protected void processNote(HWPFDocument wordDocument,
                           org.w3c.dom.Element block,
                           Range noteTextRange)

processOle2

protected boolean processOle2(HWPFDocument wordDocument,
                              org.w3c.dom.Element block,
                              Entry entry)
                       throws java.lang.Exception
Overrides:
processOle2 in class AbstractWordConverter
Throws:
java.lang.Exception

processPageBreak

protected void processPageBreak(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element flow)
Specified by:
processPageBreak in class AbstractWordConverter

processPageref

protected void processPageref(HWPFDocumentCore wordDocument,
                              org.w3c.dom.Element currentBlock,
                              Range textRange,
                              int currentTableLevel,
                              java.lang.String pageref)
Specified by:
processPageref in class AbstractWordConverter

processParagraph

protected void processParagraph(HWPFDocumentCore wordDocument,
                                org.w3c.dom.Element parentElement,
                                int currentTableLevel,
                                Paragraph paragraph,
                                java.lang.String bulletText)
Specified by:
processParagraph in class AbstractWordConverter

processSection

protected void processSection(HWPFDocumentCore wordDocument,
                              Section section,
                              int s)
Specified by:
processSection in class AbstractWordConverter

processTable

protected void processTable(HWPFDocumentCore wordDocument,
                            org.w3c.dom.Element flow,
                            Table table)
Specified by:
processTable in class AbstractWordConverter

setOutputSummaryInformation

public void setOutputSummaryInformation(boolean outputDocumentInformation)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hwpf.converter.AbstractWordConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.AbstractWordConverter

Packages that use AbstractWordConverter
org.apache.poi.hwpf.converter

Uses of AbstractWordConverter in org.apache.poi.hwpf.converter

Subclasses of AbstractWordConverter in org.apache.poi.hwpf.converter
class | WordToFoConverter
class | WordToHtmlConverter Converts Word files (95-2007) into HTML files.
class | WordToTextConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.AbstractWordUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.AbstractWordUtils

Packages that use AbstractWordUtils
org.apache.poi.hwpf.converter

Uses of AbstractWordUtils in org.apache.poi.hwpf.converter

Subclasses of AbstractWordUtils in org.apache.poi.hwpf.converter
class | WordToFoUtils
class | WordToHtmlUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.DefaultFontReplacer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.DefaultFontReplacer

No usage of org.apache.poi.hwpf.converter.DefaultFontReplacer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.FoDocumentFacade

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.FoDocumentFacade

Packages that use FoDocumentFacade
org.apache.poi.hssf.converter
org.apache.poi.hwpf.converter

Uses of FoDocumentFacade in org.apache.poi.hssf.converter

Constructors in org.apache.poi.hssf.converter with parameters of type FoDocumentFacade
ExcelToFoConverter(FoDocumentFacade foDocumentFacade)

Uses of FoDocumentFacade in org.apache.poi.hwpf.converter

Fields in org.apache.poi.hwpf.converter declared as FoDocumentFacade
protected  FoDocumentFacade WordToFoConverter.foDocumentFacade

Constructors in org.apache.poi.hwpf.converter with parameters of type FoDocumentFacade
WordToFoConverter(FoDocumentFacade foDocumentFacade)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.converter.FontReplacer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.converter.FontReplacer

Packages that use FontReplacer
org.apache.poi.hssf.converter
org.apache.poi.hwpf.converter

Uses of FontReplacer in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter that return FontReplacer
 FontReplacer AbstractExcelConverter.getFontReplacer()

Methods in org.apache.poi.hssf.converter with parameters of type FontReplacer
 void AbstractExcelConverter.setFontReplacer(FontReplacer fontReplacer)

Uses of FontReplacer in org.apache.poi.hwpf.converter

Classes in org.apache.poi.hwpf.converter that implement FontReplacer
 class DefaultFontReplacer

Methods in org.apache.poi.hwpf.converter that return FontReplacer
 FontReplacer AbstractWordConverter.getFontReplacer()

Methods in org.apache.poi.hwpf.converter with parameters of type FontReplacer
 void AbstractWordConverter.setFontReplacer(FontReplacer fontReplacer)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.FontReplacer.Triplet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.FontReplacer.Triplet

Packages that use FontReplacer.Triplet
org.apache.poi.hwpf.converter

Uses of FontReplacer.Triplet in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter that return FontReplacer.Triplet
protected FontReplacer.Triplet | AbstractWordConverter.getCharacterRunTriplet(CharacterRun characterRun)
FontReplacer.Triplet | FontReplacer.update(FontReplacer.Triplet original)
FontReplacer.Triplet | DefaultFontReplacer.update(FontReplacer.Triplet original)

Methods in org.apache.poi.hwpf.converter with parameters of type FontReplacer.Triplet
FontReplacer.Triplet | FontReplacer.update(FontReplacer.Triplet original)
FontReplacer.Triplet | DefaultFontReplacer.update(FontReplacer.Triplet original)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.HtmlDocumentFacade

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.HtmlDocumentFacade

Packages that use HtmlDocumentFacade
org.apache.poi.hssf.converter
org.apache.poi.hwpf.converter

Uses of HtmlDocumentFacade in org.apache.poi.hssf.converter

Constructors in org.apache.poi.hssf.converter with parameters of type HtmlDocumentFacade
ExcelToHtmlConverter(HtmlDocumentFacade htmlDocumentFacade)

Uses of HtmlDocumentFacade in org.apache.poi.hwpf.converter

Constructors in org.apache.poi.hwpf.converter with parameters of type HtmlDocumentFacade
WordToHtmlConverter(HtmlDocumentFacade htmlDocumentFacade)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.NumberFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.NumberFormatter

No usage of org.apache.poi.hwpf.converter.NumberFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.converter.PicturesManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.converter.PicturesManager

Packages that use PicturesManager
org.apache.poi.hwpf.converter

Uses of PicturesManager in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter that return PicturesManager
 PicturesManager AbstractWordConverter.getPicturesManager()

Methods in org.apache.poi.hwpf.converter with parameters of type PicturesManager
 void AbstractWordConverter.setPicturesManager(PicturesManager fileManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.TextDocumentFacade

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.TextDocumentFacade

Packages that use TextDocumentFacade
org.apache.poi.hwpf.converter

Uses of TextDocumentFacade in org.apache.poi.hwpf.converter

Constructors in org.apache.poi.hwpf.converter with parameters of type TextDocumentFacade
WordToTextConverter(TextDocumentFacade textDocumentFacade)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.WordToFoConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.WordToFoConverter

No usage of org.apache.poi.hwpf.converter.WordToFoConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.WordToFoUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.WordToFoUtils

No usage of org.apache.poi.hwpf.converter.WordToFoUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.WordToHtmlConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.WordToHtmlConverter

No usage of org.apache.poi.hwpf.converter.WordToHtmlConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.WordToHtmlUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.WordToHtmlUtils

No usage of org.apache.poi.hwpf.converter.WordToHtmlUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.converter.WordToTextConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.converter.WordToTextConverter

No usage of org.apache.poi.hwpf.converter.WordToTextConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FieldIterator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.dev
Class FieldIterator

java.lang.Object
    extended by  org.apache.poi.hwpf.dev.FieldIterator

@Internal
public class FieldIterator
extends java.lang.Object

For iterating through our fields. Used during model classes autogeneration.

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
protected  int offset
Constructor Summary
FieldIterator()
Method Summary
java.lang.String | calcSize(int fieldNumber, java.lang.String fieldName, java.lang.String size, java.lang.String type)
java.lang.String | fillDecoder(java.lang.String size, java.lang.String type)
java.lang.String | serialiseEncoder(int fieldNumber, java.lang.String fieldName, java.lang.String size, java.lang.String type)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

offset

protected int offset
Constructor Detail

FieldIterator

public FieldIterator()
Method Detail

calcSize

public java.lang.String calcSize(int fieldNumber,
                                 java.lang.String fieldName,
                                 java.lang.String size,
                                 java.lang.String type)

fillDecoder

public java.lang.String fillDecoder(java.lang.String size,
                                    java.lang.String type)

serialiseEncoder

public java.lang.String serialiseEncoder(int fieldNumber,
                                         java.lang.String fieldName,
                                         java.lang.String size,
                                         java.lang.String type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HWPFLister

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.dev
Class HWPFLister

java.lang.Object
    extended by  org.apache.poi.hwpf.dev.HWPFLister

@Beta
public final class HWPFLister
extends java.lang.Object

Used by developers to list out key information on a HWPF file. End users will probably never need to use this program.

Author:
Nick Burch (nick at torchbox dot com), Sergey Vladimirov (vlsergey at gmail dot com)

Constructor Summary
HWPFLister(HWPFDocumentCore doc)
Method Summary
void | dumpChpx(boolean withProperties, boolean withSprms)
void | dumpFIB()
void | dumpFileSystem()
void | dumpPapx(boolean withProperties, boolean withSprms)
protected void | dumpParagraphLevels(ListTables listTables, ParagraphProperties paragraph)
void | dumpParagraphs(boolean dumpAssotiatedPapx)
void | dumpParagraphsDom(boolean withText)
protected void | dumpSprms(SprmIterator sprmIt, java.lang.String linePrefix)
void | dumpTextPieces(boolean withText)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HWPFLister

public HWPFLister(HWPFDocumentCore doc)
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

dumpChpx

public void dumpChpx(boolean withProperties,
                     boolean withSprms)

dumpFIB

public void dumpFIB()

dumpFileSystem

public void dumpFileSystem()
                    throws java.lang.Exception
Throws:
java.lang.Exception

dumpPapx

public void dumpPapx(boolean withProperties,
                     boolean withSprms)
              throws java.lang.Exception
Throws:
java.lang.Exception

dumpParagraphs

public void dumpParagraphs(boolean dumpAssotiatedPapx)

dumpSprms

protected void dumpSprms(SprmIterator sprmIt,
                         java.lang.String linePrefix)

dumpParagraphsDom

public void dumpParagraphsDom(boolean withText)

dumpParagraphLevels

protected void dumpParagraphLevels(ListTables listTables,
                                   ParagraphProperties paragraph)

dumpTextPieces

public void dumpTextPieces(boolean withText)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf.dev
Classes
FieldIterator
HWPFLister
RecordUtil


org.apache.poi.hwpf.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.dev

Class Summary
FieldIterator | For iterating through our fields.
HWPFLister | Used by developers to list out key information on a HWPF file.
RecordUtil | Helper functions for the record transformations.


org.apache.poi.hwpf.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hwpf.dev.FieldIterator
    • org.apache.poi.hwpf.dev.HWPFLister
    • org.apache.poi.hwpf.dev.RecordUtil


Uses of Package org.apache.poi.hwpf.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.dev

No usage of org.apache.poi.hwpf.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RecordUtil

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.dev
Class RecordUtil

java.lang.Object
    extended by  org.apache.poi.hwpf.dev.RecordUtil

@Internal
public class RecordUtil
extends java.lang.Object

Helper functions for the record transformations. Used during model classes autogeneration.

Author:
Glen Stampoultzis (glens at apache.org), Andrew C. Oliver (acoliver at apache dot org)

Constructor Summary
RecordUtil()
Method Summary
static java.lang.String | getBitFieldFunction(java.lang.String name, java.lang.String bitMask, java.lang.String parentType, java.lang.String withType)
static java.lang.String | getBitFieldGet(java.lang.String name, java.lang.String bitMask, java.lang.String parentType, java.lang.String parentField)
static java.lang.String | getBitFieldSet(java.lang.String name, java.lang.String bitMask, java.lang.String parentType, java.lang.String parentField)
static java.lang.String | getBitFieldType(java.lang.String name, java.lang.String bitMask, java.lang.String parentType)
static java.lang.String | getConstName(java.lang.String parentName, java.lang.String constName, int padTo)
static java.lang.String | getFieldName(int position, java.lang.String name, int padTo)
static java.lang.String | getFieldName(java.lang.String name, int padTo)
static java.lang.String | getFieldName1stCap(java.lang.String name, int padTo)
static java.lang.String | getType1stCap(java.lang.String size, java.lang.String type, int padTo)
protected static java.lang.StringBuffer | pad(java.lang.StringBuffer fieldName, int padTo)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordUtil

public RecordUtil()
Method Detail

getBitFieldFunction

public static java.lang.String getBitFieldFunction(java.lang.String name,
                                                   java.lang.String bitMask,
                                                   java.lang.String parentType,
                                                   java.lang.String withType)

getBitFieldGet

public static java.lang.String getBitFieldGet(java.lang.String name,
                                              java.lang.String bitMask,
                                              java.lang.String parentType,
                                              java.lang.String parentField)

getBitFieldSet

public static java.lang.String getBitFieldSet(java.lang.String name,
                                              java.lang.String bitMask,
                                              java.lang.String parentType,
                                              java.lang.String parentField)

getBitFieldType

public static java.lang.String getBitFieldType(java.lang.String name,
                                               java.lang.String bitMask,
                                               java.lang.String parentType)

getConstName

public static java.lang.String getConstName(java.lang.String parentName,
                                            java.lang.String constName,
                                            int padTo)

getFieldName

public static java.lang.String getFieldName(int position,
                                            java.lang.String name,
                                            int padTo)

getFieldName

public static java.lang.String getFieldName(java.lang.String name,
                                            int padTo)

getFieldName1stCap

public static java.lang.String getFieldName1stCap(java.lang.String name,
                                                  int padTo)

getType1stCap

public static java.lang.String getType1stCap(java.lang.String size,
                                             java.lang.String type,
                                             int padTo)

pad

protected static java.lang.StringBuffer pad(java.lang.StringBuffer fieldName,
                                            int padTo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hwpf.dev.FieldIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.dev.FieldIterator

No usage of org.apache.poi.hwpf.dev.FieldIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.dev.HWPFLister

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.dev.HWPFLister

No usage of org.apache.poi.hwpf.dev.HWPFLister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.dev.RecordUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.dev.RecordUtil

No usage of org.apache.poi.hwpf.dev.RecordUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.hwpf.extractor
Classes
Word6Extractor
WordExtractor


org.apache.poi.hwpf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.extractor

Class Summary
Word6Extractor | Class to extract the text from old (Word 6 / Word 95) Word Documents.
WordExtractor | Class to extract the text from a Word Document.


org.apache.poi.hwpf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIOLE2TextExtractor
        • org.apache.poi.hwpf.extractor.Word6Extractor
        • org.apache.poi.hwpf.extractor.WordExtractor


Uses of Package org.apache.poi.hwpf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.extractor

No usage of org.apache.poi.hwpf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Word6Extractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.extractor
Class Word6Extractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hwpf.extractor.Word6Extractor

public final class Word6Extractor
extends POIOLE2TextExtractor

Class to extract the text from old (Word 6 / Word 95) Word Documents. This should only be used on the older files, for most uses you should call WordExtractor which deals properly with HWPF.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
Word6Extractor(DirectoryNode dir)
Word6Extractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use Word6Extractor(DirectoryNode) instead
Word6Extractor(HWPFOldDocument doc)
Create a new Word Extractor
Word6Extractor(java.io.InputStream is)
Create a new Word Extractor
Word6Extractor(POIFSFileSystem fs)
Create a new Word Extractor
Method Summary
java.lang.String[] | getParagraphText() Deprecated.
java.lang.String | getText() Retrieves all the text from the document.
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getDocSummaryInformation, getFileSystem, getMetadataTextExtractor, getRoot, getSummaryInformation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Word6Extractor

public Word6Extractor(java.io.InputStream is)
               throws java.io.IOException
Create a new Word Extractor

Parameters:
is - InputStream containing the word file
Throws:
java.io.IOException

Word6Extractor

public Word6Extractor(POIFSFileSystem fs)
               throws java.io.IOException
Create a new Word Extractor

Parameters:
fs - POIFSFileSystem containing the word file
Throws:
java.io.IOException

Word6Extractor

@Deprecated
public Word6Extractor(DirectoryNode dir,
                                 POIFSFileSystem fs)
               throws java.io.IOException
Deprecated. Use Word6Extractor(DirectoryNode) instead

Throws:
java.io.IOException

Word6Extractor

public Word6Extractor(DirectoryNode dir)
               throws java.io.IOException
Throws:
java.io.IOException

Word6Extractor

public Word6Extractor(HWPFOldDocument doc)
Create a new Word Extractor

Parameters:
doc - The HWPFOldDocument to extract from
Method Detail

getParagraphText

@Deprecated
public java.lang.String[] getParagraphText()
Deprecated.

Get the text from the word file, as an array with one String per paragraph

getText

public java.lang.String getText()
Description copied from class: POITextExtractor
Retrieves all the text from the document. How cells, paragraphs etc are separated in the text is implementation specific - see the javadocs for a specific project for details.

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


WordExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.extractor
Class WordExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIOLE2TextExtractor
            extended by  org.apache.poi.hwpf.extractor.WordExtractor

public final class WordExtractor
extends POIOLE2TextExtractor

Class to extract the text from a Word Document. You should use either getParagraphText() or getText() unless you have a strong reason otherwise.

Author:
Nick Burch

Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
WordExtractor(DirectoryNode dir)
WordExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use WordExtractor(DirectoryNode) instead
WordExtractor(HWPFDocument doc)
Create a new Word Extractor
WordExtractor(java.io.InputStream is)
Create a new Word Extractor
WordExtractor(POIFSFileSystem fs)
Create a new Word Extractor
Method Summary
java.lang.String[] | getCommentsText()
java.lang.String[] | getEndnoteText()
java.lang.String | getFooterText() Deprecated.
java.lang.String[] | getFootnoteText()
java.lang.String | getHeaderText() Deprecated.
java.lang.String[] | getMainTextboxText()
java.lang.String[] | getParagraphText() Get the text from the word file, as an array with one String per paragraph
protected static java.lang.String[] | getParagraphText(Range r)
java.lang.String | getText() Grab the text, based on the WordToTextConverter.
java.lang.String | getTextFromPieces() Grab the text out of the text pieces.
static void | main(java.lang.String[] args) Command line extractor, so people will stop moaning that they can't just run this.
static java.lang.String | stripFields(java.lang.String text) Removes any fields (eg macros, page markers etc) from the string.
Methods inherited from class org.apache.poi.POIOLE2TextExtractor
getDocSummaryInformation, getFileSystem, getMetadataTextExtractor, getRoot, getSummaryInformation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WordExtractor

public WordExtractor(java.io.InputStream is)
              throws java.io.IOException
Create a new Word Extractor

Parameters:
is - InputStream containing the word file
Throws:
java.io.IOException

WordExtractor

public WordExtractor(POIFSFileSystem fs)
              throws java.io.IOException
Create a new Word Extractor

Parameters:
fs - POIFSFileSystem containing the word file
Throws:
java.io.IOException

WordExtractor

@Deprecated
public WordExtractor(DirectoryNode dir,
                                POIFSFileSystem fs)
              throws java.io.IOException
Deprecated. Use WordExtractor(DirectoryNode) instead

Throws:
java.io.IOException

WordExtractor

public WordExtractor(DirectoryNode dir)
              throws java.io.IOException
Throws:
java.io.IOException

WordExtractor

public WordExtractor(HWPFDocument doc)
Create a new Word Extractor

Parameters:
doc - The HWPFDocument to extract from
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Command line extractor, so people will stop moaning that they can't just run this.

Throws:
java.io.IOException

getParagraphText

public java.lang.String[] getParagraphText()
Get the text from the word file, as an array with one String per paragraph

getFootnoteText

public java.lang.String[] getFootnoteText()

getMainTextboxText

public java.lang.String[] getMainTextboxText()

getEndnoteText

public java.lang.String[] getEndnoteText()

getCommentsText

public java.lang.String[] getCommentsText()

getParagraphText

protected static java.lang.String[] getParagraphText(Range r)

getHeaderText

@Deprecated
public java.lang.String getHeaderText()
Deprecated.

Grab the text from the headers

getFooterText

@Deprecated
public java.lang.String getFooterText()
Deprecated.

Grab the text from the footers

getTextFromPieces

public java.lang.String getTextFromPieces()
Grab the text out of the text pieces. Might also include various bits of crud, but will work in cases where the text piece -> paragraph mapping is broken. Fast too.

getText

public java.lang.String getText()
Grab the text, based on the WordToTextConverter. Shouldn't include any crud, but slower than getTextFromPieces().

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

stripFields

public static java.lang.String stripFields(java.lang.String text)
Removes any fields (eg macros, page markers etc) from the string.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hwpf.extractor.Word6Extractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.extractor.Word6Extractor

No usage of org.apache.poi.hwpf.extractor.Word6Extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.extractor.WordExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.extractor.WordExtractor

No usage of org.apache.poi.hwpf.extractor.WordExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BookmarkFirstDescriptor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class BookmarkFirstDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.BKFAbstractType
        extended by  org.apache.poi.hwpf.model.BookmarkFirstDescriptor
All Implemented Interfaces:
java.lang.Cloneable
@Internal
public final class BookmarkFirstDescriptor
extends BKFAbstractType
implements java.lang.Cloneable

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.BKFAbstractType
field_1_ibkl, field_2_bkf_flags
Constructor Summary
BookmarkFirstDescriptor()
BookmarkFirstDescriptor(byte[] data, int offset)
Method Summary
protected BookmarkFirstDescriptor | clone()
boolean | equals(java.lang.Object obj)
int | hashCode()
boolean | isEmpty()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.types.BKFAbstractType
fillFields, getBkf_flags, getIbkl, getItcFirst, getItcLim, getSize, isFCol, isFPub, serialize, setBkf_flags, setFCol, setFPub, setIbkl, setItcFirst, setItcLim
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BookmarkFirstDescriptor

public BookmarkFirstDescriptor()

BookmarkFirstDescriptor

public BookmarkFirstDescriptor(byte[] data,
                               int offset)
Method Detail

clone

protected BookmarkFirstDescriptor clone()
Overrides:
clone in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isEmpty

public boolean isEmpty()

toString

public java.lang.String toString()
Overrides:
toString in class BKFAbstractType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BookmarksTables

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class BookmarksTables

java.lang.Object
    extended by  org.apache.poi.hwpf.model.BookmarksTables

@Internal
public class BookmarksTables
extends java.lang.Object

Constructor Summary
BookmarksTables(byte[] tableStream, FileInformationBlock fib)
Method Summary
void | afterDelete(int startCp, int length)
void | afterInsert(int startCp, int length)
int | getBookmarksCount()
GenericPropertyNode | getDescriptorFirst(int index)
int | getDescriptorFirstIndex(GenericPropertyNode descriptorFirst)
GenericPropertyNode | getDescriptorLim(int index)
int | getDescriptorsFirstCount()
int | getDescriptorsLimCount()
java.lang.String | getName(int index)
int | getNamesCount()
void | remove(int index)
void | setName(int index, java.lang.String name)
void | writePlcfBkmkf(FileInformationBlock fib, HWPFOutputStream tableStream)
void | writePlcfBkmkl(FileInformationBlock fib, HWPFOutputStream tableStream)
void | writeSttbfBkmk(FileInformationBlock fib, HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BookmarksTables

public BookmarksTables(byte[] tableStream,
                       FileInformationBlock fib)
Method Detail

afterDelete

public void afterDelete(int startCp,
                        int length)

afterInsert

public void afterInsert(int startCp,
                        int length)

getBookmarksCount

public int getBookmarksCount()

getDescriptorFirst

public GenericPropertyNode getDescriptorFirst(int index)
                                       throws java.lang.IndexOutOfBoundsException
Throws:
java.lang.IndexOutOfBoundsException

getDescriptorFirstIndex

public int getDescriptorFirstIndex(GenericPropertyNode descriptorFirst)

getDescriptorLim

public GenericPropertyNode getDescriptorLim(int index)
                                     throws java.lang.IndexOutOfBoundsException
Throws:
java.lang.IndexOutOfBoundsException

getDescriptorsFirstCount

public int getDescriptorsFirstCount()

getDescriptorsLimCount

public int getDescriptorsLimCount()

getName

public java.lang.String getName(int index)

getNamesCount

public int getNamesCount()

remove

public void remove(int index)

setName

public void setName(int index,
                    java.lang.String name)

writePlcfBkmkf

public void writePlcfBkmkf(FileInformationBlock fib,
                           HWPFOutputStream tableStream)
                    throws java.io.IOException
Throws:
java.io.IOException

writePlcfBkmkl

public void writePlcfBkmkl(FileInformationBlock fib,
                           HWPFOutputStream tableStream)
                    throws java.io.IOException
Throws:
java.io.IOException

writeSttbfBkmk

public void writeSttbfBkmk(FileInformationBlock fib,
                           HWPFOutputStream tableStream)
                    throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BytePropertyNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class BytePropertyNode<T extends BytePropertyNode<T>>

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<T>
        extended by  org.apache.poi.hwpf.model.BytePropertyNode<T>
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<T>
Direct Known Subclasses:
CHPX, PAPX
Deprecated. byte positions shall not be saved in memory

@Deprecated
public abstract class BytePropertyNode<T extends BytePropertyNode<T>>
extends PropertyNode<T>

Normally PropertyNodes only ever work in characters, but a few cases actually store bytes, and this lets everything still work despite that. It handles the conversion as required between bytes and characters.

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
BytePropertyNode(int fcStart, int fcEnd, CharIndexTranslator translator, java.lang.Object buf)
Deprecated.
BytePropertyNode(int charStart, int charEnd, java.lang.Object buf)
Deprecated.
Method Summary
int | getEndBytes() Deprecated. Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.
int | getStartBytes() Deprecated. Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
adjustForDelete, clone, compareTo, equals, getEnd, getStart, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BytePropertyNode

public BytePropertyNode(int fcStart,
                        int fcEnd,
                        CharIndexTranslator translator,
                        java.lang.Object buf)
Deprecated.

Parameters:
fcStart - The start of the text for this property, in _bytes_
fcEnd - The end of the text for this property, in _bytes_

BytePropertyNode

public BytePropertyNode(int charStart,
                        int charEnd,
                        java.lang.Object buf)
Deprecated.
Method Detail

getStartBytes

@Deprecated
public int getStartBytes()
Deprecated. Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.

getEndBytes

@Deprecated
public int getEndBytes()
Deprecated. Though bytes are actually stored in file, it is advised to use char positions for all operations. Including save operations, because only char positions are preserved.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CachedPropertyNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class CachedPropertyNode

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<CachedPropertyNode>
        extended by  org.apache.poi.hwpf.model.CachedPropertyNode
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<CachedPropertyNode>
@Internal
public final class CachedPropertyNode
extends PropertyNode<CachedPropertyNode>

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
protected  java.lang.ref.SoftReference<java.lang.Object> _propCache
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
CachedPropertyNode(int start, int end, SprmBuffer buf)
Method Summary
protected void | fillCache(java.lang.Object ref)
protected java.lang.Object | getCacheContents()
SprmBuffer | getSprmBuf()
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
adjustForDelete, clone, compareTo, equals, getEnd, getStart, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

_propCache

protected java.lang.ref.SoftReference<java.lang.Object> _propCache
Constructor Detail

CachedPropertyNode

public CachedPropertyNode(int start,
                          int end,
                          SprmBuffer buf)
Method Detail

fillCache

protected void fillCache(java.lang.Object ref)

getCacheContents

protected java.lang.Object getCacheContents()

getSprmBuf

public SprmBuffer getSprmBuf()
Returns:
This property's property in compressed form.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharIndexTranslator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Interface CharIndexTranslator

All Known Implementing Classes:
TextPieceTable
@Internal
public interface CharIndexTranslator

Method Summary
int | getByteIndex(int charPos) Calculates the byte index of the given char index.
int | getCharIndex(int bytePos) Deprecated. This API were based on incorrect assumption that single byte offset corresponds to single char offset
int | getCharIndex(int bytePos, int startCP) Deprecated. This API were based on incorrect assumption that single byte offset corresponds to single char offset
int[][] | getCharIndexRanges(int startBytePosInclusive, int endBytePosExclusive) Finds character ranges that includes specified byte range.
boolean | isIndexInTable(int bytePos) Check if index is in table
int | lookIndexBackward(int bytePos) Return last index <= bytePos that is in table
int | lookIndexForward(int bytePos) Return first index >= bytePos that is in table

Method Detail

getByteIndex

int getByteIndex(int charPos)
Calculates the byte index of the given char index.

Parameters:
charPos - The char position
Returns:
The byte index

getCharIndex

@Deprecated
int getCharIndex(int bytePos)
Deprecated. This API were based on incorrect assumption that single byte offset corresponds to single char offset

Calculates the char index of the given byte index. Look forward if index is not in table

Parameters:
bytePos - The character offset to check
Returns:
the char index

getCharIndex

@Deprecated
int getCharIndex(int bytePos,
                            int startCP)
Deprecated. This API were based on incorrect assumption that single byte offset corresponds to single char offset

Calculates the char index of the given byte index. Look forward if index is not in table

Parameters:
bytePos - The character offset to check
startCP - look from this characted position
Returns:
the char index

getCharIndexRanges

int[][] getCharIndexRanges(int startBytePosInclusive,
                           int endBytePosExclusive)
Finds character ranges that includes specified byte range.

Parameters:
startBytePosInclusive - start byte range
endBytePosExclusive - end byte range

isIndexInTable

boolean isIndexInTable(int bytePos)
Check if index is in table

Parameters:
bytePos -
Returns:
true if index in table, false if not

lookIndexForward

int lookIndexForward(int bytePos)
Return first index >= bytePos that is in table

Parameters:
bytePos -
Returns:
first index greater or equal to bytePos that is in table

lookIndexBackward

int lookIndexBackward(int bytePos)
Return last index <= bytePos that is in table

Parameters:
bytePos -
Returns:
last index less of equal to bytePos that is in table
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CHPBinTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class CHPBinTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.CHPBinTable
Direct Known Subclasses:
OldCHPBinTable
@Internal
public class CHPBinTable
extends java.lang.Object

This class holds all of the character formatting properties.

Author:
Ryan Ackley

Field Summary
protected  java.util.ArrayList<CHPX> _textRuns
List of character properties.
Constructor Summary
CHPBinTable()
CHPBinTable(byte[] documentStream, byte[] tableStream, int offset, int size, CharIndexTranslator translator)
Constructor used to read a binTable in from a Word document.
CHPBinTable(byte[] documentStream, byte[] tableStream, int offset, int size, int fcMin, TextPieceTable tpt)
Deprecated. Use CHPBinTable(byte[], byte[], int, int, CharIndexTranslator) instead
Method Summary
void | adjustForDelete(int listIndex, int offset, int length)
void | adjustForInsert(int listIndex, int length)
java.util.List<CHPX> | getTextRuns()
void | insert(int listIndex, int cpStart, SprmBuffer buf)
void | rebuild(ComplexFileTable complexFileTable)
void | writeTo(HWPFFileSystem sys, int fcMin, CharIndexTranslator translator) Deprecated.
void | writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream, int fcMin, CharIndexTranslator translator)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_textRuns

protected java.util.ArrayList<CHPX> _textRuns
List of character properties.

Constructor Detail

CHPBinTable

public CHPBinTable()

CHPBinTable

public CHPBinTable(byte[] documentStream,
                   byte[] tableStream,
                   int offset,
                   int size,
                   int fcMin,
                   TextPieceTable tpt)
Deprecated. Use CHPBinTable(byte[], byte[], int, int, CharIndexTranslator) instead

Constructor used to read a binTable in from a Word document.

CHPBinTable

public CHPBinTable(byte[] documentStream,
                   byte[] tableStream,
                   int offset,
                   int size,
                   CharIndexTranslator translator)
Constructor used to read a binTable in from a Word document.

Method Detail

rebuild

public void rebuild(ComplexFileTable complexFileTable)

adjustForDelete

public void adjustForDelete(int listIndex,
                            int offset,
                            int length)

insert

public void insert(int listIndex,
                   int cpStart,
                   SprmBuffer buf)

adjustForInsert

public void adjustForInsert(int listIndex,
                            int length)

getTextRuns

public java.util.List<CHPX> getTextRuns()

writeTo

@Deprecated
public void writeTo(HWPFFileSystem sys,
                               int fcMin,
                               CharIndexTranslator translator)
             throws java.io.IOException
Deprecated.

Throws:
java.io.IOException

writeTo

public void writeTo(HWPFOutputStream wordDocumentStream,
                    HWPFOutputStream tableStream,
                    int fcMin,
                    CharIndexTranslator translator)
             throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CHPFormattedDiskPage

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class CHPFormattedDiskPage

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FormattedDiskPage
        extended by  org.apache.poi.hwpf.model.CHPFormattedDiskPage

@Internal
public final class CHPFormattedDiskPage
extends FormattedDiskPage

Represents a CHP fkp. The style properties for paragraph and character runs are stored in fkps. There are PAP fkps for paragraph properties and CHP fkps for character run properties. The first part of the fkp for both CHP and PAP fkps consists of an array of 4 byte int offsets that represent a Paragraph's or Character run's text offset in the main stream. The ending offset is the next value in the array. For example, if an fkp has X number of Paragraph's stored in it then there are (x + 1) 4 byte ints in the beginning array. The number X is determined by the last byte in a 512 byte fkp. CHP and PAP fkps also store the compressed styles(grpprl) that correspond to the offsets on the front of the fkp. The offset of the grpprls is determined differently for CHP fkps and PAP fkps.

Author:
Ryan Ackley

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.FormattedDiskPage
_crun, _fkp, _offset
Constructor Summary
CHPFormattedDiskPage()
CHPFormattedDiskPage(byte[] documentStream, int offset, CharIndexTranslator translator)
This constructs a CHPFormattedDiskPage from a raw fkp (512 byte array read from a Word file).
CHPFormattedDiskPage(byte[] documentStream, int offset, int fcMin, TextPieceTable tpt)
Deprecated. Use CHPFormattedDiskPage(byte[], int, CharIndexTranslator) instead
Method Summary
void | fill(java.util.List<CHPX> filler)
CHPX | getCHPX(int index)
java.util.List<CHPX> | getCHPXs()
protected byte[] | getGrpprl(int index) Gets the chpx for the character run at index in this fkp.
java.util.ArrayList<CHPX> | getOverflow()
protected byte[] | toByteArray(CharIndexTranslator translator)
protected byte[] | toByteArray(CharIndexTranslator translator, int fcMin) Deprecated. Use toByteArray(CharIndexTranslator) instead
Methods inherited from class org.apache.poi.hwpf.model.FormattedDiskPage
getEnd, getStart, size
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CHPFormattedDiskPage

public CHPFormattedDiskPage()

CHPFormattedDiskPage

public CHPFormattedDiskPage(byte[] documentStream,
                            int offset,
                            int fcMin,
                            TextPieceTable tpt)
Deprecated. Use CHPFormattedDiskPage(byte[], int, CharIndexTranslator) instead

This constructs a CHPFormattedDiskPage from a raw fkp (512 byte array read from a Word file).

CHPFormattedDiskPage

public CHPFormattedDiskPage(byte[] documentStream,
                            int offset,
                            CharIndexTranslator translator)
This constructs a CHPFormattedDiskPage from a raw fkp (512 byte array read from a Word file).

Method Detail

getCHPX

public CHPX getCHPX(int index)

getCHPXs

public java.util.List<CHPX> getCHPXs()

fill

public void fill(java.util.List<CHPX> filler)

getOverflow

public java.util.ArrayList<CHPX> getOverflow()

getGrpprl

protected byte[] getGrpprl(int index)
Gets the chpx for the character run at index in this fkp.

Specified by:
getGrpprl in class FormattedDiskPage
Parameters:
index - The index of the chpx to get.
Returns:
a chpx grpprl.

toByteArray

@Deprecated
protected byte[] toByteArray(CharIndexTranslator translator,
                                        int fcMin)
Deprecated. Use toByteArray(CharIndexTranslator) instead

toByteArray

protected byte[] toByteArray(CharIndexTranslator translator)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CHPX

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class CHPX

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<T>
        extended by  org.apache.poi.hwpf.model.BytePropertyNode<CHPX>
            extended by  org.apache.poi.hwpf.model.CHPX
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<CHPX>
@Internal
public final class CHPX
extends BytePropertyNode<CHPX>

DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!

Author:
Ryan Ackley

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
CHPX(int fcStart, int fcEnd, CharIndexTranslator translator, byte[] grpprl)
Deprecated.
CHPX(int fcStart, int fcEnd, CharIndexTranslator translator, SprmBuffer buf)
Deprecated.
Method Summary
CharacterProperties | getCharacterProperties(StyleSheet ss, short istd)
byte[] | getGrpprl()
SprmBuffer | getSprmBuf()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.BytePropertyNode
getEndBytes, getStartBytes
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
adjustForDelete, clone, compareTo, equals, getEnd, getStart, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CHPX

@Deprecated
public CHPX(int fcStart,
                       int fcEnd,
                       CharIndexTranslator translator,
                       byte[] grpprl)
Deprecated.

CHPX

@Deprecated
public CHPX(int fcStart,
                       int fcEnd,
                       CharIndexTranslator translator,
                       SprmBuffer buf)
Deprecated.

Method Detail

getGrpprl

public byte[] getGrpprl()

getSprmBuf

public SprmBuffer getSprmBuf()

getCharacterProperties

public CharacterProperties getCharacterProperties(StyleSheet ss,
                                                  short istd)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Colorref

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class Colorref

java.lang.Object
    extended by  org.apache.poi.hwpf.model.Colorref
All Implemented Interfaces:
java.lang.Cloneable
@Internal
public class Colorref
extends java.lang.Object
implements java.lang.Cloneable

24-bit color structure

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Constructor Summary
Colorref()
Colorref(byte[] data, int offset)
Colorref(int value)
Method Summary
Colorref | clone()
boolean | equals(java.lang.Object obj)
int | getValue()
int | hashCode()
boolean | isEmpty()
void | serialize(byte[] data, int offset)
void | setValue(int value)
byte[] | toByteArray()
java.lang.String | toString()
static Colorref | valueOfIco(int ico)
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

Colorref

public Colorref()

Colorref

public Colorref(byte[] data,
                int offset)

Colorref

public Colorref(int value)
Method Detail

valueOfIco

public static Colorref valueOfIco(int ico)

clone

public Colorref clone()
               throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

getValue

public int getValue()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isEmpty

public boolean isEmpty()

serialize

public void serialize(byte[] data,
                      int offset)

setValue

public void setValue(int value)

toByteArray

public byte[] toByteArray()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComplexFileTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ComplexFileTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ComplexFileTable

@Internal
public final class ComplexFileTable
extends java.lang.Object

Field Summary
protected  TextPieceTable _tpt
Constructor Summary
ComplexFileTable()
ComplexFileTable(byte[] documentStream, byte[] tableStream, int offset, int fcMin)
Method Summary
SprmBuffer[] | getGrpprls()
TextPieceTable | getTextPieceTable()
void | writeTo(HWPFFileSystem sys) Deprecated.
void | writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_tpt

protected TextPieceTable _tpt
Constructor Detail

ComplexFileTable

public ComplexFileTable()

ComplexFileTable

public ComplexFileTable(byte[] documentStream,
                        byte[] tableStream,
                        int offset,
                        int fcMin)
                 throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getTextPieceTable

public TextPieceTable getTextPieceTable()

getGrpprls

public SprmBuffer[] getGrpprls()

writeTo

@Deprecated
public void writeTo(HWPFFileSystem sys)
             throws java.io.IOException
Deprecated.

Throws:
java.io.IOException

writeTo

public void writeTo(HWPFOutputStream wordDocumentStream,
                    HWPFOutputStream tableStream)
             throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class DocumentProperties

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.DOPAbstractType
        extended by  org.apache.poi.hwpf.model.DocumentProperties
All Implemented Interfaces:
org.apache.poi.hdf.model.hdftypes.HDFType
@Internal
public final class DocumentProperties
extends DOPAbstractType

Comment me

Author:
Ryan Ackley

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.DOPAbstractType
field_1_formatFlags, field_10_wSpare, field_11_dxaHotz, field_12_cConsexHypLim, field_13_wSpare2, field_14_dttmCreated, field_15_dttmRevised, field_16_dttmLastPrint, field_17_nRevision, field_18_tmEdited, field_19_cWords, field_2_unused2, field_20_cCh, field_21_cPg, field_22_cParas, field_23_Edn, field_24_Edn1, field_25_cLines, field_26_cWordsFtnEnd, field_27_cChFtnEdn, field_28_cPgFtnEdn, field_29_cParasFtnEdn, field_3_footnoteInfo, field_30_cLinesFtnEdn, field_31_lKeyProtDoc, field_32_view, field_33_docinfo4, field_34_adt, field_35_doptypography, field_36_dogrid, field_37_docinfo5, field_38_docinfo6, field_39_asumyi, field_4_fOutlineDirtySave, field_40_cChWS, field_41_cChWSFtnEdn, field_42_grfDocEvents, field_43_virusinfo, field_44_Spare, field_45_reserved1, field_46_reserved2, field_47_cDBC, field_48_cDBCFtnEdn, field_49_reserved, field_5_docinfo, field_50_nfcFtnRef, field_51_nfcEdnRef, field_52_hpsZoonFontPag, field_53_dywDispPag, field_6_docinfo1, field_7_docinfo2, field_8_docinfo3, field_9_dxaTab
Constructor Summary
DocumentProperties(byte[] tableStream, int offset)
Deprecated. Use DocumentProperties(byte[],int,int) instead
DocumentProperties(byte[] tableStream, int offset, int length)
Method Summary
void | serialize(byte[] data, int offset)
void | writeTo(HWPFOutputStream tableStream)
Methods inherited from class org.apache.poi.hwpf.model.types.DOPAbstractType
fillFields, getAdt, getAsumyi, getCCh, getCChFtnEdn, getCChWS, getCChWSFtnEdn, getCConsexHypLim, getCDBC, getCDBCFtnEdn, getCLines, getCLinesFtnEdn, getCParas, getCParasFtnEdn, getCPg, getCPgFtnEdn, getCWords, getCWordsFtnEnd, getDocinfo, getDocinfo1, getDocinfo2, getDocinfo3, getDocinfo4, getDocinfo5, getDocinfo6, getDogrid, getDoptypography, getDttmCreated, getDttmLastPrint, getDttmRevised, getDxaHotz, getDxaTab, getDywDispPag, getEdn, getEdn1, getEpc, getFootnoteInfo, getFormatFlags, getFOutlineDirtySave, getFpc, getGrfDocEvents, getGrfSupression, getHpsZoonFontPag, getKeyVirusSession30, getLKeyProtDoc, getLvl, getNEdn, getNfcEdnRef, getNfcEdnRef1, getNfcFtnRef, getNfcFtnRef1, getNFtn, getNRevision, getReserved, getReserved1, getReserved2, getRncEdn, getRncFtn, getSize, getSpare, getTmEdited, getUnused2, getUnused5, getView, getVirusinfo, getWScaleSaved, getWSpare, getWSpare2, getWvkSaved, getZkSaved, isFAutoHyphen, isFAutoVersions, isFBackup, isFConvMailMergeEsc, isFDfltTrueType, isFDispFormFldSel, isFEmbedFonts, isFExactCWords, isFFacingPages, isFForcePageSizePag, isFFormNoFields, isFGramAllClean, isFGramAllDone, isFHaveVersions, isFHideLastVersion, isFHtmlDoc, isFHyphCapitals, isFIncludeFooter, isFIncludeHeader, isFLabelDoc, isFLinkStyles, isFLockAtn, isFLockRev, isFMapPrintTextColor, isFMinFontSizePag, isFMirrorMargins, isFMWSmallCaps, isFNoColumnBalance, isFNoLeading, isFNoSpaceRaiseLower, isFNoTabForInd, isFOnlyMacPics, isFOnlyWinPics, isFOrigWordTableRules, isFPagHidden, isFPagResults, isFPagSupressTopSpacing, isFPMHMainDoc, isFPrintBodyBeforeHdr, isFPrintFormData, isFProtEnabled, isFRevMarking, isFRMPrint, isFRMView, isFRotateFontW6, isFSaveFormData, isFShadeFormData, isFShowBreaksInFrames, isFSnapBorder, isFSubsetFonts, isFSuppressTopSPacingMac5, isFSupressSpdfAfterPageBreak, isFSupressTopSpacing, isFSwapBordersFacingPgs, isFTransparentMetafiles, isFTruncDxaExpand, isFVirusLoadSafe, isFVirusPrompted, isFWCFtnEdn, isFWidowControl, isFWrapTrailSpaces, isIGutterPos, isOldfConvMailMergeEsc, isOldfMapPrintTextColor, isOldfNoColumnBalance, isOldfNoSpaceRaiseLower, isOldfNoTabForInd, isOldfOrigWordTableRules, isOldfShowBreaksInFrames, isOldfSuppressSpbfAfterPageBreak, isOldfSupressTopSpacing, isOldfSwapBordersFacingPgs, isOldfTransparentMetafiles, isOldfWrapTrailSpaces, isUnused1, isUnused3, isUnused4, setAdt, setAsumyi, setCCh, setCChFtnEdn, setCChWS, setCChWSFtnEdn, setCConsexHypLim, setCDBC, setCDBCFtnEdn, setCLines, setCLinesFtnEdn, setCParas, setCParasFtnEdn, setCPg, setCPgFtnEdn, setCWords, setCWordsFtnEnd, setDocinfo, setDocinfo1, setDocinfo2, setDocinfo3, setDocinfo4, setDocinfo5, setDocinfo6, setDogrid, setDoptypography, setDttmCreated, setDttmLastPrint, setDttmRevised, setDxaHotz, setDxaTab, setDywDispPag, setEdn, setEdn1, setEpc, setFAutoHyphen, setFAutoVersions, setFBackup, setFConvMailMergeEsc, setFDfltTrueType, setFDispFormFldSel, setFEmbedFonts, setFExactCWords, setFFacingPages, setFForcePageSizePag, setFFormNoFields, setFGramAllClean, setFGramAllDone, setFHaveVersions, setFHideLastVersion, setFHtmlDoc, setFHyphCapitals, setFIncludeFooter, setFIncludeHeader, setFLabelDoc, setFLinkStyles, setFLockAtn, setFLockRev, setFMapPrintTextColor, setFMinFontSizePag, setFMirrorMargins, setFMWSmallCaps, setFNoColumnBalance, setFNoLeading, setFNoSpaceRaiseLower, setFNoTabForInd, setFOnlyMacPics, setFOnlyWinPics, setFootnoteInfo, setFOrigWordTableRules, setFormatFlags, setFOutlineDirtySave, setFPagHidden, setFPagResults, setFPagSupressTopSpacing, setFpc, setFPMHMainDoc, setFPrintBodyBeforeHdr, setFPrintFormData, setFProtEnabled, setFRevMarking, setFRMPrint, setFRMView, setFRotateFontW6, setFSaveFormData, setFShadeFormData, setFShowBreaksInFrames, setFSnapBorder, setFSubsetFonts, setFSuppressTopSPacingMac5, setFSupressSpdfAfterPageBreak, setFSupressTopSpacing, setFSwapBordersFacingPgs, setFTransparentMetafiles, setFTruncDxaExpand, setFVirusLoadSafe, setFVirusPrompted, setFWCFtnEdn, setFWidowControl, setFWrapTrailSpaces, setGrfDocEvents, setGrfSupression, setHpsZoonFontPag, setIGutterPos, setKeyVirusSession30, setLKeyProtDoc, setLvl, setNEdn, setNfcEdnRef, setNfcEdnRef1, setNfcFtnRef, setNfcFtnRef1, setNFtn, setNRevision, setOldfConvMailMergeEsc, setOldfMapPrintTextColor, setOldfNoColumnBalance, setOldfNoSpaceRaiseLower, setOldfNoTabForInd, setOldfOrigWordTableRules, setOldfShowBreaksInFrames, setOldfSuppressSpbfAfterPageBreak, setOldfSupressTopSpacing, setOldfSwapBordersFacingPgs, setOldfTransparentMetafiles, setOldfWrapTrailSpaces, setReserved, setReserved1, setReserved2, setRncEdn, setRncFtn, setSpare, setTmEdited, setUnused1, setUnused2, setUnused3, setUnused4, setUnused5, setView, setVirusinfo, setWScaleSaved, setWSpare, setWSpare2, setWvkSaved, setZkSaved, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DocumentProperties

public DocumentProperties(byte[] tableStream,
                          int offset)
Deprecated. Use DocumentProperties(byte[],int,int) instead

DocumentProperties

public DocumentProperties(byte[] tableStream,
                          int offset,
                          int length)
Method Detail

serialize

public void serialize(byte[] data,
                      int offset)
Overrides:
serialize in class DOPAbstractType

writeTo

public void writeTo(HWPFOutputStream tableStream)
             throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscherRecordHolder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class EscherRecordHolder

java.lang.Object
    extended by  org.apache.poi.hwpf.model.EscherRecordHolder

@Internal
public final class EscherRecordHolder
extends java.lang.Object

Based on AbstractEscherRecordHolder from HSSF.

Author:
Squeeself

Constructor Summary
EscherRecordHolder()
EscherRecordHolder(byte[] data, int offset, int size)
Method Summary
EscherRecord | findFirstWithId(short id) Descends into all our children, returning the first EscherRecord with the given id, or null if none found
java.util.List<? extends EscherContainerRecord> | getBStoreContainers()
java.util.List<? extends EscherContainerRecord> | getDgContainers()
java.util.List<? extends EscherContainerRecord> | getDggContainers()
EscherContainerRecord | getEscherContainer() If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.
java.util.List<EscherRecord> | getEscherRecords()
java.util.List<? extends EscherContainerRecord> | getSpContainers()
java.util.List<? extends EscherContainerRecord> | getSpgrContainers()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EscherRecordHolder

public EscherRecordHolder()

EscherRecordHolder

public EscherRecordHolder(byte[] data,
                          int offset,
                          int size)
Method Detail

getEscherRecords

public java.util.List<EscherRecord> getEscherRecords()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getEscherContainer

public EscherContainerRecord getEscherContainer()
If we have a EscherContainerRecord as one of our children (and most top level escher holders do), then return that.

findFirstWithId

public EscherRecord findFirstWithId(short id)
Descends into all our children, returning the first EscherRecord with the given id, or null if none found

getDgContainers

public java.util.List<? extends EscherContainerRecord> getDgContainers()

getDggContainers

public java.util.List<? extends EscherContainerRecord> getDggContainers()

getBStoreContainers

public java.util.List<? extends EscherContainerRecord> getBStoreContainers()

getSpgrContainers

public java.util.List<? extends EscherContainerRecord> getSpgrContainers()

getSpContainers

public java.util.List<? extends EscherContainerRecord> getSpContainers()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Ffn

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class Ffn

java.lang.Object
    extended by  org.apache.poi.hwpf.model.Ffn

@Internal
public final class Ffn
extends java.lang.Object

FFN - Font Family Name. FFN is a data structure that stores the names of the Main Font and that of Alternate font as an array of characters. It has also a header that stores info about the whole structure and the fonts

Author:
Praveen Mathew

Constructor Summary
Ffn(byte[] buf, int offset)
Method Summary
boolean | equals(java.lang.Object o)
int | get_cbFfnM1()
java.lang.String | getAltFontName()
byte | getChs()
byte[] | getFontSig()
java.lang.String | getMainFontName()
byte[] | getPanose()
int | getSize()
short | getWeight()
void | set_cbFfnM1(int _cbFfnM1)
byte[] | toByteArray()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Ffn

public Ffn(byte[] buf,
           int offset)
Method Detail

get_cbFfnM1

public int get_cbFfnM1()

getWeight

public short getWeight()

getChs

public byte getChs()

getPanose

public byte[] getPanose()

getFontSig

public byte[] getFontSig()

getSize

public int getSize()

getMainFontName

public java.lang.String getMainFontName()

getAltFontName

public java.lang.String getAltFontName()

set_cbFfnM1

public void set_cbFfnM1(int _cbFfnM1)

toByteArray

public byte[] toByteArray()

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FibBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FibBase

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FibBaseAbstractType
        extended by  org.apache.poi.hwpf.model.FibBase

@Internal
public class FibBase
extends FibBaseAbstractType

Base part of the File information Block (FibBase). Holds the core part of the FIB, from the first 32 bytes.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format.

Author:
Andrew C. Oliver; Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.FibBaseAbstractType
field_1_wIdent, field_10_flags2, field_11_Chs, field_12_chsTables, field_13_fcMin, field_14_fcMac, field_2_nFib, field_3_unused, field_4_lid, field_5_pnNext, field_6_flags1, field_7_nFibBack, field_8_lKey, field_9_envr
Constructor Summary
FibBase()
FibBase(byte[] std, int offset)
Method Summary
boolean | equals(java.lang.Object obj)
int | hashCode()
Methods inherited from class org.apache.poi.hwpf.model.types.FibBaseAbstractType
fillFields, getChs, getChsTables, getCQuickSaves, getEnvr, getFcMac, getFcMin, getFlags1, getFlags2, getFSpare0, getLid, getLKey, getNFib, getNFibBack, getPnNext, getSize, getUnused, getWIdent, isFComplex, isFDot, isFEmptySpecial, isFEncrypted, isFExtChar, isFFarEast, isFGlsy, isFHasPic, isFLoadOverride, isFLoadOverridePage, isFMac, isFObfuscated, isFReadOnlyRecommended, isFWhichTblStm, isFWriteReservation, isReserved1, isReserved2, serialize, serialize, setChs, setChsTables, setCQuickSaves, setEnvr, setFcMac, setFcMin, setFComplex, setFDot, setFEmptySpecial, setFEncrypted, setFExtChar, setFFarEast, setFGlsy, setFHasPic, setFlags1, setFlags2, setFLoadOverride, setFLoadOverridePage, setFMac, setFObfuscated, setFReadOnlyRecommended, setFSpare0, setFWhichTblStm, setFWriteReservation, setLid, setLKey, setNFib, setNFibBack, setPnNext, setReserved1, setReserved2, setUnused, setWIdent, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FibBase

public FibBase()

FibBase

public FibBase(byte[] std,
               int offset)
Method Detail

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FIBFieldHandler

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FIBFieldHandler

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FIBFieldHandler

@Internal
public final class FIBFieldHandler
extends java.lang.Object

Field Summary
static int | AUTOSAVESOURCE
static int | BKDEDN
static int | BKDFTN
static int | BKDMOTHER
static int | CLX
static int | CMDS
static int | DGGINFO
static int | DOCUNDO
static int | DOP
static int | FORMFLDSTTBS
static int | GRPXSTATNOWNERS
static int | MODIFIED
static int | PGDEDN
static int | PGDFTN
static int | PGDMOTHER
static int | PLCASUMY
static int | PLCDOAHDR
static int | PLCFANDREF
static int | PLCFANDTXT
static int | PLCFATNBKF
static int | PLCFATNBKL
static int | PLCFBKF
static int | PLCFBKL
static int | PLCFBTECHPX
static int | PLCFBTELVC
static int | PLCFBTEPAPX
static int | PLCFDOAMOM
static int | PLCFENDREF
static int | PLCFENDTXT
static int | PLCFFLDATN
static int | PLCFFLDEDN
static int | PLCFFLDFTN
static int | PLCFFLDHDR
static int | PLCFFLDHDRTXBX
static int | PLCFFLDMCR
static int | PLCFFLDMOM
static int | PLCFFLDTXBX
static int | PLCFFNDREF
static int | PLCFFNDTXT
static int | PLCFGLSY
static int | PLCFGRAM
static int | PLCFHDD
static int | PLCFHDRTXBXTXT
static int | PLCFLST
static int | PLCFLVC
static int | PLCFPAD
static int | PLCFPGDEDN
static int | PLCFPGDFTN
static int | PLCFPHE
static int | PLCFSEA
static int | PLCFSED
static int | PLCFSPL
static int | PLCFTXBXBKD
static int | PLCFTXBXHDRBKD
static int | PLCFTXBXTXT
static int | PLCFWKB
static int | PLCMCR
static int | PLCOCX
static int | PLCSPAHDR
static int | PLCSPAMOM
static int | PLCUPCRGBUSE
static int | PLCUPCUSP
static int | PLFLFO
static int | PLGOSL
static int | PMS
static int | PRDRVR
static int | PRENVLAND
static int | PRENVPORT
static int | RGBUSE
static int | ROUTESLIP
static int | STSHF
static int | STSHFORIG
static int | STTBAUTOCAPTION
static int | STTBCAPTION
static int | STTBFASSOC
static int | STTBFATNBKMK
static int | STTBFBKMK
static int | STTBFFFN
static int | STTBFINTFLD
static int | STTBFMCR
static int | STTBFNM
static int | STTBFRMARK
static int | STTBFUSSR
static int | STTBGLSY
static int | STTBGLSYSTYLE
static int | STTBLISTNAMES
static int | STTBSAVEDBY
static int | STTBTTMBD
static int | STWUSER
static int | UNUSED
static int | USKF
static int | USP
static int | WSS
Method Summary
void | clearFields()
int | getFieldOffset(int field)
int | getFieldsCount()
int | getFieldSize(int field)
void | setFieldOffset(int field, int offset)
void | setFieldSize(int field, int size)
int | sizeInBytes()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

STSHFORIG

public static final int STSHFORIG
See Also:
Constant Field Values

STSHF

public static final int STSHF
See Also:
Constant Field Values

PLCFFNDREF

public static final int PLCFFNDREF
See Also:
Constant Field Values

PLCFFNDTXT

public static final int PLCFFNDTXT
See Also:
Constant Field Values

PLCFANDREF

public static final int PLCFANDREF
See Also:
Constant Field Values

PLCFANDTXT

public static final int PLCFANDTXT
See Also:
Constant Field Values

PLCFSED

public static final int PLCFSED
See Also:
Constant Field Values

PLCFPAD

public static final int PLCFPAD
See Also:
Constant Field Values

PLCFPHE

public static final int PLCFPHE
See Also:
Constant Field Values

STTBGLSY

public static final int STTBGLSY
See Also:
Constant Field Values

PLCFGLSY

public static final int PLCFGLSY
See Also:
Constant Field Values

PLCFHDD

public static final int PLCFHDD
See Also:
Constant Field Values

PLCFBTECHPX

public static final int PLCFBTECHPX
See Also:
Constant Field Values

PLCFBTEPAPX

public static final int PLCFBTEPAPX
See Also:
Constant Field Values

PLCFSEA

public static final int PLCFSEA
See Also:
Constant Field Values

STTBFFFN

public static final int STTBFFFN
See Also:
Constant Field Values

PLCFFLDMOM

public static final int PLCFFLDMOM
See Also:
Constant Field Values

PLCFFLDHDR

public static final int PLCFFLDHDR
See Also:
Constant Field Values

PLCFFLDFTN

public static final int PLCFFLDFTN
See Also:
Constant Field Values

PLCFFLDATN

public static final int PLCFFLDATN
See Also:
Constant Field Values

PLCFFLDMCR

public static final int PLCFFLDMCR
See Also:
Constant Field Values

STTBFBKMK

public static final int STTBFBKMK
See Also:
Constant Field Values

PLCFBKF

public static final int PLCFBKF
See Also:
Constant Field Values

PLCFBKL

public static final int PLCFBKL
See Also:
Constant Field Values

CMDS

public static final int CMDS
See Also:
Constant Field Values

PLCMCR

public static final int PLCMCR
See Also:
Constant Field Values

STTBFMCR

public static final int STTBFMCR
See Also:
Constant Field Values

PRDRVR

public static final int PRDRVR
See Also:
Constant Field Values

PRENVPORT

public static final int PRENVPORT
See Also:
Constant Field Values

PRENVLAND

public static final int PRENVLAND
See Also:
Constant Field Values

WSS

public static final int WSS
See Also:
Constant Field Values

DOP

public static final int DOP
See Also:
Constant Field Values

STTBFASSOC

public static final int STTBFASSOC
See Also:
Constant Field Values

CLX

public static final int CLX
See Also:
Constant Field Values

PLCFPGDFTN

public static final int PLCFPGDFTN
See Also:
Constant Field Values

AUTOSAVESOURCE

public static final int AUTOSAVESOURCE
See Also:
Constant Field Values

GRPXSTATNOWNERS

public static final int GRPXSTATNOWNERS
See Also:
Constant Field Values

STTBFATNBKMK

public static final int STTBFATNBKMK
See Also:
Constant Field Values

PLCFDOAMOM

public static final int PLCFDOAMOM
See Also:
Constant Field Values

PLCDOAHDR

public static final int PLCDOAHDR
See Also:
Constant Field Values

PLCSPAMOM

public static final int PLCSPAMOM
See Also:
Constant Field Values

PLCSPAHDR

public static final int PLCSPAHDR
See Also:
Constant Field Values

PLCFATNBKF

public static final int PLCFATNBKF
See Also:
Constant Field Values

PLCFATNBKL

public static final int PLCFATNBKL
See Also:
Constant Field Values

PMS

public static final int PMS
See Also:
Constant Field Values

FORMFLDSTTBS

public static final int FORMFLDSTTBS
See Also:
Constant Field Values

PLCFENDREF

public static final int PLCFENDREF
See Also:
Constant Field Values

PLCFENDTXT

public static final int PLCFENDTXT
See Also:
Constant Field Values

PLCFFLDEDN

public static final int PLCFFLDEDN
See Also:
Constant Field Values

PLCFPGDEDN

public static final int PLCFPGDEDN
See Also:
Constant Field Values

DGGINFO

public static final int DGGINFO
See Also:
Constant Field Values

STTBFRMARK

public static final int STTBFRMARK
See Also:
Constant Field Values

STTBCAPTION

public static final int STTBCAPTION
See Also:
Constant Field Values

STTBAUTOCAPTION

public static final int STTBAUTOCAPTION
See Also:
Constant Field Values

PLCFWKB

public static final int PLCFWKB
See Also:
Constant Field Values

PLCFSPL

public static final int PLCFSPL
See Also:
Constant Field Values

PLCFTXBXTXT

public static final int PLCFTXBXTXT
See Also:
Constant Field Values

PLCFFLDTXBX

public static final int PLCFFLDTXBX
See Also:
Constant Field Values

PLCFHDRTXBXTXT

public static final int PLCFHDRTXBXTXT
See Also:
Constant Field Values

PLCFFLDHDRTXBX

public static final int PLCFFLDHDRTXBX
See Also:
Constant Field Values

STWUSER

public static final int STWUSER
See Also:
Constant Field Values

STTBTTMBD

public static final int STTBTTMBD
See Also:
Constant Field Values

UNUSED

public static final int UNUSED
See Also:
Constant Field Values

PGDMOTHER

public static final int PGDMOTHER
See Also:
Constant Field Values

BKDMOTHER

public static final int BKDMOTHER
See Also:
Constant Field Values

PGDFTN

public static final int PGDFTN
See Also:
Constant Field Values

BKDFTN

public static final int BKDFTN
See Also:
Constant Field Values

PGDEDN

public static final int PGDEDN
See Also:
Constant Field Values

BKDEDN

public static final int BKDEDN
See Also:
Constant Field Values

STTBFINTFLD

public static final int STTBFINTFLD
See Also:
Constant Field Values

ROUTESLIP

public static final int ROUTESLIP
See Also:
Constant Field Values

STTBSAVEDBY

public static final int STTBSAVEDBY
See Also:
Constant Field Values

STTBFNM

public static final int STTBFNM
See Also:
Constant Field Values

PLCFLST

public static final int PLCFLST
See Also:
Constant Field Values

PLFLFO

public static final int PLFLFO
See Also:
Constant Field Values

PLCFTXBXBKD

public static final int PLCFTXBXBKD
See Also:
Constant Field Values

PLCFTXBXHDRBKD

public static final int PLCFTXBXHDRBKD
See Also:
Constant Field Values

DOCUNDO

public static final int DOCUNDO
See Also:
Constant Field Values

RGBUSE

public static final int RGBUSE
See Also:
Constant Field Values

USP

public static final int USP
See Also:
Constant Field Values

USKF

public static final int USKF
See Also:
Constant Field Values

PLCUPCRGBUSE

public static final int PLCUPCRGBUSE
See Also:
Constant Field Values

PLCUPCUSP

public static final int PLCUPCUSP
See Also:
Constant Field Values

STTBGLSYSTYLE

public static final int STTBGLSYSTYLE
See Also:
Constant Field Values

PLGOSL

public static final int PLGOSL
See Also:
Constant Field Values

PLCOCX

public static final int PLCOCX
See Also:
Constant Field Values

PLCFBTELVC

public static final int PLCFBTELVC
See Also:
Constant Field Values

MODIFIED

public static final int MODIFIED
See Also:
Constant Field Values

PLCFLVC

public static final int PLCFLVC
See Also:
Constant Field Values

PLCASUMY

public static final int PLCASUMY
See Also:
Constant Field Values

PLCFGRAM

public static final int PLCFGRAM
See Also:
Constant Field Values

STTBLISTNAMES

public static final int STTBLISTNAMES
See Also:
Constant Field Values

STTBFUSSR

public static final int STTBFUSSR
See Also:
Constant Field Values
Method Detail

clearFields

public void clearFields()

getFieldOffset

public int getFieldOffset(int field)

getFieldSize

public int getFieldSize(int field)

setFieldOffset

public void setFieldOffset(int field,
                           int offset)

setFieldSize

public void setFieldSize(int field,
                         int size)

sizeInBytes

public int sizeInBytes()

getFieldsCount

public int getFieldsCount()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FieldDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FLDAbstractType
        extended by  org.apache.poi.hwpf.model.FieldDescriptor
All Implemented Interfaces:
org.apache.poi.hdf.model.hdftypes.HDFType
@Internal
public final class FieldDescriptor
extends FLDAbstractType

Class for the FLD structure.

Author:
Cedric Bosdonnat

Field Summary
static int | FIELD_BEGIN_MARK
static int | FIELD_END_MARK
static int | FIELD_SEPARATOR_MARK
Fields inherited from class org.apache.poi.hwpf.model.types.FLDAbstractType
field_1_chHolder, field_2_flt
Constructor Summary
FieldDescriptor(byte[] data)
Method Summary
int | getBoundaryType()
int | getFieldType()
boolean | isHasSep()
boolean | isLocked()
boolean | isNested()
boolean | isPrivateResult()
boolean | isResultDirty()
boolean | isResultEdited()
boolean | isZombieEmbed()
Methods inherited from class org.apache.poi.hwpf.model.types.FLDAbstractType
fillFields, getCh, getChHolder, getFlt, getReserved, getSize, isFDiffer, isFHasSep, isFLocked, isFNested, isFPrivateResult, isFResultDirty, isFResultEdited, isFZombieEmbed, serialize, setCh, setChHolder, setFDiffer, setFHasSep, setFLocked, setFlt, setFNested, setFPrivateResult, setFResultDirty, setFResultEdited, setFZombieEmbed, setReserved, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FIELD_BEGIN_MARK

public static final int FIELD_BEGIN_MARK
See Also:
Constant Field Values

FIELD_SEPARATOR_MARK

public static final int FIELD_SEPARATOR_MARK
See Also:
Constant Field Values

FIELD_END_MARK

public static final int FIELD_END_MARK
See Also:
Constant Field Values
Constructor Detail

FieldDescriptor

public FieldDescriptor(byte[] data)
Method Detail

getBoundaryType

public int getBoundaryType()

getFieldType

public int getFieldType()

isZombieEmbed

public boolean isZombieEmbed()

isResultDirty

public boolean isResultDirty()

isResultEdited

public boolean isResultEdited()

isLocked

public boolean isLocked()

isPrivateResult

public boolean isPrivateResult()

isNested

public boolean isNested()

isHasSep

public boolean isHasSep()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldsDocumentPart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.model
Enum FieldsDocumentPart

java.lang.Object
    extended by  java.lang.Enum<FieldsDocumentPart>
        extended by  org.apache.poi.hwpf.model.FieldsDocumentPart
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FieldsDocumentPart>
@Internal
public enum FieldsDocumentPart
extends java.lang.Enum<FieldsDocumentPart>

Enum Constant Summary
ANNOTATIONS
annotation subdocument
ENDNOTES
endnote subdocument
FOOTNOTES
footnote subdocument
HEADER
header subdocument
HEADER_TEXTBOX
header textbox subdoc
MAIN
main document
TEXTBOX
textbox subdoc
Method Summary
int | getFibFieldsField()
static FieldsDocumentPart | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FieldsDocumentPart[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ANNOTATIONS

public static final FieldsDocumentPart ANNOTATIONS
annotation subdocument

ENDNOTES

public static final FieldsDocumentPart ENDNOTES
endnote subdocument

FOOTNOTES

public static final FieldsDocumentPart FOOTNOTES
footnote subdocument

HEADER

public static final FieldsDocumentPart HEADER
header subdocument

HEADER_TEXTBOX

public static final FieldsDocumentPart HEADER_TEXTBOX
header textbox subdoc

MAIN

public static final FieldsDocumentPart MAIN
main document

TEXTBOX

public static final FieldsDocumentPart TEXTBOX
textbox subdoc

Method Detail

values

public static FieldsDocumentPart[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FieldsDocumentPart c : FieldsDocumentPart.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FieldsDocumentPart valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getFibFieldsField

public int getFibFieldsField()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


FieldsTables

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FieldsTables

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FieldsTables

@Internal
public class FieldsTables
extends java.lang.Object

This class provides access to all the fields Plex.

Author:
Cedric Bosdonnat

Field Summary
static int | PLCFFLDATN Deprecated.
static int | PLCFFLDEDN Deprecated.
static int | PLCFFLDFTN Deprecated.
static int | PLCFFLDHDR Deprecated.
static int | PLCFFLDHDRTXBX Deprecated.
static int | PLCFFLDMOM Deprecated.
static int | PLCFFLDTXBX Deprecated.
Constructor Summary
FieldsTables(byte[] tableStream, FileInformationBlock fib)
Method Summary
java.util.ArrayList<PlexOfField> | getFieldsPLCF(FieldsDocumentPart part)
java.util.ArrayList<PlexOfField> | getFieldsPLCF(int partIndex) Deprecated.
void | write(FileInformationBlock fib, HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PLCFFLDATN

@Deprecated
public static final int PLCFFLDATN
Deprecated.
annotation subdocument

See Also:
Constant Field Values

PLCFFLDEDN

@Deprecated
public static final int PLCFFLDEDN
Deprecated.
endnote subdocument

See Also:
Constant Field Values

PLCFFLDFTN

@Deprecated
public static final int PLCFFLDFTN
Deprecated.
footnote subdocument

See Also:
Constant Field Values

PLCFFLDHDR

@Deprecated
public static final int PLCFFLDHDR
Deprecated.
header subdocument

See Also:
Constant Field Values

PLCFFLDHDRTXBX

@Deprecated
public static final int PLCFFLDHDRTXBX
Deprecated.
header textbox subdoc

See Also:
Constant Field Values

PLCFFLDMOM

@Deprecated
public static final int PLCFFLDMOM
Deprecated.
main document

See Also:
Constant Field Values

PLCFFLDTXBX

@Deprecated
public static final int PLCFFLDTXBX
Deprecated.
textbox subdoc

See Also:
Constant Field Values
Constructor Detail

FieldsTables

public FieldsTables(byte[] tableStream,
                    FileInformationBlock fib)
Method Detail

getFieldsPLCF

public java.util.ArrayList<PlexOfField> getFieldsPLCF(FieldsDocumentPart part)

getFieldsPLCF

@Deprecated
public java.util.ArrayList<PlexOfField> getFieldsPLCF(int partIndex)
Deprecated.

write

public void write(FileInformationBlock fib,
                  HWPFOutputStream tableStream)
           throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileInformationBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FileInformationBlock

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FileInformationBlock
All Implemented Interfaces:
java.lang.Cloneable
@Internal
public final class FileInformationBlock
extends java.lang.Object
implements java.lang.Cloneable

The File Information Block (FIB). Holds pointers to various bits of the file, and lots of flags which specify properties of the document. The FibBase class, holds the first 32 bytes. The next part, the fibRgW / FibRgW97, is handled by FibRgW97. The next part, the fibRgLw / The FibRgLw97, is handled by the FibRgLw. Finally, the rest of the fields are handled by the FIBFieldHandler.

Author:
andy

Field Summary
static POILogger logger
Constructor Summary
FileInformationBlock(byte[] mainDocument)
Creates a new instance of FileInformationBlock
Method Summary
void | clearOffsetsSizes()
void | fillVariableFields(byte[] mainDocument, byte[] tableStream)
int | getCbMac() How many bytes of the main stream contain real data.
int | getFcClx()
int | getFcDggInfo()
int | getFcDop()
int | getFcPlcfbkf()
int | getFcPlcfbkl()
int | getFcPlcfbteChpx()
int | getFcPlcfbtePapx()
int | getFcPlcffldAtn() Deprecated.
int | getFcPlcffldEdn() Deprecated.
int | getFcPlcffldFtn() Deprecated.
int | getFcPlcffldHdr() Deprecated.
int | getFcPlcffldHdrtxbx() Deprecated.
int | getFcPlcffldMom() Deprecated.
int | getFcPlcffldTxbx() Deprecated.
int | getFcPlcfLst()
int | getFcPlcfsed()
int | getFcPlcspaMom() Deprecated.
int | getFcPlfLfo()
int | getFcStshf()
int | getFcSttbfbkmk()
int | getFcSttbfffn()
int | getFcSttbfRMark()
int | getFcSttbSavedBy()
FibBase | getFibBase()
int | getFieldsPlcfLength(FieldsDocumentPart part)
int | getFieldsPlcfOffset(FieldsDocumentPart part)
int | getFSPAPlcfLength(FSPADocumentPart part)
int | getFSPAPlcfOffset(FSPADocumentPart part)
int | getLcbClx()
int | getLcbDggInfo()
int | getLcbDop()
int | getLcbPlcfbkf()
int | getLcbPlcfbkl()
int | getLcbPlcfbteChpx()
int | getLcbPlcfbtePapx()
int | getLcbPlcffldAtn() Deprecated.
int | getLcbPlcffldEdn() Deprecated.
int | getLcbPlcffldFtn() Deprecated.
int | getLcbPlcffldHdr() Deprecated.
int | getLcbPlcffldHdrtxbx() Deprecated.
int | getLcbPlcffldMom() Deprecated.
int | getLcbPlcffldTxbx() Deprecated.
int | getLcbPlcfLst()
int | getLcbPlcfsed()
int | getLcbPlcspaMom() Deprecated.
int | getLcbPlfLfo()
int | getLcbStshf()
int | getLcbSttbfbkmk()
int | getLcbSttbfffn()
int | getLcbSttbfRMark()
int | getLcbSttbSavedBy()
int | getModifiedHigh()
int | getModifiedLow()
int | getNFib()
int | getNotesDescriptorsOffset(NoteType noteType)
int | getNotesDescriptorsSize(NoteType noteType)
int | getNotesTextPositionsOffset(NoteType noteType)
int | getNotesTextPositionsSize(NoteType noteType)
int | getPlcfHddOffset() Return the offset to the PlcfHdd, in the table stream, i.e.
int | getPlcfHddSize() Return the size of the PlcfHdd, in the table stream, i.e.
int | getSize()
int | getSubdocumentTextStreamLength(SubdocumentType type)
void | setCbMac(int cbMac) Updates the count of the number of bytes in the main stream which contain real data
void | setFcClx(int fcClx)
void | setFcDop(int fcDop)
void | setFcPlcfbkf(int offset)
void | setFcPlcfbkl(int offset)
void | setFcPlcfbteChpx(int fcPlcfBteChpx)
void | setFcPlcfbtePapx(int fcPlcfBtePapx)
void | setFcPlcffldAtn(int offset) Deprecated.
void | setFcPlcffldEdn(int offset) Deprecated.
void | setFcPlcffldFtn(int offset) Deprecated.
void | setFcPlcffldHdr(int offset) Deprecated.
void | setFcPlcffldHdrtxbx(int offset) Deprecated.
void | setFcPlcffldMom(int offset) Deprecated.
void | setFcPlcffldTxbx(int offset) Deprecated.
void | setFcPlcfLst(int fcPlcfLst)
void | setFcPlcfsed(int fcPlcfSed)
void | setFcPlfLfo(int fcPlfLfo)
void | setFcStshf(int fcStshf)
void | setFcSttbfbkmk(int offset)
void | setFcSttbfffn(int fcSttbFffn)
void | setFcSttbfRMark(int fcSttbfRMark)
void | setFcSttbSavedBy(int fcSttbSavedBy)
void | setFieldsPlcfLength(FieldsDocumentPart part, int length)
void | setFieldsPlcfOffset(FieldsDocumentPart part, int offset)
void | setFSPAPlcfLength(FSPADocumentPart part, int length)
void | setFSPAPlcfOffset(FSPADocumentPart part, int offset)
void | setLcbClx(int lcbClx)
void | setLcbDop(int lcbDop)
void | setLcbPlcfbkf(int length)
void | setLcbPlcfbkl(int length)
void | setLcbPlcfbteChpx(int lcbPlcfBteChpx)
void | setLcbPlcfbtePapx(int lcbPlcfBtePapx)
void | setLcbPlcffldAtn(int size) Deprecated.
void | setLcbPlcffldEdn(int size) Deprecated.
void | setLcbPlcffldFtn(int size) Deprecated.
void | setLcbPlcffldHdr(int size) Deprecated.
void | setLcbPlcffldHdrtxbx(int size) Deprecated.
void | setLcbPlcffldMom(int size) Deprecated.
void | setLcbPlcffldTxbx(int size) Deprecated.
void | setLcbPlcfLst(int lcbPlcfLst)
void | setLcbPlcfsed(int lcbPlcfSed)
void | setLcbPlfLfo(int lcbPlfLfo)
void | setLcbStshf(int lcbStshf)
void | setLcbSttbfbkmk(int length)
void | setLcbSttbfffn(int lcbSttbFffn)
void | setLcbSttbfRMark(int lcbSttbfRMark)
void | setLcbSttbSavedBy(int fcSttbSavedBy)
void | setModifiedHigh(int modifiedHigh)
void | setModifiedLow(int modifiedLow)
void | setNotesDescriptorsOffset(NoteType noteType, int offset)
void | setNotesDescriptorsSize(NoteType noteType, int offset)
void | setNotesTextPositionsOffset(NoteType noteType, int offset)
void | setNotesTextPositionsSize(NoteType noteType, int offset)
void | setPlcfHddOffset(int fcPlcfHdd)
void | setPlcfHddSize(int lcbPlcfHdd)
void | setSubdocumentTextStreamLength(SubdocumentType type, int length)
java.lang.String | toString()
void | writeTo(byte[] mainStream, HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

logger

public static final POILogger logger
Constructor Detail

FileInformationBlock

public FileInformationBlock(byte[] mainDocument)
Creates a new instance of FileInformationBlock

Method Detail

fillVariableFields

public void fillVariableFields(byte[] mainDocument,
                               byte[] tableStream)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getNFib

public int getNFib()

getFcDop

public int getFcDop()

setFcDop

public void setFcDop(int fcDop)

getLcbDop

public int getLcbDop()

setLcbDop

public void setLcbDop(int lcbDop)

getFcStshf

public int getFcStshf()

getLcbStshf

public int getLcbStshf()

setFcStshf

public void setFcStshf(int fcStshf)

setLcbStshf

public void setLcbStshf(int lcbStshf)

getFcClx

public int getFcClx()

getLcbClx

public int getLcbClx()

setFcClx

public void setFcClx(int fcClx)

setLcbClx

public void setLcbClx(int lcbClx)

getFcPlcfbteChpx

public int getFcPlcfbteChpx()

getLcbPlcfbteChpx

public int getLcbPlcfbteChpx()

setFcPlcfbteChpx

public void setFcPlcfbteChpx(int fcPlcfBteChpx)

setLcbPlcfbteChpx

public void setLcbPlcfbteChpx(int lcbPlcfBteChpx)

getFcPlcfbtePapx

public int getFcPlcfbtePapx()

getLcbPlcfbtePapx

public int getLcbPlcfbtePapx()

setFcPlcfbtePapx

public void setFcPlcfbtePapx(int fcPlcfBtePapx)

setLcbPlcfbtePapx

public void setLcbPlcfbtePapx(int lcbPlcfBtePapx)

getFcPlcfsed

public int getFcPlcfsed()

getLcbPlcfsed

public int getLcbPlcfsed()

setFcPlcfsed

public void setFcPlcfsed(int fcPlcfSed)

setLcbPlcfsed

public void setLcbPlcfsed(int lcbPlcfSed)

getFcPlcfLst

public int getFcPlcfLst()

getLcbPlcfLst

public int getLcbPlcfLst()

setFcPlcfLst

public void setFcPlcfLst(int fcPlcfLst)

setLcbPlcfLst

public void setLcbPlcfLst(int lcbPlcfLst)

getFcPlfLfo

public int getFcPlfLfo()

getLcbPlfLfo

public int getLcbPlfLfo()

getFcSttbfbkmk

public int getFcSttbfbkmk()
Returns:
Offset in table stream of the STTBF that records bookmark names in the main document

setFcSttbfbkmk

public void setFcSttbfbkmk(int offset)

getLcbSttbfbkmk

public int getLcbSttbfbkmk()
Returns:
Count of bytes in Sttbfbkmk

setLcbSttbfbkmk

public void setLcbSttbfbkmk(int length)

getFcPlcfbkf

public int getFcPlcfbkf()
Returns:
Offset in table stream of the PLCF that records the beginning CP offsets of bookmarks in the main document. See BKF structure definition.

setFcPlcfbkf

public void setFcPlcfbkf(int offset)

getLcbPlcfbkf

public int getLcbPlcfbkf()
Returns:
Count of bytes in Plcfbkf

setLcbPlcfbkf

public void setLcbPlcfbkf(int length)

getFcPlcfbkl

public int getFcPlcfbkl()
Returns:
Offset in table stream of the PLCF that records the ending CP offsets of bookmarks recorded in the main document. No structure is stored in this PLCF.

setFcPlcfbkl

public void setFcPlcfbkl(int offset)

getLcbPlcfbkl

public int getLcbPlcfbkl()
Returns:
Count of bytes in Plcfbkl

setLcbPlcfbkl

public void setLcbPlcfbkl(int length)

setFcPlfLfo

public void setFcPlfLfo(int fcPlfLfo)

setLcbPlfLfo

public void setLcbPlfLfo(int lcbPlfLfo)

getFcSttbfffn

public int getFcSttbfffn()

getLcbSttbfffn

public int getLcbSttbfffn()

setFcSttbfffn

public void setFcSttbfffn(int fcSttbFffn)

setLcbSttbfffn

public void setLcbSttbfffn(int lcbSttbFffn)

getFcSttbfRMark

public int getFcSttbfRMark()

getLcbSttbfRMark

public int getLcbSttbfRMark()

setFcSttbfRMark

public void setFcSttbfRMark(int fcSttbfRMark)

setLcbSttbfRMark

public void setLcbSttbfRMark(int lcbSttbfRMark)

getPlcfHddOffset

public int getPlcfHddOffset()
Return the offset to the PlcfHdd, in the table stream, i.e. fcPlcfHdd

getPlcfHddSize

public int getPlcfHddSize()
Return the size of the PlcfHdd, in the table stream, i.e. lcbPlcfHdd

setPlcfHddOffset

public void setPlcfHddOffset(int fcPlcfHdd)

setPlcfHddSize

public void setPlcfHddSize(int lcbPlcfHdd)

getFcSttbSavedBy

public int getFcSttbSavedBy()

getLcbSttbSavedBy

public int getLcbSttbSavedBy()

setFcSttbSavedBy

public void setFcSttbSavedBy(int fcSttbSavedBy)

setLcbSttbSavedBy

public void setLcbSttbSavedBy(int fcSttbSavedBy)

getModifiedLow

public int getModifiedLow()

getModifiedHigh

public int getModifiedHigh()

setModifiedLow

public void setModifiedLow(int modifiedLow)

setModifiedHigh

public void setModifiedHigh(int modifiedHigh)

getCbMac

public int getCbMac()
How many bytes of the main stream contain real data.

setCbMac

public void setCbMac(int cbMac)
Updates the count of the number of bytes in the main stream which contain real data

getSubdocumentTextStreamLength

public int getSubdocumentTextStreamLength(SubdocumentType type)
Returns:
length of specified subdocument text stream in characters

setSubdocumentTextStreamLength

public void setSubdocumentTextStreamLength(SubdocumentType type,
                                           int length)

clearOffsetsSizes

public void clearOffsetsSizes()

getFieldsPlcfOffset

public int getFieldsPlcfOffset(FieldsDocumentPart part)

getFieldsPlcfLength

public int getFieldsPlcfLength(FieldsDocumentPart part)

setFieldsPlcfOffset

public void setFieldsPlcfOffset(FieldsDocumentPart part,
                                int offset)

setFieldsPlcfLength

public void setFieldsPlcfLength(FieldsDocumentPart part,
                                int length)

getFcPlcffldAtn

@Deprecated
public int getFcPlcffldAtn()
Deprecated.

getLcbPlcffldAtn

@Deprecated
public int getLcbPlcffldAtn()
Deprecated.

setFcPlcffldAtn

@Deprecated
public void setFcPlcffldAtn(int offset)
Deprecated.

setLcbPlcffldAtn

@Deprecated
public void setLcbPlcffldAtn(int size)
Deprecated.

getFcPlcffldEdn

@Deprecated
public int getFcPlcffldEdn()
Deprecated.

getLcbPlcffldEdn

@Deprecated
public int getLcbPlcffldEdn()
Deprecated.

setFcPlcffldEdn

@Deprecated
public void setFcPlcffldEdn(int offset)
Deprecated.

setLcbPlcffldEdn

@Deprecated
public void setLcbPlcffldEdn(int size)
Deprecated.

getFcPlcffldFtn

@Deprecated
public int getFcPlcffldFtn()
Deprecated.

getLcbPlcffldFtn

@Deprecated
public int getLcbPlcffldFtn()
Deprecated.

setFcPlcffldFtn

@Deprecated
public void setFcPlcffldFtn(int offset)
Deprecated.

setLcbPlcffldFtn

@Deprecated
public void setLcbPlcffldFtn(int size)
Deprecated.

getFcPlcffldHdr

@Deprecated
public int getFcPlcffldHdr()
Deprecated.

getLcbPlcffldHdr

@Deprecated
public int getLcbPlcffldHdr()
Deprecated.

setFcPlcffldHdr

@Deprecated
public void setFcPlcffldHdr(int offset)
Deprecated.

setLcbPlcffldHdr

@Deprecated
public void setLcbPlcffldHdr(int size)
Deprecated.

getFcPlcffldHdrtxbx

@Deprecated
public int getFcPlcffldHdrtxbx()
Deprecated.

getLcbPlcffldHdrtxbx

@Deprecated
public int getLcbPlcffldHdrtxbx()
Deprecated.

setFcPlcffldHdrtxbx

@Deprecated
public void setFcPlcffldHdrtxbx(int offset)
Deprecated.

setLcbPlcffldHdrtxbx

@Deprecated
public void setLcbPlcffldHdrtxbx(int size)
Deprecated.

getFcPlcffldMom

@Deprecated
public int getFcPlcffldMom()
Deprecated.

getLcbPlcffldMom

@Deprecated
public int getLcbPlcffldMom()
Deprecated.

setFcPlcffldMom

@Deprecated
public void setFcPlcffldMom(int offset)
Deprecated.

setLcbPlcffldMom

@Deprecated
public void setLcbPlcffldMom(int size)
Deprecated.

getFcPlcffldTxbx

@Deprecated
public int getFcPlcffldTxbx()
Deprecated.

getLcbPlcffldTxbx

@Deprecated
public int getLcbPlcffldTxbx()
Deprecated.

setFcPlcffldTxbx

@Deprecated
public void setFcPlcffldTxbx(int offset)
Deprecated.

setLcbPlcffldTxbx

@Deprecated
public void setLcbPlcffldTxbx(int size)
Deprecated.

getFSPAPlcfOffset

public int getFSPAPlcfOffset(FSPADocumentPart part)

getFSPAPlcfLength

public int getFSPAPlcfLength(FSPADocumentPart part)

setFSPAPlcfOffset

public void setFSPAPlcfOffset(FSPADocumentPart part,
                              int offset)

setFSPAPlcfLength

public void setFSPAPlcfLength(FSPADocumentPart part,
                              int length)

getFcPlcspaMom

@Deprecated
public int getFcPlcspaMom()
Deprecated.

getLcbPlcspaMom

@Deprecated
public int getLcbPlcspaMom()
Deprecated.

getFcDggInfo

public int getFcDggInfo()

getLcbDggInfo

public int getLcbDggInfo()

getNotesDescriptorsOffset

public int getNotesDescriptorsOffset(NoteType noteType)

setNotesDescriptorsOffset

public void setNotesDescriptorsOffset(NoteType noteType,
                                      int offset)

getNotesDescriptorsSize

public int getNotesDescriptorsSize(NoteType noteType)

setNotesDescriptorsSize

public void setNotesDescriptorsSize(NoteType noteType,
                                    int offset)

getNotesTextPositionsOffset

public int getNotesTextPositionsOffset(NoteType noteType)

setNotesTextPositionsOffset

public void setNotesTextPositionsOffset(NoteType noteType,
                                        int offset)

getNotesTextPositionsSize

public int getNotesTextPositionsSize(NoteType noteType)

setNotesTextPositionsSize

public void setNotesTextPositionsSize(NoteType noteType,
                                      int offset)

writeTo

public void writeTo(byte[] mainStream,
                    HWPFOutputStream tableStream)
             throws java.io.IOException
Throws:
java.io.IOException

getSize

public int getSize()

getFibBase

public FibBase getFibBase()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FontTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FontTable

@Internal
public final class FontTable
extends java.lang.Object

FontTable or in MS terminology sttbfffn is a common data structure written in all Word files. The sttbfffn is an sttbf where each string is an FFN structure instead of pascal-style strings. An sttbf is a string Table stored in file. Thus sttbffn is like an Sttbf with an array of FFN structures that stores the font name strings

Author:
Praveen Mathew

Constructor Summary
FontTable(byte[] buf, int offset, int lcbSttbfffn)
Method Summary
boolean | equals(java.lang.Object o)
java.lang.String | getAltFont(int chpFtc)
short | getExtraDataSz()
Ffn[] | getFontNames()
java.lang.String | getMainFont(int chpFtc)
int | getSize()
short | getStringCount()
void | setStringCount(short stringCount)
void | writeTo(HWPFFileSystem sys) Deprecated.
void | writeTo(HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FontTable

public FontTable(byte[] buf,
                 int offset,
                 int lcbSttbfffn)
Method Detail

getStringCount

public short getStringCount()

getExtraDataSz

public short getExtraDataSz()

getFontNames

public Ffn[] getFontNames()

getSize

public int getSize()

getMainFont

public java.lang.String getMainFont(int chpFtc)

getAltFont

public java.lang.String getAltFont(int chpFtc)

setStringCount

public void setStringCount(short stringCount)

writeTo

@Deprecated
public void writeTo(HWPFFileSystem sys)
             throws java.io.IOException
Deprecated.

Throws:
java.io.IOException

writeTo

public void writeTo(HWPFOutputStream tableStream)
             throws java.io.IOException
Throws:
java.io.IOException

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FootnoteReferenceDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FootnoteReferenceDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FRDAbstractType
        extended by  org.apache.poi.hwpf.model.FootnoteReferenceDescriptor
All Implemented Interfaces:
java.lang.Cloneable
@Internal
public final class FootnoteReferenceDescriptor
extends FRDAbstractType
implements java.lang.Cloneable

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.FRDAbstractType
field_1_nAuto
Constructor Summary
FootnoteReferenceDescriptor()
FootnoteReferenceDescriptor(byte[] data, int offset)
Method Summary
protected FootnoteReferenceDescriptor | clone()
boolean | equals(java.lang.Object obj)
int | hashCode()
boolean | isEmpty()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.types.FRDAbstractType
fillFields, getNAuto, getSize, serialize, setNAuto
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FootnoteReferenceDescriptor

public FootnoteReferenceDescriptor()

FootnoteReferenceDescriptor

public FootnoteReferenceDescriptor(byte[] data,
                                   int offset)
Method Detail

clone

protected FootnoteReferenceDescriptor clone()
Overrides:
clone in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isEmpty

public boolean isEmpty()

toString

public java.lang.String toString()
Overrides:
toString in class FRDAbstractType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormattedDiskPage

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FormattedDiskPage

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FormattedDiskPage
Direct Known Subclasses:
CHPFormattedDiskPage, PAPFormattedDiskPage
@Internal
public abstract class FormattedDiskPage
extends java.lang.Object

Represents an FKP data structure. This data structure is used to store the grpprls of the paragraph and character properties of the document. A grpprl is a list of sprms(decompression operations) to perform on a parent style. The style properties for paragraph and character runs are stored in fkps. There are PAP fkps for paragraph properties and CHP fkps for character run properties. The first part of the fkp for both CHP and PAP fkps consists of an array of 4 byte int offsets in the main stream for that Paragraph's or Character run's text. The ending offset is the next value in the array. For example, if an fkp has X number of Paragraph's stored in it then there are (x + 1) 4 byte ints in the beginning array. The number X is determined by the last byte in a 512 byte fkp. CHP and PAP fkps also store the compressed styles(grpprl) that correspond to the offsets on the front of the fkp. The offset of the grpprls is determined differently for CHP fkps and PAP fkps.

Author:
Ryan Ackley

Field Summary
protected int | _crun
protected byte[] | _fkp
protected int | _offset
Constructor Summary
FormattedDiskPage()
FormattedDiskPage(byte[] documentStream, int offset)
Uses a 512-byte array to create a FKP
Method Summary
protected int | getEnd(int index) Used to get the end of the text corresponding to a grpprl in this fkp.
protected abstract byte[] | getGrpprl(int index)
protected int | getStart(int index) Used to get a text offset corresponding to a grpprl in this fkp.
int | size() Used to get the total number of grrprl's stored int this FKP
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_fkp

protected byte[] _fkp

_crun

protected int _crun

_offset

protected int _offset
Constructor Detail

FormattedDiskPage

public FormattedDiskPage()

FormattedDiskPage

public FormattedDiskPage(byte[] documentStream,
                         int offset)
Uses a 512-byte array to create a FKP

Method Detail

getStart

protected int getStart(int index)
Used to get a text offset corresponding to a grpprl in this fkp.

Parameters:
index - The index of the property in this FKP
Returns:
an int representing an offset in the "WordDocument" stream

getEnd

protected int getEnd(int index)
Used to get the end of the text corresponding to a grpprl in this fkp.

Parameters:
index - The index of the property in this fkp.
Returns:
an int representing an offset in the "WordDocument" stream

size

public int size()
Used to get the total number of grrprl's stored int this FKP

Returns:
The number of grpprls in this FKP

getGrpprl

protected abstract byte[] getGrpprl(int index)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FSPA

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FSPA

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FSPAAbstractType
        extended by  org.apache.poi.hwpf.model.FSPA

@Internal
public final class FSPA
extends FSPAAbstractType

File Shape Address structure

Author:
Squeeself

Field Summary
static int FSPA_SIZE
Deprecated.
Fields inherited from class org.apache.poi.hwpf.model.types.FSPAAbstractType
field_1_spid, field_2_xaLeft, field_3_yaTop, field_4_xaRight, field_5_yaBottom, field_6_flags, field_7_cTxbx
Constructor Summary
FSPA()
FSPA(byte[] bytes, int offset)
Method Summary
 byte[] toByteArray()
Methods inherited from class org.apache.poi.hwpf.model.types.FSPAAbstractType
fillFields, getBx, getBy, getCTxbx, getFlags, getSize, getSpid, getWr, getWrk, getXaLeft, getXaRight, getYaBottom, getYaTop, isFAnchorLock, isFBelowText, isFHdr, isFRcaSimple, serialize, setBx, setBy, setCTxbx, setFAnchorLock, setFBelowText, setFHdr, setFlags, setFRcaSimple, setSpid, setWr, setWrk, setXaLeft, setXaRight, setYaBottom, setYaTop, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FSPA_SIZE

@Deprecated
public static final int FSPA_SIZE
Deprecated.
Constructor Detail

FSPA

public FSPA()

FSPA

public FSPA(byte[] bytes,
            int offset)
Method Detail

toByteArray

public byte[] toByteArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FSPADocumentPart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.model
Enum FSPADocumentPart

java.lang.Object
    extended by  java.lang.Enum<FSPADocumentPart>
        extended by  org.apache.poi.hwpf.model.FSPADocumentPart
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FSPADocumentPart>
@Internal
public enum FSPADocumentPart
extends java.lang.Enum<FSPADocumentPart>

Enum Constant Summary
HEADER
MAIN
Method Summary
int | getFibFieldsField()
static FSPADocumentPart | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FSPADocumentPart[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

HEADER

public static final FSPADocumentPart HEADER

MAIN

public static final FSPADocumentPart MAIN
Method Detail

values

public static FSPADocumentPart[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FSPADocumentPart c : FSPADocumentPart.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FSPADocumentPart valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getFibFieldsField

public int getFibFieldsField()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


FSPATable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class FSPATable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FSPATable

@Internal
public final class FSPATable
extends java.lang.Object

This class holds all the FSPA (File Shape Address) structures.

Author:
Squeeself

Constructor Summary
FSPATable(byte[] tableStream, FileInformationBlock fib, FSPADocumentPart part)
FSPATable(byte[] tableStream, int fcPlcspa, int lcbPlcspa, java.util.List<TextPiece> tpt)
Deprecated.
Method Summary
FSPA | getFspaFromCp(int cp)
FSPA[] | getShapes()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FSPATable

public FSPATable(byte[] tableStream,
                 FileInformationBlock fib,
                 FSPADocumentPart part)

FSPATable

@Deprecated
public FSPATable(byte[] tableStream,
                            int fcPlcspa,
                            int lcbPlcspa,
                            java.util.List<TextPiece> tpt)
Deprecated.

Method Detail

getFspaFromCp

public FSPA getFspaFromCp(int cp)

getShapes

public FSPA[] getShapes()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GenericPropertyNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class GenericPropertyNode

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<GenericPropertyNode>
        extended by  org.apache.poi.hwpf.model.GenericPropertyNode
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<GenericPropertyNode>
@Internal
public final class GenericPropertyNode
extends PropertyNode<GenericPropertyNode>

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
GenericPropertyNode(int start, int end, byte[] buf)
Method Summary
byte[] | getBytes()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
adjustForDelete, clone, compareTo, equals, getEnd, getStart, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

GenericPropertyNode

public GenericPropertyNode(int start,
                           int end,
                           byte[] buf)
Method Detail

getBytes

public byte[] getBytes()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Grfhic

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class Grfhic

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.GrfhicAbstractType
        extended by  org.apache.poi.hwpf.model.Grfhic

@Internal
public class Grfhic
extends GrfhicAbstractType

The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure. The values specify possible incompatibilities between an LVL or LVLF and HTML lists. The values do not define list properties.

Class and fields descriptions are quoted from [MS-DOC] -- v20110315 Word (.doc) Binary File Format specification

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to [MS-DOC] -- v20110315 Word (.doc) Binary File Format specification

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.GrfhicAbstractType
field_1_grfhic
Constructor Summary
Grfhic()
Grfhic(byte[] bytes, int offset)
Method Summary
 byte[] toByteArray()
Methods inherited from class org.apache.poi.hwpf.model.types.GrfhicAbstractType
equals, fillFields, getGrfhic, getSize, hashCode, isFHtmlBuiltInBullet, isFHtmlChecked, isFHtmlFirstLineMismatch, isFHtmlHangingIndentBeneathNumber, isFHtmlListTextNotSharpDot, isFHtmlNotPeriod, isFHtmlTabLeftIndentMismatch, isFHtmlUnsupported, serialize, serialize, setFHtmlBuiltInBullet, setFHtmlChecked, setFHtmlFirstLineMismatch, setFHtmlHangingIndentBeneathNumber, setFHtmlListTextNotSharpDot, setFHtmlNotPeriod, setFHtmlTabLeftIndentMismatch, setFHtmlUnsupported, setGrfhic, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

Grfhic

public Grfhic()

Grfhic

public Grfhic(byte[] bytes,
              int offset)
Method Detail

toByteArray

public byte[] toByteArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HDFType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Interface HDFType

All Known Implementing Classes:
StyleDescription, StyleSheet
Deprecated.

@Internal
@Deprecated
public interface HDFType

Author:
andy

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Hyphenation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class Hyphenation

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.HRESIAbstractType
        extended by  org.apache.poi.hwpf.model.Hyphenation
All Implemented Interfaces:
java.lang.Cloneable
@Internal
public final class Hyphenation
extends HRESIAbstractType
implements java.lang.Cloneable

Hyphenation. Substructure of the CharacterProperties.

Author:
Sergey Vladimirov ( vlsergey {at} gmail {dot} com )

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.HRESIAbstractType
field_1_hres, field_2_chHres, HRES_ADD_LETTER_BEFORE, HRES_CHANGE_LETTER_AFTER, HRES_CHANGE_LETTER_BEFORE, HRES_DELETE_BEFORE_CHANGE_BEFORE, HRES_DELETE_LETTER_BEFORE, HRES_NO, HRES_NORMAL
Constructor Summary
Hyphenation()
Hyphenation(short hres)
Method Summary
Hyphenation | clone()
boolean | equals(java.lang.Object obj)
short | getValue()
int | hashCode()
boolean | isEmpty()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.types.HRESIAbstractType
fillFields, getChHres, getHres, getSize, serialize, setChHres, setHres
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

Hyphenation

public Hyphenation()

Hyphenation

public Hyphenation(short hres)
Method Detail

clone

public Hyphenation clone()
Overrides:
clone in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

getValue

public short getValue()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isEmpty

public boolean isEmpty()

toString

public java.lang.String toString()
Overrides:
toString in class HRESIAbstractType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ListData

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ListData

@Internal
public final class ListData
extends java.lang.Object

Constructor Summary
ListData(int listID, boolean numbered)
Method Summary
boolean | equals(java.lang.Object obj)
ListLevel | getLevel(int index) Gets the level associated to a particular List at a particular index.
ListLevel[] | getLevels()
int | getLevelStyle(int index)
int | getLsid()
int | hashCode()
int | numLevels()
void | setLevel(int index, ListLevel level)
void | setLevelStyle(int index, int styleIndex)
byte[] | toByteArray()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListData

public ListData(int listID,
                boolean numbered)
Method Detail

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

getLevel

public ListLevel getLevel(int index)
Gets the level associated to a particular List at a particular index.

Parameters:
index - 1-based index
Returns:
a list level

getLevels

public ListLevel[] getLevels()

getLevelStyle

public int getLevelStyle(int index)

getLsid

public int getLsid()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

numLevels

public int numLevels()

setLevel

public void setLevel(int index,
                     ListLevel level)

setLevelStyle

public void setLevelStyle(int index,
                          int styleIndex)

toByteArray

public byte[] toByteArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListFormatOverride

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ListFormatOverride

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ListFormatOverride

@Internal
public final class ListFormatOverride
extends java.lang.Object

Constructor Summary
ListFormatOverride(byte[] buf, int offset)
ListFormatOverride(int lsid)
Method Summary
ListFormatOverrideLevel[] | getLevelOverrides()
int | getLsid()
ListFormatOverrideLevel | getOverrideLevel(int level)
int | numOverrides()
void | setLsid(int lsid)
void | setOverride(int index, ListFormatOverrideLevel lfolvl)
byte[] | toByteArray()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListFormatOverride

public ListFormatOverride(byte[] buf,
                          int offset)

ListFormatOverride

public ListFormatOverride(int lsid)
Method Detail

getLevelOverrides

public ListFormatOverrideLevel[] getLevelOverrides()

getLsid

public int getLsid()

getOverrideLevel

public ListFormatOverrideLevel getOverrideLevel(int level)

numOverrides

public int numOverrides()

setLsid

public void setLsid(int lsid)

setOverride

public void setOverride(int index,
                        ListFormatOverrideLevel lfolvl)

toByteArray

public byte[] toByteArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListFormatOverrideLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ListFormatOverrideLevel

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ListFormatOverrideLevel

@Internal
public final class ListFormatOverrideLevel
extends java.lang.Object

The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Constructor Summary
ListFormatOverrideLevel(byte[] buf, int offset)
Method Summary
boolean | equals(java.lang.Object obj)
int | getIStartAt()
ListLevel | getLevel()
int | getLevelNum()
int | getSizeInBytes()
int | hashCode()
boolean | isFormatting()
boolean | isStartAt()
byte[] | toByteArray()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListFormatOverrideLevel

public ListFormatOverrideLevel(byte[] buf,
                               int offset)
Method Detail

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

getIStartAt

public int getIStartAt()

getLevel

public ListLevel getLevel()

getLevelNum

public int getLevelNum()

getSizeInBytes

public int getSizeInBytes()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isFormatting

public boolean isFormatting()

isStartAt

public boolean isStartAt()

toByteArray

public byte[] toByteArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ListLevel

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ListLevel

@Internal
public final class ListLevel
extends java.lang.Object

"The LVL structure contains formatting information about a specific level in a list. When a paragraph is formatted as part of this level, each placeholder in xst is replaced with the inherited level number of the most recent or current paragraph in the same list that is in the zero-based level specified by that placeholder. The level number that replaces a placeholder is formatted according to the lvlf.nfc of the LVL structure that corresponds to the level that the placeholder specifies, unless the lvlf.fLegal of this LVL structure is nonzero." -- Page 388 of 621 -- [MS-DOC] -- v20110315 Word (.doc) Binary File Format

Constructor Summary
ListLevel(byte[] buf, int startOffset)
Deprecated.
ListLevel(int level, boolean numbered)
ListLevel(int startAt, int numberFormatCode, int alignment, byte[] numberProperties, byte[] entryProperties, java.lang.String numberText)
Method Summary
boolean | equals(java.lang.Object obj)
int | getAlignment() "Alignment (left, right, or centered) of the paragraph number."
byte[] | getGrpprlChpx()
byte[] | getGrpprlPapx()
byte[] | getLevelProperties()
int | getNumberFormat() "Number format code (see anld.nfc for a list of options)"
java.lang.String | getNumberText()
int | getSizeInBytes()
int | getStartAt()
byte | getTypeOfCharFollowingTheNumber() "The type of character following the number text for the paragraph: 0 == tab, 1 == space, 2 == nothing."
void | setAlignment(int alignment)
void | setLevelProperties(byte[] grpprl)
void | setNumberFormat(int numberFormatCode)
void | setNumberProperties(byte[] grpprl)
void | setStartAt(int startAt)
void | setTypeOfCharFollowingTheNumber(byte value)
byte[] | toByteArray()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ListLevel

@Deprecated
public ListLevel(byte[] buf,
                            int startOffset)
Deprecated.

ListLevel

public ListLevel(int level,
                 boolean numbered)

ListLevel

public ListLevel(int startAt,
                 int numberFormatCode,
                 int alignment,
                 byte[] numberProperties,
                 byte[] entryProperties,
                 java.lang.String numberText)
Method Detail

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

getAlignment

public int getAlignment()
"Alignment (left, right, or centered) of the paragraph number."

getGrpprlChpx

public byte[] getGrpprlChpx()

getGrpprlPapx

public byte[] getGrpprlPapx()

getLevelProperties

public byte[] getLevelProperties()

getNumberFormat

public int getNumberFormat()
"Number format code (see anld.nfc for a list of options)"

getNumberText

public java.lang.String getNumberText()

getSizeInBytes

public int getSizeInBytes()

getStartAt

public int getStartAt()

getTypeOfCharFollowingTheNumber

public byte getTypeOfCharFollowingTheNumber()
"The type of character following the number text for the paragraph: 0 == tab, 1 == space, 2 == nothing."

setAlignment

public void setAlignment(int alignment)

setLevelProperties

public void setLevelProperties(byte[] grpprl)

setNumberFormat

public void setNumberFormat(int numberFormatCode)

setNumberProperties

public void setNumberProperties(byte[] grpprl)

setStartAt

public void setStartAt(int startAt)

setTypeOfCharFollowingTheNumber

public void setTypeOfCharFollowingTheNumber(byte value)

toByteArray

public byte[] toByteArray()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListTables

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ListTables

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ListTables

@Internal
public final class ListTables
extends java.lang.Object

Author:
Ryan Ackley

Constructor Summary
ListTables()
ListTables(byte[] tableStream, int lstOffset, int lfoOffset)
Method Summary
int | addList(ListData lst, ListFormatOverride override)
boolean | equals(java.lang.Object obj)
ListLevel | getLevel(int listID, int level)
ListData | getListData(int listID)
ListFormatOverride | getOverride(int lfoIndex)
int | getOverrideCount()
int | getOverrideIndexFromListID(int lstid)
void | writeListDataTo(FileInformationBlock fib, HWPFOutputStream tableStream)
void | writeListOverridesTo(HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListTables

public ListTables()

ListTables

public ListTables(byte[] tableStream,
                  int lstOffset,
                  int lfoOffset)
Method Detail

addList

public int addList(ListData lst,
                   ListFormatOverride override)

writeListDataTo

public void writeListDataTo(FileInformationBlock fib,
                            HWPFOutputStream tableStream)
                     throws java.io.IOException
Throws:
java.io.IOException

writeListOverridesTo

public void writeListOverridesTo(HWPFOutputStream tableStream)
                          throws java.io.IOException
Throws:
java.io.IOException

getOverride

public ListFormatOverride getOverride(int lfoIndex)

getOverrideCount

public int getOverrideCount()

getOverrideIndexFromListID

public int getOverrideIndexFromListID(int lstid)

getLevel

public ListLevel getLevel(int listID,
                          int level)

getListData

public ListData getListData(int listID)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotesTables

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class NotesTables

java.lang.Object
    extended by  org.apache.poi.hwpf.model.NotesTables

@Internal
public class NotesTables
extends java.lang.Object

Holds information about document notes (footnotes or ending notes)

Author:
Sergey Vladimirov (vlsergey {at} gmail {doc} com)

Constructor Summary
NotesTables(NoteType noteType)
NotesTables(NoteType noteType, byte[] tableStream, FileInformationBlock fib)
Method Summary
GenericPropertyNode | getDescriptor(int index)
int | getDescriptorsCount()
GenericPropertyNode | getTextPosition(int index)
void | writeRef(FileInformationBlock fib, HWPFOutputStream tableStream)
void | writeTxt(FileInformationBlock fib, HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotesTables

public NotesTables(NoteType noteType)

NotesTables

public NotesTables(NoteType noteType,
                   byte[] tableStream,
                   FileInformationBlock fib)
Method Detail

getDescriptor

public GenericPropertyNode getDescriptor(int index)

getDescriptorsCount

public int getDescriptorsCount()

getTextPosition

public GenericPropertyNode getTextPosition(int index)

writeRef

public void writeRef(FileInformationBlock fib,
                     HWPFOutputStream tableStream)
              throws java.io.IOException
Throws:
java.io.IOException

writeTxt

public void writeTxt(FileInformationBlock fib,
                     HWPFOutputStream tableStream)
              throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoteType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.model
Enum NoteType

java.lang.Object
    extended by  java.lang.Enum<NoteType>
        extended by  org.apache.poi.hwpf.model.NoteType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<NoteType>
@Internal
public enum NoteType
extends java.lang.Enum<NoteType>

Enum Constant Summary
ENDNOTE
Ending note
FOOTNOTE
Footnote
Method Summary
int | getFibDescriptorsFieldIndex()
int | getFibTextPositionsFieldIndex()
static NoteType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static NoteType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ENDNOTE

public static final NoteType ENDNOTE
Ending note

FOOTNOTE

public static final NoteType FOOTNOTE
Footnote

Method Detail

values

public static NoteType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (NoteType c : NoteType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static NoteType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getFibDescriptorsFieldIndex

public int getFibDescriptorsFieldIndex()

getFibTextPositionsFieldIndex

public int getFibTextPositionsFieldIndex()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


OldCHPBinTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class OldCHPBinTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.CHPBinTable
        extended by  org.apache.poi.hwpf.model.OldCHPBinTable

@Internal
public final class OldCHPBinTable
extends CHPBinTable

This class holds all of the character formatting properties from Old (Word 6 / Word 95) documents. Unlike with Word 97+, it all gets held in the same stream. In common with the rest of the old support, it is read only

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.CHPBinTable
_textRuns
Constructor Summary
OldCHPBinTable(byte[] documentStream, int offset, int size, int fcMin, TextPieceTable tpt)
Constructor used to read an old-style binTable in from a Word document.
Method Summary
Methods inherited from class org.apache.poi.hwpf.model.CHPBinTable
adjustForDelete, adjustForInsert, getTextRuns, insert, rebuild, writeTo, writeTo
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OldCHPBinTable

public OldCHPBinTable(byte[] documentStream,
                      int offset,
                      int size,
                      int fcMin,
                      TextPieceTable tpt)
Constructor used to read an old-style binTable in from a Word document.

Parameters:
documentStream -
offset -
size -
fcMin -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OldPAPBinTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class OldPAPBinTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PAPBinTable
        extended by  org.apache.poi.hwpf.model.OldPAPBinTable

@Internal
public final class OldPAPBinTable
extends PAPBinTable

This class holds all of the paragraph formatting properties from Old (Word 6 / Word 95) documents. Unlike with Word 97+, it all gets held in the same stream. In common with the rest of the old support, it is read only

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PAPBinTable
_paragraphs
Constructor Summary
OldPAPBinTable(byte[] documentStream, int offset, int size, int fcMin, TextPieceTable tpt)
Method Summary
Methods inherited from class org.apache.poi.hwpf.model.PAPBinTable
adjustForDelete, adjustForInsert, getParagraphs, insert, rebuild, writeTo, writeTo
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OldPAPBinTable

public OldPAPBinTable(byte[] documentStream,
                      int offset,
                      int size,
                      int fcMin,
                      TextPieceTable tpt)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OldSectionTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class OldSectionTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.SectionTable
        extended by  org.apache.poi.hwpf.model.OldSectionTable

@Internal
public final class OldSectionTable
extends SectionTable

This class holds all of the section formatting properties from Old (Word 6 / Word 95) documents. Unlike with Word 97+, it all gets held in the same stream. In common with the rest of the old support, it is read only

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.SectionTable
_sections, _text
Constructor Summary
OldSectionTable(byte[] documentStream, int offset, int size)
OldSectionTable(byte[] documentStream, int offset, int size, int fcMin, TextPieceTable tpt)
Deprecated. Use OldSectionTable(byte[],int,int) instead
Method Summary
Methods inherited from class org.apache.poi.hwpf.model.SectionTable
adjustForInsert, getSections, writeTo, writeTo
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OldSectionTable

@Deprecated
public OldSectionTable(byte[] documentStream,
                                  int offset,
                                  int size,
                                  int fcMin,
                                  TextPieceTable tpt)
Deprecated. Use OldSectionTable(byte[],int,int) instead

OldSectionTable

public OldSectionTable(byte[] documentStream,
                       int offset,
                       int size)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf.model
Interfaces
CharIndexTranslator
HDFType
Classes
BookmarkFirstDescriptor
BookmarksTables
BytePropertyNode
CachedPropertyNode
CHPBinTable
CHPFormattedDiskPage
CHPX
Colorref
ComplexFileTable
DocumentProperties
EscherRecordHolder
Ffn
FibBase
FIBFieldHandler
FieldDescriptor
FieldsTables
FileInformationBlock
FontTable
FootnoteReferenceDescriptor
FormattedDiskPage
FSPA
FSPATable
GenericPropertyNode
Grfhic
Hyphenation
ListData
ListFormatOverride
ListFormatOverrideLevel
ListLevel
ListTables
NotesTables
OldCHPBinTable
OldPAPBinTable
OldSectionTable
PAPBinTable
PAPFormattedDiskPage
PAPX
ParagraphHeight
PICF
PICFAndOfficeArtData
PicturesTable
PieceDescriptor
PlexOfCps
PlexOfField
PropertyModifier
PropertyNode
PropertyNode.EndComparator
PropertyNode.StartComparator
RevisionMarkAuthorTable
SavedByEntry
SavedByTable
SectionDescriptor
SectionTable
SEPX
ShapesTable
SinglentonTextPiece
StyleDescription
StyleSheet
TabDescriptor
TextPiece
TextPieceTable
UnhandledDataStructure
UPX
Enums
FieldsDocumentPart
FSPADocumentPart
NoteType
SubdocumentType


org.apache.poi.hwpf.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.model

Interface Summary
CharIndexTranslator |
HDFType | Deprecated.

Class Summary
BookmarkFirstDescriptor |
BookmarksTables |
BytePropertyNode<T extends BytePropertyNode<T>> | Deprecated. byte positions shall not be saved in memory
CachedPropertyNode |
CHPBinTable | This class holds all of the character formatting properties.
CHPFormattedDiskPage | Represents a CHP fkp.
CHPX | DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
Colorref | 24-bit color structure
ComplexFileTable |
DocumentProperties | Comment me
EscherRecordHolder | Based on AbstractEscherRecordHolder from HSSF.
Ffn | FFN - Font Family Name.
FibBase | Base part of the File information Block (FibBase).
FIBFieldHandler |
FieldDescriptor | Class for the FLD structure.
FieldsTables | This class provides access to all the fields Plex.
FileInformationBlock | The File Information Block (FIB).
FontTable | FontTable or in MS terminology sttbfffn is a common data structure written in all Word files.
FootnoteReferenceDescriptor |
FormattedDiskPage | Represents an FKP data structure.
FSPA | File Shape Address structure
FSPATable | This class holds all the FSPA (File Shape Address) structures.
GenericPropertyNode |
Grfhic | The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
Hyphenation | Hyphenation.
ListData |
ListFormatOverride |
ListFormatOverrideLevel | The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.
ListLevel | "The LVL structure contains formatting information about a specific level in a list.
ListTables |
NotesTables | Holds information about document notes (footnotes or ending notes)
OldCHPBinTable | This class holds all of the character formatting properties from Old (Word 6 / Word 95) documents.
OldPAPBinTable | This class holds all of the paragraph formatting properties from Old (Word 6 / Word 95) documents.
OldSectionTable | This class holds all of the section formatting properties from Old (Word 6 / Word 95) documents.
PAPBinTable | This class represents the bin table of Word document but it also serves as a holder for all of the paragraphs of document that have been loaded into memory.
PAPFormattedDiskPage | Represents a PAP FKP.
PAPX | DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
ParagraphHeight |
PICF | The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
PICFAndOfficeArtData |
PicturesTable | Holds information about all pictures embedded in Word Document either via "Insert -> Picture -> From File" or via clipboard.
PieceDescriptor |
PlexOfCps | Plex of CPs stored in File (PLCF) common data structure in a Word file.
PlexOfField | Structure describing the Plex for fields (contained plclfd* in the spec).
PropertyModifier |
PropertyNode<T extends PropertyNode<T>> | Represents a lightweight node in the Trees used to store content properties.
PropertyNode.EndComparator |
PropertyNode.StartComparator |
RevisionMarkAuthorTable | String table containing the names of authors of revision marks, e-mails and comments in this document.
SavedByEntry | A single entry in the SavedByTable.
SavedByTable | String table containing the history of the last few revisions ("saves") of the document.
SectionDescriptor | Section Descriptor (SED) See page 186 for details.
SectionTable |
SEPX |
ShapesTable | Deprecated.
SinglentonTextPiece |
StyleDescription | Comment me
StyleSheet | Represents a document's stylesheet.
TabDescriptor | Tab descriptor.
TextPiece | Lightweight representation of a text piece.
TextPieceTable | The piece table for matching up character positions to bits of text.
UnhandledDataStructure |
UPX |

Enum Summary
FieldsDocumentPart |
FSPADocumentPart |
NoteType |
SubdocumentType | Document text parts that can have text pieces (CPs)


org.apache.poi.hwpf.model Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hwpf.model.types.BKFAbstractType
      • org.apache.poi.hwpf.model.BookmarkFirstDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.BookmarksTables
    • org.apache.poi.hwpf.model.CHPBinTable
      • org.apache.poi.hwpf.model.OldCHPBinTable
    • org.apache.poi.hwpf.model.Colorref (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.ComplexFileTable
    • org.apache.poi.hwpf.model.types.DOPAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
      • org.apache.poi.hwpf.model.DocumentProperties
    • org.apache.poi.hwpf.model.EscherRecordHolder
    • org.apache.poi.hwpf.model.Ffn
    • org.apache.poi.hwpf.model.types.FibBaseAbstractType
      • org.apache.poi.hwpf.model.FibBase
    • org.apache.poi.hwpf.model.FIBFieldHandler
    • org.apache.poi.hwpf.model.FieldsTables
    • org.apache.poi.hwpf.model.FileInformationBlock (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.FLDAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
      • org.apache.poi.hwpf.model.FieldDescriptor
    • org.apache.poi.hwpf.model.FontTable
    • org.apache.poi.hwpf.model.FormattedDiskPage
      • org.apache.poi.hwpf.model.CHPFormattedDiskPage
      • org.apache.poi.hwpf.model.PAPFormattedDiskPage
    • org.apache.poi.hwpf.model.types.FRDAbstractType
      • org.apache.poi.hwpf.model.FootnoteReferenceDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.FSPAAbstractType
      • org.apache.poi.hwpf.model.FSPA
    • org.apache.poi.hwpf.model.FSPATable
    • org.apache.poi.hwpf.model.types.GrfhicAbstractType
      • org.apache.poi.hwpf.model.Grfhic
    • org.apache.poi.hwpf.model.types.HRESIAbstractType
      • org.apache.poi.hwpf.model.Hyphenation (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.ListData
    • org.apache.poi.hwpf.model.ListFormatOverride
    • org.apache.poi.hwpf.model.ListFormatOverrideLevel
    • org.apache.poi.hwpf.model.ListLevel
    • org.apache.poi.hwpf.model.ListTables
    • org.apache.poi.hwpf.model.NotesTables
    • org.apache.poi.hwpf.model.PAPBinTable
      • org.apache.poi.hwpf.model.OldPAPBinTable
    • org.apache.poi.hwpf.model.ParagraphHeight
    • org.apache.poi.hwpf.model.types.PICFAbstractType
      • org.apache.poi.hwpf.model.PICF
    • org.apache.poi.hwpf.model.PICFAndOfficeArtData
    • org.apache.poi.hwpf.model.PicturesTable
    • org.apache.poi.hwpf.model.PieceDescriptor
    • org.apache.poi.hwpf.model.PlexOfCps
    • org.apache.poi.hwpf.model.PlexOfField
    • org.apache.poi.hwpf.model.PropertyModifier (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.PropertyNode<T> (implements java.lang.Cloneable, java.lang.Comparable<T>)
      • org.apache.poi.hwpf.model.BytePropertyNode<T>
        • org.apache.poi.hwpf.model.CHPX
        • org.apache.poi.hwpf.model.PAPX
      • org.apache.poi.hwpf.model.CachedPropertyNode
      • org.apache.poi.hwpf.model.GenericPropertyNode
      • org.apache.poi.hwpf.model.SEPX
      • org.apache.poi.hwpf.model.TextPiece
        • org.apache.poi.hwpf.model.SinglentonTextPiece
    • org.apache.poi.hwpf.model.PropertyNode.EndComparator (implements java.util.Comparator<T>)
    • org.apache.poi.hwpf.model.PropertyNode.StartComparator (implements java.util.Comparator<T>)
    • org.apache.poi.hwpf.model.RevisionMarkAuthorTable
    • org.apache.poi.hwpf.model.SavedByEntry
    • org.apache.poi.hwpf.model.SavedByTable
    • org.apache.poi.hwpf.model.SectionDescriptor
    • org.apache.poi.hwpf.model.SectionTable
      • org.apache.poi.hwpf.model.OldSectionTable
    • org.apache.poi.hwpf.model.ShapesTable
    • org.apache.poi.hwpf.model.StyleDescription (implements org.apache.poi.hwpf.model.HDFType)
    • org.apache.poi.hwpf.model.StyleSheet (implements org.apache.poi.hwpf.model.HDFType)
    • org.apache.poi.hwpf.model.types.TBDAbstractType
      • org.apache.poi.hwpf.model.TabDescriptor
    • org.apache.poi.hwpf.model.TextPieceTable (implements org.apache.poi.hwpf.model.CharIndexTranslator)
    • org.apache.poi.hwpf.model.UnhandledDataStructure
    • org.apache.poi.hwpf.model.UPX

Interface Hierarchy

  • org.apache.poi.hwpf.model.CharIndexTranslator
  • org.apache.poi.hwpf.model.HDFType

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.hwpf.model.SubdocumentType
      • org.apache.poi.hwpf.model.NoteType
      • org.apache.poi.hwpf.model.FSPADocumentPart
      • org.apache.poi.hwpf.model.FieldsDocumentPart


Uses of Package org.apache.poi.hwpf.model

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.model

Packages that use org.apache.poi.hwpf.model
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.model used by org.apache.poi.hwpf
BookmarksTables
CHPBinTable
This class holds all of the character formatting properties.
ComplexFileTable
DocumentProperties
Comment me
EscherRecordHolder
Based on AbstractEscherRecordHolder from HSSF.
FieldsTables
This class provides access to all the fields Plex.
FileInformationBlock
The File Information Block (FIB).
FontTable
FontTable or in MS terminology sttbfffn is a common data structure written in all Word files.
ListTables
NotesTables
Holds information about document notes (footnotes or ending notes)
PAPBinTable
This class represents the bin table of Word document but it also serves as a holder for all of the paragraphs of document that have been loaded into memory.
PicturesTable
Holds information about all pictures embedded in Word Document either via "Insert -> Picture -> From File" or via clipboard.
RevisionMarkAuthorTable
String table containing the names of authors of revision marks, e-mails and comments in this document.
SavedByTable
String table containing the history of the last few revisions ("saves") of the document.
SectionTable
ShapesTable
Deprecated.
StyleSheet
Represents a document's stylesheet.
TextPieceTable
The piece table for matching up character positions to bits of text.

Classes in org.apache.poi.hwpf.model used by org.apache.poi.hwpf.converter
ListTables

Classes in org.apache.poi.hwpf.model used by org.apache.poi.hwpf.dev
ListTables

Classes in org.apache.poi.hwpf.model used by org.apache.poi.hwpf.model
BookmarkFirstDescriptor
BytePropertyNode
Deprecated. byte positions shall not be saved in memory
CharIndexTranslator
CHPBinTable
This class holds all of the character formatting properties.
CHPX
DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
Colorref
24-bit color structure
ComplexFileTable
EscherRecordHolder
Based on AbstractEscherRecordHolder from HSSF.
Ffn
FFN - Font Family Name.
FibBase
Base part of the File information Block (FibBase).
FieldDescriptor
Class for the FLD structure.
FieldsDocumentPart
FileInformationBlock
The File Information Block (FIB).
FootnoteReferenceDescriptor
FormattedDiskPage
Represents an FKP data structure.
FSPA
File Shape Address structure
FSPADocumentPart
FSPATable
This class holds all the FSPA (File Shape Address) structures.
GenericPropertyNode
HDFType
Deprecated.
Hyphenation
Hyphenation.
ListData
ListFormatOverride
ListFormatOverrideLevel
The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.
ListLevel
"The LVL structure contains formatting information about a specific level in a list.
NoteType
PAPBinTable
This class represents the bin table of Word document but it also serves as a holder for all of the paragraphs of document that have been loaded into memory.
PAPX
DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
ParagraphHeight
PICF
The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
PieceDescriptor
PlexOfField
Structure describing the Plex for fields (contained plclfd* in the spec).
PropertyModifier
PropertyNode
Represents a lightweight node in the Trees used to store content properties.
PropertyNode.EndComparator
PropertyNode.StartComparator
SavedByEntry
A single entry in the SavedByTable.
SectionDescriptor
Section Descriptor (SED) See page 186 for details.
SectionTable
SEPX
StyleDescription
Comment me
StyleSheet
Represents a document's stylesheet.
SubdocumentType
Document text parts that can have text pieces (CPs)
TextPiece
Lightweight representation of a text piece.
TextPieceTable
The piece table for matching up character positions to bits of text.

Classes in org.apache.poi.hwpf.model used by org.apache.poi.hwpf.model.types
Colorref
24-bit color structure
Grfhic
The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
Hyphenation
Hyphenation.
TabDescriptor
Tab descriptor.

Classes in org.apache.poi.hwpf.model used by org.apache.poi.hwpf.usermodel
BookmarksTables
CHPX
DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
EscherRecordHolder
Based on AbstractEscherRecordHolder from HSSF.
Ffn
FFN - Font Family Name.
FieldsDocumentPart
FieldsTables
This class provides access to all the fields Plex.
FSPATable
This class holds all the FSPA (File Shape Address) structures.
GenericPropertyNode
ListData
ListFormatOverride
NotesTables
Holds information about document notes (footnotes or ending notes)
PAPX
DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
PlexOfCps
Plex of CPs stored in File (PLCF) common data structure in a Word file.
SEPX
StyleSheet
Represents a document's stylesheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PAPBinTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PAPBinTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PAPBinTable
Direct Known Subclasses:
OldPAPBinTable
@Internal
public class PAPBinTable
extends java.lang.Object

This class represents the bin table of Word document but it also serves as a holder for all of the paragraphs of document that have been loaded into memory.

Author:
Ryan Ackley

Field Summary
protected  java.util.ArrayList<PAPX> _paragraphs
Constructor Summary
PAPBinTable()
PAPBinTable(byte[] documentStream, byte[] tableStream, byte[] dataStream, int offset, int size, CharIndexTranslator charIndexTranslator)
PAPBinTable(byte[] documentStream, byte[] tableStream, byte[] dataStream, int offset, int size, int fcMin, TextPieceTable tpt)
Deprecated. Use PAPBinTable(byte[], byte[], byte[], int, int, CharIndexTranslator) instead
Method Summary
void | adjustForDelete(int listIndex, int offset, int length)
void | adjustForInsert(int listIndex, int length)
java.util.ArrayList<PAPX> | getParagraphs()
void | insert(int listIndex, int cpStart, SprmBuffer buf)
void | rebuild(java.lang.StringBuilder docText, ComplexFileTable complexFileTable)
void | writeTo(HWPFFileSystem sys, CharIndexTranslator translator) Deprecated.
void | writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream, CharIndexTranslator translator)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_paragraphs

protected java.util.ArrayList<PAPX> _paragraphs
Constructor Detail

PAPBinTable

public PAPBinTable()

PAPBinTable

public PAPBinTable(byte[] documentStream,
                   byte[] tableStream,
                   byte[] dataStream,
                   int offset,
                   int size,
                   int fcMin,
                   TextPieceTable tpt)
Deprecated. Use PAPBinTable(byte[], byte[], byte[], int, int, CharIndexTranslator) instead

PAPBinTable

public PAPBinTable(byte[] documentStream,
                   byte[] tableStream,
                   byte[] dataStream,
                   int offset,
                   int size,
                   CharIndexTranslator charIndexTranslator)
Method Detail

rebuild

public void rebuild(java.lang.StringBuilder docText,
                    ComplexFileTable complexFileTable)

insert

public void insert(int listIndex,
                   int cpStart,
                   SprmBuffer buf)

adjustForDelete

public void adjustForDelete(int listIndex,
                            int offset,
                            int length)

adjustForInsert

public void adjustForInsert(int listIndex,
                            int length)

getParagraphs

public java.util.ArrayList<PAPX> getParagraphs()

writeTo

@Deprecated
public void writeTo(HWPFFileSystem sys,
                               CharIndexTranslator translator)
             throws java.io.IOException
Deprecated.

Throws:
java.io.IOException

writeTo

public void writeTo(HWPFOutputStream wordDocumentStream,
                    HWPFOutputStream tableStream,
                    CharIndexTranslator translator)
             throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PAPFormattedDiskPage

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PAPFormattedDiskPage

java.lang.Object
    extended by  org.apache.poi.hwpf.model.FormattedDiskPage
        extended by  org.apache.poi.hwpf.model.PAPFormattedDiskPage

@Internal
public final class PAPFormattedDiskPage
extends FormattedDiskPage

Represents a PAP FKP. The style properties for paragraph and character runs are stored in fkps. There are PAP fkps for paragraph properties and CHP fkps for character run properties. The first part of the fkp for both CHP and PAP fkps consists of an array of 4 byte int offsets in the main stream for that Paragraph's or Character run's text. The ending offset is the next value in the array. For example, if an fkp has X number of Paragraph's stored in it then there are (x + 1) 4 byte ints in the beginning array. The number X is determined by the last byte in a 512 byte fkp. CHP and PAP fkps also store the compressed styles(grpprl) that correspond to the offsets on the front of the fkp. The offset of the grpprls is determined differently for CHP fkps and PAP fkps.

Author:
Ryan Ackley

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.FormattedDiskPage
_crun, _fkp, _offset
Constructor Summary
PAPFormattedDiskPage()
PAPFormattedDiskPage(byte[] dataStream)
Deprecated. Use PAPFormattedDiskPage() instead
PAPFormattedDiskPage(byte[] documentStream, byte[] dataStream, int offset, CharIndexTranslator translator)
Creates a PAPFormattedDiskPage from a 512 byte array
PAPFormattedDiskPage(byte[] documentStream, byte[] dataStream, int offset, int fcMin, TextPieceTable tpt)
Deprecated. Use PAPFormattedDiskPage(byte[], byte[], int, CharIndexTranslator) instead
Method Summary
void | fill(java.util.List<PAPX> filler) Fills the queue for writing.
protected byte[] | getGrpprl(int index) Gets the papx grpprl for the paragraph at index in this fkp.
PAPX | getPAPX(int index) Gets the PAPX at index.
java.util.List<PAPX> | getPAPXs()
protected byte[] | toByteArray(HWPFOutputStream dataStream, CharIndexTranslator translator) Creates a byte array representation of this data structure.
Methods inherited from class org.apache.poi.hwpf.model.FormattedDiskPage
getEnd, getStart, size
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PAPFormattedDiskPage

public PAPFormattedDiskPage(byte[] dataStream)
Deprecated. Use PAPFormattedDiskPage() instead

PAPFormattedDiskPage

public PAPFormattedDiskPage()

PAPFormattedDiskPage

public PAPFormattedDiskPage(byte[] documentStream,
                            byte[] dataStream,
                            int offset,
                            int fcMin,
                            TextPieceTable tpt)
Deprecated. Use PAPFormattedDiskPage(byte[], byte[], int, CharIndexTranslator) instead

Creates a PAPFormattedDiskPage from a 512 byte array

PAPFormattedDiskPage

public PAPFormattedDiskPage(byte[] documentStream,
                            byte[] dataStream,
                            int offset,
                            CharIndexTranslator translator)
Creates a PAPFormattedDiskPage from a 512 byte array

Method Detail

fill

public void fill(java.util.List<PAPX> filler)
Fills the queue for writing.

Parameters:
filler - a List of PAPXs

getPAPX

public PAPX getPAPX(int index)
Gets the PAPX at index.

Parameters:
index - The index to get the PAPX for.
Returns:
The PAPX at index.

getPAPXs

public java.util.List<PAPX> getPAPXs()

getGrpprl

protected byte[] getGrpprl(int index)
Gets the papx grpprl for the paragraph at index in this fkp.

Specified by:
getGrpprl in class FormattedDiskPage
Parameters:
index - The index of the papx to get.
Returns:
a papx grpprl.

toByteArray

protected byte[] toByteArray(HWPFOutputStream dataStream,
                             CharIndexTranslator translator)
                      throws java.io.IOException
Creates a byte array representation of this data structure. Suitable for writing to a Word document.

Parameters:
dataStream - required if PAPX is too big to fit in FKP
Returns:
A byte array representing this data structure.
Throws:
java.io.IOException - if an I/O error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PAPX

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PAPX

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<T>
        extended by  org.apache.poi.hwpf.model.BytePropertyNode<PAPX>
            extended by  org.apache.poi.hwpf.model.PAPX
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<PAPX>
@Internal
public final class PAPX
extends BytePropertyNode<PAPX>

DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!

Author:
Ryan Ackley

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
PAPX(int charStart, int charEnd, byte[] papx, ParagraphHeight phe, byte[] dataStream)
PAPX(int fcStart, int fcEnd, CharIndexTranslator translator, byte[] papx, ParagraphHeight phe, byte[] dataStream)
PAPX(int fcStart, int fcEnd, CharIndexTranslator translator, SprmBuffer buf, byte[] dataStream)
Deprecated.
PAPX(int charStart, int charEnd, SprmBuffer buf)
Method Summary
boolean | equals(java.lang.Object o)
byte[] | getGrpprl()
short | getIstd()
ParagraphHeight | getParagraphHeight()
ParagraphProperties | getParagraphProperties(StyleSheet ss) Deprecated.
SprmBuffer | getSprmBuf()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.BytePropertyNode
getEndBytes, getStartBytes
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
adjustForDelete, clone, compareTo, getEnd, getStart, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PAPX

public PAPX(int fcStart,
            int fcEnd,
            CharIndexTranslator translator,
            byte[] papx,
            ParagraphHeight phe,
            byte[] dataStream)

PAPX

public PAPX(int charStart,
            int charEnd,
            byte[] papx,
            ParagraphHeight phe,
            byte[] dataStream)

PAPX

@Deprecated
public PAPX(int fcStart,
                       int fcEnd,
                       CharIndexTranslator translator,
                       SprmBuffer buf,
                       byte[] dataStream)
Deprecated.

PAPX

public PAPX(int charStart,
            int charEnd,
            SprmBuffer buf)
Method Detail

getParagraphHeight

public ParagraphHeight getParagraphHeight()

getGrpprl

public byte[] getGrpprl()

getIstd

public short getIstd()

getSprmBuf

public SprmBuffer getSprmBuf()

getParagraphProperties

@Deprecated
@Internal
public ParagraphProperties getParagraphProperties(StyleSheet ss)
Deprecated.

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class PropertyNode<PAPX>

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParagraphHeight

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ParagraphHeight

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ParagraphHeight

@Internal
public final class ParagraphHeight
extends java.lang.Object

Constructor Summary
ParagraphHeight()
ParagraphHeight(byte[] buf, int offset)
Method Summary
boolean | equals(java.lang.Object o)
protected byte[] | toByteArray()
void | write(java.io.OutputStream out)
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParagraphHeight

public ParagraphHeight(byte[] buf,
                       int offset)

ParagraphHeight

public ParagraphHeight()
Method Detail

write

public void write(java.io.OutputStream out)
           throws java.io.IOException
Throws:
java.io.IOException

toByteArray

protected byte[] toByteArray()

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PICF

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PICF

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.PICFAbstractType
        extended by  org.apache.poi.hwpf.model.PICF

@Internal
public class PICF
extends PICFAbstractType

The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.PICFAbstractType
field_1_lcb, field_10_padding2, field_11_dxaGoal, field_12_dyaGoal, field_13_mx, field_14_my, field_15_dxaReserved1, field_16_dyaReserved1, field_17_dxaReserved2, field_18_dyaReserved2, field_19_fReserved, field_2_cbHeader, field_20_bpp, field_21_brcTop80, field_22_brcLeft80, field_23_brcBottom80, field_24_brcRight80, field_25_dxaReserved3, field_26_dyaReserved3, field_27_cProps, field_3_mm, field_4_xExt, field_5_yExt, field_6_swHMF, field_7_grf, field_8_padding, field_9_mmPM
Constructor Summary
PICF()
PICF(byte[] std, int offset)
Method Summary
boolean | equals(java.lang.Object obj)
int | hashCode()
Methods inherited from class org.apache.poi.hwpf.model.types.PICFAbstractType
fillFields, getBpp, getBrcBottom80, getBrcLeft80, getBrcRight80, getBrcTop80, getCbHeader, getCProps, getDxaGoal, getDxaReserved1, getDxaReserved2, getDxaReserved3, getDyaGoal, getDyaReserved1, getDyaReserved2, getDyaReserved3, getFReserved, getGrf, getLcb, getMm, getMmPM, getMx, getMy, getPadding, getPadding2, getSize, getSwHMF, getXExt, getYExt, serialize, serialize, setBpp, setBrcBottom80, setBrcLeft80, setBrcRight80, setBrcTop80, setCbHeader, setCProps, setDxaGoal, setDxaReserved1, setDxaReserved2, setDxaReserved3, setDyaGoal, setDyaReserved1, setDyaReserved2, setDyaReserved3, setFReserved, setGrf, setLcb, setMm, setMmPM, setMx, setMy, setPadding, setPadding2, setSwHMF, setXExt, setYExt, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PICF

public PICF()

PICF

public PICF(byte[] std,
            int offset)
Method Detail

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PICFAndOfficeArtData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PICFAndOfficeArtData

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PICFAndOfficeArtData

@Internal
public class PICFAndOfficeArtData
extends java.lang.Object

Constructor Summary
PICFAndOfficeArtData(byte[] dataStream, int startOffset)
Method Summary
java.util.List<EscherRecord> | getBlipRecords()
PICF | getPicf()
EscherContainerRecord | getShape()
byte[] | getStPicName()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PICFAndOfficeArtData

public PICFAndOfficeArtData(byte[] dataStream,
                            int startOffset)
Method Detail

getBlipRecords

public java.util.List<EscherRecord> getBlipRecords()

getPicf

public PICF getPicf()

getShape

public EscherContainerRecord getShape()

getStPicName

public byte[] getStPicName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PicturesTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PicturesTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PicturesTable

@Internal
public final class PicturesTable
extends java.lang.Object

Holds information about all pictures embedded in Word Document either via "Insert -> Picture -> From File" or via clipboard. Responsible for images extraction and determining whether some document's piece contains embedded image. Analyzes raw data bytestream 'Data' (where Word stores all embedded objects) provided by HWPFDocument. Word stores images as is within so called "Data stream" - the stream within a Word docfile containing various data that hang off of characters in the main stream. For example, binary data describing in-line pictures and/or formfields an also embedded objects-native data. Word picture structures are concatenated one after the other in the data stream if the document contains pictures. Data stream is easily reachable via HWPFDocument._dataStream property. A picture is represented in the document text stream as a special character, an Unicode  whose CharacterRun.isSpecial() returns true. The file location of the picture in the Word binary file is accessed via CharacterRun.getPicOffset(). The CharacterRun.getPicOffset() is a byte offset into the data stream. Beginning at the position recorded in picOffset, a header data structure, will be stored.

Author:
Dmitry Romanov

Constructor Summary
PicturesTable(HWPFDocument _document, byte[] _dataStream, byte[] _mainStream)
PicturesTable(HWPFDocument _document, byte[] _dataStream, byte[] _mainStream, FSPATable fspa, EscherRecordHolder dgg)
Deprecated.
Method Summary
Picture | extractPicture(CharacterRun run, boolean fillBytes) Returns picture object tied to specified CharacterRun
java.util.List<Picture> | getAllPictures() Not all documents have all the images concatenated in the data stream although MS claims so.
boolean | hasEscherPicture(CharacterRun run)
boolean | hasHorizontalLine(CharacterRun run) determines whether specified CharacterRun contains reference to a picture
boolean | hasPicture(CharacterRun run) determines whether specified CharacterRun contains reference to a picture
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PicturesTable

@Deprecated
public PicturesTable(HWPFDocument _document,
                                byte[] _dataStream,
                                byte[] _mainStream,
                                FSPATable fspa,
                                EscherRecordHolder dgg)
Deprecated.

Parameters:
_document -
_dataStream -

PicturesTable

public PicturesTable(HWPFDocument _document,
                     byte[] _dataStream,
                     byte[] _mainStream)
Method Detail

hasPicture

public boolean hasPicture(CharacterRun run)
determines whether specified CharacterRun contains reference to a picture

Parameters:
run -

hasEscherPicture

public boolean hasEscherPicture(CharacterRun run)

hasHorizontalLine

public boolean hasHorizontalLine(CharacterRun run)
determines whether specified CharacterRun contains reference to a picture

Parameters:
run -

extractPicture

public Picture extractPicture(CharacterRun run,
                              boolean fillBytes)
Returns picture object tied to specified CharacterRun

Parameters:
run -
fillBytes - if true, Picture will be returned with filled byte array that represent picture's contents. If you don't want to have that byte array in memory but only write picture's contents to stream, pass false and then use Picture.writeImageContent
Returns:
a Picture object if picture exists for specified CharacterRun, null otherwise. PicturesTable.hasPicture is used to determine this.
See Also:
Picture.writeImageContent(java.io.OutputStream), hasPicture(org.apache.poi.hwpf.usermodel.CharacterRun)

getAllPictures

public java.util.List<Picture> getAllPictures()
Not all documents have all the images concatenated in the data stream although MS claims so. The best approach is to scan all character runs.

Returns:
a list of Picture objects found in current document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PieceDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PieceDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PieceDescriptor

@Internal
public final class PieceDescriptor
extends java.lang.Object

Constructor Summary
PieceDescriptor(byte[] buf, int offset)
Method Summary
boolean | equals(java.lang.Object obj)
int | getFilePosition()
PropertyModifier | getPrm()
static int | getSizeInBytes()
int | hashCode()
boolean | isUnicode()
void | setFilePosition(int pos)
protected byte[] | toByteArray()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PieceDescriptor

public PieceDescriptor(byte[] buf,
                       int offset)
Method Detail

getFilePosition

public int getFilePosition()

setFilePosition

public void setFilePosition(int pos)

isUnicode

public boolean isUnicode()

getPrm

public PropertyModifier getPrm()

toByteArray

protected byte[] toByteArray()

getSizeInBytes

public static int getSizeInBytes()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PlexOfCps

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PlexOfCps

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PlexOfCps

public final class PlexOfCps
extends java.lang.Object

Plex of CPs stored in File (PLCF) common data structure in a Word file. Contains an array of 4 byte ints in the front that relate to an array of arbitrary data structures in the back. See page 184 of official documentation for details

Author:
Ryan Ackley

Constructor Summary
PlexOfCps(byte[] buf, int start, int cb, int cbStruct)
Constructor
PlexOfCps(int sizeOfStruct)
Method Summary
void | addProperty(GenericPropertyNode node)
GenericPropertyNode | getProperty(int index)
int | length() returns the number of data structures in this PlexofCps.
byte[] | toByteArray()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PlexOfCps

public PlexOfCps(int sizeOfStruct)

PlexOfCps

public PlexOfCps(byte[] buf,
                 int start,
                 int cb,
                 int cbStruct)
Constructor

Parameters:
cb - The size of PLCF in bytes
cbStruct - The size of the data structure type stored in this PlexOfCps.
Method Detail

getProperty

public GenericPropertyNode getProperty(int index)

addProperty

public void addProperty(GenericPropertyNode node)

toByteArray

public byte[] toByteArray()

length

public int length()
returns the number of data structures in this PlexofCps.

Returns:
The number of data structures in this PlexofCps

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PlexOfField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PlexOfField

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PlexOfField

@Internal
public class PlexOfField
extends java.lang.Object

Structure describing the Plex for fields (contained plclfd* in the spec).

Author:
Cedric Bosdonnat

Constructor Summary
PlexOfField(GenericPropertyNode propertyNode)
PlexOfField(int fcStart, int fcEnd, byte[] data)
Deprecated.
Method Summary
int | getFcEnd()
int | getFcStart()
FieldDescriptor | getFld()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PlexOfField

@Deprecated
public PlexOfField(int fcStart,
                              int fcEnd,
                              byte[] data)
Deprecated.

PlexOfField

public PlexOfField(GenericPropertyNode propertyNode)
Method Detail

getFcStart

public int getFcStart()

getFcEnd

public int getFcEnd()

getFld

public FieldDescriptor getFld()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyModifier

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PropertyModifier

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyModifier
All Implemented Interfaces:
java.lang.Cloneable
@Internal
public final class PropertyModifier
extends java.lang.Object
implements java.lang.Cloneable

Constructor Summary
PropertyModifier(short value)
Method Summary
protected PropertyModifier | clone()
boolean | equals(java.lang.Object obj)
short | getIgrpprl() "Index to a grpprl stored in CLX portion of file"
short | getIsprm()
short | getVal()
short | getValue()
int | hashCode()
boolean | isComplex()
java.lang.String | toString()
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyModifier

public PropertyModifier(short value)
Method Detail

clone

protected PropertyModifier clone()
                          throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

getIgrpprl

public short getIgrpprl()
"Index to a grpprl stored in CLX portion of file"

getIsprm

public short getIsprm()

getVal

public short getVal()

getValue

public short getValue()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isComplex

public boolean isComplex()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyNode.EndComparator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PropertyNode.EndComparator

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode.EndComparator
All Implemented Interfaces:
java.util.Comparator<PropertyNode<?>>
Enclosing class:
PropertyNode<T extends PropertyNode<T>>
public static final class PropertyNode.EndComparator
extends java.lang.Object
implements java.util.Comparator<PropertyNode<?>>

Field Summary
static PropertyNode.EndComparator instance
Constructor Summary
PropertyNode.EndComparator()
Method Summary
 int compare(PropertyNode<?> o1, PropertyNode<?> o2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Field Detail

instance

public static PropertyNode.EndComparator instance
Constructor Detail

PropertyNode.EndComparator

public PropertyNode.EndComparator()
Method Detail

compare

public int compare(PropertyNode<?> o1,
                   PropertyNode<?> o2)
Specified by:
compare in interface java.util.Comparator<PropertyNode<?>>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PropertyNode<T extends PropertyNode<T>>

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<T>
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<T>
Direct Known Subclasses:
BytePropertyNode, CachedPropertyNode, GenericPropertyNode, SEPX, TextPiece
@Internal
public abstract class PropertyNode<T extends PropertyNode<T>>
extends java.lang.Object
implements java.lang.Comparable<T>, java.lang.Cloneable

Represents a lightweight node in the Trees used to store content properties. This only ever works in characters. For the few odd cases when the start and end aren't in characters (eg PAPX and CHPX), use BytePropertyNode between you and this.

Author:
Ryan Ackley

Nested Class Summary
static class | PropertyNode.EndComparator
static class | PropertyNode.StartComparator
Field Summary
protected  java.lang.Object _buf
Constructor Summary
protected PropertyNode(int fcStart, int fcEnd, java.lang.Object buf)
Method Summary
void | adjustForDelete(int start, int length) Adjust for a deletion that can span multiple PropertyNodes.
T | clone()
int | compareTo(T o) Used for sorting in collections.
boolean | equals(java.lang.Object o)
int | getEnd()
int | getStart()
int | hashCode()
protected boolean | limitsAreEqual(java.lang.Object o)
void | setEnd(int end)
void | setStart(int start)
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

_buf

protected java.lang.Object _buf
Constructor Detail

PropertyNode

protected PropertyNode(int fcStart,
                       int fcEnd,
                       java.lang.Object buf)
Parameters:
fcStart - The start of the text for this property, in characters.
fcEnd - The end of the text for this property, in characters.
buf - FIXME: Old documentation is: "grpprl The property description in compressed form."
Method Detail

getStart

public int getStart()
Returns:
The start offset of this property's text.

setStart

public void setStart(int start)

getEnd

public int getEnd()
Returns:
The offset of the end of this property's text.

setEnd

public void setEnd(int end)

adjustForDelete

public void adjustForDelete(int start,
                            int length)
Adjust for a deletion that can span multiple PropertyNodes.

Parameters:
start -
length -

limitsAreEqual

protected boolean limitsAreEqual(java.lang.Object o)

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

clone

public T clone()
                                throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

compareTo

public int compareTo(T o)
Used for sorting in collections.

Specified by:
compareTo in interface java.lang.Comparable<T extends PropertyNode<T>>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyNode.StartComparator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class PropertyNode.StartComparator

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode.StartComparator
All Implemented Interfaces:
java.util.Comparator<PropertyNode<?>>
Enclosing class:
PropertyNode<T extends PropertyNode<T>>
public static final class PropertyNode.StartComparator
extends java.lang.Object
implements java.util.Comparator<PropertyNode<?>>

Field Summary
static PropertyNode.StartComparator instance
Constructor Summary
PropertyNode.StartComparator()
Method Summary
 int compare(PropertyNode<?> o1, PropertyNode<?> o2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Field Detail

instance

public static PropertyNode.StartComparator instance
Constructor Detail

PropertyNode.StartComparator

public PropertyNode.StartComparator()
Method Detail

compare

public int compare(PropertyNode<?> o1,
                   PropertyNode<?> o2)
Specified by:
compare in interface java.util.Comparator<PropertyNode<?>>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RevisionMarkAuthorTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class RevisionMarkAuthorTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.RevisionMarkAuthorTable

@Internal
public final class RevisionMarkAuthorTable
extends java.lang.Object

String table containing the names of authors of revision marks, e-mails and comments in this document.

Author:
Ryan Lauck

Constructor Summary
RevisionMarkAuthorTable(byte[] tableStream, int offset, int size)
Constructor to read the table from the table stream.
Method Summary
java.lang.String | getAuthor(int index) Get an author by its index.
java.util.List<java.lang.String> | getEntries() Gets the entries.
int | getSize() Gets the number of entries.
void | writeTo(HWPFOutputStream tableStream) Writes this table to the table stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RevisionMarkAuthorTable

public RevisionMarkAuthorTable(byte[] tableStream,
                               int offset,
                               int size)
                        throws java.io.IOException
Constructor to read the table from the table stream.

Parameters:
tableStream - the table stream.
offset - the offset into the byte array.
size - the size of the table in the byte array.
Throws:
java.io.IOException
Method Detail

getEntries

public java.util.List<java.lang.String> getEntries()
Gets the entries. The returned list cannot be modified.

Returns:
the list of entries.

getAuthor

public java.lang.String getAuthor(int index)
Get an author by its index. Returns null if it does not exist.

Returns:
the revision mark author

getSize

public int getSize()
Gets the number of entries.

Returns:
the number of entries.

writeTo

public void writeTo(HWPFOutputStream tableStream)
             throws java.io.IOException
Writes this table to the table stream.

Parameters:
tableStream - the table stream to write to.
Throws:
java.io.IOException - if an error occurs while writing.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SavedByEntry

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class SavedByEntry

java.lang.Object
    extended by  org.apache.poi.hwpf.model.SavedByEntry

@Internal
public final class SavedByEntry
extends java.lang.Object

A single entry in the SavedByTable.

Author:
Daniel Noll

Constructor Summary
SavedByEntry(java.lang.String userName, java.lang.String saveLocation)
Method Summary
boolean | equals(java.lang.Object other) Compares this object with another, for equality.
java.lang.String | getSaveLocation()
java.lang.String | getUserName()
int | hashCode() Generates a hash code for consistency with equals(Object).
java.lang.String | toString() Returns a string for display.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SavedByEntry

public SavedByEntry(java.lang.String userName,
                    java.lang.String saveLocation)
Method Detail

getUserName

public java.lang.String getUserName()

getSaveLocation

public java.lang.String getSaveLocation()

equals

public boolean equals(java.lang.Object other)
Compares this object with another, for equality.

Overrides:
equals in class java.lang.Object
Parameters:
other - the object to compare to this one.
Returns:
true iff the other object is equal to this one.

hashCode

public int hashCode()
Generates a hash code for consistency with equals(Object).

Overrides:
hashCode in class java.lang.Object
Returns:
the hash code.

toString

public java.lang.String toString()
Returns a string for display.

Overrides:
toString in class java.lang.Object
Returns:
the string.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SavedByTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class SavedByTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.SavedByTable

@Internal
public final class SavedByTable
extends java.lang.Object

String table containing the history of the last few revisions ("saves") of the document. Read-only for the time being.

Author:
Daniel Noll

Constructor Summary
SavedByTable(byte[] tableStream, int offset, int size)
Constructor to read the table from the table stream.
Method Summary
java.util.List<SavedByEntry> | getEntries() Gets the entries.
void | writeTo(HWPFOutputStream tableStream) Writes this table to the table stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SavedByTable

public SavedByTable(byte[] tableStream,
                    int offset,
                    int size)
Constructor to read the table from the table stream.

Parameters:
tableStream - the table stream.
offset - the offset into the byte array.
size - the size of the table in the byte array.
Method Detail

getEntries

public java.util.List<SavedByEntry> getEntries()
Gets the entries. The returned list cannot be modified.

Returns:
the list of entries.

writeTo

public void writeTo(HWPFOutputStream tableStream)
             throws java.io.IOException
Writes this table to the table stream.

Parameters:
tableStream - the table stream to write to.
Throws:
java.io.IOException - if an error occurs while writing.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SectionDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class SectionDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.SectionDescriptor

@Internal
public final class SectionDescriptor
extends java.lang.Object

Section Descriptor (SED) See page 186 for details.

Constructor Summary
SectionDescriptor()
SectionDescriptor(byte[] buf, int offset)
Method Summary
boolean | equals(java.lang.Object o)
int | getFc()
void | setFc(int fc)
byte[] | toByteArray()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SectionDescriptor

public SectionDescriptor()

SectionDescriptor

public SectionDescriptor(byte[] buf,
                         int offset)
Method Detail

getFc

public int getFc()

setFc

public void setFc(int fc)

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

toByteArray

public byte[] toByteArray()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SectionTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class SectionTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.SectionTable
Direct Known Subclasses:
OldSectionTable
@Internal
public class SectionTable
extends java.lang.Object

Author:
Ryan Ackley

Field Summary
protected java.util.ArrayList<SEPX> | _sections
protected java.util.List<TextPiece> | _text
Constructor Summary
SectionTable()
SectionTable(byte[] documentStream, byte[] tableStream, int offset, int size, int fcMin, TextPieceTable tpt, int mainLength)
Method Summary
void | adjustForInsert(int listIndex, int length)
java.util.ArrayList<SEPX> | getSections()
void | writeTo(HWPFFileSystem sys, int fcMin) Deprecated.
void | writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_sections

protected java.util.ArrayList<SEPX> _sections

_text

protected java.util.List<TextPiece> _text
Constructor Detail

SectionTable

public SectionTable()

SectionTable

public SectionTable(byte[] documentStream,
                    byte[] tableStream,
                    int offset,
                    int size,
                    int fcMin,
                    TextPieceTable tpt,
                    int mainLength)
Method Detail

adjustForInsert

public void adjustForInsert(int listIndex,
                            int length)

getSections

public java.util.ArrayList<SEPX> getSections()

writeTo

@Deprecated
public void writeTo(HWPFFileSystem sys,
                               int fcMin)
             throws java.io.IOException
Deprecated.

Throws:
java.io.IOException

writeTo

public void writeTo(HWPFOutputStream wordDocumentStream,
                    HWPFOutputStream tableStream)
             throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SEPX

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class SEPX

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<SEPX>
        extended by  org.apache.poi.hwpf.model.SEPX
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<SEPX>
@Internal
public final class SEPX
extends PropertyNode<SEPX>

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
SEPX(SectionDescriptor sed, int start, int end, byte[] grpprl)
Method Summary
boolean | equals(java.lang.Object o)
byte[] | getGrpprl()
SectionDescriptor | getSectionDescriptor()
SectionProperties | getSectionProperties()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
adjustForDelete, clone, compareTo, getEnd, getStart, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SEPX

public SEPX(SectionDescriptor sed,
            int start,
            int end,
            byte[] grpprl)
Method Detail

getGrpprl

public byte[] getGrpprl()

getSectionDescriptor

public SectionDescriptor getSectionDescriptor()

getSectionProperties

public SectionProperties getSectionProperties()

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class PropertyNode<SEPX>

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapesTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class ShapesTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.ShapesTable
Deprecated.

@Internal
@Deprecated
public final class ShapesTable
extends java.lang.Object

Constructor Summary
ShapesTable(byte[] tblStream, FileInformationBlock fib)
Deprecated.
Method Summary
java.util.List<Shape> | getAllShapes() Deprecated.
java.util.List<Shape> | getVisibleShapes() Deprecated.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShapesTable

public ShapesTable(byte[] tblStream,
                   FileInformationBlock fib)
Deprecated.
Method Detail

getAllShapes

public java.util.List<Shape> getAllShapes()
Deprecated.

getVisibleShapes

public java.util.List<Shape> getVisibleShapes()
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SinglentonTextPiece

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class SinglentonTextPiece

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<TextPiece>
        extended by  org.apache.poi.hwpf.model.TextPiece
            extended by  org.apache.poi.hwpf.model.SinglentonTextPiece
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<TextPiece>
@Internal
public class SinglentonTextPiece
extends TextPiece

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
SinglentonTextPiece(java.lang.StringBuilder buffer)
Method Summary
int | bytesLength() Returns the length, in bytes
int | characterLength() Returns the length, in characters
int | getCP() Returns the character position we start at.
int | getEnd()
int | getStart()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.TextPiece
adjustForDelete, equals, getPieceDescriptor, getRawBytes, getStringBuffer, getStringBuilder, isUnicode, substring
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
clone, compareTo, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SinglentonTextPiece

public SinglentonTextPiece(java.lang.StringBuilder buffer)
                    throws java.io.IOException
Throws:
java.io.IOException
Method Detail

bytesLength

public int bytesLength()
Description copied from class: TextPiece
Returns the length, in bytes

Overrides:
bytesLength in class TextPiece

characterLength

public int characterLength()
Description copied from class: TextPiece
Returns the length, in characters

Overrides:
characterLength in class TextPiece

getCP

public int getCP()
Description copied from class: TextPiece
Returns the character position we start at.

Overrides:
getCP in class TextPiece

getEnd

public int getEnd()
Overrides:
getEnd in class PropertyNode<TextPiece>
Returns:
The offset of the end of this property's text.

getStart

public int getStart()
Overrides:
getStart in class PropertyNode<TextPiece>
Returns:
The start offset of this property's text.

toString

public java.lang.String toString()
Overrides:
toString in class TextPiece
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StyleDescription

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class StyleDescription

java.lang.Object
    extended by  org.apache.poi.hwpf.model.StyleDescription
All Implemented Interfaces:
HDFType
@Internal
public final class StyleDescription
extends java.lang.Object
implements HDFType

Comment me

Author:
Ryan Ackley

Constructor Summary
StyleDescription()
StyleDescription(byte[] std, int baseLength, int offset, boolean word9)
Method Summary
boolean | equals(java.lang.Object obj)
int | getBaseStyle()
CharacterProperties | getCHP() Deprecated.
byte[] | getCHPX()
java.lang.String | getName()
ParagraphProperties | getPAP() Deprecated.
byte[] | getPAPX()
int | hashCode()
byte[] | toByteArray()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

StyleDescription

public StyleDescription()

StyleDescription

public StyleDescription(byte[] std,
                        int baseLength,
                        int offset,
                        boolean word9)
Method Detail

getBaseStyle

public int getBaseStyle()

getCHPX

public byte[] getCHPX()

getPAPX

public byte[] getPAPX()

getPAP

@Deprecated
public ParagraphProperties getPAP()
Deprecated.

getCHP

@Deprecated
public CharacterProperties getCHP()
Deprecated.

getName

public java.lang.String getName()

toByteArray

public byte[] toByteArray()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StyleSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class StyleSheet

java.lang.Object
    extended by  org.apache.poi.hwpf.model.StyleSheet
All Implemented Interfaces:
HDFType
@Internal
public final class StyleSheet
extends java.lang.Object
implements HDFType

Represents a document's stylesheet. A word documents formatting is stored as compressed styles that are based on styles contained in the stylesheet. This class also contains static utility functions to uncompress different formatting properties.

Fields documentation is quotes from Microsoft Office Word 97-2007 Binary File Format (.doc) Specification, page 36 of 210

Author:
Ryan Ackley

Field Summary
static int NIL_STYLE
Constructor Summary
StyleSheet(byte[] tableStream, int offset)
StyleSheet constructor.
Method Summary
boolean | equals(java.lang.Object o)
CharacterProperties | getCharacterStyle(int styleIndex) Deprecated.
byte[] | getCHPX(int styleIndex)
byte[] | getPAPX(int styleIndex)
ParagraphProperties | getParagraphStyle(int styleIndex) Deprecated.
StyleDescription | getStyleDescription(int styleIndex) Gets the StyleDescription at index x.
int | numStyles() Gets the number of styles in the style sheet.
void | writeTo(HWPFOutputStream out)
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NIL_STYLE

public static final int NIL_STYLE
See Also:
Constant Field Values
Constructor Detail

StyleSheet

public StyleSheet(byte[] tableStream,
                  int offset)
StyleSheet constructor. Loads a document's stylesheet information,

Parameters:
tableStream - A byte array containing a document's raw stylesheet info. Found by using FileInformationBlock.getFcStshf() and FileInformationBLock.getLcbStshf()
Method Detail

writeTo

public void writeTo(HWPFOutputStream out)
             throws java.io.IOException
Throws:
java.io.IOException

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

numStyles

public int numStyles()
Gets the number of styles in the style sheet.

Returns:
The number of styles in the style sheet.

getStyleDescription

public StyleDescription getStyleDescription(int styleIndex)
Gets the StyleDescription at index x.

Parameters:
styleIndex - the index of the desired StyleDescription.

getCharacterStyle

@Deprecated
public CharacterProperties getCharacterStyle(int styleIndex)
Deprecated.

getParagraphStyle

@Deprecated
public ParagraphProperties getParagraphStyle(int styleIndex)
Deprecated.

getCHPX

public byte[] getCHPX(int styleIndex)

getPAPX

public byte[] getPAPX(int styleIndex)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubdocumentType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.model
Enum SubdocumentType

java.lang.Object
    extended by  java.lang.Enum<SubdocumentType>
        extended by  org.apache.poi.hwpf.model.SubdocumentType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<SubdocumentType>
@Internal
public enum SubdocumentType
extends java.lang.Enum<SubdocumentType>

Document text parts that can have text pieces (CPs)

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Enum Constant Summary
ANNOTATION
ENDNOTE
FOOTNOTE
HEADER
HEADER_TEXTBOX
MACRO
Deprecated.
MAIN
TEXTBOX
Field Summary
static SubdocumentType[] ORDERED
Array of SubdocumentTypes ordered by document position and FIB field order
Method Summary
static SubdocumentType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static SubdocumentType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

MAIN

public static final SubdocumentType MAIN

FOOTNOTE

public static final SubdocumentType FOOTNOTE

HEADER

public static final SubdocumentType HEADER

MACRO

@Deprecated
public static final SubdocumentType MACRO
Deprecated.

ANNOTATION

public static final SubdocumentType ANNOTATION

ENDNOTE

public static final SubdocumentType ENDNOTE

TEXTBOX

public static final SubdocumentType TEXTBOX

HEADER_TEXTBOX

public static final SubdocumentType HEADER_TEXTBOX
Field Detail

ORDERED

public static final SubdocumentType[] ORDERED
Array of SubdocumentTypes ordered by document position and FIB field order

Method Detail

values

public static SubdocumentType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (SubdocumentType c : SubdocumentType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SubdocumentType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


TabDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class TabDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TBDAbstractType
        extended by  org.apache.poi.hwpf.model.TabDescriptor

public class TabDescriptor
extends TBDAbstractType

Tab descriptor. Part of ParagraphProperties.

Author:
vlsergey

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.TBDAbstractType
field_1_value
Constructor Summary
TabDescriptor()
TabDescriptor(byte[] bytes, int offset)
Method Summary
 byte[] toByteArray()
Methods inherited from class org.apache.poi.hwpf.model.types.TBDAbstractType
fillFields, getJc, getReserved, getSize, getTlc, getValue, serialize, setJc, setReserved, setTlc, setValue, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TabDescriptor

public TabDescriptor()

TabDescriptor

public TabDescriptor(byte[] bytes,
                     int offset)
Method Detail

toByteArray

public byte[] toByteArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextPiece

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class TextPiece

java.lang.Object
    extended by  org.apache.poi.hwpf.model.PropertyNode<TextPiece>
        extended by  org.apache.poi.hwpf.model.TextPiece
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Comparable<TextPiece>
Direct Known Subclasses:
SinglentonTextPiece
@Internal
public class TextPiece
extends PropertyNode<TextPiece>

Lightweight representation of a text piece. Works in the character domain, not the byte domain, so you need to have turned byte references into character references before getting here.

Author:
Ryan Ackley

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.hwpf.model.PropertyNode
PropertyNode.EndComparator, PropertyNode.StartComparator
Field Summary
Fields inherited from class org.apache.poi.hwpf.model.PropertyNode
_buf
Constructor Summary
TextPiece(int start, int end, byte[] text, PieceDescriptor pd)
TextPiece(int start, int end, byte[] text, PieceDescriptor pd, int cpStart)
Deprecated. Use TextPiece(int,int,byte[],PieceDescriptor) instead
Method Summary
void | adjustForDelete(int start, int length) Deprecated.
int | bytesLength() Returns the length, in bytes
int | characterLength() Deprecated.
boolean | equals(java.lang.Object o)
int | getCP() Returns the character position we start at.
PieceDescriptor | getPieceDescriptor()
byte[] | getRawBytes()
java.lang.StringBuffer | getStringBuffer() Deprecated.
java.lang.StringBuilder | getStringBuilder()
boolean | isUnicode()
java.lang.String | substring(int start, int end) Deprecated.
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.PropertyNode
clone, compareTo, getEnd, getStart, hashCode, limitsAreEqual, setEnd, setStart
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TextPiece

public TextPiece(int start,
                 int end,
                 byte[] text,
                 PieceDescriptor pd,
                 int cpStart)
Deprecated. Use TextPiece(int,int,byte[],PieceDescriptor) instead

Parameters:
start - Beginning offset in main document stream, in characters.
end - Ending offset in main document stream, in characters.
text - The raw bytes of our text

TextPiece

public TextPiece(int start,
                 int end,
                 byte[] text,
                 PieceDescriptor pd)
Parameters:
start - Beginning offset in main document stream, in characters.
end - Ending offset in main document stream, in characters.
text - The raw bytes of our text
Method Detail

isUnicode

public boolean isUnicode()
Returns:
If this text piece is unicode

getPieceDescriptor

public PieceDescriptor getPieceDescriptor()

getStringBuffer

@Deprecated
public java.lang.StringBuffer getStringBuffer()
Deprecated.

getStringBuilder

public java.lang.StringBuilder getStringBuilder()

getRawBytes

public byte[] getRawBytes()

substring

@Deprecated
public java.lang.String substring(int start,
                                             int end)
Deprecated.

Returns part of the string. Works only in characters, not in bytes!

Parameters:
start - Local start position, in characters
end - Local end position, in characters

adjustForDelete

@Deprecated
public void adjustForDelete(int start,
                                       int length)
Deprecated.

Adjusts the internal string for deletinging some characters within this.

Overrides:
adjustForDelete in class PropertyNode<TextPiece>
Parameters:
start - The start position for the delete, in characters
length - The number of characters to delete

characterLength

@Deprecated
public int characterLength()
Deprecated.

Returns the length, in characters

bytesLength

public int bytesLength()
Returns the length, in bytes

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class PropertyNode<TextPiece>

getCP

public int getCP()
Returns the character position we start at.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextPieceTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class TextPieceTable

java.lang.Object
    extended by  org.apache.poi.hwpf.model.TextPieceTable
All Implemented Interfaces:
CharIndexTranslator
@Internal
public class TextPieceTable
extends java.lang.Object
implements CharIndexTranslator

The piece table for matching up character positions to bits of text. This mostly works in bytes, but the TextPieces themselves work in characters. This does the icky convertion.

Author:
Ryan Ackley

Field Summary
protected java.util.ArrayList<TextPiece> | _textPieces
protected java.util.ArrayList<TextPiece> | _textPiecesFCOrder
Constructor Summary
TextPieceTable()
TextPieceTable(byte[] documentStream, byte[] tableStream, int offset, int size, int fcMin)
Method Summary
void | add(TextPiece piece)
int | adjustForInsert(int listIndex, int length) Adjust all the text piece after inserting some text into one of them
boolean | equals(java.lang.Object o)
int | getByteIndex(int charPos) Calculates the byte index of the given char index.
int | getCharIndex(int bytePos) Deprecated.
int | getCharIndex(int startBytePos, int startCP) Deprecated.
int[][] | getCharIndexRanges(int startBytePosInclusive, int endBytePosExclusive) Finds character ranges that includes specified byte range.
int | getCpMin()
java.lang.StringBuilder | getText()
java.util.List<TextPiece> | getTextPieces()
int | hashCode()
boolean | isIndexInTable(int bytePos) Check if index is in table
int | lookIndexBackward(int startBytePos) Return last index <= bytePos that is in table
int | lookIndexForward(int startBytePos) Return first index >= bytePos that is in table
byte[] | writeTo(HWPFOutputStream docStream)
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

_textPieces

protected java.util.ArrayList<TextPiece> _textPieces

_textPiecesFCOrder

protected java.util.ArrayList<TextPiece> _textPiecesFCOrder
Constructor Detail

TextPieceTable

public TextPieceTable()

TextPieceTable

public TextPieceTable(byte[] documentStream,
                      byte[] tableStream,
                      int offset,
                      int size,
                      int fcMin)
Method Detail

add

public void add(TextPiece piece)

adjustForInsert

public int adjustForInsert(int listIndex,
                           int length)
Adjust all the text piece after inserting some text into one of them

Parameters:
listIndex - The TextPiece that had characters inserted into
length - The number of characters inserted

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

getByteIndex

public int getByteIndex(int charPos)
Description copied from interface: CharIndexTranslator
Calculates the byte index of the given char index.

Specified by:
getByteIndex in interface CharIndexTranslator
Parameters:
charPos - The char position
Returns:
The byte index

getCharIndex

@Deprecated
public int getCharIndex(int bytePos)
Deprecated.

Description copied from interface: CharIndexTranslator
Calculates the char index of the given byte index. Look forward if index is not in table

Specified by:
getCharIndex in interface CharIndexTranslator
Parameters:
bytePos - The character offset to check
Returns:
the char index

getCharIndex

@Deprecated
public int getCharIndex(int startBytePos,
                                   int startCP)
Deprecated.

Description copied from interface: CharIndexTranslator
Calculates the char index of the given byte index. Look forward if index is not in table

Specified by:
getCharIndex in interface CharIndexTranslator
Parameters:
startBytePos - The character offset to check
startCP - look from this characted position
Returns:
the char index

getCharIndexRanges

public int[][] getCharIndexRanges(int startBytePosInclusive,
                                  int endBytePosExclusive)
Description copied from interface: CharIndexTranslator
Finds character ranges that includes specified byte range.

Specified by:
getCharIndexRanges in interface CharIndexTranslator
Parameters:
startBytePosInclusive - start byte range
endBytePosExclusive - end byte range

getCpMin

public int getCpMin()

getText

public java.lang.StringBuilder getText()

getTextPieces

public java.util.List<TextPiece> getTextPieces()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isIndexInTable

public boolean isIndexInTable(int bytePos)
Description copied from interface: CharIndexTranslator
Check if index is in table

Specified by:
isIndexInTable in interface CharIndexTranslator
Returns:
true if index in table, false if not

lookIndexBackward

public int lookIndexBackward(int startBytePos)
Description copied from interface: CharIndexTranslator
Return last index <= bytePos that is in table

Specified by:
lookIndexBackward in interface CharIndexTranslator
Returns:
last index less of equal to bytePos that is in table

lookIndexForward

public int lookIndexForward(int startBytePos)
Description copied from interface: CharIndexTranslator
Return first index >= bytePos that is in table

Specified by:
lookIndexForward in interface CharIndexTranslator
Returns:
first index greater or equal to bytePos that is in table

writeTo

public byte[] writeTo(HWPFOutputStream docStream)
               throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnhandledDataStructure

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class UnhandledDataStructure

java.lang.Object
    extended by  org.apache.poi.hwpf.model.UnhandledDataStructure

@Internal
public final class UnhandledDataStructure
extends java.lang.Object

Constructor Summary
UnhandledDataStructure(byte[] buf, int offset, int length)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnhandledDataStructure

public UnhandledDataStructure(byte[] buf,
                              int offset,
                              int length)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UPX

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model
Class UPX

java.lang.Object
    extended by  org.apache.poi.hwpf.model.UPX

@Internal
public final class UPX
extends java.lang.Object

Constructor Summary
UPX(byte[] upx)
Method Summary
boolean | equals(java.lang.Object o)
byte[] | getUPX()
int | size()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UPX

public UPX(byte[] upx)
Method Detail

getUPX

public byte[] getUPX()

size

public int size()

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hwpf.model.BookmarkFirstDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.BookmarkFirstDescriptor

Packages that use BookmarkFirstDescriptor
org.apache.poi.hwpf.model

Uses of BookmarkFirstDescriptor in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return BookmarkFirstDescriptor
protected  BookmarkFirstDescriptor BookmarkFirstDescriptor.clone()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.BookmarksTables

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.BookmarksTables

Packages that use BookmarksTables
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of BookmarksTables in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as BookmarksTables
protected  BookmarksTables HWPFDocument._bookmarksTables
Holds the bookmarks tables

Uses of BookmarksTables in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type BookmarksTables
BookmarksImpl(BookmarksTables bookmarksTables)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.BytePropertyNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.BytePropertyNode

Packages that use BytePropertyNode
org.apache.poi.hwpf.model

Uses of BytePropertyNode in org.apache.poi.hwpf.model

Classes in org.apache.poi.hwpf.model with type parameters of type BytePropertyNode
 class BytePropertyNode<T extends BytePropertyNode<T>>
Deprecated. byte positions shall not be saved in memory

Subclasses of BytePropertyNode in org.apache.poi.hwpf.model
class | CHPX DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
class | PAPX DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.CachedPropertyNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.CachedPropertyNode

No usage of org.apache.poi.hwpf.model.CachedPropertyNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.model.CharIndexTranslator

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.model.CharIndexTranslator

Packages that use CharIndexTranslator
org.apache.poi.hwpf.model

Uses of CharIndexTranslator in org.apache.poi.hwpf.model

Classes in org.apache.poi.hwpf.model that implement CharIndexTranslator
 class TextPieceTable
The piece table for matching up character positions to bits of text.

Methods in org.apache.poi.hwpf.model with parameters of type CharIndexTranslator
protected  byte[] CHPFormattedDiskPage.toByteArray(CharIndexTranslator translator)
protected  byte[] CHPFormattedDiskPage.toByteArray(CharIndexTranslator translator, int fcMin)
Deprecated. Use CHPFormattedDiskPage.toByteArray(CharIndexTranslator) instead
protected  byte[] PAPFormattedDiskPage.toByteArray(HWPFOutputStream dataStream, CharIndexTranslator translator)
Creates a byte array representation of this data structure.
 void PAPBinTable.writeTo(HWPFFileSystem sys, CharIndexTranslator translator)
Deprecated.
 void CHPBinTable.writeTo(HWPFFileSystem sys, int fcMin, CharIndexTranslator translator)
Deprecated.
 void PAPBinTable.writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream, CharIndexTranslator translator)
 void CHPBinTable.writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream, int fcMin, CharIndexTranslator translator)

Constructors in org.apache.poi.hwpf.model with parameters of type CharIndexTranslator
BytePropertyNode(int fcStart, int fcEnd, CharIndexTranslator translator, java.lang.Object buf)
Deprecated.
CHPBinTable(byte[] documentStream, byte[] tableStream, int offset, int size, CharIndexTranslator translator)
Constructor used to read a binTable in from a Word document.
CHPFormattedDiskPage(byte[] documentStream, int offset, CharIndexTranslator translator)
This constructs a CHPFormattedDiskPage from a raw fkp (512 byte array read from a Word file).
CHPX(int fcStart, int fcEnd, CharIndexTranslator translator, byte[] grpprl)
Deprecated.
CHPX(int fcStart, int fcEnd, CharIndexTranslator translator, SprmBuffer buf)
Deprecated.
PAPBinTable(byte[] documentStream, byte[] tableStream, byte[] dataStream, int offset, int size, CharIndexTranslator charIndexTranslator)
PAPFormattedDiskPage(byte[] documentStream, byte[] dataStream, int offset, CharIndexTranslator translator)
Creates a PAPFormattedDiskPage from a 512 byte array
PAPX(int fcStart, int fcEnd, CharIndexTranslator translator, byte[] papx, ParagraphHeight phe, byte[] dataStream)
PAPX(int fcStart, int fcEnd, CharIndexTranslator translator, SprmBuffer buf, byte[] dataStream)
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.CHPBinTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.CHPBinTable

Packages that use CHPBinTable
org.apache.poi.hwpf
org.apache.poi.hwpf.model

Uses of CHPBinTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as CHPBinTable
protected  CHPBinTable HWPFDocumentCore._cbt
Contains formatting properties for text

Methods in org.apache.poi.hwpf that return CHPBinTable
 CHPBinTable HWPFDocumentCore.getCharacterTable()

Uses of CHPBinTable in org.apache.poi.hwpf.model

Subclasses of CHPBinTable in org.apache.poi.hwpf.model
 class OldCHPBinTable
This class holds all of the character formatting properties from Old (Word 6 / Word 95) documents.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.CHPFormattedDiskPage

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.CHPFormattedDiskPage

No usage of org.apache.poi.hwpf.model.CHPFormattedDiskPage

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.CHPX

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.CHPX

Packages that use CHPX
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of CHPX in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model with type parameters of type CHPX
protected  java.util.ArrayList<CHPX> CHPBinTable._textRuns
List of character properties.

Methods in org.apache.poi.hwpf.model that return CHPX
 CHPX CHPFormattedDiskPage.getCHPX(int index)

Methods in org.apache.poi.hwpf.model that return types with arguments of type CHPX
java.util.List<CHPX> | CHPFormattedDiskPage.getCHPXs()
java.util.ArrayList<CHPX> | CHPFormattedDiskPage.getOverflow()
java.util.List<CHPX> | CHPBinTable.getTextRuns()

Method parameters in org.apache.poi.hwpf.model with type arguments of type CHPX
 void CHPFormattedDiskPage.fill(java.util.List<CHPX> filler)

Uses of CHPX in org.apache.poi.hwpf.usermodel

Fields in org.apache.poi.hwpf.usermodel with type parameters of type CHPX
protected  java.util.List<CHPX> Range._characters
All CharacterRuns that belong to the document this Range belongs to.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.Colorref

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.Colorref

Packages that use Colorref
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.types

Uses of Colorref in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return Colorref
Colorref | Colorref.clone()
static Colorref | Colorref.valueOfIco(int ico)

Uses of Colorref in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as Colorref
protected Colorref | SHDAbstractType.field_1_cvFore
protected Colorref | SHDAbstractType.field_2_cvBack
protected Colorref | CHPAbstractType.field_8_cv

Methods in org.apache.poi.hwpf.model.types that return Colorref
Colorref | CHPAbstractType.getCv() 24-bit color.
Colorref | SHDAbstractType.getCvBack() 24-bit background color.
Colorref | SHDAbstractType.getCvFore() 24-bit foreground color.

Methods in org.apache.poi.hwpf.model.types with parameters of type Colorref
void | CHPAbstractType.setCv(Colorref field_8_cv) 24-bit color.
void | SHDAbstractType.setCvBack(Colorref field_2_cvBack) 24-bit background color.
void | SHDAbstractType.setCvFore(Colorref field_1_cvFore) 24-bit foreground color.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ComplexFileTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ComplexFileTable

Packages that use ComplexFileTable
org.apache.poi.hwpf
org.apache.poi.hwpf.model

Uses of ComplexFileTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as ComplexFileTable
protected  ComplexFileTable HWPFDocument._cft
Contains text of the document wrapped in a obfuscated Word data structure

Uses of ComplexFileTable in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model with parameters of type ComplexFileTable
void | CHPBinTable.rebuild(ComplexFileTable complexFileTable)
void | PAPBinTable.rebuild(java.lang.StringBuilder docText, ComplexFileTable complexFileTable)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.DocumentProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.DocumentProperties

Packages that use DocumentProperties
org.apache.poi.hwpf

Uses of DocumentProperties in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as DocumentProperties
protected  DocumentProperties HWPFDocument._dop
Document wide Properties

Methods in org.apache.poi.hwpf that return DocumentProperties
 DocumentProperties HWPFDocument.getDocProperties()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.EscherRecordHolder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.EscherRecordHolder

Packages that use EscherRecordHolder
org.apache.poi.hwpf
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of EscherRecordHolder in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as EscherRecordHolder
protected  EscherRecordHolder HWPFDocument._escherRecordHolder
Escher Drawing Group information

Methods in org.apache.poi.hwpf that return EscherRecordHolder
 EscherRecordHolder HWPFDocument.getEscherRecordHolder()

Uses of EscherRecordHolder in org.apache.poi.hwpf.model

Constructors in org.apache.poi.hwpf.model with parameters of type EscherRecordHolder
PicturesTable(HWPFDocument _document, byte[] _dataStream, byte[] _mainStream, FSPATable fspa, EscherRecordHolder dgg)
Deprecated.

Uses of EscherRecordHolder in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type EscherRecordHolder
OfficeDrawingsImpl(FSPATable fspaTable, EscherRecordHolder escherRecordHolder, byte[] mainStream)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.Ffn

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.Ffn

Packages that use Ffn
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of Ffn in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return Ffn
 Ffn[] FontTable.getFontNames()

Uses of Ffn in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return Ffn
 Ffn CharacterRun.getSymbolFont()
Returns the symbol font, if this is a symbol character run.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FibBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FibBase

Packages that use FibBase
org.apache.poi.hwpf.model

Uses of FibBase in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return FibBase
 FibBase FileInformationBlock.getFibBase()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FIBFieldHandler

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FIBFieldHandler

No usage of org.apache.poi.hwpf.model.FIBFieldHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FieldDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FieldDescriptor

Packages that use FieldDescriptor
org.apache.poi.hwpf.model

Uses of FieldDescriptor in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return FieldDescriptor
 FieldDescriptor PlexOfField.getFld()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FieldsDocumentPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FieldsDocumentPart

Packages that use FieldsDocumentPart
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of FieldsDocumentPart in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return FieldsDocumentPart
static FieldsDocumentPart | FieldsDocumentPart.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FieldsDocumentPart[] | FieldsDocumentPart.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.hwpf.model with parameters of type FieldsDocumentPart
java.util.ArrayList<PlexOfField> | FieldsTables.getFieldsPLCF(FieldsDocumentPart part)
int | FileInformationBlock.getFieldsPlcfLength(FieldsDocumentPart part)
int | FileInformationBlock.getFieldsPlcfOffset(FieldsDocumentPart part)
void | FileInformationBlock.setFieldsPlcfLength(FieldsDocumentPart part, int length)
void | FileInformationBlock.setFieldsPlcfOffset(FieldsDocumentPart part, int offset)

Uses of FieldsDocumentPart in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel with parameters of type FieldsDocumentPart
org.apache.poi.hwpf.usermodel.FieldImpl | FieldsImpl.getFieldByStartOffset(FieldsDocumentPart documentPart, int offset)
Field | Fields.getFieldByStartOffset(FieldsDocumentPart documentPart, int offset)
java.util.Collection<Field> | FieldsImpl.getFields(FieldsDocumentPart part)
java.util.Collection<Field> | Fields.getFields(FieldsDocumentPart part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FieldsTables

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FieldsTables

Packages that use FieldsTables
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of FieldsTables in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as FieldsTables
protected  FieldsTables HWPFDocument._fieldsTables
Holds the fields PLCFs

Methods in org.apache.poi.hwpf that return FieldsTables
 FieldsTables HWPFDocument.getFieldsTables()
Deprecated.

Uses of FieldsTables in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type FieldsTables
FieldsImpl(FieldsTables fieldsTables)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FileInformationBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FileInformationBlock

Packages that use FileInformationBlock
org.apache.poi.hwpf
org.apache.poi.hwpf.model

Uses of FileInformationBlock in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as FileInformationBlock
protected  FileInformationBlock HWPFDocumentCore._fib
The FIB

Methods in org.apache.poi.hwpf that return FileInformationBlock
 FileInformationBlock HWPFDocumentCore.getFileInformationBlock()

Uses of FileInformationBlock in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model with parameters of type FileInformationBlock
void | FieldsTables.write(FileInformationBlock fib, HWPFOutputStream tableStream)
void | ListTables.writeListDataTo(FileInformationBlock fib, HWPFOutputStream tableStream)
void | BookmarksTables.writePlcfBkmkf(FileInformationBlock fib, HWPFOutputStream tableStream)
void | BookmarksTables.writePlcfBkmkl(FileInformationBlock fib, HWPFOutputStream tableStream)
void | NotesTables.writeRef(FileInformationBlock fib, HWPFOutputStream tableStream)
void | BookmarksTables.writeSttbfBkmk(FileInformationBlock fib, HWPFOutputStream tableStream)
void | NotesTables.writeTxt(FileInformationBlock fib, HWPFOutputStream tableStream)

Constructors in org.apache.poi.hwpf.model with parameters of type FileInformationBlock
BookmarksTables(byte[] tableStream, FileInformationBlock fib)
FieldsTables(byte[] tableStream, FileInformationBlock fib)
FSPATable(byte[] tableStream, FileInformationBlock fib, FSPADocumentPart part)
NotesTables(NoteType noteType, byte[] tableStream, FileInformationBlock fib)
ShapesTable(byte[] tblStream, FileInformationBlock fib)
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FontTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FontTable

Packages that use FontTable
org.apache.poi.hwpf

Uses of FontTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as FontTable
protected  FontTable HWPFDocumentCore._ft
Holds fonts for this document.

Methods in org.apache.poi.hwpf that return FontTable
 FontTable HWPFDocumentCore.getFontTable()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FootnoteReferenceDescriptor

Packages that use FootnoteReferenceDescriptor
org.apache.poi.hwpf.model

Uses of FootnoteReferenceDescriptor in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return FootnoteReferenceDescriptor
protected  FootnoteReferenceDescriptor FootnoteReferenceDescriptor.clone()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FormattedDiskPage

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FormattedDiskPage

Packages that use FormattedDiskPage
org.apache.poi.hwpf.model

Uses of FormattedDiskPage in org.apache.poi.hwpf.model

Subclasses of FormattedDiskPage in org.apache.poi.hwpf.model
class | CHPFormattedDiskPage Represents a CHP fkp.
class | PAPFormattedDiskPage Represents a PAP FKP.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FSPA

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FSPA

Packages that use FSPA
org.apache.poi.hwpf.model

Uses of FSPA in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return FSPA
FSPA | FSPATable.getFspaFromCp(int cp)
FSPA[] | FSPATable.getShapes()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FSPADocumentPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FSPADocumentPart

Packages that use FSPADocumentPart
org.apache.poi.hwpf.model

Uses of FSPADocumentPart in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return FSPADocumentPart
static FSPADocumentPart | FSPADocumentPart.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FSPADocumentPart[] | FSPADocumentPart.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.hwpf.model with parameters of type FSPADocumentPart
int | FileInformationBlock.getFSPAPlcfLength(FSPADocumentPart part)
int | FileInformationBlock.getFSPAPlcfOffset(FSPADocumentPart part)
void | FileInformationBlock.setFSPAPlcfLength(FSPADocumentPart part, int length)
void | FileInformationBlock.setFSPAPlcfOffset(FSPADocumentPart part, int offset)

Constructors in org.apache.poi.hwpf.model with parameters of type FSPADocumentPart
FSPATable(byte[] tableStream, FileInformationBlock fib, FSPADocumentPart part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.FSPATable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.FSPATable

Packages that use FSPATable
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of FSPATable in org.apache.poi.hwpf.model

Constructors in org.apache.poi.hwpf.model with parameters of type FSPATable
PicturesTable(HWPFDocument _document, byte[] _dataStream, byte[] _mainStream, FSPATable fspa, EscherRecordHolder dgg)
Deprecated.

Uses of FSPATable in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type FSPATable
OfficeDrawingsImpl(FSPATable fspaTable, EscherRecordHolder escherRecordHolder, byte[] mainStream)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.GenericPropertyNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.GenericPropertyNode

Packages that use GenericPropertyNode
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of GenericPropertyNode in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return GenericPropertyNode
GenericPropertyNode | NotesTables.getDescriptor(int index)
GenericPropertyNode | BookmarksTables.getDescriptorFirst(int index)
GenericPropertyNode | BookmarksTables.getDescriptorLim(int index)
GenericPropertyNode | PlexOfCps.getProperty(int index)
GenericPropertyNode | NotesTables.getTextPosition(int index)

Methods in org.apache.poi.hwpf.model with parameters of type GenericPropertyNode
void | PlexOfCps.addProperty(GenericPropertyNode node)
int | BookmarksTables.getDescriptorFirstIndex(GenericPropertyNode descriptorFirst)

Constructors in org.apache.poi.hwpf.model with parameters of type GenericPropertyNode
PlexOfField(GenericPropertyNode propertyNode)

Uses of GenericPropertyNode in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type GenericPropertyNode
Shape(GenericPropertyNode nodo)
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.Grfhic

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.Grfhic

Packages that use Grfhic
org.apache.poi.hwpf.model.types

Uses of Grfhic in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as Grfhic
protected Grfhic | LVLFAbstractType.field_11_grfhic
protected Grfhic | LSTFAbstractType.field_5_grfhic
protected Grfhic | LFOAbstractType.field_6_grfhic

Methods in org.apache.poi.hwpf.model.types that return Grfhic
Grfhic | LVLFAbstractType.getGrfhic() A grfhic that specifies the HTML incompatibilities of the level..
Grfhic | LSTFAbstractType.getGrfhic() A grfhic that specifies the HTML incompatibilities of the list..
Grfhic | LFOAbstractType.getGrfhic() HTML compatibility flags.

Methods in org.apache.poi.hwpf.model.types with parameters of type Grfhic
void | LVLFAbstractType.setGrfhic(Grfhic field_11_grfhic) A grfhic that specifies the HTML incompatibilities of the level..
void | LSTFAbstractType.setGrfhic(Grfhic field_5_grfhic) A grfhic that specifies the HTML incompatibilities of the list..
void | LFOAbstractType.setGrfhic(Grfhic field_6_grfhic) HTML compatibility flags.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.model.HDFType

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.model.HDFType

Packages that use HDFType
org.apache.poi.hwpf.model

Uses of HDFType in org.apache.poi.hwpf.model

Classes in org.apache.poi.hwpf.model that implement HDFType
class | StyleDescription Comment me
class | StyleSheet Represents a document's stylesheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.Hyphenation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.Hyphenation

Packages that use Hyphenation
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.types

Uses of Hyphenation in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return Hyphenation
 Hyphenation Hyphenation.clone()

Uses of Hyphenation in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as Hyphenation
protected Hyphenation | CHPAbstractType.field_20_hresi
protected Hyphenation | CHPAbstractType.field_40_hresiOld

Methods in org.apache.poi.hwpf.model.types that return Hyphenation
Hyphenation | CHPAbstractType.getHresi() Get the hresi field for the CHP record.
Hyphenation | CHPAbstractType.getHresiOld() Get the hresiOld field for the CHP record.

Methods in org.apache.poi.hwpf.model.types with parameters of type Hyphenation
void | CHPAbstractType.setHresi(Hyphenation field_20_hresi) Set the hresi field for the CHP record.
void | CHPAbstractType.setHresiOld(Hyphenation field_40_hresiOld) Set the hresiOld field for the CHP record.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ListData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ListData

Packages that use ListData
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of ListData in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return ListData
 ListData ListTables.getListData(int listID)

Methods in org.apache.poi.hwpf.model with parameters of type ListData
 int ListTables.addList(ListData lst, ListFormatOverride override)

Uses of ListData in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return ListData
 ListData HWPFList.getListData()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ListFormatOverride

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ListFormatOverride

Packages that use ListFormatOverride
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of ListFormatOverride in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return ListFormatOverride
 ListFormatOverride ListTables.getOverride(int lfoIndex)

Methods in org.apache.poi.hwpf.model with parameters of type ListFormatOverride
 int ListTables.addList(ListData lst, ListFormatOverride override)

Uses of ListFormatOverride in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return ListFormatOverride
 ListFormatOverride HWPFList.getOverride()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ListFormatOverrideLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ListFormatOverrideLevel

Packages that use ListFormatOverrideLevel
org.apache.poi.hwpf.model

Uses of ListFormatOverrideLevel in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return ListFormatOverrideLevel
ListFormatOverrideLevel[] | ListFormatOverride.getLevelOverrides()
ListFormatOverrideLevel | ListFormatOverride.getOverrideLevel(int level)

Methods in org.apache.poi.hwpf.model with parameters of type ListFormatOverrideLevel
 void ListFormatOverride.setOverride(int index, ListFormatOverrideLevel lfolvl)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ListLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ListLevel

Packages that use ListLevel
org.apache.poi.hwpf.model

Uses of ListLevel in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return ListLevel
ListLevel | ListFormatOverrideLevel.getLevel()
ListLevel | ListData.getLevel(int index) Gets the level associated to a particular List at a particular index.
ListLevel | ListTables.getLevel(int listID, int level)
ListLevel[] | ListData.getLevels()

Methods in org.apache.poi.hwpf.model with parameters of type ListLevel
 void ListData.setLevel(int index, ListLevel level)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ListTables

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ListTables

Packages that use ListTables
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev

Uses of ListTables in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as ListTables
protected  ListTables HWPFDocumentCore._lt
Hold list tables

Methods in org.apache.poi.hwpf that return ListTables
 ListTables HWPFDocumentCore.getListTables()

Uses of ListTables in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type ListTables
static java.lang.String AbstractWordUtils.getBulletText(ListTables listTables, Paragraph paragraph, int listId)

Uses of ListTables in org.apache.poi.hwpf.dev

Methods in org.apache.poi.hwpf.dev with parameters of type ListTables
protected  void HWPFLister.dumpParagraphLevels(ListTables listTables, ParagraphProperties paragraph)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.NotesTables

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.NotesTables

Packages that use NotesTables
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of NotesTables in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as NotesTables
protected NotesTables | HWPFDocument._endnotesTables Holds the ending notes tables
protected NotesTables | HWPFDocument._footnotesTables Holds the footnotes tables

Uses of NotesTables in org.apache.poi.hwpf.usermodel

Constructors in org.apache.poi.hwpf.usermodel with parameters of type NotesTables
NotesImpl(NotesTables notesTables)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.NoteType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.NoteType

Packages that use NoteType
org.apache.poi.hwpf.model

Uses of NoteType in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return NoteType
static NoteType | NoteType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static NoteType[] | NoteType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.hwpf.model with parameters of type NoteType
int | FileInformationBlock.getNotesDescriptorsOffset(NoteType noteType)
int | FileInformationBlock.getNotesDescriptorsSize(NoteType noteType)
int | FileInformationBlock.getNotesTextPositionsOffset(NoteType noteType)
int | FileInformationBlock.getNotesTextPositionsSize(NoteType noteType)
void | FileInformationBlock.setNotesDescriptorsOffset(NoteType noteType, int offset)
void | FileInformationBlock.setNotesDescriptorsSize(NoteType noteType, int offset)
void | FileInformationBlock.setNotesTextPositionsOffset(NoteType noteType, int offset)
void | FileInformationBlock.setNotesTextPositionsSize(NoteType noteType, int offset)

Constructors in org.apache.poi.hwpf.model with parameters of type NoteType
NotesTables(NoteType noteType)
NotesTables(NoteType noteType, byte[] tableStream, FileInformationBlock fib)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.OldCHPBinTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.OldCHPBinTable

No usage of org.apache.poi.hwpf.model.OldCHPBinTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.OldPAPBinTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.OldPAPBinTable

No usage of org.apache.poi.hwpf.model.OldPAPBinTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.OldSectionTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.OldSectionTable

No usage of org.apache.poi.hwpf.model.OldSectionTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PAPBinTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PAPBinTable

Packages that use PAPBinTable
org.apache.poi.hwpf
org.apache.poi.hwpf.model

Uses of PAPBinTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as PAPBinTable
protected  PAPBinTable HWPFDocumentCore._pbt
Contains formatting properties for paragraphs

Methods in org.apache.poi.hwpf that return PAPBinTable
 PAPBinTable HWPFDocumentCore.getParagraphTable()

Uses of PAPBinTable in org.apache.poi.hwpf.model

Subclasses of PAPBinTable in org.apache.poi.hwpf.model
 class OldPAPBinTable
This class holds all of the paragraph formatting properties from Old (Word 6 / Word 95) documents.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PAPFormattedDiskPage

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PAPFormattedDiskPage

No usage of org.apache.poi.hwpf.model.PAPFormattedDiskPage

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PAPX

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PAPX

Packages that use PAPX
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of PAPX in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model with type parameters of type PAPX
protected  java.util.ArrayList<PAPX> PAPBinTable._paragraphs

Methods in org.apache.poi.hwpf.model that return PAPX
 PAPX PAPFormattedDiskPage.getPAPX(int index)
Gets the PAPX at index.

Methods in org.apache.poi.hwpf.model that return types with arguments of type PAPX
java.util.List<PAPX> | PAPFormattedDiskPage.getPAPXs()
java.util.ArrayList<PAPX> | PAPBinTable.getParagraphs()

Method parameters in org.apache.poi.hwpf.model with type arguments of type PAPX
 void PAPFormattedDiskPage.fill(java.util.List<PAPX> filler)
Fills the queue for writing.

Uses of PAPX in org.apache.poi.hwpf.usermodel

Fields in org.apache.poi.hwpf.usermodel with type parameters of type PAPX
protected  java.util.List<PAPX> Range._paragraphs
All paragraphs that belong to the document this Range belongs to.

Methods in org.apache.poi.hwpf.usermodel with parameters of type PAPX
protected static ParagraphProperties Paragraph.newParagraph_applyStyleProperties(StyleSheet styleSheet, PAPX papx, ParagraphProperties properties)

Constructors in org.apache.poi.hwpf.usermodel with parameters of type PAPX
Paragraph(PAPX papx, Range parent)
Deprecated.
Paragraph(PAPX papx, Range parent, int start)
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ParagraphHeight

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ParagraphHeight

Packages that use ParagraphHeight
org.apache.poi.hwpf.model

Uses of ParagraphHeight in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return ParagraphHeight
 ParagraphHeight PAPX.getParagraphHeight()

Constructors in org.apache.poi.hwpf.model with parameters of type ParagraphHeight
PAPX(int charStart, int charEnd, byte[] papx, ParagraphHeight phe, byte[] dataStream)
PAPX(int fcStart, int fcEnd, CharIndexTranslator translator, byte[] papx, ParagraphHeight phe, byte[] dataStream)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PICF

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PICF

Packages that use PICF
org.apache.poi.hwpf.model

Uses of PICF in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return PICF
 PICF PICFAndOfficeArtData.getPicf()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PICFAndOfficeArtData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PICFAndOfficeArtData

No usage of org.apache.poi.hwpf.model.PICFAndOfficeArtData

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PicturesTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PicturesTable

Packages that use PicturesTable
org.apache.poi.hwpf

Uses of PicturesTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as PicturesTable
protected  PicturesTable HWPFDocument._pictures
Holds pictures table

Methods in org.apache.poi.hwpf that return PicturesTable
 PicturesTable HWPFDocument.getPicturesTable()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PieceDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PieceDescriptor

Packages that use PieceDescriptor
org.apache.poi.hwpf.model

Uses of PieceDescriptor in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return PieceDescriptor
 PieceDescriptor TextPiece.getPieceDescriptor()

Constructors in org.apache.poi.hwpf.model with parameters of type PieceDescriptor
TextPiece(int start, int end, byte[] text, PieceDescriptor pd)
TextPiece(int start, int end, byte[] text, PieceDescriptor pd, int cpStart)
Deprecated. Use TextPiece.TextPiece(int,int,byte[],PieceDescriptor) instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PlexOfCps

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PlexOfCps

Packages that use PlexOfCps
org.apache.poi.hwpf.usermodel

Uses of PlexOfCps in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return PlexOfCps
protected  PlexOfCps HeaderStories.getPlcfHdd()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PlexOfField

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PlexOfField

Packages that use PlexOfField
org.apache.poi.hwpf.model

Uses of PlexOfField in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return types with arguments of type PlexOfField
java.util.ArrayList<PlexOfField> | FieldsTables.getFieldsPLCF(FieldsDocumentPart part)
java.util.ArrayList<PlexOfField> | FieldsTables.getFieldsPLCF(int partIndex) Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PropertyModifier

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PropertyModifier

Packages that use PropertyModifier
org.apache.poi.hwpf.model

Uses of PropertyModifier in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return PropertyModifier
protected PropertyModifier | PropertyModifier.clone()
PropertyModifier | PieceDescriptor.getPrm()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PropertyNode.EndComparator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PropertyNode.EndComparator

Packages that use PropertyNode.EndComparator
org.apache.poi.hwpf.model

Uses of PropertyNode.EndComparator in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model declared as PropertyNode.EndComparator
static PropertyNode.EndComparator PropertyNode.EndComparator.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PropertyNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PropertyNode

Packages that use PropertyNode
org.apache.poi.hwpf.model

Uses of PropertyNode in org.apache.poi.hwpf.model

Classes in org.apache.poi.hwpf.model with type parameters of type PropertyNode
 class PropertyNode<T extends PropertyNode<T>>
Represents a lightweight node in the Trees used to store content properties.

Subclasses of PropertyNode in org.apache.poi.hwpf.model
class | BytePropertyNode<T extends BytePropertyNode<T>> Deprecated. byte positions shall not be saved in memory
class | CachedPropertyNode
class | CHPX DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
class | GenericPropertyNode
class | PAPX DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
class | SEPX
class | SinglentonTextPiece
class | TextPiece Lightweight representation of a text piece.

Methods in org.apache.poi.hwpf.model with parameters of type PropertyNode
int | PropertyNode.EndComparator.compare(PropertyNode<?> o1, PropertyNode<?> o2)
int | PropertyNode.EndComparator.compare(PropertyNode<?> o1, PropertyNode<?> o2)
int | PropertyNode.StartComparator.compare(PropertyNode<?> o1, PropertyNode<?> o2)
int | PropertyNode.StartComparator.compare(PropertyNode<?> o1, PropertyNode<?> o2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.PropertyNode.StartComparator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.PropertyNode.StartComparator

Packages that use PropertyNode.StartComparator
org.apache.poi.hwpf.model

Uses of PropertyNode.StartComparator in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model declared as PropertyNode.StartComparator
static PropertyNode.StartComparator PropertyNode.StartComparator.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.RevisionMarkAuthorTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.RevisionMarkAuthorTable

Packages that use RevisionMarkAuthorTable
org.apache.poi.hwpf

Uses of RevisionMarkAuthorTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as RevisionMarkAuthorTable
protected  RevisionMarkAuthorTable HWPFDocument._rmat
Holds the revision mark authors for this document.

Methods in org.apache.poi.hwpf that return RevisionMarkAuthorTable
 RevisionMarkAuthorTable HWPFDocument.getRevisionMarkAuthorTable()
Gets a reference to the revision mark author table, which holds the revision mark authors for the document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.SavedByEntry

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.SavedByEntry

Packages that use SavedByEntry
org.apache.poi.hwpf.model

Uses of SavedByEntry in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return types with arguments of type SavedByEntry
 java.util.List<SavedByEntry> SavedByTable.getEntries()
Gets the entries.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.SavedByTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.SavedByTable

Packages that use SavedByTable
org.apache.poi.hwpf

Uses of SavedByTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as SavedByTable
protected  SavedByTable HWPFDocument._sbt
Holds the save history for this document.

Methods in org.apache.poi.hwpf that return SavedByTable
 SavedByTable HWPFDocument.getSavedByTable()
Gets a reference to the saved -by table, which holds the save history for the document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.SectionDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.SectionDescriptor

Packages that use SectionDescriptor
org.apache.poi.hwpf.model

Uses of SectionDescriptor in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return SectionDescriptor
 SectionDescriptor SEPX.getSectionDescriptor()

Constructors in org.apache.poi.hwpf.model with parameters of type SectionDescriptor
SEPX(SectionDescriptor sed, int start, int end, byte[] grpprl)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.SectionTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.SectionTable

Packages that use SectionTable
org.apache.poi.hwpf
org.apache.poi.hwpf.model

Uses of SectionTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as SectionTable
protected  SectionTable HWPFDocumentCore._st
Contains formatting properties for sections.

Methods in org.apache.poi.hwpf that return SectionTable
 SectionTable HWPFDocumentCore.getSectionTable()

Uses of SectionTable in org.apache.poi.hwpf.model

Subclasses of SectionTable in org.apache.poi.hwpf.model
 class OldSectionTable
This class holds all of the section formatting properties from Old (Word 6 / Word 95) documents.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.SEPX

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.SEPX

Packages that use SEPX
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of SEPX in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model with type parameters of type SEPX
protected  java.util.ArrayList<SEPX> SectionTable._sections

Methods in org.apache.poi.hwpf.model that return types with arguments of type SEPX
 java.util.ArrayList<SEPX> SectionTable.getSections()

Uses of SEPX in org.apache.poi.hwpf.usermodel

Fields in org.apache.poi.hwpf.usermodel with type parameters of type SEPX
protected  java.util.List<SEPX> Range._sections
All sections that belong to the document this Range belongs to.

Constructors in org.apache.poi.hwpf.usermodel with parameters of type SEPX
Section(SEPX sepx, Range parent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.ShapesTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.ShapesTable

Packages that use ShapesTable
org.apache.poi.hwpf

Uses of ShapesTable in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as ShapesTable
protected  ShapesTable HWPFDocument._officeArts
Deprecated.

Methods in org.apache.poi.hwpf that return ShapesTable
 ShapesTable HWPFDocument.getShapesTable()
Deprecated. use HWPFDocument.getOfficeDrawingsMain() instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.SinglentonTextPiece

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.SinglentonTextPiece

No usage of org.apache.poi.hwpf.model.SinglentonTextPiece

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.StyleDescription

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.StyleDescription

Packages that use StyleDescription
org.apache.poi.hwpf.model

Uses of StyleDescription in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return StyleDescription
 StyleDescription StyleSheet.getStyleDescription(int styleIndex)
Gets the StyleDescription at index x.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.StyleSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.StyleSheet

Packages that use StyleSheet
org.apache.poi.hwpf
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of StyleSheet in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as StyleSheet
protected  StyleSheet HWPFDocumentCore._ss
Holds styles for this document.

Methods in org.apache.poi.hwpf that return StyleSheet
 StyleSheet HWPFDocumentCore.getStyleSheet()

Uses of StyleSheet in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model with parameters of type StyleSheet
CharacterProperties | CHPX.getCharacterProperties(StyleSheet ss, short istd)
ParagraphProperties | PAPX.getParagraphProperties(StyleSheet ss) Deprecated.

Uses of StyleSheet in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel with parameters of type StyleSheet
protected static ParagraphProperties Paragraph.newParagraph_applyStyleProperties(StyleSheet styleSheet, PAPX papx, ParagraphProperties properties)

Constructors in org.apache.poi.hwpf.usermodel with parameters of type StyleSheet
HWPFList(boolean numbered, StyleSheet styleSheet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.SubdocumentType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.SubdocumentType

Packages that use SubdocumentType
org.apache.poi.hwpf.model

Uses of SubdocumentType in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model declared as SubdocumentType
static SubdocumentType[] SubdocumentType.ORDERED
Array of SubdocumentTypes ordered by document position and FIB field order

Methods in org.apache.poi.hwpf.model that return SubdocumentType
static SubdocumentType | SubdocumentType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static SubdocumentType[] | SubdocumentType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.hwpf.model with parameters of type SubdocumentType
int | FileInformationBlock.getSubdocumentTextStreamLength(SubdocumentType type)
void | FileInformationBlock.setSubdocumentTextStreamLength(SubdocumentType type, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.TabDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.TabDescriptor

Packages that use TabDescriptor
org.apache.poi.hwpf.model.types

Uses of TabDescriptor in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as TabDescriptor
protected  TabDescriptor[] PAPAbstractType.field_74_rgtbd

Methods in org.apache.poi.hwpf.model.types that return TabDescriptor
 TabDescriptor[] PAPAbstractType.getRgtbd()
Array of itbdMac tab descriptors.

Methods in org.apache.poi.hwpf.model.types with parameters of type TabDescriptor
 void PAPAbstractType.setRgtbd(TabDescriptor[] field_74_rgtbd)
Array of itbdMac tab descriptors.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.TextPiece

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.TextPiece

Packages that use TextPiece
org.apache.poi.hwpf.model

Uses of TextPiece in org.apache.poi.hwpf.model

Subclasses of TextPiece in org.apache.poi.hwpf.model
 class SinglentonTextPiece

Fields in org.apache.poi.hwpf.model with type parameters of type TextPiece
protected java.util.List<TextPiece> | SectionTable._text
protected java.util.ArrayList<TextPiece> | TextPieceTable._textPieces
protected java.util.ArrayList<TextPiece> | TextPieceTable._textPiecesFCOrder

Methods in org.apache.poi.hwpf.model that return types with arguments of type TextPiece
 java.util.List<TextPiece> TextPieceTable.getTextPieces()

Methods in org.apache.poi.hwpf.model with parameters of type TextPiece
 void TextPieceTable.add(TextPiece piece)

Constructor parameters in org.apache.poi.hwpf.model with type arguments of type TextPiece
FSPATable(byte[] tableStream, int fcPlcspa, int lcbPlcspa, java.util.List<TextPiece> tpt)
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.TextPieceTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.TextPieceTable

Packages that use TextPieceTable
org.apache.poi.hwpf
org.apache.poi.hwpf.model

Uses of TextPieceTable in org.apache.poi.hwpf

Methods in org.apache.poi.hwpf that return TextPieceTable
TextPieceTable | HWPFOldDocument.getTextTable()
abstract TextPieceTable | HWPFDocumentCore.getTextTable()
TextPieceTable | HWPFDocument.getTextTable()

Uses of TextPieceTable in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model declared as TextPieceTable
protected  TextPieceTable ComplexFileTable._tpt

Methods in org.apache.poi.hwpf.model that return TextPieceTable
 TextPieceTable ComplexFileTable.getTextPieceTable()

Constructors in org.apache.poi.hwpf.model with parameters of type TextPieceTable
CHPBinTable(byte[] documentStream, byte[] tableStream, int offset, int size, int fcMin, TextPieceTable tpt)
Deprecated. Use CHPBinTable.CHPBinTable(byte[], byte[], int, int, CharIndexTranslator) instead
CHPFormattedDiskPage(byte[] documentStream, int offset, int fcMin, TextPieceTable tpt)
Deprecated. Use CHPFormattedDiskPage.CHPFormattedDiskPage(byte[], int, CharIndexTranslator) instead
OldCHPBinTable(byte[] documentStream, int offset, int size, int fcMin, TextPieceTable tpt)
Constructor used to read an old-style binTable in from a Word document.
OldPAPBinTable(byte[] documentStream, int offset, int size, int fcMin, TextPieceTable tpt)
OldSectionTable(byte[] documentStream, int offset, int size, int fcMin, TextPieceTable tpt)
Deprecated. Use OldSectionTable.OldSectionTable(byte[],int,int) instead
PAPBinTable(byte[] documentStream, byte[] tableStream, byte[] dataStream, int offset, int size, int fcMin, TextPieceTable tpt)
Deprecated. Use PAPBinTable.PAPBinTable(byte[], byte[], byte[], int, int, CharIndexTranslator) instead
PAPFormattedDiskPage(byte[] documentStream, byte[] dataStream, int offset, int fcMin, TextPieceTable tpt)
Deprecated. Use PAPFormattedDiskPage.PAPFormattedDiskPage(byte[], byte[], int, CharIndexTranslator) instead
SectionTable(byte[] documentStream, byte[] tableStream, int offset, int size, int fcMin, TextPieceTable tpt, int mainLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.UnhandledDataStructure

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.UnhandledDataStructure

No usage of org.apache.poi.hwpf.model.UnhandledDataStructure

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.UPX

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.UPX

No usage of org.apache.poi.hwpf.model.UPX

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HWPFFileSystem

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.io
Class HWPFFileSystem

java.lang.Object
    extended by  org.apache.poi.hwpf.model.io.HWPFFileSystem

@Internal
public final class HWPFFileSystem
extends java.lang.Object

Constructor Summary
HWPFFileSystem()
Method Summary
 HWPFOutputStream getStream(java.lang.String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HWPFFileSystem

public HWPFFileSystem()
Method Detail

getStream

public HWPFOutputStream getStream(java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HWPFOutputStream

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.io
Class HWPFOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  java.io.ByteArrayOutputStream
            extended by  org.apache.poi.hwpf.model.io.HWPFOutputStream
All Implemented Interfaces:
java.io.Closeable, java.io.Flushable
@Internal
public final class HWPFOutputStream
extends java.io.ByteArrayOutputStream

Field Summary
Fields inherited from class java.io.ByteArrayOutputStream
buf, count
Constructor Summary
HWPFOutputStream()
Method Summary
int | getOffset()
void | reset()
void | write(byte[] buf, int off, int len)
void | write(int b)
Methods inherited from class java.io.ByteArrayOutputStream
close, size, toByteArray, toString, toString, toString, writeTo
Methods inherited from class java.io.OutputStream
flush, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HWPFOutputStream

public HWPFOutputStream()
Method Detail

getOffset

public int getOffset()

reset

public void reset()
Overrides:
reset in class java.io.ByteArrayOutputStream

write

public void write(byte[] buf,
                  int off,
                  int len)
Overrides:
write in class java.io.ByteArrayOutputStream

write

public void write(int b)
Overrides:
write in class java.io.ByteArrayOutputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf.model.io
Classes
HWPFFileSystem
HWPFOutputStream


org.apache.poi.hwpf.model.io

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.model.io

Class Summary
HWPFFileSystem
HWPFOutputStream


org.apache.poi.hwpf.model.io Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.model.io

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hwpf.model.io.HWPFFileSystem
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
        • org.apache.poi.hwpf.model.io.HWPFOutputStream


Uses of Package org.apache.poi.hwpf.model.io

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.model.io

Packages that use org.apache.poi.hwpf.model.io
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.io

Classes in org.apache.poi.hwpf.model.io used by org.apache.poi.hwpf.model
HWPFFileSystem
HWPFOutputStream

Classes in org.apache.poi.hwpf.model.io used by org.apache.poi.hwpf.model.io
HWPFOutputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.io.HWPFFileSystem

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.io.HWPFFileSystem

Packages that use HWPFFileSystem
org.apache.poi.hwpf.model

Uses of HWPFFileSystem in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model with parameters of type HWPFFileSystem
void | FontTable.writeTo(HWPFFileSystem sys) Deprecated.
void | ComplexFileTable.writeTo(HWPFFileSystem sys) Deprecated.
void | PAPBinTable.writeTo(HWPFFileSystem sys, CharIndexTranslator translator) Deprecated.
void | SectionTable.writeTo(HWPFFileSystem sys, int fcMin) Deprecated.
void | CHPBinTable.writeTo(HWPFFileSystem sys, int fcMin, CharIndexTranslator translator) Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.io.HWPFOutputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.io.HWPFOutputStream

Packages that use HWPFOutputStream
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.io

Uses of HWPFOutputStream in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model with parameters of type HWPFOutputStream
protected byte[] | PAPFormattedDiskPage.toByteArray(HWPFOutputStream dataStream, CharIndexTranslator translator) Creates a byte array representation of this data structure.
void | FieldsTables.write(FileInformationBlock fib, HWPFOutputStream tableStream)
void | ListTables.writeListDataTo(FileInformationBlock fib, HWPFOutputStream tableStream)
void | ListTables.writeListOverridesTo(HWPFOutputStream tableStream)
void | BookmarksTables.writePlcfBkmkf(FileInformationBlock fib, HWPFOutputStream tableStream)
void | BookmarksTables.writePlcfBkmkl(FileInformationBlock fib, HWPFOutputStream tableStream)
void | NotesTables.writeRef(FileInformationBlock fib, HWPFOutputStream tableStream)
void | BookmarksTables.writeSttbfBkmk(FileInformationBlock fib, HWPFOutputStream tableStream)
void | FileInformationBlock.writeTo(byte[] mainStream, HWPFOutputStream tableStream)
byte[] | TextPieceTable.writeTo(HWPFOutputStream docStream)
void | StyleSheet.writeTo(HWPFOutputStream out)
void | SavedByTable.writeTo(HWPFOutputStream tableStream) Writes this table to the table stream.
void | RevisionMarkAuthorTable.writeTo(HWPFOutputStream tableStream) Writes this table to the table stream.
void | FontTable.writeTo(HWPFOutputStream tableStream)
void | DocumentProperties.writeTo(HWPFOutputStream tableStream)
void | SectionTable.writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream)
void | ComplexFileTable.writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream)
void | PAPBinTable.writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream, CharIndexTranslator translator)
void | CHPBinTable.writeTo(HWPFOutputStream wordDocumentStream, HWPFOutputStream tableStream, int fcMin, CharIndexTranslator translator)
void | NotesTables.writeTxt(FileInformationBlock fib, HWPFOutputStream tableStream)

Uses of HWPFOutputStream in org.apache.poi.hwpf.model.io

Methods in org.apache.poi.hwpf.model.io that return HWPFOutputStream
 HWPFOutputStream HWPFFileSystem.getStream(java.lang.String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BKFAbstractType

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class BKFAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.BKFAbstractType
Direct Known Subclasses:
BookmarkFirstDescriptor
@Internal
public abstract class BKFAbstractType
extends java.lang.Object

BooKmark First descriptor (BKF).

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format (.doc) Specification NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format (.doc) Specification

Field Summary
protected short | field_1_ibkl
protected short | field_2_bkf_flags
Constructor Summary
protected BKFAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
short | getBkf_flags() Get the bkf_flags field for the BKF record.
short | getIbkl() Index to BKL entry in plcfbkl that describes the ending position of this bookmark in the CP stream.
byte | getItcFirst() When bkf.fCol==1, this is the index to the first column of a table column bookmark
byte | getItcLim() When bkf.fCol==1, this is the index to limit column of a table column bookmark
static int | getSize() Size of record
boolean | isFCol() When 1, this bookmark marks a range of columns in a table specified by (bkf.itcFirst, bkf.itcLim)
boolean | isFPub() When 1, this indicates that this bookmark is marking the range of a Macintosh Publisher section
void | serialize(byte[] data, int offset)
void | setBkf_flags(short field_2_bkf_flags) Set the bkf_flags field for the BKF record.
void | setFCol(boolean value) Sets the fCol field value.
void | setFPub(boolean value) Sets the fPub field value.
void | setIbkl(short field_1_ibkl) Index to BKL entry in plcfbkl that describes the ending position of this bookmark in the CP stream.
void | setItcFirst(byte value) Sets the itcFirst field value.
void | setItcLim(byte value) Sets the itcLim field value.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_ibkl

protected short field_1_ibkl

field_2_bkf_flags

protected short field_2_bkf_flags
Constructor Detail

BKFAbstractType

protected BKFAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getIbkl

public short getIbkl()
Index to BKL entry in plcfbkl that describes the ending position of this bookmark in the CP stream.

setIbkl

public void setIbkl(short field_1_ibkl)
Index to BKL entry in plcfbkl that describes the ending position of this bookmark in the CP stream.

getBkf_flags

public short getBkf_flags()
Get the bkf_flags field for the BKF record.

setBkf_flags

public void setBkf_flags(short field_2_bkf_flags)
Set the bkf_flags field for the BKF record.

setItcFirst

public void setItcFirst(byte value)
Sets the itcFirst field value. When bkf.fCol==1, this is the index to the first column of a table column bookmark

getItcFirst

public byte getItcFirst()
When bkf.fCol==1, this is the index to the first column of a table column bookmark

Returns:
the itcFirst field value.

setFPub

public void setFPub(boolean value)
Sets the fPub field value. When 1, this indicates that this bookmark is marking the range of a Macintosh Publisher section

isFPub

public boolean isFPub()
When 1, this indicates that this bookmark is marking the range of a Macintosh Publisher section

Returns:
the fPub field value.

setItcLim

public void setItcLim(byte value)
Sets the itcLim field value. When bkf.fCol==1, this is the index to limit column of a table column bookmark

getItcLim

public byte getItcLim()
When bkf.fCol==1, this is the index to limit column of a table column bookmark

Returns:
the itcLim field value.

setFCol

public void setFCol(boolean value)
Sets the fCol field value. When 1, this bookmark marks a range of columns in a table specified by (bkf.itcFirst, bkf.itcLim)

isFCol

public boolean isFCol()
When 1, this bookmark marks a range of columns in a table specified by (bkf.itcFirst, bkf.itcLim)

Returns:
the fCol field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CHPAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class CHPAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.CHPAbstractType
Direct Known Subclasses:
CharacterProperties
@Internal
public abstract class CHPAbstractType
extends java.lang.Object

Character Properties. NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/records/definitions.

Author:
S. Ryan Ackley

Field Summary
protected int | field_1_grpfChp
protected int | field_10_pctCharWidth
protected int | field_11_lidDefault
protected int | field_12_lidFE
protected byte | field_13_kcd
protected boolean | field_14_fUndetermine
protected byte | field_15_iss
protected boolean | field_16_fSpecSymbol
protected byte | field_17_idct
protected byte | field_18_idctHint
protected byte | field_19_kul
protected int | field_2_hps
protected Hyphenation | field_20_hresi
protected int | field_21_hpsKern
protected short | field_22_hpsPos
protected ShadingDescriptor | field_23_shd
protected BorderCode | field_24_brc
protected int | field_25_ibstRMark
protected byte | field_26_sfxtText
protected boolean | field_27_fDblBdr
protected boolean | field_28_fBorderWS
protected short | field_29_ufel
protected int | field_3_ftcAscii
protected byte | field_30_copt
protected int | field_31_hpsAsci
protected int | field_32_hpsFE
protected int | field_33_hpsBi
protected int | field_34_ftcSym
protected int | field_35_xchSym
protected int | field_36_fcPic
protected int | field_37_fcObj
protected int | field_38_lTagObj
protected int | field_39_fcData
protected int | field_4_ftcFE
protected Hyphenation | field_40_hresiOld
protected int | field_41_ibstRMarkDel
protected DateAndTime | field_42_dttmRMark
protected DateAndTime | field_43_dttmRMarkDel
protected int | field_44_istd
protected int | field_45_idslRMReason
protected int | field_46_idslReasonDel
protected int | field_47_cpg
protected short | field_48_Highlight
protected short | field_49_CharsetFlags
protected int | field_5_ftcOther
protected short | field_50_chse
protected boolean | field_51_fPropRMark
protected int | field_52_ibstPropRMark
protected DateAndTime | field_53_dttmPropRMark
protected boolean | field_54_fConflictOrig
protected boolean | field_55_fConflictOtherDel
protected int | field_56_wConflict
protected int | field_57_IbstConflict
protected DateAndTime | field_58_dttmConflict
protected boolean | field_59_fDispFldRMark
protected int | field_6_ftcBi
protected int | field_60_ibstDispFldRMark
protected DateAndTime | field_61_dttmDispFldRMark
protected byte[] | field_62_xstDispFldRMark
protected int | field_63_fcObjp
protected byte | field_64_lbrCRJ
protected boolean | field_65_fSpecVanish
protected boolean | field_66_fHasOldProps
protected boolean | field_67_fSdtVanish
protected int | field_68_wCharScale
protected int | field_7_dxaSpace
protected Colorref | field_8_cv
protected byte | field_9_ico
protected static byte | ISS_NONE
protected static byte | ISS_SUBSCRIPTED
protected static byte | ISS_SUPERSCRIPTED
protected static byte | KCD_CIRCLE
protected static byte | KCD_COMMA
protected static byte | KCD_DOT
protected static byte | KCD_NON
protected static byte | KCD_UNDER_DOT
protected static byte | KUL_BY_WORD
protected static byte | KUL_DASH
protected static byte | KUL_DASH_LONG
protected static byte | KUL_DASH_LONG_HEAVY
protected static byte | KUL_DASHED_HEAVY
protected static byte | KUL_DOT
protected static byte | KUL_DOT_DASH
protected static byte | KUL_DOT_DASH_HEAVY
protected static byte | KUL_DOT_DOT_DASH
protected static byte | KUL_DOT_DOT_DASH_HEAVY
protected static byte | KUL_DOTTED
protected static byte | KUL_DOTTED_HEAVY
protected static byte | KUL_DOUBLE
protected static byte | KUL_HIDDEN
protected static byte | KUL_NONE
protected static byte | KUL_SINGLE
protected static byte | KUL_THICK
protected static byte | KUL_WAVE
protected static byte | KUL_WAVE_DOUBLE
protected static byte | KUL_WAVE_HEAVY
protected static byte | LBRCRJ_BOTH
protected static byte | LBRCRJ_LEFT
protected static byte | LBRCRJ_NONE
protected static byte | LBRCRJ_RIGHT
protected static byte | SFXTTEXT_BACKGROUND_BLINK
protected static byte | SFXTTEXT_LAS_VEGAS_LIGHTS
protected static byte | SFXTTEXT_MARCHING_ANTS
protected static byte | SFXTTEXT_MARCHING_RED_ANTS
protected static byte | SFXTTEXT_NO
protected static byte | SFXTTEXT_SHIMMER
protected static byte | SFXTTEXT_SPARKLE_TEXT
Constructor Summary
protected CHPAbstractType()
Method Summary
BorderCode | getBrc() Border.
short | getCharsetFlags() Get the CharsetFlags field for the CHP record.
short | getChse() Get the chse field for the CHP record.
byte | getCopt() Collection of the 5 flags.
int | getCpg() Code page of run in pre-Unicode files.
Colorref | getCv() 24-bit color.
DateAndTime | getDttmConflict() When the change was made.
DateAndTime | getDttmDispFldRMark() The date for the ListNum field number change.
DateAndTime | getDttmPropRMark() Date/time at which properties of this were changed for this run of text by the author.
DateAndTime | getDttmRMark() Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
DateAndTime | getDttmRMarkDel() Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).
int | getDxaSpace() Space following each character in the run expressed in twip units..
boolean | getFBorderWS() Used internally by Word.
int | getFcData() Points to location of picture data, only if chp.fSpec is true..
int | getFcObj() Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..
int | getFcObjp() Offset in the data stream indicating the location of OLE object data.
boolean | getFConflictOrig() When chp.wConflict!=0, this is TRUE when text is part of the original version of text.
boolean | getFConflictOtherDel() When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.
int | getFcPic() Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..
boolean | getFDblBdr() Used internally by Word.
boolean | getFDispFldRMark() the number for a ListNum field is being tracked in xstDispFldRMark.
boolean | getFHasOldProps() Used for character property revision marking.
boolean | getFPropRMark() properties have been changed with revision marking on.
boolean | getFSdtVanish() Mark the character as hidden..
boolean | getFSpecSymbol() Used by Word internally.
boolean | getFSpecVanish() Special hidden for leading emphasis (always hidden).
int | getFtcAscii() Font for ASCII text.
int | getFtcBi() Font for Complex Scripts text.
int | getFtcFE() Font for East Asian text.
int | getFtcOther() Font for non-East Asian text.
int | getFtcSym() an index into the rgffn structure.
boolean | getFUndetermine() Character is undetermined.
int | getGrpfChp() Collection of the 32 flags.
short | getHighlight() Get the Highlight field for the CHP record.
int | getHps() Font size in half points.
int | getHpsAsci() Font size for ASCII font.
int | getHpsBi() Font size for Complex Scripts text.
int | getHpsFE() Font size for East Asian text.
int | getHpsKern() Kerning distance for characters in run recorded in half points.
short | getHpsPos() Reserved (actually used as vertical offset(?) value).
Hyphenation | getHresi() Get the hresi field for the CHP record.
Hyphenation | getHresiOld() Get the hresiOld field for the CHP record.
int | getIbstConflict() Who made this change for this side of the conflict..
int | getIbstDispFldRMark() Index to author IDs stored in hsttbfRMark.
int | getIbstPropRMark() Index to author IDs stored in hsttbfRMark.
int | getIbstRMark() Index to author IDs stored in hsttbfRMark.
int | getIbstRMarkDel() Index to author IDs stored in hsttbfRMark.
byte | getIco() Color of text for Word 97.
byte | getIcoHighlight() Highlight color (see chp.ico)
byte | getIdct() Not stored in file.
byte | getIdctHint() Identifier of Character type.
int | getIdslReasonDel() An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
int | getIdslRMReason() An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
byte | getIss() Superscript/subscript indices.
int | getIstd() Index to character style descriptor in the stylesheet that tags this run of text.
short | getItypFELayout()
byte | getIWarichuBracket() Bracket character for two-lines-in-one
byte | getKcd() Emphasis mark.
byte | getKul() Underline code.
byte | getLbrCRJ() Line BReak code for xchCRJ.
int | getLidDefault() Get the lidDefault field for the CHP record.
int | getLidFE() Get the lidFE field for the CHP record.
int | getLTagObj() An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..
int | getPctCharWidth() Character scale.
byte | getSfxtText() Text animation.
ShadingDescriptor | getShd() Shading.
byte | getSpare() Unused
short | getUfel() Collection properties represented by itypFELayout and copt (East Asian layout properties).
int | getWCharScale() Get the wCharScale field for the CHP record.
int | getWConflict() When != 0, index number that identifies all text participating in a particular conflict incident.
int | getXchSym() When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..
byte[] | getXstDispFldRMark() The string value of the ListNum field when revision mark tracking began.
boolean | isFBiDi() Complex Scripts right-to-left text that requires special processing to display and process (character reordering; contextual shaping; display of combining characters and diacritics; specialized justification rules; cursor positioning)
boolean | isFBold() Text is bold
boolean | isFBoldBi() Complex Scripts text is bold
boolean | isFCaps() Displayed with caps
boolean | isFCellFitText() Fit text in cell
boolean | isFChsDiff() Pre-Unicode files, char's char set different from FIB char set
boolean | isFComplexScripts() Complex Scripts text that requires special processing to display and process
boolean | isFData() chp.fcPic points to an FFDATA, the data structure binary data used by Word to describe a form field.
boolean | isFDStrike() Displayed with double strikethrough
boolean | isFEmboss() Text is embossed
boolean | isFFldVanish() Used internally by Word
boolean | isFHighlight() When 1, characters are highlighted with color specified by chp.icoHighlight
boolean | isFImprint() Text is engraved
boolean | isFItalic() Italic
boolean | isFItalicBi() Complex Scripts text is italics
boolean | isFKumimoji() combine characters
boolean | isFLowerCase() Character is displayed in lower case.
boolean | isFLSFitText() fit text
boolean | isFMacChs() fTrue if char's are Macintosh char set
boolean | isFObj() Embedded objec
boolean | isFOle2() chp.lTagObj specifies a particular object in the object stream that specifies the particular OLE object in the stream that should be displayed when the chPicture fSpec character that is tagged with the fOle2 is encountered.
boolean | isFOutline() Outlined
boolean | isFRMark() text is newly typed since the last time revision marks have been accepted and will be displayed with an underline when revision marked text is to be displayed
boolean | isFRMarkDel() has been deleted and will be displayed with strikethrough when revision marked text is to be displayed
boolean | isFRuby() Phonetic guide
boolean | isFShadow() Character is drawn with a shadow
boolean | isFSmallCaps() Displayed with small caps
boolean | isFSpec() Character is a Word special character
boolean | isFStrike() Displayed with strikethrough
boolean | isFTNY() Tatenakayoko: Horizontal-in-vertical (range of text in a direction perpendicular to the text flow) is used
boolean | isFTNYCompress() fit text in line
boolean | isFTNYFetchTxm() fetch text metrics
boolean | isFUsePgsuSettings() Used internally by Word
boolean | isFVanish() text has hidden format, and is not displayed unless fPagHidden is set in the DOP
boolean | isFWarichu() Two lines in one (text in the group is displayed as two half-height lines within a line)
boolean | isFWarichuNoOpenBracket() Two-lines-in-one uses no open
boolean | isUnused() Not used
void | setBrc(BorderCode field_24_brc) Border.
void | setCharsetFlags(short field_49_CharsetFlags) Set the CharsetFlags field for the CHP record.
void | setChse(short field_50_chse) Set the chse field for the CHP record.
void | setCopt(byte field_30_copt) Collection of the 5 flags.
void | setCpg(int field_47_cpg) Code page of run in pre-Unicode files.
void | setCv(Colorref field_8_cv) 24-bit color.
void | setDttmConflict(DateAndTime field_58_dttmConflict) When the change was made.
void | setDttmDispFldRMark(DateAndTime field_61_dttmDispFldRMark) The date for the ListNum field number change.
void | setDttmPropRMark(DateAndTime field_53_dttmPropRMark) Date/time at which properties of this were changed for this run of text by the author.
void | setDttmRMark(DateAndTime field_42_dttmRMark) Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
void | setDttmRMarkDel(DateAndTime field_43_dttmRMarkDel) Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).
void | setDxaSpace(int field_7_dxaSpace) Space following each character in the run expressed in twip units..
void | setFBiDi(boolean value) Sets the fBiDi field value.
void | setFBold(boolean value) Sets the fBold field value.
void | setFBoldBi(boolean value) Sets the fBoldBi field value.
void | setFBorderWS(boolean field_28_fBorderWS) Used internally by Word.
void | setFCaps(boolean value) Sets the fCaps field value.
void | setFcData(int field_39_fcData) Points to location of picture data, only if chp.fSpec is true..
void | setFCellFitText(boolean value) Sets the fCellFitText field value.
void | setFChsDiff(boolean value) Sets the fChsDiff field value.
void | setFcObj(int field_37_fcObj) Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..
void | setFcObjp(int field_63_fcObjp) Offset in the data stream indicating the location of OLE object data.
void | setFComplexScripts(boolean value) Sets the fComplexScripts field value.
void | setFConflictOrig(boolean field_54_fConflictOrig) When chp.wConflict!=0, this is TRUE when text is part of the original version of text.
void | setFConflictOtherDel(boolean field_55_fConflictOtherDel) When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.
void | setFcPic(int field_36_fcPic) Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..
void | setFData(boolean value) Sets the fData field value.
void | setFDblBdr(boolean field_27_fDblBdr) Used internally by Word.
void | setFDispFldRMark(boolean field_59_fDispFldRMark) the number for a ListNum field is being tracked in xstDispFldRMark.
void | setFDStrike(boolean value) Sets the fDStrike field value.
void | setFEmboss(boolean value) Sets the fEmboss field value.
void | setFFldVanish(boolean value) Sets the fFldVanish field value.
void | setFHasOldProps(boolean field_66_fHasOldProps) Used for character property revision marking.
void | setFHighlight(boolean value) Sets the fHighlight field value.
void | setFImprint(boolean value) Sets the fImprint field value.
void | setFItalic(boolean value) Sets the fItalic field value.
void | setFItalicBi(boolean value) Sets the fItalicBi field value.
void | setFKumimoji(boolean value) Sets the fKumimoji field value.
void | setFLowerCase(boolean value) Sets the fLowerCase field value.
void | setFLSFitText(boolean value) Sets the fLSFitText field value.
void | setFMacChs(boolean value) Sets the fMacChs field value.
void | setFObj(boolean value) Sets the fObj field value.
void | setFOle2(boolean value) Sets the fOle2 field value.
void | setFOutline(boolean value) Sets the fOutline field value.
void | setFPropRMark(boolean field_51_fPropRMark) properties have been changed with revision marking on.
void | setFRMark(boolean value) Sets the fRMark field value.
void | setFRMarkDel(boolean value) Sets the fRMarkDel field value.
void | setFRuby(boolean value) Sets the fRuby field value.
void | setFSdtVanish(boolean field_67_fSdtVanish) Mark the character as hidden..
void | setFShadow(boolean value) Sets the fShadow field value.
void | setFSmallCaps(boolean value) Sets the fSmallCaps field value.
void | setFSpec(boolean value) Sets the fSpec field value.
void | setFSpecSymbol(boolean field_16_fSpecSymbol) Used by Word internally.
void | setFSpecVanish(boolean field_65_fSpecVanish) Special hidden for leading emphasis (always hidden).
void | setFStrike(boolean value) Sets the fStrike field value.
void | setFtcAscii(int field_3_ftcAscii) Font for ASCII text.
void | setFtcBi(int field_6_ftcBi) Font for Complex Scripts text.
void | setFtcFE(int field_4_ftcFE) Font for East Asian text.
void | setFtcOther(int field_5_ftcOther) Font for non-East Asian text.
void | setFtcSym(int field_34_ftcSym) an index into the rgffn structure.
void | setFTNY(boolean value) Sets the fTNY field value.
void | setFTNYCompress(boolean value) Sets the fTNYCompress field value.
void | setFTNYFetchTxm(boolean value) Sets the fTNYFetchTxm field value.
void | setFUndetermine(boolean field_14_fUndetermine) Character is undetermined.
void | setFUsePgsuSettings(boolean value) Sets the fUsePgsuSettings field value.
void | setFVanish(boolean value) Sets the fVanish field value.
void | setFWarichu(boolean value) Sets the fWarichu field value.
void | setFWarichuNoOpenBracket(boolean value) Sets the fWarichuNoOpenBracket field value.
void | setGrpfChp(int field_1_grpfChp) Collection of the 32 flags.
void | setHighlight(short field_48_Highlight) Set the Highlight field for the CHP record.
void | setHps(int field_2_hps) Font size in half points.
void | setHpsAsci(int field_31_hpsAsci) Font size for ASCII font.
void | setHpsBi(int field_33_hpsBi) Font size for Complex Scripts text.
void | setHpsFE(int field_32_hpsFE) Font size for East Asian text.
void | setHpsKern(int field_21_hpsKern) Kerning distance for characters in run recorded in half points.
void | setHpsPos(short field_22_hpsPos) Reserved (actually used as vertical offset(?) value).
void | setHresi(Hyphenation field_20_hresi) Set the hresi field for the CHP record.
void | setHresiOld(Hyphenation field_40_hresiOld) Set the hresiOld field for the CHP record.
void | setIbstConflict(int field_57_IbstConflict) Who made this change for this side of the conflict..
void | setIbstDispFldRMark(int field_60_ibstDispFldRMark) Index to author IDs stored in hsttbfRMark.
void | setIbstPropRMark(int field_52_ibstPropRMark) Index to author IDs stored in hsttbfRMark.
void | setIbstRMark(int field_25_ibstRMark) Index to author IDs stored in hsttbfRMark.
void | setIbstRMarkDel(int field_41_ibstRMarkDel) Index to author IDs stored in hsttbfRMark.
void | setIco(byte field_9_ico) Color of text for Word 97.
void | setIcoHighlight(byte value) Sets the icoHighlight field value.
void | setIdct(byte field_17_idct) Not stored in file.
void | setIdctHint(byte field_18_idctHint) Identifier of Character type.
void | setIdslReasonDel(int field_46_idslReasonDel) An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
void | setIdslRMReason(int field_45_idslRMReason) An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
void | setIss(byte field_15_iss) Superscript/subscript indices.
void | setIstd(int field_44_istd) Index to character style descriptor in the stylesheet that tags this run of text.
void | setItypFELayout(short value) Sets the itypFELayout field value.
void | setIWarichuBracket(byte value) Sets the iWarichuBracket field value.
void | setKcd(byte field_13_kcd) Emphasis mark.
void | setKul(byte field_19_kul) Underline code.
void | setLbrCRJ(byte field_64_lbrCRJ) Line BReak code for xchCRJ.
void | setLidDefault(int field_11_lidDefault) Set the lidDefault field for the CHP record.
void | setLidFE(int field_12_lidFE) Set the lidFE field for the CHP record.
void | setLTagObj(int field_38_lTagObj) An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..
void | setPctCharWidth(int field_10_pctCharWidth) Character scale.
void | setSfxtText(byte field_26_sfxtText) Text animation.
void | setShd(ShadingDescriptor field_23_shd) Shading.
void | setSpare(byte value) Sets the spare field value.
void | setUfel(short field_29_ufel) Collection properties represented by itypFELayout and copt (East Asian layout properties).
void | setUnused(boolean value) Sets the unused field value.
void | setWCharScale(int field_68_wCharScale) Set the wCharScale field for the CHP record.
void | setWConflict(int field_56_wConflict) When != 0, index number that identifies all text participating in a particular conflict incident.
void | setXchSym(int field_35_xchSym) When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..
void | setXstDispFldRMark(byte[] field_62_xstDispFldRMark) The string value of the ListNum field when revision mark tracking began.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_grpfChp

protected int field_1_grpfChp

field_2_hps

protected int field_2_hps

field_3_ftcAscii

protected int field_3_ftcAscii

field_4_ftcFE

protected int field_4_ftcFE

field_5_ftcOther

protected int field_5_ftcOther

field_6_ftcBi

protected int field_6_ftcBi

field_7_dxaSpace

protected int field_7_dxaSpace

field_8_cv

protected Colorref field_8_cv

field_9_ico

protected byte field_9_ico

field_10_pctCharWidth

protected int field_10_pctCharWidth

field_11_lidDefault

protected int field_11_lidDefault

field_12_lidFE

protected int field_12_lidFE

field_13_kcd

protected byte field_13_kcd

KCD_NON

protected static final byte KCD_NON
See Also:
Constant Field Values

KCD_DOT

protected static final byte KCD_DOT
See Also:
Constant Field Values

KCD_COMMA

protected static final byte KCD_COMMA
See Also:
Constant Field Values

KCD_CIRCLE

protected static final byte KCD_CIRCLE
See Also:
Constant Field Values

KCD_UNDER_DOT

protected static final byte KCD_UNDER_DOT
See Also:
Constant Field Values

field_14_fUndetermine

protected boolean field_14_fUndetermine

field_15_iss

protected byte field_15_iss

ISS_NONE

protected static final byte ISS_NONE
See Also:
Constant Field Values

ISS_SUPERSCRIPTED

protected static final byte ISS_SUPERSCRIPTED
See Also:
Constant Field Values

ISS_SUBSCRIPTED

protected static final byte ISS_SUBSCRIPTED
See Also:
Constant Field Values

field_16_fSpecSymbol

protected boolean field_16_fSpecSymbol

field_17_idct

protected byte field_17_idct

field_18_idctHint

protected byte field_18_idctHint

field_19_kul

protected byte field_19_kul

KUL_NONE

protected static final byte KUL_NONE
See Also:
Constant Field Values

KUL_SINGLE

protected static final byte KUL_SINGLE
See Also:
Constant Field Values

KUL_BY_WORD

protected static final byte KUL_BY_WORD
See Also:
Constant Field Values

KUL_DOUBLE

protected static final byte KUL_DOUBLE
See Also:
Constant Field Values

KUL_DOTTED

protected static final byte KUL_DOTTED
See Also:
Constant Field Values

KUL_HIDDEN

protected static final byte KUL_HIDDEN
See Also:
Constant Field Values

KUL_THICK

protected static final byte KUL_THICK
See Also:
Constant Field Values

KUL_DASH

protected static final byte KUL_DASH
See Also:
Constant Field Values

KUL_DOT

protected static final byte KUL_DOT
See Also:
Constant Field Values

KUL_DOT_DASH

protected static final byte KUL_DOT_DASH
See Also:
Constant Field Values

KUL_DOT_DOT_DASH

protected static final byte KUL_DOT_DOT_DASH
See Also:
Constant Field Values

KUL_WAVE

protected static final byte KUL_WAVE
See Also:
Constant Field Values

KUL_DOTTED_HEAVY

protected static final byte KUL_DOTTED_HEAVY
See Also:
Constant Field Values

KUL_DASHED_HEAVY

protected static final byte KUL_DASHED_HEAVY
See Also:
Constant Field Values

KUL_DOT_DASH_HEAVY

protected static final byte KUL_DOT_DASH_HEAVY
See Also:
Constant Field Values

KUL_DOT_DOT_DASH_HEAVY

protected static final byte KUL_DOT_DOT_DASH_HEAVY
See Also:
Constant Field Values

KUL_WAVE_HEAVY

protected static final byte KUL_WAVE_HEAVY
See Also:
Constant Field Values

KUL_DASH_LONG

protected static final byte KUL_DASH_LONG
See Also:
Constant Field Values

KUL_WAVE_DOUBLE

protected static final byte KUL_WAVE_DOUBLE
See Also:
Constant Field Values

KUL_DASH_LONG_HEAVY

protected static final byte KUL_DASH_LONG_HEAVY
See Also:
Constant Field Values

field_20_hresi

protected Hyphenation field_20_hresi

field_21_hpsKern

protected int field_21_hpsKern

field_22_hpsPos

protected short field_22_hpsPos

field_23_shd

protected ShadingDescriptor field_23_shd

field_24_brc

protected BorderCode field_24_brc

field_25_ibstRMark

protected int field_25_ibstRMark

field_26_sfxtText

protected byte field_26_sfxtText

SFXTTEXT_NO

protected static final byte SFXTTEXT_NO
See Also:
Constant Field Values

SFXTTEXT_LAS_VEGAS_LIGHTS

protected static final byte SFXTTEXT_LAS_VEGAS_LIGHTS
See Also:
Constant Field Values

SFXTTEXT_BACKGROUND_BLINK

protected static final byte SFXTTEXT_BACKGROUND_BLINK
See Also:
Constant Field Values

SFXTTEXT_SPARKLE_TEXT

protected static final byte SFXTTEXT_SPARKLE_TEXT
See Also:
Constant Field Values

SFXTTEXT_MARCHING_ANTS

protected static final byte SFXTTEXT_MARCHING_ANTS
See Also:
Constant Field Values

SFXTTEXT_MARCHING_RED_ANTS

protected static final byte SFXTTEXT_MARCHING_RED_ANTS
See Also:
Constant Field Values

SFXTTEXT_SHIMMER

protected static final byte SFXTTEXT_SHIMMER
See Also:
Constant Field Values

field_27_fDblBdr

protected boolean field_27_fDblBdr

field_28_fBorderWS

protected boolean field_28_fBorderWS

field_29_ufel

protected short field_29_ufel

field_30_copt

protected byte field_30_copt

field_31_hpsAsci

protected int field_31_hpsAsci

field_32_hpsFE

protected int field_32_hpsFE

field_33_hpsBi

protected int field_33_hpsBi

field_34_ftcSym

protected int field_34_ftcSym

field_35_xchSym

protected int field_35_xchSym

field_36_fcPic

protected int field_36_fcPic

field_37_fcObj

protected int field_37_fcObj

field_38_lTagObj

protected int field_38_lTagObj

field_39_fcData

protected int field_39_fcData

field_40_hresiOld

protected Hyphenation field_40_hresiOld

field_41_ibstRMarkDel

protected int field_41_ibstRMarkDel

field_42_dttmRMark

protected DateAndTime field_42_dttmRMark

field_43_dttmRMarkDel

protected DateAndTime field_43_dttmRMarkDel

field_44_istd

protected int field_44_istd

field_45_idslRMReason

protected int field_45_idslRMReason

field_46_idslReasonDel

protected int field_46_idslReasonDel

field_47_cpg

protected int field_47_cpg

field_48_Highlight

protected short field_48_Highlight

field_49_CharsetFlags

protected short field_49_CharsetFlags

field_50_chse

protected short field_50_chse

field_51_fPropRMark

protected boolean field_51_fPropRMark

field_52_ibstPropRMark

protected int field_52_ibstPropRMark

field_53_dttmPropRMark

protected DateAndTime field_53_dttmPropRMark

field_54_fConflictOrig

protected boolean field_54_fConflictOrig

field_55_fConflictOtherDel

protected boolean field_55_fConflictOtherDel

field_56_wConflict

protected int field_56_wConflict

field_57_IbstConflict

protected int field_57_IbstConflict

field_58_dttmConflict

protected DateAndTime field_58_dttmConflict

field_59_fDispFldRMark

protected boolean field_59_fDispFldRMark

field_60_ibstDispFldRMark

protected int field_60_ibstDispFldRMark

field_61_dttmDispFldRMark

protected DateAndTime field_61_dttmDispFldRMark

field_62_xstDispFldRMark

protected byte[] field_62_xstDispFldRMark

field_63_fcObjp

protected int field_63_fcObjp

field_64_lbrCRJ

protected byte field_64_lbrCRJ

LBRCRJ_NONE

protected static final byte LBRCRJ_NONE
See Also:
Constant Field Values

LBRCRJ_LEFT

protected static final byte LBRCRJ_LEFT
See Also:
Constant Field Values

LBRCRJ_RIGHT

protected static final byte LBRCRJ_RIGHT
See Also:
Constant Field Values

LBRCRJ_BOTH

protected static final byte LBRCRJ_BOTH
See Also:
Constant Field Values

field_65_fSpecVanish

protected boolean field_65_fSpecVanish

field_66_fHasOldProps

protected boolean field_66_fHasOldProps

field_67_fSdtVanish

protected boolean field_67_fSdtVanish

field_68_wCharScale

protected int field_68_wCharScale
Constructor Detail

CHPAbstractType

protected CHPAbstractType()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getGrpfChp

@Internal
public int getGrpfChp()
Collection of the 32 flags.

setGrpfChp

@Internal
public void setGrpfChp(int field_1_grpfChp)
Collection of the 32 flags.

getHps

@Internal
public int getHps()
Font size in half points.

setHps

@Internal
public void setHps(int field_2_hps)
Font size in half points.

getFtcAscii

@Internal
public int getFtcAscii()
Font for ASCII text.

setFtcAscii

@Internal
public void setFtcAscii(int field_3_ftcAscii)
Font for ASCII text.

getFtcFE

@Internal
public int getFtcFE()
Font for East Asian text.

setFtcFE

@Internal
public void setFtcFE(int field_4_ftcFE)
Font for East Asian text.

getFtcOther

@Internal
public int getFtcOther()
Font for non-East Asian text.

setFtcOther

@Internal
public void setFtcOther(int field_5_ftcOther)
Font for non-East Asian text.

getFtcBi

@Internal
public int getFtcBi()
Font for Complex Scripts text.

setFtcBi

@Internal
public void setFtcBi(int field_6_ftcBi)
Font for Complex Scripts text.

getDxaSpace

@Internal
public int getDxaSpace()
Space following each character in the run expressed in twip units..

setDxaSpace

@Internal
public void setDxaSpace(int field_7_dxaSpace)
Space following each character in the run expressed in twip units..

getCv

@Internal
public Colorref getCv()
24-bit color.

setCv

@Internal
public void setCv(Colorref field_8_cv)
24-bit color.

getIco

@Internal
public byte getIco()
Color of text for Word 97.

setIco

@Internal
public void setIco(byte field_9_ico)
Color of text for Word 97.

getPctCharWidth

@Internal
public int getPctCharWidth()
Character scale.

setPctCharWidth

@Internal
public void setPctCharWidth(int field_10_pctCharWidth)
Character scale.

getLidDefault

@Internal
public int getLidDefault()
Get the lidDefault field for the CHP record.

setLidDefault

@Internal
public void setLidDefault(int field_11_lidDefault)
Set the lidDefault field for the CHP record.

getLidFE

@Internal
public int getLidFE()
Get the lidFE field for the CHP record.

setLidFE

@Internal
public void setLidFE(int field_12_lidFE)
Set the lidFE field for the CHP record.

getKcd

@Internal
public byte getKcd()
Emphasis mark.

Returns:
One of
  • KCD_NON
  • KCD_DOT
  • KCD_COMMA
  • KCD_CIRCLE
  • KCD_UNDER_DOT

    • setKcd

    @Internal
public void setKcd(byte field_13_kcd)
    Emphasis mark.

    Parameters:
    field_13_kcd - One of
  • KCD_NON
  • KCD_DOT
  • KCD_COMMA
  • KCD_CIRCLE
  • KCD_UNDER_DOT

    • getFUndetermine

    @Internal
public boolean getFUndetermine()
    Character is undetermined.

    setFUndetermine

    @Internal
public void setFUndetermine(boolean field_14_fUndetermine)
    Character is undetermined.

    getIss

    @Internal
public byte getIss()
    Superscript/subscript indices.

    Returns:
    One of
  • ISS_NONE
  • ISS_SUPERSCRIPTED
  • ISS_SUBSCRIPTED

    • setIss

    @Internal
public void setIss(byte field_15_iss)
    Superscript/subscript indices.

    Parameters:
    field_15_iss - One of
  • ISS_NONE
  • ISS_SUPERSCRIPTED
  • ISS_SUBSCRIPTED

    • getFSpecSymbol

    @Internal
public boolean getFSpecSymbol()
    Used by Word internally.

    setFSpecSymbol

    @Internal
public void setFSpecSymbol(boolean field_16_fSpecSymbol)
    Used by Word internally.

    getIdct

    @Internal
public byte getIdct()
    Not stored in file.

    setIdct

    @Internal
public void setIdct(byte field_17_idct)
    Not stored in file.

    getIdctHint

    @Internal
public byte getIdctHint()
    Identifier of Character type.

    setIdctHint

    @Internal
public void setIdctHint(byte field_18_idctHint)
    Identifier of Character type.

    getKul

    @Internal
public byte getKul()
    Underline code.

    Returns:
    One of
  • KUL_NONE
  • KUL_SINGLE
  • KUL_BY_WORD
  • KUL_DOUBLE
  • KUL_DOTTED
  • KUL_HIDDEN
  • KUL_THICK
  • KUL_DASH
  • KUL_DOT
  • KUL_DOT_DASH
  • KUL_DOT_DOT_DASH
  • KUL_WAVE
  • KUL_DOTTED_HEAVY
  • KUL_DASHED_HEAVY
  • KUL_DOT_DASH_HEAVY
  • KUL_DOT_DOT_DASH_HEAVY
  • KUL_WAVE_HEAVY
  • KUL_DASH_LONG
  • KUL_WAVE_DOUBLE
  • KUL_DASH_LONG_HEAVY

    • setKul

    @Internal
public void setKul(byte field_19_kul)
    Underline code.

    Parameters:
    field_19_kul - One of
  • KUL_NONE
  • KUL_SINGLE
  • KUL_BY_WORD
  • KUL_DOUBLE
  • KUL_DOTTED
  • KUL_HIDDEN
  • KUL_THICK
  • KUL_DASH
  • KUL_DOT
  • KUL_DOT_DASH
  • KUL_DOT_DOT_DASH
  • KUL_WAVE
  • KUL_DOTTED_HEAVY
  • KUL_DASHED_HEAVY
  • KUL_DOT_DASH_HEAVY
  • KUL_DOT_DOT_DASH_HEAVY
  • KUL_WAVE_HEAVY
  • KUL_DASH_LONG
  • KUL_WAVE_DOUBLE
  • KUL_DASH_LONG_HEAVY

    • getHresi

    @Internal
public Hyphenation getHresi()
    Get the hresi field for the CHP record.

    setHresi

    @Internal
public void setHresi(Hyphenation field_20_hresi)
    Set the hresi field for the CHP record.

    getHpsKern

    @Internal
public int getHpsKern()
    Kerning distance for characters in run recorded in half points.

    setHpsKern

    @Internal
public void setHpsKern(int field_21_hpsKern)
    Kerning distance for characters in run recorded in half points.

    getHpsPos

    @Internal
public short getHpsPos()
    Reserved (actually used as vertical offset(?) value).

    setHpsPos

    @Internal
public void setHpsPos(short field_22_hpsPos)
    Reserved (actually used as vertical offset(?) value).

    getShd

    @Internal
public ShadingDescriptor getShd()
    Shading.

    setShd

    @Internal
public void setShd(ShadingDescriptor field_23_shd)
    Shading.

    getBrc

    @Internal
public BorderCode getBrc()
    Border.

    setBrc

    @Internal
public void setBrc(BorderCode field_24_brc)
    Border.

    getIbstRMark

    @Internal
public int getIbstRMark()
    Index to author IDs stored in hsttbfRMark. Used when text in run was newly typed when revision marking was enabled.

    setIbstRMark

    @Internal
public void setIbstRMark(int field_25_ibstRMark)
    Index to author IDs stored in hsttbfRMark. Used when text in run was newly typed when revision marking was enabled.

    getSfxtText

    @Internal
public byte getSfxtText()
    Text animation.

    Returns:
    One of
  • SFXTTEXT_NO
  • SFXTTEXT_LAS_VEGAS_LIGHTS
  • SFXTTEXT_BACKGROUND_BLINK
  • SFXTTEXT_SPARKLE_TEXT
  • SFXTTEXT_MARCHING_ANTS
  • SFXTTEXT_MARCHING_RED_ANTS
  • SFXTTEXT_SHIMMER

    • setSfxtText

    @Internal
public void setSfxtText(byte field_26_sfxtText)
    Text animation.

    Parameters:
    field_26_sfxtText - One of
  • SFXTTEXT_NO
  • SFXTTEXT_LAS_VEGAS_LIGHTS
  • SFXTTEXT_BACKGROUND_BLINK
  • SFXTTEXT_SPARKLE_TEXT
  • SFXTTEXT_MARCHING_ANTS
  • SFXTTEXT_MARCHING_RED_ANTS
  • SFXTTEXT_SHIMMER

    • getFDblBdr

    @Internal
public boolean getFDblBdr()
    Used internally by Word.

    setFDblBdr

    @Internal
public void setFDblBdr(boolean field_27_fDblBdr)
    Used internally by Word.

    getFBorderWS

    @Internal
public boolean getFBorderWS()
    Used internally by Word.

    setFBorderWS

    @Internal
public void setFBorderWS(boolean field_28_fBorderWS)
    Used internally by Word.

    getUfel

    @Internal
public short getUfel()
    Collection properties represented by itypFELayout and copt (East Asian layout properties).

    setUfel

    @Internal
public void setUfel(short field_29_ufel)
    Collection properties represented by itypFELayout and copt (East Asian layout properties).

    getCopt

    @Internal
public byte getCopt()
    Collection of the 5 flags.

    setCopt

    @Internal
public void setCopt(byte field_30_copt)
    Collection of the 5 flags.

    getHpsAsci

    @Internal
public int getHpsAsci()
    Font size for ASCII font.

    setHpsAsci

    @Internal
public void setHpsAsci(int field_31_hpsAsci)
    Font size for ASCII font.

    getHpsFE

    @Internal
public int getHpsFE()
    Font size for East Asian text.

    setHpsFE

    @Internal
public void setHpsFE(int field_32_hpsFE)
    Font size for East Asian text.

    getHpsBi

    @Internal
public int getHpsBi()
    Font size for Complex Scripts text.

    setHpsBi

    @Internal
public void setHpsBi(int field_33_hpsBi)
    Font size for Complex Scripts text.

    getFtcSym

    @Internal
public int getFtcSym()
    an index into the rgffn structure. When chp.fSpec is 1 and the character recorded for the run in the document stream is chSymbol (0x28), chp.ftcSym identifies the font code of the symbol font that will be used to display the symbol character recorded in chp.xchSym..

    setFtcSym

    @Internal
public void setFtcSym(int field_34_ftcSym)
    an index into the rgffn structure. When chp.fSpec is 1 and the character recorded for the run in the document stream is chSymbol (0x28), chp.ftcSym identifies the font code of the symbol font that will be used to display the symbol character recorded in chp.xchSym..

    getXchSym

    @Internal
public int getXchSym()
    When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..

    setXchSym

    @Internal
public void setXchSym(int field_35_xchSym)
    When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..

    getFcPic

    @Internal
public int getFcPic()
    Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..

    setFcPic

    @Internal
public void setFcPic(int field_36_fcPic)
    Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..

    getFcObj

    @Internal
public int getFcObj()
    Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..

    setFcObj

    @Internal
public void setFcObj(int field_37_fcObj)
    Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..

    getLTagObj

    @Internal
public int getLTagObj()
    An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..

    setLTagObj

    @Internal
public void setLTagObj(int field_38_lTagObj)
    An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..

    getFcData

    @Internal
public int getFcData()
    Points to location of picture data, only if chp.fSpec is true..

    setFcData

    @Internal
public void setFcData(int field_39_fcData)
    Points to location of picture data, only if chp.fSpec is true..

    getHresiOld

    @Internal
public Hyphenation getHresiOld()
    Get the hresiOld field for the CHP record.

    setHresiOld

    @Internal
public void setHresiOld(Hyphenation field_40_hresiOld)
    Set the hresiOld field for the CHP record.

    getIbstRMarkDel

    @Internal
public int getIbstRMarkDel()
    Index to author IDs stored in hsttbfRMark. Used when text in run was deleted when revision marking was enabled..

    setIbstRMarkDel

    @Internal
public void setIbstRMarkDel(int field_41_ibstRMarkDel)
    Index to author IDs stored in hsttbfRMark. Used when text in run was deleted when revision marking was enabled..

    getDttmRMark

    @Internal
public DateAndTime getDttmRMark()
    Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).

    setDttmRMark

    @Internal
public void setDttmRMark(DateAndTime field_42_dttmRMark)
    Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).

    getDttmRMarkDel

    @Internal
public DateAndTime getDttmRMarkDel()
    Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).

    setDttmRMarkDel

    @Internal
public void setDttmRMarkDel(DateAndTime field_43_dttmRMarkDel)
    Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).

    getIstd

    @Internal
public int getIstd()
    Index to character style descriptor in the stylesheet that tags this run of text. When istd is istdNormalChar (10 decimal), characters in run are not affected by a character style. If chp.istd contains any other value, chpx of the specified character style are applied to CHP for this run before any other exceptional properties are applied..

    setIstd

    @Internal
public void setIstd(int field_44_istd)
    Index to character style descriptor in the stylesheet that tags this run of text. When istd is istdNormalChar (10 decimal), characters in run are not affected by a character style. If chp.istd contains any other value, chpx of the specified character style are applied to CHP for this run before any other exceptional properties are applied..

    getIdslRMReason

    @Internal
public int getIdslRMReason()
    An index to strings displayed as reasons for actions taken by Word's AutoFormat code.

    setIdslRMReason

    @Internal
public void setIdslRMReason(int field_45_idslRMReason)
    An index to strings displayed as reasons for actions taken by Word's AutoFormat code.

    getIdslReasonDel

    @Internal
public int getIdslReasonDel()
    An index to strings displayed as reasons for actions taken by Word's AutoFormat code.

    setIdslReasonDel

    @Internal
public void setIdslReasonDel(int field_46_idslReasonDel)
    An index to strings displayed as reasons for actions taken by Word's AutoFormat code.

    getCpg

    @Internal
public int getCpg()
    Code page of run in pre-Unicode files.

    setCpg

    @Internal
public void setCpg(int field_47_cpg)
    Code page of run in pre-Unicode files.

    getHighlight

    @Internal
public short getHighlight()
    Get the Highlight field for the CHP record.

    setHighlight

    @Internal
public void setHighlight(short field_48_Highlight)
    Set the Highlight field for the CHP record.

    getCharsetFlags

    @Internal
public short getCharsetFlags()
    Get the CharsetFlags field for the CHP record.

    setCharsetFlags

    @Internal
public void setCharsetFlags(short field_49_CharsetFlags)
    Set the CharsetFlags field for the CHP record.

    getChse

    @Internal
public short getChse()
    Get the chse field for the CHP record.

    setChse

    @Internal
public void setChse(short field_50_chse)
    Set the chse field for the CHP record.

    getFPropRMark

    @Internal
public boolean getFPropRMark()
    properties have been changed with revision marking on.

    setFPropRMark

    @Internal
public void setFPropRMark(boolean field_51_fPropRMark)
    properties have been changed with revision marking on.

    getIbstPropRMark

    @Internal
public int getIbstPropRMark()
    Index to author IDs stored in hsttbfRMark. Used when properties have been changed when revision marking was enabled..

    setIbstPropRMark

    @Internal
public void setIbstPropRMark(int field_52_ibstPropRMark)
    Index to author IDs stored in hsttbfRMark. Used when properties have been changed when revision marking was enabled..

    getDttmPropRMark

    @Internal
public DateAndTime getDttmPropRMark()
    Date/time at which properties of this were changed for this run of text by the author. (Only recorded when revision marking is on.).

    setDttmPropRMark

    @Internal
public void setDttmPropRMark(DateAndTime field_53_dttmPropRMark)
    Date/time at which properties of this were changed for this run of text by the author. (Only recorded when revision marking is on.).

    getFConflictOrig

    @Internal
public boolean getFConflictOrig()
    When chp.wConflict!=0, this is TRUE when text is part of the original version of text. When FALSE, text is alternative introduced by reconciliation operation..

    setFConflictOrig

    @Internal
public void setFConflictOrig(boolean field_54_fConflictOrig)
    When chp.wConflict!=0, this is TRUE when text is part of the original version of text. When FALSE, text is alternative introduced by reconciliation operation..

    getFConflictOtherDel

    @Internal
public boolean getFConflictOtherDel()
    When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.

    setFConflictOtherDel

    @Internal
public void setFConflictOtherDel(boolean field_55_fConflictOtherDel)
    When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.

    getWConflict

    @Internal
public int getWConflict()
    When != 0, index number that identifies all text participating in a particular conflict incident.

    setWConflict

    @Internal
public void setWConflict(int field_56_wConflict)
    When != 0, index number that identifies all text participating in a particular conflict incident.

    getIbstConflict

    @Internal
public int getIbstConflict()
    Who made this change for this side of the conflict..

    setIbstConflict

    @Internal
public void setIbstConflict(int field_57_IbstConflict)
    Who made this change for this side of the conflict..

    getDttmConflict

    @Internal
public DateAndTime getDttmConflict()
    When the change was made.

    setDttmConflict

    @Internal
public void setDttmConflict(DateAndTime field_58_dttmConflict)
    When the change was made.

    getFDispFldRMark

    @Internal
public boolean getFDispFldRMark()
    the number for a ListNum field is being tracked in xstDispFldRMark. If that number is different from the current value, the number has changed. Only valid for ListNum fields..

    setFDispFldRMark

    @Internal
public void setFDispFldRMark(boolean field_59_fDispFldRMark)
    the number for a ListNum field is being tracked in xstDispFldRMark. If that number is different from the current value, the number has changed. Only valid for ListNum fields..

    getIbstDispFldRMark

    @Internal
public int getIbstDispFldRMark()
    Index to author IDs stored in hsttbfRMark. Used when ListNum field numbering has been changed when revision marking was enabled..

    setIbstDispFldRMark

    @Internal
public void setIbstDispFldRMark(int field_60_ibstDispFldRMark)
    Index to author IDs stored in hsttbfRMark. Used when ListNum field numbering has been changed when revision marking was enabled..

    getDttmDispFldRMark

    @Internal
public DateAndTime getDttmDispFldRMark()
    The date for the ListNum field number change.

    setDttmDispFldRMark

    @Internal
public void setDttmDispFldRMark(DateAndTime field_61_dttmDispFldRMark)
    The date for the ListNum field number change.

    getXstDispFldRMark

    @Internal
public byte[] getXstDispFldRMark()
    The string value of the ListNum field when revision mark tracking began.

    setXstDispFldRMark

    @Internal
public void setXstDispFldRMark(byte[] field_62_xstDispFldRMark)
    The string value of the ListNum field when revision mark tracking began.

    getFcObjp

    @Internal
public int getFcObjp()
    Offset in the data stream indicating the location of OLE object data.

    setFcObjp

    @Internal
public void setFcObjp(int field_63_fcObjp)
    Offset in the data stream indicating the location of OLE object data.

    getLbrCRJ

    @Internal
public byte getLbrCRJ()
    Line BReak code for xchCRJ.

    Returns:
    One of
  • LBRCRJ_NONE
  • LBRCRJ_LEFT
  • LBRCRJ_RIGHT
  • LBRCRJ_BOTH

    • setLbrCRJ

    @Internal
public void setLbrCRJ(byte field_64_lbrCRJ)
    Line BReak code for xchCRJ.

    Parameters:
    field_64_lbrCRJ - One of
  • LBRCRJ_NONE
  • LBRCRJ_LEFT
  • LBRCRJ_RIGHT
  • LBRCRJ_BOTH

    • getFSpecVanish

    @Internal
public boolean getFSpecVanish()
    Special hidden for leading emphasis (always hidden).

    setFSpecVanish

    @Internal
public void setFSpecVanish(boolean field_65_fSpecVanish)
    Special hidden for leading emphasis (always hidden).

    getFHasOldProps

    @Internal
public boolean getFHasOldProps()
    Used for character property revision marking. The chp at the time fHasOldProps is set to 1, the is the old chp..

    setFHasOldProps

    @Internal
public void setFHasOldProps(boolean field_66_fHasOldProps)
    Used for character property revision marking. The chp at the time fHasOldProps is set to 1, the is the old chp..

    getFSdtVanish

    @Internal
public boolean getFSdtVanish()
    Mark the character as hidden..

    setFSdtVanish

    @Internal
public void setFSdtVanish(boolean field_67_fSdtVanish)
    Mark the character as hidden..

    getWCharScale

    @Internal
public int getWCharScale()
    Get the wCharScale field for the CHP record.

    setWCharScale

    @Internal
public void setWCharScale(int field_68_wCharScale)
    Set the wCharScale field for the CHP record.

    setFBold

    @Internal
public void setFBold(boolean value)
    Sets the fBold field value. Text is bold

    isFBold

    @Internal
public boolean isFBold()
    Text is bold

    Returns:
    the fBold field value.

    setFItalic

    @Internal
public void setFItalic(boolean value)
    Sets the fItalic field value. Italic

    isFItalic

    @Internal
public boolean isFItalic()
    Italic

    Returns:
    the fItalic field value.

    setFRMarkDel

    @Internal
public void setFRMarkDel(boolean value)
    Sets the fRMarkDel field value. has been deleted and will be displayed with strikethrough when revision marked text is to be displayed

    isFRMarkDel

    @Internal
public boolean isFRMarkDel()
    has been deleted and will be displayed with strikethrough when revision marked text is to be displayed

    Returns:
    the fRMarkDel field value.

    setFOutline

    @Internal
public void setFOutline(boolean value)
    Sets the fOutline field value. Outlined

    isFOutline

    @Internal
public boolean isFOutline()
    Outlined

    Returns:
    the fOutline field value.

    setFFldVanish

    @Internal
public void setFFldVanish(boolean value)
    Sets the fFldVanish field value. Used internally by Word

    isFFldVanish

    @Internal
public boolean isFFldVanish()
    Used internally by Word

    Returns:
    the fFldVanish field value.

    setFSmallCaps

    @Internal
public void setFSmallCaps(boolean value)
    Sets the fSmallCaps field value. Displayed with small caps

    isFSmallCaps

    @Internal
public boolean isFSmallCaps()
    Displayed with small caps

    Returns:
    the fSmallCaps field value.

    setFCaps

    @Internal
public void setFCaps(boolean value)
    Sets the fCaps field value. Displayed with caps

    isFCaps

    @Internal
public boolean isFCaps()
    Displayed with caps

    Returns:
    the fCaps field value.

    setFVanish

    @Internal
public void setFVanish(boolean value)
    Sets the fVanish field value. text has hidden format, and is not displayed unless fPagHidden is set in the DOP

    isFVanish

    @Internal
public boolean isFVanish()
    text has hidden format, and is not displayed unless fPagHidden is set in the DOP

    Returns:
    the fVanish field value.

    setFRMark

    @Internal
public void setFRMark(boolean value)
    Sets the fRMark field value. text is newly typed since the last time revision marks have been accepted and will be displayed with an underline when revision marked text is to be displayed

    isFRMark

    @Internal
public boolean isFRMark()
    text is newly typed since the last time revision marks have been accepted and will be displayed with an underline when revision marked text is to be displayed

    Returns:
    the fRMark field value.

    setFSpec

    @Internal
public void setFSpec(boolean value)
    Sets the fSpec field value. Character is a Word special character

    isFSpec

    @Internal
public boolean isFSpec()
    Character is a Word special character

    Returns:
    the fSpec field value.

    setFStrike

    @Internal
public void setFStrike(boolean value)
    Sets the fStrike field value. Displayed with strikethrough

    isFStrike

    @Internal
public boolean isFStrike()
    Displayed with strikethrough

    Returns:
    the fStrike field value.

    setFObj

    @Internal
public void setFObj(boolean value)
    Sets the fObj field value. Embedded objec

    isFObj

    @Internal
public boolean isFObj()
    Embedded objec

    Returns:
    the fObj field value.

    setFShadow

    @Internal
public void setFShadow(boolean value)
    Sets the fShadow field value. Character is drawn with a shadow

    isFShadow

    @Internal
public boolean isFShadow()
    Character is drawn with a shadow

    Returns:
    the fShadow field value.

    setFLowerCase

    @Internal
public void setFLowerCase(boolean value)
    Sets the fLowerCase field value. Character is displayed in lower case. This field may be set to 1 only when chp.fSmallCaps is 1.

    isFLowerCase

    @Internal
public boolean isFLowerCase()
    Character is displayed in lower case. This field may be set to 1 only when chp.fSmallCaps is 1.

    Returns:
    the fLowerCase field value.

    setFData

    @Internal
public void setFData(boolean value)
    Sets the fData field value. chp.fcPic points to an FFDATA, the data structure binary data used by Word to describe a form field. The bit chp.fData may only be 1 when chp.fSpec is also 1 and the special character in the document stream that has this property is a chPicture (0x01)

    isFData

    @Internal
public boolean isFData()
    chp.fcPic points to an FFDATA, the data structure binary data used by Word to describe a form field. The bit chp.fData may only be 1 when chp.fSpec is also 1 and the special character in the document stream that has this property is a chPicture (0x01)

    Returns:
    the fData field value.

    setFOle2

    @Internal
public void setFOle2(boolean value)
    Sets the fOle2 field value. chp.lTagObj specifies a particular object in the object stream that specifies the particular OLE object in the stream that should be displayed when the chPicture fSpec character that is tagged with the fOle2 is encountered. The bit chp.fOle2 may only be 1 when chp.fSpec is also 1 and the special character in the document stream that has this property is a chPicture (0x01).

    isFOle2

    @Internal
public boolean isFOle2()
    chp.lTagObj specifies a particular object in the object stream that specifies the particular OLE object in the stream that should be displayed when the chPicture fSpec character that is tagged with the fOle2 is encountered. The bit chp.fOle2 may only be 1 when chp.fSpec is also 1 and the special character in the document stream that has this property is a chPicture (0x01).

    Returns:
    the fOle2 field value.

    setFEmboss

    @Internal
public void setFEmboss(boolean value)
    Sets the fEmboss field value. Text is embossed

    isFEmboss

    @Internal
public boolean isFEmboss()
    Text is embossed

    Returns:
    the fEmboss field value.

    setFImprint

    @Internal
public void setFImprint(boolean value)
    Sets the fImprint field value. Text is engraved

    isFImprint

    @Internal
public boolean isFImprint()
    Text is engraved

    Returns:
    the fImprint field value.

    setFDStrike

    @Internal
public void setFDStrike(boolean value)
    Sets the fDStrike field value. Displayed with double strikethrough

    isFDStrike

    @Internal
public boolean isFDStrike()
    Displayed with double strikethrough

    Returns:
    the fDStrike field value.

    setFUsePgsuSettings

    @Internal
public void setFUsePgsuSettings(boolean value)
    Sets the fUsePgsuSettings field value. Used internally by Word

    isFUsePgsuSettings

    @Internal
public boolean isFUsePgsuSettings()
    Used internally by Word

    Returns:
    the fUsePgsuSettings field value.

    setFBoldBi

    @Internal
public void setFBoldBi(boolean value)
    Sets the fBoldBi field value. Complex Scripts text is bold

    isFBoldBi

    @Internal
public boolean isFBoldBi()
    Complex Scripts text is bold

    Returns:
    the fBoldBi field value.

    setFComplexScripts

    @Internal
public void setFComplexScripts(boolean value)
    Sets the fComplexScripts field value. Complex Scripts text that requires special processing to display and process

    isFComplexScripts

    @Internal
public boolean isFComplexScripts()
    Complex Scripts text that requires special processing to display and process

    Returns:
    the fComplexScripts field value.

    setFItalicBi

    @Internal
public void setFItalicBi(boolean value)
    Sets the fItalicBi field value. Complex Scripts text is italics

    isFItalicBi

    @Internal
public boolean isFItalicBi()
    Complex Scripts text is italics

    Returns:
    the fItalicBi field value.

    setFBiDi

    @Internal
public void setFBiDi(boolean value)
    Sets the fBiDi field value. Complex Scripts right-to-left text that requires special processing to display and process (character reordering; contextual shaping; display of combining characters and diacritics; specialized justification rules; cursor positioning)

    isFBiDi

    @Internal
public boolean isFBiDi()
    Complex Scripts right-to-left text that requires special processing to display and process (character reordering; contextual shaping; display of combining characters and diacritics; specialized justification rules; cursor positioning)

    Returns:
    the fBiDi field value.

    setItypFELayout

    @Internal
public void setItypFELayout(short value)
    Sets the itypFELayout field value.

    getItypFELayout

    @Internal
public short getItypFELayout()
    Returns:
    the itypFELayout field value.

    setFTNY

    @Internal
public void setFTNY(boolean value)
    Sets the fTNY field value. Tatenakayoko: Horizontal-in-vertical (range of text in a direction perpendicular to the text flow) is used

    isFTNY

    @Internal
public boolean isFTNY()
    Tatenakayoko: Horizontal-in-vertical (range of text in a direction perpendicular to the text flow) is used

    Returns:
    the fTNY field value.

    setFWarichu

    @Internal
public void setFWarichu(boolean value)
    Sets the fWarichu field value. Two lines in one (text in the group is displayed as two half-height lines within a line)

    isFWarichu

    @Internal
public boolean isFWarichu()
    Two lines in one (text in the group is displayed as two half-height lines within a line)

    Returns:
    the fWarichu field value.

    setFKumimoji

    @Internal
public void setFKumimoji(boolean value)
    Sets the fKumimoji field value. combine characters

    isFKumimoji

    @Internal
public boolean isFKumimoji()
    combine characters

    Returns:
    the fKumimoji field value.

    setFRuby

    @Internal
public void setFRuby(boolean value)
    Sets the fRuby field value. Phonetic guide

    isFRuby

    @Internal
public boolean isFRuby()
    Phonetic guide

    Returns:
    the fRuby field value.

    setFLSFitText

    @Internal
public void setFLSFitText(boolean value)
    Sets the fLSFitText field value. fit text

    isFLSFitText

    @Internal
public boolean isFLSFitText()
    fit text

    Returns:
    the fLSFitText field value.

    setSpare

    @Internal
public void setSpare(byte value)
    Sets the spare field value. Unused

    getSpare

    @Internal
public byte getSpare()
    Unused

    Returns:
    the spare field value.

    setIWarichuBracket

    @Internal
public void setIWarichuBracket(byte value)
    Sets the iWarichuBracket field value. Bracket character for two-lines-in-one

    getIWarichuBracket

    @Internal
public byte getIWarichuBracket()
    Bracket character for two-lines-in-one

    Returns:
    the iWarichuBracket field value.

    setFWarichuNoOpenBracket

    @Internal
public void setFWarichuNoOpenBracket(boolean value)
    Sets the fWarichuNoOpenBracket field value. Two-lines-in-one uses no open

    isFWarichuNoOpenBracket

    @Internal
public boolean isFWarichuNoOpenBracket()
    Two-lines-in-one uses no open

    Returns:
    the fWarichuNoOpenBracket field value.

    setFTNYCompress

    @Internal
public void setFTNYCompress(boolean value)
    Sets the fTNYCompress field value. fit text in line

    isFTNYCompress

    @Internal
public boolean isFTNYCompress()
    fit text in line

    Returns:
    the fTNYCompress field value.

    setFTNYFetchTxm

    @Internal
public void setFTNYFetchTxm(boolean value)
    Sets the fTNYFetchTxm field value. fetch text metrics

    isFTNYFetchTxm

    @Internal
public boolean isFTNYFetchTxm()
    fetch text metrics

    Returns:
    the fTNYFetchTxm field value.

    setFCellFitText

    @Internal
public void setFCellFitText(boolean value)
    Sets the fCellFitText field value. Fit text in cell

    isFCellFitText

    @Internal
public boolean isFCellFitText()
    Fit text in cell

    Returns:
    the fCellFitText field value.

    setUnused

    @Internal
public void setUnused(boolean value)
    Sets the unused field value. Not used

    isUnused

    @Internal
public boolean isUnused()
    Not used

    Returns:
    the unused field value.

    setIcoHighlight

    @Internal
public void setIcoHighlight(byte value)
    Sets the icoHighlight field value. Highlight color (see chp.ico)

    getIcoHighlight

    @Internal
public byte getIcoHighlight()
    Highlight color (see chp.ico)

    Returns:
    the icoHighlight field value.

    setFHighlight

    @Internal
public void setFHighlight(boolean value)
    Sets the fHighlight field value. When 1, characters are highlighted with color specified by chp.icoHighlight

    isFHighlight

    @Internal
public boolean isFHighlight()
    When 1, characters are highlighted with color specified by chp.icoHighlight

    Returns:
    the fHighlight field value.

    setFChsDiff

    @Internal
public void setFChsDiff(boolean value)
    Sets the fChsDiff field value. Pre-Unicode files, char's char set different from FIB char set

    isFChsDiff

    @Internal
public boolean isFChsDiff()
    Pre-Unicode files, char's char set different from FIB char set

    Returns:
    the fChsDiff field value.

    setFMacChs

    @Internal
public void setFMacChs(boolean value)
    Sets the fMacChs field value. fTrue if char's are Macintosh char set

    isFMacChs

    @Internal
public boolean isFMacChs()
    fTrue if char's are Macintosh char set

    Returns:
    the fMacChs field value.
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOPAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class DOPAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.DOPAbstractType
All Implemented Interfaces:
org.apache.poi.hdf.model.hdftypes.HDFType
Direct Known Subclasses:
DocumentProperties
@Internal
public abstract class DOPAbstractType
extends java.lang.Object
implements org.apache.poi.hdf.model.hdftypes.HDFType

Document Properties. NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/records/definitions.

Author:
S. Ryan Ackley

Field Summary
protected byte | field_1_formatFlags
protected int | field_10_wSpare
protected int | field_11_dxaHotz
protected int | field_12_cConsexHypLim
protected int | field_13_wSpare2
protected int | field_14_dttmCreated
protected int | field_15_dttmRevised
protected int | field_16_dttmLastPrint
protected int | field_17_nRevision
protected int | field_18_tmEdited
protected int | field_19_cWords
protected byte | field_2_unused2
protected int | field_20_cCh
protected int | field_21_cPg
protected int | field_22_cParas
protected short | field_23_Edn
protected short | field_24_Edn1
protected int | field_25_cLines
protected int | field_26_cWordsFtnEnd
protected int | field_27_cChFtnEdn
protected short | field_28_cPgFtnEdn
protected int | field_29_cParasFtnEdn
protected short | field_3_footnoteInfo
protected int | field_30_cLinesFtnEdn
protected int | field_31_lKeyProtDoc
protected short | field_32_view
protected int | field_33_docinfo4
protected short | field_34_adt
protected byte[] | field_35_doptypography
protected byte[] | field_36_dogrid
protected short | field_37_docinfo5
protected short | field_38_docinfo6
protected byte[] | field_39_asumyi
protected byte | field_4_fOutlineDirtySave
protected int | field_40_cChWS
protected int | field_41_cChWSFtnEdn
protected int | field_42_grfDocEvents
protected int | field_43_virusinfo
protected byte[] | field_44_Spare
protected int | field_45_reserved1
protected int | field_46_reserved2
protected int | field_47_cDBC
protected int | field_48_cDBCFtnEdn
protected int | field_49_reserved
protected byte | field_5_docinfo
protected short | field_50_nfcFtnRef
protected short | field_51_nfcEdnRef
protected short | field_52_hpsZoonFontPag
protected short | field_53_dywDispPag
protected byte | field_6_docinfo1
protected byte | field_7_docinfo2
protected short | field_8_docinfo3
protected int | field_9_dxaTab
Constructor Summary
protected DOPAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
short | getAdt() Get the adt field for the DOP record.
byte[] | getAsumyi() Get the asumyi field for the DOP record.
int | getCCh() Get the cCh field for the DOP record.
int | getCChFtnEdn() Get the cChFtnEdn field for the DOP record.
int | getCChWS() Get the cChWS field for the DOP record.
int | getCChWSFtnEdn() Get the cChWSFtnEdn field for the DOP record.
int | getCConsexHypLim() Get the cConsexHypLim field for the DOP record.
int | getCDBC() Get the cDBC field for the DOP record.
int | getCDBCFtnEdn() Get the cDBCFtnEdn field for the DOP record.
int | getCLines() Get the cLines field for the DOP record.
int | getCLinesFtnEdn() Get the cLinesFtnEdn field for the DOP record.
int | getCParas() Get the cParas field for the DOP record.
int | getCParasFtnEdn() Get the cParasFtnEdn field for the DOP record.
int | getCPg() Get the cPg field for the DOP record.
short | getCPgFtnEdn() Get the cPgFtnEdn field for the DOP record.
int | getCWords() Get the cWords field for the DOP record.
int | getCWordsFtnEnd() Get the cWordsFtnEnd field for the DOP record.
byte | getDocinfo() Get the docinfo field for the DOP record.
byte | getDocinfo1() Get the docinfo1 field for the DOP record.
byte | getDocinfo2() Get the docinfo2 field for the DOP record.
short | getDocinfo3() Get the docinfo3 field for the DOP record.
int | getDocinfo4() Get the docinfo4 field for the DOP record.
short | getDocinfo5() Get the docinfo5 field for the DOP record.
short | getDocinfo6() Get the docinfo6 field for the DOP record.
byte[] | getDogrid() Get the dogrid field for the DOP record.
byte[] | getDoptypography() Get the doptypography field for the DOP record.
int | getDttmCreated() Get the dttmCreated field for the DOP record.
int | getDttmLastPrint() Get the dttmLastPrint field for the DOP record.
int | getDttmRevised() Get the dttmRevised field for the DOP record.
int | getDxaHotz() Get the dxaHotz field for the DOP record.
int | getDxaTab() Get the dxaTab field for the DOP record.
short | getDywDispPag() Get the dywDispPag field for the DOP record.
short | getEdn() Get the Edn field for the DOP record.
short | getEdn1() Get the Edn1 field for the DOP record.
byte | getEpc()
short | getFootnoteInfo() Get the footnoteInfo field for the DOP record.
byte | getFormatFlags() Get the formatFlags field for the DOP record.
byte | getFOutlineDirtySave() Get the fOutlineDirtySave field for the DOP record.
byte | getFpc()
int | getGrfDocEvents() Get the grfDocEvents field for the DOP record.
byte | getGrfSupression()
short | getHpsZoonFontPag() Get the hpsZoonFontPag field for the DOP record.
int | getKeyVirusSession30()
int | getLKeyProtDoc() Get the lKeyProtDoc field for the DOP record.
byte | getLvl()
short | getNEdn()
short | getNfcEdnRef() Get the nfcEdnRef field for the DOP record.
byte | getNfcEdnRef1()
short | getNfcFtnRef() Get the nfcFtnRef field for the DOP record.
byte | getNfcFtnRef1()
short | getNFtn()
int | getNRevision() Get the nRevision field for the DOP record.
int | getReserved() Get the reserved field for the DOP record.
int | getReserved1() Get the reserved1 field for the DOP record.
int | getReserved2() Get the reserved2 field for the DOP record.
byte | getRncEdn()
byte | getRncFtn()
static int | getSize() Size of record
byte[] | getSpare() Get the Spare field for the DOP record.
int | getTmEdited() Get the tmEdited field for the DOP record.
byte | getUnused2() Get the unused2 field for the DOP record.
byte | getUnused5()
short | getView() Get the view field for the DOP record.
int | getVirusinfo() Get the virusinfo field for the DOP record.
short | getWScaleSaved()
int | getWSpare() Get the wSpare field for the DOP record.
int | getWSpare2() Get the wSpare2 field for the DOP record.
byte | getWvkSaved()
byte | getZkSaved()
boolean | isFAutoHyphen()
boolean | isFAutoVersions()
boolean | isFBackup()
boolean | isFConvMailMergeEsc()
boolean | isFDfltTrueType()
boolean | isFDispFormFldSel()
boolean | isFEmbedFonts()
boolean | isFExactCWords()
boolean | isFFacingPages()
boolean | isFForcePageSizePag()
boolean | isFFormNoFields()
boolean | isFGramAllClean()
boolean | isFGramAllDone()
boolean | isFHaveVersions()
boolean | isFHideLastVersion()
boolean | isFHtmlDoc()
boolean | isFHyphCapitals()
boolean | isFIncludeFooter()
boolean | isFIncludeHeader()
boolean | isFLabelDoc()
boolean | isFLinkStyles()
boolean | isFLockAtn()
boolean | isFLockRev()
boolean | isFMapPrintTextColor()
boolean | isFMinFontSizePag()
boolean | isFMirrorMargins()
boolean | isFMWSmallCaps()
boolean | isFNoColumnBalance()
boolean | isFNoLeading()
boolean | isFNoSpaceRaiseLower()
boolean | isFNoTabForInd()
boolean | isFOnlyMacPics()
boolean | isFOnlyWinPics()
boolean | isFOrigWordTableRules()
boolean | isFPagHidden()
boolean | isFPagResults()
boolean | isFPagSupressTopSpacing()
boolean | isFPMHMainDoc()
boolean | isFPrintBodyBeforeHdr()
boolean | isFPrintFormData()
boolean | isFProtEnabled()
boolean | isFRevMarking()
boolean | isFRMPrint()
boolean | isFRMView()
boolean | isFRotateFontW6()
boolean | isFSaveFormData()
boolean | isFShadeFormData()
boolean | isFShowBreaksInFrames()
boolean | isFSnapBorder()
boolean | isFSubsetFonts()
boolean | isFSuppressTopSPacingMac5()
boolean | isFSupressSpdfAfterPageBreak()
boolean | isFSupressTopSpacing()
boolean | isFSwapBordersFacingPgs()
boolean | isFTransparentMetafiles()
boolean | isFTruncDxaExpand()
boolean | isFVirusLoadSafe()
boolean | isFVirusPrompted()
boolean | isFWCFtnEdn()
boolean | isFWidowControl()
boolean | isFWrapTrailSpaces()
boolean | isIGutterPos()
boolean | isOldfConvMailMergeEsc()
boolean | isOldfMapPrintTextColor()
boolean | isOldfNoColumnBalance()
boolean | isOldfNoSpaceRaiseLower()
boolean | isOldfNoTabForInd()
boolean | isOldfOrigWordTableRules()
boolean | isOldfShowBreaksInFrames()
boolean | isOldfSuppressSpbfAfterPageBreak()
boolean | isOldfSupressTopSpacing()
boolean | isOldfSwapBordersFacingPgs()
boolean | isOldfTransparentMetafiles()
boolean | isOldfWrapTrailSpaces()
boolean | isUnused1()
boolean | isUnused3()
boolean | isUnused4()
void | serialize(byte[] data, int offset)
void | setAdt(short field_34_adt) Set the adt field for the DOP record.
void | setAsumyi(byte[] field_39_asumyi) Set the asumyi field for the DOP record.
void | setCCh(int field_20_cCh) Set the cCh field for the DOP record.
void | setCChFtnEdn(int field_27_cChFtnEdn) Set the cChFtnEdn field for the DOP record.
void | setCChWS(int field_40_cChWS) Set the cChWS field for the DOP record.
void | setCChWSFtnEdn(int field_41_cChWSFtnEdn) Set the cChWSFtnEdn field for the DOP record.
void | setCConsexHypLim(int field_12_cConsexHypLim) Set the cConsexHypLim field for the DOP record.
void | setCDBC(int field_47_cDBC) Set the cDBC field for the DOP record.
void | setCDBCFtnEdn(int field_48_cDBCFtnEdn) Set the cDBCFtnEdn field for the DOP record.
void | setCLines(int field_25_cLines) Set the cLines field for the DOP record.
void | setCLinesFtnEdn(int field_30_cLinesFtnEdn) Set the cLinesFtnEdn field for the DOP record.
void | setCParas(int field_22_cParas) Set the cParas field for the DOP record.
void | setCParasFtnEdn(int field_29_cParasFtnEdn) Set the cParasFtnEdn field for the DOP record.
void | setCPg(int field_21_cPg) Set the cPg field for the DOP record.
void | setCPgFtnEdn(short field_28_cPgFtnEdn) Set the cPgFtnEdn field for the DOP record.
void | setCWords(int field_19_cWords) Set the cWords field for the DOP record.
void | setCWordsFtnEnd(int field_26_cWordsFtnEnd) Set the cWordsFtnEnd field for the DOP record.
void | setDocinfo(byte field_5_docinfo) Set the docinfo field for the DOP record.
void | setDocinfo1(byte field_6_docinfo1) Set the docinfo1 field for the DOP record.
void | setDocinfo2(byte field_7_docinfo2) Set the docinfo2 field for the DOP record.
void | setDocinfo3(short field_8_docinfo3) Set the docinfo3 field for the DOP record.
void | setDocinfo4(int field_33_docinfo4) Set the docinfo4 field for the DOP record.
void | setDocinfo5(short field_37_docinfo5) Set the docinfo5 field for the DOP record.
void | setDocinfo6(short field_38_docinfo6) Set the docinfo6 field for the DOP record.
void | setDogrid(byte[] field_36_dogrid) Set the dogrid field for the DOP record.
void | setDoptypography(byte[] field_35_doptypography) Set the doptypography field for the DOP record.
void | setDttmCreated(int field_14_dttmCreated) Set the dttmCreated field for the DOP record.
void | setDttmLastPrint(int field_16_dttmLastPrint) Set the dttmLastPrint field for the DOP record.
void | setDttmRevised(int field_15_dttmRevised) Set the dttmRevised field for the DOP record.
void | setDxaHotz(int field_11_dxaHotz) Set the dxaHotz field for the DOP record.
void | setDxaTab(int field_9_dxaTab) Set the dxaTab field for the DOP record.
void | setDywDispPag(short field_53_dywDispPag) Set the dywDispPag field for the DOP record.
void | setEdn(short field_23_Edn) Set the Edn field for the DOP record.
void | setEdn1(short field_24_Edn1) Set the Edn1 field for the DOP record.
void | setEpc(byte value) Sets the epc field value.
void | setFAutoHyphen(boolean value) Sets the fAutoHyphen field value.
void | setFAutoVersions(boolean value) Sets the fAutoVersions field value.
void | setFBackup(boolean value) Sets the fBackup field value.
void | setFConvMailMergeEsc(boolean value) Sets the fConvMailMergeEsc field value.
void | setFDfltTrueType(boolean value) Sets the fDfltTrueType field value.
void | setFDispFormFldSel(boolean value) Sets the fDispFormFldSel field value.
void | setFEmbedFonts(boolean value) Sets the fEmbedFonts field value.
void | setFExactCWords(boolean value) Sets the fExactCWords field value.
void | setFFacingPages(boolean value) Sets the fFacingPages field value.
void | setFForcePageSizePag(boolean value) Sets the fForcePageSizePag field value.
void | setFFormNoFields(boolean value) Sets the fFormNoFields field value.
void | setFGramAllClean(boolean value) Sets the fGramAllClean field value.
void | setFGramAllDone(boolean value) Sets the fGramAllDone field value.
void | setFHaveVersions(boolean value) Sets the fHaveVersions field value.
void | setFHideLastVersion(boolean value) Sets the fHideLastVersion field value.
void | setFHtmlDoc(boolean value) Sets the fHtmlDoc field value.
void | setFHyphCapitals(boolean value) Sets the fHyphCapitals field value.
void | setFIncludeFooter(boolean value) Sets the fIncludeFooter field value.
void | setFIncludeHeader(boolean value) Sets the fIncludeHeader field value.
void | setFLabelDoc(boolean value) Sets the fLabelDoc field value.
void | setFLinkStyles(boolean value) Sets the fLinkStyles field value.
void | setFLockAtn(boolean value) Sets the fLockAtn field value.
void | setFLockRev(boolean value) Sets the fLockRev field value.
void | setFMapPrintTextColor(boolean value) Sets the fMapPrintTextColor field value.
void | setFMinFontSizePag(boolean value) Sets the fMinFontSizePag field value.
void | setFMirrorMargins(boolean value) Sets the fMirrorMargins field value.
void | setFMWSmallCaps(boolean value) Sets the fMWSmallCaps field value.
void | setFNoColumnBalance(boolean value) Sets the fNoColumnBalance field value.
void | setFNoLeading(boolean value) Sets the fNoLeading field value.
void | setFNoSpaceRaiseLower(boolean value) Sets the fNoSpaceRaiseLower field value.
void | setFNoTabForInd(boolean value) Sets the fNoTabForInd field value.
void | setFOnlyMacPics(boolean value) Sets the fOnlyMacPics field value.
void | setFOnlyWinPics(boolean value) Sets the fOnlyWinPics field value.
void | setFootnoteInfo(short field_3_footnoteInfo) Set the footnoteInfo field for the DOP record.
void | setFOrigWordTableRules(boolean value) Sets the fOrigWordTableRules field value.
void | setFormatFlags(byte field_1_formatFlags) Set the formatFlags field for the DOP record.
void | setFOutlineDirtySave(byte field_4_fOutlineDirtySave) Set the fOutlineDirtySave field for the DOP record.
void | setFPagHidden(boolean value) Sets the fPagHidden field value.
void | setFPagResults(boolean value) Sets the fPagResults field value.
void | setFPagSupressTopSpacing(boolean value) Sets the fPagSupressTopSpacing field value.
void | setFpc(byte value) Sets the fpc field value.
void | setFPMHMainDoc(boolean value) Sets the fPMHMainDoc field value.
void | setFPrintBodyBeforeHdr(boolean value) Sets the fPrintBodyBeforeHdr field value.
void | setFPrintFormData(boolean value) Sets the fPrintFormData field value.
void | setFProtEnabled(boolean value) Sets the fProtEnabled field value.
void | setFRevMarking(boolean value) Sets the fRevMarking field value.
void | setFRMPrint(boolean value) Sets the fRMPrint field value.
void | setFRMView(boolean value) Sets the fRMView field value.
void | setFRotateFontW6(boolean value) Sets the fRotateFontW6 field value.
void | setFSaveFormData(boolean value) Sets the fSaveFormData field value.
void | setFShadeFormData(boolean value) Sets the fShadeFormData field value.
void | setFShowBreaksInFrames(boolean value) Sets the fShowBreaksInFrames field value.
void | setFSnapBorder(boolean value) Sets the fSnapBorder field value.
void | setFSubsetFonts(boolean value) Sets the fSubsetFonts field value.
void | setFSuppressTopSPacingMac5(boolean value) Sets the fSuppressTopSPacingMac5 field value.
void | setFSupressSpdfAfterPageBreak(boolean value) Sets the fSupressSpdfAfterPageBreak field value.
void | setFSupressTopSpacing(boolean value) Sets the fSupressTopSpacing field value.
void | setFSwapBordersFacingPgs(boolean value) Sets the fSwapBordersFacingPgs field value.
void | setFTransparentMetafiles(boolean value) Sets the fTransparentMetafiles field value.
void | setFTruncDxaExpand(boolean value) Sets the fTruncDxaExpand field value.
void | setFVirusLoadSafe(boolean value) Sets the fVirusLoadSafe field value.
void | setFVirusPrompted(boolean value) Sets the fVirusPrompted field value.
void | setFWCFtnEdn(boolean value) Sets the fWCFtnEdn field value.
void | setFWidowControl(boolean value) Sets the fWidowControl field value.
void | setFWrapTrailSpaces(boolean value) Sets the fWrapTrailSpaces field value.
void | setGrfDocEvents(int field_42_grfDocEvents) Set the grfDocEvents field for the DOP record.
void | setGrfSupression(byte value) Sets the grfSupression field value.
void | setHpsZoonFontPag(short field_52_hpsZoonFontPag) Set the hpsZoonFontPag field for the DOP record.
void | setIGutterPos(boolean value) Sets the iGutterPos field value.
void | setKeyVirusSession30(int value) Sets the KeyVirusSession30 field value.
void | setLKeyProtDoc(int field_31_lKeyProtDoc) Set the lKeyProtDoc field for the DOP record.
void | setLvl(byte value) Sets the lvl field value.
void | setNEdn(short value) Sets the nEdn field value.
void | setNfcEdnRef(short field_51_nfcEdnRef) Set the nfcEdnRef field for the DOP record.
void | setNfcEdnRef1(byte value) Sets the nfcEdnRef1 field value.
void | setNfcFtnRef(short field_50_nfcFtnRef) Set the nfcFtnRef field for the DOP record.
void | setNfcFtnRef1(byte value) Sets the nfcFtnRef1 field value.
void | setNFtn(short value) Sets the nFtn field value.
void | setNRevision(int field_17_nRevision) Set the nRevision field for the DOP record.
void | setOldfConvMailMergeEsc(boolean value) Sets the oldfConvMailMergeEsc field value.
void | setOldfMapPrintTextColor(boolean value) Sets the oldfMapPrintTextColor field value.
void | setOldfNoColumnBalance(boolean value) Sets the oldfNoColumnBalance field value.
void | setOldfNoSpaceRaiseLower(boolean value) Sets the oldfNoSpaceRaiseLower field value.
void | setOldfNoTabForInd(boolean value) Sets the oldfNoTabForInd field value.
void | setOldfOrigWordTableRules(boolean value) Sets the oldfOrigWordTableRules field value.
void | setOldfShowBreaksInFrames(boolean value) Sets the oldfShowBreaksInFrames field value.
void | setOldfSuppressSpbfAfterPageBreak(boolean value) Sets the oldfSuppressSpbfAfterPageBreak field value.
void | setOldfSupressTopSpacing(boolean value) Sets the oldfSupressTopSpacing field value.
void | setOldfSwapBordersFacingPgs(boolean value) Sets the oldfSwapBordersFacingPgs field value.
void | setOldfTransparentMetafiles(boolean value) Sets the oldfTransparentMetafiles field value.
void | setOldfWrapTrailSpaces(boolean value) Sets the oldfWrapTrailSpaces field value.
void | setReserved(int field_49_reserved) Set the reserved field for the DOP record.
void | setReserved1(int field_45_reserved1) Set the reserved1 field for the DOP record.
void | setReserved2(int field_46_reserved2) Set the reserved2 field for the DOP record.
void | setRncEdn(byte value) Sets the rncEdn field value.
void | setRncFtn(byte value) Sets the rncFtn field value.
void | setSpare(byte[] field_44_Spare) Set the Spare field for the DOP record.
void | setTmEdited(int field_18_tmEdited) Set the tmEdited field for the DOP record.
void | setUnused1(boolean value) Sets the unused1 field value.
void | setUnused2(byte field_2_unused2) Set the unused2 field for the DOP record.
void | setUnused3(boolean value) Sets the unused3 field value.
void | setUnused4(boolean value) Sets the unused4 field value.
void | setUnused5(byte value) Sets the unused5 field value.
void | setView(short field_32_view) Set the view field for the DOP record.
void | setVirusinfo(int field_43_virusinfo) Set the virusinfo field for the DOP record.
void | setWScaleSaved(short value) Sets the wScaleSaved field value.
void | setWSpare(int field_10_wSpare) Set the wSpare field for the DOP record.
void | setWSpare2(int field_13_wSpare2) Set the wSpare2 field for the DOP record.
void | setWvkSaved(byte value) Sets the wvkSaved field value.
void | setZkSaved(byte value) Sets the zkSaved field value.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_formatFlags

protected byte field_1_formatFlags

field_2_unused2

protected byte field_2_unused2

field_3_footnoteInfo

protected short field_3_footnoteInfo

field_4_fOutlineDirtySave

protected byte field_4_fOutlineDirtySave

field_5_docinfo

protected byte field_5_docinfo

field_6_docinfo1

protected byte field_6_docinfo1

field_7_docinfo2

protected byte field_7_docinfo2

field_8_docinfo3

protected short field_8_docinfo3

field_9_dxaTab

protected int field_9_dxaTab

field_10_wSpare

protected int field_10_wSpare

field_11_dxaHotz

protected int field_11_dxaHotz

field_12_cConsexHypLim

protected int field_12_cConsexHypLim

field_13_wSpare2

protected int field_13_wSpare2

field_14_dttmCreated

protected int field_14_dttmCreated

field_15_dttmRevised

protected int field_15_dttmRevised

field_16_dttmLastPrint

protected int field_16_dttmLastPrint

field_17_nRevision

protected int field_17_nRevision

field_18_tmEdited

protected int field_18_tmEdited

field_19_cWords

protected int field_19_cWords

field_20_cCh

protected int field_20_cCh

field_21_cPg

protected int field_21_cPg

field_22_cParas

protected int field_22_cParas

field_23_Edn

protected short field_23_Edn

field_24_Edn1

protected short field_24_Edn1

field_25_cLines

protected int field_25_cLines

field_26_cWordsFtnEnd

protected int field_26_cWordsFtnEnd

field_27_cChFtnEdn

protected int field_27_cChFtnEdn

field_28_cPgFtnEdn

protected short field_28_cPgFtnEdn

field_29_cParasFtnEdn

protected int field_29_cParasFtnEdn

field_30_cLinesFtnEdn

protected int field_30_cLinesFtnEdn

field_31_lKeyProtDoc

protected int field_31_lKeyProtDoc

field_32_view

protected short field_32_view

field_33_docinfo4

protected int field_33_docinfo4

field_34_adt

protected short field_34_adt

field_35_doptypography

protected byte[] field_35_doptypography

field_36_dogrid

protected byte[] field_36_dogrid

field_37_docinfo5

protected short field_37_docinfo5

field_38_docinfo6

protected short field_38_docinfo6

field_39_asumyi

protected byte[] field_39_asumyi

field_40_cChWS

protected int field_40_cChWS

field_41_cChWSFtnEdn

protected int field_41_cChWSFtnEdn

field_42_grfDocEvents

protected int field_42_grfDocEvents

field_43_virusinfo

protected int field_43_virusinfo

field_44_Spare

protected byte[] field_44_Spare

field_45_reserved1

protected int field_45_reserved1

field_46_reserved2

protected int field_46_reserved2

field_47_cDBC

protected int field_47_cDBC

field_48_cDBCFtnEdn

protected int field_48_cDBCFtnEdn

field_49_reserved

protected int field_49_reserved

field_50_nfcFtnRef

protected short field_50_nfcFtnRef

field_51_nfcEdnRef

protected short field_51_nfcEdnRef

field_52_hpsZoonFontPag

protected short field_52_hpsZoonFontPag

field_53_dywDispPag

protected short field_53_dywDispPag
Constructor Detail

DOPAbstractType

protected DOPAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getFormatFlags

@Internal
public byte getFormatFlags()
Get the formatFlags field for the DOP record.

setFormatFlags

@Internal
public void setFormatFlags(byte field_1_formatFlags)
Set the formatFlags field for the DOP record.

getUnused2

@Internal
public byte getUnused2()
Get the unused2 field for the DOP record.

setUnused2

@Internal
public void setUnused2(byte field_2_unused2)
Set the unused2 field for the DOP record.

getFootnoteInfo

@Internal
public short getFootnoteInfo()
Get the footnoteInfo field for the DOP record.

setFootnoteInfo

@Internal
public void setFootnoteInfo(short field_3_footnoteInfo)
Set the footnoteInfo field for the DOP record.

getFOutlineDirtySave

@Internal
public byte getFOutlineDirtySave()
Get the fOutlineDirtySave field for the DOP record.

setFOutlineDirtySave

@Internal
public void setFOutlineDirtySave(byte field_4_fOutlineDirtySave)
Set the fOutlineDirtySave field for the DOP record.

getDocinfo

@Internal
public byte getDocinfo()
Get the docinfo field for the DOP record.

setDocinfo

@Internal
public void setDocinfo(byte field_5_docinfo)
Set the docinfo field for the DOP record.

getDocinfo1

@Internal
public byte getDocinfo1()
Get the docinfo1 field for the DOP record.

setDocinfo1

@Internal
public void setDocinfo1(byte field_6_docinfo1)
Set the docinfo1 field for the DOP record.

getDocinfo2

@Internal
public byte getDocinfo2()
Get the docinfo2 field for the DOP record.

setDocinfo2

@Internal
public void setDocinfo2(byte field_7_docinfo2)
Set the docinfo2 field for the DOP record.

getDocinfo3

@Internal
public short getDocinfo3()
Get the docinfo3 field for the DOP record.

setDocinfo3

@Internal
public void setDocinfo3(short field_8_docinfo3)
Set the docinfo3 field for the DOP record.

getDxaTab

@Internal
public int getDxaTab()
Get the dxaTab field for the DOP record.

setDxaTab

@Internal
public void setDxaTab(int field_9_dxaTab)
Set the dxaTab field for the DOP record.

getWSpare

@Internal
public int getWSpare()
Get the wSpare field for the DOP record.

setWSpare

@Internal
public void setWSpare(int field_10_wSpare)
Set the wSpare field for the DOP record.

getDxaHotz

@Internal
public int getDxaHotz()
Get the dxaHotz field for the DOP record.

setDxaHotz

@Internal
public void setDxaHotz(int field_11_dxaHotz)
Set the dxaHotz field for the DOP record.

getCConsexHypLim

@Internal
public int getCConsexHypLim()
Get the cConsexHypLim field for the DOP record.

setCConsexHypLim

@Internal
public void setCConsexHypLim(int field_12_cConsexHypLim)
Set the cConsexHypLim field for the DOP record.

getWSpare2

@Internal
public int getWSpare2()
Get the wSpare2 field for the DOP record.

setWSpare2

@Internal
public void setWSpare2(int field_13_wSpare2)
Set the wSpare2 field for the DOP record.

getDttmCreated

@Internal
public int getDttmCreated()
Get the dttmCreated field for the DOP record.

setDttmCreated

@Internal
public void setDttmCreated(int field_14_dttmCreated)
Set the dttmCreated field for the DOP record.

getDttmRevised

@Internal
public int getDttmRevised()
Get the dttmRevised field for the DOP record.

setDttmRevised

@Internal
public void setDttmRevised(int field_15_dttmRevised)
Set the dttmRevised field for the DOP record.

getDttmLastPrint

@Internal
public int getDttmLastPrint()
Get the dttmLastPrint field for the DOP record.

setDttmLastPrint

@Internal
public void setDttmLastPrint(int field_16_dttmLastPrint)
Set the dttmLastPrint field for the DOP record.

getNRevision

@Internal
public int getNRevision()
Get the nRevision field for the DOP record.

setNRevision

@Internal
public void setNRevision(int field_17_nRevision)
Set the nRevision field for the DOP record.

getTmEdited

@Internal
public int getTmEdited()
Get the tmEdited field for the DOP record.

setTmEdited

@Internal
public void setTmEdited(int field_18_tmEdited)
Set the tmEdited field for the DOP record.

getCWords

@Internal
public int getCWords()
Get the cWords field for the DOP record.

setCWords

@Internal
public void setCWords(int field_19_cWords)
Set the cWords field for the DOP record.

getCCh

@Internal
public int getCCh()
Get the cCh field for the DOP record.

setCCh

@Internal
public void setCCh(int field_20_cCh)
Set the cCh field for the DOP record.

getCPg

@Internal
public int getCPg()
Get the cPg field for the DOP record.

setCPg

@Internal
public void setCPg(int field_21_cPg)
Set the cPg field for the DOP record.

getCParas

@Internal
public int getCParas()
Get the cParas field for the DOP record.

setCParas

@Internal
public void setCParas(int field_22_cParas)
Set the cParas field for the DOP record.

getEdn

@Internal
public short getEdn()
Get the Edn field for the DOP record.

setEdn

@Internal
public void setEdn(short field_23_Edn)
Set the Edn field for the DOP record.

getEdn1

@Internal
public short getEdn1()
Get the Edn1 field for the DOP record.

setEdn1

@Internal
public void setEdn1(short field_24_Edn1)
Set the Edn1 field for the DOP record.

getCLines

@Internal
public int getCLines()
Get the cLines field for the DOP record.

setCLines

@Internal
public void setCLines(int field_25_cLines)
Set the cLines field for the DOP record.

getCWordsFtnEnd

@Internal
public int getCWordsFtnEnd()
Get the cWordsFtnEnd field for the DOP record.

setCWordsFtnEnd

@Internal
public void setCWordsFtnEnd(int field_26_cWordsFtnEnd)
Set the cWordsFtnEnd field for the DOP record.

getCChFtnEdn

@Internal
public int getCChFtnEdn()
Get the cChFtnEdn field for the DOP record.

setCChFtnEdn

@Internal
public void setCChFtnEdn(int field_27_cChFtnEdn)
Set the cChFtnEdn field for the DOP record.

getCPgFtnEdn

@Internal
public short getCPgFtnEdn()
Get the cPgFtnEdn field for the DOP record.

setCPgFtnEdn

@Internal
public void setCPgFtnEdn(short field_28_cPgFtnEdn)
Set the cPgFtnEdn field for the DOP record.

getCParasFtnEdn

@Internal
public int getCParasFtnEdn()
Get the cParasFtnEdn field for the DOP record.

setCParasFtnEdn

@Internal
public void setCParasFtnEdn(int field_29_cParasFtnEdn)
Set the cParasFtnEdn field for the DOP record.

getCLinesFtnEdn

@Internal
public int getCLinesFtnEdn()
Get the cLinesFtnEdn field for the DOP record.

setCLinesFtnEdn

@Internal
public void setCLinesFtnEdn(int field_30_cLinesFtnEdn)
Set the cLinesFtnEdn field for the DOP record.

getLKeyProtDoc

@Internal
public int getLKeyProtDoc()
Get the lKeyProtDoc field for the DOP record.

setLKeyProtDoc

@Internal
public void setLKeyProtDoc(int field_31_lKeyProtDoc)
Set the lKeyProtDoc field for the DOP record.

getView

@Internal
public short getView()
Get the view field for the DOP record.

setView

@Internal
public void setView(short field_32_view)
Set the view field for the DOP record.

getDocinfo4

@Internal
public int getDocinfo4()
Get the docinfo4 field for the DOP record.

setDocinfo4

@Internal
public void setDocinfo4(int field_33_docinfo4)
Set the docinfo4 field for the DOP record.

getAdt

@Internal
public short getAdt()
Get the adt field for the DOP record.

setAdt

@Internal
public void setAdt(short field_34_adt)
Set the adt field for the DOP record.

getDoptypography

@Internal
public byte[] getDoptypography()
Get the doptypography field for the DOP record.

setDoptypography

@Internal
public void setDoptypography(byte[] field_35_doptypography)
Set the doptypography field for the DOP record.

getDogrid

@Internal
public byte[] getDogrid()
Get the dogrid field for the DOP record.

setDogrid

@Internal
public void setDogrid(byte[] field_36_dogrid)
Set the dogrid field for the DOP record.

getDocinfo5

@Internal
public short getDocinfo5()
Get the docinfo5 field for the DOP record.

setDocinfo5

@Internal
public void setDocinfo5(short field_37_docinfo5)
Set the docinfo5 field for the DOP record.

getDocinfo6

@Internal
public short getDocinfo6()
Get the docinfo6 field for the DOP record.

setDocinfo6

@Internal
public void setDocinfo6(short field_38_docinfo6)
Set the docinfo6 field for the DOP record.

getAsumyi

@Internal
public byte[] getAsumyi()
Get the asumyi field for the DOP record.

setAsumyi

@Internal
public void setAsumyi(byte[] field_39_asumyi)
Set the asumyi field for the DOP record.

getCChWS

@Internal
public int getCChWS()
Get the cChWS field for the DOP record.

setCChWS

@Internal
public void setCChWS(int field_40_cChWS)
Set the cChWS field for the DOP record.

getCChWSFtnEdn

@Internal
public int getCChWSFtnEdn()
Get the cChWSFtnEdn field for the DOP record.

setCChWSFtnEdn

@Internal
public void setCChWSFtnEdn(int field_41_cChWSFtnEdn)
Set the cChWSFtnEdn field for the DOP record.

getGrfDocEvents

@Internal
public int getGrfDocEvents()
Get the grfDocEvents field for the DOP record.

setGrfDocEvents

@Internal
public void setGrfDocEvents(int field_42_grfDocEvents)
Set the grfDocEvents field for the DOP record.

getVirusinfo

@Internal
public int getVirusinfo()
Get the virusinfo field for the DOP record.

setVirusinfo

@Internal
public void setVirusinfo(int field_43_virusinfo)
Set the virusinfo field for the DOP record.

getSpare

@Internal
public byte[] getSpare()
Get the Spare field for the DOP record.

setSpare

@Internal
public void setSpare(byte[] field_44_Spare)
Set the Spare field for the DOP record.

getReserved1

@Internal
public int getReserved1()
Get the reserved1 field for the DOP record.

setReserved1

@Internal
public void setReserved1(int field_45_reserved1)
Set the reserved1 field for the DOP record.

getReserved2

@Internal
public int getReserved2()
Get the reserved2 field for the DOP record.

setReserved2

@Internal
public void setReserved2(int field_46_reserved2)
Set the reserved2 field for the DOP record.

getCDBC

@Internal
public int getCDBC()
Get the cDBC field for the DOP record.

setCDBC

@Internal
public void setCDBC(int field_47_cDBC)
Set the cDBC field for the DOP record.

getCDBCFtnEdn

@Internal
public int getCDBCFtnEdn()
Get the cDBCFtnEdn field for the DOP record.

setCDBCFtnEdn

@Internal
public void setCDBCFtnEdn(int field_48_cDBCFtnEdn)
Set the cDBCFtnEdn field for the DOP record.

getReserved

@Internal
public int getReserved()
Get the reserved field for the DOP record.

setReserved

@Internal
public void setReserved(int field_49_reserved)
Set the reserved field for the DOP record.

getNfcFtnRef

@Internal
public short getNfcFtnRef()
Get the nfcFtnRef field for the DOP record.

setNfcFtnRef

@Internal
public void setNfcFtnRef(short field_50_nfcFtnRef)
Set the nfcFtnRef field for the DOP record.

getNfcEdnRef

@Internal
public short getNfcEdnRef()
Get the nfcEdnRef field for the DOP record.

setNfcEdnRef

@Internal
public void setNfcEdnRef(short field_51_nfcEdnRef)
Set the nfcEdnRef field for the DOP record.

getHpsZoonFontPag

@Internal
public short getHpsZoonFontPag()
Get the hpsZoonFontPag field for the DOP record.

setHpsZoonFontPag

@Internal
public void setHpsZoonFontPag(short field_52_hpsZoonFontPag)
Set the hpsZoonFontPag field for the DOP record.

getDywDispPag

@Internal
public short getDywDispPag()
Get the dywDispPag field for the DOP record.

setDywDispPag

@Internal
public void setDywDispPag(short field_53_dywDispPag)
Set the dywDispPag field for the DOP record.

setFFacingPages

@Internal
public void setFFacingPages(boolean value)
Sets the fFacingPages field value.

isFFacingPages

@Internal
public boolean isFFacingPages()
Returns:
the fFacingPages field value.

setFWidowControl

@Internal
public void setFWidowControl(boolean value)
Sets the fWidowControl field value.

isFWidowControl

@Internal
public boolean isFWidowControl()
Returns:
the fWidowControl field value.

setFPMHMainDoc

@Internal
public void setFPMHMainDoc(boolean value)
Sets the fPMHMainDoc field value.

isFPMHMainDoc

@Internal
public boolean isFPMHMainDoc()
Returns:
the fPMHMainDoc field value.

setGrfSupression

@Internal
public void setGrfSupression(byte value)
Sets the grfSupression field value.

getGrfSupression

@Internal
public byte getGrfSupression()
Returns:
the grfSupression field value.

setFpc

@Internal
public void setFpc(byte value)
Sets the fpc field value.

getFpc

@Internal
public byte getFpc()
Returns:
the fpc field value.

setUnused1

@Internal
public void setUnused1(boolean value)
Sets the unused1 field value.

isUnused1

@Internal
public boolean isUnused1()
Returns:
the unused1 field value.

setRncFtn

@Internal
public void setRncFtn(byte value)
Sets the rncFtn field value.

getRncFtn

@Internal
public byte getRncFtn()
Returns:
the rncFtn field value.

setNFtn

@Internal
public void setNFtn(short value)
Sets the nFtn field value.

getNFtn

@Internal
public short getNFtn()
Returns:
the nFtn field value.

setFOnlyMacPics

@Internal
public void setFOnlyMacPics(boolean value)
Sets the fOnlyMacPics field value.

isFOnlyMacPics

@Internal
public boolean isFOnlyMacPics()
Returns:
the fOnlyMacPics field value.

setFOnlyWinPics

@Internal
public void setFOnlyWinPics(boolean value)
Sets the fOnlyWinPics field value.

isFOnlyWinPics

@Internal
public boolean isFOnlyWinPics()
Returns:
the fOnlyWinPics field value.

setFLabelDoc

@Internal
public void setFLabelDoc(boolean value)
Sets the fLabelDoc field value.

isFLabelDoc

@Internal
public boolean isFLabelDoc()
Returns:
the fLabelDoc field value.

setFHyphCapitals

@Internal
public void setFHyphCapitals(boolean value)
Sets the fHyphCapitals field value.

isFHyphCapitals

@Internal
public boolean isFHyphCapitals()
Returns:
the fHyphCapitals field value.

setFAutoHyphen

@Internal
public void setFAutoHyphen(boolean value)
Sets the fAutoHyphen field value.

isFAutoHyphen

@Internal
public boolean isFAutoHyphen()
Returns:
the fAutoHyphen field value.

setFFormNoFields

@Internal
public void setFFormNoFields(boolean value)
Sets the fFormNoFields field value.

isFFormNoFields

@Internal
public boolean isFFormNoFields()
Returns:
the fFormNoFields field value.

setFLinkStyles

@Internal
public void setFLinkStyles(boolean value)
Sets the fLinkStyles field value.

isFLinkStyles

@Internal
public boolean isFLinkStyles()
Returns:
the fLinkStyles field value.

setFRevMarking

@Internal
public void setFRevMarking(boolean value)
Sets the fRevMarking field value.

isFRevMarking

@Internal
public boolean isFRevMarking()
Returns:
the fRevMarking field value.

setFBackup

@Internal
public void setFBackup(boolean value)
Sets the fBackup field value.

isFBackup

@Internal
public boolean isFBackup()
Returns:
the fBackup field value.

setFExactCWords

@Internal
public void setFExactCWords(boolean value)
Sets the fExactCWords field value.

isFExactCWords

@Internal
public boolean isFExactCWords()
Returns:
the fExactCWords field value.

setFPagHidden

@Internal
public void setFPagHidden(boolean value)
Sets the fPagHidden field value.

isFPagHidden

@Internal
public boolean isFPagHidden()
Returns:
the fPagHidden field value.

setFPagResults

@Internal
public void setFPagResults(boolean value)
Sets the fPagResults field value.

isFPagResults

@Internal
public boolean isFPagResults()
Returns:
the fPagResults field value.

setFLockAtn

@Internal
public void setFLockAtn(boolean value)
Sets the fLockAtn field value.

isFLockAtn

@Internal
public boolean isFLockAtn()
Returns:
the fLockAtn field value.

setFMirrorMargins

@Internal
public void setFMirrorMargins(boolean value)
Sets the fMirrorMargins field value.

isFMirrorMargins

@Internal
public boolean isFMirrorMargins()
Returns:
the fMirrorMargins field value.

setUnused3

@Internal
public void setUnused3(boolean value)
Sets the unused3 field value.

isUnused3

@Internal
public boolean isUnused3()
Returns:
the unused3 field value.

setFDfltTrueType

@Internal
public void setFDfltTrueType(boolean value)
Sets the fDfltTrueType field value.

isFDfltTrueType

@Internal
public boolean isFDfltTrueType()
Returns:
the fDfltTrueType field value.

setFPagSupressTopSpacing

@Internal
public void setFPagSupressTopSpacing(boolean value)
Sets the fPagSupressTopSpacing field value.

isFPagSupressTopSpacing

@Internal
public boolean isFPagSupressTopSpacing()
Returns:
the fPagSupressTopSpacing field value.

setFProtEnabled

@Internal
public void setFProtEnabled(boolean value)
Sets the fProtEnabled field value.

isFProtEnabled

@Internal
public boolean isFProtEnabled()
Returns:
the fProtEnabled field value.

setFDispFormFldSel

@Internal
public void setFDispFormFldSel(boolean value)
Sets the fDispFormFldSel field value.

isFDispFormFldSel

@Internal
public boolean isFDispFormFldSel()
Returns:
the fDispFormFldSel field value.

setFRMView

@Internal
public void setFRMView(boolean value)
Sets the fRMView field value.

isFRMView

@Internal
public boolean isFRMView()
Returns:
the fRMView field value.

setFRMPrint

@Internal
public void setFRMPrint(boolean value)
Sets the fRMPrint field value.

isFRMPrint

@Internal
public boolean isFRMPrint()
Returns:
the fRMPrint field value.

setUnused4

@Internal
public void setUnused4(boolean value)
Sets the unused4 field value.

isUnused4

@Internal
public boolean isUnused4()
Returns:
the unused4 field value.

setFLockRev

@Internal
public void setFLockRev(boolean value)
Sets the fLockRev field value.

isFLockRev

@Internal
public boolean isFLockRev()
Returns:
the fLockRev field value.

setFEmbedFonts

@Internal
public void setFEmbedFonts(boolean value)
Sets the fEmbedFonts field value.

isFEmbedFonts

@Internal
public boolean isFEmbedFonts()
Returns:
the fEmbedFonts field value.

setOldfNoTabForInd

@Internal
public void setOldfNoTabForInd(boolean value)
Sets the oldfNoTabForInd field value.

isOldfNoTabForInd

@Internal
public boolean isOldfNoTabForInd()
Returns:
the oldfNoTabForInd field value.

setOldfNoSpaceRaiseLower

@Internal
public void setOldfNoSpaceRaiseLower(boolean value)
Sets the oldfNoSpaceRaiseLower field value.

isOldfNoSpaceRaiseLower

@Internal
public boolean isOldfNoSpaceRaiseLower()
Returns:
the oldfNoSpaceRaiseLower field value.

setOldfSuppressSpbfAfterPageBreak

@Internal
public void setOldfSuppressSpbfAfterPageBreak(boolean value)
Sets the oldfSuppressSpbfAfterPageBreak field value.

isOldfSuppressSpbfAfterPageBreak

@Internal
public boolean isOldfSuppressSpbfAfterPageBreak()
Returns:
the oldfSuppressSpbfAfterPageBreak field value.

setOldfWrapTrailSpaces

@Internal
public void setOldfWrapTrailSpaces(boolean value)
Sets the oldfWrapTrailSpaces field value.

isOldfWrapTrailSpaces

@Internal
public boolean isOldfWrapTrailSpaces()
Returns:
the oldfWrapTrailSpaces field value.

setOldfMapPrintTextColor

@Internal
public void setOldfMapPrintTextColor(boolean value)
Sets the oldfMapPrintTextColor field value.

isOldfMapPrintTextColor

@Internal
public boolean isOldfMapPrintTextColor()
Returns:
the oldfMapPrintTextColor field value.

setOldfNoColumnBalance

@Internal
public void setOldfNoColumnBalance(boolean value)
Sets the oldfNoColumnBalance field value.

isOldfNoColumnBalance

@Internal
public boolean isOldfNoColumnBalance()
Returns:
the oldfNoColumnBalance field value.

setOldfConvMailMergeEsc

@Internal
public void setOldfConvMailMergeEsc(boolean value)
Sets the oldfConvMailMergeEsc field value.

isOldfConvMailMergeEsc

@Internal
public boolean isOldfConvMailMergeEsc()
Returns:
the oldfConvMailMergeEsc field value.

setOldfSupressTopSpacing

@Internal
public void setOldfSupressTopSpacing(boolean value)
Sets the oldfSupressTopSpacing field value.

isOldfSupressTopSpacing

@Internal
public boolean isOldfSupressTopSpacing()
Returns:
the oldfSupressTopSpacing field value.

setOldfOrigWordTableRules

@Internal
public void setOldfOrigWordTableRules(boolean value)
Sets the oldfOrigWordTableRules field value.

isOldfOrigWordTableRules

@Internal
public boolean isOldfOrigWordTableRules()
Returns:
the oldfOrigWordTableRules field value.

setOldfTransparentMetafiles

@Internal
public void setOldfTransparentMetafiles(boolean value)
Sets the oldfTransparentMetafiles field value.

isOldfTransparentMetafiles

@Internal
public boolean isOldfTransparentMetafiles()
Returns:
the oldfTransparentMetafiles field value.

setOldfShowBreaksInFrames

@Internal
public void setOldfShowBreaksInFrames(boolean value)
Sets the oldfShowBreaksInFrames field value.

isOldfShowBreaksInFrames

@Internal
public boolean isOldfShowBreaksInFrames()
Returns:
the oldfShowBreaksInFrames field value.

setOldfSwapBordersFacingPgs

@Internal
public void setOldfSwapBordersFacingPgs(boolean value)
Sets the oldfSwapBordersFacingPgs field value.

isOldfSwapBordersFacingPgs

@Internal
public boolean isOldfSwapBordersFacingPgs()
Returns:
the oldfSwapBordersFacingPgs field value.

setUnused5

@Internal
public void setUnused5(byte value)
Sets the unused5 field value.

getUnused5

@Internal
public byte getUnused5()
Returns:
the unused5 field value.

setRncEdn

@Internal
public void setRncEdn(byte value)
Sets the rncEdn field value.

getRncEdn

@Internal
public byte getRncEdn()
Returns:
the rncEdn field value.

setNEdn

@Internal
public void setNEdn(short value)
Sets the nEdn field value.

getNEdn

@Internal
public short getNEdn()
Returns:
the nEdn field value.

setEpc

@Internal
public void setEpc(byte value)
Sets the epc field value.

getEpc

@Internal
public byte getEpc()
Returns:
the epc field value.

setNfcFtnRef1

@Internal
public void setNfcFtnRef1(byte value)
Sets the nfcFtnRef1 field value.

getNfcFtnRef1

@Internal
public byte getNfcFtnRef1()
Returns:
the nfcFtnRef1 field value.

setNfcEdnRef1

@Internal
public void setNfcEdnRef1(byte value)
Sets the nfcEdnRef1 field value.

getNfcEdnRef1

@Internal
public byte getNfcEdnRef1()
Returns:
the nfcEdnRef1 field value.

setFPrintFormData

@Internal
public void setFPrintFormData(boolean value)
Sets the fPrintFormData field value.

isFPrintFormData

@Internal
public boolean isFPrintFormData()
Returns:
the fPrintFormData field value.

setFSaveFormData

@Internal
public void setFSaveFormData(boolean value)
Sets the fSaveFormData field value.

isFSaveFormData

@Internal
public boolean isFSaveFormData()
Returns:
the fSaveFormData field value.

setFShadeFormData

@Internal
public void setFShadeFormData(boolean value)
Sets the fShadeFormData field value.

isFShadeFormData

@Internal
public boolean isFShadeFormData()
Returns:
the fShadeFormData field value.

setFWCFtnEdn

@Internal
public void setFWCFtnEdn(boolean value)
Sets the fWCFtnEdn field value.

isFWCFtnEdn

@Internal
public boolean isFWCFtnEdn()
Returns:
the fWCFtnEdn field value.

setWvkSaved

@Internal
public void setWvkSaved(byte value)
Sets the wvkSaved field value.

getWvkSaved

@Internal
public byte getWvkSaved()
Returns:
the wvkSaved field value.

setWScaleSaved

@Internal
public void setWScaleSaved(short value)
Sets the wScaleSaved field value.

getWScaleSaved

@Internal
public short getWScaleSaved()
Returns:
the wScaleSaved field value.

setZkSaved

@Internal
public void setZkSaved(byte value)
Sets the zkSaved field value.

getZkSaved

@Internal
public byte getZkSaved()
Returns:
the zkSaved field value.

setFRotateFontW6

@Internal
public void setFRotateFontW6(boolean value)
Sets the fRotateFontW6 field value.

isFRotateFontW6

@Internal
public boolean isFRotateFontW6()
Returns:
the fRotateFontW6 field value.

setIGutterPos

@Internal
public void setIGutterPos(boolean value)
Sets the iGutterPos field value.

isIGutterPos

@Internal
public boolean isIGutterPos()
Returns:
the iGutterPos field value.

setFNoTabForInd

@Internal
public void setFNoTabForInd(boolean value)
Sets the fNoTabForInd field value.

isFNoTabForInd

@Internal
public boolean isFNoTabForInd()
Returns:
the fNoTabForInd field value.

setFNoSpaceRaiseLower

@Internal
public void setFNoSpaceRaiseLower(boolean value)
Sets the fNoSpaceRaiseLower field value.

isFNoSpaceRaiseLower

@Internal
public boolean isFNoSpaceRaiseLower()
Returns:
the fNoSpaceRaiseLower field value.

setFSupressSpdfAfterPageBreak

@Internal
public void setFSupressSpdfAfterPageBreak(boolean value)
Sets the fSupressSpdfAfterPageBreak field value.

isFSupressSpdfAfterPageBreak

@Internal
public boolean isFSupressSpdfAfterPageBreak()
Returns:
the fSupressSpdfAfterPageBreak field value.

setFWrapTrailSpaces

@Internal
public void setFWrapTrailSpaces(boolean value)
Sets the fWrapTrailSpaces field value.

isFWrapTrailSpaces

@Internal
public boolean isFWrapTrailSpaces()
Returns:
the fWrapTrailSpaces field value.

setFMapPrintTextColor

@Internal
public void setFMapPrintTextColor(boolean value)
Sets the fMapPrintTextColor field value.

isFMapPrintTextColor

@Internal
public boolean isFMapPrintTextColor()
Returns:
the fMapPrintTextColor field value.

setFNoColumnBalance

@Internal
public void setFNoColumnBalance(boolean value)
Sets the fNoColumnBalance field value.

isFNoColumnBalance

@Internal
public boolean isFNoColumnBalance()
Returns:
the fNoColumnBalance field value.

setFConvMailMergeEsc

@Internal
public void setFConvMailMergeEsc(boolean value)
Sets the fConvMailMergeEsc field value.

isFConvMailMergeEsc

@Internal
public boolean isFConvMailMergeEsc()
Returns:
the fConvMailMergeEsc field value.

setFSupressTopSpacing

@Internal
public void setFSupressTopSpacing(boolean value)
Sets the fSupressTopSpacing field value.

isFSupressTopSpacing

@Internal
public boolean isFSupressTopSpacing()
Returns:
the fSupressTopSpacing field value.

setFOrigWordTableRules

@Internal
public void setFOrigWordTableRules(boolean value)
Sets the fOrigWordTableRules field value.

isFOrigWordTableRules

@Internal
public boolean isFOrigWordTableRules()
Returns:
the fOrigWordTableRules field value.

setFTransparentMetafiles

@Internal
public void setFTransparentMetafiles(boolean value)
Sets the fTransparentMetafiles field value.

isFTransparentMetafiles

@Internal
public boolean isFTransparentMetafiles()
Returns:
the fTransparentMetafiles field value.

setFShowBreaksInFrames

@Internal
public void setFShowBreaksInFrames(boolean value)
Sets the fShowBreaksInFrames field value.

isFShowBreaksInFrames

@Internal
public boolean isFShowBreaksInFrames()
Returns:
the fShowBreaksInFrames field value.

setFSwapBordersFacingPgs

@Internal
public void setFSwapBordersFacingPgs(boolean value)
Sets the fSwapBordersFacingPgs field value.

isFSwapBordersFacingPgs

@Internal
public boolean isFSwapBordersFacingPgs()
Returns:
the fSwapBordersFacingPgs field value.

setFSuppressTopSPacingMac5

@Internal
public void setFSuppressTopSPacingMac5(boolean value)
Sets the fSuppressTopSPacingMac5 field value.

isFSuppressTopSPacingMac5

@Internal
public boolean isFSuppressTopSPacingMac5()
Returns:
the fSuppressTopSPacingMac5 field value.

setFTruncDxaExpand

@Internal
public void setFTruncDxaExpand(boolean value)
Sets the fTruncDxaExpand field value.

isFTruncDxaExpand

@Internal
public boolean isFTruncDxaExpand()
Returns:
the fTruncDxaExpand field value.

setFPrintBodyBeforeHdr

@Internal
public void setFPrintBodyBeforeHdr(boolean value)
Sets the fPrintBodyBeforeHdr field value.

isFPrintBodyBeforeHdr

@Internal
public boolean isFPrintBodyBeforeHdr()
Returns:
the fPrintBodyBeforeHdr field value.

setFNoLeading

@Internal
public void setFNoLeading(boolean value)
Sets the fNoLeading field value.

isFNoLeading

@Internal
public boolean isFNoLeading()
Returns:
the fNoLeading field value.

setFMWSmallCaps

@Internal
public void setFMWSmallCaps(boolean value)
Sets the fMWSmallCaps field value.

isFMWSmallCaps

@Internal
public boolean isFMWSmallCaps()
Returns:
the fMWSmallCaps field value.

setLvl

@Internal
public void setLvl(byte value)
Sets the lvl field value.

getLvl

@Internal
public byte getLvl()
Returns:
the lvl field value.

setFGramAllDone

@Internal
public void setFGramAllDone(boolean value)
Sets the fGramAllDone field value.

isFGramAllDone

@Internal
public boolean isFGramAllDone()
Returns:
the fGramAllDone field value.

setFGramAllClean

@Internal
public void setFGramAllClean(boolean value)
Sets the fGramAllClean field value.

isFGramAllClean

@Internal
public boolean isFGramAllClean()
Returns:
the fGramAllClean field value.

setFSubsetFonts

@Internal
public void setFSubsetFonts(boolean value)
Sets the fSubsetFonts field value.

isFSubsetFonts

@Internal
public boolean isFSubsetFonts()
Returns:
the fSubsetFonts field value.

setFHideLastVersion

@Internal
public void setFHideLastVersion(boolean value)
Sets the fHideLastVersion field value.

isFHideLastVersion

@Internal
public boolean isFHideLastVersion()
Returns:
the fHideLastVersion field value.

setFHtmlDoc

@Internal
public void setFHtmlDoc(boolean value)
Sets the fHtmlDoc field value.

isFHtmlDoc

@Internal
public boolean isFHtmlDoc()
Returns:
the fHtmlDoc field value.

setFSnapBorder

@Internal
public void setFSnapBorder(boolean value)
Sets the fSnapBorder field value.

isFSnapBorder

@Internal
public boolean isFSnapBorder()
Returns:
the fSnapBorder field value.

setFIncludeHeader

@Internal
public void setFIncludeHeader(boolean value)
Sets the fIncludeHeader field value.

isFIncludeHeader

@Internal
public boolean isFIncludeHeader()
Returns:
the fIncludeHeader field value.

setFIncludeFooter

@Internal
public void setFIncludeFooter(boolean value)
Sets the fIncludeFooter field value.

isFIncludeFooter

@Internal
public boolean isFIncludeFooter()
Returns:
the fIncludeFooter field value.

setFForcePageSizePag

@Internal
public void setFForcePageSizePag(boolean value)
Sets the fForcePageSizePag field value.

isFForcePageSizePag

@Internal
public boolean isFForcePageSizePag()
Returns:
the fForcePageSizePag field value.

setFMinFontSizePag

@Internal
public void setFMinFontSizePag(boolean value)
Sets the fMinFontSizePag field value.

isFMinFontSizePag

@Internal
public boolean isFMinFontSizePag()
Returns:
the fMinFontSizePag field value.

setFHaveVersions

@Internal
public void setFHaveVersions(boolean value)
Sets the fHaveVersions field value.

isFHaveVersions

@Internal
public boolean isFHaveVersions()
Returns:
the fHaveVersions field value.

setFAutoVersions

@Internal
public void setFAutoVersions(boolean value)
Sets the fAutoVersions field value.

isFAutoVersions

@Internal
public boolean isFAutoVersions()
Returns:
the fAutoVersions field value.

setFVirusPrompted

@Internal
public void setFVirusPrompted(boolean value)
Sets the fVirusPrompted field value.

isFVirusPrompted

@Internal
public boolean isFVirusPrompted()
Returns:
the fVirusPrompted field value.

setFVirusLoadSafe

@Internal
public void setFVirusLoadSafe(boolean value)
Sets the fVirusLoadSafe field value.

isFVirusLoadSafe

@Internal
public boolean isFVirusLoadSafe()
Returns:
the fVirusLoadSafe field value.

setKeyVirusSession30

@Internal
public void setKeyVirusSession30(int value)
Sets the KeyVirusSession30 field value.

getKeyVirusSession30

@Internal
public int getKeyVirusSession30()
Returns:
the KeyVirusSession30 field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FibBaseAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class FibBaseAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FibBaseAbstractType
Direct Known Subclasses:
FibBase
@Internal
public abstract class FibBaseAbstractType
extends java.lang.Object

Base part of the File information Block (FibBase). Holds the core part of the FIB, from the first 32 bytes.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Andrew C. Oliver; Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected int | field_1_wIdent
protected byte | field_10_flags2
protected short | field_11_Chs Deprecated.
protected short | field_12_chsTables Deprecated.
protected int | field_13_fcMin Deprecated.
protected int | field_14_fcMac Deprecated.
protected int | field_2_nFib
protected int | field_3_unused
protected int | field_4_lid
protected int | field_5_pnNext
protected short | field_6_flags1
protected int | field_7_nFibBack
protected int | field_8_lKey
protected byte | field_9_envr Deprecated.
Constructor Summary
protected FibBaseAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
short | getChs() This value MUST be 0 and MUST be ignored.
short | getChsTables() This value MUST be 0 and MUST be ignored.
byte | getCQuickSaves() An unsigned integer.
byte | getEnvr() This value MUST be 0, and MUST be ignored.
int | getFcMac() This value is undefined and MUST be ignored.
int | getFcMin() This value is undefined and MUST be ignored.
short | getFlags1() Get the flags1 field for the FibBase record.
byte | getFlags2() Get the flags2 field for the FibBase record.
byte | getFSpare0() Deprecated. This field should not be used according to specification
int | getLid() A LID that specifies the install language of the application that is producing the document.
int | getLKey() If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier.
int | getNFib() An unsigned integer that specifies the version number of the file format used.
int | getNFibBack() This value SHOULD be 0x00BF.
int | getPnNext() An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.
static int | getSize() Size of record
int | getUnused() This value is undefined and MUST be ignored.
int | getWIdent() An unsigned integer that specifies that this is a Word Binary File.
boolean | isFComplex() Specifies that the last save operation that was performed on this document was an incremental save operation
boolean | isFDot() Specifies whether this is a document template
boolean | isFEmptySpecial() Deprecated. This field should not be used according to specification
boolean | isFEncrypted() Specifies whether the document is encrypted or obfuscated as specified in Encryption and Obfuscation
boolean | isFExtChar() This value MUST be 1
boolean | isFFarEast() Specifies whether the installation language of the application that created the document was an East Asian language
boolean | isFGlsy() Specifies whether this is a document that contains only AutoText items
boolean | isFHasPic() When set to 0, there SHOULD be no pictures in the document
boolean | isFLoadOverride() Specifies whether to override the language information and font that are specified in the paragraph style at istd 0 (the normal style) with the defaults that are appropriate for the installation language of the application
boolean | isFLoadOverridePage() Specifies whether to override the section properties for page size, orientation, and margins with the defaults that are appropriate for the installation language of the application
boolean | isFMac() Deprecated. This field should not be used according to specification
boolean | isFObfuscated() If fEncrypted is 1, this bit specifies whether the document is obfuscated by using XOR obfuscation; otherwise, this bit MUST be ignored
boolean | isFReadOnlyRecommended() Specifies whether the document author recommended that the document be opened in read-only mode
boolean | isFWhichTblStm() Specifies the Table stream to which the FIB refers.
boolean | isFWriteReservation() Specifies whether the document has a write-reservation password
boolean | isReserved1() Deprecated. This field should not be used according to specification
boolean | isReserved2() Deprecated. This field should not be used according to specification
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setChs(short field_11_Chs) This value MUST be 0 and MUST be ignored.
void | setChsTables(short field_12_chsTables) This value MUST be 0 and MUST be ignored.
void | setCQuickSaves(byte value) Sets the cQuickSaves field value.
void | setEnvr(byte field_9_envr) This value MUST be 0, and MUST be ignored.
void | setFcMac(int field_14_fcMac) This value is undefined and MUST be ignored.
void | setFcMin(int field_13_fcMin) This value is undefined and MUST be ignored.
void | setFComplex(boolean value) Sets the fComplex field value.
void | setFDot(boolean value) Sets the fDot field value.
void | setFEmptySpecial(boolean value) Sets the fEmptySpecial field value.
void | setFEncrypted(boolean value) Sets the fEncrypted field value.
void | setFExtChar(boolean value) Sets the fExtChar field value.
void | setFFarEast(boolean value) Sets the fFarEast field value.
void | setFGlsy(boolean value) Sets the fGlsy field value.
void | setFHasPic(boolean value) Sets the fHasPic field value.
void | setFlags1(short field_6_flags1) Set the flags1 field for the FibBase record.
void | setFlags2(byte field_10_flags2) Set the flags2 field for the FibBase record.
void | setFLoadOverride(boolean value) Sets the fLoadOverride field value.
void | setFLoadOverridePage(boolean value) Sets the fLoadOverridePage field value.
void | setFMac(boolean value) Sets the fMac field value.
void | setFObfuscated(boolean value) Sets the fObfuscated field value.
void | setFReadOnlyRecommended(boolean value) Sets the fReadOnlyRecommended field value.
void | setFSpare0(byte value) Sets the fSpare0 field value.
void | setFWhichTblStm(boolean value) Sets the fWhichTblStm field value.
void | setFWriteReservation(boolean value) Sets the fWriteReservation field value.
void | setLid(int field_4_lid) A LID that specifies the install language of the application that is producing the document.
void | setLKey(int field_8_lKey) If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier.
void | setNFib(int field_2_nFib) An unsigned integer that specifies the version number of the file format used.
void | setNFibBack(int field_7_nFibBack) This value SHOULD be 0x00BF.
void | setPnNext(int field_5_pnNext) An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.
void | setReserved1(boolean value) Sets the reserved1 field value.
void | setReserved2(boolean value) Sets the reserved2 field value.
void | setUnused(int field_3_unused) This value is undefined and MUST be ignored.
void | setWIdent(int field_1_wIdent) An unsigned integer that specifies that this is a Word Binary File.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_wIdent

protected int field_1_wIdent

field_2_nFib

protected int field_2_nFib

field_3_unused

protected int field_3_unused

field_4_lid

protected int field_4_lid

field_5_pnNext

protected int field_5_pnNext

field_6_flags1

protected short field_6_flags1

field_7_nFibBack

protected int field_7_nFibBack

field_8_lKey

protected int field_8_lKey

field_9_envr

@Deprecated
protected byte field_9_envr
Deprecated.

field_10_flags2

protected byte field_10_flags2

field_11_Chs

@Deprecated
protected short field_11_Chs
Deprecated.

field_12_chsTables

@Deprecated
protected short field_12_chsTables
Deprecated.

field_13_fcMin

@Deprecated
protected int field_13_fcMin
Deprecated.

field_14_fcMac

@Deprecated
protected int field_14_fcMac
Deprecated.
Constructor Detail

FibBaseAbstractType

protected FibBaseAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getWIdent

@Internal
public int getWIdent()
An unsigned integer that specifies that this is a Word Binary File. This value MUST be 0xA5EC.

setWIdent

@Internal
public void setWIdent(int field_1_wIdent)
An unsigned integer that specifies that this is a Word Binary File. This value MUST be 0xA5EC.

getNFib

@Internal
public int getNFib()
An unsigned integer that specifies the version number of the file format used. Superseded by FibRgCswNew.nFibNew if it is present. This value SHOULD be 0x00C1.

setNFib

@Internal
public void setNFib(int field_2_nFib)
An unsigned integer that specifies the version number of the file format used. Superseded by FibRgCswNew.nFibNew if it is present. This value SHOULD be 0x00C1.

getUnused

@Internal
public int getUnused()
This value is undefined and MUST be ignored.

setUnused

@Internal
public void setUnused(int field_3_unused)
This value is undefined and MUST be ignored.

getLid

@Internal
public int getLid()
A LID that specifies the install language of the application that is producing the document. If nFib is 0x00D9 or greater, then any East Asian install lid or any install lid with a base language of Spanish, German or French MUST be recorded as lidAmerican. If the nFib is 0x0101 or greater, then any install lid with a base language of Vietnamese, Thai, or Hindi MUST be recorded as lidAmerican..

setLid

@Internal
public void setLid(int field_4_lid)
A LID that specifies the install language of the application that is producing the document. If nFib is 0x00D9 or greater, then any East Asian install lid or any install lid with a base language of Spanish, German or French MUST be recorded as lidAmerican. If the nFib is 0x0101 or greater, then any install lid with a base language of Vietnamese, Thai, or Hindi MUST be recorded as lidAmerican..

getPnNext

@Internal
public int getPnNext()
An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.

setPnNext

@Internal
public void setPnNext(int field_5_pnNext)
An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.

getFlags1

@Internal
public short getFlags1()
Get the flags1 field for the FibBase record.

setFlags1

@Internal
public void setFlags1(short field_6_flags1)
Set the flags1 field for the FibBase record.

getNFibBack

@Internal
public int getNFibBack()
This value SHOULD be 0x00BF. This value MUST be 0x00BF or 0x00C1.

setNFibBack

@Internal
public void setNFibBack(int field_7_nFibBack)
This value SHOULD be 0x00BF. This value MUST be 0x00BF or 0x00C1.

getLKey

@Internal
public int getLKey()
If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier. If fEncryption is 1 and fObfuscation is 0, this value specifies the size of the EncryptionHeader that is stored at the beginning of the Table stream as described in Encryption and Obfuscation. Otherwise, this value MUST be 0.

setLKey

@Internal
public void setLKey(int field_8_lKey)
If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier. If fEncryption is 1 and fObfuscation is 0, this value specifies the size of the EncryptionHeader that is stored at the beginning of the Table stream as described in Encryption and Obfuscation. Otherwise, this value MUST be 0.

getEnvr

@Internal
public byte getEnvr()
This value MUST be 0, and MUST be ignored.

setEnvr

@Internal
public void setEnvr(byte field_9_envr)
This value MUST be 0, and MUST be ignored.

getFlags2

@Internal
public byte getFlags2()
Get the flags2 field for the FibBase record.

setFlags2

@Internal
public void setFlags2(byte field_10_flags2)
Set the flags2 field for the FibBase record.

getChs

@Internal
public short getChs()
This value MUST be 0 and MUST be ignored.

setChs

@Internal
public void setChs(short field_11_Chs)
This value MUST be 0 and MUST be ignored.

getChsTables

@Internal
public short getChsTables()
This value MUST be 0 and MUST be ignored.

setChsTables

@Internal
public void setChsTables(short field_12_chsTables)
This value MUST be 0 and MUST be ignored.

getFcMin

@Internal
public int getFcMin()
This value is undefined and MUST be ignored.

setFcMin

@Internal
public void setFcMin(int field_13_fcMin)
This value is undefined and MUST be ignored.

getFcMac

@Internal
public int getFcMac()
This value is undefined and MUST be ignored.

setFcMac

@Internal
public void setFcMac(int field_14_fcMac)
This value is undefined and MUST be ignored.

setFDot

@Internal
public void setFDot(boolean value)
Sets the fDot field value. Specifies whether this is a document template

isFDot

@Internal
public boolean isFDot()
Specifies whether this is a document template

Returns:
the fDot field value.

setFGlsy

@Internal
public void setFGlsy(boolean value)
Sets the fGlsy field value. Specifies whether this is a document that contains only AutoText items

isFGlsy

@Internal
public boolean isFGlsy()
Specifies whether this is a document that contains only AutoText items

Returns:
the fGlsy field value.

setFComplex

@Internal
public void setFComplex(boolean value)
Sets the fComplex field value. Specifies that the last save operation that was performed on this document was an incremental save operation

isFComplex

@Internal
public boolean isFComplex()
Specifies that the last save operation that was performed on this document was an incremental save operation

Returns:
the fComplex field value.

setFHasPic

@Internal
public void setFHasPic(boolean value)
Sets the fHasPic field value. When set to 0, there SHOULD be no pictures in the document

isFHasPic

@Internal
public boolean isFHasPic()
When set to 0, there SHOULD be no pictures in the document

Returns:
the fHasPic field value.

setCQuickSaves

@Internal
public void setCQuickSaves(byte value)
Sets the cQuickSaves field value. An unsigned integer. If nFib is less than 0x00D9, then cQuickSaves specifies the number of consecutive times this document was incrementally saved. If nFib is 0x00D9 or greater, then cQuickSaves MUST be 0xF

getCQuickSaves

@Internal
public byte getCQuickSaves()
An unsigned integer. If nFib is less than 0x00D9, then cQuickSaves specifies the number of consecutive times this document was incrementally saved. If nFib is 0x00D9 or greater, then cQuickSaves MUST be 0xF

Returns:
the cQuickSaves field value.

setFEncrypted

@Internal
public void setFEncrypted(boolean value)
Sets the fEncrypted field value. Specifies whether the document is encrypted or obfuscated as specified in Encryption and Obfuscation

isFEncrypted

@Internal
public boolean isFEncrypted()
Specifies whether the document is encrypted or obfuscated as specified in Encryption and Obfuscation

Returns:
the fEncrypted field value.

setFWhichTblStm

@Internal
public void setFWhichTblStm(boolean value)
Sets the fWhichTblStm field value. Specifies the Table stream to which the FIB refers. When this value is set to 1, use 1Table; when this value is set to 0, use 0Table.

isFWhichTblStm

@Internal
public boolean isFWhichTblStm()
Specifies the Table stream to which the FIB refers. When this value is set to 1, use 1Table; when this value is set to 0, use 0Table.

Returns:
the fWhichTblStm field value.

setFReadOnlyRecommended

@Internal
public void setFReadOnlyRecommended(boolean value)
Sets the fReadOnlyRecommended field value. Specifies whether the document author recommended that the document be opened in read-only mode

isFReadOnlyRecommended

@Internal
public boolean isFReadOnlyRecommended()
Specifies whether the document author recommended that the document be opened in read-only mode

Returns:
the fReadOnlyRecommended field value.

setFWriteReservation

@Internal
public void setFWriteReservation(boolean value)
Sets the fWriteReservation field value. Specifies whether the document has a write-reservation password

isFWriteReservation

@Internal
public boolean isFWriteReservation()
Specifies whether the document has a write-reservation password

Returns:
the fWriteReservation field value.

setFExtChar

@Internal
public void setFExtChar(boolean value)
Sets the fExtChar field value. This value MUST be 1

isFExtChar

@Internal
public boolean isFExtChar()
This value MUST be 1

Returns:
the fExtChar field value.

setFLoadOverride

@Internal
public void setFLoadOverride(boolean value)
Sets the fLoadOverride field value. Specifies whether to override the language information and font that are specified in the paragraph style at istd 0 (the normal style) with the defaults that are appropriate for the installation language of the application

isFLoadOverride

@Internal
public boolean isFLoadOverride()
Specifies whether to override the language information and font that are specified in the paragraph style at istd 0 (the normal style) with the defaults that are appropriate for the installation language of the application

Returns:
the fLoadOverride field value.

setFFarEast

@Internal
public void setFFarEast(boolean value)
Sets the fFarEast field value. Specifies whether the installation language of the application that created the document was an East Asian language

isFFarEast

@Internal
public boolean isFFarEast()
Specifies whether the installation language of the application that created the document was an East Asian language

Returns:
the fFarEast field value.

setFObfuscated

@Internal
public void setFObfuscated(boolean value)
Sets the fObfuscated field value. If fEncrypted is 1, this bit specifies whether the document is obfuscated by using XOR obfuscation; otherwise, this bit MUST be ignored

isFObfuscated

@Internal
public boolean isFObfuscated()
If fEncrypted is 1, this bit specifies whether the document is obfuscated by using XOR obfuscation; otherwise, this bit MUST be ignored

Returns:
the fObfuscated field value.

setFMac

@Internal
public void setFMac(boolean value)
Sets the fMac field value. This value MUST be 0, and MUST be ignored

isFMac

@Internal
@Deprecated
public boolean isFMac()
Deprecated. This field should not be used according to specification

This value MUST be 0, and MUST be ignored

Returns:
the fMac field value.

setFEmptySpecial

@Internal
public void setFEmptySpecial(boolean value)
Sets the fEmptySpecial field value. This value SHOULD be 0 and SHOULD be ignored

isFEmptySpecial

@Internal
@Deprecated
public boolean isFEmptySpecial()
Deprecated. This field should not be used according to specification

This value SHOULD be 0 and SHOULD be ignored

Returns:
the fEmptySpecial field value.

setFLoadOverridePage

@Internal
public void setFLoadOverridePage(boolean value)
Sets the fLoadOverridePage field value. Specifies whether to override the section properties for page size, orientation, and margins with the defaults that are appropriate for the installation language of the application

isFLoadOverridePage

@Internal
public boolean isFLoadOverridePage()
Specifies whether to override the section properties for page size, orientation, and margins with the defaults that are appropriate for the installation language of the application

Returns:
the fLoadOverridePage field value.

setReserved1

@Internal
public void setReserved1(boolean value)
Sets the reserved1 field value. This value is undefined and MUST be ignored

isReserved1

@Internal
@Deprecated
public boolean isReserved1()
Deprecated. This field should not be used according to specification

This value is undefined and MUST be ignored

Returns:
the reserved1 field value.

setReserved2

@Internal
public void setReserved2(boolean value)
Sets the reserved2 field value. This value is undefined and MUST be ignored

isReserved2

@Internal
@Deprecated
public boolean isReserved2()
Deprecated. This field should not be used according to specification

This value is undefined and MUST be ignored

Returns:
the reserved2 field value.

setFSpare0

@Internal
public void setFSpare0(byte value)
Sets the fSpare0 field value. This value is undefined and MUST be ignored

getFSpare0

@Internal
@Deprecated
public byte getFSpare0()
Deprecated. This field should not be used according to specification

This value is undefined and MUST be ignored

Returns:
the fSpare0 field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FibRgLw95AbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class FibRgLw95AbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

@Internal
public abstract class FibRgLw95AbstractType
extends java.lang.Object

The FibRgLw95 structure is the third section of the FIB for Word95.

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov

Field Summary
protected int | field_1_cbMac
protected int | field_10_ccpAtn
protected int | field_11_ccpEdn
protected int | field_12_ccpTxbx
protected int | field_13_ccpHdrTxbx
protected int | field_14_reserved5 Deprecated.
protected int | field_2_reserved1 Deprecated.
protected int | field_3_reserved2 Deprecated.
protected int | field_4_reserved3 Deprecated.
protected int | field_5_reserved4 Deprecated.
protected int | field_6_ccpText
protected int | field_7_ccpFtn
protected int | field_8_ccpHdd
protected int | field_9_ccpMcr
Constructor Summary
protected FibRgLw95AbstractType()
Method Summary
boolean | equals(java.lang.Object obj)
protected void | fillFields(byte[] data, int offset)
int | getCbMac() Get the cbMac field for the FibRgLw95 record.
int | getCcpAtn() Get the ccpAtn field for the FibRgLw95 record.
int | getCcpEdn() Get the ccpEdn field for the FibRgLw95 record.
int | getCcpFtn() Get the ccpFtn field for the FibRgLw95 record.
int | getCcpHdd() Get the ccpHdd field for the FibRgLw95 record.
int | getCcpHdrTxbx() Get the ccpHdrTxbx field for the FibRgLw95 record.
int | getCcpMcr() Get the ccpMcr field for the FibRgLw95 record.
int | getCcpText() Get the ccpText field for the FibRgLw95 record.
int | getCcpTxbx() Get the ccpTxbx field for the FibRgLw95 record.
int | getReserved1() Get the reserved1 field for the FibRgLw95 record.
int | getReserved2() Get the reserved2 field for the FibRgLw95 record.
int | getReserved3() Get the reserved3 field for the FibRgLw95 record.
int | getReserved4() Get the reserved4 field for the FibRgLw95 record.
int | getReserved5() Get the reserved5 field for the FibRgLw95 record.
static int | getSize() Size of record
int | hashCode()
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setCbMac(int field_1_cbMac) Set the cbMac field for the FibRgLw95 record.
void | setCcpAtn(int field_10_ccpAtn) Set the ccpAtn field for the FibRgLw95 record.
void | setCcpEdn(int field_11_ccpEdn) Set the ccpEdn field for the FibRgLw95 record.
void | setCcpFtn(int field_7_ccpFtn) Set the ccpFtn field for the FibRgLw95 record.
void | setCcpHdd(int field_8_ccpHdd) Set the ccpHdd field for the FibRgLw95 record.
void | setCcpHdrTxbx(int field_13_ccpHdrTxbx) Set the ccpHdrTxbx field for the FibRgLw95 record.
void | setCcpMcr(int field_9_ccpMcr) Set the ccpMcr field for the FibRgLw95 record.
void | setCcpText(int field_6_ccpText) Set the ccpText field for the FibRgLw95 record.
void | setCcpTxbx(int field_12_ccpTxbx) Set the ccpTxbx field for the FibRgLw95 record.
void | setReserved1(int field_2_reserved1) Set the reserved1 field for the FibRgLw95 record.
void | setReserved2(int field_3_reserved2) Set the reserved2 field for the FibRgLw95 record.
void | setReserved3(int field_4_reserved3) Set the reserved3 field for the FibRgLw95 record.
void | setReserved4(int field_5_reserved4) Set the reserved4 field for the FibRgLw95 record.
void | setReserved5(int field_14_reserved5) Set the reserved5 field for the FibRgLw95 record.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

field_1_cbMac

protected int field_1_cbMac

field_2_reserved1

@Deprecated
protected int field_2_reserved1
Deprecated.

field_3_reserved2

@Deprecated
protected int field_3_reserved2
Deprecated.

field_4_reserved3

@Deprecated
protected int field_4_reserved3
Deprecated.

field_5_reserved4

@Deprecated
protected int field_5_reserved4
Deprecated.

field_6_ccpText

protected int field_6_ccpText

field_7_ccpFtn

protected int field_7_ccpFtn

field_8_ccpHdd

protected int field_8_ccpHdd

field_9_ccpMcr

protected int field_9_ccpMcr

field_10_ccpAtn

protected int field_10_ccpAtn

field_11_ccpEdn

protected int field_11_ccpEdn

field_12_ccpTxbx

protected int field_12_ccpTxbx

field_13_ccpHdrTxbx

protected int field_13_ccpHdrTxbx

field_14_reserved5

@Deprecated
protected int field_14_reserved5
Deprecated.
Constructor Detail

FibRgLw95AbstractType

protected FibRgLw95AbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getCbMac

@Internal
public int getCbMac()
Get the cbMac field for the FibRgLw95 record.

setCbMac

@Internal
public void setCbMac(int field_1_cbMac)
Set the cbMac field for the FibRgLw95 record.

getReserved1

@Internal
public int getReserved1()
Get the reserved1 field for the FibRgLw95 record.

setReserved1

@Internal
public void setReserved1(int field_2_reserved1)
Set the reserved1 field for the FibRgLw95 record.

getReserved2

@Internal
public int getReserved2()
Get the reserved2 field for the FibRgLw95 record.

setReserved2

@Internal
public void setReserved2(int field_3_reserved2)
Set the reserved2 field for the FibRgLw95 record.

getReserved3

@Internal
public int getReserved3()
Get the reserved3 field for the FibRgLw95 record.

setReserved3

@Internal
public void setReserved3(int field_4_reserved3)
Set the reserved3 field for the FibRgLw95 record.

getReserved4

@Internal
public int getReserved4()
Get the reserved4 field for the FibRgLw95 record.

setReserved4

@Internal
public void setReserved4(int field_5_reserved4)
Set the reserved4 field for the FibRgLw95 record.

getCcpText

@Internal
public int getCcpText()
Get the ccpText field for the FibRgLw95 record.

setCcpText

@Internal
public void setCcpText(int field_6_ccpText)
Set the ccpText field for the FibRgLw95 record.

getCcpFtn

@Internal
public int getCcpFtn()
Get the ccpFtn field for the FibRgLw95 record.

setCcpFtn

@Internal
public void setCcpFtn(int field_7_ccpFtn)
Set the ccpFtn field for the FibRgLw95 record.

getCcpHdd

@Internal
public int getCcpHdd()
Get the ccpHdd field for the FibRgLw95 record.

setCcpHdd

@Internal
public void setCcpHdd(int field_8_ccpHdd)
Set the ccpHdd field for the FibRgLw95 record.

getCcpMcr

@Internal
public int getCcpMcr()
Get the ccpMcr field for the FibRgLw95 record.

setCcpMcr

@Internal
public void setCcpMcr(int field_9_ccpMcr)
Set the ccpMcr field for the FibRgLw95 record.

getCcpAtn

@Internal
public int getCcpAtn()
Get the ccpAtn field for the FibRgLw95 record.

setCcpAtn

@Internal
public void setCcpAtn(int field_10_ccpAtn)
Set the ccpAtn field for the FibRgLw95 record.

getCcpEdn

@Internal
public int getCcpEdn()
Get the ccpEdn field for the FibRgLw95 record.

setCcpEdn

@Internal
public void setCcpEdn(int field_11_ccpEdn)
Set the ccpEdn field for the FibRgLw95 record.

getCcpTxbx

@Internal
public int getCcpTxbx()
Get the ccpTxbx field for the FibRgLw95 record.

setCcpTxbx

@Internal
public void setCcpTxbx(int field_12_ccpTxbx)
Set the ccpTxbx field for the FibRgLw95 record.

getCcpHdrTxbx

@Internal
public int getCcpHdrTxbx()
Get the ccpHdrTxbx field for the FibRgLw95 record.

setCcpHdrTxbx

@Internal
public void setCcpHdrTxbx(int field_13_ccpHdrTxbx)
Set the ccpHdrTxbx field for the FibRgLw95 record.

getReserved5

@Internal
public int getReserved5()
Get the reserved5 field for the FibRgLw95 record.

setReserved5

@Internal
public void setReserved5(int field_14_reserved5)
Set the reserved5 field for the FibRgLw95 record.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FibRgLw97AbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class FibRgLw97AbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

@Internal
public abstract class FibRgLw97AbstractType
extends java.lang.Object

The FibRgLw97 structure is the third section of the FIB. This contains an array of 4-byte values.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected int | field_1_cbMac
protected int | field_10_ccpTxbx
protected int | field_11_ccpHdrTxbx
protected int | field_12_reserved4 Deprecated.
protected int | field_13_reserved5 Deprecated.
protected int | field_14_reserved6 Deprecated.
protected int | field_15_reserved7 Deprecated.
protected int | field_16_reserved8 Deprecated.
protected int | field_17_reserved9 Deprecated.
protected int | field_18_reserved10 Deprecated.
protected int | field_19_reserved11 Deprecated.
protected int | field_2_reserved1 Deprecated.
protected int | field_20_reserved12 Deprecated.
protected int | field_21_reserved13 Deprecated.
protected int | field_22_reserved14 Deprecated.
protected int | field_3_reserved2 Deprecated.
protected int | field_4_ccpText
protected int | field_5_ccpFtn
protected int | field_6_ccpHdd
protected int | field_7_reserved3 Deprecated.
protected int | field_8_ccpAtn
protected int | field_9_ccpEdn
Constructor Summary
protected FibRgLw97AbstractType()
Method Summary
boolean | equals(java.lang.Object obj)
protected void | fillFields(byte[] data, int offset)
int | getCbMac() Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning.
int | getCcpAtn() A signed integer that specifies the count of CPs in the comment subdocument.
int | getCcpEdn() A signed integer that specifies the count of CPs in the endnote subdocument.
int | getCcpFtn() A signed integer that specifies the count of CPs in the footnote subdocument.
int | getCcpHdd() A signed integer that specifies the count of CPs in the header subdocument.
int | getCcpHdrTxbx() A signed integer that specifies the count of CPs in the textbox subdocument of the header.
int | getCcpText() A signed integer that specifies the count of CPs in the main document.
int | getCcpTxbx() A signed integer that specifies the count of CPs in the textbox subdocument of the main document.
int | getReserved1() This value is undefined and MUST be ignored.
int | getReserved10() This value is undefined and MUST be ignored.
int | getReserved11() This value is undefined and MUST be ignored.
int | getReserved12() This value SHOULD be zero, and MUST be ignored.
int | getReserved13() This value MUST be zero and MUST be ignored.
int | getReserved14() This value MUST be zero and MUST be ignored.
int | getReserved2() This value is undefined and MUST be ignored.
int | getReserved3() This value is undefined and MUST be ignored.
int | getReserved4() This value is undefined and MUST be ignored.
int | getReserved5() This value is undefined and MUST be ignored.
int | getReserved6() This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx.
int | getReserved7() This value is undefined and MUST be ignored.
int | getReserved8() This value is undefined and MUST be ignored.
int | getReserved9() This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx.
static int | getSize() Size of record
int | hashCode()
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setCbMac(int field_1_cbMac) Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning.
void | setCcpAtn(int field_8_ccpAtn) A signed integer that specifies the count of CPs in the comment subdocument.
void | setCcpEdn(int field_9_ccpEdn) A signed integer that specifies the count of CPs in the endnote subdocument.
void | setCcpFtn(int field_5_ccpFtn) A signed integer that specifies the count of CPs in the footnote subdocument.
void | setCcpHdd(int field_6_ccpHdd) A signed integer that specifies the count of CPs in the header subdocument.
void | setCcpHdrTxbx(int field_11_ccpHdrTxbx) A signed integer that specifies the count of CPs in the textbox subdocument of the header.
void | setCcpText(int field_4_ccpText) A signed integer that specifies the count of CPs in the main document.
void | setCcpTxbx(int field_10_ccpTxbx) A signed integer that specifies the count of CPs in the textbox subdocument of the main document.
void | setReserved1(int field_2_reserved1) This value is undefined and MUST be ignored.
void | setReserved10(int field_18_reserved10) This value is undefined and MUST be ignored.
void | setReserved11(int field_19_reserved11) This value is undefined and MUST be ignored.
void | setReserved12(int field_20_reserved12) This value SHOULD be zero, and MUST be ignored.
void | setReserved13(int field_21_reserved13) This value MUST be zero and MUST be ignored.
void | setReserved14(int field_22_reserved14) This value MUST be zero and MUST be ignored.
void | setReserved2(int field_3_reserved2) This value is undefined and MUST be ignored.
void | setReserved3(int field_7_reserved3) This value is undefined and MUST be ignored.
void | setReserved4(int field_12_reserved4) This value is undefined and MUST be ignored.
void | setReserved5(int field_13_reserved5) This value is undefined and MUST be ignored.
void | setReserved6(int field_14_reserved6) This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx.
void | setReserved7(int field_15_reserved7) This value is undefined and MUST be ignored.
void | setReserved8(int field_16_reserved8) This value is undefined and MUST be ignored.
void | setReserved9(int field_17_reserved9) This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

field_1_cbMac

protected int field_1_cbMac

field_2_reserved1

@Deprecated
protected int field_2_reserved1
Deprecated.

field_3_reserved2

@Deprecated
protected int field_3_reserved2
Deprecated.

field_4_ccpText

protected int field_4_ccpText

field_5_ccpFtn

protected int field_5_ccpFtn

field_6_ccpHdd

protected int field_6_ccpHdd

field_7_reserved3

@Deprecated
protected int field_7_reserved3
Deprecated.

field_8_ccpAtn

protected int field_8_ccpAtn

field_9_ccpEdn

protected int field_9_ccpEdn

field_10_ccpTxbx

protected int field_10_ccpTxbx

field_11_ccpHdrTxbx

protected int field_11_ccpHdrTxbx

field_12_reserved4

@Deprecated
protected int field_12_reserved4
Deprecated.

field_13_reserved5

@Deprecated
protected int field_13_reserved5
Deprecated.

field_14_reserved6

@Deprecated
protected int field_14_reserved6
Deprecated.

field_15_reserved7

@Deprecated
protected int field_15_reserved7
Deprecated.

field_16_reserved8

@Deprecated
protected int field_16_reserved8
Deprecated.

field_17_reserved9

@Deprecated
protected int field_17_reserved9
Deprecated.

field_18_reserved10

@Deprecated
protected int field_18_reserved10
Deprecated.

field_19_reserved11

@Deprecated
protected int field_19_reserved11
Deprecated.

field_20_reserved12

@Deprecated
protected int field_20_reserved12
Deprecated.

field_21_reserved13

@Deprecated
protected int field_21_reserved13
Deprecated.

field_22_reserved14

@Deprecated
protected int field_22_reserved14
Deprecated.
Constructor Detail

FibRgLw97AbstractType

protected FibRgLw97AbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getCbMac

@Internal
public int getCbMac()
Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning. All bytes in the WordDocument stream at offset cbMac and greater MUST be ignored..

setCbMac

@Internal
public void setCbMac(int field_1_cbMac)
Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning. All bytes in the WordDocument stream at offset cbMac and greater MUST be ignored..

getReserved1

@Internal
public int getReserved1()
This value is undefined and MUST be ignored.

setReserved1

@Internal
public void setReserved1(int field_2_reserved1)
This value is undefined and MUST be ignored.

getReserved2

@Internal
public int getReserved2()
This value is undefined and MUST be ignored.

setReserved2

@Internal
public void setReserved2(int field_3_reserved2)
This value is undefined and MUST be ignored.

getCcpText

@Internal
public int getCcpText()
A signed integer that specifies the count of CPs in the main document. This value MUST be zero, 1, or greater.

setCcpText

@Internal
public void setCcpText(int field_4_ccpText)
A signed integer that specifies the count of CPs in the main document. This value MUST be zero, 1, or greater.

getCcpFtn

@Internal
public int getCcpFtn()
A signed integer that specifies the count of CPs in the footnote subdocument. This value MUST be zero, 1, or greater.

setCcpFtn

@Internal
public void setCcpFtn(int field_5_ccpFtn)
A signed integer that specifies the count of CPs in the footnote subdocument. This value MUST be zero, 1, or greater.

getCcpHdd

@Internal
public int getCcpHdd()
A signed integer that specifies the count of CPs in the header subdocument. This value MUST be zero, 1, or greater.

setCcpHdd

@Internal
public void setCcpHdd(int field_6_ccpHdd)
A signed integer that specifies the count of CPs in the header subdocument. This value MUST be zero, 1, or greater.

getReserved3

@Internal
public int getReserved3()
This value is undefined and MUST be ignored.

setReserved3

@Internal
public void setReserved3(int field_7_reserved3)
This value is undefined and MUST be ignored.

getCcpAtn

@Internal
public int getCcpAtn()
A signed integer that specifies the count of CPs in the comment subdocument. This value MUST be zero, 1, or greater.

setCcpAtn

@Internal
public void setCcpAtn(int field_8_ccpAtn)
A signed integer that specifies the count of CPs in the comment subdocument. This value MUST be zero, 1, or greater.

getCcpEdn

@Internal
public int getCcpEdn()
A signed integer that specifies the count of CPs in the endnote subdocument. This value MUST be zero, 1, or greater.

setCcpEdn

@Internal
public void setCcpEdn(int field_9_ccpEdn)
A signed integer that specifies the count of CPs in the endnote subdocument. This value MUST be zero, 1, or greater.

getCcpTxbx

@Internal
public int getCcpTxbx()
A signed integer that specifies the count of CPs in the textbox subdocument of the main document. This value MUST be zero, 1, or greater.

setCcpTxbx

@Internal
public void setCcpTxbx(int field_10_ccpTxbx)
A signed integer that specifies the count of CPs in the textbox subdocument of the main document. This value MUST be zero, 1, or greater.

getCcpHdrTxbx

@Internal
public int getCcpHdrTxbx()
A signed integer that specifies the count of CPs in the textbox subdocument of the header. This value MUST be zero, 1, or greater.

setCcpHdrTxbx

@Internal
public void setCcpHdrTxbx(int field_11_ccpHdrTxbx)
A signed integer that specifies the count of CPs in the textbox subdocument of the header. This value MUST be zero, 1, or greater.

getReserved4

@Internal
public int getReserved4()
This value is undefined and MUST be ignored.

setReserved4

@Internal
public void setReserved4(int field_12_reserved4)
This value is undefined and MUST be ignored.

getReserved5

@Internal
public int getReserved5()
This value is undefined and MUST be ignored.

setReserved5

@Internal
public void setReserved5(int field_13_reserved5)
This value is undefined and MUST be ignored.

getReserved6

@Internal
public int getReserved6()
This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx. This value MUST be ignored.

setReserved6

@Internal
public void setReserved6(int field_14_reserved6)
This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx. This value MUST be ignored.

getReserved7

@Internal
public int getReserved7()
This value is undefined and MUST be ignored.

setReserved7

@Internal
public void setReserved7(int field_15_reserved7)
This value is undefined and MUST be ignored.

getReserved8

@Internal
public int getReserved8()
This value is undefined and MUST be ignored.

setReserved8

@Internal
public void setReserved8(int field_16_reserved8)
This value is undefined and MUST be ignored.

getReserved9

@Internal
public int getReserved9()
This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx. This value MUST be ignored.

setReserved9

@Internal
public void setReserved9(int field_17_reserved9)
This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx. This value MUST be ignored.

getReserved10

@Internal
public int getReserved10()
This value is undefined and MUST be ignored.

setReserved10

@Internal
public void setReserved10(int field_18_reserved10)
This value is undefined and MUST be ignored.

getReserved11

@Internal
public int getReserved11()
This value is undefined and MUST be ignored.

setReserved11

@Internal
public void setReserved11(int field_19_reserved11)
This value is undefined and MUST be ignored.

getReserved12

@Internal
public int getReserved12()
This value SHOULD be zero, and MUST be ignored.

setReserved12

@Internal
public void setReserved12(int field_20_reserved12)
This value SHOULD be zero, and MUST be ignored.

getReserved13

@Internal
public int getReserved13()
This value MUST be zero and MUST be ignored.

setReserved13

@Internal
public void setReserved13(int field_21_reserved13)
This value MUST be zero and MUST be ignored.

getReserved14

@Internal
public int getReserved14()
This value MUST be zero and MUST be ignored.

setReserved14

@Internal
public void setReserved14(int field_22_reserved14)
This value MUST be zero and MUST be ignored.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FibRgW97AbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class FibRgW97AbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FibRgW97AbstractType

@Internal
public abstract class FibRgW97AbstractType
extends java.lang.Object

The FibRgW97 structure is a variable-length portion of the Fib.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected short | field_1_reserved1 Deprecated.
protected short | field_10_reserved10 Deprecated.
protected short | field_11_reserved11 Deprecated.
protected short | field_12_reserved12 Deprecated.
protected short | field_13_reserved13 Deprecated.
protected short | field_14_lidFE
protected short | field_2_reserved2 Deprecated.
protected short | field_3_reserved3 Deprecated.
protected short | field_4_reserved4 Deprecated.
protected short | field_5_reserved5 Deprecated.
protected short | field_6_reserved6 Deprecated.
protected short | field_7_reserved7 Deprecated.
protected short | field_8_reserved8 Deprecated.
protected short | field_9_reserved9 Deprecated.
Constructor Summary
protected FibRgW97AbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
short | getLidFE() A LID whose meaning depends on the nFib value.
short | getReserved1() This value is undefined and MUST be ignored.
short | getReserved10() This value is undefined and MUST be ignored.
short | getReserved11() This value is undefined and MUST be ignored.
short | getReserved12() This value is undefined and MUST be ignored.
short | getReserved13() This value is undefined and MUST be ignored.
short | getReserved2() This value is undefined and MUST be ignored.
short | getReserved3() This value is undefined and MUST be ignored.
short | getReserved4() This value is undefined and MUST be ignored.
short | getReserved5() This value is undefined and MUST be ignored.
short | getReserved6() This value is undefined and MUST be ignored.
short | getReserved7() This value is undefined and MUST be ignored.
short | getReserved8() This value is undefined and MUST be ignored.
short | getReserved9() This value is undefined and MUST be ignored.
static int | getSize() Size of record
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setLidFE(short field_14_lidFE) A LID whose meaning depends on the nFib value.
void | setReserved1(short field_1_reserved1) This value is undefined and MUST be ignored.
void | setReserved10(short field_10_reserved10) This value is undefined and MUST be ignored.
void | setReserved11(short field_11_reserved11) This value is undefined and MUST be ignored.
void | setReserved12(short field_12_reserved12) This value is undefined and MUST be ignored.
void | setReserved13(short field_13_reserved13) This value is undefined and MUST be ignored.
void | setReserved2(short field_2_reserved2) This value is undefined and MUST be ignored.
void | setReserved3(short field_3_reserved3) This value is undefined and MUST be ignored.
void | setReserved4(short field_4_reserved4) This value is undefined and MUST be ignored.
void | setReserved5(short field_5_reserved5) This value is undefined and MUST be ignored.
void | setReserved6(short field_6_reserved6) This value is undefined and MUST be ignored.
void | setReserved7(short field_7_reserved7) This value is undefined and MUST be ignored.
void | setReserved8(short field_8_reserved8) This value is undefined and MUST be ignored.
void | setReserved9(short field_9_reserved9) This value is undefined and MUST be ignored.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_reserved1

@Deprecated
protected short field_1_reserved1
Deprecated.

field_2_reserved2

@Deprecated
protected short field_2_reserved2
Deprecated.

field_3_reserved3

@Deprecated
protected short field_3_reserved3
Deprecated.

field_4_reserved4

@Deprecated
protected short field_4_reserved4
Deprecated.

field_5_reserved5

@Deprecated
protected short field_5_reserved5
Deprecated.

field_6_reserved6

@Deprecated
protected short field_6_reserved6
Deprecated.

field_7_reserved7

@Deprecated
protected short field_7_reserved7
Deprecated.

field_8_reserved8

@Deprecated
protected short field_8_reserved8
Deprecated.

field_9_reserved9

@Deprecated
protected short field_9_reserved9
Deprecated.

field_10_reserved10

@Deprecated
protected short field_10_reserved10
Deprecated.

field_11_reserved11

@Deprecated
protected short field_11_reserved11
Deprecated.

field_12_reserved12

@Deprecated
protected short field_12_reserved12
Deprecated.

field_13_reserved13

@Deprecated
protected short field_13_reserved13
Deprecated.

field_14_lidFE

protected short field_14_lidFE
Constructor Detail

FibRgW97AbstractType

protected FibRgW97AbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getReserved1

@Internal
public short getReserved1()
This value is undefined and MUST be ignored.

setReserved1

@Internal
public void setReserved1(short field_1_reserved1)
This value is undefined and MUST be ignored.

getReserved2

@Internal
public short getReserved2()
This value is undefined and MUST be ignored.

setReserved2

@Internal
public void setReserved2(short field_2_reserved2)
This value is undefined and MUST be ignored.

getReserved3

@Internal
public short getReserved3()
This value is undefined and MUST be ignored.

setReserved3

@Internal
public void setReserved3(short field_3_reserved3)
This value is undefined and MUST be ignored.

getReserved4

@Internal
public short getReserved4()
This value is undefined and MUST be ignored.

setReserved4

@Internal
public void setReserved4(short field_4_reserved4)
This value is undefined and MUST be ignored.

getReserved5

@Internal
public short getReserved5()
This value is undefined and MUST be ignored.

setReserved5

@Internal
public void setReserved5(short field_5_reserved5)
This value is undefined and MUST be ignored.

getReserved6

@Internal
public short getReserved6()
This value is undefined and MUST be ignored.

setReserved6

@Internal
public void setReserved6(short field_6_reserved6)
This value is undefined and MUST be ignored.

getReserved7

@Internal
public short getReserved7()
This value is undefined and MUST be ignored.

setReserved7

@Internal
public void setReserved7(short field_7_reserved7)
This value is undefined and MUST be ignored.

getReserved8

@Internal
public short getReserved8()
This value is undefined and MUST be ignored.

setReserved8

@Internal
public void setReserved8(short field_8_reserved8)
This value is undefined and MUST be ignored.

getReserved9

@Internal
public short getReserved9()
This value is undefined and MUST be ignored.

setReserved9

@Internal
public void setReserved9(short field_9_reserved9)
This value is undefined and MUST be ignored.

getReserved10

@Internal
public short getReserved10()
This value is undefined and MUST be ignored.

setReserved10

@Internal
public void setReserved10(short field_10_reserved10)
This value is undefined and MUST be ignored.

getReserved11

@Internal
public short getReserved11()
This value is undefined and MUST be ignored.

setReserved11

@Internal
public void setReserved11(short field_11_reserved11)
This value is undefined and MUST be ignored.

getReserved12

@Internal
public short getReserved12()
This value is undefined and MUST be ignored.

setReserved12

@Internal
public void setReserved12(short field_12_reserved12)
This value is undefined and MUST be ignored.

getReserved13

@Internal
public short getReserved13()
This value is undefined and MUST be ignored.

setReserved13

@Internal
public void setReserved13(short field_13_reserved13)
This value is undefined and MUST be ignored.

getLidFE

@Internal
public short getLidFE()
A LID whose meaning depends on the nFib value.

setLidFE

@Internal
public void setLidFE(short field_14_lidFE)
A LID whose meaning depends on the nFib value.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FLDAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class FLDAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FLDAbstractType
All Implemented Interfaces:
org.apache.poi.hdf.model.hdftypes.HDFType
Direct Known Subclasses:
FieldDescriptor
@Internal
public abstract class FLDAbstractType
extends java.lang.Object
implements org.apache.poi.hdf.model.hdftypes.HDFType

Field Descriptor (FLD).

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/records/definitions.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc]

Field Summary
protected byte | field_1_chHolder
protected byte | field_2_flt
Constructor Summary
FLDAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
byte | getCh() Type of field boundary the FLD describes: 19 -- field begin mark, 20 -- field separation mark; 21 -- field end mark
byte | getChHolder() ch field holder (along with reserved bits).
byte | getFlt() Field type when ch == 19 OR field flags when ch == 21 .
byte | getReserved() Reserved
static int | getSize() Size of record (exluding 4 byte header)
boolean | isFDiffer() Ignored for saved file
boolean | isFHasSep() ==1 when field has a field separator
boolean | isFLocked() ==1 when field is locked from recalculation
boolean | isFNested() ==1 when field is nested within another field
boolean | isFPrivateResult() ==1 whenever the result of the field is never to be shown
boolean | isFResultDirty() ==1 when user has edited or formatted the result.
boolean | isFResultEdited() ==1 when user has inserted text into or deleted text from the result
boolean | isFZombieEmbed() ==1 when result still believes this field is an EMBED or LINK field
void | serialize(byte[] data, int offset)
void | setCh(byte value) Sets the ch field value.
void | setChHolder(byte field_1_chHolder) ch field holder (along with reserved bits).
void | setFDiffer(boolean value) Sets the fDiffer field value.
void | setFHasSep(boolean value) Sets the fHasSep field value.
void | setFLocked(boolean value) Sets the fLocked field value.
void | setFlt(byte field_2_flt) Field type when ch == 19 OR field flags when ch == 21 .
void | setFNested(boolean value) Sets the fNested field value.
void | setFPrivateResult(boolean value) Sets the fPrivateResult field value.
void | setFResultDirty(boolean value) Sets the fResultDirty field value.
void | setFResultEdited(boolean value) Sets the fResultEdited field value.
void | setFZombieEmbed(boolean value) Sets the fZombieEmbed field value.
void | setReserved(byte value) Sets the reserved field value.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_chHolder

protected byte field_1_chHolder

field_2_flt

protected byte field_2_flt
Constructor Detail

FLDAbstractType

public FLDAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getSize

public static int getSize()
Size of record (exluding 4 byte header)

getChHolder

public byte getChHolder()
ch field holder (along with reserved bits).

setChHolder

public void setChHolder(byte field_1_chHolder)
ch field holder (along with reserved bits).

getFlt

public byte getFlt()
Field type when ch == 19 OR field flags when ch == 21 .

setFlt

public void setFlt(byte field_2_flt)
Field type when ch == 19 OR field flags when ch == 21 .

setCh

public void setCh(byte value)
Sets the ch field value. Type of field boundary the FLD describes: 19 -- field begin mark, 20 -- field separation mark; 21 -- field end mark

getCh

public byte getCh()
Type of field boundary the FLD describes: 19 -- field begin mark, 20 -- field separation mark; 21 -- field end mark

Returns:
the ch field value.

setReserved

public void setReserved(byte value)
Sets the reserved field value. Reserved

getReserved

public byte getReserved()
Reserved

Returns:
the reserved field value.

setFDiffer

public void setFDiffer(boolean value)
Sets the fDiffer field value. Ignored for saved file

isFDiffer

public boolean isFDiffer()
Ignored for saved file

Returns:
the fDiffer field value.

setFZombieEmbed

public void setFZombieEmbed(boolean value)
Sets the fZombieEmbed field value. ==1 when result still believes this field is an EMBED or LINK field

isFZombieEmbed

public boolean isFZombieEmbed()
==1 when result still believes this field is an EMBED or LINK field

Returns:
the fZombieEmbed field value.

setFResultDirty

public void setFResultDirty(boolean value)
Sets the fResultDirty field value. ==1 when user has edited or formatted the result. == 0 otherwise

isFResultDirty

public boolean isFResultDirty()
==1 when user has edited or formatted the result. == 0 otherwise

Returns:
the fResultDirty field value.

setFResultEdited

public void setFResultEdited(boolean value)
Sets the fResultEdited field value. ==1 when user has inserted text into or deleted text from the result

isFResultEdited

public boolean isFResultEdited()
==1 when user has inserted text into or deleted text from the result

Returns:
the fResultEdited field value.

setFLocked

public void setFLocked(boolean value)
Sets the fLocked field value. ==1 when field is locked from recalculation

isFLocked

public boolean isFLocked()
==1 when field is locked from recalculation

Returns:
the fLocked field value.

setFPrivateResult

public void setFPrivateResult(boolean value)
Sets the fPrivateResult field value. ==1 whenever the result of the field is never to be shown

isFPrivateResult

public boolean isFPrivateResult()
==1 whenever the result of the field is never to be shown

Returns:
the fPrivateResult field value.

setFNested

public void setFNested(boolean value)
Sets the fNested field value. ==1 when field is nested within another field

isFNested

public boolean isFNested()
==1 when field is nested within another field

Returns:
the fNested field value.

setFHasSep

public void setFHasSep(boolean value)
Sets the fHasSep field value. ==1 when field has a field separator

isFHasSep

public boolean isFHasSep()
==1 when field has a field separator

Returns:
the fHasSep field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FRDAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class FRDAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FRDAbstractType
Direct Known Subclasses:
FootnoteReferenceDescriptor
@Internal
public abstract class FRDAbstractType
extends java.lang.Object

Footnote Reference Descriptor (FRD).

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format (.doc) Specification NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format (.doc) Specification

Field Summary
protected  short field_1_nAuto
Constructor Summary
protected FRDAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
short | getNAuto() If > 0, the note is an automatically numbered note, otherwise it has a custom mark.
static int | getSize() Size of record
void | serialize(byte[] data, int offset)
void | setNAuto(short field_1_nAuto) If > 0, the note is an automatically numbered note, otherwise it has a custom mark.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_nAuto

protected short field_1_nAuto
Constructor Detail

FRDAbstractType

protected FRDAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getNAuto

public short getNAuto()
If > 0, the note is an automatically numbered note, otherwise it has a custom mark.

setNAuto

public void setNAuto(short field_1_nAuto)
If > 0, the note is an automatically numbered note, otherwise it has a custom mark.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FSPAAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class FSPAAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.FSPAAbstractType
Direct Known Subclasses:
FSPA
@Internal
public abstract class FSPAAbstractType
extends java.lang.Object

File Shape Address (FSPA).

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc]

Field Summary
protected int | field_1_spid
protected int | field_2_xaLeft
protected int | field_3_yaTop
protected int | field_4_xaRight
protected int | field_5_yaBottom
protected short | field_6_flags
protected int | field_7_cTxbx
Constructor Summary
protected FSPAAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
byte | getBx() X position of shape relative to anchor CP
byte | getBy() Y position of shape relative to anchor CP
int | getCTxbx() Count of textboxes in shape (undo doc only).
short | getFlags() Get the flags field for the FSPA record.
static int | getSize() Size of record
int | getSpid() Shape Identifier.
byte | getWr() Text wrapping mode
byte | getWrk() Text wrapping mode type (valid only for wrapping modes 2 and 4
int | getXaLeft() Left of rectangle enclosing shape relative to the origin of the shape.
int | getXaRight() Right of rectangle enclosing shape relative to the origin of the shape.
int | getYaBottom() Bottom of the rectangle enclosing shape relative to the origin of the shape.
int | getYaTop() Top of rectangle enclosing shape relative to the origin of the shape.
boolean | isFAnchorLock()
boolean | isFBelowText()
boolean | isFHdr() 1 in the undo doc when shape is from the header doc, 0 otherwise (undefined when not in the undo doc)
boolean | isFRcaSimple() When set, temporarily overrides bx, by, forcing the xaLeft, xaRight, yaTop, and yaBottom fields to all be page relative.
void | serialize(byte[] data, int offset)
void | setBx(byte value) Sets the bx field value.
void | setBy(byte value) Sets the by field value.
void | setCTxbx(int field_7_cTxbx) Count of textboxes in shape (undo doc only).
void | setFAnchorLock(boolean value) Sets the fAnchorLock field value.
void | setFBelowText(boolean value) Sets the fBelowText field value.
void | setFHdr(boolean value) Sets the fHdr field value.
void | setFlags(short field_6_flags) Set the flags field for the FSPA record.
void | setFRcaSimple(boolean value) Sets the fRcaSimple field value.
void | setSpid(int field_1_spid) Shape Identifier.
void | setWr(byte value) Sets the wr field value.
void | setWrk(byte value) Sets the wrk field value.
void | setXaLeft(int field_2_xaLeft) Left of rectangle enclosing shape relative to the origin of the shape.
void | setXaRight(int field_4_xaRight) Right of rectangle enclosing shape relative to the origin of the shape.
void | setYaBottom(int field_5_yaBottom) Bottom of the rectangle enclosing shape relative to the origin of the shape.
void | setYaTop(int field_3_yaTop) Top of rectangle enclosing shape relative to the origin of the shape.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_spid

protected int field_1_spid

field_2_xaLeft

protected int field_2_xaLeft

field_3_yaTop

protected int field_3_yaTop

field_4_xaRight

protected int field_4_xaRight

field_5_yaBottom

protected int field_5_yaBottom

field_6_flags

protected short field_6_flags

field_7_cTxbx

protected int field_7_cTxbx
Constructor Detail

FSPAAbstractType

protected FSPAAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getSpid

@Internal
public int getSpid()
Shape Identifier. Used in conjunction with the office art data (found via fcDggInfo in the FIB) to find the actual data for this shape.

setSpid

@Internal
public void setSpid(int field_1_spid)
Shape Identifier. Used in conjunction with the office art data (found via fcDggInfo in the FIB) to find the actual data for this shape.

getXaLeft

@Internal
public int getXaLeft()
Left of rectangle enclosing shape relative to the origin of the shape.

setXaLeft

@Internal
public void setXaLeft(int field_2_xaLeft)
Left of rectangle enclosing shape relative to the origin of the shape.

getYaTop

@Internal
public int getYaTop()
Top of rectangle enclosing shape relative to the origin of the shape.

setYaTop

@Internal
public void setYaTop(int field_3_yaTop)
Top of rectangle enclosing shape relative to the origin of the shape.

getXaRight

@Internal
public int getXaRight()
Right of rectangle enclosing shape relative to the origin of the shape.

setXaRight

@Internal
public void setXaRight(int field_4_xaRight)
Right of rectangle enclosing shape relative to the origin of the shape.

getYaBottom

@Internal
public int getYaBottom()
Bottom of the rectangle enclosing shape relative to the origin of the shape.

setYaBottom

@Internal
public void setYaBottom(int field_5_yaBottom)
Bottom of the rectangle enclosing shape relative to the origin of the shape.

getFlags

@Internal
public short getFlags()
Get the flags field for the FSPA record.

setFlags

@Internal
public void setFlags(short field_6_flags)
Set the flags field for the FSPA record.

getCTxbx

@Internal
public int getCTxbx()
Count of textboxes in shape (undo doc only).

setCTxbx

@Internal
public void setCTxbx(int field_7_cTxbx)
Count of textboxes in shape (undo doc only).

setFHdr

@Internal
public void setFHdr(boolean value)
Sets the fHdr field value. 1 in the undo doc when shape is from the header doc, 0 otherwise (undefined when not in the undo doc)

isFHdr

@Internal
public boolean isFHdr()
1 in the undo doc when shape is from the header doc, 0 otherwise (undefined when not in the undo doc)

Returns:
the fHdr field value.

setBx

@Internal
public void setBx(byte value)
Sets the bx field value. X position of shape relative to anchor CP

getBx

@Internal
public byte getBx()
X position of shape relative to anchor CP

Returns:
the bx field value.

setBy

@Internal
public void setBy(byte value)
Sets the by field value. Y position of shape relative to anchor CP

getBy

@Internal
public byte getBy()
Y position of shape relative to anchor CP

Returns:
the by field value.

setWr

@Internal
public void setWr(byte value)
Sets the wr field value. Text wrapping mode

getWr

@Internal
public byte getWr()
Text wrapping mode

Returns:
the wr field value.

setWrk

@Internal
public void setWrk(byte value)
Sets the wrk field value. Text wrapping mode type (valid only for wrapping modes 2 and 4

getWrk

@Internal
public byte getWrk()
Text wrapping mode type (valid only for wrapping modes 2 and 4

Returns:
the wrk field value.

setFRcaSimple

@Internal
public void setFRcaSimple(boolean value)
Sets the fRcaSimple field value. When set, temporarily overrides bx, by, forcing the xaLeft, xaRight, yaTop, and yaBottom fields to all be page relative.

isFRcaSimple

@Internal
public boolean isFRcaSimple()
When set, temporarily overrides bx, by, forcing the xaLeft, xaRight, yaTop, and yaBottom fields to all be page relative.

Returns:
the fRcaSimple field value.

setFBelowText

@Internal
public void setFBelowText(boolean value)
Sets the fBelowText field value.

isFBelowText

@Internal
public boolean isFBelowText()
Returns:
the fBelowText field value.

setFAnchorLock

@Internal
public void setFAnchorLock(boolean value)
Sets the fAnchorLock field value.

isFAnchorLock

@Internal
public boolean isFAnchorLock()
Returns:
the fAnchorLock field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GrfhicAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class GrfhicAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.GrfhicAbstractType
Direct Known Subclasses:
Grfhic
@Internal
public abstract class GrfhicAbstractType
extends java.lang.Object

The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure. The values specify possible incompatibilities between an LVL or LVLF and HTML lists. The values do not define list properties.

Class and fields descriptions are quoted from [MS-DOC] -- v20110315 Word (.doc) Binary File Format specification

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to [MS-DOC] -- v20110315 Word (.doc) Binary File Format specification

Field Summary
protected  byte field_1_grfhic
Constructor Summary
protected GrfhicAbstractType()
Method Summary
boolean | equals(java.lang.Object obj)
protected void | fillFields(byte[] data, int offset)
byte | getGrfhic() HTML compatibility flags.
static int | getSize() Size of record
int | hashCode()
boolean | isFHtmlBuiltInBullet() A built-in HTML bullet
boolean | isFHtmlChecked() Checked
boolean | isFHtmlFirstLineMismatch() First line indent mismatch
boolean | isFHtmlHangingIndentBeneathNumber() The hanging indent falls beneath the number (need plain text)
boolean | isFHtmlListTextNotSharpDot() The list text is not "#."
boolean | isFHtmlNotPeriod() Something other than a period is used
boolean | isFHtmlTabLeftIndentMismatch() The list tab and the dxaLeft don't match (need table?)
boolean | isFHtmlUnsupported() The numbering sequence or format is unsupported (includes tab & size)
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setFHtmlBuiltInBullet(boolean value) Sets the fHtmlBuiltInBullet field value.
void | setFHtmlChecked(boolean value) Sets the fHtmlChecked field value.
void | setFHtmlFirstLineMismatch(boolean value) Sets the fHtmlFirstLineMismatch field value.
void | setFHtmlHangingIndentBeneathNumber(boolean value) Sets the fHtmlHangingIndentBeneathNumber field value.
void | setFHtmlListTextNotSharpDot(boolean value) Sets the fHtmlListTextNotSharpDot field value.
void | setFHtmlNotPeriod(boolean value) Sets the fHtmlNotPeriod field value.
void | setFHtmlTabLeftIndentMismatch(boolean value) Sets the fHtmlTabLeftIndentMismatch field value.
void | setFHtmlUnsupported(boolean value) Sets the fHtmlUnsupported field value.
void | setGrfhic(byte field_1_grfhic) HTML compatibility flags.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

field_1_grfhic

protected byte field_1_grfhic
Constructor Detail

GrfhicAbstractType

protected GrfhicAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getGrfhic

@Internal
public byte getGrfhic()
HTML compatibility flags.

setGrfhic

@Internal
public void setGrfhic(byte field_1_grfhic)
HTML compatibility flags.

setFHtmlChecked

@Internal
public void setFHtmlChecked(boolean value)
Sets the fHtmlChecked field value. Checked

isFHtmlChecked

@Internal
public boolean isFHtmlChecked()
Checked

Returns:
the fHtmlChecked field value.

setFHtmlUnsupported

@Internal
public void setFHtmlUnsupported(boolean value)
Sets the fHtmlUnsupported field value. The numbering sequence or format is unsupported (includes tab & size)

isFHtmlUnsupported

@Internal
public boolean isFHtmlUnsupported()
The numbering sequence or format is unsupported (includes tab & size)

Returns:
the fHtmlUnsupported field value.

setFHtmlListTextNotSharpDot

@Internal
public void setFHtmlListTextNotSharpDot(boolean value)
Sets the fHtmlListTextNotSharpDot field value. The list text is not "#."

isFHtmlListTextNotSharpDot

@Internal
public boolean isFHtmlListTextNotSharpDot()
The list text is not "#."

Returns:
the fHtmlListTextNotSharpDot field value.

setFHtmlNotPeriod

@Internal
public void setFHtmlNotPeriod(boolean value)
Sets the fHtmlNotPeriod field value. Something other than a period is used

isFHtmlNotPeriod

@Internal
public boolean isFHtmlNotPeriod()
Something other than a period is used

Returns:
the fHtmlNotPeriod field value.

setFHtmlFirstLineMismatch

@Internal
public void setFHtmlFirstLineMismatch(boolean value)
Sets the fHtmlFirstLineMismatch field value. First line indent mismatch

isFHtmlFirstLineMismatch

@Internal
public boolean isFHtmlFirstLineMismatch()
First line indent mismatch

Returns:
the fHtmlFirstLineMismatch field value.

setFHtmlTabLeftIndentMismatch

@Internal
public void setFHtmlTabLeftIndentMismatch(boolean value)
Sets the fHtmlTabLeftIndentMismatch field value. The list tab and the dxaLeft don't match (need table?)

isFHtmlTabLeftIndentMismatch

@Internal
public boolean isFHtmlTabLeftIndentMismatch()
The list tab and the dxaLeft don't match (need table?)

Returns:
the fHtmlTabLeftIndentMismatch field value.

setFHtmlHangingIndentBeneathNumber

@Internal
public void setFHtmlHangingIndentBeneathNumber(boolean value)
Sets the fHtmlHangingIndentBeneathNumber field value. The hanging indent falls beneath the number (need plain text)

isFHtmlHangingIndentBeneathNumber

@Internal
public boolean isFHtmlHangingIndentBeneathNumber()
The hanging indent falls beneath the number (need plain text)

Returns:
the fHtmlHangingIndentBeneathNumber field value.

setFHtmlBuiltInBullet

@Internal
public void setFHtmlBuiltInBullet(boolean value)
Sets the fHtmlBuiltInBullet field value. A built-in HTML bullet

isFHtmlBuiltInBullet

@Internal
public boolean isFHtmlBuiltInBullet()
A built-in HTML bullet

Returns:
the fHtmlBuiltInBullet field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HRESIAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class HRESIAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.HRESIAbstractType
Direct Known Subclasses:
Hyphenation
@Internal
public abstract class HRESIAbstractType
extends java.lang.Object

Hyphenation (HRESI).

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format (.doc) Specification NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format (.doc) Specification

Field Summary
protected byte | field_1_hres
protected byte | field_2_chHres
static byte | HRES_ADD_LETTER_BEFORE
static byte | HRES_CHANGE_LETTER_AFTER
static byte | HRES_CHANGE_LETTER_BEFORE
static byte | HRES_DELETE_BEFORE_CHANGE_BEFORE
static byte | HRES_DELETE_LETTER_BEFORE
static byte | HRES_NO
static byte | HRES_NORMAL
Constructor Summary
protected HRESIAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
byte | getChHres() The character that will be used to add or change a letter when hres is 2, 3, 5 or 6.
byte | getHres() Hyphenation rule.
static int | getSize() Size of record (exluding 4 byte header)
void | serialize(byte[] data, int offset)
void | setChHres(byte field_2_chHres) The character that will be used to add or change a letter when hres is 2, 3, 5 or 6.
void | setHres(byte field_1_hres) Hyphenation rule.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_hres

protected byte field_1_hres

HRES_NO

public static final byte HRES_NO
See Also:
Constant Field Values

HRES_NORMAL

public static final byte HRES_NORMAL
See Also:
Constant Field Values

HRES_ADD_LETTER_BEFORE

public static final byte HRES_ADD_LETTER_BEFORE
See Also:
Constant Field Values

HRES_CHANGE_LETTER_BEFORE

public static final byte HRES_CHANGE_LETTER_BEFORE
See Also:
Constant Field Values

HRES_DELETE_LETTER_BEFORE

public static final byte HRES_DELETE_LETTER_BEFORE
See Also:
Constant Field Values

HRES_CHANGE_LETTER_AFTER

public static final byte HRES_CHANGE_LETTER_AFTER
See Also:
Constant Field Values

HRES_DELETE_BEFORE_CHANGE_BEFORE

public static final byte HRES_DELETE_BEFORE_CHANGE_BEFORE
See Also:
Constant Field Values

field_2_chHres

protected byte field_2_chHres
Constructor Detail

HRESIAbstractType

protected HRESIAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record (exluding 4 byte header)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getHres

public byte getHres()
Hyphenation rule.

Returns:
One of
  • HRES_NO
  • HRES_NORMAL
  • HRES_ADD_LETTER_BEFORE
  • HRES_CHANGE_LETTER_BEFORE
  • HRES_DELETE_LETTER_BEFORE
  • HRES_CHANGE_LETTER_AFTER
  • HRES_DELETE_BEFORE_CHANGE_BEFORE

    • setHres

    public void setHres(byte field_1_hres)
    Hyphenation rule.

    Parameters:
    field_1_hres - One of
  • HRES_NO
  • HRES_NORMAL
  • HRES_ADD_LETTER_BEFORE
  • HRES_CHANGE_LETTER_BEFORE
  • HRES_DELETE_LETTER_BEFORE
  • HRES_CHANGE_LETTER_AFTER
  • HRES_DELETE_BEFORE_CHANGE_BEFORE

    • getChHres

    public byte getChHres()
    The character that will be used to add or change a letter when hres is 2, 3, 5 or 6.

    setChHres

    public void setChHres(byte field_2_chHres)
    The character that will be used to add or change a letter when hres is 2, 3, 5 or 6.

    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LFOAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class LFOAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.LFOAbstractType

@Internal
public abstract class LFOAbstractType
extends java.lang.Object

List Format Override (LFO).

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc]

Field Summary
protected int | field_1_lsid
protected int | field_2_reserved1
protected int | field_3_reserved2
protected byte | field_4_clfolvl
protected byte | field_5_ibstFltAutoNum
protected Grfhic | field_6_grfhic
protected byte | field_7_reserved3
Constructor Summary
protected LFOAbstractType()
Method Summary
boolean | equals(java.lang.Object obj)
protected void | fillFields(byte[] data, int offset)
byte | getClfolvl() Count of levels whose format is overridden (see LFOLVL).
Grfhic | getGrfhic() HTML compatibility flags.
byte | getIbstFltAutoNum() Used for AUTONUM field emulation.
int | getLsid() List ID of corresponding LSTF (see LSTF).
int | getReserved1() Reserved.
int | getReserved2() Reserved.
byte | getReserved3() Reserved.
static int | getSize() Size of record
int | hashCode()
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setClfolvl(byte field_4_clfolvl) Count of levels whose format is overridden (see LFOLVL).
void | setGrfhic(Grfhic field_6_grfhic) HTML compatibility flags.
void | setIbstFltAutoNum(byte field_5_ibstFltAutoNum) Used for AUTONUM field emulation.
void | setLsid(int field_1_lsid) List ID of corresponding LSTF (see LSTF).
void | setReserved1(int field_2_reserved1) Reserved.
void | setReserved2(int field_3_reserved2) Reserved.
void | setReserved3(byte field_7_reserved3) Reserved.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

field_1_lsid

protected int field_1_lsid

field_2_reserved1

protected int field_2_reserved1

field_3_reserved2

protected int field_3_reserved2

field_4_clfolvl

protected byte field_4_clfolvl

field_5_ibstFltAutoNum

protected byte field_5_ibstFltAutoNum

field_6_grfhic

protected Grfhic field_6_grfhic

field_7_reserved3

protected byte field_7_reserved3
Constructor Detail

LFOAbstractType

protected LFOAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getLsid

@Internal
public int getLsid()
List ID of corresponding LSTF (see LSTF).

setLsid

@Internal
public void setLsid(int field_1_lsid)
List ID of corresponding LSTF (see LSTF).

getReserved1

@Internal
public int getReserved1()
Reserved.

setReserved1

@Internal
public void setReserved1(int field_2_reserved1)
Reserved.

getReserved2

@Internal
public int getReserved2()
Reserved.

setReserved2

@Internal
public void setReserved2(int field_3_reserved2)
Reserved.

getClfolvl

@Internal
public byte getClfolvl()
Count of levels whose format is overridden (see LFOLVL).

setClfolvl

@Internal
public void setClfolvl(byte field_4_clfolvl)
Count of levels whose format is overridden (see LFOLVL).

getIbstFltAutoNum

@Internal
public byte getIbstFltAutoNum()
Used for AUTONUM field emulation.

setIbstFltAutoNum

@Internal
public void setIbstFltAutoNum(byte field_5_ibstFltAutoNum)
Used for AUTONUM field emulation.

getGrfhic

@Internal
public Grfhic getGrfhic()
HTML compatibility flags.

setGrfhic

@Internal
public void setGrfhic(Grfhic field_6_grfhic)
HTML compatibility flags.

getReserved3

@Internal
public byte getReserved3()
Reserved.

setReserved3

@Internal
public void setReserved3(byte field_7_reserved3)
Reserved.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LFOLVLBaseAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class LFOLVLBaseAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

@Internal
public abstract class LFOLVLBaseAbstractType
extends java.lang.Object

The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected int | field_1_iStartAt
protected int | field_2_flags
Constructor Summary
protected LFOLVLBaseAbstractType()
Method Summary
boolean | equals(java.lang.Object obj)
protected void | fillFields(byte[] data, int offset)
int | getFlags() Get the flags field for the LFOLVLBase record.
short | getGrfhic() A grfhic that specifies the HTML incompatibilities of the overriding level formatting
byte | getILvl() An unsigned integer that specifies the zero-based level of the list that this overrides.
int | getIStartAt() If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL.
static int | getSize() Size of record
short | getUnused1() Deprecated. This field should not be used according to specification
byte | getUnused2() Deprecated. This field should not be used according to specification
int | hashCode()
boolean | isFFormatting() A bit that specifies whether lvl is an LVL that overrides the corresponding LVL
boolean | isFStartAt() A bit that specifies whether this LFOLVL overrides the start-at value of the level.
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setFFormatting(boolean value) Sets the fFormatting field value.
void | setFlags(int field_2_flags) Set the flags field for the LFOLVLBase record.
void | setFStartAt(boolean value) Sets the fStartAt field value.
void | setGrfhic(short value) Sets the grfhic field value.
void | setILvl(byte value) Sets the iLvl field value.
void | setIStartAt(int field_1_iStartAt) If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL.
void | setUnused1(short value) Sets the unused1 field value.
void | setUnused2(byte value) Sets the unused2 field value.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

field_1_iStartAt

protected int field_1_iStartAt

field_2_flags

protected int field_2_flags
Constructor Detail

LFOLVLBaseAbstractType

protected LFOLVLBaseAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getIStartAt

@Internal
public int getIStartAt()
If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL. This value MUST be less than or equal to 0x7FFF and MUST be greater than or equal to zero. If both fStartAt and fFormatting are set to 0x1, or if fStartAt is set to 0x0, this value is undefined and MUST be ignored.

setIStartAt

@Internal
public void setIStartAt(int field_1_iStartAt)
If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL. This value MUST be less than or equal to 0x7FFF and MUST be greater than or equal to zero. If both fStartAt and fFormatting are set to 0x1, or if fStartAt is set to 0x0, this value is undefined and MUST be ignored.

getFlags

@Internal
public int getFlags()
Get the flags field for the LFOLVLBase record.

setFlags

@Internal
public void setFlags(int field_2_flags)
Set the flags field for the LFOLVLBase record.

setILvl

@Internal
public void setILvl(byte value)
Sets the iLvl field value. An unsigned integer that specifies the zero-based level of the list that this overrides. This LFOLVL overrides the LVL that specifies the level formatting of this level of the LSTF that is specified by the lsid field of the LFO to which this LFOLVL corresponds. This value MUST be less than or equal to 0x08

getILvl

@Internal
public byte getILvl()
An unsigned integer that specifies the zero-based level of the list that this overrides. This LFOLVL overrides the LVL that specifies the level formatting of this level of the LSTF that is specified by the lsid field of the LFO to which this LFOLVL corresponds. This value MUST be less than or equal to 0x08

Returns:
the iLvl field value.

setFStartAt

@Internal
public void setFStartAt(boolean value)
Sets the fStartAt field value. A bit that specifies whether this LFOLVL overrides the start-at value of the level.

isFStartAt

@Internal
public boolean isFStartAt()
A bit that specifies whether this LFOLVL overrides the start-at value of the level.

Returns:
the fStartAt field value.

setFFormatting

@Internal
public void setFFormatting(boolean value)
Sets the fFormatting field value. A bit that specifies whether lvl is an LVL that overrides the corresponding LVL

isFFormatting

@Internal
public boolean isFFormatting()
A bit that specifies whether lvl is an LVL that overrides the corresponding LVL

Returns:
the fFormatting field value.

setGrfhic

@Internal
public void setGrfhic(short value)
Sets the grfhic field value. A grfhic that specifies the HTML incompatibilities of the overriding level formatting

getGrfhic

@Internal
public short getGrfhic()
A grfhic that specifies the HTML incompatibilities of the overriding level formatting

Returns:
the grfhic field value.

setUnused1

@Internal
public void setUnused1(short value)
Sets the unused1 field value. This MUST be ignored

getUnused1

@Internal
@Deprecated
public short getUnused1()
Deprecated. This field should not be used according to specification

This MUST be ignored

Returns:
the unused1 field value.

setUnused2

@Internal
public void setUnused2(byte value)
Sets the unused2 field value. This MUST be ignored

getUnused2

@Internal
@Deprecated
public byte getUnused2()
Deprecated. This field should not be used according to specification

This MUST be ignored

Returns:
the unused2 field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LSTFAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class LSTFAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.LSTFAbstractType

@Internal
public abstract class LSTFAbstractType
extends java.lang.Object

The LSTF structure contains formatting properties that apply to an entire list.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected int | field_1_lsid
protected int | field_2_tplc
protected short[] | field_3_rgistdPara
protected byte | field_4_flags
protected Grfhic | field_5_grfhic
Constructor Summary
protected LSTFAbstractType()
Method Summary
boolean | equals(java.lang.Object obj)
protected void | fillFields(byte[] data, int offset)
byte | getFlags() Get the flags field for the LSTF record.
Grfhic | getGrfhic() A grfhic that specifies the HTML incompatibilities of the list..
int | getLsid() A signed integer that specifies the list identifier.
byte | getReserved1() Deprecated. This field should not be used according to specification
short[] | getRgistdPara() An array of nine 16-bit signed integers.
static int | getSize() Size of record
int | getTplc() A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes.
int | hashCode()
boolean | isFAutoNum() A bit that specifies whether the list that this LSTF represents is used for the AUTONUMOUT, AUTONUMLGL, and AUTONUM fields (see AUTONUMOUT, AUTONUMLGL, and AUTONUM in flt)
boolean | isFHybrid() A bit that specifies whether the list this LSTF defines is a hybrid list
boolean | isFSimpleList() A bit that, when set to 0x1, specifies that this LSTF represents a simple (one-level) list that has one corresponding LVL (see the fcPlfLst field of FibRgFcLcb97).
boolean | isUnused1() Deprecated. This field should not be used according to specification
boolean | isUnused2() Deprecated. This field should not be used according to specification
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setFAutoNum(boolean value) Sets the fAutoNum field value.
void | setFHybrid(boolean value) Sets the fHybrid field value.
void | setFlags(byte field_4_flags) Set the flags field for the LSTF record.
void | setFSimpleList(boolean value) Sets the fSimpleList field value.
void | setGrfhic(Grfhic field_5_grfhic) A grfhic that specifies the HTML incompatibilities of the list..
void | setLsid(int field_1_lsid) A signed integer that specifies the list identifier.
void | setReserved1(byte value) Sets the reserved1 field value.
void | setRgistdPara(short[] field_3_rgistdPara) An array of nine 16-bit signed integers.
void | setTplc(int field_2_tplc) A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes.
void | setUnused1(boolean value) Sets the unused1 field value.
void | setUnused2(boolean value) Sets the unused2 field value.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

field_1_lsid

protected int field_1_lsid

field_2_tplc

protected int field_2_tplc

field_3_rgistdPara

protected short[] field_3_rgistdPara

field_4_flags

protected byte field_4_flags

field_5_grfhic

protected Grfhic field_5_grfhic
Constructor Detail

LSTFAbstractType

protected LSTFAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getLsid

@Internal
public int getLsid()
A signed integer that specifies the list identifier. This MUST be unique for each LSTF. This value MUST not be 0xFFFFFFFF.

setLsid

@Internal
public void setLsid(int field_1_lsid)
A signed integer that specifies the list identifier. This MUST be unique for each LSTF. This value MUST not be 0xFFFFFFFF.

getTplc

@Internal
public int getTplc()
A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes. If fHybrid is nonzero, this MUST be ignored.

setTplc

@Internal
public void setTplc(int field_2_tplc)
A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes. If fHybrid is nonzero, this MUST be ignored.

getRgistdPara

@Internal
public short[] getRgistdPara()
An array of nine 16-bit signed integers. Each element of rgistdPara specifies the ISTD of the style that is linked to the corresponding level in the list. If no style is linked to a given level, the value of the corresponding element of rgistdPara MUST be 0x0FFF.

setRgistdPara

@Internal
public void setRgistdPara(short[] field_3_rgistdPara)
An array of nine 16-bit signed integers. Each element of rgistdPara specifies the ISTD of the style that is linked to the corresponding level in the list. If no style is linked to a given level, the value of the corresponding element of rgistdPara MUST be 0x0FFF.

getFlags

@Internal
public byte getFlags()
Get the flags field for the LSTF record.

setFlags

@Internal
public void setFlags(byte field_4_flags)
Set the flags field for the LSTF record.

getGrfhic

@Internal
public Grfhic getGrfhic()
A grfhic that specifies the HTML incompatibilities of the list..

setGrfhic

@Internal
public void setGrfhic(Grfhic field_5_grfhic)
A grfhic that specifies the HTML incompatibilities of the list..

setFSimpleList

@Internal
public void setFSimpleList(boolean value)
Sets the fSimpleList field value. A bit that, when set to 0x1, specifies that this LSTF represents a simple (one-level) list that has one corresponding LVL (see the fcPlfLst field of FibRgFcLcb97). Otherwise, this LSTF represents a multi-level list that has nine corresponding LVLs

isFSimpleList

@Internal
public boolean isFSimpleList()
A bit that, when set to 0x1, specifies that this LSTF represents a simple (one-level) list that has one corresponding LVL (see the fcPlfLst field of FibRgFcLcb97). Otherwise, this LSTF represents a multi-level list that has nine corresponding LVLs

Returns:
the fSimpleList field value.

setUnused1

@Internal
public void setUnused1(boolean value)
Sets the unused1 field value. This bit MUST be ignored

isUnused1

@Internal
@Deprecated
public boolean isUnused1()
Deprecated. This field should not be used according to specification

This bit MUST be ignored

Returns:
the unused1 field value.

setFAutoNum

@Internal
public void setFAutoNum(boolean value)
Sets the fAutoNum field value. A bit that specifies whether the list that this LSTF represents is used for the AUTONUMOUT, AUTONUMLGL, and AUTONUM fields (see AUTONUMOUT, AUTONUMLGL, and AUTONUM in flt)

isFAutoNum

@Internal
public boolean isFAutoNum()
A bit that specifies whether the list that this LSTF represents is used for the AUTONUMOUT, AUTONUMLGL, and AUTONUM fields (see AUTONUMOUT, AUTONUMLGL, and AUTONUM in flt)

Returns:
the fAutoNum field value.

setUnused2

@Internal
public void setUnused2(boolean value)
Sets the unused2 field value. This bit MUST be ignored

isUnused2

@Internal
@Deprecated
public boolean isUnused2()
Deprecated. This field should not be used according to specification

This bit MUST be ignored

Returns:
the unused2 field value.

setFHybrid

@Internal
public void setFHybrid(boolean value)
Sets the fHybrid field value. A bit that specifies whether the list this LSTF defines is a hybrid list

isFHybrid

@Internal
public boolean isFHybrid()
A bit that specifies whether the list this LSTF defines is a hybrid list

Returns:
the fHybrid field value.

setReserved1

@Internal
public void setReserved1(byte value)
Sets the reserved1 field value. This MUST be zero, and MUST be ignored.

getReserved1

@Internal
@Deprecated
public byte getReserved1()
Deprecated. This field should not be used according to specification

This MUST be zero, and MUST be ignored.

Returns:
the reserved1 field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LVLFAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class LVLFAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.LVLFAbstractType

@Internal
public abstract class LVLFAbstractType
extends java.lang.Object

The LVLF structure contains formatting properties for an individual level in a list.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected int | field_1_iStartAt
protected short | field_10_ilvlRestartLim
protected Grfhic | field_11_grfhic
protected byte | field_2_nfc
protected byte | field_3_info
protected byte[] | field_4_rgbxchNums
protected byte | field_5_ixchFollow
protected int | field_6_dxaIndentSav
protected int | field_7_unused2
protected short | field_8_cbGrpprlChpx
protected short | field_9_cbGrpprlPapx
Constructor Summary
protected LVLFAbstractType()
Method Summary
boolean | equals(java.lang.Object obj)
protected void | fillFields(byte[] data, int offset)
short | getCbGrpprlChpx() An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.
short | getCbGrpprlPapx() An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.
int | getDxaIndentSav() If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed.
Grfhic | getGrfhic() A grfhic that specifies the HTML incompatibilities of the level..
short | getIlvlRestartLim() An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart.
byte | getInfo() Get the info field for the LVLF record.
int | getIStartAt() A signed integer that specifies the beginning number for the number sequence belonging to this level.
byte | getIxchFollow() An unsigned integer that specifies the character that follows the number text.
byte | getJc() An unsigned integer that specifies the justification of this level
byte | getNfc() An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list.
byte[] | getRgbxchNums() An array of 8-bit integers.
static int | getSize() Size of record
int | getUnused2() This field MUST be ignored.
int | hashCode()
boolean | isFConverted() A bit that specifies whether the nfc of this LVLF structure was previously a temporary value used for bidirectional compatibility that was converted into a standard MSONFC
boolean | isFIndentSav() A bit that specifies whether the level indented the text it was applied to and that the indent needs to be removed when numbering is removed.
boolean | isFLegal() A bit that specifies whether this level overrides the nfc of all inherited level numbers.
boolean | isFNoRestart() A bit that specifies whether the number sequence of the level does not restart after a level is encountered that is more significant than the level to which this LVLF corresponds
boolean | isFTentative() A bit that specifies whether the format of the level is tentative
boolean | isUnused1() Deprecated. This field should not be used according to specification
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setCbGrpprlChpx(short field_8_cbGrpprlChpx) An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.
void | setCbGrpprlPapx(short field_9_cbGrpprlPapx) An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.
void | setDxaIndentSav(int field_6_dxaIndentSav) If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed.
void | setFConverted(boolean value) Sets the fConverted field value.
void | setFIndentSav(boolean value) Sets the fIndentSav field value.
void | setFLegal(boolean value) Sets the fLegal field value.
void | setFNoRestart(boolean value) Sets the fNoRestart field value.
void | setFTentative(boolean value) Sets the fTentative field value.
void | setGrfhic(Grfhic field_11_grfhic) A grfhic that specifies the HTML incompatibilities of the level..
void | setIlvlRestartLim(short field_10_ilvlRestartLim) An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart.
void | setInfo(byte field_3_info) Set the info field for the LVLF record.
void | setIStartAt(int field_1_iStartAt) A signed integer that specifies the beginning number for the number sequence belonging to this level.
void | setIxchFollow(byte field_5_ixchFollow) An unsigned integer that specifies the character that follows the number text.
void | setJc(byte value) Sets the jc field value.
void | setNfc(byte field_2_nfc) An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list.
void | setRgbxchNums(byte[] field_4_rgbxchNums) An array of 8-bit integers.
void | setUnused1(boolean value) Sets the unused1 field value.
void | setUnused2(int field_7_unused2) This field MUST be ignored.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

field_1_iStartAt

protected int field_1_iStartAt

field_2_nfc

protected byte field_2_nfc

field_3_info

protected byte field_3_info

field_4_rgbxchNums

protected byte[] field_4_rgbxchNums

field_5_ixchFollow

protected byte field_5_ixchFollow

field_6_dxaIndentSav

protected int field_6_dxaIndentSav

field_7_unused2

protected int field_7_unused2

field_8_cbGrpprlChpx

protected short field_8_cbGrpprlChpx

field_9_cbGrpprlPapx

protected short field_9_cbGrpprlPapx

field_10_ilvlRestartLim

protected short field_10_ilvlRestartLim

field_11_grfhic

protected Grfhic field_11_grfhic
Constructor Detail

LVLFAbstractType

protected LVLFAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getIStartAt

@Internal
public int getIStartAt()
A signed integer that specifies the beginning number for the number sequence belonging to this level. This value MUST be less than or equal to 0x7FFF and MUST be greater than or equal to zero. If this level does not have a number sequence (see nfc), this MUST be ignored.

setIStartAt

@Internal
public void setIStartAt(int field_1_iStartAt)
A signed integer that specifies the beginning number for the number sequence belonging to this level. This value MUST be less than or equal to 0x7FFF and MUST be greater than or equal to zero. If this level does not have a number sequence (see nfc), this MUST be ignored.

getNfc

@Internal
public byte getNfc()
An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list. This value MUST not be equal to 0x08, 0x09, 0x0F, or 0x13. If this is equal to 0xFF or 0x17, this level does not have a number sequence and therefore has no number formatting. If this is equal to 0x17, the level uses bullets.

setNfc

@Internal
public void setNfc(byte field_2_nfc)
An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list. This value MUST not be equal to 0x08, 0x09, 0x0F, or 0x13. If this is equal to 0xFF or 0x17, this level does not have a number sequence and therefore has no number formatting. If this is equal to 0x17, the level uses bullets.

getInfo

@Internal
public byte getInfo()
Get the info field for the LVLF record.

setInfo

@Internal
public void setInfo(byte field_3_info)
Set the info field for the LVLF record.

getRgbxchNums

@Internal
public byte[] getRgbxchNums()
An array of 8-bit integers. Each integer specifies a one-based character offset to a level placeholder in the xst.rgtchar of the LVL that contains this LVLF. This array is zero-terminated, unless it is full. The count of elements in this array, before to the first terminating zero, MUST be less than or equal to the one-based level of the list to which this LVL corresponds. The integers in this array, before the first terminating zero, MUST be in ascending order, and MUST be unique.

setRgbxchNums

@Internal
public void setRgbxchNums(byte[] field_4_rgbxchNums)
An array of 8-bit integers. Each integer specifies a one-based character offset to a level placeholder in the xst.rgtchar of the LVL that contains this LVLF. This array is zero-terminated, unless it is full. The count of elements in this array, before to the first terminating zero, MUST be less than or equal to the one-based level of the list to which this LVL corresponds. The integers in this array, before the first terminating zero, MUST be in ascending order, and MUST be unique.

getIxchFollow

@Internal
public byte getIxchFollow()
An unsigned integer that specifies the character that follows the number text.

setIxchFollow

@Internal
public void setIxchFollow(byte field_5_ixchFollow)
An unsigned integer that specifies the character that follows the number text.

getDxaIndentSav

@Internal
public int getDxaIndentSav()
If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed. This MUST be less than or equal to 0x00007BC0 or greater than or equal to 0xFFFF8440. If fIndentSav is zero, this MUST be ignored.

setDxaIndentSav

@Internal
public void setDxaIndentSav(int field_6_dxaIndentSav)
If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed. This MUST be less than or equal to 0x00007BC0 or greater than or equal to 0xFFFF8440. If fIndentSav is zero, this MUST be ignored.

getUnused2

@Internal
public int getUnused2()
This field MUST be ignored.

setUnused2

@Internal
public void setUnused2(int field_7_unused2)
This field MUST be ignored.

getCbGrpprlChpx

@Internal
public short getCbGrpprlChpx()
An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.

setCbGrpprlChpx

@Internal
public void setCbGrpprlChpx(short field_8_cbGrpprlChpx)
An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.

getCbGrpprlPapx

@Internal
public short getCbGrpprlPapx()
An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.

setCbGrpprlPapx

@Internal
public void setCbGrpprlPapx(short field_9_cbGrpprlPapx)
An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.

getIlvlRestartLim

@Internal
public short getIlvlRestartLim()
An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart. The number sequence of this level does restart after any level that is more significant than the specified level. This MUST be less than or equal to the zero-based level of the list to which this LVLF corresponds. If fNoRestart is zero, this MUST be ignored. If this level does not have a number sequence (see nfc), this MUST be ignored.

setIlvlRestartLim

@Internal
public void setIlvlRestartLim(short field_10_ilvlRestartLim)
An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart. The number sequence of this level does restart after any level that is more significant than the specified level. This MUST be less than or equal to the zero-based level of the list to which this LVLF corresponds. If fNoRestart is zero, this MUST be ignored. If this level does not have a number sequence (see nfc), this MUST be ignored.

getGrfhic

@Internal
public Grfhic getGrfhic()
A grfhic that specifies the HTML incompatibilities of the level..

setGrfhic

@Internal
public void setGrfhic(Grfhic field_11_grfhic)
A grfhic that specifies the HTML incompatibilities of the level..

setJc

@Internal
public void setJc(byte value)
Sets the jc field value. An unsigned integer that specifies the justification of this level

getJc

@Internal
public byte getJc()
An unsigned integer that specifies the justification of this level

Returns:
the jc field value.

setFLegal

@Internal
public void setFLegal(boolean value)
Sets the fLegal field value. A bit that specifies whether this level overrides the nfc of all inherited level numbers. If the original nfc of a level number is msonfcArabicLZ, it is preserved. Otherwise, the nfc of the level number is overridden by msonfcArabic.

isFLegal

@Internal
public boolean isFLegal()
A bit that specifies whether this level overrides the nfc of all inherited level numbers. If the original nfc of a level number is msonfcArabicLZ, it is preserved. Otherwise, the nfc of the level number is overridden by msonfcArabic.

Returns:
the fLegal field value.

setFNoRestart

@Internal
public void setFNoRestart(boolean value)
Sets the fNoRestart field value. A bit that specifies whether the number sequence of the level does not restart after a level is encountered that is more significant than the level to which this LVLF corresponds

isFNoRestart

@Internal
public boolean isFNoRestart()
A bit that specifies whether the number sequence of the level does not restart after a level is encountered that is more significant than the level to which this LVLF corresponds

Returns:
the fNoRestart field value.

setFIndentSav

@Internal
public void setFIndentSav(boolean value)
Sets the fIndentSav field value. A bit that specifies whether the level indented the text it was applied to and that the indent needs to be removed when numbering is removed. The indent to be removed is stored in dxaIndentSav

isFIndentSav

@Internal
public boolean isFIndentSav()
A bit that specifies whether the level indented the text it was applied to and that the indent needs to be removed when numbering is removed. The indent to be removed is stored in dxaIndentSav

Returns:
the fIndentSav field value.

setFConverted

@Internal
public void setFConverted(boolean value)
Sets the fConverted field value. A bit that specifies whether the nfc of this LVLF structure was previously a temporary value used for bidirectional compatibility that was converted into a standard MSONFC

isFConverted

@Internal
public boolean isFConverted()
A bit that specifies whether the nfc of this LVLF structure was previously a temporary value used for bidirectional compatibility that was converted into a standard MSONFC

Returns:
the fConverted field value.

setUnused1

@Internal
public void setUnused1(boolean value)
Sets the unused1 field value. This bit MUST be ignored

isUnused1

@Internal
@Deprecated
public boolean isUnused1()
Deprecated. This field should not be used according to specification

This bit MUST be ignored

Returns:
the unused1 field value.

setFTentative

@Internal
public void setFTentative(boolean value)
Sets the fTentative field value. A bit that specifies whether the format of the level is tentative

isFTentative

@Internal
public boolean isFTentative()
A bit that specifies whether the format of the level is tentative

Returns:
the fTentative field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf.model.types
Classes
BKFAbstractType
CHPAbstractType
DOPAbstractType
FibBaseAbstractType
FibRgLw95AbstractType
FibRgLw97AbstractType
FibRgW97AbstractType
FLDAbstractType
FRDAbstractType
FSPAAbstractType
GrfhicAbstractType
HRESIAbstractType
LFOAbstractType
LFOLVLBaseAbstractType
LSTFAbstractType
LVLFAbstractType
PAPAbstractType
PICFAbstractType
SEPAbstractType
SHD80AbstractType
SHDAbstractType
StdfBaseAbstractType
StdfPost2000AbstractType
StshifAbstractType
TAPAbstractType
TBDAbstractType
TCAbstractType
TLPAbstractType


org.apache.poi.hwpf.model.types

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.model.types

Class Summary
BKFAbstractType | BooKmark First descriptor (BKF).
CHPAbstractType | Character Properties.
DOPAbstractType | Document Properties.
FibBaseAbstractType | Base part of the File information Block (FibBase).
FibRgLw95AbstractType | The FibRgLw95 structure is the third section of the FIB for Word95.
FibRgLw97AbstractType | The FibRgLw97 structure is the third section of the FIB.
FibRgW97AbstractType | The FibRgW97 structure is a variable-length portion of the Fib.
FLDAbstractType | Field Descriptor (FLD).
FRDAbstractType | Footnote Reference Descriptor (FRD).
FSPAAbstractType | File Shape Address (FSPA).
GrfhicAbstractType | The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
HRESIAbstractType | Hyphenation (HRESI).
LFOAbstractType | List Format Override (LFO).
LFOLVLBaseAbstractType | The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.
LSTFAbstractType | The LSTF structure contains formatting properties that apply to an entire list.
LVLFAbstractType | The LVLF structure contains formatting properties for an individual level in a list.
PAPAbstractType | Paragraph Properties.
PICFAbstractType | The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
SEPAbstractType | Section Properties.
SHD80AbstractType | The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.
SHDAbstractType | The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
StdfBaseAbstractType | The StdfBase structure specifies general information about a style.
StdfPost2000AbstractType | The StdfPost2000 structure specifies general information about a style.
StshifAbstractType | The Stshif structure specifies general stylesheet information.
TAPAbstractType | Table Properties.
TBDAbstractType | The TBD is a substructure of the PAP.
TCAbstractType | Table Cell Descriptor.
TLPAbstractType | Table Autoformat Look sPecifier (TLP).


org.apache.poi.hwpf.model.types Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.model.types

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hwpf.model.types.BKFAbstractType
    • org.apache.poi.hwpf.model.types.CHPAbstractType
    • org.apache.poi.hwpf.model.types.DOPAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
    • org.apache.poi.hwpf.model.types.FibBaseAbstractType
    • org.apache.poi.hwpf.model.types.FibRgLw95AbstractType
    • org.apache.poi.hwpf.model.types.FibRgLw97AbstractType
    • org.apache.poi.hwpf.model.types.FibRgW97AbstractType
    • org.apache.poi.hwpf.model.types.FLDAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
    • org.apache.poi.hwpf.model.types.FRDAbstractType
    • org.apache.poi.hwpf.model.types.FSPAAbstractType
    • org.apache.poi.hwpf.model.types.GrfhicAbstractType
    • org.apache.poi.hwpf.model.types.HRESIAbstractType
    • org.apache.poi.hwpf.model.types.LFOAbstractType
    • org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType
    • org.apache.poi.hwpf.model.types.LSTFAbstractType
    • org.apache.poi.hwpf.model.types.LVLFAbstractType
    • org.apache.poi.hwpf.model.types.PAPAbstractType
    • org.apache.poi.hwpf.model.types.PICFAbstractType
    • org.apache.poi.hwpf.model.types.SEPAbstractType
    • org.apache.poi.hwpf.model.types.SHD80AbstractType
    • org.apache.poi.hwpf.model.types.SHDAbstractType
    • org.apache.poi.hwpf.model.types.StdfBaseAbstractType
    • org.apache.poi.hwpf.model.types.StdfPost2000AbstractType
    • org.apache.poi.hwpf.model.types.StshifAbstractType
    • org.apache.poi.hwpf.model.types.TAPAbstractType
    • org.apache.poi.hwpf.model.types.TBDAbstractType
    • org.apache.poi.hwpf.model.types.TCAbstractType
    • org.apache.poi.hwpf.model.types.TLPAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)


Uses of Package org.apache.poi.hwpf.model.types

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.model.types

Packages that use org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.model.types used by org.apache.poi.hwpf.model
BKFAbstractType
BooKmark First descriptor (BKF).
DOPAbstractType
Document Properties.
FibBaseAbstractType
Base part of the File information Block (FibBase).
FLDAbstractType
Field Descriptor (FLD).
FRDAbstractType
Footnote Reference Descriptor (FRD).
FSPAAbstractType
File Shape Address (FSPA).
GrfhicAbstractType
The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
HRESIAbstractType
Hyphenation (HRESI).
PICFAbstractType
The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
TBDAbstractType
The TBD is a substructure of the PAP.

Classes in org.apache.poi.hwpf.model.types used by org.apache.poi.hwpf.usermodel
CHPAbstractType
Character Properties.
PAPAbstractType
Paragraph Properties.
SEPAbstractType
Section Properties.
SHD80AbstractType
The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.
SHDAbstractType
The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
TAPAbstractType
Table Properties.
TCAbstractType
Table Cell Descriptor.
TLPAbstractType
Table Autoformat Look sPecifier (TLP).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PAPAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class PAPAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.PAPAbstractType
Direct Known Subclasses:
ParagraphProperties
@Internal
public abstract class PAPAbstractType
extends java.lang.Object

Paragraph Properties.

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
S. Ryan Ackley

Field Summary
protected static byte | BRCL_DOUBLE
protected static byte | BRCL_SHADOW
protected static byte | BRCL_SINGLE
protected static byte | BRCL_THICK
protected static byte | BRCP_BAR_TO_LEFT_OF_PARAGRAPH
protected static byte | BRCP_BORDER_ABOVE
protected static byte | BRCP_BORDER_BELOW
protected static byte | BRCP_BOX_AROUND
protected static byte | BRCP_NONE
protected int | field_1_istd
protected boolean | field_10_fNoLnn
protected LineSpacingDescriptor | field_11_lspd
protected int | field_12_dyaBefore
protected int | field_13_dyaAfter
protected boolean | field_14_fInTable
protected boolean | field_15_finTableW97
protected boolean | field_16_fTtp
protected int | field_17_dxaAbs
protected int | field_18_dyaAbs
protected int | field_19_dxaWidth
protected boolean | field_2_fSideBySide
protected boolean | field_20_fBrLnAbove
protected boolean | field_21_fBrLnBelow
protected byte | field_22_pcVert
protected byte | field_23_pcHorz
protected byte | field_24_wr
protected boolean | field_25_fNoAutoHyph
protected int | field_26_dyaHeight
protected boolean | field_27_fMinHeight
protected DropCapSpecifier | field_28_dcs
protected int | field_29_dyaFromText
protected boolean | field_3_fKeep
protected int | field_30_dxaFromText
protected boolean | field_31_fLocked
protected boolean | field_32_fWidowControl
protected boolean | field_33_fKinsoku
protected boolean | field_34_fWordWrap
protected boolean | field_35_fOverflowPunct
protected boolean | field_36_fTopLinePunct
protected boolean | field_37_fAutoSpaceDE
protected boolean | field_38_fAutoSpaceDN
protected int | field_39_wAlignFont
protected boolean | field_4_fKeepFollow
protected short | field_40_fontAlign
protected byte | field_41_lvl
protected boolean | field_42_fBiDi
protected boolean | field_43_fNumRMIns
protected boolean | field_44_fCrLf
protected boolean | field_45_fUsePgsuSettings
protected boolean | field_46_fAdjustRight
protected int | field_47_itap
protected boolean | field_48_fInnerTableCell
protected boolean | field_49_fOpenTch
protected boolean | field_5_fPageBreakBefore
protected boolean | field_50_fTtpEmbedded
protected short | field_51_dxcRight
protected short | field_52_dxcLeft
protected short | field_53_dxcLeft1
protected boolean | field_54_fDyaBeforeAuto
protected boolean | field_55_fDyaAfterAuto
protected int | field_56_dxaRight
protected int | field_57_dxaLeft
protected int | field_58_dxaLeft1
protected byte | field_59_jc
protected byte | field_6_brcl
protected BorderCode | field_60_brcTop
protected BorderCode | field_61_brcLeft
protected BorderCode | field_62_brcBottom
protected BorderCode | field_63_brcRight
protected BorderCode | field_64_brcBetween
protected BorderCode | field_65_brcBar
protected ShadingDescriptor | field_66_shd
protected byte[] | field_67_anld
protected byte[] | field_68_phe
protected boolean | field_69_fPropRMark
protected byte | field_7_brcp
protected int | field_70_ibstPropRMark
protected DateAndTime | field_71_dttmPropRMark
protected int | field_72_itbdMac
protected int[] | field_73_rgdxaTab
protected TabDescriptor[] | field_74_rgtbd
protected byte[] | field_75_numrm
protected byte[] | field_76_ptap
protected boolean | field_77_fNoAllowOverlap
protected long | field_78_ipgp
protected long | field_79_rsid
protected byte | field_8_ilvl
protected int | field_9_ilfo
protected static boolean | FMINHEIGHT_AT_LEAST
protected static boolean | FMINHEIGHT_EXACT
protected static byte | WALIGNFONT_AUTO
protected static byte | WALIGNFONT_CENTERED
protected static byte | WALIGNFONT_HANGING
protected static byte | WALIGNFONT_ROMAN
protected static byte | WALIGNFONT_VARIABLE
Constructor Summary
protected PAPAbstractType()
Method Summary
byte[] | getAnld() Get the anld field for the PAP record.
BorderCode | getBrcBar() Get the brcBar field for the PAP record.
BorderCode | getBrcBetween() Get the brcBetween field for the PAP record.
BorderCode | getBrcBottom() Get the brcBottom field for the PAP record.
byte | getBrcl() Border line style.
BorderCode | getBrcLeft() Get the brcLeft field for the PAP record.
byte | getBrcp() Rectangle border codes.
BorderCode | getBrcRight() Get the brcRight field for the PAP record.
BorderCode | getBrcTop() Get the brcTop field for the PAP record.
DropCapSpecifier | getDcs() Get the dcs field for the PAP record.
DateAndTime | getDttmPropRMark() Get the dttmPropRMark field for the PAP record.
int | getDxaAbs() Get the dxaAbs field for the PAP record.
int | getDxaFromText() Horizontal distance between text and absolutely positioned object.
int | getDxaLeft() Get the dxaLeft field for the PAP record.
int | getDxaLeft1() Get the dxaLeft1 field for the PAP record.
int | getDxaRight() Get the dxaRight field for the PAP record.
int | getDxaWidth() Get the dxaWidth field for the PAP record.
short | getDxcLeft() Left indent in character units.
short | getDxcLeft1() First line indent in character units.
short | getDxcRight() Right indent in character units.
int | getDyaAbs() Get the dyaAbs field for the PAP record.
int | getDyaAfter() Space after paragraph.
int | getDyaBefore() Space before paragraph.
int | getDyaFromText() Vertical distance between text and absolutely positioned object.
int | getDyaHeight() Get the dyaHeight field for the PAP record.
boolean | getFAdjustRight() Get the fAdjustRight field for the PAP record.
boolean | getFAutoSpaceDE() auto space East Asian and alphabetic characters.
boolean | getFAutoSpaceDN() auto space East Asian and numeric characters.
boolean | getFBiDi() Get the fBiDi field for the PAP record.
boolean | getFBrLnAbove() Get the fBrLnAbove field for the PAP record.
boolean | getFBrLnBelow() Get the fBrLnBelow field for the PAP record.
boolean | getFCrLf() Get the fCrLf field for the PAP record.
boolean | getFDyaAfterAuto() Vertical spacing after is automatic.
boolean | getFDyaBeforeAuto() Vertical spacing before is automatic.
boolean | getFInnerTableCell() When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.
boolean | getFInTable() Paragraph is in table flag.
boolean | getFinTableW97() Archaic paragraph is in table flag.
boolean | getFKeep() Get the fKeep field for the PAP record.
boolean | getFKeepFollow() Get the fKeepFollow field for the PAP record.
boolean | getFKinsoku() apply Kinsoku rules when performing line wrapping.
boolean | getFLocked() Anchor of an absolutely positioned frame is locked.
boolean | getFMinHeight() Minimum height is exact or auto.
boolean | getFNoAllowOverlap() When 1, absolutely positioned paragraph cannot overlap with another paragraph.
boolean | getFNoAutoHyph() Get the fNoAutoHyph field for the PAP record.
boolean | getFNoLnn() No line numbering.
boolean | getFNumRMIns() Get the fNumRMIns field for the PAP record.
short | getFontAlign() Used internally by Word.
boolean | getFOpenTch() Ensure the Table Cell char doesn't show up as zero height.
boolean | getFOverflowPunct() apply overflow punctuation rules when performing line wrapping.
boolean | getFPageBreakBefore() Get the fPageBreakBefore field for the PAP record.
boolean | getFPropRMark() Get the fPropRMark field for the PAP record.
boolean | getFSideBySide() Get the fSideBySide field for the PAP record.
boolean | getFTopLinePunct() perform top line punctuation processing.
boolean | getFTtp() Table trailer paragraph (last in table row).
boolean | getFTtpEmbedded() Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.
boolean | getFUsePgsuSettings() Get the fUsePgsuSettings field for the PAP record.
boolean | getFWidowControl() 1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.
boolean | getFWordWrap() perform word wrap.
int | getIbstPropRMark() Get the ibstPropRMark field for the PAP record.
int | getIlfo() 1-based index into the pllfo (lists structure), if non-zero.
byte | getIlvl() List level if non-zero.
long | getIpgp() HTML DIV ID for this paragraph.
int | getIstd() Index to style descriptor.
int | getItap() Table nesting level.
int | getItbdMac() Number of tabs stops defined for paragraph.
byte | getJc() Get the jc field for the PAP record.
LineSpacingDescriptor | getLspd() Line spacing descriptor.
byte | getLvl() Outline level.
byte[] | getNumrm() Get the numrm field for the PAP record.
byte | getPcHorz() Get the pcHorz field for the PAP record.
byte | getPcVert() Get the pcVert field for the PAP record.
byte[] | getPhe() Get the phe field for the PAP record.
byte[] | getPtap() Get the ptap field for the PAP record.
int[] | getRgdxaTab() Array of positions of itbdMac tab stops.
TabDescriptor[] | getRgtbd() Array of itbdMac tab descriptors.
long | getRsid() Save ID for last time this PAP was revised.
ShadingDescriptor | getShd() Get the shd field for the PAP record.
int | getWAlignFont() Get the wAlignFont field for the PAP record.
byte | getWr() Get the wr field for the PAP record.
boolean | isFBackward()
boolean | isFRotateFont()
boolean | isFVertical()
void | setAnld(byte[] field_67_anld) Set the anld field for the PAP record.
void | setBrcBar(BorderCode field_65_brcBar) Set the brcBar field for the PAP record.
void | setBrcBetween(BorderCode field_64_brcBetween) Set the brcBetween field for the PAP record.
void | setBrcBottom(BorderCode field_62_brcBottom) Set the brcBottom field for the PAP record.
void | setBrcl(byte field_6_brcl) Border line style.
void | setBrcLeft(BorderCode field_61_brcLeft) Set the brcLeft field for the PAP record.
void | setBrcp(byte field_7_brcp) Rectangle border codes.
void | setBrcRight(BorderCode field_63_brcRight) Set the brcRight field for the PAP record.
void | setBrcTop(BorderCode field_60_brcTop) Set the brcTop field for the PAP record.
void | setDcs(DropCapSpecifier field_28_dcs) Set the dcs field for the PAP record.
void | setDttmPropRMark(DateAndTime field_71_dttmPropRMark) Set the dttmPropRMark field for the PAP record.
void | setDxaAbs(int field_17_dxaAbs) Set the dxaAbs field for the PAP record.
void | setDxaFromText(int field_30_dxaFromText) Horizontal distance between text and absolutely positioned object.
void | setDxaLeft(int field_57_dxaLeft) Set the dxaLeft field for the PAP record.
void | setDxaLeft1(int field_58_dxaLeft1) Set the dxaLeft1 field for the PAP record.
void | setDxaRight(int field_56_dxaRight) Set the dxaRight field for the PAP record.
void | setDxaWidth(int field_19_dxaWidth) Set the dxaWidth field for the PAP record.
void | setDxcLeft(short field_52_dxcLeft) Left indent in character units.
void | setDxcLeft1(short field_53_dxcLeft1) First line indent in character units.
void | setDxcRight(short field_51_dxcRight) Right indent in character units.
void | setDyaAbs(int field_18_dyaAbs) Set the dyaAbs field for the PAP record.
void | setDyaAfter(int field_13_dyaAfter) Space after paragraph.
void | setDyaBefore(int field_12_dyaBefore) Space before paragraph.
void | setDyaFromText(int field_29_dyaFromText) Vertical distance between text and absolutely positioned object.
void | setDyaHeight(int field_26_dyaHeight) Set the dyaHeight field for the PAP record.
void | setFAdjustRight(boolean field_46_fAdjustRight) Set the fAdjustRight field for the PAP record.
void | setFAutoSpaceDE(boolean field_37_fAutoSpaceDE) auto space East Asian and alphabetic characters.
void | setFAutoSpaceDN(boolean field_38_fAutoSpaceDN) auto space East Asian and numeric characters.
void | setFBackward(boolean value) Sets the fBackward field value.
void | setFBiDi(boolean field_42_fBiDi) Set the fBiDi field for the PAP record.
void | setFBrLnAbove(boolean field_20_fBrLnAbove) Set the fBrLnAbove field for the PAP record.
void | setFBrLnBelow(boolean field_21_fBrLnBelow) Set the fBrLnBelow field for the PAP record.
void | setFCrLf(boolean field_44_fCrLf) Set the fCrLf field for the PAP record.
void | setFDyaAfterAuto(boolean field_55_fDyaAfterAuto) Vertical spacing after is automatic.
void | setFDyaBeforeAuto(boolean field_54_fDyaBeforeAuto) Vertical spacing before is automatic.
void | setFInnerTableCell(boolean field_48_fInnerTableCell) When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.
void | setFInTable(boolean field_14_fInTable) Paragraph is in table flag.
void | setFinTableW97(boolean field_15_finTableW97) Archaic paragraph is in table flag.
void | setFKeep(boolean field_3_fKeep) Set the fKeep field for the PAP record.
void | setFKeepFollow(boolean field_4_fKeepFollow) Set the fKeepFollow field for the PAP record.
void | setFKinsoku(boolean field_33_fKinsoku) apply Kinsoku rules when performing line wrapping.
void | setFLocked(boolean field_31_fLocked) Anchor of an absolutely positioned frame is locked.
void | setFMinHeight(boolean field_27_fMinHeight) Minimum height is exact or auto.
void | setFNoAllowOverlap(boolean field_77_fNoAllowOverlap) When 1, absolutely positioned paragraph cannot overlap with another paragraph.
void | setFNoAutoHyph(boolean field_25_fNoAutoHyph) Set the fNoAutoHyph field for the PAP record.
void | setFNoLnn(boolean field_10_fNoLnn) No line numbering.
void | setFNumRMIns(boolean field_43_fNumRMIns) Set the fNumRMIns field for the PAP record.
void | setFontAlign(short field_40_fontAlign) Used internally by Word.
void | setFOpenTch(boolean field_49_fOpenTch) Ensure the Table Cell char doesn't show up as zero height.
void | setFOverflowPunct(boolean field_35_fOverflowPunct) apply overflow punctuation rules when performing line wrapping.
void | setFPageBreakBefore(boolean field_5_fPageBreakBefore) Set the fPageBreakBefore field for the PAP record.
void | setFPropRMark(boolean field_69_fPropRMark) Set the fPropRMark field for the PAP record.
void | setFRotateFont(boolean value) Sets the fRotateFont field value.
void | setFSideBySide(boolean field_2_fSideBySide) Set the fSideBySide field for the PAP record.
void | setFTopLinePunct(boolean field_36_fTopLinePunct) perform top line punctuation processing.
void | setFTtp(boolean field_16_fTtp) Table trailer paragraph (last in table row).
void | setFTtpEmbedded(boolean field_50_fTtpEmbedded) Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.
void | setFUsePgsuSettings(boolean field_45_fUsePgsuSettings) Set the fUsePgsuSettings field for the PAP record.
void | setFVertical(boolean value) Sets the fVertical field value.
void | setFWidowControl(boolean field_32_fWidowControl) 1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.
void | setFWordWrap(boolean field_34_fWordWrap) perform word wrap.
void | setIbstPropRMark(int field_70_ibstPropRMark) Set the ibstPropRMark field for the PAP record.
void | setIlfo(int field_9_ilfo) 1-based index into the pllfo (lists structure), if non-zero.
void | setIlvl(byte field_8_ilvl) List level if non-zero.
void | setIpgp(long field_78_ipgp) HTML DIV ID for this paragraph.
void | setIstd(int field_1_istd) Index to style descriptor.
void | setItap(int field_47_itap) Table nesting level.
void | setItbdMac(int field_72_itbdMac) Number of tabs stops defined for paragraph.
void | setJc(byte field_59_jc) Set the jc field for the PAP record.
void | setLspd(LineSpacingDescriptor field_11_lspd) Line spacing descriptor.
void | setLvl(byte field_41_lvl) Outline level.
void | setNumrm(byte[] field_75_numrm) Set the numrm field for the PAP record.
void | setPcHorz(byte field_23_pcHorz) Set the pcHorz field for the PAP record.
void | setPcVert(byte field_22_pcVert) Set the pcVert field for the PAP record.
void | setPhe(byte[] field_68_phe) Set the phe field for the PAP record.
void | setPtap(byte[] field_76_ptap) Set the ptap field for the PAP record.
void | setRgdxaTab(int[] field_73_rgdxaTab) Array of positions of itbdMac tab stops.
void | setRgtbd(TabDescriptor[] field_74_rgtbd) Array of itbdMac tab descriptors.
void | setRsid(long field_79_rsid) Save ID for last time this PAP was revised.
void | setShd(ShadingDescriptor field_66_shd) Set the shd field for the PAP record.
void | setWAlignFont(int field_39_wAlignFont) Set the wAlignFont field for the PAP record.
void | setWr(byte field_24_wr) Set the wr field for the PAP record.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_istd

protected int field_1_istd

field_2_fSideBySide

protected boolean field_2_fSideBySide

field_3_fKeep

protected boolean field_3_fKeep

field_4_fKeepFollow

protected boolean field_4_fKeepFollow

field_5_fPageBreakBefore

protected boolean field_5_fPageBreakBefore

field_6_brcl

protected byte field_6_brcl

BRCL_SINGLE

protected static final byte BRCL_SINGLE
See Also:
Constant Field Values

BRCL_THICK

protected static final byte BRCL_THICK
See Also:
Constant Field Values

BRCL_DOUBLE

protected static final byte BRCL_DOUBLE
See Also:
Constant Field Values

BRCL_SHADOW

protected static final byte BRCL_SHADOW
See Also:
Constant Field Values

field_7_brcp

protected byte field_7_brcp

BRCP_NONE

protected static final byte BRCP_NONE
See Also:
Constant Field Values

BRCP_BORDER_ABOVE

protected static final byte BRCP_BORDER_ABOVE
See Also:
Constant Field Values

BRCP_BORDER_BELOW

protected static final byte BRCP_BORDER_BELOW
See Also:
Constant Field Values

BRCP_BOX_AROUND

protected static final byte BRCP_BOX_AROUND
See Also:
Constant Field Values

BRCP_BAR_TO_LEFT_OF_PARAGRAPH

protected static final byte BRCP_BAR_TO_LEFT_OF_PARAGRAPH
See Also:
Constant Field Values

field_8_ilvl

protected byte field_8_ilvl

field_9_ilfo

protected int field_9_ilfo

field_10_fNoLnn

protected boolean field_10_fNoLnn

field_11_lspd

protected LineSpacingDescriptor field_11_lspd

field_12_dyaBefore

protected int field_12_dyaBefore

field_13_dyaAfter

protected int field_13_dyaAfter

field_14_fInTable

protected boolean field_14_fInTable

field_15_finTableW97

protected boolean field_15_finTableW97

field_16_fTtp

protected boolean field_16_fTtp

field_17_dxaAbs

protected int field_17_dxaAbs

field_18_dyaAbs

protected int field_18_dyaAbs

field_19_dxaWidth

protected int field_19_dxaWidth

field_20_fBrLnAbove

protected boolean field_20_fBrLnAbove

field_21_fBrLnBelow

protected boolean field_21_fBrLnBelow

field_22_pcVert

protected byte field_22_pcVert

field_23_pcHorz

protected byte field_23_pcHorz

field_24_wr

protected byte field_24_wr

field_25_fNoAutoHyph

protected boolean field_25_fNoAutoHyph

field_26_dyaHeight

protected int field_26_dyaHeight

field_27_fMinHeight

protected boolean field_27_fMinHeight

FMINHEIGHT_EXACT

protected static final boolean FMINHEIGHT_EXACT
See Also:
Constant Field Values

FMINHEIGHT_AT_LEAST

protected static final boolean FMINHEIGHT_AT_LEAST
See Also:
Constant Field Values

field_28_dcs

protected DropCapSpecifier field_28_dcs

field_29_dyaFromText

protected int field_29_dyaFromText

field_30_dxaFromText

protected int field_30_dxaFromText

field_31_fLocked

protected boolean field_31_fLocked

field_32_fWidowControl

protected boolean field_32_fWidowControl

field_33_fKinsoku

protected boolean field_33_fKinsoku

field_34_fWordWrap

protected boolean field_34_fWordWrap

field_35_fOverflowPunct

protected boolean field_35_fOverflowPunct

field_36_fTopLinePunct

protected boolean field_36_fTopLinePunct

field_37_fAutoSpaceDE

protected boolean field_37_fAutoSpaceDE

field_38_fAutoSpaceDN

protected boolean field_38_fAutoSpaceDN

field_39_wAlignFont

protected int field_39_wAlignFont

WALIGNFONT_HANGING

protected static final byte WALIGNFONT_HANGING
See Also:
Constant Field Values

WALIGNFONT_CENTERED

protected static final byte WALIGNFONT_CENTERED
See Also:
Constant Field Values

WALIGNFONT_ROMAN

protected static final byte WALIGNFONT_ROMAN
See Also:
Constant Field Values

WALIGNFONT_VARIABLE

protected static final byte WALIGNFONT_VARIABLE
See Also:
Constant Field Values

WALIGNFONT_AUTO

protected static final byte WALIGNFONT_AUTO
See Also:
Constant Field Values

field_40_fontAlign

protected short field_40_fontAlign

field_41_lvl

protected byte field_41_lvl

field_42_fBiDi

protected boolean field_42_fBiDi

field_43_fNumRMIns

protected boolean field_43_fNumRMIns

field_44_fCrLf

protected boolean field_44_fCrLf

field_45_fUsePgsuSettings

protected boolean field_45_fUsePgsuSettings

field_46_fAdjustRight

protected boolean field_46_fAdjustRight

field_47_itap

protected int field_47_itap

field_48_fInnerTableCell

protected boolean field_48_fInnerTableCell

field_49_fOpenTch

protected boolean field_49_fOpenTch

field_50_fTtpEmbedded

protected boolean field_50_fTtpEmbedded

field_51_dxcRight

protected short field_51_dxcRight

field_52_dxcLeft

protected short field_52_dxcLeft

field_53_dxcLeft1

protected short field_53_dxcLeft1

field_54_fDyaBeforeAuto

protected boolean field_54_fDyaBeforeAuto

field_55_fDyaAfterAuto

protected boolean field_55_fDyaAfterAuto

field_56_dxaRight

protected int field_56_dxaRight

field_57_dxaLeft

protected int field_57_dxaLeft

field_58_dxaLeft1

protected int field_58_dxaLeft1

field_59_jc

protected byte field_59_jc

field_60_brcTop

protected BorderCode field_60_brcTop

field_61_brcLeft

protected BorderCode field_61_brcLeft

field_62_brcBottom

protected BorderCode field_62_brcBottom

field_63_brcRight

protected BorderCode field_63_brcRight

field_64_brcBetween

protected BorderCode field_64_brcBetween

field_65_brcBar

protected BorderCode field_65_brcBar

field_66_shd

protected ShadingDescriptor field_66_shd

field_67_anld

protected byte[] field_67_anld

field_68_phe

protected byte[] field_68_phe

field_69_fPropRMark

protected boolean field_69_fPropRMark

field_70_ibstPropRMark

protected int field_70_ibstPropRMark

field_71_dttmPropRMark

protected DateAndTime field_71_dttmPropRMark

field_72_itbdMac

protected int field_72_itbdMac

field_73_rgdxaTab

protected int[] field_73_rgdxaTab

field_74_rgtbd

protected TabDescriptor[] field_74_rgtbd

field_75_numrm

protected byte[] field_75_numrm

field_76_ptap

protected byte[] field_76_ptap

field_77_fNoAllowOverlap

protected boolean field_77_fNoAllowOverlap

field_78_ipgp

protected long field_78_ipgp

field_79_rsid

protected long field_79_rsid
Constructor Detail

PAPAbstractType

protected PAPAbstractType()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getIstd

@Internal
public int getIstd()
Index to style descriptor.

setIstd

@Internal
public void setIstd(int field_1_istd)
Index to style descriptor.

getFSideBySide

@Internal
public boolean getFSideBySide()
Get the fSideBySide field for the PAP record.

setFSideBySide

@Internal
public void setFSideBySide(boolean field_2_fSideBySide)
Set the fSideBySide field for the PAP record.

getFKeep

@Internal
public boolean getFKeep()
Get the fKeep field for the PAP record.

setFKeep

@Internal
public void setFKeep(boolean field_3_fKeep)
Set the fKeep field for the PAP record.

getFKeepFollow

@Internal
public boolean getFKeepFollow()
Get the fKeepFollow field for the PAP record.

setFKeepFollow

@Internal
public void setFKeepFollow(boolean field_4_fKeepFollow)
Set the fKeepFollow field for the PAP record.

getFPageBreakBefore

@Internal
public boolean getFPageBreakBefore()
Get the fPageBreakBefore field for the PAP record.

setFPageBreakBefore

@Internal
public void setFPageBreakBefore(boolean field_5_fPageBreakBefore)
Set the fPageBreakBefore field for the PAP record.

getBrcl

@Internal
public byte getBrcl()
Border line style.

Returns:
One of
  • BRCL_SINGLE
  • BRCL_THICK
  • BRCL_DOUBLE
  • BRCL_SHADOW

    • setBrcl

    @Internal
public void setBrcl(byte field_6_brcl)
    Border line style.

    Parameters:
    field_6_brcl - One of
  • BRCL_SINGLE
  • BRCL_THICK
  • BRCL_DOUBLE
  • BRCL_SHADOW

    • getBrcp

    @Internal
public byte getBrcp()
    Rectangle border codes.

    Returns:
    One of
  • BRCP_NONE
  • BRCP_BORDER_ABOVE
  • BRCP_BORDER_BELOW
  • BRCP_BOX_AROUND
  • BRCP_BAR_TO_LEFT_OF_PARAGRAPH

    • setBrcp

    @Internal
public void setBrcp(byte field_7_brcp)
    Rectangle border codes.

    Parameters:
    field_7_brcp - One of
  • BRCP_NONE
  • BRCP_BORDER_ABOVE
  • BRCP_BORDER_BELOW
  • BRCP_BOX_AROUND
  • BRCP_BAR_TO_LEFT_OF_PARAGRAPH

    • getIlvl

    @Internal
public byte getIlvl()
    List level if non-zero.

    setIlvl

    @Internal
public void setIlvl(byte field_8_ilvl)
    List level if non-zero.

    getIlfo

    @Internal
public int getIlfo()
    1-based index into the pllfo (lists structure), if non-zero.

    setIlfo

    @Internal
public void setIlfo(int field_9_ilfo)
    1-based index into the pllfo (lists structure), if non-zero.

    getFNoLnn

    @Internal
public boolean getFNoLnn()
    No line numbering.

    setFNoLnn

    @Internal
public void setFNoLnn(boolean field_10_fNoLnn)
    No line numbering.

    getLspd

    @Internal
public LineSpacingDescriptor getLspd()
    Line spacing descriptor.

    setLspd

    @Internal
public void setLspd(LineSpacingDescriptor field_11_lspd)
    Line spacing descriptor.

    getDyaBefore

    @Internal
public int getDyaBefore()
    Space before paragraph.

    setDyaBefore

    @Internal
public void setDyaBefore(int field_12_dyaBefore)
    Space before paragraph.

    getDyaAfter

    @Internal
public int getDyaAfter()
    Space after paragraph.

    setDyaAfter

    @Internal
public void setDyaAfter(int field_13_dyaAfter)
    Space after paragraph.

    getFInTable

    @Internal
public boolean getFInTable()
    Paragraph is in table flag.

    setFInTable

    @Internal
public void setFInTable(boolean field_14_fInTable)
    Paragraph is in table flag.

    getFinTableW97

    @Internal
public boolean getFinTableW97()
    Archaic paragraph is in table flag.

    setFinTableW97

    @Internal
public void setFinTableW97(boolean field_15_finTableW97)
    Archaic paragraph is in table flag.

    getFTtp

    @Internal
public boolean getFTtp()
    Table trailer paragraph (last in table row).

    setFTtp

    @Internal
public void setFTtp(boolean field_16_fTtp)
    Table trailer paragraph (last in table row).

    getDxaAbs

    @Internal
public int getDxaAbs()
    Get the dxaAbs field for the PAP record.

    setDxaAbs

    @Internal
public void setDxaAbs(int field_17_dxaAbs)
    Set the dxaAbs field for the PAP record.

    getDyaAbs

    @Internal
public int getDyaAbs()
    Get the dyaAbs field for the PAP record.

    setDyaAbs

    @Internal
public void setDyaAbs(int field_18_dyaAbs)
    Set the dyaAbs field for the PAP record.

    getDxaWidth

    @Internal
public int getDxaWidth()
    Get the dxaWidth field for the PAP record.

    setDxaWidth

    @Internal
public void setDxaWidth(int field_19_dxaWidth)
    Set the dxaWidth field for the PAP record.

    getFBrLnAbove

    @Internal
public boolean getFBrLnAbove()
    Get the fBrLnAbove field for the PAP record.

    setFBrLnAbove

    @Internal
public void setFBrLnAbove(boolean field_20_fBrLnAbove)
    Set the fBrLnAbove field for the PAP record.

    getFBrLnBelow

    @Internal
public boolean getFBrLnBelow()
    Get the fBrLnBelow field for the PAP record.

    setFBrLnBelow

    @Internal
public void setFBrLnBelow(boolean field_21_fBrLnBelow)
    Set the fBrLnBelow field for the PAP record.

    getPcVert

    @Internal
public byte getPcVert()
    Get the pcVert field for the PAP record.

    setPcVert

    @Internal
public void setPcVert(byte field_22_pcVert)
    Set the pcVert field for the PAP record.

    getPcHorz

    @Internal
public byte getPcHorz()
    Get the pcHorz field for the PAP record.

    setPcHorz

    @Internal
public void setPcHorz(byte field_23_pcHorz)
    Set the pcHorz field for the PAP record.

    getWr

    @Internal
public byte getWr()
    Get the wr field for the PAP record.

    setWr

    @Internal
public void setWr(byte field_24_wr)
    Set the wr field for the PAP record.

    getFNoAutoHyph

    @Internal
public boolean getFNoAutoHyph()
    Get the fNoAutoHyph field for the PAP record.

    setFNoAutoHyph

    @Internal
public void setFNoAutoHyph(boolean field_25_fNoAutoHyph)
    Set the fNoAutoHyph field for the PAP record.

    getDyaHeight

    @Internal
public int getDyaHeight()
    Get the dyaHeight field for the PAP record.

    setDyaHeight

    @Internal
public void setDyaHeight(int field_26_dyaHeight)
    Set the dyaHeight field for the PAP record.

    getFMinHeight

    @Internal
public boolean getFMinHeight()
    Minimum height is exact or auto.

    Returns:
    One of
  • FMINHEIGHT_EXACT
  • FMINHEIGHT_AT_LEAST

    • setFMinHeight

    @Internal
public void setFMinHeight(boolean field_27_fMinHeight)
    Minimum height is exact or auto.

    Parameters:
    field_27_fMinHeight - One of
  • FMINHEIGHT_EXACT
  • FMINHEIGHT_AT_LEAST

    • getDcs

    @Internal
public DropCapSpecifier getDcs()
    Get the dcs field for the PAP record.

    setDcs

    @Internal
public void setDcs(DropCapSpecifier field_28_dcs)
    Set the dcs field for the PAP record.

    getDyaFromText

    @Internal
public int getDyaFromText()
    Vertical distance between text and absolutely positioned object.

    setDyaFromText

    @Internal
public void setDyaFromText(int field_29_dyaFromText)
    Vertical distance between text and absolutely positioned object.

    getDxaFromText

    @Internal
public int getDxaFromText()
    Horizontal distance between text and absolutely positioned object.

    setDxaFromText

    @Internal
public void setDxaFromText(int field_30_dxaFromText)
    Horizontal distance between text and absolutely positioned object.

    getFLocked

    @Internal
public boolean getFLocked()
    Anchor of an absolutely positioned frame is locked.

    setFLocked

    @Internal
public void setFLocked(boolean field_31_fLocked)
    Anchor of an absolutely positioned frame is locked.

    getFWidowControl

    @Internal
public boolean getFWidowControl()
    1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.

    setFWidowControl

    @Internal
public void setFWidowControl(boolean field_32_fWidowControl)
    1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.

    getFKinsoku

    @Internal
public boolean getFKinsoku()
    apply Kinsoku rules when performing line wrapping.

    setFKinsoku

    @Internal
public void setFKinsoku(boolean field_33_fKinsoku)
    apply Kinsoku rules when performing line wrapping.

    getFWordWrap

    @Internal
public boolean getFWordWrap()
    perform word wrap.

    setFWordWrap

    @Internal
public void setFWordWrap(boolean field_34_fWordWrap)
    perform word wrap.

    getFOverflowPunct

    @Internal
public boolean getFOverflowPunct()
    apply overflow punctuation rules when performing line wrapping.

    setFOverflowPunct

    @Internal
public void setFOverflowPunct(boolean field_35_fOverflowPunct)
    apply overflow punctuation rules when performing line wrapping.

    getFTopLinePunct

    @Internal
public boolean getFTopLinePunct()
    perform top line punctuation processing.

    setFTopLinePunct

    @Internal
public void setFTopLinePunct(boolean field_36_fTopLinePunct)
    perform top line punctuation processing.

    getFAutoSpaceDE

    @Internal
public boolean getFAutoSpaceDE()
    auto space East Asian and alphabetic characters.

    setFAutoSpaceDE

    @Internal
public void setFAutoSpaceDE(boolean field_37_fAutoSpaceDE)
    auto space East Asian and alphabetic characters.

    getFAutoSpaceDN

    @Internal
public boolean getFAutoSpaceDN()
    auto space East Asian and numeric characters.

    setFAutoSpaceDN

    @Internal
public void setFAutoSpaceDN(boolean field_38_fAutoSpaceDN)
    auto space East Asian and numeric characters.

    getWAlignFont

    @Internal
public int getWAlignFont()
    Get the wAlignFont field for the PAP record.

    Returns:
    One of
  • WALIGNFONT_HANGING
  • WALIGNFONT_CENTERED
  • WALIGNFONT_ROMAN
  • WALIGNFONT_VARIABLE
  • WALIGNFONT_AUTO

    • setWAlignFont

    @Internal
public void setWAlignFont(int field_39_wAlignFont)
    Set the wAlignFont field for the PAP record.

    Parameters:
    field_39_wAlignFont - One of
  • WALIGNFONT_HANGING
  • WALIGNFONT_CENTERED
  • WALIGNFONT_ROMAN
  • WALIGNFONT_VARIABLE
  • WALIGNFONT_AUTO

    • getFontAlign

    @Internal
public short getFontAlign()
    Used internally by Word.

    setFontAlign

    @Internal
public void setFontAlign(short field_40_fontAlign)
    Used internally by Word.

    getLvl

    @Internal
public byte getLvl()
    Outline level.

    setLvl

    @Internal
public void setLvl(byte field_41_lvl)
    Outline level.

    getFBiDi

    @Internal
public boolean getFBiDi()
    Get the fBiDi field for the PAP record.

    setFBiDi

    @Internal
public void setFBiDi(boolean field_42_fBiDi)
    Set the fBiDi field for the PAP record.

    getFNumRMIns

    @Internal
public boolean getFNumRMIns()
    Get the fNumRMIns field for the PAP record.

    setFNumRMIns

    @Internal
public void setFNumRMIns(boolean field_43_fNumRMIns)
    Set the fNumRMIns field for the PAP record.

    getFCrLf

    @Internal
public boolean getFCrLf()
    Get the fCrLf field for the PAP record.

    setFCrLf

    @Internal
public void setFCrLf(boolean field_44_fCrLf)
    Set the fCrLf field for the PAP record.

    getFUsePgsuSettings

    @Internal
public boolean getFUsePgsuSettings()
    Get the fUsePgsuSettings field for the PAP record.

    setFUsePgsuSettings

    @Internal
public void setFUsePgsuSettings(boolean field_45_fUsePgsuSettings)
    Set the fUsePgsuSettings field for the PAP record.

    getFAdjustRight

    @Internal
public boolean getFAdjustRight()
    Get the fAdjustRight field for the PAP record.

    setFAdjustRight

    @Internal
public void setFAdjustRight(boolean field_46_fAdjustRight)
    Set the fAdjustRight field for the PAP record.

    getItap

    @Internal
public int getItap()
    Table nesting level.

    setItap

    @Internal
public void setItap(int field_47_itap)
    Table nesting level.

    getFInnerTableCell

    @Internal
public boolean getFInnerTableCell()
    When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.

    setFInnerTableCell

    @Internal
public void setFInnerTableCell(boolean field_48_fInnerTableCell)
    When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.

    getFOpenTch

    @Internal
public boolean getFOpenTch()
    Ensure the Table Cell char doesn't show up as zero height.

    setFOpenTch

    @Internal
public void setFOpenTch(boolean field_49_fOpenTch)
    Ensure the Table Cell char doesn't show up as zero height.

    getFTtpEmbedded

    @Internal
public boolean getFTtpEmbedded()
    Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.

    setFTtpEmbedded

    @Internal
public void setFTtpEmbedded(boolean field_50_fTtpEmbedded)
    Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.

    getDxcRight

    @Internal
public short getDxcRight()
    Right indent in character units.

    setDxcRight

    @Internal
public void setDxcRight(short field_51_dxcRight)
    Right indent in character units.

    getDxcLeft

    @Internal
public short getDxcLeft()
    Left indent in character units.

    setDxcLeft

    @Internal
public void setDxcLeft(short field_52_dxcLeft)
    Left indent in character units.

    getDxcLeft1

    @Internal
public short getDxcLeft1()
    First line indent in character units.

    setDxcLeft1

    @Internal
public void setDxcLeft1(short field_53_dxcLeft1)
    First line indent in character units.

    getFDyaBeforeAuto

    @Internal
public boolean getFDyaBeforeAuto()
    Vertical spacing before is automatic.

    setFDyaBeforeAuto

    @Internal
public void setFDyaBeforeAuto(boolean field_54_fDyaBeforeAuto)
    Vertical spacing before is automatic.

    getFDyaAfterAuto

    @Internal
public boolean getFDyaAfterAuto()
    Vertical spacing after is automatic.

    setFDyaAfterAuto

    @Internal
public void setFDyaAfterAuto(boolean field_55_fDyaAfterAuto)
    Vertical spacing after is automatic.

    getDxaRight

    @Internal
public int getDxaRight()
    Get the dxaRight field for the PAP record.

    setDxaRight

    @Internal
public void setDxaRight(int field_56_dxaRight)
    Set the dxaRight field for the PAP record.

    getDxaLeft

    @Internal
public int getDxaLeft()
    Get the dxaLeft field for the PAP record.

    setDxaLeft

    @Internal
public void setDxaLeft(int field_57_dxaLeft)
    Set the dxaLeft field for the PAP record.

    getDxaLeft1

    @Internal
public int getDxaLeft1()
    Get the dxaLeft1 field for the PAP record.

    setDxaLeft1

    @Internal
public void setDxaLeft1(int field_58_dxaLeft1)
    Set the dxaLeft1 field for the PAP record.

    getJc

    @Internal
public byte getJc()
    Get the jc field for the PAP record.

    setJc

    @Internal
public void setJc(byte field_59_jc)
    Set the jc field for the PAP record.

    getBrcTop

    @Internal
public BorderCode getBrcTop()
    Get the brcTop field for the PAP record.

    setBrcTop

    @Internal
public void setBrcTop(BorderCode field_60_brcTop)
    Set the brcTop field for the PAP record.

    getBrcLeft

    @Internal
public BorderCode getBrcLeft()
    Get the brcLeft field for the PAP record.

    setBrcLeft

    @Internal
public void setBrcLeft(BorderCode field_61_brcLeft)
    Set the brcLeft field for the PAP record.

    getBrcBottom

    @Internal
public BorderCode getBrcBottom()
    Get the brcBottom field for the PAP record.

    setBrcBottom

    @Internal
public void setBrcBottom(BorderCode field_62_brcBottom)
    Set the brcBottom field for the PAP record.

    getBrcRight

    @Internal
public BorderCode getBrcRight()
    Get the brcRight field for the PAP record.

    setBrcRight

    @Internal
public void setBrcRight(BorderCode field_63_brcRight)
    Set the brcRight field for the PAP record.

    getBrcBetween

    @Internal
public BorderCode getBrcBetween()
    Get the brcBetween field for the PAP record.

    setBrcBetween

    @Internal
public void setBrcBetween(BorderCode field_64_brcBetween)
    Set the brcBetween field for the PAP record.

    getBrcBar

    @Internal
public BorderCode getBrcBar()
    Get the brcBar field for the PAP record.

    setBrcBar

    @Internal
public void setBrcBar(BorderCode field_65_brcBar)
    Set the brcBar field for the PAP record.

    getShd

    @Internal
public ShadingDescriptor getShd()
    Get the shd field for the PAP record.

    setShd

    @Internal
public void setShd(ShadingDescriptor field_66_shd)
    Set the shd field for the PAP record.

    getAnld

    @Internal
public byte[] getAnld()
    Get the anld field for the PAP record.

    setAnld

    @Internal
public void setAnld(byte[] field_67_anld)
    Set the anld field for the PAP record.

    getPhe

    @Internal
public byte[] getPhe()
    Get the phe field for the PAP record.

    setPhe

    @Internal
public void setPhe(byte[] field_68_phe)
    Set the phe field for the PAP record.

    getFPropRMark

    @Internal
public boolean getFPropRMark()
    Get the fPropRMark field for the PAP record.

    setFPropRMark

    @Internal
public void setFPropRMark(boolean field_69_fPropRMark)
    Set the fPropRMark field for the PAP record.

    getIbstPropRMark

    @Internal
public int getIbstPropRMark()
    Get the ibstPropRMark field for the PAP record.

    setIbstPropRMark

    @Internal
public void setIbstPropRMark(int field_70_ibstPropRMark)
    Set the ibstPropRMark field for the PAP record.

    getDttmPropRMark

    @Internal
public DateAndTime getDttmPropRMark()
    Get the dttmPropRMark field for the PAP record.

    setDttmPropRMark

    @Internal
public void setDttmPropRMark(DateAndTime field_71_dttmPropRMark)
    Set the dttmPropRMark field for the PAP record.

    getItbdMac

    @Internal
public int getItbdMac()
    Number of tabs stops defined for paragraph. Must be >= 0 and <= 64..

    setItbdMac

    @Internal
public void setItbdMac(int field_72_itbdMac)
    Number of tabs stops defined for paragraph. Must be >= 0 and <= 64..

    getRgdxaTab

    @Internal
public int[] getRgdxaTab()
    Array of positions of itbdMac tab stops. itbdMax==64.

    setRgdxaTab

    @Internal
public void setRgdxaTab(int[] field_73_rgdxaTab)
    Array of positions of itbdMac tab stops. itbdMax==64.

    getRgtbd

    @Internal
public TabDescriptor[] getRgtbd()
    Array of itbdMac tab descriptors.

    setRgtbd

    @Internal
public void setRgtbd(TabDescriptor[] field_74_rgtbd)
    Array of itbdMac tab descriptors.

    getNumrm

    @Internal
public byte[] getNumrm()
    Get the numrm field for the PAP record.

    setNumrm

    @Internal
public void setNumrm(byte[] field_75_numrm)
    Set the numrm field for the PAP record.

    getPtap

    @Internal
public byte[] getPtap()
    Get the ptap field for the PAP record.

    setPtap

    @Internal
public void setPtap(byte[] field_76_ptap)
    Set the ptap field for the PAP record.

    getFNoAllowOverlap

    @Internal
public boolean getFNoAllowOverlap()
    When 1, absolutely positioned paragraph cannot overlap with another paragraph.

    setFNoAllowOverlap

    @Internal
public void setFNoAllowOverlap(boolean field_77_fNoAllowOverlap)
    When 1, absolutely positioned paragraph cannot overlap with another paragraph.

    getIpgp

    @Internal
public long getIpgp()
    HTML DIV ID for this paragraph.

    setIpgp

    @Internal
public void setIpgp(long field_78_ipgp)
    HTML DIV ID for this paragraph.

    getRsid

    @Internal
public long getRsid()
    Save ID for last time this PAP was revised.

    setRsid

    @Internal
public void setRsid(long field_79_rsid)
    Save ID for last time this PAP was revised.

    setFVertical

    @Internal
public void setFVertical(boolean value)
    Sets the fVertical field value.

    isFVertical

    @Internal
public boolean isFVertical()
    Returns:
    the fVertical field value.

    setFBackward

    @Internal
public void setFBackward(boolean value)
    Sets the fBackward field value.

    isFBackward

    @Internal
public boolean isFBackward()
    Returns:
    the fBackward field value.

    setFRotateFont

    @Internal
public void setFRotateFont(boolean value)
    Sets the fRotateFont field value.

    isFRotateFont

    @Internal
public boolean isFRotateFont()
    Returns:
    the fRotateFont field value.
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PICFAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class PICFAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.PICFAbstractType
Direct Known Subclasses:
PICF
@Internal
public abstract class PICFAbstractType
extends java.lang.Object

The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected int | field_1_lcb
protected int | field_10_padding2
protected short | field_11_dxaGoal
protected short | field_12_dyaGoal
protected int | field_13_mx
protected int | field_14_my
protected short | field_15_dxaReserved1
protected short | field_16_dyaReserved1
protected short | field_17_dxaReserved2
protected short | field_18_dyaReserved2
protected byte | field_19_fReserved
protected int | field_2_cbHeader
protected byte | field_20_bpp
protected byte[] | field_21_brcTop80
protected byte[] | field_22_brcLeft80
protected byte[] | field_23_brcBottom80
protected byte[] | field_24_brcRight80
protected short | field_25_dxaReserved3
protected short | field_26_dyaReserved3
protected short | field_27_cProps
protected short | field_3_mm
protected short | field_4_xExt
protected short | field_5_yExt
protected short | field_6_swHMF
protected int | field_7_grf
protected int | field_8_padding
protected int | field_9_mmPM
Constructor Summary
protected PICFAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
byte | getBpp() Get the bpp field for the PICF record.
byte[] | getBrcBottom80() Get the brcBottom80 field for the PICF record.
byte[] | getBrcLeft80() Get the brcLeft80 field for the PICF record.
byte[] | getBrcRight80() Get the brcRight80 field for the PICF record.
byte[] | getBrcTop80() Get the brcTop80 field for the PICF record.
int | getCbHeader() An unsigned integer that specifies the size, in bytes, of this PICF structure.
short | getCProps() This value MUST be 0 and MUST be ignored.
short | getDxaGoal() Get the dxaGoal field for the PICF record.
short | getDxaReserved1() Get the dxaReserved1 field for the PICF record.
short | getDxaReserved2() Get the dxaReserved2 field for the PICF record.
short | getDxaReserved3() Get the dxaReserved3 field for the PICF record.
short | getDyaGoal() Get the dyaGoal field for the PICF record.
short | getDyaReserved1() Get the dyaReserved1 field for the PICF record.
short | getDyaReserved2() Get the dyaReserved2 field for the PICF record.
short | getDyaReserved3() Get the dyaReserved3 field for the PICF record.
byte | getFReserved() Get the fReserved field for the PICF record.
int | getGrf() This field MUST be ignored.
int | getLcb() A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.
short | getMm() A signed integer that specifies the format of the picture data.
int | getMmPM() This field MUST be ignored.
int | getMx() Get the mx field for the PICF record.
int | getMy() Get the my field for the PICF record.
int | getPadding() This value MUST be zero and MUST be ignored.
int | getPadding2() This value MUST be zero and MUST be ignored.
static int | getSize() Size of record
short | getSwHMF() This field is unused and MUST be ignored.
short | getXExt() This field is unused and MUST be ignored.
short | getYExt() This field is unused and MUST be ignored.
byte[] | serialize()
void | serialize(byte[] data, int offset)
void | setBpp(byte field_20_bpp) Set the bpp field for the PICF record.
void | setBrcBottom80(byte[] field_23_brcBottom80) Set the brcBottom80 field for the PICF record.
void | setBrcLeft80(byte[] field_22_brcLeft80) Set the brcLeft80 field for the PICF record.
void | setBrcRight80(byte[] field_24_brcRight80) Set the brcRight80 field for the PICF record.
void | setBrcTop80(byte[] field_21_brcTop80) Set the brcTop80 field for the PICF record.
void | setCbHeader(int field_2_cbHeader) An unsigned integer that specifies the size, in bytes, of this PICF structure.
void | setCProps(short field_27_cProps) This value MUST be 0 and MUST be ignored.
void | setDxaGoal(short field_11_dxaGoal) Set the dxaGoal field for the PICF record.
void | setDxaReserved1(short field_15_dxaReserved1) Set the dxaReserved1 field for the PICF record.
void | setDxaReserved2(short field_17_dxaReserved2) Set the dxaReserved2 field for the PICF record.
void | setDxaReserved3(short field_25_dxaReserved3) Set the dxaReserved3 field for the PICF record.
void | setDyaGoal(short field_12_dyaGoal) Set the dyaGoal field for the PICF record.
void | setDyaReserved1(short field_16_dyaReserved1) Set the dyaReserved1 field for the PICF record.
void | setDyaReserved2(short field_18_dyaReserved2) Set the dyaReserved2 field for the PICF record.
void | setDyaReserved3(short field_26_dyaReserved3) Set the dyaReserved3 field for the PICF record.
void | setFReserved(byte field_19_fReserved) Set the fReserved field for the PICF record.
void | setGrf(int field_7_grf) This field MUST be ignored.
void | setLcb(int field_1_lcb) A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.
void | setMm(short field_3_mm) A signed integer that specifies the format of the picture data.
void | setMmPM(int field_9_mmPM) This field MUST be ignored.
void | setMx(int field_13_mx) Set the mx field for the PICF record.
void | setMy(int field_14_my) Set the my field for the PICF record.
void | setPadding(int field_8_padding) This value MUST be zero and MUST be ignored.
void | setPadding2(int field_10_padding2) This value MUST be zero and MUST be ignored.
void | setSwHMF(short field_6_swHMF) This field is unused and MUST be ignored.
void | setXExt(short field_4_xExt) This field is unused and MUST be ignored.
void | setYExt(short field_5_yExt) This field is unused and MUST be ignored.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_lcb

protected int field_1_lcb

field_2_cbHeader

protected int field_2_cbHeader

field_3_mm

protected short field_3_mm

field_4_xExt

protected short field_4_xExt

field_5_yExt

protected short field_5_yExt

field_6_swHMF

protected short field_6_swHMF

field_7_grf

protected int field_7_grf

field_8_padding

protected int field_8_padding

field_9_mmPM

protected int field_9_mmPM

field_10_padding2

protected int field_10_padding2

field_11_dxaGoal

protected short field_11_dxaGoal

field_12_dyaGoal

protected short field_12_dyaGoal

field_13_mx

protected int field_13_mx

field_14_my

protected int field_14_my

field_15_dxaReserved1

protected short field_15_dxaReserved1

field_16_dyaReserved1

protected short field_16_dyaReserved1

field_17_dxaReserved2

protected short field_17_dxaReserved2

field_18_dyaReserved2

protected short field_18_dyaReserved2

field_19_fReserved

protected byte field_19_fReserved

field_20_bpp

protected byte field_20_bpp

field_21_brcTop80

protected byte[] field_21_brcTop80

field_22_brcLeft80

protected byte[] field_22_brcLeft80

field_23_brcBottom80

protected byte[] field_23_brcBottom80

field_24_brcRight80

protected byte[] field_24_brcRight80

field_25_dxaReserved3

protected short field_25_dxaReserved3

field_26_dyaReserved3

protected short field_26_dyaReserved3

field_27_cProps

protected short field_27_cProps
Constructor Detail

PICFAbstractType

protected PICFAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

serialize

public byte[] serialize()

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getLcb

@Internal
public int getLcb()
A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.

setLcb

@Internal
public void setLcb(int field_1_lcb)
A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.

getCbHeader

@Internal
public int getCbHeader()
An unsigned integer that specifies the size, in bytes, of this PICF structure. This value MUST be 0x44.

setCbHeader

@Internal
public void setCbHeader(int field_2_cbHeader)
An unsigned integer that specifies the size, in bytes, of this PICF structure. This value MUST be 0x44.

getMm

@Internal
public short getMm()
A signed integer that specifies the format of the picture data.

setMm

@Internal
public void setMm(short field_3_mm)
A signed integer that specifies the format of the picture data.

getXExt

@Internal
public short getXExt()
This field is unused and MUST be ignored.

setXExt

@Internal
public void setXExt(short field_4_xExt)
This field is unused and MUST be ignored.

getYExt

@Internal
public short getYExt()
This field is unused and MUST be ignored.

setYExt

@Internal
public void setYExt(short field_5_yExt)
This field is unused and MUST be ignored.

getSwHMF

@Internal
public short getSwHMF()
This field is unused and MUST be ignored.

setSwHMF

@Internal
public void setSwHMF(short field_6_swHMF)
This field is unused and MUST be ignored.

getGrf

@Internal
public int getGrf()
This field MUST be ignored.

setGrf

@Internal
public void setGrf(int field_7_grf)
This field MUST be ignored.

getPadding

@Internal
public int getPadding()
This value MUST be zero and MUST be ignored.

setPadding

@Internal
public void setPadding(int field_8_padding)
This value MUST be zero and MUST be ignored.

getMmPM

@Internal
public int getMmPM()
This field MUST be ignored.

setMmPM

@Internal
public void setMmPM(int field_9_mmPM)
This field MUST be ignored.

getPadding2

@Internal
public int getPadding2()
This value MUST be zero and MUST be ignored.

setPadding2

@Internal
public void setPadding2(int field_10_padding2)
This value MUST be zero and MUST be ignored.

getDxaGoal

@Internal
public short getDxaGoal()
Get the dxaGoal field for the PICF record.

setDxaGoal

@Internal
public void setDxaGoal(short field_11_dxaGoal)
Set the dxaGoal field for the PICF record.

getDyaGoal

@Internal
public short getDyaGoal()
Get the dyaGoal field for the PICF record.

setDyaGoal

@Internal
public void setDyaGoal(short field_12_dyaGoal)
Set the dyaGoal field for the PICF record.

getMx

@Internal
public int getMx()
Get the mx field for the PICF record.

setMx

@Internal
public void setMx(int field_13_mx)
Set the mx field for the PICF record.

getMy

@Internal
public int getMy()
Get the my field for the PICF record.

setMy

@Internal
public void setMy(int field_14_my)
Set the my field for the PICF record.

getDxaReserved1

@Internal
public short getDxaReserved1()
Get the dxaReserved1 field for the PICF record.

setDxaReserved1

@Internal
public void setDxaReserved1(short field_15_dxaReserved1)
Set the dxaReserved1 field for the PICF record.

getDyaReserved1

@Internal
public short getDyaReserved1()
Get the dyaReserved1 field for the PICF record.

setDyaReserved1

@Internal
public void setDyaReserved1(short field_16_dyaReserved1)
Set the dyaReserved1 field for the PICF record.

getDxaReserved2

@Internal
public short getDxaReserved2()
Get the dxaReserved2 field for the PICF record.

setDxaReserved2

@Internal
public void setDxaReserved2(short field_17_dxaReserved2)
Set the dxaReserved2 field for the PICF record.

getDyaReserved2

@Internal
public short getDyaReserved2()
Get the dyaReserved2 field for the PICF record.

setDyaReserved2

@Internal
public void setDyaReserved2(short field_18_dyaReserved2)
Set the dyaReserved2 field for the PICF record.

getFReserved

@Internal
public byte getFReserved()
Get the fReserved field for the PICF record.

setFReserved

@Internal
public void setFReserved(byte field_19_fReserved)
Set the fReserved field for the PICF record.

getBpp

@Internal
public byte getBpp()
Get the bpp field for the PICF record.

setBpp

@Internal
public void setBpp(byte field_20_bpp)
Set the bpp field for the PICF record.

getBrcTop80

@Internal
public byte[] getBrcTop80()
Get the brcTop80 field for the PICF record.

setBrcTop80

@Internal
public void setBrcTop80(byte[] field_21_brcTop80)
Set the brcTop80 field for the PICF record.

getBrcLeft80

@Internal
public byte[] getBrcLeft80()
Get the brcLeft80 field for the PICF record.

setBrcLeft80

@Internal
public void setBrcLeft80(byte[] field_22_brcLeft80)
Set the brcLeft80 field for the PICF record.

getBrcBottom80

@Internal
public byte[] getBrcBottom80()
Get the brcBottom80 field for the PICF record.

setBrcBottom80

@Internal
public void setBrcBottom80(byte[] field_23_brcBottom80)
Set the brcBottom80 field for the PICF record.

getBrcRight80

@Internal
public byte[] getBrcRight80()
Get the brcRight80 field for the PICF record.

setBrcRight80

@Internal
public void setBrcRight80(byte[] field_24_brcRight80)
Set the brcRight80 field for the PICF record.

getDxaReserved3

@Internal
public short getDxaReserved3()
Get the dxaReserved3 field for the PICF record.

setDxaReserved3

@Internal
public void setDxaReserved3(short field_25_dxaReserved3)
Set the dxaReserved3 field for the PICF record.

getDyaReserved3

@Internal
public short getDyaReserved3()
Get the dyaReserved3 field for the PICF record.

setDyaReserved3

@Internal
public void setDyaReserved3(short field_26_dyaReserved3)
Set the dyaReserved3 field for the PICF record.

getCProps

@Internal
public short getCProps()
This value MUST be 0 and MUST be ignored.

setCProps

@Internal
public void setCProps(short field_27_cProps)
This value MUST be 0 and MUST be ignored.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SEPAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class SEPAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.SEPAbstractType
Direct Known Subclasses:
SectionProperties
@Internal
public abstract class SEPAbstractType
extends java.lang.Object

Section Properties. NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/records/definitions.

Author:
S. Ryan Ackley

Field Summary
static byte | BKC_EVEN_PAGE
static byte | BKC_NEW_COLUMN
static byte | BKC_NEW_PAGE
static byte | BKC_NO_BREAK
static byte | BKC_ODD_PAGE
static boolean | DMORIENTPAGE_LANDSCAPE
static boolean | DMORIENTPAGE_PORTRAIT
protected byte | field_1_bkc
protected byte | field_10_grpfIhdt
protected int | field_11_nLnnMod
protected int | field_12_dxaLnn
protected int | field_13_dxaPgn
protected int | field_14_dyaPgn
protected boolean | field_15_fLBetween
protected byte | field_16_vjc
protected int | field_17_dmBinFirst
protected int | field_18_dmBinOther
protected int | field_19_dmPaperReq
protected boolean | field_2_fTitlePage
protected BorderCode | field_20_brcTop
protected BorderCode | field_21_brcLeft
protected BorderCode | field_22_brcBottom
protected BorderCode | field_23_brcRight
protected boolean | field_24_fPropMark
protected int | field_25_ibstPropRMark
protected DateAndTime | field_26_dttmPropRMark
protected int | field_27_dxtCharSpace
protected int | field_28_dyaLinePitch
protected int | field_29_clm
protected boolean | field_3_fAutoPgn
protected int | field_30_unused2
protected boolean | field_31_dmOrientPage
protected byte | field_32_iHeadingPgn
protected int | field_33_pgnStart
protected int | field_34_lnnMin
protected int | field_35_wTextFlow
protected short | field_36_unused3
protected int | field_37_pgbProp
protected short | field_38_unused4
protected int | field_39_xaPage
protected byte | field_4_nfcPgn
protected int | field_40_yaPage
protected int | field_41_xaPageNUp
protected int | field_42_yaPageNUp
protected int | field_43_dxaLeft
protected int | field_44_dxaRight
protected int | field_45_dyaTop
protected int | field_46_dyaBottom
protected int | field_47_dzaGutter
protected int | field_48_dyaHdrTop
protected int | field_49_dyaHdrBottom
protected boolean | field_5_fUnlocked
protected int | field_50_ccolM1
protected boolean | field_51_fEvenlySpaced
protected byte | field_52_unused5
protected int | field_53_dxaColumns
protected int[] | field_54_rgdxaColumn
protected int | field_55_dxaColumnWidth
protected byte | field_56_dmOrientFirst
protected byte | field_57_fLayout
protected short | field_58_unused6
protected byte[] | field_59_olstAnm
protected byte | field_6_cnsPgn
protected boolean | field_7_fPgnRestart
protected boolean | field_8_fEndNote
protected byte | field_9_lnc
static byte | NFCPGN_ARABIC
static byte | NFCPGN_LETTER_LOWER_CASE
static byte | NFCPGN_LETTER_UPPER_CASE
static byte | NFCPGN_ROMAN_LOWER_CASE
static byte | NFCPGN_ROMAN_UPPER_CASE
Constructor Summary
protected SEPAbstractType()
Method Summary
byte | getBkc() Break code.
BorderCode | getBrcBottom() Get the brcBottom field for the SEP record.
BorderCode | getBrcLeft() Get the brcLeft field for the SEP record.
BorderCode | getBrcRight() Get the brcRight field for the SEP record.
BorderCode | getBrcTop() Get the brcTop field for the SEP record.
int | getCcolM1() Get the ccolM1 field for the SEP record.
int | getClm() Get the clm field for the SEP record.
byte | getCnsPgn() Get the cnsPgn field for the SEP record.
int | getDmBinFirst() Get the dmBinFirst field for the SEP record.
int | getDmBinOther() Get the dmBinOther field for the SEP record.
byte | getDmOrientFirst() Get the dmOrientFirst field for the SEP record.
boolean | getDmOrientPage() Get the dmOrientPage field for the SEP record.
int | getDmPaperReq() Get the dmPaperReq field for the SEP record.
DateAndTime | getDttmPropRMark() Get the dttmPropRMark field for the SEP record.
int | getDxaColumns() Get the dxaColumns field for the SEP record.
int | getDxaColumnWidth() Get the dxaColumnWidth field for the SEP record.
int | getDxaLeft() Get the dxaLeft field for the SEP record.
int | getDxaLnn() Get the dxaLnn field for the SEP record.
int | getDxaPgn() Get the dxaPgn field for the SEP record.
int | getDxaRight() Get the dxaRight field for the SEP record.
int | getDxtCharSpace() Get the dxtCharSpace field for the SEP record.
int | getDyaBottom() Get the dyaBottom field for the SEP record.
int | getDyaHdrBottom() Get the dyaHdrBottom field for the SEP record.
int | getDyaHdrTop() Get the dyaHdrTop field for the SEP record.
int | getDyaLinePitch() Get the dyaLinePitch field for the SEP record.
int | getDyaPgn() Get the dyaPgn field for the SEP record.
int | getDyaTop() Get the dyaTop field for the SEP record.
int | getDzaGutter() Get the dzaGutter field for the SEP record.
boolean | getFAutoPgn() Only for Macintosh compatibility, used only during open, when 1, sep.dxaPgn and sep.dyaPgn are valid page number locations.
boolean | getFEndNote() Get the fEndNote field for the SEP record.
boolean | getFEvenlySpaced() Get the fEvenlySpaced field for the SEP record.
byte | getFLayout() Get the fLayout field for the SEP record.
boolean | getFLBetween() Get the fLBetween field for the SEP record.
boolean | getFPgnRestart() Get the fPgnRestart field for the SEP record.
boolean | getFPropMark() Get the fPropMark field for the SEP record.
boolean | getFTitlePage() Set to 1 when a title page is to be displayed.
boolean | getFUnlocked() Get the fUnlocked field for the SEP record.
byte | getGrpfIhdt() Get the grpfIhdt field for the SEP record.
int | getIbstPropRMark() Get the ibstPropRMark field for the SEP record.
byte | getIHeadingPgn() Get the iHeadingPgn field for the SEP record.
byte | getLnc() Get the lnc field for the SEP record.
int | getLnnMin() Get the lnnMin field for the SEP record.
byte | getNfcPgn() Page number format code.
int | getNLnnMod() Get the nLnnMod field for the SEP record.
byte[] | getOlstAnm() Get the olstAnm field for the SEP record.
int | getPgbProp() Get the pgbProp field for the SEP record.
int | getPgnStart() Get the pgnStart field for the SEP record.
int[] | getRgdxaColumn() Get the rgdxaColumn field for the SEP record.
int | getUnused2() Get the unused2 field for the SEP record.
short | getUnused3() Get the unused3 field for the SEP record.
short | getUnused4() Get the unused4 field for the SEP record.
byte | getUnused5() Get the unused5 field for the SEP record.
short | getUnused6() Get the unused6 field for the SEP record.
byte | getVjc() Get the vjc field for the SEP record.
int | getWTextFlow() Get the wTextFlow field for the SEP record.
int | getXaPage() Get the xaPage field for the SEP record.
int | getXaPageNUp() Get the xaPageNUp field for the SEP record.
int | getYaPage() Get the yaPage field for the SEP record.
int | getYaPageNUp() Get the yaPageNUp field for the SEP record.
void | setBkc(byte field_1_bkc) Break code.
void | setBrcBottom(BorderCode field_22_brcBottom) Set the brcBottom field for the SEP record.
void | setBrcLeft(BorderCode field_21_brcLeft) Set the brcLeft field for the SEP record.
void | setBrcRight(BorderCode field_23_brcRight) Set the brcRight field for the SEP record.
void | setBrcTop(BorderCode field_20_brcTop) Set the brcTop field for the SEP record.
void | setCcolM1(int field_50_ccolM1) Set the ccolM1 field for the SEP record.
void | setClm(int field_29_clm) Set the clm field for the SEP record.
void | setCnsPgn(byte field_6_cnsPgn) Set the cnsPgn field for the SEP record.
void | setDmBinFirst(int field_17_dmBinFirst) Set the dmBinFirst field for the SEP record.
void | setDmBinOther(int field_18_dmBinOther) Set the dmBinOther field for the SEP record.
void | setDmOrientFirst(byte field_56_dmOrientFirst) Set the dmOrientFirst field for the SEP record.
void | setDmOrientPage(boolean field_31_dmOrientPage) Set the dmOrientPage field for the SEP record.
void | setDmPaperReq(int field_19_dmPaperReq) Set the dmPaperReq field for the SEP record.
void | setDttmPropRMark(DateAndTime field_26_dttmPropRMark) Set the dttmPropRMark field for the SEP record.
void | setDxaColumns(int field_53_dxaColumns) Set the dxaColumns field for the SEP record.
void | setDxaColumnWidth(int field_55_dxaColumnWidth) Set the dxaColumnWidth field for the SEP record.
void | setDxaLeft(int field_43_dxaLeft) Set the dxaLeft field for the SEP record.
void | setDxaLnn(int field_12_dxaLnn) Set the dxaLnn field for the SEP record.
void | setDxaPgn(int field_13_dxaPgn) Set the dxaPgn field for the SEP record.
void | setDxaRight(int field_44_dxaRight) Set the dxaRight field for the SEP record.
void | setDxtCharSpace(int field_27_dxtCharSpace) Set the dxtCharSpace field for the SEP record.
void | setDyaBottom(int field_46_dyaBottom) Set the dyaBottom field for the SEP record.
void | setDyaHdrBottom(int field_49_dyaHdrBottom) Set the dyaHdrBottom field for the SEP record.
void | setDyaHdrTop(int field_48_dyaHdrTop) Set the dyaHdrTop field for the SEP record.
void | setDyaLinePitch(int field_28_dyaLinePitch) Set the dyaLinePitch field for the SEP record.
void | setDyaPgn(int field_14_dyaPgn) Set the dyaPgn field for the SEP record.
void | setDyaTop(int field_45_dyaTop) Set the dyaTop field for the SEP record.
void | setDzaGutter(int field_47_dzaGutter) Set the dzaGutter field for the SEP record.
void | setFAutoPgn(boolean field_3_fAutoPgn) Only for Macintosh compatibility, used only during open, when 1, sep.dxaPgn and sep.dyaPgn are valid page number locations.
void | setFEndNote(boolean field_8_fEndNote) Set the fEndNote field for the SEP record.
void | setFEvenlySpaced(boolean field_51_fEvenlySpaced) Set the fEvenlySpaced field for the SEP record.
void | setFLayout(byte field_57_fLayout) Set the fLayout field for the SEP record.
void | setFLBetween(boolean field_15_fLBetween) Set the fLBetween field for the SEP record.
void | setFPgnRestart(boolean field_7_fPgnRestart) Set the fPgnRestart field for the SEP record.
void | setFPropMark(boolean field_24_fPropMark) Set the fPropMark field for the SEP record.
void | setFTitlePage(boolean field_2_fTitlePage) Set to 1 when a title page is to be displayed.
void | setFUnlocked(boolean field_5_fUnlocked) Set the fUnlocked field for the SEP record.
void | setGrpfIhdt(byte field_10_grpfIhdt) Set the grpfIhdt field for the SEP record.
void | setIbstPropRMark(int field_25_ibstPropRMark) Set the ibstPropRMark field for the SEP record.
void | setIHeadingPgn(byte field_32_iHeadingPgn) Set the iHeadingPgn field for the SEP record.
void | setLnc(byte field_9_lnc) Set the lnc field for the SEP record.
void | setLnnMin(int field_34_lnnMin) Set the lnnMin field for the SEP record.
void | setNfcPgn(byte field_4_nfcPgn) Page number format code.
void | setNLnnMod(int field_11_nLnnMod) Set the nLnnMod field for the SEP record.
void | setOlstAnm(byte[] field_59_olstAnm) Set the olstAnm field for the SEP record.
void | setPgbProp(int field_37_pgbProp) Set the pgbProp field for the SEP record.
void | setPgnStart(int field_33_pgnStart) Set the pgnStart field for the SEP record.
void | setRgdxaColumn(int[] field_54_rgdxaColumn) Set the rgdxaColumn field for the SEP record.
void | setUnused2(int field_30_unused2) Set the unused2 field for the SEP record.
void | setUnused3(short field_36_unused3) Set the unused3 field for the SEP record.
void | setUnused4(short field_38_unused4) Set the unused4 field for the SEP record.
void | setUnused5(byte field_52_unused5) Set the unused5 field for the SEP record.
void | setUnused6(short field_58_unused6) Set the unused6 field for the SEP record.
void | setVjc(byte field_16_vjc) Set the vjc field for the SEP record.
void | setWTextFlow(int field_35_wTextFlow) Set the wTextFlow field for the SEP record.
void | setXaPage(int field_39_xaPage) Set the xaPage field for the SEP record.
void | setXaPageNUp(int field_41_xaPageNUp) Set the xaPageNUp field for the SEP record.
void | setYaPage(int field_40_yaPage) Set the yaPage field for the SEP record.
void | setYaPageNUp(int field_42_yaPageNUp) Set the yaPageNUp field for the SEP record.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_bkc

protected byte field_1_bkc

BKC_NO_BREAK

public static final byte BKC_NO_BREAK
See Also:
Constant Field Values

BKC_NEW_COLUMN

public static final byte BKC_NEW_COLUMN
See Also:
Constant Field Values

BKC_NEW_PAGE

public static final byte BKC_NEW_PAGE
See Also:
Constant Field Values

BKC_EVEN_PAGE

public static final byte BKC_EVEN_PAGE
See Also:
Constant Field Values

BKC_ODD_PAGE

public static final byte BKC_ODD_PAGE
See Also:
Constant Field Values

field_2_fTitlePage

protected boolean field_2_fTitlePage

field_3_fAutoPgn

protected boolean field_3_fAutoPgn

field_4_nfcPgn

protected byte field_4_nfcPgn

NFCPGN_ARABIC

public static final byte NFCPGN_ARABIC
See Also:
Constant Field Values

NFCPGN_ROMAN_UPPER_CASE

public static final byte NFCPGN_ROMAN_UPPER_CASE
See Also:
Constant Field Values

NFCPGN_ROMAN_LOWER_CASE

public static final byte NFCPGN_ROMAN_LOWER_CASE
See Also:
Constant Field Values

NFCPGN_LETTER_UPPER_CASE

public static final byte NFCPGN_LETTER_UPPER_CASE
See Also:
Constant Field Values

NFCPGN_LETTER_LOWER_CASE

public static final byte NFCPGN_LETTER_LOWER_CASE
See Also:
Constant Field Values

field_5_fUnlocked

protected boolean field_5_fUnlocked

field_6_cnsPgn

protected byte field_6_cnsPgn

field_7_fPgnRestart

protected boolean field_7_fPgnRestart

field_8_fEndNote

protected boolean field_8_fEndNote

field_9_lnc

protected byte field_9_lnc

field_10_grpfIhdt

protected byte field_10_grpfIhdt

field_11_nLnnMod

protected int field_11_nLnnMod

field_12_dxaLnn

protected int field_12_dxaLnn

field_13_dxaPgn

protected int field_13_dxaPgn

field_14_dyaPgn

protected int field_14_dyaPgn

field_15_fLBetween

protected boolean field_15_fLBetween

field_16_vjc

protected byte field_16_vjc

field_17_dmBinFirst

protected int field_17_dmBinFirst

field_18_dmBinOther

protected int field_18_dmBinOther

field_19_dmPaperReq

protected int field_19_dmPaperReq

field_20_brcTop

protected BorderCode field_20_brcTop

field_21_brcLeft

protected BorderCode field_21_brcLeft

field_22_brcBottom

protected BorderCode field_22_brcBottom

field_23_brcRight

protected BorderCode field_23_brcRight

field_24_fPropMark

protected boolean field_24_fPropMark

field_25_ibstPropRMark

protected int field_25_ibstPropRMark

field_26_dttmPropRMark

protected DateAndTime field_26_dttmPropRMark

field_27_dxtCharSpace

protected int field_27_dxtCharSpace

field_28_dyaLinePitch

protected int field_28_dyaLinePitch

field_29_clm

protected int field_29_clm

field_30_unused2

protected int field_30_unused2

field_31_dmOrientPage

protected boolean field_31_dmOrientPage

DMORIENTPAGE_LANDSCAPE

public static final boolean DMORIENTPAGE_LANDSCAPE
See Also:
Constant Field Values

DMORIENTPAGE_PORTRAIT

public static final boolean DMORIENTPAGE_PORTRAIT
See Also:
Constant Field Values

field_32_iHeadingPgn

protected byte field_32_iHeadingPgn

field_33_pgnStart

protected int field_33_pgnStart

field_34_lnnMin

protected int field_34_lnnMin

field_35_wTextFlow

protected int field_35_wTextFlow

field_36_unused3

protected short field_36_unused3

field_37_pgbProp

protected int field_37_pgbProp

field_38_unused4

protected short field_38_unused4

field_39_xaPage

protected int field_39_xaPage

field_40_yaPage

protected int field_40_yaPage

field_41_xaPageNUp

protected int field_41_xaPageNUp

field_42_yaPageNUp

protected int field_42_yaPageNUp

field_43_dxaLeft

protected int field_43_dxaLeft

field_44_dxaRight

protected int field_44_dxaRight

field_45_dyaTop

protected int field_45_dyaTop

field_46_dyaBottom

protected int field_46_dyaBottom

field_47_dzaGutter

protected int field_47_dzaGutter

field_48_dyaHdrTop

protected int field_48_dyaHdrTop

field_49_dyaHdrBottom

protected int field_49_dyaHdrBottom

field_50_ccolM1

protected int field_50_ccolM1

field_51_fEvenlySpaced

protected boolean field_51_fEvenlySpaced

field_52_unused5

protected byte field_52_unused5

field_53_dxaColumns

protected int field_53_dxaColumns

field_54_rgdxaColumn

protected int[] field_54_rgdxaColumn

field_55_dxaColumnWidth

protected int field_55_dxaColumnWidth

field_56_dmOrientFirst

protected byte field_56_dmOrientFirst

field_57_fLayout

protected byte field_57_fLayout

field_58_unused6

protected short field_58_unused6

field_59_olstAnm

protected byte[] field_59_olstAnm
Constructor Detail

SEPAbstractType

protected SEPAbstractType()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getBkc

public byte getBkc()
Break code.

Returns:
One of
  • BKC_NO_BREAK
  • BKC_NEW_COLUMN
  • BKC_NEW_PAGE
  • BKC_EVEN_PAGE
  • BKC_ODD_PAGE

    • setBkc

    public void setBkc(byte field_1_bkc)
    Break code.

    Parameters:
    field_1_bkc - One of
  • BKC_NO_BREAK
  • BKC_NEW_COLUMN
  • BKC_NEW_PAGE
  • BKC_EVEN_PAGE
  • BKC_ODD_PAGE

    • getFTitlePage

    public boolean getFTitlePage()
    Set to 1 when a title page is to be displayed.

    setFTitlePage

    public void setFTitlePage(boolean field_2_fTitlePage)
    Set to 1 when a title page is to be displayed.

    getFAutoPgn

    public boolean getFAutoPgn()
    Only for Macintosh compatibility, used only during open, when 1, sep.dxaPgn and sep.dyaPgn are valid page number locations.

    setFAutoPgn

    public void setFAutoPgn(boolean field_3_fAutoPgn)
    Only for Macintosh compatibility, used only during open, when 1, sep.dxaPgn and sep.dyaPgn are valid page number locations.

    getNfcPgn

    public byte getNfcPgn()
    Page number format code.

    Returns:
    One of
  • NFCPGN_ARABIC
  • NFCPGN_ROMAN_UPPER_CASE
  • NFCPGN_ROMAN_LOWER_CASE
  • NFCPGN_LETTER_UPPER_CASE
  • NFCPGN_LETTER_LOWER_CASE

    • setNfcPgn

    public void setNfcPgn(byte field_4_nfcPgn)
    Page number format code.

    Parameters:
    field_4_nfcPgn - One of
  • NFCPGN_ARABIC
  • NFCPGN_ROMAN_UPPER_CASE
  • NFCPGN_ROMAN_LOWER_CASE
  • NFCPGN_LETTER_UPPER_CASE
  • NFCPGN_LETTER_LOWER_CASE

    • getFUnlocked

    public boolean getFUnlocked()
    Get the fUnlocked field for the SEP record.

    setFUnlocked

    public void setFUnlocked(boolean field_5_fUnlocked)
    Set the fUnlocked field for the SEP record.

    getCnsPgn

    public byte getCnsPgn()
    Get the cnsPgn field for the SEP record.

    setCnsPgn

    public void setCnsPgn(byte field_6_cnsPgn)
    Set the cnsPgn field for the SEP record.

    getFPgnRestart

    public boolean getFPgnRestart()
    Get the fPgnRestart field for the SEP record.

    setFPgnRestart

    public void setFPgnRestart(boolean field_7_fPgnRestart)
    Set the fPgnRestart field for the SEP record.

    getFEndNote

    public boolean getFEndNote()
    Get the fEndNote field for the SEP record.

    setFEndNote

    public void setFEndNote(boolean field_8_fEndNote)
    Set the fEndNote field for the SEP record.

    getLnc

    public byte getLnc()
    Get the lnc field for the SEP record.

    setLnc

    public void setLnc(byte field_9_lnc)
    Set the lnc field for the SEP record.

    getGrpfIhdt

    public byte getGrpfIhdt()
    Get the grpfIhdt field for the SEP record.

    setGrpfIhdt

    public void setGrpfIhdt(byte field_10_grpfIhdt)
    Set the grpfIhdt field for the SEP record.

    getNLnnMod

    public int getNLnnMod()
    Get the nLnnMod field for the SEP record.

    setNLnnMod

    public void setNLnnMod(int field_11_nLnnMod)
    Set the nLnnMod field for the SEP record.

    getDxaLnn

    public int getDxaLnn()
    Get the dxaLnn field for the SEP record.

    setDxaLnn

    public void setDxaLnn(int field_12_dxaLnn)
    Set the dxaLnn field for the SEP record.

    getDxaPgn

    public int getDxaPgn()
    Get the dxaPgn field for the SEP record.

    setDxaPgn

    public void setDxaPgn(int field_13_dxaPgn)
    Set the dxaPgn field for the SEP record.

    getDyaPgn

    public int getDyaPgn()
    Get the dyaPgn field for the SEP record.

    setDyaPgn

    public void setDyaPgn(int field_14_dyaPgn)
    Set the dyaPgn field for the SEP record.

    getFLBetween

    public boolean getFLBetween()
    Get the fLBetween field for the SEP record.

    setFLBetween

    public void setFLBetween(boolean field_15_fLBetween)
    Set the fLBetween field for the SEP record.

    getVjc

    public byte getVjc()
    Get the vjc field for the SEP record.

    setVjc

    public void setVjc(byte field_16_vjc)
    Set the vjc field for the SEP record.

    getDmBinFirst

    public int getDmBinFirst()
    Get the dmBinFirst field for the SEP record.

    setDmBinFirst

    public void setDmBinFirst(int field_17_dmBinFirst)
    Set the dmBinFirst field for the SEP record.

    getDmBinOther

    public int getDmBinOther()
    Get the dmBinOther field for the SEP record.

    setDmBinOther

    public void setDmBinOther(int field_18_dmBinOther)
    Set the dmBinOther field for the SEP record.

    getDmPaperReq

    public int getDmPaperReq()
    Get the dmPaperReq field for the SEP record.

    setDmPaperReq

    public void setDmPaperReq(int field_19_dmPaperReq)
    Set the dmPaperReq field for the SEP record.

    getBrcTop

    public BorderCode getBrcTop()
    Get the brcTop field for the SEP record.

    setBrcTop

    public void setBrcTop(BorderCode field_20_brcTop)
    Set the brcTop field for the SEP record.

    getBrcLeft

    public BorderCode getBrcLeft()
    Get the brcLeft field for the SEP record.

    setBrcLeft

    public void setBrcLeft(BorderCode field_21_brcLeft)
    Set the brcLeft field for the SEP record.

    getBrcBottom

    public BorderCode getBrcBottom()
    Get the brcBottom field for the SEP record.

    setBrcBottom

    public void setBrcBottom(BorderCode field_22_brcBottom)
    Set the brcBottom field for the SEP record.

    getBrcRight

    public BorderCode getBrcRight()
    Get the brcRight field for the SEP record.

    setBrcRight

    public void setBrcRight(BorderCode field_23_brcRight)
    Set the brcRight field for the SEP record.

    getFPropMark

    public boolean getFPropMark()
    Get the fPropMark field for the SEP record.

    setFPropMark

    public void setFPropMark(boolean field_24_fPropMark)
    Set the fPropMark field for the SEP record.

    getIbstPropRMark

    public int getIbstPropRMark()
    Get the ibstPropRMark field for the SEP record.

    setIbstPropRMark

    public void setIbstPropRMark(int field_25_ibstPropRMark)
    Set the ibstPropRMark field for the SEP record.

    getDttmPropRMark

    public DateAndTime getDttmPropRMark()
    Get the dttmPropRMark field for the SEP record.

    setDttmPropRMark

    public void setDttmPropRMark(DateAndTime field_26_dttmPropRMark)
    Set the dttmPropRMark field for the SEP record.

    getDxtCharSpace

    public int getDxtCharSpace()
    Get the dxtCharSpace field for the SEP record.

    setDxtCharSpace

    public void setDxtCharSpace(int field_27_dxtCharSpace)
    Set the dxtCharSpace field for the SEP record.

    getDyaLinePitch

    public int getDyaLinePitch()
    Get the dyaLinePitch field for the SEP record.

    setDyaLinePitch

    public void setDyaLinePitch(int field_28_dyaLinePitch)
    Set the dyaLinePitch field for the SEP record.

    getClm

    public int getClm()
    Get the clm field for the SEP record.

    setClm

    public void setClm(int field_29_clm)
    Set the clm field for the SEP record.

    getUnused2

    public int getUnused2()
    Get the unused2 field for the SEP record.

    setUnused2

    public void setUnused2(int field_30_unused2)
    Set the unused2 field for the SEP record.

    getDmOrientPage

    public boolean getDmOrientPage()
    Get the dmOrientPage field for the SEP record.

    Returns:
    One of
  • DMORIENTPAGE_LANDSCAPE
  • DMORIENTPAGE_PORTRAIT

    • setDmOrientPage

    public void setDmOrientPage(boolean field_31_dmOrientPage)
    Set the dmOrientPage field for the SEP record.

    Parameters:
    field_31_dmOrientPage - One of
  • DMORIENTPAGE_LANDSCAPE
  • DMORIENTPAGE_PORTRAIT

    • getIHeadingPgn

    public byte getIHeadingPgn()
    Get the iHeadingPgn field for the SEP record.

    setIHeadingPgn

    public void setIHeadingPgn(byte field_32_iHeadingPgn)
    Set the iHeadingPgn field for the SEP record.

    getPgnStart

    public int getPgnStart()
    Get the pgnStart field for the SEP record.

    setPgnStart

    public void setPgnStart(int field_33_pgnStart)
    Set the pgnStart field for the SEP record.

    getLnnMin

    public int getLnnMin()
    Get the lnnMin field for the SEP record.

    setLnnMin

    public void setLnnMin(int field_34_lnnMin)
    Set the lnnMin field for the SEP record.

    getWTextFlow

    public int getWTextFlow()
    Get the wTextFlow field for the SEP record.

    setWTextFlow

    public void setWTextFlow(int field_35_wTextFlow)
    Set the wTextFlow field for the SEP record.

    getUnused3

    public short getUnused3()
    Get the unused3 field for the SEP record.

    setUnused3

    public void setUnused3(short field_36_unused3)
    Set the unused3 field for the SEP record.

    getPgbProp

    public int getPgbProp()
    Get the pgbProp field for the SEP record.

    setPgbProp

    public void setPgbProp(int field_37_pgbProp)
    Set the pgbProp field for the SEP record.

    getUnused4

    public short getUnused4()
    Get the unused4 field for the SEP record.

    setUnused4

    public void setUnused4(short field_38_unused4)
    Set the unused4 field for the SEP record.

    getXaPage

    public int getXaPage()
    Get the xaPage field for the SEP record.

    setXaPage

    public void setXaPage(int field_39_xaPage)
    Set the xaPage field for the SEP record.

    getYaPage

    public int getYaPage()
    Get the yaPage field for the SEP record.

    setYaPage

    public void setYaPage(int field_40_yaPage)
    Set the yaPage field for the SEP record.

    getXaPageNUp

    public int getXaPageNUp()
    Get the xaPageNUp field for the SEP record.

    setXaPageNUp

    public void setXaPageNUp(int field_41_xaPageNUp)
    Set the xaPageNUp field for the SEP record.

    getYaPageNUp

    public int getYaPageNUp()
    Get the yaPageNUp field for the SEP record.

    setYaPageNUp

    public void setYaPageNUp(int field_42_yaPageNUp)
    Set the yaPageNUp field for the SEP record.

    getDxaLeft

    public int getDxaLeft()
    Get the dxaLeft field for the SEP record.

    setDxaLeft

    public void setDxaLeft(int field_43_dxaLeft)
    Set the dxaLeft field for the SEP record.

    getDxaRight

    public int getDxaRight()
    Get the dxaRight field for the SEP record.

    setDxaRight

    public void setDxaRight(int field_44_dxaRight)
    Set the dxaRight field for the SEP record.

    getDyaTop

    public int getDyaTop()
    Get the dyaTop field for the SEP record.

    setDyaTop

    public void setDyaTop(int field_45_dyaTop)
    Set the dyaTop field for the SEP record.

    getDyaBottom

    public int getDyaBottom()
    Get the dyaBottom field for the SEP record.

    setDyaBottom

    public void setDyaBottom(int field_46_dyaBottom)
    Set the dyaBottom field for the SEP record.

    getDzaGutter

    public int getDzaGutter()
    Get the dzaGutter field for the SEP record.

    setDzaGutter

    public void setDzaGutter(int field_47_dzaGutter)
    Set the dzaGutter field for the SEP record.

    getDyaHdrTop

    public int getDyaHdrTop()
    Get the dyaHdrTop field for the SEP record.

    setDyaHdrTop

    public void setDyaHdrTop(int field_48_dyaHdrTop)
    Set the dyaHdrTop field for the SEP record.

    getDyaHdrBottom

    public int getDyaHdrBottom()
    Get the dyaHdrBottom field for the SEP record.

    setDyaHdrBottom

    public void setDyaHdrBottom(int field_49_dyaHdrBottom)
    Set the dyaHdrBottom field for the SEP record.

    getCcolM1

    public int getCcolM1()
    Get the ccolM1 field for the SEP record.

    setCcolM1

    public void setCcolM1(int field_50_ccolM1)
    Set the ccolM1 field for the SEP record.

    getFEvenlySpaced

    public boolean getFEvenlySpaced()
    Get the fEvenlySpaced field for the SEP record.

    setFEvenlySpaced

    public void setFEvenlySpaced(boolean field_51_fEvenlySpaced)
    Set the fEvenlySpaced field for the SEP record.

    getUnused5

    public byte getUnused5()
    Get the unused5 field for the SEP record.

    setUnused5

    public void setUnused5(byte field_52_unused5)
    Set the unused5 field for the SEP record.

    getDxaColumns

    public int getDxaColumns()
    Get the dxaColumns field for the SEP record.

    setDxaColumns

    public void setDxaColumns(int field_53_dxaColumns)
    Set the dxaColumns field for the SEP record.

    getRgdxaColumn

    public int[] getRgdxaColumn()
    Get the rgdxaColumn field for the SEP record.

    setRgdxaColumn

    public void setRgdxaColumn(int[] field_54_rgdxaColumn)
    Set the rgdxaColumn field for the SEP record.

    getDxaColumnWidth

    public int getDxaColumnWidth()
    Get the dxaColumnWidth field for the SEP record.

    setDxaColumnWidth

    public void setDxaColumnWidth(int field_55_dxaColumnWidth)
    Set the dxaColumnWidth field for the SEP record.

    getDmOrientFirst

    public byte getDmOrientFirst()
    Get the dmOrientFirst field for the SEP record.

    setDmOrientFirst

    public void setDmOrientFirst(byte field_56_dmOrientFirst)
    Set the dmOrientFirst field for the SEP record.

    getFLayout

    public byte getFLayout()
    Get the fLayout field for the SEP record.

    setFLayout

    public void setFLayout(byte field_57_fLayout)
    Set the fLayout field for the SEP record.

    getUnused6

    public short getUnused6()
    Get the unused6 field for the SEP record.

    setUnused6

    public void setUnused6(short field_58_unused6)
    Set the unused6 field for the SEP record.

    getOlstAnm

    public byte[] getOlstAnm()
    Get the olstAnm field for the SEP record.

    setOlstAnm

    public void setOlstAnm(byte[] field_59_olstAnm)
    Set the olstAnm field for the SEP record.

    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SHD80AbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class SHD80AbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.SHD80AbstractType
Direct Known Subclasses:
ShadingDescriptor80
@Internal
public abstract class SHD80AbstractType
extends java.lang.Object

The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc]

Field Summary
protected  short field_1_value
Constructor Summary
protected SHD80AbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
byte | getIcoBack() Background color
byte | getIcoFore() Foreground color
byte | getIpat() Shading pattern
static int | getSize() Size of record
short | getValue() Get the value field for the SHD80 record.
void | serialize(byte[] data, int offset)
void | setIcoBack(byte value) Sets the icoBack field value.
void | setIcoFore(byte value) Sets the icoFore field value.
void | setIpat(byte value) Sets the ipat field value.
void | setValue(short field_1_value) Set the value field for the SHD80 record.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_value

protected short field_1_value
Constructor Detail

SHD80AbstractType

protected SHD80AbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getValue

@Internal
public short getValue()
Get the value field for the SHD80 record.

setValue

@Internal
public void setValue(short field_1_value)
Set the value field for the SHD80 record.

setIcoFore

@Internal
public void setIcoFore(byte value)
Sets the icoFore field value. Foreground color

getIcoFore

@Internal
public byte getIcoFore()
Foreground color

Returns:
the icoFore field value.

setIcoBack

@Internal
public void setIcoBack(byte value)
Sets the icoBack field value. Background color

getIcoBack

@Internal
public byte getIcoBack()
Background color

Returns:
the icoBack field value.

setIpat

@Internal
public void setIpat(byte value)
Sets the ipat field value. Shading pattern

getIpat

@Internal
public byte getIpat()
Shading pattern

Returns:
the ipat field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SHDAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class SHDAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.SHDAbstractType
Direct Known Subclasses:
ShadingDescriptor
@Internal
public abstract class SHDAbstractType
extends java.lang.Object

The SHD is a substructure of the CHP, PAP, and TC for Word 2000.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc]

Field Summary
protected Colorref | field_1_cvFore
protected Colorref | field_2_cvBack
protected int | field_3_ipat
Constructor Summary
protected SHDAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
Colorref | getCvBack() 24-bit background color.
Colorref | getCvFore() 24-bit foreground color.
int | getIpat() Shading pattern.
static int | getSize() Size of record
void | serialize(byte[] data, int offset)
void | setCvBack(Colorref field_2_cvBack) 24-bit background color.
void | setCvFore(Colorref field_1_cvFore) 24-bit foreground color.
void | setIpat(int field_3_ipat) Shading pattern.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_cvFore

protected Colorref field_1_cvFore

field_2_cvBack

protected Colorref field_2_cvBack

field_3_ipat

protected int field_3_ipat
Constructor Detail

SHDAbstractType

protected SHDAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getCvFore

@Internal
public Colorref getCvFore()
24-bit foreground color.

setCvFore

@Internal
public void setCvFore(Colorref field_1_cvFore)
24-bit foreground color.

getCvBack

@Internal
public Colorref getCvBack()
24-bit background color.

setCvBack

@Internal
public void setCvBack(Colorref field_2_cvBack)
24-bit background color.

getIpat

@Internal
public int getIpat()
Shading pattern.

setIpat

@Internal
public void setIpat(int field_3_ipat)
Shading pattern.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StdfBaseAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class StdfBaseAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.StdfBaseAbstractType

@Internal
public abstract class StdfBaseAbstractType
extends java.lang.Object

The StdfBase structure specifies general information about a style.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected short | field_1_info1
protected short | field_2_info2
protected short | field_3_info3
protected int | field_4_bchUpe
protected short | field_5_grfstd
Constructor Summary
protected StdfBaseAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
int | getBchUpe() An unsigned integer that specifies the size, in bytes, of std in LPStd.
byte | getCupx() number of UPXs (and UPEs)
byte | getFReserved() This value MUST be 0 and MUST be ignored
short | getGrfstd() A GRFSTD that specifies miscellaneous style properties.
short | getInfo1() Get the info1 field for the StdfBase record.
short | getInfo2() Get the info2 field for the StdfBase record.
short | getInfo3() Get the info3 field for the StdfBase record.
short | getIstdBase() base style
short | getIstdNext() next style
static int | getSize() Size of record
short | getSti() An unsigned integer that specifies the invariant style identifier for application-defined styles, or 0x0FFE for user-defined styles
byte | getStk() style kind
boolean | isF97LidsSet() Specifies whether sprmCRgLid0_80 and sprmCRgLid1_80 were applied, as appropriate, to this paragraph or character style for compatibility with applications that do not support sprmCRgLid0, sprmCRgLid1, and sprmCFNoProof
boolean | isFAutoRedef() number of UPXs (and UPEs)
boolean | isFCopyLang() If f97LidsSet is 1, this value specifies whether the applied compatibility sprmCRgLid0_80 or sprmCRgLid1_80 specified an actual language or a special LID value (0x0400) signifying that no proofing is needed for the text.
boolean | isFHasUpe() This bit is undefined and MUST be ignored
boolean | isFHidden() Specifies whether this style is not shown in the application UI
boolean | isFInternalUse() This bit is undefined and MUST be ignored
boolean | isFInvalHeight() Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97, for any paragraphs having this paragraph style, MUST be ignored.
boolean | isFLocked() Specifies whether this style is prevented from being applied by using the application UI
boolean | isFMassCopy() This bit is undefined and MUST be ignored
boolean | isFNoHtmlExport() This value MUST be 0 and MUST be ignored
boolean | isFPersonal() Specifies whether this character style was applied to format all message text from one or more users in an e-mail
boolean | isFPersonalCompose() Specifies whether this character style can be used to automatically format the new message text in a new e-mail
boolean | isFPersonalReply() Specifies whether this character style can be used to automatically format the new message text when replying to an e-mail
boolean | isFQFormat() Specifies whether this style is shown in the Ribbon Style gallery
boolean | isFScratch() spare field for any temporary use, always reset back to zero!
boolean | isFSemiHidden() Specifies whether this style is not shown in the simplified main styles UI of the application
boolean | isFUnhideWhenUsed() Specifies whether the fSemiHidden property is to be set to 0 when this style is used
void | serialize(byte[] data, int offset)
void | setBchUpe(int field_4_bchUpe) An unsigned integer that specifies the size, in bytes, of std in LPStd.
void | setCupx(byte value) Sets the cupx field value.
void | setF97LidsSet(boolean value) Sets the f97LidsSet field value.
void | setFAutoRedef(boolean value) Sets the fAutoRedef field value.
void | setFCopyLang(boolean value) Sets the fCopyLang field value.
void | setFHasUpe(boolean value) Sets the fHasUpe field value.
void | setFHidden(boolean value) Sets the fHidden field value.
void | setFInternalUse(boolean value) Sets the fInternalUse field value.
void | setFInvalHeight(boolean value) Sets the fInvalHeight field value.
void | setFLocked(boolean value) Sets the fLocked field value.
void | setFMassCopy(boolean value) Sets the fMassCopy field value.
void | setFNoHtmlExport(boolean value) Sets the fNoHtmlExport field value.
void | setFPersonal(boolean value) Sets the fPersonal field value.
void | setFPersonalCompose(boolean value) Sets the fPersonalCompose field value.
void | setFPersonalReply(boolean value) Sets the fPersonalReply field value.
void | setFQFormat(boolean value) Sets the fQFormat field value.
void | setFReserved(byte value) Sets the fReserved field value.
void | setFScratch(boolean value) Sets the fScratch field value.
void | setFSemiHidden(boolean value) Sets the fSemiHidden field value.
void | setFUnhideWhenUsed(boolean value) Sets the fUnhideWhenUsed field value.
void | setGrfstd(short field_5_grfstd) A GRFSTD that specifies miscellaneous style properties.
void | setInfo1(short field_1_info1) Set the info1 field for the StdfBase record.
void | setInfo2(short field_2_info2) Set the info2 field for the StdfBase record.
void | setInfo3(short field_3_info3) Set the info3 field for the StdfBase record.
void | setIstdBase(short value) Sets the istdBase field value.
void | setIstdNext(short value) Sets the istdNext field value.
void | setSti(short value) Sets the sti field value.
void | setStk(byte value) Sets the stk field value.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_info1

protected short field_1_info1

field_2_info2

protected short field_2_info2

field_3_info3

protected short field_3_info3

field_4_bchUpe

protected int field_4_bchUpe

field_5_grfstd

protected short field_5_grfstd
Constructor Detail

StdfBaseAbstractType

protected StdfBaseAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getInfo1

@Internal
public short getInfo1()
Get the info1 field for the StdfBase record.

setInfo1

@Internal
public void setInfo1(short field_1_info1)
Set the info1 field for the StdfBase record.

getInfo2

@Internal
public short getInfo2()
Get the info2 field for the StdfBase record.

setInfo2

@Internal
public void setInfo2(short field_2_info2)
Set the info2 field for the StdfBase record.

getInfo3

@Internal
public short getInfo3()
Get the info3 field for the StdfBase record.

setInfo3

@Internal
public void setInfo3(short field_3_info3)
Set the info3 field for the StdfBase record.

getBchUpe

@Internal
public int getBchUpe()
An unsigned integer that specifies the size, in bytes, of std in LPStd. This value MUST be equal to cbStd in LPStd.

setBchUpe

@Internal
public void setBchUpe(int field_4_bchUpe)
An unsigned integer that specifies the size, in bytes, of std in LPStd. This value MUST be equal to cbStd in LPStd.

getGrfstd

@Internal
public short getGrfstd()
A GRFSTD that specifies miscellaneous style properties.

setGrfstd

@Internal
public void setGrfstd(short field_5_grfstd)
A GRFSTD that specifies miscellaneous style properties.

setSti

@Internal
public void setSti(short value)
Sets the sti field value. An unsigned integer that specifies the invariant style identifier for application-defined styles, or 0x0FFE for user-defined styles

getSti

@Internal
public short getSti()
An unsigned integer that specifies the invariant style identifier for application-defined styles, or 0x0FFE for user-defined styles

Returns:
the sti field value.

setFScratch

@Internal
public void setFScratch(boolean value)
Sets the fScratch field value. spare field for any temporary use, always reset back to zero!

isFScratch

@Internal
public boolean isFScratch()
spare field for any temporary use, always reset back to zero!

Returns:
the fScratch field value.

setFInvalHeight

@Internal
public void setFInvalHeight(boolean value)
Sets the fInvalHeight field value. Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97, for any paragraphs having this paragraph style, MUST be ignored. SHOULD be 0

isFInvalHeight

@Internal
public boolean isFInvalHeight()
Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97, for any paragraphs having this paragraph style, MUST be ignored. SHOULD be 0

Returns:
the fInvalHeight field value.

setFHasUpe

@Internal
public void setFHasUpe(boolean value)
Sets the fHasUpe field value. This bit is undefined and MUST be ignored

isFHasUpe

@Internal
public boolean isFHasUpe()
This bit is undefined and MUST be ignored

Returns:
the fHasUpe field value.

setFMassCopy

@Internal
public void setFMassCopy(boolean value)
Sets the fMassCopy field value. This bit is undefined and MUST be ignored

isFMassCopy

@Internal
public boolean isFMassCopy()
This bit is undefined and MUST be ignored

Returns:
the fMassCopy field value.

setStk

@Internal
public void setStk(byte value)
Sets the stk field value. style kind

getStk

@Internal
public byte getStk()
style kind

Returns:
the stk field value.

setIstdBase

@Internal
public void setIstdBase(short value)
Sets the istdBase field value. base style

getIstdBase

@Internal
public short getIstdBase()
base style

Returns:
the istdBase field value.

setCupx

@Internal
public void setCupx(byte value)
Sets the cupx field value. number of UPXs (and UPEs)

getCupx

@Internal
public byte getCupx()
number of UPXs (and UPEs)

Returns:
the cupx field value.

setIstdNext

@Internal
public void setIstdNext(short value)
Sets the istdNext field value. next style

getIstdNext

@Internal
public short getIstdNext()
next style

Returns:
the istdNext field value.

setFAutoRedef

@Internal
public void setFAutoRedef(boolean value)
Sets the fAutoRedef field value. number of UPXs (and UPEs)

isFAutoRedef

@Internal
public boolean isFAutoRedef()
number of UPXs (and UPEs)

Returns:
the fAutoRedef field value.

setFHidden

@Internal
public void setFHidden(boolean value)
Sets the fHidden field value. Specifies whether this style is not shown in the application UI

isFHidden

@Internal
public boolean isFHidden()
Specifies whether this style is not shown in the application UI

Returns:
the fHidden field value.

setF97LidsSet

@Internal
public void setF97LidsSet(boolean value)
Sets the f97LidsSet field value. Specifies whether sprmCRgLid0_80 and sprmCRgLid1_80 were applied, as appropriate, to this paragraph or character style for compatibility with applications that do not support sprmCRgLid0, sprmCRgLid1, and sprmCFNoProof

isF97LidsSet

@Internal
public boolean isF97LidsSet()
Specifies whether sprmCRgLid0_80 and sprmCRgLid1_80 were applied, as appropriate, to this paragraph or character style for compatibility with applications that do not support sprmCRgLid0, sprmCRgLid1, and sprmCFNoProof

Returns:
the f97LidsSet field value.

setFCopyLang

@Internal
public void setFCopyLang(boolean value)
Sets the fCopyLang field value. If f97LidsSet is 1, this value specifies whether the applied compatibility sprmCRgLid0_80 or sprmCRgLid1_80 specified an actual language or a special LID value (0x0400) signifying that no proofing is needed for the text. This MUST be ignored if f97LidsSet is 0

isFCopyLang

@Internal
public boolean isFCopyLang()
If f97LidsSet is 1, this value specifies whether the applied compatibility sprmCRgLid0_80 or sprmCRgLid1_80 specified an actual language or a special LID value (0x0400) signifying that no proofing is needed for the text. This MUST be ignored if f97LidsSet is 0

Returns:
the fCopyLang field value.

setFPersonalCompose

@Internal
public void setFPersonalCompose(boolean value)
Sets the fPersonalCompose field value. Specifies whether this character style can be used to automatically format the new message text in a new e-mail

isFPersonalCompose

@Internal
public boolean isFPersonalCompose()
Specifies whether this character style can be used to automatically format the new message text in a new e-mail

Returns:
the fPersonalCompose field value.

setFPersonalReply

@Internal
public void setFPersonalReply(boolean value)
Sets the fPersonalReply field value. Specifies whether this character style can be used to automatically format the new message text when replying to an e-mail

isFPersonalReply

@Internal
public boolean isFPersonalReply()
Specifies whether this character style can be used to automatically format the new message text when replying to an e-mail

Returns:
the fPersonalReply field value.

setFPersonal

@Internal
public void setFPersonal(boolean value)
Sets the fPersonal field value. Specifies whether this character style was applied to format all message text from one or more users in an e-mail

isFPersonal

@Internal
public boolean isFPersonal()
Specifies whether this character style was applied to format all message text from one or more users in an e-mail

Returns:
the fPersonal field value.

setFNoHtmlExport

@Internal
public void setFNoHtmlExport(boolean value)
Sets the fNoHtmlExport field value. This value MUST be 0 and MUST be ignored

isFNoHtmlExport

@Internal
public boolean isFNoHtmlExport()
This value MUST be 0 and MUST be ignored

Returns:
the fNoHtmlExport field value.

setFSemiHidden

@Internal
public void setFSemiHidden(boolean value)
Sets the fSemiHidden field value. Specifies whether this style is not shown in the simplified main styles UI of the application

isFSemiHidden

@Internal
public boolean isFSemiHidden()
Specifies whether this style is not shown in the simplified main styles UI of the application

Returns:
the fSemiHidden field value.

setFLocked

@Internal
public void setFLocked(boolean value)
Sets the fLocked field value. Specifies whether this style is prevented from being applied by using the application UI

isFLocked

@Internal
public boolean isFLocked()
Specifies whether this style is prevented from being applied by using the application UI

Returns:
the fLocked field value.

setFInternalUse

@Internal
public void setFInternalUse(boolean value)
Sets the fInternalUse field value. This bit is undefined and MUST be ignored

isFInternalUse

@Internal
public boolean isFInternalUse()
This bit is undefined and MUST be ignored

Returns:
the fInternalUse field value.

setFUnhideWhenUsed

@Internal
public void setFUnhideWhenUsed(boolean value)
Sets the fUnhideWhenUsed field value. Specifies whether the fSemiHidden property is to be set to 0 when this style is used

isFUnhideWhenUsed

@Internal
public boolean isFUnhideWhenUsed()
Specifies whether the fSemiHidden property is to be set to 0 when this style is used

Returns:
the fUnhideWhenUsed field value.

setFQFormat

@Internal
public void setFQFormat(boolean value)
Sets the fQFormat field value. Specifies whether this style is shown in the Ribbon Style gallery

isFQFormat

@Internal
public boolean isFQFormat()
Specifies whether this style is shown in the Ribbon Style gallery

Returns:
the fQFormat field value.

setFReserved

@Internal
public void setFReserved(byte value)
Sets the fReserved field value. This value MUST be 0 and MUST be ignored

getFReserved

@Internal
public byte getFReserved()
This value MUST be 0 and MUST be ignored

Returns:
the fReserved field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StdfPost2000AbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class StdfPost2000AbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

@Internal
public abstract class StdfPost2000AbstractType
extends java.lang.Object

The StdfPost2000 structure specifies general information about a style.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected short | field_1_info1
protected long | field_2_rsid
protected short | field_3_info3
Constructor Summary
protected StdfPost2000AbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
byte | getFSpare() Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97
byte | getIftcHtml() This field is undefined and MUST be ignored
short | getInfo1() Get the info1 field for the StdfPost2000 record.
short | getInfo3() Get the info3 field for the StdfPost2000 record.
short | getIPriority() An unsigned integer that specifies the priority value that is assigned to this style and that is used when ordering the styles by priority in the user interface
short | getIstdLink() An unsigned integer that specifies the istd of the style that is linked to this one, or 0x0000 if this style is not linked to any other style in the document.
long | getRsid() An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.
static int | getSize() Size of record
boolean | isFHasOriginalStyle() Specifies whether the style is revision-marked.
boolean | isUnused() This value MUST be zero and MUST be ignored
void | serialize(byte[] data, int offset)
void | setFHasOriginalStyle(boolean value) Sets the fHasOriginalStyle field value.
void | setFSpare(byte value) Sets the fSpare field value.
void | setIftcHtml(byte value) Sets the iftcHtml field value.
void | setInfo1(short field_1_info1) Set the info1 field for the StdfPost2000 record.
void | setInfo3(short field_3_info3) Set the info3 field for the StdfPost2000 record.
void | setIPriority(short value) Sets the iPriority field value.
void | setIstdLink(short value) Sets the istdLink field value.
void | setRsid(long field_2_rsid) An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.
void | setUnused(boolean value) Sets the unused field value.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_info1

protected short field_1_info1

field_2_rsid

protected long field_2_rsid

field_3_info3

protected short field_3_info3
Constructor Detail

StdfPost2000AbstractType

protected StdfPost2000AbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getInfo1

@Internal
public short getInfo1()
Get the info1 field for the StdfPost2000 record.

setInfo1

@Internal
public void setInfo1(short field_1_info1)
Set the info1 field for the StdfPost2000 record.

getRsid

@Internal
public long getRsid()
An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.

setRsid

@Internal
public void setRsid(long field_2_rsid)
An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.

getInfo3

@Internal
public short getInfo3()
Get the info3 field for the StdfPost2000 record.

setInfo3

@Internal
public void setInfo3(short field_3_info3)
Set the info3 field for the StdfPost2000 record.

setIstdLink

@Internal
public void setIstdLink(short value)
Sets the istdLink field value. An unsigned integer that specifies the istd of the style that is linked to this one, or 0x0000 if this style is not linked to any other style in the document.

getIstdLink

@Internal
public short getIstdLink()
An unsigned integer that specifies the istd of the style that is linked to this one, or 0x0000 if this style is not linked to any other style in the document.

Returns:
the istdLink field value.

setFHasOriginalStyle

@Internal
public void setFHasOriginalStyle(boolean value)
Sets the fHasOriginalStyle field value. Specifies whether the style is revision-marked. A revision-marked style stores the pre-revision formatting in addition to the current formatting. If this bit is set to 1, the cupx member of StdfBase MUST include the formatting sets that specify that pre-revision formatting

isFHasOriginalStyle

@Internal
public boolean isFHasOriginalStyle()
Specifies whether the style is revision-marked. A revision-marked style stores the pre-revision formatting in addition to the current formatting. If this bit is set to 1, the cupx member of StdfBase MUST include the formatting sets that specify that pre-revision formatting

Returns:
the fHasOriginalStyle field value.

setFSpare

@Internal
public void setFSpare(byte value)
Sets the fSpare field value. Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97

getFSpare

@Internal
public byte getFSpare()
Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97

Returns:
the fSpare field value.

setIftcHtml

@Internal
public void setIftcHtml(byte value)
Sets the iftcHtml field value. This field is undefined and MUST be ignored

getIftcHtml

@Internal
public byte getIftcHtml()
This field is undefined and MUST be ignored

Returns:
the iftcHtml field value.

setUnused

@Internal
public void setUnused(boolean value)
Sets the unused field value. This value MUST be zero and MUST be ignored

isUnused

@Internal
public boolean isUnused()
This value MUST be zero and MUST be ignored

Returns:
the unused field value.

setIPriority

@Internal
public void setIPriority(short value)
Sets the iPriority field value. An unsigned integer that specifies the priority value that is assigned to this style and that is used when ordering the styles by priority in the user interface

getIPriority

@Internal
public short getIPriority()
An unsigned integer that specifies the priority value that is assigned to this style and that is used when ordering the styles by priority in the user interface

Returns:
the iPriority field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StshifAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class StshifAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.StshifAbstractType

@Internal
public abstract class StshifAbstractType
extends java.lang.Object

The Stshif structure specifies general stylesheet information.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format and [MS-DOC] - v20110608 Word (.doc) Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc] and [MS-DOC] - v20110608 Word (.doc) Binary File Format

Field Summary
protected int | field_1_cstd
protected int | field_2_cbSTDBaseInFile
protected int | field_3_info3
protected int | field_4_stiMaxWhenSaved
protected int | field_5_istdMaxFixedWhenSaved
protected int | field_6_nVerBuiltInNamesWhenSaved
protected short | field_7_ftcAsci
protected short | field_8_ftcFE
protected short | field_9_ftcOther
Constructor Summary
protected StshifAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
int | getCbSTDBaseInFile() An unsigned integer that specifies the size, in bytes, of the Stdf structure.
int | getCstd() An unsigned integer that specifies the count of elements in STSH.rglpstd.
short | getFReserved() This value MUST be zero and MUST be ignored
short | getFtcAsci() A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.
short | getFtcFE() A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.
short | getFtcOther() A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.
int | getInfo3() Get the info3 field for the Stshif record.
int | getIstdMaxFixedWhenSaved() An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles.
int | getNVerBuiltInNamesWhenSaved() An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.
static int | getSize() Size of record
int | getStiMaxWhenSaved() An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style.
boolean | isFHasOriginalStyle() This value MUST be 1 and MUST be ignored
void | serialize(byte[] data, int offset)
void | setCbSTDBaseInFile(int field_2_cbSTDBaseInFile) An unsigned integer that specifies the size, in bytes, of the Stdf structure.
void | setCstd(int field_1_cstd) An unsigned integer that specifies the count of elements in STSH.rglpstd.
void | setFHasOriginalStyle(boolean value) Sets the fHasOriginalStyle field value.
void | setFReserved(short value) Sets the fReserved field value.
void | setFtcAsci(short field_7_ftcAsci) A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.
void | setFtcFE(short field_8_ftcFE) A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.
void | setFtcOther(short field_9_ftcOther) A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.
void | setInfo3(int field_3_info3) Set the info3 field for the Stshif record.
void | setIstdMaxFixedWhenSaved(int field_5_istdMaxFixedWhenSaved) An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles.
void | setNVerBuiltInNamesWhenSaved(int field_6_nVerBuiltInNamesWhenSaved) An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.
void | setStiMaxWhenSaved(int field_4_stiMaxWhenSaved) An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_cstd

protected int field_1_cstd

field_2_cbSTDBaseInFile

protected int field_2_cbSTDBaseInFile

field_3_info3

protected int field_3_info3

field_4_stiMaxWhenSaved

protected int field_4_stiMaxWhenSaved

field_5_istdMaxFixedWhenSaved

protected int field_5_istdMaxFixedWhenSaved

field_6_nVerBuiltInNamesWhenSaved

protected int field_6_nVerBuiltInNamesWhenSaved

field_7_ftcAsci

protected short field_7_ftcAsci

field_8_ftcFE

protected short field_8_ftcFE

field_9_ftcOther

protected short field_9_ftcOther
Constructor Detail

StshifAbstractType

protected StshifAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getCstd

@Internal
public int getCstd()
An unsigned integer that specifies the count of elements in STSH.rglpstd. This value MUST be equal to or greater than 0x000F, and MUST be less than 0x0FFE.

setCstd

@Internal
public void setCstd(int field_1_cstd)
An unsigned integer that specifies the count of elements in STSH.rglpstd. This value MUST be equal to or greater than 0x000F, and MUST be less than 0x0FFE.

getCbSTDBaseInFile

@Internal
public int getCbSTDBaseInFile()
An unsigned integer that specifies the size, in bytes, of the Stdf structure. The Stdf structure contains an StdfBase structure that is followed by a StdfPost2000OrNone structure which contains an optional StdfPost2000 structure. This value MUST be 0x000A when the Stdf structure does not contain an StdfPost2000 structure and MUST be 0x0012 when the Stdf structure does contain an StdfPost2000 structure..

setCbSTDBaseInFile

@Internal
public void setCbSTDBaseInFile(int field_2_cbSTDBaseInFile)
An unsigned integer that specifies the size, in bytes, of the Stdf structure. The Stdf structure contains an StdfBase structure that is followed by a StdfPost2000OrNone structure which contains an optional StdfPost2000 structure. This value MUST be 0x000A when the Stdf structure does not contain an StdfPost2000 structure and MUST be 0x0012 when the Stdf structure does contain an StdfPost2000 structure..

getInfo3

@Internal
public int getInfo3()
Get the info3 field for the Stshif record.

setInfo3

@Internal
public void setInfo3(int field_3_info3)
Set the info3 field for the Stshif record.

getStiMaxWhenSaved

@Internal
public int getStiMaxWhenSaved()
An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style. This SHOULD be equal to the largest sti index that is defined in the application, incremented by 1.

setStiMaxWhenSaved

@Internal
public void setStiMaxWhenSaved(int field_4_stiMaxWhenSaved)
An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style. This SHOULD be equal to the largest sti index that is defined in the application, incremented by 1.

getIstdMaxFixedWhenSaved

@Internal
public int getIstdMaxFixedWhenSaved()
An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles. This value MUST be 0x000F.

setIstdMaxFixedWhenSaved

@Internal
public void setIstdMaxFixedWhenSaved(int field_5_istdMaxFixedWhenSaved)
An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles. This value MUST be 0x000F.

getNVerBuiltInNamesWhenSaved

@Internal
public int getNVerBuiltInNamesWhenSaved()
An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.

setNVerBuiltInNamesWhenSaved

@Internal
public void setNVerBuiltInNamesWhenSaved(int field_6_nVerBuiltInNamesWhenSaved)
An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.

getFtcAsci

@Internal
public short getFtcAsci()
A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.

setFtcAsci

@Internal
public void setFtcAsci(short field_7_ftcAsci)
A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.

getFtcFE

@Internal
public short getFtcFE()
A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.

setFtcFE

@Internal
public void setFtcFE(short field_8_ftcFE)
A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.

getFtcOther

@Internal
public short getFtcOther()
A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.

setFtcOther

@Internal
public void setFtcOther(short field_9_ftcOther)
A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.

setFHasOriginalStyle

@Internal
public void setFHasOriginalStyle(boolean value)
Sets the fHasOriginalStyle field value. This value MUST be 1 and MUST be ignored

isFHasOriginalStyle

@Internal
public boolean isFHasOriginalStyle()
This value MUST be 1 and MUST be ignored

Returns:
the fHasOriginalStyle field value.

setFReserved

@Internal
public void setFReserved(short value)
Sets the fReserved field value. This value MUST be zero and MUST be ignored

getFReserved

@Internal
public short getFReserved()
This value MUST be zero and MUST be ignored

Returns:
the fReserved field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TAPAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class TAPAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TAPAbstractType
Direct Known Subclasses:
TableProperties
@Internal
public abstract class TAPAbstractType
extends java.lang.Object

Table Properties. Properties descriptions quoted from official 97-2007 binary file format specification.

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
S. Ryan Ackley

Field Summary
protected short | field_1_istd
protected short | field_10_wWidthIndent
protected short | field_11_wWidthBefore
protected short | field_12_wWidthAfter
protected int | field_13_widthAndFitsFlags
protected int | field_14_dxaAbs
protected int | field_15_dyaAbs
protected int | field_16_dxaFromText
protected int | field_17_dyaFromText
protected int | field_18_dxaFromTextRight
protected int | field_19_dyaFromTextBottom
protected short | field_2_jc
protected byte | field_20_fBiDi
protected byte | field_21_fRTL
protected byte | field_22_fNoAllowOverlap
protected byte | field_23_fSpare
protected int | field_24_grpfTap
protected int | field_25_internalFlags
protected short | field_26_itcMac
protected int | field_27_dxaAdjust
protected int | field_28_dxaWebView
protected int | field_29_dxaRTEWrapWidth
protected int | field_3_dxaGapHalf
protected int | field_30_dxaColWidthWwd
protected short | field_31_pctWwd
protected int | field_32_viewFlags
protected short[] | field_33_rgdxaCenter
protected short[] | field_34_rgdxaCenterPrint
protected ShadingDescriptor | field_35_shdTable
protected BorderCode | field_36_brcBottom
protected BorderCode | field_37_brcTop
protected BorderCode | field_38_brcLeft
protected BorderCode | field_39_brcRight
protected int | field_4_dyaRowHeight
protected BorderCode | field_40_brcVertical
protected BorderCode | field_41_brcHorizontal
protected short | field_42_wCellPaddingDefaultTop
protected short | field_43_wCellPaddingDefaultLeft
protected short | field_44_wCellPaddingDefaultBottom
protected short | field_45_wCellPaddingDefaultRight
protected byte | field_46_ftsCellPaddingDefaultTop
protected byte | field_47_ftsCellPaddingDefaultLeft
protected byte | field_48_ftsCellPaddingDefaultBottom
protected byte | field_49_ftsCellPaddingDefaultRight
protected boolean | field_5_fCantSplit
protected short | field_50_wCellSpacingDefaultTop
protected short | field_51_wCellSpacingDefaultLeft
protected short | field_52_wCellSpacingDefaultBottom
protected short | field_53_wCellSpacingDefaultRight
protected byte | field_54_ftsCellSpacingDefaultTop
protected byte | field_55_ftsCellSpacingDefaultLeft
protected byte | field_56_ftsCellSpacingDefaultBottom
protected byte | field_57_ftsCellSpacingDefaultRight
protected short | field_58_wCellPaddingOuterTop
protected short | field_59_wCellPaddingOuterLeft
protected boolean | field_6_fCantSplit90
protected short | field_60_wCellPaddingOuterBottom
protected short | field_61_wCellPaddingOuterRight
protected byte | field_62_ftsCellPaddingOuterTop
protected byte | field_63_ftsCellPaddingOuterLeft
protected byte | field_64_ftsCellPaddingOuterBottom
protected byte | field_65_ftsCellPaddingOuterRight
protected short | field_66_wCellSpacingOuterTop
protected short | field_67_wCellSpacingOuterLeft
protected short | field_68_wCellSpacingOuterBottom
protected short | field_69_wCellSpacingOuterRight
protected boolean | field_7_fTableHeader
protected byte | field_70_ftsCellSpacingOuterTop
protected byte | field_71_ftsCellSpacingOuterLeft
protected byte | field_72_ftsCellSpacingOuterBottom
protected byte | field_73_ftsCellSpacingOuterRight
protected TableCellDescriptor[] | field_74_rgtc
protected ShadingDescriptor[] | field_75_rgshd
protected byte | field_76_fPropRMark
protected byte | field_77_fHasOldProps
protected short | field_78_cHorzBands
protected short | field_79_cVertBands
protected TableAutoformatLookSpecifier | field_8_tlp
protected BorderCode | field_80_rgbrcInsideDefault_0
protected BorderCode | field_81_rgbrcInsideDefault_1
protected short | field_9_wWidth
Constructor Summary
protected TAPAbstractType()
Method Summary
BorderCode | getBrcBottom() Get the brcBottom field for the TAP record.
BorderCode | getBrcHorizontal() Get the brcHorizontal field for the TAP record.
BorderCode | getBrcLeft() Get the brcLeft field for the TAP record.
BorderCode | getBrcRight() Get the brcRight field for the TAP record.
BorderCode | getBrcTop() Get the brcTop field for the TAP record.
BorderCode | getBrcVertical() Get the brcVertical field for the TAP record.
short | getCHorzBands() Size of each horizontal style band, in number of rows.
short | getCVertBands() Size of a vertical style band, in number of columns.
int | getDxaAbs() Absolute horizontal position.
int | getDxaAdjust() Used internally by Word.
int | getDxaColWidthWwd() Used internally by Word.
int | getDxaFromText() Left distance from surrounding text when absolutely positioned.
int | getDxaFromTextRight() Right distance from surrounding text when absolutely positioned.
int | getDxaGapHalf() Measures half of the white space that will be maintained between text in adjacent columns of a table row.
int | getDxaRTEWrapWidth() Used internally by Word.
int | getDxaWebView() Used internally by Word.
int | getDyaAbs() Absolute vertical position.
int | getDyaFromText() Top distance from surrounding text when absolutely positioned.
int | getDyaFromTextBottom() Bottom distance from surrounding text when absolutely positioned.
int | getDyaRowHeight() When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high.
byte | getFBiDi() When 1, table is right-to-left.
boolean | getFCantSplit() When 1, table row may not be split across page bounds.
boolean | getFCantSplit90() When 1, table row may not be split across page bounds.
byte | getFHasOldProps() Has old properties.
byte | getFNoAllowOverlap() When set to 1, do not allow absolutely positioned table to overlap with other tables.
byte | getFPropRMark() Set to 1 if property revision.
byte | getFRTL() Word 2000 style right-to-left table.
byte | getFSpare() Not used.
boolean | getFTableHeader() When 1, table row is to be used as the header of the table.
byte | getFtsCellPaddingDefaultBottom() Default bottom cell margin/padding units.
byte | getFtsCellPaddingDefaultLeft() Default left cell margin/padding units.
byte | getFtsCellPaddingDefaultRight() Default right cell margin/padding units.
byte | getFtsCellPaddingDefaultTop() Default top cell margin/padding units.
byte | getFtsCellPaddingOuterBottom() Default outer bottom cell margin/padding units.
byte | getFtsCellPaddingOuterLeft() Default outer left cell margin/padding units.
byte | getFtsCellPaddingOuterRight() Default outer right cell margin/padding units.
byte | getFtsCellPaddingOuterTop() Default outer top cell margin/padding units.
byte | getFtsCellSpacingDefaultBottom() Default bottom cell spacings units.
byte | getFtsCellSpacingDefaultLeft() Default left cell spacings units.
byte | getFtsCellSpacingDefaultRight() Default right cell spacings units.
byte | getFtsCellSpacingDefaultTop() Default top cell spacings units.
byte | getFtsCellSpacingOuterBottom() Default outer bottom cell spacings units.
byte | getFtsCellSpacingOuterLeft() Default outer left cell spacings units.
byte | getFtsCellSpacingOuterRight() Default outer right cell spacings units.
byte | getFtsCellSpacingOuterTop() Default outer top cell spacings units.
byte | getFtsWidth() Units for wWidth: 0 -- null; 1 -- auto, ignores wWidth, 2 -- percentage (in 50ths of a percent), 3 -- twips
byte | getFtsWidthAfter() Units for wWidthAfter: 0 -- null; 1 -- auto, ignores wWidthAfter, 2 -- percentage (in 50ths of a percent), 3 -- twips
byte | getFtsWidthBefore() Units for wWidthBefore: 0 -- null; 1 -- auto, ignores wWidthBefore, 2 -- percentage (in 50ths of a percent), 3 -- twips
byte | getFtsWidthIndent() Units for wWidthIndent: 0 -- null; 1 -- auto, ignores wWidthIndent, 2 -- percentage (in 50ths of a percent), 3 -- twips
short | getGrpfTap_unused() Not used
int | getGrpfTap() Used internally by Word.
int | getInternalFlags() Used internally by Word.
short | getIstd() Table style for the Table.
short | getItcMac() Count of cells defined for this row.
short | getJc() Justification code.
byte | getPcHorz() Horizontal position code.
short | getPctWwd() Used internally by Word: percent of Window size for AutoFit in WebView.
byte | getPcVert() Vertical position code.
BorderCode | getRgbrcInsideDefault_0() Border definition for inside horizontal borders.
BorderCode | getRgbrcInsideDefault_1() Border definition for inside vertical borders.
short[] | getRgdxaCenter() rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..
short[] | getRgdxaCenterPrint() Used internally by Word.
ShadingDescriptor[] | getRgshd() Get the rgshd field for the TAP record.
TableCellDescriptor[] | getRgtc() Get the rgtc field for the TAP record.
ShadingDescriptor | getShdTable() Table shading.
TableAutoformatLookSpecifier | getTlp() Table look specifier.
short | getViewFlags_unused2() Not used
int | getViewFlags() Used internally by Word.
short | getWCellPaddingDefaultBottom() Default bottom cell margin/padding.
short | getWCellPaddingDefaultLeft() Default left cell margin/padding.
short | getWCellPaddingDefaultRight() Default right cell margin/padding.
short | getWCellPaddingDefaultTop() Default top cell margin/padding.
short | getWCellPaddingOuterBottom() Default outer bottom cell margin/padding.
short | getWCellPaddingOuterLeft() Default outer left cell margin/padding.
short | getWCellPaddingOuterRight() Default outer right cell margin/padding.
short | getWCellPaddingOuterTop() Default outer top cell margin/padding.
short | getWCellSpacingDefaultBottom() Default bottom cell spacings.
short | getWCellSpacingDefaultLeft() Default left cell spacings.
short | getWCellSpacingDefaultRight() Default right cell spacings.
short | getWCellSpacingDefaultTop() Default top cell spacings.
short | getWCellSpacingOuterBottom() Default outer bottom cell spacing.
short | getWCellSpacingOuterLeft() Default outer left cell spacing.
short | getWCellSpacingOuterRight() Default outer right cell spacing.
short | getWCellSpacingOuterTop() Default outer top cell spacing.
byte | getWidthAndFitsFlags_empty1() Not used
short | getWidthAndFitsFlags_empty2() Not used
int | getWidthAndFitsFlags() Get the widthAndFitsFlags field for the TAP record.
short | getWWidth() Preferred table width.
short | getWWidthAfter() Width of invisible cell (used for layout purposes) after the last visible cell in the row..
short | getWWidthBefore() Width of invisible cell (used for layout purposes) before the first visible cell in the row..
short | getWWidthIndent() Left Indent.
boolean | isFAdjusted() Used internally by Word
boolean | isFAutofit() When set to 1, AutoFit this table
boolean | isFCellSpacing() Used internally by Word: When set to 1 cell spacing is allowed
boolean | isFFirstRow() Used internally by Word: first row
boolean | isFInvalAutofit() When 1, TAP is still valid, but autofit properties aren't
boolean | isFKeepFollow() When set to 1, keep this row with the following row
boolean | isFLastRow() Used internally by Word: last row
boolean | isFNeverBeenAutofit() When 1, table has never been autofit
boolean | isFNotPageView() Used internally by Word: when set to 1 we are not in Page View
boolean | isFOrigWordTableRules() Used internally by Word: table combining like Word 5.x for the Macintosh and WinWord 1.x
boolean | isFOutline() Used internally by Word: row was cached for outline mode
boolean | isFVert() When 1, positioned in vertical text flow
boolean | isFWebView() Used internally by Word: Web View is on when set to 1
boolean | isFWrapToWwd() Used internally by Word: Wrap to window is on when set to 1
boolean | isViewFlags_unused1() Not used
void | setBrcBottom(BorderCode field_36_brcBottom) Set the brcBottom field for the TAP record.
void | setBrcHorizontal(BorderCode field_41_brcHorizontal) Set the brcHorizontal field for the TAP record.
void | setBrcLeft(BorderCode field_38_brcLeft) Set the brcLeft field for the TAP record.
void | setBrcRight(BorderCode field_39_brcRight) Set the brcRight field for the TAP record.
void | setBrcTop(BorderCode field_37_brcTop) Set the brcTop field for the TAP record.
void | setBrcVertical(BorderCode field_40_brcVertical) Set the brcVertical field for the TAP record.
void | setCHorzBands(short field_78_cHorzBands) Size of each horizontal style band, in number of rows.
void | setCVertBands(short field_79_cVertBands) Size of a vertical style band, in number of columns.
void | setDxaAbs(int field_14_dxaAbs) Absolute horizontal position.
void | setDxaAdjust(int field_27_dxaAdjust) Used internally by Word.
void | setDxaColWidthWwd(int field_30_dxaColWidthWwd) Used internally by Word.
void | setDxaFromText(int field_16_dxaFromText) Left distance from surrounding text when absolutely positioned.
void | setDxaFromTextRight(int field_18_dxaFromTextRight) Right distance from surrounding text when absolutely positioned.
void | setDxaGapHalf(int field_3_dxaGapHalf) Measures half of the white space that will be maintained between text in adjacent columns of a table row.
void | setDxaRTEWrapWidth(int field_29_dxaRTEWrapWidth) Used internally by Word.
void | setDxaWebView(int field_28_dxaWebView) Used internally by Word.
void | setDyaAbs(int field_15_dyaAbs) Absolute vertical position.
void | setDyaFromText(int field_17_dyaFromText) Top distance from surrounding text when absolutely positioned.
void | setDyaFromTextBottom(int field_19_dyaFromTextBottom) Bottom distance from surrounding text when absolutely positioned.
void | setDyaRowHeight(int field_4_dyaRowHeight) When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high.
void | setFAdjusted(boolean value) Sets the fAdjusted field value.
void | setFAutofit(boolean value) Sets the fAutofit field value.
void | setFBiDi(byte field_20_fBiDi) When 1, table is right-to-left.
void | setFCantSplit(boolean field_5_fCantSplit) When 1, table row may not be split across page bounds.
void | setFCantSplit90(boolean field_6_fCantSplit90) When 1, table row may not be split across page bounds.
void | setFCellSpacing(boolean value) Sets the fCellSpacing field value.
void | setFFirstRow(boolean value) Sets the fFirstRow field value.
void | setFHasOldProps(byte field_77_fHasOldProps) Has old properties.
void | setFInvalAutofit(boolean value) Sets the fInvalAutofit field value.
void | setFKeepFollow(boolean value) Sets the fKeepFollow field value.
void | setFLastRow(boolean value) Sets the fLastRow field value.
void | setFNeverBeenAutofit(boolean value) Sets the fNeverBeenAutofit field value.
void | setFNoAllowOverlap(byte field_22_fNoAllowOverlap) When set to 1, do not allow absolutely positioned table to overlap with other tables.
void | setFNotPageView(boolean value) Sets the fNotPageView field value.
void | setFOrigWordTableRules(boolean value) Sets the fOrigWordTableRules field value.
void | setFOutline(boolean value) Sets the fOutline field value.
void | setFPropRMark(byte field_76_fPropRMark) Set to 1 if property revision.
void | setFRTL(byte field_21_fRTL) Word 2000 style right-to-left table.
void | setFSpare(byte field_23_fSpare) Not used.
void | setFTableHeader(boolean field_7_fTableHeader) When 1, table row is to be used as the header of the table.
void | setFtsCellPaddingDefaultBottom(byte field_48_ftsCellPaddingDefaultBottom) Default bottom cell margin/padding units.
void | setFtsCellPaddingDefaultLeft(byte field_47_ftsCellPaddingDefaultLeft) Default left cell margin/padding units.
void | setFtsCellPaddingDefaultRight(byte field_49_ftsCellPaddingDefaultRight) Default right cell margin/padding units.
void | setFtsCellPaddingDefaultTop(byte field_46_ftsCellPaddingDefaultTop) Default top cell margin/padding units.
void | setFtsCellPaddingOuterBottom(byte field_64_ftsCellPaddingOuterBottom) Default outer bottom cell margin/padding units.
void | setFtsCellPaddingOuterLeft(byte field_63_ftsCellPaddingOuterLeft) Default outer left cell margin/padding units.
void | setFtsCellPaddingOuterRight(byte field_65_ftsCellPaddingOuterRight) Default outer right cell margin/padding units.
void | setFtsCellPaddingOuterTop(byte field_62_ftsCellPaddingOuterTop) Default outer top cell margin/padding units.
void | setFtsCellSpacingDefaultBottom(byte field_56_ftsCellSpacingDefaultBottom) Default bottom cell spacings units.
void | setFtsCellSpacingDefaultLeft(byte field_55_ftsCellSpacingDefaultLeft) Default left cell spacings units.
void | setFtsCellSpacingDefaultRight(byte field_57_ftsCellSpacingDefaultRight) Default right cell spacings units.
void | setFtsCellSpacingDefaultTop(byte field_54_ftsCellSpacingDefaultTop) Default top cell spacings units.
void | setFtsCellSpacingOuterBottom(byte field_72_ftsCellSpacingOuterBottom) Default outer bottom cell spacings units.
void | setFtsCellSpacingOuterLeft(byte field_71_ftsCellSpacingOuterLeft) Default outer left cell spacings units.
void | setFtsCellSpacingOuterRight(byte field_73_ftsCellSpacingOuterRight) Default outer right cell spacings units.
void | setFtsCellSpacingOuterTop(byte field_70_ftsCellSpacingOuterTop) Default outer top cell spacings units.
void | setFtsWidth(byte value) Sets the ftsWidth field value.
void | setFtsWidthAfter(byte value) Sets the ftsWidthAfter field value.
void | setFtsWidthBefore(byte value) Sets the ftsWidthBefore field value.
void | setFtsWidthIndent(byte value) Sets the ftsWidthIndent field value.
void | setFVert(boolean value) Sets the fVert field value.
void | setFWebView(boolean value) Sets the fWebView field value.
void | setFWrapToWwd(boolean value) Sets the fWrapToWwd field value.
void | setGrpfTap_unused(short value) Sets the grpfTap_unused field value.
void | setGrpfTap(int field_24_grpfTap) Used internally by Word.
void | setInternalFlags(int field_25_internalFlags) Used internally by Word.
void | setIstd(short field_1_istd) Table style for the Table.
void | setItcMac(short field_26_itcMac) Count of cells defined for this row.
void | setJc(short field_2_jc) Justification code.
void | setPcHorz(byte value) Sets the pcHorz field value.
void | setPctWwd(short field_31_pctWwd) Used internally by Word: percent of Window size for AutoFit in WebView.
void | setPcVert(byte value) Sets the pcVert field value.
void | setRgbrcInsideDefault_0(BorderCode field_80_rgbrcInsideDefault_0) Border definition for inside horizontal borders.
void | setRgbrcInsideDefault_1(BorderCode field_81_rgbrcInsideDefault_1) Border definition for inside vertical borders.
void | setRgdxaCenter(short[] field_33_rgdxaCenter) rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..
void | setRgdxaCenterPrint(short[] field_34_rgdxaCenterPrint) Used internally by Word.
void | setRgshd(ShadingDescriptor[] field_75_rgshd) Set the rgshd field for the TAP record.
void | setRgtc(TableCellDescriptor[] field_74_rgtc) Set the rgtc field for the TAP record.
void | setShdTable(ShadingDescriptor field_35_shdTable) Table shading.
void | setTlp(TableAutoformatLookSpecifier field_8_tlp) Table look specifier.
void | setViewFlags_unused1(boolean value) Sets the viewFlags_unused1 field value.
void | setViewFlags_unused2(short value) Sets the viewFlags_unused2 field value.
void | setViewFlags(int field_32_viewFlags) Used internally by Word.
void | setWCellPaddingDefaultBottom(short field_44_wCellPaddingDefaultBottom) Default bottom cell margin/padding.
void | setWCellPaddingDefaultLeft(short field_43_wCellPaddingDefaultLeft) Default left cell margin/padding.
void | setWCellPaddingDefaultRight(short field_45_wCellPaddingDefaultRight) Default right cell margin/padding.
void | setWCellPaddingDefaultTop(short field_42_wCellPaddingDefaultTop) Default top cell margin/padding.
void | setWCellPaddingOuterBottom(short field_60_wCellPaddingOuterBottom) Default outer bottom cell margin/padding.
void | setWCellPaddingOuterLeft(short field_59_wCellPaddingOuterLeft) Default outer left cell margin/padding.
void | setWCellPaddingOuterRight(short field_61_wCellPaddingOuterRight) Default outer right cell margin/padding.
void | setWCellPaddingOuterTop(short field_58_wCellPaddingOuterTop) Default outer top cell margin/padding.
void | setWCellSpacingDefaultBottom(short field_52_wCellSpacingDefaultBottom) Default bottom cell spacings.
void | setWCellSpacingDefaultLeft(short field_51_wCellSpacingDefaultLeft) Default left cell spacings.
void | setWCellSpacingDefaultRight(short field_53_wCellSpacingDefaultRight) Default right cell spacings.
void | setWCellSpacingDefaultTop(short field_50_wCellSpacingDefaultTop) Default top cell spacings.
void | setWCellSpacingOuterBottom(short field_68_wCellSpacingOuterBottom) Default outer bottom cell spacing.
void | setWCellSpacingOuterLeft(short field_67_wCellSpacingOuterLeft) Default outer left cell spacing.
void | setWCellSpacingOuterRight(short field_69_wCellSpacingOuterRight) Default outer right cell spacing.
void | setWCellSpacingOuterTop(short field_66_wCellSpacingOuterTop) Default outer top cell spacing.
void | setWidthAndFitsFlags_empty1(byte value) Sets the widthAndFitsFlags_empty1 field value.
void | setWidthAndFitsFlags_empty2(short value) Sets the widthAndFitsFlags_empty2 field value.
void | setWidthAndFitsFlags(int field_13_widthAndFitsFlags) Set the widthAndFitsFlags field for the TAP record.
void | setWWidth(short field_9_wWidth) Preferred table width.
void | setWWidthAfter(short field_12_wWidthAfter) Width of invisible cell (used for layout purposes) after the last visible cell in the row..
void | setWWidthBefore(short field_11_wWidthBefore) Width of invisible cell (used for layout purposes) before the first visible cell in the row..
void | setWWidthIndent(short field_10_wWidthIndent) Left Indent.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_istd

protected short field_1_istd

field_2_jc

protected short field_2_jc

field_3_dxaGapHalf

protected int field_3_dxaGapHalf

field_4_dyaRowHeight

protected int field_4_dyaRowHeight

field_5_fCantSplit

protected boolean field_5_fCantSplit

field_6_fCantSplit90

protected boolean field_6_fCantSplit90

field_7_fTableHeader

protected boolean field_7_fTableHeader

field_8_tlp

protected TableAutoformatLookSpecifier field_8_tlp

field_9_wWidth

protected short field_9_wWidth

field_10_wWidthIndent

protected short field_10_wWidthIndent

field_11_wWidthBefore

protected short field_11_wWidthBefore

field_12_wWidthAfter

protected short field_12_wWidthAfter

field_13_widthAndFitsFlags

protected int field_13_widthAndFitsFlags

field_14_dxaAbs

protected int field_14_dxaAbs

field_15_dyaAbs

protected int field_15_dyaAbs

field_16_dxaFromText

protected int field_16_dxaFromText

field_17_dyaFromText

protected int field_17_dyaFromText

field_18_dxaFromTextRight

protected int field_18_dxaFromTextRight

field_19_dyaFromTextBottom

protected int field_19_dyaFromTextBottom

field_20_fBiDi

protected byte field_20_fBiDi

field_21_fRTL

protected byte field_21_fRTL

field_22_fNoAllowOverlap

protected byte field_22_fNoAllowOverlap

field_23_fSpare

protected byte field_23_fSpare

field_24_grpfTap

protected int field_24_grpfTap

field_25_internalFlags

protected int field_25_internalFlags

field_26_itcMac

protected short field_26_itcMac

field_27_dxaAdjust

protected int field_27_dxaAdjust

field_28_dxaWebView

protected int field_28_dxaWebView

field_29_dxaRTEWrapWidth

protected int field_29_dxaRTEWrapWidth

field_30_dxaColWidthWwd

protected int field_30_dxaColWidthWwd

field_31_pctWwd

protected short field_31_pctWwd

field_32_viewFlags

protected int field_32_viewFlags

field_33_rgdxaCenter

protected short[] field_33_rgdxaCenter

field_34_rgdxaCenterPrint

protected short[] field_34_rgdxaCenterPrint

field_35_shdTable

protected ShadingDescriptor field_35_shdTable

field_36_brcBottom

protected BorderCode field_36_brcBottom

field_37_brcTop

protected BorderCode field_37_brcTop

field_38_brcLeft

protected BorderCode field_38_brcLeft

field_39_brcRight

protected BorderCode field_39_brcRight

field_40_brcVertical

protected BorderCode field_40_brcVertical

field_41_brcHorizontal

protected BorderCode field_41_brcHorizontal

field_42_wCellPaddingDefaultTop

protected short field_42_wCellPaddingDefaultTop

field_43_wCellPaddingDefaultLeft

protected short field_43_wCellPaddingDefaultLeft

field_44_wCellPaddingDefaultBottom

protected short field_44_wCellPaddingDefaultBottom

field_45_wCellPaddingDefaultRight

protected short field_45_wCellPaddingDefaultRight

field_46_ftsCellPaddingDefaultTop

protected byte field_46_ftsCellPaddingDefaultTop

field_47_ftsCellPaddingDefaultLeft

protected byte field_47_ftsCellPaddingDefaultLeft

field_48_ftsCellPaddingDefaultBottom

protected byte field_48_ftsCellPaddingDefaultBottom

field_49_ftsCellPaddingDefaultRight

protected byte field_49_ftsCellPaddingDefaultRight

field_50_wCellSpacingDefaultTop

protected short field_50_wCellSpacingDefaultTop

field_51_wCellSpacingDefaultLeft

protected short field_51_wCellSpacingDefaultLeft

field_52_wCellSpacingDefaultBottom

protected short field_52_wCellSpacingDefaultBottom

field_53_wCellSpacingDefaultRight

protected short field_53_wCellSpacingDefaultRight

field_54_ftsCellSpacingDefaultTop

protected byte field_54_ftsCellSpacingDefaultTop

field_55_ftsCellSpacingDefaultLeft

protected byte field_55_ftsCellSpacingDefaultLeft

field_56_ftsCellSpacingDefaultBottom

protected byte field_56_ftsCellSpacingDefaultBottom

field_57_ftsCellSpacingDefaultRight

protected byte field_57_ftsCellSpacingDefaultRight

field_58_wCellPaddingOuterTop

protected short field_58_wCellPaddingOuterTop

field_59_wCellPaddingOuterLeft

protected short field_59_wCellPaddingOuterLeft

field_60_wCellPaddingOuterBottom

protected short field_60_wCellPaddingOuterBottom

field_61_wCellPaddingOuterRight

protected short field_61_wCellPaddingOuterRight

field_62_ftsCellPaddingOuterTop

protected byte field_62_ftsCellPaddingOuterTop

field_63_ftsCellPaddingOuterLeft

protected byte field_63_ftsCellPaddingOuterLeft

field_64_ftsCellPaddingOuterBottom

protected byte field_64_ftsCellPaddingOuterBottom

field_65_ftsCellPaddingOuterRight

protected byte field_65_ftsCellPaddingOuterRight

field_66_wCellSpacingOuterTop

protected short field_66_wCellSpacingOuterTop

field_67_wCellSpacingOuterLeft

protected short field_67_wCellSpacingOuterLeft

field_68_wCellSpacingOuterBottom

protected short field_68_wCellSpacingOuterBottom

field_69_wCellSpacingOuterRight

protected short field_69_wCellSpacingOuterRight

field_70_ftsCellSpacingOuterTop

protected byte field_70_ftsCellSpacingOuterTop

field_71_ftsCellSpacingOuterLeft

protected byte field_71_ftsCellSpacingOuterLeft

field_72_ftsCellSpacingOuterBottom

protected byte field_72_ftsCellSpacingOuterBottom

field_73_ftsCellSpacingOuterRight

protected byte field_73_ftsCellSpacingOuterRight

field_74_rgtc

protected TableCellDescriptor[] field_74_rgtc

field_75_rgshd

protected ShadingDescriptor[] field_75_rgshd

field_76_fPropRMark

protected byte field_76_fPropRMark

field_77_fHasOldProps

protected byte field_77_fHasOldProps

field_78_cHorzBands

protected short field_78_cHorzBands

field_79_cVertBands

protected short field_79_cVertBands

field_80_rgbrcInsideDefault_0

protected BorderCode field_80_rgbrcInsideDefault_0

field_81_rgbrcInsideDefault_1

protected BorderCode field_81_rgbrcInsideDefault_1
Constructor Detail

TAPAbstractType

protected TAPAbstractType()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getIstd

@Internal
public short getIstd()
Table style for the Table.

setIstd

@Internal
public void setIstd(short field_1_istd)
Table style for the Table.

getJc

@Internal
public short getJc()
Justification code. specifies how table row should be justified within its column. 0 -- left justify, 1 -- center, 2 -- right justify.

setJc

@Internal
public void setJc(short field_2_jc)
Justification code. specifies how table row should be justified within its column. 0 -- left justify, 1 -- center, 2 -- right justify.

getDxaGapHalf

@Internal
public int getDxaGapHalf()
Measures half of the white space that will be maintained between text in adjacent columns of a table row. A dxaGapHalf width of white space will be maintained on both sides of a column boundary..

setDxaGapHalf

@Internal
public void setDxaGapHalf(int field_3_dxaGapHalf)
Measures half of the white space that will be maintained between text in adjacent columns of a table row. A dxaGapHalf width of white space will be maintained on both sides of a column boundary..

getDyaRowHeight

@Internal
public int getDyaRowHeight()
When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high. When less than 0, guarantees that the height of the table will be exactly absolute value of dyaRowHeight high. When 0, table will be given a height large enough to represent all of the text in all of the cells of the table. Cells with vertical text flow make no contribution to the computation of the height of rows with auto or at least height. Neither do vertically merged cells, except in the last row of the vertical merge. If an auto height row consists entirely of cells which have vertical text direction or are vertically merged, and the row does not contain the last cell in any vertical cell merge, then the row is given height equal to that of the end of cell mark in the first cell..

setDyaRowHeight

@Internal
public void setDyaRowHeight(int field_4_dyaRowHeight)
When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high. When less than 0, guarantees that the height of the table will be exactly absolute value of dyaRowHeight high. When 0, table will be given a height large enough to represent all of the text in all of the cells of the table. Cells with vertical text flow make no contribution to the computation of the height of rows with auto or at least height. Neither do vertically merged cells, except in the last row of the vertical merge. If an auto height row consists entirely of cells which have vertical text direction or are vertically merged, and the row does not contain the last cell in any vertical cell merge, then the row is given height equal to that of the end of cell mark in the first cell..

getFCantSplit

@Internal
public boolean getFCantSplit()
When 1, table row may not be split across page bounds.

setFCantSplit

@Internal
public void setFCantSplit(boolean field_5_fCantSplit)
When 1, table row may not be split across page bounds.

getFCantSplit90

@Internal
public boolean getFCantSplit90()
When 1, table row may not be split across page bounds. Used for Word 2000 and Word 97..

setFCantSplit90

@Internal
public void setFCantSplit90(boolean field_6_fCantSplit90)
When 1, table row may not be split across page bounds. Used for Word 2000 and Word 97..

getFTableHeader

@Internal
public boolean getFTableHeader()
When 1, table row is to be used as the header of the table.

setFTableHeader

@Internal
public void setFTableHeader(boolean field_7_fTableHeader)
When 1, table row is to be used as the header of the table.

getTlp

@Internal
public TableAutoformatLookSpecifier getTlp()
Table look specifier.

setTlp

@Internal
public void setTlp(TableAutoformatLookSpecifier field_8_tlp)
Table look specifier.

getWWidth

@Internal
public short getWWidth()
Preferred table width.

setWWidth

@Internal
public void setWWidth(short field_9_wWidth)
Preferred table width.

getWWidthIndent

@Internal
public short getWWidthIndent()
Left Indent.

setWWidthIndent

@Internal
public void setWWidthIndent(short field_10_wWidthIndent)
Left Indent.

getWWidthBefore

@Internal
public short getWWidthBefore()
Width of invisible cell (used for layout purposes) before the first visible cell in the row..

setWWidthBefore

@Internal
public void setWWidthBefore(short field_11_wWidthBefore)
Width of invisible cell (used for layout purposes) before the first visible cell in the row..

getWWidthAfter

@Internal
public short getWWidthAfter()
Width of invisible cell (used for layout purposes) after the last visible cell in the row..

setWWidthAfter

@Internal
public void setWWidthAfter(short field_12_wWidthAfter)
Width of invisible cell (used for layout purposes) after the last visible cell in the row..

getWidthAndFitsFlags

@Internal
public int getWidthAndFitsFlags()
Get the widthAndFitsFlags field for the TAP record.

setWidthAndFitsFlags

@Internal
public void setWidthAndFitsFlags(int field_13_widthAndFitsFlags)
Set the widthAndFitsFlags field for the TAP record.

getDxaAbs

@Internal
public int getDxaAbs()
Absolute horizontal position.

setDxaAbs

@Internal
public void setDxaAbs(int field_14_dxaAbs)
Absolute horizontal position.

getDyaAbs

@Internal
public int getDyaAbs()
Absolute vertical position.

setDyaAbs

@Internal
public void setDyaAbs(int field_15_dyaAbs)
Absolute vertical position.

getDxaFromText

@Internal
public int getDxaFromText()
Left distance from surrounding text when absolutely positioned.

setDxaFromText

@Internal
public void setDxaFromText(int field_16_dxaFromText)
Left distance from surrounding text when absolutely positioned.

getDyaFromText

@Internal
public int getDyaFromText()
Top distance from surrounding text when absolutely positioned.

setDyaFromText

@Internal
public void setDyaFromText(int field_17_dyaFromText)
Top distance from surrounding text when absolutely positioned.

getDxaFromTextRight

@Internal
public int getDxaFromTextRight()
Right distance from surrounding text when absolutely positioned.

setDxaFromTextRight

@Internal
public void setDxaFromTextRight(int field_18_dxaFromTextRight)
Right distance from surrounding text when absolutely positioned.

getDyaFromTextBottom

@Internal
public int getDyaFromTextBottom()
Bottom distance from surrounding text when absolutely positioned.

setDyaFromTextBottom

@Internal
public void setDyaFromTextBottom(int field_19_dyaFromTextBottom)
Bottom distance from surrounding text when absolutely positioned.

getFBiDi

@Internal
public byte getFBiDi()
When 1, table is right-to-left. Logical right-to-left table: The CP stream of a right-to-left table is meant to be displayed from right to left. So for example the first table cell is displayed on the right side of the table instead of the left..

setFBiDi

@Internal
public void setFBiDi(byte field_20_fBiDi)
When 1, table is right-to-left. Logical right-to-left table: The CP stream of a right-to-left table is meant to be displayed from right to left. So for example the first table cell is displayed on the right side of the table instead of the left..

getFRTL

@Internal
public byte getFRTL()
Word 2000 style right-to-left table. Visual right-to-left table: The CP stream of a right-to-left table is displayed from left to right just as for a normal table. So, the text which is meant to be in the first (rightmost) table cell must be placed in the last table cell in the CP stream..

setFRTL

@Internal
public void setFRTL(byte field_21_fRTL)
Word 2000 style right-to-left table. Visual right-to-left table: The CP stream of a right-to-left table is displayed from left to right just as for a normal table. So, the text which is meant to be in the first (rightmost) table cell must be placed in the last table cell in the CP stream..

getFNoAllowOverlap

@Internal
public byte getFNoAllowOverlap()
When set to 1, do not allow absolutely positioned table to overlap with other tables.

setFNoAllowOverlap

@Internal
public void setFNoAllowOverlap(byte field_22_fNoAllowOverlap)
When set to 1, do not allow absolutely positioned table to overlap with other tables.

getFSpare

@Internal
public byte getFSpare()
Not used.

setFSpare

@Internal
public void setFSpare(byte field_23_fSpare)
Not used.

getGrpfTap

@Internal
public int getGrpfTap()
Used internally by Word.

setGrpfTap

@Internal
public void setGrpfTap(int field_24_grpfTap)
Used internally by Word.

getInternalFlags

@Internal
public int getInternalFlags()
Used internally by Word.

setInternalFlags

@Internal
public void setInternalFlags(int field_25_internalFlags)
Used internally by Word.

getItcMac

@Internal
public short getItcMac()
Count of cells defined for this row. itcMac must be >= 0 and less than or equal to 64..

setItcMac

@Internal
public void setItcMac(short field_26_itcMac)
Count of cells defined for this row. itcMac must be >= 0 and less than or equal to 64..

getDxaAdjust

@Internal
public int getDxaAdjust()
Used internally by Word.

setDxaAdjust

@Internal
public void setDxaAdjust(int field_27_dxaAdjust)
Used internally by Word.

getDxaWebView

@Internal
public int getDxaWebView()
Used internally by Word.

setDxaWebView

@Internal
public void setDxaWebView(int field_28_dxaWebView)
Used internally by Word.

getDxaRTEWrapWidth

@Internal
public int getDxaRTEWrapWidth()
Used internally by Word.

setDxaRTEWrapWidth

@Internal
public void setDxaRTEWrapWidth(int field_29_dxaRTEWrapWidth)
Used internally by Word.

getDxaColWidthWwd

@Internal
public int getDxaColWidthWwd()
Used internally by Word.

setDxaColWidthWwd

@Internal
public void setDxaColWidthWwd(int field_30_dxaColWidthWwd)
Used internally by Word.

getPctWwd

@Internal
public short getPctWwd()
Used internally by Word: percent of Window size for AutoFit in WebView.

setPctWwd

@Internal
public void setPctWwd(short field_31_pctWwd)
Used internally by Word: percent of Window size for AutoFit in WebView.

getViewFlags

@Internal
public int getViewFlags()
Used internally by Word.

setViewFlags

@Internal
public void setViewFlags(int field_32_viewFlags)
Used internally by Word.

getRgdxaCenter

@Internal
public short[] getRgdxaCenter()
rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..

setRgdxaCenter

@Internal
public void setRgdxaCenter(short[] field_33_rgdxaCenter)
rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..

getRgdxaCenterPrint

@Internal
public short[] getRgdxaCenterPrint()
Used internally by Word.

setRgdxaCenterPrint

@Internal
public void setRgdxaCenterPrint(short[] field_34_rgdxaCenterPrint)
Used internally by Word.

getShdTable

@Internal
public ShadingDescriptor getShdTable()
Table shading.

setShdTable

@Internal
public void setShdTable(ShadingDescriptor field_35_shdTable)
Table shading.

getBrcBottom

@Internal
public BorderCode getBrcBottom()
Get the brcBottom field for the TAP record.

setBrcBottom

@Internal
public void setBrcBottom(BorderCode field_36_brcBottom)
Set the brcBottom field for the TAP record.

getBrcTop

@Internal
public BorderCode getBrcTop()
Get the brcTop field for the TAP record.

setBrcTop

@Internal
public void setBrcTop(BorderCode field_37_brcTop)
Set the brcTop field for the TAP record.

getBrcLeft

@Internal
public BorderCode getBrcLeft()
Get the brcLeft field for the TAP record.

setBrcLeft

@Internal
public void setBrcLeft(BorderCode field_38_brcLeft)
Set the brcLeft field for the TAP record.

getBrcRight

@Internal
public BorderCode getBrcRight()
Get the brcRight field for the TAP record.

setBrcRight

@Internal
public void setBrcRight(BorderCode field_39_brcRight)
Set the brcRight field for the TAP record.

getBrcVertical

@Internal
public BorderCode getBrcVertical()
Get the brcVertical field for the TAP record.

setBrcVertical

@Internal
public void setBrcVertical(BorderCode field_40_brcVertical)
Set the brcVertical field for the TAP record.

getBrcHorizontal

@Internal
public BorderCode getBrcHorizontal()
Get the brcHorizontal field for the TAP record.

setBrcHorizontal

@Internal
public void setBrcHorizontal(BorderCode field_41_brcHorizontal)
Set the brcHorizontal field for the TAP record.

getWCellPaddingDefaultTop

@Internal
public short getWCellPaddingDefaultTop()
Default top cell margin/padding.

setWCellPaddingDefaultTop

@Internal
public void setWCellPaddingDefaultTop(short field_42_wCellPaddingDefaultTop)
Default top cell margin/padding.

getWCellPaddingDefaultLeft

@Internal
public short getWCellPaddingDefaultLeft()
Default left cell margin/padding.

setWCellPaddingDefaultLeft

@Internal
public void setWCellPaddingDefaultLeft(short field_43_wCellPaddingDefaultLeft)
Default left cell margin/padding.

getWCellPaddingDefaultBottom

@Internal
public short getWCellPaddingDefaultBottom()
Default bottom cell margin/padding.

setWCellPaddingDefaultBottom

@Internal
public void setWCellPaddingDefaultBottom(short field_44_wCellPaddingDefaultBottom)
Default bottom cell margin/padding.

getWCellPaddingDefaultRight

@Internal
public short getWCellPaddingDefaultRight()
Default right cell margin/padding.

setWCellPaddingDefaultRight

@Internal
public void setWCellPaddingDefaultRight(short field_45_wCellPaddingDefaultRight)
Default right cell margin/padding.

getFtsCellPaddingDefaultTop

@Internal
public byte getFtsCellPaddingDefaultTop()
Default top cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingDefaultTop

@Internal
public void setFtsCellPaddingDefaultTop(byte field_46_ftsCellPaddingDefaultTop)
Default top cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellPaddingDefaultLeft

@Internal
public byte getFtsCellPaddingDefaultLeft()
Default left cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingDefaultLeft

@Internal
public void setFtsCellPaddingDefaultLeft(byte field_47_ftsCellPaddingDefaultLeft)
Default left cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellPaddingDefaultBottom

@Internal
public byte getFtsCellPaddingDefaultBottom()
Default bottom cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingDefaultBottom

@Internal
public void setFtsCellPaddingDefaultBottom(byte field_48_ftsCellPaddingDefaultBottom)
Default bottom cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellPaddingDefaultRight

@Internal
public byte getFtsCellPaddingDefaultRight()
Default right cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingDefaultRight

@Internal
public void setFtsCellPaddingDefaultRight(byte field_49_ftsCellPaddingDefaultRight)
Default right cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getWCellSpacingDefaultTop

@Internal
public short getWCellSpacingDefaultTop()
Default top cell spacings.

setWCellSpacingDefaultTop

@Internal
public void setWCellSpacingDefaultTop(short field_50_wCellSpacingDefaultTop)
Default top cell spacings.

getWCellSpacingDefaultLeft

@Internal
public short getWCellSpacingDefaultLeft()
Default left cell spacings.

setWCellSpacingDefaultLeft

@Internal
public void setWCellSpacingDefaultLeft(short field_51_wCellSpacingDefaultLeft)
Default left cell spacings.

getWCellSpacingDefaultBottom

@Internal
public short getWCellSpacingDefaultBottom()
Default bottom cell spacings.

setWCellSpacingDefaultBottom

@Internal
public void setWCellSpacingDefaultBottom(short field_52_wCellSpacingDefaultBottom)
Default bottom cell spacings.

getWCellSpacingDefaultRight

@Internal
public short getWCellSpacingDefaultRight()
Default right cell spacings.

setWCellSpacingDefaultRight

@Internal
public void setWCellSpacingDefaultRight(short field_53_wCellSpacingDefaultRight)
Default right cell spacings.

getFtsCellSpacingDefaultTop

@Internal
public byte getFtsCellSpacingDefaultTop()
Default top cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingDefaultTop

@Internal
public void setFtsCellSpacingDefaultTop(byte field_54_ftsCellSpacingDefaultTop)
Default top cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellSpacingDefaultLeft

@Internal
public byte getFtsCellSpacingDefaultLeft()
Default left cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingDefaultLeft

@Internal
public void setFtsCellSpacingDefaultLeft(byte field_55_ftsCellSpacingDefaultLeft)
Default left cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellSpacingDefaultBottom

@Internal
public byte getFtsCellSpacingDefaultBottom()
Default bottom cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingDefaultBottom

@Internal
public void setFtsCellSpacingDefaultBottom(byte field_56_ftsCellSpacingDefaultBottom)
Default bottom cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellSpacingDefaultRight

@Internal
public byte getFtsCellSpacingDefaultRight()
Default right cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingDefaultRight

@Internal
public void setFtsCellSpacingDefaultRight(byte field_57_ftsCellSpacingDefaultRight)
Default right cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getWCellPaddingOuterTop

@Internal
public short getWCellPaddingOuterTop()
Default outer top cell margin/padding.

setWCellPaddingOuterTop

@Internal
public void setWCellPaddingOuterTop(short field_58_wCellPaddingOuterTop)
Default outer top cell margin/padding.

getWCellPaddingOuterLeft

@Internal
public short getWCellPaddingOuterLeft()
Default outer left cell margin/padding.

setWCellPaddingOuterLeft

@Internal
public void setWCellPaddingOuterLeft(short field_59_wCellPaddingOuterLeft)
Default outer left cell margin/padding.

getWCellPaddingOuterBottom

@Internal
public short getWCellPaddingOuterBottom()
Default outer bottom cell margin/padding.

setWCellPaddingOuterBottom

@Internal
public void setWCellPaddingOuterBottom(short field_60_wCellPaddingOuterBottom)
Default outer bottom cell margin/padding.

getWCellPaddingOuterRight

@Internal
public short getWCellPaddingOuterRight()
Default outer right cell margin/padding.

setWCellPaddingOuterRight

@Internal
public void setWCellPaddingOuterRight(short field_61_wCellPaddingOuterRight)
Default outer right cell margin/padding.

getFtsCellPaddingOuterTop

@Internal
public byte getFtsCellPaddingOuterTop()
Default outer top cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingOuterTop

@Internal
public void setFtsCellPaddingOuterTop(byte field_62_ftsCellPaddingOuterTop)
Default outer top cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellPaddingOuterLeft

@Internal
public byte getFtsCellPaddingOuterLeft()
Default outer left cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingOuterLeft

@Internal
public void setFtsCellPaddingOuterLeft(byte field_63_ftsCellPaddingOuterLeft)
Default outer left cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellPaddingOuterBottom

@Internal
public byte getFtsCellPaddingOuterBottom()
Default outer bottom cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingOuterBottom

@Internal
public void setFtsCellPaddingOuterBottom(byte field_64_ftsCellPaddingOuterBottom)
Default outer bottom cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellPaddingOuterRight

@Internal
public byte getFtsCellPaddingOuterRight()
Default outer right cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellPaddingOuterRight

@Internal
public void setFtsCellPaddingOuterRight(byte field_65_ftsCellPaddingOuterRight)
Default outer right cell margin/padding units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getWCellSpacingOuterTop

@Internal
public short getWCellSpacingOuterTop()
Default outer top cell spacing.

setWCellSpacingOuterTop

@Internal
public void setWCellSpacingOuterTop(short field_66_wCellSpacingOuterTop)
Default outer top cell spacing.

getWCellSpacingOuterLeft

@Internal
public short getWCellSpacingOuterLeft()
Default outer left cell spacing.

setWCellSpacingOuterLeft

@Internal
public void setWCellSpacingOuterLeft(short field_67_wCellSpacingOuterLeft)
Default outer left cell spacing.

getWCellSpacingOuterBottom

@Internal
public short getWCellSpacingOuterBottom()
Default outer bottom cell spacing.

setWCellSpacingOuterBottom

@Internal
public void setWCellSpacingOuterBottom(short field_68_wCellSpacingOuterBottom)
Default outer bottom cell spacing.

getWCellSpacingOuterRight

@Internal
public short getWCellSpacingOuterRight()
Default outer right cell spacing.

setWCellSpacingOuterRight

@Internal
public void setWCellSpacingOuterRight(short field_69_wCellSpacingOuterRight)
Default outer right cell spacing.

getFtsCellSpacingOuterTop

@Internal
public byte getFtsCellSpacingOuterTop()
Default outer top cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingOuterTop

@Internal
public void setFtsCellSpacingOuterTop(byte field_70_ftsCellSpacingOuterTop)
Default outer top cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellSpacingOuterLeft

@Internal
public byte getFtsCellSpacingOuterLeft()
Default outer left cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingOuterLeft

@Internal
public void setFtsCellSpacingOuterLeft(byte field_71_ftsCellSpacingOuterLeft)
Default outer left cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellSpacingOuterBottom

@Internal
public byte getFtsCellSpacingOuterBottom()
Default outer bottom cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingOuterBottom

@Internal
public void setFtsCellSpacingOuterBottom(byte field_72_ftsCellSpacingOuterBottom)
Default outer bottom cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getFtsCellSpacingOuterRight

@Internal
public byte getFtsCellSpacingOuterRight()
Default outer right cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

setFtsCellSpacingOuterRight

@Internal
public void setFtsCellSpacingOuterRight(byte field_73_ftsCellSpacingOuterRight)
Default outer right cell spacings units. 0 -- null; 1-2 -- not relevant; 3 -- twips..

getRgtc

@Internal
public TableCellDescriptor[] getRgtc()
Get the rgtc field for the TAP record.

setRgtc

@Internal
public void setRgtc(TableCellDescriptor[] field_74_rgtc)
Set the rgtc field for the TAP record.

getRgshd

@Internal
public ShadingDescriptor[] getRgshd()
Get the rgshd field for the TAP record.

setRgshd

@Internal
public void setRgshd(ShadingDescriptor[] field_75_rgshd)
Set the rgshd field for the TAP record.

getFPropRMark

@Internal
public byte getFPropRMark()
Set to 1 if property revision.

setFPropRMark

@Internal
public void setFPropRMark(byte field_76_fPropRMark)
Set to 1 if property revision.

getFHasOldProps

@Internal
public byte getFHasOldProps()
Has old properties.

setFHasOldProps

@Internal
public void setFHasOldProps(byte field_77_fHasOldProps)
Has old properties.

getCHorzBands

@Internal
public short getCHorzBands()
Size of each horizontal style band, in number of rows.

setCHorzBands

@Internal
public void setCHorzBands(short field_78_cHorzBands)
Size of each horizontal style band, in number of rows.

getCVertBands

@Internal
public short getCVertBands()
Size of a vertical style band, in number of columns.

setCVertBands

@Internal
public void setCVertBands(short field_79_cVertBands)
Size of a vertical style band, in number of columns.

getRgbrcInsideDefault_0

@Internal
public BorderCode getRgbrcInsideDefault_0()
Border definition for inside horizontal borders.

setRgbrcInsideDefault_0

@Internal
public void setRgbrcInsideDefault_0(BorderCode field_80_rgbrcInsideDefault_0)
Border definition for inside horizontal borders.

getRgbrcInsideDefault_1

@Internal
public BorderCode getRgbrcInsideDefault_1()
Border definition for inside vertical borders.

setRgbrcInsideDefault_1

@Internal
public void setRgbrcInsideDefault_1(BorderCode field_81_rgbrcInsideDefault_1)
Border definition for inside vertical borders.

setFAutofit

@Internal
public void setFAutofit(boolean value)
Sets the fAutofit field value. When set to 1, AutoFit this table

isFAutofit

@Internal
public boolean isFAutofit()
When set to 1, AutoFit this table

Returns:
the fAutofit field value.

setFKeepFollow

@Internal
public void setFKeepFollow(boolean value)
Sets the fKeepFollow field value. When set to 1, keep this row with the following row

isFKeepFollow

@Internal
public boolean isFKeepFollow()
When set to 1, keep this row with the following row

Returns:
the fKeepFollow field value.

setFtsWidth

@Internal
public void setFtsWidth(byte value)
Sets the ftsWidth field value. Units for wWidth: 0 -- null; 1 -- auto, ignores wWidth, 2 -- percentage (in 50ths of a percent), 3 -- twips

getFtsWidth

@Internal
public byte getFtsWidth()
Units for wWidth: 0 -- null; 1 -- auto, ignores wWidth, 2 -- percentage (in 50ths of a percent), 3 -- twips

Returns:
the ftsWidth field value.

setFtsWidthIndent

@Internal
public void setFtsWidthIndent(byte value)
Sets the ftsWidthIndent field value. Units for wWidthIndent: 0 -- null; 1 -- auto, ignores wWidthIndent, 2 -- percentage (in 50ths of a percent), 3 -- twips

getFtsWidthIndent

@Internal
public byte getFtsWidthIndent()
Units for wWidthIndent: 0 -- null; 1 -- auto, ignores wWidthIndent, 2 -- percentage (in 50ths of a percent), 3 -- twips

Returns:
the ftsWidthIndent field value.

setFtsWidthBefore

@Internal
public void setFtsWidthBefore(byte value)
Sets the ftsWidthBefore field value. Units for wWidthBefore: 0 -- null; 1 -- auto, ignores wWidthBefore, 2 -- percentage (in 50ths of a percent), 3 -- twips

getFtsWidthBefore

@Internal
public byte getFtsWidthBefore()
Units for wWidthBefore: 0 -- null; 1 -- auto, ignores wWidthBefore, 2 -- percentage (in 50ths of a percent), 3 -- twips

Returns:
the ftsWidthBefore field value.

setFtsWidthAfter

@Internal
public void setFtsWidthAfter(byte value)
Sets the ftsWidthAfter field value. Units for wWidthAfter: 0 -- null; 1 -- auto, ignores wWidthAfter, 2 -- percentage (in 50ths of a percent), 3 -- twips

getFtsWidthAfter

@Internal
public byte getFtsWidthAfter()
Units for wWidthAfter: 0 -- null; 1 -- auto, ignores wWidthAfter, 2 -- percentage (in 50ths of a percent), 3 -- twips

Returns:
the ftsWidthAfter field value.

setFNeverBeenAutofit

@Internal
public void setFNeverBeenAutofit(boolean value)
Sets the fNeverBeenAutofit field value. When 1, table has never been autofit

isFNeverBeenAutofit

@Internal
public boolean isFNeverBeenAutofit()
When 1, table has never been autofit

Returns:
the fNeverBeenAutofit field value.

setFInvalAutofit

@Internal
public void setFInvalAutofit(boolean value)
Sets the fInvalAutofit field value. When 1, TAP is still valid, but autofit properties aren't

isFInvalAutofit

@Internal
public boolean isFInvalAutofit()
When 1, TAP is still valid, but autofit properties aren't

Returns:
the fInvalAutofit field value.

setWidthAndFitsFlags_empty1

@Internal
public void setWidthAndFitsFlags_empty1(byte value)
Sets the widthAndFitsFlags_empty1 field value. Not used

getWidthAndFitsFlags_empty1

@Internal
public byte getWidthAndFitsFlags_empty1()
Not used

Returns:
the widthAndFitsFlags_empty1 field value.

setFVert

@Internal
public void setFVert(boolean value)
Sets the fVert field value. When 1, positioned in vertical text flow

isFVert

@Internal
public boolean isFVert()
When 1, positioned in vertical text flow

Returns:
the fVert field value.

setPcVert

@Internal
public void setPcVert(byte value)
Sets the pcVert field value. Vertical position code. Specifies coordinate frame to use when paragraphs are absolutely positioned. 0 -- vertical position coordinates are relative to margin; 1 -- coordinates are relative to page; 2 -- coordinates are relative to text. This means: relative to where the next non-APO text would have been placed if this APO did not exist.

getPcVert

@Internal
public byte getPcVert()
Vertical position code. Specifies coordinate frame to use when paragraphs are absolutely positioned. 0 -- vertical position coordinates are relative to margin; 1 -- coordinates are relative to page; 2 -- coordinates are relative to text. This means: relative to where the next non-APO text would have been placed if this APO did not exist.

Returns:
the pcVert field value.

setPcHorz

@Internal
public void setPcHorz(byte value)
Sets the pcHorz field value. Horizontal position code. Specifies coordinate frame to use when paragraphs are absolutely positioned. 0 -- horizontal position coordinates are relative to column; 1 -- coordinates are relative to margin; 2 -- coordinates are relative to page

getPcHorz

@Internal
public byte getPcHorz()
Horizontal position code. Specifies coordinate frame to use when paragraphs are absolutely positioned. 0 -- horizontal position coordinates are relative to column; 1 -- coordinates are relative to margin; 2 -- coordinates are relative to page

Returns:
the pcHorz field value.

setWidthAndFitsFlags_empty2

@Internal
public void setWidthAndFitsFlags_empty2(short value)
Sets the widthAndFitsFlags_empty2 field value. Not used

getWidthAndFitsFlags_empty2

@Internal
public short getWidthAndFitsFlags_empty2()
Not used

Returns:
the widthAndFitsFlags_empty2 field value.

setFFirstRow

@Internal
public void setFFirstRow(boolean value)
Sets the fFirstRow field value. Used internally by Word: first row

isFFirstRow

@Internal
public boolean isFFirstRow()
Used internally by Word: first row

Returns:
the fFirstRow field value.

setFLastRow

@Internal
public void setFLastRow(boolean value)
Sets the fLastRow field value. Used internally by Word: last row

isFLastRow

@Internal
public boolean isFLastRow()
Used internally by Word: last row

Returns:
the fLastRow field value.

setFOutline

@Internal
public void setFOutline(boolean value)
Sets the fOutline field value. Used internally by Word: row was cached for outline mode

isFOutline

@Internal
public boolean isFOutline()
Used internally by Word: row was cached for outline mode

Returns:
the fOutline field value.

setFOrigWordTableRules

@Internal
public void setFOrigWordTableRules(boolean value)
Sets the fOrigWordTableRules field value. Used internally by Word: table combining like Word 5.x for the Macintosh and WinWord 1.x

isFOrigWordTableRules

@Internal
public boolean isFOrigWordTableRules()
Used internally by Word: table combining like Word 5.x for the Macintosh and WinWord 1.x

Returns:
the fOrigWordTableRules field value.

setFCellSpacing

@Internal
public void setFCellSpacing(boolean value)
Sets the fCellSpacing field value. Used internally by Word: When set to 1 cell spacing is allowed

isFCellSpacing

@Internal
public boolean isFCellSpacing()
Used internally by Word: When set to 1 cell spacing is allowed

Returns:
the fCellSpacing field value.

setGrpfTap_unused

@Internal
public void setGrpfTap_unused(short value)
Sets the grpfTap_unused field value. Not used

getGrpfTap_unused

@Internal
public short getGrpfTap_unused()
Not used

Returns:
the grpfTap_unused field value.

setFWrapToWwd

@Internal
public void setFWrapToWwd(boolean value)
Sets the fWrapToWwd field value. Used internally by Word: Wrap to window is on when set to 1

isFWrapToWwd

@Internal
public boolean isFWrapToWwd()
Used internally by Word: Wrap to window is on when set to 1

Returns:
the fWrapToWwd field value.

setFNotPageView

@Internal
public void setFNotPageView(boolean value)
Sets the fNotPageView field value. Used internally by Word: when set to 1 we are not in Page View

isFNotPageView

@Internal
public boolean isFNotPageView()
Used internally by Word: when set to 1 we are not in Page View

Returns:
the fNotPageView field value.

setViewFlags_unused1

@Internal
public void setViewFlags_unused1(boolean value)
Sets the viewFlags_unused1 field value. Not used

isViewFlags_unused1

@Internal
public boolean isViewFlags_unused1()
Not used

Returns:
the viewFlags_unused1 field value.

setFWebView

@Internal
public void setFWebView(boolean value)
Sets the fWebView field value. Used internally by Word: Web View is on when set to 1

isFWebView

@Internal
public boolean isFWebView()
Used internally by Word: Web View is on when set to 1

Returns:
the fWebView field value.

setFAdjusted

@Internal
public void setFAdjusted(boolean value)
Sets the fAdjusted field value. Used internally by Word

isFAdjusted

@Internal
public boolean isFAdjusted()
Used internally by Word

Returns:
the fAdjusted field value.

setViewFlags_unused2

@Internal
public void setViewFlags_unused2(short value)
Sets the viewFlags_unused2 field value. Not used

getViewFlags_unused2

@Internal
public short getViewFlags_unused2()
Not used

Returns:
the viewFlags_unused2 field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TBDAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class TBDAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TBDAbstractType
Direct Known Subclasses:
TabDescriptor
@Internal
public abstract class TBDAbstractType
extends java.lang.Object

The TBD is a substructure of the PAP.

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc]

Field Summary
protected  byte field_1_value
Constructor Summary
protected TBDAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
byte | getJc() Justification code
byte | getReserved()
static int | getSize() Size of record
byte | getTlc() Tab leader code
byte | getValue() Get the value field for the TBD record.
void | serialize(byte[] data, int offset)
void | setJc(byte value) Sets the jc field value.
void | setReserved(byte value) Sets the reserved field value.
void | setTlc(byte value) Sets the tlc field value.
void | setValue(byte field_1_value) Set the value field for the TBD record.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_value

protected byte field_1_value
Constructor Detail

TBDAbstractType

protected TBDAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

getSize

public static int getSize()
Size of record

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getValue

@Internal
public byte getValue()
Get the value field for the TBD record.

setValue

@Internal
public void setValue(byte field_1_value)
Set the value field for the TBD record.

setJc

@Internal
public void setJc(byte value)
Sets the jc field value. Justification code

getJc

@Internal
public byte getJc()
Justification code

Returns:
the jc field value.

setTlc

@Internal
public void setTlc(byte value)
Sets the tlc field value. Tab leader code

getTlc

@Internal
public byte getTlc()
Tab leader code

Returns:
the tlc field value.

setReserved

@Internal
public void setReserved(byte value)
Sets the reserved field value.

getReserved

@Internal
public byte getReserved()
Returns:
the reserved field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TCAbstractType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class TCAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TCAbstractType
Direct Known Subclasses:
TableCellDescriptor
@Internal
public abstract class TCAbstractType
extends java.lang.Object

Table Cell Descriptor.

NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/types/definitions.

This class is internal. It content or properties may change without notice due to changes in our knowledge of internal Microsoft Word binary structures.

Author:
S. Ryan Ackley. Field descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format (.doc) Specification

Field Summary
protected short | field_1_rgf
protected byte | field_10_ftsCellPaddingBottom
protected byte | field_11_ftsCellPaddingRight
protected short | field_12_wCellSpacingLeft
protected short | field_13_wCellSpacingTop
protected short | field_14_wCellSpacingBottom
protected short | field_15_wCellSpacingRight
protected byte | field_16_ftsCellSpacingLeft
protected byte | field_17_ftsCellSpacingTop
protected byte | field_18_ftsCellSpacingBottom
protected byte | field_19_ftsCellSpacingRight
protected short | field_2_wWidth
protected BorderCode | field_20_brcTop
protected BorderCode | field_21_brcLeft
protected BorderCode | field_22_brcBottom
protected BorderCode | field_23_brcRight
protected ShadingDescriptor | field_3_shd
protected short | field_4_wCellPaddingLeft
protected short | field_5_wCellPaddingTop
protected short | field_6_wCellPaddingBottom
protected short | field_7_wCellPaddingRight
protected byte | field_8_ftsCellPaddingLeft
protected byte | field_9_ftsCellPaddingTop
Constructor Summary
protected TCAbstractType()
Method Summary
BorderCode | getBrcBottom() Bottom border.
BorderCode | getBrcLeft() Left border.
BorderCode | getBrcRight() Right border.
BorderCode | getBrcTop() Top border.
byte | getFtsCellPaddingBottom() Bottom cell margin/padding units.
byte | getFtsCellPaddingLeft() Left cell margin/padding units.
byte | getFtsCellPaddingRight() Right cell margin/padding units.
byte | getFtsCellPaddingTop() Top cell margin/padding units.
byte | getFtsCellSpacingBottom() Bottom cell spacing units.
byte | getFtsCellSpacingLeft() Left cell spacing units.
byte | getFtsCellSpacingRight() Right cell spacing units.
byte | getFtsCellSpacingTop() Top cell spacing units.
byte | getFtsWidth() Units for wWidth
byte | getFUnused() Not used
short | getRgf() Get the rgf field for the TC record.
ShadingDescriptor | getShd() Cell shading.
byte | getVertAlign() Specifies the alignment of the cell contents relative to text flow (e.g.
short | getWCellPaddingBottom() Bottom cell margin/padding.
short | getWCellPaddingLeft() Left cell margin/padding.
short | getWCellPaddingRight() Right cell margin/padding.
short | getWCellPaddingTop() Top cell margin/padding.
short | getWCellSpacingBottom() Bottom cell spacing.
short | getWCellSpacingLeft() Left cell spacing.
short | getWCellSpacingRight() Right cell spacing.
short | getWCellSpacingTop() Top cell spacing.
short | getWWidth() Preferred cell width.
boolean | isFBackward() For a vertical table cell, text flow is bottom to top when 1 and is bottom to top when 0
boolean | isFFirstMerged() When 1, cell is first cell of a range of cells that have been merged.
boolean | isFFitText() When 1, make the text fit the table cell
boolean | isFMerged() When 1, cell has been merged with preceding cell
boolean | isFNoWrap() When 1, do not allow text to wrap in the table cell
boolean | isFRotateFont() When 1, cell has rotated characters (i.e.
boolean | isFVertical() When 1, cell has vertical text flow
boolean | isFVertMerge() When 1, cell is vertically merged with the cell(s) above and/or below.
boolean | isFVertRestart() When 1, the cell is the first of a set of vertically merged cells.
void | setBrcBottom(BorderCode field_22_brcBottom) Bottom border.
void | setBrcLeft(BorderCode field_21_brcLeft) Left border.
void | setBrcRight(BorderCode field_23_brcRight) Right border.
void | setBrcTop(BorderCode field_20_brcTop) Top border.
void | setFBackward(boolean value) Sets the fBackward field value.
void | setFFirstMerged(boolean value) Sets the fFirstMerged field value.
void | setFFitText(boolean value) Sets the fFitText field value.
void | setFMerged(boolean value) Sets the fMerged field value.
void | setFNoWrap(boolean value) Sets the fNoWrap field value.
void | setFRotateFont(boolean value) Sets the fRotateFont field value.
void | setFtsCellPaddingBottom(byte field_10_ftsCellPaddingBottom) Bottom cell margin/padding units.
void | setFtsCellPaddingLeft(byte field_8_ftsCellPaddingLeft) Left cell margin/padding units.
void | setFtsCellPaddingRight(byte field_11_ftsCellPaddingRight) Right cell margin/padding units.
void | setFtsCellPaddingTop(byte field_9_ftsCellPaddingTop) Top cell margin/padding units.
void | setFtsCellSpacingBottom(byte field_18_ftsCellSpacingBottom) Bottom cell spacing units.
void | setFtsCellSpacingLeft(byte field_16_ftsCellSpacingLeft) Left cell spacing units.
void | setFtsCellSpacingRight(byte field_19_ftsCellSpacingRight) Right cell spacing units.
void | setFtsCellSpacingTop(byte field_17_ftsCellSpacingTop) Top cell spacing units.
void | setFtsWidth(byte value) Sets the ftsWidth field value.
void | setFUnused(byte value) Sets the fUnused field value.
void | setFVertical(boolean value) Sets the fVertical field value.
void | setFVertMerge(boolean value) Sets the fVertMerge field value.
void | setFVertRestart(boolean value) Sets the fVertRestart field value.
void | setRgf(short field_1_rgf) Set the rgf field for the TC record.
void | setShd(ShadingDescriptor field_3_shd) Cell shading.
void | setVertAlign(byte value) Sets the vertAlign field value.
void | setWCellPaddingBottom(short field_6_wCellPaddingBottom) Bottom cell margin/padding.
void | setWCellPaddingLeft(short field_4_wCellPaddingLeft) Left cell margin/padding.
void | setWCellPaddingRight(short field_7_wCellPaddingRight) Right cell margin/padding.
void | setWCellPaddingTop(short field_5_wCellPaddingTop) Top cell margin/padding.
void | setWCellSpacingBottom(short field_14_wCellSpacingBottom) Bottom cell spacing.
void | setWCellSpacingLeft(short field_12_wCellSpacingLeft) Left cell spacing.
void | setWCellSpacingRight(short field_15_wCellSpacingRight) Right cell spacing.
void | setWCellSpacingTop(short field_13_wCellSpacingTop) Top cell spacing.
void | setWWidth(short field_2_wWidth) Preferred cell width.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_rgf

protected short field_1_rgf

field_2_wWidth

protected short field_2_wWidth

field_3_shd

protected ShadingDescriptor field_3_shd

field_4_wCellPaddingLeft

protected short field_4_wCellPaddingLeft

field_5_wCellPaddingTop

protected short field_5_wCellPaddingTop

field_6_wCellPaddingBottom

protected short field_6_wCellPaddingBottom

field_7_wCellPaddingRight

protected short field_7_wCellPaddingRight

field_8_ftsCellPaddingLeft

protected byte field_8_ftsCellPaddingLeft

field_9_ftsCellPaddingTop

protected byte field_9_ftsCellPaddingTop

field_10_ftsCellPaddingBottom

protected byte field_10_ftsCellPaddingBottom

field_11_ftsCellPaddingRight

protected byte field_11_ftsCellPaddingRight

field_12_wCellSpacingLeft

protected short field_12_wCellSpacingLeft

field_13_wCellSpacingTop

protected short field_13_wCellSpacingTop

field_14_wCellSpacingBottom

protected short field_14_wCellSpacingBottom

field_15_wCellSpacingRight

protected short field_15_wCellSpacingRight

field_16_ftsCellSpacingLeft

protected byte field_16_ftsCellSpacingLeft

field_17_ftsCellSpacingTop

protected byte field_17_ftsCellSpacingTop

field_18_ftsCellSpacingBottom

protected byte field_18_ftsCellSpacingBottom

field_19_ftsCellSpacingRight

protected byte field_19_ftsCellSpacingRight

field_20_brcTop

protected BorderCode field_20_brcTop

field_21_brcLeft

protected BorderCode field_21_brcLeft

field_22_brcBottom

protected BorderCode field_22_brcBottom

field_23_brcRight

protected BorderCode field_23_brcRight
Constructor Detail

TCAbstractType

protected TCAbstractType()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getRgf

@Internal
public short getRgf()
Get the rgf field for the TC record.

setRgf

@Internal
public void setRgf(short field_1_rgf)
Set the rgf field for the TC record.

getWWidth

@Internal
public short getWWidth()
Preferred cell width.

setWWidth

@Internal
public void setWWidth(short field_2_wWidth)
Preferred cell width.

getShd

@Internal
public ShadingDescriptor getShd()
Cell shading.

setShd

@Internal
public void setShd(ShadingDescriptor field_3_shd)
Cell shading.

getWCellPaddingLeft

@Internal
public short getWCellPaddingLeft()
Left cell margin/padding.

setWCellPaddingLeft

@Internal
public void setWCellPaddingLeft(short field_4_wCellPaddingLeft)
Left cell margin/padding.

getWCellPaddingTop

@Internal
public short getWCellPaddingTop()
Top cell margin/padding.

setWCellPaddingTop

@Internal
public void setWCellPaddingTop(short field_5_wCellPaddingTop)
Top cell margin/padding.

getWCellPaddingBottom

@Internal
public short getWCellPaddingBottom()
Bottom cell margin/padding.

setWCellPaddingBottom

@Internal
public void setWCellPaddingBottom(short field_6_wCellPaddingBottom)
Bottom cell margin/padding.

getWCellPaddingRight

@Internal
public short getWCellPaddingRight()
Right cell margin/padding.

setWCellPaddingRight

@Internal
public void setWCellPaddingRight(short field_7_wCellPaddingRight)
Right cell margin/padding.

getFtsCellPaddingLeft

@Internal
public byte getFtsCellPaddingLeft()
Left cell margin/padding units.

setFtsCellPaddingLeft

@Internal
public void setFtsCellPaddingLeft(byte field_8_ftsCellPaddingLeft)
Left cell margin/padding units.

getFtsCellPaddingTop

@Internal
public byte getFtsCellPaddingTop()
Top cell margin/padding units.

setFtsCellPaddingTop

@Internal
public void setFtsCellPaddingTop(byte field_9_ftsCellPaddingTop)
Top cell margin/padding units.

getFtsCellPaddingBottom

@Internal
public byte getFtsCellPaddingBottom()
Bottom cell margin/padding units.

setFtsCellPaddingBottom

@Internal
public void setFtsCellPaddingBottom(byte field_10_ftsCellPaddingBottom)
Bottom cell margin/padding units.

getFtsCellPaddingRight

@Internal
public byte getFtsCellPaddingRight()
Right cell margin/padding units.

setFtsCellPaddingRight

@Internal
public void setFtsCellPaddingRight(byte field_11_ftsCellPaddingRight)
Right cell margin/padding units.

getWCellSpacingLeft

@Internal
public short getWCellSpacingLeft()
Left cell spacing.

setWCellSpacingLeft

@Internal
public void setWCellSpacingLeft(short field_12_wCellSpacingLeft)
Left cell spacing.

getWCellSpacingTop

@Internal
public short getWCellSpacingTop()
Top cell spacing.

setWCellSpacingTop

@Internal
public void setWCellSpacingTop(short field_13_wCellSpacingTop)
Top cell spacing.

getWCellSpacingBottom

@Internal
public short getWCellSpacingBottom()
Bottom cell spacing.

setWCellSpacingBottom

@Internal
public void setWCellSpacingBottom(short field_14_wCellSpacingBottom)
Bottom cell spacing.

getWCellSpacingRight

@Internal
public short getWCellSpacingRight()
Right cell spacing.

setWCellSpacingRight

@Internal
public void setWCellSpacingRight(short field_15_wCellSpacingRight)
Right cell spacing.

getFtsCellSpacingLeft

@Internal
public byte getFtsCellSpacingLeft()
Left cell spacing units.

setFtsCellSpacingLeft

@Internal
public void setFtsCellSpacingLeft(byte field_16_ftsCellSpacingLeft)
Left cell spacing units.

getFtsCellSpacingTop

@Internal
public byte getFtsCellSpacingTop()
Top cell spacing units.

setFtsCellSpacingTop

@Internal
public void setFtsCellSpacingTop(byte field_17_ftsCellSpacingTop)
Top cell spacing units.

getFtsCellSpacingBottom

@Internal
public byte getFtsCellSpacingBottom()
Bottom cell spacing units.

setFtsCellSpacingBottom

@Internal
public void setFtsCellSpacingBottom(byte field_18_ftsCellSpacingBottom)
Bottom cell spacing units.

getFtsCellSpacingRight

@Internal
public byte getFtsCellSpacingRight()
Right cell spacing units.

setFtsCellSpacingRight

@Internal
public void setFtsCellSpacingRight(byte field_19_ftsCellSpacingRight)
Right cell spacing units.

getBrcTop

@Internal
public BorderCode getBrcTop()
Top border.

setBrcTop

@Internal
public void setBrcTop(BorderCode field_20_brcTop)
Top border.

getBrcLeft

@Internal
public BorderCode getBrcLeft()
Left border.

setBrcLeft

@Internal
public void setBrcLeft(BorderCode field_21_brcLeft)
Left border.

getBrcBottom

@Internal
public BorderCode getBrcBottom()
Bottom border.

setBrcBottom

@Internal
public void setBrcBottom(BorderCode field_22_brcBottom)
Bottom border.

getBrcRight

@Internal
public BorderCode getBrcRight()
Right border.

setBrcRight

@Internal
public void setBrcRight(BorderCode field_23_brcRight)
Right border.

setFFirstMerged

@Internal
public void setFFirstMerged(boolean value)
Sets the fFirstMerged field value. When 1, cell is first cell of a range of cells that have been merged. When a cell is merged, the display areas of the merged cells are consolidated and the text within the cells is interpreted as belonging to one text stream for purposes of calculating line breaks.

isFFirstMerged

@Internal
public boolean isFFirstMerged()
When 1, cell is first cell of a range of cells that have been merged. When a cell is merged, the display areas of the merged cells are consolidated and the text within the cells is interpreted as belonging to one text stream for purposes of calculating line breaks.

Returns:
the fFirstMerged field value.

setFMerged

@Internal
public void setFMerged(boolean value)
Sets the fMerged field value. When 1, cell has been merged with preceding cell

isFMerged

@Internal
public boolean isFMerged()
When 1, cell has been merged with preceding cell

Returns:
the fMerged field value.

setFVertical

@Internal
public void setFVertical(boolean value)
Sets the fVertical field value. When 1, cell has vertical text flow

isFVertical

@Internal
public boolean isFVertical()
When 1, cell has vertical text flow

Returns:
the fVertical field value.

setFBackward

@Internal
public void setFBackward(boolean value)
Sets the fBackward field value. For a vertical table cell, text flow is bottom to top when 1 and is bottom to top when 0

isFBackward

@Internal
public boolean isFBackward()
For a vertical table cell, text flow is bottom to top when 1 and is bottom to top when 0

Returns:
the fBackward field value.

setFRotateFont

@Internal
public void setFRotateFont(boolean value)
Sets the fRotateFont field value. When 1, cell has rotated characters (i.e. uses @font)

isFRotateFont

@Internal
public boolean isFRotateFont()
When 1, cell has rotated characters (i.e. uses @font)

Returns:
the fRotateFont field value.

setFVertMerge

@Internal
public void setFVertMerge(boolean value)
Sets the fVertMerge field value. When 1, cell is vertically merged with the cell(s) above and/or below. When cells are vertically merged, the display area of the merged cells are consolidated. The consolidated area is used to display the contents of the first vertically merged cell (the cell with fVertRestart set to 1), and all other vertically merged cells (those with fVertRestart set to 0) must be empty. Cells can only be merged vertically if their left and right boundaries are (nearly) identical (i.e. if corresponding entries in rgdxaCenter of the table rows differ by at most 3).

isFVertMerge

@Internal
public boolean isFVertMerge()
When 1, cell is vertically merged with the cell(s) above and/or below. When cells are vertically merged, the display area of the merged cells are consolidated. The consolidated area is used to display the contents of the first vertically merged cell (the cell with fVertRestart set to 1), and all other vertically merged cells (those with fVertRestart set to 0) must be empty. Cells can only be merged vertically if their left and right boundaries are (nearly) identical (i.e. if corresponding entries in rgdxaCenter of the table rows differ by at most 3).

Returns:
the fVertMerge field value.

setFVertRestart

@Internal
public void setFVertRestart(boolean value)
Sets the fVertRestart field value. When 1, the cell is the first of a set of vertically merged cells. The contents of a cell with fVertStart set to 1 are displayed in the consolidated area belonging to the entire set of vertically merged cells. Vertically merged cells with fVertRestart set to 0 must be empty.

isFVertRestart

@Internal
public boolean isFVertRestart()
When 1, the cell is the first of a set of vertically merged cells. The contents of a cell with fVertStart set to 1 are displayed in the consolidated area belonging to the entire set of vertically merged cells. Vertically merged cells with fVertRestart set to 0 must be empty.

Returns:
the fVertRestart field value.

setVertAlign

@Internal
public void setVertAlign(byte value)
Sets the vertAlign field value. Specifies the alignment of the cell contents relative to text flow (e.g. in a cell with bottom to top text flow and bottom vertical alignment, the text is shifted horizontally to match the cell's right boundary)

getVertAlign

@Internal
public byte getVertAlign()
Specifies the alignment of the cell contents relative to text flow (e.g. in a cell with bottom to top text flow and bottom vertical alignment, the text is shifted horizontally to match the cell's right boundary)

Returns:
the vertAlign field value.

setFtsWidth

@Internal
public void setFtsWidth(byte value)
Sets the ftsWidth field value. Units for wWidth

getFtsWidth

@Internal
public byte getFtsWidth()
Units for wWidth

Returns:
the ftsWidth field value.

setFFitText

@Internal
public void setFFitText(boolean value)
Sets the fFitText field value. When 1, make the text fit the table cell

isFFitText

@Internal
public boolean isFFitText()
When 1, make the text fit the table cell

Returns:
the fFitText field value.

setFNoWrap

@Internal
public void setFNoWrap(boolean value)
Sets the fNoWrap field value. When 1, do not allow text to wrap in the table cell

isFNoWrap

@Internal
public boolean isFNoWrap()
When 1, do not allow text to wrap in the table cell

Returns:
the fNoWrap field value.

setFUnused

@Internal
public void setFUnused(byte value)
Sets the fUnused field value. Not used

getFUnused

@Internal
public byte getFUnused()
Not used

Returns:
the fUnused field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TLPAbstractType

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.model.types
Class TLPAbstractType

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TLPAbstractType
All Implemented Interfaces:
org.apache.poi.hdf.model.hdftypes.HDFType
Direct Known Subclasses:
TableAutoformatLookSpecifier
@Internal
public abstract class TLPAbstractType
extends java.lang.Object
implements org.apache.poi.hdf.model.hdftypes.HDFType

Table Autoformat Look sPecifier (TLP).

Class and fields descriptions are quoted from Microsoft Office Word 97-2007 Binary File Format NOTE: This source is automatically generated please do not modify this file. Either subclass or remove the record in src/records/definitions.

Author:
Sergey Vladimirov; according to Microsoft Office Word 97-2007 Binary File Format Specification [*.doc]

Field Summary
protected short | field_1_itl
protected byte | field_2_tlp_flags
Constructor Summary
TLPAbstractType()
Method Summary
protected void | fillFields(byte[] data, int offset)
short | getItl() Get the itl field for the TLP record.
int | getSize() Size of record (exluding 4 byte header)
byte | getTlp_flags() Get the tlp_flags field for the TLP record.
boolean | isFBestFit() When == 1, do best fit from the selected table look
boolean | isFBorders() When == 1, use the border properties from the selected table look
boolean | isFColor() When == 1, use the color from the selected table look
boolean | isFFont() When == 1, use the font from the selected table look
boolean | isFHdrRows() When == 1, apply properties from the selected table look to the header rows in the table
boolean | isFLastRow() When == 1, apply properties from the selected table look to the last row in the table
boolean | isFShading() When == 1, use the shading properties from the selected table look
void | serialize(byte[] data, int offset)
void | setFBestFit(boolean value) Sets the fBestFit field value.
void | setFBorders(boolean value) Sets the fBorders field value.
void | setFColor(boolean value) Sets the fColor field value.
void | setFFont(boolean value) Sets the fFont field value.
void | setFHdrRows(boolean value) Sets the fHdrRows field value.
void | setFLastRow(boolean value) Sets the fLastRow field value.
void | setFShading(boolean value) Sets the fShading field value.
void | setItl(short field_1_itl) Set the itl field for the TLP record.
void | setTlp_flags(byte field_2_tlp_flags) Set the tlp_flags field for the TLP record.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

field_1_itl

protected short field_1_itl

field_2_tlp_flags

protected byte field_2_tlp_flags
Constructor Detail

TLPAbstractType

public TLPAbstractType()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getSize

public int getSize()
Size of record (exluding 4 byte header)

getItl

public short getItl()
Get the itl field for the TLP record.

setItl

public void setItl(short field_1_itl)
Set the itl field for the TLP record.

getTlp_flags

public byte getTlp_flags()
Get the tlp_flags field for the TLP record.

setTlp_flags

public void setTlp_flags(byte field_2_tlp_flags)
Set the tlp_flags field for the TLP record.

setFBorders

public void setFBorders(boolean value)
Sets the fBorders field value. When == 1, use the border properties from the selected table look

isFBorders

public boolean isFBorders()
When == 1, use the border properties from the selected table look

Returns:
the fBorders field value.

setFShading

public void setFShading(boolean value)
Sets the fShading field value. When == 1, use the shading properties from the selected table look

isFShading

public boolean isFShading()
When == 1, use the shading properties from the selected table look

Returns:
the fShading field value.

setFFont

public void setFFont(boolean value)
Sets the fFont field value. When == 1, use the font from the selected table look

isFFont

public boolean isFFont()
When == 1, use the font from the selected table look

Returns:
the fFont field value.

setFColor

public void setFColor(boolean value)
Sets the fColor field value. When == 1, use the color from the selected table look

isFColor

public boolean isFColor()
When == 1, use the color from the selected table look

Returns:
the fColor field value.

setFBestFit

public void setFBestFit(boolean value)
Sets the fBestFit field value. When == 1, do best fit from the selected table look

isFBestFit

public boolean isFBestFit()
When == 1, do best fit from the selected table look

Returns:
the fBestFit field value.

setFHdrRows

public void setFHdrRows(boolean value)
Sets the fHdrRows field value. When == 1, apply properties from the selected table look to the header rows in the table

isFHdrRows

public boolean isFHdrRows()
When == 1, apply properties from the selected table look to the header rows in the table

Returns:
the fHdrRows field value.

setFLastRow

public void setFLastRow(boolean value)
Sets the fLastRow field value. When == 1, apply properties from the selected table look to the last row in the table

isFLastRow

public boolean isFLastRow()
When == 1, apply properties from the selected table look to the last row in the table

Returns:
the fLastRow field value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hwpf.model.types.BKFAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.BKFAbstractType

Packages that use BKFAbstractType
org.apache.poi.hwpf.model

Uses of BKFAbstractType in org.apache.poi.hwpf.model

Subclasses of BKFAbstractType in org.apache.poi.hwpf.model
 class BookmarkFirstDescriptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.CHPAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.CHPAbstractType

Packages that use CHPAbstractType
org.apache.poi.hwpf.usermodel

Uses of CHPAbstractType in org.apache.poi.hwpf.usermodel

Subclasses of CHPAbstractType in org.apache.poi.hwpf.usermodel
 class CharacterProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.DOPAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.DOPAbstractType

Packages that use DOPAbstractType
org.apache.poi.hwpf.model

Uses of DOPAbstractType in org.apache.poi.hwpf.model

Subclasses of DOPAbstractType in org.apache.poi.hwpf.model
 class DocumentProperties
Comment me

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.FibBaseAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.FibBaseAbstractType

Packages that use FibBaseAbstractType
org.apache.poi.hwpf.model

Uses of FibBaseAbstractType in org.apache.poi.hwpf.model

Subclasses of FibBaseAbstractType in org.apache.poi.hwpf.model
 class FibBase
Base part of the File information Block (FibBase).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

No usage of org.apache.poi.hwpf.model.types.FibRgLw95AbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

No usage of org.apache.poi.hwpf.model.types.FibRgLw97AbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.FibRgW97AbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.FibRgW97AbstractType

No usage of org.apache.poi.hwpf.model.types.FibRgW97AbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.FLDAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.FLDAbstractType

Packages that use FLDAbstractType
org.apache.poi.hwpf.model

Uses of FLDAbstractType in org.apache.poi.hwpf.model

Subclasses of FLDAbstractType in org.apache.poi.hwpf.model
 class FieldDescriptor
Class for the FLD structure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.FRDAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.FRDAbstractType

Packages that use FRDAbstractType
org.apache.poi.hwpf.model

Uses of FRDAbstractType in org.apache.poi.hwpf.model

Subclasses of FRDAbstractType in org.apache.poi.hwpf.model
 class FootnoteReferenceDescriptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.FSPAAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.FSPAAbstractType

Packages that use FSPAAbstractType
org.apache.poi.hwpf.model

Uses of FSPAAbstractType in org.apache.poi.hwpf.model

Subclasses of FSPAAbstractType in org.apache.poi.hwpf.model
 class FSPA
File Shape Address structure

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.GrfhicAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.GrfhicAbstractType

Packages that use GrfhicAbstractType
org.apache.poi.hwpf.model

Uses of GrfhicAbstractType in org.apache.poi.hwpf.model

Subclasses of GrfhicAbstractType in org.apache.poi.hwpf.model
 class Grfhic
The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.HRESIAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.HRESIAbstractType

Packages that use HRESIAbstractType
org.apache.poi.hwpf.model

Uses of HRESIAbstractType in org.apache.poi.hwpf.model

Subclasses of HRESIAbstractType in org.apache.poi.hwpf.model
 class Hyphenation
Hyphenation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.LFOAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.LFOAbstractType

No usage of org.apache.poi.hwpf.model.types.LFOAbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

No usage of org.apache.poi.hwpf.model.types.LFOLVLBaseAbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.LSTFAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.LSTFAbstractType

No usage of org.apache.poi.hwpf.model.types.LSTFAbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.LVLFAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.LVLFAbstractType

No usage of org.apache.poi.hwpf.model.types.LVLFAbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.PAPAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.PAPAbstractType

Packages that use PAPAbstractType
org.apache.poi.hwpf.usermodel

Uses of PAPAbstractType in org.apache.poi.hwpf.usermodel

Subclasses of PAPAbstractType in org.apache.poi.hwpf.usermodel
 class ParagraphProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.PICFAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.PICFAbstractType

Packages that use PICFAbstractType
org.apache.poi.hwpf.model

Uses of PICFAbstractType in org.apache.poi.hwpf.model

Subclasses of PICFAbstractType in org.apache.poi.hwpf.model
 class PICF
The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.SEPAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.SEPAbstractType

Packages that use SEPAbstractType
org.apache.poi.hwpf.usermodel

Uses of SEPAbstractType in org.apache.poi.hwpf.usermodel

Subclasses of SEPAbstractType in org.apache.poi.hwpf.usermodel
 class SectionProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.SHD80AbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.SHD80AbstractType

Packages that use SHD80AbstractType
org.apache.poi.hwpf.usermodel

Uses of SHD80AbstractType in org.apache.poi.hwpf.usermodel

Subclasses of SHD80AbstractType in org.apache.poi.hwpf.usermodel
 class ShadingDescriptor80
The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.SHDAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.SHDAbstractType

Packages that use SHDAbstractType
org.apache.poi.hwpf.usermodel

Uses of SHDAbstractType in org.apache.poi.hwpf.usermodel

Subclasses of SHDAbstractType in org.apache.poi.hwpf.usermodel
 class ShadingDescriptor
The SHD is a substructure of the CHP, PAP, and TC for Word 2000.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.StdfBaseAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.StdfBaseAbstractType

No usage of org.apache.poi.hwpf.model.types.StdfBaseAbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

No usage of org.apache.poi.hwpf.model.types.StdfPost2000AbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.StshifAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.StshifAbstractType

No usage of org.apache.poi.hwpf.model.types.StshifAbstractType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.TAPAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.TAPAbstractType

Packages that use TAPAbstractType
org.apache.poi.hwpf.usermodel

Uses of TAPAbstractType in org.apache.poi.hwpf.usermodel

Subclasses of TAPAbstractType in org.apache.poi.hwpf.usermodel
 class TableProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.TBDAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.TBDAbstractType

Packages that use TBDAbstractType
org.apache.poi.hwpf.model

Uses of TBDAbstractType in org.apache.poi.hwpf.model

Subclasses of TBDAbstractType in org.apache.poi.hwpf.model
 class TabDescriptor
Tab descriptor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.TCAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.TCAbstractType

Packages that use TCAbstractType
org.apache.poi.hwpf.usermodel

Uses of TCAbstractType in org.apache.poi.hwpf.usermodel

Subclasses of TCAbstractType in org.apache.poi.hwpf.usermodel
 class TableCellDescriptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.model.types.TLPAbstractType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.model.types.TLPAbstractType

Packages that use TLPAbstractType
org.apache.poi.hwpf.usermodel

Uses of TLPAbstractType in org.apache.poi.hwpf.usermodel

Subclasses of TLPAbstractType in org.apache.poi.hwpf.usermodel
 class TableAutoformatLookSpecifier

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CharacterSprmCompressor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class CharacterSprmCompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.CharacterSprmCompressor

@Internal
public final class CharacterSprmCompressor
extends java.lang.Object

Constructor Summary
CharacterSprmCompressor()
Method Summary
static byte[] compressCharacterProperty(CharacterProperties newCHP, CharacterProperties oldCHP)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CharacterSprmCompressor

public CharacterSprmCompressor()
Method Detail

compressCharacterProperty

public static byte[] compressCharacterProperty(CharacterProperties newCHP,
                                               CharacterProperties oldCHP)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CharacterSprmUncompressor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class CharacterSprmUncompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmUncompressor
        extended by  org.apache.poi.hwpf.sprm.CharacterSprmUncompressor

@Internal
public final class CharacterSprmUncompressor
extends SprmUncompressor

Constructor Summary
CharacterSprmUncompressor()
Method Summary
static CharacterProperties uncompressCHP(CharacterProperties parent, byte[] grpprl, int offset)
Methods inherited from class org.apache.poi.hwpf.sprm.SprmUncompressor
getFlag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CharacterSprmUncompressor

public CharacterSprmUncompressor()
Method Detail

uncompressCHP

public static CharacterProperties uncompressCHP(CharacterProperties parent,
                                                byte[] grpprl,
                                                int offset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf.sprm
Classes
CharacterSprmCompressor
CharacterSprmUncompressor
ParagraphSprmCompressor
ParagraphSprmUncompressor
SectionSprmCompressor
SectionSprmUncompressor
SprmBuffer
SprmIterator
SprmOperation
SprmUncompressor
SprmUtils
TableSprmCompressor
TableSprmUncompressor


org.apache.poi.hwpf.sprm

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.sprm

Class Summary
CharacterSprmCompressor |
CharacterSprmUncompressor |
ParagraphSprmCompressor |
ParagraphSprmUncompressor |
SectionSprmCompressor |
SectionSprmUncompressor |
SprmBuffer |
SprmIterator | This class is used to iterate through a list of sprms from a Word 97/2000/XP document.
SprmOperation | This class is used to represent a sprm operation from a Word 97/2000/XP document.
SprmUncompressor |
SprmUtils |
TableSprmCompressor |
TableSprmUncompressor |


org.apache.poi.hwpf.sprm Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.sprm

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hwpf.sprm.CharacterSprmCompressor
    • org.apache.poi.hwpf.sprm.ParagraphSprmCompressor
    • org.apache.poi.hwpf.sprm.SectionSprmCompressor
    • org.apache.poi.hwpf.sprm.SprmBuffer (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.sprm.SprmIterator
    • org.apache.poi.hwpf.sprm.SprmOperation
    • org.apache.poi.hwpf.sprm.SprmUncompressor
      • org.apache.poi.hwpf.sprm.CharacterSprmUncompressor
      • org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor
      • org.apache.poi.hwpf.sprm.SectionSprmUncompressor
      • org.apache.poi.hwpf.sprm.TableSprmUncompressor
    • org.apache.poi.hwpf.sprm.SprmUtils
    • org.apache.poi.hwpf.sprm.TableSprmCompressor


Uses of Package org.apache.poi.hwpf.sprm

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.sprm

Packages that use org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.model
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.sprm used by org.apache.poi.hwpf.dev
SprmIterator
This class is used to iterate through a list of sprms from a Word 97/2000/XP document.

Classes in org.apache.poi.hwpf.sprm used by org.apache.poi.hwpf.model
SprmBuffer

Classes in org.apache.poi.hwpf.sprm used by org.apache.poi.hwpf.sprm
SprmBuffer
SprmIterator
This class is used to iterate through a list of sprms from a Word 97/2000/XP document.
SprmOperation
This class is used to represent a sprm operation from a Word 97/2000/XP document.
SprmUncompressor

Classes in org.apache.poi.hwpf.sprm used by org.apache.poi.hwpf.usermodel
SprmBuffer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ParagraphSprmCompressor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class ParagraphSprmCompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.ParagraphSprmCompressor

@Internal
public final class ParagraphSprmCompressor
extends java.lang.Object

Constructor Summary
ParagraphSprmCompressor()
Method Summary
static byte[] compressParagraphProperty(ParagraphProperties newPAP, ParagraphProperties oldPAP)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParagraphSprmCompressor

public ParagraphSprmCompressor()
Method Detail

compressParagraphProperty

public static byte[] compressParagraphProperty(ParagraphProperties newPAP,
                                               ParagraphProperties oldPAP)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParagraphSprmUncompressor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class ParagraphSprmUncompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmUncompressor
        extended by  org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor

@Internal
public final class ParagraphSprmUncompressor
extends SprmUncompressor

Constructor Summary
ParagraphSprmUncompressor()
Method Summary
static ParagraphProperties uncompressPAP(ParagraphProperties parent, byte[] grpprl, int offset)
Methods inherited from class org.apache.poi.hwpf.sprm.SprmUncompressor
getFlag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParagraphSprmUncompressor

public ParagraphSprmUncompressor()
Method Detail

uncompressPAP

public static ParagraphProperties uncompressPAP(ParagraphProperties parent,
                                                byte[] grpprl,
                                                int offset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SectionSprmCompressor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class SectionSprmCompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SectionSprmCompressor

@Internal
public final class SectionSprmCompressor
extends java.lang.Object

Constructor Summary
SectionSprmCompressor()
Method Summary
static byte[] compressSectionProperty(SectionProperties newSEP)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SectionSprmCompressor

public SectionSprmCompressor()
Method Detail

compressSectionProperty

public static byte[] compressSectionProperty(SectionProperties newSEP)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SectionSprmUncompressor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class SectionSprmUncompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmUncompressor
        extended by  org.apache.poi.hwpf.sprm.SectionSprmUncompressor

@Internal
public final class SectionSprmUncompressor
extends SprmUncompressor

Constructor Summary
SectionSprmUncompressor()
Method Summary
static SectionProperties uncompressSEP(byte[] grpprl, int offset)
Methods inherited from class org.apache.poi.hwpf.sprm.SprmUncompressor
getFlag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SectionSprmUncompressor

public SectionSprmUncompressor()
Method Detail

uncompressSEP

public static SectionProperties uncompressSEP(byte[] grpprl,
                                              int offset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SprmBuffer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class SprmBuffer

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmBuffer
All Implemented Interfaces:
java.lang.Cloneable
@Internal
public final class SprmBuffer
extends java.lang.Object
implements java.lang.Cloneable

Constructor Summary
SprmBuffer()
Deprecated. Use SprmBuffer(int) instead
SprmBuffer(byte[] buf)
Deprecated. Use SprmBuffer(byte[],int) instead
SprmBuffer(byte[] buf, boolean istd)
Deprecated. Use SprmBuffer(byte[],boolean,int) instead
SprmBuffer(byte[] buf, boolean istd, int sprmsStartOffset)
SprmBuffer(byte[] buf, int _sprmsStartOffset)
SprmBuffer(int sprmsStartOffset)
Method Summary
void | addSprm(short opcode, byte operand)
void | addSprm(short opcode, byte[] operand)
void | addSprm(short opcode, int operand)
void | addSprm(short opcode, short operand)
void | append(byte[] grpprl)
void | append(byte[] grpprl, int offset)
java.lang.Object | clone()
boolean | equals(java.lang.Object obj)
SprmOperation | findSprm(short opcode)
SprmIterator | iterator()
byte[] | toByteArray()
java.lang.String | toString()
void | updateSprm(short opcode, boolean operand)
void | updateSprm(short opcode, byte operand)
void | updateSprm(short opcode, int operand)
void | updateSprm(short opcode, short operand)
Methods inherited from class java.lang.Object
finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SprmBuffer

@Deprecated
public SprmBuffer()
Deprecated. Use SprmBuffer(int) instead

SprmBuffer

@Deprecated
public SprmBuffer(byte[] buf)
Deprecated. Use SprmBuffer(byte[],int) instead

SprmBuffer

@Deprecated
public SprmBuffer(byte[] buf,
                             boolean istd)
Deprecated. Use SprmBuffer(byte[],boolean,int) instead

SprmBuffer

public SprmBuffer(byte[] buf,
                  boolean istd,
                  int sprmsStartOffset)

SprmBuffer

public SprmBuffer(byte[] buf,
                  int _sprmsStartOffset)

SprmBuffer

public SprmBuffer(int sprmsStartOffset)
Method Detail

addSprm

public void addSprm(short opcode,
                    byte operand)

addSprm

public void addSprm(short opcode,
                    byte[] operand)

addSprm

public void addSprm(short opcode,
                    int operand)

addSprm

public void addSprm(short opcode,
                    short operand)

append

public void append(byte[] grpprl)

append

public void append(byte[] grpprl,
                   int offset)

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

findSprm

public SprmOperation findSprm(short opcode)

toByteArray

public byte[] toByteArray()

iterator

public SprmIterator iterator()

updateSprm

public void updateSprm(short opcode,
                       byte operand)

updateSprm

public void updateSprm(short opcode,
                       boolean operand)

updateSprm

public void updateSprm(short opcode,
                       int operand)

updateSprm

public void updateSprm(short opcode,
                       short operand)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SprmIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class SprmIterator

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmIterator

@Internal
public final class SprmIterator
extends java.lang.Object

This class is used to iterate through a list of sprms from a Word 97/2000/XP document.

Version:
1.0
Author:
Ryan Ackley

Constructor Summary
SprmIterator(byte[] grpprl, int offset)
Method Summary
boolean | hasNext()
SprmOperation | next()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SprmIterator

public SprmIterator(byte[] grpprl,
                    int offset)
Method Detail

hasNext

public boolean hasNext()

next

public SprmOperation next()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SprmOperation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class SprmOperation

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmOperation

@Internal
public final class SprmOperation
extends java.lang.Object

This class is used to represent a sprm operation from a Word 97/2000/XP document.

Version:
1.0
Author:
Ryan Ackley

Field Summary
static int | PAP_TYPE Deprecated.
static int | TAP_TYPE Deprecated.
static int | TYPE_CHP
static int | TYPE_PAP
static int | TYPE_PIC
static int | TYPE_SEP
static int | TYPE_TAP
Constructor Summary
SprmOperation(byte[] grpprl, int offset)
Method Summary
byte[] | getGrpprl()
int | getGrpprlOffset()
int | getOperand()
int | getOperation()
static int | getOperationFromOpcode(short opcode)
int | getSizeCode()
int | getType()
static int | getTypeFromOpcode(short opcode)
int | size()
byte[] | toByteArray()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

TYPE_PAP

public static final int TYPE_PAP
See Also:
Constant Field Values

TYPE_CHP

public static final int TYPE_CHP
See Also:
Constant Field Values

TYPE_PIC

public static final int TYPE_PIC
See Also:
Constant Field Values

TYPE_SEP

public static final int TYPE_SEP
See Also:
Constant Field Values

TYPE_TAP

public static final int TYPE_TAP
See Also:
Constant Field Values

PAP_TYPE

@Deprecated
public static final int PAP_TYPE
Deprecated.
See Also:
Constant Field Values

TAP_TYPE

@Deprecated
public static final int TAP_TYPE
Deprecated.
See Also:
Constant Field Values
Constructor Detail

SprmOperation

public SprmOperation(byte[] grpprl,
                     int offset)
Method Detail

getOperationFromOpcode

public static int getOperationFromOpcode(short opcode)

getTypeFromOpcode

public static int getTypeFromOpcode(short opcode)

toByteArray

public byte[] toByteArray()

getGrpprl

public byte[] getGrpprl()

getGrpprlOffset

public int getGrpprlOffset()

getOperand

public int getOperand()

getOperation

public int getOperation()

getSizeCode

public int getSizeCode()

getType

public int getType()

size

public int size()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SprmUncompressor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class SprmUncompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmUncompressor
Direct Known Subclasses:
CharacterSprmUncompressor, ParagraphSprmUncompressor, SectionSprmUncompressor, TableSprmUncompressor
@Internal
public abstract class SprmUncompressor
extends java.lang.Object

Constructor Summary
protected SprmUncompressor()
Method Summary
static boolean getFlag(int x)
Converts an int into a boolean.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SprmUncompressor

protected SprmUncompressor()
Method Detail

getFlag

public static boolean getFlag(int x)
Converts an int into a boolean. If the int is non-zero, it returns true. Otherwise it returns false.

Parameters:
x - The int to convert.
Returns:
A boolean whose value depends on x.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SprmUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class SprmUtils

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmUtils

@Internal
public final class SprmUtils
extends java.lang.Object

Constructor Summary
SprmUtils()
Method Summary
static int | addSpecialSprm(short instruction, byte[] varParam, java.util.List<byte[]> list)
static int | addSprm(short instruction, boolean param, java.util.List<byte[]> list)
static int | addSprm(short instruction, int param, byte[] varParam, java.util.List<byte[]> list)
static int | convertBrcToInt(short[] brc)
static byte[] | getGrpprl(java.util.List<byte[]> sprmList, int size)
static byte[] | shortArrayToByteArray(short[] convert)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SprmUtils

public SprmUtils()
Method Detail

shortArrayToByteArray

public static byte[] shortArrayToByteArray(short[] convert)

addSpecialSprm

public static int addSpecialSprm(short instruction,
                                 byte[] varParam,
                                 java.util.List<byte[]> list)

addSprm

public static int addSprm(short instruction,
                          boolean param,
                          java.util.List<byte[]> list)

addSprm

public static int addSprm(short instruction,
                          int param,
                          byte[] varParam,
                          java.util.List<byte[]> list)

getGrpprl

public static byte[] getGrpprl(java.util.List<byte[]> sprmList,
                               int size)

convertBrcToInt

public static int convertBrcToInt(short[] brc)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableSprmCompressor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class TableSprmCompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.TableSprmCompressor

@Internal
public final class TableSprmCompressor
extends java.lang.Object

Constructor Summary
TableSprmCompressor()
Method Summary
static byte[] compressTableProperty(TableProperties newTAP)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TableSprmCompressor

public TableSprmCompressor()
Method Detail

compressTableProperty

public static byte[] compressTableProperty(TableProperties newTAP)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableSprmUncompressor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.sprm
Class TableSprmUncompressor

java.lang.Object
    extended by  org.apache.poi.hwpf.sprm.SprmUncompressor
        extended by  org.apache.poi.hwpf.sprm.TableSprmUncompressor

@Internal
public final class TableSprmUncompressor
extends SprmUncompressor

Constructor Summary
TableSprmUncompressor()
Method Summary
static TableProperties | uncompressTAP(byte[] grpprl, int offset) Deprecated.
static TableProperties | uncompressTAP(SprmBuffer sprmBuffer)
Methods inherited from class org.apache.poi.hwpf.sprm.SprmUncompressor
getFlag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TableSprmUncompressor

public TableSprmUncompressor()
Method Detail

uncompressTAP

@Deprecated
public static TableProperties uncompressTAP(byte[] grpprl,
                                                       int offset)
Deprecated.

uncompressTAP

public static TableProperties uncompressTAP(SprmBuffer sprmBuffer)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.hwpf.sprm.CharacterSprmCompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.CharacterSprmCompressor

No usage of org.apache.poi.hwpf.sprm.CharacterSprmCompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.CharacterSprmUncompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.CharacterSprmUncompressor

No usage of org.apache.poi.hwpf.sprm.CharacterSprmUncompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.ParagraphSprmCompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.ParagraphSprmCompressor

No usage of org.apache.poi.hwpf.sprm.ParagraphSprmCompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor

No usage of org.apache.poi.hwpf.sprm.ParagraphSprmUncompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.SectionSprmCompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.SectionSprmCompressor

No usage of org.apache.poi.hwpf.sprm.SectionSprmCompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.SectionSprmUncompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.SectionSprmUncompressor

No usage of org.apache.poi.hwpf.sprm.SectionSprmUncompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.SprmBuffer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.SprmBuffer

Packages that use SprmBuffer
org.apache.poi.hwpf.model
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel

Uses of SprmBuffer in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return SprmBuffer
SprmBuffer[] | ComplexFileTable.getGrpprls()
SprmBuffer | PAPX.getSprmBuf()
SprmBuffer | CHPX.getSprmBuf()
SprmBuffer | CachedPropertyNode.getSprmBuf()

Methods in org.apache.poi.hwpf.model with parameters of type SprmBuffer
void | PAPBinTable.insert(int listIndex, int cpStart, SprmBuffer buf)
void | CHPBinTable.insert(int listIndex, int cpStart, SprmBuffer buf)

Constructors in org.apache.poi.hwpf.model with parameters of type SprmBuffer
CachedPropertyNode(int start, int end, SprmBuffer buf)
CHPX(int fcStart, int fcEnd, CharIndexTranslator translator, SprmBuffer buf)
Deprecated.
PAPX(int fcStart, int fcEnd, CharIndexTranslator translator, SprmBuffer buf, byte[] dataStream)
Deprecated.
PAPX(int charStart, int charEnd, SprmBuffer buf)

Uses of SprmBuffer in org.apache.poi.hwpf.sprm

Methods in org.apache.poi.hwpf.sprm with parameters of type SprmBuffer
static TableProperties TableSprmUncompressor.uncompressTAP(SprmBuffer sprmBuffer)

Uses of SprmBuffer in org.apache.poi.hwpf.usermodel

Fields in org.apache.poi.hwpf.usermodel declared as SprmBuffer
protected  SprmBuffer Paragraph._papx

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.SprmIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.SprmIterator

Packages that use SprmIterator
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.sprm

Uses of SprmIterator in org.apache.poi.hwpf.dev

Methods in org.apache.poi.hwpf.dev with parameters of type SprmIterator
protected  void HWPFLister.dumpSprms(SprmIterator sprmIt, java.lang.String linePrefix)

Uses of SprmIterator in org.apache.poi.hwpf.sprm

Methods in org.apache.poi.hwpf.sprm that return SprmIterator
 SprmIterator SprmBuffer.iterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.SprmOperation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.SprmOperation

Packages that use SprmOperation
org.apache.poi.hwpf.sprm

Uses of SprmOperation in org.apache.poi.hwpf.sprm

Methods in org.apache.poi.hwpf.sprm that return SprmOperation
SprmOperation | SprmBuffer.findSprm(short opcode)
SprmOperation | SprmIterator.next()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.SprmUncompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.SprmUncompressor

Packages that use SprmUncompressor
org.apache.poi.hwpf.sprm

Uses of SprmUncompressor in org.apache.poi.hwpf.sprm

Subclasses of SprmUncompressor in org.apache.poi.hwpf.sprm
class | CharacterSprmUncompressor
class | ParagraphSprmUncompressor
class | SectionSprmUncompressor
class | TableSprmUncompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.SprmUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.SprmUtils

No usage of org.apache.poi.hwpf.sprm.SprmUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.TableSprmCompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.TableSprmCompressor

No usage of org.apache.poi.hwpf.sprm.TableSprmCompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.sprm.TableSprmUncompressor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.sprm.TableSprmUncompressor

No usage of org.apache.poi.hwpf.sprm.TableSprmUncompressor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Bookmark

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface Bookmark

public interface Bookmark

User friendly interface to access information about document bookmarks

Author:
Sergey Vladimirov (vlsergey {at} gmail {doc} com)

Method Summary
int | getEnd()
java.lang.String | getName()
int | getStart()
void | setName(java.lang.String name)

Method Detail

getEnd

int getEnd()

getName

java.lang.String getName()

getStart

int getStart()

setName

void setName(java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Bookmarks

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface Bookmarks

All Known Implementing Classes:
BookmarksImpl
public interface Bookmarks

User-friendly interface to access document bookmarks

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Method Summary
Bookmark | getBookmark(int index)
int | getBookmarksCount()
java.util.Map<java.lang.Integer,java.util.List<Bookmark>> | getBookmarksStartedBetween(int startInclusive, int endExclusive)
void | remove(int index) Remove bookmark from document (but not the bookmark text)

Method Detail

getBookmark

Bookmark getBookmark(int index)
                     throws java.lang.IndexOutOfBoundsException
Parameters:
index - bookmark document index
Returns:
Bookmark with specified index
Throws:
java.lang.IndexOutOfBoundsException - if bookmark with specified index not present in document

getBookmarksCount

int getBookmarksCount()
Returns:
count of Bookmarks in document

getBookmarksStartedBetween

java.util.Map<java.lang.Integer,java.util.List<Bookmark>> getBookmarksStartedBetween(int startInclusive,
                                                                                int endExclusive)
Returns:
Map of bookmarks started in specified range, where key is start position and value is sorted List of Bookmark

remove

void remove(int index)
Remove bookmark from document (but not the bookmark text)

Parameters:
index - bookmark document index to be removed
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BookmarksImpl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class BookmarksImpl

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.BookmarksImpl
All Implemented Interfaces:
Bookmarks
public class BookmarksImpl
extends java.lang.Object
implements Bookmarks

Implementation of user-friendly interface for document bookmarks

Author:
Sergey Vladimirov (vlsergey {at} gmail {doc} com)

Constructor Summary
BookmarksImpl(BookmarksTables bookmarksTables)
Method Summary
Bookmark | getBookmark(int index)
java.util.List<Bookmark> | getBookmarksAt(int startCp)
int | getBookmarksCount()
java.util.Map<java.lang.Integer,java.util.List<Bookmark>> | getBookmarksStartedBetween(int startInclusive, int endExclusive)
void | remove(int index) Remove bookmark from document (but not the bookmark text)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BookmarksImpl

public BookmarksImpl(BookmarksTables bookmarksTables)
Method Detail

getBookmark

public Bookmark getBookmark(int index)
Specified by:
getBookmark in interface Bookmarks
Parameters:
index - bookmark document index
Returns:
Bookmark with specified index

getBookmarksAt

public java.util.List<Bookmark> getBookmarksAt(int startCp)

getBookmarksCount

public int getBookmarksCount()
Specified by:
getBookmarksCount in interface Bookmarks
Returns:
count of Bookmarks in document

getBookmarksStartedBetween

public java.util.Map<java.lang.Integer,java.util.List<Bookmark>> getBookmarksStartedBetween(int startInclusive,
                                                                                int endExclusive)
Specified by:
getBookmarksStartedBetween in interface Bookmarks
Returns:
Map of bookmarks started in specified range, where key is start position and value is sorted List of Bookmark

remove

public void remove(int index)
Description copied from interface: Bookmarks
Remove bookmark from document (but not the bookmark text)

Specified by:
remove in interface Bookmarks
Parameters:
index - bookmark document index to be removed
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BorderCode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class BorderCode

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.BorderCode
All Implemented Interfaces:
java.lang.Cloneable
public final class BorderCode
extends java.lang.Object
implements java.lang.Cloneable

Mapping class for BRC80 structure (Border Code for Word 97)

Comments are copied out from the binary format specification.

Field Summary
static int SIZE
Constructor Summary
BorderCode()
BorderCode(byte[] buf, int offset)
Method Summary
java.lang.Object | clone()
boolean | equals(java.lang.Object o)
int | getBorderType() Border type code: 0 none 1 single 2 thick 3 double 5 hairline 6 dot 7 dash large gap 8 dot dash 9 dot dot dash 10 triple 11 thin-thick small gap 12 thick-thin small gap 13 thin-thick-thin small gap 14 thin-thick medium gap 15 thick-thin medium gap 16 thin-thick-thin medium gap 17 thin-thick large gap 18 thick-thin large gap 19 thin-thick-thin large gap 20 wave 21 double wave 22 dash small gap 23 dash dot stroked 24 emboss 3D 25 engrave 3D codes 64 - 230 represent border art types and are used only for page borders
short | getColor() Color: 0 Auto 1 Black 2 Blue 3 Cyan 4 Green 5 Magenta 6 Red 7 Yellow 8 White 9 DkBlue 10 DkCyan 11 DkGreen 12 DkMagenta 13 DkRed 14 DkYellow 15 DkGray 16 LtGray
int | getLineWidth() Width of a single line in 1/8 pt, max of 32 pt.
int | getSpace() Width of space to maintain between border and text within border.
boolean | isEmpty()
boolean | isFrame() Don't reverse the border.
boolean | isShadow() When true, border is drawn with shadow Must be false when BRC is a substructure of the TC.
void | serialize(byte[] buf, int offset)
void | setBorderType(int borderType)
void | setColor(short color)
void | setFrame(boolean frame)
void | setLineWidth(int lineWidth)
void | setShadow(boolean shadow)
void | setSpace(int space)
int | toInt()
java.lang.String | toString()
Methods inherited from class java.lang.Object
finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values
Constructor Detail

BorderCode

public BorderCode()

BorderCode

public BorderCode(byte[] buf,
                  int offset)
Method Detail

serialize

public void serialize(byte[] buf,
                      int offset)

toInt

public int toInt()

isEmpty

public boolean isEmpty()

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

getLineWidth

public int getLineWidth()
Width of a single line in 1/8 pt, max of 32 pt.

setLineWidth

public void setLineWidth(int lineWidth)

getBorderType

public int getBorderType()
Border type code:
  • 0 none
  • 1 single
  • 2 thick
  • 3 double
  • 5 hairline
  • 6 dot
  • 7 dash large gap
  • 8 dot dash
  • 9 dot dot dash
  • 10 triple
  • 11 thin-thick small gap
  • 12 thick-thin small gap
  • 13 thin-thick-thin small gap
  • 14 thin-thick medium gap
  • 15 thick-thin medium gap
  • 16 thin-thick-thin medium gap
  • 17 thin-thick large gap
  • 18 thick-thin large gap
  • 19 thin-thick-thin large gap
  • 20 wave
  • 21 double wave
  • 22 dash small gap
  • 23 dash dot stroked
  • 24 emboss 3D
  • 25 engrave 3D
  • codes 64 - 230 represent border art types and are used only for page borders

    • setBorderType

    public void setBorderType(int borderType)

    getColor

    public short getColor()
    Color:
  • 0 Auto
  • 1 Black
  • 2 Blue
  • 3 Cyan
  • 4 Green
  • 5 Magenta
  • 6 Red
  • 7 Yellow
  • 8 White
  • 9 DkBlue
  • 10 DkCyan
  • 11 DkGreen
  • 12 DkMagenta
  • 13 DkRed
  • 14 DkYellow
  • 15 DkGray
  • 16 LtGray

    • setColor

    public void setColor(short color)

    getSpace

    public int getSpace()
    Width of space to maintain between border and text within border.

    Must be 0 when BRC is a substructure of TC.

    Stored in points.

    setSpace

    public void setSpace(int space)

    isShadow

    public boolean isShadow()
    When true, border is drawn with shadow Must be false when BRC is a substructure of the TC.

    setShadow

    public void setShadow(boolean shadow)

    isFrame

    public boolean isFrame()
    Don't reverse the border.

    setFrame

    public void setFrame(boolean frame)

    toString

    public java.lang.String toString()
    Overrides:
    toString in class java.lang.Object
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharacterProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class CharacterProperties

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.CHPAbstractType
        extended by  org.apache.poi.hwpf.usermodel.CharacterProperties
All Implemented Interfaces:
java.lang.Cloneable
public final class CharacterProperties
extends CHPAbstractType
implements java.lang.Cloneable

Author:
Ryan Ackley

Field Summary
static short | SPRM_BRC
static short | SPRM_CCV change chp.cv
static short | SPRM_CHARSCALE
static short | SPRM_CPG
static short | SPRM_DISPFLDRMARK
static short | SPRM_DTTMRMARK
static short | SPRM_DTTMRMARKDEL
static short | SPRM_DXASPACE
static short | SPRM_FBOLD
static short | SPRM_FCAPS
static short | SPRM_FDATA
static short | SPRM_FDSTRIKE
static short | SPRM_FELID
static short | SPRM_FEMBOSS
static short | SPRM_FFLDVANISH
static short | SPRM_FIMPRINT
static short | SPRM_FITALIC
static short | SPRM_FOBJ
static short | SPRM_FOLE2
static short | SPRM_FOUTLINE
static short | SPRM_FRMARK
static short | SPRM_FRMARKDEL
static short | SPRM_FSHADOW
static short | SPRM_FSMALLCAPS
static short | SPRM_FSPEC
static short | SPRM_FSTRIKE
static short | SPRM_FVANISH
static short | SPRM_HIGHLIGHT
static short | SPRM_HPS
static short | SPRM_HPSKERN
static short | SPRM_HPSPOS
static short | SPRM_IBSTRMARK
static short | SPRM_IBSTRMARKDEL
static short | SPRM_ICO
static short | SPRM_IDCTHINT
static short | SPRM_IDSIRMARKDEL
static short | SPRM_ISS
static short | SPRM_ISTD
static short | SPRM_KUL
static short | SPRM_LID
static short | SPRM_NONFELID
static short | SPRM_OBJLOCATION
static short | SPRM_PICLOCATION
static short | SPRM_PROPRMARK
static short | SPRM_RGFTCASCII
static short | SPRM_RGFTCFAREAST
static short | SPRM_RGFTCNOTFAREAST
static short | SPRM_SFXTEXT
static short | SPRM_SHD
static short | SPRM_SYMBOL
static short | SPRM_YSRI
Fields inherited from class org.apache.poi.hwpf.model.types.CHPAbstractType
field_1_grpfChp, field_10_pctCharWidth, field_11_lidDefault, field_12_lidFE, field_13_kcd, field_14_fUndetermine, field_15_iss, field_16_fSpecSymbol, field_17_idct, field_18_idctHint, field_19_kul, field_2_hps, field_20_hresi, field_21_hpsKern, field_22_hpsPos, field_23_shd, field_24_brc, field_25_ibstRMark, field_26_sfxtText, field_27_fDblBdr, field_28_fBorderWS, field_29_ufel, field_3_ftcAscii, field_30_copt, field_31_hpsAsci, field_32_hpsFE, field_33_hpsBi, field_34_ftcSym, field_35_xchSym, field_36_fcPic, field_37_fcObj, field_38_lTagObj, field_39_fcData, field_4_ftcFE, field_40_hresiOld, field_41_ibstRMarkDel, field_42_dttmRMark, field_43_dttmRMarkDel, field_44_istd, field_45_idslRMReason, field_46_idslReasonDel, field_47_cpg, field_48_Highlight, field_49_CharsetFlags, field_5_ftcOther, field_50_chse, field_51_fPropRMark, field_52_ibstPropRMark, field_53_dttmPropRMark, field_54_fConflictOrig, field_55_fConflictOtherDel, field_56_wConflict, field_57_IbstConflict, field_58_dttmConflict, field_59_fDispFldRMark, field_6_ftcBi, field_60_ibstDispFldRMark, field_61_dttmDispFldRMark, field_62_xstDispFldRMark, field_63_fcObjp, field_64_lbrCRJ, field_65_fSpecVanish, field_66_fHasOldProps, field_67_fSdtVanish, field_68_wCharScale, field_7_dxaSpace, field_8_cv, field_9_ico, ISS_NONE, ISS_SUBSCRIPTED, ISS_SUPERSCRIPTED, KCD_CIRCLE, KCD_COMMA, KCD_DOT, KCD_NON, KCD_UNDER_DOT, KUL_BY_WORD, KUL_DASH, KUL_DASH_LONG, KUL_DASH_LONG_HEAVY, KUL_DASHED_HEAVY, KUL_DOT, KUL_DOT_DASH, KUL_DOT_DASH_HEAVY, KUL_DOT_DOT_DASH, KUL_DOT_DOT_DASH_HEAVY, KUL_DOTTED, KUL_DOTTED_HEAVY, KUL_DOUBLE, KUL_HIDDEN, KUL_NONE, KUL_SINGLE, KUL_THICK, KUL_WAVE, KUL_WAVE_DOUBLE, KUL_WAVE_HEAVY, LBRCRJ_BOTH, LBRCRJ_LEFT, LBRCRJ_NONE, LBRCRJ_RIGHT, SFXTTEXT_BACKGROUND_BLINK, SFXTTEXT_LAS_VEGAS_LIGHTS, SFXTTEXT_MARCHING_ANTS, SFXTTEXT_MARCHING_RED_ANTS, SFXTTEXT_NO, SFXTTEXT_SHIMMER, SFXTTEXT_SPARKLE_TEXT
Constructor Summary
CharacterProperties()
Method Summary
java.lang.Object | clone()
int | getCharacterSpacing()
int | getColor()
int | getFontSize()
int | getIco24() Get the ico24 field for the CHP record.
int | getKerning()
short | getSubSuperScriptIndex()
int | getUnderlineCode()
int | getVerticalOffset()
boolean | isBold()
boolean | isCapitalized()
boolean | isDoubleStrikeThrough()
boolean | isEmbossed()
boolean | isFldVanished()
boolean | isHighlighted()
boolean | isImprinted()
boolean | isItalic()
boolean | isMarkedDeleted()
boolean | isMarkedInserted()
boolean | isOutlined()
boolean | isShadowed()
boolean | isSmallCaps()
boolean | isStrikeThrough()
boolean | isVanished()
void | markDeleted(boolean mark)
void | markInserted(boolean mark)
void | setBold(boolean bold)
void | setCapitalized(boolean caps)
void | setCharacterSpacing(int twips)
void | setColor(int color)
void | setDoubleStrikeThrough(boolean dstrike)
void | setEmbossed(boolean emboss)
void | setFldVanish(boolean fldVanish)
void | setFontSize(int halfPoints)
void | setHighlighted(byte color)
void | setIco24(int colour24) Set the ico24 field for the CHP record.
void | setImprinted(boolean imprint)
void | setItalic(boolean italic)
void | setKerning(int kern)
void | setOutline(boolean outlined)
void | setShadow(boolean shadow)
void | setSmallCaps(boolean smallCaps)
void | setSubSuperScriptIndex(short iss)
void | setUnderlineCode(int kul)
void | setVanished(boolean vanish)
void | setVerticalOffset(int hpsPos)
void | strikeThrough(boolean strike)
Methods inherited from class org.apache.poi.hwpf.model.types.CHPAbstractType
getBrc, getCharsetFlags, getChse, getCopt, getCpg, getCv, getDttmConflict, getDttmDispFldRMark, getDttmPropRMark, getDttmRMark, getDttmRMarkDel, getDxaSpace, getFBorderWS, getFcData, getFcObj, getFcObjp, getFConflictOrig, getFConflictOtherDel, getFcPic, getFDblBdr, getFDispFldRMark, getFHasOldProps, getFPropRMark, getFSdtVanish, getFSpecSymbol, getFSpecVanish, getFtcAscii, getFtcBi, getFtcFE, getFtcOther, getFtcSym, getFUndetermine, getGrpfChp, getHighlight, getHps, getHpsAsci, getHpsBi, getHpsFE, getHpsKern, getHpsPos, getHresi, getHresiOld, getIbstConflict, getIbstDispFldRMark, getIbstPropRMark, getIbstRMark, getIbstRMarkDel, getIco, getIcoHighlight, getIdct, getIdctHint, getIdslReasonDel, getIdslRMReason, getIss, getIstd, getItypFELayout, getIWarichuBracket, getKcd, getKul, getLbrCRJ, getLidDefault, getLidFE, getLTagObj, getPctCharWidth, getSfxtText, getShd, getSpare, getUfel, getWCharScale, getWConflict, getXchSym, getXstDispFldRMark, isFBiDi, isFBold, isFBoldBi, isFCaps, isFCellFitText, isFChsDiff, isFComplexScripts, isFData, isFDStrike, isFEmboss, isFFldVanish, isFHighlight, isFImprint, isFItalic, isFItalicBi, isFKumimoji, isFLowerCase, isFLSFitText, isFMacChs, isFObj, isFOle2, isFOutline, isFRMark, isFRMarkDel, isFRuby, isFShadow, isFSmallCaps, isFSpec, isFStrike, isFTNY, isFTNYCompress, isFTNYFetchTxm, isFUsePgsuSettings, isFVanish, isFWarichu, isFWarichuNoOpenBracket, isUnused, setBrc, setCharsetFlags, setChse, setCopt, setCpg, setCv, setDttmConflict, setDttmDispFldRMark, setDttmPropRMark, setDttmRMark, setDttmRMarkDel, setDxaSpace, setFBiDi, setFBold, setFBoldBi, setFBorderWS, setFCaps, setFcData, setFCellFitText, setFChsDiff, setFcObj, setFcObjp, setFComplexScripts, setFConflictOrig, setFConflictOtherDel, setFcPic, setFData, setFDblBdr, setFDispFldRMark, setFDStrike, setFEmboss, setFFldVanish, setFHasOldProps, setFHighlight, setFImprint, setFItalic, setFItalicBi, setFKumimoji, setFLowerCase, setFLSFitText, setFMacChs, setFObj, setFOle2, setFOutline, setFPropRMark, setFRMark, setFRMarkDel, setFRuby, setFSdtVanish, setFShadow, setFSmallCaps, setFSpec, setFSpecSymbol, setFSpecVanish, setFStrike, setFtcAscii, setFtcBi, setFtcFE, setFtcOther, setFtcSym, setFTNY, setFTNYCompress, setFTNYFetchTxm, setFUndetermine, setFUsePgsuSettings, setFVanish, setFWarichu, setFWarichuNoOpenBracket, setGrpfChp, setHighlight, setHps, setHpsAsci, setHpsBi, setHpsFE, setHpsKern, setHpsPos, setHresi, setHresiOld, setIbstConflict, setIbstDispFldRMark, setIbstPropRMark, setIbstRMark, setIbstRMarkDel, setIco, setIcoHighlight, setIdct, setIdctHint, setIdslReasonDel, setIdslRMReason, setIss, setIstd, setItypFELayout, setIWarichuBracket, setKcd, setKul, setLbrCRJ, setLidDefault, setLidFE, setLTagObj, setPctCharWidth, setSfxtText, setShd, setSpare, setUfel, setUnused, setWCharScale, setWConflict, setXchSym, setXstDispFldRMark, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SPRM_FRMARKDEL

public static final short SPRM_FRMARKDEL
See Also:
Constant Field Values

SPRM_FRMARK

public static final short SPRM_FRMARK
See Also:
Constant Field Values

SPRM_FFLDVANISH

public static final short SPRM_FFLDVANISH
See Also:
Constant Field Values

SPRM_PICLOCATION

public static final short SPRM_PICLOCATION
See Also:
Constant Field Values

SPRM_IBSTRMARK

public static final short SPRM_IBSTRMARK
See Also:
Constant Field Values

SPRM_DTTMRMARK

public static final short SPRM_DTTMRMARK
See Also:
Constant Field Values

SPRM_FDATA

public static final short SPRM_FDATA
See Also:
Constant Field Values

SPRM_SYMBOL

public static final short SPRM_SYMBOL
See Also:
Constant Field Values

SPRM_FOLE2

public static final short SPRM_FOLE2
See Also:
Constant Field Values

SPRM_HIGHLIGHT

public static final short SPRM_HIGHLIGHT
See Also:
Constant Field Values

SPRM_OBJLOCATION

public static final short SPRM_OBJLOCATION
See Also:
Constant Field Values

SPRM_ISTD

public static final short SPRM_ISTD
See Also:
Constant Field Values

SPRM_FBOLD

public static final short SPRM_FBOLD
See Also:
Constant Field Values

SPRM_FITALIC

public static final short SPRM_FITALIC
See Also:
Constant Field Values

SPRM_FSTRIKE

public static final short SPRM_FSTRIKE
See Also:
Constant Field Values

SPRM_FOUTLINE

public static final short SPRM_FOUTLINE
See Also:
Constant Field Values

SPRM_FSHADOW

public static final short SPRM_FSHADOW
See Also:
Constant Field Values

SPRM_FSMALLCAPS

public static final short SPRM_FSMALLCAPS
See Also:
Constant Field Values

SPRM_FCAPS

public static final short SPRM_FCAPS
See Also:
Constant Field Values

SPRM_FVANISH

public static final short SPRM_FVANISH
See Also:
Constant Field Values

SPRM_KUL

public static final short SPRM_KUL
See Also:
Constant Field Values

SPRM_DXASPACE

public static final short SPRM_DXASPACE
See Also:
Constant Field Values

SPRM_LID

public static final short SPRM_LID
See Also:
Constant Field Values

SPRM_ICO

public static final short SPRM_ICO
See Also:
Constant Field Values

SPRM_HPS

public static final short SPRM_HPS
See Also:
Constant Field Values

SPRM_HPSPOS

public static final short SPRM_HPSPOS
See Also:
Constant Field Values

SPRM_ISS

public static final short SPRM_ISS
See Also:
Constant Field Values

SPRM_HPSKERN

public static final short SPRM_HPSKERN
See Also:
Constant Field Values

SPRM_YSRI

public static final short SPRM_YSRI
See Also:
Constant Field Values

SPRM_RGFTCASCII

public static final short SPRM_RGFTCASCII
See Also:
Constant Field Values

SPRM_RGFTCFAREAST

public static final short SPRM_RGFTCFAREAST
See Also:
Constant Field Values

SPRM_RGFTCNOTFAREAST

public static final short SPRM_RGFTCNOTFAREAST
See Also:
Constant Field Values

SPRM_CHARSCALE

public static final short SPRM_CHARSCALE
See Also:
Constant Field Values

SPRM_FDSTRIKE

public static final short SPRM_FDSTRIKE
See Also:
Constant Field Values

SPRM_FIMPRINT

public static final short SPRM_FIMPRINT
See Also:
Constant Field Values

SPRM_FSPEC

public static final short SPRM_FSPEC
See Also:
Constant Field Values

SPRM_FOBJ

public static final short SPRM_FOBJ
See Also:
Constant Field Values

SPRM_PROPRMARK

public static final short SPRM_PROPRMARK
See Also:
Constant Field Values

SPRM_FEMBOSS

public static final short SPRM_FEMBOSS
See Also:
Constant Field Values

SPRM_SFXTEXT

public static final short SPRM_SFXTEXT
See Also:
Constant Field Values

SPRM_DISPFLDRMARK

public static final short SPRM_DISPFLDRMARK
See Also:
Constant Field Values

SPRM_IBSTRMARKDEL

public static final short SPRM_IBSTRMARKDEL
See Also:
Constant Field Values

SPRM_DTTMRMARKDEL

public static final short SPRM_DTTMRMARKDEL
See Also:
Constant Field Values

SPRM_BRC

public static final short SPRM_BRC
See Also:
Constant Field Values

SPRM_SHD

public static final short SPRM_SHD
See Also:
Constant Field Values

SPRM_IDSIRMARKDEL

public static final short SPRM_IDSIRMARKDEL
See Also:
Constant Field Values

SPRM_CPG

public static final short SPRM_CPG
See Also:
Constant Field Values

SPRM_NONFELID

public static final short SPRM_NONFELID
See Also:
Constant Field Values

SPRM_FELID

public static final short SPRM_FELID
See Also:
Constant Field Values

SPRM_IDCTHINT

public static final short SPRM_IDCTHINT
See Also:
Constant Field Values

SPRM_CCV

public static final short SPRM_CCV
change chp.cv

See Also:
Constant Field Values
Constructor Detail

CharacterProperties

public CharacterProperties()
Method Detail

isMarkedDeleted

public boolean isMarkedDeleted()

markDeleted

public void markDeleted(boolean mark)

isBold

public boolean isBold()

setBold

public void setBold(boolean bold)

isItalic

public boolean isItalic()

setItalic

public void setItalic(boolean italic)

isOutlined

public boolean isOutlined()

setOutline

public void setOutline(boolean outlined)

isFldVanished

public boolean isFldVanished()

setFldVanish

public void setFldVanish(boolean fldVanish)

isSmallCaps

public boolean isSmallCaps()

setSmallCaps

public void setSmallCaps(boolean smallCaps)

isCapitalized

public boolean isCapitalized()

setCapitalized

public void setCapitalized(boolean caps)

isVanished

public boolean isVanished()

setVanished

public void setVanished(boolean vanish)

isMarkedInserted

public boolean isMarkedInserted()

markInserted

public void markInserted(boolean mark)

isStrikeThrough

public boolean isStrikeThrough()

strikeThrough

public void strikeThrough(boolean strike)

isShadowed

public boolean isShadowed()

setShadow

public void setShadow(boolean shadow)

isEmbossed

public boolean isEmbossed()

setEmbossed

public void setEmbossed(boolean emboss)

isImprinted

public boolean isImprinted()

setImprinted

public void setImprinted(boolean imprint)

isDoubleStrikeThrough

public boolean isDoubleStrikeThrough()

setDoubleStrikeThrough

public void setDoubleStrikeThrough(boolean dstrike)

getFontSize

public int getFontSize()

setFontSize

public void setFontSize(int halfPoints)

getCharacterSpacing

public int getCharacterSpacing()

setCharacterSpacing

public void setCharacterSpacing(int twips)

getSubSuperScriptIndex

public short getSubSuperScriptIndex()

setSubSuperScriptIndex

public void setSubSuperScriptIndex(short iss)

getUnderlineCode

public int getUnderlineCode()

setUnderlineCode

public void setUnderlineCode(int kul)

getColor

public int getColor()

setColor

public void setColor(int color)

getVerticalOffset

public int getVerticalOffset()

setVerticalOffset

public void setVerticalOffset(int hpsPos)

getKerning

public int getKerning()

setKerning

public void setKerning(int kern)

isHighlighted

public boolean isHighlighted()

setHighlighted

public void setHighlighted(byte color)

getIco24

public int getIco24()
Get the ico24 field for the CHP record.

setIco24

public void setIco24(int colour24)
Set the ico24 field for the CHP record.

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharacterRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class CharacterRun

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.CharacterRun
All Implemented Interfaces:
java.lang.Cloneable
public final class CharacterRun
extends Range
implements java.lang.Cloneable

This class represents a run of text that share common properties.

Author:
Ryan Ackley

Field Summary
static short | SPRM_BRC
static short | SPRM_CHARSCALE
static short | SPRM_CPG
static short | SPRM_DISPFLDRMARK
static short | SPRM_DTTMRMARK
static short | SPRM_DTTMRMARKDEL
static short | SPRM_DXASPACE
static short | SPRM_FBOLD
static short | SPRM_FCAPS
static short | SPRM_FDATA
static short | SPRM_FDSTRIKE
static short | SPRM_FELID
static short | SPRM_FEMBOSS
static short | SPRM_FFLDVANISH
static short | SPRM_FIMPRINT
static short | SPRM_FITALIC
static short | SPRM_FOBJ
static short | SPRM_FOLE2
static short | SPRM_FOUTLINE
static short | SPRM_FRMARK
static short | SPRM_FRMARKDEL
static short | SPRM_FSHADOW
static short | SPRM_FSMALLCAPS
static short | SPRM_FSPEC
static short | SPRM_FSTRIKE
static short | SPRM_FVANISH
static short | SPRM_HIGHLIGHT
static short | SPRM_HPS
static short | SPRM_HPSKERN
static short | SPRM_HPSPOS
static short | SPRM_IBSTRMARK
static short | SPRM_IBSTRMARKDEL
static short | SPRM_ICO
static short | SPRM_IDCTHINT
static short | SPRM_IDSIRMARKDEL
static short | SPRM_ISS
static short | SPRM_ISTD
static short | SPRM_KUL
static short | SPRM_LID
static short | SPRM_NONFELID
static short | SPRM_OBJLOCATION
static short | SPRM_PICLOCATION
static short | SPRM_PROPRMARK
static short | SPRM_RGFTCASCII
static short | SPRM_RGFTCFAREAST
static short | SPRM_RGFTCNOTFAREAST
static short | SPRM_SFXTEXT
static short | SPRM_SHD
static short | SPRM_SYMBOL
static short | SPRM_YSRI
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Method Summary
java.lang.Object | clone() Used to create a deep copy of this object.
CharacterProperties | cloneProperties() Deprecated. This method shall not be public and should not be called from high-level code
BorderCode | getBorder()
int | getCharacterSpacing()
int | getColor()
java.lang.String | getFontName()
int | getFontSize()
byte | getHighlightedColor()
int | getIco24() Get the ico24 field for the CHP record.
int | getKerning()
int | getLanguageCode()
int | getObjOffset()
int | getPicOffset()
short | getSubSuperScriptIndex()
char | getSymbolCharacter() Returns the symbol character, if this is a symbol character run.
Ffn | getSymbolFont() Returns the symbol font, if this is a symbol character run.
int | getUnderlineCode()
int | getVerticalOffset()
boolean | isBold()
boolean | isCapitalized()
boolean | isData() Does the picture offset represent picture or binary data? If it's set, then the picture offset refers to a NilPICFAndBinData structure, otherwise to a PICFAndOfficeArtData
boolean | isDoubleStrikeThrough()
boolean | isEmbossed()
boolean | isFldVanished()
boolean | isHighlighted()
boolean | isImprinted()
boolean | isItalic()
boolean | isMarkedDeleted()
boolean | isMarkedInserted()
boolean | isObj()
boolean | isOle2()
boolean | isOutlined()
boolean | isShadowed()
boolean | isSmallCaps()
boolean | isSpecialCharacter()
boolean | isStrikeThrough()
boolean | isSymbol() Returns true, if the CharacterRun is a special character run containing a symbol, otherwise false.
boolean | isVanished()
void | markDeleted(boolean mark)
void | markInserted(boolean mark)
void | setBold(boolean bold)
void | setCapitalized(boolean caps)
void | setCharacterSpacing(int twips)
void | setColor(int color)
void | setData(boolean data)
void | setDoubleStrikethrough(boolean dstrike)
void | setEmbossed(boolean emboss)
void | setFldVanish(boolean fldVanish)
void | setFontSize(int halfPoints)
void | setFtcAscii(int ftcAscii)
void | setFtcFE(int ftcFE)
void | setFtcOther(int ftcOther)
void | setHighlighted(byte color)
void | setIco24(int colour24) Set the ico24 field for the CHP record.
void | setImprinted(boolean imprint)
void | setItalic(boolean italic)
void | setKerning(int kern)
void | setObj(boolean obj)
void | setObjOffset(int obj)
void | setOle2(boolean ole)
void | setOutline(boolean outlined)
void | setPicOffset(int offset)
void | setShadow(boolean shadow)
void | setSmallCaps(boolean smallCaps)
void | setSpecialCharacter(boolean spec)
void | setSubSuperScriptIndex(short iss)
void | setUnderlineCode(int kul)
void | setVanished(boolean vanish)
void | setVerticalOffset(int hpsPos)
void | strikeThrough(boolean strike)
java.lang.String | toString()
int | type() Here for runtime type determination using a switch statement convenient.
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, reset, sanityCheck, stripFields, text, usesUnicode
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SPRM_FRMARKDEL

public static final short SPRM_FRMARKDEL
See Also:
Constant Field Values

SPRM_FRMARK

public static final short SPRM_FRMARK
See Also:
Constant Field Values

SPRM_FFLDVANISH

public static final short SPRM_FFLDVANISH
See Also:
Constant Field Values

SPRM_PICLOCATION

public static final short SPRM_PICLOCATION
See Also:
Constant Field Values

SPRM_IBSTRMARK

public static final short SPRM_IBSTRMARK
See Also:
Constant Field Values

SPRM_DTTMRMARK

public static final short SPRM_DTTMRMARK
See Also:
Constant Field Values

SPRM_FDATA

public static final short SPRM_FDATA
See Also:
Constant Field Values

SPRM_SYMBOL

public static final short SPRM_SYMBOL
See Also:
Constant Field Values

SPRM_FOLE2

public static final short SPRM_FOLE2
See Also:
Constant Field Values

SPRM_HIGHLIGHT

public static final short SPRM_HIGHLIGHT
See Also:
Constant Field Values

SPRM_OBJLOCATION

public static final short SPRM_OBJLOCATION
See Also:
Constant Field Values

SPRM_ISTD

public static final short SPRM_ISTD
See Also:
Constant Field Values

SPRM_FBOLD

public static final short SPRM_FBOLD
See Also:
Constant Field Values

SPRM_FITALIC

public static final short SPRM_FITALIC
See Also:
Constant Field Values

SPRM_FSTRIKE

public static final short SPRM_FSTRIKE
See Also:
Constant Field Values

SPRM_FOUTLINE

public static final short SPRM_FOUTLINE
See Also:
Constant Field Values

SPRM_FSHADOW

public static final short SPRM_FSHADOW
See Also:
Constant Field Values

SPRM_FSMALLCAPS

public static final short SPRM_FSMALLCAPS
See Also:
Constant Field Values

SPRM_FCAPS

public static final short SPRM_FCAPS
See Also:
Constant Field Values

SPRM_FVANISH

public static final short SPRM_FVANISH
See Also:
Constant Field Values

SPRM_KUL

public static final short SPRM_KUL
See Also:
Constant Field Values

SPRM_DXASPACE

public static final short SPRM_DXASPACE
See Also:
Constant Field Values

SPRM_LID

public static final short SPRM_LID
See Also:
Constant Field Values

SPRM_ICO

public static final short SPRM_ICO
See Also:
Constant Field Values

SPRM_HPS

public static final short SPRM_HPS
See Also:
Constant Field Values

SPRM_HPSPOS

public static final short SPRM_HPSPOS
See Also:
Constant Field Values

SPRM_ISS

public static final short SPRM_ISS
See Also:
Constant Field Values

SPRM_HPSKERN

public static final short SPRM_HPSKERN
See Also:
Constant Field Values

SPRM_YSRI

public static final short SPRM_YSRI
See Also:
Constant Field Values

SPRM_RGFTCASCII

public static final short SPRM_RGFTCASCII
See Also:
Constant Field Values

SPRM_RGFTCFAREAST

public static final short SPRM_RGFTCFAREAST
See Also:
Constant Field Values

SPRM_RGFTCNOTFAREAST

public static final short SPRM_RGFTCNOTFAREAST
See Also:
Constant Field Values

SPRM_CHARSCALE

public static final short SPRM_CHARSCALE
See Also:
Constant Field Values

SPRM_FDSTRIKE

public static final short SPRM_FDSTRIKE
See Also:
Constant Field Values

SPRM_FIMPRINT

public static final short SPRM_FIMPRINT
See Also:
Constant Field Values

SPRM_FSPEC

public static final short SPRM_FSPEC
See Also:
Constant Field Values

SPRM_FOBJ

public static final short SPRM_FOBJ
See Also:
Constant Field Values

SPRM_PROPRMARK

public static final short SPRM_PROPRMARK
See Also:
Constant Field Values

SPRM_FEMBOSS

public static final short SPRM_FEMBOSS
See Also:
Constant Field Values

SPRM_SFXTEXT

public static final short SPRM_SFXTEXT
See Also:
Constant Field Values

SPRM_DISPFLDRMARK

public static final short SPRM_DISPFLDRMARK
See Also:
Constant Field Values

SPRM_IBSTRMARKDEL

public static final short SPRM_IBSTRMARKDEL
See Also:
Constant Field Values

SPRM_DTTMRMARKDEL

public static final short SPRM_DTTMRMARKDEL
See Also:
Constant Field Values

SPRM_BRC

public static final short SPRM_BRC
See Also:
Constant Field Values

SPRM_SHD

public static final short SPRM_SHD
See Also:
Constant Field Values

SPRM_IDSIRMARKDEL

public static final short SPRM_IDSIRMARKDEL
See Also:
Constant Field Values

SPRM_CPG

public static final short SPRM_CPG
See Also:
Constant Field Values

SPRM_NONFELID

public static final short SPRM_NONFELID
See Also:
Constant Field Values

SPRM_FELID

public static final short SPRM_FELID
See Also:
Constant Field Values

SPRM_IDCTHINT

public static final short SPRM_IDCTHINT
See Also:
Constant Field Values
Method Detail

type

public int type()
Here for runtime type determination using a switch statement convenient.

Overrides:
type in class Range
Returns:
TYPE_CHARACTER

isMarkedDeleted

public boolean isMarkedDeleted()

markDeleted

public void markDeleted(boolean mark)

isBold

public boolean isBold()

setBold

public void setBold(boolean bold)

isItalic

public boolean isItalic()

setItalic

public void setItalic(boolean italic)

isOutlined

public boolean isOutlined()

setOutline

public void setOutline(boolean outlined)

isFldVanished

public boolean isFldVanished()

setFldVanish

public void setFldVanish(boolean fldVanish)

isSmallCaps

public boolean isSmallCaps()

setSmallCaps

public void setSmallCaps(boolean smallCaps)

isCapitalized

public boolean isCapitalized()

setCapitalized

public void setCapitalized(boolean caps)

isVanished

public boolean isVanished()

setVanished

public void setVanished(boolean vanish)

isMarkedInserted

public boolean isMarkedInserted()

markInserted

public void markInserted(boolean mark)

isStrikeThrough

public boolean isStrikeThrough()

strikeThrough

public void strikeThrough(boolean strike)

isShadowed

public boolean isShadowed()

setShadow

public void setShadow(boolean shadow)

isEmbossed

public boolean isEmbossed()

setEmbossed

public void setEmbossed(boolean emboss)

isImprinted

public boolean isImprinted()

setImprinted

public void setImprinted(boolean imprint)

isDoubleStrikeThrough

public boolean isDoubleStrikeThrough()

setDoubleStrikethrough

public void setDoubleStrikethrough(boolean dstrike)

setFtcAscii

public void setFtcAscii(int ftcAscii)

setFtcFE

public void setFtcFE(int ftcFE)

setFtcOther

public void setFtcOther(int ftcOther)

getFontSize

public int getFontSize()

setFontSize

public void setFontSize(int halfPoints)

getCharacterSpacing

public int getCharacterSpacing()

setCharacterSpacing

public void setCharacterSpacing(int twips)

getSubSuperScriptIndex

public short getSubSuperScriptIndex()

setSubSuperScriptIndex

public void setSubSuperScriptIndex(short iss)

getUnderlineCode

public int getUnderlineCode()

setUnderlineCode

public void setUnderlineCode(int kul)

getColor

public int getColor()

setColor

public void setColor(int color)

getVerticalOffset

public int getVerticalOffset()

setVerticalOffset

public void setVerticalOffset(int hpsPos)

getKerning

public int getKerning()

setKerning

public void setKerning(int kern)

isHighlighted

public boolean isHighlighted()

getHighlightedColor

public byte getHighlightedColor()

setHighlighted

public void setHighlighted(byte color)

getFontName

public java.lang.String getFontName()

isSpecialCharacter

public boolean isSpecialCharacter()

setSpecialCharacter

public void setSpecialCharacter(boolean spec)

isObj

public boolean isObj()

setObj

public void setObj(boolean obj)

getPicOffset

public int getPicOffset()

setPicOffset

public void setPicOffset(int offset)

isData

public boolean isData()
Does the picture offset represent picture or binary data? If it's set, then the picture offset refers to a NilPICFAndBinData structure, otherwise to a PICFAndOfficeArtData

setData

public void setData(boolean data)

isOle2

public boolean isOle2()

setOle2

public void setOle2(boolean ole)

getObjOffset

public int getObjOffset()

setObjOffset

public void setObjOffset(int obj)

getIco24

public int getIco24()
Get the ico24 field for the CHP record.

setIco24

public void setIco24(int colour24)
Set the ico24 field for the CHP record.

cloneProperties

@Deprecated
public CharacterProperties cloneProperties()
Deprecated. This method shall not be public and should not be called from high-level code

clone the CharacterProperties object associated with this characterRun so that you can apply it to another CharacterRun

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Used to create a deep copy of this object.

Overrides:
clone in class java.lang.Object
Returns:
A deep copy.
Throws:
java.lang.CloneNotSupportedException - never

isSymbol

public boolean isSymbol()
Returns true, if the CharacterRun is a special character run containing a symbol, otherwise false.

In case of a symbol, the Range.text() method always returns a single character 0x0028, but word actually stores the character in a different field. Use getSymbolCharacter() to get that character and getSymbolFont() to determine its font.

getSymbolCharacter

public char getSymbolCharacter()
Returns the symbol character, if this is a symbol character run.

Throws:
java.lang.IllegalStateException - If this is not a symbol character run: call isSymbol() first.
See Also:
isSymbol()

getSymbolFont

public Ffn getSymbolFont()
Returns the symbol font, if this is a symbol character run. Might return null, if the font index is not found in the font table.

Throws:
java.lang.IllegalStateException - If this is not a symbol character run: call isSymbol() first.
See Also:
isSymbol()

getBorder

public BorderCode getBorder()

getLanguageCode

public int getLanguageCode()

toString

public java.lang.String toString()
Overrides:
toString in class Range
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateAndTime

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class DateAndTime

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.DateAndTime
All Implemented Interfaces:
java.lang.Cloneable
public final class DateAndTime
extends java.lang.Object
implements java.lang.Cloneable

This class is used to represent a date and time in a Word document.

Author:
Ryan Ackley

Field Summary
static int SIZE
Constructor Summary
DateAndTime()
DateAndTime(byte[] buf, int offset)
Method Summary
java.lang.Object | clone()
boolean | equals(java.lang.Object o)
java.util.Calendar | getDate()
boolean | isEmpty()
void | serialize(byte[] buf, int offset)
java.lang.String | toString()
Methods inherited from class java.lang.Object
finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values
Constructor Detail

DateAndTime

public DateAndTime()

DateAndTime

public DateAndTime(byte[] buf,
                   int offset)
Method Detail

getDate

public java.util.Calendar getDate()

serialize

public void serialize(byte[] buf,
                      int offset)

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

isEmpty

public boolean isEmpty()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentPosition

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class DocumentPosition

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.DocumentPosition

public final class DocumentPosition
extends Range

Field Summary
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Constructor Summary
DocumentPosition(HWPFDocument doc, int pos)
Method Summary
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, reset, sanityCheck, stripFields, text, toString, type, usesUnicode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DocumentPosition

public DocumentPosition(HWPFDocument doc,
                        int pos)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DropCapSpecifier

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class DropCapSpecifier

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.DropCapSpecifier
All Implemented Interfaces:
java.lang.Cloneable
public final class DropCapSpecifier
extends java.lang.Object
implements java.lang.Cloneable

This data structure is used by a paragraph to determine how it should drop its first letter. I think its the visual effect that will show a giant first letter to a paragraph. I've seen this used in the first paragraph of a book

Author:
Ryan Ackley

Constructor Summary
DropCapSpecifier()
DropCapSpecifier(byte[] buf, int offset)
DropCapSpecifier(short fdct)
Method Summary
DropCapSpecifier | clone()
boolean | equals(java.lang.Object obj)
byte | getCountOfLinesToDrop()
byte | getDropCapType()
int | hashCode()
boolean | isEmpty()
void | setCountOfLinesToDrop(byte value)
void | setDropCapType(byte value)
short | toShort()
java.lang.String | toString()
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DropCapSpecifier

public DropCapSpecifier()

DropCapSpecifier

public DropCapSpecifier(byte[] buf,
                        int offset)

DropCapSpecifier

public DropCapSpecifier(short fdct)
Method Detail

clone

public DropCapSpecifier clone()
Overrides:
clone in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

getCountOfLinesToDrop

public byte getCountOfLinesToDrop()

getDropCapType

public byte getDropCapType()

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isEmpty

public boolean isEmpty()

setCountOfLinesToDrop

public void setCountOfLinesToDrop(byte value)

setDropCapType

public void setDropCapType(byte value)

toShort

public short toShort()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Field

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface Field

public interface Field

Method Summary
Range | firstSubrange(Range parent)
int | getFieldEndOffset()
int | getFieldStartOffset()
CharacterRun | getMarkEndCharacterRun(Range parent)
int | getMarkEndOffset()
CharacterRun | getMarkSeparatorCharacterRun(Range parent)
int | getMarkSeparatorOffset()
CharacterRun | getMarkStartCharacterRun(Range parent)
int | getMarkStartOffset()
int | getType()
boolean | hasSeparator()
boolean | isHasSep()
boolean | isLocked()
boolean | isNested()
boolean | isPrivateResult()
boolean | isResultDirty()
boolean | isResultEdited()
boolean | isZombieEmbed()
Range | secondSubrange(Range parent)

Method Detail

firstSubrange

Range firstSubrange(Range parent)

getFieldEndOffset

int getFieldEndOffset()
Returns:
character position of first character after field (i.e. getMarkEndOffset() + 1)

getFieldStartOffset

int getFieldStartOffset()
Returns:
character position of first character in field (i.e. getFieldStartOffset())

getMarkEndCharacterRun

CharacterRun getMarkEndCharacterRun(Range parent)

getMarkEndOffset

int getMarkEndOffset()
Returns:
character position of end field mark

getMarkSeparatorCharacterRun

CharacterRun getMarkSeparatorCharacterRun(Range parent)

getMarkSeparatorOffset

int getMarkSeparatorOffset()
Returns:
character position of separator field mark (if present, NullPointerException otherwise)

getMarkStartCharacterRun

CharacterRun getMarkStartCharacterRun(Range parent)

getMarkStartOffset

int getMarkStartOffset()
Returns:
character position of start field mark

getType

int getType()

hasSeparator

boolean hasSeparator()

isHasSep

boolean isHasSep()

isLocked

boolean isLocked()

isNested

boolean isNested()

isPrivateResult

boolean isPrivateResult()

isResultDirty

boolean isResultDirty()

isResultEdited

boolean isResultEdited()

isZombieEmbed

boolean isZombieEmbed()

secondSubrange

Range secondSubrange(Range parent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fields

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface Fields

All Known Implementing Classes:
FieldsImpl
public interface Fields

User-friendly interface to access document Fields

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Method Summary
Field | getFieldByStartOffset(FieldsDocumentPart documentPart, int offset)
java.util.Collection<Field> | getFields(FieldsDocumentPart part)

Method Detail

getFieldByStartOffset

Field getFieldByStartOffset(FieldsDocumentPart documentPart,
                            int offset)

getFields

java.util.Collection<Field> getFields(FieldsDocumentPart part)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldsImpl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class FieldsImpl

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.FieldsImpl
All Implemented Interfaces:
Fields
@Internal
public class FieldsImpl
extends java.lang.Object
implements Fields

Default implementation of Field

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Constructor Summary
FieldsImpl(FieldsTables fieldsTables)
Method Summary
org.apache.poi.hwpf.usermodel.FieldImpl | getFieldByStartOffset(FieldsDocumentPart documentPart, int offset)
java.util.Collection<Field> | getFields(FieldsDocumentPart part)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FieldsImpl

public FieldsImpl(FieldsTables fieldsTables)
Method Detail

getFields

public java.util.Collection<Field> getFields(FieldsDocumentPart part)
Specified by:
getFields in interface Fields

getFieldByStartOffset

public org.apache.poi.hwpf.usermodel.FieldImpl getFieldByStartOffset(FieldsDocumentPart documentPart,
                                                                     int offset)
Specified by:
getFieldByStartOffset in interface Fields
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderStories

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class HeaderStories

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.HeaderStories

public final class HeaderStories
extends java.lang.Object

A HeaderStory is a Header, a Footer, or footnote/endnote separator. All the Header Stories get stored in the same Range in the document, and this handles getting out all the individual parts. WARNING - you shouldn't change the headers or footers, as offsets are not yet updated!

Constructor Summary
HeaderStories(HWPFDocument doc)
Method Summary
boolean | areFieldsStripped() Are fields currently being stripped from the text that this HeaderStories returns? Default is false, but can be changed
java.lang.String | getEndnoteContNote() Deprecated.
Range | getEndnoteContNoteSubrange()
java.lang.String | getEndnoteContSeparator() Deprecated.
Range | getEndnoteContSeparatorSubrange()
java.lang.String | getEndnoteSeparator() Deprecated.
Range | getEndnoteSeparatorSubrange()
java.lang.String | getEvenFooter() Deprecated.
Range | getEvenFooterSubrange()
java.lang.String | getEvenHeader() Deprecated.
Range | getEvenHeaderSubrange()
java.lang.String | getFirstFooter() Deprecated.
Range | getFirstFooterSubrange()
java.lang.String | getFirstHeader() Deprecated.
Range | getFirstHeaderSubrange()
java.lang.String | getFooter(int pageNumber) Returns the correct, defined footer for the given one based page
java.lang.String | getFootnoteContNote() Deprecated.
Range | getFootnoteContNoteSubrange()
java.lang.String | getFootnoteContSeparator() Deprecated.
Range | getFootnoteContSeparatorSubrange()
java.lang.String | getFootnoteSeparator() Deprecated.
Range | getFootnoteSeparatorSubrange()
java.lang.String | getHeader(int pageNumber) Returns the correct, defined header for the given one based page
java.lang.String | getOddFooter() Deprecated.
Range | getOddFooterSubrange()
java.lang.String | getOddHeader() Deprecated.
Range | getOddHeaderSubrange()
protected PlexOfCps | getPlcfHdd()
Range | getRange()
void | setAreFieldsStripped(boolean stripFields) Should fields (eg macros) be stripped from the text that this class returns? Default is not to strip.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HeaderStories

public HeaderStories(HWPFDocument doc)
Method Detail

getFootnoteSeparator

@Deprecated
public java.lang.String getFootnoteSeparator()
Deprecated.

getFootnoteContSeparator

@Deprecated
public java.lang.String getFootnoteContSeparator()
Deprecated.

getFootnoteContNote

@Deprecated
public java.lang.String getFootnoteContNote()
Deprecated.

getEndnoteSeparator

@Deprecated
public java.lang.String getEndnoteSeparator()
Deprecated.

getEndnoteContSeparator

@Deprecated
public java.lang.String getEndnoteContSeparator()
Deprecated.

getEndnoteContNote

@Deprecated
public java.lang.String getEndnoteContNote()
Deprecated.

getFootnoteSeparatorSubrange

public Range getFootnoteSeparatorSubrange()

getFootnoteContSeparatorSubrange

public Range getFootnoteContSeparatorSubrange()

getFootnoteContNoteSubrange

public Range getFootnoteContNoteSubrange()

getEndnoteSeparatorSubrange

public Range getEndnoteSeparatorSubrange()

getEndnoteContSeparatorSubrange

public Range getEndnoteContSeparatorSubrange()

getEndnoteContNoteSubrange

public Range getEndnoteContNoteSubrange()

getEvenHeader

@Deprecated
public java.lang.String getEvenHeader()
Deprecated.

getOddHeader

@Deprecated
public java.lang.String getOddHeader()
Deprecated.

getFirstHeader

@Deprecated
public java.lang.String getFirstHeader()
Deprecated.

getEvenHeaderSubrange

public Range getEvenHeaderSubrange()

getOddHeaderSubrange

public Range getOddHeaderSubrange()

getFirstHeaderSubrange

public Range getFirstHeaderSubrange()

getHeader

public java.lang.String getHeader(int pageNumber)
Returns the correct, defined header for the given one based page

Parameters:
pageNumber - The one based page number

getEvenFooter

@Deprecated
public java.lang.String getEvenFooter()
Deprecated.

getOddFooter

@Deprecated
public java.lang.String getOddFooter()
Deprecated.

getFirstFooter

@Deprecated
public java.lang.String getFirstFooter()
Deprecated.

getEvenFooterSubrange

public Range getEvenFooterSubrange()

getOddFooterSubrange

public Range getOddFooterSubrange()

getFirstFooterSubrange

public Range getFirstFooterSubrange()

getFooter

public java.lang.String getFooter(int pageNumber)
Returns the correct, defined footer for the given one based page

Parameters:
pageNumber - The one based page number

getRange

public Range getRange()

getPlcfHdd

protected PlexOfCps getPlcfHdd()

areFieldsStripped

public boolean areFieldsStripped()
Are fields currently being stripped from the text that this HeaderStories returns? Default is false, but can be changed

setAreFieldsStripped

public void setAreFieldsStripped(boolean stripFields)
Should fields (eg macros) be stripped from the text that this class returns? Default is not to strip.

Parameters:
stripFields -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HWPFList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class HWPFList

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.HWPFList

public final class HWPFList
extends java.lang.Object

This class is used to create a list in a Word document. It is used in conjunction with registerList in HWPFDocument. In Word, lists are not ranged entities, meaning you can't actually add one to the document. Lists only act as properties for list entries. Once you register a list, you can add list entries to a document that are a part of the list. The only benefit of this that I see, is that you can add a list entry anywhere in the document and continue numbering from the previous list.

Author:
Ryan Ackley

Constructor Summary
HWPFList(boolean numbered, StyleSheet styleSheet)
Method Summary
ListData | getListData()
ListFormatOverride | getOverride()
void | setLevelNumberProperties(int level, CharacterProperties chp) Sets the character properties of the list numbers.
void | setLevelParagraphProperties(int level, ParagraphProperties pap) Sets the paragraph properties for a particular level of the list.
void | setLevelStyle(int level, int styleIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HWPFList

public HWPFList(boolean numbered,
                StyleSheet styleSheet)
Parameters:
numbered - true if the list should be numbered; false if it should be bulleted.
styleSheet - The document's stylesheet.
Method Detail

setLevelNumberProperties

public void setLevelNumberProperties(int level,
                                     CharacterProperties chp)
Sets the character properties of the list numbers.

Parameters:
level - the level number that the properties should apply to.
chp - The character properties.

setLevelParagraphProperties

public void setLevelParagraphProperties(int level,
                                        ParagraphProperties pap)
Sets the paragraph properties for a particular level of the list.

Parameters:
level - The level number.
pap - The paragraph properties

setLevelStyle

public void setLevelStyle(int level,
                          int styleIndex)

getListData

public ListData getListData()

getOverride

public ListFormatOverride getOverride()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineSpacingDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class LineSpacingDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.LineSpacingDescriptor
All Implemented Interfaces:
java.lang.Cloneable
public final class LineSpacingDescriptor
extends java.lang.Object
implements java.lang.Cloneable

This class is used to determine line spacing for a paragraph.

Author:
Ryan Ackley

Constructor Summary
LineSpacingDescriptor()
LineSpacingDescriptor(byte[] buf, int offset)
Method Summary
java.lang.Object | clone()
boolean | equals(java.lang.Object o)
boolean | isEmpty()
void | serialize(byte[] buf, int offset)
void | setDyaLine(short dyaLine)
void | setMultiLinespace(short fMultiLinespace)
int | toInt()
java.lang.String | toString()
Methods inherited from class java.lang.Object
finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LineSpacingDescriptor

public LineSpacingDescriptor()

LineSpacingDescriptor

public LineSpacingDescriptor(byte[] buf,
                             int offset)
Method Detail

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

setMultiLinespace

public void setMultiLinespace(short fMultiLinespace)

toInt

public int toInt()

serialize

public void serialize(byte[] buf,
                      int offset)

setDyaLine

public void setDyaLine(short dyaLine)

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

isEmpty

public boolean isEmpty()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListEntry

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class ListEntry

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.Paragraph
            extended by  org.apache.poi.hwpf.usermodel.ListEntry
All Implemented Interfaces:
java.lang.Cloneable
public final class ListEntry
extends Paragraph

Field Summary
Fields inherited from class org.apache.poi.hwpf.usermodel.Paragraph
_istd, _papx, _props, SPRM_ANLD, SPRM_AUTOSPACEDE, SPRM_AUTOSPACEDN, SPRM_BRCBAR, SPRM_BRCBOTTOM, SPRM_BRCL, SPRM_BRCLEFT, SPRM_BRCP, SPRM_BRCRIGHT, SPRM_BRCTOP, SPRM_CHGTABS, SPRM_CHGTABSPAPX, SPRM_CRLF, SPRM_DCS, SPRM_DXAABS, SPRM_DXAFROMTEXT, SPRM_DXALEFT, SPRM_DXALEFT1, SPRM_DXARIGHT, SPRM_DXAWIDTH, SPRM_DYAABS, SPRM_DYAAFTER, SPRM_DYABEFORE, SPRM_DYAFROMTEXT, SPRM_DYALINE, SPRM_FADJUSTRIGHT, SPRM_FBIDI, SPRM_FINTABLE, SPRM_FKEEP, SPRM_FKEEPFOLLOW, SPRM_FKINSOKU, SPRM_FLOCKED, SPRM_FNOAUTOHYPH, SPRM_FNOLINENUMB, SPRM_FNUMRMLNS, SPRM_FOVERFLOWPUNCT, SPRM_FPAGEBREAKBEFORE, SPRM_FRAMETEXTFLOW, SPRM_FSIDEBYSIDE, SPRM_FTOPLINEPUNCT, SPRM_FTTP, SPRM_FWIDOWCONTROL, SPRM_FWORDWRAP, SPRM_ILFO, SPRM_ILVL, SPRM_JC, SPRM_NUMRM, SPRM_OUTLVL, SPRM_PC, SPRM_PROPRMARK, SPRM_RULER, SPRM_SHD, SPRM_SHD80, SPRM_USEPGSUSETTINGS, SPRM_WALIGNFONT, SPRM_WHEIGHTABS, SPRM_WR
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Method Summary
 int type()
Deprecated.
Methods inherited from class org.apache.poi.hwpf.usermodel.Paragraph
clone, cloneProperties, getBarBorder, getBottomBorder, getDropCap, getFirstLineIndent, getFontAlignment, getIlfo, getIlvl, getIndentFromLeft, getIndentFromRight, getJustification, getLeftBorder, getLineSpacing, getLvl, getRightBorder, getShading, getSpacingAfter, getSpacingBefore, getStyleIndex, getTableLevel, getTabStopsNumber, getTabStopsPositions, getTopBorder, isAutoHyphenated, isBackward, isEmbeddedCellMark, isInTable, isKinsoku, isLineNotNumbered, isSideBySide, isTableRowEnd, isVertical, isWidowControlled, isWordWrapped, keepOnPage, keepWithNext, newParagraph_applyStyleProperties, pageBreakBefore, setAutoHyphenated, setBackward, setBarBorder, setBottomBorder, setDropCap, setFirstLineIndent, setFontAlignment, setIndentFromLeft, setIndentFromRight, setJustification, setKeepOnPage, setKeepWithNext, setKinsoku, setLeftBorder, setLineNotNumbered, setLineSpacing, setPageBreakBefore, setRightBorder, setShading, setSideBySide, setSpacingAfter, setSpacingBefore, setTopBorder, setVertical, setWidowControl, setWordWrapped, toString
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, reset, sanityCheck, stripFields, text, usesUnicode
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

type

@Deprecated
public int type()
Deprecated.

Description copied from class: Range
This method is used to determine the type. Handy for switch statements compared to the instanceof operator.

Overrides:
type in class Paragraph
Returns:
A TYPE constant.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Notes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface Notes

All Known Implementing Classes:
NotesImpl
public interface Notes

User-friendly interface to access document notes information

Author:
Sergey Vladimirov (vlsergey {at} gmail {doc} com)

Method Summary
int | getNoteAnchorPosition(int index) Returns the location of note anchor in main textspace
int | getNoteIndexByAnchorPosition(int anchorPosition) Returns index of note (if exists, otherwise -1) with specified anchor position
int | getNotesCount() Returns count of notes in document
int | getNoteTextEndOffset(int index) Returns the end offset of the text corresponding to the reference within the footnote text address space
int | getNoteTextStartOffset(int index) Returns the start offset of the text corresponding to the reference within the footnote text address space

Method Detail

getNoteAnchorPosition

int getNoteAnchorPosition(int index)
Returns the location of note anchor in main textspace

getNotesCount

int getNotesCount()
Returns count of notes in document

getNoteIndexByAnchorPosition

int getNoteIndexByAnchorPosition(int anchorPosition)
Returns index of note (if exists, otherwise -1) with specified anchor position

getNoteTextEndOffset

int getNoteTextEndOffset(int index)
Returns the end offset of the text corresponding to the reference within the footnote text address space

getNoteTextStartOffset

int getNoteTextStartOffset(int index)
Returns the start offset of the text corresponding to the reference within the footnote text address space

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotesImpl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class NotesImpl

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.NotesImpl
All Implemented Interfaces:
Notes
public class NotesImpl
extends java.lang.Object
implements Notes

Default implementation of Notes interface

Author:
Sergey Vladimirov (vlsergey {at} gmail {doc} com)

Constructor Summary
NotesImpl(NotesTables notesTables)
Method Summary
int | getNoteAnchorPosition(int index) Returns the location of note anchor in main textspace
int | getNoteIndexByAnchorPosition(int anchorPosition) Returns index of note (if exists, otherwise -1) with specified anchor position
int | getNotesCount() Returns count of notes in document
int | getNoteTextEndOffset(int index) Returns the end offset of the text corresponding to the reference within the footnote text address space
int | getNoteTextStartOffset(int index) Returns the start offset of the text corresponding to the reference within the footnote text address space
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotesImpl

public NotesImpl(NotesTables notesTables)
Method Detail

getNoteAnchorPosition

public int getNoteAnchorPosition(int index)
Description copied from interface: Notes
Returns the location of note anchor in main textspace

Specified by:
getNoteAnchorPosition in interface Notes

getNoteIndexByAnchorPosition

public int getNoteIndexByAnchorPosition(int anchorPosition)
Description copied from interface: Notes
Returns index of note (if exists, otherwise -1) with specified anchor position

Specified by:
getNoteIndexByAnchorPosition in interface Notes

getNotesCount

public int getNotesCount()
Description copied from interface: Notes
Returns count of notes in document

Specified by:
getNotesCount in interface Notes

getNoteTextEndOffset

public int getNoteTextEndOffset(int index)
Description copied from interface: Notes
Returns the end offset of the text corresponding to the reference within the footnote text address space

Specified by:
getNoteTextEndOffset in interface Notes

getNoteTextStartOffset

public int getNoteTextStartOffset(int index)
Description copied from interface: Notes
Returns the start offset of the text corresponding to the reference within the footnote text address space

Specified by:
getNoteTextStartOffset in interface Notes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectPoolImpl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class ObjectPoolImpl

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.ObjectPoolImpl
All Implemented Interfaces:
ObjectsPool
@Internal
public class ObjectPoolImpl
extends java.lang.Object
implements ObjectsPool

Constructor Summary
ObjectPoolImpl(DirectoryEntry _objectPool)
Method Summary
Entry | getObjectById(java.lang.String objId)
void | writeTo(DirectoryEntry directoryEntry)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectPoolImpl

public ObjectPoolImpl(DirectoryEntry _objectPool)
Method Detail

getObjectById

public Entry getObjectById(java.lang.String objId)
Specified by:
getObjectById in interface ObjectsPool

writeTo

@Internal
public void writeTo(DirectoryEntry directoryEntry)
             throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectsPool

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface ObjectsPool

All Known Implementing Classes:
ObjectPoolImpl
public interface ObjectsPool

Method Summary
 Entry getObjectById(java.lang.String objId)

Method Detail

getObjectById

Entry getObjectById(java.lang.String objId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OfficeDrawing.HorizontalPositioning

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.usermodel
Enum OfficeDrawing.HorizontalPositioning

java.lang.Object
    extended by  java.lang.Enum<OfficeDrawing.HorizontalPositioning>
        extended by  org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalPositioning
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<OfficeDrawing.HorizontalPositioning>
Enclosing interface:
OfficeDrawing
public static enum OfficeDrawing.HorizontalPositioning
extends java.lang.Enum<OfficeDrawing.HorizontalPositioning>

Enum Constant Summary
ABSOLUTE
The shape is horizontally offset by an absolute distance from the page element.
CENTER
The shape is horizontally positioned at the center of the page element.
INSIDE
The shape is horizontally positioned like LEFT on odd-numbered pages and like RIGHT on even-numbered pages.
LEFT
The shape is horizontally positioned at the left side of the page element.
OUTSIDE
The shape is horizontally positioned like RIGHT on odd-numbered pages and like LEFT on even-numbered pages.
RIGHT
The shape is horizontally positioned at the right side of the page element.
Method Summary
static OfficeDrawing.HorizontalPositioning | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.HorizontalPositioning[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ABSOLUTE

public static final OfficeDrawing.HorizontalPositioning ABSOLUTE
The shape is horizontally offset by an absolute distance from the page element.

CENTER

public static final OfficeDrawing.HorizontalPositioning CENTER
The shape is horizontally positioned at the center of the page element.

INSIDE

public static final OfficeDrawing.HorizontalPositioning INSIDE
The shape is horizontally positioned like LEFT on odd-numbered pages and like RIGHT on even-numbered pages.

LEFT

public static final OfficeDrawing.HorizontalPositioning LEFT
The shape is horizontally positioned at the left side of the page element.

OUTSIDE

public static final OfficeDrawing.HorizontalPositioning OUTSIDE
The shape is horizontally positioned like RIGHT on odd-numbered pages and like LEFT on even-numbered pages.

RIGHT

public static final OfficeDrawing.HorizontalPositioning RIGHT
The shape is horizontally positioned at the right side of the page element.

Method Detail

values

public static OfficeDrawing.HorizontalPositioning[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (OfficeDrawing.HorizontalPositioning c : OfficeDrawing.HorizontalPositioning.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static OfficeDrawing.HorizontalPositioning valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


OfficeDrawing.HorizontalRelativeElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.usermodel
Enum OfficeDrawing.HorizontalRelativeElement

java.lang.Object
    extended by  java.lang.Enum<OfficeDrawing.HorizontalRelativeElement>
        extended by  org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalRelativeElement
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<OfficeDrawing.HorizontalRelativeElement>
Enclosing interface:
OfficeDrawing
public static enum OfficeDrawing.HorizontalRelativeElement
extends java.lang.Enum<OfficeDrawing.HorizontalRelativeElement>

Enum Constant Summary
CHAR
MARGIN
PAGE
TEXT
Method Summary
static OfficeDrawing.HorizontalRelativeElement | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.HorizontalRelativeElement[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

CHAR

public static final OfficeDrawing.HorizontalRelativeElement CHAR

MARGIN

public static final OfficeDrawing.HorizontalRelativeElement MARGIN

PAGE

public static final OfficeDrawing.HorizontalRelativeElement PAGE

TEXT

public static final OfficeDrawing.HorizontalRelativeElement TEXT
Method Detail

values

public static OfficeDrawing.HorizontalRelativeElement[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (OfficeDrawing.HorizontalRelativeElement c : OfficeDrawing.HorizontalRelativeElement.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static OfficeDrawing.HorizontalRelativeElement valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


OfficeDrawing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface OfficeDrawing

public interface OfficeDrawing

User-friendly interface to office drawing objects.

Some properties and enumeration constants description are quotes from the following sources:

  • [MS-ODRAW] -- v20110608; Office Drawing Binary File Format; Copyright (c) 2011 Microsoft Corporation.

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Nested Class Summary
static class | OfficeDrawing.HorizontalPositioning
static class | OfficeDrawing.HorizontalRelativeElement
static class | OfficeDrawing.VerticalPositioning
static class | OfficeDrawing.VerticalRelativeElement
Method Summary
OfficeDrawing.HorizontalPositioning | getHorizontalPositioning() Returns the type of horizontal positioning to use for a shape
OfficeDrawing.HorizontalRelativeElement | getHorizontalRelative() Specifies a page element relative to which a shape is horizontally positioned
EscherContainerRecord | getOfficeArtSpContainer() Returns escher record that represent shape container (record type is 0xF004).
byte[] | getPictureData() Returns picture data if this shape has (single?) associated picture data
int | getRectangleBottom() Bottom of the rectangle enclosing shape relative to the origin of the shape
int | getRectangleLeft() Left of rectangle enclosing shape relative to the origin of the shape
int | getRectangleRight() Right of rectangle enclosing shape relative to the origin of the shape
int | getRectangleTop() Top of rectangle enclosing shape relative to the origin of the shape
int | getShapeId() Shape Identifier
OfficeDrawing.VerticalPositioning | getVerticalPositioning() Specifies the type of vertical positioning to use for a shape
OfficeDrawing.VerticalRelativeElement | getVerticalRelativeElement() Specifies a page element relative to which a shape is vertically positioned

Method Detail

getHorizontalPositioning

OfficeDrawing.HorizontalPositioning getHorizontalPositioning()
Returns the type of horizontal positioning to use for a shape

Returns:
the type of horizontal positioning to use for a shape

getHorizontalRelative

OfficeDrawing.HorizontalRelativeElement getHorizontalRelative()
Specifies a page element relative to which a shape is horizontally positioned

Returns:
a page element relative to which a shape is horizontally positioned

getOfficeArtSpContainer

EscherContainerRecord getOfficeArtSpContainer()
Returns escher record that represent shape container (record type is 0xF004). Returned record has a child with record type 0xF00A and value of shape id equals to getShapeId().

Returns:
Returns office art shape container or null if not found

getPictureData

byte[] getPictureData()
Returns picture data if this shape has (single?) associated picture data

getRectangleBottom

int getRectangleBottom()
Bottom of the rectangle enclosing shape relative to the origin of the shape

getRectangleLeft

int getRectangleLeft()
Left of rectangle enclosing shape relative to the origin of the shape

getRectangleRight

int getRectangleRight()
Right of rectangle enclosing shape relative to the origin of the shape

getRectangleTop

int getRectangleTop()
Top of rectangle enclosing shape relative to the origin of the shape

getShapeId

int getShapeId()
Shape Identifier

getVerticalPositioning

OfficeDrawing.VerticalPositioning getVerticalPositioning()
Specifies the type of vertical positioning to use for a shape

Returns:
return the type of vertical positioning to use for a shape

getVerticalRelativeElement

OfficeDrawing.VerticalRelativeElement getVerticalRelativeElement()
Specifies a page element relative to which a shape is vertically positioned

Returns:
a page element relative to which a shape is vertically positioned
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OfficeDrawing.VerticalPositioning

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.usermodel
Enum OfficeDrawing.VerticalPositioning

java.lang.Object
    extended by  java.lang.Enum<OfficeDrawing.VerticalPositioning>
        extended by  org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalPositioning
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<OfficeDrawing.VerticalPositioning>
Enclosing interface:
OfficeDrawing
public static enum OfficeDrawing.VerticalPositioning
extends java.lang.Enum<OfficeDrawing.VerticalPositioning>

Enum Constant Summary
ABSOLUTE
The shape is vertically offset by an absolute distance from the page element
BOTTOM
The shape is vertically positioned at the bottom of the page element
CENTER
The shape is vertically positioned in the center of the page element
INSIDE
The shape is vertically positioned like msopvTop on odd-numbered pages and like msopvBottom on even-numbered pages
OUTSIDE
The shape is vertically positioned like BOTTOM on odd-numbered pages and like TOP on even-numbered pages
TOP
The shape is vertically positioned at the top of the page element
Method Summary
static OfficeDrawing.VerticalPositioning | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.VerticalPositioning[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ABSOLUTE

public static final OfficeDrawing.VerticalPositioning ABSOLUTE
The shape is vertically offset by an absolute distance from the page element

BOTTOM

public static final OfficeDrawing.VerticalPositioning BOTTOM
The shape is vertically positioned at the bottom of the page element

CENTER

public static final OfficeDrawing.VerticalPositioning CENTER
The shape is vertically positioned in the center of the page element

INSIDE

public static final OfficeDrawing.VerticalPositioning INSIDE
The shape is vertically positioned like msopvTop on odd-numbered pages and like msopvBottom on even-numbered pages

OUTSIDE

public static final OfficeDrawing.VerticalPositioning OUTSIDE
The shape is vertically positioned like BOTTOM on odd-numbered pages and like TOP on even-numbered pages

TOP

public static final OfficeDrawing.VerticalPositioning TOP
The shape is vertically positioned at the top of the page element

Method Detail

values

public static OfficeDrawing.VerticalPositioning[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (OfficeDrawing.VerticalPositioning c : OfficeDrawing.VerticalPositioning.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static OfficeDrawing.VerticalPositioning valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


OfficeDrawing.VerticalRelativeElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.usermodel
Enum OfficeDrawing.VerticalRelativeElement

java.lang.Object
    extended by  java.lang.Enum<OfficeDrawing.VerticalRelativeElement>
        extended by  org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalRelativeElement
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<OfficeDrawing.VerticalRelativeElement>
Enclosing interface:
OfficeDrawing
public static enum OfficeDrawing.VerticalRelativeElement
extends java.lang.Enum<OfficeDrawing.VerticalRelativeElement>

Enum Constant Summary
LINE
MARGIN
PAGE
TEXT
Method Summary
static OfficeDrawing.VerticalRelativeElement | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.VerticalRelativeElement[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LINE

public static final OfficeDrawing.VerticalRelativeElement LINE

MARGIN

public static final OfficeDrawing.VerticalRelativeElement MARGIN

PAGE

public static final OfficeDrawing.VerticalRelativeElement PAGE

TEXT

public static final OfficeDrawing.VerticalRelativeElement TEXT
Method Detail

values

public static OfficeDrawing.VerticalRelativeElement[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (OfficeDrawing.VerticalRelativeElement c : OfficeDrawing.VerticalRelativeElement.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static OfficeDrawing.VerticalRelativeElement valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


OfficeDrawings

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Interface OfficeDrawings

All Known Implementing Classes:
OfficeDrawingsImpl
public interface OfficeDrawings

User-friendly interface to access document part's office drawings

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Method Summary
OfficeDrawing | getOfficeDrawingAt(int characterPosition)
java.util.Collection<OfficeDrawing> | getOfficeDrawings()

Method Detail

getOfficeDrawingAt

OfficeDrawing getOfficeDrawingAt(int characterPosition)

getOfficeDrawings

java.util.Collection<OfficeDrawing> getOfficeDrawings()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OfficeDrawingsImpl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class OfficeDrawingsImpl

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl
All Implemented Interfaces:
OfficeDrawings
public class OfficeDrawingsImpl
extends java.lang.Object
implements OfficeDrawings

Constructor Summary
OfficeDrawingsImpl(FSPATable fspaTable, EscherRecordHolder escherRecordHolder, byte[] mainStream)
Method Summary
OfficeDrawing | getOfficeDrawingAt(int characterPosition)
java.util.Collection<OfficeDrawing> | getOfficeDrawings()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OfficeDrawingsImpl

public OfficeDrawingsImpl(FSPATable fspaTable,
                          EscherRecordHolder escherRecordHolder,
                          byte[] mainStream)
Method Detail

getOfficeDrawingAt

public OfficeDrawing getOfficeDrawingAt(int characterPosition)
Specified by:
getOfficeDrawingAt in interface OfficeDrawings

getOfficeDrawings

public java.util.Collection<OfficeDrawing> getOfficeDrawings()
Specified by:
getOfficeDrawings in interface OfficeDrawings
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.hwpf.usermodel
Interfaces
Bookmark
Bookmarks
Field
Fields
Notes
ObjectsPool
OfficeDrawing
OfficeDrawings
Classes
BookmarksImpl
BorderCode
CharacterProperties
CharacterRun
DateAndTime
DocumentPosition
DropCapSpecifier
FieldsImpl
HeaderStories
HWPFList
LineSpacingDescriptor
ListEntry
NotesImpl
ObjectPoolImpl
OfficeDrawingsImpl
Paragraph
ParagraphProperties
Picture
Range
Section
SectionProperties
ShadingDescriptor
ShadingDescriptor80
Shape
Table
TableAutoformatLookSpecifier
TableCell
TableCellDescriptor
TableIterator
TableProperties
TableRow
Enums
OfficeDrawing.HorizontalPositioning
OfficeDrawing.HorizontalRelativeElement
OfficeDrawing.VerticalPositioning
OfficeDrawing.VerticalRelativeElement
PictureType


org.apache.poi.hwpf.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.hwpf.usermodel

Interface Summary
Bookmark | User friendly interface to access information about document bookmarks
Bookmarks | User-friendly interface to access document bookmarks
Field |
Fields | User-friendly interface to access document Fields
Notes | User-friendly interface to access document notes information
ObjectsPool |
OfficeDrawing | User-friendly interface to office drawing objects.
OfficeDrawings | User-friendly interface to access document part's office drawings

Class Summary
BookmarksImpl | Implementation of user-friendly interface for document bookmarks
BorderCode | Mapping class for BRC80 structure (Border Code for Word 97)
CharacterProperties |
CharacterRun | This class represents a run of text that share common properties.
DateAndTime | This class is used to represent a date and time in a Word document.
DocumentPosition |
DropCapSpecifier | This data structure is used by a paragraph to determine how it should drop its first letter.
FieldsImpl | Default implementation of Field
HeaderStories | A HeaderStory is a Header, a Footer, or footnote/endnote separator.
HWPFList | This class is used to create a list in a Word document.
LineSpacingDescriptor | This class is used to determine line spacing for a paragraph.
ListEntry |
NotesImpl | Default implementation of Notes interface
ObjectPoolImpl |
OfficeDrawingsImpl |
Paragraph |
ParagraphProperties |
Picture | Represents embedded picture extracted from Word Document
Range | This class is the central class of the HWPF object model.
Section |
SectionProperties |
ShadingDescriptor | The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
ShadingDescriptor80 | The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.
Shape | Deprecated. Use OfficeDrawing instead
Table |
TableAutoformatLookSpecifier |
TableCell |
TableCellDescriptor |
TableIterator |
TableProperties |
TableRow |

Enum Summary
OfficeDrawing.HorizontalPositioning |
OfficeDrawing.HorizontalRelativeElement |
OfficeDrawing.VerticalPositioning |
OfficeDrawing.VerticalRelativeElement |
PictureType | Picture types supported by MS Word format


org.apache.poi.hwpf.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.hwpf.usermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.hwpf.usermodel.BookmarksImpl (implements org.apache.poi.hwpf.usermodel.Bookmarks)
    • org.apache.poi.hwpf.usermodel.BorderCode (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.CHPAbstractType
      • org.apache.poi.hwpf.usermodel.CharacterProperties (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.usermodel.DateAndTime (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.usermodel.DropCapSpecifier (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.usermodel.FieldsImpl (implements org.apache.poi.hwpf.usermodel.Fields)
    • org.apache.poi.hwpf.usermodel.HeaderStories
    • org.apache.poi.hwpf.usermodel.HWPFList
    • org.apache.poi.hwpf.usermodel.LineSpacingDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.usermodel.NotesImpl (implements org.apache.poi.hwpf.usermodel.Notes)
    • org.apache.poi.hwpf.usermodel.ObjectPoolImpl (implements org.apache.poi.hwpf.usermodel.ObjectsPool)
    • org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl (implements org.apache.poi.hwpf.usermodel.OfficeDrawings)
    • org.apache.poi.hwpf.model.types.PAPAbstractType
      • org.apache.poi.hwpf.usermodel.ParagraphProperties (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.usermodel.Picture
    • org.apache.poi.hwpf.usermodel.Range
      • org.apache.poi.hwpf.usermodel.CharacterRun (implements java.lang.Cloneable)
      • org.apache.poi.hwpf.usermodel.DocumentPosition
      • org.apache.poi.hwpf.usermodel.Paragraph (implements java.lang.Cloneable)
        • org.apache.poi.hwpf.usermodel.ListEntry
      • org.apache.poi.hwpf.usermodel.Section
      • org.apache.poi.hwpf.usermodel.Table
      • org.apache.poi.hwpf.usermodel.TableCell
      • org.apache.poi.hwpf.usermodel.TableRow
    • org.apache.poi.hwpf.model.types.SEPAbstractType
      • org.apache.poi.hwpf.usermodel.SectionProperties
    • org.apache.poi.hwpf.usermodel.Shape
    • org.apache.poi.hwpf.model.types.SHD80AbstractType
      • org.apache.poi.hwpf.usermodel.ShadingDescriptor80 (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.SHDAbstractType
      • org.apache.poi.hwpf.usermodel.ShadingDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.usermodel.TableIterator
    • org.apache.poi.hwpf.model.types.TAPAbstractType
      • org.apache.poi.hwpf.usermodel.TableProperties (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.TCAbstractType
      • org.apache.poi.hwpf.usermodel.TableCellDescriptor (implements java.lang.Cloneable)
    • org.apache.poi.hwpf.model.types.TLPAbstractType (implements org.apache.poi.hdf.model.hdftypes.HDFType)
      • org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier (implements java.lang.Cloneable)

Interface Hierarchy

  • org.apache.poi.hwpf.usermodel.Bookmark
  • org.apache.poi.hwpf.usermodel.Bookmarks
  • org.apache.poi.hwpf.usermodel.Field
  • org.apache.poi.hwpf.usermodel.Fields
  • org.apache.poi.hwpf.usermodel.Notes
  • org.apache.poi.hwpf.usermodel.ObjectsPool
  • org.apache.poi.hwpf.usermodel.OfficeDrawing
  • org.apache.poi.hwpf.usermodel.OfficeDrawings

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.hwpf.usermodel.PictureType
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalPositioning
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalRelativeElement
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalPositioning
      • org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalRelativeElement


Uses of Package org.apache.poi.hwpf.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.hwpf.usermodel

Packages that use org.apache.poi.hwpf.usermodel
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.extractor
org.apache.poi.hwpf.model
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf
Bookmarks
User-friendly interface to access document bookmarks
Fields
User-friendly interface to access document Fields
HWPFList
This class is used to create a list in a Word document.
Notes
User-friendly interface to access document notes information
ObjectPoolImpl
ObjectsPool
OfficeDrawings
User-friendly interface to access document part's office drawings
OfficeDrawingsImpl
Range
This class is the central class of the HWPF object model.

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf.converter
Bookmark
User friendly interface to access information about document bookmarks
BorderCode
Mapping class for BRC80 structure (Border Code for Word 97)
CharacterRun
This class represents a run of text that share common properties.
Field
OfficeDrawing
User-friendly interface to office drawing objects.
Paragraph
Picture
Represents embedded picture extracted from Word Document
PictureType
Picture types supported by MS Word format
Range
This class is the central class of the HWPF object model.
Section
Table
TableCell
TableRow

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf.dev
ParagraphProperties

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf.extractor
Range
This class is the central class of the HWPF object model.

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf.model
CharacterProperties
CharacterRun
This class represents a run of text that share common properties.
ParagraphProperties
Picture
Represents embedded picture extracted from Word Document
SectionProperties
Shape
Deprecated. Use OfficeDrawing instead

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf.model.types
BorderCode
Mapping class for BRC80 structure (Border Code for Word 97)
DateAndTime
This class is used to represent a date and time in a Word document.
DropCapSpecifier
This data structure is used by a paragraph to determine how it should drop its first letter.
LineSpacingDescriptor
This class is used to determine line spacing for a paragraph.
ShadingDescriptor
The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
TableAutoformatLookSpecifier
TableCellDescriptor

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf.sprm
CharacterProperties
ParagraphProperties
SectionProperties
TableProperties

Classes in org.apache.poi.hwpf.usermodel used by org.apache.poi.hwpf.usermodel
Bookmark
User friendly interface to access information about document bookmarks
Bookmarks
User-friendly interface to access document bookmarks
BorderCode
Mapping class for BRC80 structure (Border Code for Word 97)
CharacterProperties
CharacterRun
This class represents a run of text that share common properties.
DropCapSpecifier
This data structure is used by a paragraph to determine how it should drop its first letter.
Field
Fields
User-friendly interface to access document Fields
LineSpacingDescriptor
This class is used to determine line spacing for a paragraph.
ListEntry
Notes
User-friendly interface to access document notes information
ObjectsPool
OfficeDrawing
User-friendly interface to office drawing objects.
OfficeDrawing.HorizontalPositioning
OfficeDrawing.HorizontalRelativeElement
OfficeDrawing.VerticalPositioning
OfficeDrawing.VerticalRelativeElement
OfficeDrawings
User-friendly interface to access document part's office drawings
Paragraph
ParagraphProperties
PictureType
Picture types supported by MS Word format
Range
This class is the central class of the HWPF object model.
Section
ShadingDescriptor
The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
ShadingDescriptor80
The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.
Table
TableAutoformatLookSpecifier
TableCell
TableCellDescriptor
TableProperties
TableRow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Paragraph

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class Paragraph

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.Paragraph
All Implemented Interfaces:
java.lang.Cloneable
Direct Known Subclasses:
ListEntry
public class Paragraph
extends Range
implements java.lang.Cloneable

Field Summary
protected short | _istd
protected SprmBuffer | _papx
protected ParagraphProperties | _props
static short | SPRM_ANLD
static short | SPRM_AUTOSPACEDE
static short | SPRM_AUTOSPACEDN
static short | SPRM_BRCBAR
static short | SPRM_BRCBOTTOM
static short | SPRM_BRCL
static short | SPRM_BRCLEFT
static short | SPRM_BRCP
static short | SPRM_BRCRIGHT
static short | SPRM_BRCTOP
static short | SPRM_CHGTABS
static short | SPRM_CHGTABSPAPX
static short | SPRM_CRLF
static short | SPRM_DCS
static short | SPRM_DXAABS
static short | SPRM_DXAFROMTEXT
static short | SPRM_DXALEFT
static short | SPRM_DXALEFT1
static short | SPRM_DXARIGHT
static short | SPRM_DXAWIDTH
static short | SPRM_DYAABS
static short | SPRM_DYAAFTER
static short | SPRM_DYABEFORE
static short | SPRM_DYAFROMTEXT
static short | SPRM_DYALINE
static short | SPRM_FADJUSTRIGHT
static short | SPRM_FBIDI
static short | SPRM_FINTABLE
static short | SPRM_FKEEP
static short | SPRM_FKEEPFOLLOW
static short | SPRM_FKINSOKU
static short | SPRM_FLOCKED
static short | SPRM_FNOAUTOHYPH
static short | SPRM_FNOLINENUMB
static short | SPRM_FNUMRMLNS
static short | SPRM_FOVERFLOWPUNCT
static short | SPRM_FPAGEBREAKBEFORE
static short | SPRM_FRAMETEXTFLOW
static short | SPRM_FSIDEBYSIDE
static short | SPRM_FTOPLINEPUNCT
static short | SPRM_FTTP
static short | SPRM_FWIDOWCONTROL
static short | SPRM_FWORDWRAP
static short | SPRM_ILFO
static short | SPRM_ILVL
static short | SPRM_JC
static short | SPRM_NUMRM
static short | SPRM_OUTLVL
static short | SPRM_PC
static short | SPRM_PROPRMARK
static short | SPRM_RULER
static short | SPRM_SHD
static short | SPRM_SHD80
static short | SPRM_USEPGSUSETTINGS
static short | SPRM_WALIGNFONT
static short | SPRM_WHEIGHTABS
static short | SPRM_WR
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Constructor Summary
protected | Paragraph(int startIdxInclusive, int endIdxExclusive, Table parent) Deprecated.
protected | Paragraph(PAPX papx, Range parent) Deprecated.
protected | Paragraph(PAPX papx, Range parent, int start) Deprecated.
Method Summary
java.lang.Object | clone()
ParagraphProperties | cloneProperties() clone the ParagraphProperties object associated with this Paragraph so that you can apply the same properties to another paragraph.
BorderCode | getBarBorder()
BorderCode | getBottomBorder()
DropCapSpecifier | getDropCap()
int | getFirstLineIndent()
int | getFontAlignment()
int | getIlfo() Returns the ilfo, an index to the document's hpllfo, which describes the automatic number formatting of the paragraph.
int | getIlvl() Returns the multi-level indent for the paragraph.
int | getIndentFromLeft()
int | getIndentFromRight()
int | getJustification()
BorderCode | getLeftBorder()
LineSpacingDescriptor | getLineSpacing()
int | getLvl() Returns the heading level (1-8), or 9 if the paragraph isn't in a heading style.
BorderCode | getRightBorder()
ShadingDescriptor | getShading()
int | getSpacingAfter()
int | getSpacingBefore()
short | getStyleIndex()
int | getTableLevel()
int | getTabStopsNumber() Returns number of tabs stops defined for paragraph.
int[] | getTabStopsPositions() Returns array of positions of itbdMac tab stops
BorderCode | getTopBorder()
boolean | isAutoHyphenated()
boolean | isBackward()
boolean | isEmbeddedCellMark()
boolean | isInTable()
boolean | isKinsoku()
boolean | isLineNotNumbered()
boolean | isSideBySide()
boolean | isTableRowEnd()
boolean | isVertical()
boolean | isWidowControlled()
boolean | isWordWrapped()
boolean | keepOnPage()
boolean | keepWithNext()
protected static ParagraphProperties | newParagraph_applyStyleProperties(StyleSheet styleSheet, PAPX papx, ParagraphProperties properties)
boolean | pageBreakBefore()
void | setAutoHyphenated(boolean autoHyph)
void | setBackward(boolean bward)
void | setBarBorder(BorderCode bar)
void | setBottomBorder(BorderCode bottom)
void | setDropCap(DropCapSpecifier dcs)
void | setFirstLineIndent(int first)
void | setFontAlignment(int align)
void | setIndentFromLeft(int dxaLeft)
void | setIndentFromRight(int dxaRight)
void | setJustification(byte jc)
void | setKeepOnPage(boolean fKeep)
void | setKeepWithNext(boolean fKeepFollow)
void | setKinsoku(boolean kinsoku)
void | setLeftBorder(BorderCode left)
void | setLineNotNumbered(boolean fNoLnn)
void | setLineSpacing(LineSpacingDescriptor lspd)
void | setPageBreakBefore(boolean fPageBreak)
void | setRightBorder(BorderCode right)
void | setShading(ShadingDescriptor shd)
void | setSideBySide(boolean fSideBySide)
void | setSpacingAfter(int after)
void | setSpacingBefore(int before)
void | setTopBorder(BorderCode top)
void | setVertical(boolean vertical)
void | setWidowControl(boolean widowControl)
void | setWordWrapped(boolean wrap)
java.lang.String | toString()
int | type() Deprecated.
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, reset, sanityCheck, stripFields, text, usesUnicode
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SPRM_JC

public static final short SPRM_JC
See Also:
Constant Field Values

SPRM_FSIDEBYSIDE

public static final short SPRM_FSIDEBYSIDE
See Also:
Constant Field Values

SPRM_FKEEP

public static final short SPRM_FKEEP
See Also:
Constant Field Values

SPRM_FKEEPFOLLOW

public static final short SPRM_FKEEPFOLLOW
See Also:
Constant Field Values

SPRM_FPAGEBREAKBEFORE

public static final short SPRM_FPAGEBREAKBEFORE
See Also:
Constant Field Values

SPRM_BRCL

public static final short SPRM_BRCL
See Also:
Constant Field Values

SPRM_BRCP

public static final short SPRM_BRCP
See Also:
Constant Field Values

SPRM_ILVL

public static final short SPRM_ILVL
See Also:
Constant Field Values

SPRM_ILFO

public static final short SPRM_ILFO
See Also:
Constant Field Values

SPRM_FNOLINENUMB

public static final short SPRM_FNOLINENUMB
See Also:
Constant Field Values

SPRM_CHGTABSPAPX

public static final short SPRM_CHGTABSPAPX
See Also:
Constant Field Values

SPRM_DXARIGHT

public static final short SPRM_DXARIGHT
See Also:
Constant Field Values

SPRM_DXALEFT

public static final short SPRM_DXALEFT
See Also:
Constant Field Values

SPRM_DXALEFT1

public static final short SPRM_DXALEFT1
See Also:
Constant Field Values

SPRM_DYALINE

public static final short SPRM_DYALINE
See Also:
Constant Field Values

SPRM_DYABEFORE

public static final short SPRM_DYABEFORE
See Also:
Constant Field Values

SPRM_DYAAFTER

public static final short SPRM_DYAAFTER
See Also:
Constant Field Values

SPRM_CHGTABS

public static final short SPRM_CHGTABS
See Also:
Constant Field Values

SPRM_FINTABLE

public static final short SPRM_FINTABLE
See Also:
Constant Field Values

SPRM_FTTP

public static final short SPRM_FTTP
See Also:
Constant Field Values

SPRM_DXAABS

public static final short SPRM_DXAABS
See Also:
Constant Field Values

SPRM_DYAABS

public static final short SPRM_DYAABS
See Also:
Constant Field Values

SPRM_DXAWIDTH

public static final short SPRM_DXAWIDTH
See Also:
Constant Field Values

SPRM_PC

public static final short SPRM_PC
See Also:
Constant Field Values

SPRM_WR

public static final short SPRM_WR
See Also:
Constant Field Values

SPRM_BRCTOP

public static final short SPRM_BRCTOP
See Also:
Constant Field Values

SPRM_BRCLEFT

public static final short SPRM_BRCLEFT
See Also:
Constant Field Values

SPRM_BRCBOTTOM

public static final short SPRM_BRCBOTTOM
See Also:
Constant Field Values

SPRM_BRCRIGHT

public static final short SPRM_BRCRIGHT
See Also:
Constant Field Values

SPRM_BRCBAR

public static final short SPRM_BRCBAR
See Also:
Constant Field Values

SPRM_FNOAUTOHYPH

public static final short SPRM_FNOAUTOHYPH
See Also:
Constant Field Values

SPRM_WHEIGHTABS

public static final short SPRM_WHEIGHTABS
See Also:
Constant Field Values

SPRM_DCS

public static final short SPRM_DCS
See Also:
Constant Field Values

SPRM_SHD80

public static final short SPRM_SHD80
See Also:
Constant Field Values

SPRM_SHD

public static final short SPRM_SHD
See Also:
Constant Field Values

SPRM_DYAFROMTEXT

public static final short SPRM_DYAFROMTEXT
See Also:
Constant Field Values

SPRM_DXAFROMTEXT

public static final short SPRM_DXAFROMTEXT
See Also:
Constant Field Values

SPRM_FLOCKED

public static final short SPRM_FLOCKED
See Also:
Constant Field Values

SPRM_FWIDOWCONTROL

public static final short SPRM_FWIDOWCONTROL
See Also:
Constant Field Values

SPRM_RULER

public static final short SPRM_RULER
See Also:
Constant Field Values

SPRM_FKINSOKU

public static final short SPRM_FKINSOKU
See Also:
Constant Field Values

SPRM_FWORDWRAP

public static final short SPRM_FWORDWRAP
See Also:
Constant Field Values

SPRM_FOVERFLOWPUNCT

public static final short SPRM_FOVERFLOWPUNCT
See Also:
Constant Field Values

SPRM_FTOPLINEPUNCT

public static final short SPRM_FTOPLINEPUNCT
See Also:
Constant Field Values

SPRM_AUTOSPACEDE

public static final short SPRM_AUTOSPACEDE
See Also:
Constant Field Values

SPRM_AUTOSPACEDN

public static final short SPRM_AUTOSPACEDN
See Also:
Constant Field Values

SPRM_WALIGNFONT

public static final short SPRM_WALIGNFONT
See Also:
Constant Field Values

SPRM_FRAMETEXTFLOW

public static final short SPRM_FRAMETEXTFLOW
See Also:
Constant Field Values

SPRM_ANLD

public static final short SPRM_ANLD
See Also:
Constant Field Values

SPRM_PROPRMARK

public static final short SPRM_PROPRMARK
See Also:
Constant Field Values

SPRM_OUTLVL

public static final short SPRM_OUTLVL
See Also:
Constant Field Values

SPRM_FBIDI

public static final short SPRM_FBIDI
See Also:
Constant Field Values

SPRM_FNUMRMLNS

public static final short SPRM_FNUMRMLNS
See Also:
Constant Field Values

SPRM_CRLF

public static final short SPRM_CRLF
See Also:
Constant Field Values

SPRM_NUMRM

public static final short SPRM_NUMRM
See Also:
Constant Field Values

SPRM_USEPGSUSETTINGS

public static final short SPRM_USEPGSUSETTINGS
See Also:
Constant Field Values

SPRM_FADJUSTRIGHT

public static final short SPRM_FADJUSTRIGHT
See Also:
Constant Field Values

_istd

protected short _istd

_props

protected ParagraphProperties _props

_papx

protected SprmBuffer _papx
Constructor Detail

Paragraph

@Deprecated
protected Paragraph(int startIdxInclusive,
                               int endIdxExclusive,
                               Table parent)
Deprecated.

Paragraph

@Deprecated
protected Paragraph(PAPX papx,
                               Range parent)
Deprecated.

Paragraph

@Deprecated
protected Paragraph(PAPX papx,
                               Range parent,
                               int start)
Deprecated.

Method Detail

newParagraph_applyStyleProperties

protected static ParagraphProperties newParagraph_applyStyleProperties(StyleSheet styleSheet,
                                                                       PAPX papx,
                                                                       ParagraphProperties properties)

getStyleIndex

public short getStyleIndex()

type

@Deprecated
public int type()
Deprecated.

Description copied from class: Range
This method is used to determine the type. Handy for switch statements compared to the instanceof operator.

Overrides:
type in class Range
Returns:
A TYPE constant.

isInTable

public boolean isInTable()

isTableRowEnd

public boolean isTableRowEnd()
Returns:
true, if table trailer paragraph (last in table row), false otherwise

getTableLevel

public int getTableLevel()

isEmbeddedCellMark

public boolean isEmbeddedCellMark()
Returns:
true, if the end of paragraph mark is really an end of cell mark for a nested table cell, false otherwise

getJustification

public int getJustification()

setJustification

public void setJustification(byte jc)

keepOnPage

public boolean keepOnPage()

setKeepOnPage

public void setKeepOnPage(boolean fKeep)

keepWithNext

public boolean keepWithNext()

setKeepWithNext

public void setKeepWithNext(boolean fKeepFollow)

pageBreakBefore

public boolean pageBreakBefore()

setPageBreakBefore

public void setPageBreakBefore(boolean fPageBreak)

isLineNotNumbered

public boolean isLineNotNumbered()

setLineNotNumbered

public void setLineNotNumbered(boolean fNoLnn)

isSideBySide

public boolean isSideBySide()

setSideBySide

public void setSideBySide(boolean fSideBySide)

isAutoHyphenated

public boolean isAutoHyphenated()

setAutoHyphenated

public void setAutoHyphenated(boolean autoHyph)

isWidowControlled

public boolean isWidowControlled()

setWidowControl

public void setWidowControl(boolean widowControl)

getIndentFromRight

public int getIndentFromRight()

setIndentFromRight

public void setIndentFromRight(int dxaRight)

getIndentFromLeft

public int getIndentFromLeft()

setIndentFromLeft

public void setIndentFromLeft(int dxaLeft)

getFirstLineIndent

public int getFirstLineIndent()

setFirstLineIndent

public void setFirstLineIndent(int first)

getLineSpacing

public LineSpacingDescriptor getLineSpacing()

setLineSpacing

public void setLineSpacing(LineSpacingDescriptor lspd)

getSpacingBefore

public int getSpacingBefore()

setSpacingBefore

public void setSpacingBefore(int before)

getSpacingAfter

public int getSpacingAfter()

setSpacingAfter

public void setSpacingAfter(int after)

isKinsoku

public boolean isKinsoku()

setKinsoku

public void setKinsoku(boolean kinsoku)

isWordWrapped

public boolean isWordWrapped()

setWordWrapped

public void setWordWrapped(boolean wrap)

getFontAlignment

public int getFontAlignment()

setFontAlignment

public void setFontAlignment(int align)

isVertical

public boolean isVertical()

setVertical

public void setVertical(boolean vertical)

isBackward

public boolean isBackward()

setBackward

public void setBackward(boolean bward)

getTopBorder

public BorderCode getTopBorder()

setTopBorder

public void setTopBorder(BorderCode top)

getLeftBorder

public BorderCode getLeftBorder()

setLeftBorder

public void setLeftBorder(BorderCode left)

getBottomBorder

public BorderCode getBottomBorder()

setBottomBorder

public void setBottomBorder(BorderCode bottom)

getRightBorder

public BorderCode getRightBorder()

setRightBorder

public void setRightBorder(BorderCode right)

getBarBorder

public BorderCode getBarBorder()

setBarBorder

public void setBarBorder(BorderCode bar)

getShading

public ShadingDescriptor getShading()

setShading

public void setShading(ShadingDescriptor shd)

getDropCap

public DropCapSpecifier getDropCap()

setDropCap

public void setDropCap(DropCapSpecifier dcs)

getIlfo

public int getIlfo()
Returns the ilfo, an index to the document's hpllfo, which describes the automatic number formatting of the paragraph. A value of zero means it isn't numbered.

getIlvl

public int getIlvl()
Returns the multi-level indent for the paragraph. Will be zero for non-list paragraphs, and the first level of any list. Subsequent levels in hold values 1-8.

getLvl

public int getLvl()
Returns the heading level (1-8), or 9 if the paragraph isn't in a heading style.

getTabStopsNumber

public int getTabStopsNumber()
Returns number of tabs stops defined for paragraph. Must be >= 0 and <= 64.

Returns:
number of tabs stops defined for paragraph. Must be >= 0 and <= 64

getTabStopsPositions

public int[] getTabStopsPositions()
Returns array of positions of itbdMac tab stops

Returns:
array of positions of itbdMac tab stops

cloneProperties

public ParagraphProperties cloneProperties()
clone the ParagraphProperties object associated with this Paragraph so that you can apply the same properties to another paragraph.

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

toString

public java.lang.String toString()
Overrides:
toString in class Range
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParagraphProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class ParagraphProperties

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.PAPAbstractType
        extended by  org.apache.poi.hwpf.usermodel.ParagraphProperties
All Implemented Interfaces:
java.lang.Cloneable
public final class ParagraphProperties
extends PAPAbstractType
implements java.lang.Cloneable

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.PAPAbstractType
BRCL_DOUBLE, BRCL_SHADOW, BRCL_SINGLE, BRCL_THICK, BRCP_BAR_TO_LEFT_OF_PARAGRAPH, BRCP_BORDER_ABOVE, BRCP_BORDER_BELOW, BRCP_BOX_AROUND, BRCP_NONE, field_1_istd, field_10_fNoLnn, field_11_lspd, field_12_dyaBefore, field_13_dyaAfter, field_14_fInTable, field_15_finTableW97, field_16_fTtp, field_17_dxaAbs, field_18_dyaAbs, field_19_dxaWidth, field_2_fSideBySide, field_20_fBrLnAbove, field_21_fBrLnBelow, field_22_pcVert, field_23_pcHorz, field_24_wr, field_25_fNoAutoHyph, field_26_dyaHeight, field_27_fMinHeight, field_28_dcs, field_29_dyaFromText, field_3_fKeep, field_30_dxaFromText, field_31_fLocked, field_32_fWidowControl, field_33_fKinsoku, field_34_fWordWrap, field_35_fOverflowPunct, field_36_fTopLinePunct, field_37_fAutoSpaceDE, field_38_fAutoSpaceDN, field_39_wAlignFont, field_4_fKeepFollow, field_40_fontAlign, field_41_lvl, field_42_fBiDi, field_43_fNumRMIns, field_44_fCrLf, field_45_fUsePgsuSettings, field_46_fAdjustRight, field_47_itap, field_48_fInnerTableCell, field_49_fOpenTch, field_5_fPageBreakBefore, field_50_fTtpEmbedded, field_51_dxcRight, field_52_dxcLeft, field_53_dxcLeft1, field_54_fDyaBeforeAuto, field_55_fDyaAfterAuto, field_56_dxaRight, field_57_dxaLeft, field_58_dxaLeft1, field_59_jc, field_6_brcl, field_60_brcTop, field_61_brcLeft, field_62_brcBottom, field_63_brcRight, field_64_brcBetween, field_65_brcBar, field_66_shd, field_67_anld, field_68_phe, field_69_fPropRMark, field_7_brcp, field_70_ibstPropRMark, field_71_dttmPropRMark, field_72_itbdMac, field_73_rgdxaTab, field_74_rgtbd, field_75_numrm, field_76_ptap, field_77_fNoAllowOverlap, field_78_ipgp, field_79_rsid, field_8_ilvl, field_9_ilfo, FMINHEIGHT_AT_LEAST, FMINHEIGHT_EXACT, WALIGNFONT_AUTO, WALIGNFONT_CENTERED, WALIGNFONT_HANGING, WALIGNFONT_ROMAN, WALIGNFONT_VARIABLE
Constructor Summary
ParagraphProperties()
Method Summary
java.lang.Object | clone()
BorderCode | getBarBorder()
BorderCode | getBottomBorder()
DropCapSpecifier | getDropCap()
int | getFirstLineIndent()
int | getFontAlignment()
int | getIndentFromLeft()
int | getIndentFromRight()
int | getJustification()
BorderCode | getLeftBorder()
LineSpacingDescriptor | getLineSpacing()
BorderCode | getRightBorder()
ShadingDescriptor | getShading()
int | getSpacingAfter()
int | getSpacingBefore()
BorderCode | getTopBorder()
boolean | isAutoHyphenated()
boolean | isBackward()
boolean | isKinsoku()
boolean | isLineNotNumbered()
boolean | isSideBySide()
boolean | isVertical()
boolean | isWidowControlled()
boolean | isWordWrapped()
boolean | keepOnPage()
boolean | keepWithNext()
boolean | pageBreakBefore()
void | setAutoHyphenated(boolean auto)
void | setBackward(boolean bward)
void | setBarBorder(BorderCode bar)
void | setBottomBorder(BorderCode bottom)
void | setDropCap(DropCapSpecifier dcs)
void | setFirstLineIndent(int first)
void | setFontAlignment(int align)
void | setIndentFromLeft(int dxaLeft)
void | setIndentFromRight(int dxaRight)
void | setJustification(byte jc)
void | setJustificationLogical(byte jc)
void | setKeepOnPage(boolean fKeep)
void | setKeepWithNext(boolean fKeepFollow)
void | setKinsoku(boolean kinsoku)
void | setLeftBorder(BorderCode left)
void | setLineNotNumbered(boolean fNoLnn)
void | setLineSpacing(LineSpacingDescriptor lspd)
void | setPageBreakBefore(boolean fPageBreak)
void | setRightBorder(BorderCode right)
void | setShading(ShadingDescriptor shd)
void | setSideBySide(boolean fSideBySide)
void | setSpacingAfter(int after)
void | setSpacingBefore(int before)
void | setTopBorder(BorderCode top)
void | setVertical(boolean vertical)
void | setWidowControl(boolean widowControl)
void | setWordWrapped(boolean wrap)
Methods inherited from class org.apache.poi.hwpf.model.types.PAPAbstractType
getAnld, getBrcBar, getBrcBetween, getBrcBottom, getBrcl, getBrcLeft, getBrcp, getBrcRight, getBrcTop, getDcs, getDttmPropRMark, getDxaAbs, getDxaFromText, getDxaLeft, getDxaLeft1, getDxaRight, getDxaWidth, getDxcLeft, getDxcLeft1, getDxcRight, getDyaAbs, getDyaAfter, getDyaBefore, getDyaFromText, getDyaHeight, getFAdjustRight, getFAutoSpaceDE, getFAutoSpaceDN, getFBiDi, getFBrLnAbove, getFBrLnBelow, getFCrLf, getFDyaAfterAuto, getFDyaBeforeAuto, getFInnerTableCell, getFInTable, getFinTableW97, getFKeep, getFKeepFollow, getFKinsoku, getFLocked, getFMinHeight, getFNoAllowOverlap, getFNoAutoHyph, getFNoLnn, getFNumRMIns, getFontAlign, getFOpenTch, getFOverflowPunct, getFPageBreakBefore, getFPropRMark, getFSideBySide, getFTopLinePunct, getFTtp, getFTtpEmbedded, getFUsePgsuSettings, getFWidowControl, getFWordWrap, getIbstPropRMark, getIlfo, getIlvl, getIpgp, getIstd, getItap, getItbdMac, getJc, getLspd, getLvl, getNumrm, getPcHorz, getPcVert, getPhe, getPtap, getRgdxaTab, getRgtbd, getRsid, getShd, getWAlignFont, getWr, isFBackward, isFRotateFont, isFVertical, setAnld, setBrcBar, setBrcBetween, setBrcBottom, setBrcl, setBrcLeft, setBrcp, setBrcRight, setBrcTop, setDcs, setDttmPropRMark, setDxaAbs, setDxaFromText, setDxaLeft, setDxaLeft1, setDxaRight, setDxaWidth, setDxcLeft, setDxcLeft1, setDxcRight, setDyaAbs, setDyaAfter, setDyaBefore, setDyaFromText, setDyaHeight, setFAdjustRight, setFAutoSpaceDE, setFAutoSpaceDN, setFBackward, setFBiDi, setFBrLnAbove, setFBrLnBelow, setFCrLf, setFDyaAfterAuto, setFDyaBeforeAuto, setFInnerTableCell, setFInTable, setFinTableW97, setFKeep, setFKeepFollow, setFKinsoku, setFLocked, setFMinHeight, setFNoAllowOverlap, setFNoAutoHyph, setFNoLnn, setFNumRMIns, setFontAlign, setFOpenTch, setFOverflowPunct, setFPageBreakBefore, setFPropRMark, setFRotateFont, setFSideBySide, setFTopLinePunct, setFTtp, setFTtpEmbedded, setFUsePgsuSettings, setFVertical, setFWidowControl, setFWordWrap, setIbstPropRMark, setIlfo, setIlvl, setIpgp, setIstd, setItap, setItbdMac, setJc, setLspd, setLvl, setNumrm, setPcHorz, setPcVert, setPhe, setPtap, setRgdxaTab, setRgtbd, setRsid, setShd, setWAlignFont, setWr, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ParagraphProperties

public ParagraphProperties()
Method Detail

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

getBarBorder

public BorderCode getBarBorder()

getBottomBorder

public BorderCode getBottomBorder()

getDropCap

public DropCapSpecifier getDropCap()

getFirstLineIndent

public int getFirstLineIndent()

getFontAlignment

public int getFontAlignment()

getIndentFromLeft

public int getIndentFromLeft()

getIndentFromRight

public int getIndentFromRight()

getJustification

public int getJustification()

getLeftBorder

public BorderCode getLeftBorder()

getLineSpacing

public LineSpacingDescriptor getLineSpacing()

getRightBorder

public BorderCode getRightBorder()

getShading

public ShadingDescriptor getShading()

getSpacingAfter

public int getSpacingAfter()

getSpacingBefore

public int getSpacingBefore()

getTopBorder

public BorderCode getTopBorder()

isAutoHyphenated

public boolean isAutoHyphenated()

isBackward

public boolean isBackward()

isKinsoku

public boolean isKinsoku()

isLineNotNumbered

public boolean isLineNotNumbered()

isSideBySide

public boolean isSideBySide()

isVertical

public boolean isVertical()

isWidowControlled

public boolean isWidowControlled()

isWordWrapped

public boolean isWordWrapped()

keepOnPage

public boolean keepOnPage()

keepWithNext

public boolean keepWithNext()

pageBreakBefore

public boolean pageBreakBefore()

setAutoHyphenated

public void setAutoHyphenated(boolean auto)

setBackward

public void setBackward(boolean bward)

setBarBorder

public void setBarBorder(BorderCode bar)

setBottomBorder

public void setBottomBorder(BorderCode bottom)

setDropCap

public void setDropCap(DropCapSpecifier dcs)

setFirstLineIndent

public void setFirstLineIndent(int first)

setFontAlignment

public void setFontAlignment(int align)

setIndentFromLeft

public void setIndentFromLeft(int dxaLeft)

setIndentFromRight

public void setIndentFromRight(int dxaRight)

setJustification

public void setJustification(byte jc)

setJustificationLogical

public void setJustificationLogical(byte jc)

setKeepOnPage

public void setKeepOnPage(boolean fKeep)

setKeepWithNext

public void setKeepWithNext(boolean fKeepFollow)

setKinsoku

public void setKinsoku(boolean kinsoku)

setLeftBorder

public void setLeftBorder(BorderCode left)

setLineNotNumbered

public void setLineNotNumbered(boolean fNoLnn)

setLineSpacing

public void setLineSpacing(LineSpacingDescriptor lspd)

setPageBreakBefore

public void setPageBreakBefore(boolean fPageBreak)

setRightBorder

public void setRightBorder(BorderCode right)

setShading

public void setShading(ShadingDescriptor shd)

setSideBySide

public void setSideBySide(boolean fSideBySide)

setSpacingAfter

public void setSpacingAfter(int after)

setSpacingBefore

public void setSpacingBefore(int before)

setTopBorder

public void setTopBorder(BorderCode top)

setVertical

public void setVertical(boolean vertical)

setWidowControl

public void setWidowControl(boolean widowControl)

setWordWrapped

public void setWordWrapped(boolean wrap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Picture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class Picture

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Picture

public final class Picture
extends java.lang.Object

Represents embedded picture extracted from Word Document

Field Summary
static byte[] | BMP Deprecated.
static byte[] | COMPRESSED1
static byte[] | COMPRESSED2
static byte[] | EMF Deprecated.
static byte[] | GIF Deprecated.
static byte[] | IHDR
static byte[] | JPG Deprecated.
static byte[] | PNG Deprecated.
static byte[] | TIFF Deprecated.
static byte[] | TIFF1 Deprecated.
static byte[] | WMF1 Deprecated.
static byte[] | WMF2 Deprecated.
Constructor Summary
Picture(EscherBlipRecord blipRecord)
Builds a Picture object for a Picture stored as Escher.
Picture(int dataBlockStartOfsset, byte[] _dataStream, boolean fillBytes)
Builds a Picture object for a Picture stored in the DataStream
Method Summary
 int getAspectRatioX()
Deprecated. use more precise getHorizontalScalingFactor()
 int getAspectRatioY()
Deprecated. use more precise getVerticalScalingFactor()
 byte[] getContent()
 int getDxaCropLeft()
Deprecated.
 int getDxaCropRight()
Deprecated.
 int getDxaGoal()
Gets the initial width of the picture, in twips, prior to cropping or scaling.
 int getDyaCropBottom()
Deprecated.
 int getDyaCropTop()
Deprecated.
 int getDyaGoal()
Gets the initial height of the picture, in twips, prior to cropping or scaling.
 int getHeight()
returns pixel height of the picture or -1 if dimensions determining was failed
 int getHorizontalScalingFactor()
 java.lang.String getMimeType()
Returns the MIME type for the image
 byte[] getRawContent()
Returns picture's content as it stored in Word file, i.e.
 int getSize()
 int getStartOffset()
 int getVerticalScalingFactor()
 int getWidth()
returns pixel width of the picture or -1 if dimensions determining was failed
 java.lang.String suggestFileExtension()
tries to suggest extension for picture's file by matching signatures of popular image formats to first bytes of picture's contents
 java.lang.String suggestFullFileName()
Tries to suggest a filename: hex representation of picture structure offset in "Data" stream plus extension that is tried to determine from first byte of picture's content.
 PictureType suggestPictureType()
 void writeImageContent(java.io.OutputStream out)
Writes Picture's content bytes to specified OutputStream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BMP

@Deprecated
public static final byte[] BMP
Deprecated.

COMPRESSED1

public static final byte[] COMPRESSED1

COMPRESSED2

public static final byte[] COMPRESSED2

EMF

@Deprecated
public static final byte[] EMF
Deprecated.

GIF

@Deprecated
public static final byte[] GIF
Deprecated.

IHDR

public static final byte[] IHDR

JPG

@Deprecated
public static final byte[] JPG
Deprecated.

PNG

@Deprecated
public static final byte[] PNG
Deprecated.

TIFF

@Deprecated
public static final byte[] TIFF
Deprecated.

TIFF1

@Deprecated
public static final byte[] TIFF1
Deprecated.

WMF1

@Deprecated
public static final byte[] WMF1
Deprecated.

WMF2

@Deprecated
public static final byte[] WMF2
Deprecated.
Constructor Detail

Picture

public Picture(EscherBlipRecord blipRecord)
Builds a Picture object for a Picture stored as Escher. TODO We need to pass in the PICF data too somehow!

Picture

public Picture(int dataBlockStartOfsset,
               byte[] _dataStream,
               boolean fillBytes)
Builds a Picture object for a Picture stored in the DataStream

Method Detail

getAspectRatioX

@Deprecated
public int getAspectRatioX()
Deprecated. use more precise getHorizontalScalingFactor()

Returns:
the horizontal aspect ratio for picture provided by user

getAspectRatioY

@Deprecated
public int getAspectRatioY()
Deprecated. use more precise getVerticalScalingFactor()

Returns:
the vertical aspect ratio for picture provided by user

getContent

public byte[] getContent()
Returns:
picture's content as byte array

getDxaCropLeft

@Deprecated
public int getDxaCropLeft()
Deprecated.

Returns:
The amount the picture has been cropped on the left in twips

getDxaCropRight

@Deprecated
public int getDxaCropRight()
Deprecated.

Returns:
The amount the picture has been cropped on the right in twips

getDxaGoal

public int getDxaGoal()
Gets the initial width of the picture, in twips, prior to cropping or scaling.

Returns:
the initial width of the picture in twips

getDyaCropBottom

@Deprecated
public int getDyaCropBottom()
Deprecated.

Returns:
The amount the picture has been cropped on the bottom in twips

getDyaCropTop

@Deprecated
public int getDyaCropTop()
Deprecated.

Returns:
The amount the picture has been cropped on the top in twips

getDyaGoal

public int getDyaGoal()
Gets the initial height of the picture, in twips, prior to cropping or scaling.

Returns:
the initial width of the picture in twips

getHeight

public int getHeight()
returns pixel height of the picture or -1 if dimensions determining was failed

getHorizontalScalingFactor

public int getHorizontalScalingFactor()
Returns:
Horizontal scaling factor supplied by user expressed in .001% units

getMimeType

public java.lang.String getMimeType()
Returns the MIME type for the image

Returns:
MIME-type for known types of image or "image/unknown" if unknown

getRawContent

public byte[] getRawContent()
Returns picture's content as it stored in Word file, i.e. possibly in compressed form.

Returns:
picture's content as it stored in Word file

getSize

public int getSize()
Returns:
size in bytes of the picture

getStartOffset

public int getStartOffset()
Returns:
The offset of this picture in the picture bytes, used when matching up with CharacterRun.getPicOffset()

getVerticalScalingFactor

public int getVerticalScalingFactor()
Returns:
Vertical scaling factor supplied by user expressed in .001% units

getWidth

public int getWidth()
returns pixel width of the picture or -1 if dimensions determining was failed

suggestFileExtension

public java.lang.String suggestFileExtension()
tries to suggest extension for picture's file by matching signatures of popular image formats to first bytes of picture's contents

Returns:
suggested file extension

suggestFullFileName

public java.lang.String suggestFullFileName()
Tries to suggest a filename: hex representation of picture structure offset in "Data" stream plus extension that is tried to determine from first byte of picture's content.

Returns:
suggested file name

suggestPictureType

public PictureType suggestPictureType()

writeImageContent

public void writeImageContent(java.io.OutputStream out)
                       throws java.io.IOException
Writes Picture's content bytes to specified OutputStream. Is useful when there is need to write picture bytes directly to stream, omitting its representation in memory as distinct byte array.

Parameters:
out - a stream to write to
Throws:
java.io.IOException - if some exception is occured while writing to specified out
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PictureType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.hwpf.usermodel
Enum PictureType

java.lang.Object
    extended by  java.lang.Enum<PictureType>
        extended by  org.apache.poi.hwpf.usermodel.PictureType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<PictureType>
public enum PictureType
extends java.lang.Enum<PictureType>

Picture types supported by MS Word format

Author:
Sergey Vladimirov (vlsergey {at} gmail {dot} com)

Enum Constant Summary
BMP
EMF
GIF
JPEG
PICT
PNG
TIFF
UNKNOWN
WMF
Method Summary
static PictureType | findMatchingType(byte[] pictureContent)
java.lang.String | getExtension()
java.lang.String | getMime()
byte[][] | getSignatures()
boolean | matchSignature(byte[] pictureData)
static PictureType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PictureType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

BMP

public static final PictureType BMP

EMF

public static final PictureType EMF

GIF

public static final PictureType GIF

JPEG

public static final PictureType JPEG

PICT

public static final PictureType PICT

PNG

public static final PictureType PNG

TIFF

public static final PictureType TIFF

UNKNOWN

public static final PictureType UNKNOWN

WMF

public static final PictureType WMF
Method Detail

values

public static PictureType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (PictureType c : PictureType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static PictureType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

findMatchingType

public static PictureType findMatchingType(byte[] pictureContent)

getExtension

public java.lang.String getExtension()

getMime

public java.lang.String getMime()

getSignatures

public byte[][] getSignatures()

matchSignature

public boolean matchSignature(byte[] pictureData)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Range

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class Range

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
Direct Known Subclasses:
CharacterRun, DocumentPosition, Paragraph, Section, Table, TableCell, TableRow
public class Range
extends java.lang.Object

This class is the central class of the HWPF object model. All properties that apply to a range of characters in a Word document extend this class. It is possible to insert text and/or properties at the beginning or end of a range. Ranges are only valid if there hasn't been an insert in a prior Range since the Range's creation. Once an element (text, paragraph, etc.) has been inserted into a Range, subsequent Ranges become unstable.

Author:
Ryan Ackley

Field Summary
protected java.util.List<CHPX> | _characters All CharacterRuns that belong to the document this Range belongs to.
protected int | _charEnd The end index in the characterRuns list for this Range.
protected boolean | _charRangeFound Have we loaded the characterRun indexes yet.
protected int | _charStart The start index in the characterRuns list for this Range
protected HWPFDocumentCore | _doc The document this range blongs to.
protected int | _end The ending character offset of this range.
protected java.util.List<PAPX> | _paragraphs All paragraphs that belong to the document this Range belongs to.
protected int | _parEnd The end index in the paragraphs list for this Range, exclusive
protected boolean | _parRangeFound Have we loaded the paragraph indexes yet.
protected int | _parStart The start index in the paragraphs list for this Range, inclusive
protected int | _sectionEnd The end index in the sections list for this Range.
protected java.util.List<SEPX> | _sections All sections that belong to the document this Range belongs to.
protected int | _sectionStart The start index in the sections list for this Range
protected int | _start The starting character offset of this range.
protected java.lang.StringBuilder | _text
static int | TYPE_CHARACTER Deprecated.
static int | TYPE_LISTENTRY Deprecated.
static int | TYPE_PARAGRAPH Deprecated.
static int | TYPE_SECTION Deprecated.
static int | TYPE_TABLE Deprecated.
static int | TYPE_TEXT Deprecated.
static int | TYPE_UNDEFINED Deprecated.
Constructor Summary
 | Range(int start, int end, HWPFDocumentCore doc) Used to construct a Range from a document.
protected | Range(int startIdx, int endIdx, int idxType, Range parent) Deprecated.
protected | Range(int start, int end, Range parent) Used to create Ranges that are children of other Ranges.
Method Summary
protected  void adjustFIB(int adjustment)
Adjust the value of the various FIB character count fields, eg FIB.CCPText after an insert or a delete...
 void delete()
 CharacterRun getCharacterRun(int index)
Gets the character run at index.
protected  HWPFDocumentCore getDocument()
 int getEndOffset()
 Paragraph getParagraph(int index)
Gets the paragraph at index.
 Section getSection(int index)
Gets the section at index.
 int getStartOffset()
 Table getTable(Paragraph paragraph)
Gets the table that starts with paragraph.
protected  void initAll()
loads all of the list indexes.
 Paragraph insertAfter(ParagraphProperties props, int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties
 ListEntry insertAfter(ParagraphProperties props, int listID, int level, int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties
protected  Paragraph insertAfter(ParagraphProperties props, int styleIndex, java.lang.String text)
Deprecated. Use code shall not work with ParagraphProperties
 CharacterRun insertAfter(java.lang.String text)
Inserts text onto the end of this range
 CharacterRun insertAfter(java.lang.String text, CharacterProperties props)
Deprecated. User code should not work with CharacterProperties
 Paragraph insertBefore(ParagraphProperties props, int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties
 ListEntry insertBefore(ParagraphProperties props, int listID, int level, int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties
protected  Paragraph insertBefore(ParagraphProperties props, int styleIndex, java.lang.String text)
Deprecated. Use code shall not work with ParagraphProperties
 CharacterRun insertBefore(java.lang.String text)
Inserts text into the front of this range.
 CharacterRun insertBefore(java.lang.String text, CharacterProperties props)
Deprecated. User code should not work with CharacterProperties
 Table insertBefore(TableProperties props, int rows)
Deprecated. Use code shall not work with TableProperties. Use insertTableBefore(short, int) instead
 Table insertTableBefore(short columns, int rows)
Inserts a simple table into the beginning of this range.
 int numCharacterRuns()
 int numParagraphs()
Used to get the number of paragraphs in a range.
 int numSections()
Used to get the number of sections in a range.
 void replaceText(java.lang.String newText, boolean addAfter)
Replace range text with new one, adding it to the range and deleting original text from document
 void replaceText(java.lang.String pPlaceHolder, java.lang.String pValue)
Replace (all instances of) a piece of text with another...
 void replaceText(java.lang.String pPlaceHolder, java.lang.String pValue, int pOffset)
Replace (one instance of) a piece of text with another...
protected  void reset()
resets the list indexes.
 boolean sanityCheck()
Method for debug purposes.
static java.lang.String stripFields(java.lang.String text)
Removes any fields (eg macros, page markers etc) from the string.
 java.lang.String text()
Gets the text that this Range contains.
 java.lang.String toString()
 int type()
Deprecated.
 boolean usesUnicode()
Deprecated. Range is not linked to any text piece anymore, so to check if unicode is used please access TextPieceTable during document load time
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

TYPE_PARAGRAPH

@Deprecated
public static final int TYPE_PARAGRAPH
Deprecated.
See Also:
Constant Field Values

TYPE_CHARACTER

@Deprecated
public static final int TYPE_CHARACTER
Deprecated.
See Also:
Constant Field Values

TYPE_SECTION

@Deprecated
public static final int TYPE_SECTION
Deprecated.
See Also:
Constant Field Values

TYPE_TEXT

@Deprecated
public static final int TYPE_TEXT
Deprecated.
See Also:
Constant Field Values

TYPE_LISTENTRY

@Deprecated
public static final int TYPE_LISTENTRY
Deprecated.
See Also:
Constant Field Values

TYPE_TABLE

@Deprecated
public static final int TYPE_TABLE
Deprecated.
See Also:
Constant Field Values

TYPE_UNDEFINED

@Deprecated
public static final int TYPE_UNDEFINED
Deprecated.
See Also:
Constant Field Values

_start

protected int _start
The starting character offset of this range.

_end

protected int _end
The ending character offset of this range.

_doc

protected HWPFDocumentCore _doc
The document this range blongs to.

_sections

protected java.util.List<SEPX> _sections
All sections that belong to the document this Range belongs to.

_sectionStart

protected int _sectionStart
The start index in the sections list for this Range

_sectionEnd

protected int _sectionEnd
The end index in the sections list for this Range.

_parRangeFound

protected boolean _parRangeFound
Have we loaded the paragraph indexes yet.

_paragraphs

protected java.util.List<PAPX> _paragraphs
All paragraphs that belong to the document this Range belongs to.

_parStart

protected int _parStart
The start index in the paragraphs list for this Range, inclusive

_parEnd

protected int _parEnd
The end index in the paragraphs list for this Range, exclusive

_charRangeFound

protected boolean _charRangeFound
Have we loaded the characterRun indexes yet.

_characters

protected java.util.List<CHPX> _characters
All CharacterRuns that belong to the document this Range belongs to.

_charStart

protected int _charStart
The start index in the characterRuns list for this Range

_charEnd

protected int _charEnd
The end index in the characterRuns list for this Range.

_text

protected java.lang.StringBuilder _text
Constructor Detail

Range

public Range(int start,
             int end,
             HWPFDocumentCore doc)
Used to construct a Range from a document. This is generally used to create a Range that spans the whole document, or at least one whole part of the document (eg main text, header, comment)

Parameters:
start - Starting character offset of the range.
end - Ending character offset of the range.
doc - The HWPFDocument the range is based on.

Range

protected Range(int start,
                int end,
                Range parent)
Used to create Ranges that are children of other Ranges.

Parameters:
start - Starting character offset of the range.
end - Ending character offset of the range.
parent - The parent this range belongs to.

Range

@Deprecated
protected Range(int startIdx,
                           int endIdx,
                           int idxType,
                           Range parent)
Deprecated.

Constructor used to build a Range from indexes in one of its internal lists.

Parameters:
startIdx - The starting index in the list, inclusive
endIdx - The ending index in the list, exclusive
idxType - The list type.
parent - The parent Range this range belongs to.
Method Detail

usesUnicode

@Deprecated
public boolean usesUnicode()
Deprecated. Range is not linked to any text piece anymore, so to check if unicode is used please access TextPieceTable during document load time

Returns:
always return true

text

public java.lang.String text()
Gets the text that this Range contains.

Returns:
The text for this range.

stripFields

public static java.lang.String stripFields(java.lang.String text)
Removes any fields (eg macros, page markers etc) from the string. Normally used to make some text suitable for showing to humans, and the resultant text should not normally be saved back into the document!

numSections

public int numSections()
Used to get the number of sections in a range. If this range is smaller than a section, it will return 1 for its containing section.

Returns:
The number of sections in this range.

numParagraphs

public int numParagraphs()
Used to get the number of paragraphs in a range. If this range is smaller than a paragraph, it will return 1 for its containing paragraph.

Returns:
The number of paragraphs in this range.

numCharacterRuns

public int numCharacterRuns()
Returns:
The number of characterRuns in this range.

insertBefore

public CharacterRun insertBefore(java.lang.String text)
Inserts text into the front of this range.

Parameters:
text - The text to insert
Returns:
The character run that text was inserted into.

insertAfter

public CharacterRun insertAfter(java.lang.String text)
Inserts text onto the end of this range

Parameters:
text - The text to insert
Returns:
The character run the text was inserted into.

insertBefore

@Deprecated
public CharacterRun insertBefore(java.lang.String text,
                                            CharacterProperties props)
Deprecated. User code should not work with CharacterProperties

Inserts text into the front of this range and it gives that text the CharacterProperties specified in props.

Parameters:
text - The text to insert.
props - The CharacterProperties to give the text.
Returns:
A new CharacterRun that has the given text and properties and is n ow a part of the document.

insertAfter

@Deprecated
public CharacterRun insertAfter(java.lang.String text,
                                           CharacterProperties props)
Deprecated. User code should not work with CharacterProperties

Inserts text onto the end of this range and gives that text the CharacterProperties specified in props.

Parameters:
text - The text to insert.
props - The CharacterProperties to give the text.
Returns:
A new CharacterRun that has the given text and properties and is n ow a part of the document.

insertBefore

@Deprecated
public Paragraph insertBefore(ParagraphProperties props,
                                         int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties

Inserts and empty paragraph into the front of this range.

Parameters:
props - The properties that the new paragraph will have.
styleIndex - The index into the stylesheet for the new paragraph.
Returns:
The newly inserted paragraph.

insertBefore

@Deprecated
protected Paragraph insertBefore(ParagraphProperties props,
                                            int styleIndex,
                                            java.lang.String text)
Deprecated. Use code shall not work with ParagraphProperties

Inserts a paragraph into the front of this range. The paragraph will contain one character run that has the default properties for the paragraph's style. It is necessary for the text to end with the character '\r'

Parameters:
props - The paragraph's properties.
styleIndex - The index of the paragraph's style in the style sheet.
text - The text to insert.
Returns:
A newly inserted paragraph.

insertAfter

@Deprecated
public Paragraph insertAfter(ParagraphProperties props,
                                        int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties

Inserts and empty paragraph into the end of this range.

Parameters:
props - The properties that the new paragraph will have.
styleIndex - The index into the stylesheet for the new paragraph.
Returns:
The newly inserted paragraph.

insertAfter

@Deprecated
protected Paragraph insertAfter(ParagraphProperties props,
                                           int styleIndex,
                                           java.lang.String text)
Deprecated. Use code shall not work with ParagraphProperties

Inserts a paragraph into the end of this range. The paragraph will contain one character run that has the default properties for the paragraph's style. It is necessary for the text to end with the character '\r'

Parameters:
props - The paragraph's properties.
styleIndex - The index of the paragraph's style in the style sheet.
text - The text to insert.
Returns:
A newly inserted paragraph.

delete

public void delete()

insertBefore

@Deprecated
public Table insertBefore(TableProperties props,
                                     int rows)
Deprecated. Use code shall not work with TableProperties. Use insertTableBefore(short, int) instead

Inserts a simple table into the beginning of this range. The number of columns is determined by the TableProperties passed into this function.

Parameters:
props - The table properties for the table.
rows - The number of rows.
Returns:
The empty Table that is now part of the document.

insertTableBefore

public Table insertTableBefore(short columns,
                               int rows)
Inserts a simple table into the beginning of this range.

Parameters:
columns - The number of columns
rows - The number of rows.
Returns:
The empty Table that is now part of the document.

insertBefore

@Deprecated
public ListEntry insertBefore(ParagraphProperties props,
                                         int listID,
                                         int level,
                                         int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties

Inserts a list into the beginning of this range.

Parameters:
props - The properties of the list entry. All list entries are paragraphs.
listID - The id of the list that contains the properties.
level - The indentation level of the list.
styleIndex - The base style's index in the stylesheet.
Returns:
The empty ListEntry that is now part of the document.

insertAfter

@Deprecated
public ListEntry insertAfter(ParagraphProperties props,
                                        int listID,
                                        int level,
                                        int styleIndex)
Deprecated. Use code shall not work with ParagraphProperties

Inserts a list into the beginning of this range.

Parameters:
props - The properties of the list entry. All list entries are paragraphs.
listID - The id of the list that contains the properties.
level - The indentation level of the list.
styleIndex - The base style's index in the stylesheet.
Returns:
The empty ListEntry that is now part of the document.

replaceText

public void replaceText(java.lang.String newText,
                        boolean addAfter)
Replace range text with new one, adding it to the range and deleting original text from document

Parameters:
newText - The text to be replaced with
addAfter - if true the text will be added at the end of current range, otherwise to the beginning

replaceText

@Internal
public void replaceText(java.lang.String pPlaceHolder,
                                 java.lang.String pValue,
                                 int pOffset)
Replace (one instance of) a piece of text with another...

Parameters:
pPlaceHolder - The text to be replaced (e.g., "${organization}")
pValue - The replacement text (e.g., "Apache Software Foundation")
pOffset - The offset or index where the text to be replaced begins (relative to/within this Range)

replaceText

public void replaceText(java.lang.String pPlaceHolder,
                        java.lang.String pValue)
Replace (all instances of) a piece of text with another...

Parameters:
pPlaceHolder - The text to be replaced (e.g., "${organization}")
pValue - The replacement text (e.g., "Apache Software Foundation")

getCharacterRun

public CharacterRun getCharacterRun(int index)
Gets the character run at index. The index is relative to this range.

Parameters:
index - The index of the character run to get.
Returns:
The character run at the specified index in this range.

getSection

public Section getSection(int index)
Gets the section at index. The index is relative to this range.

Parameters:
index - The index of the section to get.
Returns:
The section at the specified index in this range.

getParagraph

public Paragraph getParagraph(int index)
Gets the paragraph at index. The index is relative to this range.

Parameters:
index - The index of the paragraph to get.
Returns:
The paragraph at the specified index in this range.

type

@Deprecated
public int type()
Deprecated.

This method is used to determine the type. Handy for switch statements compared to the instanceof operator.

Returns:
A TYPE constant.

getTable

public Table getTable(Paragraph paragraph)
Gets the table that starts with paragraph. In a Word file, a table consists of a group of paragraphs with certain flags set.

Parameters:
paragraph - The paragraph that is the first paragraph in the table.
Returns:
The table that starts with paragraph

initAll

protected void initAll()
loads all of the list indexes.

reset

protected void reset()
resets the list indexes.

adjustFIB

protected void adjustFIB(int adjustment)
Adjust the value of the various FIB character count fields, eg FIB.CCPText after an insert or a delete... Works on all CCP fields from this range onwards

Parameters:
adjustment - The (signed) value that should be added to the FIB CCP fields

getStartOffset

public int getStartOffset()
Returns:
Starting character offset of the range

getEndOffset

public int getEndOffset()
Returns:
The ending character offset of this range

getDocument

protected HWPFDocumentCore getDocument()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

sanityCheck

public boolean sanityCheck()
Method for debug purposes. Checks that all resolved elements are inside of current range.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Section

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class Section

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.Section

public final class Section
extends Range

Field Summary
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Constructor Summary
Section(SEPX sepx, Range parent)
Method Summary
java.lang.Object | clone()
int | getDistanceBetweenColumns()
int | getMarginBottom()
int | getMarginLeft()
int | getMarginRight()
int | getMarginTop()
int | getNumColumns()
int | getPageHeight()
int | getPageWidth()
boolean | isColumnsEvenlySpaced()
java.lang.String | toString()
int | type() This method is used to determine the type.
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, reset, sanityCheck, stripFields, text, usesUnicode
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Section

public Section(SEPX sepx,
               Range parent)
Method Detail

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

getDistanceBetweenColumns

public int getDistanceBetweenColumns()
Returns:
distance to be maintained between columns, in twips. Used when isColumnsEvenlySpaced() == true

getMarginBottom

public int getMarginBottom()

getMarginLeft

public int getMarginLeft()

getMarginRight

public int getMarginRight()

getMarginTop

public int getMarginTop()

getNumColumns

public int getNumColumns()

getPageHeight

public int getPageHeight()
Returns:
page height (in twips) in current section. Default value is 15840 twips

getPageWidth

public int getPageWidth()
Returns:
page width (in twips) in current section. Default value is 12240 twips

isColumnsEvenlySpaced

public boolean isColumnsEvenlySpaced()

toString

public java.lang.String toString()
Overrides:
toString in class Range

type

public int type()
Description copied from class: Range
This method is used to determine the type. Handy for switch statements compared to the instanceof operator.

Overrides:
type in class Range
Returns:
A TYPE constant.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SectionProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class SectionProperties

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.SEPAbstractType
        extended by  org.apache.poi.hwpf.usermodel.SectionProperties

public final class SectionProperties
extends SEPAbstractType

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.SEPAbstractType
BKC_EVEN_PAGE, BKC_NEW_COLUMN, BKC_NEW_PAGE, BKC_NO_BREAK, BKC_ODD_PAGE, DMORIENTPAGE_LANDSCAPE, DMORIENTPAGE_PORTRAIT, field_1_bkc, field_10_grpfIhdt, field_11_nLnnMod, field_12_dxaLnn, field_13_dxaPgn, field_14_dyaPgn, field_15_fLBetween, field_16_vjc, field_17_dmBinFirst, field_18_dmBinOther, field_19_dmPaperReq, field_2_fTitlePage, field_20_brcTop, field_21_brcLeft, field_22_brcBottom, field_23_brcRight, field_24_fPropMark, field_25_ibstPropRMark, field_26_dttmPropRMark, field_27_dxtCharSpace, field_28_dyaLinePitch, field_29_clm, field_3_fAutoPgn, field_30_unused2, field_31_dmOrientPage, field_32_iHeadingPgn, field_33_pgnStart, field_34_lnnMin, field_35_wTextFlow, field_36_unused3, field_37_pgbProp, field_38_unused4, field_39_xaPage, field_4_nfcPgn, field_40_yaPage, field_41_xaPageNUp, field_42_yaPageNUp, field_43_dxaLeft, field_44_dxaRight, field_45_dyaTop, field_46_dyaBottom, field_47_dzaGutter, field_48_dyaHdrTop, field_49_dyaHdrBottom, field_5_fUnlocked, field_50_ccolM1, field_51_fEvenlySpaced, field_52_unused5, field_53_dxaColumns, field_54_rgdxaColumn, field_55_dxaColumnWidth, field_56_dmOrientFirst, field_57_fLayout, field_58_unused6, field_59_olstAnm, field_6_cnsPgn, field_7_fPgnRestart, field_8_fEndNote, field_9_lnc, NFCPGN_ARABIC, NFCPGN_LETTER_LOWER_CASE, NFCPGN_LETTER_UPPER_CASE, NFCPGN_ROMAN_LOWER_CASE, NFCPGN_ROMAN_UPPER_CASE
Constructor Summary
SectionProperties()
Method Summary
java.lang.Object | clone()
boolean | equals(java.lang.Object obj)
Methods inherited from class org.apache.poi.hwpf.model.types.SEPAbstractType
getBkc, getBrcBottom, getBrcLeft, getBrcRight, getBrcTop, getCcolM1, getClm, getCnsPgn, getDmBinFirst, getDmBinOther, getDmOrientFirst, getDmOrientPage, getDmPaperReq, getDttmPropRMark, getDxaColumns, getDxaColumnWidth, getDxaLeft, getDxaLnn, getDxaPgn, getDxaRight, getDxtCharSpace, getDyaBottom, getDyaHdrBottom, getDyaHdrTop, getDyaLinePitch, getDyaPgn, getDyaTop, getDzaGutter, getFAutoPgn, getFEndNote, getFEvenlySpaced, getFLayout, getFLBetween, getFPgnRestart, getFPropMark, getFTitlePage, getFUnlocked, getGrpfIhdt, getIbstPropRMark, getIHeadingPgn, getLnc, getLnnMin, getNfcPgn, getNLnnMod, getOlstAnm, getPgbProp, getPgnStart, getRgdxaColumn, getUnused2, getUnused3, getUnused4, getUnused5, getUnused6, getVjc, getWTextFlow, getXaPage, getXaPageNUp, getYaPage, getYaPageNUp, setBkc, setBrcBottom, setBrcLeft, setBrcRight, setBrcTop, setCcolM1, setClm, setCnsPgn, setDmBinFirst, setDmBinOther, setDmOrientFirst, setDmOrientPage, setDmPaperReq, setDttmPropRMark, setDxaColumns, setDxaColumnWidth, setDxaLeft, setDxaLnn, setDxaPgn, setDxaRight, setDxtCharSpace, setDyaBottom, setDyaHdrBottom, setDyaHdrTop, setDyaLinePitch, setDyaPgn, setDyaTop, setDzaGutter, setFAutoPgn, setFEndNote, setFEvenlySpaced, setFLayout, setFLBetween, setFPgnRestart, setFPropMark, setFTitlePage, setFUnlocked, setGrpfIhdt, setIbstPropRMark, setIHeadingPgn, setLnc, setLnnMin, setNfcPgn, setNLnnMod, setOlstAnm, setPgbProp, setPgnStart, setRgdxaColumn, setUnused2, setUnused3, setUnused4, setUnused5, setUnused6, setVjc, setWTextFlow, setXaPage, setXaPageNUp, setYaPage, setYaPageNUp, toString
Methods inherited from class java.lang.Object
finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SectionProperties

public SectionProperties()
Method Detail

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShadingDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class ShadingDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.SHDAbstractType
        extended by  org.apache.poi.hwpf.usermodel.ShadingDescriptor
All Implemented Interfaces:
java.lang.Cloneable
public final class ShadingDescriptor
extends SHDAbstractType
implements java.lang.Cloneable

The SHD is a substructure of the CHP, PAP, and TC for Word 2000.

Author:
vlsergey

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.SHDAbstractType
field_1_cvFore, field_2_cvBack, field_3_ipat
Constructor Summary
ShadingDescriptor()
ShadingDescriptor(byte[] buf, int offset)
Method Summary
ShadingDescriptor | clone()
boolean | isEmpty()
byte[] | serialize()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.types.SHDAbstractType
fillFields, getCvBack, getCvFore, getIpat, getSize, serialize, setCvBack, setCvFore, setIpat
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ShadingDescriptor

public ShadingDescriptor()

ShadingDescriptor

public ShadingDescriptor(byte[] buf,
                         int offset)
Method Detail

clone

public ShadingDescriptor clone()
                        throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

isEmpty

public boolean isEmpty()

serialize

public byte[] serialize()

toString

public java.lang.String toString()
Overrides:
toString in class SHDAbstractType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShadingDescriptor80

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class ShadingDescriptor80

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.SHD80AbstractType
        extended by  org.apache.poi.hwpf.usermodel.ShadingDescriptor80
All Implemented Interfaces:
java.lang.Cloneable
public final class ShadingDescriptor80
extends SHD80AbstractType
implements java.lang.Cloneable

The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.SHD80AbstractType
field_1_value
Constructor Summary
ShadingDescriptor80()
ShadingDescriptor80(byte[] buf, int offset)
ShadingDescriptor80(short value)
Method Summary
ShadingDescriptor80 | clone()
boolean | isEmpty()
byte[] | serialize()
ShadingDescriptor | toShadingDescriptor()
java.lang.String | toString()
Methods inherited from class org.apache.poi.hwpf.model.types.SHD80AbstractType
fillFields, getIcoBack, getIcoFore, getIpat, getSize, getValue, serialize, setIcoBack, setIcoFore, setIpat, setValue
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ShadingDescriptor80

public ShadingDescriptor80()

ShadingDescriptor80

public ShadingDescriptor80(byte[] buf,
                           int offset)

ShadingDescriptor80

public ShadingDescriptor80(short value)
Method Detail

clone

public ShadingDescriptor80 clone()
                          throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

isEmpty

public boolean isEmpty()

serialize

public byte[] serialize()

toShadingDescriptor

public ShadingDescriptor toShadingDescriptor()

toString

public java.lang.String toString()
Overrides:
toString in class SHD80AbstractType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Shape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class Shape

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Shape
Deprecated. Use OfficeDrawing instead

@Deprecated
public final class Shape
extends java.lang.Object

Constructor Summary
Shape(GenericPropertyNode nodo)
Deprecated.
Method Summary
int | getBottom() Deprecated.
int | getHeight() Deprecated.
int | getId() Deprecated.
int | getLeft() Deprecated.
int | getRight() Deprecated.
int | getTop() Deprecated.
int | getWidth() Deprecated.
boolean | isWithinDocument() Deprecated.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Shape

public Shape(GenericPropertyNode nodo)
Deprecated.
Method Detail

getId

public int getId()
Deprecated.

getLeft

public int getLeft()
Deprecated.

getRight

public int getRight()
Deprecated.

getTop

public int getTop()
Deprecated.

getBottom

public int getBottom()
Deprecated.

getWidth

public int getWidth()
Deprecated.

getHeight

public int getHeight()
Deprecated.

isWithinDocument

public boolean isWithinDocument()
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Table

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class Table

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.Table

public final class Table
extends Range

Field Summary
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Method Summary
TableRow | getRow(int index)
int | getTableLevel()
int | numRows()
protected void | reset() resets the list indexes.
int | type() This method is used to determine the type.
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, sanityCheck, stripFields, text, toString, usesUnicode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getRow

public TableRow getRow(int index)

getTableLevel

public int getTableLevel()

numRows

public int numRows()

reset

protected void reset()
Description copied from class: Range
resets the list indexes.

Overrides:
reset in class Range

type

public int type()
Description copied from class: Range
This method is used to determine the type. Handy for switch statements compared to the instanceof operator.

Overrides:
type in class Range
Returns:
A TYPE constant.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableAutoformatLookSpecifier

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class TableAutoformatLookSpecifier

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TLPAbstractType
        extended by  org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier
All Implemented Interfaces:
java.lang.Cloneable, org.apache.poi.hdf.model.hdftypes.HDFType
public class TableAutoformatLookSpecifier
extends TLPAbstractType
implements java.lang.Cloneable

Field Summary
static int SIZE
Fields inherited from class org.apache.poi.hwpf.model.types.TLPAbstractType
field_1_itl, field_2_tlp_flags
Constructor Summary
TableAutoformatLookSpecifier()
TableAutoformatLookSpecifier(byte[] data, int offset)
Method Summary
TableAutoformatLookSpecifier | clone()
boolean | equals(java.lang.Object obj)
int | hashCode()
boolean | isEmpty()
Methods inherited from class org.apache.poi.hwpf.model.types.TLPAbstractType
fillFields, getItl, getSize, getTlp_flags, isFBestFit, isFBorders, isFColor, isFFont, isFHdrRows, isFLastRow, isFShading, serialize, setFBestFit, setFBorders, setFColor, setFFont, setFHdrRows, setFLastRow, setFShading, setItl, setTlp_flags, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values
Constructor Detail

TableAutoformatLookSpecifier

public TableAutoformatLookSpecifier()

TableAutoformatLookSpecifier

public TableAutoformatLookSpecifier(byte[] data,
                                    int offset)
Method Detail

clone

public TableAutoformatLookSpecifier clone()
Overrides:
clone in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isEmpty

public boolean isEmpty()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class TableCell

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.TableCell

public final class TableCell
extends Range

Field Summary
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Constructor Summary
TableCell(int startIdxInclusive, int endIdxExclusive, TableRow parent, int levelNum, TableCellDescriptor tcd, int leftEdge, int width)
Method Summary
BorderCode | getBrcBottom()
BorderCode | getBrcLeft()
BorderCode | getBrcRight()
BorderCode | getBrcTop()
TableCellDescriptor | getDescriptor() Returns the TableCellDescriptor for this cell.
int | getLeftEdge()
byte | getVertAlign()
int | getWidth()
boolean | isBackward()
boolean | isFirstMerged()
boolean | isFirstVerticallyMerged()
boolean | isMerged()
boolean | isRotateFont()
boolean | isVertical()
boolean | isVerticallyMerged()
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, reset, sanityCheck, stripFields, text, toString, type, usesUnicode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TableCell

public TableCell(int startIdxInclusive,
                 int endIdxExclusive,
                 TableRow parent,
                 int levelNum,
                 TableCellDescriptor tcd,
                 int leftEdge,
                 int width)
Method Detail

isFirstMerged

public boolean isFirstMerged()

isMerged

public boolean isMerged()

isVertical

public boolean isVertical()

isBackward

public boolean isBackward()

isRotateFont

public boolean isRotateFont()

isVerticallyMerged

public boolean isVerticallyMerged()

isFirstVerticallyMerged

public boolean isFirstVerticallyMerged()

getVertAlign

public byte getVertAlign()

getBrcTop

public BorderCode getBrcTop()

getBrcBottom

public BorderCode getBrcBottom()

getBrcLeft

public BorderCode getBrcLeft()

getBrcRight

public BorderCode getBrcRight()

getLeftEdge

public int getLeftEdge()

getWidth

public int getWidth()

getDescriptor

public TableCellDescriptor getDescriptor()
Returns the TableCellDescriptor for this cell.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableCellDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class TableCellDescriptor

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TCAbstractType
        extended by  org.apache.poi.hwpf.usermodel.TableCellDescriptor
All Implemented Interfaces:
java.lang.Cloneable
public final class TableCellDescriptor
extends TCAbstractType
implements java.lang.Cloneable

Field Summary
static int SIZE
Fields inherited from class org.apache.poi.hwpf.model.types.TCAbstractType
field_1_rgf, field_10_ftsCellPaddingBottom, field_11_ftsCellPaddingRight, field_12_wCellSpacingLeft, field_13_wCellSpacingTop, field_14_wCellSpacingBottom, field_15_wCellSpacingRight, field_16_ftsCellSpacingLeft, field_17_ftsCellSpacingTop, field_18_ftsCellSpacingBottom, field_19_ftsCellSpacingRight, field_2_wWidth, field_20_brcTop, field_21_brcLeft, field_22_brcBottom, field_23_brcRight, field_3_shd, field_4_wCellPaddingLeft, field_5_wCellPaddingTop, field_6_wCellPaddingBottom, field_7_wCellPaddingRight, field_8_ftsCellPaddingLeft, field_9_ftsCellPaddingTop
Constructor Summary
TableCellDescriptor()
Method Summary
java.lang.Object | clone()
static TableCellDescriptor | convertBytesToTC(byte[] buf, int offset)
protected void | fillFields(byte[] data, int offset)
void | serialize(byte[] data, int offset)
Methods inherited from class org.apache.poi.hwpf.model.types.TCAbstractType
getBrcBottom, getBrcLeft, getBrcRight, getBrcTop, getFtsCellPaddingBottom, getFtsCellPaddingLeft, getFtsCellPaddingRight, getFtsCellPaddingTop, getFtsCellSpacingBottom, getFtsCellSpacingLeft, getFtsCellSpacingRight, getFtsCellSpacingTop, getFtsWidth, getFUnused, getRgf, getShd, getVertAlign, getWCellPaddingBottom, getWCellPaddingLeft, getWCellPaddingRight, getWCellPaddingTop, getWCellSpacingBottom, getWCellSpacingLeft, getWCellSpacingRight, getWCellSpacingTop, getWWidth, isFBackward, isFFirstMerged, isFFitText, isFMerged, isFNoWrap, isFRotateFont, isFVertical, isFVertMerge, isFVertRestart, setBrcBottom, setBrcLeft, setBrcRight, setBrcTop, setFBackward, setFFirstMerged, setFFitText, setFMerged, setFNoWrap, setFRotateFont, setFtsCellPaddingBottom, setFtsCellPaddingLeft, setFtsCellPaddingRight, setFtsCellPaddingTop, setFtsCellSpacingBottom, setFtsCellSpacingLeft, setFtsCellSpacingRight, setFtsCellSpacingTop, setFtsWidth, setFUnused, setFVertical, setFVertMerge, setFVertRestart, setRgf, setShd, setVertAlign, setWCellPaddingBottom, setWCellPaddingLeft, setWCellPaddingRight, setWCellPaddingTop, setWCellSpacingBottom, setWCellSpacingLeft, setWCellSpacingRight, setWCellSpacingTop, setWWidth, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values
Constructor Detail

TableCellDescriptor

public TableCellDescriptor()
Method Detail

fillFields

protected void fillFields(byte[] data,
                          int offset)

serialize

public void serialize(byte[] data,
                      int offset)

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException

convertBytesToTC

public static TableCellDescriptor convertBytesToTC(byte[] buf,
                                                   int offset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class TableIterator

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.TableIterator

public final class TableIterator
extends java.lang.Object

Constructor Summary
TableIterator(Range range)
Method Summary
boolean | hasNext()
Table | next()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TableIterator

public TableIterator(Range range)
Method Detail

hasNext

public boolean hasNext()

next

public Table next()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class TableProperties

java.lang.Object
    extended by  org.apache.poi.hwpf.model.types.TAPAbstractType
        extended by  org.apache.poi.hwpf.usermodel.TableProperties
All Implemented Interfaces:
java.lang.Cloneable
public final class TableProperties
extends TAPAbstractType
implements java.lang.Cloneable

Field Summary
Fields inherited from class org.apache.poi.hwpf.model.types.TAPAbstractType
field_1_istd, field_10_wWidthIndent, field_11_wWidthBefore, field_12_wWidthAfter, field_13_widthAndFitsFlags, field_14_dxaAbs, field_15_dyaAbs, field_16_dxaFromText, field_17_dyaFromText, field_18_dxaFromTextRight, field_19_dyaFromTextBottom, field_2_jc, field_20_fBiDi, field_21_fRTL, field_22_fNoAllowOverlap, field_23_fSpare, field_24_grpfTap, field_25_internalFlags, field_26_itcMac, field_27_dxaAdjust, field_28_dxaWebView, field_29_dxaRTEWrapWidth, field_3_dxaGapHalf, field_30_dxaColWidthWwd, field_31_pctWwd, field_32_viewFlags, field_33_rgdxaCenter, field_34_rgdxaCenterPrint, field_35_shdTable, field_36_brcBottom, field_37_brcTop, field_38_brcLeft, field_39_brcRight, field_4_dyaRowHeight, field_40_brcVertical, field_41_brcHorizontal, field_42_wCellPaddingDefaultTop, field_43_wCellPaddingDefaultLeft, field_44_wCellPaddingDefaultBottom, field_45_wCellPaddingDefaultRight, field_46_ftsCellPaddingDefaultTop, field_47_ftsCellPaddingDefaultLeft, field_48_ftsCellPaddingDefaultBottom, field_49_ftsCellPaddingDefaultRight, field_5_fCantSplit, field_50_wCellSpacingDefaultTop, field_51_wCellSpacingDefaultLeft, field_52_wCellSpacingDefaultBottom, field_53_wCellSpacingDefaultRight, field_54_ftsCellSpacingDefaultTop, field_55_ftsCellSpacingDefaultLeft, field_56_ftsCellSpacingDefaultBottom, field_57_ftsCellSpacingDefaultRight, field_58_wCellPaddingOuterTop, field_59_wCellPaddingOuterLeft, field_6_fCantSplit90, field_60_wCellPaddingOuterBottom, field_61_wCellPaddingOuterRight, field_62_ftsCellPaddingOuterTop, field_63_ftsCellPaddingOuterLeft, field_64_ftsCellPaddingOuterBottom, field_65_ftsCellPaddingOuterRight, field_66_wCellSpacingOuterTop, field_67_wCellSpacingOuterLeft, field_68_wCellSpacingOuterBottom, field_69_wCellSpacingOuterRight, field_7_fTableHeader, field_70_ftsCellSpacingOuterTop, field_71_ftsCellSpacingOuterLeft, field_72_ftsCellSpacingOuterBottom, field_73_ftsCellSpacingOuterRight, field_74_rgtc, field_75_rgshd, field_76_fPropRMark, field_77_fHasOldProps, field_78_cHorzBands, field_79_cVertBands, field_8_tlp, field_80_rgbrcInsideDefault_0, field_81_rgbrcInsideDefault_1, field_9_wWidth
Constructor Summary
TableProperties()
TableProperties(short columns)
Method Summary
 java.lang.Object clone()
Methods inherited from class org.apache.poi.hwpf.model.types.TAPAbstractType
getBrcBottom, getBrcHorizontal, getBrcLeft, getBrcRight, getBrcTop, getBrcVertical, getCHorzBands, getCVertBands, getDxaAbs, getDxaAdjust, getDxaColWidthWwd, getDxaFromText, getDxaFromTextRight, getDxaGapHalf, getDxaRTEWrapWidth, getDxaWebView, getDyaAbs, getDyaFromText, getDyaFromTextBottom, getDyaRowHeight, getFBiDi, getFCantSplit, getFCantSplit90, getFHasOldProps, getFNoAllowOverlap, getFPropRMark, getFRTL, getFSpare, getFTableHeader, getFtsCellPaddingDefaultBottom, getFtsCellPaddingDefaultLeft, getFtsCellPaddingDefaultRight, getFtsCellPaddingDefaultTop, getFtsCellPaddingOuterBottom, getFtsCellPaddingOuterLeft, getFtsCellPaddingOuterRight, getFtsCellPaddingOuterTop, getFtsCellSpacingDefaultBottom, getFtsCellSpacingDefaultLeft, getFtsCellSpacingDefaultRight, getFtsCellSpacingDefaultTop, getFtsCellSpacingOuterBottom, getFtsCellSpacingOuterLeft, getFtsCellSpacingOuterRight, getFtsCellSpacingOuterTop, getFtsWidth, getFtsWidthAfter, getFtsWidthBefore, getFtsWidthIndent, getGrpfTap_unused, getGrpfTap, getInternalFlags, getIstd, getItcMac, getJc, getPcHorz, getPctWwd, getPcVert, getRgbrcInsideDefault_0, getRgbrcInsideDefault_1, getRgdxaCenter, getRgdxaCenterPrint, getRgshd, getRgtc, getShdTable, getTlp, getViewFlags_unused2, getViewFlags, getWCellPaddingDefaultBottom, getWCellPaddingDefaultLeft, getWCellPaddingDefaultRight, getWCellPaddingDefaultTop, getWCellPaddingOuterBottom, getWCellPaddingOuterLeft, getWCellPaddingOuterRight, getWCellPaddingOuterTop, getWCellSpacingDefaultBottom, getWCellSpacingDefaultLeft, getWCellSpacingDefaultRight, getWCellSpacingDefaultTop, getWCellSpacingOuterBottom, getWCellSpacingOuterLeft, getWCellSpacingOuterRight, getWCellSpacingOuterTop, getWidthAndFitsFlags_empty1, getWidthAndFitsFlags_empty2, getWidthAndFitsFlags, getWWidth, getWWidthAfter, getWWidthBefore, getWWidthIndent, isFAdjusted, isFAutofit, isFCellSpacing, isFFirstRow, isFInvalAutofit, isFKeepFollow, isFLastRow, isFNeverBeenAutofit, isFNotPageView, isFOrigWordTableRules, isFOutline, isFVert, isFWebView, isFWrapToWwd, isViewFlags_unused1, setBrcBottom, setBrcHorizontal, setBrcLeft, setBrcRight, setBrcTop, setBrcVertical, setCHorzBands, setCVertBands, setDxaAbs, setDxaAdjust, setDxaColWidthWwd, setDxaFromText, setDxaFromTextRight, setDxaGapHalf, setDxaRTEWrapWidth, setDxaWebView, setDyaAbs, setDyaFromText, setDyaFromTextBottom, setDyaRowHeight, setFAdjusted, setFAutofit, setFBiDi, setFCantSplit, setFCantSplit90, setFCellSpacing, setFFirstRow, setFHasOldProps, setFInvalAutofit, setFKeepFollow, setFLastRow, setFNeverBeenAutofit, setFNoAllowOverlap, setFNotPageView, setFOrigWordTableRules, setFOutline, setFPropRMark, setFRTL, setFSpare, setFTableHeader, setFtsCellPaddingDefaultBottom, setFtsCellPaddingDefaultLeft, setFtsCellPaddingDefaultRight, setFtsCellPaddingDefaultTop, setFtsCellPaddingOuterBottom, setFtsCellPaddingOuterLeft, setFtsCellPaddingOuterRight, setFtsCellPaddingOuterTop, setFtsCellSpacingDefaultBottom, setFtsCellSpacingDefaultLeft, setFtsCellSpacingDefaultRight, setFtsCellSpacingDefaultTop, setFtsCellSpacingOuterBottom, setFtsCellSpacingOuterLeft, setFtsCellSpacingOuterRight, setFtsCellSpacingOuterTop, setFtsWidth, setFtsWidthAfter, setFtsWidthBefore, setFtsWidthIndent, setFVert, setFWebView, setFWrapToWwd, setGrpfTap_unused, setGrpfTap, setInternalFlags, setIstd, setItcMac, setJc, setPcHorz, setPctWwd, setPcVert, setRgbrcInsideDefault_0, setRgbrcInsideDefault_1, setRgdxaCenter, setRgdxaCenterPrint, setRgshd, setRgtc, setShdTable, setTlp, setViewFlags_unused1, setViewFlags_unused2, setViewFlags, setWCellPaddingDefaultBottom, setWCellPaddingDefaultLeft, setWCellPaddingDefaultRight, setWCellPaddingDefaultTop, setWCellPaddingOuterBottom, setWCellPaddingOuterLeft, setWCellPaddingOuterRight, setWCellPaddingOuterTop, setWCellSpacingDefaultBottom, setWCellSpacingDefaultLeft, setWCellSpacingDefaultRight, setWCellSpacingDefaultTop, setWCellSpacingOuterBottom, setWCellSpacingOuterLeft, setWCellSpacingOuterRight, setWCellSpacingOuterTop, setWidthAndFitsFlags_empty1, setWidthAndFitsFlags_empty2, setWidthAndFitsFlags, setWWidth, setWWidthAfter, setWWidthBefore, setWWidthIndent, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TableProperties

public TableProperties()

TableProperties

public TableProperties(short columns)
Method Detail

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableRow

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.hwpf.usermodel
Class TableRow

java.lang.Object
    extended by  org.apache.poi.hwpf.usermodel.Range
        extended by  org.apache.poi.hwpf.usermodel.TableRow

public final class TableRow
extends Range

Field Summary
Fields inherited from class org.apache.poi.hwpf.usermodel.Range
_characters, _charEnd, _charRangeFound, _charStart, _doc, _end, _paragraphs, _parEnd, _parRangeFound, _parStart, _sectionEnd, _sections, _sectionStart, _start, _text, TYPE_CHARACTER, TYPE_LISTENTRY, TYPE_PARAGRAPH, TYPE_SECTION, TYPE_TABLE, TYPE_TEXT, TYPE_UNDEFINED
Constructor Summary
TableRow(int startIdxInclusive, int endIdxExclusive, Table parent, int levelNum)
Method Summary
boolean | cantSplit()
BorderCode | getBarBorder()
BorderCode | getBottomBorder()
TableCell | getCell(int index)
int | getGapHalf()
BorderCode | getHorizontalBorder()
BorderCode | getLeftBorder()
BorderCode | getRightBorder()
int | getRowHeight()
int | getRowJustification()
BorderCode | getTopBorder()
BorderCode | getVerticalBorder()
boolean | isTableHeader()
int | numCells()
protected void | reset() resets the list indexes.
void | setCantSplit(boolean cantSplit)
void | setGapHalf(int dxaGapHalf)
void | setRowHeight(int dyaRowHeight)
void | setRowJustification(int jc)
void | setTableHeader(boolean tableHeader)
Methods inherited from class org.apache.poi.hwpf.usermodel.Range
adjustFIB, delete, getCharacterRun, getDocument, getEndOffset, getParagraph, getSection, getStartOffset, getTable, initAll, insertAfter, insertAfter, insertAfter, insertAfter, insertAfter, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertBefore, insertTableBefore, numCharacterRuns, numParagraphs, numSections, replaceText, replaceText, replaceText, sanityCheck, stripFields, text, toString, type, usesUnicode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TableRow

public TableRow(int startIdxInclusive,
                int endIdxExclusive,
                Table parent,
                int levelNum)
Method Detail

cantSplit

public boolean cantSplit()

getBarBorder

public BorderCode getBarBorder()

getBottomBorder

public BorderCode getBottomBorder()

getCell

public TableCell getCell(int index)

getGapHalf

public int getGapHalf()

getHorizontalBorder

public BorderCode getHorizontalBorder()

getLeftBorder

public BorderCode getLeftBorder()

getRightBorder

public BorderCode getRightBorder()

getRowHeight

public int getRowHeight()

getRowJustification

public int getRowJustification()

getTopBorder

public BorderCode getTopBorder()

getVerticalBorder

public BorderCode getVerticalBorder()

isTableHeader

public boolean isTableHeader()

numCells

public int numCells()

reset

protected void reset()
Description copied from class: Range
resets the list indexes.

Overrides:
reset in class Range

setCantSplit

public void setCantSplit(boolean cantSplit)

setGapHalf

public void setGapHalf(int dxaGapHalf)

setRowHeight

public void setRowHeight(int dyaRowHeight)

setRowJustification

public void setRowJustification(int jc)

setTableHeader

public void setTableHeader(boolean tableHeader)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface org.apache.poi.hwpf.usermodel.Bookmark

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.Bookmark

Packages that use Bookmark
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of Bookmark in org.apache.poi.hwpf.converter

Method parameters in org.apache.poi.hwpf.converter with type arguments of type Bookmark
protected void | WordToTextConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected void | WordToHtmlConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected void | WordToFoConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected abstract void | AbstractWordConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks) Wrap range into bookmark(s) and process it.

Uses of Bookmark in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return Bookmark
Bookmark | BookmarksImpl.getBookmark(int index)
Bookmark | Bookmarks.getBookmark(int index)

Methods in org.apache.poi.hwpf.usermodel that return types with arguments of type Bookmark
java.util.List<Bookmark> | BookmarksImpl.getBookmarksAt(int startCp)
java.util.Map<java.lang.Integer,java.util.List<Bookmark>> | BookmarksImpl.getBookmarksStartedBetween(int startInclusive, int endExclusive)
java.util.Map<java.lang.Integer,java.util.List<Bookmark>> | Bookmarks.getBookmarksStartedBetween(int startInclusive, int endExclusive)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.usermodel.Bookmarks

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.Bookmarks

Packages that use Bookmarks
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of Bookmarks in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as Bookmarks
protected  Bookmarks HWPFDocument._bookmarks
Holds the bookmarks

Methods in org.apache.poi.hwpf that return Bookmarks
 Bookmarks HWPFDocument.getBookmarks()

Uses of Bookmarks in org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.usermodel that implement Bookmarks
 class BookmarksImpl
Implementation of user-friendly interface for document bookmarks

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.BookmarksImpl

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.BookmarksImpl

No usage of org.apache.poi.hwpf.usermodel.BookmarksImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.BorderCode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.BorderCode

Packages that use BorderCode
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.usermodel

Uses of BorderCode in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type BorderCode
static void | WordToHtmlUtils.addBorder(BorderCode borderCode, java.lang.String where, java.lang.StringBuilder style)
static java.lang.String | AbstractWordUtils.getBorderType(BorderCode borderCode)
static java.lang.String | AbstractWordUtils.getBorderWidth(BorderCode borderCode)
static void | WordToFoUtils.setBorder(org.w3c.dom.Element element, BorderCode borderCode, java.lang.String where)

Uses of BorderCode in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as BorderCode
protected BorderCode | TCAbstractType.field_20_brcTop
protected BorderCode | SEPAbstractType.field_20_brcTop
protected BorderCode | TCAbstractType.field_21_brcLeft
protected BorderCode | SEPAbstractType.field_21_brcLeft
protected BorderCode | TCAbstractType.field_22_brcBottom
protected BorderCode | SEPAbstractType.field_22_brcBottom
protected BorderCode | TCAbstractType.field_23_brcRight
protected BorderCode | SEPAbstractType.field_23_brcRight
protected BorderCode | CHPAbstractType.field_24_brc
protected BorderCode | TAPAbstractType.field_36_brcBottom
protected BorderCode | TAPAbstractType.field_37_brcTop
protected BorderCode | TAPAbstractType.field_38_brcLeft
protected BorderCode | TAPAbstractType.field_39_brcRight
protected BorderCode | TAPAbstractType.field_40_brcVertical
protected BorderCode | TAPAbstractType.field_41_brcHorizontal
protected BorderCode | PAPAbstractType.field_60_brcTop
protected BorderCode | PAPAbstractType.field_61_brcLeft
protected BorderCode | PAPAbstractType.field_62_brcBottom
protected BorderCode | PAPAbstractType.field_63_brcRight
protected BorderCode | PAPAbstractType.field_64_brcBetween
protected BorderCode | PAPAbstractType.field_65_brcBar
protected BorderCode | TAPAbstractType.field_80_rgbrcInsideDefault_0
protected BorderCode | TAPAbstractType.field_81_rgbrcInsideDefault_1

Methods in org.apache.poi.hwpf.model.types that return BorderCode
BorderCode | CHPAbstractType.getBrc() Border.
BorderCode | PAPAbstractType.getBrcBar() Get the brcBar field for the PAP record.
BorderCode | PAPAbstractType.getBrcBetween() Get the brcBetween field for the PAP record.
BorderCode | TCAbstractType.getBrcBottom() Bottom border.
BorderCode | TAPAbstractType.getBrcBottom() Get the brcBottom field for the TAP record.
BorderCode | SEPAbstractType.getBrcBottom() Get the brcBottom field for the SEP record.
BorderCode | PAPAbstractType.getBrcBottom() Get the brcBottom field for the PAP record.
BorderCode | TAPAbstractType.getBrcHorizontal() Get the brcHorizontal field for the TAP record.
BorderCode | TCAbstractType.getBrcLeft() Left border.
BorderCode | TAPAbstractType.getBrcLeft() Get the brcLeft field for the TAP record.
BorderCode | SEPAbstractType.getBrcLeft() Get the brcLeft field for the SEP record.
BorderCode | PAPAbstractType.getBrcLeft() Get the brcLeft field for the PAP record.
BorderCode | TCAbstractType.getBrcRight() Right border.
BorderCode | TAPAbstractType.getBrcRight() Get the brcRight field for the TAP record.
BorderCode | SEPAbstractType.getBrcRight() Get the brcRight field for the SEP record.
BorderCode | PAPAbstractType.getBrcRight() Get the brcRight field for the PAP record.
BorderCode | TCAbstractType.getBrcTop() Top border.
BorderCode | TAPAbstractType.getBrcTop() Get the brcTop field for the TAP record.
BorderCode | SEPAbstractType.getBrcTop() Get the brcTop field for the SEP record.
BorderCode | PAPAbstractType.getBrcTop() Get the brcTop field for the PAP record.
BorderCode | TAPAbstractType.getBrcVertical() Get the brcVertical field for the TAP record.
BorderCode | TAPAbstractType.getRgbrcInsideDefault_0() Border definition for inside horizontal borders.
BorderCode | TAPAbstractType.getRgbrcInsideDefault_1() Border definition for inside vertical borders.

Methods in org.apache.poi.hwpf.model.types with parameters of type BorderCode
void | CHPAbstractType.setBrc(BorderCode field_24_brc) Border.
void | PAPAbstractType.setBrcBar(BorderCode field_65_brcBar) Set the brcBar field for the PAP record.
void | PAPAbstractType.setBrcBetween(BorderCode field_64_brcBetween) Set the brcBetween field for the PAP record.
void | TCAbstractType.setBrcBottom(BorderCode field_22_brcBottom) Bottom border.
void | TAPAbstractType.setBrcBottom(BorderCode field_36_brcBottom) Set the brcBottom field for the TAP record.
void | SEPAbstractType.setBrcBottom(BorderCode field_22_brcBottom) Set the brcBottom field for the SEP record.
void | PAPAbstractType.setBrcBottom(BorderCode field_62_brcBottom) Set the brcBottom field for the PAP record.
void | TAPAbstractType.setBrcHorizontal(BorderCode field_41_brcHorizontal) Set the brcHorizontal field for the TAP record.
void | TCAbstractType.setBrcLeft(BorderCode field_21_brcLeft) Left border.
void | TAPAbstractType.setBrcLeft(BorderCode field_38_brcLeft) Set the brcLeft field for the TAP record.
void | SEPAbstractType.setBrcLeft(BorderCode field_21_brcLeft) Set the brcLeft field for the SEP record.
void | PAPAbstractType.setBrcLeft(BorderCode field_61_brcLeft) Set the brcLeft field for the PAP record.
void | TCAbstractType.setBrcRight(BorderCode field_23_brcRight) Right border.
void | TAPAbstractType.setBrcRight(BorderCode field_39_brcRight) Set the brcRight field for the TAP record.
void | SEPAbstractType.setBrcRight(BorderCode field_23_brcRight) Set the brcRight field for the SEP record.
void | PAPAbstractType.setBrcRight(BorderCode field_63_brcRight) Set the brcRight field for the PAP record.
void | TCAbstractType.setBrcTop(BorderCode field_20_brcTop) Top border.
void | TAPAbstractType.setBrcTop(BorderCode field_37_brcTop) Set the brcTop field for the TAP record.
void | SEPAbstractType.setBrcTop(BorderCode field_20_brcTop) Set the brcTop field for the SEP record.
void | PAPAbstractType.setBrcTop(BorderCode field_60_brcTop) Set the brcTop field for the PAP record.
void | TAPAbstractType.setBrcVertical(BorderCode field_40_brcVertical) Set the brcVertical field for the TAP record.
void | TAPAbstractType.setRgbrcInsideDefault_0(BorderCode field_80_rgbrcInsideDefault_0) Border definition for inside horizontal borders.
void | TAPAbstractType.setRgbrcInsideDefault_1(BorderCode field_81_rgbrcInsideDefault_1) Border definition for inside vertical borders.

Uses of BorderCode in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return BorderCode
BorderCode | TableRow.getBarBorder()
BorderCode | ParagraphProperties.getBarBorder()
BorderCode | Paragraph.getBarBorder()
BorderCode | CharacterRun.getBorder()
BorderCode | TableRow.getBottomBorder()
BorderCode | ParagraphProperties.getBottomBorder()
BorderCode | Paragraph.getBottomBorder()
BorderCode | TableCell.getBrcBottom()
BorderCode | TableCell.getBrcLeft()
BorderCode | TableCell.getBrcRight()
BorderCode | TableCell.getBrcTop()
BorderCode | TableRow.getHorizontalBorder()
BorderCode | TableRow.getLeftBorder()
BorderCode | ParagraphProperties.getLeftBorder()
BorderCode | Paragraph.getLeftBorder()
BorderCode | TableRow.getRightBorder()
BorderCode | ParagraphProperties.getRightBorder()
BorderCode | Paragraph.getRightBorder()
BorderCode | TableRow.getTopBorder()
BorderCode | ParagraphProperties.getTopBorder()
BorderCode | Paragraph.getTopBorder()
BorderCode | TableRow.getVerticalBorder()

Methods in org.apache.poi.hwpf.usermodel with parameters of type BorderCode
void | ParagraphProperties.setBarBorder(BorderCode bar)
void | Paragraph.setBarBorder(BorderCode bar)
void | ParagraphProperties.setBottomBorder(BorderCode bottom)
void | Paragraph.setBottomBorder(BorderCode bottom)
void | ParagraphProperties.setLeftBorder(BorderCode left)
void | Paragraph.setLeftBorder(BorderCode left)
void | ParagraphProperties.setRightBorder(BorderCode right)
void | Paragraph.setRightBorder(BorderCode right)
void | ParagraphProperties.setTopBorder(BorderCode top)
void | Paragraph.setTopBorder(BorderCode top)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.CharacterProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.CharacterProperties

Packages that use CharacterProperties
org.apache.poi.hwpf.model
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel

Uses of CharacterProperties in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return CharacterProperties
CharacterProperties | CHPX.getCharacterProperties(StyleSheet ss, short istd)
CharacterProperties | StyleSheet.getCharacterStyle(int styleIndex) Deprecated.
CharacterProperties | StyleDescription.getCHP() Deprecated.

Uses of CharacterProperties in org.apache.poi.hwpf.sprm

Methods in org.apache.poi.hwpf.sprm that return CharacterProperties
static CharacterProperties CharacterSprmUncompressor.uncompressCHP(CharacterProperties parent, byte[] grpprl, int offset)

Methods in org.apache.poi.hwpf.sprm with parameters of type CharacterProperties
static byte[] | CharacterSprmCompressor.compressCharacterProperty(CharacterProperties newCHP, CharacterProperties oldCHP)
static CharacterProperties | CharacterSprmUncompressor.uncompressCHP(CharacterProperties parent, byte[] grpprl, int offset)

Uses of CharacterProperties in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return CharacterProperties
 CharacterProperties CharacterRun.cloneProperties()
Deprecated. This method shall not be public and should not be called from high-level code

Methods in org.apache.poi.hwpf.usermodel with parameters of type CharacterProperties
CharacterRun | Range.insertAfter(java.lang.String text, CharacterProperties props) Deprecated. User code should not work with CharacterProperties
CharacterRun | Range.insertBefore(java.lang.String text, CharacterProperties props) Deprecated. User code should not work with CharacterProperties
void | HWPFList.setLevelNumberProperties(int level, CharacterProperties chp) Sets the character properties of the list numbers.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.CharacterRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.CharacterRun

Packages that use CharacterRun
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.model
org.apache.poi.hwpf.usermodel

Uses of CharacterRun in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type CharacterRun
static void | WordToHtmlUtils.addCharactersProperties(CharacterRun characterRun, java.lang.StringBuilder style)
protected FontReplacer.Triplet | AbstractWordConverter.getCharacterRunTriplet(CharacterRun characterRun)
protected void | WordToTextConverter.outputCharacters(org.w3c.dom.Element block, CharacterRun characterRun, java.lang.String text)
protected void | WordToHtmlConverter.outputCharacters(org.w3c.dom.Element pElement, CharacterRun characterRun, java.lang.String text)
protected void | WordToFoConverter.outputCharacters(org.w3c.dom.Element block, CharacterRun characterRun, java.lang.String text)
protected abstract void | AbstractWordConverter.outputCharacters(org.w3c.dom.Element block, CharacterRun characterRun, java.lang.String text)
protected void | AbstractWordConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, org.w3c.dom.Element block)
protected void | WordToTextConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToHtmlConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToFoConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected abstract void | AbstractWordConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToTextConverter.processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected void | WordToHtmlConverter.processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected void | WordToFoConverter.processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected abstract void | AbstractWordConverter.processLineBreak(org.w3c.dom.Element block, CharacterRun characterRun)
protected void | AbstractWordConverter.processNoteAnchor(HWPFDocument doc, CharacterRun characterRun, org.w3c.dom.Element block)
static void | WordToFoUtils.setCharactersProperties(CharacterRun characterRun, org.w3c.dom.Element inline)
static void | WordToFoUtils.setLanguage(CharacterRun characterRun, org.w3c.dom.Element inline)

Uses of CharacterRun in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model with parameters of type CharacterRun
Picture | PicturesTable.extractPicture(CharacterRun run, boolean fillBytes) Returns picture object tied to specified CharacterRun
boolean | PicturesTable.hasEscherPicture(CharacterRun run)
boolean | PicturesTable.hasHorizontalLine(CharacterRun run) determines whether specified CharacterRun contains reference to a picture
boolean | PicturesTable.hasPicture(CharacterRun run) determines whether specified CharacterRun contains reference to a picture

Uses of CharacterRun in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return CharacterRun
CharacterRun | Range.getCharacterRun(int index) Gets the character run at index.
CharacterRun | Field.getMarkEndCharacterRun(Range parent)
CharacterRun | Field.getMarkSeparatorCharacterRun(Range parent)
CharacterRun | Field.getMarkStartCharacterRun(Range parent)
CharacterRun | Range.insertAfter(java.lang.String text) Inserts text onto the end of this range
CharacterRun | Range.insertAfter(java.lang.String text, CharacterProperties props) Deprecated. User code should not work with CharacterProperties
CharacterRun | Range.insertBefore(java.lang.String text) Inserts text into the front of this range.
CharacterRun | Range.insertBefore(java.lang.String text, CharacterProperties props) Deprecated. User code should not work with CharacterProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.DateAndTime

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.DateAndTime

Packages that use DateAndTime
org.apache.poi.hwpf.model.types

Uses of DateAndTime in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as DateAndTime
protected DateAndTime | SEPAbstractType.field_26_dttmPropRMark
protected DateAndTime | CHPAbstractType.field_42_dttmRMark
protected DateAndTime | CHPAbstractType.field_43_dttmRMarkDel
protected DateAndTime | CHPAbstractType.field_53_dttmPropRMark
protected DateAndTime | CHPAbstractType.field_58_dttmConflict
protected DateAndTime | CHPAbstractType.field_61_dttmDispFldRMark
protected DateAndTime | PAPAbstractType.field_71_dttmPropRMark

Methods in org.apache.poi.hwpf.model.types that return DateAndTime
DateAndTime | CHPAbstractType.getDttmConflict() When the change was made.
DateAndTime | CHPAbstractType.getDttmDispFldRMark() The date for the ListNum field number change.
DateAndTime | SEPAbstractType.getDttmPropRMark() Get the dttmPropRMark field for the SEP record.
DateAndTime | PAPAbstractType.getDttmPropRMark() Get the dttmPropRMark field for the PAP record.
DateAndTime | CHPAbstractType.getDttmPropRMark() Date/time at which properties of this were changed for this run of text by the author.
DateAndTime | CHPAbstractType.getDttmRMark() Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
DateAndTime | CHPAbstractType.getDttmRMarkDel() Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).

Methods in org.apache.poi.hwpf.model.types with parameters of type DateAndTime
void | CHPAbstractType.setDttmConflict(DateAndTime field_58_dttmConflict) When the change was made.
void | CHPAbstractType.setDttmDispFldRMark(DateAndTime field_61_dttmDispFldRMark) The date for the ListNum field number change.
void | SEPAbstractType.setDttmPropRMark(DateAndTime field_26_dttmPropRMark) Set the dttmPropRMark field for the SEP record.
void | PAPAbstractType.setDttmPropRMark(DateAndTime field_71_dttmPropRMark) Set the dttmPropRMark field for the PAP record.
void | CHPAbstractType.setDttmPropRMark(DateAndTime field_53_dttmPropRMark) Date/time at which properties of this were changed for this run of text by the author.
void | CHPAbstractType.setDttmRMark(DateAndTime field_42_dttmRMark) Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
void | CHPAbstractType.setDttmRMarkDel(DateAndTime field_43_dttmRMarkDel) Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.DocumentPosition

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.DocumentPosition

No usage of org.apache.poi.hwpf.usermodel.DocumentPosition

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.DropCapSpecifier

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.DropCapSpecifier

Packages that use DropCapSpecifier
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.usermodel

Uses of DropCapSpecifier in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as DropCapSpecifier
protected  DropCapSpecifier PAPAbstractType.field_28_dcs

Methods in org.apache.poi.hwpf.model.types that return DropCapSpecifier
 DropCapSpecifier PAPAbstractType.getDcs()
Get the dcs field for the PAP record.

Methods in org.apache.poi.hwpf.model.types with parameters of type DropCapSpecifier
 void PAPAbstractType.setDcs(DropCapSpecifier field_28_dcs)
Set the dcs field for the PAP record.

Uses of DropCapSpecifier in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return DropCapSpecifier
DropCapSpecifier | DropCapSpecifier.clone()
DropCapSpecifier | ParagraphProperties.getDropCap()
DropCapSpecifier | Paragraph.getDropCap()

Methods in org.apache.poi.hwpf.usermodel with parameters of type DropCapSpecifier
void | ParagraphProperties.setDropCap(DropCapSpecifier dcs)
void | Paragraph.setDropCap(DropCapSpecifier dcs)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.usermodel.Field

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.Field

Packages that use Field
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of Field in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type Field
protected  void AbstractWordConverter.processField(HWPFDocument wordDocument, Range parentRange, int currentTableLevel, Field field, org.w3c.dom.Element currentBlock)

Uses of Field in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return Field
 Field Fields.getFieldByStartOffset(FieldsDocumentPart documentPart, int offset)

Methods in org.apache.poi.hwpf.usermodel that return types with arguments of type Field
java.util.Collection<Field> | FieldsImpl.getFields(FieldsDocumentPart part)
java.util.Collection<Field> | Fields.getFields(FieldsDocumentPart part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.usermodel.Fields

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.Fields

Packages that use Fields
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of Fields in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as Fields
protected  Fields HWPFDocument._fields
Holds the fields

Methods in org.apache.poi.hwpf that return Fields
 Fields HWPFDocument.getFields()
Returns user-friendly interface to access document Fields

Uses of Fields in org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.usermodel that implement Fields
 class FieldsImpl
Default implementation of Field

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.FieldsImpl

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.FieldsImpl

No usage of org.apache.poi.hwpf.usermodel.FieldsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.HeaderStories

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.HeaderStories

No usage of org.apache.poi.hwpf.usermodel.HeaderStories

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.HWPFList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.HWPFList

Packages that use HWPFList
org.apache.poi.hwpf

Uses of HWPFList in org.apache.poi.hwpf

Methods in org.apache.poi.hwpf with parameters of type HWPFList
 int HWPFDocument.registerList(HWPFList list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.LineSpacingDescriptor

Packages that use LineSpacingDescriptor
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.usermodel

Uses of LineSpacingDescriptor in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as LineSpacingDescriptor
protected  LineSpacingDescriptor PAPAbstractType.field_11_lspd

Methods in org.apache.poi.hwpf.model.types that return LineSpacingDescriptor
 LineSpacingDescriptor PAPAbstractType.getLspd()
Line spacing descriptor.

Methods in org.apache.poi.hwpf.model.types with parameters of type LineSpacingDescriptor
 void PAPAbstractType.setLspd(LineSpacingDescriptor field_11_lspd)
Line spacing descriptor.

Uses of LineSpacingDescriptor in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return LineSpacingDescriptor
LineSpacingDescriptor | ParagraphProperties.getLineSpacing()
LineSpacingDescriptor | Paragraph.getLineSpacing()

Methods in org.apache.poi.hwpf.usermodel with parameters of type LineSpacingDescriptor
void | ParagraphProperties.setLineSpacing(LineSpacingDescriptor lspd)
void | Paragraph.setLineSpacing(LineSpacingDescriptor lspd)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.ListEntry

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.ListEntry

Packages that use ListEntry
org.apache.poi.hwpf.usermodel

Uses of ListEntry in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return ListEntry
ListEntry | Range.insertAfter(ParagraphProperties props, int listID, int level, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties
ListEntry | Range.insertBefore(ParagraphProperties props, int listID, int level, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.usermodel.Notes

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.Notes

Packages that use Notes
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of Notes in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as Notes
protected Notes | HWPFDocument._endnotes Holds the footnotes
protected Notes | HWPFDocument._footnotes Holds the footnotes

Methods in org.apache.poi.hwpf that return Notes
Notes | HWPFDocument.getEndnotes()
Notes | HWPFDocument.getFootnotes()

Uses of Notes in org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.usermodel that implement Notes
 class NotesImpl
Default implementation of Notes interface

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.NotesImpl

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.NotesImpl

No usage of org.apache.poi.hwpf.usermodel.NotesImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.ObjectPoolImpl

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.ObjectPoolImpl

Packages that use ObjectPoolImpl
org.apache.poi.hwpf

Uses of ObjectPoolImpl in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as ObjectPoolImpl
protected  ObjectPoolImpl HWPFDocumentCore._objectPool
Holds OLE2 objects

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.usermodel.ObjectsPool

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.ObjectsPool

Packages that use ObjectsPool
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of ObjectsPool in org.apache.poi.hwpf

Methods in org.apache.poi.hwpf that return ObjectsPool
 ObjectsPool HWPFDocumentCore.getObjectsPool()

Uses of ObjectsPool in org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.usermodel that implement ObjectsPool
 class ObjectPoolImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalPositioning

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalPositioning

Packages that use OfficeDrawing.HorizontalPositioning
org.apache.poi.hwpf.usermodel

Uses of OfficeDrawing.HorizontalPositioning in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return OfficeDrawing.HorizontalPositioning
OfficeDrawing.HorizontalPositioning | OfficeDrawing.getHorizontalPositioning() Returns the type of horizontal positioning to use for a shape
static OfficeDrawing.HorizontalPositioning | OfficeDrawing.HorizontalPositioning.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.HorizontalPositioning[] | OfficeDrawing.HorizontalPositioning.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalRelativeElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.OfficeDrawing.HorizontalRelativeElement

Packages that use OfficeDrawing.HorizontalRelativeElement
org.apache.poi.hwpf.usermodel

Uses of OfficeDrawing.HorizontalRelativeElement in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return OfficeDrawing.HorizontalRelativeElement
OfficeDrawing.HorizontalRelativeElement | OfficeDrawing.getHorizontalRelative() Specifies a page element relative to which a shape is horizontally positioned
static OfficeDrawing.HorizontalRelativeElement | OfficeDrawing.HorizontalRelativeElement.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.HorizontalRelativeElement[] | OfficeDrawing.HorizontalRelativeElement.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.usermodel.OfficeDrawing

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.OfficeDrawing

Packages that use OfficeDrawing
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of OfficeDrawing in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type OfficeDrawing
protected void | WordToTextConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToHtmlConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected void | WordToFoConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)
protected abstract void | AbstractWordConverter.processDrawnObject(HWPFDocument doc, CharacterRun characterRun, OfficeDrawing officeDrawing, java.lang.String path, org.w3c.dom.Element block)

Uses of OfficeDrawing in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return OfficeDrawing
OfficeDrawing | OfficeDrawingsImpl.getOfficeDrawingAt(int characterPosition)
OfficeDrawing | OfficeDrawings.getOfficeDrawingAt(int characterPosition)

Methods in org.apache.poi.hwpf.usermodel that return types with arguments of type OfficeDrawing
java.util.Collection<OfficeDrawing> | OfficeDrawingsImpl.getOfficeDrawings()
java.util.Collection<OfficeDrawing> | OfficeDrawings.getOfficeDrawings()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalPositioning

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalPositioning

Packages that use OfficeDrawing.VerticalPositioning
org.apache.poi.hwpf.usermodel

Uses of OfficeDrawing.VerticalPositioning in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return OfficeDrawing.VerticalPositioning
OfficeDrawing.VerticalPositioning | OfficeDrawing.getVerticalPositioning() Specifies the type of vertical positioning to use for a shape
static OfficeDrawing.VerticalPositioning | OfficeDrawing.VerticalPositioning.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.VerticalPositioning[] | OfficeDrawing.VerticalPositioning.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalRelativeElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.OfficeDrawing.VerticalRelativeElement

Packages that use OfficeDrawing.VerticalRelativeElement
org.apache.poi.hwpf.usermodel

Uses of OfficeDrawing.VerticalRelativeElement in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return OfficeDrawing.VerticalRelativeElement
OfficeDrawing.VerticalRelativeElement | OfficeDrawing.getVerticalRelativeElement() Specifies a page element relative to which a shape is vertically positioned
static OfficeDrawing.VerticalRelativeElement | OfficeDrawing.VerticalRelativeElement.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OfficeDrawing.VerticalRelativeElement[] | OfficeDrawing.VerticalRelativeElement.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.hwpf.usermodel.OfficeDrawings

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.hwpf.usermodel.OfficeDrawings

Packages that use OfficeDrawings
org.apache.poi.hwpf
org.apache.poi.hwpf.usermodel

Uses of OfficeDrawings in org.apache.poi.hwpf

Methods in org.apache.poi.hwpf that return OfficeDrawings
OfficeDrawings | HWPFDocument.getOfficeDrawingsHeaders()
OfficeDrawings | HWPFDocument.getOfficeDrawingsMain()

Uses of OfficeDrawings in org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.usermodel that implement OfficeDrawings
 class OfficeDrawingsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.OfficeDrawingsImpl

Packages that use OfficeDrawingsImpl
org.apache.poi.hwpf

Uses of OfficeDrawingsImpl in org.apache.poi.hwpf

Fields in org.apache.poi.hwpf declared as OfficeDrawingsImpl
protected OfficeDrawingsImpl | HWPFDocument._officeDrawingsHeaders Holds Office Art objects
protected OfficeDrawingsImpl | HWPFDocument._officeDrawingsMain Holds Office Art objects

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.Paragraph

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.Paragraph

Packages that use Paragraph
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of Paragraph in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type Paragraph
static void | WordToHtmlUtils.addIndent(Paragraph paragraph, java.lang.StringBuilder style)
static void | WordToHtmlUtils.addJustification(Paragraph paragraph, java.lang.StringBuilder style)
static void | WordToHtmlUtils.addParagraphProperties(Paragraph paragraph, java.lang.StringBuilder style)
static java.lang.String | AbstractWordUtils.getBulletText(ListTables listTables, Paragraph paragraph, int listId)
protected void | WordToTextConverter.processParagraph(HWPFDocumentCore wordDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected void | WordToHtmlConverter.processParagraph(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected void | WordToFoConverter.processParagraph(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element parentFopElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
protected abstract void | AbstractWordConverter.processParagraph(HWPFDocumentCore wordDocument, org.w3c.dom.Element parentElement, int currentTableLevel, Paragraph paragraph, java.lang.String bulletText)
static void | WordToFoUtils.setIndent(Paragraph paragraph, org.w3c.dom.Element block)
static void | WordToFoUtils.setJustification(Paragraph paragraph, org.w3c.dom.Element element)
static void | WordToFoUtils.setParagraphProperties(Paragraph paragraph, org.w3c.dom.Element block)

Uses of Paragraph in org.apache.poi.hwpf.usermodel

Subclasses of Paragraph in org.apache.poi.hwpf.usermodel
 class ListEntry

Methods in org.apache.poi.hwpf.usermodel that return Paragraph
Paragraph | Range.getParagraph(int index) Gets the paragraph at index.
Paragraph | Range.insertAfter(ParagraphProperties props, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties
protected Paragraph | Range.insertAfter(ParagraphProperties props, int styleIndex, java.lang.String text) Deprecated. Use code shall not work with ParagraphProperties
Paragraph | Range.insertBefore(ParagraphProperties props, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties
protected Paragraph | Range.insertBefore(ParagraphProperties props, int styleIndex, java.lang.String text) Deprecated. Use code shall not work with ParagraphProperties

Methods in org.apache.poi.hwpf.usermodel with parameters of type Paragraph
 Table Range.getTable(Paragraph paragraph)
Gets the table that starts with paragraph.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.ParagraphProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.ParagraphProperties

Packages that use ParagraphProperties
org.apache.poi.hwpf.dev
org.apache.poi.hwpf.model
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel

Uses of ParagraphProperties in org.apache.poi.hwpf.dev

Methods in org.apache.poi.hwpf.dev with parameters of type ParagraphProperties
protected  void HWPFLister.dumpParagraphLevels(ListTables listTables, ParagraphProperties paragraph)

Uses of ParagraphProperties in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return ParagraphProperties
ParagraphProperties | StyleDescription.getPAP() Deprecated.
ParagraphProperties | PAPX.getParagraphProperties(StyleSheet ss) Deprecated.
ParagraphProperties | StyleSheet.getParagraphStyle(int styleIndex) Deprecated.

Uses of ParagraphProperties in org.apache.poi.hwpf.sprm

Methods in org.apache.poi.hwpf.sprm that return ParagraphProperties
static ParagraphProperties ParagraphSprmUncompressor.uncompressPAP(ParagraphProperties parent, byte[] grpprl, int offset)

Methods in org.apache.poi.hwpf.sprm with parameters of type ParagraphProperties
static byte[] | ParagraphSprmCompressor.compressParagraphProperty(ParagraphProperties newPAP, ParagraphProperties oldPAP)
static ParagraphProperties | ParagraphSprmUncompressor.uncompressPAP(ParagraphProperties parent, byte[] grpprl, int offset)

Uses of ParagraphProperties in org.apache.poi.hwpf.usermodel

Fields in org.apache.poi.hwpf.usermodel declared as ParagraphProperties
protected  ParagraphProperties Paragraph._props

Methods in org.apache.poi.hwpf.usermodel that return ParagraphProperties
ParagraphProperties | Paragraph.cloneProperties() clone the ParagraphProperties object associated with this Paragraph so that you can apply the same properties to another paragraph.
protected static ParagraphProperties | Paragraph.newParagraph_applyStyleProperties(StyleSheet styleSheet, PAPX papx, ParagraphProperties properties)

Methods in org.apache.poi.hwpf.usermodel with parameters of type ParagraphProperties
Paragraph | Range.insertAfter(ParagraphProperties props, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties
ListEntry | Range.insertAfter(ParagraphProperties props, int listID, int level, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties
protected Paragraph | Range.insertAfter(ParagraphProperties props, int styleIndex, java.lang.String text) Deprecated. Use code shall not work with ParagraphProperties
Paragraph | Range.insertBefore(ParagraphProperties props, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties
ListEntry | Range.insertBefore(ParagraphProperties props, int listID, int level, int styleIndex) Deprecated. Use code shall not work with ParagraphProperties
protected Paragraph | Range.insertBefore(ParagraphProperties props, int styleIndex, java.lang.String text) Deprecated. Use code shall not work with ParagraphProperties
protected static ParagraphProperties | Paragraph.newParagraph_applyStyleProperties(StyleSheet styleSheet, PAPX papx, ParagraphProperties properties)
void | HWPFList.setLevelParagraphProperties(int level, ParagraphProperties pap) Sets the paragraph properties for a particular level of the list.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.Picture

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.Picture

Packages that use Picture
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.model

Uses of Picture in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type Picture
protected void | WordToTextConverter.processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected void | AbstractWordConverter.processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected void | WordToTextConverter.processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String url)
protected void | WordToHtmlConverter.processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String imageSourcePath)
protected void | WordToFoConverter.processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String url)
protected abstract void | AbstractWordConverter.processImage(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture, java.lang.String url)
protected void | WordToTextConverter.processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected void | WordToHtmlConverter.processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected void | WordToFoConverter.processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
protected abstract void | AbstractWordConverter.processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)
static void | WordToFoUtils.setPictureProperties(Picture picture, org.w3c.dom.Element graphicElement)

Uses of Picture in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return Picture
 Picture PicturesTable.extractPicture(CharacterRun run, boolean fillBytes)
Returns picture object tied to specified CharacterRun

Methods in org.apache.poi.hwpf.model that return types with arguments of type Picture
 java.util.List<Picture> PicturesTable.getAllPictures()
Not all documents have all the images concatenated in the data stream although MS claims so.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.PictureType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.PictureType

Packages that use PictureType
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of PictureType in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type PictureType
 java.lang.String PicturesManager.savePicture(byte[] content, PictureType pictureType, java.lang.String suggestedName, float widthInches, float heightInches)
Stores image (probably on disk).

Uses of PictureType in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return PictureType
static PictureType | PictureType.findMatchingType(byte[] pictureContent)
PictureType | Picture.suggestPictureType()
static PictureType | PictureType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PictureType[] | PictureType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.Range

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.Range

Packages that use Range
org.apache.poi.hwpf
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.extractor
org.apache.poi.hwpf.usermodel

Uses of Range in org.apache.poi.hwpf

Methods in org.apache.poi.hwpf that return Range
Range | HWPFDocument.getCommentsRange() Returns the Range which covers all annotations.
Range | HWPFDocument.getEndnoteRange() Returns the Range which covers all endnotes.
Range | HWPFDocument.getFootnoteRange() Returns the Range which covers all the Footnotes.
Range | HWPFDocument.getHeaderStoryRange() Returns the range which covers all "Header Stories".
Range | HWPFDocument.getMainTextboxRange() Returns the Range which covers all textboxes.
Range | HWPFOldDocument.getOverallRange()
abstract Range | HWPFDocumentCore.getOverallRange() Returns the range that covers all text in the file, including main text, footnotes, headers and comments
Range | HWPFDocument.getOverallRange()
Range | HWPFOldDocument.getRange()
abstract Range | HWPFDocumentCore.getRange() Returns the range which covers the whole of the document, but excludes any headers and footers.
Range | HWPFDocument.getRange() Returns the range which covers the whole of the document, but excludes any headers and footers.

Uses of Range in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type Range
protected void | WordToTextConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected void | WordToHtmlConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected void | WordToFoConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks)
protected abstract void | AbstractWordConverter.processBookmarks(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, java.util.List<Bookmark> rangeBookmarks) Wrap range into bookmark(s) and process it.
protected boolean | AbstractWordConverter.processCharacters(HWPFDocumentCore wordDocument, int currentTableLevel, Range range, org.w3c.dom.Element block)
protected void | AbstractWordConverter.processDeadField(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range range, int currentTableLevel, int beginMark, int separatorMark, int endMark)
void | WordToTextConverter.processDocumentPart(HWPFDocumentCore wordDocument, Range range)
void | WordToHtmlConverter.processDocumentPart(HWPFDocumentCore wordDocument, Range range)
protected void | AbstractWordConverter.processDocumentPart(HWPFDocumentCore wordDocument, Range range)
protected void | WordToTextConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected void | WordToHtmlConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected void | WordToFoConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected abstract void | AbstractWordConverter.processEndnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range endnoteTextRange)
protected void | AbstractWordConverter.processField(HWPFDocument wordDocument, Range parentRange, int currentTableLevel, Field field, org.w3c.dom.Element currentBlock)
protected void | WordToTextConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected void | WordToHtmlConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected void | WordToFoConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected abstract void | AbstractWordConverter.processFootnoteAutonumbered(HWPFDocument wordDocument, int noteIndex, org.w3c.dom.Element block, Range footnoteTextRange)
protected void | WordToTextConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected void | WordToHtmlConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected void | WordToFoConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected abstract void | AbstractWordConverter.processHyperlink(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String hyperlink)
protected void | WordToTextConverter.processNote(HWPFDocument wordDocument, org.w3c.dom.Element block, Range noteTextRange)
protected void | WordToHtmlConverter.processNoteAutonumbered(HWPFDocument doc, java.lang.String type, int noteIndex, org.w3c.dom.Element block, Range noteTextRange)
protected void | WordToTextConverter.processPageref(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected void | WordToHtmlConverter.processPageref(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected void | WordToFoConverter.processPageref(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected abstract void | AbstractWordConverter.processPageref(HWPFDocumentCore wordDocument, org.w3c.dom.Element currentBlock, Range textRange, int currentTableLevel, java.lang.String pageref)
protected void | AbstractWordConverter.processParagraphes(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Range range, int currentTableLevel)
protected int | AbstractWordConverter.tryDeadField(HWPFDocumentCore wordDocument, Range range, int currentTableLevel, int beginMark, org.w3c.dom.Element currentBlock)

Uses of Range in org.apache.poi.hwpf.extractor

Methods in org.apache.poi.hwpf.extractor with parameters of type Range
protected static java.lang.String[] WordExtractor.getParagraphText(Range r)

Uses of Range in org.apache.poi.hwpf.usermodel

Subclasses of Range in org.apache.poi.hwpf.usermodel
class | CharacterRun This class represents a run of text that share common properties.
class | DocumentPosition
class | ListEntry
class | Paragraph
class | Section
class | Table
class | TableCell
class | TableRow

Methods in org.apache.poi.hwpf.usermodel that return Range
Range | Field.firstSubrange(Range parent)
Range | HeaderStories.getEndnoteContNoteSubrange()
Range | HeaderStories.getEndnoteContSeparatorSubrange()
Range | HeaderStories.getEndnoteSeparatorSubrange()
Range | HeaderStories.getEvenFooterSubrange()
Range | HeaderStories.getEvenHeaderSubrange()
Range | HeaderStories.getFirstFooterSubrange()
Range | HeaderStories.getFirstHeaderSubrange()
Range | HeaderStories.getFootnoteContNoteSubrange()
Range | HeaderStories.getFootnoteContSeparatorSubrange()
Range | HeaderStories.getFootnoteSeparatorSubrange()
Range | HeaderStories.getOddFooterSubrange()
Range | HeaderStories.getOddHeaderSubrange()
Range | HeaderStories.getRange()
Range | Field.secondSubrange(Range parent)

Methods in org.apache.poi.hwpf.usermodel with parameters of type Range
Range | Field.firstSubrange(Range parent)
CharacterRun | Field.getMarkEndCharacterRun(Range parent)
CharacterRun | Field.getMarkSeparatorCharacterRun(Range parent)
CharacterRun | Field.getMarkStartCharacterRun(Range parent)
Range | Field.secondSubrange(Range parent)

Constructors in org.apache.poi.hwpf.usermodel with parameters of type Range
Paragraph(PAPX papx, Range parent)
Deprecated.
Paragraph(PAPX papx, Range parent, int start)
Deprecated.
Range(int startIdx, int endIdx, int idxType, Range parent)
Deprecated.
Range(int start, int end, Range parent)
Used to create Ranges that are children of other Ranges.
Section(SEPX sepx, Range parent)
TableIterator(Range range)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.Section

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.Section

Packages that use Section
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of Section in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type Section
protected java.lang.String | WordToFoConverter.createPageMaster(Section section, java.lang.String type, int sectionIndex)
protected void | WordToTextConverter.processSection(HWPFDocumentCore wordDocument, Section section, int s)
protected void | WordToHtmlConverter.processSection(HWPFDocumentCore wordDocument, Section section, int sectionCounter)
protected void | WordToFoConverter.processSection(HWPFDocumentCore wordDocument, Section section, int sectionCounter)
protected abstract void | AbstractWordConverter.processSection(HWPFDocumentCore wordDocument, Section section, int s)
protected void | WordToHtmlConverter.processSingleSection(HWPFDocumentCore wordDocument, Section section)
protected void | AbstractWordConverter.processSingleSection(HWPFDocumentCore wordDocument, Section section)

Uses of Section in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return Section
 Section Range.getSection(int index)
Gets the section at index.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.SectionProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.SectionProperties

Packages that use SectionProperties
org.apache.poi.hwpf.model
org.apache.poi.hwpf.sprm

Uses of SectionProperties in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return SectionProperties
 SectionProperties SEPX.getSectionProperties()

Uses of SectionProperties in org.apache.poi.hwpf.sprm

Methods in org.apache.poi.hwpf.sprm that return SectionProperties
static SectionProperties SectionSprmUncompressor.uncompressSEP(byte[] grpprl, int offset)

Methods in org.apache.poi.hwpf.sprm with parameters of type SectionProperties
static byte[] SectionSprmCompressor.compressSectionProperty(SectionProperties newSEP)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.ShadingDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.ShadingDescriptor

Packages that use ShadingDescriptor
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.usermodel

Uses of ShadingDescriptor in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as ShadingDescriptor
protected ShadingDescriptor | CHPAbstractType.field_23_shd
protected ShadingDescriptor | TCAbstractType.field_3_shd
protected ShadingDescriptor | TAPAbstractType.field_35_shdTable
protected ShadingDescriptor | PAPAbstractType.field_66_shd
protected ShadingDescriptor[] | TAPAbstractType.field_75_rgshd

Methods in org.apache.poi.hwpf.model.types that return ShadingDescriptor
ShadingDescriptor[] | TAPAbstractType.getRgshd() Get the rgshd field for the TAP record.
ShadingDescriptor | TCAbstractType.getShd() Cell shading.
ShadingDescriptor | PAPAbstractType.getShd() Get the shd field for the PAP record.
ShadingDescriptor | CHPAbstractType.getShd() Shading.
ShadingDescriptor | TAPAbstractType.getShdTable() Table shading.

Methods in org.apache.poi.hwpf.model.types with parameters of type ShadingDescriptor
void | TAPAbstractType.setRgshd(ShadingDescriptor[] field_75_rgshd) Set the rgshd field for the TAP record.
void | TCAbstractType.setShd(ShadingDescriptor field_3_shd) Cell shading.
void | PAPAbstractType.setShd(ShadingDescriptor field_66_shd) Set the shd field for the PAP record.
void | CHPAbstractType.setShd(ShadingDescriptor field_23_shd) Shading.
void | TAPAbstractType.setShdTable(ShadingDescriptor field_35_shdTable) Table shading.

Uses of ShadingDescriptor in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return ShadingDescriptor
ShadingDescriptor | ShadingDescriptor.clone()
ShadingDescriptor | ParagraphProperties.getShading()
ShadingDescriptor | Paragraph.getShading()
ShadingDescriptor | ShadingDescriptor80.toShadingDescriptor()

Methods in org.apache.poi.hwpf.usermodel with parameters of type ShadingDescriptor
void | ParagraphProperties.setShading(ShadingDescriptor shd)
void | Paragraph.setShading(ShadingDescriptor shd)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.ShadingDescriptor80

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.ShadingDescriptor80

Packages that use ShadingDescriptor80
org.apache.poi.hwpf.usermodel

Uses of ShadingDescriptor80 in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return ShadingDescriptor80
 ShadingDescriptor80 ShadingDescriptor80.clone()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.Shape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.Shape

Packages that use Shape
org.apache.poi.hwpf.model

Uses of Shape in org.apache.poi.hwpf.model

Methods in org.apache.poi.hwpf.model that return types with arguments of type Shape
java.util.List<Shape> | ShapesTable.getAllShapes() Deprecated.
java.util.List<Shape> | ShapesTable.getVisibleShapes() Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.Table

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.Table

Packages that use Table
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of Table in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type Table
protected int | AbstractWordConverter.getNumberRowsSpanned(Table table, int[] tableCellEdges, int currentRowIndex, int currentColumnIndex, TableCell tableCell)
protected void | WordToTextConverter.processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
protected void | WordToHtmlConverter.processTable(HWPFDocumentCore hwpfDocument, org.w3c.dom.Element flow, Table table)
protected void | WordToFoConverter.processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)
protected abstract void | AbstractWordConverter.processTable(HWPFDocumentCore wordDocument, org.w3c.dom.Element flow, Table table)

Uses of Table in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return Table
 Table Range.getTable(Paragraph paragraph)
Gets the table that starts with paragraph.
 Table Range.insertBefore(TableProperties props, int rows)
Deprecated. Use code shall not work with TableProperties. Use Range.insertTableBefore(short, int) instead
 Table Range.insertTableBefore(short columns, int rows)
Inserts a simple table into the beginning of this range.
 Table TableIterator.next()

Constructors in org.apache.poi.hwpf.usermodel with parameters of type Table
Paragraph(int startIdxInclusive, int endIdxExclusive, Table parent)
Deprecated.
TableRow(int startIdxInclusive, int endIdxExclusive, Table parent, int levelNum)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.TableAutoformatLookSpecifier

Packages that use TableAutoformatLookSpecifier
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.usermodel

Uses of TableAutoformatLookSpecifier in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as TableAutoformatLookSpecifier
protected  TableAutoformatLookSpecifier TAPAbstractType.field_8_tlp

Methods in org.apache.poi.hwpf.model.types that return TableAutoformatLookSpecifier
 TableAutoformatLookSpecifier TAPAbstractType.getTlp()
Table look specifier.

Methods in org.apache.poi.hwpf.model.types with parameters of type TableAutoformatLookSpecifier
 void TAPAbstractType.setTlp(TableAutoformatLookSpecifier field_8_tlp)
Table look specifier.

Uses of TableAutoformatLookSpecifier in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return TableAutoformatLookSpecifier
 TableAutoformatLookSpecifier TableAutoformatLookSpecifier.clone()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.TableCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.TableCell

Packages that use TableCell
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of TableCell in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type TableCell
static void | WordToHtmlUtils.addTableCellProperties(TableRow tableRow, TableCell tableCell, boolean toppest, boolean bottomest, boolean leftest, boolean rightest, java.lang.StringBuilder style)
protected int | AbstractWordConverter.getNumberColumnsSpanned(int[] tableCellEdges, int currentEdgeIndex, TableCell tableCell)
protected int | AbstractWordConverter.getNumberRowsSpanned(Table table, int[] tableCellEdges, int currentRowIndex, int currentColumnIndex, TableCell tableCell)
static void | WordToFoUtils.setTableCellProperties(TableRow tableRow, TableCell tableCell, org.w3c.dom.Element element, boolean toppest, boolean bottomest, boolean leftest, boolean rightest)

Uses of TableCell in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return TableCell
 TableCell TableRow.getCell(int index)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.TableCellDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.TableCellDescriptor

Packages that use TableCellDescriptor
org.apache.poi.hwpf.model.types
org.apache.poi.hwpf.usermodel

Uses of TableCellDescriptor in org.apache.poi.hwpf.model.types

Fields in org.apache.poi.hwpf.model.types declared as TableCellDescriptor
protected  TableCellDescriptor[] TAPAbstractType.field_74_rgtc

Methods in org.apache.poi.hwpf.model.types that return TableCellDescriptor
 TableCellDescriptor[] TAPAbstractType.getRgtc()
Get the rgtc field for the TAP record.

Methods in org.apache.poi.hwpf.model.types with parameters of type TableCellDescriptor
 void TAPAbstractType.setRgtc(TableCellDescriptor[] field_74_rgtc)
Set the rgtc field for the TAP record.

Uses of TableCellDescriptor in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return TableCellDescriptor
static TableCellDescriptor | TableCellDescriptor.convertBytesToTC(byte[] buf, int offset)
TableCellDescriptor | TableCell.getDescriptor() Returns the TableCellDescriptor for this cell.

Constructors in org.apache.poi.hwpf.usermodel with parameters of type TableCellDescriptor
TableCell(int startIdxInclusive, int endIdxExclusive, TableRow parent, int levelNum, TableCellDescriptor tcd, int leftEdge, int width)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.TableIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.TableIterator

No usage of org.apache.poi.hwpf.usermodel.TableIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.TableProperties

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.TableProperties

Packages that use TableProperties
org.apache.poi.hwpf.sprm
org.apache.poi.hwpf.usermodel

Uses of TableProperties in org.apache.poi.hwpf.sprm

Methods in org.apache.poi.hwpf.sprm that return TableProperties
static TableProperties | TableSprmUncompressor.uncompressTAP(byte[] grpprl, int offset) Deprecated.
static TableProperties | TableSprmUncompressor.uncompressTAP(SprmBuffer sprmBuffer)

Methods in org.apache.poi.hwpf.sprm with parameters of type TableProperties
static byte[] TableSprmCompressor.compressTableProperty(TableProperties newTAP)

Uses of TableProperties in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel with parameters of type TableProperties
 Table Range.insertBefore(TableProperties props, int rows)
Deprecated. Use code shall not work with TableProperties. Use Range.insertTableBefore(short, int) instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.hwpf.usermodel.TableRow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.hwpf.usermodel.TableRow

Packages that use TableRow
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.usermodel

Uses of TableRow in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type TableRow
static void | WordToHtmlUtils.addTableCellProperties(TableRow tableRow, TableCell tableCell, boolean toppest, boolean bottomest, boolean leftest, boolean rightest, java.lang.StringBuilder style)
static void | WordToHtmlUtils.addTableRowProperties(TableRow tableRow, java.lang.StringBuilder style)
static void | WordToFoUtils.setTableCellProperties(TableRow tableRow, TableCell tableCell, org.w3c.dom.Element element, boolean toppest, boolean bottomest, boolean leftest, boolean rightest)
static void | WordToFoUtils.setTableRowProperties(TableRow tableRow, org.w3c.dom.Element tableRowElement)

Uses of TableRow in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return TableRow
 TableRow Table.getRow(int index)

Constructors in org.apache.poi.hwpf.usermodel with parameters of type TableRow
TableCell(int startIdxInclusive, int endIdxExclusive, TableRow parent, int levelNum, TableCellDescriptor tcd, int leftEdge, int width)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


InvalidFormatException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.exceptions
Class InvalidFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.openxml4j.exceptions.OpenXML4JException
                extended by  org.apache.poi.openxml4j.exceptions.InvalidFormatException
All Implemented Interfaces:
java.io.Serializable
public final class InvalidFormatException
extends OpenXML4JException

See Also:
Serialized Form

Constructor Summary
InvalidFormatException(java.lang.String message)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidFormatException

public InvalidFormatException(java.lang.String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidOperationException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.exceptions
Class InvalidOperationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException
                    extended by  org.apache.poi.openxml4j.exceptions.InvalidOperationException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
PartAlreadyExistsException
public class InvalidOperationException
extends OpenXML4JRuntimeException

Throw when an invalid operation is done.

See Also:
Serialized Form

Constructor Summary
InvalidOperationException(java.lang.String message)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidOperationException

public InvalidOperationException(java.lang.String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OpenXML4JException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.exceptions
Class OpenXML4JException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.openxml4j.exceptions.OpenXML4JException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
InvalidFormatException
public class OpenXML4JException
extends java.lang.Exception

Global exception throws when a critical error occurs. (this exception is not set as Runtime in order to force user to manage the exception in a try/catch).

Version:
1.0
Author:
CDubettier, Julien Chable
See Also:
Serialized Form

Constructor Summary
OpenXML4JException(java.lang.String msg)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OpenXML4JException

public OpenXML4JException(java.lang.String msg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OpenXML4JRuntimeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.exceptions
Class OpenXML4JRuntimeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
InvalidOperationException
public class OpenXML4JRuntimeException
extends java.lang.RuntimeException

Global exception throws when a critical error occurs (this exception is set as Runtime in order not to force the user to manage the exception in a try/catch).

Version:
1.0
Author:
Julien Chable
See Also:
Serialized Form

Constructor Summary
OpenXML4JRuntimeException(java.lang.String msg)
OpenXML4JRuntimeException(java.lang.String msg, java.lang.Throwable reason)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OpenXML4JRuntimeException

public OpenXML4JRuntimeException(java.lang.String msg)

OpenXML4JRuntimeException

public OpenXML4JRuntimeException(java.lang.String msg,
                                 java.lang.Throwable reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.openxml4j.exceptions
Exceptions
InvalidFormatException
InvalidOperationException
OpenXML4JException
OpenXML4JRuntimeException
PartAlreadyExistsException


org.apache.poi.openxml4j.exceptions

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.exceptions

Exception Summary
InvalidFormatException |
InvalidOperationException | Throw when an invalid operation is done.
OpenXML4JException | Global exception throws when a critical error occurs.
OpenXML4JRuntimeException | Global exception throws when a critical error occurs (this exception is set as Runtime in order not to force the user to manage the exception in a try/catch).
PartAlreadyExistsException | Throw when trying to create a PackagePart but one already exists with that name.


org.apache.poi.openxml4j.exceptions Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.exceptions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.openxml4j.exceptions.OpenXML4JException
          • org.apache.poi.openxml4j.exceptions.InvalidFormatException
        • java.lang.RuntimeException
          • org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException
            • org.apache.poi.openxml4j.exceptions.InvalidOperationException
              • org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException


Uses of Package org.apache.poi.openxml4j.exceptions

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.exceptions

Packages that use org.apache.poi.openxml4j.exceptions
org.apache.poi |
org.apache.poi.extractor |
org.apache.poi.openxml4j.exceptions |
org.apache.poi.openxml4j.opc |
org.apache.poi.openxml4j.opc.internal |
org.apache.poi.openxml4j.opc.internal.marshallers |
org.apache.poi.openxml4j.opc.internal.signature |
org.apache.poi.openxml4j.opc.internal.unmarshallers |
org.apache.poi.openxml4j.opc.signature |
org.apache.poi.ss.usermodel |
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.
org.apache.poi.xslf |
org.apache.poi.xslf.extractor |
org.apache.poi.xslf.usermodel |
org.apache.poi.xssf.eventusermodel |
org.apache.poi.xssf.extractor |
org.apache.poi.xssf.usermodel |
org.apache.poi.xwpf.extractor |
org.apache.poi.xwpf.usermodel |

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.extractor
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.openxml4j.exceptions
InvalidOperationException
Throw when an invalid operation is done.
OpenXML4JException
Global exception throws when a critical error occurs.
OpenXML4JRuntimeException
Global exception throws when a critical error occurs (this exception is set as Runtime in order not to force the user to manage the exception in a try/catch).

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.openxml4j.opc
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.openxml4j.opc.internal
InvalidFormatException
InvalidOperationException
Throw when an invalid operation is done.
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.openxml4j.opc.internal.marshallers
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.openxml4j.opc.internal.signature
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.openxml4j.opc.internal.unmarshallers
InvalidFormatException

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.openxml4j.opc.signature
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.ss.usermodel
InvalidFormatException

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.util
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xslf
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xslf.extractor
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xslf.usermodel
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xssf.eventusermodel
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xssf.extractor
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xssf.usermodel
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xwpf.extractor
OpenXML4JException
Global exception throws when a critical error occurs.

Classes in org.apache.poi.openxml4j.exceptions used by org.apache.poi.xwpf.usermodel
InvalidFormatException
OpenXML4JException
Global exception throws when a critical error occurs.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PartAlreadyExistsException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.exceptions
Class PartAlreadyExistsException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException
                    extended by  org.apache.poi.openxml4j.exceptions.InvalidOperationException
                        extended by  org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException
All Implemented Interfaces:
java.io.Serializable
public final class PartAlreadyExistsException
extends InvalidOperationException

Throw when trying to create a PackagePart but one already exists with that name.

See Also:
Serialized Form

Constructor Summary
PartAlreadyExistsException(java.lang.String message)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PartAlreadyExistsException

public PartAlreadyExistsException(java.lang.String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.openxml4j.exceptions.InvalidFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.exceptions.InvalidFormatException

Packages that use InvalidFormatException
org.apache.poi
org.apache.poi.extractor
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.signature
org.apache.poi.openxml4j.opc.internal.unmarshallers
org.apache.poi.openxml4j.opc.signature
org.apache.poi.ss.usermodel
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.usermodel
org.apache.poi.xwpf.usermodel

Uses of InvalidFormatException in org.apache.poi

Methods in org.apache.poi that throw InvalidFormatException
protected PackagePart[] | POIXMLDocument.getRelatedByType(java.lang.String contentType) Retrieves all the PackageParts which are defined as relationships of the base document with the specified content type.
protected PackagePart | POIXMLDocumentPart.getTargetPart(PackageRelationship rel) Get the PackagePart that is the target of a relationship from this Part.
protected void | POIXMLDocumentPart.rebase(OPCPackage pkg) When you open something like a theme, call this to re-base the XML Document onto the core child of the current core document

Uses of InvalidFormatException in org.apache.poi.extractor

Methods in org.apache.poi.extractor that throw InvalidFormatException
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir)
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use ExtractorFactory.createExtractor(DirectoryNode) instead
static POITextExtractor ExtractorFactory.createExtractor(java.io.File f)
static POITextExtractor ExtractorFactory.createExtractor(java.io.InputStream inp)
static POIOLE2TextExtractor ExtractorFactory.createExtractor(POIFSFileSystem fs)
static POITextExtractor[] ExtractorFactory.getEmbededDocsTextExtractors(POIOLE2TextExtractor ext)
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).

Uses of InvalidFormatException in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that throw InvalidFormatException
static PackagePartName PackagingURIHelper.createPartName(java.lang.String partName)
Create an OPC compliant part name.
static PackagePartName PackagingURIHelper.createPartName(java.lang.String partName, PackagePart relativePart)
Create an OPC compliant part name by resolving it using a base part.
static PackagePartName PackagingURIHelper.createPartName(java.net.URI partUri)
Create an OPC compliant part name by throwing an exception if the URI is not valid.
static PackagePartName PackagingURIHelper.createPartName(java.net.URI partName, PackagePart relativePart)
Create an OPC compliant part name by resolving it using a base part.
 PackageProperties OPCPackage.getPackageProperties()
Retrieves or creates if none exists, core package property part.
 java.util.ArrayList<PackagePart> OPCPackage.getParts()
Load the parts of the archive if it has not been done yet.
protected  PackagePart[] ZipPackage.getPartsImpl()
Retrieves the parts from this package.
protected abstract  PackagePart[] OPCPackage.getPartsImpl()
Get all parts link to the package.
 PackagePart PackagePart.getRelatedPart(PackageRelationship rel)
Get the PackagePart that is the target of a relationship.
 PackageRelationshipCollection RelationshipSource.getRelationships()
Retrieve all the relationships attached to this.
 PackageRelationshipCollection PackagePart.getRelationships()
Retrieve all the relationships attached to this part.
 PackageRelationshipCollection RelationshipSource.getRelationshipsByType(java.lang.String relationshipType)
Retrieve all relationships attached to this part which have the specified type.
 PackageRelationshipCollection PackagePart.getRelationshipsByType(java.lang.String relationshipType)
Retrieve all relationships attached to this part which have the specified type.
abstract  boolean PackagePart.load(java.io.InputStream ios)
Load the content of this part.
static Package Package.open(java.io.InputStream in)
Deprecated. use OPCPackage.open(InputStream)
static OPCPackage OPCPackage.open(java.io.InputStream in)
Open a package.
static Package Package.open(java.lang.String path)
Deprecated. use OPCPackage.open(String)
static OPCPackage OPCPackage.open(java.lang.String path)
Open a package with read/write permission.
static Package Package.open(java.lang.String path, PackageAccess access)
Deprecated. use OPCPackage.open(String,PackageAccess)
static OPCPackage OPCPackage.open(java.lang.String path, PackageAccess access)
Open a package.
static Package Package.openOrCreate(java.io.File file)
Deprecated. use OPCPackage.openOrCreate(java.io.File)
static OPCPackage OPCPackage.openOrCreate(java.io.File file)
Opens a package if it exists, else it creates one.
 void OPCPackage.removePartRecursive(PackagePartName partName)
Remove a part from this package as well as its relationship part, if one exists, and all parts listed in the relationship part.
 void PackagePart.setContentType(java.lang.String contentType)
Set the content type.
 boolean OPCPackage.validatePackage(OPCPackage pkg)
Validates the package compliance with the OPC specifications.

Constructors in org.apache.poi.openxml4j.opc that throw InvalidFormatException
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType)
Constructor.
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType, boolean loadRelationships)
Constructor.
PackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType)
Constructor.
PackageRelationshipCollection(OPCPackage container)
Constructor.
PackageRelationshipCollection(OPCPackage container, PackagePart part)
Constructor.
PackageRelationshipCollection(PackagePart part)
Constructor.
ZipPackagePart(OPCPackage container, PackagePartName partName, java.lang.String contentType)
Constructor.
ZipPackagePart(OPCPackage container, java.util.zip.ZipEntry zipEntry, PackagePartName partName, java.lang.String contentType)
Constructor.

Uses of InvalidFormatException in org.apache.poi.openxml4j.opc.internal

Methods in org.apache.poi.openxml4j.opc.internal that throw InvalidFormatException
boolean | MemoryPackagePart.load(java.io.InputStream ios)
PackagePart | PartUnmarshaller.unmarshall(UnmarshallContext context, java.io.InputStream in) Save the content of the package in the stream

Constructors in org.apache.poi.openxml4j.opc.internal that throw InvalidFormatException
ContentType(java.lang.String contentType)
Constructor.
ContentTypeManager(java.io.InputStream in, OPCPackage pkg)
Constructor.
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType)
Constructor.
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Constructor.
PackagePropertiesPart(OPCPackage pack, PackagePartName partName)
Constructor.
ZipContentTypeManager(java.io.InputStream in, OPCPackage pkg)
Delegate constructor to the super constructor.

Uses of InvalidFormatException in org.apache.poi.openxml4j.opc.internal.signature

Methods in org.apache.poi.openxml4j.opc.internal.signature that throw InvalidFormatException
 boolean DigitalCertificatePart.load(java.io.InputStream ios)

Constructors in org.apache.poi.openxml4j.opc.internal.signature that throw InvalidFormatException
DigitalCertificatePart()

Uses of InvalidFormatException in org.apache.poi.openxml4j.opc.internal.unmarshallers

Methods in org.apache.poi.openxml4j.opc.internal.unmarshallers that throw InvalidFormatException
void | PackagePropertiesUnmarshaller.checkElementForOPCCompliance(org.dom4j.Element el) Check the element for the following OPC compliance rules:
PackagePart | PackagePropertiesUnmarshaller.unmarshall(UnmarshallContext context, java.io.InputStream in)

Uses of InvalidFormatException in org.apache.poi.openxml4j.opc.signature

Methods in org.apache.poi.openxml4j.opc.signature that throw InvalidFormatException
 boolean PackageDigitalSignature.load(java.io.InputStream ios)

Constructors in org.apache.poi.openxml4j.opc.signature that throw InvalidFormatException
PackageDigitalSignature()

Uses of InvalidFormatException in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that throw InvalidFormatException
static Workbook | WorkbookFactory.create(java.io.File file) Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given File, which must exist and be readable.
static Workbook | WorkbookFactory.create(java.io.InputStream inp) Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given InputStream.

Uses of InvalidFormatException in org.apache.poi.xssf.eventusermodel

Methods in org.apache.poi.xssf.eventusermodel that throw InvalidFormatException
java.io.InputStream | XSSFReader.getSharedStringsData() Returns an InputStream to read the contents of the shared strings table.
SharedStringsTable | XSSFReader.getSharedStringsTable() Opens up the Shared Strings Table, parses it, and returns a handy object for working with shared strings.
java.io.InputStream | XSSFReader.getSheet(java.lang.String relId) Returns an InputStream to read the contents of the specified Sheet.
java.util.Iterator<java.io.InputStream> | XSSFReader.getSheetsData() Returns an Iterator which will let you get at all the different Sheets in turn.
java.io.InputStream | XSSFReader.getStylesData() Returns an InputStream to read the contents of the styles table.
StylesTable | XSSFReader.getStylesTable() Opens up the Styles Table, parses it, and returns a handy object for working with cell styles
java.io.InputStream | XSSFReader.getThemesData() Returns an InputStream to read the contents of the themes table.
java.io.InputStream | XSSFReader.getWorkbookData() Returns an InputStream to read the contents of the main Workbook, which contains key overall data for the file, including sheet definitions.

Uses of InvalidFormatException in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that throw InvalidFormatException
 java.io.InputStream XSSFRelation.getContents(PackagePart corePart)
Fetches the InputStream to read the contents, based of the specified core part, for which we are defined as a suitable relationship

Uses of InvalidFormatException in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that throw InvalidFormatException
XWPFPicture | XWPFRun.addPicture(java.io.InputStream pictureData, int pictureType, java.lang.String filename, int width, int height) Adds a picture to the run.
java.lang.String | XWPFHeaderFooter.addPictureData(byte[] pictureData, int format) Adds a picture to the document.
java.lang.String | XWPFDocument.addPictureData(byte[] pictureData, int format)
java.lang.String | XWPFHeaderFooter.addPictureData(java.io.InputStream is, int format) Adds a picture to the document.
java.lang.String | XWPFDocument.addPictureData(java.io.InputStream is, int format)
int | XWPFDocument.getNextPicNameNumber(int format) get the next free ImageNumber

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.exceptions.InvalidOperationException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.exceptions.InvalidOperationException

Packages that use InvalidOperationException
org.apache.poi.openxml4j.exceptions
org.apache.poi.openxml4j.opc.internal

Uses of InvalidOperationException in org.apache.poi.openxml4j.exceptions

Subclasses of InvalidOperationException in org.apache.poi.openxml4j.exceptions
 class PartAlreadyExistsException
Throw when trying to create a PackagePart but one already exists with that name.

Uses of InvalidOperationException in org.apache.poi.openxml4j.opc.internal

Methods in org.apache.poi.openxml4j.opc.internal that throw InvalidOperationException
 void ContentTypeManager.removeContentType(PackagePartName partName)
Delete a content type based on the specified part name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.exceptions.OpenXML4JException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.exceptions.OpenXML4JException

Packages that use OpenXML4JException
org.apache.poi |
org.apache.poi.extractor |
org.apache.poi.openxml4j.exceptions |
org.apache.poi.openxml4j.opc |
org.apache.poi.openxml4j.opc.internal |
org.apache.poi.openxml4j.opc.internal.marshallers |
org.apache.poi.openxml4j.opc.internal.signature |
org.apache.poi.openxml4j.opc.signature |
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.
org.apache.poi.xslf |
org.apache.poi.xslf.extractor |
org.apache.poi.xslf.usermodel |
org.apache.poi.xssf.eventusermodel |
org.apache.poi.xssf.extractor |
org.apache.poi.xssf.usermodel |
org.apache.poi.xwpf.extractor |
org.apache.poi.xwpf.usermodel |

Uses of OpenXML4JException in org.apache.poi

Methods in org.apache.poi that throw OpenXML4JException
abstract java.util.List<PackagePart> | POIXMLDocument.getAllEmbedds() Get the document's embedded files.
protected void | POIXMLDocumentPart.read(POIXMLFactory factory, java.util.Map<PackagePart,POIXMLDocumentPart> context) Iterate through the underlying PackagePart and create child POIXMLFactory instances using the specified factory

Constructors in org.apache.poi that throw OpenXML4JException
POIXMLProperties(OPCPackage docPackage)

Uses of OpenXML4JException in org.apache.poi.extractor

Methods in org.apache.poi.extractor that throw OpenXML4JException
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir)
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use ExtractorFactory.createExtractor(DirectoryNode) instead
static POITextExtractor ExtractorFactory.createExtractor(java.io.File f)
static POITextExtractor ExtractorFactory.createExtractor(java.io.InputStream inp)
static POIXMLTextExtractor ExtractorFactory.createExtractor(OPCPackage pkg)
static POIOLE2TextExtractor ExtractorFactory.createExtractor(POIFSFileSystem fs)
static POITextExtractor[] ExtractorFactory.getEmbededDocsTextExtractors(POIOLE2TextExtractor ext)
Returns an array of text extractors, one for each of the embeded documents in the file (if there are any).

Uses of OpenXML4JException in org.apache.poi.openxml4j.exceptions

Subclasses of OpenXML4JException in org.apache.poi.openxml4j.exceptions
 class InvalidFormatException

Uses of OpenXML4JException in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that throw OpenXML4JException
PackageRelationshipCollection | RelationshipSource.getRelationships() Retrieve all the relationships attached to this.
PackageRelationshipCollection | RelationshipSource.getRelationshipsByType(java.lang.String relationshipType) Retrieve all relationships attached to this part which have the specified type.
boolean | ZipPackagePart.save(java.io.OutputStream os)
abstract boolean | PackagePart.save(java.io.OutputStream zos) Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.

Uses of OpenXML4JException in org.apache.poi.openxml4j.opc.internal

Methods in org.apache.poi.openxml4j.opc.internal that throw OpenXML4JException
boolean | PartMarshaller.marshall(PackagePart part, java.io.OutputStream out) Save the content of the package in the stream
boolean | MemoryPackagePart.save(java.io.OutputStream os)

Uses of OpenXML4JException in org.apache.poi.openxml4j.opc.internal.marshallers

Methods in org.apache.poi.openxml4j.opc.internal.marshallers that throw OpenXML4JException
 boolean ZipPartMarshaller.marshall(PackagePart part, java.io.OutputStream os)
Save the specified part.
 boolean ZipPackagePropertiesMarshaller.marshall(PackagePart part, java.io.OutputStream out)
 boolean PackagePropertiesMarshaller.marshall(PackagePart part, java.io.OutputStream out)
Marshall package core properties to an XML document.
 boolean DefaultMarshaller.marshall(PackagePart part, java.io.OutputStream out)
Save part in the output stream by using the save() method of the part.

Uses of OpenXML4JException in org.apache.poi.openxml4j.opc.internal.signature

Methods in org.apache.poi.openxml4j.opc.internal.signature that throw OpenXML4JException
 boolean DigitalCertificatePart.save(java.io.OutputStream zos)

Uses of OpenXML4JException in org.apache.poi.openxml4j.opc.signature

Methods in org.apache.poi.openxml4j.opc.signature that throw OpenXML4JException
 boolean PackageDigitalSignature.save(java.io.OutputStream zos)

Uses of OpenXML4JException in org.apache.poi.util

Methods in org.apache.poi.util that throw OpenXML4JException
static OPCPackage PackageHelper.clone(OPCPackage pkg, java.io.File file)
Clone the specified package.

Uses of OpenXML4JException in org.apache.poi.xslf

Methods in org.apache.poi.xslf that throw OpenXML4JException
 java.util.List<PackagePart> XSLFSlideShow.getAllEmbedds()
Get the document's embedded files.

Constructors in org.apache.poi.xslf that throw OpenXML4JException
XSLFSlideShow(OPCPackage container)
XSLFSlideShow(java.lang.String file)

Uses of OpenXML4JException in org.apache.poi.xslf.extractor

Constructors in org.apache.poi.xslf.extractor that throw OpenXML4JException
XSLFPowerPointExtractor(OPCPackage container)

Uses of OpenXML4JException in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that throw OpenXML4JException
XSLFSlideShow | XMLSlideShow._getXSLFSlideShow() Deprecated.
java.util.List<PackagePart> | XMLSlideShow.getAllEmbedds() Get the document's embedded files.

Uses of OpenXML4JException in org.apache.poi.xssf.eventusermodel

Constructors in org.apache.poi.xssf.eventusermodel that throw OpenXML4JException
XSSFReader(OPCPackage pkg)
Creates a new XSSFReader, for the given package

Uses of OpenXML4JException in org.apache.poi.xssf.extractor

Constructors in org.apache.poi.xssf.extractor that throw OpenXML4JException
XSSFEventBasedExcelExtractor(OPCPackage container)
XSSFEventBasedExcelExtractor(java.lang.String path)
XSSFExcelExtractor(OPCPackage container)
XSSFExcelExtractor(java.lang.String path)
Deprecated. Use XSSFExcelExtractor.XSSFExcelExtractor(org.apache.poi.openxml4j.opc.OPCPackage) instead.

Uses of OpenXML4JException in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that throw OpenXML4JException
 java.util.List<PackagePart> XSSFWorkbook.getAllEmbedds()
Get the document's embedded files.

Uses of OpenXML4JException in org.apache.poi.xwpf.extractor

Constructors in org.apache.poi.xwpf.extractor that throw OpenXML4JException
XWPFWordExtractor(OPCPackage container)

Uses of OpenXML4JException in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that throw OpenXML4JException
 java.util.List<PackagePart> XWPFDocument.getAllEmbedds()
Get the document's embedded files.

Constructors in org.apache.poi.xwpf.usermodel that throw OpenXML4JException
XWPFFootnotes(PackagePart part, PackageRelationship rel)
Construct XWPFFootnotes from a package part
XWPFNumbering(PackagePart part, PackageRelationship rel)
create a new styles object with an existing document
XWPFStyles(PackagePart part, PackageRelationship rel)
Construct XWPFStyles from a package part

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.exceptions.OpenXML4JRuntimeException

Packages that use OpenXML4JRuntimeException
org.apache.poi.openxml4j.exceptions

Uses of OpenXML4JRuntimeException in org.apache.poi.openxml4j.exceptions

Subclasses of OpenXML4JRuntimeException in org.apache.poi.openxml4j.exceptions
class | InvalidOperationException Throw when an invalid operation is done.
class | PartAlreadyExistsException Throw when trying to create a PackagePart but one already exists with that name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException

No usage of org.apache.poi.openxml4j.exceptions.PartAlreadyExistsException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CertificateEmbeddingOption

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.openxml4j.opc
Enum CertificateEmbeddingOption

java.lang.Object
    extended by  java.lang.Enum<CertificateEmbeddingOption>
        extended by  org.apache.poi.openxml4j.opc.CertificateEmbeddingOption
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<CertificateEmbeddingOption>
public enum CertificateEmbeddingOption
extends java.lang.Enum<CertificateEmbeddingOption>

Specifies the location where the X.509 certificate that is used in signing is stored.

Author:
Julien Chable

Enum Constant Summary
IN_CERTIFICATE_PART
The certificate is embedded in its own PackagePart.
IN_SIGNATURE_PART
The certificate is embedded in the SignaturePart that is created for the signature being added.
NOT_EMBEDDED
The certificate in not embedded in the package.
Method Summary
static CertificateEmbeddingOption | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CertificateEmbeddingOption[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

IN_CERTIFICATE_PART

public static final CertificateEmbeddingOption IN_CERTIFICATE_PART
The certificate is embedded in its own PackagePart.

IN_SIGNATURE_PART

public static final CertificateEmbeddingOption IN_SIGNATURE_PART
The certificate is embedded in the SignaturePart that is created for the signature being added.

NOT_EMBEDDED

public static final CertificateEmbeddingOption NOT_EMBEDDED
The certificate in not embedded in the package.

Method Detail

values

public static CertificateEmbeddingOption[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (CertificateEmbeddingOption c : CertificateEmbeddingOption.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static CertificateEmbeddingOption valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD


CompressionOption

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.openxml4j.opc
Enum CompressionOption

java.lang.Object
    extended by  java.lang.Enum<CompressionOption>
        extended by  org.apache.poi.openxml4j.opc.CompressionOption
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<CompressionOption>
public enum CompressionOption
extends java.lang.Enum<CompressionOption>

Specifies the compression level for content that is stored in a PackagePart.

Version:
1.0
Author:
Julien Chable

Enum Constant Summary
FAST
Compression is optimized for performance.
MAXIMUM
Compression is optimized for size.
NORMAL
Compression is optimized for a balance between size and performance.
NOT_COMPRESSED
Compression is turned off.
Method Summary
int | value()
static CompressionOption | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CompressionOption[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

FAST

public static final CompressionOption FAST
Compression is optimized for performance.

MAXIMUM

public static final CompressionOption MAXIMUM
Compression is optimized for size.

NORMAL

public static final CompressionOption NORMAL
Compression is optimized for a balance between size and performance.

NOT_COMPRESSED

public static final CompressionOption NOT_COMPRESSED
Compression is turned off.

Method Detail

values

public static CompressionOption[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (CompressionOption c : CompressionOption.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static CompressionOption valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

value

public int value()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Configuration

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class Configuration

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.Configuration

public final class Configuration
extends java.lang.Object

Storage class for configuration storage parameters. TODO xml syntax checking is no longer done with DOM4j parser -> remove the schema or do it ?

Version:
1.0
Author:
CDubettier, Julen Chable

Constructor Summary
Configuration()
Method Summary
static java.lang.String | getPathForXmlSchema()
static void | setPathForXmlSchema(java.lang.String pathForXmlSchema)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Configuration

public Configuration()
Method Detail

getPathForXmlSchema

public static java.lang.String getPathForXmlSchema()

setPathForXmlSchema

public static void setPathForXmlSchema(java.lang.String pathForXmlSchema)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContentTypes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class ContentTypes

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.ContentTypes

public final class ContentTypes
extends java.lang.Object

Open Packaging Convention content types (see Annex F : Standard Namespaces and Content Types).

Author:
CDubettier define some constants, Julien Chable

Field Summary
static java.lang.String | CORE_PROPERTIES_PART Core Properties part.
static java.lang.String | CUSTOM_XML_PART Custom XML part.
static java.lang.String | DIGITAL_SIGNATURE_CERTIFICATE_PART Digital Signature Certificate part.
static java.lang.String | DIGITAL_SIGNATURE_ORIGIN_PART Digital Signature Origin part.
static java.lang.String | DIGITAL_SIGNATURE_XML_SIGNATURE_PART Digital Signature XML Signature part.
static java.lang.String | EXTENSION_GIF
static java.lang.String | EXTENSION_JPG_1
static java.lang.String | EXTENSION_JPG_2
static java.lang.String | EXTENSION_PICT
static java.lang.String | EXTENSION_PNG
static java.lang.String | EXTENSION_TIFF
static java.lang.String | EXTENSION_XML
static java.lang.String | IMAGE_GIF
static java.lang.String | IMAGE_JPEG
static java.lang.String | IMAGE_PICT Pict image format.
static java.lang.String | IMAGE_PNG
static java.lang.String | IMAGE_TIFF TIFF image format.
static java.lang.String | PLAIN_OLD_XML Plain old xml.
static java.lang.String | RELATIONSHIPS_PART Relationships part.
static java.lang.String | XML XML file.
Constructor Summary
ContentTypes()
Method Summary
static java.lang.String getContentTypeFromFileExtension(java.lang.String filename)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CORE_PROPERTIES_PART

public static final java.lang.String CORE_PROPERTIES_PART
Core Properties part.

See Also:
Constant Field Values

DIGITAL_SIGNATURE_CERTIFICATE_PART

public static final java.lang.String DIGITAL_SIGNATURE_CERTIFICATE_PART
Digital Signature Certificate part.

See Also:
Constant Field Values

DIGITAL_SIGNATURE_ORIGIN_PART

public static final java.lang.String DIGITAL_SIGNATURE_ORIGIN_PART
Digital Signature Origin part.

See Also:
Constant Field Values

DIGITAL_SIGNATURE_XML_SIGNATURE_PART

public static final java.lang.String DIGITAL_SIGNATURE_XML_SIGNATURE_PART
Digital Signature XML Signature part.

See Also:
Constant Field Values

RELATIONSHIPS_PART

public static final java.lang.String RELATIONSHIPS_PART
Relationships part.

See Also:
Constant Field Values

CUSTOM_XML_PART

public static final java.lang.String CUSTOM_XML_PART
Custom XML part.

See Also:
Constant Field Values

PLAIN_OLD_XML

public static final java.lang.String PLAIN_OLD_XML
Plain old xml. Note - OOXML uses application/xml, and not text/xml!

See Also:
Constant Field Values

IMAGE_JPEG

public static final java.lang.String IMAGE_JPEG
See Also:
Constant Field Values

EXTENSION_JPG_1

public static final java.lang.String EXTENSION_JPG_1
See Also:
Constant Field Values

EXTENSION_JPG_2

public static final java.lang.String EXTENSION_JPG_2
See Also:
Constant Field Values

IMAGE_PNG

public static final java.lang.String IMAGE_PNG
See Also:
Constant Field Values

EXTENSION_PNG

public static final java.lang.String EXTENSION_PNG
See Also:
Constant Field Values

IMAGE_GIF

public static final java.lang.String IMAGE_GIF
See Also:
Constant Field Values

EXTENSION_GIF

public static final java.lang.String EXTENSION_GIF
See Also:
Constant Field Values

IMAGE_TIFF

public static final java.lang.String IMAGE_TIFF
TIFF image format.

See Also:
http://partners.adobe.com/public/developer/tiff/index.html#spec, Constant Field Values

EXTENSION_TIFF

public static final java.lang.String EXTENSION_TIFF
See Also:
Constant Field Values

IMAGE_PICT

public static final java.lang.String IMAGE_PICT
Pict image format.

See Also:
http://developer.apple.com/documentation/mac/QuickDraw/QuickDraw-2.html, Constant Field Values

EXTENSION_PICT

public static final java.lang.String EXTENSION_PICT
See Also:
Constant Field Values

XML

public static final java.lang.String XML
XML file.

See Also:
Constant Field Values

EXTENSION_XML

public static final java.lang.String EXTENSION_XML
See Also:
Constant Field Values
Constructor Detail

ContentTypes

public ContentTypes()
Method Detail

getContentTypeFromFileExtension

public static java.lang.String getContentTypeFromFileExtension(java.lang.String filename)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EncryptionOption

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.openxml4j.opc
Enum EncryptionOption

java.lang.Object
    extended by  java.lang.Enum<EncryptionOption>
        extended by  org.apache.poi.openxml4j.opc.EncryptionOption
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<EncryptionOption>
public enum EncryptionOption
extends java.lang.Enum<EncryptionOption>

Specifies the encryption option for parts in a Package.

Version:
0.1
Author:
Julien Chable

Enum Constant Summary
NONE
No encryption.
Method Summary
static EncryptionOption | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static EncryptionOption[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final EncryptionOption NONE
No encryption.

Method Detail

values

public static EncryptionOption[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (EncryptionOption c : EncryptionOption.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static EncryptionOption valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


OPCPackage

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class OPCPackage

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.OPCPackage
All Implemented Interfaces:
java.io.Closeable, RelationshipSource
Direct Known Subclasses:
Package
public abstract class OPCPackage
extends java.lang.Object
implements RelationshipSource, java.io.Closeable

Represents a container that can store multiple data objects.

Version:
0.1
Author:
Julien Chable, CDubet

Field Summary
protected ContentTypeManager | contentTypeManager Manage parts content types of this package.
protected static PackageAccess | defaultPackageAccess Default package access.
protected PartMarshaller | defaultPartMarshaller Default part marshaller.
protected boolean | isDirty Flag if a modification is done to the document.
protected java.lang.String | originalPackagePath File path of this package.
protected java.io.OutputStream | output Output stream for writing this package.
protected PackagePropertiesPart | packageProperties Core package properties.
protected PackagePartCollection | partList Package parts collection.
protected java.util.Hashtable<ContentType,PartMarshaller> | partMarshallers Part marshallers by content type.
protected java.util.Hashtable<ContentType,PartUnmarshaller> | partUnmarshallers Part unmarshallers by content type.
protected PackageRelationshipCollection | relationships Package relationships.
Method Summary
PackageRelationship | addExternalRelationship(java.lang.String target, java.lang.String relationshipType) Adds an external relationship to a part (except relationships part).
PackageRelationship | addExternalRelationship(java.lang.String target, java.lang.String relationshipType, java.lang.String id) Adds an external relationship to a part (except relationships part).
void | addMarshaller(java.lang.String contentType, PartMarshaller marshaller) Add a marshaller.
protected PackagePart | addPackagePart(PackagePart part) Add the specified part to the package.
PackageRelationship | addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a package relationship.
PackageRelationship | addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String relID) Add a relationship to the package (except relationships part).
void | addThumbnail(java.lang.String path) Add a thumbnail to the package.
void | addUnmarshaller(java.lang.String contentType, PartUnmarshaller unmarshaller) Add an unmarshaller.
void | clearRelationships() Clear package relationships.
void | close() Close the open, writable package and save its content.
protected abstract void | closeImpl() Close the package and cause a save of the package.
boolean | containPart(PackagePartName partName) Check if a part already exists in this package from its name.
static OPCPackage | create(java.io.File file) Creates a new package.
static OPCPackage | create(java.io.OutputStream output)
static OPCPackage | create(java.lang.String path) Creates a new package.
PackagePart | createPart(PackagePartName partName, java.lang.String contentType) Create and add a part, with the specified name and content type, to the package.
PackagePart | createPart(PackagePartName partName, java.lang.String contentType, java.io.ByteArrayOutputStream content) Add a part to the package.
protected abstract PackagePart | createPartImpl(PackagePartName partName, java.lang.String contentType, boolean loadRelationships) Core method to create a package part.
void | deletePart(PackagePartName partName) Delete the part with the specified name and its associated relationships part if one exists.
void | deletePartRecursive(PackagePartName partName) Delete the part with the specified name and all part listed in its associated relationships part if one exists.
void | ensureRelationships() Ensure that the relationships collection is not null.
void | flush() Flush the package : save all.
protected abstract void | flushImpl() Flush the package but not save.
PackageAccess | getPackageAccess() Get the package access mode.
PackageProperties | getPackageProperties() Retrieves or creates if none exists, core package property part.
PackagePart | getPart(PackagePartName partName) Retrieve a part identified by its name.
PackagePart | getPart(PackageRelationship partRel) Get the target part from the specified relationship.
protected abstract PackagePart | getPartImpl(PackagePartName partName) Get the package part mapped to the specified URI.
java.util.ArrayList<PackagePart> | getParts() Load the parts of the archive if it has not been done yet.
java.util.ArrayList<PackagePart> | getPartsByContentType(java.lang.String contentType) Retrieve parts by content type.
java.util.List<PackagePart> | getPartsByName(java.util.regex.Pattern namePattern)
java.util.ArrayList<PackagePart> | getPartsByRelationshipType(java.lang.String relationshipType) Retrieve parts by relationship type.
protected abstract PackagePart[] | getPartsImpl() Get all parts link to the package.
PackageRelationship | getRelationship(java.lang.String id) Retrieves a package relationship from its id.
PackageRelationshipCollection | getRelationships() Retrieves all package relationships.
PackageRelationshipCollection | getRelationshipsByType(java.lang.String relationshipType) Retrieves all relationships with the specified type.
boolean | hasRelationships() Knows if the part have any relationships.
boolean | isRelationshipExists(PackageRelationship rel) Checks if the specified relationship is part of this package part.
static OPCPackage | open(java.io.InputStream in) Open a package.
static OPCPackage | open(java.lang.String path) Open a package with read/write permission.
static OPCPackage | open(java.lang.String path, PackageAccess access) Open a package.
static OPCPackage | openOrCreate(java.io.File file) Opens a package if it exists, else it creates one.
void | removeMarshaller(java.lang.String contentType) Remove a marshaller by its content type.
void | removePart(PackagePart part) Remove the specified part in this package.
void | removePart(PackagePartName partName) Remove a part in this package.
protected abstract void | removePartImpl(PackagePartName partName) Core method to delete a package part.
void | removePartRecursive(PackagePartName partName) Remove a part from this package as well as its relationship part, if one exists, and all parts listed in the relationship part.
void | removeRelationship(java.lang.String id) Delete a relationship from this package.
void | removeUnmarshaller(java.lang.String contentType) Remove an unmarshaller by its content type.
boolean | replaceContentType(java.lang.String oldContentType, java.lang.String newContentType) Replace a content type in this package.
void | revert() Close the package WITHOUT saving its content.
protected abstract void | revertImpl() Close the package without saving the document.
void | save(java.io.File targetFile) Save the document in the specified file.
void | save(java.io.OutputStream outputStream) Save the document in the specified output stream.
protected abstract void | saveImpl(java.io.OutputStream outputStream) Save the package into the specified output stream.
boolean | validatePackage(OPCPackage pkg) Validates the package compliance with the OPC specifications.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

defaultPackageAccess

protected static final PackageAccess defaultPackageAccess
Default package access.

partList

protected PackagePartCollection partList
Package parts collection.

relationships

protected PackageRelationshipCollection relationships
Package relationships.

partMarshallers

protected java.util.Hashtable<ContentType,PartMarshaller> partMarshallers
Part marshallers by content type.

defaultPartMarshaller

protected PartMarshaller defaultPartMarshaller
Default part marshaller.

partUnmarshallers

protected java.util.Hashtable<ContentType,PartUnmarshaller> partUnmarshallers
Part unmarshallers by content type.

packageProperties

protected PackagePropertiesPart packageProperties
Core package properties.

contentTypeManager

protected ContentTypeManager contentTypeManager
Manage parts content types of this package.

isDirty

protected boolean isDirty
Flag if a modification is done to the document.

originalPackagePath

protected java.lang.String originalPackagePath
File path of this package.

output

protected java.io.OutputStream output
Output stream for writing this package.

Method Detail

open

public static OPCPackage open(java.lang.String path)
                       throws InvalidFormatException
Open a package with read/write permission.

Parameters:
path - The document path.
Returns:
A Package object, else null.
Throws:
InvalidFormatException - If the specified file doesn't exist, and a parsing error occur.

open

public static OPCPackage open(java.lang.String path,
                              PackageAccess access)
                       throws InvalidFormatException
Open a package.

Parameters:
path - The document path.
access - PackageBase access.
Returns:
A PackageBase object, else null.
Throws:
InvalidFormatException - If the specified file doesn't exist, and a parsing error occur.

open

public static OPCPackage open(java.io.InputStream in)
                       throws InvalidFormatException,
                              java.io.IOException
Open a package. Note - uses quite a bit more memory than open(String), which doesn't need to hold the whole zip file in memory, and can take advantage of native methods

Parameters:
in - The InputStream to read the package from
Returns:
A PackageBase object
Throws:
InvalidFormatException
java.io.IOException

openOrCreate

public static OPCPackage openOrCreate(java.io.File file)
                               throws InvalidFormatException
Opens a package if it exists, else it creates one.

Parameters:
file - The file to open or to create.
Returns:
A newly created package if the specified file does not exist, else the package extract from the file.
Throws:
InvalidFormatException - Throws if the specified file exist and is not valid.

create

public static OPCPackage create(java.lang.String path)
Creates a new package.

Parameters:
path - Path of the document.
Returns:
A newly created PackageBase ready to use.

create

public static OPCPackage create(java.io.File file)
Creates a new package.

Parameters:
file - Path of the document.
Returns:
A newly created PackageBase ready to use.

create

public static OPCPackage create(java.io.OutputStream output)

flush

public void flush()
Flush the package : save all.

See Also:
close()

close

public void close()
           throws java.io.IOException
Close the open, writable package and save its content. If your package is open read only, then you should call revert() when finished with the package.

Specified by:
close in interface java.io.Closeable
Throws:
java.io.IOException - If an IO exception occur during the saving process.

revert

public void revert()
Close the package WITHOUT saving its content. Reinitialize this package and cancel all changes done to it.

addThumbnail

public void addThumbnail(java.lang.String path)
                  throws java.io.IOException
Add a thumbnail to the package. This method is provided to make easier the addition of a thumbnail in a package. You can do the same work by using the traditionnal relationship and part mechanism.

Parameters:
path - The full path to the image file.
Throws:
java.io.IOException

getPackageProperties

public PackageProperties getPackageProperties()
                                       throws InvalidFormatException
Retrieves or creates if none exists, core package property part.

Returns:
The PackageProperties part of this package.
Throws:
InvalidFormatException

getPart

public PackagePart getPart(PackagePartName partName)
Retrieve a part identified by its name.

Parameters:
partName - Part name of the part to retrieve.
Returns:
The part with the specified name, else null.

getPartsByContentType

public java.util.ArrayList<PackagePart> getPartsByContentType(java.lang.String contentType)
Retrieve parts by content type.

Parameters:
contentType - The content type criteria.
Returns:
All part associated to the specified content type.

getPartsByRelationshipType

public java.util.ArrayList<PackagePart> getPartsByRelationshipType(java.lang.String relationshipType)
Retrieve parts by relationship type.

Parameters:
relationshipType - Relationship type.
Returns:
All parts which are the target of a relationship with the specified type, if the method can't retrieve relationships from the package, then return null.

getPartsByName

public java.util.List<PackagePart> getPartsByName(java.util.regex.Pattern namePattern)

getPart

public PackagePart getPart(PackageRelationship partRel)
Get the target part from the specified relationship.

Parameters:
partRel - The part relationship uses to retrieve the part.

getParts

public java.util.ArrayList<PackagePart> getParts()
                                          throws InvalidFormatException
Load the parts of the archive if it has not been done yet. The relationships of each part are not loaded. Note - Rule M4.1 states that there may only ever be one Core Properties Part, but Office produced files will sometimes have multiple! As Office ignores all but the first, we relax Compliance with Rule M4.1, and ignore all others silently too.

Returns:
All this package's parts.
Throws:
InvalidFormatException

createPart

public PackagePart createPart(PackagePartName partName,
                              java.lang.String contentType)
Create and add a part, with the specified name and content type, to the package.

Parameters:
partName - Part name.
contentType - Part content type.
Returns:
The newly created part.
Throws:
InvalidFormatException - If rule M1.12 is not verified : Packages shall not contain equivalent part names and package implementers shall neither create nor recognize packages with equivalent part names.
See Also:
createPartImpl(PackagePartName, String, boolean)

createPart

public PackagePart createPart(PackagePartName partName,
                              java.lang.String contentType,
                              java.io.ByteArrayOutputStream content)
Add a part to the package.

Parameters:
partName - Part name of the part to create.
contentType - type associated with the file
content - the contents to add. In order to have faster operation in document merge, the data are stored in memory not on a hard disk
Returns:
The new part.
See Also:
createPart(PackagePartName, String)

addPackagePart

protected PackagePart addPackagePart(PackagePart part)
Add the specified part to the package. If a part already exists in the package with the same name as the one specified, then we replace the old part by the specified part.

Parameters:
part - The part to add (or replace).
Returns:
The part added to the package, the same as the one specified.
Throws:
InvalidFormatException - If rule M1.12 is not verified : Packages shall not contain equivalent part names and package implementers shall neither create nor recognize packages with equivalent part names.

removePart

public void removePart(PackagePart part)
Remove the specified part in this package. If this part is relationship part, then delete all relationships in the source part.

Parameters:
part - The part to remove. If null, skip the action.
See Also:
removePart(PackagePartName)

removePart

public void removePart(PackagePartName partName)
Remove a part in this package. If this part is relationship part, then delete all relationships in the source part.

Parameters:
partName - The part name of the part to remove.

removePartRecursive

public void removePartRecursive(PackagePartName partName)
                         throws InvalidFormatException
Remove a part from this package as well as its relationship part, if one exists, and all parts listed in the relationship part. Be aware that this do not delete relationships which target the specified part.

Parameters:
partName - The name of the part to delete.
Throws:
InvalidFormatException - Throws if the associated relationship part of the specified part is not valid.

deletePart

public void deletePart(PackagePartName partName)
Delete the part with the specified name and its associated relationships part if one exists. Prefer the use of this method to delete a part in the package, compare to the remove() methods that don't remove associated relationships part.

Parameters:
partName - Name of the part to delete

deletePartRecursive

public void deletePartRecursive(PackagePartName partName)
Delete the part with the specified name and all part listed in its associated relationships part if one exists. This process is recursively apply to all parts in the relationships part of the specified part. Prefer the use of this method to delete a part in the package, compare to the remove() methods that don't remove associated relationships part.

Parameters:
partName - Name of the part to delete

containPart

public boolean containPart(PackagePartName partName)
Check if a part already exists in this package from its name.

Parameters:
partName - Part name to check.
Returns:
true if the part is logically added to this package, else false.

addRelationship

public PackageRelationship addRelationship(PackagePartName targetPartName,
                                           TargetMode targetMode,
                                           java.lang.String relationshipType,
                                           java.lang.String relID)
Add a relationship to the package (except relationships part). Check rule M4.1 : The format designer shall specify and the format producer shall create at most one core properties relationship for a package. A format consumer shall consider more than one core properties relationship for a package to be an error. If present, the relationship shall target the Core Properties part. Check rule M1.25: The Relationships part shall not have relationships to any other part. Package implementers shall enforce this requirement upon the attempt to create such a relationship and shall treat any such relationship as invalid.

Specified by:
addRelationship in interface RelationshipSource
Parameters:
targetPartName - Target part name.
targetMode - Target mode, either Internal or External.
relationshipType - Relationship type.
relID - ID of the relationship.
Returns:
The newly created and added relationship
See Also:
PackageRelationshipTypes

addRelationship

public PackageRelationship addRelationship(PackagePartName targetPartName,
                                           TargetMode targetMode,
                                           java.lang.String relationshipType)
Add a package relationship.

Specified by:
addRelationship in interface RelationshipSource
Parameters:
targetPartName - Target part name.
targetMode - Target mode, either Internal or External.
relationshipType - Relationship type.
Returns:
The newly created and added relationship
See Also:
PackageRelationshipTypes

addExternalRelationship

public PackageRelationship addExternalRelationship(java.lang.String target,
                                                   java.lang.String relationshipType)
Adds an external relationship to a part (except relationships part). The targets of external relationships are not subject to the same validity checks that internal ones are, as the contents is potentially any file, URL or similar.

Specified by:
addExternalRelationship in interface RelationshipSource
Parameters:
target - External target of the relationship
relationshipType - Type of relationship.
Returns:
The newly created and added relationship
See Also:
RelationshipSource.addExternalRelationship(java.lang.String, java.lang.String)

addExternalRelationship

public PackageRelationship addExternalRelationship(java.lang.String target,
                                                   java.lang.String relationshipType,
                                                   java.lang.String id)
Adds an external relationship to a part (except relationships part). The targets of external relationships are not subject to the same validity checks that internal ones are, as the contents is potentially any file, URL or similar.

Specified by:
addExternalRelationship in interface RelationshipSource
Parameters:
target - External target of the relationship
relationshipType - Type of relationship.
id - Relationship unique id.
Returns:
The newly created and added relationship
See Also:
RelationshipSource.addExternalRelationship(java.lang.String, java.lang.String)

removeRelationship

public void removeRelationship(java.lang.String id)
Delete a relationship from this package.

Specified by:
removeRelationship in interface RelationshipSource
Parameters:
id - Id of the relationship to delete.

getRelationships

public PackageRelationshipCollection getRelationships()
Retrieves all package relationships.

Specified by:
getRelationships in interface RelationshipSource
Returns:
All package relationships of this package.
Throws:
OpenXML4JException
See Also:
getRelationshipsHelper(String)

getRelationshipsByType

public PackageRelationshipCollection getRelationshipsByType(java.lang.String relationshipType)
Retrieves all relationships with the specified type.

Specified by:
getRelationshipsByType in interface RelationshipSource
Parameters:
relationshipType - The filter specifying the relationship type.
Returns:
All relationships with the specified relationship type.

clearRelationships

public void clearRelationships()
Clear package relationships.

Specified by:
clearRelationships in interface RelationshipSource

ensureRelationships

public void ensureRelationships()
Ensure that the relationships collection is not null.

getRelationship

public PackageRelationship getRelationship(java.lang.String id)
Description copied from interface: RelationshipSource
Retrieves a package relationship from its id.

Specified by:
getRelationship in interface RelationshipSource
Parameters:
id - ID of the package relationship to retrieve.
Returns:
The package relationship
See Also:
RelationshipSource.getRelationship(java.lang.String)

hasRelationships

public boolean hasRelationships()
Description copied from interface: RelationshipSource
Knows if the part have any relationships.

Specified by:
hasRelationships in interface RelationshipSource
Returns:
true if the part have at least one relationship else false.
See Also:
RelationshipSource.hasRelationships()

isRelationshipExists

public boolean isRelationshipExists(PackageRelationship rel)
Description copied from interface: RelationshipSource
Checks if the specified relationship is part of this package part.

Specified by:
isRelationshipExists in interface RelationshipSource
Parameters:
rel - The relationship to check.
Returns:
true if the specified relationship exists in this part, else returns false
See Also:
RelationshipSource.isRelationshipExists(org.apache.poi.openxml4j.opc.PackageRelationship)

addMarshaller

public void addMarshaller(java.lang.String contentType,
                          PartMarshaller marshaller)
Add a marshaller.

Parameters:
contentType - The content type to bind to the specified marshaller.
marshaller - The marshaller to register with the specified content type.

addUnmarshaller

public void addUnmarshaller(java.lang.String contentType,
                            PartUnmarshaller unmarshaller)
Add an unmarshaller.

Parameters:
contentType - The content type to bind to the specified unmarshaller.
unmarshaller - The unmarshaller to register with the specified content type.

removeMarshaller

public void removeMarshaller(java.lang.String contentType)
Remove a marshaller by its content type.

Parameters:
contentType - The content type associated with the marshaller to remove.

removeUnmarshaller

public void removeUnmarshaller(java.lang.String contentType)
Remove an unmarshaller by its content type.

Parameters:
contentType - The content type associated with the unmarshaller to remove.

getPackageAccess

public PackageAccess getPackageAccess()
Get the package access mode.

Returns:
the packageAccess The current package access.

validatePackage

public boolean validatePackage(OPCPackage pkg)
                        throws InvalidFormatException
Validates the package compliance with the OPC specifications.

Returns:
true if the package is valid else false
Throws:
InvalidFormatException

save

public void save(java.io.File targetFile)
          throws java.io.IOException
Save the document in the specified file.

Parameters:
targetFile - Destination file.
Throws:
java.io.IOException - Throws if an IO exception occur.
See Also:
save(OutputStream)

save

public void save(java.io.OutputStream outputStream)
          throws java.io.IOException
Save the document in the specified output stream.

Parameters:
outputStream - The stream to save the package.
Throws:
java.io.IOException
See Also:
saveImpl(OutputStream)

createPartImpl

protected abstract PackagePart createPartImpl(PackagePartName partName,
                                              java.lang.String contentType,
                                              boolean loadRelationships)
Core method to create a package part. This method must be implemented by the subclass.

Parameters:
partName - URI of the part to create.
contentType - Content type of the part to create.
Returns:
The newly created package part.

removePartImpl

protected abstract void removePartImpl(PackagePartName partName)
Core method to delete a package part. This method must be implemented by the subclass.

Parameters:
partName - The URI of the part to delete.

flushImpl

protected abstract void flushImpl()
Flush the package but not save.

closeImpl

protected abstract void closeImpl()
                           throws java.io.IOException
Close the package and cause a save of the package.

Throws:
java.io.IOException

revertImpl

protected abstract void revertImpl()
Close the package without saving the document. Discard all changes made to this package.

saveImpl

protected abstract void saveImpl(java.io.OutputStream outputStream)
                          throws java.io.IOException
Save the package into the specified output stream.

Parameters:
outputStream - The output stream use to save this package.
Throws:
java.io.IOException

getPartImpl

protected abstract PackagePart getPartImpl(PackagePartName partName)
Get the package part mapped to the specified URI.

Parameters:
partName - The URI of the part to retrieve.
Returns:
The package part located by the specified URI, else null.

getPartsImpl

protected abstract PackagePart[] getPartsImpl()
                                       throws InvalidFormatException
Get all parts link to the package.

Returns:
A list of the part owned by the package.
Throws:
InvalidFormatException

replaceContentType

public boolean replaceContentType(java.lang.String oldContentType,
                                  java.lang.String newContentType)
Replace a content type in this package.

A typical scneario to call this method is to rename a template file to the main format, e.g. ".dotx" to ".docx" ".dotm" to ".docm" ".xltx" to ".xlsx" ".xltm" to ".xlsm" ".potx" to ".pptx" ".potm" to ".pptm"

For example, a code converting a .xlsm macro workbook to .xlsx would look as follows:

     OPCPackage pkg = OPCPackage.open(new FileInputStream("macro-workbook.xlsm"));
     pkg.replaceContentType(
         "application/vnd.ms-excel.sheet.macroEnabled.main+xml",
         "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet.main+xml");

     FileOutputStream out = new FileOutputStream("workbook.xlsx");
     pkg.save(out);
     out.close();

Parameters:
oldContentType - the content type to be replaced
newContentType - the replacement
Returns:
whether replacement was succesfull
Since:
POI-3.8
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Package

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class Package

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.OPCPackage
        extended by  org.apache.poi.openxml4j.opc.Package
All Implemented Interfaces:
java.io.Closeable, RelationshipSource
Direct Known Subclasses:
ZipPackage
Deprecated. (name clash with Package use OPCPackage instead.

@Deprecated
public abstract class Package
extends OPCPackage

Author:
Julien Chable, CDubet

Field Summary
Fields inherited from class org.apache.poi.openxml4j.opc.OPCPackage
contentTypeManager, defaultPackageAccess, defaultPartMarshaller, isDirty, originalPackagePath, output, packageProperties, partList, partMarshallers, partUnmarshallers, relationships
Constructor Summary
protected Package(PackageAccess access)
Deprecated. use OPCPackage
Method Summary
static Package create(java.io.File file)
Deprecated. use OPCPackage.create(File)
static Package create(java.io.OutputStream output)
Deprecated. use OPCPackage.create(OutputStream)
static Package create(java.lang.String path)
Deprecated. use OPCPackage.create(String)
static Package open(java.io.InputStream in)
Deprecated. use OPCPackage.open(InputStream)
static Package open(java.lang.String path)
Deprecated. use OPCPackage.open(String)
static Package open(java.lang.String path, PackageAccess access)
Deprecated. use OPCPackage.open(String,PackageAccess)
static Package openOrCreate(java.io.File file)
Deprecated. use OPCPackage.openOrCreate(java.io.File)
Methods inherited from class org.apache.poi.openxml4j.opc.OPCPackage
addExternalRelationship, addExternalRelationship, addMarshaller, addPackagePart, addRelationship, addRelationship, addThumbnail, addUnmarshaller, clearRelationships, close, closeImpl, containPart, createPart, createPart, createPartImpl, deletePart, deletePartRecursive, ensureRelationships, flush, flushImpl, getPackageAccess, getPackageProperties, getPart, getPart, getPartImpl, getParts, getPartsByContentType, getPartsByName, getPartsByRelationshipType, getPartsImpl, getRelationship, getRelationships, getRelationshipsByType, hasRelationships, isRelationshipExists, removeMarshaller, removePart, removePart, removePartImpl, removePartRecursive, removeRelationship, removeUnmarshaller, replaceContentType, revert, revertImpl, save, save, saveImpl, validatePackage
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Package

@Deprecated
protected Package(PackageAccess access)
Deprecated. use OPCPackage

Method Detail

open

@Deprecated
public static Package open(java.lang.String path)
                    throws InvalidFormatException
Deprecated. use OPCPackage.open(String)

Throws:
InvalidFormatException

open

@Deprecated
public static Package open(java.lang.String path,
                                      PackageAccess access)
                    throws InvalidFormatException
Deprecated. use OPCPackage.open(String,PackageAccess)

Throws:
InvalidFormatException

open

@Deprecated
public static Package open(java.io.InputStream in)
                    throws InvalidFormatException,
                           java.io.IOException
Deprecated. use OPCPackage.open(InputStream)

Throws:
InvalidFormatException
java.io.IOException

openOrCreate

@Deprecated
public static Package openOrCreate(java.io.File file)
                            throws InvalidFormatException
Deprecated. use OPCPackage.openOrCreate(java.io.File)

Throws:
InvalidFormatException

create

@Deprecated
public static Package create(java.lang.String path)
Deprecated. use OPCPackage.create(String)

create

@Deprecated
public static Package create(java.io.File file)
Deprecated. use OPCPackage.create(File)

create

@Deprecated
public static Package create(java.io.OutputStream output)
Deprecated. use OPCPackage.create(OutputStream)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackageAccess

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.openxml4j.opc
Enum PackageAccess

java.lang.Object
    extended by  java.lang.Enum<PackageAccess>
        extended by  org.apache.poi.openxml4j.opc.PackageAccess
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<PackageAccess>
public enum PackageAccess
extends java.lang.Enum<PackageAccess>

Specifies package access.

Version:
1.0
Author:
Julien Chable

Enum Constant Summary
READ
Read only.
READ_WRITE
Read and Write mode.
WRITE
Write only.
Method Summary
static PackageAccess | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PackageAccess[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

READ

public static final PackageAccess READ
Read only. Write not authorized.

WRITE

public static final PackageAccess WRITE
Write only. Read not authorized.

READ_WRITE

public static final PackageAccess READ_WRITE
Read and Write mode.

Method Detail

values

public static PackageAccess[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (PackageAccess c : PackageAccess.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static PackageAccess valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


 org.apache.poi.openxml4j.opc
Interfaces
PackageNamespaces
PackageProperties
PackageRelationshipTypes
RelationshipSource
Classes
Configuration
ContentTypes
OPCPackage
Package
PackagePart
PackagePartCollection
PackagePartName
PackageRelationship
PackageRelationshipCollection
PackagingURIHelper
StreamHelper
ZipPackage
ZipPackagePart
Enums
CertificateEmbeddingOption
CompressionOption
EncryptionOption
PackageAccess
TargetMode


PackageNamespaces

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Interface PackageNamespaces

public interface PackageNamespaces

Open Packaging Convention namespaces URI.

Version:
1.0
Author:
Julien Chable

Field Summary
static java.lang.String | CONTENT_TYPES Content Types.
static java.lang.String | CORE_PROPERTIES Core Properties.
static java.lang.String | DIGITAL_SIGNATURE Digital Signatures.
static java.lang.String | MARKUP_COMPATIBILITY Markup Compatibility.
static java.lang.String | RELATIONSHIPS Relationships.

Field Detail

CONTENT_TYPES

static final java.lang.String CONTENT_TYPES
Content Types.

See Also:
Constant Field Values

CORE_PROPERTIES

static final java.lang.String CORE_PROPERTIES
Core Properties.

See Also:
Constant Field Values

DIGITAL_SIGNATURE

static final java.lang.String DIGITAL_SIGNATURE
Digital Signatures.

See Also:
Constant Field Values

RELATIONSHIPS

static final java.lang.String RELATIONSHIPS
Relationships.

See Also:
Constant Field Values

MARKUP_COMPATIBILITY

static final java.lang.String MARKUP_COMPATIBILITY
Markup Compatibility.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackagePart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class PackagePart

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagePart
All Implemented Interfaces:
RelationshipSource
Direct Known Subclasses:
DigitalCertificatePart, MemoryPackagePart, PackageDigitalSignature, PackagePropertiesPart, ZipPackagePart
public abstract class PackagePart
extends java.lang.Object
implements RelationshipSource

Provides a base class for parts stored in a Package.

Version:
0.9
Author:
Julien Chable

Field Summary
protected OPCPackage | _container This part's container.
protected ContentType | _contentType The type of content of this part.
protected PackagePartName | _partName The part name.
Constructor Summary
protected | PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType) Constructor.
protected | PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType, boolean loadRelationships) Constructor.
 | PackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType) Constructor.
Method Summary
PackageRelationship | addExternalRelationship(java.lang.String target, java.lang.String relationshipType) Adds an external relationship to a part (except relationships part).
PackageRelationship | addExternalRelationship(java.lang.String target, java.lang.String relationshipType, java.lang.String id) Adds an external relationship to a part (except relationships part).
PackageRelationship | addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
PackageRelationship | addRelationship(java.net.URI targetURI, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | addRelationship(java.net.URI targetURI, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
void | clearRelationships() Delete all the relationships attached to this.
abstract void | close() Close this part : flush this part, close the input stream and output stream.
abstract void | flush() Flush the content of this part.
java.lang.String | getContentType()
java.io.InputStream | getInputStream() Get the input stream of this part to read its content.
protected abstract java.io.InputStream | getInputStreamImpl() Abtract method that get the input stream of this part.
java.io.OutputStream | getOutputStream() Get the output stream of this part.
protected abstract java.io.OutputStream | getOutputStreamImpl() Abstract method that get the output stream of this part.
OPCPackage | getPackage()
PackagePartName | getPartName()
PackagePart | getRelatedPart(PackageRelationship rel) Get the PackagePart that is the target of a relationship.
PackageRelationship | getRelationship(java.lang.String id) Retrieves a package relationship from its id.
PackageRelationshipCollection | getRelationships() Retrieve all the relationships attached to this part.
PackageRelationshipCollection | getRelationshipsByType(java.lang.String relationshipType) Retrieve all relationships attached to this part which have the specified type.
boolean | hasRelationships() Knows if the part have any relationships.
boolean | isDeleted()
boolean | isRelationshipExists(PackageRelationship rel) Checks if the specified relationship is part of this package part.
boolean | isRelationshipPart()
abstract boolean | load(java.io.InputStream ios) Load the content of this part.
void | removeRelationship(java.lang.String id) Delete the relationship specified by its id.
abstract boolean | save(java.io.OutputStream zos) Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.
void | setContentType(java.lang.String contentType) Set the content type.
void | setDeleted(boolean isDeleted)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

_container

protected OPCPackage _container
This part's container.

_partName

protected PackagePartName _partName
The part name. (required by the specification [M1.1])

_contentType

protected ContentType _contentType
The type of content of this part. (required by the specification [M1.2])

Constructor Detail

PackagePart

protected PackagePart(OPCPackage pack,
                      PackagePartName partName,
                      ContentType contentType)
               throws InvalidFormatException
Constructor.

Parameters:
pack - Parent package.
partName - The part name, relative to the parent Package root.
contentType - The content type.
Throws:
InvalidFormatException - If the specified URI is not valid.

PackagePart

protected PackagePart(OPCPackage pack,
                      PackagePartName partName,
                      ContentType contentType,
                      boolean loadRelationships)
               throws InvalidFormatException
Constructor.

Parameters:
pack - Parent package.
partName - The part name, relative to the parent Package root.
contentType - The content type.
loadRelationships - Specify if the relationships will be loaded
Throws:
InvalidFormatException - If the specified URI is not valid.

PackagePart

public PackagePart(OPCPackage pack,
                   PackagePartName partName,
                   java.lang.String contentType)
            throws InvalidFormatException
Constructor.

Parameters:
pack - Parent package.
partName - The part name, relative to the parent Package root.
contentType - The Multipurpose Internet Mail Extensions (MIME) content type of the part's data stream.
Throws:
InvalidFormatException
Method Detail

addExternalRelationship

public PackageRelationship addExternalRelationship(java.lang.String target,
                                                   java.lang.String relationshipType)
Adds an external relationship to a part (except relationships part). The targets of external relationships are not subject to the same validity checks that internal ones are, as the contents is potentially any file, URL or similar.

Specified by:
addExternalRelationship in interface RelationshipSource
Parameters:
target - External target of the relationship
relationshipType - Type of relationship.
Returns:
The newly created and added relationship
See Also:
RelationshipSource.addExternalRelationship(java.lang.String, java.lang.String)

addExternalRelationship

public PackageRelationship addExternalRelationship(java.lang.String target,
                                                   java.lang.String relationshipType,
                                                   java.lang.String id)
Adds an external relationship to a part (except relationships part). The targets of external relationships are not subject to the same validity checks that internal ones are, as the contents is potentially any file, URL or similar.

Specified by:
addExternalRelationship in interface RelationshipSource
Parameters:
target - External target of the relationship
relationshipType - Type of relationship.
id - Relationship unique id.
Returns:
The newly created and added relationship
See Also:
RelationshipSource.addExternalRelationship(java.lang.String, java.lang.String)

addRelationship

public PackageRelationship addRelationship(PackagePartName targetPartName,
                                           TargetMode targetMode,
                                           java.lang.String relationshipType)
Add a relationship to a part (except relationships part).

Specified by:
addRelationship in interface RelationshipSource
Parameters:
targetPartName - Name of the target part. This one must be relative to the source root directory of the part.
targetMode - Mode [Internal|External].
relationshipType - Type of relationship.
Returns:
The newly created and added relationship
See Also:
RelationshipSource.addRelationship(org.apache.poi.openxml4j.opc.PackagePartName, org.apache.poi.openxml4j.opc.TargetMode, java.lang.String)

addRelationship

public PackageRelationship addRelationship(PackagePartName targetPartName,
                                           TargetMode targetMode,
                                           java.lang.String relationshipType,
                                           java.lang.String id)
Add a relationship to a part (except relationships part).

Check rule M1.25: The Relationships part shall not have relationships to any other part. Package implementers shall enforce this requirement upon the attempt to create such a relationship and shall treat any such relationship as invalid.

Specified by:
addRelationship in interface RelationshipSource
Parameters:
targetPartName - Name of the target part. This one must be relative to the source root directory of the part.
targetMode - Mode [Internal|External].
relationshipType - Type of relationship.
id - Relationship unique id.
Returns:
The newly created and added relationship
Throws:
InvalidFormatException - If the URI point to a relationship part URI.
See Also:
RelationshipSource.addRelationship(org.apache.poi.openxml4j.opc.PackagePartName, org.apache.poi.openxml4j.opc.TargetMode, java.lang.String, java.lang.String)

addRelationship

public PackageRelationship addRelationship(java.net.URI targetURI,
                                           TargetMode targetMode,
                                           java.lang.String relationshipType)
Add a relationship to a part (except relationships part).

Parameters:
targetURI - URI the target part. Must be relative to the source root directory of the part.
targetMode - Mode [Internal|External].
relationshipType - Type of relationship.
Returns:
The newly created and added relationship
See Also:
RelationshipSource.addRelationship(org.apache.poi.openxml4j.opc.PackagePartName, org.apache.poi.openxml4j.opc.TargetMode, java.lang.String)

addRelationship

public PackageRelationship addRelationship(java.net.URI targetURI,
                                           TargetMode targetMode,
                                           java.lang.String relationshipType,
                                           java.lang.String id)
Add a relationship to a part (except relationships part).

Check rule M1.25: The Relationships part shall not have relationships to any other part. Package implementers shall enforce this requirement upon the attempt to create such a relationship and shall treat any such relationship as invalid.

Parameters:
targetURI - URI of the target part. Must be relative to the source root directory of the part.
targetMode - Mode [Internal|External].
relationshipType - Type of relationship.
id - Relationship unique id.
Returns:
The newly created and added relationship
Throws:
InvalidFormatException - If the URI point to a relationship part URI.
See Also:
RelationshipSource.addRelationship(org.apache.poi.openxml4j.opc.PackagePartName, org.apache.poi.openxml4j.opc.TargetMode, java.lang.String, java.lang.String)

clearRelationships

public void clearRelationships()
Description copied from interface: RelationshipSource
Delete all the relationships attached to this.

Specified by:
clearRelationships in interface RelationshipSource
See Also:
RelationshipSource.clearRelationships()

removeRelationship

public void removeRelationship(java.lang.String id)
Delete the relationship specified by its id.

Specified by:
removeRelationship in interface RelationshipSource
Parameters:
id - The ID identified the part to delete.
See Also:
RelationshipSource.removeRelationship(java.lang.String)

getRelationships

public PackageRelationshipCollection getRelationships()
                                               throws InvalidFormatException
Retrieve all the relationships attached to this part.

Specified by:
getRelationships in interface RelationshipSource
Returns:
This part's relationships.
Throws:
OpenXML4JException
InvalidFormatException
See Also:
RelationshipSource.getRelationships()

getRelationship

public PackageRelationship getRelationship(java.lang.String id)
Retrieves a package relationship from its id.

Specified by:
getRelationship in interface RelationshipSource
Parameters:
id - ID of the package relationship to retrieve.
Returns:
The package relationship
See Also:
RelationshipSource.getRelationship(java.lang.String)

getRelationshipsByType

public PackageRelationshipCollection getRelationshipsByType(java.lang.String relationshipType)
                                                     throws InvalidFormatException
Retrieve all relationships attached to this part which have the specified type.

Specified by:
getRelationshipsByType in interface RelationshipSource
Parameters:
relationshipType - Relationship type filter.
Returns:
All relationships from this part that have the specified type.
Throws:
InvalidFormatException - If an error occurs while parsing the part.
InvalidOperationException - If the package is open in write only mode.
See Also:
RelationshipSource.getRelationshipsByType(java.lang.String)

hasRelationships

public boolean hasRelationships()
Knows if the part have any relationships.

Specified by:
hasRelationships in interface RelationshipSource
Returns:
true if the part have at least one relationship else false.
See Also:
RelationshipSource.hasRelationships()

isRelationshipExists

public boolean isRelationshipExists(PackageRelationship rel)
Checks if the specified relationship is part of this package part.

Specified by:
isRelationshipExists in interface RelationshipSource
Parameters:
rel - The relationship to check.
Returns:
true if the specified relationship exists in this part, else returns false
See Also:
RelationshipSource.isRelationshipExists(org.apache.poi.openxml4j.opc.PackageRelationship)

getRelatedPart

public PackagePart getRelatedPart(PackageRelationship rel)
                           throws InvalidFormatException
Get the PackagePart that is the target of a relationship.

Parameters:
rel - A relationship from this part to another one
Returns:
The target part of the relationship
Throws:
InvalidFormatException

getInputStream

public java.io.InputStream getInputStream()
                                   throws java.io.IOException
Get the input stream of this part to read its content.

Returns:
The input stream of the content of this part, else null.
Throws:
java.io.IOException

getOutputStream

public java.io.OutputStream getOutputStream()
Get the output stream of this part. If the part is originally embedded in Zip package, it'll be transform intot a MemoryPackagePart in order to write inside (the standard Java API doesn't allow to write in the file)

See Also:
MemoryPackagePart

getPartName

public PackagePartName getPartName()
Returns:
the uri

getContentType

public java.lang.String getContentType()
Returns:
the contentType

setContentType

public void setContentType(java.lang.String contentType)
                    throws InvalidFormatException
Set the content type.

Parameters:
contentType - the contentType to set
Throws:
InvalidFormatException - Throws if the content type is not valid.
InvalidOperationException - Throws if you try to change the content type whereas this part is already attached to a package.

getPackage

public OPCPackage getPackage()

isRelationshipPart

public boolean isRelationshipPart()
Returns:
true if this part is a relationship

isDeleted

public boolean isDeleted()
Returns:
true if this part has been logically deleted

setDeleted

public void setDeleted(boolean isDeleted)
Parameters:
isDeleted - the isDeleted to set

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getInputStreamImpl

protected abstract java.io.InputStream getInputStreamImpl()
                                                   throws java.io.IOException
Abtract method that get the input stream of this part.

Throws:
java.io.IOException - Throws if an IO Exception occur in the implementation method.

getOutputStreamImpl

protected abstract java.io.OutputStream getOutputStreamImpl()
Abstract method that get the output stream of this part.

save

public abstract boolean save(java.io.OutputStream zos)
                      throws OpenXML4JException
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.

Parameters:
zos - Output stream to save this part.
Throws:
OpenXML4JException - If any exception occur.

load

public abstract boolean load(java.io.InputStream ios)
                      throws InvalidFormatException
Load the content of this part.

Parameters:
ios - The input stream of the content to load.
Returns:
true if the content has been successfully loaded, else false.
Throws:
InvalidFormatException - Throws if the content format is invalid.

close

public abstract void close()
Close this part : flush this part, close the input stream and output stream. After this method call, the part must be available for packaging.

flush

public abstract void flush()
Flush the content of this part. If the input stream and/or output stream as in a waiting state to read or write, the must to empty their respective buffer.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackagePartCollection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class PackagePartCollection

java.lang.Object
    extended by  java.util.AbstractMap<K,V>
        extended by  java.util.TreeMap<PackagePartName,PackagePart>
            extended by  org.apache.poi.openxml4j.opc.PackagePartCollection
All Implemented Interfaces:
java.io.Serializable, java.lang.Cloneable, java.util.Map<PackagePartName,PackagePart>, java.util.NavigableMap<PackagePartName,PackagePart>, java.util.SortedMap<PackagePartName,PackagePart>
public final class PackagePartCollection
extends java.util.TreeMap<PackagePartName,PackagePart>

A package part collection.

Version:
0.1
Author:
Julien Chable
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.util.AbstractMap
java.util.AbstractMap.SimpleEntry<K,V>, java.util.AbstractMap.SimpleImmutableEntry<K,V>
Constructor Summary
PackagePartCollection()
Method Summary
java.lang.Object | clone()
PackagePart | put(PackagePartName partName, PackagePart part) Check rule [M1.11]: a package implementer shall neither create nor recognize a part with a part name derived from another part name by appending segments to it.
PackagePart | remove(java.lang.Object key)
Methods inherited from class java.util.TreeMap
ceilingEntry, ceilingKey, clear, comparator, containsKey, containsValue, descendingKeySet, descendingMap, entrySet, firstEntry, firstKey, floorEntry, floorKey, get, headMap, headMap, higherEntry, higherKey, keySet, lastEntry, lastKey, lowerEntry, lowerKey, navigableKeySet, pollFirstEntry, pollLastEntry, putAll, size, subMap, subMap, tailMap, tailMap, values
Methods inherited from class java.util.AbstractMap
equals, hashCode, isEmpty, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode, isEmpty

Constructor Detail

PackagePartCollection

public PackagePartCollection()
Method Detail

clone

public java.lang.Object clone()
Overrides:
clone in class java.util.TreeMap<PackagePartName,PackagePart>

put

public PackagePart put(PackagePartName partName,
                       PackagePart part)
Check rule [M1.11]: a package implementer shall neither create nor recognize a part with a part name derived from another part name by appending segments to it.

Specified by:
put in interface java.util.Map<PackagePartName,PackagePart>
Overrides:
put in class java.util.TreeMap<PackagePartName,PackagePart>
Throws:
InvalidOperationException - Throws if you try to add a part with a name derived from another part name.

remove

public PackagePart remove(java.lang.Object key)
Specified by:
remove in interface java.util.Map<PackagePartName,PackagePart>
Overrides:
remove in class java.util.TreeMap<PackagePartName,PackagePart>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackagePartName

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class PackagePartName

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagePartName
All Implemented Interfaces:
java.lang.Comparable<PackagePartName>
public final class PackagePartName
extends java.lang.Object
implements java.lang.Comparable<PackagePartName>

An immutable Open Packaging Convention compliant part name.

Author:
Julien Chable
See Also:
http://www.ietf.org/rfc/rfc3986.txt

Method Summary
int | compareTo(PackagePartName otherPartName) Compare two part name following the rule M1.12 : Part name equivalence is determined by comparing part names as case-insensitive ASCII strings.
boolean | equals(java.lang.Object otherPartName) Part name equivalence is determined by comparing part names as case-insensitive ASCII strings.
java.lang.String | getExtension() Retrieves the extension of the part name if any.
java.lang.String | getName() Get this part name.
java.net.URI | getURI() Part name property getter.
int | hashCode()
boolean | isRelationshipPartURI() Know if this part name is a relationship part name.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Method Detail

isRelationshipPartURI

public boolean isRelationshipPartURI()
Know if this part name is a relationship part name.

Returns:
true if this part name respect the relationship part naming convention else false.

compareTo

public int compareTo(PackagePartName otherPartName)
Compare two part name following the rule M1.12 : Part name equivalence is determined by comparing part names as case-insensitive ASCII strings. Packages shall not contain equivalent part names and package implementers shall neither create nor recognize packages with equivalent part names. [M1.12]

Specified by:
compareTo in interface java.lang.Comparable<PackagePartName>

getExtension

public java.lang.String getExtension()
Retrieves the extension of the part name if any. If there is no extension returns an empty String. Example : '/document/content.xml' => 'xml'

Returns:
The extension of the part name.

getName

public java.lang.String getName()
Get this part name.

Returns:
The name of this part name.

equals

public boolean equals(java.lang.Object otherPartName)
Part name equivalence is determined by comparing part names as case-insensitive ASCII strings. Packages shall not contain equivalent part names and package implementers shall neither create nor recognize packages with equivalent part names. [M1.12]

Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getURI

public java.net.URI getURI()
Part name property getter.

Returns:
This part name URI.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackageProperties

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Interface PackageProperties

All Known Implementing Classes:
PackagePropertiesPart
public interface PackageProperties

Represents the core properties of an OPC package.

Version:
1.0
Author:
Julien Chable
See Also:
OPCPackage

Field Summary
static java.lang.String | NAMESPACE_DC Dublin Core namespace URI.
static java.lang.String | NAMESPACE_DCTERMS Dublin Core Terms URI.
Method Summary
Nullable<java.lang.String> | getCategoryProperty() Set the category of the content of this package.
Nullable<java.lang.String> | getContentStatusProperty() Set the status of the content.
Nullable<java.lang.String> | getContentTypeProperty() Get the type of content represented, generally defined by a specific use and intended audience.
Nullable<java.util.Date> | getCreatedProperty() Get the date of creation of the resource.
Nullable<java.lang.String> | getCreatorProperty() Get the entity primarily responsible for making the content of the resource.
Nullable<java.lang.String> | getDescriptionProperty() Get the explanation of the content of the resource.
Nullable<java.lang.String> | getIdentifierProperty() Get an unambiguous reference to the resource within a given context.
Nullable<java.lang.String> | getKeywordsProperty() Get a delimited set of keywords to support searching and indexing.
Nullable<java.lang.String> | getLanguageProperty() Get the language of the intellectual content of the resource.
Nullable<java.lang.String> | getLastModifiedByProperty() Get the user who performed the last modification.
Nullable<java.util.Date> | getLastPrintedProperty() Get the date and time of the last printing.
Nullable<java.util.Date> | getModifiedProperty() Get the date on which the resource was changed.
Nullable<java.lang.String> | getRevisionProperty() Get the revision number.
Nullable<java.lang.String> | getSubjectProperty() Get the topic of the content of the resource.
Nullable<java.lang.String> | getTitleProperty() Get the name given to the resource.
Nullable<java.lang.String> | getVersionProperty() Get the version number.
void | setCategoryProperty(java.lang.String category) Set the category of the content of this package.
void | setContentStatusProperty(java.lang.String contentStatus) Get the status of the content.
void | setContentTypeProperty(java.lang.String contentType) Set the type of content represented, generally defined by a specific use and intended audience.
void | setCreatedProperty(Nullable<java.util.Date> created) Set the date of creation of the resource.
void | setCreatedProperty(java.lang.String created) Set the date of creation of the resource.
void | setCreatorProperty(java.lang.String creator) Set the entity primarily responsible for making the content of the resource.
void | setDescriptionProperty(java.lang.String description) Set the explanation of the content of the resource.
void | setIdentifierProperty(java.lang.String identifier) Set an unambiguous reference to the resource within a given context.
void | setKeywordsProperty(java.lang.String keywords) Set a delimited set of keywords to support searching and indexing.
void | setLanguageProperty(java.lang.String language) Set the language of the intellectual content of the resource.
void | setLastModifiedByProperty(java.lang.String lastModifiedBy) Set the user who performed the last modification.
void | setLastPrintedProperty(Nullable<java.util.Date> lastPrinted) Set the date and time of the last printing.
void | setLastPrintedProperty(java.lang.String lastPrinted) Set the date and time of the last printing.
void | setModifiedProperty(Nullable<java.util.Date> modified) Set the date on which the resource was changed.
void | setModifiedProperty(java.lang.String modified) Set the date on which the resource was changed.
void | setRevisionProperty(java.lang.String revision) Set the revision number.
void | setSubjectProperty(java.lang.String subject) Set the topic of the content of the resource.
void | setTitleProperty(java.lang.String title) Set the name given to the resource.
void | setVersionProperty(java.lang.String version) Set the version number.

Field Detail

NAMESPACE_DCTERMS

static final java.lang.String NAMESPACE_DCTERMS
Dublin Core Terms URI.

See Also:
Constant Field Values

NAMESPACE_DC

static final java.lang.String NAMESPACE_DC
Dublin Core namespace URI.

See Also:
Constant Field Values
Method Detail

getCategoryProperty

Nullable<java.lang.String> getCategoryProperty()
Set the category of the content of this package.

setCategoryProperty

void setCategoryProperty(java.lang.String category)
Set the category of the content of this package.

getContentStatusProperty

Nullable<java.lang.String> getContentStatusProperty()
Set the status of the content.

setContentStatusProperty

void setContentStatusProperty(java.lang.String contentStatus)
Get the status of the content.

getContentTypeProperty

Nullable<java.lang.String> getContentTypeProperty()
Get the type of content represented, generally defined by a specific use and intended audience.

setContentTypeProperty

void setContentTypeProperty(java.lang.String contentType)
Set the type of content represented, generally defined by a specific use and intended audience.

getCreatedProperty

Nullable<java.util.Date> getCreatedProperty()
Get the date of creation of the resource.

setCreatedProperty

void setCreatedProperty(java.lang.String created)
Set the date of creation of the resource.

setCreatedProperty

void setCreatedProperty(Nullable<java.util.Date> created)
Set the date of creation of the resource.

getCreatorProperty

Nullable<java.lang.String> getCreatorProperty()
Get the entity primarily responsible for making the content of the resource.

setCreatorProperty

void setCreatorProperty(java.lang.String creator)
Set the entity primarily responsible for making the content of the resource.

getDescriptionProperty

Nullable<java.lang.String> getDescriptionProperty()
Get the explanation of the content of the resource.

setDescriptionProperty

void setDescriptionProperty(java.lang.String description)
Set the explanation of the content of the resource.

getIdentifierProperty

Nullable<java.lang.String> getIdentifierProperty()
Get an unambiguous reference to the resource within a given context.

setIdentifierProperty

void setIdentifierProperty(java.lang.String identifier)
Set an unambiguous reference to the resource within a given context.

getKeywordsProperty

Nullable<java.lang.String> getKeywordsProperty()
Get a delimited set of keywords to support searching and indexing. This is typically a list of terms that are not available elsewhere in the properties

setKeywordsProperty

void setKeywordsProperty(java.lang.String keywords)
Set a delimited set of keywords to support searching and indexing. This is typically a list of terms that are not available elsewhere in the properties

getLanguageProperty

Nullable<java.lang.String> getLanguageProperty()
Get the language of the intellectual content of the resource.

setLanguageProperty

void setLanguageProperty(java.lang.String language)
Set the language of the intellectual content of the resource.

getLastModifiedByProperty

Nullable<java.lang.String> getLastModifiedByProperty()
Get the user who performed the last modification.

setLastModifiedByProperty

void setLastModifiedByProperty(java.lang.String lastModifiedBy)
Set the user who performed the last modification.

getLastPrintedProperty

Nullable<java.util.Date> getLastPrintedProperty()
Get the date and time of the last printing.

setLastPrintedProperty

void setLastPrintedProperty(java.lang.String lastPrinted)
Set the date and time of the last printing.

setLastPrintedProperty

void setLastPrintedProperty(Nullable<java.util.Date> lastPrinted)
Set the date and time of the last printing.

getModifiedProperty

Nullable<java.util.Date> getModifiedProperty()
Get the date on which the resource was changed.

setModifiedProperty

void setModifiedProperty(java.lang.String modified)
Set the date on which the resource was changed.

setModifiedProperty

void setModifiedProperty(Nullable<java.util.Date> modified)
Set the date on which the resource was changed.

getRevisionProperty

Nullable<java.lang.String> getRevisionProperty()
Get the revision number.

setRevisionProperty

void setRevisionProperty(java.lang.String revision)
Set the revision number.

getSubjectProperty

Nullable<java.lang.String> getSubjectProperty()
Get the topic of the content of the resource.

setSubjectProperty

void setSubjectProperty(java.lang.String subject)
Set the topic of the content of the resource.

getTitleProperty

Nullable<java.lang.String> getTitleProperty()
Get the name given to the resource.

setTitleProperty

void setTitleProperty(java.lang.String title)
Set the name given to the resource.

getVersionProperty

Nullable<java.lang.String> getVersionProperty()
Get the version number.

setVersionProperty

void setVersionProperty(java.lang.String version)
Set the version number.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackageRelationship

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class PackageRelationship

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackageRelationship

public final class PackageRelationship
extends java.lang.Object

A part relationship.

Version:
1.0
Author:
Julien Chable

Field Summary
static java.lang.String | ID_ATTRIBUTE_NAME
static java.lang.String | RELATIONSHIP_TAG_NAME
static java.lang.String | RELATIONSHIPS_TAG_NAME
static java.lang.String | TARGET_ATTRIBUTE_NAME
static java.lang.String | TARGET_MODE_ATTRIBUTE_NAME
static java.lang.String | TYPE_ATTRIBUTE_NAME
Constructor Summary
PackageRelationship(OPCPackage pkg, PackagePart sourcePart, java.net.URI targetUri, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id)
Constructor.
Method Summary
 boolean equals(java.lang.Object obj)
static java.net.URI getContainerPartRelationship()
 java.lang.String getId()
 OPCPackage getPackage()
 java.lang.String getRelationshipType()
 PackagePart getSource()
 java.net.URI getSourceURI()
 TargetMode getTargetMode()
public URI getSourceUri(){ }
 java.net.URI getTargetURI()
 int hashCode()
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

ID_ATTRIBUTE_NAME

public static final java.lang.String ID_ATTRIBUTE_NAME
See Also:
Constant Field Values

RELATIONSHIPS_TAG_NAME

public static final java.lang.String RELATIONSHIPS_TAG_NAME
See Also:
Constant Field Values

RELATIONSHIP_TAG_NAME

public static final java.lang.String RELATIONSHIP_TAG_NAME
See Also:
Constant Field Values

TARGET_ATTRIBUTE_NAME

public static final java.lang.String TARGET_ATTRIBUTE_NAME
See Also:
Constant Field Values

TARGET_MODE_ATTRIBUTE_NAME

public static final java.lang.String TARGET_MODE_ATTRIBUTE_NAME
See Also:
Constant Field Values

TYPE_ATTRIBUTE_NAME

public static final java.lang.String TYPE_ATTRIBUTE_NAME
See Also:
Constant Field Values
Constructor Detail

PackageRelationship

public PackageRelationship(OPCPackage pkg,
                           PackagePart sourcePart,
                           java.net.URI targetUri,
                           TargetMode targetMode,
                           java.lang.String relationshipType,
                           java.lang.String id)
Constructor.

Parameters:
pkg -
sourcePart -
targetUri -
targetMode -
relationshipType -
id -
Method Detail

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getContainerPartRelationship

public static java.net.URI getContainerPartRelationship()

getPackage

public OPCPackage getPackage()
Returns:
the container

getId

public java.lang.String getId()
Returns:
the id

getRelationshipType

public java.lang.String getRelationshipType()
Returns:
the relationshipType

getSource

public PackagePart getSource()
Returns:
the source

getSourceURI

public java.net.URI getSourceURI()
Returns:
URL of the source part of this relationship

getTargetMode

public TargetMode getTargetMode()
public URI getSourceUri(){ }

Returns:
the targetMode

getTargetURI

public java.net.URI getTargetURI()
Returns:
the targetUri

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackageRelationshipCollection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class PackageRelationshipCollection

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackageRelationshipCollection
All Implemented Interfaces:
java.lang.Iterable<PackageRelationship>
public final class PackageRelationshipCollection
extends java.lang.Object
implements java.lang.Iterable<PackageRelationship>

Represents a collection of PackageRelationship elements that are owned by a given PackagePart or the Package.

Version:
0.1
Author:
Julien Chable, CDubettier

Constructor Summary
PackageRelationshipCollection(OPCPackage container)
Constructor.
PackageRelationshipCollection(OPCPackage container, PackagePart part)
Constructor.
PackageRelationshipCollection(PackagePart part)
Constructor.
PackageRelationshipCollection(PackageRelationshipCollection coll, java.lang.String filter)
Copy constructor.
Method Summary
void | addRelationship(PackageRelationship relPart) Add the specified relationship to the collection.
PackageRelationship | addRelationship(java.net.URI targetUri, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to the collection.
void | clear() Clear all relationships.
PackageRelationship | getRelationship(int index) Retrieves a relationship by its index in the collection.
PackageRelationship | getRelationshipByID(java.lang.String id) Retrieves a package relationship based on its id.
PackageRelationshipCollection | getRelationships(java.lang.String typeFilter) Retrieves all relations with the specified type.
java.util.Iterator<PackageRelationship> | iterator() Get this collection's iterator.
java.util.Iterator<PackageRelationship> | iterator(java.lang.String typeFilter) Get an iterator of a collection with all relationship with the specified type.
void | removeRelationship(PackageRelationship rel) Remove a relationship by its reference.
void | removeRelationship(java.lang.String id) Remove a relationship by its ID.
int | size() Get the numbe rof relationships in the collection.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PackageRelationshipCollection

public PackageRelationshipCollection(PackageRelationshipCollection coll,
                                     java.lang.String filter)
Copy constructor. This collection will contain only elements from the specified collection for which the type is compatible with the specified relationship type filter.

Parameters:
coll - Collection to import.
filter - Relationship type filter.

PackageRelationshipCollection

public PackageRelationshipCollection(OPCPackage container)
                              throws InvalidFormatException
Constructor.

Throws:
InvalidFormatException

PackageRelationshipCollection

public PackageRelationshipCollection(PackagePart part)
                              throws InvalidFormatException
Constructor.

Throws:
InvalidFormatException - Throws if the format of the content part is invalid.
InvalidOperationException - Throws if the specified part is a relationship part.

PackageRelationshipCollection

public PackageRelationshipCollection(OPCPackage container,
                                     PackagePart part)
                              throws InvalidFormatException
Constructor. Parse the existing package relationship part if one exists.

Parameters:
container - The parent package.
part - The part that own this relationships collection. If null then this part is considered as the package root.
Throws:
InvalidFormatException - If an error occurs during the parsing of the relatinships part fo the specified part.
Method Detail

addRelationship

public void addRelationship(PackageRelationship relPart)
Add the specified relationship to the collection.

Parameters:
relPart - The relationship to add.

addRelationship

public PackageRelationship addRelationship(java.net.URI targetUri,
                                           TargetMode targetMode,
                                           java.lang.String relationshipType,
                                           java.lang.String id)
Add a relationship to the collection.

Parameters:
targetUri - Target URI.
targetMode - The target mode : INTERNAL or EXTERNAL
relationshipType - Relationship type.
id - Relationship ID.
Returns:
The newly created relationship.
See Also:
PackageAccess

removeRelationship

public void removeRelationship(java.lang.String id)
Remove a relationship by its ID.

Parameters:
id - The relationship ID to remove.

removeRelationship

public void removeRelationship(PackageRelationship rel)
Remove a relationship by its reference.

Parameters:
rel - The relationship to delete.

getRelationship

public PackageRelationship getRelationship(int index)
Retrieves a relationship by its index in the collection.

Parameters:
index - Must be a value between [0-relationships_count-1]

getRelationshipByID

public PackageRelationship getRelationshipByID(java.lang.String id)
Retrieves a package relationship based on its id.

Parameters:
id - ID of the package relationship to retrieve.
Returns:
The package relationship identified by the specified id.

size

public int size()
Get the numbe rof relationships in the collection.

getRelationships

public PackageRelationshipCollection getRelationships(java.lang.String typeFilter)
Retrieves all relations with the specified type.

Parameters:
typeFilter - Relationship type filter. If null then all relationships are returned.
Returns:
All relationships of the type specified by the filter.

iterator

public java.util.Iterator<PackageRelationship> iterator()
Get this collection's iterator.

Specified by:
iterator in interface java.lang.Iterable<PackageRelationship>

iterator

public java.util.Iterator<PackageRelationship> iterator(java.lang.String typeFilter)
Get an iterator of a collection with all relationship with the specified type.

Parameters:
typeFilter - Type filter.
Returns:
An iterator to a collection containing all relationships with the specified type contain in this collection.

clear

public void clear()
Clear all relationships.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackageRelationshipTypes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Interface PackageRelationshipTypes

public interface PackageRelationshipTypes

Relationship types.

Version:
0.2
Author:
Julien Chable

Field Summary
static java.lang.String | CORE_DOCUMENT Core properties relationship type.
static java.lang.String | CORE_PROPERTIES Core properties relationship type.
static java.lang.String | CORE_PROPERTIES_ECMA376 Core properties relationship type as defiend in ECMA 376.
static java.lang.String | CUSTOM_PROPERTIES Custom properties relationship type.
static java.lang.String | CUSTOM_XML Custom XML relationship type.
static java.lang.String | DIGITAL_SIGNATURE Digital signature relationship type.
static java.lang.String | DIGITAL_SIGNATURE_CERTIFICATE Digital signature certificate relationship type.
static java.lang.String | DIGITAL_SIGNATURE_ORIGIN Digital signature origin relationship type.
static java.lang.String | EXTENDED_PROPERTIES Extended properties relationship type.
static java.lang.String | HYPERLINK_PART Hyperlink type.
static java.lang.String | IMAGE_PART Image type.
static java.lang.String | STYLE_PART Style type.
static java.lang.String | THUMBNAIL Thumbnail relationship type.

Field Detail

CORE_PROPERTIES

static final java.lang.String CORE_PROPERTIES
Core properties relationship type.

The standard specifies a source relations ship for the Core File Properties part as follows: http://schemas.openxmlformats.org/officedocument/2006/relationships/metadata/core-properties.

Office uses the following source relationship for the Core File Properties part: http://schemas.openxmlformats.org/package/2006/relationships/metadata/core-properties.

See 2.1.33 Part 1 Section 15.2.11.1, Core File Properties Part in [MS-OE376].pdf

See Also:
Constant Field Values

CORE_PROPERTIES_ECMA376

static final java.lang.String CORE_PROPERTIES_ECMA376
Core properties relationship type as defiend in ECMA 376.

See Also:
Constant Field Values

DIGITAL_SIGNATURE

static final java.lang.String DIGITAL_SIGNATURE
Digital signature relationship type.

See Also:
Constant Field Values

DIGITAL_SIGNATURE_CERTIFICATE

static final java.lang.String DIGITAL_SIGNATURE_CERTIFICATE
Digital signature certificate relationship type.

See Also:
Constant Field Values

DIGITAL_SIGNATURE_ORIGIN

static final java.lang.String DIGITAL_SIGNATURE_ORIGIN
Digital signature origin relationship type.

See Also:
Constant Field Values

THUMBNAIL

static final java.lang.String THUMBNAIL
Thumbnail relationship type.

See Also:
Constant Field Values

EXTENDED_PROPERTIES

static final java.lang.String EXTENDED_PROPERTIES
Extended properties relationship type.

See Also:
Constant Field Values

CUSTOM_PROPERTIES

static final java.lang.String CUSTOM_PROPERTIES
Custom properties relationship type.

See Also:
Constant Field Values

CORE_DOCUMENT

static final java.lang.String CORE_DOCUMENT
Core properties relationship type.

See Also:
Constant Field Values

CUSTOM_XML

static final java.lang.String CUSTOM_XML
Custom XML relationship type.

See Also:
Constant Field Values

IMAGE_PART

static final java.lang.String IMAGE_PART
Image type.

See Also:
Constant Field Values

HYPERLINK_PART

static final java.lang.String HYPERLINK_PART
Hyperlink type.

See Also:
Constant Field Values

STYLE_PART

static final java.lang.String STYLE_PART
Style type.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.apache.poi.openxml4j.opc

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.opc

Interface Summary
PackageNamespaces | Open Packaging Convention namespaces URI.
PackageProperties | Represents the core properties of an OPC package.
PackageRelationshipTypes | Relationship types.
RelationshipSource |

Class Summary
Configuration | Storage class for configuration storage parameters.
ContentTypes | Open Packaging Convention content types (see Annex F : Standard Namespaces and Content Types).
OPCPackage | Represents a container that can store multiple data objects.
Package | Deprecated. (name clash with Package use OPCPackage instead.
PackagePart | Provides a base class for parts stored in a Package.
PackagePartCollection | A package part collection.
PackagePartName | An immutable Open Packaging Convention compliant part name.
PackageRelationship | A part relationship.
PackageRelationshipCollection | Represents a collection of PackageRelationship elements that are owned by a given PackagePart or the Package.
PackagingURIHelper | Helper for part and pack URI.
StreamHelper |
ZipPackage | Physical zip package.
ZipPackagePart | Zip implementation of a PackagePart.

Enum Summary
CertificateEmbeddingOption | Specifies the location where the X.509 certificate that is used in signing is stored.
CompressionOption | Specifies the compression level for content that is stored in a PackagePart.
EncryptionOption | Specifies the encryption option for parts in a Package.
PackageAccess | Specifies package access.
TargetMode | Specifies whether the target of a PackageRelationship is inside or outside a Package.


org.apache.poi.openxml4j.opc Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.opc

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.TreeMap<K,V> (implements java.lang.Cloneable, java.util.NavigableMap<K,V>, java.io.Serializable)
        • org.apache.poi.openxml4j.opc.PackagePartCollection
    • org.apache.poi.openxml4j.opc.Configuration
    • org.apache.poi.openxml4j.opc.ContentTypes
    • org.apache.poi.openxml4j.opc.OPCPackage (implements java.io.Closeable, org.apache.poi.openxml4j.opc.RelationshipSource)
      • org.apache.poi.openxml4j.opc.Package
        • org.apache.poi.openxml4j.opc.ZipPackage
    • org.apache.poi.openxml4j.opc.PackagePart (implements org.apache.poi.openxml4j.opc.RelationshipSource)
      • org.apache.poi.openxml4j.opc.ZipPackagePart
    • org.apache.poi.openxml4j.opc.PackagePartName (implements java.lang.Comparable<T>)
    • org.apache.poi.openxml4j.opc.PackageRelationship
    • org.apache.poi.openxml4j.opc.PackageRelationshipCollection (implements java.lang.Iterable<T>)
    • org.apache.poi.openxml4j.opc.PackagingURIHelper
    • org.apache.poi.openxml4j.opc.StreamHelper

Interface Hierarchy

  • org.apache.poi.openxml4j.opc.PackageNamespaces
  • org.apache.poi.openxml4j.opc.PackageProperties
  • org.apache.poi.openxml4j.opc.PackageRelationshipTypes
  • org.apache.poi.openxml4j.opc.RelationshipSource

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.openxml4j.opc.TargetMode
      • org.apache.poi.openxml4j.opc.PackageAccess
      • org.apache.poi.openxml4j.opc.EncryptionOption
      • org.apache.poi.openxml4j.opc.CompressionOption
      • org.apache.poi.openxml4j.opc.CertificateEmbeddingOption


Uses of Package org.apache.poi.openxml4j.opc

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.opc

Packages that use org.apache.poi.openxml4j.opc
org.apache.poi |
org.apache.poi.dev |
org.apache.poi.extractor |
org.apache.poi.openxml4j.opc |
org.apache.poi.openxml4j.opc.internal |
org.apache.poi.openxml4j.opc.internal.marshallers |
org.apache.poi.openxml4j.opc.internal.signature |
org.apache.poi.openxml4j.opc.internal.unmarshallers |
org.apache.poi.openxml4j.opc.signature |
org.apache.poi.ss.usermodel |
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.
org.apache.poi.xslf |
org.apache.poi.xslf.extractor |
org.apache.poi.xslf.usermodel |
org.apache.poi.xssf.eventusermodel |
org.apache.poi.xssf.extractor |
org.apache.poi.xssf.model |
org.apache.poi.xssf.usermodel |
org.apache.poi.xwpf.extractor |
org.apache.poi.xwpf.usermodel |

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.
PackageRelationship
A part relationship.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.dev
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.extractor
OPCPackage
Represents a container that can store multiple data objects.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.openxml4j.opc
CertificateEmbeddingOption
Specifies the location where the X.509 certificate that is used in signing is stored.
CompressionOption
Specifies the compression level for content that is stored in a PackagePart.
EncryptionOption
Specifies the encryption option for parts in a Package.
OPCPackage
Represents a container that can store multiple data objects.
Package
Deprecated. (name clash with Package use OPCPackage instead.
PackageAccess
Specifies package access.
PackagePart
Provides a base class for parts stored in a Package.
PackagePartCollection
A package part collection.
PackagePartName
An immutable Open Packaging Convention compliant part name.
PackageProperties
Represents the core properties of an OPC package.
PackageRelationship
A part relationship.
PackageRelationshipCollection
Represents a collection of PackageRelationship elements that are owned by a given PackagePart or the Package.
RelationshipSource
TargetMode
Specifies whether the target of a PackageRelationship is inside or outside a Package.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.openxml4j.opc.internal
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.
PackagePartName
An immutable Open Packaging Convention compliant part name.
PackageProperties
Represents the core properties of an OPC package.
RelationshipSource
ZipPackage
Physical zip package.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.openxml4j.opc.internal.marshallers
PackagePart
Provides a base class for parts stored in a Package.
PackagePartName
An immutable Open Packaging Convention compliant part name.
PackageRelationshipCollection
Represents a collection of PackageRelationship elements that are owned by a given PackagePart or the Package.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.openxml4j.opc.internal.signature
PackagePart
Provides a base class for parts stored in a Package.
RelationshipSource

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.openxml4j.opc.internal.unmarshallers
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.
PackagePartName
An immutable Open Packaging Convention compliant part name.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.openxml4j.opc.signature
PackagePart
Provides a base class for parts stored in a Package.
RelationshipSource

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.ss.usermodel
OPCPackage
Represents a container that can store multiple data objects.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.util
OPCPackage
Represents a container that can store multiple data objects.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xslf
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xslf.extractor
OPCPackage
Represents a container that can store multiple data objects.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xslf.usermodel
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.
PackageRelationship
A part relationship.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xssf.eventusermodel
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.
PackageRelationship
A part relationship.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xssf.extractor
OPCPackage
Represents a container that can store multiple data objects.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xssf.model
PackagePart
Provides a base class for parts stored in a Package.
PackageRelationship
A part relationship.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xssf.usermodel
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.
PackageRelationship
A part relationship.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xwpf.extractor
OPCPackage
Represents a container that can store multiple data objects.

Classes in org.apache.poi.openxml4j.opc used by org.apache.poi.xwpf.usermodel
OPCPackage
Represents a container that can store multiple data objects.
PackagePart
Provides a base class for parts stored in a Package.
PackageRelationship
A part relationship.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PackagingURIHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class PackagingURIHelper

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagingURIHelper

public final class PackagingURIHelper
extends java.lang.Object

Helper for part and pack URI.

Version:
0.1
Author:
Julien Chable, CDubet, Kim Ung

Field Summary
static PackagePartName | CORE_PROPERTIES_PART_NAME Core properties partname.
static java.net.URI | CORE_PROPERTIES_URI Core properties part URI.
static char | FORWARD_SLASH_CHAR Forward slash URI separator.
static java.lang.String | FORWARD_SLASH_STRING Forward slash URI separator.
static java.lang.String | PACKAGE_CORE_PROPERTIES_NAME Core package properties art name.
static java.lang.String | PACKAGE_PROPERTIES_SEGMENT_NAME Segment name of the package properties folder.
static PackagePartName | PACKAGE_RELATIONSHIPS_ROOT_PART_NAME Package relationships part name.
static java.net.URI | PACKAGE_RELATIONSHIPS_ROOT_URI Package relationships part URI
static PackagePartName | PACKAGE_ROOT_PART_NAME Root package part name.
static java.net.URI | PACKAGE_ROOT_URI Root package URI.
static java.lang.String | RELATIONSHIP_PART_EXTENSION_NAME Extension name of a relationship part.
static java.lang.String | RELATIONSHIP_PART_SEGMENT_NAME Segment name of a relationship part.
Constructor Summary
PackagingURIHelper()
Method Summary
static java.lang.String | combine(java.lang.String prefix, java.lang.String suffix) Combine a string URI with a prefix and a suffix.
static java.net.URI | combine(java.net.URI prefix, java.net.URI suffix) Combine two URIs.
static PackagePartName | createPartName(java.lang.String partName) Create an OPC compliant part name.
static PackagePartName | createPartName(java.lang.String partName, PackagePart relativePart) Create an OPC compliant part name by resolving it using a base part.
static PackagePartName | createPartName(java.net.URI partUri) Create an OPC compliant part name by throwing an exception if the URI is not valid.
static PackagePartName | createPartName(java.net.URI partName, PackagePart relativePart) Create an OPC compliant part name by resolving it using a base part.
static java.lang.String | decodeURI(java.net.URI uri) Decode a URI by converting all percent encoded character into a String character.
static java.lang.String | encode(java.lang.String s) percent-encode white spaces and characters above 0x80.
static java.lang.String | getFilename(java.net.URI uri) Get file name from the specified URI.
static java.lang.String | getFilenameWithoutExtension(java.net.URI uri) Get the file name without the trailing extension.
static java.net.URI | getPackageRootUri() Gets the URI for the package root.
static java.net.URI | getPath(java.net.URI uri) Get the directory path from the specified URI.
static PackagePartName | getRelationshipPartName(PackagePartName partName) Build a part name where the relationship should be stored ((ex /word/document.xml -> /word/_rels/document.xml.rels)
static java.net.URI | getSourcePartUriFromRelationshipPartUri(java.net.URI relationshipPartUri) Get the source part URI from a specified relationships part.
static java.net.URI | getURIFromPath(java.lang.String path) Get URI from a string path.
static boolean | isRelationshipPartURI(java.net.URI partUri) Know if the specified URI is a relationship part name.
static boolean | isValidPartName(java.net.URI partUri) Validate a part URI by returning a boolean.
static java.net.URI | relativizeURI(java.net.URI sourceURI, java.net.URI targetURI) Fully relativize the source part URI against the target part URI.
static java.net.URI | relativizeURI(java.net.URI sourceURI, java.net.URI targetURI, boolean msCompatible) Fully relativize the source part URI against the target part URI.
static java.net.URI | resolvePartUri(java.net.URI sourcePartUri, java.net.URI targetUri) Resolve a source uri against a target.
static java.net.URI | toURI(java.lang.String value) Convert a string to URI If part name is not a valid URI, it is resolved as follows:
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RELATIONSHIP_PART_EXTENSION_NAME

public static final java.lang.String RELATIONSHIP_PART_EXTENSION_NAME
Extension name of a relationship part.

RELATIONSHIP_PART_SEGMENT_NAME

public static final java.lang.String RELATIONSHIP_PART_SEGMENT_NAME
Segment name of a relationship part.

PACKAGE_PROPERTIES_SEGMENT_NAME

public static final java.lang.String PACKAGE_PROPERTIES_SEGMENT_NAME
Segment name of the package properties folder.

PACKAGE_CORE_PROPERTIES_NAME

public static final java.lang.String PACKAGE_CORE_PROPERTIES_NAME
Core package properties art name.

FORWARD_SLASH_CHAR

public static final char FORWARD_SLASH_CHAR
Forward slash URI separator.

FORWARD_SLASH_STRING

public static final java.lang.String FORWARD_SLASH_STRING
Forward slash URI separator.

PACKAGE_RELATIONSHIPS_ROOT_URI

public static final java.net.URI PACKAGE_RELATIONSHIPS_ROOT_URI
Package relationships part URI

PACKAGE_RELATIONSHIPS_ROOT_PART_NAME

public static final PackagePartName PACKAGE_RELATIONSHIPS_ROOT_PART_NAME
Package relationships part name.

CORE_PROPERTIES_URI

public static final java.net.URI CORE_PROPERTIES_URI
Core properties part URI.

CORE_PROPERTIES_PART_NAME

public static final PackagePartName CORE_PROPERTIES_PART_NAME
Core properties partname.

PACKAGE_ROOT_URI

public static final java.net.URI PACKAGE_ROOT_URI
Root package URI.

PACKAGE_ROOT_PART_NAME

public static final PackagePartName PACKAGE_ROOT_PART_NAME
Root package part name.

Constructor Detail

PackagingURIHelper

public PackagingURIHelper()
Method Detail

getPackageRootUri

public static java.net.URI getPackageRootUri()
Gets the URI for the package root.

Returns:
URI of the package root.

isRelationshipPartURI

public static boolean isRelationshipPartURI(java.net.URI partUri)
Know if the specified URI is a relationship part name.

Parameters:
partUri - URI to check.
Returns:
true if the URI false.

getFilename

public static java.lang.String getFilename(java.net.URI uri)
Get file name from the specified URI.

getFilenameWithoutExtension

public static java.lang.String getFilenameWithoutExtension(java.net.URI uri)
Get the file name without the trailing extension.

getPath

public static java.net.URI getPath(java.net.URI uri)
Get the directory path from the specified URI.

combine

public static java.net.URI combine(java.net.URI prefix,
                                   java.net.URI suffix)
Combine two URIs.

Parameters:
prefix - the prefix URI
suffix - the suffix URI
Returns:
the combined URI

combine

public static java.lang.String combine(java.lang.String prefix,
                                       java.lang.String suffix)
Combine a string URI with a prefix and a suffix.

relativizeURI

public static java.net.URI relativizeURI(java.net.URI sourceURI,
                                         java.net.URI targetURI,
                                         boolean msCompatible)
Fully relativize the source part URI against the target part URI.

Parameters:
sourceURI - The source part URI.
targetURI - The target part URI.
msCompatible - if true then remove leading slash from the relativized URI. This flag violates [M1.4]: A part name shall start with a forward slash ('/') character, but allows generating URIs compatible with MS Office and OpenOffice.
Returns:
A fully relativize part name URI ('word/media/image1.gif', '/word/document.xml' => 'media/image1.gif') else null.

relativizeURI

public static java.net.URI relativizeURI(java.net.URI sourceURI,
                                         java.net.URI targetURI)
Fully relativize the source part URI against the target part URI.

Parameters:
sourceURI - The source part URI.
targetURI - The target part URI.
Returns:
A fully relativize part name URI ('word/media/image1.gif', '/word/document.xml' => 'media/image1.gif') else null.

resolvePartUri

public static java.net.URI resolvePartUri(java.net.URI sourcePartUri,
                                          java.net.URI targetUri)
Resolve a source uri against a target.

Parameters:
sourcePartUri - The source URI.
targetUri - The target URI.
Returns:
The resolved URI.

getURIFromPath

public static java.net.URI getURIFromPath(java.lang.String path)
Get URI from a string path.

getSourcePartUriFromRelationshipPartUri

public static java.net.URI getSourcePartUriFromRelationshipPartUri(java.net.URI relationshipPartUri)
Get the source part URI from a specified relationships part.

Parameters:
relationshipPartUri - The relationship part use to retrieve the source part.
Returns:
The source part URI from the specified relationships part.

createPartName

public static PackagePartName createPartName(java.net.URI partUri)
                                      throws InvalidFormatException
Create an OPC compliant part name by throwing an exception if the URI is not valid.

Parameters:
partUri - The part name URI to validate.
Returns:
A valid part name object, else null.
Throws:
InvalidFormatException - Throws if the specified URI is not OPC compliant.

createPartName

public static PackagePartName createPartName(java.lang.String partName)
                                      throws InvalidFormatException
Create an OPC compliant part name.

Parameters:
partName - The part name to validate.
Returns:
The correspondant part name if valid, else null.
Throws:
InvalidFormatException - Throws if the specified part name is not OPC compliant.
See Also:
createPartName(URI)

createPartName

public static PackagePartName createPartName(java.lang.String partName,
                                             PackagePart relativePart)
                                      throws InvalidFormatException
Create an OPC compliant part name by resolving it using a base part.

Parameters:
partName - The part name to validate.
relativePart - The relative base part.
Returns:
The correspondant part name if valid, else null.
Throws:
InvalidFormatException - Throws if the specified part name is not OPC compliant.
See Also:
createPartName(URI)

createPartName

public static PackagePartName createPartName(java.net.URI partName,
                                             PackagePart relativePart)
                                      throws InvalidFormatException
Create an OPC compliant part name by resolving it using a base part.

Parameters:
partName - The part name URI to validate.
relativePart - The relative base part.
Returns:
The correspondant part name if valid, else null.
Throws:
InvalidFormatException - Throws if the specified part name is not OPC compliant.
See Also:
createPartName(URI)

isValidPartName

public static boolean isValidPartName(java.net.URI partUri)
Validate a part URI by returning a boolean. ([M1.1],[M1.3],[M1.4],[M1.5],[M1.6]) (OPC Specifications 8.1.1 Part names) : Part Name Syntax The part name grammar is defined as follows: part_name = 1*( "/" segment ) segment = 1*( pchar ) (pchar is defined in RFC 3986)

Parameters:
partUri - The URI to validate.
Returns:
true if the URI is valid to the OPC Specifications, else false
See Also:
createPartName(URI)

decodeURI

public static java.lang.String decodeURI(java.net.URI uri)
Decode a URI by converting all percent encoded character into a String character.

Parameters:
uri - The URI to decode.
Returns:
The specified URI in a String with converted percent encoded characters.

getRelationshipPartName

public static PackagePartName getRelationshipPartName(PackagePartName partName)
Build a part name where the relationship should be stored ((ex /word/document.xml -> /word/_rels/document.xml.rels)

Parameters:
partName - Source part URI
Returns:
the full path (as URI) of the relation file
Throws:
InvalidOperationException - Throws if the specified URI is a relationshp part.

toURI

public static java.net.URI toURI(java.lang.String value)
                          throws java.net.URISyntaxException
Convert a string to URI If part name is not a valid URI, it is resolved as follows:

1. Percent-encode each open bracket ([) and close bracket (]). 2. Percent-encode each percent (%) character that is not followed by a hexadecimal notation of an octet value. 3. Un-percent-encode each percent-encoded unreserved character. 4. Un-percent-encode each forward slash (/) and back slash (\). 5. Convert all back slashes to forward slashes. 6. If present in a segment containing non-dot (?.?) characters, remove trailing dot (?.?) characters from each segment. 7. Replace each occurrence of multiple consecutive forward slashes (/) with a single forward slash. 8. If a single trailing forward slash (/) is present, remove that trailing forward slash. 9. Remove complete segments that consist of three or more dots. 10. Resolve the relative reference against the base URI of the part holding the Unicode string, as it is defined in ?5.2 of RFC 3986. The path component of the resulting absolute URI is the part name.

Parameters:
value - the string to be parsed into a URI
Returns:
the resolved part name that should be OK to construct a URI TODO YK: for now this method does only (5). Finish the rest.
Throws:
java.net.URISyntaxException

encode

public static java.lang.String encode(java.lang.String s)
percent-encode white spaces and characters above 0x80.

Examples: 'Apache POI' --> 'Apache%20POI' 'Apache?POI' --> 'Apache%04%10POI'

Parameters:
s - the string to encode
Returns:
the encoded string
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RelationshipSource

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Interface RelationshipSource

All Known Implementing Classes:
DigitalCertificatePart, MemoryPackagePart, OPCPackage, Package, PackageDigitalSignature, PackagePart, PackagePropertiesPart, ZipPackage, ZipPackagePart
public interface RelationshipSource

Method Summary
PackageRelationship | addExternalRelationship(java.lang.String target, java.lang.String relationshipType) Adds an external relationship to a part (except relationships part).
PackageRelationship | addExternalRelationship(java.lang.String target, java.lang.String relationshipType, java.lang.String id) Adds an external relationship to a part (except relationships part).
PackageRelationship | addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
void | clearRelationships() Delete all the relationships attached to this.
PackageRelationship | getRelationship(java.lang.String id) Retrieves a package relationship from its id.
PackageRelationshipCollection | getRelationships() Retrieve all the relationships attached to this.
PackageRelationshipCollection | getRelationshipsByType(java.lang.String relationshipType) Retrieve all relationships attached to this part which have the specified type.
boolean | hasRelationships() Knows if the part have any relationships.
boolean | isRelationshipExists(PackageRelationship rel) Checks if the specified relationship is part of this package part.
void | removeRelationship(java.lang.String id) Delete the relationship specified by its id.

Method Detail

addRelationship

PackageRelationship addRelationship(PackagePartName targetPartName,
                                    TargetMode targetMode,
                                    java.lang.String relationshipType)
Add a relationship to a part (except relationships part).

Parameters:
targetPartName - Name of the target part. This one must be relative to the source root directory of the part.
targetMode - Mode [Internal|External].
relationshipType - Type of relationship.
Returns:
The newly created and added relationship

addRelationship

PackageRelationship addRelationship(PackagePartName targetPartName,
                                    TargetMode targetMode,
                                    java.lang.String relationshipType,
                                    java.lang.String id)
Add a relationship to a part (except relationships part).

Check rule M1.25: The Relationships part shall not have relationships to any other part. Package implementers shall enforce this requirement upon the attempt to create such a relationship and shall treat any such relationship as invalid.

Parameters:
targetPartName - Name of the target part. This one must be relative to the source root directory of the part.
targetMode - Mode [Internal|External].
relationshipType - Type of relationship.
id - Relationship unique id.
Returns:
The newly created and added relationship
Throws:
InvalidFormatException - If the URI point to a relationship part URI.

addExternalRelationship

PackageRelationship addExternalRelationship(java.lang.String target,
                                            java.lang.String relationshipType)
Adds an external relationship to a part (except relationships part). The targets of external relationships are not subject to the same validity checks that internal ones are, as the contents is potentially any file, URL or similar.

Parameters:
target - External target of the relationship
relationshipType - Type of relationship.
Returns:
The newly created and added relationship
See Also:
addExternalRelationship(java.lang.String, java.lang.String)

addExternalRelationship

PackageRelationship addExternalRelationship(java.lang.String target,
                                            java.lang.String relationshipType,
                                            java.lang.String id)
Adds an external relationship to a part (except relationships part). The targets of external relationships are not subject to the same validity checks that internal ones are, as the contents is potentially any file, URL or similar.

Parameters:
target - External target of the relationship
relationshipType - Type of relationship.
id - Relationship unique id.
Returns:
The newly created and added relationship
See Also:
addExternalRelationship(java.lang.String, java.lang.String)

clearRelationships

void clearRelationships()
Delete all the relationships attached to this.

removeRelationship

void removeRelationship(java.lang.String id)
Delete the relationship specified by its id.

Parameters:
id - The ID identified the part to delete.

getRelationships

PackageRelationshipCollection getRelationships()
                                               throws InvalidFormatException,
                                                      OpenXML4JException
Retrieve all the relationships attached to this.

Returns:
This part's relationships.
Throws:
OpenXML4JException
InvalidFormatException

getRelationship

PackageRelationship getRelationship(java.lang.String id)
Retrieves a package relationship from its id.

Parameters:
id - ID of the package relationship to retrieve.
Returns:
The package relationship

getRelationshipsByType

PackageRelationshipCollection getRelationshipsByType(java.lang.String relationshipType)
                                                     throws InvalidFormatException,
                                                            java.lang.IllegalArgumentException,
                                                            OpenXML4JException
Retrieve all relationships attached to this part which have the specified type.

Parameters:
relationshipType - Relationship type filter.
Returns:
All relationships from this part that have the specified type.
Throws:
InvalidFormatException - If an error occurs while parsing the part.
InvalidOperationException - If the package is open in write only mode.
java.lang.IllegalArgumentException
OpenXML4JException

hasRelationships

boolean hasRelationships()
Knows if the part have any relationships.

Returns:
true if the part have at least one relationship else false.

isRelationshipExists

boolean isRelationshipExists(PackageRelationship rel)
Checks if the specified relationship is part of this package part.

Parameters:
rel - The relationship to check.
Returns:
true if the specified relationship exists in this part, else returns false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StreamHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class StreamHelper

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.StreamHelper

public final class StreamHelper
extends java.lang.Object

Method Summary
static boolean | copyStream(java.io.InputStream inStream, java.io.OutputStream outStream) Copy the input stream into the output stream.
static boolean | saveXmlInStream(org.dom4j.Document xmlContent, java.io.OutputStream outStream) Turning the DOM4j object in the specified output stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

saveXmlInStream

public static boolean saveXmlInStream(org.dom4j.Document xmlContent,
                                      java.io.OutputStream outStream)
Turning the DOM4j object in the specified output stream.

Parameters:
xmlContent - The XML document.
outStream - The OutputStream in which the XML document will be written.
Returns:
true if the xml is successfully written in the stream, else false.

copyStream

public static boolean copyStream(java.io.InputStream inStream,
                                 java.io.OutputStream outStream)
Copy the input stream into the output stream.

Parameters:
inStream - The source stream.
outStream - The destination stream.
Returns:
true if the operation succeed, else return false.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TargetMode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.openxml4j.opc
Enum TargetMode

java.lang.Object
    extended by  java.lang.Enum<TargetMode>
        extended by  org.apache.poi.openxml4j.opc.TargetMode
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<TargetMode>
public enum TargetMode
extends java.lang.Enum<TargetMode>

Specifies whether the target of a PackageRelationship is inside or outside a Package.

Version:
1.0
Author:
Julien Chable

Enum Constant Summary
EXTERNAL
The relationship references a part that is inside the package.
INTERNAL
The relationship references a resource that is external to the package.
Method Summary
static TargetMode | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TargetMode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

INTERNAL

public static final TargetMode INTERNAL
The relationship references a resource that is external to the package.

EXTERNAL

public static final TargetMode EXTERNAL
The relationship references a part that is inside the package.

Method Detail

values

public static TargetMode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (TargetMode c : TargetMode.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TargetMode valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ZipPackage

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class ZipPackage

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.OPCPackage
        extended by  org.apache.poi.openxml4j.opc.Package
            extended by  org.apache.poi.openxml4j.opc.ZipPackage
All Implemented Interfaces:
java.io.Closeable, RelationshipSource
public final class ZipPackage
extends Package

Physical zip package.

Author:
Julien Chable

Field Summary
Fields inherited from class org.apache.poi.openxml4j.opc.OPCPackage
contentTypeManager, defaultPackageAccess, defaultPartMarshaller, isDirty, originalPackagePath, output, packageProperties, partList, partMarshallers, partUnmarshallers, relationships
Constructor Summary
ZipPackage()
Constructor.
Method Summary
protected void | closeImpl() Close and save the package.
protected PackagePart | createPartImpl(PackagePartName partName, java.lang.String contentType, boolean loadRelationships) Create a new MemoryPackagePart from the specified URI and content type aram partName The part URI.
protected void | flushImpl() Flush the package.
protected PackagePart | getPartImpl(PackagePartName partName) Implement the getPart() method to retrieve a part from its URI in the current package
protected PackagePart[] | getPartsImpl() Retrieves the parts from this package.
ZipEntrySource | getZipArchive() Get the zip archive
protected void | removePartImpl(PackagePartName partName) Delete a part from the package
protected void | revertImpl() Close the package without saving the document.
void | saveImpl(java.io.OutputStream outputStream) Save this package into the specified stream
Methods inherited from class org.apache.poi.openxml4j.opc.Package
create, create, create, open, open, open, openOrCreate
Methods inherited from class org.apache.poi.openxml4j.opc.OPCPackage
addExternalRelationship, addExternalRelationship, addMarshaller, addPackagePart, addRelationship, addRelationship, addThumbnail, addUnmarshaller, clearRelationships, close, containPart, createPart, createPart, deletePart, deletePartRecursive, ensureRelationships, flush, getPackageAccess, getPackageProperties, getPart, getPart, getParts, getPartsByContentType, getPartsByName, getPartsByRelationshipType, getRelationship, getRelationships, getRelationshipsByType, hasRelationships, isRelationshipExists, removeMarshaller, removePart, removePart, removePartRecursive, removeRelationship, removeUnmarshaller, replaceContentType, revert, save, save, validatePackage
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZipPackage

public ZipPackage()
Constructor. Creates a new ZipPackage.

Method Detail

getPartsImpl

protected PackagePart[] getPartsImpl()
                              throws InvalidFormatException
Retrieves the parts from this package. We assume that the package has not been yet inspect to retrieve all the parts, this method will open the archive and look for all parts contain inside it. If the package part list is not empty, it will be emptied.

Specified by:
getPartsImpl in class OPCPackage
Returns:
All parts contain in this package.
Throws:
InvalidFormatException - Throws if the package is not valid.

createPartImpl

protected PackagePart createPartImpl(PackagePartName partName,
                                     java.lang.String contentType,
                                     boolean loadRelationships)
Create a new MemoryPackagePart from the specified URI and content type aram partName The part URI.

Specified by:
createPartImpl in class OPCPackage
Parameters:
contentType - The part content type.
partName - URI of the part to create.
Returns:
The newly created zip package part, else null.

removePartImpl

protected void removePartImpl(PackagePartName partName)
Delete a part from the package

Specified by:
removePartImpl in class OPCPackage
Parameters:
partName - The URI of the part to delete.
Throws:
java.lang.IllegalArgumentException - Throws if the part URI is nulll or invalid.

flushImpl

protected void flushImpl()
Flush the package. Do nothing.

Specified by:
flushImpl in class OPCPackage

closeImpl

protected void closeImpl()
                  throws java.io.IOException
Close and save the package.

Specified by:
closeImpl in class OPCPackage
Throws:
java.io.IOException
See Also:
OPCPackage.close()

revertImpl

protected void revertImpl()
Close the package without saving the document. Discard all the changes made to this package.

Specified by:
revertImpl in class OPCPackage

getPartImpl

protected PackagePart getPartImpl(PackagePartName partName)
Implement the getPart() method to retrieve a part from its URI in the current package

Specified by:
getPartImpl in class OPCPackage
Parameters:
partName - The URI of the part to retrieve.
Returns:
The package part located by the specified URI, else null.
See Also:
OPCPackage.getPart(PackageRelationship)

saveImpl

public void saveImpl(java.io.OutputStream outputStream)
Save this package into the specified stream

Specified by:
saveImpl in class OPCPackage
Parameters:
outputStream - The stream use to save this package.
See Also:
OPCPackage.save(OutputStream)

getZipArchive

public ZipEntrySource getZipArchive()
Get the zip archive

Returns:
The zip archive.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipPackagePart

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc
Class ZipPackagePart

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagePart
        extended by  org.apache.poi.openxml4j.opc.ZipPackagePart
All Implemented Interfaces:
RelationshipSource
public class ZipPackagePart
extends PackagePart

Zip implementation of a PackagePart.

Version:
1.0
Author:
Julien Chable
See Also:
PackagePart

Field Summary
Fields inherited from class org.apache.poi.openxml4j.opc.PackagePart
_container, _contentType, _partName
Constructor Summary
ZipPackagePart(OPCPackage container, PackagePartName partName, java.lang.String contentType)
Constructor.
ZipPackagePart(OPCPackage container, java.util.zip.ZipEntry zipEntry, PackagePartName partName, java.lang.String contentType)
Constructor.
Method Summary
 void close()
Close this part : flush this part, close the input stream and output stream.
 void flush()
Flush the content of this part.
protected  java.io.InputStream getInputStreamImpl()
Implementation of the getInputStream() which return the inputStream of this part zip entry.
protected  java.io.OutputStream getOutputStreamImpl()
Implementation of the getOutputStream().
 java.util.zip.ZipEntry getZipArchive()
Get the zip entry of this part.
 boolean load(java.io.InputStream ios)
Load the content of this part.
 boolean save(java.io.OutputStream os)
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.
Methods inherited from class org.apache.poi.openxml4j.opc.PackagePart
addExternalRelationship, addExternalRelationship, addRelationship, addRelationship, addRelationship, addRelationship, clearRelationships, getContentType, getInputStream, getOutputStream, getPackage, getPartName, getRelatedPart, getRelationship, getRelationships, getRelationshipsByType, hasRelationships, isDeleted, isRelationshipExists, isRelationshipPart, removeRelationship, setContentType, setDeleted, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ZipPackagePart

public ZipPackagePart(OPCPackage container,
                      PackagePartName partName,
                      java.lang.String contentType)
               throws InvalidFormatException
Constructor.

Parameters:
container - The container package.
partName - Part name.
contentType - Content type.
Throws:
InvalidFormatException - Throws if the content of this part invalid.

ZipPackagePart

public ZipPackagePart(OPCPackage container,
                      java.util.zip.ZipEntry zipEntry,
                      PackagePartName partName,
                      java.lang.String contentType)
               throws InvalidFormatException
Constructor.

Parameters:
container - The container package.
zipEntry - The zip entry corresponding to this part.
partName - The part name.
contentType - Content type.
Throws:
InvalidFormatException - Throws if the content of this part is invalid.
Method Detail

getZipArchive

public java.util.zip.ZipEntry getZipArchive()
Get the zip entry of this part.

Returns:
The zip entry in the zip structure coresponding to this part.

getInputStreamImpl

protected java.io.InputStream getInputStreamImpl()
                                          throws java.io.IOException
Implementation of the getInputStream() which return the inputStream of this part zip entry.

Specified by:
getInputStreamImpl in class PackagePart
Returns:
Input stream of this part zip entry.
Throws:
java.io.IOException - Throws if an IO Exception occur in the implementation method.

getOutputStreamImpl

protected java.io.OutputStream getOutputStreamImpl()
Implementation of the getOutputStream(). Return null. Normally will never be called since the MemoryPackage is use instead.

Specified by:
getOutputStreamImpl in class PackagePart
Returns:
null

save

public boolean save(java.io.OutputStream os)
             throws OpenXML4JException
Description copied from class: PackagePart
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.

Specified by:
save in class PackagePart
Parameters:
os - Output stream to save this part.
Throws:
OpenXML4JException - If any exception occur.

load

public boolean load(java.io.InputStream ios)
Description copied from class: PackagePart
Load the content of this part.

Specified by:
load in class PackagePart
Parameters:
ios - The input stream of the content to load.
Returns:
true if the content has been successfully loaded, else false.

close

public void close()
Description copied from class: PackagePart
Close this part : flush this part, close the input stream and output stream. After this method call, the part must be available for packaging.

Specified by:
close in class PackagePart

flush

public void flush()
Description copied from class: PackagePart
Flush the content of this part. If the input stream and/or output stream as in a waiting state to read or write, the must to empty their respective buffer.

Specified by:
flush in class PackagePart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.openxml4j.opc.CertificateEmbeddingOption

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.CertificateEmbeddingOption

Packages that use CertificateEmbeddingOption
org.apache.poi.openxml4j.opc

Uses of CertificateEmbeddingOption in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return CertificateEmbeddingOption
static CertificateEmbeddingOption | CertificateEmbeddingOption.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CertificateEmbeddingOption[] | CertificateEmbeddingOption.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.CompressionOption

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.CompressionOption

Packages that use CompressionOption
org.apache.poi.openxml4j.opc

Uses of CompressionOption in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return CompressionOption
static CompressionOption | CompressionOption.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CompressionOption[] | CompressionOption.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.Configuration

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.Configuration

No usage of org.apache.poi.openxml4j.opc.Configuration

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.ContentTypes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.ContentTypes

No usage of org.apache.poi.openxml4j.opc.ContentTypes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.EncryptionOption

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.EncryptionOption

Packages that use EncryptionOption
org.apache.poi.openxml4j.opc

Uses of EncryptionOption in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return EncryptionOption
static EncryptionOption | EncryptionOption.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static EncryptionOption[] | EncryptionOption.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.OPCPackage

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.OPCPackage

Packages that use OPCPackage
org.apache.poi |
org.apache.poi.dev |
org.apache.poi.extractor |
org.apache.poi.openxml4j.opc |
org.apache.poi.openxml4j.opc.internal |
org.apache.poi.openxml4j.opc.internal.unmarshallers |
org.apache.poi.ss.usermodel |
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.
org.apache.poi.xslf |
org.apache.poi.xslf.extractor |
org.apache.poi.xslf.usermodel |
org.apache.poi.xssf.eventusermodel |
org.apache.poi.xssf.extractor |
org.apache.poi.xssf.usermodel |
org.apache.poi.xwpf.extractor |
org.apache.poi.xwpf.usermodel |

Uses of OPCPackage in org.apache.poi

Methods in org.apache.poi that return OPCPackage
OPCPackage | POIXMLTextExtractor.getPackage() Returns the opened OPCPackage that contains the document
OPCPackage | POIXMLDocument.getPackage()
static OPCPackage | POIXMLDocument.openPackage(java.lang.String path) Wrapper to open a package, returning an IOException in the event of a problem.

Methods in org.apache.poi with parameters of type OPCPackage
protected  void POIXMLDocumentPart.rebase(OPCPackage pkg)
When you open something like a theme, call this to re-base the XML Document onto the core child of the current core document

Constructors in org.apache.poi with parameters of type OPCPackage
POIXMLDocument(OPCPackage pkg)
POIXMLDocumentPart(OPCPackage pkg)
Construct POIXMLDocumentPart representing a "core document" package part.
POIXMLProperties(OPCPackage docPackage)

Uses of OPCPackage in org.apache.poi.dev

Constructors in org.apache.poi.dev with parameters of type OPCPackage
OOXMLLister(OPCPackage container)
OOXMLLister(OPCPackage container, java.io.PrintStream disp)

Uses of OPCPackage in org.apache.poi.extractor

Methods in org.apache.poi.extractor with parameters of type OPCPackage
static POIXMLTextExtractor ExtractorFactory.createExtractor(OPCPackage pkg)

Uses of OPCPackage in org.apache.poi.openxml4j.opc

Subclasses of OPCPackage in org.apache.poi.openxml4j.opc
class | Package Deprecated. (name clash with Package use OPCPackage instead.
class | ZipPackage Physical zip package.

Fields in org.apache.poi.openxml4j.opc declared as OPCPackage
protected  OPCPackage PackagePart._container
This part's container.

Methods in org.apache.poi.openxml4j.opc that return OPCPackage
static OPCPackage | OPCPackage.create(java.io.File file) Creates a new package.
static OPCPackage | OPCPackage.create(java.io.OutputStream output)
static OPCPackage | OPCPackage.create(java.lang.String path) Creates a new package.
OPCPackage | PackageRelationship.getPackage()
OPCPackage | PackagePart.getPackage()
static OPCPackage | OPCPackage.open(java.io.InputStream in) Open a package.
static OPCPackage | OPCPackage.open(java.lang.String path) Open a package with read/write permission.
static OPCPackage | OPCPackage.open(java.lang.String path, PackageAccess access) Open a package.
static OPCPackage | OPCPackage.openOrCreate(java.io.File file) Opens a package if it exists, else it creates one.

Methods in org.apache.poi.openxml4j.opc with parameters of type OPCPackage
 boolean OPCPackage.validatePackage(OPCPackage pkg)
Validates the package compliance with the OPC specifications.

Constructors in org.apache.poi.openxml4j.opc with parameters of type OPCPackage
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType)
Constructor.
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType, boolean loadRelationships)
Constructor.
PackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType)
Constructor.
PackageRelationship(OPCPackage pkg, PackagePart sourcePart, java.net.URI targetUri, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id)
Constructor.
PackageRelationshipCollection(OPCPackage container)
Constructor.
PackageRelationshipCollection(OPCPackage container, PackagePart part)
Constructor.
ZipPackagePart(OPCPackage container, PackagePartName partName, java.lang.String contentType)
Constructor.
ZipPackagePart(OPCPackage container, java.util.zip.ZipEntry zipEntry, PackagePartName partName, java.lang.String contentType)
Constructor.

Uses of OPCPackage in org.apache.poi.openxml4j.opc.internal

Fields in org.apache.poi.openxml4j.opc.internal declared as OPCPackage
protected  OPCPackage ContentTypeManager.container
Reference to the package using this content type manager.

Constructors in org.apache.poi.openxml4j.opc.internal with parameters of type OPCPackage
ContentTypeManager(java.io.InputStream in, OPCPackage pkg)
Constructor.
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType)
Constructor.
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Constructor.
PackagePropertiesPart(OPCPackage pack, PackagePartName partName)
Constructor.
ZipContentTypeManager(java.io.InputStream in, OPCPackage pkg)
Delegate constructor to the super constructor.

Uses of OPCPackage in org.apache.poi.openxml4j.opc.internal.unmarshallers

Methods in org.apache.poi.openxml4j.opc.internal.unmarshallers with parameters of type OPCPackage
 void UnmarshallContext.setPackage(OPCPackage container)

Constructors in org.apache.poi.openxml4j.opc.internal.unmarshallers with parameters of type OPCPackage
UnmarshallContext(OPCPackage targetPackage, PackagePartName partName)
Constructor.

Uses of OPCPackage in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel with parameters of type OPCPackage
static Workbook WorkbookFactory.create(OPCPackage pkg)
Creates an XSSFWorkbook from the given OOXML Package

Uses of OPCPackage in org.apache.poi.util

Methods in org.apache.poi.util that return OPCPackage
static OPCPackage | PackageHelper.clone(OPCPackage pkg, java.io.File file) Clone the specified package.
static OPCPackage | PackageHelper.open(java.io.InputStream is)

Methods in org.apache.poi.util with parameters of type OPCPackage
static OPCPackage PackageHelper.clone(OPCPackage pkg, java.io.File file)
Clone the specified package.

Uses of OPCPackage in org.apache.poi.xslf

Constructors in org.apache.poi.xslf with parameters of type OPCPackage
XSLFSlideShow(OPCPackage container)

Uses of OPCPackage in org.apache.poi.xslf.extractor

Constructors in org.apache.poi.xslf.extractor with parameters of type OPCPackage
XSLFPowerPointExtractor(OPCPackage container)

Uses of OPCPackage in org.apache.poi.xslf.usermodel

Constructors in org.apache.poi.xslf.usermodel with parameters of type OPCPackage
XMLSlideShow(OPCPackage pkg)

Uses of OPCPackage in org.apache.poi.xssf.eventusermodel

Constructors in org.apache.poi.xssf.eventusermodel with parameters of type OPCPackage
ReadOnlySharedStringsTable(OPCPackage pkg)
XSSFReader(OPCPackage pkg)
Creates a new XSSFReader, for the given package

Uses of OPCPackage in org.apache.poi.xssf.extractor

Methods in org.apache.poi.xssf.extractor that return OPCPackage
 OPCPackage XSSFEventBasedExcelExtractor.getPackage()
Returns the opened OPCPackage container.

Constructors in org.apache.poi.xssf.extractor with parameters of type OPCPackage
XSSFEventBasedExcelExtractor(OPCPackage container)
XSSFExcelExtractor(OPCPackage container)

Uses of OPCPackage in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return OPCPackage
protected static OPCPackage XSSFWorkbook.newPackage()
Create a new SpreadsheetML package and setup the default minimal content

Constructors in org.apache.poi.xssf.usermodel with parameters of type OPCPackage
XSSFWorkbook(OPCPackage pkg)
Constructs a XSSFWorkbook object given a OpenXML4J Package object, see www.openxml4j.org.

Uses of OPCPackage in org.apache.poi.xwpf.extractor

Constructors in org.apache.poi.xwpf.extractor with parameters of type OPCPackage
XWPFWordExtractor(OPCPackage container)

Uses of OPCPackage in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return OPCPackage
protected static OPCPackage XWPFDocument.newPackage()
Create a new WordProcessingML package and setup the default minimal content

Constructors in org.apache.poi.xwpf.usermodel with parameters of type OPCPackage
XWPFDocument(OPCPackage pkg)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.Package

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.Package

Packages that use Package
org.apache.poi.openxml4j.opc

Uses of Package in org.apache.poi.openxml4j.opc

Subclasses of Package in org.apache.poi.openxml4j.opc
 class ZipPackage
Physical zip package.

Methods in org.apache.poi.openxml4j.opc that return Package
static Package Package.create(java.io.File file)
Deprecated. use OPCPackage.create(File)
static Package Package.create(java.io.OutputStream output)
Deprecated. use OPCPackage.create(OutputStream)
static Package Package.create(java.lang.String path)
Deprecated. use OPCPackage.create(String)
static Package Package.open(java.io.InputStream in)
Deprecated. use OPCPackage.open(InputStream)
static Package Package.open(java.lang.String path)
Deprecated. use OPCPackage.open(String)
static Package Package.open(java.lang.String path, PackageAccess access)
Deprecated. use OPCPackage.open(String,PackageAccess)
static Package Package.openOrCreate(java.io.File file)
Deprecated. use OPCPackage.openOrCreate(java.io.File)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.PackageAccess

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.PackageAccess

Packages that use PackageAccess
org.apache.poi.openxml4j.opc

Uses of PackageAccess in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as PackageAccess
protected static PackageAccess OPCPackage.defaultPackageAccess
Default package access.

Methods in org.apache.poi.openxml4j.opc that return PackageAccess
PackageAccess | OPCPackage.getPackageAccess() Get the package access mode.
static PackageAccess | PackageAccess.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PackageAccess[] | PackageAccess.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.openxml4j.opc with parameters of type PackageAccess
static Package Package.open(java.lang.String path, PackageAccess access)
Deprecated. use OPCPackage.open(String,PackageAccess)
static OPCPackage OPCPackage.open(java.lang.String path, PackageAccess access)
Open a package.

Constructors in org.apache.poi.openxml4j.opc with parameters of type PackageAccess
Package(PackageAccess access)
Deprecated. use OPCPackage

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.openxml4j.opc.PackageNamespaces

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.openxml4j.opc.PackageNamespaces

No usage of org.apache.poi.openxml4j.opc.PackageNamespaces

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.PackagePart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.PackagePart

Packages that use PackagePart
org.apache.poi
org.apache.poi.dev
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.marshallers
org.apache.poi.openxml4j.opc.internal.signature
org.apache.poi.openxml4j.opc.internal.unmarshallers
org.apache.poi.openxml4j.opc.signature
org.apache.poi.xslf
org.apache.poi.xslf.usermodel
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel
org.apache.poi.xwpf.usermodel

Uses of PackagePart in org.apache.poi

Methods in org.apache.poi that return PackagePart
protected PackagePart | POIXMLDocument.getCorePart()
PackagePart | POIXMLDocumentPart.getPackagePart() Provides access to the underlying PackagePart
protected PackagePart[] | POIXMLDocument.getRelatedByType(java.lang.String contentType) Retrieves all the PackageParts which are defined as relationships of the base document with the specified content type.
protected PackagePart | POIXMLDocumentPart.getTargetPart(PackageRelationship rel) Get the PackagePart that is the target of a relationship from this Part.

Methods in org.apache.poi that return types with arguments of type PackagePart
abstract  java.util.List<PackagePart> POIXMLDocument.getAllEmbedds()
Get the document's embedded files.

Methods in org.apache.poi with parameters of type PackagePart
abstract  POIXMLDocumentPart POIXMLFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
Create a POIXMLDocumentPart from existing package part and relation.

Method parameters in org.apache.poi with type arguments of type PackagePart
protected void | POIXMLDocumentPart.onSave(java.util.Set<PackagePart> alreadySaved) Save changes in the underlying OOXML package.
protected void | POIXMLDocumentPart.read(POIXMLFactory factory, java.util.Map<PackagePart,POIXMLDocumentPart> context) Iterate through the underlying PackagePart and create child POIXMLFactory instances using the specified factory

Constructors in org.apache.poi with parameters of type PackagePart
POIXMLDocumentPart(PackagePart part, PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part and relationship.
POIXMLDocumentPart(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part, relationship and parent Called by POIXMLDocumentPart.read(POIXMLFactory, java.util.Map) when reading in an exisiting file.

Uses of PackagePart in org.apache.poi.dev

Methods in org.apache.poi.dev with parameters of type PackagePart
static long OOXMLLister.getSize(PackagePart part)
Figures out how big a given PackagePart is.

Uses of PackagePart in org.apache.poi.openxml4j.opc

Subclasses of PackagePart in org.apache.poi.openxml4j.opc
 class ZipPackagePart
Zip implementation of a PackagePart.

Methods in org.apache.poi.openxml4j.opc that return PackagePart
protected  PackagePart OPCPackage.addPackagePart(PackagePart part)
Add the specified part to the package.
 PackagePart OPCPackage.createPart(PackagePartName partName, java.lang.String contentType)
Create and add a part, with the specified name and content type, to the package.
 PackagePart OPCPackage.createPart(PackagePartName partName, java.lang.String contentType, java.io.ByteArrayOutputStream content)
Add a part to the package.
protected  PackagePart ZipPackage.createPartImpl(PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Create a new MemoryPackagePart from the specified URI and content type aram partName The part URI.
protected abstract  PackagePart OPCPackage.createPartImpl(PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Core method to create a package part.
 PackagePart OPCPackage.getPart(PackagePartName partName)
Retrieve a part identified by its name.
 PackagePart OPCPackage.getPart(PackageRelationship partRel)
Get the target part from the specified relationship.
protected  PackagePart ZipPackage.getPartImpl(PackagePartName partName)
Implement the getPart() method to retrieve a part from its URI in the current package
protected abstract  PackagePart OPCPackage.getPartImpl(PackagePartName partName)
Get the package part mapped to the specified URI.
protected  PackagePart[] ZipPackage.getPartsImpl()
Retrieves the parts from this package.
protected abstract  PackagePart[] OPCPackage.getPartsImpl()
Get all parts link to the package.
 PackagePart PackagePart.getRelatedPart(PackageRelationship rel)
Get the PackagePart that is the target of a relationship.
 PackagePart PackageRelationship.getSource()
 PackagePart PackagePartCollection.put(PackagePartName partName, PackagePart part)
Check rule [M1.11]: a package implementer shall neither create nor recognize a part with a part name derived from another part name by appending segments to it.
 PackagePart PackagePartCollection.remove(java.lang.Object key)

Methods in org.apache.poi.openxml4j.opc that return types with arguments of type PackagePart
java.util.ArrayList<PackagePart> | OPCPackage.getParts() Load the parts of the archive if it has not been done yet.
java.util.ArrayList<PackagePart> | OPCPackage.getPartsByContentType(java.lang.String contentType) Retrieve parts by content type.
java.util.List<PackagePart> | OPCPackage.getPartsByName(java.util.regex.Pattern namePattern)
java.util.ArrayList<PackagePart> | OPCPackage.getPartsByRelationshipType(java.lang.String relationshipType) Retrieve parts by relationship type.

Methods in org.apache.poi.openxml4j.opc with parameters of type PackagePart
protected PackagePart | OPCPackage.addPackagePart(PackagePart part) Add the specified part to the package.
static PackagePartName | PackagingURIHelper.createPartName(java.lang.String partName, PackagePart relativePart) Create an OPC compliant part name by resolving it using a base part.
static PackagePartName | PackagingURIHelper.createPartName(java.net.URI partName, PackagePart relativePart) Create an OPC compliant part name by resolving it using a base part.
PackagePart | PackagePartCollection.put(PackagePartName partName, PackagePart part) Check rule [M1.11]: a package implementer shall neither create nor recognize a part with a part name derived from another part name by appending segments to it.
void | OPCPackage.removePart(PackagePart part) Remove the specified part in this package.

Constructors in org.apache.poi.openxml4j.opc with parameters of type PackagePart
PackageRelationship(OPCPackage pkg, PackagePart sourcePart, java.net.URI targetUri, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id)
Constructor.
PackageRelationshipCollection(OPCPackage container, PackagePart part)
Constructor.
PackageRelationshipCollection(PackagePart part)
Constructor.

Uses of PackagePart in org.apache.poi.openxml4j.opc.internal

Subclasses of PackagePart in org.apache.poi.openxml4j.opc.internal
class | MemoryPackagePart Memory version of a package part.
class | PackagePropertiesPart Represents the core properties part of a package.

Methods in org.apache.poi.openxml4j.opc.internal that return PackagePart
 PackagePart PartUnmarshaller.unmarshall(UnmarshallContext context, java.io.InputStream in)
Save the content of the package in the stream

Methods in org.apache.poi.openxml4j.opc.internal with parameters of type PackagePart
 boolean PartMarshaller.marshall(PackagePart part, java.io.OutputStream out)
Save the content of the package in the stream

Uses of PackagePart in org.apache.poi.openxml4j.opc.internal.marshallers

Methods in org.apache.poi.openxml4j.opc.internal.marshallers with parameters of type PackagePart
 boolean ZipPartMarshaller.marshall(PackagePart part, java.io.OutputStream os)
Save the specified part.
 boolean ZipPackagePropertiesMarshaller.marshall(PackagePart part, java.io.OutputStream out)
 boolean PackagePropertiesMarshaller.marshall(PackagePart part, java.io.OutputStream out)
Marshall package core properties to an XML document.
 boolean DefaultMarshaller.marshall(PackagePart part, java.io.OutputStream out)
Save part in the output stream by using the save() method of the part.

Uses of PackagePart in org.apache.poi.openxml4j.opc.internal.signature

Subclasses of PackagePart in org.apache.poi.openxml4j.opc.internal.signature
 class DigitalCertificatePart
Digital certificate part.

Uses of PackagePart in org.apache.poi.openxml4j.opc.internal.unmarshallers

Methods in org.apache.poi.openxml4j.opc.internal.unmarshallers that return PackagePart
 PackagePart PackagePropertiesUnmarshaller.unmarshall(UnmarshallContext context, java.io.InputStream in)

Uses of PackagePart in org.apache.poi.openxml4j.opc.signature

Subclasses of PackagePart in org.apache.poi.openxml4j.opc.signature
 class PackageDigitalSignature

Uses of PackagePart in org.apache.poi.xslf

Methods in org.apache.poi.xslf that return PackagePart
PackagePart | XSLFSlideShow.getNodesPart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry parentSlide) Gets the PackagePart of the notes for the given slide, or null if there isn't one.
PackagePart | XSLFSlideShow.getSlideMasterPart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdListEntry master)
PackagePart | XSLFSlideShow.getSlidePart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide)

Methods in org.apache.poi.xslf that return types with arguments of type PackagePart
 java.util.List<PackagePart> XSLFSlideShow.getAllEmbedds()
Get the document's embedded files.

Uses of PackagePart in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type PackagePart
 java.util.List<PackagePart> XMLSlideShow.getAllEmbedds()
Get the document's embedded files.

Methods in org.apache.poi.xslf.usermodel with parameters of type PackagePart
POIXMLDocumentPart | XSLFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
java.awt.image.BufferedImage | XSLFImageRenderer.readImage(PackagePart packagePart) Create a buffered image from the supplied package part.

Constructors in org.apache.poi.xslf.usermodel with parameters of type PackagePart
XSLFNotesMaster(PackagePart part, PackageRelationship rel)
XSLFPictureData(PackagePart part, PackageRelationship rel)
Construct XSLFPictureData from a package part
XSLFSheet(PackagePart part, PackageRelationship rel)
XSLFSlideLayout(PackagePart part, PackageRelationship rel)
XSLFSlideMaster(PackagePart part, PackageRelationship rel)
XSLFTableStyles(PackagePart part, PackageRelationship rel)
XSLFTheme(PackagePart part, PackageRelationship rel)

Uses of PackagePart in org.apache.poi.xssf.eventusermodel

Methods in org.apache.poi.xssf.eventusermodel that return PackagePart
 PackagePart XSSFReader.SheetIterator.getSheetPart()

Constructors in org.apache.poi.xssf.eventusermodel with parameters of type PackagePart
ReadOnlySharedStringsTable(PackagePart part, PackageRelationship rel_ignored)
Like POIXMLDocumentPart constructor

Uses of PackagePart in org.apache.poi.xssf.model

Constructors in org.apache.poi.xssf.model with parameters of type PackagePart
CalculationChain(PackagePart part, PackageRelationship rel)
CommentsTable(PackagePart part, PackageRelationship rel)
MapInfo(PackagePart part, PackageRelationship rel)
SharedStringsTable(PackagePart part, PackageRelationship rel)
SingleXmlCells(PackagePart part, PackageRelationship rel)
StylesTable(PackagePart part, PackageRelationship rel)
ThemesTable(PackagePart part, PackageRelationship rel)

Uses of PackagePart in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type PackagePart
 java.util.List<PackagePart> XSSFWorkbook.getAllEmbedds()
Get the document's embedded files.

Methods in org.apache.poi.xssf.usermodel with parameters of type PackagePart
POIXMLDocumentPart | XSSFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
protected void | XSSFHyperlink.generateRelationIfNeeded(PackagePart sheetPart) Generates the relation if required
java.io.InputStream | XSSFRelation.getContents(PackagePart corePart) Fetches the InputStream to read the contents, based of the specified core part, for which we are defined as a suitable relationship
protected static java.awt.Dimension | XSSFPicture.getImageDimension(PackagePart part, int type) Return the dimension of this image

Constructors in org.apache.poi.xssf.usermodel with parameters of type PackagePart
XSSFChart(PackagePart part, PackageRelationship rel)
Construct a SpreadsheetML chart from a package part.
XSSFChartSheet(PackagePart part, PackageRelationship rel)
XSSFDrawing(PackagePart part, PackageRelationship rel)
Construct a SpreadsheetML drawing from a package part
XSSFPictureData(PackagePart part, PackageRelationship rel)
Construct XSSFPictureData from a package part
XSSFSheet(PackagePart part, PackageRelationship rel)
Creates an XSSFSheet representing the given package part and relationship.
XSSFTable(PackagePart part, PackageRelationship rel)
XSSFVMLDrawing(PackagePart part, PackageRelationship rel)
Construct a SpreadsheetML drawing from a package part

Uses of PackagePart in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return PackagePart
 PackagePart XWPFDocument.getPartById(java.lang.String id)
Get the document part that's defined as the given relationship of the core document.

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type PackagePart
 java.util.List<PackagePart> XWPFDocument.getAllEmbedds()
Get the document's embedded files.

Methods in org.apache.poi.xwpf.usermodel with parameters of type PackagePart
 POIXMLDocumentPart XWPFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)

Constructors in org.apache.poi.xwpf.usermodel with parameters of type PackagePart
XWPFFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFFootnotes(PackagePart part, PackageRelationship rel)
Construct XWPFFootnotes from a package part
XWPFHeader(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFHeaderFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFNumbering(PackagePart part, PackageRelationship rel)
create a new styles object with an existing document
XWPFPictureData(PackagePart part, PackageRelationship rel)
Construct XWPFPictureData from a package part
XWPFSettings(PackagePart part, PackageRelationship rel)
XWPFStyles(PackagePart part, PackageRelationship rel)
Construct XWPFStyles from a package part

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.PackagePartCollection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.PackagePartCollection

Packages that use PackagePartCollection
org.apache.poi.openxml4j.opc

Uses of PackagePartCollection in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as PackagePartCollection
protected  PackagePartCollection OPCPackage.partList
Package parts collection.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.PackagePartName

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.PackagePartName

Packages that use PackagePartName
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.marshallers
org.apache.poi.openxml4j.opc.internal.unmarshallers

Uses of PackagePartName in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as PackagePartName
protected PackagePartName | PackagePart._partName The part name.
static PackagePartName | PackagingURIHelper.CORE_PROPERTIES_PART_NAME Core properties partname.
static PackagePartName | PackagingURIHelper.PACKAGE_RELATIONSHIPS_ROOT_PART_NAME Package relationships part name.
static PackagePartName | PackagingURIHelper.PACKAGE_ROOT_PART_NAME Root package part name.

Methods in org.apache.poi.openxml4j.opc that return PackagePartName
static PackagePartName | PackagingURIHelper.createPartName(java.lang.String partName) Create an OPC compliant part name.
static PackagePartName | PackagingURIHelper.createPartName(java.lang.String partName, PackagePart relativePart) Create an OPC compliant part name by resolving it using a base part.
static PackagePartName | PackagingURIHelper.createPartName(java.net.URI partUri) Create an OPC compliant part name by throwing an exception if the URI is not valid.
static PackagePartName | PackagingURIHelper.createPartName(java.net.URI partName, PackagePart relativePart) Create an OPC compliant part name by resolving it using a base part.
PackagePartName | PackagePart.getPartName()
static PackagePartName | PackagingURIHelper.getRelationshipPartName(PackagePartName partName) Build a part name where the relationship should be stored ((ex /word/document.xml -> /word/_rels/document.xml.rels)

Methods in org.apache.poi.openxml4j.opc with parameters of type PackagePartName
 PackageRelationship RelationshipSource.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType)
Add a relationship to a part (except relationships part).
 PackageRelationship PackagePart.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType)
Add a relationship to a part (except relationships part).
 PackageRelationship OPCPackage.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType)
Add a package relationship.
 PackageRelationship RelationshipSource.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id)
Add a relationship to a part (except relationships part).
 PackageRelationship PackagePart.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id)
Add a relationship to a part (except relationships part).
 PackageRelationship OPCPackage.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String relID)
Add a relationship to the package (except relationships part).
 int PackagePartName.compareTo(PackagePartName otherPartName)
Compare two part name following the rule M1.12 : Part name equivalence is determined by comparing part names as case-insensitive ASCII strings.
 boolean OPCPackage.containPart(PackagePartName partName)
Check if a part already exists in this package from its name.
 PackagePart OPCPackage.createPart(PackagePartName partName, java.lang.String contentType)
Create and add a part, with the specified name and content type, to the package.
 PackagePart OPCPackage.createPart(PackagePartName partName, java.lang.String contentType, java.io.ByteArrayOutputStream content)
Add a part to the package.
protected  PackagePart ZipPackage.createPartImpl(PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Create a new MemoryPackagePart from the specified URI and content type aram partName The part URI.
protected abstract  PackagePart OPCPackage.createPartImpl(PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Core method to create a package part.
 void OPCPackage.deletePart(PackagePartName partName)
Delete the part with the specified name and its associated relationships part if one exists.
 void OPCPackage.deletePartRecursive(PackagePartName partName)
Delete the part with the specified name and all part listed in its associated relationships part if one exists.
 PackagePart OPCPackage.getPart(PackagePartName partName)
Retrieve a part identified by its name.
protected  PackagePart ZipPackage.getPartImpl(PackagePartName partName)
Implement the getPart() method to retrieve a part from its URI in the current package
protected abstract  PackagePart OPCPackage.getPartImpl(PackagePartName partName)
Get the package part mapped to the specified URI.
static PackagePartName PackagingURIHelper.getRelationshipPartName(PackagePartName partName)
Build a part name where the relationship should be stored ((ex /word/document.xml -> /word/_rels/document.xml.rels)
 PackagePart PackagePartCollection.put(PackagePartName partName, PackagePart part)
Check rule [M1.11]: a package implementer shall neither create nor recognize a part with a part name derived from another part name by appending segments to it.
 void OPCPackage.removePart(PackagePartName partName)
Remove a part in this package.
protected  void ZipPackage.removePartImpl(PackagePartName partName)
Delete a part from the package
protected abstract  void OPCPackage.removePartImpl(PackagePartName partName)
Core method to delete a package part.
 void OPCPackage.removePartRecursive(PackagePartName partName)
Remove a part from this package as well as its relationship part, if one exists, and all parts listed in the relationship part.

Constructors in org.apache.poi.openxml4j.opc with parameters of type PackagePartName
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType)
Constructor.
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType, boolean loadRelationships)
Constructor.
PackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType)
Constructor.
ZipPackagePart(OPCPackage container, PackagePartName partName, java.lang.String contentType)
Constructor.
ZipPackagePart(OPCPackage container, java.util.zip.ZipEntry zipEntry, PackagePartName partName, java.lang.String contentType)
Constructor.

Uses of PackagePartName in org.apache.poi.openxml4j.opc.internal

Methods in org.apache.poi.openxml4j.opc.internal with parameters of type PackagePartName
 void ContentTypeManager.addContentType(PackagePartName partName, java.lang.String contentType)
Build association extention-> content type (will be stored in [Content_Types].xml) for example ContentType="image/png" Extension="png"
 java.lang.String ContentTypeManager.getContentType(PackagePartName partName)
Get the content type for the specified part, if any.
 void ContentTypeManager.removeContentType(PackagePartName partName)
Delete a content type based on the specified part name.

Constructors in org.apache.poi.openxml4j.opc.internal with parameters of type PackagePartName
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType)
Constructor.
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Constructor.
PackagePropertiesPart(OPCPackage pack, PackagePartName partName)
Constructor.

Uses of PackagePartName in org.apache.poi.openxml4j.opc.internal.marshallers

Methods in org.apache.poi.openxml4j.opc.internal.marshallers with parameters of type PackagePartName
static boolean ZipPartMarshaller.marshallRelationshipPart(PackageRelationshipCollection rels, PackagePartName relPartName, java.util.zip.ZipOutputStream zos)
Save relationships into the part.

Uses of PackagePartName in org.apache.poi.openxml4j.opc.internal.unmarshallers

Methods in org.apache.poi.openxml4j.opc.internal.unmarshallers with parameters of type PackagePartName
 void UnmarshallContext.setPartName(PackagePartName partName)

Constructors in org.apache.poi.openxml4j.opc.internal.unmarshallers with parameters of type PackagePartName
UnmarshallContext(OPCPackage targetPackage, PackagePartName partName)
Constructor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.openxml4j.opc.PackageProperties

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.openxml4j.opc.PackageProperties

Packages that use PackageProperties
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal

Uses of PackageProperties in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return PackageProperties
 PackageProperties OPCPackage.getPackageProperties()
Retrieves or creates if none exists, core package property part.

Uses of PackageProperties in org.apache.poi.openxml4j.opc.internal

Classes in org.apache.poi.openxml4j.opc.internal that implement PackageProperties
 class PackagePropertiesPart
Represents the core properties part of a package.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.PackageRelationship

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.PackageRelationship

Packages that use PackageRelationship
org.apache.poi
org.apache.poi.openxml4j.opc
org.apache.poi.xslf.usermodel
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel
org.apache.poi.xwpf.usermodel

Uses of PackageRelationship in org.apache.poi

Methods in org.apache.poi that return PackageRelationship
 PackageRelationship POIXMLDocumentPart.getPackageRelationship()
Provides access to the PackageRelationship that identifies this POIXMLDocumentPart

Methods in org.apache.poi with parameters of type PackageRelationship
abstract POIXMLDocumentPart | POIXMLFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part) Create a POIXMLDocumentPart from existing package part and relation.
protected PackagePart | POIXMLDocumentPart.getTargetPart(PackageRelationship rel) Get the PackagePart that is the target of a relationship from this Part.

Constructors in org.apache.poi with parameters of type PackageRelationship
POIXMLDocumentPart(PackagePart part, PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part and relationship.
POIXMLDocumentPart(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
Creates an POIXMLDocumentPart representing the given package part, relationship and parent Called by POIXMLDocumentPart.read(POIXMLFactory, java.util.Map) when reading in an exisiting file.

Uses of PackageRelationship in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return PackageRelationship
PackageRelationship | RelationshipSource.addExternalRelationship(java.lang.String target, java.lang.String relationshipType) Adds an external relationship to a part (except relationships part).
PackageRelationship | PackagePart.addExternalRelationship(java.lang.String target, java.lang.String relationshipType) Adds an external relationship to a part (except relationships part).
PackageRelationship | OPCPackage.addExternalRelationship(java.lang.String target, java.lang.String relationshipType) Adds an external relationship to a part (except relationships part).
PackageRelationship | RelationshipSource.addExternalRelationship(java.lang.String target, java.lang.String relationshipType, java.lang.String id) Adds an external relationship to a part (except relationships part).
PackageRelationship | PackagePart.addExternalRelationship(java.lang.String target, java.lang.String relationshipType, java.lang.String id) Adds an external relationship to a part (except relationships part).
PackageRelationship | OPCPackage.addExternalRelationship(java.lang.String target, java.lang.String relationshipType, java.lang.String id) Adds an external relationship to a part (except relationships part).
PackageRelationship | RelationshipSource.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | PackagePart.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | OPCPackage.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a package relationship.
PackageRelationship | RelationshipSource.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
PackageRelationship | PackagePart.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
PackageRelationship | OPCPackage.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String relID) Add a relationship to the package (except relationships part).
PackageRelationship | PackagePart.addRelationship(java.net.URI targetURI, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | PackageRelationshipCollection.addRelationship(java.net.URI targetUri, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to the collection.
PackageRelationship | PackagePart.addRelationship(java.net.URI targetURI, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
PackageRelationship | PackageRelationshipCollection.getRelationship(int index) Retrieves a relationship by its index in the collection.
PackageRelationship | RelationshipSource.getRelationship(java.lang.String id) Retrieves a package relationship from its id.
PackageRelationship | PackagePart.getRelationship(java.lang.String id) Retrieves a package relationship from its id.
PackageRelationship | OPCPackage.getRelationship(java.lang.String id)
PackageRelationship | PackageRelationshipCollection.getRelationshipByID(java.lang.String id) Retrieves a package relationship based on its id.

Methods in org.apache.poi.openxml4j.opc that return types with arguments of type PackageRelationship
java.util.Iterator<PackageRelationship> | PackageRelationshipCollection.iterator() Get this collection's iterator.
java.util.Iterator<PackageRelationship> | PackageRelationshipCollection.iterator(java.lang.String typeFilter) Get an iterator of a collection with all relationship with the specified type.

Methods in org.apache.poi.openxml4j.opc with parameters of type PackageRelationship
void | PackageRelationshipCollection.addRelationship(PackageRelationship relPart) Add the specified relationship to the collection.
PackagePart | OPCPackage.getPart(PackageRelationship partRel) Get the target part from the specified relationship.
PackagePart | PackagePart.getRelatedPart(PackageRelationship rel) Get the PackagePart that is the target of a relationship.
boolean | RelationshipSource.isRelationshipExists(PackageRelationship rel) Checks if the specified relationship is part of this package part.
boolean | PackagePart.isRelationshipExists(PackageRelationship rel) Checks if the specified relationship is part of this package part.
boolean | OPCPackage.isRelationshipExists(PackageRelationship rel)
void | PackageRelationshipCollection.removeRelationship(PackageRelationship rel) Remove a relationship by its reference.

Uses of PackageRelationship in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel with parameters of type PackageRelationship
 POIXMLDocumentPart XSLFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)

Constructors in org.apache.poi.xslf.usermodel with parameters of type PackageRelationship
XSLFNotesMaster(PackagePart part, PackageRelationship rel)
XSLFPictureData(PackagePart part, PackageRelationship rel)
Construct XSLFPictureData from a package part
XSLFSheet(PackagePart part, PackageRelationship rel)
XSLFSlideLayout(PackagePart part, PackageRelationship rel)
XSLFSlideMaster(PackagePart part, PackageRelationship rel)
XSLFTableStyles(PackagePart part, PackageRelationship rel)
XSLFTheme(PackagePart part, PackageRelationship rel)

Uses of PackageRelationship in org.apache.poi.xssf.eventusermodel

Constructors in org.apache.poi.xssf.eventusermodel with parameters of type PackageRelationship
ReadOnlySharedStringsTable(PackagePart part, PackageRelationship rel_ignored)
Like POIXMLDocumentPart constructor

Uses of PackageRelationship in org.apache.poi.xssf.model

Constructors in org.apache.poi.xssf.model with parameters of type PackageRelationship
CalculationChain(PackagePart part, PackageRelationship rel)
CommentsTable(PackagePart part, PackageRelationship rel)
MapInfo(PackagePart part, PackageRelationship rel)
SharedStringsTable(PackagePart part, PackageRelationship rel)
SingleXmlCells(PackagePart part, PackageRelationship rel)
StylesTable(PackagePart part, PackageRelationship rel)
ThemesTable(PackagePart part, PackageRelationship rel)

Uses of PackageRelationship in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return PackageRelationship
protected  PackageRelationship XSSFDrawing.addPictureReference(int pictureIndex)
Add the indexed picture to this drawing relations

Methods in org.apache.poi.xssf.usermodel with parameters of type PackageRelationship
POIXMLDocumentPart | XSSFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
protected void | XSSFPicture.setPictureReference(PackageRelationship rel) Link this shape with the picture data

Constructors in org.apache.poi.xssf.usermodel with parameters of type PackageRelationship
XSSFChart(PackagePart part, PackageRelationship rel)
Construct a SpreadsheetML chart from a package part.
XSSFChartSheet(PackagePart part, PackageRelationship rel)
XSSFDrawing(PackagePart part, PackageRelationship rel)
Construct a SpreadsheetML drawing from a package part
XSSFHyperlink(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHyperlink ctHyperlink, PackageRelationship hyperlinkRel)
Create a XSSFHyperlink amd initialize it from the supplied CTHyperlink bean and package relationship
XSSFPictureData(PackagePart part, PackageRelationship rel)
Construct XSSFPictureData from a package part
XSSFSheet(PackagePart part, PackageRelationship rel)
Creates an XSSFSheet representing the given package part and relationship.
XSSFTable(PackagePart part, PackageRelationship rel)
XSSFVMLDrawing(PackagePart part, PackageRelationship rel)
Construct a SpreadsheetML drawing from a package part

Uses of PackageRelationship in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel with parameters of type PackageRelationship
POIXMLDocumentPart | XWPFFactory.createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part)
void | XWPFPicture.setPictureReference(PackageRelationship rel) Link Picture with PictureData

Constructors in org.apache.poi.xwpf.usermodel with parameters of type PackageRelationship
XWPFFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFFootnotes(PackagePart part, PackageRelationship rel)
Construct XWPFFootnotes from a package part
XWPFHeader(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFHeaderFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFNumbering(PackagePart part, PackageRelationship rel)
create a new styles object with an existing document
XWPFPictureData(PackagePart part, PackageRelationship rel)
Construct XWPFPictureData from a package part
XWPFSettings(PackagePart part, PackageRelationship rel)
XWPFStyles(PackagePart part, PackageRelationship rel)
Construct XWPFStyles from a package part

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.PackageRelationshipCollection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.PackageRelationshipCollection

Packages that use PackageRelationshipCollection
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal.marshallers

Uses of PackageRelationshipCollection in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as PackageRelationshipCollection
protected  PackageRelationshipCollection OPCPackage.relationships
Package relationships.

Methods in org.apache.poi.openxml4j.opc that return PackageRelationshipCollection
PackageRelationshipCollection | RelationshipSource.getRelationships() Retrieve all the relationships attached to this.
PackageRelationshipCollection | PackagePart.getRelationships() Retrieve all the relationships attached to this part.
PackageRelationshipCollection | OPCPackage.getRelationships() Retrieves all package relationships.
PackageRelationshipCollection | PackageRelationshipCollection.getRelationships(java.lang.String typeFilter) Retrieves all relations with the specified type.
PackageRelationshipCollection | RelationshipSource.getRelationshipsByType(java.lang.String relationshipType) Retrieve all relationships attached to this part which have the specified type.
PackageRelationshipCollection | PackagePart.getRelationshipsByType(java.lang.String relationshipType) Retrieve all relationships attached to this part which have the specified type.
PackageRelationshipCollection | OPCPackage.getRelationshipsByType(java.lang.String relationshipType) Retrieves all relationships with the specified type.

Constructors in org.apache.poi.openxml4j.opc with parameters of type PackageRelationshipCollection
PackageRelationshipCollection(PackageRelationshipCollection coll, java.lang.String filter)
Copy constructor.

Uses of PackageRelationshipCollection in org.apache.poi.openxml4j.opc.internal.marshallers

Methods in org.apache.poi.openxml4j.opc.internal.marshallers with parameters of type PackageRelationshipCollection
static boolean ZipPartMarshaller.marshallRelationshipPart(PackageRelationshipCollection rels, PackagePartName relPartName, java.util.zip.ZipOutputStream zos)
Save relationships into the part.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.openxml4j.opc.PackageRelationshipTypes

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.openxml4j.opc.PackageRelationshipTypes

No usage of org.apache.poi.openxml4j.opc.PackageRelationshipTypes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.PackagingURIHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.PackagingURIHelper

No usage of org.apache.poi.openxml4j.opc.PackagingURIHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.openxml4j.opc.RelationshipSource

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.openxml4j.opc.RelationshipSource

Packages that use RelationshipSource
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.signature
org.apache.poi.openxml4j.opc.signature

Uses of RelationshipSource in org.apache.poi.openxml4j.opc

Classes in org.apache.poi.openxml4j.opc that implement RelationshipSource
class | OPCPackage Represents a container that can store multiple data objects.
class | Package Deprecated. (name clash with Package use OPCPackage instead.
class | PackagePart Provides a base class for parts stored in a Package.
class | ZipPackage Physical zip package.
class | ZipPackagePart Zip implementation of a PackagePart.

Uses of RelationshipSource in org.apache.poi.openxml4j.opc.internal

Classes in org.apache.poi.openxml4j.opc.internal that implement RelationshipSource
class | MemoryPackagePart Memory version of a package part.
class | PackagePropertiesPart Represents the core properties part of a package.

Uses of RelationshipSource in org.apache.poi.openxml4j.opc.internal.signature

Classes in org.apache.poi.openxml4j.opc.internal.signature that implement RelationshipSource
 class DigitalCertificatePart
Digital certificate part.

Uses of RelationshipSource in org.apache.poi.openxml4j.opc.signature

Classes in org.apache.poi.openxml4j.opc.signature that implement RelationshipSource
 class PackageDigitalSignature

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.StreamHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.StreamHelper

No usage of org.apache.poi.openxml4j.opc.StreamHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.TargetMode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.TargetMode

Packages that use TargetMode
org.apache.poi.openxml4j.opc

Uses of TargetMode in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return TargetMode
 TargetMode PackageRelationship.getTargetMode()
public URI getSourceUri(){ }
static TargetMode TargetMode.valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name.
static TargetMode[] TargetMode.values()
Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.openxml4j.opc with parameters of type TargetMode
PackageRelationship | RelationshipSource.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | PackagePart.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | OPCPackage.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType) Add a package relationship.
PackageRelationship | RelationshipSource.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
PackageRelationship | PackagePart.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).
PackageRelationship | OPCPackage.addRelationship(PackagePartName targetPartName, TargetMode targetMode, java.lang.String relationshipType, java.lang.String relID) Add a relationship to the package (except relationships part).
PackageRelationship | PackagePart.addRelationship(java.net.URI targetURI, TargetMode targetMode, java.lang.String relationshipType) Add a relationship to a part (except relationships part).
PackageRelationship | PackageRelationshipCollection.addRelationship(java.net.URI targetUri, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to the collection.
PackageRelationship | PackagePart.addRelationship(java.net.URI targetURI, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id) Add a relationship to a part (except relationships part).

Constructors in org.apache.poi.openxml4j.opc with parameters of type TargetMode
PackageRelationship(OPCPackage pkg, PackagePart sourcePart, java.net.URI targetUri, TargetMode targetMode, java.lang.String relationshipType, java.lang.String id)
Constructor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.ZipPackage

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.ZipPackage

Packages that use ZipPackage
org.apache.poi.openxml4j.opc.internal

Uses of ZipPackage in org.apache.poi.openxml4j.opc.internal

Methods in org.apache.poi.openxml4j.opc.internal with parameters of type ZipPackage
static java.util.zip.ZipEntry | ZipHelper.getContentTypeZipEntry(ZipPackage pkg) Retrieve the Zip entry of the content types part.
static java.util.zip.ZipEntry | ZipHelper.getCorePropertiesZipEntry(ZipPackage pkg) Retrieve the zip entry of the core properties part.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.ZipPackagePart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.ZipPackagePart

No usage of org.apache.poi.openxml4j.opc.ZipPackagePart

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ContentType

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class ContentType

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.ContentType

public final class ContentType
extends java.lang.Object

Represents a immutable MIME ContentType value (RFC 2616 §3.7)

media-type = type "/" subtype *( ";" parameter ) type = token
subtype = token

Rule M1.13 : Package implementers shall only create and only recognize parts with a content type; format designers shall specify a content type for each part included in the format. Content types for package parts shall fit the definition and syntax for media types as specified in RFC 2616, \§3.7.

Rule M1.14: Content types shall not use linear white space either between the type and subtype or between an attribute and its value. Content types also shall not have leading or trailing white spaces. Package implementers shall create only such content types and shall require such content types when retrieving a part from a package; format designers shall specify only such content types for inclusion in the format.

Version:
0.1
Author:
Julien Chable
See Also:
http://www.ietf.org/rfc/rfc2045.txt, http://www.ietf.org/rfc/rfc2616.txt

Constructor Summary
ContentType(java.lang.String contentType)
Constructor.
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getParameters(java.lang.String key) Gets the value associated to the specified key.
java.lang.String | getSubType() Get the subtype.
java.lang.String | getType() Get the type.
int | hashCode()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ContentType

public ContentType(java.lang.String contentType)
            throws InvalidFormatException
Constructor. Check the input with the RFC 2616 grammar.

Parameters:
contentType - The content type to store.
Throws:
InvalidFormatException - If the specified content type is not valid with RFC 2616.
Method Detail

toString

public final java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getSubType

public java.lang.String getSubType()
Get the subtype.

Returns:
The subtype of this content type.

getType

public java.lang.String getType()
Get the type.

Returns:
The type of this content type.

getParameters

public java.lang.String getParameters(java.lang.String key)
Gets the value associated to the specified key.

Parameters:
key - The key of the key/value pair.
Returns:
The value associated to the specified key.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ContentTypeManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class ContentTypeManager

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.ContentTypeManager
Direct Known Subclasses:
ZipContentTypeManager
public abstract class ContentTypeManager
extends java.lang.Object

Manage package content types ([Content_Types].xml part).

Author:
Julien Chable

Field Summary
protected OPCPackage | container Reference to the package using this content type manager.
static java.lang.String | CONTENT_TYPES_PART_NAME Content type part name.
static java.lang.String | TYPES_NAMESPACE_URI Content type namespace
Constructor Summary
ContentTypeManager(java.io.InputStream in, OPCPackage pkg)
Constructor.
Method Summary
 void addContentType(PackagePartName partName, java.lang.String contentType)
Build association extention-> content type (will be stored in [Content_Types].xml) for example ContentType="image/png" Extension="png"
 void clearAll()
Clear all content types.
 void clearOverrideContentTypes()
Clear all override content types.
 java.lang.String getContentType(PackagePartName partName)
Get the content type for the specified part, if any.
 boolean isContentTypeRegister(java.lang.String contentType)
Check if the specified content type is already register.
 void removeContentType(PackagePartName partName)
Delete a content type based on the specified part name.
 boolean save(java.io.OutputStream outStream)
Save the contents type part.
abstract  boolean saveImpl(org.dom4j.Document content, java.io.OutputStream out)
Specific implementation of the save method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONTENT_TYPES_PART_NAME

public static final java.lang.String CONTENT_TYPES_PART_NAME
Content type part name.

See Also:
Constant Field Values

TYPES_NAMESPACE_URI

public static final java.lang.String TYPES_NAMESPACE_URI
Content type namespace

See Also:
Constant Field Values

container

protected OPCPackage container
Reference to the package using this content type manager.

Constructor Detail

ContentTypeManager

public ContentTypeManager(java.io.InputStream in,
                          OPCPackage pkg)
                   throws InvalidFormatException
Constructor. Parses the content of the specified input stream.

Parameters:
in - If different of null then the content types part is retrieve and parse.
Throws:
InvalidFormatException - If the content types part content is not valid.
Method Detail

addContentType

public void addContentType(PackagePartName partName,
                           java.lang.String contentType)
Build association extention-> content type (will be stored in [Content_Types].xml) for example ContentType="image/png" Extension="png"

[M2.8]: When adding a new part to a package, the package implementer shall ensure that a content type for that part is specified in the Content Types stream; the package implementer shall perform the steps described in §9.1.2.3:

1. Get the extension from the part name by taking the substring to the right of the rightmost occurrence of the dot character (.) from the rightmost segment.

2. If a part name has no extension, a corresponding Override element shall be added to the Content Types stream.

3. Compare the resulting extension with the values specified for the Extension attributes of the Default elements in the Content Types stream. The comparison shall be case-insensitive ASCII.

4. If there is a Default element with a matching Extension attribute, then the content type of the new part shall be compared with the value of the ContentType attribute. The comparison might be case-sensitive and include every character regardless of the role it plays in the content-type grammar of RFC 2616, or it might follow the grammar of RFC 2616.

a. If the content types match, no further action is required.

b. If the content types do not match, a new Override element shall be added to the Content Types stream. .

5. If there is no Default element with a matching Extension attribute, a new Default element or Override element shall be added to the Content Types stream.

removeContentType

public void removeContentType(PackagePartName partName)
                       throws InvalidOperationException

Delete a content type based on the specified part name. If the specified part name is register with an override content type, then this content type is remove, else the content type is remove in the default content type list if it exists and if no part is associated with it yet.

Check rule M2.4: The package implementer shall require that the Content Types stream contain one of the following for every part in the package: One matching Default element One matching Override element Both a matching Default element and a matching Override element, in which case the Override element takes precedence.

Parameters:
partName - The part URI associated with the override content type to delete.
Throws:
InvalidOperationException - Throws if

isContentTypeRegister

public boolean isContentTypeRegister(java.lang.String contentType)
Check if the specified content type is already register.

Parameters:
contentType - The content type to check.
Returns:
true if the specified content type is already register, then false.

getContentType

public java.lang.String getContentType(PackagePartName partName)
Get the content type for the specified part, if any.

Rule [M2.9]: To get the content type of a part, the package implementer shall perform the steps described in §9.1.2.4:

1. Compare the part name with the values specified for the PartName attribute of the Override elements. The comparison shall be case-insensitive ASCII.

2. If there is an Override element with a matching PartName attribute, return the value of its ContentType attribute. No further action is required.

3. If there is no Override element with a matching PartName attribute, then a. Get the extension from the part name by taking the substring to the right of the rightmost occurrence of the dot character (.) from the rightmost segment. b. Check the Default elements of the Content Types stream, comparing the extension with the value of the Extension attribute. The comparison shall be case-insensitive ASCII.

4. If there is a Default element with a matching Extension attribute, return the value of its ContentType attribute. No further action is required.

5. If neither Override nor Default elements with matching attributes are found for the specified part name, the implementation shall not map this part name to a part.

Parameters:
partName - The URI part to check.
Returns:
The content type associated with the URI (in case of an override content type) or the extension (in case of default content type), else null.
Throws:
OpenXML4JRuntimeException - Throws if the content type manager is not able to find the content from an existing part.

clearAll

public void clearAll()
Clear all content types.

clearOverrideContentTypes

public void clearOverrideContentTypes()
Clear all override content types.

save

public boolean save(java.io.OutputStream outStream)
Save the contents type part.

Parameters:
outStream - The output stream use to save the XML content of the content types part.
Returns:
true if the operation success, else false.

saveImpl

public abstract boolean saveImpl(org.dom4j.Document content,
                                 java.io.OutputStream out)
Specific implementation of the save method. Call by the save() method, call before exiting.

Parameters:
out - The output stream use to write the content type XML.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class FileHelper

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.FileHelper

public final class FileHelper
extends java.lang.Object

Provide useful method to manage file.

Version:
0.1
Author:
Julien Chable

Constructor Summary
FileHelper()
Method Summary
static void | copyFile(java.io.File in, java.io.File out) Copy a file.
static java.io.File | getDirectory(java.io.File f) Get the directory part of the specified file path.
static java.lang.String | getFilename(java.io.File file) Get file name from the specified File object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileHelper

public FileHelper()
Method Detail

getDirectory

public static java.io.File getDirectory(java.io.File f)
Get the directory part of the specified file path.

Parameters:
f - File to process.
Returns:
The directory path from the specified

copyFile

public static void copyFile(java.io.File in,
                            java.io.File out)
                     throws java.io.IOException
Copy a file.

Parameters:
in - The source file.
out - The target location.
Throws:
java.io.IOException - If an I/O error occur.

getFilename

public static java.lang.String getFilename(java.io.File file)
Get file name from the specified File object.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MemoryPackagePart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class MemoryPackagePart

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagePart
        extended by  org.apache.poi.openxml4j.opc.internal.MemoryPackagePart
All Implemented Interfaces:
RelationshipSource
public final class MemoryPackagePart
extends PackagePart

Memory version of a package part. Use to

Version:
1.0
Author:
Julien Chable

Field Summary
protected byte[] | data Storage for the part data.
protected int | length Size of data.
Fields inherited from class org.apache.poi.openxml4j.opc.PackagePart
_container, _contentType, _partName
Constructor Summary
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType)
Constructor.
MemoryPackagePart(OPCPackage pack, PackagePartName partName, java.lang.String contentType, boolean loadRelationships)
Constructor.
Method Summary
void | clear()
void | close() Close this part : flush this part, close the input stream and output stream.
void | flush() Flush the content of this part.
protected java.io.InputStream | getInputStreamImpl() Abtract method that get the input stream of this part.
protected java.io.OutputStream | getOutputStreamImpl() Abstract method that get the output stream of this part.
boolean | load(java.io.InputStream ios) Load the content of this part.
boolean | save(java.io.OutputStream os) Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.
Methods inherited from class org.apache.poi.openxml4j.opc.PackagePart
addExternalRelationship, addExternalRelationship, addRelationship, addRelationship, addRelationship, addRelationship, clearRelationships, getContentType, getInputStream, getOutputStream, getPackage, getPartName, getRelatedPart, getRelationship, getRelationships, getRelationshipsByType, hasRelationships, isDeleted, isRelationshipExists, isRelationshipPart, removeRelationship, setContentType, setDeleted, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

data

protected byte[] data
Storage for the part data.

length

protected int length
Size of data.

Constructor Detail

MemoryPackagePart

public MemoryPackagePart(OPCPackage pack,
                         PackagePartName partName,
                         java.lang.String contentType)
                  throws InvalidFormatException
Constructor.

Parameters:
pack - The owner package.
partName - The part name.
contentType - The content type.
Throws:
InvalidFormatException - If the specified URI is not OPC compliant.

MemoryPackagePart

public MemoryPackagePart(OPCPackage pack,
                         PackagePartName partName,
                         java.lang.String contentType,
                         boolean loadRelationships)
                  throws InvalidFormatException
Constructor.

Parameters:
pack - The owner package.
partName - The part name.
contentType - The content type.
loadRelationships - Specify if the relationships will be loaded.
Throws:
InvalidFormatException - If the specified URI is not OPC compliant.
Method Detail

getInputStreamImpl

protected java.io.InputStream getInputStreamImpl()
Description copied from class: PackagePart
Abtract method that get the input stream of this part.

Specified by:
getInputStreamImpl in class PackagePart

getOutputStreamImpl

protected java.io.OutputStream getOutputStreamImpl()
Description copied from class: PackagePart
Abstract method that get the output stream of this part.

Specified by:
getOutputStreamImpl in class PackagePart

clear

public void clear()

save

public boolean save(java.io.OutputStream os)
             throws OpenXML4JException
Description copied from class: PackagePart
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.

Specified by:
save in class PackagePart
Parameters:
os - Output stream to save this part.
Throws:
OpenXML4JException - If any exception occur.

load

public boolean load(java.io.InputStream ios)
             throws InvalidFormatException
Description copied from class: PackagePart
Load the content of this part.

Specified by:
load in class PackagePart
Parameters:
ios - The input stream of the content to load.
Returns:
true if the content has been successfully loaded, else false.
Throws:
InvalidFormatException - Throws if the content format is invalid.

close

public void close()
Description copied from class: PackagePart
Close this part : flush this part, close the input stream and output stream. After this method call, the part must be available for packaging.

Specified by:
close in class PackagePart

flush

public void flush()
Description copied from class: PackagePart
Flush the content of this part. If the input stream and/or output stream as in a waiting state to read or write, the must to empty their respective buffer.

Specified by:
flush in class PackagePart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MemoryPackagePartOutputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class MemoryPackagePartOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream
All Implemented Interfaces:
java.io.Closeable, java.io.Flushable
public final class MemoryPackagePartOutputStream
extends java.io.OutputStream

Build an output stream for MemoryPackagePart.

Author:
Julien Chable

Constructor Summary
MemoryPackagePartOutputStream(MemoryPackagePart part)
Method Summary
void | close() Close this stream and flush the content.
void | flush() Flush this output stream.
void | write(byte[] b)
void | write(byte[] b, int off, int len)
void | write(int b)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MemoryPackagePartOutputStream

public MemoryPackagePartOutputStream(MemoryPackagePart part)
Method Detail

write

public void write(int b)
Specified by:
write in class java.io.OutputStream

close

public void close()
           throws java.io.IOException
Close this stream and flush the content.

Specified by:
close in interface java.io.Closeable
Overrides:
close in class java.io.OutputStream
Throws:
java.io.IOException
See Also:
flush()

flush

public void flush()
           throws java.io.IOException
Flush this output stream. This method is called by the close() method. Warning : don't call this method for output consistency.

Specified by:
flush in interface java.io.Flushable
Overrides:
flush in class java.io.OutputStream
Throws:
java.io.IOException
See Also:
close()

write

public void write(byte[] b,
                  int off,
                  int len)
Overrides:
write in class java.io.OutputStream

write

public void write(byte[] b)
           throws java.io.IOException
Overrides:
write in class java.io.OutputStream
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.openxml4j.opc.internal
Interfaces
PartMarshaller
PartUnmarshaller
Classes
ContentType
ContentTypeManager
FileHelper
MemoryPackagePart
MemoryPackagePartOutputStream
PackagePropertiesPart
ZipContentTypeManager
ZipHelper


PackagePropertiesPart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class PackagePropertiesPart

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagePart
        extended by  org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart
All Implemented Interfaces:
PackageProperties, RelationshipSource
public final class PackagePropertiesPart
extends PackagePart
implements PackageProperties

Represents the core properties part of a package.

Author:
Julien Chable

Field Summary
protected Nullable<java.lang.String> | category A categorization of the content of this package.
protected Nullable<java.lang.String> | contentStatus The status of the content.
protected Nullable<java.lang.String> | contentType The type of content represented, generally defined by a specific use and intended audience.
protected Nullable<java.util.Date> | created Date of creation of the resource.
protected Nullable<java.lang.String> | creator An entity primarily responsible for making the content of the resource.
protected Nullable<java.lang.String> | description An explanation of the content of the resource.
protected Nullable<java.lang.String> | identifier An unambiguous reference to the resource within a given context.
protected Nullable<java.lang.String> | keywords A delimited set of keywords to support searching and indexing.
protected Nullable<java.lang.String> | language The language of the intellectual content of the resource.
protected Nullable<java.lang.String> | lastModifiedBy The user who performed the last modification.
protected Nullable<java.util.Date> | lastPrinted The date and time of the last printing.
protected Nullable<java.util.Date> | modified Date on which the resource was changed.
static java.lang.String | NAMESPACE_CP_URI
static java.lang.String | NAMESPACE_DC_URI
static java.lang.String | NAMESPACE_DCTERMS_URI
static java.lang.String | NAMESPACE_XSI_URI
protected Nullable<java.lang.String> | revision The revision number.
protected Nullable<java.lang.String> | subject The topic of the content of the resource.
protected Nullable<java.lang.String> | title The name given to the resource.
protected Nullable<java.lang.String> | version The version number.
Fields inherited from class org.apache.poi.openxml4j.opc.PackagePart
_container, _contentType, _partName
Fields inherited from interface org.apache.poi.openxml4j.opc.PackageProperties
NAMESPACE_DC, NAMESPACE_DCTERMS
Constructor Summary
PackagePropertiesPart(OPCPackage pack, PackagePartName partName)
Constructor.
Method Summary
void | close() Close this part : flush this part, close the input stream and output stream.
void | flush() Flush the content of this part.
Nullable<java.lang.String> | getCategoryProperty() Get the category property.
Nullable<java.lang.String> | getContentStatusProperty() Get content status.
Nullable<java.lang.String> | getContentTypeProperty() Get content type.
Nullable<java.util.Date> | getCreatedProperty() Get created date.
java.lang.String | getCreatedPropertyString() Get created date formated into a String.
Nullable<java.lang.String> | getCreatorProperty() Get creator.
Nullable<java.lang.String> | getDescriptionProperty() Get description.
Nullable<java.lang.String> | getIdentifierProperty() Get identifier.
protected java.io.InputStream | getInputStreamImpl() Abtract method that get the input stream of this part.
Nullable<java.lang.String> | getKeywordsProperty() Get keywords.
Nullable<java.lang.String> | getLanguageProperty() Get the language.
Nullable<java.lang.String> | getLastModifiedByProperty() Get the author of last modifications.
Nullable<java.util.Date> | getLastPrintedProperty() Get last printed date.
java.lang.String | getLastPrintedPropertyString() Get last printed date formated into a String.
Nullable<java.util.Date> | getModifiedProperty() Get modified date.
java.lang.String | getModifiedPropertyString() Get modified date formated into a String.
protected java.io.OutputStream | getOutputStreamImpl() Abstract method that get the output stream of this part.
Nullable<java.lang.String> | getRevisionProperty() Get revision.
Nullable<java.lang.String> | getSubjectProperty() Get subject.
Nullable<java.lang.String> | getTitleProperty() Get title.
Nullable<java.lang.String> | getVersionProperty() Get version.
boolean | load(java.io.InputStream ios) Load the content of this part.
boolean | save(java.io.OutputStream zos) Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.
void | setCategoryProperty(java.lang.String category) Set the category.
void | setContentStatusProperty(java.lang.String contentStatus) Set the content status.
void | setContentTypeProperty(java.lang.String contentType) Set the content type.
void | setCreatedProperty(Nullable<java.util.Date> created) Set the created date.
void | setCreatedProperty(java.lang.String created) Set the created date.
void | setCreatorProperty(java.lang.String creator) Set the creator.
void | setDescriptionProperty(java.lang.String description) Set the description.
void | setIdentifierProperty(java.lang.String identifier) Set identifier.
void | setKeywordsProperty(java.lang.String keywords) Set keywords.
void | setLanguageProperty(java.lang.String language) Set language.
void | setLastModifiedByProperty(java.lang.String lastModifiedBy) Set last modifications author.
void | setLastPrintedProperty(Nullable<java.util.Date> lastPrinted) Set last printed date.
void | setLastPrintedProperty(java.lang.String lastPrinted) Set last printed date.
void | setModifiedProperty(Nullable<java.util.Date> modified) Set last modification date.
void | setModifiedProperty(java.lang.String modified) Set last modification date.
void | setRevisionProperty(java.lang.String revision) Set revision.
void | setSubjectProperty(java.lang.String subject) Set subject.
void | setTitleProperty(java.lang.String title) Set title.
void | setVersionProperty(java.lang.String version) Set version.
Methods inherited from class org.apache.poi.openxml4j.opc.PackagePart
addExternalRelationship, addExternalRelationship, addRelationship, addRelationship, addRelationship, addRelationship, clearRelationships, getContentType, getInputStream, getOutputStream, getPackage, getPartName, getRelatedPart, getRelationship, getRelationships, getRelationshipsByType, hasRelationships, isDeleted, isRelationshipExists, isRelationshipPart, removeRelationship, setContentType, setDeleted, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NAMESPACE_DC_URI

public static final java.lang.String NAMESPACE_DC_URI
See Also:
Constant Field Values

NAMESPACE_CP_URI

public static final java.lang.String NAMESPACE_CP_URI
See Also:
Constant Field Values

NAMESPACE_DCTERMS_URI

public static final java.lang.String NAMESPACE_DCTERMS_URI
See Also:
Constant Field Values

NAMESPACE_XSI_URI

public static final java.lang.String NAMESPACE_XSI_URI
See Also:
Constant Field Values

category

protected Nullable<java.lang.String> category
A categorization of the content of this package. [Example: Example values for this property might include: Resume, Letter, Financial Forecast, Proposal, Technical Presentation, and so on. This value might be used by an application's user interface to facilitate navigation of a large set of documents. end example]

contentStatus

protected Nullable<java.lang.String> contentStatus
The status of the content. [Example: Values might include "Draft", "Reviewed", and "Final". end example]

contentType

protected Nullable<java.lang.String> contentType
The type of content represented, generally defined by a specific use and intended audience. [Example: Values might include "Whitepaper", "Security Bulletin", and "Exam". end example] [Note: This property is distinct from MIME content types as defined in RFC 2616. end note]

created

protected Nullable<java.util.Date> created
Date of creation of the resource.

creator

protected Nullable<java.lang.String> creator
An entity primarily responsible for making the content of the resource.

description

protected Nullable<java.lang.String> description
An explanation of the content of the resource. [Example: Values might include an abstract, table of contents, reference to a graphical representation of content, and a free-text account of the content. end example]

identifier

protected Nullable<java.lang.String> identifier
An unambiguous reference to the resource within a given context.

keywords

protected Nullable<java.lang.String> keywords
A delimited set of keywords to support searching and indexing. This is typically a list of terms that are not available elsewhere in the properties.

language

protected Nullable<java.lang.String> language
The language of the intellectual content of the resource. [Note: IETF RFC 3066 provides guidance on encoding to represent languages. end note]

lastModifiedBy

protected Nullable<java.lang.String> lastModifiedBy
The user who performed the last modification. The identification is environment-specific. [Example: A name, email address, or employee ID. end example] It is recommended that this value be as concise as possible.

lastPrinted

protected Nullable<java.util.Date> lastPrinted
The date and time of the last printing.

modified

protected Nullable<java.util.Date> modified
Date on which the resource was changed.

revision

protected Nullable<java.lang.String> revision
The revision number. [Example: This value might indicate the number of saves or revisions, provided the application updates it after each revision. end example]

subject

protected Nullable<java.lang.String> subject
The topic of the content of the resource.

title

protected Nullable<java.lang.String> title
The name given to the resource.

version

protected Nullable<java.lang.String> version
The version number. This value is set by the user or by the application.

Constructor Detail

PackagePropertiesPart

public PackagePropertiesPart(OPCPackage pack,
                             PackagePartName partName)
                      throws InvalidFormatException
Constructor.

Parameters:
pack - Container package.
partName - Name of this part.
Throws:
InvalidFormatException - Throws if the content is invalid.
Method Detail

getCategoryProperty

public Nullable<java.lang.String> getCategoryProperty()
Get the category property.

Specified by:
getCategoryProperty in interface PackageProperties
See Also:
PackageProperties.getCategoryProperty()

getContentStatusProperty

public Nullable<java.lang.String> getContentStatusProperty()
Get content status.

Specified by:
getContentStatusProperty in interface PackageProperties
See Also:
PackageProperties.getContentStatusProperty()

getContentTypeProperty

public Nullable<java.lang.String> getContentTypeProperty()
Get content type.

Specified by:
getContentTypeProperty in interface PackageProperties
See Also:
PackageProperties.getContentTypeProperty()

getCreatedProperty

public Nullable<java.util.Date> getCreatedProperty()
Get created date.

Specified by:
getCreatedProperty in interface PackageProperties
See Also:
PackageProperties.getCreatedProperty()

getCreatedPropertyString

public java.lang.String getCreatedPropertyString()
Get created date formated into a String.

Returns:
A string representation of the created date.

getCreatorProperty

public Nullable<java.lang.String> getCreatorProperty()
Get creator.

Specified by:
getCreatorProperty in interface PackageProperties
See Also:
PackageProperties.getCreatorProperty()

getDescriptionProperty

public Nullable<java.lang.String> getDescriptionProperty()
Get description.

Specified by:
getDescriptionProperty in interface PackageProperties
See Also:
PackageProperties.getDescriptionProperty()

getIdentifierProperty

public Nullable<java.lang.String> getIdentifierProperty()
Get identifier.

Specified by:
getIdentifierProperty in interface PackageProperties
See Also:
PackageProperties.getIdentifierProperty()

getKeywordsProperty

public Nullable<java.lang.String> getKeywordsProperty()
Get keywords.

Specified by:
getKeywordsProperty in interface PackageProperties
See Also:
PackageProperties.getKeywordsProperty()

getLanguageProperty

public Nullable<java.lang.String> getLanguageProperty()
Get the language.

Specified by:
getLanguageProperty in interface PackageProperties
See Also:
PackageProperties.getLanguageProperty()

getLastModifiedByProperty

public Nullable<java.lang.String> getLastModifiedByProperty()
Get the author of last modifications.

Specified by:
getLastModifiedByProperty in interface PackageProperties
See Also:
PackageProperties.getLastModifiedByProperty()

getLastPrintedProperty

public Nullable<java.util.Date> getLastPrintedProperty()
Get last printed date.

Specified by:
getLastPrintedProperty in interface PackageProperties
See Also:
PackageProperties.getLastPrintedProperty()

getLastPrintedPropertyString

public java.lang.String getLastPrintedPropertyString()
Get last printed date formated into a String.

Returns:
A string representation of the last printed date.

getModifiedProperty

public Nullable<java.util.Date> getModifiedProperty()
Get modified date.

Specified by:
getModifiedProperty in interface PackageProperties
See Also:
PackageProperties.getModifiedProperty()

getModifiedPropertyString

public java.lang.String getModifiedPropertyString()
Get modified date formated into a String.

Returns:
A string representation of the modified date.

getRevisionProperty

public Nullable<java.lang.String> getRevisionProperty()
Get revision.

Specified by:
getRevisionProperty in interface PackageProperties
See Also:
PackageProperties.getRevisionProperty()

getSubjectProperty

public Nullable<java.lang.String> getSubjectProperty()
Get subject.

Specified by:
getSubjectProperty in interface PackageProperties
See Also:
PackageProperties.getSubjectProperty()

getTitleProperty

public Nullable<java.lang.String> getTitleProperty()
Get title.

Specified by:
getTitleProperty in interface PackageProperties
See Also:
PackageProperties.getTitleProperty()

getVersionProperty

public Nullable<java.lang.String> getVersionProperty()
Get version.

Specified by:
getVersionProperty in interface PackageProperties
See Also:
PackageProperties.getVersionProperty()

setCategoryProperty

public void setCategoryProperty(java.lang.String category)
Set the category.

Specified by:
setCategoryProperty in interface PackageProperties
See Also:
PackageProperties.setCategoryProperty(java.lang.String)

setContentStatusProperty

public void setContentStatusProperty(java.lang.String contentStatus)
Set the content status.

Specified by:
setContentStatusProperty in interface PackageProperties
See Also:
PackageProperties.setContentStatusProperty(java.lang.String)

setContentTypeProperty

public void setContentTypeProperty(java.lang.String contentType)
Set the content type.

Specified by:
setContentTypeProperty in interface PackageProperties
See Also:
PackageProperties.setContentTypeProperty(java.lang.String)

setCreatedProperty

public void setCreatedProperty(java.lang.String created)
Set the created date.

Specified by:
setCreatedProperty in interface PackageProperties
See Also:
PackageProperties.setCreatedProperty(org.apache.poi.openxml4j.util.Nullable)

setCreatedProperty

public void setCreatedProperty(Nullable<java.util.Date> created)
Set the created date.

Specified by:
setCreatedProperty in interface PackageProperties
See Also:
PackageProperties.setCreatedProperty(org.apache.poi.openxml4j.util.Nullable)

setCreatorProperty

public void setCreatorProperty(java.lang.String creator)
Set the creator.

Specified by:
setCreatorProperty in interface PackageProperties
See Also:
PackageProperties.setCreatorProperty(java.lang.String)

setDescriptionProperty

public void setDescriptionProperty(java.lang.String description)
Set the description.

Specified by:
setDescriptionProperty in interface PackageProperties
See Also:
PackageProperties.setDescriptionProperty(java.lang.String)

setIdentifierProperty

public void setIdentifierProperty(java.lang.String identifier)
Set identifier.

Specified by:
setIdentifierProperty in interface PackageProperties
See Also:
PackageProperties.setIdentifierProperty(java.lang.String)

setKeywordsProperty

public void setKeywordsProperty(java.lang.String keywords)
Set keywords.

Specified by:
setKeywordsProperty in interface PackageProperties
See Also:
PackageProperties.setKeywordsProperty(java.lang.String)

setLanguageProperty

public void setLanguageProperty(java.lang.String language)
Set language.

Specified by:
setLanguageProperty in interface PackageProperties
See Also:
PackageProperties.setLanguageProperty(java.lang.String)

setLastModifiedByProperty

public void setLastModifiedByProperty(java.lang.String lastModifiedBy)
Set last modifications author.

Specified by:
setLastModifiedByProperty in interface PackageProperties
See Also:
PackageProperties.setLastModifiedByProperty(java.lang.String)

setLastPrintedProperty

public void setLastPrintedProperty(java.lang.String lastPrinted)
Set last printed date.

Specified by:
setLastPrintedProperty in interface PackageProperties
See Also:
PackageProperties.setLastPrintedProperty(org.apache.poi.openxml4j.util.Nullable)

setLastPrintedProperty

public void setLastPrintedProperty(Nullable<java.util.Date> lastPrinted)
Set last printed date.

Specified by:
setLastPrintedProperty in interface PackageProperties
See Also:
PackageProperties.setLastPrintedProperty(org.apache.poi.openxml4j.util.Nullable)

setModifiedProperty

public void setModifiedProperty(java.lang.String modified)
Set last modification date.

Specified by:
setModifiedProperty in interface PackageProperties
See Also:
PackageProperties.setModifiedProperty(org.apache.poi.openxml4j.util.Nullable)

setModifiedProperty

public void setModifiedProperty(Nullable<java.util.Date> modified)
Set last modification date.

Specified by:
setModifiedProperty in interface PackageProperties
See Also:
PackageProperties.setModifiedProperty(org.apache.poi.openxml4j.util.Nullable)

setRevisionProperty

public void setRevisionProperty(java.lang.String revision)
Set revision.

Specified by:
setRevisionProperty in interface PackageProperties
See Also:
PackageProperties.setRevisionProperty(java.lang.String)

setSubjectProperty

public void setSubjectProperty(java.lang.String subject)
Set subject.

Specified by:
setSubjectProperty in interface PackageProperties
See Also:
PackageProperties.setSubjectProperty(java.lang.String)

setTitleProperty

public void setTitleProperty(java.lang.String title)
Set title.

Specified by:
setTitleProperty in interface PackageProperties
See Also:
PackageProperties.setTitleProperty(java.lang.String)

setVersionProperty

public void setVersionProperty(java.lang.String version)
Set version.

Specified by:
setVersionProperty in interface PackageProperties
See Also:
PackageProperties.setVersionProperty(java.lang.String)

getInputStreamImpl

protected java.io.InputStream getInputStreamImpl()
Description copied from class: PackagePart
Abtract method that get the input stream of this part.

Specified by:
getInputStreamImpl in class PackagePart

getOutputStreamImpl

protected java.io.OutputStream getOutputStreamImpl()
Description copied from class: PackagePart
Abstract method that get the output stream of this part.

Specified by:
getOutputStreamImpl in class PackagePart

save

public boolean save(java.io.OutputStream zos)
Description copied from class: PackagePart
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.

Specified by:
save in class PackagePart
Parameters:
zos - Output stream to save this part.

load

public boolean load(java.io.InputStream ios)
Description copied from class: PackagePart
Load the content of this part.

Specified by:
load in class PackagePart
Parameters:
ios - The input stream of the content to load.
Returns:
true if the content has been successfully loaded, else false.

close

public void close()
Description copied from class: PackagePart
Close this part : flush this part, close the input stream and output stream. After this method call, the part must be available for packaging.

Specified by:
close in class PackagePart

flush

public void flush()
Description copied from class: PackagePart
Flush the content of this part. If the input stream and/or output stream as in a waiting state to read or write, the must to empty their respective buffer.

Specified by:
flush in class PackagePart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.apache.poi.openxml4j.opc.internal

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.opc.internal

Interface Summary
PartMarshaller | Object implemented this interface are considered as part marshaller.
PartUnmarshaller | Object implemented this interface are considered as part unmarshaller.

Class Summary
ContentType | Represents a immutable MIME ContentType value (RFC 2616 §3.7)
ContentTypeManager | Manage package content types ([Content_Types].xml part).
FileHelper | Provide useful method to manage file.
MemoryPackagePart | Memory version of a package part.
MemoryPackagePartOutputStream | Build an output stream for MemoryPackagePart.
PackagePropertiesPart | Represents the core properties part of a package.
ZipContentTypeManager | Zip implementation of the ContentTypeManager.
ZipHelper |


org.apache.poi.openxml4j.opc.internal Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.opc.internal

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.openxml4j.opc.internal.ContentType
    • org.apache.poi.openxml4j.opc.internal.ContentTypeManager
      • org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager
    • org.apache.poi.openxml4j.opc.internal.FileHelper
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream
    • org.apache.poi.openxml4j.opc.PackagePart (implements org.apache.poi.openxml4j.opc.RelationshipSource)
      • org.apache.poi.openxml4j.opc.internal.MemoryPackagePart
      • org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart (implements org.apache.poi.openxml4j.opc.PackageProperties)
    • org.apache.poi.openxml4j.opc.internal.ZipHelper

Interface Hierarchy

  • org.apache.poi.openxml4j.opc.internal.PartMarshaller
  • org.apache.poi.openxml4j.opc.internal.PartUnmarshaller


Uses of Package org.apache.poi.openxml4j.opc.internal

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.opc.internal

Packages that use org.apache.poi.openxml4j.opc.internal
org.apache.poi
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.marshallers
org.apache.poi.openxml4j.opc.internal.unmarshallers

Classes in org.apache.poi.openxml4j.opc.internal used by org.apache.poi
PackagePropertiesPart
Represents the core properties part of a package.

Classes in org.apache.poi.openxml4j.opc.internal used by org.apache.poi.openxml4j.opc
ContentType
Represents a immutable MIME ContentType value (RFC 2616 §3.7)
ContentTypeManager
Manage package content types ([Content_Types].xml part).
PackagePropertiesPart
Represents the core properties part of a package.
PartMarshaller
Object implemented this interface are considered as part marshaller.
PartUnmarshaller
Object implemented this interface are considered as part unmarshaller.

Classes in org.apache.poi.openxml4j.opc.internal used by org.apache.poi.openxml4j.opc.internal
ContentTypeManager
Manage package content types ([Content_Types].xml part).
MemoryPackagePart
Memory version of a package part.

Classes in org.apache.poi.openxml4j.opc.internal used by org.apache.poi.openxml4j.opc.internal.marshallers
PartMarshaller
Object implemented this interface are considered as part marshaller.

Classes in org.apache.poi.openxml4j.opc.internal used by org.apache.poi.openxml4j.opc.internal.unmarshallers
PartUnmarshaller
Object implemented this interface are considered as part unmarshaller.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PartMarshaller

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Interface PartMarshaller

All Known Implementing Classes:
DefaultMarshaller, PackagePropertiesMarshaller, ZipPackagePropertiesMarshaller, ZipPartMarshaller
public interface PartMarshaller

Object implemented this interface are considered as part marshaller. A part marshaller is responsible to marshall a part in order to be save in a package.

Version:
0.1
Author:
Julien Chable

Method Summary
 boolean marshall(PackagePart part, java.io.OutputStream out)
Save the content of the package in the stream

Method Detail

marshall

boolean marshall(PackagePart part,
                 java.io.OutputStream out)
                 throws OpenXML4JException
Save the content of the package in the stream

Parameters:
part - Part to marshall.
out - The output stream into which the part will be marshall.
Returns:
false if any marshall error occurs, else true
Throws:
OpenXML4JException - Throws only if any other exceptions are thrown by inner methods.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartUnmarshaller

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Interface PartUnmarshaller

All Known Implementing Classes:
PackagePropertiesUnmarshaller
public interface PartUnmarshaller

Object implemented this interface are considered as part unmarshaller. A part unmarshaller is responsible to unmarshall a part in order to load it from a package.

Version:
0.1
Author:
Julien Chable

Method Summary
 PackagePart unmarshall(UnmarshallContext context, java.io.InputStream in)
Save the content of the package in the stream

Method Detail

unmarshall

PackagePart unmarshall(UnmarshallContext context,
                       java.io.InputStream in)
                       throws InvalidFormatException,
                              java.io.IOException
Save the content of the package in the stream

Parameters:
in - The input stream from which the part will be unmarshall.
Returns:
The part freshly unmarshall from the input stream.
Throws:
OpenXML4JException - Throws only if any other exceptions are thrown by inner methods.
InvalidFormatException
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipContentTypeManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class ZipContentTypeManager

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.ContentTypeManager
        extended by  org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager

public class ZipContentTypeManager
extends ContentTypeManager

Zip implementation of the ContentTypeManager.

Version:
1.0
Author:
Julien Chable
See Also:
ContentTypeManager

Field Summary
Fields inherited from class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
container, CONTENT_TYPES_PART_NAME, TYPES_NAMESPACE_URI
Constructor Summary
ZipContentTypeManager(java.io.InputStream in, OPCPackage pkg)
Delegate constructor to the super constructor.
Method Summary
 boolean saveImpl(org.dom4j.Document content, java.io.OutputStream out)
Specific implementation of the save method.
Methods inherited from class org.apache.poi.openxml4j.opc.internal.ContentTypeManager
addContentType, clearAll, clearOverrideContentTypes, getContentType, isContentTypeRegister, removeContentType, save
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZipContentTypeManager

public ZipContentTypeManager(java.io.InputStream in,
                             OPCPackage pkg)
                      throws InvalidFormatException
Delegate constructor to the super constructor.

Parameters:
in - The input stream to parse to fill internal content type collections.
Throws:
InvalidFormatException - If the content types part content is not valid.
Method Detail

saveImpl

public boolean saveImpl(org.dom4j.Document content,
                        java.io.OutputStream out)
Description copied from class: ContentTypeManager
Specific implementation of the save method. Call by the save() method, call before exiting.

Specified by:
saveImpl in class ContentTypeManager
out - The output stream use to write the content type XML.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal
Class ZipHelper

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.ZipHelper

public final class ZipHelper
extends java.lang.Object

Field Summary
static int READ_WRITE_FILE_BUFFER_SIZE
Buffer to read data from file.
Method Summary
static java.util.zip.ZipEntry | getContentTypeZipEntry(ZipPackage pkg) Retrieve the Zip entry of the content types part.
static java.util.zip.ZipEntry | getCorePropertiesZipEntry(ZipPackage pkg) Retrieve the zip entry of the core properties part.
static java.lang.String | getOPCNameFromZipItemName(java.lang.String zipItemName) Convert a zip name into an OPC name by adding a leading forward slash to the specified item name.
static java.lang.String | getZipItemNameFromOPCName(java.lang.String opcItemName) Convert an OPC item name into a zip item name by removing any leading forward slash if it exist.
static java.net.URI | getZipURIFromOPCName(java.lang.String opcItemName) Convert an OPC item name into a zip URI by removing any leading forward slash if it exist.
static java.util.zip.ZipFile | openZipFile(java.lang.String path) Retrieve and open a zip file with the specified path.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

READ_WRITE_FILE_BUFFER_SIZE

public static final int READ_WRITE_FILE_BUFFER_SIZE
Buffer to read data from file. Use big buffer to improve performaces. the InputStream class is reading only 8192 bytes per read call (default value set by sun)

See Also:
Constant Field Values
Method Detail

getCorePropertiesZipEntry

public static java.util.zip.ZipEntry getCorePropertiesZipEntry(ZipPackage pkg)
Retrieve the zip entry of the core properties part.

Throws:
OpenXML4JException - Throws if internal error occurs.

getContentTypeZipEntry

public static java.util.zip.ZipEntry getContentTypeZipEntry(ZipPackage pkg)
Retrieve the Zip entry of the content types part.

getOPCNameFromZipItemName

public static java.lang.String getOPCNameFromZipItemName(java.lang.String zipItemName)
Convert a zip name into an OPC name by adding a leading forward slash to the specified item name.

Parameters:
zipItemName - Zip item name to convert.
Returns:
An OPC compliant name.

getZipItemNameFromOPCName

public static java.lang.String getZipItemNameFromOPCName(java.lang.String opcItemName)
Convert an OPC item name into a zip item name by removing any leading forward slash if it exist.

Parameters:
opcItemName - The OPC item name to convert.
Returns:
A zip item name without any leading slashes.

getZipURIFromOPCName

public static java.net.URI getZipURIFromOPCName(java.lang.String opcItemName)
Convert an OPC item name into a zip URI by removing any leading forward slash if it exist.

Parameters:
opcItemName - The OPC item name to convert.
Returns:
A zip URI without any leading slashes.

openZipFile

public static java.util.zip.ZipFile openZipFile(java.lang.String path)
Retrieve and open a zip file with the specified path.

Parameters:
path - The file path.
Returns:
The zip archive freshly open.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.openxml4j.opc.internal.ContentType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.ContentType

Packages that use ContentType
org.apache.poi.openxml4j.opc

Uses of ContentType in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as ContentType
protected  ContentType PackagePart._contentType
The type of content of this part.

Fields in org.apache.poi.openxml4j.opc with type parameters of type ContentType
protected java.util.Hashtable<ContentType,PartMarshaller> | OPCPackage.partMarshallers Part marshallers by content type.
protected java.util.Hashtable<ContentType,PartUnmarshaller> | OPCPackage.partUnmarshallers Part unmarshallers by content type.

Constructors in org.apache.poi.openxml4j.opc with parameters of type ContentType
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType)
Constructor.
PackagePart(OPCPackage pack, PackagePartName partName, ContentType contentType, boolean loadRelationships)
Constructor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.ContentTypeManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.ContentTypeManager

Packages that use ContentTypeManager
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal

Uses of ContentTypeManager in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as ContentTypeManager
protected  ContentTypeManager OPCPackage.contentTypeManager
Manage parts content types of this package.

Uses of ContentTypeManager in org.apache.poi.openxml4j.opc.internal

Subclasses of ContentTypeManager in org.apache.poi.openxml4j.opc.internal
 class ZipContentTypeManager
Zip implementation of the ContentTypeManager.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.FileHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.FileHelper

No usage of org.apache.poi.openxml4j.opc.internal.FileHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.MemoryPackagePart

Packages that use MemoryPackagePart
org.apache.poi.openxml4j.opc.internal

Uses of MemoryPackagePart in org.apache.poi.openxml4j.opc.internal

Constructors in org.apache.poi.openxml4j.opc.internal with parameters of type MemoryPackagePart
MemoryPackagePartOutputStream(MemoryPackagePart part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream

No usage of org.apache.poi.openxml4j.opc.internal.MemoryPackagePartOutputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.PackagePropertiesPart

Packages that use PackagePropertiesPart
org.apache.poi
org.apache.poi.openxml4j.opc

Uses of PackagePropertiesPart in org.apache.poi

Methods in org.apache.poi that return PackagePropertiesPart
 PackagePropertiesPart POIXMLProperties.CoreProperties.getUnderlyingProperties()

Uses of PackagePropertiesPart in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as PackagePropertiesPart
protected  PackagePropertiesPart OPCPackage.packageProperties
Core package properties.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.openxml4j.opc.internal.PartMarshaller

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.openxml4j.opc.internal.PartMarshaller

Packages that use PartMarshaller
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal.marshallers

Uses of PartMarshaller in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc declared as PartMarshaller
protected  PartMarshaller OPCPackage.defaultPartMarshaller
Default part marshaller.

Fields in org.apache.poi.openxml4j.opc with type parameters of type PartMarshaller
protected  java.util.Hashtable<ContentType,PartMarshaller> OPCPackage.partMarshallers
Part marshallers by content type.

Methods in org.apache.poi.openxml4j.opc with parameters of type PartMarshaller
 void OPCPackage.addMarshaller(java.lang.String contentType, PartMarshaller marshaller)
Add a marshaller.

Uses of PartMarshaller in org.apache.poi.openxml4j.opc.internal.marshallers

Classes in org.apache.poi.openxml4j.opc.internal.marshallers that implement PartMarshaller
class | DefaultMarshaller Default marshaller that specified that the part is responsible to marshall its content.
class | PackagePropertiesMarshaller Package properties marshaller.
class | ZipPackagePropertiesMarshaller Package core properties marshaller specialized for zipped package.
class | ZipPartMarshaller Zip part marshaller.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.openxml4j.opc.internal.PartUnmarshaller

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.openxml4j.opc.internal.PartUnmarshaller

Packages that use PartUnmarshaller
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal.unmarshallers

Uses of PartUnmarshaller in org.apache.poi.openxml4j.opc

Fields in org.apache.poi.openxml4j.opc with type parameters of type PartUnmarshaller
protected  java.util.Hashtable<ContentType,PartUnmarshaller> OPCPackage.partUnmarshallers
Part unmarshallers by content type.

Methods in org.apache.poi.openxml4j.opc with parameters of type PartUnmarshaller
 void OPCPackage.addUnmarshaller(java.lang.String contentType, PartUnmarshaller unmarshaller)
Add an unmarshaller.

Uses of PartUnmarshaller in org.apache.poi.openxml4j.opc.internal.unmarshallers

Classes in org.apache.poi.openxml4j.opc.internal.unmarshallers that implement PartUnmarshaller
 class PackagePropertiesUnmarshaller
Package properties unmarshaller.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager

No usage of org.apache.poi.openxml4j.opc.internal.ZipContentTypeManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.ZipHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.ZipHelper

No usage of org.apache.poi.openxml4j.opc.internal.ZipHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DefaultMarshaller

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.marshallers
Class DefaultMarshaller

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller
All Implemented Interfaces:
PartMarshaller
public final class DefaultMarshaller
extends java.lang.Object
implements PartMarshaller

Default marshaller that specified that the part is responsible to marshall its content.

Version:
1.0
Author:
Julien Chable
See Also:
PartMarshaller

Constructor Summary
DefaultMarshaller()
Method Summary
 boolean marshall(PackagePart part, java.io.OutputStream out)
Save part in the output stream by using the save() method of the part.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultMarshaller

public DefaultMarshaller()
Method Detail

marshall

public boolean marshall(PackagePart part,
                        java.io.OutputStream out)
                 throws OpenXML4JException
Save part in the output stream by using the save() method of the part.

Specified by:
marshall in interface PartMarshaller
Parameters:
part - Part to marshall.
out - The output stream into which the part will be marshall.
Returns:
false if any marshall error occurs, else true
Throws:
OpenXML4JException - If any error occur.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.openxml4j.opc.internal.marshallers
Classes
DefaultMarshaller
PackagePropertiesMarshaller
ZipPackagePropertiesMarshaller
ZipPartMarshaller


PackagePropertiesMarshaller

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.marshallers
Class PackagePropertiesMarshaller

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller
All Implemented Interfaces:
PartMarshaller
Direct Known Subclasses:
ZipPackagePropertiesMarshaller
public class PackagePropertiesMarshaller
extends java.lang.Object
implements PartMarshaller

Package properties marshaller.

Author:
CDubet, Julien Chable

Field Summary
protected static java.lang.String | KEYWORD_CATEGORY
protected static java.lang.String | KEYWORD_CONTENT_STATUS
protected static java.lang.String | KEYWORD_CONTENT_TYPE
protected static java.lang.String | KEYWORD_CREATED
protected static java.lang.String | KEYWORD_CREATOR
protected static java.lang.String | KEYWORD_DESCRIPTION
protected static java.lang.String | KEYWORD_IDENTIFIER
protected static java.lang.String | KEYWORD_KEYWORDS
protected static java.lang.String | KEYWORD_LANGUAGE
protected static java.lang.String | KEYWORD_LAST_MODIFIED_BY
protected static java.lang.String | KEYWORD_LAST_PRINTED
protected static java.lang.String | KEYWORD_MODIFIED
protected static java.lang.String | KEYWORD_REVISION
protected static java.lang.String | KEYWORD_SUBJECT
protected static java.lang.String | KEYWORD_TITLE
protected static java.lang.String | KEYWORD_VERSION
Constructor Summary
PackagePropertiesMarshaller()
Method Summary
 boolean marshall(PackagePart part, java.io.OutputStream out)
Marshall package core properties to an XML document.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

KEYWORD_CATEGORY

protected static final java.lang.String KEYWORD_CATEGORY
See Also:
Constant Field Values

KEYWORD_CONTENT_STATUS

protected static final java.lang.String KEYWORD_CONTENT_STATUS
See Also:
Constant Field Values

KEYWORD_CONTENT_TYPE

protected static final java.lang.String KEYWORD_CONTENT_TYPE
See Also:
Constant Field Values

KEYWORD_CREATED

protected static final java.lang.String KEYWORD_CREATED
See Also:
Constant Field Values

KEYWORD_CREATOR

protected static final java.lang.String KEYWORD_CREATOR
See Also:
Constant Field Values

KEYWORD_DESCRIPTION

protected static final java.lang.String KEYWORD_DESCRIPTION
See Also:
Constant Field Values

KEYWORD_IDENTIFIER

protected static final java.lang.String KEYWORD_IDENTIFIER
See Also:
Constant Field Values

KEYWORD_KEYWORDS

protected static final java.lang.String KEYWORD_KEYWORDS
See Also:
Constant Field Values

KEYWORD_LANGUAGE

protected static final java.lang.String KEYWORD_LANGUAGE
See Also:
Constant Field Values

KEYWORD_LAST_MODIFIED_BY

protected static final java.lang.String KEYWORD_LAST_MODIFIED_BY
See Also:
Constant Field Values

KEYWORD_LAST_PRINTED

protected static final java.lang.String KEYWORD_LAST_PRINTED
See Also:
Constant Field Values

KEYWORD_MODIFIED

protected static final java.lang.String KEYWORD_MODIFIED
See Also:
Constant Field Values

KEYWORD_REVISION

protected static final java.lang.String KEYWORD_REVISION
See Also:
Constant Field Values

KEYWORD_SUBJECT

protected static final java.lang.String KEYWORD_SUBJECT
See Also:
Constant Field Values

KEYWORD_TITLE

protected static final java.lang.String KEYWORD_TITLE
See Also:
Constant Field Values

KEYWORD_VERSION

protected static final java.lang.String KEYWORD_VERSION
See Also:
Constant Field Values
Constructor Detail

PackagePropertiesMarshaller

public PackagePropertiesMarshaller()
Method Detail

marshall

public boolean marshall(PackagePart part,
                        java.io.OutputStream out)
                 throws OpenXML4JException
Marshall package core properties to an XML document. Always return true.

Specified by:
marshall in interface PartMarshaller
Parameters:
part - Part to marshall.
out - The output stream into which the part will be marshall.
Returns:
false if any marshall error occurs, else true
Throws:
OpenXML4JException - Throws only if any other exceptions are thrown by inner methods.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.apache.poi.openxml4j.opc.internal.marshallers

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.opc.internal.marshallers

Class Summary
DefaultMarshaller | Default marshaller that specified that the part is responsible to marshall its content.
PackagePropertiesMarshaller | Package properties marshaller.
ZipPackagePropertiesMarshaller | Package core properties marshaller specialized for zipped package.
ZipPartMarshaller | Zip part marshaller.


org.apache.poi.openxml4j.opc.internal.marshallers Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.opc.internal.marshallers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller (implements org.apache.poi.openxml4j.opc.internal.PartMarshaller)
    • org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller (implements org.apache.poi.openxml4j.opc.internal.PartMarshaller)
      • org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller
    • org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller (implements org.apache.poi.openxml4j.opc.internal.PartMarshaller)


Uses of Package org.apache.poi.openxml4j.opc.internal.marshallers

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.opc.internal.marshallers

Packages that use org.apache.poi.openxml4j.opc.internal.marshallers
org.apache.poi.openxml4j.opc.internal.marshallers

Classes in org.apache.poi.openxml4j.opc.internal.marshallers used by org.apache.poi.openxml4j.opc.internal.marshallers
PackagePropertiesMarshaller
Package properties marshaller.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ZipPackagePropertiesMarshaller

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.marshallers
Class ZipPackagePropertiesMarshaller

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller
        extended by  org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller
All Implemented Interfaces:
PartMarshaller
public final class ZipPackagePropertiesMarshaller
extends PackagePropertiesMarshaller

Package core properties marshaller specialized for zipped package.

Author:
Julien Chable

Field Summary
Fields inherited from class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller
KEYWORD_CATEGORY, KEYWORD_CONTENT_STATUS, KEYWORD_CONTENT_TYPE, KEYWORD_CREATED, KEYWORD_CREATOR, KEYWORD_DESCRIPTION, KEYWORD_IDENTIFIER, KEYWORD_KEYWORDS, KEYWORD_LANGUAGE, KEYWORD_LAST_MODIFIED_BY, KEYWORD_LAST_PRINTED, KEYWORD_MODIFIED, KEYWORD_REVISION, KEYWORD_SUBJECT, KEYWORD_TITLE, KEYWORD_VERSION
Constructor Summary
ZipPackagePropertiesMarshaller()
Method Summary
 boolean marshall(PackagePart part, java.io.OutputStream out)
Marshall package core properties to an XML document.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZipPackagePropertiesMarshaller

public ZipPackagePropertiesMarshaller()
Method Detail

marshall

public boolean marshall(PackagePart part,
                        java.io.OutputStream out)
                 throws OpenXML4JException
Description copied from class: PackagePropertiesMarshaller
Marshall package core properties to an XML document. Always return true.

Specified by:
marshall in interface PartMarshaller
Overrides:
marshall in class PackagePropertiesMarshaller
Parameters:
part - Part to marshall.
out - The output stream into which the part will be marshall.
Returns:
false if any marshall error occurs, else true
Throws:
OpenXML4JException - Throws only if any other exceptions are thrown by inner methods.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipPartMarshaller

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.marshallers
Class ZipPartMarshaller

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller
All Implemented Interfaces:
PartMarshaller
public final class ZipPartMarshaller
extends java.lang.Object
implements PartMarshaller

Zip part marshaller. This marshaller is use to save any part in a zip stream.

Author:
Julien Chable

Constructor Summary
ZipPartMarshaller()
Method Summary
boolean | marshall(PackagePart part, java.io.OutputStream os) Save the specified part.
static boolean | marshallRelationshipPart(PackageRelationshipCollection rels, PackagePartName relPartName, java.util.zip.ZipOutputStream zos) Save relationships into the part.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZipPartMarshaller

public ZipPartMarshaller()
Method Detail

marshall

public boolean marshall(PackagePart part,
                        java.io.OutputStream os)
                 throws OpenXML4JException
Save the specified part.

Specified by:
marshall in interface PartMarshaller
Parameters:
part - Part to marshall.
os - The output stream into which the part will be marshall.
Returns:
false if any marshall error occurs, else true
Throws:
OpenXML4JException - Throws if an internal exception is thrown.

marshallRelationshipPart

public static boolean marshallRelationshipPart(PackageRelationshipCollection rels,
                                               PackagePartName relPartName,
                                               java.util.zip.ZipOutputStream zos)
Save relationships into the part.

Parameters:
rels - The relationships collection to marshall.
relPartName - Part name of the relationship part to marshall.
zos - Zip output stream in which to save the XML content of the relationships serialization.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller

No usage of org.apache.poi.openxml4j.opc.internal.marshallers.DefaultMarshaller

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.marshallers.PackagePropertiesMarshaller

Packages that use PackagePropertiesMarshaller
org.apache.poi.openxml4j.opc.internal.marshallers

Uses of PackagePropertiesMarshaller in org.apache.poi.openxml4j.opc.internal.marshallers

Subclasses of PackagePropertiesMarshaller in org.apache.poi.openxml4j.opc.internal.marshallers
 class ZipPackagePropertiesMarshaller
Package core properties marshaller specialized for zipped package.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller

No usage of org.apache.poi.openxml4j.opc.internal.marshallers.ZipPackagePropertiesMarshaller

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller

No usage of org.apache.poi.openxml4j.opc.internal.marshallers.ZipPartMarshaller

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DigitalCertificatePart

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.signature
Class DigitalCertificatePart

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagePart
        extended by  org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart
All Implemented Interfaces:
RelationshipSource
public final class DigitalCertificatePart
extends PackagePart

Digital certificate part.

Version:
0.1
Author:
Julien Chable

Field Summary
Fields inherited from class org.apache.poi.openxml4j.opc.PackagePart
_container, _contentType, _partName
Constructor Summary
DigitalCertificatePart()
Method Summary
void | close() Close this part : flush this part, close the input stream and output stream.
void | flush() Flush the content of this part.
protected java.io.InputStream | getInputStreamImpl() Abtract method that get the input stream of this part.
protected java.io.OutputStream | getOutputStreamImpl() Abstract method that get the output stream of this part.
boolean | load(java.io.InputStream ios) Load the content of this part.
boolean | save(java.io.OutputStream zos) Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.
Methods inherited from class org.apache.poi.openxml4j.opc.PackagePart
addExternalRelationship, addExternalRelationship, addRelationship, addRelationship, addRelationship, addRelationship, clearRelationships, getContentType, getInputStream, getOutputStream, getPackage, getPartName, getRelatedPart, getRelationship, getRelationships, getRelationshipsByType, hasRelationships, isDeleted, isRelationshipExists, isRelationshipPart, removeRelationship, setContentType, setDeleted, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DigitalCertificatePart

public DigitalCertificatePart()
                       throws InvalidFormatException
Throws:
InvalidFormatException
Method Detail

close

public void close()
Description copied from class: PackagePart
Close this part : flush this part, close the input stream and output stream. After this method call, the part must be available for packaging.

Specified by:
close in class PackagePart

flush

public void flush()
Description copied from class: PackagePart
Flush the content of this part. If the input stream and/or output stream as in a waiting state to read or write, the must to empty their respective buffer.

Specified by:
flush in class PackagePart

getInputStreamImpl

protected java.io.InputStream getInputStreamImpl()
                                          throws java.io.IOException
Description copied from class: PackagePart
Abtract method that get the input stream of this part.

Specified by:
getInputStreamImpl in class PackagePart
Throws:
java.io.IOException - Throws if an IO Exception occur in the implementation method.

getOutputStreamImpl

protected java.io.OutputStream getOutputStreamImpl()
Description copied from class: PackagePart
Abstract method that get the output stream of this part.

Specified by:
getOutputStreamImpl in class PackagePart

load

public boolean load(java.io.InputStream ios)
             throws InvalidFormatException
Description copied from class: PackagePart
Load the content of this part.

Specified by:
load in class PackagePart
Parameters:
ios - The input stream of the content to load.
Returns:
true if the content has been successfully loaded, else false.
Throws:
InvalidFormatException - Throws if the content format is invalid.

save

public boolean save(java.io.OutputStream zos)
             throws OpenXML4JException
Description copied from class: PackagePart
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.

Specified by:
save in class PackagePart
Parameters:
zos - Output stream to save this part.
Throws:
OpenXML4JException - If any exception occur.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DigitalSignatureOriginPart

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.signature
Class DigitalSignatureOriginPart

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.signature.DigitalSignatureOriginPart

public final class DigitalSignatureOriginPart
extends java.lang.Object

Represents a digital signature origin part.

Version:
0.1
Author:
Julien Chable

Constructor Summary
DigitalSignatureOriginPart()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DigitalSignatureOriginPart

public DigitalSignatureOriginPart()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.openxml4j.opc.internal.signature
Classes
DigitalCertificatePart
DigitalSignatureOriginPart


org.apache.poi.openxml4j.opc.internal.signature

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.opc.internal.signature

Class Summary
DigitalCertificatePart | Digital certificate part.
DigitalSignatureOriginPart | Represents a digital signature origin part.


org.apache.poi.openxml4j.opc.internal.signature Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.opc.internal.signature

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.openxml4j.opc.internal.signature.DigitalSignatureOriginPart
    • org.apache.poi.openxml4j.opc.PackagePart (implements org.apache.poi.openxml4j.opc.RelationshipSource)
      • org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart


Uses of Package org.apache.poi.openxml4j.opc.internal.signature

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.opc.internal.signature

No usage of org.apache.poi.openxml4j.opc.internal.signature

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

No usage of org.apache.poi.openxml4j.opc.internal.signature.DigitalCertificatePart

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.signature.DigitalSignatureOriginPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.signature.DigitalSignatureOriginPart

No usage of org.apache.poi.openxml4j.opc.internal.signature.DigitalSignatureOriginPart

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.openxml4j.opc.internal.unmarshallers
Classes
PackagePropertiesUnmarshaller
UnmarshallContext


PackagePropertiesUnmarshaller

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.unmarshallers
Class PackagePropertiesUnmarshaller

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller
All Implemented Interfaces:
PartUnmarshaller
public final class PackagePropertiesUnmarshaller
extends java.lang.Object
implements PartUnmarshaller

Package properties unmarshaller.

Author:
Julien Chable

Field Summary
protected static java.lang.String | KEYWORD_CATEGORY
protected static java.lang.String | KEYWORD_CONTENT_STATUS
protected static java.lang.String | KEYWORD_CONTENT_TYPE
protected static java.lang.String | KEYWORD_CREATED
protected static java.lang.String | KEYWORD_CREATOR
protected static java.lang.String | KEYWORD_DESCRIPTION
protected static java.lang.String | KEYWORD_IDENTIFIER
protected static java.lang.String | KEYWORD_KEYWORDS
protected static java.lang.String | KEYWORD_LANGUAGE
protected static java.lang.String | KEYWORD_LAST_MODIFIED_BY
protected static java.lang.String | KEYWORD_LAST_PRINTED
protected static java.lang.String | KEYWORD_MODIFIED
protected static java.lang.String | KEYWORD_REVISION
protected static java.lang.String | KEYWORD_SUBJECT
protected static java.lang.String | KEYWORD_TITLE
protected static java.lang.String | KEYWORD_VERSION
Constructor Summary
PackagePropertiesUnmarshaller()
Method Summary
void | checkElementForOPCCompliance(org.dom4j.Element el) Check the element for the following OPC compliance rules:
PackagePart | unmarshall(UnmarshallContext context, java.io.InputStream in) Save the content of the package in the stream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

KEYWORD_CATEGORY

protected static final java.lang.String KEYWORD_CATEGORY
See Also:
Constant Field Values

KEYWORD_CONTENT_STATUS

protected static final java.lang.String KEYWORD_CONTENT_STATUS
See Also:
Constant Field Values

KEYWORD_CONTENT_TYPE

protected static final java.lang.String KEYWORD_CONTENT_TYPE
See Also:
Constant Field Values

KEYWORD_CREATED

protected static final java.lang.String KEYWORD_CREATED
See Also:
Constant Field Values

KEYWORD_CREATOR

protected static final java.lang.String KEYWORD_CREATOR
See Also:
Constant Field Values

KEYWORD_DESCRIPTION

protected static final java.lang.String KEYWORD_DESCRIPTION
See Also:
Constant Field Values

KEYWORD_IDENTIFIER

protected static final java.lang.String KEYWORD_IDENTIFIER
See Also:
Constant Field Values

KEYWORD_KEYWORDS

protected static final java.lang.String KEYWORD_KEYWORDS
See Also:
Constant Field Values

KEYWORD_LANGUAGE

protected static final java.lang.String KEYWORD_LANGUAGE
See Also:
Constant Field Values

KEYWORD_LAST_MODIFIED_BY

protected static final java.lang.String KEYWORD_LAST_MODIFIED_BY
See Also:
Constant Field Values

KEYWORD_LAST_PRINTED

protected static final java.lang.String KEYWORD_LAST_PRINTED
See Also:
Constant Field Values

KEYWORD_MODIFIED

protected static final java.lang.String KEYWORD_MODIFIED
See Also:
Constant Field Values

KEYWORD_REVISION

protected static final java.lang.String KEYWORD_REVISION
See Also:
Constant Field Values

KEYWORD_SUBJECT

protected static final java.lang.String KEYWORD_SUBJECT
See Also:
Constant Field Values

KEYWORD_TITLE

protected static final java.lang.String KEYWORD_TITLE
See Also:
Constant Field Values

KEYWORD_VERSION

protected static final java.lang.String KEYWORD_VERSION
See Also:
Constant Field Values
Constructor Detail

PackagePropertiesUnmarshaller

public PackagePropertiesUnmarshaller()
Method Detail

unmarshall

public PackagePart unmarshall(UnmarshallContext context,
                              java.io.InputStream in)
                       throws InvalidFormatException,
                              java.io.IOException
Description copied from interface: PartUnmarshaller
Save the content of the package in the stream

Specified by:
unmarshall in interface PartUnmarshaller
in - The input stream from which the part will be unmarshall.
Returns:
The part freshly unmarshall from the input stream.
Throws:
InvalidFormatException
java.io.IOException

checkElementForOPCCompliance

public void checkElementForOPCCompliance(org.dom4j.Element el)
                                  throws InvalidFormatException
Check the element for the following OPC compliance rules:

Rule M4.2: A format consumer shall consider the use of the Markup Compatibility namespace to be an error.

Rule M4.3: Producers shall not create a document element that contains refinements to the Dublin Core elements, except for the two specified in the schema: and Consumers shall consider a document element that violates this constraint to be an error.

Rule M4.4: Producers shall not create a document element that contains the xml:lang attribute. Consumers shall consider a document element that violates this constraint to be an error.

Rule M4.5: Producers shall not create a document element that contains the xsi:type attribute, except for a or element where the xsi:type attribute shall be present and shall hold the value dcterms:W3CDTF, where dcterms is the namespace prefix of the Dublin Core namespace. Consumers shall consider a document element that violates this constraint to be an error.

Throws:
InvalidFormatException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.poi.openxml4j.opc.internal.unmarshallers

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.opc.internal.unmarshallers

Class Summary
PackagePropertiesUnmarshaller | Package properties unmarshaller.
UnmarshallContext | Context needed for the unmarshall process of a part.


org.apache.poi.openxml4j.opc.internal.unmarshallers Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.opc.internal.unmarshallers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller (implements org.apache.poi.openxml4j.opc.internal.PartUnmarshaller)
    • org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext


Uses of Package org.apache.poi.openxml4j.opc.internal.unmarshallers

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.opc.internal.unmarshallers

Packages that use org.apache.poi.openxml4j.opc.internal.unmarshallers
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.unmarshallers

Classes in org.apache.poi.openxml4j.opc.internal.unmarshallers used by org.apache.poi.openxml4j.opc.internal
UnmarshallContext
Context needed for the unmarshall process of a part.

Classes in org.apache.poi.openxml4j.opc.internal.unmarshallers used by org.apache.poi.openxml4j.opc.internal.unmarshallers
UnmarshallContext
Context needed for the unmarshall process of a part.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


UnmarshallContext

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.internal.unmarshallers
Class UnmarshallContext

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext

public final class UnmarshallContext
extends java.lang.Object

Context needed for the unmarshall process of a part. This class is immutable.

Version:
1.0
Author:
Julien Chable

Constructor Summary
UnmarshallContext(OPCPackage targetPackage, PackagePartName partName)
Constructor.
Method Summary
void | setPackage(OPCPackage container)
void | setPartName(PackagePartName partName)
void | setZipEntry(java.util.zip.ZipEntry zipEntry)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnmarshallContext

public UnmarshallContext(OPCPackage targetPackage,
                         PackagePartName partName)
Constructor.

Parameters:
targetPackage - Container.
partName - Name of the part to unmarshall.
Method Detail

setPackage

public void setPackage(OPCPackage container)
Parameters:
container - the container to set

setPartName

public void setPartName(PackagePartName partName)
Parameters:
partName - the partName to set

setZipEntry

public void setZipEntry(java.util.zip.ZipEntry zipEntry)
Parameters:
zipEntry - the zipEntry to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

No usage of org.apache.poi.openxml4j.opc.internal.unmarshallers.PackagePropertiesUnmarshaller

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.internal.unmarshallers.UnmarshallContext

Packages that use UnmarshallContext
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.opc.internal.unmarshallers

Uses of UnmarshallContext in org.apache.poi.openxml4j.opc.internal

Methods in org.apache.poi.openxml4j.opc.internal with parameters of type UnmarshallContext
 PackagePart PartUnmarshaller.unmarshall(UnmarshallContext context, java.io.InputStream in)
Save the content of the package in the stream

Uses of UnmarshallContext in org.apache.poi.openxml4j.opc.internal.unmarshallers

Methods in org.apache.poi.openxml4j.opc.internal.unmarshallers with parameters of type UnmarshallContext
 PackagePart PackagePropertiesUnmarshaller.unmarshall(UnmarshallContext context, java.io.InputStream in)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PackageDigitalSignature

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.signature
Class PackageDigitalSignature

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.PackagePart
        extended by  org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature
All Implemented Interfaces:
RelationshipSource
public final class PackageDigitalSignature
extends PackagePart

Field Summary
Fields inherited from class org.apache.poi.openxml4j.opc.PackagePart
_container, _contentType, _partName
Constructor Summary
PackageDigitalSignature()
Method Summary
void | close() Close this part : flush this part, close the input stream and output stream.
void | flush() Flush the content of this part.
protected java.io.InputStream | getInputStreamImpl() Abtract method that get the input stream of this part.
protected java.io.OutputStream | getOutputStreamImpl() Abstract method that get the output stream of this part.
boolean | load(java.io.InputStream ios) Load the content of this part.
boolean | save(java.io.OutputStream zos) Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.
Methods inherited from class org.apache.poi.openxml4j.opc.PackagePart
addExternalRelationship, addExternalRelationship, addRelationship, addRelationship, addRelationship, addRelationship, clearRelationships, getContentType, getInputStream, getOutputStream, getPackage, getPartName, getRelatedPart, getRelationship, getRelationships, getRelationshipsByType, hasRelationships, isDeleted, isRelationshipExists, isRelationshipPart, removeRelationship, setContentType, setDeleted, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PackageDigitalSignature

public PackageDigitalSignature()
                        throws InvalidFormatException
Throws:
InvalidFormatException
Method Detail

close

public void close()
Description copied from class: PackagePart
Close this part : flush this part, close the input stream and output stream. After this method call, the part must be available for packaging.

Specified by:
close in class PackagePart

flush

public void flush()
Description copied from class: PackagePart
Flush the content of this part. If the input stream and/or output stream as in a waiting state to read or write, the must to empty their respective buffer.

Specified by:
flush in class PackagePart

getInputStreamImpl

protected java.io.InputStream getInputStreamImpl()
                                          throws java.io.IOException
Description copied from class: PackagePart
Abtract method that get the input stream of this part.

Specified by:
getInputStreamImpl in class PackagePart
Throws:
java.io.IOException - Throws if an IO Exception occur in the implementation method.

getOutputStreamImpl

protected java.io.OutputStream getOutputStreamImpl()
Description copied from class: PackagePart
Abstract method that get the output stream of this part.

Specified by:
getOutputStreamImpl in class PackagePart

load

public boolean load(java.io.InputStream ios)
             throws InvalidFormatException
Description copied from class: PackagePart
Load the content of this part.

Specified by:
load in class PackagePart
Parameters:
ios - The input stream of the content to load.
Returns:
true if the content has been successfully loaded, else false.
Throws:
InvalidFormatException - Throws if the content format is invalid.

save

public boolean save(java.io.OutputStream zos)
             throws OpenXML4JException
Description copied from class: PackagePart
Save the content of this part and the associated relationships part (if this part own at least one relationship) into the specified output stream.

Specified by:
save in class PackagePart
Parameters:
zos - Output stream to save this part.
Throws:
OpenXML4JException - If any exception occur.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PackageDigitalSignatureManager

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.opc.signature
Class PackageDigitalSignatureManager

java.lang.Object
    extended by  org.apache.poi.openxml4j.opc.signature.PackageDigitalSignatureManager

public final class PackageDigitalSignatureManager
extends java.lang.Object

Constructor Summary
PackageDigitalSignatureManager()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PackageDigitalSignatureManager

public PackageDigitalSignatureManager()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.openxml4j.opc.signature
Classes
PackageDigitalSignature
PackageDigitalSignatureManager


org.apache.poi.openxml4j.opc.signature

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.opc.signature

Class Summary
PackageDigitalSignature
PackageDigitalSignatureManager


org.apache.poi.openxml4j.opc.signature Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.opc.signature

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.openxml4j.opc.signature.PackageDigitalSignatureManager
    • org.apache.poi.openxml4j.opc.PackagePart (implements org.apache.poi.openxml4j.opc.RelationshipSource)
      • org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature


Uses of Package org.apache.poi.openxml4j.opc.signature

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.opc.signature

No usage of org.apache.poi.openxml4j.opc.signature

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

No usage of org.apache.poi.openxml4j.opc.signature.PackageDigitalSignature

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.opc.signature.PackageDigitalSignatureManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.opc.signature.PackageDigitalSignatureManager

No usage of org.apache.poi.openxml4j.opc.signature.PackageDigitalSignatureManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Nullable

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.util
Class Nullable<E>

java.lang.Object
    extended by  org.apache.poi.openxml4j.util.Nullable<E>

public final class Nullable<E>
extends java.lang.Object

An immutable object that could be defined as null.

Version:
0.9
Author:
Julien Chable

Constructor Summary
Nullable()
Constructor.
Nullable(E value)
Constructor.
Method Summary
E | getValue() Get the store value if any.
boolean | hasValue() Get the status of this nullable.
void | nullify() Set the stored value to null.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Nullable

public Nullable()
Constructor.

Nullable

public Nullable(E value)
Constructor.

Parameters:
value - The value to set to this nullable.
Method Detail

getValue

public E getValue()
Get the store value if any.

Returns:
the store value

hasValue

public boolean hasValue()
Get the status of this nullable.

Returns:
true if the nullable store a value (empty string is considered to be a value) else false.

nullify

public void nullify()
Set the stored value to null.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.openxml4j.util
Interfaces
ZipEntrySource
Classes
Nullable
ZipFileZipEntrySource
ZipInputStreamZipEntrySource
ZipInputStreamZipEntrySource.FakeZipEntry


org.apache.poi.openxml4j.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.openxml4j.util

Interface Summary
ZipEntrySource An Interface to make getting the different bits of a Zip File easy.

Class Summary
Nullable<E> | An immutable object that could be defined as null.
ZipFileZipEntrySource | A ZipEntrySource wrapper around a ZipFile.
ZipInputStreamZipEntrySource | Provides a way to get at all the ZipEntries from a ZipInputStream, as many times as required.
ZipInputStreamZipEntrySource.FakeZipEntry | So we can close the real zip entry and still effectively work with it.


org.apache.poi.openxml4j.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.openxml4j.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.openxml4j.util.Nullable<E>
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
      • org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry
    • org.apache.poi.openxml4j.util.ZipFileZipEntrySource (implements org.apache.poi.openxml4j.util.ZipEntrySource)
    • org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource (implements org.apache.poi.openxml4j.util.ZipEntrySource)

Interface Hierarchy

  • org.apache.poi.openxml4j.util.ZipEntrySource


Uses of Package org.apache.poi.openxml4j.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.openxml4j.util

Packages that use org.apache.poi.openxml4j.util
org.apache.poi
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal
org.apache.poi.openxml4j.util

Classes in org.apache.poi.openxml4j.util used by org.apache.poi
Nullable
An immutable object that could be defined as null.

Classes in org.apache.poi.openxml4j.util used by org.apache.poi.openxml4j.opc
Nullable
An immutable object that could be defined as null.
ZipEntrySource
An Interface to make getting the different bits of a Zip File easy.

Classes in org.apache.poi.openxml4j.util used by org.apache.poi.openxml4j.opc.internal
Nullable
An immutable object that could be defined as null.

Classes in org.apache.poi.openxml4j.util used by org.apache.poi.openxml4j.util
ZipEntrySource
An Interface to make getting the different bits of a Zip File easy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ZipEntrySource

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.util
Interface ZipEntrySource

All Known Implementing Classes:
ZipFileZipEntrySource, ZipInputStreamZipEntrySource
public interface ZipEntrySource

An Interface to make getting the different bits of a Zip File easy. Allows you to get at the ZipEntries, without needing to worry about ZipFile vs ZipInputStream being annoyingly very different.

Method Summary
void | close() Indicates we are done with reading, and resources may be freed
java.util.Enumeration<? extends java.util.zip.ZipEntry> | getEntries() Returns an Enumeration of all the Entries
java.io.InputStream | getInputStream(java.util.zip.ZipEntry entry) Returns an InputStream of the decompressed data that makes up the entry

Method Detail

getEntries

java.util.Enumeration<? extends java.util.zip.ZipEntry> getEntries()
Returns an Enumeration of all the Entries

getInputStream

java.io.InputStream getInputStream(java.util.zip.ZipEntry entry)
                                   throws java.io.IOException
Returns an InputStream of the decompressed data that makes up the entry

Throws:
java.io.IOException

close

void close()
           throws java.io.IOException
Indicates we are done with reading, and resources may be freed

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipFileZipEntrySource

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.util
Class ZipFileZipEntrySource

java.lang.Object
    extended by  org.apache.poi.openxml4j.util.ZipFileZipEntrySource
All Implemented Interfaces:
ZipEntrySource
public class ZipFileZipEntrySource
extends java.lang.Object
implements ZipEntrySource

A ZipEntrySource wrapper around a ZipFile. Should be as low in terms of memory as a normal ZipFile implementation is.

Constructor Summary
ZipFileZipEntrySource(java.util.zip.ZipFile zipFile)
Method Summary
void | close() Indicates we are done with reading, and resources may be freed
java.util.Enumeration<? extends java.util.zip.ZipEntry> | getEntries() Returns an Enumeration of all the Entries
java.io.InputStream | getInputStream(java.util.zip.ZipEntry entry) Returns an InputStream of the decompressed data that makes up the entry
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZipFileZipEntrySource

public ZipFileZipEntrySource(java.util.zip.ZipFile zipFile)
Method Detail

close

public void close()
           throws java.io.IOException
Description copied from interface: ZipEntrySource
Indicates we are done with reading, and resources may be freed

Specified by:
close in interface ZipEntrySource
Throws:
java.io.IOException

getEntries

public java.util.Enumeration<? extends java.util.zip.ZipEntry> getEntries()
Description copied from interface: ZipEntrySource
Returns an Enumeration of all the Entries

Specified by:
getEntries in interface ZipEntrySource

getInputStream

public java.io.InputStream getInputStream(java.util.zip.ZipEntry entry)
                                   throws java.io.IOException
Description copied from interface: ZipEntrySource
Returns an InputStream of the decompressed data that makes up the entry

Specified by:
getInputStream in interface ZipEntrySource
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipInputStreamZipEntrySource.FakeZipEntry

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.util
Class ZipInputStreamZipEntrySource.FakeZipEntry

java.lang.Object
    extended by  java.util.zip.ZipEntry
        extended by  org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry
All Implemented Interfaces:
java.lang.Cloneable
Enclosing class:
ZipInputStreamZipEntrySource
public static class ZipInputStreamZipEntrySource.FakeZipEntry
extends java.util.zip.ZipEntry

So we can close the real zip entry and still effectively work with it. Holds the (decompressed!) data in memory, so close this as soon as you can!

Field Summary
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
Fields inherited from class java.util.zip.ZipEntry
DEFLATED, STORED
Constructor Summary
ZipInputStreamZipEntrySource.FakeZipEntry(java.util.zip.ZipEntry entry, java.util.zip.ZipInputStream inp)
Method Summary
 java.io.InputStream getInputStream()
Methods inherited from class java.util.zip.ZipEntry
clone, getComment, getCompressedSize, getCrc, getExtra, getMethod, getName, getSize, getTime, hashCode, isDirectory, setComment, setCompressedSize, setCrc, setExtra, setMethod, setSize, setTime, toString
Methods inherited from class java.lang.Object
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

LOCSIG

public static final long LOCSIG
See Also:
Constant Field Values

EXTSIG

public static final long EXTSIG
See Also:
Constant Field Values

CENSIG

public static final long CENSIG
See Also:
Constant Field Values

ENDSIG

public static final long ENDSIG
See Also:
Constant Field Values

LOCHDR

public static final int LOCHDR
See Also:
Constant Field Values

EXTHDR

public static final int EXTHDR
See Also:
Constant Field Values

CENHDR

public static final int CENHDR
See Also:
Constant Field Values

ENDHDR

public static final int ENDHDR
See Also:
Constant Field Values

LOCVER

public static final int LOCVER
See Also:
Constant Field Values

LOCFLG

public static final int LOCFLG
See Also:
Constant Field Values

LOCHOW

public static final int LOCHOW
See Also:
Constant Field Values

LOCTIM

public static final int LOCTIM
See Also:
Constant Field Values

LOCCRC

public static final int LOCCRC
See Also:
Constant Field Values

LOCSIZ

public static final int LOCSIZ
See Also:
Constant Field Values

LOCLEN

public static final int LOCLEN
See Also:
Constant Field Values

LOCNAM

public static final int LOCNAM
See Also:
Constant Field Values

LOCEXT

public static final int LOCEXT
See Also:
Constant Field Values

EXTCRC

public static final int EXTCRC
See Also:
Constant Field Values

EXTSIZ

public static final int EXTSIZ
See Also:
Constant Field Values

EXTLEN

public static final int EXTLEN
See Also:
Constant Field Values

CENVEM

public static final int CENVEM
See Also:
Constant Field Values

CENVER

public static final int CENVER
See Also:
Constant Field Values

CENFLG

public static final int CENFLG
See Also:
Constant Field Values

CENHOW

public static final int CENHOW
See Also:
Constant Field Values

CENTIM

public static final int CENTIM
See Also:
Constant Field Values

CENCRC

public static final int CENCRC
See Also:
Constant Field Values

CENSIZ

public static final int CENSIZ
See Also:
Constant Field Values

CENLEN

public static final int CENLEN
See Also:
Constant Field Values

CENNAM

public static final int CENNAM
See Also:
Constant Field Values

CENEXT

public static final int CENEXT
See Also:
Constant Field Values

CENCOM

public static final int CENCOM
See Also:
Constant Field Values

CENDSK

public static final int CENDSK
See Also:
Constant Field Values

CENATT

public static final int CENATT
See Also:
Constant Field Values

CENATX

public static final int CENATX
See Also:
Constant Field Values

CENOFF

public static final int CENOFF
See Also:
Constant Field Values

ENDSUB

public static final int ENDSUB
See Also:
Constant Field Values

ENDTOT

public static final int ENDTOT
See Also:
Constant Field Values

ENDSIZ

public static final int ENDSIZ
See Also:
Constant Field Values

ENDOFF

public static final int ENDOFF
See Also:
Constant Field Values

ENDCOM

public static final int ENDCOM
See Also:
Constant Field Values
Constructor Detail

ZipInputStreamZipEntrySource.FakeZipEntry

public ZipInputStreamZipEntrySource.FakeZipEntry(java.util.zip.ZipEntry entry,
                                                 java.util.zip.ZipInputStream inp)
                                          throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getInputStream

public java.io.InputStream getInputStream()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ZipInputStreamZipEntrySource

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.openxml4j.util
Class ZipInputStreamZipEntrySource

java.lang.Object
    extended by  org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource
All Implemented Interfaces:
ZipEntrySource
public class ZipInputStreamZipEntrySource
extends java.lang.Object
implements ZipEntrySource

Provides a way to get at all the ZipEntries from a ZipInputStream, as many times as required. Allows a ZipInputStream to be treated much like a ZipFile, for a price in terms of memory. Be sure to call close() as soon as you're done, to free up that memory!

Nested Class Summary
static class ZipInputStreamZipEntrySource.FakeZipEntry
So we can close the real zip entry and still effectively work with it.
Constructor Summary
ZipInputStreamZipEntrySource(java.util.zip.ZipInputStream inp)
Reads all the entries from the ZipInputStream into memory, and closes the source stream.
Method Summary
void | close() Indicates we are done with reading, and resources may be freed
java.util.Enumeration<? extends java.util.zip.ZipEntry> | getEntries() Returns an Enumeration of all the Entries
java.io.InputStream | getInputStream(java.util.zip.ZipEntry zipEntry) Returns an InputStream of the decompressed data that makes up the entry
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZipInputStreamZipEntrySource

public ZipInputStreamZipEntrySource(java.util.zip.ZipInputStream inp)
                             throws java.io.IOException
Reads all the entries from the ZipInputStream into memory, and closes the source stream. We'll then eat lots of memory, but be able to work with the entries at-will.

Throws:
java.io.IOException
Method Detail

getEntries

public java.util.Enumeration<? extends java.util.zip.ZipEntry> getEntries()
Description copied from interface: ZipEntrySource
Returns an Enumeration of all the Entries

Specified by:
getEntries in interface ZipEntrySource

getInputStream

public java.io.InputStream getInputStream(java.util.zip.ZipEntry zipEntry)
Description copied from interface: ZipEntrySource
Returns an InputStream of the decompressed data that makes up the entry

Specified by:
getInputStream in interface ZipEntrySource

close

public void close()
Description copied from interface: ZipEntrySource
Indicates we are done with reading, and resources may be freed

Specified by:
close in interface ZipEntrySource
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.openxml4j.util.Nullable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.util.Nullable

Packages that use Nullable
org.apache.poi
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.opc.internal

Uses of Nullable in org.apache.poi

Methods in org.apache.poi with parameters of type Nullable
void | POIXMLProperties.CoreProperties.setCreated(Nullable<java.util.Date> date)
void | POIXMLProperties.CoreProperties.setLastPrinted(Nullable<java.util.Date> date)
void | POIXMLProperties.CoreProperties.setModified(Nullable<java.util.Date> date)

Uses of Nullable in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return Nullable
Nullable<java.lang.String> | PackageProperties.getCategoryProperty() Set the category of the content of this package.
Nullable<java.lang.String> | PackageProperties.getContentStatusProperty() Set the status of the content.
Nullable<java.lang.String> | PackageProperties.getContentTypeProperty() Get the type of content represented, generally defined by a specific use and intended audience.
Nullable<java.util.Date> | PackageProperties.getCreatedProperty() Get the date of creation of the resource.
Nullable<java.lang.String> | PackageProperties.getCreatorProperty() Get the entity primarily responsible for making the content of the resource.
Nullable<java.lang.String> | PackageProperties.getDescriptionProperty() Get the explanation of the content of the resource.
Nullable<java.lang.String> | PackageProperties.getIdentifierProperty() Get an unambiguous reference to the resource within a given context.
Nullable<java.lang.String> | PackageProperties.getKeywordsProperty() Get a delimited set of keywords to support searching and indexing.
Nullable<java.lang.String> | PackageProperties.getLanguageProperty() Get the language of the intellectual content of the resource.
Nullable<java.lang.String> | PackageProperties.getLastModifiedByProperty() Get the user who performed the last modification.
Nullable<java.util.Date> | PackageProperties.getLastPrintedProperty() Get the date and time of the last printing.
Nullable<java.util.Date> | PackageProperties.getModifiedProperty() Get the date on which the resource was changed.
Nullable<java.lang.String> | PackageProperties.getRevisionProperty() Get the revision number.
Nullable<java.lang.String> | PackageProperties.getSubjectProperty() Get the topic of the content of the resource.
Nullable<java.lang.String> | PackageProperties.getTitleProperty() Get the name given to the resource.
Nullable<java.lang.String> | PackageProperties.getVersionProperty() Get the version number.

Methods in org.apache.poi.openxml4j.opc with parameters of type Nullable
void | PackageProperties.setCreatedProperty(Nullable<java.util.Date> created) Set the date of creation of the resource.
void | PackageProperties.setLastPrintedProperty(Nullable<java.util.Date> lastPrinted) Set the date and time of the last printing.
void | PackageProperties.setModifiedProperty(Nullable<java.util.Date> modified) Set the date on which the resource was changed.

Uses of Nullable in org.apache.poi.openxml4j.opc.internal

Fields in org.apache.poi.openxml4j.opc.internal declared as Nullable
protected Nullable<java.lang.String> | PackagePropertiesPart.category A categorization of the content of this package.
protected Nullable<java.lang.String> | PackagePropertiesPart.contentStatus The status of the content.
protected Nullable<java.lang.String> | PackagePropertiesPart.contentType The type of content represented, generally defined by a specific use and intended audience.
protected Nullable<java.util.Date> | PackagePropertiesPart.created Date of creation of the resource.
protected Nullable<java.lang.String> | PackagePropertiesPart.creator An entity primarily responsible for making the content of the resource.
protected Nullable<java.lang.String> | PackagePropertiesPart.description An explanation of the content of the resource.
protected Nullable<java.lang.String> | PackagePropertiesPart.identifier An unambiguous reference to the resource within a given context.
protected Nullable<java.lang.String> | PackagePropertiesPart.keywords A delimited set of keywords to support searching and indexing.
protected Nullable<java.lang.String> | PackagePropertiesPart.language The language of the intellectual content of the resource.
protected Nullable<java.lang.String> | PackagePropertiesPart.lastModifiedBy The user who performed the last modification.
protected Nullable<java.util.Date> | PackagePropertiesPart.lastPrinted The date and time of the last printing.
protected Nullable<java.util.Date> | PackagePropertiesPart.modified Date on which the resource was changed.
protected Nullable<java.lang.String> | PackagePropertiesPart.revision The revision number.
protected Nullable<java.lang.String> | PackagePropertiesPart.subject The topic of the content of the resource.
protected Nullable<java.lang.String> | PackagePropertiesPart.title The name given to the resource.
protected Nullable<java.lang.String> | PackagePropertiesPart.version The version number.

Methods in org.apache.poi.openxml4j.opc.internal that return Nullable
Nullable<java.lang.String> | PackagePropertiesPart.getCategoryProperty() Get the category property.
Nullable<java.lang.String> | PackagePropertiesPart.getContentStatusProperty() Get content status.
Nullable<java.lang.String> | PackagePropertiesPart.getContentTypeProperty() Get content type.
Nullable<java.util.Date> | PackagePropertiesPart.getCreatedProperty() Get created date.
Nullable<java.lang.String> | PackagePropertiesPart.getCreatorProperty() Get creator.
Nullable<java.lang.String> | PackagePropertiesPart.getDescriptionProperty() Get description.
Nullable<java.lang.String> | PackagePropertiesPart.getIdentifierProperty() Get identifier.
Nullable<java.lang.String> | PackagePropertiesPart.getKeywordsProperty() Get keywords.
Nullable<java.lang.String> | PackagePropertiesPart.getLanguageProperty() Get the language.
Nullable<java.lang.String> | PackagePropertiesPart.getLastModifiedByProperty() Get the author of last modifications.
Nullable<java.util.Date> | PackagePropertiesPart.getLastPrintedProperty() Get last printed date.
Nullable<java.util.Date> | PackagePropertiesPart.getModifiedProperty() Get modified date.
Nullable<java.lang.String> | PackagePropertiesPart.getRevisionProperty() Get revision.
Nullable<java.lang.String> | PackagePropertiesPart.getSubjectProperty() Get subject.
Nullable<java.lang.String> | PackagePropertiesPart.getTitleProperty() Get title.
Nullable<java.lang.String> | PackagePropertiesPart.getVersionProperty() Get version.

Methods in org.apache.poi.openxml4j.opc.internal with parameters of type Nullable
void | PackagePropertiesPart.setCreatedProperty(Nullable<java.util.Date> created) Set the created date.
void | PackagePropertiesPart.setLastPrintedProperty(Nullable<java.util.Date> lastPrinted) Set last printed date.
void | PackagePropertiesPart.setModifiedProperty(Nullable<java.util.Date> modified) Set last modification date.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.openxml4j.util.ZipEntrySource

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.openxml4j.util.ZipEntrySource

Packages that use ZipEntrySource
org.apache.poi.openxml4j.opc
org.apache.poi.openxml4j.util

Uses of ZipEntrySource in org.apache.poi.openxml4j.opc

Methods in org.apache.poi.openxml4j.opc that return ZipEntrySource
 ZipEntrySource ZipPackage.getZipArchive()
Get the zip archive

Uses of ZipEntrySource in org.apache.poi.openxml4j.util

Classes in org.apache.poi.openxml4j.util that implement ZipEntrySource
class | ZipFileZipEntrySource A ZipEntrySource wrapper around a ZipFile.
class | ZipInputStreamZipEntrySource Provides a way to get at all the ZipEntries from a ZipInputStream, as many times as required.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.util.ZipFileZipEntrySource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.util.ZipFileZipEntrySource

No usage of org.apache.poi.openxml4j.util.ZipFileZipEntrySource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry

No usage of org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource.FakeZipEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource

No usage of org.apache.poi.openxml4j.util.ZipInputStreamZipEntrySource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.poifs.common
Interfaces
POIFSConstants
Classes
POIFSBigBlockSize


org.apache.poi.poifs.common

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.common

common package contains constants and other classes shared across all POIFS subpackages

See:
Description

Interface Summary
POIFSConstants A repository for constants shared by POI classes.

Class Summary
POIFSBigBlockSize A class describing attributes of the Big Block Size

Package org.apache.poi.poifs.common Description

common package contains constants and other classes shared across all POIFS subpackages

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.poifs.common Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.common

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.common.POIFSBigBlockSize

Interface Hierarchy

  • org.apache.poi.poifs.common.POIFSConstants


Uses of Package org.apache.poi.poifs.common

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.common

Packages that use org.apache.poi.poifs.common
org.apache.poi.poifs.common | common package contains constants and other classes shared across all POIFS subpackages
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Classes in org.apache.poi.poifs.common used by org.apache.poi.poifs.common
POIFSBigBlockSize
A class describing attributes of the Big Block Size

Classes in org.apache.poi.poifs.common used by org.apache.poi.poifs.filesystem
POIFSBigBlockSize
A class describing attributes of the Big Block Size

Classes in org.apache.poi.poifs.common used by org.apache.poi.poifs.storage
POIFSBigBlockSize
A class describing attributes of the Big Block Size

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POIFSBigBlockSize

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.common
Class POIFSBigBlockSize

java.lang.Object
    extended by  org.apache.poi.poifs.common.POIFSBigBlockSize

public final class POIFSBigBlockSize
extends java.lang.Object

A class describing attributes of the Big Block Size

Constructor Summary
protected POIFSBigBlockSize(int bigBlockSize, short headerValue)
Method Summary
int | getBATEntriesPerBlock()
int | getBigBlockSize()
short | getHeaderValue() Returns the value that gets written into the header.
int | getNextXBATChainOffset()
int | getPropertiesPerBlock()
int | getXBATEntriesPerBlock()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSBigBlockSize

protected POIFSBigBlockSize(int bigBlockSize,
                            short headerValue)
Method Detail

getBigBlockSize

public int getBigBlockSize()

getHeaderValue

public short getHeaderValue()
Returns the value that gets written into the header. Is the power of two that corresponds to the size of the block, eg 512 => 9

getPropertiesPerBlock

public int getPropertiesPerBlock()

getBATEntriesPerBlock

public int getBATEntriesPerBlock()

getXBATEntriesPerBlock

public int getXBATEntriesPerBlock()

getNextXBATChainOffset

public int getNextXBATChainOffset()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


POIFSConstants

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.common
Interface POIFSConstants

public interface POIFSConstants

A repository for constants shared by POI classes.

Field Summary
static int | BIG_BLOCK_MINIMUM_DOCUMENT_SIZE The minimum size of a document before it's stored using Big Blocks (normal streams).
static int | DIFAT_SECTOR_BLOCK Indicates the sector holds a DIFAT block (0xFFFFFFFC)
static int | END_OF_CHAIN Indicates the sector is the end of a chain (0xFFFFFFFE)
static int | FAT_SECTOR_BLOCK Indicates the sector holds a FAT block (0xFFFFFFFD)
static int | LARGER_BIG_BLOCK_SIZE Some use 4096 bytes
static POIFSBigBlockSize | LARGER_BIG_BLOCK_SIZE_DETAILS
static int | LARGEST_REGULAR_SECTOR_NUMBER The highest sector number you're allowed, 0xFFFFFFFA
static byte[] | OOXML_FILE_HEADER The first 4 bytes of an OOXML file, used in detection
static int | PROPERTY_SIZE How big a single property is
static int | SMALL_BLOCK_SIZE How big a block in the small block stream is.
static int | SMALLER_BIG_BLOCK_SIZE Most files use 512 bytes as their big block size
static POIFSBigBlockSize | SMALLER_BIG_BLOCK_SIZE_DETAILS
static int | UNUSED_BLOCK Indicates the sector is not used (0xFFFFFFFF)

Field Detail

SMALLER_BIG_BLOCK_SIZE

static final int SMALLER_BIG_BLOCK_SIZE
Most files use 512 bytes as their big block size

See Also:
Constant Field Values

SMALLER_BIG_BLOCK_SIZE_DETAILS

static final POIFSBigBlockSize SMALLER_BIG_BLOCK_SIZE_DETAILS

LARGER_BIG_BLOCK_SIZE

static final int LARGER_BIG_BLOCK_SIZE
Some use 4096 bytes

See Also:
Constant Field Values

LARGER_BIG_BLOCK_SIZE_DETAILS

static final POIFSBigBlockSize LARGER_BIG_BLOCK_SIZE_DETAILS

SMALL_BLOCK_SIZE

static final int SMALL_BLOCK_SIZE
How big a block in the small block stream is. Fixed size

See Also:
Constant Field Values

PROPERTY_SIZE

static final int PROPERTY_SIZE
How big a single property is

See Also:
Constant Field Values

BIG_BLOCK_MINIMUM_DOCUMENT_SIZE

static final int BIG_BLOCK_MINIMUM_DOCUMENT_SIZE
The minimum size of a document before it's stored using Big Blocks (normal streams). Smaller documents go in the Mini Stream (SBAT / Small Blocks)

See Also:
Constant Field Values

LARGEST_REGULAR_SECTOR_NUMBER

static final int LARGEST_REGULAR_SECTOR_NUMBER
The highest sector number you're allowed, 0xFFFFFFFA

See Also:
Constant Field Values

DIFAT_SECTOR_BLOCK

static final int DIFAT_SECTOR_BLOCK
Indicates the sector holds a DIFAT block (0xFFFFFFFC)

See Also:
Constant Field Values

FAT_SECTOR_BLOCK

static final int FAT_SECTOR_BLOCK
Indicates the sector holds a FAT block (0xFFFFFFFD)

See Also:
Constant Field Values

END_OF_CHAIN

static final int END_OF_CHAIN
Indicates the sector is the end of a chain (0xFFFFFFFE)

See Also:
Constant Field Values

UNUSED_BLOCK

static final int UNUSED_BLOCK
Indicates the sector is not used (0xFFFFFFFF)

See Also:
Constant Field Values

OOXML_FILE_HEADER

static final byte[] OOXML_FILE_HEADER
The first 4 bytes of an OOXML file, used in detection

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.poifs.common.POIFSBigBlockSize

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.common.POIFSBigBlockSize

Packages that use POIFSBigBlockSize
org.apache.poi.poifs.common | common package contains constants and other classes shared across all POIFS subpackages
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of POIFSBigBlockSize in org.apache.poi.poifs.common

Fields in org.apache.poi.poifs.common declared as POIFSBigBlockSize
static POIFSBigBlockSize | POIFSConstants.LARGER_BIG_BLOCK_SIZE_DETAILS
static POIFSBigBlockSize | POIFSConstants.SMALLER_BIG_BLOCK_SIZE_DETAILS

Uses of POIFSBigBlockSize in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return POIFSBigBlockSize
POIFSBigBlockSize | POIFSFileSystem.getBigBlockSizeDetails()
POIFSBigBlockSize | NPOIFSFileSystem.getBigBlockSizeDetails()

Constructors in org.apache.poi.poifs.filesystem with parameters of type POIFSBigBlockSize
POIFSDocument(java.lang.String name, int size, POIFSBigBlockSize bigBlockSize, POIFSDocumentPath path, POIFSWriterListener writer)
Constructor
POIFSDocument(java.lang.String name, POIFSBigBlockSize bigBlockSize, java.io.InputStream stream)
Constructor
POIFSDocument(java.lang.String name, POIFSBigBlockSize bigBlockSize, ListManagedBlock[] blocks, int length)
Constructor from small blocks

Uses of POIFSBigBlockSize in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage that return POIFSBigBlockSize
POIFSBigBlockSize | SmallDocumentBlock.getBigBlockSize()
POIFSBigBlockSize | HeaderBlock.getBigBlockSize()

Methods in org.apache.poi.poifs.storage with parameters of type POIFSBigBlockSize
static int | BATBlock.calculateMaximumSize(POIFSBigBlockSize bigBlockSize, int numBATs) Calculates the maximum size of a file which is addressable given the number of FAT (BAT) sectors specified.
static int | BATBlock.calculateStorageRequirements(POIFSBigBlockSize bigBlockSize, int entryCount) Calculate how many BATBlocks are needed to hold a specified number of BAT entries.
static int | BATBlock.calculateXBATStorageRequirements(POIFSBigBlockSize bigBlockSize, int entryCount) Calculate how many XBATBlocks are needed to hold a specified number of BAT entries.
static SmallDocumentBlock[] | SmallDocumentBlock.convert(POIFSBigBlockSize bigBlockSize, BlockWritable[] store, int size) Factory for creating SmallDocumentBlocks from DocumentBlocks
static SmallDocumentBlock[] | SmallDocumentBlock.convert(POIFSBigBlockSize bigBlockSize, byte[] array, int size) convert a single long array into an array of SmallDocumentBlock instances
static DocumentBlock[] | DocumentBlock.convert(POIFSBigBlockSize bigBlockSize, byte[] array, int size) convert a single long array into an array of DocumentBlock instances
static BATBlock | BATBlock.createBATBlock(POIFSBigBlockSize bigBlockSize, java.nio.ByteBuffer data) Create a single BATBlock from the byte buffer, which must hold at least one big block of data to be read.
static BATBlock[] | BATBlock.createBATBlocks(POIFSBigBlockSize bigBlockSize, int[] entries) Create an array of BATBlocks from an array of int block allocation table entries
static BATBlock | BATBlock.createEmptyBATBlock(POIFSBigBlockSize bigBlockSize, boolean isXBAT) Creates a single BATBlock, with all the values set to empty.
static BlockWritable[] | PropertyBlock.createPropertyBlockArray(POIFSBigBlockSize bigBlockSize, java.util.List<Property> properties) Create an array of PropertyBlocks from an array of Property instances, creating empty Property instances to make up any shortfall
static BATBlock[] | BATBlock.createXBATBlocks(POIFSBigBlockSize bigBlockSize, int[] entries, int startBlock) Create an array of XBATBlocks from an array of int block allocation table entries
static java.util.List | SmallDocumentBlock.extract(POIFSBigBlockSize bigBlockSize, ListManagedBlock[] blocks) create a list of SmallDocumentBlock's from raw data
static int | SmallDocumentBlock.fill(POIFSBigBlockSize bigBlockSize, java.util.List blocks) fill out a List of SmallDocumentBlocks so that it fully occupies a set of big blocks
static BlockList | SmallBlockTableReader.getSmallDocumentBlocks(POIFSBigBlockSize bigBlockSize, RawDataBlockList blockList, RootProperty root, int sbatStart) fetch the small document block list from an existing file

Constructors in org.apache.poi.poifs.storage with parameters of type POIFSBigBlockSize
BlockAllocationTableReader(POIFSBigBlockSize bigBlockSize, int block_count, int[] block_array, int xbat_count, int xbat_index, BlockList raw_block_list)
create a BlockAllocationTableReader for an existing filesystem.
BlockAllocationTableWriter(POIFSBigBlockSize bigBlockSize)
create a BlockAllocationTableWriter
DocumentBlock(java.io.InputStream stream, POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with data.
HeaderBlock(POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with default values
HeaderBlockWriter(POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with default values
RawDataBlockList(java.io.InputStream stream, POIFSBigBlockSize bigBlockSize)
Constructor RawDataBlockList
SmallBlockTableWriter(POIFSBigBlockSize bigBlockSize, java.util.List documents, RootProperty root)
Creates new SmallBlockTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.common.POIFSConstants

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.common.POIFSConstants

No usage of org.apache.poi.poifs.common.POIFSConstants

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AgileDecryptor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.crypt
Class AgileDecryptor

java.lang.Object
    extended by  org.apache.poi.poifs.crypt.Decryptor
        extended by  org.apache.poi.poifs.crypt.AgileDecryptor

public class AgileDecryptor
extends Decryptor

Author:
Gary King

Field Summary
Fields inherited from class org.apache.poi.poifs.crypt.Decryptor
DEFAULT_PASSWORD
Constructor Summary
protected AgileDecryptor(EncryptionInfo info)
Method Summary
protected  byte[] generateIv(int algorithm, byte[] salt, byte[] blockKey)
 java.io.InputStream getDataStream(DirectoryNode dir)
Return a stream with decrypted data.
 long getLength()
Returns the length of the encytpted data that can be safely read with Decryptor.getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode).
 boolean verifyPassword(java.lang.String password)
Methods inherited from class org.apache.poi.poifs.crypt.Decryptor
getBlockSize, getDataStream, getDataStream, getInstance, hashPassword
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AgileDecryptor

protected AgileDecryptor(EncryptionInfo info)
Method Detail

verifyPassword

public boolean verifyPassword(java.lang.String password)
                       throws java.security.GeneralSecurityException
Specified by:
verifyPassword in class Decryptor
Throws:
java.security.GeneralSecurityException

getDataStream

public java.io.InputStream getDataStream(DirectoryNode dir)
                                  throws java.io.IOException,
                                         java.security.GeneralSecurityException
Description copied from class: Decryptor
Return a stream with decrypted data.

Use Decryptor.getLength() to get the size of that data that can be safely read from the stream. Just reading to the end of the input stream is not sufficient because there are normally padding bytes that must be discarded

Specified by:
getDataStream in class Decryptor
Parameters:
dir - the node to read from
Returns:
decrypted stream
Throws:
java.io.IOException
java.security.GeneralSecurityException

getLength

public long getLength()
Description copied from class: Decryptor
Returns the length of the encytpted data that can be safely read with Decryptor.getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode). Just reading to the end of the input stream is not sufficient because there are normally padding bytes that must be discarded

The length variable is initialized in Decryptor.getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode), an attempt to call getLength() prior to getDataStream() will result in IllegalStateException.

Specified by:
getLength in class Decryptor
Returns:
length of the encrypted data

generateIv

protected byte[] generateIv(int algorithm,
                            byte[] salt,
                            byte[] blockKey)
                     throws java.security.NoSuchAlgorithmException
Throws:
java.security.NoSuchAlgorithmException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Decryptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.crypt
Class Decryptor

java.lang.Object
    extended by  org.apache.poi.poifs.crypt.Decryptor
Direct Known Subclasses:
AgileDecryptor, EcmaDecryptor
public abstract class Decryptor
extends java.lang.Object

Field Summary
static java.lang.String DEFAULT_PASSWORD
Constructor Summary
Decryptor()
Method Summary
protected static int getBlockSize(int algorithm)
abstract  java.io.InputStream getDataStream(DirectoryNode dir)
Return a stream with decrypted data.
 java.io.InputStream getDataStream(NPOIFSFileSystem fs)
 java.io.InputStream getDataStream(POIFSFileSystem fs)
static Decryptor getInstance(EncryptionInfo info)
abstract  long getLength()
Returns the length of the encytpted data that can be safely read with getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode).
protected  byte[] hashPassword(EncryptionInfo info, java.lang.String password)
abstract  boolean verifyPassword(java.lang.String password)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_PASSWORD

public static final java.lang.String DEFAULT_PASSWORD
See Also:
Constant Field Values
Constructor Detail

Decryptor

public Decryptor()
Method Detail

getDataStream

public abstract java.io.InputStream getDataStream(DirectoryNode dir)
                                           throws java.io.IOException,
                                                  java.security.GeneralSecurityException
Return a stream with decrypted data.

Use getLength() to get the size of that data that can be safely read from the stream. Just reading to the end of the input stream is not sufficient because there are normally padding bytes that must be discarded

Parameters:
dir - the node to read from
Returns:
decrypted stream
Throws:
java.io.IOException
java.security.GeneralSecurityException

verifyPassword

public abstract boolean verifyPassword(java.lang.String password)
                                throws java.security.GeneralSecurityException
Throws:
java.security.GeneralSecurityException

getLength

public abstract long getLength()
Returns the length of the encytpted data that can be safely read with getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode). Just reading to the end of the input stream is not sufficient because there are normally padding bytes that must be discarded

The length variable is initialized in getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode), an attempt to call getLength() prior to getDataStream() will result in IllegalStateException.

Returns:
length of the encrypted data
Throws:
java.lang.IllegalStateException - if getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode) was not called

getInstance

public static Decryptor getInstance(EncryptionInfo info)

getDataStream

public java.io.InputStream getDataStream(NPOIFSFileSystem fs)
                                  throws java.io.IOException,
                                         java.security.GeneralSecurityException
Throws:
java.io.IOException
java.security.GeneralSecurityException

getDataStream

public java.io.InputStream getDataStream(POIFSFileSystem fs)
                                  throws java.io.IOException,
                                         java.security.GeneralSecurityException
Throws:
java.io.IOException
java.security.GeneralSecurityException

getBlockSize

protected static int getBlockSize(int algorithm)

hashPassword

protected byte[] hashPassword(EncryptionInfo info,
                              java.lang.String password)
                       throws java.security.NoSuchAlgorithmException
Throws:
java.security.NoSuchAlgorithmException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EcmaDecryptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.crypt
Class EcmaDecryptor

java.lang.Object
    extended by  org.apache.poi.poifs.crypt.Decryptor
        extended by  org.apache.poi.poifs.crypt.EcmaDecryptor

public class EcmaDecryptor
extends Decryptor

Author:
Maxim Valyanskiy, Gary King

Field Summary
Fields inherited from class org.apache.poi.poifs.crypt.Decryptor
DEFAULT_PASSWORD
Constructor Summary
EcmaDecryptor(EncryptionInfo info)
Method Summary
 java.io.InputStream getDataStream(DirectoryNode dir)
Return a stream with decrypted data.
 long getLength()
Returns the length of the encytpted data that can be safely read with Decryptor.getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode).
 boolean verifyPassword(java.lang.String password)
Methods inherited from class org.apache.poi.poifs.crypt.Decryptor
getBlockSize, getDataStream, getDataStream, getInstance, hashPassword
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EcmaDecryptor

public EcmaDecryptor(EncryptionInfo info)
Method Detail

verifyPassword

public boolean verifyPassword(java.lang.String password)
                       throws java.security.GeneralSecurityException
Specified by:
verifyPassword in class Decryptor
Throws:
java.security.GeneralSecurityException

getDataStream

public java.io.InputStream getDataStream(DirectoryNode dir)
                                  throws java.io.IOException,
                                         java.security.GeneralSecurityException
Description copied from class: Decryptor
Return a stream with decrypted data.

Use Decryptor.getLength() to get the size of that data that can be safely read from the stream. Just reading to the end of the input stream is not sufficient because there are normally padding bytes that must be discarded

Specified by:
getDataStream in class Decryptor
Parameters:
dir - the node to read from
Returns:
decrypted stream
Throws:
java.io.IOException
java.security.GeneralSecurityException

getLength

public long getLength()
Description copied from class: Decryptor
Returns the length of the encytpted data that can be safely read with Decryptor.getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode). Just reading to the end of the input stream is not sufficient because there are normally padding bytes that must be discarded

The length variable is initialized in Decryptor.getDataStream(org.apache.poi.poifs.filesystem.DirectoryNode), an attempt to call getLength() prior to getDataStream() will result in IllegalStateException.

Specified by:
getLength in class Decryptor
Returns:
length of the encrypted data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EncryptionHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.crypt
Class EncryptionHeader

java.lang.Object
    extended by  org.apache.poi.poifs.crypt.EncryptionHeader

public class EncryptionHeader
extends java.lang.Object

Author:
Maxim Valyanskiy, Gary King

Field Summary
static int | ALGORITHM_AES_128
static int | ALGORITHM_AES_192
static int | ALGORITHM_AES_256
static int | ALGORITHM_RC4
static int | HASH_SHA1
static int | MODE_CBC
static int | MODE_CFB
static int | MODE_ECB
static int | PROVIDER_AES
static int | PROVIDER_RC4
Constructor Summary
EncryptionHeader(DocumentInputStream is)
EncryptionHeader(java.lang.String descriptor)
Method Summary
int | getAlgorithm()
int | getCipherMode()
java.lang.String | getCspName()
int | getFlags()
int | getHashAlgorithm()
byte[] | getKeySalt()
int | getKeySize()
int | getProviderType()
int | getSizeExtra()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALGORITHM_RC4

public static final int ALGORITHM_RC4
See Also:
Constant Field Values

ALGORITHM_AES_128

public static final int ALGORITHM_AES_128
See Also:
Constant Field Values

ALGORITHM_AES_192

public static final int ALGORITHM_AES_192
See Also:
Constant Field Values

ALGORITHM_AES_256

public static final int ALGORITHM_AES_256
See Also:
Constant Field Values

HASH_SHA1

public static final int HASH_SHA1
See Also:
Constant Field Values

PROVIDER_RC4

public static final int PROVIDER_RC4
See Also:
Constant Field Values

PROVIDER_AES

public static final int PROVIDER_AES
See Also:
Constant Field Values

MODE_ECB

public static final int MODE_ECB
See Also:
Constant Field Values

MODE_CBC

public static final int MODE_CBC
See Also:
Constant Field Values

MODE_CFB

public static final int MODE_CFB
See Also:
Constant Field Values
Constructor Detail

EncryptionHeader

public EncryptionHeader(DocumentInputStream is)
                 throws java.io.IOException
Throws:
java.io.IOException

EncryptionHeader

public EncryptionHeader(java.lang.String descriptor)
                 throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getCipherMode

public int getCipherMode()

getFlags

public int getFlags()

getSizeExtra

public int getSizeExtra()

getAlgorithm

public int getAlgorithm()

getHashAlgorithm

public int getHashAlgorithm()

getKeySize

public int getKeySize()

getKeySalt

public byte[] getKeySalt()

getProviderType

public int getProviderType()

getCspName

public java.lang.String getCspName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EncryptionInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.crypt
Class EncryptionInfo

java.lang.Object
    extended by  org.apache.poi.poifs.crypt.EncryptionInfo

public class EncryptionInfo
extends java.lang.Object

Author:
Maxim Valyanskiy, Gary King

Constructor Summary
EncryptionInfo(DirectoryNode dir)
EncryptionInfo(NPOIFSFileSystem fs)
EncryptionInfo(POIFSFileSystem fs)
Method Summary
int | getEncryptionFlags()
EncryptionHeader | getHeader()
EncryptionVerifier | getVerifier()
int | getVersionMajor()
int | getVersionMinor()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EncryptionInfo

public EncryptionInfo(POIFSFileSystem fs)
               throws java.io.IOException
Throws:
java.io.IOException

EncryptionInfo

public EncryptionInfo(NPOIFSFileSystem fs)
               throws java.io.IOException
Throws:
java.io.IOException

EncryptionInfo

public EncryptionInfo(DirectoryNode dir)
               throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getVersionMajor

public int getVersionMajor()

getVersionMinor

public int getVersionMinor()

getEncryptionFlags

public int getEncryptionFlags()

getHeader

public EncryptionHeader getHeader()

getVerifier

public EncryptionVerifier getVerifier()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EncryptionVerifier

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.crypt
Class EncryptionVerifier

java.lang.Object
    extended by  org.apache.poi.poifs.crypt.EncryptionVerifier

public class EncryptionVerifier
extends java.lang.Object

Author:
Maxim Valyanskiy, Gary King

Constructor Summary
EncryptionVerifier(DocumentInputStream is, int encryptedLength)
EncryptionVerifier(java.lang.String descriptor)
Method Summary
int | getAlgorithm()
int | getCipherMode()
byte[] | getEncryptedKey()
byte[] | getSalt()
int | getSpinCount()
byte[] | getVerifier()
byte[] | getVerifierHash()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EncryptionVerifier

public EncryptionVerifier(java.lang.String descriptor)

EncryptionVerifier

public EncryptionVerifier(DocumentInputStream is,
                          int encryptedLength)
Method Detail

getSalt

public byte[] getSalt()

getVerifier

public byte[] getVerifier()

getVerifierHash

public byte[] getVerifierHash()

getSpinCount

public int getSpinCount()

getCipherMode

public int getCipherMode()

getAlgorithm

public int getAlgorithm()

getEncryptedKey

public byte[] getEncryptedKey()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.poifs.crypt
Classes
AgileDecryptor
Decryptor
EcmaDecryptor
EncryptionHeader
EncryptionInfo
EncryptionVerifier


org.apache.poi.poifs.crypt

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.crypt

Class Summary
AgileDecryptor
Decryptor
EcmaDecryptor
EncryptionHeader
EncryptionInfo
EncryptionVerifier


org.apache.poi.poifs.crypt Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.crypt

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.crypt.Decryptor
      • org.apache.poi.poifs.crypt.AgileDecryptor
      • org.apache.poi.poifs.crypt.EcmaDecryptor
    • org.apache.poi.poifs.crypt.EncryptionHeader
    • org.apache.poi.poifs.crypt.EncryptionInfo
    • org.apache.poi.poifs.crypt.EncryptionVerifier


Uses of Package org.apache.poi.poifs.crypt

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.crypt

Packages that use org.apache.poi.poifs.crypt
org.apache.poi.poifs.crypt

Classes in org.apache.poi.poifs.crypt used by org.apache.poi.poifs.crypt
Decryptor
EncryptionHeader
EncryptionInfo
EncryptionVerifier

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.crypt.AgileDecryptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.crypt.AgileDecryptor

No usage of org.apache.poi.poifs.crypt.AgileDecryptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.crypt.Decryptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.crypt.Decryptor

Packages that use Decryptor
org.apache.poi.poifs.crypt

Uses of Decryptor in org.apache.poi.poifs.crypt

Subclasses of Decryptor in org.apache.poi.poifs.crypt
class | AgileDecryptor
class | EcmaDecryptor

Methods in org.apache.poi.poifs.crypt that return Decryptor
static Decryptor Decryptor.getInstance(EncryptionInfo info)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.crypt.EcmaDecryptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.crypt.EcmaDecryptor

No usage of org.apache.poi.poifs.crypt.EcmaDecryptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.crypt.EncryptionHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.crypt.EncryptionHeader

Packages that use EncryptionHeader
org.apache.poi.poifs.crypt

Uses of EncryptionHeader in org.apache.poi.poifs.crypt

Methods in org.apache.poi.poifs.crypt that return EncryptionHeader
 EncryptionHeader EncryptionInfo.getHeader()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.crypt.EncryptionInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.crypt.EncryptionInfo

Packages that use EncryptionInfo
org.apache.poi.poifs.crypt

Uses of EncryptionInfo in org.apache.poi.poifs.crypt

Methods in org.apache.poi.poifs.crypt with parameters of type EncryptionInfo
static Decryptor | Decryptor.getInstance(EncryptionInfo info)
protected byte[] | Decryptor.hashPassword(EncryptionInfo info, java.lang.String password)

Constructors in org.apache.poi.poifs.crypt with parameters of type EncryptionInfo
AgileDecryptor(EncryptionInfo info)
EcmaDecryptor(EncryptionInfo info)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.crypt.EncryptionVerifier

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.crypt.EncryptionVerifier

Packages that use EncryptionVerifier
org.apache.poi.poifs.crypt

Uses of EncryptionVerifier in org.apache.poi.poifs.crypt

Methods in org.apache.poi.poifs.crypt that return EncryptionVerifier
 EncryptionVerifier EncryptionInfo.getVerifier()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.poifs.dev
Interfaces
POIFSViewable
Classes
POIFSDump
POIFSHeaderDumper
POIFSLister
POIFSViewEngine
POIFSViewer


org.apache.poi.poifs.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.dev

DEV package serves two purposes.

See:
Description

Interface Summary
POIFSViewable Interface for a drill-down viewable object.

Class Summary
POIFSDump | Dump internal structure of a OLE2 file into file system
POIFSHeaderDumper | A very low level debugging tool, for printing out core information on the headers and FAT blocks.
POIFSLister | A lister of the entries in POIFS files.
POIFSViewEngine | This class contains methods used to inspect POIFSViewable objects
POIFSViewer | A simple viewer for POIFS files

Package org.apache.poi.poifs.dev Description

DEV package serves two purposes. 1. Examples for how to use POIFS and 2. tools for developing and validating POIFS.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.poifs.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.dev.POIFSDump
    • org.apache.poi.poifs.dev.POIFSHeaderDumper
    • org.apache.poi.poifs.dev.POIFSLister
    • org.apache.poi.poifs.dev.POIFSViewEngine
    • org.apache.poi.poifs.dev.POIFSViewer

Interface Hierarchy

  • org.apache.poi.poifs.dev.POIFSViewable


Uses of Package org.apache.poi.poifs.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.dev

Packages that use org.apache.poi.poifs.dev
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.

Classes in org.apache.poi.poifs.dev used by org.apache.poi.poifs.filesystem
POIFSViewable
Interface for a drill-down viewable object.

Classes in org.apache.poi.poifs.dev used by org.apache.poi.poifs.property
POIFSViewable
Interface for a drill-down viewable object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POIFSDump

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.dev
Class POIFSDump

java.lang.Object
    extended by  org.apache.poi.poifs.dev.POIFSDump

public class POIFSDump
extends java.lang.Object

Dump internal structure of a OLE2 file into file system

Author:
Yegor Kozlov

Constructor Summary
POIFSDump()
Method Summary
static void | dump(DirectoryEntry root, java.io.File parent)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSDump

public POIFSDump()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

dump

public static void dump(DirectoryEntry root,
                        java.io.File parent)
                 throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


POIFSHeaderDumper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.dev
Class POIFSHeaderDumper

java.lang.Object
    extended by  org.apache.poi.poifs.dev.POIFSHeaderDumper

public class POIFSHeaderDumper
extends java.lang.Object

A very low level debugging tool, for printing out core information on the headers and FAT blocks. You probably only want to use this if you're trying to understand POIFS, or if you're trying to track down the source of corruption in a file.

Constructor Summary
POIFSHeaderDumper()
Method Summary
static void | displayBATReader(BlockAllocationTableReader batReader)
static void | displayHeader(HeaderBlock header_block)
static void | displayRawBlocksSummary(RawDataBlockList data_blocks)
static void | main(java.lang.String[] args) Display the entries of multiple POIFS files
static void | viewFile(java.lang.String filename)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSHeaderDumper

public POIFSHeaderDumper()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Display the entries of multiple POIFS files

Parameters:
args - the names of the files to be displayed
Throws:
java.lang.Exception

viewFile

public static void viewFile(java.lang.String filename)
                     throws java.lang.Exception
Throws:
java.lang.Exception

displayHeader

public static void displayHeader(HeaderBlock header_block)
                          throws java.lang.Exception
Throws:
java.lang.Exception

displayRawBlocksSummary

public static void displayRawBlocksSummary(RawDataBlockList data_blocks)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

displayBATReader

public static void displayBATReader(BlockAllocationTableReader batReader)
                             throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSLister

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.dev
Class POIFSLister

java.lang.Object
    extended by  org.apache.poi.poifs.dev.POIFSLister

public class POIFSLister
extends java.lang.Object

A lister of the entries in POIFS files. Much simpler than POIFSViewer

Constructor Summary
POIFSLister()
Method Summary
static void | displayDirectory(DirectoryNode dir, java.lang.String indent, boolean withSizes)
static void | main(java.lang.String[] args) Display the entries of multiple POIFS files
static void | viewFile(java.lang.String filename, boolean withSizes)
static void | viewFileOld(java.lang.String filename, boolean withSizes)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSLister

public POIFSLister()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Display the entries of multiple POIFS files

Parameters:
args - the names of the files to be displayed
Throws:
java.io.IOException

viewFile

public static void viewFile(java.lang.String filename,
                            boolean withSizes)
                     throws java.io.IOException
Throws:
java.io.IOException

viewFileOld

public static void viewFileOld(java.lang.String filename,
                               boolean withSizes)
                        throws java.io.IOException
Throws:
java.io.IOException

displayDirectory

public static void displayDirectory(DirectoryNode dir,
                                    java.lang.String indent,
                                    boolean withSizes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSViewable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.dev
Interface POIFSViewable

All Known Implementing Classes:
DirectoryNode, DirectoryProperty, DocumentNode, DocumentProperty, NPOIFSDocument, NPOIFSFileSystem, POIFSDocument, POIFSFileSystem, Property, RootProperty
public interface POIFSViewable

Interface for a drill-down viewable object. Such an object has content that may or may not be displayed, at the discretion of the viewer. The content is returned to the viewer as an array or as an Iterator, and the object provides a clue as to which technique the viewer should use to get its content. A POIFSViewable object is also expected to provide a short description of itself, that can be used by a viewer when the viewable object is collapsed.

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Method Detail

getViewableArray

java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Returns:
short description
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSViewEngine

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.dev
Class POIFSViewEngine

java.lang.Object
    extended by  org.apache.poi.poifs.dev.POIFSViewEngine

public class POIFSViewEngine
extends java.lang.Object

This class contains methods used to inspect POIFSViewable objects

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
POIFSViewEngine()
Method Summary
static java.util.List inspectViewable(java.lang.Object viewable, boolean drilldown, int indentLevel, java.lang.String indentString)
Inspect an object that may be viewable, and drill down if told to
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSViewEngine

public POIFSViewEngine()
Method Detail

inspectViewable

public static java.util.List inspectViewable(java.lang.Object viewable,
                                             boolean drilldown,
                                             int indentLevel,
                                             java.lang.String indentString)
Inspect an object that may be viewable, and drill down if told to

Parameters:
viewable - the object to be viewed
drilldown - if true, and the object implements POIFSViewable, inspect the objects' contents (recursively)
indentLevel - how far in to indent each string
indentString - string to use for indenting
Returns:
a List of Strings holding the content
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSViewer

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.dev
Class POIFSViewer

java.lang.Object
    extended by  org.apache.poi.poifs.dev.POIFSViewer

public class POIFSViewer
extends java.lang.Object

A simple viewer for POIFS files

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
POIFSViewer()
Method Summary
static void main(java.lang.String[] args)
Display the contents of multiple POIFS files
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSViewer

public POIFSViewer()
Method Detail

main

public static void main(java.lang.String[] args)
Display the contents of multiple POIFS files

Parameters:
args - the names of the files to be displayed
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.poifs.dev.POIFSDump

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.dev.POIFSDump

No usage of org.apache.poi.poifs.dev.POIFSDump

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.dev.POIFSHeaderDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.dev.POIFSHeaderDumper

No usage of org.apache.poi.poifs.dev.POIFSHeaderDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.dev.POIFSLister

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.dev.POIFSLister

No usage of org.apache.poi.poifs.dev.POIFSLister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.dev.POIFSViewable

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.dev.POIFSViewable

Packages that use POIFSViewable
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.

Uses of POIFSViewable in org.apache.poi.poifs.filesystem

Classes in org.apache.poi.poifs.filesystem that implement POIFSViewable
class | DirectoryNode Simple implementation of DirectoryEntry
class | DocumentNode Simple implementation of DocumentEntry
class | NPOIFSDocument This class manages a document in the NIO POIFS filesystem.
class | NPOIFSFileSystem This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
class | POIFSDocument This class manages a document in the POIFS filesystem.
class | POIFSFileSystem This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Uses of POIFSViewable in org.apache.poi.poifs.property

Classes in org.apache.poi.poifs.property that implement POIFSViewable
class | DirectoryProperty Directory property
class | DocumentProperty Trivial extension of Property for POIFSDocuments
class | Property This abstract base class is the ancestor of all classes implementing POIFS Property behavior.
class | RootProperty Root property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.dev.POIFSViewEngine

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.dev.POIFSViewEngine

No usage of org.apache.poi.poifs.dev.POIFSViewEngine

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.dev.POIFSViewer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.dev.POIFSViewer

No usage of org.apache.poi.poifs.dev.POIFSViewer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.poifs.eventfilesystem
Interfaces
POIFSReaderListener
Classes
POIFSReader
POIFSReaderEvent


org.apache.poi.poifs.eventfilesystem

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.eventfilesystem

The eventfilesystem is an efficient method for reading OLE 2 CDF files.

See:
Description

Interface Summary
POIFSReaderListener Interface POIFSReaderListener

Class Summary
POIFSReader | An event-driven reader for POIFS file systems.
POIFSReaderEvent | Class POIFSReaderEvent

Package org.apache.poi.poifs.eventfilesystem Description

The eventfilesystem is an efficient method for reading OLE 2 CDF files. It is to OLE 2 CDF what SAX is to XML.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.poifs.filesystem


org.apache.poi.poifs.eventfilesystem Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.eventfilesystem

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.eventfilesystem.POIFSReader
    • org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent

Interface Hierarchy

  • org.apache.poi.poifs.eventfilesystem.POIFSReaderListener


Uses of Package org.apache.poi.poifs.eventfilesystem

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.eventfilesystem

Packages that use org.apache.poi.poifs.eventfilesystem
org.apache.poi.poifs.eventfilesystem The eventfilesystem is an efficient method for reading OLE 2 CDF files.

Classes in org.apache.poi.poifs.eventfilesystem used by org.apache.poi.poifs.eventfilesystem
POIFSReaderEvent
Class POIFSReaderEvent
POIFSReaderListener
Interface POIFSReaderListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POIFSReader

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.eventfilesystem
Class POIFSReader

java.lang.Object
    extended by  org.apache.poi.poifs.eventfilesystem.POIFSReader

public class POIFSReader
extends java.lang.Object

An event-driven reader for POIFS file systems. Users of this class first create an instance of it, then use the registerListener methods to register POIFSReaderListener instances for specific documents. Once all the listeners have been registered, the read() method is called, which results in the listeners being notified as their documents are read.

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
POIFSReader()
Create a POIFSReader
Method Summary
static void | main(java.lang.String[] args) read in files
void | read(java.io.InputStream stream) Read from an InputStream and process the documents we get
void | registerListener(POIFSReaderListener listener) Register a POIFSReaderListener for all documents
void | registerListener(POIFSReaderListener listener, POIFSDocumentPath path, java.lang.String name) Register a POIFSReaderListener for a document in the specified directory
void | registerListener(POIFSReaderListener listener, java.lang.String name) Register a POIFSReaderListener for a document in the root directory
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSReader

public POIFSReader()
Create a POIFSReader

Method Detail

read

public void read(java.io.InputStream stream)
          throws java.io.IOException
Read from an InputStream and process the documents we get

Parameters:
stream - the InputStream from which to read the data
Throws:
java.io.IOException - on errors reading, or on invalid data

registerListener

public void registerListener(POIFSReaderListener listener)
Register a POIFSReaderListener for all documents

Parameters:
listener - the listener to be registered
Throws:
java.lang.NullPointerException - if listener is null
java.lang.IllegalStateException - if read() has already been called

registerListener

public void registerListener(POIFSReaderListener listener,
                             java.lang.String name)
Register a POIFSReaderListener for a document in the root directory

Parameters:
listener - the listener to be registered
name - the document name
Throws:
java.lang.NullPointerException - if listener is null or name is null or empty
java.lang.IllegalStateException - if read() has already been called

registerListener

public void registerListener(POIFSReaderListener listener,
                             POIFSDocumentPath path,
                             java.lang.String name)
Register a POIFSReaderListener for a document in the specified directory

Parameters:
listener - the listener to be registered
path - the document path; if null, the root directory is assumed
name - the document name
Throws:
java.lang.NullPointerException - if listener is null or name is null or empty
java.lang.IllegalStateException - if read() has already been called

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
read in files

Parameters:
args - names of the files
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


POIFSReaderEvent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.eventfilesystem
Class POIFSReaderEvent

java.lang.Object
    extended by  org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent

public class POIFSReaderEvent
extends java.lang.Object

Class POIFSReaderEvent

Version:
%I%, %G%
Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
java.lang.String | getName()
POIFSDocumentPath | getPath()
DocumentInputStream | getStream()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getStream

public DocumentInputStream getStream()
Returns:
the DocumentInputStream, freshly opened

getPath

public POIFSDocumentPath getPath()
Returns:
the document's path

getName

public java.lang.String getName()
Returns:
the document's name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSReaderListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.eventfilesystem
Interface POIFSReaderListener

public interface POIFSReaderListener

Interface POIFSReaderListener

Version:
%I%, %G%
Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
 void processPOIFSReaderEvent(POIFSReaderEvent event)
Process a POIFSReaderEvent that this listener had registered for

Method Detail

processPOIFSReaderEvent

void processPOIFSReaderEvent(POIFSReaderEvent event)
Process a POIFSReaderEvent that this listener had registered for

Parameters:
event - the POIFSReaderEvent
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.poifs.eventfilesystem.POIFSReader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.eventfilesystem.POIFSReader

No usage of org.apache.poi.poifs.eventfilesystem.POIFSReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.eventfilesystem.POIFSReaderEvent

Packages that use POIFSReaderEvent
org.apache.poi.poifs.eventfilesystem The eventfilesystem is an efficient method for reading OLE 2 CDF files.

Uses of POIFSReaderEvent in org.apache.poi.poifs.eventfilesystem

Methods in org.apache.poi.poifs.eventfilesystem with parameters of type POIFSReaderEvent
 void POIFSReaderListener.processPOIFSReaderEvent(POIFSReaderEvent event)
Process a POIFSReaderEvent that this listener had registered for

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.eventfilesystem.POIFSReaderListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.eventfilesystem.POIFSReaderListener

Packages that use POIFSReaderListener
org.apache.poi.poifs.eventfilesystem The eventfilesystem is an efficient method for reading OLE 2 CDF files.

Uses of POIFSReaderListener in org.apache.poi.poifs.eventfilesystem

Methods in org.apache.poi.poifs.eventfilesystem with parameters of type POIFSReaderListener
void | POIFSReader.registerListener(POIFSReaderListener listener) Register a POIFSReaderListener for all documents
void | POIFSReader.registerListener(POIFSReaderListener listener, POIFSDocumentPath path, java.lang.String name) Register a POIFSReaderListener for a document in the specified directory
void | POIFSReader.registerListener(POIFSReaderListener listener, java.lang.String name) Register a POIFSReaderListener for a document in the root directory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BATManaged

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Interface BATManaged

All Known Implementing Classes:
BlockAllocationTableWriter, NPropertyTable, POIFSDocument, PropertyTable, PropertyTableBase, SmallBlockTableWriter
public interface BATManaged

This interface defines behaviors for objects managed by the Block Allocation Table (BAT).

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
int | countBlocks() Return the number of BigBlock's this instance uses
void | setStartBlock(int index) Set the start block for this instance

Method Detail

countBlocks

int countBlocks()
Return the number of BigBlock's this instance uses

Returns:
count of BigBlock instances

setStartBlock

void setStartBlock(int index)
Set the start block for this instance

Parameters:
index - index into the array of BigBlock instances making up the the filesystem
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BlockStore.ChainLoopDetector

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class BlockStore.ChainLoopDetector

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.BlockStore.ChainLoopDetector
Enclosing class:
BlockStore
protected class BlockStore.ChainLoopDetector
extends java.lang.Object

Used to detect if a chain has a loop in it, so we can bail out with an error rather than spinning away for ever...

Constructor Summary
protected BlockStore.ChainLoopDetector(long rawSize)
Method Summary
protected  void claim(int offset)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BlockStore.ChainLoopDetector

protected BlockStore.ChainLoopDetector(long rawSize)
Method Detail

claim

protected void claim(int offset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlockStore

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class BlockStore

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.BlockStore
Direct Known Subclasses:
NPOIFSFileSystem, NPOIFSMiniStore
public abstract class BlockStore
extends java.lang.Object

This abstract class describes a way to read, store, chain and free a series of blocks (be they Big or Small ones)

Nested Class Summary
protected  class BlockStore.ChainLoopDetector
Used to detect if a chain has a loop in it, so we can bail out with an error rather than spinning away for ever...
Constructor Summary
BlockStore()
Method Summary
protected abstract java.nio.ByteBuffer | createBlockIfNeeded(int offset) Extends the file if required to hold blocks up to the specified offset, and return the block from there.
protected abstract BATBlock.BATBlockAndIndex | getBATBlockAndIndex(int offset) Returns the BATBlock that handles the specified offset, and the relative index within it
protected abstract java.nio.ByteBuffer | getBlockAt(int offset) Load the block at the given offset.
protected abstract int | getBlockStoreBlockSize() Returns the size of the blocks managed through the block store.
protected abstract BlockStore.ChainLoopDetector | getChainLoopDetector() Creates a Detector for loops in the chain
protected abstract int | getFreeBlock() Finds a free block, and returns its offset.
protected abstract int | getNextBlock(int offset) Works out what block follows the specified one.
protected abstract void | setNextBlock(int offset, int nextBlock) Changes the record of what block follows the specified one.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BlockStore

public BlockStore()
Method Detail

getBlockStoreBlockSize

protected abstract int getBlockStoreBlockSize()
Returns the size of the blocks managed through the block store.

getBlockAt

protected abstract java.nio.ByteBuffer getBlockAt(int offset)
                                           throws java.io.IOException
Load the block at the given offset.

Throws:
java.io.IOException

createBlockIfNeeded

protected abstract java.nio.ByteBuffer createBlockIfNeeded(int offset)
                                                    throws java.io.IOException
Extends the file if required to hold blocks up to the specified offset, and return the block from there.

Throws:
java.io.IOException

getBATBlockAndIndex

protected abstract BATBlock.BATBlockAndIndex getBATBlockAndIndex(int offset)
Returns the BATBlock that handles the specified offset, and the relative index within it

getNextBlock

protected abstract int getNextBlock(int offset)
Works out what block follows the specified one.

setNextBlock

protected abstract void setNextBlock(int offset,
                                     int nextBlock)
Changes the record of what block follows the specified one.

getFreeBlock

protected abstract int getFreeBlock()
                             throws java.io.IOException
Finds a free block, and returns its offset. This method will extend the file/stream if needed, and if doing so, allocate new FAT blocks to address the extra space.

Throws:
java.io.IOException

getChainLoopDetector

protected abstract BlockStore.ChainLoopDetector getChainLoopDetector()
                                                              throws java.io.IOException
Creates a Detector for loops in the chain

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirectoryEntry

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Interface DirectoryEntry

All Superinterfaces:
Entry, java.lang.Iterable<Entry>
All Known Implementing Classes:
DirectoryNode, FilteringDirectoryNode
public interface DirectoryEntry
extends Entry, java.lang.Iterable<Entry>

This interface defines methods specific to Directory objects managed by a Filesystem instance.

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
DirectoryEntry | createDirectory(java.lang.String name) create a new DirectoryEntry
DocumentEntry | createDocument(java.lang.String name, java.io.InputStream stream) create a new DocumentEntry
DocumentEntry | createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry; the data will be provided later
java.util.Iterator<Entry> | getEntries() get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)
Entry | getEntry(java.lang.String name) get a specified Entry by name
int | getEntryCount() find out how many Entry instances are contained directly within this DirectoryEntry
ClassID | getStorageClsid() Gets the storage clsid of the directory entry
boolean | hasEntry(java.lang.String name) Checks if entry with specified name present
boolean | isEmpty() is this DirectoryEntry empty?
void | setStorageClsid(ClassID clsidStorage) Sets the storage clsid for the directory entry
Methods inherited from interface org.apache.poi.poifs.filesystem.Entry
delete, getName, getParent, isDirectoryEntry, isDocumentEntry, renameTo
Methods inherited from interface java.lang.Iterable
iterator

Method Detail

getEntries

java.util.Iterator<Entry> getEntries()
get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)

Returns:
iterator; never null, but hasNext() may return false immediately (i.e., this DirectoryEntry is empty). All objects retrieved by next() are guaranteed to be implementations of Entry.

isEmpty

boolean isEmpty()
is this DirectoryEntry empty?

Returns:
true if this instance contains no Entry instances

getEntryCount

int getEntryCount()
find out how many Entry instances are contained directly within this DirectoryEntry

Returns:
number of immediately (no grandchildren etc.) contained Entry instances

hasEntry

boolean hasEntry(java.lang.String name)
Checks if entry with specified name present

getEntry

Entry getEntry(java.lang.String name)
               throws java.io.FileNotFoundException
get a specified Entry by name

Parameters:
name - the name of the Entry to obtain.
Returns:
the specified Entry, if it is directly contained in this DirectoryEntry
Throws:
java.io.FileNotFoundException - if no Entry with the specified name exists in this DirectoryEntry

createDocument

DocumentEntry createDocument(java.lang.String name,
                             java.io.InputStream stream)
                             throws java.io.IOException
create a new DocumentEntry

Parameters:
name - the name of the new DocumentEntry
stream - the InputStream from which to create the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

createDocument

DocumentEntry createDocument(java.lang.String name,
                             int size,
                             POIFSWriterListener writer)
                             throws java.io.IOException
create a new DocumentEntry; the data will be provided later

Parameters:
name - the name of the new DocumentEntry
size - the size of the new DocumentEntry
writer - the writer of the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

createDirectory

DirectoryEntry createDirectory(java.lang.String name)
                               throws java.io.IOException
create a new DirectoryEntry

Parameters:
name - the name of the new DirectoryEntry
Returns:
the new DirectoryEntry
Throws:
java.io.IOException

getStorageClsid

ClassID getStorageClsid()
Gets the storage clsid of the directory entry

Returns:
storage Class ID

setStorageClsid

void setStorageClsid(ClassID clsidStorage)
Sets the storage clsid for the directory entry

Parameters:
clsidStorage - storage Class ID
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirectoryNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class DirectoryNode

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.EntryNode
        extended by  org.apache.poi.poifs.filesystem.DirectoryNode
All Implemented Interfaces:
java.lang.Iterable<Entry>, POIFSViewable, DirectoryEntry, Entry
public class DirectoryNode
extends EntryNode
implements DirectoryEntry, POIFSViewable, java.lang.Iterable<Entry>

Simple implementation of DirectoryEntry

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
DirectoryEntry | createDirectory(java.lang.String name) create a new DirectoryEntry
DocumentEntry | createDocument(java.lang.String name, java.io.InputStream stream) create a new DocumentEntry
DocumentEntry | createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry; the data will be provided later
DocumentInputStream | createDocumentInputStream(Entry document) open a document in the directory's entry's list of entries
DocumentInputStream | createDocumentInputStream(java.lang.String documentName) open a document in the directory's entry's list of entries
java.util.Iterator<Entry> | getEntries() get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)
Entry | getEntry(java.lang.String name) get a specified Entry by name
int | getEntryCount() find out how many Entry instances are contained directly within this DirectoryEntry
POIFSFileSystem | getFileSystem()
NPOIFSFileSystem | getNFileSystem()
POIFSDocumentPath | getPath()
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
ClassID | getStorageClsid() Gets the storage clsid of the directory entry
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
boolean | hasEntry(java.lang.String name) Checks if entry with specified name present
protected boolean | isDeleteOK() extensions use this method to verify internal rules regarding deletion of the underlying store.
boolean | isDirectoryEntry() is this a DirectoryEntry?
boolean | isEmpty() is this DirectoryEntry empty?
java.util.Iterator<Entry> | iterator() Returns an Iterator over all the entries
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator
void | setStorageClsid(ClassID clsidStorage) Sets the storage clsid for the directory entry
Methods inherited from class org.apache.poi.poifs.filesystem.EntryNode
delete, getName, getParent, getProperty, isDocumentEntry, isRoot, renameTo
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.poifs.filesystem.Entry
delete, getName, getParent, isDocumentEntry, renameTo

Method Detail

getPath

public POIFSDocumentPath getPath()
Returns:
this directory's path representation

getFileSystem

public POIFSFileSystem getFileSystem()
Returns:
the filesystem that this belongs to

getNFileSystem

public NPOIFSFileSystem getNFileSystem()
Returns:
the filesystem that this belongs to

createDocumentInputStream

public DocumentInputStream createDocumentInputStream(java.lang.String documentName)
                                              throws java.io.IOException
open a document in the directory's entry's list of entries

Parameters:
documentName - the name of the document to be opened
Returns:
a newly opened DocumentInputStream
Throws:
java.io.IOException - if the document does not exist or the name is that of a DirectoryEntry

createDocumentInputStream

public DocumentInputStream createDocumentInputStream(Entry document)
                                              throws java.io.IOException
open a document in the directory's entry's list of entries

Parameters:
document - the document to be opened
Returns:
a newly opened DocumentInputStream or NDocumentInputStream
Throws:
java.io.IOException - if the document does not exist or the name is that of a DirectoryEntry

getEntries

public java.util.Iterator<Entry> getEntries()
get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)

Specified by:
getEntries in interface DirectoryEntry
Returns:
iterator; never null, but hasNext() may return false immediately (i.e., this DirectoryEntry is empty). All objects retrieved by next() are guaranteed to be implementations of Entry.

isEmpty

public boolean isEmpty()
is this DirectoryEntry empty?

Specified by:
isEmpty in interface DirectoryEntry
Returns:
true if this instance contains no Entry instances

getEntryCount

public int getEntryCount()
find out how many Entry instances are contained directly within this DirectoryEntry

Specified by:
getEntryCount in interface DirectoryEntry
Returns:
number of immediately (no grandchildren etc.) contained Entry instances

hasEntry

public boolean hasEntry(java.lang.String name)
Description copied from interface: DirectoryEntry
Checks if entry with specified name present

Specified by:
hasEntry in interface DirectoryEntry

getEntry

public Entry getEntry(java.lang.String name)
               throws java.io.FileNotFoundException
get a specified Entry by name

Specified by:
getEntry in interface DirectoryEntry
Parameters:
name - the name of the Entry to obtain.
Returns:
the specified Entry, if it is directly contained in this DirectoryEntry
Throws:
java.io.FileNotFoundException - if no Entry with the specified name exists in this DirectoryEntry

createDocument

public DocumentEntry createDocument(java.lang.String name,
                                    java.io.InputStream stream)
                             throws java.io.IOException
create a new DocumentEntry

Specified by:
createDocument in interface DirectoryEntry
Parameters:
name - the name of the new DocumentEntry
stream - the InputStream from which to create the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

createDocument

public DocumentEntry createDocument(java.lang.String name,
                                    int size,
                                    POIFSWriterListener writer)
                             throws java.io.IOException
create a new DocumentEntry; the data will be provided later

Specified by:
createDocument in interface DirectoryEntry
Parameters:
name - the name of the new DocumentEntry
size - the size of the new DocumentEntry
writer - the writer of the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

createDirectory

public DirectoryEntry createDirectory(java.lang.String name)
                               throws java.io.IOException
create a new DirectoryEntry

Specified by:
createDirectory in interface DirectoryEntry
Parameters:
name - the name of the new DirectoryEntry
Returns:
the new DirectoryEntry
Throws:
java.io.IOException

getStorageClsid

public ClassID getStorageClsid()
Gets the storage clsid of the directory entry

Specified by:
getStorageClsid in interface DirectoryEntry
Returns:
storage Class ID

setStorageClsid

public void setStorageClsid(ClassID clsidStorage)
Sets the storage clsid for the directory entry

Specified by:
setStorageClsid in interface DirectoryEntry
Parameters:
clsidStorage - storage Class ID

isDirectoryEntry

public boolean isDirectoryEntry()
is this a DirectoryEntry?

Specified by:
isDirectoryEntry in interface Entry
Overrides:
isDirectoryEntry in class EntryNode
Returns:
true if the Entry is a DirectoryEntry, else false

isDeleteOK

protected boolean isDeleteOK()
extensions use this method to verify internal rules regarding deletion of the underlying store.

Specified by:
isDeleteOK in class EntryNode
Returns:
true if it's ok to delete the underlying store, else false

getViewableArray

public java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Specified by:
getViewableArray in interface POIFSViewable
Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

public java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Specified by:
getViewableIterator in interface POIFSViewable
Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

public boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Specified by:
preferArray in interface POIFSViewable
Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

public java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Specified by:
getShortDescription in interface POIFSViewable
Returns:
short description

iterator

public java.util.Iterator<Entry> iterator()
Returns an Iterator over all the entries

Specified by:
iterator in interface java.lang.Iterable<Entry>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentDescriptor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class DocumentDescriptor

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.DocumentDescriptor

public class DocumentDescriptor
extends java.lang.Object

Class DocumentDescriptor

Version:
%I%, %G%
Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
DocumentDescriptor(POIFSDocumentPath path, java.lang.String name)
Trivial constructor
Method Summary
boolean | equals(java.lang.Object o) equality.
int | hashCode() calculate and return the hashcode
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DocumentDescriptor

public DocumentDescriptor(POIFSDocumentPath path,
                          java.lang.String name)
Trivial constructor

Parameters:
path - the Document path
name - the Document name
Method Detail

equals

public boolean equals(java.lang.Object o)
equality. Two DocumentDescriptor instances are equal if they have equal paths and names

Overrides:
equals in class java.lang.Object
Parameters:
o - the object we're checking equality for
Returns:
true if the object is equal to this object

hashCode

public int hashCode()
calculate and return the hashcode

Overrides:
hashCode in class java.lang.Object
Returns:
hashcode

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentEntry

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Interface DocumentEntry

All Superinterfaces:
Entry
All Known Implementing Classes:
DocumentNode
public interface DocumentEntry
extends Entry

This interface defines methods specific to Document objects managed by a Filesystem instance.

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
 int getSize()
get the zize of the document, in bytes
Methods inherited from interface org.apache.poi.poifs.filesystem.Entry
delete, getName, getParent, isDirectoryEntry, isDocumentEntry, renameTo

Method Detail

getSize

int getSize()
get the zize of the document, in bytes

Returns:
size in bytes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class DocumentInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  org.apache.poi.poifs.filesystem.DocumentInputStream
All Implemented Interfaces:
java.io.Closeable, LittleEndianInput
Direct Known Subclasses:
NDocumentInputStream, ODocumentInputStream
public class DocumentInputStream
extends java.io.InputStream
implements LittleEndianInput

This class provides methods to read a DocumentEntry managed by a POIFSFileSystem or NPOIFSFileSystem instance. It creates the appropriate one, and delegates, allowing us to work transparently with the two.

Field Summary
protected static int | EOF returned by read operations if we're at end of document
protected static int | SIZE_INT
protected static int | SIZE_LONG
protected static int | SIZE_SHORT
Constructor Summary
protected | DocumentInputStream() For use by downstream implementations
 | DocumentInputStream(DocumentEntry document) Create an InputStream from the specified DocumentEntry
 | DocumentInputStream(NPOIFSDocument document) Create an InputStream from the specified Document
 | DocumentInputStream(POIFSDocument document) Create an InputStream from the specified Document
Method Summary
 int available()
 void close()
 void mark(int ignoredReadlimit)
 boolean markSupported()
Tests if this input stream supports the mark and reset methods.
 int read()
 int read(byte[] b)
 int read(byte[] b, int off, int len)
 byte readByte()
 double readDouble()
 void readFully(byte[] buf)
 void readFully(byte[] buf, int off, int len)
 int readInt()
 long readLong()
 short readShort()
 int readUByte()
 int readUShort()
 void reset()
Repositions this stream to the position at the time the mark() method was last called on this input stream.
 long skip(long n)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EOF

protected static final int EOF
returned by read operations if we're at end of document

See Also:
Constant Field Values

SIZE_SHORT

protected static final int SIZE_SHORT
See Also:
Constant Field Values

SIZE_INT

protected static final int SIZE_INT
See Also:
Constant Field Values

SIZE_LONG

protected static final int SIZE_LONG
See Also:
Constant Field Values
Constructor Detail

DocumentInputStream

protected DocumentInputStream()
For use by downstream implementations

DocumentInputStream

public DocumentInputStream(DocumentEntry document)
                    throws java.io.IOException
Create an InputStream from the specified DocumentEntry

Parameters:
document - the DocumentEntry to be read
Throws:
java.io.IOException - if the DocumentEntry cannot be opened (like, maybe it has been deleted?)

DocumentInputStream

public DocumentInputStream(POIFSDocument document)
Create an InputStream from the specified Document

Parameters:
document - the Document to be read

DocumentInputStream

public DocumentInputStream(NPOIFSDocument document)
Create an InputStream from the specified Document

Parameters:
document - the Document to be read
Method Detail

available

public int available()
Specified by:
available in interface LittleEndianInput
Overrides:
available in class java.io.InputStream

close

public void close()
Specified by:
close in interface java.io.Closeable
Overrides:
close in class java.io.InputStream

mark

public void mark(int ignoredReadlimit)
Overrides:
mark in class java.io.InputStream

markSupported

public boolean markSupported()
Tests if this input stream supports the mark and reset methods.

Overrides:
markSupported in class java.io.InputStream
Returns:
true always

read

public int read()
         throws java.io.IOException
Specified by:
read in class java.io.InputStream
Throws:
java.io.IOException

read

public int read(byte[] b)
         throws java.io.IOException
Overrides:
read in class java.io.InputStream
Throws:
java.io.IOException

read

public int read(byte[] b,
                int off,
                int len)
         throws java.io.IOException
Overrides:
read in class java.io.InputStream
Throws:
java.io.IOException

reset

public void reset()
Repositions this stream to the position at the time the mark() method was last called on this input stream. If mark() has not been called this method repositions the stream to its beginning.

Overrides:
reset in class java.io.InputStream

skip

public long skip(long n)
          throws java.io.IOException
Overrides:
skip in class java.io.InputStream
Throws:
java.io.IOException

readByte

public byte readByte()
Specified by:
readByte in interface LittleEndianInput

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput

readShort

public short readShort()
Specified by:
readShort in interface LittleEndianInput

readFully

public void readFully(byte[] buf)
Specified by:
readFully in interface LittleEndianInput

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput

readLong

public long readLong()
Specified by:
readLong in interface LittleEndianInput

readInt

public int readInt()
Specified by:
readInt in interface LittleEndianInput

readUShort

public int readUShort()
Specified by:
readUShort in interface LittleEndianInput

readUByte

public int readUByte()
Specified by:
readUByte in interface LittleEndianInput
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class DocumentNode

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.EntryNode
        extended by  org.apache.poi.poifs.filesystem.DocumentNode
All Implemented Interfaces:
POIFSViewable, DocumentEntry, Entry
public class DocumentNode
extends EntryNode
implements DocumentEntry, POIFSViewable

Simple implementation of DocumentEntry

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
int | getSize() get the zize of the document, in bytes
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
protected boolean | isDeleteOK() extensions use this method to verify internal rules regarding deletion of the underlying store.
boolean | isDocumentEntry() is this a DocumentEntry?
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator
Methods inherited from class org.apache.poi.poifs.filesystem.EntryNode
delete, getName, getParent, getProperty, isDirectoryEntry, isRoot, renameTo
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.poifs.filesystem.Entry
delete, getName, getParent, isDirectoryEntry, renameTo

Method Detail

getSize

public int getSize()
get the zize of the document, in bytes

Specified by:
getSize in interface DocumentEntry
Returns:
size in bytes

isDocumentEntry

public boolean isDocumentEntry()
is this a DocumentEntry?

Specified by:
isDocumentEntry in interface Entry
Overrides:
isDocumentEntry in class EntryNode
Returns:
true if the Entry is a DocumentEntry, else false

isDeleteOK

protected boolean isDeleteOK()
extensions use this method to verify internal rules regarding deletion of the underlying store.

Specified by:
isDeleteOK in class EntryNode
Returns:
true if it's ok to delete the underlying store, else false

getViewableArray

public java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Specified by:
getViewableArray in interface POIFSViewable
Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

public java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Specified by:
getViewableIterator in interface POIFSViewable
Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

public boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Specified by:
preferArray in interface POIFSViewable
Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

public java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Specified by:
getShortDescription in interface POIFSViewable
Returns:
short description
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentOutputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class DocumentOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  org.apache.poi.poifs.filesystem.DocumentOutputStream
All Implemented Interfaces:
java.io.Closeable, java.io.Flushable
public final class DocumentOutputStream
extends java.io.OutputStream

This class provides a wrapper over an OutputStream so that Document writers can't accidently go over their size limits

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
void | close() Closes this output stream and releases any system resources associated with this stream.
void | flush() Flushes this output stream and forces any buffered output bytes to be written out.
void | write(byte[] b) Writes b.length bytes from the specified byte array to this output stream.
void | write(byte[] b, int off, int len) Writes len bytes from the specified byte array starting at offset off to this output stream.
void | write(int b) Writes the specified byte to this output stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

write

public void write(int b)
           throws java.io.IOException
Writes the specified byte to this output stream. The general contract for write is that one byte is written to the output stream. The byte to be written is the eight low-order bits of the argument b. The 24 high-order bits of b are ignored.

Specified by:
write in class java.io.OutputStream
Parameters:
b - the byte.
Throws:
java.io.IOException - if an I/O error occurs. In particular, an IOException may be thrown if the output stream has been closed, or if the writer tries to write too much data.

write

public void write(byte[] b)
           throws java.io.IOException
Writes b.length bytes from the specified byte array to this output stream.

Overrides:
write in class java.io.OutputStream
Parameters:
b - the data.
Throws:
java.io.IOException - if an I/O error occurs.

write

public void write(byte[] b,
                  int off,
                  int len)
           throws java.io.IOException
Writes len bytes from the specified byte array starting at offset off to this output stream. The general contract for write(b, off, len) is that some of the bytes in the array b are written to the output stream in order; element b[off] is the first byte written and b[off+len-1] is the last byte written by this operation.

If b is null, a NullPointerException is thrown.

If off is negative, or len is negative, or off+len is greater than the length of the array b, then an IndexOutOfBoundsException is thrown.

Overrides:
write in class java.io.OutputStream
Parameters:
b - the data.
off - the start offset in the data.
len - the number of bytes to write.
Throws:
java.io.IOException - if an I/O error occurs. In particular, an IOException is thrown if the output stream is closed or if the writer tries to write too many bytes.

flush

public void flush()
           throws java.io.IOException
Flushes this output stream and forces any buffered output bytes to be written out.

Specified by:
flush in interface java.io.Flushable
Overrides:
flush in class java.io.OutputStream
Throws:
java.io.IOException - if an I/O error occurs.

close

public void close()
Closes this output stream and releases any system resources associated with this stream. The general contract of close is that it closes the output stream. A closed stream cannot perform output operations and cannot be reopened.

Specified by:
close in interface java.io.Closeable
Overrides:
close in class java.io.OutputStream
Throws:
java.io.IOException - if an I/O error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Entry

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Interface Entry

All Known Subinterfaces:
DirectoryEntry, DocumentEntry
All Known Implementing Classes:
DirectoryNode, DocumentNode, EntryNode, FilteringDirectoryNode
public interface Entry

This interface provides access to an object managed by a Filesystem instance. Entry objects are further divided into DocumentEntry and DirectoryEntry instances.

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
boolean | delete() Delete this Entry.
java.lang.String | getName() get the name of the Entry
DirectoryEntry | getParent() get this Entry's parent (the DirectoryEntry that owns this Entry).
boolean | isDirectoryEntry() is this a DirectoryEntry?
boolean | isDocumentEntry() is this a DocumentEntry?
boolean | renameTo(java.lang.String newName) Rename this Entry.

Method Detail

getName

java.lang.String getName()
get the name of the Entry

Returns:
name

isDirectoryEntry

boolean isDirectoryEntry()
is this a DirectoryEntry?

Returns:
true if the Entry is a DirectoryEntry, else false

isDocumentEntry

boolean isDocumentEntry()
is this a DocumentEntry?

Returns:
true if the Entry is a DocumentEntry, else false

getParent

DirectoryEntry getParent()
get this Entry's parent (the DirectoryEntry that owns this Entry). All Entry objects, except the root Entry, has a parent.

Returns:
this Entry's parent; null iff this is the root Entry

delete

boolean delete()
Delete this Entry. This operation should succeed, but there are special circumstances when it will not: If this Entry is the root of the Entry tree, it cannot be deleted, as there is no way to create another one. If this Entry is a directory, it cannot be deleted unless it is empty.

Returns:
true if the Entry was successfully deleted, else false

renameTo

boolean renameTo(java.lang.String newName)
Rename this Entry. This operation will fail if: There is a sibling Entry (i.e., an Entry whose parent is the same as this Entry's parent) with the same name. This Entry is the root of the Entry tree. Its name is dictated by the Filesystem and many not be changed.

Parameters:
newName - the new name for this Entry
Returns:
true if the operation succeeded, else false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntryNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class EntryNode

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.EntryNode
All Implemented Interfaces:
Entry
Direct Known Subclasses:
DirectoryNode, DocumentNode
public abstract class EntryNode
extends java.lang.Object
implements Entry

Abstract implementation of Entry Extending classes should override isDocument() or isDirectory(), as appropriate Extending classes must override isDeleteOK()

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
protected EntryNode(Property property, DirectoryNode parent)
create a DocumentNode.
Method Summary
boolean | delete() Delete this Entry.
java.lang.String | getName() get the name of the Entry
DirectoryEntry | getParent() get this Entry's parent (the DocumentEntry that owns this Entry).
protected Property | getProperty() grant access to the property
protected abstract boolean | isDeleteOK() extensions use this method to verify internal rules regarding deletion of the underlying store.
boolean | isDirectoryEntry() is this a DirectoryEntry?
boolean | isDocumentEntry() is this a DocumentEntry?
protected boolean | isRoot() is this the root of the tree?
boolean | renameTo(java.lang.String newName) Rename this Entry.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EntryNode

protected EntryNode(Property property,
                    DirectoryNode parent)
create a DocumentNode. This method is not public by design; it is intended strictly for the internal use of extending classes

Parameters:
property - the Property for this Entry
parent - the parent of this entry
Method Detail

getProperty

protected Property getProperty()
grant access to the property

Returns:
the property backing this entry

isRoot

protected boolean isRoot()
is this the root of the tree?

Returns:
true if so, else false

isDeleteOK

protected abstract boolean isDeleteOK()
extensions use this method to verify internal rules regarding deletion of the underlying store.

Returns:
true if it's ok to delete the underlying store, else false

getName

public java.lang.String getName()
get the name of the Entry

Specified by:
getName in interface Entry
Returns:
name

isDirectoryEntry

public boolean isDirectoryEntry()
is this a DirectoryEntry?

Specified by:
isDirectoryEntry in interface Entry
Returns:
true if the Entry is a DirectoryEntry, else false

isDocumentEntry

public boolean isDocumentEntry()
is this a DocumentEntry?

Specified by:
isDocumentEntry in interface Entry
Returns:
true if the Entry is a DocumentEntry, else false

getParent

public DirectoryEntry getParent()
get this Entry's parent (the DocumentEntry that owns this Entry). All Entry objects, except the root Entry, has a parent.

Specified by:
getParent in interface Entry
Returns:
this Entry's parent; null iff this is the root Entry

delete

public boolean delete()
Delete this Entry. This operation should succeed, but there are special circumstances when it will not: If this Entry is the root of the Entry tree, it cannot be deleted, as there is no way to create another one. If this Entry is a directory, it cannot be deleted unless it is empty.

Specified by:
delete in interface Entry
Returns:
true if the Entry was successfully deleted, else false

renameTo

public boolean renameTo(java.lang.String newName)
Rename this Entry. This operation will fail if: There is a sibling Entry (i.e., an Entry whose parent is the same as this Entry's parent) with the same name. This Entry is the root of the Entry tree. Its name is dictated by the Filesystem and many not be changed.

Specified by:
renameTo in interface Entry
Parameters:
newName - the new name for this Entry
Returns:
true if the operation succeeded, else false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntryUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class EntryUtils

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.EntryUtils

@Internal
public class EntryUtils
extends java.lang.Object

Constructor Summary
EntryUtils()
Method Summary
static boolean | areDirectoriesIdentical(DirectoryEntry dirA, DirectoryEntry dirB) Checks to see if the two Directories hold the same contents.
static boolean | areDocumentsIdentical(DocumentEntry docA, DocumentEntry docB) Checks to see if two Documents have the same name and the same contents.
static void | copyNodeRecursively(Entry entry, DirectoryEntry target) Copies an Entry into a target POIFS directory, recursively
static void | copyNodes(DirectoryEntry sourceRoot, DirectoryEntry targetRoot) Copies all the nodes from one POIFS Directory to another
static void | copyNodes(DirectoryEntry sourceRoot, DirectoryEntry targetRoot, java.util.List<java.lang.String> excepts) Deprecated. use FilteringDirectoryNode instead
static void | copyNodes(FilteringDirectoryNode filteredSource, FilteringDirectoryNode filteredTarget) Copies nodes from one Directory to the other minus the excepts
static void | copyNodes(POIFSFileSystem source, POIFSFileSystem target) Copies all nodes from one POIFS to the other
static void | copyNodes(POIFSFileSystem source, POIFSFileSystem target, java.util.List<java.lang.String> excepts) Copies nodes from one POIFS to the other, minus the excepts.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EntryUtils

public EntryUtils()
Method Detail

copyNodeRecursively

@Internal
public static void copyNodeRecursively(Entry entry,
                                                DirectoryEntry target)
                                throws java.io.IOException
Copies an Entry into a target POIFS directory, recursively

Throws:
java.io.IOException

copyNodes

public static void copyNodes(DirectoryEntry sourceRoot,
                             DirectoryEntry targetRoot)
                      throws java.io.IOException
Copies all the nodes from one POIFS Directory to another

Parameters:
sourceRoot - is the source Directory to copy from
targetRoot - is the target Directory to copy to
Throws:
java.io.IOException

copyNodes

public static void copyNodes(FilteringDirectoryNode filteredSource,
                             FilteringDirectoryNode filteredTarget)
                      throws java.io.IOException
Copies nodes from one Directory to the other minus the excepts

Parameters:
filteredSource - The filtering source Directory to copy from
filteredTarget - The filtering target Directory to copy to
Throws:
java.io.IOException

copyNodes

public static void copyNodes(DirectoryEntry sourceRoot,
                             DirectoryEntry targetRoot,
                             java.util.List<java.lang.String> excepts)
                      throws java.io.IOException
Deprecated. use FilteringDirectoryNode instead

Copies nodes from one Directory to the other minus the excepts

Parameters:
sourceRoot - is the source Directory to copy from
targetRoot - is the target Directory to copy to
excepts - is a list of Strings specifying what nodes NOT to copy
Throws:
java.io.IOException

copyNodes

public static void copyNodes(POIFSFileSystem source,
                             POIFSFileSystem target)
                      throws java.io.IOException
Copies all nodes from one POIFS to the other

Parameters:
source - is the source POIFS to copy from
target - is the target POIFS to copy to
Throws:
java.io.IOException

copyNodes

public static void copyNodes(POIFSFileSystem source,
                             POIFSFileSystem target,
                             java.util.List<java.lang.String> excepts)
                      throws java.io.IOException
Copies nodes from one POIFS to the other, minus the excepts. This delegates the filtering work to FilteringDirectoryNode, so excepts can be of the form "NodeToExclude" or "FilteringDirectory/ExcludedChildNode"

Parameters:
source - is the source POIFS to copy from
target - is the target POIFS to copy to
excepts - is a list of Entry Names to be excluded from the copy
Throws:
java.io.IOException

areDirectoriesIdentical

public static boolean areDirectoriesIdentical(DirectoryEntry dirA,
                                              DirectoryEntry dirB)
Checks to see if the two Directories hold the same contents. For this to be true, they must have entries with the same names, no entries in one but not the other, and the size+contents of each entry must match, and they must share names. To exclude certain parts of the Directory from being checked, use a FilteringDirectoryNode

areDocumentsIdentical

public static boolean areDocumentsIdentical(DocumentEntry docA,
                                            DocumentEntry docB)
                                     throws java.io.IOException
Checks to see if two Documents have the same name and the same contents. (Their parent directories are not checked)

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilteringDirectoryNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class FilteringDirectoryNode

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.FilteringDirectoryNode
All Implemented Interfaces:
java.lang.Iterable<Entry>, DirectoryEntry, Entry
public class FilteringDirectoryNode
extends java.lang.Object
implements DirectoryEntry

A DirectoryEntry filter, which exposes another DirectoryEntry less certain parts. This is typically used when copying or comparing Filesystems.

Constructor Summary
FilteringDirectoryNode(DirectoryEntry directory, java.util.Collection<java.lang.String> excludes)
Creates a filter round the specified directory, which will exclude entries such as "MyNode" and "MyDir/IgnoreNode".
Method Summary
DirectoryEntry | createDirectory(java.lang.String name) create a new DirectoryEntry
DocumentEntry | createDocument(java.lang.String name, java.io.InputStream stream) create a new DocumentEntry
DocumentEntry | createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry; the data will be provided later
boolean | delete() Delete this Entry.
java.util.Iterator<Entry> | getEntries() get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)
Entry | getEntry(java.lang.String name) get a specified Entry by name
int | getEntryCount() find out how many Entry instances are contained directly within this DirectoryEntry
java.lang.String | getName() get the name of the Entry
DirectoryEntry | getParent() get this Entry's parent (the DirectoryEntry that owns this Entry).
ClassID | getStorageClsid() Gets the storage clsid of the directory entry
boolean | hasEntry(java.lang.String name) Checks if entry with specified name present
boolean | isDirectoryEntry() is this a DirectoryEntry?
boolean | isDocumentEntry() is this a DocumentEntry?
boolean | isEmpty() is this DirectoryEntry empty?
java.util.Iterator<Entry> | iterator()
boolean | renameTo(java.lang.String newName) Rename this Entry.
void | setStorageClsid(ClassID clsidStorage) Sets the storage clsid for the directory entry
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FilteringDirectoryNode

public FilteringDirectoryNode(DirectoryEntry directory,
                              java.util.Collection<java.lang.String> excludes)
Creates a filter round the specified directory, which will exclude entries such as "MyNode" and "MyDir/IgnoreNode". The excludes can stretch into children, if they contain a /.

Parameters:
directory - The Directory to filter
excludes - The Entries to exclude
Method Detail

createDirectory

public DirectoryEntry createDirectory(java.lang.String name)
                               throws java.io.IOException
Description copied from interface: DirectoryEntry
create a new DirectoryEntry

Specified by:
createDirectory in interface DirectoryEntry
Parameters:
name - the name of the new DirectoryEntry
Returns:
the new DirectoryEntry
Throws:
java.io.IOException

createDocument

public DocumentEntry createDocument(java.lang.String name,
                                    java.io.InputStream stream)
                             throws java.io.IOException
Description copied from interface: DirectoryEntry
create a new DocumentEntry

Specified by:
createDocument in interface DirectoryEntry
Parameters:
name - the name of the new DocumentEntry
stream - the InputStream from which to create the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

createDocument

public DocumentEntry createDocument(java.lang.String name,
                                    int size,
                                    POIFSWriterListener writer)
                             throws java.io.IOException
Description copied from interface: DirectoryEntry
create a new DocumentEntry; the data will be provided later

Specified by:
createDocument in interface DirectoryEntry
Parameters:
name - the name of the new DocumentEntry
size - the size of the new DocumentEntry
writer - the writer of the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

getEntries

public java.util.Iterator<Entry> getEntries()
Description copied from interface: DirectoryEntry
get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)

Specified by:
getEntries in interface DirectoryEntry
Returns:
iterator; never null, but hasNext() may return false immediately (i.e., this DirectoryEntry is empty). All objects retrieved by next() are guaranteed to be implementations of Entry.

iterator

public java.util.Iterator<Entry> iterator()
Specified by:
iterator in interface java.lang.Iterable<Entry>

getEntryCount

public int getEntryCount()
Description copied from interface: DirectoryEntry
find out how many Entry instances are contained directly within this DirectoryEntry

Specified by:
getEntryCount in interface DirectoryEntry
Returns:
number of immediately (no grandchildren etc.) contained Entry instances

isEmpty

public boolean isEmpty()
Description copied from interface: DirectoryEntry
is this DirectoryEntry empty?

Specified by:
isEmpty in interface DirectoryEntry
Returns:
true if this instance contains no Entry instances

hasEntry

public boolean hasEntry(java.lang.String name)
Description copied from interface: DirectoryEntry
Checks if entry with specified name present

Specified by:
hasEntry in interface DirectoryEntry

getEntry

public Entry getEntry(java.lang.String name)
               throws java.io.FileNotFoundException
Description copied from interface: DirectoryEntry
get a specified Entry by name

Specified by:
getEntry in interface DirectoryEntry
Parameters:
name - the name of the Entry to obtain.
Returns:
the specified Entry, if it is directly contained in this DirectoryEntry
Throws:
java.io.FileNotFoundException - if no Entry with the specified name exists in this DirectoryEntry

getStorageClsid

public ClassID getStorageClsid()
Description copied from interface: DirectoryEntry
Gets the storage clsid of the directory entry

Specified by:
getStorageClsid in interface DirectoryEntry
Returns:
storage Class ID

setStorageClsid

public void setStorageClsid(ClassID clsidStorage)
Description copied from interface: DirectoryEntry
Sets the storage clsid for the directory entry

Specified by:
setStorageClsid in interface DirectoryEntry
Parameters:
clsidStorage - storage Class ID

delete

public boolean delete()
Description copied from interface: Entry
Delete this Entry. This operation should succeed, but there are special circumstances when it will not: If this Entry is the root of the Entry tree, it cannot be deleted, as there is no way to create another one. If this Entry is a directory, it cannot be deleted unless it is empty.

Specified by:
delete in interface Entry
Returns:
true if the Entry was successfully deleted, else false

renameTo

public boolean renameTo(java.lang.String newName)
Description copied from interface: Entry
Rename this Entry. This operation will fail if: There is a sibling Entry (i.e., an Entry whose parent is the same as this Entry's parent) with the same name. This Entry is the root of the Entry tree. Its name is dictated by the Filesystem and many not be changed.

Specified by:
renameTo in interface Entry
Parameters:
newName - the new name for this Entry
Returns:
true if the operation succeeded, else false

getName

public java.lang.String getName()
Description copied from interface: Entry
get the name of the Entry

Specified by:
getName in interface Entry
Returns:
name

getParent

public DirectoryEntry getParent()
Description copied from interface: Entry
get this Entry's parent (the DirectoryEntry that owns this Entry). All Entry objects, except the root Entry, has a parent.

Specified by:
getParent in interface Entry
Returns:
this Entry's parent; null iff this is the root Entry

isDirectoryEntry

public boolean isDirectoryEntry()
Description copied from interface: Entry
is this a DirectoryEntry?

Specified by:
isDirectoryEntry in interface Entry
Returns:
true if the Entry is a DirectoryEntry, else false

isDocumentEntry

public boolean isDocumentEntry()
Description copied from interface: Entry
is this a DocumentEntry?

Specified by:
isDocumentEntry in interface Entry
Returns:
true if the Entry is a DocumentEntry, else false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NDocumentInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class NDocumentInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  org.apache.poi.poifs.filesystem.DocumentInputStream
            extended by  org.apache.poi.poifs.filesystem.NDocumentInputStream
All Implemented Interfaces:
java.io.Closeable, LittleEndianInput
public final class NDocumentInputStream
extends DocumentInputStream

This class provides methods to read a DocumentEntry managed by a NPOIFSFileSystem instance.

Field Summary
Fields inherited from class org.apache.poi.poifs.filesystem.DocumentInputStream
EOF, SIZE_INT, SIZE_LONG, SIZE_SHORT
Constructor Summary
NDocumentInputStream(DocumentEntry document)
Create an InputStream from the specified DocumentEntry
NDocumentInputStream(NPOIFSDocument document)
Create an InputStream from the specified Document
Method Summary
 int available()
 void close()
 void mark(int ignoredReadlimit)
 int read()
 int read(byte[] b, int off, int len)
 byte readByte()
 double readDouble()
 void readFully(byte[] buf, int off, int len)
 int readInt()
 long readLong()
 short readShort()
 int readUByte()
 int readUShort()
 void reset()
Repositions this stream to the position at the time the mark() method was last called on this input stream.
 long skip(long n)
Methods inherited from class org.apache.poi.poifs.filesystem.DocumentInputStream
markSupported, read, readFully
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NDocumentInputStream

public NDocumentInputStream(DocumentEntry document)
                     throws java.io.IOException
Create an InputStream from the specified DocumentEntry

Parameters:
document - the DocumentEntry to be read
Throws:
java.io.IOException - if the DocumentEntry cannot be opened (like, maybe it has been deleted?)

NDocumentInputStream

public NDocumentInputStream(NPOIFSDocument document)
Create an InputStream from the specified Document

Parameters:
document - the Document to be read
Method Detail

available

public int available()
Specified by:
available in interface LittleEndianInput
Overrides:
available in class DocumentInputStream

close

public void close()
Specified by:
close in interface java.io.Closeable
Overrides:
close in class DocumentInputStream

mark

public void mark(int ignoredReadlimit)
Overrides:
mark in class DocumentInputStream

read

public int read()
         throws java.io.IOException
Overrides:
read in class DocumentInputStream
Throws:
java.io.IOException

read

public int read(byte[] b,
                int off,
                int len)
         throws java.io.IOException
Overrides:
read in class DocumentInputStream
Throws:
java.io.IOException

reset

public void reset()
Repositions this stream to the position at the time the mark() method was last called on this input stream. If mark() has not been called this method repositions the stream to its beginning.

Overrides:
reset in class DocumentInputStream

skip

public long skip(long n)
          throws java.io.IOException
Overrides:
skip in class DocumentInputStream
Throws:
java.io.IOException

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput
Overrides:
readFully in class DocumentInputStream

readByte

public byte readByte()
Specified by:
readByte in interface LittleEndianInput
Overrides:
readByte in class DocumentInputStream

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput
Overrides:
readDouble in class DocumentInputStream

readLong

public long readLong()
Specified by:
readLong in interface LittleEndianInput
Overrides:
readLong in class DocumentInputStream

readShort

public short readShort()
Specified by:
readShort in interface LittleEndianInput
Overrides:
readShort in class DocumentInputStream

readInt

public int readInt()
Specified by:
readInt in interface LittleEndianInput
Overrides:
readInt in class DocumentInputStream

readUShort

public int readUShort()
Specified by:
readUShort in interface LittleEndianInput
Overrides:
readUShort in class DocumentInputStream

readUByte

public int readUByte()
Specified by:
readUByte in interface LittleEndianInput
Overrides:
readUByte in class DocumentInputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NPOIFSDocument

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class NPOIFSDocument

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.NPOIFSDocument
All Implemented Interfaces:
POIFSViewable
public final class NPOIFSDocument
extends java.lang.Object
implements POIFSViewable

This class manages a document in the NIO POIFS filesystem. This is the NPOIFSFileSystem version.

Constructor Summary
NPOIFSDocument(DocumentProperty property, NPOIFSFileSystem filesystem)
Constructor for an existing Document
NPOIFSDocument(java.lang.String name, NPOIFSFileSystem filesystem, java.io.InputStream stream)
Constructor for a new Document
Method Summary
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
int | getSize()
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NPOIFSDocument

public NPOIFSDocument(DocumentProperty property,
                      NPOIFSFileSystem filesystem)
               throws java.io.IOException
Constructor for an existing Document

Throws:
java.io.IOException

NPOIFSDocument

public NPOIFSDocument(java.lang.String name,
                      NPOIFSFileSystem filesystem,
                      java.io.InputStream stream)
               throws java.io.IOException
Constructor for a new Document

Parameters:
name - the name of the POIFSDocument
stream - the InputStream we read data from
Throws:
java.io.IOException
Method Detail

getSize

public int getSize()
Returns:
size of the document

getViewableArray

public java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Specified by:
getViewableArray in interface POIFSViewable
Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

public java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Specified by:
getViewableIterator in interface POIFSViewable
Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

public boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Specified by:
preferArray in interface POIFSViewable
Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

public java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Specified by:
getShortDescription in interface POIFSViewable
Returns:
short description
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NPOIFSFileSystem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class NPOIFSFileSystem

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.BlockStore
        extended by  org.apache.poi.poifs.filesystem.NPOIFSFileSystem
All Implemented Interfaces:
java.io.Closeable, POIFSViewable
public class NPOIFSFileSystem
extends BlockStore
implements POIFSViewable, java.io.Closeable

This is the main class of the POIFS system; it manages the entire life cycle of the filesystem. This is the new NIO version

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.poifs.filesystem.BlockStore
BlockStore.ChainLoopDetector
Constructor Summary
NPOIFSFileSystem()
Constructor, intended for writing
NPOIFSFileSystem(java.io.File file)
Creates a POIFSFileSystem from a File.
NPOIFSFileSystem(java.io.File file, boolean readOnly)
Creates a POIFSFileSystem from a File.
NPOIFSFileSystem(java.nio.channels.FileChannel channel)
Creates a POIFSFileSystem from an open FileChannel.
NPOIFSFileSystem(java.io.InputStream stream)
Create a POIFSFileSystem from an InputStream.
Method Summary
void | close() Closes the FileSystem, freeing any underlying files, streams and buffers.
protected java.nio.ByteBuffer | createBlockIfNeeded(int offset) Load the block at the given offset, extending the file if needed
DirectoryEntry | createDirectory(java.lang.String name) create a new DirectoryEntry in the root directory
DocumentEntry | createDocument(java.io.InputStream stream, java.lang.String name) Create a new document to be added to the root directory
DocumentEntry | createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry in the root entry; the data will be provided later
DocumentInputStream | createDocumentInputStream(java.lang.String documentName) open a document in the root entry's list of entries
static java.io.InputStream | createNonClosingInputStream(java.io.InputStream is) Convenience method for clients that want to avoid the auto-close behaviour of the constructor.
protected BATBlock.BATBlockAndIndex | getBATBlockAndIndex(int offset) Returns the BATBlock that handles the specified offset, and the relative index within it
int | getBigBlockSize()
POIFSBigBlockSize | getBigBlockSizeDetails()
protected java.nio.ByteBuffer | getBlockAt(int offset) Load the block at the given offset.
protected int | getBlockStoreBlockSize() Returns the size of the blocks managed through the block store.
protected BlockStore.ChainLoopDetector | getChainLoopDetector() Creates a Detector for loops in the chain
protected int | getFreeBlock() Finds a free block, and returns its offset.
NPOIFSMiniStore | getMiniStore() Returns the MiniStore, which performs a similar low level function to this, except for the small blocks.
protected int | getNextBlock(int offset) Works out what block follows the specified one.
DirectoryNode | getRoot() Get the root entry
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
static boolean | hasPOIFSHeader(java.io.InputStream inp) Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a POIFS (OLE2) header at the start of it.
static void | main(java.lang.String[] args) read in a file and write it back out again
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator
protected void | setNextBlock(int offset, int nextBlock) Changes the record of what block follows the specified one.
void | writeFilesystem() Write the filesystem out to the open file.
void | writeFilesystem(java.io.OutputStream stream) Write the filesystem out
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NPOIFSFileSystem

public NPOIFSFileSystem()
Constructor, intended for writing

NPOIFSFileSystem

public NPOIFSFileSystem(java.io.File file)
                 throws java.io.IOException
Creates a POIFSFileSystem from a File. This uses less memory than creating from an InputStream. The File will be opened read-only Note that with this constructor, you will need to call close() when you're done to have the underlying file closed, as the file is kept open during normal operation to read the data out.

Parameters:
file - the File from which to read the data
Throws:
java.io.IOException - on errors reading, or on invalid data

NPOIFSFileSystem

public NPOIFSFileSystem(java.io.File file,
                        boolean readOnly)
                 throws java.io.IOException
Creates a POIFSFileSystem from a File. This uses less memory than creating from an InputStream. Note that with this constructor, you will need to call close() when you're done to have the underlying file closed, as the file is kept open during normal operation to read the data out.

Parameters:
file - the File from which to read the data
Throws:
java.io.IOException - on errors reading, or on invalid data

NPOIFSFileSystem

public NPOIFSFileSystem(java.nio.channels.FileChannel channel)
                 throws java.io.IOException
Creates a POIFSFileSystem from an open FileChannel. This uses less memory than creating from an InputStream. Note that with this constructor, you will need to call close() when you're done to have the underlying Channel closed, as the channel is kept open during normal operation to read the data out.

Parameters:
channel - the FileChannel from which to read the data
Throws:
java.io.IOException - on errors reading, or on invalid data

NPOIFSFileSystem

public NPOIFSFileSystem(java.io.InputStream stream)
                 throws java.io.IOException
Create a POIFSFileSystem from an InputStream. Normally the stream is read until EOF. The stream is always closed.

Some streams are usable after reaching EOF (typically those that return true for markSupported()). In the unlikely case that the caller has such a stream and needs to use it after this constructor completes, a work around is to wrap the stream in order to trap the close() call. A convenience method ( createNonClosingInputStream()) has been provided for this purpose:

 InputStream wrappedStream = POIFSFileSystem.createNonClosingInputStream(is);
 HSSFWorkbook wb = new HSSFWorkbook(wrappedStream);
 is.reset();
 doSomethingElse(is);
Note also the special case of ByteArrayInputStream for which the close() method does nothing.
 ByteArrayInputStream bais = ...
 HSSFWorkbook wb = new HSSFWorkbook(bais); // calls bais.close() !
 bais.reset(); // no problem
 doSomethingElse(bais);

Parameters:
stream - the InputStream from which to read the data
Throws:
java.io.IOException - on errors reading, or on invalid data
Method Detail

createNonClosingInputStream

public static java.io.InputStream createNonClosingInputStream(java.io.InputStream is)
Convenience method for clients that want to avoid the auto-close behaviour of the constructor.

hasPOIFSHeader

public static boolean hasPOIFSHeader(java.io.InputStream inp)
                              throws java.io.IOException
Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a POIFS (OLE2) header at the start of it. If your InputStream does not support mark / reset, then wrap it in a PushBackInputStream, then be sure to always use that, and not the original!

Parameters:
inp - An InputStream which supports either mark/reset, or is a PushbackInputStream
Throws:
java.io.IOException

getBlockAt

protected java.nio.ByteBuffer getBlockAt(int offset)
                                  throws java.io.IOException
Load the block at the given offset.

Specified by:
getBlockAt in class BlockStore
Throws:
java.io.IOException

createBlockIfNeeded

protected java.nio.ByteBuffer createBlockIfNeeded(int offset)
                                           throws java.io.IOException
Load the block at the given offset, extending the file if needed

Specified by:
createBlockIfNeeded in class BlockStore
Throws:
java.io.IOException

getBATBlockAndIndex

protected BATBlock.BATBlockAndIndex getBATBlockAndIndex(int offset)
Returns the BATBlock that handles the specified offset, and the relative index within it

Specified by:
getBATBlockAndIndex in class BlockStore

getNextBlock

protected int getNextBlock(int offset)
Works out what block follows the specified one.

Specified by:
getNextBlock in class BlockStore

setNextBlock

protected void setNextBlock(int offset,
                            int nextBlock)
Changes the record of what block follows the specified one.

Specified by:
setNextBlock in class BlockStore

getFreeBlock

protected int getFreeBlock()
                    throws java.io.IOException
Finds a free block, and returns its offset. This method will extend the file if needed, and if doing so, allocate new FAT blocks to address the extra space.

Specified by:
getFreeBlock in class BlockStore
Throws:
java.io.IOException

getChainLoopDetector

protected BlockStore.ChainLoopDetector getChainLoopDetector()
                                                     throws java.io.IOException
Description copied from class: BlockStore
Creates a Detector for loops in the chain

Specified by:
getChainLoopDetector in class BlockStore
Throws:
java.io.IOException

getMiniStore

public NPOIFSMiniStore getMiniStore()
Returns the MiniStore, which performs a similar low level function to this, except for the small blocks.

createDocument

public DocumentEntry createDocument(java.io.InputStream stream,
                                    java.lang.String name)
                             throws java.io.IOException
Create a new document to be added to the root directory

Parameters:
stream - the InputStream from which the document's data will be obtained
name - the name of the new POIFSDocument
Returns:
the new DocumentEntry
Throws:
java.io.IOException - on error creating the new POIFSDocument

createDocument

public DocumentEntry createDocument(java.lang.String name,
                                    int size,
                                    POIFSWriterListener writer)
                             throws java.io.IOException
create a new DocumentEntry in the root entry; the data will be provided later

Parameters:
name - the name of the new DocumentEntry
size - the size of the new DocumentEntry
writer - the writer of the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

createDirectory

public DirectoryEntry createDirectory(java.lang.String name)
                               throws java.io.IOException
create a new DirectoryEntry in the root directory

Parameters:
name - the name of the new DirectoryEntry
Returns:
the new DirectoryEntry
Throws:
java.io.IOException - on name duplication

writeFilesystem

public void writeFilesystem()
                     throws java.io.IOException
Write the filesystem out to the open file. Will thrown an IllegalArgumentException if opened from an InputStream.

Throws:
java.io.IOException - thrown on errors writing to the stream

writeFilesystem

public void writeFilesystem(java.io.OutputStream stream)
                     throws java.io.IOException
Write the filesystem out

Parameters:
stream - the OutputStream to which the filesystem will be written
Throws:
java.io.IOException - thrown on errors writing to the stream

close

public void close()
           throws java.io.IOException
Closes the FileSystem, freeing any underlying files, streams and buffers. After this, you will be unable to read or write from the FileSystem.

Specified by:
close in interface java.io.Closeable
Throws:
java.io.IOException

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
read in a file and write it back out again

Parameters:
args - names of the files; arg[ 0 ] is the input file, arg[ 1 ] is the output file
Throws:
java.io.IOException

getRoot

public DirectoryNode getRoot()
Get the root entry

Returns:
the root entry

createDocumentInputStream

public DocumentInputStream createDocumentInputStream(java.lang.String documentName)
                                              throws java.io.IOException
open a document in the root entry's list of entries

Parameters:
documentName - the name of the document to be opened
Returns:
a newly opened DocumentInputStream
Throws:
java.io.IOException - if the document does not exist or the name is that of a DirectoryEntry

getViewableArray

public java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Specified by:
getViewableArray in interface POIFSViewable
Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

public java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Specified by:
getViewableIterator in interface POIFSViewable
Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

public boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Specified by:
preferArray in interface POIFSViewable
Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

public java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Specified by:
getShortDescription in interface POIFSViewable
Returns:
short description

getBigBlockSize

public int getBigBlockSize()
Returns:
The Big Block size, normally 512 bytes, sometimes 4096 bytes

getBigBlockSizeDetails

public POIFSBigBlockSize getBigBlockSizeDetails()
Returns:
The Big Block size, normally 512 bytes, sometimes 4096 bytes

getBlockStoreBlockSize

protected int getBlockStoreBlockSize()
Description copied from class: BlockStore
Returns the size of the blocks managed through the block store.

Specified by:
getBlockStoreBlockSize in class BlockStore
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NPOIFSMiniStore

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class NPOIFSMiniStore

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.BlockStore
        extended by  org.apache.poi.poifs.filesystem.NPOIFSMiniStore

public class NPOIFSMiniStore
extends BlockStore

This class handles the MiniStream (small block store) in the NIO case for NPOIFSFileSystem

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.poifs.filesystem.BlockStore
BlockStore.ChainLoopDetector
Constructor Summary
protected NPOIFSMiniStore(NPOIFSFileSystem filesystem, RootProperty root, java.util.List<BATBlock> sbats, HeaderBlock header)
Method Summary
protected java.nio.ByteBuffer | createBlockIfNeeded(int offset) Load the block, extending the underlying stream if needed
protected BATBlock.BATBlockAndIndex | getBATBlockAndIndex(int offset) Returns the BATBlock that handles the specified offset, and the relative index within it
protected java.nio.ByteBuffer | getBlockAt(int offset) Load the block at the given offset.
protected int | getBlockStoreBlockSize() Returns the size of the blocks managed through the block store.
protected BlockStore.ChainLoopDetector | getChainLoopDetector() Creates a Detector for loops in the chain
protected int | getFreeBlock() Finds a free block, and returns its offset.
protected int | getNextBlock(int offset) Works out what block follows the specified one.
protected void | setNextBlock(int offset, int nextBlock) Changes the record of what block follows the specified one.
protected void | syncWithDataSource() Writes the SBATs to their backing blocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NPOIFSMiniStore

protected NPOIFSMiniStore(NPOIFSFileSystem filesystem,
                          RootProperty root,
                          java.util.List<BATBlock> sbats,
                          HeaderBlock header)
Method Detail

getBlockAt

protected java.nio.ByteBuffer getBlockAt(int offset)
                                  throws java.io.IOException
Load the block at the given offset.

Specified by:
getBlockAt in class BlockStore
Throws:
java.io.IOException

createBlockIfNeeded

protected java.nio.ByteBuffer createBlockIfNeeded(int offset)
                                           throws java.io.IOException
Load the block, extending the underlying stream if needed

Specified by:
createBlockIfNeeded in class BlockStore
Throws:
java.io.IOException

getBATBlockAndIndex

protected BATBlock.BATBlockAndIndex getBATBlockAndIndex(int offset)
Returns the BATBlock that handles the specified offset, and the relative index within it

Specified by:
getBATBlockAndIndex in class BlockStore

getNextBlock

protected int getNextBlock(int offset)
Works out what block follows the specified one.

Specified by:
getNextBlock in class BlockStore

setNextBlock

protected void setNextBlock(int offset,
                            int nextBlock)
Changes the record of what block follows the specified one.

Specified by:
setNextBlock in class BlockStore

getFreeBlock

protected int getFreeBlock()
                    throws java.io.IOException
Finds a free block, and returns its offset. This method will extend the file if needed, and if doing so, allocate new FAT blocks to address the extra space.

Specified by:
getFreeBlock in class BlockStore
Throws:
java.io.IOException

getChainLoopDetector

protected BlockStore.ChainLoopDetector getChainLoopDetector()
                                                     throws java.io.IOException
Description copied from class: BlockStore
Creates a Detector for loops in the chain

Specified by:
getChainLoopDetector in class BlockStore
Throws:
java.io.IOException

getBlockStoreBlockSize

protected int getBlockStoreBlockSize()
Description copied from class: BlockStore
Returns the size of the blocks managed through the block store.

Specified by:
getBlockStoreBlockSize in class BlockStore

syncWithDataSource

protected void syncWithDataSource()
                           throws java.io.IOException
Writes the SBATs to their backing blocks

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NPOIFSStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class NPOIFSStream

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.NPOIFSStream
All Implemented Interfaces:
java.lang.Iterable<java.nio.ByteBuffer>
public class NPOIFSStream
extends java.lang.Object
implements java.lang.Iterable<java.nio.ByteBuffer>

This handles reading and writing a stream within a NPOIFSFileSystem. It can supply an iterator to read blocks, and way to write out to existing and new blocks. Most users will want a higher level version of this, which deals with properties to track which stream this is. This only works on big block streams, it doesn't handle small block ones. This uses the new NIO code TODO Implement a streaming write method, and append

Nested Class Summary
protected  class NPOIFSStream.StreamBlockByteBufferIterator
Class that handles a streaming read of one stream
Constructor Summary
NPOIFSStream(BlockStore blockStore)
Constructor for a new stream.
NPOIFSStream(BlockStore blockStore, int startBlock)
Constructor for an existing stream.
Method Summary
void | free() Frees all blocks in the stream
java.util.Iterator<java.nio.ByteBuffer> | getBlockIterator()
int | getStartBlock() What block does this stream start at? Will be POIFSConstants.END_OF_CHAIN for a new stream that hasn't been written to yet.
java.util.Iterator<java.nio.ByteBuffer> | iterator() Returns an iterator that'll supply one ByteBuffer per block in the stream.
void | updateContents(byte[] contents) Updates the contents of the stream to the new set of bytes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NPOIFSStream

public NPOIFSStream(BlockStore blockStore,
                    int startBlock)
Constructor for an existing stream. It's up to you to know how to get the start block (eg from a HeaderBlock or a Property)

NPOIFSStream

public NPOIFSStream(BlockStore blockStore)
Constructor for a new stream. A start block won't be allocated until you begin writing to it.

Method Detail

getStartBlock

public int getStartBlock()
What block does this stream start at? Will be POIFSConstants.END_OF_CHAIN for a new stream that hasn't been written to yet.

iterator

public java.util.Iterator<java.nio.ByteBuffer> iterator()
Returns an iterator that'll supply one ByteBuffer per block in the stream.

Specified by:
iterator in interface java.lang.Iterable<java.nio.ByteBuffer>

getBlockIterator

public java.util.Iterator<java.nio.ByteBuffer> getBlockIterator()

updateContents

public void updateContents(byte[] contents)
                    throws java.io.IOException
Updates the contents of the stream to the new set of bytes. Note - if this is property based, you'll still need to update the size in the property yourself

Throws:
java.io.IOException

free

public void free()
          throws java.io.IOException
Frees all blocks in the stream

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NPOIFSStream.StreamBlockByteBufferIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class NPOIFSStream.StreamBlockByteBufferIterator

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator
All Implemented Interfaces:
java.util.Iterator<java.nio.ByteBuffer>
Enclosing class:
NPOIFSStream
protected class NPOIFSStream.StreamBlockByteBufferIterator
extends java.lang.Object
implements java.util.Iterator<java.nio.ByteBuffer>

Class that handles a streaming read of one stream

Constructor Summary
protected NPOIFSStream.StreamBlockByteBufferIterator(int firstBlock)
Method Summary
boolean | hasNext()
java.nio.ByteBuffer | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NPOIFSStream.StreamBlockByteBufferIterator

protected NPOIFSStream.StreamBlockByteBufferIterator(int firstBlock)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface java.util.Iterator<java.nio.ByteBuffer>

next

public java.nio.ByteBuffer next()
Specified by:
next in interface java.util.Iterator<java.nio.ByteBuffer>

remove

public void remove()
Specified by:
remove in interface java.util.Iterator<java.nio.ByteBuffer>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ODocumentInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class ODocumentInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  org.apache.poi.poifs.filesystem.DocumentInputStream
            extended by  org.apache.poi.poifs.filesystem.ODocumentInputStream
All Implemented Interfaces:
java.io.Closeable, LittleEndianInput
public final class ODocumentInputStream
extends DocumentInputStream

This class provides methods to read a DocumentEntry managed by a POIFSFileSystem instance.

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
Fields inherited from class org.apache.poi.poifs.filesystem.DocumentInputStream
EOF, SIZE_INT, SIZE_LONG, SIZE_SHORT
Constructor Summary
ODocumentInputStream(DocumentEntry document)
Create an InputStream from the specified DocumentEntry
ODocumentInputStream(POIFSDocument document)
Create an InputStream from the specified Document
Method Summary
 int available()
 void close()
 void mark(int ignoredReadlimit)
 int read()
 int read(byte[] b, int off, int len)
 byte readByte()
 double readDouble()
 void readFully(byte[] buf, int off, int len)
 int readInt()
 long readLong()
 short readShort()
 int readUByte()
 int readUShort()
 void reset()
Repositions this stream to the position at the time the mark() method was last called on this input stream.
 long skip(long n)
Methods inherited from class org.apache.poi.poifs.filesystem.DocumentInputStream
markSupported, read, readFully
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ODocumentInputStream

public ODocumentInputStream(DocumentEntry document)
                     throws java.io.IOException
Create an InputStream from the specified DocumentEntry

Parameters:
document - the DocumentEntry to be read
Throws:
java.io.IOException - if the DocumentEntry cannot be opened (like, maybe it has been deleted?)

ODocumentInputStream

public ODocumentInputStream(POIFSDocument document)
Create an InputStream from the specified Document

Parameters:
document - the Document to be read
Method Detail

available

public int available()
Specified by:
available in interface LittleEndianInput
Overrides:
available in class DocumentInputStream

close

public void close()
Specified by:
close in interface java.io.Closeable
Overrides:
close in class DocumentInputStream

mark

public void mark(int ignoredReadlimit)
Overrides:
mark in class DocumentInputStream

read

public int read()
         throws java.io.IOException
Overrides:
read in class DocumentInputStream
Throws:
java.io.IOException

read

public int read(byte[] b,
                int off,
                int len)
         throws java.io.IOException
Overrides:
read in class DocumentInputStream
Throws:
java.io.IOException

reset

public void reset()
Repositions this stream to the position at the time the mark() method was last called on this input stream. If mark() has not been called this method repositions the stream to its beginning.

Overrides:
reset in class DocumentInputStream

skip

public long skip(long n)
          throws java.io.IOException
Overrides:
skip in class DocumentInputStream
Throws:
java.io.IOException

readByte

public byte readByte()
Specified by:
readByte in interface LittleEndianInput
Overrides:
readByte in class DocumentInputStream

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput
Overrides:
readDouble in class DocumentInputStream

readShort

public short readShort()
Specified by:
readShort in interface LittleEndianInput
Overrides:
readShort in class DocumentInputStream

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput
Overrides:
readFully in class DocumentInputStream

readLong

public long readLong()
Specified by:
readLong in interface LittleEndianInput
Overrides:
readLong in class DocumentInputStream

readInt

public int readInt()
Specified by:
readInt in interface LittleEndianInput
Overrides:
readInt in class DocumentInputStream

readUShort

public int readUShort()
Specified by:
readUShort in interface LittleEndianInput
Overrides:
readUShort in class DocumentInputStream

readUByte

public int readUByte()
Specified by:
readUByte in interface LittleEndianInput
Overrides:
readUByte in class DocumentInputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OfficeXmlFileException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class OfficeXmlFileException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  java.lang.IllegalArgumentException
                    extended by  org.apache.poi.poifs.filesystem.OfficeXmlFileException
All Implemented Interfaces:
java.io.Serializable
public class OfficeXmlFileException
extends java.lang.IllegalArgumentException

This exception is thrown when we try to open a file that's actually an Office 2007+ XML file, rather than an OLE2 file (which is what POI works with)

Author:
Nick Burch
See Also:
Serialized Form

Constructor Summary
OfficeXmlFileException(java.lang.String s)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OfficeXmlFileException

public OfficeXmlFileException(java.lang.String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Ole10Native

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class Ole10Native

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.Ole10Native

public class Ole10Native
extends java.lang.Object

Represents an Ole10Native record which is wrapped around certain binary files being embedded in OLE2 documents.

Author:
Rainer Schwarze

Field Summary
static java.lang.String OLE10_NATIVE
Constructor Summary
Ole10Native(byte[] data, int offset)
Creates an instance and fills the fields based on the data in the given buffer.
Ole10Native(byte[] data, int offset, boolean plain)
Creates an instance and fills the fields based on the data in the given buffer.
Method Summary
static Ole10Native | createFromEmbeddedOleObject(DirectoryNode directory) Creates an instance of this class from an embedded OLE Object.
static Ole10Native | createFromEmbeddedOleObject(POIFSFileSystem poifs) Creates an instance of this class from an embedded OLE Object.
java.lang.String | getCommand() Returns the command field - usually the name of the file being embedded including the full path, may be a command specified during embedding the file.
byte[] | getDataBuffer() Returns the buffer containing the embedded file's data, or null if no data was embedded.
int | getDataSize() Returns the size of the embedded file.
java.lang.String | getFileName() Returns the fileName field - usually the name of the file being embedded including the full path.
short | getFlags1() Returns flags1 - currently unknown - usually 0x0002.
short | getFlags2() Returns flags2 - currently unknown - mostly 0x0000.
short | getFlags3() Returns the flags3 - currently unknown.
java.lang.String | getLabel() Returns the label field - usually the name of the file (without directory) but probably may be any name specified during packaging/embedding the data.
int | getTotalSize() Returns the value of the totalSize field - the total length of the structure is totalSize + 4 (value of this field + size of this field).
byte[] | getUnknown1() Returns unknown1 field - currently unknown.
byte[] | getUnknown2() Returns the unknown2 field - currently being a byte[3] - mostly {0, 0, 0}.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OLE10_NATIVE

public static final java.lang.String OLE10_NATIVE
See Also:
Constant Field Values
Constructor Detail

Ole10Native

public Ole10Native(byte[] data,
                   int offset)
            throws Ole10NativeException
Creates an instance and fills the fields based on the data in the given buffer.

Parameters:
data - The buffer containing the Ole10Native record
offset - The start offset of the record in the buffer
Throws:
Ole10NativeException - on invalid or unexcepted data format

Ole10Native

public Ole10Native(byte[] data,
                   int offset,
                   boolean plain)
            throws Ole10NativeException
Creates an instance and fills the fields based on the data in the given buffer.

Parameters:
data - The buffer containing the Ole10Native record
offset - The start offset of the record in the buffer
plain - Specified 'plain' format without filename
Throws:
Ole10NativeException - on invalid or unexcepted data format
Method Detail

createFromEmbeddedOleObject

public static Ole10Native createFromEmbeddedOleObject(POIFSFileSystem poifs)
                                               throws java.io.IOException,
                                                      Ole10NativeException
Creates an instance of this class from an embedded OLE Object. The OLE Object is expected to include a stream "{01}Ole10Native" which contains the actual data relevant for this class.

Parameters:
poifs - POI Filesystem object
Returns:
Returns an instance of this class
Throws:
java.io.IOException - on IO error
Ole10NativeException - on invalid or unexcepted data format

createFromEmbeddedOleObject

public static Ole10Native createFromEmbeddedOleObject(DirectoryNode directory)
                                               throws java.io.IOException,
                                                      Ole10NativeException
Creates an instance of this class from an embedded OLE Object. The OLE Object is expected to include a stream "{01}Ole10Native" which contains the actual data relevant for this class.

Parameters:
directory - POI Filesystem object
Returns:
Returns an instance of this class
Throws:
java.io.IOException - on IO error
Ole10NativeException - on invalid or unexcepted data format

getTotalSize

public int getTotalSize()
Returns the value of the totalSize field - the total length of the structure is totalSize + 4 (value of this field + size of this field).

Returns:
the totalSize

getFlags1

public short getFlags1()
Returns flags1 - currently unknown - usually 0x0002.

Returns:
the flags1

getLabel

public java.lang.String getLabel()
Returns the label field - usually the name of the file (without directory) but probably may be any name specified during packaging/embedding the data.

Returns:
the label

getFileName

public java.lang.String getFileName()
Returns the fileName field - usually the name of the file being embedded including the full path.

Returns:
the fileName

getFlags2

public short getFlags2()
Returns flags2 - currently unknown - mostly 0x0000.

Returns:
the flags2

getUnknown1

public byte[] getUnknown1()
Returns unknown1 field - currently unknown.

Returns:
the unknown1

getUnknown2

public byte[] getUnknown2()
Returns the unknown2 field - currently being a byte[3] - mostly {0, 0, 0}.

Returns:
the unknown2

getCommand

public java.lang.String getCommand()
Returns the command field - usually the name of the file being embedded including the full path, may be a command specified during embedding the file.

Returns:
the command

getDataSize

public int getDataSize()
Returns the size of the embedded file. If the size is 0 (zero), no data has been embedded. To be sure, that no data has been embedded, check whether getDataBuffer() returns null.

Returns:
the dataSize

getDataBuffer

public byte[] getDataBuffer()
Returns the buffer containing the embedded file's data, or null if no data was embedded. Note that an embedding may provide information about the data, but the actual data is not included. (So label, filename etc. are available, but this method returns null.)

Returns:
the dataBuffer

getFlags3

public short getFlags3()
Returns the flags3 - currently unknown.

Returns:
the flags3
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Ole10NativeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class Ole10NativeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.poifs.filesystem.Ole10NativeException
All Implemented Interfaces:
java.io.Serializable
public class Ole10NativeException
extends java.lang.Exception

See Also:
Serialized Form

Constructor Summary
Ole10NativeException(java.lang.String message)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Ole10NativeException

public Ole10NativeException(java.lang.String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.poifs.filesystem
Interfaces
BATManaged
DirectoryEntry
DocumentEntry
Entry
POIFSWriterListener
Classes
BlockStore
DirectoryNode
DocumentDescriptor
DocumentInputStream
DocumentNode
DocumentOutputStream
EntryNode
EntryUtils
FilteringDirectoryNode
NDocumentInputStream
NPOIFSDocument
NPOIFSFileSystem
NPOIFSMiniStore
NPOIFSStream
ODocumentInputStream
Ole10Native
POIFSDocument
POIFSDocumentPath
POIFSFileSystem
POIFSWriterEvent
Exceptions
OfficeXmlFileException
Ole10NativeException


org.apache.poi.poifs.filesystem

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.filesystem

filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

See:
Description

Interface Summary
BATManaged | This interface defines behaviors for objects managed by the Block Allocation Table (BAT).
DirectoryEntry | This interface defines methods specific to Directory objects managed by a Filesystem instance.
DocumentEntry | This interface defines methods specific to Document objects managed by a Filesystem instance.
Entry | This interface provides access to an object managed by a Filesystem instance.
POIFSWriterListener | Interface POIFSWriterListener

Class Summary
BlockStore | This abstract class describes a way to read, store, chain and free a series of blocks (be they Big or Small ones)
DirectoryNode | Simple implementation of DirectoryEntry
DocumentDescriptor | Class DocumentDescriptor
DocumentInputStream | This class provides methods to read a DocumentEntry managed by a POIFSFileSystem or NPOIFSFileSystem instance.
DocumentNode | Simple implementation of DocumentEntry
DocumentOutputStream | This class provides a wrapper over an OutputStream so that Document writers can't accidently go over their size limits
EntryNode | Abstract implementation of Entry Extending classes should override isDocument() or isDirectory(), as appropriate Extending classes must override isDeleteOK()
EntryUtils |
FilteringDirectoryNode | A DirectoryEntry filter, which exposes another DirectoryEntry less certain parts.
NDocumentInputStream | This class provides methods to read a DocumentEntry managed by a NPOIFSFileSystem instance.
NPOIFSDocument | This class manages a document in the NIO POIFS filesystem.
NPOIFSFileSystem | This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
NPOIFSMiniStore | This class handles the MiniStream (small block store) in the NIO case for NPOIFSFileSystem
NPOIFSStream | This handles reading and writing a stream within a NPOIFSFileSystem.
ODocumentInputStream | This class provides methods to read a DocumentEntry managed by a POIFSFileSystem instance.
Ole10Native | Represents an Ole10Native record which is wrapped around certain binary files being embedded in OLE2 documents.
POIFSDocument | This class manages a document in the POIFS filesystem.
POIFSDocumentPath | Class POIFSDocumentPath
POIFSFileSystem | This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSWriterEvent | Class POIFSWriterEvent

Exception Summary
OfficeXmlFileException | This exception is thrown when we try to open a file that's actually an Office 2007+ XML file, rather than an OLE2 file (which is what POI works with)
Ole10NativeException |

Package org.apache.poi.poifs.filesystem Description

filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.poifs.eventfilesystem


org.apache.poi.poifs.filesystem Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.filesystem

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.filesystem.BlockStore
      • org.apache.poi.poifs.filesystem.NPOIFSFileSystem (implements java.io.Closeable, org.apache.poi.poifs.dev.POIFSViewable)
      • org.apache.poi.poifs.filesystem.NPOIFSMiniStore
    • org.apache.poi.poifs.filesystem.BlockStore.ChainLoopDetector
    • org.apache.poi.poifs.filesystem.DocumentDescriptor
    • org.apache.poi.poifs.filesystem.EntryNode (implements org.apache.poi.poifs.filesystem.Entry)
      • org.apache.poi.poifs.filesystem.DirectoryNode (implements org.apache.poi.poifs.filesystem.DirectoryEntry, java.lang.Iterable<T>, org.apache.poi.poifs.dev.POIFSViewable)
      • org.apache.poi.poifs.filesystem.DocumentNode (implements org.apache.poi.poifs.filesystem.DocumentEntry, org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.filesystem.EntryUtils
    • org.apache.poi.poifs.filesystem.FilteringDirectoryNode (implements org.apache.poi.poifs.filesystem.DirectoryEntry)
    • java.io.InputStream (implements java.io.Closeable)
      • org.apache.poi.poifs.filesystem.DocumentInputStream (implements org.apache.poi.util.LittleEndianInput)
        • org.apache.poi.poifs.filesystem.NDocumentInputStream
        • org.apache.poi.poifs.filesystem.ODocumentInputStream
    • org.apache.poi.poifs.filesystem.NPOIFSDocument (implements org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.filesystem.NPOIFSStream (implements java.lang.Iterable<T>)
    • org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator (implements java.util.Iterator<E>)
    • org.apache.poi.poifs.filesystem.Ole10Native
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.apache.poi.poifs.filesystem.DocumentOutputStream
    • org.apache.poi.poifs.filesystem.POIFSDocument (implements org.apache.poi.poifs.filesystem.BATManaged, org.apache.poi.poifs.storage.BlockWritable, org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.filesystem.POIFSDocumentPath
    • org.apache.poi.poifs.filesystem.POIFSFileSystem (implements org.apache.poi.poifs.dev.POIFSViewable)
    • org.apache.poi.poifs.filesystem.POIFSWriterEvent
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.poifs.filesystem.Ole10NativeException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • org.apache.poi.poifs.filesystem.OfficeXmlFileException

Interface Hierarchy

  • org.apache.poi.poifs.filesystem.BATManaged
  • org.apache.poi.poifs.filesystem.Entry
    • org.apache.poi.poifs.filesystem.DirectoryEntry (also extends java.lang.Iterable<T>)
    • org.apache.poi.poifs.filesystem.DocumentEntry
  • java.lang.Iterable<T>
    • org.apache.poi.poifs.filesystem.DirectoryEntry (also extends org.apache.poi.poifs.filesystem.Entry)
  • org.apache.poi.poifs.filesystem.POIFSWriterListener


Uses of Package org.apache.poi.poifs.filesystem

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.filesystem

Packages that use org.apache.poi.poifs.filesystem
org.apache.poi |
org.apache.poi.extractor |
org.apache.poi.hdgf |
org.apache.poi.hdgf.extractor |
org.apache.poi.hpbf |
org.apache.poi.hpbf.dev |
org.apache.poi.hpbf.extractor |
org.apache.poi.hpbf.model |
org.apache.poi.hpsf |
org.apache.poi.hpsf.extractor |
org.apache.poi.hslf |
org.apache.poi.hslf.dev |
org.apache.poi.hslf.extractor |
org.apache.poi.hslf.record |
org.apache.poi.hsmf |
org.apache.poi.hsmf.datatypes |
org.apache.poi.hsmf.dev |
org.apache.poi.hsmf.extractor |
org.apache.poi.hsmf.parsers |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf |
org.apache.poi.hwpf.converter |
org.apache.poi.hwpf.extractor |
org.apache.poi.hwpf.usermodel |
org.apache.poi.poifs.crypt |
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.eventfilesystem | The eventfilesystem is an efficient method for reading OLE 2 CDF files.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.
org.apache.poi.ss.usermodel |

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi
DirectoryEntry
This interface defines methods specific to Directory objects managed by a Filesystem instance.
DirectoryNode
Simple implementation of DirectoryEntry
Entry
This interface provides access to an object managed by a Filesystem instance.
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.extractor
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hdgf
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hdgf.extractor
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hpbf
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hpbf.dev
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hpbf.extractor
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hpbf.model
DirectoryNode
Simple implementation of DirectoryEntry

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hpsf
DirectoryEntry
This interface defines methods specific to Directory objects managed by a Filesystem instance.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hpsf.extractor
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hslf
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hslf.dev
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hslf.extractor
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hslf.record
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hsmf
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hsmf.datatypes
DirectoryNode
Simple implementation of DirectoryEntry

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hsmf.dev
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hsmf.extractor
DirectoryNode
Simple implementation of DirectoryEntry
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hsmf.parsers
DirectoryNode
Simple implementation of DirectoryEntry
Entry
This interface provides access to an object managed by a Filesystem instance.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hssf.eventusermodel
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hssf.extractor
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hssf.usermodel
DirectoryEntry
This interface defines methods specific to Directory objects managed by a Filesystem instance.
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hwpf
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hwpf.converter
DirectoryNode
Simple implementation of DirectoryEntry
Entry
This interface provides access to an object managed by a Filesystem instance.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hwpf.extractor
DirectoryNode
Simple implementation of DirectoryEntry
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.hwpf.usermodel
DirectoryEntry
This interface defines methods specific to Directory objects managed by a Filesystem instance.
Entry
This interface provides access to an object managed by a Filesystem instance.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.poifs.crypt
DirectoryNode
Simple implementation of DirectoryEntry
DocumentInputStream
This class provides methods to read a DocumentEntry managed by a POIFSFileSystem or NPOIFSFileSystem instance.
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.poifs.dev
DirectoryEntry
This interface defines methods specific to Directory objects managed by a Filesystem instance.
DirectoryNode
Simple implementation of DirectoryEntry

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.poifs.eventfilesystem
DocumentInputStream
This class provides methods to read a DocumentEntry managed by a POIFSFileSystem or NPOIFSFileSystem instance.
POIFSDocumentPath
Class POIFSDocumentPath

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.poifs.filesystem
BATManaged
This interface defines behaviors for objects managed by the Block Allocation Table (BAT).
BlockStore
This abstract class describes a way to read, store, chain and free a series of blocks (be they Big or Small ones)
BlockStore.ChainLoopDetector
Used to detect if a chain has a loop in it, so we can bail out with an error rather than spinning away for ever...
DirectoryEntry
This interface defines methods specific to Directory objects managed by a Filesystem instance.
DirectoryNode
Simple implementation of DirectoryEntry
DocumentEntry
This interface defines methods specific to Document objects managed by a Filesystem instance.
DocumentInputStream
This class provides methods to read a DocumentEntry managed by a POIFSFileSystem or NPOIFSFileSystem instance.
DocumentOutputStream
This class provides a wrapper over an OutputStream so that Document writers can't accidently go over their size limits
Entry
This interface provides access to an object managed by a Filesystem instance.
EntryNode
Abstract implementation of Entry Extending classes should override isDocument() or isDirectory(), as appropriate Extending classes must override isDeleteOK()
FilteringDirectoryNode
A DirectoryEntry filter, which exposes another DirectoryEntry less certain parts.
NPOIFSDocument
This class manages a document in the NIO POIFS filesystem.
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
NPOIFSMiniStore
This class handles the MiniStream (small block store) in the NIO case for NPOIFSFileSystem
Ole10Native
Represents an Ole10Native record which is wrapped around certain binary files being embedded in OLE2 documents.
Ole10NativeException
POIFSDocument
This class manages a document in the POIFS filesystem.
POIFSDocumentPath
Class POIFSDocumentPath
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSWriterEvent
Class POIFSWriterEvent
POIFSWriterListener
Interface POIFSWriterListener

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.poifs.property
BATManaged
This interface defines behaviors for objects managed by the Block Allocation Table (BAT).
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
NPOIFSStream
This handles reading and writing a stream within a NPOIFSFileSystem.
POIFSDocument
This class manages a document in the POIFS filesystem.

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.poifs.storage
BATManaged
This interface defines behaviors for objects managed by the Block Allocation Table (BAT).

Classes in org.apache.poi.poifs.filesystem used by org.apache.poi.ss.usermodel
NPOIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
POIFSFileSystem
This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POIFSDocument

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class POIFSDocument

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.POIFSDocument
All Implemented Interfaces:
POIFSViewable, BATManaged, BlockWritable
public final class POIFSDocument
extends java.lang.Object
implements BATManaged, BlockWritable, POIFSViewable

This class manages a document in the POIFS filesystem.

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
POIFSDocument(java.lang.String name, java.io.InputStream stream)
POIFSDocument(java.lang.String name, int size, POIFSBigBlockSize bigBlockSize, POIFSDocumentPath path, POIFSWriterListener writer)
Constructor
POIFSDocument(java.lang.String name, int size, POIFSDocumentPath path, POIFSWriterListener writer)
POIFSDocument(java.lang.String name, ListManagedBlock[] blocks, int length)
POIFSDocument(java.lang.String name, POIFSBigBlockSize bigBlockSize, java.io.InputStream stream)
Constructor
POIFSDocument(java.lang.String name, POIFSBigBlockSize bigBlockSize, ListManagedBlock[] blocks, int length)
Constructor from small blocks
POIFSDocument(java.lang.String name, RawDataBlock[] blocks, int length)
Constructor from large blocks
POIFSDocument(java.lang.String name, SmallDocumentBlock[] blocks, int length)
Constructor from small blocks
Method Summary
int | countBlocks() Return the number of BigBlock's this instance uses
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
int | getSize()
BlockWritable[] | getSmallBlocks()
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator
void | setStartBlock(int index) Set the start block for this instance
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSDocument

public POIFSDocument(java.lang.String name,
                     RawDataBlock[] blocks,
                     int length)
              throws java.io.IOException
Constructor from large blocks

Parameters:
name - the name of the POIFSDocument
blocks - the big blocks making up the POIFSDocument
length - the actual length of the POIFSDocument
Throws:
java.io.IOException

POIFSDocument

public POIFSDocument(java.lang.String name,
                     SmallDocumentBlock[] blocks,
                     int length)
Constructor from small blocks

Parameters:
name - the name of the POIFSDocument
blocks - the small blocks making up the POIFSDocument
length - the actual length of the POIFSDocument

POIFSDocument

public POIFSDocument(java.lang.String name,
                     POIFSBigBlockSize bigBlockSize,
                     ListManagedBlock[] blocks,
                     int length)
              throws java.io.IOException
Constructor from small blocks

Parameters:
name - the name of the POIFSDocument
blocks - the small blocks making up the POIFSDocument
length - the actual length of the POIFSDocument
Throws:
java.io.IOException

POIFSDocument

public POIFSDocument(java.lang.String name,
                     ListManagedBlock[] blocks,
                     int length)
              throws java.io.IOException
Throws:
java.io.IOException

POIFSDocument

public POIFSDocument(java.lang.String name,
                     POIFSBigBlockSize bigBlockSize,
                     java.io.InputStream stream)
              throws java.io.IOException
Constructor

Parameters:
name - the name of the POIFSDocument
stream - the InputStream we read data from
Throws:
java.io.IOException

POIFSDocument

public POIFSDocument(java.lang.String name,
                     java.io.InputStream stream)
              throws java.io.IOException
Throws:
java.io.IOException

POIFSDocument

public POIFSDocument(java.lang.String name,
                     int size,
                     POIFSBigBlockSize bigBlockSize,
                     POIFSDocumentPath path,
                     POIFSWriterListener writer)
Constructor

Parameters:
name - the name of the POIFSDocument
size - the length of the POIFSDocument
path - the path of the POIFSDocument
writer - the writer who will eventually write the document contents

POIFSDocument

public POIFSDocument(java.lang.String name,
                     int size,
                     POIFSDocumentPath path,
                     POIFSWriterListener writer)
Method Detail

getSmallBlocks

public BlockWritable[] getSmallBlocks()
Returns:
array of SmallDocumentBlocks; may be empty, cannot be null

getSize

public int getSize()
Returns:
size of the document

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream

countBlocks

public int countBlocks()
Return the number of BigBlock's this instance uses

Specified by:
countBlocks in interface BATManaged
Returns:
count of BigBlock instances

setStartBlock

public void setStartBlock(int index)
Set the start block for this instance

Specified by:
setStartBlock in interface BATManaged
Parameters:
index - index into the array of blocks making up the filesystem

getViewableArray

public java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Specified by:
getViewableArray in interface POIFSViewable
Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

public java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Specified by:
getViewableIterator in interface POIFSViewable
Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

public boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Specified by:
preferArray in interface POIFSViewable
Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

public java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Specified by:
getShortDescription in interface POIFSViewable
Returns:
short description
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSDocumentPath

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class POIFSDocumentPath

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.POIFSDocumentPath

public class POIFSDocumentPath
extends java.lang.Object

Class POIFSDocumentPath

Version:
%I%, %G%
Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
POIFSDocumentPath()
simple constructor for the path of a document that is in the root of the POIFSFileSystem.
POIFSDocumentPath(POIFSDocumentPath path, java.lang.String[] components)
constructor that adds additional subdirectories to an existing path
POIFSDocumentPath(java.lang.String[] components)
constructor for the path of a document that is not in the root of the POIFSFileSystem
Method Summary
boolean | equals(java.lang.Object o) equality.
java.lang.String | getComponent(int n) get the specified component
POIFSDocumentPath | getParent() Returns the path's parent or null if this path is the root path.
int | hashCode() calculate and return the hashcode
int | length()
java.lang.String | toString() Returns a string representation of the path.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

POIFSDocumentPath

public POIFSDocumentPath(java.lang.String[] components)
                  throws java.lang.IllegalArgumentException
constructor for the path of a document that is not in the root of the POIFSFileSystem

Parameters:
components - the Strings making up the path to a document. The Strings must be ordered as they appear in the directory hierarchy of the the document -- the first string must be the name of a directory in the root of the POIFSFileSystem, and every Nth (for N > 1) string thereafter must be the name of a directory in the directory identified by the (N-1)th string.

If the components parameter is null or has zero length, the POIFSDocumentPath is appropriate for a document that is in the root of a POIFSFileSystem

Throws:
java.lang.IllegalArgumentException - if any of the elements in the components parameter are null or have zero length

POIFSDocumentPath

public POIFSDocumentPath()
simple constructor for the path of a document that is in the root of the POIFSFileSystem. The constructor that takes an array of Strings can also be used to create such a POIFSDocumentPath by passing it a null or empty String array

POIFSDocumentPath

public POIFSDocumentPath(POIFSDocumentPath path,
                         java.lang.String[] components)
                  throws java.lang.IllegalArgumentException
constructor that adds additional subdirectories to an existing path

Parameters:
path - the existing path
components - the additional subdirectory names to be added
Throws:
java.lang.IllegalArgumentException - if any of the Strings in components is null or zero length
Method Detail

equals

public boolean equals(java.lang.Object o)
equality. Two POIFSDocumentPath instances are equal if they have the same number of component Strings, and if each component String is equal to its coresponding component String

Overrides:
equals in class java.lang.Object
Parameters:
o - the object we're checking equality for
Returns:
true if the object is equal to this object

hashCode

public int hashCode()
calculate and return the hashcode

Overrides:
hashCode in class java.lang.Object
Returns:
hashcode

length

public int length()
Returns:
the number of components

getComponent

public java.lang.String getComponent(int n)
                              throws java.lang.ArrayIndexOutOfBoundsException
get the specified component

Parameters:
n - which component (0 ... length() - 1)
Returns:
the nth component;
Throws:
java.lang.ArrayIndexOutOfBoundsException - if n < 0 or n >= length()

getParent

public POIFSDocumentPath getParent()

Returns the path's parent or null if this path is the root path.

Returns:
path of parent, or null if this path is the root path
Since:
2002-01-24

toString

public java.lang.String toString()

Returns a string representation of the path. Components are separated by the platform-specific file separator.

Overrides:
toString in class java.lang.Object
Returns:
string representation
Since:
2002-01-24
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSFileSystem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class POIFSFileSystem

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.POIFSFileSystem
All Implemented Interfaces:
POIFSViewable
public class POIFSFileSystem
extends java.lang.Object
implements POIFSViewable

This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
POIFSFileSystem()
Constructor, intended for writing
POIFSFileSystem(java.io.InputStream stream)
Create a POIFSFileSystem from an InputStream.
Method Summary
DirectoryEntry | createDirectory(java.lang.String name) create a new DirectoryEntry in the root directory
DocumentEntry | createDocument(java.io.InputStream stream, java.lang.String name) Create a new document to be added to the root directory
DocumentEntry | createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry in the root entry; the data will be provided later
DocumentInputStream | createDocumentInputStream(java.lang.String documentName) open a document in the root entry's list of entries
static java.io.InputStream | createNonClosingInputStream(java.io.InputStream is) Convenience method for clients that want to avoid the auto-close behaviour of the constructor.
int | getBigBlockSize()
POIFSBigBlockSize | getBigBlockSizeDetails()
DirectoryNode | getRoot() get the root entry
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
static boolean | hasPOIFSHeader(java.io.InputStream inp) Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a POIFS (OLE2) header at the start of it.
static void | main(java.lang.String[] args) read in a file and write it back out again
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator
void | writeFilesystem(java.io.OutputStream stream) Write the filesystem out
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POIFSFileSystem

public POIFSFileSystem()
Constructor, intended for writing

POIFSFileSystem

public POIFSFileSystem(java.io.InputStream stream)
                throws java.io.IOException
Create a POIFSFileSystem from an InputStream. Normally the stream is read until EOF. The stream is always closed.

Some streams are usable after reaching EOF (typically those that return true for markSupported()). In the unlikely case that the caller has such a stream and needs to use it after this constructor completes, a work around is to wrap the stream in order to trap the close() call. A convenience method ( createNonClosingInputStream()) has been provided for this purpose:

 InputStream wrappedStream = POIFSFileSystem.createNonClosingInputStream(is);
 HSSFWorkbook wb = new HSSFWorkbook(wrappedStream);
 is.reset();
 doSomethingElse(is);
Note also the special case of ByteArrayInputStream for which the close() method does nothing.
 ByteArrayInputStream bais = ...
 HSSFWorkbook wb = new HSSFWorkbook(bais); // calls bais.close() !
 bais.reset(); // no problem
 doSomethingElse(bais);

Parameters:
stream - the InputStream from which to read the data
Throws:
java.io.IOException - on errors reading, or on invalid data
Method Detail

createNonClosingInputStream

public static java.io.InputStream createNonClosingInputStream(java.io.InputStream is)
Convenience method for clients that want to avoid the auto-close behaviour of the constructor.

hasPOIFSHeader

public static boolean hasPOIFSHeader(java.io.InputStream inp)
                              throws java.io.IOException
Checks that the supplied InputStream (which MUST support mark and reset, or be a PushbackInputStream) has a POIFS (OLE2) header at the start of it. If your InputStream does not support mark / reset, then wrap it in a PushBackInputStream, then be sure to always use that, and not the original!

Parameters:
inp - An InputStream which supports either mark/reset, or is a PushbackInputStream
Throws:
java.io.IOException

createDocument

public DocumentEntry createDocument(java.io.InputStream stream,
                                    java.lang.String name)
                             throws java.io.IOException
Create a new document to be added to the root directory

Parameters:
stream - the InputStream from which the document's data will be obtained
name - the name of the new POIFSDocument
Returns:
the new DocumentEntry
Throws:
java.io.IOException - on error creating the new POIFSDocument

createDocument

public DocumentEntry createDocument(java.lang.String name,
                                    int size,
                                    POIFSWriterListener writer)
                             throws java.io.IOException
create a new DocumentEntry in the root entry; the data will be provided later

Parameters:
name - the name of the new DocumentEntry
size - the size of the new DocumentEntry
writer - the writer of the new DocumentEntry
Returns:
the new DocumentEntry
Throws:
java.io.IOException

createDirectory

public DirectoryEntry createDirectory(java.lang.String name)
                               throws java.io.IOException
create a new DirectoryEntry in the root directory

Parameters:
name - the name of the new DirectoryEntry
Returns:
the new DirectoryEntry
Throws:
java.io.IOException - on name duplication

writeFilesystem

public void writeFilesystem(java.io.OutputStream stream)
                     throws java.io.IOException
Write the filesystem out

Parameters:
stream - the OutputStream to which the filesystem will be written
Throws:
java.io.IOException - thrown on errors writing to the stream

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
read in a file and write it back out again

Parameters:
args - names of the files; arg[ 0 ] is the input file, arg[ 1 ] is the output file
Throws:
java.io.IOException

getRoot

public DirectoryNode getRoot()
get the root entry

Returns:
the root entry

createDocumentInputStream

public DocumentInputStream createDocumentInputStream(java.lang.String documentName)
                                              throws java.io.IOException
open a document in the root entry's list of entries

Parameters:
documentName - the name of the document to be opened
Returns:
a newly opened DocumentInputStream
Throws:
java.io.IOException - if the document does not exist or the name is that of a DirectoryEntry

getViewableArray

public java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Specified by:
getViewableArray in interface POIFSViewable
Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

public java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Specified by:
getViewableIterator in interface POIFSViewable
Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

public boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Specified by:
preferArray in interface POIFSViewable
Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

public java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Specified by:
getShortDescription in interface POIFSViewable
Returns:
short description

getBigBlockSize

public int getBigBlockSize()
Returns:
The Big Block size, normally 512 bytes, sometimes 4096 bytes

getBigBlockSizeDetails

public POIFSBigBlockSize getBigBlockSizeDetails()
Returns:
The Big Block size, normally 512 bytes, sometimes 4096 bytes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSWriterEvent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Class POIFSWriterEvent

java.lang.Object
    extended by  org.apache.poi.poifs.filesystem.POIFSWriterEvent

public class POIFSWriterEvent
extends java.lang.Object

Class POIFSWriterEvent

Version:
%I%, %G%
Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
int | getLimit()
java.lang.String | getName()
POIFSDocumentPath | getPath()
DocumentOutputStream | getStream()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getStream

public DocumentOutputStream getStream()
Returns:
the DocumentOutputStream, freshly opened

getPath

public POIFSDocumentPath getPath()
Returns:
the document's path

getName

public java.lang.String getName()
Returns:
the document's name

getLimit

public int getLimit()
Returns:
the limit on writing, in bytes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POIFSWriterListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.filesystem
Interface POIFSWriterListener

public interface POIFSWriterListener

Interface POIFSWriterListener

Version:
%I%, %G%
Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
 void processPOIFSWriterEvent(POIFSWriterEvent event)
Process a POIFSWriterEvent that this listener had registered for

Method Detail

processPOIFSWriterEvent

void processPOIFSWriterEvent(POIFSWriterEvent event)
Process a POIFSWriterEvent that this listener had registered for

Parameters:
event - the POIFSWriterEvent
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface org.apache.poi.poifs.filesystem.BATManaged

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.filesystem.BATManaged

Packages that use BATManaged
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of BATManaged in org.apache.poi.poifs.filesystem

Classes in org.apache.poi.poifs.filesystem that implement BATManaged
 class POIFSDocument
This class manages a document in the POIFS filesystem.

Uses of BATManaged in org.apache.poi.poifs.property

Classes in org.apache.poi.poifs.property that implement BATManaged
class | NPropertyTable This class embodies the Property Table for a NPOIFSFileSystem; this is basically the directory for all of the documents in the filesystem.
class | PropertyTable This class embodies the Property Table for the POIFSFileSystem; this is basically the directory for all of the documents in the filesystem.
class | PropertyTableBase This class embodies the Property Table for the filesystem, which looks up entries in the filesystem to their chain of blocks.

Uses of BATManaged in org.apache.poi.poifs.storage

Classes in org.apache.poi.poifs.storage that implement BATManaged
class | BlockAllocationTableWriter This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
class | SmallBlockTableWriter This class implements storage for writing the small blocks used by small documents.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.BlockStore.ChainLoopDetector

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.BlockStore.ChainLoopDetector

Packages that use BlockStore.ChainLoopDetector
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of BlockStore.ChainLoopDetector in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return BlockStore.ChainLoopDetector
protected BlockStore.ChainLoopDetector | NPOIFSMiniStore.getChainLoopDetector()
protected BlockStore.ChainLoopDetector | NPOIFSFileSystem.getChainLoopDetector()
protected abstract BlockStore.ChainLoopDetector | BlockStore.getChainLoopDetector() Creates a Detector for loops in the chain

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.BlockStore

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.BlockStore

Packages that use BlockStore
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of BlockStore in org.apache.poi.poifs.filesystem

Subclasses of BlockStore in org.apache.poi.poifs.filesystem
class | NPOIFSFileSystem This is the main class of the POIFS system; it manages the entire life cycle of the filesystem.
class | NPOIFSMiniStore This class handles the MiniStream (small block store) in the NIO case for NPOIFSFileSystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type BlockStore
NPOIFSStream(BlockStore blockStore)
Constructor for a new stream.
NPOIFSStream(BlockStore blockStore, int startBlock)
Constructor for an existing stream.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.filesystem.DirectoryEntry

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.filesystem.DirectoryEntry

Packages that use DirectoryEntry
org.apache.poi |
org.apache.poi.hpsf |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf.usermodel |
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of DirectoryEntry in org.apache.poi

Methods in org.apache.poi that return DirectoryEntry
 DirectoryEntry POIOLE2TextExtractor.getRoot()

Methods in org.apache.poi with parameters of type DirectoryEntry
protected  void POIDocument.copyNodeRecursively(Entry entry, DirectoryEntry target)
Deprecated.

Uses of DirectoryEntry in org.apache.poi.hpsf

Methods in org.apache.poi.hpsf with parameters of type DirectoryEntry
void | SpecialPropertySet.write(DirectoryEntry dir, java.lang.String name)
void | MutablePropertySet.write(DirectoryEntry dir, java.lang.String name) Writes a property set to a document in a POI filesystem directory.

Uses of DirectoryEntry in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return DirectoryEntry
 DirectoryEntry HSSFObjectData.getDirectory()
Gets the object data.

Constructors in org.apache.poi.hssf.usermodel with parameters of type DirectoryEntry
HSSFObjectData(ObjRecord record, DirectoryEntry root)
Constructs object data by wrapping a lower level object record.

Uses of DirectoryEntry in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel with parameters of type DirectoryEntry
 void ObjectPoolImpl.writeTo(DirectoryEntry directoryEntry)

Constructors in org.apache.poi.hwpf.usermodel with parameters of type DirectoryEntry
ObjectPoolImpl(DirectoryEntry _objectPool)

Uses of DirectoryEntry in org.apache.poi.poifs.dev

Methods in org.apache.poi.poifs.dev with parameters of type DirectoryEntry
static void POIFSDump.dump(DirectoryEntry root, java.io.File parent)

Uses of DirectoryEntry in org.apache.poi.poifs.filesystem

Classes in org.apache.poi.poifs.filesystem that implement DirectoryEntry
class | DirectoryNode Simple implementation of DirectoryEntry
class | FilteringDirectoryNode A DirectoryEntry filter, which exposes another DirectoryEntry less certain parts.

Methods in org.apache.poi.poifs.filesystem that return DirectoryEntry
DirectoryEntry | POIFSFileSystem.createDirectory(java.lang.String name) create a new DirectoryEntry in the root directory
DirectoryEntry | NPOIFSFileSystem.createDirectory(java.lang.String name) create a new DirectoryEntry in the root directory
DirectoryEntry | FilteringDirectoryNode.createDirectory(java.lang.String name)
DirectoryEntry | DirectoryNode.createDirectory(java.lang.String name) create a new DirectoryEntry
DirectoryEntry | DirectoryEntry.createDirectory(java.lang.String name) create a new DirectoryEntry
DirectoryEntry | FilteringDirectoryNode.getParent()
DirectoryEntry | EntryNode.getParent() get this Entry's parent (the DocumentEntry that owns this Entry).
DirectoryEntry | Entry.getParent() get this Entry's parent (the DirectoryEntry that owns this Entry).

Methods in org.apache.poi.poifs.filesystem with parameters of type DirectoryEntry
static boolean | EntryUtils.areDirectoriesIdentical(DirectoryEntry dirA, DirectoryEntry dirB) Checks to see if the two Directories hold the same contents.
static void | EntryUtils.copyNodeRecursively(Entry entry, DirectoryEntry target) Copies an Entry into a target POIFS directory, recursively
static void | EntryUtils.copyNodes(DirectoryEntry sourceRoot, DirectoryEntry targetRoot) Copies all the nodes from one POIFS Directory to another
static void | EntryUtils.copyNodes(DirectoryEntry sourceRoot, DirectoryEntry targetRoot, java.util.List<java.lang.String> excepts) Deprecated. use FilteringDirectoryNode instead

Constructors in org.apache.poi.poifs.filesystem with parameters of type DirectoryEntry
FilteringDirectoryNode(DirectoryEntry directory, java.util.Collection<java.lang.String> excludes)
Creates a filter round the specified directory, which will exclude entries such as "MyNode" and "MyDir/IgnoreNode".

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.DirectoryNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.DirectoryNode

Packages that use DirectoryNode
org.apache.poi |
org.apache.poi.extractor |
org.apache.poi.hdgf |
org.apache.poi.hdgf.extractor |
org.apache.poi.hpbf |
org.apache.poi.hpbf.dev |
org.apache.poi.hpbf.extractor |
org.apache.poi.hpbf.model |
org.apache.poi.hslf |
org.apache.poi.hslf.extractor |
org.apache.poi.hslf.record |
org.apache.poi.hsmf |
org.apache.poi.hsmf.datatypes |
org.apache.poi.hsmf.extractor |
org.apache.poi.hsmf.parsers |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf |
org.apache.poi.hwpf.converter |
org.apache.poi.hwpf.extractor |
org.apache.poi.poifs.crypt |
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of DirectoryNode in org.apache.poi

Fields in org.apache.poi declared as DirectoryNode
protected  DirectoryNode POIDocument.directory
The directory that our document lives in

Methods in org.apache.poi with parameters of type DirectoryNode
protected  void POIDocument.copyNodes(DirectoryNode sourceRoot, DirectoryNode targetRoot, java.util.List<java.lang.String> excepts)
Deprecated.

Constructors in org.apache.poi with parameters of type DirectoryNode
POIDocument(DirectoryNode dir)
POIDocument(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. use POIDocument.POIDocument(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.extractor

Methods in org.apache.poi.extractor with parameters of type DirectoryNode
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir)
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use ExtractorFactory.createExtractor(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hdgf

Constructors in org.apache.poi.hdgf with parameters of type DirectoryNode
HDGFDiagram(DirectoryNode dir)
HDGFDiagram(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use HDGFDiagram.HDGFDiagram(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hdgf.extractor

Constructors in org.apache.poi.hdgf.extractor with parameters of type DirectoryNode
VisioTextExtractor(DirectoryNode dir)
VisioTextExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use VisioTextExtractor.VisioTextExtractor(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hpbf

Constructors in org.apache.poi.hpbf with parameters of type DirectoryNode
HPBFDocument(DirectoryNode dir)
Opens an embedded publisher document, at the given directory.
HPBFDocument(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use HPBFDocument.HPBFDocument(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hpbf.dev

Methods in org.apache.poi.hpbf.dev with parameters of type DirectoryNode
protected void | HPBFDumper.dump001CompObj(DirectoryNode dir)
void | HPBFDumper.dumpCONTENTSguessed(DirectoryNode dir)
void | HPBFDumper.dumpCONTENTSraw(DirectoryNode dir)
protected void | HPBFDumper.dumpEscherDelayStm(DirectoryNode escherDir)
protected void | HPBFDumper.dumpEscherStm(DirectoryNode escherDir)

Uses of DirectoryNode in org.apache.poi.hpbf.extractor

Constructors in org.apache.poi.hpbf.extractor with parameters of type DirectoryNode
PublisherTextExtractor(DirectoryNode dir)
PublisherTextExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated.

Uses of DirectoryNode in org.apache.poi.hpbf.model

Methods in org.apache.poi.hpbf.model with parameters of type DirectoryNode
 void HPBFPart.writeOut(DirectoryNode baseDir)

Constructors in org.apache.poi.hpbf.model with parameters of type DirectoryNode
EscherDelayStm(DirectoryNode baseDir)
EscherPart(DirectoryNode baseDir, java.lang.String[] parts)
Creates the Escher Part, and finds our child escher records
EscherStm(DirectoryNode baseDir)
HPBFPart(DirectoryNode baseDir, java.lang.String[] path)
MainContents(DirectoryNode baseDir)
QuillContents(DirectoryNode baseDir)

Uses of DirectoryNode in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return DirectoryNode
protected  DirectoryNode HSLFSlideShow.getPOIFSDirectory()
Returns the directory in the underlying POIFSFileSystem for the document that is open.

Constructors in org.apache.poi.hslf with parameters of type DirectoryNode
HSLFSlideShow(DirectoryNode dir)
Constructs a Powerpoint document from a specific point in a POIFS Filesystem.
HSLFSlideShow(DirectoryNode dir, POIFSFileSystem filesystem)
Deprecated. Use HSLFSlideShow.HSLFSlideShow(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hslf.extractor

Constructors in org.apache.poi.hslf.extractor with parameters of type DirectoryNode
PowerPointExtractor(DirectoryNode dir)
Creates a PowerPointExtractor, from a specific place inside an open NPOIFSFileSystem
PowerPointExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use PowerPointExtractor.PowerPointExtractor(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hslf.record

Constructors in org.apache.poi.hslf.record with parameters of type DirectoryNode
CurrentUserAtom(DirectoryNode dir)
Find the Current User in the filesystem, and create from that

Uses of DirectoryNode in org.apache.poi.hsmf

Constructors in org.apache.poi.hsmf with parameters of type DirectoryNode
MAPIMessage(DirectoryNode poifsDir)
Constructor for reading MSG Files from a certain point within a POIFS filesystem
MAPIMessage(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use MAPIMessage.MAPIMessage(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hsmf.datatypes

Methods in org.apache.poi.hsmf.datatypes that return DirectoryNode
 DirectoryNode DirectoryChunk.getDirectory()
Returns the directory entry for this chunk.

Constructors in org.apache.poi.hsmf.datatypes with parameters of type DirectoryNode
DirectoryChunk(DirectoryNode dir, java.lang.String namePrefix, int chunkId, int type)

Uses of DirectoryNode in org.apache.poi.hsmf.extractor

Constructors in org.apache.poi.hsmf.extractor with parameters of type DirectoryNode
OutlookTextExtactor(DirectoryNode poifsDir)
OutlookTextExtactor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated.

Uses of DirectoryNode in org.apache.poi.hsmf.parsers

Methods in org.apache.poi.hsmf.parsers with parameters of type DirectoryNode
static ChunkGroup[] | POIFSChunkParser.parse(DirectoryNode node)
protected static void | POIFSChunkParser.processChunks(DirectoryNode node, ChunkGroup grouping) Creates all the chunks for a given Directory, but doesn't recurse or descend

Uses of DirectoryNode in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel with parameters of type DirectoryNode
short | HSSFEventFactory.abortableProcessWorkbookEvents(HSSFRequest req, DirectoryNode dir) Processes a file into essentially record events.
void | HSSFEventFactory.processWorkbookEvents(HSSFRequest req, DirectoryNode dir) Processes a file into essentially record events.

Uses of DirectoryNode in org.apache.poi.hssf.extractor

Constructors in org.apache.poi.hssf.extractor with parameters of type DirectoryNode
EventBasedExcelExtractor(DirectoryNode dir)
EventBasedExcelExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use EventBasedExcelExtractor.EventBasedExcelExtractor(DirectoryNode) instead
ExcelExtractor(DirectoryNode dir)
ExcelExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use ExcelExtractor.ExcelExtractor(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type DirectoryNode
HSSFWorkbook(DirectoryNode directory, boolean preserveNodes)
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models.
HSSFWorkbook(DirectoryNode directory, POIFSFileSystem fs, boolean preserveNodes)
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models.

Uses of DirectoryNode in org.apache.poi.hwpf

Constructors in org.apache.poi.hwpf with parameters of type DirectoryNode
HWPFDocument(DirectoryNode directory)
This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default.
HWPFDocument(DirectoryNode directory, POIFSFileSystem pfilesystem)
Deprecated. Use HWPFDocument.HWPFDocument(DirectoryNode) instead
HWPFDocumentCore(DirectoryNode directory)
This constructor loads a Word document from a specific point in a POIFSFileSystem, probably not the default.
HWPFOldDocument(DirectoryNode directory)
HWPFOldDocument(DirectoryNode directory, POIFSFileSystem fs)
Deprecated.

Uses of DirectoryNode in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type DirectoryNode
static java.lang.String | WordToTextConverter.getText(DirectoryNode root)
static HWPFDocumentCore | AbstractWordUtils.loadDoc(DirectoryNode root)

Uses of DirectoryNode in org.apache.poi.hwpf.extractor

Constructors in org.apache.poi.hwpf.extractor with parameters of type DirectoryNode
Word6Extractor(DirectoryNode dir)
Word6Extractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use Word6Extractor.Word6Extractor(DirectoryNode) instead
WordExtractor(DirectoryNode dir)
WordExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use WordExtractor.WordExtractor(DirectoryNode) instead

Uses of DirectoryNode in org.apache.poi.poifs.crypt

Methods in org.apache.poi.poifs.crypt with parameters of type DirectoryNode
java.io.InputStream | EcmaDecryptor.getDataStream(DirectoryNode dir)
abstract java.io.InputStream | Decryptor.getDataStream(DirectoryNode dir) Return a stream with decrypted data.
java.io.InputStream | AgileDecryptor.getDataStream(DirectoryNode dir)

Constructors in org.apache.poi.poifs.crypt with parameters of type DirectoryNode
EncryptionInfo(DirectoryNode dir)

Uses of DirectoryNode in org.apache.poi.poifs.dev

Methods in org.apache.poi.poifs.dev with parameters of type DirectoryNode
static void POIFSLister.displayDirectory(DirectoryNode dir, java.lang.String indent, boolean withSizes)

Uses of DirectoryNode in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return DirectoryNode
DirectoryNode | POIFSFileSystem.getRoot() get the root entry
DirectoryNode | NPOIFSFileSystem.getRoot() Get the root entry

Methods in org.apache.poi.poifs.filesystem with parameters of type DirectoryNode
static Ole10Native Ole10Native.createFromEmbeddedOleObject(DirectoryNode directory)
Creates an instance of this class from an embedded OLE Object.

Constructors in org.apache.poi.poifs.filesystem with parameters of type DirectoryNode
EntryNode(Property property, DirectoryNode parent)
create a DocumentNode.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.DocumentDescriptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.DocumentDescriptor

No usage of org.apache.poi.poifs.filesystem.DocumentDescriptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.filesystem.DocumentEntry

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.filesystem.DocumentEntry

Packages that use DocumentEntry
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of DocumentEntry in org.apache.poi.poifs.filesystem

Classes in org.apache.poi.poifs.filesystem that implement DocumentEntry
 class DocumentNode
Simple implementation of DocumentEntry

Methods in org.apache.poi.poifs.filesystem that return DocumentEntry
DocumentEntry | POIFSFileSystem.createDocument(java.io.InputStream stream, java.lang.String name) Create a new document to be added to the root directory
DocumentEntry | NPOIFSFileSystem.createDocument(java.io.InputStream stream, java.lang.String name) Create a new document to be added to the root directory
DocumentEntry | FilteringDirectoryNode.createDocument(java.lang.String name, java.io.InputStream stream)
DocumentEntry | DirectoryNode.createDocument(java.lang.String name, java.io.InputStream stream) create a new DocumentEntry
DocumentEntry | DirectoryEntry.createDocument(java.lang.String name, java.io.InputStream stream) create a new DocumentEntry
DocumentEntry | POIFSFileSystem.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry in the root entry; the data will be provided later
DocumentEntry | NPOIFSFileSystem.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry in the root entry; the data will be provided later
DocumentEntry | FilteringDirectoryNode.createDocument(java.lang.String name, int size, POIFSWriterListener writer)
DocumentEntry | DirectoryNode.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry; the data will be provided later
DocumentEntry | DirectoryEntry.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry; the data will be provided later

Methods in org.apache.poi.poifs.filesystem with parameters of type DocumentEntry
static boolean EntryUtils.areDocumentsIdentical(DocumentEntry docA, DocumentEntry docB)
Checks to see if two Documents have the same name and the same contents.

Constructors in org.apache.poi.poifs.filesystem with parameters of type DocumentEntry
DocumentInputStream(DocumentEntry document)
Create an InputStream from the specified DocumentEntry
NDocumentInputStream(DocumentEntry document)
Create an InputStream from the specified DocumentEntry
ODocumentInputStream(DocumentEntry document)
Create an InputStream from the specified DocumentEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.DocumentInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.DocumentInputStream

Packages that use DocumentInputStream
org.apache.poi.poifs.crypt |
org.apache.poi.poifs.eventfilesystem | The eventfilesystem is an efficient method for reading OLE 2 CDF files.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of DocumentInputStream in org.apache.poi.poifs.crypt

Constructors in org.apache.poi.poifs.crypt with parameters of type DocumentInputStream
EncryptionHeader(DocumentInputStream is)
EncryptionVerifier(DocumentInputStream is, int encryptedLength)

Uses of DocumentInputStream in org.apache.poi.poifs.eventfilesystem

Methods in org.apache.poi.poifs.eventfilesystem that return DocumentInputStream
 DocumentInputStream POIFSReaderEvent.getStream()

Uses of DocumentInputStream in org.apache.poi.poifs.filesystem

Subclasses of DocumentInputStream in org.apache.poi.poifs.filesystem
class | NDocumentInputStream This class provides methods to read a DocumentEntry managed by a NPOIFSFileSystem instance.
class | ODocumentInputStream This class provides methods to read a DocumentEntry managed by a POIFSFileSystem instance.

Methods in org.apache.poi.poifs.filesystem that return DocumentInputStream
DocumentInputStream | DirectoryNode.createDocumentInputStream(Entry document) open a document in the directory's entry's list of entries
DocumentInputStream | POIFSFileSystem.createDocumentInputStream(java.lang.String documentName) open a document in the root entry's list of entries
DocumentInputStream | NPOIFSFileSystem.createDocumentInputStream(java.lang.String documentName) open a document in the root entry's list of entries
DocumentInputStream | DirectoryNode.createDocumentInputStream(java.lang.String documentName) open a document in the directory's entry's list of entries

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.DocumentNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.DocumentNode

No usage of org.apache.poi.poifs.filesystem.DocumentNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.DocumentOutputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.DocumentOutputStream

Packages that use DocumentOutputStream
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of DocumentOutputStream in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return DocumentOutputStream
 DocumentOutputStream POIFSWriterEvent.getStream()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.filesystem.Entry

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.filesystem.Entry

Packages that use Entry
org.apache.poi |
org.apache.poi.hsmf.parsers |
org.apache.poi.hwpf.converter |
org.apache.poi.hwpf.usermodel |
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of Entry in org.apache.poi

Methods in org.apache.poi with parameters of type Entry
protected  void POIDocument.copyNodeRecursively(Entry entry, DirectoryEntry target)
Deprecated.

Uses of Entry in org.apache.poi.hsmf.parsers

Methods in org.apache.poi.hsmf.parsers with parameters of type Entry
protected static void POIFSChunkParser.process(Entry entry, ChunkGroup grouping)
Creates a chunk, and gives it to its parent group

Uses of Entry in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type Entry
protected boolean | WordToTextConverter.processOle2(HWPFDocument wordDocument, org.w3c.dom.Element block, Entry entry)
protected boolean | AbstractWordConverter.processOle2(HWPFDocument wordDocument, org.w3c.dom.Element block, Entry entry)

Uses of Entry in org.apache.poi.hwpf.usermodel

Methods in org.apache.poi.hwpf.usermodel that return Entry
Entry | ObjectsPool.getObjectById(java.lang.String objId)
Entry | ObjectPoolImpl.getObjectById(java.lang.String objId)

Uses of Entry in org.apache.poi.poifs.filesystem

Subinterfaces of Entry in org.apache.poi.poifs.filesystem
interface | DirectoryEntry This interface defines methods specific to Directory objects managed by a Filesystem instance.
interface | DocumentEntry This interface defines methods specific to Document objects managed by a Filesystem instance.

Classes in org.apache.poi.poifs.filesystem that implement Entry
class | DirectoryNode Simple implementation of DirectoryEntry
class | DocumentNode Simple implementation of DocumentEntry
class | EntryNode Abstract implementation of Entry Extending classes should override isDocument() or isDirectory(), as appropriate Extending classes must override isDeleteOK()
class | FilteringDirectoryNode A DirectoryEntry filter, which exposes another DirectoryEntry less certain parts.

Methods in org.apache.poi.poifs.filesystem that return Entry
Entry | FilteringDirectoryNode.getEntry(java.lang.String name)
Entry | DirectoryNode.getEntry(java.lang.String name) get a specified Entry by name
Entry | DirectoryEntry.getEntry(java.lang.String name) get a specified Entry by name

Methods in org.apache.poi.poifs.filesystem that return types with arguments of type Entry
java.util.Iterator<Entry> | FilteringDirectoryNode.getEntries()
java.util.Iterator<Entry> | DirectoryNode.getEntries() get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)
java.util.Iterator<Entry> | DirectoryEntry.getEntries() get an iterator of the Entry instances contained directly in this instance (in other words, children only; no grandchildren etc.)
java.util.Iterator<Entry> | FilteringDirectoryNode.iterator()
java.util.Iterator<Entry> | DirectoryNode.iterator() Returns an Iterator over all the entries

Methods in org.apache.poi.poifs.filesystem with parameters of type Entry
static void | EntryUtils.copyNodeRecursively(Entry entry, DirectoryEntry target) Copies an Entry into a target POIFS directory, recursively
DocumentInputStream | DirectoryNode.createDocumentInputStream(Entry document) open a document in the directory's entry's list of entries

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.EntryNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.EntryNode

Packages that use EntryNode
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of EntryNode in org.apache.poi.poifs.filesystem

Subclasses of EntryNode in org.apache.poi.poifs.filesystem
class | DirectoryNode Simple implementation of DirectoryEntry
class | DocumentNode Simple implementation of DocumentEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.EntryUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.EntryUtils

No usage of org.apache.poi.poifs.filesystem.EntryUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.FilteringDirectoryNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.FilteringDirectoryNode

Packages that use FilteringDirectoryNode
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of FilteringDirectoryNode in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem with parameters of type FilteringDirectoryNode
static void EntryUtils.copyNodes(FilteringDirectoryNode filteredSource, FilteringDirectoryNode filteredTarget)
Copies nodes from one Directory to the other minus the excepts

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.NDocumentInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.NDocumentInputStream

No usage of org.apache.poi.poifs.filesystem.NDocumentInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.NPOIFSDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.NPOIFSDocument

Packages that use NPOIFSDocument
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of NPOIFSDocument in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type NPOIFSDocument
DocumentInputStream(NPOIFSDocument document)
Create an InputStream from the specified Document
NDocumentInputStream(NPOIFSDocument document)
Create an InputStream from the specified Document

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.NPOIFSFileSystem

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.NPOIFSFileSystem

Packages that use NPOIFSFileSystem
org.apache.poi |
org.apache.poi.hdgf |
org.apache.poi.hdgf.extractor |
org.apache.poi.hpbf |
org.apache.poi.hpbf.extractor |
org.apache.poi.hpsf.extractor |
org.apache.poi.hslf |
org.apache.poi.hslf.extractor |
org.apache.poi.hsmf |
org.apache.poi.hsmf.extractor |
org.apache.poi.poifs.crypt |
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.ss.usermodel |

Uses of NPOIFSFileSystem in org.apache.poi

Constructors in org.apache.poi with parameters of type NPOIFSFileSystem
POIDocument(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.hdgf

Constructors in org.apache.poi.hdgf with parameters of type NPOIFSFileSystem
HDGFDiagram(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.hdgf.extractor

Constructors in org.apache.poi.hdgf.extractor with parameters of type NPOIFSFileSystem
VisioTextExtractor(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.hpbf

Constructors in org.apache.poi.hpbf with parameters of type NPOIFSFileSystem
HPBFDocument(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.hpbf.extractor

Constructors in org.apache.poi.hpbf.extractor with parameters of type NPOIFSFileSystem
PublisherTextExtractor(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.hpsf.extractor

Constructors in org.apache.poi.hpsf.extractor with parameters of type NPOIFSFileSystem
HPSFPropertiesExtractor(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.hslf

Constructors in org.apache.poi.hslf with parameters of type NPOIFSFileSystem
HSLFSlideShow(NPOIFSFileSystem filesystem)
Constructs a Powerpoint document from a POIFS Filesystem.

Uses of NPOIFSFileSystem in org.apache.poi.hslf.extractor

Constructors in org.apache.poi.hslf.extractor with parameters of type NPOIFSFileSystem
PowerPointExtractor(NPOIFSFileSystem fs)
Creates a PowerPointExtractor, from an open NPOIFSFileSystem

Uses of NPOIFSFileSystem in org.apache.poi.hsmf

Constructors in org.apache.poi.hsmf with parameters of type NPOIFSFileSystem
MAPIMessage(NPOIFSFileSystem fs)
Constructor for reading MSG Files from a POIFS filesystem

Uses of NPOIFSFileSystem in org.apache.poi.hsmf.extractor

Constructors in org.apache.poi.hsmf.extractor with parameters of type NPOIFSFileSystem
OutlookTextExtactor(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.poifs.crypt

Methods in org.apache.poi.poifs.crypt with parameters of type NPOIFSFileSystem
 java.io.InputStream Decryptor.getDataStream(NPOIFSFileSystem fs)

Constructors in org.apache.poi.poifs.crypt with parameters of type NPOIFSFileSystem
EncryptionInfo(NPOIFSFileSystem fs)

Uses of NPOIFSFileSystem in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return NPOIFSFileSystem
 NPOIFSFileSystem DirectoryNode.getNFileSystem()

Constructors in org.apache.poi.poifs.filesystem with parameters of type NPOIFSFileSystem
NPOIFSDocument(DocumentProperty property, NPOIFSFileSystem filesystem)
Constructor for an existing Document
NPOIFSDocument(java.lang.String name, NPOIFSFileSystem filesystem, java.io.InputStream stream)
Constructor for a new Document
NPOIFSMiniStore(NPOIFSFileSystem filesystem, RootProperty root, java.util.List<BATBlock> sbats, HeaderBlock header)

Uses of NPOIFSFileSystem in org.apache.poi.poifs.property

Constructors in org.apache.poi.poifs.property with parameters of type NPOIFSFileSystem
NPropertyTable(HeaderBlock headerBlock, NPOIFSFileSystem filesystem)
reading constructor (used when we've read in a file and we want to extract the property table from it).

Uses of NPOIFSFileSystem in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel with parameters of type NPOIFSFileSystem
static Workbook WorkbookFactory.create(NPOIFSFileSystem fs)
Creates an HSSFWorkbook from the given NPOIFSFileSystem

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.NPOIFSMiniStore

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.NPOIFSMiniStore

Packages that use NPOIFSMiniStore
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of NPOIFSMiniStore in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return NPOIFSMiniStore
 NPOIFSMiniStore NPOIFSFileSystem.getMiniStore()
Returns the MiniStore, which performs a similar low level function to this, except for the small blocks.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.NPOIFSStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.NPOIFSStream

Packages that use NPOIFSStream
org.apache.poi.poifs.property property package contains high and low level Property structures for POIFS.

Uses of NPOIFSStream in org.apache.poi.poifs.property

Methods in org.apache.poi.poifs.property with parameters of type NPOIFSStream
 void NPropertyTable.write(NPOIFSStream stream)
Writes the properties out into the given low-level stream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator

No usage of org.apache.poi.poifs.filesystem.NPOIFSStream.StreamBlockByteBufferIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.ODocumentInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.ODocumentInputStream

No usage of org.apache.poi.poifs.filesystem.ODocumentInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.OfficeXmlFileException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.OfficeXmlFileException

No usage of org.apache.poi.poifs.filesystem.OfficeXmlFileException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.Ole10Native

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.Ole10Native

Packages that use Ole10Native
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of Ole10Native in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return Ole10Native
static Ole10Native | Ole10Native.createFromEmbeddedOleObject(DirectoryNode directory) Creates an instance of this class from an embedded OLE Object.
static Ole10Native | Ole10Native.createFromEmbeddedOleObject(POIFSFileSystem poifs) Creates an instance of this class from an embedded OLE Object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.Ole10NativeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.Ole10NativeException

Packages that use Ole10NativeException
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of Ole10NativeException in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that throw Ole10NativeException
static Ole10Native | Ole10Native.createFromEmbeddedOleObject(DirectoryNode directory) Creates an instance of this class from an embedded OLE Object.
static Ole10Native | Ole10Native.createFromEmbeddedOleObject(POIFSFileSystem poifs) Creates an instance of this class from an embedded OLE Object.

Constructors in org.apache.poi.poifs.filesystem that throw Ole10NativeException
Ole10Native(byte[] data, int offset)
Creates an instance and fills the fields based on the data in the given buffer.
Ole10Native(byte[] data, int offset, boolean plain)
Creates an instance and fills the fields based on the data in the given buffer.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.POIFSDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.POIFSDocument

Packages that use POIFSDocument
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.

Uses of POIFSDocument in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type POIFSDocument
DocumentInputStream(POIFSDocument document)
Create an InputStream from the specified Document
ODocumentInputStream(POIFSDocument document)
Create an InputStream from the specified Document

Uses of POIFSDocument in org.apache.poi.poifs.property

Methods in org.apache.poi.poifs.property that return POIFSDocument
 POIFSDocument DocumentProperty.getDocument()
get the POIFSDocument

Methods in org.apache.poi.poifs.property with parameters of type POIFSDocument
 void DocumentProperty.setDocument(POIFSDocument doc)
set the POIFSDocument

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.POIFSDocumentPath

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.POIFSDocumentPath

Packages that use POIFSDocumentPath
org.apache.poi.poifs.eventfilesystem | The eventfilesystem is an efficient method for reading OLE 2 CDF files.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of POIFSDocumentPath in org.apache.poi.poifs.eventfilesystem

Methods in org.apache.poi.poifs.eventfilesystem that return POIFSDocumentPath
 POIFSDocumentPath POIFSReaderEvent.getPath()

Methods in org.apache.poi.poifs.eventfilesystem with parameters of type POIFSDocumentPath
 void POIFSReader.registerListener(POIFSReaderListener listener, POIFSDocumentPath path, java.lang.String name)
Register a POIFSReaderListener for a document in the specified directory

Uses of POIFSDocumentPath in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return POIFSDocumentPath
POIFSDocumentPath | POIFSDocumentPath.getParent() Returns the path's parent or null if this path is the root path.
POIFSDocumentPath | POIFSWriterEvent.getPath()
POIFSDocumentPath | DirectoryNode.getPath()

Constructors in org.apache.poi.poifs.filesystem with parameters of type POIFSDocumentPath
DocumentDescriptor(POIFSDocumentPath path, java.lang.String name)
Trivial constructor
POIFSDocument(java.lang.String name, int size, POIFSBigBlockSize bigBlockSize, POIFSDocumentPath path, POIFSWriterListener writer)
Constructor
POIFSDocument(java.lang.String name, int size, POIFSDocumentPath path, POIFSWriterListener writer)
POIFSDocumentPath(POIFSDocumentPath path, java.lang.String[] components)
constructor that adds additional subdirectories to an existing path

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.POIFSFileSystem

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.POIFSFileSystem

Packages that use POIFSFileSystem
org.apache.poi |
org.apache.poi.extractor |
org.apache.poi.hdgf |
org.apache.poi.hdgf.extractor |
org.apache.poi.hpbf |
org.apache.poi.hpbf.dev |
org.apache.poi.hpbf.extractor |
org.apache.poi.hpsf.extractor |
org.apache.poi.hslf |
org.apache.poi.hslf.dev |
org.apache.poi.hslf.extractor |
org.apache.poi.hslf.record |
org.apache.poi.hsmf |
org.apache.poi.hsmf.dev |
org.apache.poi.hsmf.extractor |
org.apache.poi.hsmf.parsers |
org.apache.poi.hssf.eventusermodel | HSSF eventmodel Package provides an event-based API for reading HSSF files.
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf |
org.apache.poi.hwpf.converter |
org.apache.poi.hwpf.extractor |
org.apache.poi.poifs.crypt |
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.ss.usermodel |

Uses of POIFSFileSystem in org.apache.poi

Methods in org.apache.poi that return POIFSFileSystem
 POIFSFileSystem POIOLE2TextExtractor.getFileSystem()
Deprecated. Use POIOLE2TextExtractor.getRoot() instead

Methods in org.apache.poi with parameters of type POIFSFileSystem
protected void | POIDocument.copyNodes(POIFSFileSystem source, POIFSFileSystem target, java.util.List<java.lang.String> excepts) Deprecated.
protected void | POIDocument.writeProperties(POIFSFileSystem outFS) Writes out the standard Documment Information Properties (HPSF)
protected void | POIDocument.writeProperties(POIFSFileSystem outFS, java.util.List<java.lang.String> writtenEntries) Writes out the standard Documment Information Properties (HPSF)
protected void | POIDocument.writePropertySet(java.lang.String name, PropertySet set, POIFSFileSystem outFS) Writes out a given ProperySet

Constructors in org.apache.poi with parameters of type POIFSFileSystem
POIDocument(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. use POIDocument.POIDocument(DirectoryNode) instead
POIDocument(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.extractor

Methods in org.apache.poi.extractor with parameters of type POIFSFileSystem
static POITextExtractor ExtractorFactory.createExtractor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use ExtractorFactory.createExtractor(DirectoryNode) instead
static POIOLE2TextExtractor ExtractorFactory.createExtractor(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hdgf

Constructors in org.apache.poi.hdgf with parameters of type POIFSFileSystem
HDGFDiagram(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use HDGFDiagram.HDGFDiagram(DirectoryNode) instead
HDGFDiagram(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hdgf.extractor

Constructors in org.apache.poi.hdgf.extractor with parameters of type POIFSFileSystem
VisioTextExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use VisioTextExtractor.VisioTextExtractor(DirectoryNode) instead
VisioTextExtractor(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hpbf

Constructors in org.apache.poi.hpbf with parameters of type POIFSFileSystem
HPBFDocument(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use HPBFDocument.HPBFDocument(DirectoryNode) instead
HPBFDocument(POIFSFileSystem fs)
Opens a new publisher document

Uses of POIFSFileSystem in org.apache.poi.hpbf.dev

Constructors in org.apache.poi.hpbf.dev with parameters of type POIFSFileSystem
HPBFDumper(POIFSFileSystem fs)
PLCDumper(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hpbf.extractor

Constructors in org.apache.poi.hpbf.extractor with parameters of type POIFSFileSystem
PublisherTextExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated.
PublisherTextExtractor(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hpsf.extractor

Constructors in org.apache.poi.hpsf.extractor with parameters of type POIFSFileSystem
HPSFPropertiesExtractor(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hslf

Methods in org.apache.poi.hslf that return POIFSFileSystem
protected  POIFSFileSystem HSLFSlideShow.getPOIFSFileSystem()
Returns the underlying POIFSFileSystem for the document that is open.

Constructors in org.apache.poi.hslf with parameters of type POIFSFileSystem
HSLFSlideShow(DirectoryNode dir, POIFSFileSystem filesystem)
Deprecated. Use HSLFSlideShow.HSLFSlideShow(DirectoryNode) instead
HSLFSlideShow(POIFSFileSystem filesystem)
Constructs a Powerpoint document from a POIFS Filesystem.

Uses of POIFSFileSystem in org.apache.poi.hslf.dev

Constructors in org.apache.poi.hslf.dev with parameters of type POIFSFileSystem
SlideShowDumper(POIFSFileSystem filesystem)
Constructs a Powerpoint dump from a POIFS Filesystem.

Uses of POIFSFileSystem in org.apache.poi.hslf.extractor

Constructors in org.apache.poi.hslf.extractor with parameters of type POIFSFileSystem
PowerPointExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use PowerPointExtractor.PowerPointExtractor(DirectoryNode) instead
PowerPointExtractor(POIFSFileSystem fs)
Creates a PowerPointExtractor, from an open POIFSFileSystem
QuickButCruddyTextExtractor(POIFSFileSystem poifs)
Creates an extractor from a POIFS Filesystem

Uses of POIFSFileSystem in org.apache.poi.hslf.record

Methods in org.apache.poi.hslf.record with parameters of type POIFSFileSystem
 void CurrentUserAtom.writeToFS(POIFSFileSystem fs)
Writes ourselves back out to a filesystem

Constructors in org.apache.poi.hslf.record with parameters of type POIFSFileSystem
CurrentUserAtom(POIFSFileSystem fs)
Find the Current User in the filesystem, and create from that

Uses of POIFSFileSystem in org.apache.poi.hsmf

Constructors in org.apache.poi.hsmf with parameters of type POIFSFileSystem
MAPIMessage(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated. Use MAPIMessage.MAPIMessage(DirectoryNode) instead
MAPIMessage(POIFSFileSystem fs)
Constructor for reading MSG Files from a POIFS filesystem

Uses of POIFSFileSystem in org.apache.poi.hsmf.dev

Constructors in org.apache.poi.hsmf.dev with parameters of type POIFSFileSystem
HSMFDump(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hsmf.extractor

Constructors in org.apache.poi.hsmf.extractor with parameters of type POIFSFileSystem
OutlookTextExtactor(DirectoryNode poifsDir, POIFSFileSystem fs)
Deprecated.
OutlookTextExtactor(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hsmf.parsers

Methods in org.apache.poi.hsmf.parsers with parameters of type POIFSFileSystem
static ChunkGroup[] POIFSChunkParser.parse(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hssf.eventusermodel

Methods in org.apache.poi.hssf.eventusermodel with parameters of type POIFSFileSystem
short | HSSFEventFactory.abortableProcessWorkbookEvents(HSSFRequest req, POIFSFileSystem fs) Processes a file into essentially record events.
void | HSSFEventFactory.processWorkbookEvents(HSSFRequest req, POIFSFileSystem fs) Processes a file into essentially record events.

Uses of POIFSFileSystem in org.apache.poi.hssf.extractor

Methods in org.apache.poi.hssf.extractor that return POIFSFileSystem
 POIFSFileSystem EventBasedExcelExtractor.getFileSystem()
Deprecated. Use POIOLE2TextExtractor.getRoot() instead

Constructors in org.apache.poi.hssf.extractor with parameters of type POIFSFileSystem
EventBasedExcelExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use EventBasedExcelExtractor.EventBasedExcelExtractor(DirectoryNode) instead
EventBasedExcelExtractor(POIFSFileSystem fs)
ExcelExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use ExcelExtractor.ExcelExtractor(DirectoryNode) instead
ExcelExtractor(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hssf.usermodel

Constructors in org.apache.poi.hssf.usermodel with parameters of type POIFSFileSystem
HSSFWorkbook(DirectoryNode directory, POIFSFileSystem fs, boolean preserveNodes)
given a POI POIFSFileSystem object, and a specific directory within it, read in its Workbook and populate the high and low level models.
HSSFWorkbook(POIFSFileSystem fs)
HSSFWorkbook(POIFSFileSystem fs, boolean preserveNodes)
given a POI POIFSFileSystem object, read in its Workbook and populate the high and low level models.

Uses of POIFSFileSystem in org.apache.poi.hwpf

Methods in org.apache.poi.hwpf that return POIFSFileSystem
static POIFSFileSystem HWPFDocumentCore.verifyAndBuildPOIFS(java.io.InputStream istream)
Takens an InputStream, verifies that it's not RTF, builds a POIFSFileSystem from it, and returns that.

Constructors in org.apache.poi.hwpf with parameters of type POIFSFileSystem
HWPFDocument(DirectoryNode directory, POIFSFileSystem pfilesystem)
Deprecated. Use HWPFDocument.HWPFDocument(DirectoryNode) instead
HWPFDocument(POIFSFileSystem pfilesystem)
This constructor loads a Word document from a POIFSFileSystem
HWPFDocumentCore(POIFSFileSystem pfilesystem)
This constructor loads a Word document from a POIFSFileSystem
HWPFOldDocument(DirectoryNode directory, POIFSFileSystem fs)
Deprecated.
HWPFOldDocument(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with parameters of type POIFSFileSystem
static HWPFDocumentCore AbstractWordUtils.loadDoc(POIFSFileSystem poifsFileSystem)

Uses of POIFSFileSystem in org.apache.poi.hwpf.extractor

Constructors in org.apache.poi.hwpf.extractor with parameters of type POIFSFileSystem
Word6Extractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use Word6Extractor.Word6Extractor(DirectoryNode) instead
Word6Extractor(POIFSFileSystem fs)
Create a new Word Extractor
WordExtractor(DirectoryNode dir, POIFSFileSystem fs)
Deprecated. Use WordExtractor.WordExtractor(DirectoryNode) instead
WordExtractor(POIFSFileSystem fs)
Create a new Word Extractor

Uses of POIFSFileSystem in org.apache.poi.poifs.crypt

Methods in org.apache.poi.poifs.crypt with parameters of type POIFSFileSystem
 java.io.InputStream Decryptor.getDataStream(POIFSFileSystem fs)

Constructors in org.apache.poi.poifs.crypt with parameters of type POIFSFileSystem
EncryptionInfo(POIFSFileSystem fs)

Uses of POIFSFileSystem in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return POIFSFileSystem
 POIFSFileSystem DirectoryNode.getFileSystem()

Methods in org.apache.poi.poifs.filesystem with parameters of type POIFSFileSystem
static void | EntryUtils.copyNodes(POIFSFileSystem source, POIFSFileSystem target) Copies all nodes from one POIFS to the other
static void | EntryUtils.copyNodes(POIFSFileSystem source, POIFSFileSystem target, java.util.List<java.lang.String> excepts) Copies nodes from one POIFS to the other, minus the excepts.
static Ole10Native | Ole10Native.createFromEmbeddedOleObject(POIFSFileSystem poifs) Creates an instance of this class from an embedded OLE Object.

Uses of POIFSFileSystem in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel with parameters of type POIFSFileSystem
static Workbook WorkbookFactory.create(POIFSFileSystem fs)
Creates an HSSFWorkbook from the given POIFSFileSystem

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.filesystem.POIFSWriterEvent

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.filesystem.POIFSWriterEvent

Packages that use POIFSWriterEvent
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of POIFSWriterEvent in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem with parameters of type POIFSWriterEvent
 void POIFSWriterListener.processPOIFSWriterEvent(POIFSWriterEvent event)
Process a POIFSWriterEvent that this listener had registered for

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.filesystem.POIFSWriterListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.filesystem.POIFSWriterListener

Packages that use POIFSWriterListener
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of POIFSWriterListener in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem with parameters of type POIFSWriterListener
DocumentEntry | POIFSFileSystem.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry in the root entry; the data will be provided later
DocumentEntry | NPOIFSFileSystem.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry in the root entry; the data will be provided later
DocumentEntry | FilteringDirectoryNode.createDocument(java.lang.String name, int size, POIFSWriterListener writer)
DocumentEntry | DirectoryNode.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry; the data will be provided later
DocumentEntry | DirectoryEntry.createDocument(java.lang.String name, int size, POIFSWriterListener writer) create a new DocumentEntry; the data will be provided later

Constructors in org.apache.poi.poifs.filesystem with parameters of type POIFSWriterListener
POIFSDocument(java.lang.String name, int size, POIFSBigBlockSize bigBlockSize, POIFSDocumentPath path, POIFSWriterListener writer)
Constructor
POIFSDocument(java.lang.String name, int size, POIFSDocumentPath path, POIFSWriterListener writer)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ByteArrayBackedDataSource

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.nio
Class ByteArrayBackedDataSource

java.lang.Object
    extended by  org.apache.poi.poifs.nio.DataSource
        extended by  org.apache.poi.poifs.nio.ByteArrayBackedDataSource

public class ByteArrayBackedDataSource
extends DataSource

A POIFS DataSource backed by a byte array.

Constructor Summary
ByteArrayBackedDataSource(byte[] data)
ByteArrayBackedDataSource(byte[] data, int size)
Method Summary
void | close() Close the underlying stream
void | copyTo(java.io.OutputStream stream) Copies the contents to the specified OutputStream
java.nio.ByteBuffer | read(int length, long position)
long | size()
void | write(java.nio.ByteBuffer src, long position)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ByteArrayBackedDataSource

public ByteArrayBackedDataSource(byte[] data,
                                 int size)

ByteArrayBackedDataSource

public ByteArrayBackedDataSource(byte[] data)
Method Detail

read

public java.nio.ByteBuffer read(int length,
                                long position)
Specified by:
read in class DataSource

write

public void write(java.nio.ByteBuffer src,
                  long position)
Specified by:
write in class DataSource

copyTo

public void copyTo(java.io.OutputStream stream)
            throws java.io.IOException
Description copied from class: DataSource
Copies the contents to the specified OutputStream

Specified by:
copyTo in class DataSource
Throws:
java.io.IOException

size

public long size()
Specified by:
size in class DataSource

close

public void close()
Description copied from class: DataSource
Close the underlying stream

Specified by:
close in class DataSource
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DataSource

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.nio
Class DataSource

java.lang.Object
    extended by  org.apache.poi.poifs.nio.DataSource
Direct Known Subclasses:
ByteArrayBackedDataSource, FileBackedDataSource
public abstract class DataSource
extends java.lang.Object

Common definition of how we read and write bytes

Constructor Summary
DataSource()
Method Summary
abstract void | close() Close the underlying stream
abstract void | copyTo(java.io.OutputStream stream) Copies the contents to the specified OutputStream
abstract java.nio.ByteBuffer | read(int length, long position)
abstract long | size()
abstract void | write(java.nio.ByteBuffer src, long position)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataSource

public DataSource()
Method Detail

read

public abstract java.nio.ByteBuffer read(int length,
                                         long position)
                                  throws java.io.IOException
Throws:
java.io.IOException

write

public abstract void write(java.nio.ByteBuffer src,
                           long position)
                    throws java.io.IOException
Throws:
java.io.IOException

size

public abstract long size()
                   throws java.io.IOException
Throws:
java.io.IOException

close

public abstract void close()
                    throws java.io.IOException
Close the underlying stream

Throws:
java.io.IOException

copyTo

public abstract void copyTo(java.io.OutputStream stream)
                     throws java.io.IOException
Copies the contents to the specified OutputStream

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileBackedDataSource

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.nio
Class FileBackedDataSource

java.lang.Object
    extended by  org.apache.poi.poifs.nio.DataSource
        extended by  org.apache.poi.poifs.nio.FileBackedDataSource

public class FileBackedDataSource
extends DataSource

A POIFS DataSource backed by a File

Constructor Summary
FileBackedDataSource(java.io.File file)
FileBackedDataSource(java.nio.channels.FileChannel channel)
Method Summary
void | close() Close the underlying stream
void | copyTo(java.io.OutputStream stream) Copies the contents to the specified OutputStream
java.nio.ByteBuffer | read(int length, long position)
long | size()
void | write(java.nio.ByteBuffer src, long position)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileBackedDataSource

public FileBackedDataSource(java.io.File file)
                     throws java.io.FileNotFoundException
Throws:
java.io.FileNotFoundException

FileBackedDataSource

public FileBackedDataSource(java.nio.channels.FileChannel channel)
Method Detail

read

public java.nio.ByteBuffer read(int length,
                                long position)
                         throws java.io.IOException
Specified by:
read in class DataSource
Throws:
java.io.IOException

write

public void write(java.nio.ByteBuffer src,
                  long position)
           throws java.io.IOException
Specified by:
write in class DataSource
Throws:
java.io.IOException

copyTo

public void copyTo(java.io.OutputStream stream)
            throws java.io.IOException
Description copied from class: DataSource
Copies the contents to the specified OutputStream

Specified by:
copyTo in class DataSource
Throws:
java.io.IOException

size

public long size()
          throws java.io.IOException
Specified by:
size in class DataSource
Throws:
java.io.IOException

close

public void close()
           throws java.io.IOException
Description copied from class: DataSource
Close the underlying stream

Specified by:
close in class DataSource
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.poifs.nio
Classes
ByteArrayBackedDataSource
DataSource
FileBackedDataSource


org.apache.poi.poifs.nio

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.nio

Class Summary
ByteArrayBackedDataSource | A POIFS DataSource backed by a byte array.
DataSource | Common definition of how we read and write bytes
FileBackedDataSource | A POIFS DataSource backed by a File


org.apache.poi.poifs.nio Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.nio

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.nio.DataSource
      • org.apache.poi.poifs.nio.ByteArrayBackedDataSource
      • org.apache.poi.poifs.nio.FileBackedDataSource


Uses of Package org.apache.poi.poifs.nio

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.nio

Packages that use org.apache.poi.poifs.nio
org.apache.poi.poifs.nio

Classes in org.apache.poi.poifs.nio used by org.apache.poi.poifs.nio
DataSource
Common definition of how we read and write bytes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.nio.ByteArrayBackedDataSource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.nio.ByteArrayBackedDataSource

No usage of org.apache.poi.poifs.nio.ByteArrayBackedDataSource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.nio.DataSource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.nio.DataSource

Packages that use DataSource
org.apache.poi.poifs.nio

Uses of DataSource in org.apache.poi.poifs.nio

Subclasses of DataSource in org.apache.poi.poifs.nio
class | ByteArrayBackedDataSource A POIFS DataSource backed by a byte array.
class | FileBackedDataSource A POIFS DataSource backed by a File

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.nio.FileBackedDataSource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.nio.FileBackedDataSource

No usage of org.apache.poi.poifs.nio.FileBackedDataSource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Child

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Interface Child

All Known Subinterfaces:
Parent
All Known Implementing Classes:
DirectoryProperty, DocumentProperty, Property, RootProperty
public interface Child

This interface defines methods for finding and setting sibling Property instances

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
Child | getNextChild() Get the next Child, if any
Child | getPreviousChild() Get the previous Child, if any
void | setNextChild(Child child) Set the next Child
void | setPreviousChild(Child child) Set the previous Child

Method Detail

getNextChild

Child getNextChild()
Get the next Child, if any

Returns:
the next Child; may return null

getPreviousChild

Child getPreviousChild()
Get the previous Child, if any

Returns:
the previous Child; may return null

setNextChild

void setNextChild(Child child)
Set the next Child

Parameters:
child - the new 'next' child; may be null, which has the effect of saying there is no 'next' child

setPreviousChild

void setPreviousChild(Child child)
Set the previous Child

Parameters:
child - the new 'previous' child; may be null, which has the effect of saying there is no 'previous' child
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DirectoryProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class DirectoryProperty

java.lang.Object
    extended by  org.apache.poi.poifs.property.Property
        extended by  org.apache.poi.poifs.property.DirectoryProperty
All Implemented Interfaces:
POIFSViewable, Child, Parent
Direct Known Subclasses:
RootProperty
public class DirectoryProperty
extends Property
implements Parent

Directory property

Author:
Marc Johnson (mjohnson at apache dot org)

Nested Class Summary
static class DirectoryProperty.PropertyComparator
Field Summary
Fields inherited from class org.apache.poi.poifs.property.Property
_NO_INDEX, _NODE_BLACK, _NODE_RED
Constructor Summary
protected | DirectoryProperty(int index, byte[] array, int offset) reader constructor
 | DirectoryProperty(java.lang.String name) Default constructor
Method Summary
void | addChild(Property property) Add a new child to the collection of children
boolean | changeName(Property property, java.lang.String newName) Change a Property's name
boolean | deleteChild(Property property) Delete a Property
java.util.Iterator<Property> | getChildren() Get an iterator over the children of this Parent; all elements are instances of Property.
boolean | isDirectory()
protected void | preWrite() Perform whatever activities need to be performed prior to writing
Methods inherited from class org.apache.poi.poifs.property.Property
getChildIndex, getIndex, getName, getNextChild, getPreviousChild, getShortDescription, getSize, getStartBlock, getStorageClsid, getViewableArray, getViewableIterator, isSmall, preferArray, setChildProperty, setIndex, setName, setNextChild, setNodeColor, setPreviousChild, setPropertyType, setSize, setStartBlock, setStorageClsid, shouldUseSmallBlocks, writeData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.poifs.property.Parent
setNextChild, setPreviousChild
Methods inherited from interface org.apache.poi.poifs.property.Child
getNextChild, getPreviousChild

Constructor Detail

DirectoryProperty

public DirectoryProperty(java.lang.String name)
Default constructor

Parameters:
name - the name of the directory

DirectoryProperty

protected DirectoryProperty(int index,
                            byte[] array,
                            int offset)
reader constructor

Parameters:
index - index number
array - byte data
offset - offset into byte data
Method Detail

changeName

public boolean changeName(Property property,
                          java.lang.String newName)
Change a Property's name

Parameters:
property - the Property whose name is being changed
newName - the new name for the Property
Returns:
true if the name change could be made, else false

deleteChild

public boolean deleteChild(Property property)
Delete a Property

Parameters:
property - the Property being deleted
Returns:
true if the Property could be deleted, else false

isDirectory

public boolean isDirectory()
Specified by:
isDirectory in class Property
Returns:
true if a directory type Property

preWrite

protected void preWrite()
Perform whatever activities need to be performed prior to writing

Specified by:
preWrite in class Property

getChildren

public java.util.Iterator<Property> getChildren()
Get an iterator over the children of this Parent; all elements are instances of Property.

Specified by:
getChildren in interface Parent
Returns:
Iterator of children; may refer to an empty collection

addChild

public void addChild(Property property)
              throws java.io.IOException
Add a new child to the collection of children

Specified by:
addChild in interface Parent
Parameters:
property - the new child to be added; must not be null
Throws:
java.io.IOException - if we already have a child with the same name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirectoryProperty.PropertyComparator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class DirectoryProperty.PropertyComparator

java.lang.Object
    extended by  org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator
All Implemented Interfaces:
java.util.Comparator<Property>
Enclosing class:
DirectoryProperty
public static class DirectoryProperty.PropertyComparator
extends java.lang.Object
implements java.util.Comparator<Property>

Constructor Summary
DirectoryProperty.PropertyComparator()
Method Summary
int | compare(Property o1, Property o2) compare method.
boolean | equals(java.lang.Object o) Object equality, implemented as object identity
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DirectoryProperty.PropertyComparator

public DirectoryProperty.PropertyComparator()
Method Detail

equals

public boolean equals(java.lang.Object o)
Object equality, implemented as object identity

Specified by:
equals in interface java.util.Comparator<Property>
Overrides:
equals in class java.lang.Object
Parameters:
o - Object we're being compared to
Returns:
true if identical, else false

compare

public int compare(Property o1,
                   Property o2)
compare method. Assumes both parameters are non-null instances of Property. One property is less than another if its name is shorter than the other property's name. If the names are the same length, the property whose name comes before the other property's name, alphabetically, is less than the other property.

Specified by:
compare in interface java.util.Comparator<Property>
Parameters:
o1 - first object to compare, better be a Property
o2 - second object to compare, better be a Property
Returns:
negative value if o1 < o2, zero if o1 == o2, positive value if o1 > o2.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentProperty

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class DocumentProperty

java.lang.Object
    extended by  org.apache.poi.poifs.property.Property
        extended by  org.apache.poi.poifs.property.DocumentProperty
All Implemented Interfaces:
POIFSViewable, Child
public class DocumentProperty
extends Property

Trivial extension of Property for POIFSDocuments

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
Fields inherited from class org.apache.poi.poifs.property.Property
_NO_INDEX, _NODE_BLACK, _NODE_RED
Constructor Summary
protected | DocumentProperty(int index, byte[] array, int offset) reader constructor
 | DocumentProperty(java.lang.String name, int size) Constructor
Method Summary
POIFSDocument | getDocument() get the POIFSDocument
boolean | isDirectory()
protected void | preWrite() Perform whatever activities need to be performed prior to writing
void | setDocument(POIFSDocument doc) set the POIFSDocument
boolean | shouldUseSmallBlocks() give method more visibility
Methods inherited from class org.apache.poi.poifs.property.Property
getChildIndex, getIndex, getName, getNextChild, getPreviousChild, getShortDescription, getSize, getStartBlock, getStorageClsid, getViewableArray, getViewableIterator, isSmall, preferArray, setChildProperty, setIndex, setName, setNextChild, setNodeColor, setPreviousChild, setPropertyType, setSize, setStartBlock, setStorageClsid, writeData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DocumentProperty

public DocumentProperty(java.lang.String name,
                        int size)
Constructor

Parameters:
name - POIFSDocument name
size - POIFSDocument size

DocumentProperty

protected DocumentProperty(int index,
                           byte[] array,
                           int offset)
reader constructor

Parameters:
index - index number
array - byte data
offset - offset into byte data
Method Detail

setDocument

public void setDocument(POIFSDocument doc)
set the POIFSDocument

Parameters:
doc - the associated POIFSDocument

getDocument

public POIFSDocument getDocument()
get the POIFSDocument

Returns:
the associated document

shouldUseSmallBlocks

public boolean shouldUseSmallBlocks()
give method more visibility

Overrides:
shouldUseSmallBlocks in class Property
Returns:
true if this property should use small blocks

isDirectory

public boolean isDirectory()
Specified by:
isDirectory in class Property
Returns:
true if a directory type Property

preWrite

protected void preWrite()
Perform whatever activities need to be performed prior to writing

Specified by:
preWrite in class Property
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NPropertyTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class NPropertyTable

java.lang.Object
    extended by  org.apache.poi.poifs.property.PropertyTableBase
        extended by  org.apache.poi.poifs.property.NPropertyTable
All Implemented Interfaces:
BATManaged
public final class NPropertyTable
extends PropertyTableBase

This class embodies the Property Table for a NPOIFSFileSystem; this is basically the directory for all of the documents in the filesystem.

Field Summary
Fields inherited from class org.apache.poi.poifs.property.PropertyTableBase
_properties
Constructor Summary
NPropertyTable(HeaderBlock headerBlock)
NPropertyTable(HeaderBlock headerBlock, NPOIFSFileSystem filesystem)
reading constructor (used when we've read in a file and we want to extract the property table from it).
Method Summary
int | countBlocks() Return the number of BigBlock's this instance uses
void | write(NPOIFSStream stream) Writes the properties out into the given low-level stream
Methods inherited from class org.apache.poi.poifs.property.PropertyTableBase
addProperty, getRoot, getStartBlock, removeProperty, setStartBlock
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NPropertyTable

public NPropertyTable(HeaderBlock headerBlock)

NPropertyTable

public NPropertyTable(HeaderBlock headerBlock,
                      NPOIFSFileSystem filesystem)
               throws java.io.IOException
reading constructor (used when we've read in a file and we want to extract the property table from it). Populates the properties thoroughly

Parameters:
headerBlock - the header block of the file
filesystem - the filesystem to read from
Throws:
java.io.IOException - if anything goes wrong (which should be a result of the input being NFG)
Method Detail

countBlocks

public int countBlocks()
Return the number of BigBlock's this instance uses

Returns:
count of BigBlock instances

write

public void write(NPOIFSStream stream)
           throws java.io.IOException
Writes the properties out into the given low-level stream

Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.poifs.property
Interfaces
Child
Parent
PropertyConstants
Classes
DirectoryProperty
DirectoryProperty.PropertyComparator
DocumentProperty
NPropertyTable
Property
PropertyTable
PropertyTableBase
RootProperty


org.apache.poi.poifs.property

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.property

property package contains high and low level Property structures for POIFS.

See:
Description

Interface Summary
Child | This interface defines methods for finding and setting sibling Property instances
Parent | Behavior for parent (directory) properties
PropertyConstants | Interface PropertyConstants

Class Summary
DirectoryProperty | Directory property
DirectoryProperty.PropertyComparator |
DocumentProperty | Trivial extension of Property for POIFSDocuments
NPropertyTable | This class embodies the Property Table for a NPOIFSFileSystem; this is basically the directory for all of the documents in the filesystem.
Property | This abstract base class is the ancestor of all classes implementing POIFS Property behavior.
PropertyTable | This class embodies the Property Table for the POIFSFileSystem; this is basically the directory for all of the documents in the filesystem.
PropertyTableBase | This class embodies the Property Table for the filesystem, which looks up entries in the filesystem to their chain of blocks.
RootProperty | Root property

Package org.apache.poi.poifs.property Description

property package contains high and low level Property structures for POIFS.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.poifs.filesystem


org.apache.poi.poifs.property Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.property

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator (implements java.util.Comparator<T>)
    • org.apache.poi.poifs.property.Property (implements org.apache.poi.poifs.property.Child, org.apache.poi.poifs.dev.POIFSViewable)
      • org.apache.poi.poifs.property.DirectoryProperty (implements org.apache.poi.poifs.property.Parent)
        • org.apache.poi.poifs.property.RootProperty
      • org.apache.poi.poifs.property.DocumentProperty
    • org.apache.poi.poifs.property.PropertyTableBase (implements org.apache.poi.poifs.filesystem.BATManaged)
      • org.apache.poi.poifs.property.NPropertyTable
      • org.apache.poi.poifs.property.PropertyTable (implements org.apache.poi.poifs.storage.BlockWritable)

Interface Hierarchy

  • org.apache.poi.poifs.property.Child
    • org.apache.poi.poifs.property.Parent
  • org.apache.poi.poifs.property.PropertyConstants


Uses of Package org.apache.poi.poifs.property

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.property

Packages that use org.apache.poi.poifs.property
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Classes in org.apache.poi.poifs.property used by org.apache.poi.poifs.filesystem
DocumentProperty
Trivial extension of Property for POIFSDocuments
Property
This abstract base class is the ancestor of all classes implementing POIFS Property behavior.
RootProperty
Root property

Classes in org.apache.poi.poifs.property used by org.apache.poi.poifs.property
Child
This interface defines methods for finding and setting sibling Property instances
DirectoryProperty
Directory property
Parent
Behavior for parent (directory) properties
Property
This abstract base class is the ancestor of all classes implementing POIFS Property behavior.
PropertyTableBase
This class embodies the Property Table for the filesystem, which looks up entries in the filesystem to their chain of blocks.
RootProperty
Root property

Classes in org.apache.poi.poifs.property used by org.apache.poi.poifs.storage
Property
This abstract base class is the ancestor of all classes implementing POIFS Property behavior.
RootProperty
Root property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Parent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Interface Parent

All Superinterfaces:
Child
All Known Implementing Classes:
DirectoryProperty, RootProperty
public interface Parent
extends Child

Behavior for parent (directory) properties

Author:
Marc Johnson27591@hotmail.com

Method Summary
void | addChild(Property property) Add a new child to the collection of children
java.util.Iterator | getChildren() Get an iterator over the children of this Parent; all elements are instances of Property.
void | setNextChild(Child child) Set the next Child
void | setPreviousChild(Child child) Set the previous Child
Methods inherited from interface org.apache.poi.poifs.property.Child
getNextChild, getPreviousChild

Method Detail

getChildren

java.util.Iterator getChildren()
Get an iterator over the children of this Parent; all elements are instances of Property.

Returns:
Iterator of children; may refer to an empty collection

addChild

void addChild(Property property)
              throws java.io.IOException
Add a new child to the collection of children

Parameters:
property - the new child to be added; must not be null
Throws:
java.io.IOException - if the Parent already has a child with the same name

setPreviousChild

void setPreviousChild(Child child)
Set the previous Child

Specified by:
setPreviousChild in interface Child
Parameters:
child - the new 'previous' child; may be null, which has the effect of saying there is no 'previous' child

setNextChild

void setNextChild(Child child)
Set the next Child

Specified by:
setNextChild in interface Child
Parameters:
child - the new 'next' child; may be null, which has the effect of saying there is no 'next' child
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Property

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class Property

java.lang.Object
    extended by  org.apache.poi.poifs.property.Property
All Implemented Interfaces:
POIFSViewable, Child
Direct Known Subclasses:
DirectoryProperty, DocumentProperty
public abstract class Property
extends java.lang.Object
implements Child, POIFSViewable

This abstract base class is the ancestor of all classes implementing POIFS Property behavior.

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
protected static int | _NO_INDEX
protected static byte | _NODE_BLACK
protected static byte | _NODE_RED
Constructor Summary
protected | Property()
protected | Property(int index, byte[] array, int offset) Constructor from byte data
Method Summary
protected int | getChildIndex() Get the child property (its index in the Property Table)
protected int | getIndex() get the index for this Property
java.lang.String | getName() Get the name of this property
Child | getNextChild() Get the next Child, if any
Child | getPreviousChild() Get the previous Child, if any
java.lang.String | getShortDescription() Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.
int | getSize() find out the document size
int | getStartBlock()
ClassID | getStorageClsid() Sets the storage clsid, which is the Class ID of a COM object which reads and writes this stream
java.lang.Object[] | getViewableArray() Get an array of objects, some of which may implement POIFSViewable
java.util.Iterator | getViewableIterator() Get an Iterator of objects, some of which may implement POIFSViewable
abstract boolean | isDirectory()
static boolean | isSmall(int length) does the length indicate a small document?
boolean | preferArray() Give viewers a hint as to whether to call getViewableArray or getViewableIterator
protected abstract void | preWrite() Perform whatever activities need to be performed prior to writing
protected void | setChildProperty(int child) Set the child property.
protected void | setIndex(int index) Set the index for this Property
protected void | setName(java.lang.String name) Set the name; silently truncates the name if it's too long.
void | setNextChild(Child child) Set the next Child
protected void | setNodeColor(byte nodeColor) Set the node color.
void | setPreviousChild(Child child) Set the previous Child
protected void | setPropertyType(byte propertyType) Set the property type.
protected void | setSize(int size) Set the size of the document associated with this Property
void | setStartBlock(int startBlock) Set the start block for the document referred to by this Property.
void | setStorageClsid(ClassID clsidStorage) Sets the storage class ID for this property stream.
boolean | shouldUseSmallBlocks() Based on the currently defined size, should this property use small blocks?
void | writeData(java.io.OutputStream stream) Write the raw data to an OutputStream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_NO_INDEX

protected static final int _NO_INDEX
See Also:
Constant Field Values

_NODE_BLACK

protected static final byte _NODE_BLACK
See Also:
Constant Field Values

_NODE_RED

protected static final byte _NODE_RED
See Also:
Constant Field Values
Constructor Detail

Property

protected Property()

Property

protected Property(int index,
                   byte[] array,
                   int offset)
Constructor from byte data

Parameters:
index - index number
array - byte data
offset - offset into byte data
Method Detail

writeData

public void writeData(java.io.OutputStream stream)
               throws java.io.IOException
Write the raw data to an OutputStream.

Parameters:
stream - the OutputStream to which the data should be written.
Throws:
java.io.IOException - on problems writing to the specified stream.

setStartBlock

public void setStartBlock(int startBlock)
Set the start block for the document referred to by this Property.

Parameters:
startBlock - the start block index

getStartBlock

public int getStartBlock()
Returns:
the start block

getSize

public int getSize()
find out the document size

Returns:
size in bytes

shouldUseSmallBlocks

public boolean shouldUseSmallBlocks()
Based on the currently defined size, should this property use small blocks?

Returns:
true if the size is less than _big_block_minimum_bytes

isSmall

public static boolean isSmall(int length)
does the length indicate a small document?

Parameters:
length - length in bytes
Returns:
true if the length is less than _big_block_minimum_bytes

getName

public java.lang.String getName()
Get the name of this property

Returns:
property name as String

isDirectory

public abstract boolean isDirectory()
Returns:
true if a directory type Property

getStorageClsid

public ClassID getStorageClsid()
Sets the storage clsid, which is the Class ID of a COM object which reads and writes this stream

Returns:
storage Class ID for this property stream

setName

protected void setName(java.lang.String name)
Set the name; silently truncates the name if it's too long.

Parameters:
name - the new name

setStorageClsid

public void setStorageClsid(ClassID clsidStorage)
Sets the storage class ID for this property stream. This is the Class ID of the COM object which can read and write this property stream

Parameters:
clsidStorage - Storage Class ID

setPropertyType

protected void setPropertyType(byte propertyType)
Set the property type. Makes no attempt to validate the value.

Parameters:
propertyType - the property type (root, file, directory)

setNodeColor

protected void setNodeColor(byte nodeColor)
Set the node color.

Parameters:
nodeColor - the node color (red or black)

setChildProperty

protected void setChildProperty(int child)
Set the child property.

Parameters:
child - the child property's index in the Property Table

getChildIndex

protected int getChildIndex()
Get the child property (its index in the Property Table)

Returns:
child property index

setSize

protected void setSize(int size)
Set the size of the document associated with this Property

Parameters:
size - the size of the document, in bytes

setIndex

protected void setIndex(int index)
Set the index for this Property

Parameters:
index - this Property's index within its containing Property Table

getIndex

protected int getIndex()
get the index for this Property

Returns:
the index of this Property within its Property Table

preWrite

protected abstract void preWrite()
Perform whatever activities need to be performed prior to writing

getNextChild

public Child getNextChild()
Get the next Child, if any

Specified by:
getNextChild in interface Child
Returns:
the next Child; may return null

getPreviousChild

public Child getPreviousChild()
Get the previous Child, if any

Specified by:
getPreviousChild in interface Child
Returns:
the previous Child; may return null

setNextChild

public void setNextChild(Child child)
Set the next Child

Specified by:
setNextChild in interface Child
Parameters:
child - the new 'next' child; may be null, which has the effect of saying there is no 'next' child

setPreviousChild

public void setPreviousChild(Child child)
Set the previous Child

Specified by:
setPreviousChild in interface Child
Parameters:
child - the new 'previous' child; may be null, which has the effect of saying there is no 'previous' child

getViewableArray

public java.lang.Object[] getViewableArray()
Get an array of objects, some of which may implement POIFSViewable

Specified by:
getViewableArray in interface POIFSViewable
Returns:
an array of Object; may not be null, but may be empty

getViewableIterator

public java.util.Iterator getViewableIterator()
Get an Iterator of objects, some of which may implement POIFSViewable

Specified by:
getViewableIterator in interface POIFSViewable
Returns:
an Iterator; may not be null, but may have an empty back end store

preferArray

public boolean preferArray()
Give viewers a hint as to whether to call getViewableArray or getViewableIterator

Specified by:
preferArray in interface POIFSViewable
Returns:
true if a viewer should call getViewableArray, false if a viewer should call getViewableIterator

getShortDescription

public java.lang.String getShortDescription()
Provides a short description of the object, to be used when a POIFSViewable object has not provided its contents.

Specified by:
getShortDescription in interface POIFSViewable
Returns:
short description
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyConstants

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Interface PropertyConstants

public interface PropertyConstants

Interface PropertyConstants

Field Summary
static byte | DIRECTORY_TYPE
static byte | DOCUMENT_TYPE
static int | PROPERTY_TYPE_OFFSET
static byte | ROOT_TYPE

Field Detail

PROPERTY_TYPE_OFFSET

static final int PROPERTY_TYPE_OFFSET
See Also:
Constant Field Values

DIRECTORY_TYPE

static final byte DIRECTORY_TYPE
See Also:
Constant Field Values

DOCUMENT_TYPE

static final byte DOCUMENT_TYPE
See Also:
Constant Field Values

ROOT_TYPE

static final byte ROOT_TYPE
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class PropertyTable

java.lang.Object
    extended by  org.apache.poi.poifs.property.PropertyTableBase
        extended by  org.apache.poi.poifs.property.PropertyTable
All Implemented Interfaces:
BATManaged, BlockWritable
public final class PropertyTable
extends PropertyTableBase
implements BlockWritable

This class embodies the Property Table for the POIFSFileSystem; this is basically the directory for all of the documents in the filesystem.

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
Fields inherited from class org.apache.poi.poifs.property.PropertyTableBase
_properties
Constructor Summary
PropertyTable(HeaderBlock headerBlock)
PropertyTable(HeaderBlock headerBlock, RawDataBlockList blockList)
reading constructor (used when we've read in a file and we want to extract the property table from it).
Method Summary
int | countBlocks() Return the number of BigBlock's this instance uses
void | preWrite() Prepare to be written
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class org.apache.poi.poifs.property.PropertyTableBase
addProperty, getRoot, getStartBlock, removeProperty, setStartBlock
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertyTable

public PropertyTable(HeaderBlock headerBlock)

PropertyTable

public PropertyTable(HeaderBlock headerBlock,
                     RawDataBlockList blockList)
              throws java.io.IOException
reading constructor (used when we've read in a file and we want to extract the property table from it). Populates the properties thoroughly

Parameters:
headerBlock - the header block of the file
blockList - the list of blocks
Throws:
java.io.IOException - if anything goes wrong (which should be a result of the input being NFG)
Method Detail

preWrite

public void preWrite()
Prepare to be written

countBlocks

public int countBlocks()
Return the number of BigBlock's this instance uses

Specified by:
countBlocks in interface BATManaged
Returns:
count of BigBlock instances

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyTableBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class PropertyTableBase

java.lang.Object
    extended by  org.apache.poi.poifs.property.PropertyTableBase
All Implemented Interfaces:
BATManaged
Direct Known Subclasses:
NPropertyTable, PropertyTable
public abstract class PropertyTableBase
extends java.lang.Object
implements BATManaged

This class embodies the Property Table for the filesystem, which looks up entries in the filesystem to their chain of blocks. This is the core support, there are implementations for the different block schemes as needed.

Field Summary
protected  java.util.List<Property> _properties
Constructor Summary
PropertyTableBase(HeaderBlock header_block)
PropertyTableBase(HeaderBlock header_block, java.util.List<Property> properties)
Reading constructor (used when we've read in a file and we want to extract the property table from it).
Method Summary
void | addProperty(Property property) Add a property to the list of properties we manage
RootProperty | getRoot() Get the root property
int | getStartBlock() Get the start block for the property table
void | removeProperty(Property property) Remove a property from the list of properties we manage
void | setStartBlock(int index) Set the start block for this instance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.poifs.filesystem.BATManaged
countBlocks

Field Detail

_properties

protected final java.util.List<Property> _properties
Constructor Detail

PropertyTableBase

public PropertyTableBase(HeaderBlock header_block)

PropertyTableBase

public PropertyTableBase(HeaderBlock header_block,
                         java.util.List<Property> properties)
                  throws java.io.IOException
Reading constructor (used when we've read in a file and we want to extract the property table from it). Populates the properties thoroughly

Parameters:
header_block - the first block to read from
properties - the list to populate
Throws:
java.io.IOException - if anything goes wrong (which should be a result of the input being NFG)
Method Detail

addProperty

public void addProperty(Property property)
Add a property to the list of properties we manage

Parameters:
property - the new Property to manage

removeProperty

public void removeProperty(Property property)
Remove a property from the list of properties we manage

Parameters:
property - the Property to be removed

getRoot

public RootProperty getRoot()
Get the root property

Returns:
the root property

getStartBlock

public int getStartBlock()
Get the start block for the property table

Returns:
start block index

setStartBlock

public void setStartBlock(int index)
Set the start block for this instance

Specified by:
setStartBlock in interface BATManaged
Parameters:
index - index into the array of BigBlock instances making up the the filesystem
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RootProperty

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.property
Class RootProperty

java.lang.Object
    extended by  org.apache.poi.poifs.property.Property
        extended by  org.apache.poi.poifs.property.DirectoryProperty
            extended by  org.apache.poi.poifs.property.RootProperty
All Implemented Interfaces:
POIFSViewable, Child, Parent
public final class RootProperty
extends DirectoryProperty

Root property

Author:
Marc Johnson (mjohnson at apache dot org)

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.poifs.property.DirectoryProperty
DirectoryProperty.PropertyComparator
Field Summary
Fields inherited from class org.apache.poi.poifs.property.Property
_NO_INDEX, _NODE_BLACK, _NODE_RED
Constructor Summary
protected RootProperty(int index, byte[] array, int offset)
reader constructor
Method Summary
java.lang.String | getName() Returns the fixed name "Root Entry", as the raw property doesn't have a real name set
void | setSize(int size) set size
Methods inherited from class org.apache.poi.poifs.property.DirectoryProperty
addChild, changeName, deleteChild, getChildren, isDirectory, preWrite
Methods inherited from class org.apache.poi.poifs.property.Property
getChildIndex, getIndex, getNextChild, getPreviousChild, getShortDescription, getSize, getStartBlock, getStorageClsid, getViewableArray, getViewableIterator, isSmall, preferArray, setChildProperty, setIndex, setName, setNextChild, setNodeColor, setPreviousChild, setPropertyType, setStartBlock, setStorageClsid, shouldUseSmallBlocks, writeData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.poifs.property.Parent
setNextChild, setPreviousChild
Methods inherited from interface org.apache.poi.poifs.property.Child
getNextChild, getPreviousChild

Constructor Detail

RootProperty

protected RootProperty(int index,
                       byte[] array,
                       int offset)
reader constructor

Parameters:
index - index number
array - byte data
offset - offset into byte data
Method Detail

setSize

public void setSize(int size)
set size

Overrides:
setSize in class Property
Parameters:
size - size in terms of small blocks

getName

public java.lang.String getName()
Returns the fixed name "Root Entry", as the raw property doesn't have a real name set

Overrides:
getName in class Property
Returns:
property name as String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface org.apache.poi.poifs.property.Child

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.property.Child

Packages that use Child
org.apache.poi.poifs.property property package contains high and low level Property structures for POIFS.

Uses of Child in org.apache.poi.poifs.property

Subinterfaces of Child in org.apache.poi.poifs.property
 interface Parent
Behavior for parent (directory) properties

Classes in org.apache.poi.poifs.property that implement Child
class | DirectoryProperty Directory property
class | DocumentProperty Trivial extension of Property for POIFSDocuments
class | Property This abstract base class is the ancestor of all classes implementing POIFS Property behavior.
class | RootProperty Root property

Methods in org.apache.poi.poifs.property that return Child
Child | Property.getNextChild() Get the next Child, if any
Child | Child.getNextChild() Get the next Child, if any
Child | Property.getPreviousChild() Get the previous Child, if any
Child | Child.getPreviousChild() Get the previous Child, if any

Methods in org.apache.poi.poifs.property with parameters of type Child
void | Property.setNextChild(Child child) Set the next Child
void | Parent.setNextChild(Child child) Set the next Child
void | Child.setNextChild(Child child) Set the next Child
void | Property.setPreviousChild(Child child) Set the previous Child
void | Parent.setPreviousChild(Child child) Set the previous Child
void | Child.setPreviousChild(Child child) Set the previous Child

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.DirectoryProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.DirectoryProperty

Packages that use DirectoryProperty
org.apache.poi.poifs.property property package contains high and low level Property structures for POIFS.

Uses of DirectoryProperty in org.apache.poi.poifs.property

Subclasses of DirectoryProperty in org.apache.poi.poifs.property
 class RootProperty
Root property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator

No usage of org.apache.poi.poifs.property.DirectoryProperty.PropertyComparator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.DocumentProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.DocumentProperty

Packages that use DocumentProperty
org.apache.poi.poifs.filesystem filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.

Uses of DocumentProperty in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type DocumentProperty
NPOIFSDocument(DocumentProperty property, NPOIFSFileSystem filesystem)
Constructor for an existing Document

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.NPropertyTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.NPropertyTable

No usage of org.apache.poi.poifs.property.NPropertyTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.property.Parent

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.property.Parent

Packages that use Parent
org.apache.poi.poifs.property property package contains high and low level Property structures for POIFS.

Uses of Parent in org.apache.poi.poifs.property

Classes in org.apache.poi.poifs.property that implement Parent
class | DirectoryProperty Directory property
class | RootProperty Root property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.Property

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.Property

Packages that use Property
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of Property in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return Property
protected  Property EntryNode.getProperty()
grant access to the property

Constructors in org.apache.poi.poifs.filesystem with parameters of type Property
EntryNode(Property property, DirectoryNode parent)
create a DocumentNode.

Uses of Property in org.apache.poi.poifs.property

Subclasses of Property in org.apache.poi.poifs.property
class | DirectoryProperty Directory property
class | DocumentProperty Trivial extension of Property for POIFSDocuments
class | RootProperty Root property

Fields in org.apache.poi.poifs.property with type parameters of type Property
protected  java.util.List<Property> PropertyTableBase._properties

Methods in org.apache.poi.poifs.property that return types with arguments of type Property
 java.util.Iterator<Property> DirectoryProperty.getChildren()
Get an iterator over the children of this Parent; all elements are instances of Property.

Methods in org.apache.poi.poifs.property with parameters of type Property
void | Parent.addChild(Property property) Add a new child to the collection of children
void | DirectoryProperty.addChild(Property property) Add a new child to the collection of children
void | PropertyTableBase.addProperty(Property property) Add a property to the list of properties we manage
boolean | DirectoryProperty.changeName(Property property, java.lang.String newName) Change a Property's name
int | DirectoryProperty.PropertyComparator.compare(Property o1, Property o2) compare method.
boolean | DirectoryProperty.deleteChild(Property property) Delete a Property
void | PropertyTableBase.removeProperty(Property property) Remove a property from the list of properties we manage

Constructor parameters in org.apache.poi.poifs.property with type arguments of type Property
PropertyTableBase(HeaderBlock header_block, java.util.List<Property> properties)
Reading constructor (used when we've read in a file and we want to extract the property table from it).

Uses of Property in org.apache.poi.poifs.storage

Method parameters in org.apache.poi.poifs.storage with type arguments of type Property
static BlockWritable[] PropertyBlock.createPropertyBlockArray(POIFSBigBlockSize bigBlockSize, java.util.List<Property> properties)
Create an array of PropertyBlocks from an array of Property instances, creating empty Property instances to make up any shortfall

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.property.PropertyConstants

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.property.PropertyConstants

No usage of org.apache.poi.poifs.property.PropertyConstants

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.PropertyTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.PropertyTable

No usage of org.apache.poi.poifs.property.PropertyTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.PropertyTableBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.PropertyTableBase

Packages that use PropertyTableBase
org.apache.poi.poifs.property property package contains high and low level Property structures for POIFS.

Uses of PropertyTableBase in org.apache.poi.poifs.property

Subclasses of PropertyTableBase in org.apache.poi.poifs.property
class | NPropertyTable This class embodies the Property Table for a NPOIFSFileSystem; this is basically the directory for all of the documents in the filesystem.
class | PropertyTable This class embodies the Property Table for the POIFSFileSystem; this is basically the directory for all of the documents in the filesystem.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.property.RootProperty

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.property.RootProperty

Packages that use RootProperty
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of RootProperty in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type RootProperty
NPOIFSMiniStore(NPOIFSFileSystem filesystem, RootProperty root, java.util.List<BATBlock> sbats, HeaderBlock header)

Uses of RootProperty in org.apache.poi.poifs.property

Methods in org.apache.poi.poifs.property that return RootProperty
 RootProperty PropertyTableBase.getRoot()
Get the root property

Uses of RootProperty in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage with parameters of type RootProperty
static BlockList SmallBlockTableReader.getSmallDocumentBlocks(POIFSBigBlockSize bigBlockSize, RawDataBlockList blockList, RootProperty root, int sbatStart)
fetch the small document block list from an existing file

Constructors in org.apache.poi.poifs.storage with parameters of type RootProperty
SmallBlockTableWriter(POIFSBigBlockSize bigBlockSize, java.util.List documents, RootProperty root)
Creates new SmallBlockTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BATBlock.BATBlockAndIndex

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class BATBlock.BATBlockAndIndex

java.lang.Object
    extended by  org.apache.poi.poifs.storage.BATBlock.BATBlockAndIndex
Enclosing class:
BATBlock
public static class BATBlock.BATBlockAndIndex
extends java.lang.Object

Method Summary
BATBlock | getBlock()
int | getIndex()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getIndex

public int getIndex()

getBlock

public BATBlock getBlock()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BATBlock

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class BATBlock

java.lang.Object
    extended by  org.apache.poi.poifs.storage.BATBlock
All Implemented Interfaces:
BlockWritable
public final class BATBlock
extends java.lang.Object

A block of block allocation table entries. BATBlocks are created only through a static factory method: createBATBlocks.

Author:
Marc Johnson (mjohnson at apache dot org)

Nested Class Summary
static class BATBlock.BATBlockAndIndex
Field Summary
protected  POIFSBigBlockSize bigBlockSize
Either 512 bytes (POIFSConstants.SMALLER_BIG_BLOCK_SIZE) or 4096 bytes (POIFSConstants.LARGER_BIG_BLOCK_SIZE)
Method Summary
static int | calculateMaximumSize(HeaderBlock header)
static int | calculateMaximumSize(POIFSBigBlockSize bigBlockSize, int numBATs) Calculates the maximum size of a file which is addressable given the number of FAT (BAT) sectors specified.
static int | calculateStorageRequirements(POIFSBigBlockSize bigBlockSize, int entryCount) Calculate how many BATBlocks are needed to hold a specified number of BAT entries.
static int | calculateXBATStorageRequirements(POIFSBigBlockSize bigBlockSize, int entryCount) Calculate how many XBATBlocks are needed to hold a specified number of BAT entries.
static BATBlock | createBATBlock(POIFSBigBlockSize bigBlockSize, java.nio.ByteBuffer data) Create a single BATBlock from the byte buffer, which must hold at least one big block of data to be read.
static BATBlock[] | createBATBlocks(POIFSBigBlockSize bigBlockSize, int[] entries) Create an array of BATBlocks from an array of int block allocation table entries
static BATBlock | createEmptyBATBlock(POIFSBigBlockSize bigBlockSize, boolean isXBAT) Creates a single BATBlock, with all the values set to empty.
static BATBlock[] | createXBATBlocks(POIFSBigBlockSize bigBlockSize, int[] entries, int startBlock) Create an array of XBATBlocks from an array of int block allocation table entries
protected void | doWriteData(java.io.OutputStream stream, byte[] data) Default implementation of write for extending classes that contain their data in a simple array of bytes.
static BATBlock.BATBlockAndIndex | getBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> bats) Returns the BATBlock that handles the specified offset, and the relative index within it.
int | getOurBlockIndex() Retrieve where in the file we live
static BATBlock.BATBlockAndIndex | getSBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> sbats) Returns the BATBlock that handles the specified offset, and the relative index within it, for the mini stream.
int | getValueAt(int relativeOffset)
boolean | hasFreeSectors() Does this BATBlock have any free sectors in it, or is it full?
void | setOurBlockIndex(int index) Record where in the file we live
void | setValueAt(int relativeOffset, int value)
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

bigBlockSize

protected POIFSBigBlockSize bigBlockSize
Either 512 bytes (POIFSConstants.SMALLER_BIG_BLOCK_SIZE) or 4096 bytes (POIFSConstants.LARGER_BIG_BLOCK_SIZE)

Method Detail

createBATBlock

public static BATBlock createBATBlock(POIFSBigBlockSize bigBlockSize,
                                      java.nio.ByteBuffer data)
Create a single BATBlock from the byte buffer, which must hold at least one big block of data to be read.

createEmptyBATBlock

public static BATBlock createEmptyBATBlock(POIFSBigBlockSize bigBlockSize,
                                           boolean isXBAT)
Creates a single BATBlock, with all the values set to empty.

createBATBlocks

public static BATBlock[] createBATBlocks(POIFSBigBlockSize bigBlockSize,
                                         int[] entries)
Create an array of BATBlocks from an array of int block allocation table entries

Parameters:
entries - the array of int entries
Returns:
the newly created array of BATBlocks

createXBATBlocks

public static BATBlock[] createXBATBlocks(POIFSBigBlockSize bigBlockSize,
                                          int[] entries,
                                          int startBlock)
Create an array of XBATBlocks from an array of int block allocation table entries

Parameters:
entries - the array of int entries
startBlock - the start block of the array of XBAT blocks
Returns:
the newly created array of BATBlocks

calculateStorageRequirements

public static int calculateStorageRequirements(POIFSBigBlockSize bigBlockSize,
                                               int entryCount)
Calculate how many BATBlocks are needed to hold a specified number of BAT entries.

Parameters:
entryCount - the number of entries
Returns:
the number of BATBlocks needed

calculateXBATStorageRequirements

public static int calculateXBATStorageRequirements(POIFSBigBlockSize bigBlockSize,
                                                   int entryCount)
Calculate how many XBATBlocks are needed to hold a specified number of BAT entries.

Parameters:
entryCount - the number of entries
Returns:
the number of XBATBlocks needed

calculateMaximumSize

public static int calculateMaximumSize(POIFSBigBlockSize bigBlockSize,
                                       int numBATs)
Calculates the maximum size of a file which is addressable given the number of FAT (BAT) sectors specified. (We don't care if those BAT blocks come from the 109 in the header, or from header + XBATS, it won't affect the calculation) The actual file size will be between [size of fatCount-1 blocks] and [size of fatCount blocks]. For 512 byte block sizes, this means we may over-estimate by up to 65kb. For 4096 byte block sizes, this means we may over-estimate by up to 4mb

calculateMaximumSize

public static int calculateMaximumSize(HeaderBlock header)

getBATBlockAndIndex

public static BATBlock.BATBlockAndIndex getBATBlockAndIndex(int offset,
                                                            HeaderBlock header,
                                                            java.util.List<BATBlock> bats)
Returns the BATBlock that handles the specified offset, and the relative index within it. The List of BATBlocks must be in sequential order

getSBATBlockAndIndex

public static BATBlock.BATBlockAndIndex getSBATBlockAndIndex(int offset,
                                                             HeaderBlock header,
                                                             java.util.List<BATBlock> sbats)
Returns the BATBlock that handles the specified offset, and the relative index within it, for the mini stream. The List of BATBlocks must be in sequential order

hasFreeSectors

public boolean hasFreeSectors()
Does this BATBlock have any free sectors in it, or is it full?

getValueAt

public int getValueAt(int relativeOffset)

setValueAt

public void setValueAt(int relativeOffset,
                       int value)

setOurBlockIndex

public void setOurBlockIndex(int index)
Record where in the file we live

getOurBlockIndex

public int getOurBlockIndex()
Retrieve where in the file we live

doWriteData

protected void doWriteData(java.io.OutputStream stream,
                           byte[] data)
                    throws java.io.IOException
Default implementation of write for extending classes that contain their data in a simple array of bytes.

Parameters:
stream - the OutputStream to which the data should be written.
data - the byte array of to be written.
Throws:
java.io.IOException - on problems writing to the specified stream.

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BlockAllocationTableReader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class BlockAllocationTableReader

java.lang.Object
    extended by  org.apache.poi.poifs.storage.BlockAllocationTableReader

public final class BlockAllocationTableReader
extends java.lang.Object

This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.

Each block of the filesystem has an index. The first block, the header, is skipped; the first block after the header is index 0, the next is index 1, and so on.

A block's index is also its index into the Block Allocation Table. The entry that it finds in the Block Allocation Table is the index of the next block in the linked list of blocks making up a file, or it is set to -2: end of list.

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
BlockAllocationTableReader(POIFSBigBlockSize bigBlockSize, int block_count, int[] block_array, int xbat_count, int xbat_index, BlockList raw_block_list)
create a BlockAllocationTableReader for an existing filesystem.
Method Summary
static void sanityCheckBlockCount(int block_count)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BlockAllocationTableReader

public BlockAllocationTableReader(POIFSBigBlockSize bigBlockSize,
                                  int block_count,
                                  int[] block_array,
                                  int xbat_count,
                                  int xbat_index,
                                  BlockList raw_block_list)
                           throws java.io.IOException
create a BlockAllocationTableReader for an existing filesystem. Side effect: when this method finishes, the BAT blocks will have been removed from the raw block list, and any blocks labeled as 'unused' in the block allocation table will also have been removed from the raw block list.

Parameters:
block_count - the number of BAT blocks making up the block allocation table
block_array - the array of BAT block indices from the filesystem's header
xbat_count - the number of XBAT blocks
xbat_index - the index of the first XBAT block
raw_block_list - the list of RawDataBlocks
Throws:
java.io.IOException - if, in trying to create the table, we encounter logic errors
Method Detail

sanityCheckBlockCount

public static void sanityCheckBlockCount(int block_count)
                                  throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlockAllocationTableWriter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class BlockAllocationTableWriter

java.lang.Object
    extended by  org.apache.poi.poifs.storage.BlockAllocationTableWriter
All Implemented Interfaces:
BATManaged, BlockWritable
public final class BlockAllocationTableWriter
extends java.lang.Object
implements BlockWritable, BATManaged

This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.

Each block of the filesystem has an index. The first block, the header, is skipped; the first block after the header is index 0, the next is index 1, and so on.

A block's index is also its index into the Block Allocation Table. The entry that it finds in the Block Allocation Table is the index of the next block in the linked list of blocks making up a file, or it is set to -2: end of list.

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
BlockAllocationTableWriter(POIFSBigBlockSize bigBlockSize)
create a BlockAllocationTableWriter
Method Summary
int | allocateSpace(int blockCount) Allocate space for a block of indices
int | countBlocks() Return the number of BigBlock's this instance uses
int | createBlocks() Create the BATBlocks we need
int | getStartBlock() get the starting block
void | setStartBlock(int start_block) Set the start block for this instance
static void | writeBlock(BATBlock bat, java.nio.ByteBuffer block) Write the BAT into its associated block
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BlockAllocationTableWriter

public BlockAllocationTableWriter(POIFSBigBlockSize bigBlockSize)
create a BlockAllocationTableWriter

Method Detail

createBlocks

public int createBlocks()
Create the BATBlocks we need

Returns:
start block index of BAT blocks

allocateSpace

public int allocateSpace(int blockCount)
Allocate space for a block of indices

Parameters:
blockCount - the number of blocks to allocate space for
Returns:
the starting index of the blocks

getStartBlock

public int getStartBlock()
get the starting block

Returns:
the starting block index

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream

writeBlock

public static void writeBlock(BATBlock bat,
                              java.nio.ByteBuffer block)
                       throws java.io.IOException
Write the BAT into its associated block

Throws:
java.io.IOException

countBlocks

public int countBlocks()
Return the number of BigBlock's this instance uses

Specified by:
countBlocks in interface BATManaged
Returns:
count of BigBlock instances

setStartBlock

public void setStartBlock(int start_block)
Set the start block for this instance

Specified by:
setStartBlock in interface BATManaged
Parameters:
start_block - index into the array of BigBlock instances making up the the filesystem
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlockList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Interface BlockList

All Known Implementing Classes:
RawDataBlockList, SmallDocumentBlockList
public interface BlockList

Interface for lists of blocks that are mapped by block allocation tables

Author:
Marc Johnson (mjohnson at apache dot org

Method Summary
int | blockCount()
ListManagedBlock[] | fetchBlocks(int startBlock, int headerPropertiesStartBlock) get the blocks making up a particular stream in the list.
ListManagedBlock | remove(int index) remove and return the specified block from the list
void | setBAT(BlockAllocationTableReader bat) set the associated BlockAllocationTable
void | zap(int index) remove the specified block from the list

Method Detail

zap

void zap(int index)
remove the specified block from the list

Parameters:
index - the index of the specified block; if the index is out of range, that's ok

remove

ListManagedBlock remove(int index)
                        throws java.io.IOException
remove and return the specified block from the list

Parameters:
index - the index of the specified block
Returns:
the specified block
Throws:
java.io.IOException - if the index is out of range or has already been removed

fetchBlocks

ListManagedBlock[] fetchBlocks(int startBlock,
                               int headerPropertiesStartBlock)
                               throws java.io.IOException
get the blocks making up a particular stream in the list. The blocks are removed from the list.

Parameters:
startBlock - the index of the first block in the stream
headerPropertiesStartBlock - the index of the first header block in the stream
Returns:
the stream as an array of correctly ordered blocks
Throws:
java.io.IOException - if blocks are missing

setBAT

void setBAT(BlockAllocationTableReader bat)
            throws java.io.IOException
set the associated BlockAllocationTable

Parameters:
bat - the associated BlockAllocationTable
Throws:
java.io.IOException

blockCount

int blockCount()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlockWritable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Interface BlockWritable

All Known Implementing Classes:
BATBlock, BlockAllocationTableWriter, DocumentBlock, HeaderBlockWriter, POIFSDocument, PropertyBlock, PropertyTable, SmallBlockTableWriter, SmallDocumentBlock
public interface BlockWritable

An interface for persisting block storage of POIFS components.

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
 void writeBlocks(java.io.OutputStream stream)
Write the storage to an OutputStream

Method Detail

writeBlocks

void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataInputBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class DataInputBlock

java.lang.Object
    extended by  org.apache.poi.poifs.storage.DataInputBlock

public final class DataInputBlock
extends java.lang.Object

Wraps a byte array and provides simple data input access. Internally, this class maintains a buffer read index, so that for the most part, primitive data can be read in a data-input-stream-like manner.

Note - the calling class should call the available() method to detect end-of-buffer and move to the next data block when the current is exhausted. For optimisation reasons, no error handling is performed in this class. Thus, mistakes in calling code ran may raise ugly exceptions here, like ArrayIndexOutOfBoundsException, etc .

The multi-byte primitive input methods (readUShortLE(), readIntLE() and readLongLE()) have corresponding 'spanning read' methods which (when required) perform a read across the block boundary. These spanning read methods take the previous DataInputBlock as a parameter. Reads of larger amounts of data (into byte array buffers) must be managed by the caller since these could conceivably involve more than two blocks.

Author:
Josh Micich

Method Summary
int | available()
void | readFully(byte[] buf, int off, int len) Reads len bytes from this block into the supplied buffer.
int | readIntLE() Reads an int which was encoded in little endian format.
int | readIntLE(DataInputBlock prevBlock, int prevBlockAvailable) Reads an int which spans the end of prevBlock and the start of this block.
long | readLongLE() Reads a long which was encoded in little endian format.
long | readLongLE(DataInputBlock prevBlock, int prevBlockAvailable) Reads a long which spans the end of prevBlock and the start of this block.
int | readUByte()
int | readUShortLE() Reads a short which was encoded in little endian format.
int | readUShortLE(DataInputBlock prevBlock) Reads a short which spans the end of prevBlock and the start of this block.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

available

public int available()

readUByte

public int readUByte()

readUShortLE

public int readUShortLE()
Reads a short which was encoded in little endian format.

readUShortLE

public int readUShortLE(DataInputBlock prevBlock)
Reads a short which spans the end of prevBlock and the start of this block.

readIntLE

public int readIntLE()
Reads an int which was encoded in little endian format.

readIntLE

public int readIntLE(DataInputBlock prevBlock,
                     int prevBlockAvailable)
Reads an int which spans the end of prevBlock and the start of this block.

readLongLE

public long readLongLE()
Reads a long which was encoded in little endian format.

readLongLE

public long readLongLE(DataInputBlock prevBlock,
                       int prevBlockAvailable)
Reads a long which spans the end of prevBlock and the start of this block.

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Reads len bytes from this block into the supplied buffer.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class DocumentBlock

java.lang.Object
    extended by  org.apache.poi.poifs.storage.DocumentBlock
All Implemented Interfaces:
BlockWritable
public final class DocumentBlock
extends java.lang.Object

A block of document data.

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
protected  POIFSBigBlockSize bigBlockSize
Either 512 bytes (POIFSConstants.SMALLER_BIG_BLOCK_SIZE) or 4096 bytes (POIFSConstants.LARGER_BIG_BLOCK_SIZE)
Constructor Summary
DocumentBlock(java.io.InputStream stream, POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with data.
DocumentBlock(RawDataBlock block)
create a document block from a raw data block
Method Summary
static DocumentBlock[] | convert(POIFSBigBlockSize bigBlockSize, byte[] array, int size) convert a single long array into an array of DocumentBlock instances
protected void | doWriteData(java.io.OutputStream stream, byte[] data) Default implementation of write for extending classes that contain their data in a simple array of bytes.
static DataInputBlock | getDataInputBlock(DocumentBlock[] blocks, int offset)
static byte | getFillByte()
boolean | partiallyRead() Was this a partially read block?
int | size() Get the number of bytes read for this block
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

bigBlockSize

protected POIFSBigBlockSize bigBlockSize
Either 512 bytes (POIFSConstants.SMALLER_BIG_BLOCK_SIZE) or 4096 bytes (POIFSConstants.LARGER_BIG_BLOCK_SIZE)

Constructor Detail

DocumentBlock

public DocumentBlock(RawDataBlock block)
              throws java.io.IOException
create a document block from a raw data block

Parameters:
block - the raw data block
Throws:
java.io.IOException

DocumentBlock

public DocumentBlock(java.io.InputStream stream,
                     POIFSBigBlockSize bigBlockSize)
              throws java.io.IOException
Create a single instance initialized with data.

Parameters:
stream - the InputStream delivering the data.
Throws:
java.io.IOException
Method Detail

size

public int size()
Get the number of bytes read for this block

Returns:
bytes read into the block

partiallyRead

public boolean partiallyRead()
Was this a partially read block?

Returns:
true if the block was only partially filled with data

getFillByte

public static byte getFillByte()
Returns:
the fill byte used

convert

public static DocumentBlock[] convert(POIFSBigBlockSize bigBlockSize,
                                      byte[] array,
                                      int size)
convert a single long array into an array of DocumentBlock instances

Parameters:
array - the byte array to be converted
size - the intended size of the array (which may be smaller)
Returns:
an array of DocumentBlock instances, filled from the input array

getDataInputBlock

public static DataInputBlock getDataInputBlock(DocumentBlock[] blocks,
                                               int offset)

doWriteData

protected void doWriteData(java.io.OutputStream stream,
                           byte[] data)
                    throws java.io.IOException
Default implementation of write for extending classes that contain their data in a simple array of bytes.

Parameters:
stream - the OutputStream to which the data should be written.
data - the byte array of to be written.
Throws:
java.io.IOException - on problems writing to the specified stream.

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class HeaderBlock

java.lang.Object
    extended by  org.apache.poi.poifs.storage.HeaderBlock
All Implemented Interfaces:
HeaderBlockConstants
public final class HeaderBlock
extends java.lang.Object
implements HeaderBlockConstants

The block containing the archive header

Field Summary
Fields inherited from interface org.apache.poi.poifs.storage.HeaderBlockConstants
_bat_array_offset, _bat_count_offset, _max_bats_in_header, _property_start_offset, _sbat_block_count_offset, _sbat_start_offset, _signature, _signature_offset, _xbat_count_offset, _xbat_start_offset
Constructor Summary
HeaderBlock(java.nio.ByteBuffer buffer)
HeaderBlock(java.io.InputStream stream)
create a new HeaderBlockReader from an InputStream
HeaderBlock(POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with default values
Method Summary
int[] | getBATArray() Returns the offsets to the first (up to) 109 BAT sectors.
int | getBATCount()
POIFSBigBlockSize | getBigBlockSize()
int | getPropertyStart() get start of Property Table
int | getSBATCount()
int | getSBATStart()
int | getXBATCount()
int | getXBATIndex()
void | setBATArray(int[] bat_array) Sets the offsets of the first (up to) 109 BAT sectors.
void | setBATCount(int count) Sets the number of BAT blocks that are used.
void | setPropertyStart(int startBlock) Set start of Property Table
void | setSBATBlockCount(int count) Set count of SBAT blocks
void | setSBATStart(int startBlock) Set start of small block allocation table
void | setXBATCount(int count) Sets the number of XBAT (DIFAT) blocks used
void | setXBATStart(int startBlock) Sets the first XBAT (DIFAT) block location
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HeaderBlock

public HeaderBlock(java.io.InputStream stream)
            throws java.io.IOException
create a new HeaderBlockReader from an InputStream

Parameters:
stream - the source InputStream
Throws:
java.io.IOException - on errors or bad data

HeaderBlock

public HeaderBlock(java.nio.ByteBuffer buffer)
            throws java.io.IOException
Throws:
java.io.IOException

HeaderBlock

public HeaderBlock(POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with default values

Method Detail

getPropertyStart

public int getPropertyStart()
get start of Property Table

Returns:
the index of the first block of the Property Table

setPropertyStart

public void setPropertyStart(int startBlock)
Set start of Property Table

Parameters:
startBlock - the index of the first block of the Property Table

getSBATStart

public int getSBATStart()
Returns:
start of small block (MiniFAT) allocation table

getSBATCount

public int getSBATCount()

setSBATStart

public void setSBATStart(int startBlock)
Set start of small block allocation table

Parameters:
startBlock - the index of the first big block of the small block allocation table

setSBATBlockCount

public void setSBATBlockCount(int count)
Set count of SBAT blocks

Parameters:
count - the number of SBAT blocks

getBATCount

public int getBATCount()
Returns:
number of BAT blocks

setBATCount

public void setBATCount(int count)
Sets the number of BAT blocks that are used. This is the number used in both the BAT and XBAT.

getBATArray

public int[] getBATArray()
Returns the offsets to the first (up to) 109 BAT sectors. Any additional BAT sectors are held in the XBAT (DIFAT) sectors in a chain.

Returns:
BAT offset array

setBATArray

public void setBATArray(int[] bat_array)
Sets the offsets of the first (up to) 109 BAT sectors.

getXBATCount

public int getXBATCount()
Returns:
XBAT (DIFAT) count

setXBATCount

public void setXBATCount(int count)
Sets the number of XBAT (DIFAT) blocks used

getXBATIndex

public int getXBATIndex()
Returns:
XBAT (DIFAT) index

setXBATStart

public void setXBATStart(int startBlock)
Sets the first XBAT (DIFAT) block location

getBigBlockSize

public POIFSBigBlockSize getBigBlockSize()
Returns:
The Big Block size, normally 512 bytes, sometimes 4096 bytes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderBlockConstants

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Interface HeaderBlockConstants

All Known Implementing Classes:
HeaderBlock, HeaderBlockWriter
public interface HeaderBlockConstants

Constants used in reading/writing the Header block

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
static int | _bat_array_offset
static int | _bat_count_offset
static int | _max_bats_in_header
static int | _property_start_offset
static int | _sbat_block_count_offset
static int | _sbat_start_offset
static long | _signature
static int | _signature_offset
static int | _xbat_count_offset
static int | _xbat_start_offset

Field Detail

_signature

static final long _signature
See Also:
Constant Field Values

_bat_array_offset

static final int _bat_array_offset
See Also:
Constant Field Values

_max_bats_in_header

static final int _max_bats_in_header
See Also:
Constant Field Values

_signature_offset

static final int _signature_offset
See Also:
Constant Field Values

_bat_count_offset

static final int _bat_count_offset
See Also:
Constant Field Values

_property_start_offset

static final int _property_start_offset
See Also:
Constant Field Values

_sbat_start_offset

static final int _sbat_start_offset
See Also:
Constant Field Values

_sbat_block_count_offset

static final int _sbat_block_count_offset
See Also:
Constant Field Values

_xbat_start_offset

static final int _xbat_start_offset
See Also:
Constant Field Values

_xbat_count_offset

static final int _xbat_count_offset
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderBlockWriter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class HeaderBlockWriter

java.lang.Object
    extended by  org.apache.poi.poifs.storage.HeaderBlockWriter
All Implemented Interfaces:
BlockWritable, HeaderBlockConstants
public class HeaderBlockWriter
extends java.lang.Object
implements HeaderBlockConstants, BlockWritable

The block containing the archive header

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
Fields inherited from interface org.apache.poi.poifs.storage.HeaderBlockConstants
_bat_array_offset, _bat_count_offset, _max_bats_in_header, _property_start_offset, _sbat_block_count_offset, _sbat_start_offset, _signature, _signature_offset, _xbat_count_offset, _xbat_start_offset
Constructor Summary
HeaderBlockWriter(HeaderBlock headerBlock)
Create a single instance initialized with the specified existing values
HeaderBlockWriter(POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with default values
Method Summary
BATBlock[] | setBATBlocks(int blockCount, int startBlock) Set BAT block parameters.
void | setPropertyStart(int startBlock) Set start of Property Table
void | setSBATBlockCount(int count) Set count of SBAT blocks
void | setSBATStart(int startBlock) Set start of small block allocation table
void | writeBlock(java.nio.ByteBuffer block) Write the block's data to an existing block
void | writeBlocks(java.io.OutputStream stream) Write the block's data to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HeaderBlockWriter

public HeaderBlockWriter(POIFSBigBlockSize bigBlockSize)
Create a single instance initialized with default values

HeaderBlockWriter

public HeaderBlockWriter(HeaderBlock headerBlock)
Create a single instance initialized with the specified existing values

Method Detail

setBATBlocks

public BATBlock[] setBATBlocks(int blockCount,
                               int startBlock)
Set BAT block parameters. Assumes that all BAT blocks are contiguous. Will construct XBAT blocks if necessary and return the array of newly constructed XBAT blocks.

Parameters:
blockCount - count of BAT blocks
startBlock - index of first BAT block
Returns:
array of XBAT blocks; may be zero length, will not be null

setPropertyStart

public void setPropertyStart(int startBlock)
Set start of Property Table

Parameters:
startBlock - the index of the first block of the Property Table

setSBATStart

public void setSBATStart(int startBlock)
Set start of small block allocation table

Parameters:
startBlock - the index of the first big block of the small block allocation table

setSBATBlockCount

public void setSBATBlockCount(int count)
Set count of SBAT blocks

Parameters:
count - the number of SBAT blocks

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the block's data to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream

writeBlock

public void writeBlock(java.nio.ByteBuffer block)
                throws java.io.IOException
Write the block's data to an existing block

Parameters:
block - the ByteBuffer of the block to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the block
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListManagedBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Interface ListManagedBlock

All Known Implementing Classes:
RawDataBlock, SmallDocumentBlock
public interface ListManagedBlock

An interface for blocks managed by a list that works with a BlockAllocationTable to keep block sequences straight

Author:
Marc Johnson (mjohnson at apache dot org

Method Summary
 byte[] getData()
Get the data from the block

Method Detail

getData

byte[] getData()
               throws java.io.IOException
Get the data from the block

Returns:
the block's data as a byte array
Throws:
java.io.IOException - if there is no data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.poifs.storage
Interfaces
BlockList
BlockWritable
HeaderBlockConstants
ListManagedBlock
Classes
BATBlock
BATBlock.BATBlockAndIndex
BlockAllocationTableReader
BlockAllocationTableWriter
DataInputBlock
DocumentBlock
HeaderBlock
HeaderBlockWriter
PropertyBlock
RawDataBlock
RawDataBlockList
SmallBlockTableReader
SmallBlockTableWriter
SmallDocumentBlock
SmallDocumentBlockList


org.apache.poi.poifs.storage

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.poifs.storage

storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

See:
Description

Interface Summary
BlockList | Interface for lists of blocks that are mapped by block allocation tables
BlockWritable | An interface for persisting block storage of POIFS components.
HeaderBlockConstants | Constants used in reading/writing the Header block
ListManagedBlock | An interface for blocks managed by a list that works with a BlockAllocationTable to keep block sequences straight

Class Summary
BATBlock | A block of block allocation table entries.
BATBlock.BATBlockAndIndex |
BlockAllocationTableReader | This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
BlockAllocationTableWriter | This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
DataInputBlock | Wraps a byte array and provides simple data input access.
DocumentBlock | A block of document data.
HeaderBlock | The block containing the archive header
HeaderBlockWriter | The block containing the archive header
PropertyBlock | A block of Property instances
RawDataBlock | A big block created from an InputStream, holding the raw data
RawDataBlockList | A list of RawDataBlocks instances, and methods to manage the list
SmallBlockTableReader | This class implements reading the small document block list from an existing file
SmallBlockTableWriter | This class implements storage for writing the small blocks used by small documents.
SmallDocumentBlock | Storage for documents that are too small to use regular DocumentBlocks for their data
SmallDocumentBlockList | A list of SmallDocumentBlocks instances, and methods to manage the list

Package org.apache.poi.poifs.storage Description

storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.poifs.storage Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.poifs.storage

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.poifs.storage.BATBlock
    • org.apache.poi.poifs.storage.BATBlock.BATBlockAndIndex
    • org.apache.poi.poifs.storage.BlockAllocationTableReader
    • org.apache.poi.poifs.storage.BlockAllocationTableWriter (implements org.apache.poi.poifs.filesystem.BATManaged, org.apache.poi.poifs.storage.BlockWritable)
    • org.apache.poi.poifs.storage.DataInputBlock
    • org.apache.poi.poifs.storage.DocumentBlock
    • org.apache.poi.poifs.storage.HeaderBlock (implements org.apache.poi.poifs.storage.HeaderBlockConstants)
    • org.apache.poi.poifs.storage.HeaderBlockWriter (implements org.apache.poi.poifs.storage.BlockWritable, org.apache.poi.poifs.storage.HeaderBlockConstants)
    • org.apache.poi.poifs.storage.PropertyBlock
    • org.apache.poi.poifs.storage.RawDataBlock (implements org.apache.poi.poifs.storage.ListManagedBlock)
    • org.apache.poi.poifs.storage.RawDataBlockList
    • org.apache.poi.poifs.storage.SmallBlockTableReader
    • org.apache.poi.poifs.storage.SmallBlockTableWriter (implements org.apache.poi.poifs.filesystem.BATManaged, org.apache.poi.poifs.storage.BlockWritable)
    • org.apache.poi.poifs.storage.SmallDocumentBlock (implements org.apache.poi.poifs.storage.BlockWritable, org.apache.poi.poifs.storage.ListManagedBlock)
    • org.apache.poi.poifs.storage.SmallDocumentBlockList

Interface Hierarchy

  • org.apache.poi.poifs.storage.BlockList
  • org.apache.poi.poifs.storage.BlockWritable
  • org.apache.poi.poifs.storage.HeaderBlockConstants
  • org.apache.poi.poifs.storage.ListManagedBlock


Uses of Package org.apache.poi.poifs.storage

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.poifs.storage

Packages that use org.apache.poi.poifs.storage
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Classes in org.apache.poi.poifs.storage used by org.apache.poi.poifs.dev
BlockAllocationTableReader
This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
HeaderBlock
The block containing the archive header
RawDataBlockList
A list of RawDataBlocks instances, and methods to manage the list

Classes in org.apache.poi.poifs.storage used by org.apache.poi.poifs.filesystem
BATBlock
A block of block allocation table entries.
BATBlock.BATBlockAndIndex
BlockWritable
An interface for persisting block storage of POIFS components.
HeaderBlock
The block containing the archive header
ListManagedBlock
An interface for blocks managed by a list that works with a BlockAllocationTable to keep block sequences straight
RawDataBlock
A big block created from an InputStream, holding the raw data
SmallDocumentBlock
Storage for documents that are too small to use regular DocumentBlocks for their data

Classes in org.apache.poi.poifs.storage used by org.apache.poi.poifs.property
BlockWritable
An interface for persisting block storage of POIFS components.
HeaderBlock
The block containing the archive header
RawDataBlockList
A list of RawDataBlocks instances, and methods to manage the list

Classes in org.apache.poi.poifs.storage used by org.apache.poi.poifs.storage
BATBlock
A block of block allocation table entries.
BATBlock.BATBlockAndIndex
BlockAllocationTableReader
This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
BlockAllocationTableWriter
This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
BlockList
Interface for lists of blocks that are mapped by block allocation tables
BlockWritable
An interface for persisting block storage of POIFS components.
DataInputBlock
Wraps a byte array and provides simple data input access.
DocumentBlock
A block of document data.
HeaderBlock
The block containing the archive header
HeaderBlockConstants
Constants used in reading/writing the Header block
ListManagedBlock
An interface for blocks managed by a list that works with a BlockAllocationTable to keep block sequences straight
RawDataBlock
A big block created from an InputStream, holding the raw data
RawDataBlockList
A list of RawDataBlocks instances, and methods to manage the list
SmallDocumentBlock
Storage for documents that are too small to use regular DocumentBlocks for their data

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PropertyBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class PropertyBlock

java.lang.Object
    extended by  org.apache.poi.poifs.storage.PropertyBlock
All Implemented Interfaces:
BlockWritable
public final class PropertyBlock
extends java.lang.Object

A block of Property instances

Author:
Marc Johnson (mjohnson at apache dot org)

Field Summary
protected  POIFSBigBlockSize bigBlockSize
Either 512 bytes (POIFSConstants.SMALLER_BIG_BLOCK_SIZE) or 4096 bytes (POIFSConstants.LARGER_BIG_BLOCK_SIZE)
Method Summary
static BlockWritable[] | createPropertyBlockArray(POIFSBigBlockSize bigBlockSize, java.util.List<Property> properties) Create an array of PropertyBlocks from an array of Property instances, creating empty Property instances to make up any shortfall
protected void | doWriteData(java.io.OutputStream stream, byte[] data) Default implementation of write for extending classes that contain their data in a simple array of bytes.
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

bigBlockSize

protected POIFSBigBlockSize bigBlockSize
Either 512 bytes (POIFSConstants.SMALLER_BIG_BLOCK_SIZE) or 4096 bytes (POIFSConstants.LARGER_BIG_BLOCK_SIZE)

Method Detail

createPropertyBlockArray

public static BlockWritable[] createPropertyBlockArray(POIFSBigBlockSize bigBlockSize,
                                                       java.util.List<Property> properties)
Create an array of PropertyBlocks from an array of Property instances, creating empty Property instances to make up any shortfall

Parameters:
properties - the Property instances to be converted into PropertyBlocks, in a java List
Returns:
the array of newly created PropertyBlock instances

doWriteData

protected void doWriteData(java.io.OutputStream stream,
                           byte[] data)
                    throws java.io.IOException
Default implementation of write for extending classes that contain their data in a simple array of bytes.

Parameters:
stream - the OutputStream to which the data should be written.
data - the byte array of to be written.
Throws:
java.io.IOException - on problems writing to the specified stream.

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RawDataBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class RawDataBlock

java.lang.Object
    extended by  org.apache.poi.poifs.storage.RawDataBlock
All Implemented Interfaces:
ListManagedBlock
public class RawDataBlock
extends java.lang.Object
implements ListManagedBlock

A big block created from an InputStream, holding the raw data

Author:
Marc Johnson (mjohnson at apache dot org

Constructor Summary
RawDataBlock(java.io.InputStream stream)
Constructor RawDataBlock
RawDataBlock(java.io.InputStream stream, int blockSize)
Constructor RawDataBlock
Method Summary
boolean | eof() When we read the data, did we hit end of file?
int | getBigBlockSize() What's the big block size?
byte[] | getData() Get the data from the block
boolean | hasData() Did we actually find any data to read? It's possible, in the event of a short last block, to both have hit the EoF, but also to have data
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RawDataBlock

public RawDataBlock(java.io.InputStream stream)
             throws java.io.IOException
Constructor RawDataBlock

Parameters:
stream - the InputStream from which the data will be read
Throws:
java.io.IOException - on I/O errors, and if an insufficient amount of data is read (the InputStream must be an exact multiple of the block size)

RawDataBlock

public RawDataBlock(java.io.InputStream stream,
                    int blockSize)
             throws java.io.IOException
Constructor RawDataBlock

Parameters:
stream - the InputStream from which the data will be read
blockSize - the size of the POIFS blocks, normally 512 bytes POIFSConstants.SMALLER_BIG_BLOCK_SIZE
Throws:
java.io.IOException - on I/O errors, and if an insufficient amount of data is read (the InputStream must be an exact multiple of the block size)
Method Detail

eof

public boolean eof()
When we read the data, did we hit end of file?

Returns:
true if the EoF was hit during this block, or false if not. If you have a dodgy short last block, then it's possible to both have data, and also hit EoF...

hasData

public boolean hasData()
Did we actually find any data to read? It's possible, in the event of a short last block, to both have hit the EoF, but also to have data

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getData

public byte[] getData()
               throws java.io.IOException
Get the data from the block

Specified by:
getData in interface ListManagedBlock
Returns:
the block's data as a byte array
Throws:
java.io.IOException - if there is no data

getBigBlockSize

public int getBigBlockSize()
What's the big block size?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RawDataBlockList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class RawDataBlockList

java.lang.Object
    extended by  org.apache.poi.poifs.storage.RawDataBlockList
All Implemented Interfaces:
BlockList
public class RawDataBlockList
extends java.lang.Object

A list of RawDataBlocks instances, and methods to manage the list

Author:
Marc Johnson (mjohnson at apache dot org

Constructor Summary
RawDataBlockList(java.io.InputStream stream, POIFSBigBlockSize bigBlockSize)
Constructor RawDataBlockList
Method Summary
int | blockCount() Returns the count of the number of blocks
ListManagedBlock[] | fetchBlocks(int startBlock, int headerPropertiesStartBlock) get the blocks making up a particular stream in the list.
protected ListManagedBlock | get(int index) Unit testing method.
protected int | remainingBlocks() Returns the number of remaining blocks
ListManagedBlock | remove(int index) remove and return the specified block from the list
void | setBAT(BlockAllocationTableReader bat) set the associated BlockAllocationTable
protected void | setBlocks(ListManagedBlock[] blocks) provide blocks to manage
void | zap(int index) remove the specified block from the list
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RawDataBlockList

public RawDataBlockList(java.io.InputStream stream,
                        POIFSBigBlockSize bigBlockSize)
                 throws java.io.IOException
Constructor RawDataBlockList

Parameters:
stream - the InputStream from which the data will be read
bigBlockSize - The big block size, either 512 bytes or 4096 bytes
Throws:
java.io.IOException - on I/O errors, and if an incomplete block is read
Method Detail

setBlocks

protected void setBlocks(ListManagedBlock[] blocks)
provide blocks to manage

Parameters:
blocks - blocks to be managed

zap

public void zap(int index)
remove the specified block from the list

Specified by:
zap in interface BlockList
Parameters:
index - the index of the specified block; if the index is out of range, that's ok

get

protected ListManagedBlock get(int index)
Unit testing method. Gets, without sanity checks or removing.

remove

public ListManagedBlock remove(int index)
                        throws java.io.IOException
remove and return the specified block from the list

Specified by:
remove in interface BlockList
Parameters:
index - the index of the specified block
Returns:
the specified block
Throws:
java.io.IOException - if the index is out of range or has already been removed

fetchBlocks

public ListManagedBlock[] fetchBlocks(int startBlock,
                                      int headerPropertiesStartBlock)
                               throws java.io.IOException
get the blocks making up a particular stream in the list. The blocks are removed from the list.

Specified by:
fetchBlocks in interface BlockList
Parameters:
startBlock - the index of the first block in the stream
headerPropertiesStartBlock - the index of the first header block in the stream
Returns:
the stream as an array of correctly ordered blocks
Throws:
java.io.IOException - if blocks are missing

setBAT

public void setBAT(BlockAllocationTableReader bat)
            throws java.io.IOException
set the associated BlockAllocationTable

Specified by:
setBAT in interface BlockList
Parameters:
bat - the associated BlockAllocationTable
Throws:
java.io.IOException

blockCount

public int blockCount()
Returns the count of the number of blocks

Specified by:
blockCount in interface BlockList

remainingBlocks

protected int remainingBlocks()
Returns the number of remaining blocks

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SmallBlockTableReader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class SmallBlockTableReader

java.lang.Object
    extended by  org.apache.poi.poifs.storage.SmallBlockTableReader

public final class SmallBlockTableReader
extends java.lang.Object

This class implements reading the small document block list from an existing file

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
SmallBlockTableReader()
Method Summary
static BlockList getSmallDocumentBlocks(POIFSBigBlockSize bigBlockSize, RawDataBlockList blockList, RootProperty root, int sbatStart)
fetch the small document block list from an existing file
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SmallBlockTableReader

public SmallBlockTableReader()
Method Detail

getSmallDocumentBlocks

public static BlockList getSmallDocumentBlocks(POIFSBigBlockSize bigBlockSize,
                                               RawDataBlockList blockList,
                                               RootProperty root,
                                               int sbatStart)
                                        throws java.io.IOException
fetch the small document block list from an existing file

Parameters:
blockList - the raw data from which the small block table will be extracted
root - the root property (which contains the start block and small block table size)
sbatStart - the start block of the SBAT
Returns:
the small document block list
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SmallBlockTableWriter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class SmallBlockTableWriter

java.lang.Object
    extended by  org.apache.poi.poifs.storage.SmallBlockTableWriter
All Implemented Interfaces:
BATManaged, BlockWritable
public class SmallBlockTableWriter
extends java.lang.Object
implements BlockWritable, BATManaged

This class implements storage for writing the small blocks used by small documents.

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
SmallBlockTableWriter(POIFSBigBlockSize bigBlockSize, java.util.List documents, RootProperty root)
Creates new SmallBlockTable
Method Summary
int | countBlocks() Return the number of BigBlock's this instance uses
BlockAllocationTableWriter | getSBAT() Get the SBAT
int | getSBATBlockCount() Get the number of SBAT blocks
void | setStartBlock(int start_block) Set the start block for this instance
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SmallBlockTableWriter

public SmallBlockTableWriter(POIFSBigBlockSize bigBlockSize,
                             java.util.List documents,
                             RootProperty root)
Creates new SmallBlockTable

Parameters:
documents - a List of POIFSDocument instances
root - the Filesystem's root property
Method Detail

getSBATBlockCount

public int getSBATBlockCount()
Get the number of SBAT blocks

Returns:
number of SBAT big blocks

getSBAT

public BlockAllocationTableWriter getSBAT()
Get the SBAT

Returns:
the Small Block Allocation Table

countBlocks

public int countBlocks()
Return the number of BigBlock's this instance uses

Specified by:
countBlocks in interface BATManaged
Returns:
count of BigBlock instances

setStartBlock

public void setStartBlock(int start_block)
Set the start block for this instance

Specified by:
setStartBlock in interface BATManaged
Parameters:
start_block -

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SmallDocumentBlock

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class SmallDocumentBlock

java.lang.Object
    extended by  org.apache.poi.poifs.storage.SmallDocumentBlock
All Implemented Interfaces:
BlockWritable, ListManagedBlock
public final class SmallDocumentBlock
extends java.lang.Object
implements BlockWritable, ListManagedBlock

Storage for documents that are too small to use regular DocumentBlocks for their data

Author:
Marc Johnson (mjohnson at apache dot org)

Method Summary
static int | calcSize(int size) Calculate the storage size of a set of SmallDocumentBlocks
static SmallDocumentBlock[] | convert(POIFSBigBlockSize bigBlockSize, BlockWritable[] store, int size) Factory for creating SmallDocumentBlocks from DocumentBlocks
static SmallDocumentBlock[] | convert(POIFSBigBlockSize bigBlockSize, byte[] array, int size) convert a single long array into an array of SmallDocumentBlock instances
static java.util.List | extract(POIFSBigBlockSize bigBlockSize, ListManagedBlock[] blocks) create a list of SmallDocumentBlock's from raw data
static int | fill(POIFSBigBlockSize bigBlockSize, java.util.List blocks) fill out a List of SmallDocumentBlocks so that it fully occupies a set of big blocks
POIFSBigBlockSize | getBigBlockSize()
byte[] | getData() Get the data from the block
static DataInputBlock | getDataInputBlock(SmallDocumentBlock[] blocks, int offset)
void | writeBlocks(java.io.OutputStream stream) Write the storage to an OutputStream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

convert

public static SmallDocumentBlock[] convert(POIFSBigBlockSize bigBlockSize,
                                           byte[] array,
                                           int size)
convert a single long array into an array of SmallDocumentBlock instances

Parameters:
array - the byte array to be converted
size - the intended size of the array (which may be smaller)
Returns:
an array of SmallDocumentBlock instances, filled from the array

fill

public static int fill(POIFSBigBlockSize bigBlockSize,
                       java.util.List blocks)
fill out a List of SmallDocumentBlocks so that it fully occupies a set of big blocks

Parameters:
blocks - the List to be filled out
Returns:
number of big blocks the list encompasses

convert

public static SmallDocumentBlock[] convert(POIFSBigBlockSize bigBlockSize,
                                           BlockWritable[] store,
                                           int size)
                                    throws java.io.IOException,
                                           java.lang.ArrayIndexOutOfBoundsException
Factory for creating SmallDocumentBlocks from DocumentBlocks

Parameters:
store - the original DocumentBlocks
size - the total document size
Returns:
an array of new SmallDocumentBlocks instances
Throws:
java.io.IOException - on errors reading from the DocumentBlocks
java.lang.ArrayIndexOutOfBoundsException - if, somehow, the store contains less data than size indicates

extract

public static java.util.List extract(POIFSBigBlockSize bigBlockSize,
                                     ListManagedBlock[] blocks)
                              throws java.io.IOException
create a list of SmallDocumentBlock's from raw data

Parameters:
blocks - the raw data containing the SmallDocumentBlock data
Returns:
a List of SmallDocumentBlock's extracted from the input
Throws:
java.io.IOException

getDataInputBlock

public static DataInputBlock getDataInputBlock(SmallDocumentBlock[] blocks,
                                               int offset)

calcSize

public static int calcSize(int size)
Calculate the storage size of a set of SmallDocumentBlocks

Parameters:
size - number of SmallDocumentBlocks
Returns:
total size

writeBlocks

public void writeBlocks(java.io.OutputStream stream)
                 throws java.io.IOException
Write the storage to an OutputStream

Specified by:
writeBlocks in interface BlockWritable
Parameters:
stream - the OutputStream to which the stored data should be written
Throws:
java.io.IOException - on problems writing to the specified stream

getData

public byte[] getData()
Get the data from the block

Specified by:
getData in interface ListManagedBlock
Returns:
the block's data as a byte array
Throws:
java.io.IOException - if there is no data

getBigBlockSize

public POIFSBigBlockSize getBigBlockSize()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SmallDocumentBlockList

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.poifs.storage
Class SmallDocumentBlockList

java.lang.Object
    extended by  org.apache.poi.poifs.storage.SmallDocumentBlockList
All Implemented Interfaces:
BlockList
public class SmallDocumentBlockList
extends java.lang.Object

A list of SmallDocumentBlocks instances, and methods to manage the list

Author:
Marc Johnson (mjohnson at apache dot org)

Constructor Summary
SmallDocumentBlockList(java.util.List blocks)
Constructor SmallDocumentBlockList
Method Summary
int | blockCount() Returns the count of the number of blocks
ListManagedBlock[] | fetchBlocks(int startBlock, int headerPropertiesStartBlock) get the blocks making up a particular stream in the list.
protected ListManagedBlock | get(int index) Unit testing method.
protected int | remainingBlocks() Returns the number of remaining blocks
ListManagedBlock | remove(int index) remove and return the specified block from the list
void | setBAT(BlockAllocationTableReader bat) set the associated BlockAllocationTable
protected void | setBlocks(ListManagedBlock[] blocks) provide blocks to manage
void | zap(int index) remove the specified block from the list
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SmallDocumentBlockList

public SmallDocumentBlockList(java.util.List blocks)
Constructor SmallDocumentBlockList

Parameters:
blocks - a list of SmallDocumentBlock instances
Method Detail

setBlocks

protected void setBlocks(ListManagedBlock[] blocks)
provide blocks to manage

Parameters:
blocks - blocks to be managed

zap

public void zap(int index)
remove the specified block from the list

Specified by:
zap in interface BlockList
Parameters:
index - the index of the specified block; if the index is out of range, that's ok

get

protected ListManagedBlock get(int index)
Unit testing method. Gets, without sanity checks or removing.

remove

public ListManagedBlock remove(int index)
                        throws java.io.IOException
remove and return the specified block from the list

Specified by:
remove in interface BlockList
Parameters:
index - the index of the specified block
Returns:
the specified block
Throws:
java.io.IOException - if the index is out of range or has already been removed

fetchBlocks

public ListManagedBlock[] fetchBlocks(int startBlock,
                                      int headerPropertiesStartBlock)
                               throws java.io.IOException
get the blocks making up a particular stream in the list. The blocks are removed from the list.

Specified by:
fetchBlocks in interface BlockList
Parameters:
startBlock - the index of the first block in the stream
headerPropertiesStartBlock - the index of the first header block in the stream
Returns:
the stream as an array of correctly ordered blocks
Throws:
java.io.IOException - if blocks are missing

setBAT

public void setBAT(BlockAllocationTableReader bat)
            throws java.io.IOException
set the associated BlockAllocationTable

Specified by:
setBAT in interface BlockList
Parameters:
bat - the associated BlockAllocationTable
Throws:
java.io.IOException

blockCount

public int blockCount()
Returns the count of the number of blocks

Specified by:
blockCount in interface BlockList

remainingBlocks

protected int remainingBlocks()
Returns the number of remaining blocks

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.poifs.storage.BATBlock.BATBlockAndIndex

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.BATBlock.BATBlockAndIndex

Packages that use BATBlock.BATBlockAndIndex
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of BATBlock.BATBlockAndIndex in org.apache.poi.poifs.filesystem

Methods in org.apache.poi.poifs.filesystem that return BATBlock.BATBlockAndIndex
protected BATBlock.BATBlockAndIndex | NPOIFSMiniStore.getBATBlockAndIndex(int offset) Returns the BATBlock that handles the specified offset, and the relative index within it
protected BATBlock.BATBlockAndIndex | NPOIFSFileSystem.getBATBlockAndIndex(int offset) Returns the BATBlock that handles the specified offset, and the relative index within it
protected abstract BATBlock.BATBlockAndIndex | BlockStore.getBATBlockAndIndex(int offset) Returns the BATBlock that handles the specified offset, and the relative index within it

Uses of BATBlock.BATBlockAndIndex in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage that return BATBlock.BATBlockAndIndex
static BATBlock.BATBlockAndIndex | BATBlock.getBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> bats) Returns the BATBlock that handles the specified offset, and the relative index within it.
static BATBlock.BATBlockAndIndex | BATBlock.getSBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> sbats) Returns the BATBlock that handles the specified offset, and the relative index within it, for the mini stream.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.BATBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.BATBlock

Packages that use BATBlock
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of BATBlock in org.apache.poi.poifs.filesystem

Constructor parameters in org.apache.poi.poifs.filesystem with type arguments of type BATBlock
NPOIFSMiniStore(NPOIFSFileSystem filesystem, RootProperty root, java.util.List<BATBlock> sbats, HeaderBlock header)

Uses of BATBlock in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage that return BATBlock
static BATBlock | BATBlock.createBATBlock(POIFSBigBlockSize bigBlockSize, java.nio.ByteBuffer data) Create a single BATBlock from the byte buffer, which must hold at least one big block of data to be read.
static BATBlock[] | BATBlock.createBATBlocks(POIFSBigBlockSize bigBlockSize, int[] entries) Create an array of BATBlocks from an array of int block allocation table entries
static BATBlock | BATBlock.createEmptyBATBlock(POIFSBigBlockSize bigBlockSize, boolean isXBAT) Creates a single BATBlock, with all the values set to empty.
static BATBlock[] | BATBlock.createXBATBlocks(POIFSBigBlockSize bigBlockSize, int[] entries, int startBlock) Create an array of XBATBlocks from an array of int block allocation table entries
BATBlock | BATBlock.BATBlockAndIndex.getBlock()
BATBlock[] | HeaderBlockWriter.setBATBlocks(int blockCount, int startBlock) Set BAT block parameters.

Methods in org.apache.poi.poifs.storage with parameters of type BATBlock
static void BlockAllocationTableWriter.writeBlock(BATBlock bat, java.nio.ByteBuffer block)
Write the BAT into its associated block

Method parameters in org.apache.poi.poifs.storage with type arguments of type BATBlock
static BATBlock.BATBlockAndIndex | BATBlock.getBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> bats) Returns the BATBlock that handles the specified offset, and the relative index within it.
static BATBlock.BATBlockAndIndex | BATBlock.getSBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> sbats) Returns the BATBlock that handles the specified offset, and the relative index within it, for the mini stream.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.BlockAllocationTableReader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.BlockAllocationTableReader

Packages that use BlockAllocationTableReader
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of BlockAllocationTableReader in org.apache.poi.poifs.dev

Methods in org.apache.poi.poifs.dev with parameters of type BlockAllocationTableReader
static void POIFSHeaderDumper.displayBATReader(BlockAllocationTableReader batReader)

Uses of BlockAllocationTableReader in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage with parameters of type BlockAllocationTableReader
 void BlockList.setBAT(BlockAllocationTableReader bat)
set the associated BlockAllocationTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.BlockAllocationTableWriter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.BlockAllocationTableWriter

Packages that use BlockAllocationTableWriter
org.apache.poi.poifs.storage storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of BlockAllocationTableWriter in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage that return BlockAllocationTableWriter
 BlockAllocationTableWriter SmallBlockTableWriter.getSBAT()
Get the SBAT

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.storage.BlockList

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.storage.BlockList

Packages that use BlockList
org.apache.poi.poifs.storage storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of BlockList in org.apache.poi.poifs.storage

Classes in org.apache.poi.poifs.storage that implement BlockList
class | RawDataBlockList A list of RawDataBlocks instances, and methods to manage the list
class | SmallDocumentBlockList A list of SmallDocumentBlocks instances, and methods to manage the list

Methods in org.apache.poi.poifs.storage that return BlockList
static BlockList SmallBlockTableReader.getSmallDocumentBlocks(POIFSBigBlockSize bigBlockSize, RawDataBlockList blockList, RootProperty root, int sbatStart)
fetch the small document block list from an existing file

Constructors in org.apache.poi.poifs.storage with parameters of type BlockList
BlockAllocationTableReader(POIFSBigBlockSize bigBlockSize, int block_count, int[] block_array, int xbat_count, int xbat_index, BlockList raw_block_list)
create a BlockAllocationTableReader for an existing filesystem.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.storage.BlockWritable

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.storage.BlockWritable

Packages that use BlockWritable
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of BlockWritable in org.apache.poi.poifs.filesystem

Classes in org.apache.poi.poifs.filesystem that implement BlockWritable
 class POIFSDocument
This class manages a document in the POIFS filesystem.

Methods in org.apache.poi.poifs.filesystem that return BlockWritable
 BlockWritable[] POIFSDocument.getSmallBlocks()

Uses of BlockWritable in org.apache.poi.poifs.property

Classes in org.apache.poi.poifs.property that implement BlockWritable
 class PropertyTable
This class embodies the Property Table for the POIFSFileSystem; this is basically the directory for all of the documents in the filesystem.

Uses of BlockWritable in org.apache.poi.poifs.storage

Classes in org.apache.poi.poifs.storage that implement BlockWritable
class | BATBlock A block of block allocation table entries.
class | BlockAllocationTableWriter This class manages and creates the Block Allocation Table, which is basically a set of linked lists of block indices.
class | DocumentBlock A block of document data.
class | HeaderBlockWriter The block containing the archive header
class | PropertyBlock A block of Property instances
class | SmallBlockTableWriter This class implements storage for writing the small blocks used by small documents.
class | SmallDocumentBlock Storage for documents that are too small to use regular DocumentBlocks for their data

Methods in org.apache.poi.poifs.storage that return BlockWritable
static BlockWritable[] PropertyBlock.createPropertyBlockArray(POIFSBigBlockSize bigBlockSize, java.util.List<Property> properties)
Create an array of PropertyBlocks from an array of Property instances, creating empty Property instances to make up any shortfall

Methods in org.apache.poi.poifs.storage with parameters of type BlockWritable
static SmallDocumentBlock[] SmallDocumentBlock.convert(POIFSBigBlockSize bigBlockSize, BlockWritable[] store, int size)
Factory for creating SmallDocumentBlocks from DocumentBlocks

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.DataInputBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.DataInputBlock

Packages that use DataInputBlock
org.apache.poi.poifs.storage storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of DataInputBlock in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage that return DataInputBlock
static DataInputBlock | DocumentBlock.getDataInputBlock(DocumentBlock[] blocks, int offset)
static DataInputBlock | SmallDocumentBlock.getDataInputBlock(SmallDocumentBlock[] blocks, int offset)

Methods in org.apache.poi.poifs.storage with parameters of type DataInputBlock
int | DataInputBlock.readIntLE(DataInputBlock prevBlock, int prevBlockAvailable) Reads an int which spans the end of prevBlock and the start of this block.
long | DataInputBlock.readLongLE(DataInputBlock prevBlock, int prevBlockAvailable) Reads a long which spans the end of prevBlock and the start of this block.
int | DataInputBlock.readUShortLE(DataInputBlock prevBlock) Reads a short which spans the end of prevBlock and the start of this block.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.DocumentBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.DocumentBlock

Packages that use DocumentBlock
org.apache.poi.poifs.storage storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of DocumentBlock in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage that return DocumentBlock
static DocumentBlock[] DocumentBlock.convert(POIFSBigBlockSize bigBlockSize, byte[] array, int size)
convert a single long array into an array of DocumentBlock instances

Methods in org.apache.poi.poifs.storage with parameters of type DocumentBlock
static DataInputBlock DocumentBlock.getDataInputBlock(DocumentBlock[] blocks, int offset)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.HeaderBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.HeaderBlock

Packages that use HeaderBlock
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of HeaderBlock in org.apache.poi.poifs.dev

Methods in org.apache.poi.poifs.dev with parameters of type HeaderBlock
static void POIFSHeaderDumper.displayHeader(HeaderBlock header_block)

Uses of HeaderBlock in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type HeaderBlock
NPOIFSMiniStore(NPOIFSFileSystem filesystem, RootProperty root, java.util.List<BATBlock> sbats, HeaderBlock header)

Uses of HeaderBlock in org.apache.poi.poifs.property

Constructors in org.apache.poi.poifs.property with parameters of type HeaderBlock
NPropertyTable(HeaderBlock headerBlock)
NPropertyTable(HeaderBlock headerBlock, NPOIFSFileSystem filesystem)
reading constructor (used when we've read in a file and we want to extract the property table from it).
PropertyTable(HeaderBlock headerBlock)
PropertyTable(HeaderBlock headerBlock, RawDataBlockList blockList)
reading constructor (used when we've read in a file and we want to extract the property table from it).
PropertyTableBase(HeaderBlock header_block)
PropertyTableBase(HeaderBlock header_block, java.util.List<Property> properties)
Reading constructor (used when we've read in a file and we want to extract the property table from it).

Uses of HeaderBlock in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage with parameters of type HeaderBlock
static int | BATBlock.calculateMaximumSize(HeaderBlock header)
static BATBlock.BATBlockAndIndex | BATBlock.getBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> bats) Returns the BATBlock that handles the specified offset, and the relative index within it.
static BATBlock.BATBlockAndIndex | BATBlock.getSBATBlockAndIndex(int offset, HeaderBlock header, java.util.List<BATBlock> sbats) Returns the BATBlock that handles the specified offset, and the relative index within it, for the mini stream.

Constructors in org.apache.poi.poifs.storage with parameters of type HeaderBlock
HeaderBlockWriter(HeaderBlock headerBlock)
Create a single instance initialized with the specified existing values

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.storage.HeaderBlockConstants

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.storage.HeaderBlockConstants

Packages that use HeaderBlockConstants
org.apache.poi.poifs.storage storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of HeaderBlockConstants in org.apache.poi.poifs.storage

Classes in org.apache.poi.poifs.storage that implement HeaderBlockConstants
class | HeaderBlock The block containing the archive header
class | HeaderBlockWriter The block containing the archive header

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.HeaderBlockWriter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.HeaderBlockWriter

No usage of org.apache.poi.poifs.storage.HeaderBlockWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.poifs.storage.ListManagedBlock

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.poifs.storage.ListManagedBlock

Packages that use ListManagedBlock
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of ListManagedBlock in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type ListManagedBlock
POIFSDocument(java.lang.String name, ListManagedBlock[] blocks, int length)
POIFSDocument(java.lang.String name, POIFSBigBlockSize bigBlockSize, ListManagedBlock[] blocks, int length)
Constructor from small blocks

Uses of ListManagedBlock in org.apache.poi.poifs.storage

Classes in org.apache.poi.poifs.storage that implement ListManagedBlock
class | RawDataBlock A big block created from an InputStream, holding the raw data
class | SmallDocumentBlock Storage for documents that are too small to use regular DocumentBlocks for their data

Methods in org.apache.poi.poifs.storage that return ListManagedBlock
ListManagedBlock[] | BlockList.fetchBlocks(int startBlock, int headerPropertiesStartBlock) get the blocks making up a particular stream in the list.
ListManagedBlock | BlockList.remove(int index) remove and return the specified block from the list

Methods in org.apache.poi.poifs.storage with parameters of type ListManagedBlock
static java.util.List SmallDocumentBlock.extract(POIFSBigBlockSize bigBlockSize, ListManagedBlock[] blocks)
create a list of SmallDocumentBlock's from raw data

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.PropertyBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.PropertyBlock

No usage of org.apache.poi.poifs.storage.PropertyBlock

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.RawDataBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.RawDataBlock

Packages that use RawDataBlock
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of RawDataBlock in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type RawDataBlock
POIFSDocument(java.lang.String name, RawDataBlock[] blocks, int length)
Constructor from large blocks

Uses of RawDataBlock in org.apache.poi.poifs.storage

Constructors in org.apache.poi.poifs.storage with parameters of type RawDataBlock
DocumentBlock(RawDataBlock block)
create a document block from a raw data block

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.RawDataBlockList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.RawDataBlockList

Packages that use RawDataBlockList
org.apache.poi.poifs.dev | DEV package serves two purposes.
org.apache.poi.poifs.property | property package contains high and low level Property structures for POIFS.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of RawDataBlockList in org.apache.poi.poifs.dev

Methods in org.apache.poi.poifs.dev with parameters of type RawDataBlockList
static void POIFSHeaderDumper.displayRawBlocksSummary(RawDataBlockList data_blocks)

Uses of RawDataBlockList in org.apache.poi.poifs.property

Constructors in org.apache.poi.poifs.property with parameters of type RawDataBlockList
PropertyTable(HeaderBlock headerBlock, RawDataBlockList blockList)
reading constructor (used when we've read in a file and we want to extract the property table from it).

Uses of RawDataBlockList in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage with parameters of type RawDataBlockList
static BlockList SmallBlockTableReader.getSmallDocumentBlocks(POIFSBigBlockSize bigBlockSize, RawDataBlockList blockList, RootProperty root, int sbatStart)
fetch the small document block list from an existing file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.SmallBlockTableReader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.SmallBlockTableReader

No usage of org.apache.poi.poifs.storage.SmallBlockTableReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.SmallBlockTableWriter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.SmallBlockTableWriter

No usage of org.apache.poi.poifs.storage.SmallBlockTableWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.SmallDocumentBlock

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.SmallDocumentBlock

Packages that use SmallDocumentBlock
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.poifs.storage | storage package contains low level binary structures for POIFS's implementation of the OLE 2 Compound Document Format.

Uses of SmallDocumentBlock in org.apache.poi.poifs.filesystem

Constructors in org.apache.poi.poifs.filesystem with parameters of type SmallDocumentBlock
POIFSDocument(java.lang.String name, SmallDocumentBlock[] blocks, int length)
Constructor from small blocks

Uses of SmallDocumentBlock in org.apache.poi.poifs.storage

Methods in org.apache.poi.poifs.storage that return SmallDocumentBlock
static SmallDocumentBlock[] | SmallDocumentBlock.convert(POIFSBigBlockSize bigBlockSize, BlockWritable[] store, int size) Factory for creating SmallDocumentBlocks from DocumentBlocks
static SmallDocumentBlock[] | SmallDocumentBlock.convert(POIFSBigBlockSize bigBlockSize, byte[] array, int size) convert a single long array into an array of SmallDocumentBlock instances

Methods in org.apache.poi.poifs.storage with parameters of type SmallDocumentBlock
static DataInputBlock SmallDocumentBlock.getDataInputBlock(SmallDocumentBlock[] blocks, int offset)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.poifs.storage.SmallDocumentBlockList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.poifs.storage.SmallDocumentBlockList

No usage of org.apache.poi.poifs.storage.SmallDocumentBlockList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AutoShape

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface AutoShape

All Superinterfaces:
Shape, SimpleShape
All Known Subinterfaces:
Line, TextBox
public interface AutoShape
extends SimpleShape

Method Summary
 TextRun getTextRun()
Methods inherited from interface org.apache.poi.sl.usermodel.SimpleShape
getFill, getHyperlink, getLineStyle, setHyperlink
Methods inherited from interface org.apache.poi.sl.usermodel.Shape
getAnchor, getParent, getShapeType, moveTo, setAnchor

Method Detail

getTextRun

TextRun getTextRun()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Background

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Background

All Superinterfaces:
Shape
public interface Background
extends Shape

Method Summary
Methods inherited from interface org.apache.poi.sl.usermodel.Shape
getAnchor, getParent, getShapeType, moveTo, setAnchor

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fill

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Fill

All Superinterfaces:
Fill
public interface Fill
extends Fill

Method Summary
Methods inherited from interface org.apache.poi.common.usermodel.Fill
getColor, setColor

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontCollection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface FontCollection

public interface FontCollection

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Hyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Hyperlink

All Superinterfaces:
Hyperlink
public interface Hyperlink
extends Hyperlink

A PowerPoint hyperlink

Field Summary
Fields inherited from interface org.apache.poi.common.usermodel.Hyperlink
LINK_DOCUMENT, LINK_EMAIL, LINK_FILE, LINK_URL
Method Summary
Methods inherited from interface org.apache.poi.common.usermodel.Hyperlink
getAddress, getLabel, getType, setAddress, setLabel

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Line

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Line

All Superinterfaces:
AutoShape, Shape, SimpleShape
public interface Line
extends AutoShape

Method Summary
Methods inherited from interface org.apache.poi.sl.usermodel.AutoShape
getTextRun
Methods inherited from interface org.apache.poi.sl.usermodel.SimpleShape
getFill, getHyperlink, getLineStyle, setHyperlink
Methods inherited from interface org.apache.poi.sl.usermodel.Shape
getAnchor, getParent, getShapeType, moveTo, setAnchor

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface LineStyle

All Superinterfaces:
LineStyle
public interface LineStyle
extends LineStyle

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MasterSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface MasterSheet

All Superinterfaces:
ShapeContainer, Sheet
public interface MasterSheet
extends Sheet

Method Summary
Methods inherited from interface org.apache.poi.sl.usermodel.Sheet
getBackground, getMasterSheet, getSlideShow
Methods inherited from interface org.apache.poi.sl.usermodel.ShapeContainer
addShape, getShapes, removeShape

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Notes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Notes

All Superinterfaces:
ShapeContainer, Sheet
public interface Notes
extends Sheet

Method Summary
 TextRun getTextRun()
Methods inherited from interface org.apache.poi.sl.usermodel.Sheet
getBackground, getMasterSheet, getSlideShow
Methods inherited from interface org.apache.poi.sl.usermodel.ShapeContainer
addShape, getShapes, removeShape

Method Detail

getTextRun

TextRun getTextRun()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.sl.usermodel
Interfaces
AutoShape
Background
Fill
FontCollection
Hyperlink
Line
LineStyle
MasterSheet
Notes
Picture
PictureData
Resources
Shape
ShapeContainer
ShapeGroup
ShapeTypes
Sheet
SimpleShape
Slide
SlideShow
TextBox
TextRun


org.apache.poi.sl.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.sl.usermodel

Interface Summary
AutoShape |
Background |
Fill |
FontCollection |
Hyperlink | A PowerPoint hyperlink
Line |
LineStyle |
MasterSheet |
Notes |
Picture |
PictureData |
Resources | Common SlideShow resources, such as fonts, pictures and multimedia data
Shape |
ShapeContainer |
ShapeGroup |
ShapeTypes |
Sheet | Common parent of Slides, Notes and Masters
SimpleShape |
Slide |
SlideShow |
TextBox |
TextRun | Some text.


org.apache.poi.sl.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.sl.usermodel

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.apache.poi.common.usermodel.Fill
    • org.apache.poi.sl.usermodel.Fill
  • org.apache.poi.sl.usermodel.FontCollection
  • org.apache.poi.common.usermodel.Hyperlink
    • org.apache.poi.sl.usermodel.Hyperlink
  • org.apache.poi.common.usermodel.LineStyle
    • org.apache.poi.sl.usermodel.LineStyle
  • org.apache.poi.sl.usermodel.PictureData
  • org.apache.poi.sl.usermodel.Resources
  • org.apache.poi.sl.usermodel.Shape
    • org.apache.poi.sl.usermodel.Background
    • org.apache.poi.sl.usermodel.SimpleShape
      • org.apache.poi.sl.usermodel.AutoShape
        • org.apache.poi.sl.usermodel.Line
        • org.apache.poi.sl.usermodel.TextBox
      • org.apache.poi.sl.usermodel.Picture
  • org.apache.poi.sl.usermodel.ShapeContainer
    • org.apache.poi.sl.usermodel.ShapeGroup
    • org.apache.poi.sl.usermodel.Sheet
      • org.apache.poi.sl.usermodel.MasterSheet
      • org.apache.poi.sl.usermodel.Notes
      • org.apache.poi.sl.usermodel.Slide
  • org.apache.poi.sl.usermodel.ShapeTypes
  • org.apache.poi.sl.usermodel.SlideShow
  • org.apache.poi.sl.usermodel.TextRun


Uses of Package org.apache.poi.sl.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.sl.usermodel

Packages that use org.apache.poi.sl.usermodel
org.apache.poi.hslf.model
org.apache.poi.sl.usermodel

Classes in org.apache.poi.sl.usermodel used by org.apache.poi.hslf.model
ShapeTypes

Classes in org.apache.poi.sl.usermodel used by org.apache.poi.sl.usermodel
AutoShape
Background
Fill
FontCollection
Hyperlink
A PowerPoint hyperlink
LineStyle
MasterSheet
Notes
PictureData
Resources
Common SlideShow resources, such as fonts, pictures and multimedia data
Shape
ShapeContainer
Sheet
Common parent of Slides, Notes and Masters
SimpleShape
Slide
SlideShow
TextRun
Some text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Picture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Picture

All Superinterfaces:
Shape, SimpleShape
public interface Picture
extends SimpleShape

Method Summary
 PictureData getPictureData()
Methods inherited from interface org.apache.poi.sl.usermodel.SimpleShape
getFill, getHyperlink, getLineStyle, setHyperlink
Methods inherited from interface org.apache.poi.sl.usermodel.Shape
getAnchor, getParent, getShapeType, moveTo, setAnchor

Method Detail

getPictureData

PictureData getPictureData()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PictureData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface PictureData

public interface PictureData

Method Summary
byte[] | getData()
int | getType()
byte[] | getUID()
void | setData(byte[] data)

Method Detail

getType

int getType()

getUID

byte[] getUID()

getData

byte[] getData()

setData

void setData(byte[] data)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Resources

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Resources

public interface Resources

Common SlideShow resources, such as fonts, pictures and multimedia data

Method Summary
int | addPictureData(PictureData pict)
FontCollection | getFontCollection()
PictureData[] | getPictureData()

Method Detail

getFontCollection

FontCollection getFontCollection()

getPictureData

PictureData[] getPictureData()

addPictureData

int addPictureData(PictureData pict)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Shape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Shape

All Known Subinterfaces:
AutoShape, Background, Line, Picture, SimpleShape, TextBox
public interface Shape

Method Summary
java.awt.geom.Rectangle2D | getAnchor()
Shape | getParent()
int | getShapeType()
void | moveTo(float x, float y)
void | setAnchor(java.awt.geom.Rectangle2D anchor)

Method Detail

getShapeType

int getShapeType()

getAnchor

java.awt.geom.Rectangle2D getAnchor()

setAnchor

void setAnchor(java.awt.geom.Rectangle2D anchor)

moveTo

void moveTo(float x,
            float y)

getParent

Shape getParent()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface ShapeContainer

All Known Subinterfaces:
MasterSheet, Notes, ShapeGroup, Sheet, Slide
public interface ShapeContainer

Method Summary
void | addShape(Shape shape)
Shape[] | getShapes()
boolean | removeShape(Shape shape)

Method Detail

getShapes

Shape[] getShapes()

addShape

void addShape(Shape shape)

removeShape

boolean removeShape(Shape shape)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface ShapeGroup

All Superinterfaces:
ShapeContainer
public interface ShapeGroup
extends ShapeContainer

Method Summary
Methods inherited from interface org.apache.poi.sl.usermodel.ShapeContainer
addShape, getShapes, removeShape

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeTypes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface ShapeTypes

All Known Implementing Classes:
ShapeTypes
public interface ShapeTypes

Field Summary
static int | AccentBorderCallout1
static int | AccentBorderCallout2
static int | AccentBorderCallout3
static int | AccentBorderCallout90
static int | AccentCallout1
static int | AccentCallout2
static int | AccentCallout3
static int | AccentCallout90
static int | ActionButtonBackPrevious
static int | ActionButtonBeginning
static int | ActionButtonBlank
static int | ActionButtonDocument
static int | ActionButtonEnd
static int | ActionButtonForwardNext
static int | ActionButtonHelp
static int | ActionButtonHome
static int | ActionButtonInformation
static int | ActionButtonMovie
static int | ActionButtonReturn
static int | ActionButtonSound
static int | Arc
static int | Arrow
static int | Balloon
static int | BentArrow
static int | BentConnector2
static int | BentConnector3
static int | BentConnector4
static int | BentConnector5
static int | BentUpArrow
static int | Bevel
static int | BlockArc
static int | BorderCallout1
static int | BorderCallout2
static int | BorderCallout3
static int | BorderCallout90
static int | BracePair
static int | BracketPair
static int | Callout1
static int | Callout2
static int | Callout3
static int | Callout90
static int | Can
static int | Chevron
static int | CircularArrow
static int | CloudCallout
static int | Cube
static int | CurvedConnector2
static int | CurvedConnector3
static int | CurvedConnector4
static int | CurvedConnector5
static int | CurvedDownArrow
static int | CurvedLeftArrow
static int | CurvedRightArrow
static int | CurvedUpArrow
static int | Diamond
static int | Donut
static int | DoubleWave
static int | DownArrow
static int | DownArrowCallout
static int | Ellipse
static int | EllipseRibbon
static int | EllipseRibbon2
static int | FlowChartAlternateProcess
static int | FlowChartCollate
static int | FlowChartConnector
static int | FlowChartDecision
static int | FlowChartDelay
static int | FlowChartDisplay
static int | FlowChartDocument
static int | FlowChartExtract
static int | FlowChartInputOutput
static int | FlowChartInternalStorage
static int | FlowChartMagneticDisk
static int | FlowChartMagneticDrum
static int | FlowChartMagneticTape
static int | FlowChartManualInput
static int | FlowChartManualOperation
static int | FlowChartMerge
static int | FlowChartMultidocument
static int | FlowChartOfflineStorage
static int | FlowChartOffpageConnector
static int | FlowChartOnlineStorage
static int | FlowChartOr
static int | FlowChartPredefinedProcess
static int | FlowChartPreparation
static int | FlowChartProcess
static int | FlowChartPunchedCard
static int | FlowChartPunchedTape
static int | FlowChartSort
static int | FlowChartSummingJunction
static int | FlowChartTerminator
static int | FoldedCorner
static int | Heart
static int | Hexagon
static int | HomePlate
static int | HorizontalScroll
static int | HostControl
static int | IrregularSeal1
static int | IrregularSeal2
static int | IsocelesTriangle
static int | LeftArrow
static int | LeftArrowCallout
static int | LeftBrace
static int | LeftBracket
static int | LeftRightArrow
static int | LeftRightArrowCallout
static int | LeftRightUpArrow
static int | LeftUpArrow
static int | LightningBolt
static int | Line
static int | Moon
static int | NoSmoking
static int | NotchedCircularArrow
static int | NotchedRightArrow
static int | NotPrimitive
static int | Octagon
static int | Parallelogram
static int | Pentagon
static int | PictureFrame
static int | Plaque
static int | Plus
static int | QuadArrow
static int | QuadArrowCallout
static int | Rectangle
static int | Ribbon
static int | Ribbon2
static int | RightArrowCallout
static int | RightBrace
static int | RightBracket
static int | RightTriangle
static int | RoundRectangle
static int | Seal
static int | SmileyFace
static int | Star
static int | Star16
static int | Star24
static int | Star32
static int | Star4
static int | Star8
static int | StraightConnector1
static int | StripedRightArrow
static int | Sun
static int | TextArchDownCurve
static int | TextArchDownPour
static int | TextArchUpCurve
static int | TextArchUpPour
static int | TextBox
static int | TextButtonCurve
static int | TextButtonPour
static int | TextCanDown
static int | TextCanUp
static int | TextCascadeDown
static int | TextCascadeUp
static int | TextChevron
static int | TextChevronInverted
static int | TextCircleCurve
static int | TextCirclePour
static int | TextCurve
static int | TextCurveDown
static int | TextCurveUp
static int | TextDeflate
static int | TextDeflateBottom
static int | TextDeflateInflate
static int | TextDeflateInflateDeflate
static int | TextDeflateTop
static int | TextFadeDown
static int | TextFadeLeft
static int | TextFadeRight
static int | TextFadeUp
static int | TextHexagon
static int | TextInflate
static int | TextInflateBottom
static int | TextInflateTop
static int | TextOctagon
static int | TextOnCurve
static int | TextOnRing
static int | TextPlainText
static int | TextRing
static int | TextRingInside
static int | TextRingOutside
static int | TextSimple
static int | TextSlantDown
static int | TextSlantUp
static int | TextStop
static int | TextTriangle
static int | TextTriangleInverted
static int | TextWave
static int | TextWave1
static int | TextWave2
static int | TextWave3
static int | TextWave4
static int | ThickArrow
static int | Trapezoid
static int | UpArrow
static int | UpArrowCallout
static int | UpDownArrow
static int | UpDownArrowCallout
static int | UturnArrow
static int | VerticalScroll
static int | Wave
static int | WedgeEllipseCallout
static int | WedgeRectCallout
static int | WedgeRRectCallout

Field Detail

NotPrimitive

static final int NotPrimitive
See Also:
Constant Field Values

Rectangle

static final int Rectangle
See Also:
Constant Field Values

RoundRectangle

static final int RoundRectangle
See Also:
Constant Field Values

Ellipse

static final int Ellipse
See Also:
Constant Field Values

Diamond

static final int Diamond
See Also:
Constant Field Values

IsocelesTriangle

static final int IsocelesTriangle
See Also:
Constant Field Values

RightTriangle

static final int RightTriangle
See Also:
Constant Field Values

Parallelogram

static final int Parallelogram
See Also:
Constant Field Values

Trapezoid

static final int Trapezoid
See Also:
Constant Field Values

Hexagon

static final int Hexagon
See Also:
Constant Field Values

Octagon

static final int Octagon
See Also:
Constant Field Values

Plus

static final int Plus
See Also:
Constant Field Values

Star

static final int Star
See Also:
Constant Field Values

Arrow

static final int Arrow
See Also:
Constant Field Values

ThickArrow

static final int ThickArrow
See Also:
Constant Field Values

HomePlate

static final int HomePlate
See Also:
Constant Field Values

Cube

static final int Cube
See Also:
Constant Field Values

Balloon

static final int Balloon
See Also:
Constant Field Values

Seal

static final int Seal
See Also:
Constant Field Values

Arc

static final int Arc
See Also:
Constant Field Values

Line

static final int Line
See Also:
Constant Field Values

Plaque

static final int Plaque
See Also:
Constant Field Values

Can

static final int Can
See Also:
Constant Field Values

Donut

static final int Donut
See Also:
Constant Field Values

TextSimple

static final int TextSimple
See Also:
Constant Field Values

TextOctagon

static final int TextOctagon
See Also:
Constant Field Values

TextHexagon

static final int TextHexagon
See Also:
Constant Field Values

TextCurve

static final int TextCurve
See Also:
Constant Field Values

TextWave

static final int TextWave
See Also:
Constant Field Values

TextRing

static final int TextRing
See Also:
Constant Field Values

TextOnCurve

static final int TextOnCurve
See Also:
Constant Field Values

TextOnRing

static final int TextOnRing
See Also:
Constant Field Values

StraightConnector1

static final int StraightConnector1
See Also:
Constant Field Values

BentConnector2

static final int BentConnector2
See Also:
Constant Field Values

BentConnector3

static final int BentConnector3
See Also:
Constant Field Values

BentConnector4

static final int BentConnector4
See Also:
Constant Field Values

BentConnector5

static final int BentConnector5
See Also:
Constant Field Values

CurvedConnector2

static final int CurvedConnector2
See Also:
Constant Field Values

CurvedConnector3

static final int CurvedConnector3
See Also:
Constant Field Values

CurvedConnector4

static final int CurvedConnector4
See Also:
Constant Field Values

CurvedConnector5

static final int CurvedConnector5
See Also:
Constant Field Values

Callout1

static final int Callout1
See Also:
Constant Field Values

Callout2

static final int Callout2
See Also:
Constant Field Values

Callout3

static final int Callout3
See Also:
Constant Field Values

AccentCallout1

static final int AccentCallout1
See Also:
Constant Field Values

AccentCallout2

static final int AccentCallout2
See Also:
Constant Field Values

AccentCallout3

static final int AccentCallout3
See Also:
Constant Field Values

BorderCallout1

static final int BorderCallout1
See Also:
Constant Field Values

BorderCallout2

static final int BorderCallout2
See Also:
Constant Field Values

BorderCallout3

static final int BorderCallout3
See Also:
Constant Field Values

AccentBorderCallout1

static final int AccentBorderCallout1
See Also:
Constant Field Values

AccentBorderCallout2

static final int AccentBorderCallout2
See Also:
Constant Field Values

AccentBorderCallout3

static final int AccentBorderCallout3
See Also:
Constant Field Values

Ribbon

static final int Ribbon
See Also:
Constant Field Values

Ribbon2

static final int Ribbon2
See Also:
Constant Field Values

Chevron

static final int Chevron
See Also:
Constant Field Values

Pentagon

static final int Pentagon
See Also:
Constant Field Values

NoSmoking

static final int NoSmoking
See Also:
Constant Field Values

Star8

static final int Star8
See Also:
Constant Field Values

Star16

static final int Star16
See Also:
Constant Field Values

Star32

static final int Star32
See Also:
Constant Field Values

WedgeRectCallout

static final int WedgeRectCallout
See Also:
Constant Field Values

WedgeRRectCallout

static final int WedgeRRectCallout
See Also:
Constant Field Values

WedgeEllipseCallout

static final int WedgeEllipseCallout
See Also:
Constant Field Values

Wave

static final int Wave
See Also:
Constant Field Values

FoldedCorner

static final int FoldedCorner
See Also:
Constant Field Values

LeftArrow

static final int LeftArrow
See Also:
Constant Field Values

DownArrow

static final int DownArrow
See Also:
Constant Field Values

UpArrow

static final int UpArrow
See Also:
Constant Field Values

LeftRightArrow

static final int LeftRightArrow
See Also:
Constant Field Values

UpDownArrow

static final int UpDownArrow
See Also:
Constant Field Values

IrregularSeal1

static final int IrregularSeal1
See Also:
Constant Field Values

IrregularSeal2

static final int IrregularSeal2
See Also:
Constant Field Values

LightningBolt

static final int LightningBolt
See Also:
Constant Field Values

Heart

static final int Heart
See Also:
Constant Field Values

PictureFrame

static final int PictureFrame
See Also:
Constant Field Values

QuadArrow

static final int QuadArrow
See Also:
Constant Field Values

LeftArrowCallout

static final int LeftArrowCallout
See Also:
Constant Field Values

RightArrowCallout

static final int RightArrowCallout
See Also:
Constant Field Values

UpArrowCallout

static final int UpArrowCallout
See Also:
Constant Field Values

DownArrowCallout

static final int DownArrowCallout
See Also:
Constant Field Values

LeftRightArrowCallout

static final int LeftRightArrowCallout
See Also:
Constant Field Values

UpDownArrowCallout

static final int UpDownArrowCallout
See Also:
Constant Field Values

QuadArrowCallout

static final int QuadArrowCallout
See Also:
Constant Field Values

Bevel

static final int Bevel
See Also:
Constant Field Values

LeftBracket

static final int LeftBracket
See Also:
Constant Field Values

RightBracket

static final int RightBracket
See Also:
Constant Field Values

LeftBrace

static final int LeftBrace
See Also:
Constant Field Values

RightBrace

static final int RightBrace
See Also:
Constant Field Values

LeftUpArrow

static final int LeftUpArrow
See Also:
Constant Field Values

BentUpArrow

static final int BentUpArrow
See Also:
Constant Field Values

BentArrow

static final int BentArrow
See Also:
Constant Field Values

Star24

static final int Star24
See Also:
Constant Field Values

StripedRightArrow

static final int StripedRightArrow
See Also:
Constant Field Values

NotchedRightArrow

static final int NotchedRightArrow
See Also:
Constant Field Values

BlockArc

static final int BlockArc
See Also:
Constant Field Values

SmileyFace

static final int SmileyFace
See Also:
Constant Field Values

VerticalScroll

static final int VerticalScroll
See Also:
Constant Field Values

HorizontalScroll

static final int HorizontalScroll
See Also:
Constant Field Values

CircularArrow

static final int CircularArrow
See Also:
Constant Field Values

NotchedCircularArrow

static final int NotchedCircularArrow
See Also:
Constant Field Values

UturnArrow

static final int UturnArrow
See Also:
Constant Field Values

CurvedRightArrow

static final int CurvedRightArrow
See Also:
Constant Field Values

CurvedLeftArrow

static final int CurvedLeftArrow
See Also:
Constant Field Values

CurvedUpArrow

static final int CurvedUpArrow
See Also:
Constant Field Values

CurvedDownArrow

static final int CurvedDownArrow
See Also:
Constant Field Values

CloudCallout

static final int CloudCallout
See Also:
Constant Field Values

EllipseRibbon

static final int EllipseRibbon
See Also:
Constant Field Values

EllipseRibbon2

static final int EllipseRibbon2
See Also:
Constant Field Values

FlowChartProcess

static final int FlowChartProcess
See Also:
Constant Field Values

FlowChartDecision

static final int FlowChartDecision
See Also:
Constant Field Values

FlowChartInputOutput

static final int FlowChartInputOutput
See Also:
Constant Field Values

FlowChartPredefinedProcess

static final int FlowChartPredefinedProcess
See Also:
Constant Field Values

FlowChartInternalStorage

static final int FlowChartInternalStorage
See Also:
Constant Field Values

FlowChartDocument

static final int FlowChartDocument
See Also:
Constant Field Values

FlowChartMultidocument

static final int FlowChartMultidocument
See Also:
Constant Field Values

FlowChartTerminator

static final int FlowChartTerminator
See Also:
Constant Field Values

FlowChartPreparation

static final int FlowChartPreparation
See Also:
Constant Field Values

FlowChartManualInput

static final int FlowChartManualInput
See Also:
Constant Field Values

FlowChartManualOperation

static final int FlowChartManualOperation
See Also:
Constant Field Values

FlowChartConnector

static final int FlowChartConnector
See Also:
Constant Field Values

FlowChartPunchedCard

static final int FlowChartPunchedCard
See Also:
Constant Field Values

FlowChartPunchedTape

static final int FlowChartPunchedTape
See Also:
Constant Field Values

FlowChartSummingJunction

static final int FlowChartSummingJunction
See Also:
Constant Field Values

FlowChartOr

static final int FlowChartOr
See Also:
Constant Field Values

FlowChartCollate

static final int FlowChartCollate
See Also:
Constant Field Values

FlowChartSort

static final int FlowChartSort
See Also:
Constant Field Values

FlowChartExtract

static final int FlowChartExtract
See Also:
Constant Field Values

FlowChartMerge

static final int FlowChartMerge
See Also:
Constant Field Values

FlowChartOfflineStorage

static final int FlowChartOfflineStorage
See Also:
Constant Field Values

FlowChartOnlineStorage

static final int FlowChartOnlineStorage
See Also:
Constant Field Values

FlowChartMagneticTape

static final int FlowChartMagneticTape
See Also:
Constant Field Values

FlowChartMagneticDisk

static final int FlowChartMagneticDisk
See Also:
Constant Field Values

FlowChartMagneticDrum

static final int FlowChartMagneticDrum
See Also:
Constant Field Values

FlowChartDisplay

static final int FlowChartDisplay
See Also:
Constant Field Values

FlowChartDelay

static final int FlowChartDelay
See Also:
Constant Field Values

TextPlainText

static final int TextPlainText
See Also:
Constant Field Values

TextStop

static final int TextStop
See Also:
Constant Field Values

TextTriangle

static final int TextTriangle
See Also:
Constant Field Values

TextTriangleInverted

static final int TextTriangleInverted
See Also:
Constant Field Values

TextChevron

static final int TextChevron
See Also:
Constant Field Values

TextChevronInverted

static final int TextChevronInverted
See Also:
Constant Field Values

TextRingInside

static final int TextRingInside
See Also:
Constant Field Values

TextRingOutside

static final int TextRingOutside
See Also:
Constant Field Values

TextArchUpCurve

static final int TextArchUpCurve
See Also:
Constant Field Values

TextArchDownCurve

static final int TextArchDownCurve
See Also:
Constant Field Values

TextCircleCurve

static final int TextCircleCurve
See Also:
Constant Field Values

TextButtonCurve

static final int TextButtonCurve
See Also:
Constant Field Values

TextArchUpPour

static final int TextArchUpPour
See Also:
Constant Field Values

TextArchDownPour

static final int TextArchDownPour
See Also:
Constant Field Values

TextCirclePour

static final int TextCirclePour
See Also:
Constant Field Values

TextButtonPour

static final int TextButtonPour
See Also:
Constant Field Values

TextCurveUp

static final int TextCurveUp
See Also:
Constant Field Values

TextCurveDown

static final int TextCurveDown
See Also:
Constant Field Values

TextCascadeUp

static final int TextCascadeUp
See Also:
Constant Field Values

TextCascadeDown

static final int TextCascadeDown
See Also:
Constant Field Values

TextWave1

static final int TextWave1
See Also:
Constant Field Values

TextWave2

static final int TextWave2
See Also:
Constant Field Values

TextWave3

static final int TextWave3
See Also:
Constant Field Values

TextWave4

static final int TextWave4
See Also:
Constant Field Values

TextInflate

static final int TextInflate
See Also:
Constant Field Values

TextDeflate

static final int TextDeflate
See Also:
Constant Field Values

TextInflateBottom

static final int TextInflateBottom
See Also:
Constant Field Values

TextDeflateBottom

static final int TextDeflateBottom
See Also:
Constant Field Values

TextInflateTop

static final int TextInflateTop
See Also:
Constant Field Values

TextDeflateTop

static final int TextDeflateTop
See Also:
Constant Field Values

TextDeflateInflate

static final int TextDeflateInflate
See Also:
Constant Field Values

TextDeflateInflateDeflate

static final int TextDeflateInflateDeflate
See Also:
Constant Field Values

TextFadeRight

static final int TextFadeRight
See Also:
Constant Field Values

TextFadeLeft

static final int TextFadeLeft
See Also:
Constant Field Values

TextFadeUp

static final int TextFadeUp
See Also:
Constant Field Values

TextFadeDown

static final int TextFadeDown
See Also:
Constant Field Values

TextSlantUp

static final int TextSlantUp
See Also:
Constant Field Values

TextSlantDown

static final int TextSlantDown
See Also:
Constant Field Values

TextCanUp

static final int TextCanUp
See Also:
Constant Field Values

TextCanDown

static final int TextCanDown
See Also:
Constant Field Values

FlowChartAlternateProcess

static final int FlowChartAlternateProcess
See Also:
Constant Field Values

FlowChartOffpageConnector

static final int FlowChartOffpageConnector
See Also:
Constant Field Values

Callout90

static final int Callout90
See Also:
Constant Field Values

AccentCallout90

static final int AccentCallout90
See Also:
Constant Field Values

BorderCallout90

static final int BorderCallout90
See Also:
Constant Field Values

AccentBorderCallout90

static final int AccentBorderCallout90
See Also:
Constant Field Values

LeftRightUpArrow

static final int LeftRightUpArrow
See Also:
Constant Field Values

Sun

static final int Sun
See Also:
Constant Field Values

Moon

static final int Moon
See Also:
Constant Field Values

BracketPair

static final int BracketPair
See Also:
Constant Field Values

BracePair

static final int BracePair
See Also:
Constant Field Values

Star4

static final int Star4
See Also:
Constant Field Values

DoubleWave

static final int DoubleWave
See Also:
Constant Field Values

ActionButtonBlank

static final int ActionButtonBlank
See Also:
Constant Field Values

ActionButtonHome

static final int ActionButtonHome
See Also:
Constant Field Values

ActionButtonHelp

static final int ActionButtonHelp
See Also:
Constant Field Values

ActionButtonInformation

static final int ActionButtonInformation
See Also:
Constant Field Values

ActionButtonForwardNext

static final int ActionButtonForwardNext
See Also:
Constant Field Values

ActionButtonBackPrevious

static final int ActionButtonBackPrevious
See Also:
Constant Field Values

ActionButtonEnd

static final int ActionButtonEnd
See Also:
Constant Field Values

ActionButtonBeginning

static final int ActionButtonBeginning
See Also:
Constant Field Values

ActionButtonReturn

static final int ActionButtonReturn
See Also:
Constant Field Values

ActionButtonDocument

static final int ActionButtonDocument
See Also:
Constant Field Values

ActionButtonSound

static final int ActionButtonSound
See Also:
Constant Field Values

ActionButtonMovie

static final int ActionButtonMovie
See Also:
Constant Field Values

HostControl

static final int HostControl
See Also:
Constant Field Values

TextBox

static final int TextBox
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Sheet

All Superinterfaces:
ShapeContainer
All Known Subinterfaces:
MasterSheet, Notes, Slide
public interface Sheet
extends ShapeContainer

Common parent of Slides, Notes and Masters

Method Summary
Background | getBackground()
MasterSheet | getMasterSheet()
SlideShow | getSlideShow()
Methods inherited from interface org.apache.poi.sl.usermodel.ShapeContainer
addShape, getShapes, removeShape

Method Detail

getSlideShow

SlideShow getSlideShow()

getMasterSheet

MasterSheet getMasterSheet()

getBackground

Background getBackground()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface SimpleShape

All Superinterfaces:
Shape
All Known Subinterfaces:
AutoShape, Line, Picture, TextBox
public interface SimpleShape
extends Shape

Method Summary
Fill | getFill()
Hyperlink | getHyperlink()
LineStyle | getLineStyle()
void | setHyperlink(Hyperlink hyperlink)
Methods inherited from interface org.apache.poi.sl.usermodel.Shape
getAnchor, getParent, getShapeType, moveTo, setAnchor

Method Detail

getFill

Fill getFill()

getLineStyle

LineStyle getLineStyle()

getHyperlink

Hyperlink getHyperlink()

setHyperlink

void setHyperlink(Hyperlink hyperlink)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Slide

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface Slide

All Superinterfaces:
ShapeContainer, Sheet
public interface Slide
extends Sheet

Method Summary
boolean | getFollowMasterBackground()
boolean | getFollowMasterColourScheme()
boolean | getFollowMasterObjects()
Notes | getNotes()
void | setFollowMasterBackground(boolean follow)
void | setFollowMasterColourScheme(boolean follow)
void | setFollowMasterObjects(boolean follow)
void | setNotes(Notes notes)
Methods inherited from interface org.apache.poi.sl.usermodel.Sheet
getBackground, getMasterSheet, getSlideShow
Methods inherited from interface org.apache.poi.sl.usermodel.ShapeContainer
addShape, getShapes, removeShape

Method Detail

getNotes

Notes getNotes()

setNotes

void setNotes(Notes notes)

getFollowMasterBackground

boolean getFollowMasterBackground()

setFollowMasterBackground

void setFollowMasterBackground(boolean follow)

getFollowMasterColourScheme

boolean getFollowMasterColourScheme()

setFollowMasterColourScheme

void setFollowMasterColourScheme(boolean follow)

getFollowMasterObjects

boolean getFollowMasterObjects()

setFollowMasterObjects

void setFollowMasterObjects(boolean follow)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SlideShow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface SlideShow

public interface SlideShow

Method Summary
MasterSheet | createMasterSheet()
Slide | createSlide()
MasterSheet[] | getMasterSheet()
Resources | getResources()
Slide[] | getSlides()

Method Detail

createSlide

Slide createSlide()
                  throws java.io.IOException
Throws:
java.io.IOException

createMasterSheet

MasterSheet createMasterSheet()
                              throws java.io.IOException
Throws:
java.io.IOException

getSlides

Slide[] getSlides()

getMasterSheet

MasterSheet[] getMasterSheet()

getResources

Resources getResources()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface TextBox

All Superinterfaces:
AutoShape, Shape, SimpleShape
public interface TextBox
extends AutoShape

Method Summary
Methods inherited from interface org.apache.poi.sl.usermodel.AutoShape
getTextRun
Methods inherited from interface org.apache.poi.sl.usermodel.SimpleShape
getFill, getHyperlink, getLineStyle, setHyperlink
Methods inherited from interface org.apache.poi.sl.usermodel.Shape
getAnchor, getParent, getShapeType, moveTo, setAnchor

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextRun

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.sl.usermodel
Interface TextRun

public interface TextRun

Some text. TODO - decide on how we do rich text stuff

Method Summary
java.lang.String | getText()
void | setText(java.lang.String text)

Method Detail

getText

java.lang.String getText()

setText

void setText(java.lang.String text)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface org.apache.poi.sl.usermodel.AutoShape

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.AutoShape

Packages that use AutoShape
org.apache.poi.sl.usermodel

Uses of AutoShape in org.apache.poi.sl.usermodel

Subinterfaces of AutoShape in org.apache.poi.sl.usermodel
interface | Line
interface | TextBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Background

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Background

Packages that use Background
org.apache.poi.sl.usermodel

Uses of Background in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return Background
 Background Sheet.getBackground()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Fill

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Fill

Packages that use Fill
org.apache.poi.sl.usermodel

Uses of Fill in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return Fill
 Fill SimpleShape.getFill()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.FontCollection

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.FontCollection

Packages that use FontCollection
org.apache.poi.sl.usermodel

Uses of FontCollection in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return FontCollection
 FontCollection Resources.getFontCollection()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Hyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Hyperlink

Packages that use Hyperlink
org.apache.poi.sl.usermodel

Uses of Hyperlink in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return Hyperlink
 Hyperlink SimpleShape.getHyperlink()

Methods in org.apache.poi.sl.usermodel with parameters of type Hyperlink
 void SimpleShape.setHyperlink(Hyperlink hyperlink)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Line

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Line

No usage of org.apache.poi.sl.usermodel.Line

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.LineStyle

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.LineStyle

Packages that use LineStyle
org.apache.poi.sl.usermodel

Uses of LineStyle in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return LineStyle
 LineStyle SimpleShape.getLineStyle()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.MasterSheet

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.MasterSheet

Packages that use MasterSheet
org.apache.poi.sl.usermodel

Uses of MasterSheet in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return MasterSheet
MasterSheet | SlideShow.createMasterSheet()
MasterSheet[] | SlideShow.getMasterSheet()
MasterSheet | Sheet.getMasterSheet()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Notes

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Notes

Packages that use Notes
org.apache.poi.sl.usermodel

Uses of Notes in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return Notes
 Notes Slide.getNotes()

Methods in org.apache.poi.sl.usermodel with parameters of type Notes
 void Slide.setNotes(Notes notes)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Picture

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Picture

No usage of org.apache.poi.sl.usermodel.Picture

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.PictureData

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.PictureData

Packages that use PictureData
org.apache.poi.sl.usermodel

Uses of PictureData in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return PictureData
PictureData[] | Resources.getPictureData()
PictureData | Picture.getPictureData()

Methods in org.apache.poi.sl.usermodel with parameters of type PictureData
 int Resources.addPictureData(PictureData pict)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Resources

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Resources

Packages that use Resources
org.apache.poi.sl.usermodel

Uses of Resources in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return Resources
 Resources SlideShow.getResources()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Shape

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Shape

Packages that use Shape
org.apache.poi.sl.usermodel

Uses of Shape in org.apache.poi.sl.usermodel

Subinterfaces of Shape in org.apache.poi.sl.usermodel
interface | AutoShape
interface | Background
interface | Line
interface | Picture
interface | SimpleShape
interface | TextBox

Methods in org.apache.poi.sl.usermodel that return Shape
Shape | Shape.getParent()
Shape[] | ShapeContainer.getShapes()

Methods in org.apache.poi.sl.usermodel with parameters of type Shape
void | ShapeContainer.addShape(Shape shape)
boolean | ShapeContainer.removeShape(Shape shape)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.ShapeContainer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.ShapeContainer

Packages that use ShapeContainer
org.apache.poi.sl.usermodel

Uses of ShapeContainer in org.apache.poi.sl.usermodel

Subinterfaces of ShapeContainer in org.apache.poi.sl.usermodel
interface | MasterSheet
interface | Notes
interface | ShapeGroup
interface | Sheet Common parent of Slides, Notes and Masters
interface | Slide

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.ShapeGroup

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.ShapeGroup

No usage of org.apache.poi.sl.usermodel.ShapeGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.ShapeTypes

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.ShapeTypes

Packages that use ShapeTypes
org.apache.poi.hslf.model

Uses of ShapeTypes in org.apache.poi.hslf.model

Classes in org.apache.poi.hslf.model that implement ShapeTypes
 class ShapeTypes
Contains all known shape types in PowerPoint

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Sheet

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Sheet

Packages that use Sheet
org.apache.poi.sl.usermodel

Uses of Sheet in org.apache.poi.sl.usermodel

Subinterfaces of Sheet in org.apache.poi.sl.usermodel
interface | MasterSheet
interface | Notes
interface | Slide

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.SimpleShape

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.SimpleShape

Packages that use SimpleShape
org.apache.poi.sl.usermodel

Uses of SimpleShape in org.apache.poi.sl.usermodel

Subinterfaces of SimpleShape in org.apache.poi.sl.usermodel
interface | AutoShape
interface | Line
interface | Picture
interface | TextBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.Slide

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.Slide

Packages that use Slide
org.apache.poi.sl.usermodel

Uses of Slide in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return Slide
Slide | SlideShow.createSlide()
Slide[] | SlideShow.getSlides()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.SlideShow

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.SlideShow

Packages that use SlideShow
org.apache.poi.sl.usermodel

Uses of SlideShow in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return SlideShow
 SlideShow Sheet.getSlideShow()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.TextBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.TextBox

No usage of org.apache.poi.sl.usermodel.TextBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.sl.usermodel.TextRun

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.sl.usermodel.TextRun

Packages that use TextRun
org.apache.poi.sl.usermodel

Uses of TextRun in org.apache.poi.sl.usermodel

Methods in org.apache.poi.sl.usermodel that return TextRun
TextRun | Notes.getTextRun()
TextRun | AutoShape.getTextRun()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.ss
Enums
SpreadsheetVersion


org.apache.poi.ss

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss

Enum Summary
SpreadsheetVersion This enum allows spreadsheets from multiple Excel versions to be handled by the common code.


org.apache.poi.ss Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss

Package Hierarchies:
All Packages

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.ss.SpreadsheetVersion


Uses of Package org.apache.poi.ss

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss

Packages that use org.apache.poi.ss
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss |
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.util |
org.apache.poi.xssf.usermodel |

Classes in org.apache.poi.ss used by org.apache.poi.hssf.usermodel
SpreadsheetVersion
This enum allows spreadsheets from multiple Excel versions to be handled by the common code.

Classes in org.apache.poi.ss used by org.apache.poi.ss
SpreadsheetVersion
This enum allows spreadsheets from multiple Excel versions to be handled by the common code.

Classes in org.apache.poi.ss used by org.apache.poi.ss.formula
SpreadsheetVersion
This enum allows spreadsheets from multiple Excel versions to be handled by the common code.

Classes in org.apache.poi.ss used by org.apache.poi.ss.util
SpreadsheetVersion
This enum allows spreadsheets from multiple Excel versions to be handled by the common code.

Classes in org.apache.poi.ss used by org.apache.poi.xssf.usermodel
SpreadsheetVersion
This enum allows spreadsheets from multiple Excel versions to be handled by the common code.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SpreadsheetVersion

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss
Enum SpreadsheetVersion

java.lang.Object
    extended by  java.lang.Enum<SpreadsheetVersion>
        extended by  org.apache.poi.ss.SpreadsheetVersion
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<SpreadsheetVersion>
public enum SpreadsheetVersion
extends java.lang.Enum<SpreadsheetVersion>

This enum allows spreadsheets from multiple Excel versions to be handled by the common code. Properties of this enum correspond to attributes of the spreadsheet that are easily discernable to the user. It is not intended to deal with low-level issues like file formats.

Author:
Josh Micich, Yegor Kozlov

Enum Constant Summary
EXCEL2007
Excel2007 The total number of available columns is 16K (2^14) The total number of available rows is 1M (2^20) The maximum number of arguments to a function is 255 Number of conditional format conditions on a cell is unlimited (actually limited by available memory in Excel) Length of text cell contents is 32767
EXCEL97
Excel97 format aka BIFF8 The total number of available columns is 256 (2^8) The total number of available rows is 64k (2^16) The maximum number of arguments to a function is 30 Number of conditional format conditions on a cell is 3 Length of text cell contents is 32767
Method Summary
int | getLastColumnIndex()
java.lang.String | getLastColumnName()
int | getLastRowIndex()
int | getMaxColumns()
int | getMaxConditionalFormats()
int | getMaxFunctionArgs()
int | getMaxRows()
int | getMaxTextLength()
static SpreadsheetVersion | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static SpreadsheetVersion[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

EXCEL97

public static final SpreadsheetVersion EXCEL97
Excel97 format aka BIFF8
  • The total number of available columns is 256 (2^8)
  • The total number of available rows is 64k (2^16)
  • The maximum number of arguments to a function is 30
  • Number of conditional format conditions on a cell is 3
  • Length of text cell contents is 32767

EXCEL2007

public static final SpreadsheetVersion EXCEL2007
Excel2007
  • The total number of available columns is 16K (2^14)
  • The total number of available rows is 1M (2^20)
  • The maximum number of arguments to a function is 255
  • Number of conditional format conditions on a cell is unlimited (actually limited by available memory in Excel)
  • Length of text cell contents is 32767

Method Detail

values

public static SpreadsheetVersion[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (SpreadsheetVersion c : SpreadsheetVersion.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SpreadsheetVersion valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getMaxRows

public int getMaxRows()
Returns:
the maximum number of usable rows in each spreadsheet

getLastRowIndex

public int getLastRowIndex()
Returns:
the last (maximum) valid row index, equals to getMaxRows() - 1

getMaxColumns

public int getMaxColumns()
Returns:
the maximum number of usable columns in each spreadsheet

getLastColumnIndex

public int getLastColumnIndex()
Returns:
the last (maximum) valid column index, equals to getMaxColumns() - 1

getMaxFunctionArgs

public int getMaxFunctionArgs()
Returns:
the maximum number arguments that can be passed to a multi-arg function (e.g. COUNTIF)

getMaxConditionalFormats

public int getMaxConditionalFormats()
Returns:
the maximum number of conditional format conditions on a cell

getLastColumnName

public java.lang.String getLastColumnName()
Returns:
the last valid column index in a ALPHA-26 representation (IV or XFD).

getMaxTextLength

public int getMaxTextLength()
Returns:
the maximum length of a text cell
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class org.apache.poi.ss.SpreadsheetVersion

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.SpreadsheetVersion

Packages that use SpreadsheetVersion
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss |
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.util |
org.apache.poi.xssf.usermodel |

Uses of SpreadsheetVersion in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return SpreadsheetVersion
 SpreadsheetVersion HSSFEvaluationWorkbook.getSpreadsheetVersion()

Uses of SpreadsheetVersion in org.apache.poi.ss

Methods in org.apache.poi.ss that return SpreadsheetVersion
static SpreadsheetVersion | SpreadsheetVersion.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static SpreadsheetVersion[] | SpreadsheetVersion.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of SpreadsheetVersion in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return SpreadsheetVersion
 SpreadsheetVersion FormulaParsingWorkbook.getSpreadsheetVersion()
Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)

Constructors in org.apache.poi.ss.formula with parameters of type SpreadsheetVersion
SharedFormula(SpreadsheetVersion ssVersion)

Uses of SpreadsheetVersion in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util with parameters of type SpreadsheetVersion
static boolean | CellReference.cellReferenceIsWithinRange(java.lang.String colStr, java.lang.String rowStr, SpreadsheetVersion ssVersion) Used to decide whether a name of the form "[A-Z]*[0-9]*" that appears in a formula can be interpreted as a cell reference.
static CellReference.NameType | CellReference.classifyCellReference(java.lang.String str, SpreadsheetVersion ssVersion) Classifies an identifier as either a simple (2D) cell reference or a named range name
static boolean | CellReference.isColumnWithnRange(java.lang.String colStr, SpreadsheetVersion ssVersion)
static boolean | CellReference.isRowWithnRange(java.lang.String rowStr, SpreadsheetVersion ssVersion)
void | CellRangeAddressBase.validate(SpreadsheetVersion ssVersion) Validate the range limits against the supplied version of Excel

Uses of SpreadsheetVersion in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return SpreadsheetVersion
 SpreadsheetVersion XSSFEvaluationWorkbook.getSpreadsheetVersion()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ExcelExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.extractor
Interface ExcelExtractor

All Known Implementing Classes:
ExcelExtractor, XSSFExcelExtractor
public interface ExcelExtractor

Common interface for Excel text extractors, covering HSSF and XSSF

Method Summary
java.lang.String | getText() Retreives the text contents of the file
void | setFormulasNotResults(boolean formulasNotResults) Should we return the formula itself, and not the result it produces? Default is false
void | setIncludeCellComments(boolean includeCellComments) Should cell comments be included? Default is false
void | setIncludeSheetNames(boolean includeSheetNames) Should sheet names be included? Default is true

Method Detail

setIncludeSheetNames

void setIncludeSheetNames(boolean includeSheetNames)
Should sheet names be included? Default is true

setFormulasNotResults

void setFormulasNotResults(boolean formulasNotResults)
Should we return the formula itself, and not the result it produces? Default is false

setIncludeCellComments

void setIncludeCellComments(boolean includeCellComments)
Should cell comments be included? Default is false

getText

java.lang.String getText()
Retreives the text contents of the file

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.extractor
Interfaces
ExcelExtractor


org.apache.poi.ss.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.extractor

Interface Summary
ExcelExtractor Common interface for Excel text extractors, covering HSSF and XSSF


org.apache.poi.ss.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.extractor

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.apache.poi.ss.extractor.ExcelExtractor


Uses of Package org.apache.poi.ss.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.extractor

Packages that use org.apache.poi.ss.extractor
org.apache.poi.hssf.extractor
org.apache.poi.xssf.extractor

Classes in org.apache.poi.ss.extractor used by org.apache.poi.hssf.extractor
ExcelExtractor
Common interface for Excel text extractors, covering HSSF and XSSF

Classes in org.apache.poi.ss.extractor used by org.apache.poi.xssf.extractor
ExcelExtractor
Common interface for Excel text extractors, covering HSSF and XSSF

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.extractor.ExcelExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.extractor.ExcelExtractor

Packages that use ExcelExtractor
org.apache.poi.hssf.extractor
org.apache.poi.xssf.extractor

Uses of ExcelExtractor in org.apache.poi.hssf.extractor

Classes in org.apache.poi.hssf.extractor that implement ExcelExtractor
 class ExcelExtractor
A text extractor for Excel files.

Uses of ExcelExtractor in org.apache.poi.xssf.extractor

Classes in org.apache.poi.xssf.extractor that implement ExcelExtractor
 class XSSFExcelExtractor
Helper class to extract text from an OOXML Excel file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CellDateFormatter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellDateFormatter

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatter
        extended by  org.apache.poi.ss.format.CellDateFormatter

public class CellDateFormatter
extends CellFormatter

Formats a date value.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
Fields inherited from class org.apache.poi.ss.format.CellFormatter
format, LOCALE
Constructor Summary
CellDateFormatter(java.lang.String format)
Creates a new date formatter with the given specification.
Method Summary
void | formatValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according the format string.
void | simpleValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according to the type, in the most basic way.
Methods inherited from class org.apache.poi.ss.format.CellFormatter
format, simpleFormat
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellDateFormatter

public CellDateFormatter(java.lang.String format)
Creates a new date formatter with the given specification.

Parameters:
format - The format.
Method Detail

formatValue

public void formatValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
Format a value according the format string.

Specified by:
formatValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.

simpleValue

public void simpleValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
Format a value according to the type, in the most basic way.

For a date, this is "mm/d/y".

Specified by:
simpleValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CellElapsedFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellElapsedFormatter

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatter
        extended by  org.apache.poi.ss.format.CellElapsedFormatter

public class CellElapsedFormatter
extends CellFormatter

This class implements printing out an elapsed time format.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
Fields inherited from class org.apache.poi.ss.format.CellFormatter
format, LOCALE
Constructor Summary
CellElapsedFormatter(java.lang.String pattern)
Creates a elapsed time formatter.
Method Summary
void | formatValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according the format string.
void | simpleValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according to the type, in the most basic way.
Methods inherited from class org.apache.poi.ss.format.CellFormatter
format, simpleFormat
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellElapsedFormatter

public CellElapsedFormatter(java.lang.String pattern)
Creates a elapsed time formatter.

Parameters:
pattern - The pattern to parse.
Method Detail

formatValue

public void formatValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
Format a value according the format string.

Specified by:
formatValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.

simpleValue

public void simpleValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
Format a value according to the type, in the most basic way.

For a date, this is "mm/d/y".

Specified by:
simpleValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellFormat

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellFormat

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormat

public class CellFormat
extends java.lang.Object

Format a value according to the standard Excel behavior. This "standard" is not explicitly documented by Microsoft, so the behavior is determined by experimentation; see the tests.

An Excel format has up to four parts, separated by semicolons. Each part specifies what to do with particular kinds of values, depending on the number of parts given:

One part (example: [Green]#.##)
If the value is a number, display according to this one part (example: green text, with up to two decimal points). If the value is text, display it as is.
Two parts (example: [Green]#.##;[Red]#.##)
If the value is a positive number or zero, display according to the first part (example: green text, with up to two decimal points); if it is a negative number, display according to the second part (example: red text, with up to two decimal points). If the value is text, display it as is.
Three parts (example: [Green]#.##;[Black]#.##;[Red]#.##)
If the value is a positive number, display according to the first part (example: green text, with up to two decimal points); if it is zero, display according to the second part (example: black text, with up to two decimal points); if it is a negative number, display according to the third part (example: red text, with up to two decimal points). If the value is text, display it as is.
Four parts (example: [Green]#.##;[Black]#.##;[Red]#.##;[@])
If the value is a positive number, display according to the first part (example: green text, with up to two decimal points); if it is zero, display according to the second part (example: black text, with up to two decimal points); if it is a negative number, display according to the third part (example: red text, with up to two decimal points). If the value is text, display according to the fourth part (example: text in the cell's usual color, with the text value surround by brackets).

In addition to these, there is a general format that is used when no format is specified. This formatting is presented by the GENERAL_FORMAT object. TODO Merge this with DataFormatter so we only have one set of code for formatting numbers.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
static CellFormat GENERAL_FORMAT
Format a value as it would be were no format specified.
Method Summary
CellFormatResult | apply(Cell c) Fetches the appropriate value from the cell, and returns the result of applying it to the appropriate format.
CellFormatResult | apply(javax.swing.JLabel label, Cell c) Fetches the appropriate value from the cell, and uses the result, setting the text and color of a label before returning the result.
CellFormatResult | apply(javax.swing.JLabel label, java.lang.Object value) Uses the result of applying this format to the value, setting the text and color of a label before returning the result.
CellFormatResult | apply(java.lang.Object value) Returns the result of applying the format to the given value.
boolean | equals(java.lang.Object obj) Returns true if the other object is a CellFormat object with the same format.
static CellFormat | getInstance(java.lang.String format) Returns a CellFormat that applies the given format.
int | hashCode() Returns a hash code for the format.
static int | ultimateType(Cell cell) Returns the ultimate cell type, following the results of formulas.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

GENERAL_FORMAT

public static final CellFormat GENERAL_FORMAT
Format a value as it would be were no format specified. This is also used when the format specified is General.

Method Detail

getInstance

public static CellFormat getInstance(java.lang.String format)
Returns a CellFormat that applies the given format. Two calls with the same format may or may not return the same object.

Parameters:
format - The format.
Returns:
A CellFormat that applies the given format.

apply

public CellFormatResult apply(java.lang.Object value)
Returns the result of applying the format to the given value. If the value is a number (a type of Number object), the correct number format type is chosen; otherwise it is considered a text object.

Parameters:
value - The value
Returns:
The result, in a CellFormatResult.

apply

public CellFormatResult apply(Cell c)
Fetches the appropriate value from the cell, and returns the result of applying it to the appropriate format. For formula cells, the computed value is what is used.

Parameters:
c - The cell.
Returns:
The result, in a CellFormatResult.

apply

public CellFormatResult apply(javax.swing.JLabel label,
                              java.lang.Object value)
Uses the result of applying this format to the value, setting the text and color of a label before returning the result.

Parameters:
label - The label to apply to.
value - The value to process.
Returns:
The result, in a CellFormatResult.

apply

public CellFormatResult apply(javax.swing.JLabel label,
                              Cell c)
Fetches the appropriate value from the cell, and uses the result, setting the text and color of a label before returning the result.

Parameters:
label - The label to apply to.
c - The cell.
Returns:
The result, in a CellFormatResult.

ultimateType

public static int ultimateType(Cell cell)
Returns the ultimate cell type, following the results of formulas. If the cell is a Cell.CELL_TYPE_FORMULA, this returns the result of Cell.getCachedFormulaResultType(). Otherwise this returns the result of Cell.getCellType().

Parameters:
cell - The cell.
Returns:
The ultimate type of this cell.

equals

public boolean equals(java.lang.Object obj)
Returns true if the other object is a CellFormat object with the same format.

Overrides:
equals in class java.lang.Object
Parameters:
obj - The other object.
Returns:
true if the two objects are equal.

hashCode

public int hashCode()
Returns a hash code for the format.

Overrides:
hashCode in class java.lang.Object
Returns:
A hash code for the format.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellFormatCondition

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellFormatCondition

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatCondition

public abstract class CellFormatCondition
extends java.lang.Object

This object represents a condition in a cell format.

Author:
Ken Arnold, Industrious Media LLC

Constructor Summary
CellFormatCondition()
Method Summary
static CellFormatCondition | getInstance(java.lang.String opString, java.lang.String constStr) Returns an instance of a condition object.
abstract boolean | pass(double value) Returns true if the given value passes the constraint's test.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellFormatCondition

public CellFormatCondition()
Method Detail

getInstance

public static CellFormatCondition getInstance(java.lang.String opString,
                                              java.lang.String constStr)
Returns an instance of a condition object.

Parameters:
opString - The operator as a string. One of "<", "<=", ">", ">=", "=", "==", "!=", or "<>".
constStr - The constant (such as "12").
Returns:
A condition object for the given condition.

pass

public abstract boolean pass(double value)
Returns true if the given value passes the constraint's test.

Parameters:
value - The value to compare against.
Returns:
true if the given value passes the constraint's test.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellFormatPart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellFormatPart

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatPart

public class CellFormatPart
extends java.lang.Object

Objects of this class represent a single part of a cell format expression. Each cell can have up to four of these for positive, zero, negative, and text values.

Each format part can contain a color, a condition, and will always contain a format specification. For example "[Red][>=10]#" has a color ([Red]), a condition (>=10) and a format specification (#).

This class also contains patterns for matching the subparts of format specification. These are used internally, but are made public in case other code has use for them.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
static int | COLOR_GROUP Within FORMAT_PAT, the group number for the matched color.
static java.util.regex.Pattern | COLOR_PAT Pattern for the color part of a cell format part.
static int | CONDITION_OPERATOR_GROUP Within FORMAT_PAT, the group number for the operator in the condition.
static java.util.regex.Pattern | CONDITION_PAT Pattern for the condition part of a cell format part.
static int | CONDITION_VALUE_GROUP Within FORMAT_PAT, the group number for the value in the condition.
static java.util.regex.Pattern | FORMAT_PAT Pattern for an entire cell single part.
static int | SPECIFICATION_GROUP Within FORMAT_PAT, the group number for the format specification.
static java.util.regex.Pattern | SPECIFICATION_PAT Pattern for the format specification part of a cell format part.
Constructor Summary
CellFormatPart(java.lang.String desc)
Create an object to represent a format part.
Method Summary
boolean | applies(java.lang.Object valueObject) Returns true if this format part applies to the given value.
CellFormatResult | apply(javax.swing.JLabel label, java.lang.Object value) Apply this format part to the given value, applying the result to the given label.
CellFormatResult | apply(java.lang.Object value) Apply this format part to the given value.
static java.lang.String | group(java.util.regex.Matcher m, int g) Returns the string from the group, or "" if the group is null.
static java.lang.StringBuffer | parseFormat(java.lang.String fdesc, CellFormatType type, org.apache.poi.ss.format.CellFormatPart.PartHandler partHandler)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COLOR_PAT

public static final java.util.regex.Pattern COLOR_PAT
Pattern for the color part of a cell format part.

CONDITION_PAT

public static final java.util.regex.Pattern CONDITION_PAT
Pattern for the condition part of a cell format part.

SPECIFICATION_PAT

public static final java.util.regex.Pattern SPECIFICATION_PAT
Pattern for the format specification part of a cell format part.

FORMAT_PAT

public static final java.util.regex.Pattern FORMAT_PAT
Pattern for an entire cell single part.

COLOR_GROUP

public static final int COLOR_GROUP
Within FORMAT_PAT, the group number for the matched color.

CONDITION_OPERATOR_GROUP

public static final int CONDITION_OPERATOR_GROUP
Within FORMAT_PAT, the group number for the operator in the condition.

CONDITION_VALUE_GROUP

public static final int CONDITION_VALUE_GROUP
Within FORMAT_PAT, the group number for the value in the condition.

SPECIFICATION_GROUP

public static final int SPECIFICATION_GROUP
Within FORMAT_PAT, the group number for the format specification.

Constructor Detail

CellFormatPart

public CellFormatPart(java.lang.String desc)
Create an object to represent a format part.

Parameters:
desc - The string to parse.
Method Detail

applies

public boolean applies(java.lang.Object valueObject)
Returns true if this format part applies to the given value. If the value is a number and this is part has a condition, returns true only if the number passes the condition. Otherwise, this always return true.

Parameters:
valueObject - The value to evaluate.
Returns:
true if this format part applies to the given value.

apply

public CellFormatResult apply(java.lang.Object value)
Apply this format part to the given value. This returns a CellFormatResult object with the results.

Parameters:
value - The value to apply this format part to.
Returns:
A CellFormatResult object containing the results of applying the format to the value.

apply

public CellFormatResult apply(javax.swing.JLabel label,
                              java.lang.Object value)
Apply this format part to the given value, applying the result to the given label.

Parameters:
label - The label
value - The value to apply this format part to.
Returns:
true if the

parseFormat

public static java.lang.StringBuffer parseFormat(java.lang.String fdesc,
                                                 CellFormatType type,
                                                 org.apache.poi.ss.format.CellFormatPart.PartHandler partHandler)

group

public static java.lang.String group(java.util.regex.Matcher m,
                                     int g)
Returns the string from the group, or "" if the group is null.

Parameters:
m - The matcher.
g - The group number.
Returns:
The group or "".
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellFormatResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellFormatResult

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatResult

public class CellFormatResult
extends java.lang.Object

This object contains the result of applying a cell format or cell format part to a value.

Author:
Ken Arnold, Industrious Media LLC
See Also:
CellFormatPart.apply(Object), CellFormat.apply(Object)

Field Summary
boolean | applies This is true if no condition was given that applied to the value, or if the condition is satisfied.
java.lang.String | text The resulting text.
java.awt.Color | textColor The color the format sets, or null if the format sets no color.
Constructor Summary
CellFormatResult(boolean applies, java.lang.String text, java.awt.Color textColor)
Creates a new format result object.
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

applies

public final boolean applies
This is true if no condition was given that applied to the value, or if the condition is satisfied. If a condition is relevant, and when applied the value fails the test, this is false.

text

public final java.lang.String text
The resulting text. This will never be null.

textColor

public final java.awt.Color textColor
The color the format sets, or null if the format sets no color. This will always be null if applies is false.

Constructor Detail

CellFormatResult

public CellFormatResult(boolean applies,
                        java.lang.String text,
                        java.awt.Color textColor)
Creates a new format result object.

Parameters:
applies - The value for applies.
text - The value for text.
textColor - The value for textColor.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellFormatter

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatter
Direct Known Subclasses:
CellDateFormatter, CellElapsedFormatter, CellGeneralFormatter, CellNumberFormatter, CellTextFormatter
public abstract class CellFormatter
extends java.lang.Object

This is the abstract supertype for the various cell formatters.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
protected java.lang.String | format The original specified format.
static java.util.Locale | LOCALE This is the locale used to get a consistent format result from which to work.
Constructor Summary
CellFormatter(java.lang.String format)
Creates a new formatter object, storing the format in format.
Method Summary
java.lang.String | format(java.lang.Object value) Formats the value, returning the resulting string.
abstract void | formatValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according the format string.
java.lang.String | simpleFormat(java.lang.Object value) Formats the value in the most basic way, returning the resulting string.
abstract void | simpleValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according to the type, in the most basic way.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

format

protected final java.lang.String format
The original specified format.

LOCALE

public static final java.util.Locale LOCALE
This is the locale used to get a consistent format result from which to work.

Constructor Detail

CellFormatter

public CellFormatter(java.lang.String format)
Creates a new formatter object, storing the format in format.

Parameters:
format - The format.
Method Detail

formatValue

public abstract void formatValue(java.lang.StringBuffer toAppendTo,
                                 java.lang.Object value)
Format a value according the format string.

Parameters:
toAppendTo - The buffer to append to.
value - The value to format.

simpleValue

public abstract void simpleValue(java.lang.StringBuffer toAppendTo,
                                 java.lang.Object value)
Format a value according to the type, in the most basic way.

Parameters:
toAppendTo - The buffer to append to.
value - The value to format.

format

public java.lang.String format(java.lang.Object value)
Formats the value, returning the resulting string.

Parameters:
value - The value to format.
Returns:
The value, formatted.

simpleFormat

public java.lang.String simpleFormat(java.lang.Object value)
Formats the value in the most basic way, returning the resulting string.

Parameters:
value - The value to format.
Returns:
The value, formatted.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellFormatType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.format
Enum CellFormatType

java.lang.Object
    extended by  java.lang.Enum<CellFormatType>
        extended by  org.apache.poi.ss.format.CellFormatType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<CellFormatType>
public enum CellFormatType
extends java.lang.Enum<CellFormatType>

The different kinds of formats that the formatter understands.

Author:
Ken Arnold, Industrious Media LLC

Enum Constant Summary
DATE
A date format.
ELAPSED
An elapsed time format.
GENERAL
The general (default) format; also used for "General".
NUMBER
A numeric format.
TEXT
A text format.
Method Summary
static CellFormatType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CellFormatType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

GENERAL

public static final CellFormatType GENERAL
The general (default) format; also used for "General".

NUMBER

public static final CellFormatType NUMBER
A numeric format.

DATE

public static final CellFormatType DATE
A date format.

ELAPSED

public static final CellFormatType ELAPSED
An elapsed time format.

TEXT

public static final CellFormatType TEXT
A text format.

Method Detail

values

public static CellFormatType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (CellFormatType c : CellFormatType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static CellFormatType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


CellGeneralFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellGeneralFormatter

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatter
        extended by  org.apache.poi.ss.format.CellGeneralFormatter

public class CellGeneralFormatter
extends CellFormatter

A formatter for the default "General" cell format.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
Fields inherited from class org.apache.poi.ss.format.CellFormatter
format, LOCALE
Constructor Summary
CellGeneralFormatter()
Creates a new general formatter.
Method Summary
 void formatValue(java.lang.StringBuffer toAppendTo, java.lang.Object value)
The general style is not quite the same as any other, or any combination of others.
 void simpleValue(java.lang.StringBuffer toAppendTo, java.lang.Object value)
Equivalent to formatValue(StringBuffer,Object).
Methods inherited from class org.apache.poi.ss.format.CellFormatter
format, simpleFormat
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellGeneralFormatter

public CellGeneralFormatter()
Creates a new general formatter.

Method Detail

formatValue

public void formatValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
The general style is not quite the same as any other, or any combination of others.

Specified by:
formatValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.

simpleValue

public void simpleValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
Equivalent to formatValue(StringBuffer,Object). Format a value according to the type, in the most basic way..

Specified by:
simpleValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellNumberFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellNumberFormatter

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatter
        extended by  org.apache.poi.ss.format.CellNumberFormatter

public class CellNumberFormatter
extends CellFormatter

This class implements printing out a value using a number format.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
Fields inherited from class org.apache.poi.ss.format.CellFormatter
format, LOCALE
Constructor Summary
CellNumberFormatter(java.lang.String format)
Creates a new cell number formatter.
Method Summary
void | formatValue(java.lang.StringBuffer toAppendTo, java.lang.Object valueObject) Format a value according the format string.
void | simpleValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according to the type, in the most basic way.
Methods inherited from class org.apache.poi.ss.format.CellFormatter
format, simpleFormat
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellNumberFormatter

public CellNumberFormatter(java.lang.String format)
Creates a new cell number formatter.

Parameters:
format - The format to parse.
Method Detail

formatValue

public void formatValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object valueObject)
Format a value according the format string.

Specified by:
formatValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
valueObject - The value to format.

simpleValue

public void simpleValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
Format a value according to the type, in the most basic way.

For a number, this is "#" for integer values, and "#.#" for floating-point values.

Specified by:
simpleValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellTextFormatter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.format
Class CellTextFormatter

java.lang.Object
    extended by  org.apache.poi.ss.format.CellFormatter
        extended by  org.apache.poi.ss.format.CellTextFormatter

public class CellTextFormatter
extends CellFormatter

This class implements printing out text.

Author:
Ken Arnold, Industrious Media LLC

Field Summary
Fields inherited from class org.apache.poi.ss.format.CellFormatter
format, LOCALE
Constructor Summary
CellTextFormatter(java.lang.String format)
Method Summary
void | formatValue(java.lang.StringBuffer toAppendTo, java.lang.Object obj) Format a value according the format string.
void | simpleValue(java.lang.StringBuffer toAppendTo, java.lang.Object value) Format a value according to the type, in the most basic way.
Methods inherited from class org.apache.poi.ss.format.CellFormatter
format, simpleFormat
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellTextFormatter

public CellTextFormatter(java.lang.String format)
Method Detail

formatValue

public void formatValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object obj)
Format a value according the format string.

Specified by:
formatValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
obj - The value to format.

simpleValue

public void simpleValue(java.lang.StringBuffer toAppendTo,
                        java.lang.Object value)
Format a value according to the type, in the most basic way.

For text, this is just printing the text.

Specified by:
simpleValue in class CellFormatter
Parameters:
toAppendTo - The buffer to append to.
value - The value to format.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.format
Classes
CellDateFormatter
CellElapsedFormatter
CellFormat
CellFormatCondition
CellFormatPart
CellFormatResult
CellFormatter
CellGeneralFormatter
CellNumberFormatter
CellTextFormatter
Enums
CellFormatType


org.apache.poi.ss.format

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.format

This package contains classes that implement cell formatting

See:
Description

Class Summary
CellDateFormatter | Formats a date value.
CellElapsedFormatter | This class implements printing out an elapsed time format.
CellFormat | Format a value according to the standard Excel behavior.
CellFormatCondition | This object represents a condition in a cell format.
CellFormatPart | Objects of this class represent a single part of a cell format expression.
CellFormatResult | This object contains the result of applying a cell format or cell format part to a value.
CellFormatter | This is the abstract supertype for the various cell formatters.
CellGeneralFormatter | A formatter for the default "General" cell format.
CellNumberFormatter | This class implements printing out a value using a number format.
CellTextFormatter | This class implements printing out text.

Enum Summary
CellFormatType The different kinds of formats that the formatter understands.

Package org.apache.poi.ss.format Description

This package contains classes that implement cell formatting


org.apache.poi.ss.format Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.format

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.format.CellFormat
    • org.apache.poi.ss.format.CellFormatCondition
    • org.apache.poi.ss.format.CellFormatPart
    • org.apache.poi.ss.format.CellFormatResult
    • org.apache.poi.ss.format.CellFormatter
      • org.apache.poi.ss.format.CellDateFormatter
      • org.apache.poi.ss.format.CellElapsedFormatter
      • org.apache.poi.ss.format.CellGeneralFormatter
      • org.apache.poi.ss.format.CellNumberFormatter
      • org.apache.poi.ss.format.CellTextFormatter

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.ss.format.CellFormatType


Uses of Package org.apache.poi.ss.format

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.format

Packages that use org.apache.poi.ss.format
org.apache.poi.ss.format This package contains classes that implement cell formatting

Classes in org.apache.poi.ss.format used by org.apache.poi.ss.format
CellFormat
Format a value according to the standard Excel behavior.
CellFormatCondition
This object represents a condition in a cell format.
CellFormatResult
This object contains the result of applying a cell format or cell format part to a value.
CellFormatter
This is the abstract supertype for the various cell formatters.
CellFormatType
The different kinds of formats that the formatter understands.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellDateFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellDateFormatter

No usage of org.apache.poi.ss.format.CellDateFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellElapsedFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellElapsedFormatter

No usage of org.apache.poi.ss.format.CellElapsedFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellFormat

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellFormat

Packages that use CellFormat
org.apache.poi.ss.format This package contains classes that implement cell formatting

Uses of CellFormat in org.apache.poi.ss.format

Fields in org.apache.poi.ss.format declared as CellFormat
static CellFormat CellFormat.GENERAL_FORMAT
Format a value as it would be were no format specified.

Methods in org.apache.poi.ss.format that return CellFormat
static CellFormat CellFormat.getInstance(java.lang.String format)
Returns a CellFormat that applies the given format.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellFormatCondition

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellFormatCondition

Packages that use CellFormatCondition
org.apache.poi.ss.format This package contains classes that implement cell formatting

Uses of CellFormatCondition in org.apache.poi.ss.format

Methods in org.apache.poi.ss.format that return CellFormatCondition
static CellFormatCondition CellFormatCondition.getInstance(java.lang.String opString, java.lang.String constStr)
Returns an instance of a condition object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellFormatPart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellFormatPart

No usage of org.apache.poi.ss.format.CellFormatPart

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellFormatResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellFormatResult

Packages that use CellFormatResult
org.apache.poi.ss.format This package contains classes that implement cell formatting

Uses of CellFormatResult in org.apache.poi.ss.format

Methods in org.apache.poi.ss.format that return CellFormatResult
CellFormatResult | CellFormat.apply(Cell c) Fetches the appropriate value from the cell, and returns the result of applying it to the appropriate format.
CellFormatResult | CellFormat.apply(javax.swing.JLabel label, Cell c) Fetches the appropriate value from the cell, and uses the result, setting the text and color of a label before returning the result.
CellFormatResult | CellFormatPart.apply(javax.swing.JLabel label, java.lang.Object value) Apply this format part to the given value, applying the result to the given label.
CellFormatResult | CellFormat.apply(javax.swing.JLabel label, java.lang.Object value) Uses the result of applying this format to the value, setting the text and color of a label before returning the result.
CellFormatResult | CellFormatPart.apply(java.lang.Object value) Apply this format part to the given value.
CellFormatResult | CellFormat.apply(java.lang.Object value) Returns the result of applying the format to the given value.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellFormatter

Packages that use CellFormatter
org.apache.poi.ss.format This package contains classes that implement cell formatting

Uses of CellFormatter in org.apache.poi.ss.format

Subclasses of CellFormatter in org.apache.poi.ss.format
class | CellDateFormatter Formats a date value.
class | CellElapsedFormatter This class implements printing out an elapsed time format.
class | CellGeneralFormatter A formatter for the default "General" cell format.
class | CellNumberFormatter This class implements printing out a value using a number format.
class | CellTextFormatter This class implements printing out text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellFormatType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellFormatType

Packages that use CellFormatType
org.apache.poi.ss.format This package contains classes that implement cell formatting

Uses of CellFormatType in org.apache.poi.ss.format

Methods in org.apache.poi.ss.format that return CellFormatType
static CellFormatType | CellFormatType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CellFormatType[] | CellFormatType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.format with parameters of type CellFormatType
static java.lang.StringBuffer CellFormatPart.parseFormat(java.lang.String fdesc, CellFormatType type, org.apache.poi.ss.format.CellFormatPart.PartHandler partHandler)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellGeneralFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellGeneralFormatter

No usage of org.apache.poi.ss.format.CellGeneralFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellNumberFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellNumberFormatter

No usage of org.apache.poi.ss.format.CellNumberFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.format.CellTextFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.format.CellTextFormatter

No usage of org.apache.poi.ss.format.CellTextFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CollaboratingWorkbooksEnvironment

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class CollaboratingWorkbooksEnvironment

java.lang.Object
    extended by  org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment

public final class CollaboratingWorkbooksEnvironment
extends java.lang.Object

Manages a collection of WorkbookEvaluators, in order to support evaluation of formulas across spreadsheets.

For POI internal use only

Author:
Josh Micich

Nested Class Summary
static class CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
Field Summary
static CollaboratingWorkbooksEnvironment EMPTY
Method Summary
WorkbookEvaluator | getWorkbookEvaluator(java.lang.String workbookName)
static void | setup(java.lang.String[] workbookNames, WorkbookEvaluator[] evaluators)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EMPTY

public static final CollaboratingWorkbooksEnvironment EMPTY
Method Detail

setup

public static void setup(java.lang.String[] workbookNames,
                         WorkbookEvaluator[] evaluators)

getWorkbookEvaluator

public WorkbookEvaluator getWorkbookEvaluator(java.lang.String workbookName)
                                       throws CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
Throws:
CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollaboratingWorkbooksEnvironment.WorkbookNotFoundException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class CollaboratingWorkbooksEnvironment.WorkbookNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
All Implemented Interfaces:
java.io.Serializable
Enclosing class:
CollaboratingWorkbooksEnvironment
public static final class CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
extends java.lang.Exception

See Also:
Serialized Form

Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvaluationCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface EvaluationCell

public interface EvaluationCell

Abstracts a cell for the purpose of formula evaluation. This interface represents both formula and non-formula cells.
For POI internal use only

Author:
Josh Micich

Method Summary
boolean | getBooleanCellValue()
int | getCachedFormulaResultType()
int | getCellType()
int | getColumnIndex()
int | getErrorCellValue()
java.lang.Object | getIdentityKey()
double | getNumericCellValue()
int | getRowIndex()
EvaluationSheet | getSheet()
java.lang.String | getStringCellValue()

Method Detail

getIdentityKey

java.lang.Object getIdentityKey()
Returns:
an Object that identifies the underlying cell, suitable for use as a key in a HashMap

getSheet

EvaluationSheet getSheet()

getRowIndex

int getRowIndex()

getColumnIndex

int getColumnIndex()

getCellType

int getCellType()

getNumericCellValue

double getNumericCellValue()

getStringCellValue

java.lang.String getStringCellValue()

getBooleanCellValue

boolean getBooleanCellValue()

getErrorCellValue

int getErrorCellValue()

getCachedFormulaResultType

int getCachedFormulaResultType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvaluationName

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface EvaluationName

public interface EvaluationName

Abstracts a name record for formula evaluation.
For POI internal use only

Author:
Josh Micich

Method Summary
NamePtg | createPtg()
Ptg[] | getNameDefinition()
java.lang.String | getNameText()
boolean | hasFormula()
boolean | isFunctionName()
boolean | isRange()

Method Detail

getNameText

java.lang.String getNameText()

isFunctionName

boolean isFunctionName()

hasFormula

boolean hasFormula()

getNameDefinition

Ptg[] getNameDefinition()

isRange

boolean isRange()

createPtg

NamePtg createPtg()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvaluationSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface EvaluationSheet

public interface EvaluationSheet

Abstracts a sheet for the purpose of formula evaluation.
For POI internal use only

Author:
Josh Micich

Method Summary
 EvaluationCell getCell(int rowIndex, int columnIndex)

Method Detail

getCell

EvaluationCell getCell(int rowIndex,
                       int columnIndex)
Returns:
null if there is no cell at the specified coordinates
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvaluationWorkbook.ExternalName

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class EvaluationWorkbook.ExternalName

java.lang.Object
    extended by  org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName
Enclosing interface:
EvaluationWorkbook
public static class EvaluationWorkbook.ExternalName
extends java.lang.Object

Constructor Summary
EvaluationWorkbook.ExternalName(java.lang.String nameName, int nameNumber, int ix)
Method Summary
int | getIx()
java.lang.String | getName()
int | getNumber()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EvaluationWorkbook.ExternalName

public EvaluationWorkbook.ExternalName(java.lang.String nameName,
                                       int nameNumber,
                                       int ix)
Method Detail

getName

public java.lang.String getName()

getNumber

public int getNumber()

getIx

public int getIx()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvaluationWorkbook.ExternalSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class EvaluationWorkbook.ExternalSheet

java.lang.Object
    extended by  org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet
Enclosing interface:
EvaluationWorkbook
public static class EvaluationWorkbook.ExternalSheet
extends java.lang.Object

Constructor Summary
EvaluationWorkbook.ExternalSheet(java.lang.String workbookName, java.lang.String sheetName)
Method Summary
java.lang.String | getSheetName()
java.lang.String | getWorkbookName()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EvaluationWorkbook.ExternalSheet

public EvaluationWorkbook.ExternalSheet(java.lang.String workbookName,
                                        java.lang.String sheetName)
Method Detail

getWorkbookName

public java.lang.String getWorkbookName()

getSheetName

public java.lang.String getSheetName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvaluationWorkbook

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface EvaluationWorkbook

All Known Implementing Classes:
HSSFEvaluationWorkbook, XSSFEvaluationWorkbook
public interface EvaluationWorkbook

Abstracts a workbook for the purpose of formula evaluation.
For POI internal use only

Author:
Josh Micich

Nested Class Summary
static class | EvaluationWorkbook.ExternalName
static class | EvaluationWorkbook.ExternalSheet
Method Summary
int | convertFromExternSheetIndex(int externSheetIndex)
EvaluationWorkbook.ExternalName | getExternalName(int externSheetIndex, int externNameIndex)
EvaluationWorkbook.ExternalSheet | getExternalSheet(int externSheetIndex)
Ptg[] | getFormulaTokens(EvaluationCell cell)
EvaluationName | getName(NamePtg namePtg)
EvaluationName | getName(java.lang.String name, int sheetIndex)
EvaluationSheet | getSheet(int sheetIndex)
int | getSheetIndex(EvaluationSheet sheet)
int | getSheetIndex(java.lang.String sheetName) Finds a sheet index by case insensitive name.
java.lang.String | getSheetName(int sheetIndex)
UDFFinder | getUDFFinder()
java.lang.String | resolveNameXText(NameXPtg ptg)

Method Detail

getSheetName

java.lang.String getSheetName(int sheetIndex)

getSheetIndex

int getSheetIndex(EvaluationSheet sheet)
Returns:
-1 if the specified sheet is from a different book

getSheetIndex

int getSheetIndex(java.lang.String sheetName)
Finds a sheet index by case insensitive name.

Returns:
the index of the sheet matching the specified name. -1 if not found

getSheet

EvaluationSheet getSheet(int sheetIndex)

getExternalSheet

EvaluationWorkbook.ExternalSheet getExternalSheet(int externSheetIndex)
Returns:
null if externSheetIndex refers to a sheet inside the current workbook

convertFromExternSheetIndex

int convertFromExternSheetIndex(int externSheetIndex)

getExternalName

EvaluationWorkbook.ExternalName getExternalName(int externSheetIndex,
                                                int externNameIndex)

getName

EvaluationName getName(NamePtg namePtg)

getName

EvaluationName getName(java.lang.String name,
                       int sheetIndex)

resolveNameXText

java.lang.String resolveNameXText(NameXPtg ptg)

getFormulaTokens

Ptg[] getFormulaTokens(EvaluationCell cell)

getUDFFinder

UDFFinder getUDFFinder()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExternSheetReferenceToken

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface ExternSheetReferenceToken

All Known Implementing Classes:
Area3DPtg, Ref3DPtg
public interface ExternSheetReferenceToken

Should be implemented by any Ptg subclass that needs has an extern sheet index
For POI internal use only

Author:
Josh Micich

Method Summary
java.lang.String | format2DRefAsString()
int | getExternSheetIndex()

Method Detail

getExternSheetIndex

int getExternSheetIndex()

format2DRefAsString

java.lang.String format2DRefAsString()
Returns:
formula text for this reference token without the qualifying sheet name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Formula

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class Formula

java.lang.Object
    extended by  org.apache.poi.ss.formula.Formula

public class Formula
extends java.lang.Object

Encapsulates an encoded formula token array.

Author:
Josh Micich

Method Summary
 Formula copy()
static Formula create(Ptg[] ptgs)
Creates a Formula object from a supplied Ptg array.
 int getEncodedSize()
 int getEncodedTokenSize()
This method is often used when the formula length does not appear immediately before the encoded token data.
 CellReference getExpReference()
Gets the locator for the corresponding SharedFormulaRecord, ArrayRecord or TableRecord if this formula belongs to such a grouping.
 Ptg[] getTokens()
static Ptg[] getTokens(Formula formula)
Gets the Ptg array from the supplied Formula.
 boolean isSame(Formula other)
static Formula read(int encodedTokenLen, LittleEndianInput in)
Convenience method for read(int, LittleEndianInput, int)
static Formula read(int encodedTokenLen, LittleEndianInput in, int totalEncodedLen)
When there are no array constants present, encodedTokenLen==totalEncodedLen
 void serialize(LittleEndianOutput out)
Writes The formula encoding is includes: ushort tokenDataLen tokenData arrayConstantData (if present)
 void serializeArrayConstantData(LittleEndianOutput out)
 void serializeTokens(LittleEndianOutput out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

read

public static Formula read(int encodedTokenLen,
                           LittleEndianInput in)
Convenience method for read(int, LittleEndianInput, int)

read

public static Formula read(int encodedTokenLen,
                           LittleEndianInput in,
                           int totalEncodedLen)
When there are no array constants present, encodedTokenLen==totalEncodedLen

Parameters:
encodedTokenLen - number of bytes in the stream taken by the plain formula tokens
totalEncodedLen - the total number of bytes in the formula (includes trailing encoding for array constants, but does not include 2 bytes for initial ushort encodedTokenLen field.
Returns:
A new formula object as read from the stream. Possibly empty, never null.

getTokens

public Ptg[] getTokens()

serialize

public void serialize(LittleEndianOutput out)
Writes The formula encoding is includes:
  • ushort tokenDataLen
  • tokenData
  • arrayConstantData (if present)

serializeTokens

public void serializeTokens(LittleEndianOutput out)

serializeArrayConstantData

public void serializeArrayConstantData(LittleEndianOutput out)

getEncodedSize

public int getEncodedSize()
Returns:
total formula encoding length. The formula encoding includes:
  • ushort tokenDataLen
  • tokenData
  • arrayConstantData (optional)
Note - this value is different to tokenDataLength

getEncodedTokenSize

public int getEncodedTokenSize()
This method is often used when the formula length does not appear immediately before the encoded token data.

Returns:
the encoded length of the plain formula tokens. This does not include the leading ushort field, nor any trailing array constant data.

create

public static Formula create(Ptg[] ptgs)
Creates a Formula object from a supplied Ptg array. Handles nulls OK.

Parameters:
ptgs - may be null
Returns:
Never null (Possibly empty if the supplied ptgs is null)

getTokens

public static Ptg[] getTokens(Formula formula)
Gets the Ptg array from the supplied Formula. Handles nulls OK.

Parameters:
formula - may be null
Returns:
possibly null (if the supplied formula is null)

copy

public Formula copy()

getExpReference

public CellReference getExpReference()
Gets the locator for the corresponding SharedFormulaRecord, ArrayRecord or TableRecord if this formula belongs to such a grouping. The CellReference returned by this method will match the top left corner of the range of that grouping. The return value is usually not the same as the location of the cell containing this formula.

Returns:
the firstRow & firstColumn of an array formula or shared formula that this formula belongs to. null if this formula is not part of an array or shared formula.

isSame

public boolean isSame(Formula other)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaParseException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class FormulaParseException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.ss.formula.FormulaParseException
All Implemented Interfaces:
java.io.Serializable
public final class FormulaParseException
extends java.lang.RuntimeException

This exception thrown when a supplied formula has incorrect syntax (or syntax currently not supported by POI). It is primarily used by test code to confirm specific parsing exceptions. Application code should also handle this exception if it potentially supplies formula text that is not guaranteed to be well-formed.

Author:
Josh Micich
See Also:
Serialized Form

Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaParser

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class FormulaParser

java.lang.Object
    extended by  org.apache.poi.ss.formula.FormulaParser

public final class FormulaParser
extends java.lang.Object

This class parses a formula string into a List of tokens in RPN order. Inspired by Lets Build a Compiler, by Jack Crenshaw BNF for the formula expression is : ::= [ ]* ::= [ ]* ::= | () | | ::= ([expression [, expression]*])

For POI internal use only

Author:
Avik Sengupta , Andrew C. oliver (acoliver at apache dot org), Eric Ladner (eladner at goldinc dot com), Cameron Riley (criley at ekmail.com), Peter M. Murray (pete at quantrix dot com), Pavel Krupets (pkrupets at palmtreebusiness dot com), Josh Micich, David Lewis (DLewis400 at gmail dot com)

Method Summary
static Ptg[] parse(java.lang.String formula, FormulaParsingWorkbook workbook, int formulaType, int sheetIndex)
Parse a formula into a array of tokens
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

parse

public static Ptg[] parse(java.lang.String formula,
                          FormulaParsingWorkbook workbook,
                          int formulaType,
                          int sheetIndex)
Parse a formula into a array of tokens

Parameters:
formula - the formula to parse
workbook - the parent workbook
formulaType - the type of the formula, see FormulaType
sheetIndex - the 0-based index of the sheet this formula belongs to. The sheet index is required to resolve sheet-level names. -1 means that the scope of the name will be ignored and the parser will match names only by name
Returns:
array of parsed tokens
Throws:
FormulaParseException - if the formula has incorrect syntax or is otherwise invalid
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaParsingWorkbook

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface FormulaParsingWorkbook

All Known Implementing Classes:
HSSFEvaluationWorkbook, XSSFEvaluationWorkbook
public interface FormulaParsingWorkbook

Abstracts a workbook for the purpose of formula parsing.
For POI internal use only

Author:
Josh Micich

Method Summary
int | getExternalSheetIndex(java.lang.String sheetName) gets the externSheet index for a sheet from this workbook
int | getExternalSheetIndex(java.lang.String workbookName, java.lang.String sheetName) gets the externSheet index for a sheet from an external workbook
EvaluationName | getName(java.lang.String name, int sheetIndex) named range name matching is case insensitive
NameXPtg | getNameXPtg(java.lang.String name)
SpreadsheetVersion | getSpreadsheetVersion() Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)

Method Detail

getName

EvaluationName getName(java.lang.String name,
                       int sheetIndex)
named range name matching is case insensitive

getNameXPtg

NameXPtg getNameXPtg(java.lang.String name)

getExternalSheetIndex

int getExternalSheetIndex(java.lang.String sheetName)
gets the externSheet index for a sheet from this workbook

getExternalSheetIndex

int getExternalSheetIndex(java.lang.String workbookName,
                          java.lang.String sheetName)
gets the externSheet index for a sheet from an external workbook

Parameters:
workbookName - e.g. "Budget.xls"
sheetName - a name of a sheet in that workbook

getSpreadsheetVersion

SpreadsheetVersion getSpreadsheetVersion()
Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaRenderer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class FormulaRenderer

java.lang.Object
    extended by  org.apache.poi.ss.formula.FormulaRenderer

public class FormulaRenderer
extends java.lang.Object

Common logic for rendering formulas.
For POI internal use only

Author:
Josh Micich

Constructor Summary
FormulaRenderer()
Method Summary
static java.lang.String toFormulaString(FormulaRenderingWorkbook book, Ptg[] ptgs)
Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormulaRenderer

public FormulaRenderer()
Method Detail

toFormulaString

public static java.lang.String toFormulaString(FormulaRenderingWorkbook book,
                                               Ptg[] ptgs)
Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.

Parameters:
book - used for defined names and 3D references
ptgs - must not be null
Returns:
a human readable String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaRenderingWorkbook

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface FormulaRenderingWorkbook

All Known Implementing Classes:
HSSFEvaluationWorkbook, XSSFEvaluationWorkbook
public interface FormulaRenderingWorkbook

Abstracts a workbook for the purpose of converting formula to text.
For POI internal use only

Author:
Josh Micich

Method Summary
EvaluationWorkbook.ExternalSheet | getExternalSheet(int externSheetIndex)
java.lang.String | getNameText(NamePtg namePtg)
java.lang.String | getSheetNameByExternSheet(int externSheetIndex)
java.lang.String | resolveNameXText(NameXPtg nameXPtg)

Method Detail

getExternalSheet

EvaluationWorkbook.ExternalSheet getExternalSheet(int externSheetIndex)
Returns:
null if externSheetIndex refers to a sheet inside the current workbook

getSheetNameByExternSheet

java.lang.String getSheetNameByExternSheet(int externSheetIndex)

resolveNameXText

java.lang.String resolveNameXText(NameXPtg nameXPtg)

getNameText

java.lang.String getNameText(NamePtg namePtg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaShifter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class FormulaShifter

java.lang.Object
    extended by  org.apache.poi.ss.formula.FormulaShifter

public final class FormulaShifter
extends java.lang.Object

Author:
Josh Micich

Method Summary
boolean | adjustFormula(Ptg[] ptgs, int currentExternSheetIx)
static FormulaShifter | createForRowShift(int externSheetIndex, int firstMovedRowIndex, int lastMovedRowIndex, int numberOfRowsToMove)
static FormulaShifter | createForSheetShift(int srcSheetIndex, int dstSheetIndex)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

createForRowShift

public static FormulaShifter createForRowShift(int externSheetIndex,
                                               int firstMovedRowIndex,
                                               int lastMovedRowIndex,
                                               int numberOfRowsToMove)

createForSheetShift

public static FormulaShifter createForSheetShift(int srcSheetIndex,
                                                 int dstSheetIndex)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

adjustFormula

public boolean adjustFormula(Ptg[] ptgs,
                             int currentExternSheetIx)
Parameters:
ptgs - - if necessary, will get modified by this method
currentExternSheetIx - - the extern sheet index of the sheet that contains the formula being adjusted
Returns:
true if a change was made to the formula tokens
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class FormulaType

java.lang.Object
    extended by  org.apache.poi.ss.formula.FormulaType

public final class FormulaType
extends java.lang.Object

Enumeration of various formula types.
For POI internal use only

Author:
Josh Micich

Field Summary
static int | ARRAY
static int | CELL
static int | CONDFORMAT
static int | DATAVALIDATION_LIST
static int | NAMEDRANGE
static int | SHARED
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CELL

public static final int CELL
See Also:
Constant Field Values

SHARED

public static final int SHARED
See Also:
Constant Field Values

ARRAY

public static final int ARRAY
See Also:
Constant Field Values

CONDFORMAT

public static final int CONDFORMAT
See Also:
Constant Field Values

NAMEDRANGE

public static final int NAMEDRANGE
See Also:
Constant Field Values

DATAVALIDATION_LIST

public static final int DATAVALIDATION_LIST
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IStabilityClassifier

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface IStabilityClassifier

public interface IStabilityClassifier

Used to help optimise cell evaluation result caching by allowing applications to specify which parts of a workbook are final.
The term final is introduced here to denote immutability or 'having constant definition'. This classification refers to potential actions (on the evaluated workbook) by the evaluating application. It does not refer to operations performed by the evaluator (WorkbookEvaluator).

General guidelines:

  • a plain value cell can be marked as 'final' if it will not be changed after the first call to WorkbookEvaluator.evaluate(EvaluationCell).
  • a formula cell can be marked as 'final' if its formula will not be changed after the first call to WorkbookEvaluator.evaluate(EvaluationCell). This remains true even if changes in dependent values may cause the evaluated value to change.
  • plain value cells should be marked as 'not final' if their plain value value may change.
  • formula cells should be marked as 'not final' if their formula definition may change.
  • cells which may switch between plain value and formula should also be marked as 'not final'.
Notes:
  • If none of the spreadsheet cells is expected to have its definition changed after evaluation begins, every cell can be marked as 'final'. This is the most efficient / least resource intensive option.
  • To retain freedom to change any cell definition at any time, an application may classify all cells as 'not final'. This freedom comes at the expense of greater memory consumption.
  • For the purpose of these classifications, setting the cached formula result of a cell (for example in FormulaEvaluator.evaluateFormulaCell(org.apache.poi.ss.usermodel.Cell)) does not constitute changing the definition of the cell.
  • Updating cells which have been classified as 'final' will cause the evaluator to behave unpredictably (typically ignoring the update).

Author:
Josh Micich

Field Summary
static IStabilityClassifier TOTALLY_IMMUTABLE
Convenience implementation for situations where all cell definitions remain fixed after evaluation begins.
Method Summary
 boolean isCellFinal(int sheetIndex, int rowIndex, int columnIndex)
Checks if a cell's value(/formula) is fixed - in other words - not expected to be modified between calls to the evaluator.

Field Detail

TOTALLY_IMMUTABLE

static final IStabilityClassifier TOTALLY_IMMUTABLE
Convenience implementation for situations where all cell definitions remain fixed after evaluation begins.

Method Detail

isCellFinal

boolean isCellFinal(int sheetIndex,
                    int rowIndex,
                    int columnIndex)
Checks if a cell's value(/formula) is fixed - in other words - not expected to be modified between calls to the evaluator. (Note - this is an independent concept from whether a formula cell's evaluated value may change during successive calls to the evaluator).

Parameters:
sheetIndex - zero based index into workbook sheet list
rowIndex - zero based row index of cell
columnIndex - zero based column index of cell
Returns:
false if the evaluating application may need to modify the specified cell between calls to the evaluator.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperationEvaluationContext

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class OperationEvaluationContext

java.lang.Object
    extended by  org.apache.poi.ss.formula.OperationEvaluationContext

public final class OperationEvaluationContext
extends java.lang.Object

Contains all the contextual information required to evaluate an operation within a formula For POI internal use only

Author:
Josh Micich

Field Summary
static FreeRefFunction UDF
Constructor Summary
OperationEvaluationContext(WorkbookEvaluator bookEvaluator, EvaluationWorkbook workbook, int sheetIndex, int srcRowNum, int srcColNum, org.apache.poi.ss.formula.EvaluationTracker tracker)
Method Summary
FreeRefFunction | findUserDefinedFunction(java.lang.String functionName)
ValueEval | getArea3DEval(int firstRowIndex, int firstColumnIndex, int lastRowIndex, int lastColumnIndex, int extSheetIndex)
ValueEval | getAreaEval(int firstRowIndex, int firstColumnIndex, int lastRowIndex, int lastColumnIndex)
int | getColumnIndex()
ValueEval | getDynamicReference(java.lang.String workbookName, java.lang.String sheetName, java.lang.String refStrPart1, java.lang.String refStrPart2, boolean isA1Style) Resolves a cell or area reference dynamically.
ValueEval | getNameXEval(NameXPtg nameXPtg)
ValueEval | getRef3DEval(int rowIndex, int columnIndex, int extSheetIndex)
ValueEval | getRefEval(int rowIndex, int columnIndex)
org.apache.poi.ss.formula.SheetRefEvaluator | getRefEvaluatorForCurrentSheet()
int | getRowIndex()
EvaluationWorkbook | getWorkbook()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UDF

public static final FreeRefFunction UDF
Constructor Detail

OperationEvaluationContext

public OperationEvaluationContext(WorkbookEvaluator bookEvaluator,
                                  EvaluationWorkbook workbook,
                                  int sheetIndex,
                                  int srcRowNum,
                                  int srcColNum,
                                  org.apache.poi.ss.formula.EvaluationTracker tracker)
Method Detail

getWorkbook

public EvaluationWorkbook getWorkbook()

getRowIndex

public int getRowIndex()

getColumnIndex

public int getColumnIndex()

getRefEvaluatorForCurrentSheet

public org.apache.poi.ss.formula.SheetRefEvaluator getRefEvaluatorForCurrentSheet()

getDynamicReference

public ValueEval getDynamicReference(java.lang.String workbookName,
                                     java.lang.String sheetName,
                                     java.lang.String refStrPart1,
                                     java.lang.String refStrPart2,
                                     boolean isA1Style)
Resolves a cell or area reference dynamically.

Parameters:
workbookName - the name of the workbook containing the reference. If null the current workbook is assumed. Note - to evaluate formulas which use multiple workbooks, a CollaboratingWorkbooksEnvironment must be set up.
sheetName - the name of the sheet containing the reference. May be null (when workbookName is also null) in which case the current workbook and sheet is assumed.
refStrPart1 - the single cell reference or first part of the area reference. Must not be null.
refStrPart2 - the second part of the area reference. For single cell references this parameter must be null
isA1Style - specifies the format for refStrPart1 and refStrPart2. Pass true for 'A1' style and false for 'R1C1' style. TODO - currently POI only supports 'A1' reference style
Returns:
a RefEval or AreaEval

findUserDefinedFunction

public FreeRefFunction findUserDefinedFunction(java.lang.String functionName)

getRefEval

public ValueEval getRefEval(int rowIndex,
                            int columnIndex)

getRef3DEval

public ValueEval getRef3DEval(int rowIndex,
                              int columnIndex,
                              int extSheetIndex)

getAreaEval

public ValueEval getAreaEval(int firstRowIndex,
                             int firstColumnIndex,
                             int lastRowIndex,
                             int lastColumnIndex)

getArea3DEval

public ValueEval getArea3DEval(int firstRowIndex,
                               int firstColumnIndex,
                               int lastRowIndex,
                               int lastColumnIndex,
                               int extSheetIndex)

getNameXEval

public ValueEval getNameXEval(NameXPtg nameXPtg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula
Interfaces
EvaluationCell
EvaluationName
EvaluationSheet
EvaluationWorkbook
ExternSheetReferenceToken
FormulaParsingWorkbook
FormulaRenderingWorkbook
IStabilityClassifier
TwoDEval
WorkbookDependentFormula
Classes
CollaboratingWorkbooksEnvironment
EvaluationWorkbook.ExternalName
EvaluationWorkbook.ExternalSheet
Formula
FormulaParser
FormulaRenderer
FormulaShifter
FormulaType
OperationEvaluationContext
SharedFormula
SheetNameFormatter
WorkbookEvaluator
Exceptions
CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
FormulaParseException


org.apache.poi.ss.formula

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula

This package contains common internal POI code for manipulating formulas.

See:
Description

Interface Summary
EvaluationCell | Abstracts a cell for the purpose of formula evaluation.
EvaluationName | Abstracts a name record for formula evaluation. For POI internal use only
EvaluationSheet | Abstracts a sheet for the purpose of formula evaluation. For POI internal use only
EvaluationWorkbook | Abstracts a workbook for the purpose of formula evaluation. For POI internal use only
ExternSheetReferenceToken | Should be implemented by any Ptg subclass that needs has an extern sheet index For POI internal use only
FormulaParsingWorkbook | Abstracts a workbook for the purpose of formula parsing. For POI internal use only
FormulaRenderingWorkbook | Abstracts a workbook for the purpose of converting formula to text. For POI internal use only
IStabilityClassifier | Used to help optimise cell evaluation result caching by allowing applications to specify which parts of a workbook are final. The term final is introduced here to denote immutability or 'having constant definition'.
TwoDEval | Common interface of AreaEval and AreaEvalBase
WorkbookDependentFormula | Should be implemented by any Ptg subclass that needs a workbook to render its formula.

Class Summary
CollaboratingWorkbooksEnvironment | Manages a collection of WorkbookEvaluators, in order to support evaluation of formulas across spreadsheets. For POI internal use only
EvaluationWorkbook.ExternalName |
EvaluationWorkbook.ExternalSheet |
Formula | Encapsulates an encoded formula token array.
FormulaParser | This class parses a formula string into a List of tokens in RPN order.
FormulaRenderer | Common logic for rendering formulas. For POI internal use only
FormulaShifter |
FormulaType | Enumeration of various formula types. For POI internal use only
OperationEvaluationContext | Contains all the contextual information required to evaluate an operation within a formula For POI internal use only
SharedFormula | Encapsulates logic to convert shared formulaa into non shared equivalent
SheetNameFormatter | Formats sheet names for use in formula expressions.
WorkbookEvaluator | Evaluates formula cells. For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

Exception Summary
CollaboratingWorkbooksEnvironment.WorkbookNotFoundException |
FormulaParseException | This exception thrown when a supplied formula has incorrect syntax (or syntax currently not supported by POI).

Package org.apache.poi.ss.formula Description

This package contains common internal POI code for manipulating formulas. Client applications should not refer to these classes directly.


org.apache.poi.ss.formula Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment
    • org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName
    • org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet
    • org.apache.poi.ss.formula.Formula
    • org.apache.poi.ss.formula.FormulaParser
    • org.apache.poi.ss.formula.FormulaRenderer
    • org.apache.poi.ss.formula.FormulaShifter
    • org.apache.poi.ss.formula.FormulaType
    • org.apache.poi.ss.formula.OperationEvaluationContext
    • org.apache.poi.ss.formula.SharedFormula
    • org.apache.poi.ss.formula.SheetNameFormatter
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
        • java.lang.RuntimeException
          • org.apache.poi.ss.formula.FormulaParseException
    • org.apache.poi.ss.formula.WorkbookEvaluator

Interface Hierarchy

  • org.apache.poi.ss.formula.EvaluationCell
  • org.apache.poi.ss.formula.EvaluationName
  • org.apache.poi.ss.formula.EvaluationSheet
  • org.apache.poi.ss.formula.EvaluationWorkbook
  • org.apache.poi.ss.formula.ExternSheetReferenceToken
  • org.apache.poi.ss.formula.FormulaParsingWorkbook
  • org.apache.poi.ss.formula.FormulaRenderingWorkbook
  • org.apache.poi.ss.formula.IStabilityClassifier
  • org.apache.poi.ss.formula.eval.ValueEval
    • org.apache.poi.ss.formula.TwoDEval
  • org.apache.poi.ss.formula.WorkbookDependentFormula


Uses of Package org.apache.poi.ss.formula

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula

Packages that use org.apache.poi.ss.formula
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.formula.functions |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.helpers |

Classes in org.apache.poi.ss.formula used by org.apache.poi.hssf.model
EvaluationWorkbook.ExternalName
EvaluationWorkbook.ExternalSheet
FormulaParseException
This exception thrown when a supplied formula has incorrect syntax (or syntax currently not supported by POI).
FormulaShifter

Classes in org.apache.poi.ss.formula used by org.apache.poi.hssf.record
Formula
Encapsulates an encoded formula token array.

Classes in org.apache.poi.ss.formula used by org.apache.poi.hssf.record.aggregates
FormulaShifter

Classes in org.apache.poi.ss.formula used by org.apache.poi.hssf.usermodel
EvaluationCell
Abstracts a cell for the purpose of formula evaluation.
EvaluationName
Abstracts a name record for formula evaluation.
For POI internal use only
EvaluationSheet
Abstracts a sheet for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook
Abstracts a workbook for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook.ExternalName
EvaluationWorkbook.ExternalSheet
FormulaParsingWorkbook
Abstracts a workbook for the purpose of formula parsing.
For POI internal use only
FormulaRenderingWorkbook
Abstracts a workbook for the purpose of converting formula to text.
For POI internal use only
IStabilityClassifier
Used to help optimise cell evaluation result caching by allowing applications to specify which parts of a workbook are final.
The term final is introduced here to denote immutability or 'having constant definition'.

Classes in org.apache.poi.ss.formula used by org.apache.poi.ss.formula
CollaboratingWorkbooksEnvironment
Manages a collection of WorkbookEvaluators, in order to support evaluation of formulas across spreadsheets.

For POI internal use only

CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
EvaluationCell
Abstracts a cell for the purpose of formula evaluation.
EvaluationName
Abstracts a name record for formula evaluation.
For POI internal use only
EvaluationSheet
Abstracts a sheet for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook
Abstracts a workbook for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook.ExternalName
EvaluationWorkbook.ExternalSheet
Formula
Encapsulates an encoded formula token array.
FormulaParsingWorkbook
Abstracts a workbook for the purpose of formula parsing.
For POI internal use only
FormulaRenderingWorkbook
Abstracts a workbook for the purpose of converting formula to text.
For POI internal use only
FormulaShifter
IStabilityClassifier
Used to help optimise cell evaluation result caching by allowing applications to specify which parts of a workbook are final.
The term final is introduced here to denote immutability or 'having constant definition'.
TwoDEval
Common interface of AreaEval and AreaEvalBase
WorkbookEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

Classes in org.apache.poi.ss.formula used by org.apache.poi.ss.formula.eval
TwoDEval
Common interface of AreaEval and AreaEvalBase

Classes in org.apache.poi.ss.formula used by org.apache.poi.ss.formula.eval.forked
IStabilityClassifier
Used to help optimise cell evaluation result caching by allowing applications to specify which parts of a workbook are final.
The term final is introduced here to denote immutability or 'having constant definition'.

Classes in org.apache.poi.ss.formula used by org.apache.poi.ss.formula.functions
OperationEvaluationContext
Contains all the contextual information required to evaluate an operation within a formula For POI internal use only

Classes in org.apache.poi.ss.formula used by org.apache.poi.ss.formula.ptg
ExternSheetReferenceToken
Should be implemented by any Ptg subclass that needs has an extern sheet index
For POI internal use only
FormulaRenderingWorkbook
Abstracts a workbook for the purpose of converting formula to text.
For POI internal use only
WorkbookDependentFormula
Should be implemented by any Ptg subclass that needs a workbook to render its formula.

Classes in org.apache.poi.ss.formula used by org.apache.poi.ss.usermodel
FormulaParseException
This exception thrown when a supplied formula has incorrect syntax (or syntax currently not supported by POI).

Classes in org.apache.poi.ss.formula used by org.apache.poi.xssf.streaming
FormulaParseException
This exception thrown when a supplied formula has incorrect syntax (or syntax currently not supported by POI).

Classes in org.apache.poi.ss.formula used by org.apache.poi.xssf.usermodel
EvaluationCell
Abstracts a cell for the purpose of formula evaluation.
EvaluationName
Abstracts a name record for formula evaluation.
For POI internal use only
EvaluationSheet
Abstracts a sheet for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook
Abstracts a workbook for the purpose of formula evaluation.
For POI internal use only
EvaluationWorkbook.ExternalName
EvaluationWorkbook.ExternalSheet
FormulaParsingWorkbook
Abstracts a workbook for the purpose of formula parsing.
For POI internal use only
FormulaRenderingWorkbook
Abstracts a workbook for the purpose of converting formula to text.
For POI internal use only
IStabilityClassifier
Used to help optimise cell evaluation result caching by allowing applications to specify which parts of a workbook are final.
The term final is introduced here to denote immutability or 'having constant definition'.

Classes in org.apache.poi.ss.formula used by org.apache.poi.xssf.usermodel.helpers
FormulaShifter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SharedFormula

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class SharedFormula

java.lang.Object
    extended by  org.apache.poi.ss.formula.SharedFormula

public class SharedFormula
extends java.lang.Object

Encapsulates logic to convert shared formulaa into non shared equivalent

Constructor Summary
SharedFormula(SpreadsheetVersion ssVersion)
Method Summary
 Ptg[] convertSharedFormulas(Ptg[] ptgs, int formulaRow, int formulaColumn)
Creates a non shared formula from the shared formula counterpart, i.e.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SharedFormula

public SharedFormula(SpreadsheetVersion ssVersion)
Method Detail

convertSharedFormulas

public Ptg[] convertSharedFormulas(Ptg[] ptgs,
                                   int formulaRow,
                                   int formulaColumn)
Creates a non shared formula from the shared formula counterpart, i.e. Converts the shared formula into the equivalent Ptg array that it would have, were it not shared.

Parameters:
ptgs - parsed tokens of the shared formula
formulaRow -
formulaColumn -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SheetNameFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class SheetNameFormatter

java.lang.Object
    extended by  org.apache.poi.ss.formula.SheetNameFormatter

public final class SheetNameFormatter
extends java.lang.Object

Formats sheet names for use in formula expressions.

Author:
Josh Micich

Method Summary
static void | appendFormat(java.lang.StringBuffer out, java.lang.String rawSheetName) Convenience method for (format(String)) when a StringBuffer is already available.
static void | appendFormat(java.lang.StringBuffer out, java.lang.String workbookName, java.lang.String rawSheetName)
static java.lang.String | format(java.lang.String rawSheetName) Used to format sheet names as they would appear in cell formula expressions.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

format

public static java.lang.String format(java.lang.String rawSheetName)
Used to format sheet names as they would appear in cell formula expressions.

Returns:
the sheet name unchanged if there is no need for delimiting. Otherwise the sheet name is enclosed in single quotes ('). Any single quotes which were already present in the sheet name will be converted to double single quotes ('').

appendFormat

public static void appendFormat(java.lang.StringBuffer out,
                                java.lang.String rawSheetName)
Convenience method for (format(String)) when a StringBuffer is already available.

Parameters:
out - - sheet name will be appended here possibly with delimiting quotes

appendFormat

public static void appendFormat(java.lang.StringBuffer out,
                                java.lang.String workbookName,
                                java.lang.String rawSheetName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TwoDEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface TwoDEval

All Superinterfaces:
ValueEval
All Known Subinterfaces:
AreaEval
All Known Implementing Classes:
AreaEvalBase
public interface TwoDEval
extends ValueEval

Common interface of AreaEval and AreaEvalBase

Author:
Josh Micich

Method Summary
TwoDEval | getColumn(int columnIndex)
int | getHeight()
TwoDEval | getRow(int rowIndex)
ValueEval | getValue(int rowIndex, int columnIndex)
int | getWidth()
boolean | isColumn()
boolean | isRow()
boolean | isSubTotal(int rowIndex, int columnIndex)

Method Detail

getValue

ValueEval getValue(int rowIndex,
                   int columnIndex)
Parameters:
rowIndex - relative row index (zero based)
columnIndex - relative column index (zero based)
Returns:
element at the specified row and column position

getWidth

int getWidth()

getHeight

int getHeight()

isRow

boolean isRow()
Returns:
true if the area has just a single row, this also includes the trivial case when the area has just a single cell.

isColumn

boolean isColumn()
Returns:
true if the area has just a single column, this also includes the trivial case when the area has just a single cell.

getRow

TwoDEval getRow(int rowIndex)
Parameters:
rowIndex - relative row index (zero based)
Returns:
a single row TwoDEval

getColumn

TwoDEval getColumn(int columnIndex)
Parameters:
columnIndex - relative column index (zero based)
Returns:
a single column TwoDEval

isSubTotal

boolean isSubTotal(int rowIndex,
                   int columnIndex)
Returns:
true if the cell at row and col is a subtotal
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkbookDependentFormula

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Interface WorkbookDependentFormula

All Known Implementing Classes:
Area3DPtg, DeletedArea3DPtg, DeletedRef3DPtg, NamePtg, NameXPtg, Ref3DPtg
public interface WorkbookDependentFormula

Should be implemented by any Ptg subclass that needs a workbook to render its formula.
For POI internal use only

Author:
Josh Micich

Method Summary
 java.lang.String toFormulaString(FormulaRenderingWorkbook book)

Method Detail

toFormulaString

java.lang.String toFormulaString(FormulaRenderingWorkbook book)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkbookEvaluator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula
Class WorkbookEvaluator

java.lang.Object
    extended by  org.apache.poi.ss.formula.WorkbookEvaluator

public final class WorkbookEvaluator
extends java.lang.Object

Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values. Be sure to call clearAllCachedResultValues() if any workbook cells are changed between calls to evaluate~ methods on this class.
For POI internal use only

Author:
Josh Micich

Constructor Summary
WorkbookEvaluator(EvaluationWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
Method Summary
void | clearAllCachedResultValues() Should be called whenever there are changes to input cells in the evaluated workbook.
static ValueEval | dereferenceResult(ValueEval evaluationResult, int srcRowNum, int srcColNum) Dereferences a single value from any AreaEval or RefEval evaluation result.
ValueEval | evaluate(EvaluationCell srcCell)
FreeRefFunction | findUserDefinedFunction(java.lang.String functionName)
static java.util.Collection<java.lang.String> | getNotSupportedFunctionNames() Return a collection of functions that POI does not support
static java.util.Collection<java.lang.String> | getSupportedFunctionNames() Return a collection of functions that POI can evaluate
void | notifyDeleteCell(EvaluationCell cell) Should be called to tell the cell value cache that the specified cell has just been deleted.
void | notifyUpdateCell(EvaluationCell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
static void | registerFunction(java.lang.String name, FreeRefFunction func) Register a ATP function in runtime.
static void | registerFunction(java.lang.String name, Function func) Register a function in runtime.
void | setIgnoreMissingWorkbooks(boolean ignore) Whether to ignore missing references to external workbooks and use cached formula results in the main workbook instead.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkbookEvaluator

public WorkbookEvaluator(EvaluationWorkbook workbook,
                         IStabilityClassifier stabilityClassifier,
                         UDFFinder udfFinder)
Parameters:
udfFinder - pass null for default (AnalysisToolPak only)
Method Detail

clearAllCachedResultValues

public void clearAllCachedResultValues()
Should be called whenever there are changes to input cells in the evaluated workbook. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

notifyUpdateCell

public void notifyUpdateCell(EvaluationCell cell)
Should be called to tell the cell value cache that the specified (value or formula) cell has changed.

notifyDeleteCell

public void notifyDeleteCell(EvaluationCell cell)
Should be called to tell the cell value cache that the specified cell has just been deleted.

evaluate

public ValueEval evaluate(EvaluationCell srcCell)

dereferenceResult

public static ValueEval dereferenceResult(ValueEval evaluationResult,
                                          int srcRowNum,
                                          int srcColNum)
Dereferences a single value from any AreaEval or RefEval evaluation result. If the supplied evaluationResult is just a plain value, it is returned as-is.

Returns:
a NumberEval, StringEval, BoolEval, or ErrorEval. Never null. BlankEval is converted to NumberEval.ZERO

findUserDefinedFunction

public FreeRefFunction findUserDefinedFunction(java.lang.String functionName)

setIgnoreMissingWorkbooks

public void setIgnoreMissingWorkbooks(boolean ignore)
Whether to ignore missing references to external workbooks and use cached formula results in the main workbook instead.

In some cases exetrnal workbooks referenced by formulas in the main workbook are not avaiable. With this method you can control how POI handles such missing references:

  • by default ignoreMissingWorkbooks=false and POI throws CollaboratingWorkbooksEnvironment.WorkbookNotFoundException if an external reference cannot be resolved
  • if ignoreMissingWorkbooks=true then POI uses cached formula result that already exists in the main workbook

Parameters:
ignore - whether to ignore missing references to external workbooks
See Also:
Bug 52575 for details

getSupportedFunctionNames

public static java.util.Collection<java.lang.String> getSupportedFunctionNames()
Return a collection of functions that POI can evaluate

Returns:
names of functions supported by POI

getNotSupportedFunctionNames

public static java.util.Collection<java.lang.String> getNotSupportedFunctionNames()
Return a collection of functions that POI does not support

Returns:
names of functions NOT supported by POI

registerFunction

public static void registerFunction(java.lang.String name,
                                    FreeRefFunction func)
Register a ATP function in runtime.

Parameters:
name - the function name
func - the functoin to register
Throws:
java.lang.IllegalArgumentException - if the function is unknown or already registered.
Since:
3.8 beta6

registerFunction

public static void registerFunction(java.lang.String name,
                                    Function func)
Register a function in runtime.

Parameters:
name - the function name
func - the functoin to register
Throws:
java.lang.IllegalArgumentException - if the function is unknown or already registered.
Since:
3.8 beta6
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AnalysisToolPak

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.atp
Class AnalysisToolPak

java.lang.Object
    extended by  org.apache.poi.ss.formula.atp.AnalysisToolPak
All Implemented Interfaces:
UDFFinder
public final class AnalysisToolPak
extends java.lang.Object
implements UDFFinder

Author:
Josh Micich, Petr Udalau - systematized work of add-in libraries and user defined functions.

Field Summary
static UDFFinder instance
Fields inherited from interface org.apache.poi.ss.formula.udf.UDFFinder
DEFAULT
Method Summary
FreeRefFunction | findFunction(java.lang.String name) Returns executor by specified name.
static java.util.Collection<java.lang.String> | getNotSupportedFunctionNames() Returns a collection of ATP function names NOT implemented by POI.
static java.util.Collection<java.lang.String> | getSupportedFunctionNames() Returns a collection of ATP function names implemented by POI.
static boolean | isATPFunction(java.lang.String name)
static void | registerFunction(java.lang.String name, FreeRefFunction func) Register a ATP function in runtime.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final UDFFinder instance
Method Detail

findFunction

public FreeRefFunction findFunction(java.lang.String name)
Description copied from interface: UDFFinder
Returns executor by specified name. Returns null if the function name is unknown.

Specified by:
findFunction in interface UDFFinder
Parameters:
name - Name of function.
Returns:
Function executor.

isATPFunction

public static boolean isATPFunction(java.lang.String name)

getSupportedFunctionNames

public static java.util.Collection<java.lang.String> getSupportedFunctionNames()
Returns a collection of ATP function names implemented by POI.

Returns:
an array of supported functions
Since:
3.8 beta6

getNotSupportedFunctionNames

public static java.util.Collection<java.lang.String> getNotSupportedFunctionNames()
Returns a collection of ATP function names NOT implemented by POI.

Returns:
an array of not supported functions
Since:
3.8 beta6

registerFunction

public static void registerFunction(java.lang.String name,
                                    FreeRefFunction func)
Register a ATP function in runtime.

Parameters:
name - the function name
func - the functoin to register
Throws:
java.lang.IllegalArgumentException - if the function is unknown or already registered.
Since:
3.8 beta6
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DateParser

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.atp
Class DateParser

java.lang.Object
    extended by  org.apache.poi.ss.formula.atp.DateParser

public class DateParser
extends java.lang.Object

Parser for java dates.

Author:
jfaenomoto@gmail.com

Field Summary
 DateParser instance
Method Summary
static java.util.Calendar parseDate(java.lang.String strVal)
Parses a date from a string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public DateParser instance
Method Detail

parseDate

public static java.util.Calendar parseDate(java.lang.String strVal)
                                    throws EvaluationException
Parses a date from a string.

Parameters:
strVal - a string with a date pattern.
Returns:
a date parsed from argument.
Throws:
EvaluationException - exception upon parsing.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.atp
Classes
AnalysisToolPak
DateParser
WorkdayCalculator


org.apache.poi.ss.formula.atp

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.atp

Class Summary
AnalysisToolPak |
DateParser | Parser for java dates.
WorkdayCalculator | A calculator for workdays, considering dates as excel representations.


org.apache.poi.ss.formula.atp Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.atp

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.atp.AnalysisToolPak (implements org.apache.poi.ss.formula.udf.UDFFinder)
    • org.apache.poi.ss.formula.atp.DateParser
    • org.apache.poi.ss.formula.atp.WorkdayCalculator


Uses of Package org.apache.poi.ss.formula.atp

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.atp

Packages that use org.apache.poi.ss.formula.atp
org.apache.poi.ss.formula.atp

Classes in org.apache.poi.ss.formula.atp used by org.apache.poi.ss.formula.atp
DateParser
Parser for java dates.
WorkdayCalculator
A calculator for workdays, considering dates as excel representations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


WorkdayCalculator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.atp
Class WorkdayCalculator

java.lang.Object
    extended by  org.apache.poi.ss.formula.atp.WorkdayCalculator

public class WorkdayCalculator
extends java.lang.Object

A calculator for workdays, considering dates as excel representations.

Author:
jfaenomoto@gmail.com

Field Summary
static WorkdayCalculator instance
Method Summary
protected int | calculateNonWeekendHolidays(double start, double end, double[] holidays) Calculates how many holidays in a list are workdays, considering an interval of dates.
int | calculateWorkdays(double start, double end, double[] holidays) Calculate how many workdays are there between a start and an end date, as excel representations, considering a range of holidays.
java.util.Date | calculateWorkdays(double start, int workdays, double[] holidays) Calculate the workday past x workdays from a starting date, considering a range of holidays.
protected boolean | isHoliday(double aDate, double[] holidays)
protected boolean | isInARange(double start, double end, double aDate)
protected int | isNonWorkday(double aDate, double[] holidays)
protected boolean | isWeekend(double aDate)
protected int | pastDaysOfWeek(double start, double end, int dayOfWeek) Calculates how many days of week past between a start and an end date.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final WorkdayCalculator instance
Method Detail

calculateWorkdays

public int calculateWorkdays(double start,
                             double end,
                             double[] holidays)
Calculate how many workdays are there between a start and an end date, as excel representations, considering a range of holidays.

Parameters:
start - start date.
end - end date.
holidays - an array of holidays.
Returns:
number of workdays between start and end dates, including both dates.

calculateWorkdays

public java.util.Date calculateWorkdays(double start,
                                        int workdays,
                                        double[] holidays)
Calculate the workday past x workdays from a starting date, considering a range of holidays.

Parameters:
start - start date.
workdays - number of workdays to be past from starting date.
holidays - an array of holidays.
Returns:
date past x workdays.

pastDaysOfWeek

protected int pastDaysOfWeek(double start,
                             double end,
                             int dayOfWeek)
Calculates how many days of week past between a start and an end date.

Parameters:
start - start date.
end - end date.
dayOfWeek - a day of week as represented by Calendar constants.
Returns:
how many days of week past in this interval.

calculateNonWeekendHolidays

protected int calculateNonWeekendHolidays(double start,
                                          double end,
                                          double[] holidays)
Calculates how many holidays in a list are workdays, considering an interval of dates.

Parameters:
start - start date.
end - end date.
holidays - an array of holidays.
Returns:
number of holidays that occur in workdays, between start and end dates.

isWeekend

protected boolean isWeekend(double aDate)
Parameters:
aDate - a given date.
Returns:
true if date is weekend, false otherwise.

isHoliday

protected boolean isHoliday(double aDate,
                            double[] holidays)
Parameters:
aDate - a given date.
holidays - an array of holidays.
Returns:
true if date is a holiday, false otherwise.

isNonWorkday

protected int isNonWorkday(double aDate,
                           double[] holidays)
Parameters:
aDate - a given date.
holidays - an array of holidays.
Returns:
1 is not a workday, 0 otherwise.

isInARange

protected boolean isInARange(double start,
                             double end,
                             double aDate)
Parameters:
start - start date.
end - end date.
aDate - a date to be analyzed.
Returns:
true if aDate is between start and end dates, false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.ss.formula.atp.AnalysisToolPak

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.atp.AnalysisToolPak

No usage of org.apache.poi.ss.formula.atp.AnalysisToolPak

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.atp.DateParser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.atp.DateParser

Packages that use DateParser
org.apache.poi.ss.formula.atp

Uses of DateParser in org.apache.poi.ss.formula.atp

Fields in org.apache.poi.ss.formula.atp declared as DateParser
 DateParser DateParser.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.atp.WorkdayCalculator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.atp.WorkdayCalculator

Packages that use WorkdayCalculator
org.apache.poi.ss.formula.atp

Uses of WorkdayCalculator in org.apache.poi.ss.formula.atp

Fields in org.apache.poi.ss.formula.atp declared as WorkdayCalculator
static WorkdayCalculator WorkdayCalculator.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment

Packages that use CollaboratingWorkbooksEnvironment
org.apache.poi.ss.formula This package contains common internal POI code for manipulating formulas.

Uses of CollaboratingWorkbooksEnvironment in org.apache.poi.ss.formula

Fields in org.apache.poi.ss.formula declared as CollaboratingWorkbooksEnvironment
static CollaboratingWorkbooksEnvironment CollaboratingWorkbooksEnvironment.EMPTY

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment.WorkbookNotFoundException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.CollaboratingWorkbooksEnvironment.WorkbookNotFoundException

Packages that use CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
org.apache.poi.ss.formula This package contains common internal POI code for manipulating formulas.

Uses of CollaboratingWorkbooksEnvironment.WorkbookNotFoundException in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that throw CollaboratingWorkbooksEnvironment.WorkbookNotFoundException
 WorkbookEvaluator CollaboratingWorkbooksEnvironment.getWorkbookEvaluator(java.lang.String workbookName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.EvaluationCell

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.EvaluationCell

Packages that use EvaluationCell
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of EvaluationCell in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel with parameters of type EvaluationCell
 Ptg[] HSSFEvaluationWorkbook.getFormulaTokens(EvaluationCell evalCell)

Uses of EvaluationCell in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return EvaluationCell
 EvaluationCell EvaluationSheet.getCell(int rowIndex, int columnIndex)

Methods in org.apache.poi.ss.formula with parameters of type EvaluationCell
ValueEval | WorkbookEvaluator.evaluate(EvaluationCell srcCell)
Ptg[] | EvaluationWorkbook.getFormulaTokens(EvaluationCell cell)
void | WorkbookEvaluator.notifyDeleteCell(EvaluationCell cell) Should be called to tell the cell value cache that the specified cell has just been deleted.
void | WorkbookEvaluator.notifyUpdateCell(EvaluationCell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.

Uses of EvaluationCell in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type EvaluationCell
 Ptg[] XSSFEvaluationWorkbook.getFormulaTokens(EvaluationCell evalCell)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.EvaluationName

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.EvaluationName

Packages that use EvaluationName
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of EvaluationName in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return EvaluationName
EvaluationName | HSSFEvaluationWorkbook.getName(NamePtg namePtg)
EvaluationName | HSSFEvaluationWorkbook.getName(java.lang.String name, int sheetIndex) Lookup a named range by its name.

Uses of EvaluationName in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return EvaluationName
EvaluationName | EvaluationWorkbook.getName(NamePtg namePtg)
EvaluationName | FormulaParsingWorkbook.getName(java.lang.String name, int sheetIndex) named range name matching is case insensitive
EvaluationName | EvaluationWorkbook.getName(java.lang.String name, int sheetIndex)

Uses of EvaluationName in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return EvaluationName
EvaluationName | XSSFEvaluationWorkbook.getName(NamePtg namePtg)
EvaluationName | XSSFEvaluationWorkbook.getName(java.lang.String name, int sheetIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.EvaluationSheet

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.EvaluationSheet

Packages that use EvaluationSheet
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of EvaluationSheet in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return EvaluationSheet
 EvaluationSheet HSSFEvaluationWorkbook.getSheet(int sheetIndex)

Methods in org.apache.poi.hssf.usermodel with parameters of type EvaluationSheet
 int HSSFEvaluationWorkbook.getSheetIndex(EvaluationSheet evalSheet)

Uses of EvaluationSheet in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return EvaluationSheet
EvaluationSheet | EvaluationCell.getSheet()
EvaluationSheet | EvaluationWorkbook.getSheet(int sheetIndex)

Methods in org.apache.poi.ss.formula with parameters of type EvaluationSheet
 int EvaluationWorkbook.getSheetIndex(EvaluationSheet sheet)

Uses of EvaluationSheet in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return EvaluationSheet
 EvaluationSheet XSSFEvaluationWorkbook.getSheet(int sheetIndex)

Methods in org.apache.poi.xssf.usermodel with parameters of type EvaluationSheet
 int XSSFEvaluationWorkbook.getSheetIndex(EvaluationSheet evalSheet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.EvaluationWorkbook.ExternalName

Packages that use EvaluationWorkbook.ExternalName
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of EvaluationWorkbook.ExternalName in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return EvaluationWorkbook.ExternalName
 EvaluationWorkbook.ExternalName InternalWorkbook.getExternalName(int externSheetIndex, int externNameIndex)

Uses of EvaluationWorkbook.ExternalName in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return EvaluationWorkbook.ExternalName
 EvaluationWorkbook.ExternalName HSSFEvaluationWorkbook.getExternalName(int externSheetIndex, int externNameIndex)

Uses of EvaluationWorkbook.ExternalName in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return EvaluationWorkbook.ExternalName
 EvaluationWorkbook.ExternalName EvaluationWorkbook.getExternalName(int externSheetIndex, int externNameIndex)

Uses of EvaluationWorkbook.ExternalName in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return EvaluationWorkbook.ExternalName
 EvaluationWorkbook.ExternalName XSSFEvaluationWorkbook.getExternalName(int externSheetIndex, int externNameIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.EvaluationWorkbook.ExternalSheet

Packages that use EvaluationWorkbook.ExternalSheet
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of EvaluationWorkbook.ExternalSheet in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return EvaluationWorkbook.ExternalSheet
 EvaluationWorkbook.ExternalSheet InternalWorkbook.getExternalSheet(int externSheetIndex)

Uses of EvaluationWorkbook.ExternalSheet in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return EvaluationWorkbook.ExternalSheet
 EvaluationWorkbook.ExternalSheet HSSFEvaluationWorkbook.getExternalSheet(int externSheetIndex)

Uses of EvaluationWorkbook.ExternalSheet in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return EvaluationWorkbook.ExternalSheet
EvaluationWorkbook.ExternalSheet | FormulaRenderingWorkbook.getExternalSheet(int externSheetIndex)
EvaluationWorkbook.ExternalSheet | EvaluationWorkbook.getExternalSheet(int externSheetIndex)

Uses of EvaluationWorkbook.ExternalSheet in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return EvaluationWorkbook.ExternalSheet
 EvaluationWorkbook.ExternalSheet XSSFEvaluationWorkbook.getExternalSheet(int externSheetIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.EvaluationWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.EvaluationWorkbook

Packages that use EvaluationWorkbook
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of EvaluationWorkbook in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement EvaluationWorkbook
 class HSSFEvaluationWorkbook
Internal POI use only

Uses of EvaluationWorkbook in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return EvaluationWorkbook
 EvaluationWorkbook OperationEvaluationContext.getWorkbook()

Constructors in org.apache.poi.ss.formula with parameters of type EvaluationWorkbook
OperationEvaluationContext(WorkbookEvaluator bookEvaluator, EvaluationWorkbook workbook, int sheetIndex, int srcRowNum, int srcColNum, org.apache.poi.ss.formula.EvaluationTracker tracker)
WorkbookEvaluator(EvaluationWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Uses of EvaluationWorkbook in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement EvaluationWorkbook
 class XSSFEvaluationWorkbook
Internal POI use only

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.ExternSheetReferenceToken

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.ExternSheetReferenceToken

Packages that use ExternSheetReferenceToken
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of ExternSheetReferenceToken in org.apache.poi.ss.formula.ptg

Classes in org.apache.poi.ss.formula.ptg that implement ExternSheetReferenceToken
class | Area3DPtg Title: Area 3D Ptg - 3D reference (Sheet + Area)
class | Ref3DPtg Title: Reference 3D Ptg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.Formula

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.Formula

Packages that use Formula
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.

Uses of Formula in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return Formula
 Formula FormulaRecord.getFormula()

Constructors in org.apache.poi.hssf.record with parameters of type Formula
ArrayRecord(Formula formula, CellRangeAddress8Bit range)

Uses of Formula in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return Formula
 Formula Formula.copy()
static Formula Formula.create(Ptg[] ptgs)
Creates a Formula object from a supplied Ptg array.
static Formula Formula.read(int encodedTokenLen, LittleEndianInput in)
Convenience method for read(int, LittleEndianInput, int)
static Formula Formula.read(int encodedTokenLen, LittleEndianInput in, int totalEncodedLen)
When there are no array constants present, encodedTokenLen==totalEncodedLen

Methods in org.apache.poi.ss.formula with parameters of type Formula
static Ptg[] | Formula.getTokens(Formula formula) Gets the Ptg array from the supplied Formula.
boolean | Formula.isSame(Formula other)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.FormulaParseException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.FormulaParseException

Packages that use FormulaParseException
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |

Uses of FormulaParseException in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that throw FormulaParseException
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook) Convenience method for parsing cell formulas.
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType)
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType, int sheetIndex)

Uses of FormulaParseException in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that throw FormulaParseException
 void Cell.setCellFormula(java.lang.String formula)
Sets formula for this cell.

Uses of FormulaParseException in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that throw FormulaParseException
 void SXSSFCell.setCellFormula(java.lang.String formula)
Sets formula for this cell.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.FormulaParser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.FormulaParser

No usage of org.apache.poi.ss.formula.FormulaParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.FormulaParsingWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.FormulaParsingWorkbook

Packages that use FormulaParsingWorkbook
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of FormulaParsingWorkbook in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement FormulaParsingWorkbook
 class HSSFEvaluationWorkbook
Internal POI use only

Uses of FormulaParsingWorkbook in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula with parameters of type FormulaParsingWorkbook
static Ptg[] FormulaParser.parse(java.lang.String formula, FormulaParsingWorkbook workbook, int formulaType, int sheetIndex)
Parse a formula into a array of tokens

Uses of FormulaParsingWorkbook in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement FormulaParsingWorkbook
 class XSSFEvaluationWorkbook
Internal POI use only

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.FormulaRenderer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.FormulaRenderer

No usage of org.apache.poi.ss.formula.FormulaRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.FormulaRenderingWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.FormulaRenderingWorkbook

Packages that use FormulaRenderingWorkbook
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.xssf.usermodel |

Uses of FormulaRenderingWorkbook in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement FormulaRenderingWorkbook
 class HSSFEvaluationWorkbook
Internal POI use only

Uses of FormulaRenderingWorkbook in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula with parameters of type FormulaRenderingWorkbook
java.lang.String | WorkbookDependentFormula.toFormulaString(FormulaRenderingWorkbook book)
static java.lang.String | FormulaRenderer.toFormulaString(FormulaRenderingWorkbook book, Ptg[] ptgs) Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.

Uses of FormulaRenderingWorkbook in org.apache.poi.ss.formula.ptg

Methods in org.apache.poi.ss.formula.ptg with parameters of type FormulaRenderingWorkbook
java.lang.String | Ref3DPtg.toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | NameXPtg.toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | NamePtg.toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | DeletedRef3DPtg.toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | DeletedArea3DPtg.toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | Area3DPtg.toFormulaString(FormulaRenderingWorkbook book)

Uses of FormulaRenderingWorkbook in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement FormulaRenderingWorkbook
 class XSSFEvaluationWorkbook
Internal POI use only

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.FormulaShifter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.FormulaShifter

Packages that use FormulaShifter
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel.helpers |

Uses of FormulaShifter in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type FormulaShifter
void | InternalSheet.updateFormulasAfterCellShift(FormulaShifter shifter, int externSheetIndex) Updates formulas in cells and conditional formats due to moving of cells
void | InternalWorkbook.updateNamesAfterCellShift(FormulaShifter shifter) Updates named ranges due to moving of cells

Uses of FormulaShifter in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type FormulaShifter
void | ConditionalFormattingTable.updateFormulasAfterCellShift(FormulaShifter shifter, int externSheetIndex)
boolean | CFRecordsAggregate.updateFormulasAfterCellShift(FormulaShifter shifter, int currentExternSheetIx)
void | ValueRecordsAggregate.updateFormulasAfterRowShift(FormulaShifter shifter, int currentExternSheetIndex)
void | RowRecordsAggregate.updateFormulasAfterRowShift(FormulaShifter formulaShifter, int currentExternSheetIndex)

Uses of FormulaShifter in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return FormulaShifter
static FormulaShifter | FormulaShifter.createForRowShift(int externSheetIndex, int firstMovedRowIndex, int lastMovedRowIndex, int numberOfRowsToMove)
static FormulaShifter | FormulaShifter.createForSheetShift(int srcSheetIndex, int dstSheetIndex)

Uses of FormulaShifter in org.apache.poi.xssf.usermodel.helpers

Methods in org.apache.poi.xssf.usermodel.helpers with parameters of type FormulaShifter
void | XSSFRowShifter.updateConditionalFormatting(FormulaShifter shifter)
void | XSSFRowShifter.updateFormulas(FormulaShifter shifter) Update formulas.
void | XSSFRowShifter.updateNamedRanges(FormulaShifter shifter) Updated named ranges

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.FormulaType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.FormulaType

No usage of org.apache.poi.ss.formula.FormulaType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.IStabilityClassifier

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.IStabilityClassifier

Packages that use IStabilityClassifier
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.xssf.usermodel |

Uses of IStabilityClassifier in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel with parameters of type IStabilityClassifier
static HSSFFormulaEvaluator HSSFFormulaEvaluator.create(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Constructors in org.apache.poi.hssf.usermodel with parameters of type IStabilityClassifier
HSSFFormulaEvaluator(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier)

Uses of IStabilityClassifier in org.apache.poi.ss.formula

Fields in org.apache.poi.ss.formula declared as IStabilityClassifier
static IStabilityClassifier IStabilityClassifier.TOTALLY_IMMUTABLE
Convenience implementation for situations where all cell definitions remain fixed after evaluation begins.

Constructors in org.apache.poi.ss.formula with parameters of type IStabilityClassifier
WorkbookEvaluator(EvaluationWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Uses of IStabilityClassifier in org.apache.poi.ss.formula.eval.forked

Methods in org.apache.poi.ss.formula.eval.forked with parameters of type IStabilityClassifier
static ForkedEvaluator ForkedEvaluator.create(Workbook wb, IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use ForkedEvaluator.create(Workbook, IStabilityClassifier, UDFFinder)
static ForkedEvaluator ForkedEvaluator.create(Workbook wb, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Uses of IStabilityClassifier in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type IStabilityClassifier
static XSSFFormulaEvaluator XSSFFormulaEvaluator.create(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Constructors in org.apache.poi.xssf.usermodel with parameters of type IStabilityClassifier
XSSFFormulaEvaluator(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use XSSFFormulaEvaluator.create(XSSFWorkbook, org.apache.poi.ss.formula.IStabilityClassifier, org.apache.poi.ss.formula.udf.UDFFinder)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.OperationEvaluationContext

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.OperationEvaluationContext

Packages that use OperationEvaluationContext
org.apache.poi.ss.formula.functions

Uses of OperationEvaluationContext in org.apache.poi.ss.formula.functions

Methods in org.apache.poi.ss.formula.functions with parameters of type OperationEvaluationContext
ValueEval | Sumifs.evaluate(ValueEval[] args, OperationEvaluationContext ec)
ValueEval | Indirect.evaluate(ValueEval[] args, OperationEvaluationContext ec)
ValueEval | FreeRefFunction.evaluate(ValueEval[] args, OperationEvaluationContext ec)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.SharedFormula

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.SharedFormula

No usage of org.apache.poi.ss.formula.SharedFormula

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.SheetNameFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.SheetNameFormatter

No usage of org.apache.poi.ss.formula.SheetNameFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.TwoDEval

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.TwoDEval

Packages that use TwoDEval
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval |

Uses of TwoDEval in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return TwoDEval
TwoDEval | TwoDEval.getColumn(int columnIndex)
TwoDEval | TwoDEval.getRow(int rowIndex)

Uses of TwoDEval in org.apache.poi.ss.formula.eval

Subinterfaces of TwoDEval in org.apache.poi.ss.formula.eval
 interface AreaEval

Classes in org.apache.poi.ss.formula.eval that implement TwoDEval
 class AreaEvalBase

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.WorkbookDependentFormula

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.WorkbookDependentFormula

Packages that use WorkbookDependentFormula
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of WorkbookDependentFormula in org.apache.poi.ss.formula.ptg

Classes in org.apache.poi.ss.formula.ptg that implement WorkbookDependentFormula
class | Area3DPtg Title: Area 3D Ptg - 3D reference (Sheet + Area)
class | DeletedArea3DPtg Title: Deleted Area 3D Ptg - 3D referecnce (Sheet + Area)
class | DeletedRef3DPtg Title: Deleted Reference 3D Ptg
class | NamePtg
class | NameXPtg
class | Ref3DPtg Title: Reference 3D Ptg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.WorkbookEvaluator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.WorkbookEvaluator

Packages that use WorkbookEvaluator
org.apache.poi.ss.formula This package contains common internal POI code for manipulating formulas.

Uses of WorkbookEvaluator in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return WorkbookEvaluator
 WorkbookEvaluator CollaboratingWorkbooksEnvironment.getWorkbookEvaluator(java.lang.String workbookName)

Methods in org.apache.poi.ss.formula with parameters of type WorkbookEvaluator
static void CollaboratingWorkbooksEnvironment.setup(java.lang.String[] workbookNames, WorkbookEvaluator[] evaluators)

Constructors in org.apache.poi.ss.formula with parameters of type WorkbookEvaluator
OperationEvaluationContext(WorkbookEvaluator bookEvaluator, EvaluationWorkbook workbook, int sheetIndex, int srcRowNum, int srcColNum, org.apache.poi.ss.formula.EvaluationTracker tracker)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ConstantValueParser

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.constant
Class ConstantValueParser

java.lang.Object
    extended by  org.apache.poi.ss.formula.constant.ConstantValueParser

public final class ConstantValueParser
extends java.lang.Object

To support Constant Values (2.5.7) as required by the CRN record. This class is also used for two dimensional arrays which are encoded by EXTERNALNAME (5.39) records and Array tokens.

Author:
Josh Micich

Method Summary
static void | encode(LittleEndianOutput out, java.lang.Object[] values)
static int | getEncodedSize(java.lang.Object[] values)
static java.lang.Object[] | parse(LittleEndianInput in, int nValues)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

parse

public static java.lang.Object[] parse(LittleEndianInput in,
                                       int nValues)

getEncodedSize

public static int getEncodedSize(java.lang.Object[] values)

encode

public static void encode(LittleEndianOutput out,
                          java.lang.Object[] values)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ErrorConstant

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.constant
Class ErrorConstant

java.lang.Object
    extended by  org.apache.poi.ss.formula.constant.ErrorConstant

public class ErrorConstant
extends java.lang.Object

Represents a constant error code value as encoded in a constant values array.

This class is a type-safe wrapper for a 16-bit int value performing a similar job to ErrorEval.

Author:
Josh Micich

Method Summary
int | getErrorCode()
java.lang.String | getText()
java.lang.String | toString()
static ErrorConstant | valueOf(int errorCode)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getErrorCode

public int getErrorCode()

getText

public java.lang.String getText()

valueOf

public static ErrorConstant valueOf(int errorCode)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.constant
Classes
ConstantValueParser
ErrorConstant


org.apache.poi.ss.formula.constant

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.constant

Class Summary
ConstantValueParser | To support Constant Values (2.5.7) as required by the CRN record.
ErrorConstant | Represents a constant error code value as encoded in a constant values array.


org.apache.poi.ss.formula.constant Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.constant

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.constant.ConstantValueParser
    • org.apache.poi.ss.formula.constant.ErrorConstant


Uses of Package org.apache.poi.ss.formula.constant

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.constant

Packages that use org.apache.poi.ss.formula.constant
org.apache.poi.ss.formula.constant

Classes in org.apache.poi.ss.formula.constant used by org.apache.poi.ss.formula.constant
ErrorConstant
Represents a constant error code value as encoded in a constant values array.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.constant.ConstantValueParser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.constant.ConstantValueParser

No usage of org.apache.poi.ss.formula.constant.ConstantValueParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.constant.ErrorConstant

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.constant.ErrorConstant

Packages that use ErrorConstant
org.apache.poi.ss.formula.constant

Uses of ErrorConstant in org.apache.poi.ss.formula.constant

Methods in org.apache.poi.ss.formula.constant that return ErrorConstant
static ErrorConstant ErrorConstant.valueOf(int errorCode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AreaEval

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Interface AreaEval

All Superinterfaces:
TwoDEval, ValueEval
All Known Implementing Classes:
AreaEvalBase
public interface AreaEval
extends TwoDEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Method Summary
boolean | contains(int row, int col) returns true if the cell at row and col specified as absolute indexes in the sheet is contained in this area.
boolean | containsColumn(int col) returns true if the specified col is in range
boolean | containsRow(int row) returns true if the specified row is in range
ValueEval | getAbsoluteValue(int row, int col)
int | getFirstColumn() returns the 0-based index of the first col in this area.
int | getFirstRow() returns the 0-based index of the first row in this area.
int | getHeight()
int | getLastColumn() returns the 0-based index of the last col in this area.
int | getLastRow() returns the 0-based index of the last row in this area.
ValueEval | getRelativeValue(int relativeRowIndex, int relativeColumnIndex)
int | getWidth()
AreaEval | offset(int relFirstRowIx, int relLastRowIx, int relFirstColIx, int relLastColIx) Creates an AreaEval offset by a relative amount from from the upper left cell of this area
Methods inherited from interface org.apache.poi.ss.formula.TwoDEval
getColumn, getRow, getValue, isColumn, isRow, isSubTotal

Method Detail

getFirstRow

int getFirstRow()
returns the 0-based index of the first row in this area.

getLastRow

int getLastRow()
returns the 0-based index of the last row in this area.

getFirstColumn

int getFirstColumn()
returns the 0-based index of the first col in this area.

getLastColumn

int getLastColumn()
returns the 0-based index of the last col in this area.

getAbsoluteValue

ValueEval getAbsoluteValue(int row,
                           int col)
Returns:
the ValueEval from within this area at the specified row and col index. Never null (possibly BlankEval). The specified indexes should be absolute indexes in the sheet and not relative indexes within the area.

contains

boolean contains(int row,
                 int col)
returns true if the cell at row and col specified as absolute indexes in the sheet is contained in this area.

Parameters:
row -
col -

containsColumn

boolean containsColumn(int col)
returns true if the specified col is in range

Parameters:
col -

containsRow

boolean containsRow(int row)
returns true if the specified row is in range

Parameters:
row -

getWidth

int getWidth()
Specified by:
getWidth in interface TwoDEval

getHeight

int getHeight()
Specified by:
getHeight in interface TwoDEval

getRelativeValue

ValueEval getRelativeValue(int relativeRowIndex,
                           int relativeColumnIndex)
Returns:
the ValueEval from within this area at the specified relativeRowIndex and relativeColumnIndex. Never null (possibly BlankEval). The specified indexes should relative to the top left corner of this area.

offset

AreaEval offset(int relFirstRowIx,
                int relLastRowIx,
                int relFirstColIx,
                int relLastColIx)
Creates an AreaEval offset by a relative amount from from the upper left cell of this area

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AreaEvalBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class AreaEvalBase

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.AreaEvalBase
All Implemented Interfaces:
AreaEval, ValueEval, TwoDEval
public abstract class AreaEvalBase
extends java.lang.Object
implements AreaEval

Author:
Josh Micich

Constructor Summary
protected | AreaEvalBase(AreaI ptg)
protected | AreaEvalBase(int firstRow, int firstColumn, int lastRow, int lastColumn)
Method Summary
boolean | contains(int row, int col) returns true if the cell at row and col specified as absolute indexes in the sheet is contained in this area.
boolean | containsColumn(int col) returns true if the specified col is in range
boolean | containsRow(int row) returns true if the specified row is in range
ValueEval | getAbsoluteValue(int row, int col)
int | getFirstColumn() returns the 0-based index of the first col in this area.
int | getFirstRow() returns the 0-based index of the first row in this area.
int | getHeight()
int | getLastColumn() returns the 0-based index of the last col in this area.
int | getLastRow() returns the 0-based index of the last row in this area.
abstract ValueEval | getRelativeValue(int relativeRowIndex, int relativeColumnIndex)
ValueEval | getValue(int row, int col)
int | getWidth()
boolean | isColumn()
boolean | isRow()
boolean | isSubTotal(int rowIndex, int columnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.formula.eval.AreaEval
offset
Methods inherited from interface org.apache.poi.ss.formula.TwoDEval
getColumn, getRow

Constructor Detail

AreaEvalBase

protected AreaEvalBase(int firstRow,
                       int firstColumn,
                       int lastRow,
                       int lastColumn)

AreaEvalBase

protected AreaEvalBase(AreaI ptg)
Method Detail

getFirstColumn

public final int getFirstColumn()
Description copied from interface: AreaEval
returns the 0-based index of the first col in this area.

Specified by:
getFirstColumn in interface AreaEval

getFirstRow

public final int getFirstRow()
Description copied from interface: AreaEval
returns the 0-based index of the first row in this area.

Specified by:
getFirstRow in interface AreaEval

getLastColumn

public final int getLastColumn()
Description copied from interface: AreaEval
returns the 0-based index of the last col in this area.

Specified by:
getLastColumn in interface AreaEval

getLastRow

public final int getLastRow()
Description copied from interface: AreaEval
returns the 0-based index of the last row in this area.

Specified by:
getLastRow in interface AreaEval

getAbsoluteValue

public final ValueEval getAbsoluteValue(int row,
                                        int col)
Specified by:
getAbsoluteValue in interface AreaEval
Returns:
the ValueEval from within this area at the specified row and col index. Never null (possibly BlankEval). The specified indexes should be absolute indexes in the sheet and not relative indexes within the area.

contains

public final boolean contains(int row,
                              int col)
Description copied from interface: AreaEval
returns true if the cell at row and col specified as absolute indexes in the sheet is contained in this area.

Specified by:
contains in interface AreaEval

containsRow

public final boolean containsRow(int row)
Description copied from interface: AreaEval
returns true if the specified row is in range

Specified by:
containsRow in interface AreaEval

containsColumn

public final boolean containsColumn(int col)
Description copied from interface: AreaEval
returns true if the specified col is in range

Specified by:
containsColumn in interface AreaEval

isColumn

public final boolean isColumn()
Specified by:
isColumn in interface TwoDEval
Returns:
true if the area has just a single column, this also includes the trivial case when the area has just a single cell.

isRow

public final boolean isRow()
Specified by:
isRow in interface TwoDEval
Returns:
true if the area has just a single row, this also includes the trivial case when the area has just a single cell.

getHeight

public int getHeight()
Specified by:
getHeight in interface AreaEval
Specified by:
getHeight in interface TwoDEval

getValue

public final ValueEval getValue(int row,
                                int col)
Specified by:
getValue in interface TwoDEval
Parameters:
row - relative row index (zero based)
col - relative column index (zero based)
Returns:
element at the specified row and column position

getRelativeValue

public abstract ValueEval getRelativeValue(int relativeRowIndex,
                                           int relativeColumnIndex)
Specified by:
getRelativeValue in interface AreaEval
Returns:
the ValueEval from within this area at the specified relativeRowIndex and relativeColumnIndex. Never null (possibly BlankEval). The specified indexes should relative to the top left corner of this area.

getWidth

public int getWidth()
Specified by:
getWidth in interface AreaEval
Specified by:
getWidth in interface TwoDEval

isSubTotal

public boolean isSubTotal(int rowIndex,
                          int columnIndex)
Specified by:
isSubTotal in interface TwoDEval
Returns:
whether cell at rowIndex and columnIndex is a subtotal. By default return false which means 'don't care about subtotals'
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlankEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class BlankEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.BlankEval
All Implemented Interfaces:
ValueEval
public final class BlankEval
extends java.lang.Object
implements ValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com > This class is a marker class. It is a special value for empty cells.

Field Summary
static BlankEval | instance
static BlankEval | INSTANCE Deprecated. (Nov 2009) use instance
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final BlankEval instance

INSTANCE

public static final BlankEval INSTANCE
Deprecated. (Nov 2009) use instance
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BoolEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class BoolEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.BoolEval
All Implemented Interfaces:
NumericValueEval, StringValueEval, ValueEval
public final class BoolEval
extends java.lang.Object
implements NumericValueEval, StringValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static BoolEval | FALSE
static BoolEval | TRUE
Method Summary
boolean | getBooleanValue()
double | getNumberValue()
java.lang.String | getStringValue()
java.lang.String | toString()
static BoolEval | valueOf(boolean b) Convenience method for the following: (b ? BoolEval.TRUE : BoolEval.FALSE)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FALSE

public static final BoolEval FALSE

TRUE

public static final BoolEval TRUE
Method Detail

valueOf

public static final BoolEval valueOf(boolean b)
Convenience method for the following:
(b ? BoolEval.TRUE : BoolEval.FALSE)

Returns:
the BoolEval instance representing b.

getBooleanValue

public boolean getBooleanValue()

getNumberValue

public double getNumberValue()
Specified by:
getNumberValue in interface NumericValueEval

getStringValue

public java.lang.String getStringValue()
Specified by:
getStringValue in interface StringValueEval
Returns:
never null, possibly empty string.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConcatEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class ConcatEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.eval.ConcatEval
All Implemented Interfaces:
Function, Function2Arg
public final class ConcatEval
extends Fixed2ArgFunction

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function instance
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final Function instance
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ErrorEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class ErrorEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.ErrorEval
All Implemented Interfaces:
ValueEval
public final class ErrorEval
extends java.lang.Object
implements ValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static ErrorEval | CIRCULAR_REF_ERROR
static ErrorEval | DIV_ZERO #DIV/0! - Division by zero
static ErrorEval | NA #N/A - Argument or function not available
static ErrorEval | NAME_INVALID #NAME? - Wrong function or range name
static ErrorEval | NULL_INTERSECTION #NULL! - Intersection of two cell ranges is empty
static ErrorEval | NUM_ERROR #NUM! - Value range overflow
static ErrorEval | REF_INVALID #REF! - Illegal or deleted cell reference
static ErrorEval | VALUE_INVALID #VALUE! - Wrong type of operand
Method Summary
int | getErrorCode()
static java.lang.String | getText(int errorCode) Converts error codes to text.
java.lang.String | toString()
static ErrorEval | valueOf(int errorCode) Translates an Excel internal error code into the corresponding POI ErrorEval instance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NULL_INTERSECTION

public static final ErrorEval NULL_INTERSECTION
#NULL! - Intersection of two cell ranges is empty

DIV_ZERO

public static final ErrorEval DIV_ZERO
#DIV/0! - Division by zero

VALUE_INVALID

public static final ErrorEval VALUE_INVALID
#VALUE! - Wrong type of operand

REF_INVALID

public static final ErrorEval REF_INVALID
#REF! - Illegal or deleted cell reference

NAME_INVALID

public static final ErrorEval NAME_INVALID
#NAME? - Wrong function or range name

NUM_ERROR

public static final ErrorEval NUM_ERROR
#NUM! - Value range overflow

NA

public static final ErrorEval NA
#N/A - Argument or function not available

CIRCULAR_REF_ERROR

public static final ErrorEval CIRCULAR_REF_ERROR
Method Detail

valueOf

public static ErrorEval valueOf(int errorCode)
Translates an Excel internal error code into the corresponding POI ErrorEval instance

Parameters:
errorCode -

getText

public static java.lang.String getText(int errorCode)
Converts error codes to text. Handles non-standard error codes OK. For debug/test purposes (and for formatting error messages).

Returns:
the String representation of the specified Excel error code.

getErrorCode

public int getErrorCode()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvaluationException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class EvaluationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.apache.poi.ss.formula.eval.EvaluationException
All Implemented Interfaces:
java.io.Serializable
public final class EvaluationException
extends java.lang.Exception

This class is used to simplify error handling logic within operator and function implementations. Note - OperationEval.evaluate() and Function.evaluate() method signatures do not throw this exception so it cannot propagate outside.

Here is an example coded without EvaluationException, to show how it can help:

 public Eval evaluate(Eval[] args, int srcRow, short srcCol) {
        // ...
        Eval arg0 = args[0];
        if(arg0 instanceof ErrorEval) {
                return arg0;
        }
        if(!(arg0 instanceof AreaEval)) {
                return ErrorEval.VALUE_INVALID;
        }
        double temp = 0;
        AreaEval area = (AreaEval)arg0;
        ValueEval[] values = area.getValues();
        for (int i = 0; i < values.length; i++) {
                ValueEval ve = values[i];
                if(ve instanceof ErrorEval) {
                        return ve;
                }
                if(!(ve instanceof NumericValueEval)) {
                        return ErrorEval.VALUE_INVALID;
                }
                temp += ((NumericValueEval)ve).getNumberValue();
        }
        // ...
 }
In this example, if any error is encountered while processing the arguments, an error is returned immediately. This code is difficult to refactor due to all the points where errors are returned.
Using EvaluationException allows the error returning code to be consolidated to one place.

 public Eval evaluate(Eval[] args, int srcRow, short srcCol) {
        try {
                // ...
                AreaEval area = getAreaArg(args[0]);
                double temp = sumValues(area.getValues());
                // ...
        } catch (EvaluationException e) {
                return e.getErrorEval();
        }
}

private static AreaEval getAreaArg(Eval arg0) throws EvaluationException {
        if (arg0 instanceof ErrorEval) {
                throw new EvaluationException((ErrorEval) arg0);
        }
        if (arg0 instanceof AreaEval) {
                return (AreaEval) arg0;
        }
        throw EvaluationException.invalidValue();
}

private double sumValues(ValueEval[] values) throws EvaluationException {
        double temp = 0;
        for (int i = 0; i < values.length; i++) {
                ValueEval ve = values[i];
                if (ve instanceof ErrorEval) {
                        throw new EvaluationException((ErrorEval) ve);
                }
                if (!(ve instanceof NumericValueEval)) {
                        throw EvaluationException.invalidValue();
                }
                temp += ((NumericValueEval) ve).getNumberValue();
        }
        return temp;
}
It is not mandatory to use EvaluationException, doing so might give the following advantages:
- Methods can more easily be extracted, allowing for re-use.
- Type management (typecasting etc) is simpler because error conditions have been separated from intermediate calculation values.
- Fewer local variables are required. Local variables can have stronger types.
- It is easier to mimic common Excel error handling behaviour (exit upon encountering first error), because exceptions conveniently propagate up the call stack regardless of execution points or the number of levels of nested calls.

Note - Only standard evaluation errors are represented by EvaluationException ( i.e. conditions expected to be encountered when evaluating arbitrary Excel formulas). Conditions that could never occur in an Excel spreadsheet should result in runtime exceptions. Care should be taken to not translate any POI internal error into an Excel evaluation error code.

Author:
Josh Micich
See Also:
Serialized Form

Constructor Summary
EvaluationException(ErrorEval errorEval)
Method Summary
ErrorEval | getErrorEval()
static EvaluationException | invalidRef() #REF! - Illegal or deleted cell reference
static EvaluationException | invalidValue() #VALUE! - Wrong type of operand
static EvaluationException | numberError() #NUM! - Value range overflow
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EvaluationException

public EvaluationException(ErrorEval errorEval)
Method Detail

invalidValue

public static EvaluationException invalidValue()
#VALUE! - Wrong type of operand

invalidRef

public static EvaluationException invalidRef()
#REF! - Illegal or deleted cell reference

numberError

public static EvaluationException numberError()
#NUM! - Value range overflow

getErrorEval

public ErrorEval getErrorEval()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FunctionEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class FunctionEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.FunctionEval

public final class FunctionEval
extends java.lang.Object

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
protected static Function[] functions
Array elements corresponding to unimplemented functions are null
Constructor Summary
FunctionEval()
Method Summary
static Function | getBasicFunction(int functionIndex)
static java.util.Collection<java.lang.String> | getNotSupportedFunctionNames() Returns an array of function names NOT implemented by POI.
static java.util.Collection<java.lang.String> | getSupportedFunctionNames() Returns a collection of function names implemented by POI.
static void | registerFunction(java.lang.String name, Function func) Register a new function in runtime.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

functions

protected static final Function[] functions
Array elements corresponding to unimplemented functions are null

Constructor Detail

FunctionEval

public FunctionEval()
Method Detail

getBasicFunction

public static Function getBasicFunction(int functionIndex)
Returns:
null if the specified functionIndex is for INDIRECT() or any external (add-in) function.

registerFunction

public static void registerFunction(java.lang.String name,
                                    Function func)
Register a new function in runtime.

Parameters:
name - the function name
func - the functoin to register
Throws:
java.lang.IllegalArgumentException - if the function is unknown or already registered.
Since:
3.8 beta6

getSupportedFunctionNames

public static java.util.Collection<java.lang.String> getSupportedFunctionNames()
Returns a collection of function names implemented by POI.

Returns:
an array of supported functions
Since:
3.8 beta6

getNotSupportedFunctionNames

public static java.util.Collection<java.lang.String> getNotSupportedFunctionNames()
Returns an array of function names NOT implemented by POI.

Returns:
an array of not supported functions
Since:
3.8 beta6
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntersectionEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class IntersectionEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.eval.IntersectionEval
All Implemented Interfaces:
Function, Function2Arg
public final class IntersectionEval
extends Fixed2ArgFunction

Author:
Josh Micich

Field Summary
static Function instance
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final Function instance
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MissingArgEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class MissingArgEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.MissingArgEval
All Implemented Interfaces:
ValueEval
public final class MissingArgEval
extends java.lang.Object
implements ValueEval

Represents the (intermediate) evaluated result of a missing function argument. In most cases this can be translated into BlankEval but there are some notable exceptions. Functions COUNT and COUNTA do count their missing args. Note - the differences between MissingArgEval and BlankEval have not been investigated fully, so the POI evaluator may need to be updated to account for these as they are found.

Author:
Josh Micich

Field Summary
static MissingArgEval instance
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final MissingArgEval instance
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NameEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class NameEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.NameEval
All Implemented Interfaces:
ValueEval
public final class NameEval
extends java.lang.Object
implements ValueEval

Author:
Josh Micich

Constructor Summary
NameEval(java.lang.String functionName)
Creates a NameEval representing a function name
Method Summary
java.lang.String | getFunctionName()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NameEval

public NameEval(java.lang.String functionName)
Creates a NameEval representing a function name

Method Detail

getFunctionName

public java.lang.String getFunctionName()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NameXEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class NameXEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.NameXEval
All Implemented Interfaces:
ValueEval
public final class NameXEval
extends java.lang.Object
implements ValueEval

Author:
Josh Micich

Constructor Summary
NameXEval(NameXPtg ptg)
Method Summary
NameXPtg | getPtg()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NameXEval

public NameXEval(NameXPtg ptg)
Method Detail

getPtg

public NameXPtg getPtg()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotImplementedException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class NotImplementedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.ss.formula.eval.NotImplementedException
All Implemented Interfaces:
java.io.Serializable
public final class NotImplementedException
extends java.lang.RuntimeException

An exception thrown by implementors of FormulaEvaluator when attempting to evaluate a formula which requires features that POI does not (yet) support.

Author:
Josh Micich
See Also:
Serialized Form

Constructor Summary
NotImplementedException(java.lang.String message)
NotImplementedException(java.lang.String message, NotImplementedException cause)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotImplementedException

public NotImplementedException(java.lang.String message)

NotImplementedException

public NotImplementedException(java.lang.String message,
                               NotImplementedException cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumberEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class NumberEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.NumberEval
All Implemented Interfaces:
NumericValueEval, StringValueEval, ValueEval
public final class NumberEval
extends java.lang.Object
implements NumericValueEval, StringValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static NumberEval ZERO
Constructor Summary
NumberEval(double value)
NumberEval(Ptg ptg)
Method Summary
double | getNumberValue()
java.lang.String | getStringValue()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ZERO

public static final NumberEval ZERO
Constructor Detail

NumberEval

public NumberEval(Ptg ptg)

NumberEval

public NumberEval(double value)
Method Detail

getNumberValue

public double getNumberValue()
Specified by:
getNumberValue in interface NumericValueEval

getStringValue

public java.lang.String getStringValue()
Specified by:
getStringValue in interface StringValueEval
Returns:
never null, possibly empty string.

toString

public final java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumericValueEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Interface NumericValueEval

All Superinterfaces:
ValueEval
All Known Implementing Classes:
BoolEval, NumberEval
public interface NumericValueEval
extends ValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Method Summary
 double getNumberValue()

Method Detail

getNumberValue

double getNumberValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperandResolver

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class OperandResolver

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.OperandResolver

public final class OperandResolver
extends java.lang.Object

Provides functionality for evaluating arguments to functions and operators.

Author:
Josh Micich, Brendan Nolan

Method Summary
static ValueEval | chooseSingleElementFromArea(AreaEval ae, int srcCellRow, int srcCellCol) Implements (some perhaps not well known) Excel functionality to select a single cell from an area depending on the coordinates of the calling cell.
static java.lang.Boolean | coerceValueToBoolean(ValueEval ve, boolean stringsAreBlanks)
static double | coerceValueToDouble(ValueEval ev) Applies some conversion rules if the supplied value is not already a number.
static int | coerceValueToInt(ValueEval ev) Applies some conversion rules if the supplied value is not already an integer. Value is first coerced to a double ( See coerceValueToDouble() ).
static java.lang.String | coerceValueToString(ValueEval ve)
static ValueEval | getSingleValue(ValueEval arg, int srcCellRow, int srcCellCol) Retrieves a single value from a variety of different argument types according to standard Excel rules.
static java.lang.Double | parseDouble(java.lang.String pText) Converts a string to a double using standard rules that Excel would use. Tolerates leading and trailing spaces, Doesn't support currency prefixes, commas, percentage signs or arithmetic operations strings.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getSingleValue

public static ValueEval getSingleValue(ValueEval arg,
                                       int srcCellRow,
                                       int srcCellCol)
                                throws EvaluationException
Retrieves a single value from a variety of different argument types according to standard Excel rules. Does not perform any type conversion.

Parameters:
arg - the evaluated argument as passed to the function or operator.
srcCellRow - used when arg is a single column AreaRef
srcCellCol - used when arg is a single row AreaRef
Returns:
a NumberEval, StringEval, BoolEval or BlankEval. Never null or ErrorEval.
Throws:
EvaluationException(#VALUE!) - if srcCellRow or srcCellCol do not properly index into an AreaEval. If the actual value retrieved is an ErrorEval, a corresponding EvaluationException is thrown.
EvaluationException

chooseSingleElementFromArea

public static ValueEval chooseSingleElementFromArea(AreaEval ae,
                                                    int srcCellRow,
                                                    int srcCellCol)
                                             throws EvaluationException
Implements (some perhaps not well known) Excel functionality to select a single cell from an area depending on the coordinates of the calling cell. Here is an example demonstrating both selection from a single row area and a single column area in the same formula.
A | B | C | D
1 | 15 | 20 | 25
2 | 200
3 | 300
3 | 400
If the formula "=1000+A1:B1+D2:D3" is put into the 9 cells from A2 to C4, the spreadsheet will look like this:
A | B | C | D
1 | 15 | 20 | 25
2 | 1215 | 1220 | #VALUE! | 200
3 | 1315 | 1320 | #VALUE! | 300
4 | #VALUE! | #VALUE! | #VALUE! | 400
Note that the row area (A1:B1) does not include column C and the column area (D2:D3) does not include row 4, so the values in C1(=25) and D4(=400) are not accessible to the formula as written, but in the 4 cells A2:B3, the row and column selection works ok.

The same concept is extended to references across sheets, such that even multi-row, multi-column areas can be useful.

Of course with carefully (or carelessly) chosen parameters, cyclic references can occur and hence this method can throw a 'circular reference' EvaluationException. Note that this method does not attempt to detect cycles. Every cell in the specified Area ae has already been evaluated prior to this method call. Any cell (or cells) part of ae that would incur a cyclic reference error if selected by this method, will already have the value ErrorEval.CIRCULAR_REF_ERROR upon entry to this method. It is assumed logic exists elsewhere to produce this behaviour.

Returns:
whatever the selected cell's evaluated value is. Never null. Never ErrorEval.
Throws:
EvaluationException - if there is a problem with indexing into the area, or if the evaluated cell has an error.

coerceValueToInt

public static int coerceValueToInt(ValueEval ev)
                            throws EvaluationException
Applies some conversion rules if the supplied value is not already an integer.
Value is first coerced to a double ( See coerceValueToDouble() ). Note - BlankEval is converted to 0.

Excel typically converts doubles to integers by truncating toward negative infinity.
The equivalent java code is:
return (int)Math.floor(d);
not:
return (int)d; // wrong - rounds toward zero

Throws:
EvaluationException

coerceValueToDouble

public static double coerceValueToDouble(ValueEval ev)
                                  throws EvaluationException
Applies some conversion rules if the supplied value is not already a number. Note - BlankEval is converted to NumberEval.ZERO.

Parameters:
ev - must be a NumberEval, StringEval, BoolEval or BlankEval
Returns:
actual, parsed or interpreted double value (respectively).
Throws:
EvaluationException(#VALUE!) - only if a StringEval is supplied and cannot be parsed as a double (See parseDouble() for allowable formats).
java.lang.RuntimeException - if the supplied parameter is not NumberEval, StringEval, BoolEval or BlankEval
EvaluationException

parseDouble

public static java.lang.Double parseDouble(java.lang.String pText)
Converts a string to a double using standard rules that Excel would use.
Tolerates leading and trailing spaces,

Doesn't support currency prefixes, commas, percentage signs or arithmetic operations strings. Some examples:
" 123 " -> 123.0
".123" -> 0.123
"1E4" -> 1000
"-123" -> -123.0
These not supported yet:
" $ 1,000.00 " -> 1000.0
"$1.25E4" -> 12500.0
"5**2" -> 500
"250%" -> 2.5

Returns:
null if the specified text cannot be parsed as a number

coerceValueToString

public static java.lang.String coerceValueToString(ValueEval ve)
Parameters:
ve - must be a NumberEval, StringEval, BoolEval, or BlankEval
Returns:
the converted string value. never null

coerceValueToBoolean

public static java.lang.Boolean coerceValueToBoolean(ValueEval ve,
                                                     boolean stringsAreBlanks)
                                              throws EvaluationException
Returns:
null to represent blank values
Throws:
EvaluationException - if ve is an ErrorEval, or if a string value cannot be converted
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.eval
Interfaces
AreaEval
NumericValueEval
RefEval
StringValueEval
ValueEval
Classes
AreaEvalBase
BlankEval
BoolEval
ConcatEval
ErrorEval
FunctionEval
IntersectionEval
MissingArgEval
NameEval
NameXEval
NumberEval
OperandResolver
PercentEval
RangeEval
RefEvalBase
RelationalOperationEval
StringEval
TwoOperandNumericOperation
UnaryMinusEval
UnaryPlusEval
Exceptions
EvaluationException
NotImplementedException


org.apache.poi.ss.formula.eval

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.eval

Interface Summary
AreaEval
NumericValueEval
RefEval
StringValueEval
ValueEval

Class Summary
AreaEvalBase |
BlankEval |
BoolEval |
ConcatEval |
ErrorEval |
FunctionEval |
IntersectionEval |
MissingArgEval | Represents the (intermediate) evaluated result of a missing function argument.
NameEval |
NameXEval |
NumberEval |
OperandResolver | Provides functionality for evaluating arguments to functions and operators.
PercentEval | Implementation of Excel formula token '%'.
RangeEval |
RefEvalBase | Common base class for implementors of RefEval
RelationalOperationEval | Base class for all comparison operator evaluators
StringEval |
TwoOperandNumericOperation |
UnaryMinusEval |
UnaryPlusEval |

Exception Summary
EvaluationException | This class is used to simplify error handling logic within operator and function implementations.
NotImplementedException | An exception thrown by implementors of FormulaEvaluator when attempting to evaluate a formula which requires features that POI does not (yet) support.


org.apache.poi.ss.formula.eval Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.eval

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.eval.AreaEvalBase (implements org.apache.poi.ss.formula.eval.AreaEval)
    • org.apache.poi.ss.formula.eval.BlankEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.ss.formula.eval.BoolEval (implements org.apache.poi.ss.formula.eval.NumericValueEval, org.apache.poi.ss.formula.eval.StringValueEval)
    • org.apache.poi.ss.formula.eval.ErrorEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.ss.formula.functions.Fixed1ArgFunction (implements org.apache.poi.ss.formula.functions.Function1Arg)
      • org.apache.poi.ss.formula.eval.PercentEval
      • org.apache.poi.ss.formula.eval.UnaryMinusEval
      • org.apache.poi.ss.formula.eval.UnaryPlusEval
    • org.apache.poi.ss.formula.functions.Fixed2ArgFunction (implements org.apache.poi.ss.formula.functions.Function2Arg)
      • org.apache.poi.ss.formula.eval.ConcatEval
      • org.apache.poi.ss.formula.eval.IntersectionEval
      • org.apache.poi.ss.formula.eval.RangeEval
      • org.apache.poi.ss.formula.eval.RelationalOperationEval
      • org.apache.poi.ss.formula.eval.TwoOperandNumericOperation
    • org.apache.poi.ss.formula.eval.FunctionEval
    • org.apache.poi.ss.formula.eval.MissingArgEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.ss.formula.eval.NameEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.ss.formula.eval.NameXEval (implements org.apache.poi.ss.formula.eval.ValueEval)
    • org.apache.poi.ss.formula.eval.NumberEval (implements org.apache.poi.ss.formula.eval.NumericValueEval, org.apache.poi.ss.formula.eval.StringValueEval)
    • org.apache.poi.ss.formula.eval.OperandResolver
    • org.apache.poi.ss.formula.eval.RefEvalBase (implements org.apache.poi.ss.formula.eval.RefEval)
    • org.apache.poi.ss.formula.eval.StringEval (implements org.apache.poi.ss.formula.eval.StringValueEval)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.apache.poi.ss.formula.eval.EvaluationException
        • java.lang.RuntimeException
          • org.apache.poi.ss.formula.eval.NotImplementedException

Interface Hierarchy

  • org.apache.poi.ss.formula.eval.ValueEval
    • org.apache.poi.ss.formula.eval.NumericValueEval
    • org.apache.poi.ss.formula.eval.RefEval
    • org.apache.poi.ss.formula.eval.StringValueEval
    • org.apache.poi.ss.formula.TwoDEval
      • org.apache.poi.ss.formula.eval.AreaEval


Uses of Package org.apache.poi.ss.formula.eval

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.eval

Packages that use org.apache.poi.ss.formula.eval
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.atp |
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.formula.functions |

Classes in org.apache.poi.ss.formula.eval used by org.apache.poi.ss.formula
ValueEval

Classes in org.apache.poi.ss.formula.eval used by org.apache.poi.ss.formula.atp
EvaluationException
This class is used to simplify error handling logic within operator and function implementations.

Classes in org.apache.poi.ss.formula.eval used by org.apache.poi.ss.formula.eval
AreaEval
BlankEval
BoolEval
ErrorEval
EvaluationException
This class is used to simplify error handling logic within operator and function implementations.
MissingArgEval
Represents the (intermediate) evaluated result of a missing function argument.
NotImplementedException
An exception thrown by implementors of FormulaEvaluator when attempting to evaluate a formula which requires features that POI does not (yet) support.
NumberEval
NumericValueEval
RefEval
StringEval
StringValueEval
ValueEval

Classes in org.apache.poi.ss.formula.eval used by org.apache.poi.ss.formula.eval.forked
ValueEval

Classes in org.apache.poi.ss.formula.eval used by org.apache.poi.ss.formula.functions
EvaluationException
This class is used to simplify error handling logic within operator and function implementations.
ValueEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PercentEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class PercentEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.eval.PercentEval
All Implemented Interfaces:
Function, Function1Arg
public final class PercentEval
extends Fixed1ArgFunction

Implementation of Excel formula token '%'.

Author:
Josh Micich

Field Summary
static Function instance
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final Function instance
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RangeEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class RangeEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.eval.RangeEval
All Implemented Interfaces:
Function, Function2Arg
public final class RangeEval
extends Fixed2ArgFunction

Author:
Josh Micich

Field Summary
static Function instance
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final Function instance
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Interface RefEval

All Superinterfaces:
ValueEval
All Known Implementing Classes:
RefEvalBase
public interface RefEval
extends ValueEval

Author:
Amol S Deshmukh < amolweb at ya hoo dot com > RefEval is the super interface for Ref2D and Ref3DEval. Basically a RefEval impl should contain reference to the original ReferencePtg or Ref3DPtg as well as the final "value" resulting from the evaluation of the cell reference. Thus if the Cell has type CELL_TYPE_NUMERIC, the contained value object should be of type NumberEval; if cell type is CELL_TYPE_STRING, contained value object should be of type StringEval

Method Summary
int | getColumn() returns the zero based column index.
ValueEval | getInnerValueEval()
int | getRow() returns the zero based row index.
AreaEval | offset(int relFirstRowIx, int relLastRowIx, int relFirstColIx, int relLastColIx) Creates an AreaEval offset by a relative amount from this RefEval

Method Detail

getInnerValueEval

ValueEval getInnerValueEval()
Returns:
the evaluated value of the cell referred to by this RefEval.

getColumn

int getColumn()
returns the zero based column index.

getRow

int getRow()
returns the zero based row index.

offset

AreaEval offset(int relFirstRowIx,
                int relLastRowIx,
                int relFirstColIx,
                int relLastColIx)
Creates an AreaEval offset by a relative amount from this RefEval

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefEvalBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class RefEvalBase

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.RefEvalBase
All Implemented Interfaces:
RefEval, ValueEval
public abstract class RefEvalBase
extends java.lang.Object
implements RefEval

Common base class for implementors of RefEval

Author:
Josh Micich

Constructor Summary
protected RefEvalBase(int rowIndex, int columnIndex)
Method Summary
int | getColumn() returns the zero based column index.
int | getRow() returns the zero based row index.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.formula.eval.RefEval
getInnerValueEval, offset

Constructor Detail

RefEvalBase

protected RefEvalBase(int rowIndex,
                      int columnIndex)
Method Detail

getRow

public final int getRow()
Description copied from interface: RefEval
returns the zero based row index.

Specified by:
getRow in interface RefEval

getColumn

public final int getColumn()
Description copied from interface: RefEval
returns the zero based column index.

Specified by:
getColumn in interface RefEval
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RelationalOperationEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class RelationalOperationEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.eval.RelationalOperationEval
All Implemented Interfaces:
Function, Function2Arg
public abstract class RelationalOperationEval
extends Fixed2ArgFunction

Base class for all comparison operator evaluators

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function | EqualEval
static Function | GreaterEqualEval
static Function | GreaterThanEval
static Function | LessEqualEval
static Function | LessThanEval
static Function | NotEqualEval
Constructor Summary
RelationalOperationEval()
Method Summary
protected abstract boolean | convertComparisonResult(int cmpResult) Converts a standard compare result (-1, 0, 1) to true or false according to subclass' comparison type.
ValueEval | evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1) This is a description of how the relational operators apply in MS Excel.
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EqualEval

public static final Function EqualEval

GreaterEqualEval

public static final Function GreaterEqualEval

GreaterThanEval

public static final Function GreaterThanEval

LessEqualEval

public static final Function LessEqualEval

LessThanEval

public static final Function LessThanEval

NotEqualEval

public static final Function NotEqualEval
Constructor Detail

RelationalOperationEval

public RelationalOperationEval()
Method Detail

convertComparisonResult

protected abstract boolean convertComparisonResult(int cmpResult)
Converts a standard compare result (-1, 0, 1) to true or false according to subclass' comparison type.

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
This is a description of how the relational operators apply in MS Excel. Use this as a guideline when testing/implementing the evaluate methods for the relational operators Evals.
 Bool.TRUE > any number.
 Bool > any string. ALWAYS
 Bool.TRUE > Bool.FALSE
 Bool.FALSE == Blank

 Strings are never converted to numbers or booleans
 String > any number. ALWAYS
 Non-empty String > Blank
 Empty String == Blank
 String are sorted dictionary wise

 Blank > Negative numbers
 Blank == 0
 Blank < Positive numbers

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class StringEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.StringEval
All Implemented Interfaces:
StringValueEval, ValueEval
public final class StringEval
extends java.lang.Object
implements StringValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static StringEval EMPTY_INSTANCE
Constructor Summary
StringEval(Ptg ptg)
StringEval(java.lang.String value)
Method Summary
java.lang.String | getStringValue()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EMPTY_INSTANCE

public static final StringEval EMPTY_INSTANCE
Constructor Detail

StringEval

public StringEval(Ptg ptg)

StringEval

public StringEval(java.lang.String value)
Method Detail

getStringValue

public java.lang.String getStringValue()
Specified by:
getStringValue in interface StringValueEval
Returns:
never null, possibly empty string.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringValueEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Interface StringValueEval

All Superinterfaces:
ValueEval
All Known Implementing Classes:
BoolEval, NumberEval, StringEval
public interface StringValueEval
extends ValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Method Summary
 java.lang.String getStringValue()

Method Detail

getStringValue

java.lang.String getStringValue()
Returns:
never null, possibly empty string.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TwoOperandNumericOperation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class TwoOperandNumericOperation

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.eval.TwoOperandNumericOperation
All Implemented Interfaces:
Function, Function2Arg
public abstract class TwoOperandNumericOperation
extends Fixed2ArgFunction

Author:
Josh Micich

Field Summary
static Function | AddEval
static Function | DivideEval
static Function | MultiplyEval
static Function | PowerEval
static Function | SubtractEval
Constructor Summary
TwoOperandNumericOperation()
Method Summary
protected abstract  double evaluate(double d0, double d1)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
protected  double singleOperandEvaluate(ValueEval arg, int srcCellRow, int srcCellCol)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

AddEval

public static final Function AddEval

DivideEval

public static final Function DivideEval

MultiplyEval

public static final Function MultiplyEval

PowerEval

public static final Function PowerEval

SubtractEval

public static final Function SubtractEval
Constructor Detail

TwoOperandNumericOperation

public TwoOperandNumericOperation()
Method Detail

singleOperandEvaluate

protected final double singleOperandEvaluate(ValueEval arg,
                                             int srcCellRow,
                                             int srcCellCol)
                                      throws EvaluationException
Throws:
EvaluationException

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

protected abstract double evaluate(double d0,
                                   double d1)
                            throws EvaluationException
Throws:
EvaluationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnaryMinusEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class UnaryMinusEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.eval.UnaryMinusEval
All Implemented Interfaces:
Function, Function1Arg
public final class UnaryMinusEval
extends Fixed1ArgFunction

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function instance
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final Function instance
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnaryPlusEval

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Class UnaryPlusEval

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.eval.UnaryPlusEval
All Implemented Interfaces:
Function, Function1Arg
public final class UnaryPlusEval
extends Fixed1ArgFunction

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function instance
Method Summary
 ValueEval evaluate(int srcCellRow, int srcCellCol, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final Function instance
Method Detail

evaluate

public ValueEval evaluate(int srcCellRow,
                          int srcCellCol,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueEval

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval
Interface ValueEval

All Known Subinterfaces:
AreaEval, NumericValueEval, RefEval, StringValueEval, TwoDEval
All Known Implementing Classes:
AreaEvalBase, BlankEval, BoolEval, ErrorEval, MissingArgEval, NameEval, NameXEval, NumberEval, RefEvalBase, StringEval
public interface ValueEval

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface org.apache.poi.ss.formula.eval.AreaEval

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.eval.AreaEval

Packages that use AreaEval
org.apache.poi.ss.formula.eval

Uses of AreaEval in org.apache.poi.ss.formula.eval

Classes in org.apache.poi.ss.formula.eval that implement AreaEval
 class AreaEvalBase

Methods in org.apache.poi.ss.formula.eval that return AreaEval
AreaEval | RefEval.offset(int relFirstRowIx, int relLastRowIx, int relFirstColIx, int relLastColIx) Creates an AreaEval offset by a relative amount from this RefEval
AreaEval | AreaEval.offset(int relFirstRowIx, int relLastRowIx, int relFirstColIx, int relLastColIx) Creates an AreaEval offset by a relative amount from from the upper left cell of this area

Methods in org.apache.poi.ss.formula.eval with parameters of type AreaEval
static ValueEval OperandResolver.chooseSingleElementFromArea(AreaEval ae, int srcCellRow, int srcCellCol)
Implements (some perhaps not well known) Excel functionality to select a single cell from an area depending on the coordinates of the calling cell.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.AreaEvalBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.AreaEvalBase

No usage of org.apache.poi.ss.formula.eval.AreaEvalBase

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.BlankEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.BlankEval

Packages that use BlankEval
org.apache.poi.ss.formula.eval

Uses of BlankEval in org.apache.poi.ss.formula.eval

Fields in org.apache.poi.ss.formula.eval declared as BlankEval
static BlankEval | BlankEval.instance
static BlankEval | BlankEval.INSTANCE Deprecated. (Nov 2009) use instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.BoolEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.BoolEval

Packages that use BoolEval
org.apache.poi.ss.formula.eval

Uses of BoolEval in org.apache.poi.ss.formula.eval

Fields in org.apache.poi.ss.formula.eval declared as BoolEval
static BoolEval | BoolEval.FALSE
static BoolEval | BoolEval.TRUE

Methods in org.apache.poi.ss.formula.eval that return BoolEval
static BoolEval BoolEval.valueOf(boolean b)
Convenience method for the following:
(b ? BoolEval.TRUE : BoolEval.FALSE)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.ConcatEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.ConcatEval

No usage of org.apache.poi.ss.formula.eval.ConcatEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.ErrorEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.ErrorEval

Packages that use ErrorEval
org.apache.poi.ss.formula.eval

Uses of ErrorEval in org.apache.poi.ss.formula.eval

Fields in org.apache.poi.ss.formula.eval declared as ErrorEval
static ErrorEval | ErrorEval.CIRCULAR_REF_ERROR
static ErrorEval | ErrorEval.DIV_ZERO #DIV/0! - Division by zero
static ErrorEval | ErrorEval.NA #N/A - Argument or function not available
static ErrorEval | ErrorEval.NAME_INVALID #NAME? - Wrong function or range name
static ErrorEval | ErrorEval.NULL_INTERSECTION #NULL! - Intersection of two cell ranges is empty
static ErrorEval | ErrorEval.NUM_ERROR #NUM! - Value range overflow
static ErrorEval | ErrorEval.REF_INVALID #REF! - Illegal or deleted cell reference
static ErrorEval | ErrorEval.VALUE_INVALID #VALUE! - Wrong type of operand

Methods in org.apache.poi.ss.formula.eval that return ErrorEval
ErrorEval | EvaluationException.getErrorEval()
static ErrorEval | ErrorEval.valueOf(int errorCode) Translates an Excel internal error code into the corresponding POI ErrorEval instance

Constructors in org.apache.poi.ss.formula.eval with parameters of type ErrorEval
EvaluationException(ErrorEval errorEval)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.EvaluationException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.EvaluationException

Packages that use EvaluationException
org.apache.poi.ss.formula.atp
org.apache.poi.ss.formula.eval
org.apache.poi.ss.formula.functions

Uses of EvaluationException in org.apache.poi.ss.formula.atp

Methods in org.apache.poi.ss.formula.atp that throw EvaluationException
static java.util.Calendar DateParser.parseDate(java.lang.String strVal)
Parses a date from a string.

Uses of EvaluationException in org.apache.poi.ss.formula.eval

Methods in org.apache.poi.ss.formula.eval that return EvaluationException
static EvaluationException | EvaluationException.invalidRef() #REF! - Illegal or deleted cell reference
static EvaluationException | EvaluationException.invalidValue() #VALUE! - Wrong type of operand
static EvaluationException | EvaluationException.numberError() #NUM! - Value range overflow

Methods in org.apache.poi.ss.formula.eval that throw EvaluationException
static ValueEval OperandResolver.chooseSingleElementFromArea(AreaEval ae, int srcCellRow, int srcCellCol)
Implements (some perhaps not well known) Excel functionality to select a single cell from an area depending on the coordinates of the calling cell.
static java.lang.Boolean OperandResolver.coerceValueToBoolean(ValueEval ve, boolean stringsAreBlanks)
static double OperandResolver.coerceValueToDouble(ValueEval ev)
Applies some conversion rules if the supplied value is not already a number.
static int OperandResolver.coerceValueToInt(ValueEval ev)
Applies some conversion rules if the supplied value is not already an integer.
Value is first coerced to a double ( See coerceValueToDouble() ).
protected abstract  double TwoOperandNumericOperation.evaluate(double d0, double d1)
static ValueEval OperandResolver.getSingleValue(ValueEval arg, int srcCellRow, int srcCellCol)
Retrieves a single value from a variety of different argument types according to standard Excel rules.
protected  double TwoOperandNumericOperation.singleOperandEvaluate(ValueEval arg, int srcCellRow, int srcCellCol)

Uses of EvaluationException in org.apache.poi.ss.formula.functions

Methods in org.apache.poi.ss.formula.functions that throw EvaluationException
static void | NumericFunction.checkValue(double result)
protected abstract double | NumericFunction.eval(ValueEval[] args, int srcCellRow, int srcCellCol)
protected double | NumericFunction.OneArg.eval(ValueEval[] args, int srcCellRow, int srcCellCol)
protected abstract double | NumericFunction.OneArg.evaluate(double d)
protected abstract double | MultiOperandNumericFunction.evaluate(double[] values)
static double | Mode.evaluate(double[] v) if v is zero length or contains no duplicates, return value is Double.NaN.
protected double | FinanceFunction.evaluate(double[] ds)
protected abstract double | NumericFunction.TwoArg.evaluate(double d0, double d1)
protected abstract double | FinanceFunction.evaluate(double rate, double arg1, double arg2, double arg3, boolean type)
protected static double | TextFunction.evaluateDoubleArg(ValueEval arg, int srcCellRow, int srcCellCol)
static boolean | IfFunc.evaluateFirstArg(ValueEval arg, int srcCellRow, int srcCellCol)
static int | Choose.evaluateFirstArg(ValueEval arg0, int srcRowIndex, int srcColumnIndex)
protected abstract ValueEval | TextFunction.evaluateFunc(ValueEval[] args, int srcCellRow, int srcCellCol)
protected static int | TextFunction.evaluateIntArg(ValueEval arg, int srcCellRow, int srcCellCol)
protected static java.lang.String | TextFunction.evaluateStringArg(ValueEval eval, int srcRow, int srcCol)
protected double[] | MultiOperandNumericFunction.getNumberArray(ValueEval[] operands) Returns a double array that contains values for the numeric cells from among the list of operands.
protected static double | NumericFunction.singleOperandEvaluate(ValueEval arg, int srcRowIndex, int srcColumnIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.FunctionEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.FunctionEval

No usage of org.apache.poi.ss.formula.eval.FunctionEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.IntersectionEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.IntersectionEval

No usage of org.apache.poi.ss.formula.eval.IntersectionEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.MissingArgEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.MissingArgEval

Packages that use MissingArgEval
org.apache.poi.ss.formula.eval

Uses of MissingArgEval in org.apache.poi.ss.formula.eval

Fields in org.apache.poi.ss.formula.eval declared as MissingArgEval
static MissingArgEval MissingArgEval.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.NameEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.NameEval

No usage of org.apache.poi.ss.formula.eval.NameEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.NameXEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.NameXEval

No usage of org.apache.poi.ss.formula.eval.NameXEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.NotImplementedException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.NotImplementedException

Packages that use NotImplementedException
org.apache.poi.ss.formula.eval

Uses of NotImplementedException in org.apache.poi.ss.formula.eval

Constructors in org.apache.poi.ss.formula.eval with parameters of type NotImplementedException
NotImplementedException(java.lang.String message, NotImplementedException cause)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.NumberEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.NumberEval

Packages that use NumberEval
org.apache.poi.ss.formula.eval

Uses of NumberEval in org.apache.poi.ss.formula.eval

Fields in org.apache.poi.ss.formula.eval declared as NumberEval
static NumberEval NumberEval.ZERO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.eval.NumericValueEval

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.eval.NumericValueEval

Packages that use NumericValueEval
org.apache.poi.ss.formula.eval

Uses of NumericValueEval in org.apache.poi.ss.formula.eval

Classes in org.apache.poi.ss.formula.eval that implement NumericValueEval
class | BoolEval
class | NumberEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.OperandResolver

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.OperandResolver

No usage of org.apache.poi.ss.formula.eval.OperandResolver

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.PercentEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.PercentEval

No usage of org.apache.poi.ss.formula.eval.PercentEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.RangeEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.RangeEval

No usage of org.apache.poi.ss.formula.eval.RangeEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.eval.RefEval

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.eval.RefEval

Packages that use RefEval
org.apache.poi.ss.formula.eval

Uses of RefEval in org.apache.poi.ss.formula.eval

Classes in org.apache.poi.ss.formula.eval that implement RefEval
 class RefEvalBase
Common base class for implementors of RefEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.RefEvalBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.RefEvalBase

No usage of org.apache.poi.ss.formula.eval.RefEvalBase

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.RelationalOperationEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.RelationalOperationEval

No usage of org.apache.poi.ss.formula.eval.RelationalOperationEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.StringEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.StringEval

Packages that use StringEval
org.apache.poi.ss.formula.eval

Uses of StringEval in org.apache.poi.ss.formula.eval

Fields in org.apache.poi.ss.formula.eval declared as StringEval
static StringEval StringEval.EMPTY_INSTANCE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.eval.StringValueEval

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.eval.StringValueEval

Packages that use StringValueEval
org.apache.poi.ss.formula.eval

Uses of StringValueEval in org.apache.poi.ss.formula.eval

Classes in org.apache.poi.ss.formula.eval that implement StringValueEval
class | BoolEval
class | NumberEval
class | StringEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

No usage of org.apache.poi.ss.formula.eval.TwoOperandNumericOperation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.UnaryMinusEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.UnaryMinusEval

No usage of org.apache.poi.ss.formula.eval.UnaryMinusEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.UnaryPlusEval

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.UnaryPlusEval

No usage of org.apache.poi.ss.formula.eval.UnaryPlusEval

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.eval.ValueEval

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.eval.ValueEval

Packages that use ValueEval
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.formula.functions |

Uses of ValueEval in org.apache.poi.ss.formula

Subinterfaces of ValueEval in org.apache.poi.ss.formula
 interface TwoDEval
Common interface of AreaEval and AreaEvalBase

Methods in org.apache.poi.ss.formula that return ValueEval
static ValueEval | WorkbookEvaluator.dereferenceResult(ValueEval evaluationResult, int srcRowNum, int srcColNum) Dereferences a single value from any AreaEval or RefEval evaluation result.
ValueEval | WorkbookEvaluator.evaluate(EvaluationCell srcCell)
ValueEval | OperationEvaluationContext.getArea3DEval(int firstRowIndex, int firstColumnIndex, int lastRowIndex, int lastColumnIndex, int extSheetIndex)
ValueEval | OperationEvaluationContext.getAreaEval(int firstRowIndex, int firstColumnIndex, int lastRowIndex, int lastColumnIndex)
ValueEval | OperationEvaluationContext.getDynamicReference(java.lang.String workbookName, java.lang.String sheetName, java.lang.String refStrPart1, java.lang.String refStrPart2, boolean isA1Style) Resolves a cell or area reference dynamically.
ValueEval | OperationEvaluationContext.getNameXEval(NameXPtg nameXPtg)
ValueEval | OperationEvaluationContext.getRef3DEval(int rowIndex, int columnIndex, int extSheetIndex)
ValueEval | OperationEvaluationContext.getRefEval(int rowIndex, int columnIndex)
ValueEval | TwoDEval.getValue(int rowIndex, int columnIndex)

Methods in org.apache.poi.ss.formula with parameters of type ValueEval
static ValueEval WorkbookEvaluator.dereferenceResult(ValueEval evaluationResult, int srcRowNum, int srcColNum)
Dereferences a single value from any AreaEval or RefEval evaluation result.

Uses of ValueEval in org.apache.poi.ss.formula.eval

Subinterfaces of ValueEval in org.apache.poi.ss.formula.eval
interface | AreaEval
interface | NumericValueEval
interface | RefEval
interface | StringValueEval

Classes in org.apache.poi.ss.formula.eval that implement ValueEval
class | AreaEvalBase
class | BlankEval
class | BoolEval
class | ErrorEval
class | MissingArgEval Represents the (intermediate) evaluated result of a missing function argument.
class | NameEval
class | NameXEval
class | NumberEval
class | RefEvalBase Common base class for implementors of RefEval
class | StringEval

Methods in org.apache.poi.ss.formula.eval that return ValueEval
static ValueEval | OperandResolver.chooseSingleElementFromArea(AreaEval ae, int srcCellRow, int srcCellCol) Implements (some perhaps not well known) Excel functionality to select a single cell from an area depending on the coordinates of the calling cell.
ValueEval | UnaryPlusEval.evaluate(int srcCellRow, int srcCellCol, ValueEval arg0)
ValueEval | UnaryMinusEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
ValueEval | PercentEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
ValueEval | TwoOperandNumericOperation.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
ValueEval | RelationalOperationEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1) This is a description of how the relational operators apply in MS Excel.
ValueEval | RangeEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
ValueEval | IntersectionEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
ValueEval | ConcatEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
ValueEval | AreaEvalBase.getAbsoluteValue(int row, int col)
ValueEval | AreaEval.getAbsoluteValue(int row, int col)
ValueEval | RefEval.getInnerValueEval()
abstract ValueEval | AreaEvalBase.getRelativeValue(int relativeRowIndex, int relativeColumnIndex)
ValueEval | AreaEval.getRelativeValue(int relativeRowIndex, int relativeColumnIndex)
static ValueEval | OperandResolver.getSingleValue(ValueEval arg, int srcCellRow, int srcCellCol) Retrieves a single value from a variety of different argument types according to standard Excel rules.
ValueEval | AreaEvalBase.getValue(int row, int col)

Methods in org.apache.poi.ss.formula.eval with parameters of type ValueEval
static java.lang.Boolean OperandResolver.coerceValueToBoolean(ValueEval ve, boolean stringsAreBlanks)
static double OperandResolver.coerceValueToDouble(ValueEval ev)
Applies some conversion rules if the supplied value is not already a number.
static int OperandResolver.coerceValueToInt(ValueEval ev)
Applies some conversion rules if the supplied value is not already an integer.
Value is first coerced to a double ( See coerceValueToDouble() ).
static java.lang.String OperandResolver.coerceValueToString(ValueEval ve)
 ValueEval UnaryPlusEval.evaluate(int srcCellRow, int srcCellCol, ValueEval arg0)
 ValueEval UnaryMinusEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval PercentEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval TwoOperandNumericOperation.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval RelationalOperationEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
This is a description of how the relational operators apply in MS Excel.
 ValueEval RangeEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval IntersectionEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval ConcatEval.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
static ValueEval OperandResolver.getSingleValue(ValueEval arg, int srcCellRow, int srcCellCol)
Retrieves a single value from a variety of different argument types according to standard Excel rules.
protected  double TwoOperandNumericOperation.singleOperandEvaluate(ValueEval arg, int srcCellRow, int srcCellCol)

Uses of ValueEval in org.apache.poi.ss.formula.eval.forked

Methods in org.apache.poi.ss.formula.eval.forked that return ValueEval
 ValueEval ForkedEvaluator.evaluate(java.lang.String sheetName, int rowIndex, int columnIndex)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.

Methods in org.apache.poi.ss.formula.eval.forked with parameters of type ValueEval
 void ForkedEvaluator.updateCell(java.lang.String sheetName, int rowIndex, int columnIndex, ValueEval value)
Sets the specified cell to the supplied value

Uses of ValueEval in org.apache.poi.ss.formula.functions

Methods in org.apache.poi.ss.formula.functions that return ValueEval
 ValueEval Today.evaluate(int srcRowIndex, int srcColumnIndex)
 ValueEval RowFunc.evaluate(int srcRowIndex, int srcColumnIndex)
 ValueEval Now.evaluate(int srcRowIndex, int srcColumnIndex)
 ValueEval Na.evaluate(int srcCellRow, int srcCellCol)
 ValueEval Function0Arg.evaluate(int srcRowIndex, int srcColumnIndex)
see Function.evaluate(ValueEval[], int, int)
 ValueEval Column.evaluate(int srcRowIndex, int srcColumnIndex)
 ValueEval Value.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval T.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Rows.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval RowFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval NumericFunction.OneArg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval LogicalFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Hyperlink.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Function1Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
 ValueEval Errortype.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Countblank.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Columns.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Column.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval CalendarFieldFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval XYNumericFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Sumif.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Rank.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval NumericFunction.TwoArg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Match.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Lookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Index.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval IfFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Hyperlink.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Function2Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval Days360.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Countif.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Vlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval TimeFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Sumif.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Substitute.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Rank.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Match.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Lookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Index.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval IfFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Hlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Function3Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval FinanceFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Days360.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval DateFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Vlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Substitute.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Replace.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Index.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Hlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Function4Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
 ValueEval FinanceFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval FinanceFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3, ValueEval arg4)
 ValueEval TextFunction.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Sumproduct.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Subtotal.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval RowFunc.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Rate.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Offset.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval NumericFunction.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Npv.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval NotImplementedFunction.evaluate(ValueEval[] operands, int srcRow, int srcCol)
 ValueEval MultiOperandNumericFunction.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Mode.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Irr.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Index.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Function.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed4ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed3ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed2ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed1ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed0ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval FinanceFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Counta.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Count.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Column.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Choose.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval BooleanFunction.evaluate(ValueEval[] args, int srcRow, int srcCol)
 ValueEval Address.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Sumifs.evaluate(ValueEval[] args, OperationEvaluationContext ec)
 ValueEval Indirect.evaluate(ValueEval[] args, OperationEvaluationContext ec)
 ValueEval FreeRefFunction.evaluate(ValueEval[] args, OperationEvaluationContext ec)
protected abstract  ValueEval TextFunction.evaluateFunc(ValueEval[] args, int srcCellRow, int srcCellCol)

Methods in org.apache.poi.ss.formula.functions with parameters of type ValueEval
protected abstract  double NumericFunction.eval(ValueEval[] args, int srcCellRow, int srcCellCol)
protected  double NumericFunction.OneArg.eval(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Value.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval T.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Rows.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval RowFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval NumericFunction.OneArg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval LogicalFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Hyperlink.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Function1Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
 ValueEval Errortype.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Countblank.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Columns.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval Column.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval CalendarFieldFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
 ValueEval XYNumericFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Sumif.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Rank.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval NumericFunction.TwoArg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Match.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Lookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Index.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval IfFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Hyperlink.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Function2Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval Days360.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Countif.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
 ValueEval Vlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval TimeFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Sumif.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Substitute.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Rank.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Match.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Lookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Index.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval IfFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Hlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Function3Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval FinanceFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Days360.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval DateFunc.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
 ValueEval Vlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Substitute.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Replace.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Index.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Hlookup.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval Function4Arg.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
 ValueEval FinanceFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
 ValueEval FinanceFunction.evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3, ValueEval arg4)
protected abstract  boolean LogicalFunction.evaluate(ValueEval arg)
 ValueEval TextFunction.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Sumproduct.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Subtotal.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval RowFunc.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Rate.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Offset.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval NumericFunction.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Npv.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval NotImplementedFunction.evaluate(ValueEval[] operands, int srcRow, int srcCol)
 ValueEval MultiOperandNumericFunction.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Mode.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Irr.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Index.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Function.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed4ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed3ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed2ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed1ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Fixed0ArgFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval FinanceFunction.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Counta.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Count.evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
 ValueEval Column.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Choose.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval BooleanFunction.evaluate(ValueEval[] args, int srcRow, int srcCol)
 ValueEval Address.evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
 ValueEval Sumifs.evaluate(ValueEval[] args, OperationEvaluationContext ec)
 ValueEval Indirect.evaluate(ValueEval[] args, OperationEvaluationContext ec)
 ValueEval FreeRefFunction.evaluate(ValueEval[] args, OperationEvaluationContext ec)
protected static double TextFunction.evaluateDoubleArg(ValueEval arg, int srcCellRow, int srcCellCol)
static boolean IfFunc.evaluateFirstArg(ValueEval arg, int srcCellRow, int srcCellCol)
static int Choose.evaluateFirstArg(ValueEval arg0, int srcRowIndex, int srcColumnIndex)
protected abstract  ValueEval TextFunction.evaluateFunc(ValueEval[] args, int srcCellRow, int srcCellCol)
protected static int TextFunction.evaluateIntArg(ValueEval arg, int srcCellRow, int srcCellCol)
protected static java.lang.String TextFunction.evaluateStringArg(ValueEval eval, int srcRow, int srcCol)
protected  double[] MultiOperandNumericFunction.getNumberArray(ValueEval[] operands)
Returns a double array that contains values for the numeric cells from among the list of operands.
protected static double NumericFunction.singleOperandEvaluate(ValueEval arg, int srcRowIndex, int srcColumnIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ForkedEvaluator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.eval.forked
Class ForkedEvaluator

java.lang.Object
    extended by  org.apache.poi.ss.formula.eval.forked.ForkedEvaluator

public final class ForkedEvaluator
extends java.lang.Object

An alternative workbook evaluator that saves memory in situations where a single workbook is concurrently and independently evaluated many times. With standard formula evaluation, around 90% of memory consumption is due to loading of the HSSFWorkbook or XSSFWorkbook. This class enables a 'master workbook' to be loaded just once and shared between many evaluation clients. Each evaluation client creates its own ForkedEvaluator and can set cell values that will be used for local evaluations (and don't disturb evaluations on other evaluators).

Author:
Josh Micich

Method Summary
 void copyUpdatedCells(Workbook workbook)
Copies the values of all updated cells (modified by calls to updateCell(String, int, int, ValueEval)) to the supplied workbook.
Typically, the supplied workbook is a writable copy of the 'master workbook', but at the very least it must contain sheets with the same names.
static ForkedEvaluator create(Workbook wb, IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use create(Workbook, IStabilityClassifier, UDFFinder)
static ForkedEvaluator create(Workbook wb, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
 ValueEval evaluate(java.lang.String sheetName, int rowIndex, int columnIndex)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
static void setupEnvironment(java.lang.String[] workbookNames, ForkedEvaluator[] evaluators)
Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.
 void updateCell(java.lang.String sheetName, int rowIndex, int columnIndex, ValueEval value)
Sets the specified cell to the supplied value
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public static ForkedEvaluator create(Workbook wb,
                                     IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use create(Workbook, IStabilityClassifier, UDFFinder)

create

public static ForkedEvaluator create(Workbook wb,
                                     IStabilityClassifier stabilityClassifier,
                                     UDFFinder udfFinder)
Parameters:
udfFinder - pass null for default (AnalysisToolPak only)

updateCell

public void updateCell(java.lang.String sheetName,
                       int rowIndex,
                       int columnIndex,
                       ValueEval value)
Sets the specified cell to the supplied value

Parameters:
sheetName - the name of the sheet containing the cell
rowIndex - zero based
columnIndex - zero based

copyUpdatedCells

public void copyUpdatedCells(Workbook workbook)
Copies the values of all updated cells (modified by calls to updateCell(String, int, int, ValueEval)) to the supplied workbook.
Typically, the supplied workbook is a writable copy of the 'master workbook', but at the very least it must contain sheets with the same names.

evaluate

public ValueEval evaluate(java.lang.String sheetName,
                          int rowIndex,
                          int columnIndex)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type. This method should be preferred over evaluateInCell() when the call should not modify the contents of the original cell.

Parameters:
sheetName - the name of the sheet containing the cell
rowIndex - zero based
columnIndex - zero based
Returns:
null if the supplied cell is null or blank

setupEnvironment

public static void setupEnvironment(java.lang.String[] workbookNames,
                                    ForkedEvaluator[] evaluators)
Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.

Parameters:
workbookNames - the simple file names used to identify the workbooks in formulas with external links (for example "MyData.xls" as used in a formula "[MyData.xls]Sheet1!A1")
evaluators - all evaluators for the full set of workbooks required by the formulas.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.eval.forked
Classes
ForkedEvaluator


org.apache.poi.ss.formula.eval.forked

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.eval.forked

Class Summary
ForkedEvaluator An alternative workbook evaluator that saves memory in situations where a single workbook is concurrently and independently evaluated many times.


org.apache.poi.ss.formula.eval.forked Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.eval.forked

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.eval.forked.ForkedEvaluator


Uses of Package org.apache.poi.ss.formula.eval.forked

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.eval.forked

Packages that use org.apache.poi.ss.formula.eval.forked
org.apache.poi.ss.formula.eval.forked

Classes in org.apache.poi.ss.formula.eval.forked used by org.apache.poi.ss.formula.eval.forked
ForkedEvaluator
An alternative workbook evaluator that saves memory in situations where a single workbook is concurrently and independently evaluated many times.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.eval.forked.ForkedEvaluator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.eval.forked.ForkedEvaluator

Packages that use ForkedEvaluator
org.apache.poi.ss.formula.eval.forked

Uses of ForkedEvaluator in org.apache.poi.ss.formula.eval.forked

Methods in org.apache.poi.ss.formula.eval.forked that return ForkedEvaluator
static ForkedEvaluator ForkedEvaluator.create(Workbook wb, IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use create(Workbook, IStabilityClassifier, UDFFinder)
static ForkedEvaluator ForkedEvaluator.create(Workbook wb, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Methods in org.apache.poi.ss.formula.eval.forked with parameters of type ForkedEvaluator
static void ForkedEvaluator.setupEnvironment(java.lang.String[] workbookNames, ForkedEvaluator[] evaluators)
Coordinates several formula evaluators together so that formulas that involve external references can be evaluated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FunctionMetadata

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.function
Class FunctionMetadata

java.lang.Object
    extended by  org.apache.poi.ss.formula.function.FunctionMetadata

public final class FunctionMetadata
extends java.lang.Object

Holds information about Excel built-in functions.

Author:
Josh Micich

Method Summary
int | getIndex()
int | getMaxParams()
int | getMinParams()
java.lang.String | getName()
byte[] | getParameterClassCodes()
byte | getReturnClassCode()
boolean | hasFixedArgsLength()
boolean | hasUnlimitedVarags() Some varags functions (like VLOOKUP) have a specific limit to the number of arguments that can be passed.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getIndex

public int getIndex()

getName

public java.lang.String getName()

getMinParams

public int getMinParams()

getMaxParams

public int getMaxParams()

hasFixedArgsLength

public boolean hasFixedArgsLength()

getReturnClassCode

public byte getReturnClassCode()

getParameterClassCodes

public byte[] getParameterClassCodes()

hasUnlimitedVarags

public boolean hasUnlimitedVarags()
Some varags functions (like VLOOKUP) have a specific limit to the number of arguments that can be passed. Other functions (like SUM) don't have such a limit. For those functions, the spreadsheet version determines the maximum number of arguments that can be passed.

Returns:
true if this function can the maximum number of arguments allowable by the SpreadsheetVersion

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FunctionMetadataRegistry

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.function
Class FunctionMetadataRegistry

java.lang.Object
    extended by  org.apache.poi.ss.formula.function.FunctionMetadataRegistry

public final class FunctionMetadataRegistry
extends java.lang.Object

Allows clients to get FunctionMetadata instances for any built-in function of Excel.

Author:
Josh Micich

Field Summary
static int | FUNCTION_INDEX_CHOOSE
static short | FUNCTION_INDEX_EXTERNAL
static int | FUNCTION_INDEX_IF
static short | FUNCTION_INDEX_INDIRECT
static short | FUNCTION_INDEX_SUM
static java.lang.String | FUNCTION_NAME_IF The name of the IF function (i.e.
Method Summary
static FunctionMetadata | getFunctionByIndex(int index)
static FunctionMetadata | getFunctionByName(java.lang.String name)
static short | lookupIndexByName(java.lang.String name) Resolves a built-in function index.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FUNCTION_NAME_IF

public static final java.lang.String FUNCTION_NAME_IF
The name of the IF function (i.e. "IF"). Extracted as a constant for clarity.

See Also:
Constant Field Values

FUNCTION_INDEX_IF

public static final int FUNCTION_INDEX_IF
See Also:
Constant Field Values

FUNCTION_INDEX_SUM

public static final short FUNCTION_INDEX_SUM
See Also:
Constant Field Values

FUNCTION_INDEX_CHOOSE

public static final int FUNCTION_INDEX_CHOOSE
See Also:
Constant Field Values

FUNCTION_INDEX_INDIRECT

public static final short FUNCTION_INDEX_INDIRECT
See Also:
Constant Field Values

FUNCTION_INDEX_EXTERNAL

public static final short FUNCTION_INDEX_EXTERNAL
See Also:
Constant Field Values
Method Detail

getFunctionByIndex

public static FunctionMetadata getFunctionByIndex(int index)

lookupIndexByName

public static short lookupIndexByName(java.lang.String name)
Resolves a built-in function index.

Parameters:
name - uppercase function name
Returns:
a negative value if the function name is not found. This typically occurs for external functions.

getFunctionByName

public static FunctionMetadata getFunctionByName(java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.function
Classes
FunctionMetadata
FunctionMetadataRegistry


org.apache.poi.ss.formula.function

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.function

Class Summary
FunctionMetadata | Holds information about Excel built-in functions.
FunctionMetadataRegistry | Allows clients to get FunctionMetadata instances for any built-in function of Excel.


org.apache.poi.ss.formula.function Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.function

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.function.FunctionMetadata
    • org.apache.poi.ss.formula.function.FunctionMetadataRegistry


Uses of Package org.apache.poi.ss.formula.function

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.function

Packages that use org.apache.poi.ss.formula.function
org.apache.poi.ss.formula.function

Classes in org.apache.poi.ss.formula.function used by org.apache.poi.ss.formula.function
FunctionMetadata
Holds information about Excel built-in functions.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.function.FunctionMetadata

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.function.FunctionMetadata

Packages that use FunctionMetadata
org.apache.poi.ss.formula.function

Uses of FunctionMetadata in org.apache.poi.ss.formula.function

Methods in org.apache.poi.ss.formula.function that return FunctionMetadata
static FunctionMetadata | FunctionMetadataRegistry.getFunctionByIndex(int index)
static FunctionMetadata | FunctionMetadataRegistry.getFunctionByName(java.lang.String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.function.FunctionMetadataRegistry

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.function.FunctionMetadataRegistry

No usage of org.apache.poi.ss.formula.function.FunctionMetadataRegistry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Address

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Address

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Address
All Implemented Interfaces:
Function
public class Address
extends java.lang.Object
implements Function

Creates a text reference as text, given specified row and column numbers.

Author:
Aniket Banerjee (banerjee@google.com)

Field Summary
static int | REF_ABSOLUTE
static int | REF_RELATIVE
static int | REF_ROW_ABSOLUTE_COLUMN_RELATIVE
static int | REF_ROW_RELATIVE_RELATIVE_ABSOLUTE
Constructor Summary
Address()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

REF_ABSOLUTE

public static final int REF_ABSOLUTE
See Also:
Constant Field Values

REF_ROW_ABSOLUTE_COLUMN_RELATIVE

public static final int REF_ROW_ABSOLUTE_COLUMN_RELATIVE
See Also:
Constant Field Values

REF_ROW_RELATIVE_RELATIVE_ABSOLUTE

public static final int REF_ROW_RELATIVE_RELATIVE_ABSOLUTE
See Also:
Constant Field Values

REF_RELATIVE

public static final int REF_RELATIVE
See Also:
Constant Field Values
Constructor Detail

Address

public Address()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AggregateFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class AggregateFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
        extended by  org.apache.poi.ss.formula.functions.AggregateFunction
All Implemented Interfaces:
Function
public abstract class AggregateFunction
extends MultiOperandNumericFunction

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function | AVEDEV
static Function | AVERAGE
static Function | DEVSQ
static Function | LARGE
static Function | MAX
static Function | MEDIAN
static Function | MIN
static Function | PRODUCT
static Function | SMALL
static Function | STDEV
static Function | SUM
static Function | SUMSQ
static Function | VAR
static Function | VARP
Constructor Summary
protected AggregateFunction()
Method Summary
Methods inherited from class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
evaluate, evaluate, getMaxNumOperands, getNumberArray, isSubtotalCounted
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

AVEDEV

public static final Function AVEDEV

AVERAGE

public static final Function AVERAGE

DEVSQ

public static final Function DEVSQ

LARGE

public static final Function LARGE

MAX

public static final Function MAX

MEDIAN

public static final Function MEDIAN

MIN

public static final Function MIN

PRODUCT

public static final Function PRODUCT

SMALL

public static final Function SMALL

STDEV

public static final Function STDEV

SUM

public static final Function SUM

SUMSQ

public static final Function SUMSQ

VAR

public static final Function VAR

VARP

public static final Function VARP
Constructor Detail

AggregateFunction

protected AggregateFunction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BooleanFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class BooleanFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.BooleanFunction
All Implemented Interfaces:
Function
public abstract class BooleanFunction
extends java.lang.Object
implements Function

Here are the general rules concerning Boolean functions:

  1. Blanks are ignored (not either true or false)
  2. Strings are ignored if part of an area ref or cell ref, otherwise they must be 'true' or 'false'
  3. Numbers: 0 is false. Any other number is TRUE
  4. Areas: *all* cells in area are evaluated according to the above rules

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function | AND
static Function | FALSE
static Function | NOT
static Function | OR
static Function | TRUE
Constructor Summary
BooleanFunction()
Method Summary
ValueEval | evaluate(ValueEval[] args, int srcRow, int srcCol)
protected abstract boolean | getInitialResultValue()
protected abstract boolean | partialEvaluate(boolean cumulativeResult, boolean currentValue)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

AND

public static final Function AND

OR

public static final Function OR

FALSE

public static final Function FALSE

TRUE

public static final Function TRUE

NOT

public static final Function NOT
Constructor Detail

BooleanFunction

public BooleanFunction()
Method Detail

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRow,
                                int srcCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRow - row index of the cell containing the formula under evaluation
srcCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

getInitialResultValue

protected abstract boolean getInitialResultValue()

partialEvaluate

protected abstract boolean partialEvaluate(boolean cumulativeResult,
                                           boolean currentValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CalendarFieldFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class CalendarFieldFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.CalendarFieldFunction
All Implemented Interfaces:
Function, Function1Arg
public final class CalendarFieldFunction
extends Fixed1ArgFunction

Implementation of Excel functions Date parsing functions: Date - DAY, MONTH and YEAR Time - HOUR, MINUTE and SECOND

Field Summary
static Function | DAY
static Function | HOUR
static Function | MINUTE
static Function | MONTH
static Function | SECOND
static Function | YEAR
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

YEAR

public static final Function YEAR

MONTH

public static final Function MONTH

DAY

public static final Function DAY

HOUR

public static final Function HOUR

MINUTE

public static final Function MINUTE

SECOND

public static final Function SECOND
Method Detail

evaluate

public final ValueEval evaluate(int srcRowIndex,
                                int srcColumnIndex,
                                ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Choose

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Choose

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Choose
All Implemented Interfaces:
Function
public final class Choose
extends java.lang.Object
implements Function

Author:
Josh Micich

Constructor Summary
Choose()
Method Summary
ValueEval | evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
static int | evaluateFirstArg(ValueEval arg0, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Choose

public Choose()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

evaluateFirstArg

public static int evaluateFirstArg(ValueEval arg0,
                                   int srcRowIndex,
                                   int srcColumnIndex)
                            throws EvaluationException
Throws:
EvaluationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Column

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Column

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Column
All Implemented Interfaces:
Function, Function0Arg, Function1Arg
public final class Column
extends java.lang.Object
implements Function0Arg, Function1Arg

Constructor Summary
Column()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Column

public Column()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex)
Description copied from interface: Function0Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function0Arg

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function1Arg

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Columns

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Columns

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Columns
All Implemented Interfaces:
Function, Function1Arg
public final class Columns
extends Fixed1ArgFunction

Implementation for Excel COLUMNS function.

Author:
Josh Micich

Constructor Summary
Columns()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Columns

public Columns()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Count

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Count

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Count
All Implemented Interfaces:
Function
public final class Count
extends java.lang.Object
implements Function

Counts the number of cells that contain numeric data within the list of arguments. Excel Syntax COUNT(value1,value2,...) Value1, value2, ... are 1 to 30 arguments representing the values or ranges to be counted. TODO: Check this properly matches excel on edge cases like formula cells, error cells etc

Constructor Summary
Count()
Method Summary
ValueEval | evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
static Count | subtotalInstance() Create an instance of Count to use in Subtotal
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Count

public Count()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcCellRow,
                          int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

subtotalInstance

public static Count subtotalInstance()
Create an instance of Count to use in Subtotal

If there are other subtotals within argument refs (or nested subtotals), these nested subtotals are ignored to avoid double counting.

See Also:
Subtotal
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Counta

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Counta

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Counta
All Implemented Interfaces:
Function
public final class Counta
extends java.lang.Object
implements Function

Counts the number of cells that contain data within the list of arguments. Excel Syntax COUNTA(value1,value2,...) Value1, value2, ... are 1 to 30 arguments representing the values or ranges to be counted.

Author:
Josh Micich

Constructor Summary
Counta()
Method Summary
ValueEval | evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
static Counta | subtotalInstance()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Counta

public Counta()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcCellRow,
                          int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

subtotalInstance

public static Counta subtotalInstance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Countblank

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Countblank

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Countblank
All Implemented Interfaces:
Function, Function1Arg
public final class Countblank
extends Fixed1ArgFunction

Implementation for the function COUNTBLANK

Syntax: COUNTBLANK ( range )

range is the range of cells to count blanks

Author:
Mads Mohr Christensen

Constructor Summary
Countblank()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Countblank

public Countblank()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Countif

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Countif

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Countif
All Implemented Interfaces:
Function, Function2Arg
public final class Countif
extends Fixed2ArgFunction

Implementation for the function COUNTIF

Syntax: COUNTIF ( range, criteria )

range | is the range of cells to be counted based on the criteria
criteria | is used to determine which cells to count

Author:
Josh Micich

Constructor Summary
Countif()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Countif

public Countif()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateFunc

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class DateFunc

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed3ArgFunction
        extended by  org.apache.poi.ss.formula.functions.DateFunc
All Implemented Interfaces:
Function, Function3Arg
public final class DateFunc
extends Fixed3ArgFunction

Implementation for the Excel function DATE

Author:
Pavel Krupets (pkrupets at palmtreebusiness dot com)

Field Summary
static Function instance
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed3ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final Function instance
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Days360

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Days360

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Days360
All Implemented Interfaces:
Function, Function2Arg, Function3Arg
public class Days360
extends java.lang.Object

Calculates the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations. Use this function to help compute payments if your accounting system is based on twelve 30-day months.

Author:
PUdalau

Constructor Summary
Days360()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Days360

public Days360()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Errortype

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Errortype

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Errortype
All Implemented Interfaces:
Function, Function1Arg
public final class Errortype
extends Fixed1ArgFunction

Implementation for the ERROR.TYPE() Excel function.

Syntax:
ERROR.TYPE(errorValue)

Returns a number corresponding to the error type of the supplied argument.

errorValue | Return Value
#NULL! | 1
#DIV/0! | 2
#VALUE! | 3
#REF! | 4
#NAME? | 5
#NUM! | 6
#N/A! | 7
everything else | #N/A!
Note - the results of ERROR.TYPE() are different to the constants defined in ErrorConstants.

Author:
Josh Micich

Constructor Summary
Errortype()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Errortype

public Errortype()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Even

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Even

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.NumericFunction.OneArg
            extended by  org.apache.poi.ss.formula.functions.Even
All Implemented Interfaces:
Function, Function1Arg
public final class Even
extends NumericFunction.OneArg

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Constructor Summary
Even()
Method Summary
protected  double evaluate(double d)
Methods inherited from class org.apache.poi.ss.formula.functions.NumericFunction.OneArg
eval, evaluate
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Even

public Even()
Method Detail

evaluate

protected double evaluate(double d)
Specified by:
evaluate in class NumericFunction.OneArg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FinanceFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class FinanceFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.FinanceFunction
All Implemented Interfaces:
Function, Function3Arg, Function4Arg
public abstract class FinanceFunction
extends java.lang.Object
implements Function3Arg, Function4Arg

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function | FV
static Function | NPER
static Function | PMT
static Function | PV
Constructor Summary
protected FinanceFunction()
Method Summary
protected  double evaluate(double[] ds)
protected abstract  double evaluate(double rate, double arg1, double arg2, double arg3, boolean type)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3, ValueEval arg4)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FV

public static final Function FV

NPER

public static final Function NPER

PMT

public static final Function PMT

PV

public static final Function PV
Constructor Detail

FinanceFunction

protected FinanceFunction()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function3Arg

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2,
                          ValueEval arg3)
Description copied from interface: Function4Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function4Arg

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2,
                          ValueEval arg3,
                          ValueEval arg4)

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

evaluate

protected double evaluate(double[] ds)
                   throws EvaluationException
Throws:
EvaluationException

evaluate

protected abstract double evaluate(double rate,
                                   double arg1,
                                   double arg2,
                                   double arg3,
                                   boolean type)
                            throws EvaluationException
Throws:
EvaluationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FinanceLib

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class FinanceLib

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.FinanceLib

public final class FinanceLib
extends java.lang.Object

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com > This class is a functon library for common fiscal functions. Glossary of terms/abbreviations:
  • FV: Future Value
  • PV: Present Value
  • NPV: Net Present Value
  • PMT: (Periodic) Payment
For more info on the terms/abbreviations please use the references below (hyperlinks are subject to change):
Online References:
  1. GNU Emacs Calc 2.02 Manual: http://theory.uwinnipeg.ca/gnu/calc/calc_203.html
  2. Yahoo Financial Glossary: http://biz.yahoo.com/f/g/nn.html#y
  3. MS Excel function reference: http://office.microsoft.com/en-us/assistance/CH062528251033.aspx

Implementation Notes:

Symbols used in the formulae that follow:
  • p: present value
  • f: future value
  • n: number of periods
  • y: payment (in each period)
  • r: rate
  • ^: the power operator (NOT the java bitwise XOR operator!)
[From MS Excel function reference] Following are some of the key formulas that are used in this implementation:
 p(1+r)^n + y(1+rt)((1+r)^n-1)/r + f=0   ...{when r!=0}
 ny + p + f=0                            ...{when r=0}

Method Summary
static double | fv(double r, double n, double y, double p, boolean t) Future value of an amount given the number of payments, rate, amount of individual payment, present value and boolean value indicating whether payments are due at the beginning of period (false => payments are due at end of period)
static double | nper(double r, double y, double p, double f, boolean t)
static double | npv(double r, double[] cfs) calculates the Net Present Value of a principal amount given the discount rate and a sequence of cash flows (supplied as an array).
static double | pmt(double r, double n, double p, double f, boolean t)
static double | pv(double r, double n, double y, double f, boolean t) Present value of an amount given the number of future payments, rate, amount of individual payment, future value and boolean value indicating whether payments are due at the beginning of period (false => payments are due at end of period)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

fv

public static double fv(double r,
                        double n,
                        double y,
                        double p,
                        boolean t)
Future value of an amount given the number of payments, rate, amount of individual payment, present value and boolean value indicating whether payments are due at the beginning of period (false => payments are due at end of period)

Parameters:
r - rate
n - num of periods
y - pmt per period
p - future value
t - type (true=pmt at end of period, false=pmt at begining of period)

pv

public static double pv(double r,
                        double n,
                        double y,
                        double f,
                        boolean t)
Present value of an amount given the number of future payments, rate, amount of individual payment, future value and boolean value indicating whether payments are due at the beginning of period (false => payments are due at end of period)

Parameters:
r -
n -
y -
f -
t -

npv

public static double npv(double r,
                         double[] cfs)
calculates the Net Present Value of a principal amount given the discount rate and a sequence of cash flows (supplied as an array). If the amounts are income the value should be positive, else if they are payments and not income, the value should be negative.

Parameters:
r -
cfs - cashflow amounts

pmt

public static double pmt(double r,
                         double n,
                         double p,
                         double f,
                         boolean t)
Parameters:
r -
n -
p -
f -
t -

nper

public static double nper(double r,
                          double y,
                          double p,
                          double f,
                          boolean t)
Parameters:
r -
y -
p -
f -
t -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fixed0ArgFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Fixed0ArgFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed0ArgFunction
All Implemented Interfaces:
Function, Function0Arg
Direct Known Subclasses:
Na, Now, Today
public abstract class Fixed0ArgFunction
extends java.lang.Object
implements Function0Arg

Convenience base class for functions that only take zero arguments.

Author:
Josh Micich

Constructor Summary
Fixed0ArgFunction()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.formula.functions.Function0Arg
evaluate

Constructor Detail

Fixed0ArgFunction

public Fixed0ArgFunction()
Method Detail

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fixed1ArgFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Fixed1ArgFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
All Implemented Interfaces:
Function, Function1Arg
Direct Known Subclasses:
CalendarFieldFunction, Columns, Countblank, Errortype, LogicalFunction, NumericFunction.OneArg, PercentEval, Rows, T, UnaryMinusEval, UnaryPlusEval, Value
public abstract class Fixed1ArgFunction
extends java.lang.Object
implements Function1Arg

Convenience base class for functions that must take exactly one argument.

Author:
Josh Micich

Constructor Summary
Fixed1ArgFunction()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.formula.functions.Function1Arg
evaluate

Constructor Detail

Fixed1ArgFunction

public Fixed1ArgFunction()
Method Detail

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fixed2ArgFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Fixed2ArgFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
All Implemented Interfaces:
Function, Function2Arg
Direct Known Subclasses:
ConcatEval, Countif, IntersectionEval, NumericFunction.TwoArg, RangeEval, RelationalOperationEval, TwoOperandNumericOperation, XYNumericFunction
public abstract class Fixed2ArgFunction
extends java.lang.Object
implements Function2Arg

Convenience base class for functions that must take exactly two arguments.

Author:
Josh Micich

Constructor Summary
Fixed2ArgFunction()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.formula.functions.Function2Arg
evaluate

Constructor Detail

Fixed2ArgFunction

public Fixed2ArgFunction()
Method Detail

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fixed3ArgFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Fixed3ArgFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed3ArgFunction
All Implemented Interfaces:
Function, Function3Arg
Direct Known Subclasses:
DateFunc, TimeFunc
public abstract class Fixed3ArgFunction
extends java.lang.Object
implements Function3Arg

Convenience base class for functions that must take exactly three arguments.

Author:
Josh Micich

Constructor Summary
Fixed3ArgFunction()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.formula.functions.Function3Arg
evaluate

Constructor Detail

Fixed3ArgFunction

public Fixed3ArgFunction()
Method Detail

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Fixed4ArgFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Fixed4ArgFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed4ArgFunction
All Implemented Interfaces:
Function, Function4Arg
Direct Known Subclasses:
Replace
public abstract class Fixed4ArgFunction
extends java.lang.Object
implements Function4Arg

Convenience base class for functions that must take exactly four arguments.

Author:
Josh Micich

Constructor Summary
Fixed4ArgFunction()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.formula.functions.Function4Arg
evaluate

Constructor Detail

Fixed4ArgFunction

public Fixed4ArgFunction()
Method Detail

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FreeRefFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface FreeRefFunction

All Known Implementing Classes:
Indirect, Sumifs
public interface FreeRefFunction

For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed. However, a select few Excel functions have the ability to access cells that were not part of any reference passed as an argument.
Two important functions with this feature are INDIRECT and OFFSET

When POI evaluates formulas, each reference argument is capable of evaluating any cell inside its range. Actually, even cells outside the reference range but on the same sheet can be evaluated. This allows OFFSET to be implemented like most other functions - taking only the arguments, and source cell coordinates. For the moment this interface only exists to serve the INDIRECT which can decode arbitrary text into cell references, and evaluate them..

Author:
Josh Micich

Method Summary
 ValueEval evaluate(ValueEval[] args, OperationEvaluationContext ec)

Method Detail

evaluate

ValueEval evaluate(ValueEval[] args,
                   OperationEvaluationContext ec)
Parameters:
args - the pre-evaluated arguments for this function. args is never null, nor are any of its elements.
ec - primarily used to identify the source cell containing the formula being evaluated. may also be used to dynamically create reference evals.
Returns:
never null. Possibly an instance of ErrorEval in the case of a specified Excel error (Exceptions are never thrown to represent Excel errors).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface Function

All Known Subinterfaces:
Function0Arg, Function1Arg, Function2Arg, Function3Arg, Function4Arg
All Known Implementing Classes:
Address, AggregateFunction, BooleanFunction, CalendarFieldFunction, Choose, Column, Columns, ConcatEval, Count, Counta, Countblank, Countif, DateFunc, Days360, Errortype, Even, FinanceFunction, Fixed0ArgFunction, Fixed1ArgFunction, Fixed2ArgFunction, Fixed3ArgFunction, Fixed4ArgFunction, Hlookup, Hyperlink, IfFunc, Index, IntersectionEval, Irr, LogicalFunction, Lookup, Match, MinaMaxa, Mode, MultiOperandNumericFunction, Na, NotImplementedFunction, Now, Npv, NumericFunction, NumericFunction.OneArg, NumericFunction.TwoArg, Odd, Offset, PercentEval, RangeEval, Rank, Rate, RelationalOperationEval, Replace, RowFunc, Rows, Substitute, Subtotal, Sumif, Sumproduct, Sumx2my2, Sumx2py2, Sumxmy2, T, TextFunction, TimeFunc, Today, TwoOperandNumericOperation, UnaryMinusEval, UnaryPlusEval, Value, Vlookup, XYNumericFunction
public interface Function

Common interface for all implementations of Excel built-in functions.

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)

Method Detail

evaluate

ValueEval evaluate(ValueEval[] args,
                   int srcRowIndex,
                   int srcColumnIndex)
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function0Arg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface Function0Arg

All Superinterfaces:
Function
All Known Implementing Classes:
Column, Fixed0ArgFunction, Na, Now, RowFunc, Today
public interface Function0Arg
extends Function

Implemented by all functions that can be called with zero arguments

Author:
Josh Micich

Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from interface org.apache.poi.ss.formula.functions.Function
evaluate

Method Detail

evaluate

ValueEval evaluate(int srcRowIndex,
                   int srcColumnIndex)
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function1Arg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface Function1Arg

All Superinterfaces:
Function
All Known Implementing Classes:
CalendarFieldFunction, Column, Columns, Countblank, Errortype, Even, Fixed1ArgFunction, Hyperlink, LogicalFunction, NumericFunction.OneArg, Odd, PercentEval, RowFunc, Rows, T, UnaryMinusEval, UnaryPlusEval, Value
public interface Function1Arg
extends Function

Implemented by all functions that can be called with one argument

Author:
Josh Micich

Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from interface org.apache.poi.ss.formula.functions.Function
evaluate

Method Detail

evaluate

ValueEval evaluate(int srcRowIndex,
                   int srcColumnIndex,
                   ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function2Arg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface Function2Arg

All Superinterfaces:
Function
All Known Implementing Classes:
ConcatEval, Countif, Days360, Fixed2ArgFunction, Hyperlink, IfFunc, Index, IntersectionEval, Lookup, Match, NumericFunction.TwoArg, RangeEval, Rank, RelationalOperationEval, Sumif, Sumx2my2, Sumx2py2, Sumxmy2, TwoOperandNumericOperation, XYNumericFunction
public interface Function2Arg
extends Function

Implemented by all functions that can be called with two arguments

Author:
Josh Micich

Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from interface org.apache.poi.ss.formula.functions.Function
evaluate

Method Detail

evaluate

ValueEval evaluate(int srcRowIndex,
                   int srcColumnIndex,
                   ValueEval arg0,
                   ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function3Arg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface Function3Arg

All Superinterfaces:
Function
All Known Implementing Classes:
DateFunc, Days360, FinanceFunction, Fixed3ArgFunction, Hlookup, IfFunc, Index, Lookup, Match, Rank, Substitute, Sumif, TimeFunc, Vlookup
public interface Function3Arg
extends Function

Implemented by all functions that can be called with three arguments

Author:
Josh Micich

Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from interface org.apache.poi.ss.formula.functions.Function
evaluate

Method Detail

evaluate

ValueEval evaluate(int srcRowIndex,
                   int srcColumnIndex,
                   ValueEval arg0,
                   ValueEval arg1,
                   ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function4Arg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface Function4Arg

All Superinterfaces:
Function
All Known Implementing Classes:
FinanceFunction, Fixed4ArgFunction, Hlookup, Index, Replace, Substitute, Vlookup
public interface Function4Arg
extends Function

Implemented by all functions that can be called with four arguments

Author:
Josh Micich

Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from interface org.apache.poi.ss.formula.functions.Function
evaluate

Method Detail

evaluate

ValueEval evaluate(int srcRowIndex,
                   int srcColumnIndex,
                   ValueEval arg0,
                   ValueEval arg1,
                   ValueEval arg2,
                   ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Hlookup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Hlookup

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Hlookup
All Implemented Interfaces:
Function, Function3Arg, Function4Arg
public final class Hlookup
extends java.lang.Object

Implementation of the HLOOKUP() function.

HLOOKUP finds a column in a lookup table by the first row value and returns the value from another row.
Syntax:
HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.
row_index_num a 1 based index specifying which row value of the lookup data will be returned.
range_lookup If TRUE (default), HLOOKUP finds the largest value less than or equal to the lookup_value. If FALSE, only exact matches will be considered

Author:
Josh Micich

Constructor Summary
Hlookup()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Hlookup

public Hlookup()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2,
                          ValueEval arg3)
Description copied from interface: Function4Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Hyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Hyperlink

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Hyperlink
All Implemented Interfaces:
Function, Function1Arg, Function2Arg
public final class Hyperlink
extends java.lang.Object

Implementation of Excel HYPERLINK function.

In Excel this function has special behaviour - it causes the displayed cell value to behave like a hyperlink in the GUI. From an evaluation perspective however, it is very simple.

Syntax:
HYPERLINK(link_location, friendly_name)

link_location The URL of the hyperlink
friendly_name (optional) the value to display

Returns last argument. Leaves type unchanged (does not convert to StringEval).

Author:
Wayne Clingingsmith

Constructor Summary
Hyperlink()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Hyperlink

public Hyperlink()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IfFunc

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class IfFunc

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.IfFunc
All Implemented Interfaces:
Function, Function2Arg, Function3Arg
public final class IfFunc
extends java.lang.Object

Implementation for the Excel function IF

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Constructor Summary
IfFunc()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
static boolean evaluateFirstArg(ValueEval arg, int srcCellRow, int srcCellCol)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IfFunc

public IfFunc()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluateFirstArg

public static boolean evaluateFirstArg(ValueEval arg,
                                       int srcCellRow,
                                       int srcCellCol)
                                throws EvaluationException
Throws:
EvaluationException

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Index

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Index

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Index
All Implemented Interfaces:
Function, Function2Arg, Function3Arg, Function4Arg
public final class Index
extends java.lang.Object
implements Function2Arg, Function3Arg, Function4Arg

Implementation for the Excel function INDEX

Syntax :
INDEX ( reference, row_num[, column_num [, area_num]])
INDEX ( array, row_num[, column_num])

reference | typically an area reference, possibly a union of areas
array | a literal array value (currently not supported)
row_num | selects the row within the array or area reference
column_num | selects column within the array or area reference. default is 1
area_num | used when reference is a union of areas

Author:
Josh Micich

Constructor Summary
Index()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Index

public Index()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function2Arg

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function3Arg

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2,
                          ValueEval arg3)
Description copied from interface: Function4Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function4Arg

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Indirect

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Indirect

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Indirect
All Implemented Interfaces:
FreeRefFunction
public final class Indirect
extends java.lang.Object
implements FreeRefFunction

Implementation for Excel function INDIRECT

INDIRECT() returns the cell or area reference denoted by the text argument.

Syntax:
INDIRECT(ref_text,isA1Style)

ref_text a string representation of the desired reference as it would normally be written in a cell formula.
isA1Style (default TRUE) specifies whether the ref_text should be interpreted as A1-style or R1C1-style.

Author:
Josh Micich

Field Summary
static FreeRefFunction instance
Method Summary
 ValueEval evaluate(ValueEval[] args, OperationEvaluationContext ec)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final FreeRefFunction instance
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          OperationEvaluationContext ec)
Specified by:
evaluate in interface FreeRefFunction
Parameters:
args - the pre-evaluated arguments for this function. args is never null, nor are any of its elements.
ec - primarily used to identify the source cell containing the formula being evaluated. may also be used to dynamically create reference evals.
Returns:
never null. Possibly an instance of ErrorEval in the case of a specified Excel error (Exceptions are never thrown to represent Excel errors).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Irr

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Irr

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Irr
All Implemented Interfaces:
Function
public final class Irr
extends java.lang.Object
implements Function

Calculates the internal rate of return. Syntax is IRR(values) or IRR(values,guess)

Author:
Marcel May, Yegor Kozlov
See Also:
Wikipedia on IRR, Excel IRR

Constructor Summary
Irr()
Method Summary
ValueEval | evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
static double | irr(double[] income) Computes the internal rate of return using an estimated irr of 10 percent.
static double | irr(double[] values, double guess) Calculates IRR using the Newton-Raphson Method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Irr

public Irr()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

irr

public static double irr(double[] income)
Computes the internal rate of return using an estimated irr of 10 percent.

Parameters:
income - the income values.
Returns:
the irr.

irr

public static double irr(double[] values,
                         double guess)
Calculates IRR using the Newton-Raphson Method.

Starting with the guess, the method cycles through the calculation until the result is accurate within 0.00001 percent. If IRR can't find a result that works after 20 tries, the Double.NaN<> is returned.

The implementation is inspired by the NewtonSolver from the Apache Commons-Math library,

Parameters:
values - the income values.
guess - the initial guess of irr.
Returns:
the irr value. The method returns Double.NaN if the maximum iteration count is exceeded
See Also:
http://commons.apache.org

, http://en.wikipedia.org/wiki/Internal_rate_of_return#Numerical_solution, http://en.wikipedia.org/wiki/Newton%27s_method
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogicalFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class LogicalFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.LogicalFunction
All Implemented Interfaces:
Function, Function1Arg
public abstract class LogicalFunction
extends Fixed1ArgFunction

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >, Josh Micich

Field Summary
static Function | ISBLANK
static Function | ISERROR
static Function | ISLOGICAL
static Function | ISNA Implementation for Excel ISNA() function. Syntax: ISNA(value) value The value to be tested Returns TRUE if the specified value is '#N/A', FALSE otherwise.
static Function | ISNONTEXT
static Function | ISNUMBER
static Function | ISREF
static Function | ISTEXT
Constructor Summary
LogicalFunction()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
protected abstract  boolean evaluate(ValueEval arg)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ISLOGICAL

public static final Function ISLOGICAL

ISNONTEXT

public static final Function ISNONTEXT

ISNUMBER

public static final Function ISNUMBER

ISTEXT

public static final Function ISTEXT

ISBLANK

public static final Function ISBLANK

ISERROR

public static final Function ISERROR

ISNA

public static final Function ISNA
Implementation for Excel ISNA() function.

Syntax:
ISNA(value)

value The value to be tested

Returns TRUE if the specified value is '#N/A', FALSE otherwise.

ISREF

public static final Function ISREF
Constructor Detail

LogicalFunction

public LogicalFunction()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

protected abstract boolean evaluate(ValueEval arg)
Parameters:
arg - any ValueEval, potentially BlankEval or ErrorEval.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Lookup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Lookup

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Lookup
All Implemented Interfaces:
Function, Function2Arg, Function3Arg
public final class Lookup
extends java.lang.Object

Implementation of Excel function LOOKUP.

LOOKUP finds an index row in a lookup table by the first column value and returns the value from another column. Syntax:
VLOOKUP(lookup_value, lookup_vector, result_vector)

lookup_value The value to be found in the lookup vector.
lookup_vector An area reference for the lookup data.
result_vector Single row or single column area reference from which the result value is chosen.

Author:
Josh Micich

Constructor Summary
Lookup()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Lookup

public Lookup()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Match

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Match

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Match
All Implemented Interfaces:
Function, Function2Arg, Function3Arg
public final class Match
extends java.lang.Object

Implementation for the MATCH() Excel function.

Syntax:
MATCH(lookup_value, lookup_array, match_type)

Returns a 1-based index specifying at what position in the lookup_array the specified lookup_value is found.

Specific matching behaviour can be modified with the optional match_type parameter.

Value | Matching Behaviour
1 | (default) find the largest value that is less than or equal to lookup_value. The lookup_array must be in ascending order*.
0 | find the first value that is exactly equal to lookup_value. The lookup_array can be in any order.
-1 | find the smallest value that is greater than or equal to lookup_value. The lookup_array must be in descending order*.
* Note regarding order - For the match_type cases that require the lookup_array to be ordered, MATCH() can produce incorrect results if this requirement is not met. Observed behaviour in Excel is to return the lowest index value for which every item after that index breaks the match rule.
The (ascending) sort order expected by MATCH() is:
numbers (low to high), strings (A to Z), boolean (FALSE to TRUE)
MATCH() ignores all elements in the lookup_array with a different type to the lookup_value. Type conversion of the lookup_array elements is never performed.

Author:
Josh Micich

Constructor Summary
Match()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Match

public Match()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MinaMaxa

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class MinaMaxa

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
        extended by  org.apache.poi.ss.formula.functions.MinaMaxa
All Implemented Interfaces:
Function
public abstract class MinaMaxa
extends MultiOperandNumericFunction

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static Function | MAXA
static Function | MINA
Constructor Summary
protected MinaMaxa()
Method Summary
Methods inherited from class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
evaluate, evaluate, getMaxNumOperands, getNumberArray, isSubtotalCounted
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MAXA

public static final Function MAXA

MINA

public static final Function MINA
Constructor Detail

MinaMaxa

protected MinaMaxa()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Mode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Mode

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Mode
All Implemented Interfaces:
Function
public final class Mode
extends java.lang.Object
implements Function

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Constructor Summary
Mode()
Method Summary
static double | evaluate(double[] v) if v is zero length or contains no duplicates, return value is Double.NaN.
ValueEval | evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Mode

public Mode()
Method Detail

evaluate

public static double evaluate(double[] v)
                       throws EvaluationException
if v is zero length or contains no duplicates, return value is Double.NaN. Else returns the value that occurs most times and if there is a tie, returns the first such value.

Parameters:
v -
Throws:
EvaluationException

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcCellRow,
                          int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultiOperandNumericFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class MultiOperandNumericFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.MultiOperandNumericFunction
All Implemented Interfaces:
Function
Direct Known Subclasses:
AggregateFunction, MinaMaxa
public abstract class MultiOperandNumericFunction
extends java.lang.Object
implements Function

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com > This is the super class for all excel function evaluator classes that take variable number of operands, and where the order of operands does not matter

Constructor Summary
protected MultiOperandNumericFunction(boolean isReferenceBoolCounted, boolean isBlankCounted)
Method Summary
protected abstract double | evaluate(double[] values)
ValueEval | evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
protected int | getMaxNumOperands() Maximum number of operands accepted by this function.
protected double[] | getNumberArray(ValueEval[] operands) Returns a double array that contains values for the numeric cells from among the list of operands.
boolean | isSubtotalCounted() Whether to count nested subtotals.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MultiOperandNumericFunction

protected MultiOperandNumericFunction(boolean isReferenceBoolCounted,
                                      boolean isBlankCounted)
Method Detail

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcCellRow,
                                int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

evaluate

protected abstract double evaluate(double[] values)
                            throws EvaluationException
Throws:
EvaluationException

getMaxNumOperands

protected int getMaxNumOperands()
Maximum number of operands accepted by this function. Subclasses may override to change default value.

getNumberArray

protected final double[] getNumberArray(ValueEval[] operands)
                                 throws EvaluationException
Returns a double array that contains values for the numeric cells from among the list of operands. Blanks and Blank equivalent cells are ignored. Error operands or cells containing operands of type that are considered invalid and would result in #VALUE! error in excel cause this function to return null.

Returns:
never null
Throws:
EvaluationException

isSubtotalCounted

public boolean isSubtotalCounted()
Whether to count nested subtotals.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Na

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Na

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed0ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Na
All Implemented Interfaces:
Function, Function0Arg
public final class Na
extends Fixed0ArgFunction

Implementation of Excel function NA()

Author:
Josh Micich

Constructor Summary
Na()
Method Summary
 ValueEval evaluate(int srcCellRow, int srcCellCol)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed0ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Na

public Na()
Method Detail

evaluate

public ValueEval evaluate(int srcCellRow,
                          int srcCellCol)
Description copied from interface: Function0Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotImplementedFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class NotImplementedFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.NotImplementedFunction
All Implemented Interfaces:
Function
public final class NotImplementedFunction
extends java.lang.Object
implements Function

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com > This is the default implementation of a Function class. The default behaviour is to raise a POI internal error (NotImplementedException). This error should alert the user that the formula contained a function that is not yet implemented.

Constructor Summary
protected | NotImplementedFunction()
 | NotImplementedFunction(java.lang.String name)
Method Summary
ValueEval | evaluate(ValueEval[] operands, int srcRow, int srcCol)
java.lang.String | getFunctionName()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotImplementedFunction

protected NotImplementedFunction()

NotImplementedFunction

public NotImplementedFunction(java.lang.String name)
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] operands,
                          int srcRow,
                          int srcCol)
Specified by:
evaluate in interface Function
Parameters:
operands - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRow - row index of the cell containing the formula under evaluation
srcCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

getFunctionName

public java.lang.String getFunctionName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Now

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Now

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed0ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Now
All Implemented Interfaces:
Function, Function0Arg
public final class Now
extends Fixed0ArgFunction

Implementation of Excel NOW() Function

Author:
Frank Taffelt

Constructor Summary
Now()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed0ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Now

public Now()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex)
Description copied from interface: Function0Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Npv

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Npv

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Npv
All Implemented Interfaces:
Function
public final class Npv
extends java.lang.Object
implements Function

Calculates the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values). Minimum 2 arguments, first arg is the rate of discount over the length of one period others up to 254 arguments representing the payments and income.

Author:
SPetrakovsky, Marcel May

Constructor Summary
Npv()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Npv

public Npv()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumericFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class NumericFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.NumericFunction
All Implemented Interfaces:
Function
public abstract class NumericFunction
extends java.lang.Object
implements Function

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >, Josh Micich, Stephen Wolke (smwolke at geistig.com)

Nested Class Summary
static class | NumericFunction.OneArg
static class | NumericFunction.TwoArg
Field Summary
static Function | ABS
static Function | ACOS
static Function | ACOSH
static Function | ASIN
static Function | ASINH
static Function | ATAN
static Function | ATAN2
static Function | ATANH
static Function | CEILING
static Function | COMBIN
static Function | COS
static Function | COSH
static Function | DEGREES
static Function | DOLLAR
static Function | EXP
static Function | FACT
static Function | FLOOR
static Function | INT
static Function | LN
static Function | LOG
static Function | LOG10
static Function | MOD
static Function | PI
static Function | POISSON
static Function | POWER
static Function | RADIANS
static Function | RAND
static Function | ROUND
static Function | ROUNDDOWN
static Function | ROUNDUP
static Function | SIGN
static Function | SIN
static Function | SINH
static Function | SQRT
static Function | TAN
static Function | TANH
static Function | TRUNC
Constructor Summary
NumericFunction()
Method Summary
static void | checkValue(double result)
protected abstract double | eval(ValueEval[] args, int srcCellRow, int srcCellCol)
ValueEval | evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
protected static double | singleOperandEvaluate(ValueEval arg, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ABS

public static final Function ABS

ACOS

public static final Function ACOS

ACOSH

public static final Function ACOSH

ASIN

public static final Function ASIN

ASINH

public static final Function ASINH

ATAN

public static final Function ATAN

ATANH

public static final Function ATANH

COS

public static final Function COS

COSH

public static final Function COSH

DEGREES

public static final Function DEGREES

DOLLAR

public static final Function DOLLAR

EXP

public static final Function EXP

FACT

public static final Function FACT

INT

public static final Function INT

LN

public static final Function LN

LOG10

public static final Function LOG10

RADIANS

public static final Function RADIANS

SIGN

public static final Function SIGN

SIN

public static final Function SIN

SINH

public static final Function SINH

SQRT

public static final Function SQRT

TAN

public static final Function TAN

TANH

public static final Function TANH

ATAN2

public static final Function ATAN2

CEILING

public static final Function CEILING

COMBIN

public static final Function COMBIN

FLOOR

public static final Function FLOOR

MOD

public static final Function MOD

POWER

public static final Function POWER

ROUND

public static final Function ROUND

ROUNDDOWN

public static final Function ROUNDDOWN

ROUNDUP

public static final Function ROUNDUP

TRUNC

public static final Function TRUNC

LOG

public static final Function LOG

PI

public static final Function PI

RAND

public static final Function RAND

POISSON

public static final Function POISSON
Constructor Detail

NumericFunction

public NumericFunction()
Method Detail

singleOperandEvaluate

protected static final double singleOperandEvaluate(ValueEval arg,
                                                    int srcRowIndex,
                                                    int srcColumnIndex)
                                             throws EvaluationException
Throws:
EvaluationException

checkValue

public static final void checkValue(double result)
                             throws EvaluationException
Throws:
EvaluationException - (#NUM!) if result is NaN or Infinity

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcCellRow,
                                int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

eval

protected abstract double eval(ValueEval[] args,
                               int srcCellRow,
                               int srcCellCol)
                        throws EvaluationException
Throws:
EvaluationException
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumericFunction.OneArg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class NumericFunction.OneArg

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.NumericFunction.OneArg
All Implemented Interfaces:
Function, Function1Arg
Direct Known Subclasses:
Even, Odd
Enclosing class:
NumericFunction
public abstract static class NumericFunction.OneArg
extends Fixed1ArgFunction

Constructor Summary
protected NumericFunction.OneArg()
Method Summary
protected  double eval(ValueEval[] args, int srcCellRow, int srcCellCol)
protected abstract  double evaluate(double d)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NumericFunction.OneArg

protected NumericFunction.OneArg()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

eval

protected final double eval(ValueEval[] args,
                            int srcCellRow,
                            int srcCellCol)
                     throws EvaluationException
Throws:
EvaluationException

evaluate

protected abstract double evaluate(double d)
                            throws EvaluationException
Throws:
EvaluationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumericFunction.TwoArg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class NumericFunction.TwoArg

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.functions.NumericFunction.TwoArg
All Implemented Interfaces:
Function, Function2Arg
Enclosing class:
NumericFunction
public abstract static class NumericFunction.TwoArg
extends Fixed2ArgFunction

Constructor Summary
protected NumericFunction.TwoArg()
Method Summary
protected abstract  double evaluate(double d0, double d1)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NumericFunction.TwoArg

protected NumericFunction.TwoArg()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

protected abstract double evaluate(double d0,
                                   double d1)
                            throws EvaluationException
Throws:
EvaluationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Odd

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Odd

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.NumericFunction.OneArg
            extended by  org.apache.poi.ss.formula.functions.Odd
All Implemented Interfaces:
Function, Function1Arg
public final class Odd
extends NumericFunction.OneArg

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Constructor Summary
Odd()
Method Summary
protected  double evaluate(double d)
Methods inherited from class org.apache.poi.ss.formula.functions.NumericFunction.OneArg
eval, evaluate
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Odd

public Odd()
Method Detail

evaluate

protected double evaluate(double d)
Specified by:
evaluate in class NumericFunction.OneArg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Offset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Offset

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Offset
All Implemented Interfaces:
Function
public final class Offset
extends java.lang.Object
implements Function

Implementation for Excel function OFFSET()

OFFSET returns an area reference that is a specified number of rows and columns from a reference cell or area.

Syntax:
OFFSET(reference, rows, cols, height, width)

reference is the base reference.
rows is the number of rows up or down from the base reference.
cols is the number of columns left or right from the base reference.
height (default same height as base reference) is the row count for the returned area reference.
width (default same width as base reference) is the column count for the returned area reference.

Author:
Josh Micich

Constructor Summary
Offset()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Offset

public Offset()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcCellRow,
                          int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.functions
Interfaces
FreeRefFunction
Function
Function0Arg
Function1Arg
Function2Arg
Function3Arg
Function4Arg
XYNumericFunction.Accumulator
Classes
Address
AggregateFunction
BooleanFunction
CalendarFieldFunction
Choose
Column
Columns
Count
Counta
Countblank
Countif
DateFunc
Days360
Errortype
Even
FinanceFunction
FinanceLib
Fixed0ArgFunction
Fixed1ArgFunction
Fixed2ArgFunction
Fixed3ArgFunction
Fixed4ArgFunction
Hlookup
Hyperlink
IfFunc
Index
Indirect
Irr
LogicalFunction
Lookup
Match
MinaMaxa
Mode
MultiOperandNumericFunction
Na
NotImplementedFunction
Now
Npv
NumericFunction
NumericFunction.OneArg
NumericFunction.TwoArg
Odd
Offset
Rank
Rate
Replace
RowFunc
Rows
Substitute
Subtotal
Sumif
Sumifs
Sumproduct
Sumx2my2
Sumx2py2
Sumxmy2
T
TextFunction
TimeFunc
Today
Value
Vlookup
XYNumericFunction


org.apache.poi.ss.formula.functions

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.functions

Interface Summary
FreeRefFunction | For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed.
Function | Common interface for all implementations of Excel built-in functions.
Function0Arg | Implemented by all functions that can be called with zero arguments
Function1Arg | Implemented by all functions that can be called with one argument
Function2Arg | Implemented by all functions that can be called with two arguments
Function3Arg | Implemented by all functions that can be called with three arguments
Function4Arg | Implemented by all functions that can be called with four arguments
XYNumericFunction.Accumulator |

Class Summary
Address | Creates a text reference as text, given specified row and column numbers.
AggregateFunction
BooleanFunction | Here are the general rules concerning Boolean functions: Blanks are ignored (not either true or false) Strings are ignored if part of an area ref or cell ref, otherwise they must be 'true' or 'false' Numbers: 0 is false.
CalendarFieldFunction | Implementation of Excel functions Date parsing functions: Date - DAY, MONTH and YEAR Time - HOUR, MINUTE and SECOND
Choose
Column
Columns | Implementation for Excel COLUMNS function.
Count | Counts the number of cells that contain numeric data within the list of arguments.
Counta | Counts the number of cells that contain data within the list of arguments.
Countblank | Implementation for the function COUNTBLANK
Countif | Implementation for the function COUNTIF
DateFunc | Implementation for the Excel function DATE
Days360 | Calculates the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations.
Errortype | Implementation for the ERROR.TYPE() Excel function.
Even
FinanceFunction
FinanceLib
Fixed0ArgFunction | Convenience base class for functions that only take zero arguments.
Fixed1ArgFunction | Convenience base class for functions that must take exactly one argument.
Fixed2ArgFunction | Convenience base class for functions that must take exactly two arguments.
Fixed3ArgFunction | Convenience base class for functions that must take exactly three arguments.
Fixed4ArgFunction | Convenience base class for functions that must take exactly four arguments.
Hlookup Implementation of the HLOOKUP() function.

HLOOKUP finds a column in a lookup table by the first row value and returns the value from another row.
Syntax:
HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

Hyperlink Implementation of Excel HYPERLINK function.

In Excel this function has special behaviour - it causes the displayed cell value to behave like a hyperlink in the GUI.

IfFunc | Implementation for the Excel function IF
Index | Implementation for the Excel function INDEX
Indirect Implementation for Excel function INDIRECT

INDIRECT() returns the cell or area reference denoted by the text argument.

Syntax:
INDIRECT(ref_text,isA1Style)

ref_text a string representation of the desired reference as it would normally be written in a cell formula.
isA1Style (default TRUE) specifies whether the ref_text should be interpreted as A1-style or R1C1-style.

Irr | Calculates the internal rate of return.
LogicalFunction
Lookup Implementation of Excel function LOOKUP.

LOOKUP finds an index row in a lookup table by the first column value and returns the value from another column.

Match Implementation for the MATCH() Excel function.

Syntax:
MATCH(lookup_value, lookup_array, match_type)

Returns a 1-based index specifying at what position in the lookup_array the specified lookup_value is found.

Specific matching behaviour can be modified with the optional match_type parameter.

MinaMaxa
Mode
MultiOperandNumericFunction
Na | Implementation of Excel function NA()
NotImplementedFunction
Now | Implementation of Excel NOW() Function
Npv | Calculates the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values).
NumericFunction
NumericFunction.OneArg
NumericFunction.TwoArg
Odd
Offset Implementation for Excel function OFFSET()

OFFSET returns an area reference that is a specified number of rows and columns from a reference cell or area.

Syntax:
OFFSET(reference, rows, cols, height, width)

reference is the base reference.
rows is the number of rows up or down from the base reference.
cols is the number of columns left or right from the base reference.
height (default same height as base reference) is the row count for the returned area reference.
width (default same width as base reference) is the column count for the returned area reference.
Rank | Returns the rank of a number in a list of numbers.
Rate | Implements the Excel Rate function
Replace An implementation of the Excel REPLACE() function:

Replaces part of a text string based on the number of characters you specify, with another text string.
Syntax:
REPLACE(oldText, startNum, numChars, newText)

oldText The text string containing characters to replace
startNum The position of the first character to replace (1-based)
numChars The number of characters to replace
newText The new text value to replace the removed section
RowFunc | Implementation for the Excel function ROW
Rows | Implementation for Excel ROWS function.
Substitute An implementation of the SUBSTITUTE function:

Substitutes text in a text string with new text, some number of times.

Subtotal | Implementation for the Excel function SUBTOTAL
Sumif | Implementation for the Excel function SUMIF
Sumifs | Implementation for the Excel function SUMIFS
Sumproduct | Implementation for the Excel function SUMPRODUCT
Sumx2my2 Implementation of Excel function SUMX2MY2()

Calculates the sum of differences of squares in two arrays of the same size.
Syntax:
SUMX2MY2(arrayX, arrayY)

result = Σi: 0..n(xi2-yi2)

Sumx2py2 Implementation of Excel function SUMX2PY2()

Calculates the sum of squares in two arrays of the same size.
Syntax:
SUMX2PY2(arrayX, arrayY)

result = Σi: 0..n(xi2+yi2)

Sumxmy2 Implementation of Excel function SUMXMY2()

Calculates the sum of squares of differences between two arrays of the same size.
Syntax:
SUMXMY2(arrayX, arrayY)

result = Σi: 0..n(xi-yi)2

T Implementation of Excel T() function

If the argument is a text or error value it is returned unmodified.

TextFunction
TimeFunc | Implementation for the Excel function TIME
Today Implementation of Excel TODAY() Function
Value Implementation for Excel VALUE() function.

Syntax:
VALUE(text)
Converts the text argument to a number.

Vlookup Implementation of the VLOOKUP() function.

VLOOKUP finds a row in a lookup table by the first column value and returns the value from another column.
Syntax:
VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

XYNumericFunction


org.apache.poi.ss.formula.functions Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.functions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.functions.Address (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.BooleanFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Choose (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Column (implements org.apache.poi.ss.formula.functions.Function0Arg, org.apache.poi.ss.formula.functions.Function1Arg)
    • org.apache.poi.ss.formula.functions.Count (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Counta (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Days360
    • org.apache.poi.ss.formula.functions.FinanceFunction (implements org.apache.poi.ss.formula.functions.Function3Arg, org.apache.poi.ss.formula.functions.Function4Arg)
    • org.apache.poi.ss.formula.functions.FinanceLib
    • org.apache.poi.ss.formula.functions.Fixed0ArgFunction (implements org.apache.poi.ss.formula.functions.Function0Arg)
      • org.apache.poi.ss.formula.functions.Na
      • org.apache.poi.ss.formula.functions.Now
      • org.apache.poi.ss.formula.functions.Today
    • org.apache.poi.ss.formula.functions.Fixed1ArgFunction (implements org.apache.poi.ss.formula.functions.Function1Arg)
      • org.apache.poi.ss.formula.functions.CalendarFieldFunction
      • org.apache.poi.ss.formula.functions.Columns
      • org.apache.poi.ss.formula.functions.Countblank
      • org.apache.poi.ss.formula.functions.Errortype
      • org.apache.poi.ss.formula.functions.LogicalFunction
      • org.apache.poi.ss.formula.functions.NumericFunction.OneArg
        • org.apache.poi.ss.formula.functions.Even
        • org.apache.poi.ss.formula.functions.Odd
      • org.apache.poi.ss.formula.functions.Rows
      • org.apache.poi.ss.formula.functions.T
      • org.apache.poi.ss.formula.functions.Value
    • org.apache.poi.ss.formula.functions.Fixed2ArgFunction (implements org.apache.poi.ss.formula.functions.Function2Arg)
      • org.apache.poi.ss.formula.functions.Countif
      • org.apache.poi.ss.formula.functions.NumericFunction.TwoArg
      • org.apache.poi.ss.formula.functions.XYNumericFunction
        • org.apache.poi.ss.formula.functions.Sumx2my2
        • org.apache.poi.ss.formula.functions.Sumx2py2
        • org.apache.poi.ss.formula.functions.Sumxmy2
    • org.apache.poi.ss.formula.functions.Fixed3ArgFunction (implements org.apache.poi.ss.formula.functions.Function3Arg)
      • org.apache.poi.ss.formula.functions.DateFunc
      • org.apache.poi.ss.formula.functions.TimeFunc
    • org.apache.poi.ss.formula.functions.Fixed4ArgFunction (implements org.apache.poi.ss.formula.functions.Function4Arg)
      • org.apache.poi.ss.formula.functions.Replace
    • org.apache.poi.ss.formula.functions.Hlookup
    • org.apache.poi.ss.formula.functions.Hyperlink
    • org.apache.poi.ss.formula.functions.IfFunc
    • org.apache.poi.ss.formula.functions.Index (implements org.apache.poi.ss.formula.functions.Function2Arg, org.apache.poi.ss.formula.functions.Function3Arg, org.apache.poi.ss.formula.functions.Function4Arg)
    • org.apache.poi.ss.formula.functions.Indirect (implements org.apache.poi.ss.formula.functions.FreeRefFunction)
    • org.apache.poi.ss.formula.functions.Irr (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Lookup
    • org.apache.poi.ss.formula.functions.Match
    • org.apache.poi.ss.formula.functions.Mode (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.MultiOperandNumericFunction (implements org.apache.poi.ss.formula.functions.Function)
      • org.apache.poi.ss.formula.functions.AggregateFunction
      • org.apache.poi.ss.formula.functions.MinaMaxa
    • org.apache.poi.ss.formula.functions.NotImplementedFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Npv (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.NumericFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Offset (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Rank
    • org.apache.poi.ss.formula.functions.Rate (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.RowFunc (implements org.apache.poi.ss.formula.functions.Function0Arg, org.apache.poi.ss.formula.functions.Function1Arg)
    • org.apache.poi.ss.formula.functions.Substitute
    • org.apache.poi.ss.formula.functions.Subtotal (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Sumif
    • org.apache.poi.ss.formula.functions.Sumifs (implements org.apache.poi.ss.formula.functions.FreeRefFunction)
    • org.apache.poi.ss.formula.functions.Sumproduct (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.TextFunction (implements org.apache.poi.ss.formula.functions.Function)
    • org.apache.poi.ss.formula.functions.Vlookup

Interface Hierarchy

  • org.apache.poi.ss.formula.functions.FreeRefFunction
  • org.apache.poi.ss.formula.functions.Function
    • org.apache.poi.ss.formula.functions.Function0Arg
    • org.apache.poi.ss.formula.functions.Function1Arg
    • org.apache.poi.ss.formula.functions.Function2Arg
    • org.apache.poi.ss.formula.functions.Function3Arg
    • org.apache.poi.ss.formula.functions.Function4Arg
  • org.apache.poi.ss.formula.functions.XYNumericFunction.Accumulator


Uses of Package org.apache.poi.ss.formula.functions

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.functions

Packages that use org.apache.poi.ss.formula.functions
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.atp |
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.functions |
org.apache.poi.ss.formula.udf |
org.apache.poi.xssf.model |

Classes in org.apache.poi.ss.formula.functions used by org.apache.poi.ss.formula
FreeRefFunction
For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed.
Function
Common interface for all implementations of Excel built-in functions.

Classes in org.apache.poi.ss.formula.functions used by org.apache.poi.ss.formula.atp
FreeRefFunction
For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed.

Classes in org.apache.poi.ss.formula.functions used by org.apache.poi.ss.formula.eval
Fixed1ArgFunction
Convenience base class for functions that must take exactly one argument.
Fixed2ArgFunction
Convenience base class for functions that must take exactly two arguments.
Function
Common interface for all implementations of Excel built-in functions.
Function1Arg
Implemented by all functions that can be called with one argument
Function2Arg
Implemented by all functions that can be called with two arguments

Classes in org.apache.poi.ss.formula.functions used by org.apache.poi.ss.formula.functions
Count
Counts the number of cells that contain numeric data within the list of arguments.
Counta
Counts the number of cells that contain data within the list of arguments.
Fixed0ArgFunction
Convenience base class for functions that only take zero arguments.
Fixed1ArgFunction
Convenience base class for functions that must take exactly one argument.
Fixed2ArgFunction
Convenience base class for functions that must take exactly two arguments.
Fixed3ArgFunction
Convenience base class for functions that must take exactly three arguments.
Fixed4ArgFunction
Convenience base class for functions that must take exactly four arguments.
FreeRefFunction
For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed.
Function
Common interface for all implementations of Excel built-in functions.
Function0Arg
Implemented by all functions that can be called with zero arguments
Function1Arg
Implemented by all functions that can be called with one argument
Function2Arg
Implemented by all functions that can be called with two arguments
Function3Arg
Implemented by all functions that can be called with three arguments
Function4Arg
Implemented by all functions that can be called with four arguments
MultiOperandNumericFunction
NumericFunction.OneArg
XYNumericFunction
XYNumericFunction.Accumulator

Classes in org.apache.poi.ss.formula.functions used by org.apache.poi.ss.formula.udf
FreeRefFunction
For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed.

Classes in org.apache.poi.ss.formula.functions used by org.apache.poi.xssf.model
FreeRefFunction
For most Excel functions, involving references ((cell, area), (2d, 3d)), the references are passed in as arguments, and the exact location remains fixed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Rank

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Rank

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Rank
All Implemented Interfaces:
Function, Function2Arg, Function3Arg
public class Rank
extends java.lang.Object

Returns the rank of a number in a list of numbers. The rank of a number is its size relative to other values in a list. Syntax: RANK(number,ref,order) Number is the number whose rank you want to find. Ref is an array of, or a reference to, a list of numbers. Nonnumeric values in ref are ignored. Order is a number specifying how to rank number. If order is 0 (zero) or omitted, Microsoft Excel ranks number as if ref were a list sorted in descending order. If order is any nonzero value, Microsoft Excel ranks number as if ref were a list sorted in ascending order.

Author:
Rubin Wang

Constructor Summary
Rank()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Rank

public Rank()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Rate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Rate

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Rate
All Implemented Interfaces:
Function
public class Rate
extends java.lang.Object
implements Function

Implements the Excel Rate function

Constructor Summary
Rate()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Rate

public Rate()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Replace

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Replace

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed4ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Replace
All Implemented Interfaces:
Function, Function4Arg
public final class Replace
extends Fixed4ArgFunction

An implementation of the Excel REPLACE() function:

Replaces part of a text string based on the number of characters you specify, with another text string.
Syntax:
REPLACE(oldText, startNum, numChars, newText)

oldText The text string containing characters to replace
startNum The position of the first character to replace (1-based)
numChars The number of characters to replace
newText The new text value to replace the removed section

Author:
Manda Wilson < wilson at c bio dot msk cc dot org >

Constructor Summary
Replace()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed4ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Replace

public Replace()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2,
                          ValueEval arg3)
Description copied from interface: Function4Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RowFunc

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class RowFunc

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.RowFunc
All Implemented Interfaces:
Function, Function0Arg, Function1Arg
public final class RowFunc
extends java.lang.Object
implements Function0Arg, Function1Arg

Implementation for the Excel function ROW

Author:
Josh Micich

Constructor Summary
RowFunc()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RowFunc

public RowFunc()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex)
Description copied from interface: Function0Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function0Arg

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Specified by:
evaluate in interface Function1Arg

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Rows

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Rows

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Rows
All Implemented Interfaces:
Function, Function1Arg
public final class Rows
extends Fixed1ArgFunction

Implementation for Excel ROWS function.

Author:
Josh Micich

Constructor Summary
Rows()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Rows

public Rows()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Substitute

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Substitute

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Substitute
All Implemented Interfaces:
Function, Function3Arg, Function4Arg
public final class Substitute
extends java.lang.Object

An implementation of the SUBSTITUTE function:

Substitutes text in a text string with new text, some number of times.

Author:
Manda Wilson < wilson at c bio dot msk cc dot org >

Constructor Summary
Substitute()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Substitute

public Substitute()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2,
                          ValueEval arg3)
Description copied from interface: Function4Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Subtotal

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Subtotal

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Subtotal
All Implemented Interfaces:
Function
public class Subtotal
extends java.lang.Object
implements Function

Implementation for the Excel function SUBTOTAL

Syntax :
SUBTOTAL ( functionCode, ref1, ref2 ... )

functionCode | (1-11) Selects the underlying aggregate function to be used (see table below)
ref1, ref2 ... | Arguments to be passed to the underlying aggregate function

functionCode | Aggregate Function
1 | AVERAGE
2 | COUNT
3 | COUNTA
4 | MAX
5 | MIN
6 | PRODUCT
7 | STDEV
8 | STDEVP *
9 | SUM
10 | VAR *
11 | VARP *
101-111 | *

* Not implemented in POI yet. Functions 101-111 are the same as functions 1-11 but with the option 'ignore hidden values'.

Author:
Paul Tomlin < pault at bulk sms dot com >

Constructor Summary
Subtotal()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Subtotal

public Subtotal()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcRowIndex,
                          int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sumif

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Sumif

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Sumif
All Implemented Interfaces:
Function, Function2Arg, Function3Arg
public final class Sumif
extends java.lang.Object

Implementation for the Excel function SUMIF

Syntax :
SUMIF ( range, criteria, sum_range )

range | The range over which criteria is applied. Also used for addend values when the third parameter is not present
criteria | The value or expression used to filter rows from range
sum_range | Locates the top-left corner of the corresponding range of addends - values to be added (after being selected by the criteria)

Author:
Josh Micich

Constructor Summary
Sumif()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sumif

public Sumif()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sumifs

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Sumifs

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Sumifs
All Implemented Interfaces:
FreeRefFunction
public final class Sumifs
extends java.lang.Object
implements FreeRefFunction

Implementation for the Excel function SUMIFS

Syntax :
SUMIFS ( sum_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...)

  • sum_range Required. One or more cells to sum, including numbers or names, ranges, or cell references that contain numbers. Blank and text values are ignored.
  • criteria1_range Required. The first range in which to evaluate the associated criteria.
  • criteria1 Required. The criteria in the form of a number, expression, cell reference, or text that define which cells in the criteria_range1 argument will be added
  • criteria_range2, criteria2, ... Optional. Additional ranges and their associated criteria. Up to 127 range/criteria pairs are allowed.

Author:
Yegor Kozlov

Field Summary
static FreeRefFunction instance
Constructor Summary
Sumifs()
Method Summary
 ValueEval evaluate(ValueEval[] args, OperationEvaluationContext ec)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

public static final FreeRefFunction instance
Constructor Detail

Sumifs

public Sumifs()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          OperationEvaluationContext ec)
Specified by:
evaluate in interface FreeRefFunction
Parameters:
args - the pre-evaluated arguments for this function. args is never null, nor are any of its elements.
ec - primarily used to identify the source cell containing the formula being evaluated. may also be used to dynamically create reference evals.
Returns:
never null. Possibly an instance of ErrorEval in the case of a specified Excel error (Exceptions are never thrown to represent Excel errors).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sumproduct

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Sumproduct

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Sumproduct
All Implemented Interfaces:
Function
public final class Sumproduct
extends java.lang.Object
implements Function

Implementation for the Excel function SUMPRODUCT

Syntax :
SUMPRODUCT ( array1[, array2[, array3[, ...]]])

array1, ... arrayN typically area references, possibly cell references or scalar values

Let An(i,j) represent the element in the ith row jth column of the nth array
Assuming each array has the same dimensions (W, H), the result is defined as:
SUMPRODUCT = Σi: 1..H ( Σj: 1..W ( Πn: 1..N An(i,j) ) )

Author:
Josh Micich

Constructor Summary
Sumproduct()
Method Summary
 ValueEval evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sumproduct

public Sumproduct()
Method Detail

evaluate

public ValueEval evaluate(ValueEval[] args,
                          int srcCellRow,
                          int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sumx2my2

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Sumx2my2

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.functions.XYNumericFunction
            extended by  org.apache.poi.ss.formula.functions.Sumx2my2
All Implemented Interfaces:
Function, Function2Arg
public final class Sumx2my2
extends XYNumericFunction

Implementation of Excel function SUMX2MY2()

Calculates the sum of differences of squares in two arrays of the same size.
Syntax:
SUMX2MY2(arrayX, arrayY)

result = Σi: 0..n(xi2-yi2)

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.ss.formula.functions.XYNumericFunction
XYNumericFunction.Accumulator
Constructor Summary
Sumx2my2()
Method Summary
protected  XYNumericFunction.Accumulator createAccumulator()
Constructs a new instance of the Accumulator used to calculated this function
Methods inherited from class org.apache.poi.ss.formula.functions.XYNumericFunction
evaluate
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sumx2my2

public Sumx2my2()
Method Detail

createAccumulator

protected XYNumericFunction.Accumulator createAccumulator()
Description copied from class: XYNumericFunction
Constructs a new instance of the Accumulator used to calculated this function

Specified by:
createAccumulator in class XYNumericFunction
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sumx2py2

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Sumx2py2

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.functions.XYNumericFunction
            extended by  org.apache.poi.ss.formula.functions.Sumx2py2
All Implemented Interfaces:
Function, Function2Arg
public final class Sumx2py2
extends XYNumericFunction

Implementation of Excel function SUMX2PY2()

Calculates the sum of squares in two arrays of the same size.
Syntax:
SUMX2PY2(arrayX, arrayY)

result = Σi: 0..n(xi2+yi2)

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.ss.formula.functions.XYNumericFunction
XYNumericFunction.Accumulator
Constructor Summary
Sumx2py2()
Method Summary
protected  XYNumericFunction.Accumulator createAccumulator()
Constructs a new instance of the Accumulator used to calculated this function
Methods inherited from class org.apache.poi.ss.formula.functions.XYNumericFunction
evaluate
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sumx2py2

public Sumx2py2()
Method Detail

createAccumulator

protected XYNumericFunction.Accumulator createAccumulator()
Description copied from class: XYNumericFunction
Constructs a new instance of the Accumulator used to calculated this function

Specified by:
createAccumulator in class XYNumericFunction
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sumxmy2

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Sumxmy2

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.functions.XYNumericFunction
            extended by  org.apache.poi.ss.formula.functions.Sumxmy2
All Implemented Interfaces:
Function, Function2Arg
public final class Sumxmy2
extends XYNumericFunction

Implementation of Excel function SUMXMY2()

Calculates the sum of squares of differences between two arrays of the same size.
Syntax:
SUMXMY2(arrayX, arrayY)

result = Σi: 0..n(xi-yi)2

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.poi.ss.formula.functions.XYNumericFunction
XYNumericFunction.Accumulator
Constructor Summary
Sumxmy2()
Method Summary
protected  XYNumericFunction.Accumulator createAccumulator()
Constructs a new instance of the Accumulator used to calculated this function
Methods inherited from class org.apache.poi.ss.formula.functions.XYNumericFunction
evaluate
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sumxmy2

public Sumxmy2()
Method Detail

createAccumulator

protected XYNumericFunction.Accumulator createAccumulator()
Description copied from class: XYNumericFunction
Constructs a new instance of the Accumulator used to calculated this function

Specified by:
createAccumulator in class XYNumericFunction
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


T

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class T

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.T
All Implemented Interfaces:
Function, Function1Arg
public final class T
extends Fixed1ArgFunction

Implementation of Excel T() function

If the argument is a text or error value it is returned unmodified. All other argument types cause an empty string result. If the argument is an area, the first (top-left) cell is used (regardless of the coordinates of the evaluating formula cell).

Constructor Summary
T()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

T

public T()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class TextFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.TextFunction
All Implemented Interfaces:
Function
public abstract class TextFunction
extends java.lang.Object
implements Function

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >, Josh Micich, Stephen Wolke (smwolke at geistig.com)

Field Summary
static Function CHAR
Returns the character specified by a number.
static Function CLEAN
An implementation of the CLEAN function: In Excel, the Clean function removes all non-printable characters from a string.
static Function CONCATENATE
protected static java.lang.String EMPTY_STRING
static Function EXACT
static Function FIND
Implementation of the FIND() function.

Syntax:
FIND(find_text, within_text, start_num)

FIND returns the character position of the first (case sensitive) occurrence of find_text inside within_text.

protected static DataFormatter formatter
static Function LEFT
static Function LEN
static Function LOWER
static Function MID
An implementation of the MID function
MID returns a specific number of characters from a text string, starting at the specified position.

Syntax:
MID(text, start_num, num_chars)
Author: Manda Wilson < wilson at c bio dot msk cc dot org >

static Function RIGHT
static Function SEARCH
Implementation of the FIND() function.

Syntax:
SEARCH(find_text, within_text, start_num)

SEARCH is a case-insensitive version of FIND()

static Function TEXT
An implementation of the TEXT function
TEXT returns a number value formatted with the given number formatting string.
static Function TRIM
An implementation of the TRIM function: Removes leading and trailing spaces from value if evaluated operand value is string.
static Function UPPER
Constructor Summary
TextFunction()
Method Summary
ValueEval | evaluate(ValueEval[] args, int srcCellRow, int srcCellCol)
protected static double | evaluateDoubleArg(ValueEval arg, int srcCellRow, int srcCellCol)
protected abstract ValueEval | evaluateFunc(ValueEval[] args, int srcCellRow, int srcCellCol)
protected static int | evaluateIntArg(ValueEval arg, int srcCellRow, int srcCellCol)
protected static java.lang.String | evaluateStringArg(ValueEval eval, int srcRow, int srcCol)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

formatter

protected static final DataFormatter formatter

EMPTY_STRING

protected static final java.lang.String EMPTY_STRING
See Also:
Constant Field Values

CHAR

public static final Function CHAR
Returns the character specified by a number.

LEN

public static final Function LEN

LOWER

public static final Function LOWER

UPPER

public static final Function UPPER

TRIM

public static final Function TRIM
An implementation of the TRIM function: Removes leading and trailing spaces from value if evaluated operand value is string. Author: Manda Wilson < wilson at c bio dot msk cc dot org >

CLEAN

public static final Function CLEAN
An implementation of the CLEAN function: In Excel, the Clean function removes all non-printable characters from a string. Author: Aniket Banerjee(banerjee@google.com)

MID

public static final Function MID
An implementation of the MID function
MID returns a specific number of characters from a text string, starting at the specified position.

Syntax:
MID(text, start_num, num_chars)
Author: Manda Wilson < wilson at c bio dot msk cc dot org >

LEFT

public static final Function LEFT

RIGHT

public static final Function RIGHT

CONCATENATE

public static final Function CONCATENATE

EXACT

public static final Function EXACT

TEXT

public static final Function TEXT
An implementation of the TEXT function
TEXT returns a number value formatted with the given number formatting string. This function is not a complete implementation of the Excel function, but handles most of the common cases. All work is passed down to DataFormatter to be done, as this works much the same as the display focused work that that does. Syntax:
TEXT(value, format_text)

FIND

public static final Function FIND
Implementation of the FIND() function.

Syntax:
FIND(find_text, within_text, start_num)

FIND returns the character position of the first (case sensitive) occurrence of find_text inside within_text. The third parameter, start_num, is optional (default=1) and specifies where to start searching from. Character positions are 1-based.

Author: Torstein Tauno Svendsen (torstei@officenet.no)

SEARCH

public static final Function SEARCH
Implementation of the FIND() function.

Syntax:
SEARCH(find_text, within_text, start_num)

SEARCH is a case-insensitive version of FIND()

Constructor Detail

TextFunction

public TextFunction()
Method Detail

evaluateStringArg

protected static final java.lang.String evaluateStringArg(ValueEval eval,
                                                          int srcRow,
                                                          int srcCol)
                                                   throws EvaluationException
Throws:
EvaluationException

evaluateIntArg

protected static final int evaluateIntArg(ValueEval arg,
                                          int srcCellRow,
                                          int srcCellCol)
                                   throws EvaluationException
Throws:
EvaluationException

evaluateDoubleArg

protected static final double evaluateDoubleArg(ValueEval arg,
                                                int srcCellRow,
                                                int srcCellCol)
                                         throws EvaluationException
Throws:
EvaluationException

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcCellRow,
                                int srcCellCol)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcCellRow - row index of the cell containing the formula under evaluation
srcCellCol - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.

evaluateFunc

protected abstract ValueEval evaluateFunc(ValueEval[] args,
                                          int srcCellRow,
                                          int srcCellCol)
                                   throws EvaluationException
Throws:
EvaluationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimeFunc

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class TimeFunc

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed3ArgFunction
        extended by  org.apache.poi.ss.formula.functions.TimeFunc
All Implemented Interfaces:
Function, Function3Arg
public final class TimeFunc
extends Fixed3ArgFunction

Implementation for the Excel function TIME

Author:
Steven Butler (sebutler @ gmail dot com) Based on POI DateFunc

Constructor Summary
TimeFunc()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed3ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TimeFunc

public TimeFunc()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Today

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Today

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed0ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Today
All Implemented Interfaces:
Function, Function0Arg
public final class Today
extends Fixed0ArgFunction

Implementation of Excel TODAY() Function

Author:
Frank Taffelt

Constructor Summary
Today()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed0ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Today

public Today()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex)
Description copied from interface: Function0Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Value

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Value

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed1ArgFunction
        extended by  org.apache.poi.ss.formula.functions.Value
All Implemented Interfaces:
Function, Function1Arg
public final class Value
extends Fixed1ArgFunction

Implementation for Excel VALUE() function.

Syntax:
VALUE(text)
Converts the text argument to a number. Leading and/or trailing whitespace is ignored. Currency symbols and thousands separators are stripped out. Scientific notation is also supported. If the supplied text does not convert properly the result is #VALUE! error. Blank string converts to zero.

Author:
Josh Micich

Constructor Summary
Value()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed1ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Value

public Value()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0)
Description copied from interface: Function1Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Vlookup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class Vlookup

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Vlookup
All Implemented Interfaces:
Function, Function3Arg, Function4Arg
public final class Vlookup
extends java.lang.Object

Implementation of the VLOOKUP() function.

VLOOKUP finds a row in a lookup table by the first column value and returns the value from another column.
Syntax:
VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.
col_index_num a 1 based index specifying which column value of the lookup data will be returned.
range_lookup If TRUE (default), VLOOKUP finds the largest value less than or equal to the lookup_value. If FALSE, only exact matches will be considered

Author:
Josh Micich

Constructor Summary
Vlookup()
Method Summary
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1, ValueEval arg2, ValueEval arg3)
see Function.evaluate(ValueEval[], int, int)
 ValueEval evaluate(ValueEval[] args, int srcRowIndex, int srcColumnIndex)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Vlookup

public Vlookup()
Method Detail

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2)
Description copied from interface: Function3Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1,
                          ValueEval arg2,
                          ValueEval arg3)
Description copied from interface: Function4Arg
see Function.evaluate(ValueEval[], int, int)

evaluate

public final ValueEval evaluate(ValueEval[] args,
                                int srcRowIndex,
                                int srcColumnIndex)
Specified by:
evaluate in interface Function
Parameters:
args - the evaluated function arguments. Empty values are represented with BlankEval or MissingArgEval, never null.
srcRowIndex - row index of the cell containing the formula under evaluation
srcColumnIndex - column index of the cell containing the formula under evaluation
Returns:
The evaluated result, possibly an ErrorEval, never null. Note - Excel uses the error code #NUM! instead of IEEE NaN, so when numeric functions evaluate to Double.NaN be sure to translate the result to ErrorEval.NUM_ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XYNumericFunction.Accumulator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Interface XYNumericFunction.Accumulator

Enclosing class:
XYNumericFunction
protected static interface XYNumericFunction.Accumulator

Method Summary
 double accumulate(double x, double y)

Method Detail

accumulate

double accumulate(double x,
                  double y)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XYNumericFunction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.functions
Class XYNumericFunction

java.lang.Object
    extended by  org.apache.poi.ss.formula.functions.Fixed2ArgFunction
        extended by  org.apache.poi.ss.formula.functions.XYNumericFunction
All Implemented Interfaces:
Function, Function2Arg
Direct Known Subclasses:
Sumx2my2, Sumx2py2, Sumxmy2
public abstract class XYNumericFunction
extends Fixed2ArgFunction

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Nested Class Summary
protected static interface XYNumericFunction.Accumulator
Constructor Summary
XYNumericFunction()
Method Summary
protected abstract  XYNumericFunction.Accumulator createAccumulator()
Constructs a new instance of the Accumulator used to calculated this function
 ValueEval evaluate(int srcRowIndex, int srcColumnIndex, ValueEval arg0, ValueEval arg1)
see Function.evaluate(ValueEval[], int, int)
Methods inherited from class org.apache.poi.ss.formula.functions.Fixed2ArgFunction
evaluate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XYNumericFunction

public XYNumericFunction()
Method Detail

createAccumulator

protected abstract XYNumericFunction.Accumulator createAccumulator()
Constructs a new instance of the Accumulator used to calculated this function

evaluate

public ValueEval evaluate(int srcRowIndex,
                          int srcColumnIndex,
                          ValueEval arg0,
                          ValueEval arg1)
Description copied from interface: Function2Arg
see Function.evaluate(ValueEval[], int, int)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.ss.formula.functions.Address

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Address

No usage of org.apache.poi.ss.formula.functions.Address

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.AggregateFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.AggregateFunction

No usage of org.apache.poi.ss.formula.functions.AggregateFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.BooleanFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.BooleanFunction

No usage of org.apache.poi.ss.formula.functions.BooleanFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.CalendarFieldFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.CalendarFieldFunction

No usage of org.apache.poi.ss.formula.functions.CalendarFieldFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Choose

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Choose

No usage of org.apache.poi.ss.formula.functions.Choose

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Column

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Column

No usage of org.apache.poi.ss.formula.functions.Column

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Columns

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Columns

No usage of org.apache.poi.ss.formula.functions.Columns

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Count

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Count

Packages that use Count
org.apache.poi.ss.formula.functions

Uses of Count in org.apache.poi.ss.formula.functions

Methods in org.apache.poi.ss.formula.functions that return Count
static Count Count.subtotalInstance()
Create an instance of Count to use in Subtotal

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Counta

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Counta

Packages that use Counta
org.apache.poi.ss.formula.functions

Uses of Counta in org.apache.poi.ss.formula.functions

Methods in org.apache.poi.ss.formula.functions that return Counta
static Counta Counta.subtotalInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Countblank

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Countblank

No usage of org.apache.poi.ss.formula.functions.Countblank

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Countif

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Countif

No usage of org.apache.poi.ss.formula.functions.Countif

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.DateFunc

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.DateFunc

No usage of org.apache.poi.ss.formula.functions.DateFunc

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Days360

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Days360

No usage of org.apache.poi.ss.formula.functions.Days360

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Errortype

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Errortype

No usage of org.apache.poi.ss.formula.functions.Errortype

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Even

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Even

No usage of org.apache.poi.ss.formula.functions.Even

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.FinanceFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.FinanceFunction

No usage of org.apache.poi.ss.formula.functions.FinanceFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.FinanceLib

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.FinanceLib

No usage of org.apache.poi.ss.formula.functions.FinanceLib

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Fixed0ArgFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Fixed0ArgFunction

Packages that use Fixed0ArgFunction
org.apache.poi.ss.formula.functions

Uses of Fixed0ArgFunction in org.apache.poi.ss.formula.functions

Subclasses of Fixed0ArgFunction in org.apache.poi.ss.formula.functions
class | Na Implementation of Excel function NA()
class | Now Implementation of Excel NOW() Function
class | Today Implementation of Excel TODAY() Function

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Fixed1ArgFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Fixed1ArgFunction

Packages that use Fixed1ArgFunction
org.apache.poi.ss.formula.eval
org.apache.poi.ss.formula.functions

Uses of Fixed1ArgFunction in org.apache.poi.ss.formula.eval

Subclasses of Fixed1ArgFunction in org.apache.poi.ss.formula.eval
class | PercentEval Implementation of Excel formula token '%'.
class | UnaryMinusEval
class | UnaryPlusEval

Uses of Fixed1ArgFunction in org.apache.poi.ss.formula.functions

Subclasses of Fixed1ArgFunction in org.apache.poi.ss.formula.functions
class | CalendarFieldFunction Implementation of Excel functions Date parsing functions: Date - DAY, MONTH and YEAR Time - HOUR, MINUTE and SECOND
class | Columns Implementation for Excel COLUMNS function.
class | Countblank Implementation for the function COUNTBLANK
class | Errortype Implementation for the ERROR.TYPE() Excel function.
class | Even
class | LogicalFunction
static class | NumericFunction.OneArg
class | Odd
class | Rows Implementation for Excel ROWS function.
class | T Implementation of Excel T() function If the argument is a text or error value it is returned unmodified.
class | Value Implementation for Excel VALUE() function. Syntax: VALUE(text) Converts the text argument to a number.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Fixed2ArgFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Fixed2ArgFunction

Packages that use Fixed2ArgFunction
org.apache.poi.ss.formula.eval
org.apache.poi.ss.formula.functions

Uses of Fixed2ArgFunction in org.apache.poi.ss.formula.eval

Subclasses of Fixed2ArgFunction in org.apache.poi.ss.formula.eval
class | ConcatEval
class | IntersectionEval
class | RangeEval
class | RelationalOperationEval Base class for all comparison operator evaluators
class | TwoOperandNumericOperation

Uses of Fixed2ArgFunction in org.apache.poi.ss.formula.functions

Subclasses of Fixed2ArgFunction in org.apache.poi.ss.formula.functions
class | Countif Implementation for the function COUNTIF
static class | NumericFunction.TwoArg
class | Sumx2my2 Implementation of Excel function SUMX2MY2() Calculates the sum of differences of squares in two arrays of the same size. Syntax: SUMX2MY2(arrayX, arrayY) result = Σi: 0..n(xi2-yi2)
class | Sumx2py2 Implementation of Excel function SUMX2PY2() Calculates the sum of squares in two arrays of the same size. Syntax: SUMX2PY2(arrayX, arrayY) result = Σi: 0..n(xi2+yi2)
class | Sumxmy2 Implementation of Excel function SUMXMY2() Calculates the sum of squares of differences between two arrays of the same size. Syntax: SUMXMY2(arrayX, arrayY) result = Σi: 0..n(xi-yi)2
class | XYNumericFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Fixed3ArgFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Fixed3ArgFunction

Packages that use Fixed3ArgFunction
org.apache.poi.ss.formula.functions

Uses of Fixed3ArgFunction in org.apache.poi.ss.formula.functions

Subclasses of Fixed3ArgFunction in org.apache.poi.ss.formula.functions
class | DateFunc Implementation for the Excel function DATE
class | TimeFunc Implementation for the Excel function TIME

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Fixed4ArgFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Fixed4ArgFunction

Packages that use Fixed4ArgFunction
org.apache.poi.ss.formula.functions

Uses of Fixed4ArgFunction in org.apache.poi.ss.formula.functions

Subclasses of Fixed4ArgFunction in org.apache.poi.ss.formula.functions
 class Replace
An implementation of the Excel REPLACE() function:

Replaces part of a text string based on the number of characters you specify, with another text string.
Syntax:
REPLACE(oldText, startNum, numChars, newText)

oldText The text string containing characters to replace
startNum The position of the first character to replace (1-based)
numChars The number of characters to replace
newText The new text value to replace the removed section

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.FreeRefFunction

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.FreeRefFunction

Packages that use FreeRefFunction
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.atp |
org.apache.poi.ss.formula.functions |
org.apache.poi.ss.formula.udf |
org.apache.poi.xssf.model |

Uses of FreeRefFunction in org.apache.poi.ss.formula

Fields in org.apache.poi.ss.formula declared as FreeRefFunction
static FreeRefFunction OperationEvaluationContext.UDF

Methods in org.apache.poi.ss.formula that return FreeRefFunction
FreeRefFunction | WorkbookEvaluator.findUserDefinedFunction(java.lang.String functionName)
FreeRefFunction | OperationEvaluationContext.findUserDefinedFunction(java.lang.String functionName)

Methods in org.apache.poi.ss.formula with parameters of type FreeRefFunction
static void WorkbookEvaluator.registerFunction(java.lang.String name, FreeRefFunction func)
Register a ATP function in runtime.

Uses of FreeRefFunction in org.apache.poi.ss.formula.atp

Methods in org.apache.poi.ss.formula.atp that return FreeRefFunction
 FreeRefFunction AnalysisToolPak.findFunction(java.lang.String name)

Methods in org.apache.poi.ss.formula.atp with parameters of type FreeRefFunction
static void AnalysisToolPak.registerFunction(java.lang.String name, FreeRefFunction func)
Register a ATP function in runtime.

Uses of FreeRefFunction in org.apache.poi.ss.formula.functions

Classes in org.apache.poi.ss.formula.functions that implement FreeRefFunction
class | Indirect Implementation for Excel function INDIRECT INDIRECT() returns the cell or area reference denoted by the text argument. Syntax: INDIRECT(ref_text,isA1Style) ref_text a string representation of the desired reference as it would normally be written in a cell formula. isA1Style (default TRUE) specifies whether the ref_text should be interpreted as A1-style or R1C1-style.
class | Sumifs Implementation for the Excel function SUMIFS

Fields in org.apache.poi.ss.formula.functions declared as FreeRefFunction
static FreeRefFunction | Sumifs.instance
static FreeRefFunction | Indirect.instance

Uses of FreeRefFunction in org.apache.poi.ss.formula.udf

Methods in org.apache.poi.ss.formula.udf that return FreeRefFunction
FreeRefFunction | UDFFinder.findFunction(java.lang.String name) Returns executor by specified name.
FreeRefFunction | DefaultUDFFinder.findFunction(java.lang.String name)
FreeRefFunction | AggregatingUDFFinder.findFunction(java.lang.String name) Returns executor by specified name.

Constructors in org.apache.poi.ss.formula.udf with parameters of type FreeRefFunction
DefaultUDFFinder(java.lang.String[] functionNames, FreeRefFunction[] functionImpls)

Uses of FreeRefFunction in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return FreeRefFunction
 FreeRefFunction IndexedUDFFinder.findFunction(java.lang.String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.Function

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.Function

Packages that use Function
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.functions |

Uses of Function in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula with parameters of type Function
static void WorkbookEvaluator.registerFunction(java.lang.String name, Function func)
Register a function in runtime.

Uses of Function in org.apache.poi.ss.formula.eval

Classes in org.apache.poi.ss.formula.eval that implement Function
class | ConcatEval
class | IntersectionEval
class | PercentEval Implementation of Excel formula token '%'.
class | RangeEval
class | RelationalOperationEval Base class for all comparison operator evaluators
class | TwoOperandNumericOperation
class | UnaryMinusEval
class | UnaryPlusEval

Fields in org.apache.poi.ss.formula.eval declared as Function
static Function | TwoOperandNumericOperation.AddEval
static Function | TwoOperandNumericOperation.DivideEval
static Function | RelationalOperationEval.EqualEval
protected static Function[] | FunctionEval.functions Array elements corresponding to unimplemented functions are null
static Function | RelationalOperationEval.GreaterEqualEval
static Function | RelationalOperationEval.GreaterThanEval
static Function | UnaryPlusEval.instance
static Function | UnaryMinusEval.instance
static Function | RangeEval.instance
static Function | PercentEval.instance
static Function | IntersectionEval.instance
static Function | ConcatEval.instance
static Function | RelationalOperationEval.LessEqualEval
static Function | RelationalOperationEval.LessThanEval
static Function | TwoOperandNumericOperation.MultiplyEval
static Function | RelationalOperationEval.NotEqualEval
static Function | TwoOperandNumericOperation.PowerEval
static Function | TwoOperandNumericOperation.SubtractEval

Methods in org.apache.poi.ss.formula.eval that return Function
static Function FunctionEval.getBasicFunction(int functionIndex)

Methods in org.apache.poi.ss.formula.eval with parameters of type Function
static void FunctionEval.registerFunction(java.lang.String name, Function func)
Register a new function in runtime.

Uses of Function in org.apache.poi.ss.formula.functions

Subinterfaces of Function in org.apache.poi.ss.formula.functions
interface | Function0Arg Implemented by all functions that can be called with zero arguments
interface | Function1Arg Implemented by all functions that can be called with one argument
interface | Function2Arg Implemented by all functions that can be called with two arguments
interface | Function3Arg Implemented by all functions that can be called with three arguments
interface | Function4Arg Implemented by all functions that can be called with four arguments

Classes in org.apache.poi.ss.formula.functions that implement Function
 class Address
Creates a text reference as text, given specified row and column numbers.
 class AggregateFunction
 class BooleanFunction
Here are the general rules concerning Boolean functions: Blanks are ignored (not either true or false) Strings are ignored if part of an area ref or cell ref, otherwise they must be 'true' or 'false' Numbers: 0 is false.
 class CalendarFieldFunction
Implementation of Excel functions Date parsing functions: Date - DAY, MONTH and YEAR Time - HOUR, MINUTE and SECOND
 class Choose
 class Column
 class Columns
Implementation for Excel COLUMNS function.
 class Count
Counts the number of cells that contain numeric data within the list of arguments.
 class Counta
Counts the number of cells that contain data within the list of arguments.
 class Countblank
Implementation for the function COUNTBLANK
 class Countif
Implementation for the function COUNTIF
 class DateFunc
Implementation for the Excel function DATE
 class Days360
Calculates the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations.
 class Errortype
Implementation for the ERROR.TYPE() Excel function.
 class Even
 class FinanceFunction
 class Fixed0ArgFunction
Convenience base class for functions that only take zero arguments.
 class Fixed1ArgFunction
Convenience base class for functions that must take exactly one argument.
 class Fixed2ArgFunction
Convenience base class for functions that must take exactly two arguments.
 class Fixed3ArgFunction
Convenience base class for functions that must take exactly three arguments.
 class Fixed4ArgFunction
Convenience base class for functions that must take exactly four arguments.
 class Hlookup
Implementation of the HLOOKUP() function.

HLOOKUP finds a column in a lookup table by the first row value and returns the value from another row.
Syntax:
HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

 class Hyperlink
Implementation of Excel HYPERLINK function.

In Excel this function has special behaviour - it causes the displayed cell value to behave like a hyperlink in the GUI.

 class IfFunc
Implementation for the Excel function IF
 class Index
Implementation for the Excel function INDEX
 class Irr
Calculates the internal rate of return.
 class LogicalFunction
 class Lookup
Implementation of Excel function LOOKUP.

LOOKUP finds an index row in a lookup table by the first column value and returns the value from another column.

 class Match
Implementation for the MATCH() Excel function.

Syntax:
MATCH(lookup_value, lookup_array, match_type)

Returns a 1-based index specifying at what position in the lookup_array the specified lookup_value is found.

Specific matching behaviour can be modified with the optional match_type parameter.

 class MinaMaxa
 class Mode
 class MultiOperandNumericFunction
 class Na
Implementation of Excel function NA()
 class NotImplementedFunction
 class Now
Implementation of Excel NOW() Function
 class Npv
Calculates the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values).
 class NumericFunction
static class NumericFunction.OneArg
static class NumericFunction.TwoArg
 class Odd
 class Offset
Implementation for Excel function OFFSET()

OFFSET returns an area reference that is a specified number of rows and columns from a reference cell or area.

Syntax:
OFFSET(reference, rows, cols, height, width)

reference is the base reference.
rows is the number of rows up or down from the base reference.
cols is the number of columns left or right from the base reference.
height (default same height as base reference) is the row count for the returned area reference.
width (default same width as base reference) is the column count for the returned area reference.
 class Rank
Returns the rank of a number in a list of numbers.
 class Rate
Implements the Excel Rate function
 class Replace
An implementation of the Excel REPLACE() function:

Replaces part of a text string based on the number of characters you specify, with another text string.
Syntax:
REPLACE(oldText, startNum, numChars, newText)

oldText The text string containing characters to replace
startNum The position of the first character to replace (1-based)
numChars The number of characters to replace
newText The new text value to replace the removed section
 class RowFunc
Implementation for the Excel function ROW
 class Rows
Implementation for Excel ROWS function.
 class Substitute
An implementation of the SUBSTITUTE function:

Substitutes text in a text string with new text, some number of times.

 class Subtotal
Implementation for the Excel function SUBTOTAL
 class Sumif
Implementation for the Excel function SUMIF
 class Sumproduct
Implementation for the Excel function SUMPRODUCT
 class Sumx2my2
Implementation of Excel function SUMX2MY2()

Calculates the sum of differences of squares in two arrays of the same size.
Syntax:
SUMX2MY2(arrayX, arrayY)

result = Σi: 0..n(xi2-yi2)

 class Sumx2py2
Implementation of Excel function SUMX2PY2()

Calculates the sum of squares in two arrays of the same size.
Syntax:
SUMX2PY2(arrayX, arrayY)

result = Σi: 0..n(xi2+yi2)

 class Sumxmy2
Implementation of Excel function SUMXMY2()

Calculates the sum of squares of differences between two arrays of the same size.
Syntax:
SUMXMY2(arrayX, arrayY)

result = Σi: 0..n(xi-yi)2

 class T
Implementation of Excel T() function

If the argument is a text or error value it is returned unmodified.

 class TextFunction
 class TimeFunc
Implementation for the Excel function TIME
 class Today
Implementation of Excel TODAY() Function
 class Value
Implementation for Excel VALUE() function.

Syntax:
VALUE(text)
Converts the text argument to a number.

 class Vlookup
Implementation of the VLOOKUP() function.

VLOOKUP finds a row in a lookup table by the first column value and returns the value from another column.
Syntax:
VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

 class XYNumericFunction

Fields in org.apache.poi.ss.formula.functions declared as Function
static Function NumericFunction.ABS
static Function NumericFunction.ACOS
static Function NumericFunction.ACOSH
static Function BooleanFunction.AND
static Function NumericFunction.ASIN
static Function NumericFunction.ASINH
static Function NumericFunction.ATAN
static Function NumericFunction.ATAN2
static Function NumericFunction.ATANH
static Function AggregateFunction.AVEDEV
static Function AggregateFunction.AVERAGE
static Function NumericFunction.CEILING
static Function TextFunction.CHAR
Returns the character specified by a number.
static Function TextFunction.CLEAN
An implementation of the CLEAN function: In Excel, the Clean function removes all non-printable characters from a string.
static Function NumericFunction.COMBIN
static Function TextFunction.CONCATENATE
static Function NumericFunction.COS
static Function NumericFunction.COSH
static Function CalendarFieldFunction.DAY
static Function NumericFunction.DEGREES
static Function AggregateFunction.DEVSQ
static Function NumericFunction.DOLLAR
static Function TextFunction.EXACT
static Function NumericFunction.EXP
static Function NumericFunction.FACT
static Function BooleanFunction.FALSE
static Function TextFunction.FIND
Implementation of the FIND() function.

Syntax:
FIND(find_text, within_text, start_num)

FIND returns the character position of the first (case sensitive) occurrence of find_text inside within_text.

static Function NumericFunction.FLOOR
static Function FinanceFunction.FV
static Function CalendarFieldFunction.HOUR
static Function DateFunc.instance
static Function NumericFunction.INT
static Function LogicalFunction.ISBLANK
static Function LogicalFunction.ISERROR
static Function LogicalFunction.ISLOGICAL
static Function LogicalFunction.ISNA
Implementation for Excel ISNA() function.

Syntax:
ISNA(value)

value The value to be tested

Returns TRUE if the specified value is '#N/A', FALSE otherwise.

static Function LogicalFunction.ISNONTEXT
static Function LogicalFunction.ISNUMBER
static Function LogicalFunction.ISREF
static Function LogicalFunction.ISTEXT
static Function AggregateFunction.LARGE
static Function TextFunction.LEFT
static Function TextFunction.LEN
static Function NumericFunction.LN
static Function NumericFunction.LOG
static Function NumericFunction.LOG10
static Function TextFunction.LOWER
static Function AggregateFunction.MAX
static Function MinaMaxa.MAXA
static Function AggregateFunction.MEDIAN
static Function TextFunction.MID
An implementation of the MID function
MID returns a specific number of characters from a text string, starting at the specified position.

Syntax:
MID(text, start_num, num_chars)
Author: Manda Wilson < wilson at c bio dot msk cc dot org >

static Function AggregateFunction.MIN
static Function MinaMaxa.MINA
static Function CalendarFieldFunction.MINUTE
static Function NumericFunction.MOD
static Function CalendarFieldFunction.MONTH
static Function BooleanFunction.NOT
static Function FinanceFunction.NPER
static Function BooleanFunction.OR
static Function NumericFunction.PI
static Function FinanceFunction.PMT
static Function NumericFunction.POISSON
static Function NumericFunction.POWER
static Function AggregateFunction.PRODUCT
static Function FinanceFunction.PV
static Function NumericFunction.RADIANS
static Function NumericFunction.RAND
static Function TextFunction.RIGHT
static Function NumericFunction.ROUND
static Function NumericFunction.ROUNDDOWN
static Function NumericFunction.ROUNDUP
static Function TextFunction.SEARCH
Implementation of the FIND() function.

Syntax:
SEARCH(find_text, within_text, start_num)

SEARCH is a case-insensitive version of FIND()

static Function CalendarFieldFunction.SECOND
static Function NumericFunction.SIGN
static Function NumericFunction.SIN
static Function NumericFunction.SINH
static Function AggregateFunction.SMALL
static Function NumericFunction.SQRT
static Function AggregateFunction.STDEV
static Function AggregateFunction.SUM
static Function AggregateFunction.SUMSQ
static Function NumericFunction.TAN
static Function NumericFunction.TANH
static Function TextFunction.TEXT
An implementation of the TEXT function
TEXT returns a number value formatted with the given number formatting string.
static Function TextFunction.TRIM
An implementation of the TRIM function: Removes leading and trailing spaces from value if evaluated operand value is string.
static Function BooleanFunction.TRUE
static Function NumericFunction.TRUNC
static Function TextFunction.UPPER
static Function AggregateFunction.VAR
static Function AggregateFunction.VARP
static Function CalendarFieldFunction.YEAR

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.Function0Arg

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.Function0Arg

Packages that use Function0Arg
org.apache.poi.ss.formula.functions

Uses of Function0Arg in org.apache.poi.ss.formula.functions

Classes in org.apache.poi.ss.formula.functions that implement Function0Arg
class | Column
class | Fixed0ArgFunction Convenience base class for functions that only take zero arguments.
class | Na Implementation of Excel function NA()
class | Now Implementation of Excel NOW() Function
class | RowFunc Implementation for the Excel function ROW
class | Today Implementation of Excel TODAY() Function

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.Function1Arg

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.Function1Arg

Packages that use Function1Arg
org.apache.poi.ss.formula.eval
org.apache.poi.ss.formula.functions

Uses of Function1Arg in org.apache.poi.ss.formula.eval

Classes in org.apache.poi.ss.formula.eval that implement Function1Arg
class | PercentEval Implementation of Excel formula token '%'.
class | UnaryMinusEval
class | UnaryPlusEval

Uses of Function1Arg in org.apache.poi.ss.formula.functions

Classes in org.apache.poi.ss.formula.functions that implement Function1Arg
class | CalendarFieldFunction Implementation of Excel functions Date parsing functions: Date - DAY, MONTH and YEAR Time - HOUR, MINUTE and SECOND
class | Column
class | Columns Implementation for Excel COLUMNS function.
class | Countblank Implementation for the function COUNTBLANK
class | Errortype Implementation for the ERROR.TYPE() Excel function.
class | Even
class | Fixed1ArgFunction Convenience base class for functions that must take exactly one argument.
class | Hyperlink Implementation of Excel HYPERLINK function. In Excel this function has special behaviour - it causes the displayed cell value to behave like a hyperlink in the GUI.
class | LogicalFunction
static class | NumericFunction.OneArg
class | Odd
class | RowFunc Implementation for the Excel function ROW
class | Rows Implementation for Excel ROWS function.
class | T Implementation of Excel T() function If the argument is a text or error value it is returned unmodified.
class | Value Implementation for Excel VALUE() function. Syntax: VALUE(text) Converts the text argument to a number.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.Function2Arg

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.Function2Arg

Packages that use Function2Arg
org.apache.poi.ss.formula.eval
org.apache.poi.ss.formula.functions

Uses of Function2Arg in org.apache.poi.ss.formula.eval

Classes in org.apache.poi.ss.formula.eval that implement Function2Arg
class | ConcatEval
class | IntersectionEval
class | RangeEval
class | RelationalOperationEval Base class for all comparison operator evaluators
class | TwoOperandNumericOperation

Uses of Function2Arg in org.apache.poi.ss.formula.functions

Classes in org.apache.poi.ss.formula.functions that implement Function2Arg
 class Countif
Implementation for the function COUNTIF
 class Days360
Calculates the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations.
 class Fixed2ArgFunction
Convenience base class for functions that must take exactly two arguments.
 class Hyperlink
Implementation of Excel HYPERLINK function.

In Excel this function has special behaviour - it causes the displayed cell value to behave like a hyperlink in the GUI.

 class IfFunc
Implementation for the Excel function IF
 class Index
Implementation for the Excel function INDEX
 class Lookup
Implementation of Excel function LOOKUP.

LOOKUP finds an index row in a lookup table by the first column value and returns the value from another column.

 class Match
Implementation for the MATCH() Excel function.

Syntax:
MATCH(lookup_value, lookup_array, match_type)

Returns a 1-based index specifying at what position in the lookup_array the specified lookup_value is found.

Specific matching behaviour can be modified with the optional match_type parameter.

static class NumericFunction.TwoArg
 class Rank
Returns the rank of a number in a list of numbers.
 class Sumif
Implementation for the Excel function SUMIF
 class Sumx2my2
Implementation of Excel function SUMX2MY2()

Calculates the sum of differences of squares in two arrays of the same size.
Syntax:
SUMX2MY2(arrayX, arrayY)

result = Σi: 0..n(xi2-yi2)

 class Sumx2py2
Implementation of Excel function SUMX2PY2()

Calculates the sum of squares in two arrays of the same size.
Syntax:
SUMX2PY2(arrayX, arrayY)

result = Σi: 0..n(xi2+yi2)

 class Sumxmy2
Implementation of Excel function SUMXMY2()

Calculates the sum of squares of differences between two arrays of the same size.
Syntax:
SUMXMY2(arrayX, arrayY)

result = Σi: 0..n(xi-yi)2

 class XYNumericFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.Function3Arg

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.Function3Arg

Packages that use Function3Arg
org.apache.poi.ss.formula.functions

Uses of Function3Arg in org.apache.poi.ss.formula.functions

Classes in org.apache.poi.ss.formula.functions that implement Function3Arg
 class DateFunc
Implementation for the Excel function DATE
 class Days360
Calculates the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations.
 class FinanceFunction
 class Fixed3ArgFunction
Convenience base class for functions that must take exactly three arguments.
 class Hlookup
Implementation of the HLOOKUP() function.

HLOOKUP finds a column in a lookup table by the first row value and returns the value from another row.
Syntax:
HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

 class IfFunc
Implementation for the Excel function IF
 class Index
Implementation for the Excel function INDEX
 class Lookup
Implementation of Excel function LOOKUP.

LOOKUP finds an index row in a lookup table by the first column value and returns the value from another column.

 class Match
Implementation for the MATCH() Excel function.

Syntax:
MATCH(lookup_value, lookup_array, match_type)

Returns a 1-based index specifying at what position in the lookup_array the specified lookup_value is found.

Specific matching behaviour can be modified with the optional match_type parameter.

 class Rank
Returns the rank of a number in a list of numbers.
 class Substitute
An implementation of the SUBSTITUTE function:

Substitutes text in a text string with new text, some number of times.

 class Sumif
Implementation for the Excel function SUMIF
 class TimeFunc
Implementation for the Excel function TIME
 class Vlookup
Implementation of the VLOOKUP() function.

VLOOKUP finds a row in a lookup table by the first column value and returns the value from another column.
Syntax:
VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.Function4Arg

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.Function4Arg

Packages that use Function4Arg
org.apache.poi.ss.formula.functions

Uses of Function4Arg in org.apache.poi.ss.formula.functions

Classes in org.apache.poi.ss.formula.functions that implement Function4Arg
 class FinanceFunction
 class Fixed4ArgFunction
Convenience base class for functions that must take exactly four arguments.
 class Hlookup
Implementation of the HLOOKUP() function.

HLOOKUP finds a column in a lookup table by the first row value and returns the value from another row.
Syntax:
HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

 class Index
Implementation for the Excel function INDEX
 class Replace
An implementation of the Excel REPLACE() function:

Replaces part of a text string based on the number of characters you specify, with another text string.
Syntax:
REPLACE(oldText, startNum, numChars, newText)

oldText The text string containing characters to replace
startNum The position of the first character to replace (1-based)
numChars The number of characters to replace
newText The new text value to replace the removed section
 class Substitute
An implementation of the SUBSTITUTE function:

Substitutes text in a text string with new text, some number of times.

 class Vlookup
Implementation of the VLOOKUP() function.

VLOOKUP finds a row in a lookup table by the first column value and returns the value from another column.
Syntax:
VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)

lookup_value The value to be found in the first column of the table array.
table_array An area reference for the lookup data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Hlookup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Hlookup

No usage of org.apache.poi.ss.formula.functions.Hlookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Hyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Hyperlink

No usage of org.apache.poi.ss.formula.functions.Hyperlink

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.IfFunc

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.IfFunc

No usage of org.apache.poi.ss.formula.functions.IfFunc

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Index

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Index

No usage of org.apache.poi.ss.formula.functions.Index

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Indirect

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Indirect

No usage of org.apache.poi.ss.formula.functions.Indirect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Irr

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Irr

No usage of org.apache.poi.ss.formula.functions.Irr

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.LogicalFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.LogicalFunction

No usage of org.apache.poi.ss.formula.functions.LogicalFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Lookup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Lookup

No usage of org.apache.poi.ss.formula.functions.Lookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Match

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Match

No usage of org.apache.poi.ss.formula.functions.Match

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.MinaMaxa

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.MinaMaxa

No usage of org.apache.poi.ss.formula.functions.MinaMaxa

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Mode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Mode

No usage of org.apache.poi.ss.formula.functions.Mode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.MultiOperandNumericFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.MultiOperandNumericFunction

Packages that use MultiOperandNumericFunction
org.apache.poi.ss.formula.functions

Uses of MultiOperandNumericFunction in org.apache.poi.ss.formula.functions

Subclasses of MultiOperandNumericFunction in org.apache.poi.ss.formula.functions
class | AggregateFunction
class | MinaMaxa

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Na

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Na

No usage of org.apache.poi.ss.formula.functions.Na

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.NotImplementedFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.NotImplementedFunction

No usage of org.apache.poi.ss.formula.functions.NotImplementedFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Now

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Now

No usage of org.apache.poi.ss.formula.functions.Now

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Npv

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Npv

No usage of org.apache.poi.ss.formula.functions.Npv

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.NumericFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.NumericFunction

No usage of org.apache.poi.ss.formula.functions.NumericFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.NumericFunction.OneArg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.NumericFunction.OneArg

Packages that use NumericFunction.OneArg
org.apache.poi.ss.formula.functions

Uses of NumericFunction.OneArg in org.apache.poi.ss.formula.functions

Subclasses of NumericFunction.OneArg in org.apache.poi.ss.formula.functions
class | Even
class | Odd

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.NumericFunction.TwoArg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.NumericFunction.TwoArg

No usage of org.apache.poi.ss.formula.functions.NumericFunction.TwoArg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Odd

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Odd

No usage of org.apache.poi.ss.formula.functions.Odd

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Offset

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Offset

No usage of org.apache.poi.ss.formula.functions.Offset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Rank

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Rank

No usage of org.apache.poi.ss.formula.functions.Rank

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Rate

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Rate

No usage of org.apache.poi.ss.formula.functions.Rate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Replace

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Replace

No usage of org.apache.poi.ss.formula.functions.Replace

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.RowFunc

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.RowFunc

No usage of org.apache.poi.ss.formula.functions.RowFunc

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Rows

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Rows

No usage of org.apache.poi.ss.formula.functions.Rows

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Substitute

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Substitute

No usage of org.apache.poi.ss.formula.functions.Substitute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Subtotal

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Subtotal

No usage of org.apache.poi.ss.formula.functions.Subtotal

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Sumif

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Sumif

No usage of org.apache.poi.ss.formula.functions.Sumif

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Sumifs

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Sumifs

No usage of org.apache.poi.ss.formula.functions.Sumifs

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Sumproduct

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Sumproduct

No usage of org.apache.poi.ss.formula.functions.Sumproduct

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Sumx2my2

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Sumx2my2

No usage of org.apache.poi.ss.formula.functions.Sumx2my2

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Sumx2py2

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Sumx2py2

No usage of org.apache.poi.ss.formula.functions.Sumx2py2

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Sumxmy2

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Sumxmy2

No usage of org.apache.poi.ss.formula.functions.Sumxmy2

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.T

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.T

No usage of org.apache.poi.ss.formula.functions.T

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.TextFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.TextFunction

No usage of org.apache.poi.ss.formula.functions.TextFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.TimeFunc

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.TimeFunc

No usage of org.apache.poi.ss.formula.functions.TimeFunc

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Today

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Today

No usage of org.apache.poi.ss.formula.functions.Today

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Value

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Value

No usage of org.apache.poi.ss.formula.functions.Value

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.Vlookup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.Vlookup

No usage of org.apache.poi.ss.formula.functions.Vlookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.functions.XYNumericFunction.Accumulator

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.functions.XYNumericFunction.Accumulator

Packages that use XYNumericFunction.Accumulator
org.apache.poi.ss.formula.functions

Uses of XYNumericFunction.Accumulator in org.apache.poi.ss.formula.functions

Methods in org.apache.poi.ss.formula.functions that return XYNumericFunction.Accumulator
protected abstract XYNumericFunction.Accumulator | XYNumericFunction.createAccumulator() Constructs a new instance of the Accumulator used to calculated this function
protected XYNumericFunction.Accumulator | Sumxmy2.createAccumulator()
protected XYNumericFunction.Accumulator | Sumx2py2.createAccumulator()
protected XYNumericFunction.Accumulator | Sumx2my2.createAccumulator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.functions.XYNumericFunction

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.functions.XYNumericFunction

Packages that use XYNumericFunction
org.apache.poi.ss.formula.functions

Uses of XYNumericFunction in org.apache.poi.ss.formula.functions

Subclasses of XYNumericFunction in org.apache.poi.ss.formula.functions
class | Sumx2my2 Implementation of Excel function SUMX2MY2() Calculates the sum of differences of squares in two arrays of the same size. Syntax: SUMX2MY2(arrayX, arrayY) result = Σi: 0..n(xi2-yi2)
class | Sumx2py2 Implementation of Excel function SUMX2PY2() Calculates the sum of squares in two arrays of the same size. Syntax: SUMX2PY2(arrayX, arrayY) result = Σi: 0..n(xi2+yi2)
class | Sumxmy2 Implementation of Excel function SUMXMY2() Calculates the sum of squares of differences between two arrays of the same size. Syntax: SUMXMY2(arrayX, arrayY) result = Σi: 0..n(xi-yi)2

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractFunctionPtg

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AbstractFunctionPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
Direct Known Subclasses:
FuncPtg, FuncVarPtg
public abstract class AbstractFunctionPtg
extends OperationPtg

This class provides the base functionality for Excel sheet functions There are two kinds of function Ptgs - tFunc and tFuncVar Therefore, this class will have ONLY two subclasses

Author:
Avik Sengupta, Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static java.lang.String FUNCTION_NAME_IF
The name of the IF function (i.e.
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
protected AbstractFunctionPtg(int functionIndex, int pReturnClass, byte[] paramTypes, int nParams)
Method Summary
byte | getDefaultOperandClass()
short | getFunctionIndex()
java.lang.String | getName()
int | getNumberOfOperands() The number of operands expected by the operations
byte | getParameterClass(int index)
abstract int | getSize()
boolean | isBaseToken()
static boolean | isBuiltInFunctionName(java.lang.String name) Used to detect whether a function name found in a formula is one of the standard excel functions
boolean | isExternalFunction() external functions get some special processing
protected static short | lookupIndex(java.lang.String name) Resolves internal function names into function indexes.
protected java.lang.String | lookupName(short index)
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FUNCTION_NAME_IF

public static final java.lang.String FUNCTION_NAME_IF
The name of the IF function (i.e. "IF"). Extracted as a constant for clarity.

See Also:
Constant Field Values
Constructor Detail

AbstractFunctionPtg

protected AbstractFunctionPtg(int functionIndex,
                              int pReturnClass,
                              byte[] paramTypes,
                              int nParams)
Method Detail

isBaseToken

public final boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

toString

public final java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg

getFunctionIndex

public final short getFunctionIndex()

getNumberOfOperands

public final int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

getName

public final java.lang.String getName()

isExternalFunction

public final boolean isExternalFunction()
external functions get some special processing

Returns:
true if this is an external function

toFormulaString

public final java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()

getSize

public abstract int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

isBuiltInFunctionName

public static final boolean isBuiltInFunctionName(java.lang.String name)
Used to detect whether a function name found in a formula is one of the standard excel functions

The name matching is case insensitive.

Returns:
true if the name specifies a standard worksheet function, false if the name should be assumed to be an external function.

lookupName

protected final java.lang.String lookupName(short index)

lookupIndex

protected static short lookupIndex(java.lang.String name)
Resolves internal function names into function indexes.

The name matching is case insensitive.

Returns:
the standard worksheet function index if found, otherwise FUNCTION_INDEX_EXTERNAL

getDefaultOperandClass

public byte getDefaultOperandClass()
Overrides:
getDefaultOperandClass in class OperationPtg

getParameterClass

public final byte getParameterClass(int index)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AddPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AddPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.AddPtg

public final class AddPtg
extends ValueOperatorPtg

Addition operator PTG the "+" binomial operator. If you need more explanation than that then well...We really can't help you here.

Author:
Andrew C. Oliver (acoliver@apache.org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) implementation of method from OperationsPtg
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
implementation of method from OperationsPtg

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Area2DPtgBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class Area2DPtgBase

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.AreaPtgBase
                extended by  org.apache.poi.ss.formula.ptg.Area2DPtgBase
All Implemented Interfaces:
java.lang.Cloneable, AreaI
Direct Known Subclasses:
AreaNPtg, AreaPtg
public abstract class Area2DPtgBase
extends AreaPtgBase

Common superclass of 2-D area refs

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.ptg.AreaI
AreaI.OffsetArea
Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
protected | Area2DPtgBase(AreaReference ar)
protected | Area2DPtgBase(int firstRow, int lastRow, int firstColumn, int lastColumn, boolean firstRowRelative, boolean lastRowRelative, boolean firstColRelative, boolean lastColRelative)
protected | Area2DPtgBase(LittleEndianInput in)
Method Summary
protected abstract byte | getSid()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.AreaPtgBase
formatReferenceAsString, getDefaultOperandClass, getFirstColumn, getFirstColumnRaw, getFirstRow, getLastColumn, getLastColumnRaw, getLastRow, isFirstColRelative, isFirstRowRelative, isLastColRelative, isLastRowRelative, notImplemented, readCoordinates, setFirstColRelative, setFirstColumn, setFirstColumnRaw, setFirstRow, setFirstRowRelative, setLastColRelative, setLastColumn, setLastColumnRaw, setLastRow, setLastRowRelative, writeCoordinates
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Area2DPtgBase

protected Area2DPtgBase(int firstRow,
                        int lastRow,
                        int firstColumn,
                        int lastColumn,
                        boolean firstRowRelative,
                        boolean lastRowRelative,
                        boolean firstColRelative,
                        boolean lastColRelative)

Area2DPtgBase

protected Area2DPtgBase(AreaReference ar)

Area2DPtgBase

protected Area2DPtgBase(LittleEndianInput in)
Method Detail

getSid

protected abstract byte getSid()

write

public final void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public final int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public final java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Overrides:
toFormulaString in class AreaPtgBase

toString

public final java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Area3DPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class Area3DPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.AreaPtgBase
                extended by  org.apache.poi.ss.formula.ptg.Area3DPtg
All Implemented Interfaces:
java.lang.Cloneable, ExternSheetReferenceToken, AreaI, WorkbookDependentFormula
public final class Area3DPtg
extends AreaPtgBase
implements WorkbookDependentFormula, ExternSheetReferenceToken

Title: Area 3D Ptg - 3D reference (Sheet + Area)

Description: Defined a area in Extern Sheet.

REFERENCE:

Author:
Libin Roman (Vista Portal LDT. Developer), avik, Jason Height (jheight at chariot dot net dot au)

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.ptg.AreaI
AreaI.OffsetArea
Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
Area3DPtg(AreaReference arearef, int externIdx)
Area3DPtg(int firstRow, int lastRow, int firstColumn, int lastColumn, boolean firstRowRelative, boolean lastRowRelative, boolean firstColRelative, boolean lastColRelative, int externalSheetIndex)
Area3DPtg(LittleEndianInput in)
Area3DPtg(java.lang.String arearef, int externIdx)
Method Summary
java.lang.String | format2DRefAsString()
int | getExternSheetIndex()
int | getSize()
void | setExternSheetIndex(int index)
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.AreaPtgBase
formatReferenceAsString, getDefaultOperandClass, getFirstColumn, getFirstColumnRaw, getFirstRow, getLastColumn, getLastColumnRaw, getLastRow, isFirstColRelative, isFirstRowRelative, isLastColRelative, isLastRowRelative, notImplemented, readCoordinates, setFirstColRelative, setFirstColumn, setFirstColumnRaw, setFirstRow, setFirstRowRelative, setLastColRelative, setLastColumn, setLastColumnRaw, setLastRow, setLastRowRelative, writeCoordinates
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

Area3DPtg

public Area3DPtg(java.lang.String arearef,
                 int externIdx)

Area3DPtg

public Area3DPtg(LittleEndianInput in)

Area3DPtg

public Area3DPtg(int firstRow,
                 int lastRow,
                 int firstColumn,
                 int lastColumn,
                 boolean firstRowRelative,
                 boolean lastRowRelative,
                 boolean firstColRelative,
                 boolean lastColRelative,
                 int externalSheetIndex)

Area3DPtg

public Area3DPtg(AreaReference arearef,
                 int externIdx)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

getExternSheetIndex

public int getExternSheetIndex()
Specified by:
getExternSheetIndex in interface ExternSheetReferenceToken

setExternSheetIndex

public void setExternSheetIndex(int index)

format2DRefAsString

public java.lang.String format2DRefAsString()
Specified by:
format2DRefAsString in interface ExternSheetReferenceToken
Returns:
formula text for this reference token without the qualifying sheet name

toFormulaString

public java.lang.String toFormulaString(FormulaRenderingWorkbook book)
Specified by:
toFormulaString in interface WorkbookDependentFormula
Returns:
text representation of this area reference that can be used in text formulas. The sheet name will get properly delimited if required.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Overrides:
toFormulaString in class AreaPtgBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AreaErrPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AreaErrPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.AreaErrPtg
All Implemented Interfaces:
java.lang.Cloneable
public final class AreaErrPtg
extends OperandPtg

AreaErr - handles deleted cell area references.

Author:
Daniel Noll (daniel at nuix dot com dot au)

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
AreaErrPtg()
AreaErrPtg(LittleEndianInput in)
Method Summary
byte | getDefaultOperandClass()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

AreaErrPtg

public AreaErrPtg()

AreaErrPtg

public AreaErrPtg(LittleEndianInput in)
Method Detail

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AreaI

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Interface AreaI

All Known Implementing Classes:
Area2DPtgBase, Area3DPtg, AreaI.OffsetArea, AreaNPtg, AreaPtg, AreaPtgBase
public interface AreaI

Common interface for AreaPtg and Area3DPtg, and their child classes.

Nested Class Summary
static class AreaI.OffsetArea
Method Summary
int | getFirstColumn()
int | getFirstRow()
int | getLastColumn()
int | getLastRow()

Method Detail

getFirstRow

int getFirstRow()
Returns:
the first row in the area

getLastRow

int getLastRow()
Returns:
last row in the range (x2 in x1,y1-x2,y2)

getFirstColumn

int getFirstColumn()
Returns:
the first column number in the area.

getLastColumn

int getLastColumn()
Returns:
lastcolumn in the area
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AreaI.OffsetArea

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AreaI.OffsetArea

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.AreaI.OffsetArea
All Implemented Interfaces:
AreaI
Enclosing interface:
AreaI
public static class AreaI.OffsetArea
extends java.lang.Object
implements AreaI

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.ptg.AreaI
AreaI.OffsetArea
Constructor Summary
AreaI.OffsetArea(int baseRow, int baseColumn, int relFirstRowIx, int relLastRowIx, int relFirstColIx, int relLastColIx)
Method Summary
int | getFirstColumn()
int | getFirstRow()
int | getLastColumn()
int | getLastRow()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AreaI.OffsetArea

public AreaI.OffsetArea(int baseRow,
                        int baseColumn,
                        int relFirstRowIx,
                        int relLastRowIx,
                        int relFirstColIx,
                        int relLastColIx)
Method Detail

getFirstColumn

public int getFirstColumn()
Specified by:
getFirstColumn in interface AreaI
Returns:
the first column number in the area.

getFirstRow

public int getFirstRow()
Specified by:
getFirstRow in interface AreaI
Returns:
the first row in the area

getLastColumn

public int getLastColumn()
Specified by:
getLastColumn in interface AreaI
Returns:
lastcolumn in the area

getLastRow

public int getLastRow()
Specified by:
getLastRow in interface AreaI
Returns:
last row in the range (x2 in x1,y1-x2,y2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AreaNPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AreaNPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.AreaPtgBase
                extended by  org.apache.poi.ss.formula.ptg.Area2DPtgBase
                    extended by  org.apache.poi.ss.formula.ptg.AreaNPtg
All Implemented Interfaces:
java.lang.Cloneable, AreaI
public final class AreaNPtg
extends Area2DPtgBase

Specifies a rectangular area of cells A1:A4 for instance.

Author:
Jason Height (jheight at chariot dot net dot au)

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.ptg.AreaI
AreaI.OffsetArea
Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
AreaNPtg(LittleEndianInput in)
Method Summary
protected  byte getSid()
Methods inherited from class org.apache.poi.ss.formula.ptg.Area2DPtgBase
getSize, toFormulaString, toString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.AreaPtgBase
formatReferenceAsString, getDefaultOperandClass, getFirstColumn, getFirstColumnRaw, getFirstRow, getLastColumn, getLastColumnRaw, getLastRow, isFirstColRelative, isFirstRowRelative, isLastColRelative, isLastRowRelative, notImplemented, readCoordinates, setFirstColRelative, setFirstColumn, setFirstColumnRaw, setFirstRow, setFirstRowRelative, setLastColRelative, setLastColumn, setLastColumnRaw, setLastRow, setLastRowRelative, writeCoordinates
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

AreaNPtg

public AreaNPtg(LittleEndianInput in)
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class Area2DPtgBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AreaPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AreaPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.AreaPtgBase
                extended by  org.apache.poi.ss.formula.ptg.Area2DPtgBase
                    extended by  org.apache.poi.ss.formula.ptg.AreaPtg
All Implemented Interfaces:
java.lang.Cloneable, AreaI
public final class AreaPtg
extends Area2DPtgBase

Specifies a rectangular area of cells A1:A4 for instance.

Author:
Jason Height (jheight at chariot dot net dot au)

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.ptg.AreaI
AreaI.OffsetArea
Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
AreaPtg(AreaReference areaRef)
AreaPtg(int firstRow, int lastRow, int firstColumn, int lastColumn, boolean firstRowRelative, boolean lastRowRelative, boolean firstColRelative, boolean lastColRelative)
AreaPtg(LittleEndianInput in)
AreaPtg(java.lang.String arearef)
Method Summary
protected  byte getSid()
Methods inherited from class org.apache.poi.ss.formula.ptg.Area2DPtgBase
getSize, toFormulaString, toString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.AreaPtgBase
formatReferenceAsString, getDefaultOperandClass, getFirstColumn, getFirstColumnRaw, getFirstRow, getLastColumn, getLastColumnRaw, getLastRow, isFirstColRelative, isFirstRowRelative, isLastColRelative, isLastRowRelative, notImplemented, readCoordinates, setFirstColRelative, setFirstColumn, setFirstColumnRaw, setFirstRow, setFirstRowRelative, setLastColRelative, setLastColumn, setLastColumnRaw, setLastRow, setLastRowRelative, writeCoordinates
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

AreaPtg

public AreaPtg(int firstRow,
               int lastRow,
               int firstColumn,
               int lastColumn,
               boolean firstRowRelative,
               boolean lastRowRelative,
               boolean firstColRelative,
               boolean lastColRelative)

AreaPtg

public AreaPtg(LittleEndianInput in)

AreaPtg

public AreaPtg(java.lang.String arearef)

AreaPtg

public AreaPtg(AreaReference areaRef)
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class Area2DPtgBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AreaPtgBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AreaPtgBase

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.AreaPtgBase
All Implemented Interfaces:
java.lang.Cloneable, AreaI
Direct Known Subclasses:
Area2DPtgBase, Area3DPtg
public abstract class AreaPtgBase
extends OperandPtg
implements AreaI

Specifies a rectangular area of cells A1:A4 for instance.

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.ptg.AreaI
AreaI.OffsetArea
Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
protected | AreaPtgBase()
protected | AreaPtgBase(AreaReference ar)
protected | AreaPtgBase(int firstRow, int lastRow, int firstColumn, int lastColumn, boolean firstRowRelative, boolean lastRowRelative, boolean firstColRelative, boolean lastColRelative)
Method Summary
protected java.lang.String | formatReferenceAsString()
byte | getDefaultOperandClass()
int | getFirstColumn()
short | getFirstColumnRaw()
int | getFirstRow()
int | getLastColumn()
short | getLastColumnRaw()
int | getLastRow()
boolean | isFirstColRelative()
boolean | isFirstRowRelative()
boolean | isLastColRelative()
boolean | isLastRowRelative()
protected java.lang.RuntimeException | notImplemented() TODO - (May-2008) fix subclasses of AreaPtg 'AreaN~' which are used in shared formulas.
protected void | readCoordinates(LittleEndianInput in)
void | setFirstColRelative(boolean rel) set whether the first column is relative
void | setFirstColumn(int colIx) set the first column in the area
void | setFirstColumnRaw(int column) set the first column irrespective of the bitmasks
void | setFirstRow(int rowIx) sets the first row
void | setFirstRowRelative(boolean rel) sets the first row to relative or not
void | setLastColRelative(boolean rel) set whether the last column should be relative or not
void | setLastColumn(int colIx) set the last column in the area
void | setLastColumnRaw(short column) set the last column irrespective of the bitmasks
void | setLastRow(int rowIx)
void | setLastRowRelative(boolean rel) set whether the last row is relative or not
java.lang.String | toFormulaString() return a string representation of this token alone
protected void | writeCoordinates(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, getSize, readTokens, serializePtgs, setClass, toString, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AreaPtgBase

protected AreaPtgBase()

AreaPtgBase

protected AreaPtgBase(AreaReference ar)

AreaPtgBase

protected AreaPtgBase(int firstRow,
                      int lastRow,
                      int firstColumn,
                      int lastColumn,
                      boolean firstRowRelative,
                      boolean lastRowRelative,
                      boolean firstColRelative,
                      boolean lastColRelative)
Method Detail

notImplemented

protected final java.lang.RuntimeException notImplemented()
TODO - (May-2008) fix subclasses of AreaPtg 'AreaN~' which are used in shared formulas. see similar comment in ReferencePtg

readCoordinates

protected final void readCoordinates(LittleEndianInput in)

writeCoordinates

protected final void writeCoordinates(LittleEndianOutput out)

getFirstRow

public final int getFirstRow()
Specified by:
getFirstRow in interface AreaI
Returns:
the first row in the area

setFirstRow

public final void setFirstRow(int rowIx)
sets the first row

Parameters:
rowIx - number (0-based)

getLastRow

public final int getLastRow()
Specified by:
getLastRow in interface AreaI
Returns:
last row in the range (x2 in x1,y1-x2,y2)

setLastRow

public final void setLastRow(int rowIx)
Parameters:
rowIx - last row number in the area

getFirstColumn

public final int getFirstColumn()
Specified by:
getFirstColumn in interface AreaI
Returns:
the first column number in the area.

getFirstColumnRaw

public final short getFirstColumnRaw()
Returns:
the first column number + the options bit settings unstripped

isFirstRowRelative

public final boolean isFirstRowRelative()
Returns:
whether or not the first row is a relative reference or not.

setFirstRowRelative

public final void setFirstRowRelative(boolean rel)
sets the first row to relative or not

Parameters:
rel - is relative or not.

isFirstColRelative

public final boolean isFirstColRelative()
Returns:
isrelative first column to relative or not

setFirstColRelative

public final void setFirstColRelative(boolean rel)
set whether the first column is relative

setFirstColumn

public final void setFirstColumn(int colIx)
set the first column in the area

setFirstColumnRaw

public final void setFirstColumnRaw(int column)
set the first column irrespective of the bitmasks

getLastColumn

public final int getLastColumn()
Specified by:
getLastColumn in interface AreaI
Returns:
lastcolumn in the area

getLastColumnRaw

public final short getLastColumnRaw()
Returns:
last column and bitmask (the raw field)

isLastRowRelative

public final boolean isLastRowRelative()
Returns:
last row relative or not

setLastRowRelative

public final void setLastRowRelative(boolean rel)
set whether the last row is relative or not

Parameters:
rel - true if the last row relative, else false

isLastColRelative

public final boolean isLastColRelative()
Returns:
lastcol relative or not

setLastColRelative

public final void setLastColRelative(boolean rel)
set whether the last column should be relative or not

setLastColumn

public final void setLastColumn(int colIx)
set the last column in the area

setLastColumnRaw

public final void setLastColumnRaw(short column)
set the last column irrespective of the bitmasks

formatReferenceAsString

protected final java.lang.String formatReferenceAsString()

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArrayPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ArrayPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ArrayPtg

public final class ArrayPtg
extends Ptg

ArrayPtg - handles arrays The ArrayPtg is a little weird, the size of the Ptg when parsing initially only includes the Ptg sid and the reserved bytes. The next Ptg in the expression then follows. It is only after the "size" of all the Ptgs is met, that the ArrayPtg data is actually held after this. So Ptg.createParsedExpression keeps track of the number of ArrayPtg elements and need to parse the data upto the FORMULA record size.

Author:
Jason Height (jheight at chariot dot net dot au)

Field Summary
static int | PLAIN_TOKEN_SIZE The size of the plain tArray token written within the standard formula tokens (not including the data which comes after all formula tokens)
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
ArrayPtg(java.lang.Object[][] values2d)
Method Summary
int | getColumnCount()
byte | getDefaultOperandClass()
int | getRowCount()
int | getSize() This size includes the size of the array Ptg plus the Array Ptg Token value size
java.lang.Object[][] | getTokenArrayValues()
boolean | isBaseToken()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
int | writeTokenValueBytes(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

PLAIN_TOKEN_SIZE

public static final int PLAIN_TOKEN_SIZE
The size of the plain tArray token written within the standard formula tokens (not including the data which comes after all formula tokens)

See Also:
Constant Field Values
Constructor Detail

ArrayPtg

public ArrayPtg(java.lang.Object[][] values2d)
Parameters:
values2d - array values arranged in rows
Method Detail

getTokenArrayValues

public java.lang.Object[][] getTokenArrayValues()
Returns:
2-d array (inner index is rowIx, outer index is colIx)

isBaseToken

public boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

writeTokenValueBytes

public int writeTokenValueBytes(LittleEndianOutput out)

getRowCount

public int getRowCount()

getColumnCount

public int getColumnCount()

getSize

public int getSize()
This size includes the size of the array Ptg plus the Array Ptg Token value size

Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AttrPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AttrPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ControlPtg
            extended by  org.apache.poi.ss.formula.ptg.AttrPtg

public final class AttrPtg
extends ControlPtg

"Special Attributes" This seems to be a Misc Stuff and Junk record. One function it serves is in SUM functions (i.e. SUM(A1:A3) causes an area PTG then an ATTR with the SUM option set)

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Nested Class Summary
static class AttrPtg.SpaceType
Field Summary
static byte | sid
static AttrPtg | SUM
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
AttrPtg(LittleEndianInput in)
Method Summary
static AttrPtg | createIf(int dist)
static AttrPtg | createSkip(int dist)
static AttrPtg | createSpace(int type, int count)
int | getChooseFuncOffset()
short | getData()
int[] | getJumpTable()
int | getNumberOfOperands()
int | getSize()
static AttrPtg | getSumSingle()
int | getType()
boolean | isOptimizedChoose()
boolean | isOptimizedIf()
boolean | isSemiVolatile()
boolean | isSkip()
boolean | isSpace()
boolean | isSum()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(java.lang.String[] operands)
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ControlPtg
getDefaultOperandClass, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

SUM

public static final AttrPtg SUM
Constructor Detail

AttrPtg

public AttrPtg(LittleEndianInput in)
Method Detail

createSpace

public static AttrPtg createSpace(int type,
                                  int count)
Parameters:
type - a constant from SpaceType
count - the number of space characters

createIf

public static AttrPtg createIf(int dist)
Parameters:
dist - distance (in bytes) to start of either
  • false parameter
  • tFuncVar(IF) token (when false parameter is not present)

createSkip

public static AttrPtg createSkip(int dist)
Parameters:
dist - distance (in bytes) to position behind tFuncVar(IF) token (minus 1)

getSumSingle

public static AttrPtg getSumSingle()

isSemiVolatile

public boolean isSemiVolatile()

isOptimizedIf

public boolean isOptimizedIf()

isOptimizedChoose

public boolean isOptimizedChoose()

isSum

public boolean isSum()

isSkip

public boolean isSkip()

isSpace

public boolean isSpace()

getData

public short getData()

getJumpTable

public int[] getJumpTable()

getChooseFuncOffset

public int getChooseFuncOffset()

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)

getNumberOfOperands

public int getNumberOfOperands()

getType

public int getType()

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AttrPtg.SpaceType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class AttrPtg.SpaceType

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
Enclosing class:
AttrPtg
public static final class AttrPtg.SpaceType
extends java.lang.Object

Field Summary
static int | CR_BEFORE 01H = Carriage returns before the next token (not allowed before tParen token)
static int | CR_BEFORE_CLOSE_PAREN 05H = Carriage returns before closing parenthesis (only allowed before tParen, tFunc, and tFuncVar tokens)
static int | CR_BEFORE_OPEN_PAREN 03H = Carriage returns before opening parenthesis (only allowed before tParen token)
static int | SPACE_AFTER_EQUALITY 06H = Spaces following the equality sign (only in macro sheets)
static int | SPACE_BEFORE 00H = Spaces before the next token (not allowed before tParen token)
static int | SPACE_BEFORE_CLOSE_PAREN 04H = Spaces before closing parenthesis (only allowed before tParen, tFunc, and tFuncVar tokens)
static int | SPACE_BEFORE_OPEN_PAREN 02H = Spaces before opening parenthesis (only allowed before tParen token)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SPACE_BEFORE

public static final int SPACE_BEFORE
00H = Spaces before the next token (not allowed before tParen token)

See Also:
Constant Field Values

CR_BEFORE

public static final int CR_BEFORE
01H = Carriage returns before the next token (not allowed before tParen token)

See Also:
Constant Field Values

SPACE_BEFORE_OPEN_PAREN

public static final int SPACE_BEFORE_OPEN_PAREN
02H = Spaces before opening parenthesis (only allowed before tParen token)

See Also:
Constant Field Values

CR_BEFORE_OPEN_PAREN

public static final int CR_BEFORE_OPEN_PAREN
03H = Carriage returns before opening parenthesis (only allowed before tParen token)

See Also:
Constant Field Values

SPACE_BEFORE_CLOSE_PAREN

public static final int SPACE_BEFORE_CLOSE_PAREN
04H = Spaces before closing parenthesis (only allowed before tParen, tFunc, and tFuncVar tokens)

See Also:
Constant Field Values

CR_BEFORE_CLOSE_PAREN

public static final int CR_BEFORE_CLOSE_PAREN
05H = Carriage returns before closing parenthesis (only allowed before tParen, tFunc, and tFuncVar tokens)

See Also:
Constant Field Values

SPACE_AFTER_EQUALITY

public static final int SPACE_AFTER_EQUALITY
06H = Spaces following the equality sign (only in macro sheets)

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BoolPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class BoolPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ScalarConstantPtg
            extended by  org.apache.poi.ss.formula.ptg.BoolPtg

public final class BoolPtg
extends ScalarConstantPtg

Boolean (boolean) Stores a (java) boolean value in a formula.

Author:
Paul Krause (pkrause at soundbite dot com), Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte | sid
static int | SIZE
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getSize()
boolean | getValue()
static BoolPtg | read(LittleEndianInput in)
java.lang.String | toFormulaString() return a string representation of this token alone
static BoolPtg | valueOf(boolean b)
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ScalarConstantPtg
getDefaultOperandClass, isBaseToken, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values

sid

public static final byte sid
See Also:
Constant Field Values
Method Detail

valueOf

public static BoolPtg valueOf(boolean b)

read

public static BoolPtg read(LittleEndianInput in)

getValue

public boolean getValue()

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConcatPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ConcatPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.ConcatPtg

public final class ConcatPtg
extends ValueOperatorPtg

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ControlPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ControlPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ControlPtg
Direct Known Subclasses:
AttrPtg, ExpPtg, ParenthesisPtg, TblPtg
public abstract class ControlPtg
extends Ptg

Common superclass for tExp tTbl tParen tNlr tAttr tSheet tEndSheet

Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
ControlPtg()
Method Summary
byte | getDefaultOperandClass()
boolean | isBaseToken()
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, getSize, readTokens, serializePtgs, setClass, toFormulaString, toString, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ControlPtg

public ControlPtg()
Method Detail

isBaseToken

public boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

getDefaultOperandClass

public final byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DeletedArea3DPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class DeletedArea3DPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.DeletedArea3DPtg
All Implemented Interfaces:
java.lang.Cloneable, WorkbookDependentFormula
public final class DeletedArea3DPtg
extends OperandPtg
implements WorkbookDependentFormula

Title: Deleted Area 3D Ptg - 3D referecnce (Sheet + Area)

Description: Defined a area in Extern Sheet.

REFERENCE:

Version:
1.0-pre
Author:
Patrick Luby

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
DeletedArea3DPtg(int externSheetIndex)
DeletedArea3DPtg(LittleEndianInput in)
Method Summary
byte | getDefaultOperandClass()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(FormulaRenderingWorkbook book)
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

DeletedArea3DPtg

public DeletedArea3DPtg(int externSheetIndex)

DeletedArea3DPtg

public DeletedArea3DPtg(LittleEndianInput in)
Method Detail

toFormulaString

public java.lang.String toFormulaString(FormulaRenderingWorkbook book)
Specified by:
toFormulaString in interface WorkbookDependentFormula

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DeletedRef3DPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class DeletedRef3DPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.DeletedRef3DPtg
All Implemented Interfaces:
java.lang.Cloneable, WorkbookDependentFormula
public final class DeletedRef3DPtg
extends OperandPtg
implements WorkbookDependentFormula

Title: Deleted Reference 3D Ptg

Description: Defined a cell in extern sheet.

REFERENCE:

Version:
1.0-pre
Author:
Patrick Luby

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
DeletedRef3DPtg(int externSheetIndex)
DeletedRef3DPtg(LittleEndianInput in)
Creates new DeletedRef3DPtg
Method Summary
byte | getDefaultOperandClass()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(FormulaRenderingWorkbook book)
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

DeletedRef3DPtg

public DeletedRef3DPtg(LittleEndianInput in)
Creates new DeletedRef3DPtg

DeletedRef3DPtg

public DeletedRef3DPtg(int externSheetIndex)
Method Detail

toFormulaString

public java.lang.String toFormulaString(FormulaRenderingWorkbook book)
Specified by:
toFormulaString in interface WorkbookDependentFormula

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DividePtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class DividePtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.DividePtg

public final class DividePtg
extends ValueOperatorPtg

This PTG implements the standard binomial divide "/"

Author:
Andrew C. Oliver acoliver at apache dot org, Jason Height (jheight at chariot dot net dot au)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EqualPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class EqualPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.EqualPtg

public final class EqualPtg
extends ValueOperatorPtg

Author:
andy

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ErrPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ErrPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ScalarConstantPtg
            extended by  org.apache.poi.ss.formula.ptg.ErrPtg

public final class ErrPtg
extends ScalarConstantPtg

Author:
Daniel Noll (daniel at nuix dot com dot au)

Field Summary
static ErrPtg | DIV_ZERO #DIV/0! - Division by zero
static ErrPtg | N_A #N/A - Argument or function not available
static ErrPtg | NAME_INVALID #NAME? - Wrong function or range name
static ErrPtg | NULL_INTERSECTION #NULL! - Intersection of two cell ranges is empty
static ErrPtg | NUM_ERROR #NUM! - Value range overflow
static ErrPtg | REF_INVALID #REF! - Illegal or deleted cell reference
static short | sid
static ErrPtg | VALUE_INVALID #VALUE! - Wrong type of operand
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getErrorCode()
int | getSize()
static ErrPtg | read(LittleEndianInput in)
java.lang.String | toFormulaString() return a string representation of this token alone
static ErrPtg | valueOf(int code)
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ScalarConstantPtg
getDefaultOperandClass, isBaseToken, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NULL_INTERSECTION

public static final ErrPtg NULL_INTERSECTION
#NULL! - Intersection of two cell ranges is empty

DIV_ZERO

public static final ErrPtg DIV_ZERO
#DIV/0! - Division by zero

VALUE_INVALID

public static final ErrPtg VALUE_INVALID
#VALUE! - Wrong type of operand

REF_INVALID

public static final ErrPtg REF_INVALID
#REF! - Illegal or deleted cell reference

NAME_INVALID

public static final ErrPtg NAME_INVALID
#NAME? - Wrong function or range name

NUM_ERROR

public static final ErrPtg NUM_ERROR
#NUM! - Value range overflow

N_A

public static final ErrPtg N_A
#N/A - Argument or function not available

sid

public static final short sid
See Also:
Constant Field Values
Method Detail

read

public static ErrPtg read(LittleEndianInput in)

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

getErrorCode

public int getErrorCode()

valueOf

public static ErrPtg valueOf(int code)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ExpPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ControlPtg
            extended by  org.apache.poi.ss.formula.ptg.ExpPtg

public final class ExpPtg
extends ControlPtg

Author:
andy, Jason Height (jheight at chariot dot net dot au), dmui (save existing implementation)

Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
ExpPtg(int firstRow, int firstCol)
ExpPtg(LittleEndianInput in)
Method Summary
int | getColumn()
int | getRow()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ControlPtg
getDefaultOperandClass, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

ExpPtg

public ExpPtg(LittleEndianInput in)

ExpPtg

public ExpPtg(int firstRow,
              int firstCol)
Method Detail

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

getRow

public int getRow()

getColumn

public int getColumn()

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FuncPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class FuncPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
                extended by  org.apache.poi.ss.formula.ptg.FuncPtg

public final class FuncPtg
extends AbstractFunctionPtg

Author:
aviks, Jason Height (jheight at chariot dot net dot au), Danny Mui (dmui at apache dot org) (Leftover handling)

Field Summary
static byte | sid
static int | SIZE
Fields inherited from class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
FUNCTION_NAME_IF
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
static FuncPtg | create(int functionIndex)
static FuncPtg | create(LittleEndianInput in)
int | getSize()
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
getDefaultOperandClass, getFunctionIndex, getName, getNumberOfOperands, getParameterClass, isBaseToken, isBuiltInFunctionName, isExternalFunction, lookupIndex, lookupName, toFormulaString, toFormulaString, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

SIZE

public static final int SIZE
See Also:
Constant Field Values
Method Detail

create

public static FuncPtg create(LittleEndianInput in)

create

public static FuncPtg create(int functionIndex)

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class AbstractFunctionPtg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FuncVarPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class FuncVarPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
                extended by  org.apache.poi.ss.formula.ptg.FuncVarPtg

public final class FuncVarPtg
extends AbstractFunctionPtg

Author:
Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte | sid
static OperationPtg | SUM Single instance of this token for 'sum() taking a single argument'
Fields inherited from class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
FUNCTION_NAME_IF
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
static FuncVarPtg | create(LittleEndianInput in) Creates new function pointer from a byte array usually called while reading an excel file.
static FuncVarPtg | create(java.lang.String pName, int numArgs) Create a function ptg from a string tokenised by the parser
int | getSize()
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
getDefaultOperandClass, getFunctionIndex, getName, getNumberOfOperands, getParameterClass, isBaseToken, isBuiltInFunctionName, isExternalFunction, lookupIndex, lookupName, toFormulaString, toFormulaString, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

SUM

public static final OperationPtg SUM
Single instance of this token for 'sum() taking a single argument'

Method Detail

create

public static FuncVarPtg create(LittleEndianInput in)
Creates new function pointer from a byte array usually called while reading an excel file.

create

public static FuncVarPtg create(java.lang.String pName,
                                int numArgs)
Create a function ptg from a string tokenised by the parser

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class AbstractFunctionPtg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GreaterEqualPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class GreaterEqualPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.GreaterEqualPtg

public final class GreaterEqualPtg
extends ValueOperatorPtg

PTG class to implement greater or equal to

Author:
fred at stsci dot edu

Field Summary
static ValueOperatorPtg | instance
static byte | sid
static int | SIZE
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GreaterThanPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class GreaterThanPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.GreaterThanPtg

public final class GreaterThanPtg
extends ValueOperatorPtg

Greater than operator PTG ">"

Author:
Cameron Riley (criley at ekmail.com)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() Get the number of operands for the Less than operator
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) Implementation of method from OperationsPtg
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Get the number of operands for the Less than operator

Specified by:
getNumberOfOperands in class OperationPtg
Returns:
int the number of operands

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Implementation of method from OperationsPtg

Specified by:
toFormulaString in class OperationPtg
Parameters:
operands - a String array of operands
Returns:
String the Formula as a String
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntersectionPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class IntersectionPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.IntersectionPtg

public final class IntersectionPtg
extends OperationPtg

Author:
Daniel Noll (daniel at nuix dot com dot au)

Field Summary
static OperationPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
int | getSize()
boolean | isBaseToken()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
getDefaultOperandClass
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final OperationPtg instance
Method Detail

isBaseToken

public final boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class IntPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ScalarConstantPtg
            extended by  org.apache.poi.ss.formula.ptg.IntPtg

public final class IntPtg
extends ScalarConstantPtg

Integer (unsigned short integer) Stores an unsigned short value (java int) in a formula

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte | sid
static int | SIZE
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
IntPtg(int value)
IntPtg(LittleEndianInput in)
Method Summary
int | getSize()
int | getValue()
static boolean | isInRange(int i) Excel represents integers 0..65535 with the tInt token.
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ScalarConstantPtg
getDefaultOperandClass, isBaseToken, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

IntPtg

public IntPtg(LittleEndianInput in)

IntPtg

public IntPtg(int value)
Method Detail

isInRange

public static boolean isInRange(int i)
Excel represents integers 0..65535 with the tInt token.

Returns:
true if the specified value is within the range of values IntPtg can represent.

getValue

public int getValue()

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LessEqualPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class LessEqualPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.LessEqualPtg

public final class LessEqualPtg
extends ValueOperatorPtg

Ptg class to implement less than or equal

Author:
fred at stsci dot edu

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LessThanPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class LessThanPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.LessThanPtg

public final class LessThanPtg
extends ValueOperatorPtg

Less than operator PTG "<". The SID is taken from the Openoffice.orgs Documentation of the Excel File Format, Table 3.5.7

Author:
Cameron Riley (criley at ekmail.com)

Field Summary
static ValueOperatorPtg | instance
static byte | sid the sid for the less than operator as hex
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() Get the number of operands for the Less than operator
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) Implementation of method from OperationsPtg
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
the sid for the less than operator as hex

See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Get the number of operands for the Less than operator

Specified by:
getNumberOfOperands in class OperationPtg
Returns:
int the number of operands

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Implementation of method from OperationsPtg

Specified by:
toFormulaString in class OperationPtg
Parameters:
operands - a String array of operands
Returns:
String the Formula as a String
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MemAreaPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class MemAreaPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.MemAreaPtg
All Implemented Interfaces:
java.lang.Cloneable
public final class MemAreaPtg
extends OperandPtg

Author:
Daniel Noll (daniel at nuix dot com dot au)

Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
MemAreaPtg(int subexLen)
Creates new MemAreaPtg
MemAreaPtg(LittleEndianInput in)
Method Summary
byte | getDefaultOperandClass()
int | getLenRefSubexpression()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

MemAreaPtg

public MemAreaPtg(int subexLen)
Creates new MemAreaPtg

MemAreaPtg

public MemAreaPtg(LittleEndianInput in)
Method Detail

getLenRefSubexpression

public int getLenRefSubexpression()

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg

toString

public final java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MemErrPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class MemErrPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.MemErrPtg
All Implemented Interfaces:
java.lang.Cloneable
public final class MemErrPtg
extends OperandPtg

Author:
andy, Jason Height (jheight at chariot dot net dot au), Daniel Noll (daniel at nuix dot com dot au)

Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
MemErrPtg(LittleEndianInput in)
Method Summary
byte | getDefaultOperandClass()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

MemErrPtg

public MemErrPtg(LittleEndianInput in)
Method Detail

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MemFuncPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class MemFuncPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.MemFuncPtg
All Implemented Interfaces:
java.lang.Cloneable
public final class MemFuncPtg
extends OperandPtg

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
MemFuncPtg(int subExprLen)
MemFuncPtg(LittleEndianInput in)
Creates new function pointer from a byte array usually called while reading an excel file.
Method Summary
byte | getDefaultOperandClass()
int | getLenRefSubexpression()
int | getNumberOfOperands()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

MemFuncPtg

public MemFuncPtg(LittleEndianInput in)
Creates new function pointer from a byte array usually called while reading an excel file.

MemFuncPtg

public MemFuncPtg(int subExprLen)
Method Detail

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg

getNumberOfOperands

public int getNumberOfOperands()

getLenRefSubexpression

public int getLenRefSubexpression()

toString

public final java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MissingArgPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class MissingArgPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ScalarConstantPtg
            extended by  org.apache.poi.ss.formula.ptg.MissingArgPtg

public final class MissingArgPtg
extends ScalarConstantPtg

Missing Function Arguments Avik Sengupta <avik at apache.org>

Author:
Jason Height (jheight at chariot dot net dot au)

Field Summary
static Ptg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ScalarConstantPtg
getDefaultOperandClass, isBaseToken, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final Ptg instance
Method Detail

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultiplyPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class MultiplyPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.MultiplyPtg

public final class MultiplyPtg
extends ValueOperatorPtg

Implements the standard mathmatical multiplication - *

Author:
Andrew C. Oliver (acoliver at apache dot org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamePtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class NamePtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.NamePtg
All Implemented Interfaces:
java.lang.Cloneable, WorkbookDependentFormula
public final class NamePtg
extends OperandPtg
implements WorkbookDependentFormula

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
NamePtg(int nameIndex)
NamePtg(LittleEndianInput in)
Creates new NamePtg
Method Summary
byte | getDefaultOperandClass()
int | getIndex()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(FormulaRenderingWorkbook book)
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

NamePtg

public NamePtg(int nameIndex)
Parameters:
nameIndex - zero-based index to name within workbook

NamePtg

public NamePtg(LittleEndianInput in)
Creates new NamePtg

Method Detail

getIndex

public int getIndex()
Returns:
zero based index to a defined name record in the LinkTable

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString(FormulaRenderingWorkbook book)
Specified by:
toFormulaString in interface WorkbookDependentFormula

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NameXPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class NameXPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.NameXPtg
All Implemented Interfaces:
java.lang.Cloneable, WorkbookDependentFormula
public final class NameXPtg
extends OperandPtg
implements WorkbookDependentFormula

Author:
aviks

Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
NameXPtg(int sheetRefIndex, int nameIndex)
NameXPtg(LittleEndianInput in)
Method Summary
byte | getDefaultOperandClass()
int | getNameIndex()
int | getSheetRefIndex()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

NameXPtg

public NameXPtg(int sheetRefIndex,
                int nameIndex)
Parameters:
sheetRefIndex - index to REF entry in externsheet record
nameIndex - index to defined name or externname table

NameXPtg

public NameXPtg(LittleEndianInput in)
Method Detail

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString(FormulaRenderingWorkbook book)
Specified by:
toFormulaString in interface WorkbookDependentFormula

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg

getSheetRefIndex

public int getSheetRefIndex()

getNameIndex

public int getNameIndex()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotEqualPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class NotEqualPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.NotEqualPtg

public final class NotEqualPtg
extends ValueOperatorPtg

Ptg class to implement not equal

Author:
fred at stsci dot edu

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumberPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class NumberPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ScalarConstantPtg
            extended by  org.apache.poi.ss.formula.ptg.NumberPtg

public final class NumberPtg
extends ScalarConstantPtg

Number Stores a floating point value in a formula value stored in a 8 byte field using IEEE notation

Author:
Avik Sengupta, Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte | sid
static int | SIZE
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
NumberPtg(double value)
NumberPtg(LittleEndianInput in)
NumberPtg(java.lang.String value)
Create a NumberPtg from a string representation of the number Number format is not checked, it is expected to be validated in the parser that calls this method.
Method Summary
int | getSize()
double | getValue()
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ScalarConstantPtg
getDefaultOperandClass, isBaseToken, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

NumberPtg

public NumberPtg(LittleEndianInput in)

NumberPtg

public NumberPtg(java.lang.String value)
Create a NumberPtg from a string representation of the number Number format is not checked, it is expected to be validated in the parser that calls this method.

Parameters:
value - String representation of a floating point number

NumberPtg

public NumberPtg(double value)
Method Detail

getValue

public double getValue()

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperandPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class OperandPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
All Implemented Interfaces:
java.lang.Cloneable
Direct Known Subclasses:
AreaErrPtg, AreaPtgBase, DeletedArea3DPtg, DeletedRef3DPtg, MemAreaPtg, MemErrPtg, MemFuncPtg, NamePtg, NameXPtg, RefErrorPtg, RefPtgBase
public abstract class OperandPtg
extends Ptg
implements java.lang.Cloneable

Author:
Josh Micich

Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
OperandPtg()
Method Summary
OperandPtg | copy()
boolean | isBaseToken() All Operand Ptgs are classified ('relative', 'value', 'array')
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getDefaultOperandClass, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, getSize, readTokens, serializePtgs, setClass, toFormulaString, toString, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OperandPtg

public OperandPtg()
Method Detail

isBaseToken

public final boolean isBaseToken()
All Operand Ptgs are classified ('relative', 'value', 'array')

Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

copy

public final OperandPtg copy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperationPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class OperationPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
Direct Known Subclasses:
AbstractFunctionPtg, IntersectionPtg, RangePtg, UnionPtg, ValueOperatorPtg
public abstract class OperationPtg
extends Ptg

defines a Ptg that is an operation instead of an operand

Author:
andy

Field Summary
static int | TYPE_BINARY
static int | TYPE_FUNCTION
static int | TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
OperationPtg()
Method Summary
byte | getDefaultOperandClass()
abstract int | getNumberOfOperands() The number of operands expected by the operations
abstract java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, getSize, isBaseToken, readTokens, serializePtgs, setClass, toFormulaString, toString, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

TYPE_UNARY

public static final int TYPE_UNARY
See Also:
Constant Field Values

TYPE_BINARY

public static final int TYPE_BINARY
See Also:
Constant Field Values

TYPE_FUNCTION

public static final int TYPE_FUNCTION
See Also:
Constant Field Values
Constructor Detail

OperationPtg

public OperationPtg()
Method Detail

toFormulaString

public abstract java.lang.String toFormulaString(java.lang.String[] operands)
returns a string representation of the operations the length of the input array should equal the number returned by

See Also:
getNumberOfOperands()

getNumberOfOperands

public abstract int getNumberOfOperands()
The number of operands expected by the operations

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.ptg
Interfaces
AreaI
Classes
AbstractFunctionPtg
AddPtg
Area2DPtgBase
Area3DPtg
AreaErrPtg
AreaI.OffsetArea
AreaNPtg
AreaPtg
AreaPtgBase
ArrayPtg
AttrPtg
AttrPtg.SpaceType
BoolPtg
ConcatPtg
ControlPtg
DeletedArea3DPtg
DeletedRef3DPtg
DividePtg
EqualPtg
ErrPtg
ExpPtg
FuncPtg
FuncVarPtg
GreaterEqualPtg
GreaterThanPtg
IntersectionPtg
IntPtg
LessEqualPtg
LessThanPtg
MemAreaPtg
MemErrPtg
MemFuncPtg
MissingArgPtg
MultiplyPtg
NamePtg
NameXPtg
NotEqualPtg
NumberPtg
OperandPtg
OperationPtg
ParenthesisPtg
PercentPtg
PowerPtg
Ptg
RangePtg
Ref3DPtg
RefErrorPtg
RefNPtg
RefPtg
RefPtgBase
ScalarConstantPtg
StringPtg
SubtractPtg
TblPtg
UnaryMinusPtg
UnaryPlusPtg
UnionPtg
UnknownPtg
ValueOperatorPtg


org.apache.poi.ss.formula.ptg

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.ptg

formula package contains binary PTG structures used in Formulas

See:
Description

Interface Summary
AreaI Common interface for AreaPtg and Area3DPtg, and their child classes.

Class Summary
AbstractFunctionPtg | This class provides the base functionality for Excel sheet functions There are two kinds of function Ptgs - tFunc and tFuncVar Therefore, this class will have ONLY two subclasses
AddPtg | Addition operator PTG the "+" binomial operator.
Area2DPtgBase | Common superclass of 2-D area refs
Area3DPtg | Title: Area 3D Ptg - 3D reference (Sheet + Area)
AreaErrPtg | AreaErr - handles deleted cell area references.
AreaI.OffsetArea |
AreaNPtg | Specifies a rectangular area of cells A1:A4 for instance.
AreaPtg | Specifies a rectangular area of cells A1:A4 for instance.
AreaPtgBase | Specifies a rectangular area of cells A1:A4 for instance.
ArrayPtg | ArrayPtg - handles arrays The ArrayPtg is a little weird, the size of the Ptg when parsing initially only includes the Ptg sid and the reserved bytes.
AttrPtg | "Special Attributes" This seems to be a Misc Stuff and Junk record.
AttrPtg.SpaceType |
BoolPtg | Boolean (boolean) Stores a (java) boolean value in a formula.
ConcatPtg |
ControlPtg | Common superclass for tExp tTbl tParen tNlr tAttr tSheet tEndSheet
DeletedArea3DPtg | Title: Deleted Area 3D Ptg - 3D referecnce (Sheet + Area)
DeletedRef3DPtg | Title: Deleted Reference 3D Ptg
DividePtg | This PTG implements the standard binomial divide "/"
EqualPtg |
ErrPtg |
ExpPtg |
FuncPtg |
FuncVarPtg |
GreaterEqualPtg | PTG class to implement greater or equal to
GreaterThanPtg | Greater than operator PTG ">"
IntersectionPtg |
IntPtg | Integer (unsigned short integer) Stores an unsigned short value (java int) in a formula
LessEqualPtg | Ptg class to implement less than or equal
LessThanPtg | Less than operator PTG "<".
MemAreaPtg |
MemErrPtg |
MemFuncPtg |
MissingArgPtg | Missing Function Arguments Avik Sengupta <avik at apache.org>
MultiplyPtg | Implements the standard mathmatical multiplication - *
NamePtg |
NameXPtg |
NotEqualPtg | Ptg class to implement not equal
NumberPtg | Number Stores a floating point value in a formula value stored in a 8 byte field using IEEE notation
OperandPtg |
OperationPtg | defines a Ptg that is an operation instead of an operand
ParenthesisPtg | While formula tokens are stored in RPN order and thus do not need parenthesis for precedence reasons, Parenthesis tokens ARE written to ensure that user entered parenthesis are displayed as-is on reading back Avik Sengupta <lists@aviksengupta.com> Andrew C.
PercentPtg | Percent PTG.
PowerPtg |
Ptg | Ptg represents a syntactic token in a formula.
RangePtg |
Ref3DPtg | Title: Reference 3D Ptg
RefErrorPtg | RefError - handles deleted cell reference
RefNPtg | RefNPtg
RefPtg | ReferencePtg - handles references (such as A1, A2, IA4)
RefPtgBase | ReferencePtgBase - handles references (such as A1, A2, IA4)
ScalarConstantPtg | Common superclass of all Ptgs that represent simple constant values.
StringPtg | String Stores a String value in a formula value stored in the format <length 2 bytes>char[]
SubtractPtg |
TblPtg | This ptg indicates a data table.
UnaryMinusPtg | Unary Plus operator does not have any effect on the operand
UnaryPlusPtg | Unary Plus operator does not have any effect on the operand
UnionPtg |
UnknownPtg |
ValueOperatorPtg | Common superclass of all value operators.

Package org.apache.poi.ss.formula.ptg Description

formula package contains binary PTG structures used in Formulas

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project

See Also:
org.apache.poi.hssf.record, FormulaRecord


org.apache.poi.ss.formula.ptg Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.ptg

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.ptg.AreaI.OffsetArea (implements org.apache.poi.ss.formula.ptg.AreaI)
    • org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType
    • org.apache.poi.ss.formula.ptg.Ptg
      • org.apache.poi.ss.formula.ptg.ArrayPtg
      • org.apache.poi.ss.formula.ptg.ControlPtg
        • org.apache.poi.ss.formula.ptg.AttrPtg
        • org.apache.poi.ss.formula.ptg.ExpPtg
        • org.apache.poi.ss.formula.ptg.ParenthesisPtg
        • org.apache.poi.ss.formula.ptg.TblPtg
      • org.apache.poi.ss.formula.ptg.OperandPtg (implements java.lang.Cloneable)
        • org.apache.poi.ss.formula.ptg.AreaErrPtg
        • org.apache.poi.ss.formula.ptg.AreaPtgBase (implements org.apache.poi.ss.formula.ptg.AreaI)
          • org.apache.poi.ss.formula.ptg.Area2DPtgBase
            • org.apache.poi.ss.formula.ptg.AreaNPtg
            • org.apache.poi.ss.formula.ptg.AreaPtg
          • org.apache.poi.ss.formula.ptg.Area3DPtg (implements org.apache.poi.ss.formula.ExternSheetReferenceToken, org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.DeletedArea3DPtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.DeletedRef3DPtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.MemAreaPtg
        • org.apache.poi.ss.formula.ptg.MemErrPtg
        • org.apache.poi.ss.formula.ptg.MemFuncPtg
        • org.apache.poi.ss.formula.ptg.NamePtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.NameXPtg (implements org.apache.poi.ss.formula.WorkbookDependentFormula)
        • org.apache.poi.ss.formula.ptg.RefErrorPtg
        • org.apache.poi.ss.formula.ptg.RefPtgBase
          • org.apache.poi.ss.formula.ptg.Ref3DPtg (implements org.apache.poi.ss.formula.ExternSheetReferenceToken, org.apache.poi.ss.formula.WorkbookDependentFormula)
          • org.apache.poi.ss.formula.ptg.RefNPtg
          • org.apache.poi.ss.formula.ptg.RefPtg
      • org.apache.poi.ss.formula.ptg.OperationPtg
        • org.apache.poi.ss.formula.ptg.AbstractFunctionPtg
          • org.apache.poi.ss.formula.ptg.FuncPtg
          • org.apache.poi.ss.formula.ptg.FuncVarPtg
        • org.apache.poi.ss.formula.ptg.IntersectionPtg
        • org.apache.poi.ss.formula.ptg.RangePtg
        • org.apache.poi.ss.formula.ptg.UnionPtg
        • org.apache.poi.ss.formula.ptg.ValueOperatorPtg
          • org.apache.poi.ss.formula.ptg.AddPtg
          • org.apache.poi.ss.formula.ptg.ConcatPtg
          • org.apache.poi.ss.formula.ptg.DividePtg
          • org.apache.poi.ss.formula.ptg.EqualPtg
          • org.apache.poi.ss.formula.ptg.GreaterEqualPtg
          • org.apache.poi.ss.formula.ptg.GreaterThanPtg
          • org.apache.poi.ss.formula.ptg.LessEqualPtg
          • org.apache.poi.ss.formula.ptg.LessThanPtg
          • org.apache.poi.ss.formula.ptg.MultiplyPtg
          • org.apache.poi.ss.formula.ptg.NotEqualPtg
          • org.apache.poi.ss.formula.ptg.PercentPtg
          • org.apache.poi.ss.formula.ptg.PowerPtg
          • org.apache.poi.ss.formula.ptg.SubtractPtg
          • org.apache.poi.ss.formula.ptg.UnaryMinusPtg
          • org.apache.poi.ss.formula.ptg.UnaryPlusPtg
      • org.apache.poi.ss.formula.ptg.ScalarConstantPtg
        • org.apache.poi.ss.formula.ptg.BoolPtg
        • org.apache.poi.ss.formula.ptg.ErrPtg
        • org.apache.poi.ss.formula.ptg.IntPtg
        • org.apache.poi.ss.formula.ptg.MissingArgPtg
        • org.apache.poi.ss.formula.ptg.NumberPtg
        • org.apache.poi.ss.formula.ptg.StringPtg
      • org.apache.poi.ss.formula.ptg.UnknownPtg

Interface Hierarchy

  • org.apache.poi.ss.formula.ptg.AreaI


Uses of Package org.apache.poi.ss.formula.ptg

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.ptg

Packages that use org.apache.poi.ss.formula.ptg
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.xssf.usermodel |

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.hssf.model
NameXPtg
Ptg
Ptg represents a syntactic token in a formula.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.hssf.record
Ptg
Ptg represents a syntactic token in a formula.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.hssf.record.aggregates
Ptg
Ptg represents a syntactic token in a formula.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.hssf.record.chart
Ptg
Ptg represents a syntactic token in a formula.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.hssf.usermodel
NamePtg
NameXPtg
Ptg
Ptg represents a syntactic token in a formula.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.ss.formula
NamePtg
NameXPtg
Ptg
Ptg represents a syntactic token in a formula.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.ss.formula.eval
AreaI
Common interface for AreaPtg and Area3DPtg, and their child classes.
NameXPtg
Ptg
Ptg represents a syntactic token in a formula.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.ss.formula.ptg
AbstractFunctionPtg
This class provides the base functionality for Excel sheet functions There are two kinds of function Ptgs - tFunc and tFuncVar Therefore, this class will have ONLY two subclasses
Area2DPtgBase
Common superclass of 2-D area refs
AreaI
Common interface for AreaPtg and Area3DPtg, and their child classes.
AreaPtgBase
Specifies a rectangular area of cells A1:A4 for instance.
AttrPtg
"Special Attributes" This seems to be a Misc Stuff and Junk record.
BoolPtg
Boolean (boolean) Stores a (java) boolean value in a formula.
ControlPtg
Common superclass for tExp tTbl tParen tNlr tAttr tSheet tEndSheet
ErrPtg
FuncPtg
FuncVarPtg
OperandPtg
OperationPtg
defines a Ptg that is an operation instead of an operand
Ptg
Ptg represents a syntactic token in a formula.
RefPtgBase
ReferencePtgBase - handles references (such as A1, A2, IA4)
ScalarConstantPtg
Common superclass of all Ptgs that represent simple constant values.
ValueOperatorPtg
Common superclass of all value operators.

Classes in org.apache.poi.ss.formula.ptg used by org.apache.poi.xssf.usermodel
NamePtg
NameXPtg
Ptg
Ptg represents a syntactic token in a formula.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ParenthesisPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ParenthesisPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ControlPtg
            extended by  org.apache.poi.ss.formula.ptg.ParenthesisPtg

public final class ParenthesisPtg
extends ControlPtg

While formula tokens are stored in RPN order and thus do not need parenthesis for precedence reasons, Parenthesis tokens ARE written to ensure that user entered parenthesis are displayed as-is on reading back Avik Sengupta <lists@aviksengupta.com> Andrew C. Oliver (acoliver at apache dot org)

Author:
Jason Height (jheight at chariot dot net dot au)

Field Summary
static ControlPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(java.lang.String[] operands)
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ControlPtg
getDefaultOperandClass, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ControlPtg instance
Method Detail

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PercentPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class PercentPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.PercentPtg

public final class PercentPtg
extends ValueOperatorPtg

Percent PTG.

Author:
Daniel Noll (daniel at nuix.com.au)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
static int | SIZE
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PowerPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class PowerPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.PowerPtg

public final class PowerPtg
extends ValueOperatorPtg

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Ptg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class Ptg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
Direct Known Subclasses:
ArrayPtg, ControlPtg, OperandPtg, OperationPtg, ScalarConstantPtg, UnknownPtg
public abstract class Ptg
extends java.lang.Object

Ptg represents a syntactic token in a formula. 'PTG' is an acronym for 'parse thing'. Originally, the name referred to the single byte identifier at the start of the token, but in POI, Ptg encapsulates the whole formula token (initial byte + value data).

Ptgs are logically arranged in a tree representing the structure of the parsed formula. However, in BIFF files Ptgs are written/read in Reverse-Polish Notation order. The RPN ordering also simplifies formula evaluation logic, so POI mostly accesses Ptgs in the same way.

Author:
andy, avik, Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte | CLASS_ARRAY
static byte | CLASS_REF
static byte | CLASS_VALUE
static Ptg[] | EMPTY_PTG_ARRAY
Constructor Summary
Ptg()
Method Summary
static Ptg | createPtg(LittleEndianInput in)
static boolean | doesFormulaReferToDeletedCell(Ptg[] ptgs)
abstract byte | getDefaultOperandClass()
static int | getEncodedSize(Ptg[] ptgs) This method will return the same result as getEncodedSizeWithoutArrayData(Ptg[]) if there are no array tokens present.
static int | getEncodedSizeWithoutArrayData(Ptg[] ptgs) Used to calculate value that should be encoded at the start of the encoded Ptg token array;
byte | getPtgClass()
char | getRVAType() Debug / diagnostic method to get this token's 'operand class' type.
abstract int | getSize()
abstract boolean | isBaseToken()
static Ptg[] | readTokens(int size, LittleEndianInput in) Reads size bytes of the input stream, to create an array of Ptgs.
static int | serializePtgs(Ptg[] ptgs, byte[] array, int offset) Writes the ptgs to the data buffer, starting at the specified offset.
void | setClass(byte thePtgClass)
abstract java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
abstract void | write(LittleEndianOutput out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EMPTY_PTG_ARRAY

public static final Ptg[] EMPTY_PTG_ARRAY

CLASS_REF

public static final byte CLASS_REF
See Also:
Constant Field Values

CLASS_VALUE

public static final byte CLASS_VALUE
See Also:
Constant Field Values

CLASS_ARRAY

public static final byte CLASS_ARRAY
See Also:
Constant Field Values
Constructor Detail

Ptg

public Ptg()
Method Detail

readTokens

public static Ptg[] readTokens(int size,
                               LittleEndianInput in)
Reads size bytes of the input stream, to create an array of Ptgs. Extra data (beyond size) may be read if and ArrayPtgs are present.

createPtg

public static Ptg createPtg(LittleEndianInput in)

getEncodedSize

public static int getEncodedSize(Ptg[] ptgs)
This method will return the same result as getEncodedSizeWithoutArrayData(Ptg[]) if there are no array tokens present.

Returns:
the full size taken to encode the specified Ptgs

getEncodedSizeWithoutArrayData

public static int getEncodedSizeWithoutArrayData(Ptg[] ptgs)
Used to calculate value that should be encoded at the start of the encoded Ptg token array;

Returns:
the size of the encoded Ptg tokens not including any trailing array data.

serializePtgs

public static int serializePtgs(Ptg[] ptgs,
                                byte[] array,
                                int offset)
Writes the ptgs to the data buffer, starting at the specified offset.
The 2 byte encode length field is not written by this method.

Returns:
number of bytes written

getSize

public abstract int getSize()
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

write

public abstract void write(LittleEndianOutput out)

toFormulaString

public abstract java.lang.String toFormulaString()
return a string representation of this token alone

toString

public java.lang.String toString()
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class java.lang.Object

setClass

public final void setClass(byte thePtgClass)

getPtgClass

public final byte getPtgClass()
Returns:
the 'operand class' (REF/VALUE/ARRAY) for this Ptg

getRVAType

public final char getRVAType()
Debug / diagnostic method to get this token's 'operand class' type.

Returns:
'R' for 'reference', 'V' for 'value', 'A' for 'array' and '.' for base tokens

getDefaultOperandClass

public abstract byte getDefaultOperandClass()

isBaseToken

public abstract boolean isBaseToken()
Returns:
false if this token is classified as 'reference', 'value', or 'array'

doesFormulaReferToDeletedCell

public static boolean doesFormulaReferToDeletedCell(Ptg[] ptgs)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RangePtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class RangePtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.RangePtg

public final class RangePtg
extends OperationPtg

Author:
Daniel Noll (daniel at nuix dot com dot au)

Field Summary
static OperationPtg | instance
static byte | sid
static int | SIZE
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
int | getSize()
boolean | isBaseToken()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(java.lang.String[] operands) implementation of method from OperationsPtg
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
getDefaultOperandClass
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

SIZE

public static final int SIZE
See Also:
Constant Field Values

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final OperationPtg instance
Method Detail

isBaseToken

public final boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
implementation of method from OperationsPtg

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Ref3DPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class Ref3DPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.RefPtgBase
                extended by  org.apache.poi.ss.formula.ptg.Ref3DPtg
All Implemented Interfaces:
java.lang.Cloneable, ExternSheetReferenceToken, WorkbookDependentFormula
public final class Ref3DPtg
extends RefPtgBase
implements WorkbookDependentFormula, ExternSheetReferenceToken

Title: Reference 3D Ptg

Description: Defined a cell in extern sheet.

REFERENCE:

Author:
Libin Roman (Vista Portal LDT. Developer), Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
Ref3DPtg(CellReference c, int externIdx)
Ref3DPtg(LittleEndianInput in)
Ref3DPtg(java.lang.String cellref, int externIdx)
Method Summary
java.lang.String | format2DRefAsString()
int | getExternSheetIndex()
int | getSize()
void | setExternSheetIndex(int index)
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(FormulaRenderingWorkbook book)
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.RefPtgBase
formatReferenceAsString, getColumn, getDefaultOperandClass, getRow, isColRelative, isRowRelative, readCoordinates, setColRelative, setColumn, setRow, setRowRelative, writeCoordinates
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

Ref3DPtg

public Ref3DPtg(LittleEndianInput in)

Ref3DPtg

public Ref3DPtg(java.lang.String cellref,
                int externIdx)

Ref3DPtg

public Ref3DPtg(CellReference c,
                int externIdx)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

getExternSheetIndex

public int getExternSheetIndex()
Specified by:
getExternSheetIndex in interface ExternSheetReferenceToken

setExternSheetIndex

public void setExternSheetIndex(int index)

format2DRefAsString

public java.lang.String format2DRefAsString()
Specified by:
format2DRefAsString in interface ExternSheetReferenceToken
Returns:
formula text for this reference token without the qualifying sheet name

toFormulaString

public java.lang.String toFormulaString(FormulaRenderingWorkbook book)
Specified by:
toFormulaString in interface WorkbookDependentFormula
Returns:
text representation of this cell reference that can be used in text formulas. The sheet name will get properly delimited if required.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefErrorPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class RefErrorPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.RefErrorPtg
All Implemented Interfaces:
java.lang.Cloneable
public final class RefErrorPtg
extends OperandPtg

RefError - handles deleted cell reference

Author:
Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
RefErrorPtg()
RefErrorPtg(LittleEndianInput in)
Method Summary
byte | getDefaultOperandClass()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

RefErrorPtg

public RefErrorPtg()

RefErrorPtg

public RefErrorPtg(LittleEndianInput in)
Method Detail

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefNPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class RefNPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.RefPtgBase
                extended by  org.apache.poi.ss.formula.ptg.RefNPtg
All Implemented Interfaces:
java.lang.Cloneable
public final class RefNPtg
extends RefPtgBase

RefNPtg

Author:
Jason Height (jheight at apache dot com)

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
RefNPtg(LittleEndianInput in)
Method Summary
protected byte | getSid()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.RefPtgBase
formatReferenceAsString, getColumn, getDefaultOperandClass, getRow, isColRelative, isRowRelative, readCoordinates, setColRelative, setColumn, setRow, setRowRelative, writeCoordinates
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

RefNPtg

public RefNPtg(LittleEndianInput in)
Method Detail

getSid

protected byte getSid()

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public final java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getSize

public final int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toString

public final java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class RefPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.RefPtgBase
                extended by  org.apache.poi.ss.formula.ptg.RefPtg
All Implemented Interfaces:
java.lang.Cloneable
public final class RefPtg
extends RefPtgBase

ReferencePtg - handles references (such as A1, A2, IA4)

Author:
Andrew C. Oliver (acoliver@apache.org), Jason Height (jheight at chariot dot net dot au)

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
RefPtg(CellReference cr)
RefPtg(int row, int column, boolean isRowRelative, boolean isColumnRelative)
RefPtg(LittleEndianInput in)
RefPtg(java.lang.String cellref)
Takes in a String representation of a cell reference and fills out the numeric fields.
Method Summary
protected byte | getSid()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.RefPtgBase
formatReferenceAsString, getColumn, getDefaultOperandClass, getRow, isColRelative, isRowRelative, readCoordinates, setColRelative, setColumn, setRow, setRowRelative, writeCoordinates
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

RefPtg

public RefPtg(java.lang.String cellref)
Takes in a String representation of a cell reference and fills out the numeric fields.

RefPtg

public RefPtg(int row,
              int column,
              boolean isRowRelative,
              boolean isColumnRelative)

RefPtg

public RefPtg(LittleEndianInput in)

RefPtg

public RefPtg(CellReference cr)
Method Detail

getSid

protected byte getSid()

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public final java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getSize

public final int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toString

public final java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefPtgBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class RefPtgBase

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperandPtg
            extended by  org.apache.poi.ss.formula.ptg.RefPtgBase
All Implemented Interfaces:
java.lang.Cloneable
Direct Known Subclasses:
Ref3DPtg, RefNPtg, RefPtg
public abstract class RefPtgBase
extends OperandPtg

ReferencePtgBase - handles references (such as A1, A2, IA4)

Author:
Andrew C. Oliver (acoliver@apache.org), Jason Height (jheight at chariot dot net dot au)

Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
protected | RefPtgBase()
protected | RefPtgBase(CellReference c)
Method Summary
protected java.lang.String | formatReferenceAsString()
int | getColumn()
byte | getDefaultOperandClass()
int | getRow()
boolean | isColRelative()
boolean | isRowRelative()
protected void | readCoordinates(LittleEndianInput in)
void | setColRelative(boolean rel)
void | setColumn(int col)
void | setRow(int rowIndex)
void | setRowRelative(boolean rel)
protected void | writeCoordinates(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperandPtg
copy, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, getSize, readTokens, serializePtgs, setClass, toFormulaString, toString, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RefPtgBase

protected RefPtgBase()

RefPtgBase

protected RefPtgBase(CellReference c)
Method Detail

readCoordinates

protected final void readCoordinates(LittleEndianInput in)

writeCoordinates

protected final void writeCoordinates(LittleEndianOutput out)

setRow

public final void setRow(int rowIndex)

getRow

public final int getRow()
Returns:
the row number as an int

isRowRelative

public final boolean isRowRelative()

setRowRelative

public final void setRowRelative(boolean rel)

isColRelative

public final boolean isColRelative()

setColRelative

public final void setColRelative(boolean rel)

setColumn

public final void setColumn(int col)

getColumn

public final int getColumn()

formatReferenceAsString

protected final java.lang.String formatReferenceAsString()

getDefaultOperandClass

public final byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScalarConstantPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ScalarConstantPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ScalarConstantPtg
Direct Known Subclasses:
BoolPtg, ErrPtg, IntPtg, MissingArgPtg, NumberPtg, StringPtg
public abstract class ScalarConstantPtg
extends Ptg

Common superclass of all Ptgs that represent simple constant values.

Author:
Josh Micich

Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
ScalarConstantPtg()
Method Summary
byte | getDefaultOperandClass()
boolean | isBaseToken()
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, getSize, readTokens, serializePtgs, setClass, toFormulaString, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ScalarConstantPtg

public ScalarConstantPtg()
Method Detail

isBaseToken

public final boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

getDefaultOperandClass

public final byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg

toString

public final java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class StringPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ScalarConstantPtg
            extended by  org.apache.poi.ss.formula.ptg.StringPtg

public final class StringPtg
extends ScalarConstantPtg

String Stores a String value in a formula value stored in the format <length 2 bytes>char[]

Author:
Werner Froidevaux, Jason Height (jheight at chariot dot net dot au), Bernard Chesnoy

Field Summary
static byte sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
StringPtg(LittleEndianInput in)
Create a StringPtg from a stream
StringPtg(java.lang.String value)
Create a StringPtg from a string representation of the number Number format is not checked, it is expected to be validated in the parser that calls this method.
Method Summary
int | getSize()
java.lang.String | getValue()
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ScalarConstantPtg
getDefaultOperandClass, isBaseToken, toString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values
Constructor Detail

StringPtg

public StringPtg(LittleEndianInput in)
Create a StringPtg from a stream

StringPtg

public StringPtg(java.lang.String value)
Create a StringPtg from a string representation of the number Number format is not checked, it is expected to be validated in the parser that calls this method.

Parameters:
value - : String representation of a floating point number
Method Detail

getValue

public java.lang.String getValue()

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubtractPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class SubtractPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.SubtractPtg

public final class SubtractPtg
extends ValueOperatorPtg

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) returns a string representation of the operations the length of the input array should equal the number returned by
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
Description copied from class: OperationPtg
returns a string representation of the operations the length of the input array should equal the number returned by

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TblPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class TblPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.ControlPtg
            extended by  org.apache.poi.ss.formula.ptg.TblPtg

public final class TblPtg
extends ControlPtg

This ptg indicates a data table. It only occurs in a FORMULA record, never in an ARRAY or NAME record. When ptgTbl occurs in a formula, it is the only token in the formula. This indicates that the cell containing the formula is an interior cell in a data table; the table description is found in a TABLE record. Rows and columns which contain input values to be substituted in the table do not contain ptgTbl. See page 811 of the june 08 binary docs.

Field Summary
static short sid
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
TblPtg(LittleEndianInput in)
Method Summary
int | getColumn()
int | getRow()
int | getSize()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toString() Overridden toString method to ensure object hash is not printed.
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.ControlPtg
getDefaultOperandClass, isBaseToken
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final short sid
See Also:
Constant Field Values
Constructor Detail

TblPtg

public TblPtg(LittleEndianInput in)
Method Detail

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

getRow

public int getRow()

getColumn

public int getColumn()

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toString

public java.lang.String toString()
Description copied from class: Ptg
Overridden toString method to ensure object hash is not printed. This helps get rid of gratuitous diffs when comparing two dumps Subclasses may output more relevant information by overriding this method

Overrides:
toString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnaryMinusPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class UnaryMinusPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.UnaryMinusPtg

public final class UnaryMinusPtg
extends ValueOperatorPtg

Unary Plus operator does not have any effect on the operand

Author:
Avik Sengupta

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) implementation of method from OperationsPtg
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
implementation of method from OperationsPtg

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnaryPlusPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class UnaryPlusPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
                extended by  org.apache.poi.ss.formula.ptg.UnaryPlusPtg

public final class UnaryPlusPtg
extends ValueOperatorPtg

Unary Plus operator does not have any effect on the operand

Author:
Avik Sengupta

Field Summary
static ValueOperatorPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
protected byte | getSid()
java.lang.String | toFormulaString(java.lang.String[] operands) implementation of method from OperationsPtg
Methods inherited from class org.apache.poi.ss.formula.ptg.ValueOperatorPtg
getDefaultOperandClass, getSize, isBaseToken, toFormulaString, write
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final ValueOperatorPtg instance
Method Detail

getSid

protected byte getSid()
Specified by:
getSid in class ValueOperatorPtg

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
implementation of method from OperationsPtg

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnionPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class UnionPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.UnionPtg

public final class UnionPtg
extends OperationPtg

Author:
Glen Stampoultzis (glens at apache.org)

Field Summary
static OperationPtg | instance
static byte | sid
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Method Summary
int | getNumberOfOperands() The number of operands expected by the operations
int | getSize()
boolean | isBaseToken()
java.lang.String | toFormulaString() return a string representation of this token alone
java.lang.String | toFormulaString(java.lang.String[] operands) implementation of method from OperationsPtg
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
getDefaultOperandClass
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sid

public static final byte sid
See Also:
Constant Field Values

instance

public static final OperationPtg instance
Method Detail

isBaseToken

public final boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

toFormulaString

public java.lang.String toFormulaString(java.lang.String[] operands)
implementation of method from OperationsPtg

Specified by:
toFormulaString in class OperationPtg
See Also:
OperationPtg.getNumberOfOperands()

getNumberOfOperands

public int getNumberOfOperands()
Description copied from class: OperationPtg
The number of operands expected by the operations

Specified by:
getNumberOfOperands in class OperationPtg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownPtg

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class UnknownPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.UnknownPtg

public class UnknownPtg
extends Ptg

Author:
andy, Jason Height (jheight at chariot dot net dot au)

Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
UnknownPtg(int sid)
Method Summary
byte | getDefaultOperandClass()
int | getSize()
boolean | isBaseToken()
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnknownPtg

public UnknownPtg(int sid)
Method Detail

isBaseToken

public boolean isBaseToken()
Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSize

public int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg

getDefaultOperandClass

public byte getDefaultOperandClass()
Specified by:
getDefaultOperandClass in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueOperatorPtg

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.ptg
Class ValueOperatorPtg

java.lang.Object
    extended by  org.apache.poi.ss.formula.ptg.Ptg
        extended by  org.apache.poi.ss.formula.ptg.OperationPtg
            extended by  org.apache.poi.ss.formula.ptg.ValueOperatorPtg
Direct Known Subclasses:
AddPtg, ConcatPtg, DividePtg, EqualPtg, GreaterEqualPtg, GreaterThanPtg, LessEqualPtg, LessThanPtg, MultiplyPtg, NotEqualPtg, PercentPtg, PowerPtg, SubtractPtg, UnaryMinusPtg, UnaryPlusPtg
public abstract class ValueOperatorPtg
extends OperationPtg

Common superclass of all value operators. Subclasses include all unary and binary operators except for the reference operators (IntersectionPtg, RangePtg, UnionPtg)

Author:
Josh Micich

Field Summary
Fields inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
TYPE_BINARY, TYPE_FUNCTION, TYPE_UNARY
Fields inherited from class org.apache.poi.ss.formula.ptg.Ptg
CLASS_ARRAY, CLASS_REF, CLASS_VALUE, EMPTY_PTG_ARRAY
Constructor Summary
ValueOperatorPtg()
Method Summary
byte | getDefaultOperandClass()
protected abstract byte | getSid()
int | getSize()
boolean | isBaseToken() All Operator Ptgs are base tokens (i.e.
java.lang.String | toFormulaString() return a string representation of this token alone
void | write(LittleEndianOutput out)
Methods inherited from class org.apache.poi.ss.formula.ptg.OperationPtg
getNumberOfOperands, toFormulaString
Methods inherited from class org.apache.poi.ss.formula.ptg.Ptg
createPtg, doesFormulaReferToDeletedCell, getEncodedSize, getEncodedSizeWithoutArrayData, getPtgClass, getRVAType, readTokens, serializePtgs, setClass, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValueOperatorPtg

public ValueOperatorPtg()
Method Detail

isBaseToken

public final boolean isBaseToken()
All Operator Ptgs are base tokens (i.e. are not RVA classified)

Specified by:
isBaseToken in class Ptg
Returns:
false if this token is classified as 'reference', 'value', or 'array'

getDefaultOperandClass

public final byte getDefaultOperandClass()
Overrides:
getDefaultOperandClass in class OperationPtg

write

public void write(LittleEndianOutput out)
Specified by:
write in class Ptg

getSid

protected abstract byte getSid()

getSize

public final int getSize()
Specified by:
getSize in class Ptg
Returns:
the encoded length of this Ptg, including the initial Ptg type identifier byte.

toFormulaString

public final java.lang.String toFormulaString()
Description copied from class: Ptg
return a string representation of this token alone

Specified by:
toFormulaString in class Ptg
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AbstractFunctionPtg

Packages that use AbstractFunctionPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of AbstractFunctionPtg in org.apache.poi.ss.formula.ptg

Subclasses of AbstractFunctionPtg in org.apache.poi.ss.formula.ptg
class | FuncPtg
class | FuncVarPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AddPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AddPtg

No usage of org.apache.poi.ss.formula.ptg.AddPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.Area2DPtgBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.Area2DPtgBase

Packages that use Area2DPtgBase
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of Area2DPtgBase in org.apache.poi.ss.formula.ptg

Subclasses of Area2DPtgBase in org.apache.poi.ss.formula.ptg
class | AreaNPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtg Specifies a rectangular area of cells A1:A4 for instance.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.Area3DPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.Area3DPtg

No usage of org.apache.poi.ss.formula.ptg.Area3DPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AreaErrPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AreaErrPtg

No usage of org.apache.poi.ss.formula.ptg.AreaErrPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.ptg.AreaI

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.ptg.AreaI

Packages that use AreaI
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas

Uses of AreaI in org.apache.poi.ss.formula.eval

Constructors in org.apache.poi.ss.formula.eval with parameters of type AreaI
AreaEvalBase(AreaI ptg)

Uses of AreaI in org.apache.poi.ss.formula.ptg

Classes in org.apache.poi.ss.formula.ptg that implement AreaI
class | Area2DPtgBase Common superclass of 2-D area refs
class | Area3DPtg Title: Area 3D Ptg - 3D reference (Sheet + Area)
static class | AreaI.OffsetArea
class | AreaNPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtgBase Specifies a rectangular area of cells A1:A4 for instance.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

No usage of org.apache.poi.ss.formula.ptg.AreaI.OffsetArea

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AreaNPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AreaNPtg

No usage of org.apache.poi.ss.formula.ptg.AreaNPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AreaPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AreaPtg

No usage of org.apache.poi.ss.formula.ptg.AreaPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AreaPtgBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AreaPtgBase

Packages that use AreaPtgBase
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of AreaPtgBase in org.apache.poi.ss.formula.ptg

Subclasses of AreaPtgBase in org.apache.poi.ss.formula.ptg
class | Area2DPtgBase Common superclass of 2-D area refs
class | Area3DPtg Title: Area 3D Ptg - 3D reference (Sheet + Area)
class | AreaNPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtg Specifies a rectangular area of cells A1:A4 for instance.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ArrayPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ArrayPtg

No usage of org.apache.poi.ss.formula.ptg.ArrayPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AttrPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AttrPtg

Packages that use AttrPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of AttrPtg in org.apache.poi.ss.formula.ptg

Fields in org.apache.poi.ss.formula.ptg declared as AttrPtg
static AttrPtg AttrPtg.SUM

Methods in org.apache.poi.ss.formula.ptg that return AttrPtg
static AttrPtg | AttrPtg.createIf(int dist)
static AttrPtg | AttrPtg.createSkip(int dist)
static AttrPtg | AttrPtg.createSpace(int type, int count)
static AttrPtg | AttrPtg.getSumSingle()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType

No usage of org.apache.poi.ss.formula.ptg.AttrPtg.SpaceType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.BoolPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.BoolPtg

Packages that use BoolPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of BoolPtg in org.apache.poi.ss.formula.ptg

Methods in org.apache.poi.ss.formula.ptg that return BoolPtg
static BoolPtg | BoolPtg.read(LittleEndianInput in)
static BoolPtg | BoolPtg.valueOf(boolean b)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ConcatPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ConcatPtg

No usage of org.apache.poi.ss.formula.ptg.ConcatPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ControlPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ControlPtg

Packages that use ControlPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of ControlPtg in org.apache.poi.ss.formula.ptg

Subclasses of ControlPtg in org.apache.poi.ss.formula.ptg
class | AttrPtg "Special Attributes" This seems to be a Misc Stuff and Junk record.
class | ExpPtg
class | ParenthesisPtg While formula tokens are stored in RPN order and thus do not need parenthesis for precedence reasons, Parenthesis tokens ARE written to ensure that user entered parenthesis are displayed as-is on reading back Avik Sengupta <lists@aviksengupta.com> Andrew C.
class | TblPtg This ptg indicates a data table.

Fields in org.apache.poi.ss.formula.ptg declared as ControlPtg
static ControlPtg ParenthesisPtg.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

No usage of org.apache.poi.ss.formula.ptg.DeletedArea3DPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

No usage of org.apache.poi.ss.formula.ptg.DeletedRef3DPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.DividePtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.DividePtg

No usage of org.apache.poi.ss.formula.ptg.DividePtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.EqualPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.EqualPtg

No usage of org.apache.poi.ss.formula.ptg.EqualPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ErrPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ErrPtg

Packages that use ErrPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of ErrPtg in org.apache.poi.ss.formula.ptg

Fields in org.apache.poi.ss.formula.ptg declared as ErrPtg
static ErrPtg | ErrPtg.DIV_ZERO #DIV/0! - Division by zero
static ErrPtg | ErrPtg.N_A #N/A - Argument or function not available
static ErrPtg | ErrPtg.NAME_INVALID #NAME? - Wrong function or range name
static ErrPtg | ErrPtg.NULL_INTERSECTION #NULL! - Intersection of two cell ranges is empty
static ErrPtg | ErrPtg.NUM_ERROR #NUM! - Value range overflow
static ErrPtg | ErrPtg.REF_INVALID #REF! - Illegal or deleted cell reference
static ErrPtg | ErrPtg.VALUE_INVALID #VALUE! - Wrong type of operand

Methods in org.apache.poi.ss.formula.ptg that return ErrPtg
static ErrPtg | ErrPtg.read(LittleEndianInput in)
static ErrPtg | ErrPtg.valueOf(int code)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ExpPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ExpPtg

No usage of org.apache.poi.ss.formula.ptg.ExpPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.FuncPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.FuncPtg

Packages that use FuncPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of FuncPtg in org.apache.poi.ss.formula.ptg

Methods in org.apache.poi.ss.formula.ptg that return FuncPtg
static FuncPtg | FuncPtg.create(int functionIndex)
static FuncPtg | FuncPtg.create(LittleEndianInput in)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.FuncVarPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.FuncVarPtg

Packages that use FuncVarPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of FuncVarPtg in org.apache.poi.ss.formula.ptg

Methods in org.apache.poi.ss.formula.ptg that return FuncVarPtg
static FuncVarPtg | FuncVarPtg.create(LittleEndianInput in) Creates new function pointer from a byte array usually called while reading an excel file.
static FuncVarPtg | FuncVarPtg.create(java.lang.String pName, int numArgs) Create a function ptg from a string tokenised by the parser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.GreaterEqualPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.GreaterEqualPtg

No usage of org.apache.poi.ss.formula.ptg.GreaterEqualPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.GreaterThanPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.GreaterThanPtg

No usage of org.apache.poi.ss.formula.ptg.GreaterThanPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.IntersectionPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.IntersectionPtg

No usage of org.apache.poi.ss.formula.ptg.IntersectionPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.IntPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.IntPtg

No usage of org.apache.poi.ss.formula.ptg.IntPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.LessEqualPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.LessEqualPtg

No usage of org.apache.poi.ss.formula.ptg.LessEqualPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.LessThanPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.LessThanPtg

No usage of org.apache.poi.ss.formula.ptg.LessThanPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.MemAreaPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.MemAreaPtg

No usage of org.apache.poi.ss.formula.ptg.MemAreaPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.MemErrPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.MemErrPtg

No usage of org.apache.poi.ss.formula.ptg.MemErrPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.MemFuncPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.MemFuncPtg

No usage of org.apache.poi.ss.formula.ptg.MemFuncPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.MissingArgPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.MissingArgPtg

No usage of org.apache.poi.ss.formula.ptg.MissingArgPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.MultiplyPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.MultiplyPtg

No usage of org.apache.poi.ss.formula.ptg.MultiplyPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.NamePtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.NamePtg

Packages that use NamePtg
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.xssf.usermodel |

Uses of NamePtg in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel with parameters of type NamePtg
EvaluationName | HSSFEvaluationWorkbook.getName(NamePtg namePtg)
java.lang.String | HSSFEvaluationWorkbook.getNameText(NamePtg namePtg)

Uses of NamePtg in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return NamePtg
 NamePtg EvaluationName.createPtg()

Methods in org.apache.poi.ss.formula with parameters of type NamePtg
EvaluationName | EvaluationWorkbook.getName(NamePtg namePtg)
java.lang.String | FormulaRenderingWorkbook.getNameText(NamePtg namePtg)

Uses of NamePtg in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type NamePtg
EvaluationName | XSSFEvaluationWorkbook.getName(NamePtg namePtg)
java.lang.String | XSSFEvaluationWorkbook.getNameText(NamePtg namePtg)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.NameXPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.NameXPtg

Packages that use NameXPtg
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval |
org.apache.poi.xssf.usermodel |

Uses of NameXPtg in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return NameXPtg
 NameXPtg InternalWorkbook.getNameXPtg(java.lang.String name, UDFFinder udf)

Uses of NameXPtg in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return NameXPtg
 NameXPtg HSSFEvaluationWorkbook.getNameXPtg(java.lang.String name)

Methods in org.apache.poi.hssf.usermodel with parameters of type NameXPtg
 java.lang.String HSSFEvaluationWorkbook.resolveNameXText(NameXPtg n)

Uses of NameXPtg in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return NameXPtg
 NameXPtg FormulaParsingWorkbook.getNameXPtg(java.lang.String name)

Methods in org.apache.poi.ss.formula with parameters of type NameXPtg
ValueEval | OperationEvaluationContext.getNameXEval(NameXPtg nameXPtg)
java.lang.String | FormulaRenderingWorkbook.resolveNameXText(NameXPtg nameXPtg)
java.lang.String | EvaluationWorkbook.resolveNameXText(NameXPtg ptg)

Uses of NameXPtg in org.apache.poi.ss.formula.eval

Methods in org.apache.poi.ss.formula.eval that return NameXPtg
 NameXPtg NameXEval.getPtg()

Constructors in org.apache.poi.ss.formula.eval with parameters of type NameXPtg
NameXEval(NameXPtg ptg)

Uses of NameXPtg in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return NameXPtg
 NameXPtg XSSFEvaluationWorkbook.getNameXPtg(java.lang.String name)

Methods in org.apache.poi.xssf.usermodel with parameters of type NameXPtg
 java.lang.String XSSFEvaluationWorkbook.resolveNameXText(NameXPtg n)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.NotEqualPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.NotEqualPtg

No usage of org.apache.poi.ss.formula.ptg.NotEqualPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.NumberPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.NumberPtg

No usage of org.apache.poi.ss.formula.ptg.NumberPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.OperandPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.OperandPtg

Packages that use OperandPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of OperandPtg in org.apache.poi.ss.formula.ptg

Subclasses of OperandPtg in org.apache.poi.ss.formula.ptg
class | Area2DPtgBase Common superclass of 2-D area refs
class | Area3DPtg Title: Area 3D Ptg - 3D reference (Sheet + Area)
class | AreaErrPtg AreaErr - handles deleted cell area references.
class | AreaNPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtgBase Specifies a rectangular area of cells A1:A4 for instance.
class | DeletedArea3DPtg Title: Deleted Area 3D Ptg - 3D referecnce (Sheet + Area)
class | DeletedRef3DPtg Title: Deleted Reference 3D Ptg
class | MemAreaPtg
class | MemErrPtg
class | MemFuncPtg
class | NamePtg
class | NameXPtg
class | Ref3DPtg Title: Reference 3D Ptg
class | RefErrorPtg RefError - handles deleted cell reference
class | RefNPtg RefNPtg
class | RefPtg ReferencePtg - handles references (such as A1, A2, IA4)
class | RefPtgBase ReferencePtgBase - handles references (such as A1, A2, IA4)

Methods in org.apache.poi.ss.formula.ptg that return OperandPtg
 OperandPtg OperandPtg.copy()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.OperationPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.OperationPtg

Packages that use OperationPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of OperationPtg in org.apache.poi.ss.formula.ptg

Subclasses of OperationPtg in org.apache.poi.ss.formula.ptg
class | AbstractFunctionPtg This class provides the base functionality for Excel sheet functions There are two kinds of function Ptgs - tFunc and tFuncVar Therefore, this class will have ONLY two subclasses
class | AddPtg Addition operator PTG the "+" binomial operator.
class | ConcatPtg
class | DividePtg This PTG implements the standard binomial divide "/"
class | EqualPtg
class | FuncPtg
class | FuncVarPtg
class | GreaterEqualPtg PTG class to implement greater or equal to
class | GreaterThanPtg Greater than operator PTG ">"
class | IntersectionPtg
class | LessEqualPtg Ptg class to implement less than or equal
class | LessThanPtg Less than operator PTG "<".
class | MultiplyPtg Implements the standard mathmatical multiplication - *
class | NotEqualPtg Ptg class to implement not equal
class | PercentPtg Percent PTG.
class | PowerPtg
class | RangePtg
class | SubtractPtg
class | UnaryMinusPtg Unary Plus operator does not have any effect on the operand
class | UnaryPlusPtg Unary Plus operator does not have any effect on the operand
class | UnionPtg
class | ValueOperatorPtg Common superclass of all value operators.

Fields in org.apache.poi.ss.formula.ptg declared as OperationPtg
static OperationPtg | UnionPtg.instance
static OperationPtg | RangePtg.instance
static OperationPtg | IntersectionPtg.instance
static OperationPtg | FuncVarPtg.SUM Single instance of this token for 'sum() taking a single argument'

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ParenthesisPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ParenthesisPtg

No usage of org.apache.poi.ss.formula.ptg.ParenthesisPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.PercentPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.PercentPtg

No usage of org.apache.poi.ss.formula.ptg.PercentPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.PowerPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.PowerPtg

No usage of org.apache.poi.ss.formula.ptg.PowerPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.Ptg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.Ptg

Packages that use Ptg
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.eval |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.xssf.usermodel |

Uses of Ptg in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return Ptg
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook) Convenience method for parsing cell formulas.
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType)
static Ptg[] | HSSFFormulaParser.parse(java.lang.String formula, HSSFWorkbook workbook, int formulaType, int sheetIndex)

Methods in org.apache.poi.hssf.model with parameters of type Ptg
static java.lang.String HSSFFormulaParser.toFormulaString(HSSFWorkbook book, Ptg[] ptgs)
Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.

Uses of Ptg in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return Ptg
Ptg | LbsDataSubRecord.getFormula()
Ptg[] | ArrayRecord.getFormulaTokens()
Ptg[] | SharedFormulaRecord.getFormulaTokens(FormulaRecord formula)
Ptg | TextObjectRecord.getLinkRefPtg()
Ptg[] | NameRecord.getNameDefinition() gets the definition, reference (Formula)
Ptg[] | FormulaRecord.getParsedExpression()
Ptg[] | ExternalNameRecord.getParsedExpression()
Ptg[] | CFRuleRecord.getParsedExpression1() get the stack of the 1st expression as a list
Ptg[] | CFRuleRecord.getParsedExpression2() get the stack of the 2nd expression as a list

Methods in org.apache.poi.hssf.record with parameters of type Ptg
void | NameRecord.setNameDefinition(Ptg[] ptgs)
void | FormulaRecord.setParsedExpression(Ptg[] ptgs)
void | ExternalNameRecord.setParsedExpression(Ptg[] ptgs)
void | CFRuleRecord.setParsedExpression1(Ptg[] ptgs)
void | CFRuleRecord.setParsedExpression2(Ptg[] ptgs)

Constructors in org.apache.poi.hssf.record with parameters of type Ptg
DVRecord(int validationType, int operator, int errorStyle, boolean emptyCellAllowed, boolean suppressDropDownArrow, boolean isExplicitList, boolean showPromptBox, java.lang.String promptTitle, java.lang.String promptText, boolean showErrorBox, java.lang.String errorTitle, java.lang.String errorText, Ptg[] formula1, Ptg[] formula2, CellRangeAddressList regions)
DVRecord(int validationType, int operator, int errorStyle, boolean emptyCellAllowed, boolean suppressDropDownArrow, boolean isExplicitList, boolean showPromptBox, java.lang.String promptTitle, java.lang.String promptText, boolean showErrorBox, java.lang.String errorTitle, java.lang.String errorText, Ptg[] formula1, Ptg[] formula2, CellRangeAddressList regions)

Uses of Ptg in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return Ptg
 Ptg[] FormulaRecordAggregate.getFormulaTokens()

Methods in org.apache.poi.hssf.record.aggregates with parameters of type Ptg
void | FormulaRecordAggregate.setArrayFormula(CellRangeAddress r, Ptg[] ptgs)
void | FormulaRecordAggregate.setParsedExpression(Ptg[] ptgs) Also checks for a related shared formula and unlinks it if found

Uses of Ptg in org.apache.poi.hssf.record.chart

Methods in org.apache.poi.hssf.record.chart that return Ptg
 Ptg[] LinkedDataRecord.getFormulaOfLink()
Get the formula of link field for the LinkedData record.

Methods in org.apache.poi.hssf.record.chart with parameters of type Ptg
 void LinkedDataRecord.setFormulaOfLink(Ptg[] ptgs)
Set the formula of link field for the LinkedData record.

Uses of Ptg in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return Ptg
Ptg[] | DVConstraint.FormulaPair.getFormula1()
Ptg[] | DVConstraint.FormulaPair.getFormula2()
Ptg[] | HSSFEvaluationWorkbook.getFormulaTokens(EvaluationCell evalCell)

Constructors in org.apache.poi.hssf.usermodel with parameters of type Ptg
DVConstraint.FormulaPair(Ptg[] formula1, Ptg[] formula2)
DVConstraint.FormulaPair(Ptg[] formula1, Ptg[] formula2)

Uses of Ptg in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return Ptg
Ptg[] | SharedFormula.convertSharedFormulas(Ptg[] ptgs, int formulaRow, int formulaColumn) Creates a non shared formula from the shared formula counterpart, i.e.
Ptg[] | EvaluationWorkbook.getFormulaTokens(EvaluationCell cell)
Ptg[] | EvaluationName.getNameDefinition()
Ptg[] | Formula.getTokens()
static Ptg[] | Formula.getTokens(Formula formula) Gets the Ptg array from the supplied Formula.
static Ptg[] | FormulaParser.parse(java.lang.String formula, FormulaParsingWorkbook workbook, int formulaType, int sheetIndex) Parse a formula into a array of tokens

Methods in org.apache.poi.ss.formula with parameters of type Ptg
boolean | FormulaShifter.adjustFormula(Ptg[] ptgs, int currentExternSheetIx)
Ptg[] | SharedFormula.convertSharedFormulas(Ptg[] ptgs, int formulaRow, int formulaColumn) Creates a non shared formula from the shared formula counterpart, i.e.
static Formula | Formula.create(Ptg[] ptgs) Creates a Formula object from a supplied Ptg array.
static java.lang.String | FormulaRenderer.toFormulaString(FormulaRenderingWorkbook book, Ptg[] ptgs) Static method to convert an array of Ptgs in RPN order to a human readable string format in infix mode.

Uses of Ptg in org.apache.poi.ss.formula.eval

Constructors in org.apache.poi.ss.formula.eval with parameters of type Ptg
NumberEval(Ptg ptg)
StringEval(Ptg ptg)

Uses of Ptg in org.apache.poi.ss.formula.ptg

Subclasses of Ptg in org.apache.poi.ss.formula.ptg
class | AbstractFunctionPtg This class provides the base functionality for Excel sheet functions There are two kinds of function Ptgs - tFunc and tFuncVar Therefore, this class will have ONLY two subclasses
class | AddPtg Addition operator PTG the "+" binomial operator.
class | Area2DPtgBase Common superclass of 2-D area refs
class | Area3DPtg Title: Area 3D Ptg - 3D reference (Sheet + Area)
class | AreaErrPtg AreaErr - handles deleted cell area references.
class | AreaNPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtg Specifies a rectangular area of cells A1:A4 for instance.
class | AreaPtgBase Specifies a rectangular area of cells A1:A4 for instance.
class | ArrayPtg ArrayPtg - handles arrays The ArrayPtg is a little weird, the size of the Ptg when parsing initially only includes the Ptg sid and the reserved bytes.
class | AttrPtg "Special Attributes" This seems to be a Misc Stuff and Junk record.
class | BoolPtg Boolean (boolean) Stores a (java) boolean value in a formula.
class | ConcatPtg
class | ControlPtg Common superclass for tExp tTbl tParen tNlr tAttr tSheet tEndSheet
class | DeletedArea3DPtg Title: Deleted Area 3D Ptg - 3D referecnce (Sheet + Area)
class | DeletedRef3DPtg Title: Deleted Reference 3D Ptg
class | DividePtg This PTG implements the standard binomial divide "/"
class | EqualPtg
class | ErrPtg
class | ExpPtg
class | FuncPtg
class | FuncVarPtg
class | GreaterEqualPtg PTG class to implement greater or equal to
class | GreaterThanPtg Greater than operator PTG ">"
class | IntersectionPtg
class | IntPtg Integer (unsigned short integer) Stores an unsigned short value (java int) in a formula
class | LessEqualPtg Ptg class to implement less than or equal
class | LessThanPtg Less than operator PTG "<".
class | MemAreaPtg
class | MemErrPtg
class | MemFuncPtg
class | MissingArgPtg Missing Function Arguments Avik Sengupta <avik at apache.org>
class | MultiplyPtg Implements the standard mathmatical multiplication - *
class | NamePtg
class | NameXPtg
class | NotEqualPtg Ptg class to implement not equal
class | NumberPtg Number Stores a floating point value in a formula value stored in a 8 byte field using IEEE notation
class | OperandPtg
class | OperationPtg defines a Ptg that is an operation instead of an operand
class | ParenthesisPtg While formula tokens are stored in RPN order and thus do not need parenthesis for precedence reasons, Parenthesis tokens ARE written to ensure that user entered parenthesis are displayed as-is on reading back Avik Sengupta <lists@aviksengupta.com> Andrew C.
class | PercentPtg Percent PTG.
class | PowerPtg
class | RangePtg
class | Ref3DPtg Title: Reference 3D Ptg
class | RefErrorPtg RefError - handles deleted cell reference
class | RefNPtg RefNPtg
class | RefPtg ReferencePtg - handles references (such as A1, A2, IA4)
class | RefPtgBase ReferencePtgBase - handles references (such as A1, A2, IA4)
class | ScalarConstantPtg Common superclass of all Ptgs that represent simple constant values.
class | StringPtg String Stores a String value in a formula value stored in the format <length 2 bytes>char[]
class | SubtractPtg
class | TblPtg This ptg indicates a data table.
class | UnaryMinusPtg Unary Plus operator does not have any effect on the operand
class | UnaryPlusPtg Unary Plus operator does not have any effect on the operand
class | UnionPtg
class | UnknownPtg
class | ValueOperatorPtg Common superclass of all value operators.

Fields in org.apache.poi.ss.formula.ptg declared as Ptg
static Ptg[] | Ptg.EMPTY_PTG_ARRAY
static Ptg | MissingArgPtg.instance

Methods in org.apache.poi.ss.formula.ptg that return Ptg
static Ptg | Ptg.createPtg(LittleEndianInput in)
static Ptg[] | Ptg.readTokens(int size, LittleEndianInput in) Reads size bytes of the input stream, to create an array of Ptgs.

Methods in org.apache.poi.ss.formula.ptg with parameters of type Ptg
static boolean Ptg.doesFormulaReferToDeletedCell(Ptg[] ptgs)
static int Ptg.getEncodedSize(Ptg[] ptgs)
This method will return the same result as getEncodedSizeWithoutArrayData(Ptg[]) if there are no array tokens present.
static int Ptg.getEncodedSizeWithoutArrayData(Ptg[] ptgs)
Used to calculate value that should be encoded at the start of the encoded Ptg token array;
static int Ptg.serializePtgs(Ptg[] ptgs, byte[] array, int offset)
Writes the ptgs to the data buffer, starting at the specified offset.

Uses of Ptg in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return Ptg
 Ptg[] XSSFEvaluationWorkbook.getFormulaTokens(EvaluationCell evalCell)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.RangePtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.RangePtg

No usage of org.apache.poi.ss.formula.ptg.RangePtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.Ref3DPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.Ref3DPtg

No usage of org.apache.poi.ss.formula.ptg.Ref3DPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.RefErrorPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.RefErrorPtg

No usage of org.apache.poi.ss.formula.ptg.RefErrorPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.RefNPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.RefNPtg

No usage of org.apache.poi.ss.formula.ptg.RefNPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.RefPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.RefPtg

No usage of org.apache.poi.ss.formula.ptg.RefPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.RefPtgBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.RefPtgBase

Packages that use RefPtgBase
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of RefPtgBase in org.apache.poi.ss.formula.ptg

Subclasses of RefPtgBase in org.apache.poi.ss.formula.ptg
class | Ref3DPtg Title: Reference 3D Ptg
class | RefNPtg RefNPtg
class | RefPtg ReferencePtg - handles references (such as A1, A2, IA4)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ScalarConstantPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ScalarConstantPtg

Packages that use ScalarConstantPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of ScalarConstantPtg in org.apache.poi.ss.formula.ptg

Subclasses of ScalarConstantPtg in org.apache.poi.ss.formula.ptg
class | BoolPtg Boolean (boolean) Stores a (java) boolean value in a formula.
class | ErrPtg
class | IntPtg Integer (unsigned short integer) Stores an unsigned short value (java int) in a formula
class | MissingArgPtg Missing Function Arguments Avik Sengupta <avik at apache.org>
class | NumberPtg Number Stores a floating point value in a formula value stored in a 8 byte field using IEEE notation
class | StringPtg String Stores a String value in a formula value stored in the format <length 2 bytes>char[]

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.StringPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.StringPtg

No usage of org.apache.poi.ss.formula.ptg.StringPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.SubtractPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.SubtractPtg

No usage of org.apache.poi.ss.formula.ptg.SubtractPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.TblPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.TblPtg

No usage of org.apache.poi.ss.formula.ptg.TblPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.UnaryMinusPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.UnaryMinusPtg

No usage of org.apache.poi.ss.formula.ptg.UnaryMinusPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.UnaryPlusPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.UnaryPlusPtg

No usage of org.apache.poi.ss.formula.ptg.UnaryPlusPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.UnionPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.UnionPtg

No usage of org.apache.poi.ss.formula.ptg.UnionPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.UnknownPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.UnknownPtg

No usage of org.apache.poi.ss.formula.ptg.UnknownPtg

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.ptg.ValueOperatorPtg

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.ptg.ValueOperatorPtg

Packages that use ValueOperatorPtg
org.apache.poi.ss.formula.ptg formula package contains binary PTG structures used in Formulas

Uses of ValueOperatorPtg in org.apache.poi.ss.formula.ptg

Subclasses of ValueOperatorPtg in org.apache.poi.ss.formula.ptg
class | AddPtg Addition operator PTG the "+" binomial operator.
class | ConcatPtg
class | DividePtg This PTG implements the standard binomial divide "/"
class | EqualPtg
class | GreaterEqualPtg PTG class to implement greater or equal to
class | GreaterThanPtg Greater than operator PTG ">"
class | LessEqualPtg Ptg class to implement less than or equal
class | LessThanPtg Less than operator PTG "<".
class | MultiplyPtg Implements the standard mathmatical multiplication - *
class | NotEqualPtg Ptg class to implement not equal
class | PercentPtg Percent PTG.
class | PowerPtg
class | SubtractPtg
class | UnaryMinusPtg Unary Plus operator does not have any effect on the operand
class | UnaryPlusPtg Unary Plus operator does not have any effect on the operand

Fields in org.apache.poi.ss.formula.ptg declared as ValueOperatorPtg
static ValueOperatorPtg | UnaryPlusPtg.instance
static ValueOperatorPtg | UnaryMinusPtg.instance
static ValueOperatorPtg | SubtractPtg.instance
static ValueOperatorPtg | PowerPtg.instance
static ValueOperatorPtg | PercentPtg.instance
static ValueOperatorPtg | NotEqualPtg.instance
static ValueOperatorPtg | MultiplyPtg.instance
static ValueOperatorPtg | LessThanPtg.instance
static ValueOperatorPtg | LessEqualPtg.instance
static ValueOperatorPtg | GreaterThanPtg.instance
static ValueOperatorPtg | GreaterEqualPtg.instance
static ValueOperatorPtg | EqualPtg.instance
static ValueOperatorPtg | DividePtg.instance
static ValueOperatorPtg | ConcatPtg.instance
static ValueOperatorPtg | AddPtg.instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AggregatingUDFFinder

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.udf
Class AggregatingUDFFinder

java.lang.Object
    extended by  org.apache.poi.ss.formula.udf.AggregatingUDFFinder
All Implemented Interfaces:
UDFFinder
Direct Known Subclasses:
IndexedUDFFinder
public class AggregatingUDFFinder
extends java.lang.Object
implements UDFFinder

Collects add-in libraries and VB macro functions together into one UDF finder

Author:
PUdalau

Field Summary
Fields inherited from interface org.apache.poi.ss.formula.udf.UDFFinder
DEFAULT
Constructor Summary
AggregatingUDFFinder(UDFFinder... usedToolPacks)
Method Summary
void | add(UDFFinder toolPack) Add a new toolpack
FreeRefFunction | findFunction(java.lang.String name) Returns executor by specified name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AggregatingUDFFinder

public AggregatingUDFFinder(UDFFinder... usedToolPacks)
Method Detail

findFunction

public FreeRefFunction findFunction(java.lang.String name)
Returns executor by specified name. Returns null if function isn't contained by any registered tool pack.

Specified by:
findFunction in interface UDFFinder
Parameters:
name - Name of function.
Returns:
Function executor. null if not found

add

public void add(UDFFinder toolPack)
Add a new toolpack

Parameters:
toolPack - the UDF toolpack to add
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultUDFFinder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.udf
Class DefaultUDFFinder

java.lang.Object
    extended by  org.apache.poi.ss.formula.udf.DefaultUDFFinder
All Implemented Interfaces:
UDFFinder
public final class DefaultUDFFinder
extends java.lang.Object
implements UDFFinder

Default UDF finder - for adding your own user defined functions.

Author:
PUdalau

Field Summary
Fields inherited from interface org.apache.poi.ss.formula.udf.UDFFinder
DEFAULT
Constructor Summary
DefaultUDFFinder(java.lang.String[] functionNames, FreeRefFunction[] functionImpls)
Method Summary
 FreeRefFunction findFunction(java.lang.String name)
Returns executor by specified name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultUDFFinder

public DefaultUDFFinder(java.lang.String[] functionNames,
                        FreeRefFunction[] functionImpls)
Method Detail

findFunction

public FreeRefFunction findFunction(java.lang.String name)
Description copied from interface: UDFFinder
Returns executor by specified name. Returns null if the function name is unknown.

Specified by:
findFunction in interface UDFFinder
Parameters:
name - Name of function.
Returns:
Function executor.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.formula.udf
Interfaces
UDFFinder
Classes
AggregatingUDFFinder
DefaultUDFFinder


org.apache.poi.ss.formula.udf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.formula.udf

Interface Summary
UDFFinder Common interface for "Add-in" libraries and user defined function libraries.

Class Summary
AggregatingUDFFinder | Collects add-in libraries and VB macro functions together into one UDF finder
DefaultUDFFinder | Default UDF finder - for adding your own user defined functions.


org.apache.poi.ss.formula.udf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.formula.udf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.udf.AggregatingUDFFinder (implements org.apache.poi.ss.formula.udf.UDFFinder)
    • org.apache.poi.ss.formula.udf.DefaultUDFFinder (implements org.apache.poi.ss.formula.udf.UDFFinder)

Interface Hierarchy

  • org.apache.poi.ss.formula.udf.UDFFinder


Uses of Package org.apache.poi.ss.formula.udf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.formula.udf

Packages that use org.apache.poi.ss.formula.udf
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.atp |
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.formula.udf |
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.model |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.hssf.model
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.hssf.usermodel
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.ss.formula
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.ss.formula.atp
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.ss.formula.eval.forked
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.ss.formula.udf
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.ss.usermodel
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.xssf.model
AggregatingUDFFinder
Collects add-in libraries and VB macro functions together into one UDF finder
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.xssf.streaming
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Classes in org.apache.poi.ss.formula.udf used by org.apache.poi.xssf.usermodel
UDFFinder
Common interface for "Add-in" libraries and user defined function libraries.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


UDFFinder

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.formula.udf
Interface UDFFinder

All Known Implementing Classes:
AggregatingUDFFinder, AnalysisToolPak, DefaultUDFFinder, IndexedUDFFinder
public interface UDFFinder

Common interface for "Add-in" libraries and user defined function libraries.

Author:
PUdalau

Field Summary
static UDFFinder DEFAULT
Method Summary
 FreeRefFunction findFunction(java.lang.String name)
Returns executor by specified name.

Field Detail

DEFAULT

static final UDFFinder DEFAULT
Method Detail

findFunction

FreeRefFunction findFunction(java.lang.String name)
Returns executor by specified name. Returns null if the function name is unknown.

Parameters:
name - Name of function.
Returns:
Function executor.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.ss.formula.udf.AggregatingUDFFinder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.udf.AggregatingUDFFinder

Packages that use AggregatingUDFFinder
org.apache.poi.xssf.model

Uses of AggregatingUDFFinder in org.apache.poi.xssf.model

Subclasses of AggregatingUDFFinder in org.apache.poi.xssf.model
 class IndexedUDFFinder
A UDFFinder that can retrieve functions both by name and by fake index.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.formula.udf.DefaultUDFFinder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.formula.udf.DefaultUDFFinder

No usage of org.apache.poi.ss.formula.udf.DefaultUDFFinder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.formula.udf.UDFFinder

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.formula.udf.UDFFinder

Packages that use UDFFinder
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.atp |
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.formula.udf |
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.model |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of UDFFinder in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model with parameters of type UDFFinder
 NameXPtg InternalWorkbook.getNameXPtg(java.lang.String name, UDFFinder udf)

Uses of UDFFinder in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return UDFFinder
 UDFFinder HSSFEvaluationWorkbook.getUDFFinder()

Methods in org.apache.poi.hssf.usermodel with parameters of type UDFFinder
void | HSSFWorkbook.addToolPack(UDFFinder toopack) Register a new toolpack in this workbook.
static HSSFFormulaEvaluator | HSSFFormulaEvaluator.create(HSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Uses of UDFFinder in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return UDFFinder
 UDFFinder EvaluationWorkbook.getUDFFinder()

Constructors in org.apache.poi.ss.formula with parameters of type UDFFinder
WorkbookEvaluator(EvaluationWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Uses of UDFFinder in org.apache.poi.ss.formula.atp

Classes in org.apache.poi.ss.formula.atp that implement UDFFinder
 class AnalysisToolPak

Fields in org.apache.poi.ss.formula.atp declared as UDFFinder
static UDFFinder AnalysisToolPak.instance

Uses of UDFFinder in org.apache.poi.ss.formula.eval.forked

Methods in org.apache.poi.ss.formula.eval.forked with parameters of type UDFFinder
static ForkedEvaluator ForkedEvaluator.create(Workbook wb, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Uses of UDFFinder in org.apache.poi.ss.formula.udf

Classes in org.apache.poi.ss.formula.udf that implement UDFFinder
class | AggregatingUDFFinder Collects add-in libraries and VB macro functions together into one UDF finder
class | DefaultUDFFinder Default UDF finder - for adding your own user defined functions.

Fields in org.apache.poi.ss.formula.udf declared as UDFFinder
static UDFFinder UDFFinder.DEFAULT

Methods in org.apache.poi.ss.formula.udf with parameters of type UDFFinder
 void AggregatingUDFFinder.add(UDFFinder toolPack)
Add a new toolpack

Constructors in org.apache.poi.ss.formula.udf with parameters of type UDFFinder
AggregatingUDFFinder(UDFFinder... usedToolPacks)

Uses of UDFFinder in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel with parameters of type UDFFinder
 void Workbook.addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.

Uses of UDFFinder in org.apache.poi.xssf.model

Classes in org.apache.poi.xssf.model that implement UDFFinder
 class IndexedUDFFinder
A UDFFinder that can retrieve functions both by name and by fake index.

Constructors in org.apache.poi.xssf.model with parameters of type UDFFinder
IndexedUDFFinder(UDFFinder... usedToolPacks)

Uses of UDFFinder in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming with parameters of type UDFFinder
 void SXSSFWorkbook.addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.

Uses of UDFFinder in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return UDFFinder
 UDFFinder XSSFEvaluationWorkbook.getUDFFinder()

Methods in org.apache.poi.xssf.usermodel with parameters of type UDFFinder
void | XSSFWorkbook.addToolPack(UDFFinder toopack) Register a new toolpack in this workbook.
static XSSFFormulaEvaluator | XSSFFormulaEvaluator.create(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AutoFilter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface AutoFilter

All Known Implementing Classes:
HSSFAutoFilter, XSSFAutoFilter
public interface AutoFilter

Represents autofiltering for the specified worksheet.

Filtering data is a quick and easy way to find and work with a subset of data in a range of cells or table. For example, you can filter to see only the values that you specify, filter to see the top or bottom values, or filter to quickly see duplicate values.

TODO YK: For now (Aug 2010) POI only supports setting a basic autofilter on a range of cells. In future, when we support more auto-filter functions like custom criteria, sort, etc. we will add corresponding methods to this interface.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BorderFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface BorderFormatting

All Known Implementing Classes:
HSSFBorderFormatting, XSSFBorderFormatting
public interface BorderFormatting

Author:
Dmitriy Kumshayev, Yegor Kozlov

Field Summary
static short | BORDER_DASH_DOT dash-dot border
static short | BORDER_DASH_DOT_DOT dash-dot-dot border
static short | BORDER_DASHED dash border
static short | BORDER_DOTTED hair-line border
static short | BORDER_DOUBLE double-line border
static short | BORDER_HAIR dot border
static short | BORDER_MEDIUM Medium border
static short | BORDER_MEDIUM_DASH_DOT medium dash-dot border
static short | BORDER_MEDIUM_DASH_DOT_DOT medium dash-dot-dot border
static short | BORDER_MEDIUM_DASHED Medium dashed border
static short | BORDER_NONE No border
static short | BORDER_SLANTED_DASH_DOT slanted dash-dot border
static short | BORDER_THICK Thick border
static short | BORDER_THIN Thin border
Method Summary
short | getBorderBottom()
short | getBorderDiagonal()
short | getBorderLeft()
short | getBorderRight()
short | getBorderTop()
short | getBottomBorderColor()
short | getDiagonalBorderColor()
short | getLeftBorderColor()
short | getRightBorderColor()
short | getTopBorderColor()
void | setBorderBottom(short border)
void | setBorderDiagonal(short border) Set diagonal border.
void | setBorderLeft(short border) Set left border.
void | setBorderRight(short border) Set right border.
void | setBorderTop(short border) Set top border.
void | setBottomBorderColor(short color)
void | setDiagonalBorderColor(short color)
void | setLeftBorderColor(short color)
void | setRightBorderColor(short color)
void | setTopBorderColor(short color)

Field Detail

BORDER_NONE

static final short BORDER_NONE
No border

See Also:
Constant Field Values

BORDER_THIN

static final short BORDER_THIN
Thin border

See Also:
Constant Field Values

BORDER_MEDIUM

static final short BORDER_MEDIUM
Medium border

See Also:
Constant Field Values

BORDER_DASHED

static final short BORDER_DASHED
dash border

See Also:
Constant Field Values

BORDER_HAIR

static final short BORDER_HAIR
dot border

See Also:
Constant Field Values

BORDER_THICK

static final short BORDER_THICK
Thick border

See Also:
Constant Field Values

BORDER_DOUBLE

static final short BORDER_DOUBLE
double-line border

See Also:
Constant Field Values

BORDER_DOTTED

static final short BORDER_DOTTED
hair-line border

See Also:
Constant Field Values

BORDER_MEDIUM_DASHED

static final short BORDER_MEDIUM_DASHED
Medium dashed border

See Also:
Constant Field Values

BORDER_DASH_DOT

static final short BORDER_DASH_DOT
dash-dot border

See Also:
Constant Field Values

BORDER_MEDIUM_DASH_DOT

static final short BORDER_MEDIUM_DASH_DOT
medium dash-dot border

See Also:
Constant Field Values

BORDER_DASH_DOT_DOT

static final short BORDER_DASH_DOT_DOT
dash-dot-dot border

See Also:
Constant Field Values

BORDER_MEDIUM_DASH_DOT_DOT

static final short BORDER_MEDIUM_DASH_DOT_DOT
medium dash-dot-dot border

See Also:
Constant Field Values

BORDER_SLANTED_DASH_DOT

static final short BORDER_SLANTED_DASH_DOT
slanted dash-dot border

See Also:
Constant Field Values
Method Detail

getBorderBottom

short getBorderBottom()

getBorderDiagonal

short getBorderDiagonal()

getBorderLeft

short getBorderLeft()

getBorderRight

short getBorderRight()

getBorderTop

short getBorderTop()

getBottomBorderColor

short getBottomBorderColor()

getDiagonalBorderColor

short getDiagonalBorderColor()

getLeftBorderColor

short getLeftBorderColor()

getRightBorderColor

short getRightBorderColor()

getTopBorderColor

short getTopBorderColor()

setBorderBottom

void setBorderBottom(short border)

setBorderDiagonal

void setBorderDiagonal(short border)
Set diagonal border.

Parameters:
border - MUST be a BORDER_* constant

setBorderLeft

void setBorderLeft(short border)
Set left border.

Parameters:
border - MUST be a BORDER_* constant

setBorderRight

void setBorderRight(short border)
Set right border.

Parameters:
border - MUST be a BORDER_* constant

setBorderTop

void setBorderTop(short border)
Set top border.

Parameters:
border - MUST be a BORDER_* constant

setBottomBorderColor

void setBottomBorderColor(short color)

setDiagonalBorderColor

void setDiagonalBorderColor(short color)

setLeftBorderColor

void setLeftBorderColor(short color)

setRightBorderColor

void setRightBorderColor(short color)

setTopBorderColor

void setTopBorderColor(short color)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BorderStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum BorderStyle

java.lang.Object
    extended by  java.lang.Enum<BorderStyle>
        extended by  org.apache.poi.ss.usermodel.BorderStyle
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BorderStyle>
public enum BorderStyle
extends java.lang.Enum<BorderStyle>

The enumeration value indicating the line style of a border in a cell, i.e., whether it is borded dash dot, dash dot dot, dashed, dotted, double, hair, medium, medium dash dot, medium dash dot dot, medium dashed, none, slant dash dot, thick or thin.

Enum Constant Summary
DASH_DOT
dash-dot border
DASH_DOT_DOT
dash-dot-dot border
DASHED
dash border
DOTTED
hair-line border
DOUBLE
double-line border
HAIR
dot border
MEDIUM
Medium border
MEDIUM_DASH_DOT
medium dash-dot border
MEDIUM_DASH_DOT_DOTC
medium dash-dot-dot border
MEDIUM_DASHED
Medium dashed border
NONE
No border
SLANTED_DASH_DOT
slanted dash-dot border
THICK
Thick border
THIN
Thin border
Method Summary
static BorderStyle | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BorderStyle[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final BorderStyle NONE
No border

THIN

public static final BorderStyle THIN
Thin border

MEDIUM

public static final BorderStyle MEDIUM
Medium border

DASHED

public static final BorderStyle DASHED
dash border

HAIR

public static final BorderStyle HAIR
dot border

THICK

public static final BorderStyle THICK
Thick border

DOUBLE

public static final BorderStyle DOUBLE
double-line border

DOTTED

public static final BorderStyle DOTTED
hair-line border

MEDIUM_DASHED

public static final BorderStyle MEDIUM_DASHED
Medium dashed border

DASH_DOT

public static final BorderStyle DASH_DOT
dash-dot border

MEDIUM_DASH_DOT

public static final BorderStyle MEDIUM_DASH_DOT
medium dash-dot border

DASH_DOT_DOT

public static final BorderStyle DASH_DOT_DOT
dash-dot-dot border

MEDIUM_DASH_DOT_DOTC

public static final BorderStyle MEDIUM_DASH_DOT_DOTC
medium dash-dot-dot border

SLANTED_DASH_DOT

public static final BorderStyle SLANTED_DASH_DOT
slanted dash-dot border

Method Detail

values

public static BorderStyle[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (BorderStyle c : BorderStyle.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static BorderStyle valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


BuiltinFormats

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class BuiltinFormats

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.BuiltinFormats

public final class BuiltinFormats
extends java.lang.Object

Utility to identify built-in formats. The following is a list of the formats as returned by this class.

0, "General"
1, "0"
2, "0.00"
3, "#,##0"
4, "#,##0.00"
5, "$#,##0_);($#,##0)"
6, "$#,##0_);[Red]($#,##0)"
7, "$#,##0.00);($#,##0.00)"
8, "$#,##0.00_);[Red]($#,##0.00)"
9, "0%"
0xa, "0.00%"
0xb, "0.00E+00"
0xc, "# ?/?"
0xd, "# ??/??"
0xe, "m/d/yy"
0xf, "d-mmm-yy"
0x10, "d-mmm"
0x11, "mmm-yy"
0x12, "h:mm AM/PM"
0x13, "h:mm:ss AM/PM"
0x14, "h:mm"
0x15, "h:mm:ss"
0x16, "m/d/yy h:mm"

// 0x17 - 0x24 reserved for international and undocumented 0x25, "#,##0_);(#,##0)"
0x26, "#,##0_);[Red](#,##0)"
0x27, "#,##0.00_);(#,##0.00)"
0x28, "#,##0.00_);[Red](#,##0.00)"
0x29, "_(*#,##0_);_(*(#,##0);_(* \"-\"_);_(@_)"
0x2a, "_($*#,##0_);_($*(#,##0);_($* \"-\"_);_(@_)"
0x2b, "_(*#,##0.00_);_(*(#,##0.00);_(*\"-\"??_);_(@_)"
0x2c, "_($*#,##0.00_);_($*(#,##0.00);_($*\"-\"??_);_(@_)"
0x2d, "mm:ss"
0x2e, "[h]:mm:ss"
0x2f, "mm:ss.0"
0x30, "##0.0E+0"
0x31, "@" - This is text format.
0x31 "text" - Alias for "@"

Author:
Yegor Kozlov Modified 6/17/09 by Stanislav Shor - positive formats don't need starting '('

Field Summary
static int FIRST_USER_DEFINED_FORMAT_INDEX
The first user-defined format starts at 164.
Constructor Summary
BuiltinFormats()
Method Summary
static java.lang.String[] getAll()
static java.lang.String getBuiltinFormat(int index)
Get the format string that matches the given format index
static int getBuiltinFormat(java.lang.String pFmt)
Get the format index that matches the given format string

Automatically converts "text" to excel's format string to represent text.

static java.util.Map<java.lang.Integer,java.lang.String> getBuiltinFormats()
Deprecated. (May 2009) use getAll()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FIRST_USER_DEFINED_FORMAT_INDEX

public static final int FIRST_USER_DEFINED_FORMAT_INDEX
The first user-defined format starts at 164.

See Also:
Constant Field Values
Constructor Detail

BuiltinFormats

public BuiltinFormats()
Method Detail

getBuiltinFormats

public static java.util.Map<java.lang.Integer,java.lang.String> getBuiltinFormats()
Deprecated. (May 2009) use getAll()

getAll

public static java.lang.String[] getAll()
Returns:
array of built-in data formats

getBuiltinFormat

public static java.lang.String getBuiltinFormat(int index)
Get the format string that matches the given format index

Parameters:
index - of a built in format
Returns:
string represented at index of format or null if there is not a built-in format at that index

getBuiltinFormat

public static int getBuiltinFormat(java.lang.String pFmt)
Get the format index that matches the given format string

Automatically converts "text" to excel's format string to represent text.

Parameters:
pFmt - string matching a built-in format
Returns:
index of format or -1 if undefined.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Cell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Cell

All Known Implementing Classes:
HSSFCell, SXSSFCell, XSSFCell
public interface Cell

High level representation of a cell in a row of a spreadsheet.

Cells can be numeric, formula-based or string-based (text). The cell type specifies this. String cells cannot conatin numbers and numeric cells cannot contain strings (at least according to our model). Client apps should do the conversions themselves. Formula cells have the formula string, as well as the formula result, which can be numeric or string.

Cells should have their number (0 based) before being added to a row.

Field Summary
static int | CELL_TYPE_BLANK Blank Cell type (3)
static int | CELL_TYPE_BOOLEAN Boolean Cell type (4)
static int | CELL_TYPE_ERROR Error Cell type (5)
static int | CELL_TYPE_FORMULA Formula Cell type (2)
static int | CELL_TYPE_NUMERIC Numeric Cell type (0)
static int | CELL_TYPE_STRING String Cell type (1)
Method Summary
 CellRangeAddress getArrayFormulaRange()
Only valid for array formula cells
 boolean getBooleanCellValue()
Get the value of the cell as a boolean.
 int getCachedFormulaResultType()
Only valid for formula cells
 Comment getCellComment()
Returns comment associated with this cell
 java.lang.String getCellFormula()
Return a formula for the cell, for example, SUM(C4:E4)
 CellStyle getCellStyle()
Return the cell's style.
 int getCellType()
Return the cell type.
 int getColumnIndex()
Returns column index of this cell
 java.util.Date getDateCellValue()
Get the value of the cell as a date.
 byte getErrorCellValue()
Get the value of the cell as an error code.
 Hyperlink getHyperlink()
 double getNumericCellValue()
Get the value of the cell as a number.
 RichTextString getRichStringCellValue()
Get the value of the cell as a XSSFRichTextString
 Row getRow()
Returns the Row this cell belongs to
 int getRowIndex()
Returns row index of a row in the sheet that contains this cell
 Sheet getSheet()
Returns the sheet this cell belongs to
 java.lang.String getStringCellValue()
Get the value of the cell as a string
 boolean isPartOfArrayFormulaGroup()
 void removeCellComment()
Removes the comment for this cell, if there is one.
 void setAsActiveCell()
Sets this cell as the active cell for the worksheet
 void setCellComment(Comment comment)
Assign a comment to this cell
 void setCellErrorValue(byte value)
Set a error value for the cell
 void setCellFormula(java.lang.String formula)
Sets formula for this cell.
 void setCellStyle(CellStyle style)
Set the style for the cell.
 void setCellType(int cellType)
Set the cells type (numeric, formula or string)
 void setCellValue(boolean value)
Set a boolean value for the cell
 void setCellValue(java.util.Calendar value)
Set a date value for the cell.
 void setCellValue(java.util.Date value)
Converts the supplied date to its equivalent Excel numeric value and sets that into the cell.
 void setCellValue(double value)
Set a numeric value for the cell
 void setCellValue(RichTextString value)
Set a rich string value for the cell.
 void setCellValue(java.lang.String value)
Set a string value for the cell.
 void setHyperlink(Hyperlink link)
Assign a hyperlink to this cell

Field Detail

CELL_TYPE_NUMERIC

static final int CELL_TYPE_NUMERIC
Numeric Cell type (0)

See Also:
setCellType(int), getCellType(), Constant Field Values

CELL_TYPE_STRING

static final int CELL_TYPE_STRING
String Cell type (1)

See Also:
setCellType(int), getCellType(), Constant Field Values

CELL_TYPE_FORMULA

static final int CELL_TYPE_FORMULA
Formula Cell type (2)

See Also:
setCellType(int), getCellType(), Constant Field Values

CELL_TYPE_BLANK

static final int CELL_TYPE_BLANK
Blank Cell type (3)

See Also:
setCellType(int), getCellType(), Constant Field Values

CELL_TYPE_BOOLEAN

static final int CELL_TYPE_BOOLEAN
Boolean Cell type (4)

See Also:
setCellType(int), getCellType(), Constant Field Values

CELL_TYPE_ERROR

static final int CELL_TYPE_ERROR
Error Cell type (5)

See Also:
setCellType(int), getCellType(), Constant Field Values
Method Detail

getColumnIndex

int getColumnIndex()
Returns column index of this cell

Returns:
zero-based column index of a column in a sheet.

getRowIndex

int getRowIndex()
Returns row index of a row in the sheet that contains this cell

Returns:
zero-based row index of a row in the sheet that contains this cell

getSheet

Sheet getSheet()
Returns the sheet this cell belongs to

Returns:
the sheet this cell belongs to

getRow

Row getRow()
Returns the Row this cell belongs to

Returns:
the Row that owns this cell

setCellType

void setCellType(int cellType)
Set the cells type (numeric, formula or string)

Throws:
java.lang.IllegalArgumentException - if the specified cell type is invalid
See Also:
CELL_TYPE_NUMERIC, CELL_TYPE_STRING, CELL_TYPE_FORMULA, CELL_TYPE_BLANK, CELL_TYPE_BOOLEAN, CELL_TYPE_ERROR

getCellType

int getCellType()
Return the cell type.

Returns:
the cell type
See Also:
CELL_TYPE_BLANK, CELL_TYPE_NUMERIC, CELL_TYPE_STRING, CELL_TYPE_FORMULA, CELL_TYPE_BOOLEAN, CELL_TYPE_ERROR

getCachedFormulaResultType

int getCachedFormulaResultType()
Only valid for formula cells

Returns:
one of (CELL_TYPE_NUMERIC, CELL_TYPE_STRING, CELL_TYPE_BOOLEAN, CELL_TYPE_ERROR) depending on the cached value of the formula

setCellValue

void setCellValue(double value)
Set a numeric value for the cell

Parameters:
value - the numeric value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numeric cell and set its value.

setCellValue

void setCellValue(java.util.Date value)
Converts the supplied date to its equivalent Excel numeric value and sets that into the cell.

Note - There is actually no 'DATE' cell type in Excel. In many cases (when entering date values), Excel automatically adjusts the cell style to some date format, creating the illusion that the cell data type is now something besides CELL_TYPE_NUMERIC. POI does not attempt to replicate this behaviour. To make a numeric cell display as a date, use setCellStyle(CellStyle) etc.

Parameters:
value - the numeric value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numerics cell and set its value.

setCellValue

void setCellValue(java.util.Calendar value)
Set a date value for the cell. Excel treats dates as numeric so you will need to format the cell as a date.

This will set the cell value based on the Calendar's timezone. As Excel does not support timezones this means that both 20:00+03:00 and 20:00-03:00 will be reported as the same value (20:00) even that there are 6 hours difference between the two times. This difference can be preserved by using setCellValue(value.getTime()) which will automatically shift the times to the default timezone.

Parameters:
value - the date value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For othertypes we will change the cell to a numeric cell and set its value.

setCellValue

void setCellValue(RichTextString value)
Set a rich string value for the cell.

Parameters:
value - value to set the cell to. For formulas we'll set the formula string, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

setCellValue

void setCellValue(java.lang.String value)
Set a string value for the cell.

Parameters:
value - value to set the cell to. For formulas we'll set the formula string, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

setCellFormula

void setCellFormula(java.lang.String formula)
                    throws FormulaParseException
Sets formula for this cell.

Note, this method only sets the formula string and does not calculate the formula value. To set the precalculated value use setCellValue(double) or setCellValue(String)

Parameters:
formula - the formula to set, e.g. "SUM(C4:E4)". If the argument is null then the current formula is removed.
Throws:
FormulaParseException - if the formula has incorrect syntax or is otherwise invalid

getCellFormula

java.lang.String getCellFormula()
Return a formula for the cell, for example, SUM(C4:E4)

Returns:
a formula for the cell
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is not CELL_TYPE_FORMULA

getNumericCellValue

double getNumericCellValue()
Get the value of the cell as a number.

For strings we throw an exception. For blank cells we return a 0. For formulas or error cells we return the precalculated value;

Returns:
the value of the cell as a number
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is CELL_TYPE_STRING
java.lang.NumberFormatException - if the cell value isn't a parsable double.
See Also:
for turning this number into a string similar to that which Excel would render this number as.

getDateCellValue

java.util.Date getDateCellValue()
Get the value of the cell as a date.

For strings we throw an exception. For blank cells we return a null.

Returns:
the value of the cell as a date
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is CELL_TYPE_STRING
java.lang.NumberFormatException - if the cell value isn't a parsable double.
See Also:
for formatting this date into a string similar to how excel does.

getRichStringCellValue

RichTextString getRichStringCellValue()
Get the value of the cell as a XSSFRichTextString

For numeric cells we throw an exception. For blank cells we return an empty string. For formula cells we return the pre-calculated value if a string, otherwise an exception.

Returns:
the value of the cell as a XSSFRichTextString

getStringCellValue

java.lang.String getStringCellValue()
Get the value of the cell as a string

For numeric cells we throw an exception. For blank cells we return an empty string. For formulaCells that are not string Formulas, we throw an exception.

Returns:
the value of the cell as a string

setCellValue

void setCellValue(boolean value)
Set a boolean value for the cell

Parameters:
value - the boolean value to set this cell to. For formulas we'll set the precalculated value, for booleans we'll set its value. For other types we will change the cell to a boolean cell and set its value.

setCellErrorValue

void setCellErrorValue(byte value)
Set a error value for the cell

Parameters:
value - the error value to set this cell to. For formulas we'll set the precalculated value , for errors we'll set its value. For other types we will change the cell to an error cell and set its value.
See Also:
FormulaError

getBooleanCellValue

boolean getBooleanCellValue()
Get the value of the cell as a boolean.

For strings, numbers, and errors, we throw an exception. For blank cells we return a false.

Returns:
the value of the cell as a boolean
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is not CELL_TYPE_BOOLEAN, CELL_TYPE_BLANK or CELL_TYPE_FORMULA

getErrorCellValue

byte getErrorCellValue()
Get the value of the cell as an error code.

For strings, numbers, and booleans, we throw an exception. For blank cells we return a 0.

Returns:
the value of the cell as an error code
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() isn't CELL_TYPE_ERROR
See Also:
for error codes

setCellStyle

void setCellStyle(CellStyle style)
Set the style for the cell. The style should be an CellStyle created/retreived from the Workbook.

Parameters:
style - reference contained in the workbook. If the value is null then the style information is removed causing the cell to used the default workbook style.
See Also:
Workbook.createCellStyle()

getCellStyle

CellStyle getCellStyle()
Return the cell's style.

Returns:
the cell's style. Always not-null. Default cell style has zero index and can be obtained as workbook.getCellStyleAt(0)
See Also:
Workbook.getCellStyleAt(short)

setAsActiveCell

void setAsActiveCell()
Sets this cell as the active cell for the worksheet

setCellComment

void setCellComment(Comment comment)
Assign a comment to this cell

Parameters:
comment - comment associated with this cell

getCellComment

Comment getCellComment()
Returns comment associated with this cell

Returns:
comment associated with this cell or null if not found

removeCellComment

void removeCellComment()
Removes the comment for this cell, if there is one.

getHyperlink

Hyperlink getHyperlink()
Returns:
hyperlink associated with this cell or null if not found

setHyperlink

void setHyperlink(Hyperlink link)
Assign a hyperlink to this cell

Parameters:
link - hyperlink associated with this cell

getArrayFormulaRange

CellRangeAddress getArrayFormulaRange()
Only valid for array formula cells

Returns:
range of the array formula group that the cell belongs to.

isPartOfArrayFormulaGroup

boolean isPartOfArrayFormulaGroup()
Returns:
true if this cell is part of group of cells having a common array formula.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellRange

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface CellRange<C extends Cell>

All Superinterfaces:
java.lang.Iterable<C>
All Known Implementing Classes:
SSCellRange
public interface CellRange<C extends Cell>
extends java.lang.Iterable<C>

Represents a rectangular region of a Sheet

Author:
Josh Micich

Method Summary
C | getCell(int relativeRowIndex, int relativeColumnIndex)
C[][] | getCells()
C[] | getFlattenedCells()
int | getHeight()
java.lang.String | getReferenceText()
C | getTopLeftCell()
int | getWidth()
java.util.Iterator<C> | iterator()
int | size() Gets the number of cells in this range.

Method Detail

getWidth

int getWidth()

getHeight

int getHeight()

size

int size()
Gets the number of cells in this range.

Returns:
height * width

getReferenceText

java.lang.String getReferenceText()

getTopLeftCell

C getTopLeftCell()
Returns:
the cell at relative coordinates (0,0). Never null.

getCell

C getCell(int relativeRowIndex,
          int relativeColumnIndex)
Parameters:
relativeRowIndex - must be between 0 and height-1
relativeColumnIndex - must be between 0 and width-1
Returns:
the cell at the specified coordinates. Never null.

getFlattenedCells

C[] getFlattenedCells()
Returns:
a flattened array of all the cells in this CellRange

getCells

C[][] getCells()
Returns:
a 2-D array of all the cells in this CellRange. The first array dimension is the row index (values 0...height-1) and the second dimension is the column index (values 0...width-1)

iterator

java.util.Iterator<C> iterator()
Specified by:
iterator in interface java.lang.Iterable<C extends Cell>
Returns:
an Iterator over all cells in this range. Iteration starts with all cells in the first row followed by all cells in the next row, etc.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface CellStyle

All Known Implementing Classes:
HSSFCellStyle, XSSFCellStyle
public interface CellStyle

Field Summary
static short | ALIGN_CENTER center horizontal alignment
static short | ALIGN_CENTER_SELECTION center-selection? horizontal alignment
static short | ALIGN_FILL fill? horizontal alignment
static short | ALIGN_GENERAL general (normal) horizontal alignment
static short | ALIGN_JUSTIFY justified horizontal alignment
static short | ALIGN_LEFT left-justified horizontal alignment
static short | ALIGN_RIGHT right-justified horizontal alignment
static short | ALT_BARS Wide dots
static short | BIG_SPOTS Large spots
static short | BORDER_DASH_DOT dash-dot border
static short | BORDER_DASH_DOT_DOT dash-dot-dot border
static short | BORDER_DASHED dash border
static short | BORDER_DOTTED hair-line border
static short | BORDER_DOUBLE double-line border
static short | BORDER_HAIR dot border
static short | BORDER_MEDIUM Medium border
static short | BORDER_MEDIUM_DASH_DOT medium dash-dot border
static short | BORDER_MEDIUM_DASH_DOT_DOT medium dash-dot-dot border
static short | BORDER_MEDIUM_DASHED Medium dashed border
static short | BORDER_NONE No border
static short | BORDER_SLANTED_DASH_DOT slanted dash-dot border
static short | BORDER_THICK Thick border
static short | BORDER_THIN Thin border
static short | BRICKS Brick-like layout
static short | DIAMONDS Diamonds
static short | FINE_DOTS Small fine dots
static short | LEAST_DOTS Least Dots
static short | LESS_DOTS Less Dots
static short | NO_FILL No background
static short | SOLID_FOREGROUND Solidly filled
static short | SPARSE_DOTS Sparse dots
static short | SQUARES Squares
static short | THICK_BACKWARD_DIAG Thick backward facing diagonals
static short | THICK_FORWARD_DIAG Thick forward facing diagonals
static short | THICK_HORZ_BANDS Thick horizontal bands
static short | THICK_VERT_BANDS Thick vertical bands
static short | THIN_BACKWARD_DIAG Thin backward diagonal
static short | THIN_FORWARD_DIAG Thin forward diagonal
static short | THIN_HORZ_BANDS Thin horizontal bands
static short | THIN_VERT_BANDS Thin vertical bands
static short | VERTICAL_BOTTOM bottom-aligned vertical alignment
static short | VERTICAL_CENTER center-aligned vertical alignment
static short | VERTICAL_JUSTIFY vertically justified vertical alignment
static short | VERTICAL_TOP top-aligned vertical alignment
Method Summary
void | cloneStyleFrom(CellStyle source) Clones all the style information from another CellStyle, onto this one.
short | getAlignment() get the type of horizontal alignment for the cell
short | getBorderBottom() get the type of border to use for the bottom border of the cell
short | getBorderLeft() get the type of border to use for the left border of the cell
short | getBorderRight() get the type of border to use for the right border of the cell
short | getBorderTop() get the type of border to use for the top border of the cell
short | getBottomBorderColor() get the color to use for the left border
short | getDataFormat() get the index of the format
java.lang.String | getDataFormatString() Get the format string
short | getFillBackgroundColor() get the background fill color, if the fill is defined with an indexed color.
Color | getFillBackgroundColorColor() Gets the color object representing the current background fill, resolving indexes using the supplied workbook.
short | getFillForegroundColor() get the foreground fill color, if the fill is defined with an indexed color.
Color | getFillForegroundColorColor() Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook.
short | getFillPattern() get the fill pattern (??) - set to 1 to fill with foreground color
short | getFontIndex() gets the index of the font for this style
boolean | getHidden() get whether the cell's using this style are to be hidden
short | getIndention() get the number of spaces to indent the text in the cell
short | getIndex() get the index within the Workbook (sequence within the collection of ExtnededFormat objects)
short | getLeftBorderColor() get the color to use for the left border
boolean | getLocked() get whether the cell's using this style are to be locked
short | getRightBorderColor() get the color to use for the left border
short | getRotation() get the degree of rotation for the text in the cell
short | getTopBorderColor() get the color to use for the top border
short | getVerticalAlignment() get the type of vertical alignment for the cell
boolean | getWrapText() get whether the text should be wrapped
void | setAlignment(short align) set the type of horizontal alignment for the cell
void | setBorderBottom(short border) set the type of border to use for the bottom border of the cell
void | setBorderLeft(short border) set the type of border to use for the left border of the cell
void | setBorderRight(short border) set the type of border to use for the right border of the cell
void | setBorderTop(short border) set the type of border to use for the top border of the cell
void | setBottomBorderColor(short color) set the color to use for the bottom border
void | setDataFormat(short fmt) set the data format (must be a valid format)
void | setFillBackgroundColor(short bg) set the background fill color.
void | setFillForegroundColor(short bg) set the foreground fill color Note: Ensure Foreground color is set prior to background color.
void | setFillPattern(short fp) setting to one fills the cell with the foreground color...
void | setFont(Font font) set the font for this style
void | setHidden(boolean hidden) set the cell's using this style to be hidden
void | setIndention(short indent) set the number of spaces to indent the text in the cell
void | setLeftBorderColor(short color) set the color to use for the left border
void | setLocked(boolean locked) set the cell's using this style to be locked
void | setRightBorderColor(short color) set the color to use for the right border
void | setRotation(short rotation) set the degree of rotation for the text in the cell
void | setTopBorderColor(short color) set the color to use for the top border
void | setVerticalAlignment(short align) set the type of vertical alignment for the cell
void | setWrapText(boolean wrapped) Set whether the text should be wrapped.

Field Detail

ALIGN_GENERAL

static final short ALIGN_GENERAL
general (normal) horizontal alignment

See Also:
Constant Field Values

ALIGN_LEFT

static final short ALIGN_LEFT
left-justified horizontal alignment

See Also:
Constant Field Values

ALIGN_CENTER

static final short ALIGN_CENTER
center horizontal alignment

See Also:
Constant Field Values

ALIGN_RIGHT

static final short ALIGN_RIGHT
right-justified horizontal alignment

See Also:
Constant Field Values

ALIGN_FILL

static final short ALIGN_FILL
fill? horizontal alignment

See Also:
Constant Field Values

ALIGN_JUSTIFY

static final short ALIGN_JUSTIFY
justified horizontal alignment

See Also:
Constant Field Values

ALIGN_CENTER_SELECTION

static final short ALIGN_CENTER_SELECTION
center-selection? horizontal alignment

See Also:
Constant Field Values

VERTICAL_TOP

static final short VERTICAL_TOP
top-aligned vertical alignment

See Also:
Constant Field Values

VERTICAL_CENTER

static final short VERTICAL_CENTER
center-aligned vertical alignment

See Also:
Constant Field Values

VERTICAL_BOTTOM

static final short VERTICAL_BOTTOM
bottom-aligned vertical alignment

See Also:
Constant Field Values

VERTICAL_JUSTIFY

static final short VERTICAL_JUSTIFY
vertically justified vertical alignment

See Also:
Constant Field Values

BORDER_NONE

static final short BORDER_NONE
No border

See Also:
Constant Field Values

BORDER_THIN

static final short BORDER_THIN
Thin border

See Also:
Constant Field Values

BORDER_MEDIUM

static final short BORDER_MEDIUM
Medium border

See Also:
Constant Field Values

BORDER_DASHED

static final short BORDER_DASHED
dash border

See Also:
Constant Field Values

BORDER_HAIR

static final short BORDER_HAIR
dot border

See Also:
Constant Field Values

BORDER_THICK

static final short BORDER_THICK
Thick border

See Also:
Constant Field Values

BORDER_DOUBLE

static final short BORDER_DOUBLE
double-line border

See Also:
Constant Field Values

BORDER_DOTTED

static final short BORDER_DOTTED
hair-line border

See Also:
Constant Field Values

BORDER_MEDIUM_DASHED

static final short BORDER_MEDIUM_DASHED
Medium dashed border

See Also:
Constant Field Values

BORDER_DASH_DOT

static final short BORDER_DASH_DOT
dash-dot border

See Also:
Constant Field Values

BORDER_MEDIUM_DASH_DOT

static final short BORDER_MEDIUM_DASH_DOT
medium dash-dot border

See Also:
Constant Field Values

BORDER_DASH_DOT_DOT

static final short BORDER_DASH_DOT_DOT
dash-dot-dot border

See Also:
Constant Field Values

BORDER_MEDIUM_DASH_DOT_DOT

static final short BORDER_MEDIUM_DASH_DOT_DOT
medium dash-dot-dot border

See Also:
Constant Field Values

BORDER_SLANTED_DASH_DOT

static final short BORDER_SLANTED_DASH_DOT
slanted dash-dot border

See Also:
Constant Field Values

NO_FILL

static final short NO_FILL
No background

See Also:
Constant Field Values

SOLID_FOREGROUND

static final short SOLID_FOREGROUND
Solidly filled

See Also:
Constant Field Values

FINE_DOTS

static final short FINE_DOTS
Small fine dots

See Also:
Constant Field Values

ALT_BARS

static final short ALT_BARS
Wide dots

See Also:
Constant Field Values

SPARSE_DOTS

static final short SPARSE_DOTS
Sparse dots

See Also:
Constant Field Values

THICK_HORZ_BANDS

static final short THICK_HORZ_BANDS
Thick horizontal bands

See Also:
Constant Field Values

THICK_VERT_BANDS

static final short THICK_VERT_BANDS
Thick vertical bands

See Also:
Constant Field Values

THICK_BACKWARD_DIAG

static final short THICK_BACKWARD_DIAG
Thick backward facing diagonals

See Also:
Constant Field Values

THICK_FORWARD_DIAG

static final short THICK_FORWARD_DIAG
Thick forward facing diagonals

See Also:
Constant Field Values

BIG_SPOTS

static final short BIG_SPOTS
Large spots

See Also:
Constant Field Values

BRICKS

static final short BRICKS
Brick-like layout

See Also:
Constant Field Values

THIN_HORZ_BANDS

static final short THIN_HORZ_BANDS
Thin horizontal bands

See Also:
Constant Field Values

THIN_VERT_BANDS

static final short THIN_VERT_BANDS
Thin vertical bands

See Also:
Constant Field Values

THIN_BACKWARD_DIAG

static final short THIN_BACKWARD_DIAG
Thin backward diagonal

See Also:
Constant Field Values

THIN_FORWARD_DIAG

static final short THIN_FORWARD_DIAG
Thin forward diagonal

See Also:
Constant Field Values

SQUARES

static final short SQUARES
Squares

See Also:
Constant Field Values

DIAMONDS

static final short DIAMONDS
Diamonds

See Also:
Constant Field Values

LESS_DOTS

static final short LESS_DOTS
Less Dots

See Also:
Constant Field Values

LEAST_DOTS

static final short LEAST_DOTS
Least Dots

See Also:
Constant Field Values
Method Detail

getIndex

short getIndex()
get the index within the Workbook (sequence within the collection of ExtnededFormat objects)

Returns:
unique index number of the underlying record this style represents (probably you don't care unless you're comparing which one is which)

setDataFormat

void setDataFormat(short fmt)
set the data format (must be a valid format)

See Also:
DataFormat

getDataFormat

short getDataFormat()
get the index of the format

See Also:
DataFormat

getDataFormatString

java.lang.String getDataFormatString()
Get the format string

setFont

void setFont(Font font)
set the font for this style

Parameters:
font - a font object created or retreived from the Workbook object
See Also:
Workbook.createFont(), Workbook.getFontAt(short)

getFontIndex

short getFontIndex()
gets the index of the font for this style

See Also:
Workbook.getFontAt(short)

setHidden

void setHidden(boolean hidden)
set the cell's using this style to be hidden

Parameters:
hidden - - whether the cell using this style should be hidden

getHidden

boolean getHidden()
get whether the cell's using this style are to be hidden

Returns:
hidden - whether the cell using this style should be hidden

setLocked

void setLocked(boolean locked)
set the cell's using this style to be locked

Parameters:
locked - - whether the cell using this style should be locked

getLocked

boolean getLocked()
get whether the cell's using this style are to be locked

Returns:
hidden - whether the cell using this style should be locked

setAlignment

void setAlignment(short align)
set the type of horizontal alignment for the cell

Parameters:
align - - the type of alignment
See Also:
ALIGN_GENERAL, ALIGN_LEFT, ALIGN_CENTER, ALIGN_RIGHT, ALIGN_FILL, ALIGN_JUSTIFY, ALIGN_CENTER_SELECTION

getAlignment

short getAlignment()
get the type of horizontal alignment for the cell

Returns:
align - the type of alignment
See Also:
ALIGN_GENERAL, ALIGN_LEFT, ALIGN_CENTER, ALIGN_RIGHT, ALIGN_FILL, ALIGN_JUSTIFY, ALIGN_CENTER_SELECTION

setWrapText

void setWrapText(boolean wrapped)
Set whether the text should be wrapped. Setting this flag to true make all content visible whithin a cell by displaying it on multiple lines

Parameters:
wrapped - wrap text or not

getWrapText

boolean getWrapText()
get whether the text should be wrapped

Returns:
wrap text or not

setVerticalAlignment

void setVerticalAlignment(short align)
set the type of vertical alignment for the cell

Parameters:
align - the type of alignment
See Also:
VERTICAL_TOP, VERTICAL_CENTER, VERTICAL_BOTTOM, VERTICAL_JUSTIFY

getVerticalAlignment

short getVerticalAlignment()
get the type of vertical alignment for the cell

Returns:
align the type of alignment
See Also:
VERTICAL_TOP, VERTICAL_CENTER, VERTICAL_BOTTOM, VERTICAL_JUSTIFY

setRotation

void setRotation(short rotation)
set the degree of rotation for the text in the cell

Parameters:
rotation - degrees (between -90 and 90 degrees)

getRotation

short getRotation()
get the degree of rotation for the text in the cell

Returns:
rotation degrees (between -90 and 90 degrees)

setIndention

void setIndention(short indent)
set the number of spaces to indent the text in the cell

Parameters:
indent - - number of spaces

getIndention

short getIndention()
get the number of spaces to indent the text in the cell

Returns:
indent - number of spaces

setBorderLeft

void setBorderLeft(short border)
set the type of border to use for the left border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderLeft

short getBorderLeft()
get the type of border to use for the left border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setBorderRight

void setBorderRight(short border)
set the type of border to use for the right border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderRight

short getBorderRight()
get the type of border to use for the right border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setBorderTop

void setBorderTop(short border)
set the type of border to use for the top border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderTop

short getBorderTop()
get the type of border to use for the top border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setBorderBottom

void setBorderBottom(short border)
set the type of border to use for the bottom border of the cell

Parameters:
border - type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

getBorderBottom

short getBorderBottom()
get the type of border to use for the bottom border of the cell

Returns:
border type
See Also:
BORDER_NONE, BORDER_THIN, BORDER_MEDIUM, BORDER_DASHED, BORDER_DOTTED, BORDER_THICK, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM_DASHED, BORDER_DASH_DOT, BORDER_MEDIUM_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_SLANTED_DASH_DOT

setLeftBorderColor

void setLeftBorderColor(short color)
set the color to use for the left border

Parameters:
color - The index of the color definition

getLeftBorderColor

short getLeftBorderColor()
get the color to use for the left border

setRightBorderColor

void setRightBorderColor(short color)
set the color to use for the right border

Parameters:
color - The index of the color definition

getRightBorderColor

short getRightBorderColor()
get the color to use for the left border

Returns:
the index of the color definition

setTopBorderColor

void setTopBorderColor(short color)
set the color to use for the top border

Parameters:
color - The index of the color definition

getTopBorderColor

short getTopBorderColor()
get the color to use for the top border

Returns:
hhe index of the color definition

setBottomBorderColor

void setBottomBorderColor(short color)
set the color to use for the bottom border

Parameters:
color - The index of the color definition

getBottomBorderColor

short getBottomBorderColor()
get the color to use for the left border

Returns:
the index of the color definition

setFillPattern

void setFillPattern(short fp)
setting to one fills the cell with the foreground color... No idea about other values

Parameters:
fp - fill pattern (set to 1 to fill w/foreground color)
See Also:
NO_FILL, SOLID_FOREGROUND, FINE_DOTS, ALT_BARS, SPARSE_DOTS, THICK_HORZ_BANDS, THICK_VERT_BANDS, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, BIG_SPOTS, BRICKS, THIN_HORZ_BANDS, THIN_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, SQUARES, DIAMONDS

getFillPattern

short getFillPattern()
get the fill pattern (??) - set to 1 to fill with foreground color

Returns:
fill pattern

setFillBackgroundColor

void setFillBackgroundColor(short bg)
set the background fill color.

Parameters:
bg - color

getFillBackgroundColor

short getFillBackgroundColor()
get the background fill color, if the fill is defined with an indexed color.

Returns:
fill color index, or 0 if not indexed (XSSF only)

getFillBackgroundColorColor

Color getFillBackgroundColorColor()
Gets the color object representing the current background fill, resolving indexes using the supplied workbook. This will work for both indexed and rgb defined colors.

setFillForegroundColor

void setFillForegroundColor(short bg)
set the foreground fill color Note: Ensure Foreground color is set prior to background color.

Parameters:
bg - color

getFillForegroundColor

short getFillForegroundColor()
get the foreground fill color, if the fill is defined with an indexed color.

Returns:
fill color, or 0 if not indexed (XSSF only)

getFillForegroundColorColor

Color getFillForegroundColorColor()
Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook. This will work for both indexed and rgb defined colors.

cloneStyleFrom

void cloneStyleFrom(CellStyle source)
Clones all the style information from another CellStyle, onto this one. This CellStyle will then have all the same properties as the source, but the two may be edited independently. Any stylings on this CellStyle will be lost! The source CellStyle could be from another Workbook if you like. This allows you to copy styles from one Workbook to another. However, both of the CellStyles will need to be of the same type (HSSFCellStyle or XSSFCellStyle)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellValue

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class CellValue

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.CellValue

public final class CellValue
extends java.lang.Object

Mimics the 'data view' of a cell. This allows formula evaluator to return a CellValue instead of precasting the value to String or Number or boolean type.

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >

Field Summary
static CellValue | FALSE
static CellValue | TRUE
Constructor Summary
CellValue(double numberValue)
CellValue(java.lang.String stringValue)
Method Summary
java.lang.String | formatAsString()
boolean | getBooleanValue()
int | getCellType()
static CellValue | getError(int errorCode)
byte | getErrorValue()
double | getNumberValue()
java.lang.String | getStringValue()
java.lang.String | toString()
static CellValue | valueOf(boolean booleanValue)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

TRUE

public static final CellValue TRUE

FALSE

public static final CellValue FALSE
Constructor Detail

CellValue

public CellValue(double numberValue)

CellValue

public CellValue(java.lang.String stringValue)
Method Detail

valueOf

public static CellValue valueOf(boolean booleanValue)

getError

public static CellValue getError(int errorCode)

getBooleanValue

public boolean getBooleanValue()
Returns:
Returns the booleanValue.

getNumberValue

public double getNumberValue()
Returns:
Returns the numberValue.

getStringValue

public java.lang.String getStringValue()
Returns:
Returns the stringValue.

getCellType

public int getCellType()
Returns:
Returns the cellType.

getErrorValue

public byte getErrorValue()
Returns:
Returns the errorValue.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

formatAsString

public java.lang.String formatAsString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Chart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Chart

All Superinterfaces:
ManuallyPositionable
All Known Implementing Classes:
XSSFChart
public interface Chart
extends ManuallyPositionable

High level representation of a chart.

Author:
Roman Kashitsyn

Method Summary
void | deleteLegend() Delete current chart legend.
java.util.List<? extends ChartAxis> | getAxis()
ChartAxisFactory | getChartAxisFactory()
ChartDataFactory | getChartDataFactory()
ChartLegend | getOrCreateLegend()
void | plot(ChartData data, ChartAxis... axis) Plots specified data on the chart.
Methods inherited from interface org.apache.poi.ss.usermodel.charts.ManuallyPositionable
getManualLayout

Method Detail

getChartDataFactory

ChartDataFactory getChartDataFactory()
Returns:
an appropriate ChartDataFactory implementation

getChartAxisFactory

ChartAxisFactory getChartAxisFactory()
Returns:
an appropriate ChartAxisFactory implementation

getOrCreateLegend

ChartLegend getOrCreateLegend()
Returns:
chart legend instance

deleteLegend

void deleteLegend()
Delete current chart legend.

getAxis

java.util.List<? extends ChartAxis> getAxis()
Returns:
list of all chart axis

plot

void plot(ChartData data,
          ChartAxis... axis)
Plots specified data on the chart.

Parameters:
data - a data to plot
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClientAnchor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface ClientAnchor

All Known Implementing Classes:
HSSFClientAnchor, XSSFClientAnchor
public interface ClientAnchor

A client anchor is attached to an excel worksheet. It anchors against a top-left and bottom-right cell.

Author:
Yegor Kozlov

Field Summary
static int | DONT_MOVE_AND_RESIZE Do Not Move or Resize With Underlying Rows/Columns
static int | MOVE_AND_RESIZE Move and Resize With Anchor Cells
static int | MOVE_DONT_RESIZE Move With Cells but Do Not Resize
Method Summary
int | getAnchorType() Gets the anchor type
short | getCol1() Returns the column (0 based) of the first cell.
short | getCol2() Returns the column (0 based) of the second cell.
int | getDx1() Returns the x coordinate within the first cell.
int | getDx2() Returns the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
int | getDy1() Returns the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
int | getDy2() Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
int | getRow1() Returns the row (0 based) of the first cell.
int | getRow2() Returns the row (0 based) of the second cell.
void | setAnchorType(int anchorType) Sets the anchor type
void | setCol1(int col1) Sets the column (0 based) of the first cell.
void | setCol2(int col2) Returns the column (0 based) of the second cell.
void | setDx1(int dx1) Sets the x coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
void | setDx2(int dx2) Sets the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
void | setDy1(int dy1) Sets the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
void | setDy2(int dy2) Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
void | setRow1(int row1) Returns the row (0 based) of the first cell.
void | setRow2(int row2) Returns the row (0 based) of the first cell.

Field Detail

MOVE_AND_RESIZE

static final int MOVE_AND_RESIZE
Move and Resize With Anchor Cells

Specifies that the current drawing shall move and resize to maintain its row and column anchors (i.e. the object is anchored to the actual from and to row and column)

See Also:
Constant Field Values

MOVE_DONT_RESIZE

static final int MOVE_DONT_RESIZE
Move With Cells but Do Not Resize

Specifies that the current drawing shall move with its row and column (i.e. the object is anchored to the actual from row and column), but that the size shall remain absolute.

If additional rows/columns are added between the from and to locations of the drawing, the drawing shall move its to anchors as needed to maintain this same absolute size.

See Also:
Constant Field Values

DONT_MOVE_AND_RESIZE

static final int DONT_MOVE_AND_RESIZE
Do Not Move or Resize With Underlying Rows/Columns

Specifies that the current start and end positions shall be maintained with respect to the distances from the absolute start point of the worksheet.

If additional rows/columns are added before the drawing, the drawing shall move its anchors as needed to maintain this same absolute position.

See Also:
Constant Field Values
Method Detail

getCol1

short getCol1()
Returns the column (0 based) of the first cell.

Returns:
0-based column of the first cell.

setCol1

void setCol1(int col1)
Sets the column (0 based) of the first cell.

Parameters:
col1 - 0-based column of the first cell.

getCol2

short getCol2()
Returns the column (0 based) of the second cell.

Returns:
0-based column of the second cell.

setCol2

void setCol2(int col2)
Returns the column (0 based) of the second cell.

Parameters:
col2 - 0-based column of the second cell.

getRow1

int getRow1()
Returns the row (0 based) of the first cell.

Returns:
0-based row of the first cell.

setRow1

void setRow1(int row1)
Returns the row (0 based) of the first cell.

Parameters:
row1 - 0-based row of the first cell.

getRow2

int getRow2()
Returns the row (0 based) of the second cell.

Returns:
0-based row of the second cell.

setRow2

void setRow2(int row2)
Returns the row (0 based) of the first cell.

Parameters:
row2 - 0-based row of the first cell.

getDx1

int getDx1()
Returns the x coordinate within the first cell. Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Returns:
the x coordinate within the first cell

setDx1

void setDx1(int dx1)
Sets the x coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Parameters:
dx1 - the x coordinate within the first cell

getDy1

int getDy1()
Returns the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Returns:
the y coordinate within the first cell

setDy1

void setDy1(int dy1)
Sets the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Parameters:
dy1 - the y coordinate within the first cell

getDy2

int getDy2()
Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Returns:
the y coordinate within the second cell

setDy2

void setDy2(int dy2)
Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Parameters:
dy2 - the y coordinate within the second cell

getDx2

int getDx2()
Returns the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Returns:
the x coordinate within the second cell

setDx2

void setDx2(int dx2)
Sets the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Parameters:
dx2 - the x coordinate within the second cell

setAnchorType

void setAnchorType(int anchorType)
Sets the anchor type

0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

Parameters:
anchorType - the anchor type
See Also:
MOVE_AND_RESIZE, MOVE_DONT_RESIZE, DONT_MOVE_AND_RESIZE

getAnchorType

int getAnchorType()
Gets the anchor type

0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

Returns:
the anchor type
See Also:
MOVE_AND_RESIZE, MOVE_DONT_RESIZE, DONT_MOVE_AND_RESIZE
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Color

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Color

All Known Implementing Classes:
HSSFColor, HSSFColor.AQUA, HSSFColor.AUTOMATIC, HSSFColor.BLACK, HSSFColor.BLUE, HSSFColor.BLUE_GREY, HSSFColor.BRIGHT_GREEN, HSSFColor.BROWN, HSSFColor.CORAL, HSSFColor.CORNFLOWER_BLUE, HSSFColor.DARK_BLUE, HSSFColor.DARK_GREEN, HSSFColor.DARK_RED, HSSFColor.DARK_TEAL, HSSFColor.DARK_YELLOW, HSSFColor.GOLD, HSSFColor.GREEN, HSSFColor.GREY_25_PERCENT, HSSFColor.GREY_40_PERCENT, HSSFColor.GREY_50_PERCENT, HSSFColor.GREY_80_PERCENT, HSSFColor.INDIGO, HSSFColor.LAVENDER, HSSFColor.LEMON_CHIFFON, HSSFColor.LIGHT_BLUE, HSSFColor.LIGHT_CORNFLOWER_BLUE, HSSFColor.LIGHT_GREEN, HSSFColor.LIGHT_ORANGE, HSSFColor.LIGHT_TURQUOISE, HSSFColor.LIGHT_YELLOW, HSSFColor.LIME, HSSFColor.MAROON, HSSFColor.OLIVE_GREEN, HSSFColor.ORANGE, HSSFColor.ORCHID, HSSFColor.PALE_BLUE, HSSFColor.PINK, HSSFColor.PLUM, HSSFColor.RED, HSSFColor.ROSE, HSSFColor.ROYAL_BLUE, HSSFColor.SEA_GREEN, HSSFColor.SKY_BLUE, HSSFColor.TAN, HSSFColor.TEAL, HSSFColor.TURQUOISE, HSSFColor.VIOLET, HSSFColor.WHITE, HSSFColor.YELLOW, XSSFColor
public interface Color

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Comment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Comment

All Known Implementing Classes:
HSSFComment, XSSFComment
public interface Comment

Method Summary
java.lang.String | getAuthor() Name of the original comment author
int | getColumn() Return the column of the cell that contains the comment
int | getRow() Return the row of the cell that contains the comment
RichTextString | getString() Fetches the rich text string of the comment
boolean | isVisible() Sets whether this comment is visible.
void | setAuthor(java.lang.String author) Name of the original comment author
void | setColumn(int col) Set the column of the cell that contains the comment
void | setRow(int row) Set the row of the cell that contains the comment
void | setString(RichTextString string) Sets the rich text string used by this comment.
void | setVisible(boolean visible) Returns whether this comment is visible.

Method Detail

setVisible

void setVisible(boolean visible)
Returns whether this comment is visible.

Parameters:
visible - true if the comment is visible, false otherwise

isVisible

boolean isVisible()
Sets whether this comment is visible.

Returns:
true if the comment is visible, false otherwise

getRow

int getRow()
Return the row of the cell that contains the comment

Returns:
the 0-based row of the cell that contains the comment

setRow

void setRow(int row)
Set the row of the cell that contains the comment

Parameters:
row - the 0-based row of the cell that contains the comment

getColumn

int getColumn()
Return the column of the cell that contains the comment

Returns:
the 0-based column of the cell that contains the comment

setColumn

void setColumn(int col)
Set the column of the cell that contains the comment

Parameters:
col - the 0-based column of the cell that contains the comment

getAuthor

java.lang.String getAuthor()
Name of the original comment author

Returns:
the name of the original author of the comment

setAuthor

void setAuthor(java.lang.String author)
Name of the original comment author

Parameters:
author - the name of the original author of the comment

getString

RichTextString getString()
Fetches the rich text string of the comment

setString

void setString(RichTextString string)
Sets the rich text string used by this comment.

Parameters:
string - Sets the rich text string used by this object.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComparisonOperator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class ComparisonOperator

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.ComparisonOperator

public final class ComparisonOperator
extends java.lang.Object

The conditional format operators used for "Highlight Cells That Contain..." rules.

For example, "highlight cells that begin with "M2" and contain "Mountain Gear".

Author:
Dmitriy Kumshayev, Yegor Kozlov

Field Summary
static byte | BETWEEN 'Between' operator
static byte | EQUAL 'Equal to' operator
static byte | GE 'Greater than or equal to' operator
static byte | GT 'Greater than' operator
static byte | LE 'Less than or equal to' operator
static byte | LT 'Less than' operator
static byte | NO_COMPARISON
static byte | NOT_BETWEEN 'Not between' operator
static byte | NOT_EQUAL 'Not equal to' operator
Constructor Summary
ComparisonOperator()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_COMPARISON

public static final byte NO_COMPARISON
See Also:
Constant Field Values

BETWEEN

public static final byte BETWEEN
'Between' operator

See Also:
Constant Field Values

NOT_BETWEEN

public static final byte NOT_BETWEEN
'Not between' operator

See Also:
Constant Field Values

EQUAL

public static final byte EQUAL
'Equal to' operator

See Also:
Constant Field Values

NOT_EQUAL

public static final byte NOT_EQUAL
'Not equal to' operator

See Also:
Constant Field Values

GT

public static final byte GT
'Greater than' operator

See Also:
Constant Field Values

LT

public static final byte LT
'Less than' operator

See Also:
Constant Field Values

GE

public static final byte GE
'Greater than or equal to' operator

See Also:
Constant Field Values

LE

public static final byte LE
'Less than or equal to' operator

See Also:
Constant Field Values
Constructor Detail

ComparisonOperator

public ComparisonOperator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConditionalFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface ConditionalFormatting

All Known Implementing Classes:
HSSFConditionalFormatting, XSSFConditionalFormatting
public interface ConditionalFormatting

The ConditionalFormatting class encapsulates all settings of Conditional Formatting. The class can be used

  • to make a copy ConditionalFormatting settings.
    • For example:
     ConditionalFormatting cf = sheet.getConditionalFormattingAt(index);
 newSheet.addConditionalFormatting(cf);
  • or to modify existing Conditional Formatting settings (formatting regions and/or rules).
Use Sheet.getSheetConditionalFormatting() to get access to an instance of this class.

To create a new Conditional Formatting set use the following approach:

 // Define a Conditional Formatting rule, which triggers formatting
 // when cell's value is greater or equal than 100.0 and
 // applies patternFormatting defined below.
 ConditionalFormattingRule rule = sheet.createConditionalFormattingRule(
     ComparisonOperator.GE,
     "100.0", // 1st formula
     null     // 2nd formula is not used for comparison operator GE
 );

 // Create pattern with red background
 PatternFormatting patternFmt = rule.cretePatternFormatting();
 patternFormatting.setFillBackgroundColor(IndexedColor.RED.getIndex());

 // Define a region containing first column
 Region [] regions =
 {
     new Region(1,(short)1,-1,(short)1)
 };

 // Apply Conditional Formatting rule defined above to the regions
 sheet.addConditionalFormatting(regions, rule);

Author:
Dmitriy Kumshayev, Yegor Kozlov

Method Summary
void | addRule(ConditionalFormattingRule cfRule) Add a Conditional Formatting rule.
CellRangeAddress[] | getFormattingRanges()
int | getNumberOfRules()
ConditionalFormattingRule | getRule(int idx)
void | setRule(int idx, ConditionalFormattingRule cfRule) Replaces an existing Conditional Formatting rule at position idx.

Method Detail

getFormattingRanges

CellRangeAddress[] getFormattingRanges()
Returns:
array of CellRangeAddresss. Never null

setRule

void setRule(int idx,
             ConditionalFormattingRule cfRule)
Replaces an existing Conditional Formatting rule at position idx. Excel allows to create up to 3 Conditional Formatting rules. This method can be useful to modify existing Conditional Formatting rules.

Parameters:
idx - position of the rule. Should be between 0 and 2.
cfRule - - Conditional Formatting rule

addRule

void addRule(ConditionalFormattingRule cfRule)
Add a Conditional Formatting rule. Excel allows to create up to 3 Conditional Formatting rules.

Parameters:
cfRule - - Conditional Formatting rule

getRule

ConditionalFormattingRule getRule(int idx)
Returns:
the Conditional Formatting rule at position idx.

getNumberOfRules

int getNumberOfRules()
Returns:
number of Conditional Formatting rules.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConditionalFormattingRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface ConditionalFormattingRule

All Known Implementing Classes:
HSSFConditionalFormattingRule, XSSFConditionalFormattingRule
public interface ConditionalFormattingRule

Represents a description of a conditional formatting rule

Author:
Dmitriy Kumshayev, Yegor Kozlov

Field Summary
static byte | CONDITION_TYPE_CELL_VALUE_IS This conditional formatting rule compares a cell value to a formula calculated result, using an operator
static byte | CONDITION_TYPE_FORMULA This conditional formatting rule contains a formula to evaluate.
Method Summary
BorderFormatting | createBorderFormatting() Create a new border formatting structure if it does not exist, otherwise just return existing object.
FontFormatting | createFontFormatting() Create a new font formatting structure if it does not exist, otherwise just return existing object.
PatternFormatting | createPatternFormatting() Create a new pattern formatting structure if it does not exist, otherwise just return existing object.
BorderFormatting | getBorderFormatting()
byte | getComparisonOperation() The comparison function used when the type of conditional formatting is set to CONDITION_TYPE_CELL_VALUE_IS
byte | getConditionType() Type of conditional formatting rule.
FontFormatting | getFontFormatting()
java.lang.String | getFormula1() The formula used to evaluate the first operand for the conditional formatting rule.
java.lang.String | getFormula2() The formula used to evaluate the second operand of the comparison when comparison type is CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN
PatternFormatting | getPatternFormatting()

Field Detail

CONDITION_TYPE_CELL_VALUE_IS

static final byte CONDITION_TYPE_CELL_VALUE_IS
This conditional formatting rule compares a cell value to a formula calculated result, using an operator

See Also:
Constant Field Values

CONDITION_TYPE_FORMULA

static final byte CONDITION_TYPE_FORMULA
This conditional formatting rule contains a formula to evaluate. When the formula result is true, the cell is highlighted.

See Also:
Constant Field Values
Method Detail

createBorderFormatting

BorderFormatting createBorderFormatting()
Create a new border formatting structure if it does not exist, otherwise just return existing object.

Returns:
- border formatting object, never returns null.

getBorderFormatting

BorderFormatting getBorderFormatting()
Returns:
- border formatting object if defined, null otherwise

createFontFormatting

FontFormatting createFontFormatting()
Create a new font formatting structure if it does not exist, otherwise just return existing object.

Returns:
- font formatting object, never returns null.

getFontFormatting

FontFormatting getFontFormatting()
Returns:
- font formatting object if defined, null otherwise

createPatternFormatting

PatternFormatting createPatternFormatting()
Create a new pattern formatting structure if it does not exist, otherwise just return existing object.

Returns:
- pattern formatting object, never returns null.

getPatternFormatting

PatternFormatting getPatternFormatting()
Returns:
- pattern formatting object if defined, null otherwise

getConditionType

byte getConditionType()
Type of conditional formatting rule.

MUST be either CONDITION_TYPE_CELL_VALUE_IS or CONDITION_TYPE_FORMULA

Returns:
the type of condition

getComparisonOperation

byte getComparisonOperation()
The comparison function used when the type of conditional formatting is set to CONDITION_TYPE_CELL_VALUE_IS

MUST be a constant from ComparisonOperator

Returns:
the conditional format operator

getFormula1

java.lang.String getFormula1()
The formula used to evaluate the first operand for the conditional formatting rule.

If the condition type is CONDITION_TYPE_CELL_VALUE_IS, this field is the first operand of the comparison. If type is CONDITION_TYPE_FORMULA, this formula is used to determine if the conditional formatting is applied.

If comparison type is CONDITION_TYPE_FORMULA the formula MUST be a Boolean function

Returns:
the first formula

getFormula2

java.lang.String getFormula2()
The formula used to evaluate the second operand of the comparison when comparison type is CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN

Returns:
the second formula
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CreationHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface CreationHelper

All Known Implementing Classes:
HSSFCreationHelper, XSSFCreationHelper
public interface CreationHelper

An object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF. Works around a major shortcoming in Java, where we can't have static methods on interfaces or abstract classes. This allows you to get the appropriate class for a given interface, without you having to worry about if you're dealing with HSSF or XSSF, despite Java being quite rubbish.

Method Summary
ClientAnchor | createClientAnchor()
DataFormat | createDataFormat() Creates a new DataFormat instance
FormulaEvaluator | createFormulaEvaluator() Creates FormulaEvaluator - an object that evaluates formula cells.
Hyperlink | createHyperlink(int type) Creates a new Hyperlink, of the given type
RichTextString | createRichTextString(java.lang.String text) Creates a new RichTextString instance

Method Detail

createRichTextString

RichTextString createRichTextString(java.lang.String text)
Creates a new RichTextString instance

Parameters:
text - The text to initialise the RichTextString with

createDataFormat

DataFormat createDataFormat()
Creates a new DataFormat instance

createHyperlink

Hyperlink createHyperlink(int type)
Creates a new Hyperlink, of the given type

createFormulaEvaluator

FormulaEvaluator createFormulaEvaluator()
Creates FormulaEvaluator - an object that evaluates formula cells.

Returns:
a FormulaEvaluator instance

createClientAnchor

ClientAnchor createClientAnchor()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataFormat

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface DataFormat

All Known Implementing Classes:
HSSFDataFormat, XSSFDataFormat
public interface DataFormat

Method Summary
java.lang.String | getFormat(short index) get the format string that matches the given format index
short | getFormat(java.lang.String format) get the format index that matches the given format string.

Method Detail

getFormat

short getFormat(java.lang.String format)
get the format index that matches the given format string. Creates a new format if one is not found. Aliases text to the proper format.

Parameters:
format - string matching a built in format
Returns:
index of format.

getFormat

java.lang.String getFormat(short index)
get the format string that matches the given format index

Parameters:
index - of a format
Returns:
string represented at index of format or null if there is not a format at that index
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class DataFormatter

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.DataFormatter
Direct Known Subclasses:
HSSFDataFormatter
public class DataFormatter
extends java.lang.Object

DataFormatter contains methods for formatting the value stored in an Cell. This can be useful for reports and GUI presentations when you need to display data exactly as it appears in Excel. Supported formats include currency, SSN, percentages, decimals, dates, phone numbers, zip codes, etc.

Internally, formats will be implemented using subclasses of Format such as DecimalFormat and SimpleDateFormat. Therefore the formats used by this class must obey the same pattern rules as these Format subclasses. This means that only legal number pattern characters ("0", "#", ".", "," etc.) may appear in number formats. Other characters can be inserted before or after the number pattern to form a prefix or suffix.

For example the Excel pattern "$#,##0.00 "USD"_);($#,##0.00 "USD")" will be correctly formatted as "$1,000.00 USD" or "($1,000.00 USD)". However the pattern "00-00-00" is incorrectly formatted by DecimalFormat as "000000--". For Excel formats that are not compatible with DecimalFormat, you can provide your own custom Format implementation via DataFormatter.addFormat(String,Format). The following custom formats are already provided by this class:

  • SSN "000-00-0000"
    •

  • Phone Number "(###) ###-####"
    •

  • Zip plus 4 "00000-0000"
    •

If the Excel format pattern cannot be parsed successfully, then a default format will be used. The default number format will mimic the Excel General format: "#" for whole numbers and "#.##########" for decimal numbers. You can override the default format pattern with DataFormatter.setDefaultNumberFormat(Format). Note: the default format will only be used when a Format cannot be created from the cell's data format string.

Note that by default formatted numeric values are trimmed. Excel formats can contain spacers and padding and the default behavior is to strip them off.

Example:

Consider a numeric cell with a value 12.343 and format "##.##_ ". The trailing underscore and space ("_ ") in the format adds a space to the end and Excel formats this cell as "12.34 ", but DataFormatter trims the formatted value and returns "12.34".

You can enable spaces by passing the emulateCsv=true flag in the DateFormatter cosntructor. If set to true, then the output tries to conform to what you get when you take an xls or xlsx in Excel and Save As CSV file:
  • returned values are not trimmed
  • Invalid dates are formatted as 255 pound signs ("#")
  • simulate Excel's handling of a format string of all # when the value is 0. Excel will output "", DataFormatter will output "0".

Author:
James May (james dot may at fmr dot com), Robert Kish

Constructor Summary
DataFormatter()
Creates a formatter using the default locale.
DataFormatter(boolean emulateCsv)
Creates a formatter using the default locale.
DataFormatter(java.util.Locale locale)
Creates a formatter using the given locale.
DataFormatter(java.util.Locale locale, boolean emulateCsv)
Creates a formatter using the given locale.
Method Summary
void | addFormat(java.lang.String excelFormatStr, java.text.Format format) Adds a new format to the available formats.
java.text.Format | createFormat(Cell cell) Create and return a Format based on the format string from a cell's style.
java.lang.String | formatCellValue(Cell cell) Returns the formatted value of a cell as a String regardless of the cell type.
java.lang.String | formatCellValue(Cell cell, FormulaEvaluator evaluator) Returns the formatted value of a cell as a String regardless of the cell type.
java.lang.String | formatRawCellContents(double value, int formatIndex, java.lang.String formatString) Formats the given raw cell value, based on the supplied format index and string, according to excel style rules.
java.lang.String | formatRawCellContents(double value, int formatIndex, java.lang.String formatString, boolean use1904Windowing) Formats the given raw cell value, based on the supplied format index and string, according to excel style rules.
java.text.Format | getDefaultFormat(Cell cell) Returns a default format for a cell.
void | setDefaultNumberFormat(java.text.Format format) Sets a default number format to be used when the Excel format cannot be parsed successfully.
static void | setExcelStyleRoundingMode(java.text.DecimalFormat format) Enables excel style rounding mode (round half up) on the Decimal Format if possible.
static void | setExcelStyleRoundingMode(java.text.DecimalFormat format, java.math.RoundingMode roundingMode) Enables custom rounding mode on the Decimal Format if possible.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataFormatter

public DataFormatter()
Creates a formatter using the default locale.

DataFormatter

public DataFormatter(boolean emulateCsv)
Creates a formatter using the default locale.

Parameters:
emulateCsv - whether to emulate CSV output.

DataFormatter

public DataFormatter(java.util.Locale locale,
                     boolean emulateCsv)
Creates a formatter using the given locale.

Parameters:
emulateCsv - whether to emulate CSV output.

DataFormatter

public DataFormatter(java.util.Locale locale)
Creates a formatter using the given locale.

Method Detail

createFormat

public java.text.Format createFormat(Cell cell)
Create and return a Format based on the format string from a cell's style. If the pattern cannot be parsed, return a default pattern.

Parameters:
cell - The Excel cell
Returns:
A Format representing the excel format. May return null.

getDefaultFormat

public java.text.Format getDefaultFormat(Cell cell)
Returns a default format for a cell.

Parameters:
cell - The cell
Returns:
a default format

formatRawCellContents

public java.lang.String formatRawCellContents(double value,
                                              int formatIndex,
                                              java.lang.String formatString)
Formats the given raw cell value, based on the supplied format index and string, according to excel style rules.

See Also:
formatCellValue(Cell)

formatRawCellContents

public java.lang.String formatRawCellContents(double value,
                                              int formatIndex,
                                              java.lang.String formatString,
                                              boolean use1904Windowing)
Formats the given raw cell value, based on the supplied format index and string, according to excel style rules.

See Also:
formatCellValue(Cell)

formatCellValue

public java.lang.String formatCellValue(Cell cell)

Returns the formatted value of a cell as a String regardless of the cell type. If the Excel format pattern cannot be parsed then the cell value will be formatted using a default format.

When passed a null or blank cell, this method will return an empty String (""). Formulas in formula type cells will not be evaluated.

Parameters:
cell - The cell
Returns:
the formatted cell value as a String

formatCellValue

public java.lang.String formatCellValue(Cell cell,
                                        FormulaEvaluator evaluator)

Returns the formatted value of a cell as a String regardless of the cell type. If the Excel format pattern cannot be parsed then the cell value will be formatted using a default format.

When passed a null or blank cell, this method will return an empty String (""). Formula cells will be evaluated using the given FormulaEvaluator if the evaluator is non-null. If the evaluator is null, then the formula String will be returned. The caller is responsible for setting the currentRow on the evaluator

Parameters:
cell - The cell (can be null)
evaluator - The FormulaEvaluator (can be null)
Returns:
a string value of the cell

setDefaultNumberFormat

public void setDefaultNumberFormat(java.text.Format format)

Sets a default number format to be used when the Excel format cannot be parsed successfully. Note: This is a fall back for when an error occurs while parsing an Excel number format pattern. This will not affect cells with the General format.

The value that will be passed to the Format's format method (specified by java.text.Format#format) will be a double value from a numeric cell. Therefore the code in the format method should expect a Number value.

Parameters:
format - A Format instance to be used as a default
See Also:
Format.format(java.lang.Object)

addFormat

public void addFormat(java.lang.String excelFormatStr,
                      java.text.Format format)
Adds a new format to the available formats.

The value that will be passed to the Format's format method (specified by java.text.Format#format) will be a double value from a numeric cell. Therefore the code in the format method should expect a Number value.

Parameters:
excelFormatStr - The data format string
format - A Format instance

setExcelStyleRoundingMode

public static void setExcelStyleRoundingMode(java.text.DecimalFormat format)
Enables excel style rounding mode (round half up) on the Decimal Format if possible. This will work for Java 1.6, but isn't possible on Java 1.5.

setExcelStyleRoundingMode

public static void setExcelStyleRoundingMode(java.text.DecimalFormat format,
                                             java.math.RoundingMode roundingMode)
Enables custom rounding mode on the Decimal Format if possible. This will work for Java 1.6, but isn't possible on Java 1.5.

Parameters:
format - DecimalFormat
roundingMode - RoundingMode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataValidation.ErrorStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class DataValidation.ErrorStyle

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.DataValidation.ErrorStyle
Enclosing interface:
DataValidation
public static final class DataValidation.ErrorStyle
extends java.lang.Object

Error style constants for error box

Field Summary
static int | INFO INFO style
static int | STOP STOP style
static int | WARNING WARNING style
Constructor Summary
DataValidation.ErrorStyle()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STOP

public static final int STOP
STOP style

See Also:
Constant Field Values

WARNING

public static final int WARNING
WARNING style

See Also:
Constant Field Values

INFO

public static final int INFO
INFO style

See Also:
Constant Field Values
Constructor Detail

DataValidation.ErrorStyle

public DataValidation.ErrorStyle()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataValidation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface DataValidation

All Known Implementing Classes:
HSSFDataValidation, XSSFDataValidation
public interface DataValidation

Nested Class Summary
static class DataValidation.ErrorStyle
Error style constants for error box
Method Summary
void | createErrorBox(java.lang.String title, java.lang.String text) Sets the title and text for the error box .
void | createPromptBox(java.lang.String title, java.lang.String text) Sets the title and text for the prompt box .
boolean | getEmptyCellAllowed() Retrieve the settings for empty cells allowed
java.lang.String | getErrorBoxText()
java.lang.String | getErrorBoxTitle()
int | getErrorStyle() o
java.lang.String | getPromptBoxText()
java.lang.String | getPromptBoxTitle()
CellRangeAddressList | getRegions()
boolean | getShowErrorBox()
boolean | getShowPromptBox()
boolean | getSuppressDropDownArrow() Useful only list validation objects .
DataValidationConstraint | getValidationConstraint()
void | setEmptyCellAllowed(boolean allowed) Sets if this object allows empty as a valid value
void | setErrorStyle(int error_style) Sets the error style for error box
void | setShowErrorBox(boolean show) Sets the behaviour when an invalid value is entered
void | setShowPromptBox(boolean show) Sets the behaviour when a cell which belongs to this object is selected
void | setSuppressDropDownArrow(boolean suppress) Useful for list validation objects .

Method Detail

getValidationConstraint

DataValidationConstraint getValidationConstraint()

setErrorStyle

void setErrorStyle(int error_style)
Sets the error style for error box

See Also:
DataValidation.ErrorStyle

getErrorStyle

int getErrorStyle()
o

Returns:
the error style of error box
See Also:
DataValidation.ErrorStyle

setEmptyCellAllowed

void setEmptyCellAllowed(boolean allowed)
Sets if this object allows empty as a valid value

Parameters:
allowed - true if this object should treats empty as valid value , false otherwise

getEmptyCellAllowed

boolean getEmptyCellAllowed()
Retrieve the settings for empty cells allowed

Returns:
True if this object should treats empty as valid value , false otherwise

setSuppressDropDownArrow

void setSuppressDropDownArrow(boolean suppress)
Useful for list validation objects .

Parameters:
suppress - True if a list should display the values into a drop down list , false otherwise . In other words , if a list should display the arrow sign on its right side

getSuppressDropDownArrow

boolean getSuppressDropDownArrow()
Useful only list validation objects . This method always returns false if the object isn't a list validation object

Returns:
true if a list should display the values into a drop down list , false otherwise .

setShowPromptBox

void setShowPromptBox(boolean show)
Sets the behaviour when a cell which belongs to this object is selected

Parameters:
show - true if an prompt box should be displayed , false otherwise

getShowPromptBox

boolean getShowPromptBox()
Returns:
true if an prompt box should be displayed , false otherwise

setShowErrorBox

void setShowErrorBox(boolean show)
Sets the behaviour when an invalid value is entered

Parameters:
show - true if an error box should be displayed , false otherwise

getShowErrorBox

boolean getShowErrorBox()
Returns:
true if an error box should be displayed , false otherwise

createPromptBox

void createPromptBox(java.lang.String title,
                     java.lang.String text)
Sets the title and text for the prompt box . Prompt box is displayed when the user selects a cell which belongs to this validation object . In order for a prompt box to be displayed you should also use method setShowPromptBox( boolean show )

Parameters:
title - The prompt box's title
text - The prompt box's text

getPromptBoxTitle

java.lang.String getPromptBoxTitle()
Returns:
Prompt box's title or null

getPromptBoxText

java.lang.String getPromptBoxText()
Returns:
Prompt box's text or null

createErrorBox

void createErrorBox(java.lang.String title,
                    java.lang.String text)
Sets the title and text for the error box . Error box is displayed when the user enters an invalid value int o a cell which belongs to this validation object . In order for an error box to be displayed you should also use method setShowErrorBox( boolean show )

Parameters:
title - The error box's title
text - The error box's text

getErrorBoxTitle

java.lang.String getErrorBoxTitle()
Returns:
Error box's title or null

getErrorBoxText

java.lang.String getErrorBoxText()
Returns:
Error box's text or null

getRegions

CellRangeAddressList getRegions()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataValidationConstraint

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface DataValidationConstraint

All Known Implementing Classes:
DVConstraint, XSSFDataValidationConstraint
public interface DataValidationConstraint

Nested Class Summary
static class | DataValidationConstraint.OperatorType Condition operator enum
static class | DataValidationConstraint.ValidationType ValidationType enum
Method Summary
java.lang.String[] | getExplicitListValues()
java.lang.String | getFormula1()
java.lang.String | getFormula2()
int | getOperator()
int | getValidationType()
void | setExplicitListValues(java.lang.String[] explicitListValues)
void | setFormula1(java.lang.String formula1) Sets a formula for expression 1.
void | setFormula2(java.lang.String formula2) Sets a formula for expression 2.
void | setOperator(int operator) Sets the comparison operator for this constraint

Method Detail

getValidationType

int getValidationType()
Returns:
data validation type of this constraint
See Also:
DataValidationConstraint.ValidationType

getOperator

int getOperator()
Returns:
the operator used for this constraint
See Also:
DataValidationConstraint.OperatorType

setOperator

void setOperator(int operator)
Sets the comparison operator for this constraint

See Also:
DataValidationConstraint.OperatorType

getExplicitListValues

java.lang.String[] getExplicitListValues()

setExplicitListValues

void setExplicitListValues(java.lang.String[] explicitListValues)

getFormula1

java.lang.String getFormula1()
Returns:
the formula for expression 1. May be null

setFormula1

void setFormula1(java.lang.String formula1)
Sets a formula for expression 1.

getFormula2

java.lang.String getFormula2()
Returns:
the formula for expression 2. May be null

setFormula2

void setFormula2(java.lang.String formula2)
Sets a formula for expression 2.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataValidationConstraint.OperatorType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class DataValidationConstraint.OperatorType

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType
Enclosing interface:
DataValidationConstraint
public static final class DataValidationConstraint.OperatorType
extends java.lang.Object

Condition operator enum

Field Summary
static int | BETWEEN
static int | EQUAL
static int | GREATER_OR_EQUAL
static int | GREATER_THAN
static int | IGNORED default value to supply when the operator type is not used
static int | LESS_OR_EQUAL
static int | LESS_THAN
static int | NOT_BETWEEN
static int | NOT_EQUAL
Method Summary
static void validateSecondArg(int comparisonOperator, java.lang.String paramValue)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BETWEEN

public static final int BETWEEN
See Also:
Constant Field Values

NOT_BETWEEN

public static final int NOT_BETWEEN
See Also:
Constant Field Values

EQUAL

public static final int EQUAL
See Also:
Constant Field Values

NOT_EQUAL

public static final int NOT_EQUAL
See Also:
Constant Field Values

GREATER_THAN

public static final int GREATER_THAN
See Also:
Constant Field Values

LESS_THAN

public static final int LESS_THAN
See Also:
Constant Field Values

GREATER_OR_EQUAL

public static final int GREATER_OR_EQUAL
See Also:
Constant Field Values

LESS_OR_EQUAL

public static final int LESS_OR_EQUAL
See Also:
Constant Field Values

IGNORED

public static final int IGNORED
default value to supply when the operator type is not used

See Also:
Constant Field Values
Method Detail

validateSecondArg

public static void validateSecondArg(int comparisonOperator,
                                     java.lang.String paramValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataValidationConstraint.ValidationType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class DataValidationConstraint.ValidationType

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
Enclosing interface:
DataValidationConstraint
public static final class DataValidationConstraint.ValidationType
extends java.lang.Object

ValidationType enum

Field Summary
static int | ANY 'Any value' type - value not restricted
static int | DATE Date type
static int | DECIMAL Decimal type
static int | FORMULA Formula ( 'Custom' ) type
static int | INTEGER Integer ('Whole number') type
static int | LIST List type ( combo box type )
static int | TEXT_LENGTH String length type
static int | TIME Time type
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ANY

public static final int ANY
'Any value' type - value not restricted

See Also:
Constant Field Values

INTEGER

public static final int INTEGER
Integer ('Whole number') type

See Also:
Constant Field Values

DECIMAL

public static final int DECIMAL
Decimal type

See Also:
Constant Field Values

LIST

public static final int LIST
List type ( combo box type )

See Also:
Constant Field Values

DATE

public static final int DATE
Date type

See Also:
Constant Field Values

TIME

public static final int TIME
Time type

See Also:
Constant Field Values

TEXT_LENGTH

public static final int TEXT_LENGTH
String length type

See Also:
Constant Field Values

FORMULA

public static final int FORMULA
Formula ( 'Custom' ) type

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataValidationHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface DataValidationHelper

All Known Implementing Classes:
HSSFDataValidationHelper, XSSFDataValidationHelper
public interface DataValidationHelper

Author:
Radhakrishnan J

Method Summary
DataValidationConstraint | createCustomConstraint(java.lang.String formula)
DataValidationConstraint | createDateConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2, java.lang.String dateFormat)
DataValidationConstraint | createDecimalConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createExplicitListConstraint(java.lang.String[] listOfValues)
DataValidationConstraint | createFormulaListConstraint(java.lang.String listFormula)
DataValidationConstraint | createIntegerConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createNumericConstraint(int validationType, int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createTextLengthConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createTimeConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidation | createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Method Detail

createFormulaListConstraint

DataValidationConstraint createFormulaListConstraint(java.lang.String listFormula)

createExplicitListConstraint

DataValidationConstraint createExplicitListConstraint(java.lang.String[] listOfValues)

createNumericConstraint

DataValidationConstraint createNumericConstraint(int validationType,
                                                 int operatorType,
                                                 java.lang.String formula1,
                                                 java.lang.String formula2)

createTextLengthConstraint

DataValidationConstraint createTextLengthConstraint(int operatorType,
                                                    java.lang.String formula1,
                                                    java.lang.String formula2)

createDecimalConstraint

DataValidationConstraint createDecimalConstraint(int operatorType,
                                                 java.lang.String formula1,
                                                 java.lang.String formula2)

createIntegerConstraint

DataValidationConstraint createIntegerConstraint(int operatorType,
                                                 java.lang.String formula1,
                                                 java.lang.String formula2)

createDateConstraint

DataValidationConstraint createDateConstraint(int operatorType,
                                              java.lang.String formula1,
                                              java.lang.String formula2,
                                              java.lang.String dateFormat)

createTimeConstraint

DataValidationConstraint createTimeConstraint(int operatorType,
                                              java.lang.String formula1,
                                              java.lang.String formula2)

createCustomConstraint

DataValidationConstraint createCustomConstraint(java.lang.String formula)

createValidation

DataValidation createValidation(DataValidationConstraint constraint,
                                CellRangeAddressList cellRangeAddressList)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class DateUtil

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.DateUtil
Direct Known Subclasses:
HSSFDateUtil
public class DateUtil
extends java.lang.Object

Contains methods for dealing with Excel dates.

Author:
Michael Harhen, Glen Stampoultzis (glens at apache.org), Dan Sherman (dsherman at isisph.com), Hack Kampbjorn (hak at 2mba.dk), Alex Jacoby (ajacoby at gmail.com), Pavel Krupets (pkrupets at palmtreebusiness dot com)

Constructor Summary
protected DateUtil()
Method Summary
protected static int | absoluteDay(java.util.Calendar cal, boolean use1904windowing) Given a Calendar, return the number of days since 1900/12/31.
static double | convertTime(java.lang.String timeStr) Converts a string of format "HH:MM" or "HH:MM:SS" to its (Excel) numeric equivalent
static double | getExcelDate(java.util.Calendar date, boolean use1904windowing) Given a Date in the form of a Calendar, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900.
static double | getExcelDate(java.util.Date date) Given a Date, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900.
static double | getExcelDate(java.util.Date date, boolean use1904windowing) Given a Date, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900.
static java.util.Date | getJavaDate(double date) Given an Excel date with using 1900 date windowing, and converts it to a java.util.Date.
static java.util.Date | getJavaDate(double date, boolean use1904windowing) Given an Excel date with either 1900 or 1904 date windowing, converts it to a java.util.Date.
static boolean | isADateFormat(int formatIndex, java.lang.String formatString) Given a format ID and its format String, will check to see if the format represents a date format or not.
static boolean | isCellDateFormatted(Cell cell) Check if a cell contains a date Since dates are stored internally in Excel as double values we infer it is a date if it is formatted as such.
static boolean | isCellInternalDateFormatted(Cell cell) Check if a cell contains a date, checking only for internal excel date formats.
static boolean | isInternalDateFormat(int format) Given a format ID this will check whether the format represents an internal excel date format or not.
static boolean | isValidExcelDate(double value) Given a double, checks if it is a valid Excel date.
static java.util.Date | parseYYYYMMDDDate(java.lang.String dateStr) Converts a string of format "YYYY/MM/DD" to its (Excel) numeric equivalent
static void | setCalendar(java.util.Calendar calendar, int wholeDays, int millisecondsInDay, boolean use1904windowing)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DateUtil

protected DateUtil()
Method Detail

getExcelDate

public static double getExcelDate(java.util.Date date)
Given a Date, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900. Fractional days represent hours, minutes, and seconds.

Parameters:
date - the Date
Returns:
Excel representation of Date (-1 if error - test for error by checking for less than 0.1)

getExcelDate

public static double getExcelDate(java.util.Date date,
                                  boolean use1904windowing)
Given a Date, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900. Fractional days represent hours, minutes, and seconds.

Parameters:
date - the Date
use1904windowing - Should 1900 or 1904 date windowing be used?
Returns:
Excel representation of Date (-1 if error - test for error by checking for less than 0.1)

getExcelDate

public static double getExcelDate(java.util.Calendar date,
                                  boolean use1904windowing)
Given a Date in the form of a Calendar, converts it into a double representing its internal Excel representation, which is the number of days since 1/1/1900. Fractional days represent hours, minutes, and seconds.

Parameters:
date - the Calendar holding the date to convert
use1904windowing - Should 1900 or 1904 date windowing be used?
Returns:
Excel representation of Date (-1 if error - test for error by checking for less than 0.1)

getJavaDate

public static java.util.Date getJavaDate(double date)
Given an Excel date with using 1900 date windowing, and converts it to a java.util.Date. NOTE: If the default TimeZone in Java uses Daylight Saving Time then the conversion back to an Excel date may not give the same value, that is the comparison excelDate == getExcelDate(getJavaDate(excelDate,false)) is not always true. For example if default timezone is Europe/Copenhagen, on 2004-03-28 the minute after 01:59 CET is 03:00 CEST, if the excel date represents a time between 02:00 and 03:00 then it is converted to past 03:00 summer time

Parameters:
date - The Excel date.
Returns:
Java representation of the date, or null if date is not a valid Excel date
See Also:
TimeZone

getJavaDate

public static java.util.Date getJavaDate(double date,
                                         boolean use1904windowing)
Given an Excel date with either 1900 or 1904 date windowing, converts it to a java.util.Date. NOTE: If the default TimeZone in Java uses Daylight Saving Time then the conversion back to an Excel date may not give the same value, that is the comparison excelDate == getExcelDate(getJavaDate(excelDate,false)) is not always true. For example if default timezone is Europe/Copenhagen, on 2004-03-28 the minute after 01:59 CET is 03:00 CEST, if the excel date represents a time between 02:00 and 03:00 then it is converted to past 03:00 summer time

Parameters:
date - The Excel date.
use1904windowing - true if date uses 1904 windowing, or false if using 1900 date windowing.
Returns:
Java representation of the date, or null if date is not a valid Excel date
See Also:
TimeZone

setCalendar

public static void setCalendar(java.util.Calendar calendar,
                               int wholeDays,
                               int millisecondsInDay,
                               boolean use1904windowing)

isADateFormat

public static boolean isADateFormat(int formatIndex,
                                    java.lang.String formatString)
Given a format ID and its format String, will check to see if the format represents a date format or not. Firstly, it will check to see if the format ID corresponds to an internal excel date format (eg most US date formats) If not, it will check to see if the format string only contains date formatting characters (ymd-/), which covers most non US date formats.

Parameters:
formatIndex - The index of the format, eg from ExtendedFormatRecord.getFormatIndex
formatString - The format string, eg from FormatRecord.getFormatString
See Also:
isInternalDateFormat(int)

isInternalDateFormat

public static boolean isInternalDateFormat(int format)
Given a format ID this will check whether the format represents an internal excel date format or not.

See Also:
isADateFormat(int, java.lang.String)

isCellDateFormatted

public static boolean isCellDateFormatted(Cell cell)
Check if a cell contains a date Since dates are stored internally in Excel as double values we infer it is a date if it is formatted as such.

See Also:
isADateFormat(int, String), isInternalDateFormat(int)

isCellInternalDateFormatted

public static boolean isCellInternalDateFormatted(Cell cell)
Check if a cell contains a date, checking only for internal excel date formats. As Excel stores a great many of its dates in "non-internal" date formats, you will not normally want to use this method.

See Also:
isADateFormat(int,String), isInternalDateFormat(int)

isValidExcelDate

public static boolean isValidExcelDate(double value)
Given a double, checks if it is a valid Excel date.

Parameters:
value - the double value
Returns:
true if valid

absoluteDay

protected static int absoluteDay(java.util.Calendar cal,
                                 boolean use1904windowing)
Given a Calendar, return the number of days since 1900/12/31.

Parameters:
cal - the Calendar
Returns:
days number of days since 1900/12/31
Throws:
java.lang.IllegalArgumentException - if date is invalid

convertTime

public static double convertTime(java.lang.String timeStr)
Converts a string of format "HH:MM" or "HH:MM:SS" to its (Excel) numeric equivalent

Returns:
a double between 0 and 1 representing the fraction of the day

parseYYYYMMDDDate

public static java.util.Date parseYYYYMMDDDate(java.lang.String dateStr)
Converts a string of format "YYYY/MM/DD" to its (Excel) numeric equivalent

Returns:
a double representing the (integer) number of days since the start of the Excel epoch
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Drawing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Drawing

All Known Implementing Classes:
HSSFPatriarch, XSSFDrawing
public interface Drawing

High level representation of spreadsheet drawing.

Author:
Yegor Kozlov, Roman Kashitsyn

Method Summary
ClientAnchor | createAnchor(int dx1, int dy1, int dx2, int dy2, int col1, int row1, int col2, int row2) Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
Comment | createCellComment(ClientAnchor anchor) Creates a comment.
Chart | createChart(ClientAnchor anchor) Creates a chart.
Picture | createPicture(ClientAnchor anchor, int pictureIndex) Creates a picture.

Method Detail

createPicture

Picture createPicture(ClientAnchor anchor,
                      int pictureIndex)
Creates a picture.

Parameters:
anchor - the client anchor describes how this picture is attached to the sheet.
pictureIndex - the index of the picture in the workbook collection of pictures.
Returns:
the newly created picture.

createCellComment

Comment createCellComment(ClientAnchor anchor)
Creates a comment.

Parameters:
anchor - the client anchor describes how this comment is attached to the sheet.
Returns:
the newly created comment.

createChart

Chart createChart(ClientAnchor anchor)
Creates a chart.

Parameters:
anchor - the client anchor describes how this chart is attached to the sheet.
Returns:
the newly created chart

createAnchor

ClientAnchor createAnchor(int dx1,
                          int dy1,
                          int dx2,
                          int dy2,
                          int col1,
                          int row1,
                          int col2,
                          int row2)
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.

Parameters:
dx1 - the x coordinate in EMU within the first cell.
dy1 - the y coordinate in EMU within the first cell.
dx2 - the x coordinate in EMU within the second cell.
dy2 - the y coordinate in EMU within the second cell.
col1 - the column (0 based) of the first cell.
row1 - the row (0 based) of the first cell.
col2 - the column (0 based) of the second cell.
row2 - the row (0 based) of the second cell.
Returns:
the newly created client anchor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ErrorConstants

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class ErrorConstants

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.ErrorConstants
Direct Known Subclasses:
HSSFErrorConstants
public class ErrorConstants
extends java.lang.Object

Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)

Author:
Michael Harhen

Field Summary
static int | ERROR_DIV_0 #DIV/0! - Division by zero
static int | ERROR_NA #N/A - Argument or function not available
static int | ERROR_NAME #NAME? - Wrong function or range name
static int | ERROR_NULL #NULL! - Intersection of two cell ranges is empty
static int | ERROR_NUM #NUM! - Value range overflow
static int | ERROR_REF #REF! - Illegal or deleted cell reference
static int | ERROR_VALUE #VALUE! - Wrong type of operand
Constructor Summary
protected ErrorConstants()
Method Summary
static java.lang.String | getText(int errorCode)
static boolean | isValidCode(int errorCode)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ERROR_NULL

public static final int ERROR_NULL
#NULL! - Intersection of two cell ranges is empty

See Also:
Constant Field Values

ERROR_DIV_0

public static final int ERROR_DIV_0
#DIV/0! - Division by zero

See Also:
Constant Field Values

ERROR_VALUE

public static final int ERROR_VALUE
#VALUE! - Wrong type of operand

See Also:
Constant Field Values

ERROR_REF

public static final int ERROR_REF
#REF! - Illegal or deleted cell reference

See Also:
Constant Field Values

ERROR_NAME

public static final int ERROR_NAME
#NAME? - Wrong function or range name

See Also:
Constant Field Values

ERROR_NUM

public static final int ERROR_NUM
#NUM! - Value range overflow

See Also:
Constant Field Values

ERROR_NA

public static final int ERROR_NA
#N/A - Argument or function not available

See Also:
Constant Field Values
Constructor Detail

ErrorConstants

protected ErrorConstants()
Method Detail

getText

public static final java.lang.String getText(int errorCode)
Returns:
Standard Excel error literal for the specified error code.
Throws:
java.lang.IllegalArgumentException - if the specified error code is not one of the 7 standard error codes

isValidCode

public static final boolean isValidCode(int errorCode)
Returns:
true if the specified error code is a standard Excel error code.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExcelStyleDateFormatter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class ExcelStyleDateFormatter

java.lang.Object
    extended by  java.text.Format
        extended by  java.text.DateFormat
            extended by  java.text.SimpleDateFormat
                extended by  org.apache.poi.ss.usermodel.ExcelStyleDateFormatter
All Implemented Interfaces:
java.io.Serializable, java.lang.Cloneable
public class ExcelStyleDateFormatter
extends java.text.SimpleDateFormat

A wrapper around a SimpleDateFormat instance, which handles a few Excel-style extensions that are not supported by SimpleDateFormat. Currently, the extensions are around the handling of elapsed time, eg rendering 1 day 2 hours as 26 hours.

See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.text.DateFormat
java.text.DateFormat.Field
Field Summary
static char | H_BRACKET_SYMBOL
static char | HH_BRACKET_SYMBOL
static char | L_BRACKET_SYMBOL
static char | LL_BRACKET_SYMBOL
static char | M_BRACKET_SYMBOL
static char | MM_BRACKET_SYMBOL
static char | MMMMM_START_SYMBOL
static char | MMMMM_TRUNCATE_SYMBOL
static char | S_BRACKET_SYMBOL
static char | SS_BRACKET_SYMBOL
Fields inherited from class java.text.DateFormat
AM_PM_FIELD, calendar, DATE_FIELD, DAY_OF_WEEK_FIELD, DAY_OF_WEEK_IN_MONTH_FIELD, DAY_OF_YEAR_FIELD, DEFAULT, ERA_FIELD, FULL, HOUR_OF_DAY0_FIELD, HOUR_OF_DAY1_FIELD, HOUR0_FIELD, HOUR1_FIELD, LONG, MEDIUM, MILLISECOND_FIELD, MINUTE_FIELD, MONTH_FIELD, numberFormat, SECOND_FIELD, SHORT, TIMEZONE_FIELD, WEEK_OF_MONTH_FIELD, WEEK_OF_YEAR_FIELD, YEAR_FIELD
Constructor Summary
ExcelStyleDateFormatter()
ExcelStyleDateFormatter(java.lang.String pattern)
ExcelStyleDateFormatter(java.lang.String pattern, java.text.DateFormatSymbols formatSymbols)
ExcelStyleDateFormatter(java.lang.String pattern, java.util.Locale locale)
Method Summary
java.lang.StringBuffer | format(java.util.Date date, java.lang.StringBuffer paramStringBuffer, java.text.FieldPosition paramFieldPosition)
void | setDateToBeFormatted(double date) Used to let us know what the date being formatted is, in Excel terms, which we may wish to use when handling elapsed times.
Methods inherited from class java.text.SimpleDateFormat
applyLocalizedPattern, applyPattern, clone, equals, formatToCharacterIterator, get2DigitYearStart, getDateFormatSymbols, hashCode, parse, set2DigitYearStart, setDateFormatSymbols, toLocalizedPattern, toPattern
Methods inherited from class java.text.DateFormat
format, format, getAvailableLocales, getCalendar, getDateInstance, getDateInstance, getDateInstance, getDateTimeInstance, getDateTimeInstance, getDateTimeInstance, getInstance, getNumberFormat, getTimeInstance, getTimeInstance, getTimeInstance, getTimeZone, isLenient, parse, parseObject, setCalendar, setLenient, setNumberFormat, setTimeZone
Methods inherited from class java.text.Format
format, parseObject
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

MMMMM_START_SYMBOL

public static final char MMMMM_START_SYMBOL
See Also:
Constant Field Values

MMMMM_TRUNCATE_SYMBOL

public static final char MMMMM_TRUNCATE_SYMBOL
See Also:
Constant Field Values

H_BRACKET_SYMBOL

public static final char H_BRACKET_SYMBOL
See Also:
Constant Field Values

HH_BRACKET_SYMBOL

public static final char HH_BRACKET_SYMBOL
See Also:
Constant Field Values

M_BRACKET_SYMBOL

public static final char M_BRACKET_SYMBOL
See Also:
Constant Field Values

MM_BRACKET_SYMBOL

public static final char MM_BRACKET_SYMBOL
See Also:
Constant Field Values

S_BRACKET_SYMBOL

public static final char S_BRACKET_SYMBOL
See Also:
Constant Field Values

SS_BRACKET_SYMBOL

public static final char SS_BRACKET_SYMBOL
See Also:
Constant Field Values

L_BRACKET_SYMBOL

public static final char L_BRACKET_SYMBOL
See Also:
Constant Field Values

LL_BRACKET_SYMBOL

public static final char LL_BRACKET_SYMBOL
See Also:
Constant Field Values
Constructor Detail

ExcelStyleDateFormatter

public ExcelStyleDateFormatter()

ExcelStyleDateFormatter

public ExcelStyleDateFormatter(java.lang.String pattern)

ExcelStyleDateFormatter

public ExcelStyleDateFormatter(java.lang.String pattern,
                               java.text.DateFormatSymbols formatSymbols)

ExcelStyleDateFormatter

public ExcelStyleDateFormatter(java.lang.String pattern,
                               java.util.Locale locale)
Method Detail

setDateToBeFormatted

public void setDateToBeFormatted(double date)
Used to let us know what the date being formatted is, in Excel terms, which we may wish to use when handling elapsed times.

format

public java.lang.StringBuffer format(java.util.Date date,
                                     java.lang.StringBuffer paramStringBuffer,
                                     java.text.FieldPosition paramFieldPosition)
Overrides:
format in class java.text.SimpleDateFormat
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FillPatternType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum FillPatternType

java.lang.Object
    extended by  java.lang.Enum<FillPatternType>
        extended by  org.apache.poi.ss.usermodel.FillPatternType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FillPatternType>
public enum FillPatternType
extends java.lang.Enum<FillPatternType>

The enumeration value indicating the style of fill pattern being used for a cell format.

Enum Constant Summary
ALT_BARS
Wide dots
BIG_SPOTS
Large spots
BRICKS
Brick-like layout
DIAMONDS
Diamonds
FINE_DOTS
Small fine dots
LEAST_DOTS
Least Dots
LESS_DOTS
Less Dots
NO_FILL
No background
SOLID_FOREGROUND
Solidly filled
SPARSE_DOTS
Sparse dots
SQUARES
Squares
THICK_BACKWARD_DIAG
Thick backward facing diagonals
THICK_FORWARD_DIAG
Thick forward facing diagonals
THICK_HORZ_BANDS
Thick horizontal bands
THICK_VERT_BANDS
Thick vertical bands
THIN_BACKWARD_DIAG
Thin backward diagonal
THIN_FORWARD_DIAG
Thin forward diagonal
THIN_HORZ_BANDS
Thin horizontal bands
THIN_VERT_BANDS
Thin vertical bands
Method Summary
static FillPatternType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FillPatternType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NO_FILL

public static final FillPatternType NO_FILL
No background

SOLID_FOREGROUND

public static final FillPatternType SOLID_FOREGROUND
Solidly filled

FINE_DOTS

public static final FillPatternType FINE_DOTS
Small fine dots

ALT_BARS

public static final FillPatternType ALT_BARS
Wide dots

SPARSE_DOTS

public static final FillPatternType SPARSE_DOTS
Sparse dots

THICK_HORZ_BANDS

public static final FillPatternType THICK_HORZ_BANDS
Thick horizontal bands

THICK_VERT_BANDS

public static final FillPatternType THICK_VERT_BANDS
Thick vertical bands

THICK_BACKWARD_DIAG

public static final FillPatternType THICK_BACKWARD_DIAG
Thick backward facing diagonals

THICK_FORWARD_DIAG

public static final FillPatternType THICK_FORWARD_DIAG
Thick forward facing diagonals

BIG_SPOTS

public static final FillPatternType BIG_SPOTS
Large spots

BRICKS

public static final FillPatternType BRICKS
Brick-like layout

THIN_HORZ_BANDS

public static final FillPatternType THIN_HORZ_BANDS
Thin horizontal bands

THIN_VERT_BANDS

public static final FillPatternType THIN_VERT_BANDS
Thin vertical bands

THIN_BACKWARD_DIAG

public static final FillPatternType THIN_BACKWARD_DIAG
Thin backward diagonal

THIN_FORWARD_DIAG

public static final FillPatternType THIN_FORWARD_DIAG
Thin forward diagonal

SQUARES

public static final FillPatternType SQUARES
Squares

DIAMONDS

public static final FillPatternType DIAMONDS
Diamonds

LESS_DOTS

public static final FillPatternType LESS_DOTS
Less Dots

LEAST_DOTS

public static final FillPatternType LEAST_DOTS
Least Dots

Method Detail

values

public static FillPatternType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FillPatternType c : FillPatternType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FillPatternType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Font

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Font

All Known Implementing Classes:
HSSFFont, XSSFFont
public interface Font

Field Summary
static byte | ANSI_CHARSET ANSI character set
static short | BOLDWEIGHT_BOLD Bold boldness (bold)
static short | BOLDWEIGHT_NORMAL Normal boldness (not bold)
static short | COLOR_NORMAL normal type of black color.
static short | COLOR_RED Dark Red color
static byte | DEFAULT_CHARSET Default character set.
static short | SS_NONE no type offsetting (not super or subscript)
static short | SS_SUB subscript
static short | SS_SUPER superscript
static byte | SYMBOL_CHARSET Symbol character set
static byte | U_DOUBLE double underlined
static byte | U_DOUBLE_ACCOUNTING accounting style double underline
static byte | U_NONE not underlined
static byte | U_SINGLE single (normal) underline
static byte | U_SINGLE_ACCOUNTING accounting style single underline
Method Summary
short | getBoldweight()
int | getCharSet() get character-set to use.
short | getColor() get the color for the font
short | getFontHeight() get the font height in unit's of 1/20th of a point.
short | getFontHeightInPoints() get the font height
java.lang.String | getFontName() get the name for the font (i.e.
short | getIndex() get the index within the XSSFWorkbook (sequence within the collection of Font objects)
boolean | getItalic() get whether to use italics or not
boolean | getStrikeout() get whether to use a strikeout horizontal line through the text or not
short | getTypeOffset() get normal,super or subscript.
byte | getUnderline() get type of text underlining to use
void | setBoldweight(short boldweight)
void | setCharSet(byte charset) set character-set to use.
void | setCharSet(int charset) set character-set to use.
void | setColor(short color) set the color for the font
void | setFontHeight(short height) set the font height in unit's of 1/20th of a point.
void | setFontHeightInPoints(short height) set the font height
void | setFontName(java.lang.String name) set the name for the font (i.e.
void | setItalic(boolean italic) set whether to use italics or not
void | setStrikeout(boolean strikeout) set whether to use a strikeout horizontal line through the text or not
void | setTypeOffset(short offset) set normal,super or subscript.
void | setUnderline(byte underline) set type of text underlining to use

Field Detail

BOLDWEIGHT_NORMAL

static final short BOLDWEIGHT_NORMAL
Normal boldness (not bold)

See Also:
Constant Field Values

BOLDWEIGHT_BOLD

static final short BOLDWEIGHT_BOLD
Bold boldness (bold)

See Also:
Constant Field Values

COLOR_NORMAL

static final short COLOR_NORMAL
normal type of black color.

See Also:
Constant Field Values

COLOR_RED

static final short COLOR_RED
Dark Red color

See Also:
Constant Field Values

SS_NONE

static final short SS_NONE
no type offsetting (not super or subscript)

See Also:
Constant Field Values

SS_SUPER

static final short SS_SUPER
superscript

See Also:
Constant Field Values

SS_SUB

static final short SS_SUB
subscript

See Also:
Constant Field Values

U_NONE

static final byte U_NONE
not underlined

See Also:
Constant Field Values

U_SINGLE

static final byte U_SINGLE
single (normal) underline

See Also:
Constant Field Values

U_DOUBLE

static final byte U_DOUBLE
double underlined

See Also:
Constant Field Values

U_SINGLE_ACCOUNTING

static final byte U_SINGLE_ACCOUNTING
accounting style single underline

See Also:
Constant Field Values

U_DOUBLE_ACCOUNTING

static final byte U_DOUBLE_ACCOUNTING
accounting style double underline

See Also:
Constant Field Values

ANSI_CHARSET

static final byte ANSI_CHARSET
ANSI character set

See Also:
Constant Field Values

DEFAULT_CHARSET

static final byte DEFAULT_CHARSET
Default character set.

See Also:
Constant Field Values

SYMBOL_CHARSET

static final byte SYMBOL_CHARSET
Symbol character set

See Also:
Constant Field Values
Method Detail

setFontName

void setFontName(java.lang.String name)
set the name for the font (i.e. Arial)

Parameters:
name - String representing the name of the font to use

getFontName

java.lang.String getFontName()
get the name for the font (i.e. Arial)

Returns:
String representing the name of the font to use

setFontHeight

void setFontHeight(short height)
set the font height in unit's of 1/20th of a point. Maybe you might want to use the setFontHeightInPoints which matches to the familiar 10, 12, 14 etc..

Parameters:
height - height in 1/20ths of a point
See Also:
setFontHeightInPoints(short)

setFontHeightInPoints

void setFontHeightInPoints(short height)
set the font height

Parameters:
height - height in the familiar unit of measure - points
See Also:
setFontHeight(short)

getFontHeight

short getFontHeight()
get the font height in unit's of 1/20th of a point. Maybe you might want to use the getFontHeightInPoints which matches to the familiar 10, 12, 14 etc..

Returns:
short - height in 1/20ths of a point
See Also:
getFontHeightInPoints()

getFontHeightInPoints

short getFontHeightInPoints()
get the font height

Returns:
short - height in the familiar unit of measure - points
See Also:
getFontHeight()

setItalic

void setItalic(boolean italic)
set whether to use italics or not

Parameters:
italic - italics or not

getItalic

boolean getItalic()
get whether to use italics or not

Returns:
italics or not

setStrikeout

void setStrikeout(boolean strikeout)
set whether to use a strikeout horizontal line through the text or not

Parameters:
strikeout - or not

getStrikeout

boolean getStrikeout()
get whether to use a strikeout horizontal line through the text or not

Returns:
strikeout or not

setColor

void setColor(short color)
set the color for the font

Parameters:
color - to use
See Also:
Note: Use this rather than HSSFColor.AUTOMATIC for default font color, COLOR_RED

getColor

short getColor()
get the color for the font

Returns:
color to use
See Also:
COLOR_NORMAL, COLOR_RED, HSSFPalette.getColor(short)

setTypeOffset

void setTypeOffset(short offset)
set normal,super or subscript.

Parameters:
offset - type to use (none,super,sub)
See Also:
SS_NONE, SS_SUPER, SS_SUB

getTypeOffset

short getTypeOffset()
get normal,super or subscript.

Returns:
offset type to use (none,super,sub)
See Also:
SS_NONE, SS_SUPER, SS_SUB

setUnderline

void setUnderline(byte underline)
set type of text underlining to use

Parameters:
underline - type
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

getUnderline

byte getUnderline()
get type of text underlining to use

Returns:
underlining type
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

getCharSet

int getCharSet()
get character-set to use.

Returns:
character-set
See Also:
ANSI_CHARSET, DEFAULT_CHARSET, SYMBOL_CHARSET

setCharSet

void setCharSet(byte charset)
set character-set to use.

See Also:
ANSI_CHARSET, DEFAULT_CHARSET, SYMBOL_CHARSET

setCharSet

void setCharSet(int charset)
set character-set to use.

See Also:
ANSI_CHARSET, DEFAULT_CHARSET, SYMBOL_CHARSET

getIndex

short getIndex()
get the index within the XSSFWorkbook (sequence within the collection of Font objects)

Returns:
unique index number of the underlying record this Font represents (probably you don't care unless you're comparing which one is which)

setBoldweight

void setBoldweight(short boldweight)

getBoldweight

short getBoldweight()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontCharset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum FontCharset

java.lang.Object
    extended by  java.lang.Enum<FontCharset>
        extended by  org.apache.poi.ss.usermodel.FontCharset
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FontCharset>
public enum FontCharset
extends java.lang.Enum<FontCharset>

Charset represents the basic set of characters associated with a font (that it can display), and corresponds to the ANSI codepage (8-bit or DBCS) of that character set used by a given language.

Author:
Gisella Bronzetti

Enum Constant Summary
ANSI
ARABIC
BALTIC
CHINESEBIG5
DEFAULT
EASTEUROPE
GB2312
GREEK
HANGEUL
HEBREW
JOHAB
MAC
OEM
RUSSIAN
SHIFTJIS
SYMBOL
THAI
TURKISH
VIETNAMESE
Method Summary
int | getValue() Returns value of this charset
static FontCharset | valueOf(int value)
static FontCharset | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontCharset[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ANSI

public static final FontCharset ANSI

DEFAULT

public static final FontCharset DEFAULT

SYMBOL

public static final FontCharset SYMBOL

MAC

public static final FontCharset MAC

SHIFTJIS

public static final FontCharset SHIFTJIS

HANGEUL

public static final FontCharset HANGEUL

JOHAB

public static final FontCharset JOHAB

GB2312

public static final FontCharset GB2312

CHINESEBIG5

public static final FontCharset CHINESEBIG5

GREEK

public static final FontCharset GREEK

TURKISH

public static final FontCharset TURKISH

VIETNAMESE

public static final FontCharset VIETNAMESE

HEBREW

public static final FontCharset HEBREW

ARABIC

public static final FontCharset ARABIC

BALTIC

public static final FontCharset BALTIC

RUSSIAN

public static final FontCharset RUSSIAN

THAI

public static final FontCharset THAI

EASTEUROPE

public static final FontCharset EASTEUROPE

OEM

public static final FontCharset OEM
Method Detail

values

public static FontCharset[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FontCharset c : FontCharset.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FontCharset valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()
Returns value of this charset

Returns:
value of this charset

valueOf

public static FontCharset valueOf(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


FontFamily

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum FontFamily

java.lang.Object
    extended by  java.lang.Enum<FontFamily>
        extended by  org.apache.poi.ss.usermodel.FontFamily
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FontFamily>
public enum FontFamily
extends java.lang.Enum<FontFamily>

The font family this font belongs to. A font family is a set of fonts having common stroke width and serif characteristics. The font name overrides when there are conflicting values.

Author:
Gisella Bronzetti

Enum Constant Summary
DECORATIVE
MODERN
NOT_APPLICABLE
ROMAN
SCRIPT
SWISS
Method Summary
int | getValue() Returns index of this font family
static FontFamily | valueOf(int family)
static FontFamily | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontFamily[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NOT_APPLICABLE

public static final FontFamily NOT_APPLICABLE

ROMAN

public static final FontFamily ROMAN

SWISS

public static final FontFamily SWISS

MODERN

public static final FontFamily MODERN

SCRIPT

public static final FontFamily SCRIPT

DECORATIVE

public static final FontFamily DECORATIVE
Method Detail

values

public static FontFamily[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FontFamily c : FontFamily.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FontFamily valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()
Returns index of this font family

Returns:
index of this font family

valueOf

public static FontFamily valueOf(int family)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


FontFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface FontFormatting

All Known Implementing Classes:
HSSFFontFormatting, XSSFFontFormatting
public interface FontFormatting

High level representation for Font Formatting component of Conditional Formatting settings

Author:
Dmitriy Kumshayev, Yegor Kozlov

Field Summary
static short | SS_NONE Escapement type - None
static short | SS_SUB Escapement type - Subscript
static short | SS_SUPER Escapement type - Superscript
static byte | U_DOUBLE Underline type - Double
static byte | U_DOUBLE_ACCOUNTING Underline type - Double Accounting
static byte | U_NONE Underline type - None
static byte | U_SINGLE Underline type - Single
static byte | U_SINGLE_ACCOUNTING Underline type - Single Accounting
Method Summary
short | getEscapementType() get the type of super or subscript for the font
short | getFontColorIndex()
int | getFontHeight() gets the height of the font in 1/20th point units
short | getUnderlineType() get the type of underlining for the font
boolean | isBold() get whether the font weight is set to bold or not
boolean | isItalic()
void | resetFontStyle() set font style options to default values (non-italic, non-bold)
void | setEscapementType(short escapementType) set the escapement type for the font
void | setFontColorIndex(short color)
void | setFontHeight(int height) Sets the height of the font in 1/20th point units
void | setFontStyle(boolean italic, boolean bold) set font style options.
void | setUnderlineType(short underlineType) set the type of underlining type for the font

Field Detail

SS_NONE

static final short SS_NONE
Escapement type - None

See Also:
Constant Field Values

SS_SUPER

static final short SS_SUPER
Escapement type - Superscript

See Also:
Constant Field Values

SS_SUB

static final short SS_SUB
Escapement type - Subscript

See Also:
Constant Field Values

U_NONE

static final byte U_NONE
Underline type - None

See Also:
Constant Field Values

U_SINGLE

static final byte U_SINGLE
Underline type - Single

See Also:
Constant Field Values

U_DOUBLE

static final byte U_DOUBLE
Underline type - Double

See Also:
Constant Field Values

U_SINGLE_ACCOUNTING

static final byte U_SINGLE_ACCOUNTING
Underline type - Single Accounting

See Also:
Constant Field Values

U_DOUBLE_ACCOUNTING

static final byte U_DOUBLE_ACCOUNTING
Underline type - Double Accounting

See Also:
Constant Field Values
Method Detail

getEscapementType

short getEscapementType()
get the type of super or subscript for the font

Returns:
super or subscript option
See Also:
SS_NONE, SS_SUPER, SS_SUB

setEscapementType

void setEscapementType(short escapementType)
set the escapement type for the font

Parameters:
escapementType - super or subscript option
See Also:
SS_NONE, SS_SUPER, SS_SUB

getFontColorIndex

short getFontColorIndex()
Returns:
font color index

setFontColorIndex

void setFontColorIndex(short color)
Parameters:
color - font color index

getFontHeight

int getFontHeight()
gets the height of the font in 1/20th point units

Returns:
fontheight (in points/20); or -1 if not modified

setFontHeight

void setFontHeight(int height)
Sets the height of the font in 1/20th point units

Parameters:
height - the height in twips (in points/20)

getUnderlineType

short getUnderlineType()
get the type of underlining for the font

Returns:
font underlining type
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

setUnderlineType

void setUnderlineType(short underlineType)
set the type of underlining type for the font

Parameters:
underlineType - super or subscript option
See Also:
U_NONE, U_SINGLE, U_DOUBLE, U_SINGLE_ACCOUNTING, U_DOUBLE_ACCOUNTING

isBold

boolean isBold()
get whether the font weight is set to bold or not

Returns:
bold - whether the font is bold or not

isItalic

boolean isItalic()
Returns:
true if font style was set to italic

setFontStyle

void setFontStyle(boolean italic,
                  boolean bold)
set font style options.

Parameters:
italic - - if true, set posture style to italic, otherwise to normal
bold - if true, set font weight to bold, otherwise to normal

resetFontStyle

void resetFontStyle()
set font style options to default values (non-italic, non-bold)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontScheme

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum FontScheme

java.lang.Object
    extended by  java.lang.Enum<FontScheme>
        extended by  org.apache.poi.ss.usermodel.FontScheme
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FontScheme>
public enum FontScheme
extends java.lang.Enum<FontScheme>

Defines the font scheme to which this font belongs. When a font definition is part of a theme definition, then the font is categorized as either a major or minor font scheme component. When a new theme is chosen, every font that is part of a theme definition is updated to use the new major or minor font definition for that theme. Usually major fonts are used for styles like headings, and minor fonts are used for body & paragraph text.

Author:
Gisella Bronzetti

Enum Constant Summary
MAJOR
MINOR
NONE
Method Summary
int | getValue()
static FontScheme | valueOf(int value)
static FontScheme | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontScheme[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final FontScheme NONE

MAJOR

public static final FontScheme MAJOR

MINOR

public static final FontScheme MINOR
Method Detail

values

public static FontScheme[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FontScheme c : FontScheme.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FontScheme valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static FontScheme valueOf(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


FontUnderline

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum FontUnderline

java.lang.Object
    extended by  java.lang.Enum<FontUnderline>
        extended by  org.apache.poi.ss.usermodel.FontUnderline
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FontUnderline>
public enum FontUnderline
extends java.lang.Enum<FontUnderline>

the different types of possible underline formatting

Author:
Gisella Bronzetti

Enum Constant Summary
DOUBLE
Double-line underlining under each character in the cell.
DOUBLE_ACCOUNTING
Double-line accounting underlining under each character in the cell.
NONE
No underline.
SINGLE
Single-line underlining under each character in the cell.
SINGLE_ACCOUNTING
Single-line accounting underlining under each character in the cell.
Method Summary
byte | getByteValue()
int | getValue()
static FontUnderline | valueOf(byte value)
static FontUnderline | valueOf(int value)
static FontUnderline | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontUnderline[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

SINGLE

public static final FontUnderline SINGLE
Single-line underlining under each character in the cell. The underline is drawn through the descenders of characters such as g and p..

DOUBLE

public static final FontUnderline DOUBLE
Double-line underlining under each character in the cell. underlines are drawn through the descenders of characters such as g and p.

SINGLE_ACCOUNTING

public static final FontUnderline SINGLE_ACCOUNTING
Single-line accounting underlining under each character in the cell. The underline is drawn under the descenders of characters such as g and p.

DOUBLE_ACCOUNTING

public static final FontUnderline DOUBLE_ACCOUNTING
Double-line accounting underlining under each character in the cell. The underlines are drawn under the descenders of characters such as g and p.

NONE

public static final FontUnderline NONE
No underline.

Method Detail

values

public static FontUnderline[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FontUnderline c : FontUnderline.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FontUnderline valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

getByteValue

public byte getByteValue()

valueOf

public static FontUnderline valueOf(int value)

valueOf

public static FontUnderline valueOf(byte value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Footer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Footer

All Superinterfaces:
HeaderFooter
All Known Implementing Classes:
HSSFFooter, XSSFEvenFooter, XSSFFirstFooter, XSSFOddFooter
public interface Footer
extends HeaderFooter

Common definition of a HSSF or XSSF page footer. For a list of all the different fields that can be placed into a footer, such as page number, bold, underline etc, see HeaderFooter.

Method Summary
java.lang.String | getCenter() Get the center of the footer.
java.lang.String | getLeft() Get the left side of the footer.
java.lang.String | getRight() Get the right side of the footer.
void | setCenter(java.lang.String newCenter) Sets the center string.
void | setLeft(java.lang.String newLeft) Sets the left string.
void | setRight(java.lang.String newRight) Sets the right string.

Method Detail

getLeft

java.lang.String getLeft()
Get the left side of the footer.

Specified by:
getLeft in interface HeaderFooter
Returns:
The string representing the left side.

setLeft

void setLeft(java.lang.String newLeft)
Sets the left string.

Specified by:
setLeft in interface HeaderFooter
Parameters:
newLeft - The string to set as the left side.

getCenter

java.lang.String getCenter()
Get the center of the footer.

Specified by:
getCenter in interface HeaderFooter
Returns:
The string representing the center.

setCenter

void setCenter(java.lang.String newCenter)
Sets the center string.

Specified by:
setCenter in interface HeaderFooter
Parameters:
newCenter - The string to set as the center.

getRight

java.lang.String getRight()
Get the right side of the footer.

Specified by:
getRight in interface HeaderFooter
Returns:
The string representing the right side.

setRight

void setRight(java.lang.String newRight)
Sets the right string.

Specified by:
setRight in interface HeaderFooter
Parameters:
newRight - The string to set as the right side.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormulaError

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum FormulaError

java.lang.Object
    extended by  java.lang.Enum<FormulaError>
        extended by  org.apache.poi.ss.usermodel.FormulaError
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<FormulaError>
public enum FormulaError
extends java.lang.Enum<FormulaError>

Enumerates error values in SpreadsheetML formula calculations.

Author:
Yegor Kozlov

Enum Constant Summary
DIV0
Intended to indicate when any number, including zero, is divided by zero.
NA
Intended to indicate when a designated value is not available.
NAME
Intended to indicate when what looks like a name is used, but no such name has been defined.
NULL
Intended to indicate when two areas are required to intersect, but do not.
NUM
Intended to indicate when an argument to a function has a compatible type, but has a value that is outside the domain over which that function is defined.
REF
Intended to indicate when a cell reference is invalid.
VALUE
Intended to indicate when an incompatible type argument is passed to a function, or an incompatible type operand is used with an operator.
Method Summary
static FormulaError | forInt(byte type)
static FormulaError | forString(java.lang.String code)
byte | getCode()
java.lang.String | getString()
static FormulaError | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FormulaError[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NULL

public static final FormulaError NULL
Intended to indicate when two areas are required to intersect, but do not.

Example: In the case of SUM(B1 C1), the space between B1 and C1 is treated as the binary intersection operator, when a comma was intended. end example]

DIV0

public static final FormulaError DIV0
Intended to indicate when any number, including zero, is divided by zero. Note: However, any error code divided by zero results in that error code.

VALUE

public static final FormulaError VALUE
Intended to indicate when an incompatible type argument is passed to a function, or an incompatible type operand is used with an operator.

Example: In the case of a function argument, text was expected, but a number was provided

REF

public static final FormulaError REF
Intended to indicate when a cell reference is invalid.

Example: If a formula contains a reference to a cell, and then the row or column containing that cell is deleted, a #REF! error results. If a worksheet does not support 20,001 columns, OFFSET(A1,0,20000) will result in a #REF! error.

NAME

public static final FormulaError NAME
Intended to indicate when what looks like a name is used, but no such name has been defined.

Example: XYZ/3, where XYZ is not a defined name. Total is & A10, where neither Total nor is is a defined name. Presumably, "Total is " & A10 was intended. SUM(A1C10), where the range A1:C10 was intended.

NUM

public static final FormulaError NUM
Intended to indicate when an argument to a function has a compatible type, but has a value that is outside the domain over which that function is defined. (This is known as a domain error.)

Example: Certain calls to ASIN, ATANH, FACT, and SQRT might result in domain errors.

Intended to indicate that the result of a function cannot be represented in a value of the specified type, typically due to extreme magnitude. (This is known as a range error.)

Example: FACT(1000) might result in a range error.

NA

public static final FormulaError NA
Intended to indicate when a designated value is not available.

Example: Some functions, such as SUMX2MY2, perform a series of operations on corresponding elements in two arrays. If those arrays do not have the same number of elements, then for some elements in the longer array, there are no corresponding elements in the shorter one; that is, one or more values in the shorter array are not available.

This error value can be produced by calling the function NA

Method Detail

values

public static FormulaError[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (FormulaError c : FormulaError.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FormulaError valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getCode

public byte getCode()
Returns:
numeric code of the error

getString

public java.lang.String getString()
Returns:
string representation of the error

forInt

public static FormulaError forInt(byte type)

forString

public static FormulaError forString(java.lang.String code)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


FormulaEvaluator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface FormulaEvaluator

All Known Implementing Classes:
HSSFFormulaEvaluator, XSSFFormulaEvaluator
public interface FormulaEvaluator

Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values. Be sure to call clearAllCachedResultValues() if any workbook cells are changed between calls to evaluate~ methods on this class.

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >, Josh Micich

Method Summary
void | clearAllCachedResultValues() Should be called whenever there are changes to input cells in the evaluated workbook.
CellValue | evaluate(Cell cell) If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
void | evaluateAll() Loops over all cells in all sheets of the associated workbook.
int | evaluateFormulaCell(Cell cell) If cell contains formula, it evaluates the formula, and saves the result of the formula.
Cell | evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
void | notifyDeleteCell(Cell cell) Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed
void | notifySetFormula(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
void | notifyUpdateCell(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.

Method Detail

clearAllCachedResultValues

void clearAllCachedResultValues()
Should be called whenever there are changes to input cells in the evaluated workbook. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

notifySetFormula

void notifySetFormula(Cell cell)
Should be called to tell the cell value cache that the specified (value or formula) cell has changed. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

notifyDeleteCell

void notifyDeleteCell(Cell cell)
Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed

notifyUpdateCell

void notifyUpdateCell(Cell cell)
Should be called to tell the cell value cache that the specified (value or formula) cell has changed. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

evaluateAll

void evaluateAll()
Loops over all cells in all sheets of the associated workbook. For cells that contain formulas, their formulas are evaluated, and the results are saved. These cells remain as formula cells. For cells that do not contain formulas, no changes are made. This is a helpful wrapper around looping over all cells, and calling evaluateFormulaCell on each one.

evaluate

CellValue evaluate(Cell cell)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type. This method should be preferred over evaluateInCell() when the call should not modify the contents of the original cell.

Parameters:
cell -

evaluateFormulaCell

int evaluateFormulaCell(Cell cell)
If cell contains formula, it evaluates the formula, and saves the result of the formula. The cell remains as a formula cell. Else if cell does not contain formula, this method leaves the cell unchanged. Note that the type of the formula result is returned, so you know what kind of value is also stored with the formula.
 int evaluatedCellType = evaluator.evaluateFormulaCell(cell);
Be aware that your cell will hold both the formula, and the result. If you want the cell replaced with the result of the formula, use evaluateInCell(Cell)

Parameters:
cell - The cell to evaluate
Returns:
The type of the formula result (the cell's type remains as Cell.CELL_TYPE_FORMULA however)

evaluateInCell

Cell evaluateInCell(Cell cell)
If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula. Else if cell does not contain formula, this method leaves the cell unchanged. Note that the same instance of Cell is returned to allow chained calls like:
 int evaluatedCellType = evaluator.evaluateInCell(cell).getCellType();
Be aware that your cell value will be changed to hold the result of the formula. If you simply want the formula value computed for you, use evaluateFormulaCell(Cell)

Parameters:
cell -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Header

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Header

All Superinterfaces:
HeaderFooter
All Known Implementing Classes:
HSSFHeader, XSSFEvenHeader, XSSFFirstHeader, XSSFOddHeader
public interface Header
extends HeaderFooter

Common definition of a HSSF or XSSF page header. For a list of all the different fields that can be placed into a header, such as page number, bold, underline etc, see HeaderFooter.

Method Summary
java.lang.String | getCenter() Get the center of the header.
java.lang.String | getLeft() Get the left side of the header.
java.lang.String | getRight() Get the right side of the header.
void | setCenter(java.lang.String newCenter) Sets the center string.
void | setLeft(java.lang.String newLeft) Sets the left string.
void | setRight(java.lang.String newRight) Sets the right string.

Method Detail

getLeft

java.lang.String getLeft()
Get the left side of the header.

Specified by:
getLeft in interface HeaderFooter
Returns:
The string representing the left side.

setLeft

void setLeft(java.lang.String newLeft)
Sets the left string.

Specified by:
setLeft in interface HeaderFooter
Parameters:
newLeft - The string to set as the left side.

getCenter

java.lang.String getCenter()
Get the center of the header.

Specified by:
getCenter in interface HeaderFooter
Returns:
The string representing the center.

setCenter

void setCenter(java.lang.String newCenter)
Sets the center string.

Specified by:
setCenter in interface HeaderFooter
Parameters:
newCenter - The string to set as the center.

getRight

java.lang.String getRight()
Get the right side of the header.

Specified by:
getRight in interface HeaderFooter
Returns:
The string representing the right side.

setRight

void setRight(java.lang.String newRight)
Sets the right string.

Specified by:
setRight in interface HeaderFooter
Parameters:
newRight - The string to set as the right side.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeaderFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface HeaderFooter

All Known Subinterfaces:
Footer, Header
All Known Implementing Classes:
HeaderFooter, HSSFFooter, HSSFHeader, XSSFEvenFooter, XSSFEvenHeader, XSSFFirstFooter, XSSFFirstHeader, XSSFHeaderFooter, XSSFOddFooter, XSSFOddHeader
public interface HeaderFooter

Common interface for Header and Footer.

Method Summary
java.lang.String | getCenter() Get the center of the header or footer.
java.lang.String | getLeft() Get the left side of the header or footer.
java.lang.String | getRight() Get the right side of the header or footer.
void | setCenter(java.lang.String newCenter) Sets the center string.
void | setLeft(java.lang.String newLeft) Sets the left string.
void | setRight(java.lang.String newRight) Sets the right string or footer.

Method Detail

getLeft

java.lang.String getLeft()
Get the left side of the header or footer.

Returns:
The string representing the left side.

setLeft

void setLeft(java.lang.String newLeft)
Sets the left string.

Parameters:
newLeft - The string to set as the left side.

getCenter

java.lang.String getCenter()
Get the center of the header or footer.

Returns:
The string representing the center.

setCenter

void setCenter(java.lang.String newCenter)
Sets the center string.

Parameters:
newCenter - The string to set as the center.

getRight

java.lang.String getRight()
Get the right side of the header or footer.

Returns:
The string representing the right side.

setRight

void setRight(java.lang.String newRight)
Sets the right string or footer.

Parameters:
newRight - The string to set as the right side.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HorizontalAlignment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum HorizontalAlignment

java.lang.Object
    extended by  java.lang.Enum<HorizontalAlignment>
        extended by  org.apache.poi.ss.usermodel.HorizontalAlignment
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<HorizontalAlignment>
public enum HorizontalAlignment
extends java.lang.Enum<HorizontalAlignment>

The enumeration value indicating horizontal alignment of a cell, i.e., whether it is aligned general, left, right, horizontally centered, filled (replicated), justified, centered across multiple cells, or distributed.

Enum Constant Summary
CENTER
The horizontal alignment is centered, meaning the text is centered across the cell.
CENTER_SELECTION
The horizontal alignment is centered across multiple cells.
DISTRIBUTED
Indicates that each 'word' in each line of text inside the cell is evenly distributed across the width of the cell, with flush right and left margins.
FILL
Indicates that the value of the cell should be filled across the entire width of the cell.
GENERAL
The horizontal alignment is general-aligned.
JUSTIFY
The horizontal alignment is justified (flush left and right).
LEFT
The horizontal alignment is left-aligned, even in Rightto-Left mode.
RIGHT
The horizontal alignment is right-aligned, meaning that cell contents are aligned at the right edge of the cell, even in Right-to-Left mode.
Method Summary
static HorizontalAlignment | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static HorizontalAlignment[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

GENERAL

public static final HorizontalAlignment GENERAL
The horizontal alignment is general-aligned. Text data is left-aligned. Numbers, dates, and times are rightaligned. Boolean types are centered. Changing the alignment does not change the type of data.

LEFT

public static final HorizontalAlignment LEFT
The horizontal alignment is left-aligned, even in Rightto-Left mode. Aligns contents at the left edge of the cell. If an indent amount is specified, the contents of the cell is indented from the left by the specified number of character spaces. The character spaces are based on the default font and font size for the workbook.

CENTER

public static final HorizontalAlignment CENTER
The horizontal alignment is centered, meaning the text is centered across the cell.

RIGHT

public static final HorizontalAlignment RIGHT
The horizontal alignment is right-aligned, meaning that cell contents are aligned at the right edge of the cell, even in Right-to-Left mode.

FILL

public static final HorizontalAlignment FILL
Indicates that the value of the cell should be filled across the entire width of the cell. If blank cells to the right also have the fill alignment, they are also filled with the value, using a convention similar to centerContinuous.

Additional rules:

  1. Only whole values can be appended, not partial values.
  2. The column will not be widened to 'best fit' the filled value
  3. If appending an additional occurrence of the value exceeds the boundary of the cell left/right edge, don't append the additional occurrence of the value.
  4. The display value of the cell is filled, not the underlying raw number.

JUSTIFY

public static final HorizontalAlignment JUSTIFY
The horizontal alignment is justified (flush left and right). For each line of text, aligns each line of the wrapped text in a cell to the right and left (except the last line). If no single line of text wraps in the cell, then the text is not justified.

CENTER_SELECTION

public static final HorizontalAlignment CENTER_SELECTION
The horizontal alignment is centered across multiple cells. The information about how many cells to span is expressed in the Sheet Part, in the row of the cell in question. For each cell that is spanned in the alignment, a cell element needs to be written out, with the same style Id which references the centerContinuous alignment.

DISTRIBUTED

public static final HorizontalAlignment DISTRIBUTED
Indicates that each 'word' in each line of text inside the cell is evenly distributed across the width of the cell, with flush right and left margins.

When there is also an indent value to apply, both the left and right side of the cell are padded by the indent value.

A 'word' is a set of characters with no space character in them.

Two lines inside a cell are separated by a carriage return.

Method Detail

values

public static HorizontalAlignment[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (HorizontalAlignment c : HorizontalAlignment.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static HorizontalAlignment valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Hyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Hyperlink

All Superinterfaces:
Hyperlink
public interface Hyperlink
extends Hyperlink

Represents an Excel hyperlink.

Field Summary
Fields inherited from interface org.apache.poi.common.usermodel.Hyperlink
LINK_DOCUMENT, LINK_EMAIL, LINK_FILE, LINK_URL
Method Summary
int | getFirstColumn() Return the column of the first cell that contains the hyperlink
int | getFirstRow() Return the row of the first cell that contains the hyperlink
int | getLastColumn() Return the column of the last cell that contains the hyperlink
int | getLastRow() Return the row of the last cell that contains the hyperlink
void | setFirstColumn(int col) Set the column of the first cell that contains the hyperlink
void | setFirstRow(int row) Set the row of the first cell that contains the hyperlink
void | setLastColumn(int col) Set the column of the last cell that contains the hyperlink
void | setLastRow(int row) Set the row of the last cell that contains the hyperlink
Methods inherited from interface org.apache.poi.common.usermodel.Hyperlink
getAddress, getLabel, getType, setAddress, setLabel

Method Detail

getFirstRow

int getFirstRow()
Return the row of the first cell that contains the hyperlink

Returns:
the 0-based row of the cell that contains the hyperlink

setFirstRow

void setFirstRow(int row)
Set the row of the first cell that contains the hyperlink

Parameters:
row - the 0-based row of the first cell that contains the hyperlink

getLastRow

int getLastRow()
Return the row of the last cell that contains the hyperlink

Returns:
the 0-based row of the last cell that contains the hyperlink

setLastRow

void setLastRow(int row)
Set the row of the last cell that contains the hyperlink

Parameters:
row - the 0-based row of the last cell that contains the hyperlink

getFirstColumn

int getFirstColumn()
Return the column of the first cell that contains the hyperlink

Returns:
the 0-based column of the first cell that contains the hyperlink

setFirstColumn

void setFirstColumn(int col)
Set the column of the first cell that contains the hyperlink

Parameters:
col - the 0-based column of the first cell that contains the hyperlink

getLastColumn

int getLastColumn()
Return the column of the last cell that contains the hyperlink

Returns:
the 0-based column of the last cell that contains the hyperlink

setLastColumn

void setLastColumn(int col)
Set the column of the last cell that contains the hyperlink

Parameters:
col - the 0-based column of the last cell that contains the hyperlink
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexedColors

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum IndexedColors

java.lang.Object
    extended by  java.lang.Enum<IndexedColors>
        extended by  org.apache.poi.ss.usermodel.IndexedColors
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<IndexedColors>
public enum IndexedColors
extends java.lang.Enum<IndexedColors>

A deprecated indexing scheme for colours that is still required for some records, and for backwards compatibility with OLE2 formats.

Each element corresponds to a color index (zero-based). When using the default indexed color palette, the values are not written out, but instead are implied. When the color palette has been modified from default, then the entire color palette is used.

Author:
Yegor Kozlov

Enum Constant Summary
AQUA
AUTOMATIC
BLACK
BLUE
BLUE_GREY
BRIGHT_GREEN
BROWN
CORAL
CORNFLOWER_BLUE
DARK_BLUE
DARK_GREEN
DARK_RED
DARK_TEAL
DARK_YELLOW
GOLD
GREEN
GREY_25_PERCENT
GREY_40_PERCENT
GREY_50_PERCENT
GREY_80_PERCENT
INDIGO
LAVENDER
LEMON_CHIFFON
LIGHT_BLUE
LIGHT_CORNFLOWER_BLUE
LIGHT_GREEN
LIGHT_ORANGE
LIGHT_TURQUOISE
LIGHT_YELLOW
LIME
MAROON
OLIVE_GREEN
ORANGE
ORCHID
PALE_BLUE
PINK
PLUM
RED
ROSE
ROYAL_BLUE
SEA_GREEN
SKY_BLUE
TAN
TEAL
TURQUOISE
VIOLET
WHITE
YELLOW
Field Summary
 short index
Method Summary
short | getIndex() Returns index of this color
static IndexedColors | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static IndexedColors[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

BLACK

public static final IndexedColors BLACK

WHITE

public static final IndexedColors WHITE

RED

public static final IndexedColors RED

BRIGHT_GREEN

public static final IndexedColors BRIGHT_GREEN

BLUE

public static final IndexedColors BLUE

YELLOW

public static final IndexedColors YELLOW

PINK

public static final IndexedColors PINK

TURQUOISE

public static final IndexedColors TURQUOISE

DARK_RED

public static final IndexedColors DARK_RED

GREEN

public static final IndexedColors GREEN

DARK_BLUE

public static final IndexedColors DARK_BLUE

DARK_YELLOW

public static final IndexedColors DARK_YELLOW

VIOLET

public static final IndexedColors VIOLET

TEAL

public static final IndexedColors TEAL

GREY_25_PERCENT

public static final IndexedColors GREY_25_PERCENT

GREY_50_PERCENT

public static final IndexedColors GREY_50_PERCENT

CORNFLOWER_BLUE

public static final IndexedColors CORNFLOWER_BLUE

MAROON

public static final IndexedColors MAROON

LEMON_CHIFFON

public static final IndexedColors LEMON_CHIFFON

ORCHID

public static final IndexedColors ORCHID

CORAL

public static final IndexedColors CORAL

ROYAL_BLUE

public static final IndexedColors ROYAL_BLUE

LIGHT_CORNFLOWER_BLUE

public static final IndexedColors LIGHT_CORNFLOWER_BLUE

SKY_BLUE

public static final IndexedColors SKY_BLUE

LIGHT_TURQUOISE

public static final IndexedColors LIGHT_TURQUOISE

LIGHT_GREEN

public static final IndexedColors LIGHT_GREEN

LIGHT_YELLOW

public static final IndexedColors LIGHT_YELLOW

PALE_BLUE

public static final IndexedColors PALE_BLUE

ROSE

public static final IndexedColors ROSE

LAVENDER

public static final IndexedColors LAVENDER

TAN

public static final IndexedColors TAN

LIGHT_BLUE

public static final IndexedColors LIGHT_BLUE

AQUA

public static final IndexedColors AQUA

LIME

public static final IndexedColors LIME

GOLD

public static final IndexedColors GOLD

LIGHT_ORANGE

public static final IndexedColors LIGHT_ORANGE

ORANGE

public static final IndexedColors ORANGE

BLUE_GREY

public static final IndexedColors BLUE_GREY

GREY_40_PERCENT

public static final IndexedColors GREY_40_PERCENT

DARK_TEAL

public static final IndexedColors DARK_TEAL

SEA_GREEN

public static final IndexedColors SEA_GREEN

DARK_GREEN

public static final IndexedColors DARK_GREEN

OLIVE_GREEN

public static final IndexedColors OLIVE_GREEN

BROWN

public static final IndexedColors BROWN

PLUM

public static final IndexedColors PLUM

INDIGO

public static final IndexedColors INDIGO

GREY_80_PERCENT

public static final IndexedColors GREY_80_PERCENT

AUTOMATIC

public static final IndexedColors AUTOMATIC
Field Detail

index

public final short index
Method Detail

values

public static IndexedColors[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (IndexedColors c : IndexedColors.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static IndexedColors valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getIndex

public short getIndex()
Returns index of this color

Returns:
index of this color
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Name

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Name

All Known Implementing Classes:
HSSFName, XSSFName
public interface Name

Represents a defined name for a range of cells.

A name is a meaningful shorthand that makes it easier to understand the purpose of a cell reference, constant or a formula.

Examples:

  Sheet sheet = workbook.createSheet("Loan Calculator");
  Name name;

  name = workbook.createName();
  name.setNameName("Interest_Rate");
  name.setRefersToFormula("'Loan Calculator'!$E$5");

  name = wb.createName();
  name.setNameName("Loan_Amount");
  name.setRefersToFormula("'Loan Calculator'!$E$4");

  name = wb.createName();
  name.setNameName("Number_of_Payments");
  name.setRefersToFormula("'Loan Calculator'!$E$10");

  name = wb.createName();
  name.setNameName("Monthly_Payment");
  name.setRefersToFormula("-PMT(Interest_Rate/12,Number_of_Payments,Loan_Amount)");

  name = wb.createName();
  name.setNameName("Values_Entered");
  name.setRefersToFormula("IF(Loan_Amount*Interest_Rate>0,1,0)");

Method Summary
java.lang.String | getComment() Returns the comment the user provided when the name was created.
java.lang.String | getNameName() Gets the name of the named range
java.lang.String | getRefersToFormula() Returns the formula that the name is defined to refer to.
int | getSheetIndex() Returns the sheet index this name applies to.
java.lang.String | getSheetName() Get the sheets name which this named range is referenced to
boolean | isDeleted() Checks if this name points to a cell that no longer exists
boolean | isFunctionName() Checks if this name is a function name
void | setComment(java.lang.String comment) Sets the comment the user provided when the name was created.
void | setFunction(boolean value) Indicates that the defined name refers to a user-defined function.
void | setNameName(java.lang.String name) Sets the name of the named range
void | setRefersToFormula(java.lang.String formulaText) Sets the formula that the name is defined to refer to.
void | setSheetIndex(int sheetId) Tell Excel that this name applies to the worksheet with the specified index instead of the entire workbook.

Method Detail

getSheetName

java.lang.String getSheetName()
Get the sheets name which this named range is referenced to

Returns:
sheet name, which this named range refered to

getNameName

java.lang.String getNameName()
Gets the name of the named range

Returns:
named range name

setNameName

void setNameName(java.lang.String name)
Sets the name of the named range

The following is a list of syntax rules that you need to be aware of when you create and edit names.

  • Valid characters The first character of a name must be a letter, an underscore character (_), or a backslash (\). Remaining characters in the name can be letters, numbers, periods, and underscore characters.
  • Cell references disallowed Names cannot be the same as a cell reference, such as Z$100 or R1C1.
  • Spaces are not valid Spaces are not allowed as part of a name. Use the underscore character (_) and period (.) as word separators, such as, Sales_Tax or First.Quarter.
  • Name length A name can contain up to 255 characters.
  • Case sensitivity Names can contain uppercase and lowercase letters.

A name must always be unique within its scope. POI prevents you from defining a name that is not unique within its scope. However you can use the same name in different scopes. Example:

 //by default names are workbook-global
 Name name;
 name = workbook.createName();
 name.setNameName("sales_08");

 name = workbook.createName();
 name.setNameName("sales_08"); //will throw an exception: "The workbook already contains this name (case-insensitive)"

 //create sheet-level name
 name = workbook.createName();
 name.setSheetIndex(0); //the scope of the name is the first sheet
 name.setNameName("sales_08");  //ok

 name = workbook.createName();
 name.setSheetIndex(0);
 name.setNameName("sales_08");  //will throw an exception: "The sheet already contains this name (case-insensitive)"

Parameters:
name - named range name to set
Throws:
java.lang.IllegalArgumentException - if the name is invalid or the already exists within its scope (case-insensitive)

getRefersToFormula

java.lang.String getRefersToFormula()
Returns the formula that the name is defined to refer to.

Returns:
the reference for this name, null if it has not been set yet. Never empty string
See Also:
setRefersToFormula(String)

setRefersToFormula

void setRefersToFormula(java.lang.String formulaText)
Sets the formula that the name is defined to refer to. The following are representative examples:
  • 'My Sheet'!$A$3
  • 8.3
  • HR!$A$1:$Z$345
  • SUM(Sheet1!A1,Sheet2!B2)
  • -PMT(Interest_Rate/12,Number_of_Payments,Loan_Amount)

Parameters:
formulaText - the reference for this name
Throws:
java.lang.IllegalArgumentException - if the specified formulaText is unparsable

isFunctionName

boolean isFunctionName()
Checks if this name is a function name

Returns:
true if this name is a function name

isDeleted

boolean isDeleted()
Checks if this name points to a cell that no longer exists

Returns:
true if the name refers to a deleted cell, false otherwise

setSheetIndex

void setSheetIndex(int sheetId)
Tell Excel that this name applies to the worksheet with the specified index instead of the entire workbook.

Parameters:
sheetId - the sheet index this name applies to, -1 unsets this property making the name workbook-global
Throws:
java.lang.IllegalArgumentException - if the sheet index is invalid.

getSheetIndex

int getSheetIndex()
Returns the sheet index this name applies to.

Returns:
the sheet index this name applies to, -1 if this name applies to the entire workbook

getComment

java.lang.String getComment()
Returns the comment the user provided when the name was created.

Returns:
the user comment for this named range

setComment

void setComment(java.lang.String comment)
Sets the comment the user provided when the name was created.

Parameters:
comment - the user comment for this named range

setFunction

void setFunction(boolean value)
Indicates that the defined name refers to a user-defined function. This attribute is used when there is an add-in or other code project associated with the file.

Parameters:
value - true indicates the name refers to a function.
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.usermodel
Interfaces
AutoFilter
BorderFormatting
Cell
CellRange
CellStyle
Chart
ClientAnchor
Color
Comment
ConditionalFormatting
ConditionalFormattingRule
CreationHelper
DataFormat
DataValidation
DataValidationConstraint
DataValidationHelper
Drawing
Font
FontFormatting
Footer
FormulaEvaluator
Header
HeaderFooter
Hyperlink
Name
PatternFormatting
Picture
PictureData
PrintSetup
RichTextString
Row
Sheet
SheetConditionalFormatting
Textbox
Workbook
Classes
BuiltinFormats
CellValue
ComparisonOperator
DataFormatter
DataValidation.ErrorStyle
DataValidationConstraint.OperatorType
DataValidationConstraint.ValidationType
DateUtil
ErrorConstants
ExcelStyleDateFormatter
Row.MissingCellPolicy
ShapeTypes
WorkbookFactory
Enums
BorderStyle
FillPatternType
FontCharset
FontFamily
FontScheme
FontUnderline
FormulaError
HorizontalAlignment
IndexedColors
PageOrder
PaperSize
PrintCellComments
PrintOrientation
VerticalAlignment


org.apache.poi.ss.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.usermodel

Interface Summary
AutoFilter | Represents autofiltering for the specified worksheet.
BorderFormatting |
Cell | High level representation of a cell in a row of a spreadsheet.
CellRange<C extends Cell> | Represents a rectangular region of a Sheet
CellStyle |
Chart | High level representation of a chart.
ClientAnchor | A client anchor is attached to an excel worksheet.
Color |
Comment |
ConditionalFormatting | The ConditionalFormatting class encapsulates all settings of Conditional Formatting.
ConditionalFormattingRule | Represents a description of a conditional formatting rule
CreationHelper | An object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
DataFormat |
DataValidation |
DataValidationConstraint |
DataValidationHelper |
Drawing | High level representation of spreadsheet drawing.
Font |
FontFormatting | High level representation for Font Formatting component of Conditional Formatting settings
Footer | Common definition of a HSSF or XSSF page footer.
FormulaEvaluator | Evaluates formula cells. For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.
Header | Common definition of a HSSF or XSSF page header.
HeaderFooter | Common interface for Header and Footer.
Hyperlink | Represents an Excel hyperlink.
Name | Represents a defined name for a range of cells.
PatternFormatting |
Picture | Repersents a picture in a SpreadsheetML document
PictureData |
PrintSetup |
RichTextString | Rich text unicode string.
Row | High level representation of a row of a spreadsheet.
Sheet | High level representation of a Excel worksheet.
SheetConditionalFormatting | The 'Conditional Formatting' facet of Sheet
Textbox |
Workbook | High level representation of a Excel workbook.

Class Summary
BuiltinFormats | Utility to identify built-in formats.
CellValue | Mimics the 'data view' of a cell.
ComparisonOperator | The conditional format operators used for "Highlight Cells That Contain..." rules.
DataFormatter | DataFormatter contains methods for formatting the value stored in an Cell.
DataValidation.ErrorStyle | Error style constants for error box
DataValidationConstraint.OperatorType | Condition operator enum
DataValidationConstraint.ValidationType | ValidationType enum
DateUtil | Contains methods for dealing with Excel dates.
ErrorConstants | Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)
ExcelStyleDateFormatter | A wrapper around a SimpleDateFormat instance, which handles a few Excel-style extensions that are not supported by SimpleDateFormat.
Row.MissingCellPolicy | Used to specify the different possible policies if for the case of null and blank cells
ShapeTypes | All known types of automatic shapes in DrawingML
WorkbookFactory | Factory for creating the appropriate kind of Workbook (be it HSSFWorkbook or XSSFWorkbook), from the given input

Enum Summary
BorderStyle | The enumeration value indicating the line style of a border in a cell, i.e., whether it is borded dash dot, dash dot dot, dashed, dotted, double, hair, medium, medium dash dot, medium dash dot dot, medium dashed, none, slant dash dot, thick or thin.
FillPatternType | The enumeration value indicating the style of fill pattern being used for a cell format.
FontCharset | Charset represents the basic set of characters associated with a font (that it can display), and corresponds to the ANSI codepage (8-bit or DBCS) of that character set used by a given language.
FontFamily | The font family this font belongs to.
FontScheme | Defines the font scheme to which this font belongs.
FontUnderline | the different types of possible underline formatting
FormulaError | Enumerates error values in SpreadsheetML formula calculations.
HorizontalAlignment | The enumeration value indicating horizontal alignment of a cell, i.e., whether it is aligned general, left, right, horizontally centered, filled (replicated), justified, centered across multiple cells, or distributed.
IndexedColors | A deprecated indexing scheme for colours that is still required for some records, and for backwards compatibility with OLE2 formats.
PageOrder | Specifies printed page order.
PaperSize | The enumeration value indicating the possible paper size for a sheet
PrintCellComments | These enumerations specify how cell comments shall be displayed for paper printing purposes.
PrintOrientation | The enumeration value indicating the print orientation for a sheet.
VerticalAlignment | This enumeration value indicates the type of vertical alignment for a cell, i.e., whether it is aligned top, bottom, vertically centered, justified or distributed.


org.apache.poi.ss.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.usermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.usermodel.BuiltinFormats
    • org.apache.poi.ss.usermodel.CellValue
    • org.apache.poi.ss.usermodel.ComparisonOperator
    • org.apache.poi.ss.usermodel.DataFormatter
    • org.apache.poi.ss.usermodel.DataValidation.ErrorStyle
    • org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType
    • org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType
    • org.apache.poi.ss.usermodel.DateUtil
    • org.apache.poi.ss.usermodel.ErrorConstants
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
          • org.apache.poi.ss.usermodel.ExcelStyleDateFormatter
    • org.apache.poi.ss.usermodel.Row.MissingCellPolicy
    • org.apache.poi.ss.usermodel.ShapeTypes
    • org.apache.poi.ss.usermodel.WorkbookFactory

Interface Hierarchy

  • org.apache.poi.ss.usermodel.AutoFilter
  • org.apache.poi.ss.usermodel.BorderFormatting
  • org.apache.poi.ss.usermodel.Cell
  • org.apache.poi.ss.usermodel.CellStyle
  • org.apache.poi.ss.usermodel.ClientAnchor
  • org.apache.poi.ss.usermodel.Color
  • org.apache.poi.ss.usermodel.Comment
  • org.apache.poi.ss.usermodel.ConditionalFormatting
  • org.apache.poi.ss.usermodel.ConditionalFormattingRule
  • org.apache.poi.ss.usermodel.CreationHelper
  • org.apache.poi.ss.usermodel.DataFormat
  • org.apache.poi.ss.usermodel.DataValidation
  • org.apache.poi.ss.usermodel.DataValidationConstraint
  • org.apache.poi.ss.usermodel.DataValidationHelper
  • org.apache.poi.ss.usermodel.Drawing
  • org.apache.poi.ss.usermodel.Font
  • org.apache.poi.ss.usermodel.FontFormatting
  • org.apache.poi.ss.usermodel.FormulaEvaluator
  • org.apache.poi.ss.usermodel.HeaderFooter
    • org.apache.poi.ss.usermodel.Footer
    • org.apache.poi.ss.usermodel.Header
  • org.apache.poi.common.usermodel.Hyperlink
    • org.apache.poi.ss.usermodel.Hyperlink
  • java.lang.Iterable<T>
    • org.apache.poi.ss.usermodel.CellRange<C>
    • org.apache.poi.ss.usermodel.Row
    • org.apache.poi.ss.usermodel.Sheet
  • org.apache.poi.ss.usermodel.charts.ManuallyPositionable
    • org.apache.poi.ss.usermodel.Chart
  • org.apache.poi.ss.usermodel.Name
  • org.apache.poi.ss.usermodel.PatternFormatting
  • org.apache.poi.ss.usermodel.Picture
  • org.apache.poi.ss.usermodel.PictureData
  • org.apache.poi.ss.usermodel.PrintSetup
  • org.apache.poi.ss.usermodel.RichTextString
  • org.apache.poi.ss.usermodel.SheetConditionalFormatting
  • org.apache.poi.ss.usermodel.Textbox
  • org.apache.poi.ss.usermodel.Workbook

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.ss.usermodel.VerticalAlignment
      • org.apache.poi.ss.usermodel.PrintOrientation
      • org.apache.poi.ss.usermodel.PrintCellComments
      • org.apache.poi.ss.usermodel.PaperSize
      • org.apache.poi.ss.usermodel.PageOrder
      • org.apache.poi.ss.usermodel.IndexedColors
      • org.apache.poi.ss.usermodel.HorizontalAlignment
      • org.apache.poi.ss.usermodel.FormulaError
      • org.apache.poi.ss.usermodel.FontUnderline
      • org.apache.poi.ss.usermodel.FontScheme
      • org.apache.poi.ss.usermodel.FontFamily
      • org.apache.poi.ss.usermodel.FontCharset
      • org.apache.poi.ss.usermodel.FillPatternType
      • org.apache.poi.ss.usermodel.BorderStyle


Uses of Package org.apache.poi.ss.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.usermodel

Packages that use org.apache.poi.ss.usermodel
org.apache.poi.hssf.converter |
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.format | This package contains classes that implement cell formatting
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.formula.functions |
org.apache.poi.ss.usermodel |
org.apache.poi.ss.usermodel.charts |
org.apache.poi.ss.util |
org.apache.poi.ss.util.cellwalk |
org.apache.poi.xssf.eventusermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.charts |
org.apache.poi.xssf.usermodel.extensions |
org.apache.poi.xssf.usermodel.helpers |

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.hssf.converter
CellStyle

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.hssf.extractor
HeaderFooter
Common interface for Header and Footer.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.hssf.usermodel
AutoFilter
Represents autofiltering for the specified worksheet.
BorderFormatting
Cell
High level representation of a cell in a row of a spreadsheet.
CellRange
Represents a rectangular region of a Sheet
CellStyle
CellValue
Mimics the 'data view' of a cell.
Chart
High level representation of a chart.
ClientAnchor
A client anchor is attached to an excel worksheet.
Comment
ConditionalFormatting
The ConditionalFormatting class encapsulates all settings of Conditional Formatting.
ConditionalFormattingRule
Represents a description of a conditional formatting rule
CreationHelper
An object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
DataFormat
DataFormatter
DataFormatter contains methods for formatting the value stored in an Cell.
DataValidation
DataValidationConstraint
DataValidationHelper
DateUtil
Contains methods for dealing with Excel dates.
Drawing
High level representation of spreadsheet drawing.
ErrorConstants
Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)
Font
FontFormatting
High level representation for Font Formatting component of Conditional Formatting settings
Footer
Common definition of a HSSF or XSSF page footer.
FormulaEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

Header
Common definition of a HSSF or XSSF page header.
HeaderFooter
Common interface for Header and Footer.
Hyperlink
Represents an Excel hyperlink.
Name
Represents a defined name for a range of cells.
PatternFormatting
Picture
Repersents a picture in a SpreadsheetML document
PictureData
PrintSetup
RichTextString
Rich text unicode string.
Row
High level representation of a row of a spreadsheet.
Row.MissingCellPolicy
Used to specify the different possible policies if for the case of null and blank cells
Sheet
High level representation of a Excel worksheet.
SheetConditionalFormatting
The 'Conditional Formatting' facet of Sheet
Workbook
High level representation of a Excel workbook.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.hssf.util
Color

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.ss.format
Cell
High level representation of a cell in a row of a spreadsheet.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.ss.formula.eval.forked
Workbook
High level representation of a Excel workbook.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.ss.formula.functions
DataFormatter
DataFormatter contains methods for formatting the value stored in an Cell.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.ss.usermodel
AutoFilter
Represents autofiltering for the specified worksheet.
BorderFormatting
BorderStyle
The enumeration value indicating the line style of a border in a cell, i.e., whether it is borded dash dot, dash dot dot, dashed, dotted, double, hair, medium, medium dash dot, medium dash dot dot, medium dashed, none, slant dash dot, thick or thin.
Cell
High level representation of a cell in a row of a spreadsheet.
CellRange
Represents a rectangular region of a Sheet
CellStyle
CellValue
Mimics the 'data view' of a cell.
Chart
High level representation of a chart.
ClientAnchor
A client anchor is attached to an excel worksheet.
Color
Comment
ConditionalFormatting
The ConditionalFormatting class encapsulates all settings of Conditional Formatting.
ConditionalFormattingRule
Represents a description of a conditional formatting rule
CreationHelper
An object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
DataFormat
DataValidation
DataValidationConstraint
DataValidationHelper
Drawing
High level representation of spreadsheet drawing.
FillPatternType
The enumeration value indicating the style of fill pattern being used for a cell format.
Font
FontCharset
Charset represents the basic set of characters associated with a font (that it can display), and corresponds to the ANSI codepage (8-bit or DBCS) of that character set used by a given language.
FontFamily
The font family this font belongs to.
FontFormatting
High level representation for Font Formatting component of Conditional Formatting settings
FontScheme
Defines the font scheme to which this font belongs.
FontUnderline
the different types of possible underline formatting
Footer
Common definition of a HSSF or XSSF page footer.
FormulaError
Enumerates error values in SpreadsheetML formula calculations.
FormulaEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

Header
Common definition of a HSSF or XSSF page header.
HeaderFooter
Common interface for Header and Footer.
HorizontalAlignment
The enumeration value indicating horizontal alignment of a cell, i.e., whether it is aligned general, left, right, horizontally centered, filled (replicated), justified, centered across multiple cells, or distributed.
Hyperlink
Represents an Excel hyperlink.
IndexedColors
A deprecated indexing scheme for colours that is still required for some records, and for backwards compatibility with OLE2 formats.
Name
Represents a defined name for a range of cells.
PageOrder
Specifies printed page order.
PaperSize
The enumeration value indicating the possible paper size for a sheet
PatternFormatting
Picture
Repersents a picture in a SpreadsheetML document
PictureData
PrintCellComments
These enumerations specify how cell comments shall be displayed for paper printing purposes.
PrintOrientation
The enumeration value indicating the print orientation for a sheet.
PrintSetup
RichTextString
Rich text unicode string.
Row
High level representation of a row of a spreadsheet.
Row.MissingCellPolicy
Used to specify the different possible policies if for the case of null and blank cells
Sheet
High level representation of a Excel worksheet.
SheetConditionalFormatting
The 'Conditional Formatting' facet of Sheet
VerticalAlignment
This enumeration value indicates the type of vertical alignment for a cell, i.e., whether it is aligned top, bottom, vertically centered, justified or distributed.
Workbook
High level representation of a Excel workbook.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.ss.usermodel.charts
Chart
High level representation of a chart.
Sheet
High level representation of a Excel worksheet.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.ss.util
Cell
High level representation of a cell in a row of a spreadsheet.
CellRange
Represents a rectangular region of a Sheet
CellStyle
DataFormatter
DataFormatter contains methods for formatting the value stored in an Cell.
Font
Row
High level representation of a row of a spreadsheet.
Sheet
High level representation of a Excel worksheet.
Workbook
High level representation of a Excel workbook.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.ss.util.cellwalk
Cell
High level representation of a cell in a row of a spreadsheet.
Sheet
High level representation of a Excel worksheet.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.xssf.eventusermodel
DataFormatter
DataFormatter contains methods for formatting the value stored in an Cell.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.xssf.streaming
AutoFilter
Represents autofiltering for the specified worksheet.
Cell
High level representation of a cell in a row of a spreadsheet.
CellRange
Represents a rectangular region of a Sheet
CellStyle
Comment
CreationHelper
An object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
DataFormat
DataValidation
DataValidationHelper
Drawing
High level representation of spreadsheet drawing.
Font
Footer
Common definition of a HSSF or XSSF page footer.
Header
Common definition of a HSSF or XSSF page header.
Hyperlink
Represents an Excel hyperlink.
Name
Represents a defined name for a range of cells.
PictureData
PrintSetup
RichTextString
Rich text unicode string.
Row
High level representation of a row of a spreadsheet.
Row.MissingCellPolicy
Used to specify the different possible policies if for the case of null and blank cells
Sheet
High level representation of a Excel worksheet.
SheetConditionalFormatting
The 'Conditional Formatting' facet of Sheet
Workbook
High level representation of a Excel workbook.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.xssf.usermodel
AutoFilter
Represents autofiltering for the specified worksheet.
BorderFormatting
BorderStyle
The enumeration value indicating the line style of a border in a cell, i.e., whether it is borded dash dot, dash dot dot, dashed, dotted, double, hair, medium, medium dash dot, medium dash dot dot, medium dashed, none, slant dash dot, thick or thin.
Cell
High level representation of a cell in a row of a spreadsheet.
CellRange
Represents a rectangular region of a Sheet
CellStyle
CellValue
Mimics the 'data view' of a cell.
Chart
High level representation of a chart.
ClientAnchor
A client anchor is attached to an excel worksheet.
Color
Comment
ConditionalFormatting
The ConditionalFormatting class encapsulates all settings of Conditional Formatting.
ConditionalFormattingRule
Represents a description of a conditional formatting rule
CreationHelper
An object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
DataFormat
DataValidation
DataValidationConstraint
DataValidationHelper
Drawing
High level representation of spreadsheet drawing.
FillPatternType
The enumeration value indicating the style of fill pattern being used for a cell format.
Font
FontCharset
Charset represents the basic set of characters associated with a font (that it can display), and corresponds to the ANSI codepage (8-bit or DBCS) of that character set used by a given language.
FontFamily
The font family this font belongs to.
FontFormatting
High level representation for Font Formatting component of Conditional Formatting settings
FontScheme
Defines the font scheme to which this font belongs.
FontUnderline
the different types of possible underline formatting
Footer
Common definition of a HSSF or XSSF page footer.
FormulaError
Enumerates error values in SpreadsheetML formula calculations.
FormulaEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

Header
Common definition of a HSSF or XSSF page header.
HeaderFooter
Common interface for Header and Footer.
HorizontalAlignment
The enumeration value indicating horizontal alignment of a cell, i.e., whether it is aligned general, left, right, horizontally centered, filled (replicated), justified, centered across multiple cells, or distributed.
Hyperlink
Represents an Excel hyperlink.
Name
Represents a defined name for a range of cells.
PageOrder
Specifies printed page order.
PaperSize
The enumeration value indicating the possible paper size for a sheet
PatternFormatting
Picture
Repersents a picture in a SpreadsheetML document
PictureData
PrintCellComments
These enumerations specify how cell comments shall be displayed for paper printing purposes.
PrintOrientation
The enumeration value indicating the print orientation for a sheet.
PrintSetup
RichTextString
Rich text unicode string.
Row
High level representation of a row of a spreadsheet.
Row.MissingCellPolicy
Used to specify the different possible policies if for the case of null and blank cells
Sheet
High level representation of a Excel worksheet.
SheetConditionalFormatting
The 'Conditional Formatting' facet of Sheet
VerticalAlignment
This enumeration value indicates the type of vertical alignment for a cell, i.e., whether it is aligned top, bottom, vertically centered, justified or distributed.
Workbook
High level representation of a Excel workbook.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.xssf.usermodel.charts
Chart
High level representation of a chart.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.xssf.usermodel.extensions
BorderStyle
The enumeration value indicating the line style of a border in a cell, i.e., whether it is borded dash dot, dash dot dot, dashed, dotted, double, hair, medium, medium dash dot, medium dash dot dot, medium dashed, none, slant dash dot, thick or thin.
HeaderFooter
Common interface for Header and Footer.
HorizontalAlignment
The enumeration value indicating horizontal alignment of a cell, i.e., whether it is aligned general, left, right, horizontally centered, filled (replicated), justified, centered across multiple cells, or distributed.
VerticalAlignment
This enumeration value indicates the type of vertical alignment for a cell, i.e., whether it is aligned top, bottom, vertically centered, justified or distributed.

Classes in org.apache.poi.ss.usermodel used by org.apache.poi.xssf.usermodel.helpers
CellStyle

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PageOrder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum PageOrder

java.lang.Object
    extended by  java.lang.Enum<PageOrder>
        extended by  org.apache.poi.ss.usermodel.PageOrder
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<PageOrder>
public enum PageOrder
extends java.lang.Enum<PageOrder>

Specifies printed page order.

Author:
Gisella Bronzetti

Enum Constant Summary
DOWN_THEN_OVER
Order pages vertically first, then move horizontally.
OVER_THEN_DOWN
Order pages horizontally first, then move vertically
Method Summary
int | getValue()
static PageOrder | valueOf(int value)
static PageOrder | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PageOrder[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

DOWN_THEN_OVER

public static final PageOrder DOWN_THEN_OVER
Order pages vertically first, then move horizontally.

OVER_THEN_DOWN

public static final PageOrder OVER_THEN_DOWN
Order pages horizontally first, then move vertically

Method Detail

values

public static PageOrder[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (PageOrder c : PageOrder.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static PageOrder valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static PageOrder valueOf(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


PaperSize

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum PaperSize

java.lang.Object
    extended by  java.lang.Enum<PaperSize>
        extended by  org.apache.poi.ss.usermodel.PaperSize
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<PaperSize>
public enum PaperSize
extends java.lang.Enum<PaperSize>

The enumeration value indicating the possible paper size for a sheet

Author:
Daniele Montagni

Enum Constant Summary
A3_PAPER
A4_PAPER
A4_SMALL_PAPER
A5_PAPER
B4_PAPER
B5_PAPER
EXECUTIVE_PAPER
FOLIO_PAPER
LEDGER_PAPER
LEGAL_PAPER
LETTER_PAPER
LETTER_SMALL_PAPER
QUARTO_PAPER
STANDARD_PAPER_10_14
STANDARD_PAPER_11_17
STATEMENT_PAPER
TABLOID_PAPER
Method Summary
static PaperSize | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PaperSize[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LETTER_PAPER

public static final PaperSize LETTER_PAPER

LETTER_SMALL_PAPER

public static final PaperSize LETTER_SMALL_PAPER

TABLOID_PAPER

public static final PaperSize TABLOID_PAPER

LEDGER_PAPER

public static final PaperSize LEDGER_PAPER

LEGAL_PAPER

public static final PaperSize LEGAL_PAPER

STATEMENT_PAPER

public static final PaperSize STATEMENT_PAPER

EXECUTIVE_PAPER

public static final PaperSize EXECUTIVE_PAPER

A3_PAPER

public static final PaperSize A3_PAPER

A4_PAPER

public static final PaperSize A4_PAPER

A4_SMALL_PAPER

public static final PaperSize A4_SMALL_PAPER

A5_PAPER

public static final PaperSize A5_PAPER

B4_PAPER

public static final PaperSize B4_PAPER

B5_PAPER

public static final PaperSize B5_PAPER

FOLIO_PAPER

public static final PaperSize FOLIO_PAPER

QUARTO_PAPER

public static final PaperSize QUARTO_PAPER

STANDARD_PAPER_10_14

public static final PaperSize STANDARD_PAPER_10_14

STANDARD_PAPER_11_17

public static final PaperSize STANDARD_PAPER_11_17
Method Detail

values

public static PaperSize[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (PaperSize c : PaperSize.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static PaperSize valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


PatternFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface PatternFormatting

All Known Implementing Classes:
HSSFPatternFormatting, XSSFPatternFormatting
public interface PatternFormatting

Author:
Yegor Kozlov

Field Summary
static short | ALT_BARS Wide dots
static short | BIG_SPOTS Large spots
static short | BRICKS Brick-like layout
static short | DIAMONDS Diamonds
static short | FINE_DOTS Small fine dots
static short | LEAST_DOTS Least Dots
static short | LESS_DOTS Less Dots
static short | NO_FILL No background
static short | SOLID_FOREGROUND Solidly filled
static short | SPARSE_DOTS Sparse dots
static short | SQUARES Squares
static short | THICK_BACKWARD_DIAG Thick backward facing diagonals
static short | THICK_FORWARD_DIAG Thick forward facing diagonals
static short | THICK_HORZ_BANDS Thick horizontal bands
static short | THICK_VERT_BANDS Thick vertical bands
static short | THIN_BACKWARD_DIAG Thin backward diagonal
static short | THIN_FORWARD_DIAG Thin forward diagonal
static short | THIN_HORZ_BANDS Thin horizontal bands
static short | THIN_VERT_BANDS Thin vertical bands
Method Summary
short | getFillBackgroundColor()
short | getFillForegroundColor()
short | getFillPattern()
void | setFillBackgroundColor(short bg)
void | setFillForegroundColor(short fg)
void | setFillPattern(short fp)

Field Detail

NO_FILL

static final short NO_FILL
No background

See Also:
Constant Field Values

SOLID_FOREGROUND

static final short SOLID_FOREGROUND
Solidly filled

See Also:
Constant Field Values

FINE_DOTS

static final short FINE_DOTS
Small fine dots

See Also:
Constant Field Values

ALT_BARS

static final short ALT_BARS
Wide dots

See Also:
Constant Field Values

SPARSE_DOTS

static final short SPARSE_DOTS
Sparse dots

See Also:
Constant Field Values

THICK_HORZ_BANDS

static final short THICK_HORZ_BANDS
Thick horizontal bands

See Also:
Constant Field Values

THICK_VERT_BANDS

static final short THICK_VERT_BANDS
Thick vertical bands

See Also:
Constant Field Values

THICK_BACKWARD_DIAG

static final short THICK_BACKWARD_DIAG
Thick backward facing diagonals

See Also:
Constant Field Values

THICK_FORWARD_DIAG

static final short THICK_FORWARD_DIAG
Thick forward facing diagonals

See Also:
Constant Field Values

BIG_SPOTS

static final short BIG_SPOTS
Large spots

See Also:
Constant Field Values

BRICKS

static final short BRICKS
Brick-like layout

See Also:
Constant Field Values

THIN_HORZ_BANDS

static final short THIN_HORZ_BANDS
Thin horizontal bands

See Also:
Constant Field Values

THIN_VERT_BANDS

static final short THIN_VERT_BANDS
Thin vertical bands

See Also:
Constant Field Values

THIN_BACKWARD_DIAG

static final short THIN_BACKWARD_DIAG
Thin backward diagonal

See Also:
Constant Field Values

THIN_FORWARD_DIAG

static final short THIN_FORWARD_DIAG
Thin forward diagonal

See Also:
Constant Field Values

SQUARES

static final short SQUARES
Squares

See Also:
Constant Field Values

DIAMONDS

static final short DIAMONDS
Diamonds

See Also:
Constant Field Values

LESS_DOTS

static final short LESS_DOTS
Less Dots

See Also:
Constant Field Values

LEAST_DOTS

static final short LEAST_DOTS
Least Dots

See Also:
Constant Field Values
Method Detail

getFillBackgroundColor

short getFillBackgroundColor()

getFillForegroundColor

short getFillForegroundColor()

getFillPattern

short getFillPattern()

setFillBackgroundColor

void setFillBackgroundColor(short bg)

setFillForegroundColor

void setFillForegroundColor(short fg)

setFillPattern

void setFillPattern(short fp)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Picture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Picture

All Known Implementing Classes:
HSSFPicture, XSSFPicture
public interface Picture

Repersents a picture in a SpreadsheetML document

Author:
Yegor Kozlov

Method Summary
PictureData | getPictureData() Return picture data for this picture
ClientAnchor | getPreferredSize()
void | resize() Reset the image to the original size.
void | resize(double scale) Reset the image to the original size.

Method Detail

resize

void resize()
Reset the image to the original size.

Please note, that this method works correctly only for workbooks with default font size (Arial 10pt for .xls and Calibri 11pt for .xlsx). If the default font is changed the resized image can be streched vertically or horizontally.

resize

void resize(double scale)
Reset the image to the original size.

Please note, that this method works correctly only for workbooks with default font size (Arial 10pt for .xls and Calibri 11pt for .xlsx). If the default font is changed the resize() procedure can be 'off'.

Parameters:
scale - the amount by which image dimensions are multiplied relative to the original size. resize(1.0) sets the original size, resize(0.5) resize to 50% of the original, resize(2.0) resizes to 200% of the original.

getPreferredSize

ClientAnchor getPreferredSize()

getPictureData

PictureData getPictureData()
Return picture data for this picture

Returns:
picture data for this picture
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PictureData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface PictureData

All Known Implementing Classes:
HSSFPictureData, XSSFPictureData
public interface PictureData

Method Summary
byte[] | getData() Gets the picture data.
java.lang.String | getMimeType() Returns the mime type for the image
java.lang.String | suggestFileExtension() Suggests a file extension for this image.

Method Detail

getData

byte[] getData()
Gets the picture data.

Returns:
the picture data.

suggestFileExtension

java.lang.String suggestFileExtension()
Suggests a file extension for this image.

Returns:
the file extension.

getMimeType

java.lang.String getMimeType()
Returns the mime type for the image

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrintCellComments

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum PrintCellComments

java.lang.Object
    extended by  java.lang.Enum<PrintCellComments>
        extended by  org.apache.poi.ss.usermodel.PrintCellComments
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<PrintCellComments>
public enum PrintCellComments
extends java.lang.Enum<PrintCellComments>

These enumerations specify how cell comments shall be displayed for paper printing purposes.

Author:
Gisella Bronzetti

Enum Constant Summary
AS_DISPLAYED
Print cell comments as displayed.
AT_END
Print cell comments at end of document.
NONE
Do not print cell comments.
Method Summary
int | getValue()
static PrintCellComments | valueOf(int value)
static PrintCellComments | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PrintCellComments[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final PrintCellComments NONE
Do not print cell comments.

AS_DISPLAYED

public static final PrintCellComments AS_DISPLAYED
Print cell comments as displayed.

AT_END

public static final PrintCellComments AT_END
Print cell comments at end of document.

Method Detail

values

public static PrintCellComments[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (PrintCellComments c : PrintCellComments.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static PrintCellComments valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static PrintCellComments valueOf(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


PrintOrientation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum PrintOrientation

java.lang.Object
    extended by  java.lang.Enum<PrintOrientation>
        extended by  org.apache.poi.ss.usermodel.PrintOrientation
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<PrintOrientation>
public enum PrintOrientation
extends java.lang.Enum<PrintOrientation>

The enumeration value indicating the print orientation for a sheet.

Author:
Gisella Bronzetti

Enum Constant Summary
DEFAULT
orientation not specified
LANDSCAPE
landscape orientations
PORTRAIT
portrait orientation
Method Summary
int | getValue()
static PrintOrientation | valueOf(int value)
static PrintOrientation | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PrintOrientation[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

DEFAULT

public static final PrintOrientation DEFAULT
orientation not specified

PORTRAIT

public static final PrintOrientation PORTRAIT
portrait orientation

LANDSCAPE

public static final PrintOrientation LANDSCAPE
landscape orientations

Method Detail

values

public static PrintOrientation[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (PrintOrientation c : PrintOrientation.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static PrintOrientation valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static PrintOrientation valueOf(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


PrintSetup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface PrintSetup

All Known Implementing Classes:
HSSFPrintSetup, XSSFPrintSetup
public interface PrintSetup

Field Summary
static short | A3_PAPERSIZE A3 - 297x420 mm
static short | A4_EXTRA_PAPERSIZE A4 Extra - 9.27 x 12.69 in
static short | A4_PAPERSIZE A4 - 210x297 mm
static short | A4_PLUS_PAPERSIZE A4 Plus - 210x330 mm
static short | A4_ROTATED_PAPERSIZE A4 Rotated - 297x210 mm
static short | A4_SMALL_PAPERSIZE A4 Small - 210x297 mm
static short | A4_TRANSVERSE_PAPERSIZE A4 Transverse - 210x297 mm
static short | A5_PAPERSIZE A5 - 148x210 mm
static short | B4_PAPERSIZE B4 (JIS) 250x354 mm
static short | B5_PAPERSIZE B5 (JIS) 182x257 mm
static short | ELEVEN_BY_SEVENTEEN_PAPERSIZE 11 x 17 in
static short | ENVELOPE_10_PAPERSIZE US Envelope #10 4 1/8 x 9 1/2
static short | ENVELOPE_9_PAPERSIZE US Envelope #9 3 7/8 x 8 7/8
static short | ENVELOPE_C3_PAPERSIZE Envelope C3 324x458 mm
static short | ENVELOPE_C4_PAPERSIZE Envelope C4 229x324 mm
static short | ENVELOPE_C5_PAPERSIZE
static short | ENVELOPE_C6_PAPERSIZE Envelope C6 114x162 mm
static short | ENVELOPE_CS_PAPERSIZE Envelope C5 162x229 mm
static short | ENVELOPE_DL_PAPERSIZE Envelope DL 110x220 mm
static short | ENVELOPE_MONARCH_PAPERSIZE
static short | EXECUTIVE_PAPERSIZE US Executive 7 1/4 x 10 1/2 in
static short | FOLIO8_PAPERSIZE Folio 8 1/2 x 13 in
static short | LEDGER_PAPERSIZE US Ledger 17 x 11 in
static short | LEGAL_PAPERSIZE US Legal 8 1/2 x 14 in
static short | LETTER_PAPERSIZE US Letter 8 1/2 x 11 in
static short | LETTER_ROTATED_PAPERSIZE US Letter Rotated 11 x 8 1/2 in
static short | LETTER_SMALL_PAGESIZE US Letter Small 8 1/2 x 11 in
static short | NOTE8_PAPERSIZE US Note 8 1/2 x 11 in
static short | QUARTO_PAPERSIZE Quarto 215x275 mm
static short | STATEMENT_PAPERSIZE US Statement 5 1/2 x 8 1/2 in
static short | TABLOID_PAPERSIZE US Tabloid 11 x 17 in
static short | TEN_BY_FOURTEEN_PAPERSIZE 10 x 14 in
Method Summary
short | getCopies() Returns the number of copies.
boolean | getDraft() Returns the draft mode.
short | getFitHeight() Returns the number of pages high to fit the sheet in.
short | getFitWidth() Returns the number of pages wide to fit sheet in.
double | getFooterMargin() Returns the footer margin.
double | getHeaderMargin() Returns the header margin.
short | getHResolution() Returns the horizontal resolution.
boolean | getLandscape() Returns the landscape mode.
boolean | getLeftToRight() Returns the left to right print order.
boolean | getNoColor() Returns the black and white setting.
boolean | getNoOrientation() Returns the no orientation.
boolean | getNotes() Returns the print notes.
short | getPageStart() Returns the page start.
short | getPaperSize() Returns the paper size.
short | getScale() Returns the scale.
boolean | getUsePage() Returns the use page numbers.
boolean | getValidSettings() Returns the valid settings.
short | getVResolution() Returns the vertical resolution.
void | setCopies(short copies) Sets the number of copies.
void | setDraft(boolean d) Set whether it is in draft mode
void | setFitHeight(short height) Set the number of pages high to fit the sheet in
void | setFitWidth(short width) Set the number of pages wide to fit the sheet in
void | setFooterMargin(double footermargin) Sets the footer margin.
void | setHeaderMargin(double headermargin) Sets the header margin.
void | setHResolution(short resolution) Sets the horizontal resolution.
void | setLandscape(boolean ls) Set whether to print in landscape
void | setLeftToRight(boolean ltor) Set whether to go left to right or top down in ordering
void | setNoColor(boolean mono) Set whether it is black and white
void | setNoOrientation(boolean orientation) Set no orientation.
void | setNotes(boolean printnotes) Print the include notes
void | setPageStart(short start) Set the page numbering start.
void | setPaperSize(short size) Set the paper size.
void | setScale(short scale) Set the scale.
void | setUsePage(boolean page) Set whether to use page start
void | setValidSettings(boolean valid) Valid settings.
void | setVResolution(short resolution) Sets the vertical resolution.

Field Detail

LETTER_PAPERSIZE

static final short LETTER_PAPERSIZE
US Letter 8 1/2 x 11 in

See Also:
Constant Field Values

LETTER_SMALL_PAGESIZE

static final short LETTER_SMALL_PAGESIZE
US Letter Small 8 1/2 x 11 in

See Also:
Constant Field Values

TABLOID_PAPERSIZE

static final short TABLOID_PAPERSIZE
US Tabloid 11 x 17 in

See Also:
Constant Field Values

LEDGER_PAPERSIZE

static final short LEDGER_PAPERSIZE
US Ledger 17 x 11 in

See Also:
Constant Field Values

LEGAL_PAPERSIZE

static final short LEGAL_PAPERSIZE
US Legal 8 1/2 x 14 in

See Also:
Constant Field Values

STATEMENT_PAPERSIZE

static final short STATEMENT_PAPERSIZE
US Statement 5 1/2 x 8 1/2 in

See Also:
Constant Field Values

EXECUTIVE_PAPERSIZE

static final short EXECUTIVE_PAPERSIZE
US Executive 7 1/4 x 10 1/2 in

See Also:
Constant Field Values

A3_PAPERSIZE

static final short A3_PAPERSIZE
A3 - 297x420 mm

See Also:
Constant Field Values

A4_PAPERSIZE

static final short A4_PAPERSIZE
A4 - 210x297 mm

See Also:
Constant Field Values

A4_SMALL_PAPERSIZE

static final short A4_SMALL_PAPERSIZE
A4 Small - 210x297 mm

See Also:
Constant Field Values

A5_PAPERSIZE

static final short A5_PAPERSIZE
A5 - 148x210 mm

See Also:
Constant Field Values

B4_PAPERSIZE

static final short B4_PAPERSIZE
B4 (JIS) 250x354 mm

See Also:
Constant Field Values

B5_PAPERSIZE

static final short B5_PAPERSIZE
B5 (JIS) 182x257 mm

See Also:
Constant Field Values

FOLIO8_PAPERSIZE

static final short FOLIO8_PAPERSIZE
Folio 8 1/2 x 13 in

See Also:
Constant Field Values

QUARTO_PAPERSIZE

static final short QUARTO_PAPERSIZE
Quarto 215x275 mm

See Also:
Constant Field Values

TEN_BY_FOURTEEN_PAPERSIZE

static final short TEN_BY_FOURTEEN_PAPERSIZE
10 x 14 in

See Also:
Constant Field Values

ELEVEN_BY_SEVENTEEN_PAPERSIZE

static final short ELEVEN_BY_SEVENTEEN_PAPERSIZE
11 x 17 in

See Also:
Constant Field Values

NOTE8_PAPERSIZE

static final short NOTE8_PAPERSIZE
US Note 8 1/2 x 11 in

See Also:
Constant Field Values

ENVELOPE_9_PAPERSIZE

static final short ENVELOPE_9_PAPERSIZE
US Envelope #9 3 7/8 x 8 7/8

See Also:
Constant Field Values

ENVELOPE_10_PAPERSIZE

static final short ENVELOPE_10_PAPERSIZE
US Envelope #10 4 1/8 x 9 1/2

See Also:
Constant Field Values

ENVELOPE_DL_PAPERSIZE

static final short ENVELOPE_DL_PAPERSIZE
Envelope DL 110x220 mm

See Also:
Constant Field Values

ENVELOPE_CS_PAPERSIZE

static final short ENVELOPE_CS_PAPERSIZE
Envelope C5 162x229 mm

See Also:
Constant Field Values

ENVELOPE_C5_PAPERSIZE

static final short ENVELOPE_C5_PAPERSIZE
See Also:
Constant Field Values

ENVELOPE_C3_PAPERSIZE

static final short ENVELOPE_C3_PAPERSIZE
Envelope C3 324x458 mm

See Also:
Constant Field Values

ENVELOPE_C4_PAPERSIZE

static final short ENVELOPE_C4_PAPERSIZE
Envelope C4 229x324 mm

See Also:
Constant Field Values

ENVELOPE_C6_PAPERSIZE

static final short ENVELOPE_C6_PAPERSIZE
Envelope C6 114x162 mm

See Also:
Constant Field Values

ENVELOPE_MONARCH_PAPERSIZE

static final short ENVELOPE_MONARCH_PAPERSIZE
See Also:
Constant Field Values

A4_EXTRA_PAPERSIZE

static final short A4_EXTRA_PAPERSIZE
A4 Extra - 9.27 x 12.69 in

See Also:
Constant Field Values

A4_TRANSVERSE_PAPERSIZE

static final short A4_TRANSVERSE_PAPERSIZE
A4 Transverse - 210x297 mm

See Also:
Constant Field Values

A4_PLUS_PAPERSIZE

static final short A4_PLUS_PAPERSIZE
A4 Plus - 210x330 mm

See Also:
Constant Field Values

LETTER_ROTATED_PAPERSIZE

static final short LETTER_ROTATED_PAPERSIZE
US Letter Rotated 11 x 8 1/2 in

See Also:
Constant Field Values

A4_ROTATED_PAPERSIZE

static final short A4_ROTATED_PAPERSIZE
A4 Rotated - 297x210 mm

See Also:
Constant Field Values
Method Detail

setPaperSize

void setPaperSize(short size)
Set the paper size.

Parameters:
size - the paper size.

setScale

void setScale(short scale)
Set the scale.

Parameters:
scale - the scale to use

setPageStart

void setPageStart(short start)
Set the page numbering start.

Parameters:
start - the page numbering start

setFitWidth

void setFitWidth(short width)
Set the number of pages wide to fit the sheet in

Parameters:
width - the number of pages

setFitHeight

void setFitHeight(short height)
Set the number of pages high to fit the sheet in

Parameters:
height - the number of pages

setLeftToRight

void setLeftToRight(boolean ltor)
Set whether to go left to right or top down in ordering

Parameters:
ltor - left to right

setLandscape

void setLandscape(boolean ls)
Set whether to print in landscape

Parameters:
ls - landscape

setValidSettings

void setValidSettings(boolean valid)
Valid settings. I'm not for sure.

Parameters:
valid - Valid

setNoColor

void setNoColor(boolean mono)
Set whether it is black and white

Parameters:
mono - Black and white

setDraft

void setDraft(boolean d)
Set whether it is in draft mode

Parameters:
d - draft

setNotes

void setNotes(boolean printnotes)
Print the include notes

Parameters:
printnotes - print the notes

setNoOrientation

void setNoOrientation(boolean orientation)
Set no orientation. ?

Parameters:
orientation - Orientation.

setUsePage

void setUsePage(boolean page)
Set whether to use page start

Parameters:
page - Use page start

setHResolution

void setHResolution(short resolution)
Sets the horizontal resolution.

Parameters:
resolution - horizontal resolution

setVResolution

void setVResolution(short resolution)
Sets the vertical resolution.

Parameters:
resolution - vertical resolution

setHeaderMargin

void setHeaderMargin(double headermargin)
Sets the header margin.

Parameters:
headermargin - header margin

setFooterMargin

void setFooterMargin(double footermargin)
Sets the footer margin.

Parameters:
footermargin - footer margin

setCopies

void setCopies(short copies)
Sets the number of copies.

Parameters:
copies - number of copies

getPaperSize

short getPaperSize()
Returns the paper size.

Returns:
paper size

getScale

short getScale()
Returns the scale.

Returns:
scale

getPageStart

short getPageStart()
Returns the page start.

Returns:
page start

getFitWidth

short getFitWidth()
Returns the number of pages wide to fit sheet in.

Returns:
number of pages wide to fit sheet in

getFitHeight

short getFitHeight()
Returns the number of pages high to fit the sheet in.

Returns:
number of pages high to fit the sheet in

getLeftToRight

boolean getLeftToRight()
Returns the left to right print order.

Returns:
left to right print order

getLandscape

boolean getLandscape()
Returns the landscape mode.

Returns:
landscape mode

getValidSettings

boolean getValidSettings()
Returns the valid settings.

Returns:
valid settings

getNoColor

boolean getNoColor()
Returns the black and white setting.

Returns:
black and white setting

getDraft

boolean getDraft()
Returns the draft mode.

Returns:
draft mode

getNotes

boolean getNotes()
Returns the print notes.

Returns:
print notes

getNoOrientation

boolean getNoOrientation()
Returns the no orientation.

Returns:
no orientation

getUsePage

boolean getUsePage()
Returns the use page numbers.

Returns:
use page numbers

getHResolution

short getHResolution()
Returns the horizontal resolution.

Returns:
horizontal resolution

getVResolution

short getVResolution()
Returns the vertical resolution.

Returns:
vertical resolution

getHeaderMargin

double getHeaderMargin()
Returns the header margin.

Returns:
header margin

getFooterMargin

double getFooterMargin()
Returns the footer margin.

Returns:
footer margin

getCopies

short getCopies()
Returns the number of copies.

Returns:
number of copies
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RichTextString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface RichTextString

All Known Implementing Classes:
HSSFRichTextString, XSSFRichTextString
public interface RichTextString

Rich text unicode string. These strings can have fonts applied to arbitary parts of the string.

Author:
Glen Stampoultzis (glens at apache.org), Jason Height (jheight at apache.org)

Method Summary
void | applyFont(Font font) Sets the font of the entire string.
void | applyFont(int startIndex, int endIndex, Font font) Applies a font to the specified characters of a string.
void | applyFont(int startIndex, int endIndex, short fontIndex) Applies a font to the specified characters of a string.
void | applyFont(short fontIndex) Applies the specified font to the entire string.
void | clearFormatting() Removes any formatting that may have been applied to the string.
int | getIndexOfFormattingRun(int index) The index within the string to which the specified formatting run applies.
java.lang.String | getString() Returns the plain string representation.
int | length()
int | numFormattingRuns()

Method Detail

applyFont

void applyFont(int startIndex,
               int endIndex,
               short fontIndex)
Applies a font to the specified characters of a string.

Parameters:
startIndex - The start index to apply the font to (inclusive)
endIndex - The end index to apply the font to (exclusive)
fontIndex - The font to use.

applyFont

void applyFont(int startIndex,
               int endIndex,
               Font font)
Applies a font to the specified characters of a string.

Parameters:
startIndex - The start index to apply the font to (inclusive)
endIndex - The end index to apply to font to (exclusive)
font - The index of the font to use.

applyFont

void applyFont(Font font)
Sets the font of the entire string.

Parameters:
font - The font to use.

clearFormatting

void clearFormatting()
Removes any formatting that may have been applied to the string.

getString

java.lang.String getString()
Returns the plain string representation.

length

int length()
Returns:
the number of characters in the font.

numFormattingRuns

int numFormattingRuns()
Returns:
The number of formatting runs used.

getIndexOfFormattingRun

int getIndexOfFormattingRun(int index)
The index within the string to which the specified formatting run applies.

Parameters:
index - the index of the formatting run
Returns:
the index within the string.

applyFont

void applyFont(short fontIndex)
Applies the specified font to the entire string.

Parameters:
fontIndex - the font to apply.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Row

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Row

All Superinterfaces:
java.lang.Iterable<Cell>
All Known Implementing Classes:
HSSFRow, SXSSFRow, XSSFRow
public interface Row
extends java.lang.Iterable<Cell>

High level representation of a row of a spreadsheet.

Nested Class Summary
static class Row.MissingCellPolicy
Used to specify the different possible policies if for the case of null and blank cells
Field Summary
static Row.MissingCellPolicy | CREATE_NULL_AS_BLANK A new, blank cell is created for missing cells.
static Row.MissingCellPolicy | RETURN_BLANK_AS_NULL Missing cells are returned as null, as are blank cells
static Row.MissingCellPolicy | RETURN_NULL_AND_BLANK Missing cells are returned as null, Blank cells are returned as normal
Method Summary
java.util.Iterator<Cell> | cellIterator()
Cell | createCell(int column) Use this to create new cells within the row and return it.
Cell | createCell(int column, int type) Use this to create new cells within the row and return it.
Cell | getCell(int cellnum) Get the cell representing a given column (logical cell) 0-based.
Cell | getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
short | getFirstCellNum() Get the number of the first cell contained in this row.
short | getHeight() Get the row's height measured in twips (1/20th of a point).
float | getHeightInPoints() Returns row height measured in point size.
short | getLastCellNum() Gets the index of the last cell contained in this row PLUS ONE.
int | getPhysicalNumberOfCells() Gets the number of defined cells (NOT number of cells in the actual row!).
int | getRowNum() Get row number this row represents
CellStyle | getRowStyle() Returns the whole-row cell styles.
Sheet | getSheet() Returns the Sheet this row belongs to
boolean | getZeroHeight() Get whether or not to display this row with 0 height
boolean | isFormatted() Is this row formatted? Most aren't, but some rows do have whole-row styles.
void | removeCell(Cell cell) Remove the Cell from this row.
void | setHeight(short height) Set the row's height or set to ff (-1) for undefined/default-height.
void | setHeightInPoints(float height) Set the row's height in points.
void | setRowNum(int rowNum) Set the row number of this row.
void | setRowStyle(CellStyle style) Applies a whole-row cell styling to the row.
void | setZeroHeight(boolean zHeight) Set whether or not to display this row with 0 height
Methods inherited from interface java.lang.Iterable
iterator

Field Detail

RETURN_NULL_AND_BLANK

static final Row.MissingCellPolicy RETURN_NULL_AND_BLANK
Missing cells are returned as null, Blank cells are returned as normal

RETURN_BLANK_AS_NULL

static final Row.MissingCellPolicy RETURN_BLANK_AS_NULL
Missing cells are returned as null, as are blank cells

CREATE_NULL_AS_BLANK

static final Row.MissingCellPolicy CREATE_NULL_AS_BLANK
A new, blank cell is created for missing cells. Blank cells are returned as normal

Method Detail

createCell

Cell createCell(int column)
Use this to create new cells within the row and return it.

The cell that is returned is a Cell.CELL_TYPE_BLANK. The type can be changed either through calling setCellValue or setCellType.

Parameters:
column - - the column number this cell represents
Returns:
Cell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if columnIndex < 0 or greater than the maximum number of supported columns (255 for *.xls, 1048576 for *.xlsx)

createCell

Cell createCell(int column,
                int type)
Use this to create new cells within the row and return it.

The cell that is returned is a Cell.CELL_TYPE_BLANK. The type can be changed either through calling setCellValue or setCellType.

Parameters:
column - - the column number this cell represents
Returns:
Cell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if columnIndex < 0 or greate than a maximum number of supported columns (255 for *.xls, 1048576 for *.xlsx)

removeCell

void removeCell(Cell cell)
Remove the Cell from this row.

Parameters:
cell - the cell to remove

setRowNum

void setRowNum(int rowNum)
Set the row number of this row.

Parameters:
rowNum - the row number (0-based)
Throws:
java.lang.IllegalArgumentException - if rowNum < 0

getRowNum

int getRowNum()
Get row number this row represents

Returns:
the row number (0 based)

getCell

Cell getCell(int cellnum)
Get the cell representing a given column (logical cell) 0-based. If you ask for a cell that is not defined....you get a null.

Parameters:
cellnum - 0 based column number
Returns:
Cell representing that column or null if undefined.
See Also:
getCell(int, org.apache.poi.ss.usermodel.Row.MissingCellPolicy)

getCell

Cell getCell(int cellnum,
             Row.MissingCellPolicy policy)
Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy

Returns:
the cell at the given (0 based) index
Throws:
java.lang.IllegalArgumentException - if cellnum < 0 or the specified MissingCellPolicy is invalid
See Also:
RETURN_NULL_AND_BLANK, RETURN_BLANK_AS_NULL, CREATE_NULL_AS_BLANK

getFirstCellNum

short getFirstCellNum()
Get the number of the first cell contained in this row.

Returns:
short representing the first logical cell in the row, or -1 if the row does not contain any cells.

getLastCellNum

short getLastCellNum()
Gets the index of the last cell contained in this row PLUS ONE. The result also happens to be the 1-based column number of the last cell. This value can be used as a standard upper bound when iterating over cells:
 short minColIx = row.getFirstCellNum();
 short maxColIx = row.getLastCellNum();
 for(short colIx=minColIx; colIx<maxColIx; colIx++) {
   Cell cell = row.getCell(colIx);
   if(cell == null) {
     continue;
   }
   //... do something with cell
 }

Returns:
short representing the last logical cell in the row PLUS ONE, or -1 if the row does not contain any cells.

getPhysicalNumberOfCells

int getPhysicalNumberOfCells()
Gets the number of defined cells (NOT number of cells in the actual row!). That is to say if only columns 0,4,5 have values then there would be 3.

Returns:
int representing the number of defined cells in the row.

setHeight

void setHeight(short height)
Set the row's height or set to ff (-1) for undefined/default-height. Set the height in "twips" or 1/20th of a point.

Parameters:
height - rowheight or 0xff for undefined (use sheet default)

setZeroHeight

void setZeroHeight(boolean zHeight)
Set whether or not to display this row with 0 height

Parameters:
zHeight - height is zero or not.

getZeroHeight

boolean getZeroHeight()
Get whether or not to display this row with 0 height

Returns:
- zHeight height is zero or not.

setHeightInPoints

void setHeightInPoints(float height)
Set the row's height in points.

Parameters:
height - the height in points. -1 resets to the default height

getHeight

short getHeight()
Get the row's height measured in twips (1/20th of a point). If the height is not set, the default worksheet value is returned, See Sheet.getDefaultRowHeightInPoints()

Returns:
row height measured in twips (1/20th of a point)

getHeightInPoints

float getHeightInPoints()
Returns row height measured in point size. If the height is not set, the default worksheet value is returned, See Sheet.getDefaultRowHeightInPoints()

Returns:
row height measured in point size
See Also:
Sheet.getDefaultRowHeightInPoints()

isFormatted

boolean isFormatted()
Is this row formatted? Most aren't, but some rows do have whole-row styles. For those that do, you can get the formatting from getRowStyle()

getRowStyle

CellStyle getRowStyle()
Returns the whole-row cell styles. Most rows won't have one of these, so will return null. Call isFormatted() to check first.

setRowStyle

void setRowStyle(CellStyle style)
Applies a whole-row cell styling to the row.

cellIterator

java.util.Iterator<Cell> cellIterator()
Returns:
Cell iterator of the physically defined cells. Note element 4 may actually be row cell depending on how many are defined!

getSheet

Sheet getSheet()
Returns the Sheet this row belongs to

Returns:
the Sheet that owns this row
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Row.MissingCellPolicy

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class Row.MissingCellPolicy

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.Row.MissingCellPolicy
Enclosing interface:
Row
public static final class Row.MissingCellPolicy
extends java.lang.Object

Used to specify the different possible policies if for the case of null and blank cells

Field Summary
 int id
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

id

public final int id
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShapeTypes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class ShapeTypes

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.ShapeTypes

public class ShapeTypes
extends java.lang.Object

All known types of automatic shapes in DrawingML

Author:
Yegor Kozlov

Field Summary
static int | ACCENT_BORDER_CALLOUT_1
static int | ACCENT_BORDER_CALLOUT_2
static int | ACCENT_BORDER_CALLOUT_3
static int | ACCENT_CALLOUT_1
static int | ACCENT_CALLOUT_2
static int | ACCENT_CALLOUT_3
static int | ACTION_BUTTON_BACK_PREVIOUS
static int | ACTION_BUTTON_BEGINNING
static int | ACTION_BUTTON_BLANK
static int | ACTION_BUTTON_DOCUMENT
static int | ACTION_BUTTON_END
static int | ACTION_BUTTON_FORWARD_NEXT
static int | ACTION_BUTTON_HELP
static int | ACTION_BUTTON_HOME
static int | ACTION_BUTTON_INFORMATION
static int | ACTION_BUTTON_MOVIE
static int | ACTION_BUTTON_RETURN
static int | ACTION_BUTTON_SOUND
static int | ARC
static int | BENT_ARROW
static int | BENT_CONNECTOR_2
static int | BENT_CONNECTOR_3
static int | BENT_CONNECTOR_4
static int | BENT_CONNECTOR_5
static int | BENT_UP_ARROW
static int | BEVEL
static int | BLOCK_ARC
static int | BORDER_CALLOUT_1
static int | BORDER_CALLOUT_2
static int | BORDER_CALLOUT_3
static int | BRACE_PAIR
static int | BRACKET_PAIR
static int | CALLOUT_1
static int | CALLOUT_2
static int | CALLOUT_3
static int | CAN
static int | CHART_PLUS
static int | CHART_STAR
static int | CHART_X
static int | CHEVRON
static int | CHORD
static int | CIRCULAR_ARROW
static int | CLOUD
static int | CLOUD_CALLOUT
static int | CORNER
static int | CORNER_TABS
static int | CUBE
static int | CURVED_CONNECTOR_2
static int | CURVED_CONNECTOR_3
static int | CURVED_CONNECTOR_4
static int | CURVED_CONNECTOR_5
static int | CURVED_DOWN_ARROW
static int | CURVED_LEFT_ARROW
static int | CURVED_RIGHT_ARROW
static int | CURVED_UP_ARROW
static int | DECAGON
static int | DIAG_STRIPE
static int | DIAMOND
static int | DODECAGON
static int | DONUT
static int | DOUBLE_WAVE
static int | DOWN_ARROW
static int | DOWN_ARROW_CALLOUT
static int | ELLIPSE
static int | ELLIPSE_RIBBON
static int | ELLIPSE_RIBBON_2
static int | FLOW_CHART_ALTERNATE_PROCESS
static int | FLOW_CHART_COLLATE
static int | FLOW_CHART_CONNECTOR
static int | FLOW_CHART_DECISION
static int | FLOW_CHART_DELAY
static int | FLOW_CHART_DISPLAY
static int | FLOW_CHART_DOCUMENT
static int | FLOW_CHART_EXTRACT
static int | FLOW_CHART_INPUT_OUTPUT
static int | FLOW_CHART_INTERNAL_STORAGE
static int | FLOW_CHART_MAGNETIC_DISK
static int | FLOW_CHART_MAGNETIC_DRUM
static int | FLOW_CHART_MAGNETIC_TAPE
static int | FLOW_CHART_MANUAL_INPUT
static int | FLOW_CHART_MANUAL_OPERATION
static int | FLOW_CHART_MERGE
static int | FLOW_CHART_MULTIDOCUMENT
static int | FLOW_CHART_OFFLINE_STORAGE
static int | FLOW_CHART_OFFPAGE_CONNECTOR
static int | FLOW_CHART_ONLINE_STORAGE
static int | FLOW_CHART_OR
static int | FLOW_CHART_PREDEFINED_PROCESS
static int | FLOW_CHART_PREPARATION
static int | FLOW_CHART_PROCESS
static int | FLOW_CHART_PUNCHED_CARD
static int | FLOW_CHART_PUNCHED_TAPE
static int | FLOW_CHART_SORT
static int | FLOW_CHART_SUMMING_JUNCTION
static int | FLOW_CHART_TERMINATOR
static int | FOLDED_CORNER
static int | FRAME
static int | FUNNEL
static int | GEAR_6
static int | GEAR_9
static int | HALF_FRAME
static int | HEART
static int | HEPTAGON
static int | HEXAGON
static int | HOME_PLATE
static int | HORIZONTAL_SCROLL
static int | IRREGULAR_SEAL_1
static int | IRREGULAR_SEAL_2
static int | LEFT_ARROW
static int | LEFT_ARROW_CALLOUT
static int | LEFT_BRACE
static int | LEFT_BRACKET
static int | LEFT_CIRCULAR_ARROW
static int | LEFT_RIGHT_ARROW
static int | LEFT_RIGHT_ARROW_CALLOUT
static int | LEFT_RIGHT_CIRCULAR_ARROW
static int | LEFT_RIGHT_RIBBON
static int | LEFT_RIGHT_UP_ARROW
static int | LEFT_UP_ARROW
static int | LIGHTNING_BOLT
static int | LINE
static int | LINE_INV
static int | MATH_DIVIDE
static int | MATH_EQUAL
static int | MATH_MINUS
static int | MATH_MULTIPLY
static int | MATH_NOT_EQUAL
static int | MATH_PLUS
static int | MOON
static int | NO_SMOKING
static int | NON_ISOSCELES_TRAPEZOID
static int | NOTCHED_RIGHT_ARROW
static int | OCTAGON
static int | PARALLELOGRAM
static int | PENTAGON
static int | PIE
static int | PIE_WEDGE
static int | PLAQUE
static int | PLAQUE_TABS
static int | PLUS
static int | QUAD_ARROW
static int | QUAD_ARROW_CALLOUT
static int | RECT
static int | RIBBON
static int | RIBBON_2
static int | RIGHT_ARROW
static int | RIGHT_ARROW_CALLOUT
static int | RIGHT_BRACE
static int | RIGHT_BRACKET
static int | ROUND_1_RECT
static int | ROUND_2_DIAG_RECT
static int | ROUND_2_SAME_RECT
static int | ROUND_RECT
static int | RT_TRIANGLE
static int | SMILEY_FACE
static int | SNIP_1_RECT
static int | SNIP_2_DIAG_RECT
static int | SNIP_2_SAME_RECT
static int | SNIP_ROUND_RECT
static int | SQUARE_TABS
static int | STAR_10
static int | STAR_12
static int | STAR_16
static int | STAR_24
static int | STAR_32
static int | STAR_4
static int | STAR_5
static int | STAR_6
static int | STAR_7
static int | STAR_8
static int | STRAIGHT_CONNECTOR_1
static int | STRIPED_RIGHT_ARROW
static int | SUN
static int | SWOOSH_ARROW
static int | TEARDROP
static int | TRAPEZOID
static int | TRIANGLE
static int | UP_ARROW
static int | UP_ARROW_CALLOUT
static int | UP_DOWN_ARROW
static int | UP_DOWN_ARROW_CALLOUT
static int | UTURN_ARROW
static int | VERTICAL_SCROLL
static int | WAVE
static int | WEDGE_ELLIPSE_CALLOUT
static int | WEDGE_RECT_CALLOUT
static int | WEDGE_ROUND_RECT_CALLOUT
Constructor Summary
ShapeTypes()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LINE

public static final int LINE
See Also:
Constant Field Values

LINE_INV

public static final int LINE_INV
See Also:
Constant Field Values

TRIANGLE

public static final int TRIANGLE
See Also:
Constant Field Values

RT_TRIANGLE

public static final int RT_TRIANGLE
See Also:
Constant Field Values

RECT

public static final int RECT
See Also:
Constant Field Values

DIAMOND

public static final int DIAMOND
See Also:
Constant Field Values

PARALLELOGRAM

public static final int PARALLELOGRAM
See Also:
Constant Field Values

TRAPEZOID

public static final int TRAPEZOID
See Also:
Constant Field Values

NON_ISOSCELES_TRAPEZOID

public static final int NON_ISOSCELES_TRAPEZOID
See Also:
Constant Field Values

PENTAGON

public static final int PENTAGON
See Also:
Constant Field Values

HEXAGON

public static final int HEXAGON
See Also:
Constant Field Values

HEPTAGON

public static final int HEPTAGON
See Also:
Constant Field Values

OCTAGON

public static final int OCTAGON
See Also:
Constant Field Values

DECAGON

public static final int DECAGON
See Also:
Constant Field Values

DODECAGON

public static final int DODECAGON
See Also:
Constant Field Values

STAR_4

public static final int STAR_4
See Also:
Constant Field Values

STAR_5

public static final int STAR_5
See Also:
Constant Field Values

STAR_6

public static final int STAR_6
See Also:
Constant Field Values

STAR_7

public static final int STAR_7
See Also:
Constant Field Values

STAR_8

public static final int STAR_8
See Also:
Constant Field Values

STAR_10

public static final int STAR_10
See Also:
Constant Field Values

STAR_12

public static final int STAR_12
See Also:
Constant Field Values

STAR_16

public static final int STAR_16
See Also:
Constant Field Values

STAR_24

public static final int STAR_24
See Also:
Constant Field Values

STAR_32

public static final int STAR_32
See Also:
Constant Field Values

ROUND_RECT

public static final int ROUND_RECT
See Also:
Constant Field Values

ROUND_1_RECT

public static final int ROUND_1_RECT
See Also:
Constant Field Values

ROUND_2_SAME_RECT

public static final int ROUND_2_SAME_RECT
See Also:
Constant Field Values

ROUND_2_DIAG_RECT

public static final int ROUND_2_DIAG_RECT
See Also:
Constant Field Values

SNIP_ROUND_RECT

public static final int SNIP_ROUND_RECT
See Also:
Constant Field Values

SNIP_1_RECT

public static final int SNIP_1_RECT
See Also:
Constant Field Values

SNIP_2_SAME_RECT

public static final int SNIP_2_SAME_RECT
See Also:
Constant Field Values

SNIP_2_DIAG_RECT

public static final int SNIP_2_DIAG_RECT
See Also:
Constant Field Values

PLAQUE

public static final int PLAQUE
See Also:
Constant Field Values

ELLIPSE

public static final int ELLIPSE
See Also:
Constant Field Values

TEARDROP

public static final int TEARDROP
See Also:
Constant Field Values

HOME_PLATE

public static final int HOME_PLATE
See Also:
Constant Field Values

CHEVRON

public static final int CHEVRON
See Also:
Constant Field Values

PIE_WEDGE

public static final int PIE_WEDGE
See Also:
Constant Field Values

PIE

public static final int PIE
See Also:
Constant Field Values

BLOCK_ARC

public static final int BLOCK_ARC
See Also:
Constant Field Values

DONUT

public static final int DONUT
See Also:
Constant Field Values

NO_SMOKING

public static final int NO_SMOKING
See Also:
Constant Field Values

RIGHT_ARROW

public static final int RIGHT_ARROW
See Also:
Constant Field Values

LEFT_ARROW

public static final int LEFT_ARROW
See Also:
Constant Field Values

UP_ARROW

public static final int UP_ARROW
See Also:
Constant Field Values

DOWN_ARROW

public static final int DOWN_ARROW
See Also:
Constant Field Values

STRIPED_RIGHT_ARROW

public static final int STRIPED_RIGHT_ARROW
See Also:
Constant Field Values

NOTCHED_RIGHT_ARROW

public static final int NOTCHED_RIGHT_ARROW
See Also:
Constant Field Values

BENT_UP_ARROW

public static final int BENT_UP_ARROW
See Also:
Constant Field Values

LEFT_RIGHT_ARROW

public static final int LEFT_RIGHT_ARROW
See Also:
Constant Field Values

UP_DOWN_ARROW

public static final int UP_DOWN_ARROW
See Also:
Constant Field Values

LEFT_UP_ARROW

public static final int LEFT_UP_ARROW
See Also:
Constant Field Values

LEFT_RIGHT_UP_ARROW

public static final int LEFT_RIGHT_UP_ARROW
See Also:
Constant Field Values

QUAD_ARROW

public static final int QUAD_ARROW
See Also:
Constant Field Values

LEFT_ARROW_CALLOUT

public static final int LEFT_ARROW_CALLOUT
See Also:
Constant Field Values

RIGHT_ARROW_CALLOUT

public static final int RIGHT_ARROW_CALLOUT
See Also:
Constant Field Values

UP_ARROW_CALLOUT

public static final int UP_ARROW_CALLOUT
See Also:
Constant Field Values

DOWN_ARROW_CALLOUT

public static final int DOWN_ARROW_CALLOUT
See Also:
Constant Field Values

LEFT_RIGHT_ARROW_CALLOUT

public static final int LEFT_RIGHT_ARROW_CALLOUT
See Also:
Constant Field Values

UP_DOWN_ARROW_CALLOUT

public static final int UP_DOWN_ARROW_CALLOUT
See Also:
Constant Field Values

QUAD_ARROW_CALLOUT

public static final int QUAD_ARROW_CALLOUT
See Also:
Constant Field Values

BENT_ARROW

public static final int BENT_ARROW
See Also:
Constant Field Values

UTURN_ARROW

public static final int UTURN_ARROW
See Also:
Constant Field Values

CIRCULAR_ARROW

public static final int CIRCULAR_ARROW
See Also:
Constant Field Values

LEFT_CIRCULAR_ARROW

public static final int LEFT_CIRCULAR_ARROW
See Also:
Constant Field Values

LEFT_RIGHT_CIRCULAR_ARROW

public static final int LEFT_RIGHT_CIRCULAR_ARROW
See Also:
Constant Field Values

CURVED_RIGHT_ARROW

public static final int CURVED_RIGHT_ARROW
See Also:
Constant Field Values

CURVED_LEFT_ARROW

public static final int CURVED_LEFT_ARROW
See Also:
Constant Field Values

CURVED_UP_ARROW

public static final int CURVED_UP_ARROW
See Also:
Constant Field Values

CURVED_DOWN_ARROW

public static final int CURVED_DOWN_ARROW
See Also:
Constant Field Values

SWOOSH_ARROW

public static final int SWOOSH_ARROW
See Also:
Constant Field Values

CUBE

public static final int CUBE
See Also:
Constant Field Values

CAN

public static final int CAN
See Also:
Constant Field Values

LIGHTNING_BOLT

public static final int LIGHTNING_BOLT
See Also:
Constant Field Values

HEART

public static final int HEART
See Also:
Constant Field Values

SUN

public static final int SUN
See Also:
Constant Field Values

MOON

public static final int MOON
See Also:
Constant Field Values

SMILEY_FACE

public static final int SMILEY_FACE
See Also:
Constant Field Values

IRREGULAR_SEAL_1

public static final int IRREGULAR_SEAL_1
See Also:
Constant Field Values

IRREGULAR_SEAL_2

public static final int IRREGULAR_SEAL_2
See Also:
Constant Field Values

FOLDED_CORNER

public static final int FOLDED_CORNER
See Also:
Constant Field Values

BEVEL

public static final int BEVEL
See Also:
Constant Field Values

FRAME

public static final int FRAME
See Also:
Constant Field Values

HALF_FRAME

public static final int HALF_FRAME
See Also:
Constant Field Values

CORNER

public static final int CORNER
See Also:
Constant Field Values

DIAG_STRIPE

public static final int DIAG_STRIPE
See Also:
Constant Field Values

CHORD

public static final int CHORD
See Also:
Constant Field Values

ARC

public static final int ARC
See Also:
Constant Field Values

LEFT_BRACKET

public static final int LEFT_BRACKET
See Also:
Constant Field Values

RIGHT_BRACKET

public static final int RIGHT_BRACKET
See Also:
Constant Field Values

LEFT_BRACE

public static final int LEFT_BRACE
See Also:
Constant Field Values

RIGHT_BRACE

public static final int RIGHT_BRACE
See Also:
Constant Field Values

BRACKET_PAIR

public static final int BRACKET_PAIR
See Also:
Constant Field Values

BRACE_PAIR

public static final int BRACE_PAIR
See Also:
Constant Field Values

STRAIGHT_CONNECTOR_1

public static final int STRAIGHT_CONNECTOR_1
See Also:
Constant Field Values

BENT_CONNECTOR_2

public static final int BENT_CONNECTOR_2
See Also:
Constant Field Values

BENT_CONNECTOR_3

public static final int BENT_CONNECTOR_3
See Also:
Constant Field Values

BENT_CONNECTOR_4

public static final int BENT_CONNECTOR_4
See Also:
Constant Field Values

BENT_CONNECTOR_5

public static final int BENT_CONNECTOR_5
See Also:
Constant Field Values

CURVED_CONNECTOR_2

public static final int CURVED_CONNECTOR_2
See Also:
Constant Field Values

CURVED_CONNECTOR_3

public static final int CURVED_CONNECTOR_3
See Also:
Constant Field Values

CURVED_CONNECTOR_4

public static final int CURVED_CONNECTOR_4
See Also:
Constant Field Values

CURVED_CONNECTOR_5

public static final int CURVED_CONNECTOR_5
See Also:
Constant Field Values

CALLOUT_1

public static final int CALLOUT_1
See Also:
Constant Field Values

CALLOUT_2

public static final int CALLOUT_2
See Also:
Constant Field Values

CALLOUT_3

public static final int CALLOUT_3
See Also:
Constant Field Values

ACCENT_CALLOUT_1

public static final int ACCENT_CALLOUT_1
See Also:
Constant Field Values

ACCENT_CALLOUT_2

public static final int ACCENT_CALLOUT_2
See Also:
Constant Field Values

ACCENT_CALLOUT_3

public static final int ACCENT_CALLOUT_3
See Also:
Constant Field Values

BORDER_CALLOUT_1

public static final int BORDER_CALLOUT_1
See Also:
Constant Field Values

BORDER_CALLOUT_2

public static final int BORDER_CALLOUT_2
See Also:
Constant Field Values

BORDER_CALLOUT_3

public static final int BORDER_CALLOUT_3
See Also:
Constant Field Values

ACCENT_BORDER_CALLOUT_1

public static final int ACCENT_BORDER_CALLOUT_1
See Also:
Constant Field Values

ACCENT_BORDER_CALLOUT_2

public static final int ACCENT_BORDER_CALLOUT_2
See Also:
Constant Field Values

ACCENT_BORDER_CALLOUT_3

public static final int ACCENT_BORDER_CALLOUT_3
See Also:
Constant Field Values

WEDGE_RECT_CALLOUT

public static final int WEDGE_RECT_CALLOUT
See Also:
Constant Field Values

WEDGE_ROUND_RECT_CALLOUT

public static final int WEDGE_ROUND_RECT_CALLOUT
See Also:
Constant Field Values

WEDGE_ELLIPSE_CALLOUT

public static final int WEDGE_ELLIPSE_CALLOUT
See Also:
Constant Field Values

CLOUD_CALLOUT

public static final int CLOUD_CALLOUT
See Also:
Constant Field Values

CLOUD

public static final int CLOUD
See Also:
Constant Field Values

RIBBON

public static final int RIBBON
See Also:
Constant Field Values

RIBBON_2

public static final int RIBBON_2
See Also:
Constant Field Values

ELLIPSE_RIBBON

public static final int ELLIPSE_RIBBON
See Also:
Constant Field Values

ELLIPSE_RIBBON_2

public static final int ELLIPSE_RIBBON_2
See Also:
Constant Field Values

LEFT_RIGHT_RIBBON

public static final int LEFT_RIGHT_RIBBON
See Also:
Constant Field Values

VERTICAL_SCROLL

public static final int VERTICAL_SCROLL
See Also:
Constant Field Values

HORIZONTAL_SCROLL

public static final int HORIZONTAL_SCROLL
See Also:
Constant Field Values

WAVE

public static final int WAVE
See Also:
Constant Field Values

DOUBLE_WAVE

public static final int DOUBLE_WAVE
See Also:
Constant Field Values

PLUS

public static final int PLUS
See Also:
Constant Field Values

FLOW_CHART_PROCESS

public static final int FLOW_CHART_PROCESS
See Also:
Constant Field Values

FLOW_CHART_DECISION

public static final int FLOW_CHART_DECISION
See Also:
Constant Field Values

FLOW_CHART_INPUT_OUTPUT

public static final int FLOW_CHART_INPUT_OUTPUT
See Also:
Constant Field Values

FLOW_CHART_PREDEFINED_PROCESS

public static final int FLOW_CHART_PREDEFINED_PROCESS
See Also:
Constant Field Values

FLOW_CHART_INTERNAL_STORAGE

public static final int FLOW_CHART_INTERNAL_STORAGE
See Also:
Constant Field Values

FLOW_CHART_DOCUMENT

public static final int FLOW_CHART_DOCUMENT
See Also:
Constant Field Values

FLOW_CHART_MULTIDOCUMENT

public static final int FLOW_CHART_MULTIDOCUMENT
See Also:
Constant Field Values

FLOW_CHART_TERMINATOR

public static final int FLOW_CHART_TERMINATOR
See Also:
Constant Field Values

FLOW_CHART_PREPARATION

public static final int FLOW_CHART_PREPARATION
See Also:
Constant Field Values

FLOW_CHART_MANUAL_INPUT

public static final int FLOW_CHART_MANUAL_INPUT
See Also:
Constant Field Values

FLOW_CHART_MANUAL_OPERATION

public static final int FLOW_CHART_MANUAL_OPERATION
See Also:
Constant Field Values

FLOW_CHART_CONNECTOR

public static final int FLOW_CHART_CONNECTOR
See Also:
Constant Field Values

FLOW_CHART_PUNCHED_CARD

public static final int FLOW_CHART_PUNCHED_CARD
See Also:
Constant Field Values

FLOW_CHART_PUNCHED_TAPE

public static final int FLOW_CHART_PUNCHED_TAPE
See Also:
Constant Field Values

FLOW_CHART_SUMMING_JUNCTION

public static final int FLOW_CHART_SUMMING_JUNCTION
See Also:
Constant Field Values

FLOW_CHART_OR

public static final int FLOW_CHART_OR
See Also:
Constant Field Values

FLOW_CHART_COLLATE

public static final int FLOW_CHART_COLLATE
See Also:
Constant Field Values

FLOW_CHART_SORT

public static final int FLOW_CHART_SORT
See Also:
Constant Field Values

FLOW_CHART_EXTRACT

public static final int FLOW_CHART_EXTRACT
See Also:
Constant Field Values

FLOW_CHART_MERGE

public static final int FLOW_CHART_MERGE
See Also:
Constant Field Values

FLOW_CHART_OFFLINE_STORAGE

public static final int FLOW_CHART_OFFLINE_STORAGE
See Also:
Constant Field Values

FLOW_CHART_ONLINE_STORAGE

public static final int FLOW_CHART_ONLINE_STORAGE
See Also:
Constant Field Values

FLOW_CHART_MAGNETIC_TAPE

public static final int FLOW_CHART_MAGNETIC_TAPE
See Also:
Constant Field Values

FLOW_CHART_MAGNETIC_DISK

public static final int FLOW_CHART_MAGNETIC_DISK
See Also:
Constant Field Values

FLOW_CHART_MAGNETIC_DRUM

public static final int FLOW_CHART_MAGNETIC_DRUM
See Also:
Constant Field Values

FLOW_CHART_DISPLAY

public static final int FLOW_CHART_DISPLAY
See Also:
Constant Field Values

FLOW_CHART_DELAY

public static final int FLOW_CHART_DELAY
See Also:
Constant Field Values

FLOW_CHART_ALTERNATE_PROCESS

public static final int FLOW_CHART_ALTERNATE_PROCESS
See Also:
Constant Field Values

FLOW_CHART_OFFPAGE_CONNECTOR

public static final int FLOW_CHART_OFFPAGE_CONNECTOR
See Also:
Constant Field Values

ACTION_BUTTON_BLANK

public static final int ACTION_BUTTON_BLANK
See Also:
Constant Field Values

ACTION_BUTTON_HOME

public static final int ACTION_BUTTON_HOME
See Also:
Constant Field Values

ACTION_BUTTON_HELP

public static final int ACTION_BUTTON_HELP
See Also:
Constant Field Values

ACTION_BUTTON_INFORMATION

public static final int ACTION_BUTTON_INFORMATION
See Also:
Constant Field Values

ACTION_BUTTON_FORWARD_NEXT

public static final int ACTION_BUTTON_FORWARD_NEXT
See Also:
Constant Field Values

ACTION_BUTTON_BACK_PREVIOUS

public static final int ACTION_BUTTON_BACK_PREVIOUS
See Also:
Constant Field Values

ACTION_BUTTON_END

public static final int ACTION_BUTTON_END
See Also:
Constant Field Values

ACTION_BUTTON_BEGINNING

public static final int ACTION_BUTTON_BEGINNING
See Also:
Constant Field Values

ACTION_BUTTON_RETURN

public static final int ACTION_BUTTON_RETURN
See Also:
Constant Field Values

ACTION_BUTTON_DOCUMENT

public static final int ACTION_BUTTON_DOCUMENT
See Also:
Constant Field Values

ACTION_BUTTON_SOUND

public static final int ACTION_BUTTON_SOUND
See Also:
Constant Field Values

ACTION_BUTTON_MOVIE

public static final int ACTION_BUTTON_MOVIE
See Also:
Constant Field Values

GEAR_6

public static final int GEAR_6
See Also:
Constant Field Values

GEAR_9

public static final int GEAR_9
See Also:
Constant Field Values

FUNNEL

public static final int FUNNEL
See Also:
Constant Field Values

MATH_PLUS

public static final int MATH_PLUS
See Also:
Constant Field Values

MATH_MINUS

public static final int MATH_MINUS
See Also:
Constant Field Values

MATH_MULTIPLY

public static final int MATH_MULTIPLY
See Also:
Constant Field Values

MATH_DIVIDE

public static final int MATH_DIVIDE
See Also:
Constant Field Values

MATH_EQUAL

public static final int MATH_EQUAL
See Also:
Constant Field Values

MATH_NOT_EQUAL

public static final int MATH_NOT_EQUAL
See Also:
Constant Field Values

CORNER_TABS

public static final int CORNER_TABS
See Also:
Constant Field Values

SQUARE_TABS

public static final int SQUARE_TABS
See Also:
Constant Field Values

PLAQUE_TABS

public static final int PLAQUE_TABS
See Also:
Constant Field Values

CHART_X

public static final int CHART_X
See Also:
Constant Field Values

CHART_STAR

public static final int CHART_STAR
See Also:
Constant Field Values

CHART_PLUS

public static final int CHART_PLUS
See Also:
Constant Field Values
Constructor Detail

ShapeTypes

public ShapeTypes()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Sheet

All Superinterfaces:
java.lang.Iterable<Row>
All Known Implementing Classes:
HSSFSheet, SXSSFSheet, XSSFChartSheet, XSSFDialogsheet, XSSFSheet
public interface Sheet
extends java.lang.Iterable<Row>

High level representation of a Excel worksheet.

Sheets are the central structures within a workbook, and are where a user does most of his spreadsheet work. The most common type of sheet is the worksheet, which is represented as a grid of cells. Worksheet cells can contain text, numbers, dates, and formulas. Cells can also be formatted.

Field Summary
static short | BottomMargin
static short | FooterMargin
static short | HeaderMargin
static short | LeftMargin
static byte | PANE_LOWER_LEFT
static byte | PANE_LOWER_RIGHT
static byte | PANE_UPPER_LEFT
static byte | PANE_UPPER_RIGHT
static short | RightMargin
static short | TopMargin
Method Summary
int | addMergedRegion(CellRangeAddress region) Adds a merged region of cells (hence those cells form one)
void | addValidationData(DataValidation dataValidation) Creates a data validation object
void | autoSizeColumn(int column) Adjusts the column width to fit the contents.
void | autoSizeColumn(int column, boolean useMergedCells) Adjusts the column width to fit the contents.
Drawing | createDrawingPatriarch() Creates the top-level drawing patriarch.
void | createFreezePane(int colSplit, int rowSplit) Creates a split (freezepane).
void | createFreezePane(int colSplit, int rowSplit, int leftmostColumn, int topRow) Creates a split (freezepane).
Row | createRow(int rownum) Create a new row within the sheet and return the high level representation
void | createSplitPane(int xSplitPos, int ySplitPos, int leftmostColumn, int topRow, int activePane) Creates a split pane.
boolean | getAutobreaks() Flag indicating whether the sheet displays Automatic Page Breaks.
Comment | getCellComment(int row, int column) Returns cell comment for the specified row and column
int[] | getColumnBreaks() Retrieves all the vertical page breaks
CellStyle | getColumnStyle(int column) Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
int | getColumnWidth(int columnIndex) get the width (in units of 1/256th of a character width )
DataValidationHelper | getDataValidationHelper()
int | getDefaultColumnWidth() Get the default column width for the sheet (if the columns do not define their own width) in characters
short | getDefaultRowHeight() Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
float | getDefaultRowHeightInPoints() Get the default row height for the sheet (if the rows do not define their own height) in points.
boolean | getDisplayGuts() Get whether to display the guts or not, default value is true
int | getFirstRowNum() Gets the first row on the sheet
boolean | getFitToPage() Flag indicating whether the Fit to Page print option is enabled.
Footer | getFooter() Gets the user model for the default document footer.
boolean | getForceFormulaRecalculation() Whether Excel will be asked to recalculate all formulas in this sheet when the workbook is opened.
Header | getHeader() Gets the user model for the default document header.
boolean | getHorizontallyCenter() Determine whether printed output for this sheet will be horizontally centered.
int | getLastRowNum() Gets the last row on the sheet
short | getLeftCol() The left col in the visible view when the sheet is first viewed after opening it in a viewer
double | getMargin(short margin) Gets the size of the margin in inches.
CellRangeAddress | getMergedRegion(int index) Returns the merged region at the specified index
int | getNumMergedRegions() Returns the number of merged regions
PaneInformation | getPaneInformation() Returns the information regarding the currently configured pane (split or freeze)
int | getPhysicalNumberOfRows() Returns the number of physically defined rows (NOT the number of rows in the sheet)
PrintSetup | getPrintSetup() Gets the print setup object.
boolean | getProtect() Answer whether protection is enabled or disabled
Row | getRow(int rownum) Returns the logical row (not physical) 0-based.
int[] | getRowBreaks() Retrieves all the horizontal page breaks
boolean | getRowSumsBelow() Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
boolean | getRowSumsRight() Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
boolean | getScenarioProtect() Answer whether scenario protection is enabled or disabled
SheetConditionalFormatting | getSheetConditionalFormatting() The 'Conditional Formatting' facet for this Sheet
java.lang.String | getSheetName() Returns the name of this sheet
short | getTopRow() The top row in the visible view when the sheet is first viewed after opening it in a viewer
boolean | getVerticallyCenter() Determine whether printed output for this sheet will be vertically centered.
Workbook | getWorkbook() Return the parent workbook
void | groupColumn(int fromColumn, int toColumn) Create an outline for the provided column range.
void | groupRow(int fromRow, int toRow) Tie a range of rows together so that they can be collapsed or expanded
boolean | isColumnBroken(int column) Determines if there is a page break at the indicated column
boolean | isColumnHidden(int columnIndex) Get the hidden state for a given column
boolean | isDisplayFormulas() Returns if formulas are displayed
boolean | isDisplayGridlines() Returns if gridlines are displayed
boolean | isDisplayRowColHeadings() Returns if RowColHeadings are displayed.
boolean | isDisplayZeros() Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
boolean | isPrintGridlines() Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.
boolean | isRightToLeft() Whether the text is displayed in right-to-left mode in the window
boolean | isRowBroken(int row) Determines if there is a page break at the indicated row
boolean | isSelected() Note - this is not the same as whether the sheet is focused (isActive)
void | protectSheet(java.lang.String password) Sets the protection enabled as well as the password
CellRange<? extends Cell> | removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
void | removeColumnBreak(int column) Removes a page break at the indicated column
void | removeMergedRegion(int index) Removes a merged region of cells (hence letting them free)
void | removeRow(Row row) Remove a row from this sheet.
void | removeRowBreak(int row) Removes the page break at the indicated row
java.util.Iterator<Row> | rowIterator() Returns an iterator of the physical rows
CellRange<? extends Cell> | setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.
void | setAutobreaks(boolean value) Flag indicating whether the sheet displays Automatic Page Breaks.
AutoFilter | setAutoFilter(CellRangeAddress range) Enable filtering for a range of cells
void | setColumnBreak(int column) Sets a page break at the indicated column.
void | setColumnGroupCollapsed(int columnNumber, boolean collapsed) Expands or collapses a column group.
void | setColumnHidden(int columnIndex, boolean hidden) Get the visibility state for a given column
void | setColumnWidth(int columnIndex, int width) Set the width (in units of 1/256th of a character width)
void | setDefaultColumnStyle(int column, CellStyle style) Sets the default column style for a given column.
void | setDefaultColumnWidth(int width) Set the default column width for the sheet (if the columns do not define their own width) in characters
void | setDefaultRowHeight(short height) Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
void | setDefaultRowHeightInPoints(float height) Set the default row height for the sheet (if the rows do not define their own height) in points
void | setDisplayFormulas(boolean show) Sets whether the formulas are shown in a viewer
void | setDisplayGridlines(boolean show) Sets whether the gridlines are shown in a viewer
void | setDisplayGuts(boolean value) Set whether to display the guts or not
void | setDisplayRowColHeadings(boolean show) Sets whether the RowColHeadings are shown in a viewer
void | setDisplayZeros(boolean value) Set whether the window should show 0 (zero) in cells containing zero value.
void | setFitToPage(boolean value) Flag indicating whether the Fit to Page print option is enabled.
void | setForceFormulaRecalculation(boolean value) Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.
void | setHorizontallyCenter(boolean value) Determines whether the output is horizontally centered on the page.
void | setMargin(short margin, double size) Sets the size of the margin in inches.
void | setPrintGridlines(boolean show) Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier.
void | setRightToLeft(boolean value) Sets whether the worksheet is displayed from right to left instead of from left to right.
void | setRowBreak(int row) Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive.
void | setRowGroupCollapsed(int row, boolean collapse) Set view state of a groupped range of rows
void | setRowSumsBelow(boolean value) Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
void | setRowSumsRight(boolean value) Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
void | setSelected(boolean value) Sets a flag indicating whether this sheet is selected.
void | setVerticallyCenter(boolean value) Determines whether the output is vertically centered on the page.
void | setZoom(int numerator, int denominator) Sets the zoom magnication for the sheet.
void | shiftRows(int startRow, int endRow, int n) Shifts rows between startRow and endRow n number of rows.
void | shiftRows(int startRow, int endRow, int n, boolean copyRowHeight, boolean resetOriginalRowHeight) Shifts rows between startRow and endRow n number of rows.
void | showInPane(short toprow, short leftcol) Sets desktop window pane display area, when the file is first opened in a viewer.
void | ungroupColumn(int fromColumn, int toColumn) Ungroup a range of columns that were previously groupped
void | ungroupRow(int fromRow, int toRow) Ungroup a range of rows that were previously groupped
Methods inherited from interface java.lang.Iterable
iterator

Field Detail

LeftMargin

static final short LeftMargin
See Also:
Constant Field Values

RightMargin

static final short RightMargin
See Also:
Constant Field Values

TopMargin

static final short TopMargin
See Also:
Constant Field Values

BottomMargin

static final short BottomMargin
See Also:
Constant Field Values

HeaderMargin

static final short HeaderMargin
See Also:
Constant Field Values

FooterMargin

static final short FooterMargin
See Also:
Constant Field Values

PANE_LOWER_RIGHT

static final byte PANE_LOWER_RIGHT
See Also:
Constant Field Values

PANE_UPPER_RIGHT

static final byte PANE_UPPER_RIGHT
See Also:
Constant Field Values

PANE_LOWER_LEFT

static final byte PANE_LOWER_LEFT
See Also:
Constant Field Values

PANE_UPPER_LEFT

static final byte PANE_UPPER_LEFT
See Also:
Constant Field Values
Method Detail

createRow

Row createRow(int rownum)
Create a new row within the sheet and return the high level representation

Parameters:
rownum - row number
Returns:
high level Row object representing a row in the sheet
See Also:
removeRow(Row)

removeRow

void removeRow(Row row)
Remove a row from this sheet. All cells contained in the row are removed as well

Parameters:
row - representing a row to remove.

getRow

Row getRow(int rownum)
Returns the logical row (not physical) 0-based. If you ask for a row that is not defined you get a null. This is to say row 4 represents the fifth row on a sheet.

Parameters:
rownum - row to get (0-based)
Returns:
Row representing the rownumber or null if its not defined on the sheet

getPhysicalNumberOfRows

int getPhysicalNumberOfRows()
Returns the number of physically defined rows (NOT the number of rows in the sheet)

Returns:
the number of physically defined rows in this sheet

getFirstRowNum

int getFirstRowNum()
Gets the first row on the sheet

Returns:
the number of the first logical row on the sheet (0-based)

getLastRowNum

int getLastRowNum()
Gets the last row on the sheet

Returns:
last row contained n this sheet (0-based)

setColumnHidden

void setColumnHidden(int columnIndex,
                     boolean hidden)
Get the visibility state for a given column

Parameters:
columnIndex - - the column to get (0-based)
hidden - - the visiblity state of the column

isColumnHidden

boolean isColumnHidden(int columnIndex)
Get the hidden state for a given column

Parameters:
columnIndex - - the column to set (0-based)
Returns:
hidden - false if the column is visible

setRightToLeft

void setRightToLeft(boolean value)
Sets whether the worksheet is displayed from right to left instead of from left to right.

Parameters:
value - true for right to left, false otherwise.

isRightToLeft

boolean isRightToLeft()
Whether the text is displayed in right-to-left mode in the window

Returns:
whether the text is displayed in right-to-left mode in the window

setColumnWidth

void setColumnWidth(int columnIndex,
                    int width)
Set the width (in units of 1/256th of a character width)

The maximum column width for an individual cell is 255 characters. This value represents the number of characters that can be displayed in a cell that is formatted with the standard font (first font in the workbook).

Character width is defined as the maximum digit width of the numbers 0, 1, 2, ... 9 as rendered using the default font (first font in the workbook).
Unless you are using a very special font, the default character is '0' (zero), this is true for Arial (default font font in HSSF) and Calibri (default font in XSSF)

Please note, that the width set by this method includes 4 pixels of margin padding (two on each side), plus 1 pixel padding for the gridlines (Section 3.3.1.12 of the OOXML spec). This results is a slightly less value of visible characters than passed to this method (approx. 1/2 of a character).

To compute the actual number of visible characters, Excel uses the following formula (Section 3.3.1.12 of the OOXML spec):

width = Truncate([{Number of Visible Characters} * {Maximum Digit Width} + {5 pixel padding}]/{Maximum Digit Width}*256)/256

Using the Calibri font as an example, the maximum digit width of 11 point font size is 7 pixels (at 96 dpi). If you set a column width to be eight characters wide, e.g. setColumnWidth(columnIndex, 8*256), then the actual value of visible characters (the value shown in Excel) is derived from the following equation: Truncate([numChars*7+5]/7*256)/256 = 8; which gives 7.29.

Parameters:
columnIndex - - the column to set (0-based)
width - - the width in units of 1/256th of a character width
Throws:
java.lang.IllegalArgumentException - if width > 255*256 (the maximum column width in Excel is 255 characters)

getColumnWidth

int getColumnWidth(int columnIndex)
get the width (in units of 1/256th of a character width )

Character width is defined as the maximum digit width of the numbers 0, 1, 2, ... 9 as rendered using the default font (first font in the workbook)

Parameters:
columnIndex - - the column to set (0-based)
Returns:
width - the width in units of 1/256th of a character width

setDefaultColumnWidth

void setDefaultColumnWidth(int width)
Set the default column width for the sheet (if the columns do not define their own width) in characters

Parameters:
width - default column width measured in characters

getDefaultColumnWidth

int getDefaultColumnWidth()
Get the default column width for the sheet (if the columns do not define their own width) in characters

Returns:
default column width measured in characters

getDefaultRowHeight

short getDefaultRowHeight()
Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Returns:
default row height measured in twips (1/20 of a point)

getDefaultRowHeightInPoints

float getDefaultRowHeightInPoints()
Get the default row height for the sheet (if the rows do not define their own height) in points.

Returns:
default row height in points

setDefaultRowHeight

void setDefaultRowHeight(short height)
Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Parameters:
height - default row height measured in twips (1/20 of a point)

setDefaultRowHeightInPoints

void setDefaultRowHeightInPoints(float height)
Set the default row height for the sheet (if the rows do not define their own height) in points

Parameters:
height - default row height

getColumnStyle

CellStyle getColumnStyle(int column)
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column

addMergedRegion

int addMergedRegion(CellRangeAddress region)
Adds a merged region of cells (hence those cells form one)

Parameters:
region - (rowfrom/colfrom-rowto/colto) to merge
Returns:
index of this region

setVerticallyCenter

void setVerticallyCenter(boolean value)
Determines whether the output is vertically centered on the page.

Parameters:
value - true to vertically center, false otherwise.

setHorizontallyCenter

void setHorizontallyCenter(boolean value)
Determines whether the output is horizontally centered on the page.

Parameters:
value - true to horizontally center, false otherwise.

getHorizontallyCenter

boolean getHorizontallyCenter()
Determine whether printed output for this sheet will be horizontally centered.

getVerticallyCenter

boolean getVerticallyCenter()
Determine whether printed output for this sheet will be vertically centered.

removeMergedRegion

void removeMergedRegion(int index)
Removes a merged region of cells (hence letting them free)

Parameters:
index - of the region to unmerge

getNumMergedRegions

int getNumMergedRegions()
Returns the number of merged regions

Returns:
number of merged regions

getMergedRegion

CellRangeAddress getMergedRegion(int index)
Returns the merged region at the specified index

Returns:
the merged region at the specified index

rowIterator

java.util.Iterator<Row> rowIterator()
Returns an iterator of the physical rows

Returns:
an iterator of the PHYSICAL rows. Meaning the 3rd element may not be the third row if say for instance the second row is undefined.

setForceFormulaRecalculation

void setForceFormulaRecalculation(boolean value)
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.

Calculating the formula values with FormulaEvaluator is the recommended solution, but this may be used for certain cases where evaluation in POI is not possible.

To force recalcuation of formulas in the entire workbook use Workbook.setForceFormulaRecalculation(boolean) instead.

Parameters:
value - true if the application will perform a full recalculation of this worksheet values when the workbook is opened
See Also:
Workbook.setForceFormulaRecalculation(boolean)

getForceFormulaRecalculation

boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas in this sheet when the workbook is opened.

setAutobreaks

void setAutobreaks(boolean value)
Flag indicating whether the sheet displays Automatic Page Breaks.

Parameters:
value - true if the sheet displays Automatic Page Breaks.

setDisplayGuts

void setDisplayGuts(boolean value)
Set whether to display the guts or not

Parameters:
value - - guts or no guts

setDisplayZeros

void setDisplayZeros(boolean value)
Set whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

Parameters:
value - whether to display or hide all zero values on the worksheet

isDisplayZeros

boolean isDisplayZeros()
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

Returns:
whether all zero values on the worksheet are displayed

setFitToPage

void setFitToPage(boolean value)
Flag indicating whether the Fit to Page print option is enabled.

Parameters:
value - true if the Fit to Page print option is enabled.

setRowSumsBelow

void setRowSumsBelow(boolean value)
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.

When true a summary row is inserted below the detailed data being summarized and a new outline level is established on that row.

When false a summary row is inserted above the detailed data being summarized and a new outline level is established on that row.

Parameters:
value - true if row summaries appear below detail in the outline

setRowSumsRight

void setRowSumsRight(boolean value)
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.

When true a summary column is inserted to the right of the detailed data being summarized and a new outline level is established on that column.

When false a summary column is inserted to the left of the detailed data being summarized and a new outline level is established on that column.

Parameters:
value - true if col summaries appear right of the detail in the outline

getAutobreaks

boolean getAutobreaks()
Flag indicating whether the sheet displays Automatic Page Breaks.

Returns:
true if the sheet displays Automatic Page Breaks.

getDisplayGuts

boolean getDisplayGuts()
Get whether to display the guts or not, default value is true

Returns:
boolean - guts or no guts

getFitToPage

boolean getFitToPage()
Flag indicating whether the Fit to Page print option is enabled.

Returns:
true if the Fit to Page print option is enabled.

getRowSumsBelow

boolean getRowSumsBelow()
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.

When true a summary row is inserted below the detailed data being summarized and a new outline level is established on that row.

When false a summary row is inserted above the detailed data being summarized and a new outline level is established on that row.

Returns:
true if row summaries appear below detail in the outline

getRowSumsRight

boolean getRowSumsRight()
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.

When true a summary column is inserted to the right of the detailed data being summarized and a new outline level is established on that column.

When false a summary column is inserted to the left of the detailed data being summarized and a new outline level is established on that column.

Returns:
true if col summaries appear right of the detail in the outline

isPrintGridlines

boolean isPrintGridlines()
Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.

Returns:
true if this sheet displays gridlines.
See Also:
to check if printing of gridlines is turned on or off

setPrintGridlines

void setPrintGridlines(boolean show)
Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier. To turn printing of gridlines use setPrintGridlines(boolean)

Parameters:
show - true if this sheet should display gridlines.
See Also:
setPrintGridlines(boolean)

getPrintSetup

PrintSetup getPrintSetup()
Gets the print setup object.

Returns:
The user model for the print setup object.

getHeader

Header getHeader()
Gets the user model for the default document header.

Note that XSSF offers more kinds of document headers than HSSF does

Returns:
the document header. Never null

getFooter

Footer getFooter()
Gets the user model for the default document footer.

Note that XSSF offers more kinds of document footers than HSSF does.

Returns:
the document footer. Never null

setSelected

void setSelected(boolean value)
Sets a flag indicating whether this sheet is selected.

Note: multiple sheets can be selected, but only one sheet can be active at one time.

Parameters:
value - true if this sheet is selected
See Also:
Workbook.setActiveSheet(int)

getMargin

double getMargin(short margin)
Gets the size of the margin in inches.

Parameters:
margin - which margin to get
Returns:
the size of the margin

setMargin

void setMargin(short margin,
               double size)
Sets the size of the margin in inches.

Parameters:
margin - which margin to get
size - the size of the margin

getProtect

boolean getProtect()
Answer whether protection is enabled or disabled

Returns:
true => protection enabled; false => protection disabled

protectSheet

void protectSheet(java.lang.String password)
Sets the protection enabled as well as the password

Parameters:
password - to set for protection. Pass null to remove protection

getScenarioProtect

boolean getScenarioProtect()
Answer whether scenario protection is enabled or disabled

Returns:
true => protection enabled; false => protection disabled

setZoom

void setZoom(int numerator,
             int denominator)
Sets the zoom magnication for the sheet. The zoom is expressed as a fraction. For example to express a zoom of 75% use 3 for the numerator and 4 for the denominator.

Parameters:
numerator - The numerator for the zoom magnification.
denominator - The denominator for the zoom magnification.

getTopRow

short getTopRow()
The top row in the visible view when the sheet is first viewed after opening it in a viewer

Returns:
short indicating the rownum (0 based) of the top row

getLeftCol

short getLeftCol()
The left col in the visible view when the sheet is first viewed after opening it in a viewer

Returns:
short indicating the rownum (0 based) of the top row

showInPane

void showInPane(short toprow,
                short leftcol)
Sets desktop window pane display area, when the file is first opened in a viewer.

Parameters:
toprow - the top row to show in desktop window pane
leftcol - the left column to show in desktop window pane

shiftRows

void shiftRows(int startRow,
               int endRow,
               int n)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around. Calls shiftRows(startRow, endRow, n, false, false);

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift

shiftRows

void shiftRows(int startRow,
               int endRow,
               int n,
               boolean copyRowHeight,
               boolean resetOriginalRowHeight)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift
copyRowHeight - whether to copy the row height during the shift
resetOriginalRowHeight - whether to set the original row's height to the default

createFreezePane

void createFreezePane(int colSplit,
                      int rowSplit,
                      int leftmostColumn,
                      int topRow)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

If both colSplit and rowSplit are zero then the existing freeze pane is removed

Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.
leftmostColumn - Left column visible in right pane.
topRow - Top row visible in bottom pane

createFreezePane

void createFreezePane(int colSplit,
                      int rowSplit)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

If both colSplit and rowSplit are zero then the existing freeze pane is removed

Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.

createSplitPane

void createSplitPane(int xSplitPos,
                     int ySplitPos,
                     int leftmostColumn,
                     int topRow,
                     int activePane)
Creates a split pane. Any existing freezepane or split pane is overwritten.

Parameters:
xSplitPos - Horizonatal position of split (in 1/20th of a point).
ySplitPos - Vertical position of split (in 1/20th of a point).
topRow - Top row visible in bottom pane
leftmostColumn - Left column visible in right pane.
activePane - Active pane. One of: PANE_LOWER_RIGHT, PANE_UPPER_RIGHT, PANE_LOWER_LEFT, PANE_UPPER_LEFT
See Also:
PANE_LOWER_LEFT, PANE_LOWER_RIGHT, PANE_UPPER_LEFT, PANE_UPPER_RIGHT

getPaneInformation

PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze)

Returns:
null if no pane configured, or the pane information.

setDisplayGridlines

void setDisplayGridlines(boolean show)
Sets whether the gridlines are shown in a viewer

Parameters:
show - whether to show gridlines or not

isDisplayGridlines

boolean isDisplayGridlines()
Returns if gridlines are displayed

Returns:
whether gridlines are displayed

setDisplayFormulas

void setDisplayFormulas(boolean show)
Sets whether the formulas are shown in a viewer

Parameters:
show - whether to show formulas or not

isDisplayFormulas

boolean isDisplayFormulas()
Returns if formulas are displayed

Returns:
whether formulas are displayed

setDisplayRowColHeadings

void setDisplayRowColHeadings(boolean show)
Sets whether the RowColHeadings are shown in a viewer

Parameters:
show - whether to show RowColHeadings or not

isDisplayRowColHeadings

boolean isDisplayRowColHeadings()
Returns if RowColHeadings are displayed.

Returns:
whether RowColHeadings are displayed

setRowBreak

void setRowBreak(int row)
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive. For example, sheet.setColumnBreak(2); breaks the sheet into two parts with columns A,B,C in the first and D,E,... in the second. Simuilar, sheet.setRowBreak(2); breaks the sheet into two parts with first three rows (rownum=1...3) in the first part and rows starting with rownum=4 in the second.

Parameters:
row - the row to break, inclusive

isRowBroken

boolean isRowBroken(int row)
Determines if there is a page break at the indicated row

Parameters:
row - FIXME: Document this!
Returns:
FIXME: Document this!

removeRowBreak

void removeRowBreak(int row)
Removes the page break at the indicated row

Parameters:
row -

getRowBreaks

int[] getRowBreaks()
Retrieves all the horizontal page breaks

Returns:
all the horizontal page breaks, or null if there are no row page breaks

getColumnBreaks

int[] getColumnBreaks()
Retrieves all the vertical page breaks

Returns:
all the vertical page breaks, or null if there are no column page breaks

setColumnBreak

void setColumnBreak(int column)
Sets a page break at the indicated column. Breaks occur above the specified row and left of the specified column inclusive. For example, sheet.setColumnBreak(2); breaks the sheet into two parts with columns A,B,C in the first and D,E,... in the second. Simuilar, sheet.setRowBreak(2); breaks the sheet into two parts with first three rows (rownum=1...3) in the first part and rows starting with rownum=4 in the second.

Parameters:
column - the column to break, inclusive

isColumnBroken

boolean isColumnBroken(int column)
Determines if there is a page break at the indicated column

Parameters:
column - FIXME: Document this!
Returns:
FIXME: Document this!

removeColumnBreak

void removeColumnBreak(int column)
Removes a page break at the indicated column

Parameters:
column -

setColumnGroupCollapsed

void setColumnGroupCollapsed(int columnNumber,
                             boolean collapsed)
Expands or collapses a column group.

Parameters:
columnNumber - One of the columns in the group.
collapsed - true = collapse group, false = expand group.

groupColumn

void groupColumn(int fromColumn,
                 int toColumn)
Create an outline for the provided column range.

Parameters:
fromColumn - beginning of the column range.
toColumn - end of the column range.

ungroupColumn

void ungroupColumn(int fromColumn,
                   int toColumn)
Ungroup a range of columns that were previously groupped

Parameters:
fromColumn - start column (0-based)
toColumn - end column (0-based)

groupRow

void groupRow(int fromRow,
              int toRow)
Tie a range of rows together so that they can be collapsed or expanded

Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

ungroupRow

void ungroupRow(int fromRow,
                int toRow)
Ungroup a range of rows that were previously groupped

Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

setRowGroupCollapsed

void setRowGroupCollapsed(int row,
                          boolean collapse)
Set view state of a groupped range of rows

Parameters:
row - start row of a groupped range of rows (0-based)
collapse - whether to expand/collapse the detail rows

setDefaultColumnStyle

void setDefaultColumnStyle(int column,
                           CellStyle style)
Sets the default column style for a given column. POI will only apply this style to new cells added to the sheet.

Parameters:
column - the column index
style - the style to set

autoSizeColumn

void autoSizeColumn(int column)
Adjusts the column width to fit the contents.

This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing.

You can specify whether the content of merged cells should be considered or ignored. Default is to ignore merged cells.

Parameters:
column - the column index

autoSizeColumn

void autoSizeColumn(int column,
                    boolean useMergedCells)
Adjusts the column width to fit the contents.

This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing.

You can specify whether the content of merged cells should be considered or ignored. Default is to ignore merged cells.

Parameters:
column - the column index
useMergedCells - whether to use the contents of merged cells when calculating the width of the column

getCellComment

Comment getCellComment(int row,
                       int column)
Returns cell comment for the specified row and column

Returns:
cell comment or null if not found

createDrawingPatriarch

Drawing createDrawingPatriarch()
Creates the top-level drawing patriarch.

Returns:
The new drawing patriarch.

getWorkbook

Workbook getWorkbook()
Return the parent workbook

Returns:
the parent workbook

getSheetName

java.lang.String getSheetName()
Returns the name of this sheet

Returns:
the name of this sheet

isSelected

boolean isSelected()
Note - this is not the same as whether the sheet is focused (isActive)

Returns:
true if this sheet is currently selected

setArrayFormula

CellRange<? extends Cell> setArrayFormula(java.lang.String formula,
                                          CellRangeAddress range)
Sets array formula to specified region for result.

Parameters:
formula - text representation of the formula
range - Region of array formula for result.
Returns:
the CellRange of cells affected by this change

removeArrayFormula

CellRange<? extends Cell> removeArrayFormula(Cell cell)
Remove a Array Formula from this sheet. All cells contained in the Array Formula range are removed as well

Parameters:
cell - any cell within Array Formula range
Returns:
the CellRange of cells affected by this change

getDataValidationHelper

DataValidationHelper getDataValidationHelper()

addValidationData

void addValidationData(DataValidation dataValidation)
Creates a data validation object

Parameters:
dataValidation - The Data validation object settings

setAutoFilter

AutoFilter setAutoFilter(CellRangeAddress range)
Enable filtering for a range of cells

Parameters:
range - the range of cells to filter

getSheetConditionalFormatting

SheetConditionalFormatting getSheetConditionalFormatting()
The 'Conditional Formatting' facet for this Sheet

Returns:
conditional formatting rule for this sheet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SheetConditionalFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface SheetConditionalFormatting

All Known Implementing Classes:
HSSFSheetConditionalFormatting, XSSFSheetConditionalFormatting
public interface SheetConditionalFormatting

The 'Conditional Formatting' facet of Sheet

Since:
3.8
Author:
Dmitriy Kumshayev, Yegor Kozlov

Method Summary
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule) Add a new Conditional Formatting to the sheet.
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules) Add a new Conditional Formatting set to the sheet.
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2) Add a new Conditional Formatting consisting of two rules.
int | addConditionalFormatting(ConditionalFormatting cf) Adds a copy of a ConditionalFormatting object to the sheet
ConditionalFormattingRule | createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula) Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *
ConditionalFormattingRule | createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1, java.lang.String formula2) A factory method allowing to create a conditional formatting rule with a cell comparison operator
ConditionalFormattingRule | createConditionalFormattingRule(java.lang.String formula) Create a conditional formatting rule based on a Boolean formula.
ConditionalFormatting | getConditionalFormattingAt(int index) Gets Conditional Formatting object at a particular index
int | getNumConditionalFormattings()
void | removeConditionalFormatting(int index) Removes a Conditional Formatting object by index

Method Detail

addConditionalFormatting

int addConditionalFormatting(CellRangeAddress[] regions,
                             ConditionalFormattingRule rule)
Add a new Conditional Formatting to the sheet.

Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
rule - - the rule to apply
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

int addConditionalFormatting(CellRangeAddress[] regions,
                             ConditionalFormattingRule rule1,
                             ConditionalFormattingRule rule2)
Add a new Conditional Formatting consisting of two rules.

Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
rule1 - - the first rule
rule2 - - the second rule
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

int addConditionalFormatting(CellRangeAddress[] regions,
                             ConditionalFormattingRule[] cfRules)
Add a new Conditional Formatting set to the sheet.

Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
cfRules - - set of up to three conditional formatting rules
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

int addConditionalFormatting(ConditionalFormatting cf)
Adds a copy of a ConditionalFormatting object to the sheet

This method could be used to copy ConditionalFormatting object from one sheet to another. For example:

 ConditionalFormatting cf = sheet.getConditionalFormattingAt(index);
 newSheet.addConditionalFormatting(cf);

Parameters:
cf - the Conditional Formatting to clone
Returns:
index of the new Conditional Formatting object

createConditionalFormattingRule

ConditionalFormattingRule createConditionalFormattingRule(byte comparisonOperation,
                                                          java.lang.String formula1,
                                                          java.lang.String formula2)
A factory method allowing to create a conditional formatting rule with a cell comparison operator

The created conditional formatting rule compares a cell value to a formula calculated result, using the specified operator. The type of the created condition is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS

Parameters:
comparisonOperation - - MUST be a constant value from ComparisonOperator:

  • BETWEEN
  • NOT_BETWEEN
  • EQUAL
  • NOT_EQUAL
  • GT
  • LT
  • GE
  • LE

formula1 - - formula for the valued, compared with the cell
formula2 - - second formula (only used with ComparisonOperator.BETWEEN) and ComparisonOperator.NOT_BETWEEN operations)

createConditionalFormattingRule

ConditionalFormattingRule createConditionalFormattingRule(byte comparisonOperation,
                                                          java.lang.String formula)
Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *

The type of the created condition is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS

Parameters:
comparisonOperation - MUST be a constant value from ComparisonOperator except BETWEEN and NOT_BETWEEN
formula - the formula to determine if the conditional formatting is applied

createConditionalFormattingRule

ConditionalFormattingRule createConditionalFormattingRule(java.lang.String formula)
Create a conditional formatting rule based on a Boolean formula. When the formula result is true, the cell is highlighted.

The type of the created format condition is ConditionalFormattingRule.CONDITION_TYPE_FORMULA

Parameters:
formula - the formula to evaluate. MUST be a Boolean function.

getConditionalFormattingAt

ConditionalFormatting getConditionalFormattingAt(int index)
Gets Conditional Formatting object at a particular index

Parameters:
index - 0-based index of the Conditional Formatting object to fetch
Returns:
Conditional Formatting object or null if not found
Throws:
java.lang.IllegalArgumentException - if the index is outside of the allowable range (0 ... numberOfFormats-1)

getNumConditionalFormattings

int getNumConditionalFormattings()
Returns:
the number of conditional formats in this sheet

removeConditionalFormatting

void removeConditionalFormatting(int index)
Removes a Conditional Formatting object by index

Parameters:
index - 0-based index of the Conditional Formatting object to remove
Throws:
java.lang.IllegalArgumentException - if the index is outside of the allowable range (0 ... numberOfFormats-1)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Textbox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Textbox

public interface Textbox

Field Summary
static short OBJECT_TYPE_TEXT
Method Summary
int | getMarginBottom() Gets the bottom margin within the textbox.
int | getMarginLeft()
int | getMarginRight()
int | getMarginTop()
RichTextString | getString()
void | setMarginBottom(int marginBottom) Sets the bottom margin within the textbox.
void | setMarginLeft(int marginLeft) Sets the left margin within the textbox.
void | setMarginRight(int marginRight) Sets the right margin within the textbox.
void | setMarginTop(int marginTop) Sets the top margin within the textbox.
void | setString(RichTextString string)

Field Detail

OBJECT_TYPE_TEXT

static final short OBJECT_TYPE_TEXT
See Also:
Constant Field Values
Method Detail

getString

RichTextString getString()
Returns:
the rich text string for this textbox.

setString

void setString(RichTextString string)
Parameters:
string - Sets the rich text string used by this object.

getMarginLeft

int getMarginLeft()
Returns:
Returns the left margin within the textbox.

setMarginLeft

void setMarginLeft(int marginLeft)
Sets the left margin within the textbox.

getMarginRight

int getMarginRight()
Returns:
returns the right margin within the textbox.

setMarginRight

void setMarginRight(int marginRight)
Sets the right margin within the textbox.

getMarginTop

int getMarginTop()
Returns:
returns the top margin within the textbox.

setMarginTop

void setMarginTop(int marginTop)
Sets the top margin within the textbox.

getMarginBottom

int getMarginBottom()
Gets the bottom margin within the textbox.

setMarginBottom

void setMarginBottom(int marginBottom)
Sets the bottom margin within the textbox.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VerticalAlignment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel
Enum VerticalAlignment

java.lang.Object
    extended by  java.lang.Enum<VerticalAlignment>
        extended by  org.apache.poi.ss.usermodel.VerticalAlignment
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<VerticalAlignment>
public enum VerticalAlignment
extends java.lang.Enum<VerticalAlignment>

This enumeration value indicates the type of vertical alignment for a cell, i.e., whether it is aligned top, bottom, vertically centered, justified or distributed.

Enum Constant Summary
BOTTOM
The vertical alignment is aligned-to-bottom.
CENTER
The vertical alignment is centered across the height of the cell.
DISTRIBUTED
When text direction is horizontal: the vertical alignment of lines of text is distributed vertically, where each line of text inside the cell is evenly distributed across the height of the cell, with flush top
JUSTIFY
When text direction is horizontal: the vertical alignment of lines of text is distributed vertically, where each line of text inside the cell is evenly distributed across the height of the cell, with flush top and bottom margins.
TOP
The vertical alignment is aligned-to-top.
Method Summary
static VerticalAlignment | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static VerticalAlignment[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TOP

public static final VerticalAlignment TOP
The vertical alignment is aligned-to-top.

CENTER

public static final VerticalAlignment CENTER
The vertical alignment is centered across the height of the cell.

BOTTOM

public static final VerticalAlignment BOTTOM
The vertical alignment is aligned-to-bottom.

JUSTIFY

public static final VerticalAlignment JUSTIFY

When text direction is horizontal: the vertical alignment of lines of text is distributed vertically, where each line of text inside the cell is evenly distributed across the height of the cell, with flush top and bottom margins.

When text direction is vertical: similar behavior as horizontal justification. The alignment is justified (flush top and bottom in this case). For each line of text, each line of the wrapped text in a cell is aligned to the top and bottom (except the last line). If no single line of text wraps in the cell, then the text is not justified.

DISTRIBUTED

public static final VerticalAlignment DISTRIBUTED

When text direction is horizontal: the vertical alignment of lines of text is distributed vertically, where each line of text inside the cell is evenly distributed across the height of the cell, with flush top

When text direction is vertical: behaves exactly as distributed horizontal alignment. The first words in a line of text (appearing at the top of the cell) are flush with the top edge of the cell, and the last words of a line of text are flush with the bottom edge of the cell, and the line of text is distributed evenly from top to bottom.

Method Detail

values

public static VerticalAlignment[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (VerticalAlignment c : VerticalAlignment.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static VerticalAlignment valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Workbook

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Interface Workbook

All Known Implementing Classes:
HSSFWorkbook, SXSSFWorkbook, XSSFWorkbook
public interface Workbook

High level representation of a Excel workbook. This is the first object most users will construct whether they are reading or writing a workbook. It is also the top level object for creating new sheets/etc.

Field Summary
static int | PICTURE_TYPE_DIB Device independent bitmap
static int | PICTURE_TYPE_EMF Extended windows meta file
static int | PICTURE_TYPE_JPEG JPEG format
static int | PICTURE_TYPE_PICT Mac PICT format
static int | PICTURE_TYPE_PNG PNG format
static int | PICTURE_TYPE_WMF Windows Meta File
static int | SHEET_STATE_HIDDEN Indicates the book window is hidden, but can be shown by the user via the user interface.
static int | SHEET_STATE_VERY_HIDDEN Indicates the sheet is hidden and cannot be shown in the user interface (UI).
static int | SHEET_STATE_VISIBLE Indicates the sheet is visible.
Method Summary
 int addPicture(byte[] pictureData, int format)
Adds a picture to the workbook.
 void addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.
 Sheet cloneSheet(int sheetNum)
Create an Sheet from an existing sheet in the Workbook.
 CellStyle createCellStyle()
Create a new Cell style and add it to the workbook's style table
 DataFormat createDataFormat()
Returns the instance of DataFormat for this workbook.
 Font createFont()
Create a new Font and add it to the workbook's font table
 Name createName()
Creates a new (uninitialised) defined name in this workbook
 Sheet createSheet()
Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
 Sheet createSheet(java.lang.String sheetname)
Create a new sheet for this Workbook and return the high level representation.
 Font findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline)
Finds a font that matches the one with the supplied attributes
 int getActiveSheetIndex()
Convenience method to get the active sheet.
 java.util.List<? extends PictureData> getAllPictures()
Gets all pictures from the Workbook.
 CellStyle getCellStyleAt(short idx)
Get the cell style object at the given index
 CreationHelper getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
 int getFirstVisibleTab()
Gets the first tab that is displayed in the list of tabs in excel.
 Font getFontAt(short idx)
Get the font at the given index number
 boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
 Row.MissingCellPolicy getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.
 Name getName(java.lang.String name)
 Name getNameAt(int nameIndex)
 int getNameIndex(java.lang.String name)
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.
 short getNumberOfFonts()
Get the number of fonts in the font table
 int getNumberOfNames()
 int getNumberOfSheets()
Get the number of spreadsheets in the workbook
 short getNumCellStyles()
Get the number of styles the workbook contains
 java.lang.String getPrintArea(int sheetIndex)
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
 Sheet getSheet(java.lang.String name)
Get sheet with the given name
 Sheet getSheetAt(int index)
Get the Sheet object at the given index.
 int getSheetIndex(Sheet sheet)
Returns the index of the given sheet
 int getSheetIndex(java.lang.String name)
Returns the index of the sheet by his name
 java.lang.String getSheetName(int sheet)
Get the sheet name
 boolean isHidden()
 boolean isSheetHidden(int sheetIx)
Check whether a sheet is hidden.
 boolean isSheetVeryHidden(int sheetIx)
Check whether a sheet is very hidden.
 void removeName(int index)
Remove the defined name at the specified index
 void removeName(java.lang.String name)
Remove a defined name by name
 void removePrintArea(int sheetIndex)
Delete the printarea for the sheet specified
 void removeSheetAt(int index)
Removes sheet at the given index
 void setActiveSheet(int sheetIndex)
Convenience method to set the active sheet.
 void setFirstVisibleTab(int sheetIndex)
Sets the first tab that is displayed in the list of tabs in excel.
 void setForceFormulaRecalculation(boolean value)
Whether the application shall perform a full recalculation when the workbook is opened.
 void setHidden(boolean hiddenFlag)
 void setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy)
Sets the policy on what to do when getting missing or blank cells from a row.
 void setPrintArea(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow)
For the Convenience of Java Programmers maintaining pointers.
 void setPrintArea(int sheetIndex, java.lang.String reference)
Sets the printarea for the sheet provided
 void setRepeatingRowsAndColumns(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow)
Sets the repeating rows and columns for a sheet (as found in File->PageSetup->Sheet).
 void setSelectedTab(int index)
Sets the tab whose data is actually seen when the sheet is opened.
 void setSheetHidden(int sheetIx, boolean hidden)
Hide or unhide a sheet
 void setSheetHidden(int sheetIx, int hidden)
Hide or unhide a sheet.
 void setSheetName(int sheet, java.lang.String name)
Set the sheet name.
 void setSheetOrder(java.lang.String sheetname, int pos)
Sets the order of appearance for a given sheet.
 void write(java.io.OutputStream stream)
Write out this workbook to an Outputstream.

Field Detail

PICTURE_TYPE_EMF

static final int PICTURE_TYPE_EMF
Extended windows meta file

See Also:
Constant Field Values

PICTURE_TYPE_WMF

static final int PICTURE_TYPE_WMF
Windows Meta File

See Also:
Constant Field Values

PICTURE_TYPE_PICT

static final int PICTURE_TYPE_PICT
Mac PICT format

See Also:
Constant Field Values

PICTURE_TYPE_JPEG

static final int PICTURE_TYPE_JPEG
JPEG format

See Also:
Constant Field Values

PICTURE_TYPE_PNG

static final int PICTURE_TYPE_PNG
PNG format

See Also:
Constant Field Values

PICTURE_TYPE_DIB

static final int PICTURE_TYPE_DIB
Device independent bitmap

See Also:
Constant Field Values

SHEET_STATE_VISIBLE

static final int SHEET_STATE_VISIBLE
Indicates the sheet is visible.

See Also:
setSheetHidden(int, int), Constant Field Values

SHEET_STATE_HIDDEN

static final int SHEET_STATE_HIDDEN
Indicates the book window is hidden, but can be shown by the user via the user interface.

See Also:
setSheetHidden(int, int), Constant Field Values

SHEET_STATE_VERY_HIDDEN

static final int SHEET_STATE_VERY_HIDDEN
Indicates the sheet is hidden and cannot be shown in the user interface (UI).

In Excel this state is only available programmatically in VBA: ThisWorkbook.Sheets("MySheetName").Visible = xlSheetVeryHidden

See Also:
setSheetHidden(int, int), Constant Field Values
Method Detail

getActiveSheetIndex

int getActiveSheetIndex()
Convenience method to get the active sheet. The active sheet is is the sheet which is currently displayed when the workbook is viewed in Excel. 'Selected' sheet(s) is a distinct concept.

Returns:
the index of the active sheet (0-based)

setActiveSheet

void setActiveSheet(int sheetIndex)
Convenience method to set the active sheet. The active sheet is is the sheet which is currently displayed when the workbook is viewed in Excel. 'Selected' sheet(s) is a distinct concept.

Parameters:
sheetIndex - index of the active sheet (0-based)

getFirstVisibleTab

int getFirstVisibleTab()
Gets the first tab that is displayed in the list of tabs in excel.

Returns:
the first tab that to display in the list of tabs (0-based).

setFirstVisibleTab

void setFirstVisibleTab(int sheetIndex)
Sets the first tab that is displayed in the list of tabs in excel.

Parameters:
sheetIndex - the first tab that to display in the list of tabs (0-based)

setSheetOrder

void setSheetOrder(java.lang.String sheetname,
                   int pos)
Sets the order of appearance for a given sheet.

Parameters:
sheetname - the name of the sheet to reorder
pos - the position that we want to insert the sheet into (0 based)

setSelectedTab

void setSelectedTab(int index)
Sets the tab whose data is actually seen when the sheet is opened. This may be different from the "selected sheet" since excel seems to allow you to show the data of one sheet when another is seen "selected" in the tabs (at the bottom).

Parameters:
index - the index of the sheet to select (0 based)
See Also:
Sheet.setSelected(boolean)

setSheetName

void setSheetName(int sheet,
                  java.lang.String name)
Set the sheet name.

See WorkbookUtil.createSafeSheetName(String nameProposal) for a safe way to create valid names

Parameters:
sheet - number (0 based)
Throws:
java.lang.IllegalArgumentException - if the name is null or invalid or workbook already contains a sheet with this name
See Also:
createSheet(String), WorkbookUtil.createSafeSheetName(String nameProposal)

getSheetName

java.lang.String getSheetName(int sheet)
Get the sheet name

Parameters:
sheet - sheet number (0 based)
Returns:
Sheet name

getSheetIndex

int getSheetIndex(java.lang.String name)
Returns the index of the sheet by his name

Parameters:
name - the sheet name
Returns:
index of the sheet (0 based)

getSheetIndex

int getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Parameters:
sheet - the sheet to look up
Returns:
index of the sheet (0 based)

createSheet

Sheet createSheet()
Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation. Use this to create new sheets.

Returns:
Sheet representing the new sheet.

createSheet

Sheet createSheet(java.lang.String sheetname)
Create a new sheet for this Workbook and return the high level representation. Use this to create new sheets.

Note that Excel allows sheet names up to 31 chars in length but other applications (such as OpenOffice) allow more. Some versions of Excel crash with names longer than 31 chars, others - truncate such names to 31 character.

POI's SpreadsheetAPI silently truncates the input argument to 31 characters. Example:

     Sheet sheet = workbook.createSheet("My very long sheet name which is longer than 31 chars"); // will be truncated
     assert 31 == sheet.getSheetName().length();
     assert "My very long sheet name which i" == sheet.getSheetName();

Except the 31-character constraint, Excel applies some other rules:

Sheet name MUST be unique in the workbook and MUST NOT contain the any of the following characters:

  • 0x0000
  • 0x0003
  • colon (:)
  • backslash (\)
  • asterisk (*)
  • question mark (?)
  • forward slash (/)
  • opening square bracket ([)
  • closing square bracket (])
The string MUST NOT begin or end with the single quote (') character.

See WorkbookUtil.createSafeSheetName(String nameProposal) for a safe way to create valid names

Parameters:
sheetname - sheetname to set for the sheet.
Returns:
Sheet representing the new sheet.
Throws:
java.lang.IllegalArgumentException - if the name is null or invalid or workbook already contains a sheet with this name
See Also:
WorkbookUtil.createSafeSheetName(String nameProposal)

cloneSheet

Sheet cloneSheet(int sheetNum)
Create an Sheet from an existing sheet in the Workbook.

Returns:
Sheet representing the cloned sheet.

getNumberOfSheets

int getNumberOfSheets()
Get the number of spreadsheets in the workbook

Returns:
the number of sheets

getSheetAt

Sheet getSheetAt(int index)
Get the Sheet object at the given index.

Parameters:
index - of the sheet number (0-based physical & logical)
Returns:
Sheet at the provided index

getSheet

Sheet getSheet(java.lang.String name)
Get sheet with the given name

Parameters:
name - of the sheet
Returns:
Sheet with the name provided or null if it does not exist

removeSheetAt

void removeSheetAt(int index)
Removes sheet at the given index

Parameters:
index - of the sheet to remove (0-based)

setRepeatingRowsAndColumns

void setRepeatingRowsAndColumns(int sheetIndex,
                                int startColumn,
                                int endColumn,
                                int startRow,
                                int endRow)
Sets the repeating rows and columns for a sheet (as found in File->PageSetup->Sheet). This is function is included in the workbook because it creates/modifies name records which are stored at the workbook level.

To set just repeating columns:

  workbook.setRepeatingRowsAndColumns(0,0,1,-1-1);
To set just repeating rows:
  workbook.setRepeatingRowsAndColumns(0,-1,-1,0,4);
To remove all repeating rows and columns for a sheet.
  workbook.setRepeatingRowsAndColumns(0,-1,-1,-1,-1);

Parameters:
sheetIndex - 0 based index to sheet.
startColumn - 0 based start of repeating columns.
endColumn - 0 based end of repeating columns.
startRow - 0 based start of repeating rows.
endRow - 0 based end of repeating rows.

createFont

Font createFont()
Create a new Font and add it to the workbook's font table

Returns:
new font object

findFont

Font findFont(short boldWeight,
              short color,
              short fontHeight,
              java.lang.String name,
              boolean italic,
              boolean strikeout,
              short typeOffset,
              byte underline)
Finds a font that matches the one with the supplied attributes

Returns:
the font with the matched attributes or null

getNumberOfFonts

short getNumberOfFonts()
Get the number of fonts in the font table

Returns:
number of fonts

getFontAt

Font getFontAt(short idx)
Get the font at the given index number

Parameters:
idx - index number (0-based)
Returns:
font at the index

createCellStyle

CellStyle createCellStyle()
Create a new Cell style and add it to the workbook's style table

Returns:
the new Cell Style object

getNumCellStyles

short getNumCellStyles()
Get the number of styles the workbook contains

Returns:
count of cell styles

getCellStyleAt

CellStyle getCellStyleAt(short idx)
Get the cell style object at the given index

Parameters:
idx - index within the set of styles (0-based)
Returns:
CellStyle object at the index

write

void write(java.io.OutputStream stream)
           throws java.io.IOException
Write out this workbook to an Outputstream.

Parameters:
stream - - the java OutputStream you wish to write to
Throws:
java.io.IOException - if anything can't be written.

getNumberOfNames

int getNumberOfNames()
Returns:
the total number of defined names in this workbook

getName

Name getName(java.lang.String name)
Parameters:
name - the name of the defined name
Returns:
the defined name with the specified name. null if not found.

getNameAt

Name getNameAt(int nameIndex)
Parameters:
nameIndex - position of the named range (0-based)
Returns:
the defined name at the specified index
Throws:
java.lang.IllegalArgumentException - if the supplied index is invalid

createName

Name createName()
Creates a new (uninitialised) defined name in this workbook

Returns:
new defined name object

getNameIndex

int getNameIndex(java.lang.String name)
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.

Parameters:
name - the name of the defined name
Returns:
zero based index of the defined name. -1 if not found.

removeName

void removeName(int index)
Remove the defined name at the specified index

Parameters:
index - named range index (0 based)

removeName

void removeName(java.lang.String name)
Remove a defined name by name

Parameters:
name - the name of the defined name

setPrintArea

void setPrintArea(int sheetIndex,
                  java.lang.String reference)
Sets the printarea for the sheet provided

i.e. Reference = $A$1:$B$2

Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
reference - Valid name Reference for the Print Area

setPrintArea

void setPrintArea(int sheetIndex,
                  int startColumn,
                  int endColumn,
                  int startRow,
                  int endRow)
For the Convenience of Java Programmers maintaining pointers.

Parameters:
sheetIndex - Zero-based sheet index (0 = First Sheet)
startColumn - Column to begin printarea
endColumn - Column to end the printarea
startRow - Row to begin the printarea
endRow - Row to end the printarea
See Also:
setPrintArea(int, String)

getPrintArea

java.lang.String getPrintArea(int sheetIndex)
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.

Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
Returns:
String Null if no print area has been defined

removePrintArea

void removePrintArea(int sheetIndex)
Delete the printarea for the sheet specified

Parameters:
sheetIndex - Zero-based sheet index (0 = First Sheet)

getMissingCellPolicy

Row.MissingCellPolicy getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.

The default is to return blank and null cells. Row.MissingCellPolicy

setMissingCellPolicy

void setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy)
Sets the policy on what to do when getting missing or blank cells from a row. This will then apply to all calls to Row.getCell(int) }. See Row.MissingCellPolicy

createDataFormat

DataFormat createDataFormat()
Returns the instance of DataFormat for this workbook.

Returns:
the DataFormat object

addPicture

int addPicture(byte[] pictureData,
               int format)
Adds a picture to the workbook.

Parameters:
pictureData - The bytes of the picture
format - The format of the picture.
Returns:
the index to this picture (1 based).
See Also:
PICTURE_TYPE_EMF, PICTURE_TYPE_WMF, PICTURE_TYPE_PICT, PICTURE_TYPE_JPEG, PICTURE_TYPE_PNG, PICTURE_TYPE_DIB

getAllPictures

java.util.List<? extends PictureData> getAllPictures()
Gets all pictures from the Workbook.

Returns:
the list of pictures (a list of PictureData objects.)

getCreationHelper

CreationHelper getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.

isHidden

boolean isHidden()
Returns:
false if this workbook is not visible in the GUI

setHidden

void setHidden(boolean hiddenFlag)
Parameters:
hiddenFlag - pass false to make the workbook visible in the GUI

isSheetHidden

boolean isSheetHidden(int sheetIx)
Check whether a sheet is hidden.

Note that a sheet could instead be set to be very hidden, which is different (isSheetVeryHidden(int))

Parameters:
sheetIx - Number
Returns:
true if sheet is hidden

isSheetVeryHidden

boolean isSheetVeryHidden(int sheetIx)
Check whether a sheet is very hidden.

This is different from the normal hidden status (isSheetHidden(int))

Parameters:
sheetIx - sheet index to check
Returns:
true if sheet is very hidden

setSheetHidden

void setSheetHidden(int sheetIx,
                    boolean hidden)
Hide or unhide a sheet

Parameters:
sheetIx - the sheet index (0-based)
hidden - True to mark the sheet as hidden, false otherwise

setSheetHidden

void setSheetHidden(int sheetIx,
                    int hidden)
Hide or unhide a sheet.
  • 0 - visible.
  • 1 - hidden.
  • 2 - very hidden.

Parameters:
sheetIx - the sheet index (0-based)
hidden - one of the following Workbook constants: Workbook.SHEET_STATE_VISIBLE, Workbook.SHEET_STATE_HIDDEN, or Workbook.SHEET_STATE_VERY_HIDDEN.
Throws:
java.lang.IllegalArgumentException - if the supplied sheet index or state is invalid

addToolPack

void addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.

Parameters:
toopack - the toolpack to register

setForceFormulaRecalculation

void setForceFormulaRecalculation(boolean value)
Whether the application shall perform a full recalculation when the workbook is opened.

Typically you want to force formula recalculation when you modify cell formulas or values of a workbook previously created by Excel. When set to true, this flag will tell Excel that it needs to recalculate all formulas in the workbook the next time the file is opened.

Note, that recalculation updates cached formula results and, thus, modifies the workbook. Depending on the version, Excel may prompt you with "Do you want to save the changes in filename?" on close.

Parameters:
value - true if the application will perform a full recalculation of workbook values when the workbook is opened
Since:
3.8

getForceFormulaRecalculation

boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.

Since:
3.8
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkbookFactory

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel
Class WorkbookFactory

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.WorkbookFactory

public class WorkbookFactory
extends java.lang.Object

Factory for creating the appropriate kind of Workbook (be it HSSFWorkbook or XSSFWorkbook), from the given input

Constructor Summary
WorkbookFactory()
Method Summary
static Workbook | create(java.io.File file) Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given File, which must exist and be readable.
static Workbook | create(java.io.InputStream inp) Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given InputStream.
static Workbook | create(NPOIFSFileSystem fs) Creates an HSSFWorkbook from the given NPOIFSFileSystem
static Workbook | create(OPCPackage pkg) Creates an XSSFWorkbook from the given OOXML Package
static Workbook | create(POIFSFileSystem fs) Creates an HSSFWorkbook from the given POIFSFileSystem
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkbookFactory

public WorkbookFactory()
Method Detail

create

public static Workbook create(POIFSFileSystem fs)
                       throws java.io.IOException
Creates an HSSFWorkbook from the given POIFSFileSystem

Throws:
java.io.IOException

create

public static Workbook create(NPOIFSFileSystem fs)
                       throws java.io.IOException
Creates an HSSFWorkbook from the given NPOIFSFileSystem

Throws:
java.io.IOException

create

public static Workbook create(OPCPackage pkg)
                       throws java.io.IOException
Creates an XSSFWorkbook from the given OOXML Package

Throws:
java.io.IOException

create

public static Workbook create(java.io.InputStream inp)
                       throws java.io.IOException,
                              InvalidFormatException
Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given InputStream. Your input stream MUST either support mark/reset, or be wrapped as a PushbackInputStream!

Throws:
java.io.IOException
InvalidFormatException

create

public static Workbook create(java.io.File file)
                       throws java.io.IOException,
                              InvalidFormatException
Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given File, which must exist and be readable.

Throws:
java.io.IOException
InvalidFormatException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AxisCrossBetween

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel.charts
Enum AxisCrossBetween

java.lang.Object
    extended by  java.lang.Enum<AxisCrossBetween>
        extended by  org.apache.poi.ss.usermodel.charts.AxisCrossBetween
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<AxisCrossBetween>
public enum AxisCrossBetween
extends java.lang.Enum<AxisCrossBetween>

Specifies the possible crossing states of an axis.

Author:
Roman Kashitsyn

Enum Constant Summary
BETWEEN
Specifies the value axis shall cross the category axis between data markers.
MIDPOINT_CATEGORY
Specifies the value axis shall cross the category axis at the midpoint of a category.
Method Summary
static AxisCrossBetween | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisCrossBetween[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

BETWEEN

public static final AxisCrossBetween BETWEEN
Specifies the value axis shall cross the category axis between data markers.

MIDPOINT_CATEGORY

public static final AxisCrossBetween MIDPOINT_CATEGORY
Specifies the value axis shall cross the category axis at the midpoint of a category.

Method Detail

values

public static AxisCrossBetween[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (AxisCrossBetween c : AxisCrossBetween.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static AxisCrossBetween valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD


AxisCrosses

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel.charts
Enum AxisCrosses

java.lang.Object
    extended by  java.lang.Enum<AxisCrosses>
        extended by  org.apache.poi.ss.usermodel.charts.AxisCrosses
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<AxisCrosses>
public enum AxisCrosses
extends java.lang.Enum<AxisCrosses>

Specifies the possible crossing points for an axis.

Author:
Roman Kashitsyn

Enum Constant Summary
AUTO_ZERO
The category axis crosses at the zero point of the value axis (if possible), or the minimum value (if the minimum is greater than zero) or the maximum (if the maximum is less than zero).
MAX
Axis crosses at the minimum value of the chart.
MIN
The axis crosses at the maximum value.
Method Summary
static AxisCrosses | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisCrosses[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

AUTO_ZERO

public static final AxisCrosses AUTO_ZERO
The category axis crosses at the zero point of the value axis (if possible), or the minimum value (if the minimum is greater than zero) or the maximum (if the maximum is less than zero).

MIN

public static final AxisCrosses MIN
The axis crosses at the maximum value.

MAX

public static final AxisCrosses MAX
Axis crosses at the minimum value of the chart.

Method Detail

values

public static AxisCrosses[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (AxisCrosses c : AxisCrosses.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static AxisCrosses valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


AxisOrientation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel.charts
Enum AxisOrientation

java.lang.Object
    extended by  java.lang.Enum<AxisOrientation>
        extended by  org.apache.poi.ss.usermodel.charts.AxisOrientation
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<AxisOrientation>
public enum AxisOrientation
extends java.lang.Enum<AxisOrientation>

Specifies the possible ways to place a picture on a data point, series, wall, or floor.

Author:
Roman Kashitsyn

Enum Constant Summary
MAX_MIN
Specifies that the values on the axis shall be reversed so they go from maximum to minimum.
MIN_MAX
Specifies that the axis values shall be in the usual order, minimum to maximum.
Method Summary
static AxisOrientation | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisOrientation[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

MAX_MIN

public static final AxisOrientation MAX_MIN
Specifies that the values on the axis shall be reversed so they go from maximum to minimum.

MIN_MAX

public static final AxisOrientation MIN_MAX
Specifies that the axis values shall be in the usual order, minimum to maximum.

Method Detail

values

public static AxisOrientation[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (AxisOrientation c : AxisOrientation.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static AxisOrientation valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


AxisPosition

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel.charts
Enum AxisPosition

java.lang.Object
    extended by  java.lang.Enum<AxisPosition>
        extended by  org.apache.poi.ss.usermodel.charts.AxisPosition
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<AxisPosition>
public enum AxisPosition
extends java.lang.Enum<AxisPosition>

Enumeration of all possible axis positions.

Author:
Roman Kashitsyn

Enum Constant Summary
BOTTOM
LEFT
RIGHT
TOP
Method Summary
static AxisPosition | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisPosition[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

BOTTOM

public static final AxisPosition BOTTOM

LEFT

public static final AxisPosition LEFT

RIGHT

public static final AxisPosition RIGHT

TOP

public static final AxisPosition TOP
Method Detail

values

public static AxisPosition[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (AxisPosition c : AxisPosition.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static AxisPosition valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ChartAxis

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ChartAxis

All Known Subinterfaces:
ValueAxis
All Known Implementing Classes:
XSSFChartAxis, XSSFValueAxis
@Beta
public interface ChartAxis

High level representation of chart axis.

Author:
Roman Kashitsyn

Method Summary
void | crossAxis(ChartAxis axis) Declare this axis cross another axis.
AxisCrosses | getCrosses()
long | getId()
double | getLogBase()
double | getMaximum()
double | getMinimum()
java.lang.String | getNumberFormat()
AxisOrientation | getOrientation()
AxisPosition | getPosition()
boolean | isSetLogBase()
boolean | isSetMaximum()
boolean | isSetMinimum()
void | setCrosses(AxisCrosses crosses)
void | setLogBase(double logBase)
void | setMaximum(double max)
void | setMinimum(double min)
void | setNumberFormat(java.lang.String format)
void | setOrientation(AxisOrientation orientation)
void | setPosition(AxisPosition position)

Method Detail

getId

long getId()
Returns:
axis id

getPosition

AxisPosition getPosition()
Returns:
axis position

setPosition

void setPosition(AxisPosition position)
Parameters:
position - new axis position

getNumberFormat

java.lang.String getNumberFormat()
Returns:
axis number format

setNumberFormat

void setNumberFormat(java.lang.String format)
Parameters:
format - axis number format

isSetLogBase

boolean isSetLogBase()
Returns:
true if log base is defined, false otherwise

setLogBase

void setLogBase(double logBase)
Parameters:
logBase - a number between 2 and 1000 (inclusive)
Throws:
java.lang.IllegalArgumentException - if log base not within allowed range

getLogBase

double getLogBase()
Returns:
axis log base or 0.0 if not set

isSetMinimum

boolean isSetMinimum()
Returns:
true if minimum value is defined, false otherwise

getMinimum

double getMinimum()
Returns:
axis minimum or 0.0 if not set

setMinimum

void setMinimum(double min)
Parameters:
min - axis minimum

isSetMaximum

boolean isSetMaximum()
Returns:
true if maximum value is defined, false otherwise

getMaximum

double getMaximum()
Returns:
axis maximum or 0.0 if not set

setMaximum

void setMaximum(double max)
Parameters:
max - axis maximum

getOrientation

AxisOrientation getOrientation()
Returns:
axis orientation

setOrientation

void setOrientation(AxisOrientation orientation)
Parameters:
orientation - axis orientation

setCrosses

void setCrosses(AxisCrosses crosses)
Parameters:
crosses - axis cross type

getCrosses

AxisCrosses getCrosses()
Returns:
axis cross type

crossAxis

void crossAxis(ChartAxis axis)
Declare this axis cross another axis.

Parameters:
axis - that this axis should cross
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartAxisFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ChartAxisFactory

All Known Implementing Classes:
XSSFChart
@Beta
public interface ChartAxisFactory

A factory for different chart axis.

Author:
Roman Kashitsyn

Method Summary
 ValueAxis createValueAxis(AxisPosition pos)

Method Detail

createValueAxis

ValueAxis createValueAxis(AxisPosition pos)
Returns:
new value axis
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ChartData

All Known Subinterfaces:
ScatterChartData
All Known Implementing Classes:
XSSFScatterChartData
@Beta
public interface ChartData

A base for all charts data types.

Author:
Roman Kashitsyn

Method Summary
 void fillChart(Chart chart, ChartAxis... axis)
Fills a charts with data specified by implementation.

Method Detail

fillChart

void fillChart(Chart chart,
               ChartAxis... axis)
Fills a charts with data specified by implementation.

Parameters:
chart - a charts to fill in
axis - charts axis to use
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartDataFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ChartDataFactory

All Known Implementing Classes:
XSSFChartDataFactory
@Beta
public interface ChartDataFactory

A factory for different charts data types.

Author:
Roman Kashitsyn

Method Summary
 ScatterChartData createScatterChartData()

Method Detail

createScatterChartData

ScatterChartData createScatterChartData()
Returns:
an appropriate ScatterChartData instance
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartDataSource

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ChartDataSource<T>

Type Parameters:
T - type of points the data source contents
@Beta
public interface ChartDataSource<T>

Represents data model of the charts.

Author:
Roman Kashitsyn

Method Summary
java.lang.String | getFormulaString() Returns formula representation of the data source.
T | getPointAt(int index) Returns point value at specified index.
int | getPointCount() Return number of points contained by data source.
boolean | isNumeric() Returns true if data source points should be treated as numbers.
boolean | isReference() Returns true if charts data source is valid cell range.

Method Detail

getPointCount

int getPointCount()
Return number of points contained by data source.

Returns:
number of points contained by data source

getPointAt

T getPointAt(int index)
Returns point value at specified index.

Parameters:
index - index to value from
Returns:
point value at specified index.
Throws:
{@code - IndexOutOfBoundsException} if index parameter not in range 0 <= index <= pointCount

isReference

boolean isReference()
Returns true if charts data source is valid cell range.

Returns:
true if charts data source is valid cell range

isNumeric

boolean isNumeric()
Returns true if data source points should be treated as numbers.

Returns:
true if data source points should be treated as numbers

getFormulaString

java.lang.String getFormulaString()
Returns formula representation of the data source. It is only applicable for data source that is valid cell range.

Returns:
formula representation of the data source
Throws:
{@code - UnsupportedOperationException} if the data source is not a reference.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChartLegend

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ChartLegend

All Superinterfaces:
ManuallyPositionable
All Known Implementing Classes:
XSSFChartLegend
@Beta
public interface ChartLegend
extends ManuallyPositionable

High level representation of chart legend.

Author:
Roman Kashitsyn

Method Summary
LegendPosition | getPosition()
void | setPosition(LegendPosition position)
Methods inherited from interface org.apache.poi.ss.usermodel.charts.ManuallyPositionable
getManualLayout

Method Detail

getPosition

LegendPosition getPosition()
Returns:
legend position

setPosition

void setPosition(LegendPosition position)
Parameters:
position - new legend position
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataSources

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Class DataSources

java.lang.Object
    extended by  org.apache.poi.ss.usermodel.charts.DataSources

@Beta
public class DataSources
extends java.lang.Object

Class DataSources is a factory for ChartDataSource instances.

Author:
Roman Kashitsyn

Method Summary
static
<T> ChartDataSource<T>
fromArray(T[] elements)
static ChartDataSource<java.lang.Number> fromNumericCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)
static ChartDataSource<java.lang.String> fromStringCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

fromArray

public static <T> ChartDataSource<T> fromArray(T[] elements)

fromNumericCellRange

public static ChartDataSource<java.lang.Number> fromNumericCellRange(Sheet sheet,
                                                                     CellRangeAddress cellRangeAddress)

fromStringCellRange

public static ChartDataSource<java.lang.String> fromStringCellRange(Sheet sheet,
                                                                    CellRangeAddress cellRangeAddress)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LayoutMode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel.charts
Enum LayoutMode

java.lang.Object
    extended by  java.lang.Enum<LayoutMode>
        extended by  org.apache.poi.ss.usermodel.charts.LayoutMode
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LayoutMode>
public enum LayoutMode
extends java.lang.Enum<LayoutMode>

Specifies the possible ways to store a chart element's position.

Author:
Roman Kashitsyn

Enum Constant Summary
EDGE
Specifies that the Width or Height shall be interpreted as the Right or Bottom of the chart element.
FACTOR
Specifies that the Width or Height shall be interpreted as the Width or Height of the chart element.
Method Summary
static LayoutMode | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LayoutMode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

EDGE

public static final LayoutMode EDGE
Specifies that the Width or Height shall be interpreted as the Right or Bottom of the chart element.

FACTOR

public static final LayoutMode FACTOR
Specifies that the Width or Height shall be interpreted as the Width or Height of the chart element.

Method Detail

values

public static LayoutMode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LayoutMode c : LayoutMode.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LayoutMode valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


LayoutTarget

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel.charts
Enum LayoutTarget

java.lang.Object
    extended by  java.lang.Enum<LayoutTarget>
        extended by  org.apache.poi.ss.usermodel.charts.LayoutTarget
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LayoutTarget>
public enum LayoutTarget
extends java.lang.Enum<LayoutTarget>

Specifies whether to layout the plot area by its inside (not including axis and axis labels) or outside (including axis and axis labels).

Author:
Roman Kashitsyn

Enum Constant Summary
INNER
Specifies that the plot area size shall determine the size of the plot area, not including the tick marks and axis labels.
OUTER
Specifies that the plot area size shall determine the size of the plot area, the tick marks, and the axis labels.
Method Summary
static LayoutTarget | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LayoutTarget[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

INNER

public static final LayoutTarget INNER
Specifies that the plot area size shall determine the size of the plot area, not including the tick marks and axis labels.

OUTER

public static final LayoutTarget OUTER
Specifies that the plot area size shall determine the size of the plot area, the tick marks, and the axis labels.

Method Detail

values

public static LayoutTarget[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LayoutTarget c : LayoutTarget.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LayoutTarget valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


LegendPosition

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.usermodel.charts
Enum LegendPosition

java.lang.Object
    extended by  java.lang.Enum<LegendPosition>
        extended by  org.apache.poi.ss.usermodel.charts.LegendPosition
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LegendPosition>
public enum LegendPosition
extends java.lang.Enum<LegendPosition>

Enumeration of all possible chart legend positions.

Author:
Roman Kashitsyn

Enum Constant Summary
BOTTOM
LEFT
RIGHT
TOP
TOP_RIGHT
Method Summary
static LegendPosition | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LegendPosition[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

BOTTOM

public static final LegendPosition BOTTOM

LEFT

public static final LegendPosition LEFT

RIGHT

public static final LegendPosition RIGHT

TOP

public static final LegendPosition TOP

TOP_RIGHT

public static final LegendPosition TOP_RIGHT
Method Detail

values

public static LegendPosition[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LegendPosition c : LegendPosition.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LegendPosition valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ManualLayout

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ManualLayout

All Known Implementing Classes:
XSSFManualLayout
@Beta
public interface ManualLayout

High level representation of chart element manual layout.

Author:
Roman Kashitsyn

Method Summary
LayoutMode | getHeightMode() Returns current height mode of this
double | getHeightRatio() Returns current fraction of the height of the chart.
LayoutTarget | getTarget() Returns current layout target.
LayoutMode | getWidthMode() Returns current width mode of this manual layout.
double | getWidthRatio() Returns current fraction of the width of the chart.
double | getX() Returns the x location of the chart element.
LayoutMode | getXMode() Returns current x-coordinnate layout mode.
double | getY() Returns current y location of the chart element.
LayoutMode | getYMode() Returns current y-coordinate layout mode.
void | setHeightMode(LayoutMode mode) Specifies how to interpret the Height element for this manual layout.
void | setHeightRatio(double ratio) Specifies the height (if Height Mode is Factor) or bottom (if Height Mode is edge) of the chart element as a fraction of the height of the chart.
void | setTarget(LayoutTarget target) Sets the layout target.
void | setWidthMode(LayoutMode mode) Specifies how to interpret the Width element for this manual layout.
void | setWidthRatio(double ratio) Specifies the width (if Width Mode is Factor) or right (if Width Mode is Edge) of the chart element as a fraction of the width of the chart.
void | setX(double x) Specifies the x location (left) of the chart element as a fraction of the width of the chart.
void | setXMode(LayoutMode mode) Sets the x-coordinate layout mode.
void | setY(double y) Specifies the y location (top) of the chart element as a fraction of the height of the chart.
void | setYMode(LayoutMode mode) Sets the y-coordinate layout mode.

Method Detail

setTarget

void setTarget(LayoutTarget target)
Sets the layout target.

Parameters:
target - new layout target.

getTarget

LayoutTarget getTarget()
Returns current layout target.

Returns:
current layout target

setXMode

void setXMode(LayoutMode mode)
Sets the x-coordinate layout mode.

Parameters:
mode - new x-coordinate layout mode.

getXMode

LayoutMode getXMode()
Returns current x-coordinnate layout mode.

Returns:
current x-coordinate layout mode.

setYMode

void setYMode(LayoutMode mode)
Sets the y-coordinate layout mode.

Parameters:
mode - new y-coordinate layout mode.

getYMode

LayoutMode getYMode()
Returns current y-coordinate layout mode.

Returns:
current y-coordinate layout mode.

getX

double getX()
Returns the x location of the chart element.

Returns:
the x location (left) of the chart element or 0.0 if not set.

setX

void setX(double x)
Specifies the x location (left) of the chart element as a fraction of the width of the chart. If Left Mode is Factor, then the position is relative to the default position for the chart element.

getY

double getY()
Returns current y location of the chart element.

Returns:
the y location (top) of the chart element or 0.0 if not set.

setY

void setY(double y)
Specifies the y location (top) of the chart element as a fraction of the height of the chart. If Top Mode is Factor, then the position is relative to the default position for the chart element.

setWidthMode

void setWidthMode(LayoutMode mode)
Specifies how to interpret the Width element for this manual layout.

Parameters:
mode - new width layout mode of this manual layout.

getWidthMode

LayoutMode getWidthMode()
Returns current width mode of this manual layout.

Returns:
width mode of this manual layout.

setHeightMode

void setHeightMode(LayoutMode mode)
Specifies how to interpret the Height element for this manual layout.

Parameters:
mode - new height mode of this manual layout.

getHeightMode

LayoutMode getHeightMode()
Returns current height mode of this

Returns:
height mode of this manual layout.

setWidthRatio

void setWidthRatio(double ratio)
Specifies the width (if Width Mode is Factor) or right (if Width Mode is Edge) of the chart element as a fraction of the width of the chart.

Parameters:
ratio - a fraction of the width of the chart.

getWidthRatio

double getWidthRatio()
Returns current fraction of the width of the chart.

Returns:
fraction of the width of the chart or 0.0 if not set.

setHeightRatio

void setHeightRatio(double ratio)
Specifies the height (if Height Mode is Factor) or bottom (if Height Mode is edge) of the chart element as a fraction of the height of the chart.

Parameters:
ratio - a fraction of the height of the chart.

getHeightRatio

double getHeightRatio()
Returns current fraction of the height of the chart.

Returns:
fraction of the height of the chart or 0.0 if not set.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManuallyPositionable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ManuallyPositionable

All Known Subinterfaces:
Chart, ChartLegend
All Known Implementing Classes:
XSSFChart, XSSFChartLegend
@Beta
public interface ManuallyPositionable

Abstraction of chart element that can be positioned with manual layout.

Author:
Roman Kashitsyn

Method Summary
 ManualLayout getManualLayout()
Returns manual layout for the chart element.

Method Detail

getManualLayout

ManualLayout getManualLayout()
Returns manual layout for the chart element.

Returns:
manual layout for the chart element.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.usermodel.charts
Interfaces
ChartAxis
ChartAxisFactory
ChartData
ChartDataFactory
ChartDataSource
ChartLegend
ManualLayout
ManuallyPositionable
ScatterChartData
ScatterChartSerie
ValueAxis
Classes
DataSources
Enums
AxisCrossBetween
AxisCrosses
AxisOrientation
AxisPosition
LayoutMode
LayoutTarget
LegendPosition


org.apache.poi.ss.usermodel.charts

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.usermodel.charts

Interface Summary
ChartAxis | High level representation of chart axis.
ChartAxisFactory | A factory for different chart axis.
ChartData | A base for all charts data types.
ChartDataFactory | A factory for different charts data types.
ChartDataSource<T> | Represents data model of the charts.
ChartLegend | High level representation of chart legend.
ManualLayout | High level representation of chart element manual layout.
ManuallyPositionable | Abstraction of chart element that can be positioned with manual layout.
ScatterChartData |
ScatterChartSerie | Represents scatter charts serie.
ValueAxis |

Class Summary
DataSources Class DataSources is a factory for ChartDataSource instances.

Enum Summary
AxisCrossBetween | Specifies the possible crossing states of an axis.
AxisCrosses | Specifies the possible crossing points for an axis.
AxisOrientation | Specifies the possible ways to place a picture on a data point, series, wall, or floor.
AxisPosition | Enumeration of all possible axis positions.
LayoutMode | Specifies the possible ways to store a chart element's position.
LayoutTarget | Specifies whether to layout the plot area by its inside (not including axis and axis labels) or outside (including axis and axis labels).
LegendPosition | Enumeration of all possible chart legend positions.


org.apache.poi.ss.usermodel.charts Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.usermodel.charts

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.usermodel.charts.DataSources

Interface Hierarchy

  • org.apache.poi.ss.usermodel.charts.ChartAxis
    • org.apache.poi.ss.usermodel.charts.ValueAxis
  • org.apache.poi.ss.usermodel.charts.ChartAxisFactory
  • org.apache.poi.ss.usermodel.charts.ChartData
    • org.apache.poi.ss.usermodel.charts.ScatterChartData
  • org.apache.poi.ss.usermodel.charts.ChartDataFactory
  • org.apache.poi.ss.usermodel.charts.ChartDataSource<T>
  • org.apache.poi.ss.usermodel.charts.ManualLayout
  • org.apache.poi.ss.usermodel.charts.ManuallyPositionable
    • org.apache.poi.ss.usermodel.charts.ChartLegend
  • org.apache.poi.ss.usermodel.charts.ScatterChartSerie

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.ss.usermodel.charts.LegendPosition
      • org.apache.poi.ss.usermodel.charts.LayoutTarget
      • org.apache.poi.ss.usermodel.charts.LayoutMode
      • org.apache.poi.ss.usermodel.charts.AxisPosition
      • org.apache.poi.ss.usermodel.charts.AxisOrientation
      • org.apache.poi.ss.usermodel.charts.AxisCrosses
      • org.apache.poi.ss.usermodel.charts.AxisCrossBetween


Uses of Package org.apache.poi.ss.usermodel.charts

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.usermodel.charts

Packages that use org.apache.poi.ss.usermodel.charts
org.apache.poi.ss.usermodel
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.ss.usermodel.charts used by org.apache.poi.ss.usermodel
ChartAxis
High level representation of chart axis.
ChartAxisFactory
A factory for different chart axis.
ChartData
A base for all charts data types.
ChartDataFactory
A factory for different charts data types.
ChartLegend
High level representation of chart legend.
ManuallyPositionable
Abstraction of chart element that can be positioned with manual layout.

Classes in org.apache.poi.ss.usermodel.charts used by org.apache.poi.ss.usermodel.charts
AxisCrossBetween
Specifies the possible crossing states of an axis.
AxisCrosses
Specifies the possible crossing points for an axis.
AxisOrientation
Specifies the possible ways to place a picture on a data point, series, wall, or floor.
AxisPosition
Enumeration of all possible axis positions.
ChartAxis
High level representation of chart axis.
ChartData
A base for all charts data types.
ChartDataSource
Represents data model of the charts.
LayoutMode
Specifies the possible ways to store a chart element's position.
LayoutTarget
Specifies whether to layout the plot area by its inside (not including axis and axis labels) or outside (including axis and axis labels).
LegendPosition
Enumeration of all possible chart legend positions.
ManualLayout
High level representation of chart element manual layout.
ManuallyPositionable
Abstraction of chart element that can be positioned with manual layout.
ScatterChartData
ScatterChartSerie
Represents scatter charts serie.
ValueAxis

Classes in org.apache.poi.ss.usermodel.charts used by org.apache.poi.xssf.usermodel
AxisPosition
Enumeration of all possible axis positions.
ChartAxis
High level representation of chart axis.
ChartAxisFactory
A factory for different chart axis.
ChartData
A base for all charts data types.
ManuallyPositionable
Abstraction of chart element that can be positioned with manual layout.

Classes in org.apache.poi.ss.usermodel.charts used by org.apache.poi.xssf.usermodel.charts
AxisCrossBetween
Specifies the possible crossing states of an axis.
AxisCrosses
Specifies the possible crossing points for an axis.
AxisOrientation
Specifies the possible ways to place a picture on a data point, series, wall, or floor.
AxisPosition
Enumeration of all possible axis positions.
ChartAxis
High level representation of chart axis.
ChartData
A base for all charts data types.
ChartDataFactory
A factory for different charts data types.
ChartDataSource
Represents data model of the charts.
ChartLegend
High level representation of chart legend.
LayoutMode
Specifies the possible ways to store a chart element's position.
LayoutTarget
Specifies whether to layout the plot area by its inside (not including axis and axis labels) or outside (including axis and axis labels).
LegendPosition
Enumeration of all possible chart legend positions.
ManualLayout
High level representation of chart element manual layout.
ManuallyPositionable
Abstraction of chart element that can be positioned with manual layout.
ScatterChartData
ScatterChartSerie
Represents scatter charts serie.
ValueAxis

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ScatterChartData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ScatterChartData

All Superinterfaces:
ChartData
All Known Implementing Classes:
XSSFScatterChartData
public interface ScatterChartData
extends ChartData

Author:
Roman Kashitsyn

Method Summary
ScatterChartSerie | addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)
java.util.List<? extends ScatterChartSerie> | getSeries()
Methods inherited from interface org.apache.poi.ss.usermodel.charts.ChartData
fillChart

Method Detail

addSerie

ScatterChartSerie addSerie(ChartDataSource<?> xs,
                           ChartDataSource<? extends java.lang.Number> ys)
Parameters:
xs - data source to be used for X axis values
ys - data source to be used for Y axis values
Returns:
a new scatter charts serie

getSeries

java.util.List<? extends ScatterChartSerie> getSeries()
Returns:
list of all series
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScatterChartSerie

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ScatterChartSerie

@Beta
public interface ScatterChartSerie

Represents scatter charts serie.

Author:
Roman Kashitsyn

Method Summary
ChartDataSource<?> | getXValues()
ChartDataSource<? extends java.lang.Number> | getYValues()

Method Detail

getXValues

ChartDataSource<?> getXValues()
Returns:
data source used for X axis values

getYValues

ChartDataSource<? extends java.lang.Number> getYValues()
Returns:
data source used for Y axis values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueAxis

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.usermodel.charts
Interface ValueAxis

All Superinterfaces:
ChartAxis
All Known Implementing Classes:
XSSFValueAxis
@Beta
public interface ValueAxis
extends ChartAxis

Author:
Roman Kashitsyn

Method Summary
AxisCrossBetween | getCrossBetween()
void | setCrossBetween(AxisCrossBetween crossBetween)
Methods inherited from interface org.apache.poi.ss.usermodel.charts.ChartAxis
crossAxis, getCrosses, getId, getLogBase, getMaximum, getMinimum, getNumberFormat, getOrientation, getPosition, isSetLogBase, isSetMaximum, isSetMinimum, setCrosses, setLogBase, setMaximum, setMinimum, setNumberFormat, setOrientation, setPosition

Method Detail

getCrossBetween

AxisCrossBetween getCrossBetween()
Returns:
cross between type

setCrossBetween

void setCrossBetween(AxisCrossBetween crossBetween)
Parameters:
crossBetween - cross between type
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.ss.usermodel.charts.AxisCrossBetween

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.AxisCrossBetween

Packages that use AxisCrossBetween
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of AxisCrossBetween in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return AxisCrossBetween
AxisCrossBetween | ValueAxis.getCrossBetween()
static AxisCrossBetween | AxisCrossBetween.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisCrossBetween[] | AxisCrossBetween.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.usermodel.charts with parameters of type AxisCrossBetween
 void ValueAxis.setCrossBetween(AxisCrossBetween crossBetween)

Uses of AxisCrossBetween in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return AxisCrossBetween
 AxisCrossBetween XSSFValueAxis.getCrossBetween()

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type AxisCrossBetween
 void XSSFValueAxis.setCrossBetween(AxisCrossBetween crossBetween)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.charts.AxisCrosses

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.AxisCrosses

Packages that use AxisCrosses
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of AxisCrosses in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return AxisCrosses
AxisCrosses | ChartAxis.getCrosses()
static AxisCrosses | AxisCrosses.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisCrosses[] | AxisCrosses.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.usermodel.charts with parameters of type AxisCrosses
 void ChartAxis.setCrosses(AxisCrosses crosses)

Uses of AxisCrosses in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return AxisCrosses
 AxisCrosses XSSFChartAxis.getCrosses()

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type AxisCrosses
 void XSSFChartAxis.setCrosses(AxisCrosses crosses)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.charts.AxisOrientation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.AxisOrientation

Packages that use AxisOrientation
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of AxisOrientation in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return AxisOrientation
AxisOrientation | ChartAxis.getOrientation()
static AxisOrientation | AxisOrientation.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisOrientation[] | AxisOrientation.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.usermodel.charts with parameters of type AxisOrientation
 void ChartAxis.setOrientation(AxisOrientation orientation)

Uses of AxisOrientation in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return AxisOrientation
 AxisOrientation XSSFChartAxis.getOrientation()

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type AxisOrientation
 void XSSFChartAxis.setOrientation(AxisOrientation orientation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.charts.AxisPosition

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.AxisPosition

Packages that use AxisPosition
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of AxisPosition in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return AxisPosition
AxisPosition | ChartAxis.getPosition()
static AxisPosition | AxisPosition.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static AxisPosition[] | AxisPosition.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.usermodel.charts with parameters of type AxisPosition
ValueAxis | ChartAxisFactory.createValueAxis(AxisPosition pos)
void | ChartAxis.setPosition(AxisPosition position)

Uses of AxisPosition in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type AxisPosition
 XSSFValueAxis XSSFChart.createValueAxis(AxisPosition pos)

Uses of AxisPosition in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return AxisPosition
 AxisPosition XSSFChartAxis.getPosition()

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type AxisPosition
 void XSSFChartAxis.setPosition(AxisPosition position)

Constructors in org.apache.poi.xssf.usermodel.charts with parameters of type AxisPosition
XSSFValueAxis(XSSFChart chart, long id, AxisPosition pos)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ChartAxis

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ChartAxis

Packages that use ChartAxis
org.apache.poi.ss.usermodel
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of ChartAxis in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return types with arguments of type ChartAxis
 java.util.List<? extends ChartAxis> Chart.getAxis()

Methods in org.apache.poi.ss.usermodel with parameters of type ChartAxis
 void Chart.plot(ChartData data, ChartAxis... axis)
Plots specified data on the chart.

Uses of ChartAxis in org.apache.poi.ss.usermodel.charts

Subinterfaces of ChartAxis in org.apache.poi.ss.usermodel.charts
 interface ValueAxis

Methods in org.apache.poi.ss.usermodel.charts with parameters of type ChartAxis
void | ChartAxis.crossAxis(ChartAxis axis) Declare this axis cross another axis.
void | ChartData.fillChart(Chart chart, ChartAxis... axis) Fills a charts with data specified by implementation.

Uses of ChartAxis in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type ChartAxis
 void XSSFChart.plot(ChartData data, ChartAxis... axis)

Uses of ChartAxis in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ChartAxis
class | XSSFChartAxis Base class for all axis types.
class | XSSFValueAxis Value axis type.

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type ChartAxis
void | XSSFValueAxis.crossAxis(ChartAxis axis)
void | XSSFScatterChartData.fillChart(Chart chart, ChartAxis... axis)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ChartAxisFactory

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ChartAxisFactory

Packages that use ChartAxisFactory
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of ChartAxisFactory in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return ChartAxisFactory
 ChartAxisFactory Chart.getChartAxisFactory()

Uses of ChartAxisFactory in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement ChartAxisFactory
 class XSSFChart
Represents a SpreadsheetML Chart

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ChartData

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ChartData

Packages that use ChartData
org.apache.poi.ss.usermodel
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of ChartData in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel with parameters of type ChartData
 void Chart.plot(ChartData data, ChartAxis... axis)
Plots specified data on the chart.

Uses of ChartData in org.apache.poi.ss.usermodel.charts

Subinterfaces of ChartData in org.apache.poi.ss.usermodel.charts
 interface ScatterChartData

Uses of ChartData in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type ChartData
 void XSSFChart.plot(ChartData data, ChartAxis... axis)

Uses of ChartData in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ChartData
 class XSSFScatterChartData
Represents DrawingML scatter charts.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ChartDataFactory

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ChartDataFactory

Packages that use ChartDataFactory
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of ChartDataFactory in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return ChartDataFactory
 ChartDataFactory Chart.getChartDataFactory()

Uses of ChartDataFactory in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ChartDataFactory
 class XSSFChartDataFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ChartDataSource

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ChartDataSource

Packages that use ChartDataSource
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of ChartDataSource in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return ChartDataSource
static
<T> ChartDataSource<T>
DataSources.fromArray(T[] elements)
static ChartDataSource<java.lang.Number> DataSources.fromNumericCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)
static ChartDataSource<java.lang.String> DataSources.fromStringCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)
 ChartDataSource<?> ScatterChartSerie.getXValues()
 ChartDataSource<? extends java.lang.Number> ScatterChartSerie.getYValues()

Methods in org.apache.poi.ss.usermodel.charts with parameters of type ChartDataSource
ScatterChartSerie | ScatterChartData.addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)
ScatterChartSerie | ScatterChartData.addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)

Uses of ChartDataSource in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type ChartDataSource
ScatterChartSerie | XSSFScatterChartData.addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)
ScatterChartSerie | XSSFScatterChartData.addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ChartLegend

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ChartLegend

Packages that use ChartLegend
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of ChartLegend in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return ChartLegend
 ChartLegend Chart.getOrCreateLegend()

Uses of ChartLegend in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ChartLegend
 class XSSFChartLegend
Represents a SpreadsheetML chart legend

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.charts.DataSources

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.DataSources

No usage of org.apache.poi.ss.usermodel.charts.DataSources

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.charts.LayoutMode

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.LayoutMode

Packages that use LayoutMode
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of LayoutMode in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return LayoutMode
LayoutMode | ManualLayout.getHeightMode() Returns current height mode of this
LayoutMode | ManualLayout.getWidthMode() Returns current width mode of this manual layout.
LayoutMode | ManualLayout.getXMode() Returns current x-coordinnate layout mode.
LayoutMode | ManualLayout.getYMode() Returns current y-coordinate layout mode.
static LayoutMode | LayoutMode.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LayoutMode[] | LayoutMode.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.usermodel.charts with parameters of type LayoutMode
void | ManualLayout.setHeightMode(LayoutMode mode) Specifies how to interpret the Height element for this manual layout.
void | ManualLayout.setWidthMode(LayoutMode mode) Specifies how to interpret the Width element for this manual layout.
void | ManualLayout.setXMode(LayoutMode mode) Sets the x-coordinate layout mode.
void | ManualLayout.setYMode(LayoutMode mode) Sets the y-coordinate layout mode.

Uses of LayoutMode in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return LayoutMode
LayoutMode | XSSFManualLayout.getHeightMode()
LayoutMode | XSSFManualLayout.getWidthMode()
LayoutMode | XSSFManualLayout.getXMode()
LayoutMode | XSSFManualLayout.getYMode()

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type LayoutMode
void | XSSFManualLayout.setHeightMode(LayoutMode mode)
void | XSSFManualLayout.setWidthMode(LayoutMode mode)
void | XSSFManualLayout.setXMode(LayoutMode mode)
void | XSSFManualLayout.setYMode(LayoutMode mode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.charts.LayoutTarget

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.LayoutTarget

Packages that use LayoutTarget
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of LayoutTarget in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return LayoutTarget
LayoutTarget | ManualLayout.getTarget() Returns current layout target.
static LayoutTarget | LayoutTarget.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LayoutTarget[] | LayoutTarget.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.usermodel.charts with parameters of type LayoutTarget
 void ManualLayout.setTarget(LayoutTarget target)
Sets the layout target.

Uses of LayoutTarget in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return LayoutTarget
 LayoutTarget XSSFManualLayout.getTarget()

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type LayoutTarget
 void XSSFManualLayout.setTarget(LayoutTarget target)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.charts.LegendPosition

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.charts.LegendPosition

Packages that use LegendPosition
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of LegendPosition in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return LegendPosition
LegendPosition | ChartLegend.getPosition()
static LegendPosition | LegendPosition.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LegendPosition[] | LegendPosition.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.ss.usermodel.charts with parameters of type LegendPosition
 void ChartLegend.setPosition(LegendPosition position)

Uses of LegendPosition in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return LegendPosition
 LegendPosition XSSFChartLegend.getPosition()

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type LegendPosition
 void XSSFChartLegend.setPosition(LegendPosition position)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ManualLayout

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ManualLayout

Packages that use ManualLayout
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of ManualLayout in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return ManualLayout
 ManualLayout ManuallyPositionable.getManualLayout()
Returns manual layout for the chart element.

Uses of ManualLayout in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ManualLayout
 class XSSFManualLayout
Represents a SpreadsheetML manual layout.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ManuallyPositionable

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ManuallyPositionable

Packages that use ManuallyPositionable
org.apache.poi.ss.usermodel
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of ManuallyPositionable in org.apache.poi.ss.usermodel

Subinterfaces of ManuallyPositionable in org.apache.poi.ss.usermodel
 interface Chart
High level representation of a chart.

Uses of ManuallyPositionable in org.apache.poi.ss.usermodel.charts

Subinterfaces of ManuallyPositionable in org.apache.poi.ss.usermodel.charts
 interface ChartLegend
High level representation of chart legend.

Uses of ManuallyPositionable in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement ManuallyPositionable
 class XSSFChart
Represents a SpreadsheetML Chart

Uses of ManuallyPositionable in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ManuallyPositionable
 class XSSFChartLegend
Represents a SpreadsheetML chart legend

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ScatterChartData

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ScatterChartData

Packages that use ScatterChartData
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of ScatterChartData in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return ScatterChartData
 ScatterChartData ChartDataFactory.createScatterChartData()

Uses of ScatterChartData in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ScatterChartData
 class XSSFScatterChartData
Represents DrawingML scatter charts.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ScatterChartSerie

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ScatterChartSerie

Packages that use ScatterChartSerie
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of ScatterChartSerie in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return ScatterChartSerie
 ScatterChartSerie ScatterChartData.addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)

Methods in org.apache.poi.ss.usermodel.charts that return types with arguments of type ScatterChartSerie
 java.util.List<? extends ScatterChartSerie> ScatterChartData.getSeries()

Uses of ScatterChartSerie in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return ScatterChartSerie
 ScatterChartSerie XSSFScatterChartData.addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.charts.ValueAxis

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.charts.ValueAxis

Packages that use ValueAxis
org.apache.poi.ss.usermodel.charts
org.apache.poi.xssf.usermodel.charts

Uses of ValueAxis in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts that return ValueAxis
 ValueAxis ChartAxisFactory.createValueAxis(AxisPosition pos)

Uses of ValueAxis in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts that implement ValueAxis
 class XSSFValueAxis
Value axis type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.AutoFilter

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.AutoFilter

Packages that use AutoFilter
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of AutoFilter in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement AutoFilter
 class HSSFAutoFilter
Represents autofiltering for the specified worksheet.

Uses of AutoFilter in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return AutoFilter
 AutoFilter Sheet.setAutoFilter(CellRangeAddress range)
Enable filtering for a range of cells

Uses of AutoFilter in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return AutoFilter
 AutoFilter SXSSFSheet.setAutoFilter(CellRangeAddress range)
Enable filtering for a range of cells

Uses of AutoFilter in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement AutoFilter
 class XSSFAutoFilter
Represents autofiltering for the specified worksheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.BorderFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.BorderFormatting

Packages that use BorderFormatting
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of BorderFormatting in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement BorderFormatting
 class HSSFBorderFormatting
High level representation for Border Formatting component of Conditional Formatting settings

Uses of BorderFormatting in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return BorderFormatting
BorderFormatting | ConditionalFormattingRule.createBorderFormatting() Create a new border formatting structure if it does not exist, otherwise just return existing object.
BorderFormatting | ConditionalFormattingRule.getBorderFormatting()

Uses of BorderFormatting in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement BorderFormatting
 class XSSFBorderFormatting

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.BorderStyle

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.BorderStyle

Packages that use BorderStyle
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions

Uses of BorderStyle in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return BorderStyle
static BorderStyle | BorderStyle.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BorderStyle[] | BorderStyle.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of BorderStyle in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return BorderStyle
BorderStyle | XSSFCellStyle.getBorderBottomEnum() Get the type of border to use for the bottom border of the cell
BorderStyle | XSSFCellStyle.getBorderLeftEnum() Get the type of border to use for the left border of the cell
BorderStyle | XSSFCellStyle.getBorderRightEnum() Get the type of border to use for the right border of the cell
BorderStyle | XSSFCellStyle.getBorderTopEnum() Get the type of border to use for the top border of the cell

Methods in org.apache.poi.xssf.usermodel with parameters of type BorderStyle
void | XSSFCellStyle.setBorderBottom(BorderStyle border) Set the type of border to use for the bottom border of the cell
void | XSSFCellStyle.setBorderLeft(BorderStyle border) Set the type of border to use for the left border of the cell
void | XSSFCellStyle.setBorderRight(BorderStyle border) Set the type of border to use for the right border of the cell
void | XSSFCellStyle.setBorderTop(BorderStyle border) Set the type of border to use for the top border of the cell

Uses of BorderStyle in org.apache.poi.xssf.usermodel.extensions

Methods in org.apache.poi.xssf.usermodel.extensions that return BorderStyle
 BorderStyle XSSFCellBorder.getBorderStyle(XSSFCellBorder.BorderSide side)
Get the type of border to use for the selected border

Methods in org.apache.poi.xssf.usermodel.extensions with parameters of type BorderStyle
 void XSSFCellBorder.setBorderStyle(XSSFCellBorder.BorderSide side, BorderStyle style)
Set the type of border to use for the selected border

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.BuiltinFormats

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.BuiltinFormats

No usage of org.apache.poi.ss.usermodel.BuiltinFormats

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Cell

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Cell

Packages that use Cell
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.format | This package contains classes that implement cell formatting
org.apache.poi.ss.usermodel |
org.apache.poi.ss.util |
org.apache.poi.ss.util.cellwalk |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Cell in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Cell
 class HSSFCell
High level representation of a cell in a row of a spreadsheet.

Methods in org.apache.poi.hssf.usermodel that return types with arguments of type Cell
 java.util.Iterator<Cell> HSSFRow.cellIterator()

Methods in org.apache.poi.hssf.usermodel with parameters of type Cell
CellValue | HSSFFormulaEvaluator.evaluate(Cell cell) If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
int | HSSFFormulaEvaluator.evaluateFormulaCell(Cell cell) If cell contains formula, it evaluates the formula, and saves the result of the formula.
HSSFCell | HSSFFormulaEvaluator.evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
void | HSSFFormulaEvaluator.notifyDeleteCell(Cell cell)
void | HSSFFormulaEvaluator.notifySetFormula(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
void | HSSFFormulaEvaluator.notifyUpdateCell(Cell cell)
CellRange<HSSFCell> | HSSFSheet.removeArrayFormula(Cell cell)
void | HSSFRow.removeCell(Cell cell) remove the HSSFCell from this row.

Uses of Cell in org.apache.poi.ss.format

Methods in org.apache.poi.ss.format with parameters of type Cell
CellFormatResult | CellFormat.apply(Cell c) Fetches the appropriate value from the cell, and returns the result of applying it to the appropriate format.
CellFormatResult | CellFormat.apply(javax.swing.JLabel label, Cell c) Fetches the appropriate value from the cell, and uses the result, setting the text and color of a label before returning the result.
static int | CellFormat.ultimateType(Cell cell) Returns the ultimate cell type, following the results of formulas.

Uses of Cell in org.apache.poi.ss.usermodel

Classes in org.apache.poi.ss.usermodel with type parameters of type Cell
 interface CellRange<C extends Cell>
Represents a rectangular region of a Sheet

Methods in org.apache.poi.ss.usermodel that return Cell
Cell | Row.createCell(int column) Use this to create new cells within the row and return it.
Cell | Row.createCell(int column, int type) Use this to create new cells within the row and return it.
Cell | FormulaEvaluator.evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
Cell | Row.getCell(int cellnum) Get the cell representing a given column (logical cell) 0-based.
Cell | Row.getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
C[][] | CellRange.getCells()
C[] | CellRange.getFlattenedCells()

Methods in org.apache.poi.ss.usermodel that return types with arguments of type Cell
java.util.Iterator<Cell> | Row.cellIterator()
CellRange<? extends Cell> | Sheet.removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
CellRange<? extends Cell> | Sheet.setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.

Methods in org.apache.poi.ss.usermodel with parameters of type Cell
java.text.Format | DataFormatter.createFormat(Cell cell) Create and return a Format based on the format string from a cell's style.
CellValue | FormulaEvaluator.evaluate(Cell cell) If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
int | FormulaEvaluator.evaluateFormulaCell(Cell cell) If cell contains formula, it evaluates the formula, and saves the result of the formula.
Cell | FormulaEvaluator.evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
java.lang.String | DataFormatter.formatCellValue(Cell cell) Returns the formatted value of a cell as a String regardless of the cell type.
java.lang.String | DataFormatter.formatCellValue(Cell cell, FormulaEvaluator evaluator) Returns the formatted value of a cell as a String regardless of the cell type.
java.text.Format | DataFormatter.getDefaultFormat(Cell cell) Returns a default format for a cell.
static boolean | DateUtil.isCellDateFormatted(Cell cell) Check if a cell contains a date Since dates are stored internally in Excel as double values we infer it is a date if it is formatted as such.
static boolean | DateUtil.isCellInternalDateFormatted(Cell cell) Check if a cell contains a date, checking only for internal excel date formats.
void | FormulaEvaluator.notifyDeleteCell(Cell cell) Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed
void | FormulaEvaluator.notifySetFormula(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
void | FormulaEvaluator.notifyUpdateCell(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
CellRange<? extends Cell> | Sheet.removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
void | Row.removeCell(Cell cell) Remove the Cell from this row.

Uses of Cell in org.apache.poi.ss.util

Classes in org.apache.poi.ss.util with type parameters of type Cell
 class SSCellRange<K extends Cell>
For POI internal use only

Methods in org.apache.poi.ss.util with type parameters of type Cell
static
<B extends Cell>
SSCellRange<B>
SSCellRange.create(int firstRow, int firstColumn, int height, int width, java.util.List<B> flattenedList, java.lang.Class<B> cellClass)

Methods in org.apache.poi.ss.util that return Cell
static Cell | CellUtil.createCell(Row row, int column, java.lang.String value) Create a cell, and give it a value.
static Cell | CellUtil.createCell(Row row, int column, java.lang.String value, CellStyle style) Creates a cell, gives it a value, and applies a style if provided
static Cell | CellUtil.getCell(Row row, int columnIndex) Get a specific cell from a row.
K[][] | SSCellRange.getCells()
K[] | SSCellRange.getFlattenedCells()
static Cell | CellUtil.translateUnicodeValues(Cell cell) Looks for text in the cell that should be unicode, like α and provides the unicode version of it.

Methods in org.apache.poi.ss.util with parameters of type Cell
static double | SheetUtil.getCellWidth(Cell cell, int defaultCharWidth, DataFormatter formatter, boolean useMergedCells) Compute width of a single cell
static void | CellUtil.setAlignment(Cell cell, Workbook workbook, short align) Take a cell, and align it.
static void | CellUtil.setCellStyleProperty(Cell cell, Workbook workbook, java.lang.String propertyName, java.lang.Object propertyValue) This method attempt to find an already existing CellStyle that matches what you want the style to be.
static void | CellUtil.setFont(Cell cell, Workbook workbook, Font font) Take a cell, and apply a font to it
static Cell | CellUtil.translateUnicodeValues(Cell cell) Looks for text in the cell that should be unicode, like α and provides the unicode version of it.

Constructors in org.apache.poi.ss.util with parameters of type Cell
CellReference(Cell cell)

Uses of Cell in org.apache.poi.ss.util.cellwalk

Methods in org.apache.poi.ss.util.cellwalk with parameters of type Cell
 void CellHandler.onCell(Cell cell, CellWalkContext ctx)

Uses of Cell in org.apache.poi.xssf.streaming

Classes in org.apache.poi.xssf.streaming that implement Cell
 class SXSSFCell
Streaming version of XSSFRow implementing the "BigGridDemo" strategy.

Methods in org.apache.poi.xssf.streaming that return Cell
Cell | SXSSFRow.createCell(int column) Use this to create new cells within the row and return it.
Cell | SXSSFRow.createCell(int column, int type) Use this to create new cells within the row and return it.
Cell | SXSSFRow.getCell(int cellnum) Get the cell representing a given column (logical cell) 0-based.
Cell | SXSSFRow.getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
Cell | SXSSFRow.FilledCellIterator.next()
Cell | SXSSFRow.CellIterator.next()

Methods in org.apache.poi.xssf.streaming that return types with arguments of type Cell
java.util.Iterator<Cell> | SXSSFRow.allCellsIterator()
java.util.Iterator<Cell> | SXSSFRow.cellIterator()
java.util.Iterator<Cell> | SXSSFRow.iterator()
CellRange<? extends Cell> | SXSSFSheet.removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
CellRange<? extends Cell> | SXSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.

Methods in org.apache.poi.xssf.streaming with parameters of type Cell
CellRange<? extends Cell> | SXSSFSheet.removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
void | SXSSFRow.removeCell(Cell cell) Remove the Cell from this row.
void | SheetDataWriter.writeCell(int columnIndex, Cell cell)

Uses of Cell in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Cell
 class XSSFCell
High level representation of a cell in a row of a spreadsheet.

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type Cell
 java.util.Iterator<Cell> XSSFRow.cellIterator()
Cell iterator over the physically defined cells:
 java.util.Iterator<Cell> XSSFRow.iterator()
Alias for XSSFRow.cellIterator() to allow foreach loops:

Methods in org.apache.poi.xssf.usermodel with parameters of type Cell
CellValue | XSSFFormulaEvaluator.evaluate(Cell cell) If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
int | XSSFFormulaEvaluator.evaluateFormulaCell(Cell cell) If cell contains formula, it evaluates the formula, and saves the result of the formula.
XSSFCell | XSSFFormulaEvaluator.evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
void | XSSFFormulaEvaluator.notifyDeleteCell(Cell cell)
void | XSSFFormulaEvaluator.notifySetFormula(Cell cell)
void | XSSFFormulaEvaluator.notifyUpdateCell(Cell cell)
CellRange<XSSFCell> | XSSFSheet.removeArrayFormula(Cell cell)
void | XSSFRow.removeCell(Cell cell) Remove the Cell from this row.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.CellRange

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.CellRange

Packages that use CellRange
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.ss.util |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of CellRange in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return CellRange
CellRange<HSSFCell> | HSSFSheet.removeArrayFormula(Cell cell)
CellRange<HSSFCell> | HSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range)

Uses of CellRange in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return CellRange
CellRange<? extends Cell> | Sheet.removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
CellRange<? extends Cell> | Sheet.setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.

Uses of CellRange in org.apache.poi.ss.util

Classes in org.apache.poi.ss.util that implement CellRange
 class SSCellRange<K extends Cell>
For POI internal use only

Uses of CellRange in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return CellRange
CellRange<? extends Cell> | SXSSFSheet.removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
CellRange<? extends Cell> | SXSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.

Uses of CellRange in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return CellRange
CellRange<XSSFCell> | XSSFSheet.removeArrayFormula(Cell cell)
CellRange<XSSFCell> | XSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.CellStyle

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.CellStyle

Packages that use CellStyle
org.apache.poi.hssf.converter |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.ss.util |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.helpers |

Uses of CellStyle in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter with parameters of type CellStyle
protected  boolean ExcelToFoConverter.isEmptyStyle(CellStyle cellStyle)
Returns false if cell style by itself (without text, i.e.

Uses of CellStyle in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement CellStyle
 class HSSFCellStyle
High level representation of the style of a cell in a sheet of a workbook.

Methods in org.apache.poi.hssf.usermodel with parameters of type CellStyle
void | HSSFCellStyle.cloneStyleFrom(CellStyle source) Clones all the style information from another HSSFCellStyle, onto this one.
void | HSSFCell.setCellStyle(CellStyle style) set the style for the cell.
void | HSSFSheet.setDefaultColumnStyle(int column, CellStyle style) Sets the default column style for a given column.
void | HSSFRow.setRowStyle(CellStyle style) Applies a whole-row cell styling to the row.

Uses of CellStyle in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return CellStyle
CellStyle | Workbook.createCellStyle() Create a new Cell style and add it to the workbook's style table
CellStyle | Cell.getCellStyle() Return the cell's style.
CellStyle | Workbook.getCellStyleAt(short idx) Get the cell style object at the given index
CellStyle | Sheet.getColumnStyle(int column) Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
CellStyle | Row.getRowStyle() Returns the whole-row cell styles.

Methods in org.apache.poi.ss.usermodel with parameters of type CellStyle
void | CellStyle.cloneStyleFrom(CellStyle source) Clones all the style information from another CellStyle, onto this one.
void | Cell.setCellStyle(CellStyle style) Set the style for the cell.
void | Sheet.setDefaultColumnStyle(int column, CellStyle style) Sets the default column style for a given column.
void | Row.setRowStyle(CellStyle style) Applies a whole-row cell styling to the row.

Uses of CellStyle in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util with parameters of type CellStyle
static Cell CellUtil.createCell(Row row, int column, java.lang.String value, CellStyle style)
Creates a cell, gives it a value, and applies a style if provided

Uses of CellStyle in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return CellStyle
CellStyle | SXSSFWorkbook.createCellStyle() Create a new Cell style and add it to the workbook's style table
CellStyle | SXSSFCell.getCellStyle() Return the cell's style.
CellStyle | SXSSFWorkbook.getCellStyleAt(short idx) Get the cell style object at the given index
CellStyle | SXSSFSheet.getColumnStyle(int column) Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
CellStyle | SXSSFRow.getRowStyle() Returns the whole-row cell style.

Methods in org.apache.poi.xssf.streaming with parameters of type CellStyle
void | SXSSFCell.setCellStyle(CellStyle style) Set the style for the cell.
void | SXSSFSheet.setDefaultColumnStyle(int column, CellStyle style) Sets the default column style for a given column.
void | SXSSFRow.setRowStyle(CellStyle style) Applies a whole-row cell styling to the row.

Uses of CellStyle in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement CellStyle
 class XSSFCellStyle
High level representation of the the possible formatting information for the contents of the cells on a sheet in a SpreadsheetML document.

Methods in org.apache.poi.xssf.usermodel that return CellStyle
 CellStyle XSSFSheet.getColumnStyle(int column)
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column

Methods in org.apache.poi.xssf.usermodel with parameters of type CellStyle
void | XSSFCellStyle.cloneStyleFrom(CellStyle source) Clones all the style information from another XSSFCellStyle, onto this one.
void | XSSFCell.setCellStyle(CellStyle style) Set the style for the cell.
void | XSSFSheet.setDefaultColumnStyle(int column, CellStyle style)
void | XSSFRow.setRowStyle(CellStyle style) Applies a whole-row cell styling to the row.

Uses of CellStyle in org.apache.poi.xssf.usermodel.helpers

Methods in org.apache.poi.xssf.usermodel.helpers with parameters of type CellStyle
 void ColumnHelper.setColDefaultStyle(long index, CellStyle style)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.CellValue

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.CellValue

Packages that use CellValue
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of CellValue in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return CellValue
 CellValue HSSFFormulaEvaluator.evaluate(Cell cell)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.

Uses of CellValue in org.apache.poi.ss.usermodel

Fields in org.apache.poi.ss.usermodel declared as CellValue
static CellValue | CellValue.FALSE
static CellValue | CellValue.TRUE

Methods in org.apache.poi.ss.usermodel that return CellValue
CellValue | FormulaEvaluator.evaluate(Cell cell) If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
static CellValue | CellValue.getError(int errorCode)
static CellValue | CellValue.valueOf(boolean booleanValue)

Uses of CellValue in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return CellValue
 CellValue XSSFFormulaEvaluator.evaluate(Cell cell)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Chart

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Chart

Packages that use Chart
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.ss.usermodel.charts |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.charts |

Uses of Chart in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return Chart
 Chart HSSFPatriarch.createChart(ClientAnchor anchor)

Uses of Chart in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Chart
 Chart Drawing.createChart(ClientAnchor anchor)
Creates a chart.

Uses of Chart in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts with parameters of type Chart
 void ChartData.fillChart(Chart chart, ChartAxis... axis)
Fills a charts with data specified by implementation.

Uses of Chart in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Chart
 class XSSFChart
Represents a SpreadsheetML Chart

Uses of Chart in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts with parameters of type Chart
 void XSSFScatterChartData.fillChart(Chart chart, ChartAxis... axis)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.ClientAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.ClientAnchor

Packages that use ClientAnchor
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of ClientAnchor in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement ClientAnchor
 class HSSFClientAnchor
A client anchor is attached to an excel worksheet.

Methods in org.apache.poi.hssf.usermodel with parameters of type ClientAnchor
HSSFComment | HSSFPatriarch.createCellComment(ClientAnchor anchor)
Chart | HSSFPatriarch.createChart(ClientAnchor anchor)
HSSFPicture | HSSFPatriarch.createPicture(ClientAnchor anchor, int pictureIndex)

Uses of ClientAnchor in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return ClientAnchor
ClientAnchor | Drawing.createAnchor(int dx1, int dy1, int dx2, int dy2, int col1, int row1, int col2, int row2) Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
ClientAnchor | CreationHelper.createClientAnchor()
ClientAnchor | Picture.getPreferredSize()

Methods in org.apache.poi.ss.usermodel with parameters of type ClientAnchor
Comment | Drawing.createCellComment(ClientAnchor anchor) Creates a comment.
Chart | Drawing.createChart(ClientAnchor anchor) Creates a chart.
Picture | Drawing.createPicture(ClientAnchor anchor, int pictureIndex) Creates a picture.

Uses of ClientAnchor in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement ClientAnchor
 class XSSFClientAnchor
A client anchor is attached to an excel worksheet.

Methods in org.apache.poi.xssf.usermodel with parameters of type ClientAnchor
XSSFComment | XSSFDrawing.createCellComment(ClientAnchor anchor) Creates a comment.
XSSFChart | XSSFDrawing.createChart(ClientAnchor anchor)
XSSFPicture | XSSFDrawing.createPicture(ClientAnchor anchor, int pictureIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Color

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Color

Packages that use Color
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of Color in org.apache.poi.hssf.util

Classes in org.apache.poi.hssf.util that implement Color
class | HSSFColor Intends to provide support for the very evil index to triplet issue and will likely replace the color constants interface for HSSF 2.0.
static class | HSSFColor.AQUA Class AQUA
static class | HSSFColor.AUTOMATIC Special Default/Normal/Automatic color.
static class | HSSFColor.BLACK Class BLACK
static class | HSSFColor.BLUE Class BLUE
static class | HSSFColor.BLUE_GREY Class BLUE_GREY
static class | HSSFColor.BRIGHT_GREEN Class BRIGHT_GREEN
static class | HSSFColor.BROWN Class BROWN
static class | HSSFColor.CORAL Class CORAL
static class | HSSFColor.CORNFLOWER_BLUE Class CORNFLOWER_BLUE
static class | HSSFColor.DARK_BLUE Class DARK_BLUE
static class | HSSFColor.DARK_GREEN Class DARK_GREEN
static class | HSSFColor.DARK_RED Class DARK_RED
static class | HSSFColor.DARK_TEAL Class DARK_TEAL
static class | HSSFColor.DARK_YELLOW Class DARK_YELLOW
static class | HSSFColor.GOLD Class GOLD
static class | HSSFColor.GREEN Class GREEN
static class | HSSFColor.GREY_25_PERCENT Class GREY_25_PERCENT
static class | HSSFColor.GREY_40_PERCENT Class GREY_40_PERCENT
static class | HSSFColor.GREY_50_PERCENT Class GREY_50_PERCENT
static class | HSSFColor.GREY_80_PERCENT Class GREY_80_PERCENT
static class | HSSFColor.INDIGO Class INDIGO
static class | HSSFColor.LAVENDER Class LAVENDER
static class | HSSFColor.LEMON_CHIFFON Class LEMON_CHIFFON
static class | HSSFColor.LIGHT_BLUE Class LIGHT_BLUE
static class | HSSFColor.LIGHT_CORNFLOWER_BLUE Class LIGHT_CORNFLOWER_BLUE
static class | HSSFColor.LIGHT_GREEN Class LIGHT_GREEN
static class | HSSFColor.LIGHT_ORANGE Class LIGHT_ORANGE
static class | HSSFColor.LIGHT_TURQUOISE Class LIGHT_TURQUOISE
static class | HSSFColor.LIGHT_YELLOW Class LIGHT_YELLOW
static class | HSSFColor.LIME Class LIME
static class | HSSFColor.MAROON Class MAROON
static class | HSSFColor.OLIVE_GREEN Class OLIVE_GREEN
static class | HSSFColor.ORANGE Class ORANGE
static class | HSSFColor.ORCHID Class ORCHID
static class | HSSFColor.PALE_BLUE Class PALE_BLUE
static class | HSSFColor.PINK Class PINK
static class | HSSFColor.PLUM Class PLUM
static class | HSSFColor.RED Class RED
static class | HSSFColor.ROSE Class ROSE
static class | HSSFColor.ROYAL_BLUE Class ROYAL_BLUE
static class | HSSFColor.SEA_GREEN Class SEA_GREEN
static class | HSSFColor.SKY_BLUE Class SKY_BLUE
static class | HSSFColor.TAN Class TAN
static class | HSSFColor.TEAL Class TEAL
static class | HSSFColor.TURQUOISE Class TURQUOISE
static class | HSSFColor.VIOLET Class VIOLET
static class | HSSFColor.WHITE Class WHITE
static class | HSSFColor.YELLOW Class YELLOW

Uses of Color in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Color
Color | CellStyle.getFillBackgroundColorColor() Gets the color object representing the current background fill, resolving indexes using the supplied workbook.
Color | CellStyle.getFillForegroundColorColor() Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook.

Uses of Color in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Color
 class XSSFColor
Represents a color in SpreadsheetML

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Comment

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Comment

Packages that use Comment
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Comment in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Comment
 class HSSFComment
Represents a cell comment - a sticky note associated with a cell.

Methods in org.apache.poi.hssf.usermodel with parameters of type Comment
 void HSSFCell.setCellComment(Comment comment)
Assign a comment to this cell.

Uses of Comment in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Comment
Comment | Drawing.createCellComment(ClientAnchor anchor) Creates a comment.
Comment | Cell.getCellComment() Returns comment associated with this cell
Comment | Sheet.getCellComment(int row, int column) Returns cell comment for the specified row and column

Methods in org.apache.poi.ss.usermodel with parameters of type Comment
 void Cell.setCellComment(Comment comment)
Assign a comment to this cell

Uses of Comment in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Comment
Comment | SXSSFCell.getCellComment() Returns comment associated with this cell
Comment | SXSSFSheet.getCellComment(int row, int column) Returns cell comment for the specified row and column

Methods in org.apache.poi.xssf.streaming with parameters of type Comment
 void SXSSFCell.setCellComment(Comment comment)
Assign a comment to this cell

Uses of Comment in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Comment
 class XSSFComment

Methods in org.apache.poi.xssf.usermodel with parameters of type Comment
 void XSSFCell.setCellComment(Comment comment)
Assign a comment to this cell.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.ComparisonOperator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.ComparisonOperator

No usage of org.apache.poi.ss.usermodel.ComparisonOperator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.ConditionalFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.ConditionalFormatting

Packages that use ConditionalFormatting
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of ConditionalFormatting in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement ConditionalFormatting
 class HSSFConditionalFormatting
HSSFConditionalFormatting class encapsulates all settings of Conditional Formatting.

Methods in org.apache.poi.hssf.usermodel with parameters of type ConditionalFormatting
 int HSSFSheetConditionalFormatting.addConditionalFormatting(ConditionalFormatting cf)

Uses of ConditionalFormatting in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return ConditionalFormatting
 ConditionalFormatting SheetConditionalFormatting.getConditionalFormattingAt(int index)
Gets Conditional Formatting object at a particular index

Methods in org.apache.poi.ss.usermodel with parameters of type ConditionalFormatting
 int SheetConditionalFormatting.addConditionalFormatting(ConditionalFormatting cf)
Adds a copy of a ConditionalFormatting object to the sheet

Uses of ConditionalFormatting in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement ConditionalFormatting
 class XSSFConditionalFormatting

Methods in org.apache.poi.xssf.usermodel with parameters of type ConditionalFormatting
 int XSSFSheetConditionalFormatting.addConditionalFormatting(ConditionalFormatting cf)
Adds a copy of HSSFConditionalFormatting object to the sheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.ConditionalFormattingRule

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.ConditionalFormattingRule

Packages that use ConditionalFormattingRule
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of ConditionalFormattingRule in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement ConditionalFormattingRule
 class HSSFConditionalFormattingRule
High level representation of Conditional Formatting Rule.

Methods in org.apache.poi.hssf.usermodel with parameters of type ConditionalFormattingRule
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2)
void | HSSFConditionalFormatting.addRule(ConditionalFormattingRule cfRule)
void | HSSFConditionalFormatting.setRule(int idx, ConditionalFormattingRule cfRule)

Uses of ConditionalFormattingRule in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return ConditionalFormattingRule
ConditionalFormattingRule | SheetConditionalFormatting.createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula) Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *
ConditionalFormattingRule | SheetConditionalFormatting.createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1, java.lang.String formula2) A factory method allowing to create a conditional formatting rule with a cell comparison operator
ConditionalFormattingRule | SheetConditionalFormatting.createConditionalFormattingRule(java.lang.String formula) Create a conditional formatting rule based on a Boolean formula.
ConditionalFormattingRule | ConditionalFormatting.getRule(int idx)

Methods in org.apache.poi.ss.usermodel with parameters of type ConditionalFormattingRule
int | SheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule) Add a new Conditional Formatting to the sheet.
int | SheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules) Add a new Conditional Formatting set to the sheet.
int | SheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2) Add a new Conditional Formatting consisting of two rules.
void | ConditionalFormatting.addRule(ConditionalFormattingRule cfRule) Add a Conditional Formatting rule.
void | ConditionalFormatting.setRule(int idx, ConditionalFormattingRule cfRule) Replaces an existing Conditional Formatting rule at position idx.

Uses of ConditionalFormattingRule in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement ConditionalFormattingRule
 class XSSFConditionalFormattingRule

Methods in org.apache.poi.xssf.usermodel with parameters of type ConditionalFormattingRule
int | XSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1)
int | XSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules)
int | XSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2)
void | XSSFConditionalFormatting.addRule(ConditionalFormattingRule cfRule) Add a Conditional Formatting rule.
void | XSSFConditionalFormatting.setRule(int idx, ConditionalFormattingRule cfRule) Replaces an existing Conditional Formatting rule at position idx.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.CreationHelper

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.CreationHelper

Packages that use CreationHelper
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of CreationHelper in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement CreationHelper
 class HSSFCreationHelper

Uses of CreationHelper in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return CreationHelper
 CreationHelper Workbook.getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.

Uses of CreationHelper in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return CreationHelper
 CreationHelper SXSSFWorkbook.getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.

Uses of CreationHelper in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement CreationHelper
 class XSSFCreationHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.DataFormat

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.DataFormat

Packages that use DataFormat
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of DataFormat in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement DataFormat
 class HSSFDataFormat
Identifies both built-in and user defined formats within a workbook.

See BuiltinFormats for a list of supported built-in formats.

International Formats
Since version 2003 Excel has supported international formats.

Uses of DataFormat in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return DataFormat
DataFormat | Workbook.createDataFormat() Returns the instance of DataFormat for this workbook.
DataFormat | CreationHelper.createDataFormat() Creates a new DataFormat instance

Uses of DataFormat in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return DataFormat
 DataFormat SXSSFWorkbook.createDataFormat()
Returns the instance of DataFormat for this workbook.

Uses of DataFormat in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement DataFormat
 class XSSFDataFormat
Handles data formats for XSSF.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.DataFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.DataFormatter

Packages that use DataFormatter
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula.functions |
org.apache.poi.ss.util |
org.apache.poi.xssf.eventusermodel |

Uses of DataFormatter in org.apache.poi.hssf.usermodel

Subclasses of DataFormatter in org.apache.poi.hssf.usermodel
 class HSSFDataFormatter
HSSFDataFormatter contains methods for formatting the value stored in an HSSFCell.

Uses of DataFormatter in org.apache.poi.ss.formula.functions

Fields in org.apache.poi.ss.formula.functions declared as DataFormatter
protected static DataFormatter TextFunction.formatter

Uses of DataFormatter in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util with parameters of type DataFormatter
static double SheetUtil.getCellWidth(Cell cell, int defaultCharWidth, DataFormatter formatter, boolean useMergedCells)
Compute width of a single cell

Uses of DataFormatter in org.apache.poi.xssf.eventusermodel

Constructors in org.apache.poi.xssf.eventusermodel with parameters of type DataFormatter
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, DataFormatter dataFormatter, boolean formulasNotResults)
Accepts objects needed while parsing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.DataValidation.ErrorStyle

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.DataValidation.ErrorStyle

No usage of org.apache.poi.ss.usermodel.DataValidation.ErrorStyle

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.DataValidation

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.DataValidation

Packages that use DataValidation
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of DataValidation in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement DataValidation
 class HSSFDataValidation
Utility class for creating data validation cells

Methods in org.apache.poi.hssf.usermodel that return DataValidation
 DataValidation HSSFDataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Methods in org.apache.poi.hssf.usermodel with parameters of type DataValidation
 void HSSFSheet.addValidationData(DataValidation dataValidation)
Creates a data validation object

Uses of DataValidation in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return DataValidation
 DataValidation DataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Methods in org.apache.poi.ss.usermodel with parameters of type DataValidation
 void Sheet.addValidationData(DataValidation dataValidation)
Creates a data validation object

Uses of DataValidation in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming with parameters of type DataValidation
 void SXSSFSheet.addValidationData(DataValidation dataValidation)
Creates a data validation object

Uses of DataValidation in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement DataValidation
 class XSSFDataValidation

Methods in org.apache.poi.xssf.usermodel that return DataValidation
 DataValidation XSSFDataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Methods in org.apache.poi.xssf.usermodel with parameters of type DataValidation
 void XSSFSheet.addValidationData(DataValidation dataValidation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.DataValidationConstraint

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.DataValidationConstraint

Packages that use DataValidationConstraint
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of DataValidationConstraint in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement DataValidationConstraint
 class DVConstraint

Methods in org.apache.poi.hssf.usermodel that return DataValidationConstraint
DataValidationConstraint | HSSFDataValidationHelper.createCustomConstraint(java.lang.String formula)
DataValidationConstraint | HSSFDataValidationHelper.createDateConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2, java.lang.String dateFormat)
DataValidationConstraint | HSSFDataValidationHelper.createDecimalConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | HSSFDataValidationHelper.createExplicitListConstraint(java.lang.String[] listOfValues)
DataValidationConstraint | HSSFDataValidationHelper.createFormulaListConstraint(java.lang.String listFormula)
DataValidationConstraint | HSSFDataValidationHelper.createIntegerConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | HSSFDataValidationHelper.createNumericConstraint(int validationType, int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | HSSFDataValidationHelper.createTextLengthConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | HSSFDataValidationHelper.createTimeConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | HSSFDataValidation.getValidationConstraint()

Methods in org.apache.poi.hssf.usermodel with parameters of type DataValidationConstraint
 DataValidation HSSFDataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Constructors in org.apache.poi.hssf.usermodel with parameters of type DataValidationConstraint
HSSFDataValidation(CellRangeAddressList regions, DataValidationConstraint constraint)
Constructor which initializes the cell range on which this object will be applied

Uses of DataValidationConstraint in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return DataValidationConstraint
DataValidationConstraint | DataValidationHelper.createCustomConstraint(java.lang.String formula)
DataValidationConstraint | DataValidationHelper.createDateConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2, java.lang.String dateFormat)
DataValidationConstraint | DataValidationHelper.createDecimalConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | DataValidationHelper.createExplicitListConstraint(java.lang.String[] listOfValues)
DataValidationConstraint | DataValidationHelper.createFormulaListConstraint(java.lang.String listFormula)
DataValidationConstraint | DataValidationHelper.createIntegerConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | DataValidationHelper.createNumericConstraint(int validationType, int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | DataValidationHelper.createTextLengthConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | DataValidationHelper.createTimeConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | DataValidation.getValidationConstraint()

Methods in org.apache.poi.ss.usermodel with parameters of type DataValidationConstraint
 DataValidation DataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Uses of DataValidationConstraint in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement DataValidationConstraint
 class XSSFDataValidationConstraint

Methods in org.apache.poi.xssf.usermodel that return DataValidationConstraint
DataValidationConstraint | XSSFDataValidationHelper.createCustomConstraint(java.lang.String formula)
DataValidationConstraint | XSSFDataValidationHelper.createDateConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2, java.lang.String dateFormat)
DataValidationConstraint | XSSFDataValidationHelper.createDecimalConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | XSSFDataValidationHelper.createExplicitListConstraint(java.lang.String[] listOfValues)
DataValidationConstraint | XSSFDataValidationHelper.createFormulaListConstraint(java.lang.String listFormula)
DataValidationConstraint | XSSFDataValidationHelper.createIntegerConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | XSSFDataValidationHelper.createNumericConstraint(int validationType, int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | XSSFDataValidationHelper.createTextLengthConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | XSSFDataValidationHelper.createTimeConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | XSSFDataValidation.getValidationConstraint()

Methods in org.apache.poi.xssf.usermodel with parameters of type DataValidationConstraint
 DataValidation XSSFDataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

No usage of org.apache.poi.ss.usermodel.DataValidationConstraint.OperatorType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType

No usage of org.apache.poi.ss.usermodel.DataValidationConstraint.ValidationType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.DataValidationHelper

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.DataValidationHelper

Packages that use DataValidationHelper
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of DataValidationHelper in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement DataValidationHelper
 class HSSFDataValidationHelper

Methods in org.apache.poi.hssf.usermodel that return DataValidationHelper
 DataValidationHelper HSSFSheet.getDataValidationHelper()

Uses of DataValidationHelper in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return DataValidationHelper
 DataValidationHelper Sheet.getDataValidationHelper()

Uses of DataValidationHelper in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return DataValidationHelper
 DataValidationHelper SXSSFSheet.getDataValidationHelper()

Uses of DataValidationHelper in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement DataValidationHelper
 class XSSFDataValidationHelper

Methods in org.apache.poi.xssf.usermodel that return DataValidationHelper
 DataValidationHelper XSSFSheet.getDataValidationHelper()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.DateUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.DateUtil

Packages that use DateUtil
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of DateUtil in org.apache.poi.hssf.usermodel

Subclasses of DateUtil in org.apache.poi.hssf.usermodel
 class HSSFDateUtil
Contains methods for dealing with Excel dates.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Drawing

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Drawing

Packages that use Drawing
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Drawing in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Drawing
 class HSSFPatriarch
The patriarch is the toplevel container for shapes in a sheet.

Uses of Drawing in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Drawing
 Drawing Sheet.createDrawingPatriarch()
Creates the top-level drawing patriarch.

Uses of Drawing in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Drawing
 Drawing SXSSFSheet.createDrawingPatriarch()
Creates the top-level drawing patriarch.

Uses of Drawing in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Drawing
 class XSSFDrawing
Represents a SpreadsheetML drawing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.ErrorConstants

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.ErrorConstants

Packages that use ErrorConstants
org.apache.poi.hssf.usermodel usermodel package maps HSSF low level strutures to familiar workbook/sheet model

Uses of ErrorConstants in org.apache.poi.hssf.usermodel

Subclasses of ErrorConstants in org.apache.poi.hssf.usermodel
 class HSSFErrorConstants
Contains raw Excel error codes (as defined in OOO's excelfileformat.pdf (2.5.6)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

No usage of org.apache.poi.ss.usermodel.ExcelStyleDateFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.FillPatternType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.FillPatternType

Packages that use FillPatternType
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of FillPatternType in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FillPatternType
static FillPatternType | FillPatternType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FillPatternType[] | FillPatternType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of FillPatternType in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return FillPatternType
 FillPatternType XSSFCellStyle.getFillPatternEnum()
Get the fill pattern

Methods in org.apache.poi.xssf.usermodel with parameters of type FillPatternType
 void XSSFCellStyle.setFillPattern(FillPatternType ptrn)
This element is used to specify cell fill information for pattern and solid color cell fills.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Font

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Font

Packages that use Font
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.ss.util |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Font in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Font
 class HSSFFont
Represents a Font used in a workbook.

Methods in org.apache.poi.hssf.usermodel with parameters of type Font
void | HSSFRichTextString.applyFont(Font font) Sets the font of the entire string.
void | HSSFRichTextString.applyFont(int startIndex, int endIndex, Font font) Applies a font to the specified characters of a string.
void | HSSFCellStyle.setFont(Font font) set the font for this style

Uses of Font in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Font
Font | Workbook.createFont() Create a new Font and add it to the workbook's font table
Font | Workbook.findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline) Finds a font that matches the one with the supplied attributes
Font | Workbook.getFontAt(short idx) Get the font at the given index number

Methods in org.apache.poi.ss.usermodel with parameters of type Font
void | RichTextString.applyFont(Font font) Sets the font of the entire string.
void | RichTextString.applyFont(int startIndex, int endIndex, Font font) Applies a font to the specified characters of a string.
void | CellStyle.setFont(Font font) set the font for this style

Uses of Font in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util with parameters of type Font
static void CellUtil.setFont(Cell cell, Workbook workbook, Font font)
Take a cell, and apply a font to it

Uses of Font in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Font
Font | SXSSFWorkbook.createFont() Create a new Font and add it to the workbook's font table
Font | SXSSFWorkbook.findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline) Finds a font that matches the one with the supplied attributes
Font | SXSSFWorkbook.getFontAt(short idx) Get the font at the given index number

Uses of Font in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Font
 class XSSFFont
Represents a font used in a workbook.

Methods in org.apache.poi.xssf.usermodel with parameters of type Font
void | XSSFRichTextString.applyFont(Font font) Sets the font of the entire string.
void | XSSFRichTextString.applyFont(int startIndex, int endIndex, Font font) Applies a font to the specified characters of a string.
void | XSSFCellStyle.setFont(Font font) Set the font for this style

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.FontCharset

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.FontCharset

Packages that use FontCharset
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of FontCharset in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FontCharset
static FontCharset | FontCharset.valueOf(int value)
static FontCharset | FontCharset.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontCharset[] | FontCharset.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of FontCharset in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type FontCharset
 void XSSFFont.setCharSet(FontCharset charSet)
set character-set to use.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.FontFamily

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.FontFamily

Packages that use FontFamily
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of FontFamily in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FontFamily
static FontFamily | FontFamily.valueOf(int family)
static FontFamily | FontFamily.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontFamily[] | FontFamily.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of FontFamily in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type FontFamily
 void XSSFFont.setFamily(FontFamily family)
set an enumeration representing the font family this font belongs to.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.FontFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.FontFormatting

Packages that use FontFormatting
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of FontFormatting in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement FontFormatting
 class HSSFFontFormatting
High level representation for Font Formatting component of Conditional Formatting settings

Uses of FontFormatting in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FontFormatting
FontFormatting | ConditionalFormattingRule.createFontFormatting() Create a new font formatting structure if it does not exist, otherwise just return existing object.
FontFormatting | ConditionalFormattingRule.getFontFormatting()

Uses of FontFormatting in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement FontFormatting
 class XSSFFontFormatting

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.FontScheme

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.FontScheme

Packages that use FontScheme
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of FontScheme in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FontScheme
static FontScheme | FontScheme.valueOf(int value)
static FontScheme | FontScheme.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontScheme[] | FontScheme.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of FontScheme in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return FontScheme
 FontScheme XSSFFont.getScheme()
get the font scheme property.

Methods in org.apache.poi.xssf.usermodel with parameters of type FontScheme
 void XSSFFont.setScheme(FontScheme scheme)
set font scheme property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.FontUnderline

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.FontUnderline

Packages that use FontUnderline
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of FontUnderline in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FontUnderline
static FontUnderline | FontUnderline.valueOf(byte value)
static FontUnderline | FontUnderline.valueOf(int value)
static FontUnderline | FontUnderline.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FontUnderline[] | FontUnderline.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of FontUnderline in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type FontUnderline
 void XSSFFont.setUnderline(FontUnderline underline)
set an enumeration representing the style of underlining that is used.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Footer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Footer

Packages that use Footer
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Footer in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Footer
 class HSSFFooter
Class to read and manipulate the footer.

Uses of Footer in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Footer
 Footer Sheet.getFooter()
Gets the user model for the default document footer.

Uses of Footer in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Footer
 Footer SXSSFSheet.getFooter()
Gets the user model for the default document footer.

Uses of Footer in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Footer
class | XSSFEvenFooter Even page footer value.
class | XSSFFirstFooter First page footer content.
class | XSSFOddFooter Odd page footer value.

Methods in org.apache.poi.xssf.usermodel that return Footer
Footer | XSSFSheet.getEvenFooter() Returns the even footer.
Footer | XSSFSheet.getFirstFooter() Returns the first page footer.
Footer | XSSFSheet.getFooter() Returns the default footer for the sheet, creating one as needed.
Footer | XSSFSheet.getOddFooter() Returns the odd footer.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.FormulaError

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.FormulaError

Packages that use FormulaError
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of FormulaError in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FormulaError
static FormulaError | FormulaError.forInt(byte type)
static FormulaError | FormulaError.forString(java.lang.String code)
static FormulaError | FormulaError.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static FormulaError[] | FormulaError.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of FormulaError in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type FormulaError
 void XSSFCell.setCellErrorValue(FormulaError error)
Set a error value for the cell

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.FormulaEvaluator

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.FormulaEvaluator

Packages that use FormulaEvaluator
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of FormulaEvaluator in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement FormulaEvaluator
 class HSSFFormulaEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

Uses of FormulaEvaluator in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return FormulaEvaluator
 FormulaEvaluator CreationHelper.createFormulaEvaluator()
Creates FormulaEvaluator - an object that evaluates formula cells.

Methods in org.apache.poi.ss.usermodel with parameters of type FormulaEvaluator
 java.lang.String DataFormatter.formatCellValue(Cell cell, FormulaEvaluator evaluator)
Returns the formatted value of a cell as a String regardless of the cell type.

Uses of FormulaEvaluator in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement FormulaEvaluator
 class XSSFFormulaEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Header

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Header

Packages that use Header
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Header in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Header
 class HSSFHeader
Class to read and manipulate the header.

Uses of Header in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Header
 Header Sheet.getHeader()
Gets the user model for the default document header.

Uses of Header in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Header
 Header SXSSFSheet.getHeader()
Gets the user model for the default document header.

Uses of Header in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Header
class | XSSFEvenHeader Even page header value.
class | XSSFFirstHeader First page header content.
class | XSSFOddHeader Odd page header value.

Methods in org.apache.poi.xssf.usermodel that return Header
Header | XSSFSheet.getEvenHeader() Returns the even header.
Header | XSSFSheet.getFirstHeader() Returns the first page header.
Header | XSSFSheet.getHeader() Returns the default header for the sheet, creating one as needed.
Header | XSSFSheet.getOddHeader() Returns the odd header.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.HeaderFooter

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.HeaderFooter

Packages that use HeaderFooter
org.apache.poi.hssf.extractor |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.extensions |

Uses of HeaderFooter in org.apache.poi.hssf.extractor

Methods in org.apache.poi.hssf.extractor with parameters of type HeaderFooter
static java.lang.String ExcelExtractor._extractHeaderFooter(HeaderFooter hf)

Uses of HeaderFooter in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement HeaderFooter
class | HeaderFooter Common class for HSSFHeader and HSSFFooter.
class | HSSFFooter Class to read and manipulate the footer.
class | HSSFHeader Class to read and manipulate the header.

Uses of HeaderFooter in org.apache.poi.ss.usermodel

Subinterfaces of HeaderFooter in org.apache.poi.ss.usermodel
interface | Footer Common definition of a HSSF or XSSF page footer.
interface | Header Common definition of a HSSF or XSSF page header.

Uses of HeaderFooter in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement HeaderFooter
class | XSSFEvenFooter Even page footer value.
class | XSSFEvenHeader Even page header value.
class | XSSFFirstFooter First page footer content.
class | XSSFFirstHeader First page header content.
class | XSSFOddFooter Odd page footer value.
class | XSSFOddHeader Odd page header value.

Uses of HeaderFooter in org.apache.poi.xssf.usermodel.extensions

Classes in org.apache.poi.xssf.usermodel.extensions that implement HeaderFooter
 class XSSFHeaderFooter
Parent class of all XSSF headers and footers.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.HorizontalAlignment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.HorizontalAlignment

Packages that use HorizontalAlignment
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions

Uses of HorizontalAlignment in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return HorizontalAlignment
static HorizontalAlignment | HorizontalAlignment.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static HorizontalAlignment[] | HorizontalAlignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of HorizontalAlignment in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return HorizontalAlignment
 HorizontalAlignment XSSFCellStyle.getAlignmentEnum()
Get the type of horizontal alignment for the cell

Methods in org.apache.poi.xssf.usermodel with parameters of type HorizontalAlignment
 void XSSFCellStyle.setAlignment(HorizontalAlignment align)
Set the type of horizontal alignment for the cell

Uses of HorizontalAlignment in org.apache.poi.xssf.usermodel.extensions

Methods in org.apache.poi.xssf.usermodel.extensions that return HorizontalAlignment
 HorizontalAlignment XSSFCellAlignment.getHorizontal()
Get the type of horizontal alignment for the cell

Methods in org.apache.poi.xssf.usermodel.extensions with parameters of type HorizontalAlignment
 void XSSFCellAlignment.setHorizontal(HorizontalAlignment align)
Set the type of horizontal alignment for the cell

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Hyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Hyperlink

Packages that use Hyperlink
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Hyperlink in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel with parameters of type Hyperlink
 void HSSFCell.setHyperlink(Hyperlink hyperlink)
Assign a hyperlink to this cell

Uses of Hyperlink in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Hyperlink
Hyperlink | CreationHelper.createHyperlink(int type) Creates a new Hyperlink, of the given type
Hyperlink | Cell.getHyperlink()

Methods in org.apache.poi.ss.usermodel with parameters of type Hyperlink
 void Cell.setHyperlink(Hyperlink link)
Assign a hyperlink to this cell

Uses of Hyperlink in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Hyperlink
 Hyperlink SXSSFCell.getHyperlink()

Methods in org.apache.poi.xssf.streaming with parameters of type Hyperlink
 void SXSSFCell.setHyperlink(Hyperlink link)
Assign a hyperlink to this cell

Uses of Hyperlink in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type Hyperlink
 void XSSFCell.setHyperlink(Hyperlink hyperlink)
Assign a hypelrink to this cell

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.IndexedColors

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.IndexedColors

Packages that use IndexedColors
org.apache.poi.ss.usermodel

Uses of IndexedColors in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return IndexedColors
static IndexedColors | IndexedColors.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static IndexedColors[] | IndexedColors.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Name

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Name

Packages that use Name
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Name in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Name
 class HSSFName
High Level Representation of a 'defined name' which could be a 'built-in' name, 'named range' or name of a user defined function.

Uses of Name in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Name
Name | Workbook.createName() Creates a new (uninitialised) defined name in this workbook
Name | Workbook.getName(java.lang.String name)
Name | Workbook.getNameAt(int nameIndex)

Uses of Name in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Name
Name | SXSSFWorkbook.createName() Creates a new (uninitialised) defined name in this workbook
Name | SXSSFWorkbook.getName(java.lang.String name)
Name | SXSSFWorkbook.getNameAt(int nameIndex)

Uses of Name in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Name
 class XSSFName
Represents a defined named range in a SpreadsheetML workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.PageOrder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.PageOrder

Packages that use PageOrder
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of PageOrder in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PageOrder
static PageOrder | PageOrder.valueOf(int value)
static PageOrder | PageOrder.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PageOrder[] | PageOrder.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of PageOrder in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return PageOrder
 PageOrder XSSFPrintSetup.getPageOrder()
get print page order.

Methods in org.apache.poi.xssf.usermodel with parameters of type PageOrder
 void XSSFPrintSetup.setPageOrder(PageOrder pageOrder)
Set print page order.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.PaperSize

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.PaperSize

Packages that use PaperSize
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of PaperSize in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PaperSize
static PaperSize | PaperSize.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PaperSize[] | PaperSize.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of PaperSize in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return PaperSize
 PaperSize XSSFPrintSetup.getPaperSizeEnum()
Returns the paper size as enum.

Methods in org.apache.poi.xssf.usermodel with parameters of type PaperSize
 void XSSFPrintSetup.setPaperSize(PaperSize size)
Set the paper size as enum value.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.PatternFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.PatternFormatting

Packages that use PatternFormatting
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of PatternFormatting in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement PatternFormatting
 class HSSFPatternFormatting
High level representation for Conditional Formatting settings

Uses of PatternFormatting in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PatternFormatting
PatternFormatting | ConditionalFormattingRule.createPatternFormatting() Create a new pattern formatting structure if it does not exist, otherwise just return existing object.
PatternFormatting | ConditionalFormattingRule.getPatternFormatting()

Uses of PatternFormatting in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement PatternFormatting
 class XSSFPatternFormatting

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Picture

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Picture

Packages that use Picture
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.usermodel |

Uses of Picture in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Picture
 class HSSFPicture
Represents a escher picture.

Uses of Picture in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Picture
 Picture Drawing.createPicture(ClientAnchor anchor, int pictureIndex)
Creates a picture.

Uses of Picture in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Picture
 class XSSFPicture
Represents a picture shape in a SpreadsheetML drawing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.PictureData

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.PictureData

Packages that use PictureData
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of PictureData in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement PictureData
 class HSSFPictureData
Represents binary data stored in the file.

Uses of PictureData in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PictureData
 PictureData Picture.getPictureData()
Return picture data for this picture

Methods in org.apache.poi.ss.usermodel that return types with arguments of type PictureData
 java.util.List<? extends PictureData> Workbook.getAllPictures()
Gets all pictures from the Workbook.

Uses of PictureData in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return types with arguments of type PictureData
 java.util.List<? extends PictureData> SXSSFWorkbook.getAllPictures()
Gets all pictures from the Workbook.

Uses of PictureData in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement PictureData
 class XSSFPictureData
Raw picture data, normally attached to a SpreadsheetML Drawing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.PrintCellComments

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.PrintCellComments

Packages that use PrintCellComments
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of PrintCellComments in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PrintCellComments
static PrintCellComments | PrintCellComments.valueOf(int value)
static PrintCellComments | PrintCellComments.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PrintCellComments[] | PrintCellComments.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of PrintCellComments in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return PrintCellComments
 PrintCellComments XSSFPrintSetup.getCellComment()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.PrintOrientation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.PrintOrientation

Packages that use PrintOrientation
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel

Uses of PrintOrientation in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PrintOrientation
static PrintOrientation | PrintOrientation.valueOf(int value)
static PrintOrientation | PrintOrientation.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static PrintOrientation[] | PrintOrientation.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of PrintOrientation in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return PrintOrientation
 PrintOrientation XSSFPrintSetup.getOrientation()
Orientation of the page: landscape - portrait.

Methods in org.apache.poi.xssf.usermodel with parameters of type PrintOrientation
 void XSSFPrintSetup.setOrientation(PrintOrientation orientation)
Orientation of the page: landscape - portrait.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.PrintSetup

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.PrintSetup

Packages that use PrintSetup
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of PrintSetup in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement PrintSetup
 class HSSFPrintSetup
Used to modify the print setup.

Uses of PrintSetup in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return PrintSetup
 PrintSetup Sheet.getPrintSetup()
Gets the print setup object.

Uses of PrintSetup in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return PrintSetup
 PrintSetup SXSSFSheet.getPrintSetup()
Gets the print setup object.

Uses of PrintSetup in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement PrintSetup
 class XSSFPrintSetup
Page setup and page margins settings for the worksheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.RichTextString

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.RichTextString

Packages that use RichTextString
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of RichTextString in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement RichTextString
 class HSSFRichTextString
Rich text unicode string.

Methods in org.apache.poi.hssf.usermodel with parameters of type RichTextString
void | HSSFCell.setCellValue(RichTextString value) Set a string value for the cell.
void | HSSFTextbox.setString(RichTextString string)
void | HSSFComment.setString(RichTextString string) Sets the rich text string used by this comment.

Uses of RichTextString in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return RichTextString
RichTextString | CreationHelper.createRichTextString(java.lang.String text) Creates a new RichTextString instance
RichTextString | Cell.getRichStringCellValue() Get the value of the cell as a XSSFRichTextString
RichTextString | Textbox.getString()
RichTextString | Comment.getString() Fetches the rich text string of the comment

Methods in org.apache.poi.ss.usermodel with parameters of type RichTextString
void | Cell.setCellValue(RichTextString value) Set a rich string value for the cell.
void | Textbox.setString(RichTextString string)
void | Comment.setString(RichTextString string) Sets the rich text string used by this comment.

Uses of RichTextString in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return RichTextString
 RichTextString SXSSFCell.getRichStringCellValue()
Get the value of the cell as a XSSFRichTextString

Methods in org.apache.poi.xssf.streaming with parameters of type RichTextString
 void SXSSFCell.setCellValue(RichTextString value)
Set a rich string value for the cell.

Uses of RichTextString in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement RichTextString
 class XSSFRichTextString
Rich text unicode string.

Methods in org.apache.poi.xssf.usermodel with parameters of type RichTextString
void | XSSFCell.setCellValue(RichTextString str) Set a string value for the cell.
void | XSSFComment.setString(RichTextString string) Sets the rich text string used by this comment.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Row

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Row

Packages that use Row
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.ss.util |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Row in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Row
 class HSSFRow
High level representation of a row of a spreadsheet.

Methods in org.apache.poi.hssf.usermodel that return types with arguments of type Row
 java.util.Iterator<Row> HSSFSheet.iterator()
Alias for HSSFSheet.rowIterator() to allow foreach loops
 java.util.Iterator<Row> HSSFSheet.rowIterator()

Methods in org.apache.poi.hssf.usermodel with parameters of type Row
 void HSSFSheet.removeRow(Row row)
Remove a row from this sheet.

Uses of Row in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Row
Row | Sheet.createRow(int rownum) Create a new row within the sheet and return the high level representation
Row | Cell.getRow() Returns the Row this cell belongs to
Row | Sheet.getRow(int rownum) Returns the logical row (not physical) 0-based.

Methods in org.apache.poi.ss.usermodel that return types with arguments of type Row
 java.util.Iterator<Row> Sheet.rowIterator()
Returns an iterator of the physical rows

Methods in org.apache.poi.ss.usermodel with parameters of type Row
 void Sheet.removeRow(Row row)
Remove a row from this sheet.

Uses of Row in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return Row
static Row CellUtil.getRow(int rowIndex, Sheet sheet)
Get a row from the spreadsheet, and create it if it doesn't exist.

Methods in org.apache.poi.ss.util with parameters of type Row
static Cell | CellUtil.createCell(Row row, int column, java.lang.String value) Create a cell, and give it a value.
static Cell | CellUtil.createCell(Row row, int column, java.lang.String value, CellStyle style) Creates a cell, gives it a value, and applies a style if provided
static Cell | CellUtil.getCell(Row row, int columnIndex) Get a specific cell from a row.

Uses of Row in org.apache.poi.xssf.streaming

Classes in org.apache.poi.xssf.streaming that implement Row
 class SXSSFRow
Streaming version of XSSFRow implementing the "BigGridDemo" strategy.

Methods in org.apache.poi.xssf.streaming that return Row
Row | SXSSFSheet.createRow(int rownum) Create a new row within the sheet and return the high level representation
Row | SXSSFCell.getRow() Returns the Row this cell belongs to
Row | SXSSFSheet.getRow(int rownum) Returns the logical row (not physical) 0-based.

Methods in org.apache.poi.xssf.streaming that return types with arguments of type Row
java.util.Iterator<Row> | SXSSFSheet.iterator()
java.util.Iterator<Row> | SXSSFSheet.rowIterator() Returns an iterator of the physical rows

Methods in org.apache.poi.xssf.streaming with parameters of type Row
 void SXSSFSheet.removeRow(Row row)
Remove a row from this sheet.

Uses of Row in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Row
 class XSSFRow
High level representation of a row of a spreadsheet.

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type Row
 java.util.Iterator<Row> XSSFSheet.iterator()
Alias for XSSFSheet.rowIterator() to allow foreach loops
 java.util.Iterator<Row> XSSFSheet.rowIterator()

Methods in org.apache.poi.xssf.usermodel with parameters of type Row
 void XSSFSheet.removeRow(Row row)
Remove a row from this sheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.Row.MissingCellPolicy

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.Row.MissingCellPolicy

Packages that use Row.MissingCellPolicy
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Row.MissingCellPolicy in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return Row.MissingCellPolicy
 Row.MissingCellPolicy HSSFWorkbook.getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.

Methods in org.apache.poi.hssf.usermodel with parameters of type Row.MissingCellPolicy
HSSFCell | HSSFRow.getCell(int cellnum, Row.MissingCellPolicy policy) Get the hssfcell representing a given column (logical cell) 0-based.
void | HSSFWorkbook.setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy) Sets the policy on what to do when getting missing or blank cells from a row.

Uses of Row.MissingCellPolicy in org.apache.poi.ss.usermodel

Fields in org.apache.poi.ss.usermodel declared as Row.MissingCellPolicy
static Row.MissingCellPolicy | Row.CREATE_NULL_AS_BLANK A new, blank cell is created for missing cells.
static Row.MissingCellPolicy | Row.RETURN_BLANK_AS_NULL Missing cells are returned as null, as are blank cells
static Row.MissingCellPolicy | Row.RETURN_NULL_AND_BLANK Missing cells are returned as null, Blank cells are returned as normal

Methods in org.apache.poi.ss.usermodel that return Row.MissingCellPolicy
 Row.MissingCellPolicy Workbook.getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.

Methods in org.apache.poi.ss.usermodel with parameters of type Row.MissingCellPolicy
Cell | Row.getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
void | Workbook.setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy) Sets the policy on what to do when getting missing or blank cells from a row.

Uses of Row.MissingCellPolicy in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return Row.MissingCellPolicy
 Row.MissingCellPolicy SXSSFWorkbook.getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.

Methods in org.apache.poi.xssf.streaming with parameters of type Row.MissingCellPolicy
Cell | SXSSFRow.getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
void | SXSSFWorkbook.setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy) Sets the policy on what to do when getting missing or blank cells from a row.

Uses of Row.MissingCellPolicy in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return Row.MissingCellPolicy
 Row.MissingCellPolicy XSSFWorkbook.getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.

Methods in org.apache.poi.xssf.usermodel with parameters of type Row.MissingCellPolicy
XSSFCell | XSSFRow.getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
void | XSSFWorkbook.setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy) Sets the policy on what to do when getting missing or blank cells from a row.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.ShapeTypes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.ShapeTypes

No usage of org.apache.poi.ss.usermodel.ShapeTypes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Sheet

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Sheet

Packages that use Sheet
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.ss.usermodel.charts |
org.apache.poi.ss.util |
org.apache.poi.ss.util.cellwalk |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Sheet in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Sheet
 class HSSFSheet
High level representation of a worksheet.

Methods in org.apache.poi.hssf.usermodel with parameters of type Sheet
 int HSSFWorkbook.getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Uses of Sheet in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Sheet
Sheet | Workbook.cloneSheet(int sheetNum) Create an Sheet from an existing sheet in the Workbook.
Sheet | Workbook.createSheet() Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
Sheet | Workbook.createSheet(java.lang.String sheetname) Create a new sheet for this Workbook and return the high level representation.
Sheet | Row.getSheet() Returns the Sheet this row belongs to
Sheet | Cell.getSheet() Returns the sheet this cell belongs to
Sheet | Workbook.getSheet(java.lang.String name) Get sheet with the given name
Sheet | Workbook.getSheetAt(int index) Get the Sheet object at the given index.

Methods in org.apache.poi.ss.usermodel with parameters of type Sheet
 int Workbook.getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Uses of Sheet in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts with parameters of type Sheet
static ChartDataSource<java.lang.Number> | DataSources.fromNumericCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)
static ChartDataSource<java.lang.String> | DataSources.fromStringCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)

Uses of Sheet in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return Sheet
 Sheet SheetBuilder.build()
Builds sheet from parent workbook and 2D array with cell values.

Methods in org.apache.poi.ss.util with parameters of type Sheet
static double | SheetUtil.getColumnWidth(Sheet sheet, int column, boolean useMergedCells) Compute width of a column and return the result
static double | SheetUtil.getColumnWidth(Sheet sheet, int column, boolean useMergedCells, int firstRow, int lastRow) Compute width of a column based on a subset of the rows and return the result
static Row | CellUtil.getRow(int rowIndex, Sheet sheet) Get a row from the spreadsheet, and create it if it doesn't exist.
static void | RegionUtil.setBorderBottom(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | RegionUtil.setBorderLeft(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | RegionUtil.setBorderRight(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderRight attribute of the RegionUtil object
static void | RegionUtil.setBorderTop(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | RegionUtil.setBottomBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the bottomBorderColor attribute of the RegionUtil object
static void | RegionUtil.setLeftBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the leftBorderColor attribute of the RegionUtil object
static void | RegionUtil.setRightBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the rightBorderColor attribute of the RegionUtil object
static void | RegionUtil.setTopBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the topBorderColor attribute of the RegionUtil object

Uses of Sheet in org.apache.poi.ss.util.cellwalk

Constructors in org.apache.poi.ss.util.cellwalk with parameters of type Sheet
CellWalk(Sheet sheet, CellRangeAddress range)

Uses of Sheet in org.apache.poi.xssf.streaming

Classes in org.apache.poi.xssf.streaming that implement Sheet
 class SXSSFSheet
Streaming version of XSSFSheet implementing the "BigGridDemo" strategy.

Methods in org.apache.poi.xssf.streaming that return Sheet
Sheet | SXSSFWorkbook.cloneSheet(int sheetNum) Create an Sheet from an existing sheet in the Workbook.
Sheet | SXSSFWorkbook.createSheet() Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
Sheet | SXSSFWorkbook.createSheet(java.lang.String sheetname) Create an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
Sheet | SXSSFRow.getSheet() Returns the Sheet this row belongs to
Sheet | SXSSFCell.getSheet() Returns the sheet this cell belongs to
Sheet | SXSSFWorkbook.getSheet(java.lang.String name) Get sheet with the given name
Sheet | SXSSFWorkbook.getSheetAt(int index) Get the Sheet object at the given index.

Methods in org.apache.poi.xssf.streaming with parameters of type Sheet
 int SXSSFWorkbook.getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Uses of Sheet in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Sheet
class | XSSFChartSheet High level representation of Sheet Parts that are of type 'chartsheet'.
class | XSSFDialogsheet
class | XSSFSheet High level representation of a SpreadsheetML worksheet.

Methods in org.apache.poi.xssf.usermodel with parameters of type Sheet
 int XSSFWorkbook.getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.SheetConditionalFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.SheetConditionalFormatting

Packages that use SheetConditionalFormatting
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.usermodel |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of SheetConditionalFormatting in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement SheetConditionalFormatting
 class HSSFSheetConditionalFormatting
The 'Conditional Formatting' facet of HSSFSheet

Uses of SheetConditionalFormatting in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return SheetConditionalFormatting
 SheetConditionalFormatting Sheet.getSheetConditionalFormatting()
The 'Conditional Formatting' facet for this Sheet

Uses of SheetConditionalFormatting in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return SheetConditionalFormatting
 SheetConditionalFormatting SXSSFSheet.getSheetConditionalFormatting()

Uses of SheetConditionalFormatting in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement SheetConditionalFormatting
 class XSSFSheetConditionalFormatting

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Textbox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Textbox

No usage of org.apache.poi.ss.usermodel.Textbox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.VerticalAlignment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.VerticalAlignment

Packages that use VerticalAlignment
org.apache.poi.ss.usermodel
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions

Uses of VerticalAlignment in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return VerticalAlignment
static VerticalAlignment | VerticalAlignment.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static VerticalAlignment[] | VerticalAlignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of VerticalAlignment in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return VerticalAlignment
 VerticalAlignment XSSFCellStyle.getVerticalAlignmentEnum()
Get the type of vertical alignment for the cell

Methods in org.apache.poi.xssf.usermodel with parameters of type VerticalAlignment
 void XSSFCellStyle.setVerticalAlignment(VerticalAlignment align)
Set the type of vertical alignment for the cell

Uses of VerticalAlignment in org.apache.poi.xssf.usermodel.extensions

Methods in org.apache.poi.xssf.usermodel.extensions that return VerticalAlignment
 VerticalAlignment XSSFCellAlignment.getVertical()
Get the type of vertical alignment for the cell

Methods in org.apache.poi.xssf.usermodel.extensions with parameters of type VerticalAlignment
 void XSSFCellAlignment.setVertical(VerticalAlignment align)
Set the type of vertical alignment for the cell

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.usermodel.Workbook

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.usermodel.Workbook

Packages that use Workbook
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.ss.formula.eval.forked |
org.apache.poi.ss.usermodel |
org.apache.poi.ss.util |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |

Uses of Workbook in org.apache.poi.hssf.usermodel

Classes in org.apache.poi.hssf.usermodel that implement Workbook
 class HSSFWorkbook
High level representation of a workbook.

Methods in org.apache.poi.hssf.usermodel with parameters of type Workbook
static void | HSSFFormulaEvaluator.evaluateAllFormulaCells(Workbook wb) Loops over all cells in all sheets of the supplied workbook.
java.lang.String | HSSFCellStyle.getDataFormatString(Workbook workbook) Get the contents of the format string, by looking up the DataFormat against the supplied workbook
HSSFFont | HSSFCellStyle.getFont(Workbook parentWorkbook) gets the font for this style

Uses of Workbook in org.apache.poi.ss.formula.eval.forked

Methods in org.apache.poi.ss.formula.eval.forked with parameters of type Workbook
 void ForkedEvaluator.copyUpdatedCells(Workbook workbook)
Copies the values of all updated cells (modified by calls to ForkedEvaluator.updateCell(String, int, int, ValueEval)) to the supplied workbook.
Typically, the supplied workbook is a writable copy of the 'master workbook', but at the very least it must contain sheets with the same names.
static ForkedEvaluator ForkedEvaluator.create(Workbook wb, IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use ForkedEvaluator.create(Workbook, IStabilityClassifier, UDFFinder)
static ForkedEvaluator ForkedEvaluator.create(Workbook wb, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)

Uses of Workbook in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return Workbook
static Workbook | WorkbookFactory.create(java.io.File file) Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given File, which must exist and be readable.
static Workbook | WorkbookFactory.create(java.io.InputStream inp) Creates the appropriate HSSFWorkbook / XSSFWorkbook from the given InputStream.
static Workbook | WorkbookFactory.create(NPOIFSFileSystem fs) Creates an HSSFWorkbook from the given NPOIFSFileSystem
static Workbook | WorkbookFactory.create(OPCPackage pkg) Creates an XSSFWorkbook from the given OOXML Package
static Workbook | WorkbookFactory.create(POIFSFileSystem fs) Creates an HSSFWorkbook from the given POIFSFileSystem
Workbook | Sheet.getWorkbook() Return the parent workbook

Uses of Workbook in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util with parameters of type Workbook
static void | CellUtil.setAlignment(Cell cell, Workbook workbook, short align) Take a cell, and align it.
static void | RegionUtil.setBorderBottom(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | RegionUtil.setBorderLeft(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | RegionUtil.setBorderRight(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderRight attribute of the RegionUtil object
static void | RegionUtil.setBorderTop(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | RegionUtil.setBottomBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the bottomBorderColor attribute of the RegionUtil object
static void | CellUtil.setCellStyleProperty(Cell cell, Workbook workbook, java.lang.String propertyName, java.lang.Object propertyValue) This method attempt to find an already existing CellStyle that matches what you want the style to be.
static void | CellUtil.setFont(Cell cell, Workbook workbook, Font font) Take a cell, and apply a font to it
static void | RegionUtil.setLeftBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the leftBorderColor attribute of the RegionUtil object
static void | RegionUtil.setRightBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the rightBorderColor attribute of the RegionUtil object
static void | RegionUtil.setTopBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the topBorderColor attribute of the RegionUtil object

Constructors in org.apache.poi.ss.util with parameters of type Workbook
SheetBuilder(Workbook workbook, java.lang.Object[][] cells)

Uses of Workbook in org.apache.poi.xssf.streaming

Classes in org.apache.poi.xssf.streaming that implement Workbook
 class SXSSFWorkbook
Streaming version of XSSFWorkbook implementing the "BigGridDemo" strategy.

Methods in org.apache.poi.xssf.streaming that return Workbook
 Workbook SXSSFSheet.getWorkbook()
Return the parent workbook

Uses of Workbook in org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel that implement Workbook
 class XSSFWorkbook
High level representation of a SpreadsheetML workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.usermodel.WorkbookFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.usermodel.WorkbookFactory

No usage of org.apache.poi.ss.usermodel.WorkbookFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AreaReference

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class AreaReference

java.lang.Object
    extended by  org.apache.poi.ss.util.AreaReference
Direct Known Subclasses:
AreaReference
public class AreaReference
extends java.lang.Object

Constructor Summary
AreaReference(CellReference topLeft, CellReference botRight)
Creates an area ref from a pair of Cell References.
AreaReference(java.lang.String reference)
Create an area ref from a string representation.
Method Summary
 java.lang.String formatAsString()
Example return values:
Result Comment A1:A1Single cell area reference without sheet A1:$C$1Multi-cell area reference without sheet Sheet1!A$1:B4Standard sheet name 'O''Brien''s Sales'!B5:C6' Sheet name with special characters
static AreaReference[] generateContiguous(java.lang.String reference)
Takes a non-contiguous area reference, and returns an array of contiguous area references.
 CellReference[] getAllReferencedCells()
Returns a reference to every cell covered by this area
 CellReference getFirstCell()
 CellReference getLastCell()
Note - if this area reference refers to a single cell, the return value of this method will be identical to that of getFirstCell()
static AreaReference getWholeColumn(java.lang.String start, java.lang.String end)
static AreaReference getWholeRow(java.lang.String start, java.lang.String end)
static boolean isContiguous(java.lang.String reference)
Is the reference for a contiguous (i.e.
 boolean isSingleCell()
 boolean isWholeColumnReference()
static boolean isWholeColumnReference(CellReference topLeft, CellReference botRight)
Is the reference for a whole-column reference, such as C:C or D:G ?
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AreaReference

public AreaReference(java.lang.String reference)
Create an area ref from a string representation. Sheet names containing special characters should be delimited and escaped as per normal syntax rules for formulas.
The area reference must be contiguous (i.e. represent a single rectangle, not a union of rectangles)

AreaReference

public AreaReference(CellReference topLeft,
                     CellReference botRight)
Creates an area ref from a pair of Cell References.

Method Detail

isContiguous

public static boolean isContiguous(java.lang.String reference)
Is the reference for a contiguous (i.e. unbroken) area, or is it made up of several different parts? (If it is, you will need to call generateContiguous(String))

getWholeRow

public static AreaReference getWholeRow(java.lang.String start,
                                        java.lang.String end)

getWholeColumn

public static AreaReference getWholeColumn(java.lang.String start,
                                           java.lang.String end)

isWholeColumnReference

public static boolean isWholeColumnReference(CellReference topLeft,
                                             CellReference botRight)
Is the reference for a whole-column reference, such as C:C or D:G ?

isWholeColumnReference

public boolean isWholeColumnReference()

generateContiguous

public static AreaReference[] generateContiguous(java.lang.String reference)
Takes a non-contiguous area reference, and returns an array of contiguous area references.

isSingleCell

public boolean isSingleCell()
Returns:
false if this area reference involves more than one cell

getFirstCell

public CellReference getFirstCell()
Returns:
the first cell reference which defines this area. Usually this cell is in the upper left corner of the area (but this is not a requirement).

getLastCell

public CellReference getLastCell()
Note - if this area reference refers to a single cell, the return value of this method will be identical to that of getFirstCell()

Returns:
the second cell reference which defines this area. For multi-cell areas, this is cell diagonally opposite the 'first cell'. Usually this cell is in the lower right corner of the area (but this is not a requirement).

getAllReferencedCells

public CellReference[] getAllReferencedCells()
Returns a reference to every cell covered by this area

formatAsString

public java.lang.String formatAsString()
Example return values:
Result | Comment
A1:A1 | Single cell area reference without sheet
A1:$C$1 | Multi-cell area reference without sheet
Sheet1!A$1:B4 | Standard sheet name
'O''Brien''s Sales'!B5:C6' | Sheet name with special characters

Returns:
the text representation of this area reference as it would appear in a formula.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CellRangeAddress

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class CellRangeAddress

java.lang.Object
    extended by  org.apache.poi.ss.util.CellRangeAddressBase
        extended by  org.apache.poi.ss.util.CellRangeAddress
Direct Known Subclasses:
CellRangeAddress
public class CellRangeAddress
extends CellRangeAddressBase

See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

In the Microsoft documentation, this is also known as a Ref8U - see page 831 of version 1.0 of the documentation. Note - SelectionRecord uses the BIFF5 version of this structure

Author:
Dragos Buleandra (dragos.buleandra@trade2b.ro)

Field Summary
static int ENCODED_SIZE
Constructor Summary
CellRangeAddress(int firstRow, int lastRow, int firstCol, int lastCol)
CellRangeAddress(RecordInputStream in)
Method Summary
CellRangeAddress | copy()
java.lang.String | formatAsString()
java.lang.String | formatAsString(java.lang.String sheetName, boolean useAbsoluteAddress)
static int | getEncodedSize(int numberOfItems)
int | serialize(int offset, byte[] data) Deprecated. use serialize(LittleEndianOutput)
void | serialize(LittleEndianOutput out)
static CellRangeAddress | valueOf(java.lang.String ref)
Methods inherited from class org.apache.poi.ss.util.CellRangeAddressBase
getFirstColumn, getFirstRow, getLastColumn, getLastRow, getNumberOfCells, isFullColumnRange, isFullRowRange, isInRange, setFirstColumn, setFirstRow, setLastColumn, setLastRow, toString, validate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ENCODED_SIZE

public static final int ENCODED_SIZE
See Also:
Constant Field Values
Constructor Detail

CellRangeAddress

public CellRangeAddress(int firstRow,
                        int lastRow,
                        int firstCol,
                        int lastCol)

CellRangeAddress

public CellRangeAddress(RecordInputStream in)
Method Detail

serialize

public int serialize(int offset,
                     byte[] data)
Deprecated. use serialize(LittleEndianOutput)

serialize

public void serialize(LittleEndianOutput out)

copy

public CellRangeAddress copy()

getEncodedSize

public static int getEncodedSize(int numberOfItems)

formatAsString

public java.lang.String formatAsString()
Returns:
the text format of this range. Single cell ranges are formatted like single cell references (e.g. 'A1' instead of 'A1:A1').

formatAsString

public java.lang.String formatAsString(java.lang.String sheetName,
                                       boolean useAbsoluteAddress)
Returns:
the text format of this range using specified sheet name.

valueOf

public static CellRangeAddress valueOf(java.lang.String ref)
Parameters:
ref - usually a standard area ref (e.g. "B1:D8"). May be a single cell ref (e.g. "B5") in which case the result is a 1 x 1 cell range.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellRangeAddressBase

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class CellRangeAddressBase

java.lang.Object
    extended by  org.apache.poi.ss.util.CellRangeAddressBase
Direct Known Subclasses:
CellRangeAddress, CellRangeAddress8Bit
public abstract class CellRangeAddressBase
extends java.lang.Object

See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Common subclass of 8-bit and 16-bit versions

Author:
Josh Micich

Constructor Summary
protected CellRangeAddressBase(int firstRow, int lastRow, int firstCol, int lastCol)
Method Summary
int | getFirstColumn()
int | getFirstRow()
int | getLastColumn()
int | getLastRow()
int | getNumberOfCells()
boolean | isFullColumnRange()
boolean | isFullRowRange()
boolean | isInRange(int rowInd, int colInd)
void | setFirstColumn(int firstCol)
void | setFirstRow(int firstRow)
void | setLastColumn(int lastCol)
void | setLastRow(int lastRow)
java.lang.String | toString()
void | validate(SpreadsheetVersion ssVersion) Validate the range limits against the supplied version of Excel
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CellRangeAddressBase

protected CellRangeAddressBase(int firstRow,
                               int lastRow,
                               int firstCol,
                               int lastCol)
Method Detail

validate

public void validate(SpreadsheetVersion ssVersion)
Validate the range limits against the supplied version of Excel

Parameters:
ssVersion - the version of Excel to validate against
Throws:
java.lang.IllegalArgumentException - if the range limits are outside of the allowed range

isFullColumnRange

public final boolean isFullColumnRange()

isFullRowRange

public final boolean isFullRowRange()

getFirstColumn

public final int getFirstColumn()
Returns:
column number for the upper left hand corner

getFirstRow

public final int getFirstRow()
Returns:
row number for the upper left hand corner

getLastColumn

public final int getLastColumn()
Returns:
column number for the lower right hand corner

getLastRow

public final int getLastRow()
Returns:
row number for the lower right hand corner

isInRange

public boolean isInRange(int rowInd,
                         int colInd)

setFirstColumn

public final void setFirstColumn(int firstCol)
Parameters:
firstCol - column number for the upper left hand corner

setFirstRow

public final void setFirstRow(int firstRow)
Parameters:
firstRow - row number for the upper left hand corner

setLastColumn

public final void setLastColumn(int lastCol)
Parameters:
lastCol - column number for the lower right hand corner

setLastRow

public final void setLastRow(int lastRow)
Parameters:
lastRow - row number for the lower right hand corner

getNumberOfCells

public int getNumberOfCells()
Returns:
the size of the range (number of cells in the area).

toString

public final java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellRangeAddressList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class CellRangeAddressList

java.lang.Object
    extended by  org.apache.poi.ss.util.CellRangeAddressList
Direct Known Subclasses:
CellRangeAddressList
public class CellRangeAddressList
extends java.lang.Object

Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas). A cell range address list consists of a field with the number of ranges and the list of the range addresses. Each cell range address (called an ADDR structure) contains 4 16-bit-values.

Author:
Dragos Buleandra (dragos.buleandra@trade2b.ro)

Field Summary
protected  java.util.List _list
List of CellRangeAddresses.
Constructor Summary
CellRangeAddressList()
CellRangeAddressList(int firstRow, int lastRow, int firstCol, int lastCol)
Convenience constructor for creating a CellRangeAddressList with a single CellRangeAddress.
CellRangeAddressList(RecordInputStream in)
Method Summary
void | addCellRangeAddress(CellRangeAddress cra)
void | addCellRangeAddress(int firstRow, int firstCol, int lastRow, int lastCol) Add a cell range structure.
CellRangeAddressList | copy()
int | countRanges() Get the number of following ADDR structures.
CellRangeAddress | getCellRangeAddress(int index)
CellRangeAddress[] | getCellRangeAddresses()
static int | getEncodedSize(int numberOfRanges)
int | getSize()
CellRangeAddress | remove(int rangeIndex)
int | serialize(int offset, byte[] data)
void | serialize(LittleEndianOutput out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_list

protected final java.util.List _list
List of CellRangeAddresses. Each structure represents a cell range

Constructor Detail

CellRangeAddressList

public CellRangeAddressList()

CellRangeAddressList

public CellRangeAddressList(int firstRow,
                            int lastRow,
                            int firstCol,
                            int lastCol)
Convenience constructor for creating a CellRangeAddressList with a single CellRangeAddress. Other CellRangeAddresses may be added later.

CellRangeAddressList

public CellRangeAddressList(RecordInputStream in)
Parameters:
in - the RecordInputstream to read the record from
Method Detail

countRanges

public int countRanges()
Get the number of following ADDR structures. The number of this structures is automatically set when reading an Excel file and/or increased when you manually add a new ADDR structure . This is the reason there isn't a set method for this field .

Returns:
number of ADDR structures

addCellRangeAddress

public void addCellRangeAddress(int firstRow,
                                int firstCol,
                                int lastRow,
                                int lastCol)
Add a cell range structure.

Parameters:
firstRow - - the upper left hand corner's row
firstCol - - the upper left hand corner's col
lastRow - - the lower right hand corner's row
lastCol - - the lower right hand corner's col

addCellRangeAddress

public void addCellRangeAddress(CellRangeAddress cra)

remove

public CellRangeAddress remove(int rangeIndex)

getCellRangeAddress

public CellRangeAddress getCellRangeAddress(int index)
Returns:
CellRangeAddress at the given index

getSize

public int getSize()

getEncodedSize

public static int getEncodedSize(int numberOfRanges)
Returns:
the total size of for the specified number of ranges, including the initial 2 byte range count

serialize

public int serialize(int offset,
                     byte[] data)

serialize

public void serialize(LittleEndianOutput out)

copy

public CellRangeAddressList copy()

getCellRangeAddresses

public CellRangeAddress[] getCellRangeAddresses()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellReference

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class CellReference

java.lang.Object
    extended by  org.apache.poi.ss.util.CellReference
Direct Known Subclasses:
CellReference
public class CellReference
extends java.lang.Object

Author:
Avik Sengupta, Dennis Doubleday (patch to seperateRowColumns())

Nested Class Summary
static class CellReference.NameType
Used to classify identifiers found in formulas as cell references or not.
Constructor Summary
CellReference(Cell cell)
CellReference(int pRow, int pCol)
CellReference(int pRow, int pCol, boolean pAbsRow, boolean pAbsCol)
CellReference(int pRow, short pCol)
CellReference(java.lang.String cellRef)
Create an cell ref from a string representation.
CellReference(java.lang.String pSheetName, int pRow, int pCol, boolean pAbsRow, boolean pAbsCol)
Method Summary
static boolean cellReferenceIsWithinRange(java.lang.String colStr, java.lang.String rowStr, SpreadsheetVersion ssVersion)
Used to decide whether a name of the form "[A-Z]*[0-9]*" that appears in a formula can be interpreted as a cell reference.
static CellReference.NameType classifyCellReference(java.lang.String str, SpreadsheetVersion ssVersion)
Classifies an identifier as either a simple (2D) cell reference or a named range name
static int convertColStringToIndex(java.lang.String ref)
takes in a column reference portion of a CellRef and converts it from ALPHA-26 number format to 0-based base 10.
static java.lang.String convertNumToColString(int col)
Takes in a 0-based base-10 column and returns a ALPHA-26 representation.
 boolean equals(java.lang.Object o)
Checks whether this cell reference is equal to another object.
 java.lang.String formatAsString()
Example return values:
Result | Comment A1Cell reference without sheet Sheet1!A1Standard sheet name 'O''Brien''s Sales'!A1' Sheet name with special characters
java.lang.String[] | getCellRefParts() Returns the three parts of the cell reference, the Sheet name (or null if none supplied), the 1 based row number, and the A based column letter.
short | getCol()
int | getRow()
java.lang.String | getSheetName()
boolean | isColAbsolute()
static boolean | isColumnWithnRange(java.lang.String colStr, SpreadsheetVersion ssVersion)
static boolean | isPartAbsolute(java.lang.String part)
boolean | isRowAbsolute()
static boolean | isRowWithnRange(java.lang.String rowStr, SpreadsheetVersion ssVersion)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CellReference

public CellReference(java.lang.String cellRef)
Create an cell ref from a string representation. Sheet names containing special characters should be delimited and escaped as per normal syntax rules for formulas.

CellReference

public CellReference(int pRow,
                     int pCol)

CellReference

public CellReference(int pRow,
                     short pCol)

CellReference

public CellReference(Cell cell)

CellReference

public CellReference(int pRow,
                     int pCol,
                     boolean pAbsRow,
                     boolean pAbsCol)

CellReference

public CellReference(java.lang.String pSheetName,
                     int pRow,
                     int pCol,
                     boolean pAbsRow,
                     boolean pAbsCol)
Method Detail

getRow

public int getRow()

getCol

public short getCol()

isRowAbsolute

public boolean isRowAbsolute()

isColAbsolute

public boolean isColAbsolute()

getSheetName

public java.lang.String getSheetName()
Returns:
possibly null if this is a 2D reference. Special characters are not escaped or delimited

isPartAbsolute

public static boolean isPartAbsolute(java.lang.String part)

convertColStringToIndex

public static int convertColStringToIndex(java.lang.String ref)
takes in a column reference portion of a CellRef and converts it from ALPHA-26 number format to 0-based base 10. 'A' -> 0 'Z' -> 25 'AA' -> 26 'IV' -> 255

Returns:
zero based column index

classifyCellReference

public static CellReference.NameType classifyCellReference(java.lang.String str,
                                                           SpreadsheetVersion ssVersion)
Classifies an identifier as either a simple (2D) cell reference or a named range name

Returns:
one of the values from NameType

cellReferenceIsWithinRange

public static boolean cellReferenceIsWithinRange(java.lang.String colStr,
                                                 java.lang.String rowStr,
                                                 SpreadsheetVersion ssVersion)
Used to decide whether a name of the form "[A-Z]*[0-9]*" that appears in a formula can be interpreted as a cell reference. Names of that form can be also used for sheets and/or named ranges, and in those circumstances, the question of whether the potential cell reference is valid (in range) becomes important.

Note - that the maximum sheet size varies across Excel versions:

Version | File Format | Last Column | Last Row
97-2003 | BIFF8 | "IV" (2^8) | 65536 (2^14)
2007 | BIFF12 | "XFD" (2^14) | 1048576 (2^20)
POI currently targets BIFF8 (Excel 97-2003), so the following behaviour can be observed for this method:
Input | Result
"A", "1" | true
"a", "111" | true
"A", "65536" | true
"A", "65537" | false
"iv", "1" | true
"IW", "1" | false
"AAA", "1" | false
"a", "111" | true
"Sheet", "1" | false

Parameters:
colStr - a string of only letter characters
rowStr - a string of only digit characters
Returns:
true if the row and col parameters are within range of a BIFF8 spreadsheet.

isColumnWithnRange

public static boolean isColumnWithnRange(java.lang.String colStr,
                                         SpreadsheetVersion ssVersion)

isRowWithnRange

public static boolean isRowWithnRange(java.lang.String rowStr,
                                      SpreadsheetVersion ssVersion)

convertNumToColString

public static java.lang.String convertNumToColString(int col)
Takes in a 0-based base-10 column and returns a ALPHA-26 representation. eg column #3 -> D

formatAsString

public java.lang.String formatAsString()
Example return values:
Result | Comment
A1 | Cell reference without sheet
Sheet1!A1 | Standard sheet name
'O''Brien''s Sales'!A1' | Sheet name with special characters

Returns:
the text representation of this cell reference as it would appear in a formula.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getCellRefParts

public java.lang.String[] getCellRefParts()
Returns the three parts of the cell reference, the Sheet name (or null if none supplied), the 1 based row number, and the A based column letter. This will not include any markers for absolute references, so use formatAsString() to properly turn references into strings.

equals

public boolean equals(java.lang.Object o)
Checks whether this cell reference is equal to another object.

Two cells references are assumed to be equal if their string representations (formatAsString() are equal.

Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellReference.NameType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.ss.util
Enum CellReference.NameType

java.lang.Object
    extended by  java.lang.Enum<CellReference.NameType>
        extended by  org.apache.poi.ss.util.CellReference.NameType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<CellReference.NameType>
Enclosing class:
CellReference
public static enum CellReference.NameType
extends java.lang.Enum<CellReference.NameType>

Used to classify identifiers found in formulas as cell references or not.

Enum Constant Summary
BAD_CELL_OR_NAMED_RANGE
CELL
COLUMN
NAMED_RANGE
ROW
Method Summary
static CellReference.NameType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CellReference.NameType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

CELL

public static final CellReference.NameType CELL

NAMED_RANGE

public static final CellReference.NameType NAMED_RANGE

COLUMN

public static final CellReference.NameType COLUMN

ROW

public static final CellReference.NameType ROW

BAD_CELL_OR_NAMED_RANGE

public static final CellReference.NameType BAD_CELL_OR_NAMED_RANGE
Method Detail

values

public static CellReference.NameType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (CellReference.NameType c : CellReference.NameType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static CellReference.NameType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


CellUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class CellUtil

java.lang.Object
    extended by  org.apache.poi.ss.util.CellUtil

public final class CellUtil
extends java.lang.Object

Various utility functions that make working with a cells and rows easier. The various methods that deal with style's allow you to create your CellStyles as you need them. When you apply a style change to a cell, the code will attempt to see if a style already exists that meets your needs. If not, then it will create a new style. This is to prevent creating too many styles. there is an upper limit in Excel on the number of styles that can be supported.

Author:
Eric Pugh epugh@upstate.com, (secondary) Avinash Kewalramani akewalramani@accelrys.com

Field Summary
static java.lang.String | ALIGNMENT
static java.lang.String | BORDER_BOTTOM
static java.lang.String | BORDER_LEFT
static java.lang.String | BORDER_RIGHT
static java.lang.String | BORDER_TOP
static java.lang.String | BOTTOM_BORDER_COLOR
static java.lang.String | DATA_FORMAT
static java.lang.String | FILL_BACKGROUND_COLOR
static java.lang.String | FILL_FOREGROUND_COLOR
static java.lang.String | FILL_PATTERN
static java.lang.String | FONT
static java.lang.String | HIDDEN
static java.lang.String | INDENTION
static java.lang.String | LEFT_BORDER_COLOR
static java.lang.String | LOCKED
static java.lang.String | RIGHT_BORDER_COLOR
static java.lang.String | ROTATION
static java.lang.String | TOP_BORDER_COLOR
static java.lang.String | VERTICAL_ALIGNMENT
static java.lang.String | WRAP_TEXT
Method Summary
static Cell | createCell(Row row, int column, java.lang.String value) Create a cell, and give it a value.
static Cell | createCell(Row row, int column, java.lang.String value, CellStyle style) Creates a cell, gives it a value, and applies a style if provided
static Cell | getCell(Row row, int columnIndex) Get a specific cell from a row.
static Row | getRow(int rowIndex, Sheet sheet) Get a row from the spreadsheet, and create it if it doesn't exist.
static void | setAlignment(Cell cell, Workbook workbook, short align) Take a cell, and align it.
static void | setCellStyleProperty(Cell cell, Workbook workbook, java.lang.String propertyName, java.lang.Object propertyValue) This method attempt to find an already existing CellStyle that matches what you want the style to be.
static void | setFont(Cell cell, Workbook workbook, Font font) Take a cell, and apply a font to it
static Cell | translateUnicodeValues(Cell cell) Looks for text in the cell that should be unicode, like α and provides the unicode version of it.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALIGNMENT

public static final java.lang.String ALIGNMENT
See Also:
Constant Field Values

BORDER_BOTTOM

public static final java.lang.String BORDER_BOTTOM
See Also:
Constant Field Values

BORDER_LEFT

public static final java.lang.String BORDER_LEFT
See Also:
Constant Field Values

BORDER_RIGHT

public static final java.lang.String BORDER_RIGHT
See Also:
Constant Field Values

BORDER_TOP

public static final java.lang.String BORDER_TOP
See Also:
Constant Field Values

BOTTOM_BORDER_COLOR

public static final java.lang.String BOTTOM_BORDER_COLOR
See Also:
Constant Field Values

DATA_FORMAT

public static final java.lang.String DATA_FORMAT
See Also:
Constant Field Values

FILL_BACKGROUND_COLOR

public static final java.lang.String FILL_BACKGROUND_COLOR
See Also:
Constant Field Values

FILL_FOREGROUND_COLOR

public static final java.lang.String FILL_FOREGROUND_COLOR
See Also:
Constant Field Values

FILL_PATTERN

public static final java.lang.String FILL_PATTERN
See Also:
Constant Field Values

FONT

public static final java.lang.String FONT
See Also:
Constant Field Values

HIDDEN

public static final java.lang.String HIDDEN
See Also:
Constant Field Values

INDENTION

public static final java.lang.String INDENTION
See Also:
Constant Field Values

LEFT_BORDER_COLOR

public static final java.lang.String LEFT_BORDER_COLOR
See Also:
Constant Field Values

LOCKED

public static final java.lang.String LOCKED
See Also:
Constant Field Values

RIGHT_BORDER_COLOR

public static final java.lang.String RIGHT_BORDER_COLOR
See Also:
Constant Field Values

ROTATION

public static final java.lang.String ROTATION
See Also:
Constant Field Values

TOP_BORDER_COLOR

public static final java.lang.String TOP_BORDER_COLOR
See Also:
Constant Field Values

VERTICAL_ALIGNMENT

public static final java.lang.String VERTICAL_ALIGNMENT
See Also:
Constant Field Values

WRAP_TEXT

public static final java.lang.String WRAP_TEXT
See Also:
Constant Field Values
Method Detail

getRow

public static Row getRow(int rowIndex,
                         Sheet sheet)
Get a row from the spreadsheet, and create it if it doesn't exist.

Parameters:
rowIndex - The 0 based row number
sheet - The sheet that the row is part of.
Returns:
The row indicated by the rowCounter

getCell

public static Cell getCell(Row row,
                           int columnIndex)
Get a specific cell from a row. If the cell doesn't exist, then create it.

Parameters:
row - The row that the cell is part of
columnIndex - The column index that the cell is in.
Returns:
The cell indicated by the column.

createCell

public static Cell createCell(Row row,
                              int column,
                              java.lang.String value,
                              CellStyle style)
Creates a cell, gives it a value, and applies a style if provided

Parameters:
row - the row to create the cell in
column - the column index to create the cell in
value - The value of the cell
style - If the style is not null, then set
Returns:
A new Cell

createCell

public static Cell createCell(Row row,
                              int column,
                              java.lang.String value)
Create a cell, and give it a value.

Parameters:
row - the row to create the cell in
column - the column index to create the cell in
value - The value of the cell
Returns:
A new Cell.

setAlignment

public static void setAlignment(Cell cell,
                                Workbook workbook,
                                short align)
Take a cell, and align it.

Parameters:
cell - the cell to set the alignment for
workbook - The workbook that is being worked with.
align - the column alignment to use.
See Also:
for alignment options

setFont

public static void setFont(Cell cell,
                           Workbook workbook,
                           Font font)
Take a cell, and apply a font to it

Parameters:
cell - the cell to set the alignment for
workbook - The workbook that is being worked with.
font - The Font that you want to set...

setCellStyleProperty

public static void setCellStyleProperty(Cell cell,
                                        Workbook workbook,
                                        java.lang.String propertyName,
                                        java.lang.Object propertyValue)
This method attempt to find an already existing CellStyle that matches what you want the style to be. If it does not find the style, then it creates a new one. If it does create a new one, then it applies the propertyName and propertyValue to the style. This is necessary because Excel has an upper limit on the number of Styles that it supports.

Parameters:
workbook - The workbook that is being worked with.
propertyName - The name of the property that is to be changed.
propertyValue - The value of the property that is to be changed.
cell - The cell that needs it's style changes

translateUnicodeValues

public static Cell translateUnicodeValues(Cell cell)
Looks for text in the cell that should be unicode, like α and provides the unicode version of it.

Parameters:
cell - The cell to check for unicode values
Returns:
translated to unicode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateFormatConverter.DateFormatTokenizer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class DateFormatConverter.DateFormatTokenizer

java.lang.Object
    extended by  org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer
Enclosing class:
DateFormatConverter
public static class DateFormatConverter.DateFormatTokenizer
extends java.lang.Object

Constructor Summary
DateFormatConverter.DateFormatTokenizer(java.lang.String format)
Method Summary
java.lang.String | getNextToken()
static java.lang.String[] | tokenize(java.lang.String format)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DateFormatConverter.DateFormatTokenizer

public DateFormatConverter.DateFormatTokenizer(java.lang.String format)
Method Detail

getNextToken

public java.lang.String getNextToken()

tokenize

public static java.lang.String[] tokenize(java.lang.String format)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateFormatConverter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class DateFormatConverter

java.lang.Object
    extended by  org.apache.poi.ss.util.DateFormatConverter

public class DateFormatConverter
extends java.lang.Object

Convert java DateFormat patterns into Excel custom number formats. For example, to format a date in excel using the "dd MMMM, yyyy" pattern and Japanese locale, use the following code:

      // returns "[$-0411]dd MMMM, yyyy;@" where the [$-0411] prefix tells Excel to use the Japanese locale
      String excelFormatPattern = DateFormatConverter.convert(Locale.JAPANESE, "dd MMMM, yyyy");

      CellStyle cellStyle = workbook.createCellStyle();

      DataFormat poiFormat = workbook.createDataFormat();
      cellStyle.setDataFormat(poiFormat.getFormat(excelFormatPattern));
      cell.setCellValue(new Date());
      cell.setCellStyle(cellStyle);  // formats date as '2012?3?17?'

Nested Class Summary
static class DateFormatConverter.DateFormatTokenizer
Constructor Summary
DateFormatConverter()
Method Summary
static java.lang.String | convert(java.util.Locale locale, java.text.DateFormat df)
static java.lang.String | convert(java.util.Locale locale, java.lang.String format)
static java.lang.String | getJavaDatePattern(int style, java.util.Locale locale)
static java.lang.String | getJavaDateTimePattern(int style, java.util.Locale locale)
static java.lang.String | getJavaTimePattern(int style, java.util.Locale locale)
static java.lang.String | getPrefixForLocale(java.util.Locale locale)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DateFormatConverter

public DateFormatConverter()
Method Detail

getPrefixForLocale

public static java.lang.String getPrefixForLocale(java.util.Locale locale)

convert

public static java.lang.String convert(java.util.Locale locale,
                                       java.text.DateFormat df)

convert

public static java.lang.String convert(java.util.Locale locale,
                                       java.lang.String format)

getJavaDatePattern

public static java.lang.String getJavaDatePattern(int style,
                                                  java.util.Locale locale)

getJavaTimePattern

public static java.lang.String getJavaTimePattern(int style,
                                                  java.util.Locale locale)

getJavaDateTimePattern

public static java.lang.String getJavaDateTimePattern(int style,
                                                      java.util.Locale locale)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ImageUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class ImageUtils

java.lang.Object
    extended by  org.apache.poi.ss.util.ImageUtils

public class ImageUtils
extends java.lang.Object

Author:
Yegor Kozlov

Field Summary
static int PIXEL_DPI
Constructor Summary
ImageUtils()
Method Summary
static java.awt.Dimension | getImageDimension(java.io.InputStream is, int type) Return the dimension of this image
static int[] | getResolution(javax.imageio.ImageReader r) The metadata of PNG and JPEG can contain the width of a pixel in millimeters.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PIXEL_DPI

public static final int PIXEL_DPI
See Also:
Constant Field Values
Constructor Detail

ImageUtils

public ImageUtils()
Method Detail

getImageDimension

public static java.awt.Dimension getImageDimension(java.io.InputStream is,
                                                   int type)
Return the dimension of this image

Parameters:
is - the stream containing the image data
type - type of the picture: Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PNG or Workbook.PICTURE_TYPE_DIB
Returns:
image dimension in pixels

getResolution

public static int[] getResolution(javax.imageio.ImageReader r)
                           throws java.io.IOException
The metadata of PNG and JPEG can contain the width of a pixel in millimeters. Return the the "effective" dpi calculated as 25.4/HorizontalPixelSize and 25.4/VerticalPixelSize. Where 25.4 is the number of mm in inch.

Returns:
array of two elements: {horisontalPdi, verticalDpi}. {96, 96} is the default.
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumberComparer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class NumberComparer

java.lang.Object
    extended by  org.apache.poi.ss.util.NumberComparer

public final class NumberComparer
extends java.lang.Object

Excel compares numbers using different rules to those of java, so Double.compare(double, double) won't do.

Author:
Josh Micich

Constructor Summary
NumberComparer()
Method Summary
static int compare(double a, double b)
This class attempts to reproduce Excel's behaviour for comparing numbers.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NumberComparer

public NumberComparer()
Method Detail

compare

public static int compare(double a,
                          double b)
This class attempts to reproduce Excel's behaviour for comparing numbers. Results are mostly the same as those from Double.compare(double, double) but with some rounding. For numbers that are very close, this code converts to a format having 15 decimal digits of precision and a decimal exponent, before completing the comparison.

In Excel formula evaluation, expressions like "(0.06-0.01)=0.05" evaluate to "TRUE" even though the equivalent java expression is false. In examples like this, Excel achieves the effect by having additional logic for comparison operations.

Note - Excel also gives special treatment to expressions like "0.06-0.01-0.05" which evaluates to "0" (in java, rounding anomalies give a result of 6.9E-18). The special behaviour here is for different reasons to the example above: If the last operator in a cell formula is '+' or '-' and the result is less than 250 times smaller than first operand, the result is rounded to zero. Needless to say, the two rules are not consistent and it is relatively easy to find examples that satisfy
"A=B" is "TRUE" but "A-B" is not "0"
and
"A=B" is "FALSE" but "A-B" is "0"

This rule (for rounding the result of a final addition or subtraction), has not been implemented in POI (as of Jul-2009).

Returns:
negative, 0, or positive according to the standard Excel comparison of values a and b.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumberToTextConverter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class NumberToTextConverter

java.lang.Object
    extended by  org.apache.poi.ss.util.NumberToTextConverter

public final class NumberToTextConverter
extends java.lang.Object

Excel converts numbers to text with different rules to those of java, so Double.toString(value) won't do.

  • No more than 15 significant figures are output (java does 18).
  • The sign char for the exponent is included even if positive
  • Special values (NaN and Infinity) get rendered like the ordinary number that the bit pattern represents.
  • Denormalised values (between ±2-1074 and ±2-1022 are displayed as "0"
IEEE 64-bit Double Rendering Comparison
Raw bits | Java | Excel
0x0000000000000000L | 0.0 | 0
0x3FF0000000000000L | 1.0 | 1
0x3FF00068DB8BAC71L | 1.0001 | 1.0001
0x4087A00000000000L | 756.0 | 756
0x401E3D70A3D70A3DL | 7.56 | 7.56
0x405EDD3C07FB4C99L | 123.45678901234568 | 123.456789012346
0x4132D687E3DF2180L | 1234567.8901234567 | 1234567.89012346
0x3EE9E409302678BAL | 1.2345678901234568E-5 | 1.23456789012346E-05
0x3F202E85BE180B74L | 1.2345678901234567E-4 | 0.000123456789012346
0x3F543A272D9E0E51L | 0.0012345678901234567 | 0.00123456789012346
0x3F8948B0F90591E6L | 0.012345678901234568 | 0.0123456789012346
0x3EE9E409301B5A02L | 1.23456789E-5 | 0.0000123456789
0x3E6E7D05BDABDE50L | 5.6789012345E-8 | 0.000000056789012345
0x3E6E7D05BDAD407EL | 5.67890123456E-8 | 5.67890123456E-08
0x3E6E7D06029F18BEL | 5.678902E-8 | 0.00000005678902
0x2BCB5733CB32AE6EL | 9.999999999999123E-98 | 9.99999999999912E-98
0x2B617F7D4ED8C59EL | 1.0000000000001235E-99 | 1.0000000000001E-99
0x0036319916D67853L | 1.2345678901234578E-307 | 1.2345678901235E-307
0x359DEE7A4AD4B81FL | 2.0E-50 | 2E-50
0x41678C29DCD6E9E0L | 1.2345678901234567E7 | 12345678.9012346
0x42A674E79C5FE523L | 1.2345678901234568E13 | 12345678901234.6
0x42DC12218377DE6BL | 1.2345678901234567E14 | 123456789012346
0x43118B54F22AEB03L | 1.2345678901234568E15 | 1234567890123460
0x43E56A95319D63E1L | 1.2345678901234567E19 | 12345678901234600000
0x441AC53A7E04BCDAL | 1.2345678901234568E20 | 1.23456789012346E+20
0xC3E56A95319D63E1L | -1.2345678901234567E19 | -12345678901234600000
0xC41AC53A7E04BCDAL | -1.2345678901234568E20 | -1.23456789012346E+20
0x54820FE0BA17F46DL | 1.2345678901234577E99 | 1.2345678901235E+99
0x54B693D8E89DF188L | 1.2345678901234576E100 | 1.2345678901235E+100
0x4A611B0EC57E649AL | 2.0E50 | 2E+50
0x7FEFFFFFFFFFFFFFL | 1.7976931348623157E308 | 1.7976931348623E+308
0x0010000000000000L | 2.2250738585072014E-308 | 2.2250738585072E-308
0x000FFFFFFFFFFFFFL | 2.225073858507201E-308 | 0
0x0000000000000001L | 4.9E-324 | 0
0x7FF0000000000000L | Infinity | 1.7976931348623E+308
0xFFF0000000000000L | -Infinity | 1.7976931348623E+308
0x441AC7A08EAD02F2L | 1.234999999999999E20 | 1.235E+20
0x40FE26BFFFFFFFF9L | 123499.9999999999 | 123500
0x3E4A857BFB2F2809L | 1.234999999999999E-8 | 0.00000001235
0x3BCD291DEF868C89L | 1.234999999999999E-20 | 1.235E-20
0x444B1AE4D6E2EF4FL | 9.999999999999999E20 | 1E+21
0x412E847FFFFFFFFFL | 999999.9999999999 | 1000000
0x3E45798EE2308C39L | 9.999999999999999E-9 | 0.00000001
0x3C32725DD1D243ABL | 9.999999999999999E-19 | 0.000000000000000001
0x3BFD83C94FB6D2ABL | 9.999999999999999E-20 | 1E-19
0xC44B1AE4D6E2EF4FL | -9.999999999999999E20 | -1E+21
0xC12E847FFFFFFFFFL | -999999.9999999999 | -1000000
0xBE45798EE2308C39L | -9.999999999999999E-9 | -0.00000001
0xBC32725DD1D243ABL | -9.999999999999999E-19 | -0.000000000000000001
0xBBFD83C94FB6D2ABL | -9.999999999999999E-20 | -1E-19
0xFFFF0420003C0000L | NaN | 3.484840871308E+308
0x7FF8000000000000L | NaN | 2.6965397022935E+308
0x7FFF0420003C0000L | NaN | 3.484840871308E+308
0xFFF8000000000000L | NaN | 2.6965397022935E+308
0xFFFF0AAAAAAAAAAAL | NaN | 3.4877119413344E+308
0x7FF80AAAAAAAAAAAL | NaN | 2.7012211948322E+308
0xFFFFFFFFFFFFFFFFL | NaN | 3.5953862697246E+308
0x7FFFFFFFFFFFFFFFL | NaN | 3.5953862697246E+308
0xFFF7FFFFFFFFFFFFL | NaN | 2.6965397022935E+308
Note: Excel has inconsistent rules for the following numeric operations:
  • Conversion to string (as handled here)
  • Rendering numerical quantities in the cell grid.
  • Conversion from text
  • General arithmetic
Excel's text to number conversion is not a true inverse of this operation. The allowable ranges are different. Some numbers that don't correctly convert to text actually do get handled properly when used in arithmetic evaluations.

Author:
Josh Micich

Method Summary
static java.lang.String toText(double value)
          Converts the supplied value to the text representation that Excel would give if the value were to appear in an unformatted cell, or as a literal number in a formula.
Note - the results from this method differ slightly from those of Double.toString() In some special cases Excel behaves quite differently.

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

toText

public static java.lang.String toText(double value)
Converts the supplied value to the text representation that Excel would give if the value were to appear in an unformatted cell, or as a literal number in a formula.
Note - the results from this method differ slightly from those of Double.toString() In some special cases Excel behaves quite differently. This function attempts to reproduce those results.

Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.util
Classes
AreaReference
CellRangeAddress
CellRangeAddressBase
CellRangeAddressList
CellReference
CellUtil
DateFormatConverter
DateFormatConverter.DateFormatTokenizer
ImageUtils
NumberComparer
NumberToTextConverter
Region
RegionUtil
SheetBuilder
SheetReferences
SheetUtil
SSCellRange
WorkbookUtil
Enums
CellReference.NameType


org.apache.poi.ss.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.util

Class Summary
AreaReference |
CellRangeAddress | See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellRangeAddressBase | See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address' Common subclass of 8-bit and 16-bit versions
CellRangeAddressList | Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas).
CellReference |
CellUtil | Various utility functions that make working with a cells and rows easier.
DateFormatConverter | Convert java DateFormat patterns into Excel custom number formats.
DateFormatConverter.DateFormatTokenizer |
ImageUtils |
NumberComparer | Excel compares numbers using different rules to those of java, so Double.compare(double, double) won't do.
NumberToTextConverter | Excel converts numbers to text with different rules to those of java, so Double.toString(value) won't do.
Region | Deprecated. (Aug-2008) use CellRangeAddress
RegionUtil | Various utility functions that make working with a region of cells easier.
SheetBuilder | Class SheetBuilder provides an easy way of building workbook sheets from 2D array of Objects.
SheetReferences | Holds a collection of Sheet names and their associated reference numbers.
SheetUtil | Helper methods for when working with Usermodel sheets
SSCellRange<K extends Cell> | For POI internal use only
WorkbookUtil | Helper methods for when working with Usermodel Workbooks

Enum Summary
CellReference.NameType Used to classify identifiers found in formulas as cell references or not.


org.apache.poi.ss.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.util.AreaReference
    • org.apache.poi.ss.util.CellRangeAddressBase
      • org.apache.poi.ss.util.CellRangeAddress
    • org.apache.poi.ss.util.CellRangeAddressList
    • org.apache.poi.ss.util.CellReference
    • org.apache.poi.ss.util.CellUtil
    • org.apache.poi.ss.util.DateFormatConverter
    • org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer
    • org.apache.poi.ss.util.ImageUtils
    • org.apache.poi.ss.util.NumberComparer
    • org.apache.poi.ss.util.NumberToTextConverter
    • org.apache.poi.ss.util.Region (implements java.lang.Comparable<T>)
    • org.apache.poi.ss.util.RegionUtil
    • org.apache.poi.ss.util.SheetBuilder
    • org.apache.poi.ss.util.SheetReferences
    • org.apache.poi.ss.util.SheetUtil
    • org.apache.poi.ss.util.SSCellRange<K> (implements org.apache.poi.ss.usermodel.CellRange<C>)
    • org.apache.poi.ss.util.WorkbookUtil

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.ss.util.CellReference.NameType


Uses of Package org.apache.poi.ss.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.util

Packages that use org.apache.poi.ss.util
org.apache.poi.hssf.converter |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.usermodel |
org.apache.poi.ss.usermodel.charts |
org.apache.poi.ss.util |
org.apache.poi.ss.util.cellwalk |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.helpers |

Classes in org.apache.poi.ss.util used by org.apache.poi.hssf.converter
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Classes in org.apache.poi.ss.util used by org.apache.poi.hssf.model
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Classes in org.apache.poi.ss.util used by org.apache.poi.hssf.record
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellRangeAddressList
Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas).

Classes in org.apache.poi.ss.util used by org.apache.poi.hssf.record.aggregates
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellReference

Classes in org.apache.poi.ss.util used by org.apache.poi.hssf.record.cf
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Classes in org.apache.poi.ss.util used by org.apache.poi.hssf.usermodel
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellRangeAddressBase
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Common subclass of 8-bit and 16-bit versions

CellRangeAddressList
Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas).
Region
Deprecated. (Aug-2008) use CellRangeAddress

Classes in org.apache.poi.ss.util used by org.apache.poi.hssf.util
AreaReference
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellRangeAddressBase
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Common subclass of 8-bit and 16-bit versions

CellRangeAddressList
Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas).
CellReference
Region
Deprecated. (Aug-2008) use CellRangeAddress

Classes in org.apache.poi.ss.util used by org.apache.poi.ss.formula
CellReference

Classes in org.apache.poi.ss.util used by org.apache.poi.ss.formula.ptg
AreaReference
CellReference

Classes in org.apache.poi.ss.util used by org.apache.poi.ss.usermodel
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellRangeAddressList
Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas).

Classes in org.apache.poi.ss.util used by org.apache.poi.ss.usermodel.charts
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Classes in org.apache.poi.ss.util used by org.apache.poi.ss.util
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellRangeAddressBase
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Common subclass of 8-bit and 16-bit versions

CellReference
CellReference.NameType
Used to classify identifiers found in formulas as cell references or not.
SheetBuilder
Class SheetBuilder provides an easy way of building workbook sheets from 2D array of Objects.
SSCellRange
For POI internal use only

Classes in org.apache.poi.ss.util used by org.apache.poi.ss.util.cellwalk
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Classes in org.apache.poi.ss.util used by org.apache.poi.xssf.streaming
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Classes in org.apache.poi.ss.util used by org.apache.poi.xssf.usermodel
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'
CellRangeAddressList
Implementation of the cell range address lists,like is described in OpenOffice.org's Excel Documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address List' In BIFF8 there is a common way to store absolute cell range address lists in several records (not formulas).
CellReference

Classes in org.apache.poi.ss.util used by org.apache.poi.xssf.usermodel.helpers
CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Region

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class Region

java.lang.Object
    extended by  org.apache.poi.ss.util.Region
All Implemented Interfaces:
java.lang.Comparable<Region>
Direct Known Subclasses:
Region
Deprecated. (Aug-2008) use CellRangeAddress

public class Region
extends java.lang.Object
implements java.lang.Comparable<Region>

Represents a from/to row/col square. This is a object primitive that can be used to represent row,col - row,col just as one would use String to represent a string of characters. Its really only useful for HSSF though.

Author:
Andrew C. Oliver acoliver at apache dot org

Constructor Summary
Region()
Deprecated. Creates a new instance of Region (0,0 - 0,0)
Region(int rowFrom, short colFrom, int rowTo, short colTo)
Deprecated.
Region(java.lang.String ref)
Deprecated.
Method Summary
int | compareTo(Region r) Deprecated. Compares that the given region is the same less than or greater than this region.
boolean | contains(int row, short col) Deprecated. Answers: "is the row/column inside this range?"
static Region[] | convertCellRangesToRegions(CellRangeAddress[] cellRanges) Deprecated. Convert a List of CellRange objects to an array of regions
static CellRangeAddress[] | convertRegionsToCellRanges(Region[] regions) Deprecated.
static CellRangeAddress | convertToCellRangeAddress(Region r) Deprecated.
boolean | equals(Region r) Deprecated.
int | getArea() Deprecated.
short | getColumnFrom() Deprecated. get the upper left hand corner column number
short | getColumnTo() Deprecated. get the lower right hand corner column number
java.lang.String | getRegionRef() Deprecated.
int | getRowFrom() Deprecated. get the upper left hand corner row number
int | getRowTo() Deprecated. get the lower right hand corner row number
void | setColumnFrom(short colFrom) Deprecated. set the upper left hand corner column number
void | setColumnTo(short colTo) Deprecated. set the lower right hand corner column number
void | setRowFrom(int rowFrom) Deprecated. set the upper left hand corner row number
void | setRowTo(int rowTo) Deprecated. get the lower right hand corner row number
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Region

public Region()
Deprecated.
Creates a new instance of Region (0,0 - 0,0)

Region

public Region(int rowFrom,
              short colFrom,
              int rowTo,
              short colTo)
Deprecated.

Region

public Region(java.lang.String ref)
Deprecated.
Method Detail

getColumnFrom

public short getColumnFrom()
Deprecated.
get the upper left hand corner column number

Returns:
column number for the upper left hand corner

getRowFrom

public int getRowFrom()
Deprecated.
get the upper left hand corner row number

Returns:
row number for the upper left hand corner

getColumnTo

public short getColumnTo()
Deprecated.
get the lower right hand corner column number

Returns:
column number for the lower right hand corner

getRowTo

public int getRowTo()
Deprecated.
get the lower right hand corner row number

Returns:
row number for the lower right hand corner

setColumnFrom

public void setColumnFrom(short colFrom)
Deprecated.
set the upper left hand corner column number

Parameters:
colFrom - column number for the upper left hand corner

setRowFrom

public void setRowFrom(int rowFrom)
Deprecated.
set the upper left hand corner row number

Parameters:
rowFrom - row number for the upper left hand corner

setColumnTo

public void setColumnTo(short colTo)
Deprecated.
set the lower right hand corner column number

Parameters:
colTo - column number for the lower right hand corner

setRowTo

public void setRowTo(int rowTo)
Deprecated.
get the lower right hand corner row number

Parameters:
rowTo - row number for the lower right hand corner

contains

public boolean contains(int row,
                        short col)
Deprecated.
Answers: "is the row/column inside this range?"

Returns:
true if the cell is in the range and false if it is not

equals

public boolean equals(Region r)
Deprecated.

compareTo

public int compareTo(Region r)
Deprecated.
Compares that the given region is the same less than or greater than this region. If any regional coordiant passed in is less than this regions coordinants then a positive integer is returned. Otherwise a negative integer is returned.

Specified by:
compareTo in interface java.lang.Comparable<Region>
Parameters:
r - region
See Also:
Comparable.compareTo(Object)

getArea

public int getArea()
Deprecated.
Returns:
the size of the region (number of cells in the area).

convertCellRangesToRegions

public static Region[] convertCellRangesToRegions(CellRangeAddress[] cellRanges)
Deprecated.
Convert a List of CellRange objects to an array of regions

Parameters:
cellRanges - list of CellRange objects
Returns:
regions

convertRegionsToCellRanges

public static CellRangeAddress[] convertRegionsToCellRanges(Region[] regions)
Deprecated.

convertToCellRangeAddress

public static CellRangeAddress convertToCellRangeAddress(Region r)
Deprecated.

getRegionRef

public java.lang.String getRegionRef()
Deprecated.
Returns:
the string reference for this region
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RegionUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class RegionUtil

java.lang.Object
    extended by  org.apache.poi.ss.util.RegionUtil

public final class RegionUtil
extends java.lang.Object

Various utility functions that make working with a region of cells easier.

Author:
Eric Pugh epugh@upstate.com, (secondary) Avinash Kewalramani akewalramani@accelrys.com

Method Summary
static void | setBorderBottom(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | setBorderLeft(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | setBorderRight(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderRight attribute of the RegionUtil object
static void | setBorderTop(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | setBottomBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the bottomBorderColor attribute of the RegionUtil object
static void | setLeftBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the leftBorderColor attribute of the RegionUtil object
static void | setRightBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the rightBorderColor attribute of the RegionUtil object
static void | setTopBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the topBorderColor attribute of the RegionUtil object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

setBorderLeft

public static void setBorderLeft(int border,
                                 CellRangeAddress region,
                                 Sheet sheet,
                                 Workbook workbook)
Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setLeftBorderColor

public static void setLeftBorderColor(int color,
                                      CellRangeAddress region,
                                      Sheet sheet,
                                      Workbook workbook)
Sets the leftBorderColor attribute of the RegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBorderRight

public static void setBorderRight(int border,
                                  CellRangeAddress region,
                                  Sheet sheet,
                                  Workbook workbook)
Sets the borderRight attribute of the RegionUtil object

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setRightBorderColor

public static void setRightBorderColor(int color,
                                       CellRangeAddress region,
                                       Sheet sheet,
                                       Workbook workbook)
Sets the rightBorderColor attribute of the RegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBorderBottom

public static void setBorderBottom(int border,
                                   CellRangeAddress region,
                                   Sheet sheet,
                                   Workbook workbook)
Sets the borderBottom attribute of the RegionUtil object

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBottomBorderColor

public static void setBottomBorderColor(int color,
                                        CellRangeAddress region,
                                        Sheet sheet,
                                        Workbook workbook)
Sets the bottomBorderColor attribute of the RegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setBorderTop

public static void setBorderTop(int border,
                                CellRangeAddress region,
                                Sheet sheet,
                                Workbook workbook)
Sets the borderBottom attribute of the RegionUtil object

Parameters:
border - The new border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.

setTopBorderColor

public static void setTopBorderColor(int color,
                                     CellRangeAddress region,
                                     Sheet sheet,
                                     Workbook workbook)
Sets the topBorderColor attribute of the RegionUtil object

Parameters:
color - The color of the border
region - The region that should have the border
workbook - The workbook that the region is on.
sheet - The sheet that the region is on.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SheetBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class SheetBuilder

java.lang.Object
    extended by  org.apache.poi.ss.util.SheetBuilder

public class SheetBuilder
extends java.lang.Object

Class SheetBuilder provides an easy way of building workbook sheets from 2D array of Objects. It can be used in test cases to improve code readability or in Swing applications with tables.

Author:
Roman Kashitsyn

Constructor Summary
SheetBuilder(Workbook workbook, java.lang.Object[][] cells)
Method Summary
Sheet | build() Builds sheet from parent workbook and 2D array with cell values.
boolean | getCreateEmptyCells() Returns true if null array elements should be treated as empty cells.
SheetBuilder | setCreateEmptyCells(boolean shouldCreateEmptyCells) Specifies if null array elements should be treated as empty cells.
SheetBuilder | setSheetName(java.lang.String sheetName) Specifies name of the sheet to build.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SheetBuilder

public SheetBuilder(Workbook workbook,
                    java.lang.Object[][] cells)
Method Detail

getCreateEmptyCells

public boolean getCreateEmptyCells()
Returns true if null array elements should be treated as empty cells.

Returns:
true if null objects should be treated as empty cells and false otherwise

setCreateEmptyCells

public SheetBuilder setCreateEmptyCells(boolean shouldCreateEmptyCells)
Specifies if null array elements should be treated as empty cells.

Parameters:
shouldCreateEmptyCells - true if null array elements should be treated as empty cells
Returns:
this

setSheetName

public SheetBuilder setSheetName(java.lang.String sheetName)
Specifies name of the sheet to build. If not specified, default name (provided by workbook) will be used instead.

Parameters:
sheetName - sheet name to use
Returns:
this

build

public Sheet build()
Builds sheet from parent workbook and 2D array with cell values. Creates rows anyway (even if row contains only null cells), creates cells if either corresponding array value is not null or createEmptyCells property is true. The conversion is performed in the following way:

  • Numbers become numeric cells.
  • java.util.Date or java.util.Calendar instances become date cells.
  • String with leading '=' char become formulas (leading '=' will be truncated).
  • Other objects become strings via Object.toString() method call.

Returns:
newly created sheet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SheetReferences

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class SheetReferences

java.lang.Object
    extended by  org.apache.poi.ss.util.SheetReferences

public class SheetReferences
extends java.lang.Object

Holds a collection of Sheet names and their associated reference numbers.

Author:
Andrew C. Oliver (acoliver at apache dot org)

Constructor Summary
SheetReferences()
Method Summary
void | addSheetReference(java.lang.String sheetName, int number)
java.lang.String | getSheetName(int number)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SheetReferences

public SheetReferences()
Method Detail

addSheetReference

public void addSheetReference(java.lang.String sheetName,
                              int number)

getSheetName

public java.lang.String getSheetName(int number)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SheetUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class SheetUtil

java.lang.Object
    extended by  org.apache.poi.ss.util.SheetUtil

public class SheetUtil
extends java.lang.Object

Helper methods for when working with Usermodel sheets

Author:
Yegor Kozlov

Constructor Summary
SheetUtil()
Method Summary
static boolean | containsCell(CellRangeAddress cr, int rowIx, int colIx)
static double | getCellWidth(Cell cell, int defaultCharWidth, DataFormatter formatter, boolean useMergedCells) Compute width of a single cell
static double | getColumnWidth(Sheet sheet, int column, boolean useMergedCells) Compute width of a column and return the result
static double | getColumnWidth(Sheet sheet, int column, boolean useMergedCells, int firstRow, int lastRow) Compute width of a column based on a subset of the rows and return the result
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SheetUtil

public SheetUtil()
Method Detail

getCellWidth

public static double getCellWidth(Cell cell,
                                  int defaultCharWidth,
                                  DataFormatter formatter,
                                  boolean useMergedCells)
Compute width of a single cell

Parameters:
cell - the cell whose width is to be calculated
defaultCharWidth - the width of a single character
formatter - formatter used to prepare the text to be measured
useMergedCells - whether to use merged cells
Returns:
the width in pixels

getColumnWidth

public static double getColumnWidth(Sheet sheet,
                                    int column,
                                    boolean useMergedCells)
Compute width of a column and return the result

Parameters:
sheet - the sheet to calculate
column - 0-based index of the column
useMergedCells - whether to use merged cells
Returns:
the width in pixels

getColumnWidth

public static double getColumnWidth(Sheet sheet,
                                    int column,
                                    boolean useMergedCells,
                                    int firstRow,
                                    int lastRow)
Compute width of a column based on a subset of the rows and return the result

Parameters:
sheet - the sheet to calculate
column - 0-based index of the column
useMergedCells - whether to use merged cells
firstRow - 0-based index of the first row to consider (inclusive)
lastRow - 0-based index of the last row to consider (inclusive)
Returns:
the width in pixels

containsCell

public static boolean containsCell(CellRangeAddress cr,
                                   int rowIx,
                                   int colIx)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SSCellRange

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class SSCellRange<K extends Cell>

java.lang.Object
    extended by  org.apache.poi.ss.util.SSCellRange<K>
All Implemented Interfaces:
java.lang.Iterable<K>, CellRange<K>
@Internal
public final class SSCellRange<K extends Cell>
extends java.lang.Object
implements CellRange<K>

For POI internal use only

Author:
Josh Micich

Method Summary
static
<B extends Cell>
SSCellRange<B>
create(int firstRow, int firstColumn, int height, int width, java.util.List<B> flattenedList, java.lang.Class<B> cellClass)
 K getCell(int relativeRowIndex, int relativeColumnIndex)
 K[][] getCells()
 K[] getFlattenedCells()
 int getHeight()
 java.lang.String getReferenceText()
 K getTopLeftCell()
 int getWidth()
 java.util.Iterator<K> iterator()
 int size()
Gets the number of cells in this range.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public static <B extends Cell> SSCellRange<B> create(int firstRow,
                                                     int firstColumn,
                                                     int height,
                                                     int width,
                                                     java.util.List<B> flattenedList,
                                                     java.lang.Class<B> cellClass)

getHeight

public int getHeight()
Specified by:
getHeight in interface CellRange<K extends Cell>

getWidth

public int getWidth()
Specified by:
getWidth in interface CellRange<K extends Cell>

size

public int size()
Description copied from interface: CellRange
Gets the number of cells in this range.

Specified by:
size in interface CellRange<K extends Cell>
Returns:
height * width

getReferenceText

public java.lang.String getReferenceText()
Specified by:
getReferenceText in interface CellRange<K extends Cell>

getTopLeftCell

public K getTopLeftCell()
Specified by:
getTopLeftCell in interface CellRange<K extends Cell>
Returns:
the cell at relative coordinates (0,0). Never null.

getCell

public K getCell(int relativeRowIndex,
                 int relativeColumnIndex)
Specified by:
getCell in interface CellRange<K extends Cell>
Parameters:
relativeRowIndex - must be between 0 and height-1
relativeColumnIndex - must be between 0 and width-1
Returns:
the cell at the specified coordinates. Never null.

getFlattenedCells

public K[] getFlattenedCells()
Specified by:
getFlattenedCells in interface CellRange<K extends Cell>
Returns:
a flattened array of all the cells in this CellRange

getCells

public K[][] getCells()
Specified by:
getCells in interface CellRange<K extends Cell>
Returns:
a 2-D array of all the cells in this CellRange. The first array dimension is the row index (values 0...height-1) and the second dimension is the column index (values 0...width-1)

iterator

public java.util.Iterator<K> iterator()
Specified by:
iterator in interface java.lang.Iterable<K extends Cell>
Specified by:
iterator in interface CellRange<K extends Cell>
Returns:
an Iterator over all cells in this range. Iteration starts with all cells in the first row followed by all cells in the next row, etc.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkbookUtil

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util
Class WorkbookUtil

java.lang.Object
    extended by  org.apache.poi.ss.util.WorkbookUtil

public class WorkbookUtil
extends java.lang.Object

Helper methods for when working with Usermodel Workbooks

Constructor Summary
WorkbookUtil()
Method Summary
static java.lang.String | createSafeSheetName(java.lang.String nameProposal) Creates a valid sheet name, which is conform to the rules.
static java.lang.String | createSafeSheetName(java.lang.String nameProposal, char replaceChar) Creates a valid sheet name, which is conform to the rules.
static void | validateSheetName(java.lang.String sheetName) Validates sheet name.
static void | validateSheetState(int state)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkbookUtil

public WorkbookUtil()
Method Detail

createSafeSheetName

public static final java.lang.String createSafeSheetName(java.lang.String nameProposal)
Creates a valid sheet name, which is conform to the rules. In any case, the result safely can be used for Workbook.setSheetName(int, String).
Rules:
  • never null
  • minimum length is 1
  • maximum length is 31
  • doesn't contain special chars: : 0x0000, 0x0003, / \ ? * ] [
  • Sheet names must not begin or end with ' (apostrophe)
Invalid characters are replaced by one space character ' '.

Parameters:
nameProposal - can be any string, will be truncated if necessary, allowed to be null
Returns:
a valid string, "empty" if to short, "null" if null

createSafeSheetName

public static final java.lang.String createSafeSheetName(java.lang.String nameProposal,
                                                         char replaceChar)
Creates a valid sheet name, which is conform to the rules. In any case, the result safely can be used for Workbook.setSheetName(int, String).
Rules:
  • never null
  • minimum length is 1
  • maximum length is 31
  • doesn't contain special chars: : 0x0000, 0x0003, / \ ? * ] [
  • Sheet names must not begin or end with ' (apostrophe)

Parameters:
nameProposal - can be any string, will be truncated if necessary, allowed to be null
replaceChar - the char to replace invalid characters.
Returns:
a valid string, "empty" if to short, "null" if null

validateSheetName

public static void validateSheetName(java.lang.String sheetName)
Validates sheet name.

The character count MUST be greater than or equal to 1 and less than or equal to 31. The string MUST NOT contain the any of the following characters:

  • 0x0000
  • 0x0003
  • colon (:)
  • backslash (\)
  • asterisk (*)
  • question mark (?)
  • forward slash (/)
  • opening square bracket ([)
  • closing square bracket (])
The string MUST NOT begin or end with the single quote (') character.

Parameters:
sheetName - the name to validate

validateSheetState

public static void validateSheetState(int state)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CellHandler

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util.cellwalk
Interface CellHandler

public interface CellHandler

Represents callback for CellWalk traverse method.

Author:
Roman Kashitsyn

Method Summary
 void onCell(Cell cell, CellWalkContext ctx)

Method Detail

onCell

void onCell(Cell cell,
            CellWalkContext ctx)
Parameters:
cell - current cell
ctx - information about invokation context
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CellWalk

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util.cellwalk
Class CellWalk

java.lang.Object
    extended by  org.apache.poi.ss.util.cellwalk.CellWalk

public class CellWalk
extends java.lang.Object

Traverse cell range.

Author:
Roman Kashitsyn

Constructor Summary
CellWalk(Sheet sheet, CellRangeAddress range)
Method Summary
boolean | isTraverseEmptyCells() Should we call handler on empty (blank) cells.
void | setTraverseEmptyCells(boolean traverseEmptyCells) Sets the traverseEmptyCells property.
void | traverse(CellHandler handler) Traverse cell range from top left to bottom right cell.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CellWalk

public CellWalk(Sheet sheet,
                CellRangeAddress range)
Method Detail

isTraverseEmptyCells

public boolean isTraverseEmptyCells()
Should we call handler on empty (blank) cells. Default is false.

Returns:
true if handler should be called on empty (blank) cells, false otherwise.

setTraverseEmptyCells

public void setTraverseEmptyCells(boolean traverseEmptyCells)
Sets the traverseEmptyCells property.

Parameters:
traverseEmptyCells - new property value

traverse

public void traverse(CellHandler handler)
Traverse cell range from top left to bottom right cell.

Parameters:
handler - handler to call on each appropriate cell
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CellWalkContext

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.ss.util.cellwalk
Interface CellWalkContext

public interface CellWalkContext

Author:
Roman Kashitsyn

Method Summary
int | getColumnNumber() Returns number of current column.
long | getOrdinalNumber() Returns ordinal number of cell in range.
int | getRowNumber() Returns number of current row.

Method Detail

getOrdinalNumber

long getOrdinalNumber()
Returns ordinal number of cell in range. Numeration starts from top left cell and ends at bottom right cell. Here is a brief example (number in cell is it's ordinal number):
1 | 2
3 | 4

Returns:
ordinal number of current cell

getRowNumber

int getRowNumber()
Returns number of current row.

Returns:
number of current row

getColumnNumber

int getColumnNumber()
Returns number of current column.

Returns:
number of current column
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.ss.util.cellwalk
Interfaces
CellHandler
CellWalkContext
Classes
CellWalk


org.apache.poi.ss.util.cellwalk

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.ss.util.cellwalk

Interface Summary
CellHandler | Represents callback for CellWalk traverse method.
CellWalkContext |

Class Summary
CellWalk Traverse cell range.


org.apache.poi.ss.util.cellwalk Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.ss.util.cellwalk

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.util.cellwalk.CellWalk

Interface Hierarchy

  • org.apache.poi.ss.util.cellwalk.CellHandler
  • org.apache.poi.ss.util.cellwalk.CellWalkContext


Uses of Package org.apache.poi.ss.util.cellwalk

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.ss.util.cellwalk

Packages that use org.apache.poi.ss.util.cellwalk
org.apache.poi.ss.util.cellwalk

Classes in org.apache.poi.ss.util.cellwalk used by org.apache.poi.ss.util.cellwalk
CellHandler
Represents callback for CellWalk traverse method.
CellWalkContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.util.cellwalk.CellHandler

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.util.cellwalk.CellHandler

Packages that use CellHandler
org.apache.poi.ss.util.cellwalk

Uses of CellHandler in org.apache.poi.ss.util.cellwalk

Methods in org.apache.poi.ss.util.cellwalk with parameters of type CellHandler
 void CellWalk.traverse(CellHandler handler)
Traverse cell range from top left to bottom right cell.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.cellwalk.CellWalk

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.cellwalk.CellWalk

No usage of org.apache.poi.ss.util.cellwalk.CellWalk

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.ss.util.cellwalk.CellWalkContext

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.ss.util.cellwalk.CellWalkContext

Packages that use CellWalkContext
org.apache.poi.ss.util.cellwalk

Uses of CellWalkContext in org.apache.poi.ss.util.cellwalk

Methods in org.apache.poi.ss.util.cellwalk with parameters of type CellWalkContext
 void CellHandler.onCell(Cell cell, CellWalkContext ctx)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.AreaReference

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.AreaReference

Packages that use AreaReference
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.util |

Uses of AreaReference in org.apache.poi.hssf.util

Subclasses of AreaReference in org.apache.poi.hssf.util
 class AreaReference

Uses of AreaReference in org.apache.poi.ss.formula.ptg

Constructors in org.apache.poi.ss.formula.ptg with parameters of type AreaReference
Area2DPtgBase(AreaReference ar)
Area3DPtg(AreaReference arearef, int externIdx)
AreaPtg(AreaReference areaRef)
AreaPtgBase(AreaReference ar)

Uses of AreaReference in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return AreaReference
static AreaReference[] | AreaReference.generateContiguous(java.lang.String reference) Takes a non-contiguous area reference, and returns an array of contiguous area references.
static AreaReference | AreaReference.getWholeColumn(java.lang.String start, java.lang.String end)
static AreaReference | AreaReference.getWholeRow(java.lang.String start, java.lang.String end)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.CellRangeAddress

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.CellRangeAddress

Packages that use CellRangeAddress
org.apache.poi.hssf.converter |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.usermodel |
org.apache.poi.ss.usermodel.charts |
org.apache.poi.ss.util |
org.apache.poi.ss.util.cellwalk |
org.apache.poi.xssf.streaming |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.helpers |

Uses of CellRangeAddress in org.apache.poi.hssf.converter

Methods in org.apache.poi.hssf.converter that return CellRangeAddress
static CellRangeAddress[][] | ExcelToHtmlUtils.buildMergedRangesMap(HSSFSheet sheet) Creates a map (i.e.
static CellRangeAddress | AbstractExcelUtils.getMergedRange(CellRangeAddress[][] mergedRanges, int rowNumber, int columnNumber)

Methods in org.apache.poi.hssf.converter with parameters of type CellRangeAddress
static CellRangeAddress | AbstractExcelUtils.getMergedRange(CellRangeAddress[][] mergedRanges, int rowNumber, int columnNumber)
protected int | ExcelToHtmlConverter.processRow(CellRangeAddress[][] mergedRanges, HSSFRow row, org.w3c.dom.Element tableRowElement)
protected int | ExcelToFoConverter.processRow(HSSFWorkbook workbook, CellRangeAddress[][] mergedRanges, HSSFRow row, org.w3c.dom.Element tableRowElement)

Uses of CellRangeAddress in org.apache.poi.hssf.model

Methods in org.apache.poi.hssf.model that return CellRangeAddress
 CellRangeAddress InternalSheet.getMergedRegionAt(int index)

Uses of CellRangeAddress in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return CellRangeAddress
CellRangeAddress | MergeCellsRecord.getAreaAt(int index)
CellRangeAddress[] | CFHeaderRecord.getCellRanges()
CellRangeAddress[] | FeatRecord.getCellRefs()
CellRangeAddress | CFHeaderRecord.getEnclosingCellRange()

Methods in org.apache.poi.hssf.record with parameters of type CellRangeAddress
void | CFHeaderRecord.setCellRanges(CellRangeAddress[] cellRanges) Set cell ranges list to a single cell range and modify the enclosing cell range accordingly.
void | FeatRecord.setCellRefs(CellRangeAddress[] cellRefs)
void | CFHeaderRecord.setEnclosingCellRange(CellRangeAddress cr)

Constructors in org.apache.poi.hssf.record with parameters of type CellRangeAddress
CFHeaderRecord(CellRangeAddress[] regions, int nRules)
MergeCellsRecord(CellRangeAddress[] regions, int startIndex, int numberOfRegions)

Uses of CellRangeAddress in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates that return CellRangeAddress
CellRangeAddress | MergedCellsTable.get(int index)
CellRangeAddress | FormulaRecordAggregate.getArrayFormulaRange()
CellRangeAddress | FormulaRecordAggregate.removeArrayFormula(int rowIndex, int columnIndex) Removes an array formula

Methods in org.apache.poi.hssf.record.aggregates with parameters of type CellRangeAddress
 void FormulaRecordAggregate.setArrayFormula(CellRangeAddress r, Ptg[] ptgs)

Constructors in org.apache.poi.hssf.record.aggregates with parameters of type CellRangeAddress
CFRecordsAggregate(CellRangeAddress[] regions, CFRuleRecord[] rules)

Uses of CellRangeAddress in org.apache.poi.hssf.record.cf

Methods in org.apache.poi.hssf.record.cf that return CellRangeAddress
static CellRangeAddress | CellRangeUtil.createEnclosingCellRange(CellRangeAddress crA, CellRangeAddress crB) Create an enclosing CellRange for the two cell ranges.
static CellRangeAddress[] | CellRangeUtil.mergeCellRanges(CellRangeAddress[] cellRanges) Do all possible cell merges between cells of the list so that: if a cell range is completely inside of another cell range, it gets removed from the list if two cells have a shared border, merge them into one bigger cell range

Methods in org.apache.poi.hssf.record.cf with parameters of type CellRangeAddress
static boolean | CellRangeUtil.contains(CellRangeAddress crA, CellRangeAddress crB) Check if the specified range is located inside of this cell range.
static CellRangeAddress | CellRangeUtil.createEnclosingCellRange(CellRangeAddress crA, CellRangeAddress crB) Create an enclosing CellRange for the two cell ranges.
static boolean | CellRangeUtil.hasExactSharedBorder(CellRangeAddress crA, CellRangeAddress crB) Check if the specified cell range has a shared border with the current range.
static int | CellRangeUtil.intersect(CellRangeAddress crA, CellRangeAddress crB) Intersect this range with the specified range.
static CellRangeAddress[] | CellRangeUtil.mergeCellRanges(CellRangeAddress[] cellRanges) Do all possible cell merges between cells of the list so that: if a cell range is completely inside of another cell range, it gets removed from the list if two cells have a shared border, merge them into one bigger cell range

Uses of CellRangeAddress in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return CellRangeAddress
CellRangeAddress | HSSFCell.getArrayFormulaRange()
CellRangeAddress[] | HSSFConditionalFormatting.getFormattingRanges()
CellRangeAddress | HSSFSheet.getMergedRegion(int index)

Methods in org.apache.poi.hssf.usermodel with parameters of type CellRangeAddress
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule rule1)
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule[] cfRules) Allows to add a new Conditional Formatting set to the sheet.
int | HSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, HSSFConditionalFormattingRule rule1, HSSFConditionalFormattingRule rule2)
int | HSSFSheet.addMergedRegion(CellRangeAddress region) adds a merged region of cells (hence those cells form one)
CellRange<HSSFCell> | HSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range)
HSSFAutoFilter | HSSFSheet.setAutoFilter(CellRangeAddress range)

Uses of CellRangeAddress in org.apache.poi.hssf.util

Subclasses of CellRangeAddress in org.apache.poi.hssf.util
 class CellRangeAddress
Deprecated. use CellRangeAddress

Methods in org.apache.poi.hssf.util with parameters of type CellRangeAddress
static void | HSSFRegionUtil.setBorderBottom(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderLeft(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | HSSFRegionUtil.setBorderRight(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderRight attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBorderTop(int border, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the borderBottom attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setBottomBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the bottomBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setLeftBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the leftBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setRightBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the rightBorderColor attribute of the HSSFRegionUtil object
static void | HSSFRegionUtil.setTopBorderColor(int color, CellRangeAddress region, HSSFSheet sheet, HSSFWorkbook workbook) Sets the topBorderColor attribute of the HSSFRegionUtil object

Uses of CellRangeAddress in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return CellRangeAddress
CellRangeAddress | Cell.getArrayFormulaRange() Only valid for array formula cells
CellRangeAddress[] | ConditionalFormatting.getFormattingRanges()
CellRangeAddress | Sheet.getMergedRegion(int index) Returns the merged region at the specified index

Methods in org.apache.poi.ss.usermodel with parameters of type CellRangeAddress
int | SheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule) Add a new Conditional Formatting to the sheet.
int | SheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules) Add a new Conditional Formatting set to the sheet.
int | SheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2) Add a new Conditional Formatting consisting of two rules.
int | Sheet.addMergedRegion(CellRangeAddress region) Adds a merged region of cells (hence those cells form one)
CellRange<? extends Cell> | Sheet.setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.
AutoFilter | Sheet.setAutoFilter(CellRangeAddress range) Enable filtering for a range of cells

Uses of CellRangeAddress in org.apache.poi.ss.usermodel.charts

Methods in org.apache.poi.ss.usermodel.charts with parameters of type CellRangeAddress
static ChartDataSource<java.lang.Number> | DataSources.fromNumericCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)
static ChartDataSource<java.lang.String> | DataSources.fromStringCellRange(Sheet sheet, CellRangeAddress cellRangeAddress)

Uses of CellRangeAddress in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return CellRangeAddress
static CellRangeAddress[] | Region.convertRegionsToCellRanges(Region[] regions) Deprecated.
static CellRangeAddress | Region.convertToCellRangeAddress(Region r) Deprecated.
CellRangeAddress | CellRangeAddress.copy()
CellRangeAddress | CellRangeAddressList.getCellRangeAddress(int index)
CellRangeAddress[] | CellRangeAddressList.getCellRangeAddresses()
CellRangeAddress | CellRangeAddressList.remove(int rangeIndex)
static CellRangeAddress | CellRangeAddress.valueOf(java.lang.String ref)

Methods in org.apache.poi.ss.util with parameters of type CellRangeAddress
void | CellRangeAddressList.addCellRangeAddress(CellRangeAddress cra)
static boolean | SheetUtil.containsCell(CellRangeAddress cr, int rowIx, int colIx)
static Region[] | Region.convertCellRangesToRegions(CellRangeAddress[] cellRanges) Deprecated. Convert a List of CellRange objects to an array of regions
static void | RegionUtil.setBorderBottom(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | RegionUtil.setBorderLeft(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the left border for a region of cells by manipulating the cell style of the individual cells on the left
static void | RegionUtil.setBorderRight(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderRight attribute of the RegionUtil object
static void | RegionUtil.setBorderTop(int border, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the borderBottom attribute of the RegionUtil object
static void | RegionUtil.setBottomBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the bottomBorderColor attribute of the RegionUtil object
static void | RegionUtil.setLeftBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the leftBorderColor attribute of the RegionUtil object
static void | RegionUtil.setRightBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the rightBorderColor attribute of the RegionUtil object
static void | RegionUtil.setTopBorderColor(int color, CellRangeAddress region, Sheet sheet, Workbook workbook) Sets the topBorderColor attribute of the RegionUtil object

Uses of CellRangeAddress in org.apache.poi.ss.util.cellwalk

Constructors in org.apache.poi.ss.util.cellwalk with parameters of type CellRangeAddress
CellWalk(Sheet sheet, CellRangeAddress range)

Uses of CellRangeAddress in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return CellRangeAddress
CellRangeAddress | SXSSFCell.getArrayFormulaRange() Only valid for array formula cells
CellRangeAddress | SXSSFSheet.getMergedRegion(int index) Returns the merged region at the specified index

Methods in org.apache.poi.xssf.streaming with parameters of type CellRangeAddress
int | SXSSFSheet.addMergedRegion(CellRangeAddress region) Adds a merged region of cells (hence those cells form one)
CellRange<? extends Cell> | SXSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.
AutoFilter | SXSSFSheet.setAutoFilter(CellRangeAddress range) Enable filtering for a range of cells

Uses of CellRangeAddress in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return CellRangeAddress
CellRangeAddress | XSSFCell.getArrayFormulaRange()
CellRangeAddress[] | XSSFConditionalFormatting.getFormattingRanges()
CellRangeAddress | XSSFSheet.getMergedRegion(int index)

Methods in org.apache.poi.xssf.usermodel with parameters of type CellRangeAddress
int | XSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1)
int | XSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules)
int | XSSFSheetConditionalFormatting.addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2)
int | XSSFSheet.addMergedRegion(CellRangeAddress region) Adds a merged region of cells (hence those cells form one).
CellRange<XSSFCell> | XSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range)
XSSFAutoFilter | XSSFSheet.setAutoFilter(CellRangeAddress range)

Uses of CellRangeAddress in org.apache.poi.xssf.usermodel.helpers

Methods in org.apache.poi.xssf.usermodel.helpers that return types with arguments of type CellRangeAddress
 java.util.List<CellRangeAddress> XSSFRowShifter.shiftMerged(int startRow, int endRow, int n)
Shift merged regions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.CellRangeAddressBase

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.CellRangeAddressBase

Packages that use CellRangeAddressBase
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.util |

Uses of CellRangeAddressBase in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return CellRangeAddressBase
CellRangeAddressBase | HSSFChart.HSSFSeries.getCategoryLabelsCellRange()
CellRangeAddressBase | HSSFChart.HSSFSeries.getValuesCellRange()

Methods in org.apache.poi.hssf.usermodel with parameters of type CellRangeAddressBase
void | HSSFChart.HSSFSeries.setCategoryLabelsCellRange(CellRangeAddressBase range)
void | HSSFChart.HSSFSeries.setValuesCellRange(CellRangeAddressBase range)

Uses of CellRangeAddressBase in org.apache.poi.hssf.util

Subclasses of CellRangeAddressBase in org.apache.poi.hssf.util
 class CellRangeAddress8Bit
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Like CellRangeAddress except column fields are 8-bit.

Uses of CellRangeAddressBase in org.apache.poi.ss.util

Subclasses of CellRangeAddressBase in org.apache.poi.ss.util
 class CellRangeAddress
See OOO documentation: excelfileformat.pdf sec 2.5.14 - 'Cell Range Address'

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.CellRangeAddressList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.CellRangeAddressList

Packages that use CellRangeAddressList
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.usermodel |
org.apache.poi.ss.util |
org.apache.poi.xssf.usermodel |

Uses of CellRangeAddressList in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record that return CellRangeAddressList
 CellRangeAddressList DVRecord.getCellRangeAddress()

Constructors in org.apache.poi.hssf.record with parameters of type CellRangeAddressList
DVRecord(int validationType, int operator, int errorStyle, boolean emptyCellAllowed, boolean suppressDropDownArrow, boolean isExplicitList, boolean showPromptBox, java.lang.String promptTitle, java.lang.String promptText, boolean showErrorBox, java.lang.String errorTitle, java.lang.String errorText, Ptg[] formula1, Ptg[] formula2, CellRangeAddressList regions)

Uses of CellRangeAddressList in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return CellRangeAddressList
 CellRangeAddressList HSSFDataValidation.getRegions()

Methods in org.apache.poi.hssf.usermodel with parameters of type CellRangeAddressList
 DataValidation HSSFDataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Constructors in org.apache.poi.hssf.usermodel with parameters of type CellRangeAddressList
HSSFDataValidation(CellRangeAddressList regions, DataValidationConstraint constraint)
Constructor which initializes the cell range on which this object will be applied

Uses of CellRangeAddressList in org.apache.poi.hssf.util

Subclasses of CellRangeAddressList in org.apache.poi.hssf.util
 class CellRangeAddressList
Deprecated. use CellRangeAddressList

Uses of CellRangeAddressList in org.apache.poi.ss.usermodel

Methods in org.apache.poi.ss.usermodel that return CellRangeAddressList
 CellRangeAddressList DataValidation.getRegions()

Methods in org.apache.poi.ss.usermodel with parameters of type CellRangeAddressList
 DataValidation DataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Uses of CellRangeAddressList in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return CellRangeAddressList
 CellRangeAddressList CellRangeAddressList.copy()

Uses of CellRangeAddressList in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return CellRangeAddressList
 CellRangeAddressList XSSFDataValidation.getRegions()

Methods in org.apache.poi.xssf.usermodel with parameters of type CellRangeAddressList
 DataValidation XSSFDataValidationHelper.createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)

Constructors in org.apache.poi.xssf.usermodel with parameters of type CellRangeAddressList
XSSFDataValidation(XSSFDataValidationConstraint constraint, CellRangeAddressList regions, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDataValidation ctDataValidation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.CellReference

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.CellReference

Packages that use CellReference
org.apache.poi.hssf.record.aggregates | record aggregates are not real "records" but collections of records that act as a single record.
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.util |
org.apache.poi.xssf.usermodel |

Uses of CellReference in org.apache.poi.hssf.record.aggregates

Methods in org.apache.poi.hssf.record.aggregates with parameters of type CellReference
static SharedValueManager | SharedValueManager.create(SharedFormulaRecord[] sharedFormulaRecords, CellReference[] firstCells, ArrayRecord[] arrayRecords, TableRecord[] tableRecords)
SharedFormulaRecord | SharedValueManager.linkSharedFormulaRecord(CellReference firstCell, FormulaRecordAggregate agg)

Uses of CellReference in org.apache.poi.hssf.util

Subclasses of CellReference in org.apache.poi.hssf.util
 class CellReference
Common conversion functions between Excel style A1, C27 style cell references, and POI usermodel style row=0, column=0 style references.

Uses of CellReference in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula that return CellReference
 CellReference Formula.getExpReference()
Gets the locator for the corresponding SharedFormulaRecord, ArrayRecord or TableRecord if this formula belongs to such a grouping.

Uses of CellReference in org.apache.poi.ss.formula.ptg

Constructors in org.apache.poi.ss.formula.ptg with parameters of type CellReference
Ref3DPtg(CellReference c, int externIdx)
RefPtg(CellReference cr)
RefPtgBase(CellReference c)

Uses of CellReference in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return CellReference
 CellReference[] AreaReference.getAllReferencedCells()
Returns a reference to every cell covered by this area
 CellReference AreaReference.getFirstCell()
 CellReference AreaReference.getLastCell()
Note - if this area reference refers to a single cell, the return value of this method will be identical to that of getFirstCell()

Methods in org.apache.poi.ss.util with parameters of type CellReference
static boolean AreaReference.isWholeColumnReference(CellReference topLeft, CellReference botRight)
Is the reference for a whole-column reference, such as C:C or D:G ?

Constructors in org.apache.poi.ss.util with parameters of type CellReference
AreaReference(CellReference topLeft, CellReference botRight)
Creates an area ref from a pair of Cell References.

Uses of CellReference in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return CellReference
CellReference | XSSFTable.getEndCellReference()
CellReference | XSSFTable.getStartCellReference()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.CellReference.NameType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.CellReference.NameType

Packages that use CellReference.NameType
org.apache.poi.ss.util

Uses of CellReference.NameType in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return CellReference.NameType
static CellReference.NameType | CellReference.classifyCellReference(java.lang.String str, SpreadsheetVersion ssVersion) Classifies an identifier as either a simple (2D) cell reference or a named range name
static CellReference.NameType | CellReference.NameType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static CellReference.NameType[] | CellReference.NameType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.CellUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.CellUtil

No usage of org.apache.poi.ss.util.CellUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer

No usage of org.apache.poi.ss.util.DateFormatConverter.DateFormatTokenizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.DateFormatConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.DateFormatConverter

No usage of org.apache.poi.ss.util.DateFormatConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.ImageUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.ImageUtils

No usage of org.apache.poi.ss.util.ImageUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.NumberComparer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.NumberComparer

No usage of org.apache.poi.ss.util.NumberComparer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.NumberToTextConverter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.NumberToTextConverter

No usage of org.apache.poi.ss.util.NumberToTextConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.Region

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.Region

Packages that use Region
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.util |

Uses of Region in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel that return Region
 Region[] HSSFConditionalFormatting.getFormattingRegions()
Deprecated. (Aug-2008) use HSSFConditionalFormatting.getFormattingRanges()

Methods in org.apache.poi.hssf.usermodel with parameters of type Region
int | HSSFSheetConditionalFormatting.addConditionalFormatting(Region[] regions, HSSFConditionalFormattingRule[] cfRules) Deprecated. use CellRangeAddress instead of Region
int | HSSFSheet.addMergedRegion(Region region) Deprecated. (Aug-2008) use CellRangeAddress instead of Region

Uses of Region in org.apache.poi.hssf.util

Subclasses of Region in org.apache.poi.hssf.util
 class Region
Deprecated. (Aug-2008) use CellRangeAddress

Uses of Region in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return Region
static Region[] Region.convertCellRangesToRegions(CellRangeAddress[] cellRanges)
Deprecated. Convert a List of CellRange objects to an array of regions

Methods in org.apache.poi.ss.util with parameters of type Region
int | Region.compareTo(Region r) Deprecated. Compares that the given region is the same less than or greater than this region.
static CellRangeAddress[] | Region.convertRegionsToCellRanges(Region[] regions) Deprecated.
static CellRangeAddress | Region.convertToCellRangeAddress(Region r) Deprecated.
boolean | Region.equals(Region r) Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.RegionUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.RegionUtil

No usage of org.apache.poi.ss.util.RegionUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.SheetBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.SheetBuilder

Packages that use SheetBuilder
org.apache.poi.ss.util

Uses of SheetBuilder in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return SheetBuilder
SheetBuilder | SheetBuilder.setCreateEmptyCells(boolean shouldCreateEmptyCells) Specifies if null array elements should be treated as empty cells.
SheetBuilder | SheetBuilder.setSheetName(java.lang.String sheetName) Specifies name of the sheet to build.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.SheetReferences

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.SheetReferences

No usage of org.apache.poi.ss.util.SheetReferences

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.SheetUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.SheetUtil

No usage of org.apache.poi.ss.util.SheetUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.SSCellRange

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.SSCellRange

Packages that use SSCellRange
org.apache.poi.ss.util

Uses of SSCellRange in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util that return SSCellRange
static
<B extends Cell>
SSCellRange<B>
SSCellRange.create(int firstRow, int firstColumn, int height, int width, java.util.List<B> flattenedList, java.lang.Class<B> cellClass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.ss.util.WorkbookUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.ss.util.WorkbookUtil

No usage of org.apache.poi.ss.util.WorkbookUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ArrayUtil

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class ArrayUtil

java.lang.Object
    extended by  org.apache.poi.util.ArrayUtil

public class ArrayUtil
extends java.lang.Object

Utility classes for dealing with arrays.

Author:
Glen Stampoultzis

Constructor Summary
ArrayUtil()
Method Summary
static void arraycopy(byte[] src, int src_position, byte[] dst, int dst_position, int length)
This is really a debugging version of System.arraycopy().
static void arrayMoveWithin(java.lang.Object[] array, int moveFrom, int moveTo, int numToMove)
Moves a number of entries in an array to another point in the array, shifting those inbetween as required.
static byte[] copyOf(byte[] source, int newLength)
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
static byte[] copyOfRange(byte[] original, int from, int to)
Copies the specified range of the specified array into a new array.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ArrayUtil

public ArrayUtil()
Method Detail

arraycopy

public static void arraycopy(byte[] src,
                             int src_position,
                             byte[] dst,
                             int dst_position,
                             int length)
This is really a debugging version of System.arraycopy(). Use it to provide better exception messages when copying arrays around. For production use it's better to use the original for speed.

arrayMoveWithin

public static void arrayMoveWithin(java.lang.Object[] array,
                                   int moveFrom,
                                   int moveTo,
                                   int numToMove)
Moves a number of entries in an array to another point in the array, shifting those inbetween as required.

Parameters:
array - The array to alter
moveFrom - The (0 based) index of the first entry to move
moveTo - The (0 based) index of the positition to move to
numToMove - The number of entries to move

copyOf

public static byte[] copyOf(byte[] source,
                            int newLength)
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length. This method is temporary replace for Arrays.copyOf() until we start to require JDK 1.6.

Parameters:
source - the array to be copied
newLength - the length of the copy to be returned
Returns:
a copy of the original array, truncated or padded with zeros to obtain the specified length
Throws:
java.lang.NegativeArraySizeException - if newLength is negative
java.lang.NullPointerException - if original is null

copyOfRange

public static byte[] copyOfRange(byte[] original,
                                 int from,
                                 int to)
Copies the specified range of the specified array into a new array. The initial index of the range (from) must lie between zero and original.length, inclusive. The value at original[from] is placed into the initial element of the copy (unless from == original.length or from == to). Values from subsequent elements in the original array are placed into subsequent elements in the copy. The final index of the range (to), which must be greater than or equal to from, may be greater than original.length, in which case (byte)0 is placed in all elements of the copy whose index is greater than or equal to original.length - from. The length of the returned array will be to - from. This method is temporary replace for Arrays.copyOfRange() until we start to require JDK 1.6.

Parameters:
original - the array from which a range is to be copied
from - the initial index of the range to be copied, inclusive
to - the final index of the range to be copied, exclusive. (This index may lie outside the array.)
Returns:
a new array containing the specified range from the original array, truncated or padded with zeros to obtain the required length
Throws:
java.lang.ArrayIndexOutOfBoundsException - if from < 0 or from > original.length()
java.lang.IllegalArgumentException - if from > to
java.lang.NullPointerException - if original is null
Since:
1.6
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Beta

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

org.apache.poi.util
Annotation Type Beta

@Documented
@Retention(value=SOURCE)
public @interface Beta

Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release. An API bearing this annotation is exempt from any compatibility guarantees made by its containing library.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


BinaryTree

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class BinaryTree

java.lang.Object
    extended by  java.util.AbstractMap
        extended by  org.apache.poi.util.BinaryTree
All Implemented Interfaces:
java.util.Map
public class BinaryTree
extends java.util.AbstractMap

Red-Black tree-based implementation of Map. This class guarantees that the map will be in both ascending key order and ascending value order, sorted according to the natural order for the key's and value's classes.

This Map is intended for applications that need to be able to look up a key-value pairing by either key or value, and need to do so with equal efficiency.

While that goal could be accomplished by taking a pair of TreeMaps and redirecting requests to the appropriate TreeMap (e.g., containsKey would be directed to the TreeMap that maps values to keys, containsValue would be directed to the TreeMap that maps keys to values), there are problems with that implementation, particularly when trying to keep the two TreeMaps synchronized with each other. And if the data contained in the TreeMaps is large, the cost of redundant storage becomes significant.

This solution keeps the data properly synchronized and minimizes the data storage. The red-black algorithm is based on TreeMap's, but has been modified to simultaneously map a tree node by key and by value. This doubles the cost of put operations (but so does using two TreeMaps), and nearly doubles the cost of remove operations (there is a savings in that the lookup of the node to be removed only has to be performed once). And since only one node contains the key and value, storage is significantly less than that required by two TreeMaps.

There are some limitations placed on data kept in this Map. The biggest one is this:

When performing a put operation, neither the key nor the value may already exist in the Map. In the java.util Map implementations (HashMap, TreeMap), you can perform a put with an already mapped key, and neither cares about duplicate values at all ... but this implementation's put method with throw an IllegalArgumentException if either the key or the value is already in the Map.

Obviously, that same restriction (and consequence of failing to heed that restriction) applies to the putAll method.

The Map.Entry instances returned by the appropriate methods will not allow setValue() and will throw an UnsupportedOperationException on attempts to call that method.

New methods are added to take advantage of the fact that values are kept sorted independently of their keys:

Object getKeyForValue(Object value) is the opposite of get; it takes a value and returns its key, if any.

Object removeValue(Object value) finds and removes the specified value and returns the now un-used key.

Set entrySetByValue() returns the Map.Entry's in a Set whose iterator will iterate over the Map.Entry's in ascending order by their corresponding values.

Set keySetByValue() returns the keys in a Set whose iterator will iterate over the keys in ascending order by their corresponding values.

Collection valuesByValue() returns the values in a Collection whose iterator will iterate over the values in ascending order.

Author:
Marc Johnson (mjohnson at apache dot org)

Nested Class Summary
Nested classes/interfaces inherited from class java.util.AbstractMap
java.util.AbstractMap.SimpleEntry<K,V>, java.util.AbstractMap.SimpleImmutableEntry<K,V>
Nested classes/interfaces inherited from interface java.util.Map
java.util.Map.Entry<K,V>
Constructor Summary
BinaryTree()
Construct a new BinaryTree
BinaryTree(java.util.Map map)
Constructs a new BinaryTree from an existing Map, with keys and values sorted
Method Summary
void | clear() Removes all mappings from this map
boolean | containsKey(java.lang.Object key) Returns true if this map contains a mapping for the specified key.
boolean | containsValue(java.lang.Object value) Returns true if this map maps one or more keys to the specified value.
java.util.Set | entrySet() Returns a set view of the mappings contained in this map.
java.util.Set | entrySetByValue() Returns a set view of the mappings contained in this map.
java.lang.Object | get(java.lang.Object key) Returns the value to which this map maps the specified key.
java.lang.Object | getKeyForValue(java.lang.Object value) Returns the key to which this map maps the specified value.
java.util.Set | keySet() Returns a set view of the keys contained in this map.
java.util.Set | keySetByValue() Returns a set view of the keys contained in this map.
org.apache.poi.util.BinaryTree.Node | lookup(java.lang.Comparable data, int index) do the actual lookup of a piece of data
java.lang.Object | put(java.lang.Object key, java.lang.Object value) Associates the specified value with the specified key in this map.
java.lang.Object | remove(java.lang.Object key) Removes the mapping for this key from this map if present
java.lang.Object | removeValue(java.lang.Object value) Removes the mapping for this value from this map if present
int | size() Returns the number of key-value mappings in this map.
java.util.Collection | values() Returns a collection view of the values contained in this map.
java.util.Collection | valuesByValue() Returns a collection view of the values contained in this map.
Methods inherited from class java.util.AbstractMap
clone, equals, hashCode, isEmpty, putAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BinaryTree

public BinaryTree()
Construct a new BinaryTree

BinaryTree

public BinaryTree(java.util.Map map)
           throws java.lang.ClassCastException,
                  java.lang.NullPointerException,
                  java.lang.IllegalArgumentException
Constructs a new BinaryTree from an existing Map, with keys and values sorted

Parameters:
map - the map whose mappings are to be placed in this map.
Throws:
java.lang.ClassCastException - if the keys in the map are not Comparable, or are not mutually comparable; also if the values in the map are not Comparable, or are not mutually Comparable
java.lang.NullPointerException - if any key or value in the map is null
java.lang.IllegalArgumentException - if there are duplicate keys or duplicate values in the map
Method Detail

getKeyForValue

public java.lang.Object getKeyForValue(java.lang.Object value)
                                throws java.lang.ClassCastException,
                                       java.lang.NullPointerException
Returns the key to which this map maps the specified value. Returns null if the map contains no mapping for this value.

Parameters:
value - value whose associated key is to be returned.
Returns:
the key to which this map maps the specified value, or null if the map contains no mapping for this value.
Throws:
java.lang.ClassCastException - if the value is of an inappropriate type for this map.
java.lang.NullPointerException - if the value is null

removeValue

public java.lang.Object removeValue(java.lang.Object value)
Removes the mapping for this value from this map if present

Parameters:
value - value whose mapping is to be removed from the map.
Returns:
previous key associated with specified value, or null if there was no mapping for value.

entrySetByValue

public java.util.Set entrySetByValue()
Returns a set view of the mappings contained in this map. Each element in the returned set is a Map.Entry. The set is backed by the map, so changes to the map are reflected in the set, and vice-versa. If the map is modified while an iteration over the set is in progress, the results of the iteration are undefined. The set supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Set.remove, removeAll, retainAll and clear operations. It does not support the add or addAll operations.

The difference between this method and entrySet is that entrySet's iterator() method returns an iterator that iterates over the mappings in ascending order by key. This method's iterator method iterates over the mappings in ascending order by value.

Returns:
a set view of the mappings contained in this map.

keySetByValue

public java.util.Set keySetByValue()
Returns a set view of the keys contained in this map. The set is backed by the map, so changes to the map are reflected in the set, and vice-versa. If the map is modified while an iteration over the set is in progress, the results of the iteration are undefined. The set supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Set.remove, removeAll, retainAll, and clear operations. It does not support the add or addAll operations.

The difference between this method and keySet is that keySet's iterator() method returns an iterator that iterates over the keys in ascending order by key. This method's iterator method iterates over the keys in ascending order by value.

Returns:
a set view of the keys contained in this map.

valuesByValue

public java.util.Collection valuesByValue()
Returns a collection view of the values contained in this map. The collection is backed by the map, so changes to the map are reflected in the collection, and vice-versa. If the map is modified while an iteration over the collection is in progress, the results of the iteration are undefined. The collection supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Collection.remove, removeAll, retainAll and clear operations. It does not support the add or addAll operations.

The difference between this method and values is that values's iterator() method returns an iterator that iterates over the values in ascending order by key. This method's iterator method iterates over the values in ascending order by key.

Returns:
a collection view of the values contained in this map.

lookup

public org.apache.poi.util.BinaryTree.Node lookup(java.lang.Comparable data,
                                                  int index)
do the actual lookup of a piece of data

Parameters:
data - the key or value to be looked up
index - _KEY or _VALUE
Returns:
the desired Node, or null if there is no mapping of the specified data

size

public int size()
Returns the number of key-value mappings in this map. If the map contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.

Specified by:
size in interface java.util.Map
Overrides:
size in class java.util.AbstractMap
Returns:
the number of key-value mappings in this map.

containsKey

public boolean containsKey(java.lang.Object key)
                    throws java.lang.ClassCastException,
                           java.lang.NullPointerException
Returns true if this map contains a mapping for the specified key.

Specified by:
containsKey in interface java.util.Map
Overrides:
containsKey in class java.util.AbstractMap
Parameters:
key - key whose presence in this map is to be tested.
Returns:
true if this map contains a mapping for the specified key.
Throws:
java.lang.ClassCastException - if the key is of an inappropriate type for this map.
java.lang.NullPointerException - if the key is null

containsValue

public boolean containsValue(java.lang.Object value)
Returns true if this map maps one or more keys to the specified value.

Specified by:
containsValue in interface java.util.Map
Overrides:
containsValue in class java.util.AbstractMap
Parameters:
value - value whose presence in this map is to be tested.
Returns:
true if this map maps one or more keys to the specified value.

get

public java.lang.Object get(java.lang.Object key)
                     throws java.lang.ClassCastException,
                            java.lang.NullPointerException
Returns the value to which this map maps the specified key. Returns null if the map contains no mapping for this key.

Specified by:
get in interface java.util.Map
Overrides:
get in class java.util.AbstractMap
Parameters:
key - key whose associated value is to be returned.
Returns:
the value to which this map maps the specified key, or null if the map contains no mapping for this key.
Throws:
java.lang.ClassCastException - if the key is of an inappropriate type for this map.
java.lang.NullPointerException - if the key is null

put

public java.lang.Object put(java.lang.Object key,
                            java.lang.Object value)
                     throws java.lang.ClassCastException,
                            java.lang.NullPointerException,
                            java.lang.IllegalArgumentException
Associates the specified value with the specified key in this map.

Specified by:
put in interface java.util.Map
Overrides:
put in class java.util.AbstractMap
Parameters:
key - key with which the specified value is to be associated.
value - value to be associated with the specified key.
Returns:
null
Throws:
java.lang.ClassCastException - if the class of the specified key or value prevents it from being stored in this map.
java.lang.NullPointerException - if the specified key or value is null
java.lang.IllegalArgumentException - if the key duplicates an existing key, or if the value duplicates an existing value

remove

public java.lang.Object remove(java.lang.Object key)
Removes the mapping for this key from this map if present

Specified by:
remove in interface java.util.Map
Overrides:
remove in class java.util.AbstractMap
Parameters:
key - key whose mapping is to be removed from the map.
Returns:
previous value associated with specified key, or null if there was no mapping for key.

clear

public void clear()
Removes all mappings from this map

Specified by:
clear in interface java.util.Map
Overrides:
clear in class java.util.AbstractMap

keySet

public java.util.Set keySet()
Returns a set view of the keys contained in this map. The set is backed by the map, so changes to the map are reflected in the set, and vice-versa. If the map is modified while an iteration over the set is in progress, the results of the iteration are undefined. The set supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Set.remove, removeAll, retainAll, and clear operations. It does not support the add or addAll operations.

Specified by:
keySet in interface java.util.Map
Overrides:
keySet in class java.util.AbstractMap
Returns:
a set view of the keys contained in this map.

values

public java.util.Collection values()
Returns a collection view of the values contained in this map. The collection is backed by the map, so changes to the map are reflected in the collection, and vice-versa. If the map is modified while an iteration over the collection is in progress, the results of the iteration are undefined. The collection supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Collection.remove, removeAll, retainAll and clear operations. It does not support the add or addAll operations.

Specified by:
values in interface java.util.Map
Overrides:
values in class java.util.AbstractMap
Returns:
a collection view of the values contained in this map.

entrySet

public java.util.Set entrySet()
Returns a set view of the mappings contained in this map. Each element in the returned set is a Map.Entry. The set is backed by the map, so changes to the map are reflected in the set, and vice-versa. If the map is modified while an iteration over the set is in progress, the results of the iteration are undefined. The set supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Set.remove, removeAll, retainAll and clear operations. It does not support the add or addAll operations.

Specified by:
entrySet in interface java.util.Map
Specified by:
entrySet in class java.util.AbstractMap
Returns:
a set view of the mappings contained in this map.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BitField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class BitField

java.lang.Object
    extended by  org.apache.poi.util.BitField

public class BitField
extends java.lang.Object

Manage operations dealing with bit-mapped fields.

Author:
Marc Johnson (mjohnson at apache dot org), Andrew C. Oliver (acoliver at apache dot org)

Constructor Summary
BitField(int mask)
Create a BitField instance
Method Summary
int | clear(int holder) Clear the bits.
byte | clearByte(byte holder) Clear the bits.
short | clearShort(short holder) Clear the bits.
int | getRawValue(int holder) Obtain the value for the specified BitField, unshifted
short | getShortRawValue(short holder) Obtain the value for the specified BitField, unshifted
short | getShortValue(short holder) Obtain the value for the specified BitField, appropriately shifted right, as a short.
int | getValue(int holder) Obtain the value for the specified BitField, appropriately shifted right.
boolean | isAllSet(int holder) Are all of the bits set or not? This is a stricter test than isSet, in that all of the bits in a multi-bit set must be set for this method to return true
boolean | isSet(int holder) Is the field set or not? This is most commonly used for a single-bit field, which is often used to represent a boolean value; the results of using it for a multi-bit field is to determine whether *any* of its bits are set
int | set(int holder) Set the bits.
int | setBoolean(int holder, boolean flag) Set a boolean BitField
byte | setByte(byte holder) Set the bits.
byte | setByteBoolean(byte holder, boolean flag) Set a boolean BitField
short | setShort(short holder) Set the bits.
short | setShortBoolean(short holder, boolean flag) Set a boolean BitField
short | setShortValue(short holder, short value) Replace the bits with new values.
int | setValue(int holder, int value) Replace the bits with new values.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BitField

public BitField(int mask)
Create a BitField instance

Parameters:
mask - the mask specifying which bits apply to this BitField. Bits that are set in this mask are the bits that this BitField operates on
Method Detail

getValue

public int getValue(int holder)
Obtain the value for the specified BitField, appropriately shifted right. Many users of a BitField will want to treat the specified bits as an int value, and will not want to be aware that the value is stored as a BitField (and so shifted left so many bits)

Parameters:
holder - the int data containing the bits we're interested in
Returns:
the selected bits, shifted right appropriately

getShortValue

public short getShortValue(short holder)
Obtain the value for the specified BitField, appropriately shifted right, as a short. Many users of a BitField will want to treat the specified bits as an int value, and will not want to be aware that the value is stored as a BitField (and so shifted left so many bits)

Parameters:
holder - the short data containing the bits we're interested in
Returns:
the selected bits, shifted right appropriately

getRawValue

public int getRawValue(int holder)
Obtain the value for the specified BitField, unshifted

Parameters:
holder - the int data containing the bits we're interested in
Returns:
the selected bits

getShortRawValue

public short getShortRawValue(short holder)
Obtain the value for the specified BitField, unshifted

Parameters:
holder - the short data containing the bits we're interested in
Returns:
the selected bits

isSet

public boolean isSet(int holder)
Is the field set or not? This is most commonly used for a single-bit field, which is often used to represent a boolean value; the results of using it for a multi-bit field is to determine whether *any* of its bits are set

Parameters:
holder - the int data containing the bits we're interested in
Returns:
true if any of the bits are set, else false

isAllSet

public boolean isAllSet(int holder)
Are all of the bits set or not? This is a stricter test than isSet, in that all of the bits in a multi-bit set must be set for this method to return true

Parameters:
holder - the int data containing the bits we're interested in
Returns:
true if all of the bits are set, else false

setValue

public int setValue(int holder,
                    int value)
Replace the bits with new values.

Parameters:
holder - the int data containint the bits we're interested in
value - the new value for the specified bits
Returns:
the value of holder with the bits from the value parameter replacing the old bits

setShortValue

public short setShortValue(short holder,
                           short value)
Replace the bits with new values.

Parameters:
holder - the short data containing the bits we're interested in
value - the new value for the specified bits
Returns:
the value of holder with the bits from the value parameter replacing the old bits

clear

public int clear(int holder)
Clear the bits.

Parameters:
holder - the int data containing the bits we're interested in
Returns:
the value of holder with the specified bits cleared (set to 0)

clearShort

public short clearShort(short holder)
Clear the bits.

Parameters:
holder - the short data containing the bits we're interested in
Returns:
the value of holder with the specified bits cleared (set to 0)

clearByte

public byte clearByte(byte holder)
Clear the bits.

Parameters:
holder - the byte data containing the bits we're interested in
Returns:
the value of holder with the specified bits cleared (set to 0)

set

public int set(int holder)
Set the bits.

Parameters:
holder - the int data containing the bits we're interested in
Returns:
the value of holder with the specified bits set to 1

setShort

public short setShort(short holder)
Set the bits.

Parameters:
holder - the short data containing the bits we're interested in
Returns:
the value of holder with the specified bits set to 1

setByte

public byte setByte(byte holder)
Set the bits.

Parameters:
holder - the byte data containing the bits we're interested in
Returns:
the value of holder with the specified bits set to 1

setBoolean

public int setBoolean(int holder,
                      boolean flag)
Set a boolean BitField

Parameters:
holder - the int data containing the bits we're interested in
flag - indicating whether to set or clear the bits
Returns:
the value of holder with the specified bits set or cleared

setShortBoolean

public short setShortBoolean(short holder,
                             boolean flag)
Set a boolean BitField

Parameters:
holder - the short data containing the bits we're interested in
flag - indicating whether to set or clear the bits
Returns:
the value of holder with the specified bits set or cleared

setByteBoolean

public byte setByteBoolean(byte holder,
                           boolean flag)
Set a boolean BitField

Parameters:
holder - the byte data containing the bits we're interested in
flag - indicating whether to set or clear the bits
Returns:
the value of holder with the specified bits set or cleared
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BitFieldFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class BitFieldFactory

java.lang.Object
    extended by  org.apache.poi.util.BitFieldFactory

public class BitFieldFactory
extends java.lang.Object

Returns immutable Btfield instances.

Author:
Jason Height (jheight at apache dot org)

Constructor Summary
BitFieldFactory()
Method Summary
static BitField getInstance(int mask)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BitFieldFactory

public BitFieldFactory()
Method Detail

getInstance

public static BitField getInstance(int mask)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlockingInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class BlockingInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  org.apache.poi.util.BlockingInputStream
All Implemented Interfaces:
java.io.Closeable
public class BlockingInputStream
extends java.io.InputStream

Implementation of a BlockingInputStream to provide data to RawDataBlock that expects data in 512 byte chunks. Useful to read data from slow (ie, non FileInputStream) sources, for example when reading an OLE2 Document over a network. Possible extentions: add a timeout. Curently a call to read(byte[]) on this class is blocking, so use at your own peril if your underlying stream blocks.

Author:
Jens Gerhard, aviks - documentation cleanups.

Field Summary
protected  java.io.InputStream is
Constructor Summary
BlockingInputStream(java.io.InputStream is)
Method Summary
int | available()
void | close()
void | mark(int readLimit)
boolean | markSupported()
int | read()
int | read(byte[] bf) We had to revert to byte per byte reading to keep with slow network connections on one hand, without missing the end-of-file.
int | read(byte[] bf, int s, int l)
void | reset()
long | skip(long n)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

is

protected java.io.InputStream is
Constructor Detail

BlockingInputStream

public BlockingInputStream(java.io.InputStream is)
Method Detail

available

public int available()
              throws java.io.IOException
Overrides:
available in class java.io.InputStream
Throws:
java.io.IOException

close

public void close()
           throws java.io.IOException
Specified by:
close in interface java.io.Closeable
Overrides:
close in class java.io.InputStream
Throws:
java.io.IOException

mark

public void mark(int readLimit)
Overrides:
mark in class java.io.InputStream

markSupported

public boolean markSupported()
Overrides:
markSupported in class java.io.InputStream

read

public int read()
         throws java.io.IOException
Specified by:
read in class java.io.InputStream
Throws:
java.io.IOException

read

public int read(byte[] bf)
         throws java.io.IOException
We had to revert to byte per byte reading to keep with slow network connections on one hand, without missing the end-of-file. This is the only method that does its own thing in this class everything else is delegated to aggregated stream. THIS IS A BLOCKING BLOCK READ!!!

Overrides:
read in class java.io.InputStream
Throws:
java.io.IOException

read

public int read(byte[] bf,
                int s,
                int l)
         throws java.io.IOException
Overrides:
read in class java.io.InputStream
Throws:
java.io.IOException

reset

public void reset()
           throws java.io.IOException
Overrides:
reset in class java.io.InputStream
Throws:
java.io.IOException

skip

public long skip(long n)
          throws java.io.IOException
Overrides:
skip in class java.io.InputStream
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ByteField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class ByteField

java.lang.Object
    extended by  org.apache.poi.util.ByteField
All Implemented Interfaces:
FixedField
public class ByteField
extends java.lang.Object
implements FixedField

representation of a byte (8-bit) field at a fixed location within a byte array

Author:
Marc Johnson (mjohnson at apache dot org

Constructor Summary
ByteField(int offset)
construct the ByteField with its offset into its containing byte array and a default value of 0
ByteField(int offset, byte value)
construct the ByteField with its offset into its containing byte array and initialize its value
ByteField(int offset, byte[] data)
Construct the ByteField with its offset into its containing byte array and initialize its value from its byte array
ByteField(int offset, byte value, byte[] data)
construct the ByteField with its offset into its containing byte array, initialize its value, and write its value to its byte array
Method Summary
byte | get() get the ByteField's current value
void | readFromBytes(byte[] data) set the value from its offset into an array of bytes
void | readFromStream(java.io.InputStream stream) set the value from an InputStream
void | set(byte value) set the ByteField's current value
void | set(byte value, byte[] data) set the ByteField's current value and write it to a byte array
java.lang.String | toString() return the value as a String
void | writeToBytes(byte[] data) write the value out to an array of bytes at the appropriate offset
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ByteField

public ByteField(int offset)
          throws java.lang.ArrayIndexOutOfBoundsException
construct the ByteField with its offset into its containing byte array and a default value of 0

Parameters:
offset - of the field within its byte array
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative

ByteField

public ByteField(int offset,
                 byte value)
          throws java.lang.ArrayIndexOutOfBoundsException
construct the ByteField with its offset into its containing byte array and initialize its value

Parameters:
offset - of the field within its byte array
value - the initial value
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative

ByteField

public ByteField(int offset,
                 byte[] data)
          throws java.lang.ArrayIndexOutOfBoundsException
Construct the ByteField with its offset into its containing byte array and initialize its value from its byte array

Parameters:
offset - of the field within its byte array
data - the byte array to read the value from
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is not within the range of 0..(data.length - 1)

ByteField

public ByteField(int offset,
                 byte value,
                 byte[] data)
          throws java.lang.ArrayIndexOutOfBoundsException
construct the ByteField with its offset into its containing byte array, initialize its value, and write its value to its byte array

Parameters:
offset - of the field within its byte array
value - the initial value
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is not within the range of 0..(data.length - 1)
Method Detail

get

public byte get()
get the ByteField's current value

Returns:
current value

set

public void set(byte value)
set the ByteField's current value

Parameters:
value - to be set

set

public void set(byte value,
                byte[] data)
         throws java.lang.ArrayIndexOutOfBoundsException
set the ByteField's current value and write it to a byte array

Parameters:
value - to be set
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of the byte array's range

readFromBytes

public void readFromBytes(byte[] data)
                   throws java.lang.ArrayIndexOutOfBoundsException
set the value from its offset into an array of bytes

Specified by:
readFromBytes in interface FixedField
Parameters:
data - the byte array from which the value is to be read
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of range of the bte array

readFromStream

public void readFromStream(java.io.InputStream stream)
                    throws java.io.IOException,
                           LittleEndian.BufferUnderrunException
set the value from an InputStream

Specified by:
readFromStream in interface FixedField
Parameters:
stream - the InputStream from which the value is to be read
Throws:
LittleEndian.BufferUnderrunException - if there is not enough data available from the InputStream
java.io.IOException - if an IOException is thrown from reading the InputStream

writeToBytes

public void writeToBytes(byte[] data)
                  throws java.lang.ArrayIndexOutOfBoundsException
write the value out to an array of bytes at the appropriate offset

Specified by:
writeToBytes in interface FixedField
Parameters:
data - the array of bytes to which the value is to be written
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of the byte array's range

toString

public java.lang.String toString()
return the value as a String

Specified by:
toString in interface FixedField
Overrides:
toString in class java.lang.Object
Returns:
the value as a String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CloseIgnoringInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class CloseIgnoringInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  java.io.FilterInputStream
            extended by  org.apache.poi.util.CloseIgnoringInputStream
All Implemented Interfaces:
java.io.Closeable
public class CloseIgnoringInputStream
extends java.io.FilterInputStream

A wrapper around an InputStream, which ignores close requests made to it. Useful with POIFSFileSystem, where you want to control the close yourself.

Field Summary
Fields inherited from class java.io.FilterInputStream
in
Constructor Summary
CloseIgnoringInputStream(java.io.InputStream in)
Method Summary
 void close()
Methods inherited from class java.io.FilterInputStream
available, mark, markSupported, read, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CloseIgnoringInputStream

public CloseIgnoringInputStream(java.io.InputStream in)
Method Detail

close

public void close()
Specified by:
close in interface java.io.Closeable
Overrides:
close in class java.io.FilterInputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CommonsLogger

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class CommonsLogger

java.lang.Object
    extended by  org.apache.poi.util.POILogger
        extended by  org.apache.poi.util.CommonsLogger

public class CommonsLogger
extends POILogger

A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Author:
Marc Johnson (mjohnson at apache dot org), Glen Stampoultzis (glens at apache.org), Nicola Ken Barozzi (nicolaken at apache.org)

Field Summary
Fields inherited from class org.apache.poi.util.POILogger
DEBUG, ERROR, FATAL, INFO, WARN
Constructor Summary
CommonsLogger()
Method Summary
boolean | check(int level) Check if a logger is enabled to log at the specified level
void | initialize(java.lang.String cat)
void | log(int level, java.lang.Object obj1) Log a message
void | log(int level, java.lang.Object obj1, java.lang.Throwable exception) Log a message
Methods inherited from class org.apache.poi.util.POILogger
log, log, log, log, log, log, log, log, log, log, log, log, log, log, log, logFormatted, logFormatted, logFormatted, logFormatted
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommonsLogger

public CommonsLogger()
Method Detail

initialize

public void initialize(java.lang.String cat)
Specified by:
initialize in class POILogger

log

public void log(int level,
                java.lang.Object obj1)
Log a message

Specified by:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log.

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Throwable exception)
Log a message

Specified by:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log. This is converted to a string.
exception - An exception to be logged

check

public boolean check(int level)
Check if a logger is enabled to log at the specified level

Specified by:
check in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DelayableLittleEndianOutput

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Interface DelayableLittleEndianOutput

All Superinterfaces:
LittleEndianOutput
All Known Implementing Classes:
LittleEndianByteArrayOutputStream
public interface DelayableLittleEndianOutput
extends LittleEndianOutput

Implementors of this interface allow client code to 'delay' writing to a certain section of a data output stream.
A typical application is for writing BIFF records when the size is not known until well after the header has been written. The client code can call createDelayedOutput(int) to reserve two bytes of the output for the 'ushort size' header field. The delayed output can be written at any stage.

Author:
Josh Micich

Method Summary
 LittleEndianOutput createDelayedOutput(int size)
Creates an output stream intended for outputting a sequence of size bytes.
Methods inherited from interface org.apache.poi.util.LittleEndianOutput
write, write, writeByte, writeDouble, writeInt, writeLong, writeShort

Method Detail

createDelayedOutput

LittleEndianOutput createDelayedOutput(int size)
Creates an output stream intended for outputting a sequence of size bytes.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingDump

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class DrawingDump

java.lang.Object
    extended by  org.apache.poi.util.DrawingDump

public class DrawingDump
extends java.lang.Object

Dump out the aggregated escher records

Constructor Summary
DrawingDump()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingDump

public DrawingDump()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FixedField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Interface FixedField

All Known Implementing Classes:
ByteField, IntegerField, LongField, ShortField
public interface FixedField

behavior of a field at a fixed location within a byte array

Author:
Marc Johnson (mjohnson at apache dot org

Method Summary
void | readFromBytes(byte[] data) set the value from its offset into an array of bytes
void | readFromStream(java.io.InputStream stream) set the value from an InputStream
java.lang.String | toString() return the value as a String
void | writeToBytes(byte[] data) write the value out to an array of bytes at the appropriate offset

Method Detail

readFromBytes

void readFromBytes(byte[] data)
                   throws java.lang.ArrayIndexOutOfBoundsException
set the value from its offset into an array of bytes

Parameters:
data - the byte array from which the value is to be read
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of the array's valid index range

readFromStream

void readFromStream(java.io.InputStream stream)
                    throws java.io.IOException,
                           LittleEndian.BufferUnderrunException
set the value from an InputStream

Parameters:
stream - the InputStream from which the value is to be read
Throws:
LittleEndian.BufferUnderrunException - if there is not enough data available from the InputStream
java.io.IOException - if an IOException is thrown from reading the InputStream

writeToBytes

void writeToBytes(byte[] data)
                  throws java.lang.ArrayIndexOutOfBoundsException
write the value out to an array of bytes at the appropriate offset

Parameters:
data - the array of bytes to which the value is to be written
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of the array's valid index range

toString

java.lang.String toString()
return the value as a String

Overrides:
toString in class java.lang.Object
Returns:
the value as a String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FontMetricsDumper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class FontMetricsDumper

java.lang.Object
    extended by  org.apache.poi.util.FontMetricsDumper

public class FontMetricsDumper
extends java.lang.Object

Constructor Summary
FontMetricsDumper()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FontMetricsDumper

public FontMetricsDumper()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HexDump

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class HexDump

java.lang.Object
    extended by  org.apache.poi.util.HexDump

public class HexDump
extends java.lang.Object

dump data in hexadecimal format; derived from a HexDump utility I wrote in June 2001.

Author:
Marc Johnson, Glen Stampoultzis (glens at apache.org)

Field Summary
static java.lang.String EOL
Method Summary
static char[] | byteToHex(int value)
static java.lang.String | dump(byte[] data, long offset, int index) dump an array of bytes to a String
static void | dump(byte[] data, long offset, java.io.OutputStream stream, int index) dump an array of bytes to an OutputStream
static void | dump(byte[] data, long offset, java.io.OutputStream stream, int index, int length) dump an array of bytes to an OutputStream
static void | dump(java.io.InputStream in, java.io.PrintStream out, int start, int bytesToDump) Dumps bytesToDump bytes to an output stream.
static char[] | intToHex(int value)
static char[] | longToHex(long value)
static void | main(java.lang.String[] args)
static char[] | shortToHex(int value)
static java.lang.String | toHex(byte value) Converts the parameter to a hex value.
static java.lang.String | toHex(byte[] value) Converts the parameter to a hex value.
static java.lang.String | toHex(byte[] value, int bytesPerLine) Converts the parameter to a hex value breaking the results into lines.
static java.lang.String | toHex(int value) Converts the parameter to a hex value.
static java.lang.String | toHex(long value) Converts the parameter to a hex value.
static java.lang.String | toHex(short value) Converts the parameter to a hex value.
static java.lang.String | toHex(short[] value) Converts the parameter to a hex value.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EOL

public static final java.lang.String EOL
Method Detail

dump

public static void dump(byte[] data,
                        long offset,
                        java.io.OutputStream stream,
                        int index,
                        int length)
                 throws java.io.IOException,
                        java.lang.ArrayIndexOutOfBoundsException,
                        java.lang.IllegalArgumentException
dump an array of bytes to an OutputStream

Parameters:
data - the byte array to be dumped
offset - its offset, whatever that might mean
stream - the OutputStream to which the data is to be written
index - initial index into the byte array
length - number of characters to output
Throws:
java.io.IOException - is thrown if anything goes wrong writing the data to stream
java.lang.ArrayIndexOutOfBoundsException - if the index is outside the data array's bounds
java.lang.IllegalArgumentException - if the output stream is null

dump

public static void dump(byte[] data,
                        long offset,
                        java.io.OutputStream stream,
                        int index)
                 throws java.io.IOException,
                        java.lang.ArrayIndexOutOfBoundsException,
                        java.lang.IllegalArgumentException
dump an array of bytes to an OutputStream

Parameters:
data - the byte array to be dumped
offset - its offset, whatever that might mean
stream - the OutputStream to which the data is to be written
index - initial index into the byte array
Throws:
java.io.IOException - is thrown if anything goes wrong writing the data to stream
java.lang.ArrayIndexOutOfBoundsException - if the index is outside the data array's bounds
java.lang.IllegalArgumentException - if the output stream is null

dump

public static java.lang.String dump(byte[] data,
                                    long offset,
                                    int index)
dump an array of bytes to a String

Parameters:
data - the byte array to be dumped
offset - its offset, whatever that might mean
index - initial index into the byte array
Returns:
output string
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the index is outside the data array's bounds

toHex

public static java.lang.String toHex(byte[] value)
Converts the parameter to a hex value.

Parameters:
value - The value to convert
Returns:
A String representing the array of bytes

toHex

public static java.lang.String toHex(short[] value)
Converts the parameter to a hex value.

Parameters:
value - The value to convert
Returns:
A String representing the array of shorts

toHex

public static java.lang.String toHex(byte[] value,
                                     int bytesPerLine)

Converts the parameter to a hex value breaking the results into lines.

Parameters:
value - The value to convert
bytesPerLine - The maximum number of bytes per line. The next byte will be written to a new line
Returns:
A String representing the array of bytes

toHex

public static java.lang.String toHex(short value)
Converts the parameter to a hex value.

Parameters:
value - The value to convert
Returns:
The result right padded with 0

toHex

public static java.lang.String toHex(byte value)
Converts the parameter to a hex value.

Parameters:
value - The value to convert
Returns:
The result right padded with 0

toHex

public static java.lang.String toHex(int value)
Converts the parameter to a hex value.

Parameters:
value - The value to convert
Returns:
The result right padded with 0

toHex

public static java.lang.String toHex(long value)
Converts the parameter to a hex value.

Parameters:
value - The value to convert
Returns:
The result right padded with 0

dump

public static void dump(java.io.InputStream in,
                        java.io.PrintStream out,
                        int start,
                        int bytesToDump)
                 throws java.io.IOException
Dumps bytesToDump bytes to an output stream.

Parameters:
in - The stream to read from
out - The output stream
start - The index to use as the starting position for the left hand side label
bytesToDump - The number of bytes to output. Use -1 to read until the end of file.
Throws:
java.io.IOException

longToHex

public static char[] longToHex(long value)
Returns:
char array of 4 (zero padded) uppercase hex chars and prefixed with '0x'

intToHex

public static char[] intToHex(int value)
Returns:
char array of 4 (zero padded) uppercase hex chars and prefixed with '0x'

shortToHex

public static char[] shortToHex(int value)
Returns:
char array of 2 (zero padded) uppercase hex chars and prefixed with '0x'

byteToHex

public static char[] byteToHex(int value)
Returns:
char array of 1 (zero padded) uppercase hex chars and prefixed with '0x'

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HexRead

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class HexRead

java.lang.Object
    extended by  org.apache.poi.util.HexRead

public class HexRead
extends java.lang.Object

Utilities to read hex from files. TODO - move to test packages

Author:
Marc Johnson, Glen Stampoultzis (glens at apache.org)

Constructor Summary
HexRead()
Method Summary
static byte[] | readData(java.io.InputStream stream, int eofChar)
static byte[] | readData(java.io.InputStream stream, java.lang.String section) Same as readData(String) except that this method allows you to specify sections within a file.
static byte[] | readData(java.lang.String filename) This method reads hex data from a filename and returns a byte array.
static byte[] | readData(java.lang.String filename, java.lang.String section)
static byte[] | readFromString(java.lang.String data)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HexRead

public HexRead()
Method Detail

readData

public static byte[] readData(java.lang.String filename)
                       throws java.io.IOException
This method reads hex data from a filename and returns a byte array. The file may contain line comments that are preceeded with a # symbol.

Parameters:
filename - The filename to read
Returns:
The bytes read from the file.
Throws:
java.io.IOException - If there was a problem while reading the file.

readData

public static byte[] readData(java.io.InputStream stream,
                              java.lang.String section)
                       throws java.io.IOException
Same as readData(String) except that this method allows you to specify sections within a file. Sections are referenced using section headers in the form:
  [sectioname]

Throws:
java.io.IOException
See Also:
readData(String)

readData

public static byte[] readData(java.lang.String filename,
                              java.lang.String section)
                       throws java.io.IOException
Throws:
java.io.IOException

readData

public static byte[] readData(java.io.InputStream stream,
                              int eofChar)
                       throws java.io.IOException
Throws:
java.io.IOException

readFromString

public static byte[] readFromString(java.lang.String data)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class IdentifierManager

java.lang.Object
    extended by  org.apache.poi.util.IdentifierManager

public class IdentifierManager
extends java.lang.Object

24.08.2009

Author:
Stefan Stern

Field Summary
static long | MAX_ID
static long | MIN_ID
Constructor Summary
IdentifierManager(long lowerbound, long upperbound)
Method Summary
long | getRemainingIdentifiers()
boolean | release(long id)
long | reserve(long id)
long | reserveNew()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MAX_ID

public static final long MAX_ID
See Also:
Constant Field Values

MIN_ID

public static final long MIN_ID
See Also:
Constant Field Values
Constructor Detail

IdentifierManager

public IdentifierManager(long lowerbound,
                         long upperbound)
Parameters:
lowerbound - the lower limit of the id-range to manage. Must be greater than or equal to MIN_ID.
upperbound - the upper limit of the id-range to manage. Must be less then or equal MAX_ID.
Method Detail

reserve

public long reserve(long id)

reserveNew

public long reserveNew()
Returns:
a new identifier.
Throws:
java.lang.IllegalStateException - if no more identifiers are available, then an Exception is raised.

release

public boolean release(long id)
Parameters:
id - the identifier to release. Must be greater than or equal to lowerbound and must be less than or equal to upperbound
Returns:
true, if the identifier was reserved and has been successfully released, false, if the identifier was not reserved.

getRemainingIdentifiers

public long getRemainingIdentifiers()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntegerField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class IntegerField

java.lang.Object
    extended by  org.apache.poi.util.IntegerField
All Implemented Interfaces:
FixedField
public class IntegerField
extends java.lang.Object
implements FixedField

representation of an integer (32-bit) field at a fixed location within a byte array

Author:
Marc Johnson (mjohnson at apache dot org

Constructor Summary
IntegerField(int offset)
construct the IntegerField with its offset into its containing byte array
IntegerField(int offset, byte[] data)
Construct the IntegerField with its offset into its containing byte array and initialize its value from its byte array
IntegerField(int offset, int value)
construct the IntegerField with its offset into its containing byte array and initialize its value
IntegerField(int offset, int value, byte[] data)
construct the IntegerField with its offset into its containing byte array, initialize its value, and write the value to a byte array
Method Summary
int | get() get the IntegerField's current value
void | readFromBytes(byte[] data) set the value from its offset into an array of bytes
void | readFromStream(java.io.InputStream stream) set the value from an InputStream
void | set(int value) set the IntegerField's current value
void | set(int value, byte[] data) set the IntegerField's current value and write it to a byte array
java.lang.String | toString() return the value as a String
void | writeToBytes(byte[] data) write the value out to an array of bytes at the appropriate offset
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IntegerField

public IntegerField(int offset)
             throws java.lang.ArrayIndexOutOfBoundsException
construct the IntegerField with its offset into its containing byte array

Parameters:
offset - of the field within its byte array
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is negative

IntegerField

public IntegerField(int offset,
                    int value)
             throws java.lang.ArrayIndexOutOfBoundsException
construct the IntegerField with its offset into its containing byte array and initialize its value

Parameters:
offset - of the field within its byte array
value - the initial value
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is negative

IntegerField

public IntegerField(int offset,
                    byte[] data)
             throws java.lang.ArrayIndexOutOfBoundsException
Construct the IntegerField with its offset into its containing byte array and initialize its value from its byte array

Parameters:
offset - of the field within its byte array
data - the byte array to read the value from
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is not within the range of 0..(data.length - 1)

IntegerField

public IntegerField(int offset,
                    int value,
                    byte[] data)
             throws java.lang.ArrayIndexOutOfBoundsException
construct the IntegerField with its offset into its containing byte array, initialize its value, and write the value to a byte array

Parameters:
offset - of the field within its byte array
value - the initial value
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is negative or too large
Method Detail

get

public int get()
get the IntegerField's current value

Returns:
current value

set

public void set(int value)
set the IntegerField's current value

Parameters:
value - to be set

set

public void set(int value,
                byte[] data)
         throws java.lang.ArrayIndexOutOfBoundsException
set the IntegerField's current value and write it to a byte array

Parameters:
value - to be set
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is too large

readFromBytes

public void readFromBytes(byte[] data)
                   throws java.lang.ArrayIndexOutOfBoundsException
set the value from its offset into an array of bytes

Specified by:
readFromBytes in interface FixedField
Parameters:
data - the byte array from which the value is to be read
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is too large

readFromStream

public void readFromStream(java.io.InputStream stream)
                    throws java.io.IOException,
                           LittleEndian.BufferUnderrunException
set the value from an InputStream

Specified by:
readFromStream in interface FixedField
Parameters:
stream - the InputStream from which the value is to be read
Throws:
LittleEndian.BufferUnderrunException - if there is not enough data available from the InputStream
java.io.IOException - if an IOException is thrown from reading the InputStream

writeToBytes

public void writeToBytes(byte[] data)
                  throws java.lang.ArrayIndexOutOfBoundsException
write the value out to an array of bytes at the appropriate offset

Specified by:
writeToBytes in interface FixedField
Parameters:
data - the array of bytes to which the value is to be written
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is too large

toString

public java.lang.String toString()
return the value as a String

Specified by:
toString in interface FixedField
Overrides:
toString in class java.lang.Object
Returns:
the value as a String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Internal

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

org.apache.poi.util
Annotation Type Internal

@Documented
@Retention(value=RUNTIME)
public @interface Internal

Program elements annotated @Internal are intended for POI internal use only. Such elements are not public by design and likely to be removed in future versions of POI or access to such elements will be changed from 'public' to 'default' or less.

Since:
POI-3.6
Author:
Yegor Kozlov

Optional Element Summary
 java.lang.String value

value

public abstract java.lang.String value
Default:
""
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


IntList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class IntList

java.lang.Object
    extended by  org.apache.poi.util.IntList

public class IntList
extends java.lang.Object

A List of int's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows:

  • if possible, operations designated 'optional' in the List interface are attempted
  • wherever the List interface refers to an Object, substitute int
  • wherever the List interface refers to a Collection or List, substitute IntList
the mimicry is not perfect, however:
  • operations involving Iterators or ListIterators are not supported
  • remove(Object) becomes removeValue to distinguish it from remove(int index)
  • subList is not supported

Author:
Marc Johnson

Constructor Summary
IntList()
create an IntList of default size
IntList(int initialCapacity)
IntList(int initialCapacity, int fillvalue)
create an IntList with a predefined initial size
IntList(IntList list)
create a copy of an existing IntList
Method Summary
boolean | add(int value) Appends the specified element to the end of this list
void | add(int index, int value) add the specfied value at the specified index
boolean | addAll(int index, IntList c) Inserts all of the elements in the specified collection into this list at the specified position.
boolean | addAll(IntList c) Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
void | clear() Removes all of the elements from this list.
boolean | contains(int o) Returns true if this list contains the specified element.
boolean | containsAll(IntList c) Returns true if this list contains all of the elements of the specified collection.
boolean | equals(java.lang.Object o) Compares the specified object with this list for equality.
int | get(int index) Returns the element at the specified position in this list.
int | hashCode() Returns the hash code value for this list.
int | indexOf(int o) Returns the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element.
boolean | isEmpty() Returns true if this list contains no elements.
int | lastIndexOf(int o) Returns the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element.
int | remove(int index) Removes the element at the specified position in this list.
boolean | removeAll(IntList c) Removes from this list all the elements that are contained in the specified collection
boolean | removeValue(int o) Removes the first occurrence in this list of the specified element (optional operation).
boolean | retainAll(IntList c) Retains only the elements in this list that are contained in the specified collection.
int | set(int index, int element) Replaces the element at the specified position in this list with the specified element
int | size() Returns the number of elements in this list.
int[] | toArray() Returns an array containing all of the elements in this list in proper sequence.
int[] | toArray(int[] a) Returns an array containing all of the elements in this list in proper sequence.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IntList

public IntList()
create an IntList of default size

IntList

public IntList(int initialCapacity)

IntList

public IntList(IntList list)
create a copy of an existing IntList

Parameters:
list - the existing IntList

IntList

public IntList(int initialCapacity,
               int fillvalue)
create an IntList with a predefined initial size

Parameters:
initialCapacity - the size for the internal array
Method Detail

add

public void add(int index,
                int value)
add the specfied value at the specified index

Parameters:
index - the index where the new value is to be added
value - the new value
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index > size()).

add

public boolean add(int value)
Appends the specified element to the end of this list

Parameters:
value - element to be appended to this list.
Returns:
true (as per the general contract of the Collection.add method).

addAll

public boolean addAll(IntList c)
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator. The behavior of this operation is unspecified if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Parameters:
c - collection whose elements are to be added to this list.
Returns:
true if this list changed as a result of the call.

addAll

public boolean addAll(int index,
                      IntList c)
Inserts all of the elements in the specified collection into this list at the specified position. Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is unspecified if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Parameters:
index - index at which to insert first element from the specified collection.
c - elements to be inserted into this list.
Returns:
true if this list changed as a result of the call.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index > size())

clear

public void clear()
Removes all of the elements from this list. This list will be empty after this call returns (unless it throws an exception).

contains

public boolean contains(int o)
Returns true if this list contains the specified element. More formally, returns true if and only if this list contains at least one element e such that o == e

Parameters:
o - element whose presence in this list is to be tested.
Returns:
true if this list contains the specified element.

containsAll

public boolean containsAll(IntList c)
Returns true if this list contains all of the elements of the specified collection.

Parameters:
c - collection to be checked for containment in this list.
Returns:
true if this list contains all of the elements of the specified collection.

equals

public boolean equals(java.lang.Object o)
Compares the specified object with this list for equality. Returns true if and only if the specified object is also a list, both lists have the same size, and all corresponding pairs of elements in the two lists are equal. (Two elements e1 and e2 are equal if e1 == e2.) In other words, two lists are defined to be equal if they contain the same elements in the same order. This definition ensures that the equals method works properly across different implementations of the List interface.

Overrides:
equals in class java.lang.Object
Parameters:
o - the object to be compared for equality with this list.
Returns:
true if the specified object is equal to this list.

get

public int get(int index)
Returns the element at the specified position in this list.

Parameters:
index - index of element to return.
Returns:
the element at the specified position in this list.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size()).

hashCode

public int hashCode()
Returns the hash code value for this list. The hash code of a list is defined to be the result of the following calculation:
hashCode = 1;
Iterator i = list.iterator();
while (i.hasNext()) {
     Object obj = i.next();
     hashCode = 31*hashCode + (obj==null ? 0 : obj.hashCode());
}
 This ensures that list1.equals(list2) implies that list1.hashCode()==list2.hashCode() for any two lists, list1 and list2, as required by the general contract of Object.hashCode.

Overrides:
hashCode in class java.lang.Object
Returns:
the hash code value for this list.

indexOf

public int indexOf(int o)
Returns the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element. More formally, returns the lowest index i such that (o == get(i)), or -1 if there is no such index.

Parameters:
o - element to search for.
Returns:
the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element.

isEmpty

public boolean isEmpty()
Returns true if this list contains no elements.

Returns:
true if this list contains no elements.

lastIndexOf

public int lastIndexOf(int o)
Returns the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element. More formally, returns the highest index i such that (o == get(i)), or -1 if there is no such index.

Parameters:
o - element to search for.
Returns:
the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element.

remove

public int remove(int index)
Removes the element at the specified position in this list. Shifts any subsequent elements to the left (subtracts one from their indices). Returns the element that was removed from the list.

Parameters:
index - the index of the element to removed.
Returns:
the element previously at the specified position.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size()).

removeValue

public boolean removeValue(int o)
Removes the first occurrence in this list of the specified element (optional operation). If this list does not contain the element, it is unchanged. More formally, removes the element with the lowest index i such that (o.equals(get(i))) (if such an element exists).

Parameters:
o - element to be removed from this list, if present.
Returns:
true if this list contained the specified element.

removeAll

public boolean removeAll(IntList c)
Removes from this list all the elements that are contained in the specified collection

Parameters:
c - collection that defines which elements will be removed from this list.
Returns:
true if this list changed as a result of the call.

retainAll

public boolean retainAll(IntList c)
Retains only the elements in this list that are contained in the specified collection. In other words, removes from this list all the elements that are not contained in the specified collection.

Parameters:
c - collection that defines which elements this set will retain.
Returns:
true if this list changed as a result of the call.

set

public int set(int index,
               int element)
Replaces the element at the specified position in this list with the specified element

Parameters:
index - index of element to replace.
element - element to be stored at the specified position.
Returns:
the element previously at the specified position.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size()).

size

public int size()
Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.

Returns:
the number of elements in this IntList

toArray

public int[] toArray()
Returns an array containing all of the elements in this list in proper sequence. Obeys the general contract of the Collection.toArray method.

Returns:
an array containing all of the elements in this list in proper sequence.

toArray

public int[] toArray(int[] a)
Returns an array containing all of the elements in this list in proper sequence. Obeys the general contract of the Collection.toArray(Object[]) method.

Parameters:
a - the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array is allocated for this purpose.
Returns:
an array containing the elements of this list.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntMapper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class IntMapper<T>

java.lang.Object
    extended by  org.apache.poi.util.IntMapper<T>

public class IntMapper<T>
extends java.lang.Object

A List of objects that are indexed AND keyed by an int; also allows for getting the index of a value in the list

I am happy is someone wants to re-implement this without using the internal list and hashmap. If so could you please make sure that you can add elements half way into the list and have the value-key mappings update

Author:
Jason Height

Constructor Summary
IntMapper()
create an IntMapper of default size
IntMapper(int initialCapacity)
Method Summary
boolean | add(T value) Appends the specified element to the end of this list
T | get(int index)
int | getIndex(T o)
java.util.Iterator<T> | iterator()
int | size()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IntMapper

public IntMapper()
create an IntMapper of default size

IntMapper

public IntMapper(int initialCapacity)
Method Detail

add

public boolean add(T value)
Appends the specified element to the end of this list

Parameters:
value - element to be appended to this list.
Returns:
true (as per the general contract of the Collection.add method).

size

public int size()

get

public T get(int index)

getIndex

public int getIndex(T o)

iterator

public java.util.Iterator<T> iterator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IOUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class IOUtils

java.lang.Object
    extended by  org.apache.poi.util.IOUtils

public final class IOUtils
extends java.lang.Object

Method Summary
static long calculateChecksum(byte[] data)
static void closeQuietly(java.io.Closeable closeable)
Quietly (no exceptions) close Closable resource.
static void copy(java.io.InputStream inp, java.io.OutputStream out)
Copies all the data from the given InputStream to the OutputStream.
static int readFully(java.io.InputStream in, byte[] b)
Helper method, just calls readFully(in, b, 0, b.length)
static int readFully(java.io.InputStream in, byte[] b, int off, int len)
Same as the normal in.read(b, off, len), but tries to ensure that the entire len number of bytes is read.
static int readFully(java.nio.channels.ReadableByteChannel channel, java.nio.ByteBuffer b)
Same as the normal channel.read(b), but tries to ensure that the entire len number of bytes is read.
static byte[] toByteArray(java.nio.ByteBuffer buffer, int length)
Returns an array (that shouldn't be written to!) of the ByteBuffer.
static byte[] toByteArray(java.io.InputStream stream)
Reads all the data from the input stream, and returns the bytes read.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

toByteArray

public static byte[] toByteArray(java.io.InputStream stream)
                          throws java.io.IOException
Reads all the data from the input stream, and returns the bytes read.

Throws:
java.io.IOException

toByteArray

public static byte[] toByteArray(java.nio.ByteBuffer buffer,
                                 int length)
Returns an array (that shouldn't be written to!) of the ByteBuffer. Will be of the requested length, or possibly longer if that's easier.

readFully

public static int readFully(java.io.InputStream in,
                            byte[] b)
                     throws java.io.IOException
Helper method, just calls readFully(in, b, 0, b.length)

Throws:
java.io.IOException

readFully

public static int readFully(java.io.InputStream in,
                            byte[] b,
                            int off,
                            int len)
                     throws java.io.IOException
Same as the normal in.read(b, off, len), but tries to ensure that the entire len number of bytes is read.

If the end of file is reached before any bytes are read, returns -1. If the end of the file is reached after some bytes are read, returns the number of bytes read. If the end of the file isn't reached before len bytes have been read, will return len bytes.

Throws:
java.io.IOException

readFully

public static int readFully(java.nio.channels.ReadableByteChannel channel,
                            java.nio.ByteBuffer b)
                     throws java.io.IOException
Same as the normal channel.read(b), but tries to ensure that the entire len number of bytes is read.

If the end of file is reached before any bytes are read, returns -1. If the end of the file is reached after some bytes are read, returns the number of bytes read. If the end of the file isn't reached before len bytes have been read, will return len bytes.

Throws:
java.io.IOException

copy

public static void copy(java.io.InputStream inp,
                        java.io.OutputStream out)
                 throws java.io.IOException
Copies all the data from the given InputStream to the OutputStream. It leaves both streams open, so you will still need to close them once done.

Throws:
java.io.IOException

calculateChecksum

public static long calculateChecksum(byte[] data)

closeQuietly

public static void closeQuietly(java.io.Closeable closeable)
Quietly (no exceptions) close Closable resource. In case of error it will be printed to IOUtils class logger.

Parameters:
closeable - resource to close
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndian.BufferUnderrunException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LittleEndian.BufferUnderrunException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.io.IOException
                extended by  org.apache.poi.util.LittleEndian.BufferUnderrunException
All Implemented Interfaces:
java.io.Serializable
Enclosing class:
LittleEndian
public static final class LittleEndian.BufferUnderrunException
extends java.io.IOException

Exception to handle buffer underruns

Author:
Marc Johnson (mjohnson at apache dot org)
See Also:
Serialized Form

Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndian

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LittleEndian

java.lang.Object
    extended by  org.apache.poi.util.LittleEndian
All Implemented Interfaces:
LittleEndianConsts
public class LittleEndian
extends java.lang.Object
implements LittleEndianConsts

a utility class for handling little-endian numbers, which the 80x86 world is replete with. The methods are all static, and input/output is from/to byte arrays, or from InputStreams.

Author:
Marc Johnson (mjohnson at apache dot org), Andrew Oliver (acoliver at apache dot org)

Nested Class Summary
static class LittleEndian.BufferUnderrunException
Exception to handle buffer underruns
Field Summary
Fields inherited from interface org.apache.poi.util.LittleEndianConsts
BYTE_SIZE, DOUBLE_SIZE, INT_SIZE, LONG_SIZE, SHORT_SIZE
Method Summary
static byte[] getByteArray(byte[] data, int offset, int size)
Copy a portion of a byte array
static double getDouble(byte[] data)
get a double value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java double
static double getDouble(byte[] data, int offset)
get a double value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java double
static float getFloat(byte[] data)
get a float value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java float
static float getFloat(byte[] data, int offset)
get a float value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java float
static int getInt(byte[] data)
get an int value from the beginning of a byte array
static int getInt(byte[] data, int offset)
get an int value from a byte array
static long getLong(byte[] data)
get a long value from a byte array
static long getLong(byte[] data, int offset)
get a long value from a byte array
static short getShort(byte[] data)
get a short value from the beginning of a byte array
static short getShort(byte[] data, int offset)
get a short value from a byte array
static short[] getShortArray(byte[] data, int offset, int size)
Read short array
static short getUByte(byte[] data)
get the unsigned value of a byte.
static short getUByte(byte[] data, int offset)
get the unsigned value of a byte.
static long getUInt(byte[] data)
get an unsigned int value from a byte array
static long getUInt(byte[] data, int offset)
get an unsigned int value from a byte array
static int getUnsignedByte(byte[] data, int offset)
Deprecated. Use getUByte(byte[], int) instead
static int getUShort(byte[] data)
get an unsigned short value from the beginning of a byte array
static int getUShort(byte[] data, int offset)
get an unsigned short value from a byte array
static void putByte(byte[] data, int offset, int value)
executes:

data[offset] = (byte)value;

static void putDouble(byte[] data, int offset, double value)
put a double value into a byte array
static void putDouble(double value, java.io.OutputStream outputStream)
put a double value into a byte array
static void putFloat(byte[] data, int offset, float value)
put a float value into a byte array
static void putFloat(float value, java.io.OutputStream outputStream)
put a float value into a byte array
static void putInt(byte[] data, int value)
Deprecated. Use putInt(byte[], int, int) instead
static void putInt(byte[] data, int offset, int value)
put an int value into a byte array
static void putInt(int value, java.io.OutputStream outputStream)
Put int into output stream
static void putLong(byte[] data, int offset, long value)
put a long value into a byte array
static void putLong(long value, java.io.OutputStream outputStream)
Put long into output stream
static void putShort(byte[] data, int offset, short value)
put a short value into a byte array
static void putShort(byte[] data, short value)
Deprecated. Use putShort(byte[], int, short) instead
static void putShort(java.io.OutputStream outputStream, short value)
Put signed short into output stream
static void putShortArray(byte[] data, int startOffset, short[] value)
Stores short array in buffer
static void putUByte(byte[] data, int offset, short value)
put an unsigned byte value into a byte array
static void putUInt(byte[] data, int offset, long value)
put an unsigned int value into a byte array
static void putUInt(byte[] data, long value)
Deprecated. Use putUInt(byte[], int, long) instead
static void putUInt(long value, java.io.OutputStream outputStream)
Put unsigned int into output stream
static void putUShort(byte[] data, int offset, int value)
put an unsigned short value into a byte array
static void putUShort(int value, java.io.OutputStream outputStream)
Put unsigned short into output stream
static int readInt(java.io.InputStream stream)
get an int value from an InputStream
static long readLong(java.io.InputStream stream)
get a long value from an InputStream
static short readShort(java.io.InputStream stream)
get a short value from an InputStream
static int readUShort(java.io.InputStream stream)
static int ubyteToInt(byte b)
Convert an 'unsigned' byte to an integer.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getByteArray

public static byte[] getByteArray(byte[] data,
                                  int offset,
                                  int size)
Copy a portion of a byte array

Parameters:
data - the original byte array
offset - Where to start copying from.
size - Number of bytes to copy.
Returns:
The byteArray value
Throws:
java.lang.IndexOutOfBoundsException - - if copying would cause access of data outside array bounds.

getDouble

public static double getDouble(byte[] data)
get a double value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java double

Parameters:
data - the byte array
Returns:
the double (64-bit) value

getDouble

public static double getDouble(byte[] data,
                               int offset)
get a double value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java double

Parameters:
data - the byte array
offset - a starting offset into the byte array
Returns:
the double (64-bit) value

getFloat

public static float getFloat(byte[] data)
get a float value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java float

Parameters:
data - the byte array
Returns:
the double (64-bit) value

getFloat

public static float getFloat(byte[] data,
                             int offset)
get a float value from a byte array, reads it in little endian format then converts the resulting revolting IEEE 754 (curse them) floating point number to a happy java float

Parameters:
data - the byte array
offset - a starting offset into the byte array
Returns:
the double (64-bit) value

getInt

public static int getInt(byte[] data)
get an int value from the beginning of a byte array

Parameters:
data - the byte array
Returns:
the int (32-bit) value

getInt

public static int getInt(byte[] data,
                         int offset)
get an int value from a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
Returns:
the int (32-bit) value

getLong

public static long getLong(byte[] data)
get a long value from a byte array

Parameters:
data - the byte array
Returns:
the long (64-bit) value

getLong

public static long getLong(byte[] data,
                           int offset)
get a long value from a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
Returns:
the long (64-bit) value

getShort

public static short getShort(byte[] data)
get a short value from the beginning of a byte array

Parameters:
data - the byte array
Returns:
the short (16-bit) value

getShort

public static short getShort(byte[] data,
                             int offset)
get a short value from a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
Returns:
the short (16-bit) value

getShortArray

public static short[] getShortArray(byte[] data,
                                    int offset,
                                    int size)
Read short array

Parameters:
data - the original byte array
offset - Where to start copying from.
size - Number of bytes to copy.
Throws:
java.lang.IndexOutOfBoundsException - - if read would cause access of data outside array bounds.

getUByte

public static short getUByte(byte[] data)
get the unsigned value of a byte.

Parameters:
data - the byte array.
Returns:
the unsigned value of the byte as a 16 bit short

getUByte

public static short getUByte(byte[] data,
                             int offset)
get the unsigned value of a byte.

Parameters:
data - the byte array.
offset - a starting offset into the byte array.
Returns:
the unsigned value of the byte as a 16 bit short

getUInt

public static long getUInt(byte[] data)
get an unsigned int value from a byte array

Parameters:
data - the byte array
Returns:
the unsigned int (32-bit) value in a long

getUInt

public static long getUInt(byte[] data,
                           int offset)
get an unsigned int value from a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
Returns:
the unsigned int (32-bit) value in a long

getUnsignedByte

@Deprecated
public static int getUnsignedByte(byte[] data,
                                             int offset)
Deprecated. Use getUByte(byte[], int) instead

get the unsigned value of a byte.

Parameters:
data - the byte array.
offset - a starting offset into the byte array.
Returns:
the unsigned value of the byte as a 32 bit integer

getUShort

public static int getUShort(byte[] data)
get an unsigned short value from the beginning of a byte array

Parameters:
data - the byte array
Returns:
the unsigned short (16-bit) value in an int

getUShort

public static int getUShort(byte[] data,
                            int offset)
get an unsigned short value from a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
Returns:
the unsigned short (16-bit) value in an integer

putByte

public static void putByte(byte[] data,
                           int offset,
                           int value)
executes:

data[offset] = (byte)value;

Added for consistency with other put~() methods

putDouble

public static void putDouble(byte[] data,
                             int offset,
                             double value)
put a double value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the double (64-bit) value

putDouble

public static void putDouble(double value,
                             java.io.OutputStream outputStream)
                      throws java.io.IOException
put a double value into a byte array

Parameters:
value - the double (64-bit) value
outputStream - output stream
Throws:
java.io.IOException - if an I/O error occurs

putFloat

public static void putFloat(byte[] data,
                            int offset,
                            float value)
put a float value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the float (32-bit) value

putFloat

public static void putFloat(float value,
                            java.io.OutputStream outputStream)
                     throws java.io.IOException
put a float value into a byte array

Parameters:
value - the float (32-bit) value
outputStream - output stream
Throws:
java.io.IOException - if an I/O error occurs

putInt

@Deprecated
public static void putInt(byte[] data,
                                     int value)
Deprecated. Use putInt(byte[], int, int) instead

put an int value into beginning of a byte array

Parameters:
data - the byte array
value - the int (32-bit) value

putInt

public static void putInt(byte[] data,
                          int offset,
                          int value)
put an int value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the int (32-bit) value

putInt

public static void putInt(int value,
                          java.io.OutputStream outputStream)
                   throws java.io.IOException
Put int into output stream

Parameters:
value - the int (32-bit) value
outputStream - output stream
Throws:
java.io.IOException - if an I/O error occurs

putLong

public static void putLong(byte[] data,
                           int offset,
                           long value)
put a long value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the long (64-bit) value

putLong

public static void putLong(long value,
                           java.io.OutputStream outputStream)
                    throws java.io.IOException
Put long into output stream

Parameters:
value - the long (64-bit) value
outputStream - output stream
Throws:
java.io.IOException - if an I/O error occurs

putShort

public static void putShort(byte[] data,
                            int offset,
                            short value)
put a short value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the short (16-bit) value

putShort

@Deprecated
public static void putShort(byte[] data,
                                       short value)
Deprecated. Use putShort(byte[], int, short) instead

put a short value into beginning of a byte array

Parameters:
data - the byte array
value - the short (16-bit) value

putShort

public static void putShort(java.io.OutputStream outputStream,
                            short value)
                     throws java.io.IOException
Put signed short into output stream

Parameters:
value - the short (16-bit) value
outputStream - output stream
Throws:
java.io.IOException - if an I/O error occurs

putShortArray

public static void putShortArray(byte[] data,
                                 int startOffset,
                                 short[] value)
Stores short array in buffer

Parameters:
data - the byte array
startOffset - a starting offset into the byte array
value - the short (16-bit) values

putUByte

public static void putUByte(byte[] data,
                            int offset,
                            short value)
put an unsigned byte value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the short (16-bit) value
Throws:
java.lang.ArrayIndexOutOfBoundsException - may be thrown

putUInt

public static void putUInt(byte[] data,
                           int offset,
                           long value)
put an unsigned int value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the int (32-bit) value
Throws:
java.lang.ArrayIndexOutOfBoundsException - may be thrown

putUInt

@Deprecated
public static void putUInt(byte[] data,
                                      long value)
Deprecated. Use putUInt(byte[], int, long) instead

put an unsigned int value into beginning of a byte array

Parameters:
data - the byte array
value - the int (32-bit) value

putUInt

public static void putUInt(long value,
                           java.io.OutputStream outputStream)
                    throws java.io.IOException
Put unsigned int into output stream

Parameters:
value - the int (32-bit) value
outputStream - output stream
Throws:
java.io.IOException - if an I/O error occurs

putUShort

public static void putUShort(byte[] data,
                             int offset,
                             int value)
put an unsigned short value into a byte array

Parameters:
data - the byte array
offset - a starting offset into the byte array
value - the short (16-bit) value
Throws:
java.lang.ArrayIndexOutOfBoundsException - may be thrown

putUShort

public static void putUShort(int value,
                             java.io.OutputStream outputStream)
                      throws java.io.IOException
Put unsigned short into output stream

Parameters:
value - the unsigned short (16-bit) value
outputStream - output stream
Throws:
java.io.IOException - if an I/O error occurs

readInt

public static int readInt(java.io.InputStream stream)
                   throws java.io.IOException,
                          LittleEndian.BufferUnderrunException
get an int value from an InputStream

Parameters:
stream - the InputStream from which the int is to be read
Returns:
the int (32-bit) value
Throws:
java.io.IOException - will be propagated back to the caller
LittleEndian.BufferUnderrunException - if the stream cannot provide enough bytes

readLong

public static long readLong(java.io.InputStream stream)
                     throws java.io.IOException,
                            LittleEndian.BufferUnderrunException
get a long value from an InputStream

Parameters:
stream - the InputStream from which the long is to be read
Returns:
the long (64-bit) value
Throws:
java.io.IOException - will be propagated back to the caller
LittleEndian.BufferUnderrunException - if the stream cannot provide enough bytes

readShort

public static short readShort(java.io.InputStream stream)
                       throws java.io.IOException,
                              LittleEndian.BufferUnderrunException
get a short value from an InputStream

Parameters:
stream - the InputStream from which the short is to be read
Returns:
the short (16-bit) value
Throws:
java.io.IOException - will be propagated back to the caller
LittleEndian.BufferUnderrunException - if the stream cannot provide enough bytes

readUShort

public static int readUShort(java.io.InputStream stream)
                      throws java.io.IOException,
                             LittleEndian.BufferUnderrunException
Throws:
java.io.IOException
LittleEndian.BufferUnderrunException

ubyteToInt

public static int ubyteToInt(byte b)
Convert an 'unsigned' byte to an integer. ie, don't carry across the sign.

Parameters:
b - Description of the Parameter
Returns:
Description of the Return Value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndianByteArrayInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LittleEndianByteArrayInputStream

java.lang.Object
    extended by  org.apache.poi.util.LittleEndianByteArrayInputStream
All Implemented Interfaces:
LittleEndianInput
public final class LittleEndianByteArrayInputStream
extends java.lang.Object
implements LittleEndianInput

Adapts a plain byte array to LittleEndianInput

Author:
Josh Micich

Constructor Summary
LittleEndianByteArrayInputStream(byte[] buf)
LittleEndianByteArrayInputStream(byte[] buf, int startOffset)
LittleEndianByteArrayInputStream(byte[] buf, int startOffset, int maxReadLen)
Method Summary
int | available()
int | getReadIndex()
byte | readByte()
double | readDouble()
void | readFully(byte[] buf)
void | readFully(byte[] buf, int off, int len)
int | readInt()
long | readLong()
short | readShort()
int | readUByte()
int | readUShort()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LittleEndianByteArrayInputStream

public LittleEndianByteArrayInputStream(byte[] buf,
                                        int startOffset,
                                        int maxReadLen)

LittleEndianByteArrayInputStream

public LittleEndianByteArrayInputStream(byte[] buf,
                                        int startOffset)

LittleEndianByteArrayInputStream

public LittleEndianByteArrayInputStream(byte[] buf)
Method Detail

available

public int available()
Specified by:
available in interface LittleEndianInput

getReadIndex

public int getReadIndex()

readByte

public byte readByte()
Specified by:
readByte in interface LittleEndianInput

readInt

public int readInt()
Specified by:
readInt in interface LittleEndianInput

readLong

public long readLong()
Specified by:
readLong in interface LittleEndianInput

readShort

public short readShort()
Specified by:
readShort in interface LittleEndianInput

readUByte

public int readUByte()
Specified by:
readUByte in interface LittleEndianInput

readUShort

public int readUShort()
Specified by:
readUShort in interface LittleEndianInput

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput

readFully

public void readFully(byte[] buf)
Specified by:
readFully in interface LittleEndianInput

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndianByteArrayOutputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LittleEndianByteArrayOutputStream

java.lang.Object
    extended by  org.apache.poi.util.LittleEndianByteArrayOutputStream
All Implemented Interfaces:
DelayableLittleEndianOutput, LittleEndianOutput
public final class LittleEndianByteArrayOutputStream
extends java.lang.Object
implements LittleEndianOutput, DelayableLittleEndianOutput

Adapts a plain byte array to LittleEndianOutput

Author:
Josh Micich

Constructor Summary
LittleEndianByteArrayOutputStream(byte[] buf, int startOffset)
LittleEndianByteArrayOutputStream(byte[] buf, int startOffset, int maxWriteLen)
Method Summary
LittleEndianOutput | createDelayedOutput(int size) Creates an output stream intended for outputting a sequence of size bytes.
int | getWriteIndex()
void | write(byte[] b)
void | write(byte[] b, int offset, int len)
void | writeByte(int v)
void | writeDouble(double v)
void | writeInt(int v)
void | writeLong(long v)
void | writeShort(int v)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LittleEndianByteArrayOutputStream

public LittleEndianByteArrayOutputStream(byte[] buf,
                                         int startOffset,
                                         int maxWriteLen)

LittleEndianByteArrayOutputStream

public LittleEndianByteArrayOutputStream(byte[] buf,
                                         int startOffset)
Method Detail

writeByte

public void writeByte(int v)
Specified by:
writeByte in interface LittleEndianOutput

writeDouble

public void writeDouble(double v)
Specified by:
writeDouble in interface LittleEndianOutput

writeInt

public void writeInt(int v)
Specified by:
writeInt in interface LittleEndianOutput

writeLong

public void writeLong(long v)
Specified by:
writeLong in interface LittleEndianOutput

writeShort

public void writeShort(int v)
Specified by:
writeShort in interface LittleEndianOutput

write

public void write(byte[] b)
Specified by:
write in interface LittleEndianOutput

write

public void write(byte[] b,
                  int offset,
                  int len)
Specified by:
write in interface LittleEndianOutput

getWriteIndex

public int getWriteIndex()

createDelayedOutput

public LittleEndianOutput createDelayedOutput(int size)
Description copied from interface: DelayableLittleEndianOutput
Creates an output stream intended for outputting a sequence of size bytes.

Specified by:
createDelayedOutput in interface DelayableLittleEndianOutput
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndianConsts

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Interface LittleEndianConsts

All Known Implementing Classes:
LittleEndian
public interface LittleEndianConsts

a repository for constants shared by classes within this package

Author:
Marc Johnson, Andrew C. Oliver (acoliver at apache dot org)

Field Summary
static int | BYTE_SIZE
static int | DOUBLE_SIZE
static int | INT_SIZE
static int | LONG_SIZE
static int | SHORT_SIZE

Field Detail

BYTE_SIZE

static final int BYTE_SIZE
See Also:
Constant Field Values

SHORT_SIZE

static final int SHORT_SIZE
See Also:
Constant Field Values

INT_SIZE

static final int INT_SIZE
See Also:
Constant Field Values

LONG_SIZE

static final int LONG_SIZE
See Also:
Constant Field Values

DOUBLE_SIZE

static final int DOUBLE_SIZE
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndianInput

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Interface LittleEndianInput

All Known Implementing Classes:
Biff8DecryptingStream, ContinuableRecordInput, DocumentInputStream, LittleEndianByteArrayInputStream, LittleEndianInputStream, NDocumentInputStream, ODocumentInputStream, RecordInputStream
public interface LittleEndianInput

Author:
Josh Micich

Method Summary
int | available()
byte | readByte()
double | readDouble()
void | readFully(byte[] buf)
void | readFully(byte[] buf, int off, int len)
int | readInt()
long | readLong()
short | readShort()
int | readUByte()
int | readUShort()

Method Detail

available

int available()

readByte

byte readByte()

readUByte

int readUByte()

readShort

short readShort()

readUShort

int readUShort()

readInt

int readInt()

readLong

long readLong()

readDouble

double readDouble()

readFully

void readFully(byte[] buf)

readFully

void readFully(byte[] buf,
               int off,
               int len)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndianInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LittleEndianInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  java.io.FilterInputStream
            extended by  org.apache.poi.util.LittleEndianInputStream
All Implemented Interfaces:
java.io.Closeable, LittleEndianInput
public class LittleEndianInputStream
extends java.io.FilterInputStream
implements LittleEndianInput

Wraps an InputStream providing LittleEndianInput

This class does not buffer any input, so the stream read position maintained by this class is consistent with that of the inner stream.

Author:
Josh Micich

Field Summary
Fields inherited from class java.io.FilterInputStream
in
Constructor Summary
LittleEndianInputStream(java.io.InputStream is)
Method Summary
int | available()
byte | readByte()
double | readDouble()
void | readFully(byte[] buf)
void | readFully(byte[] buf, int off, int len)
int | readInt()
long | readLong()
short | readShort()
int | readUByte()
int | readUShort()
Methods inherited from class java.io.FilterInputStream
close, mark, markSupported, read, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LittleEndianInputStream

public LittleEndianInputStream(java.io.InputStream is)
Method Detail

available

public int available()
Specified by:
available in interface LittleEndianInput
Overrides:
available in class java.io.FilterInputStream

readByte

public byte readByte()
Specified by:
readByte in interface LittleEndianInput

readUByte

public int readUByte()
Specified by:
readUByte in interface LittleEndianInput

readDouble

public double readDouble()
Specified by:
readDouble in interface LittleEndianInput

readInt

public int readInt()
Specified by:
readInt in interface LittleEndianInput

readLong

public long readLong()
Specified by:
readLong in interface LittleEndianInput

readShort

public short readShort()
Specified by:
readShort in interface LittleEndianInput

readUShort

public int readUShort()
Specified by:
readUShort in interface LittleEndianInput

readFully

public void readFully(byte[] buf)
Specified by:
readFully in interface LittleEndianInput

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
Specified by:
readFully in interface LittleEndianInput
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndianOutput

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Interface LittleEndianOutput

All Known Subinterfaces:
DelayableLittleEndianOutput
All Known Implementing Classes:
ContinuableRecordOutput, LittleEndianByteArrayOutputStream, LittleEndianOutputStream
public interface LittleEndianOutput

Author:
Josh Micich

Method Summary
void | write(byte[] b)
void | write(byte[] b, int offset, int len)
void | writeByte(int v)
void | writeDouble(double v)
void | writeInt(int v)
void | writeLong(long v)
void | writeShort(int v)

Method Detail

writeByte

void writeByte(int v)

writeShort

void writeShort(int v)

writeInt

void writeInt(int v)

writeLong

void writeLong(long v)

writeDouble

void writeDouble(double v)

write

void write(byte[] b)

write

void write(byte[] b,
           int offset,
           int len)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LittleEndianOutputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LittleEndianOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  java.io.FilterOutputStream
            extended by  org.apache.poi.util.LittleEndianOutputStream
All Implemented Interfaces:
java.io.Closeable, java.io.Flushable, LittleEndianOutput
public final class LittleEndianOutputStream
extends java.io.FilterOutputStream
implements LittleEndianOutput

Author:
Josh Micich

Field Summary
Fields inherited from class java.io.FilterOutputStream
out
Constructor Summary
LittleEndianOutputStream(java.io.OutputStream out)
Method Summary
void | write(byte[] b)
void | write(byte[] b, int off, int len)
void | writeByte(int v)
void | writeDouble(double v)
void | writeInt(int v)
void | writeLong(long v)
void | writeShort(int v)
Methods inherited from class java.io.FilterOutputStream
close, flush, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LittleEndianOutputStream

public LittleEndianOutputStream(java.io.OutputStream out)
Method Detail

writeByte

public void writeByte(int v)
Specified by:
writeByte in interface LittleEndianOutput

writeDouble

public void writeDouble(double v)
Specified by:
writeDouble in interface LittleEndianOutput

writeInt

public void writeInt(int v)
Specified by:
writeInt in interface LittleEndianOutput

writeLong

public void writeLong(long v)
Specified by:
writeLong in interface LittleEndianOutput

writeShort

public void writeShort(int v)
Specified by:
writeShort in interface LittleEndianOutput

write

public void write(byte[] b)
Specified by:
write in interface LittleEndianOutput
Overrides:
write in class java.io.FilterOutputStream

write

public void write(byte[] b,
                  int off,
                  int len)
Specified by:
write in interface LittleEndianOutput
Overrides:
write in class java.io.FilterOutputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LongField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LongField

java.lang.Object
    extended by  org.apache.poi.util.LongField
All Implemented Interfaces:
FixedField
public class LongField
extends java.lang.Object
implements FixedField

representation of a long (16-bit) field at a fixed location within a byte array

Author:
Marc Johnson (mjohnson at apache dot org

Constructor Summary
LongField(int offset)
construct the LongField with its offset into its containing byte array
LongField(int offset, byte[] data)
Construct the LongField with its offset into its containing byte array and initialize its value from its byte array
LongField(int offset, long value)
construct the LongField with its offset into its containing byte array and initialize its value
LongField(int offset, long value, byte[] data)
construct the LongField with its offset into its containing byte array, initialize its value, and write the value to a byte array
Method Summary
long | get() get the LongField's current value
void | readFromBytes(byte[] data) set the value from its offset into an array of bytes
void | readFromStream(java.io.InputStream stream) set the value from an InputStream
void | set(long value) set the LongField's current value
void | set(long value, byte[] data) set the LongField's current value and write it to a byte array
java.lang.String | toString() return the value as a String
void | writeToBytes(byte[] data) write the value out to an array of bytes at the appropriate offset
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LongField

public LongField(int offset)
          throws java.lang.ArrayIndexOutOfBoundsException
construct the LongField with its offset into its containing byte array

Parameters:
offset - of the field within its byte array
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative

LongField

public LongField(int offset,
                 long value)
          throws java.lang.ArrayIndexOutOfBoundsException
construct the LongField with its offset into its containing byte array and initialize its value

Parameters:
offset - of the field within its byte array
value - the initial value
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative

LongField

public LongField(int offset,
                 byte[] data)
          throws java.lang.ArrayIndexOutOfBoundsException
Construct the LongField with its offset into its containing byte array and initialize its value from its byte array

Parameters:
offset - of the field within its byte array
data - the byte array to read the value from
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is not within the range of 0..(data.length - 1)

LongField

public LongField(int offset,
                 long value,
                 byte[] data)
          throws java.lang.ArrayIndexOutOfBoundsException
construct the LongField with its offset into its containing byte array, initialize its value, and write the value to a byte array

Parameters:
offset - of the field within its byte array
value - the initial value
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative
Method Detail

get

public long get()
get the LongField's current value

Returns:
current value

set

public void set(long value)
set the LongField's current value

Parameters:
value - to be set

set

public void set(long value,
                byte[] data)
         throws java.lang.ArrayIndexOutOfBoundsException
set the LongField's current value and write it to a byte array

Parameters:
value - to be set
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of range

readFromBytes

public void readFromBytes(byte[] data)
                   throws java.lang.ArrayIndexOutOfBoundsException
set the value from its offset into an array of bytes

Specified by:
readFromBytes in interface FixedField
Parameters:
data - the byte array from which the value is to be read
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of range

readFromStream

public void readFromStream(java.io.InputStream stream)
                    throws java.io.IOException,
                           LittleEndian.BufferUnderrunException
set the value from an InputStream

Specified by:
readFromStream in interface FixedField
Parameters:
stream - the InputStream from which the value is to be read
Throws:
LittleEndian.BufferUnderrunException - if there is not enough data available from the InputStream
java.io.IOException - if an IOException is thrown from reading the InputStream

writeToBytes

public void writeToBytes(byte[] data)
                  throws java.lang.ArrayIndexOutOfBoundsException
write the value out to an array of bytes at the appropriate offset

Specified by:
writeToBytes in interface FixedField
Parameters:
data - the array of bytes to which the value is to be written
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of range

toString

public java.lang.String toString()
return the value as a String

Specified by:
toString in interface FixedField
Overrides:
toString in class java.lang.Object
Returns:
the value as a String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LZWDecompresser

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class LZWDecompresser

java.lang.Object
    extended by  org.apache.poi.util.LZWDecompresser
Direct Known Subclasses:
CompressedRTF, HDGFLZW
public abstract class LZWDecompresser
extends java.lang.Object

This class provides common functionality for the various LZW implementations in the different file formats. It's currently used by HDGF and HMEF. Two good resources on LZW are: http://en.wikipedia.org/wiki/LZW http://marknelson.us/1989/10/01/lzw-data-compression/

Constructor Summary
protected LZWDecompresser(boolean maskMeansCompressed, int codeLengthIncrease, boolean positionIsBigEndian)
Method Summary
protected abstract int | adjustDictionaryOffset(int offset) Adjusts the position offset if needed when looking something up in the dictionary.
byte[] | decompress(java.io.InputStream src) Decompresses the given input stream, returning the array of bytes of the decompressed input.
void | decompress(java.io.InputStream src, java.io.OutputStream res) Perform a streaming decompression of the input.
static int | fromByte(byte b) Given a java byte, turn it into an integer between 0 and 255 (i.e.
static byte | fromInt(int b) Given an integer, turn it into a java byte, handling the wrapping.
protected abstract int | populateDictionary(byte[] dict) Populates the dictionary, and returns where in it to begin writing new codes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LZWDecompresser

protected LZWDecompresser(boolean maskMeansCompressed,
                          int codeLengthIncrease,
                          boolean positionIsBigEndian)
Method Detail

populateDictionary

protected abstract int populateDictionary(byte[] dict)
Populates the dictionary, and returns where in it to begin writing new codes. Generally, if the dictionary is pre-populated, then new codes should be placed at the end of that block. Equally, if the dictionary is left with all zeros, then usually the new codes can go in at the start.

adjustDictionaryOffset

protected abstract int adjustDictionaryOffset(int offset)
Adjusts the position offset if needed when looking something up in the dictionary.

decompress

public byte[] decompress(java.io.InputStream src)
                  throws java.io.IOException
Decompresses the given input stream, returning the array of bytes of the decompressed input.

Throws:
java.io.IOException

decompress

public void decompress(java.io.InputStream src,
                       java.io.OutputStream res)
                throws java.io.IOException
Perform a streaming decompression of the input. Works by: 1) Reading a flag byte, the 8 bits of which tell you if the following 8 codes are compressed our un-compressed 2) Consider the 8 bits in turn 3) If the bit is set, the next code is un-compressed, so add it to the dictionary and output it 4) If the bit isn't set, then read in the length and start position in the dictionary, and output the bytes there 5) Loop until we've done all 8 bits, then read in the next flag byte

Throws:
java.io.IOException

fromInt

public static byte fromInt(int b)
Given an integer, turn it into a java byte, handling the wrapping. This is a convenience method

fromByte

public static int fromByte(byte b)
Given a java byte, turn it into an integer between 0 and 255 (i.e. handle the unwrapping). This is a convenience method

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NullLogger

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class NullLogger

java.lang.Object
    extended by  org.apache.poi.util.POILogger
        extended by  org.apache.poi.util.NullLogger

public class NullLogger
extends POILogger

A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Author:
Marc Johnson (mjohnson at apache dot org), Glen Stampoultzis (glens at apache.org), Nicola Ken Barozzi (nicolaken at apache.org)

Field Summary
Fields inherited from class org.apache.poi.util.POILogger
DEBUG, ERROR, FATAL, INFO, WARN
Constructor Summary
NullLogger()
Method Summary
boolean | check(int level) Check if a logger is enabled to log at the specified level
void | initialize(java.lang.String cat)
void | log(int level, java.lang.Object obj1) Log a message
void | log(int level, java.lang.Object obj1, java.lang.Object obj2) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7, java.lang.Object obj8) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7, java.lang.Object obj8, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Throwable exception) Log a message
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1) Logs a formated message.
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1, java.lang.Object obj2) Logs a formated message.
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3) Logs a formated message.
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4) Logs a formated message.
Methods inherited from class org.apache.poi.util.POILogger
log
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NullLogger

public NullLogger()
Method Detail

initialize

public void initialize(java.lang.String cat)
Specified by:
initialize in class POILogger

log

public void log(int level,
                java.lang.Object obj1)
Log a message

Specified by:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log.

check

public boolean check(int level)
Check if a logger is enabled to log at the specified level

Specified by:
check in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first object to place in the message
obj2 - second object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message
obj6 - sixth Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message
obj6 - sixth Object to place in the message
obj7 - seventh Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7,
                java.lang.Object obj8)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message
obj6 - sixth Object to place in the message
obj7 - seventh Object to place in the message
obj8 - eighth Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Throwable exception)
Log a message

Specified by:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log. This is converted to a string.
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
exception - An error message to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
obj6 - sixth object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
obj6 - sixth object to place in the message
obj7 - seventh object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7,
                java.lang.Object obj8,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Overrides:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
obj6 - sixth object to place in the message
obj7 - seventh object to place in the message
obj8 - eighth object to place in the message
exception - An exception to be logged

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Overrides:
logFormatted in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1,
                         java.lang.Object obj2)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Overrides:
logFormatted in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.
obj2 - The second object to match against.

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1,
                         java.lang.Object obj2,
                         java.lang.Object obj3)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Overrides:
logFormatted in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.
obj2 - The second object to match against.
obj3 - The third object to match against.

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1,
                         java.lang.Object obj2,
                         java.lang.Object obj3,
                         java.lang.Object obj4)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Overrides:
logFormatted in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.
obj2 - The second object to match against.
obj3 - The third object to match against.
obj4 - The forth object to match against.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OOXMLLite

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class OOXMLLite

java.lang.Object
    extended by  org.apache.poi.util.OOXMLLite

public final class OOXMLLite
extends java.lang.Object

Build a 'lite' version of the ooxml-schemas.jar

Author:
Yegor Kozlov

Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.util
Interfaces
DelayableLittleEndianOutput
FixedField
LittleEndianConsts
LittleEndianInput
LittleEndianOutput
Classes
ArrayUtil
BinaryTree
BitField
BitFieldFactory
BlockingInputStream
ByteField
CloseIgnoringInputStream
CommonsLogger
DrawingDump
FontMetricsDumper
HexDump
HexRead
IdentifierManager
IntegerField
IntList
IntMapper
IOUtils
LittleEndian
LittleEndianByteArrayInputStream
LittleEndianByteArrayOutputStream
LittleEndianInputStream
LittleEndianOutputStream
LongField
LZWDecompresser
NullLogger
OOXMLLite
PackageHelper
POILogFactory
POILogger
ShortField
ShortList
StringUtil
StringUtil.StringsIterator
SystemOutLogger
TempFile
Units
Exceptions
LittleEndian.BufferUnderrunException
RecordFormatException
Annotation Types
Beta
Internal


PackageHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class PackageHelper

java.lang.Object
    extended by  org.apache.poi.util.PackageHelper

public final class PackageHelper
extends java.lang.Object

Provides handy methods to work with OOXML packages

Author:
Yegor Kozlov

Constructor Summary
PackageHelper()
Method Summary
static OPCPackage | clone(OPCPackage pkg, java.io.File file) Clone the specified package.
static java.io.File | createTempFile() Creates an empty file in the default temporary-file directory,
static OPCPackage | open(java.io.InputStream is)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PackageHelper

public PackageHelper()
Method Detail

open

public static OPCPackage open(java.io.InputStream is)
                       throws java.io.IOException
Throws:
java.io.IOException

clone

public static OPCPackage clone(OPCPackage pkg,
                               java.io.File file)
                        throws OpenXML4JException,
                               java.io.IOException
Clone the specified package.

Parameters:
pkg - the package to clone
file - the destination file
Returns:
the cloned package
Throws:
OpenXML4JException
java.io.IOException

createTempFile

public static java.io.File createTempFile()
Creates an empty file in the default temporary-file directory,

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.apache.poi.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.util

Top-level util package are classes that are useful throughout the project.

See:
Description

Interface Summary
DelayableLittleEndianOutput | Implementors of this interface allow client code to 'delay' writing to a certain section of a data output stream. A typical application is for writing BIFF records when the size is not known until well after the header has been written.
FixedField | behavior of a field at a fixed location within a byte array
LittleEndianConsts | a repository for constants shared by classes within this package
LittleEndianInput |
LittleEndianOutput |

Class Summary
ArrayUtil | Utility classes for dealing with arrays.
BinaryTree | Red-Black tree-based implementation of Map.
BitField | Manage operations dealing with bit-mapped fields.
BitFieldFactory | Returns immutable Btfield instances.
BlockingInputStream | Implementation of a BlockingInputStream to provide data to RawDataBlock that expects data in 512 byte chunks.
ByteField | representation of a byte (8-bit) field at a fixed location within a byte array
CloseIgnoringInputStream | A wrapper around an InputStream, which ignores close requests made to it.
CommonsLogger | A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
DrawingDump | Dump out the aggregated escher records
FontMetricsDumper |
HexDump | dump data in hexadecimal format; derived from a HexDump utility I wrote in June 2001.
HexRead | Utilities to read hex from files.
IdentifierManager | 24.08.2009
IntegerField | representation of an integer (32-bit) field at a fixed location within a byte array
IntList | A List of int's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows: if possible, operations designated 'optional' in the List interface are attempted wherever the List interface refers to an Object, substitute int wherever the List interface refers to a Collection or List, substitute IntList the mimicry is not perfect, however: operations involving Iterators or ListIterators are not supported remove(Object) becomes removeValue to distinguish it from remove(int index) subList is not supported
IntMapper<T> | A List of objects that are indexed AND keyed by an int; also allows for getting the index of a value in the list
IOUtils |
LittleEndian | a utility class for handling little-endian numbers, which the 80x86 world is replete with.
LittleEndianByteArrayInputStream | Adapts a plain byte array to LittleEndianInput
LittleEndianByteArrayOutputStream | Adapts a plain byte array to LittleEndianOutput
LittleEndianInputStream | Wraps an InputStream providing LittleEndianInput This class does not buffer any input, so the stream read position maintained by this class is consistent with that of the inner stream.
LittleEndianOutputStream |
LongField | representation of a long (16-bit) field at a fixed location within a byte array
LZWDecompresser | This class provides common functionality for the various LZW implementations in the different file formats.
NullLogger | A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
OOXMLLite | Build a 'lite' version of the ooxml-schemas.jar
PackageHelper | Provides handy methods to work with OOXML packages
POILogFactory | Provides logging without clients having to mess with configuration/initialization.
POILogger | A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
ShortField | representation of a short (16-bit) field at a fixed location within a byte array
ShortList | A List of short's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows: if possible, operations designated 'optional' in the List interface are attempted wherever the List interface refers to an Object, substitute short wherever the List interface refers to a Collection or List, substitute ShortList the mimicry is not perfect, however: operations involving Iterators or ListIterators are not supported remove(Object) becomes removeValue to distinguish it from remove(short index) subList is not supported
StringUtil | Title: String Utility Description: Collection of string handling utilities Note - none of the methods in this class deals with ContinueRecords.
StringUtil.StringsIterator | An Iterator over an array of Strings.
SystemOutLogger | A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
TempFile | Interface for creating temporary files.
Units |

Exception Summary
LittleEndian.BufferUnderrunException | Exception to handle buffer underruns
RecordFormatException | A common exception thrown by our binary format parsers (especially HSSF and DDF), when they hit invalid format or data when processing a record.

Annotation Types Summary
Beta | Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.
Internal | Program elements annotated @Internal are intended for POI internal use only.

Package org.apache.poi.util Description

Top-level util package are classes that are useful throughout the project. These classes are generally generic enough to be useful in any project and should be contributed elsewhere!

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Apache POI Project


org.apache.poi.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • org.apache.poi.util.BinaryTree
    • org.apache.poi.util.ArrayUtil
    • org.apache.poi.util.BitField
    • org.apache.poi.util.BitFieldFactory
    • org.apache.poi.util.ByteField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.util.DrawingDump
    • org.apache.poi.util.FontMetricsDumper
    • org.apache.poi.util.HexDump
    • org.apache.poi.util.HexRead
    • org.apache.poi.util.IdentifierManager
    • java.io.InputStream (implements java.io.Closeable)
      • org.apache.poi.util.BlockingInputStream
      • java.io.FilterInputStream
        • org.apache.poi.util.CloseIgnoringInputStream
        • org.apache.poi.util.LittleEndianInputStream (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.util.IntegerField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.util.IntList
    • org.apache.poi.util.IntMapper<T>
    • org.apache.poi.util.IOUtils
    • org.apache.poi.util.LittleEndian (implements org.apache.poi.util.LittleEndianConsts)
    • org.apache.poi.util.LittleEndianByteArrayInputStream (implements org.apache.poi.util.LittleEndianInput)
    • org.apache.poi.util.LittleEndianByteArrayOutputStream (implements org.apache.poi.util.DelayableLittleEndianOutput, org.apache.poi.util.LittleEndianOutput)
    • org.apache.poi.util.LongField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.util.LZWDecompresser
    • org.apache.poi.util.OOXMLLite
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • org.apache.poi.util.LittleEndianOutputStream (implements org.apache.poi.util.LittleEndianOutput)
    • org.apache.poi.util.PackageHelper
    • org.apache.poi.util.POILogFactory
    • org.apache.poi.util.POILogger
      • org.apache.poi.util.CommonsLogger
      • org.apache.poi.util.NullLogger
      • org.apache.poi.util.SystemOutLogger
    • org.apache.poi.util.ShortField (implements org.apache.poi.util.FixedField)
    • org.apache.poi.util.ShortList
    • org.apache.poi.util.StringUtil
    • org.apache.poi.util.StringUtil.StringsIterator (implements java.util.Iterator<E>)
    • org.apache.poi.util.TempFile
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • org.apache.poi.util.LittleEndian.BufferUnderrunException
        • java.lang.RuntimeException
          • org.apache.poi.util.RecordFormatException
    • org.apache.poi.util.Units

Interface Hierarchy

  • org.apache.poi.util.FixedField
  • org.apache.poi.util.LittleEndianConsts
  • org.apache.poi.util.LittleEndianInput
  • org.apache.poi.util.LittleEndianOutput
    • org.apache.poi.util.DelayableLittleEndianOutput

Annotation Type Hierarchy

  • org.apache.poi.util.Internal (implements java.lang.annotation.Annotation)
  • org.apache.poi.util.Beta (implements java.lang.annotation.Annotation)


Uses of Package org.apache.poi.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.util

Packages that use org.apache.poi.util
org.apache.poi |
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.hdgf |
org.apache.poi.hmef |
org.apache.poi.hslf.blip |
org.apache.poi.hslf.model |
org.apache.poi.hslf.record |
org.apache.poi.hslf.usermodel |
org.apache.poi.hsmf.extractor |
org.apache.poi.hssf.converter |
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.crypto |
org.apache.poi.hssf.record.pivottable |
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.hwpf |
org.apache.poi.hwpf.converter |
org.apache.poi.hwpf.dev |
org.apache.poi.hwpf.model |
org.apache.poi.hwpf.model.io |
org.apache.poi.hwpf.model.types |
org.apache.poi.hwpf.sprm |
org.apache.poi.hwpf.usermodel |
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.constant |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.usermodel.charts |
org.apache.poi.ss.util |
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.
org.apache.poi.xslf |
org.apache.poi.xslf.model |
org.apache.poi.xslf.usermodel |
org.apache.poi.xssf.model |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.charts |
org.apache.poi.xssf.usermodel.extensions |
org.apache.poi.xwpf.usermodel |

Classes in org.apache.poi.util used by org.apache.poi
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.ddf
Internal
Program elements annotated @Internal are intended for POI internal use only.
LittleEndian.BufferUnderrunException
Exception to handle buffer underruns

Classes in org.apache.poi.util used by org.apache.poi.hdgf
LZWDecompresser
This class provides common functionality for the various LZW implementations in the different file formats.

Classes in org.apache.poi.util used by org.apache.poi.hmef
LZWDecompresser
This class provides common functionality for the various LZW implementations in the different file formats.

Classes in org.apache.poi.util used by org.apache.poi.hslf.blip
POILogger
A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Classes in org.apache.poi.util used by org.apache.poi.hslf.model
POILogger
A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Classes in org.apache.poi.util used by org.apache.poi.hslf.record
POILogger
A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Classes in org.apache.poi.util used by org.apache.poi.hslf.usermodel
POILogger
A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Classes in org.apache.poi.util used by org.apache.poi.hsmf.extractor
StringUtil.StringsIterator
An Iterator over an array of Strings.

Classes in org.apache.poi.util used by org.apache.poi.hssf.converter
Beta
Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.

Classes in org.apache.poi.util used by org.apache.poi.hssf.model
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hssf.record
LittleEndianInput
LittleEndianOutput
RecordFormatException
A common exception thrown by our binary format parsers (especially HSSF and DDF), when they hit invalid format or data when processing a record.

Classes in org.apache.poi.util used by org.apache.poi.hssf.record.cf
LittleEndianInput
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.hssf.record.chart
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.hssf.record.common
LittleEndianInput
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.hssf.record.cont
LittleEndianInput
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.hssf.record.crypto
LittleEndianInput

Classes in org.apache.poi.util used by org.apache.poi.hssf.record.pivottable
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.hssf.usermodel
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hssf.util
LittleEndianInput
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.hwpf
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hwpf.converter
Beta
Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hwpf.dev
Beta
Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hwpf.model
Internal
Program elements annotated @Internal are intended for POI internal use only.
POILogger
A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Classes in org.apache.poi.util used by org.apache.poi.hwpf.model.io
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hwpf.model.types
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hwpf.sprm
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.hwpf.usermodel
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.poifs.filesystem
Internal
Program elements annotated @Internal are intended for POI internal use only.
LittleEndianInput

Classes in org.apache.poi.util used by org.apache.poi.ss.formula
LittleEndianInput
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.ss.formula.constant
LittleEndianInput
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.ss.formula.ptg
LittleEndianInput
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.ss.usermodel.charts
Beta
Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.

Classes in org.apache.poi.util used by org.apache.poi.ss.util
Internal
Program elements annotated @Internal are intended for POI internal use only.
LittleEndianOutput

Classes in org.apache.poi.util used by org.apache.poi.util
BitField
Manage operations dealing with bit-mapped fields.
DelayableLittleEndianOutput
Implementors of this interface allow client code to 'delay' writing to a certain section of a data output stream.
A typical application is for writing BIFF records when the size is not known until well after the header has been written.
FixedField
behavior of a field at a fixed location within a byte array
IntList
A List of int's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows: if possible, operations designated 'optional' in the List interface are attempted wherever the List interface refers to an Object, substitute int wherever the List interface refers to a Collection or List, substitute IntList the mimicry is not perfect, however: operations involving Iterators or ListIterators are not supported remove(Object) becomes removeValue to distinguish it from remove(int index) subList is not supported
LittleEndian.BufferUnderrunException
Exception to handle buffer underruns
LittleEndianConsts
a repository for constants shared by classes within this package
LittleEndianInput
LittleEndianOutput
POILogger
A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
ShortList
A List of short's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows: if possible, operations designated 'optional' in the List interface are attempted wherever the List interface refers to an Object, substitute short wherever the List interface refers to a Collection or List, substitute ShortList the mimicry is not perfect, however: operations involving Iterators or ListIterators are not supported remove(Object) becomes removeValue to distinguish it from remove(short index) subList is not supported

Classes in org.apache.poi.util used by org.apache.poi.xslf
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.xslf.model
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.xslf.usermodel
Beta
Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.xssf.model
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.xssf.usermodel
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.xssf.usermodel.charts
Beta
Signifies that a public API (public class, method or field) is subject to incompatible changes, or even removal, in a future release.
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.xssf.usermodel.extensions
Internal
Program elements annotated @Internal are intended for POI internal use only.

Classes in org.apache.poi.util used by org.apache.poi.xwpf.usermodel
Internal
Program elements annotated @Internal are intended for POI internal use only.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


POILogFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class POILogFactory

java.lang.Object
    extended by  org.apache.poi.util.POILogFactory

public class POILogFactory
extends java.lang.Object

Provides logging without clients having to mess with configuration/initialization.

Author:
Andrew C. Oliver (acoliver at apache dot org), Marc Johnson (mjohnson at apache dot org), Nicola Ken Barozzi (nicolaken at apache.org)

Method Summary
static POILogger | getLogger(java.lang.Class theclass) Get a logger, based on a class name
static POILogger | getLogger(java.lang.String cat) Get a logger, based on a String
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getLogger

public static POILogger getLogger(java.lang.Class theclass)
Get a logger, based on a class name

Parameters:
theclass - the class whose name defines the log
Returns:
a POILogger for the specified class

getLogger

public static POILogger getLogger(java.lang.String cat)
Get a logger, based on a String

Parameters:
cat - the String that defines the log
Returns:
a POILogger for the specified class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POILogger

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class POILogger

java.lang.Object
    extended by  org.apache.poi.util.POILogger
Direct Known Subclasses:
CommonsLogger, NullLogger, SystemOutLogger
public abstract class POILogger
extends java.lang.Object

A logger interface that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Author:
Marc Johnson (mjohnson at apache dot org), Glen Stampoultzis (glens at apache.org), Nicola Ken Barozzi (nicolaken at apache.org)

Field Summary
static int | DEBUG
static int | ERROR
static int | FATAL
static int | INFO
static int | WARN
Method Summary
abstract boolean | check(int level) Check if a logger is enabled to log at the specified level
abstract void | initialize(java.lang.String cat)
abstract void | log(int level, java.lang.Object obj1) Log a message
void | log(int level, java.lang.Object obj1, java.lang.Object obj2) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7, java.lang.Object obj8) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7, java.lang.Object obj8, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Object obj7, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Object obj6, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Object obj5, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Throwable exception) Log a message.
void | log(int level, java.lang.Object obj1, java.lang.Object obj2, java.lang.Throwable exception) Log a message.
abstract void | log(int level, java.lang.Object obj1, java.lang.Throwable exception) Log a message
void | log(int level, java.lang.Throwable exception) Log an exception, without a message
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1) Logs a formated message.
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1, java.lang.Object obj2) Logs a formated message.
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3) Logs a formated message.
void | logFormatted(int level, java.lang.String message, java.lang.Object obj1, java.lang.Object obj2, java.lang.Object obj3, java.lang.Object obj4) Logs a formated message.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEBUG

public static int DEBUG

INFO

public static int INFO

WARN

public static int WARN

ERROR

public static int ERROR

FATAL

public static int FATAL
Method Detail

initialize

public abstract void initialize(java.lang.String cat)

log

public abstract void log(int level,
                         java.lang.Object obj1)
Log a message

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log. This is converted to a string.

log

public abstract void log(int level,
                         java.lang.Object obj1,
                         java.lang.Throwable exception)
Log a message

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log. This is converted to a string.
exception - An exception to be logged

check

public abstract boolean check(int level)
Check if a logger is enabled to log at the specified level

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first object to place in the message
obj2 - second object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message
obj6 - sixth Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message
obj6 - sixth Object to place in the message
obj7 - seventh Object to place in the message

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7,
                java.lang.Object obj8)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third Object to place in the message
obj4 - fourth Object to place in the message
obj5 - fifth Object to place in the message
obj6 - sixth Object to place in the message
obj7 - seventh Object to place in the message
obj8 - eighth Object to place in the message

log

public void log(int level,
                java.lang.Throwable exception)
Log an exception, without a message

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
exception - An error message to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
obj6 - sixth object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
obj6 - sixth object to place in the message
obj7 - seventh object to place in the message
exception - An exception to be logged

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Object obj2,
                java.lang.Object obj3,
                java.lang.Object obj4,
                java.lang.Object obj5,
                java.lang.Object obj6,
                java.lang.Object obj7,
                java.lang.Object obj8,
                java.lang.Throwable exception)
Log a message. Lazily appends Object parameters together.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - first Object to place in the message
obj2 - second Object to place in the message
obj3 - third object to place in the message
obj4 - fourth object to place in the message
obj5 - fifth object to place in the message
obj6 - sixth object to place in the message
obj7 - seventh object to place in the message
obj8 - eighth object to place in the message
exception - An exception to be logged

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1,
                         java.lang.Object obj2)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.
obj2 - The second object to match against.

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1,
                         java.lang.Object obj2,
                         java.lang.Object obj3)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.
obj2 - The second object to match against.
obj3 - The third object to match against.

logFormatted

public void logFormatted(int level,
                         java.lang.String message,
                         java.lang.Object obj1,
                         java.lang.Object obj2,
                         java.lang.Object obj3,
                         java.lang.Object obj4)
Logs a formated message. The message itself may contain % characters as place holders. This routine will attempt to match the placeholder by looking at the type of parameter passed to obj1.

If the parameter is an array, it traverses the array first and matches parameters sequentially against the array items. Otherwise the parameters after message are matched in order.

If the place holder matches against a number it is printed as a whole number. This can be overridden by specifying a precision in the form %n.m where n is the padding for the whole part and m is the number of decimal places to display. n can be excluded if desired. n and m may not be more than 9.

If the last parameter (after flattening) is a Throwable it is logged specially.

Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
message - The message to log.
obj1 - The first object to match against.
obj2 - The second object to match against.
obj3 - The third object to match against.
obj4 - The forth object to match against.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordFormatException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class RecordFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.apache.poi.util.RecordFormatException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
RecordFormatException
public class RecordFormatException
extends java.lang.RuntimeException

A common exception thrown by our binary format parsers (especially HSSF and DDF), when they hit invalid format or data when processing a record.

See Also:
Serialized Form

Constructor Summary
RecordFormatException(java.lang.String exception)
RecordFormatException(java.lang.String exception, java.lang.Throwable thr)
RecordFormatException(java.lang.Throwable thr)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RecordFormatException

public RecordFormatException(java.lang.String exception)

RecordFormatException

public RecordFormatException(java.lang.String exception,
                             java.lang.Throwable thr)

RecordFormatException

public RecordFormatException(java.lang.Throwable thr)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShortField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class ShortField

java.lang.Object
    extended by  org.apache.poi.util.ShortField
All Implemented Interfaces:
FixedField
public class ShortField
extends java.lang.Object
implements FixedField

representation of a short (16-bit) field at a fixed location within a byte array

Author:
Marc Johnson (mjohnson at apache dot org

Constructor Summary
ShortField(int offset)
construct the ShortField with its offset into its containing byte array
ShortField(int offset, byte[] data)
Construct the ShortField with its offset into its containing byte array and initialize its value from its byte array
ShortField(int offset, short value)
construct the ShortField with its offset into its containing byte array and initialize its value
ShortField(int offset, short value, byte[] data)
construct the ShortField with its offset into its containing byte array, initialize its value, and write its value to its byte array
Method Summary
short | get() get the ShortField's current value
void | readFromBytes(byte[] data) set the value from its offset into an array of bytes
void | readFromStream(java.io.InputStream stream) set the value from an InputStream
void | set(short value) set the ShortField's current value
void | set(short value, byte[] data) set the ShortField's current value and write it to a byte array
java.lang.String | toString() return the value as a String
void | writeToBytes(byte[] data) write the value out to an array of bytes at the appropriate offset
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ShortField

public ShortField(int offset)
           throws java.lang.ArrayIndexOutOfBoundsException
construct the ShortField with its offset into its containing byte array

Parameters:
offset - of the field within its byte array
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative

ShortField

public ShortField(int offset,
                  short value)
           throws java.lang.ArrayIndexOutOfBoundsException
construct the ShortField with its offset into its containing byte array and initialize its value

Parameters:
offset - of the field within its byte array
value - the initial value
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative

ShortField

public ShortField(int offset,
                  byte[] data)
           throws java.lang.ArrayIndexOutOfBoundsException
Construct the ShortField with its offset into its containing byte array and initialize its value from its byte array

Parameters:
offset - of the field within its byte array
data - the byte array to read the value from
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is not within the range of 0..(data.length - 1)

ShortField

public ShortField(int offset,
                  short value,
                  byte[] data)
           throws java.lang.ArrayIndexOutOfBoundsException
construct the ShortField with its offset into its containing byte array, initialize its value, and write its value to its byte array

Parameters:
offset - of the field within its byte array
value - the initial value
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is negative
Method Detail

get

public short get()
get the ShortField's current value

Returns:
current value

set

public void set(short value)
set the ShortField's current value

Parameters:
value - to be set

set

public void set(short value,
                byte[] data)
         throws java.lang.ArrayIndexOutOfBoundsException
set the ShortField's current value and write it to a byte array

Parameters:
value - to be set
data - the byte array to write the value to
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of range

readFromBytes

public void readFromBytes(byte[] data)
                   throws java.lang.ArrayIndexOutOfBoundsException
set the value from its offset into an array of bytes

Specified by:
readFromBytes in interface FixedField
Parameters:
data - the byte array from which the value is to be read
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of range

readFromStream

public void readFromStream(java.io.InputStream stream)
                    throws java.io.IOException,
                           LittleEndian.BufferUnderrunException
set the value from an InputStream

Specified by:
readFromStream in interface FixedField
Parameters:
stream - the InputStream from which the value is to be read
Throws:
LittleEndian.BufferUnderrunException - if there is not enough data available from the InputStream
java.io.IOException - if an IOException is thrown from reading the InputStream

writeToBytes

public void writeToBytes(byte[] data)
                  throws java.lang.ArrayIndexOutOfBoundsException
write the value out to an array of bytes at the appropriate offset

Specified by:
writeToBytes in interface FixedField
Parameters:
data - the array of bytes to which the value is to be written
Throws:
java.lang.ArrayIndexOutOfBoundsException - if the offset is out of range

toString

public java.lang.String toString()
return the value as a String

Specified by:
toString in interface FixedField
Overrides:
toString in class java.lang.Object
Returns:
the value as a String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShortList

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class ShortList

java.lang.Object
    extended by  org.apache.poi.util.ShortList

public class ShortList
extends java.lang.Object

A List of short's; as full an implementation of the java.util.List interface as possible, with an eye toward minimal creation of objects the mimicry of List is as follows:

  • if possible, operations designated 'optional' in the List interface are attempted
  • wherever the List interface refers to an Object, substitute short
  • wherever the List interface refers to a Collection or List, substitute ShortList
the mimicry is not perfect, however:
  • operations involving Iterators or ListIterators are not supported
  • remove(Object) becomes removeValue to distinguish it from remove(short index)
  • subList is not supported

Author:
Marc Johnson

Constructor Summary
ShortList()
create an ShortList of default size
ShortList(int initialCapacity)
create an ShortList with a predefined initial size
ShortList(ShortList list)
create a copy of an existing ShortList
Method Summary
void | add(int index, short value) add the specfied value at the specified index
boolean | add(short value) Appends the specified element to the end of this list
boolean | addAll(int index, ShortList c) Inserts all of the elements in the specified collection into this list at the specified position.
boolean | addAll(ShortList c) Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
void | clear() Removes all of the elements from this list.
boolean | contains(short o) Returns true if this list contains the specified element.
boolean | containsAll(ShortList c) Returns true if this list contains all of the elements of the specified collection.
boolean | equals(java.lang.Object o) Compares the specified object with this list for equality.
short | get(int index) Returns the element at the specified position in this list.
int | hashCode() Returns the hash code value for this list.
int | indexOf(short o) Returns the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element.
boolean | isEmpty() Returns true if this list contains no elements.
int | lastIndexOf(short o) Returns the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element.
short | remove(int index) Removes the element at the specified position in this list.
boolean | removeAll(ShortList c) Removes from this list all the elements that are contained in the specified collection
boolean | removeValue(short o) Removes the first occurrence in this list of the specified element (optional operation).
boolean | retainAll(ShortList c) Retains only the elements in this list that are contained in the specified collection.
short | set(int index, short element) Replaces the element at the specified position in this list with the specified element
int | size() Returns the number of elements in this list.
short[] | toArray() Returns an array containing all of the elements in this list in proper sequence.
short[] | toArray(short[] a) Returns an array containing all of the elements in this list in proper sequence.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShortList

public ShortList()
create an ShortList of default size

ShortList

public ShortList(ShortList list)
create a copy of an existing ShortList

Parameters:
list - the existing ShortList

ShortList

public ShortList(int initialCapacity)
create an ShortList with a predefined initial size

Parameters:
initialCapacity - the size for the internal array
Method Detail

add

public void add(int index,
                short value)
add the specfied value at the specified index

Parameters:
index - the index where the new value is to be added
value - the new value
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index > size()).

add

public boolean add(short value)
Appends the specified element to the end of this list

Parameters:
value - element to be appended to this list.
Returns:
true (as per the general contract of the Collection.add method).

addAll

public boolean addAll(ShortList c)
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator. The behavior of this operation is unspecified if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Parameters:
c - collection whose elements are to be added to this list.
Returns:
true if this list changed as a result of the call.

addAll

public boolean addAll(int index,
                      ShortList c)
Inserts all of the elements in the specified collection into this list at the specified position. Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is unspecified if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Parameters:
index - index at which to insert first element from the specified collection.
c - elements to be inserted into this list.
Returns:
true if this list changed as a result of the call.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index > size())

clear

public void clear()
Removes all of the elements from this list. This list will be empty after this call returns (unless it throws an exception).

contains

public boolean contains(short o)
Returns true if this list contains the specified element. More formally, returns true if and only if this list contains at least one element e such that o == e

Parameters:
o - element whose presence in this list is to be tested.
Returns:
true if this list contains the specified element.

containsAll

public boolean containsAll(ShortList c)
Returns true if this list contains all of the elements of the specified collection.

Parameters:
c - collection to be checked for containment in this list.
Returns:
true if this list contains all of the elements of the specified collection.

equals

public boolean equals(java.lang.Object o)
Compares the specified object with this list for equality. Returns true if and only if the specified object is also a list, both lists have the same size, and all corresponding pairs of elements in the two lists are equal. (Two elements e1 and e2 are equal if e1 == e2.) In other words, two lists are defined to be equal if they contain the same elements in the same order. This definition ensures that the equals method works properly across different implementations of the List interface.

Overrides:
equals in class java.lang.Object
Parameters:
o - the object to be compared for equality with this list.
Returns:
true if the specified object is equal to this list.

get

public short get(int index)
Returns the element at the specified position in this list.

Parameters:
index - index of element to return.
Returns:
the element at the specified position in this list.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size()).

hashCode

public int hashCode()
Returns the hash code value for this list. The hash code of a list is defined to be the result of the following calculation:
hashCode = 1;
Iterator i = list.iterator();
while (i.hasNext()) {
     Object obj = i.next();
     hashCode = 31*hashCode + (obj==null ? 0 : obj.hashCode());
}
 This ensures that list1.equals(list2) implies that list1.hashCode()==list2.hashCode() for any two lists, list1 and list2, as required by the general contract of Object.hashCode.

Overrides:
hashCode in class java.lang.Object
Returns:
the hash code value for this list.

indexOf

public int indexOf(short o)
Returns the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element. More formally, returns the lowest index i such that (o == get(i)), or -1 if there is no such index.

Parameters:
o - element to search for.
Returns:
the index in this list of the first occurrence of the specified element, or -1 if this list does not contain this element.

isEmpty

public boolean isEmpty()
Returns true if this list contains no elements.

Returns:
true if this list contains no elements.

lastIndexOf

public int lastIndexOf(short o)
Returns the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element. More formally, returns the highest index i such that (o == get(i)), or -1 if there is no such index.

Parameters:
o - element to search for.
Returns:
the index in this list of the last occurrence of the specified element, or -1 if this list does not contain this element.

remove

public short remove(int index)
Removes the element at the specified position in this list. Shifts any subsequent elements to the left (subtracts one from their indices). Returns the element that was removed from the list.

Parameters:
index - the index of the element to removed.
Returns:
the element previously at the specified position.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size()).

removeValue

public boolean removeValue(short o)
Removes the first occurrence in this list of the specified element (optional operation). If this list does not contain the element, it is unchanged. More formally, removes the element with the lowest index i such that (o.equals(get(i))) (if such an element exists).

Parameters:
o - element to be removed from this list, if present.
Returns:
true if this list contained the specified element.

removeAll

public boolean removeAll(ShortList c)
Removes from this list all the elements that are contained in the specified collection

Parameters:
c - collection that defines which elements will be removed from this list.
Returns:
true if this list changed as a result of the call.

retainAll

public boolean retainAll(ShortList c)
Retains only the elements in this list that are contained in the specified collection. In other words, removes from this list all the elements that are not contained in the specified collection.

Parameters:
c - collection that defines which elements this set will retain.
Returns:
true if this list changed as a result of the call.

set

public short set(int index,
                 short element)
Replaces the element at the specified position in this list with the specified element

Parameters:
index - index of element to replace.
element - element to be stored at the specified position.
Returns:
the element previously at the specified position.
Throws:
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size()).

size

public int size()
Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.

Returns:
the number of elements in this ShortList

toArray

public short[] toArray()
Returns an array containing all of the elements in this list in proper sequence. Obeys the general contract of the Collection.toArray method.

Returns:
an array containing all of the elements in this list in proper sequence.

toArray

public short[] toArray(short[] a)
Returns an array containing all of the elements in this list in proper sequence. Obeys the general contract of the Collection.toArray(Object[]) method.

Parameters:
a - the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array is allocated for this purpose.
Returns:
an array containing the elements of this list.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class StringUtil

java.lang.Object
    extended by  org.apache.poi.util.StringUtil

public class StringUtil
extends java.lang.Object

Title: String Utility Description: Collection of string handling utilities

Note - none of the methods in this class deals with ContinueRecords. For such functionality, consider using RecordInputStream *

Author:
Andrew C. Oliver, Sergei Kozello (sergeikozello at mail.ru), Toshiaki Kamoshida (kamoshida.toshiaki at future dot co dot jp)

Nested Class Summary
static class StringUtil.StringsIterator
An Iterator over an array of Strings.
Method Summary
static java.lang.String format(java.lang.String message, java.lang.Object[] params)
Apply printf() like formatting to a string.
static int getEncodedSize(java.lang.String value)
static java.lang.String getFromCompressedUnicode(byte[] string, int offset, int len)
Read 8 bit data (in ISO-8859-1 codepage) into a (unicode) Java String and return.
static java.lang.String getFromUnicodeLE(byte[] string)
Given a byte array of 16-bit unicode characters in little endian format (most important byte last), return a Java String representation of it.
static java.lang.String getFromUnicodeLE(byte[] string, int offset, int len)
Given a byte array of 16-bit unicode characters in Little Endian format (most important byte last), return a Java String representation of it.
static java.lang.String getPreferredEncoding()
static boolean hasMultibyte(java.lang.String value)
check the parameter has multibyte character
static boolean isUnicodeString(java.lang.String value)
Checks to see if a given String needs to be represented as Unicode
static void putCompressedUnicode(java.lang.String input, byte[] output, int offset)
Takes a unicode (java) string, and returns it as 8 bit data (in ISO-8859-1 codepage).
static void putCompressedUnicode(java.lang.String input, LittleEndianOutput out)
static void putUnicodeLE(java.lang.String input, byte[] output, int offset)
Takes a unicode string, and returns it as little endian (most important byte last) bytes in the supplied byte array.
static void putUnicodeLE(java.lang.String input, LittleEndianOutput out)
static java.lang.String readCompressedUnicode(LittleEndianInput in, int nChars)
static java.lang.String readUnicodeLE(LittleEndianInput in, int nChars)
static java.lang.String readUnicodeString(LittleEndianInput in)
InputStream in is expected to contain: ushort nChars byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
static java.lang.String readUnicodeString(LittleEndianInput in, int nChars)
InputStream in is expected to contain: byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
static void writeUnicodeString(LittleEndianOutput out, java.lang.String value)
OutputStream out will get: ushort nChars byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
static void writeUnicodeStringFlagAndData(LittleEndianOutput out, java.lang.String value)
OutputStream out will get: byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getFromUnicodeLE

public static java.lang.String getFromUnicodeLE(byte[] string,
                                                int offset,
                                                int len)
                                         throws java.lang.ArrayIndexOutOfBoundsException,
                                                java.lang.IllegalArgumentException
Given a byte array of 16-bit unicode characters in Little Endian format (most important byte last), return a Java String representation of it. { 0x16, 0x00 } -0x16

Parameters:
string - the byte array to be converted
offset - the initial offset into the byte array. it is assumed that string[ offset ] and string[ offset + 1 ] contain the first 16-bit unicode character
len - the length of the final string
Returns:
the converted string, never null.
Throws:
java.lang.ArrayIndexOutOfBoundsException - if offset is out of bounds for the byte array (i.e., is negative or is greater than or equal to string.length)
java.lang.IllegalArgumentException - if len is too large (i.e., there is not enough data in string to create a String of that length)

getFromUnicodeLE

public static java.lang.String getFromUnicodeLE(byte[] string)
Given a byte array of 16-bit unicode characters in little endian format (most important byte last), return a Java String representation of it. { 0x16, 0x00 } -0x16

Parameters:
string - the byte array to be converted
Returns:
the converted string, never null

getFromCompressedUnicode

public static java.lang.String getFromCompressedUnicode(byte[] string,
                                                        int offset,
                                                        int len)
Read 8 bit data (in ISO-8859-1 codepage) into a (unicode) Java String and return. (In Excel terms, read compressed 8 bit unicode as a string)

Parameters:
string - byte array to read
offset - offset to read byte array
len - length to read byte array
Returns:
String generated String instance by reading byte array

readCompressedUnicode

public static java.lang.String readCompressedUnicode(LittleEndianInput in,
                                                     int nChars)

readUnicodeString

public static java.lang.String readUnicodeString(LittleEndianInput in)
InputStream in is expected to contain:
  1. ushort nChars
  2. byte is16BitFlag
  3. byte[]/char[] characterData
For this encoding, the is16BitFlag is always present even if nChars==0. This structure is also known as a XLUnicodeString.

readUnicodeString

public static java.lang.String readUnicodeString(LittleEndianInput in,
                                                 int nChars)
InputStream in is expected to contain:
  1. byte is16BitFlag
  2. byte[]/char[] characterData
For this encoding, the is16BitFlag is always present even if nChars==0.
This method should be used when the nChars field is not stored as a ushort immediately before the is16BitFlag. Otherwise, readUnicodeString(LittleEndianInput) can be used.

writeUnicodeString

public static void writeUnicodeString(LittleEndianOutput out,
                                      java.lang.String value)
OutputStream out will get:
  1. ushort nChars
  2. byte is16BitFlag
  3. byte[]/char[] characterData
For this encoding, the is16BitFlag is always present even if nChars==0.

writeUnicodeStringFlagAndData

public static void writeUnicodeStringFlagAndData(LittleEndianOutput out,
                                                 java.lang.String value)
OutputStream out will get:
  1. byte is16BitFlag
  2. byte[]/char[] characterData
For this encoding, the is16BitFlag is always present even if nChars==0.
This method should be used when the nChars field is not stored as a ushort immediately before the is16BitFlag. Otherwise, writeUnicodeString(LittleEndianOutput, String) can be used.

getEncodedSize

public static int getEncodedSize(java.lang.String value)
Returns:
the number of bytes that would be written by writeUnicodeString(LittleEndianOutput, String)

putCompressedUnicode

public static void putCompressedUnicode(java.lang.String input,
                                        byte[] output,
                                        int offset)
Takes a unicode (java) string, and returns it as 8 bit data (in ISO-8859-1 codepage). (In Excel terms, write compressed 8 bit unicode)

Parameters:
input - the String containing the data to be written
output - the byte array to which the data is to be written
offset - an offset into the byte arrat at which the data is start when written

putCompressedUnicode

public static void putCompressedUnicode(java.lang.String input,
                                        LittleEndianOutput out)

putUnicodeLE

public static void putUnicodeLE(java.lang.String input,
                                byte[] output,
                                int offset)
Takes a unicode string, and returns it as little endian (most important byte last) bytes in the supplied byte array. (In Excel terms, write uncompressed unicode)

Parameters:
input - the String containing the unicode data to be written
output - the byte array to hold the uncompressed unicode, should be twice the length of the String
offset - the offset to start writing into the byte array

putUnicodeLE

public static void putUnicodeLE(java.lang.String input,
                                LittleEndianOutput out)

readUnicodeLE

public static java.lang.String readUnicodeLE(LittleEndianInput in,
                                             int nChars)

format

public static java.lang.String format(java.lang.String message,
                                      java.lang.Object[] params)
Apply printf() like formatting to a string. Primarily used for logging.

Parameters:
message - the string with embedded formatting info eg. "This is a test %2.2"
params - array of values to format into the string
Returns:
The formatted string

getPreferredEncoding

public static java.lang.String getPreferredEncoding()
Returns:
the encoding we want to use, currently hardcoded to ISO-8859-1

hasMultibyte

public static boolean hasMultibyte(java.lang.String value)
check the parameter has multibyte character

Parameters:
value - string to check
Returns:
boolean result true:string has at least one multibyte character

isUnicodeString

public static boolean isUnicodeString(java.lang.String value)
Checks to see if a given String needs to be represented as Unicode

Parameters:
value -
Returns:
true if string needs Unicode to be represented.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringUtil.StringsIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class StringUtil.StringsIterator

java.lang.Object
    extended by  org.apache.poi.util.StringUtil.StringsIterator
All Implemented Interfaces:
java.util.Iterator<java.lang.String>
Enclosing class:
StringUtil
public static class StringUtil.StringsIterator
extends java.lang.Object
implements java.util.Iterator<java.lang.String>

An Iterator over an array of Strings.

Constructor Summary
StringUtil.StringsIterator(java.lang.String[] strings)
Method Summary
boolean | hasNext()
java.lang.String | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StringUtil.StringsIterator

public StringUtil.StringsIterator(java.lang.String[] strings)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface java.util.Iterator<java.lang.String>

next

public java.lang.String next()
Specified by:
next in interface java.util.Iterator<java.lang.String>

remove

public void remove()
Specified by:
remove in interface java.util.Iterator<java.lang.String>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SystemOutLogger

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class SystemOutLogger

java.lang.Object
    extended by  org.apache.poi.util.POILogger
        extended by  org.apache.poi.util.SystemOutLogger

public class SystemOutLogger
extends POILogger

A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Author:
Marc Johnson (mjohnson at apache dot org), Glen Stampoultzis (glens at apache.org), Nicola Ken Barozzi (nicolaken at apache.org)

Field Summary
Fields inherited from class org.apache.poi.util.POILogger
DEBUG, ERROR, FATAL, INFO, WARN
Constructor Summary
SystemOutLogger()
Method Summary
boolean | check(int level) Check if a logger is enabled to log at the specified level
void | initialize(java.lang.String cat)
void | log(int level, java.lang.Object obj1) Log a message
void | log(int level, java.lang.Object obj1, java.lang.Throwable exception) Log a message
Methods inherited from class org.apache.poi.util.POILogger
log, log, log, log, log, log, log, log, log, log, log, log, log, log, log, logFormatted, logFormatted, logFormatted, logFormatted
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SystemOutLogger

public SystemOutLogger()
Method Detail

initialize

public void initialize(java.lang.String cat)
Specified by:
initialize in class POILogger

log

public void log(int level,
                java.lang.Object obj1)
Log a message

Specified by:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log.

log

public void log(int level,
                java.lang.Object obj1,
                java.lang.Throwable exception)
Log a message

Specified by:
log in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
obj1 - The object to log. This is converted to a string.
exception - An exception to be logged

check

public boolean check(int level)
Check if a logger is enabled to log at the specified level

Specified by:
check in class POILogger
Parameters:
level - One of DEBUG, INFO, WARN, ERROR, FATAL
See Also:
POILogger.DEBUG, POILogger.INFO, POILogger.WARN, POILogger.ERROR, POILogger.FATAL
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TempFile

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class TempFile

java.lang.Object
    extended by  org.apache.poi.util.TempFile

public final class TempFile
extends java.lang.Object

Interface for creating temporary files. Collects them all into one directory.

Author:
Glen Stampoultzis

Constructor Summary
TempFile()
Method Summary
static java.io.File createTempFile(java.lang.String prefix, java.lang.String suffix)
Creates a temporary file.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TempFile

public TempFile()
Method Detail

createTempFile

public static java.io.File createTempFile(java.lang.String prefix,
                                          java.lang.String suffix)
Creates a temporary file. Files are collected into one directory and by default are deleted on exit from the VM. Files can be kept by defining the system property poi.keep.tmp.files.

Don't forget to close all files or it might not be possible to delete them.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Units

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.util
Class Units

java.lang.Object
    extended by  org.apache.poi.util.Units

public class Units
extends java.lang.Object

Author:
Yegor Kozlov

Field Summary
static int | EMU_PER_PIXEL
static int | EMU_PER_POINT
Constructor Summary
Units()
Method Summary
static int | toEMU(double value)
static double | toPoints(long emu)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EMU_PER_PIXEL

public static final int EMU_PER_PIXEL
See Also:
Constant Field Values

EMU_PER_POINT

public static final int EMU_PER_POINT
See Also:
Constant Field Values
Constructor Detail

Units

public Units()
Method Detail

toEMU

public static int toEMU(double value)

toPoints

public static double toPoints(long emu)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.util.ArrayUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.ArrayUtil

No usage of org.apache.poi.util.ArrayUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.Beta

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.Beta

Packages that use Beta
org.apache.poi.hssf.converter
org.apache.poi.hwpf.converter
org.apache.poi.hwpf.dev
org.apache.poi.ss.usermodel.charts
org.apache.poi.xslf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of Beta in org.apache.poi.hssf.converter

Classes in org.apache.poi.hssf.converter with annotations of type Beta
class | AbstractExcelConverter Common class for ExcelToFoConverter and ExcelToHtmlConverter
class | AbstractExcelUtils Common class for ExcelToFoUtils and ExcelToHtmlUtils
class | ExcelToFoConverter Converts xls files (97-2007) to XSL FO.
class | ExcelToFoUtils
class | ExcelToHtmlConverter Converts xls files (97-2007) to HTML file.
class | ExcelToHtmlUtils

Uses of Beta in org.apache.poi.hwpf.converter

Classes in org.apache.poi.hwpf.converter with annotations of type Beta
class | AbstractWordConverter
class | AbstractWordUtils
class | DefaultFontReplacer
class | FoDocumentFacade
interface | FontReplacer
class | HtmlDocumentFacade
class | NumberFormatter Utility class to translate numbers in letters, usually for lists.
interface | PicturesManager User-implemented pictures manager to store images on-disk
class | TextDocumentFacade
class | WordToFoConverter
class | WordToFoUtils
class | WordToHtmlConverter Converts Word files (95-2007) into HTML files.
class | WordToHtmlUtils
class | WordToTextConverter

Uses of Beta in org.apache.poi.hwpf.dev

Classes in org.apache.poi.hwpf.dev with annotations of type Beta
 class HWPFLister
Used by developers to list out key information on a HWPF file.

Uses of Beta in org.apache.poi.ss.usermodel.charts

Classes in org.apache.poi.ss.usermodel.charts with annotations of type Beta
interface | ChartAxis High level representation of chart axis.
interface | ChartAxisFactory A factory for different chart axis.
interface | ChartData A base for all charts data types.
interface | ChartDataFactory A factory for different charts data types.
interface | ChartDataSource<T> Represents data model of the charts.
interface | ChartLegend High level representation of chart legend.
class | DataSources Class DataSources is a factory for ChartDataSource instances.
interface | ManualLayout High level representation of chart element manual layout.
interface | ManuallyPositionable Abstraction of chart element that can be positioned with manual layout.
interface | ScatterChartSerie Represents scatter charts serie.
interface | ValueAxis

Uses of Beta in org.apache.poi.xslf.usermodel

Classes in org.apache.poi.xslf.usermodel with annotations of type Beta
class | XMLSlideShow High level representation of a ooxml slideshow.
class | XSLFAutoShape Represents a shape with a preset geometry.
class | XSLFColor Encapsulates logic to read color definitions from DrawingML and convert them to java.awt.Color
class | XSLFCommentAuthors
class | XSLFComments
class | XSLFCommonSlideData
class | XSLFConnectorShape Specifies a connection shape.
class | XSLFDrawing
class | XSLFFactory Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
class | XSLFFreeformShape Represents a custom geometric shape.
class | XSLFGraphicFrame
class | XSLFGroupShape Represents a group shape that consists of many shapes grouped together.
class | XSLFImageRenderer For now this class renders only images supported by the javax.imageio.ImageIO framework.
class | XSLFNotes
class | XSLFNotesMaster Notes master object associated with this layout.
class | XSLFPictureData Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
class | XSLFPictureShape Represents a picture shape
class | XSLFRelation
class | XSLFShape Base super-class class for all shapes in PresentationML
class | XSLFSheet
class | XSLFSimpleShape Represents a single (non-group) shape in a .pptx slide show
class | XSLFSlide
class | XSLFSlideLayout
class | XSLFSlideMaster Slide master object associated with this layout.
class | XSLFTableStyles
class | XSLFTextBox
class | XSLFTextParagraph Represents a paragraph of text within the containing text body.
class | XSLFTextRun Represents a run of text within the containing text body.
class | XSLFTextShape Represents a shape that can hold text.
class | XSLFTheme A shared style sheet in a .pptx slide show

Uses of Beta in org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts with annotations of type Beta
class | XSSFChartAxis Base class for all axis types.
class | XSSFChartDataFactory
class | XSSFChartLegend Represents a SpreadsheetML chart legend
class | XSSFManualLayout Represents a SpreadsheetML manual layout.
class | XSSFScatterChartData Represents DrawingML scatter charts.
class | XSSFValueAxis Value axis type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.BinaryTree

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.BinaryTree

No usage of org.apache.poi.util.BinaryTree

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.BitField

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.BitField

Packages that use BitField
org.apache.poi.util Top-level util package are classes that are useful throughout the project.

Uses of BitField in org.apache.poi.util

Methods in org.apache.poi.util that return BitField
static BitField BitFieldFactory.getInstance(int mask)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.BitFieldFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.BitFieldFactory

No usage of org.apache.poi.util.BitFieldFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.BlockingInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.BlockingInputStream

No usage of org.apache.poi.util.BlockingInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.ByteField

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.ByteField

No usage of org.apache.poi.util.ByteField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.CloseIgnoringInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.CloseIgnoringInputStream

No usage of org.apache.poi.util.CloseIgnoringInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.CommonsLogger

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.CommonsLogger

No usage of org.apache.poi.util.CommonsLogger

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.util.DelayableLittleEndianOutput

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.util.DelayableLittleEndianOutput

Packages that use DelayableLittleEndianOutput
org.apache.poi.util Top-level util package are classes that are useful throughout the project.

Uses of DelayableLittleEndianOutput in org.apache.poi.util

Classes in org.apache.poi.util that implement DelayableLittleEndianOutput
 class LittleEndianByteArrayOutputStream
Adapts a plain byte array to LittleEndianOutput

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.DrawingDump

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.DrawingDump

No usage of org.apache.poi.util.DrawingDump

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.util.FixedField

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.util.FixedField

Packages that use FixedField
org.apache.poi.util Top-level util package are classes that are useful throughout the project.

Uses of FixedField in org.apache.poi.util

Classes in org.apache.poi.util that implement FixedField
class | ByteField representation of a byte (8-bit) field at a fixed location within a byte array
class | IntegerField representation of an integer (32-bit) field at a fixed location within a byte array
class | LongField representation of a long (16-bit) field at a fixed location within a byte array
class | ShortField representation of a short (16-bit) field at a fixed location within a byte array

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.FontMetricsDumper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.FontMetricsDumper

No usage of org.apache.poi.util.FontMetricsDumper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.HexDump

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.HexDump

No usage of org.apache.poi.util.HexDump

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.HexRead

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.HexRead

No usage of org.apache.poi.util.HexRead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.IdentifierManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.IdentifierManager

No usage of org.apache.poi.util.IdentifierManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.IntegerField

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.IntegerField

No usage of org.apache.poi.util.IntegerField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.Internal

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.Internal

Packages that use Internal
org.apache.poi |
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.hssf.model | Provides low level API structures for reading, writing, modifying XLS files.
org.apache.poi.hssf.usermodel | usermodel package maps HSSF low level strutures to familiar workbook/sheet model
org.apache.poi.hwpf |
org.apache.poi.hwpf.converter |
org.apache.poi.hwpf.dev |
org.apache.poi.hwpf.model |
org.apache.poi.hwpf.model.io |
org.apache.poi.hwpf.model.types |
org.apache.poi.hwpf.sprm |
org.apache.poi.hwpf.usermodel |
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.ss.util |
org.apache.poi.xslf |
org.apache.poi.xslf.model |
org.apache.poi.xslf.usermodel |
org.apache.poi.xssf.model |
org.apache.poi.xssf.usermodel |
org.apache.poi.xssf.usermodel.charts |
org.apache.poi.xssf.usermodel.extensions |
org.apache.poi.xwpf.usermodel |

Uses of Internal in org.apache.poi

Methods in org.apache.poi with annotations of type Internal
protected  void POIDocument.copyNodeRecursively(Entry entry, DirectoryEntry target)
Deprecated.

Uses of Internal in org.apache.poi.ddf

Methods in org.apache.poi.ddf with annotations of type Internal
short | EscherRecord.getOptions() options is an internal field.
short | EscherOptRecord.getOptions() Automatically recalculate the correct option
void | EscherRecord.setOptions(short options) Set the options this this record.

Uses of Internal in org.apache.poi.hssf.model

Classes in org.apache.poi.hssf.model with annotations of type Internal
class | InternalSheet Low level model implementation of a Sheet (one workbook contains many sheets) This file contains the low level binary records starting at the sheets BOF and ending with the sheets EOF.
class | InternalWorkbook Low level model implementation of a Workbook.

Uses of Internal in org.apache.poi.hssf.usermodel

Methods in org.apache.poi.hssf.usermodel with annotations of type Internal
 void HSSFPatriarch.addShape(HSSFShape shape)
add a shape to this drawing

Uses of Internal in org.apache.poi.hwpf

Methods in org.apache.poi.hwpf with annotations of type Internal
 byte[] HWPFDocument.getDataStream()
 EscherRecordHolder HWPFDocument.getEscherRecordHolder()
 FieldsTables HWPFDocument.getFieldsTables()
Deprecated.
 RevisionMarkAuthorTable HWPFDocument.getRevisionMarkAuthorTable()
Gets a reference to the revision mark author table, which holds the revision mark authors for the document.
 SavedByTable HWPFDocument.getSavedByTable()
Gets a reference to the saved -by table, which holds the save history for the document.
 ShapesTable HWPFDocument.getShapesTable()
Deprecated. use HWPFDocument.getOfficeDrawingsMain() instead
 byte[] HWPFDocument.getTableStream()
abstract  java.lang.StringBuilder HWPFDocumentCore.getText()
Internal method to access document text
 java.lang.StringBuilder HWPFDocument.getText()
 TextPieceTable HWPFDocument.getTextTable()

Uses of Internal in org.apache.poi.hwpf.converter

Methods in org.apache.poi.hwpf.converter with annotations of type Internal
protected abstract  void AbstractWordConverter.processImageWithoutPicturesManager(org.w3c.dom.Element currentBlock, boolean inlined, Picture picture)

Uses of Internal in org.apache.poi.hwpf.dev

Classes in org.apache.poi.hwpf.dev with annotations of type Internal
class | FieldIterator For iterating through our fields.
class | RecordUtil Helper functions for the record transformations.

Uses of Internal in org.apache.poi.hwpf.model

Classes in org.apache.poi.hwpf.model with annotations of type Internal
class | BookmarkFirstDescriptor
class | BookmarksTables
class | CachedPropertyNode
interface | CharIndexTranslator
class | CHPBinTable This class holds all of the character formatting properties.
class | CHPFormattedDiskPage Represents a CHP fkp.
class | CHPX DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
class | Colorref 24-bit color structure
class | ComplexFileTable
class | DocumentProperties Comment me
class | EscherRecordHolder Based on AbstractEscherRecordHolder from HSSF.
class | Ffn FFN - Font Family Name.
class | FibBase Base part of the File information Block (FibBase).
class | FIBFieldHandler
class | FieldDescriptor Class for the FLD structure.
class | FieldsDocumentPart
class | FieldsTables This class provides access to all the fields Plex.
class | FileInformationBlock The File Information Block (FIB).
class | FontTable FontTable or in MS terminology sttbfffn is a common data structure written in all Word files.
class | FootnoteReferenceDescriptor
class | FormattedDiskPage Represents an FKP data structure.
class | FSPA File Shape Address structure
class | FSPADocumentPart
class | FSPATable This class holds all the FSPA (File Shape Address) structures.
class | GenericPropertyNode
class | Grfhic The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
interface | HDFType Deprecated.
class | Hyphenation Hyphenation.
class | ListData
class | ListFormatOverride
class | ListFormatOverrideLevel The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.
class | ListLevel "The LVL structure contains formatting information about a specific level in a list.
class | ListTables
class | NotesTables Holds information about document notes (footnotes or ending notes)
class | NoteType
class | OldCHPBinTable This class holds all of the character formatting properties from Old (Word 6 / Word 95) documents.
class | OldPAPBinTable This class holds all of the paragraph formatting properties from Old (Word 6 / Word 95) documents.
class | OldSectionTable This class holds all of the section formatting properties from Old (Word 6 / Word 95) documents.
class | PAPBinTable This class represents the bin table of Word document but it also serves as a holder for all of the paragraphs of document that have been loaded into memory.
class | PAPFormattedDiskPage Represents a PAP FKP.
class | PAPX DANGER - works in bytes! Make sure you call getStart() / getEnd() when you want characters (normal use), but getStartByte() / getEndByte() when you're reading in / writing out!
class | ParagraphHeight
class | PICF The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
class | PICFAndOfficeArtData
class | PicturesTable Holds information about all pictures embedded in Word Document either via "Insert -> Picture -> From File" or via clipboard.
class | PieceDescriptor
class | PlexOfField Structure describing the Plex for fields (contained plclfd* in the spec).
class | PropertyModifier
class | PropertyNode<T extends PropertyNode<T>> Represents a lightweight node in the Trees used to store content properties.
class | RevisionMarkAuthorTable String table containing the names of authors of revision marks, e-mails and comments in this document.
class | SavedByEntry A single entry in the SavedByTable.
class | SavedByTable String table containing the history of the last few revisions ("saves") of the document.
class | SectionDescriptor Section Descriptor (SED) See page 186 for details.
class | SectionTable
class | SEPX
class | ShapesTable Deprecated.
class | SinglentonTextPiece
class | StyleDescription Comment me
class | StyleSheet Represents a document's stylesheet.
class | SubdocumentType Document text parts that can have text pieces (CPs)
class | TextPiece Lightweight representation of a text piece.
class | TextPieceTable The piece table for matching up character positions to bits of text.
class | UnhandledDataStructure
class | UPX

Methods in org.apache.poi.hwpf.model with annotations of type Internal
 ParagraphProperties PAPX.getParagraphProperties(StyleSheet ss)
Deprecated.

Uses of Internal in org.apache.poi.hwpf.model.io

Classes in org.apache.poi.hwpf.model.io with annotations of type Internal
class | HWPFFileSystem
class | HWPFOutputStream

Uses of Internal in org.apache.poi.hwpf.model.types

Classes in org.apache.poi.hwpf.model.types with annotations of type Internal
class | BKFAbstractType BooKmark First descriptor (BKF).
class | CHPAbstractType Character Properties.
class | DOPAbstractType Document Properties.
class | FibBaseAbstractType Base part of the File information Block (FibBase).
class | FibRgLw95AbstractType The FibRgLw95 structure is the third section of the FIB for Word95.
class | FibRgLw97AbstractType The FibRgLw97 structure is the third section of the FIB.
class | FibRgW97AbstractType The FibRgW97 structure is a variable-length portion of the Fib.
class | FLDAbstractType Field Descriptor (FLD).
class | FRDAbstractType Footnote Reference Descriptor (FRD).
class | FSPAAbstractType File Shape Address (FSPA).
class | GrfhicAbstractType The grfhic structure is a set of HTML incompatibility flags that specify the HTML incompatibilities of a list structure.
class | HRESIAbstractType Hyphenation (HRESI).
class | LFOAbstractType List Format Override (LFO).
class | LFOLVLBaseAbstractType The LFOLVL structure contains information that is used to override the formatting information of a corresponding LVL.
class | LSTFAbstractType The LSTF structure contains formatting properties that apply to an entire list.
class | LVLFAbstractType The LVLF structure contains formatting properties for an individual level in a list.
class | PAPAbstractType Paragraph Properties.
class | PICFAbstractType The PICF structure specifies the type of a picture, as well as the size of the picture and information about its border.
class | SEPAbstractType Section Properties.
class | SHD80AbstractType The SHD80 is a substructure of the CHP and PAP, and TC for Word 97.
class | SHDAbstractType The SHD is a substructure of the CHP, PAP, and TC for Word 2000.
class | StdfBaseAbstractType The StdfBase structure specifies general information about a style.
class | StdfPost2000AbstractType The StdfPost2000 structure specifies general information about a style.
class | StshifAbstractType The Stshif structure specifies general stylesheet information.
class | TAPAbstractType Table Properties.
class | TBDAbstractType The TBD is a substructure of the PAP.
class | TCAbstractType Table Cell Descriptor.
class | TLPAbstractType Table Autoformat Look sPecifier (TLP).

Methods in org.apache.poi.hwpf.model.types with annotations of type Internal
short | DOPAbstractType.getAdt() Get the adt field for the DOP record.
byte[] | PAPAbstractType.getAnld() Get the anld field for the PAP record.
byte[] | DOPAbstractType.getAsumyi() Get the asumyi field for the DOP record.
int | StdfBaseAbstractType.getBchUpe() An unsigned integer that specifies the size, in bytes, of std in LPStd.
byte | PICFAbstractType.getBpp() Get the bpp field for the PICF record.
BorderCode | CHPAbstractType.getBrc() Border.
BorderCode | PAPAbstractType.getBrcBar() Get the brcBar field for the PAP record.
BorderCode | PAPAbstractType.getBrcBetween() Get the brcBetween field for the PAP record.
BorderCode | TCAbstractType.getBrcBottom() Bottom border.
BorderCode | TAPAbstractType.getBrcBottom() Get the brcBottom field for the TAP record.
BorderCode | PAPAbstractType.getBrcBottom() Get the brcBottom field for the PAP record.
byte[] | PICFAbstractType.getBrcBottom80() Get the brcBottom80 field for the PICF record.
BorderCode | TAPAbstractType.getBrcHorizontal() Get the brcHorizontal field for the TAP record.
byte | PAPAbstractType.getBrcl() Border line style.
BorderCode | TCAbstractType.getBrcLeft() Left border.
BorderCode | TAPAbstractType.getBrcLeft() Get the brcLeft field for the TAP record.
BorderCode | PAPAbstractType.getBrcLeft() Get the brcLeft field for the PAP record.
byte[] | PICFAbstractType.getBrcLeft80() Get the brcLeft80 field for the PICF record.
byte | PAPAbstractType.getBrcp() Rectangle border codes.
BorderCode | TCAbstractType.getBrcRight() Right border.
BorderCode | TAPAbstractType.getBrcRight() Get the brcRight field for the TAP record.
BorderCode | PAPAbstractType.getBrcRight() Get the brcRight field for the PAP record.
byte[] | PICFAbstractType.getBrcRight80() Get the brcRight80 field for the PICF record.
BorderCode | TCAbstractType.getBrcTop() Top border.
BorderCode | TAPAbstractType.getBrcTop() Get the brcTop field for the TAP record.
BorderCode | PAPAbstractType.getBrcTop() Get the brcTop field for the PAP record.
byte[] | PICFAbstractType.getBrcTop80() Get the brcTop80 field for the PICF record.
BorderCode | TAPAbstractType.getBrcVertical() Get the brcVertical field for the TAP record.
byte | FSPAAbstractType.getBx() X position of shape relative to anchor CP
byte | FSPAAbstractType.getBy() Y position of shape relative to anchor CP
short | LVLFAbstractType.getCbGrpprlChpx() An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.
short | LVLFAbstractType.getCbGrpprlPapx() An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.
int | PICFAbstractType.getCbHeader() An unsigned integer that specifies the size, in bytes, of this PICF structure.
int | FibRgLw97AbstractType.getCbMac() Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning.
int | FibRgLw95AbstractType.getCbMac() Get the cbMac field for the FibRgLw95 record.
int | StshifAbstractType.getCbSTDBaseInFile() An unsigned integer that specifies the size, in bytes, of the Stdf structure.
int | DOPAbstractType.getCCh() Get the cCh field for the DOP record.
int | DOPAbstractType.getCChFtnEdn() Get the cChFtnEdn field for the DOP record.
int | DOPAbstractType.getCChWS() Get the cChWS field for the DOP record.
int | DOPAbstractType.getCChWSFtnEdn() Get the cChWSFtnEdn field for the DOP record.
int | DOPAbstractType.getCConsexHypLim() Get the cConsexHypLim field for the DOP record.
int | FibRgLw97AbstractType.getCcpAtn() A signed integer that specifies the count of CPs in the comment subdocument.
int | FibRgLw95AbstractType.getCcpAtn() Get the ccpAtn field for the FibRgLw95 record.
int | FibRgLw97AbstractType.getCcpEdn() A signed integer that specifies the count of CPs in the endnote subdocument.
int | FibRgLw95AbstractType.getCcpEdn() Get the ccpEdn field for the FibRgLw95 record.
int | FibRgLw97AbstractType.getCcpFtn() A signed integer that specifies the count of CPs in the footnote subdocument.
int | FibRgLw95AbstractType.getCcpFtn() Get the ccpFtn field for the FibRgLw95 record.
int | FibRgLw97AbstractType.getCcpHdd() A signed integer that specifies the count of CPs in the header subdocument.
int | FibRgLw95AbstractType.getCcpHdd() Get the ccpHdd field for the FibRgLw95 record.
int | FibRgLw97AbstractType.getCcpHdrTxbx() A signed integer that specifies the count of CPs in the textbox subdocument of the header.
int | FibRgLw95AbstractType.getCcpHdrTxbx() Get the ccpHdrTxbx field for the FibRgLw95 record.
int | FibRgLw95AbstractType.getCcpMcr() Get the ccpMcr field for the FibRgLw95 record.
int | FibRgLw97AbstractType.getCcpText() A signed integer that specifies the count of CPs in the main document.
int | FibRgLw95AbstractType.getCcpText() Get the ccpText field for the FibRgLw95 record.
int | FibRgLw97AbstractType.getCcpTxbx() A signed integer that specifies the count of CPs in the textbox subdocument of the main document.
int | FibRgLw95AbstractType.getCcpTxbx() Get the ccpTxbx field for the FibRgLw95 record.
int | DOPAbstractType.getCDBC() Get the cDBC field for the DOP record.
int | DOPAbstractType.getCDBCFtnEdn() Get the cDBCFtnEdn field for the DOP record.
short | CHPAbstractType.getCharsetFlags() Get the CharsetFlags field for the CHP record.
short | TAPAbstractType.getCHorzBands() Size of each horizontal style band, in number of rows.
short | FibBaseAbstractType.getChs() This value MUST be 0 and MUST be ignored.
short | CHPAbstractType.getChse() Get the chse field for the CHP record.
short | FibBaseAbstractType.getChsTables() This value MUST be 0 and MUST be ignored.
byte | LFOAbstractType.getClfolvl() Count of levels whose format is overridden (see LFOLVL).
int | DOPAbstractType.getCLines() Get the cLines field for the DOP record.
int | DOPAbstractType.getCLinesFtnEdn() Get the cLinesFtnEdn field for the DOP record.
byte | CHPAbstractType.getCopt() Collection of the 5 flags.
int | DOPAbstractType.getCParas() Get the cParas field for the DOP record.
int | DOPAbstractType.getCParasFtnEdn() Get the cParasFtnEdn field for the DOP record.
int | CHPAbstractType.getCpg() Code page of run in pre-Unicode files.
int | DOPAbstractType.getCPg() Get the cPg field for the DOP record.
short | DOPAbstractType.getCPgFtnEdn() Get the cPgFtnEdn field for the DOP record.
short | PICFAbstractType.getCProps() This value MUST be 0 and MUST be ignored.
byte | FibBaseAbstractType.getCQuickSaves() An unsigned integer.
int | StshifAbstractType.getCstd() An unsigned integer that specifies the count of elements in STSH.rglpstd.
int | FSPAAbstractType.getCTxbx() Count of textboxes in shape (undo doc only).
byte | StdfBaseAbstractType.getCupx() number of UPXs (and UPEs)
Colorref | CHPAbstractType.getCv() 24-bit color.
Colorref | SHDAbstractType.getCvBack() 24-bit background color.
short | TAPAbstractType.getCVertBands() Size of a vertical style band, in number of columns.
Colorref | SHDAbstractType.getCvFore() 24-bit foreground color.
int | DOPAbstractType.getCWords() Get the cWords field for the DOP record.
int | DOPAbstractType.getCWordsFtnEnd() Get the cWordsFtnEnd field for the DOP record.
DropCapSpecifier | PAPAbstractType.getDcs() Get the dcs field for the PAP record.
byte | DOPAbstractType.getDocinfo() Get the docinfo field for the DOP record.
byte | DOPAbstractType.getDocinfo1() Get the docinfo1 field for the DOP record.
byte | DOPAbstractType.getDocinfo2() Get the docinfo2 field for the DOP record.
short | DOPAbstractType.getDocinfo3() Get the docinfo3 field for the DOP record.
int | DOPAbstractType.getDocinfo4() Get the docinfo4 field for the DOP record.
short | DOPAbstractType.getDocinfo5() Get the docinfo5 field for the DOP record.
short | DOPAbstractType.getDocinfo6() Get the docinfo6 field for the DOP record.
byte[] | DOPAbstractType.getDogrid() Get the dogrid field for the DOP record.
byte[] | DOPAbstractType.getDoptypography() Get the doptypography field for the DOP record.
DateAndTime | CHPAbstractType.getDttmConflict() When the change was made.
int | DOPAbstractType.getDttmCreated() Get the dttmCreated field for the DOP record.
DateAndTime | CHPAbstractType.getDttmDispFldRMark() The date for the ListNum field number change.
int | DOPAbstractType.getDttmLastPrint() Get the dttmLastPrint field for the DOP record.
DateAndTime | PAPAbstractType.getDttmPropRMark() Get the dttmPropRMark field for the PAP record.
DateAndTime | CHPAbstractType.getDttmPropRMark() Date/time at which properties of this were changed for this run of text by the author.
int | DOPAbstractType.getDttmRevised() Get the dttmRevised field for the DOP record.
DateAndTime | CHPAbstractType.getDttmRMark() Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
DateAndTime | CHPAbstractType.getDttmRMarkDel() Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).
int | TAPAbstractType.getDxaAbs() Absolute horizontal position.
int | PAPAbstractType.getDxaAbs() Get the dxaAbs field for the PAP record.
int | TAPAbstractType.getDxaAdjust() Used internally by Word.
int | TAPAbstractType.getDxaColWidthWwd() Used internally by Word.
int | TAPAbstractType.getDxaFromText() Left distance from surrounding text when absolutely positioned.
int | PAPAbstractType.getDxaFromText() Horizontal distance between text and absolutely positioned object.
int | TAPAbstractType.getDxaFromTextRight() Right distance from surrounding text when absolutely positioned.
int | TAPAbstractType.getDxaGapHalf() Measures half of the white space that will be maintained between text in adjacent columns of a table row.
short | PICFAbstractType.getDxaGoal() Get the dxaGoal field for the PICF record.
int | DOPAbstractType.getDxaHotz() Get the dxaHotz field for the DOP record.
int | LVLFAbstractType.getDxaIndentSav() If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed.
int | PAPAbstractType.getDxaLeft() Get the dxaLeft field for the PAP record.
int | PAPAbstractType.getDxaLeft1() Get the dxaLeft1 field for the PAP record.
short | PICFAbstractType.getDxaReserved1() Get the dxaReserved1 field for the PICF record.
short | PICFAbstractType.getDxaReserved2() Get the dxaReserved2 field for the PICF record.
short | PICFAbstractType.getDxaReserved3() Get the dxaReserved3 field for the PICF record.
int | PAPAbstractType.getDxaRight() Get the dxaRight field for the PAP record.
int | TAPAbstractType.getDxaRTEWrapWidth() Used internally by Word.
int | CHPAbstractType.getDxaSpace() Space following each character in the run expressed in twip units..
int | DOPAbstractType.getDxaTab() Get the dxaTab field for the DOP record.
int | TAPAbstractType.getDxaWebView() Used internally by Word.
int | PAPAbstractType.getDxaWidth() Get the dxaWidth field for the PAP record.
short | PAPAbstractType.getDxcLeft() Left indent in character units.
short | PAPAbstractType.getDxcLeft1() First line indent in character units.
short | PAPAbstractType.getDxcRight() Right indent in character units.
int | TAPAbstractType.getDyaAbs() Absolute vertical position.
int | PAPAbstractType.getDyaAbs() Get the dyaAbs field for the PAP record.
int | PAPAbstractType.getDyaAfter() Space after paragraph.
int | PAPAbstractType.getDyaBefore() Space before paragraph.
int | TAPAbstractType.getDyaFromText() Top distance from surrounding text when absolutely positioned.
int | PAPAbstractType.getDyaFromText() Vertical distance between text and absolutely positioned object.
int | TAPAbstractType.getDyaFromTextBottom() Bottom distance from surrounding text when absolutely positioned.
short | PICFAbstractType.getDyaGoal() Get the dyaGoal field for the PICF record.
int | PAPAbstractType.getDyaHeight() Get the dyaHeight field for the PAP record.
short | PICFAbstractType.getDyaReserved1() Get the dyaReserved1 field for the PICF record.
short | PICFAbstractType.getDyaReserved2() Get the dyaReserved2 field for the PICF record.
short | PICFAbstractType.getDyaReserved3() Get the dyaReserved3 field for the PICF record.
int | TAPAbstractType.getDyaRowHeight() When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high.
short | DOPAbstractType.getDywDispPag() Get the dywDispPag field for the DOP record.
short | DOPAbstractType.getEdn() Get the Edn field for the DOP record.
short | DOPAbstractType.getEdn1() Get the Edn1 field for the DOP record.
byte | FibBaseAbstractType.getEnvr() This value MUST be 0, and MUST be ignored.
byte | DOPAbstractType.getEpc()
boolean | PAPAbstractType.getFAdjustRight() Get the fAdjustRight field for the PAP record.
boolean | PAPAbstractType.getFAutoSpaceDE() auto space East Asian and alphabetic characters.
boolean | PAPAbstractType.getFAutoSpaceDN() auto space East Asian and numeric characters.
byte | TAPAbstractType.getFBiDi() When 1, table is right-to-left.
boolean | PAPAbstractType.getFBiDi() Get the fBiDi field for the PAP record.
boolean | CHPAbstractType.getFBorderWS() Used internally by Word.
boolean | PAPAbstractType.getFBrLnAbove() Get the fBrLnAbove field for the PAP record.
boolean | PAPAbstractType.getFBrLnBelow() Get the fBrLnBelow field for the PAP record.
boolean | TAPAbstractType.getFCantSplit() When 1, table row may not be split across page bounds.
boolean | TAPAbstractType.getFCantSplit90() When 1, table row may not be split across page bounds.
int | CHPAbstractType.getFcData() Points to location of picture data, only if chp.fSpec is true..
int | FibBaseAbstractType.getFcMac() This value is undefined and MUST be ignored.
int | FibBaseAbstractType.getFcMin() This value is undefined and MUST be ignored.
int | CHPAbstractType.getFcObj() Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..
int | CHPAbstractType.getFcObjp() Offset in the data stream indicating the location of OLE object data.
boolean | CHPAbstractType.getFConflictOrig() When chp.wConflict!=0, this is TRUE when text is part of the original version of text.
boolean | CHPAbstractType.getFConflictOtherDel() When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.
int | CHPAbstractType.getFcPic() Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..
boolean | PAPAbstractType.getFCrLf() Get the fCrLf field for the PAP record.
boolean | CHPAbstractType.getFDblBdr() Used internally by Word.
boolean | CHPAbstractType.getFDispFldRMark() the number for a ListNum field is being tracked in xstDispFldRMark.
boolean | PAPAbstractType.getFDyaAfterAuto() Vertical spacing after is automatic.
boolean | PAPAbstractType.getFDyaBeforeAuto() Vertical spacing before is automatic.
byte | TAPAbstractType.getFHasOldProps() Has old properties.
boolean | CHPAbstractType.getFHasOldProps() Used for character property revision marking.
boolean | PAPAbstractType.getFInnerTableCell() When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.
boolean | PAPAbstractType.getFInTable() Paragraph is in table flag.
boolean | PAPAbstractType.getFinTableW97() Archaic paragraph is in table flag.
boolean | PAPAbstractType.getFKeep() Get the fKeep field for the PAP record.
boolean | PAPAbstractType.getFKeepFollow() Get the fKeepFollow field for the PAP record.
boolean | PAPAbstractType.getFKinsoku() apply Kinsoku rules when performing line wrapping.
byte | LSTFAbstractType.getFlags() Get the flags field for the LSTF record.
int | LFOLVLBaseAbstractType.getFlags() Get the flags field for the LFOLVLBase record.
short | FSPAAbstractType.getFlags() Get the flags field for the FSPA record.
short | FibBaseAbstractType.getFlags1() Get the flags1 field for the FibBase record.
byte | FibBaseAbstractType.getFlags2() Get the flags2 field for the FibBase record.
boolean | PAPAbstractType.getFLocked() Anchor of an absolutely positioned frame is locked.
boolean | PAPAbstractType.getFMinHeight() Minimum height is exact or auto.
byte | TAPAbstractType.getFNoAllowOverlap() When set to 1, do not allow absolutely positioned table to overlap with other tables.
boolean | PAPAbstractType.getFNoAllowOverlap() When 1, absolutely positioned paragraph cannot overlap with another paragraph.
boolean | PAPAbstractType.getFNoAutoHyph() Get the fNoAutoHyph field for the PAP record.
boolean | PAPAbstractType.getFNoLnn() No line numbering.
boolean | PAPAbstractType.getFNumRMIns() Get the fNumRMIns field for the PAP record.
short | PAPAbstractType.getFontAlign() Used internally by Word.
short | DOPAbstractType.getFootnoteInfo() Get the footnoteInfo field for the DOP record.
boolean | PAPAbstractType.getFOpenTch() Ensure the Table Cell char doesn't show up as zero height.
byte | DOPAbstractType.getFormatFlags() Get the formatFlags field for the DOP record.
byte | DOPAbstractType.getFOutlineDirtySave() Get the fOutlineDirtySave field for the DOP record.
boolean | PAPAbstractType.getFOverflowPunct() apply overflow punctuation rules when performing line wrapping.
boolean | PAPAbstractType.getFPageBreakBefore() Get the fPageBreakBefore field for the PAP record.
byte | DOPAbstractType.getFpc()
byte | TAPAbstractType.getFPropRMark() Set to 1 if property revision.
boolean | PAPAbstractType.getFPropRMark() Get the fPropRMark field for the PAP record.
boolean | CHPAbstractType.getFPropRMark() properties have been changed with revision marking on.
short | StshifAbstractType.getFReserved() This value MUST be zero and MUST be ignored
byte | StdfBaseAbstractType.getFReserved() This value MUST be 0 and MUST be ignored
byte | PICFAbstractType.getFReserved() Get the fReserved field for the PICF record.
byte | TAPAbstractType.getFRTL() Word 2000 style right-to-left table.
boolean | CHPAbstractType.getFSdtVanish() Mark the character as hidden..
boolean | PAPAbstractType.getFSideBySide() Get the fSideBySide field for the PAP record.
byte | TAPAbstractType.getFSpare() Not used.
byte | StdfPost2000AbstractType.getFSpare() Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97
byte | FibBaseAbstractType.getFSpare0() Deprecated. This field should not be used according to specification
boolean | CHPAbstractType.getFSpecSymbol() Used by Word internally.
boolean | CHPAbstractType.getFSpecVanish() Special hidden for leading emphasis (always hidden).
boolean | TAPAbstractType.getFTableHeader() When 1, table row is to be used as the header of the table.
short | StshifAbstractType.getFtcAsci() A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.
int | CHPAbstractType.getFtcAscii() Font for ASCII text.
int | CHPAbstractType.getFtcBi() Font for Complex Scripts text.
short | StshifAbstractType.getFtcFE() A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.
int | CHPAbstractType.getFtcFE() Font for East Asian text.
short | StshifAbstractType.getFtcOther() A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.
int | CHPAbstractType.getFtcOther() Font for non-East Asian text.
int | CHPAbstractType.getFtcSym() an index into the rgffn structure.
boolean | PAPAbstractType.getFTopLinePunct() perform top line punctuation processing.
byte | TCAbstractType.getFtsCellPaddingBottom() Bottom cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingDefaultBottom() Default bottom cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingDefaultLeft() Default left cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingDefaultRight() Default right cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingDefaultTop() Default top cell margin/padding units.
byte | TCAbstractType.getFtsCellPaddingLeft() Left cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingOuterBottom() Default outer bottom cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingOuterLeft() Default outer left cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingOuterRight() Default outer right cell margin/padding units.
byte | TAPAbstractType.getFtsCellPaddingOuterTop() Default outer top cell margin/padding units.
byte | TCAbstractType.getFtsCellPaddingRight() Right cell margin/padding units.
byte | TCAbstractType.getFtsCellPaddingTop() Top cell margin/padding units.
byte | TCAbstractType.getFtsCellSpacingBottom() Bottom cell spacing units.
byte | TAPAbstractType.getFtsCellSpacingDefaultBottom() Default bottom cell spacings units.
byte | TAPAbstractType.getFtsCellSpacingDefaultLeft() Default left cell spacings units.
byte | TAPAbstractType.getFtsCellSpacingDefaultRight() Default right cell spacings units.
byte | TAPAbstractType.getFtsCellSpacingDefaultTop() Default top cell spacings units.
byte | TCAbstractType.getFtsCellSpacingLeft() Left cell spacing units.
byte | TAPAbstractType.getFtsCellSpacingOuterBottom() Default outer bottom cell spacings units.
byte | TAPAbstractType.getFtsCellSpacingOuterLeft() Default outer left cell spacings units.
byte | TAPAbstractType.getFtsCellSpacingOuterRight() Default outer right cell spacings units.
byte | TAPAbstractType.getFtsCellSpacingOuterTop() Default outer top cell spacings units.
byte | TCAbstractType.getFtsCellSpacingRight() Right cell spacing units.
byte | TCAbstractType.getFtsCellSpacingTop() Top cell spacing units.
byte | TCAbstractType.getFtsWidth() Units for wWidth
byte | TAPAbstractType.getFtsWidth() Units for wWidth: 0 -- null; 1 -- auto, ignores wWidth, 2 -- percentage (in 50ths of a percent), 3 -- twips
byte | TAPAbstractType.getFtsWidthAfter() Units for wWidthAfter: 0 -- null; 1 -- auto, ignores wWidthAfter, 2 -- percentage (in 50ths of a percent), 3 -- twips
byte | TAPAbstractType.getFtsWidthBefore() Units for wWidthBefore: 0 -- null; 1 -- auto, ignores wWidthBefore, 2 -- percentage (in 50ths of a percent), 3 -- twips
byte | TAPAbstractType.getFtsWidthIndent() Units for wWidthIndent: 0 -- null; 1 -- auto, ignores wWidthIndent, 2 -- percentage (in 50ths of a percent), 3 -- twips
boolean | PAPAbstractType.getFTtp() Table trailer paragraph (last in table row).
boolean | PAPAbstractType.getFTtpEmbedded() Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.
boolean | CHPAbstractType.getFUndetermine() Character is undetermined.
byte | TCAbstractType.getFUnused() Not used
boolean | PAPAbstractType.getFUsePgsuSettings() Get the fUsePgsuSettings field for the PAP record.
boolean | PAPAbstractType.getFWidowControl() 1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.
boolean | PAPAbstractType.getFWordWrap() perform word wrap.
int | PICFAbstractType.getGrf() This field MUST be ignored.
int | DOPAbstractType.getGrfDocEvents() Get the grfDocEvents field for the DOP record.
Grfhic | LVLFAbstractType.getGrfhic() A grfhic that specifies the HTML incompatibilities of the level..
Grfhic | LSTFAbstractType.getGrfhic() A grfhic that specifies the HTML incompatibilities of the list..
short | LFOLVLBaseAbstractType.getGrfhic() A grfhic that specifies the HTML incompatibilities of the overriding level formatting
Grfhic | LFOAbstractType.getGrfhic() HTML compatibility flags.
byte | GrfhicAbstractType.getGrfhic() HTML compatibility flags.
short | StdfBaseAbstractType.getGrfstd() A GRFSTD that specifies miscellaneous style properties.
byte | DOPAbstractType.getGrfSupression()
int | CHPAbstractType.getGrpfChp() Collection of the 32 flags.
short | TAPAbstractType.getGrpfTap_unused() Not used
int | TAPAbstractType.getGrpfTap() Used internally by Word.
short | CHPAbstractType.getHighlight() Get the Highlight field for the CHP record.
int | CHPAbstractType.getHps() Font size in half points.
int | CHPAbstractType.getHpsAsci() Font size for ASCII font.
int | CHPAbstractType.getHpsBi() Font size for Complex Scripts text.
int | CHPAbstractType.getHpsFE() Font size for East Asian text.
int | CHPAbstractType.getHpsKern() Kerning distance for characters in run recorded in half points.
short | CHPAbstractType.getHpsPos() Reserved (actually used as vertical offset(?) value).
short | DOPAbstractType.getHpsZoonFontPag() Get the hpsZoonFontPag field for the DOP record.
Hyphenation | CHPAbstractType.getHresi() Get the hresi field for the CHP record.
Hyphenation | CHPAbstractType.getHresiOld() Get the hresiOld field for the CHP record.
int | CHPAbstractType.getIbstConflict() Who made this change for this side of the conflict..
int | CHPAbstractType.getIbstDispFldRMark() Index to author IDs stored in hsttbfRMark.
byte | LFOAbstractType.getIbstFltAutoNum() Used for AUTONUM field emulation.
int | PAPAbstractType.getIbstPropRMark() Get the ibstPropRMark field for the PAP record.
int | CHPAbstractType.getIbstPropRMark() Index to author IDs stored in hsttbfRMark.
int | CHPAbstractType.getIbstRMark() Index to author IDs stored in hsttbfRMark.
int | CHPAbstractType.getIbstRMarkDel() Index to author IDs stored in hsttbfRMark.
byte | CHPAbstractType.getIco() Color of text for Word 97.
byte | SHD80AbstractType.getIcoBack() Background color
byte | SHD80AbstractType.getIcoFore() Foreground color
byte | CHPAbstractType.getIcoHighlight() Highlight color (see chp.ico)
byte | CHPAbstractType.getIdct() Not stored in file.
byte | CHPAbstractType.getIdctHint() Identifier of Character type.
int | CHPAbstractType.getIdslReasonDel() An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
int | CHPAbstractType.getIdslRMReason() An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
byte | StdfPost2000AbstractType.getIftcHtml() This field is undefined and MUST be ignored
int | PAPAbstractType.getIlfo() 1-based index into the pllfo (lists structure), if non-zero.
byte | PAPAbstractType.getIlvl() List level if non-zero.
byte | LFOLVLBaseAbstractType.getILvl() An unsigned integer that specifies the zero-based level of the list that this overrides.
short | LVLFAbstractType.getIlvlRestartLim() An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart.
byte | LVLFAbstractType.getInfo() Get the info field for the LVLF record.
short | StdfPost2000AbstractType.getInfo1() Get the info1 field for the StdfPost2000 record.
short | StdfBaseAbstractType.getInfo1() Get the info1 field for the StdfBase record.
short | StdfBaseAbstractType.getInfo2() Get the info2 field for the StdfBase record.
int | StshifAbstractType.getInfo3() Get the info3 field for the Stshif record.
short | StdfPost2000AbstractType.getInfo3() Get the info3 field for the StdfPost2000 record.
short | StdfBaseAbstractType.getInfo3() Get the info3 field for the StdfBase record.
int | TAPAbstractType.getInternalFlags() Used internally by Word.
int | SHDAbstractType.getIpat() Shading pattern.
byte | SHD80AbstractType.getIpat() Shading pattern
long | PAPAbstractType.getIpgp() HTML DIV ID for this paragraph.
short | StdfPost2000AbstractType.getIPriority() An unsigned integer that specifies the priority value that is assigned to this style and that is used when ordering the styles by priority in the user interface
byte | CHPAbstractType.getIss() Superscript/subscript indices.
int | LVLFAbstractType.getIStartAt() A signed integer that specifies the beginning number for the number sequence belonging to this level.
int | LFOLVLBaseAbstractType.getIStartAt() If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL.
short | TAPAbstractType.getIstd() Table style for the Table.
int | PAPAbstractType.getIstd() Index to style descriptor.
int | CHPAbstractType.getIstd() Index to character style descriptor in the stylesheet that tags this run of text.
short | StdfBaseAbstractType.getIstdBase() base style
short | StdfPost2000AbstractType.getIstdLink() An unsigned integer that specifies the istd of the style that is linked to this one, or 0x0000 if this style is not linked to any other style in the document.
int | StshifAbstractType.getIstdMaxFixedWhenSaved() An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles.
short | StdfBaseAbstractType.getIstdNext() next style
int | PAPAbstractType.getItap() Table nesting level.
int | PAPAbstractType.getItbdMac() Number of tabs stops defined for paragraph.
short | TAPAbstractType.getItcMac() Count of cells defined for this row.
short | CHPAbstractType.getItypFELayout()
byte | CHPAbstractType.getIWarichuBracket() Bracket character for two-lines-in-one
byte | LVLFAbstractType.getIxchFollow() An unsigned integer that specifies the character that follows the number text.
byte | TBDAbstractType.getJc() Justification code
short | TAPAbstractType.getJc() Justification code.
byte | PAPAbstractType.getJc() Get the jc field for the PAP record.
byte | LVLFAbstractType.getJc() An unsigned integer that specifies the justification of this level
byte | CHPAbstractType.getKcd() Emphasis mark.
int | DOPAbstractType.getKeyVirusSession30()
byte | CHPAbstractType.getKul() Underline code.
byte | CHPAbstractType.getLbrCRJ() Line BReak code for xchCRJ.
int | PICFAbstractType.getLcb() A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.
int | FibBaseAbstractType.getLid() A LID that specifies the install language of the application that is producing the document.
int | CHPAbstractType.getLidDefault() Get the lidDefault field for the CHP record.
short | FibRgW97AbstractType.getLidFE() A LID whose meaning depends on the nFib value.
int | CHPAbstractType.getLidFE() Get the lidFE field for the CHP record.
int | FibBaseAbstractType.getLKey() If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier.
int | DOPAbstractType.getLKeyProtDoc() Get the lKeyProtDoc field for the DOP record.
int | LSTFAbstractType.getLsid() A signed integer that specifies the list identifier.
int | LFOAbstractType.getLsid() List ID of corresponding LSTF (see LSTF).
LineSpacingDescriptor | PAPAbstractType.getLspd() Line spacing descriptor.
int | CHPAbstractType.getLTagObj() An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..
byte | PAPAbstractType.getLvl() Outline level.
byte | DOPAbstractType.getLvl()
short | PICFAbstractType.getMm() A signed integer that specifies the format of the picture data.
int | PICFAbstractType.getMmPM() This field MUST be ignored.
int | PICFAbstractType.getMx() Get the mx field for the PICF record.
int | PICFAbstractType.getMy() Get the my field for the PICF record.
short | DOPAbstractType.getNEdn()
byte | LVLFAbstractType.getNfc() An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list.
short | DOPAbstractType.getNfcEdnRef() Get the nfcEdnRef field for the DOP record.
byte | DOPAbstractType.getNfcEdnRef1()
short | DOPAbstractType.getNfcFtnRef() Get the nfcFtnRef field for the DOP record.
byte | DOPAbstractType.getNfcFtnRef1()
int | FibBaseAbstractType.getNFib() An unsigned integer that specifies the version number of the file format used.
int | FibBaseAbstractType.getNFibBack() This value SHOULD be 0x00BF.
short | DOPAbstractType.getNFtn()
int | DOPAbstractType.getNRevision() Get the nRevision field for the DOP record.
byte[] | PAPAbstractType.getNumrm() Get the numrm field for the PAP record.
int | StshifAbstractType.getNVerBuiltInNamesWhenSaved() An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.
int | PICFAbstractType.getPadding() This value MUST be zero and MUST be ignored.
int | PICFAbstractType.getPadding2() This value MUST be zero and MUST be ignored.
byte | TAPAbstractType.getPcHorz() Horizontal position code.
byte | PAPAbstractType.getPcHorz() Get the pcHorz field for the PAP record.
int | CHPAbstractType.getPctCharWidth() Character scale.
short | TAPAbstractType.getPctWwd() Used internally by Word: percent of Window size for AutoFit in WebView.
byte | TAPAbstractType.getPcVert() Vertical position code.
byte | PAPAbstractType.getPcVert() Get the pcVert field for the PAP record.
byte[] | PAPAbstractType.getPhe() Get the phe field for the PAP record.
int | FibBaseAbstractType.getPnNext() An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.
byte[] | PAPAbstractType.getPtap() Get the ptap field for the PAP record.
byte | TBDAbstractType.getReserved()
int | DOPAbstractType.getReserved() Get the reserved field for the DOP record.
byte | LSTFAbstractType.getReserved1() Deprecated. This field should not be used according to specification
int | LFOAbstractType.getReserved1() Reserved.
short | FibRgW97AbstractType.getReserved1() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved1() This value is undefined and MUST be ignored.
int | FibRgLw95AbstractType.getReserved1() Get the reserved1 field for the FibRgLw95 record.
int | DOPAbstractType.getReserved1() Get the reserved1 field for the DOP record.
short | FibRgW97AbstractType.getReserved10() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved10() This value is undefined and MUST be ignored.
short | FibRgW97AbstractType.getReserved11() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved11() This value is undefined and MUST be ignored.
short | FibRgW97AbstractType.getReserved12() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved12() This value SHOULD be zero, and MUST be ignored.
short | FibRgW97AbstractType.getReserved13() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved13() This value MUST be zero and MUST be ignored.
int | FibRgLw97AbstractType.getReserved14() This value MUST be zero and MUST be ignored.
int | LFOAbstractType.getReserved2() Reserved.
short | FibRgW97AbstractType.getReserved2() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved2() This value is undefined and MUST be ignored.
int | FibRgLw95AbstractType.getReserved2() Get the reserved2 field for the FibRgLw95 record.
int | DOPAbstractType.getReserved2() Get the reserved2 field for the DOP record.
byte | LFOAbstractType.getReserved3() Reserved.
short | FibRgW97AbstractType.getReserved3() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved3() This value is undefined and MUST be ignored.
int | FibRgLw95AbstractType.getReserved3() Get the reserved3 field for the FibRgLw95 record.
short | FibRgW97AbstractType.getReserved4() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved4() This value is undefined and MUST be ignored.
int | FibRgLw95AbstractType.getReserved4() Get the reserved4 field for the FibRgLw95 record.
short | FibRgW97AbstractType.getReserved5() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved5() This value is undefined and MUST be ignored.
int | FibRgLw95AbstractType.getReserved5() Get the reserved5 field for the FibRgLw95 record.
short | FibRgW97AbstractType.getReserved6() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved6() This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx.
short | FibRgW97AbstractType.getReserved7() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved7() This value is undefined and MUST be ignored.
short | FibRgW97AbstractType.getReserved8() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved8() This value is undefined and MUST be ignored.
short | FibRgW97AbstractType.getReserved9() This value is undefined and MUST be ignored.
int | FibRgLw97AbstractType.getReserved9() This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx.
BorderCode | TAPAbstractType.getRgbrcInsideDefault_0() Border definition for inside horizontal borders.
BorderCode | TAPAbstractType.getRgbrcInsideDefault_1() Border definition for inside vertical borders.
byte[] | LVLFAbstractType.getRgbxchNums() An array of 8-bit integers.
short[] | TAPAbstractType.getRgdxaCenter() rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..
short[] | TAPAbstractType.getRgdxaCenterPrint() Used internally by Word.
int[] | PAPAbstractType.getRgdxaTab() Array of positions of itbdMac tab stops.
short | TCAbstractType.getRgf() Get the rgf field for the TC record.
short[] | LSTFAbstractType.getRgistdPara() An array of nine 16-bit signed integers.
ShadingDescriptor[] | TAPAbstractType.getRgshd() Get the rgshd field for the TAP record.
TabDescriptor[] | PAPAbstractType.getRgtbd() Array of itbdMac tab descriptors.
TableCellDescriptor[] | TAPAbstractType.getRgtc() Get the rgtc field for the TAP record.
byte | DOPAbstractType.getRncEdn()
byte | DOPAbstractType.getRncFtn()
long | StdfPost2000AbstractType.getRsid() An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.
long | PAPAbstractType.getRsid() Save ID for last time this PAP was revised.
byte | CHPAbstractType.getSfxtText() Text animation.
ShadingDescriptor | TCAbstractType.getShd() Cell shading.
ShadingDescriptor | PAPAbstractType.getShd() Get the shd field for the PAP record.
ShadingDescriptor | CHPAbstractType.getShd() Shading.
ShadingDescriptor | TAPAbstractType.getShdTable() Table shading.
byte[] | DOPAbstractType.getSpare() Get the Spare field for the DOP record.
byte | CHPAbstractType.getSpare() Unused
int | FSPAAbstractType.getSpid() Shape Identifier.
short | StdfBaseAbstractType.getSti() An unsigned integer that specifies the invariant style identifier for application-defined styles, or 0x0FFE for user-defined styles
int | StshifAbstractType.getStiMaxWhenSaved() An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style.
byte | StdfBaseAbstractType.getStk() style kind
short | PICFAbstractType.getSwHMF() This field is unused and MUST be ignored.
byte | TBDAbstractType.getTlc() Tab leader code
TableAutoformatLookSpecifier | TAPAbstractType.getTlp() Table look specifier.
int | DOPAbstractType.getTmEdited() Get the tmEdited field for the DOP record.
int | LSTFAbstractType.getTplc() A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes.
short | CHPAbstractType.getUfel() Collection properties represented by itypFELayout and copt (East Asian layout properties).
int | FibBaseAbstractType.getUnused() This value is undefined and MUST be ignored.
short | LFOLVLBaseAbstractType.getUnused1() Deprecated. This field should not be used according to specification
int | LVLFAbstractType.getUnused2() This field MUST be ignored.
byte | LFOLVLBaseAbstractType.getUnused2() Deprecated. This field should not be used according to specification
byte | DOPAbstractType.getUnused2() Get the unused2 field for the DOP record.
byte | DOPAbstractType.getUnused5()
byte | TBDAbstractType.getValue() Get the value field for the TBD record.
short | SHD80AbstractType.getValue() Get the value field for the SHD80 record.
byte | TCAbstractType.getVertAlign() Specifies the alignment of the cell contents relative to text flow (e.g.
short | DOPAbstractType.getView() Get the view field for the DOP record.
short | TAPAbstractType.getViewFlags_unused2() Not used
int | TAPAbstractType.getViewFlags() Used internally by Word.
int | DOPAbstractType.getVirusinfo() Get the virusinfo field for the DOP record.
int | PAPAbstractType.getWAlignFont() Get the wAlignFont field for the PAP record.
short | TCAbstractType.getWCellPaddingBottom() Bottom cell margin/padding.
short | TAPAbstractType.getWCellPaddingDefaultBottom() Default bottom cell margin/padding.
short | TAPAbstractType.getWCellPaddingDefaultLeft() Default left cell margin/padding.
short | TAPAbstractType.getWCellPaddingDefaultRight() Default right cell margin/padding.
short | TAPAbstractType.getWCellPaddingDefaultTop() Default top cell margin/padding.
short | TCAbstractType.getWCellPaddingLeft() Left cell margin/padding.
short | TAPAbstractType.getWCellPaddingOuterBottom() Default outer bottom cell margin/padding.
short | TAPAbstractType.getWCellPaddingOuterLeft() Default outer left cell margin/padding.
short | TAPAbstractType.getWCellPaddingOuterRight() Default outer right cell margin/padding.
short | TAPAbstractType.getWCellPaddingOuterTop() Default outer top cell margin/padding.
short | TCAbstractType.getWCellPaddingRight() Right cell margin/padding.
short | TCAbstractType.getWCellPaddingTop() Top cell margin/padding.
short | TCAbstractType.getWCellSpacingBottom() Bottom cell spacing.
short | TAPAbstractType.getWCellSpacingDefaultBottom() Default bottom cell spacings.
short | TAPAbstractType.getWCellSpacingDefaultLeft() Default left cell spacings.
short | TAPAbstractType.getWCellSpacingDefaultRight() Default right cell spacings.
short | TAPAbstractType.getWCellSpacingDefaultTop() Default top cell spacings.
short | TCAbstractType.getWCellSpacingLeft() Left cell spacing.
short | TAPAbstractType.getWCellSpacingOuterBottom() Default outer bottom cell spacing.
short | TAPAbstractType.getWCellSpacingOuterLeft() Default outer left cell spacing.
short | TAPAbstractType.getWCellSpacingOuterRight() Default outer right cell spacing.
short | TAPAbstractType.getWCellSpacingOuterTop() Default outer top cell spacing.
short | TCAbstractType.getWCellSpacingRight() Right cell spacing.
short | TCAbstractType.getWCellSpacingTop() Top cell spacing.
int | CHPAbstractType.getWCharScale() Get the wCharScale field for the CHP record.
int | CHPAbstractType.getWConflict() When != 0, index number that identifies all text participating in a particular conflict incident.
int | FibBaseAbstractType.getWIdent() An unsigned integer that specifies that this is a Word Binary File.
byte | TAPAbstractType.getWidthAndFitsFlags_empty1() Not used
short | TAPAbstractType.getWidthAndFitsFlags_empty2() Not used
int | TAPAbstractType.getWidthAndFitsFlags() Get the widthAndFitsFlags field for the TAP record.
byte | PAPAbstractType.getWr() Get the wr field for the PAP record.
byte | FSPAAbstractType.getWr() Text wrapping mode
byte | FSPAAbstractType.getWrk() Text wrapping mode type (valid only for wrapping modes 2 and 4
short | DOPAbstractType.getWScaleSaved()
int | DOPAbstractType.getWSpare() Get the wSpare field for the DOP record.
int | DOPAbstractType.getWSpare2() Get the wSpare2 field for the DOP record.
byte | DOPAbstractType.getWvkSaved()
short | TCAbstractType.getWWidth() Preferred cell width.
short | TAPAbstractType.getWWidth() Preferred table width.
short | TAPAbstractType.getWWidthAfter() Width of invisible cell (used for layout purposes) after the last visible cell in the row..
short | TAPAbstractType.getWWidthBefore() Width of invisible cell (used for layout purposes) before the first visible cell in the row..
short | TAPAbstractType.getWWidthIndent() Left Indent.
int | FSPAAbstractType.getXaLeft() Left of rectangle enclosing shape relative to the origin of the shape.
int | FSPAAbstractType.getXaRight() Right of rectangle enclosing shape relative to the origin of the shape.
int | CHPAbstractType.getXchSym() When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..
short | PICFAbstractType.getXExt() This field is unused and MUST be ignored.
byte[] | CHPAbstractType.getXstDispFldRMark() The string value of the ListNum field when revision mark tracking began.
int | FSPAAbstractType.getYaBottom() Bottom of the rectangle enclosing shape relative to the origin of the shape.
int | FSPAAbstractType.getYaTop() Top of rectangle enclosing shape relative to the origin of the shape.
short | PICFAbstractType.getYExt() This field is unused and MUST be ignored.
byte | DOPAbstractType.getZkSaved()
boolean | StdfBaseAbstractType.isF97LidsSet() Specifies whether sprmCRgLid0_80 and sprmCRgLid1_80 were applied, as appropriate, to this paragraph or character style for compatibility with applications that do not support sprmCRgLid0, sprmCRgLid1, and sprmCFNoProof
boolean | TAPAbstractType.isFAdjusted() Used internally by Word
boolean | FSPAAbstractType.isFAnchorLock()
boolean | TAPAbstractType.isFAutofit() When set to 1, AutoFit this table
boolean | DOPAbstractType.isFAutoHyphen()
boolean | LSTFAbstractType.isFAutoNum() A bit that specifies whether the list that this LSTF represents is used for the AUTONUMOUT, AUTONUMLGL, and AUTONUM fields (see AUTONUMOUT, AUTONUMLGL, and AUTONUM in flt)
boolean | StdfBaseAbstractType.isFAutoRedef() number of UPXs (and UPEs)
boolean | DOPAbstractType.isFAutoVersions()
boolean | DOPAbstractType.isFBackup()
boolean | TCAbstractType.isFBackward() For a vertical table cell, text flow is bottom to top when 1 and is bottom to top when 0
boolean | PAPAbstractType.isFBackward()
boolean | FSPAAbstractType.isFBelowText()
boolean | CHPAbstractType.isFBiDi() Complex Scripts right-to-left text that requires special processing to display and process (character reordering; contextual shaping; display of combining characters and diacritics; specialized justification rules; cursor positioning)
boolean | CHPAbstractType.isFBold() Text is bold
boolean | CHPAbstractType.isFBoldBi() Complex Scripts text is bold
boolean | CHPAbstractType.isFCaps() Displayed with caps
boolean | CHPAbstractType.isFCellFitText() Fit text in cell
boolean | TAPAbstractType.isFCellSpacing() Used internally by Word: When set to 1 cell spacing is allowed
boolean | CHPAbstractType.isFChsDiff() Pre-Unicode files, char's char set different from FIB char set
boolean | FibBaseAbstractType.isFComplex() Specifies that the last save operation that was performed on this document was an incremental save operation
boolean | CHPAbstractType.isFComplexScripts() Complex Scripts text that requires special processing to display and process
boolean | LVLFAbstractType.isFConverted() A bit that specifies whether the nfc of this LVLF structure was previously a temporary value used for bidirectional compatibility that was converted into a standard MSONFC
boolean | DOPAbstractType.isFConvMailMergeEsc()
boolean | StdfBaseAbstractType.isFCopyLang() If f97LidsSet is 1, this value specifies whether the applied compatibility sprmCRgLid0_80 or sprmCRgLid1_80 specified an actual language or a special LID value (0x0400) signifying that no proofing is needed for the text.
boolean | CHPAbstractType.isFData() chp.fcPic points to an FFDATA, the data structure binary data used by Word to describe a form field.
boolean | DOPAbstractType.isFDfltTrueType()
boolean | DOPAbstractType.isFDispFormFldSel()
boolean | FibBaseAbstractType.isFDot() Specifies whether this is a document template
boolean | CHPAbstractType.isFDStrike() Displayed with double strikethrough
boolean | DOPAbstractType.isFEmbedFonts()
boolean | CHPAbstractType.isFEmboss() Text is embossed
boolean | FibBaseAbstractType.isFEmptySpecial() Deprecated. This field should not be used according to specification
boolean | FibBaseAbstractType.isFEncrypted() Specifies whether the document is encrypted or obfuscated as specified in Encryption and Obfuscation
boolean | DOPAbstractType.isFExactCWords()
boolean | FibBaseAbstractType.isFExtChar() This value MUST be 1
boolean | DOPAbstractType.isFFacingPages()
boolean | FibBaseAbstractType.isFFarEast() Specifies whether the installation language of the application that created the document was an East Asian language
boolean | TCAbstractType.isFFirstMerged() When 1, cell is first cell of a range of cells that have been merged.
boolean | TAPAbstractType.isFFirstRow() Used internally by Word: first row
boolean | TCAbstractType.isFFitText() When 1, make the text fit the table cell
boolean | CHPAbstractType.isFFldVanish() Used internally by Word
boolean | DOPAbstractType.isFForcePageSizePag()
boolean | LFOLVLBaseAbstractType.isFFormatting() A bit that specifies whether lvl is an LVL that overrides the corresponding LVL
boolean | DOPAbstractType.isFFormNoFields()
boolean | FibBaseAbstractType.isFGlsy() Specifies whether this is a document that contains only AutoText items
boolean | DOPAbstractType.isFGramAllClean()
boolean | DOPAbstractType.isFGramAllDone()
boolean | StshifAbstractType.isFHasOriginalStyle() This value MUST be 1 and MUST be ignored
boolean | StdfPost2000AbstractType.isFHasOriginalStyle() Specifies whether the style is revision-marked.
boolean | FibBaseAbstractType.isFHasPic() When set to 0, there SHOULD be no pictures in the document
boolean | StdfBaseAbstractType.isFHasUpe() This bit is undefined and MUST be ignored
boolean | DOPAbstractType.isFHaveVersions()
boolean | FSPAAbstractType.isFHdr() 1 in the undo doc when shape is from the header doc, 0 otherwise (undefined when not in the undo doc)
boolean | StdfBaseAbstractType.isFHidden() Specifies whether this style is not shown in the application UI
boolean | DOPAbstractType.isFHideLastVersion()
boolean | CHPAbstractType.isFHighlight() When 1, characters are highlighted with color specified by chp.icoHighlight
boolean | GrfhicAbstractType.isFHtmlBuiltInBullet() A built-in HTML bullet
boolean | GrfhicAbstractType.isFHtmlChecked() Checked
boolean | DOPAbstractType.isFHtmlDoc()
boolean | GrfhicAbstractType.isFHtmlFirstLineMismatch() First line indent mismatch
boolean | GrfhicAbstractType.isFHtmlHangingIndentBeneathNumber() The hanging indent falls beneath the number (need plain text)
boolean | GrfhicAbstractType.isFHtmlListTextNotSharpDot() The list text is not "#."
boolean | GrfhicAbstractType.isFHtmlNotPeriod() Something other than a period is used
boolean | GrfhicAbstractType.isFHtmlTabLeftIndentMismatch() The list tab and the dxaLeft don't match (need table?)
boolean | GrfhicAbstractType.isFHtmlUnsupported() The numbering sequence or format is unsupported (includes tab & size)
boolean | LSTFAbstractType.isFHybrid() A bit that specifies whether the list this LSTF defines is a hybrid list
boolean | DOPAbstractType.isFHyphCapitals()
boolean | CHPAbstractType.isFImprint() Text is engraved
boolean | DOPAbstractType.isFIncludeFooter()
boolean | DOPAbstractType.isFIncludeHeader()
boolean | LVLFAbstractType.isFIndentSav() A bit that specifies whether the level indented the text it was applied to and that the indent needs to be removed when numbering is removed.
boolean | StdfBaseAbstractType.isFInternalUse() This bit is undefined and MUST be ignored
boolean | TAPAbstractType.isFInvalAutofit() When 1, TAP is still valid, but autofit properties aren't
boolean | StdfBaseAbstractType.isFInvalHeight() Specifies whether the paragraph height information in the fcPlcfPhe field of FibRgFcLcb97, for any paragraphs having this paragraph style, MUST be ignored.
boolean | CHPAbstractType.isFItalic() Italic
boolean | CHPAbstractType.isFItalicBi() Complex Scripts text is italics
boolean | TAPAbstractType.isFKeepFollow() When set to 1, keep this row with the following row
boolean | CHPAbstractType.isFKumimoji() combine characters
boolean | DOPAbstractType.isFLabelDoc()
boolean | TAPAbstractType.isFLastRow() Used internally by Word: last row
boolean | LVLFAbstractType.isFLegal() A bit that specifies whether this level overrides the nfc of all inherited level numbers.
boolean | DOPAbstractType.isFLinkStyles()
boolean | FibBaseAbstractType.isFLoadOverride() Specifies whether to override the language information and font that are specified in the paragraph style at istd 0 (the normal style) with the defaults that are appropriate for the installation language of the application
boolean | FibBaseAbstractType.isFLoadOverridePage() Specifies whether to override the section properties for page size, orientation, and margins with the defaults that are appropriate for the installation language of the application
boolean | DOPAbstractType.isFLockAtn()
boolean | StdfBaseAbstractType.isFLocked() Specifies whether this style is prevented from being applied by using the application UI
boolean | DOPAbstractType.isFLockRev()
boolean | CHPAbstractType.isFLowerCase() Character is displayed in lower case.
boolean | CHPAbstractType.isFLSFitText() fit text
boolean | FibBaseAbstractType.isFMac() Deprecated. This field should not be used according to specification
boolean | CHPAbstractType.isFMacChs() fTrue if char's are Macintosh char set
boolean | DOPAbstractType.isFMapPrintTextColor()
boolean | StdfBaseAbstractType.isFMassCopy() This bit is undefined and MUST be ignored
boolean | TCAbstractType.isFMerged() When 1, cell has been merged with preceding cell
boolean | DOPAbstractType.isFMinFontSizePag()
boolean | DOPAbstractType.isFMirrorMargins()
boolean | DOPAbstractType.isFMWSmallCaps()
boolean | TAPAbstractType.isFNeverBeenAutofit() When 1, table has never been autofit
boolean | DOPAbstractType.isFNoColumnBalance()
boolean | StdfBaseAbstractType.isFNoHtmlExport() This value MUST be 0 and MUST be ignored
boolean | DOPAbstractType.isFNoLeading()
boolean | LVLFAbstractType.isFNoRestart() A bit that specifies whether the number sequence of the level does not restart after a level is encountered that is more significant than the level to which this LVLF corresponds
boolean | DOPAbstractType.isFNoSpaceRaiseLower()
boolean | DOPAbstractType.isFNoTabForInd()
boolean | TAPAbstractType.isFNotPageView() Used internally by Word: when set to 1 we are not in Page View
boolean | TCAbstractType.isFNoWrap() When 1, do not allow text to wrap in the table cell
boolean | FibBaseAbstractType.isFObfuscated() If fEncrypted is 1, this bit specifies whether the document is obfuscated by using XOR obfuscation; otherwise, this bit MUST be ignored
boolean | CHPAbstractType.isFObj() Embedded objec
boolean | CHPAbstractType.isFOle2() chp.lTagObj specifies a particular object in the object stream that specifies the particular OLE object in the stream that should be displayed when the chPicture fSpec character that is tagged with the fOle2 is encountered.
boolean | DOPAbstractType.isFOnlyMacPics()
boolean | DOPAbstractType.isFOnlyWinPics()
boolean | TAPAbstractType.isFOrigWordTableRules() Used internally by Word: table combining like Word 5.x for the Macintosh and WinWord 1.x
boolean | DOPAbstractType.isFOrigWordTableRules()
boolean | TAPAbstractType.isFOutline() Used internally by Word: row was cached for outline mode
boolean | CHPAbstractType.isFOutline() Outlined
boolean | DOPAbstractType.isFPagHidden()
boolean | DOPAbstractType.isFPagResults()
boolean | DOPAbstractType.isFPagSupressTopSpacing()
boolean | StdfBaseAbstractType.isFPersonal() Specifies whether this character style was applied to format all message text from one or more users in an e-mail
boolean | StdfBaseAbstractType.isFPersonalCompose() Specifies whether this character style can be used to automatically format the new message text in a new e-mail
boolean | StdfBaseAbstractType.isFPersonalReply() Specifies whether this character style can be used to automatically format the new message text when replying to an e-mail
boolean | DOPAbstractType.isFPMHMainDoc()
boolean | DOPAbstractType.isFPrintBodyBeforeHdr()
boolean | DOPAbstractType.isFPrintFormData()
boolean | DOPAbstractType.isFProtEnabled()
boolean | StdfBaseAbstractType.isFQFormat() Specifies whether this style is shown in the Ribbon Style gallery
boolean | FSPAAbstractType.isFRcaSimple() When set, temporarily overrides bx, by, forcing the xaLeft, xaRight, yaTop, and yaBottom fields to all be page relative.
boolean | FibBaseAbstractType.isFReadOnlyRecommended() Specifies whether the document author recommended that the document be opened in read-only mode
boolean | DOPAbstractType.isFRevMarking()
boolean | CHPAbstractType.isFRMark() text is newly typed since the last time revision marks have been accepted and will be displayed with an underline when revision marked text is to be displayed
boolean | CHPAbstractType.isFRMarkDel() has been deleted and will be displayed with strikethrough when revision marked text is to be displayed
boolean | DOPAbstractType.isFRMPrint()
boolean | DOPAbstractType.isFRMView()
boolean | TCAbstractType.isFRotateFont() When 1, cell has rotated characters (i.e.
boolean | PAPAbstractType.isFRotateFont()
boolean | DOPAbstractType.isFRotateFontW6()
boolean | CHPAbstractType.isFRuby() Phonetic guide
boolean | DOPAbstractType.isFSaveFormData()
boolean | StdfBaseAbstractType.isFScratch() spare field for any temporary use, always reset back to zero!
boolean | StdfBaseAbstractType.isFSemiHidden() Specifies whether this style is not shown in the simplified main styles UI of the application
boolean | DOPAbstractType.isFShadeFormData()
boolean | CHPAbstractType.isFShadow() Character is drawn with a shadow
boolean | DOPAbstractType.isFShowBreaksInFrames()
boolean | LSTFAbstractType.isFSimpleList() A bit that, when set to 0x1, specifies that this LSTF represents a simple (one-level) list that has one corresponding LVL (see the fcPlfLst field of FibRgFcLcb97).
boolean | CHPAbstractType.isFSmallCaps() Displayed with small caps
boolean | DOPAbstractType.isFSnapBorder()
boolean | CHPAbstractType.isFSpec() Character is a Word special character
boolean | LFOLVLBaseAbstractType.isFStartAt() A bit that specifies whether this LFOLVL overrides the start-at value of the level.
boolean | CHPAbstractType.isFStrike() Displayed with strikethrough
boolean | DOPAbstractType.isFSubsetFonts()
boolean | DOPAbstractType.isFSuppressTopSPacingMac5()
boolean | DOPAbstractType.isFSupressSpdfAfterPageBreak()
boolean | DOPAbstractType.isFSupressTopSpacing()
boolean | DOPAbstractType.isFSwapBordersFacingPgs()
boolean | LVLFAbstractType.isFTentative() A bit that specifies whether the format of the level is tentative
boolean | CHPAbstractType.isFTNY() Tatenakayoko: Horizontal-in-vertical (range of text in a direction perpendicular to the text flow) is used
boolean | CHPAbstractType.isFTNYCompress() fit text in line
boolean | CHPAbstractType.isFTNYFetchTxm() fetch text metrics
boolean | DOPAbstractType.isFTransparentMetafiles()
boolean | DOPAbstractType.isFTruncDxaExpand()
boolean | StdfBaseAbstractType.isFUnhideWhenUsed() Specifies whether the fSemiHidden property is to be set to 0 when this style is used
boolean | CHPAbstractType.isFUsePgsuSettings() Used internally by Word
boolean | CHPAbstractType.isFVanish() text has hidden format, and is not displayed unless fPagHidden is set in the DOP
boolean | TAPAbstractType.isFVert() When 1, positioned in vertical text flow
boolean | TCAbstractType.isFVertical() When 1, cell has vertical text flow
boolean | PAPAbstractType.isFVertical()
boolean | TCAbstractType.isFVertMerge() When 1, cell is vertically merged with the cell(s) above and/or below.
boolean | TCAbstractType.isFVertRestart() When 1, the cell is the first of a set of vertically merged cells.
boolean | DOPAbstractType.isFVirusLoadSafe()
boolean | DOPAbstractType.isFVirusPrompted()
boolean | CHPAbstractType.isFWarichu() Two lines in one (text in the group is displayed as two half-height lines within a line)
boolean | CHPAbstractType.isFWarichuNoOpenBracket() Two-lines-in-one uses no open
boolean | DOPAbstractType.isFWCFtnEdn()
boolean | TAPAbstractType.isFWebView() Used internally by Word: Web View is on when set to 1
boolean | FibBaseAbstractType.isFWhichTblStm() Specifies the Table stream to which the FIB refers.
boolean | DOPAbstractType.isFWidowControl()
boolean | TAPAbstractType.isFWrapToWwd() Used internally by Word: Wrap to window is on when set to 1
boolean | DOPAbstractType.isFWrapTrailSpaces()
boolean | FibBaseAbstractType.isFWriteReservation() Specifies whether the document has a write-reservation password
boolean | DOPAbstractType.isIGutterPos()
boolean | DOPAbstractType.isOldfConvMailMergeEsc()
boolean | DOPAbstractType.isOldfMapPrintTextColor()
boolean | DOPAbstractType.isOldfNoColumnBalance()
boolean | DOPAbstractType.isOldfNoSpaceRaiseLower()
boolean | DOPAbstractType.isOldfNoTabForInd()
boolean | DOPAbstractType.isOldfOrigWordTableRules()
boolean | DOPAbstractType.isOldfShowBreaksInFrames()
boolean | DOPAbstractType.isOldfSuppressSpbfAfterPageBreak()
boolean | DOPAbstractType.isOldfSupressTopSpacing()
boolean | DOPAbstractType.isOldfSwapBordersFacingPgs()
boolean | DOPAbstractType.isOldfTransparentMetafiles()
boolean | DOPAbstractType.isOldfWrapTrailSpaces()
boolean | FibBaseAbstractType.isReserved1() Deprecated. This field should not be used according to specification
boolean | FibBaseAbstractType.isReserved2() Deprecated. This field should not be used according to specification
boolean | StdfPost2000AbstractType.isUnused() This value MUST be zero and MUST be ignored
boolean | CHPAbstractType.isUnused() Not used
boolean | LVLFAbstractType.isUnused1() Deprecated. This field should not be used according to specification
boolean | LSTFAbstractType.isUnused1() Deprecated. This field should not be used according to specification
boolean | DOPAbstractType.isUnused1()
boolean | LSTFAbstractType.isUnused2() Deprecated. This field should not be used according to specification
boolean | DOPAbstractType.isUnused3()
boolean | DOPAbstractType.isUnused4()
boolean | TAPAbstractType.isViewFlags_unused1() Not used
void | DOPAbstractType.setAdt(short field_34_adt) Set the adt field for the DOP record.
void | PAPAbstractType.setAnld(byte[] field_67_anld) Set the anld field for the PAP record.
void | DOPAbstractType.setAsumyi(byte[] field_39_asumyi) Set the asumyi field for the DOP record.
void | StdfBaseAbstractType.setBchUpe(int field_4_bchUpe) An unsigned integer that specifies the size, in bytes, of std in LPStd.
void | PICFAbstractType.setBpp(byte field_20_bpp) Set the bpp field for the PICF record.
void | CHPAbstractType.setBrc(BorderCode field_24_brc) Border.
void | PAPAbstractType.setBrcBar(BorderCode field_65_brcBar) Set the brcBar field for the PAP record.
void | PAPAbstractType.setBrcBetween(BorderCode field_64_brcBetween) Set the brcBetween field for the PAP record.
void | TCAbstractType.setBrcBottom(BorderCode field_22_brcBottom) Bottom border.
void | TAPAbstractType.setBrcBottom(BorderCode field_36_brcBottom) Set the brcBottom field for the TAP record.
void | PAPAbstractType.setBrcBottom(BorderCode field_62_brcBottom) Set the brcBottom field for the PAP record.
void | PICFAbstractType.setBrcBottom80(byte[] field_23_brcBottom80) Set the brcBottom80 field for the PICF record.
void | TAPAbstractType.setBrcHorizontal(BorderCode field_41_brcHorizontal) Set the brcHorizontal field for the TAP record.
void | PAPAbstractType.setBrcl(byte field_6_brcl) Border line style.
void | TCAbstractType.setBrcLeft(BorderCode field_21_brcLeft) Left border.
void | TAPAbstractType.setBrcLeft(BorderCode field_38_brcLeft) Set the brcLeft field for the TAP record.
void | PAPAbstractType.setBrcLeft(BorderCode field_61_brcLeft) Set the brcLeft field for the PAP record.
void | PICFAbstractType.setBrcLeft80(byte[] field_22_brcLeft80) Set the brcLeft80 field for the PICF record.
void | PAPAbstractType.setBrcp(byte field_7_brcp) Rectangle border codes.
void | TCAbstractType.setBrcRight(BorderCode field_23_brcRight) Right border.
void | TAPAbstractType.setBrcRight(BorderCode field_39_brcRight) Set the brcRight field for the TAP record.
void | PAPAbstractType.setBrcRight(BorderCode field_63_brcRight) Set the brcRight field for the PAP record.
void | PICFAbstractType.setBrcRight80(byte[] field_24_brcRight80) Set the brcRight80 field for the PICF record.
void | TCAbstractType.setBrcTop(BorderCode field_20_brcTop) Top border.
void | TAPAbstractType.setBrcTop(BorderCode field_37_brcTop) Set the brcTop field for the TAP record.
void | PAPAbstractType.setBrcTop(BorderCode field_60_brcTop) Set the brcTop field for the PAP record.
void | PICFAbstractType.setBrcTop80(byte[] field_21_brcTop80) Set the brcTop80 field for the PICF record.
void | TAPAbstractType.setBrcVertical(BorderCode field_40_brcVertical) Set the brcVertical field for the TAP record.
void | FSPAAbstractType.setBx(byte value) Sets the bx field value.
void | FSPAAbstractType.setBy(byte value) Sets the by field value.
void | LVLFAbstractType.setCbGrpprlChpx(short field_8_cbGrpprlChpx) An unsigned integer that specifies the size, in bytes, of the grpprlChpx in the LVL that contains this LVLF.
void | LVLFAbstractType.setCbGrpprlPapx(short field_9_cbGrpprlPapx) An unsigned integer that specifies the size, in bytes, of the grpprlPapx in the LVL that contains this LVLF.
void | PICFAbstractType.setCbHeader(int field_2_cbHeader) An unsigned integer that specifies the size, in bytes, of this PICF structure.
void | FibRgLw97AbstractType.setCbMac(int field_1_cbMac) Specifies the count of bytes of those written to the WordDocument stream of the file that have any meaning.
void | FibRgLw95AbstractType.setCbMac(int field_1_cbMac) Set the cbMac field for the FibRgLw95 record.
void | StshifAbstractType.setCbSTDBaseInFile(int field_2_cbSTDBaseInFile) An unsigned integer that specifies the size, in bytes, of the Stdf structure.
void | DOPAbstractType.setCCh(int field_20_cCh) Set the cCh field for the DOP record.
void | DOPAbstractType.setCChFtnEdn(int field_27_cChFtnEdn) Set the cChFtnEdn field for the DOP record.
void | DOPAbstractType.setCChWS(int field_40_cChWS) Set the cChWS field for the DOP record.
void | DOPAbstractType.setCChWSFtnEdn(int field_41_cChWSFtnEdn) Set the cChWSFtnEdn field for the DOP record.
void | DOPAbstractType.setCConsexHypLim(int field_12_cConsexHypLim) Set the cConsexHypLim field for the DOP record.
void | FibRgLw97AbstractType.setCcpAtn(int field_8_ccpAtn) A signed integer that specifies the count of CPs in the comment subdocument.
void | FibRgLw95AbstractType.setCcpAtn(int field_10_ccpAtn) Set the ccpAtn field for the FibRgLw95 record.
void | FibRgLw97AbstractType.setCcpEdn(int field_9_ccpEdn) A signed integer that specifies the count of CPs in the endnote subdocument.
void | FibRgLw95AbstractType.setCcpEdn(int field_11_ccpEdn) Set the ccpEdn field for the FibRgLw95 record.
void | FibRgLw97AbstractType.setCcpFtn(int field_5_ccpFtn) A signed integer that specifies the count of CPs in the footnote subdocument.
void | FibRgLw95AbstractType.setCcpFtn(int field_7_ccpFtn) Set the ccpFtn field for the FibRgLw95 record.
void | FibRgLw97AbstractType.setCcpHdd(int field_6_ccpHdd) A signed integer that specifies the count of CPs in the header subdocument.
void | FibRgLw95AbstractType.setCcpHdd(int field_8_ccpHdd) Set the ccpHdd field for the FibRgLw95 record.
void | FibRgLw97AbstractType.setCcpHdrTxbx(int field_11_ccpHdrTxbx) A signed integer that specifies the count of CPs in the textbox subdocument of the header.
void | FibRgLw95AbstractType.setCcpHdrTxbx(int field_13_ccpHdrTxbx) Set the ccpHdrTxbx field for the FibRgLw95 record.
void | FibRgLw95AbstractType.setCcpMcr(int field_9_ccpMcr) Set the ccpMcr field for the FibRgLw95 record.
void | FibRgLw97AbstractType.setCcpText(int field_4_ccpText) A signed integer that specifies the count of CPs in the main document.
void | FibRgLw95AbstractType.setCcpText(int field_6_ccpText) Set the ccpText field for the FibRgLw95 record.
void | FibRgLw97AbstractType.setCcpTxbx(int field_10_ccpTxbx) A signed integer that specifies the count of CPs in the textbox subdocument of the main document.
void | FibRgLw95AbstractType.setCcpTxbx(int field_12_ccpTxbx) Set the ccpTxbx field for the FibRgLw95 record.
void | DOPAbstractType.setCDBC(int field_47_cDBC) Set the cDBC field for the DOP record.
void | DOPAbstractType.setCDBCFtnEdn(int field_48_cDBCFtnEdn) Set the cDBCFtnEdn field for the DOP record.
void | CHPAbstractType.setCharsetFlags(short field_49_CharsetFlags) Set the CharsetFlags field for the CHP record.
void | TAPAbstractType.setCHorzBands(short field_78_cHorzBands) Size of each horizontal style band, in number of rows.
void | FibBaseAbstractType.setChs(short field_11_Chs) This value MUST be 0 and MUST be ignored.
void | CHPAbstractType.setChse(short field_50_chse) Set the chse field for the CHP record.
void | FibBaseAbstractType.setChsTables(short field_12_chsTables) This value MUST be 0 and MUST be ignored.
void | LFOAbstractType.setClfolvl(byte field_4_clfolvl) Count of levels whose format is overridden (see LFOLVL).
void | DOPAbstractType.setCLines(int field_25_cLines) Set the cLines field for the DOP record.
void | DOPAbstractType.setCLinesFtnEdn(int field_30_cLinesFtnEdn) Set the cLinesFtnEdn field for the DOP record.
void | CHPAbstractType.setCopt(byte field_30_copt) Collection of the 5 flags.
void | DOPAbstractType.setCParas(int field_22_cParas) Set the cParas field for the DOP record.
void | DOPAbstractType.setCParasFtnEdn(int field_29_cParasFtnEdn) Set the cParasFtnEdn field for the DOP record.
void | CHPAbstractType.setCpg(int field_47_cpg) Code page of run in pre-Unicode files.
void | DOPAbstractType.setCPg(int field_21_cPg) Set the cPg field for the DOP record.
void | DOPAbstractType.setCPgFtnEdn(short field_28_cPgFtnEdn) Set the cPgFtnEdn field for the DOP record.
void | PICFAbstractType.setCProps(short field_27_cProps) This value MUST be 0 and MUST be ignored.
void | FibBaseAbstractType.setCQuickSaves(byte value) Sets the cQuickSaves field value.
void | StshifAbstractType.setCstd(int field_1_cstd) An unsigned integer that specifies the count of elements in STSH.rglpstd.
void | FSPAAbstractType.setCTxbx(int field_7_cTxbx) Count of textboxes in shape (undo doc only).
void | StdfBaseAbstractType.setCupx(byte value) Sets the cupx field value.
void | CHPAbstractType.setCv(Colorref field_8_cv) 24-bit color.
void | SHDAbstractType.setCvBack(Colorref field_2_cvBack) 24-bit background color.
void | TAPAbstractType.setCVertBands(short field_79_cVertBands) Size of a vertical style band, in number of columns.
void | SHDAbstractType.setCvFore(Colorref field_1_cvFore) 24-bit foreground color.
void | DOPAbstractType.setCWords(int field_19_cWords) Set the cWords field for the DOP record.
void | DOPAbstractType.setCWordsFtnEnd(int field_26_cWordsFtnEnd) Set the cWordsFtnEnd field for the DOP record.
void | PAPAbstractType.setDcs(DropCapSpecifier field_28_dcs) Set the dcs field for the PAP record.
void | DOPAbstractType.setDocinfo(byte field_5_docinfo) Set the docinfo field for the DOP record.
void | DOPAbstractType.setDocinfo1(byte field_6_docinfo1) Set the docinfo1 field for the DOP record.
void | DOPAbstractType.setDocinfo2(byte field_7_docinfo2) Set the docinfo2 field for the DOP record.
void | DOPAbstractType.setDocinfo3(short field_8_docinfo3) Set the docinfo3 field for the DOP record.
void | DOPAbstractType.setDocinfo4(int field_33_docinfo4) Set the docinfo4 field for the DOP record.
void | DOPAbstractType.setDocinfo5(short field_37_docinfo5) Set the docinfo5 field for the DOP record.
void | DOPAbstractType.setDocinfo6(short field_38_docinfo6) Set the docinfo6 field for the DOP record.
void | DOPAbstractType.setDogrid(byte[] field_36_dogrid) Set the dogrid field for the DOP record.
void | DOPAbstractType.setDoptypography(byte[] field_35_doptypography) Set the doptypography field for the DOP record.
void | CHPAbstractType.setDttmConflict(DateAndTime field_58_dttmConflict) When the change was made.
void | DOPAbstractType.setDttmCreated(int field_14_dttmCreated) Set the dttmCreated field for the DOP record.
void | CHPAbstractType.setDttmDispFldRMark(DateAndTime field_61_dttmDispFldRMark) The date for the ListNum field number change.
void | DOPAbstractType.setDttmLastPrint(int field_16_dttmLastPrint) Set the dttmLastPrint field for the DOP record.
void | PAPAbstractType.setDttmPropRMark(DateAndTime field_71_dttmPropRMark) Set the dttmPropRMark field for the PAP record.
void | CHPAbstractType.setDttmPropRMark(DateAndTime field_53_dttmPropRMark) Date/time at which properties of this were changed for this run of text by the author.
void | DOPAbstractType.setDttmRevised(int field_15_dttmRevised) Set the dttmRevised field for the DOP record.
void | CHPAbstractType.setDttmRMark(DateAndTime field_42_dttmRMark) Date/time at which this run of text was entered/modified by the author (Only recorded when revision marking is on.).
void | CHPAbstractType.setDttmRMarkDel(DateAndTime field_43_dttmRMarkDel) Date/time at which this run of text was deleted by the author (Only recorded when revision marking is on.).
void | TAPAbstractType.setDxaAbs(int field_14_dxaAbs) Absolute horizontal position.
void | PAPAbstractType.setDxaAbs(int field_17_dxaAbs) Set the dxaAbs field for the PAP record.
void | TAPAbstractType.setDxaAdjust(int field_27_dxaAdjust) Used internally by Word.
void | TAPAbstractType.setDxaColWidthWwd(int field_30_dxaColWidthWwd) Used internally by Word.
void | TAPAbstractType.setDxaFromText(int field_16_dxaFromText) Left distance from surrounding text when absolutely positioned.
void | PAPAbstractType.setDxaFromText(int field_30_dxaFromText) Horizontal distance between text and absolutely positioned object.
void | TAPAbstractType.setDxaFromTextRight(int field_18_dxaFromTextRight) Right distance from surrounding text when absolutely positioned.
void | TAPAbstractType.setDxaGapHalf(int field_3_dxaGapHalf) Measures half of the white space that will be maintained between text in adjacent columns of a table row.
void | PICFAbstractType.setDxaGoal(short field_11_dxaGoal) Set the dxaGoal field for the PICF record.
void | DOPAbstractType.setDxaHotz(int field_11_dxaHotz) Set the dxaHotz field for the DOP record.
void | LVLFAbstractType.setDxaIndentSav(int field_6_dxaIndentSav) If fIndentSav is nonzero, this is a signed integer that specifies the size, in twips, of the indent that needs to be removed when the numbering is removed.
void | PAPAbstractType.setDxaLeft(int field_57_dxaLeft) Set the dxaLeft field for the PAP record.
void | PAPAbstractType.setDxaLeft1(int field_58_dxaLeft1) Set the dxaLeft1 field for the PAP record.
void | PICFAbstractType.setDxaReserved1(short field_15_dxaReserved1) Set the dxaReserved1 field for the PICF record.
void | PICFAbstractType.setDxaReserved2(short field_17_dxaReserved2) Set the dxaReserved2 field for the PICF record.
void | PICFAbstractType.setDxaReserved3(short field_25_dxaReserved3) Set the dxaReserved3 field for the PICF record.
void | PAPAbstractType.setDxaRight(int field_56_dxaRight) Set the dxaRight field for the PAP record.
void | TAPAbstractType.setDxaRTEWrapWidth(int field_29_dxaRTEWrapWidth) Used internally by Word.
void | CHPAbstractType.setDxaSpace(int field_7_dxaSpace) Space following each character in the run expressed in twip units..
void | DOPAbstractType.setDxaTab(int field_9_dxaTab) Set the dxaTab field for the DOP record.
void | TAPAbstractType.setDxaWebView(int field_28_dxaWebView) Used internally by Word.
void | PAPAbstractType.setDxaWidth(int field_19_dxaWidth) Set the dxaWidth field for the PAP record.
void | PAPAbstractType.setDxcLeft(short field_52_dxcLeft) Left indent in character units.
void | PAPAbstractType.setDxcLeft1(short field_53_dxcLeft1) First line indent in character units.
void | PAPAbstractType.setDxcRight(short field_51_dxcRight) Right indent in character units.
void | TAPAbstractType.setDyaAbs(int field_15_dyaAbs) Absolute vertical position.
void | PAPAbstractType.setDyaAbs(int field_18_dyaAbs) Set the dyaAbs field for the PAP record.
void | PAPAbstractType.setDyaAfter(int field_13_dyaAfter) Space after paragraph.
void | PAPAbstractType.setDyaBefore(int field_12_dyaBefore) Space before paragraph.
void | TAPAbstractType.setDyaFromText(int field_17_dyaFromText) Top distance from surrounding text when absolutely positioned.
void | PAPAbstractType.setDyaFromText(int field_29_dyaFromText) Vertical distance between text and absolutely positioned object.
void | TAPAbstractType.setDyaFromTextBottom(int field_19_dyaFromTextBottom) Bottom distance from surrounding text when absolutely positioned.
void | PICFAbstractType.setDyaGoal(short field_12_dyaGoal) Set the dyaGoal field for the PICF record.
void | PAPAbstractType.setDyaHeight(int field_26_dyaHeight) Set the dyaHeight field for the PAP record.
void | PICFAbstractType.setDyaReserved1(short field_16_dyaReserved1) Set the dyaReserved1 field for the PICF record.
void | PICFAbstractType.setDyaReserved2(short field_18_dyaReserved2) Set the dyaReserved2 field for the PICF record.
void | PICFAbstractType.setDyaReserved3(short field_26_dyaReserved3) Set the dyaReserved3 field for the PICF record.
void | TAPAbstractType.setDyaRowHeight(int field_4_dyaRowHeight) When greater than 0, guarantees that the height of the table will be at least dyaRowHeight high.
void | DOPAbstractType.setDywDispPag(short field_53_dywDispPag) Set the dywDispPag field for the DOP record.
void | DOPAbstractType.setEdn(short field_23_Edn) Set the Edn field for the DOP record.
void | DOPAbstractType.setEdn1(short field_24_Edn1) Set the Edn1 field for the DOP record.
void | FibBaseAbstractType.setEnvr(byte field_9_envr) This value MUST be 0, and MUST be ignored.
void | DOPAbstractType.setEpc(byte value) Sets the epc field value.
void | StdfBaseAbstractType.setF97LidsSet(boolean value) Sets the f97LidsSet field value.
void | TAPAbstractType.setFAdjusted(boolean value) Sets the fAdjusted field value.
void | PAPAbstractType.setFAdjustRight(boolean field_46_fAdjustRight) Set the fAdjustRight field for the PAP record.
void | FSPAAbstractType.setFAnchorLock(boolean value) Sets the fAnchorLock field value.
void | TAPAbstractType.setFAutofit(boolean value) Sets the fAutofit field value.
void | DOPAbstractType.setFAutoHyphen(boolean value) Sets the fAutoHyphen field value.
void | LSTFAbstractType.setFAutoNum(boolean value) Sets the fAutoNum field value.
void | StdfBaseAbstractType.setFAutoRedef(boolean value) Sets the fAutoRedef field value.
void | PAPAbstractType.setFAutoSpaceDE(boolean field_37_fAutoSpaceDE) auto space East Asian and alphabetic characters.
void | PAPAbstractType.setFAutoSpaceDN(boolean field_38_fAutoSpaceDN) auto space East Asian and numeric characters.
void | DOPAbstractType.setFAutoVersions(boolean value) Sets the fAutoVersions field value.
void | DOPAbstractType.setFBackup(boolean value) Sets the fBackup field value.
void | TCAbstractType.setFBackward(boolean value) Sets the fBackward field value.
void | PAPAbstractType.setFBackward(boolean value) Sets the fBackward field value.
void | FSPAAbstractType.setFBelowText(boolean value) Sets the fBelowText field value.
void | PAPAbstractType.setFBiDi(boolean field_42_fBiDi) Set the fBiDi field for the PAP record.
void | CHPAbstractType.setFBiDi(boolean value) Sets the fBiDi field value.
void | TAPAbstractType.setFBiDi(byte field_20_fBiDi) When 1, table is right-to-left.
void | CHPAbstractType.setFBold(boolean value) Sets the fBold field value.
void | CHPAbstractType.setFBoldBi(boolean value) Sets the fBoldBi field value.
void | CHPAbstractType.setFBorderWS(boolean field_28_fBorderWS) Used internally by Word.
void | PAPAbstractType.setFBrLnAbove(boolean field_20_fBrLnAbove) Set the fBrLnAbove field for the PAP record.
void | PAPAbstractType.setFBrLnBelow(boolean field_21_fBrLnBelow) Set the fBrLnBelow field for the PAP record.
void | TAPAbstractType.setFCantSplit(boolean field_5_fCantSplit) When 1, table row may not be split across page bounds.
void | TAPAbstractType.setFCantSplit90(boolean field_6_fCantSplit90) When 1, table row may not be split across page bounds.
void | CHPAbstractType.setFCaps(boolean value) Sets the fCaps field value.
void | CHPAbstractType.setFcData(int field_39_fcData) Points to location of picture data, only if chp.fSpec is true..
void | CHPAbstractType.setFCellFitText(boolean value) Sets the fCellFitText field value.
void | TAPAbstractType.setFCellSpacing(boolean value) Sets the fCellSpacing field value.
void | CHPAbstractType.setFChsDiff(boolean value) Sets the fChsDiff field value.
void | FibBaseAbstractType.setFcMac(int field_14_fcMac) This value is undefined and MUST be ignored.
void | FibBaseAbstractType.setFcMin(int field_13_fcMin) This value is undefined and MUST be ignored.
void | CHPAbstractType.setFcObj(int field_37_fcObj) Offset in data stream pointing to beginning of a picture when character is an OLE1 object character (character is 0x20 and chp.fSpec is 1, chp.fOle2 is 0)..
void | CHPAbstractType.setFcObjp(int field_63_fcObjp) Offset in the data stream indicating the location of OLE object data.
void | FibBaseAbstractType.setFComplex(boolean value) Sets the fComplex field value.
void | CHPAbstractType.setFComplexScripts(boolean value) Sets the fComplexScripts field value.
void | CHPAbstractType.setFConflictOrig(boolean field_54_fConflictOrig) When chp.wConflict!=0, this is TRUE when text is part of the original version of text.
void | CHPAbstractType.setFConflictOtherDel(boolean field_55_fConflictOtherDel) When fConflictOtherDel==fTrue, the other side of a reconciliation conflict causes this text to be deleted.
void | LVLFAbstractType.setFConverted(boolean value) Sets the fConverted field value.
void | DOPAbstractType.setFConvMailMergeEsc(boolean value) Sets the fConvMailMergeEsc field value.
void | StdfBaseAbstractType.setFCopyLang(boolean value) Sets the fCopyLang field value.
void | CHPAbstractType.setFcPic(int field_36_fcPic) Offset in data stream pointing to beginning of a picture when character is a picture character (character is 0x01 and chp.fSpec is 1)..
void | PAPAbstractType.setFCrLf(boolean field_44_fCrLf) Set the fCrLf field for the PAP record.
void | CHPAbstractType.setFData(boolean value) Sets the fData field value.
void | CHPAbstractType.setFDblBdr(boolean field_27_fDblBdr) Used internally by Word.
void | DOPAbstractType.setFDfltTrueType(boolean value) Sets the fDfltTrueType field value.
void | CHPAbstractType.setFDispFldRMark(boolean field_59_fDispFldRMark) the number for a ListNum field is being tracked in xstDispFldRMark.
void | DOPAbstractType.setFDispFormFldSel(boolean value) Sets the fDispFormFldSel field value.
void | FibBaseAbstractType.setFDot(boolean value) Sets the fDot field value.
void | CHPAbstractType.setFDStrike(boolean value) Sets the fDStrike field value.
void | PAPAbstractType.setFDyaAfterAuto(boolean field_55_fDyaAfterAuto) Vertical spacing after is automatic.
void | PAPAbstractType.setFDyaBeforeAuto(boolean field_54_fDyaBeforeAuto) Vertical spacing before is automatic.
void | DOPAbstractType.setFEmbedFonts(boolean value) Sets the fEmbedFonts field value.
void | CHPAbstractType.setFEmboss(boolean value) Sets the fEmboss field value.
void | FibBaseAbstractType.setFEmptySpecial(boolean value) Sets the fEmptySpecial field value.
void | FibBaseAbstractType.setFEncrypted(boolean value) Sets the fEncrypted field value.
void | DOPAbstractType.setFExactCWords(boolean value) Sets the fExactCWords field value.
void | FibBaseAbstractType.setFExtChar(boolean value) Sets the fExtChar field value.
void | DOPAbstractType.setFFacingPages(boolean value) Sets the fFacingPages field value.
void | FibBaseAbstractType.setFFarEast(boolean value) Sets the fFarEast field value.
void | TCAbstractType.setFFirstMerged(boolean value) Sets the fFirstMerged field value.
void | TAPAbstractType.setFFirstRow(boolean value) Sets the fFirstRow field value.
void | TCAbstractType.setFFitText(boolean value) Sets the fFitText field value.
void | CHPAbstractType.setFFldVanish(boolean value) Sets the fFldVanish field value.
void | DOPAbstractType.setFForcePageSizePag(boolean value) Sets the fForcePageSizePag field value.
void | LFOLVLBaseAbstractType.setFFormatting(boolean value) Sets the fFormatting field value.
void | DOPAbstractType.setFFormNoFields(boolean value) Sets the fFormNoFields field value.
void | FibBaseAbstractType.setFGlsy(boolean value) Sets the fGlsy field value.
void | DOPAbstractType.setFGramAllClean(boolean value) Sets the fGramAllClean field value.
void | DOPAbstractType.setFGramAllDone(boolean value) Sets the fGramAllDone field value.
void | CHPAbstractType.setFHasOldProps(boolean field_66_fHasOldProps) Used for character property revision marking.
void | TAPAbstractType.setFHasOldProps(byte field_77_fHasOldProps) Has old properties.
void | StshifAbstractType.setFHasOriginalStyle(boolean value) Sets the fHasOriginalStyle field value.
void | StdfPost2000AbstractType.setFHasOriginalStyle(boolean value) Sets the fHasOriginalStyle field value.
void | FibBaseAbstractType.setFHasPic(boolean value) Sets the fHasPic field value.
void | StdfBaseAbstractType.setFHasUpe(boolean value) Sets the fHasUpe field value.
void | DOPAbstractType.setFHaveVersions(boolean value) Sets the fHaveVersions field value.
void | FSPAAbstractType.setFHdr(boolean value) Sets the fHdr field value.
void | StdfBaseAbstractType.setFHidden(boolean value) Sets the fHidden field value.
void | DOPAbstractType.setFHideLastVersion(boolean value) Sets the fHideLastVersion field value.
void | CHPAbstractType.setFHighlight(boolean value) Sets the fHighlight field value.
void | GrfhicAbstractType.setFHtmlBuiltInBullet(boolean value) Sets the fHtmlBuiltInBullet field value.
void | GrfhicAbstractType.setFHtmlChecked(boolean value) Sets the fHtmlChecked field value.
void | DOPAbstractType.setFHtmlDoc(boolean value) Sets the fHtmlDoc field value.
void | GrfhicAbstractType.setFHtmlFirstLineMismatch(boolean value) Sets the fHtmlFirstLineMismatch field value.
void | GrfhicAbstractType.setFHtmlHangingIndentBeneathNumber(boolean value) Sets the fHtmlHangingIndentBeneathNumber field value.
void | GrfhicAbstractType.setFHtmlListTextNotSharpDot(boolean value) Sets the fHtmlListTextNotSharpDot field value.
void | GrfhicAbstractType.setFHtmlNotPeriod(boolean value) Sets the fHtmlNotPeriod field value.
void | GrfhicAbstractType.setFHtmlTabLeftIndentMismatch(boolean value) Sets the fHtmlTabLeftIndentMismatch field value.
void | GrfhicAbstractType.setFHtmlUnsupported(boolean value) Sets the fHtmlUnsupported field value.
void | LSTFAbstractType.setFHybrid(boolean value) Sets the fHybrid field value.
void | DOPAbstractType.setFHyphCapitals(boolean value) Sets the fHyphCapitals field value.
void | CHPAbstractType.setFImprint(boolean value) Sets the fImprint field value.
void | DOPAbstractType.setFIncludeFooter(boolean value) Sets the fIncludeFooter field value.
void | DOPAbstractType.setFIncludeHeader(boolean value) Sets the fIncludeHeader field value.
void | LVLFAbstractType.setFIndentSav(boolean value) Sets the fIndentSav field value.
void | PAPAbstractType.setFInnerTableCell(boolean field_48_fInnerTableCell) When 1, the end of paragraph mark is really an end of cell mark for a nested table cell.
void | PAPAbstractType.setFInTable(boolean field_14_fInTable) Paragraph is in table flag.
void | PAPAbstractType.setFinTableW97(boolean field_15_finTableW97) Archaic paragraph is in table flag.
void | StdfBaseAbstractType.setFInternalUse(boolean value) Sets the fInternalUse field value.
void | TAPAbstractType.setFInvalAutofit(boolean value) Sets the fInvalAutofit field value.
void | StdfBaseAbstractType.setFInvalHeight(boolean value) Sets the fInvalHeight field value.
void | CHPAbstractType.setFItalic(boolean value) Sets the fItalic field value.
void | CHPAbstractType.setFItalicBi(boolean value) Sets the fItalicBi field value.
void | PAPAbstractType.setFKeep(boolean field_3_fKeep) Set the fKeep field for the PAP record.
void | TAPAbstractType.setFKeepFollow(boolean value) Sets the fKeepFollow field value.
void | PAPAbstractType.setFKeepFollow(boolean field_4_fKeepFollow) Set the fKeepFollow field for the PAP record.
void | PAPAbstractType.setFKinsoku(boolean field_33_fKinsoku) apply Kinsoku rules when performing line wrapping.
void | CHPAbstractType.setFKumimoji(boolean value) Sets the fKumimoji field value.
void | DOPAbstractType.setFLabelDoc(boolean value) Sets the fLabelDoc field value.
void | LSTFAbstractType.setFlags(byte field_4_flags) Set the flags field for the LSTF record.
void | LFOLVLBaseAbstractType.setFlags(int field_2_flags) Set the flags field for the LFOLVLBase record.
void | FSPAAbstractType.setFlags(short field_6_flags) Set the flags field for the FSPA record.
void | FibBaseAbstractType.setFlags1(short field_6_flags1) Set the flags1 field for the FibBase record.
void | FibBaseAbstractType.setFlags2(byte field_10_flags2) Set the flags2 field for the FibBase record.
void | TAPAbstractType.setFLastRow(boolean value) Sets the fLastRow field value.
void | LVLFAbstractType.setFLegal(boolean value) Sets the fLegal field value.
void | DOPAbstractType.setFLinkStyles(boolean value) Sets the fLinkStyles field value.
void | FibBaseAbstractType.setFLoadOverride(boolean value) Sets the fLoadOverride field value.
void | FibBaseAbstractType.setFLoadOverridePage(boolean value) Sets the fLoadOverridePage field value.
void | DOPAbstractType.setFLockAtn(boolean value) Sets the fLockAtn field value.
void | StdfBaseAbstractType.setFLocked(boolean value) Sets the fLocked field value.
void | PAPAbstractType.setFLocked(boolean field_31_fLocked) Anchor of an absolutely positioned frame is locked.
void | DOPAbstractType.setFLockRev(boolean value) Sets the fLockRev field value.
void | CHPAbstractType.setFLowerCase(boolean value) Sets the fLowerCase field value.
void | CHPAbstractType.setFLSFitText(boolean value) Sets the fLSFitText field value.
void | FibBaseAbstractType.setFMac(boolean value) Sets the fMac field value.
void | CHPAbstractType.setFMacChs(boolean value) Sets the fMacChs field value.
void | DOPAbstractType.setFMapPrintTextColor(boolean value) Sets the fMapPrintTextColor field value.
void | StdfBaseAbstractType.setFMassCopy(boolean value) Sets the fMassCopy field value.
void | TCAbstractType.setFMerged(boolean value) Sets the fMerged field value.
void | DOPAbstractType.setFMinFontSizePag(boolean value) Sets the fMinFontSizePag field value.
void | PAPAbstractType.setFMinHeight(boolean field_27_fMinHeight) Minimum height is exact or auto.
void | DOPAbstractType.setFMirrorMargins(boolean value) Sets the fMirrorMargins field value.
void | DOPAbstractType.setFMWSmallCaps(boolean value) Sets the fMWSmallCaps field value.
void | TAPAbstractType.setFNeverBeenAutofit(boolean value) Sets the fNeverBeenAutofit field value.
void | PAPAbstractType.setFNoAllowOverlap(boolean field_77_fNoAllowOverlap) When 1, absolutely positioned paragraph cannot overlap with another paragraph.
void | TAPAbstractType.setFNoAllowOverlap(byte field_22_fNoAllowOverlap) When set to 1, do not allow absolutely positioned table to overlap with other tables.
void | PAPAbstractType.setFNoAutoHyph(boolean field_25_fNoAutoHyph) Set the fNoAutoHyph field for the PAP record.
void | DOPAbstractType.setFNoColumnBalance(boolean value) Sets the fNoColumnBalance field value.
void | StdfBaseAbstractType.setFNoHtmlExport(boolean value) Sets the fNoHtmlExport field value.
void | DOPAbstractType.setFNoLeading(boolean value) Sets the fNoLeading field value.
void | PAPAbstractType.setFNoLnn(boolean field_10_fNoLnn) No line numbering.
void | LVLFAbstractType.setFNoRestart(boolean value) Sets the fNoRestart field value.
void | DOPAbstractType.setFNoSpaceRaiseLower(boolean value) Sets the fNoSpaceRaiseLower field value.
void | DOPAbstractType.setFNoTabForInd(boolean value) Sets the fNoTabForInd field value.
void | TAPAbstractType.setFNotPageView(boolean value) Sets the fNotPageView field value.
void | TCAbstractType.setFNoWrap(boolean value) Sets the fNoWrap field value.
void | PAPAbstractType.setFNumRMIns(boolean field_43_fNumRMIns) Set the fNumRMIns field for the PAP record.
void | FibBaseAbstractType.setFObfuscated(boolean value) Sets the fObfuscated field value.
void | CHPAbstractType.setFObj(boolean value) Sets the fObj field value.
void | CHPAbstractType.setFOle2(boolean value) Sets the fOle2 field value.
void | DOPAbstractType.setFOnlyMacPics(boolean value) Sets the fOnlyMacPics field value.
void | DOPAbstractType.setFOnlyWinPics(boolean value) Sets the fOnlyWinPics field value.
void | PAPAbstractType.setFontAlign(short field_40_fontAlign) Used internally by Word.
void | DOPAbstractType.setFootnoteInfo(short field_3_footnoteInfo) Set the footnoteInfo field for the DOP record.
void | PAPAbstractType.setFOpenTch(boolean field_49_fOpenTch) Ensure the Table Cell char doesn't show up as zero height.
void | TAPAbstractType.setFOrigWordTableRules(boolean value) Sets the fOrigWordTableRules field value.
void | DOPAbstractType.setFOrigWordTableRules(boolean value) Sets the fOrigWordTableRules field value.
void | DOPAbstractType.setFormatFlags(byte field_1_formatFlags) Set the formatFlags field for the DOP record.
void | TAPAbstractType.setFOutline(boolean value) Sets the fOutline field value.
void | CHPAbstractType.setFOutline(boolean value) Sets the fOutline field value.
void | DOPAbstractType.setFOutlineDirtySave(byte field_4_fOutlineDirtySave) Set the fOutlineDirtySave field for the DOP record.
void | PAPAbstractType.setFOverflowPunct(boolean field_35_fOverflowPunct) apply overflow punctuation rules when performing line wrapping.
void | PAPAbstractType.setFPageBreakBefore(boolean field_5_fPageBreakBefore) Set the fPageBreakBefore field for the PAP record.
void | DOPAbstractType.setFPagHidden(boolean value) Sets the fPagHidden field value.
void | DOPAbstractType.setFPagResults(boolean value) Sets the fPagResults field value.
void | DOPAbstractType.setFPagSupressTopSpacing(boolean value) Sets the fPagSupressTopSpacing field value.
void | DOPAbstractType.setFpc(byte value) Sets the fpc field value.
void | StdfBaseAbstractType.setFPersonal(boolean value) Sets the fPersonal field value.
void | StdfBaseAbstractType.setFPersonalCompose(boolean value) Sets the fPersonalCompose field value.
void | StdfBaseAbstractType.setFPersonalReply(boolean value) Sets the fPersonalReply field value.
void | DOPAbstractType.setFPMHMainDoc(boolean value) Sets the fPMHMainDoc field value.
void | DOPAbstractType.setFPrintBodyBeforeHdr(boolean value) Sets the fPrintBodyBeforeHdr field value.
void | DOPAbstractType.setFPrintFormData(boolean value) Sets the fPrintFormData field value.
void | PAPAbstractType.setFPropRMark(boolean field_69_fPropRMark) Set the fPropRMark field for the PAP record.
void | CHPAbstractType.setFPropRMark(boolean field_51_fPropRMark) properties have been changed with revision marking on.
void | TAPAbstractType.setFPropRMark(byte field_76_fPropRMark) Set to 1 if property revision.
void | DOPAbstractType.setFProtEnabled(boolean value) Sets the fProtEnabled field value.
void | StdfBaseAbstractType.setFQFormat(boolean value) Sets the fQFormat field value.
void | FSPAAbstractType.setFRcaSimple(boolean value) Sets the fRcaSimple field value.
void | FibBaseAbstractType.setFReadOnlyRecommended(boolean value) Sets the fReadOnlyRecommended field value.
void | StdfBaseAbstractType.setFReserved(byte value) Sets the fReserved field value.
void | PICFAbstractType.setFReserved(byte field_19_fReserved) Set the fReserved field for the PICF record.
void | StshifAbstractType.setFReserved(short value) Sets the fReserved field value.
void | DOPAbstractType.setFRevMarking(boolean value) Sets the fRevMarking field value.
void | CHPAbstractType.setFRMark(boolean value) Sets the fRMark field value.
void | CHPAbstractType.setFRMarkDel(boolean value) Sets the fRMarkDel field value.
void | DOPAbstractType.setFRMPrint(boolean value) Sets the fRMPrint field value.
void | DOPAbstractType.setFRMView(boolean value) Sets the fRMView field value.
void | TCAbstractType.setFRotateFont(boolean value) Sets the fRotateFont field value.
void | PAPAbstractType.setFRotateFont(boolean value) Sets the fRotateFont field value.
void | DOPAbstractType.setFRotateFontW6(boolean value) Sets the fRotateFontW6 field value.
void | TAPAbstractType.setFRTL(byte field_21_fRTL) Word 2000 style right-to-left table.
void | CHPAbstractType.setFRuby(boolean value) Sets the fRuby field value.
void | DOPAbstractType.setFSaveFormData(boolean value) Sets the fSaveFormData field value.
void | StdfBaseAbstractType.setFScratch(boolean value) Sets the fScratch field value.
void | CHPAbstractType.setFSdtVanish(boolean field_67_fSdtVanish) Mark the character as hidden..
void | StdfBaseAbstractType.setFSemiHidden(boolean value) Sets the fSemiHidden field value.
void | DOPAbstractType.setFShadeFormData(boolean value) Sets the fShadeFormData field value.
void | CHPAbstractType.setFShadow(boolean value) Sets the fShadow field value.
void | DOPAbstractType.setFShowBreaksInFrames(boolean value) Sets the fShowBreaksInFrames field value.
void | PAPAbstractType.setFSideBySide(boolean field_2_fSideBySide) Set the fSideBySide field for the PAP record.
void | LSTFAbstractType.setFSimpleList(boolean value) Sets the fSimpleList field value.
void | CHPAbstractType.setFSmallCaps(boolean value) Sets the fSmallCaps field value.
void | DOPAbstractType.setFSnapBorder(boolean value) Sets the fSnapBorder field value.
void | TAPAbstractType.setFSpare(byte field_23_fSpare) Not used.
void | StdfPost2000AbstractType.setFSpare(byte value) Sets the fSpare field value.
void | FibBaseAbstractType.setFSpare0(byte value) Sets the fSpare0 field value.
void | CHPAbstractType.setFSpec(boolean value) Sets the fSpec field value.
void | CHPAbstractType.setFSpecSymbol(boolean field_16_fSpecSymbol) Used by Word internally.
void | CHPAbstractType.setFSpecVanish(boolean field_65_fSpecVanish) Special hidden for leading emphasis (always hidden).
void | LFOLVLBaseAbstractType.setFStartAt(boolean value) Sets the fStartAt field value.
void | CHPAbstractType.setFStrike(boolean value) Sets the fStrike field value.
void | DOPAbstractType.setFSubsetFonts(boolean value) Sets the fSubsetFonts field value.
void | DOPAbstractType.setFSuppressTopSPacingMac5(boolean value) Sets the fSuppressTopSPacingMac5 field value.
void | DOPAbstractType.setFSupressSpdfAfterPageBreak(boolean value) Sets the fSupressSpdfAfterPageBreak field value.
void | DOPAbstractType.setFSupressTopSpacing(boolean value) Sets the fSupressTopSpacing field value.
void | DOPAbstractType.setFSwapBordersFacingPgs(boolean value) Sets the fSwapBordersFacingPgs field value.
void | TAPAbstractType.setFTableHeader(boolean field_7_fTableHeader) When 1, table row is to be used as the header of the table.
void | StshifAbstractType.setFtcAsci(short field_7_ftcAsci) A signed integer that specifies an operand value for the sprmCRgFtc0 for default document formatting.
void | CHPAbstractType.setFtcAscii(int field_3_ftcAscii) Font for ASCII text.
void | CHPAbstractType.setFtcBi(int field_6_ftcBi) Font for Complex Scripts text.
void | CHPAbstractType.setFtcFE(int field_4_ftcFE) Font for East Asian text.
void | StshifAbstractType.setFtcFE(short field_8_ftcFE) A signed integer that specifies an operand value for the sprmCRgFtc1 for default document formatting, as defined in the section Determining Formatting Properties.
void | CHPAbstractType.setFtcOther(int field_5_ftcOther) Font for non-East Asian text.
void | StshifAbstractType.setFtcOther(short field_9_ftcOther) A signed integer that specifies an operand value for the sprmCRgFtc2 for default document formatting, as defined in the section Determining Formatting Properties.
void | CHPAbstractType.setFtcSym(int field_34_ftcSym) an index into the rgffn structure.
void | LVLFAbstractType.setFTentative(boolean value) Sets the fTentative field value.
void | CHPAbstractType.setFTNY(boolean value) Sets the fTNY field value.
void | CHPAbstractType.setFTNYCompress(boolean value) Sets the fTNYCompress field value.
void | CHPAbstractType.setFTNYFetchTxm(boolean value) Sets the fTNYFetchTxm field value.
void | PAPAbstractType.setFTopLinePunct(boolean field_36_fTopLinePunct) perform top line punctuation processing.
void | DOPAbstractType.setFTransparentMetafiles(boolean value) Sets the fTransparentMetafiles field value.
void | DOPAbstractType.setFTruncDxaExpand(boolean value) Sets the fTruncDxaExpand field value.
void | TCAbstractType.setFtsCellPaddingBottom(byte field_10_ftsCellPaddingBottom) Bottom cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingDefaultBottom(byte field_48_ftsCellPaddingDefaultBottom) Default bottom cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingDefaultLeft(byte field_47_ftsCellPaddingDefaultLeft) Default left cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingDefaultRight(byte field_49_ftsCellPaddingDefaultRight) Default right cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingDefaultTop(byte field_46_ftsCellPaddingDefaultTop) Default top cell margin/padding units.
void | TCAbstractType.setFtsCellPaddingLeft(byte field_8_ftsCellPaddingLeft) Left cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingOuterBottom(byte field_64_ftsCellPaddingOuterBottom) Default outer bottom cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingOuterLeft(byte field_63_ftsCellPaddingOuterLeft) Default outer left cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingOuterRight(byte field_65_ftsCellPaddingOuterRight) Default outer right cell margin/padding units.
void | TAPAbstractType.setFtsCellPaddingOuterTop(byte field_62_ftsCellPaddingOuterTop) Default outer top cell margin/padding units.
void | TCAbstractType.setFtsCellPaddingRight(byte field_11_ftsCellPaddingRight) Right cell margin/padding units.
void | TCAbstractType.setFtsCellPaddingTop(byte field_9_ftsCellPaddingTop) Top cell margin/padding units.
void | TCAbstractType.setFtsCellSpacingBottom(byte field_18_ftsCellSpacingBottom) Bottom cell spacing units.
void | TAPAbstractType.setFtsCellSpacingDefaultBottom(byte field_56_ftsCellSpacingDefaultBottom) Default bottom cell spacings units.
void | TAPAbstractType.setFtsCellSpacingDefaultLeft(byte field_55_ftsCellSpacingDefaultLeft) Default left cell spacings units.
void | TAPAbstractType.setFtsCellSpacingDefaultRight(byte field_57_ftsCellSpacingDefaultRight) Default right cell spacings units.
void | TAPAbstractType.setFtsCellSpacingDefaultTop(byte field_54_ftsCellSpacingDefaultTop) Default top cell spacings units.
void | TCAbstractType.setFtsCellSpacingLeft(byte field_16_ftsCellSpacingLeft) Left cell spacing units.
void | TAPAbstractType.setFtsCellSpacingOuterBottom(byte field_72_ftsCellSpacingOuterBottom) Default outer bottom cell spacings units.
void | TAPAbstractType.setFtsCellSpacingOuterLeft(byte field_71_ftsCellSpacingOuterLeft) Default outer left cell spacings units.
void | TAPAbstractType.setFtsCellSpacingOuterRight(byte field_73_ftsCellSpacingOuterRight) Default outer right cell spacings units.
void | TAPAbstractType.setFtsCellSpacingOuterTop(byte field_70_ftsCellSpacingOuterTop) Default outer top cell spacings units.
void | TCAbstractType.setFtsCellSpacingRight(byte field_19_ftsCellSpacingRight) Right cell spacing units.
void | TCAbstractType.setFtsCellSpacingTop(byte field_17_ftsCellSpacingTop) Top cell spacing units.
void | TCAbstractType.setFtsWidth(byte value) Sets the ftsWidth field value.
void | TAPAbstractType.setFtsWidth(byte value) Sets the ftsWidth field value.
void | TAPAbstractType.setFtsWidthAfter(byte value) Sets the ftsWidthAfter field value.
void | TAPAbstractType.setFtsWidthBefore(byte value) Sets the ftsWidthBefore field value.
void | TAPAbstractType.setFtsWidthIndent(byte value) Sets the ftsWidthIndent field value.
void | PAPAbstractType.setFTtp(boolean field_16_fTtp) Table trailer paragraph (last in table row).
void | PAPAbstractType.setFTtpEmbedded(boolean field_50_fTtpEmbedded) Word 97 compatibility indicates this end of paragraph mark is really an end of row marker for a nested table.
void | CHPAbstractType.setFUndetermine(boolean field_14_fUndetermine) Character is undetermined.
void | StdfBaseAbstractType.setFUnhideWhenUsed(boolean value) Sets the fUnhideWhenUsed field value.
void | TCAbstractType.setFUnused(byte value) Sets the fUnused field value.
void | PAPAbstractType.setFUsePgsuSettings(boolean field_45_fUsePgsuSettings) Set the fUsePgsuSettings field for the PAP record.
void | CHPAbstractType.setFUsePgsuSettings(boolean value) Sets the fUsePgsuSettings field value.
void | CHPAbstractType.setFVanish(boolean value) Sets the fVanish field value.
void | TAPAbstractType.setFVert(boolean value) Sets the fVert field value.
void | TCAbstractType.setFVertical(boolean value) Sets the fVertical field value.
void | PAPAbstractType.setFVertical(boolean value) Sets the fVertical field value.
void | TCAbstractType.setFVertMerge(boolean value) Sets the fVertMerge field value.
void | TCAbstractType.setFVertRestart(boolean value) Sets the fVertRestart field value.
void | DOPAbstractType.setFVirusLoadSafe(boolean value) Sets the fVirusLoadSafe field value.
void | DOPAbstractType.setFVirusPrompted(boolean value) Sets the fVirusPrompted field value.
void | CHPAbstractType.setFWarichu(boolean value) Sets the fWarichu field value.
void | CHPAbstractType.setFWarichuNoOpenBracket(boolean value) Sets the fWarichuNoOpenBracket field value.
void | DOPAbstractType.setFWCFtnEdn(boolean value) Sets the fWCFtnEdn field value.
void | TAPAbstractType.setFWebView(boolean value) Sets the fWebView field value.
void | FibBaseAbstractType.setFWhichTblStm(boolean value) Sets the fWhichTblStm field value.
void | PAPAbstractType.setFWidowControl(boolean field_32_fWidowControl) 1, Word will prevent widowed lines in this paragraph from being placed at the beginning of a page.
void | DOPAbstractType.setFWidowControl(boolean value) Sets the fWidowControl field value.
void | PAPAbstractType.setFWordWrap(boolean field_34_fWordWrap) perform word wrap.
void | TAPAbstractType.setFWrapToWwd(boolean value) Sets the fWrapToWwd field value.
void | DOPAbstractType.setFWrapTrailSpaces(boolean value) Sets the fWrapTrailSpaces field value.
void | FibBaseAbstractType.setFWriteReservation(boolean value) Sets the fWriteReservation field value.
void | PICFAbstractType.setGrf(int field_7_grf) This field MUST be ignored.
void | DOPAbstractType.setGrfDocEvents(int field_42_grfDocEvents) Set the grfDocEvents field for the DOP record.
void | GrfhicAbstractType.setGrfhic(byte field_1_grfhic) HTML compatibility flags.
void | LVLFAbstractType.setGrfhic(Grfhic field_11_grfhic) A grfhic that specifies the HTML incompatibilities of the level..
void | LSTFAbstractType.setGrfhic(Grfhic field_5_grfhic) A grfhic that specifies the HTML incompatibilities of the list..
void | LFOAbstractType.setGrfhic(Grfhic field_6_grfhic) HTML compatibility flags.
void | LFOLVLBaseAbstractType.setGrfhic(short value) Sets the grfhic field value.
void | StdfBaseAbstractType.setGrfstd(short field_5_grfstd) A GRFSTD that specifies miscellaneous style properties.
void | DOPAbstractType.setGrfSupression(byte value) Sets the grfSupression field value.
void | CHPAbstractType.setGrpfChp(int field_1_grpfChp) Collection of the 32 flags.
void | TAPAbstractType.setGrpfTap_unused(short value) Sets the grpfTap_unused field value.
void | TAPAbstractType.setGrpfTap(int field_24_grpfTap) Used internally by Word.
void | CHPAbstractType.setHighlight(short field_48_Highlight) Set the Highlight field for the CHP record.
void | CHPAbstractType.setHps(int field_2_hps) Font size in half points.
void | CHPAbstractType.setHpsAsci(int field_31_hpsAsci) Font size for ASCII font.
void | CHPAbstractType.setHpsBi(int field_33_hpsBi) Font size for Complex Scripts text.
void | CHPAbstractType.setHpsFE(int field_32_hpsFE) Font size for East Asian text.
void | CHPAbstractType.setHpsKern(int field_21_hpsKern) Kerning distance for characters in run recorded in half points.
void | CHPAbstractType.setHpsPos(short field_22_hpsPos) Reserved (actually used as vertical offset(?) value).
void | DOPAbstractType.setHpsZoonFontPag(short field_52_hpsZoonFontPag) Set the hpsZoonFontPag field for the DOP record.
void | CHPAbstractType.setHresi(Hyphenation field_20_hresi) Set the hresi field for the CHP record.
void | CHPAbstractType.setHresiOld(Hyphenation field_40_hresiOld) Set the hresiOld field for the CHP record.
void | CHPAbstractType.setIbstConflict(int field_57_IbstConflict) Who made this change for this side of the conflict..
void | CHPAbstractType.setIbstDispFldRMark(int field_60_ibstDispFldRMark) Index to author IDs stored in hsttbfRMark.
void | LFOAbstractType.setIbstFltAutoNum(byte field_5_ibstFltAutoNum) Used for AUTONUM field emulation.
void | PAPAbstractType.setIbstPropRMark(int field_70_ibstPropRMark) Set the ibstPropRMark field for the PAP record.
void | CHPAbstractType.setIbstPropRMark(int field_52_ibstPropRMark) Index to author IDs stored in hsttbfRMark.
void | CHPAbstractType.setIbstRMark(int field_25_ibstRMark) Index to author IDs stored in hsttbfRMark.
void | CHPAbstractType.setIbstRMarkDel(int field_41_ibstRMarkDel) Index to author IDs stored in hsttbfRMark.
void | CHPAbstractType.setIco(byte field_9_ico) Color of text for Word 97.
void | SHD80AbstractType.setIcoBack(byte value) Sets the icoBack field value.
void | SHD80AbstractType.setIcoFore(byte value) Sets the icoFore field value.
void | CHPAbstractType.setIcoHighlight(byte value) Sets the icoHighlight field value.
void | CHPAbstractType.setIdct(byte field_17_idct) Not stored in file.
void | CHPAbstractType.setIdctHint(byte field_18_idctHint) Identifier of Character type.
void | CHPAbstractType.setIdslReasonDel(int field_46_idslReasonDel) An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
void | CHPAbstractType.setIdslRMReason(int field_45_idslRMReason) An index to strings displayed as reasons for actions taken by Word's AutoFormat code.
void | StdfPost2000AbstractType.setIftcHtml(byte value) Sets the iftcHtml field value.
void | DOPAbstractType.setIGutterPos(boolean value) Sets the iGutterPos field value.
void | PAPAbstractType.setIlfo(int field_9_ilfo) 1-based index into the pllfo (lists structure), if non-zero.
void | PAPAbstractType.setIlvl(byte field_8_ilvl) List level if non-zero.
void | LFOLVLBaseAbstractType.setILvl(byte value) Sets the iLvl field value.
void | LVLFAbstractType.setIlvlRestartLim(short field_10_ilvlRestartLim) An unsigned integer that specifies the first (most-significant) zero-based level after which the number sequence of this level does not restart.
void | LVLFAbstractType.setInfo(byte field_3_info) Set the info field for the LVLF record.
void | StdfPost2000AbstractType.setInfo1(short field_1_info1) Set the info1 field for the StdfPost2000 record.
void | StdfBaseAbstractType.setInfo1(short field_1_info1) Set the info1 field for the StdfBase record.
void | StdfBaseAbstractType.setInfo2(short field_2_info2) Set the info2 field for the StdfBase record.
void | StshifAbstractType.setInfo3(int field_3_info3) Set the info3 field for the Stshif record.
void | StdfPost2000AbstractType.setInfo3(short field_3_info3) Set the info3 field for the StdfPost2000 record.
void | StdfBaseAbstractType.setInfo3(short field_3_info3) Set the info3 field for the StdfBase record.
void | TAPAbstractType.setInternalFlags(int field_25_internalFlags) Used internally by Word.
void | SHD80AbstractType.setIpat(byte value) Sets the ipat field value.
void | SHDAbstractType.setIpat(int field_3_ipat) Shading pattern.
void | PAPAbstractType.setIpgp(long field_78_ipgp) HTML DIV ID for this paragraph.
void | StdfPost2000AbstractType.setIPriority(short value) Sets the iPriority field value.
void | CHPAbstractType.setIss(byte field_15_iss) Superscript/subscript indices.
void | LVLFAbstractType.setIStartAt(int field_1_iStartAt) A signed integer that specifies the beginning number for the number sequence belonging to this level.
void | LFOLVLBaseAbstractType.setIStartAt(int field_1_iStartAt) If fStartAt is set to 0x1, this is a signed integer that specifies the start-at value that overrides lvlf.iStartAt of the corresponding LVL.
void | PAPAbstractType.setIstd(int field_1_istd) Index to style descriptor.
void | CHPAbstractType.setIstd(int field_44_istd) Index to character style descriptor in the stylesheet that tags this run of text.
void | TAPAbstractType.setIstd(short field_1_istd) Table style for the Table.
void | StdfBaseAbstractType.setIstdBase(short value) Sets the istdBase field value.
void | StdfPost2000AbstractType.setIstdLink(short value) Sets the istdLink field value.
void | StshifAbstractType.setIstdMaxFixedWhenSaved(int field_5_istdMaxFixedWhenSaved) An unsigned integer that specifies the count of elements at the start of STSH.rglpstd that are reserved for fixed-index application-defined styles.
void | StdfBaseAbstractType.setIstdNext(short value) Sets the istdNext field value.
void | PAPAbstractType.setItap(int field_47_itap) Table nesting level.
void | PAPAbstractType.setItbdMac(int field_72_itbdMac) Number of tabs stops defined for paragraph.
void | TAPAbstractType.setItcMac(short field_26_itcMac) Count of cells defined for this row.
void | CHPAbstractType.setItypFELayout(short value) Sets the itypFELayout field value.
void | CHPAbstractType.setIWarichuBracket(byte value) Sets the iWarichuBracket field value.
void | LVLFAbstractType.setIxchFollow(byte field_5_ixchFollow) An unsigned integer that specifies the character that follows the number text.
void | TBDAbstractType.setJc(byte value) Sets the jc field value.
void | PAPAbstractType.setJc(byte field_59_jc) Set the jc field for the PAP record.
void | LVLFAbstractType.setJc(byte value) Sets the jc field value.
void | TAPAbstractType.setJc(short field_2_jc) Justification code.
void | CHPAbstractType.setKcd(byte field_13_kcd) Emphasis mark.
void | DOPAbstractType.setKeyVirusSession30(int value) Sets the KeyVirusSession30 field value.
void | CHPAbstractType.setKul(byte field_19_kul) Underline code.
void | CHPAbstractType.setLbrCRJ(byte field_64_lbrCRJ) Line BReak code for xchCRJ.
void | PICFAbstractType.setLcb(int field_1_lcb) A signed integer that specifies the size, in bytes, of this PICF structure and the subsequent data.
void | FibBaseAbstractType.setLid(int field_4_lid) A LID that specifies the install language of the application that is producing the document.
void | CHPAbstractType.setLidDefault(int field_11_lidDefault) Set the lidDefault field for the CHP record.
void | CHPAbstractType.setLidFE(int field_12_lidFE) Set the lidFE field for the CHP record.
void | FibRgW97AbstractType.setLidFE(short field_14_lidFE) A LID whose meaning depends on the nFib value.
void | FibBaseAbstractType.setLKey(int field_8_lKey) If fEncryption is 1 and fObfuscation is 1, this value specifies the XOR obfuscation password verifier.
void | DOPAbstractType.setLKeyProtDoc(int field_31_lKeyProtDoc) Set the lKeyProtDoc field for the DOP record.
void | LSTFAbstractType.setLsid(int field_1_lsid) A signed integer that specifies the list identifier.
void | LFOAbstractType.setLsid(int field_1_lsid) List ID of corresponding LSTF (see LSTF).
void | PAPAbstractType.setLspd(LineSpacingDescriptor field_11_lspd) Line spacing descriptor.
void | CHPAbstractType.setLTagObj(int field_38_lTagObj) An object ID for an OLE object, only set if chp.fSpec and chp.fOle2 are both true, and chp.fObj..
void | PAPAbstractType.setLvl(byte field_41_lvl) Outline level.
void | DOPAbstractType.setLvl(byte value) Sets the lvl field value.
void | PICFAbstractType.setMm(short field_3_mm) A signed integer that specifies the format of the picture data.
void | PICFAbstractType.setMmPM(int field_9_mmPM) This field MUST be ignored.
void | PICFAbstractType.setMx(int field_13_mx) Set the mx field for the PICF record.
void | PICFAbstractType.setMy(int field_14_my) Set the my field for the PICF record.
void | DOPAbstractType.setNEdn(short value) Sets the nEdn field value.
void | LVLFAbstractType.setNfc(byte field_2_nfc) An MSONFC, as specified in [MS-OSHARED] section 2.2.1.3, that specifies the format of the level numbers that replace the placeholders for this level in the xst fields of the LVLs in this list.
void | DOPAbstractType.setNfcEdnRef(short field_51_nfcEdnRef) Set the nfcEdnRef field for the DOP record.
void | DOPAbstractType.setNfcEdnRef1(byte value) Sets the nfcEdnRef1 field value.
void | DOPAbstractType.setNfcFtnRef(short field_50_nfcFtnRef) Set the nfcFtnRef field for the DOP record.
void | DOPAbstractType.setNfcFtnRef1(byte value) Sets the nfcFtnRef1 field value.
void | FibBaseAbstractType.setNFib(int field_2_nFib) An unsigned integer that specifies the version number of the file format used.
void | FibBaseAbstractType.setNFibBack(int field_7_nFibBack) This value SHOULD be 0x00BF.
void | DOPAbstractType.setNFtn(short value) Sets the nFtn field value.
void | DOPAbstractType.setNRevision(int field_17_nRevision) Set the nRevision field for the DOP record.
void | PAPAbstractType.setNumrm(byte[] field_75_numrm) Set the numrm field for the PAP record.
void | StshifAbstractType.setNVerBuiltInNamesWhenSaved(int field_6_nVerBuiltInNamesWhenSaved) An unsigned integer that specifies the version number of the style names as defined by the application that writes the file.
void | DOPAbstractType.setOldfConvMailMergeEsc(boolean value) Sets the oldfConvMailMergeEsc field value.
void | DOPAbstractType.setOldfMapPrintTextColor(boolean value) Sets the oldfMapPrintTextColor field value.
void | DOPAbstractType.setOldfNoColumnBalance(boolean value) Sets the oldfNoColumnBalance field value.
void | DOPAbstractType.setOldfNoSpaceRaiseLower(boolean value) Sets the oldfNoSpaceRaiseLower field value.
void | DOPAbstractType.setOldfNoTabForInd(boolean value) Sets the oldfNoTabForInd field value.
void | DOPAbstractType.setOldfOrigWordTableRules(boolean value) Sets the oldfOrigWordTableRules field value.
void | DOPAbstractType.setOldfShowBreaksInFrames(boolean value) Sets the oldfShowBreaksInFrames field value.
void | DOPAbstractType.setOldfSuppressSpbfAfterPageBreak(boolean value) Sets the oldfSuppressSpbfAfterPageBreak field value.
void | DOPAbstractType.setOldfSupressTopSpacing(boolean value) Sets the oldfSupressTopSpacing field value.
void | DOPAbstractType.setOldfSwapBordersFacingPgs(boolean value) Sets the oldfSwapBordersFacingPgs field value.
void | DOPAbstractType.setOldfTransparentMetafiles(boolean value) Sets the oldfTransparentMetafiles field value.
void | DOPAbstractType.setOldfWrapTrailSpaces(boolean value) Sets the oldfWrapTrailSpaces field value.
void | PICFAbstractType.setPadding(int field_8_padding) This value MUST be zero and MUST be ignored.
void | PICFAbstractType.setPadding2(int field_10_padding2) This value MUST be zero and MUST be ignored.
void | TAPAbstractType.setPcHorz(byte value) Sets the pcHorz field value.
void | PAPAbstractType.setPcHorz(byte field_23_pcHorz) Set the pcHorz field for the PAP record.
void | CHPAbstractType.setPctCharWidth(int field_10_pctCharWidth) Character scale.
void | TAPAbstractType.setPctWwd(short field_31_pctWwd) Used internally by Word: percent of Window size for AutoFit in WebView.
void | TAPAbstractType.setPcVert(byte value) Sets the pcVert field value.
void | PAPAbstractType.setPcVert(byte field_22_pcVert) Set the pcVert field for the PAP record.
void | PAPAbstractType.setPhe(byte[] field_68_phe) Set the phe field for the PAP record.
void | FibBaseAbstractType.setPnNext(int field_5_pnNext) An unsigned integer that specifies the offset in the WordDocument stream of the FIB for the document which contains all the AutoText items.
void | PAPAbstractType.setPtap(byte[] field_76_ptap) Set the ptap field for the PAP record.
void | TBDAbstractType.setReserved(byte value) Sets the reserved field value.
void | DOPAbstractType.setReserved(int field_49_reserved) Set the reserved field for the DOP record.
void | FibBaseAbstractType.setReserved1(boolean value) Sets the reserved1 field value.
void | LSTFAbstractType.setReserved1(byte value) Sets the reserved1 field value.
void | LFOAbstractType.setReserved1(int field_2_reserved1) Reserved.
void | FibRgLw97AbstractType.setReserved1(int field_2_reserved1) This value is undefined and MUST be ignored.
void | FibRgLw95AbstractType.setReserved1(int field_2_reserved1) Set the reserved1 field for the FibRgLw95 record.
void | DOPAbstractType.setReserved1(int field_45_reserved1) Set the reserved1 field for the DOP record.
void | FibRgW97AbstractType.setReserved1(short field_1_reserved1) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved10(int field_18_reserved10) This value is undefined and MUST be ignored.
void | FibRgW97AbstractType.setReserved10(short field_10_reserved10) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved11(int field_19_reserved11) This value is undefined and MUST be ignored.
void | FibRgW97AbstractType.setReserved11(short field_11_reserved11) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved12(int field_20_reserved12) This value SHOULD be zero, and MUST be ignored.
void | FibRgW97AbstractType.setReserved12(short field_12_reserved12) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved13(int field_21_reserved13) This value MUST be zero and MUST be ignored.
void | FibRgW97AbstractType.setReserved13(short field_13_reserved13) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved14(int field_22_reserved14) This value MUST be zero and MUST be ignored.
void | FibBaseAbstractType.setReserved2(boolean value) Sets the reserved2 field value.
void | LFOAbstractType.setReserved2(int field_3_reserved2) Reserved.
void | FibRgLw97AbstractType.setReserved2(int field_3_reserved2) This value is undefined and MUST be ignored.
void | FibRgLw95AbstractType.setReserved2(int field_3_reserved2) Set the reserved2 field for the FibRgLw95 record.
void | DOPAbstractType.setReserved2(int field_46_reserved2) Set the reserved2 field for the DOP record.
void | FibRgW97AbstractType.setReserved2(short field_2_reserved2) This value is undefined and MUST be ignored.
void | LFOAbstractType.setReserved3(byte field_7_reserved3) Reserved.
void | FibRgLw97AbstractType.setReserved3(int field_7_reserved3) This value is undefined and MUST be ignored.
void | FibRgLw95AbstractType.setReserved3(int field_4_reserved3) Set the reserved3 field for the FibRgLw95 record.
void | FibRgW97AbstractType.setReserved3(short field_3_reserved3) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved4(int field_12_reserved4) This value is undefined and MUST be ignored.
void | FibRgLw95AbstractType.setReserved4(int field_5_reserved4) Set the reserved4 field for the FibRgLw95 record.
void | FibRgW97AbstractType.setReserved4(short field_4_reserved4) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved5(int field_13_reserved5) This value is undefined and MUST be ignored.
void | FibRgLw95AbstractType.setReserved5(int field_14_reserved5) Set the reserved5 field for the FibRgLw95 record.
void | FibRgW97AbstractType.setReserved5(short field_5_reserved5) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved6(int field_14_reserved6) This value MUST be equal or less than the number of data elements in PlcBteChpx, as specified by FibRgFcLcb97.fcPlcfBteChpx and FibRgFcLcb97.lcbPlcfBteChpx.
void | FibRgW97AbstractType.setReserved6(short field_6_reserved6) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved7(int field_15_reserved7) This value is undefined and MUST be ignored.
void | FibRgW97AbstractType.setReserved7(short field_7_reserved7) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved8(int field_16_reserved8) This value is undefined and MUST be ignored.
void | FibRgW97AbstractType.setReserved8(short field_8_reserved8) This value is undefined and MUST be ignored.
void | FibRgLw97AbstractType.setReserved9(int field_17_reserved9) This value MUST be less than or equal to the number of data elements in PlcBtePapx, as specified by FibRgFcLcb97.fcPlcfBtePapx and FibRgFcLcb97.lcbPlcfBtePapx.
void | FibRgW97AbstractType.setReserved9(short field_9_reserved9) This value is undefined and MUST be ignored.
void | TAPAbstractType.setRgbrcInsideDefault_0(BorderCode field_80_rgbrcInsideDefault_0) Border definition for inside horizontal borders.
void | TAPAbstractType.setRgbrcInsideDefault_1(BorderCode field_81_rgbrcInsideDefault_1) Border definition for inside vertical borders.
void | LVLFAbstractType.setRgbxchNums(byte[] field_4_rgbxchNums) An array of 8-bit integers.
void | TAPAbstractType.setRgdxaCenter(short[] field_33_rgdxaCenter) rgdxaCenter[0] is the left boundary of cell 0 measured relative to margin rgdxaCenter[tap.itcMac - 1] is left boundary of last cell rgdxaCenter[tap.itcMac] is right boundary of last cell..
void | TAPAbstractType.setRgdxaCenterPrint(short[] field_34_rgdxaCenterPrint) Used internally by Word.
void | PAPAbstractType.setRgdxaTab(int[] field_73_rgdxaTab) Array of positions of itbdMac tab stops.
void | TCAbstractType.setRgf(short field_1_rgf) Set the rgf field for the TC record.
void | LSTFAbstractType.setRgistdPara(short[] field_3_rgistdPara) An array of nine 16-bit signed integers.
void | TAPAbstractType.setRgshd(ShadingDescriptor[] field_75_rgshd) Set the rgshd field for the TAP record.
void | PAPAbstractType.setRgtbd(TabDescriptor[] field_74_rgtbd) Array of itbdMac tab descriptors.
void | TAPAbstractType.setRgtc(TableCellDescriptor[] field_74_rgtc) Set the rgtc field for the TAP record.
void | DOPAbstractType.setRncEdn(byte value) Sets the rncEdn field value.
void | DOPAbstractType.setRncFtn(byte value) Sets the rncFtn field value.
void | StdfPost2000AbstractType.setRsid(long field_2_rsid) An unsigned integer that specifies the revision save identifier of the session when this style definition was last modified.
void | PAPAbstractType.setRsid(long field_79_rsid) Save ID for last time this PAP was revised.
void | CHPAbstractType.setSfxtText(byte field_26_sfxtText) Text animation.
void | TCAbstractType.setShd(ShadingDescriptor field_3_shd) Cell shading.
void | PAPAbstractType.setShd(ShadingDescriptor field_66_shd) Set the shd field for the PAP record.
void | CHPAbstractType.setShd(ShadingDescriptor field_23_shd) Shading.
void | TAPAbstractType.setShdTable(ShadingDescriptor field_35_shdTable) Table shading.
void | CHPAbstractType.setSpare(byte value) Sets the spare field value.
void | DOPAbstractType.setSpare(byte[] field_44_Spare) Set the Spare field for the DOP record.
void | FSPAAbstractType.setSpid(int field_1_spid) Shape Identifier.
void | StdfBaseAbstractType.setSti(short value) Sets the sti field value.
void | StshifAbstractType.setStiMaxWhenSaved(int field_4_stiMaxWhenSaved) An unsigned integer that specifies a value that is 1 larger than the largest StdfBase.sti index of any application-defined style.
void | StdfBaseAbstractType.setStk(byte value) Sets the stk field value.
void | PICFAbstractType.setSwHMF(short field_6_swHMF) This field is unused and MUST be ignored.
void | TBDAbstractType.setTlc(byte value) Sets the tlc field value.
void | TAPAbstractType.setTlp(TableAutoformatLookSpecifier field_8_tlp) Table look specifier.
void | DOPAbstractType.setTmEdited(int field_18_tmEdited) Set the tmEdited field for the DOP record.
void | LSTFAbstractType.setTplc(int field_2_tplc) A Tplc that specifies a unique identifier for this LSTF that MAY be used for user interface purposes.
void | CHPAbstractType.setUfel(short field_29_ufel) Collection properties represented by itypFELayout and copt (East Asian layout properties).
void | StdfPost2000AbstractType.setUnused(boolean value) Sets the unused field value.
void | CHPAbstractType.setUnused(boolean value) Sets the unused field value.
void | FibBaseAbstractType.setUnused(int field_3_unused) This value is undefined and MUST be ignored.
void | LVLFAbstractType.setUnused1(boolean value) Sets the unused1 field value.
void | LSTFAbstractType.setUnused1(boolean value) Sets the unused1 field value.
void | DOPAbstractType.setUnused1(boolean value) Sets the unused1 field value.
void | LFOLVLBaseAbstractType.setUnused1(short value) Sets the unused1 field value.
void | LSTFAbstractType.setUnused2(boolean value) Sets the unused2 field value.
void | LFOLVLBaseAbstractType.setUnused2(byte value) Sets the unused2 field value.
void | DOPAbstractType.setUnused2(byte field_2_unused2) Set the unused2 field for the DOP record.
void | LVLFAbstractType.setUnused2(int field_7_unused2) This field MUST be ignored.
void | DOPAbstractType.setUnused3(boolean value) Sets the unused3 field value.
void | DOPAbstractType.setUnused4(boolean value) Sets the unused4 field value.
void | DOPAbstractType.setUnused5(byte value) Sets the unused5 field value.
void | TBDAbstractType.setValue(byte field_1_value) Set the value field for the TBD record.
void | SHD80AbstractType.setValue(short field_1_value) Set the value field for the SHD80 record.
void | TCAbstractType.setVertAlign(byte value) Sets the vertAlign field value.
void | DOPAbstractType.setView(short field_32_view) Set the view field for the DOP record.
void | TAPAbstractType.setViewFlags_unused1(boolean value) Sets the viewFlags_unused1 field value.
void | TAPAbstractType.setViewFlags_unused2(short value) Sets the viewFlags_unused2 field value.
void | TAPAbstractType.setViewFlags(int field_32_viewFlags) Used internally by Word.
void | DOPAbstractType.setVirusinfo(int field_43_virusinfo) Set the virusinfo field for the DOP record.
void | PAPAbstractType.setWAlignFont(int field_39_wAlignFont) Set the wAlignFont field for the PAP record.
void | TCAbstractType.setWCellPaddingBottom(short field_6_wCellPaddingBottom) Bottom cell margin/padding.
void | TAPAbstractType.setWCellPaddingDefaultBottom(short field_44_wCellPaddingDefaultBottom) Default bottom cell margin/padding.
void | TAPAbstractType.setWCellPaddingDefaultLeft(short field_43_wCellPaddingDefaultLeft) Default left cell margin/padding.
void | TAPAbstractType.setWCellPaddingDefaultRight(short field_45_wCellPaddingDefaultRight) Default right cell margin/padding.
void | TAPAbstractType.setWCellPaddingDefaultTop(short field_42_wCellPaddingDefaultTop) Default top cell margin/padding.
void | TCAbstractType.setWCellPaddingLeft(short field_4_wCellPaddingLeft) Left cell margin/padding.
void | TAPAbstractType.setWCellPaddingOuterBottom(short field_60_wCellPaddingOuterBottom) Default outer bottom cell margin/padding.
void | TAPAbstractType.setWCellPaddingOuterLeft(short field_59_wCellPaddingOuterLeft) Default outer left cell margin/padding.
void | TAPAbstractType.setWCellPaddingOuterRight(short field_61_wCellPaddingOuterRight) Default outer right cell margin/padding.
void | TAPAbstractType.setWCellPaddingOuterTop(short field_58_wCellPaddingOuterTop) Default outer top cell margin/padding.
void | TCAbstractType.setWCellPaddingRight(short field_7_wCellPaddingRight) Right cell margin/padding.
void | TCAbstractType.setWCellPaddingTop(short field_5_wCellPaddingTop) Top cell margin/padding.
void | TCAbstractType.setWCellSpacingBottom(short field_14_wCellSpacingBottom) Bottom cell spacing.
void | TAPAbstractType.setWCellSpacingDefaultBottom(short field_52_wCellSpacingDefaultBottom) Default bottom cell spacings.
void | TAPAbstractType.setWCellSpacingDefaultLeft(short field_51_wCellSpacingDefaultLeft) Default left cell spacings.
void | TAPAbstractType.setWCellSpacingDefaultRight(short field_53_wCellSpacingDefaultRight) Default right cell spacings.
void | TAPAbstractType.setWCellSpacingDefaultTop(short field_50_wCellSpacingDefaultTop) Default top cell spacings.
void | TCAbstractType.setWCellSpacingLeft(short field_12_wCellSpacingLeft) Left cell spacing.
void | TAPAbstractType.setWCellSpacingOuterBottom(short field_68_wCellSpacingOuterBottom) Default outer bottom cell spacing.
void | TAPAbstractType.setWCellSpacingOuterLeft(short field_67_wCellSpacingOuterLeft) Default outer left cell spacing.
void | TAPAbstractType.setWCellSpacingOuterRight(short field_69_wCellSpacingOuterRight) Default outer right cell spacing.
void | TAPAbstractType.setWCellSpacingOuterTop(short field_66_wCellSpacingOuterTop) Default outer top cell spacing.
void | TCAbstractType.setWCellSpacingRight(short field_15_wCellSpacingRight) Right cell spacing.
void | TCAbstractType.setWCellSpacingTop(short field_13_wCellSpacingTop) Top cell spacing.
void | CHPAbstractType.setWCharScale(int field_68_wCharScale) Set the wCharScale field for the CHP record.
void | CHPAbstractType.setWConflict(int field_56_wConflict) When != 0, index number that identifies all text participating in a particular conflict incident.
void | FibBaseAbstractType.setWIdent(int field_1_wIdent) An unsigned integer that specifies that this is a Word Binary File.
void | TAPAbstractType.setWidthAndFitsFlags_empty1(byte value) Sets the widthAndFitsFlags_empty1 field value.
void | TAPAbstractType.setWidthAndFitsFlags_empty2(short value) Sets the widthAndFitsFlags_empty2 field value.
void | TAPAbstractType.setWidthAndFitsFlags(int field_13_widthAndFitsFlags) Set the widthAndFitsFlags field for the TAP record.
void | PAPAbstractType.setWr(byte field_24_wr) Set the wr field for the PAP record.
void | FSPAAbstractType.setWr(byte value) Sets the wr field value.
void | FSPAAbstractType.setWrk(byte value) Sets the wrk field value.
void | DOPAbstractType.setWScaleSaved(short value) Sets the wScaleSaved field value.
void | DOPAbstractType.setWSpare(int field_10_wSpare) Set the wSpare field for the DOP record.
void | DOPAbstractType.setWSpare2(int field_13_wSpare2) Set the wSpare2 field for the DOP record.
void | DOPAbstractType.setWvkSaved(byte value) Sets the wvkSaved field value.
void | TCAbstractType.setWWidth(short field_2_wWidth) Preferred cell width.
void | TAPAbstractType.setWWidth(short field_9_wWidth) Preferred table width.
void | TAPAbstractType.setWWidthAfter(short field_12_wWidthAfter) Width of invisible cell (used for layout purposes) after the last visible cell in the row..
void | TAPAbstractType.setWWidthBefore(short field_11_wWidthBefore) Width of invisible cell (used for layout purposes) before the first visible cell in the row..
void | TAPAbstractType.setWWidthIndent(short field_10_wWidthIndent) Left Indent.
void | FSPAAbstractType.setXaLeft(int field_2_xaLeft) Left of rectangle enclosing shape relative to the origin of the shape.
void | FSPAAbstractType.setXaRight(int field_4_xaRight) Right of rectangle enclosing shape relative to the origin of the shape.
void | CHPAbstractType.setXchSym(int field_35_xchSym) When chp.fSpec==1 and the character recorded for the run in the document stream is chSymbol (0x28), the character stored chp.xchSym will be displayed using the font specified in chp.ftcSym..
void | PICFAbstractType.setXExt(short field_4_xExt) This field is unused and MUST be ignored.
void | CHPAbstractType.setXstDispFldRMark(byte[] field_62_xstDispFldRMark) The string value of the ListNum field when revision mark tracking began.
void | FSPAAbstractType.setYaBottom(int field_5_yaBottom) Bottom of the rectangle enclosing shape relative to the origin of the shape.
void | FSPAAbstractType.setYaTop(int field_3_yaTop) Top of rectangle enclosing shape relative to the origin of the shape.
void | PICFAbstractType.setYExt(short field_5_yExt) This field is unused and MUST be ignored.
void | DOPAbstractType.setZkSaved(byte value) Sets the zkSaved field value.

Uses of Internal in org.apache.poi.hwpf.sprm

Classes in org.apache.poi.hwpf.sprm with annotations of type Internal
class | CharacterSprmCompressor
class | CharacterSprmUncompressor
class | ParagraphSprmCompressor
class | ParagraphSprmUncompressor
class | SectionSprmCompressor
class | SectionSprmUncompressor
class | SprmBuffer
class | SprmIterator This class is used to iterate through a list of sprms from a Word 97/2000/XP document.
class | SprmOperation This class is used to represent a sprm operation from a Word 97/2000/XP document.
class | SprmUncompressor
class | SprmUtils
class | TableSprmCompressor
class | TableSprmUncompressor

Uses of Internal in org.apache.poi.hwpf.usermodel

Classes in org.apache.poi.hwpf.usermodel with annotations of type Internal
class | FieldsImpl Default implementation of Field
class | ObjectPoolImpl

Methods in org.apache.poi.hwpf.usermodel with annotations of type Internal
void | Range.replaceText(java.lang.String pPlaceHolder, java.lang.String pValue, int pOffset) Replace (one instance of) a piece of text with another...
void | ObjectPoolImpl.writeTo(DirectoryEntry directoryEntry)

Uses of Internal in org.apache.poi.poifs.filesystem

Classes in org.apache.poi.poifs.filesystem with annotations of type Internal
 class EntryUtils

Methods in org.apache.poi.poifs.filesystem with annotations of type Internal
static void EntryUtils.copyNodeRecursively(Entry entry, DirectoryEntry target)
Copies an Entry into a target POIFS directory, recursively

Uses of Internal in org.apache.poi.ss.util

Classes in org.apache.poi.ss.util with annotations of type Internal
 class SSCellRange<K extends Cell>
For POI internal use only

Uses of Internal in org.apache.poi.xslf

Methods in org.apache.poi.xslf with annotations of type Internal
org.openxmlformats.schemas.presentationml.x2006.main.CTNotesSlide | XSLFSlideShow.getNotes(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide) Returns the low level notes object for the given slide, as found from the supplied slide reference
org.openxmlformats.schemas.presentationml.x2006.main.CTPresentation | XSLFSlideShow.getPresentation() Returns the low level presentation base object
org.openxmlformats.schemas.presentationml.x2006.main.CTSlide | XSLFSlideShow.getSlide(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide) Returns the low level slide object from the supplied slide reference
org.openxmlformats.schemas.presentationml.x2006.main.CTCommentList | XSLFSlideShow.getSlideComments(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide) Returns all the comments for the given slide
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMaster | XSLFSlideShow.getSlideMaster(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdListEntry master) Returns the low level slide master object from the supplied slide master reference
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdList | XSLFSlideShow.getSlideMasterReferences() Returns the references from the presentation to its slide masters.
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdList | XSLFSlideShow.getSlideReferences() Returns the references from the presentation to its slides.

Uses of Internal in org.apache.poi.xslf.model

Classes in org.apache.poi.xslf.model with annotations of type Internal
 class PropertyFetcher<T>
Used internally to navigate the PresentationML text style hierarchy and fetch properties

Uses of Internal in org.apache.poi.xslf.usermodel

Classes in org.apache.poi.xslf.usermodel with annotations of type Internal
 class XSLFColor
Encapsulates logic to read color definitions from DrawingML and convert them to java.awt.Color

Methods in org.apache.poi.xslf.usermodel with annotations of type Internal
XSLFCommonSlideData | XSLFSheet.getCommonSlideData()
org.openxmlformats.schemas.presentationml.x2006.main.CTPresentation | XMLSlideShow.getCTPresentation()
org.openxmlformats.schemas.drawingml.x2006.main.CTTable | XSLFTable.getCTTable()
java.net.URI | XSLFHyperlink.getTargetURI()
org.openxmlformats.schemas.drawingml.x2006.main.CTOfficeStyleSheet | XSLFTheme.getXmlObject() While developing only!
org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraph | XSLFTextParagraph.getXmlObject()
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideLayout | XSLFSlideLayout.getXmlObject() While developing only!
org.openxmlformats.schemas.drawingml.x2006.main.CTHyperlink | XSLFHyperlink.getXmlObject()
org.apache.xmlbeans.XmlObject | XSLFColor.getXmlObject()

Uses of Internal in org.apache.poi.xssf.model

Classes in org.apache.poi.xssf.model with annotations of type Internal
 class IndexedUDFFinder
A UDFFinder that can retrieve functions both by name and by fake index.

Uses of Internal in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with annotations of type Internal
void | XSSFSheet.addHyperlink(XSSFHyperlink hyperlink) Register a hyperlink in the collection of hyperlinks on this sheet
CalculationChain | XSSFWorkbook.getCalculationChain() Return the CalculationChain object for this workbook
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf | XSSFCellStyle.getCoreXf() Used so that StylesSource can figure out our location
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCell | XSSFCell.getCTCell() Returns the xml bean containing information about the cell's location (reference), value, data type, formatting, and formula
org.openxmlformats.schemas.drawingml.x2006.chart.CTChart | XSSFChart.getCTChart() Return the underlying CTChart bean, within the Chart Space
org.openxmlformats.schemas.drawingml.x2006.chart.CTChartSpace | XSSFChart.getCTChartSpace() Return the underlying CTChartSpace bean, the root element of the SpreadsheetML Chart part.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTColor | XSSFColor.getCTColor() Returns the underlying XML bean
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector | XSSFConnector.getCTConnector()
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTDrawing | XSSFDrawing.getCTDrawing() Return the underlying CTDrawing bean, the root element of the SpreadsheetML Drawing part.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont | XSSFFont.getCTFont() get the underlying CTFont font
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame | XSSFGraphicFrame.getCTGraphicalObjectFrame()
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape | XSSFShapeGroup.getCTGroupShape()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMap | XSSFMap.getCtMap()
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture | XSSFPicture.getCTPicture() Return the underlying CTPicture bean that holds all properties for this picture
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRow | XSSFRow.getCTRow() Returns the underlying CTRow xml bean containing all cell definitions in this row
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst | XSSFRichTextString.getCTRst() Return the underlying xml bean
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSchema | XSSFMap.getCTSchema()
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape | XSSFSimpleShape.getCTShape()
org.openxmlformats.schemas.drawingml.x2006.main.CTTransform2D | XSSFChildAnchor.getCTTransform2D()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorkbook | XSSFWorkbook.getCTWorkbook() Return the underlying XML bean
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet | XSSFSheet.getCTWorksheet() Provide access to the CTWorksheet bean holding this sheet's data
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker | XSSFClientAnchor.getFrom() Return starting anchor point
MapInfo | XSSFWorkbook.getMapInfo()
SharedStringsTable | XSSFWorkbook.getSharedStringSource() Returns SharedStringsTable - tha cache of string for this workbook
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf | XSSFCellStyle.getStyleXf() Used so that StylesSource can figure out our location
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker | XSSFClientAnchor.getTo() Return ending anchor point

Uses of Internal in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts with annotations of type Internal
org.openxmlformats.schemas.drawingml.x2006.chart.CTLegend | XSSFChartLegend.getCTLegend() Return the underlying CTLegend bean.
org.openxmlformats.schemas.drawingml.x2006.chart.CTManualLayout | XSSFManualLayout.getCTManualLayout() Return the underlying CTManualLayout bean.

Uses of Internal in org.apache.poi.xssf.usermodel.extensions

Methods in org.apache.poi.xssf.usermodel.extensions with annotations of type Internal
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder | XSSFCellBorder.getCTBorder() Returns the underlying XML bean.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCellAlignment | XSSFCellAlignment.getCTCellAlignment() Access to low-level data
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFill | XSSFCellFill.getCTFill() Returns the underlying XML bean.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter | XSSFHeaderFooter.getHeaderFooter() Returns the underlying CTHeaderFooter xml bean

Uses of Internal in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel with annotations of type Internal
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr | XWPFHeaderFooter._getHdrFtr()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSdtBlock | TOC.getBlock()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP | XWPFParagraph.getCTP()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR | XWPFRun.getCTR() Get the currently used CTR object
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow | XWPFTableRow.getCtRow()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl | XWPFTable.getCTTbl()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc | XWPFTableCell.getCTTc()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTDocument1 | XWPFDocument.getDocument() Returns the low level document base object
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyles | XWPFDocument.getStyle() Returns the styles object used

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.IntList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.IntList

Packages that use IntList
org.apache.poi.util Top-level util package are classes that are useful throughout the project.

Uses of IntList in org.apache.poi.util

Methods in org.apache.poi.util with parameters of type IntList
boolean | IntList.addAll(int index, IntList c) Inserts all of the elements in the specified collection into this list at the specified position.
boolean | IntList.addAll(IntList c) Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
boolean | IntList.containsAll(IntList c) Returns true if this list contains all of the elements of the specified collection.
boolean | IntList.removeAll(IntList c) Removes from this list all the elements that are contained in the specified collection
boolean | IntList.retainAll(IntList c) Retains only the elements in this list that are contained in the specified collection.

Constructors in org.apache.poi.util with parameters of type IntList
IntList(IntList list)
create a copy of an existing IntList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.IntMapper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.IntMapper

No usage of org.apache.poi.util.IntMapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.IOUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.IOUtils

No usage of org.apache.poi.util.IOUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LittleEndian.BufferUnderrunException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LittleEndian.BufferUnderrunException

Packages that use LittleEndian.BufferUnderrunException
org.apache.poi.ddf | This package contains classes for decoding the Microsoft Office Drawing format otherwise known as escher henceforth known in POI as the Dreadful Drawing Format.
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.

Uses of LittleEndian.BufferUnderrunException in org.apache.poi.ddf

Methods in org.apache.poi.ddf that throw LittleEndian.BufferUnderrunException
 void EscherDump.dumpOld(long maxLength, java.io.InputStream in, java.io.PrintStream out)
This version of dump is a translation from the open office escher dump routine.

Uses of LittleEndian.BufferUnderrunException in org.apache.poi.util

Methods in org.apache.poi.util that throw LittleEndian.BufferUnderrunException
void | ShortField.readFromStream(java.io.InputStream stream) set the value from an InputStream
void | LongField.readFromStream(java.io.InputStream stream) set the value from an InputStream
void | IntegerField.readFromStream(java.io.InputStream stream) set the value from an InputStream
void | FixedField.readFromStream(java.io.InputStream stream) set the value from an InputStream
void | ByteField.readFromStream(java.io.InputStream stream) set the value from an InputStream
static int | LittleEndian.readInt(java.io.InputStream stream) get an int value from an InputStream
static long | LittleEndian.readLong(java.io.InputStream stream) get a long value from an InputStream
static short | LittleEndian.readShort(java.io.InputStream stream) get a short value from an InputStream
static int | LittleEndian.readUShort(java.io.InputStream stream)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LittleEndian

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LittleEndian

No usage of org.apache.poi.util.LittleEndian

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LittleEndianByteArrayInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LittleEndianByteArrayInputStream

No usage of org.apache.poi.util.LittleEndianByteArrayInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LittleEndianByteArrayOutputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LittleEndianByteArrayOutputStream

No usage of org.apache.poi.util.LittleEndianByteArrayOutputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.util.LittleEndianConsts

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.util.LittleEndianConsts

Packages that use LittleEndianConsts
org.apache.poi.util Top-level util package are classes that are useful throughout the project.

Uses of LittleEndianConsts in org.apache.poi.util

Classes in org.apache.poi.util that implement LittleEndianConsts
 class LittleEndian
a utility class for handling little-endian numbers, which the 80x86 world is replete with.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.util.LittleEndianInput

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.util.LittleEndianInput

Packages that use LittleEndianInput
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.crypto |
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.poifs.filesystem | filesystem package maps OLE 2 Compound document files to a more familiar filesystem interface.
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.constant |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.

Uses of LittleEndianInput in org.apache.poi.hssf.record

Classes in org.apache.poi.hssf.record that implement LittleEndianInput
 class RecordInputStream
Title: Record Input Stream

Methods in org.apache.poi.hssf.record with parameters of type LittleEndianInput
static SubRecord SubRecord.createSubRecord(LittleEndianInput in, int cmoOt)
read a sub-record from the supplied stream

Constructors in org.apache.poi.hssf.record with parameters of type LittleEndianInput
CommonObjectDataSubRecord(LittleEndianInput in, int size)
EmbeddedObjectRefSubRecord(LittleEndianInput in, int size)
EndSubRecord(LittleEndianInput in, int size)
FtCblsSubRecord(LittleEndianInput in, int size)
GroupMarkerSubRecord(LittleEndianInput in, int size)
LbsDataSubRecord.LbsDropData(LittleEndianInput in)
LbsDataSubRecord(LittleEndianInput in, int cbFContinued, int cmoOt)
NoteStructureSubRecord(LittleEndianInput in, int size)
Read the record data from the supplied RecordInputStream
SharedValueRecordBase(LittleEndianInput in)
reads only the range (1 CellRangeAddress8Bit) from the stream

Uses of LittleEndianInput in org.apache.poi.hssf.record.cf

Constructors in org.apache.poi.hssf.record.cf with parameters of type LittleEndianInput
BorderFormatting(LittleEndianInput in)
Creates new FontFormatting
PatternFormatting(LittleEndianInput in)
Creates new FontFormatting

Uses of LittleEndianInput in org.apache.poi.hssf.record.common

Constructors in org.apache.poi.hssf.record.common with parameters of type LittleEndianInput
UnicodeString.ExtRst(LittleEndianInput in, int expectedLength)
UnicodeString.FormatRun(LittleEndianInput in)

Uses of LittleEndianInput in org.apache.poi.hssf.record.cont

Classes in org.apache.poi.hssf.record.cont that implement LittleEndianInput
 class ContinuableRecordInput
A decorated RecordInputStream that can read primitive data types (short, int, long, etc.) spanned across a ContinueRecord boundary.

Uses of LittleEndianInput in org.apache.poi.hssf.record.crypto

Classes in org.apache.poi.hssf.record.crypto that implement LittleEndianInput
 class Biff8DecryptingStream

Uses of LittleEndianInput in org.apache.poi.hssf.util

Constructors in org.apache.poi.hssf.util with parameters of type LittleEndianInput
CellRangeAddress8Bit(LittleEndianInput in)

Uses of LittleEndianInput in org.apache.poi.poifs.filesystem

Classes in org.apache.poi.poifs.filesystem that implement LittleEndianInput
class | DocumentInputStream This class provides methods to read a DocumentEntry managed by a POIFSFileSystem or NPOIFSFileSystem instance.
class | NDocumentInputStream This class provides methods to read a DocumentEntry managed by a NPOIFSFileSystem instance.
class | ODocumentInputStream This class provides methods to read a DocumentEntry managed by a POIFSFileSystem instance.

Uses of LittleEndianInput in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula with parameters of type LittleEndianInput
static Formula Formula.read(int encodedTokenLen, LittleEndianInput in)
Convenience method for Formula.read(int, LittleEndianInput, int)
static Formula Formula.read(int encodedTokenLen, LittleEndianInput in, int totalEncodedLen)
When there are no array constants present, encodedTokenLen==totalEncodedLen

Uses of LittleEndianInput in org.apache.poi.ss.formula.constant

Methods in org.apache.poi.ss.formula.constant with parameters of type LittleEndianInput
static java.lang.Object[] ConstantValueParser.parse(LittleEndianInput in, int nValues)

Uses of LittleEndianInput in org.apache.poi.ss.formula.ptg

Methods in org.apache.poi.ss.formula.ptg with parameters of type LittleEndianInput
static FuncVarPtg | FuncVarPtg.create(LittleEndianInput in) Creates new function pointer from a byte array usually called while reading an excel file.
static FuncPtg | FuncPtg.create(LittleEndianInput in)
static Ptg | Ptg.createPtg(LittleEndianInput in)
static ErrPtg | ErrPtg.read(LittleEndianInput in)
static BoolPtg | BoolPtg.read(LittleEndianInput in)
protected void | RefPtgBase.readCoordinates(LittleEndianInput in)
protected void | AreaPtgBase.readCoordinates(LittleEndianInput in)
static Ptg[] | Ptg.readTokens(int size, LittleEndianInput in) Reads size bytes of the input stream, to create an array of Ptgs.

Constructors in org.apache.poi.ss.formula.ptg with parameters of type LittleEndianInput
Area2DPtgBase(LittleEndianInput in)
Area3DPtg(LittleEndianInput in)
AreaErrPtg(LittleEndianInput in)
AreaNPtg(LittleEndianInput in)
AreaPtg(LittleEndianInput in)
AttrPtg(LittleEndianInput in)
DeletedArea3DPtg(LittleEndianInput in)
DeletedRef3DPtg(LittleEndianInput in)
Creates new DeletedRef3DPtg
ExpPtg(LittleEndianInput in)
IntPtg(LittleEndianInput in)
MemAreaPtg(LittleEndianInput in)
MemErrPtg(LittleEndianInput in)
MemFuncPtg(LittleEndianInput in)
Creates new function pointer from a byte array usually called while reading an excel file.
NamePtg(LittleEndianInput in)
Creates new NamePtg
NameXPtg(LittleEndianInput in)
NumberPtg(LittleEndianInput in)
Ref3DPtg(LittleEndianInput in)
RefErrorPtg(LittleEndianInput in)
RefNPtg(LittleEndianInput in)
RefPtg(LittleEndianInput in)
StringPtg(LittleEndianInput in)
Create a StringPtg from a stream
TblPtg(LittleEndianInput in)

Uses of LittleEndianInput in org.apache.poi.util

Classes in org.apache.poi.util that implement LittleEndianInput
class | LittleEndianByteArrayInputStream Adapts a plain byte array to LittleEndianInput
class | LittleEndianInputStream Wraps an InputStream providing LittleEndianInput This class does not buffer any input, so the stream read position maintained by this class is consistent with that of the inner stream.

Methods in org.apache.poi.util with parameters of type LittleEndianInput
static java.lang.String | StringUtil.readCompressedUnicode(LittleEndianInput in, int nChars)
static java.lang.String | StringUtil.readUnicodeLE(LittleEndianInput in, int nChars)
static java.lang.String | StringUtil.readUnicodeString(LittleEndianInput in) InputStream in is expected to contain: ushort nChars byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
static java.lang.String | StringUtil.readUnicodeString(LittleEndianInput in, int nChars) InputStream in is expected to contain: byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LittleEndianInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LittleEndianInputStream

No usage of org.apache.poi.util.LittleEndianInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.util.LittleEndianOutput

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.util.LittleEndianOutput

Packages that use LittleEndianOutput
org.apache.poi.hssf.record | Record package contains class representations for XLS binary strutures.
org.apache.poi.hssf.record.cf |
org.apache.poi.hssf.record.chart |
org.apache.poi.hssf.record.common |
org.apache.poi.hssf.record.cont |
org.apache.poi.hssf.record.pivottable |
org.apache.poi.hssf.util | util package contains tools needed for writing HSSF files that are not necesarily "real" HSSF concepts.
org.apache.poi.ss.formula | This package contains common internal POI code for manipulating formulas.
org.apache.poi.ss.formula.constant |
org.apache.poi.ss.formula.ptg | formula package contains binary PTG structures used in Formulas
org.apache.poi.ss.util |
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.

Uses of LittleEndianOutput in org.apache.poi.hssf.record

Methods in org.apache.poi.hssf.record with parameters of type LittleEndianOutput
void | WSBoolRecord.serialize(LittleEndianOutput out)
void | WriteProtectRecord.serialize(LittleEndianOutput out)
void | WriteAccessRecord.serialize(LittleEndianOutput out)
void | WindowTwoRecord.serialize(LittleEndianOutput out)
void | WindowProtectRecord.serialize(LittleEndianOutput out)
void | WindowOneRecord.serialize(LittleEndianOutput out)
void | VCenterRecord.serialize(LittleEndianOutput out)
void | UseSelFSRecord.serialize(LittleEndianOutput out)
void | UserSViewEnd.serialize(LittleEndianOutput out) spit the record out AS IS.
void | UserSViewBegin.serialize(LittleEndianOutput out) spit the record out AS IS.
void | UnknownRecord.serialize(LittleEndianOutput out) spit the record out AS IS.
void | UncalcedRecord.serialize(LittleEndianOutput out)
void | TopMarginRecord.serialize(LittleEndianOutput out)
protected void | TableStylesRecord.serialize(LittleEndianOutput out)
void | TabIdRecord.serialize(LittleEndianOutput out)
void | SupBookRecord.serialize(LittleEndianOutput out)
abstract void | SubRecord.serialize(LittleEndianOutput out)
void | StyleRecord.serialize(LittleEndianOutput out)
protected abstract void | StandardRecord.serialize(LittleEndianOutput out) Write the data content of this BIFF record.
void | SharedValueRecordBase.serialize(LittleEndianOutput out)
void | SelectionRecord.serialize(LittleEndianOutput out)
void | SCLRecord.serialize(LittleEndianOutput out)
void | ScenarioProtectRecord.serialize(LittleEndianOutput out)
void | SaveRecalcRecord.serialize(LittleEndianOutput out)
void | RowRecord.serialize(LittleEndianOutput out)
void | RightMarginRecord.serialize(LittleEndianOutput out)
void | RefreshAllRecord.serialize(LittleEndianOutput out)
void | RefModeRecord.serialize(LittleEndianOutput out)
void | RecalcIdRecord.serialize(LittleEndianOutput out)
void | ProtectRecord.serialize(LittleEndianOutput out)
void | ProtectionRev4Record.serialize(LittleEndianOutput out)
void | PrintSetupRecord.serialize(LittleEndianOutput out)
void | PrintHeadersRecord.serialize(LittleEndianOutput out)
void | PrintGridlinesRecord.serialize(LittleEndianOutput out)
void | PrecisionRecord.serialize(LittleEndianOutput out)
void | PasswordRev4Record.serialize(LittleEndianOutput out)
void | PasswordRecord.serialize(LittleEndianOutput out)
void | PaneRecord.serialize(LittleEndianOutput out)
void | PaletteRecord.serialize(LittleEndianOutput out)
void | PageBreakRecord.serialize(LittleEndianOutput out)
void | PageBreakRecord.Break.serialize(LittleEndianOutput out)
void | ObjectProtectRecord.serialize(LittleEndianOutput out)
void | NoteStructureSubRecord.serialize(LittleEndianOutput out) Serialize the record data into the supplied array of bytes
void | NoteRecord.serialize(LittleEndianOutput out)
void | NameCommentRecord.serialize(LittleEndianOutput out)
void | MulRKRecord.serialize(LittleEndianOutput out)
void | MulBlankRecord.serialize(LittleEndianOutput out)
void | MMSRecord.serialize(LittleEndianOutput out)
void | MergeCellsRecord.serialize(LittleEndianOutput out)
void | LeftMarginRecord.serialize(LittleEndianOutput out)
void | LbsDataSubRecord.serialize(LittleEndianOutput out)
void | LbsDataSubRecord.LbsDropData.serialize(LittleEndianOutput out)
void | IterationRecord.serialize(LittleEndianOutput out)
void | InterfaceHdrRecord.serialize(LittleEndianOutput out)
void | InterfaceEndRecord.serialize(LittleEndianOutput out)
void | IndexRecord.serialize(LittleEndianOutput out)
void | HyperlinkRecord.serialize(LittleEndianOutput out)
void | HideObjRecord.serialize(LittleEndianOutput out)
void | HeaderFooterRecord.serialize(LittleEndianOutput out) spit the record out AS IS.
void | HeaderFooterBase.serialize(LittleEndianOutput out)
void | HCenterRecord.serialize(LittleEndianOutput out)
void | GutsRecord.serialize(LittleEndianOutput out)
void | GroupMarkerSubRecord.serialize(LittleEndianOutput out)
void | GridsetRecord.serialize(LittleEndianOutput out)
void | FtCblsSubRecord.serialize(LittleEndianOutput out) Serialize the record data into the supplied array of bytes
void | FormatRecord.serialize(LittleEndianOutput out)
void | FontRecord.serialize(LittleEndianOutput out)
void | FnGroupCountRecord.serialize(LittleEndianOutput out)
void | FileSharingRecord.serialize(LittleEndianOutput out)
void | FilePassRecord.serialize(LittleEndianOutput out)
void | FeatRecord.serialize(LittleEndianOutput out)
void | FeatHdrRecord.serialize(LittleEndianOutput out)
void | ExtSSTRecord.InfoSubRecord.serialize(LittleEndianOutput out)
void | ExternSheetRecord.serialize(LittleEndianOutput out)
void | ExternalNameRecord.serialize(LittleEndianOutput out)
void | ExtendedFormatRecord.serialize(LittleEndianOutput out)
void | EOFRecord.serialize(LittleEndianOutput out)
void | EndSubRecord.serialize(LittleEndianOutput out)
void | EmbeddedObjectRefSubRecord.serialize(LittleEndianOutput out)
void | DVRecord.serialize(LittleEndianOutput out)
void | DVALRecord.serialize(LittleEndianOutput out)
void | DSFRecord.serialize(LittleEndianOutput out)
void | DrawingSelectionRecord.serialize(LittleEndianOutput out)
void | DrawingRecord.serialize(LittleEndianOutput out)
void | DimensionsRecord.serialize(LittleEndianOutput out)
void | DeltaRecord.serialize(LittleEndianOutput out)
void | DefaultRowHeightRecord.serialize(LittleEndianOutput out)
void | DefaultColWidthRecord.serialize(LittleEndianOutput out)
protected void | DConRefRecord.serialize(LittleEndianOutput out)
void | DBCellRecord.serialize(LittleEndianOutput out)
void | DateWindow1904Record.serialize(LittleEndianOutput out)
void | CRNRecord.serialize(LittleEndianOutput out)
void | CRNCountRecord.serialize(LittleEndianOutput out)
void | CountryRecord.serialize(LittleEndianOutput out)
void | ContinueRecord.serialize(LittleEndianOutput out)
void | CommonObjectDataSubRecord.serialize(LittleEndianOutput out)
void | ColumnInfoRecord.serialize(LittleEndianOutput out)
void | CodepageRecord.serialize(LittleEndianOutput out)
void | CFRuleRecord.serialize(LittleEndianOutput out) called by the class that is responsible for writing this sucker.
void | CFHeaderRecord.serialize(LittleEndianOutput out)
void | CellRecord.serialize(LittleEndianOutput out)
void | CalcModeRecord.serialize(LittleEndianOutput out)
void | CalcCountRecord.serialize(LittleEndianOutput out)
void | BoundSheetRecord.serialize(LittleEndianOutput out)
void | BottomMarginRecord.serialize(LittleEndianOutput out)
void | BookBoolRecord.serialize(LittleEndianOutput out)
void | BOFRecord.serialize(LittleEndianOutput out)
void | BlankRecord.serialize(LittleEndianOutput out)
void | BackupRecord.serialize(LittleEndianOutput out)
void | AutoFilterInfoRecord.serialize(LittleEndianOutput out)
protected void | TableRecord.serializeExtraData(LittleEndianOutput out)
protected abstract void | SharedValueRecordBase.serializeExtraData(LittleEndianOutput out)
protected void | SharedFormulaRecord.serializeExtraData(LittleEndianOutput out)
protected void | ArrayRecord.serializeExtraData(LittleEndianOutput out)
protected void | RKRecord.serializeValue(LittleEndianOutput out)
protected void | NumberRecord.serializeValue(LittleEndianOutput out)
protected void | LabelSSTRecord.serializeValue(LittleEndianOutput out)
protected void | FormulaRecord.serializeValue(LittleEndianOutput out)
protected abstract void | CellRecord.serializeValue(LittleEndianOutput out) writes out the value data for this cell record
protected void | BoolErrRecord.serializeValue(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.hssf.record.cf

Methods in org.apache.poi.hssf.record.cf with parameters of type LittleEndianOutput
void | PatternFormatting.serialize(LittleEndianOutput out)
void | BorderFormatting.serialize(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.hssf.record.chart

Methods in org.apache.poi.hssf.record.chart with parameters of type LittleEndianOutput
void | ValueRangeRecord.serialize(LittleEndianOutput out)
void | UnitsRecord.serialize(LittleEndianOutput out)
void | TickRecord.serialize(LittleEndianOutput out)
void | TextRecord.serialize(LittleEndianOutput out)
void | SheetPropertiesRecord.serialize(LittleEndianOutput out)
void | SeriesToChartGroupRecord.serialize(LittleEndianOutput out)
void | SeriesTextRecord.serialize(LittleEndianOutput out)
void | SeriesRecord.serialize(LittleEndianOutput out)
void | SeriesListRecord.serialize(LittleEndianOutput out)
void | SeriesLabelsRecord.serialize(LittleEndianOutput out)
void | SeriesIndexRecord.serialize(LittleEndianOutput out)
void | SeriesChartGroupIndexRecord.serialize(LittleEndianOutput out)
void | PlotGrowthRecord.serialize(LittleEndianOutput out)
void | PlotAreaRecord.serialize(LittleEndianOutput out)
void | ObjectLinkRecord.serialize(LittleEndianOutput out)
void | NumberFormatIndexRecord.serialize(LittleEndianOutput out)
void | LinkedDataRecord.serialize(LittleEndianOutput out)
void | LineFormatRecord.serialize(LittleEndianOutput out)
void | LegendRecord.serialize(LittleEndianOutput out)
void | FrameRecord.serialize(LittleEndianOutput out)
void | FontIndexRecord.serialize(LittleEndianOutput out)
void | FontBasisRecord.serialize(LittleEndianOutput out)
void | EndRecord.serialize(LittleEndianOutput out)
void | DefaultDataLabelTextPropertiesRecord.serialize(LittleEndianOutput out)
void | DatRecord.serialize(LittleEndianOutput out)
protected void | DataLabelExtensionRecord.serialize(LittleEndianOutput out)
void | DataFormatRecord.serialize(LittleEndianOutput out)
void | ChartTitleFormatRecord.serialize(LittleEndianOutput out)
void | ChartStartObjectRecord.serialize(LittleEndianOutput out)
void | ChartStartBlockRecord.serialize(LittleEndianOutput out)
void | ChartRecord.serialize(LittleEndianOutput out)
void | ChartFRTInfoRecord.serialize(LittleEndianOutput out)
void | ChartFormatRecord.serialize(LittleEndianOutput out)
void | ChartEndObjectRecord.serialize(LittleEndianOutput out)
void | ChartEndBlockRecord.serialize(LittleEndianOutput out)
void | CatLabRecord.serialize(LittleEndianOutput out)
void | CategorySeriesAxisRecord.serialize(LittleEndianOutput out)
void | BeginRecord.serialize(LittleEndianOutput out)
void | BarRecord.serialize(LittleEndianOutput out)
void | AxisUsedRecord.serialize(LittleEndianOutput out)
void | AxisRecord.serialize(LittleEndianOutput out)
void | AxisParentRecord.serialize(LittleEndianOutput out)
void | AxisOptionsRecord.serialize(LittleEndianOutput out)
void | AxisLineFormatRecord.serialize(LittleEndianOutput out)
void | AreaRecord.serialize(LittleEndianOutput out)
void | AreaFormatRecord.serialize(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.hssf.record.common

Methods in org.apache.poi.hssf.record.common with parameters of type LittleEndianOutput
void | UnicodeString.FormatRun.serialize(LittleEndianOutput out)
void | SharedFeature.serialize(LittleEndianOutput out)
void | FtrHeader.serialize(LittleEndianOutput out)
void | FeatSmartTag.serialize(LittleEndianOutput out)
void | FeatProtection.serialize(LittleEndianOutput out)
void | FeatFormulaErr2.serialize(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.hssf.record.cont

Classes in org.apache.poi.hssf.record.cont that implement LittleEndianOutput
 class ContinuableRecordOutput
An augmented LittleEndianOutput used for serialization of ContinuableRecords.

Constructors in org.apache.poi.hssf.record.cont with parameters of type LittleEndianOutput
ContinuableRecordOutput(LittleEndianOutput out, int sid)

Uses of LittleEndianOutput in org.apache.poi.hssf.record.pivottable

Methods in org.apache.poi.hssf.record.pivottable with parameters of type LittleEndianOutput
protected void | ViewSourceRecord.serialize(LittleEndianOutput out)
protected void | ViewFieldsRecord.serialize(LittleEndianOutput out)
protected void | ViewDefinitionRecord.serialize(LittleEndianOutput out)
protected void | StreamIDRecord.serialize(LittleEndianOutput out)
protected void | PageItemRecord.serialize(LittleEndianOutput out)
protected void | ExtendedPivotTableViewFieldsRecord.serialize(LittleEndianOutput out)
protected void | DataItemRecord.serialize(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.hssf.util

Methods in org.apache.poi.hssf.util with parameters of type LittleEndianOutput
 void CellRangeAddress8Bit.serialize(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.ss.formula

Methods in org.apache.poi.ss.formula with parameters of type LittleEndianOutput
void | Formula.serialize(LittleEndianOutput out) Writes The formula encoding is includes: ushort tokenDataLen tokenData arrayConstantData (if present)
void | Formula.serializeArrayConstantData(LittleEndianOutput out)
void | Formula.serializeTokens(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.ss.formula.constant

Methods in org.apache.poi.ss.formula.constant with parameters of type LittleEndianOutput
static void ConstantValueParser.encode(LittleEndianOutput out, java.lang.Object[] values)

Uses of LittleEndianOutput in org.apache.poi.ss.formula.ptg

Methods in org.apache.poi.ss.formula.ptg with parameters of type LittleEndianOutput
void | ValueOperatorPtg.write(LittleEndianOutput out)
void | UnknownPtg.write(LittleEndianOutput out)
void | UnionPtg.write(LittleEndianOutput out)
void | TblPtg.write(LittleEndianOutput out)
void | StringPtg.write(LittleEndianOutput out)
void | RefErrorPtg.write(LittleEndianOutput out)
void | Ref3DPtg.write(LittleEndianOutput out)
void | RangePtg.write(LittleEndianOutput out)
abstract void | Ptg.write(LittleEndianOutput out)
void | ParenthesisPtg.write(LittleEndianOutput out)
void | NumberPtg.write(LittleEndianOutput out)
void | NameXPtg.write(LittleEndianOutput out)
void | NamePtg.write(LittleEndianOutput out)
void | MissingArgPtg.write(LittleEndianOutput out)
void | MemFuncPtg.write(LittleEndianOutput out)
void | MemErrPtg.write(LittleEndianOutput out)
void | MemAreaPtg.write(LittleEndianOutput out)
void | IntPtg.write(LittleEndianOutput out)
void | IntersectionPtg.write(LittleEndianOutput out)
void | FuncVarPtg.write(LittleEndianOutput out)
void | FuncPtg.write(LittleEndianOutput out)
void | ExpPtg.write(LittleEndianOutput out)
void | ErrPtg.write(LittleEndianOutput out)
void | DeletedRef3DPtg.write(LittleEndianOutput out)
void | DeletedArea3DPtg.write(LittleEndianOutput out)
void | BoolPtg.write(LittleEndianOutput out)
void | AttrPtg.write(LittleEndianOutput out)
void | ArrayPtg.write(LittleEndianOutput out)
void | AreaErrPtg.write(LittleEndianOutput out)
void | Area3DPtg.write(LittleEndianOutput out)
void | Area2DPtgBase.write(LittleEndianOutput out)
protected void | RefPtgBase.writeCoordinates(LittleEndianOutput out)
protected void | AreaPtgBase.writeCoordinates(LittleEndianOutput out)
int | ArrayPtg.writeTokenValueBytes(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.ss.util

Methods in org.apache.poi.ss.util with parameters of type LittleEndianOutput
void | CellRangeAddressList.serialize(LittleEndianOutput out)
void | CellRangeAddress.serialize(LittleEndianOutput out)

Uses of LittleEndianOutput in org.apache.poi.util

Subinterfaces of LittleEndianOutput in org.apache.poi.util
 interface DelayableLittleEndianOutput
Implementors of this interface allow client code to 'delay' writing to a certain section of a data output stream.
A typical application is for writing BIFF records when the size is not known until well after the header has been written.

Classes in org.apache.poi.util that implement LittleEndianOutput
class | LittleEndianByteArrayOutputStream Adapts a plain byte array to LittleEndianOutput
class | LittleEndianOutputStream

Methods in org.apache.poi.util that return LittleEndianOutput
LittleEndianOutput | LittleEndianByteArrayOutputStream.createDelayedOutput(int size)
LittleEndianOutput | DelayableLittleEndianOutput.createDelayedOutput(int size) Creates an output stream intended for outputting a sequence of size bytes.

Methods in org.apache.poi.util with parameters of type LittleEndianOutput
static void | StringUtil.putCompressedUnicode(java.lang.String input, LittleEndianOutput out)
static void | StringUtil.putUnicodeLE(java.lang.String input, LittleEndianOutput out)
static void | StringUtil.writeUnicodeString(LittleEndianOutput out, java.lang.String value) OutputStream out will get: ushort nChars byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.
static void | StringUtil.writeUnicodeStringFlagAndData(LittleEndianOutput out, java.lang.String value) OutputStream out will get: byte is16BitFlag byte[]/char[] characterData For this encoding, the is16BitFlag is always present even if nChars==0.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LittleEndianOutputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LittleEndianOutputStream

No usage of org.apache.poi.util.LittleEndianOutputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LongField

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LongField

No usage of org.apache.poi.util.LongField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.LZWDecompresser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.LZWDecompresser

Packages that use LZWDecompresser
org.apache.poi.hdgf
org.apache.poi.hmef

Uses of LZWDecompresser in org.apache.poi.hdgf

Subclasses of LZWDecompresser in org.apache.poi.hdgf
 class HDGFLZW
A decoder for the crazy LZW implementation used in Visio.

Uses of LZWDecompresser in org.apache.poi.hmef

Subclasses of LZWDecompresser in org.apache.poi.hmef
 class CompressedRTF
Within a HMEFMessage, the content is often stored in as RTF, but LZW compressed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.NullLogger

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.NullLogger

No usage of org.apache.poi.util.NullLogger

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.OOXMLLite

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.OOXMLLite

No usage of org.apache.poi.util.OOXMLLite

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.PackageHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.PackageHelper

No usage of org.apache.poi.util.PackageHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.POILogFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.POILogFactory

No usage of org.apache.poi.util.POILogFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.POILogger

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.POILogger

Packages that use POILogger
org.apache.poi.hslf.blip |
org.apache.poi.hslf.model |
org.apache.poi.hslf.record |
org.apache.poi.hslf.usermodel |
org.apache.poi.hwpf.model |
org.apache.poi.util | Top-level util package are classes that are useful throughout the project.

Uses of POILogger in org.apache.poi.hslf.blip

Fields in org.apache.poi.hslf.blip declared as POILogger
protected  POILogger BitmapPainter.logger

Uses of POILogger in org.apache.poi.hslf.model

Fields in org.apache.poi.hslf.model declared as POILogger
protected POILogger | PPGraphics2D.log
protected POILogger | TextPainter.logger
protected static POILogger | ShapePainter.logger
protected static POILogger | ShapeFactory.logger
protected POILogger | Shape.logger
protected POILogger | Fill.logger

Uses of POILogger in org.apache.poi.hslf.record

Fields in org.apache.poi.hslf.record declared as POILogger
protected  POILogger Record.logger

Uses of POILogger in org.apache.poi.hslf.usermodel

Fields in org.apache.poi.hslf.usermodel declared as POILogger
protected POILogger | RichTextRun.logger
protected POILogger | PictureData.logger

Uses of POILogger in org.apache.poi.hwpf.model

Fields in org.apache.poi.hwpf.model declared as POILogger
static POILogger FileInformationBlock.logger

Uses of POILogger in org.apache.poi.util

Subclasses of POILogger in org.apache.poi.util
class | CommonsLogger A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
class | NullLogger A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.
class | SystemOutLogger A logger class that strives to make it as easy as possible for developers to write log calls, while simultaneously making those calls as cheap as possible by performing lazy evaluation of the log message.

Methods in org.apache.poi.util that return POILogger
static POILogger | POILogFactory.getLogger(java.lang.Class theclass) Get a logger, based on a class name
static POILogger | POILogFactory.getLogger(java.lang.String cat) Get a logger, based on a String

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.RecordFormatException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.RecordFormatException

Packages that use RecordFormatException
org.apache.poi.hssf.record Record package contains class representations for XLS binary strutures.

Uses of RecordFormatException in org.apache.poi.hssf.record

Subclasses of RecordFormatException in org.apache.poi.hssf.record
 class RecordFormatException
Title: Record Format Exception Description: Used by records to indicate invalid format/data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.ShortField

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.ShortField

No usage of org.apache.poi.util.ShortField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.ShortList

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.ShortList

Packages that use ShortList
org.apache.poi.util Top-level util package are classes that are useful throughout the project.

Uses of ShortList in org.apache.poi.util

Methods in org.apache.poi.util with parameters of type ShortList
boolean | ShortList.addAll(int index, ShortList c) Inserts all of the elements in the specified collection into this list at the specified position.
boolean | ShortList.addAll(ShortList c) Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
boolean | ShortList.containsAll(ShortList c) Returns true if this list contains all of the elements of the specified collection.
boolean | ShortList.removeAll(ShortList c) Removes from this list all the elements that are contained in the specified collection
boolean | ShortList.retainAll(ShortList c) Retains only the elements in this list that are contained in the specified collection.

Constructors in org.apache.poi.util with parameters of type ShortList
ShortList(ShortList list)
create a copy of an existing ShortList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.StringUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.StringUtil

No usage of org.apache.poi.util.StringUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.StringUtil.StringsIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.StringUtil.StringsIterator

Packages that use StringUtil.StringsIterator
org.apache.poi.hsmf.extractor

Uses of StringUtil.StringsIterator in org.apache.poi.hsmf.extractor

Methods in org.apache.poi.hsmf.extractor with parameters of type StringUtil.StringsIterator
protected  void OutlookTextExtactor.handleEmails(java.lang.StringBuffer s, java.lang.String type, java.lang.String displayText, StringUtil.StringsIterator emails)
Takes a Display focused string, eg "Nick; Jim" and an iterator of emails, and does its best to return something like "Nick ; Jim "

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.SystemOutLogger

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.SystemOutLogger

No usage of org.apache.poi.util.SystemOutLogger

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.TempFile

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.TempFile

No usage of org.apache.poi.util.TempFile

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.util.Units

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.util.Units

No usage of org.apache.poi.util.Units

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xslf
Classes
XSLFSlideShow


org.apache.poi.xslf

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xslf

Class Summary
XSLFSlideShow Experimental class to do low level processing of pptx files.


org.apache.poi.xslf Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xslf

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POIXMLDocumentPart
      • org.apache.poi.POIXMLDocument
        • org.apache.poi.xslf.XSLFSlideShow


Uses of Package org.apache.poi.xslf

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xslf

Packages that use org.apache.poi.xslf
org.apache.poi.xslf.extractor
org.apache.poi.xslf.usermodel

Classes in org.apache.poi.xslf used by org.apache.poi.xslf.extractor
XSLFSlideShow
Experimental class to do low level processing of pptx files.

Classes in org.apache.poi.xslf used by org.apache.poi.xslf.usermodel
XSLFSlideShow
Experimental class to do low level processing of pptx files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSLFSlideShow

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf
Class XSLFSlideShow

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.POIXMLDocument
            extended by  org.apache.poi.xslf.XSLFSlideShow

public class XSLFSlideShow
extends POIXMLDocument

Experimental class to do low level processing of pptx files. Most users should use the higher level XMLSlideShow instead. If you are using these low level classes, then you will almost certainly need to refer to the OOXML specifications from http://www.ecma-international.org/publications/standards/Ecma-376.htm WARNING - APIs expected to change rapidly

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocument
DOCUMENT_CREATOR, OLE_OBJECT_REL_TYPE, PACK_OBJECT_REL_TYPE
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XSLFSlideShow(OPCPackage container)
XSLFSlideShow(java.lang.String file)
Method Summary
java.util.List<PackagePart> | getAllEmbedds() Get the document's embedded files.
PackagePart | getNodesPart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry parentSlide) Gets the PackagePart of the notes for the given slide, or null if there isn't one.
org.openxmlformats.schemas.presentationml.x2006.main.CTNotesSlide | getNotes(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide) Returns the low level notes object for the given slide, as found from the supplied slide reference
org.openxmlformats.schemas.presentationml.x2006.main.CTPresentation | getPresentation() Returns the low level presentation base object
org.openxmlformats.schemas.presentationml.x2006.main.CTSlide | getSlide(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide) Returns the low level slide object from the supplied slide reference
org.openxmlformats.schemas.presentationml.x2006.main.CTCommentList | getSlideComments(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide) Returns all the comments for the given slide
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMaster | getSlideMaster(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdListEntry master) Returns the low level slide master object from the supplied slide master reference
PackagePart | getSlideMasterPart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdListEntry master)
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdList | getSlideMasterReferences() Returns the references from the presentation to its slide masters.
PackagePart | getSlidePart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide)
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdList | getSlideReferences() Returns the references from the presentation to its slides.
Methods inherited from class org.apache.poi.POIXMLDocument
getCorePart, getPackage, getProperties, getRelatedByType, hasOOXMLHeader, load, openPackage, write
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSLFSlideShow

public XSLFSlideShow(OPCPackage container)
              throws OpenXML4JException,
                     java.io.IOException,
                     org.apache.xmlbeans.XmlException
Throws:
OpenXML4JException
java.io.IOException
org.apache.xmlbeans.XmlException

XSLFSlideShow

public XSLFSlideShow(java.lang.String file)
              throws OpenXML4JException,
                     java.io.IOException,
                     org.apache.xmlbeans.XmlException
Throws:
OpenXML4JException
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getPresentation

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTPresentation getPresentation()
Returns the low level presentation base object

getSlideReferences

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdList getSlideReferences()
Returns the references from the presentation to its slides. You'll need these to figure out the slide ordering, and to get at the actual slides themselves

getSlideMasterReferences

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdList getSlideMasterReferences()
Returns the references from the presentation to its slide masters. You'll need these to get at the actual slide masters themselves

getSlideMasterPart

public PackagePart getSlideMasterPart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdListEntry master)
                               throws java.io.IOException,
                                      org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getSlideMaster

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMaster getSlideMaster(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMasterIdListEntry master)
                                                                                throws java.io.IOException,
                                                                                org.apache.xmlbeans.XmlException
Returns the low level slide master object from the supplied slide master reference

Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getSlidePart

public PackagePart getSlidePart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide)
                         throws java.io.IOException,
                                org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getSlide

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTSlide getSlide(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide)
                                                                      throws java.io.IOException,
                                                                             org.apache.xmlbeans.XmlException
Returns the low level slide object from the supplied slide reference

Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getNodesPart

public PackagePart getNodesPart(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry parentSlide)
                         throws java.io.IOException,
                                org.apache.xmlbeans.XmlException
Gets the PackagePart of the notes for the given slide, or null if there isn't one.

Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getNotes

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTNotesSlide getNotes(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide)
                                                                           throws java.io.IOException,
                                                                                org.apache.xmlbeans.XmlException
Returns the low level notes object for the given slide, as found from the supplied slide reference

Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getSlideComments

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTCommentList getSlideComments(org.openxmlformats.schemas.presentationml.x2006.main.CTSlideIdListEntry slide)
                                                                                throws java.io.IOException,
                                                                                org.apache.xmlbeans.XmlException
Returns all the comments for the given slide

Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getAllEmbedds

public java.util.List<PackagePart> getAllEmbedds()
                                          throws OpenXML4JException
Get the document's embedded files.

Specified by:
getAllEmbedds in class POIXMLDocument
Throws:
OpenXML4JException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xslf.XSLFSlideShow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.XSLFSlideShow

Packages that use XSLFSlideShow
org.apache.poi.xslf.extractor
org.apache.poi.xslf.usermodel

Uses of XSLFSlideShow in org.apache.poi.xslf.extractor

Constructors in org.apache.poi.xslf.extractor with parameters of type XSLFSlideShow
XSLFPowerPointExtractor(XSLFSlideShow slideshow)

Uses of XSLFSlideShow in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFSlideShow
 XSLFSlideShow XMLSlideShow._getXSLFSlideShow()
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xslf.extractor
Classes
XSLFPowerPointExtractor


org.apache.poi.xslf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xslf.extractor

Class Summary
XSLFPowerPointExtractor


org.apache.poi.xslf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xslf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIXMLTextExtractor
        • org.apache.poi.xslf.extractor.XSLFPowerPointExtractor


Uses of Package org.apache.poi.xslf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xslf.extractor

No usage of org.apache.poi.xslf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSLFPowerPointExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.extractor
Class XSLFPowerPointExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIXMLTextExtractor
            extended by  org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

public class XSLFPowerPointExtractor
extends POIXMLTextExtractor

Field Summary
static XSLFRelation[] SUPPORTED_TYPES
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
XSLFPowerPointExtractor(OPCPackage container)
XSLFPowerPointExtractor(XMLSlideShow slideshow)
XSLFPowerPointExtractor(XSLFSlideShow slideshow)
Method Summary
java.lang.String | getText() Gets the slide text, but not the notes text
java.lang.String | getText(boolean slideText, boolean notesText) Gets the requested text from the file
java.lang.String | getText(boolean slideText, boolean notesText, boolean masterText) Gets the requested text from the file
static void | main(java.lang.String[] args)
void | setMasterByDefault(boolean masterByDefault) Should a call to getText() return text from master? Default is no
void | setNotesByDefault(boolean notesByDefault) Should a call to getText() return notes text? Default is no
void | setSlidesByDefault(boolean slidesByDefault) Should a call to getText() return slide text? Default is yes
Methods inherited from class org.apache.poi.POIXMLTextExtractor
getCoreProperties, getCustomProperties, getDocument, getExtendedProperties, getMetadataTextExtractor, getPackage
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SUPPORTED_TYPES

public static final XSLFRelation[] SUPPORTED_TYPES
Constructor Detail

XSLFPowerPointExtractor

public XSLFPowerPointExtractor(XMLSlideShow slideshow)

XSLFPowerPointExtractor

public XSLFPowerPointExtractor(XSLFSlideShow slideshow)
                        throws org.apache.xmlbeans.XmlException,
                               java.io.IOException
Throws:
org.apache.xmlbeans.XmlException
java.io.IOException

XSLFPowerPointExtractor

public XSLFPowerPointExtractor(OPCPackage container)
                        throws org.apache.xmlbeans.XmlException,
                               OpenXML4JException,
                               java.io.IOException
Throws:
org.apache.xmlbeans.XmlException
OpenXML4JException
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

setSlidesByDefault

public void setSlidesByDefault(boolean slidesByDefault)
Should a call to getText() return slide text? Default is yes

setNotesByDefault

public void setNotesByDefault(boolean notesByDefault)
Should a call to getText() return notes text? Default is no

setMasterByDefault

public void setMasterByDefault(boolean masterByDefault)
Should a call to getText() return text from master? Default is no

getText

public java.lang.String getText()
Gets the slide text, but not the notes text

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document

getText

public java.lang.String getText(boolean slideText,
                                boolean notesText)
Gets the requested text from the file

Parameters:
slideText - Should we retrieve text from slides?
notesText - Should we retrieve text from notes?

getText

public java.lang.String getText(boolean slideText,
                                boolean notesText,
                                boolean masterText)
Gets the requested text from the file

Parameters:
slideText - Should we retrieve text from slides?
notesText - Should we retrieve text from notes?
masterText - Should we retrieve text from master slides?
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

No usage of org.apache.poi.xslf.extractor.XSLFPowerPointExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CharacterPropertyFetcher

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model
Class CharacterPropertyFetcher<T>

java.lang.Object
    extended by  org.apache.poi.xslf.model.PropertyFetcher<T>
        extended by  org.apache.poi.xslf.model.ParagraphPropertyFetcher<T>
            extended by  org.apache.poi.xslf.model.CharacterPropertyFetcher<T>

public abstract class CharacterPropertyFetcher<T>
extends ParagraphPropertyFetcher<T>

Author:
Yegor Kozlov

Field Summary
 boolean isFetchingFromMaster
Constructor Summary
CharacterPropertyFetcher(int level)
Method Summary
abstract boolean | fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextCharacterProperties props)
boolean | fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraphProperties props)
Methods inherited from class org.apache.poi.xslf.model.ParagraphPropertyFetcher
fetch
Methods inherited from class org.apache.poi.xslf.model.PropertyFetcher
getValue, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

isFetchingFromMaster

public boolean isFetchingFromMaster
Constructor Detail

CharacterPropertyFetcher

public CharacterPropertyFetcher(int level)
Method Detail

fetch

public boolean fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraphProperties props)
Specified by:
fetch in class ParagraphPropertyFetcher<T>

fetch

public abstract boolean fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextCharacterProperties props)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.xslf.model
Classes
CharacterPropertyFetcher
ParagraphPropertyFetcher
PropertyFetcher
TextBodyPropertyFetcher


org.apache.poi.xslf.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xslf.model

Class Summary
CharacterPropertyFetcher<T> |
ParagraphPropertyFetcher<T> |
PropertyFetcher<T> | Used internally to navigate the PresentationML text style hierarchy and fetch properties
TextBodyPropertyFetcher<T> | Created by IntelliJ IDEA.


org.apache.poi.xslf.model Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xslf.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xslf.model.PropertyFetcher<T>
      • org.apache.poi.xslf.model.ParagraphPropertyFetcher<T>
        • org.apache.poi.xslf.model.CharacterPropertyFetcher<T>
      • org.apache.poi.xslf.model.TextBodyPropertyFetcher<T>


Uses of Package org.apache.poi.xslf.model

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xslf.model

Packages that use org.apache.poi.xslf.model
org.apache.poi.xslf.model

Classes in org.apache.poi.xslf.model used by org.apache.poi.xslf.model
ParagraphPropertyFetcher
PropertyFetcher
Used internally to navigate the PresentationML text style hierarchy and fetch properties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ParagraphPropertyFetcher

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model
Class ParagraphPropertyFetcher<T>

java.lang.Object
    extended by  org.apache.poi.xslf.model.PropertyFetcher<T>
        extended by  org.apache.poi.xslf.model.ParagraphPropertyFetcher<T>
Direct Known Subclasses:
CharacterPropertyFetcher
public abstract class ParagraphPropertyFetcher<T>
extends PropertyFetcher<T>

Author:
Yegor Kozlov

Constructor Summary
ParagraphPropertyFetcher(int level)
Method Summary
abstract boolean | fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraphProperties props)
boolean | fetch(XSLFSimpleShape shape)
Methods inherited from class org.apache.poi.xslf.model.PropertyFetcher
getValue, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParagraphPropertyFetcher

public ParagraphPropertyFetcher(int level)
Method Detail

fetch

public boolean fetch(XSLFSimpleShape shape)
Specified by:
fetch in class PropertyFetcher<T>
Parameters:
shape - the shape being examined
Returns:
true if the desired property was fetched

fetch

public abstract boolean fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraphProperties props)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyFetcher

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model
Class PropertyFetcher<T>

java.lang.Object
    extended by  org.apache.poi.xslf.model.PropertyFetcher<T>
Direct Known Subclasses:
ParagraphPropertyFetcher, TextBodyPropertyFetcher
@Internal
public abstract class PropertyFetcher<T>
extends java.lang.Object

Used internally to navigate the PresentationML text style hierarchy and fetch properties

Author:
Yegor Kozlov

Constructor Summary
PropertyFetcher()
Method Summary
abstract boolean | fetch(XSLFSimpleShape shape)
T | getValue()
void | setValue(T val)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertyFetcher

public PropertyFetcher()
Method Detail

fetch

public abstract boolean fetch(XSLFSimpleShape shape)
Parameters:
shape - the shape being examined
Returns:
true if the desired property was fetched

getValue

public T getValue()

setValue

public void setValue(T val)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextBodyPropertyFetcher

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model
Class TextBodyPropertyFetcher<T>

java.lang.Object
    extended by  org.apache.poi.xslf.model.PropertyFetcher<T>
        extended by  org.apache.poi.xslf.model.TextBodyPropertyFetcher<T>

public abstract class TextBodyPropertyFetcher<T>
extends PropertyFetcher<T>

Created by IntelliJ IDEA. User: yegor Date: Oct 21, 2011 Time: 1:18:52 PM To change this template use File | Settings | File Templates.

Constructor Summary
TextBodyPropertyFetcher()
Method Summary
abstract boolean | fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextBodyProperties props)
boolean | fetch(XSLFSimpleShape shape)
Methods inherited from class org.apache.poi.xslf.model.PropertyFetcher
getValue, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextBodyPropertyFetcher

public TextBodyPropertyFetcher()
Method Detail

fetch

public boolean fetch(XSLFSimpleShape shape)
Specified by:
fetch in class PropertyFetcher<T>
Parameters:
shape - the shape being examined
Returns:
true if the desired property was fetched

fetch

public abstract boolean fetch(org.openxmlformats.schemas.drawingml.x2006.main.CTTextBodyProperties props)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xslf.model.CharacterPropertyFetcher

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.CharacterPropertyFetcher

No usage of org.apache.poi.xslf.model.CharacterPropertyFetcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.ParagraphPropertyFetcher

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.ParagraphPropertyFetcher

Packages that use ParagraphPropertyFetcher
org.apache.poi.xslf.model

Uses of ParagraphPropertyFetcher in org.apache.poi.xslf.model

Subclasses of ParagraphPropertyFetcher in org.apache.poi.xslf.model
 class CharacterPropertyFetcher<T>

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.PropertyFetcher

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.PropertyFetcher

Packages that use PropertyFetcher
org.apache.poi.xslf.model

Uses of PropertyFetcher in org.apache.poi.xslf.model

Subclasses of PropertyFetcher in org.apache.poi.xslf.model
class | CharacterPropertyFetcher<T>
class | ParagraphPropertyFetcher<T>
class | TextBodyPropertyFetcher<T> Created by IntelliJ IDEA.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.TextBodyPropertyFetcher

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.TextBodyPropertyFetcher

No usage of org.apache.poi.xslf.model.TextBodyPropertyFetcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbsExpression

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class AbsExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.AbsExpression
All Implemented Interfaces:
Expression
public class AbsExpression
extends java.lang.Object
implements Expression

Absolute Value Formula

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AddDivideExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class AddDivideExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.AddDivideExpression
All Implemented Interfaces:
Expression
public class AddDivideExpression
extends java.lang.Object
implements Expression

Add Divide Formula

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddSubtractExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class AddSubtractExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.AddSubtractExpression
All Implemented Interfaces:
Expression
public class AddSubtractExpression
extends java.lang.Object
implements Expression

Add Subtract Formula

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AdjustValue

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class AdjustValue

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.Formula
        extended by  org.apache.poi.xslf.model.geom.Guide
            extended by  org.apache.poi.xslf.model.geom.AdjustValue

public class AdjustValue
extends Guide

Represents a shape adjust values (see section 20.1.9.5 in the spec)

Author:
Yegor Kozlov

Constructor Summary
AdjustValue(org.openxmlformats.schemas.drawingml.x2006.main.CTGeomGuide gd)
Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdjustValue

public AdjustValue(org.openxmlformats.schemas.drawingml.x2006.main.CTGeomGuide gd)
Method Detail

evaluate

public double evaluate(Context ctx)
Overrides:
evaluate in class Guide
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArcTanExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class ArcTanExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.ArcTanExpression
All Implemented Interfaces:
Expression
public class ArcTanExpression
extends java.lang.Object
implements Expression

Date: 10/24/11

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArcToCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class ArcToCommand

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.ArcToCommand
All Implemented Interfaces:
PathCommand
public class ArcToCommand
extends java.lang.Object
implements PathCommand

ArcTo command within a shape path in DrawingML: Where wr and wh are the height and width radiuses of the supposed circle being used to draw the arc. This gives the circle a total height of (2 * hR) and a total width of (2 * wR) stAng is the start angle and swAng is the swing angle

Author:
Yegor Kozlov

Method Summary
 void execute(java.awt.geom.GeneralPath path, Context ctx)
Execute the command an append a segment to the specified path
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

execute

public void execute(java.awt.geom.GeneralPath path,
                    Context ctx)
Description copied from interface: PathCommand
Execute the command an append a segment to the specified path

Specified by:
execute in interface PathCommand
Parameters:
path - the path to append the result to
ctx - the context to lookup variables
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClosePathCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class ClosePathCommand

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.ClosePathCommand
All Implemented Interfaces:
PathCommand
public class ClosePathCommand
extends java.lang.Object
implements PathCommand

Date: 10/25/11

Author:
Yegor Kozlov

Method Summary
 void execute(java.awt.geom.GeneralPath path, Context ctx)
Execute the command an append a segment to the specified path
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

execute

public void execute(java.awt.geom.GeneralPath path,
                    Context ctx)
Description copied from interface: PathCommand
Execute the command an append a segment to the specified path

Specified by:
execute in interface PathCommand
Parameters:
path - the path to append the result to
ctx - the context to lookup variables
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Context

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class Context

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.Context

public class Context
extends java.lang.Object

Date: 10/24/11

Author:
Yegor Kozlov

Constructor Summary
Context(CustomGeometry geom, java.awt.geom.Rectangle2D anchor, IAdjustableShape props)
Method Summary
double | evaluate(Formula fmla)
Guide | getAdjustValue(java.lang.String name)
java.awt.geom.Rectangle2D | getShapeAnchor()
double | getValue(java.lang.String key)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Context

public Context(CustomGeometry geom,
               java.awt.geom.Rectangle2D anchor,
               IAdjustableShape props)
Method Detail

getShapeAnchor

public java.awt.geom.Rectangle2D getShapeAnchor()

getAdjustValue

public Guide getAdjustValue(java.lang.String name)

getValue

public double getValue(java.lang.String key)

evaluate

public double evaluate(Formula fmla)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CosExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class CosExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.CosExpression
All Implemented Interfaces:
Expression
public class CosExpression
extends java.lang.Object
implements Expression

Date: 10/24/11

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CosineArcTanExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class CosineArcTanExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.CosineArcTanExpression
All Implemented Interfaces:
Expression
public class CosineArcTanExpression
extends java.lang.Object
implements Expression

Date: 10/24/11

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurveToCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class CurveToCommand

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.CurveToCommand
All Implemented Interfaces:
PathCommand
public class CurveToCommand
extends java.lang.Object
implements PathCommand

Date: 10/25/11

Author:
Yegor Kozlov

Method Summary
 void execute(java.awt.geom.GeneralPath path, Context ctx)
Execute the command an append a segment to the specified path
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

execute

public void execute(java.awt.geom.GeneralPath path,
                    Context ctx)
Description copied from interface: PathCommand
Execute the command an append a segment to the specified path

Specified by:
execute in interface PathCommand
Parameters:
path - the path to append the result to
ctx - the context to lookup variables
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomGeometry

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class CustomGeometry

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.CustomGeometry
All Implemented Interfaces:
java.lang.Iterable<Path>
public class CustomGeometry
extends java.lang.Object
implements java.lang.Iterable<Path>

Definition of a custom geometric shape

Author:
Yegor Kozlov

Constructor Summary
CustomGeometry(org.openxmlformats.schemas.drawingml.x2006.main.CTCustomGeometry2D geom)
Method Summary
Path | getTextBounds()
java.util.Iterator<Path> | iterator()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomGeometry

public CustomGeometry(org.openxmlformats.schemas.drawingml.x2006.main.CTCustomGeometry2D geom)
Method Detail

iterator

public java.util.Iterator<Path> iterator()
Specified by:
iterator in interface java.lang.Iterable<Path>

getTextBounds

public Path getTextBounds()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Expression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Interface Expression

All Known Implementing Classes:
AbsExpression, AddDivideExpression, AddSubtractExpression, ArcTanExpression, CosExpression, CosineArcTanExpression, IfElseExpression, LiteralValueExpression, MaxExpression, MinExpression, ModExpression, MultiplyDivideExpression, PinExpression, SinArcTanExpression, SinExpression, SqrtExpression, TanExpression
public interface Expression

Date: 10/24/11

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)

Method Detail

evaluate

double evaluate(Context ctx)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpressionParser

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class ExpressionParser

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.ExpressionParser

public class ExpressionParser
extends java.lang.Object

A simple regexp-based parser of shape guide formulas in DrawingML

Author:
Yegor Kozlov

Constructor Summary
ExpressionParser()
Method Summary
static Expression parse(java.lang.String str)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExpressionParser

public ExpressionParser()
Method Detail

parse

public static Expression parse(java.lang.String str)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Formula

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class Formula

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.Formula
Direct Known Subclasses:
Guide
public abstract class Formula
extends java.lang.Object

A guide formula in DrawingML. This is a base class for adjust values, geometric guides and bilt-in guides

Author:
Yegor Kozlov

Constructor Summary
Formula()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Formula

public Formula()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Guide

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class Guide

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.Formula
        extended by  org.apache.poi.xslf.model.geom.Guide
Direct Known Subclasses:
AdjustValue
public class Guide
extends Formula

Date: 10/24/11

Author:
Yegor Kozlov

Constructor Summary
Guide(org.openxmlformats.schemas.drawingml.x2006.main.CTGeomGuide gd)
Guide(java.lang.String nm, java.lang.String fm)
Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Guide

public Guide(org.openxmlformats.schemas.drawingml.x2006.main.CTGeomGuide gd)

Guide

public Guide(java.lang.String nm,
             java.lang.String fm)
Method Detail

evaluate

public double evaluate(Context ctx)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IAdjustableShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Interface IAdjustableShape

public interface IAdjustableShape

A bridge to the consumer application. To get a shape geometry one needs to pass shape bounds and adjust values.

Author:
Yegor Kozlov

Method Summary
 Guide getAdjustValue(java.lang.String name)

Method Detail

getAdjustValue

Guide getAdjustValue(java.lang.String name)
Parameters:
name - name of a adjust value, e.g. adj1
Returns:
adjust guide defined in the shape or null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IfElseExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class IfElseExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.IfElseExpression
All Implemented Interfaces:
Expression
public class IfElseExpression
extends java.lang.Object
implements Expression

If Else Formula:

Arguments: 3 (fmla="?: x y z") Usage: "?: x y z" = if (x > 0), then y = value of this guide, else z = value of this guide

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineToCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class LineToCommand

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.LineToCommand
All Implemented Interfaces:
PathCommand
public class LineToCommand
extends java.lang.Object
implements PathCommand

Date: 10/25/11

Author:
Yegor Kozlov

Method Summary
 void execute(java.awt.geom.GeneralPath path, Context ctx)
Execute the command an append a segment to the specified path
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

execute

public void execute(java.awt.geom.GeneralPath path,
                    Context ctx)
Description copied from interface: PathCommand
Execute the command an append a segment to the specified path

Specified by:
execute in interface PathCommand
Parameters:
path - the path to append the result to
ctx - the context to lookup variables
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LiteralValueExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class LiteralValueExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.LiteralValueExpression
All Implemented Interfaces:
Expression
public class LiteralValueExpression
extends java.lang.Object
implements Expression

Date: 10/24/11

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MaxExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class MaxExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.MaxExpression
All Implemented Interfaces:
Expression
public class MaxExpression
extends java.lang.Object
implements Expression

Maximum Value Formula

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MinExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class MinExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.MinExpression
All Implemented Interfaces:
Expression
public class MinExpression
extends java.lang.Object
implements Expression

Minimum Value Formula

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class ModExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.ModExpression
All Implemented Interfaces:
Expression
public class ModExpression
extends java.lang.Object
implements Expression

Modulo Formula:

Arguments: 3 (fmla="mod x y z") Usage: "mod x y z" = sqrt(x^2 + b^2 + c^2) = value of this guide

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MoveToCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class MoveToCommand

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.MoveToCommand
All Implemented Interfaces:
PathCommand
public class MoveToCommand
extends java.lang.Object
implements PathCommand

Date: 10/25/11

Author:
Yegor Kozlov

Method Summary
 void execute(java.awt.geom.GeneralPath path, Context ctx)
Execute the command an append a segment to the specified path
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

execute

public void execute(java.awt.geom.GeneralPath path,
                    Context ctx)
Description copied from interface: PathCommand
Execute the command an append a segment to the specified path

Specified by:
execute in interface PathCommand
Parameters:
path - the path to append the result to
ctx - the context to lookup variables
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultiplyDivideExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class MultiplyDivideExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.MultiplyDivideExpression
All Implemented Interfaces:
Expression
public class MultiplyDivideExpression
extends java.lang.Object
implements Expression

Multiply Divide Formula

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Outline

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class Outline

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.Outline

public class Outline
extends java.lang.Object

Date: 11/6/11

Author:
Yegor Kozlov

Constructor Summary
Outline(java.awt.Shape shape, Path path)
Method Summary
java.awt.Shape | getOutline()
Path | getPath()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Outline

public Outline(java.awt.Shape shape,
               Path path)
Method Detail

getPath

public Path getPath()

getOutline

public java.awt.Shape getOutline()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.xslf.model.geom
Interfaces
Expression
IAdjustableShape
PathCommand
Classes
AbsExpression
AddDivideExpression
AddSubtractExpression
AdjustValue
ArcTanExpression
ArcToCommand
ClosePathCommand
Context
CosExpression
CosineArcTanExpression
CurveToCommand
CustomGeometry
ExpressionParser
Formula
Guide
IfElseExpression
LineToCommand
LiteralValueExpression
MaxExpression
MinExpression
ModExpression
MoveToCommand
MultiplyDivideExpression
Outline
Path
PinExpression
PresetGeometries
QuadToCommand
SinArcTanExpression
SinExpression
SqrtExpression
TanExpression


org.apache.poi.xslf.model.geom

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xslf.model.geom

Interface Summary
Expression | Date: 10/24/11
IAdjustableShape | A bridge to the consumer application.
PathCommand | A path command in DrawingML.

Class Summary
AbsExpression | Absolute Value Formula
AddDivideExpression | Add Divide Formula
AddSubtractExpression | Add Subtract Formula
AdjustValue | Represents a shape adjust values (see section 20.1.9.5 in the spec)
ArcTanExpression | Date: 10/24/11
ArcToCommand | ArcTo command within a shape path in DrawingML: Where wr and wh are the height and width radiuses of the supposed circle being used to draw the arc.
ClosePathCommand | Date: 10/25/11
Context | Date: 10/24/11
CosExpression | Date: 10/24/11
CosineArcTanExpression | Date: 10/24/11
CurveToCommand | Date: 10/25/11
CustomGeometry | Definition of a custom geometric shape
ExpressionParser | A simple regexp-based parser of shape guide formulas in DrawingML
Formula | A guide formula in DrawingML.
Guide | Date: 10/24/11
IfElseExpression | If Else Formula:
LineToCommand | Date: 10/25/11
LiteralValueExpression | Date: 10/24/11
MaxExpression | Maximum Value Formula
MinExpression | Minimum Value Formula
ModExpression | Modulo Formula:
MoveToCommand | Date: 10/25/11
MultiplyDivideExpression | Multiply Divide Formula
Outline | Date: 11/6/11
Path | Specifies a creation path consisting of a series of moves, lines and curves that when combined forms a geometric shape
PinExpression | Pin To Formula:
PresetGeometries | Date: 10/25/11
QuadToCommand | Date: 10/25/11
SinArcTanExpression | Sine ArcTan Formula:
SinExpression | Sine Formula:
SqrtExpression | Square Root Formula:
TanExpression | Tangent Formula:


org.apache.poi.xslf.model.geom Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xslf.model.geom

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xslf.model.geom.AbsExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.LinkedHashMap<K,V> (implements java.util.Map<K,V>)
          • org.apache.poi.xslf.model.geom.PresetGeometries
    • org.apache.poi.xslf.model.geom.AddDivideExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.AddSubtractExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.ArcTanExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.ArcToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.xslf.model.geom.ClosePathCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.xslf.model.geom.Context
    • org.apache.poi.xslf.model.geom.CosExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.CosineArcTanExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.CurveToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.xslf.model.geom.CustomGeometry (implements java.lang.Iterable<T>)
    • org.apache.poi.xslf.model.geom.ExpressionParser
    • org.apache.poi.xslf.model.geom.Formula
      • org.apache.poi.xslf.model.geom.Guide
        • org.apache.poi.xslf.model.geom.AdjustValue
    • org.apache.poi.xslf.model.geom.IfElseExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.LineToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.xslf.model.geom.LiteralValueExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.MaxExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.MinExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.ModExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.MoveToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.xslf.model.geom.MultiplyDivideExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.Outline
    • org.apache.poi.xslf.model.geom.Path
    • org.apache.poi.xslf.model.geom.PinExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.QuadToCommand (implements org.apache.poi.xslf.model.geom.PathCommand)
    • org.apache.poi.xslf.model.geom.SinArcTanExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.SinExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.SqrtExpression (implements org.apache.poi.xslf.model.geom.Expression)
    • org.apache.poi.xslf.model.geom.TanExpression (implements org.apache.poi.xslf.model.geom.Expression)

Interface Hierarchy

  • org.apache.poi.xslf.model.geom.Expression
  • org.apache.poi.xslf.model.geom.IAdjustableShape
  • org.apache.poi.xslf.model.geom.PathCommand


Uses of Package org.apache.poi.xslf.model.geom

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xslf.model.geom

Packages that use org.apache.poi.xslf.model.geom
org.apache.poi.xslf.model.geom

Classes in org.apache.poi.xslf.model.geom used by org.apache.poi.xslf.model.geom
Context
Date: 10/24/11
CustomGeometry
Definition of a custom geometric shape
Expression
Date: 10/24/11
Formula
A guide formula in DrawingML.
Guide
Date: 10/24/11
IAdjustableShape
A bridge to the consumer application.
Path
Specifies a creation path consisting of a series of moves, lines and curves that when combined forms a geometric shape
PathCommand
A path command in DrawingML.
PresetGeometries
Date: 10/25/11

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Path

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class Path

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.Path

public class Path
extends java.lang.Object

Specifies a creation path consisting of a series of moves, lines and curves that when combined forms a geometric shape

Author:
Yegor Kozlov

Constructor Summary
Path()
Path(boolean fill, boolean stroke)
Path(org.openxmlformats.schemas.drawingml.x2006.main.CTPath2D spPath)
Method Summary
void | addCommand(PathCommand cmd)
long | getH()
java.awt.geom.GeneralPath | getPath(Context ctx) Convert the internal represenation to java.awt.GeneralPath
long | getW()
boolean | isFilled()
boolean | isStroked()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Path

public Path()

Path

public Path(boolean fill,
            boolean stroke)

Path

public Path(org.openxmlformats.schemas.drawingml.x2006.main.CTPath2D spPath)
Method Detail

addCommand

public void addCommand(PathCommand cmd)

getPath

public java.awt.geom.GeneralPath getPath(Context ctx)
Convert the internal represenation to java.awt.GeneralPath

isStroked

public boolean isStroked()

isFilled

public boolean isFilled()

getW

public long getW()

getH

public long getH()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PathCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Interface PathCommand

All Known Implementing Classes:
ArcToCommand, ClosePathCommand, CurveToCommand, LineToCommand, MoveToCommand, QuadToCommand
public interface PathCommand

A path command in DrawingML. One of: - arcTo - moveTo - lineTo - cubicBezTo - quadBezTo - close

Author:
Yegor Kozlov

Method Summary
 void execute(java.awt.geom.GeneralPath path, Context ctx)
Execute the command an append a segment to the specified path

Method Detail

execute

void execute(java.awt.geom.GeneralPath path,
             Context ctx)
Execute the command an append a segment to the specified path

Parameters:
path - the path to append the result to
ctx - the context to lookup variables
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PinExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class PinExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.PinExpression
All Implemented Interfaces:
Expression
public class PinExpression
extends java.lang.Object
implements Expression

Pin To Formula:

Usage: "pin x y z" = if (y < x), then x = value of this guide else if (y > z), then z = value of this guide else y = value of this guide

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PresetGeometries

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class PresetGeometries

java.lang.Object
    extended by  java.util.AbstractMap<K,V>
        extended by  java.util.HashMap<K,V>
            extended by  java.util.LinkedHashMap<java.lang.String,CustomGeometry>
                extended by  org.apache.poi.xslf.model.geom.PresetGeometries
All Implemented Interfaces:
java.io.Serializable, java.lang.Cloneable, java.util.Map<java.lang.String,CustomGeometry>
public class PresetGeometries
extends java.util.LinkedHashMap<java.lang.String,CustomGeometry>

Date: 10/25/11

Author:
Yegor Kozlov
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.util.AbstractMap
java.util.AbstractMap.SimpleEntry<K,V>, java.util.AbstractMap.SimpleImmutableEntry<K,V>
Method Summary
static PresetGeometries getInstance()
Methods inherited from class java.util.LinkedHashMap
clear, containsValue, get, removeEldestEntry
Methods inherited from class java.util.HashMap
clone, containsKey, entrySet, isEmpty, keySet, put, putAll, remove, size, values
Methods inherited from class java.util.AbstractMap
equals, hashCode, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
containsKey, entrySet, equals, hashCode, isEmpty, keySet, put, putAll, remove, size, values

Method Detail

getInstance

public static PresetGeometries getInstance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuadToCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class QuadToCommand

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.QuadToCommand
All Implemented Interfaces:
PathCommand
public class QuadToCommand
extends java.lang.Object
implements PathCommand

Date: 10/25/11

Author:
Yegor Kozlov

Method Summary
 void execute(java.awt.geom.GeneralPath path, Context ctx)
Execute the command an append a segment to the specified path
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

execute

public void execute(java.awt.geom.GeneralPath path,
                    Context ctx)
Description copied from interface: PathCommand
Execute the command an append a segment to the specified path

Specified by:
execute in interface PathCommand
Parameters:
path - the path to append the result to
ctx - the context to lookup variables
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SinArcTanExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class SinArcTanExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.SinArcTanExpression
All Implemented Interfaces:
Expression
public class SinArcTanExpression
extends java.lang.Object
implements Expression

Sine ArcTan Formula:

Arguments: 3 (fmla="sat2 x y z") Usage: "sat2 x y z" = (x*sin(arctan(z / y))) = value of this guide

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SinExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class SinExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.SinExpression
All Implemented Interfaces:
Expression
public class SinExpression
extends java.lang.Object
implements Expression

Sine Formula:

Arguments: 2 (fmla="sin x y") Usage: "sin x y" = (x * sin( y )) = value of this guide

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqrtExpression

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class SqrtExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.SqrtExpression
All Implemented Interfaces:
Expression
public class SqrtExpression
extends java.lang.Object
implements Expression

Square Root Formula:

Arguments: 1 (fmla="sqrt x") Usage: "sqrt x" = sqrt(x) = value of this guide

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TanExpression

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.model.geom
Class TanExpression

java.lang.Object
    extended by  org.apache.poi.xslf.model.geom.TanExpression
All Implemented Interfaces:
Expression
public class TanExpression
extends java.lang.Object
implements Expression

Tangent Formula:

Arguments: 2 (fmla="tan x y") Usage: "tan x y" = (x * tan( y )) = value of this guide

Author:
Yegor Kozlov

Method Summary
 double evaluate(Context ctx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evaluate

public double evaluate(Context ctx)
Specified by:
evaluate in interface Expression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xslf.model.geom.AbsExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.AbsExpression

No usage of org.apache.poi.xslf.model.geom.AbsExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.AddDivideExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.AddDivideExpression

No usage of org.apache.poi.xslf.model.geom.AddDivideExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.AddSubtractExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.AddSubtractExpression

No usage of org.apache.poi.xslf.model.geom.AddSubtractExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.AdjustValue

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.AdjustValue

No usage of org.apache.poi.xslf.model.geom.AdjustValue

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.ArcTanExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.ArcTanExpression

No usage of org.apache.poi.xslf.model.geom.ArcTanExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.ArcToCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.ArcToCommand

No usage of org.apache.poi.xslf.model.geom.ArcToCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.ClosePathCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.ClosePathCommand

No usage of org.apache.poi.xslf.model.geom.ClosePathCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.Context

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.Context

Packages that use Context
org.apache.poi.xslf.model.geom

Uses of Context in org.apache.poi.xslf.model.geom

Methods in org.apache.poi.xslf.model.geom with parameters of type Context
double | TanExpression.evaluate(Context ctx)
double | SqrtExpression.evaluate(Context ctx)
double | SinExpression.evaluate(Context ctx)
double | SinArcTanExpression.evaluate(Context ctx)
double | PinExpression.evaluate(Context ctx)
double | MultiplyDivideExpression.evaluate(Context ctx)
double | ModExpression.evaluate(Context ctx)
double | MinExpression.evaluate(Context ctx)
double | MaxExpression.evaluate(Context ctx)
double | LiteralValueExpression.evaluate(Context ctx)
double | IfElseExpression.evaluate(Context ctx)
double | Guide.evaluate(Context ctx)
double | Expression.evaluate(Context ctx)
double | CosineArcTanExpression.evaluate(Context ctx)
double | CosExpression.evaluate(Context ctx)
double | ArcTanExpression.evaluate(Context ctx)
double | AdjustValue.evaluate(Context ctx)
double | AddSubtractExpression.evaluate(Context ctx)
double | AddDivideExpression.evaluate(Context ctx)
double | AbsExpression.evaluate(Context ctx)
void | QuadToCommand.execute(java.awt.geom.GeneralPath path, Context ctx)
void | PathCommand.execute(java.awt.geom.GeneralPath path, Context ctx) Execute the command an append a segment to the specified path
void | MoveToCommand.execute(java.awt.geom.GeneralPath path, Context ctx)
void | LineToCommand.execute(java.awt.geom.GeneralPath path, Context ctx)
void | CurveToCommand.execute(java.awt.geom.GeneralPath path, Context ctx)
void | ClosePathCommand.execute(java.awt.geom.GeneralPath path, Context ctx)
void | ArcToCommand.execute(java.awt.geom.GeneralPath path, Context ctx)
java.awt.geom.GeneralPath | Path.getPath(Context ctx) Convert the internal represenation to java.awt.GeneralPath

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.CosExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.CosExpression

No usage of org.apache.poi.xslf.model.geom.CosExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.CosineArcTanExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.CosineArcTanExpression

No usage of org.apache.poi.xslf.model.geom.CosineArcTanExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.CurveToCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.CurveToCommand

No usage of org.apache.poi.xslf.model.geom.CurveToCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.CustomGeometry

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.CustomGeometry

Packages that use CustomGeometry
org.apache.poi.xslf.model.geom

Uses of CustomGeometry in org.apache.poi.xslf.model.geom

Constructors in org.apache.poi.xslf.model.geom with parameters of type CustomGeometry
Context(CustomGeometry geom, java.awt.geom.Rectangle2D anchor, IAdjustableShape props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xslf.model.geom.Expression

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xslf.model.geom.Expression

Packages that use Expression
org.apache.poi.xslf.model.geom

Uses of Expression in org.apache.poi.xslf.model.geom

Classes in org.apache.poi.xslf.model.geom that implement Expression
class | AbsExpression Absolute Value Formula
class | AddDivideExpression Add Divide Formula
class | AddSubtractExpression Add Subtract Formula
class | ArcTanExpression Date: 10/24/11
class | CosExpression Date: 10/24/11
class | CosineArcTanExpression Date: 10/24/11
class | IfElseExpression If Else Formula:
class | LiteralValueExpression Date: 10/24/11
class | MaxExpression Maximum Value Formula
class | MinExpression Minimum Value Formula
class | ModExpression Modulo Formula:
class | MultiplyDivideExpression Multiply Divide Formula
class | PinExpression Pin To Formula:
class | SinArcTanExpression Sine ArcTan Formula:
class | SinExpression Sine Formula:
class | SqrtExpression Square Root Formula:
class | TanExpression Tangent Formula:

Methods in org.apache.poi.xslf.model.geom that return Expression
static Expression ExpressionParser.parse(java.lang.String str)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.ExpressionParser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.ExpressionParser

No usage of org.apache.poi.xslf.model.geom.ExpressionParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.Formula

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.Formula

Packages that use Formula
org.apache.poi.xslf.model.geom

Uses of Formula in org.apache.poi.xslf.model.geom

Subclasses of Formula in org.apache.poi.xslf.model.geom
class | AdjustValue Represents a shape adjust values (see section 20.1.9.5 in the spec)
class | Guide Date: 10/24/11

Methods in org.apache.poi.xslf.model.geom with parameters of type Formula
 double Context.evaluate(Formula fmla)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.Guide

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.Guide

Packages that use Guide
org.apache.poi.xslf.model.geom

Uses of Guide in org.apache.poi.xslf.model.geom

Subclasses of Guide in org.apache.poi.xslf.model.geom
 class AdjustValue
Represents a shape adjust values (see section 20.1.9.5 in the spec)

Methods in org.apache.poi.xslf.model.geom that return Guide
Guide | IAdjustableShape.getAdjustValue(java.lang.String name)
Guide | Context.getAdjustValue(java.lang.String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xslf.model.geom.IAdjustableShape

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xslf.model.geom.IAdjustableShape

Packages that use IAdjustableShape
org.apache.poi.xslf.model.geom

Uses of IAdjustableShape in org.apache.poi.xslf.model.geom

Constructors in org.apache.poi.xslf.model.geom with parameters of type IAdjustableShape
Context(CustomGeometry geom, java.awt.geom.Rectangle2D anchor, IAdjustableShape props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.IfElseExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.IfElseExpression

No usage of org.apache.poi.xslf.model.geom.IfElseExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.LineToCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.LineToCommand

No usage of org.apache.poi.xslf.model.geom.LineToCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.LiteralValueExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.LiteralValueExpression

No usage of org.apache.poi.xslf.model.geom.LiteralValueExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.MaxExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.MaxExpression

No usage of org.apache.poi.xslf.model.geom.MaxExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.MinExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.MinExpression

No usage of org.apache.poi.xslf.model.geom.MinExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.ModExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.ModExpression

No usage of org.apache.poi.xslf.model.geom.ModExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.MoveToCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.MoveToCommand

No usage of org.apache.poi.xslf.model.geom.MoveToCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.MultiplyDivideExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.MultiplyDivideExpression

No usage of org.apache.poi.xslf.model.geom.MultiplyDivideExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.Outline

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.Outline

No usage of org.apache.poi.xslf.model.geom.Outline

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.Path

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.Path

Packages that use Path
org.apache.poi.xslf.model.geom

Uses of Path in org.apache.poi.xslf.model.geom

Methods in org.apache.poi.xslf.model.geom that return Path
Path | Outline.getPath()
Path | CustomGeometry.getTextBounds()

Methods in org.apache.poi.xslf.model.geom that return types with arguments of type Path
 java.util.Iterator<Path> CustomGeometry.iterator()

Constructors in org.apache.poi.xslf.model.geom with parameters of type Path
Outline(java.awt.Shape shape, Path path)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xslf.model.geom.PathCommand

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xslf.model.geom.PathCommand

Packages that use PathCommand
org.apache.poi.xslf.model.geom

Uses of PathCommand in org.apache.poi.xslf.model.geom

Classes in org.apache.poi.xslf.model.geom that implement PathCommand
class | ArcToCommand ArcTo command within a shape path in DrawingML: Where wr and wh are the height and width radiuses of the supposed circle being used to draw the arc.
class | ClosePathCommand Date: 10/25/11
class | CurveToCommand Date: 10/25/11
class | LineToCommand Date: 10/25/11
class | MoveToCommand Date: 10/25/11
class | QuadToCommand Date: 10/25/11

Methods in org.apache.poi.xslf.model.geom with parameters of type PathCommand
 void Path.addCommand(PathCommand cmd)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.PinExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.PinExpression

No usage of org.apache.poi.xslf.model.geom.PinExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.PresetGeometries

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.PresetGeometries

Packages that use PresetGeometries
org.apache.poi.xslf.model.geom

Uses of PresetGeometries in org.apache.poi.xslf.model.geom

Methods in org.apache.poi.xslf.model.geom that return PresetGeometries
static PresetGeometries PresetGeometries.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.QuadToCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.QuadToCommand

No usage of org.apache.poi.xslf.model.geom.QuadToCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.SinArcTanExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.SinArcTanExpression

No usage of org.apache.poi.xslf.model.geom.SinArcTanExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.SinExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.SinExpression

No usage of org.apache.poi.xslf.model.geom.SinExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.SqrtExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.SqrtExpression

No usage of org.apache.poi.xslf.model.geom.SqrtExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.model.geom.TanExpression

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.model.geom.TanExpression

No usage of org.apache.poi.xslf.model.geom.TanExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DrawingParagraph

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class DrawingParagraph

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.DrawingParagraph

public class DrawingParagraph
extends java.lang.Object

Constructor Summary
DrawingParagraph(org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraph p)
Method Summary
 java.lang.CharSequence getText()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingParagraph

public DrawingParagraph(org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraph p)
Method Detail

getText

public java.lang.CharSequence getText()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DrawingTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class DrawingTable

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.DrawingTable

public class DrawingTable
extends java.lang.Object

Constructor Summary
DrawingTable(org.openxmlformats.schemas.drawingml.x2006.main.CTTable table)
Method Summary
 DrawingTableRow[] getRows()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingTable

public DrawingTable(org.openxmlformats.schemas.drawingml.x2006.main.CTTable table)
Method Detail

getRows

public DrawingTableRow[] getRows()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingTableCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class DrawingTableCell

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.DrawingTableCell

public class DrawingTableCell
extends java.lang.Object

Constructor Summary
DrawingTableCell(org.openxmlformats.schemas.drawingml.x2006.main.CTTableCell cell)
Method Summary
 DrawingTextBody getTextBody()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingTableCell

public DrawingTableCell(org.openxmlformats.schemas.drawingml.x2006.main.CTTableCell cell)
Method Detail

getTextBody

public DrawingTextBody getTextBody()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingTableRow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class DrawingTableRow

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.DrawingTableRow

public class DrawingTableRow
extends java.lang.Object

Constructor Summary
DrawingTableRow(org.openxmlformats.schemas.drawingml.x2006.main.CTTableRow row)
Method Summary
 DrawingTableCell[] getCells()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingTableRow

public DrawingTableRow(org.openxmlformats.schemas.drawingml.x2006.main.CTTableRow row)
Method Detail

getCells

public DrawingTableCell[] getCells()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingTextBody

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class DrawingTextBody

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.DrawingTextBody
Direct Known Subclasses:
DrawingTextPlaceholder
public class DrawingTextBody
extends java.lang.Object

Constructor Summary
DrawingTextBody(org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody textBody)
Method Summary
 DrawingParagraph[] getParagraphs()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingTextBody

public DrawingTextBody(org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody textBody)
Method Detail

getParagraphs

public DrawingParagraph[] getParagraphs()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DrawingTextPlaceholder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class DrawingTextPlaceholder

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.DrawingTextBody
        extended by  org.apache.poi.xslf.usermodel.DrawingTextPlaceholder

public class DrawingTextPlaceholder
extends DrawingTextBody

A DrawingTextBody which is a placeholder

Author:
nick

Constructor Summary
DrawingTextPlaceholder(org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody textBody, org.openxmlformats.schemas.presentationml.x2006.main.CTPlaceholder placeholder)
Method Summary
java.lang.String | getPlaceholderType() What kind of placeholder is this?
org.openxmlformats.schemas.presentationml.x2006.main.STPlaceholderType.Enum | getPlaceholderTypeEnum() What kind of placeholder is this?
boolean | isPlaceholderCustom() Is the PlaceHolder text customised?
Methods inherited from class org.apache.poi.xslf.usermodel.DrawingTextBody
getParagraphs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DrawingTextPlaceholder

public DrawingTextPlaceholder(org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody textBody,
                              org.openxmlformats.schemas.presentationml.x2006.main.CTPlaceholder placeholder)
Method Detail

getPlaceholderType

public java.lang.String getPlaceholderType()
What kind of placeholder is this?

getPlaceholderTypeEnum

public org.openxmlformats.schemas.presentationml.x2006.main.STPlaceholderType.Enum getPlaceholderTypeEnum()
What kind of placeholder is this?

isPlaceholderCustom

public boolean isPlaceholderCustom()
Is the PlaceHolder text customised?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineCap

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum LineCap

java.lang.Object
    extended by  java.lang.Enum<LineCap>
        extended by  org.apache.poi.xslf.usermodel.LineCap
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LineCap>
public enum LineCap
extends java.lang.Enum<LineCap>

Author:
Yegor Kozlov

Enum Constant Summary
FLAT
Line ends at end point
ROUND
Rounded ends
SQUARE
Square protrudes by half line width
Method Summary
static LineCap | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineCap[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ROUND

public static final LineCap ROUND
Rounded ends

SQUARE

public static final LineCap SQUARE
Square protrudes by half line width

FLAT

public static final LineCap FLAT
Line ends at end point

Method Detail

values

public static LineCap[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LineCap c : LineCap.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LineCap valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


LineDash

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum LineDash

java.lang.Object
    extended by  java.lang.Enum<LineDash>
        extended by  org.apache.poi.xslf.usermodel.LineDash
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LineDash>
public enum LineDash
extends java.lang.Enum<LineDash>

Author:
Yegor Kozlov

Enum Constant Summary
DASH
DASH_DOT
DOT
LG_DASH
LG_DASH_DOT
LG_DASH_DOT_DOT
SOLID
SYS_DASH
SYS_DASH_DOT
SYS_DASH_DOT_DOT
SYS_DOT
Method Summary
static LineDash | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineDash[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

SOLID

public static final LineDash SOLID

DOT

public static final LineDash DOT

DASH

public static final LineDash DASH

LG_DASH

public static final LineDash LG_DASH

DASH_DOT

public static final LineDash DASH_DOT

LG_DASH_DOT

public static final LineDash LG_DASH_DOT

LG_DASH_DOT_DOT

public static final LineDash LG_DASH_DOT_DOT

SYS_DASH

public static final LineDash SYS_DASH

SYS_DOT

public static final LineDash SYS_DOT

SYS_DASH_DOT

public static final LineDash SYS_DASH_DOT

SYS_DASH_DOT_DOT

public static final LineDash SYS_DASH_DOT_DOT
Method Detail

values

public static LineDash[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LineDash c : LineDash.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LineDash valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


LineDecoration

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum LineDecoration

java.lang.Object
    extended by  java.lang.Enum<LineDecoration>
        extended by  org.apache.poi.xslf.usermodel.LineDecoration
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LineDecoration>
public enum LineDecoration
extends java.lang.Enum<LineDecoration>

Represents the shape decoration that appears at the ends of lines.

Enum Constant Summary
ARROW
DIAMOND
NONE
OVAL
STEALTH
TRIANGLE
Method Summary
static LineDecoration | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineDecoration[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final LineDecoration NONE

TRIANGLE

public static final LineDecoration TRIANGLE

STEALTH

public static final LineDecoration STEALTH

DIAMOND

public static final LineDecoration DIAMOND

OVAL

public static final LineDecoration OVAL

ARROW

public static final LineDecoration ARROW
Method Detail

values

public static LineDecoration[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LineDecoration c : LineDecoration.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LineDecoration valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


LineEndLength

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum LineEndLength

java.lang.Object
    extended by  java.lang.Enum<LineEndLength>
        extended by  org.apache.poi.xslf.usermodel.LineEndLength
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LineEndLength>
public enum LineEndLength
extends java.lang.Enum<LineEndLength>

Author:
Yegor Kozlov

Enum Constant Summary
LARGE
MEDIUM
SMALL
Method Summary
static LineEndLength | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineEndLength[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

SMALL

public static final LineEndLength SMALL

MEDIUM

public static final LineEndLength MEDIUM

LARGE

public static final LineEndLength LARGE
Method Detail

values

public static LineEndLength[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LineEndLength c : LineEndLength.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LineEndLength valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


LineEndWidth

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum LineEndWidth

java.lang.Object
    extended by  java.lang.Enum<LineEndWidth>
        extended by  org.apache.poi.xslf.usermodel.LineEndWidth
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LineEndWidth>
public enum LineEndWidth
extends java.lang.Enum<LineEndWidth>

Author:
Yegor Kozlov

Enum Constant Summary
LARGE
MEDIUM
SMALL
Method Summary
static LineEndWidth | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineEndWidth[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

SMALL

public static final LineEndWidth SMALL

MEDIUM

public static final LineEndWidth MEDIUM

LARGE

public static final LineEndWidth LARGE
Method Detail

values

public static LineEndWidth[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LineEndWidth c : LineEndWidth.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LineEndWidth valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ListAutoNumber

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum ListAutoNumber

java.lang.Object
    extended by  java.lang.Enum<ListAutoNumber>
        extended by  org.apache.poi.xslf.usermodel.ListAutoNumber
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<ListAutoNumber>
public enum ListAutoNumber
extends java.lang.Enum<ListAutoNumber>

Specifies type of automatic numbered bullet points that should be applied to a paragraph.

Author:
Yegor Kozlov

Enum Constant Summary
ALPHA_LC_PARENT_BOTH
(a), (b), (c), ...
ALPHA_LC_PARENT_R
a), b), c), ...
ALPHA_LC_PERIOD
a., b., c., ...
ALPHA_UC_PARENT_BOTH
(A), (B), (C), ...
ALPHA_UC_PARENT_R
A), B), C), ...
ALPHA_UC_PERIOD
A., B., C., ...
ARABIC_PARENT_BOTH
(1), (2), (3), ...
ARABIC_PARENT_R
1), 2), 3), ...
ARABIC_PERIOD
1., 2., 3., ...
ARABIC_PLAIN
1, 2, 3, ...
CIRCLE_NUM_DB_PLAIN
Dbl-byte circle numbers
CIRCLE_NUM_WD_BLACK_PLAIN
Wingdings black circle numbers
CIRCLE_NUM_WD_WHITE_PLAIN
Wingdings white circle numbers
ROMAN_LC_PARENT_BOTH
(i), (ii), (iii), ...
ROMAN_LC_PARENT_R
i), ii), iii), ...
ROMAN_LC_PERIOD
i., ii., iii., ...
ROMAN_UC_PARENT_BOTH
(I), (II), (III), ...
ROMAN_UC_PARENT_R
I), II), III), ...
ROMAN_UC_PERIOD
I., II., III., ...
Method Summary
static ListAutoNumber | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ListAutoNumber[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ALPHA_LC_PARENT_BOTH

public static final ListAutoNumber ALPHA_LC_PARENT_BOTH
(a), (b), (c), ...

ALPHA_UC_PARENT_BOTH

public static final ListAutoNumber ALPHA_UC_PARENT_BOTH
(A), (B), (C), ...

ALPHA_LC_PARENT_R

public static final ListAutoNumber ALPHA_LC_PARENT_R
a), b), c), ...

ALPHA_UC_PARENT_R

public static final ListAutoNumber ALPHA_UC_PARENT_R
A), B), C), ...

ALPHA_LC_PERIOD

public static final ListAutoNumber ALPHA_LC_PERIOD
a., b., c., ...

ALPHA_UC_PERIOD

public static final ListAutoNumber ALPHA_UC_PERIOD
A., B., C., ...

ARABIC_PARENT_BOTH

public static final ListAutoNumber ARABIC_PARENT_BOTH
(1), (2), (3), ...

ARABIC_PARENT_R

public static final ListAutoNumber ARABIC_PARENT_R
1), 2), 3), ...

ARABIC_PERIOD

public static final ListAutoNumber ARABIC_PERIOD
1., 2., 3., ...

ARABIC_PLAIN

public static final ListAutoNumber ARABIC_PLAIN
1, 2, 3, ...

ROMAN_LC_PARENT_BOTH

public static final ListAutoNumber ROMAN_LC_PARENT_BOTH
(i), (ii), (iii), ...

ROMAN_UC_PARENT_BOTH

public static final ListAutoNumber ROMAN_UC_PARENT_BOTH
(I), (II), (III), ...

ROMAN_LC_PARENT_R

public static final ListAutoNumber ROMAN_LC_PARENT_R
i), ii), iii), ...

ROMAN_UC_PARENT_R

public static final ListAutoNumber ROMAN_UC_PARENT_R
I), II), III), ...

ROMAN_LC_PERIOD

public static final ListAutoNumber ROMAN_LC_PERIOD
i., ii., iii., ...

ROMAN_UC_PERIOD

public static final ListAutoNumber ROMAN_UC_PERIOD
I., II., III., ...

CIRCLE_NUM_DB_PLAIN

public static final ListAutoNumber CIRCLE_NUM_DB_PLAIN
Dbl-byte circle numbers

CIRCLE_NUM_WD_BLACK_PLAIN

public static final ListAutoNumber CIRCLE_NUM_WD_BLACK_PLAIN
Wingdings black circle numbers

CIRCLE_NUM_WD_WHITE_PLAIN

public static final ListAutoNumber CIRCLE_NUM_WD_WHITE_PLAIN
Wingdings white circle numbers

Method Detail

values

public static ListAutoNumber[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ListAutoNumber c : ListAutoNumber.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ListAutoNumber valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


 org.apache.poi.xslf.usermodel
Interfaces
XSLFFontManager
XSLFShapeContainer
Classes
DrawingParagraph
DrawingTable
DrawingTableCell
DrawingTableRow
DrawingTextBody
DrawingTextPlaceholder
XMLSlideShow
XSLFAutoShape
XSLFBackground
XSLFColor
XSLFCommentAuthors
XSLFComments
XSLFCommonSlideData
XSLFConnectorShape
XSLFDrawing
XSLFFactory
XSLFFreeformShape
XSLFGraphicFrame
XSLFGroupShape
XSLFHyperlink
XSLFImageRenderer
XSLFNotes
XSLFNotesMaster
XSLFPictureData
XSLFPictureShape
XSLFRelation
XSLFRenderingHint
XSLFShadow
XSLFShape
XSLFSheet
XSLFSimpleShape
XSLFSlide
XSLFSlideLayout
XSLFSlideMaster
XSLFTable
XSLFTableCell
XSLFTableRow
XSLFTableStyle
XSLFTableStyles
XSLFTextBox
XSLFTextParagraph
XSLFTextRun
XSLFTextShape
XSLFTheme
Enums
LineCap
LineDash
LineDecoration
LineEndLength
LineEndWidth
ListAutoNumber
Placeholder
SlideLayout
TextAlign
TextAutofit
TextCap
TextDirection
VerticalAlignment
XSLFShapeType


org.apache.poi.xslf.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xslf.usermodel

Interface Summary
XSLFFontManager | Manages fonts when rendering slides.
XSLFShapeContainer | Common interface for shape containers, e.g.

Class Summary
DrawingParagraph |
DrawingTable |
DrawingTableCell |
DrawingTableRow |
DrawingTextBody |
DrawingTextPlaceholder | A DrawingTextBody which is a placeholder
XMLSlideShow | High level representation of a ooxml slideshow.
XSLFAutoShape | Represents a shape with a preset geometry.
XSLFBackground | Background shape
XSLFColor | Encapsulates logic to read color definitions from DrawingML and convert them to java.awt.Color
XSLFCommentAuthors |
XSLFComments |
XSLFCommonSlideData |
XSLFConnectorShape | Specifies a connection shape.
XSLFDrawing |
XSLFFactory | Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSLFFreeformShape | Represents a custom geometric shape.
XSLFGraphicFrame |
XSLFGroupShape | Represents a group shape that consists of many shapes grouped together.
XSLFHyperlink |
XSLFImageRenderer | For now this class renders only images supported by the javax.imageio.ImageIO framework.
XSLFNotes |
XSLFNotesMaster | Notes master object associated with this layout.
XSLFPictureData | Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSLFPictureShape | Represents a picture shape
XSLFRelation |
XSLFRenderingHint |
XSLFShadow | Represents a shadow of a shape.
XSLFShape | Base super-class class for all shapes in PresentationML
XSLFSheet |
XSLFSimpleShape | Represents a single (non-group) shape in a .pptx slide show
XSLFSlide |
XSLFSlideLayout |
XSLFSlideMaster | Slide master object associated with this layout.
XSLFTable | Represents a table in a .pptx presentation
XSLFTableCell | Represents a cell of a table in a .pptx presentation
XSLFTableRow | Represents a table in a .pptx presentation
XSLFTableStyle | Represents a table in a .pptx presentation
XSLFTableStyles |
XSLFTextBox |
XSLFTextParagraph | Represents a paragraph of text within the containing text body.
XSLFTextRun | Represents a run of text within the containing text body.
XSLFTextShape | Represents a shape that can hold text.
XSLFTheme | A shared style sheet in a .pptx slide show

Enum Summary
LineCap |
LineDash |
LineDecoration | Represents the shape decoration that appears at the ends of lines.
LineEndLength |
LineEndWidth |
ListAutoNumber | Specifies type of automatic numbered bullet points that should be applied to a paragraph.
Placeholder |
SlideLayout | Date: 11/5/11
TextAlign | Specified a list of text alignment types
TextAutofit | Specifies alist of auto-fit types.
TextCap |
TextDirection | Vertical Text Types
VerticalAlignment | Specifies a list of available anchoring types for text
XSLFShapeType | known preset shape geometries in PresentationML


org.apache.poi.xslf.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xslf.usermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xslf.usermodel.DrawingParagraph
    • org.apache.poi.xslf.usermodel.DrawingTable
    • org.apache.poi.xslf.usermodel.DrawingTableCell
    • org.apache.poi.xslf.usermodel.DrawingTableRow
    • org.apache.poi.xslf.usermodel.DrawingTextBody
      • org.apache.poi.xslf.usermodel.DrawingTextPlaceholder
    • org.apache.poi.POIXMLDocumentPart
      • org.apache.poi.POIXMLDocument
        • org.apache.poi.xslf.usermodel.XMLSlideShow
      • org.apache.poi.xslf.usermodel.XSLFCommentAuthors
      • org.apache.poi.xslf.usermodel.XSLFComments
      • org.apache.poi.xslf.usermodel.XSLFPictureData
      • org.apache.poi.xslf.usermodel.XSLFSheet (implements org.apache.poi.xslf.usermodel.XSLFShapeContainer)
        • org.apache.poi.xslf.usermodel.XSLFNotes
        • org.apache.poi.xslf.usermodel.XSLFNotesMaster
        • org.apache.poi.xslf.usermodel.XSLFSlide
        • org.apache.poi.xslf.usermodel.XSLFSlideLayout
        • org.apache.poi.xslf.usermodel.XSLFSlideMaster
      • org.apache.poi.xslf.usermodel.XSLFTableStyles (implements java.lang.Iterable<T>)
      • org.apache.poi.xslf.usermodel.XSLFTheme
    • org.apache.poi.POIXMLFactory
      • org.apache.poi.xslf.usermodel.XSLFFactory
    • org.apache.poi.POIXMLRelation
      • org.apache.poi.xslf.usermodel.XSLFRelation
    • java.awt.RenderingHints.Key
      • org.apache.poi.xslf.usermodel.XSLFRenderingHint
    • org.apache.poi.xslf.usermodel.XSLFColor
    • org.apache.poi.xslf.usermodel.XSLFCommonSlideData
    • org.apache.poi.xslf.usermodel.XSLFDrawing
    • org.apache.poi.xslf.usermodel.XSLFHyperlink
    • org.apache.poi.xslf.usermodel.XSLFImageRenderer
    • org.apache.poi.xslf.usermodel.XSLFShape
      • org.apache.poi.xslf.usermodel.XSLFGraphicFrame
        • org.apache.poi.xslf.usermodel.XSLFTable (implements java.lang.Iterable<T>)
      • org.apache.poi.xslf.usermodel.XSLFGroupShape (implements org.apache.poi.xslf.usermodel.XSLFShapeContainer)
      • org.apache.poi.xslf.usermodel.XSLFSimpleShape
        • org.apache.poi.xslf.usermodel.XSLFBackground
        • org.apache.poi.xslf.usermodel.XSLFConnectorShape
        • org.apache.poi.xslf.usermodel.XSLFPictureShape
        • org.apache.poi.xslf.usermodel.XSLFShadow
        • org.apache.poi.xslf.usermodel.XSLFTextShape (implements java.lang.Iterable<T>)
          • org.apache.poi.xslf.usermodel.XSLFAutoShape
            • org.apache.poi.xslf.usermodel.XSLFFreeformShape
            • org.apache.poi.xslf.usermodel.XSLFTextBox
          • org.apache.poi.xslf.usermodel.XSLFTableCell
    • org.apache.poi.xslf.usermodel.XSLFTableRow (implements java.lang.Iterable<T>)
    • org.apache.poi.xslf.usermodel.XSLFTableStyle
    • org.apache.poi.xslf.usermodel.XSLFTextParagraph (implements java.lang.Iterable<T>)
    • org.apache.poi.xslf.usermodel.XSLFTextRun

Interface Hierarchy

  • java.lang.Iterable<T>
    • org.apache.poi.xslf.usermodel.XSLFShapeContainer
  • org.apache.poi.xslf.usermodel.XSLFFontManager

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.xslf.usermodel.XSLFShapeType
      • org.apache.poi.xslf.usermodel.VerticalAlignment
      • org.apache.poi.xslf.usermodel.TextDirection
      • org.apache.poi.xslf.usermodel.TextCap
      • org.apache.poi.xslf.usermodel.TextAutofit
      • org.apache.poi.xslf.usermodel.TextAlign
      • org.apache.poi.xslf.usermodel.SlideLayout
      • org.apache.poi.xslf.usermodel.Placeholder
      • org.apache.poi.xslf.usermodel.ListAutoNumber
      • org.apache.poi.xslf.usermodel.LineEndWidth
      • org.apache.poi.xslf.usermodel.LineEndLength
      • org.apache.poi.xslf.usermodel.LineDecoration
      • org.apache.poi.xslf.usermodel.LineDash
      • org.apache.poi.xslf.usermodel.LineCap


Uses of Package org.apache.poi.xslf.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xslf.usermodel

Packages that use org.apache.poi.xslf.usermodel
org.apache.poi.xslf.extractor
org.apache.poi.xslf.model
org.apache.poi.xslf.usermodel

Classes in org.apache.poi.xslf.usermodel used by org.apache.poi.xslf.extractor
XMLSlideShow
High level representation of a ooxml slideshow.
XSLFRelation

Classes in org.apache.poi.xslf.usermodel used by org.apache.poi.xslf.model
XSLFSimpleShape
Represents a single (non-group) shape in a .pptx slide show

Classes in org.apache.poi.xslf.usermodel used by org.apache.poi.xslf.usermodel
DrawingParagraph
DrawingTableCell
DrawingTableRow
DrawingTextBody
LineCap
LineDash
LineDecoration
Represents the shape decoration that appears at the ends of lines.
LineEndLength
LineEndWidth
ListAutoNumber
Specifies type of automatic numbered bullet points that should be applied to a paragraph.
Placeholder
SlideLayout
Date: 11/5/11
TextAlign
Specified a list of text alignment types
TextAutofit
Specifies alist of auto-fit types.
TextCap
TextDirection
Vertical Text Types
VerticalAlignment
Specifies a list of available anchoring types for text
XMLSlideShow
High level representation of a ooxml slideshow.
XSLFAutoShape
Represents a shape with a preset geometry.
XSLFBackground
Background shape
XSLFCommentAuthors
XSLFComments
XSLFCommonSlideData
XSLFConnectorShape
Specifies a connection shape.
XSLFFactory
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSLFFreeformShape
Represents a custom geometric shape.
XSLFGraphicFrame
XSLFGroupShape
Represents a group shape that consists of many shapes grouped together.
XSLFHyperlink
XSLFNotes
XSLFNotesMaster
Notes master object associated with this layout.
XSLFPictureData
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSLFPictureShape
Represents a picture shape
XSLFRelation
XSLFRenderingHint
XSLFShadow
Represents a shadow of a shape.
XSLFShape
Base super-class class for all shapes in PresentationML
XSLFShapeContainer
Common interface for shape containers, e.g.
XSLFShapeType
known preset shape geometries in PresentationML
XSLFSheet
XSLFSimpleShape
Represents a single (non-group) shape in a .pptx slide show
XSLFSlide
XSLFSlideLayout
XSLFSlideMaster
Slide master object associated with this layout.
XSLFTable
Represents a table in a .pptx presentation
XSLFTableCell
Represents a cell of a table in a .pptx presentation
XSLFTableRow
Represents a table in a .pptx presentation
XSLFTableStyle
Represents a table in a .pptx presentation
XSLFTableStyles
XSLFTextBox
XSLFTextParagraph
Represents a paragraph of text within the containing text body.
XSLFTextRun
Represents a run of text within the containing text body.
XSLFTextShape
Represents a shape that can hold text.
XSLFTheme
A shared style sheet in a .pptx slide show

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Placeholder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum Placeholder

java.lang.Object
    extended by  java.lang.Enum<Placeholder>
        extended by  org.apache.poi.xslf.usermodel.Placeholder
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Placeholder>
public enum Placeholder
extends java.lang.Enum<Placeholder>

Author:
Yegor Kozlov

Enum Constant Summary
BODY
CENTERED_TITLE
CHART
CLIP_ART
CONTENT
DATETIME
DGM
FOOTER
HEADER
MEDIA
PICTURE
SLIDE_IMAGE
SLIDE_NUMBER
SUBTITLE
TABLE
TITLE
Method Summary
static Placeholder | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Placeholder[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TITLE

public static final Placeholder TITLE

BODY

public static final Placeholder BODY

CENTERED_TITLE

public static final Placeholder CENTERED_TITLE

SUBTITLE

public static final Placeholder SUBTITLE

DATETIME

public static final Placeholder DATETIME

SLIDE_NUMBER

public static final Placeholder SLIDE_NUMBER

FOOTER

public static final Placeholder FOOTER

HEADER

public static final Placeholder HEADER

CONTENT

public static final Placeholder CONTENT

CHART

public static final Placeholder CHART

TABLE

public static final Placeholder TABLE

CLIP_ART

public static final Placeholder CLIP_ART

DGM

public static final Placeholder DGM

MEDIA

public static final Placeholder MEDIA

SLIDE_IMAGE

public static final Placeholder SLIDE_IMAGE

PICTURE

public static final Placeholder PICTURE
Method Detail

values

public static Placeholder[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Placeholder c : Placeholder.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Placeholder valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


SlideLayout

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum SlideLayout

java.lang.Object
    extended by  java.lang.Enum<SlideLayout>
        extended by  org.apache.poi.xslf.usermodel.SlideLayout
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<SlideLayout>
public enum SlideLayout
extends java.lang.Enum<SlideLayout>

Date: 11/5/11

Author:
Yegor Kozlov

Enum Constant Summary
BLANK
Blank
CHART
Title and chart
CHART_AND_TEXT
Title, chart on left and text on right
CLIP_ART_AND_TEXT
Title, clipart on left, text on right
CLIP_ART_AND_VERT_TX
CUST
DGM
FOUR_OBJ
MEDIA_AND_TX
OBJ_AND_TWO_OBJ
OBJ_AND_TX
OBJ_ONLY
OBJ_OVER_TX
OBJ_TX
PIC_TX
SECTION_HEADER
Section Header
TBL
TEXT
Title and text
TEXT_AND_CHART
TITLE
Title layout with centered title and subtitle placeholders
TITLE_AND_CONTENT
title and content
TITLE_ONLY
Title only
TWO_COL_TX
TWO_OBJ
TWO_OBJ_AND_OBJ
TWO_OBJ_AND_TX
TWO_OBJ_OVER_TX
TWO_TX_TWO_OBJ
TX_AND_CLIP_ART
TX_AND_MEDIA
TX_AND_OBJ
TX_AND_TWO_OBJ
TX_OVER_OBJ
VERT_TITLE_AND_TX
VERT_TITLE_AND_TX_OVER_CHART
VERT_TX
Method Summary
static SlideLayout | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static SlideLayout[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TITLE

public static final SlideLayout TITLE
Title layout with centered title and subtitle placeholders

TEXT

public static final SlideLayout TEXT
Title and text

TWO_COL_TX

public static final SlideLayout TWO_COL_TX

TBL

public static final SlideLayout TBL

TEXT_AND_CHART

public static final SlideLayout TEXT_AND_CHART

CHART_AND_TEXT

public static final SlideLayout CHART_AND_TEXT
Title, chart on left and text on right

DGM

public static final SlideLayout DGM

CHART

public static final SlideLayout CHART
Title and chart

TX_AND_CLIP_ART

public static final SlideLayout TX_AND_CLIP_ART

CLIP_ART_AND_TEXT

public static final SlideLayout CLIP_ART_AND_TEXT
Title, clipart on left, text on right

TITLE_ONLY

public static final SlideLayout TITLE_ONLY
Title only

BLANK

public static final SlideLayout BLANK
Blank

TX_AND_OBJ

public static final SlideLayout TX_AND_OBJ

OBJ_AND_TX

public static final SlideLayout OBJ_AND_TX

OBJ_ONLY

public static final SlideLayout OBJ_ONLY

TITLE_AND_CONTENT

public static final SlideLayout TITLE_AND_CONTENT
title and content

TX_AND_MEDIA

public static final SlideLayout TX_AND_MEDIA

MEDIA_AND_TX

public static final SlideLayout MEDIA_AND_TX

OBJ_OVER_TX

public static final SlideLayout OBJ_OVER_TX

TX_OVER_OBJ

public static final SlideLayout TX_OVER_OBJ

TX_AND_TWO_OBJ

public static final SlideLayout TX_AND_TWO_OBJ

TWO_OBJ_AND_TX

public static final SlideLayout TWO_OBJ_AND_TX

TWO_OBJ_OVER_TX

public static final SlideLayout TWO_OBJ_OVER_TX

FOUR_OBJ

public static final SlideLayout FOUR_OBJ

VERT_TX

public static final SlideLayout VERT_TX

CLIP_ART_AND_VERT_TX

public static final SlideLayout CLIP_ART_AND_VERT_TX

VERT_TITLE_AND_TX

public static final SlideLayout VERT_TITLE_AND_TX

VERT_TITLE_AND_TX_OVER_CHART

public static final SlideLayout VERT_TITLE_AND_TX_OVER_CHART

TWO_OBJ

public static final SlideLayout TWO_OBJ

OBJ_AND_TWO_OBJ

public static final SlideLayout OBJ_AND_TWO_OBJ

TWO_OBJ_AND_OBJ

public static final SlideLayout TWO_OBJ_AND_OBJ

CUST

public static final SlideLayout CUST

SECTION_HEADER

public static final SlideLayout SECTION_HEADER
Section Header

TWO_TX_TWO_OBJ

public static final SlideLayout TWO_TX_TWO_OBJ

OBJ_TX

public static final SlideLayout OBJ_TX

PIC_TX

public static final SlideLayout PIC_TX
Method Detail

values

public static SlideLayout[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (SlideLayout c : SlideLayout.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SlideLayout valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


TextAlign

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum TextAlign

java.lang.Object
    extended by  java.lang.Enum<TextAlign>
        extended by  org.apache.poi.xslf.usermodel.TextAlign
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<TextAlign>
public enum TextAlign
extends java.lang.Enum<TextAlign>

Specified a list of text alignment types

Author:
Yegor Kozlov

Enum Constant Summary
CENTER
Align text in the center.
DIST
JUSTIFY
Align text so that it is justified across the whole line.
JUSTIFY_LOW
LEFT
Align text to the left margin.
RIGHT
Align text to the right margin.
THAI_DIST
Method Summary
static TextAlign | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextAlign[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LEFT

public static final TextAlign LEFT
Align text to the left margin.

CENTER

public static final TextAlign CENTER
Align text in the center.

RIGHT

public static final TextAlign RIGHT
Align text to the right margin.

JUSTIFY

public static final TextAlign JUSTIFY
Align text so that it is justified across the whole line. It is smart in the sense that it will not justify sentences which are short

JUSTIFY_LOW

public static final TextAlign JUSTIFY_LOW

DIST

public static final TextAlign DIST

THAI_DIST

public static final TextAlign THAI_DIST
Method Detail

values

public static TextAlign[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (TextAlign c : TextAlign.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TextAlign valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


TextAutofit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum TextAutofit

java.lang.Object
    extended by  java.lang.Enum<TextAutofit>
        extended by  org.apache.poi.xslf.usermodel.TextAutofit
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<TextAutofit>
public enum TextAutofit
extends java.lang.Enum<TextAutofit>

Specifies alist of auto-fit types.

Autofit specofies that a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside

Author:
Yegor Kozlov

Enum Constant Summary
NONE
Specifies that text within the text body should not be auto-fit to the bounding box.
NORMAL
Specifies that text within the text body should be normally auto-fit to the bounding box.
SHAPE
Specifies that a shape should be auto-fit to fully contain the text described within it.
Method Summary
static TextAutofit | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextAutofit[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final TextAutofit NONE
Specifies that text within the text body should not be auto-fit to the bounding box. Auto-fitting is when text within a text box is scaled in order to remain inside the text box.

NORMAL

public static final TextAutofit NORMAL
Specifies that text within the text body should be normally auto-fit to the bounding box. Autofitting is when text within a text box is scaled in order to remain inside the text box.

Example: Consider the situation where a user is building a diagram and needs to have the text for each shape that they are using stay within the bounds of the shape. An easy way this might be done is by using NORMAL autofit

SHAPE

public static final TextAutofit SHAPE
Specifies that a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.

Example: Consider the situation where a user is building a diagram and needs to have the text for each shape that they are using stay within the bounds of the shape. An easy way this might be done is by using SHAPE autofit

Method Detail

values

public static TextAutofit[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (TextAutofit c : TextAutofit.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TextAutofit valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


TextCap

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum TextCap

java.lang.Object
    extended by  java.lang.Enum<TextCap>
        extended by  org.apache.poi.xslf.usermodel.TextCap
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<TextCap>
public enum TextCap
extends java.lang.Enum<TextCap>

Author:
Yegor Kozlov

Enum Constant Summary
ALL
NONE
SMALL
Method Summary
static TextCap | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextCap[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final TextCap NONE

SMALL

public static final TextCap SMALL

ALL

public static final TextCap ALL
Method Detail

values

public static TextCap[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (TextCap c : TextCap.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TextCap valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


TextDirection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum TextDirection

java.lang.Object
    extended by  java.lang.Enum<TextDirection>
        extended by  org.apache.poi.xslf.usermodel.TextDirection
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<TextDirection>
public enum TextDirection
extends java.lang.Enum<TextDirection>

Vertical Text Types

Enum Constant Summary
HORIZONTAL
Horizontal text.
STACKED
Determines if all of the text is vertical ("one letter on top of another").
VERTICAL
Vertical orientation.
VERTICAL_270
Vertical orientation.
Method Summary
static TextDirection | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextDirection[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

HORIZONTAL

public static final TextDirection HORIZONTAL
Horizontal text. This should be default.

VERTICAL

public static final TextDirection VERTICAL
Vertical orientation. (each line is 90 degrees rotated clockwise, so it goes from top to bottom; each next line is to the left from the previous one).

VERTICAL_270

public static final TextDirection VERTICAL_270
Vertical orientation. (each line is 270 degrees rotated clockwise, so it goes from bottom to top; each next line is to the right from the previous one).

STACKED

public static final TextDirection STACKED
Determines if all of the text is vertical ("one letter on top of another").

Method Detail

values

public static TextDirection[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (TextDirection c : TextDirection.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TextDirection valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


VerticalAlignment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum VerticalAlignment

java.lang.Object
    extended by  java.lang.Enum<VerticalAlignment>
        extended by  org.apache.poi.xslf.usermodel.VerticalAlignment
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<VerticalAlignment>
public enum VerticalAlignment
extends java.lang.Enum<VerticalAlignment>

Specifies a list of available anchoring types for text

Author:
Yegor Kozlov

Enum Constant Summary
BOTTOM
Anchor the text at the bottom of the bounding rectangle.
DISTRIBUTED
Anchor the text so that it is distributed vertically.
JUSTIFIED
Anchor the text so that it is justified vertically.
MIDDLE
Anchor the text at the middle of the bounding rectangle
TOP
Anchor the text at the top of the bounding rectangle
Method Summary
static VerticalAlignment | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static VerticalAlignment[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TOP

public static final VerticalAlignment TOP
Anchor the text at the top of the bounding rectangle

MIDDLE

public static final VerticalAlignment MIDDLE
Anchor the text at the middle of the bounding rectangle

BOTTOM

public static final VerticalAlignment BOTTOM
Anchor the text at the bottom of the bounding rectangle.

JUSTIFIED

public static final VerticalAlignment JUSTIFIED
Anchor the text so that it is justified vertically.

When text is horizontal, this spaces out the actual lines of text and is almost always identical in behavior to DISTRIBUTED (special case: if only 1 line, then anchored at top).

When text is vertical, then it justifies the letters vertically. This is different than DISTRIBUTED, because in some cases such as very little text in a line, it will not justify.

DISTRIBUTED

public static final VerticalAlignment DISTRIBUTED
Anchor the text so that it is distributed vertically.

When text is horizontal, this spaces out the actual lines of text and is almost always identical in behavior to JUSTIFIED (special case: if only 1 line, then anchored in middle).

When text is vertical, then it distributes the letters vertically. This is different than JUSTIFIED, because it always forces distribution of the words, even if there are only one or two words in a line.

Method Detail

values

public static VerticalAlignment[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (VerticalAlignment c : VerticalAlignment.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static VerticalAlignment valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


XMLSlideShow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XMLSlideShow

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.POIXMLDocument
            extended by  org.apache.poi.xslf.usermodel.XMLSlideShow

@Beta
public class XMLSlideShow
extends POIXMLDocument

High level representation of a ooxml slideshow. This is the first object most users will construct whether they are reading or writing a slideshow. It is also the top level object for creating new slides/etc.

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocument
DOCUMENT_CREATOR, OLE_OBJECT_REL_TYPE, PACK_OBJECT_REL_TYPE
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XMLSlideShow()
XMLSlideShow(java.io.InputStream is)
XMLSlideShow(OPCPackage pkg)
Method Summary
XSLFSlideShow | _getXSLFSlideShow() Deprecated.
int | addPicture(byte[] pictureData, int format) Adds a picture to the workbook.
protected void | commit() Save the content in the underlying package part.
XSLFSlide | createSlide() Create a blank slide.
XSLFSlide | createSlide(XSLFSlideLayout layout) Create a slide and initialize it from the specified layout.
java.util.List<PackagePart> | getAllEmbedds() Get the document's embedded files.
java.util.List<XSLFPictureData> | getAllPictures() Returns all Pictures, which are referenced from the document itself.
XSLFCommentAuthors | getCommentAuthors() Returns the list of comment authors, if there is one.
org.openxmlformats.schemas.presentationml.x2006.main.CTPresentation | getCTPresentation()
XSLFNotesMaster | getNotesMaster() Return the Notes Master, if there is one.
java.awt.Dimension | getPageSize() Returns the current page size
XSLFSlideMaster[] | getSlideMasters()
XSLFSlide[] | getSlides() Return all the slides in the slideshow
XSLFTableStyles | getTableStyles()
protected void | onDocumentRead() Fired when a package part is read
XSLFSlide | removeSlide(int index)
void | setPageSize(java.awt.Dimension pgSize) Sets the page size to the given Dimension object.
void | setSlideOrder(XSLFSlide slide, int newIndex)
Methods inherited from class org.apache.poi.POIXMLDocument
getCorePart, getPackage, getProperties, getRelatedByType, hasOOXMLHeader, load, openPackage, write
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XMLSlideShow

public XMLSlideShow()

XMLSlideShow

public XMLSlideShow(OPCPackage pkg)

XMLSlideShow

public XMLSlideShow(java.io.InputStream is)
             throws java.io.IOException
Throws:
java.io.IOException
Method Detail

_getXSLFSlideShow

@Deprecated
public XSLFSlideShow _getXSLFSlideShow()
                                throws OpenXML4JException,
                                       java.io.IOException,
                                       org.apache.xmlbeans.XmlException
Deprecated.

Throws:
OpenXML4JException
java.io.IOException
org.apache.xmlbeans.XmlException

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Fired when a package part is read

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getAllEmbedds

public java.util.List<PackagePart> getAllEmbedds()
                                          throws OpenXML4JException
Get the document's embedded files.

Specified by:
getAllEmbedds in class POIXMLDocument
Throws:
OpenXML4JException

getAllPictures

public java.util.List<XSLFPictureData> getAllPictures()
Returns all Pictures, which are referenced from the document itself.

Returns:
a List of PackagePart. The returned List is unmodifiable.

createSlide

public XSLFSlide createSlide(XSLFSlideLayout layout)
Create a slide and initialize it from the specified layout.

Parameters:
layout -
Returns:
created slide

createSlide

public XSLFSlide createSlide()
Create a blank slide.

getNotesMaster

public XSLFNotesMaster getNotesMaster()
Return the Notes Master, if there is one. (May not be present if no notes exist)

getSlideMasters

public XSLFSlideMaster[] getSlideMasters()

getSlides

public XSLFSlide[] getSlides()
Return all the slides in the slideshow

getCommentAuthors

public XSLFCommentAuthors getCommentAuthors()
Returns the list of comment authors, if there is one. Will only be present if at least one slide has comments on it.

setSlideOrder

public void setSlideOrder(XSLFSlide slide,
                          int newIndex)
Parameters:
newIndex - 0-based index of the slide

removeSlide

public XSLFSlide removeSlide(int index)

getPageSize

public java.awt.Dimension getPageSize()
Returns the current page size

Returns:
the page size

setPageSize

public void setPageSize(java.awt.Dimension pgSize)
Sets the page size to the given Dimension object.

Parameters:
pgSize - page size

getCTPresentation

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTPresentation getCTPresentation()

addPicture

public int addPicture(byte[] pictureData,
                      int format)
Adds a picture to the workbook.

Parameters:
pictureData - The bytes of the picture
format - The format of the picture.
Returns:
the index to this picture (1 based).
See Also:
XSLFPictureData.PICTURE_TYPE_EMF, XSLFPictureData.PICTURE_TYPE_WMF, XSLFPictureData.PICTURE_TYPE_PICT, XSLFPictureData.PICTURE_TYPE_JPEG, XSLFPictureData.PICTURE_TYPE_PNG, XSLFPictureData.PICTURE_TYPE_DIB

getTableStyles

public XSLFTableStyles getTableStyles()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFAutoShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFAutoShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFTextShape
                extended by  org.apache.poi.xslf.usermodel.XSLFAutoShape
All Implemented Interfaces:
java.lang.Iterable<XSLFTextParagraph>
Direct Known Subclasses:
XSLFFreeformShape, XSLFTextBox
@Beta
public class XSLFAutoShape
extends XSLFTextShape

Represents a shape with a preset geometry.

Author:
Yegor Kozlov

Method Summary
protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody | getTextBody(boolean create)
java.lang.String | toString()
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFTextShape
addNewTextParagraph, clearText, drawContent, getBottomInset, getLeftInset, getRightInset, getText, getTextAutofit, getTextBodyPr, getTextDirection, getTextHeight, getTextParagraphs, getTextType, getTopInset, getVerticalAlignment, getWordWrap, iterator, resizeToFitText, setBottomInset, setLeftInset, setPlaceholder, setRightInset, setText, setTextAutofit, setTextDirection, setTopInset, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, getAnchor, getCTPlaceholder, getFillColor, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setAnchor, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getTextBody

protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody getTextBody(boolean create)
Specified by:
getTextBody in class XSLFTextShape

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFBackground

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFBackground

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFBackground

public class XSLFBackground
extends XSLFSimpleShape

Background shape

Author:
Yegor Kozlov

Method Summary
void | draw(java.awt.Graphics2D graphics) Draw this shape into the supplied canvas
java.awt.geom.Rectangle2D | getAnchor()
java.awt.Color | getFillColor()
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
drawContent, getCTPlaceholder, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setAnchor, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getAnchor

public java.awt.geom.Rectangle2D getAnchor()
Overrides:
getAnchor in class XSLFSimpleShape
Returns:
the position of this shape within the drawing canvas. The coordinates are expressed in points

draw

public void draw(java.awt.Graphics2D graphics)
Description copied from class: XSLFShape
Draw this shape into the supplied canvas

Overrides:
draw in class XSLFSimpleShape
Parameters:
graphics - the graphics to draw into

getFillColor

public java.awt.Color getFillColor()
Overrides:
getFillColor in class XSLFSimpleShape
Returns:
solid fill color of null if not set or fill color is not solid (pattern or gradient)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFColor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFColor

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFColor

@Beta
@Internal
public class XSLFColor
extends java.lang.Object

Encapsulates logic to read color definitions from DrawingML and convert them to java.awt.Color

Author:
Yegor Kozlov

Constructor Summary
XSLFColor(org.apache.xmlbeans.XmlObject obj, XSLFTheme theme, org.openxmlformats.schemas.drawingml.x2006.main.CTSchemeColor phClr)
Method Summary
java.awt.Color | getColor()
org.apache.xmlbeans.XmlObject | getXmlObject()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSLFColor

public XSLFColor(org.apache.xmlbeans.XmlObject obj,
                 XSLFTheme theme,
                 org.openxmlformats.schemas.drawingml.x2006.main.CTSchemeColor phClr)
Method Detail

getXmlObject

@Internal
public org.apache.xmlbeans.XmlObject getXmlObject()

getColor

public java.awt.Color getColor()
Returns:
the displayed color as a Java Color. If not color information was found in the supplied xml object then a null is returned.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFCommentAuthors

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFCommentAuthors

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFCommentAuthors

@Beta
public class XSLFCommentAuthors
extends POIXMLDocumentPart

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Method Summary
org.openxmlformats.schemas.presentationml.x2006.main.CTCommentAuthor | getAuthorById(long id)
org.openxmlformats.schemas.presentationml.x2006.main.CTCommentAuthorList | getCTCommentAuthorsList()
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getCTCommentAuthorsList

public org.openxmlformats.schemas.presentationml.x2006.main.CTCommentAuthorList getCTCommentAuthorsList()

getAuthorById

public org.openxmlformats.schemas.presentationml.x2006.main.CTCommentAuthor getAuthorById(long id)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFComments

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFComments

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFComments

@Beta
public class XSLFComments
extends POIXMLDocumentPart

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Method Summary
org.openxmlformats.schemas.presentationml.x2006.main.CTComment | getCommentAt(int pos)
org.openxmlformats.schemas.presentationml.x2006.main.CTCommentList | getCTCommentsList()
int | getNumberOfComments()
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getCTCommentsList

public org.openxmlformats.schemas.presentationml.x2006.main.CTCommentList getCTCommentsList()

getNumberOfComments

public int getNumberOfComments()

getCommentAt

public org.openxmlformats.schemas.presentationml.x2006.main.CTComment getCommentAt(int pos)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFCommonSlideData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFCommonSlideData

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFCommonSlideData

@Beta
public class XSLFCommonSlideData
extends java.lang.Object

Constructor Summary
XSLFCommonSlideData(org.openxmlformats.schemas.presentationml.x2006.main.CTCommonSlideData data)
Method Summary
java.util.List<DrawingTextBody> | getDrawingText()
java.util.List<DrawingParagraph> | getText()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSLFCommonSlideData

public XSLFCommonSlideData(org.openxmlformats.schemas.presentationml.x2006.main.CTCommonSlideData data)
Method Detail

getDrawingText

public java.util.List<DrawingTextBody> getDrawingText()

getText

public java.util.List<DrawingParagraph> getText()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFConnectorShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFConnectorShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFConnectorShape

@Beta
public class XSLFConnectorShape
extends XSLFSimpleShape

Specifies a connection shape.

Author:
Yegor Kozlov

Method Summary
 XSLFShadow getShadow()
YK: shadows of lines are suppressed for now.
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, drawContent, getAnchor, getCTPlaceholder, getFillColor, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setAnchor, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getShadow

public XSLFShadow getShadow()
YK: shadows of lines are suppressed for now.

Overrides:
getShadow in class XSLFSimpleShape
Returns:
shadow of this shape or null if shadow is disabled
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFDrawing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFDrawing

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFDrawing

@Beta
public class XSLFDrawing
extends java.lang.Object

Author:
Yegor Kozlov

Method Summary
XSLFAutoShape | createAutoShape()
XSLFConnectorShape | createConnector()
XSLFFreeformShape | createFreeform()
XSLFGroupShape | createGroup()
XSLFPictureShape | createPicture(java.lang.String rel)
XSLFTable | createTable()
XSLFTextBox | createTextBox()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createAutoShape

public XSLFAutoShape createAutoShape()

createFreeform

public XSLFFreeformShape createFreeform()

createTextBox

public XSLFTextBox createTextBox()

createConnector

public XSLFConnectorShape createConnector()

createGroup

public XSLFGroupShape createGroup()

createPicture

public XSLFPictureShape createPicture(java.lang.String rel)

createTable

public XSLFTable createTable()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFFactory

java.lang.Object
    extended by  org.apache.poi.POIXMLFactory
        extended by  org.apache.poi.xslf.usermodel.XSLFFactory

@Beta
public final class XSLFFactory
extends POIXMLFactory

Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type

Author:
Yegor Kozlov

Method Summary
POIXMLDocumentPart | createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part) Create a POIXMLDocumentPart from existing package part and relation.
static XSLFFactory | getInstance()
POIXMLDocumentPart | newDocumentPart(POIXMLRelation descriptor) Create a new POIXMLDocumentPart using the supplied descriptor.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static XSLFFactory getInstance()

createDocumentPart

public POIXMLDocumentPart createDocumentPart(POIXMLDocumentPart parent,
                                             PackageRelationship rel,
                                             PackagePart part)
Description copied from class: POIXMLFactory
Create a POIXMLDocumentPart from existing package part and relation. This method is called from POIXMLDocument.load(POIXMLFactory) when parsing a document

Specified by:
createDocumentPart in class POIXMLFactory
Parameters:
parent - parent part
rel - the package part relationship
part - the PackagePart representing the created instance
Returns:
A new instance of a POIXMLDocumentPart.

newDocumentPart

public POIXMLDocumentPart newDocumentPart(POIXMLRelation descriptor)
Description copied from class: POIXMLFactory
Create a new POIXMLDocumentPart using the supplied descriptor. This method is used when adding new parts to a document, for example, when adding a sheet to a workbook, slide to a presentation, etc.

Specified by:
newDocumentPart in class POIXMLFactory
Parameters:
descriptor - describes the object to create
Returns:
A new instance of a POIXMLDocumentPart.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFFontManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Interface XSLFFontManager

public interface XSLFFontManager

Manages fonts when rendering slides. Use this class to handle unknown / missing fonts or to substitute fonts

Method Summary
 java.lang.String getRendererableFont(java.lang.String typeface, int pitchFamily)
select a font to be used to paint text

Method Detail

getRendererableFont

java.lang.String getRendererableFont(java.lang.String typeface,
                                     int pitchFamily)
select a font to be used to paint text

Parameters:
typeface - the font family as defined in the .pptx file. This can be unknown or missing in the graphic environment.
Returns:
the font to be used to paint text
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFFreeformShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFFreeformShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFTextShape
                extended by  org.apache.poi.xslf.usermodel.XSLFAutoShape
                    extended by  org.apache.poi.xslf.usermodel.XSLFFreeformShape
All Implemented Interfaces:
java.lang.Iterable<XSLFTextParagraph>
@Beta
public class XSLFFreeformShape
extends XSLFAutoShape

Represents a custom geometric shape. This shape will consist of a series of lines and curves described within a creation path.

Author:
Yegor Kozlov

Method Summary
java.awt.geom.GeneralPath | getPath() Gets the shape path.
int | setPath(java.awt.geom.GeneralPath path) Set the shape path
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFAutoShape
getTextBody, toString
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFTextShape
addNewTextParagraph, clearText, drawContent, getBottomInset, getLeftInset, getRightInset, getText, getTextAutofit, getTextBodyPr, getTextDirection, getTextHeight, getTextParagraphs, getTextType, getTopInset, getVerticalAlignment, getWordWrap, iterator, resizeToFitText, setBottomInset, setLeftInset, setPlaceholder, setRightInset, setText, setTextAutofit, setTextDirection, setTopInset, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, getAnchor, getCTPlaceholder, getFillColor, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setAnchor, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

setPath

public int setPath(java.awt.geom.GeneralPath path)
Set the shape path

Parameters:
path - shape outline
Returns:
the number of points written

getPath

public java.awt.geom.GeneralPath getPath()
Gets the shape path.

The path is translated in the shape's coordinate system, i.e. freeform.getPath().getBounds2D() equals to freeform.getAnchor() (small discrepancies are possible due to rounding errors)

Returns:
the path
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFGraphicFrame

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFGraphicFrame

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFGraphicFrame
Direct Known Subclasses:
XSLFTable
@Beta
public class XSLFGraphicFrame
extends XSLFShape

Author:
Yegor Kozlov

Method Summary
void | draw(java.awt.Graphics2D graphics) Draw this shape into the supplied canvas
java.awt.geom.Rectangle2D | getAnchor()
boolean | getFlipHorizontal() Whether the shape is horizontally flipped
boolean | getFlipVertical() Whether the shape is vertically flipped
double | getRotation() Rotation angle in degrees
int | getShapeId() Returns a unique identifier for this shape within the current document.
java.lang.String | getShapeName()
int | getShapeType()
XSLFSheet | getSheet()
org.openxmlformats.schemas.presentationml.x2006.main.CTGraphicalObjectFrame | getXmlObject()
void | setAnchor(java.awt.geom.Rectangle2D anchor)
void | setFlipHorizontal(boolean flip)
void | setFlipVertical(boolean flip) Whether the shape is vertically flipped
void | setRotation(double theta) Rotate this shape.
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlObject

public org.openxmlformats.schemas.presentationml.x2006.main.CTGraphicalObjectFrame getXmlObject()
Specified by:
getXmlObject in class XSLFShape
Returns:
the xml bean holding this shape's data

getSheet

public XSLFSheet getSheet()

getShapeType

public int getShapeType()

getShapeId

public int getShapeId()
Description copied from class: XSLFShape
Returns a unique identifier for this shape within the current document. This ID may be used to assist in uniquely identifying this object so that it can be referred to by other parts of the document.

If multiple objects within the same document share the same id attribute value, then the document shall be considered non-conformant.

Specified by:
getShapeId in class XSLFShape
Returns:
unique id of this shape

getShapeName

public java.lang.String getShapeName()
Specified by:
getShapeName in class XSLFShape
Returns:
human-readable name of this shape, e.g. "Rectange 3"

getAnchor

public java.awt.geom.Rectangle2D getAnchor()
Specified by:
getAnchor in class XSLFShape
Returns:
the position of this shape within the drawing canvas. The coordinates are expressed in points

setAnchor

public void setAnchor(java.awt.geom.Rectangle2D anchor)
Specified by:
setAnchor in class XSLFShape
Parameters:
anchor - the position of this shape within the drawing canvas. The coordinates are expressed in points

setRotation

public void setRotation(double theta)
Rotate this shape.

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Specified by:
setRotation in class XSLFShape
Parameters:
theta - the rotation angle in degrees.

getRotation

public double getRotation()
Rotation angle in degrees

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Specified by:
getRotation in class XSLFShape
Returns:
rotation angle in degrees

setFlipHorizontal

public void setFlipHorizontal(boolean flip)
Specified by:
setFlipHorizontal in class XSLFShape
Parameters:
flip - whether the shape is horizontally flipped

setFlipVertical

public void setFlipVertical(boolean flip)
Description copied from class: XSLFShape
Whether the shape is vertically flipped

Specified by:
setFlipVertical in class XSLFShape
Parameters:
flip - whether the shape is vertically flipped

getFlipHorizontal

public boolean getFlipHorizontal()
Whether the shape is horizontally flipped

Specified by:
getFlipHorizontal in class XSLFShape
Returns:
whether the shape is horizontally flipped

getFlipVertical

public boolean getFlipVertical()
Description copied from class: XSLFShape
Whether the shape is vertically flipped

Specified by:
getFlipVertical in class XSLFShape
Returns:
whether the shape is vertically flipped

draw

public void draw(java.awt.Graphics2D graphics)
Description copied from class: XSLFShape
Draw this shape into the supplied canvas

Specified by:
draw in class XSLFShape
Parameters:
graphics - the graphics to draw into
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFGroupShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFGroupShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFGroupShape
All Implemented Interfaces:
java.lang.Iterable<XSLFShape>, XSLFShapeContainer
@Beta
public class XSLFGroupShape
extends XSLFShape
implements XSLFShapeContainer

Represents a group shape that consists of many shapes grouped together.

Author:
Yegor Kozlov

Method Summary
void | clear() Removes all of the elements from this container (optional operation).
XSLFAutoShape | createAutoShape() create a new shape with a predefined geometry and add it to this shape container
XSLFConnectorShape | createConnector() create a connector
XSLFFreeformShape | createFreeform() create a new shape with a custom geometry
XSLFGroupShape | createGroup() create a group of shapes belonging to this container
XSLFPictureShape | createPicture(int pictureIndex) create a picture belonging to this container
XSLFTextBox | createTextBox() create a text box
void | draw(java.awt.Graphics2D graphics) Draw this shape into the supplied canvas
java.awt.geom.Rectangle2D | getAnchor()
boolean | getFlipHorizontal() Whether the shape is horizontally flipped
boolean | getFlipVertical() Whether the shape is vertically flipped
java.awt.geom.Rectangle2D | getInteriorAnchor()
double | getRotation() Rotation angle in degrees
int | getShapeId() Returns a unique identifier for this shape within the current document.
java.lang.String | getShapeName()
XSLFShape[] | getShapes() Returns an array containing all of the elements in this container in proper sequence (from first to last element).
org.openxmlformats.schemas.presentationml.x2006.main.CTGroupShape | getXmlObject()
java.util.Iterator<XSLFShape> | iterator() Returns an iterator over the shapes in this sheet
boolean | removeShape(XSLFShape xShape) Remove the specified shape from this group
void | setAnchor(java.awt.geom.Rectangle2D anchor)
void | setFlipHorizontal(boolean flip)
void | setFlipVertical(boolean flip) Whether the shape is vertically flipped
void | setInteriorAnchor(java.awt.geom.Rectangle2D anchor)
void | setRotation(double theta) Rotate this shape.
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlObject

public org.openxmlformats.schemas.presentationml.x2006.main.CTGroupShape getXmlObject()
Specified by:
getXmlObject in class XSLFShape
Returns:
the xml bean holding this shape's data

getAnchor

public java.awt.geom.Rectangle2D getAnchor()
Specified by:
getAnchor in class XSLFShape
Returns:
the position of this shape within the drawing canvas. The coordinates are expressed in points

setAnchor

public void setAnchor(java.awt.geom.Rectangle2D anchor)
Specified by:
setAnchor in class XSLFShape
Parameters:
anchor - the position of this shape within the drawing canvas. The coordinates are expressed in points

getInteriorAnchor

public java.awt.geom.Rectangle2D getInteriorAnchor()
Returns:
the coordinates of the child extents rectangle used for calculations of grouping, scaling, and rotation behavior of shapes placed within a group.

setInteriorAnchor

public void setInteriorAnchor(java.awt.geom.Rectangle2D anchor)
Parameters:
anchor - the coordinates of the child extents rectangle used for calculations of grouping, scaling, and rotation behavior of shapes placed within a group.

getShapes

public XSLFShape[] getShapes()
Description copied from interface: XSLFShapeContainer
Returns an array containing all of the elements in this container in proper sequence (from first to last element).

Specified by:
getShapes in interface XSLFShapeContainer
Returns:
child shapes contained witin this group

iterator

public java.util.Iterator<XSLFShape> iterator()
Returns an iterator over the shapes in this sheet

Specified by:
iterator in interface java.lang.Iterable<XSLFShape>
Returns:
an iterator over the shapes in this sheet

removeShape

public boolean removeShape(XSLFShape xShape)
Remove the specified shape from this group

Specified by:
removeShape in interface XSLFShapeContainer
Parameters:
xShape - shape to be removed from this sheet, if present
Returns:
true if this sheet contained the specified element

getShapeName

public java.lang.String getShapeName()
Specified by:
getShapeName in class XSLFShape
Returns:
human-readable name of this shape, e.g. "Rectange 3"

getShapeId

public int getShapeId()
Description copied from class: XSLFShape
Returns a unique identifier for this shape within the current document. This ID may be used to assist in uniquely identifying this object so that it can be referred to by other parts of the document.

If multiple objects within the same document share the same id attribute value, then the document shall be considered non-conformant.

Specified by:
getShapeId in class XSLFShape
Returns:
unique id of this shape

createAutoShape

public XSLFAutoShape createAutoShape()
Description copied from interface: XSLFShapeContainer
create a new shape with a predefined geometry and add it to this shape container

Specified by:
createAutoShape in interface XSLFShapeContainer

createFreeform

public XSLFFreeformShape createFreeform()
Description copied from interface: XSLFShapeContainer
create a new shape with a custom geometry

Specified by:
createFreeform in interface XSLFShapeContainer

createTextBox

public XSLFTextBox createTextBox()
Description copied from interface: XSLFShapeContainer
create a text box

Specified by:
createTextBox in interface XSLFShapeContainer

createConnector

public XSLFConnectorShape createConnector()
Description copied from interface: XSLFShapeContainer
create a connector

Specified by:
createConnector in interface XSLFShapeContainer

createGroup

public XSLFGroupShape createGroup()
Description copied from interface: XSLFShapeContainer
create a group of shapes belonging to this container

Specified by:
createGroup in interface XSLFShapeContainer

createPicture

public XSLFPictureShape createPicture(int pictureIndex)
Description copied from interface: XSLFShapeContainer
create a picture belonging to this container

Specified by:
createPicture in interface XSLFShapeContainer
Returns:

setFlipHorizontal

public void setFlipHorizontal(boolean flip)
Specified by:
setFlipHorizontal in class XSLFShape
Parameters:
flip - whether the shape is horizontally flipped

setFlipVertical

public void setFlipVertical(boolean flip)
Description copied from class: XSLFShape
Whether the shape is vertically flipped

Specified by:
setFlipVertical in class XSLFShape
Parameters:
flip - whether the shape is vertically flipped

getFlipHorizontal

public boolean getFlipHorizontal()
Description copied from class: XSLFShape
Whether the shape is horizontally flipped

Specified by:
getFlipHorizontal in class XSLFShape
Returns:
whether the shape is horizontally flipped

getFlipVertical

public boolean getFlipVertical()
Description copied from class: XSLFShape
Whether the shape is vertically flipped

Specified by:
getFlipVertical in class XSLFShape
Returns:
whether the shape is vertically flipped

setRotation

public void setRotation(double theta)
Description copied from class: XSLFShape
Rotate this shape.

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Specified by:
setRotation in class XSLFShape
Parameters:
theta - the rotation angle in degrees.

getRotation

public double getRotation()
Description copied from class: XSLFShape
Rotation angle in degrees

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Specified by:
getRotation in class XSLFShape
Returns:
rotation angle in degrees

draw

public void draw(java.awt.Graphics2D graphics)
Description copied from class: XSLFShape
Draw this shape into the supplied canvas

Specified by:
draw in class XSLFShape
Parameters:
graphics - the graphics to draw into

clear

public void clear()
Removes all of the elements from this container (optional operation). The container will be empty after this call returns.

Specified by:
clear in interface XSLFShapeContainer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFHyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFHyperlink

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFHyperlink

public class XSLFHyperlink
extends java.lang.Object

Author:
Yegor Kozlov

Method Summary
java.net.URI | getTargetURI()
org.openxmlformats.schemas.drawingml.x2006.main.CTHyperlink | getXmlObject()
void | setAddress(java.lang.String address)
void | setAddress(XSLFSlide slide)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlObject

@Internal
public org.openxmlformats.schemas.drawingml.x2006.main.CTHyperlink getXmlObject()

setAddress

public void setAddress(java.lang.String address)

setAddress

public void setAddress(XSLFSlide slide)

getTargetURI

@Internal
public java.net.URI getTargetURI()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFImageRenderer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFImageRenderer

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFImageRenderer

@Beta
public class XSLFImageRenderer
extends java.lang.Object

For now this class renders only images supported by the javax.imageio.ImageIO framework. Subclasses can override this class to support other formats, for example, Use Apache batik to render WMF:

 public class MyImageRendener extends XSLFImageRendener{
 public boolean drawImage(Graphics2D graphics, XSLFPictureData data, Rectangle2D anchor){
        boolean ok = super.drawImage(graphics, data, anchor);
        if(!ok){
                // see what type of image we are
                String contentType = data.getPackagePart().getContentType();
                if(contentType.equals("image/wmf")){
                        // use Apache Batik to handle WMF
                        // see http://xmlgraphics.apache.org/batik/
                }

        }
        return ok;
 }
 }
and then pass this class to your instance of java.awt.Graphics2D:

 graphics.setRenderingHint(XSLFRenderingHint.IMAGE_RENDERER, new MyImageRendener());

Author:
Yegor Kozlov

Constructor Summary
XSLFImageRenderer()
Method Summary
boolean | drawImage(java.awt.Graphics2D graphics, XSLFPictureData data, java.awt.geom.Rectangle2D anchor) Render picture data into the supplied graphics
java.awt.image.BufferedImage | readImage(PackagePart packagePart) Create a buffered image from the supplied package part.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSLFImageRenderer

public XSLFImageRenderer()
Method Detail

drawImage

public boolean drawImage(java.awt.Graphics2D graphics,
                         XSLFPictureData data,
                         java.awt.geom.Rectangle2D anchor)
Render picture data into the supplied graphics

Returns:
true if the picture data was successfully rendered

readImage

public java.awt.image.BufferedImage readImage(PackagePart packagePart)
                                       throws java.io.IOException
Create a buffered image from the supplied package part. This method is called to create texture paints.

Returns:
a BufferedImage containing the decoded contents of the input, or null.
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFNotes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFNotes

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFSheet
            extended by  org.apache.poi.xslf.usermodel.XSLFNotes
All Implemented Interfaces:
java.lang.Iterable<XSLFShape>, XSLFShapeContainer
@Beta
public final class XSLFNotes
extends XSLFSheet

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Method Summary
XSLFNotesMaster | getMasterSheet()
protected java.lang.String | getRootElementName()
org.openxmlformats.schemas.presentationml.x2006.main.CTNotesSlide | getXmlObject()
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSheet
appendContent, buildShapes, canDraw, clear, commit, createAutoShape, createConnector, createFreeform, createGroup, createPicture, createTable, createTextBox, draw, getBackground, getCommonSlideData, getFollowMasterGraphics, getPlaceholder, getPlaceholders, getShapes, getSlideShow, getSpTree, getTextShapeByType, importContent, iterator, removeShape, setCommonSlideData
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getXmlObject

public org.openxmlformats.schemas.presentationml.x2006.main.CTNotesSlide getXmlObject()
Specified by:
getXmlObject in class XSLFSheet
Returns:
top-level Xml bean representing this sheet

getRootElementName

protected java.lang.String getRootElementName()
Specified by:
getRootElementName in class XSLFSheet

getMasterSheet

public XSLFNotesMaster getMasterSheet()
Specified by:
getMasterSheet in class XSLFSheet
Returns:
master of this sheet.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFNotesMaster

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFNotesMaster

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFSheet
            extended by  org.apache.poi.xslf.usermodel.XSLFNotesMaster
All Implemented Interfaces:
java.lang.Iterable<XSLFShape>, XSLFShapeContainer
@Beta
public class XSLFNotesMaster
extends XSLFSheet

Notes master object associated with this layout.

Within a notes master slide are contained all elements that describe the objects and their corresponding formatting for within a presentation slide.

Within a nodes master slide are two main elements. The cSld element specifies the common slide elements such as shapes and their attached text bodies. Then the notesStyles element specifies the formatting for the text within each of these shapes.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected XSLFNotesMaster(PackagePart part, PackageRelationship rel)
Method Summary
XSLFSheet | getMasterSheet()
protected java.lang.String | getRootElementName()
org.openxmlformats.schemas.presentationml.x2006.main.CTNotesMaster | getXmlObject()
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSheet
appendContent, buildShapes, canDraw, clear, commit, createAutoShape, createConnector, createFreeform, createGroup, createPicture, createTable, createTextBox, draw, getBackground, getCommonSlideData, getFollowMasterGraphics, getPlaceholder, getPlaceholders, getShapes, getSlideShow, getSpTree, getTextShapeByType, importContent, iterator, removeShape, setCommonSlideData
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSLFNotesMaster

protected XSLFNotesMaster(PackagePart part,
                          PackageRelationship rel)
                   throws java.io.IOException,
                          org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getXmlObject

public org.openxmlformats.schemas.presentationml.x2006.main.CTNotesMaster getXmlObject()
Specified by:
getXmlObject in class XSLFSheet
Returns:
top-level Xml bean representing this sheet

getRootElementName

protected java.lang.String getRootElementName()
Specified by:
getRootElementName in class XSLFSheet

getMasterSheet

public XSLFSheet getMasterSheet()
Specified by:
getMasterSheet in class XSLFSheet
Returns:
master of this sheet.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFPictureData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFPictureData

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFPictureData

@Beta
public final class XSLFPictureData
extends POIXMLDocumentPart

Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type

Author:
Yegor Kozlov

Field Summary
static int | PICTURE_TYPE_BMP Windows Bitmap (.bmp)
static int | PICTURE_TYPE_DIB Device independent bitmap
static int | PICTURE_TYPE_EMF Extended windows meta file
static int | PICTURE_TYPE_EPS Encapsulated Postscript (.eps)
static int | PICTURE_TYPE_GIF GIF image format
static int | PICTURE_TYPE_JPEG JPEG format
static int | PICTURE_TYPE_PICT Mac PICT format
static int | PICTURE_TYPE_PNG PNG format
static int | PICTURE_TYPE_TIFF Tag Image File (.tiff)
static int | PICTURE_TYPE_WMF Windows Meta File
static int | PICTURE_TYPE_WPG WordPerfect graphics (.wpg)
protected static POIXMLRelation[] | RELATIONS Relationships for each known picture type
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected | XSLFPictureData() Create a new XSLFGraphicData node
 | XSLFPictureData(PackagePart part, PackageRelationship rel) Construct XSLFPictureData from a package part
Method Summary
byte[] | getData() Gets the picture data as a byte array.
java.lang.String | getFileName() Returns the file name of the image, eg image7.jpg .
int | getPictureType() Return an integer constant that specifies type of this picture
java.lang.String | suggestFileExtension() Suggests a file extension for this image.
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

PICTURE_TYPE_EMF

public static final int PICTURE_TYPE_EMF
Extended windows meta file

See Also:
Constant Field Values

PICTURE_TYPE_WMF

public static final int PICTURE_TYPE_WMF
Windows Meta File

See Also:
Constant Field Values

PICTURE_TYPE_PICT

public static final int PICTURE_TYPE_PICT
Mac PICT format

See Also:
Constant Field Values

PICTURE_TYPE_JPEG

public static final int PICTURE_TYPE_JPEG
JPEG format

See Also:
Constant Field Values

PICTURE_TYPE_PNG

public static final int PICTURE_TYPE_PNG
PNG format

See Also:
Constant Field Values

PICTURE_TYPE_DIB

public static final int PICTURE_TYPE_DIB
Device independent bitmap

See Also:
Constant Field Values

PICTURE_TYPE_GIF

public static final int PICTURE_TYPE_GIF
GIF image format

See Also:
Constant Field Values

PICTURE_TYPE_TIFF

public static final int PICTURE_TYPE_TIFF
Tag Image File (.tiff)

See Also:
Constant Field Values

PICTURE_TYPE_EPS

public static final int PICTURE_TYPE_EPS
Encapsulated Postscript (.eps)

See Also:
Constant Field Values

PICTURE_TYPE_BMP

public static final int PICTURE_TYPE_BMP
Windows Bitmap (.bmp)

See Also:
Constant Field Values

PICTURE_TYPE_WPG

public static final int PICTURE_TYPE_WPG
WordPerfect graphics (.wpg)

See Also:
Constant Field Values

RELATIONS

protected static final POIXMLRelation[] RELATIONS
Relationships for each known picture type

Constructor Detail

XSLFPictureData

protected XSLFPictureData()
Create a new XSLFGraphicData node

XSLFPictureData

public XSLFPictureData(PackagePart part,
                       PackageRelationship rel)
Construct XSLFPictureData from a package part

Parameters:
part - the package part holding the drawing data,
rel - the package relationship holding this drawing, the relationship type must be http://schemas.openxmlformats.org/officeDocument/2006/relationships/image
Method Detail

getData

public byte[] getData()
Gets the picture data as a byte array.

Note, that this call might be expensive since all the picture data is copied into a temporary byte array. You can grab the picture data directly from the underlying package part as follows:
InputStream is = getPackagePart().getInputStream();

Returns:
the Picture data.

getFileName

public java.lang.String getFileName()
Returns the file name of the image, eg image7.jpg . The original filename isn't always available, but if it can be found it's likely to be in the CTDrawing

suggestFileExtension

public java.lang.String suggestFileExtension()
Suggests a file extension for this image.

Returns:
the file extension.

getPictureType

public int getPictureType()
Return an integer constant that specifies type of this picture

Returns:
an integer constant that specifies type of this picture
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFPictureShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFPictureShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFPictureShape

@Beta
public class XSLFPictureShape
extends XSLFSimpleShape

Represents a picture shape

Author:
Yegor Kozlov

Method Summary
void | drawContent(java.awt.Graphics2D graphics) draw any content within this shape (image, text, etc.).
XSLFPictureData | getPictureData()
void | resize() Resize this picture to the default size.
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, getAnchor, getCTPlaceholder, getFillColor, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setAnchor, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

resize

public void resize()
Resize this picture to the default size. For PNG and JPEG resizes the image to 100%, for other types sets the default size of 200x200 pixels.

getPictureData

public XSLFPictureData getPictureData()

drawContent

public void drawContent(java.awt.Graphics2D graphics)
Description copied from class: XSLFSimpleShape
draw any content within this shape (image, text, etc.).

Overrides:
drawContent in class XSLFSimpleShape
Parameters:
graphics - the graphics to draw into
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFRelation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFRelation

java.lang.Object
    extended by  org.apache.poi.POIXMLRelation
        extended by  org.apache.poi.xslf.usermodel.XSLFRelation

@Beta
public class XSLFRelation
extends POIXMLRelation

Field Summary
protected static java.util.Map<java.lang.String,XSLFRelation> | _table A map to lookup POIXMLRelation by its relation type
static XSLFRelation | COMMENT_AUTHORS
static XSLFRelation | COMMENTS
static XSLFRelation | HYPERLINK
static XSLFRelation | IMAGE_BMP
static XSLFRelation | IMAGE_DIB
static XSLFRelation | IMAGE_EMF
static XSLFRelation | IMAGE_EPS
static XSLFRelation | IMAGE_GIF
static XSLFRelation | IMAGE_JPEG
static XSLFRelation | IMAGE_PICT
static XSLFRelation | IMAGE_PNG
static XSLFRelation | IMAGE_TIFF
static XSLFRelation | IMAGE_WMF
static XSLFRelation | IMAGE_WPG
static XSLFRelation | IMAGES
static XSLFRelation | MACRO
static XSLFRelation | MACRO_TEMPLATE
static XSLFRelation | MAIN
static XSLFRelation | NOTES
static XSLFRelation | NOTES_MASTER
static XSLFRelation | PRESENTATION_MACRO
static XSLFRelation | PRESENTATIONML
static XSLFRelation | PRESENTATIONML_TEMPLATE
static XSLFRelation | SLIDE
static XSLFRelation | SLIDE_LAYOUT
static XSLFRelation | SLIDE_MASTER
static XSLFRelation | TABLE_STYLES
static XSLFRelation | THEME
static XSLFRelation | THEME_MANAGER
static XSLFRelation | VML_DRAWING
Fields inherited from class org.apache.poi.POIXMLRelation
_defaultName, _relation, _type
Method Summary
static XSLFRelation getInstance(java.lang.String rel)
Get POIXMLRelation by relation type
Methods inherited from class org.apache.poi.POIXMLRelation
getContentType, getDefaultFileName, getFileName, getRelation, getRelationClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_table

protected static java.util.Map<java.lang.String,XSLFRelation> _table
A map to lookup POIXMLRelation by its relation type

MAIN

public static final XSLFRelation MAIN

MACRO

public static final XSLFRelation MACRO

MACRO_TEMPLATE

public static final XSLFRelation MACRO_TEMPLATE

PRESENTATIONML

public static final XSLFRelation PRESENTATIONML

PRESENTATIONML_TEMPLATE

public static final XSLFRelation PRESENTATIONML_TEMPLATE

PRESENTATION_MACRO

public static final XSLFRelation PRESENTATION_MACRO

THEME_MANAGER

public static final XSLFRelation THEME_MANAGER

NOTES

public static final XSLFRelation NOTES

SLIDE

public static final XSLFRelation SLIDE

SLIDE_LAYOUT

public static final XSLFRelation SLIDE_LAYOUT

SLIDE_MASTER

public static final XSLFRelation SLIDE_MASTER

NOTES_MASTER

public static final XSLFRelation NOTES_MASTER

COMMENTS

public static final XSLFRelation COMMENTS

COMMENT_AUTHORS

public static final XSLFRelation COMMENT_AUTHORS

HYPERLINK

public static final XSLFRelation HYPERLINK

THEME

public static final XSLFRelation THEME

VML_DRAWING

public static final XSLFRelation VML_DRAWING

IMAGE_EMF

public static final XSLFRelation IMAGE_EMF

IMAGE_WMF

public static final XSLFRelation IMAGE_WMF

IMAGE_PICT

public static final XSLFRelation IMAGE_PICT

IMAGE_JPEG

public static final XSLFRelation IMAGE_JPEG

IMAGE_PNG

public static final XSLFRelation IMAGE_PNG

IMAGE_DIB

public static final XSLFRelation IMAGE_DIB

IMAGE_GIF

public static final XSLFRelation IMAGE_GIF

IMAGE_TIFF

public static final XSLFRelation IMAGE_TIFF

IMAGE_EPS

public static final XSLFRelation IMAGE_EPS

IMAGE_BMP

public static final XSLFRelation IMAGE_BMP

IMAGE_WPG

public static final XSLFRelation IMAGE_WPG

IMAGES

public static final XSLFRelation IMAGES

TABLE_STYLES

public static final XSLFRelation TABLE_STYLES
Method Detail

getInstance

public static XSLFRelation getInstance(java.lang.String rel)
Get POIXMLRelation by relation type

Parameters:
rel - relation type, for example, http://schemas.openxmlformats.org/officeDocument/2006/relationships/image
Returns:
registered POIXMLRelation or null if not found
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFRenderingHint

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFRenderingHint

java.lang.Object
    extended by  java.awt.RenderingHints.Key
        extended by  org.apache.poi.xslf.usermodel.XSLFRenderingHint

public class XSLFRenderingHint
extends java.awt.RenderingHints.Key

Author:
Yegor Kozlov

Field Summary
static XSLFRenderingHint | FONT_HANDLER Use this object to resolve unknown / missing fonts when rendering slides
static XSLFRenderingHint | GRESTORE
static XSLFRenderingHint | GSAVE
static XSLFRenderingHint | IMAGE_RENDERER Use a custom image rendener
static int | TEXT_AS_CHARACTERS draw text via Graphics2D.drawString(java.text.AttributedCharacterIterator, float, float)
static int | TEXT_AS_SHAPES draw text via TextLayout.draw(java.awt.Graphics2D, float, float)
static XSLFRenderingHint | TEXT_RENDERING_MODE how to render text: TEXT_AS_CHARACTERS (default) means to draw via Graphics2D.drawString(java.text.AttributedCharacterIterator, float, float).
Constructor Summary
XSLFRenderingHint(int i)
Method Summary
 boolean isCompatibleValue(java.lang.Object val)
Methods inherited from class java.awt.RenderingHints.Key
equals, hashCode, intKey
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

GSAVE

public static final XSLFRenderingHint GSAVE

GRESTORE

public static final XSLFRenderingHint GRESTORE

IMAGE_RENDERER

public static final XSLFRenderingHint IMAGE_RENDERER
Use a custom image rendener

See Also:
XSLFImageRenderer

TEXT_RENDERING_MODE

public static final XSLFRenderingHint TEXT_RENDERING_MODE
how to render text: TEXT_AS_CHARACTERS (default) means to draw via Graphics2D.drawString(java.text.AttributedCharacterIterator, float, float). This mode draws text as characters. Use it if the target graphics writes the actual character codes instead of glyph outlines (PDFGraphics2D, SVGGraphics2D, etc.) TEXT_AS_SHAPES means to render via TextLayout.draw(java.awt.Graphics2D, float, float). This mode draws glyphs as shapes and provides some advanced capabilities such as justification and font substitution. Use it if the target graphics is an image.

TEXT_AS_CHARACTERS

public static final int TEXT_AS_CHARACTERS
draw text via Graphics2D.drawString(java.text.AttributedCharacterIterator, float, float)

See Also:
Constant Field Values

TEXT_AS_SHAPES

public static final int TEXT_AS_SHAPES
draw text via TextLayout.draw(java.awt.Graphics2D, float, float)

See Also:
Constant Field Values

FONT_HANDLER

public static final XSLFRenderingHint FONT_HANDLER
Use this object to resolve unknown / missing fonts when rendering slides

Constructor Detail

XSLFRenderingHint

public XSLFRenderingHint(int i)
Method Detail

isCompatibleValue

public boolean isCompatibleValue(java.lang.Object val)
Specified by:
isCompatibleValue in class java.awt.RenderingHints.Key
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFShadow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFShadow

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFShadow

public class XSLFShadow
extends XSLFSimpleShape

Represents a shadow of a shape. For now supports only outer shadows.

Author:
Yegor Kozlov

Method Summary
void | draw(java.awt.Graphics2D graphics, java.awt.Shape outline)
void | fill(java.awt.Graphics2D graphics, java.awt.Shape outline)
java.awt.geom.Rectangle2D | getAnchor()
double | getAngle()
double | getBlur()
double | getDistance()
java.awt.Color | getFillColor()
void | setAnchor(java.awt.geom.Rectangle2D anchor)
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, drawContent, getCTPlaceholder, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

fill

public void fill(java.awt.Graphics2D graphics,
                 java.awt.Shape outline)

draw

public void draw(java.awt.Graphics2D graphics,
                 java.awt.Shape outline)

getAnchor

public java.awt.geom.Rectangle2D getAnchor()
Overrides:
getAnchor in class XSLFSimpleShape
Returns:
the position of this shape within the drawing canvas. The coordinates are expressed in points

setAnchor

public void setAnchor(java.awt.geom.Rectangle2D anchor)
Overrides:
setAnchor in class XSLFSimpleShape
Parameters:
anchor - the position of this shape within the drawing canvas. The coordinates are expressed in points

getDistance

public double getDistance()
Returns:
the offset of this shadow in points

getAngle

public double getAngle()
Returns:
the direction to offset the shadow in angles

getBlur

public double getBlur()
Returns:
the blur radius of the shadow TODO: figure out how to make sense of this property when rendering shadows

getFillColor

public java.awt.Color getFillColor()
Overrides:
getFillColor in class XSLFSimpleShape
Returns:
the color of this shadow. Depending whether the parent shape is filled or stroked, this color is used to fill or stroke this shadow
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
Direct Known Subclasses:
XSLFGraphicFrame, XSLFGroupShape, XSLFSimpleShape
@Beta
public abstract class XSLFShape
extends java.lang.Object

Base super-class class for all shapes in PresentationML

Author:
Yegor Kozlov

Constructor Summary
XSLFShape()
Method Summary
protected void | applyTransform(java.awt.Graphics2D graphics) Apply 2-D transforms before drawing this shape.
abstract void | draw(java.awt.Graphics2D graphics) Draw this shape into the supplied canvas
abstract java.awt.geom.Rectangle2D | getAnchor()
abstract boolean | getFlipHorizontal() Whether the shape is horizontally flipped
abstract boolean | getFlipVertical() Whether the shape is vertically flipped
abstract double | getRotation() Rotation angle in degrees
abstract int | getShapeId() Returns a unique identifier for this shape within the current document.
abstract java.lang.String | getShapeName()
abstract org.apache.xmlbeans.XmlObject | getXmlObject()
abstract void | setAnchor(java.awt.geom.Rectangle2D anchor)
abstract void | setFlipHorizontal(boolean flip)
abstract void | setFlipVertical(boolean flip) Whether the shape is vertically flipped
abstract void | setRotation(double theta) Rotate this shape.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSLFShape

public XSLFShape()
Method Detail

getAnchor

public abstract java.awt.geom.Rectangle2D getAnchor()
Returns:
the position of this shape within the drawing canvas. The coordinates are expressed in points

setAnchor

public abstract void setAnchor(java.awt.geom.Rectangle2D anchor)
Parameters:
anchor - the position of this shape within the drawing canvas. The coordinates are expressed in points

getXmlObject

public abstract org.apache.xmlbeans.XmlObject getXmlObject()
Returns:
the xml bean holding this shape's data

getShapeName

public abstract java.lang.String getShapeName()
Returns:
human-readable name of this shape, e.g. "Rectange 3"

getShapeId

public abstract int getShapeId()
Returns a unique identifier for this shape within the current document. This ID may be used to assist in uniquely identifying this object so that it can be referred to by other parts of the document.

If multiple objects within the same document share the same id attribute value, then the document shall be considered non-conformant.

Returns:
unique id of this shape

setRotation

public abstract void setRotation(double theta)
Rotate this shape.

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Parameters:
theta - the rotation angle in degrees.

getRotation

public abstract double getRotation()
Rotation angle in degrees

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Returns:
rotation angle in degrees

setFlipHorizontal

public abstract void setFlipHorizontal(boolean flip)
Parameters:
flip - whether the shape is horizontally flipped

setFlipVertical

public abstract void setFlipVertical(boolean flip)
Whether the shape is vertically flipped

Parameters:
flip - whether the shape is vertically flipped

getFlipHorizontal

public abstract boolean getFlipHorizontal()
Whether the shape is horizontally flipped

Returns:
whether the shape is horizontally flipped

getFlipVertical

public abstract boolean getFlipVertical()
Whether the shape is vertically flipped

Returns:
whether the shape is vertically flipped

draw

public abstract void draw(java.awt.Graphics2D graphics)
Draw this shape into the supplied canvas

Parameters:
graphics - the graphics to draw into

applyTransform

protected void applyTransform(java.awt.Graphics2D graphics)
Apply 2-D transforms before drawing this shape. This includes rotation and flipping.

Parameters:
graphics - the graphics whos transform matrix will be modified
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFShapeContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Interface XSLFShapeContainer

All Superinterfaces:
java.lang.Iterable<XSLFShape>
All Known Implementing Classes:
XSLFGroupShape, XSLFNotes, XSLFNotesMaster, XSLFSheet, XSLFSlide, XSLFSlideLayout, XSLFSlideMaster
public interface XSLFShapeContainer
extends java.lang.Iterable<XSLFShape>

Common interface for shape containers, e.g. sheets or groups of shapes

Method Summary
void | clear() Removes all of the elements from this container (optional operation).
XSLFAutoShape | createAutoShape() create a new shape with a predefined geometry and add it to this shape container
XSLFConnectorShape | createConnector() create a connector
XSLFFreeformShape | createFreeform() create a new shape with a custom geometry
XSLFGroupShape | createGroup() create a group of shapes belonging to this container
XSLFPictureShape | createPicture(int pictureIndex) create a picture belonging to this container
XSLFTextBox | createTextBox() create a text box
XSLFShape[] | getShapes() Returns an array containing all of the elements in this container in proper sequence (from first to last element).
boolean | removeShape(XSLFShape xShape) Removes the specified shape from this sheet, if it is present (optional operation).
Methods inherited from interface java.lang.Iterable
iterator

Method Detail

createAutoShape

XSLFAutoShape createAutoShape()
create a new shape with a predefined geometry and add it to this shape container

createFreeform

XSLFFreeformShape createFreeform()
create a new shape with a custom geometry

createTextBox

XSLFTextBox createTextBox()
create a text box

createConnector

XSLFConnectorShape createConnector()
create a connector

createGroup

XSLFGroupShape createGroup()
create a group of shapes belonging to this container

createPicture

XSLFPictureShape createPicture(int pictureIndex)
create a picture belonging to this container

Parameters:
pictureIndex -
Returns:

getShapes

XSLFShape[] getShapes()
Returns an array containing all of the elements in this container in proper sequence (from first to last element).

Returns:
an array containing all of the elements in this container in proper sequence

removeShape

boolean removeShape(XSLFShape xShape)
Removes the specified shape from this sheet, if it is present (optional operation). If this sheet does not contain the element, it is unchanged.

Parameters:
xShape - shape to be removed from this sheet, if present
Returns:
true if this sheet contained the specified element
Throws:
java.lang.IllegalArgumentException - if the type of the specified shape is incompatible with this sheet (optional)

clear

void clear()
Removes all of the elements from this container (optional operation). The container will be empty after this call returns.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFShapeType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xslf.usermodel
Enum XSLFShapeType

java.lang.Object
    extended by  java.lang.Enum<XSLFShapeType>
        extended by  org.apache.poi.xslf.usermodel.XSLFShapeType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<XSLFShapeType>
public enum XSLFShapeType
extends java.lang.Enum<XSLFShapeType>

known preset shape geometries in PresentationML

Author:
Yegor Kozlov

Enum Constant Summary
ACCENT_BORDER_CALLOUT_1
ACCENT_BORDER_CALLOUT_2
ACCENT_BORDER_CALLOUT_3
ACCENT_CALLOUT_1
ACCENT_CALLOUT_2
ACCENT_CALLOUT_3
ACTION_BUTTON_BACK_PREVIOUS
ACTION_BUTTON_BEGINNING
ACTION_BUTTON_BLANK
ACTION_BUTTON_DOCUMENT
ACTION_BUTTON_END
ACTION_BUTTON_FORWARD_NEXT
ACTION_BUTTON_HELP
ACTION_BUTTON_HOME
ACTION_BUTTON_INFORMATION
ACTION_BUTTON_MOVIE
ACTION_BUTTON_RETURN
ACTION_BUTTON_SOUND
ARC
BENT_ARROW
BENT_CONNECTOR_2
BENT_CONNECTOR_3
BENT_CONNECTOR_4
BENT_CONNECTOR_5
BENT_UP_ARROW
BEVEL
BLOCK_ARC
BORDER_CALLOUT_1
BORDER_CALLOUT_2
BORDER_CALLOUT_3
BRACE_PAIR
BRACKET_PAIR
CALLOUT_1
CALLOUT_2
CALLOUT_3
CAN
CHART_PLUS
CHART_STAR
CHART_X
CHEVRON
CHORD
CIRCULAR_ARROW
CLOUD
CLOUD_CALLOUT
CORNER
CORNER_TABS
CUBE
CURVED_CONNECTOR_2
CURVED_CONNECTOR_3
CURVED_CONNECTOR_4
CURVED_CONNECTOR_5
CURVED_DOWN_ARROW
CURVED_LEFT_ARROW
CURVED_RIGHT_ARROW
CURVED_UP_ARROW
DECAGON
DIAG_STRIPE
DIAMOND
DODECAGON
DONUT
DOUBLE_WAVE
DOWN_ARROW
DOWN_ARROW_CALLOUT
ELLIPSE
ELLIPSE_RIBBON
ELLIPSE_RIBBON_2
FLOW_CHART_ALTERNATE_PROCESS
FLOW_CHART_COLLATE
FLOW_CHART_CONNECTOR
FLOW_CHART_DECISION
FLOW_CHART_DELAY
FLOW_CHART_DISPLAY
FLOW_CHART_DOCUMENT
FLOW_CHART_EXTRACT
FLOW_CHART_INPUT_OUTPUT
FLOW_CHART_INTERNAL_STORAGE
FLOW_CHART_MAGNETIC_DISK
FLOW_CHART_MAGNETIC_DRUM
FLOW_CHART_MAGNETIC_TAPE
FLOW_CHART_MANUAL_INPUT
FLOW_CHART_MANUAL_OPERATION
FLOW_CHART_MERGE
FLOW_CHART_MULTIDOCUMENT
FLOW_CHART_OFFLINE_STORAGE
FLOW_CHART_OFFPAGE_CONNECTOR
FLOW_CHART_ONLINE_STORAGE
FLOW_CHART_OR
FLOW_CHART_PREDEFINED_PROCESS
FLOW_CHART_PREPARATION
FLOW_CHART_PROCESS
FLOW_CHART_PUNCHED_CARD
FLOW_CHART_PUNCHED_TAPE
FLOW_CHART_SORT
FLOW_CHART_SUMMING_JUNCTION
FLOW_CHART_TERMINATOR
FOLDED_CORNER
FRAME
FUNNEL
GEAR_6
GEAR_9
HALF_FRAME
HEART
HEPTAGON
HEXAGON
HOME_PLATE
HORIZONTAL_SCROLL
IRREGULAR_SEAL_1
IRREGULAR_SEAL_2
LEFT_ARROW
LEFT_ARROW_CALLOUT
LEFT_BRACE
LEFT_BRACKET
LEFT_CIRCULAR_ARROW
LEFT_RIGHT_ARROW
LEFT_RIGHT_ARROW_CALLOUT
LEFT_RIGHT_CIRCULAR_ARROW
LEFT_RIGHT_RIBBON
LEFT_RIGHT_UP_ARROW
LEFT_UP_ARROW
LIGHTNING_BOLT
LINE
LINE_INV
MATH_DIVIDE
MATH_EQUAL
MATH_MINUS
MATH_MULTIPLY
MATH_NOT_EQUAL
MATH_PLUS
MOON
NO_SMOKING
NON_ISOSCELES_TRAPEZOID
NOTCHED_RIGHT_ARROW
OCTAGON
PARALLELOGRAM
PENTAGON
PIE
PIE_WEDGE
PLAQUE
PLAQUE_TABS
PLUS
QUAD_ARROW
QUAD_ARROW_CALLOUT
RECT
RIBBON
RIBBON_2
RIGHT_ARROW
RIGHT_ARROW_CALLOUT
RIGHT_BRACE
RIGHT_BRACKET
ROUND_1_RECT
ROUND_2_DIAG_RECT
ROUND_2_SAME_RECT
ROUND_RECT
RT_TRIANGLE
SMILEY_FACE
SNIP_1_RECT
SNIP_2_DIAG_RECT
SNIP_2_SAME_RECT
SNIP_ROUND_RECT
SQUARE_TABS
STAR_10
STAR_12
STAR_16
STAR_24
STAR_32
STAR_4
STAR_5
STAR_6
STAR_7
STAR_8
STRAIGHT_CONNECTOR_1
STRIPED_RIGHT_ARROW
SUN
SWOOSH_ARROW
TEARDROP
TRAPEZOID
TRIANGLE
UP_ARROW
UP_ARROW_CALLOUT
UP_DOWN_ARROW
UP_DOWN_ARROW_CALLOUT
UTURN_ARROW
VERTICAL_SCROLL
WAVE
WEDGE_ELLIPSE_CALLOUT
WEDGE_RECT_CALLOUT
WEDGE_ROUND_RECT_CALLOUT
Method Summary
static XSLFShapeType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XSLFShapeType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LINE

public static final XSLFShapeType LINE

LINE_INV

public static final XSLFShapeType LINE_INV

TRIANGLE

public static final XSLFShapeType TRIANGLE

RT_TRIANGLE

public static final XSLFShapeType RT_TRIANGLE

RECT

public static final XSLFShapeType RECT

DIAMOND

public static final XSLFShapeType DIAMOND

PARALLELOGRAM

public static final XSLFShapeType PARALLELOGRAM

TRAPEZOID

public static final XSLFShapeType TRAPEZOID

NON_ISOSCELES_TRAPEZOID

public static final XSLFShapeType NON_ISOSCELES_TRAPEZOID

PENTAGON

public static final XSLFShapeType PENTAGON

HEXAGON

public static final XSLFShapeType HEXAGON

HEPTAGON

public static final XSLFShapeType HEPTAGON

OCTAGON

public static final XSLFShapeType OCTAGON

DECAGON

public static final XSLFShapeType DECAGON

DODECAGON

public static final XSLFShapeType DODECAGON

STAR_4

public static final XSLFShapeType STAR_4

STAR_5

public static final XSLFShapeType STAR_5

STAR_6

public static final XSLFShapeType STAR_6

STAR_7

public static final XSLFShapeType STAR_7

STAR_8

public static final XSLFShapeType STAR_8

STAR_10

public static final XSLFShapeType STAR_10

STAR_12

public static final XSLFShapeType STAR_12

STAR_16

public static final XSLFShapeType STAR_16

STAR_24

public static final XSLFShapeType STAR_24

STAR_32

public static final XSLFShapeType STAR_32

ROUND_RECT

public static final XSLFShapeType ROUND_RECT

ROUND_1_RECT

public static final XSLFShapeType ROUND_1_RECT

ROUND_2_SAME_RECT

public static final XSLFShapeType ROUND_2_SAME_RECT

ROUND_2_DIAG_RECT

public static final XSLFShapeType ROUND_2_DIAG_RECT

SNIP_ROUND_RECT

public static final XSLFShapeType SNIP_ROUND_RECT

SNIP_1_RECT

public static final XSLFShapeType SNIP_1_RECT

SNIP_2_SAME_RECT

public static final XSLFShapeType SNIP_2_SAME_RECT

SNIP_2_DIAG_RECT

public static final XSLFShapeType SNIP_2_DIAG_RECT

PLAQUE

public static final XSLFShapeType PLAQUE

ELLIPSE

public static final XSLFShapeType ELLIPSE

TEARDROP

public static final XSLFShapeType TEARDROP

HOME_PLATE

public static final XSLFShapeType HOME_PLATE

CHEVRON

public static final XSLFShapeType CHEVRON

PIE_WEDGE

public static final XSLFShapeType PIE_WEDGE

PIE

public static final XSLFShapeType PIE

BLOCK_ARC

public static final XSLFShapeType BLOCK_ARC

DONUT

public static final XSLFShapeType DONUT

NO_SMOKING

public static final XSLFShapeType NO_SMOKING

RIGHT_ARROW

public static final XSLFShapeType RIGHT_ARROW

LEFT_ARROW

public static final XSLFShapeType LEFT_ARROW

UP_ARROW

public static final XSLFShapeType UP_ARROW

DOWN_ARROW

public static final XSLFShapeType DOWN_ARROW

STRIPED_RIGHT_ARROW

public static final XSLFShapeType STRIPED_RIGHT_ARROW

NOTCHED_RIGHT_ARROW

public static final XSLFShapeType NOTCHED_RIGHT_ARROW

BENT_UP_ARROW

public static final XSLFShapeType BENT_UP_ARROW

LEFT_RIGHT_ARROW

public static final XSLFShapeType LEFT_RIGHT_ARROW

UP_DOWN_ARROW

public static final XSLFShapeType UP_DOWN_ARROW

LEFT_UP_ARROW

public static final XSLFShapeType LEFT_UP_ARROW

LEFT_RIGHT_UP_ARROW

public static final XSLFShapeType LEFT_RIGHT_UP_ARROW

QUAD_ARROW

public static final XSLFShapeType QUAD_ARROW

LEFT_ARROW_CALLOUT

public static final XSLFShapeType LEFT_ARROW_CALLOUT

RIGHT_ARROW_CALLOUT

public static final XSLFShapeType RIGHT_ARROW_CALLOUT

UP_ARROW_CALLOUT

public static final XSLFShapeType UP_ARROW_CALLOUT

DOWN_ARROW_CALLOUT

public static final XSLFShapeType DOWN_ARROW_CALLOUT

LEFT_RIGHT_ARROW_CALLOUT

public static final XSLFShapeType LEFT_RIGHT_ARROW_CALLOUT

UP_DOWN_ARROW_CALLOUT

public static final XSLFShapeType UP_DOWN_ARROW_CALLOUT

QUAD_ARROW_CALLOUT

public static final XSLFShapeType QUAD_ARROW_CALLOUT

BENT_ARROW

public static final XSLFShapeType BENT_ARROW

UTURN_ARROW

public static final XSLFShapeType UTURN_ARROW

CIRCULAR_ARROW

public static final XSLFShapeType CIRCULAR_ARROW

LEFT_CIRCULAR_ARROW

public static final XSLFShapeType LEFT_CIRCULAR_ARROW

LEFT_RIGHT_CIRCULAR_ARROW

public static final XSLFShapeType LEFT_RIGHT_CIRCULAR_ARROW

CURVED_RIGHT_ARROW

public static final XSLFShapeType CURVED_RIGHT_ARROW

CURVED_LEFT_ARROW

public static final XSLFShapeType CURVED_LEFT_ARROW

CURVED_UP_ARROW

public static final XSLFShapeType CURVED_UP_ARROW

CURVED_DOWN_ARROW

public static final XSLFShapeType CURVED_DOWN_ARROW

SWOOSH_ARROW

public static final XSLFShapeType SWOOSH_ARROW

CUBE

public static final XSLFShapeType CUBE

CAN

public static final XSLFShapeType CAN

LIGHTNING_BOLT

public static final XSLFShapeType LIGHTNING_BOLT

HEART

public static final XSLFShapeType HEART

SUN

public static final XSLFShapeType SUN

MOON

public static final XSLFShapeType MOON

SMILEY_FACE

public static final XSLFShapeType SMILEY_FACE

IRREGULAR_SEAL_1

public static final XSLFShapeType IRREGULAR_SEAL_1

IRREGULAR_SEAL_2

public static final XSLFShapeType IRREGULAR_SEAL_2

FOLDED_CORNER

public static final XSLFShapeType FOLDED_CORNER

BEVEL

public static final XSLFShapeType BEVEL

FRAME

public static final XSLFShapeType FRAME

HALF_FRAME

public static final XSLFShapeType HALF_FRAME

CORNER

public static final XSLFShapeType CORNER

DIAG_STRIPE

public static final XSLFShapeType DIAG_STRIPE

CHORD

public static final XSLFShapeType CHORD

ARC

public static final XSLFShapeType ARC

LEFT_BRACKET

public static final XSLFShapeType LEFT_BRACKET

RIGHT_BRACKET

public static final XSLFShapeType RIGHT_BRACKET

LEFT_BRACE

public static final XSLFShapeType LEFT_BRACE

RIGHT_BRACE

public static final XSLFShapeType RIGHT_BRACE

BRACKET_PAIR

public static final XSLFShapeType BRACKET_PAIR

BRACE_PAIR

public static final XSLFShapeType BRACE_PAIR

STRAIGHT_CONNECTOR_1

public static final XSLFShapeType STRAIGHT_CONNECTOR_1

BENT_CONNECTOR_2

public static final XSLFShapeType BENT_CONNECTOR_2

BENT_CONNECTOR_3

public static final XSLFShapeType BENT_CONNECTOR_3

BENT_CONNECTOR_4

public static final XSLFShapeType BENT_CONNECTOR_4

BENT_CONNECTOR_5

public static final XSLFShapeType BENT_CONNECTOR_5

CURVED_CONNECTOR_2

public static final XSLFShapeType CURVED_CONNECTOR_2

CURVED_CONNECTOR_3

public static final XSLFShapeType CURVED_CONNECTOR_3

CURVED_CONNECTOR_4

public static final XSLFShapeType CURVED_CONNECTOR_4

CURVED_CONNECTOR_5

public static final XSLFShapeType CURVED_CONNECTOR_5

CALLOUT_1

public static final XSLFShapeType CALLOUT_1

CALLOUT_2

public static final XSLFShapeType CALLOUT_2

CALLOUT_3

public static final XSLFShapeType CALLOUT_3

ACCENT_CALLOUT_1

public static final XSLFShapeType ACCENT_CALLOUT_1

ACCENT_CALLOUT_2

public static final XSLFShapeType ACCENT_CALLOUT_2

ACCENT_CALLOUT_3

public static final XSLFShapeType ACCENT_CALLOUT_3

BORDER_CALLOUT_1

public static final XSLFShapeType BORDER_CALLOUT_1

BORDER_CALLOUT_2

public static final XSLFShapeType BORDER_CALLOUT_2

BORDER_CALLOUT_3

public static final XSLFShapeType BORDER_CALLOUT_3

ACCENT_BORDER_CALLOUT_1

public static final XSLFShapeType ACCENT_BORDER_CALLOUT_1

ACCENT_BORDER_CALLOUT_2

public static final XSLFShapeType ACCENT_BORDER_CALLOUT_2

ACCENT_BORDER_CALLOUT_3

public static final XSLFShapeType ACCENT_BORDER_CALLOUT_3

WEDGE_RECT_CALLOUT

public static final XSLFShapeType WEDGE_RECT_CALLOUT

WEDGE_ROUND_RECT_CALLOUT

public static final XSLFShapeType WEDGE_ROUND_RECT_CALLOUT

WEDGE_ELLIPSE_CALLOUT

public static final XSLFShapeType WEDGE_ELLIPSE_CALLOUT

CLOUD_CALLOUT

public static final XSLFShapeType CLOUD_CALLOUT

CLOUD

public static final XSLFShapeType CLOUD

RIBBON

public static final XSLFShapeType RIBBON

RIBBON_2

public static final XSLFShapeType RIBBON_2

ELLIPSE_RIBBON

public static final XSLFShapeType ELLIPSE_RIBBON

ELLIPSE_RIBBON_2

public static final XSLFShapeType ELLIPSE_RIBBON_2

LEFT_RIGHT_RIBBON

public static final XSLFShapeType LEFT_RIGHT_RIBBON

VERTICAL_SCROLL

public static final XSLFShapeType VERTICAL_SCROLL

HORIZONTAL_SCROLL

public static final XSLFShapeType HORIZONTAL_SCROLL

WAVE

public static final XSLFShapeType WAVE

DOUBLE_WAVE

public static final XSLFShapeType DOUBLE_WAVE

PLUS

public static final XSLFShapeType PLUS

FLOW_CHART_PROCESS

public static final XSLFShapeType FLOW_CHART_PROCESS

FLOW_CHART_DECISION

public static final XSLFShapeType FLOW_CHART_DECISION

FLOW_CHART_INPUT_OUTPUT

public static final XSLFShapeType FLOW_CHART_INPUT_OUTPUT

FLOW_CHART_PREDEFINED_PROCESS

public static final XSLFShapeType FLOW_CHART_PREDEFINED_PROCESS

FLOW_CHART_INTERNAL_STORAGE

public static final XSLFShapeType FLOW_CHART_INTERNAL_STORAGE

FLOW_CHART_DOCUMENT

public static final XSLFShapeType FLOW_CHART_DOCUMENT

FLOW_CHART_MULTIDOCUMENT

public static final XSLFShapeType FLOW_CHART_MULTIDOCUMENT

FLOW_CHART_TERMINATOR

public static final XSLFShapeType FLOW_CHART_TERMINATOR

FLOW_CHART_PREPARATION

public static final XSLFShapeType FLOW_CHART_PREPARATION

FLOW_CHART_MANUAL_INPUT

public static final XSLFShapeType FLOW_CHART_MANUAL_INPUT

FLOW_CHART_MANUAL_OPERATION

public static final XSLFShapeType FLOW_CHART_MANUAL_OPERATION

FLOW_CHART_CONNECTOR

public static final XSLFShapeType FLOW_CHART_CONNECTOR

FLOW_CHART_PUNCHED_CARD

public static final XSLFShapeType FLOW_CHART_PUNCHED_CARD

FLOW_CHART_PUNCHED_TAPE

public static final XSLFShapeType FLOW_CHART_PUNCHED_TAPE

FLOW_CHART_SUMMING_JUNCTION

public static final XSLFShapeType FLOW_CHART_SUMMING_JUNCTION

FLOW_CHART_OR

public static final XSLFShapeType FLOW_CHART_OR

FLOW_CHART_COLLATE

public static final XSLFShapeType FLOW_CHART_COLLATE

FLOW_CHART_SORT

public static final XSLFShapeType FLOW_CHART_SORT

FLOW_CHART_EXTRACT

public static final XSLFShapeType FLOW_CHART_EXTRACT

FLOW_CHART_MERGE

public static final XSLFShapeType FLOW_CHART_MERGE

FLOW_CHART_OFFLINE_STORAGE

public static final XSLFShapeType FLOW_CHART_OFFLINE_STORAGE

FLOW_CHART_ONLINE_STORAGE

public static final XSLFShapeType FLOW_CHART_ONLINE_STORAGE

FLOW_CHART_MAGNETIC_TAPE

public static final XSLFShapeType FLOW_CHART_MAGNETIC_TAPE

FLOW_CHART_MAGNETIC_DISK

public static final XSLFShapeType FLOW_CHART_MAGNETIC_DISK

FLOW_CHART_MAGNETIC_DRUM

public static final XSLFShapeType FLOW_CHART_MAGNETIC_DRUM

FLOW_CHART_DISPLAY

public static final XSLFShapeType FLOW_CHART_DISPLAY

FLOW_CHART_DELAY

public static final XSLFShapeType FLOW_CHART_DELAY

FLOW_CHART_ALTERNATE_PROCESS

public static final XSLFShapeType FLOW_CHART_ALTERNATE_PROCESS

FLOW_CHART_OFFPAGE_CONNECTOR

public static final XSLFShapeType FLOW_CHART_OFFPAGE_CONNECTOR

ACTION_BUTTON_BLANK

public static final XSLFShapeType ACTION_BUTTON_BLANK

ACTION_BUTTON_HOME

public static final XSLFShapeType ACTION_BUTTON_HOME

ACTION_BUTTON_HELP

public static final XSLFShapeType ACTION_BUTTON_HELP

ACTION_BUTTON_INFORMATION

public static final XSLFShapeType ACTION_BUTTON_INFORMATION

ACTION_BUTTON_FORWARD_NEXT

public static final XSLFShapeType ACTION_BUTTON_FORWARD_NEXT

ACTION_BUTTON_BACK_PREVIOUS

public static final XSLFShapeType ACTION_BUTTON_BACK_PREVIOUS

ACTION_BUTTON_END

public static final XSLFShapeType ACTION_BUTTON_END

ACTION_BUTTON_BEGINNING

public static final XSLFShapeType ACTION_BUTTON_BEGINNING

ACTION_BUTTON_RETURN

public static final XSLFShapeType ACTION_BUTTON_RETURN

ACTION_BUTTON_DOCUMENT

public static final XSLFShapeType ACTION_BUTTON_DOCUMENT

ACTION_BUTTON_SOUND

public static final XSLFShapeType ACTION_BUTTON_SOUND

ACTION_BUTTON_MOVIE

public static final XSLFShapeType ACTION_BUTTON_MOVIE

GEAR_6

public static final XSLFShapeType GEAR_6

GEAR_9

public static final XSLFShapeType GEAR_9

FUNNEL

public static final XSLFShapeType FUNNEL

MATH_PLUS

public static final XSLFShapeType MATH_PLUS

MATH_MINUS

public static final XSLFShapeType MATH_MINUS

MATH_MULTIPLY

public static final XSLFShapeType MATH_MULTIPLY

MATH_DIVIDE

public static final XSLFShapeType MATH_DIVIDE

MATH_EQUAL

public static final XSLFShapeType MATH_EQUAL

MATH_NOT_EQUAL

public static final XSLFShapeType MATH_NOT_EQUAL

CORNER_TABS

public static final XSLFShapeType CORNER_TABS

SQUARE_TABS

public static final XSLFShapeType SQUARE_TABS

PLAQUE_TABS

public static final XSLFShapeType PLAQUE_TABS

CHART_X

public static final XSLFShapeType CHART_X

CHART_STAR

public static final XSLFShapeType CHART_STAR

CHART_PLUS

public static final XSLFShapeType CHART_PLUS
Method Detail

values

public static XSLFShapeType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (XSLFShapeType c : XSLFShapeType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static XSLFShapeType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


XSLFSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFSheet

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFSheet
All Implemented Interfaces:
java.lang.Iterable<XSLFShape>, XSLFShapeContainer
Direct Known Subclasses:
XSLFNotes, XSLFNotesMaster, XSLFSlide, XSLFSlideLayout, XSLFSlideMaster
@Beta
public abstract class XSLFSheet
extends POIXMLDocumentPart
implements XSLFShapeContainer

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XSLFSheet()
XSLFSheet(PackagePart part, PackageRelationship rel)
Method Summary
XSLFSheet | appendContent(XSLFSheet src) Append content to this sheet.
protected java.util.List<XSLFShape> | buildShapes(org.openxmlformats.schemas.presentationml.x2006.main.CTGroupShape spTree)
protected boolean | canDraw(XSLFShape shape) Checks if this sheet displays the specified shape.
void | clear() Removes all of the elements from this container (optional operation).
protected void | commit() Save the content in the underlying package part.
XSLFAutoShape | createAutoShape() create a new shape with a predefined geometry and add it to this shape container
XSLFConnectorShape | createConnector() create a connector
XSLFFreeformShape | createFreeform() create a new shape with a custom geometry
XSLFGroupShape | createGroup() create a group of shapes belonging to this container
XSLFPictureShape | createPicture(int pictureIndex) create a picture belonging to this container
XSLFTable | createTable()
XSLFTextBox | createTextBox() create a text box
void | draw(java.awt.Graphics2D graphics) Render this sheet into the supplied graphics object
XSLFBackground | getBackground()
XSLFCommonSlideData | getCommonSlideData()
boolean | getFollowMasterGraphics()
abstract XSLFSheet | getMasterSheet()
XSLFTextShape | getPlaceholder(int idx)
XSLFTextShape[] | getPlaceholders()
protected abstract java.lang.String | getRootElementName()
XSLFShape[] | getShapes() Returns an array containing all of the shapes in this sheet
XMLSlideShow | getSlideShow()
protected org.openxmlformats.schemas.presentationml.x2006.main.CTGroupShape | getSpTree()
protected XSLFTextShape | getTextShapeByType(Placeholder type)
abstract org.apache.xmlbeans.XmlObject | getXmlObject()
XSLFSheet | importContent(XSLFSheet src) Set the contents of this sheet to be a copy of the source sheet.
java.util.Iterator<XSLFShape> | iterator() Returns an iterator over the shapes in this sheet
boolean | removeShape(XSLFShape xShape) Removes the specified shape from this sheet, if it is present (optional operation).
protected void | setCommonSlideData(org.openxmlformats.schemas.presentationml.x2006.main.CTCommonSlideData data)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSLFSheet

public XSLFSheet()

XSLFSheet

public XSLFSheet(PackagePart part,
                 PackageRelationship rel)
Method Detail

getSlideShow

public XMLSlideShow getSlideShow()
Returns:
the XMLSlideShow this sheet belongs to

buildShapes

protected java.util.List<XSLFShape> buildShapes(org.openxmlformats.schemas.presentationml.x2006.main.CTGroupShape spTree)

getXmlObject

public abstract org.apache.xmlbeans.XmlObject getXmlObject()
Returns:
top-level Xml bean representing this sheet

getCommonSlideData

@Internal
public XSLFCommonSlideData getCommonSlideData()

setCommonSlideData

protected void setCommonSlideData(org.openxmlformats.schemas.presentationml.x2006.main.CTCommonSlideData data)

createAutoShape

public XSLFAutoShape createAutoShape()
Description copied from interface: XSLFShapeContainer
create a new shape with a predefined geometry and add it to this shape container

Specified by:
createAutoShape in interface XSLFShapeContainer

createFreeform

public XSLFFreeformShape createFreeform()
Description copied from interface: XSLFShapeContainer
create a new shape with a custom geometry

Specified by:
createFreeform in interface XSLFShapeContainer

createTextBox

public XSLFTextBox createTextBox()
Description copied from interface: XSLFShapeContainer
create a text box

Specified by:
createTextBox in interface XSLFShapeContainer

createConnector

public XSLFConnectorShape createConnector()
Description copied from interface: XSLFShapeContainer
create a connector

Specified by:
createConnector in interface XSLFShapeContainer

createGroup

public XSLFGroupShape createGroup()
Description copied from interface: XSLFShapeContainer
create a group of shapes belonging to this container

Specified by:
createGroup in interface XSLFShapeContainer

createPicture

public XSLFPictureShape createPicture(int pictureIndex)
Description copied from interface: XSLFShapeContainer
create a picture belonging to this container

Specified by:
createPicture in interface XSLFShapeContainer
Returns:

createTable

public XSLFTable createTable()

getShapes

public XSLFShape[] getShapes()
Returns an array containing all of the shapes in this sheet

Specified by:
getShapes in interface XSLFShapeContainer
Returns:
an array of all shapes in this sheet

iterator

public java.util.Iterator<XSLFShape> iterator()
Returns an iterator over the shapes in this sheet

Specified by:
iterator in interface java.lang.Iterable<XSLFShape>
Returns:
an iterator over the shapes in this sheet

removeShape

public boolean removeShape(XSLFShape xShape)
Removes the specified shape from this sheet, if it is present (optional operation). If this sheet does not contain the element, it is unchanged.

Specified by:
removeShape in interface XSLFShapeContainer
Parameters:
xShape - shape to be removed from this sheet, if present
Returns:
true if this sheet contained the specified element
Throws:
java.lang.IllegalArgumentException - if the type of the specified shape is incompatible with this sheet (optional)

clear

public void clear()
Removes all of the elements from this container (optional operation). The container will be empty after this call returns.

Specified by:
clear in interface XSLFShapeContainer

getRootElementName

protected abstract java.lang.String getRootElementName()

getSpTree

protected org.openxmlformats.schemas.presentationml.x2006.main.CTGroupShape getSpTree()

commit

protected final void commit()
                     throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

importContent

public XSLFSheet importContent(XSLFSheet src)
Set the contents of this sheet to be a copy of the source sheet. This method erases any existing shapes and replaces them with object from the source sheet.

Parameters:
src - the source sheet to copy data from
Returns:
modified 'this'

appendContent

public XSLFSheet appendContent(XSLFSheet src)
Append content to this sheet.

Parameters:
src - the source sheet
Returns:
modified this.

getMasterSheet

public abstract XSLFSheet getMasterSheet()
Returns:
master of this sheet.

getTextShapeByType

protected XSLFTextShape getTextShapeByType(Placeholder type)

getPlaceholder

public XSLFTextShape getPlaceholder(int idx)
Parameters:
idx - 0-based index of a placeholder in the sheet
Returns:
placeholder

getPlaceholders

public XSLFTextShape[] getPlaceholders()
Returns:
all placeholder shapes in this sheet

canDraw

protected boolean canDraw(XSLFShape shape)
Checks if this sheet displays the specified shape. Subclasses can override it and skip certain shapes from drawings, for instance, slide masters and layouts don't display placeholders

getFollowMasterGraphics

public boolean getFollowMasterGraphics()
Returns:
whether shapes on the master sheet should be shown. By default master graphics is turned off. Sheets that support the notion of master (slide, slideLayout) should override it and check this setting in the sheet XML

getBackground

public XSLFBackground getBackground()
Returns:
background for this sheet

draw

public void draw(java.awt.Graphics2D graphics)
Render this sheet into the supplied graphics object

Parameters:
graphics -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFSimpleShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFSimpleShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
Direct Known Subclasses:
XSLFBackground, XSLFConnectorShape, XSLFPictureShape, XSLFShadow, XSLFTextShape
@Beta
public abstract class XSLFSimpleShape
extends XSLFShape

Represents a single (non-group) shape in a .pptx slide show

Author:
Yegor Kozlov

Method Summary
void | draw(java.awt.Graphics2D graphics) Draw this shape into the supplied canvas
void | drawContent(java.awt.Graphics2D graphics) draw any content within this shape (image, text, etc.).
java.awt.geom.Rectangle2D | getAnchor()
protected org.openxmlformats.schemas.presentationml.x2006.main.CTPlaceholder | getCTPlaceholder()
java.awt.Color | getFillColor()
boolean | getFlipHorizontal() Whether the shape is horizontally flipped
boolean | getFlipVertical() Whether the shape is vertically flipped
LineCap | getLineCap()
java.awt.Color | getLineColor()
LineDash | getLineDash()
LineDecoration | getLineHeadDecoration()
LineEndLength | getLineHeadLength()
LineEndWidth | getLineHeadWidth()
LineDecoration | getLineTailDecoration()
LineEndLength | getLineTailLength()
LineEndWidth | getLineTailWidth()
double | getLineWidth()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTNonVisualDrawingProps | getNvPr()
double | getRotation() Rotation angle in degrees
XSLFShadow | getShadow()
int | getShapeId() Returns a unique identifier for this shape within the current document.
java.lang.String | getShapeName()
XSLFShapeType | getShapeType()
XSLFSheet | getSheet()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties | getSpPr()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeStyle | getSpStyle()
org.apache.xmlbeans.XmlObject | getXmlObject()
void | setAnchor(java.awt.geom.Rectangle2D anchor)
void | setFillColor(java.awt.Color color) Specifies a solid color fill.
void | setFlipHorizontal(boolean flip)
void | setFlipVertical(boolean flip) Whether the shape is vertically flipped
void | setLineCap(LineCap cap)
void | setLineColor(java.awt.Color color)
void | setLineDash(LineDash dash)
void | setLineHeadDecoration(LineDecoration style) Specifies the line end decoration, such as a triangle or arrowhead.
void | setLineHeadLength(LineEndLength style) Specifies the line end width in relation to the line width.
void | setLineHeadWidth(LineEndWidth style) specifies decorations which can be added to the head of a line.
void | setLineTailDecoration(LineDecoration style) Specifies the line end decoration, such as a triangle or arrowhead.
void | setLineTailLength(LineEndLength style) Specifies the line end width in relation to the line width.
void | setLineTailWidth(LineEndWidth style) specifies decorations which can be added to the tail of a line.
void | setLineWidth(double width)
void | setRotation(double theta) Rotate this shape.
void | setShapeType(XSLFShapeType type)
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlObject

public org.apache.xmlbeans.XmlObject getXmlObject()
Specified by:
getXmlObject in class XSLFShape
Returns:
the xml bean holding this shape's data

getSheet

public XSLFSheet getSheet()
Returns:
the sheet this shape belongs to

setShapeType

public void setShapeType(XSLFShapeType type)
Parameters:
type -

getShapeType

public XSLFShapeType getShapeType()

getShapeName

public java.lang.String getShapeName()
Specified by:
getShapeName in class XSLFShape
Returns:
human-readable name of this shape, e.g. "Rectange 3"

getShapeId

public int getShapeId()
Description copied from class: XSLFShape
Returns a unique identifier for this shape within the current document. This ID may be used to assist in uniquely identifying this object so that it can be referred to by other parts of the document.

If multiple objects within the same document share the same id attribute value, then the document shall be considered non-conformant.

Specified by:
getShapeId in class XSLFShape
Returns:
unique id of this shape

getNvPr

protected org.openxmlformats.schemas.drawingml.x2006.main.CTNonVisualDrawingProps getNvPr()

getSpPr

protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties getSpPr()

getSpStyle

protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeStyle getSpStyle()

getCTPlaceholder

protected org.openxmlformats.schemas.presentationml.x2006.main.CTPlaceholder getCTPlaceholder()

getAnchor

public java.awt.geom.Rectangle2D getAnchor()
Specified by:
getAnchor in class XSLFShape
Returns:
the position of this shape within the drawing canvas. The coordinates are expressed in points

setAnchor

public void setAnchor(java.awt.geom.Rectangle2D anchor)
Specified by:
setAnchor in class XSLFShape
Parameters:
anchor - the position of this shape within the drawing canvas. The coordinates are expressed in points

setRotation

public void setRotation(double theta)
Description copied from class: XSLFShape
Rotate this shape.

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Specified by:
setRotation in class XSLFShape
Parameters:
theta - the rotation angle in degrees.

getRotation

public double getRotation()
Description copied from class: XSLFShape
Rotation angle in degrees

Positive angles are clockwise (i.e., towards the positive y axis); negative angles are counter-clockwise (i.e., towards the negative y axis).

Specified by:
getRotation in class XSLFShape
Returns:
rotation angle in degrees

setFlipHorizontal

public void setFlipHorizontal(boolean flip)
Specified by:
setFlipHorizontal in class XSLFShape
Parameters:
flip - whether the shape is horizontally flipped

setFlipVertical

public void setFlipVertical(boolean flip)
Description copied from class: XSLFShape
Whether the shape is vertically flipped

Specified by:
setFlipVertical in class XSLFShape
Parameters:
flip - whether the shape is vertically flipped

getFlipHorizontal

public boolean getFlipHorizontal()
Description copied from class: XSLFShape
Whether the shape is horizontally flipped

Specified by:
getFlipHorizontal in class XSLFShape
Returns:
whether the shape is horizontally flipped

getFlipVertical

public boolean getFlipVertical()
Description copied from class: XSLFShape
Whether the shape is vertically flipped

Specified by:
getFlipVertical in class XSLFShape
Returns:
whether the shape is vertically flipped

setLineColor

public void setLineColor(java.awt.Color color)
Parameters:
color - the color to paint the shape outline. A null value turns off the shape outline.

getLineColor

public java.awt.Color getLineColor()
Returns:
the color of the shape outline or null if outline is turned off

setLineWidth

public void setLineWidth(double width)
Parameters:
width - line width in points. 0 means no line

getLineWidth

public double getLineWidth()
Returns:
line width in points. 0 means no line.

setLineDash

public void setLineDash(LineDash dash)
Parameters:
dash - a preset line dashing scheme to stroke thr shape outline

getLineDash

public LineDash getLineDash()
Returns:
a preset line dashing scheme to stroke thr shape outline

setLineCap

public void setLineCap(LineCap cap)
Parameters:
cap - the line end cap style

getLineCap

public LineCap getLineCap()
Returns:
the line end cap style

setFillColor

public void setFillColor(java.awt.Color color)
Specifies a solid color fill. The shape is filled entirely with the specified color.

Parameters:
color - the solid color fill. The value of null unsets the solidFIll attribute from the underlying xml

getFillColor

public java.awt.Color getFillColor()
Returns:
solid fill color of null if not set or fill color is not solid (pattern or gradient)

getShadow

public XSLFShadow getShadow()
Returns:
shadow of this shape or null if shadow is disabled

draw

public void draw(java.awt.Graphics2D graphics)
Description copied from class: XSLFShape
Draw this shape into the supplied canvas

Specified by:
draw in class XSLFShape
Parameters:
graphics - the graphics to draw into

drawContent

public void drawContent(java.awt.Graphics2D graphics)
draw any content within this shape (image, text, etc.).

Parameters:
graphics - the graphics to draw into

setLineHeadDecoration

public void setLineHeadDecoration(LineDecoration style)
Specifies the line end decoration, such as a triangle or arrowhead.

getLineHeadDecoration

public LineDecoration getLineHeadDecoration()

setLineHeadWidth

public void setLineHeadWidth(LineEndWidth style)
specifies decorations which can be added to the head of a line.

getLineHeadWidth

public LineEndWidth getLineHeadWidth()

setLineHeadLength

public void setLineHeadLength(LineEndLength style)
Specifies the line end width in relation to the line width.

getLineHeadLength

public LineEndLength getLineHeadLength()

setLineTailDecoration

public void setLineTailDecoration(LineDecoration style)
Specifies the line end decoration, such as a triangle or arrowhead.

getLineTailDecoration

public LineDecoration getLineTailDecoration()

setLineTailWidth

public void setLineTailWidth(LineEndWidth style)
specifies decorations which can be added to the tail of a line.

getLineTailWidth

public LineEndWidth getLineTailWidth()

setLineTailLength

public void setLineTailLength(LineEndLength style)
Specifies the line end width in relation to the line width.

getLineTailLength

public LineEndLength getLineTailLength()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFSlide

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFSlide

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFSheet
            extended by  org.apache.poi.xslf.usermodel.XSLFSlide
All Implemented Interfaces:
java.lang.Iterable<XSLFShape>, XSLFShapeContainer
@Beta
public final class XSLFSlide
extends XSLFSheet

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Method Summary
void | draw(java.awt.Graphics2D graphics) Render this sheet into the supplied graphics object
XSLFBackground | getBackground()
XSLFComments | getComments()
boolean | getFollowMasterGraphics()
XSLFSlideLayout | getMasterSheet()
XSLFNotes | getNotes()
protected java.lang.String | getRootElementName()
XSLFSlideLayout | getSlideLayout()
XSLFSlideMaster | getSlideMaster()
XSLFTheme | getTheme()
java.lang.String | getTitle()
org.openxmlformats.schemas.presentationml.x2006.main.CTSlide | getXmlObject()
XSLFSlide | importContent(XSLFSheet src) Set the contents of this sheet to be a copy of the source sheet.
void | setFollowMasterGraphics(boolean value)
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSheet
appendContent, buildShapes, canDraw, clear, commit, createAutoShape, createConnector, createFreeform, createGroup, createPicture, createTable, createTextBox, getCommonSlideData, getPlaceholder, getPlaceholders, getShapes, getSlideShow, getSpTree, getTextShapeByType, iterator, removeShape, setCommonSlideData
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getXmlObject

public org.openxmlformats.schemas.presentationml.x2006.main.CTSlide getXmlObject()
Specified by:
getXmlObject in class XSLFSheet
Returns:
top-level Xml bean representing this sheet

getRootElementName

protected java.lang.String getRootElementName()
Specified by:
getRootElementName in class XSLFSheet

getMasterSheet

public XSLFSlideLayout getMasterSheet()
Specified by:
getMasterSheet in class XSLFSheet
Returns:
master of this sheet.

getSlideLayout

public XSLFSlideLayout getSlideLayout()

getSlideMaster

public XSLFSlideMaster getSlideMaster()

getComments

public XSLFComments getComments()

getNotes

public XSLFNotes getNotes()

getTitle

public java.lang.String getTitle()
Returns:
title of this slide or empty string if title is not set

getTheme

public XSLFTheme getTheme()
Returns:
theme (shared styles) associated with this theme. By default returns null which means that this sheet is theme-less. Sheets that support the notion of themes (slides, masters, layouts, etc.) should override this method and return the corresponding package part.

getBackground

public XSLFBackground getBackground()
Overrides:
getBackground in class XSLFSheet
Returns:
the information about background appearance of this slide

getFollowMasterGraphics

public boolean getFollowMasterGraphics()
Overrides:
getFollowMasterGraphics in class XSLFSheet
Returns:
whether shapes on the master slide should be shown or not.

setFollowMasterGraphics

public void setFollowMasterGraphics(boolean value)
Parameters:
value - whether shapes on the master slide should be shown or not.

draw

public void draw(java.awt.Graphics2D graphics)
Description copied from class: XSLFSheet
Render this sheet into the supplied graphics object

Overrides:
draw in class XSLFSheet

importContent

public XSLFSlide importContent(XSLFSheet src)
Description copied from class: XSLFSheet
Set the contents of this sheet to be a copy of the source sheet. This method erases any existing shapes and replaces them with object from the source sheet.

Overrides:
importContent in class XSLFSheet
Parameters:
src - the source sheet to copy data from
Returns:
modified 'this'
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFSlideLayout

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFSlideLayout

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFSheet
            extended by  org.apache.poi.xslf.usermodel.XSLFSlideLayout
All Implemented Interfaces:
java.lang.Iterable<XSLFShape>, XSLFShapeContainer
@Beta
public class XSLFSlideLayout
extends XSLFSheet

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XSLFSlideLayout(PackagePart part, PackageRelationship rel)
Method Summary
protected boolean | canDraw(XSLFShape shape) Render this sheet into the supplied graphics object
void | copyLayout(XSLFSlide slide) Copy placeholders from this layout to the destination slide
XSLFBackground | getBackground()
boolean | getFollowMasterGraphics()
XSLFSlideMaster | getMasterSheet()
java.lang.String | getName()
protected java.lang.String | getRootElementName()
XSLFSlideMaster | getSlideMaster() Slide master object associated with this layout.
XSLFTheme | getTheme()
SlideLayout | getType()
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideLayout | getXmlObject() While developing only!
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSheet
appendContent, buildShapes, clear, commit, createAutoShape, createConnector, createFreeform, createGroup, createPicture, createTable, createTextBox, draw, getCommonSlideData, getPlaceholder, getPlaceholders, getShapes, getSlideShow, getSpTree, getTextShapeByType, importContent, iterator, removeShape, setCommonSlideData
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSLFSlideLayout

public XSLFSlideLayout(PackagePart part,
                       PackageRelationship rel)
                throws java.io.IOException,
                       org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getName

public java.lang.String getName()

getXmlObject

@Internal
public org.openxmlformats.schemas.presentationml.x2006.main.CTSlideLayout getXmlObject()
While developing only!

Specified by:
getXmlObject in class XSLFSheet
Returns:
top-level Xml bean representing this sheet

getRootElementName

protected java.lang.String getRootElementName()
Specified by:
getRootElementName in class XSLFSheet

getSlideMaster

public XSLFSlideMaster getSlideMaster()
Slide master object associated with this layout.

Returns:
slide master. Never null.
Throws:
java.lang.IllegalStateException - if slide master was not found

getMasterSheet

public XSLFSlideMaster getMasterSheet()
Specified by:
getMasterSheet in class XSLFSheet
Returns:
master of this sheet.

getTheme

public XSLFTheme getTheme()
Returns:
theme (shared styles) associated with this theme. By default returns null which means that this sheet is theme-less. Sheets that support the notion of themes (slides, masters, layouts, etc.) should override this method and return the corresponding package part.

getFollowMasterGraphics

public boolean getFollowMasterGraphics()
Overrides:
getFollowMasterGraphics in class XSLFSheet
Returns:
whether shapes on the master sheet should be shown. By default master graphics is turned off. Sheets that support the notion of master (slide, slideLayout) should override it and check this setting in the sheet XML

canDraw

protected boolean canDraw(XSLFShape shape)
Render this sheet into the supplied graphics object

Overrides:
canDraw in class XSLFSheet

getBackground

public XSLFBackground getBackground()
Overrides:
getBackground in class XSLFSheet
Returns:
background for this sheet

copyLayout

public void copyLayout(XSLFSlide slide)
Copy placeholders from this layout to the destination slide

Parameters:
slide - destination slide

getType

public SlideLayout getType()
Returns:
type of this layout
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFSlideMaster

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFSlideMaster

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFSheet
            extended by  org.apache.poi.xslf.usermodel.XSLFSlideMaster
All Implemented Interfaces:
java.lang.Iterable<XSLFShape>, XSLFShapeContainer
@Beta
public class XSLFSlideMaster
extends XSLFSheet

Slide master object associated with this layout.

Within a slide master slide are contained all elements that describe the objects and their corresponding formatting for within a presentation slide.

Within a slide master slide are two main elements. The cSld element specifies the common slide elements such as shapes and their attached text bodies. Then the txStyles element specifies the formatting for the text within each of these shapes. The other properties within a slide master slide specify other properties for within a presentation slide such as color information, headers and footers, as well as timing and transition information for all corresponding presentation slides.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected XSLFSlideMaster(PackagePart part, PackageRelationship rel)
Method Summary
protected boolean | canDraw(XSLFShape shape) Render this sheet into the supplied graphics object
XSLFBackground | getBackground()
XSLFSlideLayout | getLayout(SlideLayout type)
XSLFSheet | getMasterSheet()
protected java.lang.String | getRootElementName()
XSLFSlideLayout[] | getSlideLayouts()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextListStyle | getTextProperties(Placeholder textType)
XSLFTheme | getTheme()
org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMaster | getXmlObject()
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSheet
appendContent, buildShapes, clear, commit, createAutoShape, createConnector, createFreeform, createGroup, createPicture, createTable, createTextBox, draw, getCommonSlideData, getFollowMasterGraphics, getPlaceholder, getPlaceholders, getShapes, getSlideShow, getSpTree, getTextShapeByType, importContent, iterator, removeShape, setCommonSlideData
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSLFSlideMaster

protected XSLFSlideMaster(PackagePart part,
                          PackageRelationship rel)
                   throws java.io.IOException,
                          org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getXmlObject

public org.openxmlformats.schemas.presentationml.x2006.main.CTSlideMaster getXmlObject()
Specified by:
getXmlObject in class XSLFSheet
Returns:
top-level Xml bean representing this sheet

getRootElementName

protected java.lang.String getRootElementName()
Specified by:
getRootElementName in class XSLFSheet

getMasterSheet

public XSLFSheet getMasterSheet()
Specified by:
getMasterSheet in class XSLFSheet
Returns:
master of this sheet.

getSlideLayouts

public XSLFSlideLayout[] getSlideLayouts()
Returns:
all slide layouts referencing this master

getLayout

public XSLFSlideLayout getLayout(SlideLayout type)

getTheme

public XSLFTheme getTheme()
Returns:
theme (shared styles) associated with this theme. By default returns null which means that this sheet is theme-less. Sheets that support the notion of themes (slides, masters, layouts, etc.) should override this method and return the corresponding package part.

getTextProperties

protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextListStyle getTextProperties(Placeholder textType)

canDraw

protected boolean canDraw(XSLFShape shape)
Render this sheet into the supplied graphics object

Overrides:
canDraw in class XSLFSheet

getBackground

public XSLFBackground getBackground()
Overrides:
getBackground in class XSLFSheet
Returns:
background for this sheet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTable

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFGraphicFrame
            extended by  org.apache.poi.xslf.usermodel.XSLFTable
All Implemented Interfaces:
java.lang.Iterable<XSLFTableRow>
public class XSLFTable
extends XSLFGraphicFrame
implements java.lang.Iterable<XSLFTableRow>

Represents a table in a .pptx presentation

Author:
Yegor Kozlov

Method Summary
XSLFTableRow | addRow()
double | getColumnWidth(int idx)
org.openxmlformats.schemas.drawingml.x2006.main.CTTable | getCTTable()
int | getNumberOfColumns()
int | getNumberOfRows()
java.util.List<XSLFTableRow> | getRows()
java.util.Iterator<XSLFTableRow> | iterator()
void | mergeCells(int firstRow, int lastRow, int firstCol, int lastCol) Merge cells of a table
void | setColumnWidth(int idx, double width)
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFGraphicFrame
draw, getAnchor, getFlipHorizontal, getFlipVertical, getRotation, getShapeId, getShapeName, getShapeType, getSheet, getXmlObject, setAnchor, setFlipHorizontal, setFlipVertical, setRotation
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getCTTable

@Internal
public org.openxmlformats.schemas.drawingml.x2006.main.CTTable getCTTable()

getNumberOfColumns

public int getNumberOfColumns()

getNumberOfRows

public int getNumberOfRows()

getColumnWidth

public double getColumnWidth(int idx)

setColumnWidth

public void setColumnWidth(int idx,
                           double width)

iterator

public java.util.Iterator<XSLFTableRow> iterator()
Specified by:
iterator in interface java.lang.Iterable<XSLFTableRow>

getRows

public java.util.List<XSLFTableRow> getRows()

addRow

public XSLFTableRow addRow()

mergeCells

public void mergeCells(int firstRow,
                       int lastRow,
                       int firstCol,
                       int lastCol)
Merge cells of a table

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTableCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTableCell

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFTextShape
                extended by  org.apache.poi.xslf.usermodel.XSLFTableCell
All Implemented Interfaces:
java.lang.Iterable<XSLFTextParagraph>
public class XSLFTableCell
extends XSLFTextShape

Represents a cell of a table in a .pptx presentation

Author:
Yegor Kozlov

Method Summary
double | getBorderBottom()
java.awt.Color | getBorderBottomColor()
double | getBorderLeft()
java.awt.Color | getBorderLeftColor()
double | getBorderRight()
java.awt.Color | getBorderRightColor()
double | getBorderTop()
java.awt.Color | getBorderTopColor()
java.awt.Color | getFillColor()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody | getTextBody(boolean create)
VerticalAlignment | getVerticalAlignment() Returns the type of vertical alignment for the text.
org.openxmlformats.schemas.drawingml.x2006.main.CTTableCell | getXmlObject()
void | setBorderBottom(double width)
void | setBorderBottomColor(java.awt.Color color)
void | setBorderLeft(double width)
void | setBorderLeftColor(java.awt.Color color)
void | setBorderRight(double width)
void | setBorderRightColor(java.awt.Color color)
void | setBorderTop(double width)
void | setBorderTopColor(java.awt.Color color)
void | setBottomInset(double margin) Sets the botom margin.
void | setFillColor(java.awt.Color color) Specifies a solid color fill.
void | setLeftInset(double margin) Sets the left margin.
void | setRightInset(double margin) Sets the right margin.
void | setTopInset(double margin) Sets the top margin.
void | setVerticalAlignment(VerticalAlignment anchor) Sets the type of vertical alignment for the text.
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFTextShape
addNewTextParagraph, clearText, drawContent, getBottomInset, getLeftInset, getRightInset, getText, getTextAutofit, getTextBodyPr, getTextDirection, getTextHeight, getTextParagraphs, getTextType, getTopInset, getWordWrap, iterator, resizeToFitText, setPlaceholder, setText, setTextAutofit, setTextDirection, setWordWrap
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, getAnchor, getCTPlaceholder, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, setAnchor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlObject

public org.openxmlformats.schemas.drawingml.x2006.main.CTTableCell getXmlObject()
Overrides:
getXmlObject in class XSLFSimpleShape
Returns:
the xml bean holding this shape's data

getTextBody

protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody getTextBody(boolean create)
Specified by:
getTextBody in class XSLFTextShape

setLeftInset

public void setLeftInset(double margin)
Description copied from class: XSLFTextShape
Sets the left margin.

Overrides:
setLeftInset in class XSLFTextShape
Parameters:
margin - the left margin
See Also:
XSLFTextShape.getLeftInset()

setRightInset

public void setRightInset(double margin)
Description copied from class: XSLFTextShape
Sets the right margin.

Overrides:
setRightInset in class XSLFTextShape
Parameters:
margin - the right margin
See Also:
XSLFTextShape.getRightInset()

setTopInset

public void setTopInset(double margin)
Description copied from class: XSLFTextShape
Sets the top margin.

Overrides:
setTopInset in class XSLFTextShape
Parameters:
margin - the top margin
See Also:
XSLFTextShape.getTopInset()

setBottomInset

public void setBottomInset(double margin)
Description copied from class: XSLFTextShape
Sets the botom margin.

Overrides:
setBottomInset in class XSLFTextShape
Parameters:
margin - the bottom margin
See Also:
XSLFTextShape.getBottomInset()

setBorderLeft

public void setBorderLeft(double width)

getBorderLeft

public double getBorderLeft()

setBorderLeftColor

public void setBorderLeftColor(java.awt.Color color)

getBorderLeftColor

public java.awt.Color getBorderLeftColor()

setBorderRight

public void setBorderRight(double width)

getBorderRight

public double getBorderRight()

setBorderRightColor

public void setBorderRightColor(java.awt.Color color)

getBorderRightColor

public java.awt.Color getBorderRightColor()

setBorderTop

public void setBorderTop(double width)

getBorderTop

public double getBorderTop()

setBorderTopColor

public void setBorderTopColor(java.awt.Color color)

getBorderTopColor

public java.awt.Color getBorderTopColor()

setBorderBottom

public void setBorderBottom(double width)

getBorderBottom

public double getBorderBottom()

setBorderBottomColor

public void setBorderBottomColor(java.awt.Color color)

getBorderBottomColor

public java.awt.Color getBorderBottomColor()

setFillColor

public void setFillColor(java.awt.Color color)
Specifies a solid color fill. The shape is filled entirely with the specified color.

Overrides:
setFillColor in class XSLFSimpleShape
Parameters:
color - the solid color fill. The value of null unsets the solidFIll attribute from the underlying xml

getFillColor

public java.awt.Color getFillColor()
Overrides:
getFillColor in class XSLFSimpleShape
Returns:
solid fill color of null if not set

setVerticalAlignment

public void setVerticalAlignment(VerticalAlignment anchor)
Description copied from class: XSLFTextShape
Sets the type of vertical alignment for the text.

Overrides:
setVerticalAlignment in class XSLFTextShape
Parameters:
anchor - - the type of alignment. A null values unsets this property.

getVerticalAlignment

public VerticalAlignment getVerticalAlignment()
Description copied from class: XSLFTextShape
Returns the type of vertical alignment for the text.

Overrides:
getVerticalAlignment in class XSLFTextShape
Returns:
the type of vertical alignment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTableRow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTableRow

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFTableRow
All Implemented Interfaces:
java.lang.Iterable<XSLFTableCell>
public class XSLFTableRow
extends java.lang.Object
implements java.lang.Iterable<XSLFTableCell>

Represents a table in a .pptx presentation

Author:
Yegor Kozlov

Method Summary
XSLFTableCell | addCell()
java.util.List<XSLFTableCell> | getCells()
double | getHeight()
org.openxmlformats.schemas.drawingml.x2006.main.CTTableRow | getXmlObject()
java.util.Iterator<XSLFTableCell> | iterator()
void | setHeight(double height)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlObject

public org.openxmlformats.schemas.drawingml.x2006.main.CTTableRow getXmlObject()

iterator

public java.util.Iterator<XSLFTableCell> iterator()
Specified by:
iterator in interface java.lang.Iterable<XSLFTableCell>

getCells

public java.util.List<XSLFTableCell> getCells()

getHeight

public double getHeight()

setHeight

public void setHeight(double height)

addCell

public XSLFTableCell addCell()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTableStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTableStyle

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFTableStyle

public class XSLFTableStyle
extends java.lang.Object

Represents a table in a .pptx presentation

Author:
Yegor Kozlov

Method Summary
java.lang.String | getStyleId()
java.lang.String | getStyleName()
org.openxmlformats.schemas.drawingml.x2006.main.CTTableStyle | getXmlObject()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlObject

public org.openxmlformats.schemas.drawingml.x2006.main.CTTableStyle getXmlObject()

getStyleName

public java.lang.String getStyleName()

getStyleId

public java.lang.String getStyleId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTableStyles

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTableStyles

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFTableStyles
All Implemented Interfaces:
java.lang.Iterable<XSLFTableStyle>
@Beta
public class XSLFTableStyles
extends POIXMLDocumentPart
implements java.lang.Iterable<XSLFTableStyle>

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XSLFTableStyles()
XSLFTableStyles(PackagePart part, PackageRelationship rel)
Method Summary
java.util.List<XSLFTableStyle> | getStyles()
org.openxmlformats.schemas.drawingml.x2006.main.CTTableStyleList | getXmlObject()
java.util.Iterator<XSLFTableStyle> | iterator()
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSLFTableStyles

public XSLFTableStyles()

XSLFTableStyles

public XSLFTableStyles(PackagePart part,
                       PackageRelationship rel)
                throws java.io.IOException,
                       org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getXmlObject

public org.openxmlformats.schemas.drawingml.x2006.main.CTTableStyleList getXmlObject()

iterator

public java.util.Iterator<XSLFTableStyle> iterator()
Specified by:
iterator in interface java.lang.Iterable<XSLFTableStyle>

getStyles

public java.util.List<XSLFTableStyle> getStyles()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTextBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTextBox

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFTextShape
                extended by  org.apache.poi.xslf.usermodel.XSLFAutoShape
                    extended by  org.apache.poi.xslf.usermodel.XSLFTextBox
All Implemented Interfaces:
java.lang.Iterable<XSLFTextParagraph>
@Beta
public class XSLFTextBox
extends XSLFAutoShape

Author:
Yegor Kozlov

Method Summary
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFAutoShape
getTextBody, toString
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFTextShape
addNewTextParagraph, clearText, drawContent, getBottomInset, getLeftInset, getRightInset, getText, getTextAutofit, getTextBodyPr, getTextDirection, getTextHeight, getTextParagraphs, getTextType, getTopInset, getVerticalAlignment, getWordWrap, iterator, resizeToFitText, setBottomInset, setLeftInset, setPlaceholder, setRightInset, setText, setTextAutofit, setTextDirection, setTopInset, setVerticalAlignment, setWordWrap
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, getAnchor, getCTPlaceholder, getFillColor, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setAnchor, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTextParagraph

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTextParagraph

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFTextParagraph
All Implemented Interfaces:
java.lang.Iterable<XSLFTextRun>
@Beta
public class XSLFTextParagraph
extends java.lang.Object
implements java.lang.Iterable<XSLFTextRun>

Represents a paragraph of text within the containing text body. The paragraph is the highest level text separation mechanism.

Since:
POI-3.8
Author:
Yegor Kozlov

Method Summary
XSLFTextRun | addLineBreak() Insert a line break
XSLFTextRun | addNewTextRun() Add a new run of text
double | draw(java.awt.Graphics2D graphics, double x, double y)
java.lang.String | getBulletCharacter()
java.lang.String | getBulletFont()
java.awt.Color | getBulletFontColor()
double | getBulletFontSize() Returns the bullet size that is to be used within a paragraph.
double | getDefaultTabSize()
double | getIndent()
double | getLeftMargin()
int | getLevel()
double | getLineSpacing() Returns the vertical line spacing that is to be used within a paragraph.
double | getSpaceAfter() The amount of vertical white space after the paragraph This may be specified in two different ways, percentage spacing and font point spacing:
double | getSpaceBefore() The amount of vertical white space before the paragraph This may be specified in two different ways, percentage spacing and font point spacing:
double | getTabStop(int idx)
java.lang.String | getText()
TextAlign | getTextAlign() Returns the alignment that is applied to the paragraph.
java.util.List<XSLFTextRun> | getTextRuns()
org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraph | getXmlObject()
boolean | isBullet() Returns whether this paragraph has bullets
java.util.Iterator<XSLFTextRun> | iterator()
void | setBullet(boolean flag)
void | setBulletAutoNumber(ListAutoNumber scheme, int startAt) Specifies that automatic numbered bullet points should be applied to this paragraph
void | setBulletCharacter(java.lang.String str)
void | setBulletFont(java.lang.String typeface)
void | setBulletFontColor(java.awt.Color color) Set the color to be used on bullet characters within a given paragraph.
void | setBulletFontSize(double bulletSize) Sets the bullet size that is to be used within a paragraph.
void | setIndent(double value) Specifies the indent size that will be applied to the first line of text in the paragraph.
void | setLeftMargin(double value) Specifies the left margin of the paragraph.
void | setLevel(int level) Specifies the particular level text properties that this paragraph will follow.
void | setLineSpacing(double linespacing) This element specifies the vertical line spacing that is to be used within a paragraph.
void | setSpaceAfter(double spaceAfter) Set the amount of vertical white space that will be present after the paragraph.
void | setSpaceBefore(double spaceBefore) Set the amount of vertical white space that will be present before the paragraph.
void | setTextAlign(TextAlign align) Specifies the alignment that is to be applied to the paragraph.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getText

public java.lang.String getText()

getXmlObject

@Internal
public org.openxmlformats.schemas.drawingml.x2006.main.CTTextParagraph getXmlObject()

getTextRuns

public java.util.List<XSLFTextRun> getTextRuns()

iterator

public java.util.Iterator<XSLFTextRun> iterator()
Specified by:
iterator in interface java.lang.Iterable<XSLFTextRun>

addNewTextRun

public XSLFTextRun addNewTextRun()
Add a new run of text

Returns:
a new run of text

addLineBreak

public XSLFTextRun addLineBreak()
Insert a line break

Returns:
text run representing this line break ('\n')

getTextAlign

public TextAlign getTextAlign()
Returns the alignment that is applied to the paragraph. If this attribute is omitted, then a value of left is implied.

Returns:
??? alignment that is applied to the paragraph

setTextAlign

public void setTextAlign(TextAlign align)
Specifies the alignment that is to be applied to the paragraph. Possible values for this include left, right, centered, justified and distributed, see TextAlign.

Parameters:
align - text align

getBulletFont

public java.lang.String getBulletFont()
Returns:
the font to be used on bullet characters within a given paragraph

setBulletFont

public void setBulletFont(java.lang.String typeface)

getBulletCharacter

public java.lang.String getBulletCharacter()
Returns:
the character to be used in place of the standard bullet point

setBulletCharacter

public void setBulletCharacter(java.lang.String str)

getBulletFontColor

public java.awt.Color getBulletFontColor()
Returns:
the color of bullet characters within a given paragraph. A null value means to use the text font color.

setBulletFontColor

public void setBulletFontColor(java.awt.Color color)
Set the color to be used on bullet characters within a given paragraph.

Parameters:
color - the bullet color

getBulletFontSize

public double getBulletFontSize()
Returns the bullet size that is to be used within a paragraph. This may be specified in two different ways, percentage spacing and font point spacing:

If bulletSize >= 0, then bulletSize is a percentage of the font size. If bulletSize < 0, then it specifies the size in points

Returns:
the bullet size

setBulletFontSize

public void setBulletFontSize(double bulletSize)
Sets the bullet size that is to be used within a paragraph. This may be specified in two different ways, percentage spacing and font point spacing:

If bulletSize >= 0, then bulletSize is a percentage of the font size. If bulletSize < 0, then it specifies the size in points

setIndent

public void setIndent(double value)
Specifies the indent size that will be applied to the first line of text in the paragraph.

Parameters:
value - the indent in points.

getIndent

public double getIndent()
Returns:
the indent applied to the first line of text in the paragraph.

setLeftMargin

public void setLeftMargin(double value)
Specifies the left margin of the paragraph. This is specified in addition to the text body inset and applies only to this text paragraph. That is the text body Inset and the LeftMargin attributes are additive with respect to the text position.

Parameters:
value - the left margin of the paragraph

getLeftMargin

public double getLeftMargin()
Returns:
the left margin of the paragraph

getDefaultTabSize

public double getDefaultTabSize()
Returns:
the default size for a tab character within this paragraph in points

getTabStop

public double getTabStop(int idx)

setLineSpacing

public void setLineSpacing(double linespacing)
This element specifies the vertical line spacing that is to be used within a paragraph. This may be specified in two different ways, percentage spacing and font point spacing:

If linespacing >= 0, then linespacing is a percentage of normal line height If linespacing < 0, the absolute value of linespacing is the spacing in points

Examples:

      // spacing will be 120% of the size of the largest text on each line
      paragraph.setLineSpacing(120);

      // spacing will be 200% of the size of the largest text on each line
      paragraph.setLineSpacing(200);

      // spacing will be 48 points
      paragraph.setLineSpacing(-48.0);

Parameters:
linespacing - the vertical line spacing

getLineSpacing

public double getLineSpacing()
Returns the vertical line spacing that is to be used within a paragraph. This may be specified in two different ways, percentage spacing and font point spacing:

If linespacing >= 0, then linespacing is a percentage of normal line height. If linespacing < 0, the absolute value of linespacing is the spacing in points

Returns:
the vertical line spacing.

setSpaceBefore

public void setSpaceBefore(double spaceBefore)
Set the amount of vertical white space that will be present before the paragraph. This space is specified in either percentage or points:

If spaceBefore >= 0, then space is a percentage of normal line height. If spaceBefore < 0, the absolute value of linespacing is the spacing in points

Examples:

      // The paragraph will be formatted to have a spacing before the paragraph text.
      // The spacing will be 200% of the size of the largest text on each line
      paragraph.setSpaceBefore(200);

      // The spacing will be a size of 48 points
      paragraph.setSpaceBefore(-48.0);

Parameters:
spaceBefore - the vertical white space before the paragraph.

getSpaceBefore

public double getSpaceBefore()
The amount of vertical white space before the paragraph This may be specified in two different ways, percentage spacing and font point spacing:

If spaceBefore >= 0, then space is a percentage of normal line height. If spaceBefore < 0, the absolute value of linespacing is the spacing in points

Returns:
the vertical white space before the paragraph

setSpaceAfter

public void setSpaceAfter(double spaceAfter)
Set the amount of vertical white space that will be present after the paragraph. This space is specified in either percentage or points:

If spaceAfter >= 0, then space is a percentage of normal line height. If spaceAfter < 0, the absolute value of linespacing is the spacing in points

Examples:

      // The paragraph will be formatted to have a spacing after the paragraph text.
      // The spacing will be 200% of the size of the largest text on each line
      paragraph.setSpaceAfter(200);

      // The spacing will be a size of 48 points
      paragraph.setSpaceAfter(-48.0);

Parameters:
spaceAfter - the vertical white space after the paragraph.

getSpaceAfter

public double getSpaceAfter()
The amount of vertical white space after the paragraph This may be specified in two different ways, percentage spacing and font point spacing:

If spaceBefore >= 0, then space is a percentage of normal line height. If spaceBefore < 0, the absolute value of linespacing is the spacing in points

Returns:
the vertical white space after the paragraph

setLevel

public void setLevel(int level)
Specifies the particular level text properties that this paragraph will follow. The value for this attribute formats the text according to the corresponding level paragraph properties defined in the SlideMaster.

Parameters:
level - the level (0 ... 4)

getLevel

public int getLevel()
Returns:
the text level of this paragraph (0-based). Default is 0.

isBullet

public boolean isBullet()
Returns whether this paragraph has bullets

setBullet

public void setBullet(boolean flag)
Parameters:
flag - whether text in this paragraph has bullets

setBulletAutoNumber

public void setBulletAutoNumber(ListAutoNumber scheme,
                                int startAt)
Specifies that automatic numbered bullet points should be applied to this paragraph

Parameters:
scheme - type of auto-numbering
startAt - the number that will start number for a given sequence of automatically numbered bullets (1-based).

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

draw

public double draw(java.awt.Graphics2D graphics,
                   double x,
                   double y)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTextRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTextRun

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFTextRun

@Beta
public class XSLFTextRun
extends java.lang.Object

Represents a run of text within the containing text body. The run element is the lowest level text separation mechanism within a text body.

Author:
Yegor Kozlov

Method Summary
XSLFHyperlink | createHyperlink()
double | getCharacterSpacing()
java.awt.Color | getFontColor()
java.lang.String | getFontFamily()
double | getFontSize()
XSLFHyperlink | getHyperlink()
byte | getPitchAndFamily()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextCharacterProperties | getRPr()
java.lang.String | getText()
TextCap | getTextCap()
org.openxmlformats.schemas.drawingml.x2006.main.CTRegularTextRun | getXmlObject()
boolean | isBold()
boolean | isItalic()
boolean | isStrikethrough()
boolean | isSubscript()
boolean | isSuperscript()
boolean | isUnderline()
void | setBold(boolean bold) Specifies whether this run of text will be formatted as bold text
void | setCharacterSpacing(double spc) Set the spacing between characters within a text run.
void | setFontColor(java.awt.Color color)
void | setFontFamily(java.lang.String typeface) Specifies the typeface, or name of the font that is to be used for this text run.
void | setFontFamily(java.lang.String typeface, byte charset, byte pictAndFamily, boolean isSymbol)
void | setFontSize(double fontSize)
void | setItalic(boolean italic)
void | setStrikethrough(boolean strike) Specifies whether a run of text will be formatted as strikethrough text.
void | setText(java.lang.String text)
void | setUnderline(boolean underline)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getText

public java.lang.String getText()

setText

public void setText(java.lang.String text)

getXmlObject

public org.openxmlformats.schemas.drawingml.x2006.main.CTRegularTextRun getXmlObject()

setFontColor

public void setFontColor(java.awt.Color color)

getFontColor

public java.awt.Color getFontColor()

setFontSize

public void setFontSize(double fontSize)
Parameters:
fontSize - font size in points. The value of -1 unsets the Sz attribyte from the underlying xml bean

getFontSize

public double getFontSize()
Returns:
font size in points or -1 if font size is not set.

getCharacterSpacing

public double getCharacterSpacing()
Returns:
the spacing between characters within a text run, If this attribute is omitted than a value of 0 or no adjustment is assumed.

setCharacterSpacing

public void setCharacterSpacing(double spc)
Set the spacing between characters within a text run.

The spacing is specified in points. Positive values will cause the text to expand, negative values to condense.

Parameters:
spc - character spacing in points.

setFontFamily

public void setFontFamily(java.lang.String typeface)
Specifies the typeface, or name of the font that is to be used for this text run.

Parameters:
typeface - the font to apply to this text run. The value of null unsets the Typeface attrubute from the underlying xml.

setFontFamily

public void setFontFamily(java.lang.String typeface,
                          byte charset,
                          byte pictAndFamily,
                          boolean isSymbol)

getFontFamily

public java.lang.String getFontFamily()
Returns:
font family or null if not set

getPitchAndFamily

public byte getPitchAndFamily()

setStrikethrough

public void setStrikethrough(boolean strike)
Specifies whether a run of text will be formatted as strikethrough text.

Parameters:
strike - whether a run of text will be formatted as strikethrough text.

isStrikethrough

public boolean isStrikethrough()
Returns:
whether a run of text will be formatted as strikethrough text. Default is false.

isSuperscript

public boolean isSuperscript()
Returns:
whether a run of text will be formatted as a superscript text. Default is false.

isSubscript

public boolean isSubscript()
Returns:
whether a run of text will be formatted as a superscript text. Default is false.

getTextCap

public TextCap getTextCap()
Returns:
whether a run of text will be formatted as a superscript text. Default is false.

setBold

public void setBold(boolean bold)
Specifies whether this run of text will be formatted as bold text

Parameters:
bold - whether this run of text will be formatted as bold text

isBold

public boolean isBold()
Returns:
whether this run of text is formatted as bold text

setItalic

public void setItalic(boolean italic)
Parameters:
italic - whether this run of text is formatted as italic text

isItalic

public boolean isItalic()
Returns:
whether this run of text is formatted as italic text

setUnderline

public void setUnderline(boolean underline)
Parameters:
underline - whether this run of text is formatted as underlined text

isUnderline

public boolean isUnderline()
Returns:
whether this run of text is formatted as underlined text

getRPr

protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextCharacterProperties getRPr()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

createHyperlink

public XSLFHyperlink createHyperlink()

getHyperlink

public XSLFHyperlink getHyperlink()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTextShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTextShape

java.lang.Object
    extended by  org.apache.poi.xslf.usermodel.XSLFShape
        extended by  org.apache.poi.xslf.usermodel.XSLFSimpleShape
            extended by  org.apache.poi.xslf.usermodel.XSLFTextShape
All Implemented Interfaces:
java.lang.Iterable<XSLFTextParagraph>
Direct Known Subclasses:
XSLFAutoShape, XSLFTableCell
@Beta
public abstract class XSLFTextShape
extends XSLFSimpleShape
implements java.lang.Iterable<XSLFTextParagraph>

Represents a shape that can hold text.

Author:
Yegor Kozlov

Method Summary
XSLFTextParagraph | addNewTextParagraph() add a new paragraph run to this shape
void | clearText() unset text from this shape
void | drawContent(java.awt.Graphics2D graphics) draw any content within this shape (image, text, etc.).
double | getBottomInset() Returns the distance (in points) between the bottom of the text frame and the bottom of the inscribed rectangle of the shape that contains the text.
double | getLeftInset() Returns the distance (in points) between the left edge of the text frame and the left edge of the inscribed rectangle of the shape that contains the text.
double | getRightInset() Returns the distance (in points) between the right edge of the text frame and the right edge of the inscribed rectangle of the shape that contains the text.
java.lang.String | getText()
TextAutofit | getTextAutofit()
protected abstract org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody | getTextBody(boolean create)
protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextBodyProperties | getTextBodyPr()
TextDirection | getTextDirection()
double | getTextHeight() Compute the cumulative height occupied by the text
java.util.List<XSLFTextParagraph> | getTextParagraphs()
Placeholder | getTextType()
double | getTopInset() Returns the distance (in points) between the top of the text frame and the top of the inscribed rectangle of the shape that contains the text.
VerticalAlignment | getVerticalAlignment() Returns the type of vertical alignment for the text.
boolean | getWordWrap()
java.util.Iterator<XSLFTextParagraph> | iterator()
java.awt.geom.Rectangle2D | resizeToFitText() Adjust the size of the shape so it encompasses the text inside it.
void | setBottomInset(double margin) Sets the botom margin.
void | setLeftInset(double margin) Sets the left margin.
void | setPlaceholder(Placeholder placeholder) Specifies that the corresponding shape should be represented by the generating application as a placeholder.
void | setRightInset(double margin) Sets the right margin.
void | setText(java.lang.String text)
void | setTextAutofit(TextAutofit value) Specifies that a shape should be auto-fit to fully contain the text described within it.
void | setTextDirection(TextDirection orientation)
void | setTopInset(double margin) Sets the top margin.
void | setVerticalAlignment(VerticalAlignment anchor) Sets the type of vertical alignment for the text.
void | setWordWrap(boolean wrap)
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFSimpleShape
draw, getAnchor, getCTPlaceholder, getFillColor, getFlipHorizontal, getFlipVertical, getLineCap, getLineColor, getLineDash, getLineHeadDecoration, getLineHeadLength, getLineHeadWidth, getLineTailDecoration, getLineTailLength, getLineTailWidth, getLineWidth, getNvPr, getRotation, getShadow, getShapeId, getShapeName, getShapeType, getSheet, getSpPr, getSpStyle, getXmlObject, setAnchor, setFillColor, setFlipHorizontal, setFlipVertical, setLineCap, setLineColor, setLineDash, setLineHeadDecoration, setLineHeadLength, setLineHeadWidth, setLineTailDecoration, setLineTailLength, setLineTailWidth, setLineWidth, setRotation, setShapeType
Methods inherited from class org.apache.poi.xslf.usermodel.XSLFShape
applyTransform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

iterator

public java.util.Iterator<XSLFTextParagraph> iterator()
Specified by:
iterator in interface java.lang.Iterable<XSLFTextParagraph>

getText

public java.lang.String getText()
Returns:
text contained within this shape or empty string

clearText

public void clearText()
unset text from this shape

setText

public void setText(java.lang.String text)

getTextParagraphs

public java.util.List<XSLFTextParagraph> getTextParagraphs()
Returns:
text paragraphs in this shape

addNewTextParagraph

public XSLFTextParagraph addNewTextParagraph()
add a new paragraph run to this shape

Returns:
created paragraph run

setVerticalAlignment

public void setVerticalAlignment(VerticalAlignment anchor)
Sets the type of vertical alignment for the text.

Parameters:
anchor - - the type of alignment. A null values unsets this property.

getVerticalAlignment

public VerticalAlignment getVerticalAlignment()
Returns the type of vertical alignment for the text.

Returns:
the type of vertical alignment

setTextDirection

public void setTextDirection(TextDirection orientation)
Parameters:
orientation - vertical orientation of the text

getTextDirection

public TextDirection getTextDirection()
Returns:
vertical orientation of the text

getBottomInset

public double getBottomInset()
Returns the distance (in points) between the bottom of the text frame and the bottom of the inscribed rectangle of the shape that contains the text.

Returns:
the bottom inset in points

getLeftInset

public double getLeftInset()
Returns the distance (in points) between the left edge of the text frame and the left edge of the inscribed rectangle of the shape that contains the text.

Returns:
the left inset in points

getRightInset

public double getRightInset()
Returns the distance (in points) between the right edge of the text frame and the right edge of the inscribed rectangle of the shape that contains the text.

Returns:
the right inset in points

getTopInset

public double getTopInset()
Returns the distance (in points) between the top of the text frame and the top of the inscribed rectangle of the shape that contains the text.

Returns:
the top inset in points

setBottomInset

public void setBottomInset(double margin)
Sets the botom margin.

Parameters:
margin - the bottom margin
See Also:
getBottomInset()

setLeftInset

public void setLeftInset(double margin)
Sets the left margin.

Parameters:
margin - the left margin
See Also:
getLeftInset()

setRightInset

public void setRightInset(double margin)
Sets the right margin.

Parameters:
margin - the right margin
See Also:
getRightInset()

setTopInset

public void setTopInset(double margin)
Sets the top margin.

Parameters:
margin - the top margin
See Also:
getTopInset()

getWordWrap

public boolean getWordWrap()
Returns:
whether to wrap words within the bounding rectangle

setWordWrap

public void setWordWrap(boolean wrap)
Parameters:
wrap - whether to wrap words within the bounding rectangle

setTextAutofit

public void setTextAutofit(TextAutofit value)
Specifies that a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside

Parameters:
value - type of autofit

getTextAutofit

public TextAutofit getTextAutofit()
Returns:
type of autofit

getTextBodyPr

protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextBodyProperties getTextBodyPr()

getTextBody

protected abstract org.openxmlformats.schemas.drawingml.x2006.main.CTTextBody getTextBody(boolean create)

getTextType

public Placeholder getTextType()

setPlaceholder

public void setPlaceholder(Placeholder placeholder)
Specifies that the corresponding shape should be represented by the generating application as a placeholder. When a shape is considered a placeholder by the generating application it can have special properties to alert the user that they may enter content into the shape. Different types of placeholders are allowed and can be specified by using the placeholder type attribute for this element

Parameters:
placeholder -

getTextHeight

public double getTextHeight()
Compute the cumulative height occupied by the text

resizeToFitText

public java.awt.geom.Rectangle2D resizeToFitText()
Adjust the size of the shape so it encompasses the text inside it.

Returns:
a Rectangle2D that is the bounds of this shape.

drawContent

public void drawContent(java.awt.Graphics2D graphics)
Description copied from class: XSLFSimpleShape
draw any content within this shape (image, text, etc.).

Overrides:
drawContent in class XSLFSimpleShape
Parameters:
graphics - the graphics to draw into
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLFTheme

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.usermodel
Class XSLFTheme

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xslf.usermodel.XSLFTheme

@Beta
public class XSLFTheme
extends POIXMLDocumentPart

A shared style sheet in a .pptx slide show

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XSLFTheme(PackagePart part, PackageRelationship rel)
Method Summary
protected void | commit() Save the content in the underlying package part.
java.lang.String | getMajorFont()
java.lang.String | getMinorFont()
java.lang.String | getName()
org.openxmlformats.schemas.drawingml.x2006.main.CTOfficeStyleSheet | getXmlObject() While developing only!
void | setName(java.lang.String name) Set name of this theme
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSLFTheme

public XSLFTheme(PackagePart part,
                 PackageRelationship rel)
          throws java.io.IOException,
                 org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getName

public java.lang.String getName()
Returns:
name of this theme, e.g. "Office Theme"

setName

public void setName(java.lang.String name)
Set name of this theme

Parameters:
name - name of this theme

getXmlObject

@Internal
public org.openxmlformats.schemas.drawingml.x2006.main.CTOfficeStyleSheet getXmlObject()
While developing only!

commit

protected final void commit()
                     throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getMajorFont

public java.lang.String getMajorFont()
Returns:
typeface of the major font to use in a document. Typically the major font is used for heading areas of a document.

getMinorFont

public java.lang.String getMinorFont()
Returns:
typeface of the minor font to use in a document. Typically the monor font is used for normal text or paragraph areas.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xslf.usermodel.DrawingParagraph

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.DrawingParagraph

Packages that use DrawingParagraph
org.apache.poi.xslf.usermodel

Uses of DrawingParagraph in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return DrawingParagraph
 DrawingParagraph[] DrawingTextBody.getParagraphs()

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type DrawingParagraph
 java.util.List<DrawingParagraph> XSLFCommonSlideData.getText()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.DrawingTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.DrawingTable

No usage of org.apache.poi.xslf.usermodel.DrawingTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.DrawingTableCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.DrawingTableCell

Packages that use DrawingTableCell
org.apache.poi.xslf.usermodel

Uses of DrawingTableCell in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return DrawingTableCell
 DrawingTableCell[] DrawingTableRow.getCells()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.DrawingTableRow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.DrawingTableRow

Packages that use DrawingTableRow
org.apache.poi.xslf.usermodel

Uses of DrawingTableRow in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return DrawingTableRow
 DrawingTableRow[] DrawingTable.getRows()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.DrawingTextBody

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.DrawingTextBody

Packages that use DrawingTextBody
org.apache.poi.xslf.usermodel

Uses of DrawingTextBody in org.apache.poi.xslf.usermodel

Subclasses of DrawingTextBody in org.apache.poi.xslf.usermodel
 class DrawingTextPlaceholder
A DrawingTextBody which is a placeholder

Methods in org.apache.poi.xslf.usermodel that return DrawingTextBody
 DrawingTextBody DrawingTableCell.getTextBody()

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type DrawingTextBody
 java.util.List<DrawingTextBody> XSLFCommonSlideData.getDrawingText()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.DrawingTextPlaceholder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.DrawingTextPlaceholder

No usage of org.apache.poi.xslf.usermodel.DrawingTextPlaceholder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.LineCap

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.LineCap

Packages that use LineCap
org.apache.poi.xslf.usermodel

Uses of LineCap in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return LineCap
LineCap | XSLFSimpleShape.getLineCap()
static LineCap | LineCap.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineCap[] | LineCap.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type LineCap
 void XSLFSimpleShape.setLineCap(LineCap cap)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.LineDash

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.LineDash

Packages that use LineDash
org.apache.poi.xslf.usermodel

Uses of LineDash in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return LineDash
LineDash | XSLFSimpleShape.getLineDash()
static LineDash | LineDash.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineDash[] | LineDash.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type LineDash
 void XSLFSimpleShape.setLineDash(LineDash dash)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.LineDecoration

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.LineDecoration

Packages that use LineDecoration
org.apache.poi.xslf.usermodel

Uses of LineDecoration in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return LineDecoration
LineDecoration | XSLFSimpleShape.getLineHeadDecoration()
LineDecoration | XSLFSimpleShape.getLineTailDecoration()
static LineDecoration | LineDecoration.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineDecoration[] | LineDecoration.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type LineDecoration
void | XSLFSimpleShape.setLineHeadDecoration(LineDecoration style) Specifies the line end decoration, such as a triangle or arrowhead.
void | XSLFSimpleShape.setLineTailDecoration(LineDecoration style) Specifies the line end decoration, such as a triangle or arrowhead.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.LineEndLength

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.LineEndLength

Packages that use LineEndLength
org.apache.poi.xslf.usermodel

Uses of LineEndLength in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return LineEndLength
LineEndLength | XSLFSimpleShape.getLineHeadLength()
LineEndLength | XSLFSimpleShape.getLineTailLength()
static LineEndLength | LineEndLength.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineEndLength[] | LineEndLength.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type LineEndLength
void | XSLFSimpleShape.setLineHeadLength(LineEndLength style) Specifies the line end width in relation to the line width.
void | XSLFSimpleShape.setLineTailLength(LineEndLength style) Specifies the line end width in relation to the line width.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.LineEndWidth

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.LineEndWidth

Packages that use LineEndWidth
org.apache.poi.xslf.usermodel

Uses of LineEndWidth in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return LineEndWidth
LineEndWidth | XSLFSimpleShape.getLineHeadWidth()
LineEndWidth | XSLFSimpleShape.getLineTailWidth()
static LineEndWidth | LineEndWidth.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineEndWidth[] | LineEndWidth.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type LineEndWidth
void | XSLFSimpleShape.setLineHeadWidth(LineEndWidth style) specifies decorations which can be added to the head of a line.
void | XSLFSimpleShape.setLineTailWidth(LineEndWidth style) specifies decorations which can be added to the tail of a line.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.ListAutoNumber

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.ListAutoNumber

Packages that use ListAutoNumber
org.apache.poi.xslf.usermodel

Uses of ListAutoNumber in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return ListAutoNumber
static ListAutoNumber | ListAutoNumber.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ListAutoNumber[] | ListAutoNumber.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type ListAutoNumber
 void XSLFTextParagraph.setBulletAutoNumber(ListAutoNumber scheme, int startAt)
Specifies that automatic numbered bullet points should be applied to this paragraph

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.Placeholder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.Placeholder

Packages that use Placeholder
org.apache.poi.xslf.usermodel

Uses of Placeholder in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return Placeholder
Placeholder | XSLFTextShape.getTextType()
static Placeholder | Placeholder.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Placeholder[] | Placeholder.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type Placeholder
protected org.openxmlformats.schemas.drawingml.x2006.main.CTTextListStyle | XSLFSlideMaster.getTextProperties(Placeholder textType)
protected XSLFTextShape | XSLFSheet.getTextShapeByType(Placeholder type)
void | XSLFTextShape.setPlaceholder(Placeholder placeholder) Specifies that the corresponding shape should be represented by the generating application as a placeholder.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.SlideLayout

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.SlideLayout

Packages that use SlideLayout
org.apache.poi.xslf.usermodel

Uses of SlideLayout in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return SlideLayout
SlideLayout | XSLFSlideLayout.getType()
static SlideLayout | SlideLayout.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static SlideLayout[] | SlideLayout.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type SlideLayout
 XSLFSlideLayout XSLFSlideMaster.getLayout(SlideLayout type)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.TextAlign

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.TextAlign

Packages that use TextAlign
org.apache.poi.xslf.usermodel

Uses of TextAlign in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return TextAlign
TextAlign | XSLFTextParagraph.getTextAlign() Returns the alignment that is applied to the paragraph.
static TextAlign | TextAlign.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextAlign[] | TextAlign.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type TextAlign
 void XSLFTextParagraph.setTextAlign(TextAlign align)
Specifies the alignment that is to be applied to the paragraph.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.TextAutofit

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.TextAutofit

Packages that use TextAutofit
org.apache.poi.xslf.usermodel

Uses of TextAutofit in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return TextAutofit
TextAutofit | XSLFTextShape.getTextAutofit()
static TextAutofit | TextAutofit.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextAutofit[] | TextAutofit.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type TextAutofit
 void XSLFTextShape.setTextAutofit(TextAutofit value)
Specifies that a shape should be auto-fit to fully contain the text described within it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.TextCap

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.TextCap

Packages that use TextCap
org.apache.poi.xslf.usermodel

Uses of TextCap in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return TextCap
TextCap | XSLFTextRun.getTextCap()
static TextCap | TextCap.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextCap[] | TextCap.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.TextDirection

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.TextDirection

Packages that use TextDirection
org.apache.poi.xslf.usermodel

Uses of TextDirection in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return TextDirection
TextDirection | XSLFTextShape.getTextDirection()
static TextDirection | TextDirection.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextDirection[] | TextDirection.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type TextDirection
 void XSLFTextShape.setTextDirection(TextDirection orientation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.VerticalAlignment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.VerticalAlignment

Packages that use VerticalAlignment
org.apache.poi.xslf.usermodel

Uses of VerticalAlignment in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return VerticalAlignment
VerticalAlignment | XSLFTextShape.getVerticalAlignment() Returns the type of vertical alignment for the text.
VerticalAlignment | XSLFTableCell.getVerticalAlignment()
static VerticalAlignment | VerticalAlignment.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static VerticalAlignment[] | VerticalAlignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type VerticalAlignment
void | XSLFTextShape.setVerticalAlignment(VerticalAlignment anchor) Sets the type of vertical alignment for the text.
void | XSLFTableCell.setVerticalAlignment(VerticalAlignment anchor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XMLSlideShow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XMLSlideShow

Packages that use XMLSlideShow
org.apache.poi.xslf.extractor
org.apache.poi.xslf.usermodel

Uses of XMLSlideShow in org.apache.poi.xslf.extractor

Constructors in org.apache.poi.xslf.extractor with parameters of type XMLSlideShow
XSLFPowerPointExtractor(XMLSlideShow slideshow)

Uses of XMLSlideShow in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XMLSlideShow
 XMLSlideShow XSLFSheet.getSlideShow()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFAutoShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFAutoShape

Packages that use XSLFAutoShape
org.apache.poi.xslf.usermodel

Uses of XSLFAutoShape in org.apache.poi.xslf.usermodel

Subclasses of XSLFAutoShape in org.apache.poi.xslf.usermodel
class | XSLFFreeformShape Represents a custom geometric shape.
class | XSLFTextBox

Methods in org.apache.poi.xslf.usermodel that return XSLFAutoShape
XSLFAutoShape | XSLFSheet.createAutoShape()
XSLFAutoShape | XSLFShapeContainer.createAutoShape() create a new shape with a predefined geometry and add it to this shape container
XSLFAutoShape | XSLFGroupShape.createAutoShape()
XSLFAutoShape | XSLFDrawing.createAutoShape()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFBackground

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFBackground

Packages that use XSLFBackground
org.apache.poi.xslf.usermodel

Uses of XSLFBackground in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFBackground
XSLFBackground | XSLFSlideMaster.getBackground()
XSLFBackground | XSLFSlideLayout.getBackground()
XSLFBackground | XSLFSlide.getBackground()
XSLFBackground | XSLFSheet.getBackground()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFColor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFColor

No usage of org.apache.poi.xslf.usermodel.XSLFColor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFCommentAuthors

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFCommentAuthors

Packages that use XSLFCommentAuthors
org.apache.poi.xslf.usermodel

Uses of XSLFCommentAuthors in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFCommentAuthors
 XSLFCommentAuthors XMLSlideShow.getCommentAuthors()
Returns the list of comment authors, if there is one.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFComments

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFComments

Packages that use XSLFComments
org.apache.poi.xslf.usermodel

Uses of XSLFComments in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFComments
 XSLFComments XSLFSlide.getComments()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFCommonSlideData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFCommonSlideData

Packages that use XSLFCommonSlideData
org.apache.poi.xslf.usermodel

Uses of XSLFCommonSlideData in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFCommonSlideData
 XSLFCommonSlideData XSLFSheet.getCommonSlideData()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFConnectorShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFConnectorShape

Packages that use XSLFConnectorShape
org.apache.poi.xslf.usermodel

Uses of XSLFConnectorShape in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFConnectorShape
XSLFConnectorShape | XSLFSheet.createConnector()
XSLFConnectorShape | XSLFShapeContainer.createConnector() create a connector
XSLFConnectorShape | XSLFGroupShape.createConnector()
XSLFConnectorShape | XSLFDrawing.createConnector()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFDrawing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFDrawing

No usage of org.apache.poi.xslf.usermodel.XSLFDrawing

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFFactory

Packages that use XSLFFactory
org.apache.poi.xslf.usermodel

Uses of XSLFFactory in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFFactory
static XSLFFactory XSLFFactory.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xslf.usermodel.XSLFFontManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xslf.usermodel.XSLFFontManager

No usage of org.apache.poi.xslf.usermodel.XSLFFontManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFFreeformShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFFreeformShape

Packages that use XSLFFreeformShape
org.apache.poi.xslf.usermodel

Uses of XSLFFreeformShape in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFFreeformShape
XSLFFreeformShape | XSLFSheet.createFreeform()
XSLFFreeformShape | XSLFShapeContainer.createFreeform() create a new shape with a custom geometry
XSLFFreeformShape | XSLFGroupShape.createFreeform()
XSLFFreeformShape | XSLFDrawing.createFreeform()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFGraphicFrame

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFGraphicFrame

Packages that use XSLFGraphicFrame
org.apache.poi.xslf.usermodel

Uses of XSLFGraphicFrame in org.apache.poi.xslf.usermodel

Subclasses of XSLFGraphicFrame in org.apache.poi.xslf.usermodel
 class XSLFTable
Represents a table in a .pptx presentation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFGroupShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFGroupShape

Packages that use XSLFGroupShape
org.apache.poi.xslf.usermodel

Uses of XSLFGroupShape in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFGroupShape
XSLFGroupShape | XSLFSheet.createGroup()
XSLFGroupShape | XSLFShapeContainer.createGroup() create a group of shapes belonging to this container
XSLFGroupShape | XSLFGroupShape.createGroup()
XSLFGroupShape | XSLFDrawing.createGroup()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFHyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFHyperlink

Packages that use XSLFHyperlink
org.apache.poi.xslf.usermodel

Uses of XSLFHyperlink in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFHyperlink
XSLFHyperlink | XSLFTextRun.createHyperlink()
XSLFHyperlink | XSLFTextRun.getHyperlink()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFImageRenderer

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFImageRenderer

No usage of org.apache.poi.xslf.usermodel.XSLFImageRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFNotes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFNotes

Packages that use XSLFNotes
org.apache.poi.xslf.usermodel

Uses of XSLFNotes in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFNotes
 XSLFNotes XSLFSlide.getNotes()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFNotesMaster

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFNotesMaster

Packages that use XSLFNotesMaster
org.apache.poi.xslf.usermodel

Uses of XSLFNotesMaster in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFNotesMaster
XSLFNotesMaster | XSLFNotes.getMasterSheet()
XSLFNotesMaster | XMLSlideShow.getNotesMaster() Return the Notes Master, if there is one.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFPictureData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFPictureData

Packages that use XSLFPictureData
org.apache.poi.xslf.usermodel

Uses of XSLFPictureData in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFPictureData
 XSLFPictureData XSLFPictureShape.getPictureData()

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type XSLFPictureData
 java.util.List<XSLFPictureData> XMLSlideShow.getAllPictures()
Returns all Pictures, which are referenced from the document itself.

Methods in org.apache.poi.xslf.usermodel with parameters of type XSLFPictureData
 boolean XSLFImageRenderer.drawImage(java.awt.Graphics2D graphics, XSLFPictureData data, java.awt.geom.Rectangle2D anchor)
Render picture data into the supplied graphics

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFPictureShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFPictureShape

Packages that use XSLFPictureShape
org.apache.poi.xslf.usermodel

Uses of XSLFPictureShape in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFPictureShape
XSLFPictureShape | XSLFSheet.createPicture(int pictureIndex)
XSLFPictureShape | XSLFShapeContainer.createPicture(int pictureIndex) create a picture belonging to this container
XSLFPictureShape | XSLFGroupShape.createPicture(int pictureIndex)
XSLFPictureShape | XSLFDrawing.createPicture(java.lang.String rel)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFRelation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFRelation

Packages that use XSLFRelation
org.apache.poi.xslf.extractor
org.apache.poi.xslf.usermodel

Uses of XSLFRelation in org.apache.poi.xslf.extractor

Fields in org.apache.poi.xslf.extractor declared as XSLFRelation
static XSLFRelation[] XSLFPowerPointExtractor.SUPPORTED_TYPES

Uses of XSLFRelation in org.apache.poi.xslf.usermodel

Fields in org.apache.poi.xslf.usermodel declared as XSLFRelation
static XSLFRelation | XSLFRelation.COMMENT_AUTHORS
static XSLFRelation | XSLFRelation.COMMENTS
static XSLFRelation | XSLFRelation.HYPERLINK
static XSLFRelation | XSLFRelation.IMAGE_BMP
static XSLFRelation | XSLFRelation.IMAGE_DIB
static XSLFRelation | XSLFRelation.IMAGE_EMF
static XSLFRelation | XSLFRelation.IMAGE_EPS
static XSLFRelation | XSLFRelation.IMAGE_GIF
static XSLFRelation | XSLFRelation.IMAGE_JPEG
static XSLFRelation | XSLFRelation.IMAGE_PICT
static XSLFRelation | XSLFRelation.IMAGE_PNG
static XSLFRelation | XSLFRelation.IMAGE_TIFF
static XSLFRelation | XSLFRelation.IMAGE_WMF
static XSLFRelation | XSLFRelation.IMAGE_WPG
static XSLFRelation | XSLFRelation.IMAGES
static XSLFRelation | XSLFRelation.MACRO
static XSLFRelation | XSLFRelation.MACRO_TEMPLATE
static XSLFRelation | XSLFRelation.MAIN
static XSLFRelation | XSLFRelation.NOTES
static XSLFRelation | XSLFRelation.NOTES_MASTER
static XSLFRelation | XSLFRelation.PRESENTATION_MACRO
static XSLFRelation | XSLFRelation.PRESENTATIONML
static XSLFRelation | XSLFRelation.PRESENTATIONML_TEMPLATE
static XSLFRelation | XSLFRelation.SLIDE
static XSLFRelation | XSLFRelation.SLIDE_LAYOUT
static XSLFRelation | XSLFRelation.SLIDE_MASTER
static XSLFRelation | XSLFRelation.TABLE_STYLES
static XSLFRelation | XSLFRelation.THEME
static XSLFRelation | XSLFRelation.THEME_MANAGER
static XSLFRelation | XSLFRelation.VML_DRAWING

Fields in org.apache.poi.xslf.usermodel with type parameters of type XSLFRelation
protected static java.util.Map<java.lang.String,XSLFRelation> XSLFRelation._table
A map to lookup POIXMLRelation by its relation type

Methods in org.apache.poi.xslf.usermodel that return XSLFRelation
static XSLFRelation XSLFRelation.getInstance(java.lang.String rel)
Get POIXMLRelation by relation type

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFRenderingHint

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFRenderingHint

Packages that use XSLFRenderingHint
org.apache.poi.xslf.usermodel

Uses of XSLFRenderingHint in org.apache.poi.xslf.usermodel

Fields in org.apache.poi.xslf.usermodel declared as XSLFRenderingHint
static XSLFRenderingHint | XSLFRenderingHint.FONT_HANDLER Use this object to resolve unknown / missing fonts when rendering slides
static XSLFRenderingHint | XSLFRenderingHint.GRESTORE
static XSLFRenderingHint | XSLFRenderingHint.GSAVE
static XSLFRenderingHint | XSLFRenderingHint.IMAGE_RENDERER Use a custom image rendener
static XSLFRenderingHint | XSLFRenderingHint.TEXT_RENDERING_MODE how to render text: TEXT_AS_CHARACTERS (default) means to draw via Graphics2D.drawString(java.text.AttributedCharacterIterator, float, float).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFShadow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFShadow

Packages that use XSLFShadow
org.apache.poi.xslf.usermodel

Uses of XSLFShadow in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFShadow
XSLFShadow | XSLFSimpleShape.getShadow()
XSLFShadow | XSLFConnectorShape.getShadow() YK: shadows of lines are suppressed for now.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFShape

Packages that use XSLFShape
org.apache.poi.xslf.usermodel

Uses of XSLFShape in org.apache.poi.xslf.usermodel

Subclasses of XSLFShape in org.apache.poi.xslf.usermodel
class | XSLFAutoShape Represents a shape with a preset geometry.
class | XSLFBackground Background shape
class | XSLFConnectorShape Specifies a connection shape.
class | XSLFFreeformShape Represents a custom geometric shape.
class | XSLFGraphicFrame
class | XSLFGroupShape Represents a group shape that consists of many shapes grouped together.
class | XSLFPictureShape Represents a picture shape
class | XSLFShadow Represents a shadow of a shape.
class | XSLFSimpleShape Represents a single (non-group) shape in a .pptx slide show
class | XSLFTable Represents a table in a .pptx presentation
class | XSLFTableCell Represents a cell of a table in a .pptx presentation
class | XSLFTextBox
class | XSLFTextShape Represents a shape that can hold text.

Methods in org.apache.poi.xslf.usermodel that return XSLFShape
XSLFShape[] | XSLFSheet.getShapes() Returns an array containing all of the shapes in this sheet
XSLFShape[] | XSLFShapeContainer.getShapes() Returns an array containing all of the elements in this container in proper sequence (from first to last element).
XSLFShape[] | XSLFGroupShape.getShapes()

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type XSLFShape
protected java.util.List<XSLFShape> | XSLFSheet.buildShapes(org.openxmlformats.schemas.presentationml.x2006.main.CTGroupShape spTree)
java.util.Iterator<XSLFShape> | XSLFSheet.iterator() Returns an iterator over the shapes in this sheet
java.util.Iterator<XSLFShape> | XSLFGroupShape.iterator() Returns an iterator over the shapes in this sheet

Methods in org.apache.poi.xslf.usermodel with parameters of type XSLFShape
protected boolean | XSLFSlideMaster.canDraw(XSLFShape shape) Render this sheet into the supplied graphics object
protected boolean | XSLFSlideLayout.canDraw(XSLFShape shape) Render this sheet into the supplied graphics object
protected boolean | XSLFSheet.canDraw(XSLFShape shape) Checks if this sheet displays the specified shape.
boolean | XSLFSheet.removeShape(XSLFShape xShape) Removes the specified shape from this sheet, if it is present (optional operation).
boolean | XSLFShapeContainer.removeShape(XSLFShape xShape) Removes the specified shape from this sheet, if it is present (optional operation).
boolean | XSLFGroupShape.removeShape(XSLFShape xShape) Remove the specified shape from this group

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xslf.usermodel.XSLFShapeContainer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xslf.usermodel.XSLFShapeContainer

Packages that use XSLFShapeContainer
org.apache.poi.xslf.usermodel

Uses of XSLFShapeContainer in org.apache.poi.xslf.usermodel

Classes in org.apache.poi.xslf.usermodel that implement XSLFShapeContainer
class | XSLFGroupShape Represents a group shape that consists of many shapes grouped together.
class | XSLFNotes
class | XSLFNotesMaster Notes master object associated with this layout.
class | XSLFSheet
class | XSLFSlide
class | XSLFSlideLayout
class | XSLFSlideMaster Slide master object associated with this layout.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFShapeType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFShapeType

Packages that use XSLFShapeType
org.apache.poi.xslf.usermodel

Uses of XSLFShapeType in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFShapeType
XSLFShapeType | XSLFSimpleShape.getShapeType()
static XSLFShapeType | XSLFShapeType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XSLFShapeType[] | XSLFShapeType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xslf.usermodel with parameters of type XSLFShapeType
 void XSLFSimpleShape.setShapeType(XSLFShapeType type)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFSheet

Packages that use XSLFSheet
org.apache.poi.xslf.usermodel

Uses of XSLFSheet in org.apache.poi.xslf.usermodel

Subclasses of XSLFSheet in org.apache.poi.xslf.usermodel
class | XSLFNotes
class | XSLFNotesMaster Notes master object associated with this layout.
class | XSLFSlide
class | XSLFSlideLayout
class | XSLFSlideMaster Slide master object associated with this layout.

Methods in org.apache.poi.xslf.usermodel that return XSLFSheet
XSLFSheet | XSLFSheet.appendContent(XSLFSheet src) Append content to this sheet.
XSLFSheet | XSLFSlideMaster.getMasterSheet()
abstract XSLFSheet | XSLFSheet.getMasterSheet()
XSLFSheet | XSLFNotesMaster.getMasterSheet()
XSLFSheet | XSLFSimpleShape.getSheet()
XSLFSheet | XSLFGraphicFrame.getSheet()
XSLFSheet | XSLFSheet.importContent(XSLFSheet src) Set the contents of this sheet to be a copy of the source sheet.

Methods in org.apache.poi.xslf.usermodel with parameters of type XSLFSheet
XSLFSheet | XSLFSheet.appendContent(XSLFSheet src) Append content to this sheet.
XSLFSlide | XSLFSlide.importContent(XSLFSheet src)
XSLFSheet | XSLFSheet.importContent(XSLFSheet src) Set the contents of this sheet to be a copy of the source sheet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFSimpleShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFSimpleShape

Packages that use XSLFSimpleShape
org.apache.poi.xslf.model
org.apache.poi.xslf.usermodel

Uses of XSLFSimpleShape in org.apache.poi.xslf.model

Methods in org.apache.poi.xslf.model with parameters of type XSLFSimpleShape
boolean | TextBodyPropertyFetcher.fetch(XSLFSimpleShape shape)
abstract boolean | PropertyFetcher.fetch(XSLFSimpleShape shape)
boolean | ParagraphPropertyFetcher.fetch(XSLFSimpleShape shape)

Uses of XSLFSimpleShape in org.apache.poi.xslf.usermodel

Subclasses of XSLFSimpleShape in org.apache.poi.xslf.usermodel
class | XSLFAutoShape Represents a shape with a preset geometry.
class | XSLFBackground Background shape
class | XSLFConnectorShape Specifies a connection shape.
class | XSLFFreeformShape Represents a custom geometric shape.
class | XSLFPictureShape Represents a picture shape
class | XSLFShadow Represents a shadow of a shape.
class | XSLFTableCell Represents a cell of a table in a .pptx presentation
class | XSLFTextBox
class | XSLFTextShape Represents a shape that can hold text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFSlide

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFSlide

Packages that use XSLFSlide
org.apache.poi.xslf.usermodel

Uses of XSLFSlide in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFSlide
XSLFSlide | XMLSlideShow.createSlide() Create a blank slide.
XSLFSlide | XMLSlideShow.createSlide(XSLFSlideLayout layout) Create a slide and initialize it from the specified layout.
XSLFSlide[] | XMLSlideShow.getSlides() Return all the slides in the slideshow
XSLFSlide | XSLFSlide.importContent(XSLFSheet src)
XSLFSlide | XMLSlideShow.removeSlide(int index)

Methods in org.apache.poi.xslf.usermodel with parameters of type XSLFSlide
void | XSLFSlideLayout.copyLayout(XSLFSlide slide) Copy placeholders from this layout to the destination slide
void | XSLFHyperlink.setAddress(XSLFSlide slide)
void | XMLSlideShow.setSlideOrder(XSLFSlide slide, int newIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFSlideLayout

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFSlideLayout

Packages that use XSLFSlideLayout
org.apache.poi.xslf.usermodel

Uses of XSLFSlideLayout in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFSlideLayout
XSLFSlideLayout | XSLFSlideMaster.getLayout(SlideLayout type)
XSLFSlideLayout | XSLFSlide.getMasterSheet()
XSLFSlideLayout | XSLFSlide.getSlideLayout()
XSLFSlideLayout[] | XSLFSlideMaster.getSlideLayouts()

Methods in org.apache.poi.xslf.usermodel with parameters of type XSLFSlideLayout
 XSLFSlide XMLSlideShow.createSlide(XSLFSlideLayout layout)
Create a slide and initialize it from the specified layout.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFSlideMaster

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFSlideMaster

Packages that use XSLFSlideMaster
org.apache.poi.xslf.usermodel

Uses of XSLFSlideMaster in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFSlideMaster
XSLFSlideMaster | XSLFSlideLayout.getMasterSheet()
XSLFSlideMaster | XSLFSlideLayout.getSlideMaster() Slide master object associated with this layout.
XSLFSlideMaster | XSLFSlide.getSlideMaster()
XSLFSlideMaster[] | XMLSlideShow.getSlideMasters()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTable

Packages that use XSLFTable
org.apache.poi.xslf.usermodel

Uses of XSLFTable in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTable
XSLFTable | XSLFSheet.createTable()
XSLFTable | XSLFDrawing.createTable()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTableCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTableCell

Packages that use XSLFTableCell
org.apache.poi.xslf.usermodel

Uses of XSLFTableCell in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTableCell
 XSLFTableCell XSLFTableRow.addCell()

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type XSLFTableCell
java.util.List<XSLFTableCell> | XSLFTableRow.getCells()
java.util.Iterator<XSLFTableCell> | XSLFTableRow.iterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTableRow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTableRow

Packages that use XSLFTableRow
org.apache.poi.xslf.usermodel

Uses of XSLFTableRow in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTableRow
 XSLFTableRow XSLFTable.addRow()

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type XSLFTableRow
java.util.List<XSLFTableRow> | XSLFTable.getRows()
java.util.Iterator<XSLFTableRow> | XSLFTable.iterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTableStyle

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTableStyle

Packages that use XSLFTableStyle
org.apache.poi.xslf.usermodel

Uses of XSLFTableStyle in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type XSLFTableStyle
java.util.List<XSLFTableStyle> | XSLFTableStyles.getStyles()
java.util.Iterator<XSLFTableStyle> | XSLFTableStyles.iterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTableStyles

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTableStyles

Packages that use XSLFTableStyles
org.apache.poi.xslf.usermodel

Uses of XSLFTableStyles in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTableStyles
 XSLFTableStyles XMLSlideShow.getTableStyles()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTextBox

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTextBox

Packages that use XSLFTextBox
org.apache.poi.xslf.usermodel

Uses of XSLFTextBox in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTextBox
XSLFTextBox | XSLFSheet.createTextBox()
XSLFTextBox | XSLFShapeContainer.createTextBox() create a text box
XSLFTextBox | XSLFGroupShape.createTextBox()
XSLFTextBox | XSLFDrawing.createTextBox()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTextParagraph

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTextParagraph

Packages that use XSLFTextParagraph
org.apache.poi.xslf.usermodel

Uses of XSLFTextParagraph in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTextParagraph
 XSLFTextParagraph XSLFTextShape.addNewTextParagraph()
add a new paragraph run to this shape

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type XSLFTextParagraph
java.util.List<XSLFTextParagraph> | XSLFTextShape.getTextParagraphs()
java.util.Iterator<XSLFTextParagraph> | XSLFTextShape.iterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTextRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTextRun

Packages that use XSLFTextRun
org.apache.poi.xslf.usermodel

Uses of XSLFTextRun in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTextRun
XSLFTextRun | XSLFTextParagraph.addLineBreak() Insert a line break
XSLFTextRun | XSLFTextParagraph.addNewTextRun() Add a new run of text

Methods in org.apache.poi.xslf.usermodel that return types with arguments of type XSLFTextRun
java.util.List<XSLFTextRun> | XSLFTextParagraph.getTextRuns()
java.util.Iterator<XSLFTextRun> | XSLFTextParagraph.iterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTextShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTextShape

Packages that use XSLFTextShape
org.apache.poi.xslf.usermodel

Uses of XSLFTextShape in org.apache.poi.xslf.usermodel

Subclasses of XSLFTextShape in org.apache.poi.xslf.usermodel
class | XSLFAutoShape Represents a shape with a preset geometry.
class | XSLFFreeformShape Represents a custom geometric shape.
class | XSLFTableCell Represents a cell of a table in a .pptx presentation
class | XSLFTextBox

Methods in org.apache.poi.xslf.usermodel that return XSLFTextShape
XSLFTextShape | XSLFSheet.getPlaceholder(int idx)
XSLFTextShape[] | XSLFSheet.getPlaceholders()
protected XSLFTextShape | XSLFSheet.getTextShapeByType(Placeholder type)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xslf.usermodel.XSLFTheme

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.usermodel.XSLFTheme

Packages that use XSLFTheme
org.apache.poi.xslf.usermodel

Uses of XSLFTheme in org.apache.poi.xslf.usermodel

Methods in org.apache.poi.xslf.usermodel that return XSLFTheme
XSLFTheme | XSLFSlideMaster.getTheme()
XSLFTheme | XSLFSlideLayout.getTheme()
XSLFTheme | XSLFSlide.getTheme()

Constructors in org.apache.poi.xslf.usermodel with parameters of type XSLFTheme
XSLFColor(org.apache.xmlbeans.XmlObject obj, XSLFTheme theme, org.openxmlformats.schemas.drawingml.x2006.main.CTSchemeColor phClr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xslf.util
Classes
PPTX2PNG


org.apache.poi.xslf.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xslf.util

Class Summary
PPTX2PNG An utulity to convert slides of a .pptx slide show to a PNG image


org.apache.poi.xslf.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xslf.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xslf.util.PPTX2PNG


Uses of Package org.apache.poi.xslf.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xslf.util

No usage of org.apache.poi.xslf.util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PPTX2PNG

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xslf.util
Class PPTX2PNG

java.lang.Object
    extended by  org.apache.poi.xslf.util.PPTX2PNG

public class PPTX2PNG
extends java.lang.Object

An utulity to convert slides of a .pptx slide show to a PNG image

Author:
Yegor Kozlov

Constructor Summary
PPTX2PNG()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PPTX2PNG

public PPTX2PNG()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xslf.util.PPTX2PNG

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xslf.util.PPTX2PNG

No usage of org.apache.poi.xslf.util.PPTX2PNG

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xssf.dev
Classes
XSSFDump
XSSFSave


org.apache.poi.xssf.dev

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.dev

Class Summary
XSSFDump | Utility class which dumps the contents of a *.xlsx file into file system.
XSSFSave | Utility which loads a SpreadsheetML file and saves it back.


org.apache.poi.xssf.dev Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.dev

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xssf.dev.XSSFDump
    • org.apache.poi.xssf.dev.XSSFSave


Uses of Package org.apache.poi.xssf.dev

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.dev

No usage of org.apache.poi.xssf.dev

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSSFDump

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.dev
Class XSSFDump

java.lang.Object
    extended by  org.apache.poi.xssf.dev.XSSFDump

public final class XSSFDump
extends java.lang.Object

Utility class which dumps the contents of a *.xlsx file into file system.

Author:
Yegor Kozlov

Constructor Summary
XSSFDump()
Method Summary
protected static void | dump(java.io.InputStream is, java.io.OutputStream out)
static void | dump(java.util.zip.ZipFile zip)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFDump

public XSSFDump()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

dump

public static void dump(java.util.zip.ZipFile zip)
                 throws java.lang.Exception
Throws:
java.lang.Exception

dump

protected static void dump(java.io.InputStream is,
                           java.io.OutputStream out)
                    throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XSSFSave

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.dev
Class XSSFSave

java.lang.Object
    extended by  org.apache.poi.xssf.dev.XSSFSave

public final class XSSFSave
extends java.lang.Object

Utility which loads a SpreadsheetML file and saves it back. This is a handy tool to investigate read-write round trip safety.

Author:
Yegor Kozlov

Constructor Summary
XSSFSave()
Method Summary
static void main(java.lang.String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFSave

public XSSFSave()
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.dev.XSSFDump

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.dev.XSSFDump

No usage of org.apache.poi.xssf.dev.XSSFDump

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.dev.XSSFSave

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.dev.XSSFSave

No usage of org.apache.poi.xssf.dev.XSSFSave

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xssf.eventusermodel
Interfaces
XSSFSheetXMLHandler.SheetContentsHandler
Classes
ReadOnlySharedStringsTable
XSSFReader
XSSFReader.SheetIterator
XSSFSheetXMLHandler


org.apache.poi.xssf.eventusermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.eventusermodel

Interface Summary
XSSFSheetXMLHandler.SheetContentsHandler You need to implement this to handle the results of the sheet parsing.

Class Summary
ReadOnlySharedStringsTable | This is a lightweight way to process the Shared Strings table.
XSSFReader | This class makes it easy to get at individual parts of an OOXML .xlsx file, suitable for low memory sax parsing or similar.
XSSFReader.SheetIterator | Iterator over sheet data.
XSSFSheetXMLHandler | This class handles the processing of a sheet#.xml sheet part of a XSSF .xlsx file, and generates row and cell events for it.


org.apache.poi.xssf.eventusermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.eventusermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
      • org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler
    • org.apache.poi.xssf.eventusermodel.XSSFReader
    • org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator (implements java.util.Iterator<E>)

Interface Hierarchy

  • org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler


Uses of Package org.apache.poi.xssf.eventusermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.eventusermodel

Packages that use org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.extractor

Classes in org.apache.poi.xssf.eventusermodel used by org.apache.poi.xssf.eventusermodel
ReadOnlySharedStringsTable
This is a lightweight way to process the Shared Strings table.
XSSFSheetXMLHandler.SheetContentsHandler
You need to implement this to handle the results of the sheet parsing.

Classes in org.apache.poi.xssf.eventusermodel used by org.apache.poi.xssf.extractor
ReadOnlySharedStringsTable
This is a lightweight way to process the Shared Strings table.
XSSFSheetXMLHandler.SheetContentsHandler
You need to implement this to handle the results of the sheet parsing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ReadOnlySharedStringsTable

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.eventusermodel
Class ReadOnlySharedStringsTable

java.lang.Object
    extended by  org.xml.sax.helpers.DefaultHandler
        extended by  org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable
All Implemented Interfaces:
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class ReadOnlySharedStringsTable
extends org.xml.sax.helpers.DefaultHandler

This is a lightweight way to process the Shared Strings table. Most of the text cells will reference something from in here.

Note that each SI entry can have multiple T elements, if the string is made up of bits with different formatting.

Example input:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<sst xmlns="http://schemas.openxmlformats.org/spreadsheetml/2006/main" count="2" uniqueCount="2">
 <si>
   <r>
     <rPr>
       <b />
       <sz val="11" />
       <color theme="1" />
       <rFont val="Calibri" />
       <family val="2" />
       <scheme val="minor" />
     </rPr>
     <t>This:</t>
   </r>
   <r>
     <rPr>
       <sz val="11" />
       <color theme="1" />
       <rFont val="Calibri" />
       <family val="2" />
       <scheme val="minor" />
     </rPr>
     <t xml:space="preserve">Causes Problems</t>
   </r>
 </si>
 <si>
   <t>This does not</t>
 </si>
</sst>

Constructor Summary
ReadOnlySharedStringsTable(OPCPackage pkg)
ReadOnlySharedStringsTable(PackagePart part, PackageRelationship rel_ignored)
Like POIXMLDocumentPart constructor
Method Summary
void | characters(char[] ch, int start, int length) Captures characters only if a t(ext) element is open.
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String name)
int | getCount() Return an integer representing the total count of strings in the workbook.
java.lang.String | getEntryAt(int idx) Return the string at a given index.
java.util.List<java.lang.String> | getItems()
int | getUniqueCount() Returns an integer representing the total count of unique strings in the Shared String Table.
void | readFrom(java.io.InputStream is) Read this shared strings table from an XML file.
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String name, org.xml.sax.Attributes attributes)
Methods inherited from class org.xml.sax.helpers.DefaultHandler
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReadOnlySharedStringsTable

public ReadOnlySharedStringsTable(OPCPackage pkg)
                           throws java.io.IOException,
                                  org.xml.sax.SAXException
Parameters:
pkg -
Throws:
java.io.IOException
org.xml.sax.SAXException
javax.xml.parsers.ParserConfigurationException

ReadOnlySharedStringsTable

public ReadOnlySharedStringsTable(PackagePart part,
                                  PackageRelationship rel_ignored)
                           throws java.io.IOException,
                                  org.xml.sax.SAXException
Like POIXMLDocumentPart constructor

Parameters:
part -
rel_ignored -
Throws:
java.io.IOException
org.xml.sax.SAXException
Method Detail

readFrom

public void readFrom(java.io.InputStream is)
              throws java.io.IOException,
                     org.xml.sax.SAXException
Read this shared strings table from an XML file.

Parameters:
is - The input stream containing the XML document.
Throws:
java.io.IOException - if an error occurs while reading.
org.xml.sax.SAXException
javax.xml.parsers.ParserConfigurationException

getCount

public int getCount()
Return an integer representing the total count of strings in the workbook. This count does not include any numbers, it counts only the total of text strings in the workbook.

Returns:
the total count of strings in the workbook

getUniqueCount

public int getUniqueCount()
Returns an integer representing the total count of unique strings in the Shared String Table. A string is unique even if it is a copy of another string, but has different formatting applied at the character level.

Returns:
the total count of unique strings in the workbook

getEntryAt

public java.lang.String getEntryAt(int idx)
Return the string at a given index. Formatting is ignored.

Parameters:
idx - index of item to return.
Returns:
the item at the specified position in this Shared String table.

getItems

public java.util.List<java.lang.String> getItems()

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String name,
                         org.xml.sax.Attributes attributes)
                  throws org.xml.sax.SAXException
Specified by:
startElement in interface org.xml.sax.ContentHandler
Overrides:
startElement in class org.xml.sax.helpers.DefaultHandler
Throws:
org.xml.sax.SAXException

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String name)
                throws org.xml.sax.SAXException
Specified by:
endElement in interface org.xml.sax.ContentHandler
Overrides:
endElement in class org.xml.sax.helpers.DefaultHandler
Throws:
org.xml.sax.SAXException

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws org.xml.sax.SAXException
Captures characters only if a t(ext) element is open.

Specified by:
characters in interface org.xml.sax.ContentHandler
Overrides:
characters in class org.xml.sax.helpers.DefaultHandler
Throws:
org.xml.sax.SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XSSFReader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.eventusermodel
Class XSSFReader

java.lang.Object
    extended by  org.apache.poi.xssf.eventusermodel.XSSFReader

public class XSSFReader
extends java.lang.Object

This class makes it easy to get at individual parts of an OOXML .xlsx file, suitable for low memory sax parsing or similar. It makes up the core part of the EventUserModel support for XSSF.

Nested Class Summary
static class XSSFReader.SheetIterator
Iterator over sheet data.
Constructor Summary
XSSFReader(OPCPackage pkg)
Creates a new XSSFReader, for the given package
Method Summary
java.io.InputStream | getSharedStringsData() Returns an InputStream to read the contents of the shared strings table.
SharedStringsTable | getSharedStringsTable() Opens up the Shared Strings Table, parses it, and returns a handy object for working with shared strings.
java.io.InputStream | getSheet(java.lang.String relId) Returns an InputStream to read the contents of the specified Sheet.
java.util.Iterator<java.io.InputStream> | getSheetsData() Returns an Iterator which will let you get at all the different Sheets in turn.
java.io.InputStream | getStylesData() Returns an InputStream to read the contents of the styles table.
StylesTable | getStylesTable() Opens up the Styles Table, parses it, and returns a handy object for working with cell styles
java.io.InputStream | getThemesData() Returns an InputStream to read the contents of the themes table.
java.io.InputStream | getWorkbookData() Returns an InputStream to read the contents of the main Workbook, which contains key overall data for the file, including sheet definitions.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFReader

public XSSFReader(OPCPackage pkg)
           throws java.io.IOException,
                  OpenXML4JException
Creates a new XSSFReader, for the given package

Throws:
java.io.IOException
OpenXML4JException
Method Detail

getSharedStringsTable

public SharedStringsTable getSharedStringsTable()
                                         throws java.io.IOException,
                                                InvalidFormatException
Opens up the Shared Strings Table, parses it, and returns a handy object for working with shared strings.

Throws:
java.io.IOException
InvalidFormatException

getStylesTable

public StylesTable getStylesTable()
                           throws java.io.IOException,
                                  InvalidFormatException
Opens up the Styles Table, parses it, and returns a handy object for working with cell styles

Throws:
java.io.IOException
InvalidFormatException

getSharedStringsData

public java.io.InputStream getSharedStringsData()
                                         throws java.io.IOException,
                                                InvalidFormatException
Returns an InputStream to read the contents of the shared strings table.

Throws:
java.io.IOException
InvalidFormatException

getStylesData

public java.io.InputStream getStylesData()
                                  throws java.io.IOException,
                                         InvalidFormatException
Returns an InputStream to read the contents of the styles table.

Throws:
java.io.IOException
InvalidFormatException

getThemesData

public java.io.InputStream getThemesData()
                                  throws java.io.IOException,
                                         InvalidFormatException
Returns an InputStream to read the contents of the themes table.

Throws:
java.io.IOException
InvalidFormatException

getWorkbookData

public java.io.InputStream getWorkbookData()
                                    throws java.io.IOException,
                                           InvalidFormatException
Returns an InputStream to read the contents of the main Workbook, which contains key overall data for the file, including sheet definitions.

Throws:
java.io.IOException
InvalidFormatException

getSheet

public java.io.InputStream getSheet(java.lang.String relId)
                             throws java.io.IOException,
                                    InvalidFormatException
Returns an InputStream to read the contents of the specified Sheet.

Parameters:
relId - The relationId of the sheet, from a r:id on the workbook
Throws:
java.io.IOException
InvalidFormatException

getSheetsData

public java.util.Iterator<java.io.InputStream> getSheetsData()
                                                      throws java.io.IOException,
                                                             InvalidFormatException
Returns an Iterator which will let you get at all the different Sheets in turn. Each sheet's InputStream is only opened when fetched from the Iterator. It's up to you to close the InputStreams when done with each one.

Throws:
java.io.IOException
InvalidFormatException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFReader.SheetIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.eventusermodel
Class XSSFReader.SheetIterator

java.lang.Object
    extended by  org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator
All Implemented Interfaces:
java.util.Iterator<java.io.InputStream>
Enclosing class:
XSSFReader
public static class XSSFReader.SheetIterator
extends java.lang.Object
implements java.util.Iterator<java.io.InputStream>

Iterator over sheet data.

Method Summary
CommentsTable | getSheetComments() Returns the comments associated with this sheet, or null if there aren't any
java.lang.String | getSheetName() Returns name of the current sheet
PackagePart | getSheetPart()
boolean | hasNext() Returns true if the iteration has more elements.
java.io.InputStream | next() Returns input stream of the next sheet in the iteration
void | remove() We're read only, so remove isn't supported
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

hasNext

public boolean hasNext()
Returns true if the iteration has more elements.

Specified by:
hasNext in interface java.util.Iterator<java.io.InputStream>
Returns:
true if the iterator has more elements.

next

public java.io.InputStream next()
Returns input stream of the next sheet in the iteration

Specified by:
next in interface java.util.Iterator<java.io.InputStream>
Returns:
input stream of the next sheet in the iteration

getSheetName

public java.lang.String getSheetName()
Returns name of the current sheet

Returns:
name of the current sheet

getSheetComments

public CommentsTable getSheetComments()
Returns the comments associated with this sheet, or null if there aren't any

getSheetPart

public PackagePart getSheetPart()

remove

public void remove()
We're read only, so remove isn't supported

Specified by:
remove in interface java.util.Iterator<java.io.InputStream>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFSheetXMLHandler

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.eventusermodel
Class XSSFSheetXMLHandler

java.lang.Object
    extended by  org.xml.sax.helpers.DefaultHandler
        extended by  org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler
All Implemented Interfaces:
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class XSSFSheetXMLHandler
extends org.xml.sax.helpers.DefaultHandler

This class handles the processing of a sheet#.xml sheet part of a XSSF .xlsx file, and generates row and cell events for it.

Nested Class Summary
static interface XSSFSheetXMLHandler.SheetContentsHandler
You need to implement this to handle the results of the sheet parsing.
Constructor Summary
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, boolean formulasNotResults)
Accepts objects needed while parsing.
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, DataFormatter dataFormatter, boolean formulasNotResults)
Accepts objects needed while parsing.
Method Summary
void | characters(char[] ch, int start, int length) Captures characters only if a suitable element is open.
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String name)
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String name, org.xml.sax.Attributes attributes)
Methods inherited from class org.xml.sax.helpers.DefaultHandler
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFSheetXMLHandler

public XSSFSheetXMLHandler(StylesTable styles,
                           ReadOnlySharedStringsTable strings,
                           XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler,
                           DataFormatter dataFormatter,
                           boolean formulasNotResults)
Accepts objects needed while parsing.

Parameters:
styles - Table of styles
strings - Table of shared strings

XSSFSheetXMLHandler

public XSSFSheetXMLHandler(StylesTable styles,
                           ReadOnlySharedStringsTable strings,
                           XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler,
                           boolean formulasNotResults)
Accepts objects needed while parsing.

Parameters:
styles - Table of styles
strings - Table of shared strings
Method Detail

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String name,
                         org.xml.sax.Attributes attributes)
                  throws org.xml.sax.SAXException
Specified by:
startElement in interface org.xml.sax.ContentHandler
Overrides:
startElement in class org.xml.sax.helpers.DefaultHandler
Throws:
org.xml.sax.SAXException

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String name)
                throws org.xml.sax.SAXException
Specified by:
endElement in interface org.xml.sax.ContentHandler
Overrides:
endElement in class org.xml.sax.helpers.DefaultHandler
Throws:
org.xml.sax.SAXException

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws org.xml.sax.SAXException
Captures characters only if a suitable element is open. Originally was just "v"; extended for inlineStr also.

Specified by:
characters in interface org.xml.sax.ContentHandler
Overrides:
characters in class org.xml.sax.helpers.DefaultHandler
Throws:
org.xml.sax.SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFSheetXMLHandler.SheetContentsHandler

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.eventusermodel
Interface XSSFSheetXMLHandler.SheetContentsHandler

All Known Implementing Classes:
XSSFEventBasedExcelExtractor.SheetTextExtractor
Enclosing class:
XSSFSheetXMLHandler
public static interface XSSFSheetXMLHandler.SheetContentsHandler

You need to implement this to handle the results of the sheet parsing.

Method Summary
void | cell(java.lang.String cellReference, java.lang.String formattedValue) A cell, with the given formatted value, was encountered
void | endRow() A row with the (zero based) row number has ended
void | headerFooter(java.lang.String text, boolean isHeader, java.lang.String tagName) A header or footer has been encountered
void | startRow(int rowNum) A row with the (zero based) row number has started

Method Detail

startRow

void startRow(int rowNum)
A row with the (zero based) row number has started

endRow

void endRow()
A row with the (zero based) row number has ended

cell

void cell(java.lang.String cellReference,
          java.lang.String formattedValue)
A cell, with the given formatted value, was encountered

headerFooter

void headerFooter(java.lang.String text,
                  boolean isHeader,
                  java.lang.String tagName)
A header or footer has been encountered

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.eventusermodel.ReadOnlySharedStringsTable

Packages that use ReadOnlySharedStringsTable
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.extractor

Uses of ReadOnlySharedStringsTable in org.apache.poi.xssf.eventusermodel

Constructors in org.apache.poi.xssf.eventusermodel with parameters of type ReadOnlySharedStringsTable
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, boolean formulasNotResults)
Accepts objects needed while parsing.
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, DataFormatter dataFormatter, boolean formulasNotResults)
Accepts objects needed while parsing.

Uses of ReadOnlySharedStringsTable in org.apache.poi.xssf.extractor

Methods in org.apache.poi.xssf.extractor with parameters of type ReadOnlySharedStringsTable
 void XSSFEventBasedExcelExtractor.processSheet(XSSFSheetXMLHandler.SheetContentsHandler sheetContentsExtractor, StylesTable styles, ReadOnlySharedStringsTable strings, java.io.InputStream sheetInputStream)
Processes the given sheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.eventusermodel.XSSFReader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.eventusermodel.XSSFReader

No usage of org.apache.poi.xssf.eventusermodel.XSSFReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator

No usage of org.apache.poi.xssf.eventusermodel.XSSFReader.SheetIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler

No usage of org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler

Packages that use XSSFSheetXMLHandler.SheetContentsHandler
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.extractor

Uses of XSSFSheetXMLHandler.SheetContentsHandler in org.apache.poi.xssf.eventusermodel

Constructors in org.apache.poi.xssf.eventusermodel with parameters of type XSSFSheetXMLHandler.SheetContentsHandler
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, boolean formulasNotResults)
Accepts objects needed while parsing.
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, DataFormatter dataFormatter, boolean formulasNotResults)
Accepts objects needed while parsing.

Uses of XSSFSheetXMLHandler.SheetContentsHandler in org.apache.poi.xssf.extractor

Classes in org.apache.poi.xssf.extractor that implement XSSFSheetXMLHandler.SheetContentsHandler
protected  class XSSFEventBasedExcelExtractor.SheetTextExtractor

Methods in org.apache.poi.xssf.extractor with parameters of type XSSFSheetXMLHandler.SheetContentsHandler
 void XSSFEventBasedExcelExtractor.processSheet(XSSFSheetXMLHandler.SheetContentsHandler sheetContentsExtractor, StylesTable styles, ReadOnlySharedStringsTable strings, java.io.InputStream sheetInputStream)
Processes the given sheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xssf.extractor
Classes
XSSFEventBasedExcelExtractor
XSSFExcelExtractor
XSSFExportToXml
XSSFImportFromXML


org.apache.poi.xssf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.extractor

Class Summary
XSSFEventBasedExcelExtractor | Implementation of a text extractor from OOXML Excel files that uses SAX event based parsing.
XSSFExcelExtractor | Helper class to extract text from an OOXML Excel file
XSSFExportToXml | Maps an XLSX to an XML according to one of the mapping defined.
XSSFImportFromXML | Imports data from an external XML to an XLSX according to one of the mappings defined.The output XML Schema must respect this limitations: the input XML must be valid according to the XML Schema used in the mapping denormalized table mapping is not supported (see OpenOffice part 4: chapter 3.5.1.7) all the namespaces used in the document must be declared in the root node


org.apache.poi.xssf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIXMLTextExtractor
        • org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor
        • org.apache.poi.xssf.extractor.XSSFExcelExtractor (implements org.apache.poi.ss.extractor.ExcelExtractor)
    • org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor (implements org.apache.poi.xssf.eventusermodel.XSSFSheetXMLHandler.SheetContentsHandler)
    • org.apache.poi.xssf.extractor.XSSFExportToXml (implements java.util.Comparator<T>)
    • org.apache.poi.xssf.extractor.XSSFImportFromXML


Uses of Package org.apache.poi.xssf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.extractor

No usage of org.apache.poi.xssf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSSFEventBasedExcelExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.extractor
Class XSSFEventBasedExcelExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIXMLTextExtractor
            extended by  org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

public class XSSFEventBasedExcelExtractor
extends POIXMLTextExtractor

Implementation of a text extractor from OOXML Excel files that uses SAX event based parsing.

Nested Class Summary
protected  class XSSFEventBasedExcelExtractor.SheetTextExtractor
Field Summary
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
XSSFEventBasedExcelExtractor(OPCPackage container)
XSSFEventBasedExcelExtractor(java.lang.String path)
Method Summary
POIXMLProperties.CoreProperties | getCoreProperties() Returns the core document properties
POIXMLProperties.CustomProperties | getCustomProperties() Returns the custom document properties
POIXMLProperties.ExtendedProperties | getExtendedProperties() Returns the extended document properties
OPCPackage | getPackage() Returns the opened OPCPackage container.
java.lang.String | getText() Processes the file and returns the text
static void | main(java.lang.String[] args)
void | processSheet(XSSFSheetXMLHandler.SheetContentsHandler sheetContentsExtractor, StylesTable styles, ReadOnlySharedStringsTable strings, java.io.InputStream sheetInputStream) Processes the given sheet
void | setFormulasNotResults(boolean formulasNotResults) Should we return the formula itself, and not the result it produces? Default is false
void | setIncludeSheetNames(boolean includeSheetNames) Should sheet names be included? Default is true
void | setLocale(java.util.Locale locale)
Methods inherited from class org.apache.poi.POIXMLTextExtractor
getDocument, getMetadataTextExtractor
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFEventBasedExcelExtractor

public XSSFEventBasedExcelExtractor(java.lang.String path)
                             throws org.apache.xmlbeans.XmlException,
                                    OpenXML4JException,
                                    java.io.IOException
Throws:
org.apache.xmlbeans.XmlException
OpenXML4JException
java.io.IOException

XSSFEventBasedExcelExtractor

public XSSFEventBasedExcelExtractor(OPCPackage container)
                             throws org.apache.xmlbeans.XmlException,
                                    OpenXML4JException,
                                    java.io.IOException
Throws:
org.apache.xmlbeans.XmlException
OpenXML4JException
java.io.IOException
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

setIncludeSheetNames

public void setIncludeSheetNames(boolean includeSheetNames)
Should sheet names be included? Default is true

setFormulasNotResults

public void setFormulasNotResults(boolean formulasNotResults)
Should we return the formula itself, and not the result it produces? Default is false

setLocale

public void setLocale(java.util.Locale locale)

getPackage

public OPCPackage getPackage()
Returns the opened OPCPackage container.

Overrides:
getPackage in class POIXMLTextExtractor

getCoreProperties

public POIXMLProperties.CoreProperties getCoreProperties()
Returns the core document properties

Overrides:
getCoreProperties in class POIXMLTextExtractor

getExtendedProperties

public POIXMLProperties.ExtendedProperties getExtendedProperties()
Returns the extended document properties

Overrides:
getExtendedProperties in class POIXMLTextExtractor

getCustomProperties

public POIXMLProperties.CustomProperties getCustomProperties()
Returns the custom document properties

Overrides:
getCustomProperties in class POIXMLTextExtractor

processSheet

public void processSheet(XSSFSheetXMLHandler.SheetContentsHandler sheetContentsExtractor,
                         StylesTable styles,
                         ReadOnlySharedStringsTable strings,
                         java.io.InputStream sheetInputStream)
                  throws java.io.IOException,
                         org.xml.sax.SAXException
Processes the given sheet

Throws:
java.io.IOException
org.xml.sax.SAXException

getText

public java.lang.String getText()
Processes the file and returns the text

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XSSFEventBasedExcelExtractor.SheetTextExtractor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.extractor
Class XSSFEventBasedExcelExtractor.SheetTextExtractor

java.lang.Object
    extended by  org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor
All Implemented Interfaces:
XSSFSheetXMLHandler.SheetContentsHandler
Enclosing class:
XSSFEventBasedExcelExtractor
protected class XSSFEventBasedExcelExtractor.SheetTextExtractor
extends java.lang.Object
implements XSSFSheetXMLHandler.SheetContentsHandler

Constructor Summary
protected XSSFEventBasedExcelExtractor.SheetTextExtractor(java.lang.StringBuffer output)
Method Summary
void | cell(java.lang.String cellRef, java.lang.String formattedValue) A cell, with the given formatted value, was encountered
void | endRow() A row with the (zero based) row number has ended
void | headerFooter(java.lang.String text, boolean isHeader, java.lang.String tagName) A header or footer has been encountered
void | startRow(int rowNum) A row with the (zero based) row number has started
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFEventBasedExcelExtractor.SheetTextExtractor

protected XSSFEventBasedExcelExtractor.SheetTextExtractor(java.lang.StringBuffer output)
Method Detail

startRow

public void startRow(int rowNum)
Description copied from interface: XSSFSheetXMLHandler.SheetContentsHandler
A row with the (zero based) row number has started

Specified by:
startRow in interface XSSFSheetXMLHandler.SheetContentsHandler

endRow

public void endRow()
Description copied from interface: XSSFSheetXMLHandler.SheetContentsHandler
A row with the (zero based) row number has ended

Specified by:
endRow in interface XSSFSheetXMLHandler.SheetContentsHandler

cell

public void cell(java.lang.String cellRef,
                 java.lang.String formattedValue)
Description copied from interface: XSSFSheetXMLHandler.SheetContentsHandler
A cell, with the given formatted value, was encountered

Specified by:
cell in interface XSSFSheetXMLHandler.SheetContentsHandler

headerFooter

public void headerFooter(java.lang.String text,
                         boolean isHeader,
                         java.lang.String tagName)
Description copied from interface: XSSFSheetXMLHandler.SheetContentsHandler
A header or footer has been encountered

Specified by:
headerFooter in interface XSSFSheetXMLHandler.SheetContentsHandler
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFExcelExtractor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.extractor
Class XSSFExcelExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIXMLTextExtractor
            extended by  org.apache.poi.xssf.extractor.XSSFExcelExtractor
All Implemented Interfaces:
ExcelExtractor
public class XSSFExcelExtractor
extends POIXMLTextExtractor
implements ExcelExtractor

Helper class to extract text from an OOXML Excel file

Field Summary
static XSSFRelation[] SUPPORTED_TYPES
Fields inherited from class org.apache.poi.POITextExtractor
document
Constructor Summary
XSSFExcelExtractor(OPCPackage container)
XSSFExcelExtractor(java.lang.String path)
Deprecated. Use XSSFExcelExtractor(org.apache.poi.openxml4j.opc.OPCPackage) instead.
XSSFExcelExtractor(XSSFWorkbook workbook)
Method Summary
java.lang.String | getText() Retreives the text contents of the file
static void | main(java.lang.String[] args)
void | setFormulasNotResults(boolean formulasNotResults) Should we return the formula itself, and not the result it produces? Default is false
void | setIncludeCellComments(boolean includeCellComments) Should cell comments be included? Default is true
void | setIncludeHeadersFooters(boolean includeHeadersFooters) Should headers and footers be included? Default is true
void | setIncludeSheetNames(boolean includeSheetNames) Should sheet names be included? Default is true
void | setLocale(java.util.Locale locale) What Locale should be used for formatting numbers (based on the styles applied to the cells)
Methods inherited from class org.apache.poi.POIXMLTextExtractor
getCoreProperties, getCustomProperties, getDocument, getExtendedProperties, getMetadataTextExtractor, getPackage
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SUPPORTED_TYPES

public static final XSSFRelation[] SUPPORTED_TYPES
Constructor Detail

XSSFExcelExtractor

public XSSFExcelExtractor(java.lang.String path)
                   throws org.apache.xmlbeans.XmlException,
                          OpenXML4JException,
                          java.io.IOException
Deprecated. Use XSSFExcelExtractor(org.apache.poi.openxml4j.opc.OPCPackage) instead.

Throws:
org.apache.xmlbeans.XmlException
OpenXML4JException
java.io.IOException

XSSFExcelExtractor

public XSSFExcelExtractor(OPCPackage container)
                   throws org.apache.xmlbeans.XmlException,
                          OpenXML4JException,
                          java.io.IOException
Throws:
org.apache.xmlbeans.XmlException
OpenXML4JException
java.io.IOException

XSSFExcelExtractor

public XSSFExcelExtractor(XSSFWorkbook workbook)
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

setIncludeSheetNames

public void setIncludeSheetNames(boolean includeSheetNames)
Should sheet names be included? Default is true

Specified by:
setIncludeSheetNames in interface ExcelExtractor

setFormulasNotResults

public void setFormulasNotResults(boolean formulasNotResults)
Should we return the formula itself, and not the result it produces? Default is false

Specified by:
setFormulasNotResults in interface ExcelExtractor

setIncludeCellComments

public void setIncludeCellComments(boolean includeCellComments)
Should cell comments be included? Default is true

Specified by:
setIncludeCellComments in interface ExcelExtractor

setIncludeHeadersFooters

public void setIncludeHeadersFooters(boolean includeHeadersFooters)
Should headers and footers be included? Default is true

setLocale

public void setLocale(java.util.Locale locale)
What Locale should be used for formatting numbers (based on the styles applied to the cells)

getText

public java.lang.String getText()
Retreives the text contents of the file

Specified by:
getText in interface ExcelExtractor
Specified by:
getText in class POITextExtractor
Returns:
All the text from the document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFExportToXml

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.extractor
Class XSSFExportToXml

java.lang.Object
    extended by  org.apache.poi.xssf.extractor.XSSFExportToXml
All Implemented Interfaces:
java.util.Comparator<java.lang.String>
public class XSSFExportToXml
extends java.lang.Object
implements java.util.Comparator<java.lang.String>

Maps an XLSX to an XML according to one of the mapping defined. The output XML Schema must respect this limitations:

  • all mandatory elements and attributes must be mapped (enable validation to check this)
  • no <any> in complex type/element declaration
  • no <anyAttribute> attributes declaration
  • no recursive structures: recursive structures can't be nested more than one level
  • no abstract elements: abstract complex types can be declared but must not be used in elements.
  • no mixed content: an element can't contain simple text and child element(s) together
  • no <substitutionGroup> in complex type/element declaration

Constructor Summary
XSSFExportToXml(XSSFMap map)
Creates a new exporter and sets the mapping to be used when generating the XML output document
Method Summary
int | compare(java.lang.String leftXpath, java.lang.String rightXpath) Compares two xpaths to define an ordering according to the XML Schema
void | exportToXML(java.io.OutputStream os, boolean validate) Exports the data in an XML stream
void | exportToXML(java.io.OutputStream os, java.lang.String encoding, boolean validate) Exports the data in an XML stream
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

XSSFExportToXml

public XSSFExportToXml(XSSFMap map)
Creates a new exporter and sets the mapping to be used when generating the XML output document

Parameters:
map - the mapping rule to be used
Method Detail

exportToXML

public void exportToXML(java.io.OutputStream os,
                        boolean validate)
                 throws org.xml.sax.SAXException,
                        javax.xml.parsers.ParserConfigurationException,
                        javax.xml.transform.TransformerException
Exports the data in an XML stream

Parameters:
os - OutputStream in which will contain the output XML
validate - if true, validates the XML againts the XML Schema
Throws:
org.xml.sax.SAXException
javax.xml.transform.TransformerException
javax.xml.parsers.ParserConfigurationException

exportToXML

public void exportToXML(java.io.OutputStream os,
                        java.lang.String encoding,
                        boolean validate)
                 throws org.xml.sax.SAXException,
                        javax.xml.parsers.ParserConfigurationException,
                        javax.xml.transform.TransformerException
Exports the data in an XML stream

Parameters:
os - OutputStream in which will contain the output XML
encoding - the output charset encoding
validate - if true, validates the XML againts the XML Schema
Throws:
org.xml.sax.SAXException
javax.xml.parsers.ParserConfigurationException
javax.xml.transform.TransformerException
InvalidFormatException

compare

public int compare(java.lang.String leftXpath,
                   java.lang.String rightXpath)
Compares two xpaths to define an ordering according to the XML Schema

Specified by:
compare in interface java.util.Comparator<java.lang.String>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFImportFromXML

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.extractor
Class XSSFImportFromXML

java.lang.Object
    extended by  org.apache.poi.xssf.extractor.XSSFImportFromXML

public class XSSFImportFromXML
extends java.lang.Object

Imports data from an external XML to an XLSX according to one of the mappings defined.The output XML Schema must respect this limitations:

  • the input XML must be valid according to the XML Schema used in the mapping
  • denormalized table mapping is not supported (see OpenOffice part 4: chapter 3.5.1.7)
  • all the namespaces used in the document must be declared in the root node

Constructor Summary
XSSFImportFromXML(XSSFMap map)
Method Summary
 void importFromXML(java.lang.String xmlInputString)
Imports an XML into the XLSX using the Custom XML mapping defined
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFImportFromXML

public XSSFImportFromXML(XSSFMap map)
Method Detail

importFromXML

public void importFromXML(java.lang.String xmlInputString)
                   throws org.xml.sax.SAXException,
                          javax.xml.xpath.XPathExpressionException,
                          javax.xml.parsers.ParserConfigurationException,
                          java.io.IOException
Imports an XML into the XLSX using the Custom XML mapping defined

Parameters:
xmlInputString - the XML to import
Throws:
org.xml.sax.SAXException - if error occurs during XML parsing
javax.xml.xpath.XPathExpressionException - if error occurs during XML navigation
javax.xml.parsers.ParserConfigurationException - if there are problems with XML parser configuration
java.io.IOException - if there are problems reading the input string
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

No usage of org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

No usage of org.apache.poi.xssf.extractor.XSSFEventBasedExcelExtractor.SheetTextExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.extractor.XSSFExcelExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.extractor.XSSFExcelExtractor

No usage of org.apache.poi.xssf.extractor.XSSFExcelExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.extractor.XSSFExportToXml

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.extractor.XSSFExportToXml

No usage of org.apache.poi.xssf.extractor.XSSFExportToXml

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.extractor.XSSFImportFromXML

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.extractor.XSSFImportFromXML

No usage of org.apache.poi.xssf.extractor.XSSFImportFromXML

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CalculationChain

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class CalculationChain

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.model.CalculationChain

public class CalculationChain
extends POIXMLDocumentPart

The cells in a workbook can be calculated in different orders depending on various optimizations and dependencies. The calculation chain object specifies the order in which the cells in a workbook were last calculated.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
CalculationChain()
CalculationChain(PackagePart part, PackageRelationship rel)
Method Summary
protected void | commit() Save the content in the underlying package part.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCalcChain | getCTCalcChain()
void | readFrom(java.io.InputStream is)
void | removeItem(int sheetId, java.lang.String ref) Remove a formula reference from the calculation chain
void | writeTo(java.io.OutputStream out)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CalculationChain

public CalculationChain()

CalculationChain

public CalculationChain(PackagePart part,
                        PackageRelationship rel)
                 throws java.io.IOException
Throws:
java.io.IOException
Method Detail

readFrom

public void readFrom(java.io.InputStream is)
              throws java.io.IOException
Throws:
java.io.IOException

writeTo

public void writeTo(java.io.OutputStream out)
             throws java.io.IOException
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getCTCalcChain

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCalcChain getCTCalcChain()

removeItem

public void removeItem(int sheetId,
                       java.lang.String ref)
Remove a formula reference from the calculation chain

Parameters:
sheetId - the sheet Id of a sheet the formula belongs to.
ref - A1 style reference to the cell containing the formula.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CommentsTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class CommentsTable

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.model.CommentsTable

public class CommentsTable
extends POIXMLDocumentPart

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
CommentsTable()
CommentsTable(PackagePart part, PackageRelationship rel)
Method Summary
protected void | commit() Save the content in the underlying package part.
int | findAuthor(java.lang.String author)
XSSFComment | findCellComment(java.lang.String cellRef)
java.lang.String | getAuthor(long authorId)
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment | getCTComment(java.lang.String cellRef)
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComments | getCTComments()
int | getNumberOfAuthors()
int | getNumberOfComments()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment | newComment()
void | readFrom(java.io.InputStream is)
void | referenceUpdated(java.lang.String oldReference, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment comment) Called after the reference is updated, so that we can reflect that in our cache
boolean | removeComment(java.lang.String cellRef)
void | writeTo(java.io.OutputStream out)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CommentsTable

public CommentsTable()

CommentsTable

public CommentsTable(PackagePart part,
                     PackageRelationship rel)
              throws java.io.IOException
Throws:
java.io.IOException
Method Detail

readFrom

public void readFrom(java.io.InputStream is)
              throws java.io.IOException
Throws:
java.io.IOException

writeTo

public void writeTo(java.io.OutputStream out)
             throws java.io.IOException
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

referenceUpdated

public void referenceUpdated(java.lang.String oldReference,
                             org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment comment)
Called after the reference is updated, so that we can reflect that in our cache

getNumberOfComments

public int getNumberOfComments()

getNumberOfAuthors

public int getNumberOfAuthors()

getAuthor

public java.lang.String getAuthor(long authorId)

findAuthor

public int findAuthor(java.lang.String author)

findCellComment

public XSSFComment findCellComment(java.lang.String cellRef)

getCTComment

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment getCTComment(java.lang.String cellRef)

newComment

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment newComment()

removeComment

public boolean removeComment(java.lang.String cellRef)

getCTComments

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComments getCTComments()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexedUDFFinder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class IndexedUDFFinder

java.lang.Object
    extended by  org.apache.poi.ss.formula.udf.AggregatingUDFFinder
        extended by  org.apache.poi.xssf.model.IndexedUDFFinder
All Implemented Interfaces:
UDFFinder
@Internal
public final class IndexedUDFFinder
extends AggregatingUDFFinder

A UDFFinder that can retrieve functions both by name and by fake index.

Author:
Yegor Kozlov

Field Summary
Fields inherited from interface org.apache.poi.ss.formula.udf.UDFFinder
DEFAULT
Constructor Summary
IndexedUDFFinder(UDFFinder... usedToolPacks)
Method Summary
FreeRefFunction | findFunction(java.lang.String name) Returns executor by specified name.
int | getFunctionIndex(java.lang.String name)
java.lang.String | getFunctionName(int idx)
Methods inherited from class org.apache.poi.ss.formula.udf.AggregatingUDFFinder
add
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IndexedUDFFinder

public IndexedUDFFinder(UDFFinder... usedToolPacks)
Method Detail

findFunction

public FreeRefFunction findFunction(java.lang.String name)
Description copied from class: AggregatingUDFFinder
Returns executor by specified name. Returns null if function isn't contained by any registered tool pack.

Specified by:
findFunction in interface UDFFinder
Overrides:
findFunction in class AggregatingUDFFinder
Parameters:
name - Name of function.
Returns:
Function executor. null if not found

getFunctionName

public java.lang.String getFunctionName(int idx)

getFunctionIndex

public int getFunctionIndex(java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class MapInfo

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.model.MapInfo

public class MapInfo
extends POIXMLDocumentPart

This class implements the Custom XML Mapping Part (Open Office XML Part 1: chapter 12.3.6) An instance of this part type contains a schema for an XML file, and information on the behavior that is used when allowing this custom XML schema to be mapped into the spreadsheet.

Author:
Roberto Manicardi

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
MapInfo()
MapInfo(PackagePart part, PackageRelationship rel)
Method Summary
protected void | commit() Save the content in the underlying package part.
java.util.Collection<XSSFMap> | getAllXSSFMaps()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMapInfo | getCTMapInfo()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSchema | getCTSchemaById(java.lang.String schemaId) Gets the
XSSFWorkbook | getWorkbook() Returns the parent XSSFWorkbook
XSSFMap | getXSSFMapById(int id)
XSSFMap | getXSSFMapByName(java.lang.String name)
void | readFrom(java.io.InputStream is)
protected void | writeTo(java.io.OutputStream out)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MapInfo

public MapInfo()

MapInfo

public MapInfo(PackagePart part,
               PackageRelationship rel)
        throws java.io.IOException
Throws:
java.io.IOException
Method Detail

readFrom

public void readFrom(java.io.InputStream is)
              throws java.io.IOException
Throws:
java.io.IOException

getWorkbook

public XSSFWorkbook getWorkbook()
Returns the parent XSSFWorkbook

Returns:
the parent XSSFWorkbook

getCTMapInfo

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMapInfo getCTMapInfo()
Returns:
the internal data object

getCTSchemaById

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSchema getCTSchemaById(java.lang.String schemaId)
Gets the

Parameters:
schemaId - the schema ID
Returns:
CTSchema by it's ID

getXSSFMapById

public XSSFMap getXSSFMapById(int id)

getXSSFMapByName

public XSSFMap getXSSFMapByName(java.lang.String name)

getAllXSSFMaps

public java.util.Collection<XSSFMap> getAllXSSFMaps()
Returns:
all the mappings configured in this document

writeTo

protected void writeTo(java.io.OutputStream out)
                throws java.io.IOException
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.xssf.model
Classes
CalculationChain
CommentsTable
IndexedUDFFinder
MapInfo
SharedStringsTable
SingleXmlCells
StylesTable
ThemesTable


org.apache.poi.xssf.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.model

Class Summary
CalculationChain | The cells in a workbook can be calculated in different orders depending on various optimizations and dependencies.
CommentsTable |
IndexedUDFFinder | A UDFFinder that can retrieve functions both by name and by fake index.
MapInfo | This class implements the Custom XML Mapping Part (Open Office XML Part 1: chapter 12.3.6) An instance of this part type contains a schema for an XML file, and information on the behavior that is used when allowing this custom XML schema to be mapped into the spreadsheet.
SharedStringsTable | Table of strings shared across all sheets in a workbook.
SingleXmlCells | This class implements the Single Cell Tables Part (Open Office XML Part 4: chapter 3.5.2)
StylesTable | Table of styles shared across all sheets in a workbook.
ThemesTable | Class that represents theme of XLSX document.


org.apache.poi.xssf.model Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.ss.formula.udf.AggregatingUDFFinder (implements org.apache.poi.ss.formula.udf.UDFFinder)
      • org.apache.poi.xssf.model.IndexedUDFFinder
    • org.apache.poi.POIXMLDocumentPart
      • org.apache.poi.xssf.model.CalculationChain
      • org.apache.poi.xssf.model.CommentsTable
      • org.apache.poi.xssf.model.MapInfo
      • org.apache.poi.xssf.model.SharedStringsTable
      • org.apache.poi.xssf.model.SingleXmlCells
      • org.apache.poi.xssf.model.StylesTable
      • org.apache.poi.xssf.model.ThemesTable


Uses of Package org.apache.poi.xssf.model

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.model

Packages that use org.apache.poi.xssf.model
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.extractor
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions
org.apache.poi.xssf.usermodel.helpers

Classes in org.apache.poi.xssf.model used by org.apache.poi.xssf.eventusermodel
CommentsTable
SharedStringsTable
Table of strings shared across all sheets in a workbook.
StylesTable
Table of styles shared across all sheets in a workbook.

Classes in org.apache.poi.xssf.model used by org.apache.poi.xssf.extractor
StylesTable
Table of styles shared across all sheets in a workbook.

Classes in org.apache.poi.xssf.model used by org.apache.poi.xssf.model
ThemesTable
Class that represents theme of XLSX document.

Classes in org.apache.poi.xssf.model used by org.apache.poi.xssf.usermodel
CalculationChain
The cells in a workbook can be calculated in different orders depending on various optimizations and dependencies.
CommentsTable
MapInfo
This class implements the Custom XML Mapping Part (Open Office XML Part 1: chapter 12.3.6) An instance of this part type contains a schema for an XML file, and information on the behavior that is used when allowing this custom XML schema to be mapped into the spreadsheet.
SharedStringsTable
Table of strings shared across all sheets in a workbook.
StylesTable
Table of styles shared across all sheets in a workbook.
ThemesTable
Class that represents theme of XLSX document.

Classes in org.apache.poi.xssf.model used by org.apache.poi.xssf.usermodel.extensions
ThemesTable
Class that represents theme of XLSX document.

Classes in org.apache.poi.xssf.model used by org.apache.poi.xssf.usermodel.helpers
SingleXmlCells
This class implements the Single Cell Tables Part (Open Office XML Part 4: chapter 3.5.2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SharedStringsTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class SharedStringsTable

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.model.SharedStringsTable

public class SharedStringsTable
extends POIXMLDocumentPart

Table of strings shared across all sheets in a workbook.

A workbook may contain thousands of cells containing string (non-numeric) data. Furthermore this data is very likely to be repeated across many rows or columns. The goal of implementing a single string table that is shared across the workbook is to improve performance in opening and saving the file by only reading and writing the repetitive information once.

Consider for example a workbook summarizing information for cities within various countries. There may be a column for the name of the country, a column for the name of each city in that country, and a column containing the data for each city. In this case the country name is repetitive, being duplicated in many cells. In many cases the repetition is extensive, and a tremendous savings is realized by making use of a shared string table when saving the workbook. When displaying text in the spreadsheet, the cell table will just contain an index into the string table as the value of a cell, instead of the full string.

The shared string table contains all the necessary information for displaying the string: the text, formatting properties, and phonetic properties (for East Asian languages).

Author:
Nick Birch, Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
SharedStringsTable()
SharedStringsTable(PackagePart part, PackageRelationship rel)
Method Summary
int | addEntry(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst st) Add an entry to this Shared String table (a new value is appened to the end).
protected void | commit() Save the content in the underlying package part.
int | getCount() Return an integer representing the total count of strings in the workbook.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst | getEntryAt(int idx) Return a string item by index
java.util.List<org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst> | getItems() Provide low-level access to the underlying array of CTRst beans
int | getUniqueCount() Returns an integer representing the total count of unique strings in the Shared String Table.
void | readFrom(java.io.InputStream is) Read this shared strings table from an XML file.
void | writeTo(java.io.OutputStream out) Write this table out as XML.
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SharedStringsTable

public SharedStringsTable()

SharedStringsTable

public SharedStringsTable(PackagePart part,
                          PackageRelationship rel)
                   throws java.io.IOException
Throws:
java.io.IOException
Method Detail

readFrom

public void readFrom(java.io.InputStream is)
              throws java.io.IOException
Read this shared strings table from an XML file.

Parameters:
is - The input stream containing the XML document.
Throws:
java.io.IOException - if an error occurs while reading.

getEntryAt

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst getEntryAt(int idx)
Return a string item by index

Parameters:
idx - index of item to return.
Returns:
the item at the specified position in this Shared String table.

getCount

public int getCount()
Return an integer representing the total count of strings in the workbook. This count does not include any numbers, it counts only the total of text strings in the workbook.

Returns:
the total count of strings in the workbook

getUniqueCount

public int getUniqueCount()
Returns an integer representing the total count of unique strings in the Shared String Table. A string is unique even if it is a copy of another string, but has different formatting applied at the character level.

Returns:
the total count of unique strings in the workbook

addEntry

public int addEntry(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst st)
Add an entry to this Shared String table (a new value is appened to the end).

If the Shared String table already contains this CTRst bean, its index is returned. Otherwise a new entry is aded.

Parameters:
st - the entry to add
Returns:
index the index of added entry

getItems

public java.util.List<org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst> getItems()
Provide low-level access to the underlying array of CTRst beans

Returns:
array of CTRst beans

writeTo

public void writeTo(java.io.OutputStream out)
             throws java.io.IOException
Write this table out as XML.

Parameters:
out - The stream to write to.
Throws:
java.io.IOException - if an error occurs while writing.

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SingleXmlCells

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class SingleXmlCells

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.model.SingleXmlCells

public class SingleXmlCells
extends POIXMLDocumentPart

This class implements the Single Cell Tables Part (Open Office XML Part 4: chapter 3.5.2)

Author:
Roberto Manicardi

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
SingleXmlCells()
SingleXmlCells(PackagePart part, PackageRelationship rel)
Method Summary
protected void | commit() Save the content in the underlying package part.
java.util.List<XSSFSingleXmlCell> | getAllSimpleXmlCell()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSingleXmlCells | getCTSingleXMLCells()
XSSFSheet | getXSSFSheet()
void | readFrom(java.io.InputStream is)
protected void | writeTo(java.io.OutputStream out)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SingleXmlCells

public SingleXmlCells()

SingleXmlCells

public SingleXmlCells(PackagePart part,
                      PackageRelationship rel)
               throws java.io.IOException
Throws:
java.io.IOException
Method Detail

readFrom

public void readFrom(java.io.InputStream is)
              throws java.io.IOException
Throws:
java.io.IOException

getXSSFSheet

public XSSFSheet getXSSFSheet()

writeTo

protected void writeTo(java.io.OutputStream out)
                throws java.io.IOException
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getCTSingleXMLCells

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSingleXmlCells getCTSingleXMLCells()

getAllSimpleXmlCell

public java.util.List<XSSFSingleXmlCell> getAllSimpleXmlCell()
Returns:
all the SimpleXmlCell contained in this SingleXmlCells element
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StylesTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class StylesTable

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.model.StylesTable

public class StylesTable
extends POIXMLDocumentPart

Table of styles shared across all sheets in a workbook.

Author:
ugo

Field Summary
static int FIRST_CUSTOM_STYLE_ID
The first style id available for use as a custom style
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
StylesTable()
Create a new, empty StylesTable
StylesTable(PackagePart part, PackageRelationship rel)
Method Summary
int | _getDXfsSize()
int | _getNumberFormatSize() For unit testing only
int | _getStyleXfsSize() For unit testing only
int | _getXfsSize() For unit testing only
protected void | commit() Save the content in the underlying package part.
XSSFCellStyle | createCellStyle()
XSSFFont | findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline) Finds a font that matches the one with the supplied attributes
XSSFCellBorder | getBorderAt(int idx)
java.util.List<XSSFCellBorder> | getBorders()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf | getCellStyleXfAt(int idx)
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf | getCellXfAt(int idx)
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTStylesheet | getCTStylesheet() For unit testing only!
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDxf | getDxfAt(int idx)
XSSFCellFill | getFillAt(int idx)
java.util.List<XSSFCellFill> | getFills()
XSSFFont | getFontAt(int idx)
java.util.List<XSSFFont> | getFonts()
java.lang.String | getNumberFormatAt(int idx)
java.util.Map<java.lang.Integer,java.lang.String> | getNumberFormats()
int | getNumCellStyles() get the size of cell styles
XSSFCellStyle | getStyleAt(int idx)
ThemesTable | getTheme()
int | putBorder(XSSFCellBorder border)
int | putCellStyleXf(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellStyleXf)
int | putCellXf(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellXf)
int | putDxf(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDxf dxf)
int | putFill(XSSFCellFill fill)
int | putFont(XSSFFont font)
int | putFont(XSSFFont font, boolean forceRegistration) Records the given font in the font table.
int | putNumberFormat(java.lang.String fmt)
int | putStyle(XSSFCellStyle style)
protected void | readFrom(java.io.InputStream is) Read this shared styles table from an XML file.
void | replaceCellStyleXfAt(int idx, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellStyleXf)
void | replaceCellXfAt(int idx, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellXf)
void | setTheme(ThemesTable theme)
void | writeTo(java.io.OutputStream out) Write this table out as XML.
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FIRST_CUSTOM_STYLE_ID

public static final int FIRST_CUSTOM_STYLE_ID
The first style id available for use as a custom style

See Also:
Constant Field Values
Constructor Detail

StylesTable

public StylesTable()
Create a new, empty StylesTable

StylesTable

public StylesTable(PackagePart part,
                   PackageRelationship rel)
            throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getTheme

public ThemesTable getTheme()

setTheme

public void setTheme(ThemesTable theme)

readFrom

protected void readFrom(java.io.InputStream is)
                 throws java.io.IOException
Read this shared styles table from an XML file.

Parameters:
is - The input stream containing the XML document.
Throws:
java.io.IOException - if an error occurs while reading.

getNumberFormatAt

public java.lang.String getNumberFormatAt(int idx)

putNumberFormat

public int putNumberFormat(java.lang.String fmt)

getFontAt

public XSSFFont getFontAt(int idx)

putFont

public int putFont(XSSFFont font,
                   boolean forceRegistration)
Records the given font in the font table. Will re-use an existing font index if this font matches another, EXCEPT if forced registration is requested. This allows people to create several fonts then customise them later. Note - End Users probably want to call XSSFFont.registerTo(StylesTable)

putFont

public int putFont(XSSFFont font)

getStyleAt

public XSSFCellStyle getStyleAt(int idx)

putStyle

public int putStyle(XSSFCellStyle style)

getBorderAt

public XSSFCellBorder getBorderAt(int idx)

putBorder

public int putBorder(XSSFCellBorder border)

getFillAt

public XSSFCellFill getFillAt(int idx)

getBorders

public java.util.List<XSSFCellBorder> getBorders()

getFills

public java.util.List<XSSFCellFill> getFills()

getFonts

public java.util.List<XSSFFont> getFonts()

getNumberFormats

public java.util.Map<java.lang.Integer,java.lang.String> getNumberFormats()

putFill

public int putFill(XSSFCellFill fill)

getCellXfAt

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf getCellXfAt(int idx)

putCellXf

public int putCellXf(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellXf)

replaceCellXfAt

public void replaceCellXfAt(int idx,
                            org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellXf)

getCellStyleXfAt

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf getCellStyleXfAt(int idx)

putCellStyleXf

public int putCellStyleXf(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellStyleXf)

replaceCellStyleXfAt

public void replaceCellStyleXfAt(int idx,
                                 org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf cellStyleXf)

getNumCellStyles

public int getNumCellStyles()
get the size of cell styles

_getNumberFormatSize

public int _getNumberFormatSize()
For unit testing only

_getXfsSize

public int _getXfsSize()
For unit testing only

_getStyleXfsSize

public int _getStyleXfsSize()
For unit testing only

getCTStylesheet

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTStylesheet getCTStylesheet()
For unit testing only!

_getDXfsSize

public int _getDXfsSize()

writeTo

public void writeTo(java.io.OutputStream out)
             throws java.io.IOException
Write this table out as XML.

Parameters:
out - The stream to write to.
Throws:
java.io.IOException - if an error occurs while writing.

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getDxfAt

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDxf getDxfAt(int idx)

putDxf

public int putDxf(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDxf dxf)

createCellStyle

public XSSFCellStyle createCellStyle()

findFont

public XSSFFont findFont(short boldWeight,
                         short color,
                         short fontHeight,
                         java.lang.String name,
                         boolean italic,
                         boolean strikeout,
                         short typeOffset,
                         byte underline)
Finds a font that matches the one with the supplied attributes

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ThemesTable

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.model
Class ThemesTable

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.model.ThemesTable

public class ThemesTable
extends POIXMLDocumentPart

Class that represents theme of XLSX document. The theme includes specific colors and fonts.

Author:
Petr Udalau(Petr.Udalau at exigenservices.com) - theme colors

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
ThemesTable(PackagePart part, PackageRelationship rel)
ThemesTable(org.openxmlformats.schemas.drawingml.x2006.main.ThemeDocument theme)
Method Summary
XSSFColor | getThemeColor(int idx)
void | inheritFromThemeAsRequired(XSSFColor color) If the colour is based on a theme, then inherit information (currently just colours) from it as required.
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ThemesTable

public ThemesTable(PackagePart part,
                   PackageRelationship rel)
            throws java.io.IOException
Throws:
java.io.IOException

ThemesTable

public ThemesTable(org.openxmlformats.schemas.drawingml.x2006.main.ThemeDocument theme)
Method Detail

getThemeColor

public XSSFColor getThemeColor(int idx)

inheritFromThemeAsRequired

public void inheritFromThemeAsRequired(XSSFColor color)
If the colour is based on a theme, then inherit information (currently just colours) from it as required.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.model.CalculationChain

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.CalculationChain

Packages that use CalculationChain
org.apache.poi.xssf.usermodel

Uses of CalculationChain in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return CalculationChain
 CalculationChain XSSFWorkbook.getCalculationChain()
Return the CalculationChain object for this workbook

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.model.CommentsTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.CommentsTable

Packages that use CommentsTable
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.usermodel

Uses of CommentsTable in org.apache.poi.xssf.eventusermodel

Methods in org.apache.poi.xssf.eventusermodel that return CommentsTable
 CommentsTable XSSFReader.SheetIterator.getSheetComments()
Returns the comments associated with this sheet, or null if there aren't any

Uses of CommentsTable in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return CommentsTable
protected  CommentsTable XSSFSheet.getCommentsTable(boolean create)
Returns the sheet's comments object if there is one, or null if not

Constructors in org.apache.poi.xssf.usermodel with parameters of type CommentsTable
XSSFComment(CommentsTable comments, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment comment, schemasMicrosoftComVml.CTShape vmlShape)
Creates a new XSSFComment, associated with a given low level comment object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.model.IndexedUDFFinder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.IndexedUDFFinder

No usage of org.apache.poi.xssf.model.IndexedUDFFinder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.model.MapInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.MapInfo

Packages that use MapInfo
org.apache.poi.xssf.usermodel

Uses of MapInfo in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return MapInfo
 MapInfo XSSFWorkbook.getMapInfo()

Constructors in org.apache.poi.xssf.usermodel with parameters of type MapInfo
XSSFMap(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMap ctMap, MapInfo mapInfo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.model.SharedStringsTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.SharedStringsTable

Packages that use SharedStringsTable
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.usermodel

Uses of SharedStringsTable in org.apache.poi.xssf.eventusermodel

Methods in org.apache.poi.xssf.eventusermodel that return SharedStringsTable
 SharedStringsTable XSSFReader.getSharedStringsTable()
Opens up the Shared Strings Table, parses it, and returns a handy object for working with shared strings.

Uses of SharedStringsTable in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return SharedStringsTable
SharedStringsTable | XSSFWorkbook.getSharedStringSource() Returns SharedStringsTable - tha cache of string for this workbook
protected SharedStringsTable | XSSFCell.getSharedStringSource()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.model.SingleXmlCells

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.SingleXmlCells

Packages that use SingleXmlCells
org.apache.poi.xssf.usermodel.helpers

Uses of SingleXmlCells in org.apache.poi.xssf.usermodel.helpers

Constructors in org.apache.poi.xssf.usermodel.helpers with parameters of type SingleXmlCells
XSSFSingleXmlCell(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSingleXmlCell singleXmlCell, SingleXmlCells parent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.model.StylesTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.StylesTable

Packages that use StylesTable
org.apache.poi.xssf.eventusermodel
org.apache.poi.xssf.extractor
org.apache.poi.xssf.usermodel

Uses of StylesTable in org.apache.poi.xssf.eventusermodel

Methods in org.apache.poi.xssf.eventusermodel that return StylesTable
 StylesTable XSSFReader.getStylesTable()
Opens up the Styles Table, parses it, and returns a handy object for working with cell styles

Constructors in org.apache.poi.xssf.eventusermodel with parameters of type StylesTable
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, boolean formulasNotResults)
Accepts objects needed while parsing.
XSSFSheetXMLHandler(StylesTable styles, ReadOnlySharedStringsTable strings, XSSFSheetXMLHandler.SheetContentsHandler sheetContentsHandler, DataFormatter dataFormatter, boolean formulasNotResults)
Accepts objects needed while parsing.

Uses of StylesTable in org.apache.poi.xssf.extractor

Methods in org.apache.poi.xssf.extractor with parameters of type StylesTable
 void XSSFEventBasedExcelExtractor.processSheet(XSSFSheetXMLHandler.SheetContentsHandler sheetContentsExtractor, StylesTable styles, ReadOnlySharedStringsTable strings, java.io.InputStream sheetInputStream)
Processes the given sheet

Uses of StylesTable in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return StylesTable
StylesTable | XSSFWorkbook.getStylesSource() Return a object representing a collection of shared objects used for styling content, e.g.
protected StylesTable | XSSFCell.getStylesSource()

Methods in org.apache.poi.xssf.usermodel with parameters of type StylesTable
long | XSSFFont.registerTo(StylesTable styles) Perform a registration of ourselves to the style table
protected void | XSSFRichTextString.setStylesTableReference(StylesTable tbl)
void | XSSFCellStyle.verifyBelongsToStylesSource(StylesTable src) Verifies that this style belongs to the supplied Workbook Styles Source.

Constructors in org.apache.poi.xssf.usermodel with parameters of type StylesTable
XSSFCellStyle(int cellXfId, int cellStyleXfId, StylesTable stylesSource, ThemesTable theme)
Creates a Cell Style from the supplied parts
XSSFCellStyle(StylesTable stylesSource)
Creates an empty Cell Style
XSSFDataFormat(StylesTable stylesSource)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.model.ThemesTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.model.ThemesTable

Packages that use ThemesTable
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions

Uses of ThemesTable in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return ThemesTable
 ThemesTable StylesTable.getTheme()

Methods in org.apache.poi.xssf.model with parameters of type ThemesTable
 void StylesTable.setTheme(ThemesTable theme)

Uses of ThemesTable in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return ThemesTable
 ThemesTable XSSFWorkbook.getTheme()
Returns the Theme of current workbook.

Methods in org.apache.poi.xssf.usermodel with parameters of type ThemesTable
 void XSSFFont.setThemesTable(ThemesTable themes)
Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.

Constructors in org.apache.poi.xssf.usermodel with parameters of type ThemesTable
XSSFCellStyle(int cellXfId, int cellStyleXfId, StylesTable stylesSource, ThemesTable theme)
Creates a Cell Style from the supplied parts

Uses of ThemesTable in org.apache.poi.xssf.usermodel.extensions

Methods in org.apache.poi.xssf.usermodel.extensions with parameters of type ThemesTable
 void XSSFCellBorder.setThemesTable(ThemesTable themes)
Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.

Constructors in org.apache.poi.xssf.usermodel.extensions with parameters of type ThemesTable
XSSFCellBorder(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder border, ThemesTable theme)
Creates a Cell Border from the supplied XML definition

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


GZIPSheetDataWriter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class GZIPSheetDataWriter

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SheetDataWriter
        extended by  org.apache.poi.xssf.streaming.GZIPSheetDataWriter

public class GZIPSheetDataWriter
extends SheetDataWriter

Sheet writer that supports gzip compression of the temp files.

Constructor Summary
GZIPSheetDataWriter()
Method Summary
java.io.File | createTempFile() Create a temp file to write sheet data.
java.io.Writer | createWriter(java.io.File fd) Create a writer for the sheet data.
java.io.InputStream | getWorksheetXMLInputStream()
Methods inherited from class org.apache.poi.xssf.streaming.SheetDataWriter
close, finalize, getLowestIndexOfFlushedRows, getNumberOfCellsOfLastFlushedRow, getNumberOfFlushedRows, outputQuotedString, writeCell, writeRow
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GZIPSheetDataWriter

public GZIPSheetDataWriter()
                    throws java.io.IOException
Throws:
java.io.IOException
Method Detail

createTempFile

public java.io.File createTempFile()
                            throws java.io.IOException
Description copied from class: SheetDataWriter
Create a temp file to write sheet data. By default, temp files are created in the default temporary-file directory with a prefix "poi-sxssf-sheet" and suffix ".xml". Subclasses can override it and specify a different temp directory or filename or suffix, e.g. .gz

Overrides:
createTempFile in class SheetDataWriter
Returns:
temp file to write sheet data
Throws:
java.io.IOException

createWriter

public java.io.Writer createWriter(java.io.File fd)
                            throws java.io.IOException
Description copied from class: SheetDataWriter
Create a writer for the sheet data.

Overrides:
createWriter in class SheetDataWriter
Parameters:
fd - the file to write to
Returns:
a wrapped instance of GZIPOutputStream
Throws:
java.io.IOException

getWorksheetXMLInputStream

public java.io.InputStream getWorksheetXMLInputStream()
                                               throws java.io.IOException
Overrides:
getWorksheetXMLInputStream in class SheetDataWriter
Returns:
a GZIPInputStream stream to read the compressed temp file
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.xssf.streaming
Classes
GZIPSheetDataWriter
SheetDataWriter
SXSSFCell
SXSSFRow
SXSSFSheet
SXSSFWorkbook


org.apache.poi.xssf.streaming

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.streaming

Class Summary
GZIPSheetDataWriter | Sheet writer that supports gzip compression of the temp files.
SheetDataWriter | Initially copied from BigGridDemo "SpreadsheetWriter".
SXSSFCell | Streaming version of XSSFRow implementing the "BigGridDemo" strategy.
SXSSFRow | Streaming version of XSSFRow implementing the "BigGridDemo" strategy.
SXSSFSheet | Streaming version of XSSFSheet implementing the "BigGridDemo" strategy.
SXSSFWorkbook | Streaming version of XSSFWorkbook implementing the "BigGridDemo" strategy.


org.apache.poi.xssf.streaming Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.streaming

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xssf.streaming.SheetDataWriter
      • org.apache.poi.xssf.streaming.GZIPSheetDataWriter
    • org.apache.poi.xssf.streaming.SXSSFCell (implements org.apache.poi.ss.usermodel.Cell)
    • org.apache.poi.xssf.streaming.SXSSFRow (implements org.apache.poi.ss.usermodel.Row)
    • org.apache.poi.xssf.streaming.SXSSFRow.CellIterator (implements java.util.Iterator<E>)
    • org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator (implements java.util.Iterator<E>)
    • org.apache.poi.xssf.streaming.SXSSFSheet (implements java.lang.Cloneable, org.apache.poi.ss.usermodel.Sheet)
    • org.apache.poi.xssf.streaming.SXSSFWorkbook (implements org.apache.poi.ss.usermodel.Workbook)


Uses of Package org.apache.poi.xssf.streaming

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.streaming

Packages that use org.apache.poi.xssf.streaming
org.apache.poi.xssf.streaming

Classes in org.apache.poi.xssf.streaming used by org.apache.poi.xssf.streaming
SheetDataWriter
Initially copied from BigGridDemo "SpreadsheetWriter".
SXSSFRow
Streaming version of XSSFRow implementing the "BigGridDemo" strategy.
SXSSFSheet
Streaming version of XSSFSheet implementing the "BigGridDemo" strategy.
SXSSFWorkbook
Streaming version of XSSFWorkbook implementing the "BigGridDemo" strategy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SheetDataWriter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class SheetDataWriter

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SheetDataWriter
Direct Known Subclasses:
GZIPSheetDataWriter
public class SheetDataWriter
extends java.lang.Object

Initially copied from BigGridDemo "SpreadsheetWriter". Unlike the original code which wrote the entire document, this class only writes the "sheetData" document fragment so that it was renamed to "SheetDataWriter"

Constructor Summary
SheetDataWriter()
Method Summary
void | close() flush and close the temp data writer.
java.io.File | createTempFile() Create a temp file to write sheet data.
java.io.Writer | createWriter(java.io.File fd) Create a writer for the sheet data.
protected void | finalize()
int | getLowestIndexOfFlushedRows()
int | getNumberOfCellsOfLastFlushedRow()
int | getNumberOfFlushedRows()
java.io.InputStream | getWorksheetXMLInputStream()
protected void | outputQuotedString(java.lang.String s)
void | writeCell(int columnIndex, Cell cell)
void | writeRow(int rownum, SXSSFRow row) Write a row to the file
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SheetDataWriter

public SheetDataWriter()
                throws java.io.IOException
Throws:
java.io.IOException
Method Detail

createTempFile

public java.io.File createTempFile()
                            throws java.io.IOException
Create a temp file to write sheet data. By default, temp files are created in the default temporary-file directory with a prefix "poi-sxssf-sheet" and suffix ".xml". Subclasses can override it and specify a different temp directory or filename or suffix, e.g. .gz

Returns:
temp file to write sheet data
Throws:
java.io.IOException

createWriter

public java.io.Writer createWriter(java.io.File fd)
                            throws java.io.IOException
Create a writer for the sheet data.

Parameters:
fd - the file to write to
Throws:
java.io.IOException

close

public void close()
           throws java.io.IOException
flush and close the temp data writer. This method must be invoked before calling getWorksheetXMLInputStream()

Throws:
java.io.IOException

getWorksheetXMLInputStream

public java.io.InputStream getWorksheetXMLInputStream()
                                               throws java.io.IOException
Returns:
a stream to read temp file with the sheet data
Throws:
java.io.IOException

getNumberOfFlushedRows

public int getNumberOfFlushedRows()

getNumberOfCellsOfLastFlushedRow

public int getNumberOfCellsOfLastFlushedRow()

getLowestIndexOfFlushedRows

public int getLowestIndexOfFlushedRows()

finalize

protected void finalize()
                 throws java.lang.Throwable
Overrides:
finalize in class java.lang.Object
Throws:
java.lang.Throwable

writeRow

public void writeRow(int rownum,
                     SXSSFRow row)
              throws java.io.IOException
Write a row to the file

Parameters:
rownum - 0-based row number
row - a row
Throws:
java.io.IOException

writeCell

public void writeCell(int columnIndex,
                      Cell cell)
               throws java.io.IOException
Throws:
java.io.IOException

outputQuotedString

protected void outputQuotedString(java.lang.String s)
                           throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SXSSFCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class SXSSFCell

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SXSSFCell
All Implemented Interfaces:
Cell
public class SXSSFCell
extends java.lang.Object
implements Cell

Streaming version of XSSFRow implementing the "BigGridDemo" strategy.

Author:
Alex Geller, Four J's Development Tools

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.Cell
CELL_TYPE_BLANK, CELL_TYPE_BOOLEAN, CELL_TYPE_ERROR, CELL_TYPE_FORMULA, CELL_TYPE_NUMERIC, CELL_TYPE_STRING
Constructor Summary
SXSSFCell(SXSSFRow row, int cellType)
Method Summary
 CellRangeAddress getArrayFormulaRange()
Only valid for array formula cells
 boolean getBooleanCellValue()
Get the value of the cell as a boolean.
 int getCachedFormulaResultType()
Only valid for formula cells
 Comment getCellComment()
Returns comment associated with this cell
 java.lang.String getCellFormula()
Return a formula for the cell, for example, SUM(C4:E4)
 CellStyle getCellStyle()
Return the cell's style.
 int getCellType()
Return the cell type.
 int getColumnIndex()
Returns column index of this cell
 java.util.Date getDateCellValue()
Get the value of the cell as a date.
 byte getErrorCellValue()
Get the value of the cell as an error code.
 Hyperlink getHyperlink()
 double getNumericCellValue()
Get the value of the cell as a number.
 RichTextString getRichStringCellValue()
Get the value of the cell as a XSSFRichTextString
 Row getRow()
Returns the Row this cell belongs to
 int getRowIndex()
Returns row index of a row in the sheet that contains this cell
 Sheet getSheet()
Returns the sheet this cell belongs to
 java.lang.String getStringCellValue()
Get the value of the cell as a string
 boolean isPartOfArrayFormulaGroup()
 void removeCellComment()
Removes the comment for this cell, if there is one.
 void setAsActiveCell()
Sets this cell as the active cell for the worksheet
 void setCellComment(Comment comment)
Assign a comment to this cell
 void setCellErrorValue(byte value)
Set a error value for the cell
 void setCellFormula(java.lang.String formula)
Sets formula for this cell.
 void setCellStyle(CellStyle style)
Set the style for the cell.
 void setCellType(int cellType)
Set the cells type (numeric, formula or string)
 void setCellValue(boolean value)
Set a boolean value for the cell
 void setCellValue(java.util.Calendar value)
Set a date value for the cell.
 void setCellValue(java.util.Date value)
Converts the supplied date to its equivalent Excel numeric value and sets that into the cell.
 void setCellValue(double value)
Set a numeric value for the cell
 void setCellValue(RichTextString value)
Set a rich string value for the cell.
 void setCellValue(java.lang.String value)
Set a string value for the cell.
 void setHyperlink(Hyperlink link)
Assign a hyperlink to this cell
 java.lang.String toString()
Returns a string representation of the cell
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SXSSFCell

public SXSSFCell(SXSSFRow row,
                 int cellType)
Method Detail

getColumnIndex

public int getColumnIndex()
Returns column index of this cell

Specified by:
getColumnIndex in interface Cell
Returns:
zero-based column index of a column in a sheet.

getRowIndex

public int getRowIndex()
Returns row index of a row in the sheet that contains this cell

Specified by:
getRowIndex in interface Cell
Returns:
zero-based row index of a row in the sheet that contains this cell

getSheet

public Sheet getSheet()
Returns the sheet this cell belongs to

Specified by:
getSheet in interface Cell
Returns:
the sheet this cell belongs to

getRow

public Row getRow()
Returns the Row this cell belongs to

Specified by:
getRow in interface Cell
Returns:
the Row that owns this cell

setCellType

public void setCellType(int cellType)
Set the cells type (numeric, formula or string)

Specified by:
setCellType in interface Cell
Throws:
java.lang.IllegalArgumentException - if the specified cell type is invalid
See Also:
Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_FORMULA, Cell.CELL_TYPE_BLANK, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR

getCellType

public int getCellType()
Return the cell type.

Specified by:
getCellType in interface Cell
Returns:
the cell type
See Also:
Cell.CELL_TYPE_BLANK, Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_FORMULA, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR

getCachedFormulaResultType

public int getCachedFormulaResultType()
Only valid for formula cells

Specified by:
getCachedFormulaResultType in interface Cell
Returns:
one of (Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR) depending on the cached value of the formula

setCellValue

public void setCellValue(double value)
Set a numeric value for the cell

Specified by:
setCellValue in interface Cell
Parameters:
value - the numeric value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numeric cell and set its value.

setCellValue

public void setCellValue(java.util.Date value)
Converts the supplied date to its equivalent Excel numeric value and sets that into the cell.

Note - There is actually no 'DATE' cell type in Excel. In many cases (when entering date values), Excel automatically adjusts the cell style to some date format, creating the illusion that the cell data type is now something besides Cell.CELL_TYPE_NUMERIC. POI does not attempt to replicate this behaviour. To make a numeric cell display as a date, use setCellStyle(CellStyle) etc.

Specified by:
setCellValue in interface Cell
Parameters:
value - the numeric value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numerics cell and set its value.

setCellValue

public void setCellValue(java.util.Calendar value)
Set a date value for the cell. Excel treats dates as numeric so you will need to format the cell as a date.

This will set the cell value based on the Calendar's timezone. As Excel does not support timezones this means that both 20:00+03:00 and 20:00-03:00 will be reported as the same value (20:00) even that there are 6 hours difference between the two times. This difference can be preserved by using setCellValue(value.getTime()) which will automatically shift the times to the default timezone.

Specified by:
setCellValue in interface Cell
Parameters:
value - the date value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For othertypes we will change the cell to a numeric cell and set its value.

setCellValue

public void setCellValue(RichTextString value)
Set a rich string value for the cell.

Specified by:
setCellValue in interface Cell
Parameters:
value - value to set the cell to. For formulas we'll set the formula string, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

setCellValue

public void setCellValue(java.lang.String value)
Set a string value for the cell.

Specified by:
setCellValue in interface Cell
Parameters:
value - value to set the cell to. For formulas we'll set the formula string, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

setCellFormula

public void setCellFormula(java.lang.String formula)
                    throws FormulaParseException
Sets formula for this cell.

Note, this method only sets the formula string and does not calculate the formula value. To set the precalculated value use setCellValue(double) or setCellValue(String)

Specified by:
setCellFormula in interface Cell
Parameters:
formula - the formula to set, e.g. "SUM(C4:E4)". If the argument is null then the current formula is removed.
Throws:
FormulaParseException - if the formula has incorrect syntax or is otherwise invalid

getCellFormula

public java.lang.String getCellFormula()
Return a formula for the cell, for example, SUM(C4:E4)

Specified by:
getCellFormula in interface Cell
Returns:
a formula for the cell
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is not CELL_TYPE_FORMULA

getNumericCellValue

public double getNumericCellValue()
Get the value of the cell as a number.

For strings we throw an exception. For blank cells we return a 0. For formulas or error cells we return the precalculated value;

Specified by:
getNumericCellValue in interface Cell
Returns:
the value of the cell as a number
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is CELL_TYPE_STRING
java.lang.NumberFormatException - if the cell value isn't a parsable double.
See Also:
for turning this number into a string similar to that which Excel would render this number as.

getDateCellValue

public java.util.Date getDateCellValue()
Get the value of the cell as a date.

For strings we throw an exception. For blank cells we return a null.

Specified by:
getDateCellValue in interface Cell
Returns:
the value of the cell as a date
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is CELL_TYPE_STRING
java.lang.NumberFormatException - if the cell value isn't a parsable double.
See Also:
for formatting this date into a string similar to how excel does.

getRichStringCellValue

public RichTextString getRichStringCellValue()
Get the value of the cell as a XSSFRichTextString

For numeric cells we throw an exception. For blank cells we return an empty string. For formula cells we return the pre-calculated value if a string, otherwise an exception.

Specified by:
getRichStringCellValue in interface Cell
Returns:
the value of the cell as a XSSFRichTextString

getStringCellValue

public java.lang.String getStringCellValue()
Get the value of the cell as a string

For numeric cells we throw an exception. For blank cells we return an empty string. For formulaCells that are not string Formulas, we throw an exception.

Specified by:
getStringCellValue in interface Cell
Returns:
the value of the cell as a string

setCellValue

public void setCellValue(boolean value)
Set a boolean value for the cell

Specified by:
setCellValue in interface Cell
Parameters:
value - the boolean value to set this cell to. For formulas we'll set the precalculated value, for booleans we'll set its value. For other types we will change the cell to a boolean cell and set its value.

setCellErrorValue

public void setCellErrorValue(byte value)
Set a error value for the cell

Specified by:
setCellErrorValue in interface Cell
Parameters:
value - the error value to set this cell to. For formulas we'll set the precalculated value , for errors we'll set its value. For other types we will change the cell to an error cell and set its value.
See Also:
FormulaError

getBooleanCellValue

public boolean getBooleanCellValue()
Get the value of the cell as a boolean.

For strings, numbers, and errors, we throw an exception. For blank cells we return a false.

Specified by:
getBooleanCellValue in interface Cell
Returns:
the value of the cell as a boolean
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is not CELL_TYPE_BOOLEAN, CELL_TYPE_BLANK or CELL_TYPE_FORMULA

getErrorCellValue

public byte getErrorCellValue()
Get the value of the cell as an error code.

For strings, numbers, and booleans, we throw an exception. For blank cells we return a 0.

Specified by:
getErrorCellValue in interface Cell
Returns:
the value of the cell as an error code
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() isn't CELL_TYPE_ERROR
See Also:
for error codes

setCellStyle

public void setCellStyle(CellStyle style)
Set the style for the cell. The style should be an CellStyle created/retreived from the Workbook.

Specified by:
setCellStyle in interface Cell
Parameters:
style - reference contained in the workbook. If the value is null then the style information is removed causing the cell to used the default workbook style.
See Also:
Workbook.createCellStyle()

getCellStyle

public CellStyle getCellStyle()
Return the cell's style.

Specified by:
getCellStyle in interface Cell
Returns:
the cell's style. Always not-null. Default cell style has zero index and can be obtained as workbook.getCellStyleAt(0)
See Also:
Workbook.getCellStyleAt(short)

setAsActiveCell

public void setAsActiveCell()
Sets this cell as the active cell for the worksheet

Specified by:
setAsActiveCell in interface Cell

setCellComment

public void setCellComment(Comment comment)
Assign a comment to this cell

Specified by:
setCellComment in interface Cell
Parameters:
comment - comment associated with this cell

getCellComment

public Comment getCellComment()
Returns comment associated with this cell

Specified by:
getCellComment in interface Cell
Returns:
comment associated with this cell or null if not found

removeCellComment

public void removeCellComment()
Removes the comment for this cell, if there is one.

Specified by:
removeCellComment in interface Cell

getHyperlink

public Hyperlink getHyperlink()
Specified by:
getHyperlink in interface Cell
Returns:
hyperlink associated with this cell or null if not found

setHyperlink

public void setHyperlink(Hyperlink link)
Assign a hyperlink to this cell

Specified by:
setHyperlink in interface Cell
Parameters:
link - hyperlink associated with this cell

getArrayFormulaRange

public CellRangeAddress getArrayFormulaRange()
Only valid for array formula cells

Specified by:
getArrayFormulaRange in interface Cell
Returns:
range of the array formula group that the cell belongs to.

isPartOfArrayFormulaGroup

public boolean isPartOfArrayFormulaGroup()
Specified by:
isPartOfArrayFormulaGroup in interface Cell
Returns:
true if this cell is part of group of cells having a common array formula.

toString

public java.lang.String toString()
Returns a string representation of the cell

Formula cells return the formula string, rather than the formula result. Dates are displayed in dd-MMM-yyyy format Errors are displayed as #ERR<errIdx>

Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SXSSFRow.CellIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class SXSSFRow.CellIterator

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SXSSFRow.CellIterator
All Implemented Interfaces:
java.util.Iterator<Cell>
Enclosing class:
SXSSFRow
public class SXSSFRow.CellIterator
extends java.lang.Object
implements java.util.Iterator<Cell>

returns all cells including empty cells in which case "null" is returned

Constructor Summary
SXSSFRow.CellIterator()
Method Summary
boolean | hasNext()
Cell | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SXSSFRow.CellIterator

public SXSSFRow.CellIterator()
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface java.util.Iterator<Cell>

next

public Cell next()
          throws java.util.NoSuchElementException
Specified by:
next in interface java.util.Iterator<Cell>
Throws:
java.util.NoSuchElementException

remove

public void remove()
Specified by:
remove in interface java.util.Iterator<Cell>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SXSSFRow.FilledCellIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class SXSSFRow.FilledCellIterator

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator
All Implemented Interfaces:
java.util.Iterator<Cell>
Enclosing class:
SXSSFRow
public class SXSSFRow.FilledCellIterator
extends java.lang.Object
implements java.util.Iterator<Cell>

returns all filled cells (created via Row.createCell())

Method Summary
boolean | hasNext()
Cell | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface java.util.Iterator<Cell>

next

public Cell next()
          throws java.util.NoSuchElementException
Specified by:
next in interface java.util.Iterator<Cell>
Throws:
java.util.NoSuchElementException

remove

public void remove()
Specified by:
remove in interface java.util.Iterator<Cell>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SXSSFRow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class SXSSFRow

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SXSSFRow
All Implemented Interfaces:
java.lang.Iterable<Cell>, Row
public class SXSSFRow
extends java.lang.Object
implements Row

Streaming version of XSSFRow implementing the "BigGridDemo" strategy.

Author:
Alex Geller, Four J's Development Tools

Nested Class Summary
class | SXSSFRow.CellIterator returns all cells including empty cells in which case "null" is returned
class | SXSSFRow.FilledCellIterator returns all filled cells (created via Row.createCell())
Nested classes/interfaces inherited from interface org.apache.poi.ss.usermodel.Row
Row.MissingCellPolicy
Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.Row
CREATE_NULL_AS_BLANK, RETURN_BLANK_AS_NULL, RETURN_NULL_AND_BLANK
Constructor Summary
SXSSFRow(SXSSFSheet sheet, int initialSize)
Method Summary
java.util.Iterator<Cell> | allCellsIterator()
java.util.Iterator<Cell> | cellIterator()
Cell | createCell(int column) Use this to create new cells within the row and return it.
Cell | createCell(int column, int type) Use this to create new cells within the row and return it.
Cell | getCell(int cellnum) Get the cell representing a given column (logical cell) 0-based.
Cell | getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
short | getFirstCellNum() Get the number of the first cell contained in this row.
short | getHeight() Get the row's height measured in twips (1/20th of a point).
float | getHeightInPoints() Returns row height measured in point size.
short | getLastCellNum() Gets the index of the last cell contained in this row PLUS ONE.
int | getPhysicalNumberOfCells() Gets the number of defined cells (NOT number of cells in the actual row!).
int | getRowNum() Get row number this row represents
CellStyle | getRowStyle() Returns the whole-row cell style.
Sheet | getSheet() Returns the Sheet this row belongs to
boolean | getZeroHeight() Get whether or not to display this row with 0 height
boolean | hasCustomHeight()
boolean | isFormatted() Is this row formatted? Most aren't, but some rows do have whole-row styles.
java.util.Iterator<Cell> | iterator()
void | removeCell(Cell cell) Remove the Cell from this row.
void | setHeight(short height) Set the row's height or set to ff (-1) for undefined/default-height.
void | setHeightInPoints(float height) Set the row's height in points.
void | setRowNum(int rowNum) Set the row number of this row.
void | setRowStyle(CellStyle style) Applies a whole-row cell styling to the row.
void | setZeroHeight(boolean zHeight) Set whether or not to display this row with 0 height
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SXSSFRow

public SXSSFRow(SXSSFSheet sheet,
                int initialSize)
Method Detail

allCellsIterator

public java.util.Iterator<Cell> allCellsIterator()

hasCustomHeight

public boolean hasCustomHeight()

iterator

public java.util.Iterator<Cell> iterator()
Specified by:
iterator in interface java.lang.Iterable<Cell>

createCell

public Cell createCell(int column)
Use this to create new cells within the row and return it.

The cell that is returned is a Cell.CELL_TYPE_BLANK. The type can be changed either through calling setCellValue or setCellType.

Specified by:
createCell in interface Row
Parameters:
column - - the column number this cell represents
Returns:
Cell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if columnIndex < 0 or greater than the maximum number of supported columns (255 for *.xls, 1048576 for *.xlsx)

createCell

public Cell createCell(int column,
                       int type)
Use this to create new cells within the row and return it.

The cell that is returned is a Cell.CELL_TYPE_BLANK. The type can be changed either through calling setCellValue or setCellType.

Specified by:
createCell in interface Row
Parameters:
column - - the column number this cell represents
Returns:
Cell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if columnIndex < 0 or greate than a maximum number of supported columns (255 for *.xls, 1048576 for *.xlsx)

removeCell

public void removeCell(Cell cell)
Remove the Cell from this row.

Specified by:
removeCell in interface Row
Parameters:
cell - the cell to remove

setRowNum

public void setRowNum(int rowNum)
Set the row number of this row.

Specified by:
setRowNum in interface Row
Parameters:
rowNum - the row number (0-based)
Throws:
java.lang.IllegalArgumentException - if rowNum < 0

getRowNum

public int getRowNum()
Get row number this row represents

Specified by:
getRowNum in interface Row
Returns:
the row number (0 based)

getCell

public Cell getCell(int cellnum)
Get the cell representing a given column (logical cell) 0-based. If you ask for a cell that is not defined....you get a null.

Specified by:
getCell in interface Row
Parameters:
cellnum - 0 based column number
Returns:
Cell representing that column or null if undefined.
See Also:
getCell(int, org.apache.poi.ss.usermodel.Row.MissingCellPolicy)

getCell

public Cell getCell(int cellnum,
                    Row.MissingCellPolicy policy)
Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy

Specified by:
getCell in interface Row
Returns:
the cell at the given (0 based) index
Throws:
java.lang.IllegalArgumentException - if cellnum < 0 or the specified MissingCellPolicy is invalid
See Also:
Row.RETURN_NULL_AND_BLANK, Row.RETURN_BLANK_AS_NULL, Row.CREATE_NULL_AS_BLANK

getFirstCellNum

public short getFirstCellNum()
Get the number of the first cell contained in this row.

Specified by:
getFirstCellNum in interface Row
Returns:
short representing the first logical cell in the row, or -1 if the row does not contain any cells.

getLastCellNum

public short getLastCellNum()
Gets the index of the last cell contained in this row PLUS ONE. The result also happens to be the 1-based column number of the last cell. This value can be used as a standard upper bound when iterating over cells:
 short minColIx = row.getFirstCellNum();
 short maxColIx = row.getLastCellNum();
 for(short colIx=minColIx; colIx<maxColIx; colIx++) {
   Cell cell = row.getCell(colIx);
   if(cell == null) {
     continue;
   }
   //... do something with cell
 }

Specified by:
getLastCellNum in interface Row
Returns:
short representing the last logical cell in the row PLUS ONE, or -1 if the row does not contain any cells.

getPhysicalNumberOfCells

public int getPhysicalNumberOfCells()
Gets the number of defined cells (NOT number of cells in the actual row!). That is to say if only columns 0,4,5 have values then there would be 3.

Specified by:
getPhysicalNumberOfCells in interface Row
Returns:
int representing the number of defined cells in the row.

setHeight

public void setHeight(short height)
Set the row's height or set to ff (-1) for undefined/default-height. Set the height in "twips" or 1/20th of a point.

Specified by:
setHeight in interface Row
Parameters:
height - rowheight or 0xff for undefined (use sheet default)

setZeroHeight

public void setZeroHeight(boolean zHeight)
Set whether or not to display this row with 0 height

Specified by:
setZeroHeight in interface Row
Parameters:
zHeight - height is zero or not.

getZeroHeight

public boolean getZeroHeight()
Get whether or not to display this row with 0 height

Specified by:
getZeroHeight in interface Row
Returns:
- zHeight height is zero or not.

setHeightInPoints

public void setHeightInPoints(float height)
Set the row's height in points.

Specified by:
setHeightInPoints in interface Row
Parameters:
height - the height in points. -1 resets to the default height

getHeight

public short getHeight()
Get the row's height measured in twips (1/20th of a point). If the height is not set, the default worksheet value is returned, See Sheet.getDefaultRowHeightInPoints()

Specified by:
getHeight in interface Row
Returns:
row height measured in twips (1/20th of a point)

getHeightInPoints

public float getHeightInPoints()
Returns row height measured in point size. If the height is not set, the default worksheet value is returned, See Sheet.getDefaultRowHeightInPoints()

Specified by:
getHeightInPoints in interface Row
Returns:
row height measured in point size
See Also:
Sheet.getDefaultRowHeightInPoints()

isFormatted

public boolean isFormatted()
Is this row formatted? Most aren't, but some rows do have whole-row styles. For those that do, you can get the formatting from getRowStyle()

Specified by:
isFormatted in interface Row

getRowStyle

public CellStyle getRowStyle()
Returns the whole-row cell style. Most rows won't have one of these, so will return null. Call isFormatted() to check first.

Specified by:
getRowStyle in interface Row

setRowStyle

public void setRowStyle(CellStyle style)
Applies a whole-row cell styling to the row.

Specified by:
setRowStyle in interface Row

cellIterator

public java.util.Iterator<Cell> cellIterator()
Specified by:
cellIterator in interface Row
Returns:
Cell iterator of the physically defined cells. Note element 4 may actually be row cell depending on how many are defined!

getSheet

public Sheet getSheet()
Returns the Sheet this row belongs to

Specified by:
getSheet in interface Row
Returns:
the Sheet that owns this row
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SXSSFSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class SXSSFSheet

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SXSSFSheet
All Implemented Interfaces:
java.lang.Cloneable, java.lang.Iterable<Row>, Sheet
public class SXSSFSheet
extends java.lang.Object
implements Sheet, java.lang.Cloneable

Streaming version of XSSFSheet implementing the "BigGridDemo" strategy.

Author:
Alex Geller, Four J's Development Tools

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.Sheet
BottomMargin, FooterMargin, HeaderMargin, LeftMargin, PANE_LOWER_LEFT, PANE_LOWER_RIGHT, PANE_UPPER_LEFT, PANE_UPPER_RIGHT, RightMargin, TopMargin
Constructor Summary
SXSSFSheet(SXSSFWorkbook workbook, XSSFSheet xSheet)
Method Summary
int | addMergedRegion(CellRangeAddress region) Adds a merged region of cells (hence those cells form one)
void | addValidationData(DataValidation dataValidation) Creates a data validation object
void | autoSizeColumn(int column) Adjusts the column width to fit the contents.
void | autoSizeColumn(int column, boolean useMergedCells) Adjusts the column width to fit the contents.
void | changeRowNum(SXSSFRow row, int newRowNum)
Drawing | createDrawingPatriarch() Creates the top-level drawing patriarch.
void | createFreezePane(int colSplit, int rowSplit) Creates a split (freezepane).
void | createFreezePane(int colSplit, int rowSplit, int leftmostColumn, int topRow) Creates a split (freezepane).
Row | createRow(int rownum) Create a new row within the sheet and return the high level representation
void | createSplitPane(int xSplitPos, int ySplitPos, int leftmostColumn, int topRow, int activePane) Creates a split pane.
void | flushRows() Flush all rows to disk.
void | flushRows(int remaining) Specifies how many rows can be accessed at most via getRow().
boolean | getAutobreaks() Flag indicating whether the sheet displays Automatic Page Breaks.
Comment | getCellComment(int row, int column) Returns cell comment for the specified row and column
int[] | getColumnBreaks() Retrieves all the vertical page breaks
CellStyle | getColumnStyle(int column) Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
int | getColumnWidth(int columnIndex) get the width (in units of 1/256th of a character width )
DataValidationHelper | getDataValidationHelper()
int | getDefaultColumnWidth() Get the default column width for the sheet (if the columns do not define their own width) in characters
short | getDefaultRowHeight() Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
float | getDefaultRowHeightInPoints() Get the default row height for the sheet (if the rows do not define their own height) in points.
boolean | getDisplayGuts() Get whether to display the guts or not, default value is true
int | getFirstRowNum() Gets the first row on the sheet
boolean | getFitToPage() Flag indicating whether the Fit to Page print option is enabled.
Footer | getFooter() Gets the user model for the default document footer.
boolean | getForceFormulaRecalculation() Whether Excel will be asked to recalculate all formulas when the workbook is opened.
Header | getHeader() Gets the user model for the default document header.
boolean | getHorizontallyCenter() Determine whether printed output for this sheet will be horizontally centered.
int | getLastRowNum() Gets the last row on the sheet
short | getLeftCol() The left col in the visible view when the sheet is first viewed after opening it in a viewer
double | getMargin(short margin) Gets the size of the margin in inches.
CellRangeAddress | getMergedRegion(int index) Returns the merged region at the specified index
int | getNumMergedRegions() Returns the number of merged regions
PaneInformation | getPaneInformation() Returns the information regarding the currently configured pane (split or freeze)
int | getPhysicalNumberOfRows() Returns the number of physically defined rows (NOT the number of rows in the sheet)
PrintSetup | getPrintSetup() Gets the print setup object.
boolean | getProtect() Answer whether protection is enabled or disabled
Row | getRow(int rownum) Returns the logical row (not physical) 0-based.
int[] | getRowBreaks() Retrieves all the horizontal page breaks
int | getRowNum(SXSSFRow row)
boolean | getRowSumsBelow() Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
boolean | getRowSumsRight() Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
boolean | getScenarioProtect() Answer whether scenario protection is enabled or disabled
SheetConditionalFormatting | getSheetConditionalFormatting() The 'Conditional Formatting' facet for this Sheet
java.lang.String | getSheetName() Returns the name of this sheet
short | getTopRow() The top row in the visible view when the sheet is first viewed after opening it in a viewer
boolean | getVerticallyCenter() Determine whether printed output for this sheet will be vertically centered.
Workbook | getWorkbook() Return the parent workbook
java.io.InputStream | getWorksheetXMLInputStream()
void | groupColumn(int fromColumn, int toColumn) Create an outline for the provided column range.
void | groupRow(int fromRow, int toRow) Tie a range of rows together so that they can be collapsed or expanded
boolean | isColumnBroken(int column) Determines if there is a page break at the indicated column
boolean | isColumnHidden(int columnIndex) Get the hidden state for a given column
boolean | isDisplayFormulas() Returns if formulas are displayed
boolean | isDisplayGridlines() Returns if gridlines are displayed
boolean | isDisplayRowColHeadings() Returns if RowColHeadings are displayed.
boolean | isDisplayZeros() Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
boolean | isPrintGridlines() Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.
boolean | isRightToLeft() Whether the text is displayed in right-to-left mode in the window
boolean | isRowBroken(int row) Determines if there is a page break at the indicated row
boolean | isSelected() Note - this is not the same as whether the sheet is focused (isActive)
java.util.Iterator<Row> | iterator()
void | protectSheet(java.lang.String password) Sets the protection enabled as well as the password
CellRange<? extends Cell> | removeArrayFormula(Cell cell) Remove a Array Formula from this sheet.
void | removeColumnBreak(int column) Removes a page break at the indicated column
void | removeMergedRegion(int index) Removes a merged region of cells (hence letting them free)
void | removeRow(Row row) Remove a row from this sheet.
void | removeRowBreak(int row) Removes the page break at the indicated row
java.util.Iterator<Row> | rowIterator() Returns an iterator of the physical rows
CellRange<? extends Cell> | setArrayFormula(java.lang.String formula, CellRangeAddress range) Sets array formula to specified region for result.
void | setAutobreaks(boolean value) Flag indicating whether the sheet displays Automatic Page Breaks.
AutoFilter | setAutoFilter(CellRangeAddress range) Enable filtering for a range of cells
void | setColumnBreak(int column) Sets a page break at the indicated column
void | setColumnGroupCollapsed(int columnNumber, boolean collapsed) Expands or collapses a column group.
void | setColumnHidden(int columnIndex, boolean hidden) Get the visibility state for a given column
void | setColumnWidth(int columnIndex, int width) Set the width (in units of 1/256th of a character width)
void | setDefaultColumnStyle(int column, CellStyle style) Sets the default column style for a given column.
void | setDefaultColumnWidth(int width) Set the default column width for the sheet (if the columns do not define their own width) in characters
void | setDefaultRowHeight(short height) Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
void | setDefaultRowHeightInPoints(float height) Set the default row height for the sheet (if the rows do not define their own height) in points
void | setDisplayFormulas(boolean show) Sets whether the formulas are shown in a viewer
void | setDisplayGridlines(boolean show) Sets whether the gridlines are shown in a viewer
void | setDisplayGuts(boolean value) Set whether to display the guts or not
void | setDisplayRowColHeadings(boolean show) Sets whether the RowColHeadings are shown in a viewer
void | setDisplayZeros(boolean value) Set whether the window should show 0 (zero) in cells containing zero value.
void | setFitToPage(boolean value) Flag indicating whether the Fit to Page print option is enabled.
void | setForceFormulaRecalculation(boolean value) Control if Excel should be asked to recalculate all formulas when the workbook is opened, via the "sheetCalcPr fullCalcOnLoad" option.
void | setHorizontallyCenter(boolean value) Determines whether the output is horizontally centered on the page.
void | setMargin(short margin, double size) Sets the size of the margin in inches.
void | setPrintGridlines(boolean show) Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier.
void | setRandomAccessWindowSize(int value) Specifies how many rows can be accessed at most via getRow().
void | setRightToLeft(boolean value) Sets whether the worksheet is displayed from right to left instead of from left to right.
void | setRowBreak(int row) Sets a page break at the indicated row
void | setRowGroupCollapsed(int row, boolean collapse) Set view state of a groupped range of rows
void | setRowSumsBelow(boolean value) Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
void | setRowSumsRight(boolean value) Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
void | setSelected(boolean value) Sets a flag indicating whether this sheet is selected.
void | setVerticallyCenter(boolean value) Determines whether the output is vertically centered on the page.
void | setZoom(int numerator, int denominator) Sets the zoom magnication for the sheet.
void | shiftRows(int startRow, int endRow, int n) Shifts rows between startRow and endRow n number of rows.
void | shiftRows(int startRow, int endRow, int n, boolean copyRowHeight, boolean resetOriginalRowHeight) Shifts rows between startRow and endRow n number of rows.
void | showInPane(short toprow, short leftcol) Sets desktop window pane display area, when the file is first opened in a viewer.
void | ungroupColumn(int fromColumn, int toColumn) Ungroup a range of columns that were previously groupped
void | ungroupRow(int fromRow, int toRow) Ungroup a range of rows that were previously groupped
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SXSSFSheet

public SXSSFSheet(SXSSFWorkbook workbook,
                  XSSFSheet xSheet)
           throws java.io.IOException
Throws:
java.io.IOException
Method Detail

getWorksheetXMLInputStream

public java.io.InputStream getWorksheetXMLInputStream()
                                               throws java.io.IOException
Throws:
java.io.IOException

iterator

public java.util.Iterator<Row> iterator()
Specified by:
iterator in interface java.lang.Iterable<Row>

createRow

public Row createRow(int rownum)
Create a new row within the sheet and return the high level representation

Specified by:
createRow in interface Sheet
Parameters:
rownum - row number
Returns:
high level Row object representing a row in the sheet
See Also:
removeRow(Row)

removeRow

public void removeRow(Row row)
Remove a row from this sheet. All cells contained in the row are removed as well

Specified by:
removeRow in interface Sheet
Parameters:
row - representing a row to remove.

getRow

public Row getRow(int rownum)
Returns the logical row (not physical) 0-based. If you ask for a row that is not defined you get a null. This is to say row 4 represents the fifth row on a sheet.

Specified by:
getRow in interface Sheet
Parameters:
rownum - row to get (0-based)
Returns:
Row representing the rownumber or null if its not defined on the sheet

getPhysicalNumberOfRows

public int getPhysicalNumberOfRows()
Returns the number of physically defined rows (NOT the number of rows in the sheet)

Specified by:
getPhysicalNumberOfRows in interface Sheet
Returns:
the number of physically defined rows in this sheet

getFirstRowNum

public int getFirstRowNum()
Gets the first row on the sheet

Specified by:
getFirstRowNum in interface Sheet
Returns:
the number of the first logical row on the sheet (0-based)

getLastRowNum

public int getLastRowNum()
Gets the last row on the sheet

Specified by:
getLastRowNum in interface Sheet
Returns:
last row contained n this sheet (0-based)

setColumnHidden

public void setColumnHidden(int columnIndex,
                            boolean hidden)
Get the visibility state for a given column

Specified by:
setColumnHidden in interface Sheet
Parameters:
columnIndex - - the column to get (0-based)
hidden - - the visiblity state of the column

isColumnHidden

public boolean isColumnHidden(int columnIndex)
Get the hidden state for a given column

Specified by:
isColumnHidden in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
Returns:
hidden - false if the column is visible

setColumnWidth

public void setColumnWidth(int columnIndex,
                           int width)
Set the width (in units of 1/256th of a character width)

The maximum column width for an individual cell is 255 characters. This value represents the number of characters that can be displayed in a cell that is formatted with the standard font.

Specified by:
setColumnWidth in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
width - - the width in units of 1/256th of a character width

getColumnWidth

public int getColumnWidth(int columnIndex)
get the width (in units of 1/256th of a character width )

Specified by:
getColumnWidth in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
Returns:
width - the width in units of 1/256th of a character width

setDefaultColumnWidth

public void setDefaultColumnWidth(int width)
Set the default column width for the sheet (if the columns do not define their own width) in characters

Specified by:
setDefaultColumnWidth in interface Sheet
Parameters:
width - default column width measured in characters

getDefaultColumnWidth

public int getDefaultColumnWidth()
Get the default column width for the sheet (if the columns do not define their own width) in characters

Specified by:
getDefaultColumnWidth in interface Sheet
Returns:
default column width measured in characters

getDefaultRowHeight

public short getDefaultRowHeight()
Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Specified by:
getDefaultRowHeight in interface Sheet
Returns:
default row height measured in twips (1/20 of a point)

getDefaultRowHeightInPoints

public float getDefaultRowHeightInPoints()
Get the default row height for the sheet (if the rows do not define their own height) in points.

Specified by:
getDefaultRowHeightInPoints in interface Sheet
Returns:
default row height in points

setDefaultRowHeight

public void setDefaultRowHeight(short height)
Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Specified by:
setDefaultRowHeight in interface Sheet
Parameters:
height - default row height measured in twips (1/20 of a point)

setDefaultRowHeightInPoints

public void setDefaultRowHeightInPoints(float height)
Set the default row height for the sheet (if the rows do not define their own height) in points

Specified by:
setDefaultRowHeightInPoints in interface Sheet
Parameters:
height - default row height

getColumnStyle

public CellStyle getColumnStyle(int column)
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column

Specified by:
getColumnStyle in interface Sheet

addMergedRegion

public int addMergedRegion(CellRangeAddress region)
Adds a merged region of cells (hence those cells form one)

Specified by:
addMergedRegion in interface Sheet
Parameters:
region - (rowfrom/colfrom-rowto/colto) to merge
Returns:
index of this region

setVerticallyCenter

public void setVerticallyCenter(boolean value)
Determines whether the output is vertically centered on the page.

Specified by:
setVerticallyCenter in interface Sheet
Parameters:
value - true to vertically center, false otherwise.

setHorizontallyCenter

public void setHorizontallyCenter(boolean value)
Determines whether the output is horizontally centered on the page.

Specified by:
setHorizontallyCenter in interface Sheet
Parameters:
value - true to horizontally center, false otherwise.

getHorizontallyCenter

public boolean getHorizontallyCenter()
Determine whether printed output for this sheet will be horizontally centered.

Specified by:
getHorizontallyCenter in interface Sheet

getVerticallyCenter

public boolean getVerticallyCenter()
Determine whether printed output for this sheet will be vertically centered.

Specified by:
getVerticallyCenter in interface Sheet

removeMergedRegion

public void removeMergedRegion(int index)
Removes a merged region of cells (hence letting them free)

Specified by:
removeMergedRegion in interface Sheet
Parameters:
index - of the region to unmerge

getNumMergedRegions

public int getNumMergedRegions()
Returns the number of merged regions

Specified by:
getNumMergedRegions in interface Sheet
Returns:
number of merged regions

getMergedRegion

public CellRangeAddress getMergedRegion(int index)
Returns the merged region at the specified index

Specified by:
getMergedRegion in interface Sheet
Returns:
the merged region at the specified index

rowIterator

public java.util.Iterator<Row> rowIterator()
Returns an iterator of the physical rows

Specified by:
rowIterator in interface Sheet
Returns:
an iterator of the PHYSICAL rows. Meaning the 3rd element may not be the third row if say for instance the second row is undefined.

setAutobreaks

public void setAutobreaks(boolean value)
Flag indicating whether the sheet displays Automatic Page Breaks.

Specified by:
setAutobreaks in interface Sheet
Parameters:
value - true if the sheet displays Automatic Page Breaks.

setDisplayGuts

public void setDisplayGuts(boolean value)
Set whether to display the guts or not

Specified by:
setDisplayGuts in interface Sheet
Parameters:
value - - guts or no guts

setDisplayZeros

public void setDisplayZeros(boolean value)
Set whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

Specified by:
setDisplayZeros in interface Sheet
Parameters:
value - whether to display or hide all zero values on the worksheet

isDisplayZeros

public boolean isDisplayZeros()
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

Specified by:
isDisplayZeros in interface Sheet
Returns:
whether all zero values on the worksheet are displayed

setRightToLeft

public void setRightToLeft(boolean value)
Sets whether the worksheet is displayed from right to left instead of from left to right.

Specified by:
setRightToLeft in interface Sheet
Parameters:
value - true for right to left, false otherwise.

isRightToLeft

public boolean isRightToLeft()
Whether the text is displayed in right-to-left mode in the window

Specified by:
isRightToLeft in interface Sheet
Returns:
whether the text is displayed in right-to-left mode in the window

setFitToPage

public void setFitToPage(boolean value)
Flag indicating whether the Fit to Page print option is enabled.

Specified by:
setFitToPage in interface Sheet
Parameters:
value - true if the Fit to Page print option is enabled.

setRowSumsBelow

public void setRowSumsBelow(boolean value)
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.

When true a summary row is inserted below the detailed data being summarized and a new outline level is established on that row.

When false a summary row is inserted above the detailed data being summarized and a new outline level is established on that row.

Specified by:
setRowSumsBelow in interface Sheet
Parameters:
value - true if row summaries appear below detail in the outline

setRowSumsRight

public void setRowSumsRight(boolean value)
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.

When true a summary column is inserted to the right of the detailed data being summarized and a new outline level is established on that column.

When false a summary column is inserted to the left of the detailed data being summarized and a new outline level is established on that column.

Specified by:
setRowSumsRight in interface Sheet
Parameters:
value - true if col summaries appear right of the detail in the outline

getAutobreaks

public boolean getAutobreaks()
Flag indicating whether the sheet displays Automatic Page Breaks.

Specified by:
getAutobreaks in interface Sheet
Returns:
true if the sheet displays Automatic Page Breaks.

getDisplayGuts

public boolean getDisplayGuts()
Get whether to display the guts or not, default value is true

Specified by:
getDisplayGuts in interface Sheet
Returns:
boolean - guts or no guts

getFitToPage

public boolean getFitToPage()
Flag indicating whether the Fit to Page print option is enabled.

Specified by:
getFitToPage in interface Sheet
Returns:
true if the Fit to Page print option is enabled.

getRowSumsBelow

public boolean getRowSumsBelow()
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.

When true a summary row is inserted below the detailed data being summarized and a new outline level is established on that row.

When false a summary row is inserted above the detailed data being summarized and a new outline level is established on that row.

Specified by:
getRowSumsBelow in interface Sheet
Returns:
true if row summaries appear below detail in the outline

getRowSumsRight

public boolean getRowSumsRight()
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.

When true a summary column is inserted to the right of the detailed data being summarized and a new outline level is established on that column.

When false a summary column is inserted to the left of the detailed data being summarized and a new outline level is established on that column.

Specified by:
getRowSumsRight in interface Sheet
Returns:
true if col summaries appear right of the detail in the outline

isPrintGridlines

public boolean isPrintGridlines()
Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.

Specified by:
isPrintGridlines in interface Sheet
Returns:
true if this sheet displays gridlines.
See Also:
to check if printing of gridlines is turned on or off

setPrintGridlines

public void setPrintGridlines(boolean show)
Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier. To turn printing of gridlines use setPrintGridlines(boolean)

Specified by:
setPrintGridlines in interface Sheet
Parameters:
show - true if this sheet should display gridlines.
See Also:
setPrintGridlines(boolean)

getPrintSetup

public PrintSetup getPrintSetup()
Gets the print setup object.

Specified by:
getPrintSetup in interface Sheet
Returns:
The user model for the print setup object.

getHeader

public Header getHeader()
Gets the user model for the default document header.

Note that XSSF offers more kinds of document headers than HSSF does

Specified by:
getHeader in interface Sheet
Returns:
the document header. Never null

getFooter

public Footer getFooter()
Gets the user model for the default document footer.

Note that XSSF offers more kinds of document footers than HSSF does.

Specified by:
getFooter in interface Sheet
Returns:
the document footer. Never null

setSelected

public void setSelected(boolean value)
Sets a flag indicating whether this sheet is selected.

Note: multiple sheets can be selected, but only one sheet can be active at one time.

Specified by:
setSelected in interface Sheet
Parameters:
value - true if this sheet is selected
See Also:
Workbook.setActiveSheet(int)

getMargin

public double getMargin(short margin)
Gets the size of the margin in inches.

Specified by:
getMargin in interface Sheet
Parameters:
margin - which margin to get
Returns:
the size of the margin

setMargin

public void setMargin(short margin,
                      double size)
Sets the size of the margin in inches.

Specified by:
setMargin in interface Sheet
Parameters:
margin - which margin to get
size - the size of the margin

getProtect

public boolean getProtect()
Answer whether protection is enabled or disabled

Specified by:
getProtect in interface Sheet
Returns:
true => protection enabled; false => protection disabled

protectSheet

public void protectSheet(java.lang.String password)
Sets the protection enabled as well as the password

Specified by:
protectSheet in interface Sheet
Parameters:
password - to set for protection. Pass null to remove protection

getScenarioProtect

public boolean getScenarioProtect()
Answer whether scenario protection is enabled or disabled

Specified by:
getScenarioProtect in interface Sheet
Returns:
true => protection enabled; false => protection disabled

setZoom

public void setZoom(int numerator,
                    int denominator)
Sets the zoom magnication for the sheet. The zoom is expressed as a fraction. For example to express a zoom of 75% use 3 for the numerator and 4 for the denominator.

Specified by:
setZoom in interface Sheet
Parameters:
numerator - The numerator for the zoom magnification.
denominator - The denominator for the zoom magnification.

getTopRow

public short getTopRow()
The top row in the visible view when the sheet is first viewed after opening it in a viewer

Specified by:
getTopRow in interface Sheet
Returns:
short indicating the rownum (0 based) of the top row

getLeftCol

public short getLeftCol()
The left col in the visible view when the sheet is first viewed after opening it in a viewer

Specified by:
getLeftCol in interface Sheet
Returns:
short indicating the rownum (0 based) of the top row

showInPane

public void showInPane(short toprow,
                       short leftcol)
Sets desktop window pane display area, when the file is first opened in a viewer.

Specified by:
showInPane in interface Sheet
Parameters:
toprow - the top row to show in desktop window pane
leftcol - the left column to show in desktop window pane

setForceFormulaRecalculation

public void setForceFormulaRecalculation(boolean value)
Control if Excel should be asked to recalculate all formulas when the workbook is opened, via the "sheetCalcPr fullCalcOnLoad" option. Calculating the formula values with FormulaEvaluator is the recommended solution, but this may be used for certain cases where evaluation in POI is not possible.

Specified by:
setForceFormulaRecalculation in interface Sheet
Parameters:
value - true if the application will perform a full recalculation of this worksheet values when the workbook is opened
See Also:
Workbook.setForceFormulaRecalculation(boolean)

getForceFormulaRecalculation

public boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.

Specified by:
getForceFormulaRecalculation in interface Sheet

shiftRows

public void shiftRows(int startRow,
                      int endRow,
                      int n)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around. Calls shiftRows(startRow, endRow, n, false, false);

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

Specified by:
shiftRows in interface Sheet
Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift

shiftRows

public void shiftRows(int startRow,
                      int endRow,
                      int n,
                      boolean copyRowHeight,
                      boolean resetOriginalRowHeight)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

Specified by:
shiftRows in interface Sheet
Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift
copyRowHeight - whether to copy the row height during the shift
resetOriginalRowHeight - whether to set the original row's height to the default

createFreezePane

public void createFreezePane(int colSplit,
                             int rowSplit,
                             int leftmostColumn,
                             int topRow)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

Specified by:
createFreezePane in interface Sheet
Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.
leftmostColumn - Left column visible in right pane.
topRow - Top row visible in bottom pane

createFreezePane

public void createFreezePane(int colSplit,
                             int rowSplit)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

Specified by:
createFreezePane in interface Sheet
Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.

createSplitPane

public void createSplitPane(int xSplitPos,
                            int ySplitPos,
                            int leftmostColumn,
                            int topRow,
                            int activePane)
Creates a split pane. Any existing freezepane or split pane is overwritten.

Specified by:
createSplitPane in interface Sheet
Parameters:
xSplitPos - Horizonatal position of split (in 1/20th of a point).
ySplitPos - Vertical position of split (in 1/20th of a point).
topRow - Top row visible in bottom pane
leftmostColumn - Left column visible in right pane.
activePane - Active pane. One of: PANE_LOWER_RIGHT, PANE_UPPER_RIGHT, PANE_LOWER_LEFT, PANE_UPPER_LEFT
See Also:
Sheet.PANE_LOWER_LEFT, Sheet.PANE_LOWER_RIGHT, Sheet.PANE_UPPER_LEFT, Sheet.PANE_UPPER_RIGHT

getPaneInformation

public PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze)

Specified by:
getPaneInformation in interface Sheet
Returns:
null if no pane configured, or the pane information.

setDisplayGridlines

public void setDisplayGridlines(boolean show)
Sets whether the gridlines are shown in a viewer

Specified by:
setDisplayGridlines in interface Sheet
Parameters:
show - whether to show gridlines or not

isDisplayGridlines

public boolean isDisplayGridlines()
Returns if gridlines are displayed

Specified by:
isDisplayGridlines in interface Sheet
Returns:
whether gridlines are displayed

setDisplayFormulas

public void setDisplayFormulas(boolean show)
Sets whether the formulas are shown in a viewer

Specified by:
setDisplayFormulas in interface Sheet
Parameters:
show - whether to show formulas or not

isDisplayFormulas

public boolean isDisplayFormulas()
Returns if formulas are displayed

Specified by:
isDisplayFormulas in interface Sheet
Returns:
whether formulas are displayed

setDisplayRowColHeadings

public void setDisplayRowColHeadings(boolean show)
Sets whether the RowColHeadings are shown in a viewer

Specified by:
setDisplayRowColHeadings in interface Sheet
Parameters:
show - whether to show RowColHeadings or not

isDisplayRowColHeadings

public boolean isDisplayRowColHeadings()
Returns if RowColHeadings are displayed.

Specified by:
isDisplayRowColHeadings in interface Sheet
Returns:
whether RowColHeadings are displayed

setRowBreak

public void setRowBreak(int row)
Sets a page break at the indicated row

Specified by:
setRowBreak in interface Sheet
Parameters:
row - FIXME: Document this!

isRowBroken

public boolean isRowBroken(int row)
Determines if there is a page break at the indicated row

Specified by:
isRowBroken in interface Sheet
Parameters:
row - FIXME: Document this!
Returns:
FIXME: Document this!

removeRowBreak

public void removeRowBreak(int row)
Removes the page break at the indicated row

Specified by:
removeRowBreak in interface Sheet
Parameters:
row -

getRowBreaks

public int[] getRowBreaks()
Retrieves all the horizontal page breaks

Specified by:
getRowBreaks in interface Sheet
Returns:
all the horizontal page breaks, or null if there are no row page breaks

getColumnBreaks

public int[] getColumnBreaks()
Retrieves all the vertical page breaks

Specified by:
getColumnBreaks in interface Sheet
Returns:
all the vertical page breaks, or null if there are no column page breaks

setColumnBreak

public void setColumnBreak(int column)
Sets a page break at the indicated column

Specified by:
setColumnBreak in interface Sheet
Parameters:
column -

isColumnBroken

public boolean isColumnBroken(int column)
Determines if there is a page break at the indicated column

Specified by:
isColumnBroken in interface Sheet
Parameters:
column - FIXME: Document this!
Returns:
FIXME: Document this!

removeColumnBreak

public void removeColumnBreak(int column)
Removes a page break at the indicated column

Specified by:
removeColumnBreak in interface Sheet
Parameters:
column -

setColumnGroupCollapsed

public void setColumnGroupCollapsed(int columnNumber,
                                    boolean collapsed)
Expands or collapses a column group.

Specified by:
setColumnGroupCollapsed in interface Sheet
Parameters:
columnNumber - One of the columns in the group.
collapsed - true = collapse group, false = expand group.

groupColumn

public void groupColumn(int fromColumn,
                        int toColumn)
Create an outline for the provided column range.

Specified by:
groupColumn in interface Sheet
Parameters:
fromColumn - beginning of the column range.
toColumn - end of the column range.

ungroupColumn

public void ungroupColumn(int fromColumn,
                          int toColumn)
Ungroup a range of columns that were previously groupped

Specified by:
ungroupColumn in interface Sheet
Parameters:
fromColumn - start column (0-based)
toColumn - end column (0-based)

groupRow

public void groupRow(int fromRow,
                     int toRow)
Tie a range of rows together so that they can be collapsed or expanded

Please note the rows being grouped must be in the current window, if the rows are already flushed then groupRow has no effect.

Correct code:

       Workbook wb = new SXSSFWorkbook(100);  // keep 100 rows in memory
       Sheet sh = wb.createSheet();
       for (int rownum = 0; rownum < 1000; rownum++) {
           Row row = sh.createRow(rownum);
           if(rownum == 200)  {
               sh.groupRow(100, 200);
           }
       }

Incorrect code:

       Workbook wb = new SXSSFWorkbook(100);  // keep 100 rows in memory
       Sheet sh = wb.createSheet();
       for (int rownum = 0; rownum < 1000; rownum++) {
           Row row = sh.createRow(rownum);
       }
       sh.groupRow(100, 200); // the rows in the range [100, 200] are already flushed and groupRows has no effect

Specified by:
groupRow in interface Sheet
Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

ungroupRow

public void ungroupRow(int fromRow,
                       int toRow)
Ungroup a range of rows that were previously groupped

Specified by:
ungroupRow in interface Sheet
Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

setRowGroupCollapsed

public void setRowGroupCollapsed(int row,
                                 boolean collapse)
Set view state of a groupped range of rows

Specified by:
setRowGroupCollapsed in interface Sheet
Parameters:
row - start row of a groupped range of rows (0-based)
collapse - whether to expand/collapse the detail rows

setDefaultColumnStyle

public void setDefaultColumnStyle(int column,
                                  CellStyle style)
Sets the default column style for a given column. POI will only apply this style to new cells added to the sheet.

Specified by:
setDefaultColumnStyle in interface Sheet
Parameters:
column - the column index
style - the style to set

autoSizeColumn

public void autoSizeColumn(int column)
Adjusts the column width to fit the contents.

This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing.

You can specify whether the content of merged cells should be considered or ignored. Default is to ignore merged cells.

Specified by:
autoSizeColumn in interface Sheet
Parameters:
column - the column index

autoSizeColumn

public void autoSizeColumn(int column,
                           boolean useMergedCells)
Adjusts the column width to fit the contents.

This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing.

You can specify whether the content of merged cells should be considered or ignored. Default is to ignore merged cells.

Specified by:
autoSizeColumn in interface Sheet
Parameters:
column - the column index
useMergedCells - whether to use the contents of merged cells when calculating the width of the column

getCellComment

public Comment getCellComment(int row,
                              int column)
Returns cell comment for the specified row and column

Specified by:
getCellComment in interface Sheet
Returns:
cell comment or null if not found

createDrawingPatriarch

public Drawing createDrawingPatriarch()
Creates the top-level drawing patriarch.

Specified by:
createDrawingPatriarch in interface Sheet
Returns:
The new drawing patriarch.

getWorkbook

public Workbook getWorkbook()
Return the parent workbook

Specified by:
getWorkbook in interface Sheet
Returns:
the parent workbook

getSheetName

public java.lang.String getSheetName()
Returns the name of this sheet

Specified by:
getSheetName in interface Sheet
Returns:
the name of this sheet

isSelected

public boolean isSelected()
Note - this is not the same as whether the sheet is focused (isActive)

Specified by:
isSelected in interface Sheet
Returns:
true if this sheet is currently selected

setArrayFormula

public CellRange<? extends Cell> setArrayFormula(java.lang.String formula,
                                                 CellRangeAddress range)
Sets array formula to specified region for result.

Specified by:
setArrayFormula in interface Sheet
Parameters:
formula - text representation of the formula
range - Region of array formula for result.
Returns:
the CellRange of cells affected by this change

removeArrayFormula

public CellRange<? extends Cell> removeArrayFormula(Cell cell)
Remove a Array Formula from this sheet. All cells contained in the Array Formula range are removed as well

Specified by:
removeArrayFormula in interface Sheet
Parameters:
cell - any cell within Array Formula range
Returns:
the CellRange of cells affected by this change

getDataValidationHelper

public DataValidationHelper getDataValidationHelper()
Specified by:
getDataValidationHelper in interface Sheet

addValidationData

public void addValidationData(DataValidation dataValidation)
Creates a data validation object

Specified by:
addValidationData in interface Sheet
Parameters:
dataValidation - The Data validation object settings

setAutoFilter

public AutoFilter setAutoFilter(CellRangeAddress range)
Enable filtering for a range of cells

Specified by:
setAutoFilter in interface Sheet
Parameters:
range - the range of cells to filter

getSheetConditionalFormatting

public SheetConditionalFormatting getSheetConditionalFormatting()
Description copied from interface: Sheet
The 'Conditional Formatting' facet for this Sheet

Specified by:
getSheetConditionalFormatting in interface Sheet
Returns:
conditional formatting rule for this sheet

setRandomAccessWindowSize

public void setRandomAccessWindowSize(int value)
Specifies how many rows can be accessed at most via getRow(). When a new node is created via createRow() and the total number of unflushed records would exeed the specified value, then the row with the lowest index value is flushed and cannot be accessed via getRow() anymore. A value of -1 indicates unlimited access. In this case all records that have not been flushed by a call to flush() are available for random access. A value of 0 is not allowed because it would flush any newly created row without having a chance to specify any cells.

flushRows

public void flushRows(int remaining)
               throws java.io.IOException
Specifies how many rows can be accessed at most via getRow(). The exeeding rows (if any) are flushed to the disk while rows with lower index values are flushed first.

Throws:
java.io.IOException

flushRows

public void flushRows()
               throws java.io.IOException
Flush all rows to disk. After this call no rows can be accessed via getRow()

Throws:
java.io.IOException

changeRowNum

public void changeRowNum(SXSSFRow row,
                         int newRowNum)

getRowNum

public int getRowNum(SXSSFRow row)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SXSSFWorkbook

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.streaming
Class SXSSFWorkbook

java.lang.Object
    extended by  org.apache.poi.xssf.streaming.SXSSFWorkbook
All Implemented Interfaces:
Workbook
public class SXSSFWorkbook
extends java.lang.Object
implements Workbook

Streaming version of XSSFWorkbook implementing the "BigGridDemo" strategy.

Author:
Alex Geller, Four J's Development Tools

Field Summary
static int DEFAULT_WINDOW_SIZE
Specifies how many rows can be accessed at most via getRow().
Fields inherited from interface org.apache.poi.ss.usermodel.Workbook
PICTURE_TYPE_DIB, PICTURE_TYPE_EMF, PICTURE_TYPE_JPEG, PICTURE_TYPE_PICT, PICTURE_TYPE_PNG, PICTURE_TYPE_WMF, SHEET_STATE_HIDDEN, SHEET_STATE_VERY_HIDDEN, SHEET_STATE_VISIBLE
Constructor Summary
SXSSFWorkbook()
Construct a new workbook
SXSSFWorkbook(int rowAccessWindowSize)
Construct an empty workbook and specify the window for row access.
SXSSFWorkbook(XSSFWorkbook workbook)
Construct a workbook from a template.
SXSSFWorkbook(XSSFWorkbook workbook, int rowAccessWindowSize)
Constructs an workbook from an existing workbook.
SXSSFWorkbook(XSSFWorkbook workbook, int rowAccessWindowSize, boolean compressTmpFiles)
Constructs an workbook from an existing workbook.
Method Summary
 int addPicture(byte[] pictureData, int format)
Adds a picture to the workbook.
 void addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.
 Sheet cloneSheet(int sheetNum)
Create an Sheet from an existing sheet in the Workbook.
 CellStyle createCellStyle()
Create a new Cell style and add it to the workbook's style table
 DataFormat createDataFormat()
Returns the instance of DataFormat for this workbook.
 Font createFont()
Create a new Font and add it to the workbook's font table
 Name createName()
Creates a new (uninitialised) defined name in this workbook
 Sheet createSheet()
Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
 Sheet createSheet(java.lang.String sheetname)
Create an Sheet for this Workbook, adds it to the sheets and returns the high level representation.
 Font findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline)
Finds a font that matches the one with the supplied attributes
 int getActiveSheetIndex()
Convenience method to get the active sheet.
 java.util.List<? extends PictureData> getAllPictures()
Gets all pictures from the Workbook.
 CellStyle getCellStyleAt(short idx)
Get the cell style object at the given index
 CreationHelper getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.
 int getFirstVisibleTab()
Gets the first tab that is displayed in the list of tabs in excel.
 Font getFontAt(short idx)
Get the font at the given index number
 boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
 Row.MissingCellPolicy getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.
 Name getName(java.lang.String name)
 Name getNameAt(int nameIndex)
 int getNameIndex(java.lang.String name)
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.
 short getNumberOfFonts()
Get the number of fonts in the font table
 int getNumberOfNames()
 int getNumberOfSheets()
Get the number of spreadsheets in the workbook
 short getNumCellStyles()
Get the number of styles the workbook contains
 java.lang.String getPrintArea(int sheetIndex)
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
 int getRandomAccessWindowSize()
 Sheet getSheet(java.lang.String name)
Get sheet with the given name
 Sheet getSheetAt(int index)
Get the Sheet object at the given index.
 int getSheetIndex(Sheet sheet)
Returns the index of the given sheet
 int getSheetIndex(java.lang.String name)
Returns the index of the sheet by his name
 java.lang.String getSheetName(int sheet)
Set the sheet name
 XSSFWorkbook getXSSFWorkbook()
 boolean isHidden()
 boolean isSheetHidden(int sheetIx)
Check whether a sheet is hidden.
 boolean isSheetVeryHidden(int sheetIx)
Check whether a sheet is very hidden.
 void removeName(int index)
Remove the defined name at the specified index
 void removeName(java.lang.String name)
Remove a defined name by name
 void removePrintArea(int sheetIndex)
Delete the printarea for the sheet specified
 void removeSheetAt(int index)
Removes sheet at the given index
 void setActiveSheet(int sheetIndex)
Convenience method to set the active sheet.
 void setCompressTempFiles(boolean compress)
Set whether temp files should be compressed.
 void setFirstVisibleTab(int sheetIndex)
Sets the first tab that is displayed in the list of tabs in excel.
 void setForceFormulaRecalculation(boolean value)
Whether the application shall perform a full recalculation when the workbook is opened.
 void setHidden(boolean hiddenFlag)
 void setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy)
Sets the policy on what to do when getting missing or blank cells from a row.
 void setPrintArea(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow)
For the Convenience of Java Programmers maintaining pointers.
 void setPrintArea(int sheetIndex, java.lang.String reference)
Sets the printarea for the sheet provided
 void setRepeatingRowsAndColumns(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow)
Sets the repeating rows and columns for a sheet (as found in File->PageSetup->Sheet).
 void setSelectedTab(int index)
Sets the tab whose data is actually seen when the sheet is opened.
 void setSheetHidden(int sheetIx, boolean hidden)
Hide or unhide a sheet
 void setSheetHidden(int sheetIx, int hidden)
Hide or unhide a sheet.
 void setSheetName(int sheet, java.lang.String name)
Set the sheet name.
 void setSheetOrder(java.lang.String sheetname, int pos)
Sets the order of appearance for a given sheet.
 void write(java.io.OutputStream stream)
Write out this workbook to an Outputstream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_WINDOW_SIZE

public static final int DEFAULT_WINDOW_SIZE
Specifies how many rows can be accessed at most via getRow(). When a new node is created via createRow() and the total number of unflushed records would exeed the specified value, then the row with the lowest index value is flushed and cannot be accessed via getRow() anymore.

See Also:
Constant Field Values
Constructor Detail

SXSSFWorkbook

public SXSSFWorkbook()
Construct a new workbook

SXSSFWorkbook

public SXSSFWorkbook(XSSFWorkbook workbook)
Construct a workbook from a template.

There are three use-cases to use SXSSFWorkbook(XSSFWorkbook) :

  1. Append new sheets to existing workbooks. You can open existing workbook from a file or create on the fly with XSSF.
  2. Append rows to existing sheets. The row number MUST be greater than max(rownum) in the template sheet.
  3. Use existing workbook as a template and re-use global objects such as cell styles, formats, images, etc.
All three use cases can work in a combination.

What is not supported:
  • Access initial cells and rows in the template. After constructing SXSSFWorkbook(XSSFWorkbook) all internal windows are empty and SXSSFSheet@getRow and SXSSFRow#getCell return null.
  • Override existing cells and rows. The API silently allows that but the output file is invalid and Excel cannot read it.

Parameters:
workbook - the template workbook

SXSSFWorkbook

public SXSSFWorkbook(XSSFWorkbook workbook,
                     int rowAccessWindowSize)
Constructs an workbook from an existing workbook.

When a new node is created via createRow() and the total number of unflushed records would exceed the specified value, then the row with the lowest index value is flushed and cannot be accessed via getRow() anymore.

A value of -1 indicates unlimited access. In this case all records that have not been flushed by a call to flush() are available for random access.

A value of 0 is not allowed because it would flush any newly created row without having a chance to specify any cells.

Parameters:
rowAccessWindowSize -

SXSSFWorkbook

public SXSSFWorkbook(XSSFWorkbook workbook,
                     int rowAccessWindowSize,
                     boolean compressTmpFiles)
Constructs an workbook from an existing workbook.

When a new node is created via createRow() and the total number of unflushed records would exceed the specified value, then the row with the lowest index value is flushed and cannot be accessed via getRow() anymore.

A value of -1 indicates unlimited access. In this case all records that have not been flushed by a call to flush() are available for random access.

A value of 0 is not allowed because it would flush any newly created row without having a chance to specify any cells.

Parameters:
rowAccessWindowSize -
compressTmpFiles - whether to use gzip compression for temporary files

SXSSFWorkbook

public SXSSFWorkbook(int rowAccessWindowSize)
Construct an empty workbook and specify the window for row access.

When a new node is created via createRow() and the total number of unflushed records would exceed the specified value, then the row with the lowest index value is flushed and cannot be accessed via getRow() anymore.

A value of -1 indicates unlimited access. In this case all records that have not been flushed by a call to flush() are available for random access.

A value of 0 is not allowed because it would flush any newly created row without having a chance to specify any cells.

Parameters:
rowAccessWindowSize -
Method Detail

getRandomAccessWindowSize

public int getRandomAccessWindowSize()

setCompressTempFiles

public void setCompressTempFiles(boolean compress)
Set whether temp files should be compressed.

SXSSF writes sheet data in temporary files (a temp file per-sheet) and the size of these temp files can grow to to a very large size, e.g. for a 20 MB csv data the size of the temp xml file become few GB large. If the "compress" flag is set to true then the temporary XML is gzipped.

Please note the the "compress" option may cause performance penalty.

Parameters:
compress - whether to compress temp files

getXSSFWorkbook

public XSSFWorkbook getXSSFWorkbook()

getActiveSheetIndex

public int getActiveSheetIndex()
Convenience method to get the active sheet. The active sheet is is the sheet which is currently displayed when the workbook is viewed in Excel. 'Selected' sheet(s) is a distinct concept.

Specified by:
getActiveSheetIndex in interface Workbook
Returns:
the index of the active sheet (0-based)

setActiveSheet

public void setActiveSheet(int sheetIndex)
Convenience method to set the active sheet. The active sheet is is the sheet which is currently displayed when the workbook is viewed in Excel. 'Selected' sheet(s) is a distinct concept.

Specified by:
setActiveSheet in interface Workbook
Parameters:
sheetIndex - index of the active sheet (0-based)

getFirstVisibleTab

public int getFirstVisibleTab()
Gets the first tab that is displayed in the list of tabs in excel.

Specified by:
getFirstVisibleTab in interface Workbook
Returns:
the first tab that to display in the list of tabs (0-based).

setFirstVisibleTab

public void setFirstVisibleTab(int sheetIndex)
Sets the first tab that is displayed in the list of tabs in excel.

Specified by:
setFirstVisibleTab in interface Workbook
Parameters:
sheetIndex - the first tab that to display in the list of tabs (0-based)

setSheetOrder

public void setSheetOrder(java.lang.String sheetname,
                          int pos)
Sets the order of appearance for a given sheet.

Specified by:
setSheetOrder in interface Workbook
Parameters:
sheetname - the name of the sheet to reorder
pos - the position that we want to insert the sheet into (0 based)

setSelectedTab

public void setSelectedTab(int index)
Sets the tab whose data is actually seen when the sheet is opened. This may be different from the "selected sheet" since excel seems to allow you to show the data of one sheet when another is seen "selected" in the tabs (at the bottom).

Specified by:
setSelectedTab in interface Workbook
Parameters:
index - the index of the sheet to select (0 based)
See Also:
Sheet.setSelected(boolean)

setSheetName

public void setSheetName(int sheet,
                         java.lang.String name)
Set the sheet name.

Specified by:
setSheetName in interface Workbook
Parameters:
sheet - number (0 based)
Throws:
java.lang.IllegalArgumentException - if the name is greater than 31 chars or contains /\?*[]
See Also:
Workbook.createSheet(String), WorkbookUtil.createSafeSheetName(String nameProposal)

getSheetName

public java.lang.String getSheetName(int sheet)
Set the sheet name

Specified by:
getSheetName in interface Workbook
Parameters:
sheet - sheet number (0 based)
Returns:
Sheet name

getSheetIndex

public int getSheetIndex(java.lang.String name)
Returns the index of the sheet by his name

Specified by:
getSheetIndex in interface Workbook
Parameters:
name - the sheet name
Returns:
index of the sheet (0 based)

getSheetIndex

public int getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Specified by:
getSheetIndex in interface Workbook
Parameters:
sheet - the sheet to look up
Returns:
index of the sheet (0 based)

createSheet

public Sheet createSheet()
Sreate an Sheet for this Workbook, adds it to the sheets and returns the high level representation. Use this to create new sheets.

Specified by:
createSheet in interface Workbook
Returns:
Sheet representing the new sheet.

createSheet

public Sheet createSheet(java.lang.String sheetname)
Create an Sheet for this Workbook, adds it to the sheets and returns the high level representation. Use this to create new sheets.

Specified by:
createSheet in interface Workbook
Parameters:
sheetname - sheetname to set for the sheet.
Returns:
Sheet representing the new sheet.
Throws:
java.lang.IllegalArgumentException - if the name is greater than 31 chars or contains /\?*[]
See Also:
WorkbookUtil.createSafeSheetName(String nameProposal)

cloneSheet

public Sheet cloneSheet(int sheetNum)
Create an Sheet from an existing sheet in the Workbook.

Specified by:
cloneSheet in interface Workbook
Returns:
Sheet representing the cloned sheet.

getNumberOfSheets

public int getNumberOfSheets()
Get the number of spreadsheets in the workbook

Specified by:
getNumberOfSheets in interface Workbook
Returns:
the number of sheets

getSheetAt

public Sheet getSheetAt(int index)
Get the Sheet object at the given index.

Specified by:
getSheetAt in interface Workbook
Parameters:
index - of the sheet number (0-based physical & logical)
Returns:
Sheet at the provided index

getSheet

public Sheet getSheet(java.lang.String name)
Get sheet with the given name

Specified by:
getSheet in interface Workbook
Parameters:
name - of the sheet
Returns:
Sheet with the name provided or null if it does not exist

removeSheetAt

public void removeSheetAt(int index)
Removes sheet at the given index

Specified by:
removeSheetAt in interface Workbook
Parameters:
index - of the sheet to remove (0-based)

setRepeatingRowsAndColumns

public void setRepeatingRowsAndColumns(int sheetIndex,
                                       int startColumn,
                                       int endColumn,
                                       int startRow,
                                       int endRow)
Sets the repeating rows and columns for a sheet (as found in File->PageSetup->Sheet). This is function is included in the workbook because it creates/modifies name records which are stored at the workbook level.

To set just repeating columns:

  workbook.setRepeatingRowsAndColumns(0,0,1,-1-1);
To set just repeating rows:
  workbook.setRepeatingRowsAndColumns(0,-1,-1,0,4);
To remove all repeating rows and columns for a sheet.
  workbook.setRepeatingRowsAndColumns(0,-1,-1,-1,-1);

Specified by:
setRepeatingRowsAndColumns in interface Workbook
Parameters:
sheetIndex - 0 based index to sheet.
startColumn - 0 based start of repeating columns.
endColumn - 0 based end of repeating columns.
startRow - 0 based start of repeating rows.
endRow - 0 based end of repeating rows.

createFont

public Font createFont()
Create a new Font and add it to the workbook's font table

Specified by:
createFont in interface Workbook
Returns:
new font object

findFont

public Font findFont(short boldWeight,
                     short color,
                     short fontHeight,
                     java.lang.String name,
                     boolean italic,
                     boolean strikeout,
                     short typeOffset,
                     byte underline)
Finds a font that matches the one with the supplied attributes

Specified by:
findFont in interface Workbook
Returns:
the font with the matched attributes or null

getNumberOfFonts

public short getNumberOfFonts()
Get the number of fonts in the font table

Specified by:
getNumberOfFonts in interface Workbook
Returns:
number of fonts

getFontAt

public Font getFontAt(short idx)
Get the font at the given index number

Specified by:
getFontAt in interface Workbook
Parameters:
idx - index number (0-based)
Returns:
font at the index

createCellStyle

public CellStyle createCellStyle()
Create a new Cell style and add it to the workbook's style table

Specified by:
createCellStyle in interface Workbook
Returns:
the new Cell Style object

getNumCellStyles

public short getNumCellStyles()
Get the number of styles the workbook contains

Specified by:
getNumCellStyles in interface Workbook
Returns:
count of cell styles

getCellStyleAt

public CellStyle getCellStyleAt(short idx)
Get the cell style object at the given index

Specified by:
getCellStyleAt in interface Workbook
Parameters:
idx - index within the set of styles (0-based)
Returns:
CellStyle object at the index

write

public void write(java.io.OutputStream stream)
           throws java.io.IOException
Write out this workbook to an Outputstream.

Specified by:
write in interface Workbook
Parameters:
stream - - the java OutputStream you wish to write to
Throws:
java.io.IOException - if anything can't be written.

getNumberOfNames

public int getNumberOfNames()
Specified by:
getNumberOfNames in interface Workbook
Returns:
the total number of defined names in this workbook

getName

public Name getName(java.lang.String name)
Specified by:
getName in interface Workbook
Parameters:
name - the name of the defined name
Returns:
the defined name with the specified name. null if not found.

getNameAt

public Name getNameAt(int nameIndex)
Specified by:
getNameAt in interface Workbook
Parameters:
nameIndex - position of the named range (0-based)
Returns:
the defined name at the specified index
Throws:
java.lang.IllegalArgumentException - if the supplied index is invalid

createName

public Name createName()
Creates a new (uninitialised) defined name in this workbook

Specified by:
createName in interface Workbook
Returns:
new defined name object

getNameIndex

public int getNameIndex(java.lang.String name)
Gets the defined name index by name
Note: Excel defined names are case-insensitive and this method performs a case-insensitive search.

Specified by:
getNameIndex in interface Workbook
Parameters:
name - the name of the defined name
Returns:
zero based index of the defined name. -1 if not found.

removeName

public void removeName(int index)
Remove the defined name at the specified index

Specified by:
removeName in interface Workbook
Parameters:
index - named range index (0 based)

removeName

public void removeName(java.lang.String name)
Remove a defined name by name

Specified by:
removeName in interface Workbook
Parameters:
name - the name of the defined name

setPrintArea

public void setPrintArea(int sheetIndex,
                         java.lang.String reference)
Sets the printarea for the sheet provided

i.e. Reference = $A$1:$B$2

Specified by:
setPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
reference - Valid name Reference for the Print Area

setPrintArea

public void setPrintArea(int sheetIndex,
                         int startColumn,
                         int endColumn,
                         int startRow,
                         int endRow)
For the Convenience of Java Programmers maintaining pointers.

Specified by:
setPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 = First Sheet)
startColumn - Column to begin printarea
endColumn - Column to end the printarea
startRow - Row to begin the printarea
endRow - Row to end the printarea
See Also:
setPrintArea(int, String)

getPrintArea

public java.lang.String getPrintArea(int sheetIndex)
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.

Specified by:
getPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
Returns:
String Null if no print area has been defined

removePrintArea

public void removePrintArea(int sheetIndex)
Delete the printarea for the sheet specified

Specified by:
removePrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 = First Sheet)

getMissingCellPolicy

public Row.MissingCellPolicy getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row.

The default is to return blank and null cells. Row.MissingCellPolicy

Specified by:
getMissingCellPolicy in interface Workbook

setMissingCellPolicy

public void setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy)
Sets the policy on what to do when getting missing or blank cells from a row. This will then apply to all calls to Row.getCell(int). See Row.MissingCellPolicy

Specified by:
setMissingCellPolicy in interface Workbook

createDataFormat

public DataFormat createDataFormat()
Returns the instance of DataFormat for this workbook.

Specified by:
createDataFormat in interface Workbook
Returns:
the DataFormat object

addPicture

public int addPicture(byte[] pictureData,
                      int format)
Adds a picture to the workbook.

Specified by:
addPicture in interface Workbook
Parameters:
pictureData - The bytes of the picture
format - The format of the picture.
Returns:
the index to this picture (1 based).
See Also:
Workbook.PICTURE_TYPE_EMF, Workbook.PICTURE_TYPE_WMF, Workbook.PICTURE_TYPE_PICT, Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PNG, Workbook.PICTURE_TYPE_DIB

getAllPictures

public java.util.List<? extends PictureData> getAllPictures()
Gets all pictures from the Workbook.

Specified by:
getAllPictures in interface Workbook
Returns:
the list of pictures (a list of PictureData objects.)

getCreationHelper

public CreationHelper getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances one needs for HSSF and XSSF.

Specified by:
getCreationHelper in interface Workbook

isHidden

public boolean isHidden()
Specified by:
isHidden in interface Workbook
Returns:
false if this workbook is not visible in the GUI

setHidden

public void setHidden(boolean hiddenFlag)
Specified by:
setHidden in interface Workbook
Parameters:
hiddenFlag - pass false to make the workbook visible in the GUI

isSheetHidden

public boolean isSheetHidden(int sheetIx)
Check whether a sheet is hidden.

Note that a sheet could instead be set to be very hidden, which is different (isSheetVeryHidden(int))

Specified by:
isSheetHidden in interface Workbook
Parameters:
sheetIx - Number
Returns:
true if sheet is hidden

isSheetVeryHidden

public boolean isSheetVeryHidden(int sheetIx)
Check whether a sheet is very hidden.

This is different from the normal hidden status (isSheetHidden(int))

Specified by:
isSheetVeryHidden in interface Workbook
Parameters:
sheetIx - sheet index to check
Returns:
true if sheet is very hidden

setSheetHidden

public void setSheetHidden(int sheetIx,
                           boolean hidden)
Hide or unhide a sheet

Specified by:
setSheetHidden in interface Workbook
Parameters:
sheetIx - the sheet index (0-based)
hidden - True to mark the sheet as hidden, false otherwise

setSheetHidden

public void setSheetHidden(int sheetIx,
                           int hidden)
Hide or unhide a sheet.
  • 0 - visible.
  • 1 - hidden.
  • 2 - very hidden.

Specified by:
setSheetHidden in interface Workbook
Parameters:
sheetIx - the sheet index (0-based)
hidden - one of the following Workbook constants: Workbook.SHEET_STATE_VISIBLE, Workbook.SHEET_STATE_HIDDEN, or Workbook.SHEET_STATE_VERY_HIDDEN.
Throws:
java.lang.IllegalArgumentException - if the supplied sheet index or state is invalid

addToolPack

public void addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.

Specified by:
addToolPack in interface Workbook
Parameters:
toopack - the toolpack to register

setForceFormulaRecalculation

public void setForceFormulaRecalculation(boolean value)
Whether the application shall perform a full recalculation when the workbook is opened.

Typically you want to force formula recalculation when you modify cell formulas or values of a workbook previously created by Excel. When set to 0, this flag will tell Excel that it needs to recalculate all formulas in the workbook the next time the file is opened.

Specified by:
setForceFormulaRecalculation in interface Workbook
Parameters:
value - true if the application will perform a full recalculation of workbook values when the workbook is opened
Since:
3.8

getForceFormulaRecalculation

public boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.

Specified by:
getForceFormulaRecalculation in interface Workbook
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.streaming.GZIPSheetDataWriter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.GZIPSheetDataWriter

No usage of org.apache.poi.xssf.streaming.GZIPSheetDataWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.streaming.SheetDataWriter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.SheetDataWriter

Packages that use SheetDataWriter
org.apache.poi.xssf.streaming

Uses of SheetDataWriter in org.apache.poi.xssf.streaming

Subclasses of SheetDataWriter in org.apache.poi.xssf.streaming
 class GZIPSheetDataWriter
Sheet writer that supports gzip compression of the temp files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.streaming.SXSSFCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.SXSSFCell

No usage of org.apache.poi.xssf.streaming.SXSSFCell

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.streaming.SXSSFRow.CellIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.SXSSFRow.CellIterator

No usage of org.apache.poi.xssf.streaming.SXSSFRow.CellIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator

No usage of org.apache.poi.xssf.streaming.SXSSFRow.FilledCellIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.streaming.SXSSFRow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.SXSSFRow

Packages that use SXSSFRow
org.apache.poi.xssf.streaming

Uses of SXSSFRow in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming with parameters of type SXSSFRow
void | SXSSFSheet.changeRowNum(SXSSFRow row, int newRowNum)
int | SXSSFSheet.getRowNum(SXSSFRow row)
void | SheetDataWriter.writeRow(int rownum, SXSSFRow row) Write a row to the file

Constructors in org.apache.poi.xssf.streaming with parameters of type SXSSFRow
SXSSFCell(SXSSFRow row, int cellType)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.streaming.SXSSFSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.SXSSFSheet

Packages that use SXSSFSheet
org.apache.poi.xssf.streaming

Uses of SXSSFSheet in org.apache.poi.xssf.streaming

Constructors in org.apache.poi.xssf.streaming with parameters of type SXSSFSheet
SXSSFRow(SXSSFSheet sheet, int initialSize)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.streaming.SXSSFWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.streaming.SXSSFWorkbook

Packages that use SXSSFWorkbook
org.apache.poi.xssf.streaming

Uses of SXSSFWorkbook in org.apache.poi.xssf.streaming

Constructors in org.apache.poi.xssf.streaming with parameters of type SXSSFWorkbook
SXSSFSheet(SXSSFWorkbook workbook, XSSFSheet xSheet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xssf.usermodel
Classes
XSSFAnchor
XSSFAutoFilter
XSSFBorderFormatting
XSSFCell
XSSFCellStyle
XSSFChart
XSSFChartSheet
XSSFChildAnchor
XSSFClientAnchor
XSSFColor
XSSFComment
XSSFConditionalFormatting
XSSFConditionalFormattingRule
XSSFConnector
XSSFCreationHelper
XSSFDataFormat
XSSFDataValidation
XSSFDataValidationConstraint
XSSFDataValidationHelper
XSSFDialogsheet
XSSFDrawing
XSSFEvaluationWorkbook
XSSFEvenFooter
XSSFEvenHeader
XSSFFactory
XSSFFirstFooter
XSSFFirstHeader
XSSFFont
XSSFFontFormatting
XSSFFormulaEvaluator
XSSFGraphicFrame
XSSFHyperlink
XSSFMap
XSSFName
XSSFOddFooter
XSSFOddHeader
XSSFPatternFormatting
XSSFPicture
XSSFPictureData
XSSFPrintSetup
XSSFRelation
XSSFRichTextString
XSSFRow
XSSFShape
XSSFShapeGroup
XSSFSheet
XSSFSheetConditionalFormatting
XSSFSimpleShape
XSSFTable
XSSFTextBox
XSSFVMLDrawing
XSSFWorkbook


org.apache.poi.xssf.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.usermodel

Class Summary
XSSFAnchor | An anchor is what specifics the position of a shape within a client object or within another containing shape.
XSSFAutoFilter | Represents autofiltering for the specified worksheet.
XSSFBorderFormatting |
XSSFCell | High level representation of a cell in a row of a spreadsheet.
XSSFCellStyle | High level representation of the the possible formatting information for the contents of the cells on a sheet in a SpreadsheetML document.
XSSFChart | Represents a SpreadsheetML Chart
XSSFChartSheet | High level representation of Sheet Parts that are of type 'chartsheet'.
XSSFChildAnchor |
XSSFClientAnchor | A client anchor is attached to an excel worksheet.
XSSFColor | Represents a color in SpreadsheetML
XSSFComment |
XSSFConditionalFormatting |
XSSFConditionalFormattingRule |
XSSFConnector | A connection shape drawing element.
XSSFCreationHelper |
XSSFDataFormat | Handles data formats for XSSF.
XSSFDataValidation |
XSSFDataValidationConstraint |
XSSFDataValidationHelper |
XSSFDialogsheet |
XSSFDrawing | Represents a SpreadsheetML drawing
XSSFEvaluationWorkbook | Internal POI use only
XSSFEvenFooter | Even page footer value.
XSSFEvenHeader | Even page header value.
XSSFFactory | Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSSFFirstFooter | First page footer content.
XSSFFirstHeader | First page header content.
XSSFFont | Represents a font used in a workbook.
XSSFFontFormatting |
XSSFFormulaEvaluator | Evaluates formula cells. For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.
XSSFGraphicFrame | Represents DrawingML GraphicalObjectFrame.
XSSFHyperlink | XSSF Implementation of a Hyperlink.
XSSFMap | This class implements the Map element (Open Office XML Part 4: chapter 3.16.2) This element contains all of the properties related to the XML map, and the behaviors expected during data refresh operations.
XSSFName | Represents a defined named range in a SpreadsheetML workbook.
XSSFOddFooter | Odd page footer value.
XSSFOddHeader | Odd page header value.
XSSFPatternFormatting |
XSSFPicture | Represents a picture shape in a SpreadsheetML drawing.
XSSFPictureData | Raw picture data, normally attached to a SpreadsheetML Drawing.
XSSFPrintSetup | Page setup and page margins settings for the worksheet.
XSSFRelation |
XSSFRichTextString | Rich text unicode string.
XSSFRow | High level representation of a row of a spreadsheet.
XSSFShape | Represents a shape in a SpreadsheetML drawing.
XSSFShapeGroup | This object specifies a group shape that represents many shapes grouped together.
XSSFSheet | High level representation of a SpreadsheetML worksheet.
XSSFSheetConditionalFormatting |
XSSFSimpleShape | Represents a shape with a predefined geometry in a SpreadsheetML drawing.
XSSFTable | This class implements the Table Part (Open Office XML Part 4: chapter 3.5.1) This implementation works under the assumption that a table contains mappings to a subtree of an XML.
XSSFTextBox | Represents a text box in a SpreadsheetML drawing.
XSSFVMLDrawing | Represents a SpreadsheetML VML drawing.
XSSFWorkbook | High level representation of a SpreadsheetML workbook.


org.apache.poi.xssf.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.usermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POIXMLDocumentPart
      • org.apache.poi.POIXMLDocument
        • org.apache.poi.xssf.usermodel.XSSFWorkbook (implements java.lang.Iterable<T>, org.apache.poi.ss.usermodel.Workbook)
      • org.apache.poi.xssf.usermodel.XSSFChart (implements org.apache.poi.ss.usermodel.Chart, org.apache.poi.ss.usermodel.charts.ChartAxisFactory)
      • org.apache.poi.xssf.usermodel.XSSFDrawing (implements org.apache.poi.ss.usermodel.Drawing)
      • org.apache.poi.xssf.usermodel.XSSFPictureData (implements org.apache.poi.ss.usermodel.PictureData)
      • org.apache.poi.xssf.usermodel.XSSFSheet (implements org.apache.poi.ss.usermodel.Sheet)
        • org.apache.poi.xssf.usermodel.XSSFChartSheet
        • org.apache.poi.xssf.usermodel.XSSFDialogsheet (implements org.apache.poi.ss.usermodel.Sheet)
      • org.apache.poi.xssf.usermodel.XSSFTable
      • org.apache.poi.xssf.usermodel.XSSFVMLDrawing
    • org.apache.poi.POIXMLFactory
      • org.apache.poi.xssf.usermodel.XSSFFactory
    • org.apache.poi.POIXMLRelation
      • org.apache.poi.xssf.usermodel.XSSFRelation
    • org.apache.poi.xssf.usermodel.XSSFAnchor
      • org.apache.poi.xssf.usermodel.XSSFChildAnchor
      • org.apache.poi.xssf.usermodel.XSSFClientAnchor (implements org.apache.poi.ss.usermodel.ClientAnchor)
    • org.apache.poi.xssf.usermodel.XSSFAutoFilter (implements org.apache.poi.ss.usermodel.AutoFilter)
    • org.apache.poi.xssf.usermodel.XSSFBorderFormatting (implements org.apache.poi.ss.usermodel.BorderFormatting)
    • org.apache.poi.xssf.usermodel.XSSFCell (implements org.apache.poi.ss.usermodel.Cell)
    • org.apache.poi.xssf.usermodel.XSSFCellStyle (implements org.apache.poi.ss.usermodel.CellStyle)
    • org.apache.poi.xssf.usermodel.XSSFColor (implements org.apache.poi.ss.usermodel.Color)
    • org.apache.poi.xssf.usermodel.XSSFComment (implements org.apache.poi.ss.usermodel.Comment)
    • org.apache.poi.xssf.usermodel.XSSFConditionalFormatting (implements org.apache.poi.ss.usermodel.ConditionalFormatting)
    • org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule (implements org.apache.poi.ss.usermodel.ConditionalFormattingRule)
    • org.apache.poi.xssf.usermodel.XSSFCreationHelper (implements org.apache.poi.ss.usermodel.CreationHelper)
    • org.apache.poi.xssf.usermodel.XSSFDataFormat (implements org.apache.poi.ss.usermodel.DataFormat)
    • org.apache.poi.xssf.usermodel.XSSFDataValidation (implements org.apache.poi.ss.usermodel.DataValidation)
    • org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint (implements org.apache.poi.ss.usermodel.DataValidationConstraint)
    • org.apache.poi.xssf.usermodel.XSSFDataValidationHelper (implements org.apache.poi.ss.usermodel.DataValidationHelper)
    • org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook (implements org.apache.poi.ss.formula.EvaluationWorkbook, org.apache.poi.ss.formula.FormulaParsingWorkbook, org.apache.poi.ss.formula.FormulaRenderingWorkbook)
    • org.apache.poi.xssf.usermodel.XSSFFont (implements org.apache.poi.ss.usermodel.Font)
    • org.apache.poi.xssf.usermodel.XSSFFontFormatting (implements org.apache.poi.ss.usermodel.FontFormatting)
    • org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator (implements org.apache.poi.ss.usermodel.FormulaEvaluator)
    • org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter (implements org.apache.poi.ss.usermodel.HeaderFooter)
      • org.apache.poi.xssf.usermodel.XSSFEvenFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.xssf.usermodel.XSSFEvenHeader (implements org.apache.poi.ss.usermodel.Header)
      • org.apache.poi.xssf.usermodel.XSSFFirstFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.xssf.usermodel.XSSFFirstHeader (implements org.apache.poi.ss.usermodel.Header)
      • org.apache.poi.xssf.usermodel.XSSFOddFooter (implements org.apache.poi.ss.usermodel.Footer)
      • org.apache.poi.xssf.usermodel.XSSFOddHeader (implements org.apache.poi.ss.usermodel.Header)
    • org.apache.poi.xssf.usermodel.XSSFHyperlink (implements org.apache.poi.ss.usermodel.Hyperlink)
    • org.apache.poi.xssf.usermodel.XSSFMap
    • org.apache.poi.xssf.usermodel.XSSFName (implements org.apache.poi.ss.usermodel.Name)
    • org.apache.poi.xssf.usermodel.XSSFPatternFormatting (implements org.apache.poi.ss.usermodel.PatternFormatting)
    • org.apache.poi.xssf.usermodel.XSSFPrintSetup (implements org.apache.poi.ss.usermodel.PrintSetup)
    • org.apache.poi.xssf.usermodel.XSSFRichTextString (implements org.apache.poi.ss.usermodel.RichTextString)
    • org.apache.poi.xssf.usermodel.XSSFRow (implements java.lang.Comparable<T>, org.apache.poi.ss.usermodel.Row)
    • org.apache.poi.xssf.usermodel.XSSFShape
      • org.apache.poi.xssf.usermodel.XSSFConnector
      • org.apache.poi.xssf.usermodel.XSSFGraphicFrame
      • org.apache.poi.xssf.usermodel.XSSFPicture (implements org.apache.poi.ss.usermodel.Picture)
      • org.apache.poi.xssf.usermodel.XSSFShapeGroup
      • org.apache.poi.xssf.usermodel.XSSFSimpleShape
        • org.apache.poi.xssf.usermodel.XSSFTextBox
    • org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting (implements org.apache.poi.ss.usermodel.SheetConditionalFormatting)


Uses of Package org.apache.poi.xssf.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.usermodel

Packages that use org.apache.poi.xssf.usermodel
org.apache.poi.xssf.extractor
org.apache.poi.xssf.model
org.apache.poi.xssf.streaming
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts
org.apache.poi.xssf.usermodel.extensions
org.apache.poi.xssf.usermodel.helpers

Classes in org.apache.poi.xssf.usermodel used by org.apache.poi.xssf.extractor
XSSFMap
This class implements the Map element (Open Office XML Part 4: chapter 3.16.2)

This element contains all of the properties related to the XML map, and the behaviors expected during data refresh operations.

XSSFRelation
XSSFWorkbook
High level representation of a SpreadsheetML workbook.

Classes in org.apache.poi.xssf.usermodel used by org.apache.poi.xssf.model
XSSFCellStyle
High level representation of the the possible formatting information for the contents of the cells on a sheet in a SpreadsheetML document.
XSSFColor
Represents a color in SpreadsheetML
XSSFComment
XSSFFont
Represents a font used in a workbook.
XSSFMap
This class implements the Map element (Open Office XML Part 4: chapter 3.16.2)

This element contains all of the properties related to the XML map, and the behaviors expected during data refresh operations.

XSSFSheet
High level representation of a SpreadsheetML worksheet.
XSSFWorkbook
High level representation of a SpreadsheetML workbook.

Classes in org.apache.poi.xssf.usermodel used by org.apache.poi.xssf.streaming
XSSFSheet
High level representation of a SpreadsheetML worksheet.
XSSFWorkbook
High level representation of a SpreadsheetML workbook.

Classes in org.apache.poi.xssf.usermodel used by org.apache.poi.xssf.usermodel
XSSFAnchor
An anchor is what specifics the position of a shape within a client object or within another containing shape.
XSSFAutoFilter
Represents autofiltering for the specified worksheet.
XSSFBorderFormatting
XSSFCell
High level representation of a cell in a row of a spreadsheet.
XSSFCellStyle
High level representation of the the possible formatting information for the contents of the cells on a sheet in a SpreadsheetML document.
XSSFChart
Represents a SpreadsheetML Chart
XSSFChildAnchor
XSSFClientAnchor
A client anchor is attached to an excel worksheet.
XSSFColor
Represents a color in SpreadsheetML
XSSFComment
XSSFConditionalFormatting
XSSFConditionalFormattingRule
XSSFConnector
A connection shape drawing element.
XSSFCreationHelper
XSSFDataFormat
Handles data formats for XSSF.
XSSFDataValidation
XSSFDataValidationConstraint
XSSFDialogsheet
XSSFDrawing
Represents a SpreadsheetML drawing
XSSFEvaluationWorkbook
Internal POI use only
XSSFFactory
Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type
XSSFFont
Represents a font used in a workbook.
XSSFFontFormatting
XSSFFormulaEvaluator
Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values.

XSSFGraphicFrame
Represents DrawingML GraphicalObjectFrame.
XSSFHyperlink
XSSF Implementation of a Hyperlink.
XSSFMap
This class implements the Map element (Open Office XML Part 4: chapter 3.16.2)

This element contains all of the properties related to the XML map, and the behaviors expected during data refresh operations.

XSSFName
Represents a defined named range in a SpreadsheetML workbook.
XSSFPatternFormatting
XSSFPicture
Represents a picture shape in a SpreadsheetML drawing.
XSSFPictureData
Raw picture data, normally attached to a SpreadsheetML Drawing.
XSSFPrintSetup
Page setup and page margins settings for the worksheet.
XSSFRelation
XSSFRichTextString
Rich text unicode string.
XSSFRow
High level representation of a row of a spreadsheet.
XSSFShape
Represents a shape in a SpreadsheetML drawing.
XSSFShapeGroup
This object specifies a group shape that represents many shapes grouped together.
XSSFSheet
High level representation of a SpreadsheetML worksheet.
XSSFSheetConditionalFormatting
XSSFSimpleShape
Represents a shape with a predefined geometry in a SpreadsheetML drawing.
XSSFTable
This class implements the Table Part (Open Office XML Part 4: chapter 3.5.1) This implementation works under the assumption that a table contains mappings to a subtree of an XML.
XSSFTextBox
Represents a text box in a SpreadsheetML drawing.
XSSFVMLDrawing
Represents a SpreadsheetML VML drawing.
XSSFWorkbook
High level representation of a SpreadsheetML workbook.

Classes in org.apache.poi.xssf.usermodel used by org.apache.poi.xssf.usermodel.charts
XSSFChart
Represents a SpreadsheetML Chart

Classes in org.apache.poi.xssf.usermodel used by org.apache.poi.xssf.usermodel.extensions
XSSFColor
Represents a color in SpreadsheetML

Classes in org.apache.poi.xssf.usermodel used by org.apache.poi.xssf.usermodel.helpers
XSSFCell
High level representation of a cell in a row of a spreadsheet.
XSSFSheet
High level representation of a SpreadsheetML worksheet.
XSSFTable
This class implements the Table Part (Open Office XML Part 4: chapter 3.5.1) This implementation works under the assumption that a table contains mappings to a subtree of an XML.
XSSFWorkbook
High level representation of a SpreadsheetML workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSSFAnchor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFAnchor

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFAnchor
Direct Known Subclasses:
XSSFChildAnchor, XSSFClientAnchor
public abstract class XSSFAnchor
extends java.lang.Object

An anchor is what specifics the position of a shape within a client object or within another containing shape.

Author:
Yegor Kozlov

Constructor Summary
XSSFAnchor()
Method Summary
abstract int | getDx1()
abstract int | getDx2()
abstract int | getDy1()
abstract int | getDy2()
abstract void | setDx1(int dx1)
abstract void | setDx2(int dx2)
abstract void | setDy1(int dy1)
abstract void | setDy2(int dy2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFAnchor

public XSSFAnchor()
Method Detail

getDx1

public abstract int getDx1()

setDx1

public abstract void setDx1(int dx1)

getDy1

public abstract int getDy1()

setDy1

public abstract void setDy1(int dy1)

getDy2

public abstract int getDy2()

setDy2

public abstract void setDy2(int dy2)

getDx2

public abstract int getDx2()

setDx2

public abstract void setDx2(int dx2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XSSFAutoFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFAutoFilter

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFAutoFilter
All Implemented Interfaces:
AutoFilter
public final class XSSFAutoFilter
extends java.lang.Object
implements AutoFilter

Represents autofiltering for the specified worksheet.

Author:
Yegor Kozlov

Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFBorderFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFBorderFormatting

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFBorderFormatting
All Implemented Interfaces:
BorderFormatting
public class XSSFBorderFormatting
extends java.lang.Object
implements BorderFormatting

Author:
Yegor Kozlov

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.BorderFormatting
BORDER_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_DASHED, BORDER_DOTTED, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM, BORDER_MEDIUM_DASH_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_MEDIUM_DASHED, BORDER_NONE, BORDER_SLANTED_DASH_DOT, BORDER_THICK, BORDER_THIN
Method Summary
short | getBorderBottom()
short | getBorderDiagonal()
short | getBorderLeft()
short | getBorderRight()
short | getBorderTop()
short | getBottomBorderColor()
short | getDiagonalBorderColor()
short | getLeftBorderColor()
short | getRightBorderColor()
short | getTopBorderColor()
void | setBorderBottom(short border)
void | setBorderDiagonal(short border) Set diagonal border.
void | setBorderLeft(short border) Set left border.
void | setBorderRight(short border) Set right border.
void | setBorderTop(short border) Set top border.
void | setBottomBorderColor(short color)
void | setDiagonalBorderColor(short color)
void | setLeftBorderColor(short color)
void | setRightBorderColor(short color)
void | setTopBorderColor(short color)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getBorderBottom

public short getBorderBottom()
Specified by:
getBorderBottom in interface BorderFormatting

getBorderDiagonal

public short getBorderDiagonal()
Specified by:
getBorderDiagonal in interface BorderFormatting

getBorderLeft

public short getBorderLeft()
Specified by:
getBorderLeft in interface BorderFormatting

getBorderRight

public short getBorderRight()
Specified by:
getBorderRight in interface BorderFormatting

getBorderTop

public short getBorderTop()
Specified by:
getBorderTop in interface BorderFormatting

getBottomBorderColor

public short getBottomBorderColor()
Specified by:
getBottomBorderColor in interface BorderFormatting

getDiagonalBorderColor

public short getDiagonalBorderColor()
Specified by:
getDiagonalBorderColor in interface BorderFormatting

getLeftBorderColor

public short getLeftBorderColor()
Specified by:
getLeftBorderColor in interface BorderFormatting

getRightBorderColor

public short getRightBorderColor()
Specified by:
getRightBorderColor in interface BorderFormatting

getTopBorderColor

public short getTopBorderColor()
Specified by:
getTopBorderColor in interface BorderFormatting

setBorderBottom

public void setBorderBottom(short border)
Specified by:
setBorderBottom in interface BorderFormatting

setBorderDiagonal

public void setBorderDiagonal(short border)
Description copied from interface: BorderFormatting
Set diagonal border.

Specified by:
setBorderDiagonal in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBorderLeft

public void setBorderLeft(short border)
Description copied from interface: BorderFormatting
Set left border.

Specified by:
setBorderLeft in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBorderRight

public void setBorderRight(short border)
Description copied from interface: BorderFormatting
Set right border.

Specified by:
setBorderRight in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBorderTop

public void setBorderTop(short border)
Description copied from interface: BorderFormatting
Set top border.

Specified by:
setBorderTop in interface BorderFormatting
Parameters:
border - MUST be a BORDER_* constant

setBottomBorderColor

public void setBottomBorderColor(short color)
Specified by:
setBottomBorderColor in interface BorderFormatting

setDiagonalBorderColor

public void setDiagonalBorderColor(short color)
Specified by:
setDiagonalBorderColor in interface BorderFormatting

setLeftBorderColor

public void setLeftBorderColor(short color)
Specified by:
setLeftBorderColor in interface BorderFormatting

setRightBorderColor

public void setRightBorderColor(short color)
Specified by:
setRightBorderColor in interface BorderFormatting

setTopBorderColor

public void setTopBorderColor(short color)
Specified by:
setTopBorderColor in interface BorderFormatting
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFCell

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFCell
All Implemented Interfaces:
Cell
public final class XSSFCell
extends java.lang.Object
implements Cell

High level representation of a cell in a row of a spreadsheet.

Cells can be numeric, formula-based or string-based (text). The cell type specifies this. String cells cannot conatin numbers and numeric cells cannot contain strings (at least according to our model). Client apps should do the conversions themselves. Formula cells have the formula string, as well as the formula result, which can be numeric or string.

Cells should have their number (0 based) before being added to a row. Only cells that have values should be added.

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.Cell
CELL_TYPE_BLANK, CELL_TYPE_BOOLEAN, CELL_TYPE_ERROR, CELL_TYPE_FORMULA, CELL_TYPE_NUMERIC, CELL_TYPE_STRING
Constructor Summary
protected XSSFCell(XSSFRow row, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCell cell)
Construct a XSSFCell.
Method Summary
 CellRangeAddress getArrayFormulaRange()
Only valid for array formula cells
 boolean getBooleanCellValue()
Get the value of the cell as a boolean.
 int getCachedFormulaResultType()
Only valid for formula cells
 XSSFComment getCellComment()
Returns cell comment associated with this cell
 java.lang.String getCellFormula()
Return a formula for the cell, for example, SUM(C4:E4)
 XSSFCellStyle getCellStyle()
Return the cell's style.
 int getCellType()
Return the cell type.
 int getColumnIndex()
Returns column index of this cell
 org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCell getCTCell()
Returns the xml bean containing information about the cell's location (reference), value, data type, formatting, and formula
 java.util.Date getDateCellValue()
Get the value of the cell as a date.
 java.lang.String getErrorCellString()
Returns the error message, such as #VALUE!
 byte getErrorCellValue()
Get the value of the cell as an error code.
 XSSFHyperlink getHyperlink()
Returns hyperlink associated with this cell
 double getNumericCellValue()
Get the value of the cell as a number.
 java.lang.String getRawValue()
Returns the raw, underlying ooxml value for the cell
 java.lang.String getReference()
Returns an A1 style reference to the location of this cell
 XSSFRichTextString getRichStringCellValue()
Get the value of the cell as a XSSFRichTextString
 XSSFRow getRow()
Returns the row this cell belongs to
 int getRowIndex()
Returns row index of a row in the sheet that contains this cell
protected  SharedStringsTable getSharedStringSource()
 XSSFSheet getSheet()
Returns the sheet this cell belongs to
 java.lang.String getStringCellValue()
Get the value of the cell as a string
protected  StylesTable getStylesSource()
 boolean isPartOfArrayFormulaGroup()
 void removeCellComment()
Removes the comment for this cell, if there is one.
 void setAsActiveCell()
Sets this cell as the active cell for the worksheet.
 void setCellComment(Comment comment)
Assign a comment to this cell.
 void setCellErrorValue(byte errorCode)
Set a error value for the cell
 void setCellErrorValue(FormulaError error)
Set a error value for the cell
 void setCellFormula(java.lang.String formula)
Sets formula for this cell.
protected  void setCellNum(int num)
Sets column index of this cell
 void setCellStyle(CellStyle style)
Set the style for the cell.
 void setCellType(int cellType)
Set the cells type (numeric, formula or string)
 void setCellValue(boolean value)
Set a boolean value for the cell
 void setCellValue(java.util.Calendar value)
Set a date value for the cell.
 void setCellValue(java.util.Date value)
Set a date value for the cell.
 void setCellValue(double value)
Set a numeric value for the cell
 void setCellValue(RichTextString str)
Set a string value for the cell.
 void setCellValue(java.lang.String str)
Set a string value for the cell.
 void setHyperlink(Hyperlink hyperlink)
Assign a hypelrink to this cell
 java.lang.String toString()
Returns a string representation of the cell
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSSFCell

protected XSSFCell(XSSFRow row,
                   org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCell cell)
Construct a XSSFCell.

Parameters:
row - the parent row.
cell - the xml bean containing information about the cell.
Method Detail

getSharedStringSource

protected SharedStringsTable getSharedStringSource()
Returns:
table of strings shared across this workbook

getStylesSource

protected StylesTable getStylesSource()
Returns:
table of cell styles shared across this workbook

getSheet

public XSSFSheet getSheet()
Returns the sheet this cell belongs to

Specified by:
getSheet in interface Cell
Returns:
the sheet this cell belongs to

getRow

public XSSFRow getRow()
Returns the row this cell belongs to

Specified by:
getRow in interface Cell
Returns:
the row this cell belongs to

getBooleanCellValue

public boolean getBooleanCellValue()
Get the value of the cell as a boolean.

For strings, numbers, and errors, we throw an exception. For blank cells we return a false.

Specified by:
getBooleanCellValue in interface Cell
Returns:
the value of the cell as a boolean
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is not CELL_TYPE_BOOLEAN, CELL_TYPE_BLANK or CELL_TYPE_FORMULA

setCellValue

public void setCellValue(boolean value)
Set a boolean value for the cell

Specified by:
setCellValue in interface Cell
Parameters:
value - the boolean value to set this cell to. For formulas we'll set the precalculated value, for booleans we'll set its value. For other types we will change the cell to a boolean cell and set its value.

getNumericCellValue

public double getNumericCellValue()
Get the value of the cell as a number.

For strings we throw an exception. For blank cells we return a 0. For formulas or error cells we return the precalculated value;

Specified by:
getNumericCellValue in interface Cell
Returns:
the value of the cell as a number
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is CELL_TYPE_STRING
java.lang.NumberFormatException - if the cell value isn't a parsable double.
See Also:
for turning this number into a string similar to that which Excel would render this number as.

setCellValue

public void setCellValue(double value)
Set a numeric value for the cell

Specified by:
setCellValue in interface Cell
Parameters:
value - the numeric value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numeric cell and set its value.

getStringCellValue

public java.lang.String getStringCellValue()
Get the value of the cell as a string

For numeric cells we throw an exception. For blank cells we return an empty string. For formulaCells that are not string Formulas, we throw an exception

Specified by:
getStringCellValue in interface Cell
Returns:
the value of the cell as a string

getRichStringCellValue

public XSSFRichTextString getRichStringCellValue()
Get the value of the cell as a XSSFRichTextString

For numeric cells we throw an exception. For blank cells we return an empty string. For formula cells we return the pre-calculated value if a string, otherwise an exception

Specified by:
getRichStringCellValue in interface Cell
Returns:
the value of the cell as a XSSFRichTextString

setCellValue

public void setCellValue(java.lang.String str)
Set a string value for the cell.

Specified by:
setCellValue in interface Cell
Parameters:
str - value to set the cell to. For formulas we'll set the formula cached string result, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

setCellValue

public void setCellValue(RichTextString str)
Set a string value for the cell.

Specified by:
setCellValue in interface Cell
Parameters:
str - value to set the cell to. For formulas we'll set the 'pre-evaluated result string, for String cells we'll set its value. For other types we will change the cell to a string cell and set its value. If value is null then we will change the cell to a Blank cell.

getCellFormula

public java.lang.String getCellFormula()
Return a formula for the cell, for example, SUM(C4:E4)

Specified by:
getCellFormula in interface Cell
Returns:
a formula for the cell
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is not CELL_TYPE_FORMULA

setCellFormula

public void setCellFormula(java.lang.String formula)
Sets formula for this cell.

Note, this method only sets the formula string and does not calculate the formula value. To set the precalculated value use setCellValue(double) or setCellValue(String)

Specified by:
setCellFormula in interface Cell
Parameters:
formula - the formula to set, e.g. "SUM(C4:E4)". If the argument is null then the current formula is removed.
Throws:
FormulaParseException - if the formula has incorrect syntax or is otherwise invalid
java.lang.IllegalStateException - if the operation is not allowed, for example, when the cell is a part of a multi-cell array formula

getColumnIndex

public int getColumnIndex()
Returns column index of this cell

Specified by:
getColumnIndex in interface Cell
Returns:
zero-based column index of a column in a sheet.

getRowIndex

public int getRowIndex()
Returns row index of a row in the sheet that contains this cell

Specified by:
getRowIndex in interface Cell
Returns:
zero-based row index of a row in the sheet that contains this cell

getReference

public java.lang.String getReference()
Returns an A1 style reference to the location of this cell

Returns:
A1 style reference to the location of this cell

getCellStyle

public XSSFCellStyle getCellStyle()
Return the cell's style.

Specified by:
getCellStyle in interface Cell
Returns:
the cell's style.
See Also:
Workbook.getCellStyleAt(short)

setCellStyle

public void setCellStyle(CellStyle style)
Set the style for the cell. The style should be an XSSFCellStyle created/retreived from the XSSFWorkbook.

Specified by:
setCellStyle in interface Cell
Parameters:
style - reference contained in the workbook. If the value is null then the style information is removed causing the cell to used the default workbook style.
See Also:
Workbook.createCellStyle()

getCellType

public int getCellType()
Return the cell type.

Specified by:
getCellType in interface Cell
Returns:
the cell type
See Also:
Cell.CELL_TYPE_BLANK, Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_FORMULA, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR

getCachedFormulaResultType

public int getCachedFormulaResultType()
Only valid for formula cells

Specified by:
getCachedFormulaResultType in interface Cell
Returns:
one of (Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR) depending on the cached value of the formula

getDateCellValue

public java.util.Date getDateCellValue()
Get the value of the cell as a date.

For strings we throw an exception. For blank cells we return a null.

Specified by:
getDateCellValue in interface Cell
Returns:
the value of the cell as a date
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() is CELL_TYPE_STRING
java.lang.NumberFormatException - if the cell value isn't a parsable double.
See Also:
for formatting this date into a string similar to how excel does.

setCellValue

public void setCellValue(java.util.Date value)
Set a date value for the cell. Excel treats dates as numeric so you will need to format the cell as a date.

Specified by:
setCellValue in interface Cell
Parameters:
value - the date value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For other types we will change the cell to a numeric cell and set its value.

setCellValue

public void setCellValue(java.util.Calendar value)
Set a date value for the cell. Excel treats dates as numeric so you will need to format the cell as a date.

This will set the cell value based on the Calendar's timezone. As Excel does not support timezones this means that both 20:00+03:00 and 20:00-03:00 will be reported as the same value (20:00) even that there are 6 hours difference between the two times. This difference can be preserved by using setCellValue(value.getTime()) which will automatically shift the times to the default timezone.

Specified by:
setCellValue in interface Cell
Parameters:
value - the date value to set this cell to. For formulas we'll set the precalculated value, for numerics we'll set its value. For othertypes we will change the cell to a numeric cell and set its value.

getErrorCellString

public java.lang.String getErrorCellString()
Returns the error message, such as #VALUE!

Returns:
the error message such as #VALUE!
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() isn't CELL_TYPE_ERROR
See Also:
FormulaError

getErrorCellValue

public byte getErrorCellValue()
Get the value of the cell as an error code.

For strings, numbers, and booleans, we throw an exception. For blank cells we return a 0.

Specified by:
getErrorCellValue in interface Cell
Returns:
the value of the cell as an error code
Throws:
java.lang.IllegalStateException - if the cell type returned by getCellType() isn't CELL_TYPE_ERROR
See Also:
FormulaError

setCellErrorValue

public void setCellErrorValue(byte errorCode)
Set a error value for the cell

Specified by:
setCellErrorValue in interface Cell
Parameters:
errorCode - the error value to set this cell to. For formulas we'll set the precalculated value , for errors we'll set its value. For other types we will change the cell to an error cell and set its value.
See Also:
FormulaError

setCellErrorValue

public void setCellErrorValue(FormulaError error)
Set a error value for the cell

Parameters:
error - the error value to set this cell to. For formulas we'll set the precalculated value , for errors we'll set its value. For other types we will change the cell to an error cell and set its value.

setAsActiveCell

public void setAsActiveCell()
Sets this cell as the active cell for the worksheet.

Specified by:
setAsActiveCell in interface Cell

setCellNum

protected void setCellNum(int num)
Sets column index of this cell

Parameters:
num - column index of this cell

setCellType

public void setCellType(int cellType)
Set the cells type (numeric, formula or string)

Specified by:
setCellType in interface Cell
Throws:
java.lang.IllegalArgumentException - if the specified cell type is invalid
See Also:
Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING, Cell.CELL_TYPE_FORMULA, Cell.CELL_TYPE_BLANK, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR

toString

public java.lang.String toString()
Returns a string representation of the cell

Formula cells return the formula string, rather than the formula result. Dates are displayed in dd-MMM-yyyy format Errors are displayed as #ERR<errIdx>

Overrides:
toString in class java.lang.Object

getRawValue

public java.lang.String getRawValue()
Returns the raw, underlying ooxml value for the cell

If the cell contains a string, then this value is an index into the shared string table, pointing to the actual string value. Otherwise, the value of the cell is expressed directly in this element. Cells containing formulas express the last calculated result of the formula in this element.

Returns:
the raw cell value as contained in the underlying CTCell bean, null for blank cells.

getCellComment

public XSSFComment getCellComment()
Returns cell comment associated with this cell

Specified by:
getCellComment in interface Cell
Returns:
the cell comment associated with this cell or null

setCellComment

public void setCellComment(Comment comment)
Assign a comment to this cell. If the supplied comment is null, the comment for this cell will be removed.

Specified by:
setCellComment in interface Cell
Parameters:
comment - the XSSFComment associated with this cell

removeCellComment

public void removeCellComment()
Removes the comment for this cell, if there is one.

Specified by:
removeCellComment in interface Cell

getHyperlink

public XSSFHyperlink getHyperlink()
Returns hyperlink associated with this cell

Specified by:
getHyperlink in interface Cell
Returns:
hyperlink associated with this cell or null if not found

setHyperlink

public void setHyperlink(Hyperlink hyperlink)
Assign a hypelrink to this cell

Specified by:
setHyperlink in interface Cell
Parameters:
hyperlink - the hypelrink to associate with this cell

getCTCell

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCell getCTCell()
Returns the xml bean containing information about the cell's location (reference), value, data type, formatting, and formula

Returns:
the xml bean containing information about this cell

getArrayFormulaRange

public CellRangeAddress getArrayFormulaRange()
Description copied from interface: Cell
Only valid for array formula cells

Specified by:
getArrayFormulaRange in interface Cell
Returns:
range of the array formula group that the cell belongs to.

isPartOfArrayFormulaGroup

public boolean isPartOfArrayFormulaGroup()
Specified by:
isPartOfArrayFormulaGroup in interface Cell
Returns:
true if this cell is part of group of cells having a common array formula.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFCellStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFCellStyle

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFCellStyle
All Implemented Interfaces:
CellStyle
public class XSSFCellStyle
extends java.lang.Object
implements CellStyle

High level representation of the the possible formatting information for the contents of the cells on a sheet in a SpreadsheetML document.

See Also:
XSSFWorkbook.createCellStyle(),
XSSFWorkbook.getCellStyleAt(short),
XSSFCell.setCellStyle(org.apache.poi.ss.usermodel.CellStyle)

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.CellStyle
ALIGN_CENTER, ALIGN_CENTER_SELECTION, ALIGN_FILL, ALIGN_GENERAL, ALIGN_JUSTIFY, ALIGN_LEFT, ALIGN_RIGHT, ALT_BARS, BIG_SPOTS, BORDER_DASH_DOT, BORDER_DASH_DOT_DOT, BORDER_DASHED, BORDER_DOTTED, BORDER_DOUBLE, BORDER_HAIR, BORDER_MEDIUM, BORDER_MEDIUM_DASH_DOT, BORDER_MEDIUM_DASH_DOT_DOT, BORDER_MEDIUM_DASHED, BORDER_NONE, BORDER_SLANTED_DASH_DOT, BORDER_THICK, BORDER_THIN, BRICKS, DIAMONDS, FINE_DOTS, LEAST_DOTS, LESS_DOTS, NO_FILL, SOLID_FOREGROUND, SPARSE_DOTS, SQUARES, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, THICK_HORZ_BANDS, THICK_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, THIN_HORZ_BANDS, THIN_VERT_BANDS, VERTICAL_BOTTOM, VERTICAL_CENTER, VERTICAL_JUSTIFY, VERTICAL_TOP
Constructor Summary
XSSFCellStyle(int cellXfId, int cellStyleXfId, StylesTable stylesSource, ThemesTable theme)
Creates a Cell Style from the supplied parts
XSSFCellStyle(StylesTable stylesSource)
Creates an empty Cell Style
Method Summary
java.lang.Object | clone() Make a copy of this style.
void | cloneStyleFrom(CellStyle source) Clones all the style information from another XSSFCellStyle, onto this one.
boolean | equals(java.lang.Object o) Checks is the supplied style is equal to this style
short | getAlignment() Get the type of horizontal alignment for the cell
HorizontalAlignment | getAlignmentEnum() Get the type of horizontal alignment for the cell
short | getBorderBottom() Get the type of border to use for the bottom border of the cell
BorderStyle | getBorderBottomEnum() Get the type of border to use for the bottom border of the cell
XSSFColor | getBorderColor(XSSFCellBorder.BorderSide side) Gets border color
short | getBorderLeft() Get the type of border to use for the left border of the cell
BorderStyle | getBorderLeftEnum() Get the type of border to use for the left border of the cell
short | getBorderRight() Get the type of border to use for the right border of the cell
BorderStyle | getBorderRightEnum() Get the type of border to use for the right border of the cell
short | getBorderTop() Get the type of border to use for the top border of the cell
BorderStyle | getBorderTopEnum() Get the type of border to use for the top border of the cell
short | getBottomBorderColor() Get the color to use for the bottom border Color is optional.
XSSFColor | getBottomBorderXSSFColor() Get the color to use for the bottom border as a XSSFColor
protected XSSFCellAlignment | getCellAlignment() get the cellAlignment object to use for manage alignment
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf | getCoreXf() Used so that StylesSource can figure out our location
short | getDataFormat() Get the index of the number format (numFmt) record used by this cell format.
java.lang.String | getDataFormatString() Get the contents of the format string, by looking up the StylesSource
short | getFillBackgroundColor() Get the background fill color.
XSSFColor | getFillBackgroundColorColor() Gets the color object representing the current background fill, resolving indexes using the supplied workbook.
XSSFColor | getFillBackgroundXSSFColor() Get the background fill color.
short | getFillForegroundColor() Get the foreground fill color.
XSSFColor | getFillForegroundColorColor() Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook.
XSSFColor | getFillForegroundXSSFColor() Get the foreground fill color.
short | getFillPattern() Get the fill pattern
FillPatternType | getFillPatternEnum() Get the fill pattern
XSSFFont | getFont() Gets the font for this style
short | getFontIndex() Gets the index of the font for this style
boolean | getHidden() Get whether the cell's using this style are to be hidden
short | getIndention() Get the number of spaces to indent the text in the cell
short | getIndex() Get the index within the StylesTable (sequence within the collection of CTXf elements)
short | getLeftBorderColor() Get the color to use for the left border
XSSFColor | getLeftBorderXSSFColor() Get the color to use for the left border
boolean | getLocked() Get whether the cell's using this style are locked
short | getRightBorderColor() Get the color to use for the right border
XSSFColor | getRightBorderXSSFColor() Get the color to use for the right border
short | getRotation() Get the degree of rotation for the text in the cell
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf | getStyleXf() Used so that StylesSource can figure out our location
short | getTopBorderColor() Get the color to use for the top border
XSSFColor | getTopBorderXSSFColor() Get the color to use for the top border
short | getVerticalAlignment() Get the type of vertical alignment for the cell
VerticalAlignment | getVerticalAlignmentEnum() Get the type of vertical alignment for the cell
boolean | getWrapText() Whether the text should be wrapped
int | hashCode() Returns a hash code value for the object.
void | setAlignment(HorizontalAlignment align) Set the type of horizontal alignment for the cell
void | setAlignment(short align) Set the type of horizontal alignment for the cell
void | setBorderBottom(BorderStyle border) Set the type of border to use for the bottom border of the cell
void | setBorderBottom(short border) Set the type of border to use for the bottom border of the cell
void | setBorderColor(XSSFCellBorder.BorderSide side, XSSFColor color) Set the color to use for the selected border
void | setBorderLeft(BorderStyle border) Set the type of border to use for the left border of the cell
void | setBorderLeft(short border) Set the type of border to use for the left border of the cell
void | setBorderRight(BorderStyle border) Set the type of border to use for the right border of the cell
void | setBorderRight(short border) Set the type of border to use for the right border of the cell
void | setBorderTop(BorderStyle border) Set the type of border to use for the top border of the cell
void | setBorderTop(short border) Set the type of border to use for the top border of the cell
void | setBottomBorderColor(short color) Set the color to use for the bottom border
void | setBottomBorderColor(XSSFColor color) Set the color to use for the bottom border
void | setDataFormat(short fmt) Set the index of a data format
void | setFillBackgroundColor(short bg) Set the background fill color represented as a indexed color value.
void | setFillBackgroundColor(XSSFColor color) Set the background fill color represented as a XSSFColor value.
void | setFillForegroundColor(short fg) Set the foreground fill color as a indexed color value Note: Ensure Foreground color is set prior to background color.
void | setFillForegroundColor(XSSFColor color) Set the foreground fill color represented as a XSSFColor value.
void | setFillPattern(FillPatternType ptrn) This element is used to specify cell fill information for pattern and solid color cell fills.
void | setFillPattern(short fp) This element is used to specify cell fill information for pattern and solid color cell fills.
void | setFont(Font font) Set the font for this style
void | setHidden(boolean hidden) Set the cell's using this style to be hidden
void | setIndention(short indent) Set the number of spaces to indent the text in the cell
void | setLeftBorderColor(short color) Set the color to use for the left border as a indexed color value
void | setLeftBorderColor(XSSFColor color) Set the color to use for the left border as a XSSFColor value
void | setLocked(boolean locked) Set the cell's using this style to be locked
void | setRightBorderColor(short color) Set the color to use for the right border
void | setRightBorderColor(XSSFColor color) Set the color to use for the right border as a XSSFColor value
void | setRotation(short rotation) Set the degree of rotation for the text in the cell
void | setTopBorderColor(short color) Set the color to use for the top border
void | setTopBorderColor(XSSFColor color) Set the color to use for the top border as a XSSFColor value
void | setVerticalAlignment(short align) Set the type of vertical alignment for the cell
void | setVerticalAlignment(VerticalAlignment align) Set the type of vertical alignment for the cell
void | setWrapText(boolean wrapped) Set whether the text should be wrapped.
void | verifyBelongsToStylesSource(StylesTable src) Verifies that this style belongs to the supplied Workbook Styles Source.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFCellStyle

public XSSFCellStyle(int cellXfId,
                     int cellStyleXfId,
                     StylesTable stylesSource,
                     ThemesTable theme)
Creates a Cell Style from the supplied parts

Parameters:
cellXfId - The main XF for the cell. Must be a valid 0-based index into the XF table
cellStyleXfId - Optional, style xf. A value of -1 means no xf.
stylesSource - Styles Source to work off

XSSFCellStyle

public XSSFCellStyle(StylesTable stylesSource)
Creates an empty Cell Style

Method Detail

getCoreXf

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf getCoreXf()
Used so that StylesSource can figure out our location

getStyleXf

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXf getStyleXf()
Used so that StylesSource can figure out our location

verifyBelongsToStylesSource

public void verifyBelongsToStylesSource(StylesTable src)
Verifies that this style belongs to the supplied Workbook Styles Source. Will throw an exception if it belongs to a different one. This is normally called when trying to assign a style to a cell, to ensure the cell and the style are from the same workbook (if they're not, it won't work)

Throws:
java.lang.IllegalArgumentException - if there's a workbook mis-match

cloneStyleFrom

public void cloneStyleFrom(CellStyle source)
Clones all the style information from another XSSFCellStyle, onto this one. This XSSFCellStyle will then have all the same properties as the source, but the two may be edited independently. Any stylings on this XSSFCellStyle will be lost! The source XSSFCellStyle could be from another XSSFWorkbook if you like. This allows you to copy styles from one XSSFWorkbook to another.

Specified by:
cloneStyleFrom in interface CellStyle

getAlignment

public short getAlignment()
Get the type of horizontal alignment for the cell

Specified by:
getAlignment in interface CellStyle
Returns:
short - the type of alignment
See Also:
CellStyle.ALIGN_GENERAL, CellStyle.ALIGN_LEFT, CellStyle.ALIGN_CENTER, CellStyle.ALIGN_RIGHT, CellStyle.ALIGN_FILL, CellStyle.ALIGN_JUSTIFY, CellStyle.ALIGN_CENTER_SELECTION

getAlignmentEnum

public HorizontalAlignment getAlignmentEnum()
Get the type of horizontal alignment for the cell

Returns:
HorizontalAlignment - the type of alignment
See Also:
HorizontalAlignment

getBorderBottom

public short getBorderBottom()
Get the type of border to use for the bottom border of the cell

Specified by:
getBorderBottom in interface CellStyle
Returns:
short - border type
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderBottomEnum

public BorderStyle getBorderBottomEnum()
Get the type of border to use for the bottom border of the cell

Returns:
border type as Java enum
See Also:
BorderStyle

getBorderLeft

public short getBorderLeft()
Get the type of border to use for the left border of the cell

Specified by:
getBorderLeft in interface CellStyle
Returns:
short - border type, default value is CellStyle.BORDER_NONE
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderLeftEnum

public BorderStyle getBorderLeftEnum()
Get the type of border to use for the left border of the cell

Returns:
border type, default value is BorderStyle.NONE

getBorderRight

public short getBorderRight()
Get the type of border to use for the right border of the cell

Specified by:
getBorderRight in interface CellStyle
Returns:
short - border type, default value is CellStyle.BORDER_NONE
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderRightEnum

public BorderStyle getBorderRightEnum()
Get the type of border to use for the right border of the cell

Returns:
border type, default value is BorderStyle.NONE

getBorderTop

public short getBorderTop()
Get the type of border to use for the top border of the cell

Specified by:
getBorderTop in interface CellStyle
Returns:
short - border type, default value is CellStyle.BORDER_NONE
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, #BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

getBorderTopEnum

public BorderStyle getBorderTopEnum()
Get the type of border to use for the top border of the cell

Returns:
border type, default value is BorderStyle.NONE

getBottomBorderColor

public short getBottomBorderColor()
Get the color to use for the bottom border
Color is optional. When missing, IndexedColors.AUTOMATIC is implied.

Specified by:
getBottomBorderColor in interface CellStyle
Returns:
the index of the color definition, default value is IndexedColors.AUTOMATIC
See Also:
IndexedColors

getBottomBorderXSSFColor

public XSSFColor getBottomBorderXSSFColor()
Get the color to use for the bottom border as a XSSFColor

Returns:
the used color or null if not set

getDataFormat

public short getDataFormat()
Get the index of the number format (numFmt) record used by this cell format.

Specified by:
getDataFormat in interface CellStyle
Returns:
the index of the number format
See Also:
DataFormat

getDataFormatString

public java.lang.String getDataFormatString()
Get the contents of the format string, by looking up the StylesSource

Specified by:
getDataFormatString in interface CellStyle
Returns:
the number format string

getFillBackgroundColor

public short getFillBackgroundColor()
Get the background fill color.

Note - many cells are actually filled with a foreground fill, not a background fill - see getFillForegroundColor()

Specified by:
getFillBackgroundColor in interface CellStyle
Returns:
fill color, default value is IndexedColors.AUTOMATIC
See Also:
IndexedColors

getFillBackgroundColorColor

public XSSFColor getFillBackgroundColorColor()
Description copied from interface: CellStyle
Gets the color object representing the current background fill, resolving indexes using the supplied workbook. This will work for both indexed and rgb defined colors.

Specified by:
getFillBackgroundColorColor in interface CellStyle

getFillBackgroundXSSFColor

public XSSFColor getFillBackgroundXSSFColor()
Get the background fill color.

Note - many cells are actually filled with a foreground fill, not a background fill - see getFillForegroundColor()

Returns:
XSSFColor - fill color or null if not set
See Also:
XSSFColor.getRgb()

getFillForegroundColor

public short getFillForegroundColor()
Get the foreground fill color.

Many cells are filled with this, instead of a background color (getFillBackgroundColor())

Specified by:
getFillForegroundColor in interface CellStyle
Returns:
fill color, default value is IndexedColors.AUTOMATIC
See Also:
IndexedColors

getFillForegroundColorColor

public XSSFColor getFillForegroundColorColor()
Description copied from interface: CellStyle
Gets the color object representing the current foreground fill, resolving indexes using the supplied workbook. This will work for both indexed and rgb defined colors.

Specified by:
getFillForegroundColorColor in interface CellStyle

getFillForegroundXSSFColor

public XSSFColor getFillForegroundXSSFColor()
Get the foreground fill color.

Returns:
XSSFColor - fill color or null if not set

getFillPattern

public short getFillPattern()
Get the fill pattern

Specified by:
getFillPattern in interface CellStyle
Returns:
fill pattern, default value is CellStyle.NO_FILL
See Also:
CellStyle.NO_FILL, CellStyle.SOLID_FOREGROUND, CellStyle.FINE_DOTS, CellStyle.ALT_BARS, CellStyle.SPARSE_DOTS, CellStyle.THICK_HORZ_BANDS, CellStyle.THICK_VERT_BANDS, CellStyle.THICK_BACKWARD_DIAG, CellStyle.THICK_FORWARD_DIAG, CellStyle.BIG_SPOTS, CellStyle.BRICKS, CellStyle.THIN_HORZ_BANDS, CellStyle.THIN_VERT_BANDS, CellStyle.THIN_BACKWARD_DIAG, CellStyle.THIN_FORWARD_DIAG, CellStyle.SQUARES, CellStyle.DIAMONDS

getFillPatternEnum

public FillPatternType getFillPatternEnum()
Get the fill pattern

Returns:
the fill pattern, default value is FillPatternType.NO_FILL

getFont

public XSSFFont getFont()
Gets the font for this style

Returns:
Font - font

getFontIndex

public short getFontIndex()
Gets the index of the font for this style

Specified by:
getFontIndex in interface CellStyle
Returns:
short - font index
See Also:
XSSFWorkbook.getFontAt(short)

getHidden

public boolean getHidden()
Get whether the cell's using this style are to be hidden

Specified by:
getHidden in interface CellStyle
Returns:
boolean - whether the cell using this style is hidden

getIndention

public short getIndention()
Get the number of spaces to indent the text in the cell

Specified by:
getIndention in interface CellStyle
Returns:
indent - number of spaces

getIndex

public short getIndex()
Get the index within the StylesTable (sequence within the collection of CTXf elements)

Specified by:
getIndex in interface CellStyle
Returns:
unique index number of the underlying record this style represents

getLeftBorderColor

public short getLeftBorderColor()
Get the color to use for the left border

Specified by:
getLeftBorderColor in interface CellStyle
Returns:
the index of the color definition, default value is IndexedColors.BLACK
See Also:
IndexedColors

getLeftBorderXSSFColor

public XSSFColor getLeftBorderXSSFColor()
Get the color to use for the left border

Returns:
the index of the color definition or null if not set
See Also:
IndexedColors

getLocked

public boolean getLocked()
Get whether the cell's using this style are locked

Specified by:
getLocked in interface CellStyle
Returns:
whether the cell using this style are locked

getRightBorderColor

public short getRightBorderColor()
Get the color to use for the right border

Specified by:
getRightBorderColor in interface CellStyle
Returns:
the index of the color definition, default value is IndexedColors.BLACK
See Also:
IndexedColors

getRightBorderXSSFColor

public XSSFColor getRightBorderXSSFColor()
Get the color to use for the right border

Returns:
the used color or null if not set

getRotation

public short getRotation()
Get the degree of rotation for the text in the cell

Expressed in degrees. Values range from 0 to 180. The first letter of the text is considered the center-point of the arc.
For 0 - 90, the value represents degrees above horizon. For 91-180 the degrees below the horizon is calculated as:
[degrees below horizon] = 90 - textRotation.

Specified by:
getRotation in interface CellStyle
Returns:
rotation degrees (between 0 and 180 degrees)

getTopBorderColor

public short getTopBorderColor()
Get the color to use for the top border

Specified by:
getTopBorderColor in interface CellStyle
Returns:
the index of the color definition, default value is IndexedColors.BLACK
See Also:
IndexedColors

getTopBorderXSSFColor

public XSSFColor getTopBorderXSSFColor()
Get the color to use for the top border

Returns:
the used color or null if not set

getVerticalAlignment

public short getVerticalAlignment()
Get the type of vertical alignment for the cell

Specified by:
getVerticalAlignment in interface CellStyle
Returns:
align the type of alignment, default value is CellStyle.VERTICAL_BOTTOM
See Also:
CellStyle.VERTICAL_TOP, CellStyle.VERTICAL_CENTER, CellStyle.VERTICAL_BOTTOM, CellStyle.VERTICAL_JUSTIFY

getVerticalAlignmentEnum

public VerticalAlignment getVerticalAlignmentEnum()
Get the type of vertical alignment for the cell

Returns:
the type of alignment, default value is VerticalAlignment.BOTTOM
See Also:
VerticalAlignment

getWrapText

public boolean getWrapText()
Whether the text should be wrapped

Specified by:
getWrapText in interface CellStyle
Returns:
a boolean value indicating if the text in a cell should be line-wrapped within the cell.

setAlignment

public void setAlignment(short align)
Set the type of horizontal alignment for the cell

Specified by:
setAlignment in interface CellStyle
Parameters:
align - - the type of alignment
See Also:
CellStyle.ALIGN_GENERAL, CellStyle.ALIGN_LEFT, CellStyle.ALIGN_CENTER, CellStyle.ALIGN_RIGHT, CellStyle.ALIGN_FILL, CellStyle.ALIGN_JUSTIFY, CellStyle.ALIGN_CENTER_SELECTION

setAlignment

public void setAlignment(HorizontalAlignment align)
Set the type of horizontal alignment for the cell

Parameters:
align - - the type of alignment
See Also:
HorizontalAlignment

setBorderBottom

public void setBorderBottom(short border)
Set the type of border to use for the bottom border of the cell

Specified by:
setBorderBottom in interface CellStyle
Parameters:
border - the type of border to use
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setBorderBottom

public void setBorderBottom(BorderStyle border)
Set the type of border to use for the bottom border of the cell

Parameters:
border - - type of border to use
See Also:
BorderStyle

setBorderLeft

public void setBorderLeft(short border)
Set the type of border to use for the left border of the cell

Specified by:
setBorderLeft in interface CellStyle
Parameters:
border - the type of border to use
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setBorderLeft

public void setBorderLeft(BorderStyle border)
Set the type of border to use for the left border of the cell

Parameters:
border - the type of border to use

setBorderRight

public void setBorderRight(short border)
Set the type of border to use for the right border of the cell

Specified by:
setBorderRight in interface CellStyle
Parameters:
border - the type of border to use
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setBorderRight

public void setBorderRight(BorderStyle border)
Set the type of border to use for the right border of the cell

Parameters:
border - the type of border to use

setBorderTop

public void setBorderTop(short border)
Set the type of border to use for the top border of the cell

Specified by:
setBorderTop in interface CellStyle
Parameters:
border - the type of border to use
See Also:
CellStyle.BORDER_NONE, CellStyle.BORDER_THIN, CellStyle.BORDER_MEDIUM, CellStyle.BORDER_DASHED, CellStyle.BORDER_DOTTED, CellStyle.BORDER_THICK, CellStyle.BORDER_DOUBLE, CellStyle.BORDER_HAIR, CellStyle.BORDER_MEDIUM_DASHED, CellStyle.BORDER_DASH_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT, CellStyle.BORDER_DASH_DOT_DOT, CellStyle.BORDER_MEDIUM_DASH_DOT_DOT, CellStyle.BORDER_SLANTED_DASH_DOT

setBorderTop

public void setBorderTop(BorderStyle border)
Set the type of border to use for the top border of the cell

Parameters:
border - the type of border to use

setBottomBorderColor

public void setBottomBorderColor(short color)
Set the color to use for the bottom border

Specified by:
setBottomBorderColor in interface CellStyle
Parameters:
color - the index of the color definition
See Also:
IndexedColors

setBottomBorderColor

public void setBottomBorderColor(XSSFColor color)
Set the color to use for the bottom border

Parameters:
color - the color to use, null means no color

setDataFormat

public void setDataFormat(short fmt)
Set the index of a data format

Specified by:
setDataFormat in interface CellStyle
Parameters:
fmt - the index of a data format
See Also:
DataFormat

setFillBackgroundColor

public void setFillBackgroundColor(XSSFColor color)
Set the background fill color represented as a XSSFColor value.

For example:

 cs.setFillPattern(XSSFCellStyle.FINE_DOTS );
 cs.setFillBackgroundXSSFColor(new XSSFColor(java.awt.Color.RED));
optionally a Foreground and background fill can be applied: Note: Ensure Foreground color is set prior to background
 cs.setFillPattern(XSSFCellStyle.FINE_DOTS );
 cs.setFillForegroundColor(new XSSFColor(java.awt.Color.BLUE));
 cs.setFillBackgroundColor(new XSSFColor(java.awt.Color.GREEN));
or, for the special case of SOLID_FILL:
 cs.setFillPattern(XSSFCellStyle.SOLID_FOREGROUND );
 cs.setFillForegroundColor(new XSSFColor(java.awt.Color.GREEN));
It is necessary to set the fill style in order for the color to be shown in the cell.

Parameters:
color - - the color to use

setFillBackgroundColor

public void setFillBackgroundColor(short bg)
Set the background fill color represented as a indexed color value.

For example:

 cs.setFillPattern(XSSFCellStyle.FINE_DOTS );
 cs.setFillBackgroundXSSFColor(IndexedColors.RED.getIndex());
optionally a Foreground and background fill can be applied: Note: Ensure Foreground color is set prior to background
 cs.setFillPattern(XSSFCellStyle.FINE_DOTS );
 cs.setFillForegroundColor(IndexedColors.BLUE.getIndex());
 cs.setFillBackgroundColor(IndexedColors.RED.getIndex());
or, for the special case of SOLID_FILL:
 cs.setFillPattern(XSSFCellStyle.SOLID_FOREGROUND );
 cs.setFillForegroundColor(IndexedColors.RED.getIndex());
It is necessary to set the fill style in order for the color to be shown in the cell.

Specified by:
setFillBackgroundColor in interface CellStyle
Parameters:
bg - - the color to use
See Also:
IndexedColors

setFillForegroundColor

public void setFillForegroundColor(XSSFColor color)
Set the foreground fill color represented as a XSSFColor value.
Note: Ensure Foreground color is set prior to background color.

Parameters:
color - the color to use
See Also:
)

setFillForegroundColor

public void setFillForegroundColor(short fg)
Set the foreground fill color as a indexed color value
Note: Ensure Foreground color is set prior to background color.

Specified by:
setFillForegroundColor in interface CellStyle
Parameters:
fg - the color to use
See Also:
IndexedColors

setFillPattern

public void setFillPattern(short fp)
This element is used to specify cell fill information for pattern and solid color cell fills. For solid cell fills (no pattern), foregorund color is used. For cell fills with patterns specified, then the cell fill color is specified by the background color.

Specified by:
setFillPattern in interface CellStyle
Parameters:
fp - fill pattern (set to CellStyle.SOLID_FOREGROUND to fill w/foreground color)
See Also:
CellStyle.NO_FILL, CellStyle.SOLID_FOREGROUND, CellStyle.FINE_DOTS, CellStyle.ALT_BARS, CellStyle.SPARSE_DOTS, CellStyle.THICK_HORZ_BANDS, CellStyle.THICK_VERT_BANDS, CellStyle.THICK_BACKWARD_DIAG, CellStyle.THICK_FORWARD_DIAG, CellStyle.BIG_SPOTS, CellStyle.BRICKS, CellStyle.THIN_HORZ_BANDS, CellStyle.THIN_VERT_BANDS, CellStyle.THIN_BACKWARD_DIAG, CellStyle.THIN_FORWARD_DIAG, CellStyle.SQUARES, CellStyle.DIAMONDS, setFillBackgroundColor(short), setFillForegroundColor(short)

setFillPattern

public void setFillPattern(FillPatternType ptrn)
This element is used to specify cell fill information for pattern and solid color cell fills. For solid cell fills (no pattern), foreground color is used is used. For cell fills with patterns specified, then the cell fill color is specified by the background color element.

Parameters:
ptrn - the fill pattern to use
See Also:
setFillBackgroundColor(short), setFillForegroundColor(short), FillPatternType

setFont

public void setFont(Font font)
Set the font for this style

Specified by:
setFont in interface CellStyle
Parameters:
font - a font object created or retreived from the XSSFWorkbook object
See Also:
XSSFWorkbook.createFont(), XSSFWorkbook.getFontAt(short)

setHidden

public void setHidden(boolean hidden)
Set the cell's using this style to be hidden

Specified by:
setHidden in interface CellStyle
Parameters:
hidden - - whether the cell using this style should be hidden

setIndention

public void setIndention(short indent)
Set the number of spaces to indent the text in the cell

Specified by:
setIndention in interface CellStyle
Parameters:
indent - - number of spaces

setLeftBorderColor

public void setLeftBorderColor(short color)
Set the color to use for the left border as a indexed color value

Specified by:
setLeftBorderColor in interface CellStyle
Parameters:
color - the index of the color definition
See Also:
IndexedColors

setLeftBorderColor

public void setLeftBorderColor(XSSFColor color)
Set the color to use for the left border as a XSSFColor value

Parameters:
color - the color to use

setLocked

public void setLocked(boolean locked)
Set the cell's using this style to be locked

Specified by:
setLocked in interface CellStyle
Parameters:
locked - - whether the cell using this style should be locked

setRightBorderColor

public void setRightBorderColor(short color)
Set the color to use for the right border

Specified by:
setRightBorderColor in interface CellStyle
Parameters:
color - the index of the color definition
See Also:
IndexedColors

setRightBorderColor

public void setRightBorderColor(XSSFColor color)
Set the color to use for the right border as a XSSFColor value

Parameters:
color - the color to use

setRotation

public void setRotation(short rotation)
Set the degree of rotation for the text in the cell

Expressed in degrees. Values range from 0 to 180. The first letter of the text is considered the center-point of the arc.
For 0 - 90, the value represents degrees above horizon. For 91-180 the degrees below the horizon is calculated as:
[degrees below horizon] = 90 - textRotation.

Specified by:
setRotation in interface CellStyle
Parameters:
rotation - - the rotation degrees (between 0 and 180 degrees)

setTopBorderColor

public void setTopBorderColor(short color)
Set the color to use for the top border

Specified by:
setTopBorderColor in interface CellStyle
Parameters:
color - the index of the color definition
See Also:
IndexedColors

setTopBorderColor

public void setTopBorderColor(XSSFColor color)
Set the color to use for the top border as a XSSFColor value

Parameters:
color - the color to use

setVerticalAlignment

public void setVerticalAlignment(short align)
Set the type of vertical alignment for the cell

Specified by:
setVerticalAlignment in interface CellStyle
Parameters:
align - - align the type of alignment
See Also:
CellStyle.VERTICAL_TOP, CellStyle.VERTICAL_CENTER, CellStyle.VERTICAL_BOTTOM, CellStyle.VERTICAL_JUSTIFY, VerticalAlignment

setVerticalAlignment

public void setVerticalAlignment(VerticalAlignment align)
Set the type of vertical alignment for the cell

Parameters:
align - - the type of alignment

setWrapText

public void setWrapText(boolean wrapped)
Set whether the text should be wrapped.

Setting this flag to true make all content visible whithin a cell by displaying it on multiple lines

Specified by:
setWrapText in interface CellStyle
Parameters:
wrapped - a boolean value indicating if the text in a cell should be line-wrapped within the cell.

getBorderColor

public XSSFColor getBorderColor(XSSFCellBorder.BorderSide side)
Gets border color

Parameters:
side - the border side
Returns:
the used color

setBorderColor

public void setBorderColor(XSSFCellBorder.BorderSide side,
                           XSSFColor color)
Set the color to use for the selected border

Parameters:
side - - where to apply the color definition
color - - the color to use

getCellAlignment

protected XSSFCellAlignment getCellAlignment()
get the cellAlignment object to use for manage alignment

Returns:
XSSFCellAlignment - cell alignment

hashCode

public int hashCode()
Returns a hash code value for the object. The hash is derived from the underlying CTXf bean.

Overrides:
hashCode in class java.lang.Object
Returns:
the hash code value for this style

equals

public boolean equals(java.lang.Object o)
Checks is the supplied style is equal to this style

Overrides:
equals in class java.lang.Object
Parameters:
o - the style to check
Returns:
true if the supplied style is equal to this style

clone

public java.lang.Object clone()
Make a copy of this style. The underlying CTXf bean is cloned, the references to fills and borders remain.

Overrides:
clone in class java.lang.Object
Returns:
a copy of this style
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFChart

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFChart

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFChart
All Implemented Interfaces:
Chart, ChartAxisFactory, ManuallyPositionable
public final class XSSFChart
extends POIXMLDocumentPart
implements Chart, ChartAxisFactory

Represents a SpreadsheetML Chart

Author:
Nick Burch, Roman Kashitsyn

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected | XSSFChart() Create a new SpreadsheetML chart
protected | XSSFChart(PackagePart part, PackageRelationship rel) Construct a SpreadsheetML chart from a package part.
Method Summary
protected void | commit() Save the content in the underlying package part.
XSSFValueAxis | createValueAxis(AxisPosition pos)
void | deleteLegend() Delete current chart legend.
java.util.List<? extends XSSFChartAxis> | getAxis()
XSSFChart | getChartAxisFactory()
XSSFChartDataFactory | getChartDataFactory()
org.openxmlformats.schemas.drawingml.x2006.chart.CTChart | getCTChart() Return the underlying CTChart bean, within the Chart Space
org.openxmlformats.schemas.drawingml.x2006.chart.CTChartSpace | getCTChartSpace() Return the underlying CTChartSpace bean, the root element of the SpreadsheetML Chart part.
XSSFGraphicFrame | getGraphicFrame() Returns the parent graphic frame.
XSSFManualLayout | getManualLayout() Returns manual layout for the chart element.
XSSFChartLegend | getOrCreateLegend()
XSSFRichTextString | getTitle() Returns the title, or null if none is set
boolean | isPlotOnlyVisibleCells()
void | plot(ChartData data, ChartAxis... axis) Plots specified data on the chart.
protected void | setGraphicFrame(XSSFGraphicFrame frame) Sets the parent graphic frame.
void | setPlotOnlyVisibleCells(boolean plotVisOnly)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSSFChart

protected XSSFChart()
Create a new SpreadsheetML chart

XSSFChart

protected XSSFChart(PackagePart part,
                    PackageRelationship rel)
             throws java.io.IOException,
                    org.apache.xmlbeans.XmlException
Construct a SpreadsheetML chart from a package part.

Parameters:
part - the package part holding the chart data, the content type must be application/vnd.openxmlformats-officedocument.drawingml.chart+xml
rel - the package relationship holding this chart, the relationship type must be http://schemas.openxmlformats.org/officeDocument/2006/relationships/chart
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getCTChartSpace

@Internal
public org.openxmlformats.schemas.drawingml.x2006.chart.CTChartSpace getCTChartSpace()
Return the underlying CTChartSpace bean, the root element of the SpreadsheetML Chart part.

Returns:
the underlying CTChartSpace bean

getCTChart

@Internal
public org.openxmlformats.schemas.drawingml.x2006.chart.CTChart getCTChart()
Return the underlying CTChart bean, within the Chart Space

Returns:
the underlying CTChart bean

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getGraphicFrame

public XSSFGraphicFrame getGraphicFrame()
Returns the parent graphic frame.

Returns:
the graphic frame this chart belongs to

setGraphicFrame

protected void setGraphicFrame(XSSFGraphicFrame frame)
Sets the parent graphic frame.

getChartDataFactory

public XSSFChartDataFactory getChartDataFactory()
Specified by:
getChartDataFactory in interface Chart
Returns:
an appropriate ChartDataFactory implementation

getChartAxisFactory

public XSSFChart getChartAxisFactory()
Specified by:
getChartAxisFactory in interface Chart
Returns:
an appropriate ChartAxisFactory implementation

plot

public void plot(ChartData data,
                 ChartAxis... axis)
Description copied from interface: Chart
Plots specified data on the chart.

Specified by:
plot in interface Chart
Parameters:
data - a data to plot

createValueAxis

public XSSFValueAxis createValueAxis(AxisPosition pos)
Specified by:
createValueAxis in interface ChartAxisFactory
Returns:
new value axis

getAxis

public java.util.List<? extends XSSFChartAxis> getAxis()
Specified by:
getAxis in interface Chart
Returns:
list of all chart axis

getManualLayout

public XSSFManualLayout getManualLayout()
Description copied from interface: ManuallyPositionable
Returns manual layout for the chart element.

Specified by:
getManualLayout in interface ManuallyPositionable
Returns:
manual layout for the chart element.

isPlotOnlyVisibleCells

public boolean isPlotOnlyVisibleCells()
Returns:
true if only visible cells will be present on the chart, false otherwise

setPlotOnlyVisibleCells

public void setPlotOnlyVisibleCells(boolean plotVisOnly)
Parameters:
plotVisOnly - a flag specifying if only visible cells should be present on the chart

getTitle

public XSSFRichTextString getTitle()
Returns the title, or null if none is set

getOrCreateLegend

public XSSFChartLegend getOrCreateLegend()
Specified by:
getOrCreateLegend in interface Chart
Returns:
chart legend instance

deleteLegend

public void deleteLegend()
Description copied from interface: Chart
Delete current chart legend.

Specified by:
deleteLegend in interface Chart
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFChartSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFChartSheet

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFSheet
            extended by  org.apache.poi.xssf.usermodel.XSSFChartSheet
All Implemented Interfaces:
java.lang.Iterable<Row>, Sheet
public class XSSFChartSheet
extends XSSFSheet

High level representation of Sheet Parts that are of type 'chartsheet'.

Chart sheet is a special kind of Sheet that contains only chart and no data.

Author:
Yegor Kozlov

Field Summary
protected  org.openxmlformats.schemas.spreadsheetml.x2006.main.CTChartsheet chartsheet
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFSheet
sheet, worksheet
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Fields inherited from interface org.apache.poi.ss.usermodel.Sheet
BottomMargin, FooterMargin, HeaderMargin, LeftMargin, PANE_LOWER_LEFT, PANE_LOWER_RIGHT, PANE_UPPER_LEFT, PANE_UPPER_RIGHT, RightMargin, TopMargin
Constructor Summary
protected XSSFChartSheet(PackagePart part, PackageRelationship rel)
Method Summary
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTChartsheet | getCTChartsheet() Provide access to the CTChartsheet bean holding this sheet's data
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDrawing | getCTDrawing()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTLegacyDrawing | getCTLegacyDrawing()
protected void | read(java.io.InputStream is)
protected void | write(java.io.OutputStream out)
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFSheet
addHyperlink, addMergedRegion, addValidationData, autoSizeColumn, autoSizeColumn, commit, createComment, createDrawingPatriarch, createFreezePane, createFreezePane, createRow, createSplitPane, createTable, disableLocking, enableLocking, findEndOfRowOutlineGroup, getActiveCell, getAutobreaks, getCellComment, getColumnBreaks, getColumnHelper, getColumnStyle, getColumnWidth, getCommentsTable, getCTWorksheet, getDataValidationHelper, getDataValidations, getDefaultColumnWidth, getDefaultRowHeight, getDefaultRowHeightInPoints, getDisplayGuts, getEvenFooter, getEvenHeader, getFirstFooter, getFirstHeader, getFirstRowNum, getFitToPage, getFooter, getForceFormulaRecalculation, getHeader, getHorizontallyCenter, getHyperlink, getLastRowNum, getLeftCol, getMargin, getMergedRegion, getNumberOfComments, getNumHyperlinks, getNumMergedRegions, getOddFooter, getOddHeader, getPaneInformation, getPhysicalNumberOfRows, getPrintSetup, getProtect, getRow, getRowBreaks, getRowSumsBelow, getRowSumsRight, getScenarioProtect, getSheetConditionalFormatting, getSheetName, getTables, getTopRow, getVerticallyCenter, getVMLDrawing, getWorkbook, groupColumn, groupRow, hasComments, isAutoFilterLocked, isColumnBroken, isColumnHidden, isDeleteColumnsLocked, isDeleteRowsLocked, isDisplayFormulas, isDisplayGridlines, isDisplayRowColHeadings, isDisplayZeros, isFormatCellsLocked, isFormatColumnsLocked, isFormatRowsLocked, isInsertColumnsLocked, isInsertHyperlinksLocked, isInsertRowsLocked, isObjectsLocked, isPivotTablesLocked, isPrintGridlines, isRightToLeft, isRowBroken, isScenariosLocked, isSelected, isSelectLockedCellsLocked, isSelectUnlockedCellsLocked, isSheetLocked, isSortLocked, iterator, lockAutoFilter, lockDeleteColumns, lockDeleteRows, lockFormatCells, lockFormatColumns, lockFormatRows, lockInsertColumns, lockInsertHyperlinks, lockInsertRows, lockObjects, lockPivotTables, lockScenarios, lockSelectLockedCells, lockSelectUnlockedCells, lockSort, onDocumentCreate, onDocumentRead, protectSheet, removeArrayFormula, removeColumnBreak, removeMergedRegion, removeRow, removeRowBreak, rowIterator, setActiveCell, setArrayFormula, setAutobreaks, setAutoFilter, setCellComment, setColumnBreak, setColumnGroupCollapsed, setColumnHidden, setColumnWidth, setDefaultColumnStyle, setDefaultColumnWidth, setDefaultRowHeight, setDefaultRowHeightInPoints, setDisplayFormulas, setDisplayGridlines, setDisplayGuts, setDisplayRowColHeadings, setDisplayZeros, setFitToPage, setForceFormulaRecalculation, setHorizontallyCenter, setMargin, setPrintGridlines, setRightToLeft, setRowBreak, setRowGroupCollapsed, setRowSumsBelow, setRowSumsRight, setSelected, setTabColor, setVerticallyCenter, setZoom, setZoom, shiftRows, shiftRows, showInPane, ungroupColumn, ungroupRow
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

chartsheet

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTChartsheet chartsheet
Constructor Detail

XSSFChartSheet

protected XSSFChartSheet(PackagePart part,
                         PackageRelationship rel)
Method Detail

read

protected void read(java.io.InputStream is)
             throws java.io.IOException
Overrides:
read in class XSSFSheet
Throws:
java.io.IOException

getCTChartsheet

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTChartsheet getCTChartsheet()
Provide access to the CTChartsheet bean holding this sheet's data

Returns:
the CTChartsheet bean holding this sheet's data

getCTDrawing

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDrawing getCTDrawing()
Overrides:
getCTDrawing in class XSSFSheet

getCTLegacyDrawing

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTLegacyDrawing getCTLegacyDrawing()
Overrides:
getCTLegacyDrawing in class XSSFSheet

write

protected void write(java.io.OutputStream out)
              throws java.io.IOException
Overrides:
write in class XSSFSheet
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFChildAnchor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFChildAnchor

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFAnchor
        extended by  org.apache.poi.xssf.usermodel.XSSFChildAnchor

public final class XSSFChildAnchor
extends XSSFAnchor

Author:
Yegor Kozlov

Constructor Summary
XSSFChildAnchor(org.openxmlformats.schemas.drawingml.x2006.main.CTTransform2D t2d)
XSSFChildAnchor(int x, int y, int cx, int cy)
Method Summary
org.openxmlformats.schemas.drawingml.x2006.main.CTTransform2D | getCTTransform2D()
int | getDx1()
int | getDx2()
int | getDy1()
int | getDy2()
void | setDx1(int dx1)
void | setDx2(int dx2)
void | setDy1(int dy1)
void | setDy2(int dy2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFChildAnchor

public XSSFChildAnchor(int x,
                       int y,
                       int cx,
                       int cy)

XSSFChildAnchor

public XSSFChildAnchor(org.openxmlformats.schemas.drawingml.x2006.main.CTTransform2D t2d)
Method Detail

getCTTransform2D

@Internal
public org.openxmlformats.schemas.drawingml.x2006.main.CTTransform2D getCTTransform2D()

getDx1

public int getDx1()
Specified by:
getDx1 in class XSSFAnchor

setDx1

public void setDx1(int dx1)
Specified by:
setDx1 in class XSSFAnchor

getDy1

public int getDy1()
Specified by:
getDy1 in class XSSFAnchor

setDy1

public void setDy1(int dy1)
Specified by:
setDy1 in class XSSFAnchor

getDy2

public int getDy2()
Specified by:
getDy2 in class XSSFAnchor

setDy2

public void setDy2(int dy2)
Specified by:
setDy2 in class XSSFAnchor

getDx2

public int getDx2()
Specified by:
getDx2 in class XSSFAnchor

setDx2

public void setDx2(int dx2)
Specified by:
setDx2 in class XSSFAnchor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFClientAnchor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFClientAnchor

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFAnchor
        extended by  org.apache.poi.xssf.usermodel.XSSFClientAnchor
All Implemented Interfaces:
ClientAnchor
public final class XSSFClientAnchor
extends XSSFAnchor
implements ClientAnchor

A client anchor is attached to an excel worksheet. It anchors against top-left and bottom-right cells.

Author:
Yegor Kozlov

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.ClientAnchor
DONT_MOVE_AND_RESIZE, MOVE_AND_RESIZE, MOVE_DONT_RESIZE
Constructor Summary
 | XSSFClientAnchor() Creates a new client anchor and defaults all the anchor positions to 0.
protected | XSSFClientAnchor(org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker cell1, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker cell2) Create XSSFClientAnchor from existing xml beans
 | XSSFClientAnchor(int dx1, int dy1, int dx2, int dy2, int col1, int row1, int col2, int row2) Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
Method Summary
boolean | equals(java.lang.Object o)
int | getAnchorType() Gets the anchor type
short | getCol1() Returns the column (0 based) of the first cell.
short | getCol2() Returns the column (0 based) of the second cell.
int | getDx1() Returns the x coordinate within the first cell.
int | getDx2() Returns the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
int | getDy1() Returns the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
int | getDy2() Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker | getFrom() Return starting anchor point
int | getRow1() Returns the row (0 based) of the first cell.
int | getRow2() Returns the row (0 based) of the second cell.
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker | getTo() Return ending anchor point
boolean | isSet()
void | setAnchorType(int anchorType) Sets the anchor type
void | setCol1(int col1) Sets the column (0 based) of the first cell.
void | setCol2(int col2) Returns the column (0 based) of the second cell.
void | setDx1(int dx1) Sets the x coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
void | setDx2(int dx2) Sets the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
void | setDy1(int dy1) Sets the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
void | setDy2(int dy2) Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL
protected void | setFrom(org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker from)
void | setRow1(int row1) Returns the row (0 based) of the first cell.
void | setRow2(int row2) Returns the row (0 based) of the first cell.
protected void | setTo(org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker to)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSSFClientAnchor

public XSSFClientAnchor()
Creates a new client anchor and defaults all the anchor positions to 0.

XSSFClientAnchor

public XSSFClientAnchor(int dx1,
                        int dy1,
                        int dx2,
                        int dy2,
                        int col1,
                        int row1,
                        int col2,
                        int row2)
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.

Parameters:
dx1 - the x coordinate within the first cell.
dy1 - the y coordinate within the first cell.
dx2 - the x coordinate within the second cell.
dy2 - the y coordinate within the second cell.
col1 - the column (0 based) of the first cell.
row1 - the row (0 based) of the first cell.
col2 - the column (0 based) of the second cell.
row2 - the row (0 based) of the second cell.

XSSFClientAnchor

protected XSSFClientAnchor(org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker cell1,
                           org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker cell2)
Create XSSFClientAnchor from existing xml beans

Parameters:
cell1 - starting anchor point
cell2 - ending anchor point
Method Detail

getCol1

public short getCol1()
Description copied from interface: ClientAnchor
Returns the column (0 based) of the first cell.

Specified by:
getCol1 in interface ClientAnchor
Returns:
0-based column of the first cell.

setCol1

public void setCol1(int col1)
Description copied from interface: ClientAnchor
Sets the column (0 based) of the first cell.

Specified by:
setCol1 in interface ClientAnchor
Parameters:
col1 - 0-based column of the first cell.

getCol2

public short getCol2()
Description copied from interface: ClientAnchor
Returns the column (0 based) of the second cell.

Specified by:
getCol2 in interface ClientAnchor
Returns:
0-based column of the second cell.

setCol2

public void setCol2(int col2)
Description copied from interface: ClientAnchor
Returns the column (0 based) of the second cell.

Specified by:
setCol2 in interface ClientAnchor
Parameters:
col2 - 0-based column of the second cell.

getRow1

public int getRow1()
Description copied from interface: ClientAnchor
Returns the row (0 based) of the first cell.

Specified by:
getRow1 in interface ClientAnchor
Returns:
0-based row of the first cell.

setRow1

public void setRow1(int row1)
Description copied from interface: ClientAnchor
Returns the row (0 based) of the first cell.

Specified by:
setRow1 in interface ClientAnchor
Parameters:
row1 - 0-based row of the first cell.

getRow2

public int getRow2()
Description copied from interface: ClientAnchor
Returns the row (0 based) of the second cell.

Specified by:
getRow2 in interface ClientAnchor
Returns:
0-based row of the second cell.

setRow2

public void setRow2(int row2)
Description copied from interface: ClientAnchor
Returns the row (0 based) of the first cell.

Specified by:
setRow2 in interface ClientAnchor
Parameters:
row2 - 0-based row of the first cell.

getDx1

public int getDx1()
Description copied from interface: ClientAnchor
Returns the x coordinate within the first cell. Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
getDx1 in interface ClientAnchor
Specified by:
getDx1 in class XSSFAnchor
Returns:
the x coordinate within the first cell

setDx1

public void setDx1(int dx1)
Description copied from interface: ClientAnchor
Sets the x coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
setDx1 in interface ClientAnchor
Specified by:
setDx1 in class XSSFAnchor
Parameters:
dx1 - the x coordinate within the first cell

getDy1

public int getDy1()
Description copied from interface: ClientAnchor
Returns the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
getDy1 in interface ClientAnchor
Specified by:
getDy1 in class XSSFAnchor
Returns:
the y coordinate within the first cell

setDy1

public void setDy1(int dy1)
Description copied from interface: ClientAnchor
Sets the y coordinate within the first cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
setDy1 in interface ClientAnchor
Specified by:
setDy1 in class XSSFAnchor
Parameters:
dy1 - the y coordinate within the first cell

getDy2

public int getDy2()
Description copied from interface: ClientAnchor
Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
getDy2 in interface ClientAnchor
Specified by:
getDy2 in class XSSFAnchor
Returns:
the y coordinate within the second cell

setDy2

public void setDy2(int dy2)
Description copied from interface: ClientAnchor
Sets the y coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
setDy2 in interface ClientAnchor
Specified by:
setDy2 in class XSSFAnchor
Parameters:
dy2 - the y coordinate within the second cell

getDx2

public int getDx2()
Description copied from interface: ClientAnchor
Returns the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
getDx2 in interface ClientAnchor
Specified by:
getDx2 in class XSSFAnchor
Returns:
the x coordinate within the second cell

setDx2

public void setDx2(int dx2)
Description copied from interface: ClientAnchor
Sets the x coordinate within the second cell Note - XSSF and HSSF have a slightly different coordinate system, values in XSSF are larger by a factor of XSSFShape.EMU_PER_PIXEL

Specified by:
setDx2 in interface ClientAnchor
Specified by:
setDx2 in class XSSFAnchor
Parameters:
dx2 - the x coordinate within the second cell

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getFrom

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker getFrom()
Return starting anchor point

Returns:
starting anchor point

setFrom

protected void setFrom(org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker from)

getTo

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker getTo()
Return ending anchor point

Returns:
ending anchor point

setTo

protected void setTo(org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTMarker to)

setAnchorType

public void setAnchorType(int anchorType)
Sets the anchor type

0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

Specified by:
setAnchorType in interface ClientAnchor
Parameters:
anchorType - the anchor type
See Also:
ClientAnchor.MOVE_AND_RESIZE, ClientAnchor.MOVE_DONT_RESIZE, ClientAnchor.DONT_MOVE_AND_RESIZE

getAnchorType

public int getAnchorType()
Gets the anchor type

0 = Move and size with Cells, 2 = Move but don't size with cells, 3 = Don't move or size with cells.

Specified by:
getAnchorType in interface ClientAnchor
Returns:
the anchor type
See Also:
ClientAnchor.MOVE_AND_RESIZE, ClientAnchor.MOVE_DONT_RESIZE, ClientAnchor.DONT_MOVE_AND_RESIZE

isSet

public boolean isSet()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFColor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFColor

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFColor
All Implemented Interfaces:
Color
public class XSSFColor
extends java.lang.Object
implements Color

Represents a color in SpreadsheetML

Constructor Summary
XSSFColor()
Create an new instance of XSSFColor
XSSFColor(byte[] rgb)
XSSFColor(java.awt.Color clr)
XSSFColor(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTColor color)
Create an instance of XSSFColor from the supplied XML bean
Method Summary
boolean | equals(java.lang.Object o)
byte[] | getARgb() Standard Alpha Red Green Blue ctColor value (ARGB).
java.lang.String | getARGBHex() Return the ARGB value in hex format, eg FF00FF00.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTColor | getCTColor() Returns the underlying XML bean
short | getIndexed() Indexed ctColor value.
byte[] | getRgb() Standard Red Green Blue ctColor value (RGB).
byte[] | getRgbWithTint() Standard Red Green Blue ctColor value (RGB) with applied tint.
int | getTheme() Index into the collection, referencing a particular or value expressed in the Theme part.
double | getTint() Specifies the tint value applied to the ctColor.
int | hashCode()
boolean | isAuto() A boolean value indicating the ctColor is automatic and system ctColor dependent.
void | setAuto(boolean auto) A boolean value indicating the ctColor is automatic and system ctColor dependent.
void | setIndexed(int indexed) Indexed ctColor value.
void | setRgb(byte[] rgb) Standard Alpha Red Green Blue ctColor value (ARGB).
void | setTheme(int theme) Index into the collection, referencing a particular or value expressed in the Theme part.
void | setTint(double tint) Specifies the tint value applied to the ctColor.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFColor

public XSSFColor(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTColor color)
Create an instance of XSSFColor from the supplied XML bean

XSSFColor

public XSSFColor()
Create an new instance of XSSFColor

XSSFColor

public XSSFColor(java.awt.Color clr)

XSSFColor

public XSSFColor(byte[] rgb)
Method Detail

isAuto

public boolean isAuto()
A boolean value indicating the ctColor is automatic and system ctColor dependent.

setAuto

public void setAuto(boolean auto)
A boolean value indicating the ctColor is automatic and system ctColor dependent.

getIndexed

public short getIndexed()
Indexed ctColor value. Only used for backwards compatibility. References a ctColor in indexedColors.

setIndexed

public void setIndexed(int indexed)
Indexed ctColor value. Only used for backwards compatibility. References a ctColor in indexedColors.

getRgb

public byte[] getRgb()
Standard Red Green Blue ctColor value (RGB). If there was an A (Alpha) value, it will be stripped.

getARgb

public byte[] getARgb()
Standard Alpha Red Green Blue ctColor value (ARGB).

getRgbWithTint

public byte[] getRgbWithTint()
Standard Red Green Blue ctColor value (RGB) with applied tint. Alpha values are ignored.

getARGBHex

public java.lang.String getARGBHex()
Return the ARGB value in hex format, eg FF00FF00. Works for both regular and indexed colours.

setRgb

public void setRgb(byte[] rgb)
Standard Alpha Red Green Blue ctColor value (ARGB).

getTheme

public int getTheme()
Index into the collection, referencing a particular or value expressed in the Theme part.

setTheme

public void setTheme(int theme)
Index into the collection, referencing a particular or value expressed in the Theme part.

getTint

public double getTint()
Specifies the tint value applied to the ctColor.

If tint is supplied, then it is applied to the RGB value of the ctColor to determine the final ctColor applied.

The tint value is stored as a double from -1.0 .. 1.0, where -1.0 means 100% darken and 1.0 means 100% lighten. Also, 0.0 means no change.

In loading the RGB value, it is converted to HLS where HLS values are (0..HLSMAX), where HLSMAX is currently 255.

Here are some examples of how to apply tint to ctColor:
 If (tint < 0)
 Lum' = Lum * (1.0 + tint)

 For example: Lum = 200; tint = -0.5; Darken 50%
 Lum' = 200 * (0.5) => 100
 For example: Lum = 200; tint = -1.0; Darken 100% (make black)
 Lum' = 200 * (1.0-1.0) => 0
 If (tint > 0)
 Lum' = Lum * (1.0-tint) + (HLSMAX - HLSMAX * (1.0-tint))
 For example: Lum = 100; tint = 0.75; Lighten 75%

 Lum' = 100 * (1-.75) + (HLSMAX - HLSMAX*(1-.75))
 = 100 * .25 + (255 - 255 * .25)
 = 25 + (255 - 63) = 25 + 192 = 217
 For example: Lum = 100; tint = 1.0; Lighten 100% (make white)
 Lum' = 100 * (1-1) + (HLSMAX - HLSMAX*(1-1))
 = 100 * 0 + (255 - 255 * 0)
 = 0 + (255 - 0) = 255

Returns:
the tint value

setTint

public void setTint(double tint)
Specifies the tint value applied to the ctColor.

If tint is supplied, then it is applied to the RGB value of the ctColor to determine the final ctColor applied.

The tint value is stored as a double from -1.0 .. 1.0, where -1.0 means 100% darken and 1.0 means 100% lighten. Also, 0.0 means no change.

In loading the RGB value, it is converted to HLS where HLS values are (0..HLSMAX), where HLSMAX is currently 255.

Here are some examples of how to apply tint to ctColor:
 If (tint < 0)
 Lum' = Lum * (1.0 + tint)

 For example: Lum = 200; tint = -0.5; Darken 50%
 Lum' = 200 * (0.5) => 100
 For example: Lum = 200; tint = -1.0; Darken 100% (make black)
 Lum' = 200 * (1.0-1.0) => 0
 If (tint > 0)
 Lum' = Lum * (1.0-tint) + (HLSMAX - HLSMAX * (1.0-tint))
 For example: Lum = 100; tint = 0.75; Lighten 75%

 Lum' = 100 * (1-.75) + (HLSMAX - HLSMAX*(1-.75))
 = 100 * .25 + (255 - 255 * .25)
 = 25 + (255 - 63) = 25 + 192 = 217
 For example: Lum = 100; tint = 1.0; Lighten 100% (make white)
 Lum' = 100 * (1-1) + (HLSMAX - HLSMAX*(1-1))
 = 100 * 0 + (255 - 255 * 0)
 = 0 + (255 - 0) = 255

Parameters:
tint - the tint value

getCTColor

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTColor getCTColor()
Returns the underlying XML bean

Returns:
the underlying XML bean

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFComment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFComment

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFComment
All Implemented Interfaces:
Comment
public class XSSFComment
extends java.lang.Object
implements Comment

Constructor Summary
XSSFComment(CommentsTable comments, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment comment, schemasMicrosoftComVml.CTShape vmlShape)
Creates a new XSSFComment, associated with a given low level comment object.
Method Summary
java.lang.String | getAuthor() Name of the original comment author
int | getColumn() Return the column of the cell that contains the comment
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment | getCTComment()
protected schemasMicrosoftComVml.CTShape | getCTShape()
int | getRow() Return the row of the cell that contains the comment
XSSFRichTextString | getString() Fetches the rich text string of the comment
boolean | isVisible() Sets whether this comment is visible.
void | setAuthor(java.lang.String author) Name of the original comment author.
void | setColumn(int col) Set the column of the cell that contains the comment
void | setRow(int row) Set the row of the cell that contains the comment
void | setString(RichTextString string) Sets the rich text string used by this comment.
void | setString(java.lang.String string)
void | setVisible(boolean visible) Returns whether this comment is visible.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFComment

public XSSFComment(CommentsTable comments,
                   org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment comment,
                   schemasMicrosoftComVml.CTShape vmlShape)
Creates a new XSSFComment, associated with a given low level comment object.

Method Detail

getAuthor

public java.lang.String getAuthor()
Description copied from interface: Comment
Name of the original comment author

Specified by:
getAuthor in interface Comment
Returns:
Name of the original comment author. Default value is blank.

setAuthor

public void setAuthor(java.lang.String author)
Name of the original comment author. Default value is blank.

Specified by:
setAuthor in interface Comment
Parameters:
author - the name of the original author of the comment

getColumn

public int getColumn()
Description copied from interface: Comment
Return the column of the cell that contains the comment

Specified by:
getColumn in interface Comment
Returns:
the 0-based column of the cell that the comment is associated with.

getRow

public int getRow()
Description copied from interface: Comment
Return the row of the cell that contains the comment

Specified by:
getRow in interface Comment
Returns:
the 0-based row index of the cell that the comment is associated with.

isVisible

public boolean isVisible()
Description copied from interface: Comment
Sets whether this comment is visible.

Specified by:
isVisible in interface Comment
Returns:
whether the comment is visible

setVisible

public void setVisible(boolean visible)
Description copied from interface: Comment
Returns whether this comment is visible.

Specified by:
setVisible in interface Comment
Parameters:
visible - whether the comment is visible

setColumn

public void setColumn(int col)
Set the column of the cell that contains the comment

Specified by:
setColumn in interface Comment
Parameters:
col - the 0-based column of the cell that contains the comment

setRow

public void setRow(int row)
Set the row of the cell that contains the comment

Specified by:
setRow in interface Comment
Parameters:
row - the 0-based row of the cell that contains the comment

getString

public XSSFRichTextString getString()
Description copied from interface: Comment
Fetches the rich text string of the comment

Specified by:
getString in interface Comment
Returns:
the rich text string of the comment

setString

public void setString(RichTextString string)
Sets the rich text string used by this comment.

Specified by:
setString in interface Comment
Parameters:
string - the XSSFRichTextString used by this object.

setString

public void setString(java.lang.String string)

getCTComment

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTComment getCTComment()
Returns:
the xml bean holding this comment's properties

getCTShape

protected schemasMicrosoftComVml.CTShape getCTShape()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFConditionalFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFConditionalFormatting

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFConditionalFormatting
All Implemented Interfaces:
ConditionalFormatting
public class XSSFConditionalFormatting
extends java.lang.Object
implements ConditionalFormatting

Author:
Yegor Kozlov

Method Summary
void | addRule(ConditionalFormattingRule cfRule) Add a Conditional Formatting rule.
CellRangeAddress[] | getFormattingRanges()
int | getNumberOfRules()
XSSFConditionalFormattingRule | getRule(int idx)
void | setRule(int idx, ConditionalFormattingRule cfRule) Replaces an existing Conditional Formatting rule at position idx.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getFormattingRanges

public CellRangeAddress[] getFormattingRanges()
Specified by:
getFormattingRanges in interface ConditionalFormatting
Returns:
array of CellRangeAddresss. Never null

setRule

public void setRule(int idx,
                    ConditionalFormattingRule cfRule)
Replaces an existing Conditional Formatting rule at position idx. Excel allows to create up to 3 Conditional Formatting rules. This method can be useful to modify existing Conditional Formatting rules.

Specified by:
setRule in interface ConditionalFormatting
Parameters:
idx - position of the rule. Should be between 0 and 2.
cfRule - - Conditional Formatting rule

addRule

public void addRule(ConditionalFormattingRule cfRule)
Add a Conditional Formatting rule. Excel allows to create up to 3 Conditional Formatting rules.

Specified by:
addRule in interface ConditionalFormatting
Parameters:
cfRule - - Conditional Formatting rule

getRule

public XSSFConditionalFormattingRule getRule(int idx)
Specified by:
getRule in interface ConditionalFormatting
Returns:
the Conditional Formatting rule at position idx.

getNumberOfRules

public int getNumberOfRules()
Specified by:
getNumberOfRules in interface ConditionalFormatting
Returns:
number of Conditional Formatting rules.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFConditionalFormattingRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFConditionalFormattingRule

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule
All Implemented Interfaces:
ConditionalFormattingRule
public class XSSFConditionalFormattingRule
extends java.lang.Object
implements ConditionalFormattingRule

Author:
Yegor Kozlov

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.ConditionalFormattingRule
CONDITION_TYPE_CELL_VALUE_IS, CONDITION_TYPE_FORMULA
Method Summary
XSSFBorderFormatting | createBorderFormatting() Create a new border formatting structure if it does not exist, otherwise just return existing object.
XSSFFontFormatting | createFontFormatting() Create a new font formatting structure if it does not exist, otherwise just return existing object.
XSSFPatternFormatting | createPatternFormatting() Create a new pattern formatting structure if it does not exist, otherwise just return existing object.
XSSFBorderFormatting | getBorderFormatting()
byte | getComparisonOperation() The comparison function used when the type of conditional formatting is set to ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS
byte | getConditionType() Type of conditional formatting rule.
XSSFFontFormatting | getFontFormatting()
java.lang.String | getFormula1() The formula used to evaluate the first operand for the conditional formatting rule.
java.lang.String | getFormula2() The formula used to evaluate the second operand of the comparison when comparison type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN
XSSFPatternFormatting | getPatternFormatting()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createBorderFormatting

public XSSFBorderFormatting createBorderFormatting()
Create a new border formatting structure if it does not exist, otherwise just return existing object.

Specified by:
createBorderFormatting in interface ConditionalFormattingRule
Returns:
- border formatting object, never returns null.

getBorderFormatting

public XSSFBorderFormatting getBorderFormatting()
Specified by:
getBorderFormatting in interface ConditionalFormattingRule
Returns:
- border formatting object if defined, null otherwise

createFontFormatting

public XSSFFontFormatting createFontFormatting()
Create a new font formatting structure if it does not exist, otherwise just return existing object.

Specified by:
createFontFormatting in interface ConditionalFormattingRule
Returns:
- font formatting object, never returns null.

getFontFormatting

public XSSFFontFormatting getFontFormatting()
Specified by:
getFontFormatting in interface ConditionalFormattingRule
Returns:
- font formatting object if defined, null otherwise

createPatternFormatting

public XSSFPatternFormatting createPatternFormatting()
Create a new pattern formatting structure if it does not exist, otherwise just return existing object.

Specified by:
createPatternFormatting in interface ConditionalFormattingRule
Returns:
- pattern formatting object, never returns null.

getPatternFormatting

public XSSFPatternFormatting getPatternFormatting()
Specified by:
getPatternFormatting in interface ConditionalFormattingRule
Returns:
- pattern formatting object if defined, null otherwise

getConditionType

public byte getConditionType()
Type of conditional formatting rule.

MUST be either ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS or ConditionalFormattingRule.CONDITION_TYPE_FORMULA

Specified by:
getConditionType in interface ConditionalFormattingRule
Returns:
the type of condition

getComparisonOperation

public byte getComparisonOperation()
The comparison function used when the type of conditional formatting is set to ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS

MUST be a constant from ComparisonOperator

Specified by:
getComparisonOperation in interface ConditionalFormattingRule
Returns:
the conditional format operator

getFormula1

public java.lang.String getFormula1()
The formula used to evaluate the first operand for the conditional formatting rule.

If the condition type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS, this field is the first operand of the comparison. If type is ConditionalFormattingRule.CONDITION_TYPE_FORMULA, this formula is used to determine if the conditional formatting is applied.

If comparison type is ConditionalFormattingRule.CONDITION_TYPE_FORMULA the formula MUST be a Boolean function

Specified by:
getFormula1 in interface ConditionalFormattingRule
Returns:
the first formula

getFormula2

public java.lang.String getFormula2()
The formula used to evaluate the second operand of the comparison when comparison type is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS and operator is either ComparisonOperator.BETWEEN or ComparisonOperator.NOT_BETWEEN

Specified by:
getFormula2 in interface ConditionalFormattingRule
Returns:
the second formula
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFConnector

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFConnector

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFShape
        extended by  org.apache.poi.xssf.usermodel.XSSFConnector

public final class XSSFConnector
extends XSSFShape

A connection shape drawing element. A connection shape is a line, etc. that connects two other shapes in this drawing.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFShape
anchor, drawing, EMU_PER_PIXEL, EMU_PER_POINT, parent, PIXEL_DPI, POINT_DPI
Constructor Summary
protected XSSFConnector(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector ctShape)
Construct a new XSSFConnector object.
Method Summary
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector | getCTConnector()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties | getShapeProperties() Returns xml bean with shape properties.
int | getShapeType() Gets the shape type, one of the constants defined in ShapeTypes.
protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector | prototype() Initialize default structure of a new auto-shape
void | setShapeType(int type) Sets the shape types.
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFShape
getAnchor, getDrawing, getParent, isNoFill, setFillColor, setLineStyle, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFConnector

protected XSSFConnector(XSSFDrawing drawing,
                        org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector ctShape)
Construct a new XSSFConnector object.

Parameters:
drawing - the XSSFDrawing that owns this shape
ctShape - the shape bean that holds all the shape properties
Method Detail

prototype

protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector prototype()
Initialize default structure of a new auto-shape

getCTConnector

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector getCTConnector()

getShapeType

public int getShapeType()
Gets the shape type, one of the constants defined in ShapeTypes.

Returns:
the shape type
See Also:
ShapeTypes

setShapeType

public void setShapeType(int type)
Sets the shape types.

Parameters:
type - the shape type, one of the constants defined in ShapeTypes.
See Also:
ShapeTypes

getShapeProperties

protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties getShapeProperties()
Description copied from class: XSSFShape
Returns xml bean with shape properties.

Specified by:
getShapeProperties in class XSSFShape
Returns:
xml bean with shape properties.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFCreationHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFCreationHelper

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFCreationHelper
All Implemented Interfaces:
CreationHelper
public class XSSFCreationHelper
extends java.lang.Object
implements CreationHelper

Method Summary
XSSFClientAnchor | createClientAnchor() Creates a XSSFClientAnchor.
XSSFDataFormat | createDataFormat() Creates a new DataFormat instance
XSSFFormulaEvaluator | createFormulaEvaluator() Creates a XSSFFormulaEvaluator, the object that evaluates formula cells.
XSSFHyperlink | createHyperlink(int type) Creates a new Hyperlink, of the given type
XSSFRichTextString | createRichTextString(java.lang.String text) Creates a new XSSFRichTextString for you.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createRichTextString

public XSSFRichTextString createRichTextString(java.lang.String text)
Creates a new XSSFRichTextString for you.

Specified by:
createRichTextString in interface CreationHelper
Parameters:
text - The text to initialise the RichTextString with

createDataFormat

public XSSFDataFormat createDataFormat()
Description copied from interface: CreationHelper
Creates a new DataFormat instance

Specified by:
createDataFormat in interface CreationHelper

createHyperlink

public XSSFHyperlink createHyperlink(int type)
Description copied from interface: CreationHelper
Creates a new Hyperlink, of the given type

Specified by:
createHyperlink in interface CreationHelper

createFormulaEvaluator

public XSSFFormulaEvaluator createFormulaEvaluator()
Creates a XSSFFormulaEvaluator, the object that evaluates formula cells.

Specified by:
createFormulaEvaluator in interface CreationHelper
Returns:
a XSSFFormulaEvaluator instance

createClientAnchor

public XSSFClientAnchor createClientAnchor()
Creates a XSSFClientAnchor. Use this object to position drawing object in a sheet

Specified by:
createClientAnchor in interface CreationHelper
Returns:
a XSSFClientAnchor instance
See Also:
Drawing
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFDataFormat

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFDataFormat

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFDataFormat
All Implemented Interfaces:
DataFormat
public class XSSFDataFormat
extends java.lang.Object
implements DataFormat

Handles data formats for XSSF.

Constructor Summary
protected XSSFDataFormat(StylesTable stylesSource)
Method Summary
java.lang.String | getFormat(short index) get the format string that matches the given format index
short | getFormat(java.lang.String format) Get the format index that matches the given format string, creating a new format entry if required.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFDataFormat

protected XSSFDataFormat(StylesTable stylesSource)
Method Detail

getFormat

public short getFormat(java.lang.String format)
Get the format index that matches the given format string, creating a new format entry if required. Aliases text to the proper format as required.

Specified by:
getFormat in interface DataFormat
Parameters:
format - string matching a built in format
Returns:
index of format.

getFormat

public java.lang.String getFormat(short index)
get the format string that matches the given format index

Specified by:
getFormat in interface DataFormat
Parameters:
index - of a format
Returns:
string represented at index of format or null if there is not a format at that index
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFDataValidation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFDataValidation

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFDataValidation
All Implemented Interfaces:
DataValidation
public class XSSFDataValidation
extends java.lang.Object
implements DataValidation

Author:
Radhakrishnan J

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.usermodel.DataValidation
DataValidation.ErrorStyle
Constructor Summary
XSSFDataValidation(XSSFDataValidationConstraint constraint, CellRangeAddressList regions, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDataValidation ctDataValidation)
Method Summary
void | createErrorBox(java.lang.String title, java.lang.String text) Sets the title and text for the error box .
void | createPromptBox(java.lang.String title, java.lang.String text) Sets the title and text for the prompt box .
boolean | getEmptyCellAllowed() Retrieve the settings for empty cells allowed
java.lang.String | getErrorBoxText()
java.lang.String | getErrorBoxTitle()
int | getErrorStyle() o
java.lang.String | getPromptBoxText()
java.lang.String | getPromptBoxTitle()
CellRangeAddressList | getRegions()
boolean | getShowErrorBox()
boolean | getShowPromptBox()
boolean | getSuppressDropDownArrow() Useful only list validation objects .
DataValidationConstraint | getValidationConstraint()
java.lang.String | prettyPrint()
void | setEmptyCellAllowed(boolean allowed) Sets if this object allows empty as a valid value
void | setErrorStyle(int errorStyle) Sets the error style for error box
void | setShowErrorBox(boolean show) Sets the behaviour when an invalid value is entered
void | setShowPromptBox(boolean show) Sets the behaviour when a cell which belongs to this object is selected
void | setSuppressDropDownArrow(boolean suppress) Useful for list validation objects .
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFDataValidation

public XSSFDataValidation(XSSFDataValidationConstraint constraint,
                          CellRangeAddressList regions,
                          org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDataValidation ctDataValidation)
Method Detail

createErrorBox

public void createErrorBox(java.lang.String title,
                           java.lang.String text)
Description copied from interface: DataValidation
Sets the title and text for the error box . Error box is displayed when the user enters an invalid value int o a cell which belongs to this validation object . In order for an error box to be displayed you should also use method setShowErrorBox( boolean show )

Specified by:
createErrorBox in interface DataValidation
Parameters:
title - The error box's title
text - The error box's text

createPromptBox

public void createPromptBox(java.lang.String title,
                            java.lang.String text)
Description copied from interface: DataValidation
Sets the title and text for the prompt box . Prompt box is displayed when the user selects a cell which belongs to this validation object . In order for a prompt box to be displayed you should also use method setShowPromptBox( boolean show )

Specified by:
createPromptBox in interface DataValidation
Parameters:
title - The prompt box's title
text - The prompt box's text

getEmptyCellAllowed

public boolean getEmptyCellAllowed()
Description copied from interface: DataValidation
Retrieve the settings for empty cells allowed

Specified by:
getEmptyCellAllowed in interface DataValidation
Returns:
True if this object should treats empty as valid value , false otherwise

getErrorBoxText

public java.lang.String getErrorBoxText()
Specified by:
getErrorBoxText in interface DataValidation
Returns:
Error box's text or null

getErrorBoxTitle

public java.lang.String getErrorBoxTitle()
Specified by:
getErrorBoxTitle in interface DataValidation
Returns:
Error box's title or null

getErrorStyle

public int getErrorStyle()
Description copied from interface: DataValidation
o

Specified by:
getErrorStyle in interface DataValidation
Returns:
the error style of error box
See Also:
DataValidation.ErrorStyle

getPromptBoxText

public java.lang.String getPromptBoxText()
Specified by:
getPromptBoxText in interface DataValidation
Returns:
Prompt box's text or null

getPromptBoxTitle

public java.lang.String getPromptBoxTitle()
Specified by:
getPromptBoxTitle in interface DataValidation
Returns:
Prompt box's title or null

getShowErrorBox

public boolean getShowErrorBox()
Specified by:
getShowErrorBox in interface DataValidation
Returns:
true if an error box should be displayed , false otherwise

getShowPromptBox

public boolean getShowPromptBox()
Specified by:
getShowPromptBox in interface DataValidation
Returns:
true if an prompt box should be displayed , false otherwise

getSuppressDropDownArrow

public boolean getSuppressDropDownArrow()
Description copied from interface: DataValidation
Useful only list validation objects . This method always returns false if the object isn't a list validation object

Specified by:
getSuppressDropDownArrow in interface DataValidation
Returns:
true if a list should display the values into a drop down list , false otherwise .

getValidationConstraint

public DataValidationConstraint getValidationConstraint()
Specified by:
getValidationConstraint in interface DataValidation

setEmptyCellAllowed

public void setEmptyCellAllowed(boolean allowed)
Description copied from interface: DataValidation
Sets if this object allows empty as a valid value

Specified by:
setEmptyCellAllowed in interface DataValidation
Parameters:
allowed - true if this object should treats empty as valid value , false otherwise

setErrorStyle

public void setErrorStyle(int errorStyle)
Description copied from interface: DataValidation
Sets the error style for error box

Specified by:
setErrorStyle in interface DataValidation
See Also:
DataValidation.ErrorStyle

setShowErrorBox

public void setShowErrorBox(boolean show)
Description copied from interface: DataValidation
Sets the behaviour when an invalid value is entered

Specified by:
setShowErrorBox in interface DataValidation
Parameters:
show - true if an error box should be displayed , false otherwise

setShowPromptBox

public void setShowPromptBox(boolean show)
Description copied from interface: DataValidation
Sets the behaviour when a cell which belongs to this object is selected

Specified by:
setShowPromptBox in interface DataValidation
Parameters:
show - true if an prompt box should be displayed , false otherwise

setSuppressDropDownArrow

public void setSuppressDropDownArrow(boolean suppress)
Description copied from interface: DataValidation
Useful for list validation objects .

Specified by:
setSuppressDropDownArrow in interface DataValidation
Parameters:
suppress - True if a list should display the values into a drop down list , false otherwise . In other words , if a list should display the arrow sign on its right side

getRegions

public CellRangeAddressList getRegions()
Specified by:
getRegions in interface DataValidation

prettyPrint

public java.lang.String prettyPrint()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFDataValidationConstraint

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFDataValidationConstraint

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint
All Implemented Interfaces:
DataValidationConstraint
public class XSSFDataValidationConstraint
extends java.lang.Object
implements DataValidationConstraint

Author:
Radhakrishnan J

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.usermodel.DataValidationConstraint
DataValidationConstraint.OperatorType, DataValidationConstraint.ValidationType
Constructor Summary
XSSFDataValidationConstraint(int validationType, int operator, java.lang.String formula1)
XSSFDataValidationConstraint(int validationType, int operator, java.lang.String formula1, java.lang.String formula2)
XSSFDataValidationConstraint(int validationType, java.lang.String formula1)
XSSFDataValidationConstraint(java.lang.String[] explicitListOfValues)
Method Summary
java.lang.String[] | getExplicitListValues()
java.lang.String | getFormula1()
java.lang.String | getFormula2()
int | getOperator()
int | getValidationType()
protected boolean | isFormulaEmpty(java.lang.String formula1)
java.lang.String | prettyPrint()
protected java.lang.String | removeLeadingEquals(java.lang.String formula1)
void | setExplicitListValues(java.lang.String[] explicitListValues)
void | setFormula1(java.lang.String formula1) Sets a formula for expression 1.
void | setFormula2(java.lang.String formula2) Sets a formula for expression 2.
void | setOperator(int operator) Sets the comparison operator for this constraint
void | validate()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFDataValidationConstraint

public XSSFDataValidationConstraint(java.lang.String[] explicitListOfValues)

XSSFDataValidationConstraint

public XSSFDataValidationConstraint(int validationType,
                                    java.lang.String formula1)

XSSFDataValidationConstraint

public XSSFDataValidationConstraint(int validationType,
                                    int operator,
                                    java.lang.String formula1)

XSSFDataValidationConstraint

public XSSFDataValidationConstraint(int validationType,
                                    int operator,
                                    java.lang.String formula1,
                                    java.lang.String formula2)
Method Detail

getExplicitListValues

public java.lang.String[] getExplicitListValues()
Specified by:
getExplicitListValues in interface DataValidationConstraint

getFormula1

public java.lang.String getFormula1()
Specified by:
getFormula1 in interface DataValidationConstraint
Returns:
the formula for expression 1. May be null

getFormula2

public java.lang.String getFormula2()
Specified by:
getFormula2 in interface DataValidationConstraint
Returns:
the formula for expression 2. May be null

getOperator

public int getOperator()
Specified by:
getOperator in interface DataValidationConstraint
Returns:
the operator used for this constraint
See Also:
DataValidationConstraint.OperatorType

getValidationType

public int getValidationType()
Specified by:
getValidationType in interface DataValidationConstraint
Returns:
data validation type of this constraint
See Also:
DataValidationConstraint.ValidationType

setExplicitListValues

public void setExplicitListValues(java.lang.String[] explicitListValues)
Specified by:
setExplicitListValues in interface DataValidationConstraint

setFormula1

public void setFormula1(java.lang.String formula1)
Description copied from interface: DataValidationConstraint
Sets a formula for expression 1.

Specified by:
setFormula1 in interface DataValidationConstraint

removeLeadingEquals

protected java.lang.String removeLeadingEquals(java.lang.String formula1)

setFormula2

public void setFormula2(java.lang.String formula2)
Description copied from interface: DataValidationConstraint
Sets a formula for expression 2.

Specified by:
setFormula2 in interface DataValidationConstraint

setOperator

public void setOperator(int operator)
Description copied from interface: DataValidationConstraint
Sets the comparison operator for this constraint

Specified by:
setOperator in interface DataValidationConstraint
See Also:
DataValidationConstraint.OperatorType

validate

public void validate()

isFormulaEmpty

protected boolean isFormulaEmpty(java.lang.String formula1)

prettyPrint

public java.lang.String prettyPrint()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFDataValidationHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFDataValidationHelper

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFDataValidationHelper
All Implemented Interfaces:
DataValidationHelper
public class XSSFDataValidationHelper
extends java.lang.Object
implements DataValidationHelper

Author:
Radhakrishnan J

Constructor Summary
XSSFDataValidationHelper(XSSFSheet xssfSheet)
Method Summary
DataValidationConstraint | createCustomConstraint(java.lang.String formula)
DataValidationConstraint | createDateConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2, java.lang.String dateFormat)
DataValidationConstraint | createDecimalConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createExplicitListConstraint(java.lang.String[] listOfValues)
DataValidationConstraint | createFormulaListConstraint(java.lang.String listFormula)
DataValidationConstraint | createIntegerConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createNumericConstraint(int validationType, int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createTextLengthConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidationConstraint | createTimeConstraint(int operatorType, java.lang.String formula1, java.lang.String formula2)
DataValidation | createValidation(DataValidationConstraint constraint, CellRangeAddressList cellRangeAddressList)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFDataValidationHelper

public XSSFDataValidationHelper(XSSFSheet xssfSheet)
Method Detail

createDateConstraint

public DataValidationConstraint createDateConstraint(int operatorType,
                                                     java.lang.String formula1,
                                                     java.lang.String formula2,
                                                     java.lang.String dateFormat)
Specified by:
createDateConstraint in interface DataValidationHelper

createDecimalConstraint

public DataValidationConstraint createDecimalConstraint(int operatorType,
                                                        java.lang.String formula1,
                                                        java.lang.String formula2)
Specified by:
createDecimalConstraint in interface DataValidationHelper

createExplicitListConstraint

public DataValidationConstraint createExplicitListConstraint(java.lang.String[] listOfValues)
Specified by:
createExplicitListConstraint in interface DataValidationHelper

createFormulaListConstraint

public DataValidationConstraint createFormulaListConstraint(java.lang.String listFormula)
Specified by:
createFormulaListConstraint in interface DataValidationHelper

createNumericConstraint

public DataValidationConstraint createNumericConstraint(int validationType,
                                                        int operatorType,
                                                        java.lang.String formula1,
                                                        java.lang.String formula2)
Specified by:
createNumericConstraint in interface DataValidationHelper

createIntegerConstraint

public DataValidationConstraint createIntegerConstraint(int operatorType,
                                                        java.lang.String formula1,
                                                        java.lang.String formula2)
Specified by:
createIntegerConstraint in interface DataValidationHelper

createTextLengthConstraint

public DataValidationConstraint createTextLengthConstraint(int operatorType,
                                                           java.lang.String formula1,
                                                           java.lang.String formula2)
Specified by:
createTextLengthConstraint in interface DataValidationHelper

createTimeConstraint

public DataValidationConstraint createTimeConstraint(int operatorType,
                                                     java.lang.String formula1,
                                                     java.lang.String formula2)
Specified by:
createTimeConstraint in interface DataValidationHelper

createCustomConstraint

public DataValidationConstraint createCustomConstraint(java.lang.String formula)
Specified by:
createCustomConstraint in interface DataValidationHelper

createValidation

public DataValidation createValidation(DataValidationConstraint constraint,
                                       CellRangeAddressList cellRangeAddressList)
Specified by:
createValidation in interface DataValidationHelper
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFDialogsheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFDialogsheet

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFSheet
            extended by  org.apache.poi.xssf.usermodel.XSSFDialogsheet
All Implemented Interfaces:
java.lang.Iterable<Row>, Sheet
public class XSSFDialogsheet
extends XSSFSheet
implements Sheet

Field Summary
protected  org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDialogsheet dialogsheet
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFSheet
sheet, worksheet
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Fields inherited from interface org.apache.poi.ss.usermodel.Sheet
BottomMargin, FooterMargin, HeaderMargin, LeftMargin, PANE_LOWER_LEFT, PANE_LOWER_RIGHT, PANE_UPPER_LEFT, PANE_UPPER_RIGHT, RightMargin, TopMargin
Constructor Summary
protected XSSFDialogsheet(XSSFSheet sheet)
Method Summary
XSSFRow | createRow(int rowNum) Create a new row within the sheet and return the high level representation
boolean | getDialog()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPageBreak | getSheetTypeColumnBreaks()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter | getSheetTypeHeaderFooter()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPageMargins | getSheetTypePageMargins()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPrintOptions | getSheetTypePrintOptions()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetProtection | getSheetTypeProtection()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPageBreak | getSheetTypeRowBreaks()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetFormatPr | getSheetTypeSheetFormatPr()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetPr | getSheetTypeSheetPr()
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetViews | getSheetTypeSheetViews()
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFSheet
addHyperlink, addMergedRegion, addValidationData, autoSizeColumn, autoSizeColumn, commit, createComment, createDrawingPatriarch, createFreezePane, createFreezePane, createSplitPane, createTable, disableLocking, enableLocking, findEndOfRowOutlineGroup, getActiveCell, getAutobreaks, getCellComment, getColumnBreaks, getColumnHelper, getColumnStyle, getColumnWidth, getCommentsTable, getCTDrawing, getCTLegacyDrawing, getCTWorksheet, getDataValidationHelper, getDataValidations, getDefaultColumnWidth, getDefaultRowHeight, getDefaultRowHeightInPoints, getDisplayGuts, getEvenFooter, getEvenHeader, getFirstFooter, getFirstHeader, getFirstRowNum, getFitToPage, getFooter, getForceFormulaRecalculation, getHeader, getHorizontallyCenter, getHyperlink, getLastRowNum, getLeftCol, getMargin, getMergedRegion, getNumberOfComments, getNumHyperlinks, getNumMergedRegions, getOddFooter, getOddHeader, getPaneInformation, getPhysicalNumberOfRows, getPrintSetup, getProtect, getRow, getRowBreaks, getRowSumsBelow, getRowSumsRight, getScenarioProtect, getSheetConditionalFormatting, getSheetName, getTables, getTopRow, getVerticallyCenter, getVMLDrawing, getWorkbook, groupColumn, groupRow, hasComments, isAutoFilterLocked, isColumnBroken, isColumnHidden, isDeleteColumnsLocked, isDeleteRowsLocked, isDisplayFormulas, isDisplayGridlines, isDisplayRowColHeadings, isDisplayZeros, isFormatCellsLocked, isFormatColumnsLocked, isFormatRowsLocked, isInsertColumnsLocked, isInsertHyperlinksLocked, isInsertRowsLocked, isObjectsLocked, isPivotTablesLocked, isPrintGridlines, isRightToLeft, isRowBroken, isScenariosLocked, isSelected, isSelectLockedCellsLocked, isSelectUnlockedCellsLocked, isSheetLocked, isSortLocked, iterator, lockAutoFilter, lockDeleteColumns, lockDeleteRows, lockFormatCells, lockFormatColumns, lockFormatRows, lockInsertColumns, lockInsertHyperlinks, lockInsertRows, lockObjects, lockPivotTables, lockScenarios, lockSelectLockedCells, lockSelectUnlockedCells, lockSort, onDocumentCreate, onDocumentRead, protectSheet, read, removeArrayFormula, removeColumnBreak, removeMergedRegion, removeRow, removeRowBreak, rowIterator, setActiveCell, setArrayFormula, setAutobreaks, setAutoFilter, setCellComment, setColumnBreak, setColumnGroupCollapsed, setColumnHidden, setColumnWidth, setDefaultColumnStyle, setDefaultColumnWidth, setDefaultRowHeight, setDefaultRowHeightInPoints, setDisplayFormulas, setDisplayGridlines, setDisplayGuts, setDisplayRowColHeadings, setDisplayZeros, setFitToPage, setForceFormulaRecalculation, setHorizontallyCenter, setMargin, setPrintGridlines, setRightToLeft, setRowBreak, setRowGroupCollapsed, setRowSumsBelow, setRowSumsRight, setSelected, setTabColor, setVerticallyCenter, setZoom, setZoom, shiftRows, shiftRows, showInPane, ungroupColumn, ungroupRow, write
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Sheet
addMergedRegion, addValidationData, autoSizeColumn, autoSizeColumn, createDrawingPatriarch, createFreezePane, createFreezePane, createSplitPane, getAutobreaks, getCellComment, getColumnBreaks, getColumnStyle, getColumnWidth, getDataValidationHelper, getDefaultColumnWidth, getDefaultRowHeight, getDefaultRowHeightInPoints, getDisplayGuts, getFirstRowNum, getFitToPage, getFooter, getForceFormulaRecalculation, getHeader, getHorizontallyCenter, getLastRowNum, getLeftCol, getMargin, getMergedRegion, getNumMergedRegions, getPaneInformation, getPhysicalNumberOfRows, getPrintSetup, getProtect, getRow, getRowBreaks, getRowSumsBelow, getRowSumsRight, getScenarioProtect, getSheetConditionalFormatting, getSheetName, getTopRow, getVerticallyCenter, getWorkbook, groupColumn, groupRow, isColumnBroken, isColumnHidden, isDisplayFormulas, isDisplayGridlines, isDisplayRowColHeadings, isDisplayZeros, isPrintGridlines, isRightToLeft, isRowBroken, isSelected, protectSheet, removeArrayFormula, removeColumnBreak, removeMergedRegion, removeRow, removeRowBreak, rowIterator, setArrayFormula, setAutobreaks, setAutoFilter, setColumnBreak, setColumnGroupCollapsed, setColumnHidden, setColumnWidth, setDefaultColumnStyle, setDefaultColumnWidth, setDefaultRowHeight, setDefaultRowHeightInPoints, setDisplayFormulas, setDisplayGridlines, setDisplayGuts, setDisplayRowColHeadings, setDisplayZeros, setFitToPage, setForceFormulaRecalculation, setHorizontallyCenter, setMargin, setPrintGridlines, setRightToLeft, setRowBreak, setRowGroupCollapsed, setRowSumsBelow, setRowSumsRight, setSelected, setVerticallyCenter, setZoom, shiftRows, shiftRows, showInPane, ungroupColumn, ungroupRow
Methods inherited from interface java.lang.Iterable
iterator

Field Detail

dialogsheet

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDialogsheet dialogsheet
Constructor Detail

XSSFDialogsheet

protected XSSFDialogsheet(XSSFSheet sheet)
Method Detail

createRow

public XSSFRow createRow(int rowNum)
Description copied from class: XSSFSheet
Create a new row within the sheet and return the high level representation

Specified by:
createRow in interface Sheet
Overrides:
createRow in class XSSFSheet
Parameters:
rowNum - row number
Returns:
High level XSSFRow object representing a row in the sheet
See Also:
XSSFSheet.removeRow(org.apache.poi.ss.usermodel.Row)

getSheetTypeHeaderFooter

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter getSheetTypeHeaderFooter()

getSheetTypeSheetPr

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetPr getSheetTypeSheetPr()

getSheetTypeColumnBreaks

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPageBreak getSheetTypeColumnBreaks()

getSheetTypeSheetFormatPr

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetFormatPr getSheetTypeSheetFormatPr()

getSheetTypePageMargins

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPageMargins getSheetTypePageMargins()

getSheetTypeRowBreaks

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPageBreak getSheetTypeRowBreaks()

getSheetTypeSheetViews

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetViews getSheetTypeSheetViews()

getSheetTypePrintOptions

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTPrintOptions getSheetTypePrintOptions()

getSheetTypeProtection

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetProtection getSheetTypeProtection()

getDialog

public boolean getDialog()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFDrawing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFDrawing

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFDrawing
All Implemented Interfaces:
Drawing
public final class XSSFDrawing
extends POIXMLDocumentPart
implements Drawing

Represents a SpreadsheetML drawing

Author:
Yegor Kozlov

Field Summary
protected static java.lang.String | NAMESPACE_A
protected static java.lang.String | NAMESPACE_C
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected | XSSFDrawing() Create a new SpreadsheetML drawing
protected | XSSFDrawing(PackagePart part, PackageRelationship rel) Construct a SpreadsheetML drawing from a package part
Method Summary
protected PackageRelationship | addPictureReference(int pictureIndex) Add the indexed picture to this drawing relations
protected void | commit() Save the content in the underlying package part.
XSSFClientAnchor | createAnchor(int dx1, int dy1, int dx2, int dy2, int col1, int row1, int col2, int row2) Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.
XSSFComment | createCellComment(ClientAnchor anchor) Creates a comment.
XSSFChart | createChart(ClientAnchor anchor) Creates a chart.
XSSFChart | createChart(XSSFClientAnchor anchor) Creates a chart.
XSSFConnector | createConnector(XSSFClientAnchor anchor) Creates a simple shape.
XSSFShapeGroup | createGroup(XSSFClientAnchor anchor) Creates a simple shape.
XSSFPicture | createPicture(ClientAnchor anchor, int pictureIndex) Creates a picture.
XSSFPicture | createPicture(XSSFClientAnchor anchor, int pictureIndex) Creates a picture.
XSSFSimpleShape | createSimpleShape(XSSFClientAnchor anchor) Creates a simple shape.
XSSFTextBox | createTextbox(XSSFClientAnchor anchor) Constructs a textbox under the drawing.
java.util.List<XSSFChart> | getCharts() Returns all charts in this drawing.
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTDrawing | getCTDrawing() Return the underlying CTDrawing bean, the root element of the SpreadsheetML Drawing part.
java.util.List<XSSFShape> | getShapes()
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NAMESPACE_A

protected static final java.lang.String NAMESPACE_A
See Also:
Constant Field Values

NAMESPACE_C

protected static final java.lang.String NAMESPACE_C
See Also:
Constant Field Values
Constructor Detail

XSSFDrawing

protected XSSFDrawing()
Create a new SpreadsheetML drawing

See Also:
XSSFSheet.createDrawingPatriarch()

XSSFDrawing

protected XSSFDrawing(PackagePart part,
                      PackageRelationship rel)
               throws java.io.IOException,
                      org.apache.xmlbeans.XmlException
Construct a SpreadsheetML drawing from a package part

Parameters:
part - the package part holding the drawing data, the content type must be application/vnd.openxmlformats-officedocument.drawing+xml
rel - the package relationship holding this drawing, the relationship type must be http://schemas.openxmlformats.org/officeDocument/2006/relationships/drawing
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

getCTDrawing

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTDrawing getCTDrawing()
Return the underlying CTDrawing bean, the root element of the SpreadsheetML Drawing part.

Returns:
the underlying CTDrawing bean

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

createAnchor

public XSSFClientAnchor createAnchor(int dx1,
                                     int dy1,
                                     int dx2,
                                     int dy2,
                                     int col1,
                                     int row1,
                                     int col2,
                                     int row2)
Description copied from interface: Drawing
Creates a new client anchor and sets the top-left and bottom-right coordinates of the anchor.

Specified by:
createAnchor in interface Drawing
Parameters:
dx1 - the x coordinate in EMU within the first cell.
dy1 - the y coordinate in EMU within the first cell.
dx2 - the x coordinate in EMU within the second cell.
dy2 - the y coordinate in EMU within the second cell.
col1 - the column (0 based) of the first cell.
row1 - the row (0 based) of the first cell.
col2 - the column (0 based) of the second cell.
row2 - the row (0 based) of the second cell.
Returns:
the newly created client anchor

createTextbox

public XSSFTextBox createTextbox(XSSFClientAnchor anchor)
Constructs a textbox under the drawing.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created textbox.

createPicture

public XSSFPicture createPicture(XSSFClientAnchor anchor,
                                 int pictureIndex)
Creates a picture.

Parameters:
anchor - the client anchor describes how this picture is attached to the sheet.
pictureIndex - the index of the picture in the workbook collection of pictures, XSSFWorkbook.getAllPictures() .
Returns:
the newly created picture shape.

createPicture

public XSSFPicture createPicture(ClientAnchor anchor,
                                 int pictureIndex)
Description copied from interface: Drawing
Creates a picture.

Specified by:
createPicture in interface Drawing
Parameters:
anchor - the client anchor describes how this picture is attached to the sheet.
pictureIndex - the index of the picture in the workbook collection of pictures.
Returns:
the newly created picture.

createChart

public XSSFChart createChart(XSSFClientAnchor anchor)
Creates a chart.

Parameters:
anchor - the client anchor describes how this chart is attached to the sheet.
Returns:
the newly created chart
See Also:
createChart(ClientAnchor)

createChart

public XSSFChart createChart(ClientAnchor anchor)
Description copied from interface: Drawing
Creates a chart.

Specified by:
createChart in interface Drawing
Parameters:
anchor - the client anchor describes how this chart is attached to the sheet.
Returns:
the newly created chart

addPictureReference

protected PackageRelationship addPictureReference(int pictureIndex)
Add the indexed picture to this drawing relations

Parameters:
pictureIndex - the index of the picture in the workbook collection of pictures, XSSFWorkbook.getAllPictures() .

createSimpleShape

public XSSFSimpleShape createSimpleShape(XSSFClientAnchor anchor)
Creates a simple shape. This includes such shapes as lines, rectangles, and ovals.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

createConnector

public XSSFConnector createConnector(XSSFClientAnchor anchor)
Creates a simple shape. This includes such shapes as lines, rectangles, and ovals.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

createGroup

public XSSFShapeGroup createGroup(XSSFClientAnchor anchor)
Creates a simple shape. This includes such shapes as lines, rectangles, and ovals.

Parameters:
anchor - the client anchor describes how this group is attached to the sheet.
Returns:
the newly created shape.

createCellComment

public XSSFComment createCellComment(ClientAnchor anchor)
Creates a comment.

Specified by:
createCellComment in interface Drawing
Parameters:
anchor - the client anchor describes how this comment is attached to the sheet.
Returns:
the newly created comment.

getCharts

public java.util.List<XSSFChart> getCharts()
Returns all charts in this drawing.

getShapes

public java.util.List<XSSFShape> getShapes()
Returns:
list of shapes in this drawing
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFEvaluationWorkbook

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFEvaluationWorkbook

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook
All Implemented Interfaces:
EvaluationWorkbook, FormulaParsingWorkbook, FormulaRenderingWorkbook
public final class XSSFEvaluationWorkbook
extends java.lang.Object
implements FormulaRenderingWorkbook, EvaluationWorkbook, FormulaParsingWorkbook

Internal POI use only

Author:
Josh Micich

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.formula.EvaluationWorkbook
EvaluationWorkbook.ExternalName, EvaluationWorkbook.ExternalSheet
Method Summary
int | convertFromExternSheetIndex(int externSheetIndex)
static XSSFEvaluationWorkbook | create(XSSFWorkbook book)
EvaluationWorkbook.ExternalName | getExternalName(int externSheetIndex, int externNameIndex)
EvaluationWorkbook.ExternalSheet | getExternalSheet(int externSheetIndex)
int | getExternalSheetIndex(java.lang.String sheetName) gets the externSheet index for a sheet from this workbook
int | getExternalSheetIndex(java.lang.String workbookName, java.lang.String sheetName) gets the externSheet index for a sheet from an external workbook
Ptg[] | getFormulaTokens(EvaluationCell evalCell)
EvaluationName | getName(NamePtg namePtg)
EvaluationName | getName(java.lang.String name, int sheetIndex) named range name matching is case insensitive
java.lang.String | getNameText(NamePtg namePtg)
NameXPtg | getNameXPtg(java.lang.String name)
EvaluationSheet | getSheet(int sheetIndex)
int | getSheetIndex(EvaluationSheet evalSheet)
int | getSheetIndex(java.lang.String sheetName) Finds a sheet index by case insensitive name.
java.lang.String | getSheetName(int sheetIndex)
java.lang.String | getSheetNameByExternSheet(int externSheetIndex)
SpreadsheetVersion | getSpreadsheetVersion() Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)
UDFFinder | getUDFFinder()
java.lang.String | resolveNameXText(NameXPtg n)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public static XSSFEvaluationWorkbook create(XSSFWorkbook book)

convertFromExternSheetIndex

public int convertFromExternSheetIndex(int externSheetIndex)
Specified by:
convertFromExternSheetIndex in interface EvaluationWorkbook
Returns:
the sheet index of the sheet with the given external index.

getExternalSheetIndex

public int getExternalSheetIndex(java.lang.String sheetName)
Description copied from interface: FormulaParsingWorkbook
gets the externSheet index for a sheet from this workbook

Specified by:
getExternalSheetIndex in interface FormulaParsingWorkbook

getName

public EvaluationName getName(java.lang.String name,
                              int sheetIndex)
Description copied from interface: FormulaParsingWorkbook
named range name matching is case insensitive

Specified by:
getName in interface EvaluationWorkbook
Specified by:
getName in interface FormulaParsingWorkbook

getSheetIndex

public int getSheetIndex(EvaluationSheet evalSheet)
Specified by:
getSheetIndex in interface EvaluationWorkbook
Returns:
-1 if the specified sheet is from a different book

getSheetName

public java.lang.String getSheetName(int sheetIndex)
Specified by:
getSheetName in interface EvaluationWorkbook

getExternalName

public EvaluationWorkbook.ExternalName getExternalName(int externSheetIndex,
                                                       int externNameIndex)
Specified by:
getExternalName in interface EvaluationWorkbook

getNameXPtg

public NameXPtg getNameXPtg(java.lang.String name)
Specified by:
getNameXPtg in interface FormulaParsingWorkbook

resolveNameXText

public java.lang.String resolveNameXText(NameXPtg n)
Specified by:
resolveNameXText in interface EvaluationWorkbook
Specified by:
resolveNameXText in interface FormulaRenderingWorkbook

getSheet

public EvaluationSheet getSheet(int sheetIndex)
Specified by:
getSheet in interface EvaluationWorkbook

getExternalSheet

public EvaluationWorkbook.ExternalSheet getExternalSheet(int externSheetIndex)
Specified by:
getExternalSheet in interface EvaluationWorkbook
Specified by:
getExternalSheet in interface FormulaRenderingWorkbook
Returns:
null if externSheetIndex refers to a sheet inside the current workbook

getExternalSheetIndex

public int getExternalSheetIndex(java.lang.String workbookName,
                                 java.lang.String sheetName)
Description copied from interface: FormulaParsingWorkbook
gets the externSheet index for a sheet from an external workbook

Specified by:
getExternalSheetIndex in interface FormulaParsingWorkbook
Parameters:
workbookName - e.g. "Budget.xls"
sheetName - a name of a sheet in that workbook

getSheetIndex

public int getSheetIndex(java.lang.String sheetName)
Description copied from interface: EvaluationWorkbook
Finds a sheet index by case insensitive name.

Specified by:
getSheetIndex in interface EvaluationWorkbook
Returns:
the index of the sheet matching the specified name. -1 if not found

getSheetNameByExternSheet

public java.lang.String getSheetNameByExternSheet(int externSheetIndex)
Specified by:
getSheetNameByExternSheet in interface FormulaRenderingWorkbook

getNameText

public java.lang.String getNameText(NamePtg namePtg)
Specified by:
getNameText in interface FormulaRenderingWorkbook

getName

public EvaluationName getName(NamePtg namePtg)
Specified by:
getName in interface EvaluationWorkbook

getFormulaTokens

public Ptg[] getFormulaTokens(EvaluationCell evalCell)
Specified by:
getFormulaTokens in interface EvaluationWorkbook

getUDFFinder

public UDFFinder getUDFFinder()
Specified by:
getUDFFinder in interface EvaluationWorkbook

getSpreadsheetVersion

public SpreadsheetVersion getSpreadsheetVersion()
Description copied from interface: FormulaParsingWorkbook
Returns an enum holding spreadhseet properties specific to an Excel version ( max column and row numbers, max arguments to a function, etc.)

Specified by:
getSpreadsheetVersion in interface FormulaParsingWorkbook
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFEvenFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFEvenFooter

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
        extended by  org.apache.poi.xssf.usermodel.XSSFEvenFooter
All Implemented Interfaces:
Footer, HeaderFooter
public class XSSFEvenFooter
extends XSSFHeaderFooter
implements Footer

Even page footer value. Corresponds to even printed pages. Even page(s) in the sheet may not be printed, for example, if the print area is specified to be a range such that it falls outside an even page's scope. If no even footer is specified, then the odd footer's value is assumed for even page footers.

Constructor Summary
XSSFEvenFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFEvenFooter from the supplied XML bean
Method Summary
java.lang.String | getText() Get the content text representing the footer
void | setText(java.lang.String text) Set a text for the footer.
Methods inherited from class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
areFieldsStripped, getCenter, getHeaderFooter, getLeft, getRight, getValue, setAreFieldsStripped, setCenter, setLeft, setRight, stripFields
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Footer
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

XSSFEvenFooter

public XSSFEvenFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFEvenFooter from the supplied XML bean

Parameters:
headerFooter -
See Also:
XSSFSheet.getEvenFooter()
Method Detail

getText

public java.lang.String getText()
Get the content text representing the footer

Specified by:
getText in class XSSFHeaderFooter
Returns:
text

setText

public void setText(java.lang.String text)
Set a text for the footer. If null unset the value.

Specified by:
setText in class XSSFHeaderFooter
Parameters:
text - - a string representing the footer.
See Also:
to see how to create a string with Header/Footer Formatting Syntax
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFEvenHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFEvenHeader

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
        extended by  org.apache.poi.xssf.usermodel.XSSFEvenHeader
All Implemented Interfaces:
Header, HeaderFooter
public class XSSFEvenHeader
extends XSSFHeaderFooter
implements Header

Even page header value. Corresponds to even printed pages. Even page(s) in the sheet may not be printed, for example, if the print area is specified to be a range such that it falls outside an even page's scope. If no even header is specified, then odd header value is assumed for even page headers.

Constructor Summary
XSSFEvenHeader(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFEvenHeader from the supplied XML bean
Method Summary
java.lang.String | getText() Get the content text representing this header
void | setText(java.lang.String text) Set a text for the header.
Methods inherited from class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
areFieldsStripped, getCenter, getHeaderFooter, getLeft, getRight, getValue, setAreFieldsStripped, setCenter, setLeft, setRight, stripFields
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Header
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

XSSFEvenHeader

public XSSFEvenHeader(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFEvenHeader from the supplied XML bean

Parameters:
headerFooter -
See Also:
XSSFSheet.getEvenHeader()
Method Detail

getText

public java.lang.String getText()
Get the content text representing this header

Specified by:
getText in class XSSFHeaderFooter
Returns:
text

setText

public void setText(java.lang.String text)
Set a text for the header. If null unset the value

Specified by:
setText in class XSSFHeaderFooter
Parameters:
text - - a string representing the header.
See Also:
to see how to create a string with Header/Footer Formatting Syntax
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFFactory

java.lang.Object
    extended by  org.apache.poi.POIXMLFactory
        extended by  org.apache.poi.xssf.usermodel.XSSFFactory

public final class XSSFFactory
extends POIXMLFactory

Instantiates sub-classes of POIXMLDocumentPart depending on their relationship type

Author:
Yegor Kozlov

Method Summary
POIXMLDocumentPart | createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part) Create a POIXMLDocumentPart from existing package part and relation.
static XSSFFactory | getInstance()
POIXMLDocumentPart | newDocumentPart(POIXMLRelation descriptor) Create a new POIXMLDocumentPart using the supplied descriptor.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static XSSFFactory getInstance()

createDocumentPart

public POIXMLDocumentPart createDocumentPart(POIXMLDocumentPart parent,
                                             PackageRelationship rel,
                                             PackagePart part)
Description copied from class: POIXMLFactory
Create a POIXMLDocumentPart from existing package part and relation. This method is called from POIXMLDocument.load(POIXMLFactory) when parsing a document

Specified by:
createDocumentPart in class POIXMLFactory
Parameters:
parent - parent part
rel - the package part relationship
part - the PackagePart representing the created instance
Returns:
A new instance of a POIXMLDocumentPart.

newDocumentPart

public POIXMLDocumentPart newDocumentPart(POIXMLRelation descriptor)
Description copied from class: POIXMLFactory
Create a new POIXMLDocumentPart using the supplied descriptor. This method is used when adding new parts to a document, for example, when adding a sheet to a workbook, slide to a presentation, etc.

Specified by:
newDocumentPart in class POIXMLFactory
Parameters:
descriptor - describes the object to create
Returns:
A new instance of a POIXMLDocumentPart.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFFirstFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFFirstFooter

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
        extended by  org.apache.poi.xssf.usermodel.XSSFFirstFooter
All Implemented Interfaces:
Footer, HeaderFooter
public class XSSFFirstFooter
extends XSSFHeaderFooter
implements Footer

First page footer content. Corresponds to first printed page. The first logical page in the sheet may not be printed, for example, if the print area is specified to be a range such that it falls outside the first page's scope.

Constructor Summary
protected XSSFFirstFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFFirstFooter from the supplied XML bean
Method Summary
java.lang.String | getText() Get the content text representing the footer
void | setText(java.lang.String text) Set a text for the footer.
Methods inherited from class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
areFieldsStripped, getCenter, getHeaderFooter, getLeft, getRight, getValue, setAreFieldsStripped, setCenter, setLeft, setRight, stripFields
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Footer
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

XSSFFirstFooter

protected XSSFFirstFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFFirstFooter from the supplied XML bean

Parameters:
headerFooter -
See Also:
XSSFSheet.getFirstFooter()
Method Detail

getText

public java.lang.String getText()
Get the content text representing the footer

Specified by:
getText in class XSSFHeaderFooter
Returns:
text

setText

public void setText(java.lang.String text)
Set a text for the footer. If null unset the value.

Specified by:
setText in class XSSFHeaderFooter
Parameters:
text - - a string representing the footer.
See Also:
to see how to create a string with Header/Footer Formatting Syntax
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFFirstHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFFirstHeader

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
        extended by  org.apache.poi.xssf.usermodel.XSSFFirstHeader
All Implemented Interfaces:
Header, HeaderFooter
public class XSSFFirstHeader
extends XSSFHeaderFooter
implements Header

First page header content. Corresponds to first printed page. The first logical page in the sheet may not be printed, for example, if the print area is specified to be a range such that it falls outside the first page's scope.

Constructor Summary
protected XSSFFirstHeader(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFFirstHeader from the supplied XML bean
Method Summary
java.lang.String | getText() Get the content text representing this header
void | setText(java.lang.String text) Set a text for the header.
Methods inherited from class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
areFieldsStripped, getCenter, getHeaderFooter, getLeft, getRight, getValue, setAreFieldsStripped, setCenter, setLeft, setRight, stripFields
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Header
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

XSSFFirstHeader

protected XSSFFirstHeader(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFFirstHeader from the supplied XML bean

Parameters:
headerFooter -
See Also:
XSSFSheet.getFirstHeader()
Method Detail

getText

public java.lang.String getText()
Get the content text representing this header

Specified by:
getText in class XSSFHeaderFooter
Returns:
text

setText

public void setText(java.lang.String text)
Set a text for the header. If null unset the value

Specified by:
setText in class XSSFHeaderFooter
Parameters:
text - - a string representing the header.
See Also:
to see how to create a string with Header/Footer Formatting Syntax
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFFont

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFFont

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFFont
All Implemented Interfaces:
Font
public class XSSFFont
extends java.lang.Object
implements Font

Represents a font used in a workbook.

Author:
Gisella Bronzetti

Field Summary
static short | DEFAULT_FONT_COLOR Default font color is black
static java.lang.String | DEFAULT_FONT_NAME By default, Microsoft Office Excel 2007 uses the Calibry font in font size 11
static short | DEFAULT_FONT_SIZE By default, Microsoft Office Excel 2007 uses the Calibry font in font size 11
Fields inherited from interface org.apache.poi.ss.usermodel.Font
ANSI_CHARSET, BOLDWEIGHT_BOLD, BOLDWEIGHT_NORMAL, COLOR_NORMAL, COLOR_RED, DEFAULT_CHARSET, SS_NONE, SS_SUB, SS_SUPER, SYMBOL_CHARSET, U_DOUBLE, U_DOUBLE_ACCOUNTING, U_NONE, U_SINGLE, U_SINGLE_ACCOUNTING
Constructor Summary
protected | XSSFFont() Create a new XSSFont.
 | XSSFFont(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont font) Create a new XSSFFont
 | XSSFFont(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont font, int index)
Method Summary
boolean | equals(java.lang.Object o)
boolean | getBold() get a boolean value for the boldness to use.
short | getBoldweight() get the boldness to use
int | getCharSet() get character-set to use.
short | getColor() get the indexed color value for the font References a color defined in IndexedColors.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont | getCTFont() get the underlying CTFont font
int | getFamily() get the font family to use.
short | getFontHeight() get the font height in point.
short | getFontHeightInPoints() get the font height
java.lang.String | getFontName() get the name of the font (i.e.
short | getIndex() get the index within the XSSFWorkbook (sequence within the collection of Font objects)
boolean | getItalic() get a boolean value that specify whether to use italics or not
FontScheme | getScheme() get the font scheme property.
boolean | getStrikeout() get a boolean value that specify whether to use a strikeout horizontal line through the text or not
short | getThemeColor() get the color value for the font References a color defined in theme.
short | getTypeOffset() get normal,super or subscript.
byte | getUnderline() get type of text underlining to use
XSSFColor | getXSSFColor() get the color value for the font References a color defined as Standard Alpha Red Green Blue color value (ARGB).
int | hashCode()
long | registerTo(StylesTable styles) Perform a registration of ourselves to the style table
void | setBold(boolean bold) set a boolean value for the boldness to use.
void | setBoldweight(short boldweight)
void | setCharSet(byte charset) set character-set to use.
void | setCharSet(FontCharset charSet) set character-set to use.
void | setCharSet(int charset) set character-set to use.
void | setColor(short color) set the indexed color for the font
void | setColor(XSSFColor color) set the color for the font in Standard Alpha Red Green Blue color value
void | setFamily(FontFamily family) set an enumeration representing the font family this font belongs to.
void | setFamily(int value) Set the font family this font belongs to.
void | setFontHeight(double height) set the font height in points.
void | setFontHeight(short height) set the font height in points.
void | setFontHeightInPoints(short height) set the font height in points.
void | setFontName(java.lang.String name) set the name for the font (i.e.
void | setItalic(boolean italic) set a boolean value for the property specifying whether to use italics or not If omitted, the default value is true.
void | setScheme(FontScheme scheme) set font scheme property
void | setStrikeout(boolean strikeout) set a boolean value for the property specifying whether to use a strikeout horizontal line through the text or not If omitted, the default value is true.
void | setThemeColor(short theme) set the theme color for the font to use
void | setThemesTable(ThemesTable themes) Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.
void | setTypeOffset(short offset) set normal,super or subscript, that representing the vertical-alignment setting.
void | setUnderline(byte underline) set the style of underlining that is used.
void | setUnderline(FontUnderline underline) set an enumeration representing the style of underlining that is used.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT_FONT_NAME

public static final java.lang.String DEFAULT_FONT_NAME
By default, Microsoft Office Excel 2007 uses the Calibry font in font size 11

See Also:
Constant Field Values

DEFAULT_FONT_SIZE

public static final short DEFAULT_FONT_SIZE
By default, Microsoft Office Excel 2007 uses the Calibry font in font size 11

See Also:
Constant Field Values

DEFAULT_FONT_COLOR

public static final short DEFAULT_FONT_COLOR
Default font color is black

See Also:
IndexedColors.BLACK
Constructor Detail

XSSFFont

public XSSFFont(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont font)
Create a new XSSFFont

Parameters:
font - the underlying CTFont bean

XSSFFont

public XSSFFont(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont font,
                int index)

XSSFFont

protected XSSFFont()
Create a new XSSFont. This method is protected to be used only by XSSFWorkbook

Method Detail

getCTFont

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont getCTFont()
get the underlying CTFont font

getBold

public boolean getBold()
get a boolean value for the boldness to use.

Returns:
boolean - bold

getCharSet

public int getCharSet()
get character-set to use.

Specified by:
getCharSet in interface Font
Returns:
int - character-set (0-255)
See Also:
FontCharset

getColor

public short getColor()
get the indexed color value for the font References a color defined in IndexedColors.

Specified by:
getColor in interface Font
Returns:
short - indexed color to use
See Also:
IndexedColors

getXSSFColor

public XSSFColor getXSSFColor()
get the color value for the font References a color defined as Standard Alpha Red Green Blue color value (ARGB).

Returns:
XSSFColor - rgb color to use

getThemeColor

public short getThemeColor()
get the color value for the font References a color defined in theme.

Returns:
short - theme defined to use

getFontHeight

public short getFontHeight()
get the font height in point.

Specified by:
getFontHeight in interface Font
Returns:
short - height in point
See Also:
Font.getFontHeightInPoints()

getFontHeightInPoints

public short getFontHeightInPoints()
Description copied from interface: Font
get the font height

Specified by:
getFontHeightInPoints in interface Font
Returns:
short - height in the familiar unit of measure - points
See Also:
getFontHeight()

getFontName

public java.lang.String getFontName()
get the name of the font (i.e. Arial)

Specified by:
getFontName in interface Font
Returns:
String - a string representing the name of the font to use

getItalic

public boolean getItalic()
get a boolean value that specify whether to use italics or not

Specified by:
getItalic in interface Font
Returns:
boolean - value for italic

getStrikeout

public boolean getStrikeout()
get a boolean value that specify whether to use a strikeout horizontal line through the text or not

Specified by:
getStrikeout in interface Font
Returns:
boolean - value for strikeout

getTypeOffset

public short getTypeOffset()
get normal,super or subscript.

Specified by:
getTypeOffset in interface Font
Returns:
short - offset type to use (none,super,sub)
See Also:
Font.SS_NONE, Font.SS_SUPER, Font.SS_SUB

getUnderline

public byte getUnderline()
get type of text underlining to use

Specified by:
getUnderline in interface Font
Returns:
byte - underlining type
See Also:
FontUnderline

setBold

public void setBold(boolean bold)
set a boolean value for the boldness to use. If omitted, the default value is true.

Parameters:
bold - - boldness to use

setBoldweight

public void setBoldweight(short boldweight)
Specified by:
setBoldweight in interface Font

getBoldweight

public short getBoldweight()
get the boldness to use

Specified by:
getBoldweight in interface Font
Returns:
boldweight
See Also:
Font.BOLDWEIGHT_NORMAL, Font.BOLDWEIGHT_BOLD

setCharSet

public void setCharSet(byte charset)
set character-set to use.

Specified by:
setCharSet in interface Font
Parameters:
charset - - charset
See Also:
FontCharset

setCharSet

public void setCharSet(int charset)
set character-set to use.

Specified by:
setCharSet in interface Font
Parameters:
charset - - charset
See Also:
FontCharset

setCharSet

public void setCharSet(FontCharset charSet)
set character-set to use.

Parameters:
charSet -

setColor

public void setColor(short color)
set the indexed color for the font

Specified by:
setColor in interface Font
Parameters:
color - - color to use
See Also:
- Note: default font color, IndexedColors

setColor

public void setColor(XSSFColor color)
set the color for the font in Standard Alpha Red Green Blue color value

Parameters:
color - - color to use

setFontHeight

public void setFontHeight(short height)
set the font height in points.

Specified by:
setFontHeight in interface Font
Parameters:
height - - height in points
See Also:
Font.setFontHeightInPoints(short)

setFontHeight

public void setFontHeight(double height)
set the font height in points.

Parameters:
height - - height in points

setFontHeightInPoints

public void setFontHeightInPoints(short height)
set the font height in points.

Specified by:
setFontHeightInPoints in interface Font
Parameters:
height - height in the familiar unit of measure - points
See Also:
Font.setFontHeight(short)

setThemeColor

public void setThemeColor(short theme)
set the theme color for the font to use

Parameters:
theme - - theme color to use

setFontName

public void setFontName(java.lang.String name)
set the name for the font (i.e. Arial). If the font doesn't exist (because it isn't installed on the system), or the charset is invalid for that font, then another font should be substituted. The string length for this attribute shall be 0 to 31 characters. Default font name is Calibri.

Specified by:
setFontName in interface Font
Parameters:
name - - value representing the name of the font to use
See Also:
DEFAULT_FONT_NAME

setItalic

public void setItalic(boolean italic)
set a boolean value for the property specifying whether to use italics or not If omitted, the default value is true.

Specified by:
setItalic in interface Font
Parameters:
italic - - value for italics or not

setStrikeout

public void setStrikeout(boolean strikeout)
set a boolean value for the property specifying whether to use a strikeout horizontal line through the text or not If omitted, the default value is true.

Specified by:
setStrikeout in interface Font
Parameters:
strikeout - - value for strikeout or not

setTypeOffset

public void setTypeOffset(short offset)
set normal,super or subscript, that representing the vertical-alignment setting. Setting this to either subscript or superscript shall make the font size smaller if a smaller font size is available.

Specified by:
setTypeOffset in interface Font
Parameters:
offset - - offset type to use (none,super,sub)
See Also:
Font.SS_NONE, Font.SS_SUPER, Font.SS_SUB

setUnderline

public void setUnderline(byte underline)
set the style of underlining that is used. The none style is equivalent to not using underlining at all.

Specified by:
setUnderline in interface Font
Parameters:
underline - - underline type to use
See Also:
FontUnderline

setUnderline

public void setUnderline(FontUnderline underline)
set an enumeration representing the style of underlining that is used. The none style is equivalent to not using underlining at all. The possible values for this attribute are defined by the FontUnderline

Parameters:
underline - - FontUnderline enum value

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

registerTo

public long registerTo(StylesTable styles)
Perform a registration of ourselves to the style table

setThemesTable

public void setThemesTable(ThemesTable themes)
Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.

getScheme

public FontScheme getScheme()
get the font scheme property. is used only in StylesTable to create the default instance of font

Returns:
FontScheme
See Also:
StylesTable.createDefaultFont()

setScheme

public void setScheme(FontScheme scheme)
set font scheme property

Parameters:
scheme - - FontScheme enum value
See Also:
FontScheme

getFamily

public int getFamily()
get the font family to use.

Returns:
the font family to use
See Also:
FontFamily

setFamily

public void setFamily(int value)
Set the font family this font belongs to. A font family is a set of fonts having common stroke width and serif characteristics. The font name overrides when there are conflicting values.

Parameters:
value - - font family
See Also:
FontFamily

setFamily

public void setFamily(FontFamily family)
set an enumeration representing the font family this font belongs to. A font family is a set of fonts having common stroke width and serif characteristics.

Parameters:
family - font family

getIndex

public short getIndex()
get the index within the XSSFWorkbook (sequence within the collection of Font objects)

Specified by:
getIndex in interface Font
Returns:
unique index number of the underlying record this Font represents (probably you don't care unless you're comparing which one is which)

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFFontFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFFontFormatting

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFFontFormatting
All Implemented Interfaces:
FontFormatting
public class XSSFFontFormatting
extends java.lang.Object
implements FontFormatting

Author:
Yegor Kozlov

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.FontFormatting
SS_NONE, SS_SUB, SS_SUPER, U_DOUBLE, U_DOUBLE_ACCOUNTING, U_NONE, U_SINGLE, U_SINGLE_ACCOUNTING
Method Summary
short | getEscapementType() get the type of super or subscript for the font
short | getFontColorIndex()
int | getFontHeight() gets the height of the font in 1/20th point units
short | getUnderlineType() get the type of underlining for the font
XSSFColor | getXSSFColor()
boolean | isBold() get whether the font weight is set to bold or not
boolean | isItalic()
void | resetFontStyle() set font style options to default values (non-italic, non-bold)
void | setEscapementType(short escapementType) set the escapement type for the font
void | setFontColorIndex(short color)
void | setFontHeight(int height) Sets the height of the font in 1/20th point units
void | setFontStyle(boolean italic, boolean bold) set font style options.
void | setUnderlineType(short underlineType) set the type of underlining type for the font
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getEscapementType

public short getEscapementType()
get the type of super or subscript for the font

Specified by:
getEscapementType in interface FontFormatting
Returns:
super or subscript option
See Also:
FontFormatting.SS_NONE, FontFormatting.SS_SUPER, FontFormatting.SS_SUB

setEscapementType

public void setEscapementType(short escapementType)
set the escapement type for the font

Specified by:
setEscapementType in interface FontFormatting
Parameters:
escapementType - super or subscript option
See Also:
FontFormatting.SS_NONE, FontFormatting.SS_SUPER, FontFormatting.SS_SUB

getFontColorIndex

public short getFontColorIndex()
Specified by:
getFontColorIndex in interface FontFormatting
Returns:
font color index

setFontColorIndex

public void setFontColorIndex(short color)
Specified by:
setFontColorIndex in interface FontFormatting
Parameters:
color - font color index

getXSSFColor

public XSSFColor getXSSFColor()
Returns:
xssf color wrapper or null if color info is missing

getFontHeight

public int getFontHeight()
gets the height of the font in 1/20th point units

Specified by:
getFontHeight in interface FontFormatting
Returns:
fontheight (in points/20); or -1 if not modified

setFontHeight

public void setFontHeight(int height)
Sets the height of the font in 1/20th point units

Specified by:
setFontHeight in interface FontFormatting
Parameters:
height - the height in twips (in points/20)

getUnderlineType

public short getUnderlineType()
get the type of underlining for the font

Specified by:
getUnderlineType in interface FontFormatting
Returns:
font underlining type
See Also:
FontFormatting.U_NONE, FontFormatting.U_SINGLE, FontFormatting.U_DOUBLE, FontFormatting.U_SINGLE_ACCOUNTING, FontFormatting.U_DOUBLE_ACCOUNTING

setUnderlineType

public void setUnderlineType(short underlineType)
set the type of underlining type for the font

Specified by:
setUnderlineType in interface FontFormatting
Parameters:
underlineType - super or subscript option
See Also:
FontFormatting.U_NONE, FontFormatting.U_SINGLE, FontFormatting.U_DOUBLE, FontFormatting.U_SINGLE_ACCOUNTING, FontFormatting.U_DOUBLE_ACCOUNTING

isBold

public boolean isBold()
get whether the font weight is set to bold or not

Specified by:
isBold in interface FontFormatting
Returns:
bold - whether the font is bold or not

isItalic

public boolean isItalic()
Specified by:
isItalic in interface FontFormatting
Returns:
true if font style was set to italic

setFontStyle

public void setFontStyle(boolean italic,
                         boolean bold)
set font style options.

Specified by:
setFontStyle in interface FontFormatting
Parameters:
italic - - if true, set posture style to italic, otherwise to normal
bold - if true, set font weight to bold, otherwise to normal

resetFontStyle

public void resetFontStyle()
set font style options to default values (non-italic, non-bold)

Specified by:
resetFontStyle in interface FontFormatting
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFFormulaEvaluator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFFormulaEvaluator

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator
All Implemented Interfaces:
FormulaEvaluator
public class XSSFFormulaEvaluator
extends java.lang.Object
implements FormulaEvaluator

Evaluates formula cells.

For performance reasons, this class keeps a cache of all previously calculated intermediate cell values. Be sure to call clearAllCachedResultValues() if any workbook cells are changed between calls to evaluate~ methods on this class.

Author:
Amol S. Deshmukh < amolweb at ya hoo dot com >, Josh Micich

Constructor Summary
XSSFFormulaEvaluator(XSSFWorkbook workbook)
XSSFFormulaEvaluator(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use create(XSSFWorkbook, org.apache.poi.ss.formula.IStabilityClassifier, org.apache.poi.ss.formula.udf.UDFFinder)
Method Summary
void | clearAllCachedResultValues() Should be called whenever there are major changes (e.g.
static XSSFFormulaEvaluator | create(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
CellValue | evaluate(Cell cell) If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type.
void | evaluateAll() Loops over all cells in all sheets of the supplied workbook.
static void | evaluateAllFormulaCells(XSSFWorkbook wb) Loops over all cells in all sheets of the supplied workbook.
int | evaluateFormulaCell(Cell cell) If cell contains formula, it evaluates the formula, and saves the result of the formula.
XSSFCell | evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
void | notifyDeleteCell(Cell cell) Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed
void | notifySetFormula(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
void | notifyUpdateCell(Cell cell) Should be called to tell the cell value cache that the specified (value or formula) cell has changed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFFormulaEvaluator

public XSSFFormulaEvaluator(XSSFWorkbook workbook)

XSSFFormulaEvaluator

@Deprecated
public XSSFFormulaEvaluator(XSSFWorkbook workbook,
                                       IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use create(XSSFWorkbook, org.apache.poi.ss.formula.IStabilityClassifier, org.apache.poi.ss.formula.udf.UDFFinder)

Parameters:
stabilityClassifier - used to optimise caching performance. Pass null for the (conservative) assumption that any cell may have its definition changed after evaluation begins.
Method Detail

create

public static XSSFFormulaEvaluator create(XSSFWorkbook workbook,
                                          IStabilityClassifier stabilityClassifier,
                                          UDFFinder udfFinder)
Parameters:
stabilityClassifier - used to optimise caching performance. Pass null for the (conservative) assumption that any cell may have its definition changed after evaluation begins.
udfFinder - pass null for default (AnalysisToolPak only)

clearAllCachedResultValues

public void clearAllCachedResultValues()
Should be called whenever there are major changes (e.g. moving sheets) to input cells in the evaluated workbook. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

Specified by:
clearAllCachedResultValues in interface FormulaEvaluator

notifySetFormula

public void notifySetFormula(Cell cell)
Description copied from interface: FormulaEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

Specified by:
notifySetFormula in interface FormulaEvaluator

notifyDeleteCell

public void notifyDeleteCell(Cell cell)
Description copied from interface: FormulaEvaluator
Should be called to tell the cell value cache that the specified cell has just become a formula cell, or the formula text has changed

Specified by:
notifyDeleteCell in interface FormulaEvaluator

notifyUpdateCell

public void notifyUpdateCell(Cell cell)
Description copied from interface: FormulaEvaluator
Should be called to tell the cell value cache that the specified (value or formula) cell has changed. Failure to call this method after changing cell values will cause incorrect behaviour of the evaluate~ methods of this class

Specified by:
notifyUpdateCell in interface FormulaEvaluator

evaluate

public CellValue evaluate(Cell cell)
If cell contains a formula, the formula is evaluated and returned, else the CellValue simply copies the appropriate cell value from the cell and also its cell type. This method should be preferred over evaluateInCell() when the call should not modify the contents of the original cell.

Specified by:
evaluate in interface FormulaEvaluator
Parameters:
cell -

evaluateFormulaCell

public int evaluateFormulaCell(Cell cell)
If cell contains formula, it evaluates the formula, and saves the result of the formula. The cell remains as a formula cell. Else if cell does not contain formula, this method leaves the cell unchanged. Note that the type of the formula result is returned, so you know what kind of value is also stored with the formula.
 int evaluatedCellType = evaluator.evaluateFormulaCell(cell);
Be aware that your cell will hold both the formula, and the result. If you want the cell replaced with the result of the formula, use evaluate(org.apache.poi.ss.usermodel.Cell) }

Specified by:
evaluateFormulaCell in interface FormulaEvaluator
Parameters:
cell - The cell to evaluate
Returns:
The type of the formula result (the cell's type remains as HSSFCell.CELL_TYPE_FORMULA however)

evaluateInCell

public XSSFCell evaluateInCell(Cell cell)
If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula. Else if cell does not contain formula, this method leaves the cell unchanged. Note that the same instance of HSSFCell is returned to allow chained calls like:
 int evaluatedCellType = evaluator.evaluateInCell(cell).getCellType();
Be aware that your cell value will be changed to hold the result of the formula. If you simply want the formula value computed for you, use evaluateFormulaCell(org.apache.poi.ss.usermodel.Cell) }

Specified by:
evaluateInCell in interface FormulaEvaluator
Parameters:
cell -

evaluateAllFormulaCells

public static void evaluateAllFormulaCells(XSSFWorkbook wb)
Loops over all cells in all sheets of the supplied workbook. For cells that contain formulas, their formulas are evaluated, and the results are saved. These cells remain as formula cells. For cells that do not contain formulas, no changes are made. This is a helpful wrapper around looping over all cells, and calling evaluateFormulaCell on each one.

evaluateAll

public void evaluateAll()
Loops over all cells in all sheets of the supplied workbook. For cells that contain formulas, their formulas are evaluated, and the results are saved. These cells remain as formula cells. For cells that do not contain formulas, no changes are made. This is a helpful wrapper around looping over all cells, and calling evaluateFormulaCell on each one.

Specified by:
evaluateAll in interface FormulaEvaluator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFGraphicFrame

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFGraphicFrame

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFShape
        extended by  org.apache.poi.xssf.usermodel.XSSFGraphicFrame

public final class XSSFGraphicFrame
extends XSSFShape

Represents DrawingML GraphicalObjectFrame.

Author:
Roman Kashitsyn

Field Summary
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFShape
EMU_PER_PIXEL, EMU_PER_POINT, parent, PIXEL_DPI, POINT_DPI
Constructor Summary
protected XSSFGraphicFrame(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame ctGraphicFrame)
Construct a new XSSFGraphicFrame object.
Method Summary
XSSFClientAnchor | getAnchor() Returns the frame anchor.
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame | getCTGraphicalObjectFrame()
long | getId() Gets the frame id.
java.lang.String | getName() Returns the frame name.
protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties | getShapeProperties() Returns xml bean with shape properties.
protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame | prototype() Initialize default structure of a new graphic frame
protected void | setAnchor(XSSFClientAnchor anchor) Attaches frame to an anchor.
protected void | setChart(XSSFChart chart, java.lang.String relId) Assign a DrawingML chart to the graphic frame.
protected void | setId(long id) Sets the frame id.
void | setMacro(java.lang.String macro) Sets the frame macro.
void | setName(java.lang.String name) Sets the frame name.
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFShape
getDrawing, getParent, isNoFill, setFillColor, setLineStyle, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFGraphicFrame

protected XSSFGraphicFrame(XSSFDrawing drawing,
                           org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame ctGraphicFrame)
Construct a new XSSFGraphicFrame object.

Parameters:
drawing - the XSSFDrawing that owns this frame
ctGraphicFrame - the XML bean that stores this frame content
Method Detail

getCTGraphicalObjectFrame

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame getCTGraphicalObjectFrame()

prototype

protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame prototype()
Initialize default structure of a new graphic frame

setMacro

public void setMacro(java.lang.String macro)
Sets the frame macro.

setName

public void setName(java.lang.String name)
Sets the frame name.

getName

public java.lang.String getName()
Returns the frame name.

Returns:
name of the frame

setAnchor

protected void setAnchor(XSSFClientAnchor anchor)
Attaches frame to an anchor.

getAnchor

public XSSFClientAnchor getAnchor()
Returns the frame anchor.

Overrides:
getAnchor in class XSSFShape
Returns:
the anchor this frame is attached to

setChart

protected void setChart(XSSFChart chart,
                        java.lang.String relId)
Assign a DrawingML chart to the graphic frame.

getId

public long getId()
Gets the frame id.

setId

protected void setId(long id)
Sets the frame id.

getShapeProperties

protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties getShapeProperties()
Description copied from class: XSSFShape
Returns xml bean with shape properties.

Specified by:
getShapeProperties in class XSSFShape
Returns:
xml bean with shape properties.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFHyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFHyperlink

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFHyperlink
All Implemented Interfaces:
Hyperlink
public class XSSFHyperlink
extends java.lang.Object
implements Hyperlink

XSSF Implementation of a Hyperlink. Note - unlike with HSSF, many kinds of hyperlink are largely stored as relations of the sheet

Field Summary
Fields inherited from interface org.apache.poi.common.usermodel.Hyperlink
LINK_DOCUMENT, LINK_EMAIL, LINK_FILE, LINK_URL
Constructor Summary
protected | XSSFHyperlink(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHyperlink ctHyperlink, PackageRelationship hyperlinkRel) Create a XSSFHyperlink amd initialize it from the supplied CTHyperlink bean and package relationship
protected | XSSFHyperlink(int type) Create a new XSSFHyperlink.
Method Summary
protected void | generateRelationIfNeeded(PackagePart sheetPart) Generates the relation if required
java.lang.String | getAddress() Hypelink address.
java.lang.String | getCellRef() Get the reference of the cell this applies to, es A55
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHyperlink | getCTHyperlink()
int | getFirstColumn() Return the column of the first cell that contains the hyperlink
int | getFirstRow() Return the row of the first cell that contains the hyperlink
java.lang.String | getLabel() Return text label for this hyperlink
int | getLastColumn() Return the column of the last cell that contains the hyperlink
int | getLastRow() Return the row of the last cell that contains the hyperlink
java.lang.String | getLocation() Location within target.
java.lang.String | getTooltip()
int | getType() Return the type of this hyperlink
boolean | needsRelationToo() Do we need to a relation too, to represent this hyperlink?
void | setAddress(java.lang.String address) Hyperlink address.
protected void | setCellReference(java.lang.String ref) Assigns this hyperlink to the given cell reference
void | setFirstColumn(int col) Set the column of the first cell that contains the hyperlink
void | setFirstRow(int row) Set the row of the first cell that contains the hyperlink
void | setLabel(java.lang.String label) Sets text label for this hyperlink
void | setLastColumn(int col) Set the column of the last cell that contains the hyperlink
void | setLastRow(int row) Set the row of the last cell that contains the hyperlink
void | setLocation(java.lang.String location) Location within target.
void | setTooltip(java.lang.String text)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFHyperlink

protected XSSFHyperlink(int type)
Create a new XSSFHyperlink. This method is protected to be used only by XSSFCreationHelper

Parameters:
type - - the type of hyperlink to create

XSSFHyperlink

protected XSSFHyperlink(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHyperlink ctHyperlink,
                        PackageRelationship hyperlinkRel)
Create a XSSFHyperlink amd initialize it from the supplied CTHyperlink bean and package relationship

Parameters:
ctHyperlink - the xml bean containing xml properties
hyperlinkRel - the relationship in the underlying OPC package which stores the actual link's address
Method Detail

getCTHyperlink

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHyperlink getCTHyperlink()
Returns:
the underlying CTHyperlink object

needsRelationToo

public boolean needsRelationToo()
Do we need to a relation too, to represent this hyperlink?

generateRelationIfNeeded

protected void generateRelationIfNeeded(PackagePart sheetPart)
Generates the relation if required

getType

public int getType()
Return the type of this hyperlink

Specified by:
getType in interface Hyperlink
Returns:
the type of this hyperlink

getCellRef

public java.lang.String getCellRef()
Get the reference of the cell this applies to, es A55

getAddress

public java.lang.String getAddress()
Hypelink address. Depending on the hyperlink type it can be URL, e-mail, path to a file

Specified by:
getAddress in interface Hyperlink
Returns:
the address of this hyperlink

getLabel

public java.lang.String getLabel()
Return text label for this hyperlink

Specified by:
getLabel in interface Hyperlink
Returns:
text to display

getLocation

public java.lang.String getLocation()
Location within target. If target is a workbook (or this workbook) this shall refer to a sheet and cell or a defined name. Can also be an HTML anchor if target is HTML file.

Returns:
location

setLabel

public void setLabel(java.lang.String label)
Sets text label for this hyperlink

Specified by:
setLabel in interface Hyperlink
Parameters:
label - text label for this hyperlink

setLocation

public void setLocation(java.lang.String location)
Location within target. If target is a workbook (or this workbook) this shall refer to a sheet and cell or a defined name. Can also be an HTML anchor if target is HTML file.

Parameters:
location - - string representing a location of this hyperlink

setAddress

public void setAddress(java.lang.String address)
Hyperlink address. Depending on the hyperlink type it can be URL, e-mail, path to a file

Specified by:
setAddress in interface Hyperlink
Parameters:
address - - the address of this hyperlink

setCellReference

protected void setCellReference(java.lang.String ref)
Assigns this hyperlink to the given cell reference

getFirstColumn

public int getFirstColumn()
Return the column of the first cell that contains the hyperlink

Returns:
the 0-based column of the first cell that contains the hyperlink

getLastColumn

public int getLastColumn()
Return the column of the last cell that contains the hyperlink

Returns:
the 0-based column of the last cell that contains the hyperlink

getFirstRow

public int getFirstRow()
Return the row of the first cell that contains the hyperlink

Returns:
the 0-based row of the cell that contains the hyperlink

getLastRow

public int getLastRow()
Return the row of the last cell that contains the hyperlink

Returns:
the 0-based row of the last cell that contains the hyperlink

setFirstColumn

public void setFirstColumn(int col)
Set the column of the first cell that contains the hyperlink

Parameters:
col - the 0-based column of the first cell that contains the hyperlink

setLastColumn

public void setLastColumn(int col)
Set the column of the last cell that contains the hyperlink

Parameters:
col - the 0-based column of the last cell that contains the hyperlink

setFirstRow

public void setFirstRow(int row)
Set the row of the first cell that contains the hyperlink

Parameters:
row - the 0-based row of the first cell that contains the hyperlink

setLastRow

public void setLastRow(int row)
Set the row of the last cell that contains the hyperlink

Parameters:
row - the 0-based row of the last cell that contains the hyperlink

getTooltip

public java.lang.String getTooltip()
Returns:
additional text to help the user understand more about the hyperlink

setTooltip

public void setTooltip(java.lang.String text)
Parameters:
text - additional text to help the user understand more about the hyperlink
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFMap

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFMap

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFMap

public class XSSFMap
extends java.lang.Object

This class implements the Map element (Open Office XML Part 4: chapter 3.16.2)

This element contains all of the properties related to the XML map, and the behaviors expected during data refresh operations.

Author:
Roberto Manicardi

Constructor Summary
XSSFMap(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMap ctMap, MapInfo mapInfo)
Method Summary
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMap | getCtMap()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSchema | getCTSchema()
java.util.List<XSSFSingleXmlCell> | getRelatedSingleXMLCell()
java.util.List<XSSFTable> | getRelatedTables()
org.w3c.dom.Node | getSchema()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFMap

public XSSFMap(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMap ctMap,
               MapInfo mapInfo)
Method Detail

getCtMap

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTMap getCtMap()

getCTSchema

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSchema getCTSchema()

getSchema

public org.w3c.dom.Node getSchema()

getRelatedSingleXMLCell

public java.util.List<XSSFSingleXmlCell> getRelatedSingleXMLCell()
Returns:
the list of Single Xml Cells that provide a map rule to this mapping.

getRelatedTables

public java.util.List<XSSFTable> getRelatedTables()
Returns:
the list of all Tables that provide a map rule to this mapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFName

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFName

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFName
All Implemented Interfaces:
Name
public final class XSSFName
extends java.lang.Object
implements Name

Represents a defined named range in a SpreadsheetML workbook.

Defined names are descriptive text that is used to represents a cell, range of cells, formula, or constant value. Use easy-to-understand names, such as Products, to refer to hard to understand ranges, such as Sales!C20:C30.

Example:

   XSSFWorkbook wb = new XSSFWorkbook();
   XSSFSheet sh = wb.createSheet("Sheet1");

   //applies to the entire workbook
   XSSFName name1 = wb.createName();
   name1.setNameName("FMLA");
   name1.setRefersToFormula("Sheet1!$B$3");

   //applies to Sheet1
   XSSFName name2 = wb.createName();
   name2.setNameName("SheetLevelName");
   name2.setComment("This name is scoped to Sheet1");
   name2.setLocalSheetId(0);
   name2.setRefersToFormula("Sheet1!$B$3");

Author:
Nick Burch, Yegor Kozlov

Field Summary
static java.lang.String | BUILTIN_CONSOLIDATE_AREA A built-in defined name that refers to a consolidation area
static java.lang.String | BUILTIN_CRITERIA A built-in defined name that refers to a range containing the criteria values to be used in applying an advanced filter to a range of data
static java.lang.String | BUILTIN_DATABASE A built-in defined name that specified that the range specified is from a database data source
static java.lang.String | BUILTIN_EXTRACT this defined name refers to the range containing the filtered output values resulting from applying an advanced filter criteria to a source range
static java.lang.String | BUILTIN_FILTER_DB ?an be one of the following this defined name refers to a range to which an advanced filter has been applied.
static java.lang.String | BUILTIN_PRINT_AREA A built-in defined name that specifies the workbook's print area
static java.lang.String | BUILTIN_PRINT_TITLE A built-in defined name that specifies the row(s) or column(s) to repeat at the top of each printed page.
static java.lang.String | BUILTIN_SHEET_TITLE A built-in defined name that refers to a sheet title.
Constructor Summary
protected XSSFName(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDefinedName name, XSSFWorkbook workbook)
Creates an XSSFName object - called internally by XSSFWorkbook.
Method Summary
boolean | equals(java.lang.Object o) Compares this name to the specified object.
java.lang.String | getComment() Returns the comment the user provided when the name was created.
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDefinedName | getCTName() Returns the underlying named range object
boolean | getFunction() Indicates that the defined name refers to a user-defined function.
int | getFunctionGroupId() Returns the function group index if the defined name refers to a function.
java.lang.String | getNameName() Returns the name that will appear in the user interface for the defined name.
java.lang.String | getRefersToFormula() Returns the formula that the name is defined to refer to.
int | getSheetIndex() Returns the sheet index this name applies to.
java.lang.String | getSheetName() Get the sheets name which this named range is referenced to
int | hashCode()
boolean | isDeleted() Checks if this name points to a cell that no longer exists
boolean | isFunctionName() Is the name refers to a user-defined function ?
void | setComment(java.lang.String comment) Specifies the comment the user provided when the name was created.
void | setFunction(boolean value) Indicates that the defined name refers to a user-defined function.
void | setFunctionGroupId(int functionGroupId) Specifies the function group index if the defined name refers to a function.
void | setNameName(java.lang.String name) Sets the name that will appear in the user interface for the defined name.
void | setRefersToFormula(java.lang.String formulaText) Sets the formula that the name is defined to refer to.
void | setSheetIndex(int index) Tell Excel that this name applies to the worksheet with the specified index instead of the entire workbook.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

BUILTIN_PRINT_AREA

public static final java.lang.String BUILTIN_PRINT_AREA
A built-in defined name that specifies the workbook's print area

See Also:
Constant Field Values

BUILTIN_PRINT_TITLE

public static final java.lang.String BUILTIN_PRINT_TITLE
A built-in defined name that specifies the row(s) or column(s) to repeat at the top of each printed page.

See Also:
Constant Field Values

BUILTIN_CRITERIA

public static final java.lang.String BUILTIN_CRITERIA
A built-in defined name that refers to a range containing the criteria values to be used in applying an advanced filter to a range of data

See Also:
Constant Field Values

BUILTIN_EXTRACT

public static final java.lang.String BUILTIN_EXTRACT
this defined name refers to the range containing the filtered output values resulting from applying an advanced filter criteria to a source range

See Also:
Constant Field Values

BUILTIN_FILTER_DB

public static final java.lang.String BUILTIN_FILTER_DB
?an be one of the following
  • this defined name refers to a range to which an advanced filter has been applied. This represents the source data range, unfiltered.
  • This defined name refers to a range to which an AutoFilter has been applied

    See Also:
    Constant Field Values

    • BUILTIN_CONSOLIDATE_AREA

    public static final java.lang.String BUILTIN_CONSOLIDATE_AREA
    A built-in defined name that refers to a consolidation area

    See Also:
    Constant Field Values

    BUILTIN_DATABASE

    public static final java.lang.String BUILTIN_DATABASE
    A built-in defined name that specified that the range specified is from a database data source

    See Also:
    Constant Field Values

    BUILTIN_SHEET_TITLE

    public static final java.lang.String BUILTIN_SHEET_TITLE
    A built-in defined name that refers to a sheet title.

    See Also:
    Constant Field Values
    Constructor Detail

    XSSFName

    protected XSSFName(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDefinedName name,
                   XSSFWorkbook workbook)
    Creates an XSSFName object - called internally by XSSFWorkbook.

    Parameters:
    name - - the xml bean that holds data represenring this defined name.
    workbook - - the workbook object associated with the name
    See Also:
    XSSFWorkbook.createName()
    Method Detail

    getCTName

    protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDefinedName getCTName()
    Returns the underlying named range object

    getNameName

    public java.lang.String getNameName()
    Returns the name that will appear in the user interface for the defined name.

    Specified by:
    getNameName in interface Name
    Returns:
    text name of this defined name

    setNameName

    public void setNameName(java.lang.String name)
    Sets the name that will appear in the user interface for the defined name. Names must begin with a letter or underscore, not contain spaces and be unique across the workbook.

    A name must always be unique within its scope. POI prevents you from defining a name that is not unique within its scope. However you can use the same name in different scopes. Example:

 //by default names are workbook-global
 XSSFName name;
 name = workbook.createName();
 name.setNameName("sales_08");

 name = workbook.createName();
 name.setNameName("sales_08"); //will throw an exception: "The workbook already contains this name (case-insensitive)"

 //create sheet-level name
 name = workbook.createName();
 name.setSheetIndex(0); //the scope of the name is the first sheet
 name.setNameName("sales_08");  //ok

 name = workbook.createName();
 name.setSheetIndex(0);
 name.setNameName("sales_08");  //will throw an exception: "The sheet already contains this name (case-insensitive)"

    Specified by:
    setNameName in interface Name
    Parameters:
    name - name of this defined name
    Throws:
    java.lang.IllegalArgumentException - if the name is invalid or the workbook already contains this name (case-insensitive)

    getRefersToFormula

    public java.lang.String getRefersToFormula()
    Description copied from interface: Name
    Returns the formula that the name is defined to refer to.

    Specified by:
    getRefersToFormula in interface Name
    Returns:
    the reference for this name, null if it has not been set yet. Never empty string
    See Also:
    Name.setRefersToFormula(String)

    setRefersToFormula

    public void setRefersToFormula(java.lang.String formulaText)
    Description copied from interface: Name
    Sets the formula that the name is defined to refer to. The following are representative examples:
    • 'My Sheet'!$A$3
    • 8.3
    • HR!$A$1:$Z$345
    • SUM(Sheet1!A1,Sheet2!B2)
    • -PMT(Interest_Rate/12,Number_of_Payments,Loan_Amount)

    Specified by:
    setRefersToFormula in interface Name
    Parameters:
    formulaText - the reference for this name

    isDeleted

    public boolean isDeleted()
    Description copied from interface: Name
    Checks if this name points to a cell that no longer exists

    Specified by:
    isDeleted in interface Name
    Returns:
    true if the name refers to a deleted cell, false otherwise

    setSheetIndex

    public void setSheetIndex(int index)
    Tell Excel that this name applies to the worksheet with the specified index instead of the entire workbook.

    Specified by:
    setSheetIndex in interface Name
    Parameters:
    index - the sheet index this name applies to, -1 unsets this property making the name workbook-global

    getSheetIndex

    public int getSheetIndex()
    Returns the sheet index this name applies to.

    Specified by:
    getSheetIndex in interface Name
    Returns:
    the sheet index this name applies to, -1 if this name applies to the entire workbook

    setFunction

    public void setFunction(boolean value)
    Indicates that the defined name refers to a user-defined function. This attribute is used when there is an add-in or other code project associated with the file.

    Specified by:
    setFunction in interface Name
    Parameters:
    value - true indicates the name refers to a function.

    getFunction

    public boolean getFunction()
    Indicates that the defined name refers to a user-defined function. This attribute is used when there is an add-in or other code project associated with the file.

    Returns:
    true indicates the name refers to a function.

    setFunctionGroupId

    public void setFunctionGroupId(int functionGroupId)
    Specifies the function group index if the defined name refers to a function. The function group defines the general category for the function. This attribute is used when there is an add-in or other code project associated with the file.

    Parameters:
    functionGroupId - the function group index that defines the general category for the function

    getFunctionGroupId

    public int getFunctionGroupId()
    Returns the function group index if the defined name refers to a function. The function group defines the general category for the function. This attribute is used when there is an add-in or other code project associated with the file.

    Returns:
    the function group index that defines the general category for the function

    getSheetName

    public java.lang.String getSheetName()
    Get the sheets name which this named range is referenced to

    Specified by:
    getSheetName in interface Name
    Returns:
    sheet name, which this named range referred to. Empty string if the referenced sheet name weas not found.

    isFunctionName

    public boolean isFunctionName()
    Is the name refers to a user-defined function ?

    Specified by:
    isFunctionName in interface Name
    Returns:
    true if this name refers to a user-defined function

    getComment

    public java.lang.String getComment()
    Returns the comment the user provided when the name was created.

    Specified by:
    getComment in interface Name
    Returns:
    the user comment for this named range

    setComment

    public void setComment(java.lang.String comment)
    Specifies the comment the user provided when the name was created.

    Specified by:
    setComment in interface Name
    Parameters:
    comment - the user comment for this named range

    hashCode

    public int hashCode()
    Overrides:
    hashCode in class java.lang.Object

    equals

    public boolean equals(java.lang.Object o)
    Compares this name to the specified object. The result is true if the argument is XSSFName and the underlying CTDefinedName bean equals to the CTDefinedName representing this name

    Overrides:
    equals in class java.lang.Object
    Parameters:
    o - the object to compare this XSSFName against.
    Returns:
    true if the XSSFName are equal; false otherwise.
    Overview  Package   Class  Use  Tree  Deprecated  Index  Help
     PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFOddFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFOddFooter

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
        extended by  org.apache.poi.xssf.usermodel.XSSFOddFooter
All Implemented Interfaces:
Footer, HeaderFooter
public class XSSFOddFooter
extends XSSFHeaderFooter
implements Footer

Odd page footer value. Corresponds to odd printed pages. Odd page(s) in the sheet may not be printed, for example, if the print area is specified to be a range such that it falls outside an odd page's scope.

Constructor Summary
XSSFOddFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFOddFooter from the supplied XML bean
Method Summary
java.lang.String | getText() Get the content text representing the footer
void | setText(java.lang.String text) Set a text for the footer.
Methods inherited from class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
areFieldsStripped, getCenter, getHeaderFooter, getLeft, getRight, getValue, setAreFieldsStripped, setCenter, setLeft, setRight, stripFields
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Footer
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

XSSFOddFooter

public XSSFOddFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFOddFooter from the supplied XML bean

Parameters:
headerFooter -
See Also:
XSSFSheet.getOddFooter()
Method Detail

getText

public java.lang.String getText()
Get the content text representing the footer

Specified by:
getText in class XSSFHeaderFooter
Returns:
text

setText

public void setText(java.lang.String text)
Set a text for the footer. If null unset the value.

Specified by:
setText in class XSSFHeaderFooter
Parameters:
text - - a string representing the footer.
See Also:
to see how to create a string with Header/Footer Formatting Syntax
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFOddHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFOddHeader

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
        extended by  org.apache.poi.xssf.usermodel.XSSFOddHeader
All Implemented Interfaces:
Header, HeaderFooter
public class XSSFOddHeader
extends XSSFHeaderFooter
implements Header

Odd page header value. Corresponds to odd printed pages. Odd page(s) in the sheet may not be printed, for example, if the print area is specified to be a range such that it falls outside an odd page's scope.

Constructor Summary
protected XSSFOddHeader(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFOddHeader from the supplied XML bean
Method Summary
java.lang.String | getText() Get the content text representing this header
void | setText(java.lang.String text) Set a text for the header.
Methods inherited from class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
areFieldsStripped, getCenter, getHeaderFooter, getLeft, getRight, getValue, setAreFieldsStripped, setCenter, setLeft, setRight, stripFields
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Header
getCenter, getLeft, getRight, setCenter, setLeft, setRight

Constructor Detail

XSSFOddHeader

protected XSSFOddHeader(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFOddHeader from the supplied XML bean

Parameters:
headerFooter -
See Also:
XSSFSheet.getOddHeader()
Method Detail

getText

public java.lang.String getText()
Get the content text representing this header

Specified by:
getText in class XSSFHeaderFooter
Returns:
text

setText

public void setText(java.lang.String text)
Set a text for the header. If null unset the value

Specified by:
setText in class XSSFHeaderFooter
Parameters:
text - - a string representing the header.
See Also:
to see how to create a string with Header/Footer Formatting Syntax
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFPatternFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFPatternFormatting

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFPatternFormatting
All Implemented Interfaces:
PatternFormatting
public class XSSFPatternFormatting
extends java.lang.Object
implements PatternFormatting

Author:
Yegor Kozlov

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.PatternFormatting
ALT_BARS, BIG_SPOTS, BRICKS, DIAMONDS, FINE_DOTS, LEAST_DOTS, LESS_DOTS, NO_FILL, SOLID_FOREGROUND, SPARSE_DOTS, SQUARES, THICK_BACKWARD_DIAG, THICK_FORWARD_DIAG, THICK_HORZ_BANDS, THICK_VERT_BANDS, THIN_BACKWARD_DIAG, THIN_FORWARD_DIAG, THIN_HORZ_BANDS, THIN_VERT_BANDS
Method Summary
short | getFillBackgroundColor()
short | getFillForegroundColor()
short | getFillPattern()
void | setFillBackgroundColor(short bg)
void | setFillForegroundColor(short fg)
void | setFillPattern(short fp)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getFillBackgroundColor

public short getFillBackgroundColor()
Specified by:
getFillBackgroundColor in interface PatternFormatting

getFillForegroundColor

public short getFillForegroundColor()
Specified by:
getFillForegroundColor in interface PatternFormatting

getFillPattern

public short getFillPattern()
Specified by:
getFillPattern in interface PatternFormatting

setFillBackgroundColor

public void setFillBackgroundColor(short bg)
Specified by:
setFillBackgroundColor in interface PatternFormatting

setFillForegroundColor

public void setFillForegroundColor(short fg)
Specified by:
setFillForegroundColor in interface PatternFormatting

setFillPattern

public void setFillPattern(short fp)
Specified by:
setFillPattern in interface PatternFormatting
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFPicture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFPicture

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFShape
        extended by  org.apache.poi.xssf.usermodel.XSSFPicture
All Implemented Interfaces:
Picture
public final class XSSFPicture
extends XSSFShape
implements Picture

Represents a picture shape in a SpreadsheetML drawing.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFShape
anchor, drawing, EMU_PER_PIXEL, EMU_PER_POINT, parent, PIXEL_DPI, POINT_DPI
Constructor Summary
protected XSSFPicture(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture ctPicture)
Construct a new XSSFPicture object.
Method Summary
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture | getCTPicture() Return the underlying CTPicture bean that holds all properties for this picture
protected static java.awt.Dimension | getImageDimension(PackagePart part, int type) Return the dimension of this image
XSSFPictureData | getPictureData() Return picture data for this shape
XSSFClientAnchor | getPreferredSize() Calculate the preferred size for this picture.
XSSFClientAnchor | getPreferredSize(double scale) Calculate the preferred size for this picture.
protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties | getShapeProperties() Returns xml bean with shape properties.
protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture | prototype() Returns a prototype that is used to construct new shapes
void | resize() Reset the image to the original size.
void | resize(double scale) Reset the image to the original size.
protected void | setPictureReference(PackageRelationship rel) Link this shape with the picture data
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFShape
getAnchor, getDrawing, getParent, isNoFill, setFillColor, setLineStyle, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFPicture

protected XSSFPicture(XSSFDrawing drawing,
                      org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture ctPicture)
Construct a new XSSFPicture object. This constructor is called from XSSFDrawing.createPicture(XSSFClientAnchor, int)

Parameters:
drawing - the XSSFDrawing that owns this picture
Method Detail

prototype

protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture prototype()
Returns a prototype that is used to construct new shapes

Returns:
a prototype that is used to construct new shapes

setPictureReference

protected void setPictureReference(PackageRelationship rel)
Link this shape with the picture data

Parameters:
rel - relationship referring the picture data

getCTPicture

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture getCTPicture()
Return the underlying CTPicture bean that holds all properties for this picture

Returns:
the underlying CTPicture bean

resize

public void resize()
Reset the image to the original size.

Please note, that this method works correctly only for workbooks with the default font size (Calibri 11pt for .xlsx). If the default font is changed the resized image can be streched vertically or horizontally.

Specified by:
resize in interface Picture

resize

public void resize(double scale)
Reset the image to the original size.

Please note, that this method works correctly only for workbooks with the default font size (Calibri 11pt for .xlsx). If the default font is changed the resized image can be streched vertically or horizontally.

Specified by:
resize in interface Picture
Parameters:
scale - the amount by which image dimensions are multiplied relative to the original size. resize(1.0) sets the original size, resize(0.5) resize to 50% of the original, resize(2.0) resizes to 200% of the original.

getPreferredSize

public XSSFClientAnchor getPreferredSize()
Calculate the preferred size for this picture.

Specified by:
getPreferredSize in interface Picture
Returns:
XSSFClientAnchor with the preferred size for this image

getPreferredSize

public XSSFClientAnchor getPreferredSize(double scale)
Calculate the preferred size for this picture.

Parameters:
scale - the amount by which image dimensions are multiplied relative to the original size.
Returns:
XSSFClientAnchor with the preferred size for this image

getImageDimension

protected static java.awt.Dimension getImageDimension(PackagePart part,
                                                      int type)
Return the dimension of this image

Parameters:
part - the package part holding raw picture data
type - type of the picture: Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PNG or Workbook.PICTURE_TYPE_DIB
Returns:
image dimension in pixels

getPictureData

public XSSFPictureData getPictureData()
Return picture data for this shape

Specified by:
getPictureData in interface Picture
Returns:
picture data for this shape

getShapeProperties

protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties getShapeProperties()
Description copied from class: XSSFShape
Returns xml bean with shape properties.

Specified by:
getShapeProperties in class XSSFShape
Returns:
xml bean with shape properties.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFPictureData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFPictureData

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFPictureData
All Implemented Interfaces:
PictureData
public class XSSFPictureData
extends POIXMLDocumentPart
implements PictureData

Raw picture data, normally attached to a SpreadsheetML Drawing. As a rule, pictures are stored in the /xl/media/ part of a SpreadsheetML package.

Field Summary
protected static POIXMLRelation[] RELATIONS
Relationships for each known picture type
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected | XSSFPictureData() Create a new XSSFPictureData node
protected | XSSFPictureData(PackagePart part, PackageRelationship rel) Construct XSSFPictureData from a package part
Method Summary
byte[] | getData() Gets the picture data as a byte array.
java.lang.String | getMimeType() Returns the mime type for the image
int | getPictureType() Return an integer constant that specifies type of this picture
java.lang.String | suggestFileExtension() Suggests a file extension for this image.
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RELATIONS

protected static final POIXMLRelation[] RELATIONS
Relationships for each known picture type

Constructor Detail

XSSFPictureData

protected XSSFPictureData()
Create a new XSSFPictureData node

See Also:
XSSFWorkbook.addPicture(byte[], int)

XSSFPictureData

protected XSSFPictureData(PackagePart part,
                          PackageRelationship rel)
Construct XSSFPictureData from a package part

Parameters:
part - the package part holding the drawing data,
rel - the package relationship holding this drawing, the relationship type must be http://schemas.openxmlformats.org/officeDocument/2006/relationships/image
Method Detail

getData

public byte[] getData()
Gets the picture data as a byte array.

Note, that this call might be expensive since all the picture data is copied into a temporary byte array. You can grab the picture data directly from the underlying package part as follows:
InputStream is = getPackagePart().getInputStream();

Specified by:
getData in interface PictureData
Returns:
the picture data.

suggestFileExtension

public java.lang.String suggestFileExtension()
Suggests a file extension for this image.

Specified by:
suggestFileExtension in interface PictureData
Returns:
the file extension.

getPictureType

public int getPictureType()
Return an integer constant that specifies type of this picture

Returns:
an integer constant that specifies type of this picture
See Also:
Workbook.PICTURE_TYPE_EMF, Workbook.PICTURE_TYPE_WMF, Workbook.PICTURE_TYPE_PICT, Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PNG, Workbook.PICTURE_TYPE_DIB

getMimeType

public java.lang.String getMimeType()
Description copied from interface: PictureData
Returns the mime type for the image

Specified by:
getMimeType in interface PictureData
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFPrintSetup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFPrintSetup

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFPrintSetup
All Implemented Interfaces:
PrintSetup
public class XSSFPrintSetup
extends java.lang.Object
implements PrintSetup

Page setup and page margins settings for the worksheet.

Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.PrintSetup
A3_PAPERSIZE, A4_EXTRA_PAPERSIZE, A4_PAPERSIZE, A4_PLUS_PAPERSIZE, A4_ROTATED_PAPERSIZE, A4_SMALL_PAPERSIZE, A4_TRANSVERSE_PAPERSIZE, A5_PAPERSIZE, B4_PAPERSIZE, B5_PAPERSIZE, ELEVEN_BY_SEVENTEEN_PAPERSIZE, ENVELOPE_10_PAPERSIZE, ENVELOPE_9_PAPERSIZE, ENVELOPE_C3_PAPERSIZE, ENVELOPE_C4_PAPERSIZE, ENVELOPE_C5_PAPERSIZE, ENVELOPE_C6_PAPERSIZE, ENVELOPE_CS_PAPERSIZE, ENVELOPE_DL_PAPERSIZE, ENVELOPE_MONARCH_PAPERSIZE, EXECUTIVE_PAPERSIZE, FOLIO8_PAPERSIZE, LEDGER_PAPERSIZE, LEGAL_PAPERSIZE, LETTER_PAPERSIZE, LETTER_ROTATED_PAPERSIZE, LETTER_SMALL_PAGESIZE, NOTE8_PAPERSIZE, QUARTO_PAPERSIZE, STATEMENT_PAPERSIZE, TABLOID_PAPERSIZE, TEN_BY_FOURTEEN_PAPERSIZE
Constructor Summary
protected XSSFPrintSetup(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet worksheet)
Method Summary
PrintCellComments | getCellComment()
short | getCopies() Returns the number of copies.
boolean | getDraft() Returns the draft mode.
short | getFitHeight() Returns the number of pages high to fit the sheet in.
short | getFitWidth() Returns the number of pages wide to fit sheet in.
double | getFooterMargin() Returns the footer margin.
double | getHeaderMargin() Returns the header margin.
short | getHResolution() Returns the horizontal resolution.
boolean | getLandscape() Returns the landscape mode.
boolean | getLeftToRight() Returns the left to right print order.
boolean | getNoColor() Returns the black and white setting.
boolean | getNoOrientation() Returns the no orientation.
boolean | getNotes() Returns the print notes.
PrintOrientation | getOrientation() Orientation of the page: landscape - portrait.
PageOrder | getPageOrder() get print page order.
short | getPageStart() Set the page numbering start.
short | getPaperSize() Returns the paper size.
PaperSize | getPaperSizeEnum() Returns the paper size as enum.
short | getScale() Returns the scale.
boolean | getUsePage() Returns the use page numbers.
boolean | getValidSettings() Use the printer's defaults settings for page setup values and don't use the default values specified in the schema.
short | getVResolution() Returns the vertical resolution.
void | setCopies(short copies) Sets the number of copies.
void | setDraft(boolean d) Set whether it is in draft mode
void | setFitHeight(short height) Set the number of pages high to fit the sheet in
void | setFitWidth(short width) Set the number of pages wide to fit the sheet in
void | setFooterMargin(double footermargin) Sets the footer margin.
void | setHeaderMargin(double headermargin) Sets the header margin.
void | setHResolution(short resolution) Sets the horizontal resolution.
void | setLandscape(boolean ls) Set whether to print in landscape
void | setLeftToRight(boolean ltor) Set whether to go left to right or top down in ordering
void | setNoColor(boolean mono) Set whether it is black and white
void | setNoOrientation(boolean orientation) Set no orientation.
void | setNotes(boolean printnotes) Print the include notes
void | setOrientation(PrintOrientation orientation) Orientation of the page: landscape - portrait.
void | setPageOrder(PageOrder pageOrder) Set print page order.
void | setPageStart(short start) Set the page numbering start.
void | setPaperSize(PaperSize size) Set the paper size as enum value.
void | setPaperSize(short size) Set the paper size.
void | setScale(short scale) Set the scale.
void | setUsePage(boolean page) Set whether to use page start
void | setValidSettings(boolean valid) Use the printer's defaults settings for page setup values and don't use the default values specified in the schema.
void | setVResolution(short resolution) Sets the vertical resolution.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFPrintSetup

protected XSSFPrintSetup(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet worksheet)
Method Detail

setPaperSize

public void setPaperSize(short size)
Set the paper size.

Specified by:
setPaperSize in interface PrintSetup
Parameters:
size - the paper size.

setPaperSize

public void setPaperSize(PaperSize size)
Set the paper size as enum value.

Parameters:
size - value for the paper size.

setScale

public void setScale(short scale)
Set the scale. Valid values range from 10 to 400. This setting is overridden when fitToWidth and/or fitToHeight are in use

Specified by:
setScale in interface PrintSetup
Parameters:
scale - the scale to use

setPageStart

public void setPageStart(short start)
Set the page numbering start. Page number for first printed page. If no value is specified, then 'automatic' is assumed.

Specified by:
setPageStart in interface PrintSetup
Parameters:
start - the page numbering start

setFitWidth

public void setFitWidth(short width)
Set the number of pages wide to fit the sheet in

Specified by:
setFitWidth in interface PrintSetup
Parameters:
width - the number of pages

setFitHeight

public void setFitHeight(short height)
Set the number of pages high to fit the sheet in

Specified by:
setFitHeight in interface PrintSetup
Parameters:
height - the number of pages

setLeftToRight

public void setLeftToRight(boolean ltor)
Set whether to go left to right or top down in ordering

Specified by:
setLeftToRight in interface PrintSetup
Parameters:
ltor - left to right

setLandscape

public void setLandscape(boolean ls)
Set whether to print in landscape

Specified by:
setLandscape in interface PrintSetup
Parameters:
ls - landscape

setValidSettings

public void setValidSettings(boolean valid)
Use the printer's defaults settings for page setup values and don't use the default values specified in the schema. For example, if dpi is not present or specified in the XML, the a plication shall not assume 600dpi as specified in the schema as a default and instead shall let the printer specify the default dpi.

Specified by:
setValidSettings in interface PrintSetup
Parameters:
valid - Valid

setNoColor

public void setNoColor(boolean mono)
Set whether it is black and white

Specified by:
setNoColor in interface PrintSetup
Parameters:
mono - Black and white

setDraft

public void setDraft(boolean d)
Set whether it is in draft mode

Specified by:
setDraft in interface PrintSetup
Parameters:
d - draft

setNotes

public void setNotes(boolean printnotes)
Print the include notes

Specified by:
setNotes in interface PrintSetup
Parameters:
printnotes - print the notes

setNoOrientation

public void setNoOrientation(boolean orientation)
Set no orientation.

Specified by:
setNoOrientation in interface PrintSetup
Parameters:
orientation - Orientation.

setUsePage

public void setUsePage(boolean page)
Set whether to use page start

Specified by:
setUsePage in interface PrintSetup
Parameters:
page - Use page start

setHResolution

public void setHResolution(short resolution)
Sets the horizontal resolution.

Specified by:
setHResolution in interface PrintSetup
Parameters:
resolution - horizontal resolution

setVResolution

public void setVResolution(short resolution)
Sets the vertical resolution.

Specified by:
setVResolution in interface PrintSetup
Parameters:
resolution - vertical resolution

setHeaderMargin

public void setHeaderMargin(double headermargin)
Sets the header margin.

Specified by:
setHeaderMargin in interface PrintSetup
Parameters:
headermargin - header margin

setFooterMargin

public void setFooterMargin(double footermargin)
Sets the footer margin.

Specified by:
setFooterMargin in interface PrintSetup
Parameters:
footermargin - footer margin

setCopies

public void setCopies(short copies)
Sets the number of copies.

Specified by:
setCopies in interface PrintSetup
Parameters:
copies - number of copies

setOrientation

public void setOrientation(PrintOrientation orientation)
Orientation of the page: landscape - portrait.

Parameters:
orientation - - Orientation of the page
See Also:
PrintOrientation

getOrientation

public PrintOrientation getOrientation()
Orientation of the page: landscape - portrait.

Returns:
Orientation of the page
See Also:
PrintOrientation

getCellComment

public PrintCellComments getCellComment()

setPageOrder

public void setPageOrder(PageOrder pageOrder)
Set print page order.

Parameters:
pageOrder -

getPageOrder

public PageOrder getPageOrder()
get print page order.

Returns:
PageOrder

getPaperSize

public short getPaperSize()
Returns the paper size.

Specified by:
getPaperSize in interface PrintSetup
Returns:
short - paper size

getPaperSizeEnum

public PaperSize getPaperSizeEnum()
Returns the paper size as enum.

Returns:
PaperSize paper size
See Also:
PaperSize

getScale

public short getScale()
Returns the scale.

Specified by:
getScale in interface PrintSetup
Returns:
short - scale

getPageStart

public short getPageStart()
Set the page numbering start. Page number for first printed page. If no value is specified, then 'automatic' is assumed.

Specified by:
getPageStart in interface PrintSetup
Returns:
page number for first printed page

getFitWidth

public short getFitWidth()
Returns the number of pages wide to fit sheet in.

Specified by:
getFitWidth in interface PrintSetup
Returns:
number of pages wide to fit sheet in

getFitHeight

public short getFitHeight()
Returns the number of pages high to fit the sheet in.

Specified by:
getFitHeight in interface PrintSetup
Returns:
number of pages high to fit the sheet in

getLeftToRight

public boolean getLeftToRight()
Returns the left to right print order.

Specified by:
getLeftToRight in interface PrintSetup
Returns:
left to right print order

getLandscape

public boolean getLandscape()
Returns the landscape mode.

Specified by:
getLandscape in interface PrintSetup
Returns:
landscape mode

getValidSettings

public boolean getValidSettings()
Use the printer's defaults settings for page setup values and don't use the default values specified in the schema. For example, if dpi is not present or specified in the XML, the application shall not assume 600dpi as specified in the schema as a default and instead shall let the printer specify the default dpi.

Specified by:
getValidSettings in interface PrintSetup
Returns:
valid settings

getNoColor

public boolean getNoColor()
Returns the black and white setting.

Specified by:
getNoColor in interface PrintSetup
Returns:
black and white setting

getDraft

public boolean getDraft()
Returns the draft mode.

Specified by:
getDraft in interface PrintSetup
Returns:
draft mode

getNotes

public boolean getNotes()
Returns the print notes.

Specified by:
getNotes in interface PrintSetup
Returns:
print notes

getNoOrientation

public boolean getNoOrientation()
Returns the no orientation.

Specified by:
getNoOrientation in interface PrintSetup
Returns:
no orientation

getUsePage

public boolean getUsePage()
Returns the use page numbers.

Specified by:
getUsePage in interface PrintSetup
Returns:
use page numbers

getHResolution

public short getHResolution()
Returns the horizontal resolution.

Specified by:
getHResolution in interface PrintSetup
Returns:
horizontal resolution

getVResolution

public short getVResolution()
Returns the vertical resolution.

Specified by:
getVResolution in interface PrintSetup
Returns:
vertical resolution

getHeaderMargin

public double getHeaderMargin()
Returns the header margin.

Specified by:
getHeaderMargin in interface PrintSetup
Returns:
header margin

getFooterMargin

public double getFooterMargin()
Returns the footer margin.

Specified by:
getFooterMargin in interface PrintSetup
Returns:
footer margin

getCopies

public short getCopies()
Returns the number of copies.

Specified by:
getCopies in interface PrintSetup
Returns:
number of copies
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFRelation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFRelation

java.lang.Object
    extended by  org.apache.poi.POIXMLRelation
        extended by  org.apache.poi.xssf.usermodel.XSSFRelation

public final class XSSFRelation
extends POIXMLRelation

Field Summary
protected static java.util.Map<java.lang.String,XSSFRelation> | _table A map to lookup POIXMLRelation by its relation type
static XSSFRelation | ACTIVEX_BINS
static XSSFRelation | ACTIVEX_CONTROLS
static XSSFRelation | CALC_CHAIN
static XSSFRelation | CHART
static XSSFRelation | CHARTSHEET
static XSSFRelation | CUSTOM_XML_MAPPINGS
static XSSFRelation | DRAWINGS
static XSSFRelation | IMAGE_BMP
static XSSFRelation | IMAGE_DIB
static XSSFRelation | IMAGE_EMF
static XSSFRelation | IMAGE_EPS
static XSSFRelation | IMAGE_GIF
static XSSFRelation | IMAGE_JPEG
static XSSFRelation | IMAGE_PICT
static XSSFRelation | IMAGE_PNG
static XSSFRelation | IMAGE_TIFF
static XSSFRelation | IMAGE_WMF
static XSSFRelation | IMAGE_WPG
static XSSFRelation | IMAGES
static XSSFRelation | MACRO_ADDIN_WORKBOOK
static XSSFRelation | MACRO_TEMPLATE_WORKBOOK
static XSSFRelation | MACROS_WORKBOOK
static XSSFRelation | OLEEMBEDDINGS
static XSSFRelation | PACKEMBEDDINGS
static XSSFRelation | PRINTER_SETTINGS
static XSSFRelation | SHARED_STRINGS
static XSSFRelation | SHEET_COMMENTS
static XSSFRelation | SHEET_HYPERLINKS
static XSSFRelation | SINGLE_XML_CELLS
static XSSFRelation | STYLES
static XSSFRelation | TABLE
static XSSFRelation | TEMPLATE_WORKBOOK
static XSSFRelation | THEME
static XSSFRelation | VBA_MACROS
static XSSFRelation | VML_DRAWINGS
static XSSFRelation | WORKBOOK
static XSSFRelation | WORKSHEET
Fields inherited from class org.apache.poi.POIXMLRelation
_defaultName, _relation, _type
Method Summary
java.io.InputStream | getContents(PackagePart corePart) Fetches the InputStream to read the contents, based of the specified core part, for which we are defined as a suitable relationship
static XSSFRelation | getInstance(java.lang.String rel) Get POIXMLRelation by relation type
Methods inherited from class org.apache.poi.POIXMLRelation
getContentType, getDefaultFileName, getFileName, getRelation, getRelationClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_table

protected static java.util.Map<java.lang.String,XSSFRelation> _table
A map to lookup POIXMLRelation by its relation type

WORKBOOK

public static final XSSFRelation WORKBOOK

MACROS_WORKBOOK

public static final XSSFRelation MACROS_WORKBOOK

TEMPLATE_WORKBOOK

public static final XSSFRelation TEMPLATE_WORKBOOK

MACRO_TEMPLATE_WORKBOOK

public static final XSSFRelation MACRO_TEMPLATE_WORKBOOK

MACRO_ADDIN_WORKBOOK

public static final XSSFRelation MACRO_ADDIN_WORKBOOK

WORKSHEET

public static final XSSFRelation WORKSHEET

CHARTSHEET

public static final XSSFRelation CHARTSHEET

SHARED_STRINGS

public static final XSSFRelation SHARED_STRINGS

STYLES

public static final XSSFRelation STYLES

DRAWINGS

public static final XSSFRelation DRAWINGS

VML_DRAWINGS

public static final XSSFRelation VML_DRAWINGS

CHART

public static final XSSFRelation CHART

CUSTOM_XML_MAPPINGS

public static final XSSFRelation CUSTOM_XML_MAPPINGS

SINGLE_XML_CELLS

public static final XSSFRelation SINGLE_XML_CELLS

TABLE

public static final XSSFRelation TABLE

IMAGES

public static final XSSFRelation IMAGES

IMAGE_EMF

public static final XSSFRelation IMAGE_EMF

IMAGE_WMF

public static final XSSFRelation IMAGE_WMF

IMAGE_PICT

public static final XSSFRelation IMAGE_PICT

IMAGE_JPEG

public static final XSSFRelation IMAGE_JPEG

IMAGE_PNG

public static final XSSFRelation IMAGE_PNG

IMAGE_DIB

public static final XSSFRelation IMAGE_DIB

IMAGE_GIF

public static final XSSFRelation IMAGE_GIF

IMAGE_TIFF

public static final XSSFRelation IMAGE_TIFF

IMAGE_EPS

public static final XSSFRelation IMAGE_EPS

IMAGE_BMP

public static final XSSFRelation IMAGE_BMP

IMAGE_WPG

public static final XSSFRelation IMAGE_WPG

SHEET_COMMENTS

public static final XSSFRelation SHEET_COMMENTS

SHEET_HYPERLINKS

public static final XSSFRelation SHEET_HYPERLINKS

OLEEMBEDDINGS

public static final XSSFRelation OLEEMBEDDINGS

PACKEMBEDDINGS

public static final XSSFRelation PACKEMBEDDINGS

VBA_MACROS

public static final XSSFRelation VBA_MACROS

ACTIVEX_CONTROLS

public static final XSSFRelation ACTIVEX_CONTROLS

ACTIVEX_BINS

public static final XSSFRelation ACTIVEX_BINS

THEME

public static final XSSFRelation THEME

CALC_CHAIN

public static final XSSFRelation CALC_CHAIN

PRINTER_SETTINGS

public static final XSSFRelation PRINTER_SETTINGS
Method Detail

getContents

public java.io.InputStream getContents(PackagePart corePart)
                                throws java.io.IOException,
                                       InvalidFormatException
Fetches the InputStream to read the contents, based of the specified core part, for which we are defined as a suitable relationship

Throws:
java.io.IOException
InvalidFormatException

getInstance

public static XSSFRelation getInstance(java.lang.String rel)
Get POIXMLRelation by relation type

Parameters:
rel - relation type, for example, http://schemas.openxmlformats.org/officeDocument/2006/relationships/image
Returns:
registered POIXMLRelation or null if not found
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFRichTextString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFRichTextString

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFRichTextString
All Implemented Interfaces:
RichTextString
public class XSSFRichTextString
extends java.lang.Object
implements RichTextString

Rich text unicode string. These strings can have fonts applied to arbitary parts of the string.

Most strings in a workbook have formatting applied at the cell level, that is, the entire string in the cell has the same formatting applied. In these cases, the formatting for the cell is stored in the styles part, and the string for the cell can be shared across the workbook. The following code illustrates the example.

     cell1.setCellValue(new XSSFRichTextString("Apache POI"));
     cell2.setCellValue(new XSSFRichTextString("Apache POI"));
     cell3.setCellValue(new XSSFRichTextString("Apache POI"));
In the above example all three cells will use the same string cached on workbook level.

Some strings in the workbook may have formatting applied at a level that is more granular than the cell level. For instance, specific characters within the string may be bolded, have coloring, italicizing, etc. In these cases, the formatting is stored along with the text in the string table, and is treated as a unique entry in the workbook. The following xml and code snippet illustrate this.

     XSSFRichTextString s1 = new XSSFRichTextString("Apache POI");
     s1.applyFont(boldArial);
     cell1.setCellValue(s1);

     XSSFRichTextString s2 = new XSSFRichTextString("Apache POI");
     s2.applyFont(italicCourier);
     cell2.setCellValue(s2);

Author:
Yegor Kozlov

Constructor Summary
XSSFRichTextString()
Create empty rich text string and initialize it with empty string
XSSFRichTextString(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst st)
Create a rich text string from the supplied XML bean
XSSFRichTextString(java.lang.String str)
Create a rich text string
Method Summary
void | append(java.lang.String text) Append new text to this text run
void | append(java.lang.String text, XSSFFont font) Append new text to this text run and apply the specify font to it
void | applyFont(Font font) Sets the font of the entire string.
void | applyFont(int startIndex, int endIndex, Font font) Applies a font to the specified characters of a string.
void | applyFont(int startIndex, int endIndex, short fontIndex) Applies a font to the specified characters of a string.
void | applyFont(short fontIndex) Applies the specified font to the entire string.
void | clearFormatting() Removes any formatting that may have been applied to the string.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst | getCTRst() Return the underlying xml bean
XSSFFont | getFontAtIndex(int index) Return a copy of the font in use at a particular index.
XSSFFont | getFontOfFormattingRun(int index) Gets a copy of the font used in a particular formatting run.
int | getIndexOfFormattingRun(int index) The index within the string to which the specified formatting run applies.
int | getLengthOfFormattingRun(int index) Returns the number of characters this format run covers.
java.lang.String | getString() Returns the plain string representation.
int | length() Returns the number of characters in this string.
int | numFormattingRuns()
protected static void | preserveSpaces(org.openxmlformats.schemas.spreadsheetml.x2006.main.STXstring xs) Add the xml:spaces="preserve" attribute if the string has leading or trailing spaces
void | setString(java.lang.String s) Removes any formatting and sets new string value
protected void | setStylesTableReference(StylesTable tbl)
protected static org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont | toCTFont(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRPrElt pr) CTRPrElt --> CTFont adapter
java.lang.String | toString() Returns the plain string representation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSSFRichTextString

public XSSFRichTextString(java.lang.String str)
Create a rich text string

XSSFRichTextString

public XSSFRichTextString()
Create empty rich text string and initialize it with empty string

XSSFRichTextString

public XSSFRichTextString(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst st)
Create a rich text string from the supplied XML bean

Method Detail

applyFont

public void applyFont(int startIndex,
                      int endIndex,
                      short fontIndex)
Applies a font to the specified characters of a string.

Specified by:
applyFont in interface RichTextString
Parameters:
startIndex - The start index to apply the font to (inclusive)
endIndex - The end index to apply the font to (exclusive)
fontIndex - The font to use.

applyFont

public void applyFont(int startIndex,
                      int endIndex,
                      Font font)
Applies a font to the specified characters of a string.

Specified by:
applyFont in interface RichTextString
Parameters:
startIndex - The start index to apply the font to (inclusive)
endIndex - The end index to apply to font to (exclusive)
font - The index of the font to use.

applyFont

public void applyFont(Font font)
Sets the font of the entire string.

Specified by:
applyFont in interface RichTextString
Parameters:
font - The font to use.

applyFont

public void applyFont(short fontIndex)
Applies the specified font to the entire string.

Specified by:
applyFont in interface RichTextString
Parameters:
fontIndex - the font to apply.

append

public void append(java.lang.String text,
                   XSSFFont font)
Append new text to this text run and apply the specify font to it

Parameters:
text - the text to append
font - the font to apply to the appended text or null if no formatting is required

append

public void append(java.lang.String text)
Append new text to this text run

Parameters:
text - the text to append

clearFormatting

public void clearFormatting()
Removes any formatting that may have been applied to the string.

Specified by:
clearFormatting in interface RichTextString

getIndexOfFormattingRun

public int getIndexOfFormattingRun(int index)
The index within the string to which the specified formatting run applies.

Specified by:
getIndexOfFormattingRun in interface RichTextString
Parameters:
index - the index of the formatting run
Returns:
the index within the string.

getLengthOfFormattingRun

public int getLengthOfFormattingRun(int index)
Returns the number of characters this format run covers.

Parameters:
index - the index of the formatting run
Returns:
the number of characters this format run covers

getString

public java.lang.String getString()
Returns the plain string representation.

Specified by:
getString in interface RichTextString

setString

public void setString(java.lang.String s)
Removes any formatting and sets new string value

Parameters:
s - new string value

toString

public java.lang.String toString()
Returns the plain string representation.

Overrides:
toString in class java.lang.Object

length

public int length()
Returns the number of characters in this string.

Specified by:
length in interface RichTextString
Returns:
the number of characters in the font.

numFormattingRuns

public int numFormattingRuns()
Specified by:
numFormattingRuns in interface RichTextString
Returns:
The number of formatting runs used.

getFontOfFormattingRun

public XSSFFont getFontOfFormattingRun(int index)
Gets a copy of the font used in a particular formatting run.

Parameters:
index - the index of the formatting run
Returns:
A copy of the font used or null if no formatting is applied to the specified text run.

getFontAtIndex

public XSSFFont getFontAtIndex(int index)
Return a copy of the font in use at a particular index.

Parameters:
index - The index.
Returns:
A copy of the font that's currently being applied at that index or null if no font is being applied or the index is out of range.

getCTRst

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRst getCTRst()
Return the underlying xml bean

setStylesTableReference

protected void setStylesTableReference(StylesTable tbl)

toCTFont

protected static org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont toCTFont(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRPrElt pr)
CTRPrElt --> CTFont adapter

preserveSpaces

protected static void preserveSpaces(org.openxmlformats.schemas.spreadsheetml.x2006.main.STXstring xs)
Add the xml:spaces="preserve" attribute if the string has leading or trailing spaces

Parameters:
xs - the string to check
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFRow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFRow

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFRow
All Implemented Interfaces:
java.lang.Comparable<XSSFRow>, java.lang.Iterable<Cell>, Row
public class XSSFRow
extends java.lang.Object
implements Row, java.lang.Comparable<XSSFRow>

High level representation of a row of a spreadsheet.

Nested Class Summary
Nested classes/interfaces inherited from interface org.apache.poi.ss.usermodel.Row
Row.MissingCellPolicy
Field Summary
Fields inherited from interface org.apache.poi.ss.usermodel.Row
CREATE_NULL_AS_BLANK, RETURN_BLANK_AS_NULL, RETURN_NULL_AND_BLANK
Constructor Summary
protected XSSFRow(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRow row, XSSFSheet sheet)
Construct a XSSFRow.
Method Summary
 java.util.Iterator<Cell> cellIterator()
Cell iterator over the physically defined cells:
 int compareTo(XSSFRow row)
Compares two XSSFRow objects.
 XSSFCell createCell(int columnIndex)
Use this to create new cells within the row and return it.
 XSSFCell createCell(int columnIndex, int type)
Use this to create new cells within the row and return it.
 XSSFCell getCell(int cellnum)
Returns the cell at the given (0 based) index, with the Row.MissingCellPolicy from the parent Workbook.
 XSSFCell getCell(int cellnum, Row.MissingCellPolicy policy)
Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy
 org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRow getCTRow()
Returns the underlying CTRow xml bean containing all cell definitions in this row
 short getFirstCellNum()
Get the number of the first cell contained in this row.
 short getHeight()
Get the row's height measured in twips (1/20th of a point).
 float getHeightInPoints()
Returns row height measured in point size.
 short getLastCellNum()
Gets the index of the last cell contained in this row PLUS ONE.
 int getPhysicalNumberOfCells()
Gets the number of defined cells (NOT number of cells in the actual row!).
 int getRowNum()
Get row number this row represents
 XSSFCellStyle getRowStyle()
Returns the whole-row cell style.
 XSSFSheet getSheet()
Returns the XSSFSheet this row belongs to
 boolean getZeroHeight()
Get whether or not to display this row with 0 height
 boolean isFormatted()
Is this row formatted? Most aren't, but some rows do have whole-row styles.
 java.util.Iterator<Cell> iterator()
Alias for cellIterator() to allow foreach loops:
protected  void onDocumentWrite()
Fired when the document is written to an output stream.
 void removeCell(Cell cell)
Remove the Cell from this row.
 void setHeight(short height)
Set the height in "twips" or 1/20th of a point.
 void setHeightInPoints(float height)
Set the row's height in points.
 void setRowNum(int rowIndex)
Set the row number of this row.
 void setRowStyle(CellStyle style)
Applies a whole-row cell styling to the row.
 void setZeroHeight(boolean height)
Set whether or not to display this row with 0 height
protected  void shift(int n)
update cell references when shifting rows
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSSFRow

protected XSSFRow(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRow row,
                  XSSFSheet sheet)
Construct a XSSFRow.

Parameters:
row - the xml bean containing all cell definitions for this row.
sheet - the parent sheet.
Method Detail

getSheet

public XSSFSheet getSheet()
Returns the XSSFSheet this row belongs to

Specified by:
getSheet in interface Row
Returns:
the XSSFSheet that owns this row

cellIterator

public java.util.Iterator<Cell> cellIterator()
Cell iterator over the physically defined cells:
 for (Iterator it = row.cellIterator(); it.hasNext(); ) {
     Cell cell = it.next();
     ...
 }

Specified by:
cellIterator in interface Row
Returns:
an iterator over cells in this row.

iterator

public java.util.Iterator<Cell> iterator()
Alias for cellIterator() to allow foreach loops:
 for(Cell cell : row){
     ...
 }

Specified by:
iterator in interface java.lang.Iterable<Cell>
Returns:
an iterator over cells in this row.

compareTo

public int compareTo(XSSFRow row)
Compares two XSSFRow objects. Two rows are equal if they belong to the same worksheet and their row indexes are equal.

Specified by:
compareTo in interface java.lang.Comparable<XSSFRow>
Parameters:
row - the XSSFRow to be compared.
Returns:
the value 0 if the row number of this XSSFRow is equal to the row number of the argument XSSFRow; a value less than 0 if the row number of this this XSSFRow is numerically less than the row number of the argument XSSFRow; and a value greater than 0 if the row number of this this XSSFRow is numerically greater than the row number of the argument XSSFRow.
Throws:
java.lang.IllegalArgumentException - if the argument row belongs to a different worksheet

createCell

public XSSFCell createCell(int columnIndex)
Use this to create new cells within the row and return it.

The cell that is returned is a Cell.CELL_TYPE_BLANK. The type can be changed either through calling setCellValue or setCellType.

Specified by:
createCell in interface Row
Parameters:
columnIndex - - the column number this cell represents
Returns:
Cell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if columnIndex < 0 or greater than 16384, the maximum number of columns supported by the SpreadsheetML format (.xlsx)

createCell

public XSSFCell createCell(int columnIndex,
                           int type)
Use this to create new cells within the row and return it.

Specified by:
createCell in interface Row
Parameters:
columnIndex - - the column number this cell represents
type - - the cell's data type
Returns:
XSSFCell a high level representation of the created cell.
Throws:
java.lang.IllegalArgumentException - if the specified cell type is invalid, columnIndex < 0 or greater than 16384, the maximum number of columns supported by the SpreadsheetML format (.xlsx)
See Also:
Cell.CELL_TYPE_BLANK, Cell.CELL_TYPE_BOOLEAN, Cell.CELL_TYPE_ERROR, Cell.CELL_TYPE_FORMULA, Cell.CELL_TYPE_NUMERIC, Cell.CELL_TYPE_STRING

getCell

public XSSFCell getCell(int cellnum)
Returns the cell at the given (0 based) index, with the Row.MissingCellPolicy from the parent Workbook.

Specified by:
getCell in interface Row
Parameters:
cellnum - 0 based column number
Returns:
the cell at the given (0 based) index
See Also:
Row.getCell(int, org.apache.poi.ss.usermodel.Row.MissingCellPolicy)

getCell

public XSSFCell getCell(int cellnum,
                        Row.MissingCellPolicy policy)
Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy

Specified by:
getCell in interface Row
Returns:
the cell at the given (0 based) index
Throws:
java.lang.IllegalArgumentException - if cellnum < 0 or the specified MissingCellPolicy is invalid
See Also:
Row.RETURN_NULL_AND_BLANK, Row.RETURN_BLANK_AS_NULL, Row.CREATE_NULL_AS_BLANK

getFirstCellNum

public short getFirstCellNum()
Get the number of the first cell contained in this row.

Specified by:
getFirstCellNum in interface Row
Returns:
short representing the first logical cell in the row, or -1 if the row does not contain any cells.

getLastCellNum

public short getLastCellNum()
Gets the index of the last cell contained in this row PLUS ONE. The result also happens to be the 1-based column number of the last cell. This value can be used as a standard upper bound when iterating over cells:
 short minColIx = row.getFirstCellNum();
 short maxColIx = row.getLastCellNum();
 for(short colIx=minColIx; colIx<maxColIx; colIx++) {
   XSSFCell cell = row.getCell(colIx);
   if(cell == null) {
     continue;
   }
   //... do something with cell
 }

Specified by:
getLastCellNum in interface Row
Returns:
short representing the last logical cell in the row PLUS ONE, or -1 if the row does not contain any cells.

getHeight

public short getHeight()
Get the row's height measured in twips (1/20th of a point). If the height is not set, the default worksheet value is returned, See XSSFSheet.getDefaultRowHeightInPoints()

Specified by:
getHeight in interface Row
Returns:
row height measured in twips (1/20th of a point)

getHeightInPoints

public float getHeightInPoints()
Returns row height measured in point size. If the height is not set, the default worksheet value is returned, See XSSFSheet.getDefaultRowHeightInPoints()

Specified by:
getHeightInPoints in interface Row
Returns:
row height measured in point size
See Also:
XSSFSheet.getDefaultRowHeightInPoints()

setHeight

public void setHeight(short height)
Set the height in "twips" or 1/20th of a point.

Specified by:
setHeight in interface Row
Parameters:
height - the height in "twips" or 1/20th of a point. -1 resets to the default height

setHeightInPoints

public void setHeightInPoints(float height)
Set the row's height in points.

Specified by:
setHeightInPoints in interface Row
Parameters:
height - the height in points. -1 resets to the default height

getPhysicalNumberOfCells

public int getPhysicalNumberOfCells()
Gets the number of defined cells (NOT number of cells in the actual row!). That is to say if only columns 0,4,5 have values then there would be 3.

Specified by:
getPhysicalNumberOfCells in interface Row
Returns:
int representing the number of defined cells in the row.

getRowNum

public int getRowNum()
Get row number this row represents

Specified by:
getRowNum in interface Row
Returns:
the row number (0 based)

setRowNum

public void setRowNum(int rowIndex)
Set the row number of this row.

Specified by:
setRowNum in interface Row
Parameters:
rowIndex - the row number (0-based)
Throws:
java.lang.IllegalArgumentException - if rowNum < 0 or greater than 1048575

getZeroHeight

public boolean getZeroHeight()
Get whether or not to display this row with 0 height

Specified by:
getZeroHeight in interface Row
Returns:
- height is zero or not.

setZeroHeight

public void setZeroHeight(boolean height)
Set whether or not to display this row with 0 height

Specified by:
setZeroHeight in interface Row
Parameters:
height - height is zero or not.

isFormatted

public boolean isFormatted()
Is this row formatted? Most aren't, but some rows do have whole-row styles. For those that do, you can get the formatting from getRowStyle()

Specified by:
isFormatted in interface Row

getRowStyle

public XSSFCellStyle getRowStyle()
Returns the whole-row cell style. Most rows won't have one of these, so will return null. Call isFormatted() to check first.

Specified by:
getRowStyle in interface Row

setRowStyle

public void setRowStyle(CellStyle style)
Applies a whole-row cell styling to the row. If the value is null then the style information is removed, causing the cell to used the default workbook style.

Specified by:
setRowStyle in interface Row

removeCell

public void removeCell(Cell cell)
Remove the Cell from this row.

Specified by:
removeCell in interface Row
Parameters:
cell - the cell to remove

getCTRow

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRow getCTRow()
Returns the underlying CTRow xml bean containing all cell definitions in this row

Returns:
the underlying CTRow xml bean

onDocumentWrite

protected void onDocumentWrite()
Fired when the document is written to an output stream.

See Also:
()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Returns:
formatted xml representation of this row

shift

protected void shift(int n)
update cell references when shifting rows

Parameters:
n - the number of rows to move
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFShape

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFShape
Direct Known Subclasses:
XSSFConnector, XSSFGraphicFrame, XSSFPicture, XSSFShapeGroup, XSSFSimpleShape
public abstract class XSSFShape
extends java.lang.Object

Represents a shape in a SpreadsheetML drawing.

Author:
Yegor Kozlov

Field Summary
protected XSSFAnchor | anchor anchor that is used by this shape
protected XSSFDrawing | drawing Parent drawing
static int | EMU_PER_PIXEL
static int | EMU_PER_POINT
protected XSSFShapeGroup | parent The parent shape, always not-null for shapes in groups
static int | PIXEL_DPI
static int | POINT_DPI
Constructor Summary
XSSFShape()
Method Summary
XSSFAnchor | getAnchor()
XSSFDrawing | getDrawing() Return the drawing that owns this shape
XSSFShapeGroup | getParent() Gets the parent shape.
protected abstract org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties | getShapeProperties() Returns xml bean with shape properties.
boolean | isNoFill() Whether this shape is not filled with a color
void | setFillColor(int red, int green, int blue) Sets the color used to fill this shape using the solid fill pattern.
void | setLineStyle(int lineStyle) Sets the line style.
void | setLineStyleColor(int red, int green, int blue) The color applied to the lines of this shape.
void | setLineWidth(double lineWidth) Specifies the width to be used for the underline stroke.
void | setNoFill(boolean noFill) Sets whether this shape is filled or transparent.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EMU_PER_PIXEL

public static final int EMU_PER_PIXEL
See Also:
Constant Field Values

EMU_PER_POINT

public static final int EMU_PER_POINT
See Also:
Constant Field Values

POINT_DPI

public static final int POINT_DPI
See Also:
Constant Field Values

PIXEL_DPI

public static final int PIXEL_DPI
See Also:
Constant Field Values

drawing

protected XSSFDrawing drawing
Parent drawing

parent

protected XSSFShapeGroup parent
The parent shape, always not-null for shapes in groups

anchor

protected XSSFAnchor anchor
anchor that is used by this shape

Constructor Detail

XSSFShape

public XSSFShape()
Method Detail

getDrawing

public XSSFDrawing getDrawing()
Return the drawing that owns this shape

Returns:
the parent drawing that owns this shape

getParent

public XSSFShapeGroup getParent()
Gets the parent shape.

getAnchor

public XSSFAnchor getAnchor()
Returns:
the anchor that is used by this shape.

getShapeProperties

protected abstract org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties getShapeProperties()
Returns xml bean with shape properties.

Returns:
xml bean with shape properties.

isNoFill

public boolean isNoFill()
Whether this shape is not filled with a color

Returns:
true if this shape is not filled with a color.

setNoFill

public void setNoFill(boolean noFill)
Sets whether this shape is filled or transparent.

Parameters:
noFill - if true then no fill will be applied to the shape element.

setFillColor

public void setFillColor(int red,
                         int green,
                         int blue)
Sets the color used to fill this shape using the solid fill pattern.

setLineStyleColor

public void setLineStyleColor(int red,
                              int green,
                              int blue)
The color applied to the lines of this shape.

setLineWidth

public void setLineWidth(double lineWidth)
Specifies the width to be used for the underline stroke.

Parameters:
lineWidth - width in points

setLineStyle

public void setLineStyle(int lineStyle)
Sets the line style.

Parameters:
lineStyle -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFShapeGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFShapeGroup

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFShape
        extended by  org.apache.poi.xssf.usermodel.XSSFShapeGroup

public final class XSSFShapeGroup
extends XSSFShape

This object specifies a group shape that represents many shapes grouped together. This shape is to be treated just as if it were a regular shape but instead of being described by a single geometry it is made up of all the shape geometries encompassed within it. Within a group shape each of the shapes that make up the group are specified just as they normally would.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFShape
anchor, drawing, EMU_PER_PIXEL, EMU_PER_POINT, parent, PIXEL_DPI, POINT_DPI
Constructor Summary
protected XSSFShapeGroup(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape ctGroup)
Construct a new XSSFSimpleShape object.
Method Summary
XSSFConnector | createConnector(XSSFChildAnchor anchor) Creates a simple shape.
XSSFPicture | createPicture(XSSFClientAnchor anchor, int pictureIndex) Creates a picture.
XSSFSimpleShape | createSimpleShape(XSSFChildAnchor anchor) Creates a simple shape.
XSSFTextBox | createTextbox(XSSFChildAnchor anchor) Constructs a textbox.
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape | getCTGroupShape()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties | getShapeProperties() Returns xml bean with shape properties.
protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape | prototype() Initialize default structure of a new shape group
void | setCoordinates(int x1, int y1, int x2, int y2) Sets the coordinate space of this group.
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFShape
getAnchor, getDrawing, getParent, isNoFill, setFillColor, setLineStyle, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFShapeGroup

protected XSSFShapeGroup(XSSFDrawing drawing,
                         org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape ctGroup)
Construct a new XSSFSimpleShape object.

Parameters:
drawing - the XSSFDrawing that owns this shape
ctGroup - the XML bean that stores this group content
Method Detail

prototype

protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape prototype()
Initialize default structure of a new shape group

createTextbox

public XSSFTextBox createTextbox(XSSFChildAnchor anchor)
Constructs a textbox.

Parameters:
anchor - the child anchor describes how this shape is attached to the group.
Returns:
the newly created textbox.

createSimpleShape

public XSSFSimpleShape createSimpleShape(XSSFChildAnchor anchor)
Creates a simple shape. This includes such shapes as lines, rectangles, and ovals.

Parameters:
anchor - the child anchor describes how this shape is attached to the group.
Returns:
the newly created shape.

createConnector

public XSSFConnector createConnector(XSSFChildAnchor anchor)
Creates a simple shape. This includes such shapes as lines, rectangles, and ovals.

Parameters:
anchor - the child anchor describes how this shape is attached to the group.
Returns:
the newly created shape.

createPicture

public XSSFPicture createPicture(XSSFClientAnchor anchor,
                                 int pictureIndex)
Creates a picture.

Parameters:
anchor - the client anchor describes how this picture is attached to the sheet.
pictureIndex - the index of the picture in the workbook collection of pictures, XSSFWorkbook.getAllPictures() .
Returns:
the newly created picture shape.

getCTGroupShape

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape getCTGroupShape()

setCoordinates

public void setCoordinates(int x1,
                           int y1,
                           int x2,
                           int y2)
Sets the coordinate space of this group. All children are constrained to these coordinates.

getShapeProperties

protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties getShapeProperties()
Description copied from class: XSSFShape
Returns xml bean with shape properties.

Specified by:
getShapeProperties in class XSSFShape
Returns:
xml bean with shape properties.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFSheet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFSheet

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFSheet
All Implemented Interfaces:
java.lang.Iterable<Row>, Sheet
Direct Known Subclasses:
XSSFChartSheet, XSSFDialogsheet
public class XSSFSheet
extends POIXMLDocumentPart
implements Sheet

High level representation of a SpreadsheetML worksheet.

Sheets are the central structures within a workbook, and are where a user does most of his spreadsheet work. The most common type of sheet is the worksheet, which is represented as a grid of cells. Worksheet cells can contain text, numbers, dates, and formulas. Cells can also be formatted.

Field Summary
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheet | sheet
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet | worksheet
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Fields inherited from interface org.apache.poi.ss.usermodel.Sheet
BottomMargin, FooterMargin, HeaderMargin, LeftMargin, PANE_LOWER_LEFT, PANE_LOWER_RIGHT, PANE_UPPER_LEFT, PANE_UPPER_RIGHT, RightMargin, TopMargin
Constructor Summary
protected | XSSFSheet() Creates new XSSFSheet - called by XSSFWorkbook to create a sheet from scratch.
protected | XSSFSheet(PackagePart part, PackageRelationship rel) Creates an XSSFSheet representing the given package part and relationship.
Method Summary
 void addHyperlink(XSSFHyperlink hyperlink)
Register a hyperlink in the collection of hyperlinks on this sheet
 int addMergedRegion(CellRangeAddress region)
Adds a merged region of cells (hence those cells form one).
 void addValidationData(DataValidation dataValidation)
Creates a data validation object
 void autoSizeColumn(int column)
Adjusts the column width to fit the contents.
 void autoSizeColumn(int column, boolean useMergedCells)
Adjusts the column width to fit the contents.
protected  void commit()
Save the content in the underlying package part.
 XSSFComment createComment()
Deprecated. since Nov 2009 this method is not compatible with the common SS interfaces, use (org.apache.poi.ss.usermodel.ClientAnchor) instead
 XSSFDrawing createDrawingPatriarch()
Create a new SpreadsheetML drawing.
 void createFreezePane(int colSplit, int rowSplit)
Creates a split (freezepane).
 void createFreezePane(int colSplit, int rowSplit, int leftmostColumn, int topRow)
Creates a split (freezepane).
 XSSFRow createRow(int rownum)
Create a new row within the sheet and return the high level representation
 void createSplitPane(int xSplitPos, int ySplitPos, int leftmostColumn, int topRow, int activePane)
Creates a split pane.
 XSSFTable createTable()
Creates a new Table, and associates it with this Sheet
 void disableLocking()
Disable sheet protection
 void enableLocking()
Enable sheet protection
 int findEndOfRowOutlineGroup(int row)
 java.lang.String getActiveCell()
Return location of the active cell, e.g.
 boolean getAutobreaks()
Flag indicating whether the sheet displays Automatic Page Breaks.
 XSSFComment getCellComment(int row, int column)
Returns cell comment for the specified row and column
 int[] getColumnBreaks()
Vertical page break information used for print layout view, page layout view, drawing print breaks in normal view, and for printing the worksheet.
 ColumnHelper getColumnHelper()
 CellStyle getColumnStyle(int column)
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column
 int getColumnWidth(int columnIndex)
Get the actual column width (in units of 1/256th of a character width )
protected  CommentsTable getCommentsTable(boolean create)
Returns the sheet's comments object if there is one, or null if not
protected  org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDrawing getCTDrawing()
protected  org.openxmlformats.schemas.spreadsheetml.x2006.main.CTLegacyDrawing getCTLegacyDrawing()
 org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet getCTWorksheet()
Provide access to the CTWorksheet bean holding this sheet's data
 DataValidationHelper getDataValidationHelper()
 java.util.List<XSSFDataValidation> getDataValidations()
 int getDefaultColumnWidth()
Get the default column width for the sheet (if the columns do not define their own width) in characters.
 short getDefaultRowHeight()
Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
 float getDefaultRowHeightInPoints()
Get the default row height for the sheet measued in point size (if the rows do not define their own height).
 boolean getDisplayGuts()
Get whether to display the guts or not, default value is true
 Footer getEvenFooter()
Returns the even footer.
 Header getEvenHeader()
Returns the even header.
 Footer getFirstFooter()
Returns the first page footer.
 Header getFirstHeader()
Returns the first page header.
 int getFirstRowNum()
Gets the first row on the sheet
 boolean getFitToPage()
Flag indicating whether the Fit to Page print option is enabled.
 Footer getFooter()
Returns the default footer for the sheet, creating one as needed.
 boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.
 Header getHeader()
Returns the default header for the sheet, creating one as needed.
 boolean getHorizontallyCenter()
Determine whether printed output for this sheet will be horizontally centered.
 XSSFHyperlink getHyperlink(int row, int column)
 int getLastRowNum()
Gets the last row on the sheet
 short getLeftCol()
The left col in the visible view when the sheet is first viewed after opening it in a viewer
 double getMargin(short margin)
Gets the size of the margin in inches.
 CellRangeAddress getMergedRegion(int index)
Returns the merged region at the specified index
protected  int getNumberOfComments()
 int getNumHyperlinks()
 int getNumMergedRegions()
Returns the number of merged regions defined in this worksheet
 Footer getOddFooter()
Returns the odd footer.
 Header getOddHeader()
Returns the odd header.
 PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).
 int getPhysicalNumberOfRows()
Returns the number of phsyically defined rows (NOT the number of rows in the sheet)
 XSSFPrintSetup getPrintSetup()
Gets the print setup object.
 boolean getProtect()
Answer whether protection is enabled or disabled
 XSSFRow getRow(int rownum)
Returns the logical row ( 0-based).
 int[] getRowBreaks()
Horizontal page break information used for print layout view, page layout view, drawing print breaks in normal view, and for printing the worksheet.
 boolean getRowSumsBelow()
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
 boolean getRowSumsRight()
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
 boolean getScenarioProtect()
A flag indicating whether scenarios are locked when the sheet is protected.
 XSSFSheetConditionalFormatting getSheetConditionalFormatting()
The 'Conditional Formatting' facet for this Sheet
 java.lang.String getSheetName()
Returns the name of this sheet
 java.util.List<XSSFTable> getTables()
Returns any tables associated with this Sheet
 short getTopRow()
The top row in the visible view when the sheet is first viewed after opening it in a viewer
 boolean getVerticallyCenter()
Determine whether printed output for this sheet will be vertically centered.
protected  XSSFVMLDrawing getVMLDrawing(boolean autoCreate)
Get VML drawing for this sheet (aka 'legacy' drawig)
 XSSFWorkbook getWorkbook()
Returns the parent XSSFWorkbook
 void groupColumn(int fromColumn, int toColumn)
Group between (0 based) columns
 void groupRow(int fromRow, int toRow)
Tie a range of cell together so that they can be collapsed or expanded
 boolean hasComments()
Does this sheet have any comments on it? We need to know, so we can decide about writing it to disk or not
 boolean isAutoFilterLocked()
 boolean isColumnBroken(int column)
Determines if there is a page break at the indicated column
 boolean isColumnHidden(int columnIndex)
Get the hidden state for a given column.
 boolean isDeleteColumnsLocked()
 boolean isDeleteRowsLocked()
 boolean isDisplayFormulas()
Gets the flag indicating whether this sheet should display formulas.
 boolean isDisplayGridlines()
Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.
 boolean isDisplayRowColHeadings()
Gets the flag indicating whether this sheet should display row and column headings.
 boolean isDisplayZeros()
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value.
 boolean isFormatCellsLocked()
 boolean isFormatColumnsLocked()
 boolean isFormatRowsLocked()
 boolean isInsertColumnsLocked()
 boolean isInsertHyperlinksLocked()
 boolean isInsertRowsLocked()
 boolean isObjectsLocked()
 boolean isPivotTablesLocked()
 boolean isPrintGridlines()
Returns whether gridlines are printed.
 boolean isRightToLeft()
Whether the text is displayed in right-to-left mode in the window
 boolean isRowBroken(int row)
Tests if there is a page break at the indicated row
 boolean isScenariosLocked()
 boolean isSelected()
Returns a flag indicating whether this sheet is selected.
 boolean isSelectLockedCellsLocked()
 boolean isSelectUnlockedCellsLocked()
 boolean isSheetLocked()
 boolean isSortLocked()
 java.util.Iterator<Row> iterator()
Alias for rowIterator() to allow foreach loops
 void lockAutoFilter()
Enable Autofilters locking.
 void lockDeleteColumns()
Enable Deleting columns locking.
 void lockDeleteRows()
Enable Deleting rows locking.
 void lockFormatCells()
Enable Formatting cells locking.
 void lockFormatColumns()
Enable Formatting columns locking.
 void lockFormatRows()
Enable Formatting rows locking.
 void lockInsertColumns()
Enable Inserting columns locking.
 void lockInsertHyperlinks()
Enable Inserting hyperlinks locking.
 void lockInsertRows()
Enable Inserting rows locking.
 void lockObjects()
Enable Objects locking.
 void lockPivotTables()
Enable Pivot Tables locking.
 void lockScenarios()
Enable Scenarios locking.
 void lockSelectLockedCells()
Enable Selection of locked cells locking.
 void lockSelectUnlockedCells()
Enable Selection of unlocked cells locking.
 void lockSort()
Enable Sort locking.
protected  void onDocumentCreate()
Initialize worksheet data when creating a new sheet.
protected  void onDocumentRead()
Initialize worksheet data when reading in an exisiting file.
 void protectSheet(java.lang.String password)
Enables sheet protection and sets the password for the sheet.
protected  void read(java.io.InputStream is)
 CellRange<XSSFCell> removeArrayFormula(Cell cell)
Remove a Array Formula from this sheet.
 void removeColumnBreak(int column)
Removes a page break at the indicated column
 void removeMergedRegion(int index)
Removes a merged region of cells (hence letting them free)
 void removeRow(Row row)
Remove a row from this sheet.
 void removeRowBreak(int row)
Removes the page break at the indicated row
 java.util.Iterator<Row> rowIterator()
Returns an iterator of the physical rows
 void setActiveCell(java.lang.String cellRef)
Sets location of the active cell
 CellRange<XSSFCell> setArrayFormula(java.lang.String formula, CellRangeAddress range)
Sets array formula to specified region for result.
 void setAutobreaks(boolean value)
Flag indicating whether the sheet displays Automatic Page Breaks.
 XSSFAutoFilter setAutoFilter(CellRangeAddress range)
Enable filtering for a range of cells
static void setCellComment(java.lang.String cellRef, XSSFComment comment)
Deprecated. since Nov 2009 use XSSFCell.setCellComment(org.apache.poi.ss.usermodel.Comment) instead
 void setColumnBreak(int column)
Sets a page break at the indicated column.
 void setColumnGroupCollapsed(int columnNumber, boolean collapsed)
Expands or collapses a column group.
 void setColumnHidden(int columnIndex, boolean hidden)
Get the visibility state for a given column.
 void setColumnWidth(int columnIndex, int width)
Set the width (in units of 1/256th of a character width)
 void setDefaultColumnStyle(int column, CellStyle style)
Sets the default column style for a given column.
 void setDefaultColumnWidth(int width)
Specifies the number of characters of the maximum digit width of the normal style's font.
 void setDefaultRowHeight(short height)
Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)
 void setDefaultRowHeightInPoints(float height)
Sets default row height measured in point size.
 void setDisplayFormulas(boolean show)
Sets the flag indicating whether this sheet should display formulas.
 void setDisplayGridlines(boolean show)
Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier.
 void setDisplayGuts(boolean value)
Set whether to display the guts or not
 void setDisplayRowColHeadings(boolean show)
Sets the flag indicating whether this sheet should display row and column headings.
 void setDisplayZeros(boolean value)
Set whether the window should show 0 (zero) in cells containing zero value.
 void setFitToPage(boolean b)
Flag indicating whether the Fit to Page print option is enabled.
 void setForceFormulaRecalculation(boolean value)
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.
 void setHorizontallyCenter(boolean value)
Center on page horizontally when printing.
 void setMargin(short margin, double size)
Sets the size of the margin in inches.
 void setPrintGridlines(boolean value)
Turns on or off the printing of gridlines.
 void setRightToLeft(boolean value)
Sets whether the worksheet is displayed from right to left instead of from left to right.
 void setRowBreak(int row)
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive.
 void setRowGroupCollapsed(int rowIndex, boolean collapse)
group the row It is possible for collapsed to be false and yet still have the rows in question hidden.
 void setRowSumsBelow(boolean value)
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.
 void setRowSumsRight(boolean value)
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.
 void setSelected(boolean value)
Sets a flag indicating whether this sheet is selected.
 void setTabColor(int colorIndex)
Set background color of the sheet tab
 void setVerticallyCenter(boolean value)
Whether the output is vertically centered on the page.
 void setZoom(int scale)
Window zoom magnification for current view representing percent values.
 void setZoom(int numerator, int denominator)
Sets the zoom magnication for the sheet.
 void shiftRows(int startRow, int endRow, int n)
Shifts rows between startRow and endRow n number of rows.
 void shiftRows(int startRow, int endRow, int n, boolean copyRowHeight, boolean resetOriginalRowHeight)
Shifts rows between startRow and endRow n number of rows.
 void showInPane(short toprow, short leftcol)
Location of the top left visible cell Location of the top left visible cell in the bottom right pane (when in Left-to-Right mode).
 void ungroupColumn(int fromColumn, int toColumn)
Ungroup a range of columns that were previously groupped
 void ungroupRow(int fromRow, int toRow)
Ungroup a range of rows that were previously groupped
protected  void write(java.io.OutputStream out)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

sheet

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheet sheet

worksheet

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet worksheet
Constructor Detail

XSSFSheet

protected XSSFSheet()
Creates new XSSFSheet - called by XSSFWorkbook to create a sheet from scratch.

See Also:
XSSFWorkbook.createSheet()

XSSFSheet

protected XSSFSheet(PackagePart part,
                    PackageRelationship rel)
Creates an XSSFSheet representing the given package part and relationship. Should only be called by XSSFWorkbook when reading in an exisiting file.

Parameters:
part - - The package part that holds xml data represenring this sheet.
rel - - the relationship of the given package part in the underlying OPC package
Method Detail

getWorkbook

public XSSFWorkbook getWorkbook()
Returns the parent XSSFWorkbook

Specified by:
getWorkbook in interface Sheet
Returns:
the parent XSSFWorkbook

onDocumentRead

protected void onDocumentRead()
Initialize worksheet data when reading in an exisiting file.

Overrides:
onDocumentRead in class POIXMLDocumentPart

read

protected void read(java.io.InputStream is)
             throws java.io.IOException
Throws:
java.io.IOException

onDocumentCreate

protected void onDocumentCreate()
Initialize worksheet data when creating a new sheet.

Overrides:
onDocumentCreate in class POIXMLDocumentPart

getCTWorksheet

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet getCTWorksheet()
Provide access to the CTWorksheet bean holding this sheet's data

Returns:
the CTWorksheet bean holding this sheet's data

getColumnHelper

public ColumnHelper getColumnHelper()

getSheetName

public java.lang.String getSheetName()
Returns the name of this sheet

Specified by:
getSheetName in interface Sheet
Returns:
the name of this sheet

addMergedRegion

public int addMergedRegion(CellRangeAddress region)
Adds a merged region of cells (hence those cells form one).

Specified by:
addMergedRegion in interface Sheet
Parameters:
region - (rowfrom/colfrom-rowto/colto) to merge
Returns:
index of this region

autoSizeColumn

public void autoSizeColumn(int column)
Adjusts the column width to fit the contents. This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing.

Specified by:
autoSizeColumn in interface Sheet
Parameters:
column - the column index

autoSizeColumn

public void autoSizeColumn(int column,
                           boolean useMergedCells)
Adjusts the column width to fit the contents.

This process can be relatively slow on large sheets, so this should normally only be called once per column, at the end of your processing.

You can specify whether the content of merged cells should be considered or ignored. Default is to ignore merged cells.

Specified by:
autoSizeColumn in interface Sheet
Parameters:
column - the column index
useMergedCells - whether to use the contents of merged cells when calculating the width of the column

createDrawingPatriarch

public XSSFDrawing createDrawingPatriarch()
Create a new SpreadsheetML drawing. If this sheet already contains a drawing - return that.

Specified by:
createDrawingPatriarch in interface Sheet
Returns:
a SpreadsheetML drawing

getVMLDrawing

protected XSSFVMLDrawing getVMLDrawing(boolean autoCreate)
Get VML drawing for this sheet (aka 'legacy' drawig)

Parameters:
autoCreate - if true, then a new VML drawing part is created
Returns:
the VML drawing of null if the drawing was not found and autoCreate=false

getCTDrawing

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDrawing getCTDrawing()

getCTLegacyDrawing

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTLegacyDrawing getCTLegacyDrawing()

createFreezePane

public void createFreezePane(int colSplit,
                             int rowSplit)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

Specified by:
createFreezePane in interface Sheet
Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.

createFreezePane

public void createFreezePane(int colSplit,
                             int rowSplit,
                             int leftmostColumn,
                             int topRow)
Creates a split (freezepane). Any existing freezepane or split pane is overwritten.

If both colSplit and rowSplit are zero then the existing freeze pane is removed

Specified by:
createFreezePane in interface Sheet
Parameters:
colSplit - Horizonatal position of split.
rowSplit - Vertical position of split.
leftmostColumn - Left column visible in right pane.
topRow - Top row visible in bottom pane

createComment

@Deprecated
public XSSFComment createComment()
Deprecated. since Nov 2009 this method is not compatible with the common SS interfaces, use (org.apache.poi.ss.usermodel.ClientAnchor) instead

Creates a new comment for this sheet. You still need to assign it to a cell though

createRow

public XSSFRow createRow(int rownum)
Create a new row within the sheet and return the high level representation

Specified by:
createRow in interface Sheet
Parameters:
rownum - row number
Returns:
High level XSSFRow object representing a row in the sheet
See Also:
removeRow(org.apache.poi.ss.usermodel.Row)

createSplitPane

public void createSplitPane(int xSplitPos,
                            int ySplitPos,
                            int leftmostColumn,
                            int topRow,
                            int activePane)
Creates a split pane. Any existing freezepane or split pane is overwritten.

Specified by:
createSplitPane in interface Sheet
Parameters:
xSplitPos - Horizonatal position of split (in 1/20th of a point).
ySplitPos - Vertical position of split (in 1/20th of a point).
topRow - Top row visible in bottom pane
leftmostColumn - Left column visible in right pane.
activePane - Active pane. One of: PANE_LOWER_RIGHT, PANE_UPPER_RIGHT, PANE_LOWER_LEFT, PANE_UPPER_LEFT
See Also:
Sheet.PANE_LOWER_LEFT, Sheet.PANE_LOWER_RIGHT, Sheet.PANE_UPPER_LEFT, Sheet.PANE_UPPER_RIGHT

getCellComment

public XSSFComment getCellComment(int row,
                                  int column)
Description copied from interface: Sheet
Returns cell comment for the specified row and column

Specified by:
getCellComment in interface Sheet
Returns:
cell comment or null if not found

getHyperlink

public XSSFHyperlink getHyperlink(int row,
                                  int column)

getColumnBreaks

public int[] getColumnBreaks()
Vertical page break information used for print layout view, page layout view, drawing print breaks in normal view, and for printing the worksheet.

Specified by:
getColumnBreaks in interface Sheet
Returns:
column indexes of all the vertical page breaks, never null

getColumnWidth

public int getColumnWidth(int columnIndex)
Get the actual column width (in units of 1/256th of a character width )

Note, the returned value is always gerater that getDefaultColumnWidth() because the latter does not include margins. Actual column width measured as the number of characters of the maximum digit width of the numbers 0, 1, 2, ..., 9 as rendered in the normal style's font. There are 4 pixels of margin padding (two on each side), plus 1 pixel padding for the gridlines.

Specified by:
getColumnWidth in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
Returns:
width - the width in units of 1/256th of a character width

getDefaultColumnWidth

public int getDefaultColumnWidth()
Get the default column width for the sheet (if the columns do not define their own width) in characters.

Note, this value is different from getColumnWidth(int). The latter is always greater and includes 4 pixels of margin padding (two on each side), plus 1 pixel padding for the gridlines.

Specified by:
getDefaultColumnWidth in interface Sheet
Returns:
column width, default value is 8

getDefaultRowHeight

public short getDefaultRowHeight()
Get the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Specified by:
getDefaultRowHeight in interface Sheet
Returns:
default row height

getDefaultRowHeightInPoints

public float getDefaultRowHeightInPoints()
Get the default row height for the sheet measued in point size (if the rows do not define their own height).

Specified by:
getDefaultRowHeightInPoints in interface Sheet
Returns:
default row height in points

getColumnStyle

public CellStyle getColumnStyle(int column)
Returns the CellStyle that applies to the given (0 based) column, or null if no style has been set for that column

Specified by:
getColumnStyle in interface Sheet

setRightToLeft

public void setRightToLeft(boolean value)
Sets whether the worksheet is displayed from right to left instead of from left to right.

Specified by:
setRightToLeft in interface Sheet
Parameters:
value - true for right to left, false otherwise.

isRightToLeft

public boolean isRightToLeft()
Whether the text is displayed in right-to-left mode in the window

Specified by:
isRightToLeft in interface Sheet
Returns:
whether the text is displayed in right-to-left mode in the window

getDisplayGuts

public boolean getDisplayGuts()
Get whether to display the guts or not, default value is true

Specified by:
getDisplayGuts in interface Sheet
Returns:
boolean - guts or no guts

setDisplayGuts

public void setDisplayGuts(boolean value)
Set whether to display the guts or not

Specified by:
setDisplayGuts in interface Sheet
Parameters:
value - - guts or no guts

isDisplayZeros

public boolean isDisplayZeros()
Gets the flag indicating whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

Specified by:
isDisplayZeros in interface Sheet
Returns:
whether all zero values on the worksheet are displayed

setDisplayZeros

public void setDisplayZeros(boolean value)
Set whether the window should show 0 (zero) in cells containing zero value. When false, cells with zero value appear blank instead of showing the number zero.

Specified by:
setDisplayZeros in interface Sheet
Parameters:
value - whether to display or hide all zero values on the worksheet

getFirstRowNum

public int getFirstRowNum()
Gets the first row on the sheet

Specified by:
getFirstRowNum in interface Sheet
Returns:
the number of the first logical row on the sheet, zero based

getFitToPage

public boolean getFitToPage()
Flag indicating whether the Fit to Page print option is enabled.

Specified by:
getFitToPage in interface Sheet
Returns:
true

getFooter

public Footer getFooter()
Returns the default footer for the sheet, creating one as needed. You may also want to look at getFirstFooter(), getOddFooter() and getEvenFooter()

Specified by:
getFooter in interface Sheet
Returns:
the document footer. Never null

getHeader

public Header getHeader()
Returns the default header for the sheet, creating one as needed. You may also want to look at getFirstHeader(), getOddHeader() and getEvenHeader()

Specified by:
getHeader in interface Sheet
Returns:
the document header. Never null

getOddFooter

public Footer getOddFooter()
Returns the odd footer. Used on all pages unless other footers also present, when used on only odd pages.

getEvenFooter

public Footer getEvenFooter()
Returns the even footer. Not there by default, but when set, used on even pages.

getFirstFooter

public Footer getFirstFooter()
Returns the first page footer. Not there by default, but when set, used on the first page.

getOddHeader

public Header getOddHeader()
Returns the odd header. Used on all pages unless other headers also present, when used on only odd pages.

getEvenHeader

public Header getEvenHeader()
Returns the even header. Not there by default, but when set, used on even pages.

getFirstHeader

public Header getFirstHeader()
Returns the first page header. Not there by default, but when set, used on the first page.

getHorizontallyCenter

public boolean getHorizontallyCenter()
Determine whether printed output for this sheet will be horizontally centered.

Specified by:
getHorizontallyCenter in interface Sheet

getLastRowNum

public int getLastRowNum()
Description copied from interface: Sheet
Gets the last row on the sheet

Specified by:
getLastRowNum in interface Sheet
Returns:
last row contained n this sheet (0-based)

getLeftCol

public short getLeftCol()
Description copied from interface: Sheet
The left col in the visible view when the sheet is first viewed after opening it in a viewer

Specified by:
getLeftCol in interface Sheet
Returns:
short indicating the rownum (0 based) of the top row

getMargin

public double getMargin(short margin)
Gets the size of the margin in inches.

Specified by:
getMargin in interface Sheet
Parameters:
margin - which margin to get
Returns:
the size of the margin
See Also:
Sheet.LeftMargin, Sheet.RightMargin, Sheet.TopMargin, Sheet.BottomMargin, Sheet.HeaderMargin, Sheet.FooterMargin

setMargin

public void setMargin(short margin,
                      double size)
Sets the size of the margin in inches.

Specified by:
setMargin in interface Sheet
Parameters:
margin - which margin to get
size - the size of the margin
See Also:
Sheet.LeftMargin, Sheet.RightMargin, Sheet.TopMargin, Sheet.BottomMargin, Sheet.HeaderMargin, Sheet.FooterMargin

getMergedRegion

public CellRangeAddress getMergedRegion(int index)
Description copied from interface: Sheet
Returns the merged region at the specified index

Specified by:
getMergedRegion in interface Sheet
Returns:
the merged region at the specified index
Throws:
java.lang.IllegalStateException - if this worksheet does not contain merged regions

getNumMergedRegions

public int getNumMergedRegions()
Returns the number of merged regions defined in this worksheet

Specified by:
getNumMergedRegions in interface Sheet
Returns:
number of merged regions in this worksheet

getNumHyperlinks

public int getNumHyperlinks()

getPaneInformation

public PaneInformation getPaneInformation()
Returns the information regarding the currently configured pane (split or freeze).

Specified by:
getPaneInformation in interface Sheet
Returns:
null if no pane configured, or the pane information.

getPhysicalNumberOfRows

public int getPhysicalNumberOfRows()
Returns the number of phsyically defined rows (NOT the number of rows in the sheet)

Specified by:
getPhysicalNumberOfRows in interface Sheet
Returns:
the number of phsyically defined rows

getPrintSetup

public XSSFPrintSetup getPrintSetup()
Gets the print setup object.

Specified by:
getPrintSetup in interface Sheet
Returns:
The user model for the print setup object.

getProtect

public boolean getProtect()
Answer whether protection is enabled or disabled

Specified by:
getProtect in interface Sheet
Returns:
true => protection enabled; false => protection disabled

protectSheet

public void protectSheet(java.lang.String password)
Enables sheet protection and sets the password for the sheet. Also sets some attributes on the CTSheetProtection that correspond to the default values used by Excel

Specified by:
protectSheet in interface Sheet
Parameters:
password - to set for protection. Pass null to remove protection

getRow

public XSSFRow getRow(int rownum)
Returns the logical row ( 0-based). If you ask for a row that is not defined you get a null. This is to say row 4 represents the fifth row on a sheet.

Specified by:
getRow in interface Sheet
Parameters:
rownum - row to get
Returns:
XSSFRow representing the rownumber or null if its not defined on the sheet

getRowBreaks

public int[] getRowBreaks()
Horizontal page break information used for print layout view, page layout view, drawing print breaks in normal view, and for printing the worksheet.

Specified by:
getRowBreaks in interface Sheet
Returns:
row indexes of all the horizontal page breaks, never null

getRowSumsBelow

public boolean getRowSumsBelow()
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.

When true a summary row is inserted below the detailed data being summarized and a new outline level is established on that row.

When false a summary row is inserted above the detailed data being summarized and a new outline level is established on that row.

Specified by:
getRowSumsBelow in interface Sheet
Returns:
true if row summaries appear below detail in the outline

setRowSumsBelow

public void setRowSumsBelow(boolean value)
Flag indicating whether summary rows appear below detail in an outline, when applying an outline.

When true a summary row is inserted below the detailed data being summarized and a new outline level is established on that row.

When false a summary row is inserted above the detailed data being summarized and a new outline level is established on that row.

Specified by:
setRowSumsBelow in interface Sheet
Parameters:
value - true if row summaries appear below detail in the outline

getRowSumsRight

public boolean getRowSumsRight()
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.

When true a summary column is inserted to the right of the detailed data being summarized and a new outline level is established on that column.

When false a summary column is inserted to the left of the detailed data being summarized and a new outline level is established on that column.

Specified by:
getRowSumsRight in interface Sheet
Returns:
true if col summaries appear right of the detail in the outline

setRowSumsRight

public void setRowSumsRight(boolean value)
Flag indicating whether summary columns appear to the right of detail in an outline, when applying an outline.

When true a summary column is inserted to the right of the detailed data being summarized and a new outline level is established on that column.

When false a summary column is inserted to the left of the detailed data being summarized and a new outline level is established on that column.

Specified by:
setRowSumsRight in interface Sheet
Parameters:
value - true if col summaries appear right of the detail in the outline

getScenarioProtect

public boolean getScenarioProtect()
A flag indicating whether scenarios are locked when the sheet is protected.

Specified by:
getScenarioProtect in interface Sheet
Returns:
true => protection enabled; false => protection disabled

getTopRow

public short getTopRow()
The top row in the visible view when the sheet is first viewed after opening it in a viewer

Specified by:
getTopRow in interface Sheet
Returns:
integer indicating the rownum (0 based) of the top row

getVerticallyCenter

public boolean getVerticallyCenter()
Determine whether printed output for this sheet will be vertically centered.

Specified by:
getVerticallyCenter in interface Sheet
Returns:
whether printed output for this sheet will be vertically centered.

groupColumn

public void groupColumn(int fromColumn,
                        int toColumn)
Group between (0 based) columns

Specified by:
groupColumn in interface Sheet
Parameters:
fromColumn - beginning of the column range.
toColumn - end of the column range.

groupRow

public void groupRow(int fromRow,
                     int toRow)
Tie a range of cell together so that they can be collapsed or expanded

Specified by:
groupRow in interface Sheet
Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

isColumnBroken

public boolean isColumnBroken(int column)
Determines if there is a page break at the indicated column

Specified by:
isColumnBroken in interface Sheet
Parameters:
column - FIXME: Document this!
Returns:
FIXME: Document this!

isColumnHidden

public boolean isColumnHidden(int columnIndex)
Get the hidden state for a given column.

Specified by:
isColumnHidden in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
Returns:
hidden - false if the column is visible

isDisplayFormulas

public boolean isDisplayFormulas()
Gets the flag indicating whether this sheet should display formulas.

Specified by:
isDisplayFormulas in interface Sheet
Returns:
true if this sheet should display formulas.

isDisplayGridlines

public boolean isDisplayGridlines()
Gets the flag indicating whether this sheet displays the lines between rows and columns to make editing and reading easier.

Specified by:
isDisplayGridlines in interface Sheet
Returns:
true if this sheet displays gridlines.
See Also:
to check if printing of gridlines is turned on or off

setDisplayGridlines

public void setDisplayGridlines(boolean show)
Sets the flag indicating whether this sheet should display the lines between rows and columns to make editing and reading easier. To turn printing of gridlines use setPrintGridlines(boolean)

Specified by:
setDisplayGridlines in interface Sheet
Parameters:
show - true if this sheet should display gridlines.
See Also:
setPrintGridlines(boolean)

isDisplayRowColHeadings

public boolean isDisplayRowColHeadings()
Gets the flag indicating whether this sheet should display row and column headings.

Row heading are the row numbers to the side of the sheet

Column heading are the letters or numbers that appear above the columns of the sheet

Specified by:
isDisplayRowColHeadings in interface Sheet
Returns:
true if this sheet should display row and column headings.

setDisplayRowColHeadings

public void setDisplayRowColHeadings(boolean show)
Sets the flag indicating whether this sheet should display row and column headings.

Row heading are the row numbers to the side of the sheet

Column heading are the letters or numbers that appear above the columns of the sheet

Specified by:
setDisplayRowColHeadings in interface Sheet
Parameters:
show - true if this sheet should display row and column headings.

isPrintGridlines

public boolean isPrintGridlines()
Returns whether gridlines are printed.

Specified by:
isPrintGridlines in interface Sheet
Returns:
whether gridlines are printed
See Also:
to check if printing of gridlines is turned on or off

setPrintGridlines

public void setPrintGridlines(boolean value)
Turns on or off the printing of gridlines.

Specified by:
setPrintGridlines in interface Sheet
Parameters:
value - boolean to turn on or off the printing of gridlines
See Also:
Sheet.setPrintGridlines(boolean)

isRowBroken

public boolean isRowBroken(int row)
Tests if there is a page break at the indicated row

Specified by:
isRowBroken in interface Sheet
Parameters:
row - index of the row to test
Returns:
true if there is a page break at the indicated row

setRowBreak

public void setRowBreak(int row)
Sets a page break at the indicated row Breaks occur above the specified row and left of the specified column inclusive. For example, sheet.setColumnBreak(2); breaks the sheet into two parts with columns A,B,C in the first and D,E,... in the second. Simuilar, sheet.setRowBreak(2); breaks the sheet into two parts with first three rows (rownum=1...3) in the first part and rows starting with rownum=4 in the second.

Specified by:
setRowBreak in interface Sheet
Parameters:
row - the row to break, inclusive

removeColumnBreak

public void removeColumnBreak(int column)
Removes a page break at the indicated column

Specified by:
removeColumnBreak in interface Sheet

removeMergedRegion

public void removeMergedRegion(int index)
Removes a merged region of cells (hence letting them free)

Specified by:
removeMergedRegion in interface Sheet
Parameters:
index - of the region to unmerge

removeRow

public void removeRow(Row row)
Remove a row from this sheet. All cells contained in the row are removed as well

Specified by:
removeRow in interface Sheet
Parameters:
row - the row to remove.

removeRowBreak

public void removeRowBreak(int row)
Removes the page break at the indicated row

Specified by:
removeRowBreak in interface Sheet

setForceFormulaRecalculation

public void setForceFormulaRecalculation(boolean value)
Control if Excel should be asked to recalculate all formulas on this sheet when the workbook is opened.

Calculating the formula values with FormulaEvaluator is the recommended solution, but this may be used for certain cases where evaluation in POI is not possible.

It is recommended to force recalcuation of formulas on workbook level using Workbook.setForceFormulaRecalculation(boolean) to ensure that all cross-worksheet formuals and external dependencies are updated.

Specified by:
setForceFormulaRecalculation in interface Sheet
Parameters:
value - true if the application will perform a full recalculation of this worksheet values when the workbook is opened
See Also:
Workbook.setForceFormulaRecalculation(boolean)

getForceFormulaRecalculation

public boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.

Specified by:
getForceFormulaRecalculation in interface Sheet

rowIterator

public java.util.Iterator<Row> rowIterator()
Description copied from interface: Sheet
Returns an iterator of the physical rows

Specified by:
rowIterator in interface Sheet
Returns:
an iterator of the PHYSICAL rows. Meaning the 3rd element may not be the third row if say for instance the second row is undefined. Call getRowNum() on each row if you care which one it is.

iterator

public java.util.Iterator<Row> iterator()
Alias for rowIterator() to allow foreach loops

Specified by:
iterator in interface java.lang.Iterable<Row>

getAutobreaks

public boolean getAutobreaks()
Flag indicating whether the sheet displays Automatic Page Breaks.

Specified by:
getAutobreaks in interface Sheet
Returns:
true if the sheet displays Automatic Page Breaks.

setAutobreaks

public void setAutobreaks(boolean value)
Flag indicating whether the sheet displays Automatic Page Breaks.

Specified by:
setAutobreaks in interface Sheet
Parameters:
value - true if the sheet displays Automatic Page Breaks.

setColumnBreak

public void setColumnBreak(int column)
Sets a page break at the indicated column. Breaks occur above the specified row and left of the specified column inclusive. For example, sheet.setColumnBreak(2); breaks the sheet into two parts with columns A,B,C in the first and D,E,... in the second. Simuilar, sheet.setRowBreak(2); breaks the sheet into two parts with first three rows (rownum=1...3) in the first part and rows starting with rownum=4 in the second.

Specified by:
setColumnBreak in interface Sheet
Parameters:
column - the column to break, inclusive

setColumnGroupCollapsed

public void setColumnGroupCollapsed(int columnNumber,
                                    boolean collapsed)
Description copied from interface: Sheet
Expands or collapses a column group.

Specified by:
setColumnGroupCollapsed in interface Sheet
Parameters:
columnNumber - One of the columns in the group.
collapsed - true = collapse group, false = expand group.

setColumnHidden

public void setColumnHidden(int columnIndex,
                            boolean hidden)
Get the visibility state for a given column.

Specified by:
setColumnHidden in interface Sheet
Parameters:
columnIndex - - the column to get (0-based)
hidden - - the visiblity state of the column

setColumnWidth

public void setColumnWidth(int columnIndex,
                           int width)
Set the width (in units of 1/256th of a character width)

The maximum column width for an individual cell is 255 characters. This value represents the number of characters that can be displayed in a cell that is formatted with the standard font (first font in the workbook).

Character width is defined as the maximum digit width of the numbers 0, 1, 2, ... 9 as rendered using the default font (first font in the workbook).
Unless you are using a very special font, the default character is '0' (zero), this is true for Arial (default font font in HSSF) and Calibri (default font in XSSF)

Please note, that the width set by this method includes 4 pixels of margin padding (two on each side), plus 1 pixel padding for the gridlines (Section 3.3.1.12 of the OOXML spec). This results is a slightly less value of visible characters than passed to this method (approx. 1/2 of a character).

To compute the actual number of visible characters, Excel uses the following formula (Section 3.3.1.12 of the OOXML spec):

width = Truncate([{Number of Visible Characters} * {Maximum Digit Width} + {5 pixel padding}]/{Maximum Digit Width}*256)/256

Using the Calibri font as an example, the maximum digit width of 11 point font size is 7 pixels (at 96 dpi). If you set a column width to be eight characters wide, e.g. setColumnWidth(columnIndex, 8*256), then the actual value of visible characters (the value shown in Excel) is derived from the following equation: Truncate([numChars*7+5]/7*256)/256 = 8; which gives 7.29.

Specified by:
setColumnWidth in interface Sheet
Parameters:
columnIndex - - the column to set (0-based)
width - - the width in units of 1/256th of a character width
Throws:
java.lang.IllegalArgumentException - if width > 255*256 (the maximum column width in Excel is 255 characters)

setDefaultColumnStyle

public void setDefaultColumnStyle(int column,
                                  CellStyle style)
Description copied from interface: Sheet
Sets the default column style for a given column. POI will only apply this style to new cells added to the sheet.

Specified by:
setDefaultColumnStyle in interface Sheet
Parameters:
column - the column index
style - the style to set

setDefaultColumnWidth

public void setDefaultColumnWidth(int width)
Specifies the number of characters of the maximum digit width of the normal style's font. This value does not include margin padding or extra padding for gridlines. It is only the number of characters.

Specified by:
setDefaultColumnWidth in interface Sheet
Parameters:
width - the number of characters. Default value is 8.

setDefaultRowHeight

public void setDefaultRowHeight(short height)
Set the default row height for the sheet (if the rows do not define their own height) in twips (1/20 of a point)

Specified by:
setDefaultRowHeight in interface Sheet
Parameters:
height - default row height in twips (1/20 of a point)

setDefaultRowHeightInPoints

public void setDefaultRowHeightInPoints(float height)
Sets default row height measured in point size.

Specified by:
setDefaultRowHeightInPoints in interface Sheet
Parameters:
height - default row height measured in point size.

setDisplayFormulas

public void setDisplayFormulas(boolean show)
Sets the flag indicating whether this sheet should display formulas.

Specified by:
setDisplayFormulas in interface Sheet
Parameters:
show - true if this sheet should display formulas.

setFitToPage

public void setFitToPage(boolean b)
Flag indicating whether the Fit to Page print option is enabled.

Specified by:
setFitToPage in interface Sheet
Parameters:
b - true if the Fit to Page print option is enabled.

setHorizontallyCenter

public void setHorizontallyCenter(boolean value)
Center on page horizontally when printing.

Specified by:
setHorizontallyCenter in interface Sheet
Parameters:
value - whether to center on page horizontally when printing.

setVerticallyCenter

public void setVerticallyCenter(boolean value)
Whether the output is vertically centered on the page.

Specified by:
setVerticallyCenter in interface Sheet
Parameters:
value - true to vertically center, false otherwise.

setRowGroupCollapsed

public void setRowGroupCollapsed(int rowIndex,
                                 boolean collapse)
group the row It is possible for collapsed to be false and yet still have the rows in question hidden. This can be achieved by having a lower outline level collapsed, thus hiding all the child rows. Note that in this case, if the lowest level were expanded, the middle level would remain collapsed.

Specified by:
setRowGroupCollapsed in interface Sheet
Parameters:
rowIndex - - the row involved, 0 based
collapse - - boolean value for collapse

findEndOfRowOutlineGroup

public int findEndOfRowOutlineGroup(int row)
Parameters:
row - the zero based row index to find from

setZoom

public void setZoom(int numerator,
                    int denominator)
Sets the zoom magnication for the sheet. The zoom is expressed as a fraction. For example to express a zoom of 75% use 3 for the numerator and 4 for the denominator.

Specified by:
setZoom in interface Sheet
Parameters:
numerator - The numerator for the zoom magnification.
denominator - The denominator for the zoom magnification.
See Also:
setZoom(int)

setZoom

public void setZoom(int scale)
Window zoom magnification for current view representing percent values. Valid values range from 10 to 400. Horizontal & Vertical scale together. For example:
 10 - 10%
 20 - 20%
 ...
 100 - 100%
 ...
 400 - 400%
Current view can be Normal, Page Layout, or Page Break Preview.

Parameters:
scale - window zoom magnification
Throws:
java.lang.IllegalArgumentException - if scale is invalid

shiftRows

public void shiftRows(int startRow,
                      int endRow,
                      int n)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around. Calls shiftRows(startRow, endRow, n, false, false);

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

Specified by:
shiftRows in interface Sheet
Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift

shiftRows

public void shiftRows(int startRow,
                      int endRow,
                      int n,
                      boolean copyRowHeight,
                      boolean resetOriginalRowHeight)
Shifts rows between startRow and endRow n number of rows. If you use a negative number, it will shift rows up. Code ensures that rows don't wrap around

Additionally shifts merged regions that are completely defined in these rows (ie. merged 2 cells on a row to be shifted).

Specified by:
shiftRows in interface Sheet
Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift
copyRowHeight - whether to copy the row height during the shift
resetOriginalRowHeight - whether to set the original row's height to the default

showInPane

public void showInPane(short toprow,
                       short leftcol)
Location of the top left visible cell Location of the top left visible cell in the bottom right pane (when in Left-to-Right mode).

Specified by:
showInPane in interface Sheet
Parameters:
toprow - the top row to show in desktop window pane
leftcol - the left column to show in desktop window pane

ungroupColumn

public void ungroupColumn(int fromColumn,
                          int toColumn)
Description copied from interface: Sheet
Ungroup a range of columns that were previously groupped

Specified by:
ungroupColumn in interface Sheet
Parameters:
fromColumn - start column (0-based)
toColumn - end column (0-based)

ungroupRow

public void ungroupRow(int fromRow,
                       int toRow)
Ungroup a range of rows that were previously groupped

Specified by:
ungroupRow in interface Sheet
Parameters:
fromRow - start row (0-based)
toRow - end row (0-based)

isSelected

public boolean isSelected()
Returns a flag indicating whether this sheet is selected.

When only 1 sheet is selected and active, this value should be in synch with the activeTab value. In case of a conflict, the Start Part setting wins and sets the active sheet tab.

Note: multiple sheets can be selected, but only one sheet can be active at one time.

Specified by:
isSelected in interface Sheet
Returns:
true if this sheet is selected

setSelected

public void setSelected(boolean value)
Sets a flag indicating whether this sheet is selected.

When only 1 sheet is selected and active, this value should be in synch with the activeTab value. In case of a conflict, the Start Part setting wins and sets the active sheet tab.

Note: multiple sheets can be selected, but only one sheet can be active at one time.

Specified by:
setSelected in interface Sheet
Parameters:
value - true if this sheet is selected
See Also:
Workbook.setActiveSheet(int)

setCellComment

@Deprecated
public static void setCellComment(java.lang.String cellRef,
                                             XSSFComment comment)
Deprecated. since Nov 2009 use XSSFCell.setCellComment(org.apache.poi.ss.usermodel.Comment) instead

Assign a cell comment to a cell region in this worksheet

Parameters:
cellRef - cell region
comment - the comment to assign

addHyperlink

@Internal
public void addHyperlink(XSSFHyperlink hyperlink)
Register a hyperlink in the collection of hyperlinks on this sheet

Parameters:
hyperlink - the link to add

getActiveCell

public java.lang.String getActiveCell()
Return location of the active cell, e.g. A1.

Returns:
the location of the active cell.

setActiveCell

public void setActiveCell(java.lang.String cellRef)
Sets location of the active cell

Parameters:
cellRef - the location of the active cell, e.g. A1..

hasComments

public boolean hasComments()
Does this sheet have any comments on it? We need to know, so we can decide about writing it to disk or not

getNumberOfComments

protected int getNumberOfComments()

getCommentsTable

protected CommentsTable getCommentsTable(boolean create)
Returns the sheet's comments object if there is one, or null if not

Parameters:
create - create a new comments table if it does not exist

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

write

protected void write(java.io.OutputStream out)
              throws java.io.IOException
Throws:
java.io.IOException

isAutoFilterLocked

public boolean isAutoFilterLocked()
Returns:
true when Autofilters are locked and the sheet is protected.

isDeleteColumnsLocked

public boolean isDeleteColumnsLocked()
Returns:
true when Deleting columns is locked and the sheet is protected.

isDeleteRowsLocked

public boolean isDeleteRowsLocked()
Returns:
true when Deleting rows is locked and the sheet is protected.

isFormatCellsLocked

public boolean isFormatCellsLocked()
Returns:
true when Formatting cells is locked and the sheet is protected.

isFormatColumnsLocked

public boolean isFormatColumnsLocked()
Returns:
true when Formatting columns is locked and the sheet is protected.

isFormatRowsLocked

public boolean isFormatRowsLocked()
Returns:
true when Formatting rows is locked and the sheet is protected.

isInsertColumnsLocked

public boolean isInsertColumnsLocked()
Returns:
true when Inserting columns is locked and the sheet is protected.

isInsertHyperlinksLocked

public boolean isInsertHyperlinksLocked()
Returns:
true when Inserting hyperlinks is locked and the sheet is protected.

isInsertRowsLocked

public boolean isInsertRowsLocked()
Returns:
true when Inserting rows is locked and the sheet is protected.

isPivotTablesLocked

public boolean isPivotTablesLocked()
Returns:
true when Pivot tables are locked and the sheet is protected.

isSortLocked

public boolean isSortLocked()
Returns:
true when Sorting is locked and the sheet is protected.

isObjectsLocked

public boolean isObjectsLocked()
Returns:
true when Objects are locked and the sheet is protected.

isScenariosLocked

public boolean isScenariosLocked()
Returns:
true when Scenarios are locked and the sheet is protected.

isSelectLockedCellsLocked

public boolean isSelectLockedCellsLocked()
Returns:
true when Selection of locked cells is locked and the sheet is protected.

isSelectUnlockedCellsLocked

public boolean isSelectUnlockedCellsLocked()
Returns:
true when Selection of unlocked cells is locked and the sheet is protected.

isSheetLocked

public boolean isSheetLocked()
Returns:
true when Sheet is Protected.

enableLocking

public void enableLocking()
Enable sheet protection

disableLocking

public void disableLocking()
Disable sheet protection

lockAutoFilter

public void lockAutoFilter()
Enable Autofilters locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockDeleteColumns

public void lockDeleteColumns()
Enable Deleting columns locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockDeleteRows

public void lockDeleteRows()
Enable Deleting rows locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockFormatCells

public void lockFormatCells()
Enable Formatting cells locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockFormatColumns

public void lockFormatColumns()
Enable Formatting columns locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockFormatRows

public void lockFormatRows()
Enable Formatting rows locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockInsertColumns

public void lockInsertColumns()
Enable Inserting columns locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockInsertHyperlinks

public void lockInsertHyperlinks()
Enable Inserting hyperlinks locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockInsertRows

public void lockInsertRows()
Enable Inserting rows locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockPivotTables

public void lockPivotTables()
Enable Pivot Tables locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockSort

public void lockSort()
Enable Sort locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockObjects

public void lockObjects()
Enable Objects locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockScenarios

public void lockScenarios()
Enable Scenarios locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockSelectLockedCells

public void lockSelectLockedCells()
Enable Selection of locked cells locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

lockSelectUnlockedCells

public void lockSelectUnlockedCells()
Enable Selection of unlocked cells locking. This does not modify sheet protection status. To enforce this locking, call enableLocking()

setArrayFormula

public CellRange<XSSFCell> setArrayFormula(java.lang.String formula,
                                           CellRangeAddress range)
Description copied from interface: Sheet
Sets array formula to specified region for result.

Specified by:
setArrayFormula in interface Sheet
Parameters:
formula - text representation of the formula
range - Region of array formula for result.
Returns:
the CellRange of cells affected by this change

removeArrayFormula

public CellRange<XSSFCell> removeArrayFormula(Cell cell)
Description copied from interface: Sheet
Remove a Array Formula from this sheet. All cells contained in the Array Formula range are removed as well

Specified by:
removeArrayFormula in interface Sheet
Parameters:
cell - any cell within Array Formula range
Returns:
the CellRange of cells affected by this change

getDataValidationHelper

public DataValidationHelper getDataValidationHelper()
Specified by:
getDataValidationHelper in interface Sheet

getDataValidations

public java.util.List<XSSFDataValidation> getDataValidations()

addValidationData

public void addValidationData(DataValidation dataValidation)
Description copied from interface: Sheet
Creates a data validation object

Specified by:
addValidationData in interface Sheet
Parameters:
dataValidation - The Data validation object settings

setAutoFilter

public XSSFAutoFilter setAutoFilter(CellRangeAddress range)
Description copied from interface: Sheet
Enable filtering for a range of cells

Specified by:
setAutoFilter in interface Sheet
Parameters:
range - the range of cells to filter

createTable

public XSSFTable createTable()
Creates a new Table, and associates it with this Sheet

getTables

public java.util.List<XSSFTable> getTables()
Returns any tables associated with this Sheet

getSheetConditionalFormatting

public XSSFSheetConditionalFormatting getSheetConditionalFormatting()
Description copied from interface: Sheet
The 'Conditional Formatting' facet for this Sheet

Specified by:
getSheetConditionalFormatting in interface Sheet
Returns:
conditional formatting rule for this sheet

setTabColor

public void setTabColor(int colorIndex)
Set background color of the sheet tab

Parameters:
colorIndex - the indexed color to set, must be a constant from IndexedColors
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFSheetConditionalFormatting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFSheetConditionalFormatting

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting
All Implemented Interfaces:
SheetConditionalFormatting
public class XSSFSheetConditionalFormatting
extends java.lang.Object
implements SheetConditionalFormatting

Author:
Yegor Kozlov

Method Summary
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1) Add a new Conditional Formatting to the sheet.
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule[] cfRules) Add a new Conditional Formatting set to the sheet.
int | addConditionalFormatting(CellRangeAddress[] regions, ConditionalFormattingRule rule1, ConditionalFormattingRule rule2) Add a new Conditional Formatting consisting of two rules.
int | addConditionalFormatting(ConditionalFormatting cf) Adds a copy of HSSFConditionalFormatting object to the sheet
XSSFConditionalFormattingRule | createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula) Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *
XSSFConditionalFormattingRule | createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1, java.lang.String formula2) A factory method allowing to create a conditional formatting rule with a cell comparison operator TODO - formulas containing cell references are currently not parsed properly
XSSFConditionalFormattingRule | createConditionalFormattingRule(java.lang.String formula) A factory method allowing to create a conditional formatting rule with a formula.
XSSFConditionalFormatting | getConditionalFormattingAt(int index) gets Conditional Formatting object at a particular index
int | getNumConditionalFormattings()
void | removeConditionalFormatting(int index) removes a Conditional Formatting object by index
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createConditionalFormattingRule

public XSSFConditionalFormattingRule createConditionalFormattingRule(byte comparisonOperation,
                                                                     java.lang.String formula1,
                                                                     java.lang.String formula2)
A factory method allowing to create a conditional formatting rule with a cell comparison operator

TODO - formulas containing cell references are currently not parsed properly

Specified by:
createConditionalFormattingRule in interface SheetConditionalFormatting
Parameters:
comparisonOperation - - a constant value from CFRuleRecord.ComparisonOperator:

  • BETWEEN
  • NOT_BETWEEN
  • EQUAL
  • NOT_EQUAL
  • GT
  • LT
  • GE
  • LE

formula1 - - formula for the valued, compared with the cell
formula2 - - second formula (only used with ComparisonOperator.BETWEEN) and ComparisonOperator.NOT_BETWEEN operations)

createConditionalFormattingRule

public XSSFConditionalFormattingRule createConditionalFormattingRule(byte comparisonOperation,
                                                                     java.lang.String formula)
Description copied from interface: SheetConditionalFormatting
Create a conditional formatting rule that compares a cell value to a formula calculated result, using an operator *

The type of the created condition is ConditionalFormattingRule.CONDITION_TYPE_CELL_VALUE_IS

Specified by:
createConditionalFormattingRule in interface SheetConditionalFormatting
Parameters:
comparisonOperation - MUST be a constant value from ComparisonOperator except BETWEEN and NOT_BETWEEN
formula - the formula to determine if the conditional formatting is applied

createConditionalFormattingRule

public XSSFConditionalFormattingRule createConditionalFormattingRule(java.lang.String formula)
A factory method allowing to create a conditional formatting rule with a formula.

Specified by:
createConditionalFormattingRule in interface SheetConditionalFormatting
Parameters:
formula - - formula for the valued, compared with the cell

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    ConditionalFormattingRule[] cfRules)
Description copied from interface: SheetConditionalFormatting
Add a new Conditional Formatting set to the sheet.

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
cfRules - - set of up to three conditional formatting rules
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    ConditionalFormattingRule rule1)
Description copied from interface: SheetConditionalFormatting
Add a new Conditional Formatting to the sheet.

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
rule1 - - the rule to apply
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(CellRangeAddress[] regions,
                                    ConditionalFormattingRule rule1,
                                    ConditionalFormattingRule rule2)
Description copied from interface: SheetConditionalFormatting
Add a new Conditional Formatting consisting of two rules.

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
regions - - list of rectangular regions to apply conditional formatting rules
rule1 - - the first rule
rule2 - - the second rule
Returns:
index of the newly created Conditional Formatting object

addConditionalFormatting

public int addConditionalFormatting(ConditionalFormatting cf)
Adds a copy of HSSFConditionalFormatting object to the sheet

This method could be used to copy HSSFConditionalFormatting object from one sheet to another. For example:

 HSSFConditionalFormatting cf = sheet.getConditionalFormattingAt(index);
 newSheet.addConditionalFormatting(cf);

Specified by:
addConditionalFormatting in interface SheetConditionalFormatting
Parameters:
cf - HSSFConditionalFormatting object
Returns:
index of the new Conditional Formatting object

getConditionalFormattingAt

public XSSFConditionalFormatting getConditionalFormattingAt(int index)
gets Conditional Formatting object at a particular index

Specified by:
getConditionalFormattingAt in interface SheetConditionalFormatting
Parameters:
index - of the Conditional Formatting object to fetch
Returns:
Conditional Formatting object

getNumConditionalFormattings

public int getNumConditionalFormattings()
Specified by:
getNumConditionalFormattings in interface SheetConditionalFormatting
Returns:
number of Conditional Formatting objects of the sheet

removeConditionalFormatting

public void removeConditionalFormatting(int index)
removes a Conditional Formatting object by index

Specified by:
removeConditionalFormatting in interface SheetConditionalFormatting
Parameters:
index - of a Conditional Formatting object to remove
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFSimpleShape

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFSimpleShape

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFShape
        extended by  org.apache.poi.xssf.usermodel.XSSFSimpleShape
Direct Known Subclasses:
XSSFTextBox
public class XSSFSimpleShape
extends XSSFShape

Represents a shape with a predefined geometry in a SpreadsheetML drawing. Possible shape types are defined in ShapeTypes

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFShape
anchor, drawing, EMU_PER_PIXEL, EMU_PER_POINT, parent, PIXEL_DPI, POINT_DPI
Constructor Summary
protected XSSFSimpleShape(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape ctShape)
Method Summary
org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape | getCTShape()
protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties | getShapeProperties() Returns xml bean with shape properties.
int | getShapeType() Gets the shape type, one of the constants defined in ShapeTypes.
protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape | prototype() Prototype with the default structure of a new auto-shape.
void | setShapeType(int type) Sets the shape types.
void | setText(XSSFRichTextString str)
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFShape
getAnchor, getDrawing, getParent, isNoFill, setFillColor, setLineStyle, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFSimpleShape

protected XSSFSimpleShape(XSSFDrawing drawing,
                          org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape ctShape)
Method Detail

prototype

protected static org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape prototype()
Prototype with the default structure of a new auto-shape.

getCTShape

@Internal
public org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape getCTShape()

getShapeType

public int getShapeType()
Gets the shape type, one of the constants defined in ShapeTypes.

Returns:
the shape type
See Also:
ShapeTypes

setShapeType

public void setShapeType(int type)
Sets the shape types.

Parameters:
type - the shape type, one of the constants defined in ShapeTypes.
See Also:
ShapeTypes

getShapeProperties

protected org.openxmlformats.schemas.drawingml.x2006.main.CTShapeProperties getShapeProperties()
Description copied from class: XSSFShape
Returns xml bean with shape properties.

Specified by:
getShapeProperties in class XSSFShape
Returns:
xml bean with shape properties.

setText

public void setText(XSSFRichTextString str)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFTable

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFTable

public class XSSFTable
extends POIXMLDocumentPart

This class implements the Table Part (Open Office XML Part 4: chapter 3.5.1) This implementation works under the assumption that a table contains mappings to a subtree of an XML. The root element of this subtree an occur multiple times (one for each row of the table). The child nodes of the root element can be only attributes or element with maxOccurs=1 property set

Author:
Roberto Manicardi

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XSSFTable()
XSSFTable(PackagePart part, PackageRelationship rel)
Method Summary
protected void | commit() Save the content in the underlying package part.
java.lang.String | getCommonXpath() Calculates the xpath of the root element for the table.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTTable | getCTTable()
java.lang.String | getDisplayName()
CellReference | getEndCellReference()
java.lang.String | getName()
long | getNumerOfMappedColumns()
int | getRowCount()
CellReference | getStartCellReference()
java.util.List<XSSFXmlColumnPr> | getXmlColumnPrs()
XSSFSheet | getXSSFSheet()
boolean | mapsTo(long id) Checks if this Table element contains even a single mapping to the map identified by id
void | readFrom(java.io.InputStream is)
void | setDisplayName(java.lang.String name) Changes the display name of the Table
void | setName(java.lang.String name) Changes the name of the Table
void | writeTo(java.io.OutputStream out)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSSFTable

public XSSFTable()

XSSFTable

public XSSFTable(PackagePart part,
                 PackageRelationship rel)
          throws java.io.IOException
Throws:
java.io.IOException
Method Detail

readFrom

public void readFrom(java.io.InputStream is)
              throws java.io.IOException
Throws:
java.io.IOException

getXSSFSheet

public XSSFSheet getXSSFSheet()

writeTo

public void writeTo(java.io.OutputStream out)
             throws java.io.IOException
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getCTTable

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTTable getCTTable()

mapsTo

public boolean mapsTo(long id)
Checks if this Table element contains even a single mapping to the map identified by id

Parameters:
id - the XSSFMap ID
Returns:
true if the Table element contain mappings

getCommonXpath

public java.lang.String getCommonXpath()
Calculates the xpath of the root element for the table. This will be the common part of all the mapping's xpaths

Returns:
the xpath of the table's root element

getXmlColumnPrs

public java.util.List<XSSFXmlColumnPr> getXmlColumnPrs()

getName

public java.lang.String getName()
Returns:
the name of the Table, if set

setName

public void setName(java.lang.String name)
Changes the name of the Table

getDisplayName

public java.lang.String getDisplayName()
Returns:
the display name of the Table, if set

setDisplayName

public void setDisplayName(java.lang.String name)
Changes the display name of the Table

getNumerOfMappedColumns

public long getNumerOfMappedColumns()
Returns:
the number of mapped table columns (see Open Office XML Part 4: chapter 3.5.1.4)

getStartCellReference

public CellReference getStartCellReference()
Returns:
The reference for the cell in the top-left part of the table (see Open Office XML Part 4: chapter 3.5.1.2, attribute ref)

getEndCellReference

public CellReference getEndCellReference()
Returns:
The reference for the cell in the bottom-right part of the table (see Open Office XML Part 4: chapter 3.5.1.2, attribute ref)

getRowCount

public int getRowCount()
Returns:
the total number of rows in the selection. (Note: in this version autofiltering is ignored)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFTextBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFTextBox

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.XSSFShape
        extended by  org.apache.poi.xssf.usermodel.XSSFSimpleShape
            extended by  org.apache.poi.xssf.usermodel.XSSFTextBox

public final class XSSFTextBox
extends XSSFSimpleShape

Represents a text box in a SpreadsheetML drawing.

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.xssf.usermodel.XSSFShape
anchor, drawing, EMU_PER_PIXEL, EMU_PER_POINT, parent, PIXEL_DPI, POINT_DPI
Constructor Summary
protected XSSFTextBox(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape ctShape)
Method Summary
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFSimpleShape
getCTShape, getShapeProperties, getShapeType, prototype, setShapeType, setText
Methods inherited from class org.apache.poi.xssf.usermodel.XSSFShape
getAnchor, getDrawing, getParent, isNoFill, setFillColor, setLineStyle, setLineStyleColor, setLineWidth, setNoFill
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFTextBox

protected XSSFTextBox(XSSFDrawing drawing,
                      org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape ctShape)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFVMLDrawing

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFVMLDrawing

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xssf.usermodel.XSSFVMLDrawing

public final class XSSFVMLDrawing
extends POIXMLDocumentPart

Represents a SpreadsheetML VML drawing.

In Excel 2007 VML drawings are used to describe properties of cell comments, although the spec says that VML is deprecated:

The VML format is a legacy format originally introduced with Office 2000 and is included and fully defined in this Standard for backwards compatibility reasons. The DrawingML format is a newer and richer format created with the goal of eventually replacing any uses of VML in the Office Open XML formats. VML should be considered a deprecated format included in Office Open XML for legacy reasons only and new applications that need a file format for drawings are strongly encouraged to use preferentially DrawingML

Warning - Excel is known to put invalid XML into these files! For example, >br< without being closed or escaped crops up.

See 6.4 VML - SpreadsheetML Drawing in Office Open XML Part 4 - Markup Language Reference.pdf

Author:
Yegor Kozlov

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected | XSSFVMLDrawing() Create a new SpreadsheetML drawing
protected | XSSFVMLDrawing(PackagePart part, PackageRelationship rel) Construct a SpreadsheetML drawing from a package part
Method Summary
protected void | commit() Save the content in the underlying package part.
protected schemasMicrosoftComVml.CTShape | findCommentShape(int row, int col) Find a shape with ClientData of type "NOTE" and the specified row and column
protected java.util.List<org.apache.xmlbeans.XmlObject> | getItems()
protected schemasMicrosoftComVml.CTShape | newCommentShape()
protected void | read(java.io.InputStream is)
protected boolean | removeCommentShape(int row, int col)
protected void | write(java.io.OutputStream out)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRead, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XSSFVMLDrawing

protected XSSFVMLDrawing()
Create a new SpreadsheetML drawing

See Also:
XSSFSheet.createDrawingPatriarch()

XSSFVMLDrawing

protected XSSFVMLDrawing(PackagePart part,
                         PackageRelationship rel)
                  throws java.io.IOException,
                         org.apache.xmlbeans.XmlException
Construct a SpreadsheetML drawing from a package part

Parameters:
part - the package part holding the drawing data, the content type must be application/vnd.openxmlformats-officedocument.drawing+xml
rel - the package relationship holding this drawing, the relationship type must be http://schemas.openxmlformats.org/officeDocument/2006/relationships/drawing
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

read

protected void read(java.io.InputStream is)
             throws java.io.IOException,
                    org.apache.xmlbeans.XmlException
Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

getItems

protected java.util.List<org.apache.xmlbeans.XmlObject> getItems()

write

protected void write(java.io.OutputStream out)
              throws java.io.IOException
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

newCommentShape

protected schemasMicrosoftComVml.CTShape newCommentShape()

findCommentShape

protected schemasMicrosoftComVml.CTShape findCommentShape(int row,
                                                          int col)
Find a shape with ClientData of type "NOTE" and the specified row and column

Returns:
the comment shape or null

removeCommentShape

protected boolean removeCommentShape(int row,
                                     int col)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFWorkbook

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel
Class XSSFWorkbook

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.POIXMLDocument
            extended by  org.apache.poi.xssf.usermodel.XSSFWorkbook
All Implemented Interfaces:
java.lang.Iterable<XSSFSheet>, Workbook
public class XSSFWorkbook
extends POIXMLDocument
implements Workbook, java.lang.Iterable<XSSFSheet>

High level representation of a SpreadsheetML workbook. This is the first object most users will construct whether they are reading or writing a workbook. It is also the top level object for creating new sheets/etc.

Field Summary
static float | DEFAULT_CHARACTER_WIDTH Width of one character of the default font in pixels.
static int | PICTURE_TYPE_BMP
static int | PICTURE_TYPE_EPS
static int | PICTURE_TYPE_GIF Images formats supported by XSSF but not by HSSF
static int | PICTURE_TYPE_TIFF
static int | PICTURE_TYPE_WPG
Fields inherited from class org.apache.poi.POIXMLDocument
DOCUMENT_CREATOR, OLE_OBJECT_REL_TYPE, PACK_OBJECT_REL_TYPE
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Fields inherited from interface org.apache.poi.ss.usermodel.Workbook
PICTURE_TYPE_DIB, PICTURE_TYPE_EMF, PICTURE_TYPE_JPEG, PICTURE_TYPE_PICT, PICTURE_TYPE_PNG, PICTURE_TYPE_WMF, SHEET_STATE_HIDDEN, SHEET_STATE_VERY_HIDDEN, SHEET_STATE_VISIBLE
Constructor Summary
XSSFWorkbook()
Create a new SpreadsheetML workbook.
XSSFWorkbook(java.io.InputStream is)
XSSFWorkbook(OPCPackage pkg)
Constructs a XSSFWorkbook object given a OpenXML4J Package object, see www.openxml4j.org.
XSSFWorkbook(java.lang.String path)
Deprecated.
Method Summary
int | addPicture(byte[] pictureData, int format) Adds a picture to the workbook.
int | addPicture(java.io.InputStream is, int format) Adds a picture to the workbook.
void | addToolPack(UDFFinder toopack) Register a new toolpack in this workbook.
XSSFSheet | cloneSheet(int sheetNum) Create an XSSFSheet from an existing sheet in the XSSFWorkbook.
protected void | commit() Save the content in the underlying package part.
XSSFCellStyle | createCellStyle() Create a new XSSFCellStyle and add it to the workbook's style table
XSSFDataFormat | createDataFormat() Returns the instance of XSSFDataFormat for this workbook.
protected XSSFDialogsheet | createDialogsheet(java.lang.String sheetname, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDialogsheet dialogsheet)
XSSFFont | createFont() Create a new Font and add it to the workbook's font table
XSSFName | createName() Creates a new (uninitialised) defined name in this workbook
XSSFSheet | createSheet() Create an XSSFSheet for this workbook, adds it to the sheets and returns the high level representation.
XSSFSheet | createSheet(java.lang.String sheetname) Create a new sheet for this Workbook and return the high level representation.
XSSFFont | findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline) Finds a font that matches the one with the supplied attributes
int | getActiveSheetIndex() Convenience method to get the active sheet.
java.util.List<PackagePart> | getAllEmbedds() Get the document's embedded files.
java.util.List<XSSFPictureData> | getAllPictures() Gets all pictures from the Workbook.
CalculationChain | getCalculationChain() Return the CalculationChain object for this workbook
XSSFCellStyle | getCellStyleAt(short idx) gGet the cell style object at the given index
XSSFCreationHelper | getCreationHelper() Returns an object that handles instantiating concrete classes of the various instances for XSSF.
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorkbook | getCTWorkbook() Return the underlying XML bean
java.util.Collection<XSSFMap> | getCustomXMLMappings()
int | getFirstVisibleTab() Gets the first tab that is displayed in the list of tabs in excel.
XSSFFont | getFontAt(short idx) Get the font at the given index number
boolean | getForceFormulaRecalculation() Whether Excel will be asked to recalculate all formulas when the workbook is opened.
MapInfo | getMapInfo()
Row.MissingCellPolicy | getMissingCellPolicy() Retrieves the current policy on what to do when getting missing or blank cells from a row.
XSSFName | getName(java.lang.String name)
XSSFName | getNameAt(int nameIndex)
int | getNameIndex(java.lang.String name) Gets the named range index by his name Note:Excel named ranges are case-insensitive and this method performs a case-insensitive search.
short | getNumberOfFonts() Get the number of fonts in the this workbook
int | getNumberOfNames() Get the number of named ranges in the this workbook
int | getNumberOfSheets() Get the number of worksheets in the this workbook
short | getNumCellStyles() Get the number of styles the workbook contains
java.lang.String | getPrintArea(int sheetIndex) Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.
SharedStringsTable | getSharedStringSource() Returns SharedStringsTable - tha cache of string for this workbook
XSSFSheet | getSheet(java.lang.String name) Get sheet with the given name (case insensitive match)
XSSFSheet | getSheetAt(int index) Get the XSSFSheet object at the given index.
int | getSheetIndex(Sheet sheet) Returns the index of the given sheet
int | getSheetIndex(java.lang.String name) Returns the index of the sheet by his name (case insensitive match)
java.lang.String | getSheetName(int sheetIx) Get the sheet name
StylesTable | getStylesSource() Return a object representing a collection of shared objects used for styling content, e.g.
ThemesTable | getTheme() Returns the Theme of current workbook.
protected boolean | isDate1904() Gets a boolean value that indicates whether the date systems used in the workbook starts in 1904.
boolean | isHidden()
boolean | isMacroEnabled() Are we a normal workbook (.xlsx), or a macro enabled workbook (.xlsm)?
boolean | isRevisionLocked() Specifies a boolean value that indicates whether the workbook is locked for revisions.
boolean | isSheetHidden(int sheetIx) Check whether a sheet is hidden.
boolean | isSheetVeryHidden(int sheetIx) Check whether a sheet is very hidden.
boolean | isStructureLocked() Specifies a boolean value that indicates whether structure of workbook is locked.
boolean | isWindowsLocked() Specifies a boolean value that indicates whether the windows that comprise the workbook are locked.
java.util.Iterator<XSSFSheet> | iterator() Allows foreach loops:
void | lockRevision() Locks the workbook for revisions.
void | lockStructure() Locks the structure of workbook.
void | lockWindows() Locks the windows that comprise the workbook.
protected static OPCPackage | newPackage() Create a new SpreadsheetML package and setup the default minimal content
protected void | onDeleteFormula(XSSFCell cell) Fired when a formula is deleted from this workbook, for example when calling cell.setCellFormula(null)
protected void | onDocumentRead() Fired when a package part is read
void | removeName(int nameIndex) Remove the defined name at the specified index
void | removeName(java.lang.String name) Remove a defined name by name
void | removePrintArea(int sheetIndex) Delete the printarea for the sheet specified
void | removeSheetAt(int index) Removes sheet at the given index. Care must be taken if the removed sheet is the currently active or only selected sheet in the workbook.
void | setActiveSheet(int index) Convenience method to set the active sheet.
void | setFirstVisibleTab(int index) Sets the first tab that is displayed in the list of tabs in excel.
void | setForceFormulaRecalculation(boolean value) Whether the application shall perform a full recalculation when the workbook is opened.
void | setHidden(boolean hiddenFlag)
void | setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy) Sets the policy on what to do when getting missing or blank cells from a row.
void | setPrintArea(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow) For the Convenience of Java Programmers maintaining pointers.
void | setPrintArea(int sheetIndex, java.lang.String reference) Sets the printarea for the sheet provided
void | setRepeatingRowsAndColumns(int sheetIndex, int startColumn, int endColumn, int startRow, int endRow) Sets the repeating rows and columns for a sheet.
void | setSelectedTab(int index) We only set one sheet as selected for compatibility with HSSF.
void | setSheetHidden(int sheetIx, boolean hidden) Sets the visible state of this sheet.
void | setSheetHidden(int sheetIx, int state) Hide or unhide a sheet.
void | setSheetName(int sheetIndex, java.lang.String sheetname) Set the sheet name.
void | setSheetOrder(java.lang.String sheetname, int pos) sets the order of appearance for a given sheet.
void | unLockRevision() Unlocks the workbook for revisions.
void | unLockStructure() Unlocks the structure of workbook.
void | unLockWindows() Unlocks the windows that comprise the workbook.
Methods inherited from class org.apache.poi.POIXMLDocument
getCorePart, getPackage, getProperties, getRelatedByType, hasOOXMLHeader, load, openPackage, write
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.Workbook
write

Field Detail

DEFAULT_CHARACTER_WIDTH

public static final float DEFAULT_CHARACTER_WIDTH
Width of one character of the default font in pixels. Same for Calibry and Arial.

See Also:
Constant Field Values

PICTURE_TYPE_GIF

public static final int PICTURE_TYPE_GIF
Images formats supported by XSSF but not by HSSF

See Also:
Constant Field Values

PICTURE_TYPE_TIFF

public static final int PICTURE_TYPE_TIFF
See Also:
Constant Field Values

PICTURE_TYPE_EPS

public static final int PICTURE_TYPE_EPS
See Also:
Constant Field Values

PICTURE_TYPE_BMP

public static final int PICTURE_TYPE_BMP
See Also:
Constant Field Values

PICTURE_TYPE_WPG

public static final int PICTURE_TYPE_WPG
See Also:
Constant Field Values
Constructor Detail

XSSFWorkbook

public XSSFWorkbook()
Create a new SpreadsheetML workbook.

XSSFWorkbook

public XSSFWorkbook(OPCPackage pkg)
             throws java.io.IOException
Constructs a XSSFWorkbook object given a OpenXML4J Package object, see www.openxml4j.org.

Parameters:
pkg - the OpenXML4J Package object.
Throws:
java.io.IOException

XSSFWorkbook

public XSSFWorkbook(java.io.InputStream is)
             throws java.io.IOException
Throws:
java.io.IOException

XSSFWorkbook

@Deprecated
public XSSFWorkbook(java.lang.String path)
             throws java.io.IOException
Deprecated.

Constructs a XSSFWorkbook object given a file name.

This constructor is deprecated since POI-3.8 because it does not close the underlying .zip file stream. In short, there are two ways to open a OPC package:

  1. from file which leads to invoking java.util.zip.ZipFile(File file) deep in POI internals.
  2. from input stream in which case we first read everything into memory and then pass the data to ZipInputStream.

      3. It should be noted, that (2) uses quite a bit more memory than (1), which doesn't need to hold the whole zip file in memory, and can take advantage of native methods.

      To construct a workbook from file use the XSSFWorkbook(org.apache.poi.openxml4j.opc.OPCPackage) constructor:

       OPCPackage pkg = OPCPackage.open(path);
       XSSFWorkbook wb = new XSSFWorkbook(pkg);
       // work with the wb object
       ......
       pkg.close(); // gracefully closes the underlying zip file

      Parameters:
      path - the file name.
      Throws:
      java.io.IOException
Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Fired when a package part is read

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

newPackage

protected static OPCPackage newPackage()
Create a new SpreadsheetML package and setup the default minimal content

getCTWorkbook

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorkbook getCTWorkbook()
Return the underlying XML bean

Returns:
the underlying CTWorkbook bean

addPicture

public int addPicture(byte[] pictureData,
                      int format)
Adds a picture to the workbook.

Specified by:
addPicture in interface Workbook
Parameters:
pictureData - The bytes of the picture
format - The format of the picture.
Returns:
the index to this picture (0 based), the added picture can be obtained from getAllPictures() .
See Also:
Workbook.PICTURE_TYPE_EMF, Workbook.PICTURE_TYPE_WMF, Workbook.PICTURE_TYPE_PICT, Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PNG, Workbook.PICTURE_TYPE_DIB, getAllPictures()

addPicture

public int addPicture(java.io.InputStream is,
                      int format)
               throws java.io.IOException
Adds a picture to the workbook.

Parameters:
is - The sream to read image from
format - The format of the picture.
Returns:
the index to this picture (0 based), the added picture can be obtained from getAllPictures() .
Throws:
java.io.IOException
See Also:
Workbook.PICTURE_TYPE_EMF, Workbook.PICTURE_TYPE_WMF, Workbook.PICTURE_TYPE_PICT, Workbook.PICTURE_TYPE_JPEG, Workbook.PICTURE_TYPE_PNG, Workbook.PICTURE_TYPE_DIB, getAllPictures()

cloneSheet

public XSSFSheet cloneSheet(int sheetNum)
Create an XSSFSheet from an existing sheet in the XSSFWorkbook. The cloned sheet is a deep copy of the original.

Specified by:
cloneSheet in interface Workbook
Returns:
XSSFSheet representing the cloned sheet.
Throws:
java.lang.IllegalArgumentException - if the sheet index in invalid
POIXMLException - if there were errors when cloning

createCellStyle

public XSSFCellStyle createCellStyle()
Create a new XSSFCellStyle and add it to the workbook's style table

Specified by:
createCellStyle in interface Workbook
Returns:
the new XSSFCellStyle object

createDataFormat

public XSSFDataFormat createDataFormat()
Returns the instance of XSSFDataFormat for this workbook.

Specified by:
createDataFormat in interface Workbook
Returns:
the XSSFDataFormat object
See Also:
DataFormat

createFont

public XSSFFont createFont()
Create a new Font and add it to the workbook's font table

Specified by:
createFont in interface Workbook
Returns:
new font object

createName

public XSSFName createName()
Description copied from interface: Workbook
Creates a new (uninitialised) defined name in this workbook

Specified by:
createName in interface Workbook
Returns:
new defined name object

createSheet

public XSSFSheet createSheet()
Create an XSSFSheet for this workbook, adds it to the sheets and returns the high level representation. Use this to create new sheets.

Specified by:
createSheet in interface Workbook
Returns:
XSSFSheet representing the new sheet.

createSheet

public XSSFSheet createSheet(java.lang.String sheetname)
Create a new sheet for this Workbook and return the high level representation. Use this to create new sheets.

Note that Excel allows sheet names up to 31 chars in length but other applications (such as OpenOffice) allow more. Some versions of Excel crash with names longer than 31 chars, others - truncate such names to 31 character.

POI's SpreadsheetAPI silently truncates the input argument to 31 characters. Example:

     Sheet sheet = workbook.createSheet("My very long sheet name which is longer than 31 chars"); // will be truncated
     assert 31 == sheet.getSheetName().length();
     assert "My very long sheet name which i" == sheet.getSheetName();

Except the 31-character constraint, Excel applies some other rules:

Sheet name MUST be unique in the workbook and MUST NOT contain the any of the following characters:

  • 0x0000
  • 0x0003
  • colon (:)
  • backslash (\)
  • asterisk (*)
  • question mark (?)
  • forward slash (/)
  • opening square bracket ([)
  • closing square bracket (])
The string MUST NOT begin or end with the single quote (') character.

See WorkbookUtil.createSafeSheetName(String nameProposal) for a safe way to create valid names

Specified by:
createSheet in interface Workbook
Parameters:
sheetname - sheetname to set for the sheet.
Returns:
Sheet representing the new sheet.
Throws:
java.lang.IllegalArgumentException - if the name is null or invalid or workbook already contains a sheet with this name
See Also:
WorkbookUtil.createSafeSheetName(String nameProposal)

createDialogsheet

protected XSSFDialogsheet createDialogsheet(java.lang.String sheetname,
                                            org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDialogsheet dialogsheet)

findFont

public XSSFFont findFont(short boldWeight,
                         short color,
                         short fontHeight,
                         java.lang.String name,
                         boolean italic,
                         boolean strikeout,
                         short typeOffset,
                         byte underline)
Finds a font that matches the one with the supplied attributes

Specified by:
findFont in interface Workbook
Returns:
the font with the matched attributes or null

getActiveSheetIndex

public int getActiveSheetIndex()
Convenience method to get the active sheet. The active sheet is is the sheet which is currently displayed when the workbook is viewed in Excel. 'Selected' sheet(s) is a distinct concept.

Specified by:
getActiveSheetIndex in interface Workbook
Returns:
the index of the active sheet (0-based)

getAllPictures

public java.util.List<XSSFPictureData> getAllPictures()
Gets all pictures from the Workbook.

Specified by:
getAllPictures in interface Workbook
Returns:
the list of pictures (a list of XSSFPictureData objects.)
See Also:
addPicture(byte[], int)

getCellStyleAt

public XSSFCellStyle getCellStyleAt(short idx)
gGet the cell style object at the given index

Specified by:
getCellStyleAt in interface Workbook
Parameters:
idx - index within the set of styles
Returns:
XSSFCellStyle object at the index

getFontAt

public XSSFFont getFontAt(short idx)
Get the font at the given index number

Specified by:
getFontAt in interface Workbook
Parameters:
idx - index number
Returns:
XSSFFont at the index

getName

public XSSFName getName(java.lang.String name)
Specified by:
getName in interface Workbook
Parameters:
name - the name of the defined name
Returns:
the defined name with the specified name. null if not found.

getNameAt

public XSSFName getNameAt(int nameIndex)
Specified by:
getNameAt in interface Workbook
Parameters:
nameIndex - position of the named range (0-based)
Returns:
the defined name at the specified index

getNameIndex

public int getNameIndex(java.lang.String name)
Gets the named range index by his name Note:Excel named ranges are case-insensitive and this method performs a case-insensitive search.

Specified by:
getNameIndex in interface Workbook
Parameters:
name - named range name
Returns:
named range index

getNumCellStyles

public short getNumCellStyles()
Get the number of styles the workbook contains

Specified by:
getNumCellStyles in interface Workbook
Returns:
count of cell styles

getNumberOfFonts

public short getNumberOfFonts()
Get the number of fonts in the this workbook

Specified by:
getNumberOfFonts in interface Workbook
Returns:
number of fonts

getNumberOfNames

public int getNumberOfNames()
Get the number of named ranges in the this workbook

Specified by:
getNumberOfNames in interface Workbook
Returns:
number of named ranges

getNumberOfSheets

public int getNumberOfSheets()
Get the number of worksheets in the this workbook

Specified by:
getNumberOfSheets in interface Workbook
Returns:
number of worksheets

getPrintArea

public java.lang.String getPrintArea(int sheetIndex)
Retrieves the reference for the printarea of the specified sheet, the sheet name is appended to the reference even if it was not specified.

Specified by:
getPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
Returns:
String Null if no print area has been defined

getSheet

public XSSFSheet getSheet(java.lang.String name)
Get sheet with the given name (case insensitive match)

Specified by:
getSheet in interface Workbook
Parameters:
name - of the sheet
Returns:
XSSFSheet with the name provided or null if it does not exist

getSheetAt

public XSSFSheet getSheetAt(int index)
Get the XSSFSheet object at the given index.

Specified by:
getSheetAt in interface Workbook
Parameters:
index - of the sheet number (0-based physical & logical)
Returns:
XSSFSheet at the provided index
Throws:
java.lang.IllegalArgumentException - if the index is out of range (index < 0 || index >= getNumberOfSheets()).

getSheetIndex

public int getSheetIndex(java.lang.String name)
Returns the index of the sheet by his name (case insensitive match)

Specified by:
getSheetIndex in interface Workbook
Parameters:
name - the sheet name
Returns:
index of the sheet (0 based) or -1

getSheetIndex

public int getSheetIndex(Sheet sheet)
Returns the index of the given sheet

Specified by:
getSheetIndex in interface Workbook
Parameters:
sheet - the sheet to look up
Returns:
index of the sheet (0 based). -1 if not found

getSheetName

public java.lang.String getSheetName(int sheetIx)
Get the sheet name

Specified by:
getSheetName in interface Workbook
Parameters:
sheetIx - Number
Returns:
Sheet name

iterator

public java.util.Iterator<XSSFSheet> iterator()
Allows foreach loops:

 XSSFWorkbook wb = new XSSFWorkbook(package);
 for(XSSFSheet sheet : wb){

 }

Specified by:
iterator in interface java.lang.Iterable<XSSFSheet>

isMacroEnabled

public boolean isMacroEnabled()
Are we a normal workbook (.xlsx), or a macro enabled workbook (.xlsm)?

removeName

public void removeName(int nameIndex)
Description copied from interface: Workbook
Remove the defined name at the specified index

Specified by:
removeName in interface Workbook
Parameters:
nameIndex - named range index (0 based)

removeName

public void removeName(java.lang.String name)
Description copied from interface: Workbook
Remove a defined name by name

Specified by:
removeName in interface Workbook
Parameters:
name - the name of the defined name

removePrintArea

public void removePrintArea(int sheetIndex)
Delete the printarea for the sheet specified

Specified by:
removePrintArea in interface Workbook
Parameters:
sheetIndex - 0-based sheet index (0 = First Sheet)

removeSheetAt

public void removeSheetAt(int index)
Removes sheet at the given index.

Care must be taken if the removed sheet is the currently active or only selected sheet in the workbook. There are a few situations when Excel must have a selection and/or active sheet. (For example when printing - see Bug 40414).
This method makes sure that if the removed sheet was active, another sheet will become active in its place. Furthermore, if the removed sheet was the only selected sheet, another sheet will become selected. The newly active/selected sheet will have the same index, or one less if the removed sheet was the last in the workbook.

Specified by:
removeSheetAt in interface Workbook
Parameters:
index - of the sheet (0-based)

getMissingCellPolicy

public Row.MissingCellPolicy getMissingCellPolicy()
Retrieves the current policy on what to do when getting missing or blank cells from a row. The default is to return blank and null cells. Row.MissingCellPolicy

Specified by:
getMissingCellPolicy in interface Workbook

setMissingCellPolicy

public void setMissingCellPolicy(Row.MissingCellPolicy missingCellPolicy)
Sets the policy on what to do when getting missing or blank cells from a row. This will then apply to all calls to Row.getCell(int)}. See Row.MissingCellPolicy

Specified by:
setMissingCellPolicy in interface Workbook

setActiveSheet

public void setActiveSheet(int index)
Convenience method to set the active sheet. The active sheet is is the sheet which is currently displayed when the workbook is viewed in Excel. 'Selected' sheet(s) is a distinct concept.

Specified by:
setActiveSheet in interface Workbook
Parameters:
index - index of the active sheet (0-based)

getFirstVisibleTab

public int getFirstVisibleTab()
Gets the first tab that is displayed in the list of tabs in excel.

Specified by:
getFirstVisibleTab in interface Workbook
Returns:
integer that contains the index to the active sheet in this book view.

setFirstVisibleTab

public void setFirstVisibleTab(int index)
Sets the first tab that is displayed in the list of tabs in excel.

Specified by:
setFirstVisibleTab in interface Workbook
Parameters:
index - integer that contains the index to the active sheet in this book view.

setPrintArea

public void setPrintArea(int sheetIndex,
                         java.lang.String reference)
Sets the printarea for the sheet provided

i.e. Reference = $A$1:$B$2

Specified by:
setPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 Represents the first sheet to keep consistent with java)
reference - Valid name Reference for the Print Area

setPrintArea

public void setPrintArea(int sheetIndex,
                         int startColumn,
                         int endColumn,
                         int startRow,
                         int endRow)
For the Convenience of Java Programmers maintaining pointers.

Specified by:
setPrintArea in interface Workbook
Parameters:
sheetIndex - Zero-based sheet index (0 = First Sheet)
startColumn - Column to begin printarea
endColumn - Column to end the printarea
startRow - Row to begin the printarea
endRow - Row to end the printarea
See Also:
setPrintArea(int, String)

setRepeatingRowsAndColumns

public void setRepeatingRowsAndColumns(int sheetIndex,
                                       int startColumn,
                                       int endColumn,
                                       int startRow,
                                       int endRow)
Sets the repeating rows and columns for a sheet.

To set just repeating columns:

  workbook.setRepeatingRowsAndColumns(0,0,1,-1,-1);
To set just repeating rows:
  workbook.setRepeatingRowsAndColumns(0,-1,-1,0,4);
To remove all repeating rows and columns for a sheet.
  workbook.setRepeatingRowsAndColumns(0,-1,-1,-1,-1);

Specified by:
setRepeatingRowsAndColumns in interface Workbook
Parameters:
sheetIndex - 0 based index to sheet.
startColumn - 0 based start of repeating columns.
endColumn - 0 based end of repeating columns.
startRow - 0 based start of repeating rows.
endRow - 0 based end of repeating rows.

setSelectedTab

public void setSelectedTab(int index)
We only set one sheet as selected for compatibility with HSSF.

Specified by:
setSelectedTab in interface Workbook
Parameters:
index - the index of the sheet to select (0 based)
See Also:
Sheet.setSelected(boolean)

setSheetName

public void setSheetName(int sheetIndex,
                         java.lang.String sheetname)
Set the sheet name.

Specified by:
setSheetName in interface Workbook
Parameters:
sheetIndex - sheet number (0 based)
sheetname - the new sheet name
Throws:
java.lang.IllegalArgumentException - if the name is null or invalid or workbook already contains a sheet with this name
See Also:
createSheet(String), WorkbookUtil.createSafeSheetName(String nameProposal)

setSheetOrder

public void setSheetOrder(java.lang.String sheetname,
                          int pos)
sets the order of appearance for a given sheet.

Specified by:
setSheetOrder in interface Workbook
Parameters:
sheetname - the name of the sheet to reorder
pos - the position that we want to insert the sheet into (0 based)

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getSharedStringSource

@Internal
public SharedStringsTable getSharedStringSource()
Returns SharedStringsTable - tha cache of string for this workbook

Returns:
the shared string table

getStylesSource

public StylesTable getStylesSource()
Return a object representing a collection of shared objects used for styling content, e.g. fonts, cell styles, colors, etc.

getTheme

public ThemesTable getTheme()
Returns the Theme of current workbook.

getCreationHelper

public XSSFCreationHelper getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances for XSSF.

Specified by:
getCreationHelper in interface Workbook

isDate1904

protected boolean isDate1904()
Gets a boolean value that indicates whether the date systems used in the workbook starts in 1904.

The default value is false, meaning that the workbook uses the 1900 date system, where 1/1/1900 is the first day in the system..

Returns:
true if the date systems used in the workbook starts in 1904

getAllEmbedds

public java.util.List<PackagePart> getAllEmbedds()
                                          throws OpenXML4JException
Get the document's embedded files.

Specified by:
getAllEmbedds in class POIXMLDocument
Throws:
OpenXML4JException

isHidden

public boolean isHidden()
Specified by:
isHidden in interface Workbook
Returns:
false if this workbook is not visible in the GUI

setHidden

public void setHidden(boolean hiddenFlag)
Specified by:
setHidden in interface Workbook
Parameters:
hiddenFlag - pass false to make the workbook visible in the GUI

isSheetHidden

public boolean isSheetHidden(int sheetIx)
Check whether a sheet is hidden.

Note that a sheet could instead be set to be very hidden, which is different (isSheetVeryHidden(int))

Specified by:
isSheetHidden in interface Workbook
Parameters:
sheetIx - Number
Returns:
true if sheet is hidden

isSheetVeryHidden

public boolean isSheetVeryHidden(int sheetIx)
Check whether a sheet is very hidden.

This is different from the normal hidden status (isSheetHidden(int))

Specified by:
isSheetVeryHidden in interface Workbook
Parameters:
sheetIx - sheet index to check
Returns:
true if sheet is very hidden

setSheetHidden

public void setSheetHidden(int sheetIx,
                           boolean hidden)
Sets the visible state of this sheet.

   Calling setSheetHidden(sheetIndex, true) is equivalent to
   setSheetHidden(sheetIndex, Workbook.SHEET_STATE_HIDDEN).
Calling setSheetHidden(sheetIndex, false) is equivalent to
   setSheetHidden(sheetIndex, Workbook.SHEET_STATE_VISIBLE).

Specified by:
setSheetHidden in interface Workbook
Parameters:
sheetIx - the 0-based index of the sheet
hidden - whether this sheet is hidden
See Also:
setSheetHidden(int, int)

setSheetHidden

public void setSheetHidden(int sheetIx,
                           int state)
Hide or unhide a sheet.
  • 0 - visible.
  • 1 - hidden.
  • 2 - very hidden.

Specified by:
setSheetHidden in interface Workbook
Parameters:
sheetIx - the sheet index (0-based)
state - one of the following Workbook constants: Workbook.SHEET_STATE_VISIBLE, Workbook.SHEET_STATE_HIDDEN, or Workbook.SHEET_STATE_VERY_HIDDEN.
Throws:
java.lang.IllegalArgumentException - if the supplied sheet index or state is invalid

onDeleteFormula

protected void onDeleteFormula(XSSFCell cell)
Fired when a formula is deleted from this workbook, for example when calling cell.setCellFormula(null)

See Also:
XSSFCell.setCellFormula(String)

getCalculationChain

@Internal
public CalculationChain getCalculationChain()
Return the CalculationChain object for this workbook

The calculation chain object specifies the order in which the cells in a workbook were last calculated

Returns:
the CalculationChain object or null if not defined

getCustomXMLMappings

public java.util.Collection<XSSFMap> getCustomXMLMappings()
Returns:
a collection of custom XML mappings defined in this workbook

getMapInfo

@Internal
public MapInfo getMapInfo()
Returns:
the helper class used to query the custom XML mapping defined in this workbook

isStructureLocked

public boolean isStructureLocked()
Specifies a boolean value that indicates whether structure of workbook is locked.
A value true indicates the structure of the workbook is locked. Worksheets in the workbook can't be moved, deleted, hidden, unhidden, or renamed, and new worksheets can't be inserted.
A value of false indicates the structure of the workbook is not locked.

Returns:
true if structure of workbook is locked

isWindowsLocked

public boolean isWindowsLocked()
Specifies a boolean value that indicates whether the windows that comprise the workbook are locked.
A value of true indicates the workbook windows are locked. Windows are the same size and position each time the workbook is opened.
A value of false indicates the workbook windows are not locked.

Returns:
true if windows that comprise the workbook are locked

isRevisionLocked

public boolean isRevisionLocked()
Specifies a boolean value that indicates whether the workbook is locked for revisions.

Returns:
true if the workbook is locked for revisions.

lockStructure

public void lockStructure()
Locks the structure of workbook.

unLockStructure

public void unLockStructure()
Unlocks the structure of workbook.

lockWindows

public void lockWindows()
Locks the windows that comprise the workbook.

unLockWindows

public void unLockWindows()
Unlocks the windows that comprise the workbook.

lockRevision

public void lockRevision()
Locks the workbook for revisions.

unLockRevision

public void unLockRevision()
Unlocks the workbook for revisions.

addToolPack

public void addToolPack(UDFFinder toopack)
Register a new toolpack in this workbook.

Specified by:
addToolPack in interface Workbook
Parameters:
toopack - the toolpack to register

setForceFormulaRecalculation

public void setForceFormulaRecalculation(boolean value)
Whether the application shall perform a full recalculation when the workbook is opened.

Typically you want to force formula recalculation when you modify cell formulas or values of a workbook previously created by Excel. When set to true, this flag will tell Excel that it needs to recalculate all formulas in the workbook the next time the file is opened.

Note, that recalculation updates cached formula results and, thus, modifies the workbook. Depending on the version, Excel may prompt you with "Do you want to save the changes in filename?" on close.

Specified by:
setForceFormulaRecalculation in interface Workbook
Parameters:
value - true if the application will perform a full recalculation of workbook values when the workbook is opened
Since:
3.8

getForceFormulaRecalculation

public boolean getForceFormulaRecalculation()
Whether Excel will be asked to recalculate all formulas when the workbook is opened.

Specified by:
getForceFormulaRecalculation in interface Workbook
Since:
3.8
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.xssf.usermodel.charts
Classes
XSSFChartAxis
XSSFChartDataFactory
XSSFChartLegend
XSSFManualLayout
XSSFScatterChartData
XSSFValueAxis


org.apache.poi.xssf.usermodel.charts

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.usermodel.charts

Class Summary
XSSFChartAxis | Base class for all axis types.
XSSFChartDataFactory |
XSSFChartLegend | Represents a SpreadsheetML chart legend
XSSFManualLayout | Represents a SpreadsheetML manual layout.
XSSFScatterChartData | Represents DrawingML scatter charts.
XSSFValueAxis | Value axis type.


org.apache.poi.xssf.usermodel.charts Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.usermodel.charts

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xssf.usermodel.charts.XSSFChartAxis (implements org.apache.poi.ss.usermodel.charts.ChartAxis)
      • org.apache.poi.xssf.usermodel.charts.XSSFValueAxis (implements org.apache.poi.ss.usermodel.charts.ValueAxis)
    • org.apache.poi.xssf.usermodel.charts.XSSFChartDataFactory (implements org.apache.poi.ss.usermodel.charts.ChartDataFactory)
    • org.apache.poi.xssf.usermodel.charts.XSSFChartLegend (implements org.apache.poi.ss.usermodel.charts.ChartLegend)
    • org.apache.poi.xssf.usermodel.charts.XSSFManualLayout (implements org.apache.poi.ss.usermodel.charts.ManualLayout)
    • org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData (implements org.apache.poi.ss.usermodel.charts.ScatterChartData)


Uses of Package org.apache.poi.xssf.usermodel.charts

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.usermodel.charts

Packages that use org.apache.poi.xssf.usermodel.charts
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Classes in org.apache.poi.xssf.usermodel.charts used by org.apache.poi.xssf.usermodel
XSSFChartAxis
Base class for all axis types.
XSSFChartDataFactory
XSSFChartLegend
Represents a SpreadsheetML chart legend
XSSFManualLayout
Represents a SpreadsheetML manual layout.
XSSFValueAxis
Value axis type.

Classes in org.apache.poi.xssf.usermodel.charts used by org.apache.poi.xssf.usermodel.charts
XSSFChartAxis
Base class for all axis types.
XSSFChartDataFactory
XSSFManualLayout
Represents a SpreadsheetML manual layout.
XSSFScatterChartData
Represents DrawingML scatter charts.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSSFChartAxis

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.charts
Class XSSFChartAxis

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.charts.XSSFChartAxis
All Implemented Interfaces:
ChartAxis
Direct Known Subclasses:
XSSFValueAxis
@Beta
public abstract class XSSFChartAxis
extends java.lang.Object
implements ChartAxis

Base class for all axis types.

Author:
Roman Kashitsyn

Field Summary
protected  XSSFChart chart
Constructor Summary
protected XSSFChartAxis(XSSFChart chart)
Method Summary
AxisCrosses | getCrosses()
protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTAxPos | getCTAxPos()
protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTCrosses | getCTCrosses()
protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTNumFmt | getCTNumFmt()
protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTScaling | getCTScaling()
double | getLogBase()
double | getMaximum()
double | getMinimum()
java.lang.String | getNumberFormat()
AxisOrientation | getOrientation()
AxisPosition | getPosition()
boolean | isSetLogBase()
boolean | isSetMaximum()
boolean | isSetMinimum()
void | setCrosses(AxisCrosses crosses)
void | setLogBase(double logBase)
void | setMaximum(double max)
void | setMinimum(double min)
void | setNumberFormat(java.lang.String format)
void | setOrientation(AxisOrientation orientation)
void | setPosition(AxisPosition position)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.charts.ChartAxis
crossAxis, getId

Field Detail

chart

protected XSSFChart chart
Constructor Detail

XSSFChartAxis

protected XSSFChartAxis(XSSFChart chart)
Method Detail

getPosition

public AxisPosition getPosition()
Specified by:
getPosition in interface ChartAxis
Returns:
axis position

setPosition

public void setPosition(AxisPosition position)
Specified by:
setPosition in interface ChartAxis
Parameters:
position - new axis position

setNumberFormat

public void setNumberFormat(java.lang.String format)
Specified by:
setNumberFormat in interface ChartAxis
Parameters:
format - axis number format

getNumberFormat

public java.lang.String getNumberFormat()
Specified by:
getNumberFormat in interface ChartAxis
Returns:
axis number format

isSetLogBase

public boolean isSetLogBase()
Specified by:
isSetLogBase in interface ChartAxis
Returns:
true if log base is defined, false otherwise

setLogBase

public void setLogBase(double logBase)
Specified by:
setLogBase in interface ChartAxis
Parameters:
logBase - a number between 2 and 1000 (inclusive)

getLogBase

public double getLogBase()
Specified by:
getLogBase in interface ChartAxis
Returns:
axis log base or 0.0 if not set

isSetMinimum

public boolean isSetMinimum()
Specified by:
isSetMinimum in interface ChartAxis
Returns:
true if minimum value is defined, false otherwise

setMinimum

public void setMinimum(double min)
Specified by:
setMinimum in interface ChartAxis
Parameters:
min - axis minimum

getMinimum

public double getMinimum()
Specified by:
getMinimum in interface ChartAxis
Returns:
axis minimum or 0.0 if not set

isSetMaximum

public boolean isSetMaximum()
Specified by:
isSetMaximum in interface ChartAxis
Returns:
true if maximum value is defined, false otherwise

setMaximum

public void setMaximum(double max)
Specified by:
setMaximum in interface ChartAxis
Parameters:
max - axis maximum

getMaximum

public double getMaximum()
Specified by:
getMaximum in interface ChartAxis
Returns:
axis maximum or 0.0 if not set

getOrientation

public AxisOrientation getOrientation()
Specified by:
getOrientation in interface ChartAxis
Returns:
axis orientation

setOrientation

public void setOrientation(AxisOrientation orientation)
Specified by:
setOrientation in interface ChartAxis
Parameters:
orientation - axis orientation

getCrosses

public AxisCrosses getCrosses()
Specified by:
getCrosses in interface ChartAxis
Returns:
axis cross type

setCrosses

public void setCrosses(AxisCrosses crosses)
Specified by:
setCrosses in interface ChartAxis
Parameters:
crosses - axis cross type

getCTAxPos

protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTAxPos getCTAxPos()

getCTNumFmt

protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTNumFmt getCTNumFmt()

getCTScaling

protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTScaling getCTScaling()

getCTCrosses

protected abstract org.openxmlformats.schemas.drawingml.x2006.chart.CTCrosses getCTCrosses()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XSSFChartDataFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.charts
Class XSSFChartDataFactory

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.charts.XSSFChartDataFactory
All Implemented Interfaces:
ChartDataFactory
@Beta
public class XSSFChartDataFactory
extends java.lang.Object
implements ChartDataFactory

Author:
Roman Kashitsyn

Method Summary
XSSFScatterChartData | createScatterChartData()
static XSSFChartDataFactory | getInstance()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createScatterChartData

public XSSFScatterChartData createScatterChartData()
Specified by:
createScatterChartData in interface ChartDataFactory
Returns:
new scatter charts data instance

getInstance

public static XSSFChartDataFactory getInstance()
Returns:
factory instance
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFChartLegend

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.charts
Class XSSFChartLegend

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.charts.XSSFChartLegend
All Implemented Interfaces:
ChartLegend, ManuallyPositionable
@Beta
public final class XSSFChartLegend
extends java.lang.Object
implements ChartLegend

Represents a SpreadsheetML chart legend

Author:
Roman Kashitsyn

Constructor Summary
XSSFChartLegend(XSSFChart chart)
Create a new SpreadsheetML chart legend
Method Summary
org.openxmlformats.schemas.drawingml.x2006.chart.CTLegend | getCTLegend() Return the underlying CTLegend bean.
XSSFManualLayout | getManualLayout() Returns manual layout for the chart element.
LegendPosition | getPosition()
void | setPosition(LegendPosition position)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFChartLegend

public XSSFChartLegend(XSSFChart chart)
Create a new SpreadsheetML chart legend

Method Detail

getCTLegend

@Internal
public org.openxmlformats.schemas.drawingml.x2006.chart.CTLegend getCTLegend()
Return the underlying CTLegend bean.

Returns:
the underlying CTLegend bean

setPosition

public void setPosition(LegendPosition position)
Specified by:
setPosition in interface ChartLegend
Parameters:
position - new legend position

getPosition

public LegendPosition getPosition()
Specified by:
getPosition in interface ChartLegend
Returns:
legend position

getManualLayout

public XSSFManualLayout getManualLayout()
Description copied from interface: ManuallyPositionable
Returns manual layout for the chart element.

Specified by:
getManualLayout in interface ManuallyPositionable
Returns:
manual layout for the chart element.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFManualLayout

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.charts
Class XSSFManualLayout

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.charts.XSSFManualLayout
All Implemented Interfaces:
ManualLayout
@Beta
public final class XSSFManualLayout
extends java.lang.Object
implements ManualLayout

Represents a SpreadsheetML manual layout.

Author:
Roman Kashitsyn

Constructor Summary
XSSFManualLayout(org.openxmlformats.schemas.drawingml.x2006.chart.CTLayout ctLayout)
Create a new SpreadsheetML manual layout.
XSSFManualLayout(XSSFChart chart)
Create a new SpreadsheetML manual layout for chart.
Method Summary
org.openxmlformats.schemas.drawingml.x2006.chart.CTManualLayout | getCTManualLayout() Return the underlying CTManualLayout bean.
LayoutMode | getHeightMode() Returns current height mode of this
double | getHeightRatio() Returns current fraction of the height of the chart.
LayoutTarget | getTarget() Returns current layout target.
LayoutMode | getWidthMode() Returns current width mode of this manual layout.
double | getWidthRatio() Returns current fraction of the width of the chart.
double | getX() Returns the x location of the chart element.
LayoutMode | getXMode() Returns current x-coordinnate layout mode.
double | getY() Returns current y location of the chart element.
LayoutMode | getYMode() Returns current y-coordinate layout mode.
void | setHeightMode(LayoutMode mode) Specifies how to interpret the Height element for this manual layout.
void | setHeightRatio(double ratio) Specifies the height (if Height Mode is Factor) or bottom (if Height Mode is edge) of the chart element as a fraction of the height of the chart.
void | setTarget(LayoutTarget target) Sets the layout target.
void | setWidthMode(LayoutMode mode) Specifies how to interpret the Width element for this manual layout.
void | setWidthRatio(double ratio) Specifies the width (if Width Mode is Factor) or right (if Width Mode is Edge) of the chart element as a fraction of the width of the chart.
void | setX(double x) Specifies the x location (left) of the chart element as a fraction of the width of the chart.
void | setXMode(LayoutMode mode) Sets the x-coordinate layout mode.
void | setY(double y) Specifies the y location (top) of the chart element as a fraction of the height of the chart.
void | setYMode(LayoutMode mode) Sets the y-coordinate layout mode.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFManualLayout

public XSSFManualLayout(org.openxmlformats.schemas.drawingml.x2006.chart.CTLayout ctLayout)
Create a new SpreadsheetML manual layout.

Parameters:
ctLayout - a Spreadsheet ML layout that should be used as base.

XSSFManualLayout

public XSSFManualLayout(XSSFChart chart)
Create a new SpreadsheetML manual layout for chart.

Parameters:
chart - a chart to create layout for.
Method Detail

getCTManualLayout

@Internal
public org.openxmlformats.schemas.drawingml.x2006.chart.CTManualLayout getCTManualLayout()
Return the underlying CTManualLayout bean.

Returns:
the underlying CTManualLayout bean.

setWidthRatio

public void setWidthRatio(double ratio)
Description copied from interface: ManualLayout
Specifies the width (if Width Mode is Factor) or right (if Width Mode is Edge) of the chart element as a fraction of the width of the chart.

Specified by:
setWidthRatio in interface ManualLayout
Parameters:
ratio - a fraction of the width of the chart.

getWidthRatio

public double getWidthRatio()
Description copied from interface: ManualLayout
Returns current fraction of the width of the chart.

Specified by:
getWidthRatio in interface ManualLayout
Returns:
fraction of the width of the chart or 0.0 if not set.

setHeightRatio

public void setHeightRatio(double ratio)
Description copied from interface: ManualLayout
Specifies the height (if Height Mode is Factor) or bottom (if Height Mode is edge) of the chart element as a fraction of the height of the chart.

Specified by:
setHeightRatio in interface ManualLayout
Parameters:
ratio - a fraction of the height of the chart.

getHeightRatio

public double getHeightRatio()
Description copied from interface: ManualLayout
Returns current fraction of the height of the chart.

Specified by:
getHeightRatio in interface ManualLayout
Returns:
fraction of the height of the chart or 0.0 if not set.

getTarget

public LayoutTarget getTarget()
Description copied from interface: ManualLayout
Returns current layout target.

Specified by:
getTarget in interface ManualLayout
Returns:
current layout target

setTarget

public void setTarget(LayoutTarget target)
Description copied from interface: ManualLayout
Sets the layout target.

Specified by:
setTarget in interface ManualLayout
Parameters:
target - new layout target.

getXMode

public LayoutMode getXMode()
Description copied from interface: ManualLayout
Returns current x-coordinnate layout mode.

Specified by:
getXMode in interface ManualLayout
Returns:
current x-coordinate layout mode.

setXMode

public void setXMode(LayoutMode mode)
Description copied from interface: ManualLayout
Sets the x-coordinate layout mode.

Specified by:
setXMode in interface ManualLayout
Parameters:
mode - new x-coordinate layout mode.

getYMode

public LayoutMode getYMode()
Description copied from interface: ManualLayout
Returns current y-coordinate layout mode.

Specified by:
getYMode in interface ManualLayout
Returns:
current y-coordinate layout mode.

setYMode

public void setYMode(LayoutMode mode)
Description copied from interface: ManualLayout
Sets the y-coordinate layout mode.

Specified by:
setYMode in interface ManualLayout
Parameters:
mode - new y-coordinate layout mode.

getX

public double getX()
Description copied from interface: ManualLayout
Returns the x location of the chart element.

Specified by:
getX in interface ManualLayout
Returns:
the x location (left) of the chart element or 0.0 if not set.

setX

public void setX(double x)
Description copied from interface: ManualLayout
Specifies the x location (left) of the chart element as a fraction of the width of the chart. If Left Mode is Factor, then the position is relative to the default position for the chart element.

Specified by:
setX in interface ManualLayout

getY

public double getY()
Description copied from interface: ManualLayout
Returns current y location of the chart element.

Specified by:
getY in interface ManualLayout
Returns:
the y location (top) of the chart element or 0.0 if not set.

setY

public void setY(double y)
Description copied from interface: ManualLayout
Specifies the y location (top) of the chart element as a fraction of the height of the chart. If Top Mode is Factor, then the position is relative to the default position for the chart element.

Specified by:
setY in interface ManualLayout

getWidthMode

public LayoutMode getWidthMode()
Description copied from interface: ManualLayout
Returns current width mode of this manual layout.

Specified by:
getWidthMode in interface ManualLayout
Returns:
width mode of this manual layout.

setWidthMode

public void setWidthMode(LayoutMode mode)
Description copied from interface: ManualLayout
Specifies how to interpret the Width element for this manual layout.

Specified by:
setWidthMode in interface ManualLayout
Parameters:
mode - new width layout mode of this manual layout.

getHeightMode

public LayoutMode getHeightMode()
Description copied from interface: ManualLayout
Returns current height mode of this

Specified by:
getHeightMode in interface ManualLayout
Returns:
height mode of this manual layout.

setHeightMode

public void setHeightMode(LayoutMode mode)
Description copied from interface: ManualLayout
Specifies how to interpret the Height element for this manual layout.

Specified by:
setHeightMode in interface ManualLayout
Parameters:
mode - new height mode of this manual layout.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFScatterChartData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.charts
Class XSSFScatterChartData

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData
All Implemented Interfaces:
ChartData, ScatterChartData
@Beta
public class XSSFScatterChartData
extends java.lang.Object
implements ScatterChartData

Represents DrawingML scatter charts.

Author:
Roman Kashitsyn

Constructor Summary
XSSFScatterChartData()
Method Summary
ScatterChartSerie | addSerie(ChartDataSource<?> xs, ChartDataSource<? extends java.lang.Number> ys)
void | fillChart(Chart chart, ChartAxis... axis) Fills a charts with data specified by implementation.
java.util.List<? extends org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData.Serie> | getSeries()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFScatterChartData

public XSSFScatterChartData()
Method Detail

addSerie

public ScatterChartSerie addSerie(ChartDataSource<?> xs,
                                  ChartDataSource<? extends java.lang.Number> ys)
Specified by:
addSerie in interface ScatterChartData
Parameters:
xs - data source to be used for X axis values
ys - data source to be used for Y axis values
Returns:
a new scatter charts serie

fillChart

public void fillChart(Chart chart,
                      ChartAxis... axis)
Description copied from interface: ChartData
Fills a charts with data specified by implementation.

Specified by:
fillChart in interface ChartData
Parameters:
chart - a charts to fill in
axis - charts axis to use

getSeries

public java.util.List<? extends org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData.Serie> getSeries()
Specified by:
getSeries in interface ScatterChartData
Returns:
list of all series
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFValueAxis

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.charts
Class XSSFValueAxis

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.charts.XSSFChartAxis
        extended by  org.apache.poi.xssf.usermodel.charts.XSSFValueAxis
All Implemented Interfaces:
ChartAxis, ValueAxis
@Beta
public class XSSFValueAxis
extends XSSFChartAxis
implements ValueAxis

Value axis type.

Author:
Roman Kashitsyn

Field Summary
Fields inherited from class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis
chart
Constructor Summary
XSSFValueAxis(XSSFChart chart, org.openxmlformats.schemas.drawingml.x2006.chart.CTValAx ctValAx)
XSSFValueAxis(XSSFChart chart, long id, AxisPosition pos)
Method Summary
void | crossAxis(ChartAxis axis) Declare this axis cross another axis.
AxisCrossBetween | getCrossBetween()
protected org.openxmlformats.schemas.drawingml.x2006.chart.CTAxPos | getCTAxPos()
protected org.openxmlformats.schemas.drawingml.x2006.chart.CTCrosses | getCTCrosses()
protected org.openxmlformats.schemas.drawingml.x2006.chart.CTNumFmt | getCTNumFmt()
protected org.openxmlformats.schemas.drawingml.x2006.chart.CTScaling | getCTScaling()
long | getId()
void | setCrossBetween(AxisCrossBetween crossBetween)
Methods inherited from class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis
getCrosses, getLogBase, getMaximum, getMinimum, getNumberFormat, getOrientation, getPosition, isSetLogBase, isSetMaximum, isSetMinimum, setCrosses, setLogBase, setMaximum, setMinimum, setNumberFormat, setOrientation, setPosition
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.poi.ss.usermodel.charts.ChartAxis
getCrosses, getLogBase, getMaximum, getMinimum, getNumberFormat, getOrientation, getPosition, isSetLogBase, isSetMaximum, isSetMinimum, setCrosses, setLogBase, setMaximum, setMinimum, setNumberFormat, setOrientation, setPosition

Constructor Detail

XSSFValueAxis

public XSSFValueAxis(XSSFChart chart,
                     long id,
                     AxisPosition pos)

XSSFValueAxis

public XSSFValueAxis(XSSFChart chart,
                     org.openxmlformats.schemas.drawingml.x2006.chart.CTValAx ctValAx)
Method Detail

getId

public long getId()
Specified by:
getId in interface ChartAxis
Returns:
axis id

setCrossBetween

public void setCrossBetween(AxisCrossBetween crossBetween)
Specified by:
setCrossBetween in interface ValueAxis
Parameters:
crossBetween - cross between type

getCrossBetween

public AxisCrossBetween getCrossBetween()
Specified by:
getCrossBetween in interface ValueAxis
Returns:
cross between type

getCTAxPos

protected org.openxmlformats.schemas.drawingml.x2006.chart.CTAxPos getCTAxPos()
Specified by:
getCTAxPos in class XSSFChartAxis

getCTNumFmt

protected org.openxmlformats.schemas.drawingml.x2006.chart.CTNumFmt getCTNumFmt()
Specified by:
getCTNumFmt in class XSSFChartAxis

getCTScaling

protected org.openxmlformats.schemas.drawingml.x2006.chart.CTScaling getCTScaling()
Specified by:
getCTScaling in class XSSFChartAxis

getCTCrosses

protected org.openxmlformats.schemas.drawingml.x2006.chart.CTCrosses getCTCrosses()
Specified by:
getCTCrosses in class XSSFChartAxis

crossAxis

public void crossAxis(ChartAxis axis)
Description copied from interface: ChartAxis
Declare this axis cross another axis.

Specified by:
crossAxis in interface ChartAxis
Parameters:
axis - that this axis should cross
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.charts.XSSFChartAxis

Packages that use XSSFChartAxis
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of XSSFChartAxis in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFChartAxis
 java.util.List<? extends XSSFChartAxis> XSSFChart.getAxis()

Uses of XSSFChartAxis in org.apache.poi.xssf.usermodel.charts

Subclasses of XSSFChartAxis in org.apache.poi.xssf.usermodel.charts
 class XSSFValueAxis
Value axis type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.charts.XSSFChartDataFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.charts.XSSFChartDataFactory

Packages that use XSSFChartDataFactory
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of XSSFChartDataFactory in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFChartDataFactory
 XSSFChartDataFactory XSSFChart.getChartDataFactory()

Uses of XSSFChartDataFactory in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return XSSFChartDataFactory
static XSSFChartDataFactory XSSFChartDataFactory.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.charts.XSSFChartLegend

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.charts.XSSFChartLegend

Packages that use XSSFChartLegend
org.apache.poi.xssf.usermodel

Uses of XSSFChartLegend in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFChartLegend
 XSSFChartLegend XSSFChart.getOrCreateLegend()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.charts.XSSFManualLayout

Packages that use XSSFManualLayout
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of XSSFManualLayout in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFManualLayout
 XSSFManualLayout XSSFChart.getManualLayout()

Uses of XSSFManualLayout in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return XSSFManualLayout
 XSSFManualLayout XSSFChartLegend.getManualLayout()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.charts.XSSFScatterChartData

Packages that use XSSFScatterChartData
org.apache.poi.xssf.usermodel.charts

Uses of XSSFScatterChartData in org.apache.poi.xssf.usermodel.charts

Methods in org.apache.poi.xssf.usermodel.charts that return XSSFScatterChartData
 XSSFScatterChartData XSSFChartDataFactory.createScatterChartData()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.charts.XSSFValueAxis

Packages that use XSSFValueAxis
org.apache.poi.xssf.usermodel

Uses of XSSFValueAxis in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFValueAxis
 XSSFValueAxis XSSFChart.createValueAxis(AxisPosition pos)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFAnchor

Packages that use XSSFAnchor
org.apache.poi.xssf.usermodel

Uses of XSSFAnchor in org.apache.poi.xssf.usermodel

Subclasses of XSSFAnchor in org.apache.poi.xssf.usermodel
class | XSSFChildAnchor
class | XSSFClientAnchor A client anchor is attached to an excel worksheet.

Fields in org.apache.poi.xssf.usermodel declared as XSSFAnchor
protected  XSSFAnchor XSSFShape.anchor
anchor that is used by this shape

Methods in org.apache.poi.xssf.usermodel that return XSSFAnchor
 XSSFAnchor XSSFShape.getAnchor()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFAutoFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFAutoFilter

Packages that use XSSFAutoFilter
org.apache.poi.xssf.usermodel

Uses of XSSFAutoFilter in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFAutoFilter
 XSSFAutoFilter XSSFSheet.setAutoFilter(CellRangeAddress range)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFBorderFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFBorderFormatting

Packages that use XSSFBorderFormatting
org.apache.poi.xssf.usermodel

Uses of XSSFBorderFormatting in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFBorderFormatting
XSSFBorderFormatting | XSSFConditionalFormattingRule.createBorderFormatting() Create a new border formatting structure if it does not exist, otherwise just return existing object.
XSSFBorderFormatting | XSSFConditionalFormattingRule.getBorderFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFCell

Packages that use XSSFCell
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.helpers

Uses of XSSFCell in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFCell
XSSFCell | XSSFRow.createCell(int columnIndex) Use this to create new cells within the row and return it.
XSSFCell | XSSFRow.createCell(int columnIndex, int type) Use this to create new cells within the row and return it.
XSSFCell | XSSFFormulaEvaluator.evaluateInCell(Cell cell) If cell contains formula, it evaluates the formula, and puts the formula result back into the cell, in place of the old formula.
XSSFCell | XSSFRow.getCell(int cellnum) Returns the cell at the given (0 based) index, with the Row.MissingCellPolicy from the parent Workbook.
XSSFCell | XSSFRow.getCell(int cellnum, Row.MissingCellPolicy policy) Returns the cell at the given (0 based) index, with the specified Row.MissingCellPolicy

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFCell
CellRange<XSSFCell> | XSSFSheet.removeArrayFormula(Cell cell)
CellRange<XSSFCell> | XSSFSheet.setArrayFormula(java.lang.String formula, CellRangeAddress range)

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFCell
protected  void XSSFWorkbook.onDeleteFormula(XSSFCell cell)
Fired when a formula is deleted from this workbook, for example when calling cell.setCellFormula(null)

Uses of XSSFCell in org.apache.poi.xssf.usermodel.helpers

Methods in org.apache.poi.xssf.usermodel.helpers that return XSSFCell
 XSSFCell XSSFSingleXmlCell.getReferencedCell()
Gets the XSSFCell referenced by the R attribute or creates a new one if cell doesn't exists

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFCellStyle

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFCellStyle

Packages that use XSSFCellStyle
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel

Uses of XSSFCellStyle in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFCellStyle
XSSFCellStyle | StylesTable.createCellStyle()
XSSFCellStyle | StylesTable.getStyleAt(int idx)

Methods in org.apache.poi.xssf.model with parameters of type XSSFCellStyle
 int StylesTable.putStyle(XSSFCellStyle style)

Uses of XSSFCellStyle in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFCellStyle
XSSFCellStyle | XSSFWorkbook.createCellStyle() Create a new XSSFCellStyle and add it to the workbook's style table
XSSFCellStyle | XSSFCell.getCellStyle() Return the cell's style.
XSSFCellStyle | XSSFWorkbook.getCellStyleAt(short idx) gGet the cell style object at the given index
XSSFCellStyle | XSSFRow.getRowStyle() Returns the whole-row cell style.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFChart

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFChart

Packages that use XSSFChart
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.charts

Uses of XSSFChart in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFChart
XSSFChart | XSSFDrawing.createChart(ClientAnchor anchor)
XSSFChart | XSSFDrawing.createChart(XSSFClientAnchor anchor) Creates a chart.
XSSFChart | XSSFChart.getChartAxisFactory()

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFChart
 java.util.List<XSSFChart> XSSFDrawing.getCharts()
Returns all charts in this drawing.

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFChart
protected  void XSSFGraphicFrame.setChart(XSSFChart chart, java.lang.String relId)
Assign a DrawingML chart to the graphic frame.

Uses of XSSFChart in org.apache.poi.xssf.usermodel.charts

Fields in org.apache.poi.xssf.usermodel.charts declared as XSSFChart
protected  XSSFChart XSSFChartAxis.chart

Constructors in org.apache.poi.xssf.usermodel.charts with parameters of type XSSFChart
XSSFChartAxis(XSSFChart chart)
XSSFChartLegend(XSSFChart chart)
Create a new SpreadsheetML chart legend
XSSFManualLayout(XSSFChart chart)
Create a new SpreadsheetML manual layout for chart.
XSSFValueAxis(XSSFChart chart, org.openxmlformats.schemas.drawingml.x2006.chart.CTValAx ctValAx)
XSSFValueAxis(XSSFChart chart, long id, AxisPosition pos)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFChartSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFChartSheet

No usage of org.apache.poi.xssf.usermodel.XSSFChartSheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFChildAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFChildAnchor

Packages that use XSSFChildAnchor
org.apache.poi.xssf.usermodel

Uses of XSSFChildAnchor in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFChildAnchor
XSSFConnector | XSSFShapeGroup.createConnector(XSSFChildAnchor anchor) Creates a simple shape.
XSSFSimpleShape | XSSFShapeGroup.createSimpleShape(XSSFChildAnchor anchor) Creates a simple shape.
XSSFTextBox | XSSFShapeGroup.createTextbox(XSSFChildAnchor anchor) Constructs a textbox.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFClientAnchor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFClientAnchor

Packages that use XSSFClientAnchor
org.apache.poi.xssf.usermodel

Uses of XSSFClientAnchor in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFClientAnchor
XSSFClientAnchor | XSSFDrawing.createAnchor(int dx1, int dy1, int dx2, int dy2, int col1, int row1, int col2, int row2)
XSSFClientAnchor | XSSFCreationHelper.createClientAnchor() Creates a XSSFClientAnchor.
XSSFClientAnchor | XSSFGraphicFrame.getAnchor() Returns the frame anchor.
XSSFClientAnchor | XSSFPicture.getPreferredSize() Calculate the preferred size for this picture.
XSSFClientAnchor | XSSFPicture.getPreferredSize(double scale) Calculate the preferred size for this picture.

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFClientAnchor
XSSFChart | XSSFDrawing.createChart(XSSFClientAnchor anchor) Creates a chart.
XSSFConnector | XSSFDrawing.createConnector(XSSFClientAnchor anchor) Creates a simple shape.
XSSFShapeGroup | XSSFDrawing.createGroup(XSSFClientAnchor anchor) Creates a simple shape.
XSSFPicture | XSSFShapeGroup.createPicture(XSSFClientAnchor anchor, int pictureIndex) Creates a picture.
XSSFPicture | XSSFDrawing.createPicture(XSSFClientAnchor anchor, int pictureIndex) Creates a picture.
XSSFSimpleShape | XSSFDrawing.createSimpleShape(XSSFClientAnchor anchor) Creates a simple shape.
XSSFTextBox | XSSFDrawing.createTextbox(XSSFClientAnchor anchor) Constructs a textbox under the drawing.
protected void | XSSFGraphicFrame.setAnchor(XSSFClientAnchor anchor) Attaches frame to an anchor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFColor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFColor

Packages that use XSSFColor
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions

Uses of XSSFColor in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFColor
 XSSFColor ThemesTable.getThemeColor(int idx)

Methods in org.apache.poi.xssf.model with parameters of type XSSFColor
 void ThemesTable.inheritFromThemeAsRequired(XSSFColor color)
If the colour is based on a theme, then inherit information (currently just colours) from it as required.

Uses of XSSFColor in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFColor
XSSFColor | XSSFCellStyle.getBorderColor(XSSFCellBorder.BorderSide side) Gets border color
XSSFColor | XSSFCellStyle.getBottomBorderXSSFColor() Get the color to use for the bottom border as a XSSFColor
XSSFColor | XSSFCellStyle.getFillBackgroundColorColor()
XSSFColor | XSSFCellStyle.getFillBackgroundXSSFColor() Get the background fill color.
XSSFColor | XSSFCellStyle.getFillForegroundColorColor()
XSSFColor | XSSFCellStyle.getFillForegroundXSSFColor() Get the foreground fill color.
XSSFColor | XSSFCellStyle.getLeftBorderXSSFColor() Get the color to use for the left border
XSSFColor | XSSFCellStyle.getRightBorderXSSFColor() Get the color to use for the right border
XSSFColor | XSSFCellStyle.getTopBorderXSSFColor() Get the color to use for the top border
XSSFColor | XSSFFontFormatting.getXSSFColor()
XSSFColor | XSSFFont.getXSSFColor() get the color value for the font References a color defined as Standard Alpha Red Green Blue color value (ARGB).

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFColor
void | XSSFCellStyle.setBorderColor(XSSFCellBorder.BorderSide side, XSSFColor color) Set the color to use for the selected border
void | XSSFCellStyle.setBottomBorderColor(XSSFColor color) Set the color to use for the bottom border
void | XSSFFont.setColor(XSSFColor color) set the color for the font in Standard Alpha Red Green Blue color value
void | XSSFCellStyle.setFillBackgroundColor(XSSFColor color) Set the background fill color represented as a XSSFColor value.
void | XSSFCellStyle.setFillForegroundColor(XSSFColor color) Set the foreground fill color represented as a XSSFColor value.
void | XSSFCellStyle.setLeftBorderColor(XSSFColor color) Set the color to use for the left border as a XSSFColor value
void | XSSFCellStyle.setRightBorderColor(XSSFColor color) Set the color to use for the right border as a XSSFColor value
void | XSSFCellStyle.setTopBorderColor(XSSFColor color) Set the color to use for the top border as a XSSFColor value

Uses of XSSFColor in org.apache.poi.xssf.usermodel.extensions

Methods in org.apache.poi.xssf.usermodel.extensions that return XSSFColor
XSSFColor | XSSFCellBorder.getBorderColor(XSSFCellBorder.BorderSide side) Get the color to use for the selected border
XSSFColor | XSSFCellFill.getFillBackgroundColor() Get the background fill color.
XSSFColor | XSSFCellFill.getFillForegroundColor() Get the foreground fill color.

Methods in org.apache.poi.xssf.usermodel.extensions with parameters of type XSSFColor
void | XSSFCellBorder.setBorderColor(XSSFCellBorder.BorderSide side, XSSFColor color) Set the color to use for the selected border
void | XSSFCellFill.setFillBackgroundColor(XSSFColor color) Set the background fill color represented as a XSSFColor value.
void | XSSFCellFill.setFillForegroundColor(XSSFColor color) Set the foreground fill color represented as a XSSFColor value.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFComment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFComment

Packages that use XSSFComment
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel

Uses of XSSFComment in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFComment
 XSSFComment CommentsTable.findCellComment(java.lang.String cellRef)

Uses of XSSFComment in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFComment
XSSFComment | XSSFDrawing.createCellComment(ClientAnchor anchor) Creates a comment.
XSSFComment | XSSFSheet.createComment() Deprecated. since Nov 2009 this method is not compatible with the common SS interfaces, use (org.apache.poi.ss.usermodel.ClientAnchor) instead
XSSFComment | XSSFCell.getCellComment() Returns cell comment associated with this cell
XSSFComment | XSSFSheet.getCellComment(int row, int column)

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFComment
static void XSSFSheet.setCellComment(java.lang.String cellRef, XSSFComment comment)
Deprecated. since Nov 2009 use XSSFCell.setCellComment(org.apache.poi.ss.usermodel.Comment) instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFConditionalFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFConditionalFormatting

Packages that use XSSFConditionalFormatting
org.apache.poi.xssf.usermodel

Uses of XSSFConditionalFormatting in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFConditionalFormatting
 XSSFConditionalFormatting XSSFSheetConditionalFormatting.getConditionalFormattingAt(int index)
gets Conditional Formatting object at a particular index

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFConditionalFormattingRule

Packages that use XSSFConditionalFormattingRule
org.apache.poi.xssf.usermodel

Uses of XSSFConditionalFormattingRule in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFConditionalFormattingRule
XSSFConditionalFormattingRule | XSSFSheetConditionalFormatting.createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula)
XSSFConditionalFormattingRule | XSSFSheetConditionalFormatting.createConditionalFormattingRule(byte comparisonOperation, java.lang.String formula1, java.lang.String formula2) A factory method allowing to create a conditional formatting rule with a cell comparison operator TODO - formulas containing cell references are currently not parsed properly
XSSFConditionalFormattingRule | XSSFSheetConditionalFormatting.createConditionalFormattingRule(java.lang.String formula) A factory method allowing to create a conditional formatting rule with a formula.
XSSFConditionalFormattingRule | XSSFConditionalFormatting.getRule(int idx)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFConnector

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFConnector

Packages that use XSSFConnector
org.apache.poi.xssf.usermodel

Uses of XSSFConnector in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFConnector
XSSFConnector | XSSFShapeGroup.createConnector(XSSFChildAnchor anchor) Creates a simple shape.
XSSFConnector | XSSFDrawing.createConnector(XSSFClientAnchor anchor) Creates a simple shape.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFCreationHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFCreationHelper

Packages that use XSSFCreationHelper
org.apache.poi.xssf.usermodel

Uses of XSSFCreationHelper in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFCreationHelper
 XSSFCreationHelper XSSFWorkbook.getCreationHelper()
Returns an object that handles instantiating concrete classes of the various instances for XSSF.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFDataFormat

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFDataFormat

Packages that use XSSFDataFormat
org.apache.poi.xssf.usermodel

Uses of XSSFDataFormat in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFDataFormat
XSSFDataFormat | XSSFWorkbook.createDataFormat() Returns the instance of XSSFDataFormat for this workbook.
XSSFDataFormat | XSSFCreationHelper.createDataFormat()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFDataValidation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFDataValidation

Packages that use XSSFDataValidation
org.apache.poi.xssf.usermodel

Uses of XSSFDataValidation in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFDataValidation
 java.util.List<XSSFDataValidation> XSSFSheet.getDataValidations()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFDataValidationConstraint

Packages that use XSSFDataValidationConstraint
org.apache.poi.xssf.usermodel

Uses of XSSFDataValidationConstraint in org.apache.poi.xssf.usermodel

Constructors in org.apache.poi.xssf.usermodel with parameters of type XSSFDataValidationConstraint
XSSFDataValidation(XSSFDataValidationConstraint constraint, CellRangeAddressList regions, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDataValidation ctDataValidation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

No usage of org.apache.poi.xssf.usermodel.XSSFDataValidationHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFDialogsheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFDialogsheet

Packages that use XSSFDialogsheet
org.apache.poi.xssf.usermodel

Uses of XSSFDialogsheet in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFDialogsheet
protected  XSSFDialogsheet XSSFWorkbook.createDialogsheet(java.lang.String sheetname, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDialogsheet dialogsheet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFDrawing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFDrawing

Packages that use XSSFDrawing
org.apache.poi.xssf.usermodel

Uses of XSSFDrawing in org.apache.poi.xssf.usermodel

Fields in org.apache.poi.xssf.usermodel declared as XSSFDrawing
protected  XSSFDrawing XSSFShape.drawing
Parent drawing

Methods in org.apache.poi.xssf.usermodel that return XSSFDrawing
XSSFDrawing | XSSFSheet.createDrawingPatriarch() Create a new SpreadsheetML drawing.
XSSFDrawing | XSSFShape.getDrawing() Return the drawing that owns this shape

Constructors in org.apache.poi.xssf.usermodel with parameters of type XSSFDrawing
XSSFConnector(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTConnector ctShape)
Construct a new XSSFConnector object.
XSSFGraphicFrame(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGraphicalObjectFrame ctGraphicFrame)
Construct a new XSSFGraphicFrame object.
XSSFPicture(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTPicture ctPicture)
Construct a new XSSFPicture object.
XSSFShapeGroup(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTGroupShape ctGroup)
Construct a new XSSFSimpleShape object.
XSSFSimpleShape(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape ctShape)
XSSFTextBox(XSSFDrawing drawing, org.openxmlformats.schemas.drawingml.x2006.spreadsheetDrawing.CTShape ctShape)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFEvaluationWorkbook

Packages that use XSSFEvaluationWorkbook
org.apache.poi.xssf.usermodel

Uses of XSSFEvaluationWorkbook in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFEvaluationWorkbook
static XSSFEvaluationWorkbook XSSFEvaluationWorkbook.create(XSSFWorkbook book)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFEvenFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFEvenFooter

No usage of org.apache.poi.xssf.usermodel.XSSFEvenFooter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFEvenHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFEvenHeader

No usage of org.apache.poi.xssf.usermodel.XSSFEvenHeader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFFactory

Packages that use XSSFFactory
org.apache.poi.xssf.usermodel

Uses of XSSFFactory in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFFactory
static XSSFFactory XSSFFactory.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFFirstFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFFirstFooter

No usage of org.apache.poi.xssf.usermodel.XSSFFirstFooter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFFirstHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFFirstHeader

No usage of org.apache.poi.xssf.usermodel.XSSFFirstHeader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFFont

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFFont

Packages that use XSSFFont
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel

Uses of XSSFFont in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFFont
XSSFFont | StylesTable.findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline) Finds a font that matches the one with the supplied attributes
XSSFFont | StylesTable.getFontAt(int idx)

Methods in org.apache.poi.xssf.model that return types with arguments of type XSSFFont
 java.util.List<XSSFFont> StylesTable.getFonts()

Methods in org.apache.poi.xssf.model with parameters of type XSSFFont
int | StylesTable.putFont(XSSFFont font)
int | StylesTable.putFont(XSSFFont font, boolean forceRegistration) Records the given font in the font table.

Uses of XSSFFont in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFFont
XSSFFont | XSSFWorkbook.createFont() Create a new Font and add it to the workbook's font table
XSSFFont | XSSFWorkbook.findFont(short boldWeight, short color, short fontHeight, java.lang.String name, boolean italic, boolean strikeout, short typeOffset, byte underline) Finds a font that matches the one with the supplied attributes
XSSFFont | XSSFCellStyle.getFont() Gets the font for this style
XSSFFont | XSSFWorkbook.getFontAt(short idx) Get the font at the given index number
XSSFFont | XSSFRichTextString.getFontAtIndex(int index) Return a copy of the font in use at a particular index.
XSSFFont | XSSFRichTextString.getFontOfFormattingRun(int index) Gets a copy of the font used in a particular formatting run.

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFFont
 void XSSFRichTextString.append(java.lang.String text, XSSFFont font)
Append new text to this text run and apply the specify font to it

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFFontFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFFontFormatting

Packages that use XSSFFontFormatting
org.apache.poi.xssf.usermodel

Uses of XSSFFontFormatting in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFFontFormatting
XSSFFontFormatting | XSSFConditionalFormattingRule.createFontFormatting() Create a new font formatting structure if it does not exist, otherwise just return existing object.
XSSFFontFormatting | XSSFConditionalFormattingRule.getFontFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFFormulaEvaluator

Packages that use XSSFFormulaEvaluator
org.apache.poi.xssf.usermodel

Uses of XSSFFormulaEvaluator in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFFormulaEvaluator
static XSSFFormulaEvaluator | XSSFFormulaEvaluator.create(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
XSSFFormulaEvaluator | XSSFCreationHelper.createFormulaEvaluator() Creates a XSSFFormulaEvaluator, the object that evaluates formula cells.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFGraphicFrame

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFGraphicFrame

Packages that use XSSFGraphicFrame
org.apache.poi.xssf.usermodel

Uses of XSSFGraphicFrame in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFGraphicFrame
 XSSFGraphicFrame XSSFChart.getGraphicFrame()
Returns the parent graphic frame.

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFGraphicFrame
protected  void XSSFChart.setGraphicFrame(XSSFGraphicFrame frame)
Sets the parent graphic frame.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFHyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFHyperlink

Packages that use XSSFHyperlink
org.apache.poi.xssf.usermodel

Uses of XSSFHyperlink in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFHyperlink
XSSFHyperlink | XSSFCreationHelper.createHyperlink(int type)
XSSFHyperlink | XSSFCell.getHyperlink() Returns hyperlink associated with this cell
XSSFHyperlink | XSSFSheet.getHyperlink(int row, int column)

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFHyperlink
 void XSSFSheet.addHyperlink(XSSFHyperlink hyperlink)
Register a hyperlink in the collection of hyperlinks on this sheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFMap

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFMap

Packages that use XSSFMap
org.apache.poi.xssf.extractor
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel

Uses of XSSFMap in org.apache.poi.xssf.extractor

Constructors in org.apache.poi.xssf.extractor with parameters of type XSSFMap
XSSFExportToXml(XSSFMap map)
Creates a new exporter and sets the mapping to be used when generating the XML output document
XSSFImportFromXML(XSSFMap map)

Uses of XSSFMap in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFMap
XSSFMap | MapInfo.getXSSFMapById(int id)
XSSFMap | MapInfo.getXSSFMapByName(java.lang.String name)

Methods in org.apache.poi.xssf.model that return types with arguments of type XSSFMap
 java.util.Collection<XSSFMap> MapInfo.getAllXSSFMaps()

Uses of XSSFMap in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFMap
 java.util.Collection<XSSFMap> XSSFWorkbook.getCustomXMLMappings()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFName

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFName

Packages that use XSSFName
org.apache.poi.xssf.usermodel

Uses of XSSFName in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFName
XSSFName | XSSFWorkbook.createName()
XSSFName | XSSFWorkbook.getName(java.lang.String name)
XSSFName | XSSFWorkbook.getNameAt(int nameIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFOddFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFOddFooter

No usage of org.apache.poi.xssf.usermodel.XSSFOddFooter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFOddHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFOddHeader

No usage of org.apache.poi.xssf.usermodel.XSSFOddHeader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFPatternFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFPatternFormatting

Packages that use XSSFPatternFormatting
org.apache.poi.xssf.usermodel

Uses of XSSFPatternFormatting in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFPatternFormatting
XSSFPatternFormatting | XSSFConditionalFormattingRule.createPatternFormatting() Create a new pattern formatting structure if it does not exist, otherwise just return existing object.
XSSFPatternFormatting | XSSFConditionalFormattingRule.getPatternFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFPicture

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFPicture

Packages that use XSSFPicture
org.apache.poi.xssf.usermodel

Uses of XSSFPicture in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFPicture
XSSFPicture | XSSFDrawing.createPicture(ClientAnchor anchor, int pictureIndex)
XSSFPicture | XSSFShapeGroup.createPicture(XSSFClientAnchor anchor, int pictureIndex) Creates a picture.
XSSFPicture | XSSFDrawing.createPicture(XSSFClientAnchor anchor, int pictureIndex) Creates a picture.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFPictureData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFPictureData

Packages that use XSSFPictureData
org.apache.poi.xssf.usermodel

Uses of XSSFPictureData in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFPictureData
 XSSFPictureData XSSFPicture.getPictureData()
Return picture data for this shape

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFPictureData
 java.util.List<XSSFPictureData> XSSFWorkbook.getAllPictures()
Gets all pictures from the Workbook.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFPrintSetup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFPrintSetup

Packages that use XSSFPrintSetup
org.apache.poi.xssf.usermodel

Uses of XSSFPrintSetup in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFPrintSetup
 XSSFPrintSetup XSSFSheet.getPrintSetup()
Gets the print setup object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFRelation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFRelation

Packages that use XSSFRelation
org.apache.poi.xssf.extractor
org.apache.poi.xssf.usermodel

Uses of XSSFRelation in org.apache.poi.xssf.extractor

Fields in org.apache.poi.xssf.extractor declared as XSSFRelation
static XSSFRelation[] XSSFExcelExtractor.SUPPORTED_TYPES

Uses of XSSFRelation in org.apache.poi.xssf.usermodel

Fields in org.apache.poi.xssf.usermodel declared as XSSFRelation
static XSSFRelation | XSSFRelation.ACTIVEX_BINS
static XSSFRelation | XSSFRelation.ACTIVEX_CONTROLS
static XSSFRelation | XSSFRelation.CALC_CHAIN
static XSSFRelation | XSSFRelation.CHART
static XSSFRelation | XSSFRelation.CHARTSHEET
static XSSFRelation | XSSFRelation.CUSTOM_XML_MAPPINGS
static XSSFRelation | XSSFRelation.DRAWINGS
static XSSFRelation | XSSFRelation.IMAGE_BMP
static XSSFRelation | XSSFRelation.IMAGE_DIB
static XSSFRelation | XSSFRelation.IMAGE_EMF
static XSSFRelation | XSSFRelation.IMAGE_EPS
static XSSFRelation | XSSFRelation.IMAGE_GIF
static XSSFRelation | XSSFRelation.IMAGE_JPEG
static XSSFRelation | XSSFRelation.IMAGE_PICT
static XSSFRelation | XSSFRelation.IMAGE_PNG
static XSSFRelation | XSSFRelation.IMAGE_TIFF
static XSSFRelation | XSSFRelation.IMAGE_WMF
static XSSFRelation | XSSFRelation.IMAGE_WPG
static XSSFRelation | XSSFRelation.IMAGES
static XSSFRelation | XSSFRelation.MACRO_ADDIN_WORKBOOK
static XSSFRelation | XSSFRelation.MACRO_TEMPLATE_WORKBOOK
static XSSFRelation | XSSFRelation.MACROS_WORKBOOK
static XSSFRelation | XSSFRelation.OLEEMBEDDINGS
static XSSFRelation | XSSFRelation.PACKEMBEDDINGS
static XSSFRelation | XSSFRelation.PRINTER_SETTINGS
static XSSFRelation | XSSFRelation.SHARED_STRINGS
static XSSFRelation | XSSFRelation.SHEET_COMMENTS
static XSSFRelation | XSSFRelation.SHEET_HYPERLINKS
static XSSFRelation | XSSFRelation.SINGLE_XML_CELLS
static XSSFRelation | XSSFRelation.STYLES
static XSSFRelation | XSSFRelation.TABLE
static XSSFRelation | XSSFRelation.TEMPLATE_WORKBOOK
static XSSFRelation | XSSFRelation.THEME
static XSSFRelation | XSSFRelation.VBA_MACROS
static XSSFRelation | XSSFRelation.VML_DRAWINGS
static XSSFRelation | XSSFRelation.WORKBOOK
static XSSFRelation | XSSFRelation.WORKSHEET

Fields in org.apache.poi.xssf.usermodel with type parameters of type XSSFRelation
protected static java.util.Map<java.lang.String,XSSFRelation> XSSFRelation._table
A map to lookup POIXMLRelation by its relation type

Methods in org.apache.poi.xssf.usermodel that return XSSFRelation
static XSSFRelation XSSFRelation.getInstance(java.lang.String rel)
Get POIXMLRelation by relation type

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFRichTextString

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFRichTextString

Packages that use XSSFRichTextString
org.apache.poi.xssf.usermodel

Uses of XSSFRichTextString in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFRichTextString
XSSFRichTextString | XSSFCreationHelper.createRichTextString(java.lang.String text) Creates a new XSSFRichTextString for you.
XSSFRichTextString | XSSFCell.getRichStringCellValue() Get the value of the cell as a XSSFRichTextString
XSSFRichTextString | XSSFComment.getString()
XSSFRichTextString | XSSFChart.getTitle() Returns the title, or null if none is set

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFRichTextString
 void XSSFSimpleShape.setText(XSSFRichTextString str)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFRow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFRow

Packages that use XSSFRow
org.apache.poi.xssf.usermodel

Uses of XSSFRow in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFRow
XSSFRow | XSSFSheet.createRow(int rownum) Create a new row within the sheet and return the high level representation
XSSFRow | XSSFDialogsheet.createRow(int rowNum)
XSSFRow | XSSFCell.getRow() Returns the row this cell belongs to
XSSFRow | XSSFSheet.getRow(int rownum) Returns the logical row ( 0-based).

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFRow
 int XSSFRow.compareTo(XSSFRow row)
Compares two XSSFRow objects.

Constructors in org.apache.poi.xssf.usermodel with parameters of type XSSFRow
XSSFCell(XSSFRow row, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCell cell)
Construct a XSSFCell.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFShape

Packages that use XSSFShape
org.apache.poi.xssf.usermodel

Uses of XSSFShape in org.apache.poi.xssf.usermodel

Subclasses of XSSFShape in org.apache.poi.xssf.usermodel
class | XSSFConnector A connection shape drawing element.
class | XSSFGraphicFrame Represents DrawingML GraphicalObjectFrame.
class | XSSFPicture Represents a picture shape in a SpreadsheetML drawing.
class | XSSFShapeGroup This object specifies a group shape that represents many shapes grouped together.
class | XSSFSimpleShape Represents a shape with a predefined geometry in a SpreadsheetML drawing.
class | XSSFTextBox Represents a text box in a SpreadsheetML drawing.

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFShape
 java.util.List<XSSFShape> XSSFDrawing.getShapes()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFShapeGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFShapeGroup

Packages that use XSSFShapeGroup
org.apache.poi.xssf.usermodel

Uses of XSSFShapeGroup in org.apache.poi.xssf.usermodel

Fields in org.apache.poi.xssf.usermodel declared as XSSFShapeGroup
protected  XSSFShapeGroup XSSFShape.parent
The parent shape, always not-null for shapes in groups

Methods in org.apache.poi.xssf.usermodel that return XSSFShapeGroup
XSSFShapeGroup | XSSFDrawing.createGroup(XSSFClientAnchor anchor) Creates a simple shape.
XSSFShapeGroup | XSSFShape.getParent() Gets the parent shape.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFSheet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFSheet

Packages that use XSSFSheet
org.apache.poi.xssf.model
org.apache.poi.xssf.streaming
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.helpers

Uses of XSSFSheet in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFSheet
 XSSFSheet SingleXmlCells.getXSSFSheet()

Uses of XSSFSheet in org.apache.poi.xssf.streaming

Constructors in org.apache.poi.xssf.streaming with parameters of type XSSFSheet
SXSSFSheet(SXSSFWorkbook workbook, XSSFSheet xSheet)

Uses of XSSFSheet in org.apache.poi.xssf.usermodel

Subclasses of XSSFSheet in org.apache.poi.xssf.usermodel
class | XSSFChartSheet High level representation of Sheet Parts that are of type 'chartsheet'.
class | XSSFDialogsheet

Methods in org.apache.poi.xssf.usermodel that return XSSFSheet
XSSFSheet | XSSFWorkbook.cloneSheet(int sheetNum) Create an XSSFSheet from an existing sheet in the XSSFWorkbook.
XSSFSheet | XSSFWorkbook.createSheet() Create an XSSFSheet for this workbook, adds it to the sheets and returns the high level representation.
XSSFSheet | XSSFWorkbook.createSheet(java.lang.String sheetname) Create a new sheet for this Workbook and return the high level representation.
XSSFSheet | XSSFRow.getSheet() Returns the XSSFSheet this row belongs to
XSSFSheet | XSSFCell.getSheet() Returns the sheet this cell belongs to
XSSFSheet | XSSFWorkbook.getSheet(java.lang.String name) Get sheet with the given name (case insensitive match)
XSSFSheet | XSSFWorkbook.getSheetAt(int index) Get the XSSFSheet object at the given index.
XSSFSheet | XSSFTable.getXSSFSheet()

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFSheet
 java.util.Iterator<XSSFSheet> XSSFWorkbook.iterator()
Allows foreach loops:

Constructors in org.apache.poi.xssf.usermodel with parameters of type XSSFSheet
XSSFDataValidationHelper(XSSFSheet xssfSheet)
XSSFDialogsheet(XSSFSheet sheet)
XSSFRow(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTRow row, XSSFSheet sheet)
Construct a XSSFRow.

Uses of XSSFSheet in org.apache.poi.xssf.usermodel.helpers

Constructors in org.apache.poi.xssf.usermodel.helpers with parameters of type XSSFSheet
XSSFRowShifter(XSSFSheet sh)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFSheetConditionalFormatting

Packages that use XSSFSheetConditionalFormatting
org.apache.poi.xssf.usermodel

Uses of XSSFSheetConditionalFormatting in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFSheetConditionalFormatting
 XSSFSheetConditionalFormatting XSSFSheet.getSheetConditionalFormatting()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFSimpleShape

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFSimpleShape

Packages that use XSSFSimpleShape
org.apache.poi.xssf.usermodel

Uses of XSSFSimpleShape in org.apache.poi.xssf.usermodel

Subclasses of XSSFSimpleShape in org.apache.poi.xssf.usermodel
 class XSSFTextBox
Represents a text box in a SpreadsheetML drawing.

Methods in org.apache.poi.xssf.usermodel that return XSSFSimpleShape
XSSFSimpleShape | XSSFShapeGroup.createSimpleShape(XSSFChildAnchor anchor) Creates a simple shape.
XSSFSimpleShape | XSSFDrawing.createSimpleShape(XSSFClientAnchor anchor) Creates a simple shape.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFTable

Packages that use XSSFTable
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.helpers

Uses of XSSFTable in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFTable
 XSSFTable XSSFSheet.createTable()
Creates a new Table, and associates it with this Sheet

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFTable
java.util.List<XSSFTable> | XSSFMap.getRelatedTables()
java.util.List<XSSFTable> | XSSFSheet.getTables() Returns any tables associated with this Sheet

Uses of XSSFTable in org.apache.poi.xssf.usermodel.helpers

Constructors in org.apache.poi.xssf.usermodel.helpers with parameters of type XSSFTable
XSSFXmlColumnPr(XSSFTable table, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTTableColumn ctTableColum, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXmlColumnPr ctXmlColumnPr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFTextBox

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFTextBox

Packages that use XSSFTextBox
org.apache.poi.xssf.usermodel

Uses of XSSFTextBox in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFTextBox
XSSFTextBox | XSSFShapeGroup.createTextbox(XSSFChildAnchor anchor) Constructs a textbox.
XSSFTextBox | XSSFDrawing.createTextbox(XSSFClientAnchor anchor) Constructs a textbox under the drawing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFVMLDrawing

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFVMLDrawing

Packages that use XSSFVMLDrawing
org.apache.poi.xssf.usermodel

Uses of XSSFVMLDrawing in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFVMLDrawing
protected  XSSFVMLDrawing XSSFSheet.getVMLDrawing(boolean autoCreate)
Get VML drawing for this sheet (aka 'legacy' drawig)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.XSSFWorkbook

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.XSSFWorkbook

Packages that use XSSFWorkbook
org.apache.poi.xssf.extractor
org.apache.poi.xssf.model
org.apache.poi.xssf.streaming
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.helpers

Uses of XSSFWorkbook in org.apache.poi.xssf.extractor

Constructors in org.apache.poi.xssf.extractor with parameters of type XSSFWorkbook
XSSFExcelExtractor(XSSFWorkbook workbook)

Uses of XSSFWorkbook in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFWorkbook
 XSSFWorkbook MapInfo.getWorkbook()
Returns the parent XSSFWorkbook

Uses of XSSFWorkbook in org.apache.poi.xssf.streaming

Methods in org.apache.poi.xssf.streaming that return XSSFWorkbook
 XSSFWorkbook SXSSFWorkbook.getXSSFWorkbook()

Constructors in org.apache.poi.xssf.streaming with parameters of type XSSFWorkbook
SXSSFWorkbook(XSSFWorkbook workbook)
Construct a workbook from a template.
SXSSFWorkbook(XSSFWorkbook workbook, int rowAccessWindowSize)
Constructs an workbook from an existing workbook.
SXSSFWorkbook(XSSFWorkbook workbook, int rowAccessWindowSize, boolean compressTmpFiles)
Constructs an workbook from an existing workbook.

Uses of XSSFWorkbook in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFWorkbook
 XSSFWorkbook XSSFSheet.getWorkbook()
Returns the parent XSSFWorkbook

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFWorkbook
static XSSFEvaluationWorkbook | XSSFEvaluationWorkbook.create(XSSFWorkbook book)
static XSSFFormulaEvaluator | XSSFFormulaEvaluator.create(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier, UDFFinder udfFinder)
static void | XSSFFormulaEvaluator.evaluateAllFormulaCells(XSSFWorkbook wb) Loops over all cells in all sheets of the supplied workbook.

Constructors in org.apache.poi.xssf.usermodel with parameters of type XSSFWorkbook
XSSFFormulaEvaluator(XSSFWorkbook workbook)
XSSFFormulaEvaluator(XSSFWorkbook workbook, IStabilityClassifier stabilityClassifier)
Deprecated. (Sep 2009) (reduce overloading) use XSSFFormulaEvaluator.create(XSSFWorkbook, org.apache.poi.ss.formula.IStabilityClassifier, org.apache.poi.ss.formula.udf.UDFFinder)
XSSFName(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTDefinedName name, XSSFWorkbook workbook)
Creates an XSSFName object - called internally by XSSFWorkbook.

Uses of XSSFWorkbook in org.apache.poi.xssf.usermodel.helpers

Constructors in org.apache.poi.xssf.usermodel.helpers with parameters of type XSSFWorkbook
XSSFFormulaUtils(XSSFWorkbook wb)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xssf.usermodel.extensions
Classes
XSSFCellAlignment
XSSFCellBorder
XSSFCellFill
XSSFHeaderFooter
Enums
XSSFCellBorder.BorderSide


org.apache.poi.xssf.usermodel.extensions

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.usermodel.extensions

Class Summary
XSSFCellAlignment | Cell settings avaiable in the Format/Alignment tab
XSSFCellBorder | This element contains border formatting information, specifying border definition formats (left, right, top, bottom, diagonal) for cells in the workbook.
XSSFCellFill | This element specifies fill formatting.
XSSFHeaderFooter | Parent class of all XSSF headers and footers.

Enum Summary
XSSFCellBorder.BorderSide The enumeration value indicating the side being used for a cell border.


org.apache.poi.xssf.usermodel.extensions Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.usermodel.extensions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment
    • org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder
    • org.apache.poi.xssf.usermodel.extensions.XSSFCellFill
    • org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter (implements org.apache.poi.ss.usermodel.HeaderFooter)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder.BorderSide


Uses of Package org.apache.poi.xssf.usermodel.extensions

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.usermodel.extensions

Packages that use org.apache.poi.xssf.usermodel.extensions
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions

Classes in org.apache.poi.xssf.usermodel.extensions used by org.apache.poi.xssf.model
XSSFCellBorder
This element contains border formatting information, specifying border definition formats (left, right, top, bottom, diagonal) for cells in the workbook.
XSSFCellFill
This element specifies fill formatting.

Classes in org.apache.poi.xssf.usermodel.extensions used by org.apache.poi.xssf.usermodel
XSSFCellAlignment
Cell settings avaiable in the Format/Alignment tab
XSSFCellBorder.BorderSide
The enumeration value indicating the side being used for a cell border.
XSSFHeaderFooter
Parent class of all XSSF headers and footers.

Classes in org.apache.poi.xssf.usermodel.extensions used by org.apache.poi.xssf.usermodel.extensions
XSSFCellBorder.BorderSide
The enumeration value indicating the side being used for a cell border.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSSFCellAlignment

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.extensions
Class XSSFCellAlignment

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment

public class XSSFCellAlignment
extends java.lang.Object

Cell settings avaiable in the Format/Alignment tab

Constructor Summary
XSSFCellAlignment(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCellAlignment cellAlignment)
Creates a Cell Alignment from the supplied XML definition
Method Summary
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCellAlignment | getCTCellAlignment() Access to low-level data
HorizontalAlignment | getHorizontal() Get the type of horizontal alignment for the cell
long | getIndent() Get the number of spaces to indent the text in the cell
long | getTextRotation() Get the degree of rotation for the text in the cell Expressed in degrees.
VerticalAlignment | getVertical() Get the type of vertical alignment for the cell
boolean | getWrapText() Whether the text should be wrapped
void | setHorizontal(HorizontalAlignment align) Set the type of horizontal alignment for the cell
void | setIndent(long indent) Set the number of spaces to indent the text in the cell
void | setTextRotation(long rotation) Set the degree of rotation for the text in the cell Expressed in degrees.
void | setVertical(VerticalAlignment align) Set the type of vertical alignment for the cell
void | setWrapText(boolean wrapped) Set whether the text should be wrapped
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFCellAlignment

public XSSFCellAlignment(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCellAlignment cellAlignment)
Creates a Cell Alignment from the supplied XML definition

Parameters:
cellAlignment -
Method Detail

getVertical

public VerticalAlignment getVertical()
Get the type of vertical alignment for the cell

Returns:
the type of aligment
See Also:
VerticalAlignment

setVertical

public void setVertical(VerticalAlignment align)
Set the type of vertical alignment for the cell

Parameters:
align - - the type of alignment
See Also:
VerticalAlignment

getHorizontal

public HorizontalAlignment getHorizontal()
Get the type of horizontal alignment for the cell

Returns:
the type of aligment
See Also:
HorizontalAlignment

setHorizontal

public void setHorizontal(HorizontalAlignment align)
Set the type of horizontal alignment for the cell

Parameters:
align - - the type of alignment
See Also:
HorizontalAlignment

getIndent

public long getIndent()
Get the number of spaces to indent the text in the cell

Returns:
indent - number of spaces

setIndent

public void setIndent(long indent)
Set the number of spaces to indent the text in the cell

Parameters:
indent - - number of spaces

getTextRotation

public long getTextRotation()
Get the degree of rotation for the text in the cell

Expressed in degrees. Values range from 0 to 180. The first letter of the text is considered the center-point of the arc.
For 0 - 90, the value represents degrees above horizon. For 91-180 the degrees below the horizon is calculated as:
[degrees below horizon] = 90 - textRotation.

Returns:
rotation degrees (between 0 and 180 degrees)

setTextRotation

public void setTextRotation(long rotation)
Set the degree of rotation for the text in the cell

Expressed in degrees. Values range from 0 to 180. The first letter of the text is considered the center-point of the arc.
For 0 - 90, the value represents degrees above horizon. For 91-180 the degrees below the horizon is calculated as:
[degrees below horizon] = 90 - textRotation.

Parameters:
rotation - - the rotation degrees (between 0 and 180 degrees)

getWrapText

public boolean getWrapText()
Whether the text should be wrapped

Returns:
a boolean value indicating if the text in a cell should be line-wrapped within the cell.

setWrapText

public void setWrapText(boolean wrapped)
Set whether the text should be wrapped

Parameters:
wrapped - a boolean value indicating if the text in a cell should be line-wrapped within the cell.

getCTCellAlignment

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCellAlignment getCTCellAlignment()
Access to low-level data

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XSSFCellBorder.BorderSide

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xssf.usermodel.extensions
Enum XSSFCellBorder.BorderSide

java.lang.Object
    extended by  java.lang.Enum<XSSFCellBorder.BorderSide>
        extended by  org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder.BorderSide
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<XSSFCellBorder.BorderSide>
Enclosing class:
XSSFCellBorder
public static enum XSSFCellBorder.BorderSide
extends java.lang.Enum<XSSFCellBorder.BorderSide>

The enumeration value indicating the side being used for a cell border.

Enum Constant Summary
BOTTOM
LEFT
RIGHT
TOP
Method Summary
static XSSFCellBorder.BorderSide | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XSSFCellBorder.BorderSide[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TOP

public static final XSSFCellBorder.BorderSide TOP

RIGHT

public static final XSSFCellBorder.BorderSide RIGHT

BOTTOM

public static final XSSFCellBorder.BorderSide BOTTOM

LEFT

public static final XSSFCellBorder.BorderSide LEFT
Method Detail

values

public static XSSFCellBorder.BorderSide[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (XSSFCellBorder.BorderSide c : XSSFCellBorder.BorderSide.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static XSSFCellBorder.BorderSide valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


XSSFCellBorder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.extensions
Class XSSFCellBorder

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder

public class XSSFCellBorder
extends java.lang.Object

This element contains border formatting information, specifying border definition formats (left, right, top, bottom, diagonal) for cells in the workbook. Color is optional.

Nested Class Summary
static class XSSFCellBorder.BorderSide
The enumeration value indicating the side being used for a cell border.
Constructor Summary
XSSFCellBorder()
Creates a new, empty Cell Border.
XSSFCellBorder(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder border)
Creates a Cell Border from the supplied XML definition
XSSFCellBorder(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder border, ThemesTable theme)
Creates a Cell Border from the supplied XML definition
Method Summary
boolean | equals(java.lang.Object o)
XSSFColor | getBorderColor(XSSFCellBorder.BorderSide side) Get the color to use for the selected border
BorderStyle | getBorderStyle(XSSFCellBorder.BorderSide side) Get the type of border to use for the selected border
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder | getCTBorder() Returns the underlying XML bean.
int | hashCode()
void | setBorderColor(XSSFCellBorder.BorderSide side, XSSFColor color) Set the color to use for the selected border
void | setBorderStyle(XSSFCellBorder.BorderSide side, BorderStyle style) Set the type of border to use for the selected border
void | setThemesTable(ThemesTable themes) Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFCellBorder

public XSSFCellBorder(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder border,
                      ThemesTable theme)
Creates a Cell Border from the supplied XML definition

XSSFCellBorder

public XSSFCellBorder(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder border)
Creates a Cell Border from the supplied XML definition

XSSFCellBorder

public XSSFCellBorder()
Creates a new, empty Cell Border. You need to attach this to the Styles Table

Method Detail

setThemesTable

public void setThemesTable(ThemesTable themes)
Records the Themes Table that is associated with the current font, used when looking up theme based colours and properties.

getCTBorder

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTBorder getCTBorder()
Returns the underlying XML bean.

Returns:
CTBorder

getBorderStyle

public BorderStyle getBorderStyle(XSSFCellBorder.BorderSide side)
Get the type of border to use for the selected border

Parameters:
side - - - where to apply the color definition
Returns:
borderstyle - the type of border to use. default value is NONE if border style is not set.
See Also:
BorderStyle

setBorderStyle

public void setBorderStyle(XSSFCellBorder.BorderSide side,
                           BorderStyle style)
Set the type of border to use for the selected border

Parameters:
side - - - where to apply the color definition
style - - border style
See Also:
BorderStyle

getBorderColor

public XSSFColor getBorderColor(XSSFCellBorder.BorderSide side)
Get the color to use for the selected border

Parameters:
side - - where to apply the color definition
Returns:
color - color to use as XSSFColor. null if color is not set

setBorderColor

public void setBorderColor(XSSFCellBorder.BorderSide side,
                           XSSFColor color)
Set the color to use for the selected border

Parameters:
side - - where to apply the color definition
color - - the color to use

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFCellFill

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.extensions
Class XSSFCellFill

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFCellFill

public final class XSSFCellFill
extends java.lang.Object

This element specifies fill formatting. A cell fill consists of a background color, foreground color, and pattern to be applied across the cell.

Constructor Summary
XSSFCellFill()
Creates an empty CellFill
XSSFCellFill(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFill fill)
Creates a CellFill from the supplied parts
Method Summary
boolean | equals(java.lang.Object o)
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFill | getCTFill() Returns the underlying XML bean.
XSSFColor | getFillBackgroundColor() Get the background fill color.
XSSFColor | getFillForegroundColor() Get the foreground fill color.
org.openxmlformats.schemas.spreadsheetml.x2006.main.STPatternType.Enum | getPatternType() get the fill pattern
int | hashCode()
void | setFillBackgroundColor(int index) Set the background fill color represented as a indexed color value.
void | setFillBackgroundColor(XSSFColor color) Set the background fill color represented as a XSSFColor value.
void | setFillForegroundColor(int index) Set the foreground fill color as a indexed color value
void | setFillForegroundColor(XSSFColor color) Set the foreground fill color represented as a XSSFColor value.
void | setPatternType(org.openxmlformats.schemas.spreadsheetml.x2006.main.STPatternType.Enum patternType) set the fill pattern
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFCellFill

public XSSFCellFill(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFill fill)
Creates a CellFill from the supplied parts

Parameters:
fill - - fill

XSSFCellFill

public XSSFCellFill()
Creates an empty CellFill

Method Detail

getFillBackgroundColor

public XSSFColor getFillBackgroundColor()
Get the background fill color.

Returns:
fill color, null if color is not set

setFillBackgroundColor

public void setFillBackgroundColor(int index)
Set the background fill color represented as a indexed color value.

Parameters:
index -

setFillBackgroundColor

public void setFillBackgroundColor(XSSFColor color)
Set the background fill color represented as a XSSFColor value.

Parameters:
color -

getFillForegroundColor

public XSSFColor getFillForegroundColor()
Get the foreground fill color.

Returns:
XSSFColor - foreground color. null if color is not set

setFillForegroundColor

public void setFillForegroundColor(int index)
Set the foreground fill color as a indexed color value

Parameters:
index - - the color to use

setFillForegroundColor

public void setFillForegroundColor(XSSFColor color)
Set the foreground fill color represented as a XSSFColor value.

Parameters:
color - - the color to use

getPatternType

public org.openxmlformats.schemas.spreadsheetml.x2006.main.STPatternType.Enum getPatternType()
get the fill pattern

Returns:
fill pattern type. null if fill pattern is not set

setPatternType

public void setPatternType(org.openxmlformats.schemas.spreadsheetml.x2006.main.STPatternType.Enum patternType)
set the fill pattern

Parameters:
patternType - fill pattern to use

getCTFill

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFill getCTFill()
Returns the underlying XML bean.

Returns:
CTFill

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFHeaderFooter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.extensions
Class XSSFHeaderFooter

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter
All Implemented Interfaces:
HeaderFooter
Direct Known Subclasses:
XSSFEvenFooter, XSSFEvenHeader, XSSFFirstFooter, XSSFFirstHeader, XSSFOddFooter, XSSFOddHeader
public abstract class XSSFHeaderFooter
extends java.lang.Object
implements HeaderFooter

Parent class of all XSSF headers and footers. For a list of all the different fields that can be placed into a header or footer, such as page number, bold, underline etc, see the follow formatting syntax Header/Footer Formatting Syntax

There are a number of formatting codes that can be written inline with the actual header / footer text, which affect the formatting in the header or footer.

This example shows the text "Center Bold Header" on the first line (center section), and the date on the second line (center section). &CCenter &"-,Bold"Bold &"-,Regular"Header_x000A_&D General Rules: There is no required order in which these codes must appear. The first occurrence of the following codes turns the formatting ON, the second occurrence turns it OFF again:
&L
code for "left section" (there are three header / footer locations, "left", "center", and "right"). When two or more occurrences of this section marker exist, the contents from all markers are concatenated, in the order of appearance, and placed into the left section.
&P
code for "current page #"
&N
code for "total pages"
&font size
code for "text font size", where font size is a font size in points.
&K
code for "text font color" RGB Color is specified as RRGGBB Theme Color is specifed as TTSNN where TT is the theme color Id, S is either "+" or "-" of the tint/shade value, NN is the tint/shade value.
&S
code for "text strikethrough" on / off
&X
code for "text super script" on / off
&Y
code for "text subscript" on / off
&C
code for "center section". When two or more occurrences of this section marker exist, the contents from all markers are concatenated, in the order of appearance, and placed into the center section. SpreadsheetML Reference Material - Worksheets 1966
&D
code for "date"
&T
code for "time"
&G
code for "picture as background"
&U
code for "text single underline"
&E
code for "double underline"
&R
code for "right section". When two or more occurrences of this section marker exist, the contents from all markers are concatenated, in the order of appearance, and placed into the right section.
&Z
code for "this workbook's file path"
&F
code for "this workbook's file name"
&A
code for "sheet tab name"
&+
code for add to page #.
&-
code for subtract from page #.
&"font name,font type" - code for "text font name" and "text font type", where font name and font type are strings specifying the name and type of the font, separated by a comma. When a hyphen appears in font name, it means "none specified". Both of font name and font type can be localized values.
&"-,Bold"
code for "bold font style"
&B
also means "bold font style"
&"-,Regular"
code for "regular font style"
&"-,Italic"
code for "italic font style"
&I
also means "italic font style"
&"-,Bold Italic"
code for "bold italic font style"
&O
code for "outline style"
&H
code for "shadow style"

Constructor Summary
XSSFHeaderFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFHeaderFooter from the supplied XML bean
Method Summary
boolean | areFieldsStripped() Are fields currently being stripped from the text that this XSSFHeaderFooter returns? Default is false, but can be changed
java.lang.String | getCenter() get the text representing the center part of this element
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter | getHeaderFooter() Returns the underlying CTHeaderFooter xml bean
java.lang.String | getLeft() get the text representing the left part of this element
java.lang.String | getRight() get the text representing the right part of this element
abstract java.lang.String | getText()
java.lang.String | getValue()
void | setAreFieldsStripped(boolean stripFields) Should fields (eg macros) be stripped from the text that this class returns? Default is not to strip.
void | setCenter(java.lang.String newCenter) set a centered string value for this element
void | setLeft(java.lang.String newLeft) set a left string value for this element
void | setRight(java.lang.String newRight) set a right string value for this element
protected abstract void | setText(java.lang.String text)
static java.lang.String | stripFields(java.lang.String text) Removes any fields (eg macros, page markers etc) from the string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFHeaderFooter

public XSSFHeaderFooter(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter headerFooter)
Create an instance of XSSFHeaderFooter from the supplied XML bean

Parameters:
headerFooter -
Method Detail

getHeaderFooter

@Internal
public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTHeaderFooter getHeaderFooter()
Returns the underlying CTHeaderFooter xml bean

Returns:
the underlying CTHeaderFooter xml bean

getValue

public java.lang.String getValue()

areFieldsStripped

public boolean areFieldsStripped()
Are fields currently being stripped from the text that this XSSFHeaderFooter returns? Default is false, but can be changed

setAreFieldsStripped

public void setAreFieldsStripped(boolean stripFields)
Should fields (eg macros) be stripped from the text that this class returns? Default is not to strip.

Parameters:
stripFields -

stripFields

public static java.lang.String stripFields(java.lang.String text)
Removes any fields (eg macros, page markers etc) from the string. Normally used to make some text suitable for showing to humans, and the resultant text should not normally be saved back into the document!

getText

public abstract java.lang.String getText()

setText

protected abstract void setText(java.lang.String text)

getCenter

public java.lang.String getCenter()
get the text representing the center part of this element

Specified by:
getCenter in interface HeaderFooter
Returns:
The string representing the center.

getLeft

public java.lang.String getLeft()
get the text representing the left part of this element

Specified by:
getLeft in interface HeaderFooter
Returns:
The string representing the left side.

getRight

public java.lang.String getRight()
get the text representing the right part of this element

Specified by:
getRight in interface HeaderFooter
Returns:
The string representing the right side.

setCenter

public void setCenter(java.lang.String newCenter)
set a centered string value for this element

Specified by:
setCenter in interface HeaderFooter
Parameters:
newCenter - The string to set as the center.

setLeft

public void setLeft(java.lang.String newLeft)
set a left string value for this element

Specified by:
setLeft in interface HeaderFooter
Parameters:
newLeft - The string to set as the left side.

setRight

public void setRight(java.lang.String newRight)
set a right string value for this element

Specified by:
setRight in interface HeaderFooter
Parameters:
newRight - The string to set as the right side.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.extensions.XSSFCellAlignment

Packages that use XSSFCellAlignment
org.apache.poi.xssf.usermodel

Uses of XSSFCellAlignment in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return XSSFCellAlignment
protected  XSSFCellAlignment XSSFCellStyle.getCellAlignment()
get the cellAlignment object to use for manage alignment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder.BorderSide

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder.BorderSide

Packages that use XSSFCellBorder.BorderSide
org.apache.poi.xssf.usermodel
org.apache.poi.xssf.usermodel.extensions

Uses of XSSFCellBorder.BorderSide in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel with parameters of type XSSFCellBorder.BorderSide
XSSFColor | XSSFCellStyle.getBorderColor(XSSFCellBorder.BorderSide side) Gets border color
void | XSSFCellStyle.setBorderColor(XSSFCellBorder.BorderSide side, XSSFColor color) Set the color to use for the selected border

Uses of XSSFCellBorder.BorderSide in org.apache.poi.xssf.usermodel.extensions

Methods in org.apache.poi.xssf.usermodel.extensions that return XSSFCellBorder.BorderSide
static XSSFCellBorder.BorderSide | XSSFCellBorder.BorderSide.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XSSFCellBorder.BorderSide[] | XSSFCellBorder.BorderSide.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xssf.usermodel.extensions with parameters of type XSSFCellBorder.BorderSide
XSSFColor | XSSFCellBorder.getBorderColor(XSSFCellBorder.BorderSide side) Get the color to use for the selected border
BorderStyle | XSSFCellBorder.getBorderStyle(XSSFCellBorder.BorderSide side) Get the type of border to use for the selected border
void | XSSFCellBorder.setBorderColor(XSSFCellBorder.BorderSide side, XSSFColor color) Set the color to use for the selected border
void | XSSFCellBorder.setBorderStyle(XSSFCellBorder.BorderSide side, BorderStyle style) Set the type of border to use for the selected border

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.extensions.XSSFCellBorder

Packages that use XSSFCellBorder
org.apache.poi.xssf.model

Uses of XSSFCellBorder in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFCellBorder
 XSSFCellBorder StylesTable.getBorderAt(int idx)

Methods in org.apache.poi.xssf.model that return types with arguments of type XSSFCellBorder
 java.util.List<XSSFCellBorder> StylesTable.getBorders()

Methods in org.apache.poi.xssf.model with parameters of type XSSFCellBorder
 int StylesTable.putBorder(XSSFCellBorder border)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.extensions.XSSFCellFill

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.extensions.XSSFCellFill

Packages that use XSSFCellFill
org.apache.poi.xssf.model

Uses of XSSFCellFill in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return XSSFCellFill
 XSSFCellFill StylesTable.getFillAt(int idx)

Methods in org.apache.poi.xssf.model that return types with arguments of type XSSFCellFill
 java.util.List<XSSFCellFill> StylesTable.getFills()

Methods in org.apache.poi.xssf.model with parameters of type XSSFCellFill
 int StylesTable.putFill(XSSFCellFill fill)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.extensions.XSSFHeaderFooter

Packages that use XSSFHeaderFooter
org.apache.poi.xssf.usermodel

Uses of XSSFHeaderFooter in org.apache.poi.xssf.usermodel

Subclasses of XSSFHeaderFooter in org.apache.poi.xssf.usermodel
class | XSSFEvenFooter Even page footer value.
class | XSSFEvenHeader Even page header value.
class | XSSFFirstFooter First page footer content.
class | XSSFFirstHeader First page header content.
class | XSSFOddFooter Odd page footer value.
class | XSSFOddHeader Odd page header value.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ColumnHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.helpers
Class ColumnHelper

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.helpers.ColumnHelper

public class ColumnHelper
extends java.lang.Object

Helper class for dealing with the Column settings on a CTWorksheet (the data part of a sheet). Note - within POI, we use 0 based column indexes, but the column definitions in the XML are 1 based!

Constructor Summary
ColumnHelper(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet worksheet)
Method Summary
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols | addCleanColIntoCols(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol col)
void | cleanColumns()
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol | cloneCol(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol col)
boolean | columnExists(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols, long index) Does the column at the given 0 based index exist in the supplied list of column definitions?
int | getColDefaultStyle(long index)
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol | getColumn(long index, boolean splitColumns) Returns the Column at the given 0 based index
org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol | getColumn1Based(long index1, boolean splitColumns) Returns the Column at the given 1 based index.
int | getIndexOfColumn(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol col)
protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol | getOrCreateColumn1Based(long index1, boolean splitColumns) Return the CTCol at the given (0 based) column index, creating it if required.
void | setColBestFit(long index, boolean bestFit)
void | setColDefaultStyle(long index, CellStyle style)
void | setColDefaultStyle(long index, int styleId)
void | setColHidden(long index, boolean hidden)
void | setColumnAttributes(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol fromCol, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol toCol)
void | setColWidth(long index, double width)
void | setCustomWidth(long index, boolean bestFit)
static void | sortColumns(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols newCols)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ColumnHelper

public ColumnHelper(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorksheet worksheet)
Method Detail

cleanColumns

public void cleanColumns()

sortColumns

public static void sortColumns(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols newCols)

cloneCol

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol cloneCol(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols,
                                                                          org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol col)

getColumn

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol getColumn(long index,
                                                                           boolean splitColumns)
Returns the Column at the given 0 based index

getColumn1Based

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol getColumn1Based(long index1,
                                                                                boolean splitColumns)
Returns the Column at the given 1 based index. POI default is 0 based, but the file stores as 1 based.

addCleanColIntoCols

public org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols addCleanColIntoCols(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols,
                                                                                org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol col)

columnExists

public boolean columnExists(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols,
                            long index)
Does the column at the given 0 based index exist in the supplied list of column definitions?

setColumnAttributes

public void setColumnAttributes(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol fromCol,
                                org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol toCol)

setColBestFit

public void setColBestFit(long index,
                          boolean bestFit)

setCustomWidth

public void setCustomWidth(long index,
                           boolean bestFit)

setColWidth

public void setColWidth(long index,
                        double width)

setColHidden

public void setColHidden(long index,
                         boolean hidden)

getOrCreateColumn1Based

protected org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol getOrCreateColumn1Based(long index1,
                                                                                boolean splitColumns)
Return the CTCol at the given (0 based) column index, creating it if required.

setColDefaultStyle

public void setColDefaultStyle(long index,
                               CellStyle style)

setColDefaultStyle

public void setColDefaultStyle(long index,
                               int styleId)

getColDefaultStyle

public int getColDefaultStyle(long index)

getIndexOfColumn

public int getIndexOfColumn(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCols cols,
                            org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol col)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HeaderFooterHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.helpers
Class HeaderFooterHelper

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

public class HeaderFooterHelper
extends java.lang.Object

Field Summary
static java.lang.String | HeaderFooterEntity_Date
static java.lang.String | HeaderFooterEntity_File
static java.lang.String | HeaderFooterEntity_Time
Constructor Summary
HeaderFooterHelper()
Method Summary
java.lang.String | getCenterSection(java.lang.String string)
java.lang.String | getLeftSection(java.lang.String string)
java.lang.String | getRightSection(java.lang.String string)
java.lang.String | setCenterSection(java.lang.String string, java.lang.String newCenter)
java.lang.String | setLeftSection(java.lang.String string, java.lang.String newLeft)
java.lang.String | setRightSection(java.lang.String string, java.lang.String newRight)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HeaderFooterEntity_File

public static final java.lang.String HeaderFooterEntity_File
See Also:
Constant Field Values

HeaderFooterEntity_Date

public static final java.lang.String HeaderFooterEntity_Date
See Also:
Constant Field Values

HeaderFooterEntity_Time

public static final java.lang.String HeaderFooterEntity_Time
See Also:
Constant Field Values
Constructor Detail

HeaderFooterHelper

public HeaderFooterHelper()
Method Detail

getLeftSection

public java.lang.String getLeftSection(java.lang.String string)

getCenterSection

public java.lang.String getCenterSection(java.lang.String string)

getRightSection

public java.lang.String getRightSection(java.lang.String string)

setLeftSection

public java.lang.String setLeftSection(java.lang.String string,
                                       java.lang.String newLeft)

setCenterSection

public java.lang.String setCenterSection(java.lang.String string,
                                         java.lang.String newCenter)

setRightSection

public java.lang.String setRightSection(java.lang.String string,
                                        java.lang.String newRight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.xssf.usermodel.helpers
Classes
ColumnHelper
HeaderFooterHelper
XSSFFormulaUtils
XSSFRowShifter
XSSFSingleXmlCell
XSSFXmlColumnPr


org.apache.poi.xssf.usermodel.helpers

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.usermodel.helpers

Class Summary
ColumnHelper | Helper class for dealing with the Column settings on a CTWorksheet (the data part of a sheet).
HeaderFooterHelper |
XSSFFormulaUtils | Utility to update formulas and named ranges when a sheet name was changed
XSSFRowShifter |
XSSFSingleXmlCell | This class is a wrapper around the CTSingleXmlCell (Open Office XML Part 4: chapter 3.5.2.1)
XSSFXmlColumnPr | This class is a wrapper around the CTXmlColumnPr (Open Office XML Part 4: chapter 3.5.1.7)


org.apache.poi.xssf.usermodel.helpers Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.usermodel.helpers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xssf.usermodel.helpers.ColumnHelper
    • org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper
    • org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils
    • org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter
    • org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell
    • org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr


Uses of Package org.apache.poi.xssf.usermodel.helpers

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.usermodel.helpers

Packages that use org.apache.poi.xssf.usermodel.helpers
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel

Classes in org.apache.poi.xssf.usermodel.helpers used by org.apache.poi.xssf.model
XSSFSingleXmlCell
This class is a wrapper around the CTSingleXmlCell (Open Office XML Part 4: chapter 3.5.2.1)

Classes in org.apache.poi.xssf.usermodel.helpers used by org.apache.poi.xssf.usermodel
ColumnHelper
Helper class for dealing with the Column settings on a CTWorksheet (the data part of a sheet).
XSSFSingleXmlCell
This class is a wrapper around the CTSingleXmlCell (Open Office XML Part 4: chapter 3.5.2.1)
XSSFXmlColumnPr
This class is a wrapper around the CTXmlColumnPr (Open Office XML Part 4: chapter 3.5.1.7)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XSSFFormulaUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.helpers
Class XSSFFormulaUtils

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils

public final class XSSFFormulaUtils
extends java.lang.Object

Utility to update formulas and named ranges when a sheet name was changed

Author:
Yegor Kozlov

Constructor Summary
XSSFFormulaUtils(XSSFWorkbook wb)
Method Summary
 void updateSheetName(int sheetIndex, java.lang.String name)
Update sheet name in all formulas and named ranges.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFFormulaUtils

public XSSFFormulaUtils(XSSFWorkbook wb)
Method Detail

updateSheetName

public void updateSheetName(int sheetIndex,
                            java.lang.String name)
Update sheet name in all formulas and named ranges. Called from XSSFWorkbook.setSheetName(int, String)

The idea is to parse every formula and render it back to string with the updated sheet name. The FormulaParsingWorkbook passed to the formula parser is constructed from the old workbook (sheet name is not yet updated) and the FormulaRenderingWorkbook passed to FormulaRenderer#toFormulaString is a custom implementation that returns the new sheet name.

Parameters:
sheetIndex - the 0-based index of the sheet being changed
name - the new sheet name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFRowShifter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.helpers
Class XSSFRowShifter

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter

public final class XSSFRowShifter
extends java.lang.Object

Author:
Yegor Kozlov

Constructor Summary
XSSFRowShifter(XSSFSheet sh)
Method Summary
java.util.List<CellRangeAddress> | shiftMerged(int startRow, int endRow, int n) Shift merged regions
void | updateConditionalFormatting(FormulaShifter shifter)
void | updateFormulas(FormulaShifter shifter) Update formulas.
void | updateNamedRanges(FormulaShifter shifter) Updated named ranges
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFRowShifter

public XSSFRowShifter(XSSFSheet sh)
Method Detail

shiftMerged

public java.util.List<CellRangeAddress> shiftMerged(int startRow,
                                                    int endRow,
                                                    int n)
Shift merged regions

Parameters:
startRow - the row to start shifting
endRow - the row to end shifting
n - the number of rows to shift
Returns:
an array of affected cell regions

updateNamedRanges

public void updateNamedRanges(FormulaShifter shifter)
Updated named ranges

updateFormulas

public void updateFormulas(FormulaShifter shifter)
Update formulas.

updateConditionalFormatting

public void updateConditionalFormatting(FormulaShifter shifter)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFSingleXmlCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.helpers
Class XSSFSingleXmlCell

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell

public class XSSFSingleXmlCell
extends java.lang.Object

This class is a wrapper around the CTSingleXmlCell (Open Office XML Part 4: chapter 3.5.2.1)

Author:
Roberto Manicardi

Constructor Summary
XSSFSingleXmlCell(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSingleXmlCell singleXmlCell, SingleXmlCells parent)
Method Summary
long | getMapId()
XSSFCell | getReferencedCell() Gets the XSSFCell referenced by the R attribute or creates a new one if cell doesn't exists
org.openxmlformats.schemas.spreadsheetml.x2006.main.STXmlDataType.Enum | getXmlDataType()
java.lang.String | getXpath()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFSingleXmlCell

public XSSFSingleXmlCell(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSingleXmlCell singleXmlCell,
                         SingleXmlCells parent)
Method Detail

getReferencedCell

public XSSFCell getReferencedCell()
Gets the XSSFCell referenced by the R attribute or creates a new one if cell doesn't exists

Returns:
the referenced XSSFCell, null if the cell reference is invalid

getXpath

public java.lang.String getXpath()

getMapId

public long getMapId()

getXmlDataType

public org.openxmlformats.schemas.spreadsheetml.x2006.main.STXmlDataType.Enum getXmlDataType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSSFXmlColumnPr

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.usermodel.helpers
Class XSSFXmlColumnPr

java.lang.Object
    extended by  org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr

public class XSSFXmlColumnPr
extends java.lang.Object

This class is a wrapper around the CTXmlColumnPr (Open Office XML Part 4: chapter 3.5.1.7)

Author:
Roberto Manicardi

Constructor Summary
XSSFXmlColumnPr(XSSFTable table, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTTableColumn ctTableColum, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXmlColumnPr ctXmlColumnPr)
Method Summary
long | getId() (see Open Office XML Part 4: chapter 3.5.1.3)
java.lang.String | getLocalXPath() If the XPath is, for example, /Node1/Node2/Node3 and /Node1/Node2 is the common XPath for the table, the local XPath is /Node3
long | getMapId()
org.openxmlformats.schemas.spreadsheetml.x2006.main.STXmlDataType.Enum | getXmlDataType()
java.lang.String | getXPath()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XSSFXmlColumnPr

public XSSFXmlColumnPr(XSSFTable table,
                       org.openxmlformats.schemas.spreadsheetml.x2006.main.CTTableColumn ctTableColum,
                       org.openxmlformats.schemas.spreadsheetml.x2006.main.CTXmlColumnPr ctXmlColumnPr)
Method Detail

getMapId

public long getMapId()

getXPath

public java.lang.String getXPath()

getId

public long getId()
(see Open Office XML Part 4: chapter 3.5.1.3)

Returns:
An integer representing the unique identifier of this column.

getLocalXPath

public java.lang.String getLocalXPath()
If the XPath is, for example, /Node1/Node2/Node3 and /Node1/Node2 is the common XPath for the table, the local XPath is /Node3

Returns:
the local XPath

getXmlDataType

public org.openxmlformats.schemas.spreadsheetml.x2006.main.STXmlDataType.Enum getXmlDataType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xssf.usermodel.helpers.ColumnHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.helpers.ColumnHelper

Packages that use ColumnHelper
org.apache.poi.xssf.usermodel

Uses of ColumnHelper in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return ColumnHelper
 ColumnHelper XSSFSheet.getColumnHelper()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

No usage of org.apache.poi.xssf.usermodel.helpers.HeaderFooterHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils

No usage of org.apache.poi.xssf.usermodel.helpers.XSSFFormulaUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter

No usage of org.apache.poi.xssf.usermodel.helpers.XSSFRowShifter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.helpers.XSSFSingleXmlCell

Packages that use XSSFSingleXmlCell
org.apache.poi.xssf.model
org.apache.poi.xssf.usermodel

Uses of XSSFSingleXmlCell in org.apache.poi.xssf.model

Methods in org.apache.poi.xssf.model that return types with arguments of type XSSFSingleXmlCell
 java.util.List<XSSFSingleXmlCell> SingleXmlCells.getAllSimpleXmlCell()

Uses of XSSFSingleXmlCell in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFSingleXmlCell
 java.util.List<XSSFSingleXmlCell> XSSFMap.getRelatedSingleXMLCell()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.usermodel.helpers.XSSFXmlColumnPr

Packages that use XSSFXmlColumnPr
org.apache.poi.xssf.usermodel

Uses of XSSFXmlColumnPr in org.apache.poi.xssf.usermodel

Methods in org.apache.poi.xssf.usermodel that return types with arguments of type XSSFXmlColumnPr
 java.util.List<XSSFXmlColumnPr> XSSFTable.getXmlColumnPrs()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CTColComparator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.util
Class CTColComparator

java.lang.Object
    extended by  org.apache.poi.xssf.util.CTColComparator
All Implemented Interfaces:
java.util.Comparator<org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol>
public class CTColComparator
extends java.lang.Object
implements java.util.Comparator<org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol>

Constructor Summary
CTColComparator()
Method Summary
 int compare(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol o1, org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol o2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

CTColComparator

public CTColComparator()
Method Detail

compare

public int compare(org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol o1,
                   org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol o2)
Specified by:
compare in interface java.util.Comparator<org.openxmlformats.schemas.spreadsheetml.x2006.main.CTCol>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EvilUnclosedBRFixingInputStream

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.util
Class EvilUnclosedBRFixingInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream
All Implemented Interfaces:
java.io.Closeable
public class EvilUnclosedBRFixingInputStream
extends java.io.InputStream

This is a seriously sick fix for the fact that some .xlsx files contain raw bits of HTML, without being escaped or properly turned into XML. The result is that they contain things like >br<, which breaks the XML parsing. This very sick InputStream wrapper attempts to spot these go past, and fix them. Only works for UTF-8 and US-ASCII based streams! It should only be used where experience shows the problem can occur...

Constructor Summary
EvilUnclosedBRFixingInputStream(java.io.InputStream source)
Method Summary
int | read() Warning - doesn't fix!
int | read(byte[] b)
int | read(byte[] b, int off, int len)
Methods inherited from class java.io.InputStream
available, close, mark, markSupported, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EvilUnclosedBRFixingInputStream

public EvilUnclosedBRFixingInputStream(java.io.InputStream source)
Method Detail

read

public int read()
         throws java.io.IOException
Warning - doesn't fix!

Specified by:
read in class java.io.InputStream
Throws:
java.io.IOException

read

public int read(byte[] b,
                int off,
                int len)
         throws java.io.IOException
Overrides:
read in class java.io.InputStream
Throws:
java.io.IOException

read

public int read(byte[] b)
         throws java.io.IOException
Overrides:
read in class java.io.InputStream
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumericRanges

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xssf.util
Class NumericRanges

java.lang.Object
    extended by  org.apache.poi.xssf.util.NumericRanges

public class NumericRanges
extends java.lang.Object

Field Summary
static int | NO_OVERLAPS
static int | OVERLAPS_1_MINOR
static int | OVERLAPS_1_WRAPS
static int | OVERLAPS_2_MINOR
static int | OVERLAPS_2_WRAPS
Constructor Summary
NumericRanges()
Method Summary
static long[] | getOverlappingRange(long[] range1, long[] range2)
static int | getOverlappingType(long[] range1, long[] range2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_OVERLAPS

public static int NO_OVERLAPS

OVERLAPS_1_MINOR

public static int OVERLAPS_1_MINOR

OVERLAPS_2_MINOR

public static int OVERLAPS_2_MINOR

OVERLAPS_1_WRAPS

public static int OVERLAPS_1_WRAPS

OVERLAPS_2_WRAPS

public static int OVERLAPS_2_WRAPS
Constructor Detail

NumericRanges

public NumericRanges()
Method Detail

getOverlappingRange

public static long[] getOverlappingRange(long[] range1,
                                         long[] range2)

getOverlappingType

public static int getOverlappingType(long[] range1,
                                     long[] range2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 org.apache.poi.xssf.util
Classes
CTColComparator
EvilUnclosedBRFixingInputStream
NumericRanges


org.apache.poi.xssf.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xssf.util

Class Summary
CTColComparator |
EvilUnclosedBRFixingInputStream | This is a seriously sick fix for the fact that some .xlsx files contain raw bits of HTML, without being escaped or properly turned into XML.
NumericRanges |


org.apache.poi.xssf.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xssf.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xssf.util.CTColComparator (implements java.util.Comparator<T>)
    • java.io.InputStream (implements java.io.Closeable)
      • org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream
    • org.apache.poi.xssf.util.NumericRanges


Uses of Package org.apache.poi.xssf.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xssf.util

No usage of org.apache.poi.xssf.util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.util.CTColComparator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.util.CTColComparator

No usage of org.apache.poi.xssf.util.CTColComparator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream

No usage of org.apache.poi.xssf.util.EvilUnclosedBRFixingInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xssf.util.NumericRanges

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xssf.util.NumericRanges

No usage of org.apache.poi.xssf.util.NumericRanges

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xwpf.extractor
Classes
XWPFWordExtractor


org.apache.poi.xwpf.extractor

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xwpf.extractor

Class Summary
XWPFWordExtractor Helper class to extract text from an OOXML Word file


org.apache.poi.xwpf.extractor Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xwpf.extractor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POITextExtractor
      • org.apache.poi.POIXMLTextExtractor
        • org.apache.poi.xwpf.extractor.XWPFWordExtractor


Uses of Package org.apache.poi.xwpf.extractor

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xwpf.extractor

No usage of org.apache.poi.xwpf.extractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XWPFWordExtractor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.extractor
Class XWPFWordExtractor

java.lang.Object
    extended by  org.apache.poi.POITextExtractor
        extended by  org.apache.poi.POIXMLTextExtractor
            extended by  org.apache.poi.xwpf.extractor.XWPFWordExtractor

public class XWPFWordExtractor
extends POIXMLTextExtractor

Helper class to extract text from an OOXML Word file

Field Summary
static XWPFRelation[] SUPPORTED_TYPES
Constructor Summary
XWPFWordExtractor(OPCPackage container)
XWPFWordExtractor(XWPFDocument document)
Method Summary
java.lang.String | getText() Retrieves all the text from the document.
static void | main(java.lang.String[] args)
void | setFetchHyperlinks(boolean fetch) Should we also fetch the hyperlinks, when fetching the text content? Default is to only output the hyperlink label, and not the contents
Methods inherited from class org.apache.poi.POIXMLTextExtractor
getCoreProperties, getCustomProperties, getDocument, getExtendedProperties, getMetadataTextExtractor, getPackage
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SUPPORTED_TYPES

public static final XWPFRelation[] SUPPORTED_TYPES
Constructor Detail

XWPFWordExtractor

public XWPFWordExtractor(OPCPackage container)
                  throws org.apache.xmlbeans.XmlException,
                         OpenXML4JException,
                         java.io.IOException
Throws:
org.apache.xmlbeans.XmlException
OpenXML4JException
java.io.IOException

XWPFWordExtractor

public XWPFWordExtractor(XWPFDocument document)
Method Detail

setFetchHyperlinks

public void setFetchHyperlinks(boolean fetch)
Should we also fetch the hyperlinks, when fetching the text content? Default is to only output the hyperlink label, and not the contents

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

getText

public java.lang.String getText()
Description copied from class: POITextExtractor
Retrieves all the text from the document. How cells, paragraphs etc are separated in the text is implementation specific - see the javadocs for a specific project for details.

Specified by:
getText in class POITextExtractor
Returns:
All the text from the document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xwpf.extractor.XWPFWordExtractor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.extractor.XWPFWordExtractor

No usage of org.apache.poi.xwpf.extractor.XWPFWordExtractor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.apache.poi.xwpf.model
Classes
XMLParagraph
XWPFCommentsDecorator
XWPFHeaderFooterPolicy
XWPFHyperlinkDecorator
XWPFParagraphDecorator


org.apache.poi.xwpf.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xwpf.model

Class Summary
XMLParagraph | Base class for XWPF paragraphs
XWPFCommentsDecorator | Decorator class for XWPFParagraph allowing to add comments found in paragraph to its text
XWPFHeaderFooterPolicy | A .docx file can have no headers/footers, the same header/footer on each page, odd/even page footers, and optionally also a different header/footer on the first page.
XWPFHyperlinkDecorator | Deprecated. Use XWPFHyperlinkRun instead
XWPFParagraphDecorator | Base decorator class for XWPFParagraph


org.apache.poi.xwpf.model Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xwpf.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.xwpf.model.XMLParagraph
    • org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy
    • org.apache.poi.xwpf.model.XWPFParagraphDecorator
      • org.apache.poi.xwpf.model.XWPFCommentsDecorator
      • org.apache.poi.xwpf.model.XWPFHyperlinkDecorator


Uses of Package org.apache.poi.xwpf.model

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xwpf.model

Packages that use org.apache.poi.xwpf.model
org.apache.poi.xwpf.model
org.apache.poi.xwpf.usermodel

Classes in org.apache.poi.xwpf.model used by org.apache.poi.xwpf.model
XWPFParagraphDecorator
Base decorator class for XWPFParagraph

Classes in org.apache.poi.xwpf.model used by org.apache.poi.xwpf.usermodel
XWPFHeaderFooterPolicy
A .docx file can have no headers/footers, the same header/footer on each page, odd/even page footers, and optionally also a different header/footer on the first page.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XMLParagraph

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.model
Class XMLParagraph

java.lang.Object
    extended by  org.apache.poi.xwpf.model.XMLParagraph

public class XMLParagraph
extends java.lang.Object

Base class for XWPF paragraphs

Author:
Yury Batrakov (batrakov at gmail.com)

Field Summary
protected  org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP paragraph
Constructor Summary
XMLParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP paragraph)
Method Summary
 org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP getCTP()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

paragraph

protected org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP paragraph
Constructor Detail

XMLParagraph

public XMLParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP paragraph)
Method Detail

getCTP

public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP getCTP()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XWPFCommentsDecorator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.model
Class XWPFCommentsDecorator

java.lang.Object
    extended by  org.apache.poi.xwpf.model.XWPFParagraphDecorator
        extended by  org.apache.poi.xwpf.model.XWPFCommentsDecorator

public class XWPFCommentsDecorator
extends XWPFParagraphDecorator

Decorator class for XWPFParagraph allowing to add comments found in paragraph to its text

Author:
Yury Batrakov (batrakov at gmail.com)

Field Summary
Fields inherited from class org.apache.poi.xwpf.model.XWPFParagraphDecorator
nextDecorator, paragraph
Constructor Summary
XWPFCommentsDecorator(XWPFParagraphDecorator nextDecorator)
XWPFCommentsDecorator(XWPFParagraph paragraph, XWPFParagraphDecorator nextDecorator)
Method Summary
java.lang.String | getCommentText()
java.lang.String | getText()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWPFCommentsDecorator

public XWPFCommentsDecorator(XWPFParagraphDecorator nextDecorator)

XWPFCommentsDecorator

public XWPFCommentsDecorator(XWPFParagraph paragraph,
                             XWPFParagraphDecorator nextDecorator)
Method Detail

getCommentText

public java.lang.String getCommentText()

getText

public java.lang.String getText()
Overrides:
getText in class XWPFParagraphDecorator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFHeaderFooterPolicy

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.model
Class XWPFHeaderFooterPolicy

java.lang.Object
    extended by  org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

public class XWPFHeaderFooterPolicy
extends java.lang.Object

A .docx file can have no headers/footers, the same header/footer on each page, odd/even page footers, and optionally also a different header/footer on the first page. This class handles sorting out what there is, and giving you the right headers and footers for the document.

Field Summary
static org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum | DEFAULT
static org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum | EVEN
static org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum | FIRST
Constructor Summary
XWPFHeaderFooterPolicy(XWPFDocument doc)
Figures out the policy for the given document, and creates any header and footer objects as required.
XWPFHeaderFooterPolicy(XWPFDocument doc, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSectPr sectPr)
Figures out the policy for the given document, and creates any header and footer objects as required.
Method Summary
XWPFFooter | createFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type)
XWPFFooter | createFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type, XWPFParagraph[] pars)
XWPFHeader | createHeader(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type)
XWPFHeader | createHeader(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type, XWPFParagraph[] pars)
void | createWatermark(java.lang.String text)
XWPFFooter | getDefaultFooter()
XWPFHeader | getDefaultHeader()
XWPFFooter | getEvenPageFooter()
XWPFHeader | getEvenPageHeader()
XWPFFooter | getFirstPageFooter()
XWPFHeader | getFirstPageHeader()
XWPFFooter | getFooter(int pageNumber) Get the footer that applies to the given (1 based) page.
XWPFHeader | getHeader(int pageNumber) Get the header that applies to the given (1 based) page.
XWPFFooter | getOddPageFooter() Returns the odd page footer.
XWPFHeader | getOddPageHeader() Returns the odd page header.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT

public static final org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum DEFAULT

EVEN

public static final org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum EVEN

FIRST

public static final org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum FIRST
Constructor Detail

XWPFHeaderFooterPolicy

public XWPFHeaderFooterPolicy(XWPFDocument doc)
                       throws java.io.IOException,
                              org.apache.xmlbeans.XmlException
Figures out the policy for the given document, and creates any header and footer objects as required.

Throws:
java.io.IOException
org.apache.xmlbeans.XmlException

XWPFHeaderFooterPolicy

public XWPFHeaderFooterPolicy(XWPFDocument doc,
                              org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSectPr sectPr)
                       throws java.io.IOException,
                              org.apache.xmlbeans.XmlException
Figures out the policy for the given document, and creates any header and footer objects as required.

Throws:
java.io.IOException
org.apache.xmlbeans.XmlException
Method Detail

createHeader

public XWPFHeader createHeader(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type)
                        throws java.io.IOException
Throws:
java.io.IOException

createHeader

public XWPFHeader createHeader(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type,
                               XWPFParagraph[] pars)
                        throws java.io.IOException
Throws:
java.io.IOException

createFooter

public XWPFFooter createFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type)
                        throws java.io.IOException
Throws:
java.io.IOException

createFooter

public XWPFFooter createFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type,
                               XWPFParagraph[] pars)
                        throws java.io.IOException
Throws:
java.io.IOException

getFirstPageHeader

public XWPFHeader getFirstPageHeader()

getFirstPageFooter

public XWPFFooter getFirstPageFooter()

getOddPageHeader

public XWPFHeader getOddPageHeader()
Returns the odd page header. This is also the same as the default one...

getOddPageFooter

public XWPFFooter getOddPageFooter()
Returns the odd page footer. This is also the same as the default one...

getEvenPageHeader

public XWPFHeader getEvenPageHeader()

getEvenPageFooter

public XWPFFooter getEvenPageFooter()

getDefaultHeader

public XWPFHeader getDefaultHeader()

getDefaultFooter

public XWPFFooter getDefaultFooter()

getHeader

public XWPFHeader getHeader(int pageNumber)
Get the header that applies to the given (1 based) page.

Parameters:
pageNumber - The one based page number

getFooter

public XWPFFooter getFooter(int pageNumber)
Get the footer that applies to the given (1 based) page.

Parameters:
pageNumber - The one based page number

createWatermark

public void createWatermark(java.lang.String text)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFHyperlinkDecorator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.model
Class XWPFHyperlinkDecorator

java.lang.Object
    extended by  org.apache.poi.xwpf.model.XWPFParagraphDecorator
        extended by  org.apache.poi.xwpf.model.XWPFHyperlinkDecorator
Deprecated. Use XWPFHyperlinkRun instead

@Deprecated
public class XWPFHyperlinkDecorator
extends XWPFParagraphDecorator

Decorator class for XWPFParagraph allowing to add hyperlinks found in paragraph to its text. Note - adds the hyperlink at the end, not in the right place...

Field Summary
Fields inherited from class org.apache.poi.xwpf.model.XWPFParagraphDecorator
nextDecorator, paragraph
Constructor Summary
XWPFHyperlinkDecorator(XWPFParagraphDecorator nextDecorator, boolean outputHyperlinkUrls)
Deprecated.
XWPFHyperlinkDecorator(XWPFParagraph prgrph, XWPFParagraphDecorator nextDecorator, boolean outputHyperlinkUrls)
Deprecated.
Method Summary
 java.lang.String getText()
Deprecated.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWPFHyperlinkDecorator

public XWPFHyperlinkDecorator(XWPFParagraphDecorator nextDecorator,
                              boolean outputHyperlinkUrls)
Deprecated.
Parameters:
nextDecorator - The next decorator to use
outputHyperlinkUrls - Should we output the links too, or just the link text?

XWPFHyperlinkDecorator

public XWPFHyperlinkDecorator(XWPFParagraph prgrph,
                              XWPFParagraphDecorator nextDecorator,
                              boolean outputHyperlinkUrls)
Deprecated.
Parameters:
prgrph - The paragraph of text to work on
outputHyperlinkUrls - Should we output the links too, or just the link text?
Method Detail

getText

public java.lang.String getText()
Deprecated.
Overrides:
getText in class XWPFParagraphDecorator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFParagraphDecorator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.model
Class XWPFParagraphDecorator

java.lang.Object
    extended by  org.apache.poi.xwpf.model.XWPFParagraphDecorator
Direct Known Subclasses:
XWPFCommentsDecorator, XWPFHyperlinkDecorator
public abstract class XWPFParagraphDecorator
extends java.lang.Object

Base decorator class for XWPFParagraph

Field Summary
protected XWPFParagraphDecorator | nextDecorator
protected XWPFParagraph | paragraph
Constructor Summary
XWPFParagraphDecorator(XWPFParagraph paragraph)
XWPFParagraphDecorator(XWPFParagraph paragraph, XWPFParagraphDecorator nextDecorator)
Method Summary
 java.lang.String getText()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

paragraph

protected XWPFParagraph paragraph

nextDecorator

protected XWPFParagraphDecorator nextDecorator
Constructor Detail

XWPFParagraphDecorator

public XWPFParagraphDecorator(XWPFParagraph paragraph)

XWPFParagraphDecorator

public XWPFParagraphDecorator(XWPFParagraph paragraph,
                              XWPFParagraphDecorator nextDecorator)
Method Detail

getText

public java.lang.String getText()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xwpf.model.XMLParagraph

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.model.XMLParagraph

No usage of org.apache.poi.xwpf.model.XMLParagraph

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.model.XWPFCommentsDecorator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.model.XWPFCommentsDecorator

No usage of org.apache.poi.xwpf.model.XWPFCommentsDecorator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.model.XWPFHeaderFooterPolicy

Packages that use XWPFHeaderFooterPolicy
org.apache.poi.xwpf.usermodel

Uses of XWPFHeaderFooterPolicy in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFHeaderFooterPolicy
 XWPFHeaderFooterPolicy XWPFDocument.getHeaderFooterPolicy()
Returns the policy on headers and footers, which also provides a way to get at them.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.model.XWPFHyperlinkDecorator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.model.XWPFHyperlinkDecorator

No usage of org.apache.poi.xwpf.model.XWPFHyperlinkDecorator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.model.XWPFParagraphDecorator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.model.XWPFParagraphDecorator

Packages that use XWPFParagraphDecorator
org.apache.poi.xwpf.model

Uses of XWPFParagraphDecorator in org.apache.poi.xwpf.model

Subclasses of XWPFParagraphDecorator in org.apache.poi.xwpf.model
class | XWPFCommentsDecorator Decorator class for XWPFParagraph allowing to add comments found in paragraph to its text
class | XWPFHyperlinkDecorator Deprecated. Use XWPFHyperlinkRun instead

Fields in org.apache.poi.xwpf.model declared as XWPFParagraphDecorator
protected  XWPFParagraphDecorator XWPFParagraphDecorator.nextDecorator

Constructors in org.apache.poi.xwpf.model with parameters of type XWPFParagraphDecorator
XWPFCommentsDecorator(XWPFParagraphDecorator nextDecorator)
XWPFCommentsDecorator(XWPFParagraph paragraph, XWPFParagraphDecorator nextDecorator)
XWPFHyperlinkDecorator(XWPFParagraphDecorator nextDecorator, boolean outputHyperlinkUrls)
Deprecated.
XWPFHyperlinkDecorator(XWPFParagraph prgrph, XWPFParagraphDecorator nextDecorator, boolean outputHyperlinkUrls)
Deprecated.
XWPFParagraphDecorator(XWPFParagraph paragraph, XWPFParagraphDecorator nextDecorator)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BodyElementType

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum BodyElementType

java.lang.Object
    extended by  java.lang.Enum<BodyElementType>
        extended by  org.apache.poi.xwpf.usermodel.BodyElementType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BodyElementType>
public enum BodyElementType
extends java.lang.Enum<BodyElementType>

9 Jan 2010

// TODO insert Javadoc here!

Author:
epp

Enum Constant Summary
PARAGRAPH
TABLE
Method Summary
static BodyElementType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BodyElementType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

PARAGRAPH

public static final BodyElementType PARAGRAPH

TABLE

public static final BodyElementType TABLE
Method Detail

values

public static BodyElementType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (BodyElementType c : BodyElementType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static BodyElementType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD


BodyType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum BodyType

java.lang.Object
    extended by  java.lang.Enum<BodyType>
        extended by  org.apache.poi.xwpf.usermodel.BodyType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BodyType>
public enum BodyType
extends java.lang.Enum<BodyType>

9 Jan 2010

// TODO insert Javadoc here!

Author:
epp

Enum Constant Summary
DOCUMENT
FOOTER
FOOTNOTE
HEADER
TABLECELL
Method Summary
static BodyType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BodyType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

DOCUMENT

public static final BodyType DOCUMENT

HEADER

public static final BodyType HEADER

FOOTER

public static final BodyType FOOTER

FOOTNOTE

public static final BodyType FOOTNOTE

TABLECELL

public static final BodyType TABLECELL
Method Detail

values

public static BodyType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (BodyType c : BodyType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static BodyType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Borders

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum Borders

java.lang.Object
    extended by  java.lang.Enum<Borders>
        extended by  org.apache.poi.xwpf.usermodel.Borders
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Borders>
public enum Borders
extends java.lang.Enum<Borders>

Specifies all types of borders which can be specified for WordprocessingML objects which have a border. Borders can be separated into two types:

  • Line borders: which specify a pattern to be used when drawing a line around the specified object.
  • Art borders: which specify a repeated image to be used when drawing a border around the specified object. Line borders may be specified on any object which allows a border, however, art borders may only be used as a border at the page level - the borders under the pgBorders element

Author:
Gisella Bronzetti

Enum Constant Summary
APPLES
Specifies an art border consisting of a repeated image of an apple
ARCHED_SCALLOPS
Specifies an art border consisting of a repeated image of a shell pattern
BABY_PACIFIER
Specifies an art border consisting of a repeated image of a baby pacifier
BABY_RATTLE
Specifies an art border consisting of a repeated image of a baby rattle
BALLOONS_3_COLORS
Specifies an art border consisting of a repeated image of a set of balloons
BALLOONS_HOT_AIR
Specifies an art border consisting of a repeated image of a hot air balloon
BASIC_BLACK_DASHES
Specifies an art border consisting of a repeating image of a black and white background.
BASIC_BLACK_DOTS
Specifies an art border consisting of a repeating image of a black dot on a white background.
BASIC_BLACK_SQUARES
Specifies an art border consisting of a repeating image of a black and white background
BASIC_THIN_LINES
Specifies an art border consisting of a repeating image of a black and white background.
BASIC_WHITE_DASHES
Specifies an art border consisting of a repeating image of a black and white background.
BASIC_WHITE_DOTS
Specifies an art border consisting of a repeating image of a white dot on a black background.
BASIC_WHITE_SQUARES
Specifies an art border consisting of a repeating image of a black and white background.
BASIC_WIDE_INLINE
Specifies an art border consisting of a repeating image of a black and white background.
BASIC_WIDE_MIDLINE
Specifies an art border consisting of a repeating image of a black and white background
BASIC_WIDE_OUTLINE
Specifies an art border consisting of a repeating image of a black and white background
BATS
Specifies an art border consisting of a repeated image of bats
BIRDS
Specifies an art border consisting of repeating images of birds
BIRDS_FLIGHT
Specifies an art border consisting of a repeated image of birds flying
CABINS
Specifies an art border consisting of a repeated image of a cabin
CAKE_SLICE
Specifies an art border consisting of a repeated image of a piece of cake
CANDY_CORN
Specifies an art border consisting of a repeated image of candy corn
CELTIC_KNOTWORK
Specifies an art border consisting of a repeated image of a knot work pattern
CERTIFICATE_BANNER
Specifies an art border consisting of a banner.
CHAIN_LINK
Specifies an art border consisting of a repeating image of a chain link pattern.
CHAMPAGNE_BOTTLE
Specifies an art border consisting of a repeated image of a champagne bottle
CHECKED_BAR_BLACK
Specifies an art border consisting of repeating images of a compass
CHECKED_BAR_COLOR
Specifies an art border consisting of a repeating image of a colored pattern.
CHECKERED
Specifies an art border consisting of a repeated image of a checkerboard
CHRISTMAS_TREE
Specifies an art border consisting of a repeated image of a Christmas tree
CIRCLES_LINES
Specifies an art border consisting of repeating images of lines and circles
CIRCLES_RECTANGLES
Specifies an art border consisting of a repeated image of a rectangular pattern
CLASSICAL_WAVE
Specifies an art border consisting of a repeated image of a wave
CLOCKS
Specifies an art border consisting of a repeated image of a clock
COMPASS
Specifies an art border consisting of repeating images of a compass
CONFETTI
Specifies an art border consisting of a repeated image of confetti
CONFETTI_GRAYS
Specifies an art border consisting of a repeated image of confetti
CONFETTI_OUTLINE
Specifies an art border consisting of a repeated image of confetti
CONFETTI_STREAMERS
Specifies an art border consisting of a repeated image of confetti streamers
CONFETTI_WHITE
Specifies an art border consisting of a repeated image of confetti
CORNER_TRIANGLES
Specifies an art border consisting of a repeated image
COUPON_CUTOUT_DASHES
Specifies an art border consisting of a dashed line
COUPON_CUTOUT_DOTS
Specifies an art border consisting of a dotted line
CRAZY_MAZE
Specifies an art border consisting of a repeated image of a maze-like pattern
CREATURES_BUTTERFLY
Specifies an art border consisting of a repeated image of a butterfly
CREATURES_FISH
Specifies an art border consisting of a repeated image of a fish
CREATURES_INSECTS
Specifies an art border consisting of repeating images of insects.
CREATURES_LADY_BUG
Specifies an art border consisting of a repeated image of a ladybug
CROSS_STITCH
Specifies an art border consisting of repeating images of a cross-stitch pattern
CUP
Specifies an art border consisting of a repeated image of Cupid
DASH_DOT_STROKED
DASH_SMALL_GAP
DASHED
DECO_ARCH
DECO_ARCH_COLOR
DECO_BLOCKS
DIAMONDS_GRAY
DOT_DASH
DOT_DOT_DASH
DOTTED
DOUBLE
DOUBLE_D
DOUBLE_DIAMONDS
DOUBLE_WAVE
EARTH_1
EARTH_2
ECLIPSING_SQUARES_1
ECLIPSING_SQUARES_2
EGGS_BLACK
FANS
FILM
FIRECRACKERS
FLOWERS_BLOCK_PRINT
FLOWERS_DAISIES
FLOWERS_MODERN_1
FLOWERS_MODERN_2
FLOWERS_PANSY
FLOWERS_RED_ROSE
FLOWERS_ROSES
FLOWERS_TEACUP
FLOWERS_TINY
GEMS
GINGERBREAD_MAN
GRADIENT
HANDMADE_1
HANDMADE_2
HEART_BALLOON
HEART_GRAY
HEARTS
HEEBIE_JEEBIES
HOLLY
HOUSE_FUNKY
HYPNOTIC
ICE_CREAM_CONES
INSET
LIGHT_BULB
LIGHTNING_1
LIGHTNING_2
MAP_PINS
MAPLE_LEAF
MAPLE_MUFFINS
MARQUEE
MARQUEE_TOOTHED
MOONS
MOSAIC
MUSIC_NOTES
NIL
NONE
NORTHWEST
OUTSET
OVALS
PACKAGES
PALMS_BLACK
PALMS_COLOR
PAPER_CLIPS
PAPYRUS
PARTY_FAVOR
PARTY_GLASS
PENCILS
PEOPLE
PEOPLE_HATS
PEOPLE_WAVING
POINSETTIAS
POSTAGE_STAMP
PUMPKIN_1
PUSH_PIN_NOTE_1
PUSH_PIN_NOTE_2
PYRAMIDS
PYRAMIDS_ABOVE
QUADRANTS
RINGS
SAFARI
SAWTOOTH
SAWTOOTH_GRAY
SCARED_CAT
SEATTLE
SHADOWED_SQUARES
SHARKS_TEETH
SHOREBIRD_TRACKS
SINGLE
Specifies a line border consisting of a single line around the parent object.
SKYROCKET
SNOWFLAKE_FANCY
SNOWFLAKES
SOMBRERO
SOUTHWEST
STARS
STARS_3_D
STARS_BLACK
STARS_SHADOWED
STARS_TOP
SUN
SWIRLIGIG
THICK
THICK_THIN_LARGE_GAP
THICK_THIN_MEDIUM_GAP
THICK_THIN_SMALL_GAP
THIN_THICK_LARGE_GAP
THIN_THICK_MEDIUM_GAP
THIN_THICK_SMALL_GAP
THIN_THICK_THIN_LARGE_GAP
THIN_THICK_THIN_MEDIUM_GAP
THIN_THICK_THIN_SMALL_GAP
THREE_D_EMBOSS
THREE_D_ENGRAVE
TORN_PAPER
TORN_PAPER_BLACK
TREES
TRIANGLE_PARTY
TRIANGLES
TRIBAL_1
TRIBAL_2
TRIBAL_3
TRIBAL_4
TRIBAL_5
TRIBAL_6
TRIPLE
TWISTED_LINES_1
TWISTED_LINES_2
VINE
WAVE
WAVELINE
WEAVING_ANGLES
WEAVING_BRAID
WEAVING_RIBBON
WEAVING_STRIPS
WHITE_FLOWERS
WOODWORK
X_ILLUSIONS
ZANY_TRIANGLES
ZIG_ZAG
ZIG_ZAG_STITCH
Method Summary
int | getValue()
static Borders | valueOf(int type)
static Borders | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Borders[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NIL

public static final Borders NIL

NONE

public static final Borders NONE

SINGLE

public static final Borders SINGLE
Specifies a line border consisting of a single line around the parent object.

THICK

public static final Borders THICK

DOUBLE

public static final Borders DOUBLE

DOTTED

public static final Borders DOTTED

DASHED

public static final Borders DASHED

DOT_DASH

public static final Borders DOT_DASH

DOT_DOT_DASH

public static final Borders DOT_DOT_DASH

TRIPLE

public static final Borders TRIPLE

THIN_THICK_SMALL_GAP

public static final Borders THIN_THICK_SMALL_GAP

THICK_THIN_SMALL_GAP

public static final Borders THICK_THIN_SMALL_GAP

THIN_THICK_THIN_SMALL_GAP

public static final Borders THIN_THICK_THIN_SMALL_GAP

THIN_THICK_MEDIUM_GAP

public static final Borders THIN_THICK_MEDIUM_GAP

THICK_THIN_MEDIUM_GAP

public static final Borders THICK_THIN_MEDIUM_GAP

THIN_THICK_THIN_MEDIUM_GAP

public static final Borders THIN_THICK_THIN_MEDIUM_GAP

THIN_THICK_LARGE_GAP

public static final Borders THIN_THICK_LARGE_GAP

THICK_THIN_LARGE_GAP

public static final Borders THICK_THIN_LARGE_GAP

THIN_THICK_THIN_LARGE_GAP

public static final Borders THIN_THICK_THIN_LARGE_GAP

WAVE

public static final Borders WAVE

DOUBLE_WAVE

public static final Borders DOUBLE_WAVE

DASH_SMALL_GAP

public static final Borders DASH_SMALL_GAP

DASH_DOT_STROKED

public static final Borders DASH_DOT_STROKED

THREE_D_EMBOSS

public static final Borders THREE_D_EMBOSS

THREE_D_ENGRAVE

public static final Borders THREE_D_ENGRAVE

OUTSET

public static final Borders OUTSET

INSET

public static final Borders INSET

APPLES

public static final Borders APPLES
Specifies an art border consisting of a repeated image of an apple

ARCHED_SCALLOPS

public static final Borders ARCHED_SCALLOPS
Specifies an art border consisting of a repeated image of a shell pattern

BABY_PACIFIER

public static final Borders BABY_PACIFIER
Specifies an art border consisting of a repeated image of a baby pacifier

BABY_RATTLE

public static final Borders BABY_RATTLE
Specifies an art border consisting of a repeated image of a baby rattle

BALLOONS_3_COLORS

public static final Borders BALLOONS_3_COLORS
Specifies an art border consisting of a repeated image of a set of balloons

BALLOONS_HOT_AIR

public static final Borders BALLOONS_HOT_AIR
Specifies an art border consisting of a repeated image of a hot air balloon

BASIC_BLACK_DASHES

public static final Borders BASIC_BLACK_DASHES
Specifies an art border consisting of a repeating image of a black and white background.

BASIC_BLACK_DOTS

public static final Borders BASIC_BLACK_DOTS
Specifies an art border consisting of a repeating image of a black dot on a white background.

BASIC_BLACK_SQUARES

public static final Borders BASIC_BLACK_SQUARES
Specifies an art border consisting of a repeating image of a black and white background

BASIC_THIN_LINES

public static final Borders BASIC_THIN_LINES
Specifies an art border consisting of a repeating image of a black and white background.

BASIC_WHITE_DASHES

public static final Borders BASIC_WHITE_DASHES
Specifies an art border consisting of a repeating image of a black and white background.

BASIC_WHITE_DOTS

public static final Borders BASIC_WHITE_DOTS
Specifies an art border consisting of a repeating image of a white dot on a black background.

BASIC_WHITE_SQUARES

public static final Borders BASIC_WHITE_SQUARES
Specifies an art border consisting of a repeating image of a black and white background.

BASIC_WIDE_INLINE

public static final Borders BASIC_WIDE_INLINE
Specifies an art border consisting of a repeating image of a black and white background.

BASIC_WIDE_MIDLINE

public static final Borders BASIC_WIDE_MIDLINE
Specifies an art border consisting of a repeating image of a black and white background

BASIC_WIDE_OUTLINE

public static final Borders BASIC_WIDE_OUTLINE
Specifies an art border consisting of a repeating image of a black and white background

BATS

public static final Borders BATS
Specifies an art border consisting of a repeated image of bats

BIRDS

public static final Borders BIRDS
Specifies an art border consisting of repeating images of birds

BIRDS_FLIGHT

public static final Borders BIRDS_FLIGHT
Specifies an art border consisting of a repeated image of birds flying

CABINS

public static final Borders CABINS
Specifies an art border consisting of a repeated image of a cabin

CAKE_SLICE

public static final Borders CAKE_SLICE
Specifies an art border consisting of a repeated image of a piece of cake

CANDY_CORN

public static final Borders CANDY_CORN
Specifies an art border consisting of a repeated image of candy corn

CELTIC_KNOTWORK

public static final Borders CELTIC_KNOTWORK
Specifies an art border consisting of a repeated image of a knot work pattern

CERTIFICATE_BANNER

public static final Borders CERTIFICATE_BANNER
Specifies an art border consisting of a banner.

If the border is on the left or right, no border is displayed.

CHAIN_LINK

public static final Borders CHAIN_LINK
Specifies an art border consisting of a repeating image of a chain link pattern.

CHAMPAGNE_BOTTLE

public static final Borders CHAMPAGNE_BOTTLE
Specifies an art border consisting of a repeated image of a champagne bottle

CHECKED_BAR_BLACK

public static final Borders CHECKED_BAR_BLACK
Specifies an art border consisting of repeating images of a compass

CHECKED_BAR_COLOR

public static final Borders CHECKED_BAR_COLOR
Specifies an art border consisting of a repeating image of a colored pattern.

CHECKERED

public static final Borders CHECKERED
Specifies an art border consisting of a repeated image of a checkerboard

CHRISTMAS_TREE

public static final Borders CHRISTMAS_TREE
Specifies an art border consisting of a repeated image of a Christmas tree

CIRCLES_LINES

public static final Borders CIRCLES_LINES
Specifies an art border consisting of repeating images of lines and circles

CIRCLES_RECTANGLES

public static final Borders CIRCLES_RECTANGLES
Specifies an art border consisting of a repeated image of a rectangular pattern

CLASSICAL_WAVE

public static final Borders CLASSICAL_WAVE
Specifies an art border consisting of a repeated image of a wave

CLOCKS

public static final Borders CLOCKS
Specifies an art border consisting of a repeated image of a clock

COMPASS

public static final Borders COMPASS
Specifies an art border consisting of repeating images of a compass

CONFETTI

public static final Borders CONFETTI
Specifies an art border consisting of a repeated image of confetti

CONFETTI_GRAYS

public static final Borders CONFETTI_GRAYS
Specifies an art border consisting of a repeated image of confetti

CONFETTI_OUTLINE

public static final Borders CONFETTI_OUTLINE
Specifies an art border consisting of a repeated image of confetti

CONFETTI_STREAMERS

public static final Borders CONFETTI_STREAMERS
Specifies an art border consisting of a repeated image of confetti streamers

CONFETTI_WHITE

public static final Borders CONFETTI_WHITE
Specifies an art border consisting of a repeated image of confetti

CORNER_TRIANGLES

public static final Borders CORNER_TRIANGLES
Specifies an art border consisting of a repeated image

COUPON_CUTOUT_DASHES

public static final Borders COUPON_CUTOUT_DASHES
Specifies an art border consisting of a dashed line

COUPON_CUTOUT_DOTS

public static final Borders COUPON_CUTOUT_DOTS
Specifies an art border consisting of a dotted line

CRAZY_MAZE

public static final Borders CRAZY_MAZE
Specifies an art border consisting of a repeated image of a maze-like pattern

CREATURES_BUTTERFLY

public static final Borders CREATURES_BUTTERFLY
Specifies an art border consisting of a repeated image of a butterfly

CREATURES_FISH

public static final Borders CREATURES_FISH
Specifies an art border consisting of a repeated image of a fish

CREATURES_INSECTS

public static final Borders CREATURES_INSECTS
Specifies an art border consisting of repeating images of insects.

CREATURES_LADY_BUG

public static final Borders CREATURES_LADY_BUG
Specifies an art border consisting of a repeated image of a ladybug

CROSS_STITCH

public static final Borders CROSS_STITCH
Specifies an art border consisting of repeating images of a cross-stitch pattern

CUP

public static final Borders CUP
Specifies an art border consisting of a repeated image of Cupid

DECO_ARCH

public static final Borders DECO_ARCH

DECO_ARCH_COLOR

public static final Borders DECO_ARCH_COLOR

DECO_BLOCKS

public static final Borders DECO_BLOCKS

DIAMONDS_GRAY

public static final Borders DIAMONDS_GRAY

DOUBLE_D

public static final Borders DOUBLE_D

DOUBLE_DIAMONDS

public static final Borders DOUBLE_DIAMONDS

EARTH_1

public static final Borders EARTH_1

EARTH_2

public static final Borders EARTH_2

ECLIPSING_SQUARES_1

public static final Borders ECLIPSING_SQUARES_1

ECLIPSING_SQUARES_2

public static final Borders ECLIPSING_SQUARES_2

EGGS_BLACK

public static final Borders EGGS_BLACK

FANS

public static final Borders FANS

FILM

public static final Borders FILM

FIRECRACKERS

public static final Borders FIRECRACKERS

FLOWERS_BLOCK_PRINT

public static final Borders FLOWERS_BLOCK_PRINT

FLOWERS_DAISIES

public static final Borders FLOWERS_DAISIES

FLOWERS_MODERN_1

public static final Borders FLOWERS_MODERN_1

FLOWERS_MODERN_2

public static final Borders FLOWERS_MODERN_2

FLOWERS_PANSY

public static final Borders FLOWERS_PANSY

FLOWERS_RED_ROSE

public static final Borders FLOWERS_RED_ROSE

FLOWERS_ROSES

public static final Borders FLOWERS_ROSES

FLOWERS_TEACUP

public static final Borders FLOWERS_TEACUP

FLOWERS_TINY

public static final Borders FLOWERS_TINY

GEMS

public static final Borders GEMS

GINGERBREAD_MAN

public static final Borders GINGERBREAD_MAN

GRADIENT

public static final Borders GRADIENT

HANDMADE_1

public static final Borders HANDMADE_1

HANDMADE_2

public static final Borders HANDMADE_2

HEART_BALLOON

public static final Borders HEART_BALLOON

HEART_GRAY

public static final Borders HEART_GRAY

HEARTS

public static final Borders HEARTS

HEEBIE_JEEBIES

public static final Borders HEEBIE_JEEBIES

HOLLY

public static final Borders HOLLY

HOUSE_FUNKY

public static final Borders HOUSE_FUNKY

HYPNOTIC

public static final Borders HYPNOTIC

ICE_CREAM_CONES

public static final Borders ICE_CREAM_CONES

LIGHT_BULB

public static final Borders LIGHT_BULB

LIGHTNING_1

public static final Borders LIGHTNING_1

LIGHTNING_2

public static final Borders LIGHTNING_2

MAP_PINS

public static final Borders MAP_PINS

MAPLE_LEAF

public static final Borders MAPLE_LEAF

MAPLE_MUFFINS

public static final Borders MAPLE_MUFFINS

MARQUEE

public static final Borders MARQUEE

MARQUEE_TOOTHED

public static final Borders MARQUEE_TOOTHED

MOONS

public static final Borders MOONS

MOSAIC

public static final Borders MOSAIC

MUSIC_NOTES

public static final Borders MUSIC_NOTES

NORTHWEST

public static final Borders NORTHWEST

OVALS

public static final Borders OVALS

PACKAGES

public static final Borders PACKAGES

PALMS_BLACK

public static final Borders PALMS_BLACK

PALMS_COLOR

public static final Borders PALMS_COLOR

PAPER_CLIPS

public static final Borders PAPER_CLIPS

PAPYRUS

public static final Borders PAPYRUS

PARTY_FAVOR

public static final Borders PARTY_FAVOR

PARTY_GLASS

public static final Borders PARTY_GLASS

PENCILS

public static final Borders PENCILS

PEOPLE

public static final Borders PEOPLE

PEOPLE_WAVING

public static final Borders PEOPLE_WAVING

PEOPLE_HATS

public static final Borders PEOPLE_HATS

POINSETTIAS

public static final Borders POINSETTIAS

POSTAGE_STAMP

public static final Borders POSTAGE_STAMP

PUMPKIN_1

public static final Borders PUMPKIN_1

PUSH_PIN_NOTE_2

public static final Borders PUSH_PIN_NOTE_2

PUSH_PIN_NOTE_1

public static final Borders PUSH_PIN_NOTE_1

PYRAMIDS

public static final Borders PYRAMIDS

PYRAMIDS_ABOVE

public static final Borders PYRAMIDS_ABOVE

QUADRANTS

public static final Borders QUADRANTS

RINGS

public static final Borders RINGS

SAFARI

public static final Borders SAFARI

SAWTOOTH

public static final Borders SAWTOOTH

SAWTOOTH_GRAY

public static final Borders SAWTOOTH_GRAY

SCARED_CAT

public static final Borders SCARED_CAT

SEATTLE

public static final Borders SEATTLE

SHADOWED_SQUARES

public static final Borders SHADOWED_SQUARES

SHARKS_TEETH

public static final Borders SHARKS_TEETH

SHOREBIRD_TRACKS

public static final Borders SHOREBIRD_TRACKS

SKYROCKET

public static final Borders SKYROCKET

SNOWFLAKE_FANCY

public static final Borders SNOWFLAKE_FANCY

SNOWFLAKES

public static final Borders SNOWFLAKES

SOMBRERO

public static final Borders SOMBRERO

SOUTHWEST

public static final Borders SOUTHWEST

STARS

public static final Borders STARS

STARS_TOP

public static final Borders STARS_TOP

STARS_3_D

public static final Borders STARS_3_D

STARS_BLACK

public static final Borders STARS_BLACK

STARS_SHADOWED

public static final Borders STARS_SHADOWED

SUN

public static final Borders SUN

SWIRLIGIG

public static final Borders SWIRLIGIG

TORN_PAPER

public static final Borders TORN_PAPER

TORN_PAPER_BLACK

public static final Borders TORN_PAPER_BLACK

TREES

public static final Borders TREES

TRIANGLE_PARTY

public static final Borders TRIANGLE_PARTY

TRIANGLES

public static final Borders TRIANGLES

TRIBAL_1

public static final Borders TRIBAL_1

TRIBAL_2

public static final Borders TRIBAL_2

TRIBAL_3

public static final Borders TRIBAL_3

TRIBAL_4

public static final Borders TRIBAL_4

TRIBAL_5

public static final Borders TRIBAL_5

TRIBAL_6

public static final Borders TRIBAL_6

TWISTED_LINES_1

public static final Borders TWISTED_LINES_1

TWISTED_LINES_2

public static final Borders TWISTED_LINES_2

VINE

public static final Borders VINE

WAVELINE

public static final Borders WAVELINE

WEAVING_ANGLES

public static final Borders WEAVING_ANGLES

WEAVING_BRAID

public static final Borders WEAVING_BRAID

WEAVING_RIBBON

public static final Borders WEAVING_RIBBON

WEAVING_STRIPS

public static final Borders WEAVING_STRIPS

WHITE_FLOWERS

public static final Borders WHITE_FLOWERS

WOODWORK

public static final Borders WOODWORK

X_ILLUSIONS

public static final Borders X_ILLUSIONS

ZANY_TRIANGLES

public static final Borders ZANY_TRIANGLES

ZIG_ZAG

public static final Borders ZIG_ZAG

ZIG_ZAG_STITCH

public static final Borders ZIG_ZAG_STITCH
Method Detail

values

public static Borders[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Borders c : Borders.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Borders valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static Borders valueOf(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


BreakClear

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum BreakClear

java.lang.Object
    extended by  java.lang.Enum<BreakClear>
        extended by  org.apache.poi.xwpf.usermodel.BreakClear
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BreakClear>
public enum BreakClear
extends java.lang.Enum<BreakClear>

Specifies the set of possible restart locations which may be used as to determine the next available line when a break's type attribute has a value of textWrapping.

Author:
Gisella Bronzetti

Enum Constant Summary
ALL
Specifies that the text wrapping break shall advance the text to the next line in the WordprocessingML document which spans the full width of the line.
LEFT
Specifies that the text wrapping break shall behave as follows: If this line is broken into multiple regions (a floating object in the center of the page has text wrapping on both sides: If this is the leftmost region of text flow on this line, advance the text to the next position on the line Otherwise, treat this as a text wrapping break of type all.
NONE
Specifies that the text wrapping break shall advance the text to the next line in the WordprocessingML document, regardless of its position left to right or the presence of any floating objects which intersect with the line, This is the setting for a typical line break in a document.
RIGHT
Specifies that the text wrapping break shall behave as follows: If this line is broken into multiple regions (a floating object in the center of the page has text wrapping on both sides: If this is the rightmost region of text flow on this line, advance the text to the next position on the next line Otherwise, treat this as a text wrapping break of type all.
Method Summary
int | getValue()
static BreakClear | valueOf(int type)
static BreakClear | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BreakClear[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NONE

public static final BreakClear NONE
Specifies that the text wrapping break shall advance the text to the next line in the WordprocessingML document, regardless of its position left to right or the presence of any floating objects which intersect with the line, This is the setting for a typical line break in a document.

LEFT

public static final BreakClear LEFT
Specifies that the text wrapping break shall behave as follows:
  • If this line is broken into multiple regions (a floating object in the center of the page has text wrapping on both sides:
    • If this is the leftmost region of text flow on this line, advance the text to the next position on the line
    • Otherwise, treat this as a text wrapping break of type all.
  • If this line is not broken into multiple regions, then treat this break as a text wrapping break of type none.
  • If the parent paragraph is right to left, then these behaviors are also reversed.

    • RIGHT

    public static final BreakClear RIGHT
    Specifies that the text wrapping break shall behave as follows:
    • If this line is broken into multiple regions (a floating object in the center of the page has text wrapping on both sides:
      • If this is the rightmost region of text flow on this line, advance the text to the next position on the next line
      • Otherwise, treat this as a text wrapping break of type all.
    • If this line is not broken into multiple regions, then treat this break as a text wrapping break of type none.
    • If the parent paragraph is right to left, then these beha viors are also reversed.

    ALL

    public static final BreakClear ALL
    Specifies that the text wrapping break shall advance the text to the next line in the WordprocessingML document which spans the full width of the line.

    Method Detail

    values

    public static BreakClear[] values()
    Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
    for (BreakClear c : BreakClear.values())
    System.out.println(c);

    Returns:
    an array containing the constants of this enum type, in the order they are declared

    valueOf

    public static BreakClear valueOf(java.lang.String name)
    Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

    Parameters:
    name - the name of the enum constant to be returned.
    Returns:
    the enum constant with the specified name
    Throws:
    java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
    java.lang.NullPointerException - if the argument is null

    getValue

    public int getValue()

    valueOf

    public static BreakClear valueOf(int type)
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


BreakType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum BreakType

java.lang.Object
    extended by  java.lang.Enum<BreakType>
        extended by  org.apache.poi.xwpf.usermodel.BreakType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BreakType>
public enum BreakType
extends java.lang.Enum<BreakType>

Specifies the possible types of break characters in a WordprocessingML document. The break type determines the next location where text shall be placed after this manual break is applied to the text contents

Author:
Gisella Bronzetti

Enum Constant Summary
COLUMN
Specifies that the current break shall restart itself on the next column available on the current page when the document is displayed in page view.
PAGE
Specifies that the current break shall restart itself on the next page of the document when the document is displayed in page view.
TEXT_WRAPPING
Specifies that the current break shall restart itself on the next line in the document when the document is displayed in page view.
Method Summary
int | getValue()
static BreakType | valueOf(int type)
static BreakType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BreakType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

PAGE

public static final BreakType PAGE
Specifies that the current break shall restart itself on the next page of the document when the document is displayed in page view.

COLUMN

public static final BreakType COLUMN
Specifies that the current break shall restart itself on the next column available on the current page when the document is displayed in page view.

If the current section is not divided into columns, or the column break occurs in the last column on the current page when displayed, then the restart location for text shall be the next page in the document.

TEXT_WRAPPING

public static final BreakType TEXT_WRAPPING
Specifies that the current break shall restart itself on the next line in the document when the document is displayed in page view. The determine of the next line shall be done subject to the value of the clear attribute on the specified break character.

Method Detail

values

public static BreakType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (BreakType c : BreakType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static BreakType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static BreakType valueOf(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Document

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Interface Document

All Known Implementing Classes:
XWPFDocument
public interface Document

Field Summary
static int | PICTURE_TYPE_BMP Windows Bitmap (.bmp)
static int | PICTURE_TYPE_DIB Device independent bitmap
static int | PICTURE_TYPE_EMF Extended windows meta file
static int | PICTURE_TYPE_EPS Encapsulated Postscript (.eps)
static int | PICTURE_TYPE_GIF GIF image format
static int | PICTURE_TYPE_JPEG JPEG format
static int | PICTURE_TYPE_PICT Mac PICT format
static int | PICTURE_TYPE_PNG PNG format
static int | PICTURE_TYPE_TIFF Tag Image File (.tiff)
static int | PICTURE_TYPE_WMF Windows Meta File
static int | PICTURE_TYPE_WPG WordPerfect graphics (.wpg)

Field Detail

PICTURE_TYPE_EMF

static final int PICTURE_TYPE_EMF
Extended windows meta file

See Also:
Constant Field Values

PICTURE_TYPE_WMF

static final int PICTURE_TYPE_WMF
Windows Meta File

See Also:
Constant Field Values

PICTURE_TYPE_PICT

static final int PICTURE_TYPE_PICT
Mac PICT format

See Also:
Constant Field Values

PICTURE_TYPE_JPEG

static final int PICTURE_TYPE_JPEG
JPEG format

See Also:
Constant Field Values

PICTURE_TYPE_PNG

static final int PICTURE_TYPE_PNG
PNG format

See Also:
Constant Field Values

PICTURE_TYPE_DIB

static final int PICTURE_TYPE_DIB
Device independent bitmap

See Also:
Constant Field Values

PICTURE_TYPE_GIF

static final int PICTURE_TYPE_GIF
GIF image format

See Also:
Constant Field Values

PICTURE_TYPE_TIFF

static final int PICTURE_TYPE_TIFF
Tag Image File (.tiff)

See Also:
Constant Field Values

PICTURE_TYPE_EPS

static final int PICTURE_TYPE_EPS
Encapsulated Postscript (.eps)

See Also:
Constant Field Values

PICTURE_TYPE_BMP

static final int PICTURE_TYPE_BMP
Windows Bitmap (.bmp)

See Also:
Constant Field Values

PICTURE_TYPE_WPG

static final int PICTURE_TYPE_WPG
WordPerfect graphics (.wpg)

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IBody

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Interface IBody

All Known Implementing Classes:
XWPFDocument, XWPFFooter, XWPFFootnote, XWPFHeader, XWPFHeaderFooter, XWPFTableCell
public interface IBody

8 Jan 2010

// This Interface represents an object, which is able to have a collection of paragraphs and tables this can be XWFPDocument, XWPFHeader, XWPFFooter, XWPFTableCell

Author:
Philipp Epp

Method Summary
java.util.List<IBodyElement> | getBodyElements() Returns an Iterator with paragraphs and tables, in the order that they occur in the text.
XWPFParagraph | getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | getParagraphArray(int pos) Returns the paragraph that of position pos
java.util.List<XWPFParagraph> | getParagraphs() Returns the paragraph(s) that holds the text of the header or footer.
POIXMLDocumentPart | getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell.
BodyType | getPartType() get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,
XWPFTable | getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
XWPFTable | getTableArray(int pos) Returns the table at position pos
XWPFTableCell | getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) returns the TableCell to which the Table belongs
java.util.List<XWPFTable> | getTables() Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.
XWPFDocument | getXWPFDocument() Return XWPFDocument
XWPFParagraph | insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) inserts a new paragraph at position of the cursor
XWPFTable | insertNewTbl(org.apache.xmlbeans.XmlCursor cursor) inserts a new Table at the cursor position.
void | insertTable(int pos, XWPFTable table) inserts a new Table at position pos

Method Detail

getPart

POIXMLDocumentPart getPart()
returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell. Because you have to know to which part the tableCell belongs.

Returns:
the Part, to which the body belongs

getPartType

BodyType getPartType()
get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,

Returns:
the PartType of the body

getBodyElements

java.util.List<IBodyElement> getBodyElements()
Returns an Iterator with paragraphs and tables, in the order that they occur in the text.

getParagraphs

java.util.List<XWPFParagraph> getParagraphs()
Returns the paragraph(s) that holds the text of the header or footer.

getTables

java.util.List<XWPFTable> getTables()
Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.

getParagraph

XWPFParagraph getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p)
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null

Parameters:
p - is instance of CTP and is searching for an XWPFParagraph
Returns:
null if there is no XWPFParagraph with an corresponding CTPparagraph in the paragraphList of this header or footer XWPFParagraph with the correspondig CTP p

getTable

XWPFTable getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable)
if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null

Parameters:
ctTable -

getParagraphArray

XWPFParagraph getParagraphArray(int pos)
Returns the paragraph that of position pos

getTableArray

XWPFTable getTableArray(int pos)
Returns the table at position pos

insertNewParagraph

XWPFParagraph insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor)
inserts a new paragraph at position of the cursor

Parameters:
cursor -

insertNewTbl

XWPFTable insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
inserts a new Table at the cursor position.

Parameters:
cursor -

insertTable

void insertTable(int pos,
                 XWPFTable table)
inserts a new Table at position pos

Parameters:
pos -
table -

getTableCell

XWPFTableCell getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell)
returns the TableCell to which the Table belongs

Parameters:
cell -

getXWPFDocument

XWPFDocument getXWPFDocument()
Return XWPFDocument

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IBodyElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Interface IBodyElement

All Known Implementing Classes:
XWPFParagraph, XWPFTable
public interface IBodyElement

9 Jan 2010

Author:
Philipp Epp

Method Summary
IBody | getBody()
BodyElementType | getElementType()
POIXMLDocumentPart | getPart()
BodyType | getPartType()

Method Detail

getBody

IBody getBody()

getPart

POIXMLDocumentPart getPart()

getPartType

BodyType getPartType()

getElementType

BodyElementType getElementType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LineSpacingRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum LineSpacingRule

java.lang.Object
    extended by  java.lang.Enum<LineSpacingRule>
        extended by  org.apache.poi.xwpf.usermodel.LineSpacingRule
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LineSpacingRule>
public enum LineSpacingRule
extends java.lang.Enum<LineSpacingRule>

Specifies the logic which shall be used to calculate the line spacing of the parent object when it is displayed in the document.

Author:
Gisella Bronzetti

Enum Constant Summary
AT_LEAST
Specifies that the height of the line shall be at least the value specified, but may be expanded to fit its content as needed.
AUTO
Specifies that the line spacing of the parent object shall be automatically determined by the size of its contents, with no predetermined minimum or maximum size.
EXACT
Specifies that the height of the line shall be exactly the value specified, regardless of the size of the contents If the contents are too large for the specified height, then they shall be clipped as necessary.
Method Summary
int | getValue()
static LineSpacingRule | valueOf(int type)
static LineSpacingRule | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineSpacingRule[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

AUTO

public static final LineSpacingRule AUTO
Specifies that the line spacing of the parent object shall be automatically determined by the size of its contents, with no predetermined minimum or maximum size.

EXACT

public static final LineSpacingRule EXACT
Specifies that the height of the line shall be exactly the value specified, regardless of the size of the contents If the contents are too large for the specified height, then they shall be clipped as necessary.

AT_LEAST

public static final LineSpacingRule AT_LEAST
Specifies that the height of the line shall be at least the value specified, but may be expanded to fit its content as needed.

Method Detail

values

public static LineSpacingRule[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LineSpacingRule c : LineSpacingRule.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LineSpacingRule valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static LineSpacingRule valueOf(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


 org.apache.poi.xwpf.usermodel
Interfaces
Document
IBody
IBodyElement
Classes
PositionInParagraph
TextSegement
TOC
XWPFAbstractNum
XWPFComment
XWPFDocument
XWPFFactory
XWPFFooter
XWPFFootnote
XWPFFootnotes
XWPFHeader
XWPFHeaderFooter
XWPFHyperlink
XWPFHyperlinkRun
XWPFLatentStyles
XWPFNum
XWPFNumbering
XWPFParagraph
XWPFPicture
XWPFPictureData
XWPFRelation
XWPFRun
XWPFSettings
XWPFStyle
XWPFStyles
XWPFTable
XWPFTableCell
XWPFTableRow
Enums
BodyElementType
BodyType
Borders
BreakClear
BreakType
LineSpacingRule
ParagraphAlignment
TextAlignment
UnderlinePatterns
VerticalAlign
XWPFTable.XWPFBorderType
XWPFTableCell.XWPFVertAlign


org.apache.poi.xwpf.usermodel

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.poi.xwpf.usermodel

Interface Summary
Document |
IBody | 8 Jan 2010
IBodyElement | 9 Jan 2010

Class Summary
PositionInParagraph | postion of a character in a paragrapho 1st RunPositon 2nd TextPosition 3rd CharacterPosition
TextSegement | saves the begin and end position of a text in a Paragraph
TOC |
XWPFAbstractNum |
XWPFComment | Sketch of XWPF comment class
XWPFDocument | Experimental class to do low level processing of docx files.
XWPFFactory |
XWPFFooter | Sketch of XWPF footer class
XWPFFootnote |
XWPFFootnotes | Looks after the collection of Footnotes for a document
XWPFHeader | Sketch of XWPF header class
XWPFHeaderFooter | Parent of XWPF headers and footers
XWPFHyperlink | Sketch of XWPF hyperlink class
XWPFHyperlinkRun | A run of text with a Hyperlink applied to it.
XWPFLatentStyles |
XWPFNum |
XWPFNumbering |
XWPFParagraph | Sketch of XWPF paragraph class
XWPFPicture |
XWPFPictureData |
XWPFRelation |
XWPFRun | XWPFRun object defines a region of text with a common set of properties
XWPFSettings |
XWPFStyle |
XWPFStyles |
XWPFTable | Sketch of XWPFTable class.
XWPFTableCell | XWPFTableCell class.
XWPFTableRow |

Enum Summary
BodyElementType | 9 Jan 2010
BodyType | 9 Jan 2010
Borders | Specifies all types of borders which can be specified for WordprocessingML objects which have a border.
BreakClear | Specifies the set of possible restart locations which may be used as to determine the next available line when a break's type attribute has a value of textWrapping.
BreakType | Specifies the possible types of break characters in a WordprocessingML document.
LineSpacingRule | Specifies the logic which shall be used to calculate the line spacing of the parent object when it is displayed in the document.
ParagraphAlignment | Specifies all types of alignment which are available to be applied to objects in a WordprocessingML document
TextAlignment | Specifies all types of vertical alignment which are available to be applied to of all text on each line displayed within a paragraph.
UnderlinePatterns | Specifies the types of patterns which may be used to create the underline applied beneath the text in a run.
VerticalAlign | Specifies possible values for the alignment of the contents of this run in relation to the default appearance of the run's text.
XWPFTable.XWPFBorderType |
XWPFTableCell.XWPFVertAlign |

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.apache.poi.xwpf.usermodel Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.apache.poi.xwpf.usermodel

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.poi.POIXMLDocumentPart
      • org.apache.poi.POIXMLDocument
        • org.apache.poi.xwpf.usermodel.XWPFDocument (implements org.apache.poi.xwpf.usermodel.Document, org.apache.poi.xwpf.usermodel.IBody)
      • org.apache.poi.xwpf.usermodel.XWPFFootnotes
      • org.apache.poi.xwpf.usermodel.XWPFHeaderFooter (implements org.apache.poi.xwpf.usermodel.IBody)
        • org.apache.poi.xwpf.usermodel.XWPFFooter
        • org.apache.poi.xwpf.usermodel.XWPFHeader
      • org.apache.poi.xwpf.usermodel.XWPFNumbering
      • org.apache.poi.xwpf.usermodel.XWPFPictureData
      • org.apache.poi.xwpf.usermodel.XWPFSettings
      • org.apache.poi.xwpf.usermodel.XWPFStyles
    • org.apache.poi.POIXMLFactory
      • org.apache.poi.xwpf.usermodel.XWPFFactory
    • org.apache.poi.POIXMLRelation
      • org.apache.poi.xwpf.usermodel.XWPFRelation
    • org.apache.poi.xwpf.usermodel.PositionInParagraph
    • org.apache.poi.xwpf.usermodel.TextSegement
    • org.apache.poi.xwpf.usermodel.TOC
    • org.apache.poi.xwpf.usermodel.XWPFAbstractNum
    • org.apache.poi.xwpf.usermodel.XWPFComment
    • org.apache.poi.xwpf.usermodel.XWPFFootnote (implements org.apache.poi.xwpf.usermodel.IBody, java.lang.Iterable<T>)
    • org.apache.poi.xwpf.usermodel.XWPFHyperlink
    • org.apache.poi.xwpf.usermodel.XWPFLatentStyles
    • org.apache.poi.xwpf.usermodel.XWPFNum
    • org.apache.poi.xwpf.usermodel.XWPFParagraph (implements org.apache.poi.xwpf.usermodel.IBodyElement)
    • org.apache.poi.xwpf.usermodel.XWPFPicture
    • org.apache.poi.xwpf.usermodel.XWPFRun
      • org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun
    • org.apache.poi.xwpf.usermodel.XWPFStyle
    • org.apache.poi.xwpf.usermodel.XWPFTable (implements org.apache.poi.xwpf.usermodel.IBodyElement)
    • org.apache.poi.xwpf.usermodel.XWPFTableCell (implements org.apache.poi.xwpf.usermodel.IBody)
    • org.apache.poi.xwpf.usermodel.XWPFTableRow

Interface Hierarchy

  • org.apache.poi.xwpf.usermodel.Document
  • org.apache.poi.xwpf.usermodel.IBody
  • org.apache.poi.xwpf.usermodel.IBodyElement

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • org.apache.poi.xwpf.usermodel.XWPFTableCell.XWPFVertAlign
      • org.apache.poi.xwpf.usermodel.XWPFTable.XWPFBorderType
      • org.apache.poi.xwpf.usermodel.VerticalAlign
      • org.apache.poi.xwpf.usermodel.UnderlinePatterns
      • org.apache.poi.xwpf.usermodel.TextAlignment
      • org.apache.poi.xwpf.usermodel.ParagraphAlignment
      • org.apache.poi.xwpf.usermodel.LineSpacingRule
      • org.apache.poi.xwpf.usermodel.BreakType
      • org.apache.poi.xwpf.usermodel.BreakClear
      • org.apache.poi.xwpf.usermodel.Borders
      • org.apache.poi.xwpf.usermodel.BodyType
      • org.apache.poi.xwpf.usermodel.BodyElementType
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.apache.poi.xwpf.usermodel

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.apache.poi.xwpf.usermodel

Packages that use org.apache.poi.xwpf.usermodel
org.apache.poi.xwpf.extractor
org.apache.poi.xwpf.model
org.apache.poi.xwpf.usermodel

Classes in org.apache.poi.xwpf.usermodel used by org.apache.poi.xwpf.extractor
XWPFDocument
Experimental class to do low level processing of docx files.
XWPFRelation

Classes in org.apache.poi.xwpf.usermodel used by org.apache.poi.xwpf.model
XWPFDocument
Experimental class to do low level processing of docx files.
XWPFFooter
Sketch of XWPF footer class
XWPFHeader
Sketch of XWPF header class
XWPFParagraph
Sketch of XWPF paragraph class

Classes in org.apache.poi.xwpf.usermodel used by org.apache.poi.xwpf.usermodel
BodyElementType
9 Jan 2010
BodyType
9 Jan 2010
Borders
Specifies all types of borders which can be specified for WordprocessingML objects which have a border.
BreakClear
Specifies the set of possible restart locations which may be used as to determine the next available line when a break's type attribute has a value of textWrapping.
BreakType
Specifies the possible types of break characters in a WordprocessingML document.
Document
IBody
8 Jan 2010
IBodyElement
9 Jan 2010
LineSpacingRule
Specifies the logic which shall be used to calculate the line spacing of the parent object when it is displayed in the document.
ParagraphAlignment
Specifies all types of alignment which are available to be applied to objects in a WordprocessingML document
PositionInParagraph
postion of a character in a paragrapho 1st RunPositon 2nd TextPosition 3rd CharacterPosition
TextAlignment
Specifies all types of vertical alignment which are available to be applied to of all text on each line displayed within a paragraph.
TextSegement
saves the begin and end position of a text in a Paragraph
UnderlinePatterns
Specifies the types of patterns which may be used to create the underline applied beneath the text in a run.
VerticalAlign
Specifies possible values for the alignment of the contents of this run in relation to the default appearance of the run's text.
XWPFAbstractNum
XWPFComment
Sketch of XWPF comment class
XWPFDocument
Experimental class to do low level processing of docx files.
XWPFFactory
XWPFFooter
Sketch of XWPF footer class
XWPFFootnote
XWPFFootnotes
Looks after the collection of Footnotes for a document
XWPFHeader
Sketch of XWPF header class
XWPFHeaderFooter
Parent of XWPF headers and footers
XWPFHyperlink
Sketch of XWPF hyperlink class
XWPFLatentStyles
XWPFNum
XWPFNumbering
XWPFParagraph
Sketch of XWPF paragraph class
XWPFPicture
XWPFPictureData
XWPFRelation
XWPFRun
XWPFRun object defines a region of text with a common set of properties
XWPFStyle
XWPFStyles
XWPFTable
Sketch of XWPFTable class.
XWPFTable.XWPFBorderType
XWPFTableCell
XWPFTableCell class.
XWPFTableCell.XWPFVertAlign
XWPFTableRow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ParagraphAlignment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum ParagraphAlignment

java.lang.Object
    extended by  java.lang.Enum<ParagraphAlignment>
        extended by  org.apache.poi.xwpf.usermodel.ParagraphAlignment
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<ParagraphAlignment>
public enum ParagraphAlignment
extends java.lang.Enum<ParagraphAlignment>

Specifies all types of alignment which are available to be applied to objects in a WordprocessingML document

Author:
Yegor Kozlov

Enum Constant Summary
BOTH
CENTER
DISTRIBUTE
HIGH_KASHIDA
LEFT
LOW_KASHIDA
MEDIUM_KASHIDA
NUM_TAB
RIGHT
THAI_DISTRIBUTE
Method Summary
int | getValue()
static ParagraphAlignment | valueOf(int type)
static ParagraphAlignment | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ParagraphAlignment[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LEFT

public static final ParagraphAlignment LEFT

CENTER

public static final ParagraphAlignment CENTER

RIGHT

public static final ParagraphAlignment RIGHT

BOTH

public static final ParagraphAlignment BOTH

MEDIUM_KASHIDA

public static final ParagraphAlignment MEDIUM_KASHIDA

DISTRIBUTE

public static final ParagraphAlignment DISTRIBUTE

NUM_TAB

public static final ParagraphAlignment NUM_TAB

HIGH_KASHIDA

public static final ParagraphAlignment HIGH_KASHIDA

LOW_KASHIDA

public static final ParagraphAlignment LOW_KASHIDA

THAI_DISTRIBUTE

public static final ParagraphAlignment THAI_DISTRIBUTE
Method Detail

values

public static ParagraphAlignment[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ParagraphAlignment c : ParagraphAlignment.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ParagraphAlignment valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static ParagraphAlignment valueOf(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


PositionInParagraph

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class PositionInParagraph

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.PositionInParagraph

public class PositionInParagraph
extends java.lang.Object

postion of a character in a paragrapho 1st RunPositon 2nd TextPosition 3rd CharacterPosition

Constructor Summary
PositionInParagraph()
PositionInParagraph(int posRun, int posText, int posChar)
Method Summary
int | getChar()
int | getRun()
int | getText()
void | setChar(int beginChar)
void | setRun(int beginRun)
void | setText(int beginText)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PositionInParagraph

public PositionInParagraph()

PositionInParagraph

public PositionInParagraph(int posRun,
                           int posText,
                           int posChar)
Method Detail

getRun

public int getRun()

setRun

public void setRun(int beginRun)

getText

public int getText()

setText

public void setText(int beginText)

getChar

public int getChar()

setChar

public void setChar(int beginChar)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextAlignment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum TextAlignment

java.lang.Object
    extended by  java.lang.Enum<TextAlignment>
        extended by  org.apache.poi.xwpf.usermodel.TextAlignment
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<TextAlignment>
public enum TextAlignment
extends java.lang.Enum<TextAlignment>

Specifies all types of vertical alignment which are available to be applied to of all text on each line displayed within a paragraph.

Author:
Gisella Bronzetti

Enum Constant Summary
AUTO
Specifies that all text in the parent object shall be aligned automatically when displayed.
BASELINE
Specifies that all text in the parent object shall be aligned to the baseline of each character when displayed.
BOTTOM
Specifies that all text in the parent object shall be aligned to the bottom of each character when displayed.
CENTER
Specifies that all text in the parent object shall be aligned to the center of each character when displayed.
TOP
Specifies that all text in the parent object shall be aligned to the top of each character when displayed
Method Summary
int | getValue()
static TextAlignment | valueOf(int type)
static TextAlignment | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextAlignment[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TOP

public static final TextAlignment TOP
Specifies that all text in the parent object shall be aligned to the top of each character when displayed

CENTER

public static final TextAlignment CENTER
Specifies that all text in the parent object shall be aligned to the center of each character when displayed.

BASELINE

public static final TextAlignment BASELINE
Specifies that all text in the parent object shall be aligned to the baseline of each character when displayed.

BOTTOM

public static final TextAlignment BOTTOM
Specifies that all text in the parent object shall be aligned to the bottom of each character when displayed.

AUTO

public static final TextAlignment AUTO
Specifies that all text in the parent object shall be aligned automatically when displayed.

Method Detail

values

public static TextAlignment[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (TextAlignment c : TextAlignment.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TextAlignment valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static TextAlignment valueOf(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


TextSegement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class TextSegement

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.TextSegement

public class TextSegement
extends java.lang.Object

saves the begin and end position of a text in a Paragraph

Constructor Summary
TextSegement()
TextSegement(int beginRun, int endRun, int beginText, int endText, int beginChar, int endChar)
TextSegement(PositionInParagraph beginPos, PositionInParagraph endPos)
Method Summary
int | getBeginChar()
PositionInParagraph | getBeginPos()
int | getBeginRun()
int | getBeginText()
int | getEndChar()
PositionInParagraph | getEndPos()
int | getEndRun()
int | getEndText()
void | setBeginChar(int beginChar)
void | setBeginRun(int beginRun)
void | setBeginText(int beginText)
void | setEndChar(int endChar)
void | setEndRun(int endRun)
void | setEndText(int endText)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextSegement

public TextSegement()

TextSegement

public TextSegement(int beginRun,
                    int endRun,
                    int beginText,
                    int endText,
                    int beginChar,
                    int endChar)

TextSegement

public TextSegement(PositionInParagraph beginPos,
                    PositionInParagraph endPos)
Method Detail

getBeginPos

public PositionInParagraph getBeginPos()

getEndPos

public PositionInParagraph getEndPos()

getBeginRun

public int getBeginRun()

setBeginRun

public void setBeginRun(int beginRun)

getBeginText

public int getBeginText()

setBeginText

public void setBeginText(int beginText)

getBeginChar

public int getBeginChar()

setBeginChar

public void setBeginChar(int beginChar)

getEndRun

public int getEndRun()

setEndRun

public void setEndRun(int endRun)

getEndText

public int getEndText()

setEndText

public void setEndText(int endText)

getEndChar

public int getEndChar()

setEndChar

public void setEndChar(int endChar)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TOC

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class TOC

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.TOC

public class TOC
extends java.lang.Object

Constructor Summary
TOC()
TOC(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSdtBlock block)
Method Summary
void | addRow(int level, java.lang.String title, int page, java.lang.String bookmarkRef)
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSdtBlock | getBlock()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TOC

public TOC()

TOC

public TOC(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSdtBlock block)
Method Detail

getBlock

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSdtBlock getBlock()

addRow

public void addRow(int level,
                   java.lang.String title,
                   int page,
                   java.lang.String bookmarkRef)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnderlinePatterns

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum UnderlinePatterns

java.lang.Object
    extended by  java.lang.Enum<UnderlinePatterns>
        extended by  org.apache.poi.xwpf.usermodel.UnderlinePatterns
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<UnderlinePatterns>
public enum UnderlinePatterns
extends java.lang.Enum<UnderlinePatterns>

Specifies the types of patterns which may be used to create the underline applied beneath the text in a run.

Author:
Gisella Bronzetti

Enum Constant Summary
DASH
Specifies an underline consisting of a dashed line beneath all characters in this run.
DASH_DOT_DOT_HEAVY
Specifies an underline consisting of a series of thick dash, dot, dot characters beneath all characters in this run.
DASH_DOT_HEAVY
Specifies an underline consisting of a series of thick dash, dot characters beneath all characters in this run.
DASH_LONG
Specifies an underline consisting of long dashed characters beneath all characters in this run.
DASH_LONG_HEAVY
Specifies an underline consisting of thick long dashed characters beneath all characters in this run.
DASHED_HEAVY
Specifies an underline consisting of a series of thick dashes beneath all characters in this run.
DOT_DASH
Specifies an underline consisting of a series of dash, dot characters beneath all characters in this run.
DOT_DOT_DASH
Specifies an underline consisting of a series of dash, dot, dot characters beneath all characters in this run.
DOTTED
Specifies an underline consisting of a series of dot characters beneath all characters in this run.
DOTTED_HEAVY
Specifies an underline consisting of a series of thick dot characters beneath all characters in this run.
DOUBLE
Specifies an underline consisting of two lines beneath all characters in this run
NONE
Specifies no underline beneath this run.
SINGLE
Specifies an underline consisting of a single line beneath all characters in this run.
THICK
Specifies an underline consisting of a single thick line beneath all characters in this run.
WAVE
Specifies an underline consisting of a single wavy line beneath all characters in this run.
WAVY_DOUBLE
Specifies an underline consisting of a pair of wavy lines beneath all characters in this run.
WAVY_HEAVY
Specifies an underline consisting of a single thick wavy line beneath all characters in this run.
WORDS
Specifies an underline consisting of a single line beneath all non-space characters in the run.
Method Summary
int | getValue()
static UnderlinePatterns | valueOf(int type)
static UnderlinePatterns | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static UnderlinePatterns[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

SINGLE

public static final UnderlinePatterns SINGLE
Specifies an underline consisting of a single line beneath all characters in this run.

WORDS

public static final UnderlinePatterns WORDS
Specifies an underline consisting of a single line beneath all non-space characters in the run. There shall be no underline beneath any space character (breaking or non-breaking).

DOUBLE

public static final UnderlinePatterns DOUBLE
Specifies an underline consisting of two lines beneath all characters in this run

THICK

public static final UnderlinePatterns THICK
Specifies an underline consisting of a single thick line beneath all characters in this run.

DOTTED

public static final UnderlinePatterns DOTTED
Specifies an underline consisting of a series of dot characters beneath all characters in this run.

DOTTED_HEAVY

public static final UnderlinePatterns DOTTED_HEAVY
Specifies an underline consisting of a series of thick dot characters beneath all characters in this run.

DASH

public static final UnderlinePatterns DASH
Specifies an underline consisting of a dashed line beneath all characters in this run.

DASHED_HEAVY

public static final UnderlinePatterns DASHED_HEAVY
Specifies an underline consisting of a series of thick dashes beneath all characters in this run.

DASH_LONG

public static final UnderlinePatterns DASH_LONG
Specifies an underline consisting of long dashed characters beneath all characters in this run.

DASH_LONG_HEAVY

public static final UnderlinePatterns DASH_LONG_HEAVY
Specifies an underline consisting of thick long dashed characters beneath all characters in this run.

DOT_DASH

public static final UnderlinePatterns DOT_DASH
Specifies an underline consisting of a series of dash, dot characters beneath all characters in this run.

DASH_DOT_HEAVY

public static final UnderlinePatterns DASH_DOT_HEAVY
Specifies an underline consisting of a series of thick dash, dot characters beneath all characters in this run.

DOT_DOT_DASH

public static final UnderlinePatterns DOT_DOT_DASH
Specifies an underline consisting of a series of dash, dot, dot characters beneath all characters in this run.

DASH_DOT_DOT_HEAVY

public static final UnderlinePatterns DASH_DOT_DOT_HEAVY
Specifies an underline consisting of a series of thick dash, dot, dot characters beneath all characters in this run.

WAVE

public static final UnderlinePatterns WAVE
Specifies an underline consisting of a single wavy line beneath all characters in this run.

WAVY_HEAVY

public static final UnderlinePatterns WAVY_HEAVY
Specifies an underline consisting of a single thick wavy line beneath all characters in this run.

WAVY_DOUBLE

public static final UnderlinePatterns WAVY_DOUBLE
Specifies an underline consisting of a pair of wavy lines beneath all characters in this run.

NONE

public static final UnderlinePatterns NONE
Specifies no underline beneath this run.

Method Detail

values

public static UnderlinePatterns[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (UnderlinePatterns c : UnderlinePatterns.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static UnderlinePatterns valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static UnderlinePatterns valueOf(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


VerticalAlign

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum VerticalAlign

java.lang.Object
    extended by  java.lang.Enum<VerticalAlign>
        extended by  org.apache.poi.xwpf.usermodel.VerticalAlign
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<VerticalAlign>
public enum VerticalAlign
extends java.lang.Enum<VerticalAlign>

Specifies possible values for the alignment of the contents of this run in relation to the default appearance of the run's text. This allows the text to be repositioned as subscript or superscript without altering the font size of the run properties.

Author:
Gisella Bronzetti

Enum Constant Summary
BASELINE
Specifies that the text in the parent run shall be located at the baseline and presented in the same size as surrounding text.
SUBSCRIPT
Specifies that this text should be superscript.
SUPERSCRIPT
Specifies that this text should be subscript.
Method Summary
int | getValue()
static VerticalAlign | valueOf(int type)
static VerticalAlign | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static VerticalAlign[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

BASELINE

public static final VerticalAlign BASELINE
Specifies that the text in the parent run shall be located at the baseline and presented in the same size as surrounding text.

SUPERSCRIPT

public static final VerticalAlign SUPERSCRIPT
Specifies that this text should be subscript. This setting shall lower the text in this run below the baseline and change it to a smaller size, if a smaller size is available.

SUBSCRIPT

public static final VerticalAlign SUBSCRIPT
Specifies that this text should be superscript. This setting shall raise the text in this run above the baseline and change it to a smaller size, if a smaller size is available.

Method Detail

values

public static VerticalAlign[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (VerticalAlign c : VerticalAlign.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static VerticalAlign valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()

valueOf

public static VerticalAlign valueOf(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


XWPFAbstractNum

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFAbstractNum

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFAbstractNum

public class XWPFAbstractNum
extends java.lang.Object

Author:
Philipp Epp

Field Summary
protected  XWPFNumbering numbering
Constructor Summary
protected | XWPFAbstractNum()
 | XWPFAbstractNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum abstractNum)
 | XWPFAbstractNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum ctAbstractNum, XWPFNumbering numbering)
Method Summary
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum | getAbstractNum()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum | getCTAbstractNum()
XWPFNumbering | getNumbering()
void | setNumbering(XWPFNumbering numbering)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

numbering

protected XWPFNumbering numbering
Constructor Detail

XWPFAbstractNum

protected XWPFAbstractNum()

XWPFAbstractNum

public XWPFAbstractNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum abstractNum)

XWPFAbstractNum

public XWPFAbstractNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum ctAbstractNum,
                       XWPFNumbering numbering)
Method Detail

getAbstractNum

public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum getAbstractNum()

getNumbering

public XWPFNumbering getNumbering()

getCTAbstractNum

public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum getCTAbstractNum()

setNumbering

public void setNumbering(XWPFNumbering numbering)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFComment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFComment

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFComment

public class XWPFComment
extends java.lang.Object

Sketch of XWPF comment class

Author:
Yury Batrakov (batrakov at gmail.com)

Field Summary
protected java.lang.String | author
protected java.lang.String | id
protected java.lang.StringBuffer | text
Constructor Summary
XWPFComment(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTComment comment, XWPFDocument document)
Method Summary
java.lang.String | getAuthor()
java.lang.String | getId()
java.lang.String | getText()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

id

protected java.lang.String id

author

protected java.lang.String author

text

protected java.lang.StringBuffer text
Constructor Detail

XWPFComment

public XWPFComment(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTComment comment,
                   XWPFDocument document)
Method Detail

getId

public java.lang.String getId()

getAuthor

public java.lang.String getAuthor()

getText

public java.lang.String getText()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFDocument

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFDocument

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.POIXMLDocument
            extended by  org.apache.poi.xwpf.usermodel.XWPFDocument
All Implemented Interfaces:
Document, IBody
public class XWPFDocument
extends POIXMLDocument
implements Document, IBody

Experimental class to do low level processing of docx files. If you're using these low level classes, then you will almost certainly need to refer to the OOXML specifications from http://www.ecma-international.org/publications/standards/Ecma-376.htm WARNING - APIs expected to change rapidly

Field Summary
protected java.util.List<IBodyElement> | bodyElements
protected java.util.List<XWPFComment> | comments
protected java.util.Map<java.lang.Integer,XWPFFootnote> | endnotes
protected java.util.List<XWPFFooter> | footers
protected XWPFFootnotes | footnotes
protected java.util.List<XWPFHeader> | headers
protected java.util.List<XWPFHyperlink> | hyperlinks
protected XWPFNumbering | numbering
protected java.util.Map<java.lang.Long,java.util.List<XWPFPictureData>> | packagePictures
protected java.util.List<XWPFParagraph> | paragraphs
protected java.util.List<XWPFPictureData> | pictures
protected XWPFStyles | styles
protected java.util.List<XWPFTable> | tables
Fields inherited from class org.apache.poi.POIXMLDocument
DOCUMENT_CREATOR, OLE_OBJECT_REL_TYPE, PACK_OBJECT_REL_TYPE
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Fields inherited from interface org.apache.poi.xwpf.usermodel.Document
PICTURE_TYPE_BMP, PICTURE_TYPE_DIB, PICTURE_TYPE_EMF, PICTURE_TYPE_EPS, PICTURE_TYPE_GIF, PICTURE_TYPE_JPEG, PICTURE_TYPE_PICT, PICTURE_TYPE_PNG, PICTURE_TYPE_TIFF, PICTURE_TYPE_WMF, PICTURE_TYPE_WPG
Constructor Summary
XWPFDocument()
XWPFDocument(java.io.InputStream is)
XWPFDocument(OPCPackage pkg)
Method Summary
XWPFFootnote | addEndnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note)
XWPFFootnote | addFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note)
java.lang.String | addPictureData(byte[] pictureData, int format)
java.lang.String | addPictureData(java.io.InputStream is, int format)
protected void | commit() commit and saves the document
XWPFFootnotes | createFootnotes() Creates an empty footnotes element for the document if one does not already exist
XWPFNumbering | createNumbering() Creates an empty numbering if one does not already exist and sets the numbering member
XWPFParagraph | createParagraph() Appends a new paragraph to this document
XWPFStyles | createStyles() Creates an empty styles for the document if one does not already exist
XWPFTable | createTable() Create an empty table with one row and one column as default.
XWPFTable | createTable(int rows, int cols) Create an empty table with a number of rows and cols specified
void | createTOC()
void | enforceCommentsProtection() Enforce the Comments protection. In the documentProtection tag inside settings.xml file, it sets the value of enforcement to "1" (w:enforcement="1") and the value of edit to comments (w:edit="comments") sample snippet from settings.xml
void | enforceFillingFormsProtection() Enforce the Filling Forms protection. In the documentProtection tag inside settings.xml file, it sets the value of enforcement to "1" (w:enforcement="1") and the value of edit to forms (w:edit="forms") sample snippet from settings.xml
void | enforceReadonlyProtection() Enforces the readOnly protection. In the documentProtection tag inside settings.xml file, it sets the value of enforcement to "1" (w:enforcement="1") and the value of edit to readOnly (w:edit="readOnly") sample snippet from settings.xml
void | enforceTrackedChangesProtection() Enforce the Tracked Changes protection. In the documentProtection tag inside settings.xml file, it sets the value of enforcement to "1" (w:enforcement="1") and the value of edit to trackedChanges (w:edit="trackedChanges") sample snippet from settings.xml
void | enforceUpdateFields() Enforces fields update on document open (in Word).
java.util.List<PackagePart> | getAllEmbedds() Get the document's embedded files.
java.util.List<XWPFPictureData> | getAllPackagePictures()
java.util.List<XWPFPictureData> | getAllPictures() Returns all Pictures, which are referenced from the document itself.
java.util.List<IBodyElement> | getBodyElements() returns an Iterator with paragraphs and tables
java.util.Iterator<IBodyElement> | getBodyElementsIterator()
XWPFComment | getCommentByID(java.lang.String id)
XWPFComment[] | getComments()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTDocument1 | getDocument() Returns the low level document base object
XWPFFootnote | getEndnoteByID(int id)
XWPFFooter | getFooterArray(int pos)
java.util.List<XWPFFooter> | getFooterList()
XWPFFootnote | getFootnoteByID(int id)
java.util.List<XWPFFootnote> | getFootnotes()
XWPFHeader | getHeaderArray(int pos)
XWPFHeaderFooterPolicy | getHeaderFooterPolicy() Returns the policy on headers and footers, which also provides a way to get at them.
java.util.List<XWPFHeader> | getHeaderList()
XWPFHyperlink | getHyperlinkByID(java.lang.String id)
XWPFHyperlink[] | getHyperlinks()
XWPFParagraph | getLastParagraph()
int | getNextPicNameNumber(int format) get the next free ImageNumber
XWPFNumbering | getNumbering() getNumbering
XWPFParagraph | getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) get the paragraph with the CTP class p
XWPFParagraph | getParagraphArray(int pos) Returns the paragraph that of position pos
int | getParagraphPos(int pos) Look up the paragraph at the specified position in the body elements list and return this paragraphs position in the paragraphs list
java.util.List<XWPFParagraph> | getParagraphs() Returns the paragraph(s) that holds the text of the header or footer.
java.util.Iterator<XWPFParagraph> | getParagraphsIterator()
POIXMLDocumentPart | getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell.
PackagePart | getPartById(java.lang.String id) Get the document part that's defined as the given relationship of the core document.
BodyType | getPartType() get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,
XWPFPictureData | getPictureDataByID(java.lang.String blipID) returns the PictureData by blipID
int | getPosOfParagraph(XWPFParagraph p) Get the position of the paragraph, within the list of all the body elements.
int | getPosOfTable(XWPFTable t) Get the position of the table, within the list of all the body elements.
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyles | getStyle() Returns the styles object used
XWPFStyles | getStyles() get Styles
XWPFTable | getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTbl) get a table by its CTTbl-Object
XWPFTable | getTableArray(int pos) Returns the table at position pos
XWPFTableCell | getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
int | getTablePos(int pos) get with the position of a table in the bodyelement array list the position of this table in the table array list
java.util.List<XWPFTable> | getTables() Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.
java.util.Iterator<XWPFTable> | getTablesIterator()
java.lang.String | getTblStyle(XWPFTable table)
XWPFDocument | getXWPFDocument() Return XWPFDocument
XWPFParagraph | insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) Add a new paragraph at position of the cursor.
XWPFTable | insertNewTbl(org.apache.xmlbeans.XmlCursor cursor) inserts a new Table at the cursor position.
void | insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
boolean | isEnforcedCommentsProtection() Verifies that the documentProtection tag in settings.xml file specifies that the protection is enforced (w:enforcement="1") and that the kind of protection is comments (w:edit="comments") sample snippet from settings.xml
boolean | isEnforcedFillingFormsProtection() Verifies that the documentProtection tag in settings.xml file specifies that the protection is enforced (w:enforcement="1") and that the kind of protection is forms (w:edit="forms") sample snippet from settings.xml
boolean | isEnforcedReadonlyProtection() Verifies that the documentProtection tag in settings.xml file specifies that the protection is enforced (w:enforcement="1") and that the kind of protection is readOnly (w:edit="readOnly") sample snippet from settings.xml
boolean | isEnforcedTrackedChangesProtection() Verifies that the documentProtection tag in settings.xml file specifies that the protection is enforced (w:enforcement="1") and that the kind of protection is trackedChanges (w:edit="trackedChanges") sample snippet from settings.xml
boolean | isEnforcedUpdateFields()
protected static OPCPackage | newPackage() Create a new WordProcessingML package and setup the default minimal content
protected void | onDocumentCreate() Create a new CTWorkbook with all values set to default
protected void | onDocumentRead() Fired when a package part is read
boolean | removeBodyElement(int pos) remove a BodyElement from bodyElements array list
void | removeProtectionEnforcement() Remove protection enforcement. In the documentProtection tag inside settings.xml file it sets the value of enforcement to "0" (w:enforcement="0")
void | setParagraph(XWPFParagraph paragraph, int pos) copies content of a paragraph to a existing paragraph in the list paragraphs at position pos
void | setTable(int pos, XWPFTable table) Replace content of table in array tables at position pos with a
Methods inherited from class org.apache.poi.POIXMLDocument
getCorePart, getPackage, getProperties, getRelatedByType, hasOOXMLHeader, load, openPackage, write
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

footers

protected java.util.List<XWPFFooter> footers

headers

protected java.util.List<XWPFHeader> headers

comments

protected java.util.List<XWPFComment> comments

hyperlinks

protected java.util.List<XWPFHyperlink> hyperlinks

paragraphs

protected java.util.List<XWPFParagraph> paragraphs

tables

protected java.util.List<XWPFTable> tables

bodyElements

protected java.util.List<IBodyElement> bodyElements

pictures

protected java.util.List<XWPFPictureData> pictures

packagePictures

protected java.util.Map<java.lang.Long,java.util.List<XWPFPictureData>> packagePictures

endnotes

protected java.util.Map<java.lang.Integer,XWPFFootnote> endnotes

numbering

protected XWPFNumbering numbering

styles

protected XWPFStyles styles

footnotes

protected XWPFFootnotes footnotes
Constructor Detail

XWPFDocument

public XWPFDocument(OPCPackage pkg)
             throws java.io.IOException
Throws:
java.io.IOException

XWPFDocument

public XWPFDocument(java.io.InputStream is)
             throws java.io.IOException
Throws:
java.io.IOException

XWPFDocument

public XWPFDocument()
Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Fired when a package part is read

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

newPackage

protected static OPCPackage newPackage()
Create a new WordProcessingML package and setup the default minimal content

onDocumentCreate

protected void onDocumentCreate()
Create a new CTWorkbook with all values set to default

Overrides:
onDocumentCreate in class POIXMLDocumentPart

getDocument

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTDocument1 getDocument()
Returns the low level document base object

getBodyElements

public java.util.List<IBodyElement> getBodyElements()
returns an Iterator with paragraphs and tables

Specified by:
getBodyElements in interface IBody
See Also:
IBody.getBodyElements()

getBodyElementsIterator

public java.util.Iterator<IBodyElement> getBodyElementsIterator()

getParagraphs

public java.util.List<XWPFParagraph> getParagraphs()
Description copied from interface: IBody
Returns the paragraph(s) that holds the text of the header or footer.

Specified by:
getParagraphs in interface IBody
See Also:
IBody.getParagraphs()

getTables

public java.util.List<XWPFTable> getTables()
Description copied from interface: IBody
Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.

Specified by:
getTables in interface IBody
See Also:
IBody.getTables()

getTableArray

public XWPFTable getTableArray(int pos)
Description copied from interface: IBody
Returns the table at position pos

Specified by:
getTableArray in interface IBody
See Also:
IBody.getTableArray(int)

getFooterList

public java.util.List<XWPFFooter> getFooterList()
Returns:
the list of footers

getFooterArray

public XWPFFooter getFooterArray(int pos)

getHeaderList

public java.util.List<XWPFHeader> getHeaderList()
Returns:
the list of headers

getHeaderArray

public XWPFHeader getHeaderArray(int pos)

getTblStyle

public java.lang.String getTblStyle(XWPFTable table)

getHyperlinkByID

public XWPFHyperlink getHyperlinkByID(java.lang.String id)

getFootnoteByID

public XWPFFootnote getFootnoteByID(int id)

getEndnoteByID

public XWPFFootnote getEndnoteByID(int id)

getFootnotes

public java.util.List<XWPFFootnote> getFootnotes()

getHyperlinks

public XWPFHyperlink[] getHyperlinks()

getCommentByID

public XWPFComment getCommentByID(java.lang.String id)

getComments

public XWPFComment[] getComments()

getPartById

public PackagePart getPartById(java.lang.String id)
Get the document part that's defined as the given relationship of the core document.

getHeaderFooterPolicy

public XWPFHeaderFooterPolicy getHeaderFooterPolicy()
Returns the policy on headers and footers, which also provides a way to get at them.

getStyle

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyles getStyle()
                                                                         throws org.apache.xmlbeans.XmlException,
                                                                                java.io.IOException
Returns the styles object used

Throws:
org.apache.xmlbeans.XmlException
java.io.IOException

getAllEmbedds

public java.util.List<PackagePart> getAllEmbedds()
                                          throws OpenXML4JException
Get the document's embedded files.

Specified by:
getAllEmbedds in class POIXMLDocument
Throws:
OpenXML4JException

getParagraphPos

public int getParagraphPos(int pos)
Look up the paragraph at the specified position in the body elements list and return this paragraphs position in the paragraphs list

Parameters:
pos - The position of the relevant paragraph in the body elements list
Returns:
the position of the paragraph in the paragraphs list, if there is a paragraph at the position in the bodyelements list. Else it will return -1

getTablePos

public int getTablePos(int pos)
get with the position of a table in the bodyelement array list the position of this table in the table array list

Parameters:
pos - position of the table in the bodyelement array list
Returns:
if there is a table at the position in the bodyelement array list, else it will return null.

insertNewParagraph

public XWPFParagraph insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor)
Add a new paragraph at position of the cursor. The cursor must be on the XmlCursor.TokenType.START tag of an subelement of the documents body. When this method is done, the cursor passed as parameter points to the XmlCursor.TokenType.END of the newly inserted paragraph.

Specified by:
insertNewParagraph in interface IBody
Parameters:
cursor -
Returns:
the XWPFParagraph object representing the newly inserted CTP object

insertNewTbl

public XWPFTable insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
Description copied from interface: IBody
inserts a new Table at the cursor position.

Specified by:
insertNewTbl in interface IBody

getPosOfParagraph

public int getPosOfParagraph(XWPFParagraph p)
Get the position of the paragraph, within the list of all the body elements.

Parameters:
p - The paragraph to find
Returns:
The location, or -1 if the paragraph couldn't be found

getPosOfTable

public int getPosOfTable(XWPFTable t)
Get the position of the table, within the list of all the body elements.

Parameters:
t - The table to find
Returns:
The location, or -1 if the table couldn't be found

commit

protected void commit()
               throws java.io.IOException
commit and saves the document

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

createParagraph

public XWPFParagraph createParagraph()
Appends a new paragraph to this document

Returns:
a new paragraph

createNumbering

public XWPFNumbering createNumbering()
Creates an empty numbering if one does not already exist and sets the numbering member

Returns:
numbering

createStyles

public XWPFStyles createStyles()
Creates an empty styles for the document if one does not already exist

Returns:
styles

createFootnotes

public XWPFFootnotes createFootnotes()
Creates an empty footnotes element for the document if one does not already exist

Returns:
footnotes

addFootnote

public XWPFFootnote addFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note)

addEndnote

public XWPFFootnote addEndnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note)

removeBodyElement

public boolean removeBodyElement(int pos)
remove a BodyElement from bodyElements array list

Parameters:
pos -
Returns:
true if removing was successfully, else return false

setParagraph

public void setParagraph(XWPFParagraph paragraph,
                         int pos)
copies content of a paragraph to a existing paragraph in the list paragraphs at position pos

Parameters:
paragraph -
pos -

getLastParagraph

public XWPFParagraph getLastParagraph()
Returns:
the LastParagraph of the document

createTable

public XWPFTable createTable()
Create an empty table with one row and one column as default.

Returns:
a new table

createTable

public XWPFTable createTable(int rows,
                             int cols)
Create an empty table with a number of rows and cols specified

Parameters:
rows -
cols -
Returns:
table

createTOC

public void createTOC()

setTable

public void setTable(int pos,
                     XWPFTable table)
Replace content of table in array tables at position pos with a

Parameters:
pos -
table -

isEnforcedReadonlyProtection

public boolean isEnforcedReadonlyProtection()
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is readOnly (w:edit="readOnly")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="readOnly" w:enforcement="1"/>

Returns:
true if documentProtection is enforced with option readOnly

isEnforcedFillingFormsProtection

public boolean isEnforcedFillingFormsProtection()
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is forms (w:edit="forms")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="forms" w:enforcement="1"/>

Returns:
true if documentProtection is enforced with option forms

isEnforcedCommentsProtection

public boolean isEnforcedCommentsProtection()
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is comments (w:edit="comments")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="comments" w:enforcement="1"/>

Returns:
true if documentProtection is enforced with option comments

isEnforcedTrackedChangesProtection

public boolean isEnforcedTrackedChangesProtection()
Verifies that the documentProtection tag in settings.xml file
specifies that the protection is enforced (w:enforcement="1")
and that the kind of protection is trackedChanges (w:edit="trackedChanges")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="trackedChanges" w:enforcement="1"/>

Returns:
true if documentProtection is enforced with option trackedChanges

isEnforcedUpdateFields

public boolean isEnforcedUpdateFields()

enforceReadonlyProtection

public void enforceReadonlyProtection()
Enforces the readOnly protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to readOnly (w:edit="readOnly")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="readOnly" w:enforcement="1"/>

enforceFillingFormsProtection

public void enforceFillingFormsProtection()
Enforce the Filling Forms protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to forms (w:edit="forms")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="forms" w:enforcement="1"/>

enforceCommentsProtection

public void enforceCommentsProtection()
Enforce the Comments protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to comments (w:edit="comments")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="comments" w:enforcement="1"/>

enforceTrackedChangesProtection

public void enforceTrackedChangesProtection()
Enforce the Tracked Changes protection.
In the documentProtection tag inside settings.xml file,
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to trackedChanges (w:edit="trackedChanges")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="trackedChanges" w:enforcement="1"/>

removeProtectionEnforcement

public void removeProtectionEnforcement()
Remove protection enforcement.
In the documentProtection tag inside settings.xml file
it sets the value of enforcement to "0" (w:enforcement="0")

enforceUpdateFields

public void enforceUpdateFields()
Enforces fields update on document open (in Word). In the settings.xml file
sets the updateSettings value to true (w:updateSettings w:val="true") NOTICES:
  • Causing Word to ask on open: "This document contains fields that may refer to other files. Do you want to update the fields in this document?" (if "Update automatic links at open" is enabled)
  • Flag is removed after saving with changes in Word

insertTable

public void insertTable(int pos,
                        XWPFTable table)
inserts an existing XWPFTable to the arrays bodyElements and tables

Specified by:
insertTable in interface IBody
Parameters:
pos -
table -

getAllPictures

public java.util.List<XWPFPictureData> getAllPictures()
Returns all Pictures, which are referenced from the document itself.

Returns:
a List of XWPFPictureData. The returned List is unmodifiable. Use #a

getAllPackagePictures

public java.util.List<XWPFPictureData> getAllPackagePictures()
Returns:
all Pictures in this package

addPictureData

public java.lang.String addPictureData(byte[] pictureData,
                                       int format)
                                throws InvalidFormatException
Throws:
InvalidFormatException

addPictureData

public java.lang.String addPictureData(java.io.InputStream is,
                                       int format)
                                throws InvalidFormatException
Throws:
InvalidFormatException

getNextPicNameNumber

public int getNextPicNameNumber(int format)
                         throws InvalidFormatException
get the next free ImageNumber

Parameters:
format -
Returns:
the next free ImageNumber
Throws:
InvalidFormatException

getPictureDataByID

public XWPFPictureData getPictureDataByID(java.lang.String blipID)
returns the PictureData by blipID

Parameters:
blipID -
Returns:
XWPFPictureData of a specificID

getNumbering

public XWPFNumbering getNumbering()
getNumbering

Returns:
numbering

getStyles

public XWPFStyles getStyles()
get Styles

Returns:
styles for this document

getParagraph

public XWPFParagraph getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p)
get the paragraph with the CTP class p

Specified by:
getParagraph in interface IBody
Parameters:
p -
Returns:
the paragraph with the CTP class p

getTable

public XWPFTable getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTbl)
get a table by its CTTbl-Object

Specified by:
getTable in interface IBody
Parameters:
ctTbl -
Returns:
a table by its CTTbl-Object or null
See Also:
IBody.getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl)

getTablesIterator

public java.util.Iterator<XWPFTable> getTablesIterator()

getParagraphsIterator

public java.util.Iterator<XWPFParagraph> getParagraphsIterator()

getParagraphArray

public XWPFParagraph getParagraphArray(int pos)
Returns the paragraph that of position pos

Specified by:
getParagraphArray in interface IBody
See Also:
IBody.getParagraphArray(int)

getPart

public POIXMLDocumentPart getPart()
returns the Part, to which the body belongs, which you need for adding relationship to other parts Actually it is needed of the class XWPFTableCell. Because you have to know to which part the tableCell belongs.

Specified by:
getPart in interface IBody
Returns:
the Part, to which the body belongs
See Also:
IBody.getPart()

getPartType

public BodyType getPartType()
get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,

Specified by:
getPartType in interface IBody
Returns:
the PartType of the body
See Also:
IBody.getPartType()

getTableCell

public XWPFTableCell getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell)
get the TableCell which belongs to the TableCell

Specified by:
getTableCell in interface IBody
Parameters:
cell -

getXWPFDocument

public XWPFDocument getXWPFDocument()
Description copied from interface: IBody
Return XWPFDocument

Specified by:
getXWPFDocument in interface IBody
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFFactory

java.lang.Object
    extended by  org.apache.poi.POIXMLFactory
        extended by  org.apache.poi.xwpf.usermodel.XWPFFactory

public final class XWPFFactory
extends POIXMLFactory

Author:
Yegor Kozlov

Method Summary
POIXMLDocumentPart | createDocumentPart(POIXMLDocumentPart parent, PackageRelationship rel, PackagePart part) Create a POIXMLDocumentPart from existing package part and relation.
static XWPFFactory | getInstance()
POIXMLDocumentPart | newDocumentPart(POIXMLRelation descriptor) Create a new POIXMLDocumentPart using the supplied descriptor.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static XWPFFactory getInstance()

createDocumentPart

public POIXMLDocumentPart createDocumentPart(POIXMLDocumentPart parent,
                                             PackageRelationship rel,
                                             PackagePart part)
Description copied from class: POIXMLFactory
Create a POIXMLDocumentPart from existing package part and relation. This method is called from POIXMLDocument.load(POIXMLFactory) when parsing a document

Specified by:
createDocumentPart in class POIXMLFactory
Parameters:
parent - parent part
rel - the package part relationship
part - the PackagePart representing the created instance
Returns:
A new instance of a POIXMLDocumentPart.

newDocumentPart

public POIXMLDocumentPart newDocumentPart(POIXMLRelation descriptor)
Description copied from class: POIXMLFactory
Create a new POIXMLDocumentPart using the supplied descriptor. This method is used when adding new parts to a document, for example, when adding a sheet to a workbook, slide to a presentation, etc.

Specified by:
newDocumentPart in class POIXMLFactory
Parameters:
descriptor - describes the object to create
Returns:
A new instance of a POIXMLDocumentPart.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFFooter

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
            extended by  org.apache.poi.xwpf.usermodel.XWPFFooter
All Implemented Interfaces:
IBody
public class XWPFFooter
extends XWPFHeaderFooter

Sketch of XWPF footer class

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XWPFFooter()
XWPFFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFFooter(XWPFDocument doc, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr hdrFtr)
Method Summary
protected void | commit() save and commit footer
BodyType | getPartType() get the PartType of the body
protected void | onDocumentRead() Fired when a package part is read
Methods inherited from class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
_getHdrFtr, addPictureData, addPictureData, getAllPackagePictures, getAllPictures, getBodyElements, getListParagraph, getOwner, getParagraph, getParagraphArray, getParagraphs, getPart, getPictureDataByID, getTable, getTableArray, getTableCell, getTables, getText, getXWPFDocument, insertNewParagraph, insertNewTbl, insertTable, readHdrFtr, setHeaderFooter, setXWPFDocument
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XWPFFooter

public XWPFFooter()

XWPFFooter

public XWPFFooter(XWPFDocument doc,
                  org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr hdrFtr)
           throws java.io.IOException
Throws:
java.io.IOException

XWPFFooter

public XWPFFooter(POIXMLDocumentPart parent,
                  PackagePart part,
                  PackageRelationship rel)
           throws java.io.IOException
Throws:
java.io.IOException
Method Detail

commit

protected void commit()
               throws java.io.IOException
save and commit footer

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Fired when a package part is read

Overrides:
onDocumentRead in class XWPFHeaderFooter
Throws:
java.io.IOException

getPartType

public BodyType getPartType()
get the PartType of the body

Returns:
the PartType of the body
See Also:
IBody.getPartType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFFootnote

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFFootnote

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFFootnote
All Implemented Interfaces:
java.lang.Iterable<XWPFParagraph>, IBody
public class XWPFFootnote
extends java.lang.Object
implements java.lang.Iterable<XWPFParagraph>, IBody

Constructor Summary
XWPFFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note, XWPFFootnotes xFootnotes)
XWPFFootnote(XWPFDocument document, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn body)
Method Summary
XWPFParagraph | addNewParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP paragraph) add a new paragraph to the end of the footnote
XWPFTable | addNewTbl(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table) add a new table to the end of the footnote
java.util.List<IBodyElement> | getBodyElements() Returns an Iterator with paragraphs and tables, in the order that they occur in the text.
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn | getCTFtnEdn()
POIXMLDocumentPart | getOwner()
XWPFParagraph | getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | getParagraphArray(int pos) Returns the paragraph that holds the text of the header or footer.
java.util.List<XWPFParagraph> | getParagraphs() Returns the paragraph(s) that holds the text of the header or footer.
POIXMLDocumentPart | getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts
BodyType | getPartType() get the PartType of the body
java.util.List<XWPFPictureData> | getPictures()
XWPFTable | getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
XWPFTable | getTableArray(int pos) Returns the table at position pos
XWPFTableCell | getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
java.util.List<XWPFTable> | getTables() Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.
XWPFDocument | getXWPFDocument() Return XWPFDocument
XWPFParagraph | insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) add a new paragraph at position of the cursor
XWPFTable | insertNewTbl(org.apache.xmlbeans.XmlCursor cursor) inserts a new Table at the cursor position.
void | insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
java.util.Iterator<XWPFParagraph> | iterator()
void | setCTFtnEdn(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn footnote)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWPFFootnote

public XWPFFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note,
                    XWPFFootnotes xFootnotes)

XWPFFootnote

public XWPFFootnote(XWPFDocument document,
                    org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn body)
Method Detail

getParagraphs

public java.util.List<XWPFParagraph> getParagraphs()
Description copied from interface: IBody
Returns the paragraph(s) that holds the text of the header or footer.

Specified by:
getParagraphs in interface IBody

iterator

public java.util.Iterator<XWPFParagraph> iterator()
Specified by:
iterator in interface java.lang.Iterable<XWPFParagraph>

getTables

public java.util.List<XWPFTable> getTables()
Description copied from interface: IBody
Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.

Specified by:
getTables in interface IBody

getPictures

public java.util.List<XWPFPictureData> getPictures()

getBodyElements

public java.util.List<IBodyElement> getBodyElements()
Description copied from interface: IBody
Returns an Iterator with paragraphs and tables, in the order that they occur in the text.

Specified by:
getBodyElements in interface IBody

getCTFtnEdn

public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn getCTFtnEdn()

setCTFtnEdn

public void setCTFtnEdn(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn footnote)

getTableArray

public XWPFTable getTableArray(int pos)
Description copied from interface: IBody
Returns the table at position pos

Specified by:
getTableArray in interface IBody
Parameters:
pos - in table array
Returns:
The table at position pos
See Also:
IBody.getTableArray(int)

insertTable

public void insertTable(int pos,
                        XWPFTable table)
inserts an existing XWPFTable to the arrays bodyElements and tables

Specified by:
insertTable in interface IBody
Parameters:
pos -
table -
See Also:
IBody.insertTable(int pos, XWPFTable table)

getTable

public XWPFTable getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable)
if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null

Specified by:
getTable in interface IBody
Parameters:
ctTable -
See Also:
IBody.getTable(CTTbl ctTable)

getParagraph

public XWPFParagraph getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p)
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null

Specified by:
getParagraph in interface IBody
Parameters:
p - is instance of CTP and is searching for an XWPFParagraph
Returns:
null if there is no XWPFParagraph with an corresponding CTPparagraph in the paragraphList of this header or footer XWPFParagraph with the correspondig CTP p
See Also:
IBody.getParagraph(CTP p)

getParagraphArray

public XWPFParagraph getParagraphArray(int pos)
Returns the paragraph that holds the text of the header or footer.

Specified by:
getParagraphArray in interface IBody
See Also:
IBody.getParagraphArray(int pos)

getTableCell

public XWPFTableCell getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell)
get the TableCell which belongs to the TableCell

Specified by:
getTableCell in interface IBody
Parameters:
cell -
See Also:
IBody.getTableCell(CTTc cell)

getOwner

public POIXMLDocumentPart getOwner()

insertNewTbl

public XWPFTable insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
Description copied from interface: IBody
inserts a new Table at the cursor position.

Specified by:
insertNewTbl in interface IBody
Parameters:
cursor -
Returns:
the inserted table
See Also:
IBody.insertNewTbl(XmlCursor cursor)

insertNewParagraph

public XWPFParagraph insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor)
add a new paragraph at position of the cursor

Specified by:
insertNewParagraph in interface IBody
Parameters:
cursor -
Returns:
the inserted paragraph
See Also:
IBody.insertNewParagraph(XmlCursor cursor)

addNewTbl

public XWPFTable addNewTbl(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table)
add a new table to the end of the footnote

Parameters:
table -
Returns:
the added XWPFTable

addNewParagraph

public XWPFParagraph addNewParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP paragraph)
add a new paragraph to the end of the footnote

Parameters:
paragraph -
Returns:
the added XWPFParagraph

getXWPFDocument

public XWPFDocument getXWPFDocument()
Description copied from interface: IBody
Return XWPFDocument

Specified by:
getXWPFDocument in interface IBody
See Also:
IBody.getXWPFDocument()

getPart

public POIXMLDocumentPart getPart()
returns the Part, to which the body belongs, which you need for adding relationship to other parts

Specified by:
getPart in interface IBody
Returns:
the Part, to which the body belongs
See Also:
IBody.getPart()

getPartType

public BodyType getPartType()
get the PartType of the body

Specified by:
getPartType in interface IBody
Returns:
the PartType of the body
See Also:
IBody.getPartType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFFootnotes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFFootnotes

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFFootnotes

public class XWPFFootnotes
extends POIXMLDocumentPart

Looks after the collection of Footnotes for a document

Author:
Mike McEuen (mceuen@hp.com)

Field Summary
protected  XWPFDocument document
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XWPFFootnotes()
Construct XWPFFootnotes from scratch for a new document.
XWPFFootnotes(PackagePart part, PackageRelationship rel)
Construct XWPFFootnotes from a package part
Method Summary
XWPFFootnote | addFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note) add a footnote to the document
void | addFootnote(XWPFFootnote footnote) add an XWPFFootnote to the document
protected void | commit() Save the content in the underlying package part.
XWPFFootnote | getFootnoteById(int id)
java.util.List<XWPFFootnote> | getFootnotesList()
XWPFDocument | getXWPFDocument()
protected void | onDocumentRead() Read document
void | setFootnotes(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFootnotes footnotes) Sets the ctFootnotes
void | setXWPFDocument(XWPFDocument doc)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

document

protected XWPFDocument document
Constructor Detail

XWPFFootnotes

public XWPFFootnotes(PackagePart part,
                     PackageRelationship rel)
              throws java.io.IOException,
                     OpenXML4JException
Construct XWPFFootnotes from a package part

Parameters:
part - the package part holding the data of the footnotes,
rel - the package relationship of type "http://schemas.openxmlformats.org/officeDocument/2006/relationships/footnotes"
Throws:
java.io.IOException
OpenXML4JException

XWPFFootnotes

public XWPFFootnotes()
Construct XWPFFootnotes from scratch for a new document.

Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Read document

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

getFootnotesList

public java.util.List<XWPFFootnote> getFootnotesList()

getFootnoteById

public XWPFFootnote getFootnoteById(int id)

setFootnotes

public void setFootnotes(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFootnotes footnotes)
Sets the ctFootnotes

Parameters:
footnotes -

addFootnote

public void addFootnote(XWPFFootnote footnote)
add an XWPFFootnote to the document

Parameters:
footnote -
Throws:
java.io.IOException

addFootnote

public XWPFFootnote addFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note)
add a footnote to the document

Parameters:
note -
Throws:
java.io.IOException

setXWPFDocument

public void setXWPFDocument(XWPFDocument doc)

getXWPFDocument

public XWPFDocument getXWPFDocument()
See Also:
IBody.getPart()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFHeader

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFHeader

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
            extended by  org.apache.poi.xwpf.usermodel.XWPFHeader
All Implemented Interfaces:
IBody
public class XWPFHeader
extends XWPFHeaderFooter

Sketch of XWPF header class

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XWPFHeader()
XWPFHeader(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
XWPFHeader(XWPFDocument doc, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr hdrFtr)
Method Summary
protected void | commit() save and commit footer
BodyType | getPartType() get the PartType of the body
protected void | onDocumentRead() reads the document
Methods inherited from class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
_getHdrFtr, addPictureData, addPictureData, getAllPackagePictures, getAllPictures, getBodyElements, getListParagraph, getOwner, getParagraph, getParagraphArray, getParagraphs, getPart, getPictureDataByID, getTable, getTableArray, getTableCell, getTables, getText, getXWPFDocument, insertNewParagraph, insertNewTbl, insertTable, readHdrFtr, setHeaderFooter, setXWPFDocument
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XWPFHeader

public XWPFHeader()

XWPFHeader

public XWPFHeader(POIXMLDocumentPart parent,
                  PackagePart part,
                  PackageRelationship rel)
           throws java.io.IOException
Throws:
java.io.IOException

XWPFHeader

public XWPFHeader(XWPFDocument doc,
                  org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr hdrFtr)
Method Detail

commit

protected void commit()
               throws java.io.IOException
save and commit footer

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
reads the document

Overrides:
onDocumentRead in class XWPFHeaderFooter
Throws:
java.io.IOException

getPartType

public BodyType getPartType()
get the PartType of the body

Returns:
the PartType of the body
See Also:
IBody.getPartType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFHeaderFooter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFHeaderFooter

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFHeaderFooter
All Implemented Interfaces:
IBody
Direct Known Subclasses:
XWPFFooter, XWPFHeader
public abstract class XWPFHeaderFooter
extends POIXMLDocumentPart
implements IBody

Parent of XWPF headers and footers

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected | XWPFHeaderFooter()
 | XWPFHeaderFooter(POIXMLDocumentPart parent, PackagePart part, PackageRelationship rel)
Method Summary
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr | _getHdrFtr()
java.lang.String | addPictureData(byte[] pictureData, int format) Adds a picture to the document.
java.lang.String | addPictureData(java.io.InputStream is, int format) Adds a picture to the document.
java.util.List<XWPFPictureData> | getAllPackagePictures() get all Pictures in this package
java.util.List<XWPFPictureData> | getAllPictures()
java.util.List<IBodyElement> | getBodyElements() Returns an Iterator with paragraphs and tables, in the order that they occur in the text.
java.util.List<XWPFParagraph> | getListParagraph() get a List of all Paragraphs
POIXMLDocumentPart | getOwner()
XWPFParagraph | getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | getParagraphArray(int pos) Returns the paragraph that holds the text of the header or footer.
java.util.List<XWPFParagraph> | getParagraphs() Returns the paragraph(s) that holds the text of the header or footer.
POIXMLDocumentPart | getPart() returns the Part, to which the body belongs, which you need for adding relationship to other parts
XWPFPictureData | getPictureDataByID(java.lang.String blipID) returns the PictureData by blipID
XWPFTable | getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
XWPFTable | getTableArray(int pos) Returns the table at position pos
XWPFTableCell | getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
java.util.List<XWPFTable> | getTables() Return the table(s) that holds the text of the header or footer, for complex cases where a paragraph isn't used.
java.lang.String | getText() Returns the textual content of the header/footer, by flattening out the text of its paragraph(s)
XWPFDocument | getXWPFDocument() Return XWPFDocument
XWPFParagraph | insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) add a new paragraph at position of the cursor
XWPFTable | insertNewTbl(org.apache.xmlbeans.XmlCursor cursor) inserts a new Table at the cursor position.
void | insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
protected void | onDocumentRead() Fired when a package part is read
void | readHdrFtr()
void | setHeaderFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr headerFooter) set a new headerFooter
void | setXWPFDocument(XWPFDocument doc)
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.apache.poi.xwpf.usermodel.IBody
getPartType

Constructor Detail

XWPFHeaderFooter

protected XWPFHeaderFooter()

XWPFHeaderFooter

public XWPFHeaderFooter(POIXMLDocumentPart parent,
                        PackagePart part,
                        PackageRelationship rel)
                 throws java.io.IOException
Throws:
java.io.IOException
Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Fired when a package part is read

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

_getHdrFtr

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr _getHdrFtr()

getBodyElements

public java.util.List<IBodyElement> getBodyElements()
Description copied from interface: IBody
Returns an Iterator with paragraphs and tables, in the order that they occur in the text.

Specified by:
getBodyElements in interface IBody

getParagraphs

public java.util.List<XWPFParagraph> getParagraphs()
Returns the paragraph(s) that holds the text of the header or footer. Normally there is only the one paragraph, but there could be more in certain cases, or a table.

Specified by:
getParagraphs in interface IBody

getTables

public java.util.List<XWPFTable> getTables()
                                    throws java.lang.ArrayIndexOutOfBoundsException
Return the table(s) that holds the text of the header or footer, for complex cases where a paragraph isn't used. Normally there's just one paragraph, but some complex headers/footers have a table or two in addition.

Specified by:
getTables in interface IBody
Throws:
java.lang.ArrayIndexOutOfBoundsException

getText

public java.lang.String getText()
Returns the textual content of the header/footer, by flattening out the text of its paragraph(s)

setHeaderFooter

public void setHeaderFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr headerFooter)
set a new headerFooter

getTable

public XWPFTable getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable)
if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null

Specified by:
getTable in interface IBody
Parameters:
ctTable -

getParagraph

public XWPFParagraph getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p)
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null

Specified by:
getParagraph in interface IBody
Parameters:
p - is instance of CTP and is searching for an XWPFParagraph
Returns:
null if there is no XWPFParagraph with an corresponding CTPparagraph in the paragraphList of this header or footer XWPFParagraph with the correspondig CTP p

getParagraphArray

public XWPFParagraph getParagraphArray(int pos)
Returns the paragraph that holds the text of the header or footer.

Specified by:
getParagraphArray in interface IBody

getListParagraph

public java.util.List<XWPFParagraph> getListParagraph()
get a List of all Paragraphs

Returns:
a list of XWPFParagraph

getAllPictures

public java.util.List<XWPFPictureData> getAllPictures()

getAllPackagePictures

public java.util.List<XWPFPictureData> getAllPackagePictures()
get all Pictures in this package

Returns:
all Pictures in this package

addPictureData

public java.lang.String addPictureData(byte[] pictureData,
                                       int format)
                                throws InvalidFormatException
Adds a picture to the document.

Parameters:
pictureData - The picture data
format - The format of the picture.
Returns:
the index to this picture (0 based), the added picture can be obtained from getAllPictures() .
Throws:
InvalidFormatException

addPictureData

public java.lang.String addPictureData(java.io.InputStream is,
                                       int format)
                                throws InvalidFormatException,
                                       java.io.IOException
Adds a picture to the document.

Parameters:
is - The stream to read image from
format - The format of the picture.
Returns:
the index to this picture (0 based), the added picture can be obtained from getAllPictures() .
Throws:
InvalidFormatException
java.io.IOException

getPictureDataByID

public XWPFPictureData getPictureDataByID(java.lang.String blipID)
returns the PictureData by blipID

Parameters:
blipID -
Returns:
XWPFPictureData of a specificID
Throws:
java.lang.Exception

insertNewParagraph

public XWPFParagraph insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor)
add a new paragraph at position of the cursor

Specified by:
insertNewParagraph in interface IBody
Parameters:
cursor -
Returns:
the inserted paragraph

insertNewTbl

public XWPFTable insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
Description copied from interface: IBody
inserts a new Table at the cursor position.

Specified by:
insertNewTbl in interface IBody
Parameters:
cursor -
Returns:
the inserted table

getOwner

public POIXMLDocumentPart getOwner()

getTableArray

public XWPFTable getTableArray(int pos)
Returns the table at position pos

Specified by:
getTableArray in interface IBody
See Also:
IBody.getTableArray(int)

insertTable

public void insertTable(int pos,
                        XWPFTable table)
inserts an existing XWPFTable to the arrays bodyElements and tables

Specified by:
insertTable in interface IBody
Parameters:
pos -
table -

readHdrFtr

public void readHdrFtr()

getTableCell

public XWPFTableCell getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell)
get the TableCell which belongs to the TableCell

Specified by:
getTableCell in interface IBody
Parameters:
cell -

setXWPFDocument

public void setXWPFDocument(XWPFDocument doc)

getXWPFDocument

public XWPFDocument getXWPFDocument()
Description copied from interface: IBody
Return XWPFDocument

Specified by:
getXWPFDocument in interface IBody

getPart

public POIXMLDocumentPart getPart()
returns the Part, to which the body belongs, which you need for adding relationship to other parts

Specified by:
getPart in interface IBody
Returns:
the Part, to which the body belongs
See Also:
IBody.getPart()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFHyperlink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFHyperlink

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFHyperlink

public class XWPFHyperlink
extends java.lang.Object

Sketch of XWPF hyperlink class

Author:
Yury Batrakov (batrakov at gmail.com)

Constructor Summary
XWPFHyperlink(java.lang.String id, java.lang.String url)
Method Summary
java.lang.String | getId()
java.lang.String | getURL()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWPFHyperlink

public XWPFHyperlink(java.lang.String id,
                     java.lang.String url)
Method Detail

getId

public java.lang.String getId()

getURL

public java.lang.String getURL()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFHyperlinkRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFHyperlinkRun

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFRun
        extended by  org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

public class XWPFHyperlinkRun
extends XWPFRun

A run of text with a Hyperlink applied to it. Any given Hyperlink may be made up of multiple of these.

Constructor Summary
XWPFHyperlinkRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHyperlink hyperlink, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR run, XWPFParagraph p)
Method Summary
java.lang.String | getAnchor()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHyperlink | getCTHyperlink()
XWPFHyperlink | getHyperlink(XWPFDocument document) If this Hyperlink is an external reference hyperlink, return the object for it.
java.lang.String | getHyperlinkId() Returns the ID of the hyperlink, if one is set.
void | setHyperlinkId(java.lang.String id)
Methods inherited from class org.apache.poi.xwpf.usermodel.XWPFRun
addBreak, addBreak, addBreak, addCarriageReturn, addPicture, getColor, getCTR, getDocument, getEmbeddedPictures, getFontFamily, getFontSize, getParagraph, getPictureText, getSubscript, getText, getTextPosition, getUnderline, isBold, isItalic, isStrike, removeBreak, removeCarriageReturn, setBold, setColor, setFontFamily, setFontSize, setItalic, setStrike, setSubscript, setText, setText, setTextPosition, setUnderline, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XWPFHyperlinkRun

public XWPFHyperlinkRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHyperlink hyperlink,
                        org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR run,
                        XWPFParagraph p)
Method Detail

getCTHyperlink

public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHyperlink getCTHyperlink()

getAnchor

public java.lang.String getAnchor()

getHyperlinkId

public java.lang.String getHyperlinkId()
Returns the ID of the hyperlink, if one is set.

setHyperlinkId

public void setHyperlinkId(java.lang.String id)

getHyperlink

public XWPFHyperlink getHyperlink(XWPFDocument document)
If this Hyperlink is an external reference hyperlink, return the object for it.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFLatentStyles

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFLatentStyles

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFLatentStyles

public class XWPFLatentStyles
extends java.lang.Object

Field Summary
protected  XWPFStyles styles
Constructor Summary
protected | XWPFLatentStyles()
protected | XWPFLatentStyles(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTLatentStyles latentStyles)
protected | XWPFLatentStyles(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTLatentStyles latentStyles, XWPFStyles styles)
Method Summary
protected  boolean isLatentStyle(java.lang.String latentStyleID)
checks wheter specific LatentStyleID is a latentStyle
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

styles

protected XWPFStyles styles
Constructor Detail

XWPFLatentStyles

protected XWPFLatentStyles()

XWPFLatentStyles

protected XWPFLatentStyles(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTLatentStyles latentStyles)

XWPFLatentStyles

protected XWPFLatentStyles(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTLatentStyles latentStyles,
                           XWPFStyles styles)
Method Detail

isLatentStyle

protected boolean isLatentStyle(java.lang.String latentStyleID)
checks wheter specific LatentStyleID is a latentStyle

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFNum

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFNum

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFNum

public class XWPFNum
extends java.lang.Object

Author:
Philipp Epp

Field Summary
protected  XWPFNumbering numbering
Constructor Summary
XWPFNum()
XWPFNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum ctNum)
XWPFNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum ctNum, XWPFNumbering numbering)
XWPFNum(XWPFNumbering numbering)
Method Summary
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum | getCTNum()
XWPFNumbering | getNumbering()
void | setCTNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum ctNum)
void | setNumbering(XWPFNumbering numbering)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

numbering

protected XWPFNumbering numbering
Constructor Detail

XWPFNum

public XWPFNum()

XWPFNum

public XWPFNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum ctNum)

XWPFNum

public XWPFNum(XWPFNumbering numbering)

XWPFNum

public XWPFNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum ctNum,
               XWPFNumbering numbering)
Method Detail

getNumbering

public XWPFNumbering getNumbering()

getCTNum

public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum getCTNum()

setNumbering

public void setNumbering(XWPFNumbering numbering)

setCTNum

public void setCTNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum ctNum)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFNumbering

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFNumbering

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFNumbering

public class XWPFNumbering
extends POIXMLDocumentPart

Author:
Philipp Epp

Field Summary
protected java.util.List<XWPFAbstractNum> | abstractNums
protected java.util.List<XWPFNum> | nums
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XWPFNumbering()
create a new XWPFNumbering object for use in a new document
XWPFNumbering(PackagePart part, PackageRelationship rel)
create a new styles object with an existing document
Method Summary
java.math.BigInteger | addAbstractNum(XWPFAbstractNum abstractNum) add a new AbstractNum and return its AbstractNumID
java.math.BigInteger | addNum(java.math.BigInteger abstractNumID) Add a new num with an abstractNumID
void | addNum(java.math.BigInteger abstractNumID, java.math.BigInteger numID) Add a new num with an abstractNumID and a numID
java.math.BigInteger | addNum(XWPFNum num) add a new number to the numbering document
protected void | commit() save and commit numbering
XWPFAbstractNum | getAbstractNum(java.math.BigInteger abstractNumID) get AbstractNum by abstractNumID
java.math.BigInteger | getAbstractNumID(java.math.BigInteger numID) return the abstractNumID If the AbstractNumID not exists return null
java.math.BigInteger | getIdOfAbstractNum(XWPFAbstractNum abstractNum) Compare AbstractNum with abstractNums of this numbering document.
XWPFNum | getNum(java.math.BigInteger numID) get Num by NumID
boolean | numExist(java.math.BigInteger numID) Checks whether number with numID exists
protected void | onDocumentRead() read numbering form an existing package
boolean | removeAbstractNum(java.math.BigInteger abstractNumID) remove an existing abstractNum
void | setNumbering(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNumbering numbering) Sets the ctNumbering
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

abstractNums

protected java.util.List<XWPFAbstractNum> abstractNums

nums

protected java.util.List<XWPFNum> nums
Constructor Detail

XWPFNumbering

public XWPFNumbering(PackagePart part,
                     PackageRelationship rel)
              throws java.io.IOException,
                     OpenXML4JException
create a new styles object with an existing document

Throws:
java.io.IOException
OpenXML4JException

XWPFNumbering

public XWPFNumbering()
create a new XWPFNumbering object for use in a new document

Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
read numbering form an existing package

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
save and commit numbering

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

setNumbering

public void setNumbering(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNumbering numbering)
Sets the ctNumbering

Parameters:
numbering -

numExist

public boolean numExist(java.math.BigInteger numID)
Checks whether number with numID exists

Parameters:
numID -
Returns:
boolean true if num exist, false if num not exist

addNum

public java.math.BigInteger addNum(XWPFNum num)
add a new number to the numbering document

Parameters:
num -

addNum

public java.math.BigInteger addNum(java.math.BigInteger abstractNumID)
Add a new num with an abstractNumID

Returns:
return NumId of the added num

addNum

public void addNum(java.math.BigInteger abstractNumID,
                   java.math.BigInteger numID)
Add a new num with an abstractNumID and a numID

Parameters:
abstractNumID -
numID -

getNum

public XWPFNum getNum(java.math.BigInteger numID)
get Num by NumID

Parameters:
numID -
Returns:
abstractNum with NumId if no Num exists with that NumID null will be returned

getAbstractNum

public XWPFAbstractNum getAbstractNum(java.math.BigInteger abstractNumID)
get AbstractNum by abstractNumID

Parameters:
abstractNumID -
Returns:
abstractNum with abstractNumId if no abstractNum exists with that abstractNumID null will be returned

getIdOfAbstractNum

public java.math.BigInteger getIdOfAbstractNum(XWPFAbstractNum abstractNum)
Compare AbstractNum with abstractNums of this numbering document. If the content of abstractNum equals with an abstractNum of the List in numbering the BigInteger Value of it will be returned. If no equal abstractNum is existing null will be returned

Parameters:
abstractNum -
Returns:
BigInteger

addAbstractNum

public java.math.BigInteger addAbstractNum(XWPFAbstractNum abstractNum)
add a new AbstractNum and return its AbstractNumID

Parameters:
abstractNum -

removeAbstractNum

public boolean removeAbstractNum(java.math.BigInteger abstractNumID)
remove an existing abstractNum

Parameters:
abstractNumID -
Returns:
true if abstractNum with abstractNumID exists in NumberingArray, false if abstractNum with abstractNumID not exists

getAbstractNumID

public java.math.BigInteger getAbstractNumID(java.math.BigInteger numID)
return the abstractNumID If the AbstractNumID not exists return null

Parameters:
numID -
Returns:
abstractNumID
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFParagraph

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFParagraph

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFParagraph
All Implemented Interfaces:
IBodyElement
public class XWPFParagraph
extends java.lang.Object
implements IBodyElement

Sketch of XWPF paragraph class

Field Summary
protected XWPFDocument | document For access to the document's hyperlink, comments, tables etc
protected IBody | part
protected java.util.List<XWPFRun> | runs
Constructor Summary
XWPFParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP prgrph, IBody part)
Method Summary
protected void | addRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR run) add a new run at the end of the position of the content of parameter run
void | addRun(XWPFRun r) adds a new Run to the Paragraph
XWPFRun | createRun() Appends a new run to this paragraph
ParagraphAlignment | getAlignment() Returns the paragraph alignment which shall be applied to text in this paragraph.
IBody | getBody()
Borders | getBorderBetween() Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.
Borders | getBorderBottom() Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.
Borders | getBorderLeft() Specifies the border which shall be displayed on the left side of the page around the specified paragraph.
Borders | getBorderRight() Specifies the border which shall be displayed on the right side of the page around the specified paragraph.
Borders | getBorderTop() Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP | getCTP()
XWPFDocument | getDocument()
BodyElementType | getElementType() returns the type of the BodyElement Paragraph
java.lang.String | getFootnoteText() Returns the footnote text of the paragraph
int | getIndentationFirstLine() Specifies the additional indentation which shall be applied to the first line of the parent paragraph.
int | getIndentationHanging() Specifies the indentation which shall be removed from the first line of the parent paragraph, by moving the indentation on the first line back towards the beginning of the direction of text flow.
int | getIndentationLeft() Specifies the indentation which shall be placed between the left text margin for this paragraph and the left edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph If this attribute is omitted, its value shall be assumed to be zero.
int | getIndentationRight() Specifies the indentation which shall be placed between the right text margin for this paragraph and the right edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph If this attribute is omitted, its value shall be assumed to be zero.
java.math.BigInteger | getNumID() If style exist for this paragraph NumId of the paragraph will be returned.
java.lang.String | getParagraphText() Returns the text of the paragraph, but not of any objects in the paragraph
POIXMLDocumentPart | getPart() returns the part of the bodyElement
BodyType | getPartType() returns the partType of the bodyPart which owns the bodyElement
java.lang.String | getPictureText() Returns any text from any suitable pictures in the paragraph
XWPFRun | getRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR r) return the XWPFRun-Element which owns the CTR run-Element
java.util.List<XWPFRun> | getRuns()
int | getSpacingAfter() Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.
int | getSpacingAfterLines() Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.
int | getSpacingBefore() Specifies the spacing that should be added above the first line in this paragraph in the document in absolute units.
int | getSpacingBeforeLines() Specifies the spacing that should be added before the first line in this paragraph in the document in line units.
LineSpacingRule | getSpacingLineRule() Specifies how the spacing between lines is calculated as stored in the line attribute.
java.lang.String | getStyle()
java.lang.String | getStyleID() Return styleID of the paragraph if style exist for this paragraph if not, null will be returned
java.lang.String | getText() Return the textual content of the paragraph, including text from pictures in it.
java.lang.String | getText(TextSegement segment) get a Text
TextAlignment | getVerticalAlignment() Returns the text vertical alignment which shall be applied to text in this paragraph.
XWPFRun | insertNewRun(int pos) insert a new Run in RunArray
boolean | isEmpty()
boolean | isPageBreak() Specifies that when rendering this document in a paginated view, the contents of this paragraph are rendered on the start of a new page in the document.
boolean | isWordWrap() This element specifies whether a consumer shall break Latin text which exceeds the text extents of a line by breaking the word across two lines (breaking on the character level) or by moving the word to the following line (breaking on the word level).
boolean | removeRun(int pos) removes a Run at the position pos in the paragraph
TextSegement | searchText(java.lang.String searched, PositionInParagraph startPos) this methods parse the paragraph and search for the string searched.
void | setAlignment(ParagraphAlignment align) Specifies the paragraph alignment which shall be applied to text in this paragraph.
void | setBorderBetween(Borders border) Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.
void | setBorderBottom(Borders border) Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.
void | setBorderLeft(Borders border) Specifies the border which shall be displayed on the left side of the page around the specified paragraph.
void | setBorderRight(Borders border) Specifies the border which shall be displayed on the right side of the page around the specified paragraph.
void | setBorderTop(Borders border) Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.
void | setIndentationFirstLine(int indentation) Specifies the additional indentation which shall be applied to the first line of the parent paragraph.
void | setIndentationHanging(int indentation) Specifies the indentation which shall be removed from the first line of the parent paragraph, by moving the indentation on the first line back towards the beginning of the direction of text flow.
void | setIndentationLeft(int indentation) Specifies the indentation which shall be placed between the left text margin for this paragraph and the left edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph If this attribute is omitted, its value shall be assumed to be zero.
void | setIndentationRight(int indentation) Specifies the indentation which shall be placed between the right text margin for this paragraph and the right edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph If this attribute is omitted, its value shall be assumed to be zero.
void | setNumID(java.math.BigInteger numPos) setNumID of Paragraph
void | setPageBreak(boolean pageBreak) Specifies that when rendering this document in a paginated view, the contents of this paragraph are rendered on the start of a new page in the document.
void | setSpacingAfter(int spaces) Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.
void | setSpacingAfterLines(int spaces) Specifies the spacing that should be added after the last line in this paragraph in the document in line units.
void | setSpacingBefore(int spaces) Specifies the spacing that should be added above the first line in this paragraph in the document in absolute units.
void | setSpacingBeforeLines(int spaces) Specifies the spacing that should be added before the first line in this paragraph in the document in line units.
void | setSpacingLineRule(LineSpacingRule rule) Specifies how the spacing between lines is calculated as stored in the line attribute.
void | setStyle(java.lang.String newStyle) This method provides a style to the paragraph This is useful when, e.g.
void | setVerticalAlignment(TextAlignment valign) Specifies the text vertical alignment which shall be applied to text in this paragraph.
void | setWordWrap(boolean wrap) This element specifies whether a consumer shall break Latin text which exceeds the text extents of a line by breaking the word across two lines (breaking on the character level) or by moving the word to the following line (breaking on the word level).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

part

protected IBody part

document

protected XWPFDocument document
For access to the document's hyperlink, comments, tables etc

runs

protected java.util.List<XWPFRun> runs
Constructor Detail

XWPFParagraph

public XWPFParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP prgrph,
                     IBody part)
Method Detail

getCTP

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP getCTP()

getRuns

public java.util.List<XWPFRun> getRuns()

isEmpty

public boolean isEmpty()

getDocument

public XWPFDocument getDocument()

getText

public java.lang.String getText()
Return the textual content of the paragraph, including text from pictures in it.

getStyleID

public java.lang.String getStyleID()
Return styleID of the paragraph if style exist for this paragraph if not, null will be returned

Returns:
styleID as String

getNumID

public java.math.BigInteger getNumID()
If style exist for this paragraph NumId of the paragraph will be returned. If style not exist null will be returned

Returns:
NumID as BigInteger

setNumID

public void setNumID(java.math.BigInteger numPos)
setNumID of Paragraph

Parameters:
numPos -

getParagraphText

public java.lang.String getParagraphText()
Returns the text of the paragraph, but not of any objects in the paragraph

getPictureText

public java.lang.String getPictureText()
Returns any text from any suitable pictures in the paragraph

getFootnoteText

public java.lang.String getFootnoteText()
Returns the footnote text of the paragraph

Returns:
the footnote text or empty string if the paragraph does not have footnotes

createRun

public XWPFRun createRun()
Appends a new run to this paragraph

Returns:
a new text run

getAlignment

public ParagraphAlignment getAlignment()
Returns the paragraph alignment which shall be applied to text in this paragraph.

If this element is not set on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then no alignment is applied to the paragraph.

Returns:
the paragraph alignment of this paragraph.

setAlignment

public void setAlignment(ParagraphAlignment align)
Specifies the paragraph alignment which shall be applied to text in this paragraph.

If this element is not set on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then no alignment is applied to the paragraph.

Parameters:
align - the paragraph alignment to apply to this paragraph.

getVerticalAlignment

public TextAlignment getVerticalAlignment()
Returns the text vertical alignment which shall be applied to text in this paragraph.

If the line height (before any added spacing) is larger than one or more characters on the line, all characters will be aligned to each other as specified by this element.

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then the vertical alignment of all characters on the line shall be automatically determined by the consumer.

Returns:
the vertical alignment of this paragraph.

setVerticalAlignment

public void setVerticalAlignment(TextAlignment valign)
Specifies the text vertical alignment which shall be applied to text in this paragraph.

If the line height (before any added spacing) is larger than one or more characters on the line, all characters will be aligned to each other as specified by this element.

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then the vertical alignment of all characters on the line shall be automatically determined by the consumer.

Parameters:
valign - the paragraph vertical alignment to apply to this paragraph.

setBorderTop

public void setBorderTop(Borders border)
Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.

To determine if any two adjoining paragraphs shall have an individual top and bottom border or a between border, the set of borders on the two adjoining paragraphs are compared. If the border information on those two paragraphs is identical for all possible paragraphs borders, then the between border is displayed. Otherwise, the final paragraph shall use its bottom border and the following paragraph shall use its top border, respectively. If this border specifies a space attribute, that value determines the space above the text (ignoring any spacing above) which should be left before this border is drawn, specified in points.

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then no between border shall be applied above identical paragraphs.

This border can only be a line border.

Parameters:
border -
See Also:
for a list of all types of borders

getBorderTop

public Borders getBorderTop()
Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.

Returns:
paragraphBorder - the top border for the paragraph
See Also:
setBorderTop(Borders), a list of all types of borders

setBorderBottom

public void setBorderBottom(Borders border)
Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.

To determine if any two adjoining paragraphs shall have an individual top and bottom border or a between border, the set of borders on the two adjoining paragraphs are compared. If the border information on those two paragraphs is identical for all possible paragraphs borders, then the between border is displayed. Otherwise, the final paragraph shall use its bottom border and the following paragraph shall use its top border, respectively. If this border specifies a space attribute, that value determines the space after the bottom of the text (ignoring any space below) which should be left before this border is drawn, specified in points.

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then no between border shall be applied below identical paragraphs.

This border can only be a line border.

Parameters:
border -
See Also:
a list of all types of borders

getBorderBottom

public Borders getBorderBottom()
Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.

Returns:
paragraphBorder - the bottom border for the paragraph
See Also:
setBorderBottom(Borders), a list of all types of borders

setBorderLeft

public void setBorderLeft(Borders border)
Specifies the border which shall be displayed on the left side of the page around the specified paragraph.

To determine if any two adjoining paragraphs should have a left border which spans the full line height or not, the left border shall be drawn between the top border or between border at the top (whichever would be rendered for the current paragraph), and the bottom border or between border at the bottom (whichever would be rendered for the current paragraph).

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then no left border shall be applied.

This border can only be a line border.

Parameters:
border -
See Also:
for a list of all possible borders

getBorderLeft

public Borders getBorderLeft()
Specifies the border which shall be displayed on the left side of the page around the specified paragraph.

Returns:
ParagraphBorder - the left border for the paragraph
See Also:
setBorderLeft(Borders), for a list of all possible borders

setBorderRight

public void setBorderRight(Borders border)
Specifies the border which shall be displayed on the right side of the page around the specified paragraph.

To determine if any two adjoining paragraphs should have a right border which spans the full line height or not, the right border shall be drawn between the top border or between border at the top (whichever would be rendered for the current paragraph), and the bottom border or between border at the bottom (whichever would be rendered for the current paragraph).

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then no right border shall be applied.

This border can only be a line border.

Parameters:
border -
See Also:
for a list of all possible borders

getBorderRight

public Borders getBorderRight()
Specifies the border which shall be displayed on the right side of the page around the specified paragraph.

Returns:
ParagraphBorder - the right border for the paragraph
See Also:
setBorderRight(Borders), for a list of all possible borders

setBorderBetween

public void setBorderBetween(Borders border)
Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.

To determine if any two adjoining paragraphs should have a between border or an individual top and bottom border, the set of borders on the two adjoining paragraphs are compared. If the border information on those two paragraphs is identical for all possible paragraphs borders, then the between border is displayed. Otherwise, each paragraph shall use its bottom and top border, respectively. If this border specifies a space attribute, that value is ignored - this border is always located at the bottom of each paragraph with an identical following paragraph, taking into account any space after the line pitch.

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then no between border shall be applied between identical paragraphs.

This border can only be a line border.

Parameters:
border -
See Also:
for a list of all possible borders

getBorderBetween

public Borders getBorderBetween()
Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.

Returns:
ParagraphBorder - the between border for the paragraph
See Also:
setBorderBetween(Borders), for a list of all possible borders

setPageBreak

public void setPageBreak(boolean pageBreak)
Specifies that when rendering this document in a paginated view, the contents of this paragraph are rendered on the start of a new page in the document.

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then this property shall not be applied. Since the paragraph is specified to start on a new page, it begins page two even though it could have fit on page one.

Parameters:
pageBreak - - boolean value

isPageBreak

public boolean isPageBreak()
Specifies that when rendering this document in a paginated view, the contents of this paragraph are rendered on the start of a new page in the document.

If this element is omitted on a given paragraph, its value is determined by the setting previously set at any level of the style hierarchy (i.e. that previous setting remains unchanged). If this setting is never specified in the style hierarchy, then this property shall not be applied. Since the paragraph is specified to start on a new page, it begins page two even though it could have fit on page one.

Returns:
boolean - if page break is set

setSpacingAfter

public void setSpacingAfter(int spaces)
Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.

If the afterLines attribute or the afterAutoSpacing attribute is also specified, then this attribute value is ignored.

Parameters:
spaces - - a positive whole number, whose contents consist of a measurement in twentieths of a point.

getSpacingAfter

public int getSpacingAfter()
Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.

Returns:
int - value representing the spacing after the paragraph

setSpacingAfterLines

public void setSpacingAfterLines(int spaces)
Specifies the spacing that should be added after the last line in this paragraph in the document in line units. The value of this attribute is specified in one hundredths of a line.

If the afterAutoSpacing attribute is also specified, then this attribute value is ignored. If this setting is never specified in the style hierarchy, then its value shall be zero (if needed)

Parameters:
spaces - - a positive whole number, whose contents consist of a measurement in twentieths of a

getSpacingAfterLines

public int getSpacingAfterLines()
Specifies the spacing that should be added after the last line in this paragraph in the document in absolute units.

Returns:
bigInteger - value representing the spacing after the paragraph
See Also:
setSpacingAfterLines(int)

setSpacingBefore

public void setSpacingBefore(int spaces)
Specifies the spacing that should be added above the first line in this paragraph in the document in absolute units.

If the beforeLines attribute or the beforeAutoSpacing attribute is also specified, then this attribute value is ignored.

Parameters:
spaces -

getSpacingBefore

public int getSpacingBefore()
Specifies the spacing that should be added above the first line in this paragraph in the document in absolute units.

Returns:
the spacing that should be added above the first line
See Also:
setSpacingBefore(int)

setSpacingBeforeLines

public void setSpacingBeforeLines(int spaces)
Specifies the spacing that should be added before the first line in this paragraph in the document in line units. The value of this attribute is specified in one hundredths of a line.

If the beforeAutoSpacing attribute is also specified, then this attribute value is ignored. If this setting is never specified in the style hierarchy, then its value shall be zero.

Parameters:
spaces -

getSpacingBeforeLines

public int getSpacingBeforeLines()
Specifies the spacing that should be added before the first line in this paragraph in the document in line units. The value of this attribute is specified in one hundredths of a line.

Returns:
the spacing that should be added before the first line in this paragraph
See Also:
setSpacingBeforeLines(int)

setSpacingLineRule

public void setSpacingLineRule(LineSpacingRule rule)
Specifies how the spacing between lines is calculated as stored in the line attribute. If this attribute is omitted, then it shall be assumed to be of a value auto if a line attribute value is present.

Parameters:
rule -
See Also:
LineSpacingRule

getSpacingLineRule

public LineSpacingRule getSpacingLineRule()
Specifies how the spacing between lines is calculated as stored in the line attribute. If this attribute is omitted, then it shall be assumed to be of a value auto if a line attribute value is present.

Returns:
rule
See Also:
LineSpacingRule, setSpacingLineRule(LineSpacingRule)

setIndentationLeft

public void setIndentationLeft(int indentation)
Specifies the indentation which shall be placed between the left text margin for this paragraph and the left edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph

If this attribute is omitted, its value shall be assumed to be zero. Negative values are defined such that the text is moved past the text margin, positive values move the text inside the text margin.

Parameters:
indentation -

getIndentationLeft

public int getIndentationLeft()
Specifies the indentation which shall be placed between the left text margin for this paragraph and the left edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph

If this attribute is omitted, its value shall be assumed to be zero. Negative values are defined such that the text is moved past the text margin, positive values move the text inside the text margin.

Returns:
indentation or null if indentation is not set

setIndentationRight

public void setIndentationRight(int indentation)
Specifies the indentation which shall be placed between the right text margin for this paragraph and the right edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph

If this attribute is omitted, its value shall be assumed to be zero. Negative values are defined such that the text is moved past the text margin, positive values move the text inside the text margin.

Parameters:
indentation -

getIndentationRight

public int getIndentationRight()
Specifies the indentation which shall be placed between the right text margin for this paragraph and the right edge of that paragraph's content in a left to right paragraph, and the right text margin and the right edge of that paragraph's text in a right to left paragraph

If this attribute is omitted, its value shall be assumed to be zero. Negative values are defined such that the text is moved past the text margin, positive values move the text inside the text margin.

Returns:
indentation or null if indentation is not set

setIndentationHanging

public void setIndentationHanging(int indentation)
Specifies the indentation which shall be removed from the first line of the parent paragraph, by moving the indentation on the first line back towards the beginning of the direction of text flow. This indentation is specified relative to the paragraph indentation which is specified for all other lines in the parent paragraph.

The firstLine and hanging attributes are mutually exclusive, if both are specified, then the firstLine value is ignored.

Parameters:
indentation -

getIndentationHanging

public int getIndentationHanging()
Specifies the indentation which shall be removed from the first line of the parent paragraph, by moving the indentation on the first line back towards the beginning of the direction of text flow. This indentation is specified relative to the paragraph indentation which is specified for all other lines in the parent paragraph. The firstLine and hanging attributes are mutually exclusive, if both are specified, then the firstLine value is ignored.

Returns:
indentation or null if indentation is not set

setIndentationFirstLine

public void setIndentationFirstLine(int indentation)
Specifies the additional indentation which shall be applied to the first line of the parent paragraph. This additional indentation is specified relative to the paragraph indentation which is specified for all other lines in the parent paragraph. The firstLine and hanging attributes are mutually exclusive, if both are specified, then the firstLine value is ignored. If the firstLineChars attribute is also specified, then this value is ignored. If this attribute is omitted, then its value shall be assumed to be zero (if needed).

Parameters:
indentation -

getIndentationFirstLine

public int getIndentationFirstLine()
Specifies the additional indentation which shall be applied to the first line of the parent paragraph. This additional indentation is specified relative to the paragraph indentation which is specified for all other lines in the parent paragraph. The firstLine and hanging attributes are mutually exclusive, if both are specified, then the firstLine value is ignored. If the firstLineChars attribute is also specified, then this value is ignored. If this attribute is omitted, then its value shall be assumed to be zero (if needed).

Returns:
indentation or null if indentation is not set

setWordWrap

public void setWordWrap(boolean wrap)
This element specifies whether a consumer shall break Latin text which exceeds the text extents of a line by breaking the word across two lines (breaking on the character level) or by moving the word to the following line (breaking on the word level).

Parameters:
wrap - - boolean

isWordWrap

public boolean isWordWrap()
This element specifies whether a consumer shall break Latin text which exceeds the text extents of a line by breaking the word across two lines (breaking on the character level) or by moving the word to the following line (breaking on the word level).

Returns:
boolean

setStyle

public void setStyle(java.lang.String newStyle)
This method provides a style to the paragraph This is useful when, e.g. an Heading style has to be assigned

Parameters:
newStyle -

getStyle

public java.lang.String getStyle()
Returns:
the style of the paragraph

addRun

protected void addRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR run)
add a new run at the end of the position of the content of parameter run

Parameters:
run -

searchText

public TextSegement searchText(java.lang.String searched,
                               PositionInParagraph startPos)
this methods parse the paragraph and search for the string searched. If it finds the string, it will return true and the position of the String will be saved in the parameter startPos.

Parameters:
searched -
startPos -

insertNewRun

public XWPFRun insertNewRun(int pos)
insert a new Run in RunArray

Parameters:
pos -
Returns:
the inserted run

getText

public java.lang.String getText(TextSegement segment)
get a Text

Parameters:
segment -

removeRun

public boolean removeRun(int pos)
removes a Run at the position pos in the paragraph

Parameters:
pos -
Returns:
true if the run was removed

getElementType

public BodyElementType getElementType()
returns the type of the BodyElement Paragraph

Specified by:
getElementType in interface IBodyElement
See Also:
IBodyElement.getElementType()

getBody

public IBody getBody()
Specified by:
getBody in interface IBodyElement

getPart

public POIXMLDocumentPart getPart()
returns the part of the bodyElement

Specified by:
getPart in interface IBodyElement
See Also:
IBody.getPart()

getPartType

public BodyType getPartType()
returns the partType of the bodyPart which owns the bodyElement

Specified by:
getPartType in interface IBodyElement
See Also:
IBody.getPartType()

addRun

public void addRun(XWPFRun r)
adds a new Run to the Paragraph

Parameters:
r -

getRun

public XWPFRun getRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR r)
return the XWPFRun-Element which owns the CTR run-Element

Parameters:
r -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFPicture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFPicture

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFPicture

public class XWPFPicture
extends java.lang.Object

Author:
Philipp Epp

Constructor Summary
XWPFPicture(org.openxmlformats.schemas.drawingml.x2006.picture.CTPicture ctPic, XWPFRun run)
Method Summary
org.openxmlformats.schemas.drawingml.x2006.picture.CTPicture | getCTPicture() Return the underlying CTPicture bean that holds all properties for this picture
java.lang.String | getDescription()
XWPFPictureData | getPictureData() Get the PictureData of the Picture, if present.
void | setPictureReference(PackageRelationship rel) Link Picture with PictureData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWPFPicture

public XWPFPicture(org.openxmlformats.schemas.drawingml.x2006.picture.CTPicture ctPic,
                   XWPFRun run)
Method Detail

setPictureReference

public void setPictureReference(PackageRelationship rel)
Link Picture with PictureData

Parameters:
rel -

getCTPicture

public org.openxmlformats.schemas.drawingml.x2006.picture.CTPicture getCTPicture()
Return the underlying CTPicture bean that holds all properties for this picture

Returns:
the underlying CTPicture bean

getPictureData

public XWPFPictureData getPictureData()
Get the PictureData of the Picture, if present. Note - not all kinds of picture have data

getDescription

public java.lang.String getDescription()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFPictureData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFPictureData

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFPictureData

public class XWPFPictureData
extends POIXMLDocumentPart

Author:
Philipp Epp

Field Summary
protected static POIXMLRelation[] RELATIONS
Relationships for each known picture type
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
protected | XWPFPictureData() Create a new XWPFGraphicData node
 | XWPFPictureData(PackagePart part, PackageRelationship rel) Construct XWPFPictureData from a package part
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.Long | getChecksum()
byte[] | getData() Gets the picture data as a byte array.
java.lang.String | getFileName() Returns the file name of the image, eg image7.jpg .
int | getPictureType() Return an integer constant that specifies type of this picture
int | hashCode()
protected void | onDocumentRead() Fired when a package part is read
java.lang.String | suggestFileExtension() Suggests a file extension for this image.
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, commit, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

RELATIONS

protected static final POIXMLRelation[] RELATIONS
Relationships for each known picture type

Constructor Detail

XWPFPictureData

protected XWPFPictureData()
Create a new XWPFGraphicData node

XWPFPictureData

public XWPFPictureData(PackagePart part,
                       PackageRelationship rel)
Construct XWPFPictureData from a package part

Parameters:
part - the package part holding the drawing data,
rel - the package relationship holding this drawing, the relationship type must be http://schemas.openxmlformats.org/officeDocument/2006/relationships/image
Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Fired when a package part is read

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

getData

public byte[] getData()
Gets the picture data as a byte array.

Note, that this call might be expensive since all the picture data is copied into a temporary byte array. You can grab the picture data directly from the underlying package part as follows:
InputStream is = getPackagePart().getInputStream();

Returns:
the Picture data.

getFileName

public java.lang.String getFileName()
Returns the file name of the image, eg image7.jpg . The original filename isn't always available, but if it can be found it's likely to be in the CTDrawing

suggestFileExtension

public java.lang.String suggestFileExtension()
Suggests a file extension for this image.

Returns:
the file extension.

getPictureType

public int getPictureType()
Return an integer constant that specifies type of this picture

Returns:
an integer constant that specifies type of this picture
See Also:
Document.PICTURE_TYPE_EMF, Document.PICTURE_TYPE_WMF, Document.PICTURE_TYPE_PICT, Document.PICTURE_TYPE_JPEG, Document.PICTURE_TYPE_PNG, Document.PICTURE_TYPE_DIB

getChecksum

public java.lang.Long getChecksum()

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFRelation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFRelation

java.lang.Object
    extended by  org.apache.poi.POIXMLRelation
        extended by  org.apache.poi.xwpf.usermodel.XWPFRelation

public final class XWPFRelation
extends POIXMLRelation

Author:
Yegor Kozlov

Field Summary
protected static java.util.Map<java.lang.String,XWPFRelation> | _table A map to lookup POIXMLRelation by its relation type
static XWPFRelation | COMMENT
static XWPFRelation | DOCUMENT
static XWPFRelation | ENDNOTE
static XWPFRelation | FONT_TABLE
static XWPFRelation | FOOTER
static XWPFRelation | FOOTNOTE
static XWPFRelation | GLOSSARY_DOCUMENT
static XWPFRelation | HEADER
static XWPFRelation | HYPERLINK
static XWPFRelation | IMAGE_BMP
static XWPFRelation | IMAGE_DIB
static XWPFRelation | IMAGE_EMF Supported image formats
static XWPFRelation | IMAGE_EPS
static XWPFRelation | IMAGE_GIF
static XWPFRelation | IMAGE_JPEG
static XWPFRelation | IMAGE_PICT
static XWPFRelation | IMAGE_PNG
static XWPFRelation | IMAGE_TIFF
static XWPFRelation | IMAGE_WMF
static XWPFRelation | IMAGE_WPG
static XWPFRelation | IMAGES
static XWPFRelation | MACRO_DOCUMENT
static XWPFRelation | MACRO_TEMPLATE_DOCUMENT
static XWPFRelation | NUMBERING
static XWPFRelation | SETTINGS
static XWPFRelation | STYLES
static XWPFRelation | TEMPLATE
static XWPFRelation | WEB_SETTINGS
Fields inherited from class org.apache.poi.POIXMLRelation
_defaultName, _relation, _type
Method Summary
static XWPFRelation getInstance(java.lang.String rel)
Get POIXMLRelation by relation type
Methods inherited from class org.apache.poi.POIXMLRelation
getContentType, getDefaultFileName, getFileName, getRelation, getRelationClass
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_table

protected static java.util.Map<java.lang.String,XWPFRelation> _table
A map to lookup POIXMLRelation by its relation type

DOCUMENT

public static final XWPFRelation DOCUMENT

TEMPLATE

public static final XWPFRelation TEMPLATE

MACRO_DOCUMENT

public static final XWPFRelation MACRO_DOCUMENT

MACRO_TEMPLATE_DOCUMENT

public static final XWPFRelation MACRO_TEMPLATE_DOCUMENT

GLOSSARY_DOCUMENT

public static final XWPFRelation GLOSSARY_DOCUMENT

NUMBERING

public static final XWPFRelation NUMBERING

FONT_TABLE

public static final XWPFRelation FONT_TABLE

SETTINGS

public static final XWPFRelation SETTINGS

STYLES

public static final XWPFRelation STYLES

WEB_SETTINGS

public static final XWPFRelation WEB_SETTINGS

HEADER

public static final XWPFRelation HEADER

FOOTER

public static final XWPFRelation FOOTER

HYPERLINK

public static final XWPFRelation HYPERLINK

COMMENT

public static final XWPFRelation COMMENT

FOOTNOTE

public static final XWPFRelation FOOTNOTE

ENDNOTE

public static final XWPFRelation ENDNOTE

IMAGE_EMF

public static final XWPFRelation IMAGE_EMF
Supported image formats

IMAGE_WMF

public static final XWPFRelation IMAGE_WMF

IMAGE_PICT

public static final XWPFRelation IMAGE_PICT

IMAGE_JPEG

public static final XWPFRelation IMAGE_JPEG

IMAGE_PNG

public static final XWPFRelation IMAGE_PNG

IMAGE_DIB

public static final XWPFRelation IMAGE_DIB

IMAGE_GIF

public static final XWPFRelation IMAGE_GIF

IMAGE_TIFF

public static final XWPFRelation IMAGE_TIFF

IMAGE_EPS

public static final XWPFRelation IMAGE_EPS

IMAGE_BMP

public static final XWPFRelation IMAGE_BMP

IMAGE_WPG

public static final XWPFRelation IMAGE_WPG

IMAGES

public static final XWPFRelation IMAGES
Method Detail

getInstance

public static XWPFRelation getInstance(java.lang.String rel)
Get POIXMLRelation by relation type

Parameters:
rel - relation type, for example, http://schemas.openxmlformats.org/officeDocument/2006/relationships/image
Returns:
registered POIXMLRelation or null if not found
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFRun

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFRun

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFRun
Direct Known Subclasses:
XWPFHyperlinkRun
public class XWPFRun
extends java.lang.Object

XWPFRun object defines a region of text with a common set of properties

Author:
Yegor Kozlov, Gregg Morris (gregg dot morris at gmail dot com) - added getColor(), setColor()

Constructor Summary
XWPFRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR r, XWPFParagraph p)
Method Summary
void | addBreak() Specifies that a break shall be placed at the current location in the run content.
void | addBreak(BreakClear clear) Specifies that a break shall be placed at the current location in the run content.
void | addBreak(BreakType type) Specifies that a break shall be placed at the current location in the run content.
void | addCarriageReturn() Specifies that a carriage return shall be placed at the current location in the run content.
XWPFPicture | addPicture(java.io.InputStream pictureData, int pictureType, java.lang.String filename, int width, int height) Adds a picture to the run.
java.lang.String | getColor() Get text color.
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR | getCTR() Get the currently used CTR object
XWPFDocument | getDocument()
java.util.List<XWPFPicture> | getEmbeddedPictures() Returns the embedded pictures of the run.
java.lang.String | getFontFamily() Specifies the fonts which shall be used to display the text contents of this run.
int | getFontSize() Specifies the font size which shall be applied to all non complex script characters in the contents of this run when displayed.
XWPFParagraph | getParagraph() Get the currenty referenced paragraph object
java.lang.String | getPictureText() Returns text embedded in pictures
VerticalAlign | getSubscript() Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text.
java.lang.String | getText(int pos) Return the string content of this text run
int | getTextPosition() This element specifies the amount by which text shall be raised or lowered for this run in relation to the default baseline of the surrounding non-positioned text.
UnderlinePatterns | getUnderline() Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh
boolean | isBold() Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document
boolean | isItalic() Whether the italic property should be applied to all non-complex script characters in the contents of this run when displayed in a document.
boolean | isStrike() Specifies that the contents of this run shall be displayed with a single horizontal line through the center of the line.
void | removeBreak()
void | removeCarriageReturn()
void | setBold(boolean value) Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document.
void | setColor(java.lang.String rgbStr) Set text color.
void | setFontFamily(java.lang.String fontFamily) Specifies the fonts which shall be used to display the text contents of this run.
void | setFontSize(int size) Specifies the font size which shall be applied to all non complex script characters in the contents of this run when displayed.
void | setItalic(boolean value) Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document This formatting property is a toggle property, which specifies that its behavior differs between its use within a style definition and its use as direct formatting.
void | setStrike(boolean value) Specifies that the contents of this run shall be displayed with a single horizontal line through the center of the line.
void | setSubscript(VerticalAlign valign) Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text.
void | setText(java.lang.String value) Sets the text of this text run
void | setText(java.lang.String value, int pos) Sets the text of this text run in the
void | setTextPosition(int val) This element specifies the amount by which text shall be raised or lowered for this run in relation to the default baseline of the surrounding non-positioned text.
void | setUnderline(UnderlinePatterns value) Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy.
java.lang.String | toString() Returns the string version of the text, with tabs and carriage returns in place of their xml equivalents.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XWPFRun

public XWPFRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR r,
               XWPFParagraph p)
Parameters:
r - the CTR bean which holds the run attributes
p - the parent paragraph
Method Detail

getCTR

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR getCTR()
Get the currently used CTR object

Returns:
ctr object

getParagraph

public XWPFParagraph getParagraph()
Get the currenty referenced paragraph object

Returns:
current paragraph

getDocument

public XWPFDocument getDocument()
Returns:
The XWPFDocument instance, this run belongs to, or null if parent structure (paragraph > document) is not properly set.

isBold

public boolean isBold()
Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document

Returns:
true if the bold property is applied

setBold

public void setBold(boolean value)
Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document.

This formatting property is a toggle property, which specifies that its behavior differs between its use within a style definition and its use as direct formatting. When used as part of a style definition, setting this property shall toggle the current state of that property as specified up to this point in the hierarchy (i.e. applied to not applied, and vice versa). Setting it to false (or an equivalent) shall result in the current setting remaining unchanged. However, when used as direct formatting, setting this property to true or false shall set the absolute state of the resulting property.

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy. If this element is never applied in the style hierarchy, then bold shall not be applied to non-complex script characters.

Parameters:
value - true if the bold property is applied to this run

getColor

public java.lang.String getColor()
Get text color. The returned value is a string in the hex form "RRGGBB".

setColor

public void setColor(java.lang.String rgbStr)
Set text color.

Parameters:
rgbStr - - the desired color, in the hex form "RRGGBB".

getText

public java.lang.String getText(int pos)
Return the string content of this text run

Returns:
the text of this text run or null if not set

getPictureText

public java.lang.String getPictureText()
Returns text embedded in pictures

setText

public void setText(java.lang.String value)
Sets the text of this text run

Parameters:
value - the literal text which shall be displayed in the document

setText

public void setText(java.lang.String value,
                    int pos)
Sets the text of this text run in the

Parameters:
value - the literal text which shall be displayed in the document
pos - - position in the text array (NB: 0 based)

isItalic

public boolean isItalic()
Whether the italic property should be applied to all non-complex script characters in the contents of this run when displayed in a document.

Returns:
true if the italic property is applied

setItalic

public void setItalic(boolean value)
Whether the bold property shall be applied to all non-complex script characters in the contents of this run when displayed in a document

This formatting property is a toggle property, which specifies that its behavior differs between its use within a style definition and its use as direct formatting. When used as part of a style definition, setting this property shall toggle the current state of that property as specified up to this point in the hierarchy (i.e. applied to not applied, and vice versa). Setting it to false (or an equivalent) shall result in the current setting remaining unchanged. However, when used as direct formatting, setting this property to true or false shall set the absolute state of the resulting property.

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy. If this element is never applied in the style hierarchy, then bold shall not be applied to non-complex script characters.

Parameters:
value - true if the italic property is applied to this run

getUnderline

public UnderlinePatterns getUnderline()
Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh

Returns:
the Underline pattern applyed to this run
See Also:
UnderlinePatterns

setUnderline

public void setUnderline(UnderlinePatterns value)
Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy. If this element is never applied in the style hierarchy, then an underline shall not be applied to the contents of this run.

Parameters:
value - - underline type
See Also:
: all possible patterns that could be applied

isStrike

public boolean isStrike()
Specifies that the contents of this run shall be displayed with a single horizontal line through the center of the line.

Returns:
true if the strike property is applied

setStrike

public void setStrike(boolean value)
Specifies that the contents of this run shall be displayed with a single horizontal line through the center of the line.

This formatting property is a toggle property, which specifies that its behavior differs between its use within a style definition and its use as direct formatting. When used as part of a style definition, setting this property shall toggle the current state of that property as specified up to this point in the hierarchy (i.e. applied to not applied, and vice versa). Setting it to false (or an equivalent) shall result in the current setting remaining unchanged. However, when used as direct formatting, setting this property to true or false shall set the absolute state of the resulting property.

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy. If this element is never applied in the style hierarchy, then strikethrough shall not be applied to the contents of this run.

Parameters:
value - true if the strike property is applied to this run

getSubscript

public VerticalAlign getSubscript()
Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text. This allows the text to be repositioned as subscript or superscript without altering the font size of the run properties.

Returns:
VerticalAlign
See Also:
all possible value that could be applyed to this run

setSubscript

public void setSubscript(VerticalAlign valign)
Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text. This allows the text to be repositioned as subscript or superscript without altering the font size of the run properties.

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy. If this element is never applied in the style hierarchy, then the text shall not be subscript or superscript relative to the default baseline location for the contents of this run.

Parameters:
valign -
See Also:
VerticalAlign

getFontFamily

public java.lang.String getFontFamily()
Specifies the fonts which shall be used to display the text contents of this run. Specifies a font which shall be used to format all characters in the ASCII range (0 - 127) within the parent run

Returns:
a string representing the font family

setFontFamily

public void setFontFamily(java.lang.String fontFamily)
Specifies the fonts which shall be used to display the text contents of this run. Specifies a font which shall be used to format all characters in the ASCII range (0 - 127) within the parent run

Parameters:
fontFamily -

getFontSize

public int getFontSize()
Specifies the font size which shall be applied to all non complex script characters in the contents of this run when displayed.

Returns:
value representing the font size

setFontSize

public void setFontSize(int size)
Specifies the font size which shall be applied to all non complex script characters in the contents of this run when displayed.

If this element is not present, the default value is to leave the value applied at previous level in the style hierarchy. If this element is never applied in the style hierarchy, then any appropriate font size may be used for non complex script characters.

Parameters:
size -

getTextPosition

public int getTextPosition()
This element specifies the amount by which text shall be raised or lowered for this run in relation to the default baseline of the surrounding non-positioned text. This allows the text to be repositioned without altering the font size of the contents.

Returns:
a big integer representing the amount of text shall be "moved"

setTextPosition

public void setTextPosition(int val)
This element specifies the amount by which text shall be raised or lowered for this run in relation to the default baseline of the surrounding non-positioned text. This allows the text to be repositioned without altering the font size of the contents.

If the val attribute is positive, then the parent run shall be raised above the baseline of the surrounding text by the specified number of half-points. If the val attribute is negative, then the parent run shall be lowered below the baseline of the surrounding text by the specified number of half-points.

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy. If this element is never applied in the style hierarchy, then the text shall not be raised or lowered relative to the default baseline location for the contents of this run.

Parameters:
val -

removeBreak

public void removeBreak()

addBreak

public void addBreak()
Specifies that a break shall be placed at the current location in the run content. A break is a special character which is used to override the normal line breaking that would be performed based on the normal layout of the document's contents.

See Also:
addCarriageReturn()

addBreak

public void addBreak(BreakType type)
Specifies that a break shall be placed at the current location in the run content. A break is a special character which is used to override the normal line breaking that would be performed based on the normal layout of the document's contents.

The behavior of this break character (the location where text shall be restarted after this break) shall be determined by its type values.

See Also:
BreakType

addBreak

public void addBreak(BreakClear clear)
Specifies that a break shall be placed at the current location in the run content. A break is a special character which is used to override the normal line breaking that would be performed based on the normal layout of the document's contents.

The behavior of this break character (the location where text shall be restarted after this break) shall be determined by its type (in this case is BreakType.TEXT_WRAPPING as default) and clear attribute values.

See Also:
BreakClear

addCarriageReturn

public void addCarriageReturn()
Specifies that a carriage return shall be placed at the current location in the run content. A carriage return is used to end the current line of text in Wordprocess. The behavior of a carriage return in run content shall be identical to a break character with null type and clear attributes, which shall end the current line and find the next available line on which to continue. The carriage return character forced the following text to be restarted on the next available line in the document.

removeCarriageReturn

public void removeCarriageReturn()

addPicture

public XWPFPicture addPicture(java.io.InputStream pictureData,
                              int pictureType,
                              java.lang.String filename,
                              int width,
                              int height)
                       throws InvalidFormatException,
                              java.io.IOException
Adds a picture to the run. This method handles attaching the picture data to the overall file.

Parameters:
pictureData - The raw picture data
pictureType - The type of the picture, eg Document.PICTURE_TYPE_JPEG
image - width in EMUs. To convert to / from points use Units
image - height in EMUs. To convert to / from points use Units
Throws:
InvalidFormatException
java.io.IOException
See Also:
Document.PICTURE_TYPE_EMF, Document.PICTURE_TYPE_WMF, Document.PICTURE_TYPE_PICT, Document.PICTURE_TYPE_JPEG, Document.PICTURE_TYPE_PNG, Document.PICTURE_TYPE_DIB

getEmbeddedPictures

public java.util.List<XWPFPicture> getEmbeddedPictures()
Returns the embedded pictures of the run. These are pictures which reference an external, embedded picture image such as a .png or .jpg

toString

public java.lang.String toString()
Returns the string version of the text, with tabs and carriage returns in place of their xml equivalents.

Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFSettings

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFSettings

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFSettings

public class XWPFSettings
extends POIXMLDocumentPart

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XWPFSettings()
XWPFSettings(PackagePart part, PackageRelationship rel)
Method Summary
protected void | commit() Save the content in the underlying package part.
long | getZoomPercent() Set zoom. In the zoom tag inside settings.xml file it sets the value of zoom sample snippet from settings.xml
boolean | isEnforcedWith(org.openxmlformats.schemas.wordprocessingml.x2006.main.STDocProtect.Enum editValue) Verifies the documentProtection tag inside settings.xml file if the protection is enforced (w:enforcement="1") and if the kind of protection equals to passed (STDocProtect.Enum editValue) sample snippet from settings.xml
protected void | onDocumentRead() Fired when a package part is read
void | removeEnforcement() Removes protection enforcement. In the documentProtection tag inside settings.xml file it sets the value of enforcement to "0" (w:enforcement="0")
void | setEnforcementEditValue(org.openxmlformats.schemas.wordprocessingml.x2006.main.STDocProtect.Enum editValue) Enforces the protection with the option specified by passed editValue. In the documentProtection tag inside settings.xml file it sets the value of enforcement to "1" (w:enforcement="1") and the value of edit to the passed editValue (w:edit="[passed editValue]") sample snippet from settings.xml
void | setUpdateFields() Enforces fields update on document open (in Word).
void | setZoomPercent(long zoomPercent) Set zoom. In the zoom tag inside settings.xml file it sets the value of zoom sample snippet from settings.xml
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XWPFSettings

public XWPFSettings(PackagePart part,
                    PackageRelationship rel)
             throws java.io.IOException
Throws:
java.io.IOException

XWPFSettings

public XWPFSettings()
Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Fired when a package part is read

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

getZoomPercent

public long getZoomPercent()
Set zoom.
In the zoom tag inside settings.xml file
it sets the value of zoom
sample snippet from settings.xml
    <w:zoom w:percent="50" />

Returns:
percentage as an integer of zoom level

setZoomPercent

public void setZoomPercent(long zoomPercent)
Set zoom.
In the zoom tag inside settings.xml file
it sets the value of zoom
sample snippet from settings.xml
    <w:zoom w:percent="50" />

isEnforcedWith

public boolean isEnforcedWith(org.openxmlformats.schemas.wordprocessingml.x2006.main.STDocProtect.Enum editValue)
Verifies the documentProtection tag inside settings.xml file
if the protection is enforced (w:enforcement="1")
and if the kind of protection equals to passed (STDocProtect.Enum editValue)

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="readOnly" w:enforcement="1"/>

Returns:
true if documentProtection is enforced with option readOnly

setEnforcementEditValue

public void setEnforcementEditValue(org.openxmlformats.schemas.wordprocessingml.x2006.main.STDocProtect.Enum editValue)
Enforces the protection with the option specified by passed editValue.

In the documentProtection tag inside settings.xml file
it sets the value of enforcement to "1" (w:enforcement="1")
and the value of edit to the passed editValue (w:edit="[passed editValue]")

sample snippet from settings.xml
     <w:settings  ... >
         <w:documentProtection w:edit="[passed editValue]" w:enforcement="1"/>

removeEnforcement

public void removeEnforcement()
Removes protection enforcement.
In the documentProtection tag inside settings.xml file
it sets the value of enforcement to "0" (w:enforcement="0")

setUpdateFields

public void setUpdateFields()
Enforces fields update on document open (in Word). In the settings.xml file
sets the updateSettings value to true (w:updateSettings w:val="true") NOTICES:
  • Causing Word to ask on open: "This document contains fields that may refer to other files. Do you want to update the fields in this document?" (if "Update automatic links at open" is enabled)
  • Flag is removed after saving with changes in Word

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFStyle

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFStyle

public class XWPFStyle
extends java.lang.Object

Author:
Philipp Epp

Field Summary
protected  XWPFStyles styles
Constructor Summary
XWPFStyle(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle style)
constructor
XWPFStyle(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle style, XWPFStyles styles)
constructor
Method Summary
java.lang.String | getBasisStyleID()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle | getCTStyle() get ctStyle
java.lang.String | getLinkStyleID() get StyleID of the linked Style
java.lang.String | getName()
java.lang.String | getNextStyleID() get StyleID of the next style
java.lang.String | getStyleId() get StyleID of the style
XWPFStyles | getStyles() get styles
org.openxmlformats.schemas.wordprocessingml.x2006.main.STStyleType.Enum | getType() get Type of the Style
boolean | hasSameName(XWPFStyle compStyle) compares the names of the Styles
void | setStyle(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle style) set style
void | setStyleId(java.lang.String styleId) set styleID
void | setType(org.openxmlformats.schemas.wordprocessingml.x2006.main.STStyleType.Enum type) set styleType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

styles

protected XWPFStyles styles
Constructor Detail

XWPFStyle

public XWPFStyle(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle style)
constructor

Parameters:
style -

XWPFStyle

public XWPFStyle(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle style,
                 XWPFStyles styles)
constructor

Parameters:
style -
styles -
Method Detail

getStyleId

public java.lang.String getStyleId()
get StyleID of the style

Returns:
styleID StyleID of the style

getType

public org.openxmlformats.schemas.wordprocessingml.x2006.main.STStyleType.Enum getType()
get Type of the Style

Returns:
ctType

setStyle

public void setStyle(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle style)
set style

Parameters:
style -

getCTStyle

public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle getCTStyle()
get ctStyle

Returns:
ctStyle

setStyleId

public void setStyleId(java.lang.String styleId)
set styleID

Parameters:
styleId -

setType

public void setType(org.openxmlformats.schemas.wordprocessingml.x2006.main.STStyleType.Enum type)
set styleType

Parameters:
type -

getStyles

public XWPFStyles getStyles()
get styles

Returns:
styles the styles to which this style belongs

getBasisStyleID

public java.lang.String getBasisStyleID()

getLinkStyleID

public java.lang.String getLinkStyleID()
get StyleID of the linked Style

getNextStyleID

public java.lang.String getNextStyleID()
get StyleID of the next style

getName

public java.lang.String getName()

hasSameName

public boolean hasSameName(XWPFStyle compStyle)
compares the names of the Styles

Parameters:
compStyle -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFStyles

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFStyles

java.lang.Object
    extended by  org.apache.poi.POIXMLDocumentPart
        extended by  org.apache.poi.xwpf.usermodel.XWPFStyles

public class XWPFStyles
extends POIXMLDocumentPart

Author:
Philipp Epp

Field Summary
Fields inherited from class org.apache.poi.POIXMLDocumentPart
DEFAULT_XML_OPTIONS
Constructor Summary
XWPFStyles()
Construct XWPFStyles from scratch for a new document.
XWPFStyles(PackagePart part, PackageRelationship rel)
Construct XWPFStyles from a package part
Method Summary
void | addStyle(XWPFStyle style) add a style to the document
protected void | commit() Save the content in the underlying package part.
XWPFLatentStyles | getLatentStyles() get latentstyles
XWPFStyle | getStyle(java.lang.String styleID) get style by a styleID
XWPFStyle | getStyleWithSameName(XWPFStyle style) get the style with the same name if this style is not existing, return null
java.util.List<XWPFStyle> | getUsedStyleList(XWPFStyle style) get the styles which are related to the parameter style and their relatives this method can be used to copy all styles from one document to another document
protected void | onDocumentRead() Read document
void | setDefaultFonts(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFonts fonts) Sets the default font on ctStyles DocDefaults parameter
void | setEastAsia(java.lang.String strEastAsia) Sets the default East Asia spelling language on ctStyles DocDefaults parameter
void | setSpellingLanguage(java.lang.String strSpellingLanguage) Sets the default spelling language on ctStyles DocDefaults parameter
void | setStyles(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyles styles) Sets the ctStyles
boolean | styleExist(java.lang.String styleID) checks whether style with styleID exist
Methods inherited from class org.apache.poi.POIXMLDocumentPart
addRelation, createRelationship, createRelationship, createRelationship, getPackagePart, getPackageRelationship, getParent, getRelationById, getRelationId, getRelations, getTargetPart, onDocumentCreate, onDocumentRemove, onSave, read, rebase, removeRelation, removeRelation, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XWPFStyles

public XWPFStyles(PackagePart part,
                  PackageRelationship rel)
           throws java.io.IOException,
                  OpenXML4JException
Construct XWPFStyles from a package part

Parameters:
part - the package part holding the data of the styles,
rel - the package relationship of type "http://schemas.openxmlformats.org/officeDocument/2006/relationships/styles"
Throws:
java.io.IOException
OpenXML4JException

XWPFStyles

public XWPFStyles()
Construct XWPFStyles from scratch for a new document.

Method Detail

onDocumentRead

protected void onDocumentRead()
                       throws java.io.IOException
Read document

Overrides:
onDocumentRead in class POIXMLDocumentPart
Throws:
java.io.IOException

commit

protected void commit()
               throws java.io.IOException
Description copied from class: POIXMLDocumentPart
Save the content in the underlying package part. Default implementation is empty meaning that the package part is left unmodified. Sub-classes should override and add logic to marshal the "model" into Ooxml4J. For example, the code saving a generic XML entry may look as follows:

 protected void commit() throws IOException {
   PackagePart part = getPackagePart();
   OutputStream out = part.getOutputStream();
   XmlObject bean = getXmlBean(); //the "model" which holds changes in memory
   bean.save(out, DEFAULT_XML_OPTIONS);
   out.close();
 }

Overrides:
commit in class POIXMLDocumentPart
Throws:
java.io.IOException

setStyles

public void setStyles(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyles styles)
Sets the ctStyles

Parameters:
styles -

styleExist

public boolean styleExist(java.lang.String styleID)
checks whether style with styleID exist

Parameters:
styleID - styleID of the Style in the style-Document
Returns:
true if style exist, false if style not exist

addStyle

public void addStyle(XWPFStyle style)
add a style to the document

Parameters:
style -
Throws:
java.io.IOException

getStyle

public XWPFStyle getStyle(java.lang.String styleID)
get style by a styleID

Parameters:
styleID - styleID of the searched style
Returns:
style

getUsedStyleList

public java.util.List<XWPFStyle> getUsedStyleList(XWPFStyle style)
get the styles which are related to the parameter style and their relatives this method can be used to copy all styles from one document to another document

Parameters:
style -
Returns:
a list of all styles which were used by this method

setSpellingLanguage

public void setSpellingLanguage(java.lang.String strSpellingLanguage)
Sets the default spelling language on ctStyles DocDefaults parameter

Parameters:
strSpellingLanguage -

setEastAsia

public void setEastAsia(java.lang.String strEastAsia)
Sets the default East Asia spelling language on ctStyles DocDefaults parameter

Parameters:
strEastAsia -

setDefaultFonts

public void setDefaultFonts(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFonts fonts)
Sets the default font on ctStyles DocDefaults parameter

Parameters:
fonts -

getLatentStyles

public XWPFLatentStyles getLatentStyles()
get latentstyles

getStyleWithSameName

public XWPFStyle getStyleWithSameName(XWPFStyle style)
get the style with the same name if this style is not existing, return null

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFTable

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFTable
All Implemented Interfaces:
IBodyElement
public class XWPFTable
extends java.lang.Object
implements IBodyElement

Sketch of XWPFTable class. Only table's text is being hold.

Specifies the contents of a table present in the document. A table is a set of paragraphs (and other block-level content) arranged in rows and columns.

Author:
Yury Batrakov (batrakov at gmail.com), Gregg Morris (gregg dot morris at gmail dot com) - added
         setStyleID()
         getRowBandSize(), setRowBandSize()
         getColBandSize(), setColBandSize()
         getInsideHBorderType(), getInsideHBorderSize(), getInsideHBorderSpace(), getInsideHBorderColor()
         getInsideVBorderType(), getInsideVBorderSize(), getInsideVBorderSpace(), getInsideVBorderColor()
         setInsideHBorder(), setInsideVBorder()
         getCellMarginTop(), getCellMarginLeft(), getCellMarginBottom(), getCellMarginRight()
         setCellMargins()

Nested Class Summary
static class XWPFTable.XWPFBorderType
Field Summary
protected IBody | part
protected java.util.List<java.lang.String> | styleIDs
protected java.util.List<XWPFTableRow> | tableRows
protected java.lang.StringBuffer | text
Constructor Summary
XWPFTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table, IBody part)
XWPFTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table, IBody part, int row, int col)
Method Summary
void | addNewCol() add a new column for each row in this table
void | addNewRowBetween(int start, int end)
void | addRow(XWPFTableRow row) add a new Row to the table
boolean | addRow(XWPFTableRow row, int pos) add a new Row to the table at position pos
XWPFTableRow | createRow() create a new XWPFTableRow object with as many cells as the number of columns defined in that moment
IBody | getBody()
int | getCellMarginBottom()
int | getCellMarginLeft()
int | getCellMarginRight()
int | getCellMarginTop()
int | getColBandSize()
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl | getCTTbl()
BodyElementType | getElementType() returns the type of the BodyElement Table
java.lang.String | getInsideHBorderColor()
int | getInsideHBorderSize()
int | getInsideHBorderSpace()
XWPFTable.XWPFBorderType | getInsideHBorderType()
java.lang.String | getInsideVBorderColor()
int | getInsideVBorderSize()
int | getInsideVBorderSpace()
XWPFTable.XWPFBorderType | getInsideVBorderType()
int | getNumberOfRows()
POIXMLDocumentPart | getPart() returns the part of the bodyElement
BodyType | getPartType() returns the partType of the bodyPart which owns the bodyElement
XWPFTableRow | getRow(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow row) returns the XWPFRow which belongs to the CTRow row if this row is not existing in the table null will be returned
XWPFTableRow | getRow(int pos)
int | getRowBandSize()
java.util.List<XWPFTableRow> | getRows()
java.lang.String | getStyleID() get the StyleID of the table
java.lang.String | getText()
int | getWidth()
XWPFTableRow | insertNewTableRow(int pos) inserts a new tablerow
boolean | removeRow(int pos) Remove a row at position pos from the table
void | setCellMargins(int top, int left, int bottom, int right)
void | setColBandSize(int size)
void | setInsideHBorder(XWPFTable.XWPFBorderType type, int size, int space, java.lang.String rgbColor)
void | setInsideVBorder(XWPFTable.XWPFBorderType type, int size, int space, java.lang.String rgbColor)
void | setRowBandSize(int size)
void | setStyleID(java.lang.String styleName) Set the table style.
void | setWidth(int width)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

text

protected java.lang.StringBuffer text

tableRows

protected java.util.List<XWPFTableRow> tableRows

styleIDs

protected java.util.List<java.lang.String> styleIDs

part

protected IBody part
Constructor Detail

XWPFTable

public XWPFTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table,
                 IBody part,
                 int row,
                 int col)

XWPFTable

public XWPFTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table,
                 IBody part)
Method Detail

getCTTbl

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl getCTTbl()
Returns:
ctTbl object

getText

public java.lang.String getText()
Returns:
text

addNewRowBetween

public void addNewRowBetween(int start,
                             int end)

addNewCol

public void addNewCol()
add a new column for each row in this table

createRow

public XWPFTableRow createRow()
create a new XWPFTableRow object with as many cells as the number of columns defined in that moment

Returns:
tableRow

getRow

public XWPFTableRow getRow(int pos)
Parameters:
pos - - index of the row
Returns:
the row at the position specified or null if no rows is defined or if the position is greather than the max size of rows array

setWidth

public void setWidth(int width)
Parameters:
width -

getWidth

public int getWidth()
Returns:
width value

getNumberOfRows

public int getNumberOfRows()
Returns:
number of rows in table

getStyleID

public java.lang.String getStyleID()
get the StyleID of the table

Returns:
style-ID of the table

setStyleID

public void setStyleID(java.lang.String styleName)
Set the table style. If the style is not defined in the document, MS Word will set the table style to "Normal".

Parameters:
styleName - - the style name to apply to this table

getInsideHBorderType

public XWPFTable.XWPFBorderType getInsideHBorderType()

getInsideHBorderSize

public int getInsideHBorderSize()

getInsideHBorderSpace

public int getInsideHBorderSpace()

getInsideHBorderColor

public java.lang.String getInsideHBorderColor()

getInsideVBorderType

public XWPFTable.XWPFBorderType getInsideVBorderType()

getInsideVBorderSize

public int getInsideVBorderSize()

getInsideVBorderSpace

public int getInsideVBorderSpace()

getInsideVBorderColor

public java.lang.String getInsideVBorderColor()

getRowBandSize

public int getRowBandSize()

setRowBandSize

public void setRowBandSize(int size)

getColBandSize

public int getColBandSize()

setColBandSize

public void setColBandSize(int size)

setInsideHBorder

public void setInsideHBorder(XWPFTable.XWPFBorderType type,
                             int size,
                             int space,
                             java.lang.String rgbColor)

setInsideVBorder

public void setInsideVBorder(XWPFTable.XWPFBorderType type,
                             int size,
                             int space,
                             java.lang.String rgbColor)

getCellMarginTop

public int getCellMarginTop()

getCellMarginLeft

public int getCellMarginLeft()

getCellMarginBottom

public int getCellMarginBottom()

getCellMarginRight

public int getCellMarginRight()

setCellMargins

public void setCellMargins(int top,
                           int left,
                           int bottom,
                           int right)

addRow

public void addRow(XWPFTableRow row)
add a new Row to the table

Parameters:
row - the row which should be added

addRow

public boolean addRow(XWPFTableRow row,
                      int pos)
add a new Row to the table at position pos

Parameters:
row - the row which should be added

insertNewTableRow

public XWPFTableRow insertNewTableRow(int pos)
inserts a new tablerow

Parameters:
pos -
Returns:
the inserted row

removeRow

public boolean removeRow(int pos)
                  throws java.lang.IndexOutOfBoundsException
Remove a row at position pos from the table

Parameters:
pos - position the Row in the Table
Throws:
java.lang.IndexOutOfBoundsException

getRows

public java.util.List<XWPFTableRow> getRows()

getElementType

public BodyElementType getElementType()
returns the type of the BodyElement Table

Specified by:
getElementType in interface IBodyElement
See Also:
IBodyElement.getElementType()

getBody

public IBody getBody()
Specified by:
getBody in interface IBodyElement

getPart

public POIXMLDocumentPart getPart()
returns the part of the bodyElement

Specified by:
getPart in interface IBodyElement
See Also:
IBody.getPart()

getPartType

public BodyType getPartType()
returns the partType of the bodyPart which owns the bodyElement

Specified by:
getPartType in interface IBodyElement
See Also:
IBody.getPartType()

getRow

public XWPFTableRow getRow(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow row)
returns the XWPFRow which belongs to the CTRow row if this row is not existing in the table null will be returned

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFTable.XWPFBorderType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum XWPFTable.XWPFBorderType

java.lang.Object
    extended by  java.lang.Enum<XWPFTable.XWPFBorderType>
        extended by  org.apache.poi.xwpf.usermodel.XWPFTable.XWPFBorderType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<XWPFTable.XWPFBorderType>
Enclosing class:
XWPFTable
public static enum XWPFTable.XWPFBorderType
extends java.lang.Enum<XWPFTable.XWPFBorderType>

Enum Constant Summary
DASHED
DOT_DASH
DOTTED
DOUBLE
NIL
NONE
SINGLE
THICK
Method Summary
static XWPFTable.XWPFBorderType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XWPFTable.XWPFBorderType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

NIL

public static final XWPFTable.XWPFBorderType NIL

NONE

public static final XWPFTable.XWPFBorderType NONE

SINGLE

public static final XWPFTable.XWPFBorderType SINGLE

THICK

public static final XWPFTable.XWPFBorderType THICK

DOUBLE

public static final XWPFTable.XWPFBorderType DOUBLE

DOTTED

public static final XWPFTable.XWPFBorderType DOTTED

DASHED

public static final XWPFTable.XWPFBorderType DASHED

DOT_DASH

public static final XWPFTable.XWPFBorderType DOT_DASH
Method Detail

values

public static XWPFTable.XWPFBorderType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (XWPFTable.XWPFBorderType c : XWPFTable.XWPFBorderType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static XWPFTable.XWPFBorderType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


XWPFTableCell

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFTableCell

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFTableCell
All Implemented Interfaces:
IBody
public class XWPFTableCell
extends java.lang.Object
implements IBody

XWPFTableCell class.

Author:
Gregg Morris (gregg dot morris at gmail dot com) - added XWPFVertAlign enum, setColor(), setVerticalAlignment()

Nested Class Summary
static class XWPFTableCell.XWPFVertAlign
Field Summary
protected java.util.List<IBodyElement> | bodyElements
protected java.util.List<XWPFParagraph> | paragraphs
protected IBody | part
protected java.util.List<XWPFTable> | tables
Constructor Summary
XWPFTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell, XWPFTableRow tableRow, IBody part)
If a table cell does not include at least one block-level element, then this document shall be considered corrupt
Method Summary
XWPFParagraph | addParagraph() Add a Paragraph to this Table Cell
void | addParagraph(XWPFParagraph p) add a Paragraph to this TableCell
java.util.List<IBodyElement> | getBodyElements() returns an Iterator with paragraphs and tables
java.lang.String | getColor() Get cell color.
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc | getCTTc()
XWPFParagraph | getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this table the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | getParagraphArray(int pos) Returns the paragraph that of position pos
java.util.List<XWPFParagraph> | getParagraphs() returns a list of paragraphs
POIXMLDocumentPart | getPart() get the to which the TableCell belongs
BodyType | getPartType() get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,
XWPFTable | getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) get a table by its CTTbl-Object
XWPFTable | getTableArray(int pos) Returns the table at position pos
XWPFTableCell | getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
XWPFTableRow | getTableRow()
java.util.List<XWPFTable> | getTables() Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.
java.lang.String | getText()
XWPFTableCell.XWPFVertAlign | getVerticalAlignment() Get the vertical alignment of the cell.
XWPFDocument | getXWPFDocument() Return XWPFDocument
XWPFParagraph | insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) add a new paragraph at position of the cursor
XWPFTable | insertNewTbl(org.apache.xmlbeans.XmlCursor cursor) inserts a new Table at the cursor position.
void | insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
void | removeParagraph(int pos) removes a paragraph of this tablecell
void | setColor(java.lang.String rgbStr) Set cell color.
void | setParagraph(XWPFParagraph p)
void | setText(java.lang.String text)
void | setVerticalAlignment(XWPFTableCell.XWPFVertAlign vAlign) Set the vertical alignment of the cell.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

paragraphs

protected java.util.List<XWPFParagraph> paragraphs

tables

protected java.util.List<XWPFTable> tables

bodyElements

protected java.util.List<IBodyElement> bodyElements

part

protected IBody part
Constructor Detail

XWPFTableCell

public XWPFTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell,
                     XWPFTableRow tableRow,
                     IBody part)
If a table cell does not include at least one block-level element, then this document shall be considered corrupt

Method Detail

getCTTc

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc getCTTc()

getBodyElements

public java.util.List<IBodyElement> getBodyElements()
returns an Iterator with paragraphs and tables

Specified by:
getBodyElements in interface IBody
See Also:
IBody.getBodyElements()

setParagraph

public void setParagraph(XWPFParagraph p)

getParagraphs

public java.util.List<XWPFParagraph> getParagraphs()
returns a list of paragraphs

Specified by:
getParagraphs in interface IBody

addParagraph

public XWPFParagraph addParagraph()
Add a Paragraph to this Table Cell

Returns:
The paragraph which was added

addParagraph

public void addParagraph(XWPFParagraph p)
add a Paragraph to this TableCell

Parameters:
p - the paragaph which has to be added

removeParagraph

public void removeParagraph(int pos)
removes a paragraph of this tablecell

Parameters:
pos -

getParagraph

public XWPFParagraph getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p)
if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this table the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null

Specified by:
getParagraph in interface IBody
Parameters:
p - is instance of CTP and is searching for an XWPFParagraph
Returns:
null if there is no XWPFParagraph with an corresponding CTPparagraph in the paragraphList of this table XWPFParagraph with the correspondig CTP p

setText

public void setText(java.lang.String text)

getTableRow

public XWPFTableRow getTableRow()

setColor

public void setColor(java.lang.String rgbStr)
Set cell color. This sets some associated values; for finer control you may want to access these elements individually.

Parameters:
rgbStr - - the desired cell color, in the hex form "RRGGBB".

getColor

public java.lang.String getColor()
Get cell color. Note that this method only returns the "fill" value.

Returns:
RGB string of cell color

setVerticalAlignment

public void setVerticalAlignment(XWPFTableCell.XWPFVertAlign vAlign)
Set the vertical alignment of the cell.

Parameters:
vAlign - - the desired alignment enum value

getVerticalAlignment

public XWPFTableCell.XWPFVertAlign getVerticalAlignment()
Get the vertical alignment of the cell.

Returns:
the cell alignment enum value

insertNewParagraph

public XWPFParagraph insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor)
add a new paragraph at position of the cursor

Specified by:
insertNewParagraph in interface IBody
Parameters:
cursor -
Returns:
the inserted paragraph

insertNewTbl

public XWPFTable insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
Description copied from interface: IBody
inserts a new Table at the cursor position.

Specified by:
insertNewTbl in interface IBody

getParagraphArray

public XWPFParagraph getParagraphArray(int pos)
Description copied from interface: IBody
Returns the paragraph that of position pos

Specified by:
getParagraphArray in interface IBody
See Also:
IBody.getParagraphArray(int)

getPart

public POIXMLDocumentPart getPart()
get the to which the TableCell belongs

Specified by:
getPart in interface IBody
Returns:
the Part, to which the body belongs
See Also:
IBody.getPart()

getPartType

public BodyType getPartType()
Description copied from interface: IBody
get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,

Specified by:
getPartType in interface IBody
Returns:
the PartType of the body
See Also:
IBody.getPartType()

getTable

public XWPFTable getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable)
get a table by its CTTbl-Object

Specified by:
getTable in interface IBody
See Also:
IBody.getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl)

getTableArray

public XWPFTable getTableArray(int pos)
Description copied from interface: IBody
Returns the table at position pos

Specified by:
getTableArray in interface IBody
See Also:
IBody.getTableArray(int)

getTables

public java.util.List<XWPFTable> getTables()
Description copied from interface: IBody
Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.

Specified by:
getTables in interface IBody
See Also:
IBody.getTables()

insertTable

public void insertTable(int pos,
                        XWPFTable table)
inserts an existing XWPFTable to the arrays bodyElements and tables

Specified by:
insertTable in interface IBody
See Also:
IBody.insertTable(int, org.apache.poi.xwpf.usermodel.XWPFTable)

getText

public java.lang.String getText()

getTableCell

public XWPFTableCell getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell)
get the TableCell which belongs to the TableCell

Specified by:
getTableCell in interface IBody

getXWPFDocument

public XWPFDocument getXWPFDocument()
Description copied from interface: IBody
Return XWPFDocument

Specified by:
getXWPFDocument in interface IBody
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWPFTableCell.XWPFVertAlign

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

org.apache.poi.xwpf.usermodel
Enum XWPFTableCell.XWPFVertAlign

java.lang.Object
    extended by  java.lang.Enum<XWPFTableCell.XWPFVertAlign>
        extended by  org.apache.poi.xwpf.usermodel.XWPFTableCell.XWPFVertAlign
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<XWPFTableCell.XWPFVertAlign>
Enclosing class:
XWPFTableCell
public static enum XWPFTableCell.XWPFVertAlign
extends java.lang.Enum<XWPFTableCell.XWPFVertAlign>

Enum Constant Summary
BOTH
BOTTOM
CENTER
TOP
Method Summary
static XWPFTableCell.XWPFVertAlign | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XWPFTableCell.XWPFVertAlign[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TOP

public static final XWPFTableCell.XWPFVertAlign TOP

CENTER

public static final XWPFTableCell.XWPFVertAlign CENTER

BOTH

public static final XWPFTableCell.XWPFVertAlign BOTH

BOTTOM

public static final XWPFTableCell.XWPFVertAlign BOTTOM
Method Detail

values

public static XWPFTableCell.XWPFVertAlign[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (XWPFTableCell.XWPFVertAlign c : XWPFTableCell.XWPFVertAlign.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static XWPFTableCell.XWPFVertAlign valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


XWPFTableRow

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.poi.xwpf.usermodel
Class XWPFTableRow

java.lang.Object
    extended by  org.apache.poi.xwpf.usermodel.XWPFTableRow

public class XWPFTableRow
extends java.lang.Object

Author:
gisellabronzetti, gregg morris - added removeCell(), setCantSplitRow(), setRepeatHeader()

Constructor Summary
XWPFTableRow(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow row, XWPFTable table)
Method Summary
XWPFTableCell | addNewTableCell() adds a new TableCell at the end of this tableRow
XWPFTableCell | createCell() create a new XWPFTableCell and add it to the tableCell-list of this tableRow
XWPFTableCell | getCell(int pos)
org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow | getCtRow()
int | getHeight() This element specifies the height of the current table row within the current table.
XWPFTable | getTable()
XWPFTableCell | getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) returns the XWPFTableCell which belongs to the CTTC cell if there is no XWPFTableCell which belongs to the parameter CTTc cell null will be returned
java.util.List<XWPFTableCell> | getTableCells() create and return a list of all XWPFTableCell who belongs to this row
boolean | isCantSplitRow() Return true if the "can't split row" value is true.
boolean | isRepeatHeader() Return true if a table's header row should be repeated at the top of a table split across pages.
void | removeCell(int pos)
void | setCantSplitRow(boolean split) This attribute controls whether to allow table rows to split across pages.
void | setHeight(int height) This element specifies the height of the current table row within the current table.
void | setRepeatHeader(boolean repeat) This attribute controls whether to repeat a table's header row at the top of a table split across pages.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWPFTableRow

public XWPFTableRow(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow row,
                    XWPFTable table)
Method Detail

getCtRow

@Internal
public org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow getCtRow()

createCell

public XWPFTableCell createCell()
create a new XWPFTableCell and add it to the tableCell-list of this tableRow

Returns:
the newly created XWPFTableCell

getCell

public XWPFTableCell getCell(int pos)

removeCell

public void removeCell(int pos)

addNewTableCell

public XWPFTableCell addNewTableCell()
adds a new TableCell at the end of this tableRow

setHeight

public void setHeight(int height)
This element specifies the height of the current table row within the current table. This height shall be used to determine the resulting height of the table row, which may be absolute or relative (depending on its attribute values). If omitted, then the table row shall automatically resize its height to the height required by its contents (the equivalent of an hRule value of auto).

Parameters:
height -

getHeight

public int getHeight()
This element specifies the height of the current table row within the current table. This height shall be used to determine the resulting height of the table row, which may be absolute or relative (depending on its attribute values). If omitted, then the table row shall automatically resize its height to the height required by its contents (the equivalent of an hRule value of auto).

Returns:
height

getTable

public XWPFTable getTable()

getTableCells

public java.util.List<XWPFTableCell> getTableCells()
create and return a list of all XWPFTableCell who belongs to this row

Returns:
a list of XWPFTableCell

getTableCell

public XWPFTableCell getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell)
returns the XWPFTableCell which belongs to the CTTC cell if there is no XWPFTableCell which belongs to the parameter CTTc cell null will be returned

setCantSplitRow

public void setCantSplitRow(boolean split)
This attribute controls whether to allow table rows to split across pages. The logic for this attribute is a little unusual: a true value means DON'T allow rows to split, false means allow rows to split.

Parameters:
split - - if true, don't allow rows to be split. If false, allow rows to be split.

isCantSplitRow

public boolean isCantSplitRow()
Return true if the "can't split row" value is true. The logic for this attribute is a little unusual: a TRUE value means DON'T allow rows to split, FALSE means allow rows to split.

Returns:
true if rows can't be split, false otherwise.

setRepeatHeader

public void setRepeatHeader(boolean repeat)
This attribute controls whether to repeat a table's header row at the top of a table split across pages.

Parameters:
repeat - - if TRUE, repeat header row at the top of each page of table; if FALSE, don't repeat header row.

isRepeatHeader

public boolean isRepeatHeader()
Return true if a table's header row should be repeated at the top of a table split across pages.

Returns:
true if table's header row should be repeated at the top of each page of table, false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.apache.poi.xwpf.usermodel.BodyElementType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.BodyElementType

Packages that use BodyElementType
org.apache.poi.xwpf.usermodel

Uses of BodyElementType in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return BodyElementType
BodyElementType | XWPFTable.getElementType() returns the type of the BodyElement Table
BodyElementType | XWPFParagraph.getElementType() returns the type of the BodyElement Paragraph
BodyElementType | IBodyElement.getElementType()
static BodyElementType | BodyElementType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BodyElementType[] | BodyElementType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.BodyType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.BodyType

Packages that use BodyType
org.apache.poi.xwpf.usermodel

Uses of BodyType in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return BodyType
BodyType | XWPFTableCell.getPartType()
BodyType | XWPFTable.getPartType() returns the partType of the bodyPart which owns the bodyElement
BodyType | XWPFParagraph.getPartType() returns the partType of the bodyPart which owns the bodyElement
BodyType | XWPFHeader.getPartType() get the PartType of the body
BodyType | XWPFFootnote.getPartType() get the PartType of the body
BodyType | XWPFFooter.getPartType() get the PartType of the body
BodyType | XWPFDocument.getPartType() get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,
BodyType | IBodyElement.getPartType()
BodyType | IBody.getPartType() get the PartType of the body, for example DOCUMENT, HEADER, FOOTER, FOOTNOTE,
static BodyType | BodyType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BodyType[] | BodyType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.Borders

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.Borders

Packages that use Borders
org.apache.poi.xwpf.usermodel

Uses of Borders in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return Borders
Borders | XWPFParagraph.getBorderBetween() Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.
Borders | XWPFParagraph.getBorderBottom() Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.
Borders | XWPFParagraph.getBorderLeft() Specifies the border which shall be displayed on the left side of the page around the specified paragraph.
Borders | XWPFParagraph.getBorderRight() Specifies the border which shall be displayed on the right side of the page around the specified paragraph.
Borders | XWPFParagraph.getBorderTop() Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.
static Borders | Borders.valueOf(int type)
static Borders | Borders.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Borders[] | Borders.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type Borders
void | XWPFParagraph.setBorderBetween(Borders border) Specifies the border which shall be displayed between each paragraph in a set of paragraphs which have the same set of paragraph border settings.
void | XWPFParagraph.setBorderBottom(Borders border) Specifies the border which shall be displayed below a set of paragraphs which have the same set of paragraph border settings.
void | XWPFParagraph.setBorderLeft(Borders border) Specifies the border which shall be displayed on the left side of the page around the specified paragraph.
void | XWPFParagraph.setBorderRight(Borders border) Specifies the border which shall be displayed on the right side of the page around the specified paragraph.
void | XWPFParagraph.setBorderTop(Borders border) Specifies the border which shall be displayed above a set of paragraphs which have the same set of paragraph border settings.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.BreakClear

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.BreakClear

Packages that use BreakClear
org.apache.poi.xwpf.usermodel

Uses of BreakClear in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return BreakClear
static BreakClear | BreakClear.valueOf(int type)
static BreakClear | BreakClear.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BreakClear[] | BreakClear.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type BreakClear
 void XWPFRun.addBreak(BreakClear clear)
Specifies that a break shall be placed at the current location in the run content.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.BreakType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.BreakType

Packages that use BreakType
org.apache.poi.xwpf.usermodel

Uses of BreakType in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return BreakType
static BreakType | BreakType.valueOf(int type)
static BreakType | BreakType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BreakType[] | BreakType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type BreakType
 void XWPFRun.addBreak(BreakType type)
Specifies that a break shall be placed at the current location in the run content.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xwpf.usermodel.Document

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xwpf.usermodel.Document

Packages that use Document
org.apache.poi.xwpf.usermodel

Uses of Document in org.apache.poi.xwpf.usermodel

Classes in org.apache.poi.xwpf.usermodel that implement Document
 class XWPFDocument
Experimental class to do low level processing of docx files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xwpf.usermodel.IBody

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xwpf.usermodel.IBody

Packages that use IBody
org.apache.poi.xwpf.usermodel

Uses of IBody in org.apache.poi.xwpf.usermodel

Classes in org.apache.poi.xwpf.usermodel that implement IBody
class | XWPFDocument Experimental class to do low level processing of docx files.
class | XWPFFooter Sketch of XWPF footer class
class | XWPFFootnote
class | XWPFHeader Sketch of XWPF header class
class | XWPFHeaderFooter Parent of XWPF headers and footers
class | XWPFTableCell XWPFTableCell class.

Fields in org.apache.poi.xwpf.usermodel declared as IBody
protected IBody | XWPFTableCell.part
protected IBody | XWPFTable.part
protected IBody | XWPFParagraph.part

Methods in org.apache.poi.xwpf.usermodel that return IBody
IBody | XWPFTable.getBody()
IBody | XWPFParagraph.getBody()
IBody | IBodyElement.getBody()

Constructors in org.apache.poi.xwpf.usermodel with parameters of type IBody
XWPFParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP prgrph, IBody part)
XWPFTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table, IBody part)
XWPFTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table, IBody part, int row, int col)
XWPFTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell, XWPFTableRow tableRow, IBody part)
If a table cell does not include at least one block-level element, then this document shall be considered corrupt

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.poi.xwpf.usermodel.IBodyElement

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.apache.poi.xwpf.usermodel.IBodyElement

Packages that use IBodyElement
org.apache.poi.xwpf.usermodel

Uses of IBodyElement in org.apache.poi.xwpf.usermodel

Classes in org.apache.poi.xwpf.usermodel that implement IBodyElement
class | XWPFParagraph Sketch of XWPF paragraph class
class | XWPFTable Sketch of XWPFTable class.

Fields in org.apache.poi.xwpf.usermodel with type parameters of type IBodyElement
protected java.util.List<IBodyElement> | XWPFTableCell.bodyElements
protected java.util.List<IBodyElement> | XWPFDocument.bodyElements

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type IBodyElement
java.util.List<IBodyElement> | XWPFTableCell.getBodyElements() returns an Iterator with paragraphs and tables
java.util.List<IBodyElement> | XWPFHeaderFooter.getBodyElements()
java.util.List<IBodyElement> | XWPFFootnote.getBodyElements()
java.util.List<IBodyElement> | XWPFDocument.getBodyElements() returns an Iterator with paragraphs and tables
java.util.List<IBodyElement> | IBody.getBodyElements() Returns an Iterator with paragraphs and tables, in the order that they occur in the text.
java.util.Iterator<IBodyElement> | XWPFDocument.getBodyElementsIterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.LineSpacingRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.LineSpacingRule

Packages that use LineSpacingRule
org.apache.poi.xwpf.usermodel

Uses of LineSpacingRule in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return LineSpacingRule
LineSpacingRule | XWPFParagraph.getSpacingLineRule() Specifies how the spacing between lines is calculated as stored in the line attribute.
static LineSpacingRule | LineSpacingRule.valueOf(int type)
static LineSpacingRule | LineSpacingRule.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LineSpacingRule[] | LineSpacingRule.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type LineSpacingRule
 void XWPFParagraph.setSpacingLineRule(LineSpacingRule rule)
Specifies how the spacing between lines is calculated as stored in the line attribute.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.ParagraphAlignment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.ParagraphAlignment

Packages that use ParagraphAlignment
org.apache.poi.xwpf.usermodel

Uses of ParagraphAlignment in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return ParagraphAlignment
ParagraphAlignment | XWPFParagraph.getAlignment() Returns the paragraph alignment which shall be applied to text in this paragraph.
static ParagraphAlignment | ParagraphAlignment.valueOf(int type)
static ParagraphAlignment | ParagraphAlignment.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ParagraphAlignment[] | ParagraphAlignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type ParagraphAlignment
 void XWPFParagraph.setAlignment(ParagraphAlignment align)
Specifies the paragraph alignment which shall be applied to text in this paragraph.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.PositionInParagraph

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.PositionInParagraph

Packages that use PositionInParagraph
org.apache.poi.xwpf.usermodel

Uses of PositionInParagraph in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return PositionInParagraph
PositionInParagraph | TextSegement.getBeginPos()
PositionInParagraph | TextSegement.getEndPos()

Methods in org.apache.poi.xwpf.usermodel with parameters of type PositionInParagraph
 TextSegement XWPFParagraph.searchText(java.lang.String searched, PositionInParagraph startPos)
this methods parse the paragraph and search for the string searched.

Constructors in org.apache.poi.xwpf.usermodel with parameters of type PositionInParagraph
TextSegement(PositionInParagraph beginPos, PositionInParagraph endPos)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.TextAlignment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.TextAlignment

Packages that use TextAlignment
org.apache.poi.xwpf.usermodel

Uses of TextAlignment in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return TextAlignment
TextAlignment | XWPFParagraph.getVerticalAlignment() Returns the text vertical alignment which shall be applied to text in this paragraph.
static TextAlignment | TextAlignment.valueOf(int type)
static TextAlignment | TextAlignment.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static TextAlignment[] | TextAlignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type TextAlignment
 void XWPFParagraph.setVerticalAlignment(TextAlignment valign)
Specifies the text vertical alignment which shall be applied to text in this paragraph.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.TextSegement

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.TextSegement

Packages that use TextSegement
org.apache.poi.xwpf.usermodel

Uses of TextSegement in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return TextSegement
 TextSegement XWPFParagraph.searchText(java.lang.String searched, PositionInParagraph startPos)
this methods parse the paragraph and search for the string searched.

Methods in org.apache.poi.xwpf.usermodel with parameters of type TextSegement
 java.lang.String XWPFParagraph.getText(TextSegement segment)
get a Text

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.TOC

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.TOC

No usage of org.apache.poi.xwpf.usermodel.TOC

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.UnderlinePatterns

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.UnderlinePatterns

Packages that use UnderlinePatterns
org.apache.poi.xwpf.usermodel

Uses of UnderlinePatterns in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return UnderlinePatterns
UnderlinePatterns | XWPFRun.getUnderline() Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh
static UnderlinePatterns | UnderlinePatterns.valueOf(int type)
static UnderlinePatterns | UnderlinePatterns.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static UnderlinePatterns[] | UnderlinePatterns.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type UnderlinePatterns
 void XWPFRun.setUnderline(UnderlinePatterns value)
Specifies that the contents of this run should be displayed along with an underline appearing directly below the character heigh

If this element is not present, the default value is to leave the formatting applied at previous level in the style hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.VerticalAlign

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.VerticalAlign

Packages that use VerticalAlign
org.apache.poi.xwpf.usermodel

Uses of VerticalAlign in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return VerticalAlign
VerticalAlign | XWPFRun.getSubscript() Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text.
static VerticalAlign | VerticalAlign.valueOf(int type)
static VerticalAlign | VerticalAlign.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static VerticalAlign[] | VerticalAlign.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type VerticalAlign
 void XWPFRun.setSubscript(VerticalAlign valign)
Specifies the alignment which shall be applied to the contents of this run in relation to the default appearance of the run's text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFAbstractNum

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFAbstractNum

Packages that use XWPFAbstractNum
org.apache.poi.xwpf.usermodel

Uses of XWPFAbstractNum in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFAbstractNum
protected  java.util.List<XWPFAbstractNum> XWPFNumbering.abstractNums

Methods in org.apache.poi.xwpf.usermodel that return XWPFAbstractNum
 XWPFAbstractNum XWPFNumbering.getAbstractNum(java.math.BigInteger abstractNumID)
get AbstractNum by abstractNumID

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFAbstractNum
java.math.BigInteger | XWPFNumbering.addAbstractNum(XWPFAbstractNum abstractNum) add a new AbstractNum and return its AbstractNumID
java.math.BigInteger | XWPFNumbering.getIdOfAbstractNum(XWPFAbstractNum abstractNum) Compare AbstractNum with abstractNums of this numbering document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFComment

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFComment

Packages that use XWPFComment
org.apache.poi.xwpf.usermodel

Uses of XWPFComment in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFComment
protected  java.util.List<XWPFComment> XWPFDocument.comments

Methods in org.apache.poi.xwpf.usermodel that return XWPFComment
XWPFComment | XWPFDocument.getCommentByID(java.lang.String id)
XWPFComment[] | XWPFDocument.getComments()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFDocument

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFDocument

Packages that use XWPFDocument
org.apache.poi.xwpf.extractor
org.apache.poi.xwpf.model
org.apache.poi.xwpf.usermodel

Uses of XWPFDocument in org.apache.poi.xwpf.extractor

Constructors in org.apache.poi.xwpf.extractor with parameters of type XWPFDocument
XWPFWordExtractor(XWPFDocument document)

Uses of XWPFDocument in org.apache.poi.xwpf.model

Constructors in org.apache.poi.xwpf.model with parameters of type XWPFDocument
XWPFHeaderFooterPolicy(XWPFDocument doc)
Figures out the policy for the given document, and creates any header and footer objects as required.
XWPFHeaderFooterPolicy(XWPFDocument doc, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTSectPr sectPr)
Figures out the policy for the given document, and creates any header and footer objects as required.

Uses of XWPFDocument in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel declared as XWPFDocument
protected XWPFDocument | XWPFParagraph.document For access to the document's hyperlink, comments, tables etc
protected XWPFDocument | XWPFFootnotes.document

Methods in org.apache.poi.xwpf.usermodel that return XWPFDocument
XWPFDocument | XWPFRun.getDocument()
XWPFDocument | XWPFParagraph.getDocument()
XWPFDocument | XWPFTableCell.getXWPFDocument()
XWPFDocument | XWPFHeaderFooter.getXWPFDocument()
XWPFDocument | XWPFFootnotes.getXWPFDocument()
XWPFDocument | XWPFFootnote.getXWPFDocument()
XWPFDocument | XWPFDocument.getXWPFDocument()
XWPFDocument | IBody.getXWPFDocument() Return XWPFDocument

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFDocument
XWPFHyperlink | XWPFHyperlinkRun.getHyperlink(XWPFDocument document) If this Hyperlink is an external reference hyperlink, return the object for it.
void | XWPFHeaderFooter.setXWPFDocument(XWPFDocument doc)
void | XWPFFootnotes.setXWPFDocument(XWPFDocument doc)

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFDocument
XWPFComment(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTComment comment, XWPFDocument document)
XWPFFooter(XWPFDocument doc, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr hdrFtr)
XWPFFootnote(XWPFDocument document, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn body)
XWPFHeader(XWPFDocument doc, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHdrFtr hdrFtr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFFactory

Packages that use XWPFFactory
org.apache.poi.xwpf.usermodel

Uses of XWPFFactory in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFFactory
static XWPFFactory XWPFFactory.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFFooter

Packages that use XWPFFooter
org.apache.poi.xwpf.model
org.apache.poi.xwpf.usermodel

Uses of XWPFFooter in org.apache.poi.xwpf.model

Methods in org.apache.poi.xwpf.model that return XWPFFooter
XWPFFooter | XWPFHeaderFooterPolicy.createFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type)
XWPFFooter | XWPFHeaderFooterPolicy.createFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type, XWPFParagraph[] pars)
XWPFFooter | XWPFHeaderFooterPolicy.getDefaultFooter()
XWPFFooter | XWPFHeaderFooterPolicy.getEvenPageFooter()
XWPFFooter | XWPFHeaderFooterPolicy.getFirstPageFooter()
XWPFFooter | XWPFHeaderFooterPolicy.getFooter(int pageNumber) Get the footer that applies to the given (1 based) page.
XWPFFooter | XWPFHeaderFooterPolicy.getOddPageFooter() Returns the odd page footer.

Uses of XWPFFooter in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFFooter
protected  java.util.List<XWPFFooter> XWPFDocument.footers

Methods in org.apache.poi.xwpf.usermodel that return XWPFFooter
 XWPFFooter XWPFDocument.getFooterArray(int pos)

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFFooter
 java.util.List<XWPFFooter> XWPFDocument.getFooterList()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFFootnote

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFFootnote

Packages that use XWPFFootnote
org.apache.poi.xwpf.usermodel

Uses of XWPFFootnote in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFFootnote
protected  java.util.Map<java.lang.Integer,XWPFFootnote> XWPFDocument.endnotes

Methods in org.apache.poi.xwpf.usermodel that return XWPFFootnote
XWPFFootnote | XWPFDocument.addEndnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note)
XWPFFootnote | XWPFFootnotes.addFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note) add a footnote to the document
XWPFFootnote | XWPFDocument.addFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note)
XWPFFootnote | XWPFDocument.getEndnoteByID(int id)
XWPFFootnote | XWPFFootnotes.getFootnoteById(int id)
XWPFFootnote | XWPFDocument.getFootnoteByID(int id)

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFFootnote
java.util.List<XWPFFootnote> | XWPFDocument.getFootnotes()
java.util.List<XWPFFootnote> | XWPFFootnotes.getFootnotesList()

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFFootnote
 void XWPFFootnotes.addFootnote(XWPFFootnote footnote)
add an XWPFFootnote to the document

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFFootnotes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFFootnotes

Packages that use XWPFFootnotes
org.apache.poi.xwpf.usermodel

Uses of XWPFFootnotes in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel declared as XWPFFootnotes
protected  XWPFFootnotes XWPFDocument.footnotes

Methods in org.apache.poi.xwpf.usermodel that return XWPFFootnotes
 XWPFFootnotes XWPFDocument.createFootnotes()
Creates an empty footnotes element for the document if one does not already exist

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFFootnotes
XWPFFootnote(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFtnEdn note, XWPFFootnotes xFootnotes)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFHeader

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFHeader

Packages that use XWPFHeader
org.apache.poi.xwpf.model
org.apache.poi.xwpf.usermodel

Uses of XWPFHeader in org.apache.poi.xwpf.model

Methods in org.apache.poi.xwpf.model that return XWPFHeader
XWPFHeader | XWPFHeaderFooterPolicy.createHeader(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type)
XWPFHeader | XWPFHeaderFooterPolicy.createHeader(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type, XWPFParagraph[] pars)
XWPFHeader | XWPFHeaderFooterPolicy.getDefaultHeader()
XWPFHeader | XWPFHeaderFooterPolicy.getEvenPageHeader()
XWPFHeader | XWPFHeaderFooterPolicy.getFirstPageHeader()
XWPFHeader | XWPFHeaderFooterPolicy.getHeader(int pageNumber) Get the header that applies to the given (1 based) page.
XWPFHeader | XWPFHeaderFooterPolicy.getOddPageHeader() Returns the odd page header.

Uses of XWPFHeader in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFHeader
protected  java.util.List<XWPFHeader> XWPFDocument.headers

Methods in org.apache.poi.xwpf.usermodel that return XWPFHeader
 XWPFHeader XWPFDocument.getHeaderArray(int pos)

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFHeader
 java.util.List<XWPFHeader> XWPFDocument.getHeaderList()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFHeaderFooter

Packages that use XWPFHeaderFooter
org.apache.poi.xwpf.usermodel

Uses of XWPFHeaderFooter in org.apache.poi.xwpf.usermodel

Subclasses of XWPFHeaderFooter in org.apache.poi.xwpf.usermodel
class | XWPFFooter Sketch of XWPF footer class
class | XWPFHeader Sketch of XWPF header class

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFHyperlink

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFHyperlink

Packages that use XWPFHyperlink
org.apache.poi.xwpf.usermodel

Uses of XWPFHyperlink in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFHyperlink
protected  java.util.List<XWPFHyperlink> XWPFDocument.hyperlinks

Methods in org.apache.poi.xwpf.usermodel that return XWPFHyperlink
XWPFHyperlink | XWPFHyperlinkRun.getHyperlink(XWPFDocument document) If this Hyperlink is an external reference hyperlink, return the object for it.
XWPFHyperlink | XWPFDocument.getHyperlinkByID(java.lang.String id)
XWPFHyperlink[] | XWPFDocument.getHyperlinks()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

No usage of org.apache.poi.xwpf.usermodel.XWPFHyperlinkRun

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFLatentStyles

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFLatentStyles

Packages that use XWPFLatentStyles
org.apache.poi.xwpf.usermodel

Uses of XWPFLatentStyles in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFLatentStyles
 XWPFLatentStyles XWPFStyles.getLatentStyles()
get latentstyles

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFNum

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFNum

Packages that use XWPFNum
org.apache.poi.xwpf.usermodel

Uses of XWPFNum in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFNum
protected  java.util.List<XWPFNum> XWPFNumbering.nums

Methods in org.apache.poi.xwpf.usermodel that return XWPFNum
 XWPFNum XWPFNumbering.getNum(java.math.BigInteger numID)
get Num by NumID

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFNum
 java.math.BigInteger XWPFNumbering.addNum(XWPFNum num)
add a new number to the numbering document

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFNumbering

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFNumbering

Packages that use XWPFNumbering
org.apache.poi.xwpf.usermodel

Uses of XWPFNumbering in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel declared as XWPFNumbering
protected XWPFNumbering | XWPFNum.numbering
protected XWPFNumbering | XWPFDocument.numbering
protected XWPFNumbering | XWPFAbstractNum.numbering

Methods in org.apache.poi.xwpf.usermodel that return XWPFNumbering
XWPFNumbering | XWPFDocument.createNumbering() Creates an empty numbering if one does not already exist and sets the numbering member
XWPFNumbering | XWPFNum.getNumbering()
XWPFNumbering | XWPFDocument.getNumbering() getNumbering
XWPFNumbering | XWPFAbstractNum.getNumbering()

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFNumbering
void | XWPFNum.setNumbering(XWPFNumbering numbering)
void | XWPFAbstractNum.setNumbering(XWPFNumbering numbering)

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFNumbering
XWPFAbstractNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTAbstractNum ctAbstractNum, XWPFNumbering numbering)
XWPFNum(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTNum ctNum, XWPFNumbering numbering)
XWPFNum(XWPFNumbering numbering)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFParagraph

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFParagraph

Packages that use XWPFParagraph
org.apache.poi.xwpf.model
org.apache.poi.xwpf.usermodel

Uses of XWPFParagraph in org.apache.poi.xwpf.model

Fields in org.apache.poi.xwpf.model declared as XWPFParagraph
protected  XWPFParagraph XWPFParagraphDecorator.paragraph

Methods in org.apache.poi.xwpf.model with parameters of type XWPFParagraph
XWPFFooter | XWPFHeaderFooterPolicy.createFooter(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type, XWPFParagraph[] pars)
XWPFHeader | XWPFHeaderFooterPolicy.createHeader(org.openxmlformats.schemas.wordprocessingml.x2006.main.STHdrFtr.Enum type, XWPFParagraph[] pars)

Constructors in org.apache.poi.xwpf.model with parameters of type XWPFParagraph
XWPFCommentsDecorator(XWPFParagraph paragraph, XWPFParagraphDecorator nextDecorator)
XWPFHyperlinkDecorator(XWPFParagraph prgrph, XWPFParagraphDecorator nextDecorator, boolean outputHyperlinkUrls)
Deprecated.
XWPFParagraphDecorator(XWPFParagraph paragraph)
XWPFParagraphDecorator(XWPFParagraph paragraph, XWPFParagraphDecorator nextDecorator)

Uses of XWPFParagraph in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFParagraph
protected java.util.List<XWPFParagraph> | XWPFTableCell.paragraphs
protected java.util.List<XWPFParagraph> | XWPFDocument.paragraphs

Methods in org.apache.poi.xwpf.usermodel that return XWPFParagraph
XWPFParagraph | XWPFFootnote.addNewParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP paragraph) add a new paragraph to the end of the footnote
XWPFParagraph | XWPFTableCell.addParagraph() Add a Paragraph to this Table Cell
XWPFParagraph | XWPFDocument.createParagraph() Appends a new paragraph to this document
XWPFParagraph | XWPFDocument.getLastParagraph()
XWPFParagraph | XWPFRun.getParagraph() Get the currenty referenced paragraph object
XWPFParagraph | XWPFTableCell.getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this table the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | XWPFHeaderFooter.getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | XWPFFootnote.getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | XWPFDocument.getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) get the paragraph with the CTP class p
XWPFParagraph | IBody.getParagraph(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTP p) if there is a corresponding XWPFParagraph of the parameter ctTable in the paragraphList of this header or footer the method will return this paragraph if there is no corresponding XWPFParagraph the method will return null
XWPFParagraph | XWPFTableCell.getParagraphArray(int pos)
XWPFParagraph | XWPFHeaderFooter.getParagraphArray(int pos) Returns the paragraph that holds the text of the header or footer.
XWPFParagraph | XWPFFootnote.getParagraphArray(int pos) Returns the paragraph that holds the text of the header or footer.
XWPFParagraph | XWPFDocument.getParagraphArray(int pos) Returns the paragraph that of position pos
XWPFParagraph | IBody.getParagraphArray(int pos) Returns the paragraph that of position pos
XWPFParagraph | XWPFTableCell.insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) add a new paragraph at position of the cursor
XWPFParagraph | XWPFHeaderFooter.insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) add a new paragraph at position of the cursor
XWPFParagraph | XWPFFootnote.insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) add a new paragraph at position of the cursor
XWPFParagraph | XWPFDocument.insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) Add a new paragraph at position of the cursor.
XWPFParagraph | IBody.insertNewParagraph(org.apache.xmlbeans.XmlCursor cursor) inserts a new paragraph at position of the cursor

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFParagraph
java.util.List<XWPFParagraph> | XWPFHeaderFooter.getListParagraph() get a List of all Paragraphs
java.util.List<XWPFParagraph> | XWPFTableCell.getParagraphs() returns a list of paragraphs
java.util.List<XWPFParagraph> | XWPFHeaderFooter.getParagraphs() Returns the paragraph(s) that holds the text of the header or footer.
java.util.List<XWPFParagraph> | XWPFFootnote.getParagraphs()
java.util.List<XWPFParagraph> | XWPFDocument.getParagraphs()
java.util.List<XWPFParagraph> | IBody.getParagraphs() Returns the paragraph(s) that holds the text of the header or footer.
java.util.Iterator<XWPFParagraph> | XWPFDocument.getParagraphsIterator()
java.util.Iterator<XWPFParagraph> | XWPFFootnote.iterator()

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFParagraph
void | XWPFTableCell.addParagraph(XWPFParagraph p) add a Paragraph to this TableCell
int | XWPFDocument.getPosOfParagraph(XWPFParagraph p) Get the position of the paragraph, within the list of all the body elements.
void | XWPFTableCell.setParagraph(XWPFParagraph p)
void | XWPFDocument.setParagraph(XWPFParagraph paragraph, int pos) copies content of a paragraph to a existing paragraph in the list paragraphs at position pos

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFParagraph
XWPFHyperlinkRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTHyperlink hyperlink, org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR run, XWPFParagraph p)
XWPFRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR r, XWPFParagraph p)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFPicture

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFPicture

Packages that use XWPFPicture
org.apache.poi.xwpf.usermodel

Uses of XWPFPicture in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFPicture
 XWPFPicture XWPFRun.addPicture(java.io.InputStream pictureData, int pictureType, java.lang.String filename, int width, int height)
Adds a picture to the run.

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFPicture
 java.util.List<XWPFPicture> XWPFRun.getEmbeddedPictures()
Returns the embedded pictures of the run.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFPictureData

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFPictureData

Packages that use XWPFPictureData
org.apache.poi.xwpf.usermodel

Uses of XWPFPictureData in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFPictureData
protected java.util.Map<java.lang.Long,java.util.List<XWPFPictureData>> | XWPFDocument.packagePictures
protected java.util.List<XWPFPictureData> | XWPFDocument.pictures

Methods in org.apache.poi.xwpf.usermodel that return XWPFPictureData
XWPFPictureData | XWPFPicture.getPictureData() Get the PictureData of the Picture, if present.
XWPFPictureData | XWPFHeaderFooter.getPictureDataByID(java.lang.String blipID) returns the PictureData by blipID
XWPFPictureData | XWPFDocument.getPictureDataByID(java.lang.String blipID) returns the PictureData by blipID

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFPictureData
java.util.List<XWPFPictureData> | XWPFHeaderFooter.getAllPackagePictures() get all Pictures in this package
java.util.List<XWPFPictureData> | XWPFDocument.getAllPackagePictures()
java.util.List<XWPFPictureData> | XWPFHeaderFooter.getAllPictures()
java.util.List<XWPFPictureData> | XWPFDocument.getAllPictures() Returns all Pictures, which are referenced from the document itself.
java.util.List<XWPFPictureData> | XWPFFootnote.getPictures()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFRelation

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFRelation

Packages that use XWPFRelation
org.apache.poi.xwpf.extractor
org.apache.poi.xwpf.usermodel

Uses of XWPFRelation in org.apache.poi.xwpf.extractor

Fields in org.apache.poi.xwpf.extractor declared as XWPFRelation
static XWPFRelation[] XWPFWordExtractor.SUPPORTED_TYPES

Uses of XWPFRelation in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel declared as XWPFRelation
static XWPFRelation | XWPFRelation.COMMENT
static XWPFRelation | XWPFRelation.DOCUMENT
static XWPFRelation | XWPFRelation.ENDNOTE
static XWPFRelation | XWPFRelation.FONT_TABLE
static XWPFRelation | XWPFRelation.FOOTER
static XWPFRelation | XWPFRelation.FOOTNOTE
static XWPFRelation | XWPFRelation.GLOSSARY_DOCUMENT
static XWPFRelation | XWPFRelation.HEADER
static XWPFRelation | XWPFRelation.HYPERLINK
static XWPFRelation | XWPFRelation.IMAGE_BMP
static XWPFRelation | XWPFRelation.IMAGE_DIB
static XWPFRelation | XWPFRelation.IMAGE_EMF Supported image formats
static XWPFRelation | XWPFRelation.IMAGE_EPS
static XWPFRelation | XWPFRelation.IMAGE_GIF
static XWPFRelation | XWPFRelation.IMAGE_JPEG
static XWPFRelation | XWPFRelation.IMAGE_PICT
static XWPFRelation | XWPFRelation.IMAGE_PNG
static XWPFRelation | XWPFRelation.IMAGE_TIFF
static XWPFRelation | XWPFRelation.IMAGE_WMF
static XWPFRelation | XWPFRelation.IMAGE_WPG
static XWPFRelation | XWPFRelation.IMAGES
static XWPFRelation | XWPFRelation.MACRO_DOCUMENT
static XWPFRelation | XWPFRelation.MACRO_TEMPLATE_DOCUMENT
static XWPFRelation | XWPFRelation.NUMBERING
static XWPFRelation | XWPFRelation.SETTINGS
static XWPFRelation | XWPFRelation.STYLES
static XWPFRelation | XWPFRelation.TEMPLATE
static XWPFRelation | XWPFRelation.WEB_SETTINGS

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFRelation
protected static java.util.Map<java.lang.String,XWPFRelation> XWPFRelation._table
A map to lookup POIXMLRelation by its relation type

Methods in org.apache.poi.xwpf.usermodel that return XWPFRelation
static XWPFRelation XWPFRelation.getInstance(java.lang.String rel)
Get POIXMLRelation by relation type

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFRun

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFRun

Packages that use XWPFRun
org.apache.poi.xwpf.usermodel

Uses of XWPFRun in org.apache.poi.xwpf.usermodel

Subclasses of XWPFRun in org.apache.poi.xwpf.usermodel
 class XWPFHyperlinkRun
A run of text with a Hyperlink applied to it.

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFRun
protected  java.util.List<XWPFRun> XWPFParagraph.runs

Methods in org.apache.poi.xwpf.usermodel that return XWPFRun
XWPFRun | XWPFParagraph.createRun() Appends a new run to this paragraph
XWPFRun | XWPFParagraph.getRun(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTR r) return the XWPFRun-Element which owns the CTR run-Element
XWPFRun | XWPFParagraph.insertNewRun(int pos) insert a new Run in RunArray

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFRun
 java.util.List<XWPFRun> XWPFParagraph.getRuns()

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFRun
 void XWPFParagraph.addRun(XWPFRun r)
adds a new Run to the Paragraph

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFRun
XWPFPicture(org.openxmlformats.schemas.drawingml.x2006.picture.CTPicture ctPic, XWPFRun run)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFSettings

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFSettings

No usage of org.apache.poi.xwpf.usermodel.XWPFSettings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFStyle

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFStyle

Packages that use XWPFStyle
org.apache.poi.xwpf.usermodel

Uses of XWPFStyle in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFStyle
XWPFStyle | XWPFStyles.getStyle(java.lang.String styleID) get style by a styleID
XWPFStyle | XWPFStyles.getStyleWithSameName(XWPFStyle style) get the style with the same name if this style is not existing, return null

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFStyle
 java.util.List<XWPFStyle> XWPFStyles.getUsedStyleList(XWPFStyle style)
get the styles which are related to the parameter style and their relatives this method can be used to copy all styles from one document to another document

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFStyle
void | XWPFStyles.addStyle(XWPFStyle style) add a style to the document
XWPFStyle | XWPFStyles.getStyleWithSameName(XWPFStyle style) get the style with the same name if this style is not existing, return null
java.util.List<XWPFStyle> | XWPFStyles.getUsedStyleList(XWPFStyle style) get the styles which are related to the parameter style and their relatives this method can be used to copy all styles from one document to another document
boolean | XWPFStyle.hasSameName(XWPFStyle compStyle) compares the names of the Styles

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFStyles

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFStyles

Packages that use XWPFStyles
org.apache.poi.xwpf.usermodel

Uses of XWPFStyles in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel declared as XWPFStyles
protected XWPFStyles | XWPFStyle.styles
protected XWPFStyles | XWPFLatentStyles.styles
protected XWPFStyles | XWPFDocument.styles

Methods in org.apache.poi.xwpf.usermodel that return XWPFStyles
XWPFStyles | XWPFDocument.createStyles() Creates an empty styles for the document if one does not already exist
XWPFStyles | XWPFStyle.getStyles() get styles
XWPFStyles | XWPFDocument.getStyles() get Styles

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFStyles
XWPFLatentStyles(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTLatentStyles latentStyles, XWPFStyles styles)
XWPFStyle(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTStyle style, XWPFStyles styles)
constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFTable

Packages that use XWPFTable
org.apache.poi.xwpf.usermodel

Uses of XWPFTable in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFTable
protected java.util.List<XWPFTable> | XWPFTableCell.tables
protected java.util.List<XWPFTable> | XWPFDocument.tables

Methods in org.apache.poi.xwpf.usermodel that return XWPFTable
XWPFTable | XWPFFootnote.addNewTbl(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl table) add a new table to the end of the footnote
XWPFTable | XWPFDocument.createTable() Create an empty table with one row and one column as default.
XWPFTable | XWPFDocument.createTable(int rows, int cols) Create an empty table with a number of rows and cols specified
XWPFTable | XWPFTableRow.getTable()
XWPFTable | XWPFTableCell.getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) get a table by its CTTbl-Object
XWPFTable | XWPFHeaderFooter.getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
XWPFTable | XWPFFootnote.getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
XWPFTable | XWPFDocument.getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTbl) get a table by its CTTbl-Object
XWPFTable | IBody.getTable(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTbl ctTable) if there is a corresponding XWPFTable of the parameter ctTable in the tableList of this header the method will return this table if there is no corresponding XWPFTable the method will return null
XWPFTable | XWPFTableCell.getTableArray(int pos)
XWPFTable | XWPFHeaderFooter.getTableArray(int pos) Returns the table at position pos
XWPFTable | XWPFFootnote.getTableArray(int pos)
XWPFTable | XWPFDocument.getTableArray(int pos)
XWPFTable | IBody.getTableArray(int pos) Returns the table at position pos
XWPFTable | XWPFTableCell.insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
XWPFTable | XWPFHeaderFooter.insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
XWPFTable | XWPFFootnote.insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
XWPFTable | XWPFDocument.insertNewTbl(org.apache.xmlbeans.XmlCursor cursor)
XWPFTable | IBody.insertNewTbl(org.apache.xmlbeans.XmlCursor cursor) inserts a new Table at the cursor position.

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFTable
java.util.List<XWPFTable> | XWPFTableCell.getTables()
java.util.List<XWPFTable> | XWPFHeaderFooter.getTables() Return the table(s) that holds the text of the header or footer, for complex cases where a paragraph isn't used.
java.util.List<XWPFTable> | XWPFFootnote.getTables()
java.util.List<XWPFTable> | XWPFDocument.getTables()
java.util.List<XWPFTable> | IBody.getTables() Return the table(s) that holds the text of the IBodyPart, for complex cases where a paragraph isn't used.
java.util.Iterator<XWPFTable> | XWPFDocument.getTablesIterator()

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFTable
int | XWPFDocument.getPosOfTable(XWPFTable t) Get the position of the table, within the list of all the body elements.
java.lang.String | XWPFDocument.getTblStyle(XWPFTable table)
void | XWPFTableCell.insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
void | XWPFHeaderFooter.insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
void | XWPFFootnote.insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
void | XWPFDocument.insertTable(int pos, XWPFTable table) inserts an existing XWPFTable to the arrays bodyElements and tables
void | IBody.insertTable(int pos, XWPFTable table) inserts a new Table at position pos
void | XWPFDocument.setTable(int pos, XWPFTable table) Replace content of table in array tables at position pos with a

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFTable
XWPFTableRow(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow row, XWPFTable table)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFTable.XWPFBorderType

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFTable.XWPFBorderType

Packages that use XWPFTable.XWPFBorderType
org.apache.poi.xwpf.usermodel

Uses of XWPFTable.XWPFBorderType in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFTable.XWPFBorderType
XWPFTable.XWPFBorderType | XWPFTable.getInsideHBorderType()
XWPFTable.XWPFBorderType | XWPFTable.getInsideVBorderType()
static XWPFTable.XWPFBorderType | XWPFTable.XWPFBorderType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XWPFTable.XWPFBorderType[] | XWPFTable.XWPFBorderType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFTable.XWPFBorderType
void | XWPFTable.setInsideHBorder(XWPFTable.XWPFBorderType type, int size, int space, java.lang.String rgbColor)
void | XWPFTable.setInsideVBorder(XWPFTable.XWPFBorderType type, int size, int space, java.lang.String rgbColor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFTableCell

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFTableCell

Packages that use XWPFTableCell
org.apache.poi.xwpf.usermodel

Uses of XWPFTableCell in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFTableCell
XWPFTableCell | XWPFTableRow.addNewTableCell() adds a new TableCell at the end of this tableRow
XWPFTableCell | XWPFTableRow.createCell() create a new XWPFTableCell and add it to the tableCell-list of this tableRow
XWPFTableCell | XWPFTableRow.getCell(int pos)
XWPFTableCell | XWPFTableRow.getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) returns the XWPFTableCell which belongs to the CTTC cell if there is no XWPFTableCell which belongs to the parameter CTTc cell null will be returned
XWPFTableCell | XWPFTableCell.getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
XWPFTableCell | XWPFHeaderFooter.getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
XWPFTableCell | XWPFFootnote.getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
XWPFTableCell | XWPFDocument.getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) get the TableCell which belongs to the TableCell
XWPFTableCell | IBody.getTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell) returns the TableCell to which the Table belongs

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFTableCell
 java.util.List<XWPFTableCell> XWPFTableRow.getTableCells()
create and return a list of all XWPFTableCell who belongs to this row

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFTableCell.XWPFVertAlign

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFTableCell.XWPFVertAlign

Packages that use XWPFTableCell.XWPFVertAlign
org.apache.poi.xwpf.usermodel

Uses of XWPFTableCell.XWPFVertAlign in org.apache.poi.xwpf.usermodel

Methods in org.apache.poi.xwpf.usermodel that return XWPFTableCell.XWPFVertAlign
XWPFTableCell.XWPFVertAlign | XWPFTableCell.getVerticalAlignment() Get the vertical alignment of the cell.
static XWPFTableCell.XWPFVertAlign | XWPFTableCell.XWPFVertAlign.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static XWPFTableCell.XWPFVertAlign[] | XWPFTableCell.XWPFVertAlign.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFTableCell.XWPFVertAlign
 void XWPFTableCell.setVerticalAlignment(XWPFTableCell.XWPFVertAlign vAlign)
Set the vertical alignment of the cell.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.poi.xwpf.usermodel.XWPFTableRow

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.apache.poi.xwpf.usermodel.XWPFTableRow

Packages that use XWPFTableRow
org.apache.poi.xwpf.usermodel

Uses of XWPFTableRow in org.apache.poi.xwpf.usermodel

Fields in org.apache.poi.xwpf.usermodel with type parameters of type XWPFTableRow
protected  java.util.List<XWPFTableRow> XWPFTable.tableRows

Methods in org.apache.poi.xwpf.usermodel that return XWPFTableRow
XWPFTableRow | XWPFTable.createRow() create a new XWPFTableRow object with as many cells as the number of columns defined in that moment
XWPFTableRow | XWPFTable.getRow(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTRow row) returns the XWPFRow which belongs to the CTRow row if this row is not existing in the table null will be returned
XWPFTableRow | XWPFTable.getRow(int pos)
XWPFTableRow | XWPFTableCell.getTableRow()
XWPFTableRow | XWPFTable.insertNewTableRow(int pos) inserts a new tablerow

Methods in org.apache.poi.xwpf.usermodel that return types with arguments of type XWPFTableRow
 java.util.List<XWPFTableRow> XWPFTable.getRows()

Methods in org.apache.poi.xwpf.usermodel with parameters of type XWPFTableRow
void | XWPFTable.addRow(XWPFTableRow row) add a new Row to the table
boolean | XWPFTable.addRow(XWPFTableRow row, int pos) add a new Row to the table at position pos

Constructors in org.apache.poi.xwpf.usermodel with parameters of type XWPFTableRow
XWPFTableCell(org.openxmlformats.schemas.wordprocessingml.x2006.main.CTTc cell, XWPFTableRow tableRow, IBody part)
If a table cell does not include at least one block-level element, then this document shall be considered corrupt

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES